Atalasoft DotImage

Welcome to Atalasoft DotImage, an easy-to-use suite of .NET assemblies for use in projects that need to acquire, read, write, display, annotate, or process images. DotImage assemblies can be used in desktop and ASP.NET projects and the various objects and methods are accessible from any .NET-compliant language including VB.NET, C#, and Managed C++.

This document contains the complete class library reference for DotImage. For conceptual overviews, step-by-step procedures, and samples, please refer to the Developers Guide that was installed with your copy of DotImage.

Copyright 2000-2023 Kofax. All rights reserved.

Send comments on this topic to Atalasoft Development Team


Atalasoft DotImage Class Library

Atalasoft DotImage API Reference
Namespaces
Namespace | Description
Atalasoft.Annotate |
Atalasoft.Annotate.Converters |
Atalasoft.Annotate.Editors |
Atalasoft.Annotate.Exporters | The Atalasoft.Annotate.Exporters namespace provides objects used to export annotations to a specific format. Currently PDF is the only format supported.
Atalasoft.Annotate.Formatters |
Atalasoft.Annotate.Icons |
Atalasoft.Annotate.Importers | The Atalasoft.Annotate.Importers namespace contains classes used to import annotations from a specific format into DotImage annotations.
Atalasoft.Annotate.Ink |
Atalasoft.Annotate.Pdf | This namespace contains PDF specific annotation classes.
Atalasoft.Annotate.Renderer |
Atalasoft.Annotate.UI |
Atalasoft.Annotate.UI.Exporters |
Atalasoft.Annotate.UI.Importers |
Atalasoft.Annotate.Wpf |
Atalasoft.Annotate.Wpf.Pdf |
Atalasoft.Annotate.Wpf.Renderer |
Atalasoft.Barcoding.Reading | Contains classes and interfaces related to barcode recognition.
Atalasoft.Barcoding.Reading.BarcodeLib |
Atalasoft.Barcoding.Writing |
Atalasoft.Converters |
Atalasoft.dotImage.PdfDoc.Bridge |
Atalasoft.dotImage.PdfDoc.Bridge.Annotate |
Atalasoft.Exceptions |
Atalasoft.FormsProcessing |
Atalasoft.FormsProcessing.Alignment |
Atalasoft.FormsProcessing.Geometry |
Atalasoft.FormsProcessing.Omr |
Atalasoft.Imaging |
Atalasoft.Imaging.Codec |
Atalasoft.Imaging.Codec.CadCam |
Atalasoft.Imaging.Codec.Dicom |
Atalasoft.Imaging.Codec.Heif |
Atalasoft.Imaging.Codec.Jbig2 |
Atalasoft.Imaging.Codec.Jpeg2000 |
Atalasoft.Imaging.Codec.Office |
Atalasoft.Imaging.Codec.Office.Caching |
Atalasoft.Imaging.Codec.Pdf | Contains classes that give DotImage PDF Encode functionality.
Atalasoft.Imaging.Codec.Tiff |
Atalasoft.Imaging.ColorManagement |
Atalasoft.Imaging.ConnectedComponents |
Atalasoft.Imaging.Drawing |
Atalasoft.Imaging.ImageProcessing |
Atalasoft.Imaging.ImageProcessing.Channels |
Atalasoft.Imaging.ImageProcessing.Document | Contains classes that are designed to be used with 1-bit document (binary) images. These classes are enabled in the professional edition.
Atalasoft.Imaging.ImageProcessing.Effects | Namespace where all Advanced Photo Effect classes are located.
Atalasoft.Imaging.ImageProcessing.Fft |
Atalasoft.Imaging.ImageProcessing.Filters |
Atalasoft.Imaging.ImageProcessing.Transforms |
Atalasoft.Imaging.ImageSources |
Atalasoft.Imaging.ImageSources.Data |
Atalasoft.Imaging.Memory |
Atalasoft.Imaging.Metadata |
Atalasoft.Imaging.Text |
Atalasoft.Imaging.WebControls |
Atalasoft.Imaging.WebControls.Annotations |
Atalasoft.Imaging.WebControls.Capture |
Atalasoft.Imaging.WebControls.Capture.Authentication |
Atalasoft.Imaging.WebControls.Capture.Cmis |
Atalasoft.Imaging.WebControls.Capture.Kic |
Atalasoft.Imaging.WebControls.Core |
Atalasoft.Imaging.WebControls.Exceptions |
Atalasoft.Imaging.WebControls.Mvc |
Atalasoft.Imaging.WebControls.OCR |
Atalasoft.Imaging.WebControls.Text |
Atalasoft.Imaging.WinControls |
Atalasoft.Imaging.Wpf |
Atalasoft.Isis | Classing that is required to scan using ISIS scanners.
Atalasoft.Ocr | High level classes for managing OCR engines and their output.
Atalasoft.Ocr.GlyphReader |
Atalasoft.Ocr.OmniPage |
Atalasoft.Ocr.Tesseract |
Atalasoft.Ocr.Voting |
Atalasoft.Pdf.TextExtract |
Atalasoft.PdfDoc |
Atalasoft.PdfDoc.Actions |
Atalasoft.PdfDoc.BarcodeWriting |
Atalasoft.PdfDoc.DigitalSignatures |
Atalasoft.PdfDoc.Examiner |
Atalasoft.PdfDoc.Generating |
Atalasoft.PdfDoc.Generating.Annotations |
Atalasoft.PdfDoc.Generating.Forms |
Atalasoft.PdfDoc.Generating.Multimedia |
Atalasoft.PdfDoc.Generating.Rendering |
Atalasoft.PdfDoc.Generating.ResourceHandling |
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors |
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts |
Atalasoft.PdfDoc.Generating.ResourceHandling.Images |
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates |
Atalasoft.PdfDoc.Generating.Shapes |
Atalasoft.PdfDoc.Generating.Templates |
Atalasoft.PdfDoc.Generating.Utilities |
Atalasoft.PdfDoc.Generating.Utilities.VectorImport |
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM |
Atalasoft.PdfDoc.Generating.Validation |
Atalasoft.PdfDoc.Geometry |
Atalasoft.PdfDoc.MergeForms |
Atalasoft.PdfDoc.PdfA | This namespace contains PDF/A specific classes and enumerations.
Atalasoft.PdfDoc.Repair |
Atalasoft.Shared |
Atalasoft.Shared.Diagnostics |
Atalasoft.Shared.IO |
Atalasoft.Shared.Validation |
Atalasoft.Twain |
Atalasoft.Utils |
Atalasoft.Utils.Geometry |


Atalasoft.Annotate Namespace

Classes
 | Class | Description
 | AnnotateSpaceConverter | The AnnotateSpaceConverter class provides helper methods for converting from one coordinate space to another.
Public class | AnnotationBinder | A SerializationBinder that remaps a default set of Atalasoft assembly and type names for annotations.
 | AnnotationBrush | This class describes a brush object used for drawing annotations.
 | AnnotationControllerNotificationEventArgs | This class provides information when the AnnotationController is sent a notification from another object.
Public class | AnnotationData | This is the main annotation data class used to hold base information required by all annotations.
Public class | AnnotationDataCollection | This class can be used to hold a collection of AnnotationData objects.
Public class | AnnotationDataCollectionT | This class can be used to hold a collection of AnnotationData objects.
Public class | AnnotationEventArgs | This class provides information for events that involve an annotation.
 | AnnotationFont | This class represents a font used with annotations.
Public class | AnnotationImage | This class represents an image object used by AnnotationBrush and EmbeddedImageData classes.
Public class | AnnotationLineCap | This class is used to define a line cap used for AnnotationPen objects.
Public class | AnnotationLocationChangedEventArgs | This class is used to hold information for the LocationChanged event.
Public class | AnnotationLock | This class is the default security used for annotations. It uses simple string encryption to secure annotations and keep users from being able to modify the data.
 | AnnotationPen | This class represents a pen object used for drawing lines of annotations.
Public class | AnnotationPropertyChangedEventArgs | Contains information for a property changed event.
Public class | AnnotationPropertyChangingEventArgs | This class hold information about a PropertyChanging event.
Public class | AnnotationRegion | This class defines a display region used for hit testing.
Public class | AnnotationSizeChangedEventArgs | This class is used to hold information about the SizeChanged event.
Public class | CalloutData | Callout data used with the CalloutAnnotation.
Public class | CommentData | The CommentData class is used for adding comments to other annotations, but it can also be used standalone.
Public class | EllipseData | Ellipse annotation data.
Public class | EmbeddedImageData | Data for the EmbeddedImageAnnotation.
Public class | FreehandData | Data for a FreehandAnnotation.
Public class | HotSpotData | Data for a HotSpotAnnotation object.
Public class | HotSpotFreehandData | Data for a hot spot freehand annotation.
 | LayerData | The LayerData class is used to hold a collection of AnnotationData objects, including other LayerData objects, allowing the annotations to be organized into layers.
Public class | LineData | This class holds data for the LineAnnotation.
Public class | LinesData | This class holds information for the LinesAnnotation.
Public class | MirrorEventArgs | This class is used with the OnMirrored(MirrorEventArgs) method to provide information on the mirror action.
Public class | OcrRegionData | This class holds information for the OcrRegionAnnotation.
Public class | PointBaseData | This abstract class is used for annotations that require a series of points to define their shape.
Public class | PointFCollection | A collection of PointF objects used by points based annotations.
Public class | PolygonData | Contains annotation information for a PolygonAnnotation.
Public class | RectangleData | Contains information describing data for a RectangleAnnotation.
Public class | ReferencedImageData | The data for a ReferencedImageAnnotation object.
Public class | RegisteredAnnotationAssemblies | This class includes static members containing information on assemblies to use in the project when deserialize annotations.
Public class | RubberStampData | The annotation data object for a RubberStampAnnotation.
Public class | SerializationInfoHelper | Obsolete. This class contains methods used when serializing or deserializing annotations.
Public class | TextData | Data for a TextAnnotation.
Public class | WangAttributeData | This class hold information used by the WangFormatter when serializing AnnotationData objects.
Structures
 | Structure | Description
Public structure | AnnotationLineCapStringSizes |
Interfaces
 | Interface | Description
Public interface | IAnnotationLock | The interface used to define the security when locking annotations is required.
Public interface | IAttachableAnnotation | This interface is implemented by annotation data classes, such as CommentData, that can be attached to other annotations.
Public interface | IHighlighter | This interface is used by AnnotationData objects to indicate that they have highlighter support. This information is used by the AnnotateViewer when burning annotations.
Public interface | IWangCompatible | This interface is used to indicate that an AnnotationData object is WANG compatible.
Delegates
 | Delegate | Description
Public delegate | AnnotationControllerNotificationEventHandler | This delegate is used for the AnnotationControllerNotification event to send information to the AnnotationController.
Public delegate | AnnotationEventHandler | This delegate is used for various events that apply to an annotation.
Public delegate | AnnotationLocationChangedEventHandler | This delegate is used for the LocationChanged event.
Public delegate | AnnotationPropertyChangedEventHandler | This delegate is used for the PropertyChanged event.
Public delegate | AnnotationPropertyChangingEventHandler | This delegate is used for the PropertyChanging event.
Public delegate | AnnotationSizeChangedEventHandler | This delegate is used for the SizeChanged event.
Public delegate | MirrorEventHandler | This delegate is used for the Mirrored event.
Enumerations
 | Enumeration | Description
Public enumeration | AnnotateInteractMode | Specifies the user interaction mode for the AnnotationController
Public enumeration | AnnotateSpace | Used to specify the coordinate space used by various methods.
Public enumeration | AnnotationConfinementMode | Specifies the type of confinement used for the annotations when they are being moved or resized using the mouse.
Public enumeration | AnnotationControllerNotification | Specifies the type of notification being sent to the AnnotationController.
Public enumeration | AnnotationDataFormat | Specifies the format used for serialized annotation data.
Public enumeration | AnnotationGripAction | Specifies the action that will be taken by the AnnotationController when a grip is dragged with the mouse.
Public enumeration | AnnotationGripMode | Specifies the type of grips being used for an annotation.
Public enumeration | AnnotationGripState | Specifies the state of a grip.
Public enumeration | AnnotationLineCapStyle | Specifies the type of line cap for a AnnotationLineCap object.
Public enumeration | AnnotationPenAlignment | Specifies the alignment of the AnnotationPen.
Public enumeration | AnnotationState | Specifies the current state of the annotation.
Public enumeration | AnnotationUnit | Specifies the unit of measure used for annotations.
Public enumeration | ChangePositionMethod | Specifies the reordering to perform on a layer or annotation.
Public enumeration | CreateAnnotationMode | Specifies the annotation creation mode when calling AnnotationController.
Public enumeration | DocumentRotation | Specifies the amount of rotation to apply to the document and annotations by the RotateDocument method.
Public enumeration | FillType | Specifies the type of fill used by an AnnotationBrush.
Public enumeration | FreehandLineType | Specifies the line type used for freehand annotations.
Public enumeration | MirrorDirection | Specifies the mirror direction.
Public enumeration | RectangleGrip | Specifies the position of the grip.
Public enumeration | RectangleGripDisplay | Specifies the grips to display.
Public enumeration | RenderDevice | Specifies the type of device annotations will be rendered on. This allows the renderer to adjust for differences in media.
Public enumeration | ShadowMode | Specifies the shadow mode used for text annotations.
Public enumeration | UndoChange | Specifies the type of undo being performed.
Public enumeration | UndoManagerAction | Specifies the actions taken when an AnnotationUndo is passed to the AnnotationControllerNotification event.
Public enumeration | WangAnnotationType | Specifies the type of WANG annotation used for serialization.


AnnotateInteractMode Enumeration

Specifies the user interaction mode for the AnnotationController

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotateInteractMode
Public Enumeration AnnotateInteractMode
Members
Member name | Description
None | Mouse events are ignored.
View | Annotations cannot be modified. Hot spot annotations are not rendered but react to mouse events.
Author | Annotations can be selected, moved and resized using the mouse.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotateSpace Enumeration

Used to specify the coordinate space used by various methods.
Specifies the coordinate space used by various methods.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotateSpace
Public Enumeration AnnotateSpace
Members
Member name | Description
View | Use the view space of the control. View space is always represented in pixels with its origin at the top-left of the control.
Document | Use the document space of the viewer with its origin at the top-left of the document. Coordinates are specified in document Units.
Annotation | Use annotation space coordinates. The origin is at the location of the annotation specified in document Units.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotateSpaceConverter Class

The AnnotateSpaceConverter class provides helper methods for converting from one coordinate space to another.
The AnnotateSpaceConverter class provides helper methods for converting from one coordinate space to another.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotateSpaceConverter

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotateSpaceConverter : IDisposable
Public Class AnnotateSpaceConverter
    Implements IDisposable

The AnnotateSpaceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotateSpaceConverter | Creates a new instance of AnnotateSpaceConverter specifying the IAnnotate parent and AnnotationData objects that will be used for the conversion methods.
Top
Methods
 | Name | Description
Public method | AnnotationSpaceToDocumentSpace(PointF) | Converts a point from annotation space to document space.
Public method | AnnotationSpaceToDocumentSpace(PointF) | Converts an array of points from annotation space to document space.
Public method | AnnotationSpaceToDocumentSpace(PointFCollection) | Returns a new PointFCollection converted from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointFCollection) | Returns a new PointFCollection converted from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointF) | Converts a point from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointF) | Converts a point from annotation space to document space.
Public method | AnnotationSpaceToViewSpace(PointF) | Converts from annotation space to view space.
Public method | AnnotationSpaceToViewSpace(PointF) | Converts an array of points from annotation space to view space.
 | AnnotationSpaceToViewSpace(IAnnotate, AnnotationData, PointF) | Converts from annotation space to view space.
 | AnnotationSpaceToViewSpace(IAnnotate, AnnotationData, PointF) | Converts from annotation space to view space.
Public method | Dispose | Releases resources used for conversion.
Protected method | Dispose(Boolean) | Releases resources used by this object.
Public method | DocumentSpaceToAnnotationSpace(PointF) | Converts a point from document space to annotation space.
Public method | DocumentSpaceToAnnotationSpace(PointF) | Converts an array of points from document space to annotation space.
Public method | DocumentSpaceToAnnotationSpace(PointFCollection) | Returns a new PointFCollection with the points converted from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointFCollection) | Returns a new PointFCollection with the points converted from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointF) | Converts a point from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointF) | Converts an array of points from document space to annotation space.
Public method | DocumentSpaceToViewSpace(PointF) | Converts a point from document space to view space.
Public method | DocumentSpaceToViewSpace(PointF) | Converts an array of points from document space to view space.
Public method | DocumentSpaceToViewSpace(RectangleF) | Converts a rectangle from document space to view space.
 | DocumentSpaceToViewSpace(IAnnotate, PointF) | Converts a point from document space to view space.
 | DocumentSpaceToViewSpace(IAnnotate, RectangleF) | Converts a rectangle from document space to view space.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnnotateSpaceConverter class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ViewSpaceToAnnotationSpace(PointF) | Converts a point from view space to annotation space.
Public method | ViewSpaceToAnnotationSpace(PointF) | Converts an array of PointF from view space to annotation space.
 | ViewSpaceToAnnotationSpace(IAnnotate, AnnotationData, PointF) | Converts a point from view space to annotation space.
Public method | ViewSpaceToDocumentSpace(PointF) | Converts a point from view space to document space.
Public method | ViewSpaceToDocumentSpace(PointF) | Converts an array of points from view space to document space.
Public method | ViewSpaceToDocumentSpace(RectangleF) | Converts a rectangle from view space to document space.
 | ViewSpaceToDocumentSpace(IAnnotate, PointF) | Converts a point from view space to document space.
 | ViewSpaceToDocumentSpace(IAnnotate, RectangleF) | Converts a rectangle from view space to document space.
Top
Remarks
If any changes occur to the annotation or viewer matrices after the AnnotateSpaceConverter is created, the calculations will not be correct. If changes will be made to the annotation during this time it's best to use the static methods instead.
Examples
The following example converts the rectangular points of an annotation into document space.
ConverterExample
Copy
AnnotationUI annotation = this.Viewer.Annotations.ActiveAnnotation;
AnnotateSpaceConverter converter = new AnnotateSpaceConverter(this.Viewer, annotation.Data);
PointF asLocation = converter.AnnotationSpaceToDocumentSpace(annotation.Data.Location);
PointF asLocation2 = converter.AnnotationSpaceToDocumentSpace(new PointF(annotation.Data.Location.X + annotation.Data.Size.Width, annotation.Data.Location.Y + annotation.Data.Size.Height));
converter.Dispose();
ConverterExampleVB
Copy
Dim annotation As AnnotationUI =  Me.Viewer.Annotations.ActiveAnnotation
Dim converter As AnnotateSpaceConverter = New AnnotateSpaceConverter(Me.Viewer,annotation.Data)
Dim asLocation As PointF = converter.AnnotationSpaceToDocumentSpace(annotation.Data.Location)
Dim asLocation2 As PointF = converter.AnnotationSpaceToDocumentSpace(New PointF(annotation.Data.Location.X + annotation.Data.Size.Width,annotation.Data.Location.Y + annotation.Data.Size.Height))
converter.Dispose()
See Also

Reference

Atalasoft.Annotate Namespace


AnnotateSpaceConverter Constructor

Creates a new instance of AnnotateSpaceConverter specifying the IAnnotate parent and AnnotationData objects that will be used for the conversion methods.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateSpaceConverter(
    IAnnotate parent,
    AnnotationData data
)
Public Sub New (
    parent As IAnnotate,
    data As AnnotationData
)

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter Methods

The AnnotateSpaceConverter type exposes the following members.

Methods
 | Name | Description
Public method | AnnotationSpaceToDocumentSpace(PointF) | Converts a point from annotation space to document space.
Public method | AnnotationSpaceToDocumentSpace(PointF) | Converts an array of points from annotation space to document space.
Public method | AnnotationSpaceToDocumentSpace(PointFCollection) | Returns a new PointFCollection converted from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointFCollection) | Returns a new PointFCollection converted from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointF) | Converts a point from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointF) | Converts a point from annotation space to document space.
Public method | AnnotationSpaceToViewSpace(PointF) | Converts from annotation space to view space.
Public method | AnnotationSpaceToViewSpace(PointF) | Converts an array of points from annotation space to view space.
 | AnnotationSpaceToViewSpace(IAnnotate, AnnotationData, PointF) | Converts from annotation space to view space.
 | AnnotationSpaceToViewSpace(IAnnotate, AnnotationData, PointF) | Converts from annotation space to view space.
Public method | Dispose | Releases resources used for conversion.
Protected method | Dispose(Boolean) | Releases resources used by this object.
Public method | DocumentSpaceToAnnotationSpace(PointF) | Converts a point from document space to annotation space.
Public method | DocumentSpaceToAnnotationSpace(PointF) | Converts an array of points from document space to annotation space.
Public method | DocumentSpaceToAnnotationSpace(PointFCollection) | Returns a new PointFCollection with the points converted from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointFCollection) | Returns a new PointFCollection with the points converted from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointF) | Converts a point from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointF) | Converts an array of points from document space to annotation space.
Public method | DocumentSpaceToViewSpace(PointF) | Converts a point from document space to view space.
Public method | DocumentSpaceToViewSpace(PointF) | Converts an array of points from document space to view space.
Public method | DocumentSpaceToViewSpace(RectangleF) | Converts a rectangle from document space to view space.
 | DocumentSpaceToViewSpace(IAnnotate, PointF) | Converts a point from document space to view space.
 | DocumentSpaceToViewSpace(IAnnotate, RectangleF) | Converts a rectangle from document space to view space.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnnotateSpaceConverter class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ViewSpaceToAnnotationSpace(PointF) | Converts a point from view space to annotation space.
Public method | ViewSpaceToAnnotationSpace(PointF) | Converts an array of PointF from view space to annotation space.
 | ViewSpaceToAnnotationSpace(IAnnotate, AnnotationData, PointF) | Converts a point from view space to annotation space.
Public method | ViewSpaceToDocumentSpace(PointF) | Converts a point from view space to document space.
Public method | ViewSpaceToDocumentSpace(PointF) | Converts an array of points from view space to document space.
Public method | ViewSpaceToDocumentSpace(RectangleF) | Converts a rectangle from view space to document space.
 | ViewSpaceToDocumentSpace(IAnnotate, PointF) | Converts a point from view space to document space.
 | ViewSpaceToDocumentSpace(IAnnotate, RectangleF) | Converts a rectangle from view space to document space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method

Atalasoft DotImage 11.4

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method

These methods are used to convert PointF and RectangleF values form annotation space to document space.
Overload List
 | Name | Description
Public method | AnnotationSpaceToDocumentSpace(PointF) | Converts a point from annotation space to document space.
Public method | AnnotationSpaceToDocumentSpace(PointF) | Converts an array of points from annotation space to document space.
Public method | AnnotationSpaceToDocumentSpace(PointFCollection) | Returns a new PointFCollection converted from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointFCollection) | Returns a new PointFCollection converted from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointF) | Converts a point from annotation space to document space.
 | AnnotationSpaceToDocumentSpace(AnnotationData, PointF) | Converts a point from annotation space to document space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method (PointF)

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method (PointF)

Converts a point from annotation space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF AnnotationSpaceToDocumentSpace(
    PointF point
)
Public Function AnnotationSpaceToDocumentSpace (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to document space.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method (PointF[])

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method (PointF)

Converts an array of points from annotation space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AnnotationSpaceToDocumentSpace(
    PointF[] points
)
Public Sub AnnotationSpaceToDocumentSpace (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The points to convert.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method (PointFCollection)

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method (PointFCollection)

Returns a new PointFCollection converted from annotation space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection AnnotationSpaceToDocumentSpace(
    PointFCollection points
)
Public Function AnnotationSpaceToDocumentSpace (
    points As PointFCollection
) As PointFCollection

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the points to convert.

Return Value

Type: PointFCollection
A new PointFCollection with the converted points.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method (AnnotationData, PointFCollection)

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method (AnnotationData, PointFCollection)

Returns a new PointFCollection converted from annotation space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointFCollection AnnotationSpaceToDocumentSpace(
    AnnotationData data,
    PointFCollection points
)
Public Shared Function AnnotationSpaceToDocumentSpace (
    data As AnnotationData,
    points As PointFCollection
) As PointFCollection

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the points to convert.

Return Value

Type: PointFCollection
A new PointFCollection with the converted points.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method (AnnotationData, PointF)

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method (AnnotationData, PointF)

Converts a point from annotation space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF AnnotationSpaceToDocumentSpace(
    AnnotationData data,
    PointF point
)
Public Shared Function AnnotationSpaceToDocumentSpace (
    data As AnnotationData,
    point As PointF
) As PointF

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to document space.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToDocumentSpace Method (AnnotationData, PointF[])

AnnotateSpaceConverterAnnotationSpaceToDocumentSpace Method (AnnotationData, PointF)

Converts a point from annotation space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void AnnotationSpaceToDocumentSpace(
    AnnotationData data,
    PointF[] points
)
Public Shared Sub AnnotationSpaceToDocumentSpace (
    data As AnnotationData,
    points As PointF()
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
points
Type: System.DrawingPointF
The points to convert.

Return Value

Type:
The point converted to document space.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToViewSpace Method

AnnotateSpaceConverterAnnotationSpaceToViewSpace Method

These methods are used to convert PointF and RectangleF values form annotation space to view space.
Overload List
 | Name | Description
Public method | AnnotationSpaceToViewSpace(PointF) | Converts from annotation space to view space.
Public method | AnnotationSpaceToViewSpace(PointF) | Converts an array of points from annotation space to view space.
 | AnnotationSpaceToViewSpace(IAnnotate, AnnotationData, PointF) | Converts from annotation space to view space.
 | AnnotationSpaceToViewSpace(IAnnotate, AnnotationData, PointF) | Converts from annotation space to view space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToViewSpace Method (PointF)

AnnotateSpaceConverterAnnotationSpaceToViewSpace Method (PointF)

Converts from annotation space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF AnnotationSpaceToViewSpace(
    PointF point
)
Public Function AnnotationSpaceToViewSpace (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted into view space.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToViewSpace Method (PointF[])

AnnotateSpaceConverterAnnotationSpaceToViewSpace Method (PointF)

Converts an array of points from annotation space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AnnotationSpaceToViewSpace(
    PointF[] points
)
Public Sub AnnotationSpaceToViewSpace (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
An array of PointF that will be converted.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToViewSpace Method (IAnnotate, AnnotationData, PointF)

AnnotateSpaceConverterAnnotationSpaceToViewSpace Method (IAnnotate, AnnotationData, PointF)

Converts from annotation space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF AnnotationSpaceToViewSpace(
    IAnnotate parent,
    AnnotationData data,
    PointF point
)
Public Shared Function AnnotationSpaceToViewSpace (
    parent As IAnnotate,
    data As AnnotationData,
    point As PointF
) As PointF

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted into view space.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.AnnotationSpaceToViewSpace Method (IAnnotate, AnnotationData, PointF[])

AnnotateSpaceConverterAnnotationSpaceToViewSpace Method (IAnnotate, AnnotationData, PointF)

Converts from annotation space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void AnnotationSpaceToViewSpace(
    IAnnotate parent,
    AnnotationData data,
    PointF[] points
)
Public Shared Sub AnnotationSpaceToViewSpace (
    parent As IAnnotate,
    data As AnnotationData,
    points As PointF()
)

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
points
Type: System.DrawingPointF
An array of PointF that will be converted.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
AnnotationSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.Dispose Method

AnnotateSpaceConverterDispose Method

Dispose must be called to release resources held by the converter.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used for conversion.
Protected method | Dispose(Boolean) | Releases resources used by this object.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.Dispose Method

AnnotateSpaceConverterDispose Method

Releases resources used for conversion.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AnnotateSpaceConverter Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.Dispose Method (Boolean)

AnnotateSpaceConverterDispose Method (Boolean)

Releases resources used by this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

AnnotateSpaceConverter Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method

These methods are used to convert PointF and RectangleF values form document space to annotation space.
Overload List
 | Name | Description
Public method | DocumentSpaceToAnnotationSpace(PointF) | Converts a point from document space to annotation space.
Public method | DocumentSpaceToAnnotationSpace(PointF) | Converts an array of points from document space to annotation space.
Public method | DocumentSpaceToAnnotationSpace(PointFCollection) | Returns a new PointFCollection with the points converted from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointFCollection) | Returns a new PointFCollection with the points converted from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointF) | Converts a point from document space to annotation space.
 | DocumentSpaceToAnnotationSpace(AnnotationData, PointF) | Converts an array of points from document space to annotation space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method (PointF)

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method (PointF)

Converts a point from document space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF DocumentSpaceToAnnotationSpace(
    PointF point
)
Public Function DocumentSpaceToAnnotationSpace (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to annotation space.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method (PointF[])

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method (PointF)

Converts an array of points from document space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DocumentSpaceToAnnotationSpace(
    PointF[] points
)
Public Sub DocumentSpaceToAnnotationSpace (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The points to convert.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method (PointFCollection)

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method (PointFCollection)

Returns a new PointFCollection with the points converted from document space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection DocumentSpaceToAnnotationSpace(
    PointFCollection points
)
Public Function DocumentSpaceToAnnotationSpace (
    points As PointFCollection
) As PointFCollection

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the points to convert.

Return Value

Type: PointFCollection
A new PointFCollection with the converted points.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method (AnnotationData, PointFCollection)

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method (AnnotationData, PointFCollection)

Returns a new PointFCollection with the points converted from document space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointFCollection DocumentSpaceToAnnotationSpace(
    AnnotationData data,
    PointFCollection points
)
Public Shared Function DocumentSpaceToAnnotationSpace (
    data As AnnotationData,
    points As PointFCollection
) As PointFCollection

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the points to convert.

Return Value

Type: PointFCollection
A new PointFCollection with the converted points.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method (AnnotationData, PointF)

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method (AnnotationData, PointF)

Converts a point from document space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF DocumentSpaceToAnnotationSpace(
    AnnotationData data,
    PointF point
)
Public Shared Function DocumentSpaceToAnnotationSpace (
    data As AnnotationData,
    point As PointF
) As PointF

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to annotation space.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToAnnotationSpace Method (AnnotationData, PointF[])

AnnotateSpaceConverterDocumentSpaceToAnnotationSpace Method (AnnotationData, PointF)

Converts an array of points from document space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void DocumentSpaceToAnnotationSpace(
    AnnotationData data,
    PointF[] points
)
Public Shared Sub DocumentSpaceToAnnotationSpace (
    data As AnnotationData,
    points As PointF()
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
points
Type: System.DrawingPointF
The points to convert.
Remarks
For this method to function accurately the data parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToViewSpace Method

AnnotateSpaceConverterDocumentSpaceToViewSpace Method

These methods are used to convert PointF and RectangleF values form document space to view space.
Overload List
 | Name | Description
Public method | DocumentSpaceToViewSpace(PointF) | Converts a point from document space to view space.
Public method | DocumentSpaceToViewSpace(PointF) | Converts an array of points from document space to view space.
Public method | DocumentSpaceToViewSpace(RectangleF) | Converts a rectangle from document space to view space.
 | DocumentSpaceToViewSpace(IAnnotate, PointF) | Converts a point from document space to view space.
 | DocumentSpaceToViewSpace(IAnnotate, RectangleF) | Converts a rectangle from document space to view space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToViewSpace Method (PointF)

AnnotateSpaceConverterDocumentSpaceToViewSpace Method (PointF)

Converts a point from document space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF DocumentSpaceToViewSpace(
    PointF point
)
Public Function DocumentSpaceToViewSpace (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to view space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToViewSpace Method (PointF[])

AnnotateSpaceConverterDocumentSpaceToViewSpace Method (PointF)

Converts an array of points from document space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DocumentSpaceToViewSpace(
    PointF[] points
)
Public Sub DocumentSpaceToViewSpace (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The points to convert.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToViewSpace Method (RectangleF)

AnnotateSpaceConverterDocumentSpaceToViewSpace Method (RectangleF)

Converts a rectangle from document space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF DocumentSpaceToViewSpace(
    RectangleF rectangle
)
Public Function DocumentSpaceToViewSpace (
    rectangle As RectangleF
) As RectangleF

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle to convert.

Return Value

Type: RectangleF
The rectangle converted to view space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToViewSpace Method (IAnnotate, PointF)

AnnotateSpaceConverterDocumentSpaceToViewSpace Method (IAnnotate, PointF)

Converts a point from document space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF DocumentSpaceToViewSpace(
    IAnnotate parent,
    PointF point
)
Public Shared Function DocumentSpaceToViewSpace (
    parent As IAnnotate,
    point As PointF
) As PointF

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to view space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.DocumentSpaceToViewSpace Method (IAnnotate, RectangleF)

AnnotateSpaceConverterDocumentSpaceToViewSpace Method (IAnnotate, RectangleF)

Converts a rectangle from document space to view space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RectangleF DocumentSpaceToViewSpace(
    IAnnotate parent,
    RectangleF rectangle
)
Public Shared Function DocumentSpaceToViewSpace (
    parent As IAnnotate,
    rectangle As RectangleF
) As RectangleF

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
rectangle
Type: System.DrawingRectangleF
The rectangle to convert.

Return Value

Type: RectangleF
The rectangle converted to view space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
DocumentSpaceToViewSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.Finalize Method

AnnotateSpaceConverterFinalize Method

Finalizes an instance of the AnnotateSpaceConverter class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToAnnotationSpace Method

AnnotateSpaceConverterViewSpaceToAnnotationSpace Method

These methods are used to convert PointF and RectangleF values form view space to annotation space.
Overload List
 | Name | Description
Public method | ViewSpaceToAnnotationSpace(PointF) | Converts a point from view space to annotation space.
Public method | ViewSpaceToAnnotationSpace(PointF) | Converts an array of PointF from view space to annotation space.
 | ViewSpaceToAnnotationSpace(IAnnotate, AnnotationData, PointF) | Converts a point from view space to annotation space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToAnnotationSpace Method (PointF)

AnnotateSpaceConverterViewSpaceToAnnotationSpace Method (PointF)

Converts a point from view space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ViewSpaceToAnnotationSpace(
    PointF point
)
Public Function ViewSpaceToAnnotationSpace (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point value in annotation space.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToAnnotationSpace Method (PointF[])

AnnotateSpaceConverterViewSpaceToAnnotationSpace Method (PointF)

Converts an array of PointF from view space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ViewSpaceToAnnotationSpace(
    PointF[] points
)
Public Sub ViewSpaceToAnnotationSpace (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
An array of points to convert.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToAnnotationSpace Method (IAnnotate, AnnotationData, PointF)

AnnotateSpaceConverterViewSpaceToAnnotationSpace Method (IAnnotate, AnnotationData, PointF)

Converts a point from view space to annotation space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF ViewSpaceToAnnotationSpace(
    IAnnotate parent,
    AnnotationData data,
    PointF point
)
Public Shared Function ViewSpaceToAnnotationSpace (
    parent As IAnnotate,
    data As AnnotationData,
    point As PointF
) As PointF

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object used for converting. This can be null (Nothing in VB) if only converting between view and document space.
point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point value in annotation space.
Remarks
For this method to function accurately both parent and data parameters must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToAnnotationSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToDocumentSpace Method

AnnotateSpaceConverterViewSpaceToDocumentSpace Method

These methods are used to convert PointF and RectangleF values form view space to document space.
Overload List
 | Name | Description
Public method | ViewSpaceToDocumentSpace(PointF) | Converts a point from view space to document space.
Public method | ViewSpaceToDocumentSpace(PointF) | Converts an array of points from view space to document space.
Public method | ViewSpaceToDocumentSpace(RectangleF) | Converts a rectangle from view space to document space.
 | ViewSpaceToDocumentSpace(IAnnotate, PointF) | Converts a point from view space to document space.
 | ViewSpaceToDocumentSpace(IAnnotate, RectangleF) | Converts a rectangle from view space to document space.
Top
See Also

Reference

AnnotateSpaceConverter Class
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToDocumentSpace Method (PointF)

AnnotateSpaceConverterViewSpaceToDocumentSpace Method (PointF)

Converts a point from view space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ViewSpaceToDocumentSpace(
    PointF point
)
Public Function ViewSpaceToDocumentSpace (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to document space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToDocumentSpace Method (PointF[])

AnnotateSpaceConverterViewSpaceToDocumentSpace Method (PointF)

Converts an array of points from view space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ViewSpaceToDocumentSpace(
    PointF[] points
)
Public Sub ViewSpaceToDocumentSpace (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
An array of PointF that will be converted.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToDocumentSpace Method (RectangleF)

AnnotateSpaceConverterViewSpaceToDocumentSpace Method (RectangleF)

Converts a rectangle from view space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF ViewSpaceToDocumentSpace(
    RectangleF rectangle
)
Public Function ViewSpaceToDocumentSpace (
    rectangle As RectangleF
) As RectangleF

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle to convert.

Return Value

Type: RectangleF
The rectangle converted to document space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToDocumentSpace Method (IAnnotate, PointF)

AnnotateSpaceConverterViewSpaceToDocumentSpace Method (IAnnotate, PointF)

Converts a point from view space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF ViewSpaceToDocumentSpace(
    IAnnotate parent,
    PointF point
)
Public Shared Function ViewSpaceToDocumentSpace (
    parent As IAnnotate,
    point As PointF
) As PointF

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
point
Type: System.DrawingPointF
The point to convert.

Return Value

Type: PointF
The point converted to document space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotateSpaceConverter.ViewSpaceToDocumentSpace Method (IAnnotate, RectangleF)

AnnotateSpaceConverterViewSpaceToDocumentSpace Method (IAnnotate, RectangleF)

Converts a rectangle from view space to document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RectangleF ViewSpaceToDocumentSpace(
    IAnnotate parent,
    RectangleF rectangle
)
Public Shared Function ViewSpaceToDocumentSpace (
    parent As IAnnotate,
    rectangle As RectangleF
) As RectangleF

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
The IAnnotate parent used for converting between view, document and annotation spaces. This can be null (Nothing in VB) if only converting between document and annotation space.
rectangle
Type: System.DrawingRectangleF
The rectangle to convert.

Return Value

Type: RectangleF
The rectangle converted to document space.
Remarks
For this method to function accurately the parent parameter must be provided when constructing the AnnotateSpaceConverter.
See Also

Reference

AnnotateSpaceConverter Class
ViewSpaceToDocumentSpace Overload
Atalasoft.Annotate Namespace


AnnotationBinder Class

A SerializationBinder that remaps a default set of Atalasoft assembly and type names for annotations.
Inheritance Hierarchy
SystemObject
System.Runtime.SerializationSerializationBinder
Atalasoft.AnnotateAnnotationBinder

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationBinder : SerializationBinder
Public Class AnnotationBinder
    Inherits SerializationBinder

The AnnotationBinder type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationBinder | Initializes a new instance of the AnnotationBinder class
Top
Methods
 | Name | Description
Public method | BindToName | When overridden in a derived class, controls the binding of a serialized object to a type. (Inherited from SerializationBinder.)
Public method | BindToType | Controls the binding of a serialized object to a type. (Overrides SerializationBinderBindToType(String, String).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationBinder Constructor

Initializes a new instance of the AnnotationBinder class

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBinder()
Public Sub New
See Also

Reference

AnnotationBinder Class
Atalasoft.Annotate Namespace


AnnotationBinder Methods

The AnnotationBinder type exposes the following members.

Methods
 | Name | Description
Public method | BindToName | When overridden in a derived class, controls the binding of a serialized object to a type. (Inherited from SerializationBinder.)
Public method | BindToType | Controls the binding of a serialized object to a type. (Overrides SerializationBinderBindToType(String, String).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationBinder Class
Atalasoft.Annotate Namespace


AnnotationBinder.BindToType Method

AnnotationBinderBindToType Method

Controls the binding of a serialized object to a type.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Type BindToType(
    string assemblyName,
    string typeName
)
Public Overrides Function BindToType (
    assemblyName As String,
    typeName As String
) As Type

Parameters

assemblyName
Type: SystemString
Specifies the assembly name of the serialized object.
typeName
Type: SystemString
Specifies the Type name of the serialized object.

Return Value

Type: Type
The type of the object the formatter creates a new instance of.
See Also

Reference

AnnotationBinder Class
Atalasoft.Annotate Namespace


AnnotationBrush Class

This class describes a brush object used for drawing annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationBrush

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(AnnotationBrushConverter))]
public class AnnotationBrush : ISerializable
<SerializableAttribute>
<TypeConverterAttribute(GetType(AnnotationBrushConverter))>
Public Class AnnotationBrush
    Implements ISerializable

The AnnotationBrush type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationBrush(Color) | Creates a solid brush with the specified color.
Public method | AnnotationBrush(AnnotationImage) | Creates a texture brush using the specified image.
Public method | AnnotationBrush(HatchStyle, Color) | Creates a hatch brush with the specified hatch style and forecolor.
Public method | AnnotationBrush(SerializationInfo, StreamingContext) | Creates a brush from serialized information.
Public method | AnnotationBrush(AnnotationImage, WrapMode) | Creates a new texture brush with the specified image and wrap mode.
Public method | AnnotationBrush(AnnotationImage, Rectangle) | Creates a texture brush using the specified image and bounding rectangle.
Public method | AnnotationBrush(AnnotationImage, RectangleF) | Creates a texture brush using the specified image and bounding rectangle.
Public method | AnnotationBrush(HatchStyle, Color, Color) | Creates a hatch brush with the specified hatch style, forecolor and background color.
Public method | AnnotationBrush(AnnotationImage, WrapMode, Rectangle) | Creates a texture brush with the specified image, wrap mode and bounding rectangle.
Public method | AnnotationBrush(AnnotationImage, WrapMode, RectangleF) | Creates a texture brush with the specified image, wrap mode and bounding rectangle.
Public method | AnnotationBrush(Point, Point, Color, Color) | Creates a linear gradient brush using the specified start point, end point, start color and end color.
Public method | AnnotationBrush(PointF, PointF, Color, Color) | Creates a linear gradient brush using the specified start point, end point, start color and end color.
Public method | AnnotationBrush(Rectangle, Color, Color, LinearGradientMode) | Creates a linear gradient brush with the bounding rectangle, starting and ending colors, and the gradient orientation.
Public method | AnnotationBrush(RectangleF, Color, Color, LinearGradientMode) | Creates a linear gradient brush with the bounding rectangle, starting and ending colors, and the gradient orientation.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets the color of a solid brush.
Public property | FillType | Gets or sets the type of brush used.
Public property | HatchBackColor | Gets or sets the hatch background color of a hatch brush.
Public property | HatchForeColor | Gets or sets the hatch forecolor of a hatch brush.
Public property | HatchStyle | Gets or sets the hatch style of a hatch brush.
Public property | Image | Gets or sets the image used for a texture brush.
Public property | LinearColors | Gets or sets the colors used by a linear gradient brush.
Public property | LinearGradientMode | The orientation of a linear gradient brush.
Public property | Rectangle | The bounding rectangle a texture or linear gradient brush.
Public property | WrapMode | Gets or sets the wrap mode of a texture brush.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of the AnnotationBrush object.
Public method | Equals | Used to compare two AnnotationBrush objects. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with information about the brush.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called after a property has been changed.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property has been changed.
Public method | ToString | Returns a information about this AnnotationBrush. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
Remarks
The IAnnotationRenderer for each annotation will use this information to construct a brush or equivalent for the drawing environment of its choice.
Examples
The code below creates a RectangleAnnotation with a solid brush and black border.
CreateRectAnn
Copy
RectangleAnnotation rect = new RectangleAnnotation(RectangleF.Empty, new AnnotationBrush(Color.Red), new AnnotationPen(Color.Black, 1));
((RectangleGrips)rect.Grips).GripsToDisplay = RectangleGripDisplay.Both;
this.annotateViewer1.Annotations.CreateAnnotation(rect);
CreateRectAnn
Copy
Dim rect As RectangleAnnotation =  New RectangleAnnotation(RectangleF.Empty,New AnnotationBrush(Color.Red),New AnnotationPen(Color.Black,1))
((RectangleGrips)rect.Grips).GripsToDisplay = RectangleGripDisplay.Both
Me.annotateViewer1.Annotations.CreateAnnotation(rect)
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationBrush Constructor

Construct a new solid, hatch, texture or linear gradient AnnotationBrush.
Overload List
 | Name | Description
Public method | AnnotationBrush(Color) | Creates a solid brush with the specified color.
Public method | AnnotationBrush(AnnotationImage) | Creates a texture brush using the specified image.
Public method | AnnotationBrush(HatchStyle, Color) | Creates a hatch brush with the specified hatch style and forecolor.
Public method | AnnotationBrush(SerializationInfo, StreamingContext) | Creates a brush from serialized information.
Public method | AnnotationBrush(AnnotationImage, WrapMode) | Creates a new texture brush with the specified image and wrap mode.
Public method | AnnotationBrush(AnnotationImage, Rectangle) | Creates a texture brush using the specified image and bounding rectangle.
Public method | AnnotationBrush(AnnotationImage, RectangleF) | Creates a texture brush using the specified image and bounding rectangle.
Public method | AnnotationBrush(HatchStyle, Color, Color) | Creates a hatch brush with the specified hatch style, forecolor and background color.
Public method | AnnotationBrush(AnnotationImage, WrapMode, Rectangle) | Creates a texture brush with the specified image, wrap mode and bounding rectangle.
Public method | AnnotationBrush(AnnotationImage, WrapMode, RectangleF) | Creates a texture brush with the specified image, wrap mode and bounding rectangle.
Public method | AnnotationBrush(Point, Point, Color, Color) | Creates a linear gradient brush using the specified start point, end point, start color and end color.
Public method | AnnotationBrush(PointF, PointF, Color, Color) | Creates a linear gradient brush using the specified start point, end point, start color and end color.
Public method | AnnotationBrush(Rectangle, Color, Color, LinearGradientMode) | Creates a linear gradient brush with the bounding rectangle, starting and ending colors, and the gradient orientation.
Public method | AnnotationBrush(RectangleF, Color, Color, LinearGradientMode) | Creates a linear gradient brush with the bounding rectangle, starting and ending colors, and the gradient orientation.
Top
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (Color)

Creates a solid brush with the specified color.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor
The color of the brush.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (AnnotationImage)

Creates a texture brush using the specified image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    AnnotationImage image
)
Public Sub New (
    image As AnnotationImage
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image used for the texture.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (HatchStyle, Color)

Creates a hatch brush with the specified hatch style and forecolor.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    HatchStyle hatchStyle,
    Color foreColor
)
Public Sub New (
    hatchStyle As HatchStyle,
    foreColor As Color
)

Parameters

hatchStyle
Type: System.Drawing.Drawing2DHatchStyle
The hatch style used by this brush.
foreColor
Type: System.DrawingColor
The forecolor of the brush.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (SerializationInfo, StreamingContext)

Creates a brush from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo containing the brush data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (AnnotationImage, WrapMode)

Creates a new texture brush with the specified image and wrap mode.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    AnnotationImage image,
    WrapMode wrapMode
)
Public Sub New (
    image As AnnotationImage,
    wrapMode As WrapMode
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image used for the texture.
wrapMode
Type: System.Drawing.Drawing2DWrapMode
The wrap mode that specifies how the texture is tiled.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (AnnotationImage, Rectangle)

Creates a texture brush using the specified image and bounding rectangle.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    AnnotationImage image,
    Rectangle dstRect
)
Public Sub New (
    image As AnnotationImage,
    dstRect As Rectangle
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image used for the texture.
dstRect
Type: System.DrawingRectangle
A bounding rectangle for the texture.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (AnnotationImage, RectangleF)

Creates a texture brush using the specified image and bounding rectangle.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    AnnotationImage image,
    RectangleF dstRect
)
Public Sub New (
    image As AnnotationImage,
    dstRect As RectangleF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image used for the texture.
dstRect
Type: System.DrawingRectangleF
A bounding rectangle for the texture.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (HatchStyle, Color, Color)

Creates a hatch brush with the specified hatch style, forecolor and background color.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    HatchStyle hatchStyle,
    Color foreColor,
    Color backColor
)
Public Sub New (
    hatchStyle As HatchStyle,
    foreColor As Color,
    backColor As Color
)

Parameters

hatchStyle
Type: System.Drawing.Drawing2DHatchStyle
The hatch style used by this brush.
foreColor
Type: System.DrawingColor
The forecolor of the brush.
backColor
Type: System.DrawingColor
The background color of the brush.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (AnnotationImage, WrapMode, Rectangle)

Creates a texture brush with the specified image, wrap mode and bounding rectangle.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    AnnotationImage image,
    WrapMode wrapMode,
    Rectangle dstRect
)
Public Sub New (
    image As AnnotationImage,
    wrapMode As WrapMode,
    dstRect As Rectangle
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image used for the texture.
wrapMode
Type: System.Drawing.Drawing2DWrapMode
The wrap mode that specifies how the texture is tiled.
dstRect
Type: System.DrawingRectangle
A bounding rectangle for the texture.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (AnnotationImage, WrapMode, RectangleF)

Creates a texture brush with the specified image, wrap mode and bounding rectangle.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    AnnotationImage image,
    WrapMode wrapMode,
    RectangleF dstRect
)
Public Sub New (
    image As AnnotationImage,
    wrapMode As WrapMode,
    dstRect As RectangleF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image used for the texture.
wrapMode
Type: System.Drawing.Drawing2DWrapMode
The wrap mode that specifies how the texture is tiled.
dstRect
Type: System.DrawingRectangleF
A bounding rectangle for the texture.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (Point, Point, Color, Color)

Creates a linear gradient brush using the specified start point, end point, start color and end color.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    Point point1,
    Point point2,
    Color color1,
    Color color2
)
Public Sub New (
    point1 As Point,
    point2 As Point,
    color1 As Color,
    color2 As Color
)

Parameters

point1
Type: System.DrawingPoint
The starting point of the gradient.
point2
Type: System.DrawingPoint
The ending point of the gradient.
color1
Type: System.DrawingColor
The starting color of the gradient.
color2
Type: System.DrawingColor
The ending color of the gradient.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (PointF, PointF, Color, Color)

Creates a linear gradient brush using the specified start point, end point, start color and end color.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    PointF point1,
    PointF point2,
    Color color1,
    Color color2
)
Public Sub New (
    point1 As PointF,
    point2 As PointF,
    color1 As Color,
    color2 As Color
)

Parameters

point1
Type: System.DrawingPointF
The starting point of the gradient.
point2
Type: System.DrawingPointF
The ending point of the gradient.
color1
Type: System.DrawingColor
The starting color of the gradient.
color2
Type: System.DrawingColor
The ending color of the gradient.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (Rectangle, Color, Color, LinearGradientMode)

Creates a linear gradient brush with the bounding rectangle, starting and ending colors, and the gradient orientation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    Rectangle rect,
    Color color1,
    Color color2,
    LinearGradientMode linearGradientMode
)
Public Sub New (
    rect As Rectangle,
    color1 As Color,
    color2 As Color,
    linearGradientMode As LinearGradientMode
)

Parameters

rect
Type: System.DrawingRectangle
The bounding rectangle of the linear gradient.
color1
Type: System.DrawingColor
The starting color of the gradient.
color2
Type: System.DrawingColor
The ending color of the gradient.
linearGradientMode
Type: System.Drawing.Drawing2DLinearGradientMode
The orientation of the gradient.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Constructor (RectangleF, Color, Color, LinearGradientMode)

Creates a linear gradient brush with the bounding rectangle, starting and ending colors, and the gradient orientation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush(
    RectangleF rect,
    Color color1,
    Color color2,
    LinearGradientMode linearGradientMode
)
Public Sub New (
    rect As RectangleF,
    color1 As Color,
    color2 As Color,
    linearGradientMode As LinearGradientMode
)

Parameters

rect
Type: System.DrawingRectangleF
The bounding rectangle of the linear gradient.
color1
Type: System.DrawingColor
The starting color of the gradient.
color2
Type: System.DrawingColor
The ending color of the gradient.
linearGradientMode
Type: System.Drawing.Drawing2DLinearGradientMode
The orientation of the gradient.
See Also

Reference

AnnotationBrush Class
AnnotationBrush Overload
Atalasoft.Annotate Namespace


AnnotationBrush Properties

The AnnotationBrush type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets or sets the color of a solid brush.
Public property | FillType | Gets or sets the type of brush used.
Public property | HatchBackColor | Gets or sets the hatch background color of a hatch brush.
Public property | HatchForeColor | Gets or sets the hatch forecolor of a hatch brush.
Public property | HatchStyle | Gets or sets the hatch style of a hatch brush.
Public property | Image | Gets or sets the image used for a texture brush.
Public property | LinearColors | Gets or sets the colors used by a linear gradient brush.
Public property | LinearGradientMode | The orientation of a linear gradient brush.
Public property | Rectangle | The bounding rectangle a texture or linear gradient brush.
Public property | WrapMode | Gets or sets the wrap mode of a texture brush.
Top
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.Color Property

AnnotationBrushColor Property

Gets or sets the color of a solid brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The solid brush color.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.FillType Property

AnnotationBrushFillType Property

Gets or sets the type of brush used.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FillType FillType { get; set; }
Public Property FillType As FillType
    Get
    Set

Property Value

Type: FillType
The type of brush used for this object.
Remarks

Only specific properties are valid for each FillType. These are specified below:

FillType | Properties
Solid | Color
Texture Image
WrapMode
Rectangle
Hatch HatchStyle
HatchForeColor
HatchBackColor
LinearGradient LinearColors
LinearGradientMode
Rectangle

See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.HatchBackColor Property

AnnotationBrushHatchBackColor Property

Gets or sets the hatch background color of a hatch brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HatchBackColor { get; set; }
Public Property HatchBackColor As Color
    Get
    Set

Property Value

Type: Color
The background color of a hatch brush.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.HatchForeColor Property

AnnotationBrushHatchForeColor Property

Gets or sets the hatch forecolor of a hatch brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HatchForeColor { get; set; }
Public Property HatchForeColor As Color
    Get
    Set

Property Value

Type: Color
The hatch forecolor.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.HatchStyle Property

AnnotationBrushHatchStyle Property

Gets or sets the hatch style of a hatch brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HatchStyle HatchStyle { get; set; }
Public Property HatchStyle As HatchStyle
    Get
    Set

Property Value

Type: HatchStyle
The hatch style of the brush.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.Image Property

AnnotationBrushImage Property

Gets or sets the image used for a texture brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage Image { get; set; }
Public Property Image As AnnotationImage
    Get
    Set

Property Value

Type: AnnotationImage
The image used as a texture.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.LinearColors Property

AnnotationBrushLinearColors Property

Gets or sets the colors used by a linear gradient brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color[] LinearColors { get; set; }
Public Property LinearColors As Color()
    Get
    Set

Property Value

Type: Color
The colors of a linear gradient brush.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.LinearGradientMode Property

AnnotationBrushLinearGradientMode Property

The orientation of a linear gradient brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinearGradientMode LinearGradientMode { get; set; }
Public Property LinearGradientMode As LinearGradientMode
    Get
    Set

Property Value

Type: LinearGradientMode
The gradient orientation.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.Rectangle Property

AnnotationBrushRectangle Property

The bounding rectangle a texture or linear gradient brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(RectangleFTypeConverter))]
public RectangleF Rectangle { get; set; }
<TypeConverterAttribute(GetType(RectangleFTypeConverter))>
Public Property Rectangle As RectangleF
    Get
    Set

Property Value

Type: RectangleF
The bounding rectangle of the brush.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.WrapMode Property

AnnotationBrushWrapMode Property

Gets or sets the wrap mode of a texture brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WrapMode WrapMode { get; set; }
Public Property WrapMode As WrapMode
    Get
    Set

Property Value

Type: WrapMode
The texture wrap mode.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush Methods

The AnnotationBrush type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of the AnnotationBrush object.
Public method | Equals | Used to compare two AnnotationBrush objects. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with information about the brush.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called after a property has been changed.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property has been changed.
Public method | ToString | Returns a information about this AnnotationBrush. (Overrides ObjectToString.)
Top
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.Clone Method

AnnotationBrushClone Method

Creates a copy of the AnnotationBrush object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Clone()
Public Function Clone As AnnotationBrush

Return Value

Type: AnnotationBrush
A copy of this brush.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.Equals Method

AnnotationBrushEquals Method

Used to compare two AnnotationBrush objects.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AnnotationBrush this object is compared to.

Return Value

Type: Boolean
True if the brush parameters are the same.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.GetHashCode Method

AnnotationBrushGetHashCode Method

Returns an identifier for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An identifier for this object.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.GetObjectData Method

AnnotationBrushGetObjectData Method

Fills a SerializationInfo object with information about the brush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with brush information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.OnAnnotationControllerNotification Method

AnnotationBrushOnAnnotationControllerNotification Method

Called after a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs specifying the property that was modified.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.OnPropertyChanged Method

AnnotationBrushOnPropertyChanged Method

Called when a property value has changed and raises the PropertyChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationLocationChangedEventArgs containing information for this event.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.OnPropertyChanging Method

AnnotationBrushOnPropertyChanging Method

Called before a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs specifying the property that is being modified.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.ToString Method

AnnotationBrushToString Method

Returns a information about this AnnotationBrush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string containing information about this object.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush Events

The AnnotationBrush type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.AnnotationControllerNotification Event

AnnotationBrushAnnotationControllerNotification Event

Raised after a property of the AnnotationBrush if modified.
Raised after a property of the AnnotationBrush if modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.PropertyChanged Event

AnnotationBrushPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationBrush.PropertyChanging Event

AnnotationBrushPropertyChanging Event

Raised just before a property is about to be modified.
Raised just before a property is about to be modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationBrush Class
Atalasoft.Annotate Namespace


AnnotationConfinementMode Enumeration

Specifies the type of confinement used for the annotations when they are being moved or resized using the mouse.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationConfinementMode
Public Enumeration AnnotationConfinementMode
Members
Member name | Description
None | There is no limitation to the annotation location.
ClientArea | Annotations can be located outside of the document but not outside of the client area of the viewer.
DocumentBounds | Annotations are confined to the document bounds.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationControllerNotification Enumeration

Specifies the type of notification being sent to the AnnotationController.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationControllerNotification
Public Enumeration AnnotationControllerNotification
Members
Member name | Description
Invalidate | Informs the controller that it needs to invalidate the control.
AddControl | Tells the controller to add a Control to the viewer.
RemoveControl | Removes a previously added control from the viewer.
SelectionChange | The Selection property of an annotation has changed.
PropertyChange | A property of the control has changed.
LayerContentChange | The content of a layer has changed.
ZoomChanged | The zoom level of the viewer has changed.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Class

This class provides information when the AnnotationController is sent a notification from another object.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateAnnotationControllerNotificationEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationControllerNotificationEventArgs : EventArgs
Public Class AnnotationControllerNotificationEventArgs
    Inherits EventArgs

The AnnotationControllerNotificationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the type of notification being sent.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationRegion) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and invalidation region to send.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationUndo) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and undo to send.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, Control) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and a control to process.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationRegion, AnnotationUndo) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, invalidation region and undo to send.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationUndo, UndoManagerAction) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, undo and special undo action.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, CollectionChangedEventArgs, AnnotationUndo) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, CollectionChangedEventArgs and an undo.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationRegion, AnnotationUndo, UndoManagerAction) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, invalidation region, undo and a special undo action.
Top
Properties
 | Name | Description
Public property | CollectionChangedArgs | Gets the CollectionChangedEventArgs containing information about the collection change.
Public property | Control | Gets a System.Windows.Forms.Control object used with this notification.
Public property | InvalidateRegion | Gets or sets a region used for invalidating the parent control.
Public property | Notification | Gets the type of notification performed on the object.
Public property | Undo | Gets the AnnotationUndo to store into the AnnotationUndoManager.
Public property | UndoAction | Gets a special undo action to send to the undo manager.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Custom annotations can make use of this to notify the controller when it needs to invalidate or add undo information to the AnnotationUndoManager.
Examples
AnnotationPropertyChangingEventArgs Class
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor

Constructs an AnnotationControllerNotificationEventArgs.
Overload List
 | Name | Description
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the type of notification being sent.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationRegion) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and invalidation region to send.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationUndo) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and undo to send.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, Control) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and a control to process.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationRegion, AnnotationUndo) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, invalidation region and undo to send.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationUndo, UndoManagerAction) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, undo and special undo action.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, CollectionChangedEventArgs, AnnotationUndo) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, CollectionChangedEventArgs and an undo.
Public method | AnnotationControllerNotificationEventArgs(AnnotationControllerNotification, AnnotationRegion, AnnotationUndo, UndoManagerAction) | Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, invalidation region, undo and a special undo action.
Top
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the type of notification being sent.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification
)
Public Sub New (
    notification As AnnotationControllerNotification
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, AnnotationRegion)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and invalidation region to send.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    AnnotationRegion invalidateRegion
)
Public Sub New (
    notification As AnnotationControllerNotification,
    invalidateRegion As AnnotationRegion
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
invalidateRegion
Type: Atalasoft.AnnotateAnnotationRegion
A region to invalidate.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, AnnotationUndo)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and undo to send.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    AnnotationUndo undo
)
Public Sub New (
    notification As AnnotationControllerNotification,
    undo As AnnotationUndo
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
undo
Type: Atalasoft.Annotate.UIAnnotationUndo
An undo to add to the undo collection.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, Control)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification and a control to process.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    Control control
)
Public Sub New (
    notification As AnnotationControllerNotification,
    control As Control
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
control
Type: System.Windows.FormsControl
A control to process.
Remarks
This constructor is used by the TextAnnotation to add or remove the edit control to the AnnotateViewer. Custom annotations could use this to add any class deriving from System.Windows.Forms.Control to the viewer.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, AnnotationRegion, AnnotationUndo)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, invalidation region and undo to send.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    AnnotationRegion invalidateRegion,
    AnnotationUndo undo
)
Public Sub New (
    notification As AnnotationControllerNotification,
    invalidateRegion As AnnotationRegion,
    undo As AnnotationUndo
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
invalidateRegion
Type: Atalasoft.AnnotateAnnotationRegion
A region to invalidate.
undo
Type: Atalasoft.Annotate.UIAnnotationUndo
An undo to add to the undo collection.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, AnnotationUndo, UndoManagerAction)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, undo and special undo action.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    AnnotationUndo undo,
    UndoManagerAction undoAction
)
Public Sub New (
    notification As AnnotationControllerNotification,
    undo As AnnotationUndo,
    undoAction As UndoManagerAction
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
undo
Type: Atalasoft.Annotate.UIAnnotationUndo
An undo to add to the undo collection.
undoAction
Type: Atalasoft.AnnotateUndoManagerAction
A special undo action that should be taken.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, CollectionChangedEventArgs, AnnotationUndo)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, CollectionChangedEventArgs and an undo.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    CollectionChangedEventArgs collectionChangedArgs,
    AnnotationUndo undo
)
Public Sub New (
    notification As AnnotationControllerNotification,
    collectionChangedArgs As CollectionChangedEventArgs,
    undo As AnnotationUndo
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
collectionChangedArgs
Type: Atalasoft.UtilsCollectionChangedEventArgs
An CollectionChangedEventArgs indicating a change to a collection.
undo
Type: Atalasoft.Annotate.UIAnnotationUndo
An undo to add to the undo collection.
Remarks
This constructor is used by collections to notify the controller when an annotation or layer has been changed.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Constructor (AnnotationControllerNotification, AnnotationRegion, AnnotationUndo, UndoManagerAction)

Creates a new instance of AnnotationControllerNotificationEventArgs specifying the notification, invalidation region, undo and a special undo action.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotificationEventArgs(
    AnnotationControllerNotification notification,
    AnnotationRegion invalidateRegion,
    AnnotationUndo undo,
    UndoManagerAction undoAction
)
Public Sub New (
    notification As AnnotationControllerNotification,
    invalidateRegion As AnnotationRegion,
    undo As AnnotationUndo,
    undoAction As UndoManagerAction
)

Parameters

notification
Type: Atalasoft.AnnotateAnnotationControllerNotification
The notification to send.
invalidateRegion
Type: Atalasoft.AnnotateAnnotationRegion
A region to invalidate.
undo
Type: Atalasoft.Annotate.UIAnnotationUndo
An undo to add to the undo collection.
undoAction
Type: Atalasoft.AnnotateUndoManagerAction
A special undo action to take.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
AnnotationControllerNotificationEventArgs Overload
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Properties

The AnnotationControllerNotificationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CollectionChangedArgs | Gets the CollectionChangedEventArgs containing information about the collection change.
Public property | Control | Gets a System.Windows.Forms.Control object used with this notification.
Public property | InvalidateRegion | Gets or sets a region used for invalidating the parent control.
Public property | Notification | Gets the type of notification performed on the object.
Public property | Undo | Gets the AnnotationUndo to store into the AnnotationUndoManager.
Public property | UndoAction | Gets a special undo action to send to the undo manager.
Top
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs.CollectionChangedArgs Property

AnnotationControllerNotificationEventArgsCollectionChangedArgs Property

Gets the CollectionChangedEventArgs containing information about the collection change.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs CollectionChangedArgs { get; }
Public ReadOnly Property CollectionChangedArgs As CollectionChangedEventArgs
    Get

Property Value

Type: CollectionChangedEventArgs
A CollectionChangedEventArgs for this change.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs.Control Property

AnnotationControllerNotificationEventArgsControl Property

Gets a System.Windows.Forms.Control object used with this notification.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Control Control { get; }
Public ReadOnly Property Control As Control
    Get

Property Value

Type: Control
A control used with this notification.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs.InvalidateRegion Property

AnnotationControllerNotificationEventArgsInvalidateRegion Property

Gets or sets a region used for invalidating the parent control.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRegion InvalidateRegion { get; set; }
Public Property InvalidateRegion As AnnotationRegion
    Get
    Set

Property Value

Type: AnnotationRegion
A Region to invalidate.
Remarks
This property is only checked by the AnnotationController in the AnnotationControllerNotification event if the Change property is RegionChange, ContentChange or SelectionChange.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs.Notification Property

AnnotationControllerNotificationEventArgsNotification Property

Gets the type of notification performed on the object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationControllerNotification Notification { get; }
Public ReadOnly Property Notification As AnnotationControllerNotification
    Get

Property Value

Type: AnnotationControllerNotification
The notification performed.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs.Undo Property

AnnotationControllerNotificationEventArgsUndo Property

Gets the AnnotationUndo to store into the AnnotationUndoManager.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo Undo { get; }
Public ReadOnly Property Undo As AnnotationUndo
    Get

Property Value

Type: AnnotationUndo
The undo for this operation.
Remarks
This property is only checked by the AnnotationController in the PropertyChanging event.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs.UndoAction Property

AnnotationControllerNotificationEventArgsUndoAction Property

Gets a special undo action to send to the undo manager.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoManagerAction UndoAction { get; }
Public ReadOnly Property UndoAction As UndoManagerAction
    Get

Property Value

Type: UndoManagerAction
The undo action provided to the undo manager.
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventArgs Methods

The AnnotationControllerNotificationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationControllerNotificationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationControllerNotificationEventHandler Delegate

This delegate is used for the AnnotationControllerNotification event to send information to the AnnotationController.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationControllerNotificationEventHandler(
    Object sender,
    AnnotationControllerNotificationEventArgs e
)
Public Delegate Sub AnnotationControllerNotificationEventHandler (
    sender As Object,
    e As AnnotationControllerNotificationEventArgs
)

Parameters

sender
Type: SystemObject
The object sending this notification.
e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information for this event.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationData Class

This is the main annotation data class used to hold base information required by all annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
More...

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class AnnotationData : ISerializable,
    ICloneable, IDisposable
<SerializableAttribute>
Public MustInherit Class AnnotationData
    Implements ISerializable, ICloneable, IDisposable

The AnnotationData type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationData | Default constructor of AnnotationData.
Protected method | AnnotationData(SerializationInfo, StreamingContext) | Default serialization constructor of AnnotationData.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied.
Public property | Bounds | Gets the bounding rectangle of the annotation.
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror.
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved.
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized.
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated.
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected.
Public property | CreationTime | Gets or sets the creation time of the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally.
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically.
Public property | Location | Gets or sets the location of this annotation.
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified.
Public property | Name | Gets or sets a name for this annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation.
Public property | Security | Gets or sets the security lock used for this annotation.
Public property | Selected | Get or set whether this AnnotationData object is selected
Public property | Size | Gets or sets the size of the annotation.
Public property | State | Get or set the AnnotationState of this AnnotationData object
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip.
Public property | Transform | Gets the transformation matrix used for rendering this annotation.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations.
Public property | Visible | Gets or sets a value indicating if the annotation is visible.
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms.
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms.
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account.
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds.
 | Clone | Returns a copy of this annotation data.
 | CloneBaseData | Fills the data object with cloned property values.
Protected method | CloneBaseDataFrom | Clones the base data from.
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called to release resources used by the annotation.
Public method | Equals | Compares the current annotation with another. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Overrides ObjectFinalize.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties.
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String).
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.
 | GetObjectData | Fills the SerializationInfo object with properties values for the base AnnotationData class.
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically.
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed.
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed.
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed.
Protected method | OnCanResizeChanged | Called when the CanResize property has changed.
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed.
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed.
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed.
Protected method | OnLocationChanged | Called when the Location property value has changed.
Protected method | OnMirrored | Called when the annotation has been mirrored.
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed.
Protected method | OnNameChanged | Called when the Name property has changed.
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called just before a property value is changed.
Protected method | OnRotationChanged | Called when the Rotation property has changed.
Protected method | OnSecurityChanged | Called when the Security property has changed.
Protected method | OnSizeChanged | Called when the Size property has changed.
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event.
Protected method | OnTooltipChanged | Called when the ToolTip property has changed.
Protected method | OnTransformChanged | Called when the Transform property has changed.
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event.
Protected method | OnVisibleChanged | Called when the Visible property has changed.
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush.
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont.
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen.
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock.
Public method | Rotate | Applies rotation to the annotation from its current rotation amount.
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush.
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String).
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont.
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen.
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed.
Public event | CanMirrorChanged | Raised when the CanMirror property is changed.
Public event | CanMoveChanged | Raised when the CanMove property is changed.
Public event | CanResizeChanged | Raised when the CanResize property has changed.
Public event | CanRotateChanged | Raised when the CanRotate property has changed.
Public event | CanSelectChanged | Raised when the CanSelect property has changed.
Public event | CreationTimeChanged | Raised when the CreationTime property has changed.
Public event | LocationChanged | Raised when the Location property has changed.
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called.
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed.
Public event | NameChanged | Raised when the Name property has changed.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised before a property is changed.
Public event | RotationChanged | Raised when the Rotation property has changed.
Public event | SecurityChanged | Raised when the Security property has changed.
Public event | SizeChanged | Raised when the Size property has changed.
Public event | StateChanged | This event is raised when the State property value has changed.
Public event | TooltipChanged | Raised when the ToolTip property has changed.
Public event | TransformChanged | Raised when the Transform property has changed.
Public event | UserNameChanged | This event is raised when the UserName property has changed.
Public event | VisibleChanged | Raised when the Visible property has changed.
Top
See Also

Reference

Atalasoft.Annotate Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateCalloutData
Atalasoft.AnnotateEllipseData
Atalasoft.AnnotateEmbeddedImageData
Atalasoft.AnnotateHotSpotData
Atalasoft.Annotate.InkInkData
Atalasoft.AnnotateLayerData
Atalasoft.AnnotateLineData
Atalasoft.AnnotateOcrRegionData
Atalasoft.Annotate.PdfPdfAnnotationData
Atalasoft.AnnotatePointBaseData
Atalasoft.AnnotateRectangleData
Atalasoft.AnnotateReferencedImageData
Atalasoft.AnnotateRubberStampData
Atalasoft.AnnotateTextData


AnnotationData Constructor

Overload List
 | Name | Description
Public method | AnnotationData | Default constructor of AnnotationData.
Protected method | AnnotationData(SerializationInfo, StreamingContext) | Default serialization constructor of AnnotationData.
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData Constructor

Default constructor of AnnotationData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData()
Public Sub New
Remarks
AnnotationData is an abstract class and cannot be created directly.
See Also

Reference

AnnotationData Class
AnnotationData Overload
Atalasoft.Annotate Namespace


AnnotationData Constructor (SerializationInfo, StreamingContext)

Default serialization constructor of AnnotationData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AnnotationData(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo containing annotation data.
context
Type: System.Runtime.SerializationStreamingContext
StreamingContext object for this class.
See Also

Reference

AnnotationData Class
AnnotationData Overload
Atalasoft.Annotate Namespace


AnnotationData Properties

The AnnotationData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied.
Public property | Bounds | Gets the bounding rectangle of the annotation.
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror.
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved.
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized.
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated.
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected.
Public property | CreationTime | Gets or sets the creation time of the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally.
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically.
Public property | Location | Gets or sets the location of this annotation.
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified.
Public property | Name | Gets or sets a name for this annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation.
Public property | Security | Gets or sets the security lock used for this annotation.
Public property | Selected | Get or set whether this AnnotationData object is selected
Public property | Size | Gets or sets the size of the annotation.
Public property | State | Get or set the AnnotationState of this AnnotationData object
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip.
Public property | Transform | Gets the transformation matrix used for rendering this annotation.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations.
Public property | Visible | Gets or sets a value indicating if the annotation is visible.
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.AnnotationBounds Property

AnnotationDataAnnotationBounds Property

Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied.
Gets the rectangle bounds of the annotation, including any pen or shadow, before any matrices are applied.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RectangleF AnnotationBounds { get; }
Public Overridable ReadOnly Property AnnotationBounds As RectangleF
    Get

Property Value

Type: RectangleF
The rectangular bounds of the annotation without any matrices applied.

Property Value

Type: RectangleF
The rectangular bounds of the annotation without any matrices applied.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Bounds Property

AnnotationDataBounds Property

Gets the bounding rectangle of the annotation.
Gets the bounding rectangle of the annotation in document space.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RectangleF Bounds { get; }
Public Overridable ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
The bounding rectangle of all visual elements of the annotation.

Property Value

Type: RectangleF
The bounding rectangle of all visual elements of the annotation.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanMirror Property

AnnotationDataCanMirror Property

Gets or sets a value indicating if the annotation can mirror.
Gets or sets a value indicating if the annotation can mirror from user interaction.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanMirror { get; set; }
Public Property CanMirror As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation can mirror.

Property Value

Type: Boolean
Indicates if the annotation can mirror.
Remarks
A mirror happens when one side of an annotation is dragged past the opposite side. This will perform a horizontal or vertical flip on the annotation.
Remarks
A mirror happens when one side of an annotation is dragged past the opposite side. This will perform a horizontal or vertical flip on the annotation.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanMove Property

AnnotationDataCanMove Property

Gets or sets a value indicating if the annotation can be moved.
Gets or sets a value indicating if the annotation can be moved by the user.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanMove { get; set; }
Public Property CanMove As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation can be moved.

Property Value

Type: Boolean
Indicates if the annotation can be moved.
Remarks
This will only prevent the annotation from being moved by the end-user. The annotation can still be programmatically moved.
Remarks
This will only prevent the annotation from being moved by the end-user. The annotation can still be programmatically moved.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanResize Property

AnnotationDataCanResize Property

Gets or sets a value indicating if the annotation can be resized.
Gets or sets a value indicating if the annotation can be resized by the user.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanResize { get; set; }
Public Property CanResize As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation can be resized.

Property Value

Type: Boolean
Indicates if the annotation can be resized.
Remarks
This will only prevent the annotation from being resized by the end-user. The annotation can still be programmatically resized.
Remarks
This will only prevent the annotation from being resized by the end-user. The annotation can still be programmatically resized.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanRotate Property

AnnotationDataCanRotate Property

Gets or sets a value indicating if the annotation can be rotated.
Gets or sets a value indicating if the annotation can be rotated by the user.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanRotate { get; set; }
Public Property CanRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation can be rotated.

Property Value

Type: Boolean
Indicates if the annotation can be rotated.
Remarks
This will only prevent the annotation from being rotated by the end-user. The annotation can still be programmatically rotated.
Remarks
This will only prevent the annotation from being rotated by the end-user. The annotation can still be programmatically rotated.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanSelect Property

AnnotationDataCanSelect Property

Gets or sets a value indicating if the annotation can be selected.
Gets or sets a value indicating if the annotation can be selected.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanSelect { get; set; }
Public Property CanSelect As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation can be selected.

Property Value

Type: Boolean
Indicates if the annotation can be selected.
Remarks
This will only prevent the annotation from being selected by the end-user. The annotation can still be programmatically selected.
Remarks
This will only prevent the annotation from being selected by the end-user. The annotation can still be programmatically selected.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CreationTime Property

AnnotationDataCreationTime Property

Gets or sets the creation time of the annotation.
Gets or sets the creation time of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationTime { get; set; }
Public Property CreationTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The creation time of the annotation.

Property Value

Type: DateTime
The creation time of the annotation.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.IgnoreDataChanges Property

AnnotationDataIgnoreDataChanges Property

Gets or sets a value indicating whether any properties changes should be passed to the undo manager.
Gets or sets a value indicating whether any properties changes should be passed to the undo manager.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IgnoreDataChanges { get; set; }
Public Property IgnoreDataChanges As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if properties changes are sent to the undo manager.

Property Value

Type: Boolean
Indicates if properties changes are sent to the undo manager.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.IsMirroredHorizontally Property

AnnotationDataIsMirroredHorizontally Property

Gets a value indicating whether the annotation is mirrored horizontally.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMirroredHorizontally { get; }
Public ReadOnly Property IsMirroredHorizontally As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the annotation is mirrored horizontally.
Remarks
Horizontal mirroring occurs when resizing the annotation and dragging a grip past its opposite grip. This can also happen when the Mirror(MirrorDirection, Boolean) method is called.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.IsMirroredVertically Property

AnnotationDataIsMirroredVertically Property

Gets a value indicating whether the annotation is mirrored vertically.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMirroredVertically { get; }
Public ReadOnly Property IsMirroredVertically As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the annotation is mirrored vertically.
Remarks
Vertical mirroring occurs when resizing the annotation and dragging a grip past its opposite grip. This can also happen when the Mirror(MirrorDirection, Boolean) method is called.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Location Property

AnnotationDataLocation Property

Gets or sets the location of this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF Location { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property Location As PointF
    Get
    Set

Property Value

Type: PointF
The annotation location.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.ModifiedTime Property

AnnotationDataModifiedTime Property

Gets or sets the time in which this annotation was modified.
Gets or sets the last time this annotation was modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime ModifiedTime { get; set; }
Public Property ModifiedTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The last modified time.

Property Value

Type: DateTime
The last modified time.
Remarks
This value is updated when a property change is detected.
Remarks
This value is updated when a property change is detected.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Name Property

AnnotationDataName Property

Gets or sets a name for this annotation.
Gets or sets a name for this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
A name for this annotation.

Property Value

Type: String
A name for this annotation.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Rotation Property

AnnotationDataRotation Property

Gets or sets the current amount of rotation for this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Rotation { get; set; }
Public Property Rotation As Single
    Get
    Set

Property Value

Type: Single
The amount this annotation is rotated. Values should be from 0.0 to 259.99999: Values outside of this range will be automatically corrected.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Security Property

AnnotationDataSecurity Property

Gets or sets the security lock used for this annotation.
Gets or sets the security lock used for this annotation. This can be set to null (Nothing in VB).

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock Security { get; set; }
Public Property Security As IAnnotationLock
    Get
    Set

Property Value

Type: IAnnotationLock
The security lock used.

Property Value

Type: IAnnotationLock
The security lock used or null (Nothing in VB) if there is no security lock.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Selected Property

AnnotationDataSelected Property

Get or set whether this AnnotationData object is selected

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation is selected.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Size Property

AnnotationDataSize Property

Gets or sets the size of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(SizeFTypeConverter))]
public SizeF Size { get; set; }
<TypeConverterAttribute(GetType(SizeFTypeConverter))>
Public Property Size As SizeF
    Get
    Set

Property Value

Type: SizeF
The size of the annotation.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.State Property

AnnotationDataState Property

Get or set the AnnotationState of this AnnotationData object

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationState State { get; set; }
Public Property State As AnnotationState
    Get
    Set

Property Value

Type: AnnotationState
The current annotation state.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.ToolTip Property

AnnotationDataToolTip Property

Gets or sets the text displayed in the annotation tooltip.
Gets or sets the text displayed in the annotation tooltip.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set

Property Value

Type: String
Text used for the tooltip.

Property Value

Type: String
Text used for the tooltip.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Transform Property

AnnotationDataTransform Property

Gets the transformation matrix used for rendering this annotation.
Gets or sets the transformation matrix used for rendering this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix Transform { get; set; }
Public Property Transform As Matrix
    Get
    Set

Property Value

Type: Matrix
A transformation maxtrix used for rendering.

Property Value

Type: Matrix
A transformation matrix used for rendering.
Remarks

Each annotation has multiple matrices. The Transform property matrix is multiplied in after all others, allowing for a custom transform.

Note: The RotateDocument method applies a transform to this matrix.

See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.UserName Property

AnnotationDataUserName Property

Gets or sets the username for the annotation. Internally this is used with PDF annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set

Property Value

Type: String
The user that last modified the annotation.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Visible Property

AnnotationDataVisible Property

Gets or sets a value indicating if the annotation is visible.
Gets or sets a value indicating if the annotation is visible.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation is visible.

Property Value

Type: Boolean
Indicates if the annotation is visible.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData Methods

The AnnotationData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms.
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms.
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account.
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds.
 | Clone | Returns a copy of this annotation data.
 | CloneBaseData | Fills the data object with cloned property values.
Protected method | CloneBaseDataFrom | Clones the base data from.
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called to release resources used by the annotation.
Public method | Equals | Compares the current annotation with another. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Overrides ObjectFinalize.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties.
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String).
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.
 | GetObjectData | Fills the SerializationInfo object with properties values for the base AnnotationData class.
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically.
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed.
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed.
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed.
Protected method | OnCanResizeChanged | Called when the CanResize property has changed.
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed.
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed.
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed.
Protected method | OnLocationChanged | Called when the Location property value has changed.
Protected method | OnMirrored | Called when the annotation has been mirrored.
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed.
Protected method | OnNameChanged | Called when the Name property has changed.
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called just before a property value is changed.
Protected method | OnRotationChanged | Called when the Rotation property has changed.
Protected method | OnSecurityChanged | Called when the Security property has changed.
Protected method | OnSizeChanged | Called when the Size property has changed.
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event.
Protected method | OnTooltipChanged | Called when the ToolTip property has changed.
Protected method | OnTransformChanged | Called when the Transform property has changed.
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event.
Protected method | OnVisibleChanged | Called when the Visible property has changed.
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush.
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont.
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen.
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock.
Public method | Rotate | Applies rotation to the annotation from its current rotation amount.
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush.
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String).
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont.
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen.
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CalculateAnnotationBounds Method

AnnotationDataCalculateAnnotationBounds Method

Calculates the bounding rectangle of an annotation without applying the annotation transforms.
Overload List
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms.
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms.
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CalculateAnnotationBounds Method (AnnotationPen, AnnotationBrush, PointF)

AnnotationDataCalculateAnnotationBounds Method (AnnotationPen, AnnotationBrush, PointF)

This method will calculate the bounding rectangle without applying the annotation transforms.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF CalculateAnnotationBounds(
    AnnotationPen pen,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Protected Function CalculateAnnotationBounds (
    pen As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
) As RectangleF

Parameters

pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used by the annotation, if any.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the shadow, if any.
shadowOffset
Type: System.DrawingPointF
The position offset used for the shadow.

Return Value

Type: RectangleF
The bounding rectangle of the annotation without its transforms applied.
Remarks
To get the annotation bounds with its transforms applied, use the PointF method.
See Also

Reference

AnnotationData Class
CalculateAnnotationBounds Overload
Atalasoft.Annotate Namespace


AnnotationData.CalculateAnnotationBounds Method (RectangleF, AnnotationPen, AnnotationBrush, PointF)

AnnotationDataCalculateAnnotationBounds Method (RectangleF, AnnotationPen, AnnotationBrush, PointF)

This method will calculate the bounding rectangle without applying the annotation transforms.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF CalculateAnnotationBounds(
    RectangleF bounds,
    AnnotationPen pen,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Protected Function CalculateAnnotationBounds (
    bounds As RectangleF,
    pen As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
) As RectangleF

Parameters

bounds
Type: System.DrawingRectangleF
A bounding rectangle to which the pen and shadow will be applied.
pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used on this rectangle, if any.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the shadow of this rectangle, if any.
shadowOffset
Type: System.DrawingPointF
The position offset of the shadow.

Return Value

Type: RectangleF
The rectangle that includes the pen and shadow offsets.
See Also

Reference

AnnotationData Class
CalculateAnnotationBounds Overload
Atalasoft.Annotate Namespace


AnnotationData.CalculateBounds Method

AnnotationDataCalculateBounds Method

Calculates the bounding rectangle of an annotation.
Overload List
 | Name | Description
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account.
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds.
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CalculateBounds Method (AnnotationPen, AnnotationBrush, PointF)

AnnotationDataCalculateBounds Method (AnnotationPen, AnnotationBrush, PointF)

This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF CalculateBounds(
    AnnotationPen pen,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Protected Function CalculateBounds (
    pen As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
) As RectangleF

Parameters

pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used by the annotation, if any.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the shadow, if any.
shadowOffset
Type: System.DrawingPointF
The position offset used for the shadow.

Return Value

Type: RectangleF
The bounding rectangle of the annotation in document space.
Remarks
This method will apply the render transforms when calculating the bounds. Use the AnnotationBrush method to get the bounds without any transforms applied.
See Also

Reference

AnnotationData Class
CalculateBounds Overload
Atalasoft.Annotate Namespace


AnnotationData.CalculateBounds Method (RectangleF, AnnotationPen, AnnotationBrush, PointF)

AnnotationDataCalculateBounds Method (RectangleF, AnnotationPen, AnnotationBrush, PointF)

This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF CalculateBounds(
    RectangleF bounds,
    AnnotationPen pen,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Protected Function CalculateBounds (
    bounds As RectangleF,
    pen As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
) As RectangleF

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle to which the pen, shadow and transforms will be applied.
pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen being applied to the bounds.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the shadow.
shadowOffset
Type: System.DrawingPointF
The position offset used for the shadow.

Return Value

Type: RectangleF
The rectangle in document space.
Remarks
This method will apply the render transforms when calculating the bounds. Use the CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) method to get the bounds without any transforms applied.
See Also

Reference

AnnotationData Class
CalculateBounds Overload
Atalasoft.Annotate Namespace


AnnotationData.Clone Method

AnnotationDataClone Method

Returns a copy of this annotation data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object

Return Value

Type: Object
A copy of this data.

Implements

ICloneableClone
Examples
AnnotationData Class
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CloneBaseData Method

AnnotationDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void CloneBaseData(
    AnnotationData data
)
Protected Overridable Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CloneBaseDataFrom Method

AnnotationDataCloneBaseDataFrom Method

Clones the base data from.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void CloneBaseDataFrom(
    AnnotationData data
)
Protected Sub CloneBaseDataFrom (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The data.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Dispose Method

AnnotationDataDispose Method

These methods release resources used by the annotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called to release resources used by the annotation.
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Dispose Method

AnnotationDataDispose Method

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AnnotationData Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotationData.Dispose Method (Boolean)

AnnotationDataDispose Method (Boolean)

Called to release resources used by the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was called from the public Dispose method or the class finalizer.
See Also

Reference

AnnotationData Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotationData.Equals Method

AnnotationDataEquals Method

Compares the current annotation with another.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The object to compare against.

Return Value

Type: Boolean
Remarks
Some unique properties are not compared, such as Name, CreationTime and ModifiedTime. All other properties, including transforms used for rendering, are compared.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Finalize Method

AnnotationDataFinalize Method

Finalizes an instance of the AnnotationData class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.GetAllExtraProperties Method

AnnotationDataGetAllExtraProperties Method

Returns a Dictionary containing the key value pairs for extra properties.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Dictionary<string, string> GetAllExtraProperties()
Public Overridable Function GetAllExtraProperties As Dictionary(Of String, String)

Return Value

Type: Dictionary String, String
A Dictionary containing the key value pairs.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.GetExtraProperty Method

AnnotationDataGetExtraProperty Method

Returns the value stored with SetExtraProperty(String, String).

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetExtraProperty(
    string key
)
Public Overridable Function GetExtraProperty (
    key As String
) As String

Parameters

key
Type: SystemString
Key name of the value requested.

Return Value

Type: String
The object with the given key name, null if it doesn't exist.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
SetExtraProperty Method


AnnotationData.GetHashCode Method

AnnotationDataGetHashCode Method

Returns an identifier for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A value representing this object.
Remarks
This value is not guaranteed to be unique, but the same object instance will always return the same hash value.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.GetLineCapBounds Method

AnnotationDataGetLineCapBounds Method

Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual RectangleF GetLineCapBounds()
Protected Overridable Function GetLineCapBounds As RectangleF

Return Value

Type: RectangleF
The bounds for the line cap.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.GetObjectData Method

AnnotationDataGetObjectData Method

Fills the SerializationInfo object with properties values for the base AnnotationData class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Examples
AnnotationData Class
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.GetRenderTransform Method

AnnotationDataGetRenderTransform Method

Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix GetRenderTransform()
Public Function GetRenderTransform As Matrix

Return Value

Type: Matrix
A Matrix containing all of the matrices applied to the annotation.
Remarks

Internally several matrices are used to hold the position, rotation and mirroring of the annotation. This method will return a single Matrix combining these matrices along with the public Transform property.

This Matrix should be disposed when finished working with it.

See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Mirror Method

AnnotationDataMirror Method

Flips (mirrors) the annotation horizontally or vertically.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Mirror(
    MirrorDirection direction,
    bool maintainPosition
)
Public Overridable Sub Mirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The direction to mirror the annotation.
maintainPosition
Type: SystemBoolean
Determines whether the mirror is performed in place or if the annotation pivots along its location.
Remarks
If the maintainPosition argument is true, the location of the annotation will be changed.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnAnnotationControllerNotification Method

AnnotationDataOnAnnotationControllerNotification Method

Called after a property value has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information about this change.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnCanMirrorChanged Method

AnnotationDataOnCanMirrorChanged Method

Called when the CanMirror property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCanMirrorChanged(
    EventArgs e
)
Protected Overridable Sub OnCanMirrorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnCanMoveChanged Method

AnnotationDataOnCanMoveChanged Method

Called when the CanMove property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCanMoveChanged(
    EventArgs e
)
Protected Overridable Sub OnCanMoveChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnCanResizeChanged Method

AnnotationDataOnCanResizeChanged Method

Called when the CanResize property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCanResizeChanged(
    EventArgs e
)
Protected Overridable Sub OnCanResizeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnCanRotateChanged Method

AnnotationDataOnCanRotateChanged Method

Called when the CanRotate property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCanRotateChanged(
    EventArgs e
)
Protected Overridable Sub OnCanRotateChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnCanSelectChanged Method

AnnotationDataOnCanSelectChanged Method

Called when the CanSelect property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCanSelectChanged(
    EventArgs e
)
Protected Overridable Sub OnCanSelectChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnCreationTimeChanged Method

AnnotationDataOnCreationTimeChanged Method

Called when the CreationTime property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCreationTimeChanged(
    EventArgs e
)
Protected Overridable Sub OnCreationTimeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnLocationChanged Method

AnnotationDataOnLocationChanged Method

Called when the Location property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnLocationChanged(
    AnnotationLocationChangedEventArgs e
)
Protected Overridable Sub OnLocationChanged (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
An AnnotationLocationChangedEventArgs containing information about this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnMirrored Method

AnnotationDataOnMirrored Method

Called when the annotation has been mirrored.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMirrored(
    MirrorEventArgs e
)
Protected Overridable Sub OnMirrored (
    e As MirrorEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateMirrorEventArgs
A MirrorEventArgs containing information about this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnModifiedTimeChanged Method

AnnotationDataOnModifiedTimeChanged Method

Called when the ModifiedTime property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnModifiedTimeChanged(
    EventArgs e
)
Protected Overridable Sub OnModifiedTimeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnNameChanged Method

AnnotationDataOnNameChanged Method

Called when the Name property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnNameChanged(
    EventArgs e
)
Protected Overridable Sub OnNameChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnPropertyChanged Method

AnnotationDataOnPropertyChanged Method

Called when a property has been changed and raises the PropertyChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationLocationChangedEventArgs containing information for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnPropertyChanging Method

AnnotationDataOnPropertyChanging Method

Called just before a property value is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs containing information about this change.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnRotationChanged Method

AnnotationDataOnRotationChanged Method

Called when the Rotation property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotationChanged(
    EventArgs e
)
Protected Overridable Sub OnRotationChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnSecurityChanged Method

AnnotationDataOnSecurityChanged Method

Called when the Security property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSecurityChanged(
    EventArgs e
)
Protected Overridable Sub OnSecurityChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnSizeChanged Method

AnnotationDataOnSizeChanged Method

Called when the Size property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
An AnnotationSizeChangedEventArgs containing information about this change.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnStateChanged Method

AnnotationDataOnStateChanged Method

Called when the State property has changed and raises the StateChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnStateChanged(
    EventArgs e
)
Protected Overridable Sub OnStateChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs passed to the StateChanged event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnTooltipChanged Method

AnnotationDataOnTooltipChanged Method

Called when the ToolTip property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnTooltipChanged(
    EventArgs e
)
Protected Overridable Sub OnTooltipChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnTransformChanged Method

AnnotationDataOnTransformChanged Method

Called when the Transform property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnTransformChanged(
    EventArgs e
)
Protected Overridable Sub OnTransformChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnUserNameChanged Method

AnnotationDataOnUserNameChanged Method

Called when the UserName property has changed and raises the UserNameChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnUserNameChanged(
    EventArgs e
)
Protected Overridable Sub OnUserNameChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs passed to the UserNameChanged event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.OnVisibleChanged Method

AnnotationDataOnVisibleChanged Method

Called when the Visible property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnVisibleChanged(
    EventArgs e
)
Protected Overridable Sub OnVisibleChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.RemoveBrushEvents Method

AnnotationDataRemoveBrushEvents Method

This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RemoveBrushEvents(
    AnnotationBrush brush
)
Protected Sub RemoveBrushEvents (
    brush As AnnotationBrush
)

Parameters

brush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush to remove event handlers from.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
SetBrushEvents Method


AnnotationData.RemoveFontEvents Method

AnnotationDataRemoveFontEvents Method

This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RemoveFontEvents(
    AnnotationFont font
)
Protected Sub RemoveFontEvents (
    font As AnnotationFont
)

Parameters

font
Type: Atalasoft.AnnotateAnnotationFont
The font to remove events from.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
SetFontEvents Method


AnnotationData.RemovePenEvents Method

AnnotationDataRemovePenEvents Method

This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RemovePenEvents(
    AnnotationPen pen
)
Protected Sub RemovePenEvents (
    pen As AnnotationPen
)

Parameters

pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen to remove the event handlers from.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
SetPenEvents Method


AnnotationData.RemoveSecurityEvents Method

AnnotationDataRemoveSecurityEvents Method

This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RemoveSecurityEvents(
    IAnnotationLock security
)
Protected Sub RemoveSecurityEvents (
    security As IAnnotationLock
)

Parameters

security
Type: Atalasoft.AnnotateIAnnotationLock
The class implementing IAnnotationLock that will have event handlers removed.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
SetSecurityEvents Method


AnnotationData.Rotate Method

AnnotationDataRotate Method

Applies rotation to the annotation from its current rotation amount.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Rotate(
    float degrees
)
Public Overridable Sub Rotate (
    degrees As Single
)

Parameters

degrees
Type: SystemSingle
The amount of rotation being added to this annotation.
Remarks
This method will add additional rotation to an annotation. To set the annotation rotation to a specific amount, set the Rotation property.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.SetBrushEvents Method

AnnotationDataSetBrushEvents Method

This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetBrushEvents(
    AnnotationBrush brush
)
Protected Sub SetBrushEvents (
    brush As AnnotationBrush
)

Parameters

brush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush to set event handlers for.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
RemoveBrushEvents Method


AnnotationData.SetExtraProperty Method

AnnotationDataSetExtraProperty Method

Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String).

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void SetExtraProperty(
    string key,
    string val
)
Public Overridable Sub SetExtraProperty (
    key As String,
    val As String
)

Parameters

key
Type: SystemString
Key name of the property to be set to.
val
Type: SystemString
Object value of the property being set.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
AnnotationDataGetExtraProperty(String)


AnnotationData.SetFontEvents Method

AnnotationDataSetFontEvents Method

This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetFontEvents(
    AnnotationFont font
)
Protected Sub SetFontEvents (
    font As AnnotationFont
)

Parameters

font
Type: Atalasoft.AnnotateAnnotationFont
The AnnotationFont to set event handlers for.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
RemoveFontEvents Method


AnnotationData.SetPenEvents Method

AnnotationDataSetPenEvents Method

This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetPenEvents(
    AnnotationPen pen
)
Protected Sub SetPenEvents (
    pen As AnnotationPen
)

Parameters

pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen to set event handlers for.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
RemovePenEvents Method


AnnotationData.SetSecurityEvents Method

AnnotationDataSetSecurityEvents Method

This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetSecurityEvents(
    IAnnotationLock security
)
Protected Sub SetSecurityEvents (
    security As IAnnotationLock
)

Parameters

security
Type: Atalasoft.AnnotateIAnnotationLock
The class implementing IAnnotationLock to set event handlers for.
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace
RemoveSecurityEvents Method


AnnotationData Events

The AnnotationData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed.
Public event | CanMirrorChanged | Raised when the CanMirror property is changed.
Public event | CanMoveChanged | Raised when the CanMove property is changed.
Public event | CanResizeChanged | Raised when the CanResize property has changed.
Public event | CanRotateChanged | Raised when the CanRotate property has changed.
Public event | CanSelectChanged | Raised when the CanSelect property has changed.
Public event | CreationTimeChanged | Raised when the CreationTime property has changed.
Public event | LocationChanged | Raised when the Location property has changed.
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called.
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed.
Public event | NameChanged | Raised when the Name property has changed.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised before a property is changed.
Public event | RotationChanged | Raised when the Rotation property has changed.
Public event | SecurityChanged | Raised when the Security property has changed.
Public event | SizeChanged | Raised when the Size property has changed.
Public event | StateChanged | This event is raised when the State property value has changed.
Public event | TooltipChanged | Raised when the ToolTip property has changed.
Public event | TransformChanged | Raised when the Transform property has changed.
Public event | UserNameChanged | This event is raised when the UserName property has changed.
Public event | VisibleChanged | Raised when the Visible property has changed.
Top
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.AnnotationControllerNotification Event

AnnotationDataAnnotationControllerNotification Event

Raised after a property has been changed.
Raised after a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanMirrorChanged Event

AnnotationDataCanMirrorChanged Event

Raised when the CanMirror property is changed.
Raised when the CanMirror property is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CanMirrorChanged
Public Event CanMirrorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanMoveChanged Event

AnnotationDataCanMoveChanged Event

Raised when the CanMove property is changed.
Raised when the CanMove property is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CanMoveChanged
Public Event CanMoveChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanResizeChanged Event

AnnotationDataCanResizeChanged Event

Raised when the CanResize property has changed.
Raised when the CanResize property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CanResizeChanged
Public Event CanResizeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanRotateChanged Event

AnnotationDataCanRotateChanged Event

Raised when the CanRotate property has changed.
Raised when the CanRotate property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CanRotateChanged
Public Event CanRotateChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CanSelectChanged Event

AnnotationDataCanSelectChanged Event

Raised when the CanSelect property has changed.
Raised when the CanSelect property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CanSelectChanged
Public Event CanSelectChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.CreationTimeChanged Event

AnnotationDataCreationTimeChanged Event

Raised when the CreationTime property has changed.
Raised when the CreationTime property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CreationTimeChanged
Public Event CreationTimeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.LocationChanged Event

AnnotationDataLocationChanged Event

Raised when the Location property has changed.
Raised when the Location property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationLocationChangedEventHandler LocationChanged
Public Event LocationChanged As AnnotationLocationChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationLocationChangedEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.Mirrored Event

AnnotationDataMirrored Event

Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called.
Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror(MirrorDirection, Boolean) method is called.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MirrorEventHandler Mirrored
Public Event Mirrored As MirrorEventHandler

Value

Type: Atalasoft.AnnotateMirrorEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.ModifiedTimeChanged Event

AnnotationDataModifiedTimeChanged Event

Raised when the ModifiedTime property has changed.
Raised when the ModifiedTime property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ModifiedTimeChanged
Public Event ModifiedTimeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.NameChanged Event

AnnotationDataNameChanged Event

Raised when the Name property has changed.
Raised when the Name property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler NameChanged
Public Event NameChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.PropertyChanged Event

AnnotationDataPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.PropertyChanging Event

AnnotationDataPropertyChanging Event

Raised before a property is changed.
Raised before a property is changed, allowing the changed value to be modified or canceled.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.RotationChanged Event

AnnotationDataRotationChanged Event

Raised when the Rotation property has changed.
Raised when the Rotation property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler RotationChanged
Public Event RotationChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.SecurityChanged Event

AnnotationDataSecurityChanged Event

Raised when the Security property has changed.
Raised when the Security property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SecurityChanged
Public Event SecurityChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.SizeChanged Event

AnnotationDataSizeChanged Event

Raised when the Size property has changed.
Raised when the Size property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationSizeChangedEventHandler SizeChanged
Public Event SizeChanged As AnnotationSizeChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationSizeChangedEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.StateChanged Event

AnnotationDataStateChanged Event

This event is raised when the State property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler StateChanged
Public Event StateChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.TooltipChanged Event

AnnotationDataTooltipChanged Event

Raised when the ToolTip property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler TooltipChanged
Public Event TooltipChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.TransformChanged Event

AnnotationDataTransformChanged Event

Raised when the Transform property has changed.
Raised when the Transform property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler TransformChanged
Public Event TransformChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.UserNameChanged Event

AnnotationDataUserNameChanged Event

This event is raised when the UserName property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationData.VisibleChanged Event

AnnotationDataVisibleChanged Event

Raised when the Visible property has changed.
Raised when the Visible property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationData Class
Atalasoft.Annotate Namespace


AnnotationDataCollection Class

This class can be used to hold a collection of AnnotationData objects.
This class can be used to hold a collection of AnnotationData objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.AnnotateAnnotationDataCollection

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AnnotationDataCollection : CollectionBase,
    ISerializable, ICloneable, IDeserializationCallback
<SerializableAttribute>
Public Class AnnotationDataCollection
    Inherits CollectionBase
    Implements ISerializable, ICloneable, IDeserializationCallback

The AnnotationDataCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataCollection | Creates a new instance of AnnotationDataCollection.
Public method | AnnotationDataCollection(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationDataCollection from serialized information.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets an AnnotationData object form the collection at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an AnnotationData object to the collection.
Public method | AddRange | Adds an array of AnnotationData objects to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone | Create a copy of the AnnotationDataCollection.
Public method | Contains | Determines whether the AnnotationDataCollection contains the specified element
Public method | CopyTo | Copies items into the specified array.
Public method | Equals | Compares one collection to another to see if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with serialized data for this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of an item in the collection.
Public method | Insert | Inserts an AnnotationData object into the collection at a specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Called when the Clear method has been invoked. (Overrides CollectionBaseOnClear.)
Protected method | OnClearComplete | Called when the collection is cleared. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnCollectionChanged | Called when there is a change in the collection.
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Called when an add or insert has completed. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Called when a remove has completed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Called when a set has completed. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes an AnnotationData object from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised when the annotation sends a notification to the AnnotationController.
Public event | CollectionChanged | Raised when the collection has changed.
Public event | PropertyChanging | Raised before a property is changed.
Top
Remarks
The LayerData object uses this class to hold the AnnotationData for the layer. In most cases there is no need to create an instance of this class.
Remarks
The LayerData object makes use of this class to hold the AnnotationData for the layer. In most cases there is no need to create an instance of this class.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationDataCollection Constructor

Constructs an AnnotationDataCollection.
Overload List
 | Name | Description
Public method | AnnotationDataCollection | Creates a new instance of AnnotationDataCollection.
Public method | AnnotationDataCollection(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationDataCollection from serialized information.
Top
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection Constructor

Creates a new instance of AnnotationDataCollection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataCollection()
Public Sub New
See Also

Reference

AnnotationDataCollection Class
AnnotationDataCollection Overload
Atalasoft.Annotate Namespace


AnnotationDataCollection Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationDataCollection from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataCollection(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that contains information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info parameter is null.
See Also

Reference

AnnotationDataCollection Class
AnnotationDataCollection Overload
Atalasoft.Annotate Namespace


AnnotationDataCollection Properties

The AnnotationDataCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets an AnnotationData object form the collection at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Item Property

AnnotationDataCollectionItem Property

Gets an AnnotationData object form the collection at the specified index.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As AnnotationData
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to retrieve.

Property Value

Type: AnnotationData
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index parameter is out of range for this collection.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection Methods

The AnnotationDataCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an AnnotationData object to the collection.
Public method | AddRange | Adds an array of AnnotationData objects to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone | Create a copy of the AnnotationDataCollection.
Public method | Contains | Determines whether the AnnotationDataCollection contains the specified element
Public method | CopyTo | Copies items into the specified array.
Public method | Equals | Compares one collection to another to see if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with serialized data for this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of an item in the collection.
Public method | Insert | Inserts an AnnotationData object into the collection at a specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Called when the Clear method has been invoked. (Overrides CollectionBaseOnClear.)
Protected method | OnClearComplete | Called when the collection is cleared. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnCollectionChanged | Called when there is a change in the collection.
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Called when an add or insert has completed. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Called when a remove has completed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Called when a set has completed. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes an AnnotationData object from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Add Method

AnnotationDataCollectionAdd Method

Adds an AnnotationData object to the collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AnnotationData data
)
Public Sub Add (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The class derived from AnnotationData to add.
Exceptions
Exception | Condition
 | Thrown if the data parameter is null.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.AddRange Method

AnnotationDataCollectionAddRange Method

Adds an array of AnnotationData objects to the collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    AnnotationData[] data
)
Public Sub AddRange (
    data As AnnotationData()
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
An array of AnnotationData objects to add.
Exceptions
Exception | Condition
 | Thrown if the data parameter is null or zero length.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Clone Method

AnnotationDataCollectionClone Method

Create a copy of the AnnotationDataCollection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
An AnnotationDataCollection containing a clone of every AnnotationData object.

Implements

ICloneableClone
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Contains Method

AnnotationDataCollectionContains Method

Determines whether the AnnotationDataCollection contains the specified element

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    AnnotationData data
)
Public Function Contains (
    data As AnnotationData
) As Boolean

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The element to locate in the CollectionBase

Return Value

Type: Boolean
true if the AnnotationDataCollection contains the specified value; otherwise, false.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.CopyTo Method

AnnotationDataCollectionCopyTo Method

Copies items into the specified array.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    AnnotationData[] array,
    int index
)
Public Sub CopyTo (
    array As AnnotationData(),
    index As Integer
)

Parameters

array
Type: Atalasoft.AnnotateAnnotationData
The array to copy items into.
index
Type: SystemInt32
The index of the target array to being copying.
Exceptions
Exception | Condition
 | Thrown if the array is null (Nothing in VB).
 | Thrown if the index is invalid.
 | Thrown if the array is not large enough to perform this task.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Equals Method

AnnotationDataCollectionEquals Method

Compares one collection to another to see if they are equal.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AnnotationDataCollection being compared to.

Return Value

Type: Boolean
True if the collections hold equal data.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.GetHashCode Method

AnnotationDataCollectionGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.GetObjectData Method

AnnotationDataCollectionGetObjectData Method

Fills a SerializationInfo object with serialized data for this collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info parameter is null.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.IndexOf Method

AnnotationDataCollectionIndexOf Method

Returns the index of an item in the collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    AnnotationData data
)
Public Function IndexOf (
    data As AnnotationData
) As Integer

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The item to search for.

Return Value

Type: Int32
The index of the item or -1 if the item does not exist in the collection.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Insert Method

AnnotationDataCollectionInsert Method

Inserts an AnnotationData object into the collection at a specified index.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AnnotationData data
)
Public Sub Insert (
    index As Integer,
    data As AnnotationData
)

Parameters

index
Type: SystemInt32
The position within the collection to place this object.
data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object to insert.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data parameter is null.
ArgumentOutOfRangeException | Thrown if the index parameter if out of range for this collection.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnClear Method

AnnotationDataCollectionOnClear Method

Called when the Clear method has been invoked.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClear()
Protected Overrides Sub OnClear
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnClearComplete Method

AnnotationDataCollectionOnClearComplete Method

Called when the collection is cleared.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnCollectionChanged Method

AnnotationDataCollectionOnCollectionChanged Method

Called when there is a change in the collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnCollectionChanged(
    CollectionChangedEventArgs args
)
Protected Sub OnCollectionChanged (
    args As CollectionChangedEventArgs
)

Parameters

args
Type: Atalasoft.UtilsCollectionChangedEventArgs
An CollectionChangedEventArgs containing information about the change.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnDeserialization Method

AnnotationDataCollectionOnDeserialization Method

Called after an object has been fully deserialized by a serialization formatter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
This parameter is not used and will be null (Nothing in VB).

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnInsertComplete Method

AnnotationDataCollectionOnInsertComplete Method

Called when an add or insert has completed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index in the collection where the item was placed.
value
Type: SystemObject
The object that was added to the collection.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnRemoveComplete Method

AnnotationDataCollectionOnRemoveComplete Method

Called when a remove has completed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the item that was removed.
value
Type: SystemObject
The object that was removed.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.OnSetComplete Method

AnnotationDataCollectionOnSetComplete Method

Called when a set has completed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The index in the collection where the item was changed.
oldValue
Type: SystemObject
The previous object at the specified index.
newValue
Type: SystemObject
The new object at the specified index.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.Remove Method

AnnotationDataCollectionRemove Method

Removes an AnnotationData object from the collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AnnotationData data
)
Public Sub Remove (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The object to remove.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data parameter is null.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection Events

The AnnotationDataCollection type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised when the annotation sends a notification to the AnnotationController.
Public event | CollectionChanged | Raised when the collection has changed.
Public event | PropertyChanging | Raised before a property is changed.
Top
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.AnnotationControllerNotification Event

AnnotationDataCollectionAnnotationControllerNotification Event

Raised when the annotation sends a notification to the AnnotationController.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.CollectionChanged Event

AnnotationDataCollectionCollectionChanged Event

Raised when the collection has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As CollectionChangedEventHandler

Value

Type: Atalasoft.UtilsCollectionChangedEventHandler
Remarks
This event will be raised when items are added, inserted and removed.
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection.PropertyChanging Event

AnnotationDataCollectionPropertyChanging Event

Raised before a property is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
See Also

Reference

AnnotationDataCollection Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T) Class

AnnotationDataCollectionT Class

This class can be used to hold a collection of AnnotationData objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
Atalasoft.AnnotateAnnotationDataCollectionT

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDataCollection<T> : Collection<T>,
    ICloneable, IDeserializationCallback
where T : AnnotationData

Public Class AnnotationDataCollection(Of T As AnnotationData)
    Inherits Collection(Of T)
    Implements ICloneable, IDeserializationCallback

Type Parameters

T

The AnnotationDataCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataCollectionT | Creates a new instance of AnnotationDataCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides CollectionTClearItems.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Called when there is a change in the collection.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed.
Public event | CollectionChanged | Raised when the collection has changed.
Public event | PropertyChanging | Raised before a property is changed.
Top
Remarks
The LayerData object makes use of this class to hold the AnnotationData for the layer. In most cases there is no need to create an instance of this class.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationDataCollection(T) Constructor

AnnotationDataCollectionT Constructor

Creates a new instance of AnnotationDataCollection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataCollection()
Public Sub New
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T) Properties

AnnotationDataCollectionT Properties

The AnnotationDataCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Top
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T) Methods

AnnotationDataCollectionT Methods

The AnnotationDataCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides CollectionTClearItems.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Called when there is a change in the collection.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).ClearItems Method

AnnotationDataCollectionTClearItems Method

Removes all elements from the CollectionT.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).Clone Method

AnnotationDataCollectionTClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).InsertItem Method

AnnotationDataCollectionTInsertItem Method

Inserts an element into the CollectionT at the specified index.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentNullException | item
ArgumentOutOfRangeException | index;Invalid index for this collection.
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).OnCollectionChanged Method

AnnotationDataCollectionTOnCollectionChanged Method

Called when there is a change in the collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnCollectionChanged(
    CollectionChangedEventArgs args
)
Protected Sub OnCollectionChanged (
    args As CollectionChangedEventArgs
)

Parameters

args
Type: Atalasoft.UtilsCollectionChangedEventArgs
An Atalasoft.Utils.CollectionChangedEventArgs containing information about the change.
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).OnDeserialization Method

AnnotationDataCollectionTOnDeserialization Method

Runs when the entire object graph has been deserialized.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
The object that initiated the callback. The functionality for this parameter is not currently implemented.

Implements

IDeserializationCallbackOnDeserialization(Object)
Exceptions
Exception | Condition
SerializationException | Invalid object passed into the AnnotationDataCollection.
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).RemoveItem Method

AnnotationDataCollectionTRemoveItem Method

Removes the element at the specified index of the CollectionT.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).SetItem Method

AnnotationDataCollectionTSetItem Method

Replaces the element at the specified index.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentNullException | item
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T) Events

AnnotationDataCollectionT Events

The AnnotationDataCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed.
Public event | CollectionChanged | Raised when the collection has changed.
Public event | PropertyChanging | Raised before a property is changed.
Top
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).AnnotationControllerNotification Event

AnnotationDataCollectionTAnnotationControllerNotification Event

Raised after a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).CollectionChanged Event

AnnotationDataCollectionTCollectionChanged Event

Raised when the collection has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As CollectionChangedEventHandler

Value

Type: Atalasoft.UtilsCollectionChangedEventHandler
Remarks
This event will be raised when items are added, inserted and removed.
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataCollection(T).PropertyChanging Event

AnnotationDataCollectionTPropertyChanging Event

Raised before a property is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
See Also

Reference

AnnotationDataCollectionT Class
Atalasoft.Annotate Namespace


AnnotationDataFormat Enumeration

Specifies the format used for serialized annotation data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationDataFormat
Public Enumeration AnnotationDataFormat
Members
Member name | Description
Xmp | The data is serialized using the XmpFormatter.
Wang | The data is serialized using the WangFormatter.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationEventArgs Class

This class provides information for events that involve an annotation.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateAnnotationEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationEventArgs : EventArgs
Public Class AnnotationEventArgs
    Inherits EventArgs

The AnnotationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationEventArgs | Creates a new instance of AnnotationEventArgs.
Top
Properties
 | Name | Description
Public property | Annotation | Gets the annotation this event relates to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationEventArgs Constructor

Creates a new instance of AnnotationEventArgs.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationEventArgs(
    AnnotationUI annotation
)
Public Sub New (
    annotation As AnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation this event relates to.
See Also

Reference

AnnotationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationEventArgs Properties

The AnnotationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Annotation | Gets the annotation this event relates to.
Top
See Also

Reference

AnnotationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationEventArgs.Annotation Property

AnnotationEventArgsAnnotation Property

Gets the annotation this event relates to.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI Annotation { get; }
Public ReadOnly Property Annotation As AnnotationUI
    Get

Property Value

Type: AnnotationUI
The annotation for this event.
See Also

Reference

AnnotationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationEventArgs Methods

The AnnotationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationEventArgs Class
Atalasoft.Annotate Namespace


AnnotationEventHandler Delegate

This delegate is used for various events that apply to an annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationEventHandler(
    Object sender,
    AnnotationEventArgs e
)
Public Delegate Sub AnnotationEventHandler (
    sender As Object,
    e As AnnotationEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation for the event.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationFont Class

This class represents a font used with annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationFont

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class AnnotationFont : ISerializable
<SerializableAttribute>
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class AnnotationFont
    Implements ISerializable

The AnnotationFont type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationFont | Creates a new instance of AnnotationFont of type Arial and size 12.
Public method | AnnotationFont(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationFont from serialized data.
Public method | AnnotationFont(String, Single) | Creates a new instance of AnnotationFont specifying the font name and size.
Public method | AnnotationFont(String, Single, Boolean, Boolean, Boolean, Boolean) | Creates a new instance of AnnotationFont specifying the font parameters.
Top
Properties
 | Name | Description
Public property | Bold | Gets or sets a value indicating whether the font is bold.
Public property | CharSet | Gets or sets the character set for this font.
Public property | CheckFontAvailability |
Public property | Italic | Gets or sets a value indicating whether the font is italic.
Public property | Name | Gets or sets the name of the font.
Public property | Size | Gets or sets the size of the font in points.
Public property | Strikeout | Gets or sets a value indicating whether the font has a strikeout.
Public property | Underline | Gets or sets a value indicating whether the font is underlined.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationFont.
Public method | Equals | Compares the AnnotationFont with another to see if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this AnnotationFont.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called to notify the AnnotationController about a property change.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property has been changed.
Public method | ToString | Returns a string representation of this object. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationFont is modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
Fields
Name | Description
FallbackFontName | The FallbackFontName is used when a deserialized or requested font does not exist on the system.
Top
Examples
The following example prepares an AnnotationViewer to create a new TextAnnotation with a Times New Roman font.
C#
VB
Copy
AnnotationFont font = new AnnotationFont("Times New Roman", 16);
TextAnnotation txt = new TextAnnotation("My New TextAnnotation", font);
this.annotateViewer1.Annotations.CreateAnnotation(txt);
Dim font As AnnotationFont =  New AnnotationFont("Times New Roman",16)
Dim txt As TextAnnotation =  New TextAnnotation("My New TextAnnotation",font)
Me.annotateViewer1.Annotations.CreateAnnotation(txt)
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationFont Constructor

Constructs an AnnotationFont.
Overload List
 | Name | Description
Public method | AnnotationFont | Creates a new instance of AnnotationFont of type Arial and size 12.
Public method | AnnotationFont(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationFont from serialized data.
Public method | AnnotationFont(String, Single) | Creates a new instance of AnnotationFont specifying the font name and size.
Public method | AnnotationFont(String, Single, Boolean, Boolean, Boolean, Boolean) | Creates a new instance of AnnotationFont specifying the font parameters.
Top
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont Constructor

Creates a new instance of AnnotationFont of type Arial and size 12.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont()
Public Sub New
See Also

Reference

AnnotationFont Class
AnnotationFont Overload
Atalasoft.Annotate Namespace


AnnotationFont Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationFont from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing font data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the 'info' argument is null (Nothing in VB).
See Also

Reference

AnnotationFont Class
AnnotationFont Overload
Atalasoft.Annotate Namespace


AnnotationFont Constructor (String, Single)

Creates a new instance of AnnotationFont specifying the font name and size.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont(
    string fontName,
    float size
)
Public Sub New (
    fontName As String,
    size As Single
)

Parameters

fontName
Type: SystemString
The name of the font.
size
Type: SystemSingle
The size of the font.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the 'fontName' is null (Nothing in VB) or an empty string.
ArgumentOutOfRangeException | Thrown if the 'size' argument is less than or equal to 0.
See Also

Reference

AnnotationFont Class
AnnotationFont Overload
Atalasoft.Annotate Namespace


AnnotationFont Constructor (String, Single, Boolean, Boolean, Boolean, Boolean)

Creates a new instance of AnnotationFont specifying the font parameters.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont(
    string fontName,
    float size,
    bool bold,
    bool italic,
    bool underline,
    bool strikeout
)
Public Sub New (
    fontName As String,
    size As Single,
    bold As Boolean,
    italic As Boolean,
    underline As Boolean,
    strikeout As Boolean
)

Parameters

fontName
Type: SystemString
The name of the font.
size
Type: SystemSingle
The size of the font.
bold
Type: SystemBoolean
Indicates if this font is bold.
italic
Type: SystemBoolean
Indicates if this font is italic.
underline
Type: SystemBoolean
Indicates if this font is underlined.
strikeout
Type: SystemBoolean
Indicates if this font has a strikeout.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the 'fontName' argument is null (Nothing in VB) or an empty string.
ArgumentOutOfRangeException | Thrown if the 'size' argument is less than or equal to 0.
See Also

Reference

AnnotationFont Class
AnnotationFont Overload
Atalasoft.Annotate Namespace


AnnotationFont Properties

The AnnotationFont type exposes the following members.

Properties
 | Name | Description
Public property | Bold | Gets or sets a value indicating whether the font is bold.
Public property | CharSet | Gets or sets the character set for this font.
Public property | CheckFontAvailability |
Public property | Italic | Gets or sets a value indicating whether the font is italic.
Public property | Name | Gets or sets the name of the font.
Public property | Size | Gets or sets the size of the font in points.
Public property | Strikeout | Gets or sets a value indicating whether the font has a strikeout.
Public property | Underline | Gets or sets a value indicating whether the font is underlined.
Top
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Bold Property

AnnotationFontBold Property

Gets or sets a value indicating whether the font is bold.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Bold { get; set; }
Public Property Bold As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the font is bold type.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.CharSet Property

AnnotationFontCharSet Property

Gets or sets the character set for this font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CharSet { get; set; }
Public Property CharSet As Integer
    Get
    Set

Property Value

Type: Int32
The font character set.
Remarks
This property takes a value from the list defined in the platform SDK header file WinGDI.h. The default value is zero, which will use the system's default character set.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.CheckFontAvailability Property

AnnotationFontCheckFontAvailability Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CheckFontAvailability { get; set; }
Public Property CheckFontAvailability As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Italic Property

AnnotationFontItalic Property

Gets or sets a value indicating whether the font is italic.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Italic { get; set; }
Public Property Italic As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the font is italic type.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Name Property

AnnotationFontName Property

Gets or sets the name of the font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

The font name, such as "Arial" or "Times New Roman".

See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Size Property

AnnotationFontSize Property

Gets or sets the size of the font in points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Size { get; set; }
Public Property Size As Single
    Get
    Set

Property Value

Type: Single
The point size of the font.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Strikeout Property

AnnotationFontStrikeout Property

Gets or sets a value indicating whether the font has a strikeout.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Strikeout { get; set; }
Public Property Strikeout As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the font has a strikeout (line through it).
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Underline Property

AnnotationFontUnderline Property

Gets or sets a value indicating whether the font is underlined.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Underline { get; set; }
Public Property Underline As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the font is underlined.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont Methods

The AnnotationFont type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationFont.
Public method | Equals | Compares the AnnotationFont with another to see if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this AnnotationFont.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called to notify the AnnotationController about a property change.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property has been changed.
Public method | ToString | Returns a string representation of this object. (Overrides ObjectToString.)
Top
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Clone Method

AnnotationFontClone Method

Creates a copy of this AnnotationFont.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Clone()
Public Function Clone As AnnotationFont

Return Value

Type: AnnotationFont
A clone of this object.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.Equals Method

AnnotationFontEquals Method

Compares the AnnotationFont with another to see if they are equal.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AnnotationFont to compare against.

Return Value

Type: Boolean
True if they are equal.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.GetHashCode Method

AnnotationFontGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.GetObjectData Method

AnnotationFontGetObjectData Method

Fills a SerializationInfo object with information about this AnnotationFont.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object where data will be filled.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the 'info' object is null (Nothing in VB).
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.OnAnnotationControllerNotification Method

AnnotationFontOnAnnotationControllerNotification Method

Called to notify the AnnotationController about a property change.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs specifying the property that was modified.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.OnPropertyChanged Method

AnnotationFontOnPropertyChanged Method

Called when a property value has changed and raises the PropertyChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationLocationChangedEventArgs containing information for this event.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.OnPropertyChanging Method

AnnotationFontOnPropertyChanging Method

Called before a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs specifying the property that is being modified.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.ToString Method

AnnotationFontToString Method

Returns a string representation of this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string containing the font name, size and attributes.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont Events

The AnnotationFont type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationFont is modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.AnnotationControllerNotification Event

AnnotationFontAnnotationControllerNotification Event

Raised after a property of the AnnotationFont is modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.PropertyChanged Event

AnnotationFontPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.PropertyChanging Event

AnnotationFontPropertyChanging Event

Raised just before a property is about to be modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont Fields

The AnnotationFont type exposes the following members.

Fields
Name | Description
FallbackFontName | The FallbackFontName is used when a deserialized or requested font does not exist on the system.
Top
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationFont.FallbackFontName Field

AnnotationFontFallbackFontName Field

The FallbackFontName is used when a deserialized or requested font does not exist on the system.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string FallbackFontName
Public Shared FallbackFontName As String

Field Value

Type: String
The font used as a fallback when a deserialized font does not exist on the system.
Remarks
If FallbackFontName is null (Nothing in VB) the System.Drawing.FontFamily.GenericSansSerif font will be used.
See Also

Reference

AnnotationFont Class
Atalasoft.Annotate Namespace


AnnotationGripAction Enumeration

Specifies the action that will be taken by the AnnotationController when a grip is dragged with the mouse.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationGripAction
Public Enumeration AnnotationGripAction
Members
Member name | Description
Resizing | The grip is used to resize the annotation.
Moving | The grip is used to move the annotation.
Rotating | The grip is used for rotating the annotation.
Indepenent | Obsolete. The grip is used for custom movement determined by the annotation.
Independent | The grip is used for custom movement determined by the annotation.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationGripMode Enumeration

Specifies the type of grips being used for an annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationGripMode
Public Enumeration AnnotationGripMode
Members
Member name | Description
Rectangular | Rectangle grips are used.
Points | Point grips are used.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationGripState Enumeration

Specifies the state of a grip.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationGripState
Public Enumeration AnnotationGripState
Members
Member name | Description
Default | The grip is shown normally.
MouseOver | The mouse is over the grip.
MouseDown | The mouse is pressing the grip.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationImage Class

This class represents an image object used by AnnotationBrush and EmbeddedImageData classes.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationImage

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(AnnotationImageConverter))]
public class AnnotationImage : ISerializable,
    IDisposable
<SerializableAttribute>
<TypeConverterAttribute(GetType(AnnotationImageConverter))>
Public Class AnnotationImage
    Implements ISerializable, IDisposable

The AnnotationImage type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationImage | Creates a new empty instance of AnnotationImage.
Public method | AnnotationImage(Image) | Creates a new instance of AnnotationImage specifying the System.Drawing.Image object used.
Public method | AnnotationImage(Stream) | Creates a new instance of AnnotationImage from the specified stream.
Public method | AnnotationImage(String) | Creates a new instance of AnnotationImage from the specified file.
Public method | AnnotationImage(AtalaImage) | Creates a new instance of AnnotationImage specifying the Atalasoft.Imaging.AtalaImage object used.
Public method | AnnotationImage(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationImage from serialized data.
Public method | AnnotationImage(Int32, Int32, Int32, Byte) | Creates a new instance of AnnotationImage specifying the width, height, bit count and image data.
Public method | AnnotationImage(Int32, Int32, Int32, Byte, Byte) | Creates a new instance of AnnotationImage specifying the width, height, bit count, image and palette data.
Public method | AnnotationImage(Int32, Int32, Int32, Byte, Byte, Single, Single) | Creates a new instance of AnnotationImage specifying the image properties.
Top
Properties
 | Name | Description
Public property | BitCount | Gets the bit count (or bits-per-pixel) of the image.
Public property | Disposed | Gets a value indicating whether this object has been disposed.
Public property | DpiX | Gets the horizontal resolution of the image.
Public property | DpiY | Gets the vertical resolution of the image.
Public property | Height | Gets the height of the image in pixels.
Public property | ImageData | Gets the image data.
Public property | ImageObject | Gets the actual image object for this AnnotationImage.
Public property | Palette | Gets the image palette, if any.
Public property | Width | Gets the width of the image in pixels.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationImage.
Public method | Dispose | Releases resources used by this class.
Protected method | Dispose(Boolean) | Releases resources used by this class.
Public method | Equals | Compares this AnnotationImage with another to see if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationImage class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with image data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreateImageObject | Called when the ImageObject property is being requested.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

The properties of this class describe the image data, allowing the image data to be read by any application into a format it requires.

The ImageObject property is used to store the actual image created from these property values. Our default implementation will create a System.Drawing.Imaging.Image object. Inheritors should override the OnCreateImageObject method to generate the image object.

See Also

Reference

Atalasoft.Annotate Namespace


AnnotationImage Constructor

Constructs an AnnotationImage.
Overload List
 | Name | Description
Public method | AnnotationImage | Creates a new empty instance of AnnotationImage.
Public method | AnnotationImage(Image) | Creates a new instance of AnnotationImage specifying the System.Drawing.Image object used.
Public method | AnnotationImage(Stream) | Creates a new instance of AnnotationImage from the specified stream.
Public method | AnnotationImage(String) | Creates a new instance of AnnotationImage from the specified file.
Public method | AnnotationImage(AtalaImage) | Creates a new instance of AnnotationImage specifying the Atalasoft.Imaging.AtalaImage object used.
Public method | AnnotationImage(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationImage from serialized data.
Public method | AnnotationImage(Int32, Int32, Int32, Byte) | Creates a new instance of AnnotationImage specifying the width, height, bit count and image data.
Public method | AnnotationImage(Int32, Int32, Int32, Byte, Byte) | Creates a new instance of AnnotationImage specifying the width, height, bit count, image and palette data.
Public method | AnnotationImage(Int32, Int32, Int32, Byte, Byte, Single, Single) | Creates a new instance of AnnotationImage specifying the image properties.
Top
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage Constructor

Creates a new empty instance of AnnotationImage.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage()
Public Sub New
Remarks
This constructor should only be used by inheritors that require custom image data.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (Image)

Creates a new instance of AnnotationImage specifying the System.Drawing.Image object used.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    Image image
)
Public Sub New (
    image As Image
)

Parameters

image
Type: System.DrawingImage
A System.Drawing.Image object for this class.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (Stream)

Creates a new instance of AnnotationImage from the specified stream.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing the image to load.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (String)

Creates a new instance of AnnotationImage from the specified file.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The filename of the image to load.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (AtalaImage)

Creates a new instance of AnnotationImage specifying the Atalasoft.Imaging.AtalaImage object used.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
A Atalasoft.Imaging.AtalaImage object for this class.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationImage from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing AnnotationImage information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (Int32, Int32, Int32, Byte[])

AnnotationImage Constructor (Int32, Int32, Int32, Byte)

Creates a new instance of AnnotationImage specifying the width, height, bit count and image data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    int width,
    int height,
    int bitCount,
    byte[] imageData
)
Public Sub New (
    width As Integer,
    height As Integer,
    bitCount As Integer,
    imageData As Byte()
)

Parameters

width
Type: SystemInt32
The width of the image.
height
Type: SystemInt32
The height of the image.
bitCount
Type: SystemInt32
The bit count of the image.
imageData
Type: SystemByte
A byte array containing the image data.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (Int32, Int32, Int32, Byte[], Byte[])

AnnotationImage Constructor (Int32, Int32, Int32, Byte, Byte)

Creates a new instance of AnnotationImage specifying the width, height, bit count, image and palette data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    int width,
    int height,
    int bitCount,
    byte[] imageData,
    byte[] palette
)
Public Sub New (
    width As Integer,
    height As Integer,
    bitCount As Integer,
    imageData As Byte(),
    palette As Byte()
)

Parameters

width
Type: SystemInt32
The width of the image.
height
Type: SystemInt32
The height of the image.
bitCount
Type: SystemInt32
The bit count of the image.
imageData
Type: SystemByte
A byte array containing the image data.
palette
Type: SystemByte
A byte array containing the palette data.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Constructor (Int32, Int32, Int32, Byte[], Byte[], Single, Single)

AnnotationImage Constructor (Int32, Int32, Int32, Byte, Byte, Single, Single)

Creates a new instance of AnnotationImage specifying the image properties.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage(
    int width,
    int height,
    int bitCount,
    byte[] imageData,
    byte[] palette,
    float dpiX,
    float dpiY
)
Public Sub New (
    width As Integer,
    height As Integer,
    bitCount As Integer,
    imageData As Byte(),
    palette As Byte(),
    dpiX As Single,
    dpiY As Single
)

Parameters

width
Type: SystemInt32
The width of the image.
height
Type: SystemInt32

The height of the image.

bitCount
Type: SystemInt32
The bit count of the image.
imageData
Type: SystemByte
A byte array containing the image data.
palette
Type: SystemByte
A byte array containing the palette data or null if a palette is not required.
dpiX
Type: SystemSingle
The horizontal resolution of the image.
dpiY
Type: SystemSingle
The vertical resolution of the image.
See Also

Reference

AnnotationImage Class
AnnotationImage Overload
Atalasoft.Annotate Namespace


AnnotationImage Properties

The AnnotationImage type exposes the following members.

Properties
 | Name | Description
Public property | BitCount | Gets the bit count (or bits-per-pixel) of the image.
Public property | Disposed | Gets a value indicating whether this object has been disposed.
Public property | DpiX | Gets the horizontal resolution of the image.
Public property | DpiY | Gets the vertical resolution of the image.
Public property | Height | Gets the height of the image in pixels.
Public property | ImageData | Gets the image data.
Public property | ImageObject | Gets the actual image object for this AnnotationImage.
Public property | Palette | Gets the image palette, if any.
Public property | Width | Gets the width of the image in pixels.
Top
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.BitCount Property

AnnotationImageBitCount Property

Gets the bit count (or bits-per-pixel) of the image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BitCount { get; }
Public ReadOnly Property BitCount As Integer
    Get

Property Value

Type: Int32
The image bit count.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Disposed Property

AnnotationImageDisposed Property

Gets a value indicating whether this object has been disposed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Disposed { get; }
Public ReadOnly Property Disposed As Boolean
    Get

Property Value

Type: Boolean
True if this object has been disposed.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.DpiX Property

AnnotationImageDpiX Property

Gets the horizontal resolution of the image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float DpiX { get; }
Public ReadOnly Property DpiX As Single
    Get

Property Value

Type: Single
The horizontal resolution in dots-per-inch.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.DpiY Property

AnnotationImageDpiY Property

Gets the vertical resolution of the image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float DpiY { get; }
Public ReadOnly Property DpiY As Single
    Get

Property Value

Type: Single
The vertical resolution in dots-per-inch.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Height Property

AnnotationImageHeight Property

Gets the height of the image in pixels.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
The image height in pixels.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.ImageData Property

AnnotationImageImageData Property

Gets the image data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ImageData { get; }
Public ReadOnly Property ImageData As Byte()
    Get

Property Value

Type: Byte
A byte array containing the raw image data.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.ImageObject Property

AnnotationImageImageObject Property

Gets the actual image object for this AnnotationImage.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object ImageObject { get; }
Public ReadOnly Property ImageObject As Object
    Get

Property Value

Type: Object
The image object. The DotImage implementation returns a System.Drawing.Image object.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Palette Property

AnnotationImagePalette Property

Gets the image palette, if any.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Palette { get; }
Public ReadOnly Property Palette As Byte()
    Get

Property Value

Type: Byte
A byte array containing the image palette data or null if there is no palette.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Width Property

AnnotationImageWidth Property

Gets the width of the image in pixels.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
The image width in pixels.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage Methods

The AnnotationImage type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationImage.
Public method | Dispose | Releases resources used by this class.
Protected method | Dispose(Boolean) | Releases resources used by this class.
Public method | Equals | Compares this AnnotationImage with another to see if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationImage class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with image data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreateImageObject | Called when the ImageObject property is being requested.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Clone Method

AnnotationImageClone Method

Creates a copy of this AnnotationImage.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AnnotationImage Clone()
Public Overridable Function Clone As AnnotationImage

Return Value

Type: AnnotationImage
A copy of this image.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Dispose Method

AnnotationImageDispose Method

Releases resources used by this class.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by this class.
Protected method | Dispose(Boolean) | Releases resources used by this class.
Top
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Dispose Method

AnnotationImageDispose Method

Releases resources used by this class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Dispose()
Public Overridable Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AnnotationImage Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotationImage.Dispose Method (Boolean)

AnnotationImageDispose Method (Boolean)

Releases resources used by this class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

AnnotationImage Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotationImage.Equals Method

AnnotationImageEquals Method

Compares this AnnotationImage with another to see if they are equal.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AnnotationImage to compare against.

Return Value

Type: Boolean
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.Finalize Method

AnnotationImageFinalize Method

Finalizes an instance of the AnnotationImage class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.GetHashCode Method

AnnotationImageGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.GetObjectData Method

AnnotationImageGetObjectData Method

Fills a SerializationInfo object with image data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where data will the stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this image.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationImage.OnCreateImageObject Method

AnnotationImageOnCreateImageObject Method

Called when the ImageObject property is being requested.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object OnCreateImageObject()
Protected Overridable Function OnCreateImageObject As Object

Return Value

Type: Object
The object that will be set for the ImageObject property.
Remarks
This method will only be called if the ImageObject is null.
See Also

Reference

AnnotationImage Class
Atalasoft.Annotate Namespace


AnnotationLineCap Class

This class is used to define a line cap used for AnnotationPen objects.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationLineCap

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AnnotationLineCap : ISerializable
<SerializableAttribute>
Public Class AnnotationLineCap
    Implements ISerializable

The AnnotationLineCap type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationLineCap | Creates a new instance of AnnotationLineCap.
Public method | AnnotationLineCap(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationLineCap from serialized information.
Public method | AnnotationLineCap(AnnotationLineCapStyle, SizeF) | Creates a new instance of AnnotationLineCap specifying the style and size.
Top
Properties
 | Name | Description
Public property | RenderOffset | Gets the offset from the line point to the top-left of the bounding rectangle for the line cap.
Public property | Size | Gets or sets the size of the line cap.
Public property | Style | Gets or sets the style of the line cap.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationLineCap.
Public method | Equals | Compares one AnnotationLineCap with another to determine of that contain the same property values. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills the SerializationInfo object with properties values for the AnnoationLineCap class.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LineCapSizeFromString | Converts the string representation of the annotation cap size, which are used by JavaScript on client part, to the numerical values used by AnnotationLineCap class.
 | LineCapSizeToString | Converts the annotation cap size to the string representation, which are used by JavaScript on client part
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called when a notification is being sent to the AnnotationController.
Protected method | OnPropertyChanged | Called when a property value has changed.
Protected method | OnPropertyChanging | Called when a property value changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised when a notification must be sent to the AnnotationController.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised when a property value has changed.
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationLineCap Constructor

Constructs an AnnotationLineCap.
Overload List
 | Name | Description
Public method | AnnotationLineCap | Creates a new instance of AnnotationLineCap.
Public method | AnnotationLineCap(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationLineCap from serialized information.
Public method | AnnotationLineCap(AnnotationLineCapStyle, SizeF) | Creates a new instance of AnnotationLineCap specifying the style and size.
Top
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap Constructor

Creates a new instance of AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLineCap()
Public Sub New
See Also

Reference

AnnotationLineCap Class
AnnotationLineCap Overload
Atalasoft.Annotate Namespace


AnnotationLineCap Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationLineCap from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLineCap(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

AnnotationLineCap Class
AnnotationLineCap Overload
Atalasoft.Annotate Namespace


AnnotationLineCap Constructor (AnnotationLineCapStyle, SizeF)

Creates a new instance of AnnotationLineCap specifying the style and size.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLineCap(
    AnnotationLineCapStyle style,
    SizeF size
)
Public Sub New (
    style As AnnotationLineCapStyle,
    size As SizeF
)

Parameters

style
Type: Atalasoft.AnnotateAnnotationLineCapStyle
The style of the line cap.
size
Type: System.DrawingSizeF
The size of the line cap.
See Also

Reference

AnnotationLineCap Class
AnnotationLineCap Overload
Atalasoft.Annotate Namespace


AnnotationLineCap Properties

The AnnotationLineCap type exposes the following members.

Properties
 | Name | Description
Public property | RenderOffset | Gets the offset from the line point to the top-left of the bounding rectangle for the line cap.
Public property | Size | Gets or sets the size of the line cap.
Public property | Style | Gets or sets the style of the line cap.
Top
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.RenderOffset Property

AnnotationLineCapRenderOffset Property

Gets the offset from the line point to the top-left of the bounding rectangle for the line cap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF RenderOffset { get; }
Public ReadOnly Property RenderOffset As PointF
    Get

Property Value

Type: PointF
The offset of the bounding rectangle from the line cap position.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.Size Property

AnnotationLineCapSize Property

Gets or sets the size of the line cap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(SizeFTypeConverter))]
public SizeF Size { get; set; }
<TypeConverterAttribute(GetType(SizeFTypeConverter))>
Public Property Size As SizeF
    Get
    Set

Property Value

Type: SizeF
The size of the line cap.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.Style Property

AnnotationLineCapStyle Property

Gets or sets the style of the line cap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLineCapStyle Style { get; set; }
Public Property Style As AnnotationLineCapStyle
    Get
    Set

Property Value

Type: AnnotationLineCapStyle
The style of the line cap.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap Methods

The AnnotationLineCap type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationLineCap.
Public method | Equals | Compares one AnnotationLineCap with another to determine of that contain the same property values. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills the SerializationInfo object with properties values for the AnnoationLineCap class.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LineCapSizeFromString | Converts the string representation of the annotation cap size, which are used by JavaScript on client part, to the numerical values used by AnnotationLineCap class.
 | LineCapSizeToString | Converts the annotation cap size to the string representation, which are used by JavaScript on client part
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called when a notification is being sent to the AnnotationController.
Protected method | OnPropertyChanged | Called when a property value has changed.
Protected method | OnPropertyChanging | Called when a property value changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.Clone Method

AnnotationLineCapClone Method

Creates a copy of this AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLineCap Clone()
Public Function Clone As AnnotationLineCap

Return Value

Type: AnnotationLineCap
A copy of the AnnotationLineCap.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.Equals Method

AnnotationLineCapEquals Method

Compares one AnnotationLineCap with another to determine of that contain the same property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AnnotationLineCap to compare against.

Return Value

Type: Boolean
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.GetHashCode Method

AnnotationLineCapGetHashCode Method

Returns an identifier for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A value representing this object.
Remarks
This value is not guaranteed to be unique, but the same object instance will always return the same hash value.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.GetObjectData Method

AnnotationLineCapGetObjectData Method

Fills the SerializationInfo object with properties values for the AnnoationLineCap class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.LineCapSizeFromString Method

AnnotationLineCapLineCapSizeFromString Method

Converts the string representation of the annotation cap size, which are used by JavaScript on client part, to the numerical values used by AnnotationLineCap class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static SizeF LineCapSizeFromString(
    AnnotationLineCapStyle style,
    string width,
    string height,
    float lineCapWidth
)
Public Shared Function LineCapSizeFromString (
    style As AnnotationLineCapStyle,
    width As String,
    height As String,
    lineCapWidth As Single
) As SizeF

Parameters

style
Type: Atalasoft.AnnotateAnnotationLineCapStyle
The style of the line cap.
width
Type: SystemString
The string describing the cap width. Valid values are: narrow, medium, wide.
height
Type: SystemString
The string describing the cap height. Valid values are: short, medium, long.
lineCapWidth
Type: SystemSingle
The width of line.

Return Value

Type: SizeF
Numerical values that can be used by AnnotationLineCap class.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.LineCapSizeToString Method

AnnotationLineCapLineCapSizeToString Method

Converts the annotation cap size to the string representation, which are used by JavaScript on client part

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationLineCapStringSizes LineCapSizeToString(
    AnnotationLineCapStyle style,
    SizeF capSize,
    float lineWidth,
    bool legacy = false
)
Public Shared Function LineCapSizeToString (
    style As AnnotationLineCapStyle,
    capSize As SizeF,
    lineWidth As Single,
    Optional legacy As Boolean = false
) As AnnotationLineCapStringSizes

Parameters

style
Type: Atalasoft.AnnotateAnnotationLineCapStyle
The style of the line cap.
capSize
Type: System.DrawingSizeF
The size of line cap.
lineWidth
Type: SystemSingle
legacy (Optional)
Type: SystemBoolean
Determine if legacy algorithm should be used. Default: false

Return Value

Type: AnnotationLineCapStringSizes
Structure that contains a string representation of cap size
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.OnAnnotationControllerNotification Method

AnnotationLineCapOnAnnotationControllerNotification Method

Called when a notification is being sent to the AnnotationController.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information for this event.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.OnPropertyChanged Method

AnnotationLineCapOnPropertyChanged Method

Called when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationPropertyChangedEventArgs containing information about this change.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.OnPropertyChanging Method

AnnotationLineCapOnPropertyChanging Method

Called when a property value changes.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs containing information about the changed property.
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap Events

The AnnotationLineCap type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised when a notification must be sent to the AnnotationController.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised when a property value has changed.
Top
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.AnnotationControllerNotification Event

AnnotationLineCapAnnotationControllerNotification Event

Raised when a notification must be sent to the AnnotationController.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.PropertyChanged Event

AnnotationLineCapPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.PropertyChanging Event

AnnotationLineCapPropertyChanging Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
See Also

Reference

AnnotationLineCap Class
Atalasoft.Annotate Namespace


AnnotationLineCap.StringSizes Structure

AnnotationLineCapStringSizes Structure

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public struct StringSizes
Public Structure StringSizes

The AnnotationLineCapStringSizes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Height |
Public field | Width |
Top
See Also

Reference

Atalasoft.Annotate Namespace


StringSizes Methods

The AnnotationLineCapStringSizes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

AnnotationLineCapStringSizes Structure
Atalasoft.Annotate Namespace


StringSizes Fields

The AnnotationLineCapStringSizes type exposes the following members.

Fields
 | Name | Description
Public field | Height |
Public field | Width |
Top
See Also

Reference

AnnotationLineCapStringSizes Structure
Atalasoft.Annotate Namespace


AnnotationLineCap.StringSizes.Height Field

AnnotationLineCapStringSizesHeight Field

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Height
Public Height As String

Field Value

Type: String
See Also

Reference

AnnotationLineCapStringSizes Structure
Atalasoft.Annotate Namespace


AnnotationLineCap.StringSizes.Width Field

AnnotationLineCapStringSizesWidth Field

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Width
Public Width As String

Field Value

Type: String
See Also

Reference

AnnotationLineCapStringSizes Structure
Atalasoft.Annotate Namespace


AnnotationLineCapStyle Enumeration

Specifies the type of line cap for a AnnotationLineCap object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationLineCapStyle
Public Enumeration AnnotationLineCapStyle
Members
Member name | Description
None | No line cap is drawn.
Arrow | A simple thin line arrow.
FilledArrow | A filled arrow.
ClosedArrow | A closed arrow that is not filled.
Ellipse | An ellipse is drawn.
FilledEllipse | A filled ellipse is drawn.
Rectangle | A rectangle is drawn.
FilledRectangle | A filled rectangle is drawn.
Diamond | A diamond is drawn.
FilledDiamond | A filled diamond is drawn.
ReversedArrow | An arrow pointing in toward the line is drawn
ReversedClosedArrow | A closed arrow pointing in toward the line is drawn
ReversedFilledArrow | A filled, closed array is drawn pointing in toward the line is drawn
Butt | A line perpendicular to the line is drawn
Slash | A hash line is drawn
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationLocationChangedEventArgs Class

This class is used to hold information for the LocationChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateAnnotationLocationChangedEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationLocationChangedEventArgs : EventArgs
Public Class AnnotationLocationChangedEventArgs
    Inherits EventArgs

The AnnotationLocationChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationLocationChangedEventArgs | Creates a new instance of AnnotationLocationChangedEventArgs.
Top
Properties
 | Name | Description
Public property | NewLocation | Gets the new location of the annotation.
Public property | OldLocation | Gets the previous location of the annotation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationLocationChangedEventArgs Constructor

Creates a new instance of AnnotationLocationChangedEventArgs.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLocationChangedEventArgs(
    PointF oldLocation,
    PointF newLocation
)
Public Sub New (
    oldLocation As PointF,
    newLocation As PointF
)

Parameters

oldLocation
Type: System.DrawingPointF
The previous location of the annotation.
newLocation
Type: System.DrawingPointF
The new location of the annotation.
See Also

Reference

AnnotationLocationChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationLocationChangedEventArgs Properties

The AnnotationLocationChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewLocation | Gets the new location of the annotation.
Public property | OldLocation | Gets the previous location of the annotation.
Top
See Also

Reference

AnnotationLocationChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationLocationChangedEventArgs.NewLocation Property

AnnotationLocationChangedEventArgsNewLocation Property

Gets the new location of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF NewLocation { get; }
Public ReadOnly Property NewLocation As PointF
    Get

Property Value

Type: PointF
The new location.
See Also

Reference

AnnotationLocationChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationLocationChangedEventArgs.OldLocation Property

AnnotationLocationChangedEventArgsOldLocation Property

Gets the previous location of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF OldLocation { get; }
Public ReadOnly Property OldLocation As PointF
    Get

Property Value

Type: PointF
The previous annotation location.
See Also

Reference

AnnotationLocationChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationLocationChangedEventArgs Methods

The AnnotationLocationChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationLocationChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationLocationChangedEventHandler Delegate

This delegate is used for the LocationChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationLocationChangedEventHandler(
    Object sender,
    AnnotationLocationChangedEventArgs e
)
Public Delegate Sub AnnotationLocationChangedEventHandler (
    sender As Object,
    e As AnnotationLocationChangedEventArgs
)

Parameters

sender
Type: SystemObject
The annotation sending this event.
e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
An AnnotationLocationChangedEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationLock Class

This class is the default security used for annotations. It uses simple string encryption to secure annotations and keep users from being able to modify the data.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationLock

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AnnotationLock : IAnnotationLock,
    ISerializable
<SerializableAttribute>
Public Class AnnotationLock
    Implements IAnnotationLock, ISerializable

The AnnotationLock type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationLock | Creates a new instance of AnnotationLock.
Public method | AnnotationLock(String) | Creates a new instance of AnnotationLock whose key is the given string value
Public method | AnnotationLock(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationLock from serialized data.
Top
Properties
 | Name | Description
Public property | EncryptionKey | Gets the encrypted key for the lock.
Public property | Locked | Gets a value indicating whether or not the annotation is currently locked.
Public property | LockedImage | Gets or sets the image displayed on the annotation when it's been locked.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this lock.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with AnnotationLock information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Lock | Locks the annotation without specifying a password.
Public method | Lock(String) | Locks the annotation using the specified password.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called to notify the AnnotationController after a property has been changed.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property has been changed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unlock | This method will disable the lock on a locked annotation.
Public method | Unlock(String) | This method will disable the lock on an annotation that was previously locked with a password.
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
Remarks
For more security a custom class can be created by implementing the IAnnotationLock interface.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationLock Constructor

Constructs an AnnotationLock.
Overload List
 | Name | Description
Public method | AnnotationLock | Creates a new instance of AnnotationLock.
Public method | AnnotationLock(String) | Creates a new instance of AnnotationLock whose key is the given string value
Public method | AnnotationLock(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationLock from serialized data.
Top
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock Constructor

Creates a new instance of AnnotationLock.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLock()
Public Sub New
See Also

Reference

AnnotationLock Class
AnnotationLock Overload
Atalasoft.Annotate Namespace


AnnotationLock Constructor (String)

Creates a new instance of AnnotationLock whose key is the given string value

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLock(
    string encryptedKey
)
Public Sub New (
    encryptedKey As String
)

Parameters

encryptedKey
Type: SystemString
The key used for the lock encryption.
See Also

Reference

AnnotationLock Class
AnnotationLock Overload
Atalasoft.Annotate Namespace


AnnotationLock Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationLock from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationLock(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo containing the serialized data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

AnnotationLock Class
AnnotationLock Overload
Atalasoft.Annotate Namespace


AnnotationLock Properties

The AnnotationLock type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKey | Gets the encrypted key for the lock.
Public property | Locked | Gets a value indicating whether or not the annotation is currently locked.
Public property | LockedImage | Gets or sets the image displayed on the annotation when it's been locked.
Top
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.EncryptionKey Property

AnnotationLockEncryptionKey Property

Gets the encrypted key for the lock.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EncryptionKey { get; }
Public ReadOnly Property EncryptionKey As String
    Get

Property Value

Type: String
The encryption key.

Implements

IAnnotationLockEncryptionKey
Remarks
This key is stored into the serialized annotation data to allow the annotations to remain locked when deserialized at a later time.
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.Locked Property

AnnotationLockLocked Property

Gets a value indicating whether or not the annotation is currently locked.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Locked { get; }
Public ReadOnly Property Locked As Boolean
    Get

Property Value

Type: Boolean
A value indicating the lock status.

Implements

IAnnotationLockLocked
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.LockedImage Property

AnnotationLockLockedImage Property

Gets or sets the image displayed on the annotation when it's been locked.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage LockedImage { get; set; }
Public Property LockedImage As AnnotationImage
    Get
    Set

Property Value

Type: AnnotationImage
The image displayed when the annotation is locked.

Implements

IAnnotationLockLockedImage
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock Methods

The AnnotationLock type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this lock.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with AnnotationLock information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Lock | Locks the annotation without specifying a password.
Public method | Lock(String) | Locks the annotation using the specified password.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called to notify the AnnotationController after a property has been changed.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property has been changed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unlock | This method will disable the lock on a locked annotation.
Public method | Unlock(String) | This method will disable the lock on an annotation that was previously locked with a password.
Top
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.Clone Method

AnnotationLockClone Method

Creates a copy of this lock.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock Clone()
Public Function Clone As IAnnotationLock

Return Value

Type: IAnnotationLock
A copy of this AnnotationLock.

Implements

IAnnotationLockClone
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.GetObjectData Method

AnnotationLockGetObjectData Method

Fills a SerializationInfo object with AnnotationLock information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.Lock Method

AnnotationLockLock Method

Overload List
 | Name | Description
Public method | Lock | Locks the annotation without specifying a password.
Public method | Lock(String) | Locks the annotation using the specified password.
Top
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.Lock Method

AnnotationLockLock Method

Locks the annotation without specifying a password.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Lock()
Public Sub Lock

Implements

IAnnotationLockLock
Remarks
Use this method when an annotation needs to be locked to prevent users from modifying it rather than for security reasons. Use the Unlock method to disable the lock.
See Also

Reference

AnnotationLock Class
Lock Overload
Atalasoft.Annotate Namespace


AnnotationLock.Lock Method (String)

AnnotationLockLock Method (String)

Locks the annotation using the specified password.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Lock(
    string password
)
Public Sub Lock (
    password As String
)

Parameters

password
Type: SystemString
The password used to generate the EncryptionKey.

Return Value

Type:
Use the Unlock method with the same password to disable the lock.

Implements

IAnnotationLockLock(String)
See Also

Reference

AnnotationLock Class
Lock Overload
Atalasoft.Annotate Namespace


AnnotationLock.OnAnnotationControllerNotification Method

AnnotationLockOnAnnotationControllerNotification Method

Called to notify the AnnotationController after a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs specifying the property that was modified.
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.OnPropertyChanged Method

AnnotationLockOnPropertyChanged Method

Called when a property value has changed and raises the PropertyChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationLocationChangedEventArgs containing information for this event.
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.OnPropertyChanging Method

AnnotationLockOnPropertyChanging Method

Called before a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs specifying the property that is being modified.
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.Unlock Method

AnnotationLockUnlock Method

Overload List
 | Name | Description
Public method | Unlock | This method will disable the lock on a locked annotation.
Public method | Unlock(String) | This method will disable the lock on an annotation that was previously locked with a password.
Top
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.Unlock Method

AnnotationLockUnlock Method

This method will disable the lock on a locked annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Unlock()
Public Function Unlock As Boolean

Return Value

Type: Boolean
True if the annotation was unlocked.

Implements

IAnnotationLockUnlock
Remarks
The annotation must have been locked without a password for this method to disable the lock. If a password was used the overload for this method that takes a password must be used.
See Also

Reference

AnnotationLock Class
Unlock Overload
Atalasoft.Annotate Namespace


AnnotationLock.Unlock Method (String)

AnnotationLockUnlock Method (String)

This method will disable the lock on an annotation that was previously locked with a password.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Unlock(
    string password
)
Public Function Unlock (
    password As String
) As Boolean

Parameters

password
Type: SystemString
The password required to unlock the annotation. This must be the same password used with the Lock method.

Return Value

Type: Boolean

Implements

IAnnotationLockUnlock(String)
See Also

Reference

AnnotationLock Class
Unlock Overload
Atalasoft.Annotate Namespace


AnnotationLock Events

The AnnotationLock type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.AnnotationControllerNotification Event

AnnotationLockAnnotationControllerNotification Event

Raised after a property of the AnnotationBrush if modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler

Implements

IAnnotationLockAnnotationControllerNotification
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.PropertyChanged Event

AnnotationLockPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler

Implements

IAnnotationLockPropertyChanged
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationLock.PropertyChanging Event

AnnotationLockPropertyChanging Event

Raised just before a property is about to be modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler

Implements

IAnnotationLockPropertyChanging
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationLock Class
Atalasoft.Annotate Namespace


AnnotationPen Class

This class represents a pen object used for drawing lines of annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationPen

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(AnnotationPenConverter))]
public class AnnotationPen : ISerializable
<SerializableAttribute>
<TypeConverterAttribute(GetType(AnnotationPenConverter))>
Public Class AnnotationPen
    Implements ISerializable

The AnnotationPen type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPen(Color) | Creates a new instance of AnnotationPen specifying the color of the pen.
Public method | AnnotationPen(AnnotationBrush) | Creates a new instance of AnnotationPen from an AnnotationBrush object.
Public method | AnnotationPen(Color, Single) | Creates a new instance of AnnotationPen specifying the color and width of the pen.
Public method | AnnotationPen(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationPen from serialized data.
Public method | AnnotationPen(AnnotationBrush, Single) | Creates a new instance of AnnotationPen specifying the AnnotationBrush and pen width.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the AnnotationPenAlignment for the pen.
Public property | Brush | Gets or sets the AnnotationBrush used to describe this pen.
Public property | Color | Gets or sets the color for the pen.
Public property | DashCap | Gets or sets the DashCap used at the end of the dashes that make up dashed lines drawn with this pen.
Public property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Public property | DashPattern | Gets or sets the dash pattern used
Public property | DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
Public property | EndCap | Gets or sets the AnnotationLineCap used at the end of lines drawn with this pen.
Public property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
Public property | MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Public property | StartCap | Gets or sets the AnnotationLineCap used at the beginning of lines drawn with this pen.
Public property | Width | Gets or sets the width of the pen.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationPen.
Public method | Equals | Compares this AnnotationPen with another to test if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this AnnotationPen.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called to notify the AnnotationController after a property has been changed.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property is changed.
Protected method | RemoveLineCapEvents | This is a helper method used to remove event handler for an AnnotationLineCap object.
Protected method | SetLineCapEvents | This is a helper method used to add event handling to an AnnotationLineCap.
Public method | ToString | Returns a string representation of this object. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
Remarks
The IAnnotationRenderer for each annotation will use this information to construct a pen or equivalent for the drawing environment of its choice.
Examples
The code below creates a RectangleAnnotation with a black 1 pixel border.
CreateRectAnn
Copy
RectangleAnnotation rect = new RectangleAnnotation(RectangleF.Empty, new AnnotationBrush(Color.Red), new AnnotationPen(Color.Black, 1));
((RectangleGrips)rect.Grips).GripsToDisplay = RectangleGripDisplay.Both;
this.annotateViewer1.Annotations.CreateAnnotation(rect);
CreateRectAnn
Copy
Dim rect As RectangleAnnotation =  New RectangleAnnotation(RectangleF.Empty,New AnnotationBrush(Color.Red),New AnnotationPen(Color.Black,1))
((RectangleGrips)rect.Grips).GripsToDisplay = RectangleGripDisplay.Both
Me.annotateViewer1.Annotations.CreateAnnotation(rect)
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationPen Constructor

Constructs an AnnotationPen.
Overload List
 | Name | Description
Public method | AnnotationPen(Color) | Creates a new instance of AnnotationPen specifying the color of the pen.
Public method | AnnotationPen(AnnotationBrush) | Creates a new instance of AnnotationPen from an AnnotationBrush object.
Public method | AnnotationPen(Color, Single) | Creates a new instance of AnnotationPen specifying the color and width of the pen.
Public method | AnnotationPen(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationPen from serialized data.
Public method | AnnotationPen(AnnotationBrush, Single) | Creates a new instance of AnnotationPen specifying the AnnotationBrush and pen width.
Top
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen Constructor (Color)

Creates a new instance of AnnotationPen specifying the color of the pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor
The color for this pen.
Remarks
The AnnotationPen will have a width of 1 when no width if provided.
See Also

Reference

AnnotationPen Class
AnnotationPen Overload
Atalasoft.Annotate Namespace


AnnotationPen Constructor (AnnotationBrush)

Creates a new instance of AnnotationPen from an AnnotationBrush object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen(
    AnnotationBrush brush
)
Public Sub New (
    brush As AnnotationBrush
)

Parameters

brush
Type: Atalasoft.AnnotateAnnotationBrush
An AnnotationBrush used for the pen object.
Exceptions
Exception | Condition
 | Thrown if the brush parameter is null.
See Also

Reference

AnnotationPen Class
AnnotationPen Overload
Atalasoft.Annotate Namespace


AnnotationPen Constructor (Color, Single)

Creates a new instance of AnnotationPen specifying the color and width of the pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen(
    Color color,
    float width
)
Public Sub New (
    color As Color,
    width As Single
)

Parameters

color
Type: System.DrawingColor
The color for the pen.
width
Type: SystemSingle
The width of the pen. This value must be greater than zero.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the width parameter is not greater than zero.
See Also

Reference

AnnotationPen Class
AnnotationPen Overload
Atalasoft.Annotate Namespace


AnnotationPen Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationPen from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about the pen.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

AnnotationPen Class
AnnotationPen Overload
Atalasoft.Annotate Namespace


AnnotationPen Constructor (AnnotationBrush, Single)

Creates a new instance of AnnotationPen specifying the AnnotationBrush and pen width.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen(
    AnnotationBrush brush,
    float width
)
Public Sub New (
    brush As AnnotationBrush,
    width As Single
)

Parameters

brush
Type: Atalasoft.AnnotateAnnotationBrush
An AnnotationBrush used for the pen object.
width
Type: SystemSingle
The width of the pen. This value must be greater than zero.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the brush parameter is null.
ArgumentOutOfRangeException | Thrown if the width parameter is not greater than zero.
See Also

Reference

AnnotationPen Class
AnnotationPen Overload
Atalasoft.Annotate Namespace


AnnotationPen Properties

The AnnotationPen type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the AnnotationPenAlignment for the pen.
Public property | Brush | Gets or sets the AnnotationBrush used to describe this pen.
Public property | Color | Gets or sets the color for the pen.
Public property | DashCap | Gets or sets the DashCap used at the end of the dashes that make up dashed lines drawn with this pen.
Public property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Public property | DashPattern | Gets or sets the dash pattern used
Public property | DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
Public property | EndCap | Gets or sets the AnnotationLineCap used at the end of lines drawn with this pen.
Public property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
Public property | MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Public property | StartCap | Gets or sets the AnnotationLineCap used at the beginning of lines drawn with this pen.
Public property | Width | Gets or sets the width of the pen.
Top
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.Alignment Property

AnnotationPenAlignment Property

Gets or sets the AnnotationPenAlignment for the pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPenAlignment Alignment { get; set; }
Public Property Alignment As AnnotationPenAlignment
    Get
    Set

Property Value

Type: AnnotationPenAlignment
The pen alignment.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.Brush Property

AnnotationPenBrush Property

Gets or sets the AnnotationBrush used to describe this pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Brush { get; set; }
Public Property Brush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used by this pen.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.Color Property

AnnotationPenColor Property

Gets or sets the color for the pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The pen color.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.DashCap Property

AnnotationPenDashCap Property

Gets or sets the DashCap used at the end of the dashes that make up dashed lines drawn with this pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DashCap DashCap { get; set; }
Public Property DashCap As DashCap
    Get
    Set

Property Value

Type: DashCap
The pen dash cap.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.DashOffset Property

AnnotationPenDashOffset Property

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float DashOffset { get; set; }
Public Property DashOffset As Single
    Get
    Set

Property Value

Type: Single
The pen dash offset.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.DashPattern Property

AnnotationPenDashPattern Property

Gets or sets the dash pattern used

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] DashPattern { get; set; }
Public Property DashPattern As Single()
    Get
    Set

Property Value

Type: Single

The dash pattern for the pen

See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.DashStyle Property

AnnotationPenDashStyle Property

Gets or sets the style used for dashed lines drawn with this pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DashStyle DashStyle { get; set; }
Public Property DashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
The dash style for the pen.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.EndCap Property

AnnotationPenEndCap Property

Gets or sets the AnnotationLineCap used at the end of lines drawn with this pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public AnnotationLineCap EndCap { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Property EndCap As AnnotationLineCap
    Get
    Set

Property Value

Type: AnnotationLineCap
The pen end cap.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.LineJoin Property

AnnotationPenLineJoin Property

Gets or sets the join style for the ends of two consecutive lines drawn with this pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineJoin LineJoin { get; set; }
Public Property LineJoin As LineJoin
    Get
    Set

Property Value

Type: LineJoin
The line join style for the pen.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.MiterLimit Property

AnnotationPenMiterLimit Property

Gets or sets the limit of the thickness of the join on a mitered corner.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float MiterLimit { get; set; }
Public Property MiterLimit As Single
    Get
    Set

Property Value

Type: Single
The miter limit of the pen.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.StartCap Property

AnnotationPenStartCap Property

Gets or sets the AnnotationLineCap used at the beginning of lines drawn with this pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public AnnotationLineCap StartCap { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Property StartCap As AnnotationLineCap
    Get
    Set

Property Value

Type: AnnotationLineCap
The pen start cap.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.Width Property

AnnotationPenWidth Property

Gets or sets the width of the pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Width { get; set; }
Public Property Width As Single
    Get
    Set

Property Value

Type: Single
The pen width. This value must be greater than zero.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if this property is set to a value less than or equal to zero.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen Methods

The AnnotationPen type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this AnnotationPen.
Public method | Equals | Compares this AnnotationPen with another to test if they are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns an identifier for this object. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this AnnotationPen.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called to notify the AnnotationController after a property has been changed.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called before a property is changed.
Protected method | RemoveLineCapEvents | This is a helper method used to remove event handler for an AnnotationLineCap object.
Protected method | SetLineCapEvents | This is a helper method used to add event handling to an AnnotationLineCap.
Public method | ToString | Returns a string representation of this object. (Overrides ObjectToString.)
Top
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.Clone Method

AnnotationPenClone Method

Creates a copy of this AnnotationPen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Clone()
Public Function Clone As AnnotationPen

Return Value

Type: AnnotationPen
A copy of the AnnotationPen object.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.Equals Method

AnnotationPenEquals Method

Compares this AnnotationPen with another to test if they are equal.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AnnotationPen to compare against.

Return Value

Type: Boolean
True if they are equal.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.GetHashCode Method

AnnotationPenGetHashCode Method

Returns an identifier for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A value representing this object.
Remarks
This value is not guaranteed to be unique, but the same object instance will always return the same hash value.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.GetObjectData Method

AnnotationPenGetObjectData Method

Fills a SerializationInfo object with information about this AnnotationPen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where the information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.OnAnnotationControllerNotification Method

AnnotationPenOnAnnotationControllerNotification Method

Called to notify the AnnotationController after a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs specifying the property that was modified.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.OnPropertyChanged Method

AnnotationPenOnPropertyChanged Method

Called when a property value has changed and raises the PropertyChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationLocationChangedEventArgs containing information for this event.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.OnPropertyChanging Method

AnnotationPenOnPropertyChanging Method

Called before a property is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs specifying the property that is being modified.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.RemoveLineCapEvents Method

AnnotationPenRemoveLineCapEvents Method

This is a helper method used to remove event handler for an AnnotationLineCap object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RemoveLineCapEvents(
    AnnotationLineCap lineCap
)
Protected Sub RemoveLineCapEvents (
    lineCap As AnnotationLineCap
)

Parameters

lineCap
Type: Atalasoft.AnnotateAnnotationLineCap
The AnnotationLineCap to process.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace
AnnotationPenSetLineCapEvents(AnnotationLineCap)


AnnotationPen.SetLineCapEvents Method

AnnotationPenSetLineCapEvents Method

This is a helper method used to add event handling to an AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetLineCapEvents(
    AnnotationLineCap lineCap
)
Protected Sub SetLineCapEvents (
    lineCap As AnnotationLineCap
)

Parameters

lineCap
Type: Atalasoft.AnnotateAnnotationLineCap
The AnnotationLineCap to process.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.ToString Method

AnnotationPenToString Method

Returns a string representation of this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of this object.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen Events

The AnnotationPen type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.AnnotationControllerNotification Event

AnnotationPenAnnotationControllerNotification Event

Raised after a property of the AnnotationBrush if modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.PropertyChanged Event

AnnotationPenPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPen.PropertyChanging Event

AnnotationPenPropertyChanging Event

Raised just before a property is about to be modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

AnnotationPen Class
Atalasoft.Annotate Namespace


AnnotationPenAlignment Enumeration

Specifies the alignment of the AnnotationPen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationPenAlignment
Public Enumeration AnnotationPenAlignment
Members
Member name | Description
Center | The pen is centered over the line.
Inset | The pen is drawn inside the line.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs Class

Contains information for a property changed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateAnnotationPropertyChangedEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationPropertyChangedEventArgs : EventArgs
Public Class AnnotationPropertyChangedEventArgs
    Inherits EventArgs

The AnnotationPropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPropertyChangedEventArgs | Creates a new instance of AnnotationPropertyChangedEventArgs.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property.
Public property | OldValue | Gets the old value of the property.
Public property | PropertyName | Gets the name of the property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs Constructor

Creates a new instance of AnnotationPropertyChangedEventArgs.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPropertyChangedEventArgs(
    string propertyName,
    Object oldValue,
    Object newValue
)
Public Sub New (
    propertyName As String,
    oldValue As Object,
    newValue As Object
)

Parameters

propertyName
Type: SystemString
The name of the property that has been changed.
oldValue
Type: SystemObject
The previous value of the property.
newValue
Type: SystemObject
The new value of the property.
See Also

Reference

AnnotationPropertyChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs Properties

The AnnotationPropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property.
Public property | OldValue | Gets the old value of the property.
Public property | PropertyName | Gets the name of the property.
Top
See Also

Reference

AnnotationPropertyChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs.NewValue Property

AnnotationPropertyChangedEventArgsNewValue Property

Gets the new value of the property.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object NewValue { get; }
Public ReadOnly Property NewValue As Object
    Get

Property Value

Type: Object
The new value of the property.
See Also

Reference

AnnotationPropertyChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs.OldValue Property

AnnotationPropertyChangedEventArgsOldValue Property

Gets the old value of the property.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object OldValue { get; }
Public ReadOnly Property OldValue As Object
    Get

Property Value

Type: Object
The old value of the property.
See Also

Reference

AnnotationPropertyChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs.PropertyName Property

AnnotationPropertyChangedEventArgsPropertyName Property

Gets the name of the property.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get

Property Value

Type: String
The name of the property.
See Also

Reference

AnnotationPropertyChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventArgs Methods

The AnnotationPropertyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationPropertyChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangedEventHandler Delegate

This delegate is used for the PropertyChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationPropertyChangedEventHandler(
    Object sender,
    AnnotationPropertyChangedEventArgs e
)
Public Delegate Sub AnnotationPropertyChangedEventHandler (
    sender As Object,
    e As AnnotationPropertyChangedEventArgs
)

Parameters

sender
Type: SystemObject
The object that is affected.
e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationPropertyChangedEventArgs containing information for the property change.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs Class

This class hold information about a PropertyChanging event.
This class hold information about a PropertyChanging event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateAnnotationPropertyChangingEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationPropertyChangingEventArgs : EventArgs
Public Class AnnotationPropertyChangingEventArgs
    Inherits EventArgs

The AnnotationPropertyChangingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPropertyChangingEventArgs | Creates a new instance of AnnotationPropertyChangingEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this change should be accepted.
Public property | CurrentValue | Gets the current value of the property.
Public property | NewValue | Gets or sets the new value for the property.
Public property | PropertyName | Gets the name of the property that is being changed.
Public property | Sender | Gets the object that raised the event.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs Constructor

Creates a new instance of AnnotationPropertyChangingEventArgs.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPropertyChangingEventArgs(
    Object sender,
    string propertyName,
    Object currentValue,
    Object newValue
)
Public Sub New (
    sender As Object,
    propertyName As String,
    currentValue As Object,
    newValue As Object
)

Parameters

sender
Type: SystemObject
The object sending this event.
propertyName
Type: SystemString
The name of the property being changed.
currentValue
Type: SystemObject
The current value of the property.
newValue
Type: SystemObject
The new value of the property.
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs Properties

The AnnotationPropertyChangingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this change should be accepted.
Public property | CurrentValue | Gets the current value of the property.
Public property | NewValue | Gets or sets the new value for the property.
Public property | PropertyName | Gets the name of the property that is being changed.
Public property | Sender | Gets the object that raised the event.
Top
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs.Cancel Property

AnnotationPropertyChangingEventArgsCancel Property

Gets or sets a value indicating whether this change should be accepted.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this property change will be accepted.
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs.CurrentValue Property

AnnotationPropertyChangingEventArgsCurrentValue Property

Gets the current value of the property.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object CurrentValue { get; }
Public ReadOnly Property CurrentValue As Object
    Get

Property Value

Type: Object
The current value of the property.
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs.NewValue Property

AnnotationPropertyChangingEventArgsNewValue Property

Gets or sets the new value for the property.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object NewValue { get; set; }
Public Property NewValue As Object
    Get
    Set

Property Value

Type: Object
The new property value.
Remarks
This property can be set to a different value if the new value provided is not valid.
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs.PropertyName Property

AnnotationPropertyChangingEventArgsPropertyName Property

Gets the name of the property that is being changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get

Property Value

Type: String
The name of the property.
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs.Sender Property

AnnotationPropertyChangingEventArgsSender Property

Gets the object that raised the event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Sender { get; }
Public ReadOnly Property Sender As Object
    Get

Property Value

Type: Object
The object that raised the event.
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventArgs Methods

The AnnotationPropertyChangingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationPropertyChangingEventArgs Class
Atalasoft.Annotate Namespace


AnnotationPropertyChangingEventHandler Delegate

This delegate is used for the PropertyChanging event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationPropertyChangingEventHandler(
    Object sender,
    AnnotationPropertyChangingEventArgs e
)
Public Delegate Sub AnnotationPropertyChangingEventHandler (
    sender As Object,
    e As AnnotationPropertyChangingEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationRegion Class

This class defines a display region used for hit testing.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationRegion

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationRegion : IDisposable
Public Class AnnotationRegion
    Implements IDisposable

The AnnotationRegion type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationRegion | Creates a new instance of AnnotationRegion with an empty region.
Public method | AnnotationRegion(GraphicsPath) | Creates a new instance of AnnotationRegion specifying a GraphicsPath for the region.
Public method | AnnotationRegion(RectangleF) | Creates a new instance of AnnotationRegion from a rectangle.
Top
Properties
 | Name | Description
Public property | Path | The GraphicsPath used by the AnnotationRegion.
Top
Methods
 | Name | Description
Public method | Dispose | Releases region resources.
Protected method | Dispose(Boolean) | Releases resources used by the region.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnnotationRegion class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRegion | Returns a .NET Region for this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invalidate | Applies this region to a control's invalidation region.
Public method | IsVisible | Tests if a point is inside this region.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Applies a transformation matrix to this region.
Public method | Union(GraphicsPath) | Performs a union of the supplied GraphcisPath and the existing region.
Public method | Union(Rectangle) | Performs a union of the supplied rectangle and the existing region.
Public method | Union(RectangleF) | Performs a union of the supplied RectangleF and the existing region.
Public method | Union(AnnotationRegion) | Performs a union of the supplied AnnotationRegion and the existing region.
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationRegion Constructor

Constructs an AnnotationRegion.
Overload List
 | Name | Description
Public method | AnnotationRegion | Creates a new instance of AnnotationRegion with an empty region.
Public method | AnnotationRegion(GraphicsPath) | Creates a new instance of AnnotationRegion specifying a GraphicsPath for the region.
Public method | AnnotationRegion(RectangleF) | Creates a new instance of AnnotationRegion from a rectangle.
Top
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion Constructor

Creates a new instance of AnnotationRegion with an empty region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRegion()
Public Sub New
See Also

Reference

AnnotationRegion Class
AnnotationRegion Overload
Atalasoft.Annotate Namespace


AnnotationRegion Constructor (GraphicsPath)

Creates a new instance of AnnotationRegion specifying a GraphicsPath for the region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRegion(
    GraphicsPath path
)
Public Sub New (
    path As GraphicsPath
)

Parameters

path
Type: System.Drawing.Drawing2DGraphicsPath
The GraphicsPath used by the region. This GraphicsPath becomes the property of the AnnotationRegion and will automatically be disposed when the AnnotationRegion is disposed.
See Also

Reference

AnnotationRegion Class
AnnotationRegion Overload
Atalasoft.Annotate Namespace


AnnotationRegion Constructor (RectangleF)

Creates a new instance of AnnotationRegion from a rectangle.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRegion(
    RectangleF rectangle
)
Public Sub New (
    rectangle As RectangleF
)

Parameters

rectangle
Type: System.DrawingRectangleF
A rectangle used to define the initial region.
See Also

Reference

AnnotationRegion Class
AnnotationRegion Overload
Atalasoft.Annotate Namespace


AnnotationRegion Properties

The AnnotationRegion type exposes the following members.

Properties
 | Name | Description
Public property | Path | The GraphicsPath used by the AnnotationRegion.
Top
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Path Property

AnnotationRegionPath Property

The GraphicsPath used by the AnnotationRegion.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GraphicsPath Path { get; }
Public ReadOnly Property Path As GraphicsPath
    Get

Property Value

Type: GraphicsPath
The GraphicsPath object containing the region information.
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion Methods

The AnnotationRegion type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases region resources.
Protected method | Dispose(Boolean) | Releases resources used by the region.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnnotationRegion class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRegion | Returns a .NET Region for this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invalidate | Applies this region to a control's invalidation region.
Public method | IsVisible | Tests if a point is inside this region.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Applies a transformation matrix to this region.
Public method | Union(GraphicsPath) | Performs a union of the supplied GraphcisPath and the existing region.
Public method | Union(Rectangle) | Performs a union of the supplied rectangle and the existing region.
Public method | Union(RectangleF) | Performs a union of the supplied RectangleF and the existing region.
Public method | Union(AnnotationRegion) | Performs a union of the supplied AnnotationRegion and the existing region.
Top
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Dispose Method

AnnotationRegionDispose Method

Releases resources used by the AnnotationRegion class.
Overload List
 | Name | Description
Public method | Dispose | Releases region resources.
Protected method | Dispose(Boolean) | Releases resources used by the region.
Top
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Dispose Method

AnnotationRegionDispose Method

Releases region resources.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AnnotationRegion Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotationRegion.Dispose Method (Boolean)

AnnotationRegionDispose Method (Boolean)

Releases resources used by the region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was call from the public Dispose method.
See Also

Reference

AnnotationRegion Class
Dispose Overload
Atalasoft.Annotate Namespace


AnnotationRegion.Finalize Method

AnnotationRegionFinalize Method

Finalizes an instance of the AnnotationRegion class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.GetRegion Method

AnnotationRegionGetRegion Method

Returns a .NET Region for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Region GetRegion()
Public Function GetRegion As Region

Return Value

Type: Region
A .NET Region object containing the AnnotationRegion area.
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Invalidate Method

AnnotationRegionInvalidate Method

Applies this region to a control's invalidation region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Invalidate(
    Control control
)
Public Sub Invalidate (
    control As Control
)

Parameters

control
Type: System.Windows.FormsControl
The control to apply the invalidate to.
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.IsVisible Method

AnnotationRegionIsVisible Method

Tests if a point is inside this region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible(
    PointF point
)
Public Function IsVisible (
    point As PointF
) As Boolean

Parameters

point
Type: System.DrawingPointF
The point to test.

Return Value

Type: Boolean
True if the point is within this region.
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Transform Method

AnnotationRegionTransform Method

Applies a transformation matrix to this region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Transform(
    Matrix matrix
)
Public Sub Transform (
    matrix As Matrix
)

Parameters

matrix
Type: System.Drawing.Drawing2DMatrix
The matrix to apply.
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Union Method

AnnotationRegionUnion Method

This methods are used to combine areas to this region.
Overload List
 | Name | Description
Public method | Union(GraphicsPath) | Performs a union of the supplied GraphcisPath and the existing region.
Public method | Union(Rectangle) | Performs a union of the supplied rectangle and the existing region.
Public method | Union(RectangleF) | Performs a union of the supplied RectangleF and the existing region.
Public method | Union(AnnotationRegion) | Performs a union of the supplied AnnotationRegion and the existing region.
Top
See Also

Reference

AnnotationRegion Class
Atalasoft.Annotate Namespace


AnnotationRegion.Union Method (GraphicsPath)

AnnotationRegionUnion Method (GraphicsPath)

Performs a union of the supplied GraphcisPath and the existing region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Union(
    GraphicsPath path
)
Public Sub Union (
    path As GraphicsPath
)

Parameters

path
Type: System.Drawing.Drawing2DGraphicsPath
The GraphicsPath to apply.
See Also

Reference

AnnotationRegion Class
Union Overload
Atalasoft.Annotate Namespace


AnnotationRegion.Union Method (Rectangle)

AnnotationRegionUnion Method (Rectangle)

Performs a union of the supplied rectangle and the existing region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Union(
    Rectangle rectangle
)
Public Sub Union (
    rectangle As Rectangle
)

Parameters

rectangle
Type: System.DrawingRectangle
The rectangle to apply.
See Also

Reference

AnnotationRegion Class
Union Overload
Atalasoft.Annotate Namespace


AnnotationRegion.Union Method (RectangleF)

AnnotationRegionUnion Method (RectangleF)

Performs a union of the supplied RectangleF and the existing region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Union(
    RectangleF rectangle
)
Public Sub Union (
    rectangle As RectangleF
)

Parameters

rectangle
Type: System.DrawingRectangleF
The RectangleF to apply.
See Also

Reference

AnnotationRegion Class
Union Overload
Atalasoft.Annotate Namespace


AnnotationRegion.Union Method (AnnotationRegion)

AnnotationRegionUnion Method (AnnotationRegion)

Performs a union of the supplied AnnotationRegion and the existing region.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Union(
    AnnotationRegion region
)
Public Sub Union (
    region As AnnotationRegion
)

Parameters

region
Type: Atalasoft.AnnotateAnnotationRegion
The AnnotationRegion to apply.
See Also

Reference

AnnotationRegion Class
Union Overload
Atalasoft.Annotate Namespace


AnnotationSizeChangedEventArgs Class

This class is used to hold information about the SizeChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateAnnotationSizeChangedEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationSizeChangedEventArgs : EventArgs
Public Class AnnotationSizeChangedEventArgs
    Inherits EventArgs

The AnnotationSizeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationSizeChangedEventArgs | Creates a new instance of AnnotationSizeChangedEventArgs.
Top
Properties
 | Name | Description
Public property | NewSize | Gets the new size of the annotation.
Public property | OldSize | Gets the previous size of the annotation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationSizeChangedEventArgs Constructor

Creates a new instance of AnnotationSizeChangedEventArgs.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationSizeChangedEventArgs(
    SizeF oldSize,
    SizeF newSize
)
Public Sub New (
    oldSize As SizeF,
    newSize As SizeF
)

Parameters

oldSize
Type: System.DrawingSizeF
The previous size of the annotation.
newSize
Type: System.DrawingSizeF
The new size of the annotation.
See Also

Reference

AnnotationSizeChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationSizeChangedEventArgs Properties

The AnnotationSizeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewSize | Gets the new size of the annotation.
Public property | OldSize | Gets the previous size of the annotation.
Top
See Also

Reference

AnnotationSizeChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationSizeChangedEventArgs.NewSize Property

AnnotationSizeChangedEventArgsNewSize Property

Gets the new size of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF NewSize { get; }
Public ReadOnly Property NewSize As SizeF
    Get

Property Value

Type: SizeF
The new annotation size.
See Also

Reference

AnnotationSizeChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationSizeChangedEventArgs.OldSize Property

AnnotationSizeChangedEventArgsOldSize Property

Gets the previous size of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF OldSize { get; }
Public ReadOnly Property OldSize As SizeF
    Get

Property Value

Type: SizeF
The previous annotation size.
See Also

Reference

AnnotationSizeChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationSizeChangedEventArgs Methods

The AnnotationSizeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationSizeChangedEventArgs Class
Atalasoft.Annotate Namespace


AnnotationSizeChangedEventHandler Delegate

This delegate is used for the SizeChanged event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationSizeChangedEventHandler(
    Object sender,
    AnnotationSizeChangedEventArgs e
)
Public Delegate Sub AnnotationSizeChangedEventHandler (
    sender As Object,
    e As AnnotationSizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The annotation sending the event.
e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
An AnnotationSizeChangedEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationState Enumeration

Specifies the current state of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationState
Public Enumeration AnnotationState
Members
Member name | Description
Moving | The annotation is being moved by the user.
Resizing | The annotation is being resized by the user.
Creating | The annotation is being created by the user.
Idle | The annotation is sitting idle.
Loading | The annotation is loading from XMP or WANG data.
Rotating | The annotation is being rotated by the user.
GripMoving | Indicates that a grip is moving.
See Also

Reference

Atalasoft.Annotate Namespace


AnnotationUnit Enumeration

Specifies the unit of measure used for annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationUnit
Public Enumeration AnnotationUnit
Members
Member name | Description
Custom | A custom value in pixels per unit.
Pixel | Pixels.
Inch | Inches.
Micrometer | Micrometers.
Centimeter | Centimeters.
Foot | Feet.
Yard | Yards.
Meter | Meters.
Mile | Miles.
Kilometer | Kilometers.
See Also

Reference

Atalasoft.Annotate Namespace


CalloutData Class

Callout data used with the CalloutAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateCalloutData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CalloutData : AnnotationData
<SerializableAttribute>
Public Class CalloutData
    Inherits AnnotationData

The CalloutData type exposes the following members.

Constructors
 | Name | Description
Public method | CalloutData | Creates a new instance of CalloutData.
Public method | CalloutData(String) | Creates a new instance of CalloutData specifying the text for the annotation.
Public method | CalloutData(SerializationInfo, StreamingContext) | Creates a new instance of CalloutData from serialized information.
Public method | CalloutData(String, AnnotationFont, AnnotationBrush, Single) | Creates a new instance of CalloutData specifying the text, font, font brush and padding for the annotation.
Public method | CalloutData(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single) | Creates a new instance of CalloutData specifying the text, font, font brush, padding, outline and line pen.
Public method | CalloutData(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single, PointF, Boolean) | Creates a new instance of CalloutData specifying its parameters.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text.
Public property | AllowEditing | Gets or sets a value indicating whether the annotation's text data should be editable or read-only.
Public property | AnnotationBounds | (Overrides AnnotationDataAnnotationBounds.)
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text.
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the text area of the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Leader | Gets or sets the pen used for the leader of the annotation.
Public property | LeaderFlatLength | Gets or sets the length of the leader line.
Public property | LineAlignment | Gets or sets the line alignment.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to outline the text area of the annotation.
Public property | Padding | Gets or sets the amount of padding to add around the text.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | TargetPosition | Gets or sets the position on the document the leader will point to.
Public property | Text | Gets or sets the text of the annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Trimming | Get or sets the type of character trimming to perform on the text.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Public method | GetLeaderPoints | Returns an array of points used for rendering the callout leader line.
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


CalloutData Constructor

Creates a new instance of the CalloutData object.
Overload List
 | Name | Description
Public method | CalloutData | Creates a new instance of CalloutData.
Public method | CalloutData(String) | Creates a new instance of CalloutData specifying the text for the annotation.
Public method | CalloutData(SerializationInfo, StreamingContext) | Creates a new instance of CalloutData from serialized information.
Public method | CalloutData(String, AnnotationFont, AnnotationBrush, Single) | Creates a new instance of CalloutData specifying the text, font, font brush and padding for the annotation.
Public method | CalloutData(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single) | Creates a new instance of CalloutData specifying the text, font, font brush, padding, outline and line pen.
Public method | CalloutData(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single, PointF, Boolean) | Creates a new instance of CalloutData specifying its parameters.
Top
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData Constructor

Creates a new instance of CalloutData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutData()
Public Sub New
See Also

Reference

CalloutData Class
CalloutData Overload
Atalasoft.Annotate Namespace


CalloutData Constructor (String)

Creates a new instance of CalloutData specifying the text for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutData(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text for the annotation.
See Also

Reference

CalloutData Class
CalloutData Overload
Atalasoft.Annotate Namespace


CalloutData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of CalloutData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the annotation data information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

CalloutData Class
CalloutData Overload
Atalasoft.Annotate Namespace


CalloutData Constructor (String, AnnotationFont, AnnotationBrush, Single)

Creates a new instance of CalloutData specifying the text, font, font brush and padding for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    float padding
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    padding As Single
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
padding
Type: SystemSingle
The padding around the text.
See Also

Reference

CalloutData Class
CalloutData Overload
Atalasoft.Annotate Namespace


CalloutData Constructor (String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single)

Creates a new instance of CalloutData specifying the text, font, font brush, padding, outline and line pen.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    float padding,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationPen leader,
    float leaderFlatLength
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    padding As Single,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    leader As AnnotationPen,
    leaderFlatLength As Single
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
padding
Type: SystemSingle
The padding around the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the text area of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render an outline around the text area of the annotation.
leader
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the line of the annotation.
leaderFlatLength
Type: SystemSingle
The distance from the leader will stick out from the annotation.
See Also

Reference

CalloutData Class
CalloutData Overload
Atalasoft.Annotate Namespace


CalloutData Constructor (String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single, PointF, Boolean)

Creates a new instance of CalloutData specifying its parameters.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    float padding,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationPen leader,
    float leaderFlatLength,
    PointF targetPosition,
    bool autoSize
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    padding As Single,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    leader As AnnotationPen,
    leaderFlatLength As Single,
    targetPosition As PointF,
    autoSize As Boolean
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
padding
Type: SystemSingle
The padding around the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the text area of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render an outline around the text area of the annotation.
leader
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the line of the annotation.
leaderFlatLength
Type: SystemSingle
The distance the leader will stick out from the annotation.
targetPosition
Type: System.DrawingPointF
The document position the line will point to.
autoSize
Type: SystemBoolean
Indicates whether the annotation will automatically resize to fit the text.
See Also

Reference

CalloutData Class
CalloutData Overload
Atalasoft.Annotate Namespace


CalloutData Properties

The CalloutData type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text.
Public property | AllowEditing | Gets or sets a value indicating whether the annotation's text data should be editable or read-only.
Public property | AnnotationBounds | (Overrides AnnotationDataAnnotationBounds.)
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text.
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the text area of the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Leader | Gets or sets the pen used for the leader of the annotation.
Public property | LeaderFlatLength | Gets or sets the length of the leader line.
Public property | LineAlignment | Gets or sets the line alignment.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to outline the text area of the annotation.
Public property | Padding | Gets or sets the amount of padding to add around the text.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | TargetPosition | Gets or sets the position on the document the leader will point to.
Public property | Text | Gets or sets the text of the annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Trimming | Get or sets the type of character trimming to perform on the text.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Alignment Property

CalloutDataAlignment Property

Gets or sets the horizontal alignment of the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment Alignment { get; set; }
Public Property Alignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The horizontal text alignment.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.AllowEditing Property

CalloutDataAllowEditing Property

Gets or sets a value indicating whether the annotation's text data should be editable or read-only.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

Property Value

Type: Boolean

Indicates whether the annotation's text data should be editable or read-only.

See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.AnnotationBounds Property

CalloutDataAnnotationBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF AnnotationBounds { get; }
Public Overrides ReadOnly Property AnnotationBounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.AutoSize Property

CalloutDataAutoSize Property

Gets or sets a value indicating whether the annotation will automatically resize to fit the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation will resize to fit the text.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Bounds Property

CalloutDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Fill Property

CalloutDataFill Property

Gets or sets the brush used to fill the text area of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the text area.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Font Property

CalloutDataFont Property

Gets or sets the font used to render the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used to render the text.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.FontBrush Property

CalloutDataFontBrush Property

Gets or sets the brush used to render the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to render the text.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.FormatFlags Property

CalloutDataFormatFlags Property

Gets or sets a StringFormatFlags enumeration that contains formatting information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringFormatFlags FormatFlags { get; set; }
Public Property FormatFlags As StringFormatFlags
    Get
    Set

Property Value

Type: StringFormatFlags
Formatting for the text.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Leader Property

CalloutDataLeader Property

Gets or sets the pen used for the leader of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Leader { get; set; }
Public Property Leader As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the leader.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.LeaderFlatLength Property

CalloutDataLeaderFlatLength Property

Gets or sets the length of the leader line.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float LeaderFlatLength { get; set; }
Public Property LeaderFlatLength As Single
    Get
    Set

Property Value

Type: Single
The length of the leader line.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.LineAlignment Property

CalloutDataLineAlignment Property

Gets or sets the line alignment.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment LineAlignment { get; set; }
Public Property LineAlignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The line alignment.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Outline Property

CalloutDataOutline Property

Gets or sets the pen used to outline the text area of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the text area outline.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Padding Property

CalloutDataPadding Property

Gets or sets the amount of padding to add around the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Padding { get; set; }
Public Property Padding As Single
    Get
    Set

Property Value

Type: Single
The padding around the text.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.TargetPosition Property

CalloutDataTargetPosition Property

Gets or sets the position on the document the leader will point to.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF TargetPosition { get; set; }
Public Property TargetPosition As PointF
    Get
    Set

Property Value

Type: PointF
The position on the document this callout will point to.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Text Property

CalloutDataText Property

Gets or sets the text of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text of the annotation.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Trimming Property

CalloutDataTrimming Property

Get or sets the type of character trimming to perform on the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringTrimming Trimming { get; set; }
Public Property Trimming As StringTrimming
    Get
    Set

Property Value

Type: StringTrimming
Specifies how to trim characters from a string that does not completely fit into a layout shape.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData Methods

The CalloutData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Public method | GetLeaderPoints | Returns an array of points used for rendering the callout leader line.
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.Clone Method

CalloutDataClone Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.CloneBaseData Method

CalloutDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.GetLeaderPoints Method

CalloutDataGetLeaderPoints Method

Returns an array of points used for rendering the callout leader line.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF[] GetLeaderPoints()
Public Function GetLeaderPoints As PointF()

Return Value

Type: PointF
An array of points for the leader line.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.GetLineCapBounds Method

CalloutDataGetLineCapBounds Method

Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override RectangleF GetLineCapBounds()
Protected Overrides Function GetLineCapBounds As RectangleF

Return Value

Type: RectangleF
The bounds for the line cap.
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData.GetObjectData Method

CalloutDataGetObjectData Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


CalloutData Events

The CalloutData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

CalloutData Class
Atalasoft.Annotate Namespace


ChangePositionMethod Enumeration

Specifies the reordering to perform on a layer or annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ChangePositionMethod
Public Enumeration ChangePositionMethod
Members
Member name | Description
MoveToFront | Moves the item to the beginning of the collection.
MoveUp | Moves the item one position closer to the beginning of the collection.
MoveBack | Moves the item one position closer to the end of the collection.
MoveToBack | Moves the item to the end of the collection.
See Also

Reference

Atalasoft.Annotate Namespace


CommentData Class

The CommentData class is used for adding comments to other annotations, but it can also be used standalone.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateTextData
Atalasoft.AnnotateCommentData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommentData : TextData,
    IAttachableAnnotation, ISerializable, ICloneable
<SerializableAttribute>
Public Class CommentData
    Inherits TextData
    Implements IAttachableAnnotation, ISerializable, ICloneable

The CommentData type exposes the following members.

Constructors
 | Name | Description
Public method | CommentData | Creates a new instance of CommentData.
Public method | CommentData(RectangleF) | Creates a new instance of CommentData specifying the annotation location and size.
Public method | CommentData(String) | Creates a new instance of CommentData specifying the annotation text.
Public method | CommentData(WangAttributeData) | Creates a new instance of CommentData from WANG annotation information.
Public method | CommentData(RectangleF, String) | Creates a new instance of CommentData specifying the annotation text.
Public method | CommentData(SerializationInfo, StreamingContext) | Creates a new instance of CommentData from serialized information.
Public method | CommentData(String, AnnotationFont) | Creates a new instance of CommentData specifying the text and font.
Public method | CommentData(RectangleF, String, AnnotationFont) | Creates a new instance of CommentData specifying the text and font.
Public method | CommentData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of CommentData specifying the text, font, font brush, fill and outline for the annotation.
Public method | CommentData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of CommentData specifying the text, font, font brush, fill and outline for the annotation.
Public method | CommentData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of CommentData specifying the properties for this object.
Public method | CommentData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of CommentData specifying the properties for this object.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text. (Inherited from TextData.)
Public property | AllowEditing | Gets or sets a value indicating whether the annotation's text data should be editable or read-only via the user interface. (Inherited from TextData.)
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text. (Inherited from TextData.)
Public property | Bounds | (Inherited from TextData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation. (Inherited from TextData.)
Public property | Font | Gets or sets the font for the text. (Inherited from TextData.)
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font. (Inherited from TextData.)
Public property | FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information. (Inherited from TextData.)
Public property | Guid | Gets a Guid used to identify the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineAlignment | Gets or sets the line alignment. (Inherited from TextData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | Minimized | Gets or sets a value indicating whether the annotation is minimized. (Inherited from TextData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation. (Inherited from TextData.)
Public property | Padding | Gets or sets a value indicating how much padding is added around the text. (Inherited from TextData.)
Public property | Parent | Gets or sets the annotation this annotation is attached to, if any.
Public property | RenderingHint | Gets or sets the System.Drawing.Text.TextRenderingHint used when rendering this text (Inherited from TextData.)
Public property | Replies | Gets a list of CommentData replies.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow. (Inherited from TextData.)
Public property | ShadowMode | Gets or sets the shadow mode used to indicate how the shadow is drawn. (Inherited from TextData.)
Public property | ShadowOffset | Gets or sets the shadow offset. (Inherited from TextData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for this annotation. (Inherited from TextData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Trimming | Get or sets the type of character trimming to perform on the text. (Inherited from TextData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this TextData. (Overrides TextDataClone.)
Protected method | CloneBaseData | Creates a copy of this TextData. (Overrides TextDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides TextDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides TextDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this object. (Inherited from TextData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData containing information about this TextData. (Inherited from TextData.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


CommentData Constructor

Constructs a new CommentData.
Overload List
 | Name | Description
Public method | CommentData | Creates a new instance of CommentData.
Public method | CommentData(RectangleF) | Creates a new instance of CommentData specifying the annotation location and size.
Public method | CommentData(String) | Creates a new instance of CommentData specifying the annotation text.
Public method | CommentData(WangAttributeData) | Creates a new instance of CommentData from WANG annotation information.
Public method | CommentData(RectangleF, String) | Creates a new instance of CommentData specifying the annotation text.
Public method | CommentData(SerializationInfo, StreamingContext) | Creates a new instance of CommentData from serialized information.
Public method | CommentData(String, AnnotationFont) | Creates a new instance of CommentData specifying the text and font.
Public method | CommentData(RectangleF, String, AnnotationFont) | Creates a new instance of CommentData specifying the text and font.
Public method | CommentData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of CommentData specifying the text, font, font brush, fill and outline for the annotation.
Public method | CommentData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of CommentData specifying the text, font, font brush, fill and outline for the annotation.
Public method | CommentData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of CommentData specifying the properties for this object.
Public method | CommentData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of CommentData specifying the properties for this object.
Top
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData Constructor

Creates a new instance of CommentData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData()
Public Sub New
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (RectangleF)

Creates a new instance of CommentData specifying the annotation location and size.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    RectangleF bounds
)
Public Sub New (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (String)

Creates a new instance of CommentData specifying the annotation text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text for this annotation.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (WangAttributeData)

Creates a new instance of CommentData from WANG annotation information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
A WangAttributeData object containing information about this annotation.
Remarks
WANG does not support comments. This constructor only exists to insure initialization of the annotation.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (RectangleF, String)

Creates a new instance of CommentData specifying the annotation text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    RectangleF bounds,
    string text
)
Public Sub New (
    bounds As RectangleF,
    text As String
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of CommentData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the information.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (String, AnnotationFont)

Creates a new instance of CommentData specifying the text and font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    string text,
    AnnotationFont font
)
Public Sub New (
    text As String,
    font As AnnotationFont
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (RectangleF, String, AnnotationFont)

Creates a new instance of CommentData specifying the text and font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    RectangleF bounds,
    string text,
    AnnotationFont font
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of CommentData specifying the text, font, font brush, fill and outline for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of CommentData specifying the text, font, font brush, fill and outline for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    RectangleF bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode)

Creates a new instance of CommentData specifying the properties for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    ShadowMode shadowMode
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    shadowMode As ShadowMode
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
shadowMode
Type: Atalasoft.AnnotateShadowMode
Defines the type of shadow to apply.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Constructor (RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode)

Creates a new instance of CommentData specifying the properties for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CommentData(
    RectangleF bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    ShadowMode shadowMode
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    shadowMode As ShadowMode
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
shadowMode
Type: Atalasoft.AnnotateShadowMode
Defines the type of shadow to apply.
See Also

Reference

CommentData Class
CommentData Overload
Atalasoft.Annotate Namespace


CommentData Properties

The CommentData type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text. (Inherited from TextData.)
Public property | AllowEditing | Gets or sets a value indicating whether the annotation's text data should be editable or read-only via the user interface. (Inherited from TextData.)
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text. (Inherited from TextData.)
Public property | Bounds | (Inherited from TextData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation. (Inherited from TextData.)
Public property | Font | Gets or sets the font for the text. (Inherited from TextData.)
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font. (Inherited from TextData.)
Public property | FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information. (Inherited from TextData.)
Public property | Guid | Gets a Guid used to identify the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineAlignment | Gets or sets the line alignment. (Inherited from TextData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | Minimized | Gets or sets a value indicating whether the annotation is minimized. (Inherited from TextData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation. (Inherited from TextData.)
Public property | Padding | Gets or sets a value indicating how much padding is added around the text. (Inherited from TextData.)
Public property | Parent | Gets or sets the annotation this annotation is attached to, if any.
Public property | RenderingHint | Gets or sets the System.Drawing.Text.TextRenderingHint used when rendering this text (Inherited from TextData.)
Public property | Replies | Gets a list of CommentData replies.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow. (Inherited from TextData.)
Public property | ShadowMode | Gets or sets the shadow mode used to indicate how the shadow is drawn. (Inherited from TextData.)
Public property | ShadowOffset | Gets or sets the shadow offset. (Inherited from TextData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for this annotation. (Inherited from TextData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Trimming | Get or sets the type of character trimming to perform on the text. (Inherited from TextData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.Guid Property

CommentDataGuid Property

Gets a Guid used to identify the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Guid Guid { get; }
Public ReadOnly Property Guid As Guid
    Get

Property Value

Type: Guid
A Guid used to identify the annotation.

Implements

IAttachableAnnotationGuid
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.Parent Property

CommentDataParent Property

Gets or sets the annotation this annotation is attached to, if any.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData Parent { get; set; }
Public Property Parent As AnnotationData
    Get
    Set

Property Value

Type: AnnotationData
The annotation this annotation is attached to or null (Nothing in VB) if it is a standalone annotation.

Implements

IAttachableAnnotationParent
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.Replies Property

CommentDataReplies Property

Gets a list of CommentData replies.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<CommentData> Replies { get; }
Public ReadOnly Property Replies As IList(Of CommentData)
    Get

Property Value

Type: IList CommentData
A list of replies to this comment.
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData Methods

The CommentData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this TextData. (Overrides TextDataClone.)
Protected method | CloneBaseData | Creates a copy of this TextData. (Overrides TextDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides TextDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides TextDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this object. (Inherited from TextData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData containing information about this TextData. (Inherited from TextData.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.Clone Method

CommentDataClone Method

Creates a copy of this TextData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this annotation data.

Implements

ICloneableClone
ICloneableClone
ICloneableClone
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.CloneBaseData Method

CommentDataCloneBaseData Method

Creates a copy of this TextData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
Exceptions
Exception | Condition
Exception | Unexpected exception - cloned child added to comment collection has incorrect parent.
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.Equals Method

CommentDataEquals Method

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData.GetHashCode Method

CommentDataGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CommentData Events

The CommentData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

CommentData Class
Atalasoft.Annotate Namespace


CreateAnnotationMode Enumeration

Specifies the annotation creation mode when calling AnnotationController.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CreateAnnotationMode
Public Enumeration CreateAnnotationMode
Members
Member name | Description
Default | Annotations are created by click and drag or with multiple clicks.
SingleClickLocation | Annotations are added with a single click and the annotation location is set to the document position that was clicked.
DoubleClickLocation | Annotations are added with a double-click and the annotation location is set to the document position that was clicked.
SingleClickCenter | Annotations are added with a single click and the annotation is centered on the document position that was clicked.
DoubleClickCenter | Annotations are added with a double-click and the annotation is centered on the document position that was clicked.
See Also

Reference

Atalasoft.Annotate Namespace


DocumentRotation Enumeration

Specifies the amount of rotation to apply to the document and annotations by the RotateDocument method.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DocumentRotation
Public Enumeration DocumentRotation
Members
Member name | Description
Rotate90 | Rotates 90 degrees clockwise.
Rotate180 | Rotates 180 degrees clockwise.
Rotate270 | Rotates 270 degrees clockwise.
See Also

Reference

Atalasoft.Annotate Namespace


EllipseData Class

Ellipse annotation data.
Ellipse annotation data.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateEllipseData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EllipseData : AnnotationData,
    ISerializable, IHighlighter
<SerializableAttribute>
Public Class EllipseData
    Inherits AnnotationData
    Implements ISerializable, IHighlighter

The EllipseData type exposes the following members.

Constructors
 | Name | Description
Public method | EllipseData | Creates a new instance of EllipseData.
Public method | EllipseData(RectangleF, AnnotationBrush) | Creates a new instance of EllipseData specifying the bounding rectangle and fill.
Public method | EllipseData(RectangleF, AnnotationPen) | Creates a new instance of EllipseData specifying the bounding rectangle and outline.
Public method | EllipseData(SerializationInfo, StreamingContext) | Creates a new instance of EllipseData from serialized information.
Public method | EllipseData(RectangleF, AnnotationBrush, Boolean) | Creates a new instance of EllipseData specifying the rectangle, fill and translucent properties.
Public method | EllipseData(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of EllipseData specifying the bounding rectangle, fill, outline and shadow options.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of the EllipseData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another EllipseData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with EllipseData information. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
EllipseAnnotation Class


EllipseData Constructor

Constructs a new EllipseData.
Overload List
 | Name | Description
Public method | EllipseData | Creates a new instance of EllipseData.
Public method | EllipseData(RectangleF, AnnotationBrush) | Creates a new instance of EllipseData specifying the bounding rectangle and fill.
Public method | EllipseData(RectangleF, AnnotationPen) | Creates a new instance of EllipseData specifying the bounding rectangle and outline.
Public method | EllipseData(SerializationInfo, StreamingContext) | Creates a new instance of EllipseData from serialized information.
Public method | EllipseData(RectangleF, AnnotationBrush, Boolean) | Creates a new instance of EllipseData specifying the rectangle, fill and translucent properties.
Public method | EllipseData(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of EllipseData specifying the bounding rectangle, fill, outline and shadow options.
Top
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData Constructor

Creates a new instance of EllipseData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseData()
Public Sub New
See Also

Reference

EllipseData Class
EllipseData Overload
Atalasoft.Annotate Namespace


EllipseData Constructor (RectangleF, AnnotationBrush)

Creates a new instance of EllipseData specifying the bounding rectangle and fill.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseData(
    RectangleF rectangle,
    AnnotationBrush fill
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the ellipse.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used by the ellipse.
See Also

Reference

EllipseData Class
EllipseData Overload
Atalasoft.Annotate Namespace


EllipseData Constructor (RectangleF, AnnotationPen)

Creates a new instance of EllipseData specifying the bounding rectangle and outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseData(
    RectangleF rectangle,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the ellipse.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used by the ellipse.
See Also

Reference

EllipseData Class
EllipseData Overload
Atalasoft.Annotate Namespace


EllipseData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of EllipseData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information containing the ellipse data.
context
Type: System.Runtime.SerializationStreamingContext
A context containing information about this object.
See Also

Reference

EllipseData Class
EllipseData Overload
Atalasoft.Annotate Namespace


EllipseData Constructor (RectangleF, AnnotationBrush, Boolean)

Creates a new instance of EllipseData specifying the rectangle, fill and translucent properties.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseData(
    RectangleF rectangle,
    AnnotationBrush fill,
    bool translucent
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    translucent As Boolean
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for this annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill this annotation.
translucent
Type: SystemBoolean
A value indicating whether this annotation will act as a highlighter.
See Also

Reference

EllipseData Class
EllipseData Overload
Atalasoft.Annotate Namespace


EllipseData Constructor (RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of EllipseData specifying the bounding rectangle, fill, outline and shadow options.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseData(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the ellipse.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used by the ellipse.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used by the ellipse.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
A value indicating whether or not the ellipse has a shadow.
shadowOffset
Type: System.DrawingPointF
The amount of offset applied to the shadow.
See Also

Reference

EllipseData Class
EllipseData Overload
Atalasoft.Annotate Namespace


EllipseData Properties

The EllipseData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Bounds Property

EllipseDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Fill Property

EllipseDataFill Property

Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Outline Property

EllipseDataOutline Property

Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Shadow Property

EllipseDataShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.ShadowOffset Property

EllipseDataShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Translucent Property

EllipseDataTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.

Implements

IHighlighterTranslucent
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument method.
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData Methods

The EllipseData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of the EllipseData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another EllipseData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with EllipseData information. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Clone Method

EllipseDataClone Method

Creates a copy of the EllipseData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.CloneBaseData Method

EllipseDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.Equals Method

EllipseDataEquals Method

Determines if another EllipseData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An EllipseData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.GetHashCode Method

EllipseDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.GetObjectData Method

EllipseDataGetObjectData Method

Fills a SerializationInfo object with EllipseData information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object to fill with data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData.OnPropertyChanging Method

EllipseDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EllipseData Events

The EllipseData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

EllipseData Class
Atalasoft.Annotate Namespace


EmbeddedImageData Class

Data for the EmbeddedImageAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateEmbeddedImageData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EmbeddedImageData : AnnotationData,
    ISerializable, ICloneable, IWangCompatible
<SerializableAttribute>
Public Class EmbeddedImageData
    Inherits AnnotationData
    Implements ISerializable, ICloneable, IWangCompatible

The EmbeddedImageData type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedImageData | Creates a new instance of EmbeddedImageData.
Public method | EmbeddedImageData(AnnotationImage) | Creates a new instance of EmbeddedImageData specifying the image.
Public method | EmbeddedImageData(WangAttributeData) | Creates a new instance of EmbeddedImageData from WANG data.
Public method | EmbeddedImageData(SerializationInfo, StreamingContext) | Creates a new instance of EmbeddedImageData from serialized information.
Public method | EmbeddedImageData(AnnotationImage, PointF) | Creates a new instance of EmbeddedImageData specifying the image, whether or not to maintain the aspect ratio and the initial location of this object.
Public method | EmbeddedImageData(AnnotationImage, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageData specifying the image, shadow and shadow offset.
Public method | EmbeddedImageData(AnnotationImage, PointF, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageData specifying the image, initial location, shadow and shadow offset.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | Image | Gets or sets the image of the annotation.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this object. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Overrides AnnotationDataDispose(Boolean).)
Public method | Equals | Determines if another EmbeddedImageData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this data. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object containing information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
EmbeddedImageAnnotation Class


EmbeddedImageData Constructor

Constructs an EmbeddedImageData.
Overload List
 | Name | Description
Public method | EmbeddedImageData | Creates a new instance of EmbeddedImageData.
Public method | EmbeddedImageData(AnnotationImage) | Creates a new instance of EmbeddedImageData specifying the image.
Public method | EmbeddedImageData(WangAttributeData) | Creates a new instance of EmbeddedImageData from WANG data.
Public method | EmbeddedImageData(SerializationInfo, StreamingContext) | Creates a new instance of EmbeddedImageData from serialized information.
Public method | EmbeddedImageData(AnnotationImage, PointF) | Creates a new instance of EmbeddedImageData specifying the image, whether or not to maintain the aspect ratio and the initial location of this object.
Public method | EmbeddedImageData(AnnotationImage, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageData specifying the image, shadow and shadow offset.
Public method | EmbeddedImageData(AnnotationImage, PointF, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageData specifying the image, initial location, shadow and shadow offset.
Top
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor

Creates a new instance of EmbeddedImageData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData()
Public Sub New
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor (AnnotationImage)

Creates a new instance of EmbeddedImageData specifying the image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData(
    AnnotationImage image
)
Public Sub New (
    image As AnnotationImage
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image for the annotation.
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor (WangAttributeData)

Creates a new instance of EmbeddedImageData from WANG data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
A WangAttributeData object containing information about this annotation.
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of EmbeddedImageData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor (AnnotationImage, PointF)

Creates a new instance of EmbeddedImageData specifying the image, whether or not to maintain the aspect ratio and the initial location of this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData(
    AnnotationImage image,
    PointF location
)
Public Sub New (
    image As AnnotationImage,
    location As PointF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image for the annotation.
location
Type: System.DrawingPointF
The initial location of this annotation on the document.
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor (AnnotationImage, AnnotationBrush, PointF)

Creates a new instance of EmbeddedImageData specifying the image, shadow and shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData(
    AnnotationImage image,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    image As AnnotationImage,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to embed.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Constructor (AnnotationImage, PointF, AnnotationBrush, PointF)

Creates a new instance of EmbeddedImageData specifying the image, initial location, shadow and shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageData(
    AnnotationImage image,
    PointF location,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    image As AnnotationImage,
    location As PointF,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to embed.
location
Type: System.DrawingPointF
The initial location of this annotation on the document.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EmbeddedImageData Class
EmbeddedImageData Overload
Atalasoft.Annotate Namespace


EmbeddedImageData Properties

The EmbeddedImageData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | Image | Gets or sets the image of the annotation.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.Bounds Property

EmbeddedImageDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.Image Property

EmbeddedImageDataImage Property

Gets or sets the image of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage Image { get; set; }
Public Property Image As AnnotationImage
    Get
    Set

Property Value

Type: AnnotationImage
The image to embed.
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.Shadow Property

EmbeddedImageDataShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.ShadowOffset Property

EmbeddedImageDataShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData Methods

The EmbeddedImageData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this object. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Overrides AnnotationDataDispose(Boolean).)
Public method | Equals | Determines if another EmbeddedImageData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this data. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object containing information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.Clone Method

EmbeddedImageDataClone Method

Creates a copy of this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this EmbeddedImageData.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.CloneBaseData Method

EmbeddedImageDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.Dispose Method

EmbeddedImageDataDispose Method

These methods release resources used by the annotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Overrides AnnotationDataDispose(Boolean).)
Top
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.Dispose Method (Boolean)

EmbeddedImageDataDispose Method (Boolean)

Called to release resources used by the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was called from the public Dispose method or the class finalizer.
See Also

Reference

EmbeddedImageData Class
Dispose Overload
Atalasoft.Annotate Namespace


EmbeddedImageData.Equals Method

EmbeddedImageDataEquals Method

Determines if another EmbeddedImageData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An EmbeddedImageData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.GetHashCode Method

EmbeddedImageDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.GetObjectData Method

EmbeddedImageDataGetObjectData Method

Fills a SerializationInfo object with information about this data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where the information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData.GetWangAttributeData Method

EmbeddedImageDataGetWangAttributeData Method

Returns a WangAttributeData object containing information about this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData for this annotation.

Implements

IWangCompatibleGetWangAttributeData
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


EmbeddedImageData Events

The EmbeddedImageData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

EmbeddedImageData Class
Atalasoft.Annotate Namespace


FillType Enumeration

Specifies the type of fill used by an AnnotationBrush.
Specifies the type of fill used by an AnnotationBrush.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FillType
Public Enumeration FillType
Members
Member name | Description
Solid | A solid fill.
Hatch | A hatch brush.
Texture | A texture brush.
LinearGradient | A linear gradient brush.
See Also

Reference

Atalasoft.Annotate Namespace


FreehandData Class

Data for a FreehandAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotatePointBaseData
Atalasoft.AnnotateFreehandData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FreehandData : PointBaseData,
    ISerializable, ICloneable, IWangCompatible, IHighlighter
<SerializableAttribute>
Public Class FreehandData
    Inherits PointBaseData
    Implements ISerializable, ICloneable, IWangCompatible, IHighlighter

The FreehandData type exposes the following members.

Constructors
 | Name | Description
Public method | FreehandData | Creates a new instance of FreehandData.
Public method | FreehandData(PointF) | Creates a new instance of FreehandData specifying the initial points.
Public method | FreehandData(AnnotationPen) | Creates a new instance of FreehandData specifying the outline.
Public method | FreehandData(WangAttributeData) | Creates a new instance of FreehandData from WANG attribute data.
Public method | FreehandData(SerializationInfo, StreamingContext) | Creates a new instance of FreehandData from serialized information.
Public method | FreehandData(AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandData specifying the outline and initial points.
Public method | FreehandData(AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandData with no initial points, specifying the fill, outline and translucency
Public method | FreehandData(AnnotationBrush, AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandData specifying the outline, fill and initial points.
Public method | FreehandData(PointF, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandData specifying the initial points, fill, outline and translucency
Public method | FreehandData(PointFCollection, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandData specifying the initial points, fill, outline and translucency
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | ClosedShape | Gets or sets a value indicating whether the freehand is a closed shape.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill for the freehand.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineType | Gets or sets the FreehandLineType used for the lines or curves of this annotation.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for this freehand.
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | Create a copy of this annotation. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another FreehandData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
FreehandAnnotation Class


FreehandData Constructor

Constructs a FreehandData.
Overload List
 | Name | Description
Public method | FreehandData | Creates a new instance of FreehandData.
Public method | FreehandData(PointF) | Creates a new instance of FreehandData specifying the initial points.
Public method | FreehandData(AnnotationPen) | Creates a new instance of FreehandData specifying the outline.
Public method | FreehandData(WangAttributeData) | Creates a new instance of FreehandData from WANG attribute data.
Public method | FreehandData(SerializationInfo, StreamingContext) | Creates a new instance of FreehandData from serialized information.
Public method | FreehandData(AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandData specifying the outline and initial points.
Public method | FreehandData(AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandData with no initial points, specifying the fill, outline and translucency
Public method | FreehandData(AnnotationBrush, AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandData specifying the outline, fill and initial points.
Public method | FreehandData(PointF, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandData specifying the initial points, fill, outline and translucency
Public method | FreehandData(PointFCollection, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandData specifying the initial points, fill, outline and translucency
Top
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData Constructor

Creates a new instance of FreehandData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData()
Public Sub New
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (PointF[])

FreehandData Constructor (PointF)

Creates a new instance of FreehandData specifying the initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    params PointF[] points
)
Public Sub New (
    ParamArray points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The initial points for the freehand. These points must be in annotation space.
Exceptions
Exception | Condition
 | Thrown if the points parameter is null.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (AnnotationPen)

Creates a new instance of FreehandData specifying the outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    AnnotationPen outline
)
Public Sub New (
    outline As AnnotationPen
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the lines or curves.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (WangAttributeData)

Creates a new instance of FreehandData from WANG attribute data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
The WangAttributeData containing information about this object.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FreehandData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information for this object.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context for this object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (AnnotationPen, PointF[])

FreehandData Constructor (AnnotationPen, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of FreehandData specifying the outline and initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public FreehandData(
    AnnotationPen outline,
    params PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    ParamArray points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
points
Type: System.DrawingPointF
The initial point for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (AnnotationBrush, AnnotationPen, Boolean)

Creates a new instance of FreehandData with no initial points, specifying the fill, outline and translucency

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    AnnotationBrush fill,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (AnnotationBrush, AnnotationPen, PointF[])

FreehandData Constructor (AnnotationBrush, AnnotationPen, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of FreehandData specifying the outline, fill and initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public FreehandData(
    AnnotationBrush fill,
    AnnotationPen outline,
    params PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    ParamArray points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
points
Type: System.DrawingPointF
The initial point for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (PointF[], AnnotationBrush, AnnotationPen, Boolean)

FreehandData Constructor (PointF, AnnotationBrush, AnnotationPen, Boolean)

Creates a new instance of FreehandData specifying the initial points, fill, outline and translucency

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    PointF[] points,
    AnnotationBrush fill,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointF(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: System.DrawingPointF
The initial points for the freehand. These points must be in annotation space.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Constructor (PointFCollection, AnnotationBrush, AnnotationPen, Boolean)

Creates a new instance of FreehandData specifying the initial points, fill, outline and translucency

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandData(
    PointFCollection points,
    AnnotationBrush fill,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointFCollection,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the freehand points. These points must be in annotation space.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

FreehandData Class
FreehandData Overload
Atalasoft.Annotate Namespace


FreehandData Properties

The FreehandData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | ClosedShape | Gets or sets a value indicating whether the freehand is a closed shape.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill for the freehand.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineType | Gets or sets the FreehandLineType used for the lines or curves of this annotation.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for this freehand.
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.Bounds Property

FreehandDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.ClosedShape Property

FreehandDataClosedShape Property

Gets or sets a value indicating whether the freehand is a closed shape.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClosedShape { get; set; }
Public Property ClosedShape As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the freehand is a closed shape.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.Fill Property

FreehandDataFill Property

Gets or sets the fill for the freehand.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill of the freehand.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.LineType Property

FreehandDataLineType Property

Gets or sets the FreehandLineType used for the lines or curves of this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandLineType LineType { get; set; }
Public Property LineType As FreehandLineType
    Get
    Set

Property Value

Type: FreehandLineType
The line type for this annotation.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.Outline Property

FreehandDataOutline Property

Gets or sets the outline for this freehand.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The outline for this freehand.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.Translucent Property

FreehandDataTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.

Implements

IHighlighterTranslucent
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument method.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData Methods

The FreehandData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | Create a copy of this annotation. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another FreehandData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.Clone Method

FreehandDataClone Method

Create a copy of this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this FreehandData.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.CloneBaseData Method

FreehandDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from PointBaseData.
Remarks
This method should be called by classes that derive from PointBaseData when they need to create a clone of the object.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.Equals Method

FreehandDataEquals Method

Determines if another FreehandData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An FreehandData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.GetHashCode Method

FreehandDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.GetLineCapBounds Method

FreehandDataGetLineCapBounds Method

Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override RectangleF GetLineCapBounds()
Protected Overrides Function GetLineCapBounds As RectangleF

Return Value

Type: RectangleF
The bounds for the line cap.
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.GetObjectData Method

FreehandDataGetObjectData Method

Fills a SerializationInfo object with information about this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.GetWangAttributeData Method

FreehandDataGetWangAttributeData Method

Returns a WangAttributeData with information about this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData for this annotation.

Implements

IWangCompatibleGetWangAttributeData
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData.OnPropertyChanging Method

FreehandDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandData Events

The FreehandData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

FreehandData Class
Atalasoft.Annotate Namespace


FreehandLineType Enumeration

Specifies the line type used for freehand annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FreehandLineType
Public Enumeration FreehandLineType
Members
Member name | Description
Straight | The points are joined with straight lines.
Curves | The points are joined with curved lines.
Beziers | The points are used for Bezier curves.
See Also

Reference

Atalasoft.Annotate Namespace


HotSpotData Class

Data for a HotSpotAnnotation object.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateHotSpotData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HotSpotData : AnnotationData,
    ISerializable, ICloneable
<SerializableAttribute>
Public Class HotSpotData
    Inherits AnnotationData
    Implements ISerializable, ICloneable

The HotSpotData type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotData | Creates a new instance of HotSpotData.
Public method | HotSpotData(RectangleF, AnnotationBrush) | Creates a new instance of HotSpotData specifying the rectangle bounds fill.
Public method | HotSpotData(RectangleF, AnnotationPen) | Creates a new instance of HotSpotData specifying the rectangle bounds and outline.
Public method | HotSpotData(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotData from serialized information.
Public method | HotSpotData(RectangleF, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotData specifying the rectangle bounds, fill and outline.
Public method | HotSpotData(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotData specifying the rectangle bounds, active and inactive fill, and outline.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the hotspot is active.
Public property | ActiveFill | Gets or sets the fill used when the HotSpot is active.
Public property | ActiveOutline | Gets or sets the outline used when the HotSpot is active.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used when the HotSpot is not active.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline used when the HotSpot is inactive.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this HotSpotData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another HotSpotData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this HotSpotData. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


HotSpotData Constructor

Constructs a HotSpotData.
Overload List
 | Name | Description
Public method | HotSpotData | Creates a new instance of HotSpotData.
Public method | HotSpotData(RectangleF, AnnotationBrush) | Creates a new instance of HotSpotData specifying the rectangle bounds fill.
Public method | HotSpotData(RectangleF, AnnotationPen) | Creates a new instance of HotSpotData specifying the rectangle bounds and outline.
Public method | HotSpotData(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotData from serialized information.
Public method | HotSpotData(RectangleF, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotData specifying the rectangle bounds, fill and outline.
Public method | HotSpotData(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotData specifying the rectangle bounds, active and inactive fill, and outline.
Top
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData Constructor

Creates a new instance of HotSpotData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotData()
Public Sub New
See Also

Reference

HotSpotData Class
HotSpotData Overload
Atalasoft.Annotate Namespace


HotSpotData Constructor (RectangleF, AnnotationBrush)

Creates a new instance of HotSpotData specifying the rectangle bounds fill.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotData(
    RectangleF rectangle,
    AnnotationBrush fill
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when not active.
See Also

Reference

HotSpotData Class
HotSpotData Overload
Atalasoft.Annotate Namespace


HotSpotData Constructor (RectangleF, AnnotationPen)

Creates a new instance of HotSpotData specifying the rectangle bounds and outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotData(
    RectangleF rectangle,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when not active.
See Also

Reference

HotSpotData Class
HotSpotData Overload
Atalasoft.Annotate Namespace


HotSpotData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HotSpotData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information of this object.
context
Type: System.Runtime.SerializationStreamingContext
A context containing information about this object.
See Also

Reference

HotSpotData Class
HotSpotData Overload
Atalasoft.Annotate Namespace


HotSpotData Constructor (RectangleF, AnnotationBrush, AnnotationPen)

Creates a new instance of HotSpotData specifying the rectangle bounds, fill and outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotData(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when not active.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when not active.
See Also

Reference

HotSpotData Class
HotSpotData Overload
Atalasoft.Annotate Namespace


HotSpotData Constructor (RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen)

Creates a new instance of HotSpotData specifying the rectangle bounds, active and inactive fill, and outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotData(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush activeFill,
    AnnotationPen activeOutline
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    activeFill As AnnotationBrush,
    activeOutline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when not active.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when not active.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when the annotation is active.
activeOutline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when the annotation is active.
See Also

Reference

HotSpotData Class
HotSpotData Overload
Atalasoft.Annotate Namespace


HotSpotData Properties

The HotSpotData type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the hotspot is active.
Public property | ActiveFill | Gets or sets the fill used when the HotSpot is active.
Public property | ActiveOutline | Gets or sets the outline used when the HotSpot is active.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used when the HotSpot is not active.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline used when the HotSpot is inactive.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.Active Property

HotSpotDataActive Property

Gets or sets a value indicating whether the hotspot is active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the hotspot is active.
Remarks
When the hotspot is active, the ActiveFill brush and ActiveOutline pen are used to provide a visual indication of the hotspot area.
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.ActiveFill Property

HotSpotDataActiveFill Property

Gets or sets the fill used when the HotSpot is active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush ActiveFill { get; set; }
Public Property ActiveFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The active fill.
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.ActiveOutline Property

HotSpotDataActiveOutline Property

Gets or sets the outline used when the HotSpot is active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen ActiveOutline { get; set; }
Public Property ActiveOutline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The active outline.
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.Bounds Property

HotSpotDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.Fill Property

HotSpotDataFill Property

Gets or sets the fill used when the HotSpot is not active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The inactive fill.
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.Outline Property

HotSpotDataOutline Property

Gets or sets the outline used when the HotSpot is inactive.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The inactive outline.
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData Methods

The HotSpotData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this HotSpotData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another HotSpotData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this HotSpotData. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.Clone Method

HotSpotDataClone Method

Creates a copy of this HotSpotData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.CloneBaseData Method

HotSpotDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.Equals Method

HotSpotDataEquals Method

Determines if another HotSpotData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An HotSpotData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.GetHashCode Method

HotSpotDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData.GetObjectData Method

HotSpotDataGetObjectData Method

Fills a SerializationInfo object with information about this HotSpotData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotData Events

The HotSpotData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

HotSpotData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData Class

Data for a hot spot freehand annotation.
Data for a HotSpotFreehandAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotatePointBaseData
Atalasoft.AnnotateHotSpotFreehandData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HotSpotFreehandData : PointBaseData,
    ISerializable, ICloneable
<SerializableAttribute>
Public Class HotSpotFreehandData
    Inherits PointBaseData
    Implements ISerializable, ICloneable

The HotSpotFreehandData type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotFreehandData | Creates a new instance of HotSpotFreehandData.
Public method | HotSpotFreehandData(PointF) | Creates a new instance of HotSpotFreehandData specifying the initial points.
Public method | HotSpotFreehandData(AnnotationBrush) | Creates a new instance of HotSpotFreehandData specifying the fill.
Public method | HotSpotFreehandData(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotFreehandData from serialized information.
Public method | HotSpotFreehandData(AnnotationBrush, AnnotationBrush) | Creates a new instance of HotSpotFreehandData specifying the fill and active fill.
Public method | HotSpotFreehandData(AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandData specifying the outline, fill and initial points.
Public method | HotSpotFreehandData(AnnotationBrush, AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandData specifying the outline, fill and initial points.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the hotspot is active.
Public property | ActiveFill | Gets or sets the fill used when the HotSpot is active.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used when the HotSpot is not active.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineType | Gets or sets the FreehandLineType used for the lines or curves of this annotation.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another HotSpotFreehandData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
HotSpotFreehandAnnotation Class


HotSpotFreehandData Constructor

Constructs a HotSpotFreehandData.
Overload List
 | Name | Description
Public method | HotSpotFreehandData | Creates a new instance of HotSpotFreehandData.
Public method | HotSpotFreehandData(PointF) | Creates a new instance of HotSpotFreehandData specifying the initial points.
Public method | HotSpotFreehandData(AnnotationBrush) | Creates a new instance of HotSpotFreehandData specifying the fill.
Public method | HotSpotFreehandData(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotFreehandData from serialized information.
Public method | HotSpotFreehandData(AnnotationBrush, AnnotationBrush) | Creates a new instance of HotSpotFreehandData specifying the fill and active fill.
Public method | HotSpotFreehandData(AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandData specifying the outline, fill and initial points.
Public method | HotSpotFreehandData(AnnotationBrush, AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandData specifying the outline, fill and initial points.
Top
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor

Creates a new instance of HotSpotFreehandData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData()
Public Sub New
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor (PointF[])

HotSpotFreehandData Constructor (PointF)

Creates a new instance of HotSpotFreehandData specifying the initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData(
    PointF[] points
)
Public Sub New (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The initial points for the hotspot. These points must be in annotation space.
Exceptions
Exception | Condition
 | Thrown if the points parameter is null.
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor (AnnotationBrush)

Creates a new instance of HotSpotFreehandData specifying the fill.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData(
    AnnotationBrush fill
)
Public Sub New (
    fill As AnnotationBrush
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the fill.
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HotSpotFreehandData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information for this object.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context for this object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor (AnnotationBrush, AnnotationBrush)

Creates a new instance of HotSpotFreehandData specifying the fill and active fill.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData(
    AnnotationBrush fill,
    AnnotationBrush activeFill
)
Public Sub New (
    fill As AnnotationBrush,
    activeFill As AnnotationBrush
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the fill.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the fill when the hotspot is active.
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor (AnnotationBrush, PointF[])

HotSpotFreehandData Constructor (AnnotationBrush, PointF)

Creates a new instance of HotSpotFreehandData specifying the outline, fill and initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData(
    AnnotationBrush fill,
    params PointF[] points
)
Public Sub New (
    fill As AnnotationBrush,
    ParamArray points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the hotspot.
points
Type: System.DrawingPointF
The initial point for the hotspot. These points must be in annotation space.
Exceptions
Exception | Condition
 | Thrown if a parameter is null.
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Constructor (AnnotationBrush, AnnotationBrush, PointF[])

HotSpotFreehandData Constructor (AnnotationBrush, AnnotationBrush, PointF)

Creates a new instance of HotSpotFreehandData specifying the outline, fill and initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandData(
    AnnotationBrush fill,
    AnnotationBrush activeFill,
    params PointF[] points
)
Public Sub New (
    fill As AnnotationBrush,
    activeFill As AnnotationBrush,
    ParamArray points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the hotspot.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when the hotspot is active.
points
Type: System.DrawingPointF
The initial points for the hotspot. These points must be in annotation space.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

HotSpotFreehandData Class
HotSpotFreehandData Overload
Atalasoft.Annotate Namespace


HotSpotFreehandData Properties

The HotSpotFreehandData type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the hotspot is active.
Public property | ActiveFill | Gets or sets the fill used when the HotSpot is active.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used when the HotSpot is not active.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineType | Gets or sets the FreehandLineType used for the lines or curves of this annotation.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.Active Property

HotSpotFreehandDataActive Property

Gets or sets a value indicating whether the hotspot is active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the hotspot is active.
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.ActiveFill Property

HotSpotFreehandDataActiveFill Property

Gets or sets the fill used when the HotSpot is active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush ActiveFill { get; set; }
Public Property ActiveFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The active fill.
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.Fill Property

HotSpotFreehandDataFill Property

Gets or sets the fill used when the HotSpot is not active.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The inactive fill.
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.LineType Property

HotSpotFreehandDataLineType Property

Gets or sets the FreehandLineType used for the lines or curves of this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandLineType LineType { get; set; }
Public Property LineType As FreehandLineType
    Get
    Set

Property Value

Type: FreehandLineType
The line type for this annotation.
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData Methods

The HotSpotFreehandData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another HotSpotFreehandData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.Clone Method

HotSpotFreehandDataClone Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
ICloneableClone
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.CloneBaseData Method

HotSpotFreehandDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from PointBaseData.
Remarks
This method should be called by classes that derive from PointBaseData when they need to create a clone of the object.
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.Equals Method

HotSpotFreehandDataEquals Method

Determines if another HotSpotFreehandData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An HotSpotFreehandData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.GetHashCode Method

HotSpotFreehandDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData.GetObjectData Method

HotSpotFreehandDataGetObjectData Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


HotSpotFreehandData Events

The HotSpotFreehandData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

HotSpotFreehandData Class
Atalasoft.Annotate Namespace


IAnnotationLock Interface

The interface used to define the security when locking annotations is required.
The interface used to define the security when locking annotations is required.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationLock : ISerializable
Public Interface IAnnotationLock
    Inherits ISerializable

The IAnnotationLock type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the encrypted key used to lock or unlock the annotation.
Public property | Locked | Gets a value indicating whether the object is currently locked.
Public property | LockedImage | Gets or sets the image used to indicate that an annotation is locked.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this IAnnotationLock.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | Lock | Locks the annotation without a password.
Public method | Lock(String) | Locks the annotation with a password.
Public method | Unlock | Unlocks an annotation previously locked with the Lock method.
Public method | Unlock(String) | Unlocks an annotation that has be locked with a password.
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property has been changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
See Also

Reference

Atalasoft.Annotate Namespace


IAnnotationLock Properties

The IAnnotationLock type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the encrypted key used to lock or unlock the annotation.
Public property | Locked | Gets a value indicating whether the object is currently locked.
Public property | LockedImage | Gets or sets the image used to indicate that an annotation is locked.
Top
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.EncryptionKey Property

IAnnotationLockEncryptionKey Property

Gets or sets the encrypted key used to lock or unlock the annotation.
Gets or sets the encrypted key used to lock or unlock the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string EncryptionKey { get; }
ReadOnly Property EncryptionKey As String
    Get

Property Value

Type: String
The encrypted key of a locked annotation.

Property Value

Type: String
The encrypted key of a locked annotation.
Remarks
This key is stored into the serialized annotation data to allow the annotations to remain locked when deserialized at a later time.
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.Locked Property

IAnnotationLockLocked Property

Gets a value indicating whether the object is currently locked.
Gets a value indicating whether the object is currently locked.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Locked { get; }
ReadOnly Property Locked As Boolean
    Get

Property Value

Type: Boolean
Indicates if the annotation is locked.

Property Value

Type: Boolean
Indicates if the annotation is locked.
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.LockedImage Property

IAnnotationLockLockedImage Property

Gets or sets the image used to indicate that an annotation is locked.
Gets or sets the image used to indicate that an annotation is locked.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationImage LockedImage { get; set; }
Property LockedImage As AnnotationImage
    Get
    Set

Property Value

Type: AnnotationImage
The image drawn on a locked annotation.

Property Value

Type: AnnotationImage
The image drawn on a locked annotation.
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock Methods

The IAnnotationLock type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this IAnnotationLock.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | Lock | Locks the annotation without a password.
Public method | Lock(String) | Locks the annotation with a password.
Public method | Unlock | Unlocks an annotation previously locked with the Lock method.
Public method | Unlock(String) | Unlocks an annotation that has be locked with a password.
Top
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.Clone Method

IAnnotationLockClone Method

Creates a copy of this IAnnotationLock.
Creates a copy of this IAnnotationLock.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IAnnotationLock Clone()
Function Clone As IAnnotationLock

Return Value

Type: IAnnotationLock
A copy of the security lock.

Return Value

Type: IAnnotationLock
A copy of the security lock.
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.Lock Method

IAnnotationLockLock Method

These methods lock an annotation.
These methods lock an annotation.
Overload List
 | Name | Description
Public method | Lock | Locks the annotation without a password.
Public method | Lock(String) | Locks the annotation with a password.
Top
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.Lock Method

IAnnotationLockLock Method

Locks the annotation without a password.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Lock()
Sub Lock
Remarks
This is useful when there is a need to keep the object from being modified.
See Also

Reference

IAnnotationLock Interface
Lock Overload
Atalasoft.Annotate Namespace


IAnnotationLock.Lock Method (String)

IAnnotationLockLock Method (String)

Locks the annotation with a password.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Lock(
    string password
)
Sub Lock (
    password As String
)

Parameters

password
Type: SystemString
A password that will be required to unlock the annotation.
See Also

Reference

IAnnotationLock Interface
Lock Overload
Atalasoft.Annotate Namespace


IAnnotationLock.Unlock Method

IAnnotationLockUnlock Method

These methods unlock a previously locked annotation.
These methods unlock a previously locked annotation.
Overload List
 | Name | Description
Public method | Unlock | Unlocks an annotation previously locked with the Lock method.
Public method | Unlock(String) | Unlocks an annotation that has be locked with a password.
Top
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.Unlock Method

IAnnotationLockUnlock Method

Unlocks an annotation previously locked with the Lock method.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Unlock()
Function Unlock As Boolean

Return Value

Type: Boolean
See Also

Reference

IAnnotationLock Interface
Unlock Overload
Atalasoft.Annotate Namespace


IAnnotationLock.Unlock Method (String)

IAnnotationLockUnlock Method (String)

Unlocks an annotation that has be locked with a password.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Unlock(
    string password
)
Function Unlock (
    password As String
) As Boolean

Parameters

password
Type: SystemString
The password required to unlock the annotation.

Return Value

Type: Boolean
True if the unlock was successful.
See Also

Reference

IAnnotationLock Interface
Unlock Overload
Atalasoft.Annotate Namespace


IAnnotationLock Events

The IAnnotationLock type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property of the AnnotationBrush if modified.
Public event | PropertyChanged | Raised when a property has been changed.
Public event | PropertyChanging | Raised just before a property is about to be modified.
Top
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.AnnotationControllerNotification Event

IAnnotationLockAnnotationControllerNotification Event

Raised after a property of the AnnotationBrush if modified.
Raised after a property of the AnnotationBrush if modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.PropertyChanged Event

IAnnotationLockPropertyChanged Event

Raised when a property has been changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event AnnotationPropertyChangedEventHandler PropertyChanged
Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAnnotationLock.PropertyChanging Event

IAnnotationLockPropertyChanging Event

Raised just before a property is about to be modified.
Raised just before a property is about to be modified.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event AnnotationPropertyChangingEventHandler PropertyChanging
Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
Remarks
Primarily this event is used for internal notification of property changes.
Remarks
Primarily this event is used for internal notification of property changes.
See Also

Reference

IAnnotationLock Interface
Atalasoft.Annotate Namespace


IAttachableAnnotation Interface

This interface is implemented by annotation data classes, such as CommentData, that can be attached to other annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAttachableAnnotation
Public Interface IAttachableAnnotation

The IAttachableAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Guid | Gets a Guid used to identify the annotation.
Public property | Parent | Gets or sets the annotation this annotation is attached to, if any.
Top
See Also

Reference

Atalasoft.Annotate Namespace


IAttachableAnnotation Properties

The IAttachableAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Guid | Gets a Guid used to identify the annotation.
Public property | Parent | Gets or sets the annotation this annotation is attached to, if any.
Top
See Also

Reference

IAttachableAnnotation Interface
Atalasoft.Annotate Namespace


IAttachableAnnotation.Guid Property

IAttachableAnnotationGuid Property

Gets a Guid used to identify the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Guid Guid { get; }
ReadOnly Property Guid As Guid
    Get

Property Value

Type: Guid
A Guid used to identify the annotation.
See Also

Reference

IAttachableAnnotation Interface
Atalasoft.Annotate Namespace


IAttachableAnnotation.Parent Property

IAttachableAnnotationParent Property

Gets or sets the annotation this annotation is attached to, if any.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationData Parent { get; set; }
Property Parent As AnnotationData
    Get
    Set

Property Value

Type: AnnotationData
The annotation this annotation is attached to or null (Nothing in VB) if it is a standalone annotation.
See Also

Reference

IAttachableAnnotation Interface
Atalasoft.Annotate Namespace


IHighlighter Interface

This interface is used by AnnotationData objects to indicate that they have highlighter support. This information is used by the AnnotateViewer when burning annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IHighlighter
Public Interface IHighlighter

The IHighlighter type exposes the following members.

Properties
 | Name | Description
Public property | Translucent | Gets a value indicating whether the annotation is a highlighter.
Top
See Also

Reference

Atalasoft.Annotate Namespace


IHighlighter Properties

The IHighlighter type exposes the following members.

Properties
 | Name | Description
Public property | Translucent | Gets a value indicating whether the annotation is a highlighter.
Top
See Also

Reference

IHighlighter Interface
Atalasoft.Annotate Namespace


IHighlighter.Translucent Property

IHighlighterTranslucent Property

Gets a value indicating whether the annotation is a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Translucent { get; }
ReadOnly Property Translucent As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the annotation is a highlighter.
See Also

Reference

IHighlighter Interface
Atalasoft.Annotate Namespace


IWangCompatible Interface

This interface is used to indicate that an AnnotationData object is WANG compatible.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWangCompatible
Public Interface IWangCompatible

The IWangCompatible type exposes the following members.

Methods
 | Name | Description
Public method | GetWangAttributeData | Returns a WangAttributeData object containing information about the annotation to be formatted as WANG data.
Top
Remarks

The WangFormatter will only convert AnnotationData objects that implement the IWangCompatible interface. Below is a list of classes which implement this interface:

  • EmbeddedImageData
  • FreehandData
  • LineData
  • LinesData
  • RectangleData
  • ReferencedImageData
  • TextData

Note to implementors:
In addition to the GetWangAttributeData method there must be a constructor that takes a WangAttributeData object in the class to allow the WangFormatter to deserialize the data.

See Also

Reference

Atalasoft.Annotate Namespace


IWangCompatible Methods

The IWangCompatible type exposes the following members.

Methods
 | Name | Description
Public method | GetWangAttributeData | Returns a WangAttributeData object containing information about the annotation to be formatted as WANG data.
Top
See Also

Reference

IWangCompatible Interface
Atalasoft.Annotate Namespace


IWangCompatible.GetWangAttributeData Method

IWangCompatibleGetWangAttributeData Method

Returns a WangAttributeData object containing information about the annotation to be formatted as WANG data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
WangAttributeData GetWangAttributeData()
Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData object containing the information required to generate WANG data.
Remarks

The WangFormatter will call this method when serializing the AnnotationData.

Note to implementors:,In addition to the GetWangAttributeData method there must be a constructor that takes a WangAttributeData object in the class to allow the WangFormatter to deserialize the data.

See Also

Reference

IWangCompatible Interface
Atalasoft.Annotate Namespace


LayerData Class

The LayerData class is used to hold a collection of AnnotationData objects, including other LayerData objects, allowing the annotations to be organized into layers.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateLayerData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LayerData : AnnotationData, ICloneable,
    IDeserializationCallback
<SerializableAttribute>
Public Class LayerData
    Inherits AnnotationData
    Implements ICloneable, IDeserializationCallback

The LayerData type exposes the following members.

Constructors
 | Name | Description
Public method | LayerData | Creates a new instance of LayerData.
Public method | LayerData(SerializationInfo, StreamingContext) | Creates a new instance of LayerData from serialized data.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | GroupAnnotation | Gets or sets a value indicating whether the annotations in this layer are acting as a single group.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Items | Gets an AnnotationDataCollection used to hold the data for this layer.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | SerializeCollection | Gets or sets a value indicating whether the AnnotationDataCollection is serialized along with the LayerData object.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this LayerData object. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LayerData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetAttachments | Returns an IEumerable of AnnotationData for all annotations attached to the specified parent.
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this LayerData. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | (Overrides AnnotationDataMirror(MirrorDirection, Boolean).)
Protected method | OnAnnotationControllerNotification | (Overrides AnnotationDataOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnLocationChanged | (Overrides AnnotationDataOnLocationChanged(AnnotationLocationChangedEventArgs).)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | (Overrides AnnotationDataOnRotationChanged(EventArgs).)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | (Overrides AnnotationDataRotate(Single).)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
Examples
The code below creates a LayerData object and adds a couple AnnotationData objects in addition to a sub layer.
LayerDataExample
Copy
LayerData mainLayer = new LayerData();

// Add a couple AnnotationData objects.
mainLayer.Items.Add(new EllipseData(new RectangleF(120, 12, 90, 180), new AnnotationBrush(Color.Red)));
mainLayer.Items.Add(new LineData(new AnnotationPen(Color.Blue, 2), new PointF(30, 30), new PointF(180, 180)));

// Add a sub layer object.
LayerData subLayer = new LayerData();
subLayer.Items.Add(new RectangleData(new RectangleF(10, 20, 120, 80), new AnnotationBrush(Color.BlueViolet)));
subLayer.Items.Add(new TextData("My TextData Object"));
mainLayer.Items.Add(subLayer);
LayerDataExampleVB
Copy
Dim mainLayer As LayerData =  New LayerData()

' Add a couple AnnotationData objects.
mainLayer.Items.Add(New EllipseData(New RectangleF(120, 12, 90, 180), New AnnotationBrush(Color.Red)))
mainLayer.Items.Add(New LineData(New AnnotationPen(Color.Blue, 2), New PointF(30, 30), New PointF(180, 180)))

' Add a sub layer object.
Dim subLayer As LayerData =  New LayerData()
subLayer.Items.Add(New RectangleData(New RectangleF(10, 20, 120, 80), New AnnotationBrush(Color.BlueViolet)))
subLayer.Items.Add(New TextData("My TextData Object"))
mainLayer.Items.Add(subLayer)
See Also

Reference

Atalasoft.Annotate Namespace


LayerData Constructor

Constructs a LayerData.
Overload List
 | Name | Description
Public method | LayerData | Creates a new instance of LayerData.
Public method | LayerData(SerializationInfo, StreamingContext) | Creates a new instance of LayerData from serialized data.
Top
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData Constructor

Creates a new instance of LayerData.
Creates a new instance of LayerData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerData()
Public Sub New
See Also

Reference

LayerData Class
LayerData Overload
Atalasoft.Annotate Namespace


LayerData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LayerData from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this LayerData.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

LayerData Class
LayerData Overload
Atalasoft.Annotate Namespace


LayerData Properties

The LayerData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | GroupAnnotation | Gets or sets a value indicating whether the annotations in this layer are acting as a single group.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Items | Gets an AnnotationDataCollection used to hold the data for this layer.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | SerializeCollection | Gets or sets a value indicating whether the AnnotationDataCollection is serialized along with the LayerData object.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.Bounds Property

LayerDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.GroupAnnotation Property

LayerDataGroupAnnotation Property

Gets or sets a value indicating whether the annotations in this layer are acting as a single group.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GroupAnnotation { get; set; }
Public Property GroupAnnotation As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this layer is a group.
Remarks
Setting this property to true will allow all contained annotations to be moved and resized together rather than separately.
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.Items Property

LayerDataItems Property

Gets an AnnotationDataCollection used to hold the data for this layer.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataCollection Items { get; }
Public ReadOnly Property Items As AnnotationDataCollection
    Get

Property Value

Type: AnnotationDataCollection
An AnnotationDataCollection for this layer.
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.SerializeCollection Property

LayerDataSerializeCollection Property

Gets or sets a value indicating whether the AnnotationDataCollection is serialized along with the LayerData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SerializeCollection { get; set; }
Public Property SerializeCollection As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the AnnotationDataCollection should be serialized.
Remarks
This property can be used to prevent the entire collection of AnnotationData objects from being serialized when the GetObjectData(SerializationInfo, StreamingContext) method is called.
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData Methods

The LayerData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this LayerData object. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LayerData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetAttachments | Returns an IEumerable of AnnotationData for all annotations attached to the specified parent.
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this LayerData. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | (Overrides AnnotationDataMirror(MirrorDirection, Boolean).)
Protected method | OnAnnotationControllerNotification | (Overrides AnnotationDataOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnLocationChanged | (Overrides AnnotationDataOnLocationChanged(AnnotationLocationChangedEventArgs).)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | (Overrides AnnotationDataOnRotationChanged(EventArgs).)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | (Overrides AnnotationDataRotate(Single).)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.Clone Method

LayerDataClone Method

Creates a copy of this LayerData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
ICloneableClone
Remarks
A clone of every AnnotationData in the layer is also created in this process.
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.CloneBaseData Method

LayerDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.Equals Method

LayerDataEquals Method

Determines if another LayerData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An LayerData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.GetAttachments Method

LayerDataGetAttachments Method

Returns an IEumerable of AnnotationData for all annotations attached to the specified parent.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<AnnotationData> GetAttachments(
    AnnotationData parent
)
Public Function GetAttachments (
    parent As AnnotationData
) As IEnumerable(Of AnnotationData)

Parameters

parent
Type: Atalasoft.AnnotateAnnotationData
The parent annotation.

Return Value

Type: IEnumerable AnnotationData
An IEumerable of AnnotationData for all annotations attached to the specified parent.
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.GetHashCode Method

LayerDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.GetObjectData Method

LayerDataGetObjectData Method

Fills a SerializationInfo object with information about this LayerData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo where information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.Mirror Method

LayerDataMirror Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Mirror(
    MirrorDirection direction,
    bool maintainPosition
)
Public Overrides Sub Mirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
maintainPosition
Type: SystemBoolean
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.OnAnnotationControllerNotification Method

LayerDataOnAnnotationControllerNotification Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overrides Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.OnDeserialization Method

LayerDataOnDeserialization Method

Called after an object has been fully deserialized by a serialization formatter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
This parameter is not used and will be null (Nothing in VB).

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.OnLocationChanged Method

LayerDataOnLocationChanged Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLocationChanged(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnLocationChanged (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.OnPropertyChanging Method

LayerDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.OnRotationChanged Method

LayerDataOnRotationChanged Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRotationChanged(
    EventArgs e
)
Protected Overrides Sub OnRotationChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.OnSizeChanged Method

LayerDataOnSizeChanged Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overrides Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData.Rotate Method

LayerDataRotate Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Rotate(
    float degrees
)
Public Overrides Sub Rotate (
    degrees As Single
)

Parameters

degrees
Type: SystemSingle
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LayerData Events

The LayerData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

LayerData Class
Atalasoft.Annotate Namespace


LineData Class

This class holds data for the LineAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateLineData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LineData : AnnotationData, ISerializable,
    ICloneable, IWangCompatible, IHighlighter
<SerializableAttribute>
Public Class LineData
    Inherits AnnotationData
    Implements ISerializable, ICloneable, IWangCompatible, IHighlighter

The LineData type exposes the following members.

Constructors
 | Name | Description
Public method | LineData | Creates a new instance of LineData.
Public method | LineData(AnnotationPen) | Creates a new instance of LineData specifying the outline.
Public method | LineData(WangAttributeData) | Creates a new instance of LineData from a WangAttributeData object.
Public method | LineData(SerializationInfo, StreamingContext) | Creates a new instance of LineData from serialized information.
Public method | LineData(AnnotationPen, Boolean) | Creates a new instance of LineData specifying the outline and translucency.
Public method | LineData(AnnotationPen, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineData specifying the outline, starting and ending points.
Public method | LineData(PointF, PointF, AnnotationPen, Boolean) | Creates a new instance of LineData specifying the start point, end point, outline and translucency.
Public method | LineData(AnnotationPen, PointF, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineData specifying the outline, starting and ending points.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | EndPoint | Gets or sets the ending point for the line.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for the LineData.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | StartPoint | Gets or sets the starting point for the line.
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether the line is drawn as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this LineData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LineData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | Fills a SerializationInfo object with data describing this LineData. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ResizeToBounds | Resizes this LineData object to fit within the given bounds
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
Remarks
This class is used by the LineAnnotation object.
See Also

Reference

Atalasoft.Annotate Namespace
LineAnnotation Class


LineData Constructor

Constructs a LineData.
Overload List
 | Name | Description
Public method | LineData | Creates a new instance of LineData.
Public method | LineData(AnnotationPen) | Creates a new instance of LineData specifying the outline.
Public method | LineData(WangAttributeData) | Creates a new instance of LineData from a WangAttributeData object.
Public method | LineData(SerializationInfo, StreamingContext) | Creates a new instance of LineData from serialized information.
Public method | LineData(AnnotationPen, Boolean) | Creates a new instance of LineData specifying the outline and translucency.
Public method | LineData(AnnotationPen, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineData specifying the outline, starting and ending points.
Public method | LineData(PointF, PointF, AnnotationPen, Boolean) | Creates a new instance of LineData specifying the start point, end point, outline and translucency.
Public method | LineData(AnnotationPen, PointF, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineData specifying the outline, starting and ending points.
Top
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData Constructor

Creates a new instance of LineData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineData()
Public Sub New
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (AnnotationPen)

Creates a new instance of LineData specifying the outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineData(
    AnnotationPen outline
)
Public Sub New (
    outline As AnnotationPen
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (WangAttributeData)

Creates a new instance of LineData from a WangAttributeData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineData(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
The WangAttributeData containing information about this annotation.
Remarks
This annotation requires the Bounds, Color1 and Points properties of the WangAttributeData.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LineData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this LineData.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext of this information.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (AnnotationPen, Boolean)

Creates a new instance of LineData specifying the outline and translucency.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineData(
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (AnnotationPen, PointF, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LineData specifying the outline, starting and ending points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)]
public LineData(
    AnnotationPen outline,
    PointF startPoint,
    PointF endPoint
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    startPoint As PointF,
    endPoint As PointF
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
startPoint
Type: System.DrawingPointF
The starting point of the line.
endPoint
Type: System.DrawingPointF
The ending point of the line.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (PointF, PointF, AnnotationPen, Boolean)

Creates a new instance of LineData specifying the start point, end point, outline and translucency.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineData(
    PointF startPoint,
    PointF endPoint,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

startPoint
Type: System.DrawingPointF
The starting point of the line.
endPoint
Type: System.DrawingPointF
The ending point of the line.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Constructor (AnnotationPen, PointF, PointF, Boolean)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LineData specifying the outline, starting and ending points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)]
public LineData(
    AnnotationPen outline,
    PointF startPoint,
    PointF endPoint,
    bool translucent
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    startPoint As PointF,
    endPoint As PointF,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
startPoint
Type: System.DrawingPointF
The starting point of the line.
endPoint
Type: System.DrawingPointF
The ending point of the line.
translucent
Type: SystemBoolean
A value indicating if this annotation should act as a highlighter.
See Also

Reference

LineData Class
LineData Overload
Atalasoft.Annotate Namespace


LineData Properties

The LineData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | EndPoint | Gets or sets the ending point for the line.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for the LineData.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | StartPoint | Gets or sets the starting point for the line.
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether the line is drawn as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.Bounds Property

LineDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.EndPoint Property

LineDataEndPoint Property

Gets or sets the ending point for the line.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF EndPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property EndPoint As PointF
    Get
    Set

Property Value

Type: PointF
The ending point for the line in annotation space.
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.Outline Property

LineDataOutline Property

Gets or sets the outline for the LineData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the line.
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.StartPoint Property

LineDataStartPoint Property

Gets or sets the starting point for the line.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF StartPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property StartPoint As PointF
    Get
    Set

Property Value

Type: PointF
The starting point for the line in annotation space.
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.Translucent Property

LineDataTranslucent Property

Gets or sets a value indicating whether the line is drawn as a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if this annotation should act as a highlighter.

Implements

IHighlighterTranslucent
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument method.
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData Methods

The LineData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this LineData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LineData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | Fills a SerializationInfo object with data describing this LineData. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ResizeToBounds | Resizes this LineData object to fit within the given bounds
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.Clone Method

LineDataClone Method

Creates a copy of this LineData.
Creates a copy of this LineData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.CloneBaseData Method

LineDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.Equals Method

LineDataEquals Method

Determines if another LineData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An LineData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.GetHashCode Method

LineDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.GetLineCapBounds Method

LineDataGetLineCapBounds Method

Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override RectangleF GetLineCapBounds()
Protected Overrides Function GetLineCapBounds As RectangleF

Return Value

Type: RectangleF
The bounds for the line cap.
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.GetObjectData Method

LineDataGetObjectData Method

Fills a SerializationInfo object with data describing this LineData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.GetWangAttributeData Method

LineDataGetWangAttributeData Method

Returns a WangAttributeData object with information about this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData object containing information required for WANG serialization.

Implements

IWangCompatibleGetWangAttributeData
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.OnPropertyChanging Method

LineDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.OnSizeChanged Method

LineDataOnSizeChanged Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overrides Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData.ResizeToBounds Method

LineDataResizeToBounds Method

Resizes this LineData object to fit within the given bounds

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ResizeToBounds(
    RectangleF bounds
)
Public Overridable Sub ResizeToBounds (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LineData Events

The LineData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

LineData Class
Atalasoft.Annotate Namespace


LinesData Class

This class holds information for the LinesAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotatePointBaseData
Atalasoft.AnnotateLinesData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LinesData : PointBaseData, ISerializable,
    ICloneable, IWangCompatible, IHighlighter
<SerializableAttribute>
Public Class LinesData
    Inherits PointBaseData
    Implements ISerializable, ICloneable, IWangCompatible, IHighlighter

The LinesData type exposes the following members.

Constructors
 | Name | Description
Public method | LinesData | Creates a new instance of LinesData.
Public method | LinesData(AnnotationPen) | Creates a new instance of LinesData specifying the outline.
Public method | LinesData(SerializationInfo, StreamingContext) | Creates a new instance of LinesData from serialized information.
Public method | LinesData(AnnotationPen, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesData specifying the outline and end points.
Public method | LinesData(AnnotationPen, Boolean) | Creates a new instance of LinesData specifying the outline and translucency.
Public method | LinesData(AnnotationPen, PointF) | Obsolete. Creates a new instance of LinesData specifying the outline and an array of end points.
Public method | LinesData(PointF, AnnotationPen, Boolean) | Creates a new instance of LinesData specifying the end points, outline and translucency.
Public method | LinesData(AnnotationPen, PointFCollection, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesData specifying the outline, points and whether this annotation is a highlighter.
Public method | LinesData(AnnotationPen, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesData specifying the outline, an array of points and whether this annotation is a highlighter.
Public method | LinesData(PointFCollection, AnnotationPen, Boolean) | Creates a new instance of LinesData specifying the end points, outline and translucency.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for the LinesData object.
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether the line is drawn as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | Create a copy of this LinesData. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LinesData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | Fills the SerializationInfo object with data from this class. (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object describing this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
LinesAnnotation Class


LinesData Constructor

Constructs a LinesData.
Overload List
 | Name | Description
Public method | LinesData | Creates a new instance of LinesData.
Public method | LinesData(AnnotationPen) | Creates a new instance of LinesData specifying the outline.
Public method | LinesData(SerializationInfo, StreamingContext) | Creates a new instance of LinesData from serialized information.
Public method | LinesData(AnnotationPen, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesData specifying the outline and end points.
Public method | LinesData(AnnotationPen, Boolean) | Creates a new instance of LinesData specifying the outline and translucency.
Public method | LinesData(AnnotationPen, PointF) | Obsolete. Creates a new instance of LinesData specifying the outline and an array of end points.
Public method | LinesData(PointF, AnnotationPen, Boolean) | Creates a new instance of LinesData specifying the end points, outline and translucency.
Public method | LinesData(AnnotationPen, PointFCollection, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesData specifying the outline, points and whether this annotation is a highlighter.
Public method | LinesData(AnnotationPen, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesData specifying the outline, an array of points and whether this annotation is a highlighter.
Public method | LinesData(PointFCollection, AnnotationPen, Boolean) | Creates a new instance of LinesData specifying the end points, outline and translucency.
Top
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData Constructor

Creates a new instance of LinesData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesData()
Public Sub New
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (AnnotationPen)

Creates a new instance of LinesData specifying the outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesData(
    AnnotationPen outline
)
Public Sub New (
    outline As AnnotationPen
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LinesData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information containing data for this object.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext for this information.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (AnnotationPen, PointFCollection)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesData specifying the outline and end points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public LinesData(
    AnnotationPen outline,
    PointFCollection points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointFCollection
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the line end points. These must be specified in annotation space.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (AnnotationPen, Boolean)

Creates a new instance of LinesData specifying the outline and translucency.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesData(
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (AnnotationPen, PointF[])

LinesData Constructor (AnnotationPen, PointF)

Note: This API is now obsolete.

Creates a new instance of LinesData specifying the outline and an array of end points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public LinesData(
    AnnotationPen outline,
    PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: System.DrawingPointF
An array of end points for the LinesData. These must be specified in annotation space.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (PointF[], AnnotationPen, Boolean)

LinesData Constructor (PointF, AnnotationPen, Boolean)

Creates a new instance of LinesData specifying the end points, outline and translucency.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesData(
    PointF[] points,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointF(),
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: System.DrawingPointF
An array of end points for the lines. Theses must be specified in annotation space.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (AnnotationPen, PointFCollection, Boolean)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesData specifying the outline, points and whether this annotation is a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public LinesData(
    AnnotationPen outline,
    PointFCollection points,
    bool translucent
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointFCollection,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the line end points. These must be specified in annotation space.
translucent
Type: SystemBoolean
A value indicating whether this annotation is a highlighter.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (AnnotationPen, PointF[], Boolean)

LinesData Constructor (AnnotationPen, PointF, Boolean)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesData specifying the outline, an array of points and whether this annotation is a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public LinesData(
    AnnotationPen outline,
    PointF[] points,
    bool translucent
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointF(),
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: System.DrawingPointF
An array of end points for the LinesData. Theses must be specified in annotation space.
translucent
Type: SystemBoolean
A value indicating whether this annotation is a highlighter.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Constructor (PointFCollection, AnnotationPen, Boolean)

Creates a new instance of LinesData specifying the end points, outline and translucency.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesData(
    PointFCollection points,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointFCollection,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the line end points. These must be specified in annotation space.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

LinesData Class
LinesData Overload
Atalasoft.Annotate Namespace


LinesData Properties

The LinesData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for the LinesData object.
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether the line is drawn as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.Bounds Property

LinesDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.Outline Property

LinesDataOutline Property

Gets or sets the outline for the LinesData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the lines.
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.Translucent Property

LinesDataTranslucent Property

Gets or sets a value indicating whether the line is drawn as a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if this annotation should act as a highlighter.

Implements

IHighlighterTranslucent
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument method.
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData Methods

The LinesData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | Create a copy of this LinesData. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LinesData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | Fills the SerializationInfo object with data from this class. (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object describing this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.Clone Method

LinesDataClone Method

Create a copy of this LinesData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.CloneBaseData Method

LinesDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from PointBaseData.
Remarks
This method should be called by classes that derive from PointBaseData when they need to create a clone of the object.
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.Equals Method

LinesDataEquals Method

Determines if another LinesData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An LinesData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.GetHashCode Method

LinesDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.GetLineCapBounds Method

LinesDataGetLineCapBounds Method

Called to get the rectangle bounds of the line cap used in an AnnotationLineCap.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override RectangleF GetLineCapBounds()
Protected Overrides Function GetLineCapBounds As RectangleF

Return Value

Type: RectangleF
The bounds for the line cap.
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.GetObjectData Method

LinesDataGetObjectData Method

Fills the SerializationInfo object with data from this class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object that LinesData will be stored into.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.GetWangAttributeData Method

LinesDataGetWangAttributeData Method

Returns a WangAttributeData object describing this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData for this LinesData.

Implements

IWangCompatibleGetWangAttributeData
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData.OnPropertyChanging Method

LinesDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


LinesData Events

The LinesData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

LinesData Class
Atalasoft.Annotate Namespace


MirrorDirection Enumeration

Specifies the mirror direction.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MirrorDirection
Public Enumeration MirrorDirection
Members
Member name | Description
Horizontal | Mirror (flip) the annotation horizontally.
Vertical | Mirror (flip) the annotation vertically.
See Also

Reference

Atalasoft.Annotate Namespace


MirrorEventArgs Class

This class is used with the OnMirrored(MirrorEventArgs) method to provide information on the mirror action.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.AnnotateMirrorEventArgs

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MirrorEventArgs : EventArgs
Public Class MirrorEventArgs
    Inherits EventArgs

The MirrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MirrorEventArgs | Creates a new instance of MirrorEventArgs specifying the mirror direction and whether the annotation should maintain it's visual position.
Top
Properties
 | Name | Description
Public property | Direction | Gets the direction of the mirror operation.
Public property | MaintainPosition | Gets a value indicating whether the annotation should maintain its visual position.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


MirrorEventArgs Constructor

Creates a new instance of MirrorEventArgs specifying the mirror direction and whether the annotation should maintain it's visual position.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MirrorEventArgs(
    MirrorDirection direction,
    bool maintainPosition
)
Public Sub New (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The direction to mirror.
maintainPosition
Type: SystemBoolean
Indicates whether the annotation maintains its visual position. If true, the annotation's location will be changed to keep the annotation visually in the same location. If false, the annotation is flipped along its axis.
See Also

Reference

MirrorEventArgs Class
Atalasoft.Annotate Namespace


MirrorEventArgs Properties

The MirrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Gets the direction of the mirror operation.
Public property | MaintainPosition | Gets a value indicating whether the annotation should maintain its visual position.
Top
See Also

Reference

MirrorEventArgs Class
Atalasoft.Annotate Namespace


MirrorEventArgs.Direction Property

MirrorEventArgsDirection Property

Gets the direction of the mirror operation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MirrorDirection Direction { get; }
Public ReadOnly Property Direction As MirrorDirection
    Get

Property Value

Type: MirrorDirection
The mirror direction.
See Also

Reference

MirrorEventArgs Class
Atalasoft.Annotate Namespace


MirrorEventArgs.MaintainPosition Property

MirrorEventArgsMaintainPosition Property

Gets a value indicating whether the annotation should maintain its visual position.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MaintainPosition { get; }
Public ReadOnly Property MaintainPosition As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the visual position should be maintained.
Remarks
When this property is true, the annotation's location will be changed to keep the annotation visually in the same location. If false, the annotation is flipped along its axis.
See Also

Reference

MirrorEventArgs Class
Atalasoft.Annotate Namespace


MirrorEventArgs Methods

The MirrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MirrorEventArgs Class
Atalasoft.Annotate Namespace


MirrorEventHandler Delegate

This delegate is used for the Mirrored event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void MirrorEventHandler(
    Object sender,
    MirrorEventArgs e
)
Public Delegate Sub MirrorEventHandler (
    sender As Object,
    e As MirrorEventArgs
)

Parameters

sender
Type: SystemObject
The object sending this event.
e
Type: Atalasoft.AnnotateMirrorEventArgs
A MirrorEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate Namespace


OcrRegionData Class

This class holds information for the OcrRegionAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateOcrRegionData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrRegionData : AnnotationData,
    ISerializable, IWangCompatible
<SerializableAttribute>
Public Class OcrRegionData
    Inherits AnnotationData
    Implements ISerializable, IWangCompatible

The OcrRegionData type exposes the following members.

Constructors
 | Name | Description
Public method | OcrRegionData | Creates a new instance of OcrRegionData.
Public method | OcrRegionData(WangAttributeData) | Creates a new instance of OcrRegionData from WANG data.
Public method | OcrRegionData(SerializationInfo, StreamingContext) | Creates a new instance of OcrRegionData from serialization data.
Public method | OcrRegionData(RectangleF, Int32, Color) | Creates a new instance of OcrRegionData specifying the selection bounds, sequence number of color.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | Color | Gets or sets the color used for the selection.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | SequenceOrder | Gets or sets the sequence order value.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
 | Clone | Returns a copy of this annotation data. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
 | GetObjectData | Fills the SerializationInfo object with properties values for the base AnnotationData class. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object containing information about the annotation to be formatted as WANG data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


OcrRegionData Constructor

Constructs an OcrRegionData.
Overload List
 | Name | Description
Public method | OcrRegionData | Creates a new instance of OcrRegionData.
Public method | OcrRegionData(WangAttributeData) | Creates a new instance of OcrRegionData from WANG data.
Public method | OcrRegionData(SerializationInfo, StreamingContext) | Creates a new instance of OcrRegionData from serialization data.
Public method | OcrRegionData(RectangleF, Int32, Color) | Creates a new instance of OcrRegionData specifying the selection bounds, sequence number of color.
Top
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData Constructor

Creates a new instance of OcrRegionData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionData()
Public Sub New
See Also

Reference

OcrRegionData Class
OcrRegionData Overload
Atalasoft.Annotate Namespace


OcrRegionData Constructor (WangAttributeData)

Creates a new instance of OcrRegionData from WANG data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionData(
    WangAttributeData wangData
)
Public Sub New (
    wangData As WangAttributeData
)

Parameters

wangData
Type: Atalasoft.AnnotateWangAttributeData
The WangAttributeData containing information about this annotation.
See Also

Reference

OcrRegionData Class
OcrRegionData Overload
Atalasoft.Annotate Namespace


OcrRegionData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of OcrRegionData from serialization data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing the annotation data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the data.
See Also

Reference

OcrRegionData Class
OcrRegionData Overload
Atalasoft.Annotate Namespace


OcrRegionData Constructor (RectangleF, Int32, Color)

Creates a new instance of OcrRegionData specifying the selection bounds, sequence number of color.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionData(
    RectangleF bounds,
    int sequenceOrder,
    Color color
)
Public Sub New (
    bounds As RectangleF,
    sequenceOrder As Integer,
    color As Color
)

Parameters

bounds
Type: System.DrawingRectangleF
The annotation bounds.
sequenceOrder
Type: SystemInt32
The sequence number for this annotation. This value must be 1 or greater.
color
Type: System.DrawingColor
The color for the selection.
See Also

Reference

OcrRegionData Class
OcrRegionData Overload
Atalasoft.Annotate Namespace


OcrRegionData Properties

The OcrRegionData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | Color | Gets or sets the color used for the selection.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | SequenceOrder | Gets or sets the sequence order value.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.Color Property

OcrRegionDataColor Property

Gets or sets the color used for the selection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color used for the selection.
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.SequenceOrder Property

OcrRegionDataSequenceOrder Property

Gets or sets the sequence order value.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SequenceOrder { get; set; }
Public Property SequenceOrder As Integer
    Get
    Set

Property Value

Type: Int32
The sequence order.
Exceptions
Exception | Condition
 | Thrown if the value is less than 1.
Remarks

This value determines the order in which OCR regions should be processed. The first region must start with a value of 1.

See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData Methods

The OcrRegionData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
 | Clone | Returns a copy of this annotation data. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
 | GetObjectData | Fills the SerializationInfo object with properties values for the base AnnotationData class. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object containing information about the annotation to be formatted as WANG data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.Clone Method

OcrRegionDataClone Method

Returns a copy of this annotation data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this data.

Implements

ICloneableClone
Examples
AnnotationData Class
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.CloneBaseData Method

OcrRegionDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.Equals Method

OcrRegionDataEquals Method

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Remarks
Some unique properties are not compared, such as Name, CreationTime and ModifiedTime. All other properties, including transforms used for rendering, are compared.
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.GetHashCode Method

OcrRegionDataGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Remarks
This value is not guaranteed to be unique, but the same object instance will always return the same hash value.
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.GetObjectData Method

OcrRegionDataGetObjectData Method

Fills the SerializationInfo object with properties values for the base AnnotationData class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Examples
AnnotationData Class
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.GetWangAttributeData Method

OcrRegionDataGetWangAttributeData Method

Returns a WangAttributeData object containing information about the annotation to be formatted as WANG data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData object containing the information required to generate WANG data.

Implements

IWangCompatibleGetWangAttributeData
Remarks

The WangFormatter will call this method when serializing the AnnotationData.

Note to implementors:,In addition to the GetWangAttributeData method there must be a constructor that takes a WangAttributeData object in the class to allow the WangFormatter to deserialize the data.

See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData.OnPropertyChanging Method

OcrRegionDataOnPropertyChanging Method

Called just before a property value is changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs containing information about this change.
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


OcrRegionData Events

The OcrRegionData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

OcrRegionData Class
Atalasoft.Annotate Namespace


PointBaseData Class

This abstract class is used for annotations that require a series of points to define their shape.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotatePointBaseData
Atalasoft.AnnotateFreehandData
Atalasoft.AnnotateHotSpotFreehandData
Atalasoft.AnnotateLinesData
Atalasoft.AnnotatePolygonData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class PointBaseData : AnnotationData,
    ISerializable, ICloneable
<SerializableAttribute>
Public MustInherit Class PointBaseData
    Inherits AnnotationData
    Implements ISerializable, ICloneable

The PointBaseData type exposes the following members.

Constructors
 | Name | Description
Public method | PointBaseData | The default constructor of a PointBaseData object. PointBaseData is an abstract class and cannot be created directly.
Public method | PointBaseData(PointFCollection) | A constructor for the PointBaseData object specifying the PointFCollection used.
Public method | PointBaseData(SerializationInfo, StreamingContext) | A constructor for the PointBaseData object specifying the serialization information for this data.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Points | Gets a PointFCollection used to store the points for the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation.
 | Clone | Returns a copy of this annotation data. (Inherited from AnnotationData.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object for this data. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
Remarks
When creating a custom annotation that derives from Atalasoft.Annotate.UI.PointBaseAnnotation, the related AnnotationData object must derive form PointBaseData.
See Also

Reference

Atalasoft.Annotate Namespace


PointBaseData Constructor

Overload List
 | Name | Description
Public method | PointBaseData | The default constructor of a PointBaseData object. PointBaseData is an abstract class and cannot be created directly.
Public method | PointBaseData(PointFCollection) | A constructor for the PointBaseData object specifying the PointFCollection used.
Public method | PointBaseData(SerializationInfo, StreamingContext) | A constructor for the PointBaseData object specifying the serialization information for this data.
Top
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData Constructor

The default constructor of a PointBaseData object. PointBaseData is an abstract class and cannot be created directly.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointBaseData()
Public Sub New
See Also

Reference

PointBaseData Class
PointBaseData Overload
Atalasoft.Annotate Namespace


PointBaseData Constructor (PointFCollection)

A constructor for the PointBaseData object specifying the PointFCollection used.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointBaseData(
    PointFCollection points
)
Public Sub New (
    points As PointFCollection
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection for this object.
See Also

Reference

PointBaseData Class
PointBaseData Overload
Atalasoft.Annotate Namespace


PointBaseData Constructor (SerializationInfo, StreamingContext)

A constructor for the PointBaseData object specifying the serialization information for this data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointBaseData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PointBaseData Class
PointBaseData Overload
Atalasoft.Annotate Namespace


PointBaseData Properties

The PointBaseData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Points | Gets a PointFCollection used to store the points for the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData.Points Property

PointBaseDataPoints Property

Gets a PointFCollection used to store the points for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection Points { get; }
Public ReadOnly Property Points As PointFCollection
    Get

Property Value

Type: PointFCollection
A collection of PointF objects.
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData Methods

The PointBaseData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation.
 | Clone | Returns a copy of this annotation data. (Inherited from AnnotationData.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object for this data. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData.CalculateBounds Method

PointBaseDataCalculateBounds Method

Calculates the bounding rectangle of an annotation.
Overload List
 | Name | Description
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation.
Top
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData.CalculateBounds Method (AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean)

PointBaseDataCalculateBounds Method (AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean)

Calculates the bounding rectangle for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF CalculateBounds(
    AnnotationPen pen,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent,
    bool closed
)
Protected Function CalculateBounds (
    pen As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean,
    closed As Boolean
) As RectangleF

Parameters

pen
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the points.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The shadow for the annotation.
shadowOffset
Type: System.DrawingPointF
The shadow offset for the annotation.
translucent
Type: SystemBoolean
A value indicating whether the annotation is translucent.
closed
Type: SystemBoolean
A value indicating whether the annotation points form a closed shape.

Return Value

Type: RectangleF
The bounding rectangle for the annotation.
See Also

Reference

PointBaseData Class
CalculateBounds Overload
Atalasoft.Annotate Namespace


PointBaseData.CloneBaseData Method

PointBaseDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from PointBaseData.
Remarks
This method should be called by classes that derive from PointBaseData when they need to create a clone of the object.
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData.GetObjectData Method

PointBaseDataGetObjectData Method

Fills a SerializationInfo object for this data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData.GetPointBounds Method

PointBaseDataGetPointBounds Method

Gets a bounding rectangle which includes all of the Points

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF GetPointBounds()
Public Function GetPointBounds As RectangleF

Return Value

Type: RectangleF
A RectangleF that contains all of the Points
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData.OnSizeChanged Method

PointBaseDataOnSizeChanged Method

Called when the Size property has changed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overrides Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
An AnnotationSizeChangedEventArgs containing information about this change.
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointBaseData Events

The PointBaseData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

PointBaseData Class
Atalasoft.Annotate Namespace


PointFCollection Class

A collection of PointF objects used by points based annotations.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Utils.GeometryPointFCollection
Atalasoft.AnnotatePointFCollection

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PointFCollection : PointFCollection
<SerializableAttribute>
Public Class PointFCollection
    Inherits PointFCollection

The PointFCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PointFCollection | Creates a new instance of PointFCollection.
Public method | PointFCollection(PointF) | Creates a new instance of PointFCollection specifying the initial points.
Public method | PointFCollection(SerializationInfo, StreamingContext) | Creates a new instance of PointFCollection from serialized data.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | IgnoreChanges | Obsolete. Gets or sets a value indicating whether the PointFCollection event should not be raised.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | (Inherited from PointFCollection.)
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | RaiseCollectionChangedEvent | (Inherited from PointFCollection.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from PointFCollection.)
Public method | AddRange | (Inherited from PointFCollection.)
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone | (Inherited from PointFCollection.)
Public method | Equals | (Inherited from PointFCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject | Returns a new instance of PointFCollection. (Overrides PointFCollectionGetClonedObject.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | (Inherited from PointFCollection.)
Public method | GetObjectData | (Inherited from PointFCollection.)
Public method | GetPointBounds | (Inherited from PointFCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | (Inherited from PointFCollection.)
Public method | InsertRange | (Inherited from PointFCollection.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | (Inherited from PointFCollection.)
Public method | Normalize | (Inherited from PointFCollection.)
Public method | OffsetPoints | (Inherited from PointFCollection.)
Protected method | OnClear | (Inherited from PointFCollection.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnCollectionChanged | (Inherited from PointFCollection.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | (Inherited from PointFCollection.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | (Inherited from PointFCollection.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ResizeToBounds | (Inherited from PointFCollection.)
Public method | ToArray | (Inherited from PointFCollection.)
Public method | ToArray(PointF) | (Inherited from PointFCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from PointFCollection.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


PointFCollection Constructor

Constructs a PointFCollection.
Overload List
 | Name | Description
Public method | PointFCollection | Creates a new instance of PointFCollection.
Public method | PointFCollection(PointF) | Creates a new instance of PointFCollection specifying the initial points.
Public method | PointFCollection(SerializationInfo, StreamingContext) | Creates a new instance of PointFCollection from serialized data.
Top
See Also

Reference

PointFCollection Class
Atalasoft.Annotate Namespace


PointFCollection Constructor

Creates a new instance of PointFCollection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection()
Public Sub New
See Also

Reference

PointFCollection Class
PointFCollection Overload
Atalasoft.Annotate Namespace


PointFCollection Constructor (PointF[])

PointFCollection Constructor (PointF)

Creates a new instance of PointFCollection specifying the initial points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection(
    PointF[] points
)
Public Sub New (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The initial points for this collection.
Exceptions
Exception | Condition
 | Thrown if the points parameter is null or contains no items.
See Also

Reference

PointFCollection Class
PointFCollection Overload
Atalasoft.Annotate Namespace


PointFCollection Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PointFCollection from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information for this object.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context for this object.
See Also

Reference

PointFCollection Class
PointFCollection Overload
Atalasoft.Annotate Namespace


PointFCollection Properties

The PointFCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | IgnoreChanges | Obsolete. Gets or sets a value indicating whether the PointFCollection event should not be raised.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | (Inherited from PointFCollection.)
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | RaiseCollectionChangedEvent | (Inherited from PointFCollection.)
Top
See Also

Reference

PointFCollection Class
Atalasoft.Annotate Namespace


PointFCollection.IgnoreChanges Property

PointFCollectionIgnoreChanges Property

Note: This API is now obsolete.

Gets or sets a value indicating whether the PointFCollection event should not be raised.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property may be removed in a future release.  Use the RaiseCollectionChangedEvent property instead.",
    false)]
public bool IgnoreChanges { get; set; }
<ObsoleteAttribute("This property may be removed in a future release.  Use the RaiseCollectionChangedEvent property instead.",
    false)>
Public Property IgnoreChanges As Boolean
    Get
    Set

Property Value

Type: Boolean
True if the PointFCollection event should not be raised.
See Also

Reference

PointFCollection Class
Atalasoft.Annotate Namespace


PointFCollection Methods

The PointFCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from PointFCollection.)
Public method | AddRange | (Inherited from PointFCollection.)
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone | (Inherited from PointFCollection.)
Public method | Equals | (Inherited from PointFCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject | Returns a new instance of PointFCollection. (Overrides PointFCollectionGetClonedObject.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | (Inherited from PointFCollection.)
Public method | GetObjectData | (Inherited from PointFCollection.)
Public method | GetPointBounds | (Inherited from PointFCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | (Inherited from PointFCollection.)
Public method | InsertRange | (Inherited from PointFCollection.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | (Inherited from PointFCollection.)
Public method | Normalize | (Inherited from PointFCollection.)
Public method | OffsetPoints | (Inherited from PointFCollection.)
Protected method | OnClear | (Inherited from PointFCollection.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnCollectionChanged | (Inherited from PointFCollection.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | (Inherited from PointFCollection.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | (Inherited from PointFCollection.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ResizeToBounds | (Inherited from PointFCollection.)
Public method | ToArray | (Inherited from PointFCollection.)
Public method | ToArray(PointF) | (Inherited from PointFCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PointFCollection Class
Atalasoft.Annotate Namespace


PointFCollection.GetClonedObject Method

PointFCollectionGetClonedObject Method

Returns a new instance of PointFCollection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PointFCollection GetClonedObject()
Protected Overrides Function GetClonedObject As PointFCollection

Return Value

Type: PointFCollection
A new instance of PointFCollection.
Remarks
The collection returned by this method does not clone the point values.
See Also

Reference

PointFCollection Class
Atalasoft.Annotate Namespace


PointFCollection Events

The PointFCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from PointFCollection.)
Top
See Also

Reference

PointFCollection Class
Atalasoft.Annotate Namespace


PolygonData Class

Contains annotation information for a PolygonAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotatePointBaseData
Atalasoft.AnnotatePolygonData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PolygonData : PointBaseData,
    ISerializable, ICloneable, IHighlighter
<SerializableAttribute>
Public Class PolygonData
    Inherits PointBaseData
    Implements ISerializable, ICloneable, IHighlighter

The PolygonData type exposes the following members.

Constructors
 | Name | Description
Public method | PolygonData | Creates a new instance of PolygonData.
Public method | PolygonData(SerializationInfo, StreamingContext) | Creates a new instance of PolygonData from serialization information.
Public method | PolygonData(AnnotationBrush, AnnotationPen) | Creates a new instance of PolygonData specifying the outline and fill.
Public method | PolygonData(AnnotationBrush, AnnotationPen, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill and points collection.
Public method | PolygonData(AnnotationBrush, AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill and an array of points.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of PolygonData specifying the outline, fill and shadow settings.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill, shadow settings and points of the polygon.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonData specifying the outline, fill, shadow settings, and translucency.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill, shadow settings and array of points for the polygon.
Public method | PolygonData(PointF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonData specifying the a set of points, outline, fill and shadow settings.
Public method | PolygonData(PointFCollection, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonData specifying the a set of points, outline, fill and shadow settings.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill for the PolygonData.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for the PolygonData.
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used for the drop shadow.
Public property | ShadowOffset | Gets or sets the drop shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | Creates a copy of the PolygonData. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another PolygonData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills the SerializationInfo object will PolygonData information. (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
Remarks
This class is used by the PolygonAnnotation.
See Also

Reference

Atalasoft.Annotate Namespace
PolygonAnnotation Class


PolygonData Constructor

Constructs a PolygonData.
Overload List
 | Name | Description
Public method | PolygonData | Creates a new instance of PolygonData.
Public method | PolygonData(SerializationInfo, StreamingContext) | Creates a new instance of PolygonData from serialization information.
Public method | PolygonData(AnnotationBrush, AnnotationPen) | Creates a new instance of PolygonData specifying the outline and fill.
Public method | PolygonData(AnnotationBrush, AnnotationPen, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill and points collection.
Public method | PolygonData(AnnotationBrush, AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill and an array of points.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of PolygonData specifying the outline, fill and shadow settings.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill, shadow settings and points of the polygon.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonData specifying the outline, fill, shadow settings, and translucency.
Public method | PolygonData(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonData specifying the outline, fill, shadow settings and array of points for the polygon.
Public method | PolygonData(PointF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonData specifying the a set of points, outline, fill and shadow settings.
Public method | PolygonData(PointFCollection, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonData specifying the a set of points, outline, fill and shadow settings.
Top
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData Constructor

Creates a new instance of PolygonData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData()
Public Sub New
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PolygonData from serialization information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about the PolygonData.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen)

Creates a new instance of PolygonData specifying the outline and fill.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen, PointFCollection)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonData specifying the outline, fill and points collection.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline,
    PointFCollection points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    points As PointFCollection
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the initial points for the polygon.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen, PointF[])

PolygonData Constructor (AnnotationBrush, AnnotationPen, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonData specifying the outline, fill and an array of points.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline,
    PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
points
Type: System.DrawingPointF
An array of PointF objects specifying the initial points of the polygon.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of PolygonData specifying the outline, fill and shadow settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointFCollection)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonData specifying the outline, fill, shadow settings and points of the polygon.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    PointFCollection points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    points As PointFCollection
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the initial points for the polygon.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

Creates a new instance of PolygonData specifying the outline, fill, shadow settings, and translucency.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointF[])

PolygonData Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonData specifying the outline, fill, shadow settings and array of points for the polygon.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public PolygonData(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
points
Type: System.DrawingPointF
An array of PointF objects specifying the initial points of the polygon.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (PointF[], AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

PolygonData Constructor (PointF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

Creates a new instance of PolygonData specifying the a set of points, outline, fill and shadow settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData(
    PointF[] points,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent
)
Public Sub New (
    points As PointF(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean
)

Parameters

points
Type: System.DrawingPointF
An array of PointF objects specifying the initial points of the polygon.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Constructor (PointFCollection, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

Creates a new instance of PolygonData specifying the a set of points, outline, fill and shadow settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonData(
    PointFCollection points,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent
)
Public Sub New (
    points As PointFCollection,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the initial points for the polygon.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
translucent
Type: SystemBoolean
Indicates if the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

PolygonData Class
PolygonData Overload
Atalasoft.Annotate Namespace


PolygonData Properties

The PolygonData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill for the PolygonData.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline for the PolygonData.
Public property | Points | Gets a PointFCollection used to store the points for the annotation. (Inherited from PointBaseData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used for the drop shadow.
Public property | ShadowOffset | Gets or sets the drop shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Bounds Property

PolygonDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Fill Property

PolygonDataFill Property

Gets or sets the fill for the PolygonData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill for the PolygonData.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Outline Property

PolygonDataOutline Property

Gets or sets the outline for the PolygonData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The outline of the PolygonData.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Shadow Property

PolygonDataShadow Property

Gets or sets the AnnotationBrush used for the drop shadow.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill for the drop shadow.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.ShadowOffset Property

PolygonDataShadowOffset Property

Gets or sets the drop shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset specifying the position of the drop shadow.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Translucent Property

PolygonDataTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.

Implements

IHighlighterTranslucent
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument method.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData Methods

The PolygonData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF, Boolean, Boolean) | Calculates the bounding rectangle for the annotation. (Inherited from PointBaseData.)
Public method | Clone | Creates a copy of the PolygonData. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Fills the data object with cloned property values. (Overrides PointBaseDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another PolygonData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills the SerializationInfo object will PolygonData information. (Overrides PointBaseDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPointBounds | Gets a bounding rectangle which includes all of the Points (Inherited from PointBaseData.)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from PointBaseData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Clone Method

PolygonDataClone Method

Creates a copy of the PolygonData.
Creates a copy of the PolygonData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.CloneBaseData Method

PolygonDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from PointBaseData.
Remarks
This method should be called by classes that derive from PointBaseData when they need to create a clone of the object.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.Equals Method

PolygonDataEquals Method

Determines if another PolygonData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An PolygonData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.GetHashCode Method

PolygonDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.GetObjectData Method

PolygonDataGetObjectData Method

Fills the SerializationInfo object will PolygonData information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerialziationInfo where information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData.OnPropertyChanging Method

PolygonDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


PolygonData Events

The PolygonData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

PolygonData Class
Atalasoft.Annotate Namespace


RectangleData Class

Contains information describing data for a RectangleAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateRectangleData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RectangleData : AnnotationData,
    ISerializable, IWangCompatible, IHighlighter
<SerializableAttribute>
Public Class RectangleData
    Inherits AnnotationData
    Implements ISerializable, IWangCompatible, IHighlighter

The RectangleData type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleData | Creates a new instance of RectangleData.
Public method | RectangleData(WangAttributeData) | Creates a new instance of RectangleData from a WangAttributeData object.
Public method | RectangleData(RectangleF, AnnotationBrush) | Creates a new instance of RectangleData specifying the rectangle and fill.
Public method | RectangleData(RectangleF, AnnotationPen) | Creates a new instance of RectangleData specifying the rectangle and outline.
Public method | RectangleData(SerializationInfo, StreamingContext) | Creates a new instance of RectangleData from serialized information.
Public method | RectangleData(RectangleF, AnnotationBrush, Boolean) | Creates a new instance of RectangleData specifying the rectangle, fill and translucent properties.
Public method | RectangleData(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of RectangleData specifying the rectangle, fill, outline and shadow settings.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | (Overrides AnnotationDataAnnotationBounds.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of the RectangleData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another RectangleData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with RectangleData information. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
RectangleAnnotation Class


RectangleData Constructor

Constructs a RectangleData.
Overload List
 | Name | Description
Public method | RectangleData | Creates a new instance of RectangleData.
Public method | RectangleData(WangAttributeData) | Creates a new instance of RectangleData from a WangAttributeData object.
Public method | RectangleData(RectangleF, AnnotationBrush) | Creates a new instance of RectangleData specifying the rectangle and fill.
Public method | RectangleData(RectangleF, AnnotationPen) | Creates a new instance of RectangleData specifying the rectangle and outline.
Public method | RectangleData(SerializationInfo, StreamingContext) | Creates a new instance of RectangleData from serialized information.
Public method | RectangleData(RectangleF, AnnotationBrush, Boolean) | Creates a new instance of RectangleData specifying the rectangle, fill and translucent properties.
Public method | RectangleData(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of RectangleData specifying the rectangle, fill, outline and shadow settings.
Top
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData Constructor

Creates a new instance of RectangleData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData()
Public Sub New
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Constructor (WangAttributeData)

Creates a new instance of RectangleData from a WangAttributeData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData(
    WangAttributeData wangData
)
Public Sub New (
    wangData As WangAttributeData
)

Parameters

wangData
Type: Atalasoft.AnnotateWangAttributeData
A WangAttributeData object containing information for a HollowRectangle or FilledRectangle WANG annotation.
Remarks
The WangFormatter will use this constructor for standard WANG data.
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Constructor (RectangleF, AnnotationBrush)

Creates a new instance of RectangleData specifying the rectangle and fill.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData(
    RectangleF rectangle,
    AnnotationBrush fill
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for this annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill this annotation.
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Constructor (RectangleF, AnnotationPen)

Creates a new instance of RectangleData specifying the rectangle and outline.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData(
    RectangleF rectangle,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for this annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RectangleData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing RectangleData information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Constructor (RectangleF, AnnotationBrush, Boolean)

Creates a new instance of RectangleData specifying the rectangle, fill and translucent properties.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData(
    RectangleF rectangle,
    AnnotationBrush fill,
    bool translucent
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    translucent As Boolean
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for this annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill this annotation.
translucent
Type: SystemBoolean
A value indicating whether this annotation will act as a highlighter.
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Constructor (RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of RectangleData specifying the rectangle, fill, outline and shadow settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleData(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for this annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill this annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to position the drop shadow.
See Also

Reference

RectangleData Class
RectangleData Overload
Atalasoft.Annotate Namespace


RectangleData Properties

The RectangleData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | (Overrides AnnotationDataAnnotationBounds.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.AnnotationBounds Property

RectangleDataAnnotationBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF AnnotationBounds { get; }
Public Overrides ReadOnly Property AnnotationBounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Bounds Property

RectangleDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Fill Property

RectangleDataFill Property

Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Outline Property

RectangleDataOutline Property

Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Shadow Property

RectangleDataShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.ShadowOffset Property

RectangleDataShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Translucent Property

RectangleDataTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.

Implements

IHighlighterTranslucent
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument method.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData Methods

The RectangleData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of the RectangleData. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another RectangleData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with RectangleData information. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Clone Method

RectangleDataClone Method

Creates a copy of the RectangleData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.CloneBaseData Method

RectangleDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.Equals Method

RectangleDataEquals Method

Determines if another RectangleData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An RectangleData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.GetHashCode Method

RectangleDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.GetObjectData Method

RectangleDataGetObjectData Method

Fills a SerializationInfo object with RectangleData information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object to fill with data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.GetWangAttributeData Method

RectangleDataGetWangAttributeData Method

Returns a WangAttributeData object with information about this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData object.

Implements

IWangCompatibleGetWangAttributeData
Remarks
The WangFormatter calls this method when serializing.
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData.OnPropertyChanging Method

RectangleDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleData Events

The RectangleData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

RectangleData Class
Atalasoft.Annotate Namespace


RectangleGrip Enumeration

Specifies the position of the grip.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RectangleGrip
Public Enumeration RectangleGrip
Members
Member name | Description
TopLeft | The grip positioned at the top-left of the annotation.
TopCenter | The grip positioned at the top-center of the annotation.
TopRight | The grip positioned at the top-right of the annotation.
CenterLeft | The grip positioned at the center-left of the annotation.
CenterRight | The grip positioned at the center-right of the annotation.
BottomLeft | The grip positioned at the bottom-left of the annotation.
BottomCenter | The grip positioned at the bottom-center of the annotation.
BottomRight | The grip positioned at the bottom-right of the annotation.
Rotation | The grip positioned above the top-center of the annotation used for rotating.
See Also

Reference

Atalasoft.Annotate Namespace


RectangleGripDisplay Enumeration

Specifies the grips to display.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RectangleGripDisplay
Public Enumeration RectangleGripDisplay
Members
Member name | Description
Both | Both corner and side grips are displayed.
CornerGrips | Only the corner grips are displayed.
SideGrips | Only the side grips are displayed.
Remarks
For more control, each grip has a visible property that will determine which grips to render.
See Also

Reference

Atalasoft.Annotate Namespace


ReferencedImageData Class

The data for a ReferencedImageAnnotation object.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateReferencedImageData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ReferencedImageData : AnnotationData,
    ISerializable, ICloneable, IWangCompatible, IDisposable
<SerializableAttribute>
Public Class ReferencedImageData
    Inherits AnnotationData
    Implements ISerializable, ICloneable, IWangCompatible, IDisposable

The ReferencedImageData type exposes the following members.

Constructors
 | Name | Description
Public method | ReferencedImageData | Creates a new instance of ReferencedImageData.
Public method | ReferencedImageData(String) | Creates a new instance of ReferencedImageData specifying the filename of the image.
Public method | ReferencedImageData(WangAttributeData) | Creates a new instance of ReferencedImageData from WANG annotation data.
Public method | ReferencedImageData(SerializationInfo, StreamingContext) | Creates a new instance of ReferencedImageData from serialized information.
Public method | ReferencedImageData(String, PointF) | Creates a new instance of ReferencedImageData specifying the filename, location and whether the aspect ratio should be maintained.
Public method | ReferencedImageData(String, AnnotationBrush, PointF) | Creates a new instance of ReferencedImageData specifying the filename, shadow and shadow offset.
Public method | ReferencedImageData(String, PointF, AnnotationBrush, PointF) | Creates a new instance of ReferencedImageData specifying the filename, initial location, shadow and shadow offset.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | FileName | Gets or sets the filename of the annotation image.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | ImageObject | Gets or sets the image object for this annotation.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this ReferencedImageData object. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Releases internal resources used by the ReferencedImageData object. (Overrides AnnotationDataDispose(Boolean).)
Public method | Equals | Determines if another ReferencedImageData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the ReferencedImageData class. (Overrides AnnotationDataFinalize.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this ReferencedImageData object. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreateImageObject | Called when the ImageObject needs to be created.
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


ReferencedImageData Constructor

Constructs a ReferencedImageData.
Overload List
 | Name | Description
Public method | ReferencedImageData | Creates a new instance of ReferencedImageData.
Public method | ReferencedImageData(String) | Creates a new instance of ReferencedImageData specifying the filename of the image.
Public method | ReferencedImageData(WangAttributeData) | Creates a new instance of ReferencedImageData from WANG annotation data.
Public method | ReferencedImageData(SerializationInfo, StreamingContext) | Creates a new instance of ReferencedImageData from serialized information.
Public method | ReferencedImageData(String, PointF) | Creates a new instance of ReferencedImageData specifying the filename, location and whether the aspect ratio should be maintained.
Public method | ReferencedImageData(String, AnnotationBrush, PointF) | Creates a new instance of ReferencedImageData specifying the filename, shadow and shadow offset.
Public method | ReferencedImageData(String, PointF, AnnotationBrush, PointF) | Creates a new instance of ReferencedImageData specifying the filename, initial location, shadow and shadow offset.
Top
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData Constructor

Creates a new instance of ReferencedImageData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData()
Public Sub New
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Constructor (String)

Creates a new instance of ReferencedImageData specifying the filename of the image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Constructor (WangAttributeData)

Creates a new instance of ReferencedImageData from WANG annotation data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
A WangAttributeData object containing information for this annotation.
Remarks
The WangAttributeData must have its Bounds and FileName properties set.
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ReferencedImageData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Constructor (String, PointF)

Creates a new instance of ReferencedImageData specifying the filename, location and whether the aspect ratio should be maintained.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData(
    string fileName,
    PointF location
)
Public Sub New (
    fileName As String,
    location As PointF
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
location
Type: System.DrawingPointF
The location of the annotation.
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Constructor (String, AnnotationBrush, PointF)

Creates a new instance of ReferencedImageData specifying the filename, shadow and shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData(
    string fileName,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    fileName As String,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Constructor (String, PointF, AnnotationBrush, PointF)

Creates a new instance of ReferencedImageData specifying the filename, initial location, shadow and shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageData(
    string fileName,
    PointF location,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    fileName As String,
    location As PointF,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
location
Type: System.DrawingPointF
The location of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

ReferencedImageData Class
ReferencedImageData Overload
Atalasoft.Annotate Namespace


ReferencedImageData Properties

The ReferencedImageData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | FileName | Gets or sets the filename of the annotation image.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | ImageObject | Gets or sets the image object for this annotation.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.Bounds Property

ReferencedImageDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.FileName Property

ReferencedImageDataFileName Property

Gets or sets the filename of the annotation image.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The filename of the image for this annotation.
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.ImageObject Property

ReferencedImageDataImageObject Property

Gets or sets the image object for this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object ImageObject { get; set; }
Public Property ImageObject As Object
    Get
    Set

Property Value

Type: Object
The real image for this annotation.
Remarks
The DotImage implementation of this object is a System.Drawing.Bitmap.
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.Shadow Property

ReferencedImageDataShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.ShadowOffset Property

ReferencedImageDataShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData Methods

The ReferencedImageData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this ReferencedImageData object. (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Releases internal resources used by the ReferencedImageData object. (Overrides AnnotationDataDispose(Boolean).)
Public method | Equals | Determines if another ReferencedImageData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the ReferencedImageData class. (Overrides AnnotationDataFinalize.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this ReferencedImageData object. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData object with information about this annotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreateImageObject | Called when the ImageObject needs to be created.
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.Clone Method

ReferencedImageDataClone Method

Creates a copy of this ReferencedImageData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.CloneBaseData Method

ReferencedImageDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.Dispose Method

ReferencedImageDataDispose Method

These methods release resources used by the annotation.
Releases the memory used by this annotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Releases internal resources used by the ReferencedImageData object. (Overrides AnnotationDataDispose(Boolean).)
Top
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.Dispose Method (Boolean)

ReferencedImageDataDispose Method (Boolean)

Releases internal resources used by the ReferencedImageData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Set to true when called from the Dispose(Boolean) method.
See Also

Reference

ReferencedImageData Class
Dispose Overload
Atalasoft.Annotate Namespace


ReferencedImageData.Equals Method

ReferencedImageDataEquals Method

Determines if another ReferencedImageData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An ReferencedImageData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.Finalize Method

ReferencedImageDataFinalize Method

Finalizes an instance of the ReferencedImageData class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.GetHashCode Method

ReferencedImageDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.GetObjectData Method

ReferencedImageDataGetObjectData Method

Fills a SerializationInfo object with information about this ReferencedImageData object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where the information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.GetWangAttributeData Method

ReferencedImageDataGetWangAttributeData Method

Returns a WangAttributeData object with information about this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData for this annotation.

Implements

IWangCompatibleGetWangAttributeData
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData.OnCreateImageObject Method

ReferencedImageDataOnCreateImageObject Method

Called when the ImageObject needs to be created.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCreateImageObject()
Protected Overridable Sub OnCreateImageObject
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


ReferencedImageData Events

The ReferencedImageData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

ReferencedImageData Class
Atalasoft.Annotate Namespace


RegisteredAnnotationAssemblies Class

This class includes static members containing information on assemblies to use in the project when deserialize annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateRegisteredAnnotationAssemblies

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class RegisteredAnnotationAssemblies
Public NotInheritable Class RegisteredAnnotationAssemblies

The RegisteredAnnotationAssemblies type exposes the following members.

Methods
Name | Description
GetRegisteredAssemblies | Returns a collection of assemblies that will be used to deserialize annotations.
RegisterAssembly | Registers assembly that will be used to deserialize annotations.
Top
See Also

Reference

Atalasoft.Annotate Namespace


RegisteredAnnotationAssemblies Methods

The RegisteredAnnotationAssemblies type exposes the following members.

Methods
Name | Description
GetRegisteredAssemblies | Returns a collection of assemblies that will be used to deserialize annotations.
RegisterAssembly | Registers assembly that will be used to deserialize annotations.
Top
See Also

Reference

RegisteredAnnotationAssemblies Class
Atalasoft.Annotate Namespace


RegisteredAnnotationAssemblies.GetRegisteredAssemblies Method

RegisteredAnnotationAssembliesGetRegisteredAssemblies Method

Returns a collection of assemblies that will be used to deserialize annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ICollection<Assembly> GetRegisteredAssemblies()
Public Shared Function GetRegisteredAssemblies As ICollection(Of Assembly)

Return Value

Type: ICollection Assembly
See Also

Reference

RegisteredAnnotationAssemblies Class
Atalasoft.Annotate Namespace


RegisteredAnnotationAssemblies.RegisterAssembly Method

RegisteredAnnotationAssembliesRegisterAssembly Method

Registers assembly that will be used to deserialize annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void RegisterAssembly(
    Assembly asm
)
Public Shared Sub RegisterAssembly (
    asm As Assembly
)

Parameters

asm
Type: System.ReflectionAssembly
Remarks
Add any assemblies with custom annotations so that XmpFormatter, JoltXmpFormatter and LegacyXmpFormatter will use that assembly when attempting to deserialize an annotation.
See Also

Reference

RegisteredAnnotationAssemblies Class
Atalasoft.Annotate Namespace


RenderDevice Enumeration

Specifies the type of device annotations will be rendered on. This allows the renderer to adjust for differences in media.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RenderDevice
Public Enumeration RenderDevice
Members
Member name | Description
Display | Rendering is going to the screen or a control.
Printer | Rendering is for a printer.
Image | Rendering is directly to an image.
See Also

Reference

Atalasoft.Annotate Namespace


RubberStampData Class

The annotation data object for a RubberStampAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateRubberStampData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RubberStampData : AnnotationData,
    ISerializable, ICloneable
<SerializableAttribute>
Public Class RubberStampData
    Inherits AnnotationData
    Implements ISerializable, ICloneable

The RubberStampData type exposes the following members.

Constructors
 | Name | Description
Public method | RubberStampData | Creates a new instance of RubberStampData with default parameters.
Public method | RubberStampData(RectangleF) | Creates a new instance of RubberStampData specifying the bounding rectangle of the annotation.
Public method | RubberStampData(String) | Creates a new instance of RubberStampData specifying the annotation text.
Public method | RubberStampData(RectangleF, String) | Creates an instance of RubberStampData specifying the bounding rectangle and text of the annotation.
Public method | RubberStampData(SerializationInfo, StreamingContext) | Creates a new instance of RubberStampData from serialized data.
Public method | RubberStampData(String, AnnotationFont) | Create a new instance of RubberStampData specifying the annotation text and font.
Public method | RubberStampData(RectangleF, String, AnnotationFont) | Creates an instance of RubberStampData specifying the bounding rectangle, text and font.
Public method | RubberStampData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampData specifying the annotation text, font, font brush, fill outline and corner radius.
Public method | RubberStampData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampData specifying the bounding rectangle, text, font, font brush, fill, outline and corner radius.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CornerRadius | Gets or sets the radius used for the corners of the annotation.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Font | Gets or sets the font for the text.
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Padding | Gets or sets the amount of space around the text.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for this annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another RubberStampData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace
RubberStampAnnotation Class


RubberStampData Constructor

Constructs a RubberStampData.
Overload List
 | Name | Description
Public method | RubberStampData | Creates a new instance of RubberStampData with default parameters.
Public method | RubberStampData(RectangleF) | Creates a new instance of RubberStampData specifying the bounding rectangle of the annotation.
Public method | RubberStampData(String) | Creates a new instance of RubberStampData specifying the annotation text.
Public method | RubberStampData(RectangleF, String) | Creates an instance of RubberStampData specifying the bounding rectangle and text of the annotation.
Public method | RubberStampData(SerializationInfo, StreamingContext) | Creates a new instance of RubberStampData from serialized data.
Public method | RubberStampData(String, AnnotationFont) | Create a new instance of RubberStampData specifying the annotation text and font.
Public method | RubberStampData(RectangleF, String, AnnotationFont) | Creates an instance of RubberStampData specifying the bounding rectangle, text and font.
Public method | RubberStampData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampData specifying the annotation text, font, font brush, fill outline and corner radius.
Public method | RubberStampData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampData specifying the bounding rectangle, text, font, font brush, fill, outline and corner radius.
Top
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData Constructor

Creates a new instance of RubberStampData with default parameters.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData()
Public Sub New
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (RectangleF)

Creates a new instance of RubberStampData specifying the bounding rectangle of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    RectangleF bounds
)
Public Sub New (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (String)

Creates a new instance of RubberStampData specifying the annotation text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text drawn for the rubber stamp.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (RectangleF, String)

Creates an instance of RubberStampData specifying the bounding rectangle and text of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    RectangleF bounds,
    string text
)
Public Sub New (
    bounds As RectangleF,
    text As String
)

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
text
Type: SystemString
The text drawn for the rubber stamp.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RubberStampData from serialized data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (String, AnnotationFont)

Create a new instance of RubberStampData specifying the annotation text and font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    string text,
    AnnotationFont font
)
Public Sub New (
    text As String,
    font As AnnotationFont
)

Parameters

text
Type: SystemString
The text drawn for the rubber stamp.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the annotation text.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (RectangleF, String, AnnotationFont)

Creates an instance of RubberStampData specifying the bounding rectangle, text and font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    RectangleF bounds,
    string text,
    AnnotationFont font
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont
)

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
text
Type: SystemString
The text drawn for the rubber stamp.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the annotation text.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single)

Creates a new instance of RubberStampData specifying the annotation text, font, font brush, fill outline and corner radius.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    float cornerRadius,
    float padding
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    cornerRadius As Single,
    padding As Single
)

Parameters

text
Type: SystemString
The text drawn for the rubber stamp.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the annotation text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for filling the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used for drawing the outline of the annotation.
cornerRadius
Type: SystemSingle
The radius used on the corners.
padding
Type: SystemSingle
Space added around the text.
See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Constructor (RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single)

Creates a new instance of RubberStampData specifying the bounding rectangle, text, font, font brush, fill, outline and corner radius.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampData(
    RectangleF bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    float cornerRadius,
    float padding
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    cornerRadius As Single,
    padding As Single
)

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
text
Type: SystemString
The text drawn for the rubber stamp.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the annotation text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for filling the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used for drawing the outline of the annotation.
cornerRadius
Type: SystemSingle
The radius used on the corners.
padding
Type: SystemSingle

Space added around the text.

See Also

Reference

RubberStampData Class
RubberStampData Overload
Atalasoft.Annotate Namespace


RubberStampData Properties

The RubberStampData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CornerRadius | Gets or sets the radius used for the corners of the annotation.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Font | Gets or sets the font for the text.
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Padding | Gets or sets the amount of space around the text.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for this annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Bounds Property

RubberStampDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.CornerRadius Property

RubberStampDataCornerRadius Property

Gets or sets the radius used for the corners of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float CornerRadius { get; set; }
Public Property CornerRadius As Single
    Get
    Set

Property Value

Type: Single
The corner radius of the rectangle.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Fill Property

RubberStampDataFill Property

Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Font Property

RubberStampDataFont Property

Gets or sets the font for the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used when rendering the text.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.FontBrush Property

RubberStampDataFontBrush Property

Gets or sets the AnnotationBrush used for the font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used when rendering the text.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Outline Property

RubberStampDataOutline Property

Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Padding Property

RubberStampDataPadding Property

Gets or sets the amount of space around the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Padding { get; set; }
Public Property Padding As Single
    Get
    Set

Property Value

Type: Single
The amount of space around the text.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Text Property

RubberStampDataText Property

Gets or sets the text for this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The annotation text.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData Methods

The RubberStampData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another RubberStampData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Clone Method

RubberStampDataClone Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
ICloneableClone
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.CloneBaseData Method

RubberStampDataCloneBaseData Method

Fills the data object with cloned property values.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A class that derives from AnnotationData.
Remarks
This method should be called by classes that derive from AnnotationData when they need to create a clone of the object.
Examples
AnnotationData Class
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.Equals Method

RubberStampDataEquals Method

Determines if another RubberStampData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An RubberStampData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.GetHashCode Method

RubberStampDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData.GetObjectData Method

RubberStampDataGetObjectData Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


RubberStampData Events

The RubberStampData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

RubberStampData Class
Atalasoft.Annotate Namespace


SerializationInfoHelper Class

Note: This API is now obsolete.

This class contains methods used when serializing or deserializing annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.UtilsSerializationInfoHelper
Atalasoft.AnnotateSerializationInfoHelper

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This class may be removed in a future release.  Use the Atalasoft.Util.SerializationInfoHelper class instead.",
    false)]
public class SerializationInfoHelper : SerializationInfoHelper
<ObsoleteAttribute("This class may be removed in a future release.  Use the Atalasoft.Util.SerializationInfoHelper class instead.",
    false)>
Public Class SerializationInfoHelper
    Inherits SerializationInfoHelper

The SerializationInfoHelper type exposes the following members.

Constructors
 | Name | Description
Public method | SerializationInfoHelper | Initializes a new instance of the SerializationInfoHelper class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Object) | (Inherited from SerializationInfoHelper.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


SerializationInfoHelper Constructor

Initializes a new instance of the SerializationInfoHelper class.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SerializationInfoHelper(
    SerializationInfo info
)
Public Sub New (
    info As SerializationInfo
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
See Also

Reference

SerializationInfoHelper Class
Atalasoft.Annotate Namespace


SerializationInfoHelper Methods

The SerializationInfoHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Object) | (Inherited from SerializationInfoHelper.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SerializationInfoHelper Class
Atalasoft.Annotate Namespace


ShadowMode Enumeration

Specifies the shadow mode used for text annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ShadowMode
Public Enumeration ShadowMode
Members
Member name | Description
Annotation | The shadow is applied only to the annotation.
Text | The shadow is applied only to the text.
AnnotationAndText | The shadow is applied to both text and annotation.
See Also

Reference

Atalasoft.Annotate Namespace


TextData Class

Data for a TextAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.AnnotateTextData
Atalasoft.AnnotateCommentData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TextData : AnnotationData, ISerializable,
    ICloneable, IWangCompatible
<SerializableAttribute>
Public Class TextData
    Inherits AnnotationData
    Implements ISerializable, ICloneable, IWangCompatible

The TextData type exposes the following members.

Constructors
 | Name | Description
Public method | TextData | Creates a new instance of TextData.
Public method | TextData(RectangleF) | Creates a new instance of TextData specifying the annotation location and size.
Public method | TextData(String) | Creates a new instance of TextData specifying the annotation text.
Public method | TextData(WangAttributeData) | Creates a new instance of TextData from WANG annotation information.
Public method | TextData(RectangleF, String) | Creates a new instance of TextData specifying the annotation text.
Public method | TextData(SerializationInfo, StreamingContext) | Creates a new instance of TextData from serialized information.
Public method | TextData(String, AnnotationFont) | Creates a new instance of TextData specifying the text and font.
Public method | TextData(RectangleF, String, AnnotationFont) | Creates a new instance of TextData specifying the text and font.
Public method | TextData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of TextData specifying the text, font, font brush, fill and outline for the annotation.
Public method | TextData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of TextData specifying the text, font, font brush, fill and outline for the annotation.
Public method | TextData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of TextData specifying the properties for this object.
Public method | TextData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of TextData specifying the properties for this object.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text.
Public property | AllowEditing | Gets or sets a value indicating whether the annotation's text data should be editable or read-only via the user interface.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text.
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Font | Gets or sets the font for the text.
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font.
Public property | FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineAlignment | Gets or sets the line alignment.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | Minimized | Gets or sets a value indicating whether the annotation is minimized.
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Padding | Gets or sets a value indicating how much padding is added around the text.
Public property | RenderingHint | Gets or sets the System.Drawing.Text.TextRenderingHint used when rendering this text
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowMode | Gets or sets the shadow mode used to indicate how the shadow is drawn.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for this annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Trimming | Get or sets the type of character trimming to perform on the text.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this TextData. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Creates a copy of this TextData. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another TextData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this object. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData containing information about this TextData.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


TextData Constructor

Constructs a TextData.
Overload List
 | Name | Description
Public method | TextData | Creates a new instance of TextData.
Public method | TextData(RectangleF) | Creates a new instance of TextData specifying the annotation location and size.
Public method | TextData(String) | Creates a new instance of TextData specifying the annotation text.
Public method | TextData(WangAttributeData) | Creates a new instance of TextData from WANG annotation information.
Public method | TextData(RectangleF, String) | Creates a new instance of TextData specifying the annotation text.
Public method | TextData(SerializationInfo, StreamingContext) | Creates a new instance of TextData from serialized information.
Public method | TextData(String, AnnotationFont) | Creates a new instance of TextData specifying the text and font.
Public method | TextData(RectangleF, String, AnnotationFont) | Creates a new instance of TextData specifying the text and font.
Public method | TextData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of TextData specifying the text, font, font brush, fill and outline for the annotation.
Public method | TextData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of TextData specifying the text, font, font brush, fill and outline for the annotation.
Public method | TextData(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of TextData specifying the properties for this object.
Public method | TextData(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of TextData specifying the properties for this object.
Top
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData Constructor

Creates a new instance of TextData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData()
Public Sub New
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (RectangleF)

Creates a new instance of TextData specifying the annotation location and size.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    RectangleF bounds
)
Public Sub New (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (String)

Creates a new instance of TextData specifying the annotation text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text for the annotation.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (WangAttributeData)

Creates a new instance of TextData from WANG annotation information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
A WangAttributeData object containing information about this annotation.
Remarks
The WangAttributeData must have the Bounds, Font, Text and Color1 properties set. If the annotation type is Attach-a-Note the Color2 property must also be set.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (RectangleF, String)

Creates a new instance of TextData specifying the annotation text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    RectangleF bounds,
    string text
)
Public Sub New (
    bounds As RectangleF,
    text As String
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for the annotation.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of TextData from serialized information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the information.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (String, AnnotationFont)

Creates a new instance of TextData specifying the text and font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    string text,
    AnnotationFont font
)
Public Sub New (
    text As String,
    font As AnnotationFont
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (RectangleF, String, AnnotationFont)

Creates a new instance of TextData specifying the text and font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    RectangleF bounds,
    string text,
    AnnotationFont font
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of TextData specifying the text, font, font brush, fill and outline for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of TextData specifying the text, font, font brush, fill and outline for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    RectangleF bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode)

Creates a new instance of TextData specifying the properties for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    ShadowMode shadowMode
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    shadowMode As ShadowMode
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
shadowMode
Type: Atalasoft.AnnotateShadowMode
Defines the type of shadow to apply.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Constructor (RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode)

Creates a new instance of TextData specifying the properties for this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextData(
    RectangleF bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    ShadowMode shadowMode
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    shadowMode As ShadowMode
)

Parameters

bounds
Type: System.DrawingRectangleF
The location and size of the annotation.
text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
shadowMode
Type: Atalasoft.AnnotateShadowMode
Defines the type of shadow to apply.
See Also

Reference

TextData Class
TextData Overload
Atalasoft.Annotate Namespace


TextData Properties

The TextData type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text.
Public property | AllowEditing | Gets or sets a value indicating whether the annotation's text data should be editable or read-only via the user interface.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text.
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Font | Gets or sets the font for the text.
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font.
Public property | FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | LineAlignment | Gets or sets the line alignment.
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | Minimized | Gets or sets a value indicating whether the annotation is minimized.
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Padding | Gets or sets a value indicating how much padding is added around the text.
Public property | RenderingHint | Gets or sets the System.Drawing.Text.TextRenderingHint used when rendering this text
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowMode | Gets or sets the shadow mode used to indicate how the shadow is drawn.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for this annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | Trimming | Get or sets the type of character trimming to perform on the text.
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Alignment Property

TextDataAlignment Property

Gets or sets the horizontal alignment of the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment Alignment { get; set; }
Public Property Alignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The horizontal text alignment.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.AllowEditing Property

TextDataAllowEditing Property

Gets or sets a value indicating whether the annotation's text data should be editable or read-only via the user interface.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

Property Value

Type: Boolean

Indicates whether the annotation's text data should be editable or read-only.

See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.AutoSize Property

TextDataAutoSize Property

Gets or sets a value indicating whether the annotation will automatically resize to fit the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation will resize to fit the text.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Bounds Property

TextDataBounds Property

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Fill Property

TextDataFill Property

Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Font Property

TextDataFont Property

Gets or sets the font for the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used when rendering the text.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.FontBrush Property

TextDataFontBrush Property

Gets or sets the AnnotationBrush used for the font.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used when rendering the text.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.FormatFlags Property

TextDataFormatFlags Property

Gets or sets a StringFormatFlags enumeration that contains formatting information.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringFormatFlags FormatFlags { get; set; }
Public Property FormatFlags As StringFormatFlags
    Get
    Set

Property Value

Type: StringFormatFlags
Formatting for the text.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.LineAlignment Property

TextDataLineAlignment Property

Gets or sets the line alignment.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment LineAlignment { get; set; }
Public Property LineAlignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The line alignment.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Minimized Property

TextDataMinimized Property

Gets or sets a value indicating whether the annotation is minimized.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Minimized { get; set; }
Public Property Minimized As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation is minimized.
Remarks
This feature may not be implemented by all viewers.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Outline Property

TextDataOutline Property

Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Padding Property

TextDataPadding Property

Gets or sets a value indicating how much padding is added around the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Padding { get; set; }
Public Property Padding As Single
    Get
    Set

Property Value

Type: Single
A value indicating the amount of padding to add around the text.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.RenderingHint Property

TextDataRenderingHint Property

Gets or sets the System.Drawing.Text.TextRenderingHint used when rendering this text

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextRenderingHint RenderingHint { get; set; }
Public Property RenderingHint As TextRenderingHint
    Get
    Set

Property Value

Type: TextRenderingHint
The current System.Drawing.Text.TextRenderingHint setting
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Shadow Property

TextDataShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.ShadowMode Property

TextDataShadowMode Property

Gets or sets the shadow mode used to indicate how the shadow is drawn.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ShadowMode ShadowMode { get; set; }
Public Property ShadowMode As ShadowMode
    Get
    Set

Property Value

Type: ShadowMode
A value indicating how the shadow is drawn.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.ShadowOffset Property

TextDataShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Text Property

TextDataText Property

Gets or sets the text for this annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The annotation text.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Trimming Property

TextDataTrimming Property

Get or sets the type of character trimming to perform on the text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringTrimming Trimming { get; set; }
Public Property Trimming As StringTrimming
    Get
    Set

Property Value

Type: StringTrimming
Specifies how to trim characters from a string that does not completely fit into a layout shape.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData Methods

The TextData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this TextData. (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | Creates a copy of this TextData. (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another TextData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this object. (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWangAttributeData | Returns a WangAttributeData containing information about this TextData.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | Called just before a property value is changed. (Inherited from AnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Clone Method

TextDataClone Method

Creates a copy of this TextData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this annotation data.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.CloneBaseData Method

TextDataCloneBaseData Method

Creates a copy of this TextData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData

Return Value

Type:
A copy of this annotation data.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.Equals Method

TextDataEquals Method

Determines if another TextData object has the same property settings.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An TextData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.GetHashCode Method

TextDataGetHashCode Method

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.GetObjectData Method

TextDataGetObjectData Method

Fills a SerializationInfo object with information about this object.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where the information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData.GetWangAttributeData Method

TextDataGetWangAttributeData Method

Returns a WangAttributeData containing information about this TextData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData GetWangAttributeData()
Public Function GetWangAttributeData As WangAttributeData

Return Value

Type: WangAttributeData
A WangAttributeData for this annotation.

Implements

IWangCompatibleGetWangAttributeData
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


TextData Events

The TextData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

TextData Class
Atalasoft.Annotate Namespace


UndoChange Enumeration

Specifies the type of undo being performed.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum UndoChange
Public Enumeration UndoChange
Members
Member name | Description
PropertyChange | Used when a property of the annotation has been changed.
CollectiveChange | Used when multiple undo actions are combined into a single undo.
InvokeMethod | Used when a method, such as Mirror, is invoked.
See Also

Reference

Atalasoft.Annotate Namespace


UndoManagerAction Enumeration

Specifies the actions taken when an AnnotationUndo is passed to the AnnotationControllerNotification event.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum UndoManagerAction
Public Enumeration UndoManagerAction
Members
Member name | Description
Default | The undo is added to the AnnotationUndoManager.
Ignore | The undo is ignored.
Combine | The undo and all that follow until a ResetDefault action is received are combined into a single undo object.
ResetDefault | Indicates that this is the last undo to combine with previous undos.
See Also

Reference

Atalasoft.Annotate Namespace


WangAnnotationType Enumeration

Specifies the type of WANG annotation used for serialization.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WangAnnotationType
Public Enumeration WangAnnotationType
Members
Member name | Description
ImageEmbedded | An image annotation in which the image data is embedded into the WANG data.
ImageReference | An image annotation in which a filename is specified for the image.
StraightLine | A single line annotation.
FreehandLine | A freehand annotation.
HollowRectangle | A rectangle annotation without a fill.
FilledRectangle | A filled rectangle annotation.
TypedText | A text annotation.
TextFromFile | A text annotation containing text from a file.
TextStamp | A text annotation that cannot be edited.
AttachANote | A text annotation that has the appearance of a sticky note.
OcrRegion | A rectangle selected to identify an area of the image to OCR in a separate process.
See Also

Reference

Atalasoft.Annotate Namespace


WangAttributeData Class

This class hold information used by the WangFormatter when serializing AnnotationData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateWangAttributeData

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WangAttributeData
Public Class WangAttributeData

The WangAttributeData type exposes the following members.

Constructors
 | Name | Description
Public method | WangAttributeData | Creates a new instance of WangAttributeData.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounding rectangle of the annotation.
Public property | Color1 | The primary color of the annotation.
Public property | Color2 | Gets or sets the text color of an Attach-a-Note WANG annotation.
Public property | Dib | Gets or sets the image data for embedded image annotations.
Public property | FileName | Gets or sets the filename of the image for ImageReference WANG annotations.
Public property | Font | Gets or sets the font used for WANG annotations that contain text.
Public property | Group | Gets or sets the group.
Public property | Highlighting | Gets or sets a value indicating whether the annotation is a highlighter.
Public property | ImageTransformation | Gets or sets the image transformation.
Public property | LineSize | Gets or sets the size of the annotation lines.
Public property | Points | Gets or sets a PointFCollection containing the points for a StraightLine or FreehandLine WANG annotation.
Public property | Text | Gets or sets the text for the annotation.
Public property | Time | Gets or sets the time that the annotation was first saved.
Public property | Transparent | Gets or sets a value indicating whether white pixel are rendered as transparent.
Public property | Type | The type of WANG annotation.
Public property | UnknownType6Data | Gets or sets the unknown type6 data.
Public property | Visible | Gets or sets a value indicating if the annotation is visible.
Top
Methods
 | Name | Description
 | CreateAttachANoteAttribute | Creates a new instance of WangAttributeData for an Attach-a-Note annotation.
 | CreateFilledRectangleAttribute | Creates a new instance of WangAttributeData for a FilledRectangle annotation.
 | CreateFreehandLineAttribute | Creates a new instance of WangAttributeData for a FreehandLine annotation.
 | CreateHollowRectangleAttribute | Creates a new instance of WangAttributeData for a HollowRectangle annotation.
 | CreateImageEmbeddedAttribute | Creates a new WangAttributeData for an ImageEmbedded annotation.
 | CreateImageReferenceAttribute | Creates a new instance of WangAttributeData for an ImageReference annotation.
 | CreateOcrRegionAttribute | Creates a new instance of WangAttributeData for an OCR region annotation.
 | CreateStraightLineAttribute | Creates a new instance of WangAttributeData for a StraightLine annotation.
 | CreateTextFromFileAttribute | Creates a new instance of WantAttributeData for a TextFromFile annotation.
 | CreateTextStampAttribute | Creates a new instance of WangAttributeData for a TextStamp annotation.
 | CreateTypedTextAttribute | Creates a new instance of WangAttributeData for a TypedText annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate Namespace


WangAttributeData Constructor

Creates a new instance of WangAttributeData.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData()
Public Sub New
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData Properties

The WangAttributeData type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounding rectangle of the annotation.
Public property | Color1 | The primary color of the annotation.
Public property | Color2 | Gets or sets the text color of an Attach-a-Note WANG annotation.
Public property | Dib | Gets or sets the image data for embedded image annotations.
Public property | FileName | Gets or sets the filename of the image for ImageReference WANG annotations.
Public property | Font | Gets or sets the font used for WANG annotations that contain text.
Public property | Group | Gets or sets the group.
Public property | Highlighting | Gets or sets a value indicating whether the annotation is a highlighter.
Public property | ImageTransformation | Gets or sets the image transformation.
Public property | LineSize | Gets or sets the size of the annotation lines.
Public property | Points | Gets or sets a PointFCollection containing the points for a StraightLine or FreehandLine WANG annotation.
Public property | Text | Gets or sets the text for the annotation.
Public property | Time | Gets or sets the time that the annotation was first saved.
Public property | Transparent | Gets or sets a value indicating whether white pixel are rendered as transparent.
Public property | Type | The type of WANG annotation.
Public property | UnknownType6Data | Gets or sets the unknown type6 data.
Public property | Visible | Gets or sets a value indicating if the annotation is visible.
Top
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Bounds Property

WangAttributeDataBounds Property

Gets or sets the bounding rectangle of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Bounds { get; set; }
Public Property Bounds As RectangleF
    Get
    Set

Property Value

Type: RectangleF
The bounding rectangle of the annotation.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Color1 Property

WangAttributeDataColor1 Property

The primary color of the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color1 { get; set; }
Public Property Color1 As Color
    Get
    Set

Property Value

Type: Color
The color of the annotation.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Color2 Property

WangAttributeDataColor2 Property

Gets or sets the text color of an Attach-a-Note WANG annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color2 { get; set; }
Public Property Color2 As Color
    Get
    Set

Property Value

Type: Color
The Attach-a-Note text color.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Dib Property

WangAttributeDataDib Property

Gets or sets the image data for embedded image annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Dib { get; set; }
Public Property Dib As Byte()
    Get
    Set

Property Value

Type: Byte
The embedded image data in DIB format.
Remarks
This data must be a standard DIB including the BITMAPINFOHEADER.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.FileName Property

WangAttributeDataFileName Property

Gets or sets the filename of the image for ImageReference WANG annotations.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The filename of the image.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Font Property

WangAttributeDataFont Property

Gets or sets the font used for WANG annotations that contain text.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used when rendering text.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Group Property

WangAttributeDataGroup Property

Gets or sets the group.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set

Property Value

Type: String
The group.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Highlighting Property

WangAttributeDataHighlighting Property

Gets or sets a value indicating whether the annotation is a highlighter.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Highlighting { get; set; }
Public Property Highlighting As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether or not this annotation is a highlighter.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.ImageTransformation Property

WangAttributeDataImageTransformation Property

Gets or sets the image transformation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangFormatterWangImageAnnotationImageAttributes ImageTransformation { get; set; }
Public Property ImageTransformation As WangFormatterWangImageAnnotationImageAttributes
    Get
    Set

Property Value

Type: WangFormatterWangImageAnnotationImageAttributes
The image transformation.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.LineSize Property

WangAttributeDataLineSize Property

Gets or sets the size of the annotation lines.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float LineSize { get; set; }
Public Property LineSize As Single
    Get
    Set

Property Value

Type: Single
The annotation line size.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Points Property

WangAttributeDataPoints Property

Gets or sets a PointFCollection containing the points for a StraightLine or FreehandLine WANG annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection Points { get; set; }
Public Property Points As PointFCollection
    Get
    Set

Property Value

Type: PointFCollection
A PointFCollection containing annotation data points.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Text Property

WangAttributeDataText Property

Gets or sets the text for the annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text of the annotation.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Time Property

WangAttributeDataTime Property

Gets or sets the time that the annotation was first saved.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime Time { get; set; }
Public Property Time As DateTime
    Get
    Set

Property Value

Type: DateTime
The time the annotation as saved.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Transparent Property

WangAttributeDataTransparent Property

Gets or sets a value indicating whether white pixel are rendered as transparent.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Transparent { get; set; }
Public Property Transparent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether white pixels are rendered as transparent.
Remarks
See the Type property for information on which WANG annotation types require this property.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Type Property

WangAttributeDataType Property

The type of WANG annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAnnotationType Type { get; set; }
Public Property Type As WangAnnotationType
    Get
    Set

Property Value

Type: WangAnnotationType
The annotation type.
Remarks

Each WangAnnotationType requires setting specific properties. Below is a list for these properties:

WangAnnotationType | Properties
ImageEmbedded | Bounds Dib Transparent
ImageReference | Bounds FileName Transparent
StraightLine FreehandLine | Color1 Highlighting LineSize Points
HollowRectangle | Bounds Color1 Highlighting LineSize
FilledRectangle | Bounds Color1 Highlighting
TypedText TextFromFile TextStamp | Bounds Color1 Font Text
AttachANote | Bounds Color1 Color2 Font Text

See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.UnknownType6Data Property

WangAttributeDataUnknownType6Data Property

Gets or sets the unknown type6 data.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dictionary<string, byte[]> UnknownType6Data { get; set; }
Public Property UnknownType6Data As Dictionary(Of String, Byte())
    Get
    Set

Property Value

Type: Dictionary String, Byte
The unknown type6 data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.Visible Property

WangAttributeDataVisible Property

Gets or sets a value indicating if the annotation is visible.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the annotation is visible.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData Methods

The WangAttributeData type exposes the following members.

Methods
 | Name | Description
 | CreateAttachANoteAttribute | Creates a new instance of WangAttributeData for an Attach-a-Note annotation.
 | CreateFilledRectangleAttribute | Creates a new instance of WangAttributeData for a FilledRectangle annotation.
 | CreateFreehandLineAttribute | Creates a new instance of WangAttributeData for a FreehandLine annotation.
 | CreateHollowRectangleAttribute | Creates a new instance of WangAttributeData for a HollowRectangle annotation.
 | CreateImageEmbeddedAttribute | Creates a new WangAttributeData for an ImageEmbedded annotation.
 | CreateImageReferenceAttribute | Creates a new instance of WangAttributeData for an ImageReference annotation.
 | CreateOcrRegionAttribute | Creates a new instance of WangAttributeData for an OCR region annotation.
 | CreateStraightLineAttribute | Creates a new instance of WangAttributeData for a StraightLine annotation.
 | CreateTextFromFileAttribute | Creates a new instance of WantAttributeData for a TextFromFile annotation.
 | CreateTextStampAttribute | Creates a new instance of WangAttributeData for a TextStamp annotation.
 | CreateTypedTextAttribute | Creates a new instance of WangAttributeData for a TypedText annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateAttachANoteAttribute Method

WangAttributeDataCreateAttachANoteAttribute Method

Creates a new instance of WangAttributeData for an Attach-a-Note annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateAttachANoteAttribute(
    RectangleF bounds,
    Color color1,
    Color color2,
    AnnotationFont font,
    string text
)
Public Shared Function CreateAttachANoteAttribute (
    bounds As RectangleF,
    color1 As Color,
    color2 As Color,
    font As AnnotationFont,
    text As String
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
color1
Type: System.DrawingColor
The color of the annotation.
color2
Type: System.DrawingColor
The text color.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used when rendering text.
text
Type: SystemString
The text of the annotation.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateFilledRectangleAttribute Method

WangAttributeDataCreateFilledRectangleAttribute Method

Creates a new instance of WangAttributeData for a FilledRectangle annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateFilledRectangleAttribute(
    RectangleF bounds,
    Color color1,
    bool highlighting
)
Public Shared Function CreateFilledRectangleAttribute (
    bounds As RectangleF,
    color1 As Color,
    highlighting As Boolean
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
color1
Type: System.DrawingColor
The color of the annotation.
highlighting
Type: SystemBoolean
A value indicating whether or not this annotation is a highlighter.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateFreehandLineAttribute Method

WangAttributeDataCreateFreehandLineAttribute Method

Creates a new instance of WangAttributeData for a FreehandLine annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateFreehandLineAttribute(
    Color color1,
    bool highlighting,
    float lineSize,
    PointFCollection points
)
Public Shared Function CreateFreehandLineAttribute (
    color1 As Color,
    highlighting As Boolean,
    lineSize As Single,
    points As PointFCollection
) As WangAttributeData

Parameters

color1
Type: System.DrawingColor
The line color of the annotation.
highlighting
Type: SystemBoolean
A value indicating whether or not this annotation is a highlighter.
lineSize
Type: SystemSingle
The annotation line size.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing annotation data points.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateHollowRectangleAttribute Method

WangAttributeDataCreateHollowRectangleAttribute Method

Creates a new instance of WangAttributeData for a HollowRectangle annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateHollowRectangleAttribute(
    RectangleF bounds,
    Color color1,
    bool highlighting,
    float lineSize
)
Public Shared Function CreateHollowRectangleAttribute (
    bounds As RectangleF,
    color1 As Color,
    highlighting As Boolean,
    lineSize As Single
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
color1
Type: System.DrawingColor
The line color of the annotation.
highlighting
Type: SystemBoolean
A value indicating whether or not this annotation is a highlighter.
lineSize
Type: SystemSingle
The annotation line size.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateImageEmbeddedAttribute Method

WangAttributeDataCreateImageEmbeddedAttribute Method

Creates a new WangAttributeData for an ImageEmbedded annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateImageEmbeddedAttribute(
    RectangleF bounds,
    byte[] dib,
    bool transparent
)
Public Shared Function CreateImageEmbeddedAttribute (
    bounds As RectangleF,
    dib As Byte(),
    transparent As Boolean
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
dib
Type: SystemByte
The embedded image data in DIB format.
transparent
Type: SystemBoolean
A value indicating whether white pixels are rendered as transparent.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateImageReferenceAttribute Method

WangAttributeDataCreateImageReferenceAttribute Method

Creates a new instance of WangAttributeData for an ImageReference annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateImageReferenceAttribute(
    RectangleF bounds,
    string fileName,
    bool transparent
)
Public Shared Function CreateImageReferenceAttribute (
    bounds As RectangleF,
    fileName As String,
    transparent As Boolean
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
fileName
Type: SystemString
The filename of the image.
transparent
Type: SystemBoolean
A value indicating whether white pixels are rendered as transparent.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateOcrRegionAttribute Method

WangAttributeDataCreateOcrRegionAttribute Method

Creates a new instance of WangAttributeData for an OCR region annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateOcrRegionAttribute(
    RectangleF bounds,
    Color color1,
    AnnotationFont font,
    int sequenceOrder
)
Public Shared Function CreateOcrRegionAttribute (
    bounds As RectangleF,
    color1 As Color,
    font As AnnotationFont,
    sequenceOrder As Integer
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounds for the annotation.
color1
Type: System.DrawingColor
The color of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font for the annotation.
sequenceOrder
Type: SystemInt32
The sequence order for the annotation.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateStraightLineAttribute Method

WangAttributeDataCreateStraightLineAttribute Method

Creates a new instance of WangAttributeData for a StraightLine annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateStraightLineAttribute(
    Color color1,
    bool highlighting,
    float lineSize,
    PointFCollection points
)
Public Shared Function CreateStraightLineAttribute (
    color1 As Color,
    highlighting As Boolean,
    lineSize As Single,
    points As PointFCollection
) As WangAttributeData

Parameters

color1
Type: System.DrawingColor
The line color of the annotation.
highlighting
Type: SystemBoolean
A value indicating whether or not this annotation is a highlighter.
lineSize
Type: SystemSingle
The annotation line size.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing annotation data points.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateTextFromFileAttribute Method

WangAttributeDataCreateTextFromFileAttribute Method

Creates a new instance of WantAttributeData for a TextFromFile annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateTextFromFileAttribute(
    RectangleF bounds,
    Color color1,
    AnnotationFont font,
    string text
)
Public Shared Function CreateTextFromFileAttribute (
    bounds As RectangleF,
    color1 As Color,
    font As AnnotationFont,
    text As String
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
color1
Type: System.DrawingColor
The color of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used when rendering text.
text
Type: SystemString
The text of the annotation.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateTextStampAttribute Method

WangAttributeDataCreateTextStampAttribute Method

Creates a new instance of WangAttributeData for a TextStamp annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateTextStampAttribute(
    RectangleF bounds,
    Color color1,
    AnnotationFont font,
    string text
)
Public Shared Function CreateTextStampAttribute (
    bounds As RectangleF,
    color1 As Color,
    font As AnnotationFont,
    text As String
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
color1
Type: System.DrawingColor
The color of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used when rendering text.
text
Type: SystemString
The text of the annotation.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


WangAttributeData.CreateTypedTextAttribute Method

WangAttributeDataCreateTypedTextAttribute Method

Creates a new instance of WangAttributeData for a TypedText annotation.

Namespace: Atalasoft.Annotate
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static WangAttributeData CreateTypedTextAttribute(
    RectangleF bounds,
    Color color1,
    AnnotationFont font,
    string text
)
Public Shared Function CreateTypedTextAttribute (
    bounds As RectangleF,
    color1 As Color,
    font As AnnotationFont,
    text As String
) As WangAttributeData

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
color1
Type: System.DrawingColor
The color of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used when rendering text.
text
Type: SystemString
The text of the annotation.

Return Value

Type: WangAttributeData
A WangAttributeData containing the annotation data.
See Also

Reference

WangAttributeData Class
Atalasoft.Annotate Namespace


Atalasoft.Annotate.Converters Namespace

Classes
 | Class | Description
Public class | AnnotationBrushConverter | This class is a TypeConverter for the AnnotationBrush object.
Public class | AnnotationImageConverter | This class is a TypeConverter for the AnnotationImage object.
Public class | AnnotationPenConverter | This class is a TypeConverter for the AnnotationPen object.


AnnotationBrushConverter Class

This class is a TypeConverter for the AnnotationBrush object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Atalasoft.Annotate.ConvertersAnnotationBrushConverter

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationBrushConverter : TypeConverter
Public Class AnnotationBrushConverter
    Inherits TypeConverter

The AnnotationBrushConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationBrushConverter | Creates a new instance of AnnotationBrushConverter.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter Constructor

Creates a new instance of AnnotationBrushConverter.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrushConverter()
Public Sub New
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter Methods

The AnnotationBrushConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.CanConvertFrom Method

AnnotationBrushConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

AnnotationBrushConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

AnnotationBrushConverter Class
CanConvertFrom Overload
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.CanConvertTo Method

AnnotationBrushConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

AnnotationBrushConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

AnnotationBrushConverter Class
CanConvertTo Overload
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.ConvertFrom Method

AnnotationBrushConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

AnnotationBrushConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AnnotationBrushConverter Class
ConvertFrom Overload
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.ConvertTo Method

AnnotationBrushConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

AnnotationBrushConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AnnotationBrushConverter Class
ConvertTo Overload
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.GetProperties Method

AnnotationBrushConverterGetProperties Method

Overload List
 | Name | Description
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

AnnotationBrushConverterGetProperties Method (ITypeDescriptorContext, Object, Attribute)

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
value
Type: SystemObject
An Object that specifies the type of array for which to get properties.
attributes
Type: SystemAttribute
An array of type Attribute that is used as a filter.

Return Value

Type: PropertyDescriptorCollection
A PropertyDescriptorCollection with the properties that are exposed for this data type, or a null reference (Nothing in Visual Basic) if there are no properties.
See Also

Reference

AnnotationBrushConverter Class
GetProperties Overload
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.GetPropertiesSupported Method

AnnotationBrushConverterGetPropertiesSupported Method

Overload List
 | Name | Description
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationBrushConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationBrushConverter.GetPropertiesSupported Method (ITypeDescriptorContext)

AnnotationBrushConverterGetPropertiesSupported Method (ITypeDescriptorContext)

Returns whether this object supports properties, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.

Return Value

Type: Boolean
True if GetProperties should be called to find the properties of this object; otherwise, false.
See Also

Reference

AnnotationBrushConverter Class
GetPropertiesSupported Overload
Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter Class

This class is a TypeConverter for the AnnotationImage object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Atalasoft.Annotate.ConvertersAnnotationImageConverter

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationImageConverter : TypeConverter
Public Class AnnotationImageConverter
    Inherits TypeConverter

The AnnotationImageConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationImageConverter | Creates a new instance of AnnotationImageConverter object.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter Constructor

Creates a new instance of AnnotationImageConverter object.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImageConverter()
Public Sub New
See Also

Reference

AnnotationImageConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter Methods

The AnnotationImageConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationImageConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter.CanConvertFrom Method

AnnotationImageConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AnnotationImageConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

AnnotationImageConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

AnnotationImageConverter Class
CanConvertFrom Overload
Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter.ConvertFrom Method

AnnotationImageConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

AnnotationImageConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationImageConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

AnnotationImageConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AnnotationImageConverter Class
ConvertFrom Overload
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter Class

This class is a TypeConverter for the AnnotationPen object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Atalasoft.Annotate.ConvertersAnnotationPenConverter

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationPenConverter : TypeConverter
Public Class AnnotationPenConverter
    Inherits TypeConverter

The AnnotationPenConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPenConverter | Creates a new instance of AnnotationPenConverter.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter Constructor

Creates a new instance of AnnotationPenConverter.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPenConverter()
Public Sub New
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter Methods

The AnnotationPenConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.CanConvertFrom Method

AnnotationPenConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

AnnotationPenConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

AnnotationPenConverter Class
CanConvertFrom Overload
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.CanConvertTo Method

AnnotationPenConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

AnnotationPenConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

AnnotationPenConverter Class
CanConvertTo Overload
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.ConvertFrom Method

AnnotationPenConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

AnnotationPenConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AnnotationPenConverter Class
ConvertFrom Overload
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.ConvertTo Method

AnnotationPenConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

AnnotationPenConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AnnotationPenConverter Class
ConvertTo Overload
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.GetProperties Method

AnnotationPenConverterGetProperties Method

Overload List
 | Name | Description
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverterGetProperties(ITypeDescriptorContext, Object, Attribute).)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

AnnotationPenConverterGetProperties Method (ITypeDescriptorContext, Object, Attribute)

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
value
Type: SystemObject
An Object that specifies the type of array for which to get properties.
attributes
Type: SystemAttribute
An array of type Attribute that is used as a filter.

Return Value

Type: PropertyDescriptorCollection
A PropertyDescriptorCollection with the properties that are exposed for this data type, or a null reference (Nothing in Visual Basic) if there are no properties.
See Also

Reference

AnnotationPenConverter Class
GetProperties Overload
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.GetPropertiesSupported Method

AnnotationPenConverterGetPropertiesSupported Method

Overload List
 | Name | Description
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverterGetPropertiesSupported(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationPenConverter Class
Atalasoft.Annotate.Converters Namespace


AnnotationPenConverter.GetPropertiesSupported Method (ITypeDescriptorContext)

AnnotationPenConverterGetPropertiesSupported Method (ITypeDescriptorContext)

Returns whether this object supports properties, using the specified context.

Namespace: Atalasoft.Annotate.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.

Return Value

Type: Boolean
True if GetProperties should be called to find the properties of this object; otherwise, false.
See Also

Reference

AnnotationPenConverter Class
GetPropertiesSupported Overload
Atalasoft.Annotate.Converters Namespace


Atalasoft.Annotate.Editors Namespace

Classes
 | Class | Description
Public class | AnnotationBrushEditor | This class is a UITypeEditor for the AnnotationBrush object.
Public class | AnnotationFontEditor | This class is a UITypeEditor for the AnnotationFont object.
Public class | AnnotationImageEditor | This class is a UITypeEditor for the AnnotationImage object.
Public class | AnnotationPenEditor | This class is a UITypeEditor for the AnnotationPen object.


AnnotationBrushEditor Class

This class is a UITypeEditor for the AnnotationBrush object.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
Atalasoft.Annotate.EditorsAnnotationBrushEditor

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationBrushEditor : UITypeEditor
Public Class AnnotationBrushEditor
    Inherits UITypeEditor

The AnnotationBrushEditor type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationBrushEditor | Creates a new instance of AnnotationBrushEditor.
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor Constructor

Creates a new instance of AnnotationBrushEditor.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrushEditor()
Public Sub New
See Also

Reference

AnnotationBrushEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor Properties

The AnnotationBrushEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

AnnotationBrushEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor Methods

The AnnotationBrushEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationBrushEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor.EditValue Method

AnnotationBrushEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

AnnotationBrushEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

AnnotationBrushEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Edits the specified object's value using the editor style indicated by GetEditStyle.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: SystemIServiceProvider
An IServiceProvider that this editor can use to obtain services.
value
Type: SystemObject
The object to edit.

Return Value

Type: Object
The new value of the object.
See Also

Reference

AnnotationBrushEditor Class
EditValue Overload
Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor.GetEditStyle Method

AnnotationBrushEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationBrushEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationBrushEditor.GetEditStyle Method (ITypeDescriptorContext)

AnnotationBrushEditorGetEditStyle Method (ITypeDescriptorContext)

Gets the editor style used by the EditValue method.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: UITypeEditorEditStyle
A UITypeEditorEditStyle value that indicates the style of editor used by EditValue. If the UITypeEditor does not support this method, then GetEditStyle will return None.
See Also

Reference

AnnotationBrushEditor Class
GetEditStyle Overload
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor Class

This class is a UITypeEditor for the AnnotationFont object.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
Atalasoft.Annotate.EditorsAnnotationFontEditor

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationFontEditor : UITypeEditor
Public Class AnnotationFontEditor
    Inherits UITypeEditor

The AnnotationFontEditor type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationFontEditor | Creates a new instance of AnnotationFontEditor.
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor Constructor

Creates a new instance of AnnotationFontEditor.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFontEditor()
Public Sub New
See Also

Reference

AnnotationFontEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor Properties

The AnnotationFontEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

AnnotationFontEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor Methods

The AnnotationFontEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationFontEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor.EditValue Method

AnnotationFontEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

AnnotationFontEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

AnnotationFontEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Edits the specified object's value using the editor style indicated by GetEditStyle.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: SystemIServiceProvider
An IServiceProvider that this editor can use to obtain services.
value
Type: SystemObject
The object to edit.

Return Value

Type: Object
The new value of the object.
See Also

Reference

AnnotationFontEditor Class
EditValue Overload
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor.GetEditStyle Method

AnnotationFontEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationFontEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationFontEditor.GetEditStyle Method (ITypeDescriptorContext)

AnnotationFontEditorGetEditStyle Method (ITypeDescriptorContext)

Gets the editor style used by the EditValue method.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: UITypeEditorEditStyle
A UITypeEditorEditStyle value that indicates the style of editor used by EditValue. If the UITypeEditor does not support this method, then GetEditStyle will return None.
See Also

Reference

AnnotationFontEditor Class
GetEditStyle Overload
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor Class

This class is a UITypeEditor for the AnnotationImage object.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
Atalasoft.Annotate.EditorsAnnotationImageEditor

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationImageEditor : UITypeEditor
Public Class AnnotationImageEditor
    Inherits UITypeEditor

The AnnotationImageEditor type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationImageEditor | Creates a new instance of AnnotationImageEditor.
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditorGetPaintValueSupported(ITypeDescriptorContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditorPaintValue(PaintValueEventArgs).)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor Constructor

Creates a new instance of AnnotationImageEditor.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImageEditor()
Public Sub New
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor Properties

The AnnotationImageEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor Methods

The AnnotationImageEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditorGetPaintValueSupported(ITypeDescriptorContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditorPaintValue(PaintValueEventArgs).)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.EditValue Method

AnnotationImageEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

AnnotationImageEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Edits the specified object's value using the editor style indicated by GetEditStyle.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: SystemIServiceProvider
An IServiceProvider that this editor can use to obtain services.
value
Type: SystemObject
The object to edit.

Return Value

Type: Object
The new value of the object.
See Also

Reference

AnnotationImageEditor Class
EditValue Overload
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.GetEditStyle Method

AnnotationImageEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.GetEditStyle Method (ITypeDescriptorContext)

AnnotationImageEditorGetEditStyle Method (ITypeDescriptorContext)

Gets the editor style used by the EditValue method.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: UITypeEditorEditStyle
A UITypeEditorEditStyle value that indicates the style of editor used by EditValue. If the UITypeEditor does not support this method, then GetEditStyle will return None.
See Also

Reference

AnnotationImageEditor Class
GetEditStyle Overload
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.GetPaintValueSupported Method

AnnotationImageEditorGetPaintValueSupported Method

Overload List
 | Name | Description
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditorGetPaintValueSupported(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.GetPaintValueSupported Method (ITypeDescriptorContext)

AnnotationImageEditorGetPaintValueSupported Method (ITypeDescriptorContext)

Indicates whether the specified context supports painting a representation of an object's value within the specified context.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool GetPaintValueSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPaintValueSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: Boolean
True if PaintValue is implemented; otherwise, false.
See Also

Reference

AnnotationImageEditor Class
GetPaintValueSupported Overload
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.PaintValue Method

AnnotationImageEditorPaintValue Method

Overload List
 | Name | Description
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditorPaintValue(PaintValueEventArgs).)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Top
See Also

Reference

AnnotationImageEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationImageEditor.PaintValue Method (PaintValueEventArgs)

AnnotationImageEditorPaintValue Method (PaintValueEventArgs)

Paints a representation of the value of an object using the specified PaintValueEventArgs.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void PaintValue(
    PaintValueEventArgs e
)
Public Overrides Sub PaintValue (
    e As PaintValueEventArgs
)

Parameters

e
Type: System.Drawing.DesignPaintValueEventArgs
A PaintValueEventArgs that indicates what to paint and where to paint it.
See Also

Reference

AnnotationImageEditor Class
PaintValue Overload
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor Class

This class is a UITypeEditor for the AnnotationPen object.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
Atalasoft.Annotate.EditorsAnnotationPenEditor

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationPenEditor : UITypeEditor
Public Class AnnotationPenEditor
    Inherits UITypeEditor

The AnnotationPenEditor type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPenEditor | Creates a new instance of AnnotationPenEditor.
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor Constructor

Creates a new instance of AnnotationPenEditor.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPenEditor()
Public Sub New
See Also

Reference

AnnotationPenEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor Properties

The AnnotationPenEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

AnnotationPenEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor Methods

The AnnotationPenEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationPenEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor.EditValue Method

AnnotationPenEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by GetEditStyle. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

AnnotationPenEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

AnnotationPenEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Edits the specified object's value using the editor style indicated by GetEditStyle.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: SystemIServiceProvider
An IServiceProvider that this editor can use to obtain services.
value
Type: SystemObject
The object to edit.

Return Value

Type: Object
The new value of the object.
See Also

Reference

AnnotationPenEditor Class
EditValue Overload
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor.GetEditStyle Method

AnnotationPenEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

AnnotationPenEditor Class
Atalasoft.Annotate.Editors Namespace


AnnotationPenEditor.GetEditStyle Method (ITypeDescriptorContext)

AnnotationPenEditorGetEditStyle Method (ITypeDescriptorContext)

Gets the editor style used by the EditValue method.

Namespace: Atalasoft.Annotate.Editors
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: UITypeEditorEditStyle
A UITypeEditorEditStyle value that indicates the style of editor used by EditValue. If the UITypeEditor does not support this method, then GetEditStyle will return None.
See Also

Reference

AnnotationPenEditor Class
GetEditStyle Overload
Atalasoft.Annotate.Editors Namespace


Atalasoft.Annotate.Exporters Namespace

The Atalasoft.Annotate.Exporters namespace provides objects used to export annotations to a specific format. Currently PDF is the only format supported.
Classes
 | Class | Description
Public class | AnnotationDataExporter | An abstract base class that encompasses elements for exporting annotations.
Public class | PdfAnnotationDataExporter | The PdfAnnotationDataExporter object is capable of taking DotImage Annotation objects and translating them into a format suitable for PDF.
Public class | PdfAnnotationExportPolicy | PdfAnnotationExportPolicy is a class used to help the PdfAnnotationDataExporter select a mechanism for exporting an unknown annotation type.
Delegates
 | Delegate | Description
Public delegate | PdfUnknownAnnotationHandler | Represents a method for selecting a PdfAnnotationExportPolicy to use when an unknown annotation type is encountered.
Enumerations
 | Enumeration | Description
Public enumeration | PdfAnnotationEmbeddingAction | This enumeration is used to select how an unknown annotation type will be exported to pdf.


AnnotationDataExporter Class

An abstract base class that encompasses elements for exporting annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ExportersAnnotationDataExporter
Atalasoft.Annotate.ExportersPdfAnnotationDataExporter

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class AnnotationDataExporter
Public MustInherit Class AnnotationDataExporter

The AnnotationDataExporter type exposes the following members.

Constructors
 | Name | Description
Protected method | AnnotationDataExporter | Initializes the AnnotationDataExporter.
Top
Properties
 | Name | Description
Public property | CanExport | Gets a value indicating whether or not this AnnotationDataExporter can do a simple export.
Public property | CanExportOver | Gets a value indicating whether or not this AnnotationDataExporter can write annotations to a stream without affecting existing contents.
Top
Methods
 | Name | Description
Public method | Construct | A factory method to construct a new AnnotationDataExporter.
Protected method | CopyStream | Copies the entire source stream to the destination stream.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Exports a single page of annotations to a given stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Export a set of annotations over an existing stream
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Export a set of annotations over an existing stream.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if the stream is the correct format.
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter Constructor

Initializes the AnnotationDataExporter.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AnnotationDataExporter()
Protected Sub New
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter Properties

The AnnotationDataExporter type exposes the following members.

Properties
 | Name | Description
Public property | CanExport | Gets a value indicating whether or not this AnnotationDataExporter can do a simple export.
Public property | CanExportOver | Gets a value indicating whether or not this AnnotationDataExporter can write annotations to a stream without affecting existing contents.
Top
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.CanExport Property

AnnotationDataExporterCanExport Property

Gets a value indicating whether or not this AnnotationDataExporter can do a simple export.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool CanExport { get; }
Public MustOverride ReadOnly Property CanExport As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether this AnnotationDataExporter can do a simple export.
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.CanExportOver Property

AnnotationDataExporterCanExportOver Property

Gets a value indicating whether or not this AnnotationDataExporter can write annotations to a stream without affecting existing contents.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool CanExportOver { get; }
Public MustOverride ReadOnly Property CanExportOver As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether or not this AnnotationDataExporter can write annotations to a stream without affecting existing contents.
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter Methods

The AnnotationDataExporter type exposes the following members.

Methods
 | Name | Description
Public method | Construct | A factory method to construct a new AnnotationDataExporter.
Protected method | CopyStream | Copies the entire source stream to the destination stream.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Exports a single page of annotations to a given stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Export a set of annotations over an existing stream
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Export a set of annotations over an existing stream.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if the stream is the correct format.
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.Construct Method

AnnotationDataExporterConstruct Method

A factory method to construct a new AnnotationDataExporter.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AnnotationDataExporter Construct()
Public MustOverride Function Construct As AnnotationDataExporter

Return Value

Type: AnnotationDataExporter
A new AnnotationDataExporter object.
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.CopyStream Method

AnnotationDataExporterCopyStream Method

Copies the entire source stream to the destination stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void CopyStream(
    Stream sourceStream,
    Stream destStream
)
Protected Overridable Sub CopyStream (
    sourceStream As Stream,
    destStream As Stream
)

Parameters

sourceStream
Type: System.IOStream
A non-null stream with annotation source data
destStream
Type: System.IOStream
A non-null stream to which the source data will be copied.
Exceptions
Exception | Condition
 | Thrown if either stream argument is null (Nothing in VB).
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.Export Method

AnnotationDataExporterExport Method

Exports annotations from a given source stream to a given destination stream.
Overload List
 | Name | Description
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Exports a single page of annotations to a given stream.
Top
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.Export Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection)

AnnotationDataExporterExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection)

Exports a multiple pages of annotations to a given stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    AnnotationDataCollection layers
)
Public Sub Export (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
Exceptions
Exception | Condition
 | Thrown if sourceStream or destStream is null (Nothing in VB).
 | Thrown if both CanExport and CanExportOver properties are false.
Remarks
To create a page with no annotations, add an empty LayerData to the collection.
See Also

Reference

AnnotationDataExporter Class
Export Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.Export Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

AnnotationDataExporterExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

Exports a single page of annotations to a given stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex
)
Public Sub Export (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.AnnotateLayerData
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
Exceptions
Exception | Condition
 | Thrown if sourceStream or destStream is null (Nothing in VB).
 | Thrown if frameIndex is less than zero.
 | Thrown if both CanExport and CanExportOver properties are false.
Remarks
A source stream is necessary for some file formats like PDF which require an entire document to hold the annotations. Other formats may ignore the source stream entirely.
See Also

Reference

AnnotationDataExporter Class
Export Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.ExportOver Method

AnnotationDataExporterExportOver Method

Export a set of annotations over an existing stream.
Overload List
 | Name | Description
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Export a set of annotations over an existing stream
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Export a set of annotations over an existing stream.
Top
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.ExportOver Method (Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection)

AnnotationDataExporterExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection)

Export a set of annotations over an existing stream

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ExportOver(
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    AnnotationDataCollection layers
)
Public Sub ExportOver (
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
Exceptions
Exception | Condition
 | Thrown if is null (Nothing in VB).
 | Thrown if both CanExport and CanExportOver properties are false.
See Also

Reference

AnnotationDataExporter Class
ExportOver Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.ExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

AnnotationDataExporterExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

Export a set of annotations over an existing stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ExportOver(
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex
)
Public Sub ExportOver (
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer
)

Parameters

destStream
Type: System.IOStream
The destination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.AnnotateLayerData
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
Exceptions
Exception | Condition
 | Thrown if destStream is null (Nothing in VB).
 | Thrown if the frameIndex is less than zero.
 | Thrown if both CanExport and CanExportOver properties are false.
See Also

Reference

AnnotationDataExporter Class
ExportOver Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.IsValidFormat Method

AnnotationDataExporterIsValidFormat Method

Determines if the stream is the correct format.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool IsValidFormat(
    Stream stm
)
Public MustOverride Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream.

Return Value

Type: Boolean
Returns true if the stream contains valid data for this AnnotationDataExporter, false otherwise.
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.LLExport Method

AnnotationDataExporterLLExport Method

Overload List
 | Name | Description
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).
Top
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.LLExport Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection)

AnnotationDataExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection)

Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolution,
    AnnotationDataCollection layers
)
Protected MustOverride Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolution As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
pageSizes
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
See Also

Reference

AnnotationDataExporter Class
LLExport Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.LLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

AnnotationDataExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

Low level implementation of Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex
)
Protected MustOverride Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer
)

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
pageSize
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layer
Type: Atalasoft.AnnotateLayerData
frameIndex
Type: SystemInt32
See Also

Reference

AnnotationDataExporter Class
LLExport Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.LLExportOver Method

AnnotationDataExporterLLExportOver Method

Overload List
 | Name | Description
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).
Top
See Also

Reference

AnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.LLExportOver Method (Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection)

AnnotationDataExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection)

Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExportOver(
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolution,
    AnnotationDataCollection layers
)
Protected MustOverride Sub LLExportOver (
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolution As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

destStream
Type: System.IOStream
pageSizes
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
See Also

Reference

AnnotationDataExporter Class
LLExportOver Overload
Atalasoft.Annotate.Exporters Namespace


AnnotationDataExporter.LLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

AnnotationDataExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

Low level implementation of ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExportOver(
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex
)
Protected MustOverride Sub LLExportOver (
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer
)

Parameters

destStream
Type: System.IOStream
pageSize
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layer
Type: Atalasoft.AnnotateLayerData
frameIndex
Type: SystemInt32
See Also

Reference

AnnotationDataExporter Class
LLExportOver Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter Class

The PdfAnnotationDataExporter object is capable of taking DotImage Annotation objects and translating them into a format suitable for PDF.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ExportersAnnotationDataExporter
Atalasoft.Annotate.ExportersPdfAnnotationDataExporter

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfAnnotationDataExporter : AnnotationDataExporter
Public Class PdfAnnotationDataExporter
    Inherits AnnotationDataExporter

The PdfAnnotationDataExporter type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationDataExporter | Constructs a new PdfAnnotationDataExporter object.
Public method | PdfAnnotationDataExporter(String, String) | Obsolete. Constructs a new PdfAnnotationDataExporter object with passwords set for loading and saving the PDFs.
Top
Properties
 | Name | Description
Public property | AlwaysEmbedAnnotationData | Indicates whether or not the PdfAnnotationDataExporter will embed data representing the DotImage annotation in its entirety.
Public property | CanExport | For PdfAnnotationDataExporter, this property always return true. (Overrides AnnotationDataExporterCanExport.)
Public property | CanExportOver | For PdfAnnotationDataExporter, this property always return false. (Overrides AnnotationDataExporterCanExportOver.)
Public property | OverwriteExistingAnnotations | Indicates whether or not the PdfAnnotationDataExporter will overwrite annotations that already exist on a page.
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to use when opening and saving the PDF.
Public property | UnknownAnnotationHandler | Sets or gets a handler for unknown annotation types.
Public property | UserPassword | Obsolete. Gets or sets the user password to use when opening and saving the PDF.
Top
Methods
 | Name | Description
Public method | Construct | Constructs a new PdfAnnotationDataExporter. (Overrides AnnotationDataExporterConstruct.)
Protected method | CopyStream | Copies the entire source stream to the destination stream. (Inherited from AnnotationDataExporter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection) | Saves the Pdf file into destStream with exported annotations layers.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Exports a multiple pages of annotations to a given stream. (Inherited from AnnotationDataExporter.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Exports a single page of annotations to a given stream. (Inherited from AnnotationDataExporter.)
Public method | Export(PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString) | Saves the Pdf file into destStream with exported annotations layers.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32, SecureString, SecureString) | Exports a single page of annotations to a given stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Export a set of annotations over an existing stream (Inherited from AnnotationDataExporter.)
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Export a set of annotations over an existing stream. (Inherited from AnnotationDataExporter.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if a stream contains PDF content. (Overrides AnnotationDataExporterIsValidFormat(Stream).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low-level implementation of exporting a multiple pages of annotations to a given stream. (Overrides AnnotationDataExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low-level implementation of exporting a single page of annotations to a given stream. (Overrides AnnotationDataExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low-level implementation of exporting a set of annotations over an existing stream. (Overrides AnnotationDataExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low-level implementation of exporting a set of annotations over an existing stream. (Overrides AnnotationDataExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter Constructor

Overload List
 | Name | Description
Public method | PdfAnnotationDataExporter | Constructs a new PdfAnnotationDataExporter object.
Public method | PdfAnnotationDataExporter(String, String) | Obsolete. Constructs a new PdfAnnotationDataExporter object with passwords set for loading and saving the PDFs.
Top
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter Constructor

Constructs a new PdfAnnotationDataExporter object.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationDataExporter()
Public Sub New
See Also

Reference

PdfAnnotationDataExporter Class
PdfAnnotationDataExporter Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter Constructor (String, String)

Note: This API is now obsolete.

Constructs a new PdfAnnotationDataExporter object with passwords set for loading and saving the PDFs.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use Export method with user and owner passwords parameters.",
    true)]
public PdfAnnotationDataExporter(
    string userPassword,
    string ownerPassword
)
<ObsoleteAttribute("This constructor is obsolete. Use Export method with user and owner passwords parameters.",
    true)>
Public Sub New (
    userPassword As String,
    ownerPassword As String
)

Parameters

userPassword
Type: SystemString
The user password to use when opening and saving the PDF.
ownerPassword
Type: SystemString
The owner password to use when opening and saving the PDF.
See Also

Reference

PdfAnnotationDataExporter Class
PdfAnnotationDataExporter Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter Properties

The PdfAnnotationDataExporter type exposes the following members.

Properties
 | Name | Description
Public property | AlwaysEmbedAnnotationData | Indicates whether or not the PdfAnnotationDataExporter will embed data representing the DotImage annotation in its entirety.
Public property | CanExport | For PdfAnnotationDataExporter, this property always return true. (Overrides AnnotationDataExporterCanExport.)
Public property | CanExportOver | For PdfAnnotationDataExporter, this property always return false. (Overrides AnnotationDataExporterCanExportOver.)
Public property | OverwriteExistingAnnotations | Indicates whether or not the PdfAnnotationDataExporter will overwrite annotations that already exist on a page.
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to use when opening and saving the PDF.
Public property | UnknownAnnotationHandler | Sets or gets a handler for unknown annotation types.
Public property | UserPassword | Obsolete. Gets or sets the user password to use when opening and saving the PDF.
Top
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.AlwaysEmbedAnnotationData Property

PdfAnnotationDataExporterAlwaysEmbedAnnotationData Property

Indicates whether or not the PdfAnnotationDataExporter will embed data representing the DotImage annotation in its entirety.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AlwaysEmbedAnnotationData { get; set; }
Public Property AlwaysEmbedAnnotationData As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
The PdfAnnotationDataExporter tries to build equivalent PDF annotations for known annotation types. There is not always a 1:1 match with the capabilities of DotImage annotations. When this AlwaysEmbedAnnotationData is set to true, the DotImage data will always be embeded in the equivalent PDF annotation. This will create larger PDFs, but the annotations will round-trip 100%.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.CanExport Property

PdfAnnotationDataExporterCanExport Property

For PdfAnnotationDataExporter, this property always return true.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanExport { get; }
Public Overrides ReadOnly Property CanExport As Boolean
    Get

Property Value

Type: Boolean
True.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.CanExportOver Property

PdfAnnotationDataExporterCanExportOver Property

For PdfAnnotationDataExporter, this property always return false.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanExportOver { get; }
Public Overrides ReadOnly Property CanExportOver As Boolean
    Get

Property Value

Type: Boolean
False.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.OverwriteExistingAnnotations Property

PdfAnnotationDataExporterOverwriteExistingAnnotations Property

Indicates whether or not the PdfAnnotationDataExporter will overwrite annotations that already exist on a page.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OverwriteExistingAnnotations { get; set; }
Public Property OverwriteExistingAnnotations As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When set to true, the PdfAnnotationDataExporter will remove existing annotations on a PDF page before writing annotations to be exported. When set to false, the PdfAnnotationExporter will append annotations to the list of existing annotations on a page.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.OwnerPassword Property

PdfAnnotationDataExporterOwnerPassword Property

Note: This API is now obsolete.

Gets or sets the owner password to use when opening and saving the PDF.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use Export method with user and owner passwords parameters.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use Export method with user and owner passwords parameters.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
The owner password.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.UnknownAnnotationHandler Property

PdfAnnotationDataExporterUnknownAnnotationHandler Property

Sets or gets a handler for unknown annotation types.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfUnknownAnnotationHandler UnknownAnnotationHandler { get; set; }
Public Property UnknownAnnotationHandler As PdfUnknownAnnotationHandler
    Get
    Set

Property Value

Type: PdfUnknownAnnotationHandler
Remarks

The PdfAnnotationDataExporter knows how to handle a number of standard annotation types. When an unknown annotation type is found the PdfUnknownAnnotationHandler is invoked to select the mechanism for best exporting this type of annotation. This delegate should return a new PdfAnnotationExportPolicy object that describes how the object should be exported. If the UnknownAnnotationHandler is set to null, the annotation will be skipped.

The default value for PdfUnknownAnnotationHandler is an instance of PdfAnnotationExportPolicy made with its default constructor.

When selecting a policy, an annotation can be skipped, aliased to another annotation, or embedded with a facade.

See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.UserPassword Property

PdfAnnotationDataExporterUserPassword Property

Note: This API is now obsolete.

Gets or sets the user password to use when opening and saving the PDF.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use Export method with user and owner passwords parameters.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use Export method with user and owner passwords parameters.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
The user password.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter Methods

The PdfAnnotationDataExporter type exposes the following members.

Methods
 | Name | Description
Public method | Construct | Constructs a new PdfAnnotationDataExporter. (Overrides AnnotationDataExporterConstruct.)
Protected method | CopyStream | Copies the entire source stream to the destination stream. (Inherited from AnnotationDataExporter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection) | Saves the Pdf file into destStream with exported annotations layers.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Exports a multiple pages of annotations to a given stream. (Inherited from AnnotationDataExporter.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Exports a single page of annotations to a given stream. (Inherited from AnnotationDataExporter.)
Public method | Export(PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString) | Saves the Pdf file into destStream with exported annotations layers.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32, SecureString, SecureString) | Exports a single page of annotations to a given stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Export a set of annotations over an existing stream (Inherited from AnnotationDataExporter.)
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Export a set of annotations over an existing stream. (Inherited from AnnotationDataExporter.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if a stream contains PDF content. (Overrides AnnotationDataExporterIsValidFormat(Stream).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low-level implementation of exporting a multiple pages of annotations to a given stream. (Overrides AnnotationDataExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low-level implementation of exporting a single page of annotations to a given stream. (Overrides AnnotationDataExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low-level implementation of exporting a set of annotations over an existing stream. (Overrides AnnotationDataExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low-level implementation of exporting a set of annotations over an existing stream. (Overrides AnnotationDataExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.Construct Method

PdfAnnotationDataExporterConstruct Method

Constructs a new PdfAnnotationDataExporter.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationDataExporter Construct()
Public Overrides Function Construct As AnnotationDataExporter

Return Value

Type: AnnotationDataExporter
A new instance of PdfAnnotationDataExporter.
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.Export Method

PdfAnnotationDataExporterExport Method

Exports annotations from a given source stream to a given destination stream.
Exports annotations from a given source stream to a given destination stream.
Overload List
 | Name | Description
Public method | Export(PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection) | Saves the Pdf file into destStream with exported annotations layers.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Exports a multiple pages of annotations to a given stream. (Inherited from AnnotationDataExporter.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Exports a single page of annotations to a given stream. (Inherited from AnnotationDataExporter.)
Public method | Export(PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString) | Saves the Pdf file into destStream with exported annotations layers.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32, SecureString, SecureString) | Exports a single page of annotations to a given stream.
Top
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.Export Method (PdfDocument, Stream, AnnotationUnit, Dpi[], AnnotationDataCollection)

PdfAnnotationDataExporterExport Method (PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection)

Saves the Pdf file into destStream with exported annotations layers.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    PdfDocument doc,
    Stream destStream,
    AnnotationUnit unit,
    Dpi[] resolutions,
    AnnotationDataCollection layers
)
Public Sub Export (
    doc As PdfDocument,
    destStream As Stream,
    unit As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

doc
Type: Atalasoft.PdfDocPdfDocument
The source document.
destStream
Type: System.IOStream
Destination stream to save the document into.
unit
Type: Atalasoft.AnnotateAnnotationUnit
A unit to measure annotation.
resolutions
Type: Atalasoft.ImagingDpi
Page resolutions.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
Layers of annotations to save into the file.
See Also

Reference

PdfAnnotationDataExporter Class
Export Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.Export Method (PdfDocument, Stream, AnnotationUnit, Dpi[], AnnotationDataCollection, SecureString, SecureString)

PdfAnnotationDataExporterExport Method (PdfDocument, Stream, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString)

Saves the Pdf file into destStream with exported annotations layers.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    PdfDocument doc,
    Stream destStream,
    AnnotationUnit unit,
    Dpi[] resolutions,
    AnnotationDataCollection layers,
    SecureString userPassword,
    SecureString ownerPassword = null
)
Public Sub Export (
    doc As PdfDocument,
    destStream As Stream,
    unit As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection,
    userPassword As SecureString,
    Optional ownerPassword As SecureString = Nothing
)

Parameters

doc
Type: Atalasoft.PdfDocPdfDocument
The source document.
destStream
Type: System.IOStream
Destination stream to save the document into.
unit
Type: Atalasoft.AnnotateAnnotationUnit
A unit to measure annotation.
resolutions
Type: Atalasoft.ImagingDpi
Page resolutions.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
Layers of annotations to save into the file.
userPassword
Type: System.SecuritySecureString
The user password to use when opening and saving the PDF.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password to use when opening and saving the PDF.
See Also

Reference

PdfAnnotationDataExporter Class
Export Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.Export Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection, SecureString, SecureString)

PdfAnnotationDataExporterExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection, SecureString, SecureString)

Exports a multiple pages of annotations to a given stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    AnnotationDataCollection layers,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Sub Export (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
userPassword
Type: System.SecuritySecureString
The user password to use when opening and saving the PDF.
ownerPassword
Type: System.SecuritySecureString
The owner password to use when opening and saving the PDF.
Exceptions
Exception | Condition
 | Thrown if sourceStream or destStream is null (Nothing in VB).
 | Thrown if both CanExport and CanExportOver properties are false.
Remarks
To create a page with no annotations, add an empty LayerData to the collection.
See Also

Reference

PdfAnnotationDataExporter Class
Export Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.Export Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32, SecureString, SecureString)

PdfAnnotationDataExporterExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32, SecureString, SecureString)

Exports a single page of annotations to a given stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Sub Export (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.AnnotateLayerData
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
userPassword
Type: System.SecuritySecureString
The user password to use when opening and saving the PDF.
ownerPassword
Type: System.SecuritySecureString
The owner password to use when opening and saving the PDF.
Exceptions
Exception | Condition
 | Thrown if sourceStream or destStream is null (Nothing in VB).
 | Thrown if frameIndex is less than zero.
 | Thrown if both CanExport and CanExportOver properties are false.
Remarks
A source stream is necessary for some file formats like PDF which require an entire document to hold the annotations. Other formats may ignore the source stream entirely.
See Also

Reference

PdfAnnotationDataExporter Class
Export Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.IsValidFormat Method

PdfAnnotationDataExporterIsValidFormat Method

Determines if a stream contains PDF content.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stm
)
Public Overrides Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream.

Return Value

Type: Boolean
Returns true if the stream contains PDF, false otherwise.
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.LLExport Method

PdfAnnotationDataExporterLLExport Method

Overload List
 | Name | Description
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low-level implementation of exporting a multiple pages of annotations to a given stream. (Overrides AnnotationDataExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low-level implementation of exporting a single page of annotations to a given stream. (Overrides AnnotationDataExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).)
Top
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.LLExport Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection)

PdfAnnotationDataExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection)

Low-level implementation of exporting a multiple pages of annotations to a given stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    AnnotationDataCollection layers
)
Protected Overrides Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
See Also

Reference

PdfAnnotationDataExporter Class
LLExport Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.LLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

PdfAnnotationDataExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

Low-level implementation of exporting a single page of annotations to a given stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex
)
Protected Overrides Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.AnnotateLayerData
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
See Also

Reference

PdfAnnotationDataExporter Class
LLExport Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.LLExportOver Method

PdfAnnotationDataExporterLLExportOver Method

Overload List
 | Name | Description
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection) | Low-level implementation of exporting a set of annotations over an existing stream. (Overrides AnnotationDataExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32) | Low-level implementation of exporting a set of annotations over an existing stream. (Overrides AnnotationDataExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32).)
Top
See Also

Reference

PdfAnnotationDataExporter Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.LLExportOver Method (Stream, SizeF[], AnnotationUnit, Dpi[], AnnotationDataCollection)

PdfAnnotationDataExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, AnnotationDataCollection)

Low-level implementation of exporting a set of annotations over an existing stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExportOver(
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    AnnotationDataCollection layers
)
Protected Overrides Sub LLExportOver (
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As AnnotationDataCollection
)

Parameters

destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
Exceptions
Exception | Condition
NotImplementedException | This feature is not supported in the base implementation.
See Also

Reference

PdfAnnotationDataExporter Class
LLExportOver Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationDataExporter.LLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

PdfAnnotationDataExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerData, Int32)

Low-level implementation of exporting a set of annotations over an existing stream.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExportOver(
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerData layer,
    int frameIndex
)
Protected Overrides Sub LLExportOver (
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerData,
    frameIndex As Integer
)

Parameters

destStream
Type: System.IOStream
The destrination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.AnnotateLayerData
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
Exceptions
Exception | Condition
NotImplementedException | This feature is not supported in the base implementation.
See Also

Reference

PdfAnnotationDataExporter Class
LLExportOver Overload
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationEmbeddingAction Enumeration

This enumeration is used to select how an unknown annotation type will be exported to pdf.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfAnnotationEmbeddingAction
Public Enumeration PdfAnnotationEmbeddingAction
Members
Member name | Description
None | No action - the annotation will be skipped.
EmbedAlias | The annotation will be exported as a different annotation type entirely.
EmbedFacade | The annotation will be exported with a set of images that represent its appearance in the PDF
See Also

Reference

Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy Class

PdfAnnotationExportPolicy is a class used to help the PdfAnnotationDataExporter select a mechanism for exporting an unknown annotation type.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ExportersPdfAnnotationExportPolicy

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfAnnotationExportPolicy
Public Class PdfAnnotationExportPolicy

The PdfAnnotationExportPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationExportPolicy | Constructs a new PdfAnnotationExportPolicy object.
Top
Properties
 | Name | Description
Public property | AnnotationDataAlias | Sets or gets an AnnotationData object to be used in place of an unknown annotation type.
Public property | AnnotationFacades | Sets or gets a collection of AtalaImage objects to use as facades in PDF.
Public property | EmbeddingAction | Sets or gets the action that will be taken when an unknown annotation will be exported.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

Currently there are three general policies for handling unknown annotation types:

  1. None - the annotation will be skipped.
  2. EmbedAlias - a different annotation type will be substituted for an unknown annotation. The unknown annotation data will be embedded within the alias so it can be recovered. The allows a "close match" annotation to be selected instead.
  3. Facade - a PDF rectangle annotation will be embedded with a visual facade that makes it appear differently. PDF defines up to three appearances for an annotation, Normal, Rollover, and Clicked. There are up to three "facade" images that can be set to represent these appearances.
See Also

Reference

Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy Constructor

Constructs a new PdfAnnotationExportPolicy object.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationExportPolicy()
Public Sub New
See Also

Reference

PdfAnnotationExportPolicy Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy Properties

The PdfAnnotationExportPolicy type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationDataAlias | Sets or gets an AnnotationData object to be used in place of an unknown annotation type.
Public property | AnnotationFacades | Sets or gets a collection of AtalaImage objects to use as facades in PDF.
Public property | EmbeddingAction | Sets or gets the action that will be taken when an unknown annotation will be exported.
Top
See Also

Reference

PdfAnnotationExportPolicy Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy.AnnotationDataAlias Property

PdfAnnotationExportPolicyAnnotationDataAlias Property

Sets or gets an AnnotationData object to be used in place of an unknown annotation type.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData AnnotationDataAlias { get; set; }
Public Property AnnotationDataAlias As AnnotationData
    Get
    Set

Property Value

Type: AnnotationData
See Also

Reference

PdfAnnotationExportPolicy Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy.AnnotationFacades Property

PdfAnnotationExportPolicyAnnotationFacades Property

Sets or gets a collection of AtalaImage objects to use as facades in PDF.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage[] AnnotationFacades { get; }
Public ReadOnly Property AnnotationFacades As AtalaImage()
    Get

Property Value

Type: AtalaImage
Remarks

This property should be set to a set of three AtalaImage objects. Each one must be the same size. Each image may be null. The first image will be used for the "normal" appearance. The second will be used for the rollover appearance. The third will be used for the clicked appearance.

If the first image is null, DotImage will create a facade on the fly by rendering the annotation to an AtalaImage and using that as the normal facade.

Facades with an alpha channel will be split into a color image and an 8 bit mask.

Facades may not be in the following PixelFormats:

  • 16 bit grayscale with alpha -
  • 48 bit color -
  • 64 bit color with alpha -
See Also

Reference

PdfAnnotationExportPolicy Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy.EmbeddingAction Property

PdfAnnotationExportPolicyEmbeddingAction Property

Sets or gets the action that will be taken when an unknown annotation will be exported.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationEmbeddingAction EmbeddingAction { get; set; }
Public Property EmbeddingAction As PdfAnnotationEmbeddingAction
    Get
    Set

Property Value

Type: PdfAnnotationEmbeddingAction
Remarks
The default value is None, which will skip the annotation.
See Also

Reference

PdfAnnotationExportPolicy Class
Atalasoft.Annotate.Exporters Namespace


PdfAnnotationExportPolicy Methods

The PdfAnnotationExportPolicy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationExportPolicy Class
Atalasoft.Annotate.Exporters Namespace


PdfUnknownAnnotationHandler Delegate

Represents a method for selecting a PdfAnnotationExportPolicy to use when an unknown annotation type is encountered.

Namespace: Atalasoft.Annotate.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate PdfAnnotationExportPolicy PdfUnknownAnnotationHandler(
    AnnotationData annotation
)
Public Delegate Function PdfUnknownAnnotationHandler (
    annotation As AnnotationData
) As PdfAnnotationExportPolicy

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
An AnnotationData of an unknown type.

Return Value

Type: PdfAnnotationExportPolicy
The PdfAnnotationExportPolicy that describes how the annotation should be handled.
See Also

Reference

Atalasoft.Annotate.Exporters Namespace
PdfAnnotationDataExporterUnknownAnnotationHandler


Atalasoft.Annotate.Formatters Namespace

Classes
 | Class | Description
Public class | AnnotationDeserializationEventArgs | This class contains information used when deserializing annotations.
Public class | AnnotationDeserializationEventArgsT | This class contains information used when deserializing annotations.
Public class | JoltXmpFormatter | This class is used to serialize and deserialize XMP annotation data from JoltImage. The XmpFormatter will automatically use this class to deserialize when needed.
Public class | LegacyXmpFormatter | This class is used to serialize and deserialize XMP annotation data from DotAnnotate 4.0 and earlier. The XmpFormatter will automatically use this class to deserialize when needed.
Public class | WangAnnotationSerializationEventArgs | This class contains information used for WANG serialization.
Public class | WangFormatter | The WangFormatter converts annotation data to and from WANG format.
Public class | XmpFormatter | This class converts objects into XMP data to be embedded into images or saved as standalone files.
Structures
 | Structure | Description
Public structure | WangFormatterWangImageAnnotationImageAttributes | Attributes of Wang Image Annotations
Interfaces
 | Interface | Description
Public interface | ILegacyXmpSupport | This interface is used by annotation to support reading from and generating XMP annotation data for versions 4 and below of DotAnnotate.
Delegates
 | Delegate | Description
Public delegate | AnnotationDeserializationEventHandler | Used to handle the AnnotationDeserialization event.


AnnotationDeserializationEventArgs Class

This class contains information used when deserializing annotations.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.FormattersAnnotationDeserializationEventArgs

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDeserializationEventArgs : EventArgs
Public Class AnnotationDeserializationEventArgs
    Inherits EventArgs

The AnnotationDeserializationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDeserializationEventArgs | Creates a new instance of AnnotationDeserializationEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether to add this object into the controller.
Public property | Controller | Gets the controller being serialized into.
Public property | Data | Gets or sets the object that will be added into the controller.
Public property | Formatter | Gets the formatter used to deserialize the data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs Constructor

Creates a new instance of AnnotationDeserializationEventArgs.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDeserializationEventArgs(
    AnnotationController controller,
    IFormatter formatter,
    Object data
)
Public Sub New (
    controller As AnnotationController,
    formatter As IFormatter,
    data As Object
)

Parameters

controller
Type: Atalasoft.Annotate.UIAnnotationController
The AnnotationController for the annotation.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
data
Type: SystemObject
The object resulting from deserialization.
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs Properties

The AnnotationDeserializationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether to add this object into the controller.
Public property | Controller | Gets the controller being serialized into.
Public property | Data | Gets or sets the object that will be added into the controller.
Public property | Formatter | Gets the formatter used to deserialize the data.
Top
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs.Cancel Property

AnnotationDeserializationEventArgsCancel Property

Gets or sets a value indicating whether to add this object into the controller.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether to cancel adding this object into the controller.
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs.Controller Property

AnnotationDeserializationEventArgsController Property

Gets the controller being serialized into.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController Controller { get; }
Public ReadOnly Property Controller As AnnotationController
    Get

Property Value

Type: AnnotationController
The controller the object will be added to.
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs.Data Property

AnnotationDeserializationEventArgsData Property

Gets or sets the object that will be added into the controller.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Data { get; set; }
Public Property Data As Object
    Get
    Set

Property Value

Type: Object
The object that will be added into the controller.
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs.Formatter Property

AnnotationDeserializationEventArgsFormatter Property

Gets the formatter used to deserialize the data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFormatter Formatter { get; }
Public ReadOnly Property Formatter As IFormatter
    Get

Property Value

Type: IFormatter
The formatter used to deserialize the data.
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs Methods

The AnnotationDeserializationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDeserializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T) Class

AnnotationDeserializationEventArgsT Class

This class contains information used when deserializing annotations.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.FormattersAnnotationDeserializationEventArgsT

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDeserializationEventArgs<T> : EventArgs

Public Class AnnotationDeserializationEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T

The AnnotationDeserializationEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDeserializationEventArgsT | Initializes a new instance of the AnnotationDeserializationEventArgsT class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether [cancel].
Public property | Controller | Gets the controller.
Public property | Data | Gets or sets the data.
Public property | Formatter | Gets the formatter.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T) Constructor

AnnotationDeserializationEventArgsT Constructor

Initializes a new instance of the AnnotationDeserializationEventArgsT class.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDeserializationEventArgs(
    T controller,
    IFormatter formatter,
    Object data
)
Public Sub New (
    controller As T,
    formatter As IFormatter,
    data As Object
)

Parameters

controller
Type: T
The controller.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter.
data
Type: SystemObject
The data.
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T) Properties

AnnotationDeserializationEventArgsT Properties

The AnnotationDeserializationEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether [cancel].
Public property | Controller | Gets the controller.
Public property | Data | Gets or sets the data.
Public property | Formatter | Gets the formatter.
Top
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T).Cancel Property

AnnotationDeserializationEventArgsTCancel Property

Gets or sets a value indicating whether [cancel].

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [cancel]; otherwise, false.
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T).Controller Property

AnnotationDeserializationEventArgsTController Property

Gets the controller.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Controller { get; }
Public ReadOnly Property Controller As T
    Get

Property Value

Type: T
The controller.
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T).Data Property

AnnotationDeserializationEventArgsTData Property

Gets or sets the data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Data { get; set; }
Public Property Data As Object
    Get
    Set

Property Value

Type: Object
The data.
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T).Formatter Property

AnnotationDeserializationEventArgsTFormatter Property

Gets the formatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFormatter Formatter { get; }
Public ReadOnly Property Formatter As IFormatter
    Get

Property Value

Type: IFormatter
The formatter.
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventArgs(T) Methods

AnnotationDeserializationEventArgsT Methods

The AnnotationDeserializationEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDeserializationEventArgsT Class
Atalasoft.Annotate.Formatters Namespace


AnnotationDeserializationEventHandler Delegate

Used to handle the AnnotationDeserialization event.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationDeserializationEventHandler(
    Object sender,
    AnnotationDeserializationEventArgs e
)
Public Delegate Sub AnnotationDeserializationEventHandler (
    sender As Object,
    e As AnnotationDeserializationEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Annotate.FormattersAnnotationDeserializationEventArgs
An AnnotationDeserializationEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


ILegacyXmpSupport Interface

This interface is used by annotation to support reading from and generating XMP annotation data for versions 4 and below of DotAnnotate.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ILegacyXmpSupport
Public Interface ILegacyXmpSupport

The ILegacyXmpSupport type exposes the following members.

Methods
 | Name | Description
Public method | FromXmp | Set the annotation property settings.
Public method | ToXmp | Generates the XMP data.
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


ILegacyXmpSupport Methods

The ILegacyXmpSupport type exposes the following members.

Methods
 | Name | Description
Public method | FromXmp | Set the annotation property settings.
Public method | ToXmp | Generates the XMP data.
Top
See Also

Reference

ILegacyXmpSupport Interface
Atalasoft.Annotate.Formatters Namespace


ILegacyXmpSupport.FromXmp Method

ILegacyXmpSupportFromXmp Method

Set the annotation property settings.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void FromXmp(
    XmlTextReader reader
)
Sub FromXmp (
    reader As XmlTextReader
)

Parameters

reader
Type: XmlTextReader
The XmlTextReader containing the annotation data.
See Also

Reference

ILegacyXmpSupport Interface
Atalasoft.Annotate.Formatters Namespace


ILegacyXmpSupport.ToXmp Method

ILegacyXmpSupportToXmp Method

Generates the XMP data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void ToXmp(
    XmlTextWriter writer
)
Sub ToXmp (
    writer As XmlTextWriter
)

Parameters

writer
Type: XmlTextWriter
The XmlTextWriter in which to write the data.
See Also

Reference

ILegacyXmpSupport Interface
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter Class

This class is used to serialize and deserialize XMP annotation data from JoltImage. The XmpFormatter will automatically use this class to deserialize when needed.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.FormattersJoltXmpFormatter

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JoltXmpFormatter : IFormatter
Public Class JoltXmpFormatter
    Implements IFormatter

The JoltXmpFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | JoltXmpFormatter | Creates a new instance of JoltXmpFormatter with default options.
Public method | JoltXmpFormatter(Formatting, Int32, Boolean, PointF) | Creates a new instance of JoltXmpFormatter with the specified property values.
Top
Properties
 | Name | Description
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | CreateXmpPacket | Gets or sets a value indicating whether [create XMP packet].
Public property | Formatting | Gets or sets the formatting.
Public property | Indentation | Gets or sets the indentation.
Public property | Resolution | Gets or sets the resolution.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializes the data on the provided stream and reconstitutes the graph of objects.
 | DeserializeBrush | Converts XMP data into an AnnotationBrush.
 | DeserializeFont | Converts XMP data into an AnnotationBrush.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes an object, or graph of objects with the given root to the provided stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter Constructor

Creates a new instance of JoltXmpFormatter.
Overload List
 | Name | Description
Public method | JoltXmpFormatter | Creates a new instance of JoltXmpFormatter with default options.
Public method | JoltXmpFormatter(Formatting, Int32, Boolean, PointF) | Creates a new instance of JoltXmpFormatter with the specified property values.
Top
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter Constructor

Creates a new instance of JoltXmpFormatter with default options.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JoltXmpFormatter()
Public Sub New
See Also

Reference

JoltXmpFormatter Class
JoltXmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter Constructor (Formatting, Int32, Boolean, PointF)

Creates a new instance of JoltXmpFormatter with the specified property values.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JoltXmpFormatter(
    Formatting formatting,
    int indentation,
    bool packet,
    PointF resolution
)
Public Sub New (
    formatting As Formatting,
    indentation As Integer,
    packet As Boolean,
    resolution As PointF
)

Parameters

formatting
Type: System.XmlFormatting
Indicates how the XML will be formatted.
indentation
Type: SystemInt32
The number of spaces for indenting.
packet
Type: SystemBoolean
Indicates whether to generate an XMP packet. This is required when the data is embedded into an image.
resolution
Type: System.DrawingPointF
The resolution of the annotation data.
See Also

Reference

JoltXmpFormatter Class
JoltXmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter Properties

The JoltXmpFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | CreateXmpPacket | Gets or sets a value indicating whether [create XMP packet].
Public property | Formatting | Gets or sets the formatting.
Public property | Indentation | Gets or sets the indentation.
Public property | Resolution | Gets or sets the resolution.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Top
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Binder Property

JoltXmpFormatterBinder Property

Gets or sets the SerializationBinder that performs type lookups during deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SerializationBinder Binder { get; set; }
Public Property Binder As SerializationBinder
    Get
    Set

Return Value

Type: SerializationBinder
The SerializationBinder that performs type lookups during deserialization.

Implements

IFormatterBinder
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Context Property

JoltXmpFormatterContext Property

Gets or sets the StreamingContext used for serialization and deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StreamingContext Context { get; set; }
Public Property Context As StreamingContext
    Get
    Set

Return Value

Type: StreamingContext
The StreamingContext used for serialization and deserialization.

Implements

IFormatterContext
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.CreateXmpPacket Property

JoltXmpFormatterCreateXmpPacket Property

Gets or sets a value indicating whether [create XMP packet].

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CreateXmpPacket { get; set; }
Public Property CreateXmpPacket As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [create XMP packet]; otherwise, false.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Formatting Property

JoltXmpFormatterFormatting Property

Gets or sets the formatting.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Formatting Formatting { get; set; }
Public Property Formatting As Formatting
    Get
    Set

Property Value

Type: Formatting
The formatting.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Indentation Property

JoltXmpFormatterIndentation Property

Gets or sets the indentation.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Indentation { get; set; }
Public Property Indentation As Integer
    Get
    Set

Property Value

Type: Int32
The indentation.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Resolution Property

JoltXmpFormatterResolution Property

Gets or sets the resolution.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; set; }
Public Property Resolution As PointF
    Get
    Set

Property Value

Type: PointF
The resolution.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.SurrogateSelector Property

JoltXmpFormatterSurrogateSelector Property

Gets or sets the SurrogateSelector used by the current formatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ISurrogateSelector SurrogateSelector { get; set; }
Public Property SurrogateSelector As ISurrogateSelector
    Get
    Set

Return Value

Type: ISurrogateSelector
The SurrogateSelector used by this formatter.

Implements

IFormatterSurrogateSelector
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter Methods

The JoltXmpFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes the data on the provided stream and reconstitutes the graph of objects.
 | DeserializeBrush | Converts XMP data into an AnnotationBrush.
 | DeserializeFont | Converts XMP data into an AnnotationBrush.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes an object, or graph of objects with the given root to the provided stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Deserialize Method

JoltXmpFormatterDeserialize Method

Deserializes the data on the provided stream and reconstitutes the graph of objects.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Deserialize(
    Stream serializationStream
)
Public Function Deserialize (
    serializationStream As Stream
) As Object

Parameters

serializationStream
Type: System.IOStream
The stream that contains the data to deserialize.

Return Value

Type: Object
The top object of the deserialized graph.

Implements

IFormatterDeserialize(Stream)
Exceptions
Exception | Condition
ArgumentNullException | serializationStream
ArgumentException | The stream must have read permissions.;serializationStream
SerializationException | There was an error deserializing the stream.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.DeserializeBrush Method

JoltXmpFormatterDeserializeBrush Method

Converts XMP data into an AnnotationBrush.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationBrush DeserializeBrush(
    XmlReader reader
)
Public Shared Function DeserializeBrush (
    reader As XmlReader
) As AnnotationBrush

Parameters

reader
Type: System.XmlXmlReader
An XmlReader containing the serialized data.

Return Value

Type: AnnotationBrush
An AnnotationBrush created from the data.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.DeserializeFont Method

JoltXmpFormatterDeserializeFont Method

Converts XMP data into an AnnotationBrush.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Font DeserializeFont(
    XmlReader reader
)
Public Shared Function DeserializeFont (
    reader As XmlReader
) As Font

Parameters

reader
Type: System.XmlXmlReader
An XmlReader containing the serialized data.

Return Value

Type: Font
An AnnotationBrush created from the data.
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


JoltXmpFormatter.Serialize Method

JoltXmpFormatterSerialize Method

Serializes an object, or graph of objects with the given root to the provided stream.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Serialize(
    Stream serializationStream,
    Object graph
)
Public Sub Serialize (
    serializationStream As Stream,
    graph As Object
)

Parameters

serializationStream
Type: System.IOStream
The stream where the formatter puts the serialized data. This stream can reference a variety of backing stores (such as files, network, memory, and so on).
graph
Type: SystemObject
The object, or root of the object graph, to serialize. All child objects of this root object are automatically serialized.

Implements

IFormatterSerialize(Stream, Object)
See Also

Reference

JoltXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter Class

This class is used to serialize and deserialize XMP annotation data from DotAnnotate 4.0 and earlier. The XmpFormatter will automatically use this class to deserialize when needed.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.FormattersLegacyXmpFormatter

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LegacyXmpFormatter : IFormatter
Public Class LegacyXmpFormatter
    Implements IFormatter

The LegacyXmpFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | LegacyXmpFormatter | Creates a new instance of LegacyXmpFormatter with default options.
Public method | LegacyXmpFormatter(Formatting, Int32, Boolean, PointF) | Creates a new instance of LegacyXmpFormatter with the specified property values.
Top
Properties
 | Name | Description
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | CreateXmpPacket | Gets or sets a value indicating whether [create XMP packet].
Public property | Formatting | Gets or sets the formatting.
Public property | Indentation | Gets or sets the indentation.
Public property | Resolution | Gets or sets the resolution.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializes the data on the provided stream and reconstitutes the graph of objects.
 | DeserializeBrush | Converts XMP data into an AnnotationBrush.
 | DeserializePen | Converts XMP data into an AnnotationPen.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes an object, or graph of objects with the given root to the provided stream.
 | SerializeBrush | Converts an AnnotationBrush into XMP data.
 | SerializePen | Converts an AnnotationPen into XMP data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter Constructor

Creates a new instance of LegacyXmpFormatter.
Overload List
 | Name | Description
Public method | LegacyXmpFormatter | Creates a new instance of LegacyXmpFormatter with default options.
Public method | LegacyXmpFormatter(Formatting, Int32, Boolean, PointF) | Creates a new instance of LegacyXmpFormatter with the specified property values.
Top
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter Constructor

Creates a new instance of LegacyXmpFormatter with default options.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LegacyXmpFormatter()
Public Sub New
See Also

Reference

LegacyXmpFormatter Class
LegacyXmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter Constructor (Formatting, Int32, Boolean, PointF)

Creates a new instance of LegacyXmpFormatter with the specified property values.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LegacyXmpFormatter(
    Formatting formatting,
    int indentation,
    bool packet,
    PointF resolution
)
Public Sub New (
    formatting As Formatting,
    indentation As Integer,
    packet As Boolean,
    resolution As PointF
)

Parameters

formatting
Type: System.XmlFormatting
Indicates how the XML will be formatted.
indentation
Type: SystemInt32
The number of spaces for indenting.
packet
Type: SystemBoolean
Indicates whether to generate an XMP packet. This is required when the data is embedded into an image.
resolution
Type: System.DrawingPointF
The resolution of the annotation data.
See Also

Reference

LegacyXmpFormatter Class
LegacyXmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter Properties

The LegacyXmpFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | CreateXmpPacket | Gets or sets a value indicating whether [create XMP packet].
Public property | Formatting | Gets or sets the formatting.
Public property | Indentation | Gets or sets the indentation.
Public property | Resolution | Gets or sets the resolution.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Top
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Binder Property

LegacyXmpFormatterBinder Property

Gets or sets the SerializationBinder that performs type lookups during deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SerializationBinder Binder { get; set; }
Public Property Binder As SerializationBinder
    Get
    Set

Return Value

Type: SerializationBinder
The SerializationBinder that performs type lookups during deserialization.

Implements

IFormatterBinder
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Context Property

LegacyXmpFormatterContext Property

Gets or sets the StreamingContext used for serialization and deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StreamingContext Context { get; set; }
Public Property Context As StreamingContext
    Get
    Set

Return Value

Type: StreamingContext
The StreamingContext used for serialization and deserialization.

Implements

IFormatterContext
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.CreateXmpPacket Property

LegacyXmpFormatterCreateXmpPacket Property

Gets or sets a value indicating whether [create XMP packet].

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CreateXmpPacket { get; set; }
Public Property CreateXmpPacket As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [create XMP packet]; otherwise, false.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Formatting Property

LegacyXmpFormatterFormatting Property

Gets or sets the formatting.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Formatting Formatting { get; set; }
Public Property Formatting As Formatting
    Get
    Set

Property Value

Type: Formatting
The formatting.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Indentation Property

LegacyXmpFormatterIndentation Property

Gets or sets the indentation.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Indentation { get; set; }
Public Property Indentation As Integer
    Get
    Set

Property Value

Type: Int32
The indentation.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Resolution Property

LegacyXmpFormatterResolution Property

Gets or sets the resolution.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; set; }
Public Property Resolution As PointF
    Get
    Set

Property Value

Type: PointF
The resolution.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.SurrogateSelector Property

LegacyXmpFormatterSurrogateSelector Property

Gets or sets the SurrogateSelector used by the current formatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ISurrogateSelector SurrogateSelector { get; set; }
Public Property SurrogateSelector As ISurrogateSelector
    Get
    Set

Return Value

Type: ISurrogateSelector
The SurrogateSelector used by this formatter.

Implements

IFormatterSurrogateSelector
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter Methods

The LegacyXmpFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes the data on the provided stream and reconstitutes the graph of objects.
 | DeserializeBrush | Converts XMP data into an AnnotationBrush.
 | DeserializePen | Converts XMP data into an AnnotationPen.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes an object, or graph of objects with the given root to the provided stream.
 | SerializeBrush | Converts an AnnotationBrush into XMP data.
 | SerializePen | Converts an AnnotationPen into XMP data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Deserialize Method

LegacyXmpFormatterDeserialize Method

Deserializes the data on the provided stream and reconstitutes the graph of objects.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Deserialize(
    Stream serializationStream
)
Public Function Deserialize (
    serializationStream As Stream
) As Object

Parameters

serializationStream
Type: System.IOStream
The stream that contains the data to deserialize.

Return Value

Type: Object
The top object of the deserialized graph.

Implements

IFormatterDeserialize(Stream)
Exceptions
Exception | Condition
ArgumentNullException | serializationStream
ArgumentException | The stream must have read permissions.;serializationStream
SerializationException | There was an error deserializing the stream.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.DeserializeBrush Method

LegacyXmpFormatterDeserializeBrush Method

Converts XMP data into an AnnotationBrush.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationBrush DeserializeBrush(
    XmlReader reader
)
Public Shared Function DeserializeBrush (
    reader As XmlReader
) As AnnotationBrush

Parameters

reader
Type: System.XmlXmlReader
An XmlReader containing the serialized data.

Return Value

Type: AnnotationBrush
An AnnotationBrush created from the data.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.DeserializePen Method

LegacyXmpFormatterDeserializePen Method

Converts XMP data into an AnnotationPen.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationPen DeserializePen(
    XmlReader reader
)
Public Shared Function DeserializePen (
    reader As XmlReader
) As AnnotationPen

Parameters

reader
Type: System.XmlXmlReader
The XmlReader containing the pen data.

Return Value

Type: AnnotationPen
An AnnotationPen created from the data.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.Serialize Method

LegacyXmpFormatterSerialize Method

Serializes an object, or graph of objects with the given root to the provided stream.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Serialize(
    Stream serializationStream,
    Object graph
)
Public Sub Serialize (
    serializationStream As Stream,
    graph As Object
)

Parameters

serializationStream
Type: System.IOStream
The stream where the formatter puts the serialized data. This stream can reference a variety of backing stores (such as files, network, memory, and so on).
graph
Type: SystemObject
The object, or root of the object graph, to serialize. All child objects of this root object are automatically serialized.

Implements

IFormatterSerialize(Stream, Object)
Exceptions
Exception | Condition
ArgumentNullException | serializationStream or graph
ArgumentException | The stream must have write access.;serializationStream
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.SerializeBrush Method

LegacyXmpFormatterSerializeBrush Method

Converts an AnnotationBrush into XMP data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SerializeBrush(
    XmlTextWriter writer,
    AnnotationBrush brush,
    string tagName
)
Public Shared Sub SerializeBrush (
    writer As XmlTextWriter,
    brush As AnnotationBrush,
    tagName As String
)

Parameters

writer
Type: XmlTextWriter
The XmlTextWriter to write the serialized data into.
brush
Type: Atalasoft.AnnotateAnnotationBrush
The brush to convert.
tagName
Type: SystemString
The name of the tag to give the brush data.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


LegacyXmpFormatter.SerializePen Method

LegacyXmpFormatterSerializePen Method

Converts an AnnotationPen into XMP data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SerializePen(
    XmlTextWriter writer,
    AnnotationPen pen
)
Public Shared Sub SerializePen (
    writer As XmlTextWriter,
    pen As AnnotationPen
)

Parameters

writer
Type: XmlTextWriter
The XmlTextWriter to write the data into.
pen
Type: Atalasoft.AnnotateAnnotationPen
The pen to convert.
See Also

Reference

LegacyXmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs Class

This class contains information used for WANG serialization.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.FormattersWangAnnotationSerializationEventArgs

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WangAnnotationSerializationEventArgs : EventArgs
Public Class WangAnnotationSerializationEventArgs
    Inherits EventArgs

The WangAnnotationSerializationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WangAnnotationSerializationEventArgs | Creates a new instance of WangAnnotationSerializationEventArgs.
Top
Properties
 | Name | Description
Public property | Annotation | Obsolete. Gets or sets the annotation related to the serialization process.
Public property | AnnotationData | Gets or sets the AnnotationData related to the serialization process.
Public property | Data | Gets the WangAttributeData for the annotation during deserialization.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs Constructor

Creates a new instance of WangAnnotationSerializationEventArgs.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAnnotationSerializationEventArgs(
    WangAttributeData data
)
Public Sub New (
    data As WangAttributeData
)

Parameters

data
Type: Atalasoft.AnnotateWangAttributeData
The WangAttributeData being deserialized.
See Also

Reference

WangAnnotationSerializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs Properties

The WangAnnotationSerializationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Annotation | Obsolete. Gets or sets the annotation related to the serialization process.
Public property | AnnotationData | Gets or sets the AnnotationData related to the serialization process.
Public property | Data | Gets the WangAttributeData for the annotation during deserialization.
Top
See Also

Reference

WangAnnotationSerializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs.Annotation Property

WangAnnotationSerializationEventArgsAnnotation Property

Note: This API is now obsolete.

Gets or sets the annotation related to the serialization process.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property will be removed in a future release. Set the AnnotationData property instead.",
    false)]
public AnnotationUI Annotation { get; set; }
<ObsoleteAttribute("This property will be removed in a future release. Set the AnnotationData property instead.",
    false)>
Public Property Annotation As AnnotationUI
    Get
    Set

Property Value

Type: AnnotationUI
The annotation related to the serialization process.
See Also

Reference

WangAnnotationSerializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs.AnnotationData Property

WangAnnotationSerializationEventArgsAnnotationData Property

Gets or sets the AnnotationData related to the serialization process.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData AnnotationData { get; set; }
Public Property AnnotationData As AnnotationData
    Get
    Set

Property Value

Type: AnnotationData
See Also

Reference

WangAnnotationSerializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs.Data Property

WangAnnotationSerializationEventArgsData Property

Gets the WangAttributeData for the annotation during deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangAttributeData Data { get; }
Public ReadOnly Property Data As WangAttributeData
    Get

Property Value

Type: WangAttributeData
The WangAttributeData for the annotation during deserialization.
See Also

Reference

WangAnnotationSerializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


WangAnnotationSerializationEventArgs Methods

The WangAnnotationSerializationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WangAnnotationSerializationEventArgs Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter Class

The WangFormatter converts annotation data to and from WANG format.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.FormattersWangFormatter

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WangFormatter : IFormatter
Public Class WangFormatter
    Implements IFormatter

The WangFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | WangFormatter | Creates a new instance of WangFormatter.
Public method | WangFormatter(PointF) | Creates a new instance of WangFormatter specifying the viewer resolution.
Top
Properties
 | Name | Description
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | Resolution | Gets or sets the document resolution used by the AnnotateViewer.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Public property | UseWangBoldLevels | Gets or sets a value indicating how the lfWeight property will be interpreted for a TextAnnotation. Default value is false, to preserve backwards compatibility, an lfWeight of 400 or greater will indicate bold text. Setting this to true will be consistent with the WANG specification, an lfWeight of 700 or greater will indicate bold text.
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializes WANG data into a LayerData object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserialize | Called when an annotation is being deserialized.
Public method | Serialize | Serializes annotations into WANG format.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteUnsupportedAnnotation | Called when an AnnotationData object being serialized does not implement the IWangCompatible interface.
Protected method | WriteUnsupportedObject | Called when an unsupported object needs to be serialized.
Protected method | WriteWangAnnotation | Called to write a WANG compatible annotation to the serialization stream.
Top
Events
 | Name | Description
Public event | DeserializeAnnotation | Raised when an annotation is being deserialized.
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


WangFormatter Constructor

Constructs a WangFormatter.
Overload List
 | Name | Description
Public method | WangFormatter | Creates a new instance of WangFormatter.
Public method | WangFormatter(PointF) | Creates a new instance of WangFormatter specifying the viewer resolution.
Top
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter Constructor

Creates a new instance of WangFormatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangFormatter()
Public Sub New
See Also

Reference

WangFormatter Class
WangFormatter Overload
Atalasoft.Annotate.Formatters Namespace


WangFormatter Constructor (PointF)

Creates a new instance of WangFormatter specifying the viewer resolution.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WangFormatter(
    PointF resolution
)
Public Sub New (
    resolution As PointF
)

Parameters

resolution
Type: System.DrawingPointF
The resolution of the viewer.
See Also

Reference

WangFormatter Class
WangFormatter Overload
Atalasoft.Annotate.Formatters Namespace


WangFormatter Properties

The WangFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | Resolution | Gets or sets the document resolution used by the AnnotateViewer.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Public property | UseWangBoldLevels | Gets or sets a value indicating how the lfWeight property will be interpreted for a TextAnnotation. Default value is false, to preserve backwards compatibility, an lfWeight of 400 or greater will indicate bold text. Setting this to true will be consistent with the WANG specification, an lfWeight of 700 or greater will indicate bold text.
Top
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.Binder Property

WangFormatterBinder Property

Gets or sets the SerializationBinder that performs type lookups during deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SerializationBinder Binder { get; set; }
Public Property Binder As SerializationBinder
    Get
    Set

Property Value

Type: SerializationBinder
The SerializationBinder that performs type lookups during deserialization.

Implements

IFormatterBinder
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.Context Property

WangFormatterContext Property

Gets or sets the StreamingContext used for serialization and deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StreamingContext Context { get; set; }
Public Property Context As StreamingContext
    Get
    Set

Property Value

Type: StreamingContext
The StreamingContext used for serialization and deserialization.

Implements

IFormatterContext
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.Resolution Property

WangFormatterResolution Property

Gets or sets the document resolution used by the AnnotateViewer.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; set; }
Public Property Resolution As PointF
    Get
    Set

Property Value

Type: PointF
The document resolution of the viewer.
Remarks
If the Units property of the viewer is not set to Pixels, this property must be set to allow the annotation positioning to be converted to and from pixels.
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.SurrogateSelector Property

WangFormatterSurrogateSelector Property

Gets or sets the SurrogateSelector used by the current formatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ISurrogateSelector SurrogateSelector { get; set; }
Public Property SurrogateSelector As ISurrogateSelector
    Get
    Set

Property Value

Type: ISurrogateSelector
The SurrogateSelector used by this formatter.

Implements

IFormatterSurrogateSelector
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.UseWangBoldLevels Property

WangFormatterUseWangBoldLevels Property

Gets or sets a value indicating how the lfWeight property will be interpreted for a TextAnnotation. Default value is false, to preserve backwards compatibility, an lfWeight of 400 or greater will indicate bold text. Setting this to true will be consistent with the WANG specification, an lfWeight of 700 or greater will indicate bold text.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseWangBoldLevels { get; set; }
Public Property UseWangBoldLevels As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter Methods

The WangFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes WANG data into a LayerData object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserialize | Called when an annotation is being deserialized.
Public method | Serialize | Serializes annotations into WANG format.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteUnsupportedAnnotation | Called when an AnnotationData object being serialized does not implement the IWangCompatible interface.
Protected method | WriteUnsupportedObject | Called when an unsupported object needs to be serialized.
Protected method | WriteWangAnnotation | Called to write a WANG compatible annotation to the serialization stream.
Top
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.Deserialize Method

WangFormatterDeserialize Method

Deserializes WANG data into a LayerData object.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Deserialize(
    Stream serializationStream
)
Public Function Deserialize (
    serializationStream As Stream
) As Object

Parameters

serializationStream
Type: System.IOStream
A stream containing WANG annotation data.

Return Value

Type: Object
A LayerData object containing the annotations.

Implements

IFormatterDeserialize(Stream)
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.OnDeserialize Method

WangFormatterOnDeserialize Method

Called when an annotation is being deserialized.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDeserialize(
    WangAnnotationSerializationEventArgs e
)
Protected Overridable Sub OnDeserialize (
    e As WangAnnotationSerializationEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.FormattersWangAnnotationSerializationEventArgs
A WangAnnotationSerializationEventArgs containing the WangAttributeData being deserialized.
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.Serialize Method

WangFormatterSerialize Method

Serializes annotations into WANG format.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Serialize(
    Stream serializationStream,
    Object graph
)
Public Sub Serialize (
    serializationStream As Stream,
    graph As Object
)

Parameters

serializationStream
Type: System.IOStream
The stream where serialized data will be stored.
graph
Type: SystemObject
The object to serialize.

Implements

IFormatterSerialize(Stream, Object)
Remarks

The WANG format supports only basic annotation data. The following DotImage annotations are WANG compatible:

Data | Annotation
EmbeddedImageData | EmbeddedImageAnnotation
FreehandData | FreehandAnnotation
LineData | LineAnnotation
RectangleData | RectangleAnnotation
ReferencedImageData | ReferencedImageAnnotation
TextData | TextAnnotation

See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WriteUnsupportedAnnotation Method

WangFormatterWriteUnsupportedAnnotation Method

Called when an AnnotationData object being serialized does not implement the IWangCompatible interface.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void WriteUnsupportedAnnotation(
    Stream stream,
    AnnotationData annotation,
    string group,
    int index
)
Protected Overridable Sub WriteUnsupportedAnnotation (
    stream As Stream,
    annotation As AnnotationData,
    group As String,
    index As Integer
)

Parameters

stream
Type: System.IOStream
The stream where annotation data will be stored.
annotation
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object to serialize.
group
Type: SystemString
The group name for this annotation. This is saved as the OiGroup marker.
index
Type: SystemInt32
The index for this annotation. This is saved as the OiIndex marker.
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WriteUnsupportedObject Method

WangFormatterWriteUnsupportedObject Method

Called when an unsupported object needs to be serialized.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void WriteUnsupportedObject(
    Stream stream,
    Object graph
)
Protected Overridable Sub WriteUnsupportedObject (
    stream As Stream,
    graph As Object
)

Parameters

stream
Type: System.IOStream
The stream where annotation data will be stored.
graph
Type: SystemObject
The object to serialize.
Remarks

The WangFormatter will only attempt to serialize the following objects:

  • LayerCollection
  • LayerAnnotation
  • LayerData
  • AnnotationDataCollection
  • AnnotationUI
  • AnnotationData
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WriteWangAnnotation Method

WangFormatterWriteWangAnnotation Method

Called to write a WANG compatible annotation to the serialization stream.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void WriteWangAnnotation(
    Stream stream,
    IWangCompatible wang,
    string group,
    int index
)
Protected Overridable Sub WriteWangAnnotation (
    stream As Stream,
    wang As IWangCompatible,
    group As String,
    index As Integer
)

Parameters

stream
Type: System.IOStream
The stream where this data will be stored.
wang
Type: Atalasoft.AnnotateIWangCompatible
An IWangCompatible object to serialize.
group
Type: SystemString
The name of the group for this annotation. This is saved as the OiGroup marker.
index
Type: SystemInt32
The index for this annotation. This is saved as the OiIndex marker.
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter Events

The WangFormatter type exposes the following members.

Events
 | Name | Description
Public event | DeserializeAnnotation | Raised when an annotation is being deserialized.
Top
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.DeserializeAnnotation Event

WangFormatterDeserializeAnnotation Event

Raised when an annotation is being deserialized.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<WangAnnotationSerializationEventArgs> DeserializeAnnotation
Public Event DeserializeAnnotation As EventHandler(Of WangAnnotationSerializationEventArgs)

Value

Type: SystemEventHandler WangAnnotationSerializationEventArgs
Remarks
The WangAnnotationSerializationEventArgs contains the WangAttributeData for the annotation being deserialized.
See Also

Reference

WangFormatter Class
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes Structure

WangFormatterWangImageAnnotationImageAttributes Structure

Attributes of Wang Image Annotations

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public struct WangImageAnnotationImageAttributes
Public Structure WangImageAnnotationImageAttributes

The WangFormatterWangImageAnnotationImageAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | bReserved1 | Reserved
Public field | bReserved2 | Reserved
Public field | nHRes | The horizontal resolution
Public field | nOrigHRes | The original horizontal resolution
Public field | nOrigVRes | The original vertical resolution
Public field | nReserved | Reserved
Public field | nVRes | The vertical resolution
Public field | rotation | The rotation
Public field | scale | The scale
Top
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


WangImageAnnotationImageAttributes Methods

The WangFormatterWangImageAnnotationImageAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangImageAnnotationImageAttributes Fields

The WangFormatterWangImageAnnotationImageAttributes type exposes the following members.

Fields
 | Name | Description
Public field | bReserved1 | Reserved
Public field | bReserved2 | Reserved
Public field | nHRes | The horizontal resolution
Public field | nOrigHRes | The original horizontal resolution
Public field | nOrigVRes | The original vertical resolution
Public field | nReserved | Reserved
Public field | nVRes | The vertical resolution
Public field | rotation | The rotation
Public field | scale | The scale
Top
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.bReserved1 Field

WangFormatterWangImageAnnotationImageAttributesbReserved1 Field

Reserved

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool bReserved1
Public bReserved1 As Boolean

Field Value

Type: Boolean
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.bReserved2 Field

WangFormatterWangImageAnnotationImageAttributesbReserved2 Field

Reserved

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool bReserved2
Public bReserved2 As Boolean

Field Value

Type: Boolean
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.nHRes Field

WangFormatterWangImageAnnotationImageAttributesnHRes Field

The horizontal resolution

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int nHRes
Public nHRes As Integer

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.nOrigHRes Field

WangFormatterWangImageAnnotationImageAttributesnOrigHRes Field

The original horizontal resolution

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int nOrigHRes
Public nOrigHRes As Integer

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.nOrigVRes Field

WangFormatterWangImageAnnotationImageAttributesnOrigVRes Field

The original vertical resolution

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int nOrigVRes
Public nOrigVRes As Integer

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.nReserved Field

WangFormatterWangImageAnnotationImageAttributesnReserved Field

Reserved

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] nReserved
Public nReserved As Integer()

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.nVRes Field

WangFormatterWangImageAnnotationImageAttributesnVRes Field

The vertical resolution

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int nVRes
Public nVRes As Integer

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.rotation Field

WangFormatterWangImageAnnotationImageAttributesrotation Field

The rotation

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int rotation
Public rotation As Integer

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


WangFormatter.WangImageAnnotationImageAttributes.scale Field

WangFormatterWangImageAnnotationImageAttributesscale Field

The scale

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int scale
Public scale As Integer

Field Value

Type: Int32
See Also

Reference

WangFormatterWangImageAnnotationImageAttributes Structure
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Class

This class converts objects into XMP data to be embedded into images or saved as standalone files.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.FormattersXmpFormatter

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class XmpFormatter : IFormatter
Public Class XmpFormatter
    Implements IFormatter

The XmpFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | XmpFormatter | Creates a new instance of XmpFormatter.
Public method | XmpFormatter(Formatting, Int32, Boolean, Boolean) | Creates a new instance of XmpFormatter specifying formatting, indentation, whether or not data should be formatted as an XMP packet and whether to SkipUnknownObjects.
Public method | XmpFormatter(Formatting, Int32, Boolean, Boolean, PointF) | Creates a new instance of XmpFormatter specifying formatting, indentation, whether or not data should be formatted as an XMP packet, whether to SkipUnknownObjects, and a resolution.
Public method | XmpFormatter(Formatting, Int32, Encoding, Boolean, Boolean, PointF) | Creates a new instance of XmpFormatter specifying formatting, indentation, encoding, whether or not data should be formatted as an XMP packet, whether to SkipUnknownObjects, and a resolution.
Top
Properties
 | Name | Description
Public property | AnnotationDataVersion | Gets the annotation version
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | CreateXmpPacket | Gets or sets a value indicating whether full XMP is generated or an XMP packet.
Public property | Encoding | Gets or sets the System.Text.Encoding to use when serializing the annotation data.
Public property | Formatting | Gets or sets the type of XML formatting used when serializing data.
Public property | Indentation | Gets or sets the number of spaces to indent the data when serializing.
Public property | Resolution | Gets or sets the resolution of the annotation data.
Public property | SkipUnknownObjects | Gets or sets a value indicating whether objects that cannot be created are skipped instead of throwing an exception.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializes XMP data back into the original objects.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes an object into XMP data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Only objects that implement the ISerializable interface can be converted by this formatter.
See Also

Reference

Atalasoft.Annotate.Formatters Namespace


XmpFormatter Constructor

Constructs an XmpFormatter.
Overload List
 | Name | Description
Public method | XmpFormatter | Creates a new instance of XmpFormatter.
Public method | XmpFormatter(Formatting, Int32, Boolean, Boolean) | Creates a new instance of XmpFormatter specifying formatting, indentation, whether or not data should be formatted as an XMP packet and whether to SkipUnknownObjects.
Public method | XmpFormatter(Formatting, Int32, Boolean, Boolean, PointF) | Creates a new instance of XmpFormatter specifying formatting, indentation, whether or not data should be formatted as an XMP packet, whether to SkipUnknownObjects, and a resolution.
Public method | XmpFormatter(Formatting, Int32, Encoding, Boolean, Boolean, PointF) | Creates a new instance of XmpFormatter specifying formatting, indentation, encoding, whether or not data should be formatted as an XMP packet, whether to SkipUnknownObjects, and a resolution.
Top
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Constructor

Creates a new instance of XmpFormatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpFormatter()
Public Sub New
See Also

Reference

XmpFormatter Class
XmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Constructor (Formatting, Int32, Boolean, Boolean)

Creates a new instance of XmpFormatter specifying formatting, indentation, whether or not data should be formatted as an XMP packet and whether to SkipUnknownObjects.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpFormatter(
    Formatting formatting,
    int indentation,
    bool packet,
    bool skipUnknownObjects
)
Public Sub New (
    formatting As Formatting,
    indentation As Integer,
    packet As Boolean,
    skipUnknownObjects As Boolean
)

Parameters

formatting
Type: System.XmlFormatting
Specifies formatting options for the XmlTextWriter.
indentation
Type: SystemInt32
The number of characters to use for indentation.
packet
Type: SystemBoolean
Indicates if the data should be formatted as an XMP packet.
skipUnknownObjects
Type: SystemBoolean
Indicates if the formatter should ignore unknown objects or raise an exception.
See Also

Reference

XmpFormatter Class
XmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Constructor (Formatting, Int32, Boolean, Boolean, PointF)

Creates a new instance of XmpFormatter specifying formatting, indentation, whether or not data should be formatted as an XMP packet, whether to SkipUnknownObjects, and a resolution.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpFormatter(
    Formatting formatting,
    int indentation,
    bool packet,
    bool skipUnknownObjects,
    PointF resolution
)
Public Sub New (
    formatting As Formatting,
    indentation As Integer,
    packet As Boolean,
    skipUnknownObjects As Boolean,
    resolution As PointF
)

Parameters

formatting
Type: System.XmlFormatting
Specifies formatting options for the XmlTextWriter.
indentation
Type: SystemInt32
The number of characters to use for indentation.
packet
Type: SystemBoolean
Indicates if the data should be formatted as an XMP packet.
skipUnknownObjects
Type: SystemBoolean
Indicates if the formatter should ignore unknown objects or raise an exception.
resolution
Type: System.DrawingPointF
The resolution of the annotations.
See Also

Reference

XmpFormatter Class
XmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Constructor (Formatting, Int32, Encoding, Boolean, Boolean, PointF)

Creates a new instance of XmpFormatter specifying formatting, indentation, encoding, whether or not data should be formatted as an XMP packet, whether to SkipUnknownObjects, and a resolution.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpFormatter(
    Formatting formatting,
    int indentation,
    Encoding encoding,
    bool packet,
    bool skipUnknownObjects,
    PointF resolution
)
Public Sub New (
    formatting As Formatting,
    indentation As Integer,
    encoding As Encoding,
    packet As Boolean,
    skipUnknownObjects As Boolean,
    resolution As PointF
)

Parameters

formatting
Type: System.XmlFormatting
Specifies formatting options for the XmlTextWriter.
indentation
Type: SystemInt32
The number of characters to use for indentation.
encoding
Type: System.TextEncoding

The System.Text.Encoding to use when serializing the annotations.

packet
Type: SystemBoolean
Indicates if the data should be formatted as an XMP packet.
skipUnknownObjects
Type: SystemBoolean
Indicates if the formatter should ignore unknown objects or raise an exception.
resolution
Type: System.DrawingPointF
The resolution of the annotations.
See Also

Reference

XmpFormatter Class
XmpFormatter Overload
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Properties

The XmpFormatter type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationDataVersion | Gets the annotation version
Public property | Binder | Gets or sets the SerializationBinder that performs type lookups during deserialization.
Public property | Context | Gets or sets the StreamingContext used for serialization and deserialization.
Public property | CreateXmpPacket | Gets or sets a value indicating whether full XMP is generated or an XMP packet.
Public property | Encoding | Gets or sets the System.Text.Encoding to use when serializing the annotation data.
Public property | Formatting | Gets or sets the type of XML formatting used when serializing data.
Public property | Indentation | Gets or sets the number of spaces to indent the data when serializing.
Public property | Resolution | Gets or sets the resolution of the annotation data.
Public property | SkipUnknownObjects | Gets or sets a value indicating whether objects that cannot be created are skipped instead of throwing an exception.
Public property | SurrogateSelector | Gets or sets the SurrogateSelector used by the current formatter.
Top
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.AnnotationDataVersion Property

XmpFormatterAnnotationDataVersion Property

Gets the annotation version

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float AnnotationDataVersion { get; }
Public ReadOnly Property AnnotationDataVersion As Single
    Get

Property Value

Type: Single
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Binder Property

XmpFormatterBinder Property

Gets or sets the SerializationBinder that performs type lookups during deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SerializationBinder Binder { get; set; }
Public Property Binder As SerializationBinder
    Get
    Set

Property Value

Type: SerializationBinder
The SerializationBinder that performs type lookups during deserialization.

Implements

IFormatterBinder
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Context Property

XmpFormatterContext Property

Gets or sets the StreamingContext used for serialization and deserialization.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StreamingContext Context { get; set; }
Public Property Context As StreamingContext
    Get
    Set

Property Value

Type: StreamingContext
The StreamingContext used for serialization and deserialization.

Implements

IFormatterContext
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.CreateXmpPacket Property

XmpFormatterCreateXmpPacket Property

Gets or sets a value indicating whether full XMP is generated or an XMP packet.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CreateXmpPacket { get; set; }
Public Property CreateXmpPacket As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the serialized data is formatter as an XMP packet.
Remarks
The data must be formatted as an XMP packet when embedded into images.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Encoding Property

XmpFormatterEncoding Property

Gets or sets the System.Text.Encoding to use when serializing the annotation data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set

Property Value

Type: Encoding
The text encoding used to serialize the annotation data.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Formatting Property

XmpFormatterFormatting Property

Gets or sets the type of XML formatting used when serializing data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Formatting Formatting { get; set; }
Public Property Formatting As Formatting
    Get
    Set

Property Value

Type: Formatting
Type type of XML formatting to use.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Indentation Property

XmpFormatterIndentation Property

Gets or sets the number of spaces to indent the data when serializing.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Indentation { get; set; }
Public Property Indentation As Integer
    Get
    Set

Property Value

Type: Int32
The amount of indention.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace
Formatting Property


XmpFormatter.Resolution Property

XmpFormatterResolution Property

Gets or sets the resolution of the annotation data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; set; }
Public Property Resolution As PointF
    Get
    Set

Property Value

Type: PointF
The resolution of the annotation data.
Remarks
This value is saved as a DocumentResolution tag in the XMP data, allowing deserialization to customize the annotation's Location and Size properties to match the viewer resolution. See the AnnotationDeserialization event for more information.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.SkipUnknownObjects Property

XmpFormatterSkipUnknownObjects Property

Gets or sets a value indicating whether objects that cannot be created are skipped instead of throwing an exception.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SkipUnknownObjects { get; set; }
Public Property SkipUnknownObjects As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if unknown objects are skipped when deserialized.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.SurrogateSelector Property

XmpFormatterSurrogateSelector Property

Gets or sets the SurrogateSelector used by the current formatter.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ISurrogateSelector SurrogateSelector { get; set; }
Public Property SurrogateSelector As ISurrogateSelector
    Get
    Set

Property Value

Type: ISurrogateSelector
The SurrogateSelector used by this formatter.

Implements

IFormatterSurrogateSelector
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter Methods

The XmpFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes XMP data back into the original objects.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes an object into XMP data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Deserialize Method

XmpFormatterDeserialize Method

Deserializes XMP data back into the original objects.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Deserialize(
    Stream serializationStream
)
Public Function Deserialize (
    serializationStream As Stream
) As Object

Parameters

serializationStream
Type: System.IOStream
A stream containing XMP formatted data.

Return Value

Type: Object
The deserialized object.

Implements

IFormatterDeserialize(Stream)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the serializationStream parameter is null.
SerializationException | Thrown if there are any errors during the deserialization process.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


XmpFormatter.Serialize Method

XmpFormatterSerialize Method

Serializes an object into XMP data.

Namespace: Atalasoft.Annotate.Formatters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Serialize(
    Stream serializationStream,
    Object graph
)
Public Sub Serialize (
    serializationStream As Stream,
    graph As Object
)

Parameters

serializationStream
Type: System.IOStream
The stream where the XMP data will be stored.
graph
Type: SystemObject
The object to serialize.

Implements

IFormatterSerialize(Stream, Object)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the serializationStream or graph parameter is null.
SerializationException | Thrown if there is an error during the serialization process.
See Also

Reference

XmpFormatter Class
Atalasoft.Annotate.Formatters Namespace


Atalasoft.Annotate.Icons Namespace

Classes
 | Class | Description
Public class | IconResource | This class can be used to extract annotation icon images from the DotImage assembly.
Enumerations
 | Enumeration | Description
Public enumeration | AnnotateIcon | Specifies which image to extract with the ExtractAnnotationIcon(AnnotateIcon, AnnotateIconSize) method.
Public enumeration | AnnotateIconSize | Specifies the image size to extract with ExtractAnnotationIcon(AnnotateIcon, AnnotateIconSize).


AnnotateIcon Enumeration

Specifies which image to extract with the ExtractAnnotationIcon(AnnotateIcon, AnnotateIconSize) method.

Namespace: Atalasoft.Annotate.Icons
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotateIcon
Public Enumeration AnnotateIcon
Members
Member name | Description
Ellipse | Ellipse icon
Freehand | Freehand icon
FreehandHighlighter | FreehandHighlighter icon
Line | Line icon
Lines | Lines icon
Polygon | Polygon icon
Protractor | Protractor icon
Rectangle | Rectangle icon
RectangleHighlighter | RectangleHighlighter icon
Redact | Redact icon
RubberStamp | RubberStamp icon
Ruler | Ruler icon
StickyNote | StickyNote icon
Text | Text icon
FreehandHotspot | FreehandHotspot icon
Callout | Callout icon
RectangleHotspot | RectangleHotspot icon
EmbeddedImage | EmbeddedImage icon
ReferencedImage | ReferencedImage icon
PdfLine | PdfLine icon
PdfMarkup | PdfMarkup icon
See Also

Reference

Atalasoft.Annotate.Icons Namespace


AnnotateIconSize Enumeration

Specifies the image size to extract with ExtractAnnotationIcon(AnnotateIcon, AnnotateIconSize).

Namespace: Atalasoft.Annotate.Icons
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotateIconSize
Public Enumeration AnnotateIconSize
Members
Member name | Description
Size16 | A 16 x 16 pixel image.
Size24 | A 24 x 24 pixel image.
Size32 | A 32 x 32 pixel image.
See Also

Reference

Atalasoft.Annotate.Icons Namespace


IconResource Class

This class can be used to extract annotation icon images from the DotImage assembly.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.IconsIconResource

Namespace: Atalasoft.Annotate.Icons
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class IconResource
Public NotInheritable Class IconResource

The IconResource type exposes the following members.

Constructors
 | Name | Description
Public method | IconResource | Initializes a new instance of the IconResource class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExtractAnnotationIcon | Extracts an image from the DotImage assembly.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Icons Namespace


IconResource Constructor

Initializes a new instance of the IconResource class

Namespace: Atalasoft.Annotate.Icons
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IconResource()
Public Sub New
See Also

Reference

IconResource Class
Atalasoft.Annotate.Icons Namespace


IconResource Methods

The IconResource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExtractAnnotationIcon | Extracts an image from the DotImage assembly.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IconResource Class
Atalasoft.Annotate.Icons Namespace


IconResource.ExtractAnnotationIcon Method

IconResourceExtractAnnotationIcon Method

Extracts an image from the DotImage assembly.

Namespace: Atalasoft.Annotate.Icons
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Image ExtractAnnotationIcon(
    AnnotateIcon icon,
    AnnotateIconSize size
)
Public Shared Function ExtractAnnotationIcon (
    icon As AnnotateIcon,
    size As AnnotateIconSize
) As Image

Parameters

icon
Type: Atalasoft.Annotate.IconsAnnotateIcon
The image to extract.
size
Type: Atalasoft.Annotate.IconsAnnotateIconSize
The size of the image to extract.

Return Value

Type: Image
See Also

Reference

IconResource Class
Atalasoft.Annotate.Icons Namespace


Atalasoft.Annotate.Importers Namespace

The Atalasoft.Annotate.Importers namespace contains classes used to import annotations from a specific format into DotImage annotations.
Classes
 | Class | Description
Public class | AnnotationDataImporter | AnnotationDataImporter is an abstract base class used to define how annotations are imported from arbitrary data files into DotImage.
Public class | AnnotationDataImportEventArgs | An object representing information about an annotation being imported.
Public class | AnnotationDataMergerDictionary | THis is a collection of types and delegates that define how annotations are merged after importing.
Public class | AnnotationDataPageImportEventArgs | An object representing information about a page of annotations being imported.
Public class | AnnotationDataPropertyMerger | AnnotationDataPropertyMerger is a utility class that conditionally merges properties from one annotation into another. This class is used as the default property merger in the PdfAnnotationDataImporter.
Public class | PdfAnnotationDataImporter | Constructs a new PdfAnnotationDataImporter object.
Public class | XmpAnnotationDataImporter | An object for importing annotations from a stream of XMP data.
Delegates
 | Delegate | Description
Public delegate | AnnotationDataImporterFactory | A delegate for constructing annotations from data that a given AnnotationDataImporter doesn't understand.
Public delegate | AnnotationDataImportEventHandler | A delegate called after annotation data has been imported.
Public delegate | AnnotationDataMerger | Merges data from one annotation into another, returning the merged annotation.
Public delegate | AnnotationDataPageImportEventHandler | A delegate called for each page imported.
Enumerations
 | Enumeration | Description
Public enumeration | AnnotationDataPropertyChoice | Enumeration used to select how one property is chosen from a pair of AnnotationData objects.


AnnotationDataImporter Class

AnnotationDataImporter is an abstract base class used to define how annotations are imported from arbitrary data files into DotImage.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ImportersAnnotationDataImporter
Atalasoft.Annotate.ImportersPdfAnnotationDataImporter
Atalasoft.Annotate.ImportersXmpAnnotationDataImporter

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class AnnotationDataImporter
Public MustInherit Class AnnotationDataImporter

The AnnotationDataImporter type exposes the following members.

Constructors
 | Name | Description
Protected method | AnnotationDataImporter | Initializes a new instance of the AnnotationDataImporter class
Top
Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so.
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations.
Public property | PageCount | Gets the total number of pages in a document.
Public property | Resolution | Gets or sets the target resolution for the annotations.
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions.
Public property | Units | Gets or sets the units of the target for the annotations.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new annotation importer associated with a given stream.
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as AnnotationDataCollection.
Public method | Import(Int32) | Imports a page of annotations as LayerData.
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations.
Public method | IsValidFormat | Indicates whether or not an AnnotationDataImporter can recognize a particular data format.
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount(Int32).
Protected method | LLGetPageCount | The low-level implementation of PageCount.
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object.
Protected method | LLImport(Int32, Int32) |
Protected method | LLLoad | The low-level implementation of Load.
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Raises the AnnotationImported event.
Protected method | OnAnnotationPageImported | Raises the AnnotationPageImported event.
Protected method | OnAnnotationPageImporting | Raises the AnnotationPageImporting event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported.
Public event | AnnotationPageImported | Raised after a page of annotations has been imported.
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported.
Top
Fields
 | Name | Description
Protected field | Loaded |
Top
Remarks
Since this class is abstract, you can't use it directly
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter Constructor

Initializes a new instance of the AnnotationDataImporter class

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AnnotationDataImporter()
Protected Sub New
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter Properties

The AnnotationDataImporter type exposes the following members.

Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so.
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations.
Public property | PageCount | Gets the total number of pages in a document.
Public property | Resolution | Gets or sets the target resolution for the annotations.
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions.
Public property | Units | Gets or sets the units of the target for the annotations.
Top
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.FailsafeAnnotationFactory Property

AnnotationDataImporterFailsafeAnnotationFactory Property

Gets or sets a delegate that is used to create annotations if an importer is unable to do so.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataImporterFactory FailsafeAnnotationFactory { get; set; }
Public Property FailsafeAnnotationFactory As AnnotationDataImporterFactory
    Get
    Set

Property Value

Type: AnnotationDataImporterFactory
A delegate used to create annotations if an importer is unable to do so.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LastErrors Property

AnnotationDataImporterLastErrors Property

Gets a collection of strings representing errors encountered while importing annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringCollection LastErrors { get; }
Public ReadOnly Property LastErrors As StringCollection
    Get

Property Value

Type: StringCollection
A StringCollection containing errors encountered while importing.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.PageCount Property

AnnotationDataImporterPageCount Property

Gets the total number of pages in a document.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32
The number of pages in a document.
Remarks
It is not necessary to call Load before accessing PageCount; this will happen automatically.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Resolution Property

AnnotationDataImporterResolution Property

Gets or sets the target resolution for the annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; set; }
Public Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
The target resolution.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.ThrowOnError Property

AnnotationDataImporterThrowOnError Property

Gets or sets whether or not the importer will throw or suppress exceptions.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ThrowOnError { get; set; }
Public Property ThrowOnError As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the importer will throw exceptions.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Units Property

AnnotationDataImporterUnits Property

Gets or sets the units of the target for the annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUnit Units { get; set; }
Public Property Units As AnnotationUnit
    Get
    Set

Property Value

Type: AnnotationUnit
The target units.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter Methods

The AnnotationDataImporter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new annotation importer associated with a given stream.
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as AnnotationDataCollection.
Public method | Import(Int32) | Imports a page of annotations as LayerData.
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations.
Public method | IsValidFormat | Indicates whether or not an AnnotationDataImporter can recognize a particular data format.
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount(Int32).
Protected method | LLGetPageCount | The low-level implementation of PageCount.
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object.
Protected method | LLImport(Int32, Int32) |
Protected method | LLLoad | The low-level implementation of Load.
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Raises the AnnotationImported event.
Protected method | OnAnnotationPageImported | Raises the AnnotationPageImported event.
Protected method | OnAnnotationPageImporting | Raises the AnnotationPageImporting event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.FromStream Method

AnnotationDataImporterFromStream Method

Constructs a new annotation importer associated with a given stream.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AnnotationDataImporter FromStream(
    Stream stm
)
Public MustOverride Function FromStream (
    stm As Stream
) As AnnotationDataImporter

Parameters

stm
Type: System.IOStream
A non-null stream containing annotation data.

Return Value

Type: AnnotationDataImporter
A new annotation importer for importing annotations.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.GetAnnotationCount Method

AnnotationDataImporterGetAnnotationCount Method

Returns the number of annotations on a conceptual page of a document.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetAnnotationCount(
    int page
)
Public Function GetAnnotationCount (
    page As Integer
) As Integer

Parameters

page
Type: SystemInt32
page is an integer that represents the conceptual zero based page index of a document. It will be range checked against the total number of pages in the document.

Return Value

Type: Int32
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Import Method

AnnotationDataImporterImport Method

Imports annotations from a source
Overload List
 | Name | Description
Public method | Import | Imports all annotations as AnnotationDataCollection.
Public method | Import(Int32) | Imports a page of annotations as LayerData.
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations.
Top
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Import Method

AnnotationDataImporterImport Method

Imports all annotations as AnnotationDataCollection.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AnnotationDataCollection Import()
Public Overridable Function Import As AnnotationDataCollection

Return Value

Type: AnnotationDataCollection
A new AnnotationDataCollection object representing annotations for the entire document. Each LayerData within the collection represents one page of annotations. If a page has no annotations, the LayerData will be non-null, but empty.
Remarks
Load must be called before any of the Import methods.
See Also

Reference

AnnotationDataImporter Class
Import Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Import Method (Int32)

AnnotationDataImporterImport Method (Int32)

Imports a page of annotations as LayerData.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual LayerData Import(
    int page
)
Public Overridable Function Import (
    page As Integer
) As LayerData

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerData
A LayerData containing a set of annotations from the page.
See Also

Reference

AnnotationDataImporter Class
Import Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Import Method (Int32, Int32)

AnnotationDataImporterImport Method (Int32, Int32)

Imports a single annotation from a given page of annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AnnotationData Import(
    int page,
    int annotIndex
)
Public Overridable Function Import (
    page As Integer,
    annotIndex As Integer
) As AnnotationData

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.
annotIndex
Type: SystemInt32
The zero-based annotation which will be imported. annotIndex is range checked against the number of annotations of the page. The number of annotations on a page is available through GetAnnotationCount(Int32).

Return Value

Type: AnnotationData
A single AnnotationData object representing the imported annotation.
See Also

Reference

AnnotationDataImporter Class
Import Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.IsValidFormat Method

AnnotationDataImporterIsValidFormat Method

Indicates whether or not an AnnotationDataImporter can recognize a particular data format.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool IsValidFormat(
    Stream stm
)
Public MustOverride Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream used to recognize file format.

Return Value

Type: Boolean
true indicates that the AnnotationDataImporter recognizes this format.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LLGetAnnotationCount Method

AnnotationDataImporterLLGetAnnotationCount Method

Low level implementation of GetAnnotationCount(Int32).

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LLGetAnnotationCount(
    int page
)
Protected MustOverride Function LLGetAnnotationCount (
    page As Integer
) As Integer

Parameters

page
Type: SystemInt32
A zero-based integer representing the page from which the annotations are being counted. Page will always be in range.

Return Value

Type: Int32
An integer representing the number of annotations on the page.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LLGetPageCount Method

AnnotationDataImporterLLGetPageCount Method

The low-level implementation of PageCount.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LLGetPageCount()
Protected MustOverride Function LLGetPageCount As Integer

Return Value

Type: Int32
Returns the number of pages in the document.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LLImport Method

AnnotationDataImporterLLImport Method

The low-level implementation of Import.
The low-level implementation of Import.
Overload List
 | Name | Description
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object.
Protected method | LLImport(Int32, Int32) |
Top
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LLImport Method (Int32)

AnnotationDataImporterLLImport Method (Int32)

Imports all annotations as a LayerData object.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual LayerData LLImport(
    int page
)
Protected Overridable Function LLImport (
    page As Integer
) As LayerData

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerData
A LayerData containing a set of annotations from the page.
See Also

Reference

AnnotationDataImporter Class
LLImport Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LLImport Method (Int32, Int32)

AnnotationDataImporterLLImport Method (Int32, Int32)

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract AnnotationData LLImport(
    int page,
    int annotIndex
)
Protected MustOverride Function LLImport (
    page As Integer,
    annotIndex As Integer
) As AnnotationData

Parameters

page
Type: SystemInt32
annotIndex
Type: SystemInt32

Return Value

Type: AnnotationData
See Also

Reference

AnnotationDataImporter Class
LLImport Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.LLLoad Method

AnnotationDataImporterLLLoad Method

The low-level implementation of Load.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLLoad()
Protected MustOverride Sub LLLoad
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Load Method

AnnotationDataImporterLoad Method

The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load()
Public Sub Load
Remarks
Load is called automatically by any method that needs to access internal annotation data (e.g., PageCount or Import). Load is present for clients who want to control when annotation data is specifically loaded.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.OnAnnotationImported Method

AnnotationDataImporterOnAnnotationImported Method

Raises the AnnotationImported event.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationImported(
    AnnotationDataImportEventArgs e
)
Protected Sub OnAnnotationImported (
    e As AnnotationDataImportEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.ImportersAnnotationDataImportEventArgs
The AnnotationDataImportEventArgs for this event.
Remarks
This event is raised after an annotation has been imported.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.OnAnnotationPageImported Method

AnnotationDataImporterOnAnnotationPageImported Method

Raises the AnnotationPageImported event.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationPageImported(
    AnnotationDataPageImportEventArgs e
)
Protected Sub OnAnnotationPageImported (
    e As AnnotationDataPageImportEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.ImportersAnnotationDataPageImportEventArgs
The AnnotationDataPageImportEventArgs for this event.
Remarks
The event is raised after a page of annotations has been imported.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.OnAnnotationPageImporting Method

AnnotationDataImporterOnAnnotationPageImporting Method

Raises the AnnotationPageImporting event.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationPageImporting(
    AnnotationDataPageImportEventArgs e
)
Protected Sub OnAnnotationPageImporting (
    e As AnnotationDataPageImportEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.ImportersAnnotationDataPageImportEventArgs
The AnnotationDataPageImportEventArgs for this event.
Remarks
This event is raised before a page of annotations will be imported.
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter Events

The AnnotationDataImporter type exposes the following members.

Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported.
Public event | AnnotationPageImported | Raised after a page of annotations has been imported.
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported.
Top
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.AnnotationImported Event

AnnotationDataImporterAnnotationImported Event

Raised after a single annotation has been imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationDataImportEventHandler AnnotationImported
Public Event AnnotationImported As AnnotationDataImportEventHandler

Value

Type: Atalasoft.Annotate.ImportersAnnotationDataImportEventHandler
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.AnnotationPageImported Event

AnnotationDataImporterAnnotationPageImported Event

Raised after a page of annotations has been imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationDataPageImportEventHandler AnnotationPageImported
Public Event AnnotationPageImported As AnnotationDataPageImportEventHandler

Value

Type: Atalasoft.Annotate.ImportersAnnotationDataPageImportEventHandler
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.AnnotationPageImporting Event

AnnotationDataImporterAnnotationPageImporting Event

Raised before a page of annotations will be imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationDataPageImportEventHandler AnnotationPageImporting
Public Event AnnotationPageImporting As AnnotationDataPageImportEventHandler

Value

Type: Atalasoft.Annotate.ImportersAnnotationDataPageImportEventHandler
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter Fields

The AnnotationDataImporter type exposes the following members.

Fields
 | Name | Description
Protected field | Loaded |
Top
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporter.Loaded Field

AnnotationDataImporterLoaded Field

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool Loaded
Protected Loaded As Boolean

Field Value

Type: Boolean
See Also

Reference

AnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImporterFactory Delegate

A delegate for constructing annotations from data that a given AnnotationDataImporter doesn't understand.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate AnnotationData AnnotationDataImporterFactory(
    AnnotationDataImporter importer,
    RectangleF location,
    Object data
)
Public Delegate Function AnnotationDataImporterFactory (
    importer As AnnotationDataImporter,
    location As RectangleF,
    data As Object
) As AnnotationData

Parameters

importer
Type: Atalasoft.Annotate.ImportersAnnotationDataImporter
The AnnotationDataImporter that attempted to import the annotation.
location
Type: System.DrawingRectangleF
The location on the target page where the annotation will go.
data
Type: SystemObject
The data used to construct the annotation.

Return Value

Type: AnnotationData
A new AnnotationData object or null. If the delegate returns null, this annotation is ignored.
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs Class

An object representing information about an annotation being imported.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.ImportersAnnotationDataImportEventArgs

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDataImportEventArgs : EventArgs
Public Class AnnotationDataImportEventArgs
    Inherits EventArgs

The AnnotationDataImportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataImportEventArgs | Constructs a new AnnotationDataImportEventArgs object.
Top
Properties
 | Name | Description
Public property | Annotation | Gets the annotation that was imported.
Public property | AnnotationIndex | Gets the index on the page of the AnnotationData object.
Public property | Importer | Gets the AnnotationDataImporter that has imported the annotation.
Public property | Page | Gets the page from which the AnnotationData object was imported.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs Constructor

Constructs a new AnnotationDataImportEventArgs object.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataImportEventArgs(
    AnnotationDataImporter importer,
    AnnotationData annotation,
    int page,
    int annotIndex
)
Public Sub New (
    importer As AnnotationDataImporter,
    annotation As AnnotationData,
    page As Integer,
    annotIndex As Integer
)

Parameters

importer
Type: Atalasoft.Annotate.ImportersAnnotationDataImporter
The AnnotationDataImporter that has imported the annotation.
annotation
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object that was imported.
page
Type: SystemInt32
The page from which the AnnotationData object was imported.
annotIndex
Type: SystemInt32
The index on the page of the AnnotationData object.
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs Properties

The AnnotationDataImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Annotation | Gets the annotation that was imported.
Public property | AnnotationIndex | Gets the index on the page of the AnnotationData object.
Public property | Importer | Gets the AnnotationDataImporter that has imported the annotation.
Public property | Page | Gets the page from which the AnnotationData object was imported.
Top
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs.Annotation Property

AnnotationDataImportEventArgsAnnotation Property

Gets the annotation that was imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData Annotation { get; }
Public ReadOnly Property Annotation As AnnotationData
    Get

Property Value

Type: AnnotationData
The imported annotation.
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs.AnnotationIndex Property

AnnotationDataImportEventArgsAnnotationIndex Property

Gets the index on the page of the AnnotationData object.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AnnotationIndex { get; }
Public ReadOnly Property AnnotationIndex As Integer
    Get

Property Value

Type: Int32
The index of the annotation.
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs.Importer Property

AnnotationDataImportEventArgsImporter Property

Gets the AnnotationDataImporter that has imported the annotation.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataImporter Importer { get; }
Public ReadOnly Property Importer As AnnotationDataImporter
    Get

Property Value

Type: AnnotationDataImporter
The annotation importer.
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs.Page Property

AnnotationDataImportEventArgsPage Property

Gets the page from which the AnnotationData object was imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Page { get; }
Public ReadOnly Property Page As Integer
    Get

Property Value

Type: Int32
The page the annotation was imported from.
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventArgs Methods

The AnnotationDataImportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataImportEventHandler Delegate

A delegate called after annotation data has been imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationDataImportEventHandler(
    Object sender,
    AnnotationDataImportEventArgs args
)
Public Delegate Sub AnnotationDataImportEventHandler (
    sender As Object,
    args As AnnotationDataImportEventArgs
)

Parameters

sender
Type: SystemObject
The importer being used.
args
Type: Atalasoft.Annotate.ImportersAnnotationDataImportEventArgs
An AnnotationDataImportEventArgs containing information about the imported data.
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataMerger Delegate

Merges data from one annotation into another, returning the merged annotation.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate AnnotationData AnnotationDataMerger(
    AnnotationData pdfAnnotationData,
    AnnotationData serializedAnnotationData
)
Public Delegate Function AnnotationDataMerger (
    pdfAnnotationData As AnnotationData,
    serializedAnnotationData As AnnotationData
) As AnnotationData

Parameters

pdfAnnotationData
Type: Atalasoft.AnnotateAnnotationData
An annotation that was imported from a PDF file
serializedAnnotationData
Type: Atalasoft.AnnotateAnnotationData
An annotation that was extracted from embedded data in the imported PDF annotation

Return Value

Type: AnnotationData
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataMergerDictionary Class

THis is a collection of types and delegates that define how annotations are merged after importing.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary Type, AnnotationDataMerger
Atalasoft.Annotate.ImportersAnnotationDataMergerDictionary

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDataMergerDictionary : Dictionary<Type, AnnotationDataMerger>
Public Class AnnotationDataMergerDictionary
    Inherits Dictionary(Of Type, AnnotationDataMerger)

The AnnotationDataMergerDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataMergerDictionary | Initializes a new instance of the AnnotationDataMergerDictionary class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary Type, AnnotationDataMerger .)
Top
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataMergerDictionary Constructor

Initializes a new instance of the AnnotationDataMergerDictionary class

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataMergerDictionary()
Public Sub New
See Also

Reference

AnnotationDataMergerDictionary Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataMergerDictionary Properties

The AnnotationDataMergerDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Top
See Also

Reference

AnnotationDataMergerDictionary Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataMergerDictionary Methods

The AnnotationDataMergerDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary Type, AnnotationDataMerger .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary Type, AnnotationDataMerger .)
Top
See Also

Reference

AnnotationDataMergerDictionary Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs Class

An object representing information about a page of annotations being imported.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.ImportersAnnotationDataPageImportEventArgs

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDataPageImportEventArgs : EventArgs
Public Class AnnotationDataPageImportEventArgs
    Inherits EventArgs

The AnnotationDataPageImportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataPageImportEventArgs | Constructs a new AnnotationDataPageImportEventArgs object.
Top
Properties
 | Name | Description
Public property | Importer | Gets the AnnotationDataImporter used to import the annotations.
Public property | Layer | Gets the layer of annotations imported.
Public property | Page | Gets the page number of the annotations being imported.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs Constructor

Constructs a new AnnotationDataPageImportEventArgs object.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataPageImportEventArgs(
    AnnotationDataImporter importer,
    LayerData layer,
    int page
)
Public Sub New (
    importer As AnnotationDataImporter,
    layer As LayerData,
    page As Integer
)

Parameters

importer
Type: Atalasoft.Annotate.ImportersAnnotationDataImporter
The AnnotationDataImporter importing the page.
layer
Type: Atalasoft.AnnotateLayerData
The layer of annotations imported.
page
Type: SystemInt32
The page number of the annotations being imported.
See Also

Reference

AnnotationDataPageImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs Properties

The AnnotationDataPageImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Importer | Gets the AnnotationDataImporter used to import the annotations.
Public property | Layer | Gets the layer of annotations imported.
Public property | Page | Gets the page number of the annotations being imported.
Top
See Also

Reference

AnnotationDataPageImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs.Importer Property

AnnotationDataPageImportEventArgsImporter Property

Gets the AnnotationDataImporter used to import the annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataImporter Importer { get; }
Public ReadOnly Property Importer As AnnotationDataImporter
    Get

Property Value

Type: AnnotationDataImporter
The annotation importer.
See Also

Reference

AnnotationDataPageImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs.Layer Property

AnnotationDataPageImportEventArgsLayer Property

Gets the layer of annotations imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerData Layer { get; }
Public ReadOnly Property Layer As LayerData
    Get

Property Value

Type: LayerData
The layer imported.
See Also

Reference

AnnotationDataPageImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs.Page Property

AnnotationDataPageImportEventArgsPage Property

Gets the page number of the annotations being imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Page { get; }
Public ReadOnly Property Page As Integer
    Get

Property Value

Type: Int32
The page number of the annotations.
See Also

Reference

AnnotationDataPageImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventArgs Methods

The AnnotationDataPageImportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataPageImportEventArgs Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPageImportEventHandler Delegate

A delegate called for each page imported.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationDataPageImportEventHandler(
    Object sender,
    AnnotationDataPageImportEventArgs args
)
Public Delegate Sub AnnotationDataPageImportEventHandler (
    sender As Object,
    args As AnnotationDataPageImportEventArgs
)

Parameters

sender
Type: SystemObject
The importer used.
args
Type: Atalasoft.Annotate.ImportersAnnotationDataPageImportEventArgs
An AnnotationDataPageImportEventArgs containing information about the page that was imported.
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyChoice Enumeration

Enumeration used to select how one property is chosen from a pair of AnnotationData objects.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationDataPropertyChoice
Public Enumeration AnnotationDataPropertyChoice
Members
Member name | Description
FromPdfData | Use a property from the imported PDF annotation
FromSerializedData | Use a property from the annotation data embedded within the PDF annotation
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger Class

AnnotationDataPropertyMerger is a utility class that conditionally merges properties from one annotation into another. This class is used as the default property merger in the PdfAnnotationDataImporter.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ImportersAnnotationDataPropertyMerger

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDataPropertyMerger
Public Class AnnotationDataPropertyMerger

The AnnotationDataPropertyMerger type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataPropertyMerger | Makes a default merger that will merge Location, Size, and Modified time.
Public method | AnnotationDataPropertyMerger(String) | Makes a merger that will merge a set of properties by name.
Top
Properties
 | Name | Description
Public property | MergeList | Gets a collection of properties that will be merged from one annotation data object to another.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeSpecificCommonProperties | Merges a set of properties from one object into another using the MergeList to select how it will be merged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
It is unlikely that this class is needed outside of the context of PdfAnnotationDataImporter, although it could be used as a general mechanism for copying public properties from one AnnotationData object to another by name.
See Also

Reference

Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger Constructor

Constructs a new AnnotationDataPropertyMerger.
Overload List
 | Name | Description
Public method | AnnotationDataPropertyMerger | Makes a default merger that will merge Location, Size, and Modified time.
Public method | AnnotationDataPropertyMerger(String) | Makes a merger that will merge a set of properties by name.
Top
See Also

Reference

AnnotationDataPropertyMerger Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger Constructor

Makes a default merger that will merge Location, Size, and Modified time.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataPropertyMerger()
Public Sub New
See Also

Reference

AnnotationDataPropertyMerger Class
AnnotationDataPropertyMerger Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger Constructor (String[])

AnnotationDataPropertyMerger Constructor (String)

Makes a merger that will merge a set of properties by name.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataPropertyMerger(
    params string[] items
)
Public Sub New (
    ParamArray items As String()
)

Parameters

items
Type: SystemString
A list of items that will be copied from the imported PDF annotation into the embedded PDF annotation.
See Also

Reference

AnnotationDataPropertyMerger Class
AnnotationDataPropertyMerger Overload
Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger Properties

The AnnotationDataPropertyMerger type exposes the following members.

Properties
 | Name | Description
Public property | MergeList | Gets a collection of properties that will be merged from one annotation data object to another.
Top
See Also

Reference

AnnotationDataPropertyMerger Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger.MergeList Property

AnnotationDataPropertyMergerMergeList Property

Gets a collection of properties that will be merged from one annotation data object to another.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dictionary<string, AnnotationDataPropertyChoice> MergeList { get; }
Public ReadOnly Property MergeList As Dictionary(Of String, AnnotationDataPropertyChoice)
    Get

Property Value

Type: Dictionary String, AnnotationDataPropertyChoice
See Also

Reference

AnnotationDataPropertyMerger Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger Methods

The AnnotationDataPropertyMerger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeSpecificCommonProperties | Merges a set of properties from one object into another using the MergeList to select how it will be merged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataPropertyMerger Class
Atalasoft.Annotate.Importers Namespace


AnnotationDataPropertyMerger.MergeSpecificCommonProperties Method

AnnotationDataPropertyMergerMergeSpecificCommonProperties Method

Merges a set of properties from one object into another using the MergeList to select how it will be merged.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData MergeSpecificCommonProperties(
    AnnotationData pdfAnnotationData,
    AnnotationData serializedAnnotationData
)
Public Function MergeSpecificCommonProperties (
    pdfAnnotationData As AnnotationData,
    serializedAnnotationData As AnnotationData
) As AnnotationData

Parameters

pdfAnnotationData
Type: Atalasoft.AnnotateAnnotationData
An annotation that was imported from a PDF file
serializedAnnotationData
Type: Atalasoft.AnnotateAnnotationData
An annotation that was extracted from embedded data in the imported PDF annotation

Return Value

Type: AnnotationData
See Also

Reference

AnnotationDataPropertyMerger Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Class

Constructs a new PdfAnnotationDataImporter object.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ImportersAnnotationDataImporter
Atalasoft.Annotate.ImportersPdfAnnotationDataImporter

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfAnnotationDataImporter : AnnotationDataImporter
Public Class PdfAnnotationDataImporter
    Inherits AnnotationDataImporter

The PdfAnnotationDataImporter type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationDataImporter | Constructs a new PdfAnnotationDataImporter.
Public method | PdfAnnotationDataImporter(Stream) | Constructs a new PdfAnnotationDataImporter for the given stream.
Public method | PdfAnnotationDataImporter(Stream, String) | Obsolete. Constructs a new PdfAnnotationDataImporter for the given stream.
Public method | PdfAnnotationDataImporter(Stream, String, String) | Obsolete. Constructs a new PdfAnnotationDataImporter for the given stream.
Top
Properties
 | Name | Description
Public property | AnnotationDataMergers | Gets a collection of mergers that are used to import annotation data from PDF annotations.
Public property | AnnotationStream | The stream which contains the annotation information.
Public property | DefaultMerger | Gets the default merger used by DotImage.
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationDataImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationDataImporter.)
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to open the PDF containing the annotations.
Public property | PageCount | Gets the total number of pages in a document. (Inherited from AnnotationDataImporter.)
Public property | Resolution | Gets or sets the target resolution for the annotations. (Inherited from AnnotationDataImporter.)
Public property | SkipUnknownAnnotationTypes | Gets or sets a value indicating whether to skip unknown annotations.
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationDataImporter.)
Public property | Units | Gets or sets the units of the target for the annotations. (Inherited from AnnotationDataImporter.)
Public property | UserPassword | Obsolete. Gets or sets the user password to open the PDF containing the annotations.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Returns a new PdfAnnotationDataImporter object attached to the given Stream. (Overrides AnnotationDataImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationDataImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as AnnotationDataCollection. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32) | (Overrides AnnotationDataImporterImport(Int32).)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationDataImporter.)
Public method | IsValidFormat | Indicates whether or not the stream is a PDF. (Overrides AnnotationDataImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | (Overrides AnnotationDataImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | (Overrides AnnotationDataImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object. (Inherited from AnnotationDataImporter.)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationDataImporterLLImport(Int32, Int32).)
Protected method | LLLoad | (Overrides AnnotationDataImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations. (Inherited from AnnotationDataImporter.)
Public method | Load(SecureString, SecureString) | The load method is used to allow an PdfAnnotationDataImporter to load annotations from encrypted PDF document.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Raises the AnnotationImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImported | Raises the AnnotationPageImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImporting | Raises the AnnotationPageImporting event. (Inherited from AnnotationDataImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationDataImporter.)
Top
Fields
 | Name | Description
Protected field | Loaded | (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Constructor

Constructs a new PdfAnnotationDataImporter object.
Overload List
 | Name | Description
Public method | PdfAnnotationDataImporter | Constructs a new PdfAnnotationDataImporter.
Public method | PdfAnnotationDataImporter(Stream) | Constructs a new PdfAnnotationDataImporter for the given stream.
Public method | PdfAnnotationDataImporter(Stream, String) | Obsolete. Constructs a new PdfAnnotationDataImporter for the given stream.
Public method | PdfAnnotationDataImporter(Stream, String, String) | Obsolete. Constructs a new PdfAnnotationDataImporter for the given stream.
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Constructor

Constructs a new PdfAnnotationDataImporter.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationDataImporter()
Public Sub New
See Also

Reference

PdfAnnotationDataImporter Class
PdfAnnotationDataImporter Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Constructor (Stream)

Constructs a new PdfAnnotationDataImporter for the given stream.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationDataImporter(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
 | Thrown if the stream is not seekable.
See Also

Reference

PdfAnnotationDataImporter Class
PdfAnnotationDataImporter Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Constructor (Stream, String)

Note: This API is now obsolete.

Constructs a new PdfAnnotationDataImporter for the given stream.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)]
public PdfAnnotationDataImporter(
    Stream stm,
    string password
)
<ObsoleteAttribute("This constructor is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)>
Public Sub New (
    stm As Stream,
    password As String
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
password
Type: SystemString
The password to open the PDF.
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
 | Thrown if the stream is not seekable.
See Also

Reference

PdfAnnotationDataImporter Class
PdfAnnotationDataImporter Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Constructor (Stream, String, String)

Note: This API is now obsolete.

Constructs a new PdfAnnotationDataImporter for the given stream.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)]
public PdfAnnotationDataImporter(
    Stream stm,
    string userPassword,
    string ownerPassword
)
<ObsoleteAttribute("This constructor is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)>
Public Sub New (
    stm As Stream,
    userPassword As String,
    ownerPassword As String
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
userPassword
Type: SystemString
The user password for the PDF.
ownerPassword
Type: SystemString
The owner password for the PDF.
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
 | Thrown if the stream is not seekable.
See Also

Reference

PdfAnnotationDataImporter Class
PdfAnnotationDataImporter Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Properties

The PdfAnnotationDataImporter type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationDataMergers | Gets a collection of mergers that are used to import annotation data from PDF annotations.
Public property | AnnotationStream | The stream which contains the annotation information.
Public property | DefaultMerger | Gets the default merger used by DotImage.
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationDataImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationDataImporter.)
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to open the PDF containing the annotations.
Public property | PageCount | Gets the total number of pages in a document. (Inherited from AnnotationDataImporter.)
Public property | Resolution | Gets or sets the target resolution for the annotations. (Inherited from AnnotationDataImporter.)
Public property | SkipUnknownAnnotationTypes | Gets or sets a value indicating whether to skip unknown annotations.
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationDataImporter.)
Public property | Units | Gets or sets the units of the target for the annotations. (Inherited from AnnotationDataImporter.)
Public property | UserPassword | Obsolete. Gets or sets the user password to open the PDF containing the annotations.
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.AnnotationDataMergers Property

PdfAnnotationDataImporterAnnotationDataMergers Property

Gets a collection of mergers that are used to import annotation data from PDF annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataMergerDictionary AnnotationDataMergers { get; }
Public ReadOnly Property AnnotationDataMergers As AnnotationDataMergerDictionary
    Get

Property Value

Type: AnnotationDataMergerDictionary
Remarks

When annotations have been exported to a PDF with DotImage annotation embedded in them, the DotImage annotation does not change when a user interacts with the annotation contained in the PDF. As a result, some properties of the embedded annotation and the imported annotation may not match, such as Bounds, Fill, and so on.

AnnotationDataMergers are used to select a mechanism by which properties will be merged from the imported annotation and the embedded annotation. By default, this is done by selecting properties in the imported annotation that match properties in the embedded annotation by name and copying them into the embedded annotation based on a choice.

Given the type of the embedded annotation, a merge delegate is selected that will choose how properties will be copied from one annotation to the other.

See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.AnnotationStream Property

PdfAnnotationDataImporterAnnotationStream Property

The stream which contains the annotation information.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream AnnotationStream { get; set; }
Public Property AnnotationStream As Stream
    Get
    Set

Property Value

Type: Stream
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.DefaultMerger Property

PdfAnnotationDataImporterDefaultMerger Property

Gets the default merger used by DotImage.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataPropertyMerger DefaultMerger { get; }
Public ReadOnly Property DefaultMerger As AnnotationDataPropertyMerger
    Get

Property Value

Type: AnnotationDataPropertyMerger
This is a default merger that is used if there is no other merger available.
Remarks
The DefaultMerger is an instance of AnnotationDataPropertyMerger constructed with the default constructor.
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.OwnerPassword Property

PdfAnnotationDataImporterOwnerPassword Property

Note: This API is now obsolete.

Gets or sets the owner password to open the PDF containing the annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
The owner password for opening the PDF.
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.SkipUnknownAnnotationTypes Property

PdfAnnotationDataImporterSkipUnknownAnnotationTypes Property

Gets or sets a value indicating whether to skip unknown annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SkipUnknownAnnotationTypes { get; set; }
Public Property SkipUnknownAnnotationTypes As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.UserPassword Property

PdfAnnotationDataImporterUserPassword Property

Note: This API is now obsolete.

Gets or sets the user password to open the PDF containing the annotations.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. To use PdfAnnotationDataImporter with passwords, provide passwords to Load method.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
The user password for opening the PDF.
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Methods

The PdfAnnotationDataImporter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Returns a new PdfAnnotationDataImporter object attached to the given Stream. (Overrides AnnotationDataImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationDataImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as AnnotationDataCollection. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32) | (Overrides AnnotationDataImporterImport(Int32).)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationDataImporter.)
Public method | IsValidFormat | Indicates whether or not the stream is a PDF. (Overrides AnnotationDataImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | (Overrides AnnotationDataImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | (Overrides AnnotationDataImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object. (Inherited from AnnotationDataImporter.)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationDataImporterLLImport(Int32, Int32).)
Protected method | LLLoad | (Overrides AnnotationDataImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations. (Inherited from AnnotationDataImporter.)
Public method | Load(SecureString, SecureString) | The load method is used to allow an PdfAnnotationDataImporter to load annotations from encrypted PDF document.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Raises the AnnotationImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImported | Raises the AnnotationPageImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImporting | Raises the AnnotationPageImporting event. (Inherited from AnnotationDataImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.FromStream Method

PdfAnnotationDataImporterFromStream Method

Returns a new PdfAnnotationDataImporter object attached to the given Stream.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationDataImporter FromStream(
    Stream stm
)
Public Overrides Function FromStream (
    stm As Stream
) As AnnotationDataImporter

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.

Return Value

Type: AnnotationDataImporter
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.Import Method

PdfAnnotationDataImporterImport Method

Imports annotations from a source
Overload List
 | Name | Description
Public method | Import | Imports all annotations as AnnotationDataCollection. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32) | (Overrides AnnotationDataImporterImport(Int32).)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.Import Method (Int32)

PdfAnnotationDataImporterImport Method (Int32)

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override LayerData Import(
    int pageNo
)
Public Overrides Function Import (
    pageNo As Integer
) As LayerData

Parameters

pageNo
Type: SystemInt32

Return Value

Type: LayerData
See Also

Reference

PdfAnnotationDataImporter Class
Import Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.IsValidFormat Method

PdfAnnotationDataImporterIsValidFormat Method

Indicates whether or not the stream is a PDF.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stm
)
Public Overrides Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream.

Return Value

Type: Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stm argument is null (Nothing in VB).
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.LLGetAnnotationCount Method

PdfAnnotationDataImporterLLGetAnnotationCount Method

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetAnnotationCount(
    int pageNo
)
Protected Overrides Function LLGetAnnotationCount (
    pageNo As Integer
) As Integer

Parameters

pageNo
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.LLGetPageCount Method

PdfAnnotationDataImporterLLGetPageCount Method

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetPageCount()
Protected Overrides Function LLGetPageCount As Integer

Return Value

Type: Int32
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.LLImport Method

PdfAnnotationDataImporterLLImport Method

The low-level implementation of Import.
Overload List
 | Name | Description
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object. (Inherited from AnnotationDataImporter.)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationDataImporterLLImport(Int32, Int32).)
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.LLImport Method (Int32, Int32)

PdfAnnotationDataImporterLLImport Method (Int32, Int32)

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData LLImport(
    int pageNo,
    int annotIndex
)
Protected Overrides Function LLImport (
    pageNo As Integer,
    annotIndex As Integer
) As AnnotationData

Parameters

pageNo
Type: SystemInt32
annotIndex
Type: SystemInt32

Return Value

Type: AnnotationData
See Also

Reference

PdfAnnotationDataImporter Class
LLImport Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.LLLoad Method

PdfAnnotationDataImporterLLLoad Method

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLLoad()
Protected Overrides Sub LLLoad
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.Load Method

PdfAnnotationDataImporterLoad Method

Overload List
 | Name | Description
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations. (Inherited from AnnotationDataImporter.)
Public method | Load(SecureString, SecureString) | The load method is used to allow an PdfAnnotationDataImporter to load annotations from encrypted PDF document.
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter.Load Method (SecureString, SecureString)

PdfAnnotationDataImporterLoad Method (SecureString, SecureString)

The load method is used to allow an PdfAnnotationDataImporter to load annotations from encrypted PDF document.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    SecureString userPassword,
    SecureString ownerPassword
)
Public Sub Load (
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

userPassword
Type: System.SecuritySecureString
The user password to load the PDF document.
ownerPassword
Type: System.SecuritySecureString
The owner password to load the PDF document.
See Also

Reference

PdfAnnotationDataImporter Class
Load Overload
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Events

The PdfAnnotationDataImporter type exposes the following members.

Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


PdfAnnotationDataImporter Fields

The PdfAnnotationDataImporter type exposes the following members.

Fields
 | Name | Description
Protected field | Loaded | (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

PdfAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Class

An object for importing annotations from a stream of XMP data.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.ImportersAnnotationDataImporter
Atalasoft.Annotate.ImportersXmpAnnotationDataImporter

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class XmpAnnotationDataImporter : AnnotationDataImporter
Public Class XmpAnnotationDataImporter
    Inherits AnnotationDataImporter

The XmpAnnotationDataImporter type exposes the following members.

Constructors
 | Name | Description
Public method | XmpAnnotationDataImporter | Creates a new instance of XmpAnnotationDataImporter.
Public method | XmpAnnotationDataImporter(Stream) | Creates a new instance of XmpAnnotationDataImporter with a stream of XMP data.
Top
Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationDataImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationDataImporter.)
Public property | PageCount | Gets the total number of pages in a document. (Inherited from AnnotationDataImporter.)
Public property | Resolution | Gets or sets the target resolution for the annotations. (Inherited from AnnotationDataImporter.)
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationDataImporter.)
Public property | Units | Gets or sets the units of the target for the annotations. (Inherited from AnnotationDataImporter.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new XmpAnnotationDataImporter for the given stream. (Overrides AnnotationDataImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationDataImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as AnnotationDataCollection. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerData. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationDataImporter.)
Public method | IsValidFormat | Indicates if the stream contains XMP data. (Overrides AnnotationDataImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount(Int32). (Overrides AnnotationDataImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | The low-level implementation of PageCount. (Overrides AnnotationDataImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object. (Overrides AnnotationDataImporterLLImport(Int32).)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationDataImporterLLImport(Int32, Int32).)
Protected method | LLLoad | The low-level implementation of Load. (Overrides AnnotationDataImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations. (Inherited from AnnotationDataImporter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Raises the AnnotationImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImported | Raises the AnnotationPageImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImporting | Raises the AnnotationPageImporting event. (Inherited from AnnotationDataImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationDataImporter.)
Top
Fields
 | Name | Description
Protected field | Loaded | (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Constructor

Constructs a new XmpAnnotationDataImporter object.
Overload List
 | Name | Description
Public method | XmpAnnotationDataImporter | Creates a new instance of XmpAnnotationDataImporter.
Public method | XmpAnnotationDataImporter(Stream) | Creates a new instance of XmpAnnotationDataImporter with a stream of XMP data.
Top
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Constructor

Creates a new instance of XmpAnnotationDataImporter.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpAnnotationDataImporter()
Public Sub New
See Also

Reference

XmpAnnotationDataImporter Class
XmpAnnotationDataImporter Overload
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Constructor (Stream)

Creates a new instance of XmpAnnotationDataImporter with a stream of XMP data.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpAnnotationDataImporter(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
A stream from which annotations will be imported.
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
See Also

Reference

XmpAnnotationDataImporter Class
XmpAnnotationDataImporter Overload
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Properties

The XmpAnnotationDataImporter type exposes the following members.

Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationDataImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationDataImporter.)
Public property | PageCount | Gets the total number of pages in a document. (Inherited from AnnotationDataImporter.)
Public property | Resolution | Gets or sets the target resolution for the annotations. (Inherited from AnnotationDataImporter.)
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationDataImporter.)
Public property | Units | Gets or sets the units of the target for the annotations. (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Methods

The XmpAnnotationDataImporter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new XmpAnnotationDataImporter for the given stream. (Overrides AnnotationDataImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationDataImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as AnnotationDataCollection. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerData. (Inherited from AnnotationDataImporter.)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationDataImporter.)
Public method | IsValidFormat | Indicates if the stream contains XMP data. (Overrides AnnotationDataImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount(Int32). (Overrides AnnotationDataImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | The low-level implementation of PageCount. (Overrides AnnotationDataImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object. (Overrides AnnotationDataImporterLLImport(Int32).)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationDataImporterLLImport(Int32, Int32).)
Protected method | LLLoad | The low-level implementation of Load. (Overrides AnnotationDataImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationDataImporter to load and to possibly cache annotations. (Inherited from AnnotationDataImporter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Raises the AnnotationImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImported | Raises the AnnotationPageImported event. (Inherited from AnnotationDataImporter.)
Protected method | OnAnnotationPageImporting | Raises the AnnotationPageImporting event. (Inherited from AnnotationDataImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.FromStream Method

XmpAnnotationDataImporterFromStream Method

Constructs a new XmpAnnotationDataImporter for the given stream.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationDataImporter FromStream(
    Stream stm
)
Public Overrides Function FromStream (
    stm As Stream
) As AnnotationDataImporter

Parameters

stm
Type: System.IOStream
A non-null stream containing XMP data.

Return Value

Type: AnnotationDataImporter
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.IsValidFormat Method

XmpAnnotationDataImporterIsValidFormat Method

Indicates if the stream contains XMP data.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stm
)
Public Overrides Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream containing XMP data

Return Value

Type: Boolean
Returns true if the stream contains XMP data; false otherwise.
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.LLGetAnnotationCount Method

XmpAnnotationDataImporterLLGetAnnotationCount Method

Low level implementation of GetAnnotationCount(Int32).

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetAnnotationCount(
    int page
)
Protected Overrides Function LLGetAnnotationCount (
    page As Integer
) As Integer

Parameters

page
Type: SystemInt32
A zero-based integer representing the page from which the annotations are being counted. Page will always be in range.

Return Value

Type: Int32
An integer representing the number of annotations on the page.
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.LLGetPageCount Method

XmpAnnotationDataImporterLLGetPageCount Method

The low-level implementation of PageCount.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetPageCount()
Protected Overrides Function LLGetPageCount As Integer

Return Value

Type: Int32
Returns the number of pages in the document.
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.LLImport Method

XmpAnnotationDataImporterLLImport Method

The low-level implementation of Import(Int32, Int32).
The low-level implementation of Import(Int32, Int32).
Overload List
 | Name | Description
Protected method | LLImport(Int32) | Imports all annotations as a LayerData object. (Overrides AnnotationDataImporterLLImport(Int32).)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationDataImporterLLImport(Int32, Int32).)
Top
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.LLImport Method (Int32)

XmpAnnotationDataImporterLLImport Method (Int32)

Imports all annotations as a LayerData object.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override LayerData LLImport(
    int page
)
Protected Overrides Function LLImport (
    page As Integer
) As LayerData

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerData
A LayerData containing a set of annotations from the page.
See Also

Reference

XmpAnnotationDataImporter Class
LLImport Overload
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.LLImport Method (Int32, Int32)

XmpAnnotationDataImporterLLImport Method (Int32, Int32)

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData LLImport(
    int page,
    int annotIndex
)
Protected Overrides Function LLImport (
    page As Integer,
    annotIndex As Integer
) As AnnotationData

Parameters

page
Type: SystemInt32
annotIndex
Type: SystemInt32

Return Value

Type: AnnotationData
See Also

Reference

XmpAnnotationDataImporter Class
LLImport Overload
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter.LLLoad Method

XmpAnnotationDataImporterLLLoad Method

The low-level implementation of Load.

Namespace: Atalasoft.Annotate.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLLoad()
Protected Overrides Sub LLLoad
Exceptions
Exception | Condition
CodecException | Xmp data stream is neither JPEG nor TIFF.
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Events

The XmpAnnotationDataImporter type exposes the following members.

Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationDataImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


XmpAnnotationDataImporter Fields

The XmpAnnotationDataImporter type exposes the following members.

Fields
 | Name | Description
Protected field | Loaded | (Inherited from AnnotationDataImporter.)
Top
See Also

Reference

XmpAnnotationDataImporter Class
Atalasoft.Annotate.Importers Namespace


Atalasoft.Annotate.Ink Namespace

Classes
 | Class | Description
Public class | InkAnnotation | Obsolete. The InkAnnotation class uses Microsoft.Ink.InkCollector to generate an annotation object for use with DotImage.
Public class | InkAnnotationFactory | Obsolete. The InkAnnotationFactory is used by DotImage to create an InkAnnotation when deserializing an InkData object. Normally the entire InkAnnotation will be serialized to eliminate this step.
Public class | InkAnnotationRenderingEngine | Obsolete. This class is used for rendering InkData objects. An instance of this class is automatically added to the AnnotationRenderers when an InkData object is created.
Public class | InkData | Obsolete. This class holds the InkCollector data for an InkAnnotation.
Public class | InkDrawingAttributes | Obsolete. This class is used to define the pen properties used when drawing ink.


InkAnnotation Class

Note: This API is now obsolete.

The InkAnnotation class uses Microsoft.Ink.InkCollector to generate an annotation object for use with DotImage.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.InkInkAnnotation

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute("This component is no longer available in DotImage.",
    true)]
public class InkAnnotation : AnnotationUI,
    IDisposable, ISerializable, ILegacyXmpSupport
<SerializableAttribute>
<ObsoleteAttribute("This component is no longer available in DotImage.",
    true)>
Public Class InkAnnotation
    Inherits AnnotationUI
    Implements IDisposable, ISerializable, ILegacyXmpSupport

The InkAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | InkAnnotation | Creates a new instance of InkAnnotation.
Public method | InkAnnotation(InkData) | Creates an instance of InkAnnotation from an InkData object.
Public method | InkAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of InkAnnotation from serialized information.
Top
Properties
 | Name | Description
Public property | AllowPenScaling |
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | DrawingAttributes |
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | InkEnabled | Gets or sets a value that specifies whether the InkCollector object collects pen input.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Strokes |
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Returns a new InkAnnotation object created from the ink data contained in this object (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the InkAnnotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | InkAnnotation destructor (note: IDisposable) (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | (Overrides AnnotationUIOnControllerChanged(EventArgs).)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Ink Namespace


InkAnnotation Constructor

Overload List
 | Name | Description
Public method | InkAnnotation | Creates a new instance of InkAnnotation.
Public method | InkAnnotation(InkData) | Creates an instance of InkAnnotation from an InkData object.
Public method | InkAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of InkAnnotation from serialized information.
Top
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation Constructor

Creates a new instance of InkAnnotation.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkAnnotation()
Public Sub New
See Also

Reference

InkAnnotation Class
InkAnnotation Overload
Atalasoft.Annotate.Ink Namespace


InkAnnotation Constructor (InkData)

Creates an instance of InkAnnotation from an InkData object.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkAnnotation(
    InkData data
)
Public Sub New (
    data As InkData
)

Parameters

data
Type: Atalasoft.Annotate.InkInkData
An InkData object used to create this annotation.
See Also

Reference

InkAnnotation Class
InkAnnotation Overload
Atalasoft.Annotate.Ink Namespace


InkAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of InkAnnotation from serialized information.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

InkAnnotation Class
InkAnnotation Overload
Atalasoft.Annotate.Ink Namespace


InkAnnotation Properties

The InkAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AllowPenScaling |
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | DrawingAttributes |
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | InkEnabled | Gets or sets a value that specifies whether the InkCollector object collects pen input.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Strokes |
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.AllowPenScaling Property

InkAnnotationAllowPenScaling Property

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowPenScaling { get; set; }
Public Property AllowPenScaling As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.DrawingAttributes Property

InkAnnotationDrawingAttributes Property

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkDrawingAttributes DrawingAttributes { get; set; }
Public Property DrawingAttributes As InkDrawingAttributes
    Get
    Set

Property Value

Type: InkDrawingAttributes
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.InkEnabled Property

InkAnnotationInkEnabled Property

Gets or sets a value that specifies whether the InkCollector object collects pen input.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool InkEnabled { get; set; }
Public Property InkEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.Strokes Property

InkAnnotationStrokes Property

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Strokes Strokes { get; }
Public ReadOnly Property Strokes As Strokes
    Get

Property Value

Type: Strokes
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation Methods

The InkAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Returns a new InkAnnotation object created from the ink data contained in this object (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the InkAnnotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | InkAnnotation destructor (note: IDisposable) (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | (Overrides AnnotationUIOnControllerChanged(EventArgs).)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.Clone Method

InkAnnotationClone Method

Returns a new InkAnnotation object created from the ink data contained in this object

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.Dispose Method

InkAnnotationDispose Method

Releases resources used by the InkAnnotation
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the InkAnnotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Top
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.Dispose Method

InkAnnotationDispose Method

Releases resources used by the InkAnnotation.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

InkAnnotation Class
Dispose Overload
Atalasoft.Annotate.Ink Namespace


InkAnnotation.Dispose Method (Boolean)

InkAnnotationDispose Method (Boolean)

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

InkAnnotation Class
Dispose Overload
Atalasoft.Annotate.Ink Namespace


InkAnnotation.Finalize Method

InkAnnotationFinalize Method

InkAnnotation destructor (note: IDisposable)

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.OnControllerChanged Method

InkAnnotationOnControllerChanged Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnControllerChanged(
    EventArgs e
)
Protected Overrides Sub OnControllerChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.OnMoving Method

InkAnnotationOnMoving Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.OnPropertyChanging Method

InkAnnotationOnPropertyChanging Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation.OnResizing Method

InkAnnotationOnResizing Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResizing(
    EventArgs e
)
Protected Overrides Sub OnResizing (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotation Events

The InkAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

InkAnnotation Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationFactory Class

Note: This API is now obsolete.

The InkAnnotationFactory is used by DotImage to create an InkAnnotation when deserializing an InkData object. Normally the entire InkAnnotation will be serialized to eliminate this step.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.InkInkAnnotationFactory

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This component is no longer available in DotImage.",
    true)]
public class InkAnnotationFactory : IAnnotationUIFactory
<ObsoleteAttribute("This component is no longer available in DotImage.",
    true)>
Public Class InkAnnotationFactory
    Implements IAnnotationUIFactory

The InkAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | InkAnnotationFactory | Creates a new instance of InkAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an InkAnnotation containing the InkData supplied.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Ink Namespace


InkAnnotationFactory Constructor

Creates a new instance of InkAnnotationFactory.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkAnnotationFactory()
Public Sub New
Remarks
This class is automatically created and added to the Factories collection when the InkAnnotation is added to an AnnotationController.
Remarks
This class is automatically created and added to the Factories collection when the InkAnnotation is added to an AnnotationController.
See Also

Reference

InkAnnotationFactory Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationFactory Methods

The InkAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an InkAnnotation containing the InkData supplied.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InkAnnotationFactory Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationFactory.GetAnnotationUI Method

InkAnnotationFactoryGetAnnotationUI Method

Returns an InkAnnotation containing the InkData supplied.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
An InkData object used to generate the InkAnnotation.

Return Value

Type: AnnotationUI

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

InkAnnotationFactory Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationRenderingEngine Class

Note: This API is now obsolete.

This class is used for rendering InkData objects. An instance of this class is automatically added to the AnnotationRenderers when an InkData object is created.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.InkInkAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This component is no longer available in DotImage.",
    true)]
public class InkAnnotationRenderingEngine : AnnotationRenderingEngine
<ObsoleteAttribute("This component is no longer available in DotImage.",
    true)>
Public Class InkAnnotationRenderingEngine
    Inherits AnnotationRenderingEngine

The InkAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | InkAnnotationRenderingEngine | Creates an instance of InkAnnotationRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders an InkData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Ink Namespace


InkAnnotationRenderingEngine Constructor

Creates an instance of InkAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkAnnotationRenderingEngine()
Public Sub New
See Also

Reference

InkAnnotationRenderingEngine Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationRenderingEngine Properties

The InkAnnotationRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

InkAnnotationRenderingEngine Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationRenderingEngine Methods

The InkAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders an InkData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InkAnnotationRenderingEngine Class
Atalasoft.Annotate.Ink Namespace


InkAnnotationRenderingEngine.RenderAnnotation Method

InkAnnotationRenderingEngineRenderAnnotation Method

Renders an InkData object.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The InkData to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment object containing the information required to render the data.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

InkAnnotationRenderingEngine Class
Atalasoft.Annotate.Ink Namespace


InkData Class

Note: This API is now obsolete.

This class holds the InkCollector data for an InkAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.Annotate.InkInkData

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute("This component is no longer available in DotImage.",
    true)]
public class InkData : AnnotationData, IDisposable,
    ISerializable
<SerializableAttribute>
<ObsoleteAttribute("This component is no longer available in DotImage.",
    true)>
Public Class InkData
    Inherits AnnotationData
    Implements IDisposable, ISerializable

The InkData type exposes the following members.

Constructors
 | Name | Description
Public method | InkData | Creates a new instance of InkData.
Public method | InkData(SerializationInfo, StreamingContext) | Creates a new instance of InkData from serialized information.
Top
Properties
 | Name | Description
Public property | AllowPenScaling | Gets or sets a value indicating whether the ink pen size should be scaled along with the zoom level of the viewer.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Disposed | Gets a value indicating whether this object has been disposed.
Public property | DrawingAttributes | Gets or sets the attributes that are applied to the ink when drawn.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | InkCollector | Gets the Microsoft.Ink.InkCollector used to store the ink strokes.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Strokes | Gets a collection of Microsoft.Ink.Stroke objects.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Inherited from AnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InkData and optionally releases the managed resources (Overrides AnnotationDataDispose(Boolean).)
Public method | Equals | (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | InkData destructor (Overrides AnnotationDataFinalize.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Get hash code for this object (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | (Overrides AnnotationDataMirror(MirrorDirection, Boolean).)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | (Overrides AnnotationDataOnLocationChanged(AnnotationLocationChangedEventArgs).)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | (Overrides AnnotationDataOnRotationChanged(EventArgs).)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | (Overrides AnnotationDataRotate(Single).)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
Remarks
Access to the internal InkData of an InkAnnotation is provided through the Data property.
See Also

Reference

Atalasoft.Annotate.Ink Namespace


InkData Constructor

Overload List
 | Name | Description
Public method | InkData | Creates a new instance of InkData.
Public method | InkData(SerializationInfo, StreamingContext) | Creates a new instance of InkData from serialized information.
Top
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData Constructor

Creates a new instance of InkData.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkData()
Public Sub New
See Also

Reference

InkData Class
InkData Overload
Atalasoft.Annotate.Ink Namespace


InkData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of InkData from serialized information.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information containing the ink data.
context
Type: System.Runtime.SerializationStreamingContext
A context containing information about this object.
See Also

Reference

InkData Class
InkData Overload
Atalasoft.Annotate.Ink Namespace


InkData Properties

The InkData type exposes the following members.

Properties
 | Name | Description
Public property | AllowPenScaling | Gets or sets a value indicating whether the ink pen size should be scaled along with the zoom level of the viewer.
Public property | AnnotationBounds | Gets the rectangle bounds of the annotation, including any pen or shadow, before any matricies are applied. (Inherited from AnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Disposed | Gets a value indicating whether this object has been disposed.
Public property | DrawingAttributes | Gets or sets the attributes that are applied to the ink when drawn.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | InkCollector | Gets the Microsoft.Ink.InkCollector used to store the ink strokes.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Strokes | Gets a collection of Microsoft.Ink.Stroke objects.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.AllowPenScaling Property

InkDataAllowPenScaling Property

Gets or sets a value indicating whether the ink pen size should be scaled along with the zoom level of the viewer.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowPenScaling { get; set; }
Public Property AllowPenScaling As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the ink pen size will be scaled along with the zoom level of the viewer.
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Disposed Property

InkDataDisposed Property

Gets a value indicating whether this object has been disposed.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Disposed { get; }
Public ReadOnly Property Disposed As Boolean
    Get

Property Value

Type: Boolean
True if the InkData has been disposed.
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.DrawingAttributes Property

InkDataDrawingAttributes Property

Gets or sets the attributes that are applied to the ink when drawn.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkDrawingAttributes DrawingAttributes { get; set; }
Public Property DrawingAttributes As InkDrawingAttributes
    Get
    Set

Property Value

Type: InkDrawingAttributes
The drawing attributes applied to the ink.
Remarks

This is useful for modifying the pen size and color.

Hint: A highlighter can be created by setting the RasterOperation to MaskPen.

See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.InkCollector Property

InkDataInkCollector Property

Gets the Microsoft.Ink.InkCollector used to store the ink strokes.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkCollector InkCollector { get; }
Public ReadOnly Property InkCollector As InkCollector
    Get

Property Value

Type: InkCollector
The Microsoft.Ink.InkCollector used by the InkAnnotation.
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Strokes Property

InkDataStrokes Property

Gets a collection of Microsoft.Ink.Stroke objects.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Strokes Strokes { get; }
Public ReadOnly Property Strokes As Strokes
    Get

Property Value

Type: Strokes
The Stroke objects of the InkCollector.
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData Methods

The InkData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
 | CloneBaseData | Fills the data object with cloned property values. (Inherited from AnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | (Overrides AnnotationDataDispose(Boolean).)
Public method | Equals | (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | InkData destructor (Overrides AnnotationDataFinalize.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Get hash code for this object (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | (Overrides AnnotationDataMirror(MirrorDirection, Boolean).)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | (Overrides AnnotationDataOnLocationChanged(AnnotationLocationChangedEventArgs).)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | (Overrides AnnotationDataOnRotationChanged(EventArgs).)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | (Overrides AnnotationDataRotate(Single).)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Clone Method

InkDataClone Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Dispose Method

InkDataDispose Method

These methods release resources used by the annotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InkData and optionally releases the managed resources (Overrides AnnotationDataDispose(Boolean).)
Top
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Dispose Method (Boolean)

InkDataDispose Method (Boolean)

Releases the unmanaged resources used by the InkData and optionally releases the managed resources

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

InkData Class
Dispose Overload
Atalasoft.Annotate.Ink Namespace


InkData.Equals Method

InkDataEquals Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Finalize Method

InkDataFinalize Method

InkData destructor

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.GetHashCode Method

InkDataGetHashCode Method

Get hash code for this object

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this object
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.GetObjectData Method

InkDataGetObjectData Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Mirror Method

InkDataMirror Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Mirror(
    MirrorDirection direction,
    bool maintainPosition
)
Public Overrides Sub Mirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
maintainPosition
Type: SystemBoolean
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.OnLocationChanged Method

InkDataOnLocationChanged Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLocationChanged(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnLocationChanged (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.OnPropertyChanging Method

InkDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.OnRotationChanged Method

InkDataOnRotationChanged Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRotationChanged(
    EventArgs e
)
Protected Overrides Sub OnRotationChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData.Rotate Method

InkDataRotate Method

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Rotate(
    float degrees
)
Public Overrides Sub Rotate (
    degrees As Single
)

Parameters

degrees
Type: SystemSingle
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkData Events

The InkData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

InkData Class
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes Class

Note: This API is now obsolete.

This class is used to define the pen properties used when drawing ink.
Inheritance Hierarchy
SystemObject
DrawingAttributes
Atalasoft.Annotate.InkInkDrawingAttributes

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute("This component is no longer available in DotImage.",
    true)]
public class InkDrawingAttributes : DrawingAttributes,
    ISerializable
<SerializableAttribute>
<ObsoleteAttribute("This component is no longer available in DotImage.",
    true)>
Public Class InkDrawingAttributes
    Inherits DrawingAttributes
    Implements ISerializable

The InkDrawingAttributes type exposes the following members.

Constructors
 | Name | Description
Public method | InkDrawingAttributes | Creates a new instance of InkDrawingAttributes.
Public method | InkDrawingAttributes(SerializationInfo, StreamingContext) | Creates a new instance of InkDrawingAttributes from serialized data.
Top
Properties
 | Name | Description
Public property | AntiAliased | (Inherited from DrawingAttributes.)
Public property | Color | (Inherited from DrawingAttributes.)
Public property | ExtendedProperties | (Inherited from DrawingAttributes.)
Public property | FitToCurve | (Inherited from DrawingAttributes.)
Public property | Height | (Inherited from DrawingAttributes.)
Public property | IgnorePressure | (Inherited from DrawingAttributes.)
Public property | PenTip | (Inherited from DrawingAttributes.)
Public property | RasterOperation | (Inherited from DrawingAttributes.)
Public property | Transparency | (Inherited from DrawingAttributes.)
Public property | Width | (Inherited from DrawingAttributes.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from DrawingAttributes.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromDrawingAttributes | Returns an InkDrawingAttributes object from a Microsoft.Ink.DrawingAttributes instance.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this class.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes Constructor

Overload List
 | Name | Description
Public method | InkDrawingAttributes | Creates a new instance of InkDrawingAttributes.
Public method | InkDrawingAttributes(SerializationInfo, StreamingContext) | Creates a new instance of InkDrawingAttributes from serialized data.
Top
See Also

Reference

InkDrawingAttributes Class
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes Constructor

Creates a new instance of InkDrawingAttributes.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkDrawingAttributes()
Public Sub New
See Also

Reference

InkDrawingAttributes Class
InkDrawingAttributes Overload
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes Constructor (SerializationInfo, StreamingContext)

Creates a new instance of InkDrawingAttributes from serialized data.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkDrawingAttributes(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the ink drawing data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

InkDrawingAttributes Class
InkDrawingAttributes Overload
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes Properties

The InkDrawingAttributes type exposes the following members.

Properties
 | Name | Description
Public property | AntiAliased | (Inherited from DrawingAttributes.)
Public property | Color | (Inherited from DrawingAttributes.)
Public property | ExtendedProperties | (Inherited from DrawingAttributes.)
Public property | FitToCurve | (Inherited from DrawingAttributes.)
Public property | Height | (Inherited from DrawingAttributes.)
Public property | IgnorePressure | (Inherited from DrawingAttributes.)
Public property | PenTip | (Inherited from DrawingAttributes.)
Public property | RasterOperation | (Inherited from DrawingAttributes.)
Public property | Transparency | (Inherited from DrawingAttributes.)
Public property | Width | (Inherited from DrawingAttributes.)
Top
See Also

Reference

InkDrawingAttributes Class
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes Methods

The InkDrawingAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from DrawingAttributes.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromDrawingAttributes | Returns an InkDrawingAttributes object from a Microsoft.Ink.DrawingAttributes instance.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this class.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InkDrawingAttributes Class
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes.FromDrawingAttributes Method

InkDrawingAttributesFromDrawingAttributes Method

Returns an InkDrawingAttributes object from a Microsoft.Ink.DrawingAttributes instance.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static InkDrawingAttributes FromDrawingAttributes(
    DrawingAttributes attributes
)
Public Shared Function FromDrawingAttributes (
    attributes As DrawingAttributes
) As InkDrawingAttributes

Parameters

attributes
Type: DrawingAttributes
A Microsoft.Ink.DrawingAttributes object from which the InkDrawingAttributes will be created.

Return Value

Type: InkDrawingAttributes
An InkDrawingAttributes containing the same settings as the attributes parameter.
See Also

Reference

InkDrawingAttributes Class
Atalasoft.Annotate.Ink Namespace


InkDrawingAttributes.GetObjectData Method

InkDrawingAttributesGetObjectData Method

Fills a SerializationInfo object with information about this class.

Namespace: Atalasoft.Annotate.Ink
Assembly: Atalasoft.DotAnnotate.Ink (in Atalasoft.DotAnnotate.Ink.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

InkDrawingAttributes Class
Atalasoft.Annotate.Ink Namespace


Atalasoft.Annotate.Pdf Namespace

This namespace contains PDF specific annotation classes.
Classes
 | Class | Description
Public class | PdfAnnotation | This is the base PDF annotation class all PDF annotations derive from. This class should not be created directly.
Public class | PdfAnnotationData | This is the base PDF annotation data class from which all PDF annotation data objects derive. This class should not be created directly.
Public class | PdfLineAnnotation | This class represents a PDF line annotation. While similar to a standard line annotation, the PDF version includes a caption which is centered within or above the line (if the text is too long to fit within).
Public class | PdfLineData | This class hold the data used by a PdfLineAnnotation.
Public class | PdfLineRenderingEngine | This class is used to render PdfLineData objects.
Public class | PdfLinkData | Implements PDF Link annotation data.
Public class | PdfMarkupAnnotation | This class represents a PDF markup annotation, such as underline, squiggly, strikeout and highlight.
Public class | PdfMarkupData | This class contains the data used by PdfMarkupAnnotation objects.
Public class | PdfMarkupRenderingEngine | This class is used to render PdfMarkupData objects.
Enumerations
 | Enumeration | Description
Public enumeration | PdfMarkupType | Specifies the type of markup annotation.


PdfAnnotation Class

This is the base PDF annotation class all PDF annotations derive from. This class should not be created directly.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.PdfPdfAnnotation
Atalasoft.Annotate.PdfPdfLineAnnotation
Atalasoft.Annotate.PdfPdfMarkupAnnotation

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAnnotation : AnnotationUI,
    IDisposable
<SerializableAttribute>
Public Class PdfAnnotation
    Inherits AnnotationUI
    Implements IDisposable

The PdfAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotation | Creates a new instance of PdfAnnotation with default parameters.
Public method | PdfAnnotation(PdfAnnotationData) | Creates a new instance of PdfAnnotation specifying the PdfAnnotationData class.
Public method | PdfAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PdfAnnotation from serialized information.
Public method | PdfAnnotation(AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfAnnotation specifying all of its parameters.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | PopupEventHandler | An event handler used when the annotation is double-clicked and a popup window needs to be shown.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Returns a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called when the annotation is being disposed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | PdfAnnotation class destructor. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Overrides AnnotationUIOnDoubleClick(EventArgs).)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Constructor

Creates a new instance of PdfAnnotation.
Overload List
 | Name | Description
Public method | PdfAnnotation | Creates a new instance of PdfAnnotation with default parameters.
Public method | PdfAnnotation(PdfAnnotationData) | Creates a new instance of PdfAnnotation specifying the PdfAnnotationData class.
Public method | PdfAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PdfAnnotation from serialized information.
Public method | PdfAnnotation(AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfAnnotation specifying all of its parameters.
Top
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Constructor

Creates a new instance of PdfAnnotation with default parameters.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotation()
Public Sub New
See Also

Reference

PdfAnnotation Class
PdfAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Constructor (PdfAnnotationData)

Creates a new instance of PdfAnnotation specifying the PdfAnnotationData class.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotation(
    PdfAnnotationData data
)
Public Sub New (
    data As PdfAnnotationData
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfAnnotationData
The PdfAnnotationData class used by this annotation.
See Also

Reference

PdfAnnotation Class
PdfAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PdfAnnotation from serialized information.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the serialized annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

PdfAnnotation Class
PdfAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Constructor (AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of PdfAnnotation specifying all of its parameters.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for filling the annotation or line cap.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
text
Type: SystemString
The text of the annotation.
username
Type: SystemString
The username of the person modifying it. If null (Nothing in VB) the current user will be retrieved from the system.
modifiedDate
Type: SystemDateTime
The date when the annotation was last modified.
See Also

Reference

PdfAnnotation Class
PdfAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Properties

The PdfAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | PopupEventHandler | An event handler used when the annotation is double-clicked and a popup window needs to be shown.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Fill Property

PdfAnnotationFill Property

Gets or sets the brush used to fill the annotation or line cap.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Outline Property

PdfAnnotationOutline Property

Gets or sets the pen used to draw the outline of the annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the outline.
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.PopupEventHandler Property

PdfAnnotationPopupEventHandler Property

An event handler used when the annotation is double-clicked and a popup window needs to be shown.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EventHandler PopupEventHandler { get; set; }
Public Property PopupEventHandler As EventHandler
    Get
    Set

Property Value

Type: EventHandler
The event handler used when the popup window of the annotation needs to be shown.
Remarks
DotImage provides a simple default popup window for PDF annotations. Setting this property allows you to override this behavior to display your own custom dialog. To disable the dialog, set this property to null (Nothing in VB).
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Text Property

PdfAnnotationText Property

Gets or sets the text for the annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text for the annotation.
Remarks
This text is displayed in tooltips and as the PdfLineAnnotation's caption. The default popup dialog does not update this value until the dialog has been closed.
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Methods

The PdfAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Returns a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called when the annotation is being disposed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | PdfAnnotation class destructor. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Overrides AnnotationUIOnDoubleClick(EventArgs).)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Clone Method

PdfAnnotationClone Method

Returns a copy of this annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this annotation.
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Dispose Method

PdfAnnotationDispose Method

Releases resources used by the annotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called when the annotation is being disposed.
Top
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Dispose Method

PdfAnnotationDispose Method

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfAnnotation Class
Dispose Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Dispose Method (Boolean)

PdfAnnotationDispose Method (Boolean)

Called when the annotation is being disposed.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True if this was called from the public Dispose method.
See Also

Reference

PdfAnnotation Class
Dispose Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.Finalize Method

PdfAnnotationFinalize Method

PdfAnnotation class destructor.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation.OnDoubleClick Method

PdfAnnotationOnDoubleClick Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDoubleClick(
    EventArgs e
)
Protected Overrides Sub OnDoubleClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotation Events

The PdfAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Class

This is the base PDF annotation data class from which all PDF annotation data objects derive. This class should not be created directly.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.Annotate.PdfPdfAnnotationData
Atalasoft.Annotate.PdfPdfLineData
Atalasoft.Annotate.PdfPdfLinkData
Atalasoft.Annotate.PdfPdfMarkupData

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAnnotationData : AnnotationData
<SerializableAttribute>
Public Class PdfAnnotationData
    Inherits AnnotationData

The PdfAnnotationData type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationData | Creates a new instance of PdfAnnotationData with default settings.
Public method | PdfAnnotationData(SerializationInfo, StreamingContext) | Creates a new instance of PdfAnnotationData from serialized information.
Public method | PdfAnnotationData(AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfAnnotationData specifying all of its settings.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | (Overrides AnnotationDataAnnotationBounds.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string.
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Constructor

Creates a new instance of PdfAnnotationData.
Overload List
 | Name | Description
Public method | PdfAnnotationData | Creates a new instance of PdfAnnotationData with default settings.
Public method | PdfAnnotationData(SerializationInfo, StreamingContext) | Creates a new instance of PdfAnnotationData from serialized information.
Public method | PdfAnnotationData(AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfAnnotationData specifying all of its settings.
Top
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Constructor

Creates a new instance of PdfAnnotationData with default settings.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationData()
Public Sub New
See Also

Reference

PdfAnnotationData Class
PdfAnnotationData Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PdfAnnotationData from serialized information.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the serialized annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

PdfAnnotationData Class
PdfAnnotationData Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Constructor (AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of PdfAnnotationData specifying all of its settings.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationData(
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for filling the annotation or line cap.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
text
Type: SystemString
The text of the annotation.
username
Type: SystemString
The username of the person modifying it. If null (Nothing in VB) the current user will be retrieved from the system.
modifiedDate
Type: SystemDateTime
The date when the annotation was last modified.
See Also

Reference

PdfAnnotationData Class
PdfAnnotationData Overload
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Properties

The PdfAnnotationData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | (Overrides AnnotationDataAnnotationBounds.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap.
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.AnnotationBounds Property

PdfAnnotationDataAnnotationBounds Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF AnnotationBounds { get; }
Public Overrides ReadOnly Property AnnotationBounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.Fill Property

PdfAnnotationDataFill Property

Gets or sets the brush used to fill the annotation or line cap.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.Outline Property

PdfAnnotationDataOutline Property

Gets or sets the pen used to draw the outline of the annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the outline.
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.Text Property

PdfAnnotationDataText Property

Gets or sets the text for the annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text for the annotation.
Remarks
This text is displayed in tooltips and as the PdfLineAnnotation's caption. The default popup dialog does not update this value until the dialog has been closed.
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Methods

The PdfAnnotationData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides AnnotationDataClone.)
Protected method | CloneBaseData | (Overrides AnnotationDataCloneBaseData(AnnotationData).)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string.
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides AnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Overrides AnnotationDataOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.Clone Method

PdfAnnotationDataClone Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.CloneBaseData Method

PdfAnnotationDataCloneBaseData Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CloneBaseData(
    AnnotationData data
)
Protected Overrides Sub CloneBaseData (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.FormatToolTipText Method

PdfAnnotationDataFormatToolTipText Method

This method is called to return the tooltip text string.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string FormatToolTipText()
Protected Overridable Function FormatToolTipText As String

Return Value

Type: String
The string used in a tooltip.
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.GetObjectData Method

PdfAnnotationDataGetObjectData Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData.OnPropertyChanging Method

PdfAnnotationDataOnPropertyChanging Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfAnnotationData Events

The PdfAnnotationData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfAnnotationData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Class

This class represents a PDF line annotation. While similar to a standard line annotation, the PDF version includes a caption which is centered within or above the line (if the text is too long to fit within).
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.PdfPdfAnnotation
Atalasoft.Annotate.PdfPdfLineAnnotation

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfLineAnnotation : PdfAnnotation
Public Class PdfLineAnnotation
    Inherits PdfAnnotation

The PdfLineAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLineAnnotation | Creates a new instance of PdfLineAnnotation with default values.
Public method | PdfLineAnnotation(PdfLineData) | Creates a new instance of PdfLineAnnotation from a PdfLineData object.
Public method | PdfLineAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PdfLineAnnotation from serialized information.
Public method | PdfLineAnnotation(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen) | Creates a new instance of PdfLineAnnotation specifying the points, fill, outline and whether or not to display its caption.
Public method | PdfLineAnnotation(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime) | Create a new instance of PdfLineData specifying its parameters.
Top
Properties
 | Name | Description
Public property | Bounds | (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | DisplayCaption |
Public property | EndPoint |
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotation.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | PopupEventHandler | An event handler used when the annotation is double-clicked and a popup window needs to be shown. (Inherited from PdfAnnotation.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | StartPoint |
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotation.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | (Overrides AnnotationUIBeginCreate.)
Public method | Clone | (Overrides PdfAnnotationClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from PdfAnnotation.)
Protected method | Dispose(Boolean) | Called when the annotation is being disposed. (Inherited from PdfAnnotation.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | PdfAnnotation class destructor. (Inherited from PdfAnnotation.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Inherited from PdfAnnotation.)
Protected method | OnGripPositionChanged | (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | (Overrides AnnotationUIOnSizeChanged(AnnotationSizeChangedEventArgs).)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Constructor

Creates a new instance of PdfLineAnnotation.
Overload List
 | Name | Description
Public method | PdfLineAnnotation | Creates a new instance of PdfLineAnnotation with default values.
Public method | PdfLineAnnotation(PdfLineData) | Creates a new instance of PdfLineAnnotation from a PdfLineData object.
Public method | PdfLineAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PdfLineAnnotation from serialized information.
Public method | PdfLineAnnotation(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen) | Creates a new instance of PdfLineAnnotation specifying the points, fill, outline and whether or not to display its caption.
Public method | PdfLineAnnotation(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime) | Create a new instance of PdfLineData specifying its parameters.
Top
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Constructor

Creates a new instance of PdfLineAnnotation with default values.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineAnnotation()
Public Sub New
See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Constructor (PdfLineData)

Creates a new instance of PdfLineAnnotation from a PdfLineData object.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineAnnotation(
    PdfLineData data
)
Public Sub New (
    data As PdfLineData
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfLineData
The data object for the annotation.
See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PdfLineAnnotation from serialized information.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Constructor (PointF, PointF, Boolean, AnnotationBrush, AnnotationPen)

Creates a new instance of PdfLineAnnotation specifying the points, fill, outline and whether or not to display its caption.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineAnnotation(
    PointF startPoint,
    PointF endPoint,
    bool displayCaption,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF,
    displayCaption As Boolean,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

startPoint
Type: System.DrawingPointF
The start point of the line in annotation space.
endPoint
Type: System.DrawingPointF
The end point of the line in annotation space.
displayCaption
Type: SystemBoolean
A value indicating whether to display the line caption.
fill
Type: Atalasoft.AnnotateAnnotationBrush
A brush used for filling line caps.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the line.
See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Constructor (PointF, PointF, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime)

Create a new instance of PdfLineData specifying its parameters.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineAnnotation(
    PointF startPoint,
    PointF endPoint,
    bool displayCaption,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF,
    displayCaption As Boolean,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

startPoint
Type: System.DrawingPointF
The start point of the line in annotation space.
endPoint
Type: System.DrawingPointF
The end point of the line in annotation space.
displayCaption
Type: SystemBoolean
A value indicating whether to display the line caption.
fill
Type: Atalasoft.AnnotateAnnotationBrush
A brush used for filling line caps.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the line.
text
Type: SystemString
The text of the annotation.
username
Type: SystemString
The username of the person modifying the annotation.
modifiedDate
Type: SystemDateTime
The last modified date for the annotation.
See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Properties

The PdfLineAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | DisplayCaption |
Public property | EndPoint |
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotation.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | PopupEventHandler | An event handler used when the annotation is double-clicked and a popup window needs to be shown. (Inherited from PdfAnnotation.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | StartPoint |
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotation.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.Bounds Property

PdfLineAnnotationBounds Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.DisplayCaption Property

PdfLineAnnotationDisplayCaption Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayCaption { get; set; }
Public Property DisplayCaption As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.EndPoint Property

PdfLineAnnotationEndPoint Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF EndPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property EndPoint As PointF
    Get
    Set

Property Value

Type: PointF
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.StartPoint Property

PdfLineAnnotationStartPoint Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF StartPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property StartPoint As PointF
    Get
    Set

Property Value

Type: PointF
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Methods

The PdfLineAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | (Overrides AnnotationUIBeginCreate.)
Public method | Clone | (Overrides PdfAnnotationClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from PdfAnnotation.)
Protected method | Dispose(Boolean) | Called when the annotation is being disposed. (Inherited from PdfAnnotation.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | PdfAnnotation class destructor. (Inherited from PdfAnnotation.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Inherited from PdfAnnotation.)
Protected method | OnGripPositionChanged | (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | (Overrides AnnotationUIOnSizeChanged(AnnotationSizeChangedEventArgs).)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.BeginCreate Method

PdfLineAnnotationBeginCreate Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void BeginCreate()
Public Overrides Sub BeginCreate
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.Clone Method

PdfLineAnnotationClone Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.OnGripPositionChanged Method

PdfLineAnnotationOnGripPositionChanged Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    AnnotationGripChangedEventArgs e
)
Protected Overrides Sub OnGripPositionChanged (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.OnMouseDown Method

PdfLineAnnotationOnMouseDown Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.OnMouseMove Method

PdfLineAnnotationOnMouseMove Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.OnMouseUp Method

PdfLineAnnotationOnMouseUp Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs

Return Value

Type: Boolean
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation.OnSizeChanged Method

PdfLineAnnotationOnSizeChanged Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overrides Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineAnnotation Events

The PdfLineAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfLineAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData Class

This class hold the data used by a PdfLineAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.Annotate.PdfPdfAnnotationData
Atalasoft.Annotate.PdfPdfLineData

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfLineData : PdfAnnotationData
<SerializableAttribute>
Public Class PdfLineData
    Inherits PdfAnnotationData

The PdfLineData type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLineData | Creates a new instance of PdfLineData with default values.
Public method | PdfLineData(SerializationInfo, StreamingContext) | Creates a new instance of PdfLineData from serialized information.
Public method | PdfLineData(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen) | Creates a new instance of PdfLineData specifying the points, brush, pen and whether to display the line caption.
Public method | PdfLineData(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfLineData specifying its parameters.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | (Inherited from PdfAnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | DisplayCaption | Gets or sets a value indicating whether the caption is displayed.
Public property | EndPoint | Gets or sets the ending point for the line.
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | StartPoint | Gets or sets the starting point for the line.
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this LineData. (Overrides PdfAnnotationDataClone.)
Protected method | CloneBaseData | (Inherited from PdfAnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LineData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string. (Inherited from PdfAnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | (Overrides PdfAnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Inherited from PdfAnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ResizeToBounds | Resizes the annotation so its points are within the specified rectangle.
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfLineData Constructor

Creates a new instance of PdfLineData.
Overload List
 | Name | Description
Public method | PdfLineData | Creates a new instance of PdfLineData with default values.
Public method | PdfLineData(SerializationInfo, StreamingContext) | Creates a new instance of PdfLineData from serialized information.
Public method | PdfLineData(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen) | Creates a new instance of PdfLineData specifying the points, brush, pen and whether to display the line caption.
Public method | PdfLineData(PointF, PointF, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfLineData specifying its parameters.
Top
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData Constructor

Creates a new instance of PdfLineData with default values.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineData()
Public Sub New
See Also

Reference

PdfLineData Class
PdfLineData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PdfLineData from serialized information.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

PdfLineData Class
PdfLineData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineData Constructor (PointF, PointF, Boolean, AnnotationBrush, AnnotationPen)

Creates a new instance of PdfLineData specifying the points, brush, pen and whether to display the line caption.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineData(
    PointF startPoint,
    PointF endPoint,
    bool displayCaption,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF,
    displayCaption As Boolean,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

startPoint
Type: System.DrawingPointF
The start point of the line in annotation space.
endPoint
Type: System.DrawingPointF
The end point of the line in annotation space.
displayCaption
Type: SystemBoolean
A value indicating whether to display the line caption.
fill
Type: Atalasoft.AnnotateAnnotationBrush
A brush used for filling line caps.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the line.
See Also

Reference

PdfLineData Class
PdfLineData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineData Constructor (PointF, PointF, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of PdfLineData specifying its parameters.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineData(
    PointF startPoint,
    PointF endPoint,
    bool displayCaption,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF,
    displayCaption As Boolean,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

startPoint
Type: System.DrawingPointF
The start point of the line in annotation space.
endPoint
Type: System.DrawingPointF
The end point of the line in annotation space.
displayCaption
Type: SystemBoolean
A value indicating whether to display the line caption.
fill
Type: Atalasoft.AnnotateAnnotationBrush
A brush used for filling line caps.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the line.
text
Type: SystemString
The text of the annotation.
username
Type: SystemString
The username of the person modifying the annotation.
modifiedDate
Type: SystemDateTime
The last modified date for the annotation.
See Also

Reference

PdfLineData Class
PdfLineData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLineData Properties

The PdfLineData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | (Inherited from PdfAnnotationData.)
Public property | Bounds | (Overrides AnnotationDataBounds.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | DisplayCaption | Gets or sets a value indicating whether the caption is displayed.
Public property | EndPoint | Gets or sets the ending point for the line.
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotationData.)
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | StartPoint | Gets or sets the starting point for the line.
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.Bounds Property

PdfLineDataBounds Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.DisplayCaption Property

PdfLineDataDisplayCaption Property

Gets or sets a value indicating whether the caption is displayed.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayCaption { get; set; }
Public Property DisplayCaption As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the caption is displayed.
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.EndPoint Property

PdfLineDataEndPoint Property

Gets or sets the ending point for the line.
Gets or sets the end point of the line in annotation space.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF EndPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property EndPoint As PointF
    Get
    Set

Property Value

Type: PointF
The ending point for the line.

Property Value

Type: PointF
The end point of the line in annotation space.
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.StartPoint Property

PdfLineDataStartPoint Property

Gets or sets the starting point for the line.
Gets or sets the start point of the line in annotation space.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF StartPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property StartPoint As PointF
    Get
    Set

Property Value

Type: PointF
The starting point for the line.

Property Value

Type: PointF
The start point of the line in annotation space.
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData Methods

The PdfLineData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | Creates a copy of this LineData. (Overrides PdfAnnotationDataClone.)
Protected method | CloneBaseData | (Inherited from PdfAnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Determines if another LineData object has the same property settings. (Overrides AnnotationDataEquals(Object).)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string. (Inherited from PdfAnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | (Overrides AnnotationDataGetHashCode.)
Protected method | GetLineCapBounds | (Overrides AnnotationDataGetLineCapBounds.)
Public method | GetObjectData | (Overrides PdfAnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Inherited from PdfAnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | (Overrides AnnotationDataOnSizeChanged(AnnotationSizeChangedEventArgs).)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ResizeToBounds | Resizes the annotation so its points are within the specified rectangle.
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.Clone Method

PdfLineDataClone Method

Creates a copy of this LineData.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this object.

Implements

ICloneableClone
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.Equals Method

PdfLineDataEquals Method

Determines if another LineData object has the same property settings.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An LineData object to compare.

Return Value

Type: Boolean
True if the object provided has the same property values.
Remarks
Some unique properties are not compared, such as Name and ModifiedTime.
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.GetHashCode Method

PdfLineDataGetHashCode Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.GetLineCapBounds Method

PdfLineDataGetLineCapBounds Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override RectangleF GetLineCapBounds()
Protected Overrides Function GetLineCapBounds As RectangleF

Return Value

Type: RectangleF
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.GetObjectData Method

PdfLineDataGetObjectData Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.OnSizeChanged Method

PdfLineDataOnSizeChanged Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overrides Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData.ResizeToBounds Method

PdfLineDataResizeToBounds Method

Resizes the annotation so its points are within the specified rectangle.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ResizeToBounds(
    RectangleF bounds
)
Public Overridable Sub ResizeToBounds (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
The rectangle bounds to resize the annotation into.
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineData Events

The PdfLineData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfLineData Class
Atalasoft.Annotate.Pdf Namespace


PdfLineRenderingEngine Class

This class is used to render PdfLineData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.PdfPdfLineRenderingEngine

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfLineRenderingEngine : AnnotationRenderingEngine
Public Class PdfLineRenderingEngine
    Inherits AnnotationRenderingEngine

The PdfLineRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLineRenderingEngine | Creates a new instance of PdfLineRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfLineRenderingEngine Constructor

Creates a new instance of PdfLineRenderingEngine.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineRenderingEngine()
Public Sub New
See Also

Reference

PdfLineRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfLineRenderingEngine Properties

The PdfLineRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

PdfLineRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfLineRenderingEngine Methods

The PdfLineRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfLineRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfLineRenderingEngine.RenderAnnotation Method

PdfLineRenderingEngineRenderAnnotation Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
e
Type: Atalasoft.Annotate.RendererRenderEnvironment

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

PdfLineRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Class

Implements PDF Link annotation data.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.Annotate.PdfPdfAnnotationData
Atalasoft.Annotate.PdfPdfLinkData

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfLinkData : PdfAnnotationData
<SerializableAttribute>
Public Class PdfLinkData
    Inherits PdfAnnotationData

The PdfLinkData type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLinkData | Initializes a new instance of the PdfLinkData class.
Public method | PdfLinkData(QuadrilateralF) | Initializes a new instance of the PdfLinkData class.
Public method | PdfLinkData(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfLinkData class.
Public method | PdfLinkData(QuadrilateralF, AnnotationBrush, AnnotationPen, String, String, DateTime) | Initializes a new instance of the PdfLinkData class.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | (Inherited from PdfAnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | ClickAction | Gets the list of click delegates.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotationData.)
Public property | Quadrilaterals | Gets the rectangle where the annotation is created.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides PdfAnnotationDataClone.)
Protected method | CloneBaseData | (Inherited from PdfAnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string. (Inherited from PdfAnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides PdfAnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Inherited from PdfAnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfLinkData Constructor

Overload List
 | Name | Description
Public method | PdfLinkData | Initializes a new instance of the PdfLinkData class.
Public method | PdfLinkData(QuadrilateralF) | Initializes a new instance of the PdfLinkData class.
Public method | PdfLinkData(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfLinkData class.
Public method | PdfLinkData(QuadrilateralF, AnnotationBrush, AnnotationPen, String, String, DateTime) | Initializes a new instance of the PdfLinkData class.
Top
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Constructor

Initializes a new instance of the PdfLinkData class.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLinkData()
Public Sub New
See Also

Reference

PdfLinkData Class
PdfLinkData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Constructor (QuadrilateralF[])

PdfLinkData Constructor (QuadrilateralF)

Initializes a new instance of the PdfLinkData class.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLinkData(
    QuadrilateralF[] quads
)
Public Sub New (
    quads As QuadrilateralF()
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
Rectangle where the annotation is created.
See Also

Reference

PdfLinkData Class
PdfLinkData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfLinkData class.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLinkData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the serialized annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
See Also

Reference

PdfLinkData Class
PdfLinkData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Constructor (QuadrilateralF[], AnnotationBrush, AnnotationPen, String, String, DateTime)

PdfLinkData Constructor (QuadrilateralF, AnnotationBrush, AnnotationPen, String, String, DateTime)

Initializes a new instance of the PdfLinkData class.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLinkData(
    QuadrilateralF[] quads,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    quads As QuadrilateralF(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
Rectangle where the annotation is created.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for filling the annotation or line cap.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
text
Type: SystemString
The text of the annotation.
username
Type: SystemString
The username of the person modifying it. If null (Nothing in VB) the current user will be retrieved from the system.
modifiedDate
Type: SystemDateTime
The date when the annotation was last modified.
See Also

Reference

PdfLinkData Class
PdfLinkData Overload
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Properties

The PdfLinkData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | (Inherited from PdfAnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | ClickAction | Gets the list of click delegates.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotationData.)
Public property | Quadrilaterals | Gets the rectangle where the annotation is created.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData.ClickAction Property

PdfLinkDataClickAction Property

Gets the list of click delegates.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList ClickAction { get; }
Public ReadOnly Property ClickAction As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData.Quadrilaterals Property

PdfLinkDataQuadrilaterals Property

Gets the rectangle where the annotation is created.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralFCollection Quadrilaterals { get; }
Public ReadOnly Property Quadrilaterals As QuadrilateralFCollection
    Get

Property Value

Type: QuadrilateralFCollection
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Methods

The PdfLinkData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides PdfAnnotationDataClone.)
Protected method | CloneBaseData | (Inherited from PdfAnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string. (Inherited from PdfAnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides PdfAnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Inherited from PdfAnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData.Clone Method

PdfLinkDataClone Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData.GetObjectData Method

PdfLinkDataGetObjectData Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfLinkData Events

The PdfLinkData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfLinkData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Class

This class represents a PDF markup annotation, such as underline, squiggly, strikeout and highlight.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.PdfPdfAnnotation
Atalasoft.Annotate.PdfPdfMarkupAnnotation

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfMarkupAnnotation : PdfAnnotation
<SerializableAttribute>
Public Class PdfMarkupAnnotation
    Inherits PdfAnnotation

The PdfMarkupAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PdfMarkupAnnotation | Creates a new instance of PdfMarkupAnnotation with default values.
Public method | PdfMarkupAnnotation(PdfMarkupData) | Creates a new instance of PdfMarkupAnnotation from a PdfMarkupData object.
Public method | PdfMarkupAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PdfMarkupAnnotation from serialized information.
Public method | PdfMarkupAnnotation(QuadrilateralF, PdfMarkupType) | Creates a new instance of PdfMarkupAnnotation specifying an array of quadrilaterals and the markup type.
Public method | PdfMarkupAnnotation(QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfMarkupAnnotation specifying its parameters.
Top
Properties
 | Name | Description
Public property | Bounds | (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | MarkupType | Gets or sets the type of markup annotation.
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotation.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | PopupEventHandler | An event handler used when the annotation is double-clicked and a popup window needs to be shown. (Inherited from PdfAnnotation.)
Public property | Quadrilaterals | Gets the list of quadrilaterals.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | SquigglyHeight | Gets or sets the height of the squiggly line.
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotation.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | (Overrides AnnotationUIBeginCreate.)
Public method | Clone | (Overrides PdfAnnotationClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from PdfAnnotation.)
Protected method | Dispose(Boolean) | Called when the annotation is being disposed. (Inherited from PdfAnnotation.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | PdfAnnotation class destructor. (Inherited from PdfAnnotation.)
Public method | GetConfinedGripPosition | (Overrides AnnotationUIGetConfinedGripPosition(RectangleF, AnnotationGrip, PointF, Boolean).)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Inherited from PdfAnnotation.)
Protected method | OnGripPositionChanged | (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Constructor

Creates a new instance of PdfMarkupAnnotation.
Overload List
 | Name | Description
Public method | PdfMarkupAnnotation | Creates a new instance of PdfMarkupAnnotation with default values.
Public method | PdfMarkupAnnotation(PdfMarkupData) | Creates a new instance of PdfMarkupAnnotation from a PdfMarkupData object.
Public method | PdfMarkupAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PdfMarkupAnnotation from serialized information.
Public method | PdfMarkupAnnotation(QuadrilateralF, PdfMarkupType) | Creates a new instance of PdfMarkupAnnotation specifying an array of quadrilaterals and the markup type.
Public method | PdfMarkupAnnotation(QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfMarkupAnnotation specifying its parameters.
Top
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Constructor

Creates a new instance of PdfMarkupAnnotation with default values.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupAnnotation()
Public Sub New
See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Constructor (PdfMarkupData)

Creates a new instance of PdfMarkupAnnotation from a PdfMarkupData object.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupAnnotation(
    PdfMarkupData data
)
Public Sub New (
    data As PdfMarkupData
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The data class for this annotation.
See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PdfMarkupAnnotation from serialized information.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the annotation data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the data.
See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Constructor (QuadrilateralF[], PdfMarkupType)

PdfMarkupAnnotation Constructor (QuadrilateralF, PdfMarkupType)

Creates a new instance of PdfMarkupAnnotation specifying an array of quadrilaterals and the markup type.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupAnnotation(
    QuadrilateralF[] quads,
    PdfMarkupType markup
)
Public Sub New (
    quads As QuadrilateralF(),
    markup As PdfMarkupType
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
An array of quadrilaterals for the annotation.
markup
Type: Atalasoft.Annotate.PdfPdfMarkupType
The markup type of this annotation.
See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Constructor (QuadrilateralF[], PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime)

PdfMarkupAnnotation Constructor (QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of PdfMarkupAnnotation specifying its parameters.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupAnnotation(
    QuadrilateralF[] quads,
    PdfMarkupType markup,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    quads As QuadrilateralF(),
    markup As PdfMarkupType,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
An array of qualrilaterals for the annotation.
markup
Type: Atalasoft.Annotate.PdfPdfMarkupType
The markup type of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline of the annotation.
text
Type: SystemString
The text for the annotation.
username
Type: SystemString
The username of the person modifying the annotation.
modifiedDate
Type: SystemDateTime
The last modified date of the annotation.
See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Properties

The PdfMarkupAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | MarkupType | Gets or sets the type of markup annotation.
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotation.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | PopupEventHandler | An event handler used when the annotation is double-clicked and a popup window needs to be shown. (Inherited from PdfAnnotation.)
Public property | Quadrilaterals | Gets the list of quadrilaterals.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | SquigglyHeight | Gets or sets the height of the squiggly line.
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotation.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.Bounds Property

PdfMarkupAnnotationBounds Property

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.MarkupType Property

PdfMarkupAnnotationMarkupType Property

Gets or sets the type of markup annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupType MarkupType { get; set; }
Public Property MarkupType As PdfMarkupType
    Get
    Set

Property Value

Type: PdfMarkupType
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.Quadrilaterals Property

PdfMarkupAnnotationQuadrilaterals Property

Gets the list of quadrilaterals.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralFCollection Quadrilaterals { get; }
Public ReadOnly Property Quadrilaterals As QuadrilateralFCollection
    Get

Property Value

Type: QuadrilateralFCollection
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.SquigglyHeight Property

PdfMarkupAnnotationSquigglyHeight Property

Gets or sets the height of the squiggly line.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float SquigglyHeight { get; set; }
Public Property SquigglyHeight As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Methods

The PdfMarkupAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | (Overrides AnnotationUIBeginCreate.)
Public method | Clone | (Overrides PdfAnnotationClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from PdfAnnotation.)
Protected method | Dispose(Boolean) | Called when the annotation is being disposed. (Inherited from PdfAnnotation.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | PdfAnnotation class destructor. (Inherited from PdfAnnotation.)
Public method | GetConfinedGripPosition | (Overrides AnnotationUIGetConfinedGripPosition(RectangleF, AnnotationGrip, PointF, Boolean).)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Inherited from PdfAnnotation.)
Protected method | OnGripPositionChanged | (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.BeginCreate Method

PdfMarkupAnnotationBeginCreate Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void BeginCreate()
Public Overrides Sub BeginCreate
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.Clone Method

PdfMarkupAnnotationClone Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.GetConfinedGripPosition Method

PdfMarkupAnnotationGetConfinedGripPosition Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PointF GetConfinedGripPosition(
    RectangleF dsConfinedBounds,
    AnnotationGrip grip,
    PointF dsRequestedPosition,
    out bool ignoreMove
)
Public Overrides Function GetConfinedGripPosition (
    dsConfinedBounds As RectangleF,
    grip As AnnotationGrip,
    dsRequestedPosition As PointF,
    <OutAttribute> ByRef ignoreMove As Boolean
) As PointF

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
grip
Type: Atalasoft.Annotate.UIAnnotationGrip
dsRequestedPosition
Type: System.DrawingPointF
ignoreMove
Type: SystemBoolean

Return Value

Type: PointF
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.GetObjectData Method

PdfMarkupAnnotationGetObjectData Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.OnGripPositionChanged Method

PdfMarkupAnnotationOnGripPositionChanged Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    AnnotationGripChangedEventArgs e
)
Protected Overrides Sub OnGripPositionChanged (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.OnMouseDown Method

PdfMarkupAnnotationOnMouseDown Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.OnMouseMove Method

PdfMarkupAnnotationOnMouseMove Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.OnMouseUp Method

PdfMarkupAnnotationOnMouseUp Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs

Return Value

Type: Boolean
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.OnMoving Method

PdfMarkupAnnotationOnMoving Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation.OnResizing Method

PdfMarkupAnnotationOnResizing Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResizing(
    EventArgs e
)
Protected Overrides Sub OnResizing (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupAnnotation Events

The PdfMarkupAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

PdfMarkupAnnotation Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Class

This class contains the data used by PdfMarkupAnnotation objects.
Inheritance Hierarchy
SystemObject
Atalasoft.AnnotateAnnotationData
Atalasoft.Annotate.PdfPdfAnnotationData
Atalasoft.Annotate.PdfPdfMarkupData

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfMarkupData : PdfAnnotationData
<SerializableAttribute>
Public Class PdfMarkupData
    Inherits PdfAnnotationData

The PdfMarkupData type exposes the following members.

Constructors
 | Name | Description
Public method | PdfMarkupData | Initializes a new instance of the PdfMarkupData class.
Public method | PdfMarkupData(SerializationInfo, StreamingContext) | Creates a new instance of PdfMarkupData from serialized data.
Public method | PdfMarkupData(QuadrilateralF, PdfMarkupType) | Creates a new instance of PdfMarkupData specifying an array of quadrilaterals and the markup type.
Public method | PdfMarkupData(QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfMarkupData specifying the annotation parameters.
Top
Properties
 | Name | Description
Public property | AnnotationBounds | (Inherited from PdfAnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | MarkupType | Gets or sets the markup type for this annotation.
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotationData.)
Public property | Quadrilaterals | Gets the QuadrilateralFCollection holding quadrilaterals for this annotation. NOTE: According to Table 179 in ISO 32000-1, the QuadPoints array lists the vertices in counterclockwise order and the text orientation is defined by the first and second vertex. This basically means QuadPoints is specified as lower-left, lower-right, top-right, top-left. HOWEVER, Adobe's interpretation (tested at least with Acrobat 10, Acrobat 11, Reader 11) is top-left, top-right, lower-left, lower-right (Z-shaped order). This means that if the QuadPoints array is specified according to the standard, the rendering is not as expected. Other viewers seem to follow Adobe's interpretation. Hence we recommend to use and expect QuadPoints array in Z-order, just as Acrobat and probably most other viewers expect.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | SquigglyHeight | Gets or sets the height of the squiggly line.
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides PdfAnnotationDataClone.)
Protected method | CloneBaseData | (Inherited from PdfAnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string. (Inherited from PdfAnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides PdfAnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Inherited from PdfAnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Constructor

Overload List
 | Name | Description
Public method | PdfMarkupData | Initializes a new instance of the PdfMarkupData class.
Public method | PdfMarkupData(SerializationInfo, StreamingContext) | Creates a new instance of PdfMarkupData from serialized data.
Public method | PdfMarkupData(QuadrilateralF, PdfMarkupType) | Creates a new instance of PdfMarkupData specifying an array of quadrilaterals and the markup type.
Public method | PdfMarkupData(QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of PdfMarkupData specifying the annotation parameters.
Top
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Constructor

Initializes a new instance of the PdfMarkupData class.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupData()
Public Sub New
See Also

Reference

PdfMarkupData Class
PdfMarkupData Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PdfMarkupData from serialized data.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the annotation data.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the data.
See Also

Reference

PdfMarkupData Class
PdfMarkupData Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Constructor (QuadrilateralF[], PdfMarkupType)

PdfMarkupData Constructor (QuadrilateralF, PdfMarkupType)

Creates a new instance of PdfMarkupData specifying an array of quadrilaterals and the markup type.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupData(
    QuadrilateralF[] quads,
    PdfMarkupType markup
)
Public Sub New (
    quads As QuadrilateralF(),
    markup As PdfMarkupType
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
An array of quadrilaterals for the annotation. See more: Quadrilaterals.
markup
Type: Atalasoft.Annotate.PdfPdfMarkupType
The markup type of the annotation.
See Also

Reference

PdfMarkupData Class
PdfMarkupData Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Constructor (QuadrilateralF[], PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime)

PdfMarkupData Constructor (QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of PdfMarkupData specifying the annotation parameters.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupData(
    QuadrilateralF[] quads,
    PdfMarkupType markup,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    quads As QuadrilateralF(),
    markup As PdfMarkupType,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
An array of quadrilaterals for the annotation. See more: Quadrilaterals.
markup
Type: Atalasoft.Annotate.PdfPdfMarkupType
The markup type of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline of the annotation.
text
Type: SystemString
The text for the annotation.
username
Type: SystemString
The username of the person modifying the annotation.
modifiedDate
Type: SystemDateTime
The last modified date of the annotation.
See Also

Reference

PdfMarkupData Class
PdfMarkupData Overload
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Properties

The PdfMarkupData type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationBounds | (Inherited from PdfAnnotationData.)
Public property | Bounds | Gets the bounding rectangle of the annotation. (Inherited from AnnotationData.)
Public property | CanMirror | Gets or sets a value indicating if the annotation can mirror. (Inherited from AnnotationData.)
Public property | CanMove | Gets or sets a value indicating if the annotation can be moved. (Inherited from AnnotationData.)
Public property | CanResize | Gets or sets a value indicating if the annotation can be resized. (Inherited from AnnotationData.)
Public property | CanRotate | Gets or sets a value indicating if the annotation can be rotated. (Inherited from AnnotationData.)
Public property | CanSelect | Gets or sets a value indicating if the annotation can be selected. (Inherited from AnnotationData.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from AnnotationData.)
Public property | Fill | Gets or sets the brush used to fill the annotation or line cap. (Inherited from PdfAnnotationData.)
Public property | IgnoreDataChanges | Gets or sets a value indicating whether any properties changes should be passed to the undo manager. (Inherited from AnnotationData.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from AnnotationData.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from AnnotationData.)
Public property | Location | Gets or sets the location of this annotation. (Inherited from AnnotationData.)
Public property | MarkupType | Gets or sets the markup type for this annotation.
Public property | ModifiedTime | Gets or sets the time in which this annotation was modified. (Inherited from AnnotationData.)
Public property | Name | Gets or sets a name for this annotation. (Inherited from AnnotationData.)
Public property | Outline | Gets or sets the pen used to draw the outline of the annotation. (Inherited from PdfAnnotationData.)
Public property | Quadrilaterals | Gets the QuadrilateralFCollection holding quadrilaterals for this annotation. NOTE: According to Table 179 in ISO 32000-1, the QuadPoints array lists the vertices in counterclockwise order and the text orientation is defined by the first and second vertex. This basically means QuadPoints is specified as lower-left, lower-right, top-right, top-left. HOWEVER, Adobe's interpretation (tested at least with Acrobat 10, Acrobat 11, Reader 11) is top-left, top-right, lower-left, lower-right (Z-shaped order). This means that if the QuadPoints array is specified according to the standard, the rendering is not as expected. Other viewers seem to follow Adobe's interpretation. Hence we recommend to use and expect QuadPoints array in Z-order, just as Acrobat and probably most other viewers expect.
Public property | Rotation | Gets or sets the current amount of rotation for this annotation. (Inherited from AnnotationData.)
Public property | Security | Gets or sets the security lock used for this annotation. (Inherited from AnnotationData.)
Public property | Selected | Get or set whether this AnnotationData object is selected (Inherited from AnnotationData.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationData.)
Public property | SquigglyHeight | Gets or sets the height of the squiggly line.
Public property | State | Get or set the AnnotationState of this AnnotationData object (Inherited from AnnotationData.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from PdfAnnotationData.)
Public property | ToolTip | Gets or sets the text displayed in the annotation tooltip. (Inherited from AnnotationData.)
Public property | Transform | Gets the transformation matrix used for rendering this annotation. (Inherited from AnnotationData.)
Public property | UserName | Gets or sets the username for the annotation. Internally this is used with PDF annotations. (Inherited from AnnotationData.)
Public property | Visible | Gets or sets a value indicating if the annotation is visible. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData.MarkupType Property

PdfMarkupDataMarkupType Property

Gets or sets the markup type for this annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupType MarkupType { get; set; }
Public Property MarkupType As PdfMarkupType
    Get
    Set

Property Value

Type: PdfMarkupType
The markup type for this annotation.
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData.Quadrilaterals Property

PdfMarkupDataQuadrilaterals Property

Gets the QuadrilateralFCollection holding quadrilaterals for this annotation.

NOTE: According to Table 179 in ISO 32000-1, the QuadPoints array lists the vertices in counterclockwise order and the text orientation is defined by the first and second vertex. This basically means QuadPoints is specified as lower-left, lower-right, top-right, top-left. HOWEVER, Adobe's interpretation (tested at least with Acrobat 10, Acrobat 11, Reader 11) is top-left, top-right, lower-left, lower-right (Z-shaped order). This means that if the QuadPoints array is specified according to the standard, the rendering is not as expected. Other viewers seem to follow Adobe's interpretation. Hence we recommend to use and expect QuadPoints array in Z-order, just as Acrobat and probably most other viewers expect.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralFCollection Quadrilaterals { get; }
Public ReadOnly Property Quadrilaterals As QuadrilateralFCollection
    Get

Property Value

Type: QuadrilateralFCollection
A QuadrilateralFCollection containing quadrilaterals for the annotation.
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData.SquigglyHeight Property

PdfMarkupDataSquigglyHeight Property

Gets or sets the height of the squiggly line.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float SquigglyHeight { get; set; }
Public Property SquigglyHeight As Single
    Get
    Set

Property Value

Type: Single
The height of the squiggly line.
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Methods

The PdfMarkupData type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateAnnotationBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateAnnotationBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle without applying the annotation transforms. (Inherited from AnnotationData.)
Protected method | CalculateBounds(AnnotationPen, AnnotationBrush, PointF) | This method will calculate the bounding rectangle for the annotation, taking the pen width, shadow and annotation transforms into account. (Inherited from AnnotationData.)
Protected method | CalculateBounds(RectangleF, AnnotationPen, AnnotationBrush, PointF) | This method will add the annotation pen width, shadow and transforms to the provided rectangle bounds. (Inherited from AnnotationData.)
Public method | Clone | (Overrides PdfAnnotationDataClone.)
Protected method | CloneBaseData | (Inherited from PdfAnnotationData.)
Protected method | CloneBaseDataFrom | Clones the base data from. (Inherited from AnnotationData.)
Public method | Dispose | Releases resources used by the annotation. (Inherited from AnnotationData.)
Protected method | Dispose(Boolean) | Called to release resources used by the annotation. (Inherited from AnnotationData.)
Public method | Equals | Compares the current annotation with another. (Inherited from AnnotationData.)
Protected method | Finalize | Finalizes an instance of the AnnotationData class. (Inherited from AnnotationData.)
Protected method | FormatToolTipText | This method is called to return the tooltip text string. (Inherited from PdfAnnotationData.)
Public method | GetAllExtraProperties | Returns a Dictionary containing the key value pairs for extra properties. (Inherited from AnnotationData.)
Public method | GetExtraProperty | Returns the value stored with SetExtraProperty(String, String). (Inherited from AnnotationData.)
Public method | GetHashCode | Returns an identifier for this object. (Inherited from AnnotationData.)
Protected method | GetLineCapBounds | Called to get the rectangle bounds of the line cap used in an AnnotationLineCap. (Inherited from AnnotationData.)
Public method | GetObjectData | (Overrides PdfAnnotationDataGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetRenderTransform | Returns a System.Drawing.Drawing2D.Matrix containing the matrices applied to the annotation. (Inherited from AnnotationData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Flips (mirrors) the annotation horizontally or vertically. (Inherited from AnnotationData.)
Protected method | OnAnnotationControllerNotification | Called after a property value has been changed. (Inherited from AnnotationData.)
Protected method | OnCanMirrorChanged | Called when the CanMirror property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanMoveChanged | Called when the CanMove property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanResizeChanged | Called when the CanResize property has changed. (Inherited from AnnotationData.)
Protected method | OnCanRotateChanged | Called when the CanRotate property value has changed. (Inherited from AnnotationData.)
Protected method | OnCanSelectChanged | Called when the CanSelect property value has changed. (Inherited from AnnotationData.)
Protected method | OnCreationTimeChanged | Called when the CreationTime property value has changed. (Inherited from AnnotationData.)
Protected method | OnLocationChanged | Called when the Location property value has changed. (Inherited from AnnotationData.)
Protected method | OnMirrored | Called when the annotation has been mirrored. (Inherited from AnnotationData.)
Protected method | OnModifiedTimeChanged | Called when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Protected method | OnNameChanged | Called when the Name property has changed. (Inherited from AnnotationData.)
Protected method | OnPropertyChanged | Called when a property has been changed and raises the PropertyChanged event. (Inherited from AnnotationData.)
Protected method | OnPropertyChanging | (Inherited from PdfAnnotationData.)
Protected method | OnRotationChanged | Called when the Rotation property has changed. (Inherited from AnnotationData.)
Protected method | OnSecurityChanged | Called when the Security property has changed. (Inherited from AnnotationData.)
Protected method | OnSizeChanged | Called when the Size property has changed. (Inherited from AnnotationData.)
Protected method | OnStateChanged | Called when the State property has changed and raises the StateChanged event. (Inherited from AnnotationData.)
Protected method | OnTooltipChanged | Called when the ToolTip property has changed. (Inherited from AnnotationData.)
Protected method | OnTransformChanged | Called when the Transform property has changed. (Inherited from AnnotationData.)
Protected method | OnUserNameChanged | Called when the UserName property has changed and raises the UserNameChanged event. (Inherited from AnnotationData.)
Protected method | OnVisibleChanged | Called when the Visible property has changed. (Inherited from AnnotationData.)
Protected method | RemoveBrushEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationBrush. (Inherited from AnnotationData.)
Protected method | RemoveFontEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationFont. (Inherited from AnnotationData.)
Protected method | RemovePenEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an AnnotationPen. (Inherited from AnnotationData.)
Protected method | RemoveSecurityEvents | This is a helper method to remove the PropertyChanging and AnnotationControllerNotification event handlers for an IAnnotationLock. (Inherited from AnnotationData.)
Public method | Rotate | Applies rotation to the annotation from its current rotation amount. (Inherited from AnnotationData.)
Protected method | SetBrushEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationBrush. (Inherited from AnnotationData.)
Public method | SetExtraProperty | Sets a custom value within an annotation that can be retrieved using GetExtraProperty(String). (Inherited from AnnotationData.)
Protected method | SetFontEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationFont. (Inherited from AnnotationData.)
Protected method | SetPenEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an AnnotationPen. (Inherited from AnnotationData.)
Protected method | SetSecurityEvents | This is a helper method used to set event handlers for the PropertyChanging and AnnotationControllerNotification event handlers in an IAnnotationLock. (Inherited from AnnotationData.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData.Clone Method

PdfMarkupDataClone Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData.GetObjectData Method

PdfMarkupDataGetObjectData Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupData Events

The PdfMarkupData type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property has been changed. (Inherited from AnnotationData.)
Public event | CanMirrorChanged | Raised when the CanMirror property is changed. (Inherited from AnnotationData.)
Public event | CanMoveChanged | Raised when the CanMove property is changed. (Inherited from AnnotationData.)
Public event | CanResizeChanged | Raised when the CanResize property has changed. (Inherited from AnnotationData.)
Public event | CanRotateChanged | Raised when the CanRotate property has changed. (Inherited from AnnotationData.)
Public event | CanSelectChanged | Raised when the CanSelect property has changed. (Inherited from AnnotationData.)
Public event | CreationTimeChanged | Raised when the CreationTime property has changed. (Inherited from AnnotationData.)
Public event | LocationChanged | Raised when the Location property has changed. (Inherited from AnnotationData.)
Public event | Mirrored | Raised when the annotation is mirrored, either by the user dragging a grip across its opposite or when the Mirror method is called. (Inherited from AnnotationData.)
Public event | ModifiedTimeChanged | Raised when the ModifiedTime property has changed. (Inherited from AnnotationData.)
Public event | NameChanged | Raised when the Name property has changed. (Inherited from AnnotationData.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationData.)
Public event | PropertyChanging | Raised before a property is changed. (Inherited from AnnotationData.)
Public event | RotationChanged | Raised when the Rotation property has changed. (Inherited from AnnotationData.)
Public event | SecurityChanged | Raised when the Security property has changed. (Inherited from AnnotationData.)
Public event | SizeChanged | Raised when the Size property has changed. (Inherited from AnnotationData.)
Public event | StateChanged | This event is raised when the State property value has changed. (Inherited from AnnotationData.)
Public event | TooltipChanged | Raised when the ToolTip property has changed. (Inherited from AnnotationData.)
Public event | TransformChanged | Raised when the Transform property has changed. (Inherited from AnnotationData.)
Public event | UserNameChanged | This event is raised when the UserName property has changed. (Inherited from AnnotationData.)
Public event | VisibleChanged | Raised when the Visible property has changed. (Inherited from AnnotationData.)
Top
See Also

Reference

PdfMarkupData Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine Class

This class is used to render PdfMarkupData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.PdfPdfMarkupRenderingEngine

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfMarkupRenderingEngine : AnnotationRenderingEngine
Public Class PdfMarkupRenderingEngine
    Inherits AnnotationRenderingEngine

The PdfMarkupRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | PdfMarkupRenderingEngine | Creates a new instance of PdfMarkupRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Protected method | RenderButtons | This method is called to render the plus and minus buttons on the annotation.
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderHighlighter | Called to render a highlight annotation.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderSelectionRectangle | Called to render a selection rectangle when the annotation is being created.
Protected method | RenderSquiggly | Called to render a squiggly annotation.
Protected method | RenderStrikeOut | Called to render a strikeout annotation.
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderUnderline | Called to render an underline annotation.
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine Constructor

Creates a new instance of PdfMarkupRenderingEngine.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupRenderingEngine()
Public Sub New
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine Properties

The PdfMarkupRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine Methods

The PdfMarkupRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Protected method | RenderButtons | This method is called to render the plus and minus buttons on the annotation.
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderHighlighter | Called to render a highlight annotation.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderSelectionRectangle | Called to render a selection rectangle when the annotation is being created.
Protected method | RenderSquiggly | Called to render a squiggly annotation.
Protected method | RenderStrikeOut | Called to render a strikeout annotation.
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderUnderline | Called to render an underline annotation.
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderAnnotation Method

PdfMarkupRenderingEngineRenderAnnotation Method

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
e
Type: Atalasoft.Annotate.RendererRenderEnvironment

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderButtons Method

PdfMarkupRenderingEngineRenderButtons Method

This method is called to render the plus and minus buttons on the annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderButtons(
    QuadrilateralF quad,
    RenderEnvironment e
)
Protected Overridable Sub RenderButtons (
    quad As QuadrilateralF,
    e As RenderEnvironment
)

Parameters

quad
Type: Atalasoft.Utils.GeometryQuadrilateralF
The quadrilateral in the annotation for which buttons will be drawn.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment for this process.
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderHighlighter Method

PdfMarkupRenderingEngineRenderHighlighter Method

Called to render a highlight annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderHighlighter(
    PdfMarkupData data,
    RenderEnvironment e
)
Protected Overridable Sub RenderHighlighter (
    data As PdfMarkupData,
    e As RenderEnvironment
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The PdfMarkupData to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment for this process.
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderSelectionRectangle Method

PdfMarkupRenderingEngineRenderSelectionRectangle Method

Called to render a selection rectangle when the annotation is being created.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderSelectionRectangle(
    PdfMarkupData data,
    RenderEnvironment e
)
Protected Overridable Sub RenderSelectionRectangle (
    data As PdfMarkupData,
    e As RenderEnvironment
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The PdfMarkupData to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment for this process.
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderSquiggly Method

PdfMarkupRenderingEngineRenderSquiggly Method

Called to render a squiggly annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderSquiggly(
    PdfMarkupData data,
    RenderEnvironment e
)
Protected Overridable Sub RenderSquiggly (
    data As PdfMarkupData,
    e As RenderEnvironment
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The PdfMarkupData to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment for this process.
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderStrikeOut Method

PdfMarkupRenderingEngineRenderStrikeOut Method

Called to render a strikeout annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderStrikeOut(
    PdfMarkupData data,
    RenderEnvironment e
)
Protected Overridable Sub RenderStrikeOut (
    data As PdfMarkupData,
    e As RenderEnvironment
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The PdfMarkupData to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment for this process.
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupRenderingEngine.RenderUnderline Method

PdfMarkupRenderingEngineRenderUnderline Method

Called to render an underline annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderUnderline(
    PdfMarkupData data,
    RenderEnvironment e
)
Protected Overridable Sub RenderUnderline (
    data As PdfMarkupData,
    e As RenderEnvironment
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The PdfMarkupData to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment for this process.
See Also

Reference

PdfMarkupRenderingEngine Class
Atalasoft.Annotate.Pdf Namespace


PdfMarkupType Enumeration

Specifies the type of markup annotation.

Namespace: Atalasoft.Annotate.Pdf
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfMarkupType
Public Enumeration PdfMarkupType
Members
Member name | Description
Highlight | A highlighter annotation.
Squiggly | A squiggly underline annotation.
StrikeOut | A strikeout annotation.
Underline | An underline annotation.
See Also

Reference

Atalasoft.Annotate.Pdf Namespace


Atalasoft.Annotate.Renderer Namespace

Classes
 | Class | Description
Public class | AnnotationRenderers | This class holds all of the annotation renderers used for drawing the annotations. When a custom annotation is created, its IAnnotationRenderer should be added to this collection to allow the AnnotationController to render the object.
Public class | AnnotationRenderingEngine | This class is the fallback rendering engine used when a specific rendering engine for an annotation can't be found.
Public class | CalloutRenderingEngine | This class is used to render CalloutData objects.
Public class | EllipseRenderingEngine | This class is used for rendering EllipseData objects.
Public class | EmbeddedImageRenderingEngine | This class is used for rendering EmbeddedImageData objects.
Public class | FreehandRenderingEngine | This class is used for rendering FreehandData objects.
Public class | HotSpotFreehandRenderingEngine | This class is used for rendering HotSpotFreehandData objects.
Public class | HotSpotRenderingEngine | This class is used for rendering HotSpotData objects.
Public class | LayerRenderingEngine | This class is used to render LayerData objects.
Public class | LineRenderingEngine | This class is used for rendering LineData objects.
Public class | LinesRenderingEngine | This class is used for rendering LinesData objects.
Public class | OcrRegionRenderingEngine | This class is used for rendering OcrRegionData.
Public class | PolygonRenderingEngine | This class is used for rendering PolygonData objects.
Public class | RectangleRenderingEngine | This class is used for rendering RectangleData objects.
Public class | ReferencedImageRenderingEngine | This class is used for rendering ReferencedImageData objects.
Public class | RenderEnvironment | This class is passed into the IAnnotationRenderer methods to provide information for the rendering process.
Public class | RubberStampRenderingEngine | This class is used for rendering RubberStampData objects.
Public class | TextAnnotationRenderingEngine | This class is used for rendering TextData objects.
Interfaces
 | Interface | Description
Public interface | IAnnotationGripRenderer | This interface must be implemented by classes used to render annotation grips.
Public interface | IAnnotationRenderer | This interface must be implemented by classes that will be used to render annotations.


AnnotationRenderers Class

This class holds all of the annotation renderers used for drawing the annotations. When a custom annotation is created, its IAnnotationRenderer should be added to this collection to allow the AnnotationController to render the object.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderers

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class AnnotationRenderers
Public NotInheritable Class AnnotationRenderers

The AnnotationRenderers type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationRenderers | Initializes a new instance of the AnnotationRenderers class
Top
Methods
 | Name | Description
 | Add | Adds or replaces a rendering engine for the specified type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Get | Gets the rendering engine for a specific type.
 | GetAnnotationDataTypes | Returns a list of all AnnotationData types registered in the AnnotationRenderers table.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
To implement custom rendering of annotations, use the Add(Type, IAnnotationRenderer) method to replace the default renderer for an annotation.
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


AnnotationRenderers Constructor

Initializes a new instance of the AnnotationRenderers class

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRenderers()
Public Sub New
See Also

Reference

AnnotationRenderers Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderers Methods

The AnnotationRenderers type exposes the following members.

Methods
 | Name | Description
 | Add | Adds or replaces a rendering engine for the specified type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Get | Gets the rendering engine for a specific type.
 | GetAnnotationDataTypes | Returns a list of all AnnotationData types registered in the AnnotationRenderers table.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationRenderers Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderers.Add Method

AnnotationRenderersAdd Method

Adds or replaces a rendering engine for the specified type.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Add(
    Type type,
    IAnnotationRenderer renderer
)
Public Shared Sub Add (
    type As Type,
    renderer As IAnnotationRenderer
)

Parameters

type
Type: SystemType
The type of the annotation data this renderer will handle.
renderer
Type: Atalasoft.Annotate.RendererIAnnotationRenderer
A class that will act as the renderer for this type.
See Also

Reference

AnnotationRenderers Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderers.Get Method

AnnotationRenderersGet Method

Gets the rendering engine for a specific type.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IAnnotationRenderer Get(
    Type type
)
Public Shared Function Get (
    type As Type
) As IAnnotationRenderer

Parameters

type
Type: SystemType
The annotation data type to look up.

Return Value

Type: IAnnotationRenderer
The renderer for this annotation data or a AnnotationRenderingEngine if a renderer is not found.
See Also

Reference

AnnotationRenderers Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderers.GetAnnotationDataTypes Method

AnnotationRenderersGetAnnotationDataTypes Method

Returns a list of all AnnotationData types registered in the AnnotationRenderers table.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Type[] GetAnnotationDataTypes()
Public Shared Function GetAnnotationDataTypes As Type()

Return Value

Type: Type
An array of Type for the AnnotationData renderers that are currently registered.
See Also

Reference

AnnotationRenderers Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine Class

This class is the fallback rendering engine used when a specific rendering engine for an annotation can't be found.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
More...

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationRenderingEngine : IAnnotationRenderer,
    IAnnotationGripRenderer
Public Class AnnotationRenderingEngine
    Implements IAnnotationRenderer, IAnnotationGripRenderer

The AnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationRenderingEngine | Creates a new instance of AnnotationRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips.
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image.
 | CorrectRectangle | Corrects negative width and height values for the rectangle.
 | CreateBrush | Converts an AnnotationBrush into a System.Drawing.Brush object.
 | CreateFont | Converts an AnnotationFont into a System.Drawing.Font object.
 | CreatePen | Converts an AnnotationPen into a System.Drawing.Pen object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush).
Public method | RenderAnnotation | Called to render an annotation.
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations.
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill.
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point.
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked.
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation.
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points.
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment).
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
RenderLock | The render lock
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.InkInkAnnotationRenderingEngine
Atalasoft.Annotate.PdfPdfLineRenderingEngine
Atalasoft.Annotate.PdfPdfMarkupRenderingEngine
Atalasoft.Annotate.RendererCalloutRenderingEngine
Atalasoft.Annotate.RendererEllipseRenderingEngine
Atalasoft.Annotate.RendererEmbeddedImageRenderingEngine
Atalasoft.Annotate.RendererFreehandRenderingEngine
Atalasoft.Annotate.RendererHotSpotFreehandRenderingEngine
Atalasoft.Annotate.RendererHotSpotRenderingEngine
Atalasoft.Annotate.RendererLayerRenderingEngine
Atalasoft.Annotate.RendererLineRenderingEngine
Atalasoft.Annotate.RendererLinesRenderingEngine
Atalasoft.Annotate.RendererOcrRegionRenderingEngine
Atalasoft.Annotate.RendererPolygonRenderingEngine
Atalasoft.Annotate.RendererRectangleRenderingEngine
Atalasoft.Annotate.RendererReferencedImageRenderingEngine
Atalasoft.Annotate.RendererRubberStampRenderingEngine
Atalasoft.Annotate.RendererTextAnnotationRenderingEngine


AnnotationRenderingEngine Constructor

Creates a new instance of AnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRenderingEngine()
Public Sub New
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine Properties

The AnnotationRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips.
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.GripRenderer Property

AnnotationRenderingEngineGripRenderer Property

Gets the IAnnotationGripRenderer used to render grips.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationGripRenderer GripRenderer { get; set; }
Public Property GripRenderer As IAnnotationGripRenderer
    Get
    Set

Property Value

Type: IAnnotationGripRenderer
The annotation grip renderer.

Implements

IAnnotationRendererGripRenderer
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine Methods

The AnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image.
 | CorrectRectangle | Corrects negative width and height values for the rectangle.
 | CreateBrush | Converts an AnnotationBrush into a System.Drawing.Brush object.
 | CreateFont | Converts an AnnotationFont into a System.Drawing.Font object.
 | CreatePen | Converts an AnnotationPen into a System.Drawing.Pen object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush).
Public method | RenderAnnotation | Called to render an annotation.
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations.
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill.
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point.
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked.
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation.
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points.
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment).
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.BurnTranslucentAnnotation Method

AnnotationRenderingEngineBurnTranslucentAnnotation Method

This method is used to burn translucent (highlighter) annotations onto an image.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void BurnTranslucentAnnotation(
    RenderEnvironment environment,
    RectangleF bounds,
    Color color,
    AnnotationImage mask
)
Protected Overridable Sub BurnTranslucentAnnotation (
    environment As RenderEnvironment,
    bounds As RectangleF,
    color As Color,
    mask As AnnotationImage
)

Parameters

environment
Type: Atalasoft.Annotate.RendererRenderEnvironment
The RenderEnvironment containing the image to burn onto.
bounds
Type: System.DrawingRectangleF
The bounding rectangle where the annotation will be placed.
color
Type: System.DrawingColor
The color of the highlighter.
mask
Type: Atalasoft.AnnotateAnnotationImage
A mask image used to apply the highlight effect.
Exceptions
Exception | Condition
 | Thrown if the Image or ImageObject property of the RenderEnvironment is null (Nothing in VB).
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.CorrectRectangle Method

AnnotationRenderingEngineCorrectRectangle Method

Corrects negative width and height values for the rectangle.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static RectangleF CorrectRectangle(
    RectangleF rect
)
Protected Shared Function CorrectRectangle (
    rect As RectangleF
) As RectangleF

Parameters

rect
Type: System.DrawingRectangleF
The rectangle to correct.

Return Value

Type: RectangleF
A new RectangleF with corrected values.
Remarks
If the width or height is equal to zero, it will be converted to 1 so a line is drawn instead of nothing.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.CreateBrush Method

AnnotationRenderingEngineCreateBrush Method

Converts an AnnotationBrush into a System.Drawing.Brush object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Brush CreateBrush(
    AnnotationBrush annBrush
)
Public Shared Function CreateBrush (
    annBrush As AnnotationBrush
) As Brush

Parameters

annBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush to convert.

Return Value

Type: Brush
A System.Drawing.Brush
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.CreateFont Method

AnnotationRenderingEngineCreateFont Method

Converts an AnnotationFont into a System.Drawing.Font object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Font CreateFont(
    AnnotationFont annFont,
    RenderEnvironment e
)
Public Shared Function CreateFont (
    annFont As AnnotationFont,
    e As RenderEnvironment
) As Font

Parameters

annFont
Type: Atalasoft.AnnotateAnnotationFont
The AnnotationFont to convert.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment that will be used with this Font.

Return Value

Type: Font
A System.Drawing.Font.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.CreatePen Method

AnnotationRenderingEngineCreatePen Method

Converts an AnnotationPen into a System.Drawing.Pen object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Pen CreatePen(
    AnnotationPen annPen
)
Public Shared Function CreatePen (
    annPen As AnnotationPen
) As Pen

Parameters

annPen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen to convert.

Return Value

Type: Pen
A System.Drawing.Pen.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.GetTranslucentHandle Method

AnnotationRenderingEngineGetTranslucentHandle Method

Returns a GDI HDC used for rendering the translucent effect.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IntPtr GetTranslucentHandle(
    RenderEnvironment e,
    RectangleF annotationBounds,
    AnnotationPen pen,
    AnnotationBrush fill
)
Protected Function GetTranslucentHandle (
    e As RenderEnvironment,
    annotationBounds As RectangleF,
    pen As AnnotationPen,
    fill As AnnotationBrush
) As IntPtr

Parameters

e
Type: Atalasoft.Annotate.RendererRenderEnvironment
The RenderEnvironment used.
annotationBounds
Type: System.DrawingRectangleF
A bounding rectangle for the annotation.
pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used for drawing lines.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for filling objects.

Return Value

Type: IntPtr
An HDC that can be used for rendering the translucent area.
Remarks
The HDC returned from this function must be released using the ReleaseTranslucentHandle(RenderEnvironment) method.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace
ReleaseTranslucentHandle Method


AnnotationRenderingEngine.ReleaseTranslucentHandle Method

AnnotationRenderingEngineReleaseTranslucentHandle Method

Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush).

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ReleaseTranslucentHandle(
    RenderEnvironment e
)
Protected Sub ReleaseTranslucentHandle (
    e As RenderEnvironment
)

Parameters

e
Type: Atalasoft.Annotate.RendererRenderEnvironment
The RenderEnvironment used.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace
AnnotationRenderingEngineGetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush)


AnnotationRenderingEngine.RenderAnnotation Method

AnnotationRenderingEngineRenderAnnotation Method

Called to render an annotation.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overridable Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
Remarks
This class will simply render a rectangle with the name of the annotation. For custom annotations a new class implementing IAnnotationRenderer or derived from another renderer must be created.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderGrips Method

AnnotationRenderingEngineRenderGrips Method

Overload List
 | Name | Description
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations.
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering.
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderGrips Method (IAnnotationGrips, AnnotationData, RenderEnvironment)

AnnotationRenderingEngineRenderGrips Method (IAnnotationGrips, AnnotationData, RenderEnvironment)

This method renders the grips for annotations.
Called to render annotation grips.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void RenderGrips(
    IAnnotationGrips grips,
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overridable Sub RenderGrips (
    grips As IAnnotationGrips,
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

grips
Type: Atalasoft.Annotate.UIIAnnotationGrips
The grips to render.
annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation associated with the grips.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationGripRendererRenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment)
Remarks
This overload handles matrix manipulation used when rendering the grips. When overriding this method these calculations must be handled. To render custom grips without dealing with matrix manipulation issues use the protected RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) overload instead.
See Also

Reference

AnnotationRenderingEngine Class
RenderGrips Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderGrips Method (IAnnotationGrips, AnnotationData, RenderEnvironment, PointF)

AnnotationRenderingEngineRenderGrips Method (IAnnotationGrips, AnnotationData, RenderEnvironment, PointF)

This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderGrips(
    IAnnotationGrips grips,
    AnnotationData annotation,
    RenderEnvironment e,
    PointF scale
)
Protected Overridable Sub RenderGrips (
    grips As IAnnotationGrips,
    annotation As AnnotationData,
    e As RenderEnvironment,
    scale As PointF
)

Parameters

grips
Type: Atalasoft.Annotate.UIIAnnotationGrips
The grips to render.
annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation associated with the grips.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.
scale
Type: System.DrawingPointF
The scaling that must be applied to the grip positions. Grip sizes should not scale, only their positions.
Remarks
Override this method to draw custom grips without having the deal with matrix manipulation.
See Also

Reference

AnnotationRenderingEngine Class
RenderGrips Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLineCap Method

AnnotationRenderingEngineRenderLineCap Method

Renders an AnnotationLineCap.
Overload List
 | Name | Description
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill.
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill.
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLineCap Method (PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment)

AnnotationRenderingEngineRenderLineCap Method (PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment)

Renders an AnnotationLineCap without a fill.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderLineCap(
    PointF startingPoint,
    PointF endingPoint,
    AnnotationLineCap lineCap,
    AnnotationPen pen,
    RenderEnvironment e
)
Protected Overridable Sub RenderLineCap (
    startingPoint As PointF,
    endingPoint As PointF,
    lineCap As AnnotationLineCap,
    pen As AnnotationPen,
    e As RenderEnvironment
)

Parameters

startingPoint
Type: System.DrawingPointF
The starting point of the line.
endingPoint
Type: System.DrawingPointF
The ending point of the line. The line cap will be rendered at this point.
lineCap
Type: Atalasoft.AnnotateAnnotationLineCap
The AnnotationLineCap to render.
pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen for this line cap.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
The RenderEnvironment used to render the line cap.
Remarks
The startingPoint and endingPoint arguments are used to determine the angle to apply when rendering.
See Also

Reference

AnnotationRenderingEngine Class
RenderLineCap Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLineCap Method (PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment)

AnnotationRenderingEngineRenderLineCap Method (PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment)

Renders an AnnotationLineCap with a fill.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderLineCap(
    PointF startingPoint,
    PointF endingPoint,
    AnnotationLineCap lineCap,
    AnnotationBrush fill,
    AnnotationPen pen,
    RenderEnvironment e
)
Protected Overridable Sub RenderLineCap (
    startingPoint As PointF,
    endingPoint As PointF,
    lineCap As AnnotationLineCap,
    fill As AnnotationBrush,
    pen As AnnotationPen,
    e As RenderEnvironment
)

Parameters

startingPoint
Type: System.DrawingPointF
The starting point of the line.
endingPoint
Type: System.DrawingPointF
The ending point of the line. The line cap will be rendered at this point.
lineCap
Type: Atalasoft.AnnotateAnnotationLineCap
The AnnotationLineCap to render.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the line cap.
pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen for this line cap.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
The RenderEnvironment used to render the line cap.
See Also

Reference

AnnotationRenderingEngine Class
RenderLineCap Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLockImage Method

AnnotationRenderingEngineRenderLockImage Method

Renders the lock image for locked annotations.
Overload List
 | Name | Description
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point.
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked.
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLockImage Method (AnnotationImage, PointF, RenderEnvironment)

AnnotationRenderingEngineRenderLockImage Method (AnnotationImage, PointF, RenderEnvironment)

Renders a small image at the specified point.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderLockImage(
    AnnotationImage image,
    PointF location,
    RenderEnvironment e
)
Protected Overridable Sub RenderLockImage (
    image As AnnotationImage,
    location As PointF,
    e As RenderEnvironment
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to render.
location
Type: System.DrawingPointF
The location where the image is placed.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.
See Also

Reference

AnnotationRenderingEngine Class
RenderLockImage Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLockImage Method (AnnotationImage, RectangleF, RenderEnvironment)

AnnotationRenderingEngineRenderLockImage Method (AnnotationImage, RectangleF, RenderEnvironment)

Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderLockImage(
    AnnotationImage image,
    RectangleF annotationBounds,
    RenderEnvironment e
)
Protected Overridable Sub RenderLockImage (
    image As AnnotationImage,
    annotationBounds As RectangleF,
    e As RenderEnvironment
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to render.
annotationBounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.
See Also

Reference

AnnotationRenderingEngine Class
RenderLockImage Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderTranslucentPointsAnnotation Method

AnnotationRenderingEngineRenderTranslucentPointsAnnotation Method

Renders a translucent point based annotation.
Overload List
 | Name | Description
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation.
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points.
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderTranslucentPointsAnnotation Method (PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean)

AnnotationRenderingEngineRenderTranslucentPointsAnnotation Method (PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean)

Renders a point based translucent annotation.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF RenderTranslucentPointsAnnotation(
    PointBaseData data,
    AnnotationPen outline,
    AnnotationBrush fill,
    RenderEnvironment e,
    bool closeFigure
)
Protected Function RenderTranslucentPointsAnnotation (
    data As PointBaseData,
    outline As AnnotationPen,
    fill As AnnotationBrush,
    e As RenderEnvironment,
    closeFigure As Boolean
) As PointF

Parameters

data
Type: Atalasoft.AnnotatePointBaseData
The annotation to render. This must derive from PointBaseData.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline pen used.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used when rendering.
closeFigure
Type: SystemBoolean
Indicates whether the points should form a closed figure.

Return Value

Type: PointF
See Also

Reference

AnnotationRenderingEngine Class
RenderTranslucentPointsAnnotation Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderTranslucentPointsAnnotation Method (PointF[], AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean)

AnnotationRenderingEngineRenderTranslucentPointsAnnotation Method (PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean)

Renders a translucent annotation from the specified points.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF RenderTranslucentPointsAnnotation(
    PointF[] points,
    AnnotationData data,
    AnnotationPen outline,
    AnnotationBrush fill,
    RenderEnvironment e,
    bool closeFigure
)
Protected Function RenderTranslucentPointsAnnotation (
    points As PointF(),
    data As AnnotationData,
    outline As AnnotationPen,
    fill As AnnotationBrush,
    e As RenderEnvironment,
    closeFigure As Boolean
) As PointF

Parameters

points
Type: System.DrawingPointF
An array of points for the annotation.
data
Type: Atalasoft.AnnotateAnnotationData
The annotation to render. This must derive from PointBaseData.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline pen used.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used when rendering.
closeFigure
Type: SystemBoolean
Indicates whether the points should form a closed figure.

Return Value

Type: PointF
Returns a point that can be used for the locked image.
See Also

Reference

AnnotationRenderingEngine Class
RenderTranslucentPointsAnnotation Overload
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RestoreGraphicsTransform Method

AnnotationRenderingEngineRestoreGraphicsTransform Method

Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment).

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RestoreGraphicsTransform(
    RenderEnvironment e
)
Protected Sub RestoreGraphicsTransform (
    e As RenderEnvironment
)

Parameters

e
Type: Atalasoft.Annotate.RendererRenderEnvironment
The Atalasoft.Annotate.Renderer used.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.SetGraphicsTransform Method

AnnotationRenderingEngineSetGraphicsTransform Method

Prepares the Graphics object to use the IAnnotate and AnnotationData transforms.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetGraphicsTransform(
    AnnotationData data,
    RenderEnvironment e
)
Protected Sub SetGraphicsTransform (
    data As AnnotationData,
    e As RenderEnvironment
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData that will be drawn.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
The Atalasoft.Annotate.Renderer that will be used.
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine Fields

The AnnotationRenderingEngine type exposes the following members.

Fields
Name | Description
RenderLock | The render lock
Top
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


AnnotationRenderingEngine.RenderLock Field

AnnotationRenderingEngineRenderLock Field

The render lock

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static readonly Object RenderLock
Protected Shared ReadOnly RenderLock As Object

Field Value

Type: Object
See Also

Reference

AnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


CalloutRenderingEngine Class

This class is used to render CalloutData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererCalloutRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CalloutRenderingEngine : AnnotationRenderingEngine
Public Class CalloutRenderingEngine
    Inherits AnnotationRenderingEngine

The CalloutRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | CalloutRenderingEngine | Creates a new instance of CalloutRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


CalloutRenderingEngine Constructor

Creates a new instance of CalloutRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutRenderingEngine()
Public Sub New
See Also

Reference

CalloutRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


CalloutRenderingEngine Properties

The CalloutRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

CalloutRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


CalloutRenderingEngine Methods

The CalloutRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalloutRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


CalloutRenderingEngine.RenderAnnotation Method

CalloutRenderingEngineRenderAnnotation Method

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
e
Type: Atalasoft.Annotate.RendererRenderEnvironment

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

CalloutRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EllipseRenderingEngine Class

This class is used for rendering EllipseData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererEllipseRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EllipseRenderingEngine : AnnotationRenderingEngine
Public Class EllipseRenderingEngine
    Inherits AnnotationRenderingEngine

The EllipseRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | EllipseRenderingEngine | Creates a new instance of EllipseRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders an EllipseData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


EllipseRenderingEngine Constructor

Creates a new instance of EllipseRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseRenderingEngine()
Public Sub New
See Also

Reference

EllipseRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EllipseRenderingEngine Properties

The EllipseRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

EllipseRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EllipseRenderingEngine Methods

The EllipseRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders an EllipseData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EllipseRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EllipseRenderingEngine.RenderAnnotation Method

EllipseRenderingEngineRenderAnnotation Method

Renders an EllipseData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

EllipseRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EmbeddedImageRenderingEngine Class

This class is used for rendering EmbeddedImageData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererEmbeddedImageRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EmbeddedImageRenderingEngine : AnnotationRenderingEngine
Public Class EmbeddedImageRenderingEngine
    Inherits AnnotationRenderingEngine

The EmbeddedImageRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedImageRenderingEngine | Creates a new instance of EmbeddedImageRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders an EmbeddedImageData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


EmbeddedImageRenderingEngine Constructor

Creates a new instance of EmbeddedImageRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageRenderingEngine()
Public Sub New
See Also

Reference

EmbeddedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EmbeddedImageRenderingEngine Properties

The EmbeddedImageRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

EmbeddedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EmbeddedImageRenderingEngine Methods

The EmbeddedImageRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders an EmbeddedImageData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmbeddedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


EmbeddedImageRenderingEngine.RenderAnnotation Method

EmbeddedImageRenderingEngineRenderAnnotation Method

Renders an EmbeddedImageData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

EmbeddedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


FreehandRenderingEngine Class

This class is used for rendering FreehandData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererFreehandRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FreehandRenderingEngine : AnnotationRenderingEngine
Public Class FreehandRenderingEngine
    Inherits AnnotationRenderingEngine

The FreehandRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | FreehandRenderingEngine | Creates a new instance of FreehandRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a FreehandData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


FreehandRenderingEngine Constructor

Creates a new instance of FreehandRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandRenderingEngine()
Public Sub New
See Also

Reference

FreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


FreehandRenderingEngine Properties

The FreehandRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

FreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


FreehandRenderingEngine Methods

The FreehandRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a FreehandData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


FreehandRenderingEngine.RenderAnnotation Method

FreehandRenderingEngineRenderAnnotation Method

Renders a FreehandData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

FreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotFreehandRenderingEngine Class

This class is used for rendering HotSpotFreehandData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererHotSpotFreehandRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HotSpotFreehandRenderingEngine : AnnotationRenderingEngine
Public Class HotSpotFreehandRenderingEngine
    Inherits AnnotationRenderingEngine

The HotSpotFreehandRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotFreehandRenderingEngine | Creates a new instance of HotSpotFreehandRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a HotSpotFreehandData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


HotSpotFreehandRenderingEngine Constructor

Creates a new instance of HotSpotFreehandRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandRenderingEngine()
Public Sub New
See Also

Reference

HotSpotFreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotFreehandRenderingEngine Properties

The HotSpotFreehandRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

HotSpotFreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotFreehandRenderingEngine Methods

The HotSpotFreehandRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a HotSpotFreehandData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotSpotFreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotFreehandRenderingEngine.RenderAnnotation Method

HotSpotFreehandRenderingEngineRenderAnnotation Method

Renders a HotSpotFreehandData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

HotSpotFreehandRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotRenderingEngine Class

This class is used for rendering HotSpotData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererHotSpotRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HotSpotRenderingEngine : AnnotationRenderingEngine
Public Class HotSpotRenderingEngine
    Inherits AnnotationRenderingEngine

The HotSpotRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotRenderingEngine | Creates a new instance of HotSpotRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a HotSpotData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


HotSpotRenderingEngine Constructor

Creates a new instance of HotSpotRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotRenderingEngine()
Public Sub New
See Also

Reference

HotSpotRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotRenderingEngine Properties

The HotSpotRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

HotSpotRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotRenderingEngine Methods

The HotSpotRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a HotSpotData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotSpotRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


HotSpotRenderingEngine.RenderAnnotation Method

HotSpotRenderingEngineRenderAnnotation Method

Renders a HotSpotData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

HotSpotRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


IAnnotationGripRenderer Interface

This interface must be implemented by classes used to render annotation grips.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationGripRenderer
Public Interface IAnnotationGripRenderer

The IAnnotationGripRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderGrips | Called when grips for an annotation need to be rendered.
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


IAnnotationGripRenderer Methods

The IAnnotationGripRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderGrips | Called when grips for an annotation need to be rendered.
Top
See Also

Reference

IAnnotationGripRenderer Interface
Atalasoft.Annotate.Renderer Namespace


IAnnotationGripRenderer.RenderGrips Method

IAnnotationGripRendererRenderGrips Method

Called when grips for an annotation need to be rendered.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void RenderGrips(
    IAnnotationGrips grips,
    AnnotationData annotation,
    RenderEnvironment e
)
Sub RenderGrips (
    grips As IAnnotationGrips,
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

grips
Type: Atalasoft.Annotate.UIIAnnotationGrips
The grips that need to be rendered.
annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation the grips belong to.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used to render the grips.
See Also

Reference

IAnnotationGripRenderer Interface
Atalasoft.Annotate.Renderer Namespace


IAnnotationRenderer Interface

This interface must be implemented by classes that will be used to render annotations.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationRenderer
Public Interface IAnnotationRenderer

The IAnnotationRenderer type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips.
Top
Methods
 | Name | Description
Public method | RenderAnnotation | Called to render an annotation.
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


IAnnotationRenderer Properties

The IAnnotationRenderer type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips.
Top
See Also

Reference

IAnnotationRenderer Interface
Atalasoft.Annotate.Renderer Namespace


IAnnotationRenderer.GripRenderer Property

IAnnotationRendererGripRenderer Property

Gets the IAnnotationGripRenderer used to render grips.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IAnnotationGripRenderer GripRenderer { get; set; }
Property GripRenderer As IAnnotationGripRenderer
    Get
    Set

Property Value

Type: IAnnotationGripRenderer
The annotation grip renderer.
See Also

Reference

IAnnotationRenderer Interface
Atalasoft.Annotate.Renderer Namespace


IAnnotationRenderer Methods

The IAnnotationRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderAnnotation | Called to render an annotation.
Top
See Also

Reference

IAnnotationRenderer Interface
Atalasoft.Annotate.Renderer Namespace


IAnnotationRenderer.RenderAnnotation Method

IAnnotationRendererRenderAnnotation Method

Called to render an annotation.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used to render the annotation.
See Also

Reference

IAnnotationRenderer Interface
Atalasoft.Annotate.Renderer Namespace


LayerRenderingEngine Class

This class is used to render LayerData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererLayerRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LayerRenderingEngine : AnnotationRenderingEngine
Public Class LayerRenderingEngine
    Inherits AnnotationRenderingEngine

The LayerRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | LayerRenderingEngine | Creates a new instance of LayerRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


LayerRenderingEngine Constructor

Creates a new instance of LayerRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerRenderingEngine()
Public Sub New
See Also

Reference

LayerRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LayerRenderingEngine Properties

The LayerRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

LayerRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LayerRenderingEngine Methods

The LayerRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LayerRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LayerRenderingEngine.RenderAnnotation Method

LayerRenderingEngineRenderAnnotation Method

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
e
Type: Atalasoft.Annotate.RendererRenderEnvironment

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

LayerRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LineRenderingEngine Class

This class is used for rendering LineData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererLineRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LineRenderingEngine : AnnotationRenderingEngine
Public Class LineRenderingEngine
    Inherits AnnotationRenderingEngine

The LineRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | LineRenderingEngine | Creates a new instance of LineRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a LineData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


LineRenderingEngine Constructor

Creates a new instance of LineRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineRenderingEngine()
Public Sub New
See Also

Reference

LineRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LineRenderingEngine Properties

The LineRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

LineRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LineRenderingEngine Methods

The LineRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a LineData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LineRenderingEngine.RenderAnnotation Method

LineRenderingEngineRenderAnnotation Method

Renders a LineData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

LineRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LinesRenderingEngine Class

This class is used for rendering LinesData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererLinesRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LinesRenderingEngine : AnnotationRenderingEngine
Public Class LinesRenderingEngine
    Inherits AnnotationRenderingEngine

The LinesRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | LinesRenderingEngine | Creates a new instance of LinesRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a LinesData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


LinesRenderingEngine Constructor

Creates a new instance of LinesRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesRenderingEngine()
Public Sub New
See Also

Reference

LinesRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LinesRenderingEngine Properties

The LinesRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

LinesRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LinesRenderingEngine Methods

The LinesRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a LinesData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinesRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


LinesRenderingEngine.RenderAnnotation Method

LinesRenderingEngineRenderAnnotation Method

Renders a LinesData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

LinesRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


OcrRegionRenderingEngine Class

This class is used for rendering OcrRegionData.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererOcrRegionRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrRegionRenderingEngine : AnnotationRenderingEngine
Public Class OcrRegionRenderingEngine
    Inherits AnnotationRenderingEngine

The OcrRegionRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | OcrRegionRenderingEngine | Creates a new instance of OcrRegionRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Called to render an annotation. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


OcrRegionRenderingEngine Constructor

Creates a new instance of OcrRegionRenderingEngine.
Creates a new instance of OcrRegionRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionRenderingEngine()
Public Sub New
See Also

Reference

OcrRegionRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


OcrRegionRenderingEngine Properties

The OcrRegionRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

OcrRegionRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


OcrRegionRenderingEngine Methods

The OcrRegionRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Called to render an annotation. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrRegionRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


OcrRegionRenderingEngine.RenderAnnotation Method

OcrRegionRenderingEngineRenderAnnotation Method

Called to render an annotation.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
Exceptions
Exception | Condition
ArgumentNullException | annotation or e
ArgumentException | Only OcrRegionData objects can be rendered using the OcrRegionRenderingEngine.;annotation
Remarks
This class will simply render a rectangle with the name of the annotation. For custom annotations a new class implementing IAnnotationRenderer or derived from another renderer must be created.
See Also

Reference

OcrRegionRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


PolygonRenderingEngine Class

This class is used for rendering PolygonData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererPolygonRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PolygonRenderingEngine : AnnotationRenderingEngine
Public Class PolygonRenderingEngine
    Inherits AnnotationRenderingEngine

The PolygonRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | PolygonRenderingEngine | Creates a new instance of PolygonRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a PolygonData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


PolygonRenderingEngine Constructor

Creates a new instance of PolygonRenderingEngine.
Creates a new instance of PolygonRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonRenderingEngine()
Public Sub New
See Also

Reference

PolygonRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


PolygonRenderingEngine Properties

The PolygonRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

PolygonRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


PolygonRenderingEngine Methods

The PolygonRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a PolygonData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolygonRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


PolygonRenderingEngine.RenderAnnotation Method

PolygonRenderingEngineRenderAnnotation Method

Renders a PolygonData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

PolygonRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine Class

This class is used for rendering RectangleData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererRectangleRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RectangleRenderingEngine : AnnotationRenderingEngine
Public Class RectangleRenderingEngine
    Inherits AnnotationRenderingEngine

The RectangleRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleRenderingEngine | Creates a new instance of RectangleRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a RectangleData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
lck | The LCK
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine Constructor

Creates a new instance of RectangleRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleRenderingEngine()
Public Sub New
See Also

Reference

RectangleRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine Properties

The RectangleRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

RectangleRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine Methods

The RectangleRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a RectangleData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RectangleRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine.RenderAnnotation Method

RectangleRenderingEngineRenderAnnotation Method

Renders a RectangleData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

RectangleRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine Fields

The RectangleRenderingEngine type exposes the following members.

Fields
Name | Description
lck | The LCK
Top
See Also

Reference

RectangleRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RectangleRenderingEngine.lck Field

RectangleRenderingEnginelck Field

The LCK

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly Object lck
Public Shared ReadOnly lck As Object

Field Value

Type: Object
See Also

Reference

RectangleRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


ReferencedImageRenderingEngine Class

This class is used for rendering ReferencedImageData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererReferencedImageRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ReferencedImageRenderingEngine : AnnotationRenderingEngine
Public Class ReferencedImageRenderingEngine
    Inherits AnnotationRenderingEngine

The ReferencedImageRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | ReferencedImageRenderingEngine | Creates a new instance of ReferencedImageRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a ReferencedImageData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


ReferencedImageRenderingEngine Constructor

Creates a new instance of ReferencedImageRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageRenderingEngine()
Public Sub New
See Also

Reference

ReferencedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


ReferencedImageRenderingEngine Properties

The ReferencedImageRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

ReferencedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


ReferencedImageRenderingEngine Methods

The ReferencedImageRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a ReferencedImageData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReferencedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


ReferencedImageRenderingEngine.RenderAnnotation Method

ReferencedImageRenderingEngineRenderAnnotation Method

Renders a ReferencedImageData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

ReferencedImageRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Class

This class is passed into the IAnnotationRenderer methods to provide information for the rendering process.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererRenderEnvironment

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RenderEnvironment : IDisposable
Public Class RenderEnvironment
    Implements IDisposable

The RenderEnvironment type exposes the following members.

Constructors
 | Name | Description
Public method | RenderEnvironment | Creates a new instance of RenderEnvironment.
Public method | RenderEnvironment(AnnotationImage, PointF, AnnotationUnit, Matrix) | Creates a new instance of RenderEnvironment specifying parameters for burning annotations onto an image.
Public method | RenderEnvironment(RenderDevice, Graphics, PointF, AnnotationUnit, Matrix, PointF) | Creates a new instance of RenderEnvironment specifying information when rendering to a Graphics object retrieved from an image.
Public method | RenderEnvironment(RenderDevice, Graphics, PointF, AnnotationUnit, Matrix, PointF, PointF) | Creates a new instance of RenderEnvironment specifying its properties.
Top
Properties
 | Name | Description
Public property | Device | Gets the type of device being rendered onto.
Public property | Graphics | The graphics object used to render the annotation onto.
Public property | Image | Gets the image when rendering to an image.
Public property | ImageResolution | Gets the resolution of the image. This is only needed if a Graphics object is provided instead of an AnnotationImage.
Public property | Resolution | The number of units per pixel.
Public property | Transform | Gets the transformation matrix used by the IAnnotate control.
Public property | Units | Gets the units of measure used by the annotation Locate and Size.
Public property | ViewerResolution | Gets the resolution of the viewer.
Top
Methods
 | Name | Description
Public method | Dispose | Releases resources used by the object.
Protected method | Dispose(Boolean) | Release resources used by the object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the RenderEnvironment class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Constructor

Constructs a RenderEnvironment.
Overload List
 | Name | Description
Public method | RenderEnvironment | Creates a new instance of RenderEnvironment.
Public method | RenderEnvironment(AnnotationImage, PointF, AnnotationUnit, Matrix) | Creates a new instance of RenderEnvironment specifying parameters for burning annotations onto an image.
Public method | RenderEnvironment(RenderDevice, Graphics, PointF, AnnotationUnit, Matrix, PointF) | Creates a new instance of RenderEnvironment specifying information when rendering to a Graphics object retrieved from an image.
Public method | RenderEnvironment(RenderDevice, Graphics, PointF, AnnotationUnit, Matrix, PointF, PointF) | Creates a new instance of RenderEnvironment specifying its properties.
Top
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Constructor

Creates a new instance of RenderEnvironment.
Creates a new instance of RenderEnvironment.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderEnvironment()
Public Sub New
See Also

Reference

RenderEnvironment Class
RenderEnvironment Overload
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Constructor (AnnotationImage, PointF, AnnotationUnit, Matrix)

Creates a new instance of RenderEnvironment specifying parameters for burning annotations onto an image.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderEnvironment(
    AnnotationImage image,
    PointF resolution,
    AnnotationUnit units,
    Matrix transform
)
Public Sub New (
    image As AnnotationImage,
    resolution As PointF,
    units As AnnotationUnit,
    transform As Matrix
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to burn onto.
resolution
Type: System.DrawingPointF
The resolution to render at.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units of measure used by the annotation.
transform
Type: System.Drawing.Drawing2DMatrix
A transformation matrix used when burning.
Exceptions
Exception | Condition
 | Thrown if the image.BitCount is less than 24.
See Also

Reference

RenderEnvironment Class
RenderEnvironment Overload
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Constructor (RenderDevice, Graphics, PointF, AnnotationUnit, Matrix, PointF)

Creates a new instance of RenderEnvironment specifying information when rendering to a Graphics object retrieved from an image.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderEnvironment(
    RenderDevice device,
    Graphics graphics,
    PointF resolution,
    AnnotationUnit units,
    Matrix transform,
    PointF imageResolution
)
Public Sub New (
    device As RenderDevice,
    graphics As Graphics,
    resolution As PointF,
    units As AnnotationUnit,
    transform As Matrix,
    imageResolution As PointF
)

Parameters

device
Type: Atalasoft.AnnotateRenderDevice
The device used when rendering.
graphics
Type: System.DrawingGraphics
A Graphics object to render onto.
resolution
Type: System.DrawingPointF
The resolution to render at.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units of measure used by the annotation.
transform
Type: System.Drawing.Drawing2DMatrix
A transformation matrix used when rendering.
imageResolution
Type: System.DrawingPointF
The resolution of the image.
See Also

Reference

RenderEnvironment Class
RenderEnvironment Overload
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Constructor (RenderDevice, Graphics, PointF, AnnotationUnit, Matrix, PointF, PointF)

Creates a new instance of RenderEnvironment specifying its properties.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderEnvironment(
    RenderDevice device,
    Graphics graphics,
    PointF resolution,
    AnnotationUnit units,
    Matrix transform,
    PointF imageResolution,
    PointF viewerResolution
)
Public Sub New (
    device As RenderDevice,
    graphics As Graphics,
    resolution As PointF,
    units As AnnotationUnit,
    transform As Matrix,
    imageResolution As PointF,
    viewerResolution As PointF
)

Parameters

device
Type: Atalasoft.AnnotateRenderDevice
The device used when rendering.
graphics
Type: System.DrawingGraphics
A Graphics object to render onto.
resolution
Type: System.DrawingPointF
The resolution to render at
units
Type: Atalasoft.AnnotateAnnotationUnit
The units of measure used by the annotation.
transform
Type: System.Drawing.Drawing2DMatrix
A transformation matrix used when rendering.
imageResolution
Type: System.DrawingPointF
The resolution of the image.
viewerResolution
Type: System.DrawingPointF
The resolution of the viewer.
See Also

Reference

RenderEnvironment Class
RenderEnvironment Overload
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Properties

The RenderEnvironment type exposes the following members.

Properties
 | Name | Description
Public property | Device | Gets the type of device being rendered onto.
Public property | Graphics | The graphics object used to render the annotation onto.
Public property | Image | Gets the image when rendering to an image.
Public property | ImageResolution | Gets the resolution of the image. This is only needed if a Graphics object is provided instead of an AnnotationImage.
Public property | Resolution | The number of units per pixel.
Public property | Transform | Gets the transformation matrix used by the IAnnotate control.
Public property | Units | Gets the units of measure used by the annotation Locate and Size.
Public property | ViewerResolution | Gets the resolution of the viewer.
Top
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Device Property

RenderEnvironmentDevice Property

Gets the type of device being rendered onto.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderDevice Device { get; }
Public ReadOnly Property Device As RenderDevice
    Get

Property Value

Type: RenderDevice
The device to render onto.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Graphics Property

RenderEnvironmentGraphics Property

The graphics object used to render the annotation onto.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get

Property Value

Type: Graphics
The graphics used when rendering.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Image Property

RenderEnvironmentImage Property

Gets the image when rendering to an image.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage Image { get; }
Public ReadOnly Property Image As AnnotationImage
    Get

Property Value

Type: AnnotationImage
The image being rendered onto.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.ImageResolution Property

RenderEnvironmentImageResolution Property

Gets the resolution of the image. This is only needed if a Graphics object is provided instead of an AnnotationImage.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ImageResolution { get; }
Public ReadOnly Property ImageResolution As PointF
    Get

Property Value

Type: PointF
The resolution of the image.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Resolution Property

RenderEnvironmentResolution Property

The number of units per pixel.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; }
Public ReadOnly Property Resolution As PointF
    Get

Property Value

Type: PointF
The resolution of this object.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Transform Property

RenderEnvironmentTransform Property

Gets the transformation matrix used by the IAnnotate control.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix Transform { get; }
Public ReadOnly Property Transform As Matrix
    Get

Property Value

Type: Matrix
The IAnnotate transformation matrix.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Units Property

RenderEnvironmentUnits Property

Gets the units of measure used by the annotation Locate and Size.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUnit Units { get; }
Public ReadOnly Property Units As AnnotationUnit
    Get

Property Value

Type: AnnotationUnit
The units of measure used by the annotations.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.ViewerResolution Property

RenderEnvironmentViewerResolution Property

Gets the resolution of the viewer.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ViewerResolution { get; }
Public ReadOnly Property ViewerResolution As PointF
    Get

Property Value

Type: PointF
The viewer resolution.
Remarks
The viewer resolution is used for Font creation in the AnnotationRenderingEngine.
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment Methods

The RenderEnvironment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases resources used by the object.
Protected method | Dispose(Boolean) | Release resources used by the object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the RenderEnvironment class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Dispose Method

RenderEnvironmentDispose Method

Disposes the RenderEnvironment.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the object.
Protected method | Dispose(Boolean) | Release resources used by the object.
Top
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Dispose Method

RenderEnvironmentDispose Method

Releases resources used by the object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

RenderEnvironment Class
Dispose Overload
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Dispose Method (Boolean)

RenderEnvironmentDispose Method (Boolean)

Release resources used by the object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

RenderEnvironment Class
Dispose Overload
Atalasoft.Annotate.Renderer Namespace


RenderEnvironment.Finalize Method

RenderEnvironmentFinalize Method

Finalizes an instance of the RenderEnvironment class.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

RenderEnvironment Class
Atalasoft.Annotate.Renderer Namespace


RubberStampRenderingEngine Class

This class is used for rendering RubberStampData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererRubberStampRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RubberStampRenderingEngine : AnnotationRenderingEngine
Public Class RubberStampRenderingEngine
    Inherits AnnotationRenderingEngine

The RubberStampRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | RubberStampRenderingEngine | Creates a new instance of RubberStampRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a RubberStampData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


RubberStampRenderingEngine Constructor

Creates a new instance of RubberStampRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampRenderingEngine()
Public Sub New
See Also

Reference

RubberStampRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RubberStampRenderingEngine Properties

The RubberStampRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

RubberStampRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RubberStampRenderingEngine Methods

The RubberStampRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a RubberStampData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RubberStampRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


RubberStampRenderingEngine.RenderAnnotation Method

RubberStampRenderingEngineRenderAnnotation Method

Renders a RubberStampData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

RubberStampRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


TextAnnotationRenderingEngine Class

This class is used for rendering TextData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.RendererAnnotationRenderingEngine
Atalasoft.Annotate.RendererTextAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextAnnotationRenderingEngine : AnnotationRenderingEngine
Public Class TextAnnotationRenderingEngine
    Inherits AnnotationRenderingEngine

The TextAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | TextAnnotationRenderingEngine | Creates a new instance of TextAnnotationRenderingEngine.
Top
Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a TextData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Renderer Namespace


TextAnnotationRenderingEngine Constructor

Creates a new instance of TextAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotationRenderingEngine()
Public Sub New
See Also

Reference

TextAnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


TextAnnotationRenderingEngine Properties

The TextAnnotationRenderingEngine type exposes the following members.

Properties
 | Name | Description
Public property | GripRenderer | Gets the IAnnotationGripRenderer used to render grips. (Inherited from AnnotationRenderingEngine.)
Top
See Also

Reference

TextAnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


TextAnnotationRenderingEngine Methods

The TextAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | BurnTranslucentAnnotation | This method is used to burn translucent (highlighter) annotations onto an image. (Inherited from AnnotationRenderingEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetTranslucentHandle | Returns a GDI HDC used for rendering the translucent effect. (Inherited from AnnotationRenderingEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReleaseTranslucentHandle | Release the HDC and drawing objects created with GetTranslucentHandle(RenderEnvironment, RectangleF, AnnotationPen, AnnotationBrush). (Inherited from AnnotationRenderingEngine.)
Public method | RenderAnnotation | Renders a TextData object. (Overrides AnnotationRenderingEngineRenderAnnotation(AnnotationData, RenderEnvironment).)
Public method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) | This method renders the grips for annotations. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment, PointF) | This method is used to render the annotation grips. The public RenderGrips(IAnnotationGrips, AnnotationData, RenderEnvironment) method calls into this protected method to perform the actual rendering. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap without a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLineCap(PointF, PointF, AnnotationLineCap, AnnotationBrush, AnnotationPen, RenderEnvironment) | Renders an AnnotationLineCap with a fill. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, PointF, RenderEnvironment) | Renders a small image at the specified point. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderLockImage(AnnotationImage, RectangleF, RenderEnvironment) | Renders a small image, centered in the annotation bounds, used to indicate that an annotation is locked. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointBaseData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a point based translucent annotation. (Inherited from AnnotationRenderingEngine.)
Protected method | RenderTranslucentPointsAnnotation(PointF, AnnotationData, AnnotationPen, AnnotationBrush, RenderEnvironment, Boolean) | Renders a translucent annotation from the specified points. (Inherited from AnnotationRenderingEngine.)
Protected method | RestoreGraphicsTransform | Restores the Graphics object to the state it was in before using SetGraphicsTransform(AnnotationData, RenderEnvironment). (Inherited from AnnotationRenderingEngine.)
Protected method | SetGraphicsTransform | Prepares the Graphics object to use the IAnnotate and AnnotationData transforms. (Inherited from AnnotationRenderingEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextAnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


TextAnnotationRenderingEngine.RenderAnnotation Method

TextAnnotationRenderingEngineRenderAnnotation Method

Renders a TextData object.

Namespace: Atalasoft.Annotate.Renderer
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void RenderAnnotation(
    AnnotationData annotation,
    RenderEnvironment e
)
Public Overrides Sub RenderAnnotation (
    annotation As AnnotationData,
    e As RenderEnvironment
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to render.
e
Type: Atalasoft.Annotate.RendererRenderEnvironment
A RenderEnvironment containing information used for rendering.

Implements

IAnnotationRendererRenderAnnotation(AnnotationData, RenderEnvironment)
See Also

Reference

TextAnnotationRenderingEngine Class
Atalasoft.Annotate.Renderer Namespace


Atalasoft.Annotate.UI Namespace

Classes
 | Class | Description
Public class | AnnotatePrintDocument | This control derives from DotImage ImagePrintDocument and is used to print images with annotations.
Public class | AnnotateViewer | This control derives from DotImage WorkspaceViewer and contains a reference to an AnnotationController. Drop this control onto a form to start creating annotations.
Public class | AnnotateViewerParameters | This class is returned by GetViewerParameters to provide information about the viewer the annotations are rendered on.
Public class | AnnotationController | The AnnotationController is the central hub for DotImage. It contains a LayerCollection for any number of LayerAnnotation objects, each containing any number of annotations.
Public class | AnnotationCursors | AnnotationCursors is a used to hold all of the Cursor objects for the annotations. This simplifies changing the appearance of the cursors.
Public class | AnnotationGrip | This class represents a single grip. To access these grip objects use the Grips property of the annotation.
Public class | AnnotationGripChangedEventArgs | This class is used to with the GripPositionChanged event.
Public class | AnnotationKey | This class is used with the AnnotationKeyBinder to define the action or handler to call when a specific key is pressed.
Public class | AnnotationKeyBinder | The AnnotationKeyBinder class is used to bind key press events to annotation actions.
Public class | AnnotationKeyEventArgs | This class is sent to the AnnotationKey handler during a key press event.
Public class | AnnotationMouseEventArgs | This class is passed to mouse event handlers.
Public class | AnnotationSaveOptions | This class provides options used when saving annotations with the DocumentAnnotationViewer.
Public class | AnnotationUI | This abstract class represents the base annotation object. All annotations must derive from AnnotationUI.
Public class | AnnotationUICollection | This class holds a collection of annotation objects. LayerAnnotations use this collection to hold the AnnotationUI objects they contain.
Public class | AnnotationUIFactoryCollection | This class is a collection of IAnnotationUIFactory objects which are used to create new AnnotationUI objects from AnnotationData.
Public class | AnnotationUndo | This class is used to store an undo or redo change for an object.
Public class | AnnotationUndoManager | The AnnotationUndoManager keeps track of annotation changes and allows undo and redo functionality.
Public class | CachedImageAnnotationEventArgs | This class is used with the UndoPerformed and RedoPerformed events of CachedImageAnnotationUndoManager.
Public class | CachedImageAnnotationUndoManager | This class manages the undo and redo features of DocumentAnnotationViewer.
Public class | CalloutAnnotation | This annotation is designed to provide additional information on a specific area of the document. It contains an editable text area and a leader line used to point to the area of the document. When creating this annotation, the first click sets the target for the leader and a second click sets the annotation location. It can also be created by pressing down the mouse button to set the leader and dragging. Both annotation and leader point can be repositioned independently after the annotation has been created.
Public class | CalloutAnnotationFactory | This class generates a CalloutAnnotation object from a CalloutData class for use with the AnnotationUIFactoryCollection.
Public class | CreatePdfAnnotationDataExporterEventArgs | This class provides information for events that create Pdf AnnotationData Exporters.
Public class | DocumentAnnotationViewer | The DocumentAnnotationViewer control simplifies the process of synchronizing a ThumbnailView with an AnnotateViewer. The control's ThumbnailView can be docked on any side using the ThumbnailDockStyle property. A Separator can be enabled, allowing the end user to resize the ThumbnailView and the AnnotateViewer will fill the rest of the control.
Public class | EllipseAnnotation | This class uses an EllipseData object to generate an ellipse annotation.
Public class | EllipseAnnotationFactory | This class generates an EllipseAnnotation object from an EllipseData class for use with the AnnotationUIFactoryCollection.
Public class | EmbeddedAnnotationDataProvider | This class is used by the DocumentAnnotationViewer to extract annotation data from JPEG, TIFF and PDF files.
Public class | EmbeddedImageAnnotation | This is an image annotation that will embed the image into the serialized XMP or WANG data.
Public class | EmbeddedImageAnnotationFactory | This class generates an EmbeddedImageAnnotation object from an EmbeddedImageData class for use with the AnnotationUIFactoryCollection.
Public class | FreehandAnnotation | This class is used for a freehand drawing annotation.
Public class | FreehandAnnotationFactory | This class generates a FreehandAnnotation object from a FreehandData class for use with the AnnotationUIFactoryCollection.
Public class | HotSpotAnnotation | This annotations can be used to add rectangular hot spots on a document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked. For a non-rectangular area use the HotSpotFreehandAnnotation.
Public class | HotSpotAnnotationFactory | This class generates a HotSpotAnnotation object from a AnnotationData class for use with the AnnotationUIFactoryCollection.
Public class | HotSpotFreehandAnnotation | This annotation can be used to create a freehand hot spot area on the document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked. For a rectangular hot spot use the HotSpotAnnotation.
Public class | HotSpotFreehandAnnotationFactory | This class generates a HotSpotFreehandAnnotation object from a HotSpotFreehandData class for use with the AnnotationUIFactoryCollection.
Public class | LayerAnnotation | A LayerAnnotation is a collection of other annotations, including other LayerAnnotation objects.
Public class | LayerAnnotationFactory | This class generates a LayerAnnotation object from a LayerData class for use with the AnnotationUIFactoryCollection.
Public class | LayerCollection | This class is used to hold a collection of LayerAnnotation objects.
Public class | LineAnnotation | This is a single line annotation from StartPoint to EndPoint.
Public class | LineAnnotationFactory | This class generates a LineAnnotation object from a LineData class for use with the AnnotationUIFactoryCollection.
 | LinesAnnotation | The LinesAnnoation represents a series of points connected by straight lines.
Public class | LinesAnnotationFactory | This class generates a LinesAnnotation object from a LinesData class for use with the AnnotationUIFactoryCollection.
Public class | OcrRegionAnnotation | This annotation is used to select an area of the image to OCR is a separate process.
Public class | OcrRegionAnnotationFactory | This class generates a OcrRegionAnnotation object from a OcrRegionData class for use with the AnnotationUIFactoryCollection.
Public class | PdfAnnotationUIFactory | A class for initializing an AnnotationUIFactoryCollection with PDF annotation UI factories.
Public class | PdfLineAnnotationFactory | This class is used to generate a PdfLineAnnotation from a PdfLineData object.
Public class | PdfMarkupAnnotationFactory | This class is used to generate a PdfMarkupAnnotation from a PdfMarkupData object.
Public class | PointBaseAnnotation | This abstract class is used to simplify creating annotations that are defined with multiple points instead of a rectangular structure.
Public class | PointGrips | PointGrips is the base class implementation used for annotation grips. All annotations in DotImage use PointGrips or RectangleGrips, which derives from PointGrips. In essence, PointGrips is a collection of AnnotationGrip objects.
Public class | PolygonAnnotation | A PolygonAnnotation is a series of points used to draw a polygon with an optional fill.
Public class | PolygonAnnotationFactory | This class generates a PolygonAnnotation object from a PolygonData class for use with the AnnotationUIFactoryCollection.
Public class | RectangleAnnotation | This is a rectangular annotation with an optional shadow brush.
Public class | RectangleAnnotationFactory | This class generates a RectangleAnnotation object from a RectangleData class for use with the AnnotationUIFactoryCollection.
Public class | RectangleGrips | This class represents a group of AnnotationGrip objects for rectangular shaped annotations.
Public class | ReferencedImageAnnotation | This annotation references a local image by filename. When viewing this annotation on multiple systems, the image file must be provided at the same location of each system.
Public class | ReferencedImageAnnotationFactory | This class generates a ReferencedImageAnnotation object from a ReferencedImageData class for use with the AnnotationUIFactoryCollection.
Public class | RubberStampAnnotation | This annotation provides a text message with a rounded rectangle outline similar to a rubber stamp.
Public class | RubberStampAnnotationFactory | This class generates a RubberStampAnnotation object from a RubberStampData class for use with the AnnotationUIFactoryCollection.
Public class | ScrollPositionChangedEventArgs | This class is used with the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method.
Public class | TextAnnotation | This annotation displays text which can be edited by the user.
Public class | TextAnnotationFactory | This class generates a TextAnnotation object from a TextData class for use with the AnnotationUIFactoryCollection.
Public class | TransparentRichTextBox | This class is used by the TextAnnotation and CalloutAnnotation for editing text.
Public class | UndoEventArgs | This class contains information for the UndoRequest and RedoRequest events.
Interfaces
 | Interface | Description
Public interface | IAnnotate | This interface must be implemented by any control hosting annotations. The AnnotationController requires the properties of this interface for rendering and user interaction.
Public interface | IAnnotationDataProvider | This interface is used to provide LayerData objects for images.
Public interface | IAnnotationGrips | This interface must be implemented by any class acting as annotation grips.
Public interface | IAnnotationUIFactory | This interface must be implemented by any class used as an annotation UI factory.
Delegates
 | Delegate | Description
Public delegate | AnnotationKeyEventHandler | This event handler is used with the AnnotationKey class to process key actions.
Public delegate | AnnotationMouseEventHandler | This event handler is used with several mouse events.
Public delegate | AnnotationSaveOptionsHandler | This delegate is used to provide annotation save options to the DocumentAnnotationViewer.
Public delegate | CreatePdfAnnotationDataExporterHandler | This delegate is used when viewers need to create a PdfAnnotationDataExporter.
Public delegate | GripPositionChangedEventHandler | This event handler is used with the GripPositionChanged event.
Public delegate | UndoEventHandler | This delegate is used for the UndoRequest and RedoRequest events of the AnnotationUndoManager.
Enumerations
 | Enumeration | Description
Public enumeration | AnnotationKeyAction | This enumeration is used to define the actions used with AnnotationKeyBinder.


AnnotatePrintDocument Class

This control derives from DotImage ImagePrintDocument and is used to print images with annotations.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Drawing.PrintingPrintDocument
Atalasoft.Imaging.WinControlsImagePrintDocument
Atalasoft.Annotate.UIAnnotatePrintDocument

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotatePrintDocument : ImagePrintDocument
Public Class AnnotatePrintDocument
    Inherits ImagePrintDocument

The AnnotatePrintDocument type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotatePrintDocument | Creates a new instance of AnnotatePrintDocument.
Public method | AnnotatePrintDocument(AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the image to print with no annotations.
Public method | AnnotatePrintDocument(AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the images to print with no annotations.
Public method | AnnotatePrintDocument(ImageCollection) | Creates a new instance of AnnotatePrintDocument specifying the images to print with no annotations.
Public method | AnnotatePrintDocument(AnnotationController, AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the annotations and image to print.
Public method | AnnotatePrintDocument(AnnotationController, AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the annotations and images to print.
Public method | AnnotatePrintDocument(AnnotationController, ImageCollection) | Creates a new instance of AnnotatePrintDocument specifying the annotations and images for this print job.
Top
Properties
 | Name | Description
Public property | Annotations | Gets or sets the AnnotationController which contains all annotations to print.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Center | Gets or sets a value indicating if the image is centered onto the page. (Inherited from ImagePrintDocument.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitToPage | Obsolete. A value indicating if the image is stretched to fit the page. (Inherited from ImagePrintDocument.)
Public property | Image | Gets or sets the AtalaImage to print. (Inherited from ImagePrintDocument.)
Public property | Images | Gets or sets the images to print. (Inherited from ImagePrintDocument.)
Protected property | ImageToPrint | Gets the image that will be printed for this page. (Inherited from ImagePrintDocument.)
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | ScaleMode | Gets or sets the scale mode used when printing an image. (Inherited from ImagePrintDocument.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Units | Gets or sets the units of measure used for the annotation data. This is required in order to correctly scale annotations that are not specified in pixels.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterPrintPage | Called after the OnPrintPage(PrintPageEventArgs) method. (Inherited from ImagePrintDocument.)
Protected method | OnBeginPrint | Called when printing is about to begin. (Overrides ImagePrintDocumentOnBeginPrint(PrintEventArgs).)
Protected method | OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
Protected method | OnGetImage | Raises the GetImage event to obtain the image to print. (Inherited from ImagePrintDocument.)
Protected method | OnPrintImage | Called when each image needs to be printed. (Overrides ImagePrintDocumentOnPrintImage(PrintImageEventArgs).)
Protected method | OnPrintPage | Called when a new page needs to be printed. (Overrides ImagePrintDocumentOnPrintPage(PrintPageEventArgs).)
Protected method | OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | SetImagesFromImageCollection | Sets the Images in this ImagePrintDocument to an ImageCollection in a Workspace or WorkspaceViewer. (Inherited from ImagePrintDocument.)
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
Events
 | Name | Description
Public event | AfterPrintPage | Occurs after image is prepared to print. (Inherited from ImagePrintDocument.)
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
 | GetImage | Occurs when the print job requires the next image to print. (Inherited from ImagePrintDocument.)
Public event | PrintImage | Occurs just before the image is printed. (Inherited from ImagePrintDocument.)
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
Remarks
The AnnotatePrintDocument can be used with the other printing .NET components for specifying page settings, printer settings, and a print preview. See the PrintDialog, PrintPreviewDialog, PrintPreviewControl, PrintDocument, and PageSetupDialog controls in the toolbox.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor

Overload List
 | Name | Description
Public method | AnnotatePrintDocument | Creates a new instance of AnnotatePrintDocument.
Public method | AnnotatePrintDocument(AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the image to print with no annotations.
Public method | AnnotatePrintDocument(AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the images to print with no annotations.
Public method | AnnotatePrintDocument(ImageCollection) | Creates a new instance of AnnotatePrintDocument specifying the images to print with no annotations.
Public method | AnnotatePrintDocument(AnnotationController, AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the annotations and image to print.
Public method | AnnotatePrintDocument(AnnotationController, AtalaImage) | Creates a new instance of AnnotatePrintDocument specifying the annotations and images to print.
Public method | AnnotatePrintDocument(AnnotationController, ImageCollection) | Creates a new instance of AnnotatePrintDocument specifying the annotations and images for this print job.
Top
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor

Creates a new instance of AnnotatePrintDocument.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument()
Public Sub New
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor (AtalaImage)

Creates a new instance of AnnotatePrintDocument specifying the image to print with no annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to print.
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor (AtalaImage[])

AnnotatePrintDocument Constructor (AtalaImage)

Creates a new instance of AnnotatePrintDocument specifying the images to print with no annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument(
    params AtalaImage[] images
)
Public Sub New (
    ParamArray images As AtalaImage()
)

Parameters

images
Type: Atalasoft.ImagingAtalaImage
An array of images to print.
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor (ImageCollection)

Creates a new instance of AnnotatePrintDocument specifying the images to print with no annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument(
    ImageCollection images
)
Public Sub New (
    images As ImageCollection
)

Parameters

images
Type: Atalasoft.ImagingImageCollection
An ImageCollection containing the images to print.
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor (AnnotationController, AtalaImage)

Creates a new instance of AnnotatePrintDocument specifying the annotations and image to print.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument(
    AnnotationController annotations,
    AtalaImage image
)
Public Sub New (
    annotations As AnnotationController,
    image As AtalaImage
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationController
An AnnotationController containing the annotations to print.
image
Type: Atalasoft.ImagingAtalaImage
The image to print.
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor (AnnotationController, AtalaImage[])

AnnotatePrintDocument Constructor (AnnotationController, AtalaImage)

Creates a new instance of AnnotatePrintDocument specifying the annotations and images to print.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument(
    AnnotationController annotations,
    params AtalaImage[] images
)
Public Sub New (
    annotations As AnnotationController,
    ParamArray images As AtalaImage()
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationController
An AnnotationController containing the annotations to print.
images
Type: Atalasoft.ImagingAtalaImage
An array of images to print.
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Constructor (AnnotationController, ImageCollection)

Creates a new instance of AnnotatePrintDocument specifying the annotations and images for this print job.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotatePrintDocument(
    AnnotationController annotations,
    ImageCollection images
)
Public Sub New (
    annotations As AnnotationController,
    images As ImageCollection
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationController
An AnnotationController containing the annotations to print.
images
Type: Atalasoft.ImagingImageCollection
An ImageCollection containing the images to print.
See Also

Reference

AnnotatePrintDocument Class
AnnotatePrintDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Properties

The AnnotatePrintDocument type exposes the following members.

Properties
 | Name | Description
Public property | Annotations | Gets or sets the AnnotationController which contains all annotations to print.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Center | Gets or sets a value indicating if the image is centered onto the page. (Inherited from ImagePrintDocument.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitToPage | Obsolete. A value indicating if the image is stretched to fit the page. (Inherited from ImagePrintDocument.)
Public property | Image | Gets or sets the AtalaImage to print. (Inherited from ImagePrintDocument.)
Public property | Images | Gets or sets the images to print. (Inherited from ImagePrintDocument.)
Protected property | ImageToPrint | Gets the image that will be printed for this page. (Inherited from ImagePrintDocument.)
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | ScaleMode | Gets or sets the scale mode used when printing an image. (Inherited from ImagePrintDocument.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Units | Gets or sets the units of measure used for the annotation data. This is required in order to correctly scale annotations that are not specified in pixels.
Top
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument.Annotations Property

AnnotatePrintDocumentAnnotations Property

Gets or sets the AnnotationController which contains all annotations to print.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController Annotations { get; set; }
Public Property Annotations As AnnotationController
    Get
    Set

Property Value

Type: AnnotationController
The AnnotationController for this print job.
Remarks
If the AnnotatePrintDocument component contains multiple images, each annotation layer will be associated with the respective image page.
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument.Units Property

AnnotatePrintDocumentUnits Property

Gets or sets the units of measure used for the annotation data. This is required in order to correctly scale annotations that are not specified in pixels.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUnit Units { get; set; }
Public Property Units As AnnotationUnit
    Get
    Set

Property Value

Type: AnnotationUnit
Units of measure for the annotations.
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Methods

The AnnotatePrintDocument type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterPrintPage | Called after the OnPrintPage(PrintPageEventArgs) method. (Inherited from ImagePrintDocument.)
Protected method | OnBeginPrint | Called when printing is about to begin. (Overrides ImagePrintDocumentOnBeginPrint(PrintEventArgs).)
Protected method | OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
Protected method | OnGetImage | Raises the GetImage event to obtain the image to print. (Inherited from ImagePrintDocument.)
Protected method | OnPrintImage | Called when each image needs to be printed. (Overrides ImagePrintDocumentOnPrintImage(PrintImageEventArgs).)
Protected method | OnPrintPage | Called when a new page needs to be printed. (Overrides ImagePrintDocumentOnPrintPage(PrintPageEventArgs).)
Protected method | OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | SetImagesFromImageCollection | Sets the Images in this ImagePrintDocument to an ImageCollection in a Workspace or WorkspaceViewer. (Inherited from ImagePrintDocument.)
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument.OnBeginPrint Method

AnnotatePrintDocumentOnBeginPrint Method

Called when printing is about to begin.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnBeginPrint(
    PrintEventArgs e
)
Protected Overrides Sub OnBeginPrint (
    e As PrintEventArgs
)

Parameters

e
Type: System.Drawing.PrintingPrintEventArgs
A PrintEventArgs containing information about this print job.
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument.OnPrintImage Method

AnnotatePrintDocumentOnPrintImage Method

Called when each image needs to be printed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPrintImage(
    PrintImageEventArgs e
)
Protected Overrides Sub OnPrintImage (
    e As PrintImageEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
A PrintImageEventArgs containing information needed to print the image.
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument.OnPrintPage Method

AnnotatePrintDocumentOnPrintPage Method

Called when a new page needs to be printed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPrintPage(
    PrintPageEventArgs e
)
Protected Overrides Sub OnPrintPage (
    e As PrintPageEventArgs
)

Parameters

e
Type: System.Drawing.PrintingPrintPageEventArgs
A PrintPageEventArgs containing information about this page.
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotatePrintDocument Events

The AnnotatePrintDocument type exposes the following members.

Events
 | Name | Description
Public event | AfterPrintPage | Occurs after image is prepared to print. (Inherited from ImagePrintDocument.)
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
 | GetImage | Occurs when the print job requires the next image to print. (Inherited from ImagePrintDocument.)
Public event | PrintImage | Occurs just before the image is printed. (Inherited from ImagePrintDocument.)
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
See Also

Reference

AnnotatePrintDocument Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer Class

This control derives from DotImage WorkspaceViewer and contains a reference to an AnnotationController. Drop this control onto a form to start creating annotations.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsScrollport
Atalasoft.Imaging.WinControlsViewport
Atalasoft.Imaging.WinControlsImageViewer
Atalasoft.Imaging.WinControlsWorkspaceViewer
Atalasoft.Annotate.UIAnnotateViewer

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotateViewer : WorkspaceViewer,
    IAnnotate
Public Class AnnotateViewer
    Inherits WorkspaceViewer
    Implements IAnnotate

The AnnotateViewer type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotateViewer | Creates a new instance of AnnotateViewer.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnnotationConfinement | Gets or sets the annotation confinement used to keep annotations within a specific area of the control.
Public property | Annotations | Gets the AnnotationController used by this viewer.
Public property | AntialiasDisplay | Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels. (Inherited from ImageViewer.)
Public property | Asynchronous | (Inherited from WorkspaceViewer.)
Public property | AutoDispose | Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized. (Inherited from WorkspaceViewer.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoUpdate | Gets or sets a value indicating if the control updates its display whenever the current image changes. (Inherited from WorkspaceViewer.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColorManage | Get or set a value indicating if the control will automatically color correct images. (Inherited from ImageViewer.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets the control that the annotations will be drawn onto.
Protected property | ControlHandleDestroyed | Gets a value indicating whether the control handle has been destroyed. (Inherited from WorkspaceViewer.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataImporters | Returns a collection of AnnotationDataImporter used by GetDataImporter(Stream).
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Public property | DefaultSecurity | Gets or sets the default security used for new annotations.
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device. (Inherited from ImageViewer.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DocumentBounds | Gets the bounding rectangle for this document.
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | (Inherited from WorkspaceViewer.)
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | Images | (Inherited from WorkspaceViewer.)
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | Importers | Obsolete. Gets and sets the [!:importers collection] used by this class. This property is obsolete. Use the DataImporters property instead.
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the AnnotationController.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | KeyBinder | Gets an AnnotationKeyBinder used to bind key press events to annotation actions.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | MultipageAnnotateMode | Gets or sets a value indicating whether the AnnotateViewer will automatically add and remove top level LayerAnnotation to match the number of images in the Images collection.
Public property | MultiSelectKey | Gets or sets the key held down to select multiple annotations.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device. (Inherited from ImageViewer.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images. (Inherited from ImageViewer.)
Public property | Queue | (Inherited from WorkspaceViewer.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device. (Inherited from ImageViewer.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Resolution | Gets the horizontal and vertical resolution of the viewer.
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RotationSnapInterval |
Public property | RotationSnapThreshold |
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothingMode | Gets or sets the smoothing mode used when drawing annotations.
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the tooltip control used for annotation tooltips.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transform | Gets the transformation matrix for this viewer.
Public property | UndoLevels | Gets or sets the number of undo levels in the Undo collection. (Inherited from WorkspaceViewer.)
Public property | UndoManager | Gets the AnnotationUndoManager used by the controller.
Public property | Undos | (Inherited from WorkspaceViewer.)
Public property | Units | Gets or sets the units of measure used for the annotation Location and Size.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image. (Inherited from WorkspaceViewer.)
Public method | ApplyCommand(ImageCommand, String) | Applies an ImageCommand to the current image with a custom undo description. (Inherited from WorkspaceViewer.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Burn | Burns all of the annotations onto the current image or all images if MultipageAnnotateMode is set to true.
Public method | Burn(AtalaImage) | Burns all annotations onto the supplied image.
Public method | Burn(AnnotationData, AtalaImage) | Burns an annotation data onto the supplied image or the current image.
Public method | Burn(AnnotationDataCollection, AtalaImage) | Burns a collection of AnnotationData objects onto the supplied image or the current image.
Public method | Burn(AnnotationUI, AtalaImage) | Burns an annotation onto the supplied image or the current image.
Public method | Burn(AnnotationUICollection, AtalaImage) | Burns a collection of AnnotationUI objects onto the supplied image or the current image.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the viewer. (Overrides WorkspaceViewerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from WorkspaceViewer.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Returns the current image and indicates whether or not this image is a Bitmap. (Inherited from ImageViewer.)
Protected method | GetDataImporter | Returns the AnnotationDataImporter for the specified stream.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control. (Inherited from ImageViewer.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Protected method | ImportAnnotations | Using the provided importer, this method will add annotations into the viewer.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Used to determine if the key press is used as an input key of the control. (Overrides ControlIsInputKey(Keys).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAnnotationCreated | Called when the viewer's AnnotationController raises the AnnotationCreated event.
Protected method | OnAnnotationMoved | Called when the viewer's AnnotationController raises the Moved event.
Protected method | OnAnnotationMoving | Called when the viewer's AnnotationController raises the Moving event.
Protected method | OnAnnotationResized | Called when the viewer's AnnotationController raises the Resized event.
Protected method | OnAnnotationResizing | Called when the viewer's AnnotationController raises the Resizing event.
Protected method | OnAnnotationRotated | Called when the viewer's AnnotationController raises the Rotated event.
Protected method | OnAnnotationRotating | Called when the viewer's AnnotationController raises the Rotating event.
Protected method | OnAnnotationSelectionChanged | Called when the viewer's AnnotationController raises the SelectionChanged event.
Protected method | OnAntialiasDisplayChanged | Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event. (Inherited from ImageViewer.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCurrentLayerChanged | Called when the viewer's AnnotationController raises the CurrentLayerChanged event.
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDisposeImage | Called when an image is about to be disposed. (Inherited from WorkspaceViewer.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the control handle is created. (Inherited from WorkspaceViewer.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageChanged | (Overrides WorkspaceViewerOnImageChanged(ImageEventArgs).)
Protected method | OnImageDraw | This method is used to draw the image onto the Viewport graphics. (Inherited from ImageViewer.)
Protected method | OnImageStreamCompleted | Called when the stream being used to read an image is no longer needed and raises the ImageStreamCompleted event. (Inherited from WorkspaceViewer.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to redraw itself. (Inherited from ImageViewer.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProcessCompleted | Called when an asynchronous process has completed and raises the ProcessCompleted event. (Inherited from WorkspaceViewer.)
Protected method | OnProcessError | Called when there is an error during an asynchronous process and raises the ProcessError event. (Inherited from WorkspaceViewer.)
Protected method | OnProgress | Raises the Progress event. (Inherited from WorkspaceViewer.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | (Overrides ViewportOnZoomChanged(EventArgs).)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | Open(Stream) | Loads an image from a stream into the WorkspaceViewer. (Inherited from WorkspaceViewer.)
Public method | Open(String) | Loads an image file into a WorkspaceViewer. (Inherited from WorkspaceViewer.)
Public method | Open(Stream, Int32) | Loads an image from a stream into the WorkspaceViewer specifying the frame to load. (Inherited from WorkspaceViewer.)
Public method | Open(String, Int32) | Loads an image file into a WorkspaceViewer with the specified frame index. (Inherited from WorkspaceViewer.)
Public method | Open(Stream, Int32, Boolean) | This method will open an image from a viewer and optionally load the XMP annotations embedded in that image.
Public method | Open(String, Int32, Boolean) | This method will open an image from a filename and optionally load embedded XMP annotations.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Removes any cached images used for fast displays and redraws the image. (Inherited from ImageViewer.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RotateDocument(DocumentRotation) | Rotates the document by the given DocumentRotation.
Public method | RotateDocument(DocumentRotation, LayerAnnotation) | Rotates the specified LayerAnnotation by the given DocumentRotation
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the document at the given layer index by the given DocumentRotation.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the current image(s) to a stream. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageEncoder) | Saves the current image(s) to a file using the specified encoder. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageType) | Obsolete. Saves the current image(s) using the specified image type. (Inherited from WorkspaceViewer.)
Public method | Save(Stream, ImageEncoder, Int32) | Saves the current image(s) to a stream using the specified encoder and frame index. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageEncoder, Int32) | Saves the current image(s) to a file using the specified encoder and frame index. (Inherited from WorkspaceViewer.)
Public method | Save(Stream, IAnnotationEncoder, Int32, Boolean) | Saves an image to a stream and optionally stores annotation data embedded as XMP into the file.
Public method | Save(String, IAnnotationEncoder, Int32, Boolean) | Saves an image to a file and optionally stores annotation data embedded as XMP into the file.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetInputKeys | Use this method to allow special keys to raise the KeyDown and KeyUp events.
Protected method | SetNewImage | Called when the Image is being replaced. (Inherited from ImageViewer.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetWorkspace | Sets the Workspace of this control. (Inherited from WorkspaceViewer.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Updates the image in the control with the current image in the workspace. (Inherited from WorkspaceViewer.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
Events
 | Name | Description
Public event | AnnotationClicked |
Public event | AnnotationCreated |
Public event | AnnotationDeserialization | Raised after annotation data has been deserialized but before the annotations have been added to the AnnotationController.
Public event | AnnotationDoubleClicked |
Public event | AnnotationMoved |
Public event | AnnotationMoving |
Public event | AnnotationResized |
Public event | AnnotationResizing |
Public event | AnnotationRotated |
Public event | AnnotationRotating |
Public event | AnnotationSelectionChanged |
Public event | AntialiasDisplayChanged | Occurs when AntialiasDisplay changes. (Inherited from ImageViewer.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CurrentLayerChanged |
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DisposeImage | Fired when an image in the ImageCollection or UndoCollection is disposed. (Inherited from WorkspaceViewer.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HotSpotClicked |
Public event | ImageChanged | Occurs when commands are applied to change the image. (Inherited from ImageViewer.)
Public event | ImageStreamCompleted | (Inherited from WorkspaceViewer.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | ProcessCompleted | (Inherited from WorkspaceViewer.)
Public event | ProcessError | (Inherited from WorkspaceViewer.)
Public event | Progress | (Inherited from WorkspaceViewer.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
Remarks
To access annotating capabilities, see the Annotations property. This control can be used to view single and multiple AtalaImage objects. It also will automatically handle multipage images by setting the MultipageAnnotateMode property to true.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotateViewer Constructor

Creates a new instance of AnnotateViewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateViewer()
Public Sub New
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer Properties

The AnnotateViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnnotationConfinement | Gets or sets the annotation confinement used to keep annotations within a specific area of the control.
Public property | Annotations | Gets the AnnotationController used by this viewer.
Public property | AntialiasDisplay | Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels. (Inherited from ImageViewer.)
Public property | Asynchronous | (Inherited from WorkspaceViewer.)
Public property | AutoDispose | Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized. (Inherited from WorkspaceViewer.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoUpdate | Gets or sets a value indicating if the control updates its display whenever the current image changes. (Inherited from WorkspaceViewer.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColorManage | Get or set a value indicating if the control will automatically color correct images. (Inherited from ImageViewer.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets the control that the annotations will be drawn onto.
Protected property | ControlHandleDestroyed | Gets a value indicating whether the control handle has been destroyed. (Inherited from WorkspaceViewer.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataImporters | Returns a collection of AnnotationDataImporter used by GetDataImporter(Stream).
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Public property | DefaultSecurity | Gets or sets the default security used for new annotations.
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device. (Inherited from ImageViewer.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DocumentBounds | Gets the bounding rectangle for this document.
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | (Inherited from WorkspaceViewer.)
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | Images | (Inherited from WorkspaceViewer.)
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | Importers | Obsolete. Gets and sets the [!:importers collection] used by this class. This property is obsolete. Use the DataImporters property instead.
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the AnnotationController.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | KeyBinder | Gets an AnnotationKeyBinder used to bind key press events to annotation actions.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | MultipageAnnotateMode | Gets or sets a value indicating whether the AnnotateViewer will automatically add and remove top level LayerAnnotation to match the number of images in the Images collection.
Public property | MultiSelectKey | Gets or sets the key held down to select multiple annotations.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device. (Inherited from ImageViewer.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images. (Inherited from ImageViewer.)
Public property | Queue | (Inherited from WorkspaceViewer.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device. (Inherited from ImageViewer.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Resolution | Gets the horizontal and vertical resolution of the viewer.
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RotationSnapInterval |
Public property | RotationSnapThreshold |
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothingMode | Gets or sets the smoothing mode used when drawing annotations.
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the tooltip control used for annotation tooltips.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transform | Gets the transformation matrix for this viewer.
Public property | UndoLevels | Gets or sets the number of undo levels in the Undo collection. (Inherited from WorkspaceViewer.)
Public property | UndoManager | Gets the AnnotationUndoManager used by the controller.
Public property | Undos | (Inherited from WorkspaceViewer.)
Public property | Units | Gets or sets the units of measure used for the annotation Location and Size.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationConfinement Property

AnnotateViewerAnnotationConfinement Property

Gets or sets the annotation confinement used to keep annotations within a specific area of the control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationConfinementMode AnnotationConfinement { get; set; }
Public Property AnnotationConfinement As AnnotationConfinementMode
    Get
    Set

Property Value

Type: AnnotationConfinementMode
The annotation confinement.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Annotations Property

AnnotateViewerAnnotations Property

Gets the AnnotationController used by this viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController Annotations { get; }
Public ReadOnly Property Annotations As AnnotationController
    Get

Property Value

Type: AnnotationController
The AnnotationController that holds all of the annotations.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Control Property

AnnotateViewerControl Property

Gets the control that the annotations will be drawn onto.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Control Control { get; }
Public ReadOnly Property Control As Control
    Get

Property Value

Type: Control
The control that will host the annotation.

Implements

IAnnotateControl
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.DataImporters Property

AnnotateViewerDataImporters Property

Returns a collection of AnnotationDataImporter used by GetDataImporter(Stream).

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Collection<AnnotationDataImporter> DataImporters { get; set; }
Public Property DataImporters As Collection(Of AnnotationDataImporter)
    Get
    Set

Property Value

Type: Collection AnnotationDataImporter
A collection of AnnotationDataImporter.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.DefaultSecurity Property

AnnotateViewerDefaultSecurity Property

Gets or sets the default security used for new annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock DefaultSecurity { get; set; }
Public Property DefaultSecurity As IAnnotationLock
    Get
    Set

Property Value

Type: IAnnotationLock
The default security used for annotations.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.DocumentBounds Property

AnnotateViewerDocumentBounds Property

Gets the bounding rectangle for this document.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF DocumentBounds { get; }
Public ReadOnly Property DocumentBounds As RectangleF
    Get

Property Value

Type: RectangleF
The bounding rectangle of the document.

Implements

IAnnotateDocumentBounds
Remarks
This property represents the image area in Units or the client area in Units if no image is loaded.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Importers Property

AnnotateViewerImporters Property

Note: This API is now obsolete.

Gets and sets the [!:importers collection] used by this class.

This property is obsolete. Use the DataImporters property instead.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The Importers property may be removed in a future release. Use the DataImporters property instead.",
    false)]
public AnnotationImporterCollection Importers { get; set; }
<ObsoleteAttribute("The Importers property may be removed in a future release. Use the DataImporters property instead.",
    false)>
Public Property Importers As AnnotationImporterCollection
    Get
    Set

Property Value

Type: AnnotationImporterCollection
The importers collection
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.InteractMode Property

AnnotateViewerInteractMode Property

Gets or sets a value specifying the user interactive mode of the AnnotationController.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateInteractMode InteractMode { get; set; }
Public Property InteractMode As AnnotateInteractMode
    Get
    Set

Property Value

Type: AnnotateInteractMode
The interaction mode of the AnnotationController.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.KeyBinder Property

AnnotateViewerKeyBinder Property

Gets an AnnotationKeyBinder used to bind key press events to annotation actions.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKeyBinder KeyBinder { get; }
Public ReadOnly Property KeyBinder As AnnotationKeyBinder
    Get

Property Value

Type: AnnotationKeyBinder
The annotation key binder used by the viewer.

Implements

IAnnotateKeyBinder
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.MultipageAnnotateMode Property

AnnotateViewerMultipageAnnotateMode Property

Gets or sets a value indicating whether the AnnotateViewer will automatically add and remove top level LayerAnnotation to match the number of images in the Images collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MultipageAnnotateMode { get; set; }
Public Property MultipageAnnotateMode As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the AnnotateViewer will handle multipage annotations.
Remarks
When MultipageAnnotateMode is true, changing the Image property of the viewer will automatically change the current layer for the AnnotationController.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.MultiSelectKey Property

AnnotateViewerMultiSelectKey Property

Gets or sets the key held down to select multiple annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Keys MultiSelectKey { get; set; }
Public Property MultiSelectKey As Keys
    Get
    Set

Property Value

Type: Keys
The key held down to select multiple annotations.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Resolution Property

AnnotateViewerResolution Property

Gets the horizontal and vertical resolution of the viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; set; }
Public Property Resolution As PointF
    Get
    Set

Property Value

Type: PointF
The resolution of the viewer.

Implements

IAnnotateResolution
Remarks
This value reflects the Image resolution in the Units of the viewer. When this value is changed, either directly or by loading an image with a different resolution, the annotation size and location will render differently to match the new viewer resolution.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace
Units Property


AnnotateViewer.RotationSnapInterval Property

AnnotateViewerRotationSnapInterval Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float RotationSnapInterval { get; set; }
Public Property RotationSnapInterval As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.RotationSnapThreshold Property

AnnotateViewerRotationSnapThreshold Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float RotationSnapThreshold { get; set; }
Public Property RotationSnapThreshold As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.SmoothingMode Property

AnnotateViewerSmoothingMode Property

Gets or sets the smoothing mode used when drawing annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SmoothingMode SmoothingMode { get; set; }
Public Property SmoothingMode As SmoothingMode
    Get
    Set

Property Value

Type: SmoothingMode
The smoothing mode used when drawing annotations.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.ToolTip Property

AnnotateViewerToolTip Property

Gets or sets the tooltip control used for annotation tooltips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ToolTip ToolTip { get; set; }
Public Property ToolTip As ToolTip
    Get
    Set

Property Value

Type: ToolTip
The tooltip control used for annotation tooltips.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Transform Property

AnnotateViewerTransform Property

Gets the transformation matrix for this viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix Transform { get; }
Public ReadOnly Property Transform As Matrix
    Get

Property Value

Type: Matrix
The transformation matrix of this viewer.

Implements

IAnnotateTransform
Remarks
The value of this property is used when rendering annotations: It does not affect the viewer control itself.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.UndoManager Property

AnnotateViewerUndoManager Property

Gets the AnnotationUndoManager used by the controller.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndoManager UndoManager { get; }
Public ReadOnly Property UndoManager As AnnotationUndoManager
    Get

Property Value

Type: AnnotationUndoManager
The undo manager used by the controller.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Units Property

AnnotateViewerUnits Property

Gets or sets the units of measure used for the annotation Location and Size.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUnit Units { get; set; }
Public Property Units As AnnotationUnit
    Get
    Set

Property Value

Type: AnnotationUnit
The unit of measure for the annotations.

Implements

IAnnotateUnits
Remarks
This property can only be changed when there are no annotations loaded.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer Methods

The AnnotateViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image. (Inherited from WorkspaceViewer.)
Public method | ApplyCommand(ImageCommand, String) | Applies an ImageCommand to the current image with a custom undo description. (Inherited from WorkspaceViewer.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Burn | Burns all of the annotations onto the current image or all images if MultipageAnnotateMode is set to true.
Public method | Burn(AtalaImage) | Burns all annotations onto the supplied image.
Public method | Burn(AnnotationData, AtalaImage) | Burns an annotation data onto the supplied image or the current image.
Public method | Burn(AnnotationDataCollection, AtalaImage) | Burns a collection of AnnotationData objects onto the supplied image or the current image.
Public method | Burn(AnnotationUI, AtalaImage) | Burns an annotation onto the supplied image or the current image.
Public method | Burn(AnnotationUICollection, AtalaImage) | Burns a collection of AnnotationUI objects onto the supplied image or the current image.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the viewer. (Overrides WorkspaceViewerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from WorkspaceViewer.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Returns the current image and indicates whether or not this image is a Bitmap. (Inherited from ImageViewer.)
Protected method | GetDataImporter | Returns the AnnotationDataImporter for the specified stream.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control. (Inherited from ImageViewer.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Protected method | ImportAnnotations | Using the provided importer, this method will add annotations into the viewer.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Used to determine if the key press is used as an input key of the control. (Overrides ControlIsInputKey(Keys).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAnnotationCreated | Called when the viewer's AnnotationController raises the AnnotationCreated event.
Protected method | OnAnnotationMoved | Called when the viewer's AnnotationController raises the Moved event.
Protected method | OnAnnotationMoving | Called when the viewer's AnnotationController raises the Moving event.
Protected method | OnAnnotationResized | Called when the viewer's AnnotationController raises the Resized event.
Protected method | OnAnnotationResizing | Called when the viewer's AnnotationController raises the Resizing event.
Protected method | OnAnnotationRotated | Called when the viewer's AnnotationController raises the Rotated event.
Protected method | OnAnnotationRotating | Called when the viewer's AnnotationController raises the Rotating event.
Protected method | OnAnnotationSelectionChanged | Called when the viewer's AnnotationController raises the SelectionChanged event.
Protected method | OnAntialiasDisplayChanged | Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event. (Inherited from ImageViewer.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCurrentLayerChanged | Called when the viewer's AnnotationController raises the CurrentLayerChanged event.
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDisposeImage | Called when an image is about to be disposed. (Inherited from WorkspaceViewer.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the control handle is created. (Inherited from WorkspaceViewer.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageChanged | (Overrides WorkspaceViewerOnImageChanged(ImageEventArgs).)
Protected method | OnImageDraw | This method is used to draw the image onto the Viewport graphics. (Inherited from ImageViewer.)
Protected method | OnImageStreamCompleted | Called when the stream being used to read an image is no longer needed and raises the ImageStreamCompleted event. (Inherited from WorkspaceViewer.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to redraw itself. (Inherited from ImageViewer.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProcessCompleted | Called when an asynchronous process has completed and raises the ProcessCompleted event. (Inherited from WorkspaceViewer.)
Protected method | OnProcessError | Called when there is an error during an asynchronous process and raises the ProcessError event. (Inherited from WorkspaceViewer.)
Protected method | OnProgress | Raises the Progress event. (Inherited from WorkspaceViewer.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | (Overrides ViewportOnZoomChanged(EventArgs).)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | Open(Stream) | Loads an image from a stream into the WorkspaceViewer. (Inherited from WorkspaceViewer.)
Public method | Open(String) | Loads an image file into a WorkspaceViewer. (Inherited from WorkspaceViewer.)
Public method | Open(Stream, Int32) | Loads an image from a stream into the WorkspaceViewer specifying the frame to load. (Inherited from WorkspaceViewer.)
Public method | Open(String, Int32) | Loads an image file into a WorkspaceViewer with the specified frame index. (Inherited from WorkspaceViewer.)
Public method | Open(Stream, Int32, Boolean) | This method will open an image from a viewer and optionally load the XMP annotations embedded in that image.
Public method | Open(String, Int32, Boolean) | This method will open an image from a filename and optionally load embedded XMP annotations.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Removes any cached images used for fast displays and redraws the image. (Inherited from ImageViewer.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RotateDocument(DocumentRotation) | Rotates the document by the given DocumentRotation.
Public method | RotateDocument(DocumentRotation, LayerAnnotation) | Rotates the specified LayerAnnotation by the given DocumentRotation
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the document at the given layer index by the given DocumentRotation.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the current image(s) to a stream. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageEncoder) | Saves the current image(s) to a file using the specified encoder. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageType) | Obsolete. Saves the current image(s) using the specified image type. (Inherited from WorkspaceViewer.)
Public method | Save(Stream, ImageEncoder, Int32) | Saves the current image(s) to a stream using the specified encoder and frame index. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageEncoder, Int32) | Saves the current image(s) to a file using the specified encoder and frame index. (Inherited from WorkspaceViewer.)
Public method | Save(Stream, IAnnotationEncoder, Int32, Boolean) | Saves an image to a stream and optionally stores annotation data embedded as XMP into the file.
Public method | Save(String, IAnnotationEncoder, Int32, Boolean) | Saves an image to a file and optionally stores annotation data embedded as XMP into the file.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetInputKeys | Use this method to allow special keys to raise the KeyDown and KeyUp events.
Protected method | SetNewImage | Called when the Image is being replaced. (Inherited from ImageViewer.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetWorkspace | Sets the Workspace of this control. (Inherited from WorkspaceViewer.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Updates the image in the control with the current image in the workspace. (Inherited from WorkspaceViewer.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method

AnnotateViewerBurn Method

These methods are used to burn annotations onto an image.
Overload List
 | Name | Description
Public method | Burn | Burns all of the annotations onto the current image or all images if MultipageAnnotateMode is set to true.
Public method | Burn(AtalaImage) | Burns all annotations onto the supplied image.
Public method | Burn(AnnotationData, AtalaImage) | Burns an annotation data onto the supplied image or the current image.
Public method | Burn(AnnotationDataCollection, AtalaImage) | Burns a collection of AnnotationData objects onto the supplied image or the current image.
Public method | Burn(AnnotationUI, AtalaImage) | Burns an annotation onto the supplied image or the current image.
Public method | Burn(AnnotationUICollection, AtalaImage) | Burns a collection of AnnotationUI objects onto the supplied image or the current image.
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method

AnnotateViewerBurn Method

Burns all of the annotations onto the current image or all images if MultipageAnnotateMode is set to true.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn()
Public Sub Burn
Remarks
When MultipageAnnotateMode is true and the number of images in the Images collection is equal to the number of top level layers in the Layers collection, each layer will be burnt onto its corresponding image. Otherwise all layers will be burnt onto the current image.
See Also

Reference

AnnotateViewer Class
Burn Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method (AtalaImage)

AnnotateViewerBurn Method (AtalaImage)

Burns all annotations onto the supplied image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn(
    AtalaImage image
)
Public Sub Burn (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to burn annotations on.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image is null (Nothing in VB).
See Also

Reference

AnnotateViewer Class
Burn Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method (AnnotationData, AtalaImage)

AnnotateViewerBurn Method (AnnotationData, AtalaImage)

Burns an annotation data onto the supplied image or the current image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn(
    AnnotationData annotation,
    AtalaImage image
)
Public Sub Burn (
    annotation As AnnotationData,
    image As AtalaImage
)

Parameters

annotation
Type: Atalasoft.AnnotateAnnotationData
The annotation to burn.
image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotation onto. If null (Nothing in VB) the current image in the viewer is used.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if annotation is null (Nothing in VB).
See Also

Reference

AnnotateViewer Class
Burn Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method (AnnotationDataCollection, AtalaImage)

AnnotateViewerBurn Method (AnnotationDataCollection, AtalaImage)

Burns a collection of AnnotationData objects onto the supplied image or the current image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn(
    AnnotationDataCollection annotations,
    AtalaImage image
)
Public Sub Burn (
    annotations As AnnotationDataCollection,
    image As AtalaImage
)

Parameters

annotations
Type: Atalasoft.AnnotateAnnotationDataCollection
An AnnotationDataCollection containing the annotations to burn.
image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotation onto. If null (Nothing in VB) the current image in the viewer is used.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if annotations is null (Nothing in VB).
See Also

Reference

AnnotateViewer Class
Burn Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method (AnnotationUI, AtalaImage)

AnnotateViewerBurn Method (AnnotationUI, AtalaImage)

Burns an annotation onto the supplied image or the current image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn(
    AnnotationUI annotation,
    AtalaImage image
)
Public Sub Burn (
    annotation As AnnotationUI,
    image As AtalaImage
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to burn.
image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotation onto. If null (Nothing in VB) the current image in the viewer is used.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if annotation is null (Nothing in VB).
See Also

Reference

AnnotateViewer Class
Burn Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Burn Method (AnnotationUICollection, AtalaImage)

AnnotateViewerBurn Method (AnnotationUICollection, AtalaImage)

Burns a collection of AnnotationUI objects onto the supplied image or the current image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn(
    AnnotationUICollection annotations,
    AtalaImage image
)
Public Sub Burn (
    annotations As AnnotationUICollection,
    image As AtalaImage
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUICollection
An AnnotationUICollection containing the annotations to burn.
image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotation onto. If null (Nothing in VB) the current image in the viewer is used.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if annotations is null (Nothing in VB).
See Also

Reference

AnnotateViewer Class
Burn Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Dispose Method

AnnotateViewerDispose Method

Releases resources used by the AnnotateViewer.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the viewer. (Overrides WorkspaceViewerDispose(Boolean).)
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Dispose Method (Boolean)

AnnotateViewerDispose Method (Boolean)

Releases resources used by the viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from the Dispose method or the finalizer.
See Also

Reference

AnnotateViewer Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.GetDataImporter Method

AnnotateViewerGetDataImporter Method

Returns the AnnotationDataImporter for the specified stream.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AnnotationDataImporter GetDataImporter(
    Stream stream
)
Protected Overridable Function GetDataImporter (
    stream As Stream
) As AnnotationDataImporter

Parameters

stream
Type: System.IOStream
A stream containing the image data with embedded annotations.

Return Value

Type: AnnotationDataImporter
An importer for this file or null (Nothing in VB) if an importer cannot be found.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if stream is null (Nothing in VB).
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.ImportAnnotations Method

AnnotateViewerImportAnnotations Method

Using the provided importer, this method will add annotations into the viewer.

Imports annotations using the specified importer and frame index.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ImportAnnotations(
    AnnotationDataImporter importer,
    int frameIndex
)
Protected Overridable Sub ImportAnnotations (
    importer As AnnotationDataImporter,
    frameIndex As Integer
)

Parameters

importer
Type: Atalasoft.Annotate.ImportersAnnotationDataImporter
The importer to use.
frameIndex
Type: SystemInt32
The frame index to extract annotations from or -1 to extract from all pages. See Remarks for more information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the importer is null (Nothing in VB).
Remarks

If -1 is passed for frameIndex, all existing layers in the viewer will be removed and replaced with annotations pulled from the importer. If frameIndex is 0 or greater, a new layer will be added to the viewer containing annotations from the specified page.

See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.IsInputKey Method

AnnotateViewerIsInputKey Method

Used to determine if the key press is used as an input key of the control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool IsInputKey(
    Keys keyData
)
Protected Overrides Function IsInputKey (
    keyData As Keys
) As Boolean

Parameters

keyData
Type: System.Windows.FormsKeys
The key to test.

Return Value

Type: Boolean
True if the key is an input key.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationCreated Method

AnnotateViewerOnAnnotationCreated Method

Called when the viewer's AnnotationController raises the AnnotationCreated event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationCreated(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationCreated (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the new annotation.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationMoved Method

AnnotateViewerOnAnnotationMoved Method

Called when the viewer's AnnotationController raises the Moved event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationMoved(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationMoved (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the moved annotation.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationMoving Method

AnnotateViewerOnAnnotationMoving Method

Called when the viewer's AnnotationController raises the Moving event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationMoving(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationMoving (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation being moved.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationResized Method

AnnotateViewerOnAnnotationResized Method

Called when the viewer's AnnotationController raises the Resized event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationResized(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationResized (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the resized annotation.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationResizing Method

AnnotateViewerOnAnnotationResizing Method

Called when the viewer's AnnotationController raises the Resizing event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationResizing(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationResizing (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation being resized.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationRotated Method

AnnotateViewerOnAnnotationRotated Method

Called when the viewer's AnnotationController raises the Rotated event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationRotated(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationRotated (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the rotated annotation.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationRotating Method

AnnotateViewerOnAnnotationRotating Method

Called when the viewer's AnnotationController raises the Rotating event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationRotating(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationRotating (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation being rotated.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnAnnotationSelectionChanged Method

AnnotateViewerOnAnnotationSelectionChanged Method

Called when the viewer's AnnotationController raises the SelectionChanged event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationSelectionChanged(
    EventArgs e
)
Protected Overridable Sub OnAnnotationSelectionChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnCurrentLayerChanged Method

AnnotateViewerOnCurrentLayerChanged Method

Called when the viewer's AnnotationController raises the CurrentLayerChanged event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCurrentLayerChanged(
    EventArgs e
)
Protected Overridable Sub OnCurrentLayerChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnImageChanged Method

AnnotateViewerOnImageChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnImageChanged(
    ImageEventArgs e
)
Protected Overrides Sub OnImageChanged (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.OnZoomChanged Method

AnnotateViewerOnZoomChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnZoomChanged(
    EventArgs e
)
Protected Overrides Sub OnZoomChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Open Method

AnnotateViewerOpen Method

This method opens the image and optionally the annotations embedded in the image from a file or stream.
Overload List
 | Name | Description
Public method | Open(Stream) | Loads an image from a stream into the WorkspaceViewer. (Inherited from WorkspaceViewer.)
Public method | Open(String) | Loads an image file into a WorkspaceViewer. (Inherited from WorkspaceViewer.)
Public method | Open(Stream, Int32) | Loads an image from a stream into the WorkspaceViewer specifying the frame to load. (Inherited from WorkspaceViewer.)
Public method | Open(String, Int32) | Loads an image file into a WorkspaceViewer with the specified frame index. (Inherited from WorkspaceViewer.)
Public method | Open(Stream, Int32, Boolean) | This method will open an image from a viewer and optionally load the XMP annotations embedded in that image.
Public method | Open(String, Int32, Boolean) | This method will open an image from a filename and optionally load embedded XMP annotations.
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Open Method (Stream, Int32, Boolean)

AnnotateViewerOpen Method (Stream, Int32, Boolean)

This method will open an image from a viewer and optionally load the XMP annotations embedded in that image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex,
    bool loadAnnotations
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer,
    loadAnnotations As Boolean
)

Parameters

stream
Type: System.IOStream
A stream containing the image file.
frameIndex
Type: SystemInt32
A frame index to load, or -1 to load all frames.
loadAnnotations
Type: SystemBoolean
True to load XMP annotations embedded into the image file.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the frameIndex is invalid for the image.
See Also

Reference

AnnotateViewer Class
Open Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Open Method (String, Int32, Boolean)

AnnotateViewerOpen Method (String, Int32, Boolean)

This method will open an image from a filename and optionally load embedded XMP annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex,
    bool loadAnnotations
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer,
    loadAnnotations As Boolean
)

Parameters

fileName
Type: SystemString
The full path and filename of the image to open.
frameIndex
Type: SystemInt32
The frame index to load, or -1 to load all frames.
loadAnnotations
Type: SystemBoolean
True to load embedded XMP annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the fileName is null (Nothing in VB).
FileNotFoundException | Thrown if the fileName cannot be found.
ArgumentOutOfRangeException | Thrown if the frameIndex is invalid for the image.
See Also

Reference

AnnotateViewer Class
Open Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.RotateDocument Method

AnnotateViewerRotateDocument Method

These methods will rotate the image and annotations.
Overload List
 | Name | Description
Public method | RotateDocument(DocumentRotation) | Rotates the document by the given DocumentRotation.
Public method | RotateDocument(DocumentRotation, LayerAnnotation) | Rotates the specified LayerAnnotation by the given DocumentRotation
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the document at the given layer index by the given DocumentRotation.
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.RotateDocument Method (DocumentRotation)

AnnotateViewerRotateDocument Method (DocumentRotation)

Rotates the document by the given DocumentRotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation
)
Public Sub RotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation to apply.
Remarks
If the annotation is translucent, the location will be changed but the annotation itself will not be rotated.
See Also

Reference

AnnotateViewer Class
RotateDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.RotateDocument Method (DocumentRotation, LayerAnnotation)

AnnotateViewerRotateDocument Method (DocumentRotation, LayerAnnotation)

Rotates the specified LayerAnnotation by the given DocumentRotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    LayerAnnotation layer
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layer As LayerAnnotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation to apply.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to rotate.
Exceptions
Exception | Condition
 | Thrown if the layer is null (Nothing in VB).
Remarks
If the annotation is translucent, the location will be changed but the annotation itself will not be rotated.
See Also

Reference

AnnotateViewer Class
RotateDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.RotateDocument Method (DocumentRotation, Int32)

AnnotateViewerRotateDocument Method (DocumentRotation, Int32)

Rotates the document at the given layer index by the given DocumentRotation.
Rotates the document and its annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    int layerIndex
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layerIndex As Integer
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation to apply.
layerIndex
Type: SystemInt32
The index of the layer to rotate.
Exceptions
Exception | Condition
 | Thrown if hte layerIndex is invalid for the Layers collection.
Remarks
If the annotation is translucent, the location will be changed but the annotation itself will not be rotated.
Remarks
If the annotation is translucent, the location will be changed but the annotation itself will not be rotated.
See Also

Reference

AnnotateViewer Class
RotateDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Save Method

AnnotateViewerSave Method

This method saves the image and optionally the annotations to a file or stream.
Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder) | Saves the current image(s) to a stream. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageEncoder) | Saves the current image(s) to a file using the specified encoder. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageType) | Obsolete. Saves the current image(s) using the specified image type. (Inherited from WorkspaceViewer.)
Public method | Save(Stream, ImageEncoder, Int32) | Saves the current image(s) to a stream using the specified encoder and frame index. (Inherited from WorkspaceViewer.)
Public method | Save(String, ImageEncoder, Int32) | Saves the current image(s) to a file using the specified encoder and frame index. (Inherited from WorkspaceViewer.)
Public method | Save(Stream, IAnnotationEncoder, Int32, Boolean) | Saves an image to a stream and optionally stores annotation data embedded as XMP into the file.
Public method | Save(String, IAnnotationEncoder, Int32, Boolean) | Saves an image to a file and optionally stores annotation data embedded as XMP into the file.
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Save Method (Stream, IAnnotationEncoder, Int32, Boolean)

AnnotateViewerSave Method (Stream, IAnnotationEncoder, Int32, Boolean)

Saves an image to a stream and optionally stores annotation data embedded as XMP into the file.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    IAnnotationEncoder encoder,
    int frameIndex,
    bool saveAnnotations
)
Public Sub Save (
    stream As Stream,
    encoder As IAnnotationEncoder,
    frameIndex As Integer,
    saveAnnotations As Boolean
)

Parameters

stream
Type: System.IOStream
The stream to save this image into.
encoder
Type: Atalasoft.Imaging.CodecIAnnotationEncoder
An image encoder implementing the IAnnotationEncoder interface. Currently this is only supported by the JpegEncoder and TiffEncoder.
frameIndex
Type: SystemInt32
The frame index to save or -1 to save all frames.
saveAnnotations
Type: SystemBoolean
True to save the annotations embedded as XMP data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream or encoder is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the frameIndex is invalid for the image collection.
See Also

Reference

AnnotateViewer Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.Save Method (String, IAnnotationEncoder, Int32, Boolean)

AnnotateViewerSave Method (String, IAnnotationEncoder, Int32, Boolean)

Saves an image to a file and optionally stores annotation data embedded as XMP into the file.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    IAnnotationEncoder encoder,
    int frameIndex,
    bool saveAnnotations
)
Public Sub Save (
    fileName As String,
    encoder As IAnnotationEncoder,
    frameIndex As Integer,
    saveAnnotations As Boolean
)

Parameters

fileName
Type: SystemString
The filename for this image.
encoder
Type: Atalasoft.Imaging.CodecIAnnotationEncoder
An image encoder implementing the IAnnotationEncoder interface. Currently this is only supported by the JpegEncoder and TiffEncoder.
frameIndex
Type: SystemInt32
The frame index to save or -1 to save all frames.
saveAnnotations
Type: SystemBoolean
True to save the annotations embedded as XMP data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the fileName or encoder is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the frameIndex is invalid for the image collection.
See Also

Reference

AnnotateViewer Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewer.SetInputKeys Method

AnnotateViewerSetInputKeys Method

Use this method to allow special keys to raise the KeyDown and KeyUp events.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetInputKeys(
    Keys[] keys
)
Public Sub SetInputKeys (
    keys As Keys()
)

Parameters

keys
Type: System.Windows.FormsKeys
An array of Keys to use.
Remarks
Keys used by the KeyBinder object are automatically supported and do not need to be added with SetInputKeys.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer Events

The AnnotateViewer type exposes the following members.

Events
 | Name | Description
Public event | AnnotationClicked |
Public event | AnnotationCreated |
Public event | AnnotationDeserialization | Raised after annotation data has been deserialized but before the annotations have been added to the AnnotationController.
Public event | AnnotationDoubleClicked |
Public event | AnnotationMoved |
Public event | AnnotationMoving |
Public event | AnnotationResized |
Public event | AnnotationResizing |
Public event | AnnotationRotated |
Public event | AnnotationRotating |
Public event | AnnotationSelectionChanged |
Public event | AntialiasDisplayChanged | Occurs when AntialiasDisplay changes. (Inherited from ImageViewer.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CurrentLayerChanged |
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DisposeImage | Fired when an image in the ImageCollection or UndoCollection is disposed. (Inherited from WorkspaceViewer.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HotSpotClicked |
Public event | ImageChanged | Occurs when commands are applied to change the image. (Inherited from ImageViewer.)
Public event | ImageStreamCompleted | (Inherited from WorkspaceViewer.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | ProcessCompleted | (Inherited from WorkspaceViewer.)
Public event | ProcessError | (Inherited from WorkspaceViewer.)
Public event | Progress | (Inherited from WorkspaceViewer.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationClicked Event

AnnotateViewerAnnotationClicked Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationClicked
Public Event AnnotationClicked As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationCreated Event

AnnotateViewerAnnotationCreated Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationCreated
Public Event AnnotationCreated As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationDeserialization Event

AnnotateViewerAnnotationDeserialization Event

Raised after annotation data has been deserialized but before the annotations have been added to the AnnotationController.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationDeserializationEventHandler AnnotationDeserialization
Public Event AnnotationDeserialization As AnnotationDeserializationEventHandler

Value

Type: Atalasoft.Annotate.FormattersAnnotationDeserializationEventHandler
Remarks
This event is useful for modifying the annotations before they are shown to the end-user.
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationDoubleClicked Event

AnnotateViewerAnnotationDoubleClicked Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationDoubleClicked
Public Event AnnotationDoubleClicked As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationMoved Event

AnnotateViewerAnnotationMoved Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationMoved
Public Event AnnotationMoved As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationMoving Event

AnnotateViewerAnnotationMoving Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationMoving
Public Event AnnotationMoving As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationResized Event

AnnotateViewerAnnotationResized Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationResized
Public Event AnnotationResized As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationResizing Event

AnnotateViewerAnnotationResizing Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationResizing
Public Event AnnotationResizing As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationRotated Event

AnnotateViewerAnnotationRotated Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationRotated
Public Event AnnotationRotated As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationRotating Event

AnnotateViewerAnnotationRotating Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationRotating
Public Event AnnotationRotating As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.AnnotationSelectionChanged Event

AnnotateViewerAnnotationSelectionChanged Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AnnotationSelectionChanged
Public Event AnnotationSelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.CurrentLayerChanged Event

AnnotateViewerCurrentLayerChanged Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CurrentLayerChanged
Public Event CurrentLayerChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewer.HotSpotClicked Event

AnnotateViewerHotSpotClicked Event

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler HotSpotClicked
Public Event HotSpotClicked As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotateViewer Class
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters Class

This class is returned by GetViewerParameters to provide information about the viewer the annotations are rendered on.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotateViewerParameters

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotateViewerParameters
Public Class AnnotateViewerParameters

The AnnotateViewerParameters type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotateViewerParameters | Creates a new instance of AnnotateViewerParameters.
Public method | AnnotateViewerParameters(PointF, PointF, PointF) | Creates a new instance of AnnotateViewerParameters specifying the resolution, zoom and scroll offset.
Top
Properties
 | Name | Description
Public property | Resolution | Gets the resolution of the viewer.
Public property | ScrollOffset | Gets the scroll position (offset from the top-left corner) of the document.
Public property | Zoom | Gets the zoom level of the viewer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters Constructor

Constructs an AnnotateViewerParameters.
Overload List
 | Name | Description
Public method | AnnotateViewerParameters | Creates a new instance of AnnotateViewerParameters.
Public method | AnnotateViewerParameters(PointF, PointF, PointF) | Creates a new instance of AnnotateViewerParameters specifying the resolution, zoom and scroll offset.
Top
See Also

Reference

AnnotateViewerParameters Class
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters Constructor

Creates a new instance of AnnotateViewerParameters.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateViewerParameters()
Public Sub New
See Also

Reference

AnnotateViewerParameters Class
AnnotateViewerParameters Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters Constructor (PointF, PointF, PointF)

Creates a new instance of AnnotateViewerParameters specifying the resolution, zoom and scroll offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateViewerParameters(
    PointF resolution,
    PointF zoom,
    PointF scrollOffset
)
Public Sub New (
    resolution As PointF,
    zoom As PointF,
    scrollOffset As PointF
)

Parameters

resolution
Type: System.DrawingPointF
The resolution of the viewer.
zoom
Type: System.DrawingPointF
The zoom level of the viewer.
scrollOffset
Type: System.DrawingPointF
The scroll position (offset from the top-left corner) of the document.
Exceptions
Exception | Condition
 | Thrown if the zoom is less than or equal to 0.
See Also

Reference

AnnotateViewerParameters Class
AnnotateViewerParameters Overload
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters Properties

The AnnotateViewerParameters type exposes the following members.

Properties
 | Name | Description
Public property | Resolution | Gets the resolution of the viewer.
Public property | ScrollOffset | Gets the scroll position (offset from the top-left corner) of the document.
Public property | Zoom | Gets the zoom level of the viewer.
Top
See Also

Reference

AnnotateViewerParameters Class
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters.Resolution Property

AnnotateViewerParametersResolution Property

Gets the resolution of the viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Resolution { get; }
Public ReadOnly Property Resolution As PointF
    Get

Property Value

Type: PointF
The viewer resolution.
See Also

Reference

AnnotateViewerParameters Class
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters.ScrollOffset Property

AnnotateViewerParametersScrollOffset Property

Gets the scroll position (offset from the top-left corner) of the document.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ScrollOffset { get; }
Public ReadOnly Property ScrollOffset As PointF
    Get

Property Value

Type: PointF
The scroll offset of the document.
See Also

Reference

AnnotateViewerParameters Class
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters.Zoom Property

AnnotateViewerParametersZoom Property

Gets the zoom level of the viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Zoom { get; }
Public ReadOnly Property Zoom As PointF
    Get

Property Value

Type: PointF
The zoom level of the viewer.
See Also

Reference

AnnotateViewerParameters Class
Atalasoft.Annotate.UI Namespace


AnnotateViewerParameters Methods

The AnnotateViewerParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotateViewerParameters Class
Atalasoft.Annotate.UI Namespace


AnnotationController Class

The AnnotationController is the central hub for DotImage. It contains a LayerCollection for any number of LayerAnnotation objects, each containing any number of annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationController

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationController : IComponent,
    IDisposable
Public Class AnnotationController
    Implements IComponent, IDisposable

The AnnotationController type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationController | Creates a new instance of AnnotationController.
Public method | AnnotationController(IAnnotate) | Creates a new instance of AnnotationController specifying the IAnnotate parent control.
Top
Properties
 | Name | Description
Public property | ActiveAnnotation | Gets or sets the currently selected annotation.
Public property | AnnotationConfinement | Gets or sets the annotation confinement used to keep annotations within a specific area of the control.
Public property | ClipToDocument | Gets or sets a value indicating whether the annotation rendering is clipped to the document bounds.
Public property | CreateMouseButton | Gets or sets the mouse button used for creating annotations.
Public property | CurrentLayer | Gets or sets the current active layer.
Public property | DefaultSecurity | Gets or sets the default security used for new annotations.
Public property | Factories | Gets the AnnotationUIFactoryCollection containing IAnnotationUIFactory objects used to create annotations from AnnotationData classes.
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the AnnotationController.
Public property | IsDirty | Gets a value indicating whether the annotations have been modified since the last load or save.
Public property | Layers | Gets or sets the LayerCollection used by the AnnotationController.
Public property | MultiSelectKey | Gets or sets the key held down to select multiple annotations.
Public property | Parent | Gets or sets the IAnnotate parent control where the annotations will be rendered.
 | RotationSnapInterval | Gets or sets the interval used for snapping interactive rotation to degrees. This is used to help users when rotating an annotation, making it easier to stop at whole degrees. The snap area is determined by the RotationSnapThreshold property.
 | RotationSnapThreshold | Gets or sets the amount of deviation from the RotationSnapInterval that will be used to snap to the rotation interval.
Public property | SelectedAnnotations | Gets an array of annotations currently selected.
Public property | Site | Gets or sets the site of the control.
Public property | SmoothingMode | Gets or sets the smoothing mode used when drawing annotations.
Public property | ToolTip | Gets or sets the tooltip control used for annotation tooltips.
Public property | UndoManager | Gets the AnnotationUndoManager used by the controller.
Public property | WaitingToCreate | Gets a value indicating whether the AnnotationController is waiting for the user to create an annotation with the mouse.
Top
Methods
 | Name | Description
Public method | AnnotationFromPoint(PointF) | Returns the annotation located at a specific point on the control.
Public method | AnnotationFromPoint(LayerAnnotation, PointF) | Returns the annotation at the specified point of a specified layer.
Public method | CanPaste | Returns a value indicating whether there is annotation data on the clipboard.
Public method | ChangeAnnotationPosition(ChangePositionMethod) | Changes the position of the selected annotation within the stacking order.
Public method | ChangeAnnotationPosition(AnnotationUI, ChangePositionMethod) | Changes the position of an annotation or layer within the stacking order.
Public method | ClearSelection | Unselects all of the selected annotations.
Public method | Clone | Creates a copy of the AnnotationController including all of the layers and annotations.
Public method | Copy | Copies the selected annotation(s) to the clipboard.
Public method | CountAnnotations | Returns the number of annotations in all of the layers.
Public method | CountAnnotations(LayerAnnotation) | Returns the number of annotations in the provided layer.
 | CreateAnnotation(AnnotationUI) | Call this method to prepare the AnnotationController for creating a new annotation with the mouse.
Public method | CreateAnnotation(AnnotationUI, CreateAnnotationMode) | Call this method to prepare the AnnotationController for creating a new annotation with the mouse, specifying the creation mode to use.
Public method | Cut | Cuts the selected annotation(s) and places them onto the clipboard.
Public method | Dispose | Releases memory used by the AnnotationController and all of its annotations.
Protected method | Dispose(Boolean) | Releases resources used by the AnnotationController.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExitCreateMode | This method will exit 'create mode' started with CreateAnnotation(AnnotationUI).
Protected method | Finalize | Finalizes an instance of the AnnotationController class. (Overrides ObjectFinalize.)
Public method | FindAnnotationLayer(AnnotationUI) | Returns the LayerAnnotation containing a specified annotation.
Public method | FindAnnotationLayer(LayerAnnotation, AnnotationUI) | Returns the LayerAnnotation containing a specified annotation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTopLevelLayer | Returns the top level LayerAnnotation for the supplied annotation. This method will scan through the nested layers until it finds the top most layer.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Group | Combines all selected annotations into a new LayerAnnotation object and adds this layer to the CurrentLayer.
Public method | Group(AnnotationUI) | Combines annotations into a LayerAnnotation and adds it to the CurrentLayer.
Public method | InvalidateAnnotation | Forces an annotation to be redrawn.
Public method | Load(Byte, AnnotationDataFormat) | Loads annotation data from a byte array and adds the annotations to the Layers collection.
Public method | Load(Byte, IFormatter) | Loads annotation data from a byte array using the supplied formatter and adds them to the Layers.
Public method | Load(Stream, AnnotationDataFormat) | Loads annotation data from a stream and adds the annotations to the Layers collection.
Public method | Load(Stream, IFormatter) | Loads annotation data from a stream using the supplied formatter into the Layers collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotation data from a file and adds the annotations to the Layers collection.
Public method | Load(String, IFormatter) | Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.
Public method | Load(Byte, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a byte array and adds the annotations to the specified layer.
Public method | Load(Byte, LayerAnnotation, IFormatter) | Loads annotation data into the specified layer using the provided formatter.
Public method | Load(Stream, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a stream and adds the annotations to the specified layer.
Public method | Load(Stream, LayerAnnotation, IFormatter) | Loads annotation data from a stream using the formatter and adds the annotations to the provided layer.
Public method | Load(String, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a file and adds the annotations to the specified layer.
Public method | Load(String, LayerAnnotation, IFormatter) | Loads annotation data from a file using the formatter and adds the annotations to the provided layer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyController | This method is used by layer and annotation objects to notify the AnnotationController of events.
Protected method | OnAnnotationCreated | Called when a new annotation has been created by the user.
Protected method | OnClick | Called when a Click event is received from the parent control.
Protected method | OnCurrentLayerChanged | Called when the CurrentLayer property has changed.
Protected method | OnDoubleClick | Called when a DoubleClick event has been received from the parent control.
Protected method | OnHotSpotClicked | Called when a hot spot annotation has been clicked.
Protected method | OnMouseDown | Called when a MouseDown event is received from the parent control.
Protected method | OnMouseMove | Called when a MouseMove event is received from the parent control.
Protected method | OnMouseUp | Called when a MouseUp event is received from the parent control.
Protected method | OnMoving | Called while an annotation is being moved by the user.
Protected method | OnPaint | Called when a Paint event is received from the parent control.
Protected method | OnResizing | Called while an annotation is being resized by the user.
Protected method | OnRotating | Called while the annotation is being rotated by the user.
Protected method | OnScrollPositionChanged | Called when a scroll event has been detected.
Protected method | OnSelectionChanged | Called when an annotation selection has changed.
Public method | Paste | Pastes annotation data from the clipboard into the current layer.
Public method | Refresh | This method will cause the control to redraw itself.
 | RenderAnnotations(AnnotationImage) | Renders the annotations to the supplied image.
Public method | RenderAnnotations(RenderDevice, Graphics) | Renders the annotations to a Graphics object
Public method | RenderAnnotations(RenderDevice, Graphics, LayerAnnotation) | Renders the annotations in a specified layer to a Graphics object.
Public method | ResumePaint | Resumes painting after it has been suspended with SuspendPaint.
Public method | RotateDocument(DocumentRotation) | Rotates all layers in the Layers collection.
Public method | RotateDocument(DocumentRotation, LayerAnnotation) | Rotates the specified layer.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the annotations in 90 degree increments.
Public method | Save(IFormatter) | Saves the annotations to a byte array using the specified formatter.
Public method | Save(Stream, AnnotationDataFormat) | Writes annotation data to the specified stream.
Public method | Save(Stream, IFormatter) | Saves the annotations to a stream using the specified formatter.
Public method | Save(String, AnnotationDataFormat) | Saves the annotations to a file using a predefined formatter.
Public method | Save(String, IFormatter) | Saves the annotations to a file using the specified formatter.
Public method | Save(LayerAnnotation, IFormatter) | Returns a byte array containing the annotation data from a specified LayerAnnotation. This is useful when saving annotation data to be embedded into image metadata.
Public method | Save(Stream, LayerAnnotation, AnnotationDataFormat) | Writes annotation data from a layer into the specified stream.
Public method | Save(Stream, LayerAnnotation, IFormatter) | Saves the specified layer to a stream using the formatter supplied.
Public method | Save(String, LayerAnnotation, AnnotationDataFormat) | Saves a layer to a file using a predefined format.
Public method | Save(String, LayerAnnotation, IFormatter) | Saves a layer to a file using the specified formatter.
Public method | SelectAll | Selects all of the annotations on the current layer or all layers.
Public method | SelectFromBounds(RectangleF, Boolean) | Selects annotations that are partially or fully within a rectangular area.
Public method | SelectFromBounds(LayerAnnotation, RectangleF, Boolean) | Selects annotations from a layer that are without a bounding region.
Public method | SuspendPaint | Use this method to suspend painting any annotations until the ResumePaint method is called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Ungroup | Ungroups the currently selected annotation.
Public method | Ungroup(LayerAnnotation, LayerAnnotation) | Removes annotations from one layer and adds them to another.
Top
Events
 | Name | Description
Public event | AnnotationCreated | Raised when an annotation is created by the user.
Public event | AnnotationDeserialization | Raised when an object is deserialized to allow developers to cancel or modify the object before its added into the controller.
Public event | Click | Raised when an annotation is clicked with the mouse.
Public event | CurrentLayerChanged | Raised when the CurrentLayer property has changed.
Public event | Disposed | Raised when the AnnotationController has been disposed.
Public event | DoubleClick | Raised when an annotation is double-clicked by the user.
Public event | HotSpotClicked | Raised when a hot spot annotation is clicked.
Public event | Moved | Raised when an annotation is moved.
Public event | Moving | Raised while an annotation is being moved.
Public event | Resized | Raised when an annotation is resized.
Public event | Resizing | Raised while an annotation is being resized.
Public event | Rotated | Raised when an annotation is rotated by the user.
Public event | Rotating | Raised while an annotation is being rotated by the user.
Public event | SelectionChanged | Raise when there has been a change in the annotation selection.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationController Constructor

Creates a new AnnotationController used to handle mouse events from the viewer for manipulating annotations.
Overload List
 | Name | Description
Public method | AnnotationController | Creates a new instance of AnnotationController.
Public method | AnnotationController(IAnnotate) | Creates a new instance of AnnotationController specifying the IAnnotate parent control.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController Constructor

Creates a new instance of AnnotationController.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController()
Public Sub New
See Also

Reference

AnnotationController Class
AnnotationController Overload
Atalasoft.Annotate.UI Namespace


AnnotationController Constructor (IAnnotate)

Creates a new instance of AnnotationController specifying the IAnnotate parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController(
    IAnnotate parent
)
Public Sub New (
    parent As IAnnotate
)

Parameters

parent
Type: Atalasoft.Annotate.UIIAnnotate
An object that will be used as the parent control for the controller.
See Also

Reference

AnnotationController Class
AnnotationController Overload
Atalasoft.Annotate.UI Namespace


AnnotationController Properties

The AnnotationController type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAnnotation | Gets or sets the currently selected annotation.
Public property | AnnotationConfinement | Gets or sets the annotation confinement used to keep annotations within a specific area of the control.
Public property | ClipToDocument | Gets or sets a value indicating whether the annotation rendering is clipped to the document bounds.
Public property | CreateMouseButton | Gets or sets the mouse button used for creating annotations.
Public property | CurrentLayer | Gets or sets the current active layer.
Public property | DefaultSecurity | Gets or sets the default security used for new annotations.
Public property | Factories | Gets the AnnotationUIFactoryCollection containing IAnnotationUIFactory objects used to create annotations from AnnotationData classes.
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the AnnotationController.
Public property | IsDirty | Gets a value indicating whether the annotations have been modified since the last load or save.
Public property | Layers | Gets or sets the LayerCollection used by the AnnotationController.
Public property | MultiSelectKey | Gets or sets the key held down to select multiple annotations.
Public property | Parent | Gets or sets the IAnnotate parent control where the annotations will be rendered.
 | RotationSnapInterval | Gets or sets the interval used for snapping interactive rotation to degrees. This is used to help users when rotating an annotation, making it easier to stop at whole degrees. The snap area is determined by the RotationSnapThreshold property.
 | RotationSnapThreshold | Gets or sets the amount of deviation from the RotationSnapInterval that will be used to snap to the rotation interval.
Public property | SelectedAnnotations | Gets an array of annotations currently selected.
Public property | Site | Gets or sets the site of the control.
Public property | SmoothingMode | Gets or sets the smoothing mode used when drawing annotations.
Public property | ToolTip | Gets or sets the tooltip control used for annotation tooltips.
Public property | UndoManager | Gets the AnnotationUndoManager used by the controller.
Public property | WaitingToCreate | Gets a value indicating whether the AnnotationController is waiting for the user to create an annotation with the mouse.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.ActiveAnnotation Property

AnnotationControllerActiveAnnotation Property

Gets or sets the currently selected annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI ActiveAnnotation { get; set; }
Public Property ActiveAnnotation As AnnotationUI
    Get
    Set

Property Value

Type: AnnotationUI
The active annotation being used.
Remarks

An annotation becomes active when the user selects it using the mouse. When multiple annotations are selected the ActiveAnnotation will be the last annotation selected by the user.

See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.AnnotationConfinement Property

AnnotationControllerAnnotationConfinement Property

Gets or sets the annotation confinement used to keep annotations within a specific area of the control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationConfinementMode AnnotationConfinement { get; set; }
Public Property AnnotationConfinement As AnnotationConfinementMode
    Get
    Set

Property Value

Type: AnnotationConfinementMode
The annotation confinement.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.ClipToDocument Property

AnnotationControllerClipToDocument Property

Gets or sets a value indicating whether the annotation rendering is clipped to the document bounds.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClipToDocument { get; set; }
Public Property ClipToDocument As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the annotation rendering is clipped to the document bounds.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.CreateMouseButton Property

AnnotationControllerCreateMouseButton Property

Gets or sets the mouse button used for creating annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButtons CreateMouseButton { get; set; }
Public Property CreateMouseButton As MouseButtons
    Get
    Set

Property Value

Type: MouseButtons
The mouse button used for creating annotations. Defaults to Left.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.CurrentLayer Property

AnnotationControllerCurrentLayer Property

Gets or sets the current active layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation CurrentLayer { get; set; }
Public Property CurrentLayer As LayerAnnotation
    Get
    Set

Property Value

Type: LayerAnnotation
The current LayerAnnotation being used.
Remarks

When an annotation is selected, either through code or by the user, the layer it's contained in becomes the current layer. When multiple annotations in different layers are selected, the last selected annotation's layer will become the current layer.

When an annotation is created by the user, it will be added as a child of the current layer.

See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.DefaultSecurity Property

AnnotationControllerDefaultSecurity Property

Gets or sets the default security used for new annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock DefaultSecurity { get; set; }
Public Property DefaultSecurity As IAnnotationLock
    Get
    Set

Property Value

Type: IAnnotationLock
The default security used for annotations.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Factories Property

AnnotationControllerFactories Property

Gets the AnnotationUIFactoryCollection containing IAnnotationUIFactory objects used to create annotations from AnnotationData classes.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUIFactoryCollection Factories { get; }
Public ReadOnly Property Factories As AnnotationUIFactoryCollection
    Get

Property Value

Type: AnnotationUIFactoryCollection
The annotation factory collection used to create AnnotationUI objects from AnnotationData classes.
Remarks
The UI factories are used when deserializing AnnotationData classes. When custom annotations are used for serialization an IAnnotationUIFactory for the UI should be added to the factory collection.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.InteractMode Property

AnnotationControllerInteractMode Property

Gets or sets a value specifying the user interactive mode of the AnnotationController.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateInteractMode InteractMode { get; set; }
Public Property InteractMode As AnnotateInteractMode
    Get
    Set

Property Value

Type: AnnotateInteractMode
The interaction mode of the AnnotationController.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.IsDirty Property

AnnotationControllerIsDirty Property

Gets a value indicating whether the annotations have been modified since the last load or save.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDirty { get; }
Public ReadOnly Property IsDirty As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the data needs to be saved.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Layers Property

AnnotationControllerLayers Property

Gets or sets the LayerCollection used by the AnnotationController.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerCollection Layers { get; set; }
Public Property Layers As LayerCollection
    Get
    Set

Property Value

Type: LayerCollection
The LayerCollection used for this controller.
Remarks
Each AnnotationController must have its own LayerCollection. Setting the Layers property of more than one AnnotationController to the same LayerCollection will have unforeseen consequences.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.MultiSelectKey Property

AnnotationControllerMultiSelectKey Property

Gets or sets the key held down to select multiple annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Keys MultiSelectKey { get; set; }
Public Property MultiSelectKey As Keys
    Get
    Set

Property Value

Type: Keys
The key held down to select multiple annotations.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Parent Property

AnnotationControllerParent Property

Gets or sets the IAnnotate parent control where the annotations will be rendered.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotate Parent { get; set; }
Public Property Parent As IAnnotate
    Get
    Set

Property Value

Type: IAnnotate
The control where the annotations will be rendered.
Remarks
Each AnnotationController must have its own IAnnotate parent. Giving multiple AnnotationController objects the same parent will cause unforeseen consequences and is not supported. This property should be set to null (Nothing in Visual Basic) when the controller is being replaced by another AnnotationController.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.RotationSnapInterval Property

AnnotationControllerRotationSnapInterval Property

Gets or sets the interval used for snapping interactive rotation to degrees.

This is used to help users when rotating an annotation, making it easier to stop at whole degrees. The snap area is determined by the RotationSnapThreshold property.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float RotationSnapInterval { get; set; }
Public Property RotationSnapInterval As Single
    Get
    Set

Property Value

Type: Single
The degree interval used for interactive rotation snapping.
Remarks
This value must be from 0 to 180 and evenly divisible into 360. When setting this property the value will automatically be converted into a valid value.
Examples
The following settings will cause the rotation to snap at 10 degree intervals when the rotation gets within 2 degrees of the interval.
RotationSnapCS
Copy
this.annotateViewer1.RotationSnapInterval = 10;
this.annotateViewer1.RotationSnapThreshold = 2;
RotationSnapVB
Copy
Me.annotateViewer1.RotationSnapInterval = 10
Me.annotateViewer1.RotationSnapThreshold = 2
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace
RotationSnapThreshold Property


AnnotationController.RotationSnapThreshold Property

AnnotationControllerRotationSnapThreshold Property

Gets or sets the amount of deviation from the RotationSnapInterval that will be used to snap to the rotation interval.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float RotationSnapThreshold { get; set; }
Public Property RotationSnapThreshold As Single
    Get
    Set

Property Value

Type: Single
The amount of deviation from the RotationSnapInterval.
Remarks
This value must be from 0 to half the RotationSnapInterval. If the property is set to an invalid value it will be automatically corrected.
Examples
The following settings will cause the rotation to snap at 10 degree intervals when the rotation gets within 2 degrees of the interval.
RotationSnapCS
Copy
this.annotateViewer1.RotationSnapInterval = 10;
this.annotateViewer1.RotationSnapThreshold = 2;
RotationSnapVB
Copy
Me.annotateViewer1.RotationSnapInterval = 10
Me.annotateViewer1.RotationSnapThreshold = 2
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace
RotationSnapInterval Property


AnnotationController.SelectedAnnotations Property

AnnotationControllerSelectedAnnotations Property

Gets an array of annotations currently selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI[] SelectedAnnotations { get; }
Public ReadOnly Property SelectedAnnotations As AnnotationUI()
    Get

Property Value

Type: AnnotationUI
An array of IAnnotate containing the currently selected annotations.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Site Property

AnnotationControllerSite Property

Gets or sets the site of the control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ISite Site { get; set; }
Public Property Site As ISite
    Get
    Set

Property Value

Type: ISite
The ISite associated with the Control, if any.

Implements

IComponentSite
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.SmoothingMode Property

AnnotationControllerSmoothingMode Property

Gets or sets the smoothing mode used when drawing annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SmoothingMode SmoothingMode { get; set; }
Public Property SmoothingMode As SmoothingMode
    Get
    Set

Property Value

Type: SmoothingMode
The smoothing mode used when drawing annotations.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.ToolTip Property

AnnotationControllerToolTip Property

Gets or sets the tooltip control used for annotation tooltips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ToolTip ToolTip { get; set; }
Public Property ToolTip As ToolTip
    Get
    Set

Property Value

Type: ToolTip
The tooltip control used for annotation tooltips.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.UndoManager Property

AnnotationControllerUndoManager Property

Gets the AnnotationUndoManager used by the controller.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndoManager UndoManager { get; }
Public ReadOnly Property UndoManager As AnnotationUndoManager
    Get

Property Value

Type: AnnotationUndoManager
The undo manager used by the controller.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.WaitingToCreate Property

AnnotationControllerWaitingToCreate Property

Gets a value indicating whether the AnnotationController is waiting for the user to create an annotation with the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WaitingToCreate { get; }
Public ReadOnly Property WaitingToCreate As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the AnnotationController is ready to create a new annotation.
Remarks

This property will return true between the time CreateAnnotation(AnnotationUI) is called and the user begins to create the annotation.

To cancel out of 'create' mode call the ExitCreateMode method.

See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController Methods

The AnnotationController type exposes the following members.

Methods
 | Name | Description
Public method | AnnotationFromPoint(PointF) | Returns the annotation located at a specific point on the control.
Public method | AnnotationFromPoint(LayerAnnotation, PointF) | Returns the annotation at the specified point of a specified layer.
Public method | CanPaste | Returns a value indicating whether there is annotation data on the clipboard.
Public method | ChangeAnnotationPosition(ChangePositionMethod) | Changes the position of the selected annotation within the stacking order.
Public method | ChangeAnnotationPosition(AnnotationUI, ChangePositionMethod) | Changes the position of an annotation or layer within the stacking order.
Public method | ClearSelection | Unselects all of the selected annotations.
Public method | Clone | Creates a copy of the AnnotationController including all of the layers and annotations.
Public method | Copy | Copies the selected annotation(s) to the clipboard.
Public method | CountAnnotations | Returns the number of annotations in all of the layers.
Public method | CountAnnotations(LayerAnnotation) | Returns the number of annotations in the provided layer.
 | CreateAnnotation(AnnotationUI) | Call this method to prepare the AnnotationController for creating a new annotation with the mouse.
Public method | CreateAnnotation(AnnotationUI, CreateAnnotationMode) | Call this method to prepare the AnnotationController for creating a new annotation with the mouse, specifying the creation mode to use.
Public method | Cut | Cuts the selected annotation(s) and places them onto the clipboard.
Public method | Dispose | Releases memory used by the AnnotationController and all of its annotations.
Protected method | Dispose(Boolean) | Releases resources used by the AnnotationController.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExitCreateMode | This method will exit 'create mode' started with CreateAnnotation(AnnotationUI).
Protected method | Finalize | Finalizes an instance of the AnnotationController class. (Overrides ObjectFinalize.)
Public method | FindAnnotationLayer(AnnotationUI) | Returns the LayerAnnotation containing a specified annotation.
Public method | FindAnnotationLayer(LayerAnnotation, AnnotationUI) | Returns the LayerAnnotation containing a specified annotation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTopLevelLayer | Returns the top level LayerAnnotation for the supplied annotation. This method will scan through the nested layers until it finds the top most layer.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Group | Combines all selected annotations into a new LayerAnnotation object and adds this layer to the CurrentLayer.
Public method | Group(AnnotationUI) | Combines annotations into a LayerAnnotation and adds it to the CurrentLayer.
Public method | InvalidateAnnotation | Forces an annotation to be redrawn.
Public method | Load(Byte, AnnotationDataFormat) | Loads annotation data from a byte array and adds the annotations to the Layers collection.
Public method | Load(Byte, IFormatter) | Loads annotation data from a byte array using the supplied formatter and adds them to the Layers.
Public method | Load(Stream, AnnotationDataFormat) | Loads annotation data from a stream and adds the annotations to the Layers collection.
Public method | Load(Stream, IFormatter) | Loads annotation data from a stream using the supplied formatter into the Layers collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotation data from a file and adds the annotations to the Layers collection.
Public method | Load(String, IFormatter) | Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.
Public method | Load(Byte, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a byte array and adds the annotations to the specified layer.
Public method | Load(Byte, LayerAnnotation, IFormatter) | Loads annotation data into the specified layer using the provided formatter.
Public method | Load(Stream, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a stream and adds the annotations to the specified layer.
Public method | Load(Stream, LayerAnnotation, IFormatter) | Loads annotation data from a stream using the formatter and adds the annotations to the provided layer.
Public method | Load(String, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a file and adds the annotations to the specified layer.
Public method | Load(String, LayerAnnotation, IFormatter) | Loads annotation data from a file using the formatter and adds the annotations to the provided layer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyController | This method is used by layer and annotation objects to notify the AnnotationController of events.
Protected method | OnAnnotationCreated | Called when a new annotation has been created by the user.
Protected method | OnClick | Called when a Click event is received from the parent control.
Protected method | OnCurrentLayerChanged | Called when the CurrentLayer property has changed.
Protected method | OnDoubleClick | Called when a DoubleClick event has been received from the parent control.
Protected method | OnHotSpotClicked | Called when a hot spot annotation has been clicked.
Protected method | OnMouseDown | Called when a MouseDown event is received from the parent control.
Protected method | OnMouseMove | Called when a MouseMove event is received from the parent control.
Protected method | OnMouseUp | Called when a MouseUp event is received from the parent control.
Protected method | OnMoving | Called while an annotation is being moved by the user.
Protected method | OnPaint | Called when a Paint event is received from the parent control.
Protected method | OnResizing | Called while an annotation is being resized by the user.
Protected method | OnRotating | Called while the annotation is being rotated by the user.
Protected method | OnScrollPositionChanged | Called when a scroll event has been detected.
Protected method | OnSelectionChanged | Called when an annotation selection has changed.
Public method | Paste | Pastes annotation data from the clipboard into the current layer.
Public method | Refresh | This method will cause the control to redraw itself.
 | RenderAnnotations(AnnotationImage) | Renders the annotations to the supplied image.
Public method | RenderAnnotations(RenderDevice, Graphics) | Renders the annotations to a Graphics object
Public method | RenderAnnotations(RenderDevice, Graphics, LayerAnnotation) | Renders the annotations in a specified layer to a Graphics object.
Public method | ResumePaint | Resumes painting after it has been suspended with SuspendPaint.
Public method | RotateDocument(DocumentRotation) | Rotates all layers in the Layers collection.
Public method | RotateDocument(DocumentRotation, LayerAnnotation) | Rotates the specified layer.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the annotations in 90 degree increments.
Public method | Save(IFormatter) | Saves the annotations to a byte array using the specified formatter.
Public method | Save(Stream, AnnotationDataFormat) | Writes annotation data to the specified stream.
Public method | Save(Stream, IFormatter) | Saves the annotations to a stream using the specified formatter.
Public method | Save(String, AnnotationDataFormat) | Saves the annotations to a file using a predefined formatter.
Public method | Save(String, IFormatter) | Saves the annotations to a file using the specified formatter.
Public method | Save(LayerAnnotation, IFormatter) | Returns a byte array containing the annotation data from a specified LayerAnnotation. This is useful when saving annotation data to be embedded into image metadata.
Public method | Save(Stream, LayerAnnotation, AnnotationDataFormat) | Writes annotation data from a layer into the specified stream.
Public method | Save(Stream, LayerAnnotation, IFormatter) | Saves the specified layer to a stream using the formatter supplied.
Public method | Save(String, LayerAnnotation, AnnotationDataFormat) | Saves a layer to a file using a predefined format.
Public method | Save(String, LayerAnnotation, IFormatter) | Saves a layer to a file using the specified formatter.
Public method | SelectAll | Selects all of the annotations on the current layer or all layers.
Public method | SelectFromBounds(RectangleF, Boolean) | Selects annotations that are partially or fully within a rectangular area.
Public method | SelectFromBounds(LayerAnnotation, RectangleF, Boolean) | Selects annotations from a layer that are without a bounding region.
Public method | SuspendPaint | Use this method to suspend painting any annotations until the ResumePaint method is called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Ungroup | Ungroups the currently selected annotation.
Public method | Ungroup(LayerAnnotation, LayerAnnotation) | Removes annotations from one layer and adds them to another.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.AnnotationFromPoint Method

AnnotationControllerAnnotationFromPoint Method

Used to test if an annotation exists at the specified point in viewer space.
Overload List
 | Name | Description
Public method | AnnotationFromPoint(PointF) | Returns the annotation located at a specific point on the control.
Public method | AnnotationFromPoint(LayerAnnotation, PointF) | Returns the annotation at the specified point of a specified layer.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.AnnotationFromPoint Method (PointF)

AnnotationControllerAnnotationFromPoint Method (PointF)

Returns the annotation located at a specific point on the control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI AnnotationFromPoint(
    PointF vsPoint
)
Public Function AnnotationFromPoint (
    vsPoint As PointF
) As AnnotationUI

Parameters

vsPoint
Type: System.DrawingPointF
The point to search for an annotation. This point should be specified in view space.

Return Value

Type: AnnotationUI
The annotation at the location or null (Nothing in VB) if there is no annotation at that location.
See Also

Reference

AnnotationController Class
AnnotationFromPoint Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.AnnotationFromPoint Method (LayerAnnotation, PointF)

AnnotationControllerAnnotationFromPoint Method (LayerAnnotation, PointF)

Returns the annotation at the specified point of a specified layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI AnnotationFromPoint(
    LayerAnnotation layer,
    PointF vsPoint
)
Public Function AnnotationFromPoint (
    layer As LayerAnnotation,
    vsPoint As PointF
) As AnnotationUI

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to search for annotations.
vsPoint
Type: System.DrawingPointF
The point to search for an annotation. This point should be specified in view space.

Return Value

Type: AnnotationUI
The annotation at the location or null (Nothing in VB) if there is no annotation at that location.
See Also

Reference

AnnotationController Class
AnnotationFromPoint Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.CanPaste Method

AnnotationControllerCanPaste Method

Returns a value indicating whether there is annotation data on the clipboard.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanPaste()
Public Function CanPaste As Boolean

Return Value

Type: Boolean
True if there is annotation data on the clipboard.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.ChangeAnnotationPosition Method

AnnotationControllerChangeAnnotationPosition Method

Used to change the top-down order of the annotations and layers.
Overload List
 | Name | Description
Public method | ChangeAnnotationPosition(ChangePositionMethod) | Changes the position of the selected annotation within the stacking order.
Public method | ChangeAnnotationPosition(AnnotationUI, ChangePositionMethod) | Changes the position of an annotation or layer within the stacking order.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.ChangeAnnotationPosition Method (ChangePositionMethod)

AnnotationControllerChangeAnnotationPosition Method (ChangePositionMethod)

Changes the position of the selected annotation within the stacking order.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeAnnotationPosition(
    ChangePositionMethod method
)
Public Sub ChangeAnnotationPosition (
    method As ChangePositionMethod
)

Parameters

method
Type: Atalasoft.AnnotateChangePositionMethod
The type of reordering to perform.
See Also

Reference

AnnotationController Class
ChangeAnnotationPosition Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.ChangeAnnotationPosition Method (AnnotationUI, ChangePositionMethod)

AnnotationControllerChangeAnnotationPosition Method (AnnotationUI, ChangePositionMethod)

Changes the position of an annotation or layer within the stacking order.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeAnnotationPosition(
    AnnotationUI annotation,
    ChangePositionMethod method
)
Public Sub ChangeAnnotationPosition (
    annotation As AnnotationUI,
    method As ChangePositionMethod
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation or layer to change.
method
Type: Atalasoft.AnnotateChangePositionMethod
The type of ordering to perform.
See Also

Reference

AnnotationController Class
ChangeAnnotationPosition Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.ClearSelection Method

AnnotationControllerClearSelection Method

Unselects all of the selected annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearSelection()
Public Sub ClearSelection
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Clone Method

AnnotationControllerClone Method

Creates a copy of the AnnotationController including all of the layers and annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clone()
Public Sub Clone

Return Value

Type:
A copy of the AnnotationController.
Remarks
The undo/redo items are not cloned in this process.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Copy Method

AnnotationControllerCopy Method

Copies the selected annotation(s) to the clipboard.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Copy()
Public Sub Copy
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.CountAnnotations Method

AnnotationControllerCountAnnotations Method

These methods are used to count the number of annotations in all layers or only a specified layer.
Overload List
 | Name | Description
Public method | CountAnnotations | Returns the number of annotations in all of the layers.
Public method | CountAnnotations(LayerAnnotation) | Returns the number of annotations in the provided layer.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.CountAnnotations Method

AnnotationControllerCountAnnotations Method

Returns the number of annotations in all of the layers.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CountAnnotations()
Public Function CountAnnotations As Integer

Return Value

Type: Int32
The number of annotations in the controller.
Remarks
If a LayerAnnotation is being used as a group it will only count as 1, even though it may contain several child annotations.
See Also

Reference

AnnotationController Class
CountAnnotations Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.CountAnnotations Method (LayerAnnotation)

AnnotationControllerCountAnnotations Method (LayerAnnotation)

Returns the number of annotations in the provided layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CountAnnotations(
    LayerAnnotation layer
)
Public Function CountAnnotations (
    layer As LayerAnnotation
) As Integer

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to count.

Return Value

Type: Int32
The number of annotations in the layer.
Remarks
If a LayerAnnotation is being used as a group it will only count as 1, even though it may contain several child annotations.
See Also

Reference

AnnotationController Class
CountAnnotations Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.CreateAnnotation Method

AnnotationControllerCreateAnnotation Method

Overload List
 | Name | Description
 | CreateAnnotation(AnnotationUI) | Call this method to prepare the AnnotationController for creating a new annotation with the mouse.
Public method | CreateAnnotation(AnnotationUI, CreateAnnotationMode) | Call this method to prepare the AnnotationController for creating a new annotation with the mouse, specifying the creation mode to use.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.CreateAnnotation Method (AnnotationUI)

AnnotationControllerCreateAnnotation Method (AnnotationUI)

Call this method to prepare the AnnotationController for creating a new annotation with the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CreateAnnotation(
    AnnotationUI annotation
)
Public Sub CreateAnnotation (
    annotation As AnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to create.
Remarks
Use the ExitCreateMode method to cancel creating an annotation.
Examples
The following example creates a new ReferencedImageAnnotation and prepares the AnnotationController to render the annotation when the user drags the mouse on the AnnotateViewer.
CreateAnnotation
Copy
OpenFileDialog dlg = new OpenFileDialog();
dlg.Filter = "Images|*.bmp;*.jpg;*.png;*.tif;*.gif";
if (dlg.ShowDialog(this) == DialogResult.OK)
{
    ReferencedImageAnnotation ann = new ReferencedImageAnnotation(dlg.FileName, true);
    this.annotateViewer1.Annotations.CreateAnnotation(ann);
}
dlg.Dispose();
CreateAnnotationVB
Copy
Dim dlg As OpenFileDialog =  New OpenFileDialog()
dlg.Filter = "Images|*.bmp;*.jpg;*.png;*.tif;*.gif"
If dlg.ShowDialog(Me) = DialogResult.OK Then
    Dim ann As ReferencedImageAnnotation =  New ReferencedImageAnnotation(dlg.FileName,True)
    Me.annotateViewer1.Annotations.CreateAnnotation(ann)
End If
dlg.Dispose()
See Also

Reference

AnnotationController Class
CreateAnnotation Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.CreateAnnotation Method (AnnotationUI, CreateAnnotationMode)

AnnotationControllerCreateAnnotation Method (AnnotationUI, CreateAnnotationMode)

Call this method to prepare the AnnotationController for creating a new annotation with the mouse, specifying the creation mode to use.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CreateAnnotation(
    AnnotationUI annotation,
    CreateAnnotationMode createMode
)
Public Sub CreateAnnotation (
    annotation As AnnotationUI,
    createMode As CreateAnnotationMode
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to create.
createMode
Type: Atalasoft.AnnotateCreateAnnotationMode
The mode used to create the annotation.
See Also

Reference

AnnotationController Class
CreateAnnotation Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Cut Method

AnnotationControllerCut Method

Cuts the selected annotation(s) and places them onto the clipboard.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Cut()
Public Sub Cut
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Dispose Method

AnnotationControllerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases memory used by the AnnotationController and all of its annotations.
Protected method | Dispose(Boolean) | Releases resources used by the AnnotationController.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Dispose Method

AnnotationControllerDispose Method

Releases memory used by the AnnotationController and all of its annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
All annotations and supporting objects implementing the IDisposeable interface will be disposed in this process. To prevent them from being disposed they must be removed from the controller prior to calling this method.
See Also

Reference

AnnotationController Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Dispose Method (Boolean)

AnnotationControllerDispose Method (Boolean)

Releases resources used by the AnnotationController.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was called from the Dispose method or a finalizer.
See Also

Reference

AnnotationController Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.ExitCreateMode Method

AnnotationControllerExitCreateMode Method

This method will exit 'create mode' started with CreateAnnotation(AnnotationUI).

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ExitCreateMode()
Public Sub ExitCreateMode
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Finalize Method

AnnotationControllerFinalize Method

Finalizes an instance of the AnnotationController class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.FindAnnotationLayer Method

AnnotationControllerFindAnnotationLayer Method

These methods are used to location the parent layer of an annotation.
Overload List
 | Name | Description
Public method | FindAnnotationLayer(AnnotationUI) | Returns the LayerAnnotation containing a specified annotation.
Public method | FindAnnotationLayer(LayerAnnotation, AnnotationUI) | Returns the LayerAnnotation containing a specified annotation.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.FindAnnotationLayer Method (AnnotationUI)

AnnotationControllerFindAnnotationLayer Method (AnnotationUI)

Returns the LayerAnnotation containing a specified annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation FindAnnotationLayer(
    AnnotationUI annotation
)
Public Function FindAnnotationLayer (
    annotation As AnnotationUI
) As LayerAnnotation

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to search for.

Return Value

Type: LayerAnnotation
The LayerAnnotation containing the annotation or null (Nothing in Visual Basic) if the annotation was not found.
Remarks
This method will being searching through all of the layers in the LayerCollection. Use the FindAnnotationLayer(AnnotationUI) overload to specify a LayerAnnotation from which searching will being.
See Also

Reference

AnnotationController Class
FindAnnotationLayer Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.FindAnnotationLayer Method (LayerAnnotation, AnnotationUI)

AnnotationControllerFindAnnotationLayer Method (LayerAnnotation, AnnotationUI)

Returns the LayerAnnotation containing a specified annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation FindAnnotationLayer(
    LayerAnnotation hostLayer,
    AnnotationUI annotation
)
Public Function FindAnnotationLayer (
    hostLayer As LayerAnnotation,
    annotation As AnnotationUI
) As LayerAnnotation

Parameters

hostLayer
Type: Atalasoft.Annotate.UILayerAnnotation
The host layer to being searching from.
annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to search for.

Return Value

Type: LayerAnnotation
The LayerAnnotation containing the annotation or null (Nothing in Visual Basic) if the annotation is not found.
See Also

Reference

AnnotationController Class
FindAnnotationLayer Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.GetTopLevelLayer Method

AnnotationControllerGetTopLevelLayer Method

Returns the top level LayerAnnotation for the supplied annotation. This method will scan through the nested layers until it finds the top most layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation GetTopLevelLayer(
    AnnotationUI annotation
)
Public Function GetTopLevelLayer (
    annotation As AnnotationUI
) As LayerAnnotation

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation where the search will begin.

Return Value

Type: LayerAnnotation
The LayerAnnotation that is loaded in the Layers collection or null (Nothing in VB) if no parent layer is found.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Group Method

AnnotationControllerGroup Method

Use these methods to combine multiple annotations into a group which can be moved and resized together as a single object.
Overload List
 | Name | Description
Public method | Group | Combines all selected annotations into a new LayerAnnotation object and adds this layer to the CurrentLayer.
Public method | Group(AnnotationUI) | Combines annotations into a LayerAnnotation and adds it to the CurrentLayer.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Group Method

AnnotationControllerGroup Method

Combines all selected annotations into a new LayerAnnotation object and adds this layer to the CurrentLayer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Group()
Public Sub Group
See Also

Reference

AnnotationController Class
Group Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Group Method (AnnotationUI[])

AnnotationControllerGroup Method (AnnotationUI)

Combines annotations into a LayerAnnotation and adds it to the CurrentLayer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Group(
    AnnotationUI[] annotations
)
Public Sub Group (
    annotations As AnnotationUI()
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUI
An array of annotations to group.
Remarks
This method will remove the annotations from the current layer they are in and place them into a new LayerAnnotation.
See Also

Reference

AnnotationController Class
Group Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.InvalidateAnnotation Method

AnnotationControllerInvalidateAnnotation Method

Forces an annotation to be redrawn.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void InvalidateAnnotation(
    AnnotationUI annotation
)
Public Sub InvalidateAnnotation (
    annotation As AnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to invalidate.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method

AnnotationControllerLoad Method

Use these methods to load annotation data into the controller.
Overload List
 | Name | Description
Public method | Load(Byte, AnnotationDataFormat) | Loads annotation data from a byte array and adds the annotations to the Layers collection.
Public method | Load(Byte, IFormatter) | Loads annotation data from a byte array using the supplied formatter and adds them to the Layers.
Public method | Load(Stream, AnnotationDataFormat) | Loads annotation data from a stream and adds the annotations to the Layers collection.
Public method | Load(Stream, IFormatter) | Loads annotation data from a stream using the supplied formatter into the Layers collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotation data from a file and adds the annotations to the Layers collection.
Public method | Load(String, IFormatter) | Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.
Public method | Load(Byte, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a byte array and adds the annotations to the specified layer.
Public method | Load(Byte, LayerAnnotation, IFormatter) | Loads annotation data into the specified layer using the provided formatter.
Public method | Load(Stream, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a stream and adds the annotations to the specified layer.
Public method | Load(Stream, LayerAnnotation, IFormatter) | Loads annotation data from a stream using the formatter and adds the annotations to the provided layer.
Public method | Load(String, LayerAnnotation, AnnotationDataFormat) | Loads annotation data from a file and adds the annotations to the specified layer.
Public method | Load(String, LayerAnnotation, IFormatter) | Loads annotation data from a file using the formatter and adds the annotations to the provided layer.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Byte[], AnnotationDataFormat)

AnnotationControllerLoad Method (Byte, AnnotationDataFormat)

Loads annotation data from a byte array and adds the annotations to the Layers collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] annotationData,
    AnnotationDataFormat format
)
Public Sub Load (
    annotationData As Byte(),
    format As AnnotationDataFormat
)

Parameters

annotationData
Type: SystemByte
A byte array containing the annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Byte[], IFormatter)

AnnotationControllerLoad Method (Byte, IFormatter)

Loads annotation data from a byte array using the supplied formatter and adds them to the Layers.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] annotationData,
    IFormatter formatter
)
Public Sub Load (
    annotationData As Byte(),
    formatter As IFormatter
)

Parameters

annotationData
Type: SystemByte
A byte array containing the annotation data.
formatter
Type: System.Runtime.SerializationIFormatter
An IFormatter used to deserialize the data.
Remarks
We strongly recommend do not use standard formatters to load annotations from untrusted sources. You can use one of the following formatters that have passed Veracode scanning:
  • XmpFormatter
  • [!:Atalasoft.Annotate.Formatters.JoltXmpFormatted]
  • WangFormatter
  • LegacyXmpFormatter
Alternatively, custom secure formatter can be created.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Stream, AnnotationDataFormat)

AnnotationControllerLoad Method (Stream, AnnotationDataFormat)

Loads annotation data from a stream and adds the annotations to the Layers collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    AnnotationDataFormat format
)
Public Sub Load (
    stream As Stream,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
A stream containing the annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Stream, IFormatter)

AnnotationControllerLoad Method (Stream, IFormatter)

Loads annotation data from a stream using the supplied formatter into the Layers collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    IFormatter formatter
)
Public Sub Load (
    stream As Stream,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
A stream containing annotation data.
formatter
Type: System.Runtime.SerializationIFormatter
An IFormatter used to deserialize the data.
Remarks
We recommend to ensure that stream is trusted and usage of formatter will not introduce vulnerabilities. You can use one of the following formatters:
  • XmpFormatter
  • [!:Atalasoft.Annotate.Formatters.JoltXmpFormatted]
  • WangFormatter
  • LegacyXmpFormatter
Alternatively, custom secure formatter can be created.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (String, AnnotationDataFormat)

AnnotationControllerLoad Method (String, AnnotationDataFormat)

Loads annotation data from a file and adds the annotations to the Layers collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    AnnotationDataFormat format
)
Public Sub Load (
    fileName As String,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The file containing the annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
FileNotFoundException | Thrown if there is an error reading the data.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (String, IFormatter)

AnnotationControllerLoad Method (String, IFormatter)

Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    IFormatter formatter
)
Public Sub Load (
    fileName As String,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The filename for the annotation data.
formatter
Type: System.Runtime.SerializationIFormatter
An IFormatter used to deserialize the annotation data.
Remarks
We recommend to ensure that file path is trusted and usage of formatter will not introduce vulnerabilities. You can use one of the following formatters:
  • XmpFormatter
  • [!:Atalasoft.Annotate.Formatters.JoltXmpFormatted]
  • WangFormatter
  • LegacyXmpFormatter
Alternatively, custom secure formatter can be created.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Byte[], LayerAnnotation, AnnotationDataFormat)

AnnotationControllerLoad Method (Byte, LayerAnnotation, AnnotationDataFormat)

Loads annotation data from a byte array and adds the annotations to the specified layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] annotationData,
    LayerAnnotation layer,
    AnnotationDataFormat format
)
Public Sub Load (
    annotationData As Byte(),
    layer As LayerAnnotation,
    format As AnnotationDataFormat
)

Parameters

annotationData
Type: SystemByte
A byte array containing the annotation data.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The LayerAnnotation where annotations will be added.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Byte[], LayerAnnotation, IFormatter)

AnnotationControllerLoad Method (Byte, LayerAnnotation, IFormatter)

Loads annotation data into the specified layer using the provided formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] annotationData,
    LayerAnnotation layer,
    IFormatter formatter
)
Public Sub Load (
    annotationData As Byte(),
    layer As LayerAnnotation,
    formatter As IFormatter
)

Parameters

annotationData
Type: SystemByte
A byte array containing the annotation data to read.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to store the annotations.
formatter
Type: System.Runtime.SerializationIFormatter
An IFormatter used to deserialize the annotation data.
Remarks
We strongly recommend do not use standard formatters to load annotations from untrusted sources. You can use one of the following formatters that have passed Veracode scanning:
  • XmpFormatter
  • [!:Atalasoft.Annotate.Formatters.JoltXmpFormatted]
  • WangFormatter
  • LegacyXmpFormatter
Alternatively, custom secure formatter can be created.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Stream, LayerAnnotation, AnnotationDataFormat)

AnnotationControllerLoad Method (Stream, LayerAnnotation, AnnotationDataFormat)

Loads annotation data from a stream and adds the annotations to the specified layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    LayerAnnotation layer,
    AnnotationDataFormat format
)
Public Sub Load (
    stream As Stream,
    layer As LayerAnnotation,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
The stream containing annotation data.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The LayerAnnotation where annotations will be added.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (Stream, LayerAnnotation, IFormatter)

AnnotationControllerLoad Method (Stream, LayerAnnotation, IFormatter)

Loads annotation data from a stream using the formatter and adds the annotations to the provided layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    LayerAnnotation layer,
    IFormatter formatter
)
Public Sub Load (
    stream As Stream,
    layer As LayerAnnotation,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
A stream containing the annotation data.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
A LayerAnnotation where the annotations will be added.
formatter
Type: System.Runtime.SerializationIFormatter
An IFormatter used to deserialize the annotation data.
Remarks
We strongly recommend do not use standard formatters to load annotations from untrusted sources. You can use one of the following formatters that have passed Veracode scanning:
  • XmpFormatter
  • [!:Atalasoft.Annotate.Formatters.JoltXmpFormatted]
  • WangFormatter
  • LegacyXmpFormatter
Alternatively, custom secure formatter can be created.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (String, LayerAnnotation, AnnotationDataFormat)

AnnotationControllerLoad Method (String, LayerAnnotation, AnnotationDataFormat)

Loads annotation data from a file and adds the annotations to the specified layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    LayerAnnotation layer,
    AnnotationDataFormat format
)
Public Sub Load (
    fileName As String,
    layer As LayerAnnotation,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The file containing the annotation data.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The LayerAnnotation where annotations will be added.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Load Method (String, LayerAnnotation, IFormatter)

AnnotationControllerLoad Method (String, LayerAnnotation, IFormatter)

Loads annotation data from a file using the formatter and adds the annotations to the provided layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    LayerAnnotation layer,
    IFormatter formatter
)
Public Sub Load (
    fileName As String,
    layer As LayerAnnotation,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
A filename for the annotation data.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
A LayerAnnotation where these annotations will be loaded.
formatter
Type: System.Runtime.SerializationIFormatter
An IFormatter used to deserialize the annotation data.
Remarks
We strongly recommend do not use standard formatters to load annotations from untrusted sources. You can use one of the following formatters that have passed Veracode scanning:
  • XmpFormatter
  • [!:Atalasoft.Annotate.Formatters.JoltXmpFormatted]
  • WangFormatter
  • LegacyXmpFormatter
Alternatively, custom secure formatter can be created.
See Also

Reference

AnnotationController Class
Load Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.NotifyController Method

AnnotationControllerNotifyController Method

This method is used by layer and annotation objects to notify the AnnotationController of events.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyController(
    Object sender,
    AnnotationControllerNotificationEventArgs e
)
Public Sub NotifyController (
    sender As Object,
    e As AnnotationControllerNotificationEventArgs
)

Parameters

sender
Type: SystemObject
The object sending this notification.
e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information about this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnAnnotationCreated Method

AnnotationControllerOnAnnotationCreated Method

Called when a new annotation has been created by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationCreated(
    AnnotationEventArgs e
)
Protected Overridable Sub OnAnnotationCreated (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the new annotation.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnClick Method

AnnotationControllerOnClick Method

Called when a Click event is received from the parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnClick(
    AnnotationEventArgs e
)
Protected Overridable Sub OnClick (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation that was clicked.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnCurrentLayerChanged Method

AnnotationControllerOnCurrentLayerChanged Method

Called when the CurrentLayer property has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCurrentLayerChanged(
    EventArgs e
)
Protected Overridable Sub OnCurrentLayerChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnDoubleClick Method

AnnotationControllerOnDoubleClick Method

Called when a DoubleClick event has been received from the parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDoubleClick(
    AnnotationEventArgs e
)
Protected Overridable Sub OnDoubleClick (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnHotSpotClicked Method

AnnotationControllerOnHotSpotClicked Method

Called when a hot spot annotation has been clicked.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnHotSpotClicked(
    AnnotationEventArgs e
)
Protected Overridable Sub OnHotSpotClicked (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the hot spot annotation.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnMouseDown Method

AnnotationControllerOnMouseDown Method

Called when a MouseDown event is received from the parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overridable Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
A AnnotationMouseEventArgs containing information about this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnMouseMove Method

AnnotationControllerOnMouseMove Method

Called when a MouseMove event is received from the parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overridable Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
A AnnotationMouseEventArgs containing information about this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnMouseUp Method

AnnotationControllerOnMouseUp Method

Called when a MouseUp event is received from the parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overridable Sub OnMouseUp (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
A AnnotationMouseEventArgs containing information about this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnMoving Method

AnnotationControllerOnMoving Method

Called while an annotation is being moved by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMoving(
    AnnotationEventArgs e
)
Protected Overridable Sub OnMoving (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnPaint Method

AnnotationControllerOnPaint Method

Called when a Paint event is received from the parent control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPaint(
    PaintEventArgs e
)
Protected Overridable Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs containing information for this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnResizing Method

AnnotationControllerOnResizing Method

Called while an annotation is being resized by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnResizing(
    AnnotationEventArgs e
)
Protected Overridable Sub OnResizing (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnRotating Method

AnnotationControllerOnRotating Method

Called while the annotation is being rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotating(
    AnnotationEventArgs e
)
Protected Overridable Sub OnRotating (
    e As AnnotationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationEventArgs
An AnnotationEventArgs containing the annotation.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnScrollPositionChanged Method

AnnotationControllerOnScrollPositionChanged Method

Called when a scroll event has been detected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnScrollPositionChanged(
    ScrollPositionChangedEventArgs e
)
Protected Overridable Sub OnScrollPositionChanged (
    e As ScrollPositionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIScrollPositionChangedEventArgs
A ScrollPositionChangedEventArgs containing information about this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.OnSelectionChanged Method

AnnotationControllerOnSelectionChanged Method

Called when an annotation selection has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectionChanged(
    EventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Paste Method

AnnotationControllerPaste Method

Pastes annotation data from the clipboard into the current layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Paste()
Public Sub Paste
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Refresh Method

AnnotationControllerRefresh Method

This method will cause the control to redraw itself.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.RenderAnnotations Method

AnnotationControllerRenderAnnotations Method

These methods are used to force the annotations to render onto the specified image or Graphics object.
Overload List
 | Name | Description
 | RenderAnnotations(AnnotationImage) | Renders the annotations to the supplied image.
Public method | RenderAnnotations(RenderDevice, Graphics) | Renders the annotations to a Graphics object
Public method | RenderAnnotations(RenderDevice, Graphics, LayerAnnotation) | Renders the annotations in a specified layer to a Graphics object.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.RenderAnnotations Method (AnnotationImage)

AnnotationControllerRenderAnnotations Method (AnnotationImage)

Renders the annotations to the supplied image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RenderAnnotations(
    AnnotationImage image
)
Public Sub RenderAnnotations (
    image As AnnotationImage
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image that will be rendered onto.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image argument is null (Nothing in VB).
Examples
The following example gets a Bitmap from an AtalaImage, renders the annotations onto the Bitmap and converts it back to an AtalaImage for viewing in an AnnotateViewer.
Render Annotations Example
Copy
// We are only burning the current image.
// Because we can't get a Graphics object from an indexed image
// we may need to convert it to 24-bit.
if (this.annotateViewer1.Image.ColorDepth < 24)
{
    Atalasoft.Imaging.ImageProcessing.ChangePixelFormatCommand cmd = new Atalasoft.Imaging.ImageProcessing.ChangePixelFormatCommand(PixelFormat.Pixel24bppBgr);
    this.annotateViewer1.ApplyCommand(cmd);
}

Bitmap bmp = this.annotateViewer1.Image.ToBitmap();
this.annotateViewer1.Annotations.RenderAnnotations(new AnnotationImage(bmp));
AtalaImage img = AtalaImage.FromBitmap(bmp);

this.annotateViewer1.Image = img;
RenderAnnotationsVB
Copy
' We are only burning the current image.
' Because we can't get a Graphics object from an indexed image
' we may need to convert it to 24-bit.
If Me.annotateViewer1.Image.ColorDepth < 24 Then
    Dim cmd As Atalasoft.Imaging.ImageProcessing.ChangePixelFormatCommand =  New Atalasoft.Imaging.ImageProcessing.ChangePixelFormatCommand(PixelFormat.Pixel24bppBgr)
    Me.annotateViewer1.ApplyCommand(cmd)
End If

Dim bmp As Bitmap =  Me.annotateViewer1.Image.ToBitmap()
Me.annotateViewer1.Annotations.RenderAnnotations(New AnnotationImage(bmp))
Dim img As AtalaImage =  AtalaImage.FromBitmap(bmp)

Me.annotateViewer1.Image = img
See Also

Reference

AnnotationController Class
RenderAnnotations Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.RenderAnnotations Method (RenderDevice, Graphics)

AnnotationControllerRenderAnnotations Method (RenderDevice, Graphics)

Renders the annotations to a Graphics object

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RenderAnnotations(
    RenderDevice device,
    Graphics graphics
)
Public Sub RenderAnnotations (
    device As RenderDevice,
    graphics As Graphics
)

Parameters

device
Type: Atalasoft.AnnotateRenderDevice
Indicates the device that created the Graphics object.
graphics
Type: System.DrawingGraphics
The Graphics object used for rendering.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the graphics object is null (Nothing in VB).
See Also

Reference

AnnotationController Class
RenderAnnotations Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.RenderAnnotations Method (RenderDevice, Graphics, LayerAnnotation)

AnnotationControllerRenderAnnotations Method (RenderDevice, Graphics, LayerAnnotation)

Renders the annotations in a specified layer to a Graphics object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RenderAnnotations(
    RenderDevice device,
    Graphics graphics,
    LayerAnnotation layer
)
Public Sub RenderAnnotations (
    device As RenderDevice,
    graphics As Graphics,
    layer As LayerAnnotation
)

Parameters

device
Type: Atalasoft.AnnotateRenderDevice
Indicates the device that created the Graphics object.
graphics
Type: System.DrawingGraphics
The Graphics object used for rendering.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to render.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the graphics or layer arguments are null (Nothing in VB).
See Also

Reference

AnnotationController Class
RenderAnnotations Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.ResumePaint Method

AnnotationControllerResumePaint Method

Resumes painting after it has been suspended with SuspendPaint.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ResumePaint(
    bool forceRefresh
)
Public Sub ResumePaint (
    forceRefresh As Boolean
)

Parameters

forceRefresh
Type: SystemBoolean
Indicates whether the AnnotationController should force a refresh.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.RotateDocument Method

AnnotationControllerRotateDocument Method

Rotates the annotations in one or all layers.
Overload List
 | Name | Description
Public method | RotateDocument(DocumentRotation) | Rotates all layers in the Layers collection.
Public method | RotateDocument(DocumentRotation, LayerAnnotation) | Rotates the specified layer.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the annotations in 90 degree increments.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.RotateDocument Method (DocumentRotation)

AnnotationControllerRotateDocument Method (DocumentRotation)

Rotates all layers in the Layers collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation
)
Public Sub RotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation amount.
Remarks
If the annotation has a Translucent property set to true or its CanRotate property set to false, its location will change but it will not rotate.
See Also

Reference

AnnotationController Class
RotateDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.RotateDocument Method (DocumentRotation, LayerAnnotation)

AnnotationControllerRotateDocument Method (DocumentRotation, LayerAnnotation)

Rotates the specified layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    LayerAnnotation layer
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layer As LayerAnnotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to rotate.
Exceptions
Exception | Condition
 | Thrown if the layer is null (Nothing in VB).
Remarks
If the annotation has a Translucent property set to true or its CanRotate property set to false, its location will change but it will not rotate.
See Also

Reference

AnnotationController Class
RotateDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.RotateDocument Method (DocumentRotation, Int32)

AnnotationControllerRotateDocument Method (DocumentRotation, Int32)

Rotates the annotations in 90 degree increments.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    int layerIndex
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layerIndex As Integer
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation.
layerIndex
Type: SystemInt32
The index of the layer to rotate.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the layer index is invalid for the Layers collection.
Remarks
If the annotation has a Translucent property set to true or its CanRotate property set to false, its location will change but it will not rotate.
See Also

Reference

AnnotationController Class
RotateDocument Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method

AnnotationControllerSave Method

Use these methods to save the annotations into the specified format.
Overload List
 | Name | Description
Public method | Save(IFormatter) | Saves the annotations to a byte array using the specified formatter.
Public method | Save(Stream, AnnotationDataFormat) | Writes annotation data to the specified stream.
Public method | Save(Stream, IFormatter) | Saves the annotations to a stream using the specified formatter.
Public method | Save(String, AnnotationDataFormat) | Saves the annotations to a file using a predefined formatter.
Public method | Save(String, IFormatter) | Saves the annotations to a file using the specified formatter.
Public method | Save(LayerAnnotation, IFormatter) | Returns a byte array containing the annotation data from a specified LayerAnnotation. This is useful when saving annotation data to be embedded into image metadata.
Public method | Save(Stream, LayerAnnotation, AnnotationDataFormat) | Writes annotation data from a layer into the specified stream.
Public method | Save(Stream, LayerAnnotation, IFormatter) | Saves the specified layer to a stream using the formatter supplied.
Public method | Save(String, LayerAnnotation, AnnotationDataFormat) | Saves a layer to a file using a predefined format.
Public method | Save(String, LayerAnnotation, IFormatter) | Saves a layer to a file using the specified formatter.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (IFormatter)

AnnotationControllerSave Method (IFormatter)

Saves the annotations to a byte array using the specified formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Save(
    IFormatter formatter
)
Public Function Save (
    formatter As IFormatter
) As Byte()

Parameters

formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to serialize the annotation data.

Return Value

Type: Byte
A byte array containing the serialized data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (Stream, AnnotationDataFormat)

AnnotationControllerSave Method (Stream, AnnotationDataFormat)

Writes annotation data to the specified stream.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    AnnotationDataFormat format
)
Public Sub Save (
    stream As Stream,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
The stream where data will be stored.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format used to save the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (Stream, IFormatter)

AnnotationControllerSave Method (Stream, IFormatter)

Saves the annotations to a stream using the specified formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    IFormatter formatter
)
Public Sub Save (
    stream As Stream,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
A stream where the data will be stored.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used for serializing the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (String, AnnotationDataFormat)

AnnotationControllerSave Method (String, AnnotationDataFormat)

Saves the annotations to a file using a predefined formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    AnnotationDataFormat format
)
Public Sub Save (
    fileName As String,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The full path and filename that will be created.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format used to save the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (String, IFormatter)

AnnotationControllerSave Method (String, IFormatter)

Saves the annotations to a file using the specified formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    IFormatter formatter
)
Public Sub Save (
    fileName As String,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The full path and filename that will be created.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter use to serialize the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (LayerAnnotation, IFormatter)

AnnotationControllerSave Method (LayerAnnotation, IFormatter)

Returns a byte array containing the annotation data from a specified LayerAnnotation. This is useful when saving annotation data to be embedded into image metadata.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Save(
    LayerAnnotation layer,
    IFormatter formatter
)
Public Function Save (
    layer As LayerAnnotation,
    formatter As IFormatter
) As Byte()

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The LayerAnnotation containing the annotations to save.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to convert the annotation data.

Return Value

Type: Byte
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (Stream, LayerAnnotation, AnnotationDataFormat)

AnnotationControllerSave Method (Stream, LayerAnnotation, AnnotationDataFormat)

Writes annotation data from a layer into the specified stream.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    LayerAnnotation layer,
    AnnotationDataFormat format
)
Public Sub Save (
    stream As Stream,
    layer As LayerAnnotation,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
The stream where annotation data will be stored.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The LayerAnnotation that will be saved.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format used when saving the annotation data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (Stream, LayerAnnotation, IFormatter)

AnnotationControllerSave Method (Stream, LayerAnnotation, IFormatter)

Saves the specified layer to a stream using the formatter supplied.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    LayerAnnotation layer,
    IFormatter formatter
)
Public Sub Save (
    stream As Stream,
    layer As LayerAnnotation,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
The stream where data will be stored.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to save.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to serialize the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (String, LayerAnnotation, AnnotationDataFormat)

AnnotationControllerSave Method (String, LayerAnnotation, AnnotationDataFormat)

Saves a layer to a file using a predefined format.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    LayerAnnotation layer,
    AnnotationDataFormat format
)
Public Sub Save (
    fileName As String,
    layer As LayerAnnotation,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The full path and filename that will be created.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to save.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format used to save the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Save Method (String, LayerAnnotation, IFormatter)

AnnotationControllerSave Method (String, LayerAnnotation, IFormatter)

Saves a layer to a file using the specified formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    LayerAnnotation layer,
    IFormatter formatter
)
Public Sub Save (
    fileName As String,
    layer As LayerAnnotation,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The full path and filename that will be created.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to save.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to serialize the data.
See Also

Reference

AnnotationController Class
Save Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.SelectAll Method

AnnotationControllerSelectAll Method

Selects all of the annotations on the current layer or all layers.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAll(
    bool allLayers
)
Public Sub SelectAll (
    allLayers As Boolean
)

Parameters

allLayers
Type: SystemBoolean
Indicates whether to select annotations on all of the layers. If this is false, only the current layer annotations are selected.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.SelectFromBounds Method

AnnotationControllerSelectFromBounds Method

Use these methods to select annotations from a rectangle specifying the bounds in document space.
Overload List
 | Name | Description
Public method | SelectFromBounds(RectangleF, Boolean) | Selects annotations that are partially or fully within a rectangular area.
Public method | SelectFromBounds(LayerAnnotation, RectangleF, Boolean) | Selects annotations from a layer that are without a bounding region.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.SelectFromBounds Method (RectangleF, Boolean)

AnnotationControllerSelectFromBounds Method (RectangleF, Boolean)

Selects annotations that are partially or fully within a rectangular area.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectFromBounds(
    RectangleF bounds,
    bool fullyContained
)
Public Sub SelectFromBounds (
    bounds As RectangleF,
    fullyContained As Boolean
)

Parameters

bounds
Type: System.DrawingRectangleF
The bounding rectangle to look for annotations. This value must be specified in document space.
fullyContained
Type: SystemBoolean
Indicates if the annotation has to be fully within the bounds before it's selected.
See Also

Reference

AnnotationController Class
SelectFromBounds Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.SelectFromBounds Method (LayerAnnotation, RectangleF, Boolean)

AnnotationControllerSelectFromBounds Method (LayerAnnotation, RectangleF, Boolean)

Selects annotations from a layer that are without a bounding region.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectFromBounds(
    LayerAnnotation layer,
    RectangleF bounds,
    bool fullyContained
)
Public Sub SelectFromBounds (
    layer As LayerAnnotation,
    bounds As RectangleF,
    fullyContained As Boolean
)

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to search for annotations.
bounds
Type: System.DrawingRectangleF
The bounding rectangle to search. This value must be specified in document space.
fullyContained
Type: SystemBoolean
Indicates if the annotation has to be fully within the bounds before it's selected.
See Also

Reference

AnnotationController Class
SelectFromBounds Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.SuspendPaint Method

AnnotationControllerSuspendPaint Method

Use this method to suspend painting any annotations until the ResumePaint method is called.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SuspendPaint()
Public Sub SuspendPaint
Remarks
This method is useful when multiple annotations or multiple properties of an annotation are being modified for a single action. Use ResumePaint to allow rendering of the annotations to resume.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Ungroup Method

AnnotationControllerUngroup Method

Use these methods to separate annotations that are combined into a group.
Overload List
 | Name | Description
Public method | Ungroup | Ungroups the currently selected annotation.
Public method | Ungroup(LayerAnnotation, LayerAnnotation) | Removes annotations from one layer and adds them to another.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Ungroup Method

AnnotationControllerUngroup Method

Ungroups the currently selected annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Ungroup()
Public Sub Ungroup
Remarks
This method will do nothing if the currently selected annotation is not a group.
See Also

Reference

AnnotationController Class
Ungroup Overload
Atalasoft.Annotate.UI Namespace


AnnotationController.Ungroup Method (LayerAnnotation, LayerAnnotation)

AnnotationControllerUngroup Method (LayerAnnotation, LayerAnnotation)

Removes annotations from one layer and adds them to another.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Ungroup(
    LayerAnnotation groupLayer,
    LayerAnnotation hostLayer
)
Public Sub Ungroup (
    groupLayer As LayerAnnotation,
    hostLayer As LayerAnnotation
)

Parameters

groupLayer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer containing annotations to ungroup.
hostLayer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer where annotation will be added.
Remarks
If the groupLayer is contained within a layer currently in the LayerCollection it will be removed from the collection.
See Also

Reference

AnnotationController Class
Ungroup Overload
Atalasoft.Annotate.UI Namespace


AnnotationController Events

The AnnotationController type exposes the following members.

Events
 | Name | Description
Public event | AnnotationCreated | Raised when an annotation is created by the user.
Public event | AnnotationDeserialization | Raised when an object is deserialized to allow developers to cancel or modify the object before its added into the controller.
Public event | Click | Raised when an annotation is clicked with the mouse.
Public event | CurrentLayerChanged | Raised when the CurrentLayer property has changed.
Public event | Disposed | Raised when the AnnotationController has been disposed.
Public event | DoubleClick | Raised when an annotation is double-clicked by the user.
Public event | HotSpotClicked | Raised when a hot spot annotation is clicked.
Public event | Moved | Raised when an annotation is moved.
Public event | Moving | Raised while an annotation is being moved.
Public event | Resized | Raised when an annotation is resized.
Public event | Resizing | Raised while an annotation is being resized.
Public event | Rotated | Raised when an annotation is rotated by the user.
Public event | Rotating | Raised while an annotation is being rotated by the user.
Public event | SelectionChanged | Raise when there has been a change in the annotation selection.
Top
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.AnnotationCreated Event

AnnotationControllerAnnotationCreated Event

Raised when an annotation is created by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler AnnotationCreated
Public Event AnnotationCreated As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
Remarks
This event is only raised when an annotation is added by the user drawing it with the mouse. Adding annotations to a LayerAnnotation will not raise this event.
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.AnnotationDeserialization Event

AnnotationControllerAnnotationDeserialization Event

Raised when an object is deserialized to allow developers to cancel or modify the object before its added into the controller.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationDeserializationEventHandler AnnotationDeserialization
Public Event AnnotationDeserialization As AnnotationDeserializationEventHandler

Value

Type: Atalasoft.Annotate.FormattersAnnotationDeserializationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Click Event

AnnotationControllerClick Event

Raised when an annotation is clicked with the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Click
Public Event Click As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.CurrentLayerChanged Event

AnnotationControllerCurrentLayerChanged Event

Raised when the CurrentLayer property has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CurrentLayerChanged
Public Event CurrentLayerChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Disposed Event

AnnotationControllerDisposed Event

Raised when the AnnotationController has been disposed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler

Value

Type: SystemEventHandler

Implements

IComponentDisposed
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.DoubleClick Event

AnnotationControllerDoubleClick Event

Raised when an annotation is double-clicked by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler DoubleClick
Public Event DoubleClick As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.HotSpotClicked Event

AnnotationControllerHotSpotClicked Event

Raised when a hot spot annotation is clicked.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler HotSpotClicked
Public Event HotSpotClicked As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Moved Event

AnnotationControllerMoved Event

Raised when an annotation is moved.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Moved
Public Event Moved As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Moving Event

AnnotationControllerMoving Event

Raised while an annotation is being moved.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Moving
Public Event Moving As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Resized Event

AnnotationControllerResized Event

Raised when an annotation is resized.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Resized
Public Event Resized As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Resizing Event

AnnotationControllerResizing Event

Raised while an annotation is being resized.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Resizing
Public Event Resizing As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Rotated Event

AnnotationControllerRotated Event

Raised when an annotation is rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Rotated
Public Event Rotated As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.Rotating Event

AnnotationControllerRotating Event

Raised while an annotation is being rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationEventHandler Rotating
Public Event Rotating As AnnotationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationController.SelectionChanged Event

AnnotationControllerSelectionChanged Event

Raise when there has been a change in the annotation selection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationController Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors Class

AnnotationCursors is a used to hold all of the Cursor objects for the annotations. This simplifies changing the appearance of the cursors.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationCursors

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class AnnotationCursors
Public NotInheritable Class AnnotationCursors

The AnnotationCursors type exposes the following members.

Properties
Name | Description
DefaultCursor | Gets or sets the default cursor used when the pointer is not over an annotation or grip.
EastWestCursor | Gets or sets the cursor used when over the left or right center grip.
HotSpotCursor | Gets or sets the cursor used for hot spots. This is only shown when InteractMode is set to View.
MoveCursor | Gets or sets the cursor used to indicate a move operation.
NortheastSouthwestCursor | Gets or sets the cursor used for the top-right and bottom-left grips.
NorthSouthCursor | Gets or sets the cursor used for the top and bottom center grips.
NorthwestSoutheastCursor | Gets or sets the cursor used for the top-left and bottom-right grips.
RotateCursor | Gets or sets the cursor used for the rotation grip.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationCursors Properties

The AnnotationCursors type exposes the following members.

Properties
Name | Description
DefaultCursor | Gets or sets the default cursor used when the pointer is not over an annotation or grip.
EastWestCursor | Gets or sets the cursor used when over the left or right center grip.
HotSpotCursor | Gets or sets the cursor used for hot spots. This is only shown when InteractMode is set to View.
MoveCursor | Gets or sets the cursor used to indicate a move operation.
NortheastSouthwestCursor | Gets or sets the cursor used for the top-right and bottom-left grips.
NorthSouthCursor | Gets or sets the cursor used for the top and bottom center grips.
NorthwestSoutheastCursor | Gets or sets the cursor used for the top-left and bottom-right grips.
RotateCursor | Gets or sets the cursor used for the rotation grip.
Top
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.DefaultCursor Property

AnnotationCursorsDefaultCursor Property

Gets or sets the default cursor used when the pointer is not over an annotation or grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor DefaultCursor { get; set; }
Public Shared Property DefaultCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The default cursor.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.EastWestCursor Property

AnnotationCursorsEastWestCursor Property

Gets or sets the cursor used when over the left or right center grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor EastWestCursor { get; set; }
Public Shared Property EastWestCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor for the left and right center grip.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.HotSpotCursor Property

AnnotationCursorsHotSpotCursor Property

Gets or sets the cursor used for hot spots. This is only shown when InteractMode is set to View.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor HotSpotCursor { get; set; }
Public Shared Property HotSpotCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used for hot spots.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.MoveCursor Property

AnnotationCursorsMoveCursor Property

Gets or sets the cursor used to indicate a move operation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor MoveCursor { get; set; }
Public Shared Property MoveCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used for moving.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.NortheastSouthwestCursor Property

AnnotationCursorsNortheastSouthwestCursor Property

Gets or sets the cursor used for the top-right and bottom-left grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor NortheastSouthwestCursor { get; set; }
Public Shared Property NortheastSouthwestCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used for the top-right and bottom-left grips.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.NorthSouthCursor Property

AnnotationCursorsNorthSouthCursor Property

Gets or sets the cursor used for the top and bottom center grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor NorthSouthCursor { get; set; }
Public Shared Property NorthSouthCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor for the top and bottom center grips.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.NorthwestSoutheastCursor Property

AnnotationCursorsNorthwestSoutheastCursor Property

Gets or sets the cursor used for the top-left and bottom-right grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor NorthwestSoutheastCursor { get; set; }
Public Shared Property NorthwestSoutheastCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used for the top-left and bottom-right grips.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors.RotateCursor Property

AnnotationCursorsRotateCursor Property

Gets or sets the cursor used for the rotation grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor RotateCursor { get; set; }
Public Shared Property RotateCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used for the rotation grip.
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationCursors Methods

The AnnotationCursors type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationCursors Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip Class

This class represents a single grip. To access these grip objects use the Grips property of the annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationGrip

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationGrip
Public Class AnnotationGrip

The AnnotationGrip type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationGrip | Creates a new instance of AnnotationGrip.
Public method | AnnotationGrip(PointF, AnnotationGripState) | Creates a new instance of AnnotationGrip specifying the grip position and state.
Public method | AnnotationGrip(PointF, AnnotationGripState, AnnotationGripAction) | Creates a new instance of AnnotationGrip specifying the grip position, state and its action.
Top
Properties
 | Name | Description
Public property | Action | Gets or sets the action to take when the grip is dragged with the mouse.
Public property | Position | Gets or sets the position of the grip in annotation space.
Public property | State | Gets or sets the state of the grip.
Public property | Visible | Gets or sets the visibility of the grip.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationGrip Constructor

Creates a single annotation grip.
Overload List
 | Name | Description
Public method | AnnotationGrip | Creates a new instance of AnnotationGrip.
Public method | AnnotationGrip(PointF, AnnotationGripState) | Creates a new instance of AnnotationGrip specifying the grip position and state.
Public method | AnnotationGrip(PointF, AnnotationGripState, AnnotationGripAction) | Creates a new instance of AnnotationGrip specifying the grip position, state and its action.
Top
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip Constructor

Creates a new instance of AnnotationGrip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGrip()
Public Sub New
See Also

Reference

AnnotationGrip Class
AnnotationGrip Overload
Atalasoft.Annotate.UI Namespace


AnnotationGrip Constructor (PointF, AnnotationGripState)

Creates a new instance of AnnotationGrip specifying the grip position and state.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGrip(
    PointF position,
    AnnotationGripState state
)
Public Sub New (
    position As PointF,
    state As AnnotationGripState
)

Parameters

position
Type: System.DrawingPointF
The position of the grip in annotation space.
state
Type: Atalasoft.AnnotateAnnotationGripState
The initial state of the grip.
See Also

Reference

AnnotationGrip Class
AnnotationGrip Overload
Atalasoft.Annotate.UI Namespace


AnnotationGrip Constructor (PointF, AnnotationGripState, AnnotationGripAction)

Creates a new instance of AnnotationGrip specifying the grip position, state and its action.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGrip(
    PointF position,
    AnnotationGripState state,
    AnnotationGripAction action
)
Public Sub New (
    position As PointF,
    state As AnnotationGripState,
    action As AnnotationGripAction
)

Parameters

position
Type: System.DrawingPointF
The position of the grip in annotation space.
state
Type: Atalasoft.AnnotateAnnotationGripState
The initial state of the grip.
action
Type: Atalasoft.AnnotateAnnotationGripAction
Defines the action to take when this grip is dragged with the mouse.
See Also

Reference

AnnotationGrip Class
AnnotationGrip Overload
Atalasoft.Annotate.UI Namespace


AnnotationGrip Properties

The AnnotationGrip type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets or sets the action to take when the grip is dragged with the mouse.
Public property | Position | Gets or sets the position of the grip in annotation space.
Public property | State | Gets or sets the state of the grip.
Public property | Visible | Gets or sets the visibility of the grip.
Top
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip.Action Property

AnnotationGripAction Property

Gets or sets the action to take when the grip is dragged with the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGripAction Action { get; set; }
Public Property Action As AnnotationGripAction
    Get
    Set

Property Value

Type: AnnotationGripAction
The grip action.
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip.Position Property

AnnotationGripPosition Property

Gets or sets the position of the grip in annotation space.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Position { get; set; }
Public Property Position As PointF
    Get
    Set

Property Value

Type: PointF
The position of the grip in annotation space.
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip.State Property

AnnotationGripState Property

Gets or sets the state of the grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGripState State { get; set; }
Public Property State As AnnotationGripState
    Get
    Set

Property Value

Type: AnnotationGripState
The grip state.
Remarks
This is useful is the IAnnotationGripRenderer being used renders the grips differently based on its state.
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip.Visible Property

AnnotationGripVisible Property

Gets or sets the visibility of the grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the grip is visible.
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGrip Methods

The AnnotationGrip type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationGrip Class
Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs Class

This class is used to with the GripPositionChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UIAnnotationGripChangedEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationGripChangedEventArgs : EventArgs
Public Class AnnotationGripChangedEventArgs
    Inherits EventArgs

The AnnotationGripChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationGripChangedEventArgs | Creates a new instance of AnnotationGripChangedEventArgs.
Top
Properties
 | Name | Description
Public property | Confinement | Gets the viewer confinement rectangle.
Public property | Grip | Gets the grip being modified.
Public property | NewPosition | Gets the new location for the grip in annotation space.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs Constructor

Creates a new instance of AnnotationGripChangedEventArgs.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGripChangedEventArgs(
    AnnotationGrip grip,
    PointF newPosition,
    RectangleF confinement
)
Public Sub New (
    grip As AnnotationGrip,
    newPosition As PointF,
    confinement As RectangleF
)

Parameters

grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The grip being modified.
newPosition
Type: System.DrawingPointF
The new position of the grip in annotation space.
confinement
Type: System.DrawingRectangleF
The viewer confinement rectangle.
See Also

Reference

AnnotationGripChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs Properties

The AnnotationGripChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Confinement | Gets the viewer confinement rectangle.
Public property | Grip | Gets the grip being modified.
Public property | NewPosition | Gets the new location for the grip in annotation space.
Top
See Also

Reference

AnnotationGripChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs.Confinement Property

AnnotationGripChangedEventArgsConfinement Property

Gets the viewer confinement rectangle.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Confinement { get; }
Public ReadOnly Property Confinement As RectangleF
    Get

Property Value

Type: RectangleF
The viewer confinement rectangle.
See Also

Reference

AnnotationGripChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs.Grip Property

AnnotationGripChangedEventArgsGrip Property

Gets the grip being modified.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGrip Grip { get; set; }
Public Property Grip As AnnotationGrip
    Get
    Set

Property Value

Type: AnnotationGrip
The grip being modified.
See Also

Reference

AnnotationGripChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs.NewPosition Property

AnnotationGripChangedEventArgsNewPosition Property

Gets the new location for the grip in annotation space.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF NewPosition { get; }
Public ReadOnly Property NewPosition As PointF
    Get

Property Value

Type: PointF
The new location for the grip.
See Also

Reference

AnnotationGripChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationGripChangedEventArgs Methods

The AnnotationGripChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationGripChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKey Class

This class is used with the AnnotationKeyBinder to define the action or handler to call when a specific key is pressed.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationKey

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationKey
Public Class AnnotationKey

The AnnotationKey type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationKey | Creates a new instance of AnnotationKey.
Public method | AnnotationKey(AnnotationKeyAction) | Creates a new instance of AnnotationKey specifying its action.
Public method | AnnotationKey(AnnotationKeyAction, AnnotationKeyEventHandler) | Creates a new instance of AnnotationKey specifying the action and event handler of the key event.
Top
Properties
 | Name | Description
Public property | Action | Gets or sets the action for this key.
Public property | Handler | Gets or sets the AnnotationKeyEventHandler that will be called to perform the action.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationKey Constructor

Constructs an AnnotationKey.
Overload List
 | Name | Description
Public method | AnnotationKey | Creates a new instance of AnnotationKey.
Public method | AnnotationKey(AnnotationKeyAction) | Creates a new instance of AnnotationKey specifying its action.
Public method | AnnotationKey(AnnotationKeyAction, AnnotationKeyEventHandler) | Creates a new instance of AnnotationKey specifying the action and event handler of the key event.
Top
See Also

Reference

AnnotationKey Class
Atalasoft.Annotate.UI Namespace


AnnotationKey Constructor

Creates a new instance of AnnotationKey.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKey()
Public Sub New
See Also

Reference

AnnotationKey Class
AnnotationKey Overload
Atalasoft.Annotate.UI Namespace


AnnotationKey Constructor (AnnotationKeyAction)

Creates a new instance of AnnotationKey specifying its action.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKey(
    AnnotationKeyAction action
)
Public Sub New (
    action As AnnotationKeyAction
)

Parameters

action
Type: Atalasoft.Annotate.UIAnnotationKeyAction
The action to take when the key is pressed.
See Also

Reference

AnnotationKey Class
AnnotationKey Overload
Atalasoft.Annotate.UI Namespace


AnnotationKey Constructor (AnnotationKeyAction, AnnotationKeyEventHandler)

Creates a new instance of AnnotationKey specifying the action and event handler of the key event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKey(
    AnnotationKeyAction action,
    AnnotationKeyEventHandler handler
)
Public Sub New (
    action As AnnotationKeyAction,
    handler As AnnotationKeyEventHandler
)

Parameters

action
Type: Atalasoft.Annotate.UIAnnotationKeyAction
The action to take when the key is pressed.
handler
Type: Atalasoft.Annotate.UIAnnotationKeyEventHandler
An AnnotationKeyEventHandler called to perform this action.
See Also

Reference

AnnotationKey Class
AnnotationKey Overload
Atalasoft.Annotate.UI Namespace


AnnotationKey Properties

The AnnotationKey type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets or sets the action for this key.
Public property | Handler | Gets or sets the AnnotationKeyEventHandler that will be called to perform the action.
Top
See Also

Reference

AnnotationKey Class
Atalasoft.Annotate.UI Namespace


AnnotationKey.Action Property

AnnotationKeyAction Property

Gets or sets the action for this key.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKeyAction Action { get; set; }
Public Property Action As AnnotationKeyAction
    Get
    Set

Property Value

Type: AnnotationKeyAction
The action of the key.
See Also

Reference

AnnotationKey Class
Atalasoft.Annotate.UI Namespace


AnnotationKey.Handler Property

AnnotationKeyHandler Property

Gets or sets the AnnotationKeyEventHandler that will be called to perform the action.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKeyEventHandler Handler { get; set; }
Public Property Handler As AnnotationKeyEventHandler
    Get
    Set

Property Value

Type: AnnotationKeyEventHandler
The handler for this action.
See Also

Reference

AnnotationKey Class
Atalasoft.Annotate.UI Namespace


AnnotationKey Methods

The AnnotationKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationKey Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyAction Enumeration

This enumeration is used to define the actions used with AnnotationKeyBinder.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationKeyAction
Public Enumeration AnnotationKeyAction
Members
Member name | Description
None | No action is taken.
SelectNext | The next annotation in the collection is selected. If the current annotation is the last in the collection, the first annotation will be selected.
SelectPrevious | The previous annotation in the collection is selected. If the current annotation is at index zero, the last annotation in the collection will be selected.
SelectLeft | Selects the annotation who has the next lowest X location value.
SelectRight | Selects the annotation who has the next highest X location value.
SelectAbove | Selects the annotation who has the next lowest Y location value.
SelectBelow | Selects the annotation who has the next highest Y location value.
MoveLeft | Moves the selected annotations to the left.
MoveRight | Moves the selected annotations to the right.
MoveUp | Moves the selected annotations up.
MoveDown | Moves the selected annotations down.
RotateCounterclockwise | Rotates the active annotation counterclockwise.
RotateClockwise | Rotates the active annotation clockwise.
IncreaseWidth | Increases the width of the active annotation.
DecreaseWidth | Decreases the width of the active annotation.
IncreaseHeight | Increases the height of the active annotation.
DecreaseHeight | Decreases the height of the active annotation.
ClearSelection | Unselects all annotations.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationKeyBinder Class

The AnnotationKeyBinder class is used to bind key press events to annotation actions.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationKeyBinder

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationKeyBinder
Public Class AnnotationKeyBinder

The AnnotationKeyBinder type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationKeyBinder | Creates a new instance of AnnotationKeyBinder.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the AnnotationKey with the specified key.
Top
Methods
 | Name | Description
Public method | Contains | Returns a value indicating if the AnnotationKeyBinder contains a specific key.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationKeyBinder Constructor

Creates a new instance of AnnotationKeyBinder.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKeyBinder()
Public Sub New
See Also

Reference

AnnotationKeyBinder Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyBinder Properties

The AnnotationKeyBinder type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the AnnotationKey with the specified key.
Top
See Also

Reference

AnnotationKeyBinder Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyBinder.Item Property

AnnotationKeyBinderItem Property

Gets or sets the AnnotationKey with the specified key.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKey this[
    Keys key
] { get; set; }
Public Default Property Item (
    key As Keys
) As AnnotationKey
    Get
    Set

Parameters

key
Type: System.Windows.FormsKeys
The key.

Property Value

Type: AnnotationKey
The AnnotationKey.

Return Value

Type: AnnotationKey
See Also

Reference

AnnotationKeyBinder Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyBinder Methods

The AnnotationKeyBinder type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns a value indicating if the AnnotationKeyBinder contains a specific key.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationKeyBinder Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyBinder.Contains Method

AnnotationKeyBinderContains Method

Returns a value indicating if the AnnotationKeyBinder contains a specific key.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    Keys key
)
Public Function Contains (
    key As Keys
) As Boolean

Parameters

key
Type: System.Windows.FormsKeys
The key to search for.

Return Value

Type: Boolean
True if the AnnotationKeyBinder contains the specified key.
See Also

Reference

AnnotationKeyBinder Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs Class

This class is sent to the AnnotationKey handler during a key press event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UIAnnotationKeyEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationKeyEventArgs : EventArgs
Public Class AnnotationKeyEventArgs
    Inherits EventArgs

The AnnotationKeyEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationKeyEventArgs | Creates a new instance of AnnotationKeyEventArgs specifying its parameters.
Top
Properties
 | Name | Description
Public property | Action | Gets the action to be taken by this event.
Public property | Annotation | Gets the annotation being modified.
Public property | KeyEventArgs | Gets the KeyEventArgs from the key press event.
Public property | Repeat | Gets a value indicating if this is a repeat event caused by the user holding down a key.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs Constructor

Creates a new instance of AnnotationKeyEventArgs specifying its parameters.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKeyEventArgs(
    AnnotationUI annotation,
    AnnotationKeyAction action,
    bool repeat,
    KeyEventArgs e
)
Public Sub New (
    annotation As AnnotationUI,
    action As AnnotationKeyAction,
    repeat As Boolean,
    e As KeyEventArgs
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation being affected by this event.
action
Type: Atalasoft.Annotate.UIAnnotationKeyAction
The action to take.
repeat
Type: SystemBoolean
Indicates whether this is a repeat event caused from a key being held down.
e
Type: System.Windows.FormsKeyEventArgs
The KeyEventArgs from the key press event.
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs Properties

The AnnotationKeyEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets the action to be taken by this event.
Public property | Annotation | Gets the annotation being modified.
Public property | KeyEventArgs | Gets the KeyEventArgs from the key press event.
Public property | Repeat | Gets a value indicating if this is a repeat event caused by the user holding down a key.
Top
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs.Action Property

AnnotationKeyEventArgsAction Property

Gets the action to be taken by this event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationKeyAction Action { get; }
Public ReadOnly Property Action As AnnotationKeyAction
    Get

Property Value

Type: AnnotationKeyAction
The action to take.
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs.Annotation Property

AnnotationKeyEventArgsAnnotation Property

Gets the annotation being modified.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI Annotation { get; }
Public ReadOnly Property Annotation As AnnotationUI
    Get

Property Value

Type: AnnotationUI
The annotation being modified.
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs.KeyEventArgs Property

AnnotationKeyEventArgsKeyEventArgs Property

Gets the KeyEventArgs from the key press event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public KeyEventArgs KeyEventArgs { get; }
Public ReadOnly Property KeyEventArgs As KeyEventArgs
    Get

Property Value

Type: KeyEventArgs
The KeyEventArgs from this event.
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs.Repeat Property

AnnotationKeyEventArgsRepeat Property

Gets a value indicating if this is a repeat event caused by the user holding down a key.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Repeat { get; }
Public ReadOnly Property Repeat As Boolean
    Get

Property Value

Type: Boolean
Indicates a repeat event from a key being held down.
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventArgs Methods

The AnnotationKeyEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationKeyEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationKeyEventHandler Delegate

This event handler is used with the AnnotationKey class to process key actions.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationKeyEventHandler(
    Object sender,
    AnnotationKeyEventArgs e
)
Public Delegate Sub AnnotationKeyEventHandler (
    sender As Object,
    e As AnnotationKeyEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Annotate.UIAnnotationKeyEventArgs
An AnnotationKeyEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs Class

This class is passed to mouse event handlers.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UIAnnotationMouseEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationMouseEventArgs : EventArgs
Public Class AnnotationMouseEventArgs
    Inherits EventArgs

The AnnotationMouseEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationMouseEventArgs(MouseEventArgs) | Creates a new instance of AnnotationMouseEventArgs from a MouseEventArgs object.
Public method | AnnotationMouseEventArgs(MouseButtons, Int32, Single, Single, Int32) | Creates a new instance of AnnotationMouseEventArgs specifying its parameters.
Top
Properties
 | Name | Description
Public property | Button | Gets which mouse button was pressed.
Public property | Clicks | Gets the number of times the mouse button was pressed and released.
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Public property | Processed | Gets or sets a value indicating whether the event has been handled.
Public property | X | Gets the x-coordinate of the mouse.
Public property | Y | Gets the y-coordinate of the mouse.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs Constructor

Constructs an AnnotationMouseEventArgs.
Overload List
 | Name | Description
Public method | AnnotationMouseEventArgs(MouseEventArgs) | Creates a new instance of AnnotationMouseEventArgs from a MouseEventArgs object.
Public method | AnnotationMouseEventArgs(MouseButtons, Int32, Single, Single, Int32) | Creates a new instance of AnnotationMouseEventArgs specifying its parameters.
Top
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs Constructor (MouseEventArgs)

Creates a new instance of AnnotationMouseEventArgs from a MouseEventArgs object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationMouseEventArgs(
    MouseEventArgs e
)
Public Sub New (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

AnnotationMouseEventArgs Class
AnnotationMouseEventArgs Overload
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs Constructor (MouseButtons, Int32, Single, Single, Int32)

Creates a new instance of AnnotationMouseEventArgs specifying its parameters.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationMouseEventArgs(
    MouseButtons button,
    int clicks,
    float x,
    float y,
    int delta
)
Public Sub New (
    button As MouseButtons,
    clicks As Integer,
    x As Single,
    y As Single,
    delta As Integer
)

Parameters

button
Type: System.Windows.FormsMouseButtons
The mouse button being pressed.
clicks
Type: SystemInt32
The click count.
x
Type: SystemSingle
The x position of the mouse.
y
Type: SystemSingle
The y position of the mouse.
delta
Type: SystemInt32
The delta of the mouse wheel.
See Also

Reference

AnnotationMouseEventArgs Class
AnnotationMouseEventArgs Overload
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs Properties

The AnnotationMouseEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Button | Gets which mouse button was pressed.
Public property | Clicks | Gets the number of times the mouse button was pressed and released.
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Public property | Processed | Gets or sets a value indicating whether the event has been handled.
Public property | X | Gets the x-coordinate of the mouse.
Public property | Y | Gets the y-coordinate of the mouse.
Top
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs.Button Property

AnnotationMouseEventArgsButton Property

Gets which mouse button was pressed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButtons Button { get; }
Public ReadOnly Property Button As MouseButtons
    Get

Property Value

Type: MouseButtons
The mouse button that was pressed.
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs.Clicks Property

AnnotationMouseEventArgsClicks Property

Gets the number of times the mouse button was pressed and released.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Clicks { get; }
Public ReadOnly Property Clicks As Integer
    Get

Property Value

Type: Int32
The number of mouse clicks.
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs.Delta Property

AnnotationMouseEventArgsDelta Property

Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Delta { get; }
Public ReadOnly Property Delta As Integer
    Get

Property Value

Type: Int32
The delta for the mouse wheel.
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs.Processed Property

AnnotationMouseEventArgsProcessed Property

Gets or sets a value indicating whether the event has been handled.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Processed { get; set; }
Public Property Processed As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the event has been handled.
Remarks
Annotations can set this property to true to prevent the base AnnotationUI class from processing mouse move events.
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs.X Property

AnnotationMouseEventArgsX Property

Gets the x-coordinate of the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float X { get; }
Public ReadOnly Property X As Single
    Get

Property Value

Type: Single
The x position of the mouse.
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs.Y Property

AnnotationMouseEventArgsY Property

Gets the y-coordinate of the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Y { get; }
Public ReadOnly Property Y As Single
    Get

Property Value

Type: Single
The y position of the mouse.
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventArgs Methods

The AnnotationMouseEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationMouseEventArgs Class
Atalasoft.Annotate.UI Namespace


AnnotationMouseEventHandler Delegate

This event handler is used with several mouse events.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationMouseEventHandler(
    Object sender,
    AnnotationMouseEventArgs e
)
Public Delegate Sub AnnotationMouseEventHandler (
    sender As Object,
    e As AnnotationMouseEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions Class

This class provides options used when saving annotations with the DocumentAnnotationViewer.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationSaveOptions

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationSaveOptions
Public Class AnnotationSaveOptions

The AnnotationSaveOptions type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationSaveOptions | Creates a new instance of AnnotationSaveOptions.
Public method | AnnotationSaveOptions(Boolean, AnnotationDataFormat) | Creates a new instance of AnnotationSaveOptions specifying whether to embed the annotations into the image and the annotation format to use for TIFF.
Top
Properties
 | Name | Description
Public property | EmbedAnnotations | Gets or sets a value indicating whether annotations will be embedded into the image when saved as JPEG, TIFF of PDF.
Public property | TiffAnnotationFormat | Gets or sets a value indicating whether annotations will be embedded as XMP or WANG in TIFF files.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions Constructor

Constructs a new AnnotationSaveOptions object.
Overload List
 | Name | Description
Public method | AnnotationSaveOptions | Creates a new instance of AnnotationSaveOptions.
Public method | AnnotationSaveOptions(Boolean, AnnotationDataFormat) | Creates a new instance of AnnotationSaveOptions specifying whether to embed the annotations into the image and the annotation format to use for TIFF.
Top
See Also

Reference

AnnotationSaveOptions Class
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions Constructor

Creates a new instance of AnnotationSaveOptions.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationSaveOptions()
Public Sub New
See Also

Reference

AnnotationSaveOptions Class
AnnotationSaveOptions Overload
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions Constructor (Boolean, AnnotationDataFormat)

Creates a new instance of AnnotationSaveOptions specifying whether to embed the annotations into the image and the annotation format to use for TIFF.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationSaveOptions(
    bool embedAnnotations,
    AnnotationDataFormat tiffAnnotationFormat
)
Public Sub New (
    embedAnnotations As Boolean,
    tiffAnnotationFormat As AnnotationDataFormat
)

Parameters

embedAnnotations
Type: SystemBoolean
Indicates whether the annotations should be embedded into the image.
tiffAnnotationFormat
Type: Atalasoft.AnnotateAnnotationDataFormat
Indicates whether annotations embedded into TIFF images with be WANG or XMP.
See Also

Reference

AnnotationSaveOptions Class
AnnotationSaveOptions Overload
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions Properties

The AnnotationSaveOptions type exposes the following members.

Properties
 | Name | Description
Public property | EmbedAnnotations | Gets or sets a value indicating whether annotations will be embedded into the image when saved as JPEG, TIFF of PDF.
Public property | TiffAnnotationFormat | Gets or sets a value indicating whether annotations will be embedded as XMP or WANG in TIFF files.
Top
See Also

Reference

AnnotationSaveOptions Class
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions.EmbedAnnotations Property

AnnotationSaveOptionsEmbedAnnotations Property

Gets or sets a value indicating whether annotations will be embedded into the image when saved as JPEG, TIFF of PDF.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EmbedAnnotations { get; set; }
Public Property EmbedAnnotations As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether annotations will be embedded into images.
Remarks
If this property is true, JPEG will have annotations embedded as XMP data, TIFF with have annotations embedded as XMP or WANG (depending on the value of TiffAnnotationFormat) and PDF will have annotations embedded and converted to PDF annotations.
See Also

Reference

AnnotationSaveOptions Class
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions.TiffAnnotationFormat Property

AnnotationSaveOptionsTiffAnnotationFormat Property

Gets or sets a value indicating whether annotations will be embedded as XMP or WANG in TIFF files.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataFormat TiffAnnotationFormat { get; set; }
Public Property TiffAnnotationFormat As AnnotationDataFormat
    Get
    Set

Property Value

Type: AnnotationDataFormat
A value indicating whether TIFF annotations will be saved as XMP or WANG.
Remarks
This value is only used if EmbedAnnotations is set to true.
See Also

Reference

AnnotationSaveOptions Class
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptions Methods

The AnnotationSaveOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationSaveOptions Class
Atalasoft.Annotate.UI Namespace


AnnotationSaveOptionsHandler Delegate

This delegate is used to provide annotation save options to the DocumentAnnotationViewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationSaveOptionsHandler(
    DocumentAnnotationViewer viewer,
    AnnotationSaveOptions options
)
Public Delegate Sub AnnotationSaveOptionsHandler (
    viewer As DocumentAnnotationViewer,
    options As AnnotationSaveOptions
)

Parameters

viewer
Type: Atalasoft.Annotate.UIDocumentAnnotationViewer
The viewer where annotations are being saved.
options
Type: Atalasoft.Annotate.UIAnnotationSaveOptions
An AnnotationSaveOptions to specify the save options.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationUI Class

This abstract class represents the base annotation object. All annotations must derive from AnnotationUI.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
More...

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class AnnotationUI : ISerializable
<SerializableAttribute>
Public MustInherit Class AnnotationUI
    Implements ISerializable

The AnnotationUI type exposes the following members.

Constructors
 | Name | Description
Protected method | AnnotationUI(AnnotationData) | A constructor for the AnnotationUI object specifying the releated AnnotationData.
Public method | AnnotationUI(SerializationInfo, StreamingContext) | A constructor for AnnotationUI specifying the serialization information for this annotation.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation.
Public property | CanMirror | Gets or sets a value indicating whether can mirror.
Public property | CanMove | Gets or sets a value indicating whether can move.
Public property | CanResize | Gets or sets a value indicating whether can resize.
Public property | CanRotate | Gets or sets a value indicating whether can rotate.
Public property | CanSelect | Gets or sets a value indicating whether can select.
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation.
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation.
Public property | Controller | Gets the AnnotationController for this annotation.
Public property | CreationTime | Gets or sets the creation time.
Public property | Data | Gets the AnnotationData object associated with this annotation.
Public property | Grips | Gets the grips used for the annotation.
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.
Public property | Location | Gets or sets the location of the annotation in document space.
Public property | ModifiedTime | Gets or sets the modification time.
Public property | Name | Gets or sets the name.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation.
Public property | Rotation | Gets or sets the rotation.
Public property | Security | Gets or sets the security.
Public property | Selected | Gets or sets a value indicating whether this annotation the selected.
Public property | Size | Gets or sets the size of the annotation.
Public property | State | Gets or sets the current state of the annotation.
Public property | ToolTip | Gets or sets the tool tip.
Public property | Transform | Gets or sets the transform.
Public property | UserName | Gets or sets the name of the user.
Public property | Visible | Gets or sets a value indicating whether the annotation is visible.
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space.
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space.
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse.
Public method | Clone | Creates a copy of this annotation.
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position.
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided.
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation.
Public method | GetConfinedRotation | Gets the confined rotation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation.
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units.
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically.
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified.
Protected method | OnClick | Called when the user has clicked on the annotation.
Protected method | OnControllerChanged | Called when the Controller property has changed.
Protected method | OnDoubleClick | Called when the annotation is double-clicked.
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse.
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip.
Protected method | OnMouseDown | Called when the user clicks down on the annotation.
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region.
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region.
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation.
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation.
Protected method | OnMoved | Called when a move to a new location has completed.
Protected method | OnMoving | Called while an annotation is being moved by the user.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed.
Protected method | OnResized | Called when a resize on the annotation has completed.
Protected method | OnResizing | Called while the annotation is being resized by the user.
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation.
Protected method | OnRotated | Called when the annotation has been rotated by the user.
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used.
Protected method | OnRotating | Called while an annotation is being rotated by the user.
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position).
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed.
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed.
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation.
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation.
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation.
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation.
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation.
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation.
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation.
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation.
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation.
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation.
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called.
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation.
Public method | RaiseRotatedEvent | This method invokes the Rotated event.
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called.
Public method | Remove | Forces the annotation to remove itself from its parent layer.
Public method | Rotate | Rotates the annotation by the specified number of degrees.
Protected method | SetGrips | Sets the grips used by the annotation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle.
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed.
Public event | Click | Raised when the annotation has been clicked with the mouse.
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse.
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved.
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation.
Public event | MouseEnter | Raised when the mouse enters the annotation region.
Public event | MouseExit | Raised when the mouse exists the annotation region.
Public event | MouseMove | Raised when the mouse is moved over the annotation.
Public event | MouseUp | Raised when the mouse button is released from an annotation.
Public event | Moved | Raised when the annotation has been moved.
Public event | Moving | Raised while the annotation is being moved.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed.
Public event | Resized | Raised when the annotation has been resized.
Public event | Resizing | Raised while the annotation is being resized.
Public event | Rotated | Raised after the annotation has been rotated by the user.
Public event | Rotating | Raise while an annotation is being rotated.
Public event | SelectedChanged | Raised when the Selected property changes.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.InkInkAnnotation
Atalasoft.Annotate.PdfPdfAnnotation
Atalasoft.Annotate.UICalloutAnnotation
Atalasoft.Annotate.UIEllipseAnnotation
Atalasoft.Annotate.UIEmbeddedImageAnnotation
Atalasoft.Annotate.UIHotSpotAnnotation
Atalasoft.Annotate.UILayerAnnotation
Atalasoft.Annotate.UILineAnnotation
Atalasoft.Annotate.UIOcrRegionAnnotation
Atalasoft.Annotate.UIPointBaseAnnotation
Atalasoft.Annotate.UIRectangleAnnotation
Atalasoft.Annotate.UIReferencedImageAnnotation
Atalasoft.Annotate.UIRubberStampAnnotation
Atalasoft.Annotate.UITextAnnotation


AnnotationUI Constructor

Overload List
 | Name | Description
Protected method | AnnotationUI(AnnotationData) | A constructor for the AnnotationUI object specifying the releated AnnotationData.
Public method | AnnotationUI(SerializationInfo, StreamingContext) | A constructor for AnnotationUI specifying the serialization information for this annotation.
Top
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI Constructor (AnnotationData)

A constructor for the AnnotationUI object specifying the releated AnnotationData.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AnnotationUI(
    AnnotationData data
)
Protected Sub New (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData for this annotation. This parameter cannot be null (Nothing in Visual Basic).
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data parameter is null.
See Also

Reference

AnnotationUI Class
AnnotationUI Overload
Atalasoft.Annotate.UI Namespace


AnnotationUI Constructor (SerializationInfo, StreamingContext)

A constructor for AnnotationUI specifying the serialization information for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

AnnotationUI Class
AnnotationUI Overload
Atalasoft.Annotate.UI Namespace


AnnotationUI Properties

The AnnotationUI type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation.
Public property | CanMirror | Gets or sets a value indicating whether can mirror.
Public property | CanMove | Gets or sets a value indicating whether can move.
Public property | CanResize | Gets or sets a value indicating whether can resize.
Public property | CanRotate | Gets or sets a value indicating whether can rotate.
Public property | CanSelect | Gets or sets a value indicating whether can select.
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation.
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation.
Public property | Controller | Gets the AnnotationController for this annotation.
Public property | CreationTime | Gets or sets the creation time.
Public property | Data | Gets the AnnotationData object associated with this annotation.
Public property | Grips | Gets the grips used for the annotation.
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.
Public property | Location | Gets or sets the location of the annotation in document space.
Public property | ModifiedTime | Gets or sets the modification time.
Public property | Name | Gets or sets the name.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation.
Public property | Rotation | Gets or sets the rotation.
Public property | Security | Gets or sets the security.
Public property | Selected | Gets or sets a value indicating whether this annotation the selected.
Public property | Size | Gets or sets the size of the annotation.
Public property | State | Gets or sets the current state of the annotation.
Public property | ToolTip | Gets or sets the tool tip.
Public property | Transform | Gets or sets the transform.
Public property | UserName | Gets or sets the name of the user.
Public property | Visible | Gets or sets a value indicating whether the annotation is visible.
Top
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Bounds Property

AnnotationUIBounds Property

Gets the bounding rectangle for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RectangleF Bounds { get; }
Public Overridable ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
The bounding rectangle for the annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CanMirror Property

AnnotationUICanMirror Property

Gets or sets a value indicating whether can mirror.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanMirror { get; set; }
Public Property CanMirror As Boolean
    Get
    Set

Property Value

Type: Boolean
true if can mirror; otherwise, false.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CanMove Property

AnnotationUICanMove Property

Gets or sets a value indicating whether can move.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanMove { get; set; }
Public Property CanMove As Boolean
    Get
    Set

Property Value

Type: Boolean
true if can move; otherwise, false.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CanResize Property

AnnotationUICanResize Property

Gets or sets a value indicating whether can resize.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanResize { get; set; }
Public Property CanResize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if can resize; otherwise, false.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CanRotate Property

AnnotationUICanRotate Property

Gets or sets a value indicating whether can rotate.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanRotate { get; set; }
Public Property CanRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
true if can rotate; otherwise, false.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CanSelect Property

AnnotationUICanSelect Property

Gets or sets a value indicating whether can select.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanSelect { get; set; }
Public Property CanSelect As Boolean
    Get
    Set

Property Value

Type: Boolean
true if can select; otherwise, false.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.ContextMenu Property

AnnotationUIContextMenu Property

Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContextMenuStrip ContextMenu { get; set; }
Public Property ContextMenu As ContextMenuStrip
    Get
    Set

Property Value

Type: ContextMenuStrip
The context menu for the annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.ContextMenuStrip Property

AnnotationUIContextMenuStrip Property

Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContextMenuStrip ContextMenuStrip { get; set; }
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set

Property Value

Type: ContextMenuStrip
The context menu for the annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Controller Property

AnnotationUIController Property

Gets the AnnotationController for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController Controller { get; }
Public ReadOnly Property Controller As AnnotationController
    Get

Property Value

Type: AnnotationController
The AnnotationController used with this annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CreationTime Property

AnnotationUICreationTime Property

Gets or sets the creation time.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationTime { get; set; }
Public Property CreationTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The creation time.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Data Property

AnnotationUIData Property

Gets the AnnotationData object associated with this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public AnnotationData Data { get; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public ReadOnly Property Data As AnnotationData
    Get

Property Value

Type: AnnotationData
The AnnotationData object for this annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Grips Property

AnnotationUIGrips Property

Gets the grips used for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationGrips Grips { get; }
Public ReadOnly Property Grips As IAnnotationGrips
    Get

Property Value

Type: IAnnotationGrips
The annotation grips.
Remarks
Derived classes can use the SetGrips(IAnnotationGrips) method to change the grips used by the annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.HitTestRectangle Property

AnnotationUIHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RectangleF HitTestRectangle { get; }
Public Overridable ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Location Property

AnnotationUILocation Property

Gets or sets the location of the annotation in document space.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF Location { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property Location As PointF
    Get
    Set

Property Value

Type: PointF
The location of the top-left corner of the annotation in document space.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.ModifiedTime Property

AnnotationUIModifiedTime Property

Gets or sets the modification time.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime ModifiedTime { get; set; }
Public Property ModifiedTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The modification time.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Name Property

AnnotationUIName Property

Gets or sets the name.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.ParentLayer Property

AnnotationUIParentLayer Property

Gets or sets the LayerAnnotation that contains this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation ParentLayer { get; set; }
Public Property ParentLayer As LayerAnnotation
    Get
    Set

Property Value

Type: LayerAnnotation
The parent layer for this annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Rotation Property

AnnotationUIRotation Property

Gets or sets the rotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Rotation { get; set; }
Public Property Rotation As Single
    Get
    Set

Property Value

Type: Single
The rotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Security Property

AnnotationUISecurity Property

Gets or sets the security.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock Security { get; set; }
Public Property Security As IAnnotationLock
    Get
    Set

Property Value

Type: IAnnotationLock
The security.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Selected Property

AnnotationUISelected Property

Gets or sets a value indicating whether this annotation the selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the annotation is selected.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Size Property

AnnotationUISize Property

Gets or sets the size of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(SizeFTypeConverter))]
public SizeF Size { get; set; }
<TypeConverterAttribute(GetType(SizeFTypeConverter))>
Public Property Size As SizeF
    Get
    Set

Property Value

Type: SizeF
The size of the annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.State Property

AnnotationUIState Property

Gets or sets the current state of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationState State { get; set; }
Public Property State As AnnotationState
    Get
    Set

Property Value

Type: AnnotationState
The current state of the annotation.
Remarks
The primary usage of this property is to keep track of where the annotation is at in the creation process.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.ToolTip Property

AnnotationUIToolTip Property

Gets or sets the tool tip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set

Property Value

Type: String
The tool tip.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Transform Property

AnnotationUITransform Property

Gets or sets the transform.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix Transform { get; set; }
Public Property Transform As Matrix
    Get
    Set

Property Value

Type: Matrix
The transform.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.UserName Property

AnnotationUIUserName Property

Gets or sets the name of the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set

Property Value

Type: String
The name of the user.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Visible Property

AnnotationUIVisible Property

Gets or sets a value indicating whether the annotation is visible.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the annotation is visible.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI Methods

The AnnotationUI type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space.
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space.
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse.
Public method | Clone | Creates a copy of this annotation.
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position.
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided.
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation.
Public method | GetConfinedRotation | Gets the confined rotation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation.
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units.
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically.
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified.
Protected method | OnClick | Called when the user has clicked on the annotation.
Protected method | OnControllerChanged | Called when the Controller property has changed.
Protected method | OnDoubleClick | Called when the annotation is double-clicked.
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse.
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip.
Protected method | OnMouseDown | Called when the user clicks down on the annotation.
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region.
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region.
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation.
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation.
Protected method | OnMoved | Called when a move to a new location has completed.
Protected method | OnMoving | Called while an annotation is being moved by the user.
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event.
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed.
Protected method | OnResized | Called when a resize on the annotation has completed.
Protected method | OnResizing | Called while the annotation is being resized by the user.
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation.
Protected method | OnRotated | Called when the annotation has been rotated by the user.
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used.
Protected method | OnRotating | Called while an annotation is being rotated by the user.
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position).
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed.
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed.
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation.
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation.
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation.
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation.
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation.
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation.
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation.
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation.
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation.
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation.
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called.
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation.
Public method | RaiseRotatedEvent | This method invokes the Rotated event.
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called.
Public method | Remove | Forces the annotation to remove itself from its parent layer.
Public method | Rotate | Rotates the annotation by the specified number of degrees.
Protected method | SetGrips | Sets the grips used by the annotation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle.
Top
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.AddGripsToRegion Method

AnnotationUIAddGripsToRegion Method

Adds the annotation grips to a region. The grips are added in annotation space.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void AddGripsToRegion(
    AnnotationRegion region
)
Protected Sub AddGripsToRegion (
    region As AnnotationRegion
)

Parameters

region
Type: Atalasoft.AnnotateAnnotationRegion
The AnnotationRegion to which grips will be added.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the region argument is null (Nothing in VB).
Examples
See the GetRegion(AnnotateSpace) method for an example of using AddGripsToRegion.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace
GetRegion Add


AnnotationUI.ApplyRegionTransform Method

AnnotationUIApplyRegionTransform Method

Use this method to convert a region from annotation space to document or view space.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ApplyRegionTransform(
    AnnotationRegion region,
    AnnotateSpace space
)
Protected Sub ApplyRegionTransform (
    region As AnnotationRegion,
    space As AnnotateSpace
)

Parameters

region
Type: Atalasoft.AnnotateAnnotationRegion
The region to convert. This must be a region in annotation space.
space
Type: Atalasoft.AnnotateAnnotateSpace
The space to convert the region into. If this argument is AnnotateSpace.Annotation, no transform is applied.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the region argument is null (Nothing in VB).
Examples
See the GetRegion method for an example of using ApplyRegionTransform.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace
GetRegion Add


AnnotationUI.BeginCreate Method

AnnotationUIBeginCreate Method

This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void BeginCreate()
Public Overridable Sub BeginCreate
Remarks
Use this method to prepare the annotation for creation by receiving the OnMouseDown(AnnotationMouseEventArgs), OnMouseMove(AnnotationMouseEventArgs) and OnMouseUp(AnnotationMouseEventArgs) method calls.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Clone Method

AnnotationUIClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AnnotationUI Clone()
Public MustOverride Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.CreateRenderTransform Method

AnnotationUICreateRenderTransform Method

Returns the Matrix used by the renderer to transform the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Matrix CreateRenderTransform()
Protected Function CreateRenderTransform As Matrix

Return Value

Type: Matrix
The transform Matrix used when rendering.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetConfinedGripPosition Method

AnnotationUIGetConfinedGripPosition Method

Gets the confined grip position.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PointF GetConfinedGripPosition(
    RectangleF dsConfinedBounds,
    AnnotationGrip grip,
    PointF dsRequestedPosition,
    out bool ignoreMove
)
Public Overridable Function GetConfinedGripPosition (
    dsConfinedBounds As RectangleF,
    grip As AnnotationGrip,
    dsRequestedPosition As PointF,
    <OutAttribute> ByRef ignoreMove As Boolean
) As PointF

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
The ds confined bounds.
grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The grip.
dsRequestedPosition
Type: System.DrawingPointF
The ds requested position.
ignoreMove
Type: SystemBoolean
if set to true [ignore move].

Return Value

Type: PointF
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetConfinedLocation Method

AnnotationUIGetConfinedLocation Method

These methods are used by the AnnotationController to handle annotation confinement.
Overload List
 | Name | Description
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided.
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation.
Top
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetConfinedLocation Method (RectangleF, PointF)

AnnotationUIGetConfinedLocation Method (RectangleF, PointF)

Returns the new confined location of the annotation when a confinement bounds and new location offset are provided.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PointF GetConfinedLocation(
    RectangleF dsConfinedBounds,
    PointF dsLocationOffset
)
Public Overridable Function GetConfinedLocation (
    dsConfinedBounds As RectangleF,
    dsLocationOffset As PointF
) As PointF

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
The bounding rectangle in document space for the confinement.
dsLocationOffset
Type: System.DrawingPointF
The difference between the current and suggested new location of the annotation in document space units.

Return Value

Type: PointF
See Also

Reference

AnnotationUI Class
GetConfinedLocation Overload
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetConfinedLocation Method (RectangleF, RectangleF, PointF)

AnnotationUIGetConfinedLocation Method (RectangleF, RectangleF, PointF)

Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided.

This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF GetConfinedLocation(
    RectangleF dsAnnotationBounds,
    RectangleF dsConfinedBounds,
    PointF dsLocationOffset
)
Protected Function GetConfinedLocation (
    dsAnnotationBounds As RectangleF,
    dsConfinedBounds As RectangleF,
    dsLocationOffset As PointF
) As PointF

Parameters

dsAnnotationBounds
Type: System.DrawingRectangleF
The bounding rectangle of the annotation in document space.
dsConfinedBounds
Type: System.DrawingRectangleF
The bounding rectangle in document space for the confinement.
dsLocationOffset
Type: System.DrawingPointF
The difference between the current and suggested new location of the annotation in document space units.

Return Value

Type: PointF
See Also

Reference

AnnotationUI Class
GetConfinedLocation Overload
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetConfinedRotation Method

AnnotationUIGetConfinedRotation Method

Gets the confined rotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual float GetConfinedRotation(
    RectangleF dsConfinedBounds,
    float newAngle
)
Public Overridable Function GetConfinedRotation (
    dsConfinedBounds As RectangleF,
    newAngle As Single
) As Single

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
The ds confined bounds.
newAngle
Type: SystemSingle
The new angle.

Return Value

Type: Single
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetObjectData Method

AnnotationUIGetObjectData Method

Fills a SerializationInfo object with information about this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetOnePixel Method

AnnotationUIGetOnePixel Method

Returns the equivalent of 1 pixel in resolution units.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF GetOnePixel()
Protected Function GetOnePixel As PointF

Return Value

Type: PointF
The equivalent of 1 pixel in resolution units.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GetRegion Method

AnnotationUIGetRegion Method

Returns a rectangular region for this annotation, including its grips if selected.
Returns a rectangular region for this annotation, including its grips if selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overridable Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
The space coordinate system used to generate this region.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.
Examples
The following is an example of how a custom annotation may override the GetRegion method.
GetRegionCS
Copy
public override AnnotationRegion GetRegion(AnnotateSpace space)
{
    // Create the region in annotation space.
    AnnotationRegion reg = new AnnotationRegion(new RectangleF(PointF.Empty, _data.Size));
    if (this.Selected && this.Grips != null)
        AddGripsToRegion(reg);

    ApplyRegionTransform(reg, space);
    return reg;
}
GetRegionVB
Copy
Public Overrides Function GetRegion(ByVal space As AnnotateSpace) As AnnotationRegion
    ' Create the region in annotation space.
    Dim reg As AnnotationRegion =  New AnnotationRegion(New RectangleF(PointF.Empty,_data.Size))
    If Not Me.Selected And Me.Grips Is Nothing Then
        AddGripsToRegion(reg)
    End If

    ApplyRegionTransform(reg, space)
    Return reg
End Function
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace
AddGripsToRegion Add
ApplyRegionTransform Add


AnnotationUI.GetViewerParameters Method

AnnotationUIGetViewerParameters Method

This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AnnotateViewerParameters GetViewerParameters()
Protected Function GetViewerParameters As AnnotateViewerParameters

Return Value

Type: AnnotateViewerParameters
An AnnotateViewerParameters object containing the viewer information.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Mirror Method

AnnotationUIMirror Method

Mirrors (flips) the annotation horizontally or vertically.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Mirror(
    MirrorDirection direction,
    bool maintainPosition
)
Public Sub Mirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The direction to flip the annotation.
maintainPosition
Type: SystemBoolean
Determines whether the mirror is performed in place or if the annotation pivots along its location.
Remarks
The OnMirror(MirrorDirection, Boolean) method is called as a result of using Mirror.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnAnnotationControllerNotification Method

AnnotationUIOnAnnotationControllerNotification Method

Called after a property of the annotation or related AnnotationData has been modified.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information on this changed.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnClick Method

AnnotationUIOnClick Method

Called when the user has clicked on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnClick(
    EventArgs e
)
Protected Overridable Sub OnClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnControllerChanged Method

AnnotationUIOnControllerChanged Method

Called when the Controller property has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnControllerChanged(
    EventArgs e
)
Protected Overridable Sub OnControllerChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnDoubleClick Method

AnnotationUIOnDoubleClick Method

Called when the annotation is double-clicked.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDoubleClick(
    EventArgs e
)
Protected Overridable Sub OnDoubleClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnGripPositionChanged Method

AnnotationUIOnGripPositionChanged Method

Called when a grip of the annotation has been moved by the user using the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnGripPositionChanged(
    AnnotationGripChangedEventArgs e
)
Protected Overridable Sub OnGripPositionChanged (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
An AnnotationGripChangedEventArgs containing information about this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMirror Method

AnnotationUIOnMirror Method

Called when the grips of an annotation have been dragged past the opposite grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMirror(
    MirrorDirection direction,
    bool maintainPosition
)
Protected Overridable Sub OnMirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The direction in which the annotation should be mirrored.
maintainPosition
Type: SystemBoolean
Determines whether the mirror is performed in place or if the annotation pivots along its location.
Remarks
This method will only be called if the CanMirror property of the annotation is true.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMouseDown Method

AnnotationUIOnMouseDown Method

Called when the user clicks down on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overridable Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMouseEnter Method

AnnotationUIOnMouseEnter Method

Called when the mouse is moved into the annotation region.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseEnter(
    EventArgs e
)
Protected Overridable Sub OnMouseEnter (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMouseExit Method

AnnotationUIOnMouseExit Method

Called when the mouse is moved out of the annotation region.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseExit(
    EventArgs e
)
Protected Overridable Sub OnMouseExit (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMouseMove Method

AnnotationUIOnMouseMove Method

Called when the user has moved the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overridable Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMouseUp Method

AnnotationUIOnMouseUp Method

Called when the user has released the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overridable Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.

Return Value

Type: Boolean
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMoved Method

AnnotationUIOnMoved Method

Called when a move to a new location has completed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMoved(
    EventArgs e
)
Protected Overridable Sub OnMoved (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnMoving Method

AnnotationUIOnMoving Method

Called while an annotation is being moved by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overridable Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
An AnnotationLocationChangedEventArgs containing information about this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnPropertyChanged Method

AnnotationUIOnPropertyChanged Method

Called when a property value has changed and raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As AnnotationPropertyChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationLocationChangedEventArgs containing information for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnPropertyChanging Method

AnnotationUIOnPropertyChanging Method

Called when a property of the annotation or AnnotationData is about to be changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs containing information about this change.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnResized Method

AnnotationUIOnResized Method

Called when a resize on the annotation has completed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnResized(
    EventArgs e
)
Protected Overridable Sub OnResized (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnResizing Method

AnnotationUIOnResizing Method

Called while the annotation is being resized by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnResizing(
    EventArgs e
)
Protected Overridable Sub OnResizing (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnRotate Method

AnnotationUIOnRotate Method

Called when the Rotate(Single) method is called on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotate(
    EventArgs e
)
Protected Overridable Sub OnRotate (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnRotated Method

AnnotationUIOnRotated Method

Called when the annotation has been rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotated(
    EventArgs e
)
Protected Overridable Sub OnRotated (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnRotateDocument Method

AnnotationUIOnRotateDocument Method

Called when the RotateDocument(DocumentRotation, Int32) method is used.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotateDocument(
    DocumentRotation rotation
)
Protected Overridable Sub OnRotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnRotating Method

AnnotationUIOnRotating Method

Called while an annotation is being rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotating(
    EventArgs e
)
Protected Overridable Sub OnRotating (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnScrollPositionChanged Method

AnnotationUIOnScrollPositionChanged Method

Called when the IAnnotate. Transform indicates a change in its offset (scroll position).

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnScrollPositionChanged(
    ScrollPositionChangedEventArgs e
)
Protected Overridable Sub OnScrollPositionChanged (
    e As ScrollPositionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIScrollPositionChangedEventArgs
A ScrollPositionChangedEventArgs containing information for this change.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnSelectedChanged Method

AnnotationUIOnSelectedChanged Method

Called when the Selected property of the annotation has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectedChanged(
    EventArgs e
)
Protected Overridable Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.OnSizeChanged Method

AnnotationUIOnSizeChanged Method

Called when the Size property of the annotation has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
An AnnotationSizeChangedEventArgs containing information for this event.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseClickEvent Method

AnnotationUIRaiseClickEvent Method

Use this method to force a Click event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseClickEvent()
Public Sub RaiseClickEvent
Remarks
The OnClick(EventArgs) method will be called as a result of using RaiseClickEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseDoubleClickEvent Method

AnnotationUIRaiseDoubleClickEvent Method

Use this method to force a DoubleClick event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseDoubleClickEvent()
Public Sub RaiseDoubleClickEvent
Remarks
The OnDoubleClick(EventArgs) method is called as a result of using RaiseDoubleClickEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseGripPositionChangedEvent Method

AnnotationUIRaiseGripPositionChangedEvent Method

Use this method to force a GripPositionChanged event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseGripPositionChangedEvent(
    AnnotationGripChangedEventArgs e
)
Public Sub RaiseGripPositionChangedEvent (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
An AnnotationGripChangedEventArgs containing information about this event.
Exceptions
Exception | Condition
 | Thrown if the event args is null (Nothing in VB).
Remarks
The OnGripPositionChanged(AnnotationGripChangedEventArgs) method is called as a result of using RaiseGripPositionChangedEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMouseDownEvent Method

AnnotationUIRaiseMouseDownEvent Method

Use this method to force a MouseDown event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseMouseDownEvent(
    AnnotationMouseEventArgs e
)
Public Sub RaiseMouseDownEvent (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about the MouseDown event.
Exceptions
Exception | Condition
 | Thrown if the event args is null (Nothing in VB).
Remarks
The OnMouseDown(AnnotationMouseEventArgs) method is called as a result of using RaiseMouseDownEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMouseEnterEvent Method

AnnotationUIRaiseMouseEnterEvent Method

Use to force the MouseEnter event for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseMouseEnterEvent()
Public Sub RaiseMouseEnterEvent
Remarks
The OnMouseEnter(EventArgs) method is called as a result of using RaiseMouseEnterEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMouseExitEvent Method

AnnotationUIRaiseMouseExitEvent Method

Use to force a MouseExit event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseMouseExitEvent()
Public Sub RaiseMouseExitEvent
Remarks
The OnMouseExit(EventArgs) method is called as a result of using RaiseMouseExitEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMouseMoveEvent Method

AnnotationUIRaiseMouseMoveEvent Method

Use this method to force a MouseMove event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseMouseMoveEvent(
    AnnotationMouseEventArgs e
)
Public Sub RaiseMouseMoveEvent (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
Exceptions
Exception | Condition
 | Thrown if the event args is null (Nothing in VB).
Remarks
The OnMouseMove(AnnotationMouseEventArgs) method is called as a result of using RaiseMouseMoveEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMouseUpEvent Method

AnnotationUIRaiseMouseUpEvent Method

Use this method to force a MouseUp event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RaiseMouseUpEvent(
    AnnotationMouseEventArgs e
)
Public Function RaiseMouseUpEvent (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information for this event.

Return Value

Type: Boolean
True if the annotation is finished being created. Point base annotations will return false while being created until the final point.
Exceptions
Exception | Condition
 | Thrown if the event args is null (Nothing in VB).
Remarks
The OnMouseUp(AnnotationMouseEventArgs) method is called as a result of using RaiseMouseUpEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMovedEvent Method

AnnotationUIRaiseMovedEvent Method

Use this method to force a Moved event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseMovedEvent()
Public Sub RaiseMovedEvent
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseMovingEvent Method

AnnotationUIRaiseMovingEvent Method

Use this method to force a Moving event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseMovingEvent(
    AnnotationLocationChangedEventArgs e
)
Public Sub RaiseMovingEvent (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
An AnnotationLocationChangedEventArgs containing information about this event. This may be null (Nothing in VB).
Remarks
The OnMoving(AnnotationLocationChangedEventArgs) method is called as a result of using RaiseMovingEvent.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseOnRotateDocument Method

AnnotationUIRaiseOnRotateDocument Method

Use this method to force the OnRotateDocument(DocumentRotation) method to be called.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseOnRotateDocument(
    DocumentRotation rotation
)
Public Sub RaiseOnRotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation applied.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseResizedEvent Method

AnnotationUIRaiseResizedEvent Method

Use this method to force a Resized event on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseResizedEvent()
Public Sub RaiseResizedEvent
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseRotatedEvent Method

AnnotationUIRaiseRotatedEvent Method

This method invokes the Rotated event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseRotatedEvent()
Public Sub RaiseRotatedEvent
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.RaiseScrollPositionChangedEvent Method

AnnotationUIRaiseScrollPositionChangedEvent Method

Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseScrollPositionChangedEvent(
    ScrollPositionChangedEventArgs e
)
Public Sub RaiseScrollPositionChangedEvent (
    e As ScrollPositionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIScrollPositionChangedEventArgs
A ScrollPositionChangedEventArgs containing information about this event.
Exceptions
Exception | Condition
 | Thrown if the event args is null (Nothing in VB).
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Remove Method

AnnotationUIRemove Method

Forces the annotation to remove itself from its parent layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove()
Public Sub Remove
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Rotate Method

AnnotationUIRotate Method

Rotates the annotation by the specified number of degrees.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Rotate(
    float degrees
)
Public Sub Rotate (
    degrees As Single
)

Parameters

degrees
Type: SystemSingle
The number of degrees to rotate the annotation.
Remarks
This degrees parameter is added the the Rotate value of the annotation in order to determine the full rotation of the annotation.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.SetGrips Method

AnnotationUISetGrips Method

Sets the grips used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetGrips(
    IAnnotationGrips grips
)
Protected Sub SetGrips (
    grips As IAnnotationGrips
)

Parameters

grips
Type: Atalasoft.Annotate.UIIAnnotationGrips
The grips to use.
Remarks
Use this method in derived classes to set the Grips property.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.TransformRectangle Method

AnnotationUITransformRectangle Method

Applies the render transformation matrix to a rectangle.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF TransformRectangle(
    RectangleF rectangle
)
Protected Function TransformRectangle (
    rectangle As RectangleF
) As RectangleF

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle to transform.

Return Value

Type: RectangleF
The transformed rectangle.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI Events

The AnnotationUI type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed.
Public event | Click | Raised when the annotation has been clicked with the mouse.
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse.
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved.
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation.
Public event | MouseEnter | Raised when the mouse enters the annotation region.
Public event | MouseExit | Raised when the mouse exists the annotation region.
Public event | MouseMove | Raised when the mouse is moved over the annotation.
Public event | MouseUp | Raised when the mouse button is released from an annotation.
Public event | Moved | Raised when the annotation has been moved.
Public event | Moving | Raised while the annotation is being moved.
Public event | PropertyChanged | Raised when a property value has changed.
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed.
Public event | Resized | Raised when the annotation has been resized.
Public event | Resizing | Raised while the annotation is being resized.
Public event | Rotated | Raised after the annotation has been rotated by the user.
Public event | Rotating | Raise while an annotation is being rotated.
Public event | SelectedChanged | Raised when the Selected property changes.
Top
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.AnnotationControllerNotification Event

AnnotationUIAnnotationControllerNotification Event

Raised after a property value has been changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace
PropertyChanging Event


AnnotationUI.Click Event

AnnotationUIClick Event

Raised when the annotation has been clicked with the mouse.
Raised when the annotation has been clicked with the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Click
Public Event Click As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.DoubleClick Event

AnnotationUIDoubleClick Event

Raised when the annotation has been double-clicked with the mouse.
Raised when the annotation has been double-clicked with the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler DoubleClick
Public Event DoubleClick As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.GripPositionChanged Event

AnnotationUIGripPositionChanged Event

Raised when a grip for the annotation has been moved.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event GripPositionChangedEventHandler GripPositionChanged
Public Event GripPositionChanged As GripPositionChangedEventHandler

Value

Type: Atalasoft.Annotate.UIGripPositionChangedEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.MouseDown Event

AnnotationUIMouseDown Event

Raised when a mouse button is pressed while on top of the annotation.
Raised when a mouse button is pressed while on top of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationMouseEventHandler MouseDown
Public Event MouseDown As AnnotationMouseEventHandler

Value

Type: Atalasoft.Annotate.UIAnnotationMouseEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.MouseEnter Event

AnnotationUIMouseEnter Event

Raised when the mouse enters the annotation region.
Raised when the mouse enters the annotation region.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler MouseEnter
Public Event MouseEnter As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.MouseExit Event

AnnotationUIMouseExit Event

Raised when the mouse exists the annotation region.
Raised when the mouse exists the annotation region.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler MouseExit
Public Event MouseExit As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.MouseMove Event

AnnotationUIMouseMove Event

Raised when the mouse is moved over the annotation.
Raised when the mouse is moved over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationMouseEventHandler MouseMove
Public Event MouseMove As AnnotationMouseEventHandler

Value

Type: Atalasoft.Annotate.UIAnnotationMouseEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.MouseUp Event

AnnotationUIMouseUp Event

Raised when the mouse button is released from an annotation.
Raised when the mouse button is released from an annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationMouseEventHandler MouseUp
Public Event MouseUp As AnnotationMouseEventHandler

Value

Type: Atalasoft.Annotate.UIAnnotationMouseEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Moved Event

AnnotationUIMoved Event

Raised when the annotation has been moved.
Raised when the annotation has been moved.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Moved
Public Event Moved As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Moving Event

AnnotationUIMoving Event

Raised while the annotation is being moved.
Raised while the annotation is being moved.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationLocationChangedEventHandler Moving
Public Event Moving As AnnotationLocationChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationLocationChangedEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.PropertyChanged Event

AnnotationUIPropertyChanged Event

Raised when a property value has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As AnnotationPropertyChangedEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangedEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.PropertyChanging Event

AnnotationUIPropertyChanging Event

Raised when a property of the annotation or AnnotationData is going to be changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
Remarks
This will be raised before the property value has been modified.
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace
AnnotationControllerNotification Event


AnnotationUI.Resized Event

AnnotationUIResized Event

Raised when the annotation has been resized.
Raised when the annotation has been resized.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Resized
Public Event Resized As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Resizing Event

AnnotationUIResizing Event

Raised while the annotation is being resized.
Raised while the annotation is being resized.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Resizing
Public Event Resizing As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Rotated Event

AnnotationUIRotated Event

Raised after the annotation has been rotated by the user.
Raised after the annotation has been rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Rotated
Public Event Rotated As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.Rotating Event

AnnotationUIRotating Event

Raise while an annotation is being rotated.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Rotating
Public Event Rotating As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUI.SelectedChanged Event

AnnotationUISelectedChanged Event

Raised when the Selected property changes.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectedChanged
Public Event SelectedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUI Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Class

This class holds a collection of annotation objects. LayerAnnotations use this collection to hold the AnnotationUI objects they contain.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Annotate.UIAnnotationUICollection

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AnnotationUICollection : CollectionBase,
    ISerializable, IDisposable, IDeserializationCallback
<SerializableAttribute>
Public Class AnnotationUICollection
    Inherits CollectionBase
    Implements ISerializable, IDisposable, IDeserializationCallback

The AnnotationUICollection type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationUICollection | Creates a new instance of AnnotationUICollection.
Public method | AnnotationUICollection(Boolean) | Creates a new instance of AnnotationUICollection used for storage.
Public method | AnnotationUICollection(AnnotationUI) | Creates a new instance of AnnotationUICollection specifying an array of AnnotationUI objects.
Public method | AnnotationUICollection(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationUICollection from serialized information.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the AnnotationUI at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds a single annotation to the collection.
Public method | AddRange(AnnotationUI) | Adds an array of annotations to the collection.
Public method | AddRange(AnnotationUICollection) | Adds annotations from another AnnotationUICollection to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone | Creates a copy of this collection and all items it contains.
Public method | Contains | Determines if an annotation is contained within the collection.
Public method | CopyTo(AnnotationUI) | Copies all of the items from this collection into an array.
Public method | CopyTo(AnnotationUI, Int32) | Copies items into the specifed array.
Public method | CopyTo(Int32, AnnotationUI, Int32, Int32) | Copies annotations from this collection into an array.
Public method | Dispose | Disposes this collection and all items it contains.
Protected method | Dispose(Boolean) | Releases resources used by this object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnnotationUICollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified annotation.
Public method | Insert | Inserts an annotation into the collection at the specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Called when the Clear method is used. (Overrides CollectionBaseOnClear.)
Protected method | OnClearComplete | Called when the clear operation has finished. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnCollectionChanged | Called when there is a change to the collection.
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Called when an insert operation has finished. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Called when an annotation is removed from the collection. (Overrides CollectionBaseOnRemove(Int32, Object).)
Protected method | OnRemoveComplete | Called when a remove operation has finished. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Called when an item has been swapped with another. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(AnnotationUI) | Removes an annotation from the collection.
Public method | Remove(AnnotationUI) | Removes multiple annotations from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised when there has been a change to an item in this collection.
Public event | CollectionChanged | Raised when there has been a change in the collection.
Public event | PropertyChanging | Raise before a change is applied to an item in this collection.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationUICollection Constructor

Constructs an AnnotationUICollection.
Overload List
 | Name | Description
Public method | AnnotationUICollection | Creates a new instance of AnnotationUICollection.
Public method | AnnotationUICollection(Boolean) | Creates a new instance of AnnotationUICollection used for storage.
Public method | AnnotationUICollection(AnnotationUI) | Creates a new instance of AnnotationUICollection specifying an array of AnnotationUI objects.
Public method | AnnotationUICollection(SerializationInfo, StreamingContext) | Creates a new instance of AnnotationUICollection from serialized information.
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Constructor

Creates a new instance of AnnotationUICollection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection()
Public Sub New
See Also

Reference

AnnotationUICollection Class
AnnotationUICollection Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Constructor (Boolean)

Creates a new instance of AnnotationUICollection used for storage.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection(
    bool storage
)
Public Sub New (
    storage As Boolean
)

Parameters

storage
Type: SystemBoolean
Indicates whether this collection is only used for storage.
Remarks
This overload is primarily for internal use but can be used to store annotations outside of a layer.
See Also

Reference

AnnotationUICollection Class
AnnotationUICollection Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Constructor (AnnotationUI[])

AnnotationUICollection Constructor (AnnotationUI)

Creates a new instance of AnnotationUICollection specifying an array of AnnotationUI objects.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection(
    AnnotationUI[] annotations
)
Public Sub New (
    annotations As AnnotationUI()
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUI
An array of AnnotationUI objects to initialize the collection with.
Exceptions
Exception | Condition
 | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

AnnotationUICollection Class
AnnotationUICollection Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AnnotationUICollection from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this collection.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info parameter is null.
See Also

Reference

AnnotationUICollection Class
AnnotationUICollection Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Properties

The AnnotationUICollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the AnnotationUI at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Item Property

AnnotationUICollectionItem Property

Gets the AnnotationUI at the specified index.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As AnnotationUI
    Get

Parameters

index
Type: SystemInt32
The index in the collection of the annotation to retrieve.

Property Value

Type: AnnotationUI
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Methods

The AnnotationUICollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a single annotation to the collection.
Public method | AddRange(AnnotationUI) | Adds an array of annotations to the collection.
Public method | AddRange(AnnotationUICollection) | Adds annotations from another AnnotationUICollection to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone | Creates a copy of this collection and all items it contains.
Public method | Contains | Determines if an annotation is contained within the collection.
Public method | CopyTo(AnnotationUI) | Copies all of the items from this collection into an array.
Public method | CopyTo(AnnotationUI, Int32) | Copies items into the specifed array.
Public method | CopyTo(Int32, AnnotationUI, Int32, Int32) | Copies annotations from this collection into an array.
Public method | Dispose | Disposes this collection and all items it contains.
Protected method | Dispose(Boolean) | Releases resources used by this object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnnotationUICollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified annotation.
Public method | Insert | Inserts an annotation into the collection at the specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Called when the Clear method is used. (Overrides CollectionBaseOnClear.)
Protected method | OnClearComplete | Called when the clear operation has finished. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnCollectionChanged | Called when there is a change to the collection.
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Called when an insert operation has finished. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Called when an annotation is removed from the collection. (Overrides CollectionBaseOnRemove(Int32, Object).)
Protected method | OnRemoveComplete | Called when a remove operation has finished. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Called when an item has been swapped with another. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(AnnotationUI) | Removes an annotation from the collection.
Public method | Remove(AnnotationUI) | Removes multiple annotations from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Add Method

AnnotationUICollectionAdd Method

Adds a single annotation to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AnnotationUI annotation
)
Public Sub Add (
    annotation As AnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to add.
Exceptions
Exception | Condition
 | Thrown if the annotation parameter is null.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.AddRange Method

AnnotationUICollectionAddRange Method

Use these methods to add multiple annotations into the collection.
Overload List
 | Name | Description
Public method | AddRange(AnnotationUI) | Adds an array of annotations to the collection.
Public method | AddRange(AnnotationUICollection) | Adds annotations from another AnnotationUICollection to this collection.
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.AddRange Method (AnnotationUI[])

AnnotationUICollectionAddRange Method (AnnotationUI)

Adds an array of annotations to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    AnnotationUI[] annotations
)
Public Sub AddRange (
    annotations As AnnotationUI()
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUI
An array of annotations to add.
Exceptions
Exception | Condition
 | Thrown if the annotations parameter is null.
See Also

Reference

AnnotationUICollection Class
AddRange Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.AddRange Method (AnnotationUICollection)

AnnotationUICollectionAddRange Method (AnnotationUICollection)

Adds annotations from another AnnotationUICollection to this collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    AnnotationUICollection annotations
)
Public Sub AddRange (
    annotations As AnnotationUICollection
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUICollection
An AnnotationUICollection containing items to add into this collection.
Exceptions
Exception | Condition
 | Thrown if the annotations parameter is null.
See Also

Reference

AnnotationUICollection Class
AddRange Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Clone Method

AnnotationUICollectionClone Method

Creates a copy of this collection and all items it contains.
Creates a copy of this collection and all items it contains.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection Clone()
Public Function Clone As AnnotationUICollection

Return Value

Type: AnnotationUICollection
A copy of this AnnotationUICollection.

Return Value

Type: AnnotationUICollection
A copy of this AnnotationUICollection.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Contains Method

AnnotationUICollectionContains Method

Determines if an annotation is contained within the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    AnnotationUI annotation
)
Public Function Contains (
    annotation As AnnotationUI
) As Boolean

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to search for.

Return Value

Type: Boolean
True if the annotation is within the collection.
Exceptions
Exception | Condition
 | Thrown if the annotation parameter is null.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.CopyTo Method

AnnotationUICollectionCopyTo Method

Use these methods to copy the annotations into an array.
Overload List
 | Name | Description
Public method | CopyTo(AnnotationUI) | Copies all of the items from this collection into an array.
Public method | CopyTo(AnnotationUI, Int32) | Copies items into the specifed array.
Public method | CopyTo(Int32, AnnotationUI, Int32, Int32) | Copies annotations from this collection into an array.
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.CopyTo Method (AnnotationUI[])

AnnotationUICollectionCopyTo Method (AnnotationUI)

Copies all of the items from this collection into an array.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    AnnotationUI[] array
)
Public Sub CopyTo (
    array As AnnotationUI()
)

Parameters

array
Type: Atalasoft.Annotate.UIAnnotationUI
The array where items will be copied.
Exceptions
Exception | Condition
 | Thrown if the array is null (Nothing in VB).
See Also

Reference

AnnotationUICollection Class
CopyTo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.CopyTo Method (AnnotationUI[], Int32)

AnnotationUICollectionCopyTo Method (AnnotationUI, Int32)

Copies items into the specifed array.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    AnnotationUI[] array,
    int index
)
Public Sub CopyTo (
    array As AnnotationUI(),
    index As Integer
)

Parameters

array
Type: Atalasoft.Annotate.UIAnnotationUI
The array to copy items into.
index
Type: SystemInt32
An index in the target array where copying will being.
Exceptions
Exception | Condition
 | Thrown if the array is null (Nothing in VB).
 | Thrown if the index is invalid.
See Also

Reference

AnnotationUICollection Class
CopyTo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.CopyTo Method (Int32, AnnotationUI[], Int32, Int32)

AnnotationUICollectionCopyTo Method (Int32, AnnotationUI, Int32, Int32)

Copies annotations from this collection into an array.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    int index,
    AnnotationUI[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    index As Integer,
    array As AnnotationUI(),
    arrayIndex As Integer,
    count As Integer
)

Parameters

index
Type: SystemInt32
The index of this collection where copying will begin.
array
Type: Atalasoft.Annotate.UIAnnotationUI
The array to copy items into.
arrayIndex
Type: SystemInt32
The index in the array where copying will begin.
count
Type: SystemInt32
The number of items to copy.
Exceptions
Exception | Condition
 | Thrown if the index or arrayIndex arguments are invalid.
 | Thrown if array is null (Nothing in VB).
See Also

Reference

AnnotationUICollection Class
CopyTo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Dispose Method

AnnotationUICollectionDispose Method

Disposes the AnnotationUICollection.
Overload List
 | Name | Description
Public method | Dispose | Disposes this collection and all items it contains.
Protected method | Dispose(Boolean) | Releases resources used by this object.
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Dispose Method

AnnotationUICollectionDispose Method

Disposes this collection and all items it contains.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AnnotationUICollection Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Dispose Method (Boolean)

AnnotationUICollectionDispose Method (Boolean)

Releases resources used by this object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was called from the public Dispose method.
See Also

Reference

AnnotationUICollection Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Finalize Method

AnnotationUICollectionFinalize Method

Finalizes an instance of the AnnotationUICollection class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.GetObjectData Method

AnnotationUICollectionGetObjectData Method

Fills a SerializationInfo object with information about this collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info parameter is null.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.IndexOf Method

AnnotationUICollectionIndexOf Method

Returns the index of a specified annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    AnnotationUI annotation
)
Public Function IndexOf (
    annotation As AnnotationUI
) As Integer

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to search for.

Return Value

Type: Int32
The collection index of the annotation or -1 if the annotation was not found.
Exceptions
Exception | Condition
 | Thrown if the annotation is null (Nothing in VB).
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Insert Method

AnnotationUICollectionInsert Method

Inserts an annotation into the collection at the specified position.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AnnotationUI annotation
)
Public Sub Insert (
    index As Integer,
    annotation As AnnotationUI
)

Parameters

index
Type: SystemInt32
The index in the collection where the annotation will be inserted.
annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to insert.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation parameter is null.
ArgumentOutOfRangeException | Thrown if the index parameter is out of range for this collection.
ArgumentException | Thrown if the annotation already exists in the collection. To move an annotation to a different location, use the ChangePosition method.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnClear Method

AnnotationUICollectionOnClear Method

Called when the Clear method is used.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClear()
Protected Overrides Sub OnClear
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnClearComplete Method

AnnotationUICollectionOnClearComplete Method

Called when the clear operation has finished.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnCollectionChanged Method

AnnotationUICollectionOnCollectionChanged Method

Called when there is a change to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnCollectionChanged(
    CollectionChangedEventArgs args
)
Protected Sub OnCollectionChanged (
    args As CollectionChangedEventArgs
)

Parameters

args
Type: Atalasoft.UtilsCollectionChangedEventArgs
An CollectionChangedEventArgs containing information about this change.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnDeserialization Method

AnnotationUICollectionOnDeserialization Method

Called after an object has been fully deserialized by a serialization formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
This parameter is not used and will be null (Nothing in VB).

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnInsertComplete Method

AnnotationUICollectionOnInsertComplete Method

Called when an insert operation has finished.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the item inserted.
value
Type: SystemObject
The item that was inserted. This could be an array of objects.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnRemove Method

AnnotationUICollectionOnRemove Method

Called when an annotation is removed from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemove(
    int index,
    Object value
)
Protected Overrides Sub OnRemove (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the annotation being removed.
value
Type: SystemObject
The annotation being removed.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnRemoveComplete Method

AnnotationUICollectionOnRemoveComplete Method

Called when a remove operation has finished.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the item removed.
value
Type: SystemObject
The item that was removed. This may be an array of objects.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.OnSetComplete Method

AnnotationUICollectionOnSetComplete Method

Called when an item has been swapped with another.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The index of the item.
oldValue
Type: SystemObject
The old item.
newValue
Type: SystemObject
The new item.
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Remove Method

AnnotationUICollectionRemove Method

Use these methods to remove one or more annotations from the collection.
Overload List
 | Name | Description
Public method | Remove(AnnotationUI) | Removes an annotation from the collection.
Public method | Remove(AnnotationUI) | Removes multiple annotations from the collection.
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Remove Method (AnnotationUI)

AnnotationUICollectionRemove Method (AnnotationUI)

Removes an annotation from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AnnotationUI annotation
)
Public Sub Remove (
    annotation As AnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation to remove.
Exceptions
Exception | Condition
 | Thrown if the annotation parameter is null.
See Also

Reference

AnnotationUICollection Class
Remove Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.Remove Method (AnnotationUI[])

AnnotationUICollectionRemove Method (AnnotationUI)

Removes multiple annotations from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AnnotationUI[] annotations
)
Public Sub Remove (
    annotations As AnnotationUI()
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUI
An array of AnnotationUI objects to remove.
Exceptions
Exception | Condition
 | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

AnnotationUICollection Class
Remove Overload
Atalasoft.Annotate.UI Namespace


AnnotationUICollection Events

The AnnotationUICollection type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised when there has been a change to an item in this collection.
Public event | CollectionChanged | Raised when there has been a change in the collection.
Public event | PropertyChanging | Raise before a change is applied to an item in this collection.
Top
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.AnnotationControllerNotification Event

AnnotationUICollectionAnnotationControllerNotification Event

Raised when there has been a change to an item in this collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.CollectionChanged Event

AnnotationUICollectionCollectionChanged Event

Raised when there has been a change in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As CollectionChangedEventHandler

Value

Type: Atalasoft.UtilsCollectionChangedEventHandler
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUICollection.PropertyChanging Event

AnnotationUICollectionPropertyChanging Event

Raise before a change is applied to an item in this collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
See Also

Reference

AnnotationUICollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection Class

This class is a collection of IAnnotationUIFactory objects which are used to create new AnnotationUI objects from AnnotationData.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Annotate.UIAnnotationUIFactoryCollection

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationUIFactoryCollection : CollectionBase
Public Class AnnotationUIFactoryCollection
    Inherits CollectionBase

The AnnotationUIFactoryCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationUIFactoryCollection | Creates a new instance of AnnotationUIFactoryCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Get the IAnnotationUIFactory at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an IAnnotationUIFactory to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationFromData | Returns a new AnnotationUI object for the AnnotationData provided.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts an item into the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a factory from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Replace | Replaces a factory in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The AnnotationController keeps this collection in its Factories property.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection Constructor

Creates a new instance of AnnotationUIFactoryCollection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUIFactoryCollection()
Public Sub New
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection Properties

The AnnotationUIFactoryCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Get the IAnnotationUIFactory at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection.Item Property

AnnotationUIFactoryCollectionItem Property

Get the IAnnotationUIFactory at the specified index.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationUIFactory this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IAnnotationUIFactory
    Get

Parameters

index
Type: SystemInt32
The index of the item to return.

Property Value

Type: IAnnotationUIFactory
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection Methods

The AnnotationUIFactoryCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an IAnnotationUIFactory to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationFromData | Returns a new AnnotationUI object for the AnnotationData provided.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts an item into the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a factory from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Replace | Replaces a factory in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection.Add Method

AnnotationUIFactoryCollectionAdd Method

Adds an IAnnotationUIFactory to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    IAnnotationUIFactory factory
)
Public Sub Add (
    factory As IAnnotationUIFactory
)

Parameters

factory
Type: Atalasoft.Annotate.UIIAnnotationUIFactory
The factory to add.
Exceptions
Exception | Condition
 | Thrown if the factory parameter is null.
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection.GetAnnotationFromData Method

AnnotationUIFactoryCollectionGetAnnotationFromData Method

Returns a new AnnotationUI object for the AnnotationData provided.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationFromData(
    AnnotationData data
)
Public Function GetAnnotationFromData (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object from which the AnnotationUI must be created.

Return Value

Type: AnnotationUI
A new AnnotationUI object for the AnnotationData or a RectangleAnnotation if no IAnnotationUIFactory can be found for the data.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection.Insert Method

AnnotationUIFactoryCollectionInsert Method

Inserts an item into the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    IAnnotationUIFactory factory
)
Public Sub Insert (
    index As Integer,
    factory As IAnnotationUIFactory
)

Parameters

index
Type: SystemInt32
The index where the item will be inserted.
factory
Type: Atalasoft.Annotate.UIIAnnotationUIFactory
The factory to insert.
Exceptions
Exception | Condition
 | Thrown if the factory is null (Nothing in VB).
 | Thrown if the index is invalid.
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection.Remove Method

AnnotationUIFactoryCollectionRemove Method

Removes a factory from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    IAnnotationUIFactory factory
)
Public Sub Remove (
    factory As IAnnotationUIFactory
)

Parameters

factory
Type: Atalasoft.Annotate.UIIAnnotationUIFactory
The factory to remove.
Exceptions
Exception | Condition
 | Thrown if the factory parameter is null.
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUIFactoryCollection.Replace Method

AnnotationUIFactoryCollectionReplace Method

Replaces a factory in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    IAnnotationUIFactory oldFactory,
    IAnnotationUIFactory newFactory
)
Public Sub Replace (
    oldFactory As IAnnotationUIFactory,
    newFactory As IAnnotationUIFactory
)

Parameters

oldFactory
Type: Atalasoft.Annotate.UIIAnnotationUIFactory
The factory currently in the collection.
newFactory
Type: Atalasoft.Annotate.UIIAnnotationUIFactory
The new factory that will replace the old one.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the oldFactory or newFactory parameter is null.
Remarks
If the old factory is not found in the collection, the new factory will be added to the end of the collection.
See Also

Reference

AnnotationUIFactoryCollection Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo Class

This class is used to store an undo or redo change for an object.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUndo

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationUndo
Public Class AnnotationUndo

The AnnotationUndo type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationUndo(Object, UndoChange, String) | Creates a new instance of AnnotationUndo specifying the object being modified and the type of change being performed.
Public method | AnnotationUndo(Object, Object, UndoChange, String) | Creates a new instance of AnnotationUndo specifying the object being changed, the current value of the object and the type of change being performed.
Public method | AnnotationUndo(Object, String, Object, String) | Creates a new instance of AnnotationUndo specifying the object being changed, name of the property being changed, the current value of the property and a description of the undo.
Public method | AnnotationUndo(Object, Object, Int32, UndoChange, String) | Creates a new instance of AnnotationUndo specifying the object being changed, the current value of the object and the type of change being performed.
Public method | AnnotationUndo(Object, String, Object, String, Object, String) | Creates a new instance of AnnotationUndo for methods.
Top
Properties
 | Name | Description
Public property | Change | Gets the type of undo change being performed.
Public property | Description | Gets the description of the undo.
Public property | Index | Gets the index of the item.
Public property | Item | Gets the object that was changed.
Public property | PropertyName | Gets the name of the property that was changed.
Public property | RedoMethodName | Gets the name of the method called when performing a redo.
Public property | RedoMethodParameters | Gets an object array containing the parameters used by the Redo method.
Public property | UndoMethodName | Gets the name of the method that will be called when an undo is performed.
Public property | UndoMethodParameters | Gets an object array of parameters sent to the Undo method.
Public property | Value | Gets the value of the object or property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationUndo Constructor

Constructs an AnnotationUndo.
Overload List
 | Name | Description
Public method | AnnotationUndo(Object, UndoChange, String) | Creates a new instance of AnnotationUndo specifying the object being modified and the type of change being performed.
Public method | AnnotationUndo(Object, Object, UndoChange, String) | Creates a new instance of AnnotationUndo specifying the object being changed, the current value of the object and the type of change being performed.
Public method | AnnotationUndo(Object, String, Object, String) | Creates a new instance of AnnotationUndo specifying the object being changed, name of the property being changed, the current value of the property and a description of the undo.
Public method | AnnotationUndo(Object, Object, Int32, UndoChange, String) | Creates a new instance of AnnotationUndo specifying the object being changed, the current value of the object and the type of change being performed.
Public method | AnnotationUndo(Object, String, Object, String, Object, String) | Creates a new instance of AnnotationUndo for methods.
Top
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo Constructor (Object, UndoChange, String)

Creates a new instance of AnnotationUndo specifying the object being modified and the type of change being performed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo(
    Object item,
    UndoChange change,
    string description
)
Public Sub New (
    item As Object,
    change As UndoChange,
    description As String
)

Parameters

item
Type: SystemObject
The object being changed.
change
Type: Atalasoft.AnnotateUndoChange
The type of change being performed.
description
Type: SystemString
A short string describing the undo.
See Also

Reference

AnnotationUndo Class
AnnotationUndo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUndo Constructor (Object, Object, UndoChange, String)

Creates a new instance of AnnotationUndo specifying the object being changed, the current value of the object and the type of change being performed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo(
    Object item,
    Object value,
    UndoChange change,
    string description
)
Public Sub New (
    item As Object,
    value As Object,
    change As UndoChange,
    description As String
)

Parameters

item
Type: SystemObject
The object being changed.
value
Type: SystemObject
The current value of the object.
change
Type: Atalasoft.AnnotateUndoChange
The type of change being performed.
description
Type: SystemString
A short string describing the undo.
See Also

Reference

AnnotationUndo Class
AnnotationUndo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUndo Constructor (Object, String, Object, String)

Creates a new instance of AnnotationUndo specifying the object being changed, name of the property being changed, the current value of the property and a description of the undo.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo(
    Object item,
    string propertyName,
    Object value,
    string description
)
Public Sub New (
    item As Object,
    propertyName As String,
    value As Object,
    description As String
)

Parameters

item
Type: SystemObject
The object being changed.
propertyName
Type: SystemString
The name of the property being changed.
value
Type: SystemObject
The current value of the property.
description
Type: SystemString
A short string describing the undo.
See Also

Reference

AnnotationUndo Class
AnnotationUndo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUndo Constructor (Object, Object, Int32, UndoChange, String)

Creates a new instance of AnnotationUndo specifying the object being changed, the current value of the object and the type of change being performed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo(
    Object item,
    Object value,
    int index,
    UndoChange change,
    string description
)
Public Sub New (
    item As Object,
    value As Object,
    index As Integer,
    change As UndoChange,
    description As String
)

Parameters

item
Type: SystemObject
The object being changed.
value
Type: SystemObject
The current value of the object.
index
Type: SystemInt32
The index of the item or -1 if no index is required.
change
Type: Atalasoft.AnnotateUndoChange
The type of change being performed.
description
Type: SystemString
A short string describing the undo.
See Also

Reference

AnnotationUndo Class
AnnotationUndo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUndo Constructor (Object, String, Object[], String, Object[], String)

AnnotationUndo Constructor (Object, String, Object, String, Object, String)

Creates a new instance of AnnotationUndo for methods.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo(
    Object item,
    string undoMethodName,
    Object[] undoMethodParameters,
    string redoMethodName,
    Object[] redoMethodParameters,
    string description
)
Public Sub New (
    item As Object,
    undoMethodName As String,
    undoMethodParameters As Object(),
    redoMethodName As String,
    redoMethodParameters As Object(),
    description As String
)

Parameters

item
Type: SystemObject
The object where the undo and redo methods exist.
undoMethodName
Type: SystemString
The name of the method called when an undo is performed.
undoMethodParameters
Type: SystemObject
An object array containing the parameters sent to the undo method or null (Nothing in VB) if no parameters are required.
redoMethodName
Type: SystemString
The name of the method called when a redo is performed.
redoMethodParameters
Type: SystemObject
An object array containing the parameters sent to the redo method or null (Nothing in VB) if no parameters are required.
description
Type: SystemString
A string description of this undo action.
See Also

Reference

AnnotationUndo Class
AnnotationUndo Overload
Atalasoft.Annotate.UI Namespace


AnnotationUndo Properties

The AnnotationUndo type exposes the following members.

Properties
 | Name | Description
Public property | Change | Gets the type of undo change being performed.
Public property | Description | Gets the description of the undo.
Public property | Index | Gets the index of the item.
Public property | Item | Gets the object that was changed.
Public property | PropertyName | Gets the name of the property that was changed.
Public property | RedoMethodName | Gets the name of the method called when performing a redo.
Public property | RedoMethodParameters | Gets an object array containing the parameters used by the Redo method.
Public property | UndoMethodName | Gets the name of the method that will be called when an undo is performed.
Public property | UndoMethodParameters | Gets an object array of parameters sent to the Undo method.
Public property | Value | Gets the value of the object or property.
Top
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo.Change Property

AnnotationUndoChange Property

Gets the type of undo change being performed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoChange Change { get; }
Public ReadOnly Property Change As UndoChange
    Get

Property Value

Type: UndoChange
The type of change to undo or redo.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo.Description Property

AnnotationUndoDescription Property

Gets the description of the undo.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
A short string describing the undo action.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo.Index Property

AnnotationUndoIndex Property

Gets the index of the item.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the item or -1 if there is no index.
Remarks
This property is used to undo/redo collection inserts.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo.Item Property

AnnotationUndoItem Property

Gets the object that was changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Item { get; }
Public ReadOnly Property Item As Object
    Get

Property Value

Type: Object
The object to perform the undo or redo on.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo.PropertyName Property

AnnotationUndoPropertyName Property

Gets the name of the property that was changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get

Property Value

Type: String
The name of the property to undo or redo.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo.RedoMethodName Property

AnnotationUndoRedoMethodName Property

Gets the name of the method called when performing a redo.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RedoMethodName { get; }
Public ReadOnly Property RedoMethodName As String
    Get

Property Value

Type: String
The name of the method used by Redo.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace
RedoMethodParameters Property


AnnotationUndo.RedoMethodParameters Property

AnnotationUndoRedoMethodParameters Property

Gets an object array containing the parameters used by the Redo method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] RedoMethodParameters { get; }
Public ReadOnly Property RedoMethodParameters As Object()
    Get

Property Value

Type: Object
An object array of parameters for the Redo method.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace
RedoMethodName Property


AnnotationUndo.UndoMethodName Property

AnnotationUndoUndoMethodName Property

Gets the name of the method that will be called when an undo is performed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UndoMethodName { get; }
Public ReadOnly Property UndoMethodName As String
    Get

Property Value

Type: String
The name of the method called by Undo.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace
UndoMethodParameters Property


AnnotationUndo.UndoMethodParameters Property

AnnotationUndoUndoMethodParameters Property

Gets an object array of parameters sent to the Undo method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] UndoMethodParameters { get; }
Public ReadOnly Property UndoMethodParameters As Object()
    Get

Property Value

Type: Object
An object array of parameters used by the Undo method.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace
UndoMethodName Property


AnnotationUndo.Value Property

AnnotationUndoValue Property

Gets the value of the object or property.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get

Property Value

Type: Object
The value of the object or property that was changed.
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndo Methods

The AnnotationUndo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationUndo Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager Class

The AnnotationUndoManager keeps track of annotation changes and allows undo and redo functionality.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUndoManager

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationUndoManager
Public Class AnnotationUndoManager

The AnnotationUndoManager type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationUndoManager | Creates a new instance of AnnotationUndoManager.
Top
Properties
 | Name | Description
Public property | Levels | Gets or sets the number of undo/redo levels to keep in memory.
Public property | Merging | Gets a value indicating whether the manager is merging undos added into a single undo action.
Public property | RedoCount | Gets the number of redos available.
Public property | RedoDescription | Gets the description string of the redo that will be performed when Redo is called.
Public property | UndoCount | Gets the number of undos available.
Public property | UndoDescription | Gets the description string of the undo that will be performed when Undo is called.
Top
Methods
 | Name | Description
Public method | AddUndo | Adds an undo to the collection.
 | BeginUndoMerge | This method puts the AnnotationUndoManager into a collective undo state. All calls to AddUndo(AnnotationUndo) will be collected until the EndUndoMerge(String) method has been called.
Public method | Clear | Clears the undo and redo collections.
 | EndUndoMerge | Exits the collective undo state and stores all actions added since the BeginUndoMerge call as a single undo operation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRedoDescriptions | Returns a string array of the descriptions in the order which they would be redone. This is useful for displaying a list of items to redo. For displaying only the latest redo description use the RedoDescription method.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUndoDescriptions | Returns a string array of the descriptions in the order which they would be undone. This is useful for displaying a list of items to undo. For displaying only the latest undo description use the UndoDescription method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Performs a redo on the collection and raises the RedoRequest event with the AnnotationUndo that was processed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Performs an undo on the collection and raises the UndoRequest event with the AnnotationUndo that was processed.
Top
Events
 | Name | Description
Public event | RedoRequest | Raised when a call to Redo has been requested.
Public event | UndoListChanged | Raised when the items in the undo stack have changed.
Public event | UndoRequest | Raised when a call to Undo has been requested.
Top
Remarks
In addition to annotation property changes, the undo manager will track adding and removing annotations from a layer. This includes adding and removing LayerAnnotation objects in the LayerCollection.
See Also

Reference

Atalasoft.Annotate.UI Namespace


AnnotationUndoManager Constructor

Creates a new instance of AnnotationUndoManager.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndoManager()
Public Sub New
Remarks
The AnnotationController will automatically create an AnnotationUndoManager for its UndoManager property.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager Properties

The AnnotationUndoManager type exposes the following members.

Properties
 | Name | Description
Public property | Levels | Gets or sets the number of undo/redo levels to keep in memory.
Public property | Merging | Gets a value indicating whether the manager is merging undos added into a single undo action.
Public property | RedoCount | Gets the number of redos available.
Public property | RedoDescription | Gets the description string of the redo that will be performed when Redo is called.
Public property | UndoCount | Gets the number of undos available.
Public property | UndoDescription | Gets the description string of the undo that will be performed when Undo is called.
Top
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.Levels Property

AnnotationUndoManagerLevels Property

Gets or sets the number of undo/redo levels to keep in memory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Levels { get; set; }
Public Property Levels As Integer
    Get
    Set

Property Value

Type: Int32
The number of undo/redo levels.
Exceptions
Exception | Condition
 | Thrown if the value is set to less than zero.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.Merging Property

AnnotationUndoManagerMerging Property

Gets a value indicating whether the manager is merging undos added into a single undo action.
Gets a value indicating whether the manager is merging undos added into a single undo action.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Merging { get; }
Public ReadOnly Property Merging As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the manager is merging undos.

Property Value

Type: Boolean
A value indicating if the manager is merging undos.
Remarks
This property will be true between calls to the BeginUndoMerge and EndUndoMerge methods which allow multiple undos to be merged into a single undo action.
Remarks
This property will be true between calls to the BeginUndoMerge and EndUndoMerge(String) methods which allow multiple undos to be merged into a single undo action.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.RedoCount Property

AnnotationUndoManagerRedoCount Property

Gets the number of redos available.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RedoCount { get; }
Public ReadOnly Property RedoCount As Integer
    Get

Property Value

Type: Int32
The number of redos in the manager.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.RedoDescription Property

AnnotationUndoManagerRedoDescription Property

Gets the description string of the redo that will be performed when Redo is called.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RedoDescription { get; }
Public ReadOnly Property RedoDescription As String
    Get

Property Value

Type: String
The description of the next redo.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.UndoCount Property

AnnotationUndoManagerUndoCount Property

Gets the number of undos available.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndoCount { get; }
Public ReadOnly Property UndoCount As Integer
    Get

Property Value

Type: Int32
The number of undos currently in the manager.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.UndoDescription Property

AnnotationUndoManagerUndoDescription Property

Gets the description string of the undo that will be performed when Undo is called.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UndoDescription { get; }
Public ReadOnly Property UndoDescription As String
    Get

Property Value

Type: String
The description of the undo that will be performed.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager Methods

The AnnotationUndoManager type exposes the following members.

Methods
 | Name | Description
Public method | AddUndo | Adds an undo to the collection.
 | BeginUndoMerge | This method puts the AnnotationUndoManager into a collective undo state. All calls to AddUndo(AnnotationUndo) will be collected until the EndUndoMerge(String) method has been called.
Public method | Clear | Clears the undo and redo collections.
 | EndUndoMerge | Exits the collective undo state and stores all actions added since the BeginUndoMerge call as a single undo operation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRedoDescriptions | Returns a string array of the descriptions in the order which they would be redone. This is useful for displaying a list of items to redo. For displaying only the latest redo description use the RedoDescription method.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUndoDescriptions | Returns a string array of the descriptions in the order which they would be undone. This is useful for displaying a list of items to undo. For displaying only the latest undo description use the UndoDescription method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Performs a redo on the collection and raises the RedoRequest event with the AnnotationUndo that was processed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Performs an undo on the collection and raises the UndoRequest event with the AnnotationUndo that was processed.
Top
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.AddUndo Method

AnnotationUndoManagerAddUndo Method

Adds an undo to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddUndo(
    AnnotationUndo undo
)
Public Sub AddUndo (
    undo As AnnotationUndo
)

Parameters

undo
Type: Atalasoft.Annotate.UIAnnotationUndo
The AnnotationUndo to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the undo argument is null (Nothing in VB).
Remarks

Adding an undo will clear any redo objects.

Use the Undo method to restore this change.

See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.BeginUndoMerge Method

AnnotationUndoManagerBeginUndoMerge Method

This method puts the AnnotationUndoManager into a collective undo state. All calls to AddUndo(AnnotationUndo) will be collected until the EndUndoMerge(String) method has been called.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void BeginUndoMerge()
Public Sub BeginUndoMerge
Remarks
Use this method along with EndUndoMerge(String) to place multiple undo operations into a single undo request.
Examples
EndUndoMerge Example
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.Clear Method

AnnotationUndoManagerClear Method

Clears the undo and redo collections.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.EndUndoMerge Method

AnnotationUndoManagerEndUndoMerge Method

Exits the collective undo state and stores all actions added since the BeginUndoMerge call as a single undo operation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void EndUndoMerge(
    string description
)
Public Sub EndUndoMerge (
    description As String
)

Parameters

description
Type: SystemString
A short description of the collective undo action.
Examples
The following example combines multiple property changes into a single undo using the BeginUndoMerge and EndUndoMerge(String) methods.
UndoMerge
Copy
// Tell the AnnotationUndoManager to combine the undo changes.
this.annotateViewer1.Annotations.UndoManager.BeginUndoMerge();

// Make some changes to the active annotation.
AnnotationUI ann = this.annotateViewer1.Annotations.ActiveAnnotation;
ann.Data.Name = "My New Name";
ann.Data.Size = new SizeF(100, 120);
ann.Data.Location = new PointF(45, 60);

// Store the above changes into a single undo.
this.annotateViewer1.Annotations.UndoManager.EndUndoMerge();
UndoMergeVB
Copy
' Tell the AnnotationUndoManager to combine the undo changes.
Me.annotateViewer1.Annotations.UndoManager.BeginUndoMerge()

' Make some changes to the active annotation.
Dim ann As AnnotationUI =  Me.annotateViewer1.Annotations.ActiveAnnotation
ann.Data.Name = "My New Name"
ann.Data.Size = New SizeF(100, 120)
ann.Data.Location = New PointF(45, 60)

' Store the above changes into a single undo.
Me.annotateViewer1.Annotations.UndoManager.EndUndoMerge()
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.GetRedoDescriptions Method

AnnotationUndoManagerGetRedoDescriptions Method

Returns a string array of the descriptions in the order which they would be redone. This is useful for displaying a list of items to redo. For displaying only the latest redo description use the RedoDescription method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetRedoDescriptions()
Public Function GetRedoDescriptions As String()

Return Value

Type: String
A string array containing the redo descriptions.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.GetUndoDescriptions Method

AnnotationUndoManagerGetUndoDescriptions Method

Returns a string array of the descriptions in the order which they would be undone. This is useful for displaying a list of items to undo. For displaying only the latest undo description use the UndoDescription method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetUndoDescriptions()
Public Function GetUndoDescriptions As String()

Return Value

Type: String
An array of string descriptions for the undos.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.Redo Method

AnnotationUndoManagerRedo Method

Performs a redo on the collection and raises the RedoRequest event with the AnnotationUndo that was processed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Redo()
Public Sub Redo
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.Undo Method

AnnotationUndoManagerUndo Method

Performs an undo on the collection and raises the UndoRequest event with the AnnotationUndo that was processed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Undo()
Public Sub Undo
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager Events

The AnnotationUndoManager type exposes the following members.

Events
 | Name | Description
Public event | RedoRequest | Raised when a call to Redo has been requested.
Public event | UndoListChanged | Raised when the items in the undo stack have changed.
Public event | UndoRequest | Raised when a call to Undo has been requested.
Top
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.RedoRequest Event

AnnotationUndoManagerRedoRequest Event

Raised when a call to Redo has been requested.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event UndoEventHandler RedoRequest
Public Event RedoRequest As UndoEventHandler

Value

Type: Atalasoft.Annotate.UIUndoEventHandler
Remarks
The AnnotationUndoManager itself does not perform the redo action.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.UndoListChanged Event

AnnotationUndoManagerUndoListChanged Event

Raised when the items in the undo stack have changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler UndoListChanged
Public Event UndoListChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


AnnotationUndoManager.UndoRequest Event

AnnotationUndoManagerUndoRequest Event

Raised when a call to Undo has been requested.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event UndoEventHandler UndoRequest
Public Event UndoRequest As UndoEventHandler

Value

Type: Atalasoft.Annotate.UIUndoEventHandler
Remarks
The AnnotationUndoManager itself does not perform the undo action.
See Also

Reference

AnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationEventArgs Class

This class is used with the UndoPerformed and RedoPerformed events of CachedImageAnnotationUndoManager.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UICachedImageAnnotationEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CachedImageAnnotationEventArgs : EventArgs
Public Class CachedImageAnnotationEventArgs
    Inherits EventArgs

The CachedImageAnnotationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CachedImageAnnotationEventArgs | Creates a new instance of CachedImageAnnotationEventArgs.
Top
Properties
 | Name | Description
Public property | IsImageChange | Gets a value indicating whether the undo/redo change affected the image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


CachedImageAnnotationEventArgs Constructor

Creates a new instance of CachedImageAnnotationEventArgs.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CachedImageAnnotationEventArgs(
    bool isImageChange
)
Public Sub New (
    isImageChange As Boolean
)

Parameters

isImageChange
Type: SystemBoolean
Indicates if the event is due to an image change.
See Also

Reference

CachedImageAnnotationEventArgs Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationEventArgs Properties

The CachedImageAnnotationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsImageChange | Gets a value indicating whether the undo/redo change affected the image.
Top
See Also

Reference

CachedImageAnnotationEventArgs Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationEventArgs.IsImageChange Property

CachedImageAnnotationEventArgsIsImageChange Property

Gets a value indicating whether the undo/redo change affected the image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsImageChange { get; }
Public ReadOnly Property IsImageChange As Boolean
    Get

Property Value

Type: Boolean
True if the change affected the image. False if the change affected the annotations.
See Also

Reference

CachedImageAnnotationEventArgs Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationEventArgs Methods

The CachedImageAnnotationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CachedImageAnnotationEventArgs Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager Class

This class manages the undo and redo features of DocumentAnnotationViewer.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsCachedImageUndoManager
Atalasoft.Annotate.UICachedImageAnnotationUndoManager

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CachedImageAnnotationUndoManager : CachedImageUndoManager
Public Class CachedImageAnnotationUndoManager
    Inherits CachedImageUndoManager

The CachedImageAnnotationUndoManager type exposes the following members.

Constructors
 | Name | Description
Public method | CachedImageAnnotationUndoManager | Creates a new instance of CachedImageAnnotationUndoManager.
Top
Properties
 | Name | Description
Public property | RedoCount | Gets the number of redo items. (Inherited from CachedImageUndoManager.)
Public property | UndoCount | Gets the number of undo items. (Inherited from CachedImageUndoManager.)
Public property | UndoLevels | Gets or sets the maximum number of undo items to hold at any one time. (Inherited from CachedImageUndoManager.)
Top
Methods
 | Name | Description
Public method | AddUndo | Adds a new undo state to the manager. (Inherited from CachedImageUndoManager.)
Public method | Clear | Clears all undo and redo items. (Inherited from CachedImageUndoManager.)
Public method | Dispose | Releases all resources used by the CachedImageUndoManager. (Inherited from CachedImageUndoManager.)
Protected method | Dispose(Boolean) | Called from the Dispose and finalizer to release all resources for the CachedImageUndoManager. (Inherited from CachedImageUndoManager.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CachedImageUndoManager.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRedoCount | (Overrides CachedImageUndoManagerGetRedoCount.)
Public method | GetRedoDescriptions | Called to get an array of redo descriptions. (Inherited from CachedImageUndoManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUndoCount | (Overrides CachedImageUndoManagerGetUndoCount.)
Public method | GetUndoDescriptions | Called to get an array of undo descriptions. (Inherited from CachedImageUndoManager.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddUndo | (Overrides CachedImageUndoManagerOnAddUndo(AtalaImage, String).)
Protected method | OnClear | (Overrides CachedImageUndoManagerOnClear.)
Protected method | OnGetRedoDescriptions | (Overrides CachedImageUndoManagerOnGetRedoDescriptions.)
Protected method | OnGetUndoDescriptions | (Overrides CachedImageUndoManagerOnGetUndoDescriptions.)
Protected method | OnRedo | (Overrides CachedImageUndoManagerOnRedo.)
Protected method | OnRedoPerformed | (Overrides CachedImageUndoManagerOnRedoPerformed(EventArgs).)
Protected method | OnUndo | (Overrides CachedImageUndoManagerOnUndo(AtalaImage).)
Protected method | OnUndoLevelsChanged | (Overrides CachedImageUndoManagerOnUndoLevelsChanged(EventArgs).)
Protected method | OnUndoListChanged | Called when the undo/redo lists have changed and raises the UndoListChanged event. (Inherited from CachedImageUndoManager.)
Protected method | OnUndoPerformed | (Overrides CachedImageUndoManagerOnUndoPerformed(EventArgs).)
Public method | Redo | Performs a redo operation and returns the resulting image. (Inherited from CachedImageUndoManager.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Performs an undo operation and returns the resulting image. (Inherited from CachedImageUndoManager.)
Top
Events
 | Name | Description
Public event | RedoPerformed | Raised when a redo operation has been performed. (Inherited from CachedImageUndoManager.)
Public event | UndoListChanged | Raised when the undo/redo lists have changed. (Inherited from CachedImageUndoManager.)
Public event | UndoPerformed | Raised when an undo operation has been performed. (Inherited from CachedImageUndoManager.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager Constructor

Creates a new instance of CachedImageAnnotationUndoManager.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CachedImageAnnotationUndoManager(
    AnnotationUndoManager annotationUndoManager
)
Public Sub New (
    annotationUndoManager As AnnotationUndoManager
)

Parameters

annotationUndoManager
Type: Atalasoft.Annotate.UIAnnotationUndoManager
The AnnotationUndoManager used by the AnnotationController that contains the annotations.
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager Properties

The CachedImageAnnotationUndoManager type exposes the following members.

Properties
 | Name | Description
Public property | RedoCount | Gets the number of redo items. (Inherited from CachedImageUndoManager.)
Public property | UndoCount | Gets the number of undo items. (Inherited from CachedImageUndoManager.)
Public property | UndoLevels | Gets or sets the maximum number of undo items to hold at any one time. (Inherited from CachedImageUndoManager.)
Top
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager Methods

The CachedImageAnnotationUndoManager type exposes the following members.

Methods
 | Name | Description
Public method | AddUndo | Adds a new undo state to the manager. (Inherited from CachedImageUndoManager.)
Public method | Clear | Clears all undo and redo items. (Inherited from CachedImageUndoManager.)
Public method | Dispose | Releases all resources used by the CachedImageUndoManager. (Inherited from CachedImageUndoManager.)
Protected method | Dispose(Boolean) | Called from the Dispose and finalizer to release all resources for the CachedImageUndoManager. (Inherited from CachedImageUndoManager.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CachedImageUndoManager.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRedoCount | (Overrides CachedImageUndoManagerGetRedoCount.)
Public method | GetRedoDescriptions | Called to get an array of redo descriptions. (Inherited from CachedImageUndoManager.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUndoCount | (Overrides CachedImageUndoManagerGetUndoCount.)
Public method | GetUndoDescriptions | Called to get an array of undo descriptions. (Inherited from CachedImageUndoManager.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddUndo | (Overrides CachedImageUndoManagerOnAddUndo(AtalaImage, String).)
Protected method | OnClear | (Overrides CachedImageUndoManagerOnClear.)
Protected method | OnGetRedoDescriptions | (Overrides CachedImageUndoManagerOnGetRedoDescriptions.)
Protected method | OnGetUndoDescriptions | (Overrides CachedImageUndoManagerOnGetUndoDescriptions.)
Protected method | OnRedo | (Overrides CachedImageUndoManagerOnRedo.)
Protected method | OnRedoPerformed | (Overrides CachedImageUndoManagerOnRedoPerformed(EventArgs).)
Protected method | OnUndo | (Overrides CachedImageUndoManagerOnUndo(AtalaImage).)
Protected method | OnUndoLevelsChanged | (Overrides CachedImageUndoManagerOnUndoLevelsChanged(EventArgs).)
Protected method | OnUndoListChanged | Called when the undo/redo lists have changed and raises the UndoListChanged event. (Inherited from CachedImageUndoManager.)
Protected method | OnUndoPerformed | (Overrides CachedImageUndoManagerOnUndoPerformed(EventArgs).)
Public method | Redo | Performs a redo operation and returns the resulting image. (Inherited from CachedImageUndoManager.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Performs an undo operation and returns the resulting image. (Inherited from CachedImageUndoManager.)
Top
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.GetRedoCount Method

CachedImageAnnotationUndoManagerGetRedoCount Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int GetRedoCount()
Protected Overrides Function GetRedoCount As Integer

Return Value

Type: Int32
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.GetUndoCount Method

CachedImageAnnotationUndoManagerGetUndoCount Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int GetUndoCount()
Protected Overrides Function GetUndoCount As Integer

Return Value

Type: Int32
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnAddUndo Method

CachedImageAnnotationUndoManagerOnAddUndo Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAddUndo(
    AtalaImage image,
    string description
)
Protected Overrides Sub OnAddUndo (
    image As AtalaImage,
    description As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
description
Type: SystemString
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnClear Method

CachedImageAnnotationUndoManagerOnClear Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClear()
Protected Overrides Sub OnClear
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnGetRedoDescriptions Method

CachedImageAnnotationUndoManagerOnGetRedoDescriptions Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string[] OnGetRedoDescriptions()
Protected Overrides Function OnGetRedoDescriptions As String()

Return Value

Type: String
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnGetUndoDescriptions Method

CachedImageAnnotationUndoManagerOnGetUndoDescriptions Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string[] OnGetUndoDescriptions()
Protected Overrides Function OnGetUndoDescriptions As String()

Return Value

Type: String
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnRedo Method

CachedImageAnnotationUndoManagerOnRedo Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage OnRedo()
Protected Overrides Function OnRedo As AtalaImage

Return Value

Type: AtalaImage
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnRedoPerformed Method

CachedImageAnnotationUndoManagerOnRedoPerformed Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRedoPerformed(
    EventArgs e
)
Protected Overrides Sub OnRedoPerformed (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnUndo Method

CachedImageAnnotationUndoManagerOnUndo Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage OnUndo(
    AtalaImage redoImage
)
Protected Overrides Function OnUndo (
    redoImage As AtalaImage
) As AtalaImage

Parameters

redoImage
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnUndoLevelsChanged Method

CachedImageAnnotationUndoManagerOnUndoLevelsChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnUndoLevelsChanged(
    EventArgs e
)
Protected Overrides Sub OnUndoLevelsChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager.OnUndoPerformed Method

CachedImageAnnotationUndoManagerOnUndoPerformed Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnUndoPerformed(
    EventArgs e
)
Protected Overrides Sub OnUndoPerformed (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CachedImageAnnotationUndoManager Events

The CachedImageAnnotationUndoManager type exposes the following members.

Events
 | Name | Description
Public event | RedoPerformed | Raised when a redo operation has been performed. (Inherited from CachedImageUndoManager.)
Public event | UndoListChanged | Raised when the undo/redo lists have changed. (Inherited from CachedImageUndoManager.)
Public event | UndoPerformed | Raised when an undo operation has been performed. (Inherited from CachedImageUndoManager.)
Top
See Also

Reference

CachedImageAnnotationUndoManager Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Class

This annotation is designed to provide additional information on a specific area of the document. It contains an editable text area and a leader line used to point to the area of the document.

When creating this annotation, the first click sets the target for the leader and a second click sets the annotation location. It can also be created by pressing down the mouse button to set the leader and dragging. Both annotation and leader point can be repositioned independently after the annotation has been created.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UICalloutAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CalloutAnnotation : AnnotationUI,
    IDisposable
<SerializableAttribute>
Public Class CalloutAnnotation
    Inherits AnnotationUI
    Implements IDisposable

The CalloutAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | CalloutAnnotation | Creates a new instance of CalloutAnnotation.
Public method | CalloutAnnotation(String) | Creates a new instance of CalloutAnnotation specifying the text for the annotation.
Public method | CalloutAnnotation(CalloutData) | Creates a new instance of CalloutAnnotation specifying the CalloutData object used by the annotation.
Public method | CalloutAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of CalloutAnnotation from serialized information.
Public method | CalloutAnnotation(String, AnnotationFont, AnnotationBrush, Single) | Creates a new instance of CalloutAnnotation specifying the text, font and font brush for the annotation.
Public method | CalloutAnnotation(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single) | Creates a new instance of CalloutAnnotation specifying the text, font, font brush, outline and line pen.
Public method | CalloutAnnotation(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single, PointF, Boolean) | Creates a new instance of CalloutAnnotation specifying its parameters.
Top
Properties
 | Name | Description
Public property | AllowEditing | Gets or sets a value indicating whether [allow editing].
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | EditMode | Gets or sets a value indicating whether the annotation text is currently in edit mode.
Public property | Fill | Gets or sets the brush used to fill the text area of the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Leader | Gets or sets the pen used for the line of the annotation.
Public property | LeaderFlatLength | Gets or sets the length of the leader line to the bend.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to outline the text area of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | TargetPosition | Gets or sets the position on the document the line will point to.
Public property | Text | Gets or sets the text of the annotation.
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | (Overrides AnnotationUIBeginCreate.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the CalloutAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Overrides AnnotationUIGetConfinedLocation(RectangleF, PointF).)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
 | HideEditDialog | Removes the edit control from the viewer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Overrides AnnotationUIOnDoubleClick(EventArgs).)
Protected method | OnGripPositionChanged | (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Overrides AnnotationUIOnRotateDocument(DocumentRotation).)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Overrides AnnotationUIOnRotating(EventArgs).)
Protected method | OnScrollPositionChanged | (Overrides AnnotationUIOnScrollPositionChanged(ScrollPositionChangedEventArgs).)
Protected method | OnSelectedChanged | (Overrides AnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Protected method | ShowEditDialog | Adds an edit control to the viewer to allow the user to change the text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor

Constructs a CalloutAnnotation.
Overload List
 | Name | Description
Public method | CalloutAnnotation | Creates a new instance of CalloutAnnotation.
Public method | CalloutAnnotation(String) | Creates a new instance of CalloutAnnotation specifying the text for the annotation.
Public method | CalloutAnnotation(CalloutData) | Creates a new instance of CalloutAnnotation specifying the CalloutData object used by the annotation.
Public method | CalloutAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of CalloutAnnotation from serialized information.
Public method | CalloutAnnotation(String, AnnotationFont, AnnotationBrush, Single) | Creates a new instance of CalloutAnnotation specifying the text, font and font brush for the annotation.
Public method | CalloutAnnotation(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single) | Creates a new instance of CalloutAnnotation specifying the text, font, font brush, outline and line pen.
Public method | CalloutAnnotation(String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single, PointF, Boolean) | Creates a new instance of CalloutAnnotation specifying its parameters.
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor

Creates a new instance of CalloutAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation()
Public Sub New
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor (String)

Creates a new instance of CalloutAnnotation specifying the text for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text for the annotation.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor (CalloutData)

Creates a new instance of CalloutAnnotation specifying the CalloutData object used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    CalloutData data
)
Public Sub New (
    data As CalloutData
)

Parameters

data
Type: Atalasoft.AnnotateCalloutData
The CalloutData used with this annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of CalloutAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the serialized information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor (String, AnnotationFont, AnnotationBrush, Single)

Creates a new instance of CalloutAnnotation specifying the text, font and font brush for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    float padding
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    padding As Single
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
padding
Type: SystemSingle
The amount of space around the text.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor (String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single)

Creates a new instance of CalloutAnnotation specifying the text, font, font brush, outline and line pen.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    float padding,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationPen leader,
    float leaderFlatLength
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    padding As Single,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    leader As AnnotationPen,
    leaderFlatLength As Single
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
padding
Type: SystemSingle
The amount of space around the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the text area of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render an outline around the text area of the annotation.
leader
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the line of the annotation.
leaderFlatLength
Type: SystemSingle
The length from the annotation to the leader bend.
Exceptions
Exception | Condition
 | Thrown if the leaderFlatLength is less than 0.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Constructor (String, AnnotationFont, AnnotationBrush, Single, AnnotationBrush, AnnotationPen, AnnotationPen, Single, PointF, Boolean)

Creates a new instance of CalloutAnnotation specifying its parameters.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    float padding,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationPen leader,
    float leaderFlatLength,
    PointF targetPosition,
    bool autoSize
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    padding As Single,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    leader As AnnotationPen,
    leaderFlatLength As Single,
    targetPosition As PointF,
    autoSize As Boolean
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
padding
Type: SystemSingle
The amount of space around the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the text area of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render an outline around the text area of the annotation.
leader
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the line of the annotation.
leaderFlatLength
Type: SystemSingle
The length from the annotation to the leader bend.
targetPosition
Type: System.DrawingPointF
The document position the line will point to.
autoSize
Type: SystemBoolean
Indicates whether the annotation will automatically resize to fit the text.
Exceptions
Exception | Condition
 | Thrown if the leaderFlatLength is less than 0.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Properties

The CalloutAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AllowEditing | Gets or sets a value indicating whether [allow editing].
Public property | AutoSize | Gets or sets a value indicating whether the annotation will automatically resize to fit the text.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | EditMode | Gets or sets a value indicating whether the annotation text is currently in edit mode.
Public property | Fill | Gets or sets the brush used to fill the text area of the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Leader | Gets or sets the pen used for the line of the annotation.
Public property | LeaderFlatLength | Gets or sets the length of the leader line to the bend.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the pen used to outline the text area of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | TargetPosition | Gets or sets the position on the document the line will point to.
Public property | Text | Gets or sets the text of the annotation.
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.AllowEditing Property

CalloutAnnotationAllowEditing Property

Gets or sets a value indicating whether [allow editing].

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [allow editing]; otherwise, false.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.AutoSize Property

CalloutAnnotationAutoSize Property

Gets or sets a value indicating whether the annotation will automatically resize to fit the text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation will resize to fit the text.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.EditMode Property

CalloutAnnotationEditMode Property

Gets or sets a value indicating whether the annotation text is currently in edit mode.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EditMode { get; set; }
Public Property EditMode As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation text is in edit mode.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Fill Property

CalloutAnnotationFill Property

Gets or sets the brush used to fill the text area of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the text area.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Font Property

CalloutAnnotationFont Property

Gets or sets the font used to render the text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used to render the text.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.FontBrush Property

CalloutAnnotationFontBrush Property

Gets or sets the brush used to render the text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to render the text.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Leader Property

CalloutAnnotationLeader Property

Gets or sets the pen used for the line of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Leader { get; set; }
Public Property Leader As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the line or null (Nothing in VB) if a leader isn't used.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.LeaderFlatLength Property

CalloutAnnotationLeaderFlatLength Property

Gets or sets the length of the leader line to the bend.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float LeaderFlatLength { get; set; }
Public Property LeaderFlatLength As Single
    Get
    Set

Property Value

Type: Single
The length of the leader line to the bend.
Exceptions
Exception | Condition
 | Thrown if the value is less than 0.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Outline Property

CalloutAnnotationOutline Property

Gets or sets the pen used to outline the text area of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the text area outline.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.TargetPosition Property

CalloutAnnotationTargetPosition Property

Gets or sets the position on the document the line will point to.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF TargetPosition { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property TargetPosition As PointF
    Get
    Set

Property Value

Type: PointF
The position on the document this callout will point to.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Text Property

CalloutAnnotationText Property

Gets or sets the text of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text of the annotation.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Methods

The CalloutAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | (Overrides AnnotationUIBeginCreate.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the CalloutAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Overrides AnnotationUIGetConfinedLocation(RectangleF, PointF).)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
 | HideEditDialog | Removes the edit control from the viewer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Overrides AnnotationUIOnDoubleClick(EventArgs).)
Protected method | OnGripPositionChanged | (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Overrides AnnotationUIOnRotateDocument(DocumentRotation).)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Overrides AnnotationUIOnRotating(EventArgs).)
Protected method | OnScrollPositionChanged | (Overrides AnnotationUIOnScrollPositionChanged(ScrollPositionChangedEventArgs).)
Protected method | OnSelectedChanged | (Overrides AnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Protected method | ShowEditDialog | Adds an edit control to the viewer to allow the user to change the text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.BeginCreate Method

CalloutAnnotationBeginCreate Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void BeginCreate()
Public Overrides Sub BeginCreate
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Clone Method

CalloutAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Dispose Method

CalloutAnnotationDispose Method

Disposes the CalloutAnnotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Dispose Method

CalloutAnnotationDispose Method

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CalloutAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Dispose Method (Boolean)

CalloutAnnotationDispose Method (Boolean)

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

CalloutAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.Finalize Method

CalloutAnnotationFinalize Method

Finalizes an instance of the CalloutAnnotation class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.GetConfinedLocation Method

CalloutAnnotationGetConfinedLocation Method

These methods are used by the AnnotationController to handle annotation confinement.
Overload List
 | Name | Description
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Overrides AnnotationUIGetConfinedLocation(RectangleF, PointF).)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.GetConfinedLocation Method (RectangleF, PointF)

CalloutAnnotationGetConfinedLocation Method (RectangleF, PointF)

Returns the new confined location of the annotation when a confinement bounds and new location offset are provided.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PointF GetConfinedLocation(
    RectangleF dsConfinedBounds,
    PointF dsLocationOffset
)
Public Overrides Function GetConfinedLocation (
    dsConfinedBounds As RectangleF,
    dsLocationOffset As PointF
) As PointF

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
The bounding rectangle in document space for the confinement.
dsLocationOffset
Type: System.DrawingPointF
The difference between the current and suggested new location of the annotation in document space units.

Return Value

Type: PointF
See Also

Reference

CalloutAnnotation Class
GetConfinedLocation Overload
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.GetRegion Method

CalloutAnnotationGetRegion Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace

Return Value

Type: AnnotationRegion
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.HideEditDialog Method

CalloutAnnotationHideEditDialog Method

Removes the edit control from the viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void HideEditDialog()
Protected Overridable Sub HideEditDialog
Remarks
This method can be overridden to provide a custom edit control.
Examples
ShowEditDialog Example
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnDoubleClick Method

CalloutAnnotationOnDoubleClick Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDoubleClick(
    EventArgs e
)
Protected Overrides Sub OnDoubleClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnGripPositionChanged Method

CalloutAnnotationOnGripPositionChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    AnnotationGripChangedEventArgs e
)
Protected Overrides Sub OnGripPositionChanged (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnMouseDown Method

CalloutAnnotationOnMouseDown Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnMouseMove Method

CalloutAnnotationOnMouseMove Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnMouseUp Method

CalloutAnnotationOnMouseUp Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs

Return Value

Type: Boolean
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnMoving Method

CalloutAnnotationOnMoving Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnPropertyChanging Method

CalloutAnnotationOnPropertyChanging Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnResizing Method

CalloutAnnotationOnResizing Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResizing(
    EventArgs e
)
Protected Overrides Sub OnResizing (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnRotateDocument Method

CalloutAnnotationOnRotateDocument Method

Called when the RotateDocument(DocumentRotation, Int32) method is used.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRotateDocument(
    DocumentRotation rotation
)
Protected Overrides Sub OnRotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnRotating Method

CalloutAnnotationOnRotating Method

Called while an annotation is being rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRotating(
    EventArgs e
)
Protected Overrides Sub OnRotating (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnScrollPositionChanged Method

CalloutAnnotationOnScrollPositionChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnScrollPositionChanged(
    ScrollPositionChangedEventArgs e
)
Protected Overrides Sub OnScrollPositionChanged (
    e As ScrollPositionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIScrollPositionChangedEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.OnSelectedChanged Method

CalloutAnnotationOnSelectedChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSelectedChanged(
    EventArgs e
)
Protected Overrides Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation.ShowEditDialog Method

CalloutAnnotationShowEditDialog Method

Adds an edit control to the viewer to allow the user to change the text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ShowEditDialog()
Protected Overridable Sub ShowEditDialog
Remarks
This method can be overridden to provide a custom edit control.
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotation Events

The CalloutAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotationFactory Class

This class generates a CalloutAnnotation object from a CalloutData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UICalloutAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class CalloutAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class CalloutAnnotationFactory
    Implements IAnnotationUIFactory

The CalloutAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | CalloutAnnotationFactory | Creates a new instance of CalloutAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a CalloutAnnotation if the data object is a CalloutData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


CalloutAnnotationFactory Constructor

Creates a new instance of CalloutAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotationFactory()
Public Sub New
See Also

Reference

CalloutAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotationFactory Methods

The CalloutAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a CalloutAnnotation if the data object is a CalloutData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalloutAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


CalloutAnnotationFactory.GetAnnotationUI Method

CalloutAnnotationFactoryGetAnnotationUI Method

Returns a CalloutAnnotation if the data object is a CalloutData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object for the annotation.

Return Value

Type: AnnotationUI
A CalloutAnnotation or null (Nothing in Visual Basic) if the data parameter is not a CalloutData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

CalloutAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


CreatePdfAnnotationDataExporterEventArgs Class

This class provides information for events that create Pdf AnnotationData Exporters.
This class provides information for events that create Pdf AnnotationData Exporters.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UICreatePdfAnnotationDataExporterEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CreatePdfAnnotationDataExporterEventArgs : EventArgs
Public Class CreatePdfAnnotationDataExporterEventArgs
    Inherits EventArgs

The CreatePdfAnnotationDataExporterEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CreatePdfAnnotationDataExporterEventArgs | Initializes a new instance of the CreatePdfAnnotationDataExporterEventArgs class
Top
Properties
 | Name | Description
Public property | Layers | The annotations that are going to be stored in the PDF
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


CreatePdfAnnotationDataExporterEventArgs Constructor

Initializes a new instance of the CreatePdfAnnotationDataExporterEventArgs class

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CreatePdfAnnotationDataExporterEventArgs()
Public Sub New
See Also

Reference

CreatePdfAnnotationDataExporterEventArgs Class
Atalasoft.Annotate.UI Namespace


CreatePdfAnnotationDataExporterEventArgs Properties

The CreatePdfAnnotationDataExporterEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Layers | The annotations that are going to be stored in the PDF
Top
See Also

Reference

CreatePdfAnnotationDataExporterEventArgs Class
Atalasoft.Annotate.UI Namespace


CreatePdfAnnotationDataExporterEventArgs.Layers Property

CreatePdfAnnotationDataExporterEventArgsLayers Property

The annotations that are going to be stored in the PDF

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataCollection Layers { get; set; }
Public Property Layers As AnnotationDataCollection
    Get
    Set

Property Value

Type: AnnotationDataCollection
See Also

Reference

CreatePdfAnnotationDataExporterEventArgs Class
Atalasoft.Annotate.UI Namespace


CreatePdfAnnotationDataExporterEventArgs Methods

The CreatePdfAnnotationDataExporterEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreatePdfAnnotationDataExporterEventArgs Class
Atalasoft.Annotate.UI Namespace


CreatePdfAnnotationDataExporterHandler Delegate

This delegate is used when viewers need to create a PdfAnnotationDataExporter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate PdfAnnotationDataExporter CreatePdfAnnotationDataExporterHandler(
    Object sender,
    CreatePdfAnnotationDataExporterEventArgs e
)
Public Delegate Function CreatePdfAnnotationDataExporterHandler (
    sender As Object,
    e As CreatePdfAnnotationDataExporterEventArgs
) As PdfAnnotationDataExporter

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Annotate.UICreatePdfAnnotationDataExporterEventArgs
An event args with more information about the event

Return Value

Type: PdfAnnotationDataExporter
See Also

Reference

Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer Class

The DocumentAnnotationViewer control simplifies the process of synchronizing a ThumbnailView with an AnnotateViewer.

The control's ThumbnailView can be docked on any side using the ThumbnailDockStyle property. A Separator can be enabled, allowing the end user to resize the ThumbnailView and the AnnotateViewer will fill the rest of the control.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsDocumentViewer
Atalasoft.Annotate.UIDocumentAnnotationViewer

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentAnnotationViewer : DocumentViewer
Public Class DocumentAnnotationViewer
    Inherits DocumentViewer

The DocumentAnnotationViewer type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentAnnotationViewer | Creates a new instance of DocumentAnnotationViewer.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnnotationDataProvider | Gets or sets the provider class used for loading annotation data. If this property is null (Nothing in VB) we will automatically extract embedded annotation data from JPEG, TIFF and PDF files.
Public property | Annotations | Gets the AnnotationController used by the DocumentAnnotationViewer.
Public property | AnnotationSaveOptionsHandler | Gets or sets the delegate used for annotation saving options. If this property is null (Nothing in VB) the annotations will be embedded into JPEG, TIFF and PDF files.
Public property | Asynchronous | Indicates whether processing is performed in a background thread. The default value is false (Inherited from DocumentViewer.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Count | Gets the number of thumbnails in the ThumbnailView. (Inherited from DocumentViewer.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CurrentImageIndex | Gets the index of the image loaded in the viewer. (Inherited from DocumentViewer.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
 | ImageControl | Gets the image control properties. (Inherited from DocumentViewer.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoCount | Gets the number of redo operations. (Inherited from DocumentViewer.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectFirstPageOnOpen | Gets or sets a value indicating whether the first page of an image is automatically selected after a call to Open(String). (Inherited from DocumentViewer.)
 | Separator | Gets the properties used for the separator. (Inherited from DocumentViewer.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | SquareResolutionRequired | Gets or sets a value indicating whether the images must have equal X and Y resolution values. (Inherited from DocumentViewer.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
 | ThumbnailControl | Gets the ThumbnailView properties. (Inherited from DocumentViewer.)
 | ThumbnailControlSize | Gets or sets the width or height of the ThumbnailView. (Inherited from DocumentViewer.)
 | ThumbnailDockStyle | Gets or sets a value indicating which side the thumbnail control should be docked against. (Inherited from DocumentViewer.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoCount | Gets the number of undo operations. (Inherited from DocumentViewer.)
Public property | UndoLevels | Gets or sets the maximum number of undo operations to hold. (Inherited from DocumentViewer.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the DocumentViewer. (Inherited from DocumentViewer.)
 | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from an image and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages from a file into the control and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
 | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Add(AtalaImage, String, String) | Adds an AtalaImage to the thumbnail control. (Inherited from DocumentViewer.)
Public method | Add(Stream, Int32, String, String) | Loads one or more images from a Stream. (Inherited from DocumentViewer.)
Public method | Add(String, Int32, String, String) | Adds one or more images from a file. (Inherited from DocumentViewer.)
Public method | ApplyCommand | (Inherited from DocumentViewer.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | (Inherited from DocumentViewer.)
Public method | ClearSelection | (Inherited from DocumentViewer.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DocumentAnnotationViewer and optionally releases the managed resources (Overrides DocumentViewerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | (Inherited from DocumentViewer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DocumentViewer.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetImageSource | (Inherited from DocumentViewer.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTemporaryXmpFileName | Returns the temorary filename used by the DocumentAnnotationViewer to store XMP annotation data. (Inherited from DocumentViewer.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert(Int32, RandomAccessImageSource) | Inserts images from a RandomAccessImageSource into the collection. (Inherited from DocumentViewer.)
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all images from a stream into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an AtalaImage into the thumbnail control. (Inherited from DocumentViewer.)
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts one or more images into the ThumbnailView from a Stream. (Inherited from DocumentViewer.)
Public method | Insert(Int32, String, Int32, String, String) | Inserts one or more images into the ThumbnailView from a file. (Inherited from DocumentViewer.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsThumbnailVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is currently visible. (Inherited from DocumentViewer.)
Public method | IsThumbnailVisible(Thumbnail, Boolean) | Returns a value indicating whether the specified thumbnail is currently visible. (Inherited from DocumentViewer.)
Public method | LoadAnnotationData | Loads annotation data into the viewer for the specified page.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClear | (Overrides DocumentViewerOnClear.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from DocumentViewer.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | (Inherited from DocumentViewer.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageInserted | (Overrides DocumentViewerOnImageInserted(ImageInsertEventArgs).)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnOpenDocument | (Overrides DocumentViewerOnOpenDocument(OpenDocumentEventArgs).)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Inherited from DocumentViewer.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPrintingPage | (Overrides DocumentViewerOnPrintingPage(PrintImageEventArgs).)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | (Overrides DocumentViewerOnSelectedIndexChanged(EventArgs).)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailControlSizeChanged | (Inherited from DocumentViewer.)
Protected method | OnThumbnailDockStyleChanged | (Inherited from DocumentViewer.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
 | Open(Stream) | Opens all pages of an image from a stream. (Inherited from DocumentViewer.)
Public method | Open(String) | Opens an image from a filename. If the file is a multipage document, all pages are added to the control. (Inherited from DocumentViewer.)
 | Open(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the viewer. (Inherited from DocumentViewer.)
 | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Open(Stream, Int32) | Opens the specified page from an image. (Inherited from DocumentViewer.)
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages in an image and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Open(String, Int32) | Opens the specified frame index from a file. (Inherited from DocumentViewer.)
 | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Open(Stream, Int32, String, String) | Opens the specified page from an image and provides the thumbnail caption and tooltip. (Inherited from DocumentViewer.)
Public method | Open(String, Int32, String, String) | Opens the specified frame from an image and provides the thumbnail caption and tooltip. (Inherited from DocumentViewer.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | Print | This method will print the contents of the DocumentViewer. (Inherited from DocumentViewer.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Performs a redo operation on the viewer. (Inherited from DocumentViewer.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshCurrentImageThumbnail | This method will force the DocumentAnnotationViewer to refresh the thumbnail for the current image.
Public method | Remove | (Inherited from DocumentViewer.)
Public method | RemoveAt | (Inherited from DocumentViewer.)
Public method | RemoveSelected | (Inherited from DocumentViewer.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RotateDocument | Rotates the current image and its annotations.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the current image for single page encoders or all pages for multipage encoders. By default, annotations will be embedded into JPEG, TIFF and PDF files. Set the AnnotationSaveOptionsHandler property to control the annotation save behavior. (Overrides DocumentViewerSave(Stream, ImageEncoder).)
Public method | Save(String, ImageEncoder) | Saves the image(s) to a file using the supplied encoder. (Inherited from DocumentViewer.)
Public method | SaveAnnotationData | This method will save the annotations into the provided stream.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | (Inherited from DocumentViewer.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectThumbnail | (Inherited from DocumentViewer.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetImageViewer | Use this method to replace the standard ImageViewer with another control deriving from ImageViewer. (Inherited from DocumentViewer.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetUndoManager | Call this method to replace the default CachedImageUndoManager with a custom version. (Inherited from DocumentViewer.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetZoomMode | (Inherited from DocumentViewer.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Performs an undo operation on the viewer. (Inherited from DocumentViewer.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AfterLabelEdit | (Inherited from DocumentViewer.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | (Inherited from DocumentViewer.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CreatePdfAnnotationDataExporter | Add a handler to this event if you want to create your own PdfAnnotationDataExporter object for use when saving annotations into a PDF. You may want to do this if you have custom PDF export policies that you want to install in it.
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PrintingPage | Raised as each page is about to be printed. (Inherited from DocumentViewer.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RedoPerformed | Raised when a redo operation has been performed. (Inherited from DocumentViewer.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | (Inherited from DocumentViewer.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | UndoListChanged | Raised when there has been a change in the undo/redo lists. (Inherited from DocumentViewer.)
Public event | UndoPerformed | Raised when an undo operation has been performed. (Inherited from DocumentViewer.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer Constructor

Creates a new instance of DocumentAnnotationViewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentAnnotationViewer()
Public Sub New
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer Properties

The DocumentAnnotationViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnnotationDataProvider | Gets or sets the provider class used for loading annotation data. If this property is null (Nothing in VB) we will automatically extract embedded annotation data from JPEG, TIFF and PDF files.
Public property | Annotations | Gets the AnnotationController used by the DocumentAnnotationViewer.
Public property | AnnotationSaveOptionsHandler | Gets or sets the delegate used for annotation saving options. If this property is null (Nothing in VB) the annotations will be embedded into JPEG, TIFF and PDF files.
Public property | Asynchronous | Indicates whether processing is performed in a background thread. The default value is false (Inherited from DocumentViewer.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Count | Gets the number of thumbnails in the ThumbnailView. (Inherited from DocumentViewer.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CurrentImageIndex | Gets the index of the image loaded in the viewer. (Inherited from DocumentViewer.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
 | ImageControl | Gets the image control properties. (Inherited from DocumentViewer.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoCount | Gets the number of redo operations. (Inherited from DocumentViewer.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectFirstPageOnOpen | Gets or sets a value indicating whether the first page of an image is automatically selected after a call to Open(String). (Inherited from DocumentViewer.)
 | Separator | Gets the properties used for the separator. (Inherited from DocumentViewer.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | SquareResolutionRequired | Gets or sets a value indicating whether the images must have equal X and Y resolution values. (Inherited from DocumentViewer.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
 | ThumbnailControl | Gets the ThumbnailView properties. (Inherited from DocumentViewer.)
 | ThumbnailControlSize | Gets or sets the width or height of the ThumbnailView. (Inherited from DocumentViewer.)
 | ThumbnailDockStyle | Gets or sets a value indicating which side the thumbnail control should be docked against. (Inherited from DocumentViewer.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoCount | Gets the number of undo operations. (Inherited from DocumentViewer.)
Public property | UndoLevels | Gets or sets the maximum number of undo operations to hold. (Inherited from DocumentViewer.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.AnnotationDataProvider Property

DocumentAnnotationViewerAnnotationDataProvider Property

Gets or sets the provider class used for loading annotation data.

If this property is null (Nothing in VB) we will automatically extract embedded annotation data from JPEG, TIFF and PDF files.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationDataProvider AnnotationDataProvider { get; set; }
Public Property AnnotationDataProvider As IAnnotationDataProvider
    Get
    Set

Property Value

Type: IAnnotationDataProvider
The data provider used to load annotations.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.Annotations Property

DocumentAnnotationViewerAnnotations Property

Gets the AnnotationController used by the DocumentAnnotationViewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController Annotations { get; }
Public ReadOnly Property Annotations As AnnotationController
    Get

Property Value

Type: AnnotationController
The AnnotationController used by the viewer.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.AnnotationSaveOptionsHandler Property

DocumentAnnotationViewerAnnotationSaveOptionsHandler Property

Gets or sets the delegate used for annotation saving options.

If this property is null (Nothing in VB) the annotations will be embedded into JPEG, TIFF and PDF files.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationSaveOptionsHandler AnnotationSaveOptionsHandler { get; set; }
Public Property AnnotationSaveOptionsHandler As AnnotationSaveOptionsHandler
    Get
    Set

Property Value

Type: AnnotationSaveOptionsHandler
The delegate used for annotation saving options.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer Methods

The DocumentAnnotationViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the DocumentViewer. (Inherited from DocumentViewer.)
 | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from an image and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages from a file into the control and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
 | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Add(AtalaImage, String, String) | Adds an AtalaImage to the thumbnail control. (Inherited from DocumentViewer.)
Public method | Add(Stream, Int32, String, String) | Loads one or more images from a Stream. (Inherited from DocumentViewer.)
Public method | Add(String, Int32, String, String) | Adds one or more images from a file. (Inherited from DocumentViewer.)
Public method | ApplyCommand | (Inherited from DocumentViewer.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | (Inherited from DocumentViewer.)
Public method | ClearSelection | (Inherited from DocumentViewer.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides DocumentViewerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | (Inherited from DocumentViewer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DocumentViewer.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetImageSource | (Inherited from DocumentViewer.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTemporaryXmpFileName | Returns the temorary filename used by the DocumentAnnotationViewer to store XMP annotation data. (Inherited from DocumentViewer.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert(Int32, RandomAccessImageSource) | Inserts images from a RandomAccessImageSource into the collection. (Inherited from DocumentViewer.)
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all images from a stream into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an AtalaImage into the thumbnail control. (Inherited from DocumentViewer.)
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts one or more images into the ThumbnailView from a Stream. (Inherited from DocumentViewer.)
Public method | Insert(Int32, String, Int32, String, String) | Inserts one or more images into the ThumbnailView from a file. (Inherited from DocumentViewer.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsThumbnailVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is currently visible. (Inherited from DocumentViewer.)
Public method | IsThumbnailVisible(Thumbnail, Boolean) | Returns a value indicating whether the specified thumbnail is currently visible. (Inherited from DocumentViewer.)
Public method | LoadAnnotationData | Loads annotation data into the viewer for the specified page.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClear | (Overrides DocumentViewerOnClear.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from DocumentViewer.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | (Inherited from DocumentViewer.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageInserted | (Overrides DocumentViewerOnImageInserted(ImageInsertEventArgs).)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnOpenDocument | (Overrides DocumentViewerOnOpenDocument(OpenDocumentEventArgs).)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Inherited from DocumentViewer.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPrintingPage | (Overrides DocumentViewerOnPrintingPage(PrintImageEventArgs).)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | (Overrides DocumentViewerOnSelectedIndexChanged(EventArgs).)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailControlSizeChanged | (Inherited from DocumentViewer.)
Protected method | OnThumbnailDockStyleChanged | (Inherited from DocumentViewer.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
 | Open(Stream) | Opens all pages of an image from a stream. (Inherited from DocumentViewer.)
Public method | Open(String) | Opens an image from a filename. If the file is a multipage document, all pages are added to the control. (Inherited from DocumentViewer.)
 | Open(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the viewer. (Inherited from DocumentViewer.)
 | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Open(Stream, Int32) | Opens the specified page from an image. (Inherited from DocumentViewer.)
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages in an image and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Open(String, Int32) | Opens the specified frame index from a file. (Inherited from DocumentViewer.)
 | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler. (Inherited from DocumentViewer.)
Public method | Open(Stream, Int32, String, String) | Opens the specified page from an image and provides the thumbnail caption and tooltip. (Inherited from DocumentViewer.)
Public method | Open(String, Int32, String, String) | Opens the specified frame from an image and provides the thumbnail caption and tooltip. (Inherited from DocumentViewer.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | Print | This method will print the contents of the DocumentViewer. (Inherited from DocumentViewer.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Performs a redo operation on the viewer. (Inherited from DocumentViewer.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshCurrentImageThumbnail | This method will force the DocumentAnnotationViewer to refresh the thumbnail for the current image.
Public method | Remove | (Inherited from DocumentViewer.)
Public method | RemoveAt | (Inherited from DocumentViewer.)
Public method | RemoveSelected | (Inherited from DocumentViewer.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RotateDocument | Rotates the current image and its annotations.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the current image for single page encoders or all pages for multipage encoders. By default, annotations will be embedded into JPEG, TIFF and PDF files. Set the AnnotationSaveOptionsHandler property to control the annotation save behavior. (Overrides DocumentViewerSave(Stream, ImageEncoder).)
Public method | Save(String, ImageEncoder) | Saves the image(s) to a file using the supplied encoder. (Inherited from DocumentViewer.)
Public method | SaveAnnotationData | This method will save the annotations into the provided stream.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | (Inherited from DocumentViewer.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectThumbnail | (Inherited from DocumentViewer.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetImageViewer | Use this method to replace the standard ImageViewer with another control deriving from ImageViewer. (Inherited from DocumentViewer.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetUndoManager | Call this method to replace the default CachedImageUndoManager with a custom version. (Inherited from DocumentViewer.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetZoomMode | (Inherited from DocumentViewer.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Performs an undo operation on the viewer. (Inherited from DocumentViewer.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.Dispose Method

DocumentAnnotationViewerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DocumentAnnotationViewer and optionally releases the managed resources (Overrides DocumentViewerDispose(Boolean).)
Top
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.Dispose Method (Boolean)

DocumentAnnotationViewerDispose Method (Boolean)

Releases the unmanaged resources used by the DocumentAnnotationViewer and optionally releases the managed resources

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

DocumentAnnotationViewer Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.LoadAnnotationData Method

DocumentAnnotationViewerLoadAnnotationData Method

Loads annotation data into the viewer for the specified page.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadAnnotationData(
    Stream stream,
    int frameIndex,
    IFormatter annotationDataFormatter,
    bool overwriteExistingAnnotations
)
Public Sub LoadAnnotationData (
    stream As Stream,
    frameIndex As Integer,
    annotationDataFormatter As IFormatter,
    overwriteExistingAnnotations As Boolean
)

Parameters

stream
Type: System.IOStream
A stream containing the annotation data.
frameIndex
Type: SystemInt32
The index of the page the data will be loaded into. Pass -1 to load data for all pages. If a specific frame is specified, the annotation data must contain only one layer or have enough layers that frameIndex is a valid layer index.
annotationDataFormatter
Type: System.Runtime.SerializationIFormatter
The formatter used to read the annotation data from the stream.
overwriteExistingAnnotations
Type: SystemBoolean
True to replace any existing annotations with those being loaded. If false, the annotations will be inserted into the existing layer.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if there are no images loaded.
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the stream does not have read access.
ArgumentOutOfRangeException | Thrown if the frame index is invalid.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.OnClear Method

DocumentAnnotationViewerOnClear Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClear()
Protected Overrides Sub OnClear
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.OnImageInserted Method

DocumentAnnotationViewerOnImageInserted Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnImageInserted(
    ImageInsertEventArgs e
)
Protected Overrides Sub OnImageInserted (
    e As ImageInsertEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsImageInsertEventArgs
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.OnOpenDocument Method

DocumentAnnotationViewerOnOpenDocument Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnOpenDocument(
    OpenDocumentEventArgs e
)
Protected Overrides Sub OnOpenDocument (
    e As OpenDocumentEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsOpenDocumentEventArgs
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.OnPrintingPage Method

DocumentAnnotationViewerOnPrintingPage Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPrintingPage(
    PrintImageEventArgs e
)
Protected Overrides Sub OnPrintingPage (
    e As PrintImageEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.OnSelectedIndexChanged Method

DocumentAnnotationViewerOnSelectedIndexChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSelectedIndexChanged(
    EventArgs e
)
Protected Overrides Sub OnSelectedIndexChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.RefreshCurrentImageThumbnail Method

DocumentAnnotationViewerRefreshCurrentImageThumbnail Method

This method will force the DocumentAnnotationViewer to refresh the thumbnail for the current image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RefreshCurrentImageThumbnail()
Public Sub RefreshCurrentImageThumbnail
Remarks
Under normal conditions this method should never need to be called. This is not a quick process and should be avoided when possible.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.RotateDocument Method

DocumentAnnotationViewerRotateDocument Method

Rotates the current image and its annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation
)
Public Sub RotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation to perform.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.Save Method

DocumentAnnotationViewerSave Method

Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder) | Saves the current image for single page encoders or all pages for multipage encoders. By default, annotations will be embedded into JPEG, TIFF and PDF files. Set the AnnotationSaveOptionsHandler property to control the annotation save behavior. (Overrides DocumentViewerSave(Stream, ImageEncoder).)
Public method | Save(String, ImageEncoder) | Saves the image(s) to a file using the supplied encoder. (Inherited from DocumentViewer.)
Top
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.Save Method (Stream, ImageEncoder)

DocumentAnnotationViewerSave Method (Stream, ImageEncoder)

Saves the current image for single page encoders or all pages for multipage encoders.

By default, annotations will be embedded into JPEG, TIFF and PDF files. Set the AnnotationSaveOptionsHandler property to control the annotation save behavior.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Save(
    Stream stream,
    ImageEncoder encoder
)
Public Overrides Sub Save (
    stream As Stream,
    encoder As ImageEncoder
)

Parameters

stream
Type: System.IOStream
The stream to save the image(s) into.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The encoder to use for the image(s).
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the encoder is a MultiFramedImageEncoder and the stream is not seekable.
See Also

Reference

DocumentAnnotationViewer Class
Save Overload
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.SaveAnnotationData Method

DocumentAnnotationViewerSaveAnnotationData Method

This method will save the annotations into the provided stream.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SaveAnnotationData(
    Stream stream,
    int frameIndex,
    IFormatter annotationDataFormatter
)
Public Sub SaveAnnotationData (
    stream As Stream,
    frameIndex As Integer,
    annotationDataFormatter As IFormatter
)

Parameters

stream
Type: System.IOStream
The stream to save the annotations into.
frameIndex
Type: SystemInt32
The frame index to save. Specify -1 to save all frames together.
annotationDataFormatter
Type: System.Runtime.SerializationIFormatter
The formatter used to save the annotations. Pass in null (Nothing in VB) to use the XmpFormatter.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the stream does not have read access.
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer Events

The DocumentAnnotationViewer type exposes the following members.

Events
 | Name | Description
Public event | AfterLabelEdit | (Inherited from DocumentViewer.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | (Inherited from DocumentViewer.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CreatePdfAnnotationDataExporter | Add a handler to this event if you want to create your own PdfAnnotationDataExporter object for use when saving annotations into a PDF. You may want to do this if you have custom PDF export policies that you want to install in it.
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PrintingPage | Raised as each page is about to be printed. (Inherited from DocumentViewer.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RedoPerformed | Raised when a redo operation has been performed. (Inherited from DocumentViewer.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | (Inherited from DocumentViewer.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | UndoListChanged | Raised when there has been a change in the undo/redo lists. (Inherited from DocumentViewer.)
Public event | UndoPerformed | Raised when an undo operation has been performed. (Inherited from DocumentViewer.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


DocumentAnnotationViewer.CreatePdfAnnotationDataExporter Event

DocumentAnnotationViewerCreatePdfAnnotationDataExporter Event

Add a handler to this event if you want to create your own PdfAnnotationDataExporter object for use when saving annotations into a PDF. You may want to do this if you have custom PDF export policies that you want to install in it.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CreatePdfAnnotationDataExporterHandler CreatePdfAnnotationDataExporter
Public Event CreatePdfAnnotationDataExporter As CreatePdfAnnotationDataExporterHandler

Value

Type: Atalasoft.Annotate.UICreatePdfAnnotationDataExporterHandler
See Also

Reference

DocumentAnnotationViewer Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Class

This class uses an EllipseData object to generate an ellipse annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIEllipseAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EllipseAnnotation : AnnotationUI
<SerializableAttribute>
Public Class EllipseAnnotation
    Inherits AnnotationUI

The EllipseAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | EllipseAnnotation | Creates a new instance of EllipseAnnotation.
Public method | EllipseAnnotation(EllipseData) | Creates a new instance of EllipseAnnotation specifying the ellipse data.
Public method | EllipseAnnotation(RectangleF, AnnotationBrush) | Creates a new instance of EllipseAnnotation specifying the bounding rectangle and fill.
Public method | EllipseAnnotation(RectangleF, AnnotationPen) | Creates a new instance of EllipseAnnotation specifying the bounding rectangle and outline.
Public method | EllipseAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of EllipseAnnotation from serialized information.
Public method | EllipseAnnotation(AnnotationBrush, AnnotationPen) | Creates a new instance of EllipseAnnotation specifying its fill and outline.
Public method | EllipseAnnotation(RectangleF, AnnotationBrush, Boolean) | Creates a new instance of EllipseAnnotation specifying the rectangle, fill and translucent properties.
Public method | EllipseAnnotation(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of EllipseAnnotation specifying the fill, outline, shadow brush and shadow offset.
Public method | EllipseAnnotation(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of EllipseAnnotation specifying the bounding rectangle, fill, outline and shadow options.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor

Constructs an EllipseAnnotation.
Overload List
 | Name | Description
Public method | EllipseAnnotation | Creates a new instance of EllipseAnnotation.
Public method | EllipseAnnotation(EllipseData) | Creates a new instance of EllipseAnnotation specifying the ellipse data.
Public method | EllipseAnnotation(RectangleF, AnnotationBrush) | Creates a new instance of EllipseAnnotation specifying the bounding rectangle and fill.
Public method | EllipseAnnotation(RectangleF, AnnotationPen) | Creates a new instance of EllipseAnnotation specifying the bounding rectangle and outline.
Public method | EllipseAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of EllipseAnnotation from serialized information.
Public method | EllipseAnnotation(AnnotationBrush, AnnotationPen) | Creates a new instance of EllipseAnnotation specifying its fill and outline.
Public method | EllipseAnnotation(RectangleF, AnnotationBrush, Boolean) | Creates a new instance of EllipseAnnotation specifying the rectangle, fill and translucent properties.
Public method | EllipseAnnotation(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of EllipseAnnotation specifying the fill, outline, shadow brush and shadow offset.
Public method | EllipseAnnotation(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of EllipseAnnotation specifying the bounding rectangle, fill, outline and shadow options.
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor

Creates a new instance of EllipseAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation()
Public Sub New
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (EllipseData)

Creates a new instance of EllipseAnnotation specifying the ellipse data.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    EllipseData data
)
Public Sub New (
    data As EllipseData
)

Parameters

data
Type: Atalasoft.AnnotateEllipseData
The EllipseData object used by this annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (RectangleF, AnnotationBrush)

Creates a new instance of EllipseAnnotation specifying the bounding rectangle and fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the ellipse.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used by the ellipse.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (RectangleF, AnnotationPen)

Creates a new instance of EllipseAnnotation specifying the bounding rectangle and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    RectangleF rectangle,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the ellipse.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used by the ellipse.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of EllipseAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this data.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (AnnotationBrush, AnnotationPen)

Creates a new instance of EllipseAnnotation specifying its fill and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (RectangleF, AnnotationBrush, Boolean)

Creates a new instance of EllipseAnnotation specifying the rectangle, fill and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill,
    bool translucent
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    translucent As Boolean
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for this annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill this annotation.
translucent
Type: SystemBoolean
A value indicating whether this annotation will act as a highlighter.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of EllipseAnnotation specifying the fill, outline, shadow brush and shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to draw the shadow of the annotation.
shadowOffset
Type: System.DrawingPointF
The amount of offset from the annotation for the shadow.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Constructor (RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of EllipseAnnotation specifying the bounding rectangle, fill, outline and shadow options.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle of the ellipse.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used by the ellipse.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used by the ellipse.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
A value indicating whether or not the ellipse has a shadow.
shadowOffset
Type: System.DrawingPointF
The amount of offset from the annotation for the shadow.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Properties

The EllipseAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.Fill Property

EllipseAnnotationFill Property

Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.Outline Property

EllipseAnnotationOutline Property

Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.Shadow Property

EllipseAnnotationShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.ShadowOffset Property

EllipseAnnotationShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.Translucent Property

EllipseAnnotationTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument(DocumentRotation, Int32) method.
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Methods

The EllipseAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.Clone Method

EllipseAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation.GetRegion Method

EllipseAnnotationGetRegion Method

Returns a rectangular region for this annotation, including its grips if selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
The space coordinate system used to generate this region.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.
Examples
The following is an example of how a custom annotation may override the GetRegion method.
GetRegionCS
Copy
public override AnnotationRegion GetRegion(AnnotateSpace space)
{
Create the region in annotation space.
AnnotationRegion reg = new AnnotationRegion(new RectangleF(PointF.Empty, _data.Size));
if (this.Selected && this.Grips != null)
AddGripsToRegion(reg);
ApplyRegionTransform(reg, space);
return reg;
}
GetRegionVB
Copy
Public Overrides Function GetRegion(ByVal space As AnnotateSpace) As AnnotationRegion
' Create the region in annotation space.
Dim reg As AnnotationRegion =  New AnnotationRegion(New RectangleF(PointF.Empty,_data.Size))
If Not Me.Selected And Me.Grips Is Nothing Then
AddGripsToRegion(reg)
End If
ApplyRegionTransform(reg, space)
Return reg
End Function
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotation Events

The EllipseAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotationFactory Class

This class generates an EllipseAnnotation object from an EllipseData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIEllipseAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class EllipseAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class EllipseAnnotationFactory
    Implements IAnnotationUIFactory

The EllipseAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | EllipseAnnotationFactory | Creates a new instance of EllipseAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an EllipseAnnotation if the data object is an EllipseData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


EllipseAnnotationFactory Constructor

Creates a new instance of EllipseAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotationFactory()
Public Sub New
See Also

Reference

EllipseAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotationFactory Methods

The EllipseAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an EllipseAnnotation if the data object is an EllipseData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EllipseAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


EllipseAnnotationFactory.GetAnnotationUI Method

EllipseAnnotationFactoryGetAnnotationUI Method

Returns an EllipseAnnotation if the data object is an EllipseData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object for the annotation.

Return Value

Type: AnnotationUI
An EllipseAnnotation or null (Nothing in Visual Basic) if the data parameter is not an EllipseData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

EllipseAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider Class

This class is used by the DocumentAnnotationViewer to extract annotation data from JPEG, TIFF and PDF files.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIEmbeddedAnnotationDataProvider

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EmbeddedAnnotationDataProvider : IAnnotationDataProvider
Public Class EmbeddedAnnotationDataProvider
    Implements IAnnotationDataProvider

The EmbeddedAnnotationDataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedAnnotationDataProvider | Creates a new instance of EmbeddedAnnotationDataProvider.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerData |
Public method | GetResolution | Gets the resolution which will be used to scale annotations on import.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForExtraction(AtalaImage) |
Public method | PrepareForExtraction(Stream, Int32) |
Public method | PrepareForExtraction(String, Int32) |
Public method | PrepareForExtraction(RandomAccessImageSource, Int32) |
Public method | SetResolution | Sets the resolution which will be used to scale annotations on import.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider Constructor

Creates a new instance of EmbeddedAnnotationDataProvider.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedAnnotationDataProvider(
    PointF viewerResolution
)
Public Sub New (
    viewerResolution As PointF
)

Parameters

viewerResolution
Type: System.DrawingPointF
The resolution of the image viewer.
See Also

Reference

EmbeddedAnnotationDataProvider Class
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider Methods

The EmbeddedAnnotationDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerData |
Public method | GetResolution | Gets the resolution which will be used to scale annotations on import.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForExtraction(AtalaImage) |
Public method | PrepareForExtraction(Stream, Int32) |
Public method | PrepareForExtraction(String, Int32) |
Public method | PrepareForExtraction(RandomAccessImageSource, Int32) |
Public method | SetResolution | Sets the resolution which will be used to scale annotations on import.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmbeddedAnnotationDataProvider Class
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.GetLayerData Method

EmbeddedAnnotationDataProviderGetLayerData Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerData GetLayerData(
    int frameIndex
)
Public Function GetLayerData (
    frameIndex As Integer
) As LayerData

Parameters

frameIndex
Type: SystemInt32

Return Value

Type: LayerData

Implements

IAnnotationDataProviderGetLayerData(Int32)
See Also

Reference

EmbeddedAnnotationDataProvider Class
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.GetResolution Method

EmbeddedAnnotationDataProviderGetResolution Method

Gets the resolution which will be used to scale annotations on import.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF GetResolution()
Public Function GetResolution As PointF

Return Value

Type: PointF
Resolution
See Also

Reference

EmbeddedAnnotationDataProvider Class
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.PrepareForExtraction Method

EmbeddedAnnotationDataProviderPrepareForExtraction Method

Overload List
 | Name | Description
Public method | PrepareForExtraction(AtalaImage) |
Public method | PrepareForExtraction(Stream, Int32) |
Public method | PrepareForExtraction(String, Int32) |
Public method | PrepareForExtraction(RandomAccessImageSource, Int32) |
Top
See Also

Reference

EmbeddedAnnotationDataProvider Class
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.PrepareForExtraction Method (AtalaImage)

EmbeddedAnnotationDataProviderPrepareForExtraction Method (AtalaImage)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PrepareForExtraction(
    AtalaImage image
)
Public Sub PrepareForExtraction (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Implements

IAnnotationDataProviderPrepareForExtraction(AtalaImage)
See Also

Reference

EmbeddedAnnotationDataProvider Class
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.PrepareForExtraction Method (Stream, Int32)

EmbeddedAnnotationDataProviderPrepareForExtraction Method (Stream, Int32)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PrepareForExtraction(
    Stream stream,
    int frameIndex
)
Public Sub PrepareForExtraction (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
frameIndex
Type: SystemInt32

Implements

IAnnotationDataProviderPrepareForExtraction(Stream, Int32)
See Also

Reference

EmbeddedAnnotationDataProvider Class
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.PrepareForExtraction Method (String, Int32)

EmbeddedAnnotationDataProviderPrepareForExtraction Method (String, Int32)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PrepareForExtraction(
    string fileName,
    int frameIndex
)
Public Sub PrepareForExtraction (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
frameIndex
Type: SystemInt32

Implements

IAnnotationDataProviderPrepareForExtraction(String, Int32)
See Also

Reference

EmbeddedAnnotationDataProvider Class
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.PrepareForExtraction Method (RandomAccessImageSource, Int32)

EmbeddedAnnotationDataProviderPrepareForExtraction Method (RandomAccessImageSource, Int32)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PrepareForExtraction(
    RandomAccessImageSource source,
    int frameIndex
)
Public Sub PrepareForExtraction (
    source As RandomAccessImageSource,
    frameIndex As Integer
)

Parameters

source
Type: Atalasoft.ImagingRandomAccessImageSource
frameIndex
Type: SystemInt32

Implements

IAnnotationDataProviderPrepareForExtraction(RandomAccessImageSource, Int32)
See Also

Reference

EmbeddedAnnotationDataProvider Class
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


EmbeddedAnnotationDataProvider.SetResolution Method

EmbeddedAnnotationDataProviderSetResolution Method

Sets the resolution which will be used to scale annotations on import.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetResolution(
    PointF resolution
)
Public Sub SetResolution (
    resolution As PointF
)

Parameters

resolution
Type: System.DrawingPointF
Resolution
See Also

Reference

EmbeddedAnnotationDataProvider Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Class

This is an image annotation that will embed the image into the serialized XMP or WANG data.
This is an image annotation that will embed the image into the serialized XMP or WANG data.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIEmbeddedImageAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EmbeddedImageAnnotation : AnnotationUI,
    IDisposable
<SerializableAttribute>
Public Class EmbeddedImageAnnotation
    Inherits AnnotationUI
    Implements IDisposable

The EmbeddedImageAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedImageAnnotation | Creates a new instance of EmbeddedImageAnnotation.
Public method | EmbeddedImageAnnotation(EmbeddedImageData) | Creates a new instance of EmbeddedImageAnnotation specifying the EmbeddedImageData used by the annotation.
Public method | EmbeddedImageAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of EmbeddedImageAnnotation from serialized information.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean) | Creates a new instance of EmbeddedImageAnnotation specifying the image.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean, PointF) | Creates a new instance of EmbeddedImageAnnotation specifying the image, whether or not to maintain the aspect ratio and the initial location of this object.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageAnnotation specifying the image, shadow and shadow offset.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean, PointF, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageAnnotation specifying the image, initial location, shadow and shadow offset.
Top
Properties
 | Name | Description
Public property | AllowClickThrough | Gets or sets a value indicating whether to allow mouse clicks to pass through transparent areas of the image.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Image | Gets or sets the image of the annotation.
Public property | KeepAspectRatio | Gets or sets a value indicating whether the image ratio is maintained while resizing.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called when disposing or finalizing to release resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the EmbeddedImageAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with annotation information. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor

Constructs an EmbeddedImageAnnotation.
Overload List
 | Name | Description
Public method | EmbeddedImageAnnotation | Creates a new instance of EmbeddedImageAnnotation.
Public method | EmbeddedImageAnnotation(EmbeddedImageData) | Creates a new instance of EmbeddedImageAnnotation specifying the EmbeddedImageData used by the annotation.
Public method | EmbeddedImageAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of EmbeddedImageAnnotation from serialized information.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean) | Creates a new instance of EmbeddedImageAnnotation specifying the image.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean, PointF) | Creates a new instance of EmbeddedImageAnnotation specifying the image, whether or not to maintain the aspect ratio and the initial location of this object.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageAnnotation specifying the image, shadow and shadow offset.
Public method | EmbeddedImageAnnotation(AnnotationImage, Boolean, PointF, AnnotationBrush, PointF) | Creates a new instance of EmbeddedImageAnnotation specifying the image, initial location, shadow and shadow offset.
Top
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor

Creates a new instance of EmbeddedImageAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation()
Public Sub New
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor (EmbeddedImageData)

Creates a new instance of EmbeddedImageAnnotation specifying the EmbeddedImageData used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation(
    EmbeddedImageData data
)
Public Sub New (
    data As EmbeddedImageData
)

Parameters

data
Type: Atalasoft.AnnotateEmbeddedImageData
The EmbeddedImageData for this annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of EmbeddedImageAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor (AnnotationImage, Boolean)

Creates a new instance of EmbeddedImageAnnotation specifying the image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation(
    AnnotationImage image,
    bool keepAspectRatio
)
Public Sub New (
    image As AnnotationImage,
    keepAspectRatio As Boolean
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image for the annotation.
keepAspectRatio
Type: SystemBoolean
Indicates whether the aspect ratio of the image is maintained.
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor (AnnotationImage, Boolean, PointF)

Creates a new instance of EmbeddedImageAnnotation specifying the image, whether or not to maintain the aspect ratio and the initial location of this object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation(
    AnnotationImage image,
    bool keepAspectRatio,
    PointF location
)
Public Sub New (
    image As AnnotationImage,
    keepAspectRatio As Boolean,
    location As PointF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image for the annotation.
keepAspectRatio
Type: SystemBoolean
Indicates whether the aspect ratio of the image is maintained.
location
Type: System.DrawingPointF
The initial location of this annotation on the document.
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor (AnnotationImage, Boolean, AnnotationBrush, PointF)

Creates a new instance of EmbeddedImageAnnotation specifying the image, shadow and shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation(
    AnnotationImage image,
    bool keepAspectRatio,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    image As AnnotationImage,
    keepAspectRatio As Boolean,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to embed.
keepAspectRatio
Type: SystemBoolean
Indicates whether the aspect ratio of the image is maintained.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Constructor (AnnotationImage, Boolean, PointF, AnnotationBrush, PointF)

Creates a new instance of EmbeddedImageAnnotation specifying the image, initial location, shadow and shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotation(
    AnnotationImage image,
    bool keepAspectRatio,
    PointF location,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    image As AnnotationImage,
    keepAspectRatio As Boolean,
    location As PointF,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image to embed.
keepAspectRatio
Type: SystemBoolean
Indicates whether the aspect ratio of the image is maintained.
location
Type: System.DrawingPointF
The initial location of this annotation on the document.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EmbeddedImageAnnotation Class
EmbeddedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Properties

The EmbeddedImageAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AllowClickThrough | Gets or sets a value indicating whether to allow mouse clicks to pass through transparent areas of the image.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Image | Gets or sets the image of the annotation.
Public property | KeepAspectRatio | Gets or sets a value indicating whether the image ratio is maintained while resizing.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.AllowClickThrough Property

EmbeddedImageAnnotationAllowClickThrough Property

Gets or sets a value indicating whether to allow mouse clicks to pass through transparent areas of the image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowClickThrough { get; set; }
Public Property AllowClickThrough As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if mouse clicks will pass through transparent areas.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.HitTestRectangle Property

EmbeddedImageAnnotationHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF HitTestRectangle { get; }
Public Overrides ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Image Property

EmbeddedImageAnnotationImage Property

Gets or sets the image of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage Image { get; set; }
Public Property Image As AnnotationImage
    Get
    Set

Property Value

Type: AnnotationImage
The image to embed.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.KeepAspectRatio Property

EmbeddedImageAnnotationKeepAspectRatio Property

Gets or sets a value indicating whether the image ratio is maintained while resizing.
Gets or sets a value indicating whether the image ratio is maintained while resizing.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool KeepAspectRatio { get; set; }
Public Property KeepAspectRatio As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the image ratio is maintained.

Property Value

Type: Boolean
Indicates if the image ratio is maintained.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Shadow Property

EmbeddedImageAnnotationShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.
Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.ShadowOffset Property

EmbeddedImageAnnotationShadowOffset Property

Gets or sets the shadow offset.
Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Methods

The EmbeddedImageAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called when disposing or finalizing to release resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the EmbeddedImageAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with annotation information. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Clone Method

EmbeddedImageAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Dispose Method

EmbeddedImageAnnotationDispose Method

Disposes the EmbeddedImageAnnotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called when disposing or finalizing to release resources used by the annotation.
Top
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Dispose Method

EmbeddedImageAnnotationDispose Method

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

EmbeddedImageAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Dispose Method (Boolean)

EmbeddedImageAnnotationDispose Method (Boolean)

Called when disposing or finalizing to release resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether the annotation is being disposed or finalized.
See Also

Reference

EmbeddedImageAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.Finalize Method

EmbeddedImageAnnotationFinalize Method

Finalizes an instance of the EmbeddedImageAnnotation class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.GetObjectData Method

EmbeddedImageAnnotationGetObjectData Method

Fills a SerializationInfo object with annotation information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object where the data will be added.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation.GetRegion Method

EmbeddedImageAnnotationGetRegion Method

Returns a rectangular region for this annotation, including its grips if selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
The space coordinate system used to generate this region.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.
Examples
The following is an example of how a custom annotation may override the GetRegion method.
GetRegionCS
Copy
public override AnnotationRegion GetRegion(AnnotateSpace space)
{
Create the region in annotation space.
AnnotationRegion reg = new AnnotationRegion(new RectangleF(PointF.Empty, _data.Size));
if (this.Selected && this.Grips != null)
AddGripsToRegion(reg);
ApplyRegionTransform(reg, space);
return reg;
}
GetRegionVB
Copy
Public Overrides Function GetRegion(ByVal space As AnnotateSpace) As AnnotationRegion
' Create the region in annotation space.
Dim reg As AnnotationRegion =  New AnnotationRegion(New RectangleF(PointF.Empty,_data.Size))
If Not Me.Selected And Me.Grips Is Nothing Then
AddGripsToRegion(reg)
End If
ApplyRegionTransform(reg, space)
Return reg
End Function
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotation Events

The EmbeddedImageAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

EmbeddedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotationFactory Class

This class generates an EmbeddedImageAnnotation object from an EmbeddedImageData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIEmbeddedImageAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class EmbeddedImageAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class EmbeddedImageAnnotationFactory
    Implements IAnnotationUIFactory

The EmbeddedImageAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedImageAnnotationFactory | Creates a new instance of EmbeddedImageAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an EmbeddedImageAnnotation if the data object is an EmbeddedImageData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotationFactory Constructor

Creates a new instance of EmbeddedImageAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbeddedImageAnnotationFactory()
Public Sub New
See Also

Reference

EmbeddedImageAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotationFactory Methods

The EmbeddedImageAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an EmbeddedImageAnnotation if the data object is an EmbeddedImageData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmbeddedImageAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


EmbeddedImageAnnotationFactory.GetAnnotationUI Method

EmbeddedImageAnnotationFactoryGetAnnotationUI Method

Returns an EmbeddedImageAnnotation if the data object is an EmbeddedImageData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The EmbeddedImageData object for the annotation.

Return Value

Type: AnnotationUI
An EmbeddedImageAnnotation or null (Nothing in Visual Basic) if the data parameter is not an EmbeddedImageData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

EmbeddedImageAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Class

This class is used for a freehand drawing annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIPointBaseAnnotation
Atalasoft.Annotate.UIFreehandAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FreehandAnnotation : PointBaseAnnotation
<SerializableAttribute>
Public Class FreehandAnnotation
    Inherits PointBaseAnnotation

The FreehandAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | FreehandAnnotation | Creates a new instance of FreehandAnnotation.
Public method | FreehandAnnotation(PointF) | Creates a new instance of FreehandAnnotation specifying the initial points.
Public method | FreehandAnnotation(AnnotationPen) | Creates a new instance of FreehandAnnotation specifying the AnnotationPen used for drawing the lines or curves.
Public method | FreehandAnnotation(FreehandData) | Creates a new instance of FreehandAnnotation specifying the FreehandData object for this annotation.
Public method | FreehandAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of FreehandAnnotation from serialized information.
Public method | FreehandAnnotation(AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandAnnotation specifying the outline and initial points.
Public method | FreehandAnnotation(AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandAnnotation specifying the fill, outline and translucent properties.
Public method | FreehandAnnotation(AnnotationPen, AnnotationBrush, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandAnnotation specifying the outline, fill and initial points.
Public method | FreehandAnnotation(PointF, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandAnnotation specifying the points, fill, outline and translucent properties.
Public method | FreehandAnnotation(PointFCollection, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandAnnotation specifying the point collection, fill, outline and translucent properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ClosedShape | Gets or sets a value indicating whether the freehand is a closed shape.
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill for the freehand.
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | LineType |
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for this freehand.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets a PointFCollection containing the points for the freehand.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for this annotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Overrides PointBaseAnnotationOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides PointBaseAnnotationOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor

Constructs a FreehandAnnotation.
Overload List
 | Name | Description
Public method | FreehandAnnotation | Creates a new instance of FreehandAnnotation.
Public method | FreehandAnnotation(PointF) | Creates a new instance of FreehandAnnotation specifying the initial points.
Public method | FreehandAnnotation(AnnotationPen) | Creates a new instance of FreehandAnnotation specifying the AnnotationPen used for drawing the lines or curves.
Public method | FreehandAnnotation(FreehandData) | Creates a new instance of FreehandAnnotation specifying the FreehandData object for this annotation.
Public method | FreehandAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of FreehandAnnotation from serialized information.
Public method | FreehandAnnotation(AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandAnnotation specifying the outline and initial points.
Public method | FreehandAnnotation(AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandAnnotation specifying the fill, outline and translucent properties.
Public method | FreehandAnnotation(AnnotationPen, AnnotationBrush, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of FreehandAnnotation specifying the outline, fill and initial points.
Public method | FreehandAnnotation(PointF, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandAnnotation specifying the points, fill, outline and translucent properties.
Public method | FreehandAnnotation(PointFCollection, AnnotationBrush, AnnotationPen, Boolean) | Creates a new instance of FreehandAnnotation specifying the point collection, fill, outline and translucent properties.
Top
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor

Creates a new instance of FreehandAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation()
Public Sub New
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (PointF[])

FreehandAnnotation Constructor (PointF)

Creates a new instance of FreehandAnnotation specifying the initial points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    params PointF[] points
)
Public Sub New (
    ParamArray points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The initial points for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the points parameter is null.
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (AnnotationPen)

Creates a new instance of FreehandAnnotation specifying the AnnotationPen used for drawing the lines or curves.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    AnnotationPen outline
)
Public Sub New (
    outline As AnnotationPen
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen for the lines or curves.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the points parameter is null.
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (FreehandData)

Creates a new instance of FreehandAnnotation specifying the FreehandData object for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    FreehandData data
)
Public Sub New (
    data As FreehandData
)

Parameters

data
Type: Atalasoft.AnnotateFreehandData
A FreehandData object used for this annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data parameter is null.
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FreehandAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (AnnotationPen, PointF[])

FreehandAnnotation Constructor (AnnotationPen, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of FreehandAnnotation specifying the outline and initial points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public FreehandAnnotation(
    AnnotationPen outline,
    params PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    ParamArray points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
points
Type: System.DrawingPointF
The initial points for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (AnnotationBrush, AnnotationPen, Boolean)

Creates a new instance of FreehandAnnotation specifying the fill, outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
translucent
Type: SystemBoolean

Indicates whether the line will be translucent, giving it a highlighter effect.

Exceptions
Exception | Condition
 | Thrown if both fill and outline are null (Nothing in VB).
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (AnnotationPen, AnnotationBrush, PointF[])

FreehandAnnotation Constructor (AnnotationPen, AnnotationBrush, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of FreehandAnnotation specifying the outline, fill and initial points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public FreehandAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill,
    params PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush,
    ParamArray points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
points
Type: System.DrawingPointF
The initial point for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the points parameter is null or if both outline and fill parameters are null.
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (PointF[], AnnotationBrush, AnnotationPen, Boolean)

FreehandAnnotation Constructor (PointF, AnnotationBrush, AnnotationPen, Boolean)

Creates a new instance of FreehandAnnotation specifying the points, fill, outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    PointF[] points,
    AnnotationBrush fill,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointF(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: System.DrawingPointF
The initial points for the freehand.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
translucent
Type: SystemBoolean

Indicates whether the line will be translucent, giving it a highlighter effect.

Exceptions
Exception | Condition
 | Thrown if points is null or if both fill and outline are null (Nothing in VB).
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Constructor (PointFCollection, AnnotationBrush, AnnotationPen, Boolean)

Creates a new instance of FreehandAnnotation specifying the point collection, fill, outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotation(
    PointFCollection points,
    AnnotationBrush fill,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointFCollection,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
The initial point collection for the freehand.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the freehand.
translucent
Type: SystemBoolean

Indicates whether the line will be translucent, giving it a highlighter effect.

Exceptions
Exception | Condition
 | Thrown if both fill and outline are null (Nothing in VB).
See Also

Reference

FreehandAnnotation Class
FreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Properties

The FreehandAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ClosedShape | Gets or sets a value indicating whether the freehand is a closed shape.
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill for the freehand.
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | LineType |
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for this freehand.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets a PointFCollection containing the points for the freehand.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.ClosedShape Property

FreehandAnnotationClosedShape Property

Gets or sets a value indicating whether the freehand is a closed shape.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClosedShape { get; set; }
Public Property ClosedShape As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the freehand is a closed shape.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.Fill Property

FreehandAnnotationFill Property

Gets or sets the fill for the freehand.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill of the freehand.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.LineType Property

FreehandAnnotationLineType Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandLineType LineType { get; set; }
Public Property LineType As FreehandLineType
    Get
    Set

Property Value

Type: FreehandLineType
Remarks
If the FreehandLineType.Beziers value is used, padding will be added to the end (if required) to provide a valid number of points for Bezier curves.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.Outline Property

FreehandAnnotationOutline Property

Gets or sets the outline for this freehand.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The outline for this freehand.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.Points Property

FreehandAnnotationPoints Property

Gets a PointFCollection containing the points for the freehand.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection Points { get; }
Public ReadOnly Property Points As PointFCollection
    Get

Property Value

Type: PointFCollection
A collection of points for this annotation. Theses points must be specified in annotation space.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.Translucent Property

FreehandAnnotationTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument(DocumentRotation, Int32) method.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Methods

The FreehandAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for this annotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Overrides PointBaseAnnotationOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides PointBaseAnnotationOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.Clone Method

FreehandAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.GetRegion Method

FreehandAnnotationGetRegion Method

Returns a region for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace

Return Value

Type: AnnotationRegion
A region for this annotation.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.OnAnnotationControllerNotification Method

FreehandAnnotationOnAnnotationControllerNotification Method

Called after a property of the annotation or related AnnotationData has been modified.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overrides Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information on this changed.
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation.OnMouseUp Method

FreehandAnnotationOnMouseUp Method

Called when the user has released the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.

Return Value

Type: Boolean
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotation Events

The FreehandAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

FreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotationFactory Class

This class generates a FreehandAnnotation object from a FreehandData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIFreehandAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class FreehandAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class FreehandAnnotationFactory
    Implements IAnnotationUIFactory

The FreehandAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | FreehandAnnotationFactory | Creates a new instance of FreehandAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an FreehandAnnotation if the data object is an FreehandData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


FreehandAnnotationFactory Constructor

Creates a new instance of FreehandAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandAnnotationFactory()
Public Sub New
See Also

Reference

FreehandAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotationFactory Methods

The FreehandAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns an FreehandAnnotation if the data object is an FreehandData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FreehandAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


FreehandAnnotationFactory.GetAnnotationUI Method

FreehandAnnotationFactoryGetAnnotationUI Method

Returns an FreehandAnnotation if the data object is an FreehandData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The FreehandData object for the annotation.

Return Value

Type: AnnotationUI
A FreehandAnnotation or null (Nothing in Visual Basic) if the data parameter is not a FreehandData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

FreehandAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


GripPositionChangedEventHandler Delegate

This event handler is used with the GripPositionChanged event.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void GripPositionChangedEventHandler(
    Object sender,
    AnnotationGripChangedEventArgs e
)
Public Delegate Sub GripPositionChangedEventHandler (
    sender As Object,
    e As AnnotationGripChangedEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
An AnnotationGripChangedEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Class

This annotations can be used to add rectangular hot spots on a document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked.

For a non-rectangular area use the HotSpotFreehandAnnotation.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIHotSpotAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HotSpotAnnotation : AnnotationUI
<SerializableAttribute>
Public Class HotSpotAnnotation
    Inherits AnnotationUI

The HotSpotAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotAnnotation | Creates a new instance of HotSpotAnnotation.
Public method | HotSpotAnnotation(HotSpotData) | Creates a new instance of HotSpotAnnotation specifying the annotation data.
Public method | HotSpotAnnotation(RectangleF, AnnotationBrush) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds fill.
Public method | HotSpotAnnotation(RectangleF, AnnotationPen) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds and outline.
Public method | HotSpotAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotAnnotation from serialized information.
Public method | HotSpotAnnotation(RectangleF, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds, fill and outline.
Public method | HotSpotAnnotation(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds, active and inactive fill, and outline.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether [active].
Public property | ActiveFill | Gets or sets the active fill.
Public property | ActiveOutline | Gets or sets the active outline.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor

Constructs a HotSpotAnnotation.
Overload List
 | Name | Description
Public method | HotSpotAnnotation | Creates a new instance of HotSpotAnnotation.
Public method | HotSpotAnnotation(HotSpotData) | Creates a new instance of HotSpotAnnotation specifying the annotation data.
Public method | HotSpotAnnotation(RectangleF, AnnotationBrush) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds fill.
Public method | HotSpotAnnotation(RectangleF, AnnotationPen) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds and outline.
Public method | HotSpotAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotAnnotation from serialized information.
Public method | HotSpotAnnotation(RectangleF, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds, fill and outline.
Public method | HotSpotAnnotation(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen) | Creates a new instance of HotSpotAnnotation specifying the rectangle bounds, active and inactive fill, and outline.
Top
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor

Creates a new instance of HotSpotAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation()
Public Sub New
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor (HotSpotData)

Creates a new instance of HotSpotAnnotation specifying the annotation data.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation(
    HotSpotData data
)
Public Sub New (
    data As HotSpotData
)

Parameters

data
Type: Atalasoft.AnnotateHotSpotData
The HotSpotData for this annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor (RectangleF, AnnotationBrush)

Creates a new instance of HotSpotAnnotation specifying the rectangle bounds fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when not active.
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor (RectangleF, AnnotationPen)

Creates a new instance of HotSpotAnnotation specifying the rectangle bounds and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation(
    RectangleF rectangle,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when not active.
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HotSpotAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information of this object.
context
Type: System.Runtime.SerializationStreamingContext
A context containing information about this object.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor (RectangleF, AnnotationBrush, AnnotationPen)

Creates a new instance of HotSpotAnnotation specifying the rectangle bounds, fill and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when not active.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when not active.
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Constructor (RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen)

Creates a new instance of HotSpotAnnotation specifying the rectangle bounds, active and inactive fill, and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush activeFill,
    AnnotationPen activeOutline
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    activeFill As AnnotationBrush,
    activeOutline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The bounding rectangle for this object.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when not active.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when not active.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when the annotation is active.
activeOutline
Type: Atalasoft.AnnotateAnnotationPen
The outline used when the annotation is active.
See Also

Reference

HotSpotAnnotation Class
HotSpotAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Properties

The HotSpotAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether [active].
Public property | ActiveFill | Gets or sets the active fill.
Public property | ActiveOutline | Gets or sets the active outline.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.Active Property

HotSpotAnnotationActive Property

Gets or sets a value indicating whether [active].

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [active]; otherwise, false.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.ActiveFill Property

HotSpotAnnotationActiveFill Property

Gets or sets the active fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush ActiveFill { get; set; }
Public Property ActiveFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The active fill.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.ActiveOutline Property

HotSpotAnnotationActiveOutline Property

Gets or sets the active outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen ActiveOutline { get; set; }
Public Property ActiveOutline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The active outline.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.Fill Property

HotSpotAnnotationFill Property

Gets or sets the fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.HitTestRectangle Property

HotSpotAnnotationHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF HitTestRectangle { get; }
Public Overrides ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.Outline Property

HotSpotAnnotationOutline Property

Gets or sets the outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The outline.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Methods

The HotSpotAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.Clone Method

HotSpotAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation.OnMoving Method

HotSpotAnnotationOnMoving Method

Called while an annotation is being moved by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
An AnnotationLocationChangedEventArgs containing information about this event.
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotation Events

The HotSpotAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

HotSpotAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotationFactory Class

This class generates a HotSpotAnnotation object from a AnnotationData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIHotSpotAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class HotSpotAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class HotSpotAnnotationFactory
    Implements IAnnotationUIFactory

The HotSpotAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotAnnotationFactory | Creates a new instance of HotSpotAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a HotSpotAnnotation if the data object is a HotSpotData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


HotSpotAnnotationFactory Constructor

Creates a new instance of HotSpotAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotAnnotationFactory()
Public Sub New
See Also

Reference

HotSpotAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotationFactory Methods

The HotSpotAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a HotSpotAnnotation if the data object is a HotSpotData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotSpotAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


HotSpotAnnotationFactory.GetAnnotationUI Method

HotSpotAnnotationFactoryGetAnnotationUI Method

Returns a HotSpotAnnotation if the data object is a HotSpotData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The HotSpotData object for the annotation.

Return Value

Type: AnnotationUI
A HotSpotAnnotation or null (Nothing in Visual Basic) if the data parameter is not a HotSpotData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

HotSpotAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Class

This annotation can be used to create a freehand hot spot area on the document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked.

For a rectangular hot spot use the HotSpotAnnotation.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIPointBaseAnnotation
Atalasoft.Annotate.UIHotSpotFreehandAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HotSpotFreehandAnnotation : PointBaseAnnotation
<SerializableAttribute>
Public Class HotSpotFreehandAnnotation
    Inherits PointBaseAnnotation

The HotSpotFreehandAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotFreehandAnnotation | Creates a new instance of HotSpotFreehandAnnotation.
Public method | HotSpotFreehandAnnotation(PointF) | Creates a new instance of HotSpotFreehandAnnotation specifying the initial points.
Public method | HotSpotFreehandAnnotation(AnnotationBrush) | Creates a new instance of HotSpotFreehandAnnotation specifying the fill.
Public method | HotSpotFreehandAnnotation(HotSpotFreehandData) | Creates a new instance of HotSpotFreehandAnnotation specifying the annotation data.
Public method | HotSpotFreehandAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotFreehandAnnotation from serialized information.
Public method | HotSpotFreehandAnnotation(AnnotationBrush, AnnotationBrush) | Creates a new instance of HotSpotFreehandAnnotation specifying the fill and active fill.
Public method | HotSpotFreehandAnnotation(AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandAnnotation specifying the outline, fill and initial points.
Public method | HotSpotFreehandAnnotation(AnnotationBrush, AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandAnnotation specifying the outline, fill and initial points.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets whether this hot spot is active.
Public property | ActiveFill | Gets or sets the fill used when the HotSpot is active.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used when the HotSpot is not active.
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | LineType | Gets or sets the LineType used for the lines or curves of this annotation.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets the PointFCollection used for this freehand.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for this annotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from PointBaseAnnotation.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides PointBaseAnnotationOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor

Constructs a HotSpotFreehandAnnotation.
Overload List
 | Name | Description
Public method | HotSpotFreehandAnnotation | Creates a new instance of HotSpotFreehandAnnotation.
Public method | HotSpotFreehandAnnotation(PointF) | Creates a new instance of HotSpotFreehandAnnotation specifying the initial points.
Public method | HotSpotFreehandAnnotation(AnnotationBrush) | Creates a new instance of HotSpotFreehandAnnotation specifying the fill.
Public method | HotSpotFreehandAnnotation(HotSpotFreehandData) | Creates a new instance of HotSpotFreehandAnnotation specifying the annotation data.
Public method | HotSpotFreehandAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of HotSpotFreehandAnnotation from serialized information.
Public method | HotSpotFreehandAnnotation(AnnotationBrush, AnnotationBrush) | Creates a new instance of HotSpotFreehandAnnotation specifying the fill and active fill.
Public method | HotSpotFreehandAnnotation(AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandAnnotation specifying the outline, fill and initial points.
Public method | HotSpotFreehandAnnotation(AnnotationBrush, AnnotationBrush, PointF) | Creates a new instance of HotSpotFreehandAnnotation specifying the outline, fill and initial points.
Top
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor

Creates a new instance of HotSpotFreehandAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation()
Public Sub New
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (PointF[])

HotSpotFreehandAnnotation Constructor (PointF)

Creates a new instance of HotSpotFreehandAnnotation specifying the initial points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    PointF[] points
)
Public Sub New (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
The initial points for the freehand. These must be specified in annotation space.
Exceptions
Exception | Condition
 | Thrown if the points parameter is null.
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (AnnotationBrush)

Creates a new instance of HotSpotFreehandAnnotation specifying the fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    AnnotationBrush fill
)
Public Sub New (
    fill As AnnotationBrush
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the fill.
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (HotSpotFreehandData)

Creates a new instance of HotSpotFreehandAnnotation specifying the annotation data.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    HotSpotFreehandData data
)
Public Sub New (
    data As HotSpotFreehandData
)

Parameters

data
Type: Atalasoft.AnnotateHotSpotFreehandData
A HotSpotFreehandData object for this annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HotSpotFreehandAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information for this object.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context for this object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (AnnotationBrush, AnnotationBrush)

Creates a new instance of HotSpotFreehandAnnotation specifying the fill and active fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    AnnotationBrush fill,
    AnnotationBrush activeFill
)
Public Sub New (
    fill As AnnotationBrush,
    activeFill As AnnotationBrush
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the fill.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used when the Active property is true.
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (AnnotationBrush, PointF[])

HotSpotFreehandAnnotation Constructor (AnnotationBrush, PointF)

Creates a new instance of HotSpotFreehandAnnotation specifying the outline, fill and initial points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    AnnotationBrush fill,
    params PointF[] points
)
Public Sub New (
    fill As AnnotationBrush,
    ParamArray points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
points
Type: System.DrawingPointF
The initial point for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Constructor (AnnotationBrush, AnnotationBrush, PointF[])

HotSpotFreehandAnnotation Constructor (AnnotationBrush, AnnotationBrush, PointF)

Creates a new instance of HotSpotFreehandAnnotation specifying the outline, fill and initial points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotation(
    AnnotationBrush fill,
    AnnotationBrush activeFill,
    params PointF[] points
)
Public Sub New (
    fill As AnnotationBrush,
    activeFill As AnnotationBrush,
    ParamArray points As PointF()
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the freehand.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used when the hotspot is active.
points
Type: System.DrawingPointF
The initial point for the freehand.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if a parameter is null.
See Also

Reference

HotSpotFreehandAnnotation Class
HotSpotFreehandAnnotation Overload
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Properties

The HotSpotFreehandAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets whether this hot spot is active.
Public property | ActiveFill | Gets or sets the fill used when the HotSpot is active.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used when the HotSpot is not active.
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | LineType | Gets or sets the LineType used for the lines or curves of this annotation.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets the PointFCollection used for this freehand.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.Active Property

HotSpotFreehandAnnotationActive Property

Gets or sets whether this hot spot is active.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if this hot spot is active.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.ActiveFill Property

HotSpotFreehandAnnotationActiveFill Property

Gets or sets the fill used when the HotSpot is active.
Gets or sets the fill used when the HotSpot is active.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush ActiveFill { get; set; }
Public Property ActiveFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The active fill.

Property Value

Type: AnnotationBrush
The active fill.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.Fill Property

HotSpotFreehandAnnotationFill Property

Gets or sets the fill used when the HotSpot is not active.
Gets or sets the fill used when the HotSpot is not active.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The inactive fill.

Property Value

Type: AnnotationBrush
The inactive fill.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.LineType Property

HotSpotFreehandAnnotationLineType Property

Gets or sets the LineType used for the lines or curves of this annotation.
Gets or sets the LineType used for the lines or curves of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FreehandLineType LineType { get; set; }
Public Property LineType As FreehandLineType
    Get
    Set

Property Value

Type: FreehandLineType
The line type for this annotation.

Property Value

Type: FreehandLineType
The line type for this annotation.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.Points Property

HotSpotFreehandAnnotationPoints Property

Gets the PointFCollection used for this freehand.
Gets the PointFCollection used for this freehand.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection Points { get; }
Public ReadOnly Property Points As PointFCollection
    Get

Property Value

Type: PointFCollection
The points collection.

Property Value

Type: PointFCollection
The points collection. These must be specified in annotation space.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Methods

The HotSpotFreehandAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for this annotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from PointBaseAnnotation.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides PointBaseAnnotationOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.Clone Method

HotSpotFreehandAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.GetRegion Method

HotSpotFreehandAnnotationGetRegion Method

Returns a region for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace

Return Value

Type: AnnotationRegion
A region for this annotation.
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation.OnMouseUp Method

HotSpotFreehandAnnotationOnMouseUp Method

Called when the user has released the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.

Return Value

Type: Boolean
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotation Events

The HotSpotFreehandAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

HotSpotFreehandAnnotation Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotationFactory Class

This class generates a HotSpotFreehandAnnotation object from a HotSpotFreehandData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIHotSpotFreehandAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class HotSpotFreehandAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class HotSpotFreehandAnnotationFactory
    Implements IAnnotationUIFactory

The HotSpotFreehandAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | HotSpotFreehandAnnotationFactory | Creates a new instance of HotSpotFreehandAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a HotSpotFreehandAnnotation if the data object is a HotSpotFreehandData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotationFactory Constructor

Creates a new instance of HotSpotFreehandAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HotSpotFreehandAnnotationFactory()
Public Sub New
See Also

Reference

HotSpotFreehandAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotationFactory Methods

The HotSpotFreehandAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a HotSpotFreehandAnnotation if the data object is a HotSpotFreehandData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotSpotFreehandAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


HotSpotFreehandAnnotationFactory.GetAnnotationUI Method

HotSpotFreehandAnnotationFactoryGetAnnotationUI Method

Returns a HotSpotFreehandAnnotation if the data object is a HotSpotFreehandData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The HotSpotFreehandData object for the annotation.

Return Value

Type: AnnotationUI
A HotSpotFreehandAnnotation or null (Nothing in Visual Basic) if the data parameter is not a HotSpotFreehandData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

HotSpotFreehandAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


IAnnotate Interface

This interface must be implemented by any control hosting annotations. The AnnotationController requires the properties of this interface for rendering and user interaction.
This interface must be implemented by any control hosting annotations. The AnnotationController requires the properties of this interface for rendering and user interaction.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotate
Public Interface IAnnotate

The IAnnotate type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control used to render the annotations onto.
Public property | DocumentBounds | Gets the bounding rectangle of the document area.
Public property | KeyBinder | Gets the AnnotationKeyBinder used for binding annotation actions to key press events.
Public property | Resolution | Gets the resolution of the document.
Public property | Transform | Gets a transformation matrix used by the host control.
Public property | Units | Gets the units of measure for the document.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


IAnnotate Properties

The IAnnotate type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control used to render the annotations onto.
Public property | DocumentBounds | Gets the bounding rectangle of the document area.
Public property | KeyBinder | Gets the AnnotationKeyBinder used for binding annotation actions to key press events.
Public property | Resolution | Gets the resolution of the document.
Public property | Transform | Gets a transformation matrix used by the host control.
Public property | Units | Gets the units of measure for the document.
Top
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotate.Control Property

IAnnotateControl Property

Gets the control used to render the annotations onto.
Gets the control used to render the annotations onto.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Control Control { get; }
ReadOnly Property Control As Control
    Get

Property Value

Type: Control
The control hosting the annotations.

Property Value

Type: Control
The control hosting the annotations.
Remarks
The AnnotationController uses paint and mouse events to render and control the annotations.
Remarks
The AnnotationController uses paint and mouse events to render and control the annotations.
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotate.DocumentBounds Property

IAnnotateDocumentBounds Property

Gets the bounding rectangle of the document area.
Gets the bounding rectangle of the document area.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
RectangleF DocumentBounds { get; }
ReadOnly Property DocumentBounds As RectangleF
    Get

Property Value

Type: RectangleF
The bounding rectangle of the document.

Property Value

Type: RectangleF
The bounding rectangle of the document.
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotate.KeyBinder Property

IAnnotateKeyBinder Property

Gets the AnnotationKeyBinder used for binding annotation actions to key press events.
Gets the AnnotationKeyBinder used for binding annotation actions to key press events.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationKeyBinder KeyBinder { get; }
ReadOnly Property KeyBinder As AnnotationKeyBinder
    Get

Property Value

Type: AnnotationKeyBinder
The AnnotationKeyBinder used for this host or null (Nothing in VB) if key binding is not supported.

Property Value

Type: AnnotationKeyBinder
The AnnotationKeyBinder used for this host or null (Nothing in VB) if key binding is not supported.
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotate.Resolution Property

IAnnotateResolution Property

Gets the resolution of the document.
Gets the resolution of the document.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
PointF Resolution { get; }
ReadOnly Property Resolution As PointF
    Get

Property Value

Type: PointF
The resolution of the document.

Property Value

Type: PointF
The resolution of the document.
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotate.Transform Property

IAnnotateTransform Property

Gets a transformation matrix used by the host control.
Gets a transformation matrix used by the host control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Matrix Transform { get; }
ReadOnly Property Transform As Matrix
    Get

Property Value

Type: Matrix
A transformation matrix for the control.

Property Value

Type: Matrix
A transformation matrix for the control.
Remarks
This matrix is used to represent any offsets from scrolling and scaling that need to be reflected in the rendered annotations.
Remarks
This matrix is used to represent any offsets from scrolling and scaling that need to be reflected in the rendered annotations.
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotate.Units Property

IAnnotateUnits Property

Gets the units of measure for the document.
Gets the units of measure for the document.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationUnit Units { get; }
ReadOnly Property Units As AnnotationUnit
    Get

Property Value

Type: AnnotationUnit
The units of measure for the document.

Property Value

Type: AnnotationUnit
The units of measure for the document.
See Also

Reference

IAnnotate Interface
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider Interface

This interface is used to provide LayerData objects for images.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationDataProvider
Public Interface IAnnotationDataProvider

The IAnnotationDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetLayerData | Returns a LayerData object for the specified frame index or null (Nothing in VB) if there are no annotations.
Public method | PrepareForExtraction(AtalaImage) |
Public method | PrepareForExtraction(Stream, Int32) |
Public method | PrepareForExtraction(String, Int32) |
Public method | PrepareForExtraction(RandomAccessImageSource, Int32) |
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider Methods

The IAnnotationDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetLayerData | Returns a LayerData object for the specified frame index or null (Nothing in VB) if there are no annotations.
Public method | PrepareForExtraction(AtalaImage) |
Public method | PrepareForExtraction(Stream, Int32) |
Public method | PrepareForExtraction(String, Int32) |
Public method | PrepareForExtraction(RandomAccessImageSource, Int32) |
Top
See Also

Reference

IAnnotationDataProvider Interface
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider.GetLayerData Method

IAnnotationDataProviderGetLayerData Method

Returns a LayerData object for the specified frame index or null (Nothing in VB) if there are no annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
LayerData GetLayerData(
    int frameIndex
)
Function GetLayerData (
    frameIndex As Integer
) As LayerData

Parameters

frameIndex
Type: SystemInt32
The index of the layer to return.

Return Value

Type: LayerData
A LayerData for the image or null (Nothing in VB) if there are no annotations.
See Also

Reference

IAnnotationDataProvider Interface
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider.PrepareForExtraction Method

IAnnotationDataProviderPrepareForExtraction Method

These methods are used to prepare the IAnnotationDataProvider for calls to GetLayerData(Int32).
These methods are used to prepare the IAnnotationDataProvider for calls to GetLayerData(Int32).
These methods are used to prepare the IAnnotationDataProvider for calls to GetLayerData(Int32).
These methods are used to prepare the IAnnotationDataProvider for calls to GetLayerData(Int32).
Overload List
 | Name | Description
Public method | PrepareForExtraction(AtalaImage) |
Public method | PrepareForExtraction(Stream, Int32) |
Public method | PrepareForExtraction(String, Int32) |
Public method | PrepareForExtraction(RandomAccessImageSource, Int32) |
Top
See Also

Reference

IAnnotationDataProvider Interface
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider.PrepareForExtraction Method (AtalaImage)

IAnnotationDataProviderPrepareForExtraction Method (AtalaImage)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PrepareForExtraction(
    AtalaImage image
)
Sub PrepareForExtraction (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

IAnnotationDataProvider Interface
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider.PrepareForExtraction Method (Stream, Int32)

IAnnotationDataProviderPrepareForExtraction Method (Stream, Int32)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PrepareForExtraction(
    Stream stream,
    int frameIndex
)
Sub PrepareForExtraction (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
frameIndex
Type: SystemInt32
See Also

Reference

IAnnotationDataProvider Interface
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider.PrepareForExtraction Method (String, Int32)

IAnnotationDataProviderPrepareForExtraction Method (String, Int32)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PrepareForExtraction(
    string fileName,
    int frameIndex
)
Sub PrepareForExtraction (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
frameIndex
Type: SystemInt32
See Also

Reference

IAnnotationDataProvider Interface
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


IAnnotationDataProvider.PrepareForExtraction Method (RandomAccessImageSource, Int32)

IAnnotationDataProviderPrepareForExtraction Method (RandomAccessImageSource, Int32)

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PrepareForExtraction(
    RandomAccessImageSource source,
    int frameIndex
)
Sub PrepareForExtraction (
    source As RandomAccessImageSource,
    frameIndex As Integer
)

Parameters

source
Type: Atalasoft.ImagingRandomAccessImageSource
frameIndex
Type: SystemInt32
See Also

Reference

IAnnotationDataProvider Interface
PrepareForExtraction Overload
Atalasoft.Annotate.UI Namespace


IAnnotationGrips Interface

This interface must be implemented by any class acting as annotation grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationGrips
Public Interface IAnnotationGrips

The IAnnotationGrips type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of AnnotationGrip objects in the collection.
Public property | Fill | Gets the AnnotationBrush used for filling the grips.
Public property | Item | Returns an AnnotationGrip object from the collection at the specified index.
Public property | Outline | Gets the AnnotationPen used to draw the outline of the grip.
Public property | RotationFill | Gets the AnnotationBrush used to fill a rotation grip.
Public property | RotationOutline | Gets the AnnotationPen used to draw the outline of a rotation grip.
Public property | Size | Gets the size of the grips in pixels.
Top
Methods
 | Name | Description
Public method | GetEnumerator | An IEnumerator used to allow enumeration through the collection.
Public method | GetRegion | Returns a Region for the grips.
Public method | GripFromPoint | Returns a grip from the specified position.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


IAnnotationGrips Properties

The IAnnotationGrips type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of AnnotationGrip objects in the collection.
Public property | Fill | Gets the AnnotationBrush used for filling the grips.
Public property | Item | Returns an AnnotationGrip object from the collection at the specified index.
Public property | Outline | Gets the AnnotationPen used to draw the outline of the grip.
Public property | RotationFill | Gets the AnnotationBrush used to fill a rotation grip.
Public property | RotationOutline | Gets the AnnotationPen used to draw the outline of a rotation grip.
Public property | Size | Gets the size of the grips in pixels.
Top
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.Count Property

IAnnotationGripsCount Property

Gets the number of AnnotationGrip objects in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of grips in the collection.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.Fill Property

IAnnotationGripsFill Property

Gets the AnnotationBrush used for filling the grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationBrush Fill { get; set; }
Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the grips.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.Item Property

IAnnotationGripsItem Property

Returns an AnnotationGrip object from the collection at the specified index.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationGrip this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As AnnotationGrip
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: AnnotationGrip
The grip at the specified index.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.Outline Property

IAnnotationGripsOutline Property

Gets the AnnotationPen used to draw the outline of the grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationPen Outline { get; set; }
Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the outline.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.RotationFill Property

IAnnotationGripsRotationFill Property

Gets the AnnotationBrush used to fill a rotation grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationBrush RotationFill { get; set; }
Property RotationFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill a rotation grip.
Remarks
If this property is null (Nothing in VB) the Fill value will be used.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.RotationOutline Property

IAnnotationGripsRotationOutline Property

Gets the AnnotationPen used to draw the outline of a rotation grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationPen RotationOutline { get; set; }
Property RotationOutline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used to draw the outline of a rotation grip.
Remarks
If this value is null (Nothing in VB) the Outline property will be used.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.Size Property

IAnnotationGripsSize Property

Gets the size of the grips in pixels.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
SizeF Size { get; set; }
Property Size As SizeF
    Get
    Set

Property Value

Type: SizeF
The size of the grips in pixels.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips Methods

The IAnnotationGrips type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | An IEnumerator used to allow enumeration through the collection.
Public method | GetRegion | Returns a Region for the grips.
Public method | GripFromPoint | Returns a grip from the specified position.
Top
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.GetEnumerator Method

IAnnotationGripsGetEnumerator Method

An IEnumerator used to allow enumeration through the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
The IEnumerator for this class.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.GetRegion Method

IAnnotationGripsGetRegion Method

Returns a Region for the grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationRegion GetRegion()
Function GetRegion As AnnotationRegion

Return Value

Type: AnnotationRegion
A render for the grips.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationGrips.GripFromPoint Method

IAnnotationGripsGripFromPoint Method

Returns a grip from the specified position.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationGrip GripFromPoint(
    PointF point
)
Function GripFromPoint (
    point As PointF
) As AnnotationGrip

Parameters

point
Type: System.DrawingPointF
The point to search for. This position must be in annotation space.

Return Value

Type: AnnotationGrip
The grip at the location provided or null (Nothing in VB) if there was no grip found.
See Also

Reference

IAnnotationGrips Interface
Atalasoft.Annotate.UI Namespace


IAnnotationUIFactory Interface

This interface must be implemented by any class used as an annotation UI factory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationUIFactory
Public Interface IAnnotationUIFactory

The IAnnotationUIFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetAnnotationUI | Returns the AnnotationUI object for a specific AnnotationData class.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


IAnnotationUIFactory Methods

The IAnnotationUIFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetAnnotationUI | Returns the AnnotationUI object for a specific AnnotationData class.
Top
See Also

Reference

IAnnotationUIFactory Interface
Atalasoft.Annotate.UI Namespace


IAnnotationUIFactory.GetAnnotationUI Method

IAnnotationUIFactoryGetAnnotationUI Method

Returns the AnnotationUI object for a specific AnnotationData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data from which a UI is requested.

Return Value

Type: AnnotationUI
The AnnotationUI object or null (Nothing in VB) if the factory is unable to create the object.
See Also

Reference

IAnnotationUIFactory Interface
Atalasoft.Annotate.UI Namespace


LayerAnnotation Class

A LayerAnnotation is a collection of other annotations, including other LayerAnnotation objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UILayerAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LayerAnnotation : AnnotationUI,
    IDisposable, IDeserializationCallback
<SerializableAttribute>
Public Class LayerAnnotation
    Inherits AnnotationUI
    Implements IDisposable, IDeserializationCallback

The LayerAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | LayerAnnotation | Creates a new instance of LayerAnnotation.
Public method | LayerAnnotation(AnnotationUICollection) | Creates a new instance of LayerAnnotation specifying an AnnotationUICollection for this layer.
Public method | LayerAnnotation(LayerData) | Creates a new instance of LayerAnnotation specifying the LayerData for this annotation.
Public method | LayerAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of LayerAnnotation from serialized information.
Top
Properties
 | Name | Description
Public property | Bounds | (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | GroupAnnotation | Gets or sets a value indicating whether the annotations in this layer are acting as a single group.
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Items | Gets an AnnotationUICollection for this layer.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Public method | CreateAnnotationUIObjects | Use this method to force the LayerAnnotation to create AnnotationUI objects for its AnnotationData objects after deserialization or after using the constructor taking a LayerData.
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Disposes this layer and all items it contains.
Protected method | Dispose(Boolean) | Releases resources used by the layer and its contained annotations.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the LayerAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this layer. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Gets the combined region for all annotations contained in this layer. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | (Overrides AnnotationUIOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnChildAnnotationPropertyChanged | Called when a property of a child annotation has changed.
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | (Overrides AnnotationUIOnControllerChanged(EventArgs).)
Public method | OnDeserialization | Called when a formatter is finished deserializing the LayerAnnotation.
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | ChildAnnotationPropertyChanged | This event is raised when a property of an annotation contained in the layer has been changed.
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
Remarks
The LayerAnnotation can be used as a 'group' by setting its GroupAnnotation property to true. This will allow all of the annotations it contains to be moved and resized as a single unit.
See Also

Reference

Atalasoft.Annotate.UI Namespace


LayerAnnotation Constructor

Constructs a LayerAnnotation.
Overload List
 | Name | Description
Public method | LayerAnnotation | Creates a new instance of LayerAnnotation.
Public method | LayerAnnotation(AnnotationUICollection) | Creates a new instance of LayerAnnotation specifying an AnnotationUICollection for this layer.
Public method | LayerAnnotation(LayerData) | Creates a new instance of LayerAnnotation specifying the LayerData for this annotation.
Public method | LayerAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of LayerAnnotation from serialized information.
Top
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation Constructor

Creates a new instance of LayerAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation()
Public Sub New
See Also

Reference

LayerAnnotation Class
LayerAnnotation Overload
Atalasoft.Annotate.UI Namespace


LayerAnnotation Constructor (AnnotationUICollection)

Creates a new instance of LayerAnnotation specifying an AnnotationUICollection for this layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation(
    AnnotationUICollection annotations
)
Public Sub New (
    annotations As AnnotationUICollection
)

Parameters

annotations
Type: Atalasoft.Annotate.UIAnnotationUICollection
An AnnotationUICollection for this layer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

LayerAnnotation Class
LayerAnnotation Overload
Atalasoft.Annotate.UI Namespace


LayerAnnotation Constructor (LayerData)

Creates a new instance of LayerAnnotation specifying the LayerData for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation(
    LayerData data
)
Public Sub New (
    data As LayerData
)

Parameters

data
Type: Atalasoft.AnnotateLayerData
The LayerData for this annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

LayerAnnotation Class
LayerAnnotation Overload
Atalasoft.Annotate.UI Namespace


LayerAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LayerAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this layer.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LayerAnnotation Class
LayerAnnotation Overload
Atalasoft.Annotate.UI Namespace


LayerAnnotation Properties

The LayerAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | GroupAnnotation | Gets or sets a value indicating whether the annotations in this layer are acting as a single group.
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Items | Gets an AnnotationUICollection for this layer.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Bounds Property

LayerAnnotationBounds Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.GroupAnnotation Property

LayerAnnotationGroupAnnotation Property

Gets or sets a value indicating whether the annotations in this layer are acting as a single group.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GroupAnnotation { get; set; }
Public Property GroupAnnotation As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this layer is a group.
Remarks
Setting this property to true will allow all contained annotations to be moved and resized together rather than separately.
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Items Property

LayerAnnotationItems Property

Gets an AnnotationUICollection for this layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection Items { get; }
Public ReadOnly Property Items As AnnotationUICollection
    Get

Property Value

Type: AnnotationUICollection
An collection of AnnotationUI objects.
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation Methods

The LayerAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Public method | CreateAnnotationUIObjects | Use this method to force the LayerAnnotation to create AnnotationUI objects for its AnnotationData objects after deserialization or after using the constructor taking a LayerData.
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Disposes this layer and all items it contains.
Protected method | Dispose(Boolean) | Releases resources used by the layer and its contained annotations.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the LayerAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this layer. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Gets the combined region for all annotations contained in this layer. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | (Overrides AnnotationUIOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnChildAnnotationPropertyChanged | Called when a property of a child annotation has changed.
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | (Overrides AnnotationUIOnControllerChanged(EventArgs).)
Public method | OnDeserialization | Called when a formatter is finished deserializing the LayerAnnotation.
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Clone Method

LayerAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.CreateAnnotationUIObjects Method

LayerAnnotationCreateAnnotationUIObjects Method

Use this method to force the LayerAnnotation to create AnnotationUI objects for its AnnotationData objects after deserialization or after using the constructor taking a LayerData.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CreateAnnotationUIObjects(
    AnnotationUIFactoryCollection factories
)
Public Sub CreateAnnotationUIObjects (
    factories As AnnotationUIFactoryCollection
)

Parameters

factories
Type: Atalasoft.Annotate.UIAnnotationUIFactoryCollection
The UI factories that will be used to create the annotation objects. Normally this will be the AnnotationController.Factories property.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the factories argument is null (Nothing in VB).
Remarks
This method is automatically called when annotations are deserialized using the AnnotationController.Load method.
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Dispose Method

LayerAnnotationDispose Method

Disposes the LayerAnnotation and all of its child objects.
Overload List
 | Name | Description
Public method | Dispose | Disposes this layer and all items it contains.
Protected method | Dispose(Boolean) | Releases resources used by the layer and its contained annotations.
Top
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Dispose Method

LayerAnnotationDispose Method

Disposes this layer and all items it contains.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

LayerAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Dispose Method (Boolean)

LayerAnnotationDispose Method (Boolean)

Releases resources used by the layer and its contained annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

LayerAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


LayerAnnotation.Finalize Method

LayerAnnotationFinalize Method

Finalizes an instance of the LayerAnnotation class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.GetObjectData Method

LayerAnnotationGetObjectData Method

Fills a SerializationInfo object with information about this layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where information is stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.GetRegion Method

LayerAnnotationGetRegion Method

Gets the combined region for all annotations contained in this layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
Indicates the space coordinates to return.

Return Value

Type: AnnotationRegion
A Region for this layer.
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnAnnotationControllerNotification Method

LayerAnnotationOnAnnotationControllerNotification Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overrides Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnChildAnnotationPropertyChanged Method

LayerAnnotationOnChildAnnotationPropertyChanged Method

Called when a property of a child annotation has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnChildAnnotationPropertyChanged(
    Object sender,
    AnnotationPropertyChangedEventArgs e
)
Protected Overridable Sub OnChildAnnotationPropertyChanged (
    sender As Object,
    e As AnnotationPropertyChangedEventArgs
)

Parameters

sender
Type: SystemObject
The annotation that has changed.
e
Type: Atalasoft.AnnotateAnnotationPropertyChangedEventArgs
An AnnotationPropertyChangedEventArgs containing information for this change.
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnControllerChanged Method

LayerAnnotationOnControllerChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnControllerChanged(
    EventArgs e
)
Protected Overrides Sub OnControllerChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnDeserialization Method

LayerAnnotationOnDeserialization Method

Called when a formatter is finished deserializing the LayerAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
The object calling this method. This is normally null (Nothing in VB).

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnMoving Method

LayerAnnotationOnMoving Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnPropertyChanging Method

LayerAnnotationOnPropertyChanging Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.OnResizing Method

LayerAnnotationOnResizing Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResizing(
    EventArgs e
)
Protected Overrides Sub OnResizing (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation Events

The LayerAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | ChildAnnotationPropertyChanged | This event is raised when a property of an annotation contained in the layer has been changed.
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotation.ChildAnnotationPropertyChanged Event

LayerAnnotationChildAnnotationPropertyChanged Event

This event is raised when a property of an annotation contained in the layer has been changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<AnnotationPropertyChangedEventArgs> ChildAnnotationPropertyChanged
Public Event ChildAnnotationPropertyChanged As EventHandler(Of AnnotationPropertyChangedEventArgs)

Value

Type: SystemEventHandler AnnotationPropertyChangedEventArgs
See Also

Reference

LayerAnnotation Class
Atalasoft.Annotate.UI Namespace


LayerAnnotationFactory Class

This class generates a LayerAnnotation object from a LayerData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UILayerAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class LayerAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class LayerAnnotationFactory
    Implements IAnnotationUIFactory

The LayerAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LayerAnnotationFactory | Creates a new instance of LayerAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a LayerAnnotation if the data object is a LayerData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


LayerAnnotationFactory Constructor

Creates a new instance of LayerAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotationFactory()
Public Sub New
See Also

Reference

LayerAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LayerAnnotationFactory Methods

The LayerAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a LayerAnnotation if the data object is a LayerData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LayerAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LayerAnnotationFactory.GetAnnotationUI Method

LayerAnnotationFactoryGetAnnotationUI Method

Returns a LayerAnnotation if the data object is a LayerData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The LayerData object for the annotation.

Return Value

Type: AnnotationUI
A LayerAnnotation or null (Nothing in Visual Basic) if the data parameter is not a LayerData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

LayerAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LayerCollection Class

This class is used to hold a collection of LayerAnnotation objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Annotate.UILayerCollection

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LayerCollection : CollectionBase,
    ISerializable, IDisposable, IDeserializationCallback
<SerializableAttribute>
Public Class LayerCollection
    Inherits CollectionBase
    Implements ISerializable, IDisposable, IDeserializationCallback

The LayerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LayerCollection | Creates a new instance of LayerCollection.
Public method | LayerCollection(SerializationInfo, StreamingContext) | Creates a new instance of LayerCollection from serialized information.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Controller | Gets the AnnotationController for this LayerCollection.
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the LayerAnnotation at the specified index in the collection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds a layer to the collection.
Public method | AddRange | Adds an array of layers to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value indicating whether a layer is contains within the collection.
Public method | CopyTo | Copies items into the specified array.
Public method | Dispose | Releases memory used by this collection and all of its annotations.
Protected method | Dispose(Boolean) | Releases resources used by the collection and all of its LayerAnnotation objects.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the LayerCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the position of a layer within the collection or -1 if the layer is not in the collection.
Public method | Insert | Inserts a layer into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called when a change has been made to the collection or an object in the collection.
Protected method | OnClear | Called when the Clear method is invoked. (Overrides CollectionBaseOnClear.)
Protected method | OnClearComplete | Called when the Clear method has completed. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnCollectionChanged | Called when there is any change to the collection.
Protected method | OnControllerChanged | Called when the AnnotationController using this LayerCollection has changed.
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Called when an item has been added or inserted into the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnPropertyChanging | Called before this collection or an object in the collection has been changed.
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Called when a remove method has completed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Called when an item in the collection has been changed. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(LayerAnnotation) | Removes a layer from the collection.
Public method | Remove(LayerAnnotation) | Removes an array of LayerAnnotation objects from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Replace(Int32, LayerAnnotation) | Replaces a layer at the specified index with the provided layer.
Public method | Replace(LayerAnnotation, LayerAnnotation) | Replaces an existing layer with another one.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after this collection or an item in the collection has been changed.
Public event | CollectionChanged | Raised when there has been a change in the collection.
Public event | PropertyChanging | Raised before this collection or an item in the collection has been changed.
Top
Remarks
The order of the layers in the LayerCollection determines the stacking (z-order) used when rendering. For instance, the layer at index 1 is rendered on top of the layer at index 0. The order can be changed using the ChangeAnnotationPosition(ChangePositionMethod) method; this is because a LayerAnnotation derives from AnnotationUI.
See Also

Reference

Atalasoft.Annotate.UI Namespace


LayerCollection Constructor

Constructs a LayerCollection.
Overload List
 | Name | Description
Public method | LayerCollection | Creates a new instance of LayerCollection.
Public method | LayerCollection(SerializationInfo, StreamingContext) | Creates a new instance of LayerCollection from serialized information.
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection Constructor

Creates a new instance of LayerCollection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerCollection()
Public Sub New
See Also

Reference

LayerCollection Class
LayerCollection Overload
Atalasoft.Annotate.UI Namespace


LayerCollection Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LayerCollection from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerCollection(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this collection.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LayerCollection Class
LayerCollection Overload
Atalasoft.Annotate.UI Namespace


LayerCollection Properties

The LayerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Controller | Gets the AnnotationController for this LayerCollection.
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the LayerAnnotation at the specified index in the collection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Controller Property

LayerCollectionController Property

Gets the AnnotationController for this LayerCollection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationController Controller { get; }
Public ReadOnly Property Controller As AnnotationController
    Get

Property Value

Type: AnnotationController
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Item Property

LayerCollectionItem Property

Gets the LayerAnnotation at the specified index in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As LayerAnnotation
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to get.

Property Value

Type: LayerAnnotation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection Methods

The LayerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a layer to the collection.
Public method | AddRange | Adds an array of layers to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value indicating whether a layer is contains within the collection.
Public method | CopyTo | Copies items into the specified array.
Public method | Dispose | Releases memory used by this collection and all of its annotations.
Protected method | Dispose(Boolean) | Releases resources used by the collection and all of its LayerAnnotation objects.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the LayerCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the position of a layer within the collection or -1 if the layer is not in the collection.
Public method | Insert | Inserts a layer into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationControllerNotification | Called when a change has been made to the collection or an object in the collection.
Protected method | OnClear | Called when the Clear method is invoked. (Overrides CollectionBaseOnClear.)
Protected method | OnClearComplete | Called when the Clear method has completed. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnCollectionChanged | Called when there is any change to the collection.
Protected method | OnControllerChanged | Called when the AnnotationController using this LayerCollection has changed.
Public method | OnDeserialization | Called after an object has been fully deserialized by a serialization formatter.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Called when an item has been added or inserted into the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnPropertyChanging | Called before this collection or an object in the collection has been changed.
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Called when a remove method has completed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Called when an item in the collection has been changed. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(LayerAnnotation) | Removes a layer from the collection.
Public method | Remove(LayerAnnotation) | Removes an array of LayerAnnotation objects from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Replace(Int32, LayerAnnotation) | Replaces a layer at the specified index with the provided layer.
Public method | Replace(LayerAnnotation, LayerAnnotation) | Replaces an existing layer with another one.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Add Method

LayerCollectionAdd Method

Adds a layer to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    LayerAnnotation layer
)
Public Sub Add (
    layer As LayerAnnotation
)

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer parameter is null.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.AddRange Method

LayerCollectionAddRange Method

Adds an array of layers to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    LayerAnnotation[] layers
)
Public Sub AddRange (
    layers As LayerAnnotation()
)

Parameters

layers
Type: Atalasoft.Annotate.UILayerAnnotation
An array of layers to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layers parameter is null.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Contains Method

LayerCollectionContains Method

Returns a value indicating whether a layer is contains within the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    LayerAnnotation layer
)
Public Function Contains (
    layer As LayerAnnotation
) As Boolean

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to search for.

Return Value

Type: Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer parameter is null.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.CopyTo Method

LayerCollectionCopyTo Method

Copies items into the specified array.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    LayerAnnotation[] array,
    int index
)
Public Sub CopyTo (
    array As LayerAnnotation(),
    index As Integer
)

Parameters

array
Type: Atalasoft.Annotate.UILayerAnnotation
The array to copy items into.
index
Type: SystemInt32
The index in the target array to begin copying items.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Dispose Method

LayerCollectionDispose Method

Disposes the LayerCollection and all contained layers.
Overload List
 | Name | Description
Public method | Dispose | Releases memory used by this collection and all of its annotations.
Protected method | Dispose(Boolean) | Releases resources used by the collection and all of its LayerAnnotation objects.
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Dispose Method

LayerCollectionDispose Method

Releases memory used by this collection and all of its annotations.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

LayerCollection Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


LayerCollection.Dispose Method (Boolean)

LayerCollectionDispose Method (Boolean)

Releases resources used by the collection and all of its LayerAnnotation objects.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method was called from the public Dispose method.
See Also

Reference

LayerCollection Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


LayerCollection.Finalize Method

LayerCollectionFinalize Method

Finalizes an instance of the LayerCollection class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.GetObjectData Method

LayerCollectionGetObjectData Method

Fills a SerializationInfo object with information about this collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object where information will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.IndexOf Method

LayerCollectionIndexOf Method

Returns the position of a layer within the collection or -1 if the layer is not in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    LayerAnnotation layer
)
Public Function IndexOf (
    layer As LayerAnnotation
) As Integer

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to search for.

Return Value

Type: Int32
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer parameter is null.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Insert Method

LayerCollectionInsert Method

Inserts a layer into the collection at the specified index.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    LayerAnnotation layer
)
Public Sub Insert (
    index As Integer,
    layer As LayerAnnotation
)

Parameters

index
Type: SystemInt32
The position within the collection this layer should be placed.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to insert.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer parameter is null.
ArgumentOutOfRangeException | Thrown if the index parameter is out of range for this collection.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnAnnotationControllerNotification Method

LayerCollectionOnAnnotationControllerNotification Method

Called when a change has been made to the collection or an object in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overridable Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information about this change.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnClear Method

LayerCollectionOnClear Method

Called when the Clear method is invoked.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClear()
Protected Overrides Sub OnClear
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnClearComplete Method

LayerCollectionOnClearComplete Method

Called when the Clear method has completed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnCollectionChanged Method

LayerCollectionOnCollectionChanged Method

Called when there is any change to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCollectionChanged(
    CollectionChangedEventArgs e
)
Protected Overridable Sub OnCollectionChanged (
    e As CollectionChangedEventArgs
)

Parameters

e
Type: Atalasoft.UtilsCollectionChangedEventArgs
An CollectionChangedEventArgs containing information about this event.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnControllerChanged Method

LayerCollectionOnControllerChanged Method

Called when the AnnotationController using this LayerCollection has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnControllerChanged()
Protected Overridable Sub OnControllerChanged
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnDeserialization Method

LayerCollectionOnDeserialization Method

Called after an object has been fully deserialized by a serialization formatter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
The formatter deserializing the data.

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnInsertComplete Method

LayerCollectionOnInsertComplete Method

Called when an item has been added or inserted into the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index where the item was placed.
value
Type: SystemObject
The items that was added.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnPropertyChanging Method

LayerCollectionOnPropertyChanging Method

Called before this collection or an object in the collection has been changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overridable Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
An AnnotationPropertyChangingEventArgs containing information about this change.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnRemoveComplete Method

LayerCollectionOnRemoveComplete Method

Called when a remove method has completed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the item that was removed.
value
Type: SystemObject
The item that was removed.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.OnSetComplete Method

LayerCollectionOnSetComplete Method

Called when an item in the collection has been changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The index of the item that was changed.
oldValue
Type: SystemObject
The old value of the item.
newValue
Type: SystemObject
The new value of the item.
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Remove Method

LayerCollectionRemove Method

Use these methods to remove a layer from the collection.
Overload List
 | Name | Description
Public method | Remove(LayerAnnotation) | Removes a layer from the collection.
Public method | Remove(LayerAnnotation) | Removes an array of LayerAnnotation objects from the collection.
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Remove Method (LayerAnnotation)

LayerCollectionRemove Method (LayerAnnotation)

Removes a layer from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    LayerAnnotation layer
)
Public Sub Remove (
    layer As LayerAnnotation
)

Parameters

layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to remove.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer parameter is null.
See Also

Reference

LayerCollection Class
Remove Overload
Atalasoft.Annotate.UI Namespace


LayerCollection.Remove Method (LayerAnnotation[])

LayerCollectionRemove Method (LayerAnnotation)

Removes an array of LayerAnnotation objects from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    LayerAnnotation[] layers
)
Public Sub Remove (
    layers As LayerAnnotation()
)

Parameters

layers
Type: Atalasoft.Annotate.UILayerAnnotation
An array of LayerAnnotation to remove.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layers argument is null (Nothing in VB).
See Also

Reference

LayerCollection Class
Remove Overload
Atalasoft.Annotate.UI Namespace


LayerCollection.Replace Method

LayerCollectionReplace Method

These methods are used to replace a layer in the collection.
Overload List
 | Name | Description
Public method | Replace(Int32, LayerAnnotation) | Replaces a layer at the specified index with the provided layer.
Public method | Replace(LayerAnnotation, LayerAnnotation) | Replaces an existing layer with another one.
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.Replace Method (Int32, LayerAnnotation)

LayerCollectionReplace Method (Int32, LayerAnnotation)

Replaces a layer at the specified index with the provided layer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    int index,
    LayerAnnotation newLayer
)
Public Sub Replace (
    index As Integer,
    newLayer As LayerAnnotation
)

Parameters

index
Type: SystemInt32
The index of the layer to replace.
newLayer
Type: Atalasoft.Annotate.UILayerAnnotation
The new layer to insert into the collection.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
ArgumentNullException | Thrown if the new layer is null (Nothing in VB).
See Also

Reference

LayerCollection Class
Replace Overload
Atalasoft.Annotate.UI Namespace


LayerCollection.Replace Method (LayerAnnotation, LayerAnnotation)

LayerCollectionReplace Method (LayerAnnotation, LayerAnnotation)

Replaces an existing layer with another one.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    LayerAnnotation oldLayer,
    LayerAnnotation newLayer
)
Public Sub Replace (
    oldLayer As LayerAnnotation,
    newLayer As LayerAnnotation
)

Parameters

oldLayer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer currently in the collection.
newLayer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer to insert into the collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if either argument is null (Nothing in VB).
ArgumentException | Thrown if the old layer does not exist in the collection.
See Also

Reference

LayerCollection Class
Replace Overload
Atalasoft.Annotate.UI Namespace


LayerCollection Events

The LayerCollection type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after this collection or an item in the collection has been changed.
Public event | CollectionChanged | Raised when there has been a change in the collection.
Public event | PropertyChanging | Raised before this collection or an item in the collection has been changed.
Top
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.AnnotationControllerNotification Event

LayerCollectionAnnotationControllerNotification Event

Raised after this collection or an item in the collection has been changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationControllerNotificationEventHandler AnnotationControllerNotification
Public Event AnnotationControllerNotification As AnnotationControllerNotificationEventHandler

Value

Type: Atalasoft.AnnotateAnnotationControllerNotificationEventHandler
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.CollectionChanged Event

LayerCollectionCollectionChanged Event

Raised when there has been a change in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As CollectionChangedEventHandler

Value

Type: Atalasoft.UtilsCollectionChangedEventHandler
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LayerCollection.PropertyChanging Event

LayerCollectionPropertyChanging Event

Raised before this collection or an item in the collection has been changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As AnnotationPropertyChangingEventHandler

Value

Type: Atalasoft.AnnotateAnnotationPropertyChangingEventHandler
See Also

Reference

LayerCollection Class
Atalasoft.Annotate.UI Namespace


LineAnnotation Class

This is a single line annotation from StartPoint to EndPoint.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UILineAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LineAnnotation : AnnotationUI
<SerializableAttribute>
Public Class LineAnnotation
    Inherits AnnotationUI

The LineAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | LineAnnotation | Creates a new instance of LineAnnotation.
Public method | LineAnnotation(AnnotationPen) | Creates a new instance of LineAnnotation specifying the outline.
Public method | LineAnnotation(LineData) | Creates a new instance of LineAnnotation specifying the LineData used for this annotation.
Public method | LineAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of LineAnnotation from serialized information.
Public method | LineAnnotation(AnnotationPen, Boolean) | Creates a new instance of LineAnnotation specifying the outline and translucent properties.
Public method | LineAnnotation(AnnotationPen, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineAnnotation specifying the outline, starting and ending points.
Public method | LineAnnotation(PointF, PointF, AnnotationPen, Boolean) | Creates a new instance of LineAnnotation specifying the start and end points, outline and translucent properties.
Public method | LineAnnotation(AnnotationPen, PointF, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineAnnotation specifying the outline, starting and ending points.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | EndPoint | Gets or sets the ending point for the line.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for this annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | StartPoint | Gets or sets the starting point for the line.
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used has a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Overrides AnnotationUIBeginCreate.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Overrides AnnotationUIOnSizeChanged(AnnotationSizeChangedEventArgs).)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
Remarks
This annotation can be created with a single click and drag or by clicking once for the start point and a second time for the end point.
See Also

Reference

Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor

Constructs a LineAnnotation.
Overload List
 | Name | Description
Public method | LineAnnotation | Creates a new instance of LineAnnotation.
Public method | LineAnnotation(AnnotationPen) | Creates a new instance of LineAnnotation specifying the outline.
Public method | LineAnnotation(LineData) | Creates a new instance of LineAnnotation specifying the LineData used for this annotation.
Public method | LineAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of LineAnnotation from serialized information.
Public method | LineAnnotation(AnnotationPen, Boolean) | Creates a new instance of LineAnnotation specifying the outline and translucent properties.
Public method | LineAnnotation(AnnotationPen, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineAnnotation specifying the outline, starting and ending points.
Public method | LineAnnotation(PointF, PointF, AnnotationPen, Boolean) | Creates a new instance of LineAnnotation specifying the start and end points, outline and translucent properties.
Public method | LineAnnotation(AnnotationPen, PointF, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LineAnnotation specifying the outline, starting and ending points.
Top
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor

Creates a new instance of LineAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation()
Public Sub New
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (AnnotationPen)

Creates a new instance of LineAnnotation specifying the outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation(
    AnnotationPen outline
)
Public Sub New (
    outline As AnnotationPen
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (LineData)

Creates a new instance of LineAnnotation specifying the LineData used for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation(
    LineData data
)
Public Sub New (
    data As LineData
)

Parameters

data
Type: Atalasoft.AnnotateLineData
The LineData object for the annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LineAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext of this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (AnnotationPen, Boolean)

Creates a new instance of LineAnnotation specifying the outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation(
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
translucent
Type: SystemBoolean
A value indicating whether the line will be translucent, giving it a highlighter effect.
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (AnnotationPen, PointF, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LineAnnotation specifying the outline, starting and ending points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)]
public LineAnnotation(
    AnnotationPen outline,
    PointF startPoint,
    PointF endPoint
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    startPoint As PointF,
    endPoint As PointF
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
startPoint
Type: System.DrawingPointF
The starting point of the line.
endPoint
Type: System.DrawingPointF
The ending point of the line.
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (PointF, PointF, AnnotationPen, Boolean)

Creates a new instance of LineAnnotation specifying the start and end points, outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation(
    PointF startPoint,
    PointF endPoint,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

startPoint
Type: System.DrawingPointF
The starting point of the line.
endPoint
Type: System.DrawingPointF
The ending point of the line.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
translucent
Type: SystemBoolean
A value indicating whether the line will be translucent, giving it a highlighter effect.
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Constructor (AnnotationPen, PointF, PointF, Boolean)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LineAnnotation specifying the outline, starting and ending points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)]
public LineAnnotation(
    AnnotationPen outline,
    PointF startPoint,
    PointF endPoint,
    bool translucent
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes the start and end points as its first arguments.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    startPoint As PointF,
    endPoint As PointF,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the line.
startPoint
Type: System.DrawingPointF
The starting point of the line.
endPoint
Type: System.DrawingPointF
The ending point of the line.
translucent
Type: SystemBoolean
A value indicating if this annotation should act as a highlighter.
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.Annotate.UI Namespace


LineAnnotation Properties

The LineAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | EndPoint | Gets or sets the ending point for the line.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for this annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | StartPoint | Gets or sets the starting point for the line.
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used has a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.Bounds Property

LineAnnotationBounds Property

Gets the bounding rectangle for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
The bounding rectangle for the annotation.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.EndPoint Property

LineAnnotationEndPoint Property

Gets or sets the ending point for the line.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF EndPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property EndPoint As PointF
    Get
    Set

Property Value

Type: PointF
The ending point for the line in annotation space.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.Outline Property

LineAnnotationOutline Property

Gets or sets the outline for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the line.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.StartPoint Property

LineAnnotationStartPoint Property

Gets or sets the starting point for the line.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF StartPoint { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property StartPoint As PointF
    Get
    Set

Property Value

Type: PointF
The starting point for the line in annotation space.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.Translucent Property

LineAnnotationTranslucent Property

Gets or sets a value indicating whether this annotation is used has a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if this annotation is a highlighter.
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument(DocumentRotation, Int32) method.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation Methods

The LineAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Overrides AnnotationUIBeginCreate.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Overrides AnnotationUIOnSizeChanged(AnnotationSizeChangedEventArgs).)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.BeginCreate Method

LineAnnotationBeginCreate Method

This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void BeginCreate()
Public Overrides Sub BeginCreate
Remarks
Use this method to prepare the annotation for creation by receiving the OnMouseDown(AnnotationMouseEventArgs), OnMouseMove(AnnotationMouseEventArgs) and OnMouseUp(AnnotationMouseEventArgs) method calls.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.Clone Method

LineAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.GetRegion Method

LineAnnotationGetRegion Method

Returns a rectangular region for this annotation, including its grips if selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
The space coordinate system used to generate this region.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.
Examples
The following is an example of how a custom annotation may override the GetRegion method.
GetRegionCS
Copy
public override AnnotationRegion GetRegion(AnnotateSpace space)
{
Create the region in annotation space.
AnnotationRegion reg = new AnnotationRegion(new RectangleF(PointF.Empty, _data.Size));
if (this.Selected && this.Grips != null)
AddGripsToRegion(reg);
ApplyRegionTransform(reg, space);
return reg;
}
GetRegionVB
Copy
Public Overrides Function GetRegion(ByVal space As AnnotateSpace) As AnnotationRegion
' Create the region in annotation space.
Dim reg As AnnotationRegion =  New AnnotationRegion(New RectangleF(PointF.Empty,_data.Size))
If Not Me.Selected And Me.Grips Is Nothing Then
AddGripsToRegion(reg)
End If
ApplyRegionTransform(reg, space)
Return reg
End Function
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.OnGripPositionChanged Method

LineAnnotationOnGripPositionChanged Method

Called when a grip of the annotation has been moved by the user using the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    AnnotationGripChangedEventArgs e
)
Protected Overrides Sub OnGripPositionChanged (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
An AnnotationGripChangedEventArgs containing information about this event.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.OnMouseDown Method

LineAnnotationOnMouseDown Method

Called when the user clicks down on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.OnMouseMove Method

LineAnnotationOnMouseMove Method

Called when the user has moved the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.OnMouseUp Method

LineAnnotationOnMouseUp Method

Called when the user has released the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.

Return Value

Type: Boolean
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation.OnSizeChanged Method

LineAnnotationOnSizeChanged Method

Called when the Size property of the annotation has changed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSizeChanged(
    AnnotationSizeChangedEventArgs e
)
Protected Overrides Sub OnSizeChanged (
    e As AnnotationSizeChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationSizeChangedEventArgs
An AnnotationSizeChangedEventArgs containing information for this event.
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotation Events

The LineAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

LineAnnotation Class
Atalasoft.Annotate.UI Namespace


LineAnnotationFactory Class

This class generates a LineAnnotation object from a LineData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UILineAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class LineAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class LineAnnotationFactory
    Implements IAnnotationUIFactory

The LineAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LineAnnotationFactory | Creates a new instance of LineAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a LineAnnotation if the data object is a LineData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


LineAnnotationFactory Constructor

Creates a new instance of LineAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotationFactory()
Public Sub New
See Also

Reference

LineAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LineAnnotationFactory Methods

The LineAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a LineAnnotation if the data object is a LineData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LineAnnotationFactory.GetAnnotationUI Method

LineAnnotationFactoryGetAnnotationUI Method

Returns a LineAnnotation if the data object is a LineData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The LineData object for the annotation.

Return Value

Type: AnnotationUI
A LineAnnotation or null (Nothing in Visual Basic) if the data parameter is not a LineData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

LineAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation Class

The LinesAnnoation represents a series of points connected by straight lines.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIPointBaseAnnotation
Atalasoft.Annotate.UILinesAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LinesAnnotation : PointBaseAnnotation
<SerializableAttribute>
Public Class LinesAnnotation
    Inherits PointBaseAnnotation

The LinesAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | LinesAnnotation | Creates a new instance of LinesAnnotation.
Public method | LinesAnnotation(AnnotationPen) | Creates a new instance of LinesAnnotation specifying the outline.
Public method | LinesAnnotation(LinesData) | Creates a new instance of LinesAnnotation specifying the LinesData used by this annotation.
Public method | LinesAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of LinesAnnotation from serialized information.
Public method | LinesAnnotation(AnnotationPen, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline and end points.
Public method | LinesAnnotation(AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline and an array of end points.
Public method | LinesAnnotation(PointF, AnnotationPen, Boolean) | Creates a new instance of LinesAnnotation specifying the points, outline and translucent properties.
Public method | LinesAnnotation(AnnotationPen, PointFCollection, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline, points and whether this annotation is a highlighter.
Public method | LinesAnnotation(AnnotationPen, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline, an array of points and whether this annotation is a highlighter.
Public method | LinesAnnotation(PointFCollection, AnnotationPen, Boolean) | Creates a new instance of LinesAnnotation specifying the point collection, outline and translucent properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets a PointFCollection containing the points for this annotation.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether the line is drawn as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for this annotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from PointBaseAnnotation.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
Remarks

To generate a LinesAnnotation, the user clicks the left mouse button to set each point. The user can stop adding points by clicking the right mouse button.

There must be at least two points in the Points collection for this annotation.

Examples
The following code creates a new LinesAnnotation and prepares the AnnotationController for the user to create the annotation using a mouse.
LinesAnnotation
Copy
LinesAnnotation lines = new LinesAnnotation(new AnnotationPen(Color.ForestGreen, 1));
this.annotateViewer1.Annotations.CreateAnnotation(lines);
LinesAnnotationVB
Copy
Dim lines As LinesAnnotation =  New LinesAnnotation(New AnnotationPen(Color.ForestGreen,1))
Me.annotateViewer1.Annotations.CreateAnnotation(lines)
See Also

Reference

Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor

Constructs a LinesAnnotation.
Overload List
 | Name | Description
Public method | LinesAnnotation | Creates a new instance of LinesAnnotation.
Public method | LinesAnnotation(AnnotationPen) | Creates a new instance of LinesAnnotation specifying the outline.
Public method | LinesAnnotation(LinesData) | Creates a new instance of LinesAnnotation specifying the LinesData used by this annotation.
Public method | LinesAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of LinesAnnotation from serialized information.
Public method | LinesAnnotation(AnnotationPen, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline and end points.
Public method | LinesAnnotation(AnnotationPen, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline and an array of end points.
Public method | LinesAnnotation(PointF, AnnotationPen, Boolean) | Creates a new instance of LinesAnnotation specifying the points, outline and translucent properties.
Public method | LinesAnnotation(AnnotationPen, PointFCollection, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline, points and whether this annotation is a highlighter.
Public method | LinesAnnotation(AnnotationPen, PointF, Boolean) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of LinesAnnotation specifying the outline, an array of points and whether this annotation is a highlighter.
Public method | LinesAnnotation(PointFCollection, AnnotationPen, Boolean) | Creates a new instance of LinesAnnotation specifying the point collection, outline and translucent properties.
Top
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor

Creates a new instance of LinesAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotation()
Public Sub New
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (AnnotationPen)

Creates a new instance of LinesAnnotation specifying the outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotation(
    AnnotationPen outline
)
Public Sub New (
    outline As AnnotationPen
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (LinesData)

Creates a new instance of LinesAnnotation specifying the LinesData used by this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotation(
    LinesData data
)
Public Sub New (
    data As LinesData
)

Parameters

data
Type: Atalasoft.AnnotateLinesData
A LinesData object for this annotation.
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LinesAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information containing data for this object.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (AnnotationPen, PointFCollection)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesAnnotation specifying the outline and end points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public LinesAnnotation(
    AnnotationPen outline,
    PointFCollection points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointFCollection
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the line end points.
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (AnnotationPen, PointF[])

LinesAnnotation Constructor (AnnotationPen, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesAnnotation specifying the outline and an array of end points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public LinesAnnotation(
    AnnotationPen outline,
    PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: System.DrawingPointF
An array of end points for the lines. These must be specified in annotation space.
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (PointF[], AnnotationPen, Boolean)

LinesAnnotation Constructor (PointF, AnnotationPen, Boolean)

Creates a new instance of LinesAnnotation specifying the points, outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotation(
    PointF[] points,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointF(),
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: System.DrawingPointF
An array of end points for the lines. These must be specified in annotation space.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
translucent
Type: SystemBoolean
A value indicating whether the lines will be translucent, giving it a highlighter effect.
Exceptions
Exception | Condition
 | Thrown if the points argument is null (Nothing in VB).
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (AnnotationPen, PointFCollection, Boolean)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesAnnotation specifying the outline, points and whether this annotation is a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public LinesAnnotation(
    AnnotationPen outline,
    PointFCollection points,
    bool translucent
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointFCollection,
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the line end points.
translucent
Type: SystemBoolean
A value indicating whether this annotation is a highlighter.
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (AnnotationPen, PointF[], Boolean)

LinesAnnotation Constructor (AnnotationPen, PointF, Boolean)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of LinesAnnotation specifying the outline, an array of points and whether this annotation is a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public LinesAnnotation(
    AnnotationPen outline,
    PointF[] points,
    bool translucent
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    points As PointF(),
    translucent As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
points
Type: System.DrawingPointF
An array of end points for the lines. These must be specified in annotation space.
translucent
Type: SystemBoolean
A value indicating whether this annotation is a highlighter.
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Constructor (PointFCollection, AnnotationPen, Boolean)

Creates a new instance of LinesAnnotation specifying the point collection, outline and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotation(
    PointFCollection points,
    AnnotationPen outline,
    bool translucent
)
Public Sub New (
    points As PointFCollection,
    outline As AnnotationPen,
    translucent As Boolean
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the line end points.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the lines.
translucent
Type: SystemBoolean
A value indicating whether the lines will be translucent, giving it a highlighter effect.
See Also

Reference

LinesAnnotation Class
LinesAnnotation Overload
Atalasoft.Annotate.UI Namespace


LinesAnnotation Properties

The LinesAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets a PointFCollection containing the points for this annotation.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether the line is drawn as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation.Outline Property

LinesAnnotationOutline Property

Gets or sets the outline for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the lines.
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation.Points Property

LinesAnnotationPoints Property

Gets a PointFCollection containing the points for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection Points { get; }
Public ReadOnly Property Points As PointFCollection
    Get

Property Value

Type: PointFCollection
The points for this annotation in annotation space.
Remarks
The LinesAnnotation must have at least two points in the collection.
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation.Translucent Property

LinesAnnotationTranslucent Property

Gets or sets a value indicating whether the line is drawn as a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if this annotation should act as a highlighter.
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument(DocumentRotation, Int32) method.
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation Methods

The LinesAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for this annotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from PointBaseAnnotation.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation.Clone Method

LinesAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation.GetRegion Method

LinesAnnotationGetRegion Method

Returns a region for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace

Return Value

Type: AnnotationRegion
A region for this LinesAnnotation.
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotation Events

The LinesAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

LinesAnnotation Class
Atalasoft.Annotate.UI Namespace


LinesAnnotationFactory Class

This class generates a LinesAnnotation object from a LinesData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UILinesAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class LinesAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class LinesAnnotationFactory
    Implements IAnnotationUIFactory

The LinesAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LinesAnnotationFactory | Creates a new instance of LinesAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a LinesAnnotation if the data object is a LinesData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


LinesAnnotationFactory Constructor

Creates a new instance of LinesAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinesAnnotationFactory()
Public Sub New
See Also

Reference

LinesAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LinesAnnotationFactory Methods

The LinesAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a LinesAnnotation if the data object is a LinesData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinesAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


LinesAnnotationFactory.GetAnnotationUI Method

LinesAnnotationFactoryGetAnnotationUI Method

Returns a LinesAnnotation if the data object is a LinesData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The LinesData object for the annotation.

Return Value

Type: AnnotationUI
A LinesAnnotation or null (Nothing in Visual Basic) if the data parameter is not a LinesData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

LinesAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Class

This annotation is used to select an area of the image to OCR is a separate process.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIOcrRegionAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrRegionAnnotation : AnnotationUI
<SerializableAttribute>
Public Class OcrRegionAnnotation
    Inherits AnnotationUI

The OcrRegionAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | OcrRegionAnnotation | Creates a new instance of OcrRegionAnnotation.
Public method | OcrRegionAnnotation(OcrRegionData) | Creates a new instance of OcrRegionAnnotation from an OcrRegionData object.
Public method | OcrRegionAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of OcrRegionAnnotation from serialization information.
Public method | OcrRegionAnnotation(RectangleF, Int32, Color) | Creates a new instance of OcrRegionAnnotation specifying its bounds, sequence order and color.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | Color | Gets or sets the color to draw OCR region selection.
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | SequenceOrder | Gets or sets the sequence order.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
Remarks
This annotation does not perform OCR, it simply creates a selection for use by another process.
See Also

Reference

Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Constructor

Constructs an OcrRegionAnnotation.
Overload List
 | Name | Description
Public method | OcrRegionAnnotation | Creates a new instance of OcrRegionAnnotation.
Public method | OcrRegionAnnotation(OcrRegionData) | Creates a new instance of OcrRegionAnnotation from an OcrRegionData object.
Public method | OcrRegionAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of OcrRegionAnnotation from serialization information.
Public method | OcrRegionAnnotation(RectangleF, Int32, Color) | Creates a new instance of OcrRegionAnnotation specifying its bounds, sequence order and color.
Top
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Constructor

Creates a new instance of OcrRegionAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionAnnotation()
Public Sub New
See Also

Reference

OcrRegionAnnotation Class
OcrRegionAnnotation Overload
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Constructor (OcrRegionData)

Creates a new instance of OcrRegionAnnotation from an OcrRegionData object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionAnnotation(
    OcrRegionData data
)
Public Sub New (
    data As OcrRegionData
)

Parameters

data
Type: Atalasoft.AnnotateOcrRegionData
The data object for this annotation.
See Also

Reference

OcrRegionAnnotation Class
OcrRegionAnnotation Overload
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of OcrRegionAnnotation from serialization information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

OcrRegionAnnotation Class
OcrRegionAnnotation Overload
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Constructor (RectangleF, Int32, Color)

Creates a new instance of OcrRegionAnnotation specifying its bounds, sequence order and color.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionAnnotation(
    RectangleF bounds,
    int sequenceOrder,
    Color color
)
Public Sub New (
    bounds As RectangleF,
    sequenceOrder As Integer,
    color As Color
)

Parameters

bounds
Type: System.DrawingRectangleF
The selection bounds for the annotation.
sequenceOrder
Type: SystemInt32
The sequence number for the annotation. This must be 1 or greater.
color
Type: System.DrawingColor
The color for this annotation.
Exceptions
Exception | Condition
 | Thrown if the sequenceOrder is less than 1.
See Also

Reference

OcrRegionAnnotation Class
OcrRegionAnnotation Overload
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Properties

The OcrRegionAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | Color | Gets or sets the color to draw OCR region selection.
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | SequenceOrder | Gets or sets the sequence order.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation.Color Property

OcrRegionAnnotationColor Property

Gets or sets the color to draw OCR region selection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color.
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation.HitTestRectangle Property

OcrRegionAnnotationHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF HitTestRectangle { get; }
Public Overrides ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation.SequenceOrder Property

OcrRegionAnnotationSequenceOrder Property

Gets or sets the sequence order.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SequenceOrder { get; set; }
Public Property SequenceOrder As Integer
    Get
    Set

Property Value

Type: Int32
The sequence order.
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Methods

The OcrRegionAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation.Clone Method

OcrRegionAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotation Events

The OcrRegionAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

OcrRegionAnnotation Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotationFactory Class

This class generates a OcrRegionAnnotation object from a OcrRegionData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIOcrRegionAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class OcrRegionAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class OcrRegionAnnotationFactory
    Implements IAnnotationUIFactory

The OcrRegionAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | OcrRegionAnnotationFactory | Creates a new instance of OcrRegionAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a OcrRegionAnnotation if the data object is a OcrRegionData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


OcrRegionAnnotationFactory Constructor

Creates a new instance of OcrRegionAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionAnnotationFactory()
Public Sub New
See Also

Reference

OcrRegionAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotationFactory Methods

The OcrRegionAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a OcrRegionAnnotation if the data object is a OcrRegionData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrRegionAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


OcrRegionAnnotationFactory.GetAnnotationUI Method

OcrRegionAnnotationFactoryGetAnnotationUI Method

Returns a OcrRegionAnnotation if the data object is a OcrRegionData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The OcrRegionData object for the annotation.

Return Value

Type: AnnotationUI
A OcrRegionAnnotation or null (Nothing in Visual Basic) if the data parameter is not a OcrRegionData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

OcrRegionAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PdfAnnotationUIFactory Class

A class for initializing an AnnotationUIFactoryCollection with PDF annotation UI factories.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIPdfAnnotationUIFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class PdfAnnotationUIFactory
Public NotInheritable Class PdfAnnotationUIFactory

The PdfAnnotationUIFactory type exposes the following members.

Methods
Name | Description
Initialize | Initializes a given AnnotationUIFactoryCollection with a default set of PDF annotation UI factories.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


PdfAnnotationUIFactory Methods

The PdfAnnotationUIFactory type exposes the following members.

Methods
Name | Description
Initialize | Initializes a given AnnotationUIFactoryCollection with a default set of PDF annotation UI factories.
Top
See Also

Reference

PdfAnnotationUIFactory Class
Atalasoft.Annotate.UI Namespace


PdfAnnotationUIFactory.Initialize Method

PdfAnnotationUIFactoryInitialize Method

Initializes a given AnnotationUIFactoryCollection with a default set of PDF annotation UI factories.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Initialize(
    AnnotationUIFactoryCollection factoryCollection
)
Public Shared Sub Initialize (
    factoryCollection As AnnotationUIFactoryCollection
)

Parameters

factoryCollection
Type: Atalasoft.Annotate.UIAnnotationUIFactoryCollection
The factory collection to populate.
Remarks
If the given factory collection already has instances of the default PDF annotation UI factory types, they will be preserved, and new ones will not be added.
See Also

Reference

PdfAnnotationUIFactory Class
Atalasoft.Annotate.UI Namespace


PdfLineAnnotationFactory Class

This class is used to generate a PdfLineAnnotation from a PdfLineData object.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIPdfLineAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class PdfLineAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class PdfLineAnnotationFactory
    Implements IAnnotationUIFactory

The PdfLineAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLineAnnotationFactory | Creates a new instance of PdfLineAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a new PdfLineAnnotation from the PdfLineData provided.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


PdfLineAnnotationFactory Constructor

Creates a new instance of PdfLineAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineAnnotationFactory()
Public Sub New
See Also

Reference

PdfLineAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PdfLineAnnotationFactory Methods

The PdfLineAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a new PdfLineAnnotation from the PdfLineData provided.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfLineAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PdfLineAnnotationFactory.GetAnnotationUI Method

PdfLineAnnotationFactoryGetAnnotationUI Method

Returns a new PdfLineAnnotation from the PdfLineData provided.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
A PdfLineData to create the annotation from.

Return Value

Type: AnnotationUI
A new PdfLineAnnotation or null (Nothing in VB) if the data class was not a PdfLineData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

PdfLineAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PdfMarkupAnnotationFactory Class

This class is used to generate a PdfMarkupAnnotation from a PdfMarkupData object.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIPdfMarkupAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class PdfMarkupAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class PdfMarkupAnnotationFactory
    Implements IAnnotationUIFactory

The PdfMarkupAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | PdfMarkupAnnotationFactory | Creates a new instance of PdfMarkupAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a new PdfMarkupAnnotation from a PdfMarkupData object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


PdfMarkupAnnotationFactory Constructor

Creates a new instance of PdfMarkupAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupAnnotationFactory()
Public Sub New
See Also

Reference

PdfMarkupAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PdfMarkupAnnotationFactory Methods

The PdfMarkupAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a new PdfMarkupAnnotation from a PdfMarkupData object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfMarkupAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PdfMarkupAnnotationFactory.GetAnnotationUI Method

PdfMarkupAnnotationFactoryGetAnnotationUI Method

Returns a new PdfMarkupAnnotation from a PdfMarkupData object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The PdfMarkupData to create the annotation from.

Return Value

Type: AnnotationUI
A new PdfMarkupAnnotation or null (Nothing in VB) if the data is not a PdfMarkupData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

PdfMarkupAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Class

This abstract class is used to simplify creating annotations that are defined with multiple points instead of a rectangular structure.
This abstract class is used to simplify creating annotations that are defined with multiple points instead of a rectangular structure.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIPointBaseAnnotation
Atalasoft.Annotate.UIFreehandAnnotation
Atalasoft.Annotate.UIHotSpotFreehandAnnotation
Atalasoft.Annotate.UILinesAnnotation
Atalasoft.Annotate.UIPolygonAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PointBaseAnnotation : AnnotationUI
Public MustInherit Class PointBaseAnnotation
    Inherits AnnotationUI

The PointBaseAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PointBaseAnnotation(PointBaseData) | Creates a new instance of PointBaseAnnotation.
Public method | PointBaseAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PointBaseAnnotation from serialized data.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation.
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Overrides AnnotationUIBeginCreate.)
Public method | Clone | Creates a copy of this annotation. (Inherited from AnnotationUI.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Overrides AnnotationUIGetConfinedLocation(RectangleF, PointF).)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Overrides AnnotationUIGetConfinedRotation(RectangleF, Single).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Overrides AnnotationUIOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Overrides AnnotationUIOnMirror(MirrorDirection, Boolean).)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Overrides AnnotationUIOnResized(EventArgs).)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
Remarks
The PointBaseAnnotation class takes care of most user interaction code required for points based annotations such as the Freehand, Lines and Polygon annotations. Annotations derived from PointBaseAnnotation essentially only need to add custom constructors to function properly.
Remarks
The PointBaseAnnotation class takes care of most user interaction code required for points based annotations such as the Freehand, Lines and Polygon annotations. Annotations derived from PointBaseAnnotation essentially only need to add custom constructors and override the GetRegion method to function properly.
See Also

Reference

Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Constructor

Overload List
 | Name | Description
Public method | PointBaseAnnotation(PointBaseData) | Creates a new instance of PointBaseAnnotation.
Public method | PointBaseAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PointBaseAnnotation from serialized data.
Top
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Constructor (PointBaseData)

Creates a new instance of PointBaseAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointBaseAnnotation(
    PointBaseData data
)
Public Sub New (
    data As PointBaseData
)

Parameters

data
Type: Atalasoft.AnnotatePointBaseData
A PointBaseData object for this annotation.
Remarks
This is an abstract class and cannot be created directly.
See Also

Reference

PointBaseAnnotation Class
PointBaseAnnotation Overload
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PointBaseAnnotation from serialized data.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointBaseAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information about this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PointBaseAnnotation Class
PointBaseAnnotation Overload
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Properties

The PointBaseAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation.
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.FreehandStyle Property

PointBaseAnnotationFreehandStyle Property

Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation.
Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool FreehandStyle { get; set; }
Protected Property FreehandStyle As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the points are added by multiple clicks or by dragging the mouse.

Property Value

Type: Boolean
A value indicating if the points are added by multiple clicks or by dragging the mouse.
Remarks

Setting this property to true will allow the user to create the annotation by dragging the mouse. Points are added as the mouse moves.

To create an annotation where the user must make multiple mouse clicks, one per point, this property should be set to false.

Remarks

Setting this property to true will allow the user to create the annotation by dragging the mouse. Points are added as the mouse moves.

To create an annotation where the user must make multiple mouse clicks, one per point, this property should be set to false.

See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.GripMode Property

PointBaseAnnotationGripMode Property

Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation.
Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGripMode GripMode { get; set; }
Public Property GripMode As AnnotationGripMode
    Get
    Set

Property Value

Type: AnnotationGripMode
A value indicating which type of grips to use for this annotation.

Property Value

Type: AnnotationGripMode
A value indicating which type of grips to use for this annotation.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Methods

The PointBaseAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Overrides AnnotationUIBeginCreate.)
Public method | Clone | Creates a copy of this annotation. (Inherited from AnnotationUI.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Overrides AnnotationUIGetConfinedLocation(RectangleF, PointF).)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Overrides AnnotationUIGetConfinedRotation(RectangleF, Single).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Overrides AnnotationUIOnAnnotationControllerNotification(AnnotationControllerNotificationEventArgs).)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Overrides AnnotationUIOnGripPositionChanged(AnnotationGripChangedEventArgs).)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Overrides AnnotationUIOnMirror(MirrorDirection, Boolean).)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Overrides AnnotationUIOnMouseDown(AnnotationMouseEventArgs).)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Overrides AnnotationUIOnMouseMove(AnnotationMouseEventArgs).)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Overrides AnnotationUIOnResized(EventArgs).)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.BeginCreate Method

PointBaseAnnotationBeginCreate Method

This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void BeginCreate()
Public Overrides Sub BeginCreate
Remarks
Use this method to prepare the annotation for creation by receiving the OnMouseDown(AnnotationMouseEventArgs), OnMouseMove(AnnotationMouseEventArgs) and OnMouseUp(AnnotationMouseEventArgs) method calls.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.GetConfinedLocation Method

PointBaseAnnotationGetConfinedLocation Method

These methods are used by the AnnotationController to handle annotation confinement.
Overload List
 | Name | Description
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Overrides AnnotationUIGetConfinedLocation(RectangleF, PointF).)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Top
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.GetConfinedLocation Method (RectangleF, PointF)

PointBaseAnnotationGetConfinedLocation Method (RectangleF, PointF)

Returns the new confined location of the annotation when a confinement bounds and new location offset are provided.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PointF GetConfinedLocation(
    RectangleF dsConfinedBounds,
    PointF dsLocationOffset
)
Public Overrides Function GetConfinedLocation (
    dsConfinedBounds As RectangleF,
    dsLocationOffset As PointF
) As PointF

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
The bounding rectangle in document space for the confinement.
dsLocationOffset
Type: System.DrawingPointF
The difference between the current and suggested new location of the annotation in document space units.

Return Value

Type: PointF
See Also

Reference

PointBaseAnnotation Class
GetConfinedLocation Overload
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.GetConfinedRotation Method

PointBaseAnnotationGetConfinedRotation Method

Gets the confined rotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override float GetConfinedRotation(
    RectangleF dsConfinedBounds,
    float newAngle
)
Public Overrides Function GetConfinedRotation (
    dsConfinedBounds As RectangleF,
    newAngle As Single
) As Single

Parameters

dsConfinedBounds
Type: System.DrawingRectangleF
The ds confined bounds.
newAngle
Type: SystemSingle
The new angle.

Return Value

Type: Single
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.GetObjectData Method

PointBaseAnnotationGetObjectData Method

Fills a SerializationInfo object with information about this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnAnnotationControllerNotification Method

PointBaseAnnotationOnAnnotationControllerNotification Method

Called after a property of the annotation or related AnnotationData has been modified.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationControllerNotification(
    AnnotationControllerNotificationEventArgs e
)
Protected Overrides Sub OnAnnotationControllerNotification (
    e As AnnotationControllerNotificationEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationControllerNotificationEventArgs
An AnnotationControllerNotificationEventArgs containing information on this changed.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnGripPositionChanged Method

PointBaseAnnotationOnGripPositionChanged Method

Called when a grip of the annotation has been moved by the user using the mouse.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    AnnotationGripChangedEventArgs e
)
Protected Overrides Sub OnGripPositionChanged (
    e As AnnotationGripChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationGripChangedEventArgs
An AnnotationGripChangedEventArgs containing information about this event.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnMirror Method

PointBaseAnnotationOnMirror Method

Called when the grips of an annotation have been dragged past the opposite grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMirror(
    MirrorDirection direction,
    bool maintainPosition
)
Protected Overrides Sub OnMirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The direction in which the annotation should be mirrored.
maintainPosition
Type: SystemBoolean
Determines whether the mirror is performed in place or if the annotation pivots along its location.
Remarks
This method will only be called if the CanMirror property of the annotation is true.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnMouseDown Method

PointBaseAnnotationOnMouseDown Method

Called when the user clicks down on the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnMouseMove Method

PointBaseAnnotationOnMouseMove Method

Called when the user has moved the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    AnnotationMouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As AnnotationMouseEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnMouseUp Method

PointBaseAnnotationOnMouseUp Method

Called when the user has released the mouse over the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs
An AnnotationMouseEventArgs containing information about this event.

Return Value

Type: Boolean
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnMoving Method

PointBaseAnnotationOnMoving Method

Called while an annotation is being moved by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
An AnnotationLocationChangedEventArgs containing information about this event.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation.OnResized Method

PointBaseAnnotationOnResized Method

Called when a resize on the annotation has completed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResized(
    EventArgs e
)
Protected Overrides Sub OnResized (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointBaseAnnotation Events

The PointBaseAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

PointBaseAnnotation Class
Atalasoft.Annotate.UI Namespace


PointGrips Class

PointGrips is the base class implementation used for annotation grips. All annotations in DotImage use PointGrips or RectangleGrips, which derives from PointGrips.

In essence, PointGrips is a collection of AnnotationGrip objects.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIPointGrips
Atalasoft.Annotate.UIRectangleGrips

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PointGrips : IAnnotationGrips
Public Class PointGrips
    Implements IAnnotationGrips

The PointGrips type exposes the following members.

Constructors
 | Name | Description
Public method | PointGrips | Creates a new instance of PointGrips.
Public method | PointGrips(PointF) | Creates a new instance of PointGrips specifying an array of points.
Public method | PointGrips(AnnotationGrip) | Creates a new instance of PointGrips specifying an array of AnnotationGrip objects.
Top
Properties
 | Name | Description
Public property | Bounds | Returns a bounding rectangle for all of the grips.
Public property | Count | Returns the number of grips in the collection.
Public property | Fill |
Public property | Item |
Public property | Outline |
Public property | RotationFill |
Public property | RotationOutline |
Public property | Size |
Top
Methods
 | Name | Description
Public method | Add | Adds an AnnotationGrip to the collection.
Public method | AddRange | Adds an array of AnnotationGrip objects to the collection.
Public method | Clear | Clears the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator for this grip collection.
Public method | GetGripBounds | Returns a bounding rectangle for a single grip.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRegion | Returns a region for the grips.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GripFromPoint | Returns the AnnotationGrip located at a specified point.
Public method | IndexOf | Returns the index of a grip within the collection.
Public method | Insert | Inserts an AnnotationGrip object into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffsetPoints | Applies an offset to all of the grip positions.
Public method | Remove | Removes a grip from the collection.
Public method | RemoveAt | Removes a grip at the specified index from the collection.
Public method | Replace | Replaces a grip in the collection with another one.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


PointGrips Constructor

Constructs a PointGrips.
Overload List
 | Name | Description
Public method | PointGrips | Creates a new instance of PointGrips.
Public method | PointGrips(PointF) | Creates a new instance of PointGrips specifying an array of points.
Public method | PointGrips(AnnotationGrip) | Creates a new instance of PointGrips specifying an array of AnnotationGrip objects.
Top
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips Constructor

Creates a new instance of PointGrips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointGrips()
Public Sub New
See Also

Reference

PointGrips Class
PointGrips Overload
Atalasoft.Annotate.UI Namespace


PointGrips Constructor (PointF[])

PointGrips Constructor (PointF)

Creates a new instance of PointGrips specifying an array of points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointGrips(
    PointF[] points
)
Public Sub New (
    points As PointF()
)

Parameters

points
Type: System.DrawingPointF
An array of points that will be used to generate AnnotationGrip objects which are then added to the collection.
See Also

Reference

PointGrips Class
PointGrips Overload
Atalasoft.Annotate.UI Namespace


PointGrips Constructor (AnnotationGrip[])

PointGrips Constructor (AnnotationGrip)

Creates a new instance of PointGrips specifying an array of AnnotationGrip objects.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointGrips(
    AnnotationGrip[] grips
)
Public Sub New (
    grips As AnnotationGrip()
)

Parameters

grips
Type: Atalasoft.Annotate.UIAnnotationGrip
An array of AnnotationGrip objects to add to the collection.
See Also

Reference

PointGrips Class
PointGrips Overload
Atalasoft.Annotate.UI Namespace


PointGrips Properties

The PointGrips type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Returns a bounding rectangle for all of the grips.
Public property | Count | Returns the number of grips in the collection.
Public property | Fill |
Public property | Item |
Public property | Outline |
Public property | RotationFill |
Public property | RotationOutline |
Public property | Size |
Top
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Bounds Property

PointGripsBounds Property

Returns a bounding rectangle for all of the grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Bounds { get; }
Public ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
A bounding rectangle for the grips.
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Count Property

PointGripsCount Property

Returns the number of grips in the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of grips in the collection.

Implements

IAnnotationGripsCount
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Fill Property

PointGripsFill Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush

Implements

IAnnotationGripsFill
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Item Property

PointGripsItem Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGrip this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As AnnotationGrip
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: AnnotationGrip

Implements

IAnnotationGripsItemInt32
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Outline Property

PointGripsOutline Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen

Implements

IAnnotationGripsOutline
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.RotationFill Property

PointGripsRotationFill Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush RotationFill { get; set; }
Public Property RotationFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush

Implements

IAnnotationGripsRotationFill
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.RotationOutline Property

PointGripsRotationOutline Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen RotationOutline { get; set; }
Public Property RotationOutline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen

Implements

IAnnotationGripsRotationOutline
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Size Property

PointGripsSize Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF Size { get; set; }
Public Property Size As SizeF
    Get
    Set

Property Value

Type: SizeF

Implements

IAnnotationGripsSize
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips Methods

The PointGrips type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an AnnotationGrip to the collection.
Public method | AddRange | Adds an array of AnnotationGrip objects to the collection.
Public method | Clear | Clears the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator for this grip collection.
Public method | GetGripBounds | Returns a bounding rectangle for a single grip.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRegion | Returns a region for the grips.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GripFromPoint | Returns the AnnotationGrip located at a specified point.
Public method | IndexOf | Returns the index of a grip within the collection.
Public method | Insert | Inserts an AnnotationGrip object into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffsetPoints | Applies an offset to all of the grip positions.
Public method | Remove | Removes a grip from the collection.
Public method | RemoveAt | Removes a grip at the specified index from the collection.
Public method | Replace | Replaces a grip in the collection with another one.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Add Method

PointGripsAdd Method

Adds an AnnotationGrip to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AnnotationGrip grip
)
Public Sub Add (
    grip As AnnotationGrip
)

Parameters

grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The AnnotationGrip to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the grip argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.AddRange Method

PointGripsAddRange Method

Adds an array of AnnotationGrip objects to the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    AnnotationGrip[] grips
)
Public Sub AddRange (
    grips As AnnotationGrip()
)

Parameters

grips
Type: Atalasoft.Annotate.UIAnnotationGrip
An array of AnnotationGrip objects to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the grips argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Clear Method

PointGripsClear Method

Clears the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.GetEnumerator Method

PointGripsGetEnumerator Method

Returns an IEnumerator for this grip collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator for the collection.

Implements

IAnnotationGripsGetEnumerator
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.GetGripBounds Method

PointGripsGetGripBounds Method

Returns a bounding rectangle for a single grip.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF GetGripBounds(
    AnnotationGrip grip
)
Public Function GetGripBounds (
    grip As AnnotationGrip
) As RectangleF

Parameters

grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The grip to get bounds from.

Return Value

Type: RectangleF
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the grip argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.GetRegion Method

PointGripsGetRegion Method

Returns a region for the grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRegion GetRegion()
Public Function GetRegion As AnnotationRegion

Return Value

Type: AnnotationRegion
A region for the annotation grips.

Implements

IAnnotationGripsGetRegion
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.GripFromPoint Method

PointGripsGripFromPoint Method

Returns the AnnotationGrip located at a specified point.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGrip GripFromPoint(
    PointF point
)
Public Function GripFromPoint (
    point As PointF
) As AnnotationGrip

Parameters

point
Type: System.DrawingPointF
The point to search for a grip.

Return Value

Type: AnnotationGrip
The AnnotationGrip found at the specified point or null (Nothing in Visual Basic) if no grip exists at that point.

Implements

IAnnotationGripsGripFromPoint(PointF)
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.IndexOf Method

PointGripsIndexOf Method

Returns the index of a grip within the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    AnnotationGrip grip
)
Public Function IndexOf (
    grip As AnnotationGrip
) As Integer

Parameters

grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The grip to search for.

Return Value

Type: Int32
The index of the grip or -1 if the grip was not found in the collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the grip argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Insert Method

PointGripsInsert Method

Inserts an AnnotationGrip object into the collection at the specified index.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AnnotationGrip grip
)
Public Sub Insert (
    index As Integer,
    grip As AnnotationGrip
)

Parameters

index
Type: SystemInt32
The index where the grip will be placed.
grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The AnnotationGrip object to add.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index value is out of range for this collection.
ArgumentNullException | Thrown if the grip argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.OffsetPoints Method

PointGripsOffsetPoints Method

Applies an offset to all of the grip positions.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OffsetPoints(
    float x,
    float y
)
Public Sub OffsetPoints (
    x As Single,
    y As Single
)

Parameters

x
Type: SystemSingle
The amount to offset the grip positions in the x-axis.
y
Type: SystemSingle
The amount to offset the grip position in the y-axis.
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Remove Method

PointGripsRemove Method

Removes a grip from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AnnotationGrip grip
)
Public Sub Remove (
    grip As AnnotationGrip
)

Parameters

grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The grip to remove.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the grip argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.RemoveAt Method

PointGripsRemoveAt Method

Removes a grip at the specified index from the collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the grip to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index argument is out of range for this collection.
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PointGrips.Replace Method

PointGripsReplace Method

Replaces a grip in the collection with another one.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    int index,
    AnnotationGrip newGrip
)
Public Sub Replace (
    index As Integer,
    newGrip As AnnotationGrip
)

Parameters

index
Type: SystemInt32
The index of the grip to replace.
newGrip
Type: Atalasoft.Annotate.UIAnnotationGrip
The new grip that will be used.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index argument is out of range for this collection.
ArgumentNullException | Thrown if the newGrip argument is null (Nothing in VB).
See Also

Reference

PointGrips Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Class

A PolygonAnnotation is a series of points used to draw a polygon with an optional fill.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIPointBaseAnnotation
Atalasoft.Annotate.UIPolygonAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PolygonAnnotation : PointBaseAnnotation
<SerializableAttribute>
Public Class PolygonAnnotation
    Inherits PointBaseAnnotation

The PolygonAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PolygonAnnotation | Creates a new instance of PolygonAnnotation.
Public method | PolygonAnnotation(PolygonData) | Creates a new instance of PolygonAnnotation specifying the PolygonData for this annotation.
Public method | PolygonAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PolygonAnnotation from serialization information.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush) | Creates a new instance of PolygonAnnotation specifying the outline and fill.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill and points collection.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill and an array of points.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, AnnotationBrush, PointF) | Creates a new instance of PolygonAnnotation specifying the outline, fill and shadow settings.
Public method | PolygonAnnotation(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonAnnotation specifying its fill, outline, shadow, shadow offset and translucent properties.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill, shadow settings and points of the polygon.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill, shadow settings and array of points for the polygon.
Public method | PolygonAnnotation(PointF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonAnnotation specifying the points, fill, outline, shadow, shadow offset and translucent properties.
Public method | PolygonAnnotation(PointFCollection, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonAnnotation specifying the point collection, fill, outline, shadow, shadow offset and translucent properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill for the annotation.
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets a PointFCollection containing the points for this polygon in annotation space.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used for the drop shadow.
Public property | ShadowOffset | Gets or sets the drop shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for the PolygonAnnotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from PointBaseAnnotation.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
Remarks

To generate a polygon, the user clicks the left mouse button to set each point. The user can stop adding points by clicking the right mouse button.

A polygon requires at least three points in the Points collection.

See Also

Reference

Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor

Constructs a PolygonAnnotation.
Overload List
 | Name | Description
Public method | PolygonAnnotation | Creates a new instance of PolygonAnnotation.
Public method | PolygonAnnotation(PolygonData) | Creates a new instance of PolygonAnnotation specifying the PolygonData for this annotation.
Public method | PolygonAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of PolygonAnnotation from serialization information.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush) | Creates a new instance of PolygonAnnotation specifying the outline and fill.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill and points collection.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill and an array of points.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, AnnotationBrush, PointF) | Creates a new instance of PolygonAnnotation specifying the outline, fill and shadow settings.
Public method | PolygonAnnotation(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonAnnotation specifying its fill, outline, shadow, shadow offset and translucent properties.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointFCollection) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill, shadow settings and points of the polygon.
Public method | PolygonAnnotation(AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointF) | Obsolete. This overload is obsolete and may be removed in a future release. Creates a new instance of PolygonAnnotation specifying the outline, fill, shadow settings and array of points for the polygon.
Public method | PolygonAnnotation(PointF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonAnnotation specifying the points, fill, outline, shadow, shadow offset and translucent properties.
Public method | PolygonAnnotation(PointFCollection, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean) | Creates a new instance of PolygonAnnotation specifying the point collection, fill, outline, shadow, shadow offset and translucent properties.
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor

Creates a new instance of PolygonAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation()
Public Sub New
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (PolygonData)

Creates a new instance of PolygonAnnotation specifying the PolygonData for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    PolygonData data
)
Public Sub New (
    data As PolygonData
)

Parameters

data
Type: Atalasoft.AnnotatePolygonData
The PolygonData for this annotation.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PolygonAnnotation from serialization information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about the annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush)

Creates a new instance of PolygonAnnotation specifying the outline and fill.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill
)
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, PointFCollection)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonAnnotation specifying the outline, fill and points collection.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public PolygonAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill,
    PointFCollection points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush,
    points As PointFCollection
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the initial points for the polygon in annotation space.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, PointF[])

PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonAnnotation specifying the outline, fill and an array of points.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public PolygonAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill,
    PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush,
    points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
points
Type: System.DrawingPointF
An array of PointF objects specifying the initial points of the polygon in annotation space.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, AnnotationBrush, PointF)

Creates a new instance of PolygonAnnotation specifying the outline, fill and shadow settings.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

Creates a new instance of PolygonAnnotation specifying its fill, outline, shadow, shadow offset and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
translucent
Type: SystemBoolean
A value indicating whether the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointFCollection)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonAnnotation specifying the outline, fill, shadow settings and points of the polygon.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)]
public PolygonAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill,
    AnnotationBrush shadow,
    PointF shadowOffset,
    PointFCollection points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointFCollection as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    points As PointFCollection
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the initial points for the polygon in annotation space.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointF[])

PolygonAnnotation Constructor (AnnotationPen, AnnotationBrush, AnnotationBrush, PointF, PointF)

Note: This API is now obsolete.

This overload is obsolete and may be removed in a future release.

Creates a new instance of PolygonAnnotation specifying the outline, fill, shadow settings and array of points for the polygon.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)]
public PolygonAnnotation(
    AnnotationPen outline,
    AnnotationBrush fill,
    AnnotationBrush shadow,
    PointF shadowOffset,
    PointF[] points
)
<ObsoleteAttribute("This constructor may be removed in a future release. Please use the constructor which takes a PointF array as its first argument.",
    false)>
Public Sub New (
    outline As AnnotationPen,
    fill As AnnotationBrush,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    points As PointF()
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
points
Type: System.DrawingPointF
An array of PointF objects specifying the initial points of the polygon in annotation space.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (PointF[], AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

PolygonAnnotation Constructor (PointF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

Creates a new instance of PolygonAnnotation specifying the points, fill, outline, shadow, shadow offset and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    PointF[] points,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent
)
Public Sub New (
    points As PointF(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean
)

Parameters

points
Type: System.DrawingPointF
An array of PointF objects specifying the initial points of the polygon in annotation space.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
translucent
Type: SystemBoolean
A value indicating whether the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Constructor (PointFCollection, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, Boolean)

Creates a new instance of PolygonAnnotation specifying the point collection, fill, outline, shadow, shadow offset and translucent properties.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    PointFCollection points,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    bool translucent
)
Public Sub New (
    points As PointFCollection,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    translucent As Boolean
)

Parameters

points
Type: Atalasoft.AnnotatePointFCollection
A PointFCollection containing the initial points for the polygon in annotation space.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to draw the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for a drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
translucent
Type: SystemBoolean
A value indicating whether the annotation will be translucent, giving it a highlighter effect.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Properties

The PolygonAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Overrides AnnotationUIBounds.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill for the annotation.
Protected property | FreehandStyle | Gets or sets a value indicating whether this annotation should create in the same style as a FreehandAnnotation. (Inherited from PointBaseAnnotation.)
Public property | GripMode | Gets or sets whether a RectangleGrips or PointGrips object is used for this annotation. (Inherited from PointBaseAnnotation.)
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline for the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Points | Gets a PointFCollection containing the points for this polygon in annotation space.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used for the drop shadow.
Public property | ShadowOffset | Gets or sets the drop shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Bounds Property

PolygonAnnotationBounds Property

Gets the bounding rectangle for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF Bounds { get; }
Public Overrides ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
The bounding rectangle for the annotation.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Fill Property

PolygonAnnotationFill Property

Gets or sets the fill for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill for the annotation.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Outline Property

PolygonAnnotationOutline Property

Gets or sets the outline for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The outline of the annotation.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Points Property

PolygonAnnotationPoints Property

Gets a PointFCollection containing the points for this polygon in annotation space.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFCollection Points { get; }
Public ReadOnly Property Points As PointFCollection
    Get

Property Value

Type: PointFCollection
The points used by this annotation.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Shadow Property

PolygonAnnotationShadow Property

Gets or sets the AnnotationBrush used for the drop shadow.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The fill for the drop shadow.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.ShadowOffset Property

PolygonAnnotationShadowOffset Property

Gets or sets the drop shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset specifying the position of the drop shadow.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Translucent Property

PolygonAnnotationTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument(DocumentRotation, Int32) method.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Methods

The PolygonAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from PointBaseAnnotation.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from PointBaseAnnotation.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from PointBaseAnnotation.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from PointBaseAnnotation.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
Public method | GetRegion | Returns a region for the PolygonAnnotation. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from PointBaseAnnotation.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from PointBaseAnnotation.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from PointBaseAnnotation.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from PointBaseAnnotation.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from PointBaseAnnotation.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.Clone Method

PolygonAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation.GetRegion Method

PolygonAnnotationGetRegion Method

Returns a region for the PolygonAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace

Return Value

Type: AnnotationRegion
The region for this annotation.
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotation Events

The PolygonAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotationFactory Class

This class generates a PolygonAnnotation object from a PolygonData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIPolygonAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class PolygonAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class PolygonAnnotationFactory
    Implements IAnnotationUIFactory

The PolygonAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | PolygonAnnotationFactory | Creates a new instance of PolygonAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a PolygonAnnotation if the data object is a PolygonData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


PolygonAnnotationFactory Constructor

Creates a new instance of PolygonAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotationFactory()
Public Sub New
See Also

Reference

PolygonAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotationFactory Methods

The PolygonAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a PolygonAnnotation if the data object is a PolygonData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolygonAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


PolygonAnnotationFactory.GetAnnotationUI Method

PolygonAnnotationFactoryGetAnnotationUI Method

Returns a PolygonAnnotation if the data object is a PolygonData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The PolygonData object for the annotation.

Return Value

Type: AnnotationUI
A PolygonAnnotation or null (Nothing in Visual Basic) if the data parameter is not a PolygonData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

PolygonAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Class

This is a rectangular annotation with an optional shadow brush.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIRectangleAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RectangleAnnotation : AnnotationUI
<SerializableAttribute>
Public Class RectangleAnnotation
    Inherits AnnotationUI

The RectangleAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleAnnotation | Creates a new instance of RectangleAnnotation.
Public method | RectangleAnnotation(RectangleData) | Creates a new instance of RectangleAnnotation specifying the RectangleData.
Public method | RectangleAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of RectangleAnnotation from serialized data.
Public method | RectangleAnnotation(AnnotationBrush, AnnotationPen) | Creates a new instance of RectangleAnnotation specifying the fill and outline.
Public method | RectangleAnnotation(RectangleF, AnnotationBrush, AnnotationPen) | Creates a new instance of RectangleAnnotation specifying the rectangle, fill and outline.
Public method | RectangleAnnotation(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of RectangleAnnotation specifying the fill, outline and shadow options.
Public method | RectangleAnnotation(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of RectangleAnnotation specifying the rectangle, fill, outline and shadow options.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor

Constructs a RectangleAnnotation.
Overload List
 | Name | Description
Public method | RectangleAnnotation | Creates a new instance of RectangleAnnotation.
Public method | RectangleAnnotation(RectangleData) | Creates a new instance of RectangleAnnotation specifying the RectangleData.
Public method | RectangleAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of RectangleAnnotation from serialized data.
Public method | RectangleAnnotation(AnnotationBrush, AnnotationPen) | Creates a new instance of RectangleAnnotation specifying the fill and outline.
Public method | RectangleAnnotation(RectangleF, AnnotationBrush, AnnotationPen) | Creates a new instance of RectangleAnnotation specifying the rectangle, fill and outline.
Public method | RectangleAnnotation(AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of RectangleAnnotation specifying the fill, outline and shadow options.
Public method | RectangleAnnotation(RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF) | Creates a new instance of RectangleAnnotation specifying the rectangle, fill, outline and shadow options.
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor

Creates a new instance of RectangleAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation()
Public Sub New
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor (RectangleData)

Creates a new instance of RectangleAnnotation specifying the RectangleData.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    RectangleData data
)
Public Sub New (
    data As RectangleData
)

Parameters

data
Type: Atalasoft.AnnotateRectangleData
The RectangleData for this annotation.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RectangleAnnotation from serialized data.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the information for this annotation.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor (AnnotationBrush, AnnotationPen)

Creates a new instance of RectangleAnnotation specifying the fill and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill used for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline used for the annotation.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor (RectangleF, AnnotationBrush, AnnotationPen)

Creates a new instance of RectangleAnnotation specifying the rectangle, fill and outline.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for this annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for this annotation.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor (AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of RectangleAnnotation specifying the fill, outline and shadow options.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The shadow brush for the annotation.
shadowOffset
Type: System.DrawingPointF
The offset used for the shadow.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Constructor (RectangleF, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF)

Creates a new instance of RectangleAnnotation specifying the rectangle, fill, outline and shadow options.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    RectangleF rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    rectangle As RectangleF,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

rectangle
Type: System.DrawingRectangleF
The rectangle for the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The shadow brush for the annotation.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Properties

The RectangleAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Inherited from AnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Translucent | Gets or sets a value indicating whether this annotation is used as a highlighter.
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.Fill Property

RectangleAnnotationFill Property

Gets or sets the fill used for the annotation.
Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.Outline Property

RectangleAnnotationOutline Property

Gets or sets the outline of the annotation.
Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.Shadow Property

RectangleAnnotationShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.
Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.ShadowOffset Property

RectangleAnnotationShadowOffset Property

Gets or sets the shadow offset.
Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.Translucent Property

RectangleAnnotationTranslucent Property

Gets or sets a value indicating whether this annotation is used as a highlighter.
Gets or sets a value indicating whether this annotation is used as a highlighter.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Translucent { get; set; }
Public Property Translucent As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.

Property Value

Type: Boolean
A value indicating whether this annotation is used as a highlighter.
Remarks
Setting Translucent to true will disable rotation for the annotation. This also affects the behavior of the RotateDocument(DocumentRotation, Int32) method.
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Methods

The RectangleAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Inherited from AnnotationUI.)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.Clone Method

RectangleAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation.GetRegion Method

RectangleAnnotationGetRegion Method

Returns a rectangular region for this annotation, including its grips if selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
The space coordinate system used to generate this region.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.
Examples
The following is an example of how a custom annotation may override the GetRegion method.
GetRegionCS
Copy
public override AnnotationRegion GetRegion(AnnotateSpace space)
{
Create the region in annotation space.
AnnotationRegion reg = new AnnotationRegion(new RectangleF(PointF.Empty, _data.Size));
if (this.Selected && this.Grips != null)
AddGripsToRegion(reg);
ApplyRegionTransform(reg, space);
return reg;
}
GetRegionVB
Copy
Public Overrides Function GetRegion(ByVal space As AnnotateSpace) As AnnotationRegion
' Create the region in annotation space.
Dim reg As AnnotationRegion =  New AnnotationRegion(New RectangleF(PointF.Empty,_data.Size))
If Not Me.Selected And Me.Grips Is Nothing Then
AddGripsToRegion(reg)
End If
ApplyRegionTransform(reg, space)
Return reg
End Function
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotation Events

The RectangleAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotationFactory Class

This class generates a RectangleAnnotation object from a RectangleData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIRectangleAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class RectangleAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class RectangleAnnotationFactory
    Implements IAnnotationUIFactory

The RectangleAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleAnnotationFactory | Creates a new instance of RectangleAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a RectangleAnnotation if the data object is a RectangleData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


RectangleAnnotationFactory Constructor

Creates a new instance of RectangleAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotationFactory()
Public Sub New
See Also

Reference

RectangleAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotationFactory Methods

The RectangleAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a RectangleAnnotation if the data object is a RectangleData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RectangleAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RectangleAnnotationFactory.GetAnnotationUI Method

RectangleAnnotationFactoryGetAnnotationUI Method

Returns a RectangleAnnotation if the data object is a RectangleData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The RectangleData object for the annotation.

Return Value

Type: AnnotationUI
A RectangleAnnotation or null (Nothing in Visual Basic) if the data parameter is not a RectangleData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

RectangleAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RectangleGrips Class

This class represents a group of AnnotationGrip objects for rectangular shaped annotations.
This class represents a group of AnnotationGrip objects for rectangular shaped annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIPointGrips
Atalasoft.Annotate.UIRectangleGrips

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RectangleGrips : PointGrips
Public Class RectangleGrips
    Inherits PointGrips

The RectangleGrips type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleGrips | Creates a new instance of RectangleGrips.
Public method | RectangleGrips(RectangleGripDisplay) | Creates a new instance of RectangleGrips specifying the grips to display.
Top
Properties
 | Name | Description
Public property | AspectRatio | Gets or sets a value used for the width-to-height ratio.
Public property | Bounds | Returns a bounding rectangle for all of the grips. (Inherited from PointGrips.)
Public property | Count | Returns the number of grips in the collection. (Inherited from PointGrips.)
Public property | Fill | (Inherited from PointGrips.)
Public property | GripsToDisplay | Gets or sets the grips to display.
Public property | Item | (Inherited from PointGrips.)
Public property | Outline | (Inherited from PointGrips.)
Public property | Rectangle | Gets the bounding rectangle of the grips.
Public property | RotationFill | (Inherited from PointGrips.)
Public property | RotationOutline | (Inherited from PointGrips.)
Public property | ShowRotationGrips | Gets or sets a value indicating whether rotation grips are displayed.
Public property | Size | (Inherited from PointGrips.)
Top
Methods
 | Name | Description
Public method | Add | Adds an AnnotationGrip to the collection. (Inherited from PointGrips.)
Public method | AddRange | Adds an array of AnnotationGrip objects to the collection. (Inherited from PointGrips.)
Public method | Clear | Clears the collection. (Inherited from PointGrips.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator for this grip collection. (Inherited from PointGrips.)
Public method | GetGripBounds | Returns a bounding rectangle for a single grip. (Inherited from PointGrips.)
Public method | GetGripDefinition | Returns which rectangle grip the AnnotationGrip object represents.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRegion | Returns a region for the grips. (Inherited from PointGrips.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GripFromPoint | Returns the AnnotationGrip located at a specified point. (Inherited from PointGrips.)
Public method | IndexOf | Returns the index of a grip within the collection. (Inherited from PointGrips.)
Public method | Insert | Inserts an AnnotationGrip object into the collection at the specified index. (Inherited from PointGrips.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffsetPoints | Applies an offset to all of the grip positions. (Inherited from PointGrips.)
Public method | Remove | Removes a grip from the collection. (Inherited from PointGrips.)
Public method | RemoveAt | Removes a grip at the specified index from the collection. (Inherited from PointGrips.)
Public method | Replace | Replaces a grip in the collection with another one. (Inherited from PointGrips.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePositions | Forces the grips to reset their positions based on a bounding rectangle.
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


RectangleGrips Constructor

Constructs a RectangleGrips.
Overload List
 | Name | Description
Public method | RectangleGrips | Creates a new instance of RectangleGrips.
Public method | RectangleGrips(RectangleGripDisplay) | Creates a new instance of RectangleGrips specifying the grips to display.
Top
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips Constructor

Creates a new instance of RectangleGrips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleGrips()
Public Sub New
See Also

Reference

RectangleGrips Class
RectangleGrips Overload
Atalasoft.Annotate.UI Namespace


RectangleGrips Constructor (RectangleGripDisplay)

Creates a new instance of RectangleGrips specifying the grips to display.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleGrips(
    RectangleGripDisplay gripsToDisplay
)
Public Sub New (
    gripsToDisplay As RectangleGripDisplay
)

Parameters

gripsToDisplay
Type: Atalasoft.AnnotateRectangleGripDisplay
The grips to display.
See Also

Reference

RectangleGrips Class
RectangleGrips Overload
Atalasoft.Annotate.UI Namespace


RectangleGrips Properties

The RectangleGrips type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets or sets a value used for the width-to-height ratio.
Public property | Bounds | Returns a bounding rectangle for all of the grips. (Inherited from PointGrips.)
Public property | Count | Returns the number of grips in the collection. (Inherited from PointGrips.)
Public property | Fill | (Inherited from PointGrips.)
Public property | GripsToDisplay | Gets or sets the grips to display.
Public property | Item | (Inherited from PointGrips.)
Public property | Outline | (Inherited from PointGrips.)
Public property | Rectangle | Gets the bounding rectangle of the grips.
Public property | RotationFill | (Inherited from PointGrips.)
Public property | RotationOutline | (Inherited from PointGrips.)
Public property | ShowRotationGrips | Gets or sets a value indicating whether rotation grips are displayed.
Public property | Size | (Inherited from PointGrips.)
Top
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips.AspectRatio Property

RectangleGripsAspectRatio Property

Gets or sets a value used for the width-to-height ratio.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float AspectRatio { get; set; }
Public Property AspectRatio As Single
    Get
    Set

Property Value

Type: Single
The width-to-height ratio for the annotation. A value of zero will disable this feature.
Remarks
Use this property to force annotation resizing to maintain a specific aspect ratio. The height of the annotation is calculated by multiplying the annotation width by this aspect ratio value.
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips.GripsToDisplay Property

RectangleGripsGripsToDisplay Property

Gets or sets the grips to display.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleGripDisplay GripsToDisplay { get; set; }
Public Property GripsToDisplay As RectangleGripDisplay
    Get
    Set

Property Value

Type: RectangleGripDisplay
The grips to display.
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips.Rectangle Property

RectangleGripsRectangle Property

Gets the bounding rectangle of the grips.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Rectangle { get; }
Public ReadOnly Property Rectangle As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips.ShowRotationGrips Property

RectangleGripsShowRotationGrips Property

Gets or sets a value indicating whether rotation grips are displayed.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowRotationGrips { get; set; }
Public Property ShowRotationGrips As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether rotation grips are displayed.
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips Methods

The RectangleGrips type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an AnnotationGrip to the collection. (Inherited from PointGrips.)
Public method | AddRange | Adds an array of AnnotationGrip objects to the collection. (Inherited from PointGrips.)
Public method | Clear | Clears the collection. (Inherited from PointGrips.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator for this grip collection. (Inherited from PointGrips.)
Public method | GetGripBounds | Returns a bounding rectangle for a single grip. (Inherited from PointGrips.)
Public method | GetGripDefinition | Returns which rectangle grip the AnnotationGrip object represents.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRegion | Returns a region for the grips. (Inherited from PointGrips.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GripFromPoint | Returns the AnnotationGrip located at a specified point. (Inherited from PointGrips.)
Public method | IndexOf | Returns the index of a grip within the collection. (Inherited from PointGrips.)
Public method | Insert | Inserts an AnnotationGrip object into the collection at the specified index. (Inherited from PointGrips.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffsetPoints | Applies an offset to all of the grip positions. (Inherited from PointGrips.)
Public method | Remove | Removes a grip from the collection. (Inherited from PointGrips.)
Public method | RemoveAt | Removes a grip at the specified index from the collection. (Inherited from PointGrips.)
Public method | Replace | Replaces a grip in the collection with another one. (Inherited from PointGrips.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePositions | Forces the grips to reset their positions based on a bounding rectangle.
Top
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips.GetGripDefinition Method

RectangleGripsGetGripDefinition Method

Returns which rectangle grip the AnnotationGrip object represents.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleGrip GetGripDefinition(
    AnnotationGrip grip
)
Public Function GetGripDefinition (
    grip As AnnotationGrip
) As RectangleGrip

Parameters

grip
Type: Atalasoft.Annotate.UIAnnotationGrip
The grip to lookup.

Return Value

Type: RectangleGrip
A RectangleGrip value for this grip.
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


RectangleGrips.UpdatePositions Method

RectangleGripsUpdatePositions Method

Forces the grips to reset their positions based on a bounding rectangle.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void UpdatePositions(
    RectangleF bounds,
    PointF resolution,
    PointF scale
)
Public Overridable Sub UpdatePositions (
    bounds As RectangleF,
    resolution As PointF,
    scale As PointF
)

Parameters

bounds
Type: System.DrawingRectangleF
A bounding rectangle defining the grip locations.
resolution
Type: System.DrawingPointF
The viewer resolution.
scale
Type: System.DrawingPointF
The scale (zoom) of the viewer.
See Also

Reference

RectangleGrips Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Class

This annotation references a local image by filename. When viewing this annotation on multiple systems, the image file must be provided at the same location of each system.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIReferencedImageAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ReferencedImageAnnotation : AnnotationUI,
    IDisposable
<SerializableAttribute>
Public Class ReferencedImageAnnotation
    Inherits AnnotationUI
    Implements IDisposable

The ReferencedImageAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | ReferencedImageAnnotation | Creates a new instance of ReferencedImageAnnotation.
Public method | ReferencedImageAnnotation(String) | Creates a new instance of ReferencedImageAnnotation specifying the filename of the image.
Public method | ReferencedImageAnnotation(ReferencedImageData) | Creates a new instance of ReferencedImageAnnotation specifying the annotation data.
Public method | ReferencedImageAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of ReferencedImageAnnotation from serialized information.
Public method | ReferencedImageAnnotation(String, Boolean) | Creates an instance of ReferencedImageAnnotation specifying the filename of the image and indicating whether the aspect ratio should be maintained.
Public method | ReferencedImageAnnotation(String, Boolean, PointF) | Creates a new instance of ReferencedImageAnnotation specifying the filename, location and whether the aspect ratio should be maintained.
Public method | ReferencedImageAnnotation(String, Boolean, PointF, AnnotationBrush, PointF) | Creates a new instance of ReferencedImageAnnotation specifying the filename, initial location, shadow, shadow offset and indicates whether the image aspect ratio should be maintained.
Top
Properties
 | Name | Description
Public property | AllowClickThrough | Gets or sets a value indicating whether mouse clicks will pass through transparent areas of the image.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | FileName | Gets or sets the filename of the annotation image.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | KeepAspectRatio | Gets or sets a value indicating whether the image ratio is maintained while resizing.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called by Dispose or the finalizer to release resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ReferencedImageAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor

Constructs a ReferencedImageAnnotation.
Overload List
 | Name | Description
Public method | ReferencedImageAnnotation | Creates a new instance of ReferencedImageAnnotation.
Public method | ReferencedImageAnnotation(String) | Creates a new instance of ReferencedImageAnnotation specifying the filename of the image.
Public method | ReferencedImageAnnotation(ReferencedImageData) | Creates a new instance of ReferencedImageAnnotation specifying the annotation data.
Public method | ReferencedImageAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of ReferencedImageAnnotation from serialized information.
Public method | ReferencedImageAnnotation(String, Boolean) | Creates an instance of ReferencedImageAnnotation specifying the filename of the image and indicating whether the aspect ratio should be maintained.
Public method | ReferencedImageAnnotation(String, Boolean, PointF) | Creates a new instance of ReferencedImageAnnotation specifying the filename, location and whether the aspect ratio should be maintained.
Public method | ReferencedImageAnnotation(String, Boolean, PointF, AnnotationBrush, PointF) | Creates a new instance of ReferencedImageAnnotation specifying the filename, initial location, shadow, shadow offset and indicates whether the image aspect ratio should be maintained.
Top
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor

Creates a new instance of ReferencedImageAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation()
Public Sub New
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor (String)

Creates a new instance of ReferencedImageAnnotation specifying the filename of the image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor (ReferencedImageData)

Creates a new instance of ReferencedImageAnnotation specifying the annotation data.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation(
    ReferencedImageData data
)
Public Sub New (
    data As ReferencedImageData
)

Parameters

data
Type: Atalasoft.AnnotateReferencedImageData
A ReferencedImageData object for this annotation.
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ReferencedImageAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor (String, Boolean)

Creates an instance of ReferencedImageAnnotation specifying the filename of the image and indicating whether the aspect ratio should be maintained.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation(
    string fileName,
    bool keepAspectRatio
)
Public Sub New (
    fileName As String,
    keepAspectRatio As Boolean
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
keepAspectRatio
Type: SystemBoolean
Indicates if the image ratio is maintained.
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor (String, Boolean, PointF)

Creates a new instance of ReferencedImageAnnotation specifying the filename, location and whether the aspect ratio should be maintained.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation(
    string fileName,
    bool keepAspectRatio,
    PointF location
)
Public Sub New (
    fileName As String,
    keepAspectRatio As Boolean,
    location As PointF
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
keepAspectRatio
Type: SystemBoolean
Indicates if the image ratio is maintained.
location
Type: System.DrawingPointF
The location of the annotation.
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Constructor (String, Boolean, PointF, AnnotationBrush, PointF)

Creates a new instance of ReferencedImageAnnotation specifying the filename, initial location, shadow, shadow offset and indicates whether the image aspect ratio should be maintained.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotation(
    string fileName,
    bool keepAspectRatio,
    PointF location,
    AnnotationBrush shadow,
    PointF shadowOffset
)
Public Sub New (
    fileName As String,
    keepAspectRatio As Boolean,
    location As PointF,
    shadow As AnnotationBrush,
    shadowOffset As PointF
)

Parameters

fileName
Type: SystemString
The filename of the image for this annotation.
keepAspectRatio
Type: SystemBoolean
Indicates if the image ratio is maintained.
location
Type: System.DrawingPointF
The location of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

ReferencedImageAnnotation Class
ReferencedImageAnnotation Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Properties

The ReferencedImageAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AllowClickThrough | Gets or sets a value indicating whether mouse clicks will pass through transparent areas of the image.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | FileName | Gets or sets the filename of the annotation image.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | KeepAspectRatio | Gets or sets a value indicating whether the image ratio is maintained while resizing.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow | Gets or sets the AnnotationBrush used draw the drop shadow.
Public property | ShadowOffset | Gets or sets the shadow offset.
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.AllowClickThrough Property

ReferencedImageAnnotationAllowClickThrough Property

Gets or sets a value indicating whether mouse clicks will pass through transparent areas of the image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowClickThrough { get; set; }
Public Property AllowClickThrough As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether mouse clicks pass through transparent areas.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.FileName Property

ReferencedImageAnnotationFileName Property

Gets or sets the filename of the annotation image.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The filename of the image for this annotation.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.HitTestRectangle Property

ReferencedImageAnnotationHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF HitTestRectangle { get; }
Public Overrides ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.KeepAspectRatio Property

ReferencedImageAnnotationKeepAspectRatio Property

Gets or sets a value indicating whether the image ratio is maintained while resizing.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool KeepAspectRatio { get; set; }
Public Property KeepAspectRatio As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the image ratio is maintained.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.Shadow Property

ReferencedImageAnnotationShadow Property

Gets or sets the AnnotationBrush used draw the drop shadow.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used for the drop shadow.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.ShadowOffset Property

ReferencedImageAnnotationShadowOffset Property

Gets or sets the shadow offset.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
The offset used to specifying the position of the drop shadow.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Methods

The ReferencedImageAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called by Dispose or the finalizer to release resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ReferencedImageAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Overrides AnnotationUIGetRegion(AnnotateSpace).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.Clone Method

ReferencedImageAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.Dispose Method

ReferencedImageAnnotationDispose Method

Disposes the ReferencedImageAnnotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Called by Dispose or the finalizer to release resources.
Top
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.Dispose Method

ReferencedImageAnnotationDispose Method

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ReferencedImageAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.Dispose Method (Boolean)

ReferencedImageAnnotationDispose Method (Boolean)

Called by Dispose or the finalizer to release resources.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was called from Dispose or the finalizer.
See Also

Reference

ReferencedImageAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.Finalize Method

ReferencedImageAnnotationFinalize Method

Finalizes an instance of the ReferencedImageAnnotation class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.GetObjectData Method

ReferencedImageAnnotationGetObjectData Method

Fills a SerializationInfo object with information about this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation.GetRegion Method

ReferencedImageAnnotationGetRegion Method

Returns a rectangular region for this annotation, including its grips if selected.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationRegion GetRegion(
    AnnotateSpace space
)
Public Overrides Function GetRegion (
    space As AnnotateSpace
) As AnnotationRegion

Parameters

space
Type: Atalasoft.AnnotateAnnotateSpace
The space coordinate system used to generate this region.

Return Value

Type: AnnotationRegion
The region of this annotation in the specified space.
Examples
The following is an example of how a custom annotation may override the GetRegion method.
GetRegionCS
Copy
public override AnnotationRegion GetRegion(AnnotateSpace space)
{
Create the region in annotation space.
AnnotationRegion reg = new AnnotationRegion(new RectangleF(PointF.Empty, _data.Size));
if (this.Selected && this.Grips != null)
AddGripsToRegion(reg);
ApplyRegionTransform(reg, space);
return reg;
}
GetRegionVB
Copy
Public Overrides Function GetRegion(ByVal space As AnnotateSpace) As AnnotationRegion
' Create the region in annotation space.
Dim reg As AnnotationRegion =  New AnnotationRegion(New RectangleF(PointF.Empty,_data.Size))
If Not Me.Selected And Me.Grips Is Nothing Then
AddGripsToRegion(reg)
End If
ApplyRegionTransform(reg, space)
Return reg
End Function
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotation Events

The ReferencedImageAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

ReferencedImageAnnotation Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotationFactory Class

This class generates a ReferencedImageAnnotation object from a ReferencedImageData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIReferencedImageAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class ReferencedImageAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class ReferencedImageAnnotationFactory
    Implements IAnnotationUIFactory

The ReferencedImageAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | ReferencedImageAnnotationFactory | Creates a new instance of ReferencedImageAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a ReferencedImageAnnotation if the data object is a ReferencedImageData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotationFactory Constructor

Creates a new instance of ReferencedImageAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReferencedImageAnnotationFactory()
Public Sub New
See Also

Reference

ReferencedImageAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotationFactory Methods

The ReferencedImageAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a ReferencedImageAnnotation if the data object is a ReferencedImageData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReferencedImageAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


ReferencedImageAnnotationFactory.GetAnnotationUI Method

ReferencedImageAnnotationFactoryGetAnnotationUI Method

Returns a ReferencedImageAnnotation if the data object is a ReferencedImageData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The ReferencedImageData object for the annotation.

Return Value

Type: AnnotationUI
A ReferencedImageAnnotation or null (Nothing in Visual Basic) if the data parameter is not a ReferencedImageData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
Exceptions
Exception | Condition
 | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

ReferencedImageAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Class

This annotation provides a text message with a rounded rectangle outline similar to a rubber stamp.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UIRubberStampAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RubberStampAnnotation : AnnotationUI,
    ISerializable
<SerializableAttribute>
Public Class RubberStampAnnotation
    Inherits AnnotationUI
    Implements ISerializable

The RubberStampAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | RubberStampAnnotation | Creates a new instance of RubberStampAnnotation.
Public method | RubberStampAnnotation(RectangleF) | Creates a new instance of RubberStampAnnotation specifying the rectangle.
Public method | RubberStampAnnotation(String) | Creates a new instance of RubberStampAnnotation specifying the annotation text.
Public method | RubberStampAnnotation(RubberStampData) | Creates a new instance of RubberStampAnnotation providing the RubberStampData used by the annotation.
Public method | RubberStampAnnotation(RectangleF, String) | Creates a new instance of RubberStampAnnotation specifying the rectangle and text.
Public method | RubberStampAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of RubberStampAnnotation from serialized information.
Public method | RubberStampAnnotation(String, AnnotationFont) | Creates a new instance of RubberStampAnnotation specifying the text and font.
Public method | RubberStampAnnotation(RectangleF, String, AnnotationFont) | Creates a new instance of RubberStampAnnotation specifying the rectangle, text and font.
Public method | RubberStampAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampAnnotation specifying its parameters.
Public method | RubberStampAnnotation(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampAnnotation specifying the annotation parameters.
Top
Properties
 | Name | Description
Public property | AllowClickThrough | Gets or sets a value indicating whether mouse clicks will pass through transparent areas of the annotation.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CornerRadius | Gets or sets the corner radius.
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Font | Gets or sets the font for the text.
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Padding | Gets or sets the padding around the text.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for this annotation.
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor

Constructs a RubberStampAnnotation.
Overload List
 | Name | Description
Public method | RubberStampAnnotation | Creates a new instance of RubberStampAnnotation.
Public method | RubberStampAnnotation(RectangleF) | Creates a new instance of RubberStampAnnotation specifying the rectangle.
Public method | RubberStampAnnotation(String) | Creates a new instance of RubberStampAnnotation specifying the annotation text.
Public method | RubberStampAnnotation(RubberStampData) | Creates a new instance of RubberStampAnnotation providing the RubberStampData used by the annotation.
Public method | RubberStampAnnotation(RectangleF, String) | Creates a new instance of RubberStampAnnotation specifying the rectangle and text.
Public method | RubberStampAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of RubberStampAnnotation from serialized information.
Public method | RubberStampAnnotation(String, AnnotationFont) | Creates a new instance of RubberStampAnnotation specifying the text and font.
Public method | RubberStampAnnotation(RectangleF, String, AnnotationFont) | Creates a new instance of RubberStampAnnotation specifying the rectangle, text and font.
Public method | RubberStampAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampAnnotation specifying its parameters.
Public method | RubberStampAnnotation(RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single) | Creates a new instance of RubberStampAnnotation specifying the annotation parameters.
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor

Creates a new instance of RubberStampAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation()
Public Sub New
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (RectangleF)

Creates a new instance of RubberStampAnnotation specifying the rectangle.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    RectangleF bounds
)
Public Sub New (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
The rectangle for this annotation.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (String)

Creates a new instance of RubberStampAnnotation specifying the annotation text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The annotation text.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (RubberStampData)

Creates a new instance of RubberStampAnnotation providing the RubberStampData used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    RubberStampData data
)
Public Sub New (
    data As RubberStampData
)

Parameters

data
Type: Atalasoft.AnnotateRubberStampData
The RubberStampData used by this annotation.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (RectangleF, String)

Creates a new instance of RubberStampAnnotation specifying the rectangle and text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    RectangleF bounds,
    string text
)
Public Sub New (
    bounds As RectangleF,
    text As String
)

Parameters

bounds
Type: System.DrawingRectangleF
The rectangle for this annotation.
text
Type: SystemString
The text for this annotation.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RubberStampAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing the annotation information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (String, AnnotationFont)

Creates a new instance of RubberStampAnnotation specifying the text and font.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    string text,
    AnnotationFont font
)
Public Sub New (
    text As String,
    font As AnnotationFont
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (RectangleF, String, AnnotationFont)

Creates a new instance of RubberStampAnnotation specifying the rectangle, text and font.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    RectangleF bounds,
    string text,
    AnnotationFont font
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont
)

Parameters

bounds
Type: System.DrawingRectangleF
The rectangle for the annotation.
text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single)

Creates a new instance of RubberStampAnnotation specifying its parameters.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    float cornerRadius,
    float padding
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    cornerRadius As Single,
    padding As Single
)

Parameters

text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
cornerRadius
Type: SystemSingle
A value providing the rounding radius of the rectangle corners.
padding
Type: SystemSingle
Padding applied around the text.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Constructor (RectangleF, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Single, Single)

Creates a new instance of RubberStampAnnotation specifying the annotation parameters.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    RectangleF bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    float cornerRadius,
    float padding
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    cornerRadius As Single,
    padding As Single
)

Parameters

bounds
Type: System.DrawingRectangleF
The rectangle for the annotation.
text
Type: SystemString
The text for the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
cornerRadius
Type: SystemSingle
A value providing the rounding radius of the rectangle corners.
padding
Type: SystemSingle
Padding applied around the text.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Properties

The RubberStampAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AllowClickThrough | Gets or sets a value indicating whether mouse clicks will pass through transparent areas of the annotation.
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CornerRadius | Gets or sets the corner radius.
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | Fill | Gets or sets the fill used for the annotation.
Public property | Font | Gets or sets the font for the text.
Public property | FontBrush | Gets or sets the AnnotationBrush used for the font.
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline | Gets or sets the outline of the annotation.
Public property | Padding | Gets or sets the padding around the text.
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text | Gets or sets the text for this annotation.
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.AllowClickThrough Property

RubberStampAnnotationAllowClickThrough Property

Gets or sets a value indicating whether mouse clicks will pass through transparent areas of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowClickThrough { get; set; }
Public Property AllowClickThrough As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether mouse clicks will pass through transparent areas.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.CornerRadius Property

RubberStampAnnotationCornerRadius Property

Gets or sets the corner radius.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float CornerRadius { get; set; }
Public Property CornerRadius As Single
    Get
    Set

Property Value

Type: Single
The corner radius.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.Fill Property

RubberStampAnnotationFill Property

Gets or sets the fill used for the annotation.
Gets or sets the fill used for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.

Property Value

Type: AnnotationBrush
The AnnotationBrush used to fill the annotation.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.Font Property

RubberStampAnnotationFont Property

Gets or sets the font for the text.
Gets or sets the font for the text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used when rendering the text.

Property Value

Type: AnnotationFont
The font used when rendering the text.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.FontBrush Property

RubberStampAnnotationFontBrush Property

Gets or sets the AnnotationBrush used for the font.
Gets or sets the AnnotationBrush used for the font.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used when rendering the text.

Property Value

Type: AnnotationBrush
The brush used when rendering the text.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.HitTestRectangle Property

RubberStampAnnotationHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF HitTestRectangle { get; }
Public Overrides ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.Outline Property

RubberStampAnnotationOutline Property

Gets or sets the outline of the annotation.
Gets or sets the outline of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.

Property Value

Type: AnnotationPen
The AnnotationPen used to draw the outline of the annotation.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.Padding Property

RubberStampAnnotationPadding Property

Gets or sets the padding around the text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Padding { get; set; }
Public Property Padding As Single
    Get
    Set

Property Value

Type: Single
Padding applied around the text.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.Text Property

RubberStampAnnotationText Property

Gets or sets the text for this annotation.
Gets or sets the text for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The annotation text.

Property Value

Type: String
The annotation text.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Methods

The RubberStampAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | Called when the annotation is double-clicked. (Inherited from AnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | Called when the user has released the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | Called while an annotation is being moved by the user. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | Called when a property of the annotation or AnnotationData is about to be changed. (Inherited from AnnotationUI.)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | Called while the annotation is being resized by the user. (Inherited from AnnotationUI.)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnScrollPositionChanged | Called when the IAnnotate. Transform indicates a change in its offset (scroll position). (Inherited from AnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property of the annotation has changed. (Inherited from AnnotationUI.)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.Clone Method

RubberStampAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation.GetObjectData Method

RubberStampAnnotationGetObjectData Method

Fills a SerializationInfo object with information about this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotation Events

The RubberStampAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotationFactory Class

This class generates a RubberStampAnnotation object from a RubberStampData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIRubberStampAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class RubberStampAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class RubberStampAnnotationFactory
    Implements IAnnotationUIFactory

The RubberStampAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | RubberStampAnnotationFactory | Creates a new instance of RubberStampAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a RubberStampAnnotation if the data object is a RubberStampData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


RubberStampAnnotationFactory Constructor

Creates a new instance of RubberStampAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotationFactory()
Public Sub New
See Also

Reference

RubberStampAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotationFactory Methods

The RubberStampAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a RubberStampAnnotation if the data object is a RubberStampData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RubberStampAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


RubberStampAnnotationFactory.GetAnnotationUI Method

RubberStampAnnotationFactoryGetAnnotationUI Method

Returns a RubberStampAnnotation if the data object is a RubberStampData class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The RubberStampData object for the annotation.

Return Value

Type: AnnotationUI

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

RubberStampAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


ScrollPositionChangedEventArgs Class

This class is used with the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UIScrollPositionChangedEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ScrollPositionChangedEventArgs : EventArgs
Public Class ScrollPositionChangedEventArgs
    Inherits EventArgs

The ScrollPositionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollPositionChangedEventArgs | Creates a new instance of ScrollPositionChangedEventArgs.
Top
Properties
 | Name | Description
Public property | NewPosition | Gets the new scroll position.
Public property | PreviousPosition | Gets the previous scroll position.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


ScrollPositionChangedEventArgs Constructor

Creates a new instance of ScrollPositionChangedEventArgs.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollPositionChangedEventArgs(
    PointF previousPosition,
    PointF newPosition
)
Public Sub New (
    previousPosition As PointF,
    newPosition As PointF
)

Parameters

previousPosition
Type: System.DrawingPointF
The previous scroll position.
newPosition
Type: System.DrawingPointF
The new scroll position.
See Also

Reference

ScrollPositionChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


ScrollPositionChangedEventArgs Properties

The ScrollPositionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewPosition | Gets the new scroll position.
Public property | PreviousPosition | Gets the previous scroll position.
Top
See Also

Reference

ScrollPositionChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


ScrollPositionChangedEventArgs.NewPosition Property

ScrollPositionChangedEventArgsNewPosition Property

Gets the new scroll position.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF NewPosition { get; }
Public ReadOnly Property NewPosition As PointF
    Get

Property Value

Type: PointF
The new scroll position.
See Also

Reference

ScrollPositionChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


ScrollPositionChangedEventArgs.PreviousPosition Property

ScrollPositionChangedEventArgsPreviousPosition Property

Gets the previous scroll position.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF PreviousPosition { get; }
Public ReadOnly Property PreviousPosition As PointF
    Get

Property Value

Type: PointF
The previous scroll position.
See Also

Reference

ScrollPositionChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


ScrollPositionChangedEventArgs Methods

The ScrollPositionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScrollPositionChangedEventArgs Class
Atalasoft.Annotate.UI Namespace


TextAnnotation Class

This annotation displays text which can be edited by the user.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UIAnnotationUI
Atalasoft.Annotate.UITextAnnotation

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TextAnnotation : AnnotationUI,
    IDisposable
<SerializableAttribute>
Public Class TextAnnotation
    Inherits AnnotationUI
    Implements IDisposable

The TextAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | TextAnnotation | Creates a new instance of TextAnnotation.
Public method | TextAnnotation(String) | Creates a new instance of TextAnnotation specifying the annotation text.
Public method | TextAnnotation(TextData) | Creates a new instance of TextAnnotation specifying the TextData object used for this annotation.
Public method | TextAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of TextAnnotation from serialized information.
Public method | TextAnnotation(String, AnnotationFont) | Creates a new instance of TextAnnotation specifying the text and font.
Public method | TextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of TextAnnotation specifying the text, font, font brush, fill and outline for the annotation.
Public method | TextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of TextAnnotation specifying the properties for this object.
Top
Properties
 | Name | Description
Public property | Alignment |
Public property | AllowClickThrough | Gets or sets a value indicating whether mouse clicks can pass through transparent areas of the annotation.
Public property | AllowEditing | Gets or sets a value indicating whether double-clicking on the annotation will switch into edit mode.
Public property | AutoSelectOnEdit | Gets or sets a value indicating whether the text is automatically selected when the annotation is put into 'Edit' mode.
Public property | AutoSize |
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | EditMode | Gets or sets a value indicating whether the annotation text is currently in edit mode.
Public property | Fill |
Public property | Font |
Public property | FontBrush |
Public property | FormatFlags |
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | LineAlignment |
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline |
Public property | Padding |
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | RenderingHint | Gets or sets the rendering hint.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow |
Public property | ShadowOffset |
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text |
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Trimming |
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
 | CreateFont | Creates a System.Drawing.Font from an AnnotationFont.
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the TextAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | HideEditDialog | Removes the edit control from the viewer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Overrides AnnotationUIOnDoubleClick(EventArgs).)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Overrides AnnotationUIOnRotating(EventArgs).)
Protected method | OnScrollPositionChanged | (Overrides AnnotationUIOnScrollPositionChanged(ScrollPositionChangedEventArgs).)
Protected method | OnSelectedChanged | (Overrides AnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Protected method | ShowEditDialog | Displays an edit control in the viewer to allow text to be edited.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor

Constructs a TextAnnotation.
Overload List
 | Name | Description
Public method | TextAnnotation | Creates a new instance of TextAnnotation.
Public method | TextAnnotation(String) | Creates a new instance of TextAnnotation specifying the annotation text.
Public method | TextAnnotation(TextData) | Creates a new instance of TextAnnotation specifying the TextData object used for this annotation.
Public method | TextAnnotation(SerializationInfo, StreamingContext) | Creates a new instance of TextAnnotation from serialized information.
Public method | TextAnnotation(String, AnnotationFont) | Creates a new instance of TextAnnotation specifying the text and font.
Public method | TextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of TextAnnotation specifying the text, font, font brush, fill and outline for the annotation.
Public method | TextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode) | Creates a new instance of TextAnnotation specifying the properties for this object.
Top
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor

Creates a new instance of TextAnnotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation()
Public Sub New
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor (String)

Creates a new instance of TextAnnotation specifying the annotation text.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text for the annotation.
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor (TextData)

Creates a new instance of TextAnnotation specifying the TextData object used for this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation(
    TextData data
)
Public Sub New (
    data As TextData
)

Parameters

data
Type: Atalasoft.AnnotateTextData
The TextData object used by this annotation.
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor (SerializationInfo, StreamingContext)

Creates a new instance of TextAnnotation from serialized information.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the information.
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor (String, AnnotationFont)

Creates a new instance of TextAnnotation specifying the text and font.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation(
    string text,
    AnnotationFont font
)
Public Sub New (
    text As String,
    font As AnnotationFont
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of TextAnnotation specifying the text, font, font brush, fill and outline for the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, PointF, ShadowMode)

Creates a new instance of TextAnnotation specifying the properties for this object.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    PointF shadowOffset,
    ShadowMode shadowMode
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As PointF,
    shadowMode As ShadowMode
)

Parameters

text
Type: SystemString
The text for this annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for rendering the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for rendering the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used to fill the background of the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen used to render the outline of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The AnnotationBrush used for the drop shadow.
shadowOffset
Type: System.DrawingPointF
The offset for the shadow.
shadowMode
Type: Atalasoft.AnnotateShadowMode
The type of shadow to render.
See Also

Reference

TextAnnotation Class
TextAnnotation Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation Properties

The TextAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Alignment |
Public property | AllowClickThrough | Gets or sets a value indicating whether mouse clicks can pass through transparent areas of the annotation.
Public property | AllowEditing | Gets or sets a value indicating whether double-clicking on the annotation will switch into edit mode.
Public property | AutoSelectOnEdit | Gets or sets a value indicating whether the text is automatically selected when the annotation is put into 'Edit' mode.
Public property | AutoSize |
Public property | Bounds | Gets the bounding rectangle for the annotation. (Inherited from AnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether can mirror. (Inherited from AnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether can move. (Inherited from AnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether can resize. (Inherited from AnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether can rotate. (Inherited from AnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether can select. (Inherited from AnnotationUI.)
Public property | ContextMenu | Gets or sets a ContextMenu object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | ContextMenuStrip | Gets or sets a ContextMenuStrip object that will be displayed when the user right-clicks on the annotation. (Inherited from AnnotationUI.)
Public property | Controller | Gets the AnnotationController for this annotation. (Inherited from AnnotationUI.)
Public property | CreationTime | Gets or sets the creation time. (Inherited from AnnotationUI.)
Public property | Data | Gets the AnnotationData object associated with this annotation. (Inherited from AnnotationUI.)
Public property | EditMode | Gets or sets a value indicating whether the annotation text is currently in edit mode.
Public property | Fill |
Public property | Font |
Public property | FontBrush |
Public property | FormatFlags |
Public property | Grips | Gets the grips used for the annotation. (Inherited from AnnotationUI.)
Public property | HitTestRectangle | Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method. (Overrides AnnotationUIHitTestRectangle.)
Public property | LineAlignment |
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from AnnotationUI.)
Public property | ModifiedTime | Gets or sets the modification time. (Inherited from AnnotationUI.)
Public property | Name | Gets or sets the name. (Inherited from AnnotationUI.)
Public property | Outline |
Public property | Padding |
Public property | ParentLayer | Gets or sets the LayerAnnotation that contains this annotation. (Inherited from AnnotationUI.)
Public property | RenderingHint | Gets or sets the rendering hint.
Public property | Rotation | Gets or sets the rotation. (Inherited from AnnotationUI.)
Public property | Security | Gets or sets the security. (Inherited from AnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether this annotation the selected. (Inherited from AnnotationUI.)
Public property | Shadow |
Public property | ShadowOffset |
Public property | Size | Gets or sets the size of the annotation. (Inherited from AnnotationUI.)
Public property | State | Gets or sets the current state of the annotation. (Inherited from AnnotationUI.)
Public property | Text |
Public property | ToolTip | Gets or sets the tool tip. (Inherited from AnnotationUI.)
Public property | Transform | Gets or sets the transform. (Inherited from AnnotationUI.)
Public property | Trimming |
Public property | UserName | Gets or sets the name of the user. (Inherited from AnnotationUI.)
Public property | Visible | Gets or sets a value indicating whether the annotation is visible. (Inherited from AnnotationUI.)
Top
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Alignment Property

TextAnnotationAlignment Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment Alignment { get; set; }
Public Property Alignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.AllowClickThrough Property

TextAnnotationAllowClickThrough Property

Gets or sets a value indicating whether mouse clicks can pass through transparent areas of the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowClickThrough { get; set; }
Public Property AllowClickThrough As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether mouse clicks pass through transparent areas.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.AllowEditing Property

TextAnnotationAllowEditing Property

Gets or sets a value indicating whether double-clicking on the annotation will switch into edit mode.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether double-clicking on the annotation will switch into edit mode.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.AutoSelectOnEdit Property

TextAnnotationAutoSelectOnEdit Property

Gets or sets a value indicating whether the text is automatically selected when the annotation is put into 'Edit' mode.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSelectOnEdit { get; set; }
Public Property AutoSelectOnEdit As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates if the text is automatically selected when switched to 'Edit' mode.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.AutoSize Property

TextAnnotationAutoSize Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.EditMode Property

TextAnnotationEditMode Property

Gets or sets a value indicating whether the annotation text is currently in edit mode.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EditMode { get; set; }
Public Property EditMode As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation text is in edit mode.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Fill Property

TextAnnotationFill Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Font Property

TextAnnotationFont Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.FontBrush Property

TextAnnotationFontBrush Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.FormatFlags Property

TextAnnotationFormatFlags Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringFormatFlags FormatFlags { get; set; }
Public Property FormatFlags As StringFormatFlags
    Get
    Set

Property Value

Type: StringFormatFlags
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.HitTestRectangle Property

TextAnnotationHitTestRectangle Property

Gets a rectangle used for hit testing or RectangleF.Empty to use the default hit testing method.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override RectangleF HitTestRectangle { get; }
Public Overrides ReadOnly Property HitTestRectangle As RectangleF
    Get

Property Value

Type: RectangleF
A rectangle to use for hit testing or RectangleF.Empty to indicate that the default hit testing method should be used.
Remarks
The default hit testing method will ignore transparent areas of the annotation. This property can be used to override this behavior.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.LineAlignment Property

TextAnnotationLineAlignment Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment LineAlignment { get; set; }
Public Property LineAlignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Outline Property

TextAnnotationOutline Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Padding Property

TextAnnotationPadding Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Padding { get; set; }
Public Property Padding As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.RenderingHint Property

TextAnnotationRenderingHint Property

Gets or sets the rendering hint.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextRenderingHint RenderingHint { get; set; }
Public Property RenderingHint As TextRenderingHint
    Get
    Set

Property Value

Type: TextRenderingHint
The rendering hint.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Shadow Property

TextAnnotationShadow Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.ShadowOffset Property

TextAnnotationShadowOffset Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(PointFTypeConverter))]
public PointF ShadowOffset { get; set; }
<TypeConverterAttribute(GetType(PointFTypeConverter))>
Public Property ShadowOffset As PointF
    Get
    Set

Property Value

Type: PointF
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Text Property

TextAnnotationText Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Trimming Property

TextAnnotationTrimming Property

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringTrimming Trimming { get; set; }
Public Property Trimming As StringTrimming
    Get
    Set

Property Value

Type: StringTrimming
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation Methods

The TextAnnotation type exposes the following members.

Methods
 | Name | Description
 | AddGripsToRegion | Adds the annotation grips to a region. The grips are added in annotation space. (Inherited from AnnotationUI.)
 | ApplyRegionTransform | Use this method to convert a region from annotation space to document or view space. (Inherited from AnnotationUI.)
Public method | BeginCreate | This method is called by the AnnotationController when the user is beginning to create this annotation using the mouse. (Inherited from AnnotationUI.)
Public method | Clone | Creates a copy of this annotation. (Overrides AnnotationUIClone.)
 | CreateFont | Creates a System.Drawing.Font from an AnnotationFont.
Protected method | CreateRenderTransform | Returns the Matrix used by the renderer to transform the annotation. (Inherited from AnnotationUI.)
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the TextAnnotation class. (Overrides ObjectFinalize.)
Public method | GetConfinedGripPosition | Gets the confined grip position. (Inherited from AnnotationUI.)
Public method | GetConfinedLocation(RectangleF, PointF) | Returns the new confined location of the annotation when a confinement bounds and new location offset are provided. (Inherited from AnnotationUI.)
Protected method | GetConfinedLocation(RectangleF, RectangleF, PointF) | Returns the new confined location of the annotation when the annotation bounds, a confinement bounds and new location offset are provided. This overload is useful when only a portion of the annotation bounds should be taken into account for this calculation. (Inherited from AnnotationUI.)
Public method | GetConfinedRotation | Gets the confined rotation. (Inherited from AnnotationUI.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this annotation. (Overrides AnnotationUIGetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetOnePixel | Returns the equivalent of 1 pixel in resolution units. (Inherited from AnnotationUI.)
 | GetRegion | Returns a rectangular region for this annotation, including its grips if selected. (Inherited from AnnotationUI.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewerParameters | This method is used to get information about the viewer where the annotations are rendered, including resolution, zoom (scale) level and scrollbar position. (Inherited from AnnotationUI.)
Protected method | HideEditDialog | Removes the edit control from the viewer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors (flips) the annotation horizontally or vertically. (Inherited from AnnotationUI.)
Protected method | OnAnnotationControllerNotification | Called after a property of the annotation or related AnnotationData has been modified. (Inherited from AnnotationUI.)
Protected method | OnClick | Called when the user has clicked on the annotation. (Inherited from AnnotationUI.)
Protected method | OnControllerChanged | Called when the Controller property has changed. (Inherited from AnnotationUI.)
Protected method | OnDoubleClick | (Overrides AnnotationUIOnDoubleClick(EventArgs).)
Protected method | OnGripPositionChanged | Called when a grip of the annotation has been moved by the user using the mouse. (Inherited from AnnotationUI.)
Protected method | OnMirror | Called when the grips of an annotation have been dragged past the opposite grip. (Inherited from AnnotationUI.)
Protected method | OnMouseDown | Called when the user clicks down on the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseEnter | Called when the mouse is moved into the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseExit | Called when the mouse is moved out of the annotation region. (Inherited from AnnotationUI.)
Protected method | OnMouseMove | Called when the user has moved the mouse over the annotation. (Inherited from AnnotationUI.)
Protected method | OnMouseUp | (Overrides AnnotationUIOnMouseUp(AnnotationMouseEventArgs).)
Protected method | OnMoved | Called when a move to a new location has completed. (Inherited from AnnotationUI.)
Protected method | OnMoving | (Overrides AnnotationUIOnMoving(AnnotationLocationChangedEventArgs).)
Protected method | OnPropertyChanged | Called when a property value has changed and raises the PropertyChanged event. (Inherited from AnnotationUI.)
Protected method | OnPropertyChanging | (Overrides AnnotationUIOnPropertyChanging(AnnotationPropertyChangingEventArgs).)
Protected method | OnResized | Called when a resize on the annotation has completed. (Inherited from AnnotationUI.)
Protected method | OnResizing | (Overrides AnnotationUIOnResizing(EventArgs).)
Protected method | OnRotate | Called when the Rotate(Single) method is called on the annotation. (Inherited from AnnotationUI.)
Protected method | OnRotated | Called when the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Protected method | OnRotateDocument | Called when the RotateDocument(DocumentRotation, Int32) method is used. (Inherited from AnnotationUI.)
Protected method | OnRotating | Called while an annotation is being rotated by the user. (Overrides AnnotationUIOnRotating(EventArgs).)
Protected method | OnScrollPositionChanged | (Overrides AnnotationUIOnScrollPositionChanged(ScrollPositionChangedEventArgs).)
Protected method | OnSelectedChanged | (Overrides AnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnSizeChanged | Called when the Size property of the annotation has changed. (Inherited from AnnotationUI.)
Public method | RaiseClickEvent | Use this method to force a Click event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseDoubleClickEvent | Use this method to force a DoubleClick event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseGripPositionChangedEvent | Use this method to force a GripPositionChanged event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseDownEvent | Use this method to force a MouseDown event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseEnterEvent | Use to force the MouseEnter event for the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseExitEvent | Use to force a MouseExit event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseMoveEvent | Use this method to force a MouseMove event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMouseUpEvent | Use this method to force a MouseUp event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovedEvent | Use this method to force a Moved event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseMovingEvent | Use this method to force a Moving event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseOnRotateDocument | Use this method to force the OnRotateDocument(DocumentRotation) method to be called. (Inherited from AnnotationUI.)
Public method | RaiseResizedEvent | Use this method to force a Resized event on the annotation. (Inherited from AnnotationUI.)
Public method | RaiseRotatedEvent | This method invokes the Rotated event. (Inherited from AnnotationUI.)
Public method | RaiseScrollPositionChangedEvent | Use this method to force the OnScrollPositionChanged(ScrollPositionChangedEventArgs) method to be called. (Inherited from AnnotationUI.)
Public method | Remove | Forces the annotation to remove itself from its parent layer. (Inherited from AnnotationUI.)
Public method | Rotate | Rotates the annotation by the specified number of degrees. (Inherited from AnnotationUI.)
Protected method | SetGrips | Sets the grips used by the annotation. (Inherited from AnnotationUI.)
Protected method | ShowEditDialog | Displays an edit control in the viewer to allow text to be edited.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransformRectangle | Applies the render transformation matrix to a rectangle. (Inherited from AnnotationUI.)
Top
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Clone Method

TextAnnotationClone Method

Creates a copy of this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationUI Clone()
Public Overrides Function Clone As AnnotationUI

Return Value

Type: AnnotationUI
A copy of this AnnotationUI.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.CreateFont Method

TextAnnotationCreateFont Method

Creates a System.Drawing.Font from an AnnotationFont.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Font CreateFont(
    AnnotationFont annFont
)
Public Shared Function CreateFont (
    annFont As AnnotationFont
) As Font

Parameters

annFont
Type: Atalasoft.AnnotateAnnotationFont
The AnnotationFont used to create the Font.

Return Value

Type: Font
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Dispose Method

TextAnnotationDispose Method

Disposes the TextAnnotation.
Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the annotation.
Protected method | Dispose(Boolean) | Releases resources used by the annotation.
Top
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.Dispose Method

TextAnnotationDispose Method

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

TextAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation.Dispose Method (Boolean)

TextAnnotationDispose Method (Boolean)

Releases resources used by the annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this method is called from the public Dispose method.
See Also

Reference

TextAnnotation Class
Dispose Overload
Atalasoft.Annotate.UI Namespace


TextAnnotation.Finalize Method

TextAnnotationFinalize Method

Finalizes an instance of the TextAnnotation class.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.GetObjectData Method

TextAnnotationGetObjectData Method

Fills a SerializationInfo object with information about this annotation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo where data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.HideEditDialog Method

TextAnnotationHideEditDialog Method

Removes the edit control from the viewer.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void HideEditDialog()
Protected Overridable Sub HideEditDialog
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnDoubleClick Method

TextAnnotationOnDoubleClick Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDoubleClick(
    EventArgs e
)
Protected Overrides Sub OnDoubleClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnMouseUp Method

TextAnnotationOnMouseUp Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool OnMouseUp(
    AnnotationMouseEventArgs e
)
Protected Overrides Function OnMouseUp (
    e As AnnotationMouseEventArgs
) As Boolean

Parameters

e
Type: Atalasoft.Annotate.UIAnnotationMouseEventArgs

Return Value

Type: Boolean
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnMoving Method

TextAnnotationOnMoving Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMoving(
    AnnotationLocationChangedEventArgs e
)
Protected Overrides Sub OnMoving (
    e As AnnotationLocationChangedEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationLocationChangedEventArgs
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnPropertyChanging Method

TextAnnotationOnPropertyChanging Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanging(
    AnnotationPropertyChangingEventArgs e
)
Protected Overrides Sub OnPropertyChanging (
    e As AnnotationPropertyChangingEventArgs
)

Parameters

e
Type: Atalasoft.AnnotateAnnotationPropertyChangingEventArgs
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnResizing Method

TextAnnotationOnResizing Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResizing(
    EventArgs e
)
Protected Overrides Sub OnResizing (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnRotating Method

TextAnnotationOnRotating Method

Called while an annotation is being rotated by the user.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRotating(
    EventArgs e
)
Protected Overrides Sub OnRotating (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnScrollPositionChanged Method

TextAnnotationOnScrollPositionChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnScrollPositionChanged(
    ScrollPositionChangedEventArgs e
)
Protected Overrides Sub OnScrollPositionChanged (
    e As ScrollPositionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UIScrollPositionChangedEventArgs
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.OnSelectedChanged Method

TextAnnotationOnSelectedChanged Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSelectedChanged(
    EventArgs e
)
Protected Overrides Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation.ShowEditDialog Method

TextAnnotationShowEditDialog Method

Displays an edit control in the viewer to allow text to be edited.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ShowEditDialog()
Protected Overridable Sub ShowEditDialog
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotation Events

The TextAnnotation type exposes the following members.

Events
 | Name | Description
Public event | AnnotationControllerNotification | Raised after a property value has been changed. (Inherited from AnnotationUI.)
Public event | Click | Raised when the annotation has been clicked with the mouse. (Inherited from AnnotationUI.)
Public event | DoubleClick | Raised when the annotation has been double-clicked with the mouse. (Inherited from AnnotationUI.)
Public event | GripPositionChanged | Raised when a grip for the annotation has been moved. (Inherited from AnnotationUI.)
Public event | MouseDown | Raised when a mouse button is pressed while on top of the annotation. (Inherited from AnnotationUI.)
Public event | MouseEnter | Raised when the mouse enters the annotation region. (Inherited from AnnotationUI.)
Public event | MouseExit | Raised when the mouse exists the annotation region. (Inherited from AnnotationUI.)
Public event | MouseMove | Raised when the mouse is moved over the annotation. (Inherited from AnnotationUI.)
Public event | MouseUp | Raised when the mouse button is released from an annotation. (Inherited from AnnotationUI.)
Public event | Moved | Raised when the annotation has been moved. (Inherited from AnnotationUI.)
Public event | Moving | Raised while the annotation is being moved. (Inherited from AnnotationUI.)
Public event | PropertyChanged | Raised when a property value has changed. (Inherited from AnnotationUI.)
Public event | PropertyChanging | Raised when a property of the annotation or AnnotationData is going to be changed. (Inherited from AnnotationUI.)
Public event | Resized | Raised when the annotation has been resized. (Inherited from AnnotationUI.)
Public event | Resizing | Raised while the annotation is being resized. (Inherited from AnnotationUI.)
Public event | Rotated | Raised after the annotation has been rotated by the user. (Inherited from AnnotationUI.)
Public event | Rotating | Raise while an annotation is being rotated. (Inherited from AnnotationUI.)
Public event | SelectedChanged | Raised when the Selected property changes. (Inherited from AnnotationUI.)
Top
See Also

Reference

TextAnnotation Class
Atalasoft.Annotate.UI Namespace


TextAnnotationFactory Class

This class generates a TextAnnotation object from a TextData class for use with the AnnotationUIFactoryCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UITextAnnotationFactory

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class TextAnnotationFactory : IAnnotationUIFactory
Public NotInheritable Class TextAnnotationFactory
    Implements IAnnotationUIFactory

The TextAnnotationFactory type exposes the following members.

Constructors
 | Name | Description
Public method | TextAnnotationFactory | Creates a new instance of TextAnnotationFactory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


TextAnnotationFactory Constructor

Creates a new instance of TextAnnotationFactory.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAnnotationFactory()
Public Sub New
See Also

Reference

TextAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


TextAnnotationFactory Methods

The TextAnnotationFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


TextAnnotationFactory.GetAnnotationUI Method

TextAnnotationFactoryGetAnnotationUI Method

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The TextData object for the annotation.

Return Value

Type: AnnotationUI
A TextAnnotation or null (Nothing in Visual Basic) if the data parameter is not a TextData object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

TextAnnotationFactory Class
Atalasoft.Annotate.UI Namespace


TransparentRichTextBox Class

This class is used by the TextAnnotation and CalloutAnnotation for editing text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsRichTextBox
Atalasoft.Annotate.UITransparentRichTextBox

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TransparentRichTextBox : RichTextBox
Public Class TransparentRichTextBox
    Inherits RichTextBox

The TransparentRichTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | TransparentRichTextBox | Creates a new instance of TransparentRichTextBox.
Top
Properties
 | Name | Description
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (Inherited from RichTextBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (Inherited from RichTextBox.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BackgroundImageLayout | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (Inherited from RichTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (Inherited from RichTextBox.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Overrides RichTextBoxCreateParams.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from RichTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control. (Inherited from RichTextBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (Inherited from RichTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the font color used when displaying text in the control. (Inherited from RichTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the Input Method Editor (IME) mode of a control. (Inherited from TextBoxBase.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (Inherited from RichTextBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (Inherited from RichTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (Inherited from RichTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo method is called. (Inherited from RichTextBox.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RichTextShortcutsEnabled | This property is not relevant for this class. (Inherited from RichTextBox.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (Inherited from RichTextBox.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (Inherited from RichTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (Inherited from RichTextBox.)
Public property | SelectedText | Gets or sets the selected text within the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (Inherited from RichTextBox.)
Public property | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionFont | Gets or sets the font of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (Inherited from RichTextBox.)
Public property | SelectionIndent | Gets or sets the length, in pixels, of the indentation of the line where the selection starts. (Inherited from RichTextBox.)
Public property | SelectionLength | Gets or sets the number of characters selected in control. (Inherited from RichTextBox.)
Public property | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (Inherited from RichTextBox.)
Public property | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (Inherited from RichTextBox.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionType | Gets the selection type within the control. (Inherited from RichTextBox.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (Inherited from RichTextBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the rich text box. (Inherited from RichTextBox.)
Public property | TextLength | (Inherited from RichTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoActionName | Gets the name of the action that can be undone in the control when the Undo method is called. (Inherited from RichTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Public property | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (Inherited from RichTextBox.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanPaste | Determines whether you can paste information from the Clipboard in the specified data format. (Inherited from RichTextBox.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | (Inherited from TextBoxBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateRichEditOleCallback | Creates an IRichEditOleCallback-compatible object for handling rich-edit callback operations. (Inherited from RichTextBox.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | This method is not relevant for this class. (Inherited from RichTextBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | Find(String) | Searches the text in a RichTextBox control for a string. (Inherited from RichTextBox.)
Public method | Find(Char) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(Char, Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(Char, Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from RichTextBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the RichTextBox control. (Inherited from RichTextBox.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from RichTextBox.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBoxBase.)
Public method | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control. (Inherited from RichTextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAcceptsTabChanged | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from RichTextBox.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnBorderStyleChanged | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContentsResized | Raises the ContentsResized event. (Inherited from RichTextBox.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from RichTextBox.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from TextBoxBase.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from RichTextBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from RichTextBox.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideSelectionChanged | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
Protected method | OnHScroll | Raises the HScroll event. (Inherited from RichTextBox.)
Protected method | OnImeChange | Raises the ImeChange event. (Inherited from RichTextBox.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLinkClicked | Raises the LinkClicked event. (Inherited from RichTextBox.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnModifiedChanged | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnMultilineChanged | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | This method is not relevant for this class. (Inherited from TextBoxBase.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Overrides ControlOnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProtected | Raises the Protected event. (Inherited from RichTextBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnReadOnlyChanged | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from RichTextBox.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event. (Inherited from RichTextBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from TextBoxBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnVScroll | Raises the VScroll event. (Inherited from RichTextBox.)
Public method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(DataFormatsFormat) | Pastes the contents of the Clipboard in the specified Clipboard format. (Inherited from RichTextBox.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from RichTextBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | (Inherited from TextBoxBase.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Reapplies the last operation that was undone in the control. (Inherited from RichTextBox.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file. (Inherited from RichTextBox.)
Public method | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file. (Inherited from RichTextBox.)
Public method | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream. (Inherited from RichTextBox.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from RichTextBox.)
Top
Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from RichTextBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from RichTextBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContentsResized | Occurs when contents within the control are resized. (Inherited from RichTextBox.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when the user completes a drag-and-drop (Inherited from RichTextBox.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from RichTextBox.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from RichTextBox.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from RichTextBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from RichTextBox.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (Inherited from RichTextBox.)
Public event | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (Inherited from RichTextBox.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LinkClicked | Occurs when the user clicks on a link within the text of the control. (Inherited from RichTextBox.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | Protected | Occurs when the user attempts to modify protected text in the control. (Inherited from RichTextBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | This event is not relevant to this class. (Inherited from RichTextBox.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from RichTextBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (Inherited from RichTextBox.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


TransparentRichTextBox Constructor

Creates a new instance of TransparentRichTextBox.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TransparentRichTextBox(
    bool transparentBackground
)
Public Sub New (
    transparentBackground As Boolean
)

Parameters

transparentBackground
Type: SystemBoolean
Indicates if the textbox will have a transparent background.
See Also

Reference

TransparentRichTextBox Class
Atalasoft.Annotate.UI Namespace


TransparentRichTextBox Properties

The TransparentRichTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (Inherited from RichTextBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (Inherited from RichTextBox.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BackgroundImageLayout | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (Inherited from RichTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (Inherited from RichTextBox.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Overrides RichTextBoxCreateParams.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from RichTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control. (Inherited from RichTextBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (Inherited from RichTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the font color used when displaying text in the control. (Inherited from RichTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the Input Method Editor (IME) mode of a control. (Inherited from TextBoxBase.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (Inherited from RichTextBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (Inherited from RichTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (Inherited from RichTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo method is called. (Inherited from RichTextBox.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RichTextShortcutsEnabled | This property is not relevant for this class. (Inherited from RichTextBox.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (Inherited from RichTextBox.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (Inherited from RichTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (Inherited from RichTextBox.)
Public property | SelectedText | Gets or sets the selected text within the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (Inherited from RichTextBox.)
Public property | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionFont | Gets or sets the font of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (Inherited from RichTextBox.)
Public property | SelectionIndent | Gets or sets the length, in pixels, of the indentation of the line where the selection starts. (Inherited from RichTextBox.)
Public property | SelectionLength | Gets or sets the number of characters selected in control. (Inherited from RichTextBox.)
Public property | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (Inherited from RichTextBox.)
Public property | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (Inherited from RichTextBox.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionType | Gets the selection type within the control. (Inherited from RichTextBox.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (Inherited from RichTextBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the rich text box. (Inherited from RichTextBox.)
Public property | TextLength | (Inherited from RichTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoActionName | Gets the name of the action that can be undone in the control when the Undo method is called. (Inherited from RichTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Public property | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (Inherited from RichTextBox.)
Top
See Also

Reference

TransparentRichTextBox Class
Atalasoft.Annotate.UI Namespace


TransparentRichTextBox.CreateParams Property

TransparentRichTextBoxCreateParams Property

Gets the required creation parameters when the control handle is created.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override CreateParams CreateParams { get; }
Protected Overrides ReadOnly Property CreateParams As CreateParams
    Get

Property Value

Type: CreateParams
A CreateParams object that contains the required creation parameters when the handle to the control is created.
See Also

Reference

TransparentRichTextBox Class
Atalasoft.Annotate.UI Namespace


TransparentRichTextBox Methods

The TransparentRichTextBox type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanPaste | Determines whether you can paste information from the Clipboard in the specified data format. (Inherited from RichTextBox.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | (Inherited from TextBoxBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateRichEditOleCallback | Creates an IRichEditOleCallback-compatible object for handling rich-edit callback operations. (Inherited from RichTextBox.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | This method is not relevant for this class. (Inherited from RichTextBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | Find(String) | Searches the text in a RichTextBox control for a string. (Inherited from RichTextBox.)
Public method | Find(Char) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(Char, Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(Char, Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from RichTextBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the RichTextBox control. (Inherited from RichTextBox.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from RichTextBox.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBoxBase.)
Public method | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control. (Inherited from RichTextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAcceptsTabChanged | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from RichTextBox.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnBorderStyleChanged | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContentsResized | Raises the ContentsResized event. (Inherited from RichTextBox.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from RichTextBox.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from TextBoxBase.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from RichTextBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from RichTextBox.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideSelectionChanged | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
Protected method | OnHScroll | Raises the HScroll event. (Inherited from RichTextBox.)
Protected method | OnImeChange | Raises the ImeChange event. (Inherited from RichTextBox.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLinkClicked | Raises the LinkClicked event. (Inherited from RichTextBox.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnModifiedChanged | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnMultilineChanged | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | This method is not relevant for this class. (Inherited from TextBoxBase.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Overrides ControlOnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProtected | Raises the Protected event. (Inherited from RichTextBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnReadOnlyChanged | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from RichTextBox.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event. (Inherited from RichTextBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from TextBoxBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnVScroll | Raises the VScroll event. (Inherited from RichTextBox.)
Public method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(DataFormatsFormat) | Pastes the contents of the Clipboard in the specified Clipboard format. (Inherited from RichTextBox.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from RichTextBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | (Inherited from TextBoxBase.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Reapplies the last operation that was undone in the control. (Inherited from RichTextBox.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file. (Inherited from RichTextBox.)
Public method | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file. (Inherited from RichTextBox.)
Public method | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream. (Inherited from RichTextBox.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from RichTextBox.)
Top
See Also

Reference

TransparentRichTextBox Class
Atalasoft.Annotate.UI Namespace


TransparentRichTextBox.OnPaintBackground Method

TransparentRichTextBoxOnPaintBackground Method

Paints the background of the control.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaintBackground(
    PaintEventArgs pevent
)
Protected Overrides Sub OnPaintBackground (
    pevent As PaintEventArgs
)

Parameters

pevent
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs that contains information about the control to paint.
See Also

Reference

TransparentRichTextBox Class
Atalasoft.Annotate.UI Namespace


TransparentRichTextBox Events

The TransparentRichTextBox type exposes the following members.

Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from RichTextBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from RichTextBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContentsResized | Occurs when contents within the control are resized. (Inherited from RichTextBox.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when the user completes a drag-and-drop (Inherited from RichTextBox.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from RichTextBox.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from RichTextBox.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from RichTextBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from RichTextBox.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (Inherited from RichTextBox.)
Public event | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (Inherited from RichTextBox.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LinkClicked | Occurs when the user clicks on a link within the text of the control. (Inherited from RichTextBox.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | Protected | Occurs when the user attempts to modify protected text in the control. (Inherited from RichTextBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | This event is not relevant to this class. (Inherited from RichTextBox.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from RichTextBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (Inherited from RichTextBox.)
Top
See Also

Reference

TransparentRichTextBox Class
Atalasoft.Annotate.UI Namespace


UndoEventArgs Class

This class contains information for the UndoRequest and RedoRequest events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UIUndoEventArgs

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UndoEventArgs : EventArgs
Public Class UndoEventArgs
    Inherits EventArgs

The UndoEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UndoEventArgs | Creates a new instance of UndoEventArgs specifying the AnnotationUndo for this action.
Top
Properties
 | Name | Description
Public property | Undo | Gets the undo for this operation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI Namespace


UndoEventArgs Constructor

Creates a new instance of UndoEventArgs specifying the AnnotationUndo for this action.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoEventArgs(
    AnnotationUndo undo
)
Public Sub New (
    undo As AnnotationUndo
)

Parameters

undo
Type: Atalasoft.Annotate.UIAnnotationUndo
The undo for this action.
See Also

Reference

UndoEventArgs Class
Atalasoft.Annotate.UI Namespace


UndoEventArgs Properties

The UndoEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Undo | Gets the undo for this operation.
Top
See Also

Reference

UndoEventArgs Class
Atalasoft.Annotate.UI Namespace


UndoEventArgs.Undo Property

UndoEventArgsUndo Property

Gets the undo for this operation.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUndo Undo { get; }
Public ReadOnly Property Undo As AnnotationUndo
    Get

Property Value

Type: AnnotationUndo
The AnnotationUndo for this operation.
See Also

Reference

UndoEventArgs Class
Atalasoft.Annotate.UI Namespace


UndoEventArgs Methods

The UndoEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UndoEventArgs Class
Atalasoft.Annotate.UI Namespace


UndoEventHandler Delegate

This delegate is used for the UndoRequest and RedoRequest events of the AnnotationUndoManager.

Namespace: Atalasoft.Annotate.UI
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void UndoEventHandler(
    Object sender,
    UndoEventArgs e
)
Public Delegate Sub UndoEventHandler (
    sender As Object,
    e As UndoEventArgs
)

Parameters

sender
Type: SystemObject
The AnnotationUndoManager sending the request.
e
Type: Atalasoft.Annotate.UIUndoEventArgs
The UndoEventArgs containing information about this event.
See Also

Reference

Atalasoft.Annotate.UI Namespace


Atalasoft.Annotate.UI.Exporters Namespace

Classes
 | Class | Description
Public class | AnnotationExporter | Obsolete. An abstract base class that encompasses elements for exporting annotations.
Public class | PdfAnnotationExporter | Obsolete. The PdfAnnotationExporter object is capable of taking DotImage Annotation objects and translating them into a format suitable for PDF.


AnnotationExporter Class

Note: This API is now obsolete.

An abstract base class that encompasses elements for exporting annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UI.ExportersAnnotationExporter
Atalasoft.Annotate.UI.ExportersPdfAnnotationExporter

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("AnnotationExporter may be removed from a future release.  Please inherit from AnnotationDataExporter instead.",
    false)]
public abstract class AnnotationExporter
<ObsoleteAttribute("AnnotationExporter may be removed from a future release.  Please inherit from AnnotationDataExporter instead.",
    false)>
Public MustInherit Class AnnotationExporter

The AnnotationExporter type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationExporter | Initializes a new instance of the AnnotationExporter class.
Top
Properties
 | Name | Description
Public property | CanExport | Indicates whether or not this AnnotationExporter can do a simple export.
Public property | CanExportOver | Indicates whether or not this AnnotationExporter can write annotations to a stream without affecting existing contents.
Top
Methods
 | Name | Description
Public method | Construct | A factory method to construct a new AnnotationExporter.
Protected method | CopyStream | Copies the entire source stream to the destination stream.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Exports a single page of annotations to a given stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Export a set of annotations over an existing stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Export a set of annotations over an existing stream.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if the stream is the correct format.
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) |
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) |
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) |
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter Constructor

Initializes a new instance of the AnnotationExporter class.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationExporter()
Public Sub New
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter Properties

The AnnotationExporter type exposes the following members.

Properties
 | Name | Description
Public property | CanExport | Indicates whether or not this AnnotationExporter can do a simple export.
Public property | CanExportOver | Indicates whether or not this AnnotationExporter can write annotations to a stream without affecting existing contents.
Top
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.CanExport Property

AnnotationExporterCanExport Property

Indicates whether or not this AnnotationExporter can do a simple export.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool CanExport { get; }
Public MustOverride ReadOnly Property CanExport As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.CanExportOver Property

AnnotationExporterCanExportOver Property

Indicates whether or not this AnnotationExporter can write annotations to a stream without affecting existing contents.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool CanExportOver { get; }
Public MustOverride ReadOnly Property CanExportOver As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter Methods

The AnnotationExporter type exposes the following members.

Methods
 | Name | Description
Public method | Construct | A factory method to construct a new AnnotationExporter.
Protected method | CopyStream | Copies the entire source stream to the destination stream.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Exports a single page of annotations to a given stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Export a set of annotations over an existing stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Export a set of annotations over an existing stream.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if the stream is the correct format.
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) |
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) |
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) |
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.Construct Method

AnnotationExporterConstruct Method

A factory method to construct a new AnnotationExporter.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AnnotationExporter Construct()
Public MustOverride Function Construct As AnnotationExporter

Return Value

Type: AnnotationExporter
A new AnnotationExporter object.
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.CopyStream Method

AnnotationExporterCopyStream Method

Copies the entire source stream to the destination stream.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void CopyStream(
    Stream sourceStream,
    Stream destStream
)
Protected Overridable Sub CopyStream (
    sourceStream As Stream,
    destStream As Stream
)

Parameters

sourceStream
Type: System.IOStream
A non-null stream with annotation source data
destStream
Type: System.IOStream
a non-null stream to which the source data will be copied.
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.Export Method

AnnotationExporterExport Method

Exports annotations from a given source stream to a given destination stream.
Overload List
 | Name | Description
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Exports a multiple pages of annotations to a given stream.
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Exports a single page of annotations to a given stream.
Top
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.Export Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], LayerCollection)

AnnotationExporterExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection)

Exports a multiple pages of annotations to a given stream.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    LayerCollection layers
)
Public Sub Export (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As LayerCollection
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.Annotate.UILayerCollection
A collection of pages of annotations.
Remarks
To create a page with no annotations, add an empty LayerAnnotation to the collection.
See Also

Reference

AnnotationExporter Class
Export Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.Export Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

AnnotationExporterExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

Exports a single page of annotations to a given stream.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Export(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerAnnotation layer,
    int frameIndex
)
Public Sub Export (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerAnnotation,
    frameIndex As Integer
)

Parameters

sourceStream
Type: System.IOStream
The original source stream for the document.
destStream
Type: System.IOStream
The destination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
Remarks
Source stream is necessary for some file formats like PDF which require an entire document to hold the annotations. Other formats may ignore the source stream entirely.
See Also

Reference

AnnotationExporter Class
Export Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.ExportOver Method

AnnotationExporterExportOver Method

Export a set of annotations over an existing stream.
Overload List
 | Name | Description
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Export a set of annotations over an existing stream.
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Export a set of annotations over an existing stream.
Top
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.ExportOver Method (Stream, SizeF[], AnnotationUnit, Dpi[], LayerCollection)

AnnotationExporterExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerCollection)

Export a set of annotations over an existing stream.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ExportOver(
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    LayerCollection layers
)
Public Sub ExportOver (
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As LayerCollection
)

Parameters

destStream
Type: System.IOStream
The destination stream for the document.
pageSizes
Type: System.DrawingSizeF
An array of sizes of the source pages.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
layers
Type: Atalasoft.Annotate.UILayerCollection
A collection of pages of annotations.
See Also

Reference

AnnotationExporter Class
ExportOver Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.ExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

AnnotationExporterExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

Export a set of annotations over an existing stream.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ExportOver(
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerAnnotation layer,
    int frameIndex
)
Public Sub ExportOver (
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerAnnotation,
    frameIndex As Integer
)

Parameters

destStream
Type: System.IOStream
The destination stream for the document.
pageSize
Type: System.DrawingSizeF
The size of the source page.
units
Type: Atalasoft.AnnotateAnnotationUnit
The units in which the page size is expressed.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The page of annotations to export.
frameIndex
Type: SystemInt32
The page number for exporting.
See Also

Reference

AnnotationExporter Class
ExportOver Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.IsValidFormat Method

AnnotationExporterIsValidFormat Method

Determines if the stream is the correct format.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool IsValidFormat(
    Stream stm
)
Public MustOverride Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream

Return Value

Type: Boolean
Returns true if the stream contains valid data for this AnnotationExporter, false otherwise.
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.LLExport Method

AnnotationExporterLLExport Method

Low level implementation of Export.
Low level implementation of Export.
Overload List
 | Name | Description
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) |
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) |
Top
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.LLExport Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], LayerCollection)

AnnotationExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolution,
    LayerCollection layers
)
Protected MustOverride Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolution As Dpi(),
    layers As LayerCollection
)

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
pageSizes
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layers
Type: Atalasoft.Annotate.UILayerCollection
See Also

Reference

AnnotationExporter Class
LLExport Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.LLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

AnnotationExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerAnnotation layer,
    int frameIndex
)
Protected MustOverride Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerAnnotation,
    frameIndex As Integer
)

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
pageSize
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layer
Type: Atalasoft.Annotate.UILayerAnnotation
frameIndex
Type: SystemInt32
See Also

Reference

AnnotationExporter Class
LLExport Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.LLExportOver Method

AnnotationExporterLLExportOver Method

Low level implementation of ExportOver.
Low level implementation of ExportOver.
Overload List
 | Name | Description
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) |
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) |
Top
See Also

Reference

AnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.LLExportOver Method (Stream, SizeF[], AnnotationUnit, Dpi[], LayerCollection)

AnnotationExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerCollection)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExportOver(
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolution,
    LayerCollection layers
)
Protected MustOverride Sub LLExportOver (
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolution As Dpi(),
    layers As LayerCollection
)

Parameters

destStream
Type: System.IOStream
pageSizes
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layers
Type: Atalasoft.Annotate.UILayerCollection
See Also

Reference

AnnotationExporter Class
LLExportOver Overload
Atalasoft.Annotate.UI.Exporters Namespace


AnnotationExporter.LLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

AnnotationExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLExportOver(
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerAnnotation layer,
    int frameIndex
)
Protected MustOverride Sub LLExportOver (
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerAnnotation,
    frameIndex As Integer
)

Parameters

destStream
Type: System.IOStream
pageSize
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layer
Type: Atalasoft.Annotate.UILayerAnnotation
frameIndex
Type: SystemInt32
See Also

Reference

AnnotationExporter Class
LLExportOver Overload
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter Class

Note: This API is now obsolete.

The PdfAnnotationExporter object is capable of taking DotImage Annotation objects and translating them into a format suitable for PDF.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UI.ExportersAnnotationExporter
Atalasoft.Annotate.UI.ExportersPdfAnnotationExporter

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("PdfAnnotationExporter may be removed from a future release.  Please use PdfAnnotationDataExporter instead",
    false)]
public class PdfAnnotationExporter : AnnotationExporter
<ObsoleteAttribute("PdfAnnotationExporter may be removed from a future release.  Please use PdfAnnotationDataExporter instead",
    false)>
Public Class PdfAnnotationExporter
    Inherits AnnotationExporter

The PdfAnnotationExporter type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationExporter | Constructs a new PdfAnnotationExporter object.
Top
Properties
 | Name | Description
Public property | CanExport | Overridden. Returns false. (Overrides AnnotationExporterCanExport.)
Public property | CanExportOver | Overridden. Returns true. (Overrides AnnotationExporterCanExportOver.)
Top
Methods
 | Name | Description
Public method | Construct | Constructs a new PdfAnnotationExporter. (Overrides AnnotationExporterConstruct.)
Protected method | CopyStream | Copies the entire source stream to the destination stream. (Inherited from AnnotationExporter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Exports a multiple pages of annotations to a given stream. (Inherited from AnnotationExporter.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Exports a single page of annotations to a given stream. (Inherited from AnnotationExporter.)
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Export a set of annotations over an existing stream. (Inherited from AnnotationExporter.)
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Export a set of annotations over an existing stream. (Inherited from AnnotationExporter.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if a stream contains PDF content. (Overrides AnnotationExporterIsValidFormat(Stream).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | (Overrides AnnotationExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | (Overrides AnnotationExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | (Overrides AnnotationExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | (Overrides AnnotationExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter Constructor

Constructs a new PdfAnnotationExporter object.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationExporter()
Public Sub New
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter Properties

The PdfAnnotationExporter type exposes the following members.

Properties
 | Name | Description
Public property | CanExport | Overridden. Returns false. (Overrides AnnotationExporterCanExport.)
Public property | CanExportOver | Overridden. Returns true. (Overrides AnnotationExporterCanExportOver.)
Top
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.CanExport Property

PdfAnnotationExporterCanExport Property

Overridden. Returns false.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanExport { get; }
Public Overrides ReadOnly Property CanExport As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.CanExportOver Property

PdfAnnotationExporterCanExportOver Property

Overridden. Returns true.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanExportOver { get; }
Public Overrides ReadOnly Property CanExportOver As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter Methods

The PdfAnnotationExporter type exposes the following members.

Methods
 | Name | Description
Public method | Construct | Constructs a new PdfAnnotationExporter. (Overrides AnnotationExporterConstruct.)
Protected method | CopyStream | Copies the entire source stream to the destination stream. (Inherited from AnnotationExporter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Exports a multiple pages of annotations to a given stream. (Inherited from AnnotationExporter.)
Public method | Export(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Exports a single page of annotations to a given stream. (Inherited from AnnotationExporter.)
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | Export a set of annotations over an existing stream. (Inherited from AnnotationExporter.)
Public method | ExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | Export a set of annotations over an existing stream. (Inherited from AnnotationExporter.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if a stream contains PDF content. (Overrides AnnotationExporterIsValidFormat(Stream).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | (Overrides AnnotationExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | (Overrides AnnotationExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | (Overrides AnnotationExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | (Overrides AnnotationExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.Construct Method

PdfAnnotationExporterConstruct Method

Constructs a new PdfAnnotationExporter.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationExporter Construct()
Public Overrides Function Construct As AnnotationExporter

Return Value

Type: AnnotationExporter
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.IsValidFormat Method

PdfAnnotationExporterIsValidFormat Method

Determines if a stream contains PDF content.

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stm
)
Public Overrides Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream.

Return Value

Type: Boolean
Returns true if the stream contains PDF, false otherwise.
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.LLExport Method

PdfAnnotationExporterLLExport Method

Overload List
 | Name | Description
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | (Overrides AnnotationExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection).)
Protected method | LLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | (Overrides AnnotationExporterLLExport(Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32).)
Top
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.LLExport Method (Stream, Stream, SizeF[], AnnotationUnit, Dpi[], LayerCollection)

PdfAnnotationExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerCollection)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    LayerCollection layers
)
Protected Overrides Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As LayerCollection
)

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
pageSizes
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolutions
Type: Atalasoft.ImagingDpi
layers
Type: Atalasoft.Annotate.UILayerCollection
See Also

Reference

PdfAnnotationExporter Class
LLExport Overload
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.LLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

PdfAnnotationExporterLLExport Method (Stream, Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExport(
    Stream sourceStream,
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerAnnotation layer,
    int frameIndex
)
Protected Overrides Sub LLExport (
    sourceStream As Stream,
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerAnnotation,
    frameIndex As Integer
)

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
pageSize
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layer
Type: Atalasoft.Annotate.UILayerAnnotation
frameIndex
Type: SystemInt32
See Also

Reference

PdfAnnotationExporter Class
LLExport Overload
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.LLExportOver Method

PdfAnnotationExporterLLExportOver Method

Overload List
 | Name | Description
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection) | (Overrides AnnotationExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerCollection).)
Protected method | LLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32) | (Overrides AnnotationExporterLLExportOver(Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32).)
Top
See Also

Reference

PdfAnnotationExporter Class
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.LLExportOver Method (Stream, SizeF[], AnnotationUnit, Dpi[], LayerCollection)

PdfAnnotationExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerCollection)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExportOver(
    Stream destStream,
    SizeF[] pageSizes,
    AnnotationUnit units,
    Dpi[] resolutions,
    LayerCollection layers
)
Protected Overrides Sub LLExportOver (
    destStream As Stream,
    pageSizes As SizeF(),
    units As AnnotationUnit,
    resolutions As Dpi(),
    layers As LayerCollection
)

Parameters

destStream
Type: System.IOStream
pageSizes
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolutions
Type: Atalasoft.ImagingDpi
layers
Type: Atalasoft.Annotate.UILayerCollection
See Also

Reference

PdfAnnotationExporter Class
LLExportOver Overload
Atalasoft.Annotate.UI.Exporters Namespace


PdfAnnotationExporter.LLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

PdfAnnotationExporterLLExportOver Method (Stream, SizeF, AnnotationUnit, Dpi, LayerAnnotation, Int32)

Namespace: Atalasoft.Annotate.UI.Exporters
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLExportOver(
    Stream destStream,
    SizeF pageSize,
    AnnotationUnit units,
    Dpi resolution,
    LayerAnnotation layer,
    int frameIndex
)
Protected Overrides Sub LLExportOver (
    destStream As Stream,
    pageSize As SizeF,
    units As AnnotationUnit,
    resolution As Dpi,
    layer As LayerAnnotation,
    frameIndex As Integer
)

Parameters

destStream
Type: System.IOStream
pageSize
Type: System.DrawingSizeF
units
Type: Atalasoft.AnnotateAnnotationUnit
resolution
Type: Atalasoft.ImagingDpi
layer
Type: Atalasoft.Annotate.UILayerAnnotation
frameIndex
Type: SystemInt32
See Also

Reference

PdfAnnotationExporter Class
LLExportOver Overload
Atalasoft.Annotate.UI.Exporters Namespace


Atalasoft.Annotate.UI.Importers Namespace

Classes
 | Class | Description
Public class | AnnotationImporter | Obsolete. AnnotationImporter is an abstract base class used to define how annotations are imported from arbitrary data files into DotImage. This class is obsolete: Use AnnotationDataImporter instead.
Public class | AnnotationImporterCollection | This is a collection used to contain a set of AnnotationImporter objects.
Public class | AnnotationImportEventArgs | An object representing information about an annotation being imported.
Public class | AnnotationPageImportEventArgs | An object representing information about a page of annotations being imported.
Public class | PdfAnnotationImporter | Obsolete. Constructs a new PdfAnnotationImporter object. This class is obsolete: Use PdfAnnotationDataImporter instead.
Public class | XmpAnnotationImporter | Obsolete. Summary description for XmpImporter.
Delegates
 | Delegate | Description
Public delegate | AnnotationImporterFactory | A delegate for constructing annotations from data that a given AnnotationImporter doesn't understand.
Public delegate | AnnotationImportEventHandler | Defines a handler to be called on annotation import.
Public delegate | AnnotationPageImportEventHandler | Defines a handler to be called on annotation page import.


AnnotationImporter Class

Note: This API is now obsolete.

AnnotationImporter is an abstract base class used to define how annotations are imported from arbitrary data files into DotImage.

This class is obsolete: Use AnnotationDataImporter instead.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UI.ImportersAnnotationImporter
Atalasoft.Annotate.UI.ImportersPdfAnnotationImporter
Atalasoft.Annotate.UI.ImportersXmpAnnotationImporter

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("AnnotationImporter may be removed from a future release. Use AnnotationDataImporter instead.",
    false)]
public abstract class AnnotationImporter
<ObsoleteAttribute("AnnotationImporter may be removed from a future release. Use AnnotationDataImporter instead.",
    false)>
Public MustInherit Class AnnotationImporter

The AnnotationImporter type exposes the following members.

Constructors
 | Name | Description
Protected method | AnnotationImporter | Initializes a new instance of the AnnotationImporter class
Top
Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so.
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations.
Public property | PageCount | Returns the total number of pages in a document.
Public property | Resolution | Sets or gets the resolution of the target for the annotations.
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions.
Public property | Units | Sets or gets the units of the target for the annotations.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new annotation importer associated with a given stream.
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as LayerCollection.
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation.
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations.
Public method | IsValidFormat | Indicates whether or not an AnnotationImporter can recognize a particular data format.
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount
Protected method | LLGetPageCount | The low-level implementation of PageCount
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection.
Protected method | LLImport(Int32, Int32) |
Protected method | LLLoad | The low-level implementation of Load
Public method | Load | The load method is used to allow an AnnotationImporter to load and to possibly cache annotations.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Fires the AnnotationImported event.
Protected method | OnAnnotationPageImported | Fires the AnnotationPageImported event.
Protected method | OnAnnotationPageImporting | Fires the AnnotationPageImporting event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported.
Public event | AnnotationPageImported | Raised after a page of annotations has been imported.
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported.
Top
Remarks
Since this class is abstract, you can't use it directly.
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter Constructor

Initializes a new instance of the AnnotationImporter class

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AnnotationImporter()
Protected Sub New
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter Properties

The AnnotationImporter type exposes the following members.

Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so.
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations.
Public property | PageCount | Returns the total number of pages in a document.
Public property | Resolution | Sets or gets the resolution of the target for the annotations.
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions.
Public property | Units | Sets or gets the units of the target for the annotations.
Top
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.FailsafeAnnotationFactory Property

AnnotationImporterFailsafeAnnotationFactory Property

Gets or sets a delegate that is used to create annotations if an importer is unable to do so.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImporterFactory FailsafeAnnotationFactory { get; set; }
Public Property FailsafeAnnotationFactory As AnnotationImporterFactory
    Get
    Set

Property Value

Type: AnnotationImporterFactory
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LastErrors Property

AnnotationImporterLastErrors Property

Gets a collection of strings representing errors encountered while importing annotations.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringCollection LastErrors { get; }
Public ReadOnly Property LastErrors As StringCollection
    Get

Property Value

Type: StringCollection
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.PageCount Property

AnnotationImporterPageCount Property

Returns the total number of pages in a document.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32
Remarks
It is not necessary to call Load before accessing PageCount; this will happen automatically.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Resolution Property

AnnotationImporterResolution Property

Sets or gets the resolution of the target for the annotations.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; set; }
Public Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.ThrowOnError Property

AnnotationImporterThrowOnError Property

Gets or sets whether or not the importer will throw or suppress exceptions.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ThrowOnError { get; set; }
Public Property ThrowOnError As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Units Property

AnnotationImporterUnits Property

Sets or gets the units of the target for the annotations.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUnit Units { get; set; }
Public Property Units As AnnotationUnit
    Get
    Set

Property Value

Type: AnnotationUnit
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter Methods

The AnnotationImporter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new annotation importer associated with a given stream.
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as LayerCollection.
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation.
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations.
Public method | IsValidFormat | Indicates whether or not an AnnotationImporter can recognize a particular data format.
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount
Protected method | LLGetPageCount | The low-level implementation of PageCount
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection.
Protected method | LLImport(Int32, Int32) |
Protected method | LLLoad | The low-level implementation of Load
Public method | Load | The load method is used to allow an AnnotationImporter to load and to possibly cache annotations.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Fires the AnnotationImported event.
Protected method | OnAnnotationPageImported | Fires the AnnotationPageImported event.
Protected method | OnAnnotationPageImporting | Fires the AnnotationPageImporting event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.FromStream Method

AnnotationImporterFromStream Method

Constructs a new annotation importer associated with a given stream.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AnnotationImporter FromStream(
    Stream stm
)
Public MustOverride Function FromStream (
    stm As Stream
) As AnnotationImporter

Parameters

stm
Type: System.IOStream
A non-null stream containing annotation data.

Return Value

Type: AnnotationImporter
A new annotation importer for importing annotations.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.GetAnnotationCount Method

AnnotationImporterGetAnnotationCount Method

Returns the number of annotations on a conceptual page of a document.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetAnnotationCount(
    int page
)
Public Function GetAnnotationCount (
    page As Integer
) As Integer

Parameters

page
Type: SystemInt32
page is an integer that represents the conceptual zero based page index of a document. It will be range checked against the total number of pages in the document.

Return Value

Type: Int32
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Import Method

AnnotationImporterImport Method

Imports annotations from a source
Overload List
 | Name | Description
Public method | Import | Imports all annotations as LayerCollection.
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation.
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations.
Top
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Import Method

AnnotationImporterImport Method

Imports all annotations as LayerCollection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual LayerCollection Import()
Public Overridable Function Import As LayerCollection

Return Value

Type: LayerCollection
A new LayerCollection object representing annotations for the entire document. Each LayerAnnotation within the collection represents one page of annotations. If a page has no annotations, the LayerAnnotation will be non-null, but empty.
Remarks
Load must be called before any of the Import methods.
See Also

Reference

AnnotationImporter Class
Import Overload
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Import Method (Int32)

AnnotationImporterImport Method (Int32)

Imports a page of annotations as LayerAnnotation.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual LayerAnnotation Import(
    int page
)
Public Overridable Function Import (
    page As Integer
) As LayerAnnotation

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerAnnotation
A LayerAnnotation containing a set of annotations from the page.
See Also

Reference

AnnotationImporter Class
Import Overload
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Import Method (Int32, Int32)

AnnotationImporterImport Method (Int32, Int32)

Imports a single annotation from a given page of annotations.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AnnotationUI Import(
    int page,
    int annotIndex
)
Public Overridable Function Import (
    page As Integer,
    annotIndex As Integer
) As AnnotationUI

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.
annotIndex
Type: SystemInt32
The zero-based annotation which will be imported. annotIndex is range checked against the number of annotations of the page. The number of annotations on a page is available through GetAnnotationCount(Int32).

Return Value

Type: AnnotationUI
A single AnnotationUI object representing the imported annotation.
See Also

Reference

AnnotationImporter Class
Import Overload
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.IsValidFormat Method

AnnotationImporterIsValidFormat Method

Indicates whether or not an AnnotationImporter can recognize a particular data format.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool IsValidFormat(
    Stream stm
)
Public MustOverride Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream used to recognize file format.

Return Value

Type: Boolean
true indicates that the AnnotationImporter recognizes this format.
Remarks
The stream should be left in the same state on exit as on entrance.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LLGetAnnotationCount Method

AnnotationImporterLLGetAnnotationCount Method

Low level implementation of GetAnnotationCount

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LLGetAnnotationCount(
    int page
)
Protected MustOverride Function LLGetAnnotationCount (
    page As Integer
) As Integer

Parameters

page
Type: SystemInt32
A zero-based integer representing the page from which the annotations are being counted. Page will always be in range.

Return Value

Type: Int32
An integer representing the number of annotations on the page.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LLGetPageCount Method

AnnotationImporterLLGetPageCount Method

The low-level implementation of PageCount

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LLGetPageCount()
Protected MustOverride Function LLGetPageCount As Integer

Return Value

Type: Int32
Returns the number of pages in the document.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LLImport Method

AnnotationImporterLLImport Method

The low-level implementation of Import
The low-level implementation of Import
Overload List
 | Name | Description
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection.
Protected method | LLImport(Int32, Int32) |
Top
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LLImport Method (Int32)

AnnotationImporterLLImport Method (Int32)

Imports all annotations as LayerCollection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual LayerAnnotation LLImport(
    int page
)
Protected Overridable Function LLImport (
    page As Integer
) As LayerAnnotation

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerAnnotation
A LayerAnnotation containing a set of annotations from the page.
Remarks
page will always be in range.
See Also

Reference

AnnotationImporter Class
LLImport Overload
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LLImport Method (Int32, Int32)

AnnotationImporterLLImport Method (Int32, Int32)

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract AnnotationUI LLImport(
    int page,
    int annotIndex
)
Protected MustOverride Function LLImport (
    page As Integer,
    annotIndex As Integer
) As AnnotationUI

Parameters

page
Type: SystemInt32
annotIndex
Type: SystemInt32

Return Value

Type: AnnotationUI
See Also

Reference

AnnotationImporter Class
LLImport Overload
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.LLLoad Method

AnnotationImporterLLLoad Method

The low-level implementation of Load

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLLoad()
Protected MustOverride Sub LLLoad
Remarks
LLLoad should only ever be called once per stream.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.Load Method

AnnotationImporterLoad Method

The load method is used to allow an AnnotationImporter to load and to possibly cache annotations.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load()
Public Sub Load
Remarks
Load is called automatically by any method that needs to access internal annotation data (e.g., PageCount or Import). Load is present for clients who want to control when annotation data is specifically loaded.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.OnAnnotationImported Method

AnnotationImporterOnAnnotationImported Method

Fires the AnnotationImported event.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationImported(
    AnnotationImportEventArgs e
)
Protected Sub OnAnnotationImported (
    e As AnnotationImportEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UI.ImportersAnnotationImportEventArgs
The AnnotationImportEventArgs for this event
Remarks
This event is fired after an annotation has been imported.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.OnAnnotationPageImported Method

AnnotationImporterOnAnnotationPageImported Method

Fires the AnnotationPageImported event.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationPageImported(
    AnnotationPageImportEventArgs e
)
Protected Sub OnAnnotationPageImported (
    e As AnnotationPageImportEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UI.ImportersAnnotationPageImportEventArgs
The AnnotationPageImportEventArgs for this event.

Return Value

Type:
The event is fired after a page of annotations has been imported.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.OnAnnotationPageImporting Method

AnnotationImporterOnAnnotationPageImporting Method

Fires the AnnotationPageImporting event.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationPageImporting(
    AnnotationPageImportEventArgs e
)
Protected Sub OnAnnotationPageImporting (
    e As AnnotationPageImportEventArgs
)

Parameters

e
Type: Atalasoft.Annotate.UI.ImportersAnnotationPageImportEventArgs
The AnnotationPageImport events args for this event.

Return Value

Type:
This event is fired before a page of annotations will be imported.
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter Events

The AnnotationImporter type exposes the following members.

Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported.
Public event | AnnotationPageImported | Raised after a page of annotations has been imported.
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported.
Top
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.AnnotationImported Event

AnnotationImporterAnnotationImported Event

Raised after a single annotation has been imported.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationImportEventHandler AnnotationImported
Public Event AnnotationImported As AnnotationImportEventHandler

Value

Type: Atalasoft.Annotate.UI.ImportersAnnotationImportEventHandler
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.AnnotationPageImported Event

AnnotationImporterAnnotationPageImported Event

Raised after a page of annotations has been imported.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPageImportEventHandler AnnotationPageImported
Public Event AnnotationPageImported As AnnotationPageImportEventHandler

Value

Type: Atalasoft.Annotate.UI.ImportersAnnotationPageImportEventHandler
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporter.AnnotationPageImporting Event

AnnotationImporterAnnotationPageImporting Event

Raised before a page of annotations will be imported.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationPageImportEventHandler AnnotationPageImporting
Public Event AnnotationPageImporting As AnnotationPageImportEventHandler

Value

Type: Atalasoft.Annotate.UI.ImportersAnnotationPageImportEventHandler
See Also

Reference

AnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection Class

This is a collection used to contain a set of AnnotationImporter objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Annotate.UI.ImportersAnnotationImporterCollection

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationImporterCollection : CollectionBase
Public Class AnnotationImporterCollection
    Inherits CollectionBase

The AnnotationImporterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationImporterCollection | Constructs a new AnnotationImporterCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets or sets the element at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an AnnotationImporter to the end of the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns true if the collection contains a given AnnotationImporter.
Public method | CopyTo | Copies the entire contents of the collection to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Finds the index of a given AnnotationImporter within the collection.
Public method | Insert | Inserts an AnnotationImporter into the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes an AnnotationImporter from the colection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection Constructor

Constructs a new AnnotationImporterCollection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImporterCollection()
Public Sub New
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection Properties

The AnnotationImporterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets or sets the element at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.Item Property

AnnotationImporterCollectionItem Property

Gets or sets the element at the specified index.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImporter this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As AnnotationImporter
    Get
    Set

Parameters

index
Type: SystemInt32
The index.

Return Value

Type: AnnotationImporter
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection Methods

The AnnotationImporterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an AnnotationImporter to the end of the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns true if the collection contains a given AnnotationImporter.
Public method | CopyTo | Copies the entire contents of the collection to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Finds the index of a given AnnotationImporter within the collection.
Public method | Insert | Inserts an AnnotationImporter into the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes an AnnotationImporter from the colection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.Add Method

AnnotationImporterCollectionAdd Method

Adds an AnnotationImporter to the end of the collection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    AnnotationImporter value
)
Public Function Add (
    value As AnnotationImporter
) As Integer

Parameters

value
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter to add.

Return Value

Type: Int32
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.Contains Method

AnnotationImporterCollectionContains Method

Returns true if the collection contains a given AnnotationImporter.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    AnnotationImporter value
)
Public Function Contains (
    value As AnnotationImporter
) As Boolean

Parameters

value
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImported that to search for.

Return Value

Type: Boolean
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.CopyTo Method

AnnotationImporterCollectionCopyTo Method

Copies the entire contents of the collection to an array.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    AnnotationImporter[] array,
    int index
)
Public Sub CopyTo (
    array As AnnotationImporter(),
    index As Integer
)

Parameters

array
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The array that will be used for copying.
index
Type: SystemInt32
The start of the array.
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.IndexOf Method

AnnotationImporterCollectionIndexOf Method

Finds the index of a given AnnotationImporter within the collection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    AnnotationImporter value
)
Public Function IndexOf (
    value As AnnotationImporter
) As Integer

Parameters

value
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter to find.

Return Value

Type: Int32
A value 0 or greater if the AnnotationImporter was found, less than zero if not.
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.Insert Method

AnnotationImporterCollectionInsert Method

Inserts an AnnotationImporter into the collection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AnnotationImporter value
)
Public Sub Insert (
    index As Integer,
    value As AnnotationImporter
)

Parameters

index
Type: SystemInt32
The index before which the AnnotationImporter will be inserted.
value
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter to insert.
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterCollection.Remove Method

AnnotationImporterCollectionRemove Method

Removes an AnnotationImporter from the colection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AnnotationImporter value
)
Public Sub Remove (
    value As AnnotationImporter
)

Parameters

value
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter to remove.
See Also

Reference

AnnotationImporterCollection Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImporterFactory Delegate

A delegate for constructing annotations from data that a given AnnotationImporter doesn't understand.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate AnnotationUI AnnotationImporterFactory(
    AnnotationImporter importer,
    RectangleF location,
    Object data
)
Public Delegate Function AnnotationImporterFactory (
    importer As AnnotationImporter,
    location As RectangleF,
    data As Object
) As AnnotationUI

Parameters

importer
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter that attempted to import the annotation
location
Type: System.DrawingRectangleF
The location on the target page where the annotation will go
data
Type: SystemObject
The data used to construct the annotation.

Return Value

Type: AnnotationUI
A new AnnotationUI object or null. If the delegate returns null, this annotation is ignored.
Remarks
The data object will be specific to a given type of AnnotationImporter.
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs Class

An object representing information about an annotation being imported.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UI.ImportersAnnotationImportEventArgs

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationImportEventArgs : EventArgs
Public Class AnnotationImportEventArgs
    Inherits EventArgs

The AnnotationImportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationImportEventArgs | Constructs a new AnnotationImportEventArgs object.
Top
Properties
 | Name | Description
Public property | Annotation | Gets the AnnotationImporter that has imported the annotation.
Public property | AnnotationIndex | Gets the index on the page of the AnnotationUI object.
Public property | Importer | Gets the index on the page of the AnnotationUI object.
Public property | Page | Gets the index on the page of the AnnotationUI object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs Constructor

Constructs a new AnnotationImportEventArgs object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImportEventArgs(
    AnnotationImporter importer,
    AnnotationUI annotation,
    int page,
    int annotIndex
)
Public Sub New (
    importer As AnnotationImporter,
    annotation As AnnotationUI,
    page As Integer,
    annotIndex As Integer
)

Parameters

importer
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter that has imported the annotation.
annotation
Type: Atalasoft.Annotate.UIAnnotationUI
The AnnotationUI object that was imported.
page
Type: SystemInt32
The page from which the AnnotationUI object was imported.
annotIndex
Type: SystemInt32
The index on the page of the AnnotationUI object.
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs Properties

The AnnotationImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Annotation | Gets the AnnotationImporter that has imported the annotation.
Public property | AnnotationIndex | Gets the index on the page of the AnnotationUI object.
Public property | Importer | Gets the index on the page of the AnnotationUI object.
Public property | Page | Gets the index on the page of the AnnotationUI object.
Top
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs.Annotation Property

AnnotationImportEventArgsAnnotation Property

Gets the AnnotationImporter that has imported the annotation.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI Annotation { get; }
Public ReadOnly Property Annotation As AnnotationUI
    Get

Property Value

Type: AnnotationUI
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs.AnnotationIndex Property

AnnotationImportEventArgsAnnotationIndex Property

Gets the index on the page of the AnnotationUI object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AnnotationIndex { get; }
Public ReadOnly Property AnnotationIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs.Importer Property

AnnotationImportEventArgsImporter Property

Gets the index on the page of the AnnotationUI object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImporter Importer { get; }
Public ReadOnly Property Importer As AnnotationImporter
    Get

Property Value

Type: AnnotationImporter
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs.Page Property

AnnotationImportEventArgsPage Property

Gets the index on the page of the AnnotationUI object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Page { get; }
Public ReadOnly Property Page As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventArgs Methods

The AnnotationImportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationImportEventHandler Delegate

Defines a handler to be called on annotation import.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationImportEventHandler(
    Object sender,
    AnnotationImportEventArgs args
)
Public Delegate Sub AnnotationImportEventHandler (
    sender As Object,
    args As AnnotationImportEventArgs
)

Parameters

sender
Type: SystemObject
The sender of the event.
args
Type: Atalasoft.Annotate.UI.ImportersAnnotationImportEventArgs
The AnnotationImportEventArgs instance containing the event data.
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs Class

An object representing information about a page of annotations being imported.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.UI.ImportersAnnotationPageImportEventArgs

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationPageImportEventArgs : EventArgs
Public Class AnnotationPageImportEventArgs
    Inherits EventArgs

The AnnotationPageImportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPageImportEventArgs | Constructs a new AnnotationPageImportEventArgs object.
Top
Properties
 | Name | Description
Public property | Importer | Gets the AnnotationImporter importing the page.
Public property | Layer | Gets the layer of annotations imported.
Public property | Page | Gets the page number of the annotations being imported.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs Constructor

Constructs a new AnnotationPageImportEventArgs object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPageImportEventArgs(
    AnnotationImporter importer,
    LayerAnnotation layer,
    int page
)
Public Sub New (
    importer As AnnotationImporter,
    layer As LayerAnnotation,
    page As Integer
)

Parameters

importer
Type: Atalasoft.Annotate.UI.ImportersAnnotationImporter
The AnnotationImporter importing the page.
layer
Type: Atalasoft.Annotate.UILayerAnnotation
The layer of annotations imported.
page
Type: SystemInt32
The page number of the annotations being imported.
See Also

Reference

AnnotationPageImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs Properties

The AnnotationPageImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Importer | Gets the AnnotationImporter importing the page.
Public property | Layer | Gets the layer of annotations imported.
Public property | Page | Gets the page number of the annotations being imported.
Top
See Also

Reference

AnnotationPageImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs.Importer Property

AnnotationPageImportEventArgsImporter Property

Gets the AnnotationImporter importing the page.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImporter Importer { get; }
Public ReadOnly Property Importer As AnnotationImporter
    Get

Property Value

Type: AnnotationImporter
See Also

Reference

AnnotationPageImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs.Layer Property

AnnotationPageImportEventArgsLayer Property

Gets the layer of annotations imported.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation Layer { get; }
Public ReadOnly Property Layer As LayerAnnotation
    Get

Property Value

Type: LayerAnnotation
See Also

Reference

AnnotationPageImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs.Page Property

AnnotationPageImportEventArgsPage Property

Gets the page number of the annotations being imported.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Page { get; }
Public ReadOnly Property Page As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AnnotationPageImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventArgs Methods

The AnnotationPageImportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationPageImportEventArgs Class
Atalasoft.Annotate.UI.Importers Namespace


AnnotationPageImportEventHandler Delegate

Defines a handler to be called on annotation page import.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationPageImportEventHandler(
    Object sender,
    AnnotationPageImportEventArgs args
)
Public Delegate Sub AnnotationPageImportEventHandler (
    sender As Object,
    args As AnnotationPageImportEventArgs
)

Parameters

sender
Type: SystemObject
The sender.
args
Type: Atalasoft.Annotate.UI.ImportersAnnotationPageImportEventArgs
The AnnotationPageImportEventArgs instance containing the event data.
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Class

Note: This API is now obsolete.

Constructs a new PdfAnnotationImporter object.

This class is obsolete: Use PdfAnnotationDataImporter instead.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UI.ImportersAnnotationImporter
Atalasoft.Annotate.UI.ImportersPdfAnnotationImporter

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("PdfAnnotationImporter may be removed from a future release. Use PdfAnnotationDataImporter instead.",
    false)]
public class PdfAnnotationImporter : AnnotationImporter
<ObsoleteAttribute("PdfAnnotationImporter may be removed from a future release. Use PdfAnnotationDataImporter instead.",
    false)>
Public Class PdfAnnotationImporter
    Inherits AnnotationImporter

The PdfAnnotationImporter type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationImporter | Initializes a new instance of the PdfAnnotationImporter class.
Public method | PdfAnnotationImporter(Stream) | Constructs a new PdfAnnotationImporterObject for the given stream.
Top
Properties
 | Name | Description
Public property | AnnotationStream | The stream which contains the annotation information.
Public property | Factories |
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationImporter.)
Public property | PageCount | Returns the total number of pages in a document. (Inherited from AnnotationImporter.)
Public property | Resolution | Sets or gets the resolution of the target for the annotations. (Inherited from AnnotationImporter.)
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationImporter.)
Public property | Units | Sets or gets the units of the target for the annotations. (Inherited from AnnotationImporter.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Returns a new PdfAnnotationImporter object attached to the given Stream. (Overrides AnnotationImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation. (Overrides AnnotationImporterImport(Int32).)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationImporter.)
Public method | IsValidFormat | Indicates whether or not the stream is a PDF. (Overrides AnnotationImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | (Overrides AnnotationImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | (Overrides AnnotationImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationImporterLLImport(Int32, Int32).)
Protected method | LLLoad | (Overrides AnnotationImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationImporter to load and to possibly cache annotations. (Inherited from AnnotationImporter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Fires the AnnotationImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImported | Fires the AnnotationPageImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImporting | Fires the AnnotationPageImporting event. (Inherited from AnnotationImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationImporter.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Constructor

Overload List
 | Name | Description
Public method | PdfAnnotationImporter | Initializes a new instance of the PdfAnnotationImporter class.
Public method | PdfAnnotationImporter(Stream) | Constructs a new PdfAnnotationImporterObject for the given stream.
Top
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Constructor

Initializes a new instance of the PdfAnnotationImporter class.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationImporter()
Public Sub New
See Also

Reference

PdfAnnotationImporter Class
PdfAnnotationImporter Overload
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Constructor (Stream)

Constructs a new PdfAnnotationImporterObject for the given stream.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationImporter(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
See Also

Reference

PdfAnnotationImporter Class
PdfAnnotationImporter Overload
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Properties

The PdfAnnotationImporter type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationStream | The stream which contains the annotation information.
Public property | Factories |
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationImporter.)
Public property | PageCount | Returns the total number of pages in a document. (Inherited from AnnotationImporter.)
Public property | Resolution | Sets or gets the resolution of the target for the annotations. (Inherited from AnnotationImporter.)
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationImporter.)
Public property | Units | Sets or gets the units of the target for the annotations. (Inherited from AnnotationImporter.)
Top
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.AnnotationStream Property

PdfAnnotationImporterAnnotationStream Property

The stream which contains the annotation information.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream AnnotationStream { get; set; }
Public Property AnnotationStream As Stream
    Get
    Set

Property Value

Type: Stream
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.Factories Property

PdfAnnotationImporterFactories Property

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUIFactoryCollection Factories { get; set; }
Public Property Factories As AnnotationUIFactoryCollection
    Get
    Set

Property Value

Type: AnnotationUIFactoryCollection
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Methods

The PdfAnnotationImporter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Returns a new PdfAnnotationImporter object attached to the given Stream. (Overrides AnnotationImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation. (Overrides AnnotationImporterImport(Int32).)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationImporter.)
Public method | IsValidFormat | Indicates whether or not the stream is a PDF. (Overrides AnnotationImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | (Overrides AnnotationImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | (Overrides AnnotationImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationImporterLLImport(Int32, Int32).)
Protected method | LLLoad | (Overrides AnnotationImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationImporter to load and to possibly cache annotations. (Inherited from AnnotationImporter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Fires the AnnotationImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImported | Fires the AnnotationPageImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImporting | Fires the AnnotationPageImporting event. (Inherited from AnnotationImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.FromStream Method

PdfAnnotationImporterFromStream Method

Returns a new PdfAnnotationImporter object attached to the given Stream.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationImporter FromStream(
    Stream stm
)
Public Overrides Function FromStream (
    stm As Stream
) As AnnotationImporter

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.

Return Value

Type: AnnotationImporter
Exceptions
Exception | Condition
 | Thrown if the stm argument is null (Nothing in VB).
 | Thrown if the stream is not seekable.
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.Import Method

PdfAnnotationImporterImport Method

Imports annotations from a source
Imports annotations from a stream.
Overload List
 | Name | Description
Public method | Import | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation. (Overrides AnnotationImporterImport(Int32).)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationImporter.)
Top
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.Import Method (Int32)

PdfAnnotationImporterImport Method (Int32)

Imports a page of annotations as LayerAnnotation.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override LayerAnnotation Import(
    int pageNo
)
Public Overrides Function Import (
    pageNo As Integer
) As LayerAnnotation

Parameters

pageNo
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerAnnotation
A LayerAnnotation containing a set of annotations from the page, or null
See Also

Reference

PdfAnnotationImporter Class
Import Overload
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.IsValidFormat Method

PdfAnnotationImporterIsValidFormat Method

Indicates whether or not the stream is a PDF.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stm
)
Public Overrides Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream.

Return Value

Type: Boolean
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.LLGetAnnotationCount Method

PdfAnnotationImporterLLGetAnnotationCount Method

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetAnnotationCount(
    int pageNo
)
Protected Overrides Function LLGetAnnotationCount (
    pageNo As Integer
) As Integer

Parameters

pageNo
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.LLGetPageCount Method

PdfAnnotationImporterLLGetPageCount Method

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetPageCount()
Protected Overrides Function LLGetPageCount As Integer

Return Value

Type: Int32
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.LLImport Method

PdfAnnotationImporterLLImport Method

The low-level implementation of Import
Overload List
 | Name | Description
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationImporterLLImport(Int32, Int32).)
Top
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.LLImport Method (Int32, Int32)

PdfAnnotationImporterLLImport Method (Int32, Int32)

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationUI LLImport(
    int pageNo,
    int annotIndex
)
Protected Overrides Function LLImport (
    pageNo As Integer,
    annotIndex As Integer
) As AnnotationUI

Parameters

pageNo
Type: SystemInt32
annotIndex
Type: SystemInt32

Return Value

Type: AnnotationUI
See Also

Reference

PdfAnnotationImporter Class
LLImport Overload
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter.LLLoad Method

PdfAnnotationImporterLLLoad Method

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLLoad()
Protected Overrides Sub LLLoad
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


PdfAnnotationImporter Events

The PdfAnnotationImporter type exposes the following members.

Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationImporter.)
Top
See Also

Reference

PdfAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Class

Note: This API is now obsolete.

Summary description for XmpImporter.

An object for importing annotations from a stream of XMP data.

This class is obsolete: Use XmpAnnotationDataImporter instead.

Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.UI.ImportersAnnotationImporter
Atalasoft.Annotate.UI.ImportersXmpAnnotationImporter

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("XmpAnnotationImporter may be removed in a future release. Use XmpAnnotationDataImporter instead.",
    false)]
public class XmpAnnotationImporter : AnnotationImporter
<ObsoleteAttribute("XmpAnnotationImporter may be removed in a future release. Use XmpAnnotationDataImporter instead.",
    false)>
Public Class XmpAnnotationImporter
    Inherits AnnotationImporter

The XmpAnnotationImporter type exposes the following members.

Constructors
 | Name | Description
Public method | XmpAnnotationImporter(AnnotationController) | Constructs a new XmpAnnotationImporter object.
Public method | XmpAnnotationImporter(AnnotationController, Stream) | Constructs a new XmpAnnotationImporter object.
Top
Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationImporter.)
Public property | PageCount | Returns the total number of pages in a document. (Inherited from AnnotationImporter.)
Public property | Resolution | Sets or gets the resolution of the target for the annotations. (Inherited from AnnotationImporter.)
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationImporter.)
Public property | Units | Sets or gets the units of the target for the annotations. (Inherited from AnnotationImporter.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new XmpAnnotationImporter for the given stream. (Overrides AnnotationImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation. (Inherited from AnnotationImporter.)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationImporter.)
Public method | IsValidFormat | Indicates if the stream contains XMP data. (Overrides AnnotationImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount (Overrides AnnotationImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | The low-level implementation of PageCount (Overrides AnnotationImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection. (Overrides AnnotationImporterLLImport(Int32).)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationImporterLLImport(Int32, Int32).)
Protected method | LLLoad | The low-level implementation of Load (Overrides AnnotationImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationImporter to load and to possibly cache annotations. (Inherited from AnnotationImporter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Fires the AnnotationImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImported | Fires the AnnotationPageImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImporting | Fires the AnnotationPageImporting event. (Inherited from AnnotationImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationImporter.)
Top
See Also

Reference

Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Constructor

Constructs a new XmpAnnotationImporter object.
Overload List
 | Name | Description
Public method | XmpAnnotationImporter(AnnotationController) | Constructs a new XmpAnnotationImporter object.
Public method | XmpAnnotationImporter(AnnotationController, Stream) | Constructs a new XmpAnnotationImporter object.
Top
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Constructor (AnnotationController)

Constructs a new XmpAnnotationImporter object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpAnnotationImporter(
    AnnotationController controller
)
Public Sub New (
    controller As AnnotationController
)

Parameters

controller
Type: Atalasoft.Annotate.UIAnnotationController
A hosting AnnotationController object.
See Also

Reference

XmpAnnotationImporter Class
XmpAnnotationImporter Overload
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Constructor (AnnotationController, Stream)

Constructs a new XmpAnnotationImporter object.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpAnnotationImporter(
    AnnotationController controller,
    Stream stm
)
Public Sub New (
    controller As AnnotationController,
    stm As Stream
)

Parameters

controller
Type: Atalasoft.Annotate.UIAnnotationController
A hosting AnnotationController object.
stm
Type: System.IOStream
A stream from which annotations will be imported.
See Also

Reference

XmpAnnotationImporter Class
XmpAnnotationImporter Overload
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Properties

The XmpAnnotationImporter type exposes the following members.

Properties
 | Name | Description
Public property | FailsafeAnnotationFactory | Gets or sets a delegate that is used to create annotations if an importer is unable to do so. (Inherited from AnnotationImporter.)
Public property | LastErrors | Gets a collection of strings representing errors encountered while importing annotations. (Inherited from AnnotationImporter.)
Public property | PageCount | Returns the total number of pages in a document. (Inherited from AnnotationImporter.)
Public property | Resolution | Sets or gets the resolution of the target for the annotations. (Inherited from AnnotationImporter.)
Public property | ThrowOnError | Gets or sets whether or not the importer will throw or suppress exceptions. (Inherited from AnnotationImporter.)
Public property | Units | Sets or gets the units of the target for the annotations. (Inherited from AnnotationImporter.)
Top
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Methods

The XmpAnnotationImporter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStream | Constructs a new XmpAnnotationImporter for the given stream. (Overrides AnnotationImporterFromStream(Stream).)
Public method | GetAnnotationCount | Returns the number of annotations on a conceptual page of a document. (Inherited from AnnotationImporter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports all annotations as LayerCollection. (Inherited from AnnotationImporter.)
Public method | Import(Int32) | Imports a page of annotations as LayerAnnotation. (Inherited from AnnotationImporter.)
Public method | Import(Int32, Int32) | Imports a single annotation from a given page of annotations. (Inherited from AnnotationImporter.)
Public method | IsValidFormat | Indicates if the stream contains XMP data. (Overrides AnnotationImporterIsValidFormat(Stream).)
Protected method | LLGetAnnotationCount | Low level implementation of GetAnnotationCount (Overrides AnnotationImporterLLGetAnnotationCount(Int32).)
Protected method | LLGetPageCount | The low-level implementation of PageCount (Overrides AnnotationImporterLLGetPageCount.)
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection. (Overrides AnnotationImporterLLImport(Int32).)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationImporterLLImport(Int32, Int32).)
Protected method | LLLoad | The low-level implementation of Load (Overrides AnnotationImporterLLLoad.)
Public method | Load | The load method is used to allow an AnnotationImporter to load and to possibly cache annotations. (Inherited from AnnotationImporter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationImported | Fires the AnnotationImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImported | Fires the AnnotationPageImported event. (Inherited from AnnotationImporter.)
Protected method | OnAnnotationPageImporting | Fires the AnnotationPageImporting event. (Inherited from AnnotationImporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.FromStream Method

XmpAnnotationImporterFromStream Method

Constructs a new XmpAnnotationImporter for the given stream.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AnnotationImporter FromStream(
    Stream stm
)
Public Overrides Function FromStream (
    stm As Stream
) As AnnotationImporter

Parameters

stm
Type: System.IOStream
A non-null stream containing XMP data.

Return Value

Type: AnnotationImporter
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.IsValidFormat Method

XmpAnnotationImporterIsValidFormat Method

Indicates if the stream contains XMP data.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stm
)
Public Overrides Function IsValidFormat (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
A non-null stream containing XMP data.

Return Value

Type: Boolean
Returns true if the stream contains XMP data; false otherwise.
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.LLGetAnnotationCount Method

XmpAnnotationImporterLLGetAnnotationCount Method

Low level implementation of GetAnnotationCount

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetAnnotationCount(
    int page
)
Protected Overrides Function LLGetAnnotationCount (
    page As Integer
) As Integer

Parameters

page
Type: SystemInt32
A zero-based integer representing the page from which the annotations are being counted. Page will always be in range.

Return Value

Type: Int32
An integer representing the number of annotations on the page.
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.LLGetPageCount Method

XmpAnnotationImporterLLGetPageCount Method

The low-level implementation of PageCount

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetPageCount()
Protected Overrides Function LLGetPageCount As Integer

Return Value

Type: Int32
Returns the number of pages in the document.
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.LLImport Method

XmpAnnotationImporterLLImport Method

The low-level implementation of Import
The low-level implementation of Import
Overload List
 | Name | Description
Protected method | LLImport(Int32) | Imports all annotations as LayerCollection. (Overrides AnnotationImporterLLImport(Int32).)
Protected method | LLImport(Int32, Int32) | (Overrides AnnotationImporterLLImport(Int32, Int32).)
Top
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.LLImport Method (Int32)

XmpAnnotationImporterLLImport Method (Int32)

Imports all annotations as LayerCollection.

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override LayerAnnotation LLImport(
    int page
)
Protected Overrides Function LLImport (
    page As Integer
) As LayerAnnotation

Parameters

page
Type: SystemInt32
The zero-based page from which annotations will be imported. page is range checked against the document.

Return Value

Type: LayerAnnotation
A LayerAnnotation containing a set of annotations from the page.
Remarks
page will always be in range.
See Also

Reference

XmpAnnotationImporter Class
LLImport Overload
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.LLImport Method (Int32, Int32)

XmpAnnotationImporterLLImport Method (Int32, Int32)

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationUI LLImport(
    int page,
    int annotIndex
)
Protected Overrides Function LLImport (
    page As Integer,
    annotIndex As Integer
) As AnnotationUI

Parameters

page
Type: SystemInt32
annotIndex
Type: SystemInt32

Return Value

Type: AnnotationUI
See Also

Reference

XmpAnnotationImporter Class
LLImport Overload
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter.LLLoad Method

XmpAnnotationImporterLLLoad Method

The low-level implementation of Load

Namespace: Atalasoft.Annotate.UI.Importers
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLLoad()
Protected Overrides Sub LLLoad
Exceptions
Exception | Condition
CodecException | Xmp data stream is neither JPEG nor TIFF.
Remarks
LLLoad should only ever be called once per stream.
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


XmpAnnotationImporter Events

The XmpAnnotationImporter type exposes the following members.

Events
 | Name | Description
Public event | AnnotationImported | Raised after a single annotation has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImported | Raised after a page of annotations has been imported. (Inherited from AnnotationImporter.)
Public event | AnnotationPageImporting | Raised before a page of annotations will be imported. (Inherited from AnnotationImporter.)
Top
See Also

Reference

XmpAnnotationImporter Class
Atalasoft.Annotate.UI.Importers Namespace


Atalasoft.Annotate.Wpf Namespace

Classes
 | Class | Description
Public class | AtalaAnnotationViewer | This control is used to view and annotate images in a WPF environment. It contains an AtalaImageViewer (accessed through the ImageViewer property) and a WpfAnnotationCanvas (accessed through the Annotations property).
Public class | CollectionChangedEventArgsT | This class is used to indicate changes made to a collection.
Public class | EventArgsT | This class is a generic version of EventArgs.
Public class | GripMoveRequest | This class holds information for a grip move operation request.
Public class | MoveAnnotationRequest | This class hold information for a move request.
Public class | OperationRequestInformation | This class is used to send an operation request to an annotation.
Public class | RotateAnnotationRequest | This class holds information for a rotate request.
Public class | ValueChangedEventArgsT | This class is used to indicate that a value has changed.
Public class | WpfAnnotationCanvas | The WpfAnnotationCanvas is a Canvas object used to render annotations. This class is similar to the AnnotationController used in DotImage.
Public class | WpfAnnotationCursors | AnnotationCursors is a used to hold all of the Cursor objects for the annotations. This simplifies changing the appearance of the cursors.
Public class | WpfAnnotationGrip | This class represents a single grip.
Public class | WpfAnnotationGrips | This is the base grips class used for annotations.
Public class | WpfAnnotationSpaceConverter | This class is used to convert between viewer, document and annotation space.
Public class | WpfAnnotationUI | This is the base class for all WPF annotations.
Public class | WpfAnnotationUICollection | This class is a collection of WpfAnnotationUI objects.
Public class | WpfAnnotationUIEnumerator | This class is returned by WpfAnnotationUICollection.GetEnumerator to enumerate through the annotation collection.
Public class | WpfAnnotationUIFactoryT, TData | This class is the default annotation factory used by all WPF annotations provided.
Public class | WpfAnnotationUIFactoryCollection | This class holds the annotation UI factories used when deserializing AnnotationData objects.
Public class | WpfCalloutAnnotation | This annotation is designed to provide additional information on a specific area of the document. It contains an editable text area and a leader line used to point to the area of the document. When creating this annotation, the first click sets the target for the leader and centers the annotation over the target. With the mouse still pressed, drag the annotation to the desired location. Both annotation and leader point can be repositioned independently after the annotation has been created.
Public class | WpfEllipseAnnotation | This class is used to create an elliptical annotation.
Public class | WpfEmbeddedImageAnnotation | This is an image annotation that will embed the image into the serialized XMP or WANG data.
Public class | WpfFreehandAnnotation | This class is used for a freehand annotation.
Public class | WpfHotSpotAnnotation | This annotations can be used to add rectangular hot spots on a document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked. For a non-rectangular area use the WpfHotSpotFreehandAnnotation.
Public class | WpfHotSpotFreehandAnnotation | This annotation can be used to create a freehand hot spot area on the document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked. For a rectangular hot spot use the WpfHotSpotAnnotation.
Public class | WpfLayerAnnotation | A WpfLayerAnnotation is a collection of other annotations, including other WpfLayerAnnotation objects.
Public class | WpfLayerAnnotationEnumerator | This class is used to enumerate the WpfLayerCollection.
Public class | WpfLayerCollection | This class holds a collection of WpfLayerAnnotation objects, each containing the visible annotations.
Public class | WpfLineAnnotation | This is a single line annotation from StartPoint to EndPoint.
Public class | WpfLinesAnnotation | The WpfLinesAnnoation represents a series of points connected by straight lines.
Public class | WpfObjectConverter | This class contains helpful methods for converting between System.Drawing and System.Windows.Media objects. There are also methods for converting DotImage classes into System.Windows.Media objects.
Public class | WpfPointBaseAnnotation | WpfPointBaseAnnotation is an abstract class from which all point base annotations derive. This reduces the amount of code required to create this annotations.
Public class | WpfPointCollection | A Collection of Point objects for use in WPF
Public class | WpfPolygonAnnotation | A WpfPolygonAnnotation is a series of points used to draw a polygon with an optional fill.
Public class | WpfRectangleAnnotation | This is a rectangular annotation with an optional shadow brush.
Public class | WpfRectangleGrips | This class represents a group of WpfAnnotationGrip objects for rectangular shaped annotations.
Public class | WpfReferencedImageAnnotation | This annotation references a local image by filename. When viewing this annotation on multiple systems, the image file must be provided at the same location of each system.
Public class | WpfRubberStampAnnotation | This annotation provides a text message with a rounded rectangle outline similar to a rubber stamp.
Public class | WpfTextAnnotation | This annotation displays text which can be edited by the user.
Interfaces
 | Interface | Description
Public interface | IWpfAnnotationUIFactory | This interface is implemented by factory classes used to create annotations from AnnotationData.
Enumerations
 | Enumeration | Description
Public enumeration | WpfAnnotationGripAction | Indicates the action performed by a grip.
Public enumeration | WpfAnnotationGripMode | Indicates whether rectangular or point grips are used for point based annotations.
Public enumeration | WpfAnnotationOperationRequests | Indicates the operation requested on the annotation.
Public enumeration | WpfAnnotationSelectionMode | Indicates whether the WpfAnnotationCanvas should perform single or multiple selections.
Public enumeration | WpfFreehandLineType | Indicates the freehand line style.
Public enumeration | WpfGripHotZoneAction | Indicates the action for a zone grip.
Public enumeration | WpfRectangleGrip | Identifies the rectangular grip.
Public enumeration | WpfRectangleGripRotationMode | Indicates the grip rotation behavior.
Public enumeration | WpfVisualScaleMode | Indicates the type of scaling performed by the GenerateVisual and CreateVisual methods.


AtalaAnnotationViewer Class

This control is used to view and annotate images in a WPF environment. It contains an AtalaImageViewer (accessed through the ImageViewer property) and a WpfAnnotationCanvas (accessed through the Annotations property).
AtalaAnnotationViewer
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Atalasoft.Annotate.WpfAtalaAnnotationViewer

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaAnnotationViewer : UserControl,
    IComponentConnector
Public Class AtalaAnnotationViewer
    Inherits UserControl
    Implements IComponentConnector

The AtalaAnnotationViewer type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaAnnotationViewer | Creates a new instance of AtalaAnnotationViewer.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Annotations | Gets the WpfAnnotationCanvas used for hosting the annotations.
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoLoadWang | Gets or sets a value indicating whether WANG annotations are automatically loaded in the Open method.
Public property | AutoLoadXmp | Gets or sets a value indicating whether XMP annotations are automatically loaded in the Open method.
Public property | AutoSaveWang | Gets or sets a value indicating whether WANG annotations are automatically saved for TIFF files in the Save method.
Public property | AutoSaveXmp | Gets or sets a value indicating whether XMP annotations are automatically saved for JPEG and TIFF files in the Save method.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageViewer | Gets the AtalaImageViewer used for viewing the image.
Public property | Importers | Gets a list of AnnotationDataImporter objects used to import annotations from an image.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | Burn | Burns all annotations onto the current image.
Public method | Burn(AtalaImage) | Burns all annotations along with the specified image.
Public method | Burn(WpfAnnotationUI, AtalaImage) | Burns the specified annotation along with the specified image.
Public method | Burn(WpfAnnotationUICollection, AtalaImage) | Burns the annotations in the provided collection along with the specified image.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateVisual | Returns a Visual object of the annotations and current image. This is useful for printing annotations or saving them to XPS documents.
Public method | CreateVisual(Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the annotations and current image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImporter | Returns the AnnotationDataImporter for the specified stream.
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | ImportAnnotations | This method loads annotations from the provided importer into a WpfLayerAnnotation, which is then added to the layer collection.
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | Open(Stream, Int32, ProgressEventHandler) | Opens an image from a stream along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).
Public method | Open(String, Int32, ProgressEventHandler) | Opens an image from a file along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RotateDocument(DocumentRotation) | Rotates the document and its annotations.
Public method | RotateDocument(DocumentRotation, WpfLayerAnnotation) | Rotates the specified LayerAnnotation by the given DocumentRotation.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the document at the given layer index by the given DocumentRotation.
Public method | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AutoLoadWangProperty | Identifies the AutoLoadWang dependency property.
AutoLoadXmpProperty | Identifies the AutoLoadXmp dependency property.
AutoSaveWangProperty | Identifies the AutoSaveWang dependency property.
AutoSaveXmpProperty | Identifies the AutoSaveXmp dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer Constructor

Creates a new instance of AtalaAnnotationViewer.
Creates a new instance of AtalaAnnotationViewer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaAnnotationViewer()
Public Sub New
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer Properties

The AtalaAnnotationViewer type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Annotations | Gets the WpfAnnotationCanvas used for hosting the annotations.
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoLoadWang | Gets or sets a value indicating whether WANG annotations are automatically loaded in the Open method.
Public property | AutoLoadXmp | Gets or sets a value indicating whether XMP annotations are automatically loaded in the Open method.
Public property | AutoSaveWang | Gets or sets a value indicating whether WANG annotations are automatically saved for TIFF files in the Save method.
Public property | AutoSaveXmp | Gets or sets a value indicating whether XMP annotations are automatically saved for JPEG and TIFF files in the Save method.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageViewer | Gets the AtalaImageViewer used for viewing the image.
Public property | Importers | Gets a list of AnnotationDataImporter objects used to import annotations from an image.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Annotations Property

AtalaAnnotationViewerAnnotations Property

Gets the WpfAnnotationCanvas used for hosting the annotations.
Gets the WpfAnnotationCanvas used for hosting the annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationCanvas Annotations { get; }
Public ReadOnly Property Annotations As WpfAnnotationCanvas
    Get

Property Value

Type: WpfAnnotationCanvas
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoLoadWang Property

AtalaAnnotationViewerAutoLoadWang Property

Gets or sets a value indicating whether WANG annotations are automatically loaded in the Open method.
Gets or sets a value indicating whether WANG annotations are automatically loaded in the Open(String, Int32, ProgressEventHandler) method.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoLoadWang { get; set; }
Public Property AutoLoadWang As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether WANG annotations are automatically loaded in the Open method.

Property Value

Type: Boolean
Indicates whether WANG annotations are automatically loaded in the Open(String, Int32, ProgressEventHandler) method.
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoLoadXmp Property

AtalaAnnotationViewerAutoLoadXmp Property

Gets or sets a value indicating whether XMP annotations are automatically loaded in the Open method.
Gets or sets a value indicating whether XMP annotations are automatically loaded in the Open(String, Int32, ProgressEventHandler) method.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoLoadXmp { get; set; }
Public Property AutoLoadXmp As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether XMP annotations are automatically loaded in the Open method.

Property Value

Type: Boolean
Indicates whether XMP annotations are automatically loaded in the Open(String, Int32, ProgressEventHandler) method.
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoSaveWang Property

AtalaAnnotationViewerAutoSaveWang Property

Gets or sets a value indicating whether WANG annotations are automatically saved for TIFF files in the Save method.
Gets or sets a value indicating whether WANG annotations are automatically saved for TIFF files in the Save(String, ImageEncoder, ProgressEventHandler) method.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSaveWang { get; set; }
Public Property AutoSaveWang As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether WANG annotations are automatically saved in the Save method.

Property Value

Type: Boolean
Indicates whether WANG annotations are automatically saved in the Save(String, ImageEncoder, ProgressEventHandler) method.
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoSaveXmp Property

AtalaAnnotationViewerAutoSaveXmp Property

Gets or sets a value indicating whether XMP annotations are automatically saved for JPEG and TIFF files in the Save method.
Gets or sets a value indicating whether XMP annotations are automatically saved for JPEG and TIFF files in the Save(String, ImageEncoder, ProgressEventHandler) method.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoSaveXmp { get; set; }
Public Property AutoSaveXmp As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether XMP annotations are automatically saved in the Save method.

Property Value

Type: Boolean
Indicates whether XMP annotations are automatically saved in the Save(String, ImageEncoder, ProgressEventHandler) method.
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.ImageViewer Property

AtalaAnnotationViewerImageViewer Property

Gets the AtalaImageViewer used for viewing the image.
Gets the AtalaImageViewer used for viewing the image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageViewer ImageViewer { get; }
Public ReadOnly Property ImageViewer As AtalaImageViewer
    Get

Property Value

Type: AtalaImageViewer
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Importers Property

AtalaAnnotationViewerImporters Property

Gets a list of AnnotationDataImporter objects used to import annotations from an image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Collection<AnnotationDataImporter> Importers { get; }
Public ReadOnly Property Importers As Collection(Of AnnotationDataImporter)
    Get

Property Value

Type: Collection AnnotationDataImporter
A list of importers for annotations.
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer Methods

The AtalaAnnotationViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | Burn | Burns all annotations onto the current image.
Public method | Burn(AtalaImage) | Burns all annotations along with the specified image.
Public method | Burn(WpfAnnotationUI, AtalaImage) | Burns the specified annotation along with the specified image.
Public method | Burn(WpfAnnotationUICollection, AtalaImage) | Burns the annotations in the provided collection along with the specified image.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateVisual | Returns a Visual object of the annotations and current image. This is useful for printing annotations or saving them to XPS documents.
Public method | CreateVisual(Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the annotations and current image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImporter | Returns the AnnotationDataImporter for the specified stream.
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | ImportAnnotations | This method loads annotations from the provided importer into a WpfLayerAnnotation, which is then added to the layer collection.
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | Open(Stream, Int32, ProgressEventHandler) | Opens an image from a stream along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).
Public method | Open(String, Int32, ProgressEventHandler) | Opens an image from a file along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RotateDocument(DocumentRotation) | Rotates the document and its annotations.
Public method | RotateDocument(DocumentRotation, WpfLayerAnnotation) | Rotates the specified LayerAnnotation by the given DocumentRotation.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the document at the given layer index by the given DocumentRotation.
Public method | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Burn Method

AtalaAnnotationViewerBurn Method

Burn method overloads used to burn annotations onto an image.
Overload List
 | Name | Description
Public method | Burn | Burns all annotations onto the current image.
Public method | Burn(AtalaImage) | Burns all annotations along with the specified image.
Public method | Burn(WpfAnnotationUI, AtalaImage) | Burns the specified annotation along with the specified image.
Public method | Burn(WpfAnnotationUICollection, AtalaImage) | Burns the annotations in the provided collection along with the specified image.
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Burn Method

AtalaAnnotationViewerBurn Method

Burns all annotations onto the current image.
Burns all annotations onto the current image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Burn()
Public Sub Burn
Remarks
The current image will be replaced by a new image with the annotations.
Remarks
The current image will be replaced by a new image with the annotations.
See Also

Reference

AtalaAnnotationViewer Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Burn Method (AtalaImage)

AtalaAnnotationViewerBurn Method (AtalaImage)

Burns all annotations along with the specified image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Burn(
    AtalaImage image
)
Public Function Burn (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotations onto.

Return Value

Type: AtalaImage
A new image with the annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image argument is null (Nothing in VB).
Remarks
This method will not modify the image passed in as an argument.
See Also

Reference

AtalaAnnotationViewer Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Burn Method (WpfAnnotationUI, AtalaImage)

AtalaAnnotationViewerBurn Method (WpfAnnotationUI, AtalaImage)

Burns the specified annotation along with the specified image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Burn(
    WpfAnnotationUI annotation,
    AtalaImage image
)
Public Function Burn (
    annotation As WpfAnnotationUI,
    image As AtalaImage
) As AtalaImage

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to burn.
image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotation onto.

Return Value

Type: AtalaImage
A new image with the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
Remarks
This method will not modify the image passed in as an argument.
See Also

Reference

AtalaAnnotationViewer Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Burn Method (WpfAnnotationUICollection, AtalaImage)

AtalaAnnotationViewerBurn Method (WpfAnnotationUICollection, AtalaImage)

Burns the annotations in the provided collection along with the specified image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Burn(
    WpfAnnotationUICollection annotations,
    AtalaImage image
)
Public Function Burn (
    annotations As WpfAnnotationUICollection,
    image As AtalaImage
) As AtalaImage

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUICollection
The annotations to burn.
image
Type: Atalasoft.ImagingAtalaImage
The image to burn the annotations onto.

Return Value

Type: AtalaImage
A new image with the annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
Remarks
This method will not modify the image passed in as an argument.
See Also

Reference

AtalaAnnotationViewer Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.CreateVisual Method

AtalaAnnotationViewerCreateVisual Method

These methods are used to render the annotations onto a Visual, which can then be used for printing or saving to XPS.
Overload List
 | Name | Description
Public method | CreateVisual | Returns a Visual object of the annotations and current image. This is useful for printing annotations or saving them to XPS documents.
Public method | CreateVisual(Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the annotations and current image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.CreateVisual Method

AtalaAnnotationViewerCreateVisual Method

Returns a Visual object of the annotations and current image. This is useful for printing annotations or saving them to XPS documents.
Returns a Visual object of the annotations and current image. This is useful for printing annotations or saving them to XPS documents.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Visual CreateVisual()
Public Function CreateVisual As Visual

Return Value

Type: Visual
A Visual object of the annotations and image.

Return Value

Type: Visual
A Visual object of the annotations and image.
See Also

Reference

AtalaAnnotationViewer Class
CreateVisual Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.CreateVisual Method (Size, WpfVisualScaleMode, Thickness)

AtalaAnnotationViewerCreateVisual Method (Size, WpfVisualScaleMode, Thickness)

Returns a Visual object of the annotations and current image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Visual CreateVisual(
    Size pageSize,
    WpfVisualScaleMode scaleMode,
    Thickness padding
)
Public Function CreateVisual (
    pageSize As Size,
    scaleMode As WpfVisualScaleMode,
    padding As Thickness
) As Visual

Parameters

pageSize
Type: System.WindowsSize
The page size used to scale the annotation and image rendering.
scaleMode
Type: Atalasoft.Annotate.WpfWpfVisualScaleMode
The type of scaling to perform.
padding
Type: System.WindowsThickness
The padding around the annotations and image.

Return Value

Type: Visual
A Visual object of the annotations and image.
See Also

Reference

AtalaAnnotationViewer Class
CreateVisual Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.GetImporter Method

AtalaAnnotationViewerGetImporter Method

Returns the AnnotationDataImporter for the specified stream.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AnnotationDataImporter GetImporter(
    Stream stream
)
Protected Overridable Function GetImporter (
    stream As Stream
) As AnnotationDataImporter

Parameters

stream
Type: System.IOStream
A stream containing the image to extract annotations from.

Return Value

Type: AnnotationDataImporter
The importer for the image or null (Nothing in VB) if an importer cannot be found.
Exceptions
Exception | Condition
 | Thrown if the stream argument is null (Nothing in VB).
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.ImportAnnotations Method

AtalaAnnotationViewerImportAnnotations Method

This method loads annotations from the provided importer into a WpfLayerAnnotation, which is then added to the layer collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ImportAnnotations(
    AnnotationDataImporter importer,
    int frameIndex
)
Protected Overridable Sub ImportAnnotations (
    importer As AnnotationDataImporter,
    frameIndex As Integer
)

Parameters

importer
Type: Atalasoft.Annotate.ImportersAnnotationDataImporter
The importer from which annotations will be retrieved.
frameIndex
Type: SystemInt32
The zero based frame index of the page to pull annotations from. Passing in -1 will add all pages in the importer to the layer collection.
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.InitializeComponent Method

AtalaAnnotationViewerInitializeComponent Method

InitializeComponent

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void InitializeComponent()
Public Sub InitializeComponent

Implements

IComponentConnectorInitializeComponent
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Open Method

AtalaAnnotationViewerOpen Method

These methods are used to load an image and optionally annotation data into the viewer.
Overload List
 | Name | Description
Public method | Open(Stream, Int32, ProgressEventHandler) | Opens an image from a stream along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).
Public method | Open(String, Int32, ProgressEventHandler) | Opens an image from a file along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Open Method (Stream, Int32, ProgressEventHandler)

AtalaAnnotationViewerOpen Method (Stream, Int32, ProgressEventHandler)

Opens an image from a stream along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing the image file.
frameIndex
Type: SystemInt32
The zero based frame index to load.
progress
Type: Atalasoft.ImagingProgressEventHandler
An event handler used to raise progress events during the load process.
Exceptions
Exception | Condition
 | Thrown if the stream argument is null (Nothing in VB).
 | Thrown if the stream does not have read or seek access.
Remarks
If both AutoLoadXmp and AutoLoadWang properties are true and both XMP and WANG data is present in the file, only the XMP data will be loaded to prevent duplicate annotations.
See Also

Reference

AtalaAnnotationViewer Class
Open Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Open Method (String, Int32, ProgressEventHandler)

AtalaAnnotationViewerOpen Method (String, Int32, ProgressEventHandler)

Opens an image from a file along with its embedded annotations (if AutoLoadXmp or AutoLoadWang is true).

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex,
    ProgressEventHandler progress
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The filename of the image to open.
frameIndex
Type: SystemInt32
The zero based frame index to load.
progress
Type: Atalasoft.ImagingProgressEventHandler
An event handler used to raise progress events during the load process.
Exceptions
Exception | Condition
 | Thrown if the fileName argument is null (Nothing in VB).
 | Thrown if the fileName is an empty string.
 | Thrown if the filename cannot be found.
Remarks
If both AutoLoadXmp and AutoLoadWang properties are true and both XMP and WANG data is present in the file, only the XMP data will be loaded to prevent duplicate annotations.
See Also

Reference

AtalaAnnotationViewer Class
Open Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.RotateDocument Method

AtalaAnnotationViewerRotateDocument Method

The RotateDocument method is used to rotate the image and annotations in 90 degree increments.
Overload List
 | Name | Description
Public method | RotateDocument(DocumentRotation) | Rotates the document and its annotations.
Public method | RotateDocument(DocumentRotation, WpfLayerAnnotation) | Rotates the specified LayerAnnotation by the given DocumentRotation.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the document at the given layer index by the given DocumentRotation.
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.RotateDocument Method (DocumentRotation)

AtalaAnnotationViewerRotateDocument Method (DocumentRotation)

Rotates the document and its annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation
)
Public Sub RotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation to apply.
See Also

Reference

AtalaAnnotationViewer Class
RotateDocument Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.RotateDocument Method (DocumentRotation, WpfLayerAnnotation)

AtalaAnnotationViewerRotateDocument Method (DocumentRotation, WpfLayerAnnotation)

Rotates the specified LayerAnnotation by the given DocumentRotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    WpfLayerAnnotation layer
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layer As WpfLayerAnnotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to rotate.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer argument is null (Nothing in VB).
See Also

Reference

AtalaAnnotationViewer Class
RotateDocument Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.RotateDocument Method (DocumentRotation, Int32)

AtalaAnnotationViewerRotateDocument Method (DocumentRotation, Int32)

Rotates the document at the given layer index by the given DocumentRotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    int layerIndex
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layerIndex As Integer
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The amount of rotation.
layerIndex
Type: SystemInt32
The index of the layer in the layer collection to rotate.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the layerIndex argument is invalid for the layer collection.
See Also

Reference

AtalaAnnotationViewer Class
RotateDocument Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Save Method

AtalaAnnotationViewerSave Method

These methods are used to save the image and optionally annotation data to a file or stream.
Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Save Method (Stream, ImageEncoder, ProgressEventHandler)

AtalaAnnotationViewerSave Method (Stream, ImageEncoder, ProgressEventHandler)

Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
The stream where the image will be saved.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The encoder used to save the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
An event handler for progress notification.
Exceptions
Exception | Condition
 | Thrown if the stream or encoder argument is null (Nothing in VB).
 | Thrown if the stream does not have write access.
Remarks
Annotation data will automatically be embedded into the image when the AutoSaveXmp and/or AutoSaveWang properties are true and a compatible ImageEncoder is provided. XMP data is only supported in JPEG and TIFF files and WANG is only supported in TIFF files.
See Also

Reference

AtalaAnnotationViewer Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.Save Method (String, ImageEncoder, ProgressEventHandler)

AtalaAnnotationViewerSave Method (String, ImageEncoder, ProgressEventHandler)

Saves the image along with annotations (if AutoSaveXmp or AutoSaveWang are true) using the specified ImageEncoder.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The filename of the image to create.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The encoder used to save the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
An event handler for progress notification.
Exceptions
Exception | Condition
 | Thrown if the fileName or encoder argument is null (Nothing in VB).
 | Thrown if the fileName argument is an empty string.
Remarks
Annotation data will automatically be embedded into the image when the AutoSaveXmp and/or AutoSaveWang properties are true and a compatible ImageEncoder is provided. XMP data is only supported in JPEG and TIFF files and WANG is only supported in TIFF files.
See Also

Reference

AtalaAnnotationViewer Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer Events

The AtalaAnnotationViewer type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer Fields

The AtalaAnnotationViewer type exposes the following members.

Fields
Name | Description
AutoLoadWangProperty | Identifies the AutoLoadWang dependency property.
AutoLoadXmpProperty | Identifies the AutoLoadXmp dependency property.
AutoSaveWangProperty | Identifies the AutoSaveWang dependency property.
AutoSaveXmpProperty | Identifies the AutoSaveXmp dependency property.
Top
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoLoadWangProperty Field

AtalaAnnotationViewerAutoLoadWangProperty Field

Identifies the AutoLoadWang dependency property.
Identifies the AutoLoadWang dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoLoadWangProperty
Public Shared ReadOnly AutoLoadWangProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoLoadXmpProperty Field

AtalaAnnotationViewerAutoLoadXmpProperty Field

Identifies the AutoLoadXmp dependency property.
Identifies the AutoLoadXmp dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoLoadXmpProperty
Public Shared ReadOnly AutoLoadXmpProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoSaveWangProperty Field

AtalaAnnotationViewerAutoSaveWangProperty Field

Identifies the AutoSaveWang dependency property.
Identifies the AutoSaveWang dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoSaveWangProperty
Public Shared ReadOnly AutoSaveWangProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


AtalaAnnotationViewer.AutoSaveXmpProperty Field

AtalaAnnotationViewerAutoSaveXmpProperty Field

Identifies the AutoSaveXmp dependency property.
Identifies the AutoSaveXmp dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoSaveXmpProperty
Public Shared ReadOnly AutoSaveXmpProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AtalaAnnotationViewer Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Class

CollectionChangedEventArgsT Class

This class is used to indicate changes made to a collection.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.WpfCollectionChangedEventArgsT

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CollectionChangedEventArgs<T> : EventArgs

Public Class CollectionChangedEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The Type used for the collection.

The CollectionChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionChangedEventArgsT(CollectionAction) | Creates a new instance of CollectionChangedEventArgs indicating the action.
Public method | CollectionChangedEventArgsT(IEnumerableT, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the items, starting index and action performed.
Public method | CollectionChangedEventArgsT(T, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the item, index and action performed.
Public method | CollectionChangedEventArgsT(IEnumerableT, IEnumerableT, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the old items, new items, starting index and action performed.
Public method | CollectionChangedEventArgsT(T, T, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the old item, new item, index and action performed.
Top
Properties
 | Name | Description
Public property | Action | Gets the action performed on the items.
Public property | Index | Gets the index of the item.
Public property | NewItem | Gets the new item that was inserted.
Public property | NewItems | Gets the items that were inserted.
Public property | OldItem | Gets the old item that was removed.
Public property | OldItems | Gets the old items that were removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Constructor

CollectionChangedEventArgsT Constructor

Overload List
 | Name | Description
Public method | CollectionChangedEventArgsT(CollectionAction) | Creates a new instance of CollectionChangedEventArgs indicating the action.
Public method | CollectionChangedEventArgsT(IEnumerableT, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the items, starting index and action performed.
Public method | CollectionChangedEventArgsT(T, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the item, index and action performed.
Public method | CollectionChangedEventArgsT(IEnumerableT, IEnumerableT, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the old items, new items, starting index and action performed.
Public method | CollectionChangedEventArgsT(T, T, Int32, CollectionAction) | Creates a new instance of CollectionChangedEventArgs specifying the old item, new item, index and action performed.
Top
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Constructor (CollectionAction)

CollectionChangedEventArgsT Constructor (CollectionAction)

Creates a new instance of CollectionChangedEventArgs indicating the action.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    CollectionAction action
)
Public Sub New (
    action As CollectionAction
)

Parameters

action
Type: Atalasoft.UtilsCollectionAction
The action performed by the collection.
See Also

Reference

CollectionChangedEventArgsT Class
CollectionChangedEventArgsT Overload
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Constructor (IEnumerable(T), Int32, CollectionAction)

CollectionChangedEventArgsT Constructor (IEnumerableT, Int32, CollectionAction)

Creates a new instance of CollectionChangedEventArgs specifying the items, starting index and action performed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    IEnumerable<T> items,
    int index,
    CollectionAction action
)
Public Sub New (
    items As IEnumerable(Of T),
    index As Integer,
    action As CollectionAction
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The items affected.
index
Type: SystemInt32
The index of the first item.
action
Type: Atalasoft.UtilsCollectionAction
The action performed.
See Also

Reference

CollectionChangedEventArgsT Class
CollectionChangedEventArgsT Overload
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Constructor (T, Int32, CollectionAction)

CollectionChangedEventArgsT Constructor (T, Int32, CollectionAction)

Creates a new instance of CollectionChangedEventArgs specifying the item, index and action performed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    T item,
    int index,
    CollectionAction action
)
Public Sub New (
    item As T,
    index As Integer,
    action As CollectionAction
)

Parameters

item
Type: T
The item the action was performed on.
index
Type: SystemInt32
The index of the item.
action
Type: Atalasoft.UtilsCollectionAction
Teh action performed.
See Also

Reference

CollectionChangedEventArgsT Class
CollectionChangedEventArgsT Overload
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Constructor (IEnumerable(T), IEnumerable(T), Int32, CollectionAction)

CollectionChangedEventArgsT Constructor (IEnumerableT, IEnumerableT, Int32, CollectionAction)

Creates a new instance of CollectionChangedEventArgs specifying the old items, new items, starting index and action performed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    IEnumerable<T> oldItems,
    IEnumerable<T> newItems,
    int index,
    CollectionAction action
)
Public Sub New (
    oldItems As IEnumerable(Of T),
    newItems As IEnumerable(Of T),
    index As Integer,
    action As CollectionAction
)

Parameters

oldItems
Type: System.Collections.GenericIEnumerable T
The old items that were removed.
newItems
Type: System.Collections.GenericIEnumerable T
The new items that were inserted.
index
Type: SystemInt32
The index of the first item.
action
Type: Atalasoft.UtilsCollectionAction
The action performed.
See Also

Reference

CollectionChangedEventArgsT Class
CollectionChangedEventArgsT Overload
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Constructor (T, T, Int32, CollectionAction)

CollectionChangedEventArgsT Constructor (T, T, Int32, CollectionAction)

Creates a new instance of CollectionChangedEventArgs specifying the old item, new item, index and action performed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    T oldItem,
    T newItem,
    int index,
    CollectionAction action
)
Public Sub New (
    oldItem As T,
    newItem As T,
    index As Integer,
    action As CollectionAction
)

Parameters

oldItem
Type: T
The old item that was replaced or removed.
newItem
Type: T
The new item that was inserted.
index
Type: SystemInt32
The index of the items.
action
Type: Atalasoft.UtilsCollectionAction
The action performed.
See Also

Reference

CollectionChangedEventArgsT Class
CollectionChangedEventArgsT Overload
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Properties

CollectionChangedEventArgsT Properties

The CollectionChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets the action performed on the items.
Public property | Index | Gets the index of the item.
Public property | NewItem | Gets the new item that was inserted.
Public property | NewItems | Gets the items that were inserted.
Public property | OldItem | Gets the old item that was removed.
Public property | OldItems | Gets the old items that were removed.
Top
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T).Action Property

CollectionChangedEventArgsTAction Property

Gets the action performed on the items.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionAction Action { get; }
Public ReadOnly Property Action As CollectionAction
    Get

Property Value

Type: CollectionAction
The action performed.
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T).Index Property

CollectionChangedEventArgsTIndex Property

Gets the index of the item.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the item.
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T).NewItem Property

CollectionChangedEventArgsTNewItem Property

Gets the new item that was inserted.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T NewItem { get; }
Public ReadOnly Property NewItem As T
    Get

Property Value

Type: T
The item that was inserted or null (Nothing in VB).
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T).NewItems Property

CollectionChangedEventArgsTNewItems Property

Gets the items that were inserted.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<T> NewItems { get; }
Public ReadOnly Property NewItems As IEnumerable(Of T)
    Get

Property Value

Type: IEnumerable T
The items that were inserted or null (Nothing in VB).
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T).OldItem Property

CollectionChangedEventArgsTOldItem Property

Gets the old item that was removed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T OldItem { get; }
Public ReadOnly Property OldItem As T
    Get

Property Value

Type: T
The item that was removed from the collection or null (Nothing in VB).
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T).OldItems Property

CollectionChangedEventArgsTOldItems Property

Gets the old items that were removed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<T> OldItems { get; }
Public ReadOnly Property OldItems As IEnumerable(Of T)
    Get

Property Value

Type: IEnumerable T
The items that were removed or null (Nothing in VB).
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


CollectionChangedEventArgs(T) Methods

CollectionChangedEventArgsT Methods

The CollectionChangedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CollectionChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


EventArgs(T) Class

EventArgsT Class

This class is a generic version of EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.WpfEventArgsT

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EventArgs<T> : EventArgs

Public Class EventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The argument type.

The EventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT | Creates a new instance of EventArgs.
Top
Properties
 | Name | Description
Public property | Item | Gets the event item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


EventArgs(T) Constructor

EventArgsT Constructor

Creates a new instance of EventArgs.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EventArgs(
    T item
)
Public Sub New (
    item As T
)

Parameters

item
Type: T
The item for the event.
See Also

Reference

EventArgsT Class
Atalasoft.Annotate.Wpf Namespace


EventArgs(T) Properties

EventArgsT Properties

The EventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the event item.
Top
See Also

Reference

EventArgsT Class
Atalasoft.Annotate.Wpf Namespace


EventArgs(T).Item Property

EventArgsTItem Property

Gets the event item.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Item { get; }
Public ReadOnly Property Item As T
    Get

Property Value

Type: T
The event item.
See Also

Reference

EventArgsT Class
Atalasoft.Annotate.Wpf Namespace


EventArgs(T) Methods

EventArgsT Methods

The EventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventArgsT Class
Atalasoft.Annotate.Wpf Namespace


GripMoveRequest Class

This class holds information for a grip move operation request.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfGripMoveRequest

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GripMoveRequest
Public Class GripMoveRequest

The GripMoveRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GripMoveRequest | Creates a new instance of GripMoveRequest.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this action should be canceled.
Public property | Grip | Gets or sets the grip being moved.
Public property | NewPosition | Gets the new requested position.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


GripMoveRequest Constructor

Creates a new instance of GripMoveRequest.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GripMoveRequest(
    WpfAnnotationGrip grip,
    Point newPosition
)
Public Sub New (
    grip As WpfAnnotationGrip,
    newPosition As Point
)

Parameters

grip
Type: Atalasoft.Annotate.WpfWpfAnnotationGrip
The grip being moved.
newPosition
Type: System.WindowsPoint
The new requested grip position.
See Also

Reference

GripMoveRequest Class
Atalasoft.Annotate.Wpf Namespace


GripMoveRequest Properties

The GripMoveRequest type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this action should be canceled.
Public property | Grip | Gets or sets the grip being moved.
Public property | NewPosition | Gets the new requested position.
Top
See Also

Reference

GripMoveRequest Class
Atalasoft.Annotate.Wpf Namespace


GripMoveRequest.Cancel Property

GripMoveRequestCancel Property

Gets or sets a value indicating whether this action should be canceled.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this action should be canceled.
See Also

Reference

GripMoveRequest Class
Atalasoft.Annotate.Wpf Namespace


GripMoveRequest.Grip Property

GripMoveRequestGrip Property

Gets or sets the grip being moved.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGrip Grip { get; set; }
Public Property Grip As WpfAnnotationGrip
    Get
    Set

Property Value

Type: WpfAnnotationGrip
The grip being moved.
See Also

Reference

GripMoveRequest Class
Atalasoft.Annotate.Wpf Namespace


GripMoveRequest.NewPosition Property

GripMoveRequestNewPosition Property

Gets the new requested position.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point NewPosition { get; }
Public ReadOnly Property NewPosition As Point
    Get

Property Value

Type: Point
The requested position.
See Also

Reference

GripMoveRequest Class
Atalasoft.Annotate.Wpf Namespace


GripMoveRequest Methods

The GripMoveRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GripMoveRequest Class
Atalasoft.Annotate.Wpf Namespace


IWpfAnnotationUIFactory Interface

This interface is implemented by factory classes used to create annotations from AnnotationData.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWpfAnnotationUIFactory
Public Interface IWpfAnnotationUIFactory

The IWpfAnnotationUIFactory type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationType | Gets the type of annotation the factory can create.
Top
Methods
 | Name | Description
Public method | GetAnnotationUI | Returns a new annotation from an AnnotationData class.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


IWpfAnnotationUIFactory Properties

The IWpfAnnotationUIFactory type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationType | Gets the type of annotation the factory can create.
Top
See Also

Reference

IWpfAnnotationUIFactory Interface
Atalasoft.Annotate.Wpf Namespace


IWpfAnnotationUIFactory.AnnotationType Property

IWpfAnnotationUIFactoryAnnotationType Property

Gets the type of annotation the factory can create.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Type AnnotationType { get; }
ReadOnly Property AnnotationType As Type
    Get

Property Value

Type: Type
The annotation type created by the factory.
See Also

Reference

IWpfAnnotationUIFactory Interface
Atalasoft.Annotate.Wpf Namespace


IWpfAnnotationUIFactory Methods

The IWpfAnnotationUIFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetAnnotationUI | Returns a new annotation from an AnnotationData class.
Top
See Also

Reference

IWpfAnnotationUIFactory Interface
Atalasoft.Annotate.Wpf Namespace


IWpfAnnotationUIFactory.GetAnnotationUI Method

IWpfAnnotationUIFactoryGetAnnotationUI Method

Returns a new annotation from an AnnotationData class.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
WpfAnnotationUI GetAnnotationUI(
    AnnotationData data
)
Function GetAnnotationUI (
    data As AnnotationData
) As WpfAnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data used to construct the annotation.

Return Value

Type: WpfAnnotationUI
A new annotation or null (Nothing in VB) if the annotation could not be created by the factory.
See Also

Reference

IWpfAnnotationUIFactory Interface
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest Class

This class hold information for a move request.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfMoveAnnotationRequest

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MoveAnnotationRequest
Public Class MoveAnnotationRequest

The MoveAnnotationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | MoveAnnotationRequest | Creates a new instance of MoveAnnotationRequest.
Top
Properties
 | Name | Description
Public property | AllowLocationChange | Gets or set a value indicating whether the move is allowed.
Public property | AutoUpdateGripPositions | Gets or sets a value indicating whether the grip positions should be updated.
Public property | CurrentLocation | Gets the current location of the annotation.
Public property | MousePosition | Gets the current mouse position.
Public property | NewLocation | Gets or sets the new location of the annotation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest Constructor

Creates a new instance of MoveAnnotationRequest.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MoveAnnotationRequest(
    Point mousePosition,
    Point currentLocation,
    Point newLocation
)
Public Sub New (
    mousePosition As Point,
    currentLocation As Point,
    newLocation As Point
)

Parameters

mousePosition
Type: System.WindowsPoint
The current mouse position.
currentLocation
Type: System.WindowsPoint
The current annotation location.
newLocation
Type: System.WindowsPoint
The requested annotation location.
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest Properties

The MoveAnnotationRequest type exposes the following members.

Properties
 | Name | Description
Public property | AllowLocationChange | Gets or set a value indicating whether the move is allowed.
Public property | AutoUpdateGripPositions | Gets or sets a value indicating whether the grip positions should be updated.
Public property | CurrentLocation | Gets the current location of the annotation.
Public property | MousePosition | Gets the current mouse position.
Public property | NewLocation | Gets or sets the new location of the annotation.
Top
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest.AllowLocationChange Property

MoveAnnotationRequestAllowLocationChange Property

Gets or set a value indicating whether the move is allowed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowLocationChange { get; set; }
Public Property AllowLocationChange As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the move is allowed.
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest.AutoUpdateGripPositions Property

MoveAnnotationRequestAutoUpdateGripPositions Property

Gets or sets a value indicating whether the grip positions should be updated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoUpdateGripPositions { get; set; }
Public Property AutoUpdateGripPositions As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the grip positions should be updated.
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest.CurrentLocation Property

MoveAnnotationRequestCurrentLocation Property

Gets the current location of the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point CurrentLocation { get; }
Public ReadOnly Property CurrentLocation As Point
    Get

Property Value

Type: Point
The current location of the annotation.
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest.MousePosition Property

MoveAnnotationRequestMousePosition Property

Gets the current mouse position.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point MousePosition { get; }
Public ReadOnly Property MousePosition As Point
    Get

Property Value

Type: Point
The mouse position.
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest.NewLocation Property

MoveAnnotationRequestNewLocation Property

Gets or sets the new location of the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point NewLocation { get; set; }
Public Property NewLocation As Point
    Get
    Set

Property Value

Type: Point
The new location of the annotation.
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


MoveAnnotationRequest Methods

The MoveAnnotationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoveAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Class

This class is used to send an operation request to an annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfOperationRequestInformation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OperationRequestInformation
Public Class OperationRequestInformation

The OperationRequestInformation type exposes the following members.

Constructors
 | Name | Description
Public method | OperationRequestInformation(WpfAnnotationUI, GripMoveRequest) | Creates a new instance of OperationRequestInformation for a grip move operation.
Public method | OperationRequestInformation(WpfAnnotationUI, MoveAnnotationRequest) | Creates a new instance of OperationRequestInformation for a move operation.
Public method | OperationRequestInformation(WpfAnnotationUI, RotateAnnotationRequest) | Creates a new instance of OperationRequestInformation for a rotation operation.
Top
Properties
 | Name | Description
Public property | GripMoveRequest | Gets a GripMoveRequest for this operation.
Public property | MoveRequest | Gets a MoveAnnotationRequest for this operation.
Public property | Operation | Gets the operation for this request.
Public property | RotateRequest | Gets a RotateAnnotationRequest for this operation.
Public property | TargetAnnotation | Gets the annotation the request will be sent to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This is used by grips to give annotations a chance to cancel out of a change the user is trying to apply. It's not meant to be used directly.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Constructor

Overload List
 | Name | Description
Public method | OperationRequestInformation(WpfAnnotationUI, GripMoveRequest) | Creates a new instance of OperationRequestInformation for a grip move operation.
Public method | OperationRequestInformation(WpfAnnotationUI, MoveAnnotationRequest) | Creates a new instance of OperationRequestInformation for a move operation.
Public method | OperationRequestInformation(WpfAnnotationUI, RotateAnnotationRequest) | Creates a new instance of OperationRequestInformation for a rotation operation.
Top
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Constructor (WpfAnnotationUI, GripMoveRequest)

Creates a new instance of OperationRequestInformation for a grip move operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OperationRequestInformation(
    WpfAnnotationUI targetAnnotation,
    GripMoveRequest request
)
Public Sub New (
    targetAnnotation As WpfAnnotationUI,
    request As GripMoveRequest
)

Parameters

targetAnnotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation the request will be sent to.
request
Type: Atalasoft.Annotate.WpfGripMoveRequest
A GripMoveRequest for this operation.
See Also

Reference

OperationRequestInformation Class
OperationRequestInformation Overload
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Constructor (WpfAnnotationUI, MoveAnnotationRequest)

Creates a new instance of OperationRequestInformation for a move operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OperationRequestInformation(
    WpfAnnotationUI targetAnnotation,
    MoveAnnotationRequest request
)
Public Sub New (
    targetAnnotation As WpfAnnotationUI,
    request As MoveAnnotationRequest
)

Parameters

targetAnnotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation the request will be sent to.
request
Type: Atalasoft.Annotate.WpfMoveAnnotationRequest
A MoveAnnotationRequest for this operation.
See Also

Reference

OperationRequestInformation Class
OperationRequestInformation Overload
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Constructor (WpfAnnotationUI, RotateAnnotationRequest)

Creates a new instance of OperationRequestInformation for a rotation operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OperationRequestInformation(
    WpfAnnotationUI targetAnnotation,
    RotateAnnotationRequest request
)
Public Sub New (
    targetAnnotation As WpfAnnotationUI,
    request As RotateAnnotationRequest
)

Parameters

targetAnnotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation the request will be sent to.
request
Type: Atalasoft.Annotate.WpfRotateAnnotationRequest
A RotateAnnotationRequest for this operation.
See Also

Reference

OperationRequestInformation Class
OperationRequestInformation Overload
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Properties

The OperationRequestInformation type exposes the following members.

Properties
 | Name | Description
Public property | GripMoveRequest | Gets a GripMoveRequest for this operation.
Public property | MoveRequest | Gets a MoveAnnotationRequest for this operation.
Public property | Operation | Gets the operation for this request.
Public property | RotateRequest | Gets a RotateAnnotationRequest for this operation.
Public property | TargetAnnotation | Gets the annotation the request will be sent to.
Top
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation.GripMoveRequest Property

OperationRequestInformationGripMoveRequest Property

Gets a GripMoveRequest for this operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GripMoveRequest GripMoveRequest { get; }
Public ReadOnly Property GripMoveRequest As GripMoveRequest
    Get

Property Value

Type: GripMoveRequest
A GripMoveRequest for this operation. This may be null (Nothing in VB).
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation.MoveRequest Property

OperationRequestInformationMoveRequest Property

Gets a MoveAnnotationRequest for this operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MoveAnnotationRequest MoveRequest { get; }
Public ReadOnly Property MoveRequest As MoveAnnotationRequest
    Get

Property Value

Type: MoveAnnotationRequest
A MoveAnnotationRequest for this operation. This may be null (Nothing in VB).
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation.Operation Property

OperationRequestInformationOperation Property

Gets the operation for this request.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationOperationRequests Operation { get; }
Public ReadOnly Property Operation As WpfAnnotationOperationRequests
    Get

Property Value

Type: WpfAnnotationOperationRequests
The operation for this request.
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation.RotateRequest Property

OperationRequestInformationRotateRequest Property

Gets a RotateAnnotationRequest for this operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateAnnotationRequest RotateRequest { get; }
Public ReadOnly Property RotateRequest As RotateAnnotationRequest
    Get

Property Value

Type: RotateAnnotationRequest
A RotateAnnotationRequest for this operation. This may be null (Nothing in VB).
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation.TargetAnnotation Property

OperationRequestInformationTargetAnnotation Property

Gets the annotation the request will be sent to.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI TargetAnnotation { get; }
Public ReadOnly Property TargetAnnotation As WpfAnnotationUI
    Get

Property Value

Type: WpfAnnotationUI
The annotation the request will be sent to.
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


OperationRequestInformation Methods

The OperationRequestInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OperationRequestInformation Class
Atalasoft.Annotate.Wpf Namespace


RotateAnnotationRequest Class

This class holds information for a rotate request.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfRotateAnnotationRequest

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RotateAnnotationRequest
Public Class RotateAnnotationRequest

The RotateAnnotationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RotateAnnotationRequest | Creates a new instance of RotateAnnotationRequest.
Top
Properties
 | Name | Description
Public property | AllowRotationChange | Gets or sets a value indicating whether the rotation will be allowed.
Public property | NewRotation | Gets or sets the new rotation value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


RotateAnnotationRequest Constructor

Creates a new instance of RotateAnnotationRequest.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateAnnotationRequest(
    double rotation
)
Public Sub New (
    rotation As Double
)

Parameters

rotation
Type: SystemDouble
The requested rotation.
See Also

Reference

RotateAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


RotateAnnotationRequest Properties

The RotateAnnotationRequest type exposes the following members.

Properties
 | Name | Description
Public property | AllowRotationChange | Gets or sets a value indicating whether the rotation will be allowed.
Public property | NewRotation | Gets or sets the new rotation value.
Top
See Also

Reference

RotateAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


RotateAnnotationRequest.AllowRotationChange Property

RotateAnnotationRequestAllowRotationChange Property

Gets or sets a value indicating whether the rotation will be allowed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowRotationChange { get; set; }
Public Property AllowRotationChange As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the rotation will be allowed.
See Also

Reference

RotateAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


RotateAnnotationRequest.NewRotation Property

RotateAnnotationRequestNewRotation Property

Gets or sets the new rotation value.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double NewRotation { get; set; }
Public Property NewRotation As Double
    Get
    Set

Property Value

Type: Double
The rotation value.
See Also

Reference

RotateAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


RotateAnnotationRequest Methods

The RotateAnnotationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RotateAnnotationRequest Class
Atalasoft.Annotate.Wpf Namespace


ValueChangedEventArgs(T) Class

ValueChangedEventArgsT Class

This class is used to indicate that a value has changed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Annotate.WpfValueChangedEventArgsT

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ValueChangedEventArgs<T> : EventArgs

Public Class ValueChangedEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The type of object being changed.

The ValueChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | ValueChangedEventArgsT | Creates a new instance of ValueChangedEventArgs.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value.
Public property | PreviousValue | Gets the previous value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


ValueChangedEventArgs(T) Constructor

ValueChangedEventArgsT Constructor

Creates a new instance of ValueChangedEventArgs.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ValueChangedEventArgs(
    T previousValue,
    T newValue
)
Public Sub New (
    previousValue As T,
    newValue As T
)

Parameters

previousValue
Type: T
The previous value.
newValue
Type: T
The new value.
See Also

Reference

ValueChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


ValueChangedEventArgs(T) Properties

ValueChangedEventArgsT Properties

The ValueChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value.
Public property | PreviousValue | Gets the previous value.
Top
See Also

Reference

ValueChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


ValueChangedEventArgs(T).NewValue Property

ValueChangedEventArgsTNewValue Property

Gets the new value.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T NewValue { get; }
Public ReadOnly Property NewValue As T
    Get

Property Value

Type: T
The new value.
See Also

Reference

ValueChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


ValueChangedEventArgs(T).PreviousValue Property

ValueChangedEventArgsTPreviousValue Property

Gets the previous value.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T PreviousValue { get; }
Public ReadOnly Property PreviousValue As T
    Get

Property Value

Type: T
The previous value.
See Also

Reference

ValueChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


ValueChangedEventArgs(T) Methods

ValueChangedEventArgsT Methods

The ValueChangedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValueChangedEventArgsT Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas Class

The WpfAnnotationCanvas is a Canvas object used to render annotations. This class is similar to the AnnotationController used in DotImage.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsCanvas
Atalasoft.Annotate.WpfWpfAnnotationCanvas

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationCanvas : Canvas
Public Class WpfAnnotationCanvas
    Inherits Canvas

The WpfAnnotationCanvas type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationCanvas | Creates a new instance of WpfAnnotationCanvas.
Top
Properties
 | Name | Description
Public property | ActiveAnnotation | Gets or sets the annotation that is currently active.
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AnnotationConfinement | Gets or sets the confinement mode used for the annotations.
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanPaste | Gets a value indicating whether there is annotation data on the clipboard.
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToDocument | Gets or sets a value indicating whether the annotation rendering should be clipped to the document bounds.
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ConfinedBounds | Gets the confined bounds based on the AnnotationConfinement, DocumentBounds and Zoom properties.
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CreateMouseButton | Gets or sets the mouse button used for annotation creation.
Public property | CurrentLayer | Gets or sets the current active layer.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultSecurity | Gets or sets the default security for newly created annotations.
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DocumentBounds | Gets or sets the bounding rectangle of the document being annotated.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Factories | Gets the WpfAnnotationUIFactoryCollection used when deserializing annotation data.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GripClip | Gets or sets a clipping region for the annotation grips.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InteractMode | Gets or sets the mouse interaction mode for annotations.
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDirty | Gets a value indicating whether there have been any changes since the last call to Save.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | Layers | Gets the WpfLayerCollection used by the canvas.
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resolution | Gets or sets the resolution of the document.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotationSnapInterval | Gets or sets the interval used for snapping interactive rotation to degrees. This is used to help users when rotating an annotation, making it easier to stop at whole degrees. The snap area is determined by the RotationSnapThreshold property.
Public property | RotationSnapThreshold | Gets or sets the amount of deviation from the RotationSnapInterval that will be used to snap to the rotation interval.
Public property | ScaledResolutionHeightFactor | Gets or sets the scaled resolution height factor used for image with different X and Y resolution values.
Public property | ScrollPosition | Gets or sets the scrollbar position.
Public property | SelectedAnnotations | Gets a read-only collection of the currently selected annotations.
Public property | SelectionMode | Gets or sets the selection mode to use when a mouse is clicked on an annotation.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WaitingToCreate | Gets a value indicating whether the WpfAnnotationCanvas is waiting for the user to create an annotation.
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Zoom | Gets or sets the zoom level for the document.
Top
Methods
 | Name | Description
Public method | ActivateControlElement | Adds a child element to the canvas.
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AnnotationFromPoint | Finds the annotation at the specified point.
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Protected method | AttachGrips | Attaches the grip adorner of the specified annotation to the WpfAnnotationCanvas.
Protected method | AttachLayerGrips | Attaches the grip adorners of annotations in the provided layer to the WpfAnnotationCanvas.
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
 | Burn(BitmapSource) | Burns all annotations and BitmapSource together, returning the combined image.
 | Burn(WpfAnnotationUI, BitmapSource) | Burns the provided annotation and BitmapSource together, returning the combined image.
 | Burn(WpfAnnotationUICollection, BitmapSource) | Burns annotations in the provided WpfAnnotationUICollection along with the provided BitmapSource and returns the combined image.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearSelection | Clears the currently selected annotations.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the selected annotations to the clipboard as XMP annotation data.
Public method | CountAnnotations | Counts the number of annotations in this canvas.
Public method | CountAnnotations(WpfLayerAnnotation) | Counts the number of annotations in the provided layer.
Public method | CreateAnnotation | Use this method to enter "create" mode where the user will create the provided annotation using the mouse.
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | CreateViewerMatrix | Returns a Matrix used when rendering annotations to the viewer.
 | CreateVisual | Returns a Visual object of the annotations. This is useful for printing annotations or saving them to XPS documents.
 | CreateVisual(BitmapSource) | Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
 | CreateVisual(BitmapSource, Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
 | CreateVisual(WpfAnnotationUICollection, BitmapSource, Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the specified annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
Public method | Cut | Copies the selected annotations to the clipboard as XMP annotation data, then removes the selected annotations from the viewer.
Public method | DeactivateControlElement | Removes a child control from the canvas.
Protected method | DetachGrips | Detaches the annotation grips from the WpfAnnotationCanvas.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | ExitCreateMode | Use this method to exit out of "create" mode.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetConfinedLocation | This method can be used to determine a valid location for an annotation with regard to the confinement area.
Public method | GetConfinedRotation | This method can be used to determine whether the provided rotation value is valid for the annotation with regard to the confinement area.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a clipping geometry that indicates the area that will be clipped if the ClipToBounds property is set to true. (Inherited from Canvas.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetTopLevelLayer | Returns the top level layer for the provided annotation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | Group | Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.
Public method | Group(WpfAnnotationUI) | Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Overrides UIElementHitTestCore(PointHitTestParameters).)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Load(Byte, AnnotationDataFormat) | Loads annotations from a byte array with the specified data format.
Public method | Load(Byte, IFormatter) | Loads annotations from a byte array into the layer collection.
Public method | Load(Stream, AnnotationDataFormat) | Loads annotations from a stream with the specified data format.
Public method | Load(Stream, IFormatter) | Loads annotations from a stream into the layer collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotations from a file with the specified data format.
Public method | Load(String, IFormatter) | Loads annotations from a file into the layers collection.
Public method | Load(Byte, WpfLayerAnnotation, IFormatter) | Loads annotations from a byte array into the provided layer.
Public method | Load(Stream, WpfLayerAnnotation, IFormatter) | Loads annotations from a stream into the provided layer.
Public method | Load(String, WpfLayerAnnotation, IFormatter) | Loads annotations from a file into the provided layer.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAnnotationCreated | Raises the AnnotationCreated event.
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseUp(MouseButtonEventArgs).)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Overrides PanelOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes annotations from the clipboard into the current layer.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RenderAllLayers | Renders all annotations using the provided environment.
 | RenderLayer | Renders a single layer of annotations using the WpfRenderEnvironment provided.
Public method | ReplaceGrips | Replaces the grips of an annotation with new grips.
Public method | RotateDocument(DocumentRotation) | Rotates the annotations in 90 degree increments.
Public method | RotateDocument(DocumentRotation, WpfLayerAnnotation) | Rotates the annotations in 90 degree increments for the specified layer.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the annotations in 90 degree increments for the specified layer index.
Public method | Save(IFormatter) | Serializes all annotations into a byte array.
Public method | Save(AnnotationDataFormat) | Serializes all annotations into a byte array using the specified format.
Public method | Save(Stream, AnnotationDataFormat) | Saves all loaded annotations to a stream with the specified data format.
Public method | Save(Stream, IFormatter) | Saves all loaded annotations to a stream.
Public method | Save(String, AnnotationDataFormat) | Saves all loaded annotations to a file with the specified data format.
Public method | Save(String, IFormatter) | Saves all loaded annotations to a file.
Public method | Save(WpfLayerAnnotation, IFormatter) | Serializes the provided layer into a byte array.
Public method | Save(Stream, WpfLayerAnnotation, IFormatter) | Saves the provided layer to a stream.
Public method | Save(String, WpfLayerAnnotation, IFormatter) | Saves the provided layer to a file.
Public method | SelectAll(Boolean) | Selects all of the annotations on the current layer or all layers.
Public method | SelectAll(WpfLayerAnnotation) | Selects all of the annotations in the specified layer.
Public method | SelectAnnotation(WpfAnnotationUI, Boolean) | Selects the specified annotation optionally replacing the current selection.
Public method | SelectAnnotation(WpfAnnotationUI, Boolean) | Selects one or more annotations with the option of replacing the current selection.
Public method | SelectFromBounds(Rect, Boolean) | Selects annotations that are partially or fully within a rectangular area.
Public method | SelectFromBounds(WpfLayerAnnotation, Rect, Boolean) | Selects annotations from a layer that are without a bounding region.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Ungroup | Ungroups the currently selected annotation into the CurrentLayer.
Public method | Ungroup(WpfLayerAnnotation, WpfLayerAnnotation) | Removes annotations from one layer and adds them to another.
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | AnnotationCreated | This event is raised when a user has finished creating an annotation.
Public event | AnnotationDeserialization | This event is raised after annotation have been deserialized, providing an option to replace the annotation objects.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | GripsAttached | This event is raised when grips have been attached to an annotation.
Public event | HotSpotClicked | This event is raised when a hot spot annotation is clicked.
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | This event is raised when a property has changed.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectedAnnotationsChanged | This event is raised when the annoation selection has changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ActiveAnnotationProperty | Identifies the ActiveAnnotation dependency property.
AnnotationConfinementProperty | Identifies the AnnotationConfinement dependency property.
ClipToDocumentProperty | Identifies the ClipToDocument dependency property.
CreateMouseButtonProperty | Identifies the CreateMouseButton dependency property.
CurrentLayerProperty | Identifies the CurrentLayer dependency property.
DefaultSecurityProperty | Identifies the DefaultSecurity dependency property.
DocumentBoundsProperty | Identifies the DocumentBounds dependency property.
GripClipProperty | Identifies the GripClip dependency property.
InteractModeProperty | Identifies the InteractMode dependency property.
IsDirtyProperty | Identifies the IsDirty dependency property.
ResolutionProperty | Identifies the Resolution dependency property.
RotationSnapIntervalProperty | Identifies the RotationSnapInterval dependency property.
RotationSnapThresholdProperty | Identifies the RotationSnapThreshold dependency property.
ScaledResolutionHeightFactorProperty | Identifies the ScaledResolutionHeightFactor dependency property.
ScrollPositionProperty | Identifies the ScrollPosition dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.
ZoomProperty | Identifies the Zoom dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas Constructor

Creates a new instance of WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationCanvas()
Public Sub New
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas Properties

The WpfAnnotationCanvas type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAnnotation | Gets or sets the annotation that is currently active.
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AnnotationConfinement | Gets or sets the confinement mode used for the annotations.
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanPaste | Gets a value indicating whether there is annotation data on the clipboard.
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToDocument | Gets or sets a value indicating whether the annotation rendering should be clipped to the document bounds.
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ConfinedBounds | Gets the confined bounds based on the AnnotationConfinement, DocumentBounds and Zoom properties.
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CreateMouseButton | Gets or sets the mouse button used for annotation creation.
Public property | CurrentLayer | Gets or sets the current active layer.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultSecurity | Gets or sets the default security for newly created annotations.
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DocumentBounds | Gets or sets the bounding rectangle of the document being annotated.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Factories | Gets the WpfAnnotationUIFactoryCollection used when deserializing annotation data.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GripClip | Gets or sets a clipping region for the annotation grips.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InteractMode | Gets or sets the mouse interaction mode for annotations.
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDirty | Gets a value indicating whether there have been any changes since the last call to Save.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | Layers | Gets the WpfLayerCollection used by the canvas.
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resolution | Gets or sets the resolution of the document.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotationSnapInterval | Gets or sets the interval used for snapping interactive rotation to degrees. This is used to help users when rotating an annotation, making it easier to stop at whole degrees. The snap area is determined by the RotationSnapThreshold property.
Public property | RotationSnapThreshold | Gets or sets the amount of deviation from the RotationSnapInterval that will be used to snap to the rotation interval.
Public property | ScaledResolutionHeightFactor | Gets or sets the scaled resolution height factor used for image with different X and Y resolution values.
Public property | ScrollPosition | Gets or sets the scrollbar position.
Public property | SelectedAnnotations | Gets a read-only collection of the currently selected annotations.
Public property | SelectionMode | Gets or sets the selection mode to use when a mouse is clicked on an annotation.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WaitingToCreate | Gets a value indicating whether the WpfAnnotationCanvas is waiting for the user to create an annotation.
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Zoom | Gets or sets the zoom level for the document.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ActiveAnnotation Property

WpfAnnotationCanvasActiveAnnotation Property

Gets or sets the annotation that is currently active.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI ActiveAnnotation { get; set; }
Public Property ActiveAnnotation As WpfAnnotationUI
    Get
    Set

Property Value

Type: WpfAnnotationUI
The active annotation or null (Nothing in VB) if there is no active annotation.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AnnotationConfinement Property

WpfAnnotationCanvasAnnotationConfinement Property

Gets or sets the confinement mode used for the annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationConfinementMode AnnotationConfinement { get; set; }
Public Property AnnotationConfinement As AnnotationConfinementMode
    Get
    Set

Property Value

Type: AnnotationConfinementMode
The confinement mode for the annotations.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CanPaste Property

WpfAnnotationCanvasCanPaste Property

Gets a value indicating whether there is annotation data on the clipboard.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanPaste { get; }
Public ReadOnly Property CanPaste As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether there is annotation data on the clipboard.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ClipToDocument Property

WpfAnnotationCanvasClipToDocument Property

Gets or sets a value indicating whether the annotation rendering should be clipped to the document bounds.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClipToDocument { get; set; }
Public Property ClipToDocument As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation rendering should be clipped to the document bounds.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ConfinedBounds Property

WpfAnnotationCanvasConfinedBounds Property

Gets the confined bounds based on the AnnotationConfinement, DocumentBounds and Zoom properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect ConfinedBounds { get; }
Public ReadOnly Property ConfinedBounds As Rect
    Get

Property Value

Type: Rect
The confined bounds.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateMouseButton Property

WpfAnnotationCanvasCreateMouseButton Property

Gets or sets the mouse button used for annotation creation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButton CreateMouseButton { get; set; }
Public Property CreateMouseButton As MouseButton
    Get
    Set

Property Value

Type: MouseButton
The mouse button used for annotation creation.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CurrentLayer Property

WpfAnnotationCanvasCurrentLayer Property

Gets or sets the current active layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation CurrentLayer { get; set; }
Public Property CurrentLayer As WpfLayerAnnotation
    Get
    Set

Property Value

Type: WpfLayerAnnotation
The current active layer.
Remarks
When an annotation is created, it will automatically be placed into the current layer.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.DefaultSecurity Property

WpfAnnotationCanvasDefaultSecurity Property

Gets or sets the default security for newly created annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock DefaultSecurity { get; set; }
Public Property DefaultSecurity As IAnnotationLock
    Get
    Set

Property Value

Type: IAnnotationLock
The default security for new annotations.
Remarks
The security will only be set if the new annotation does not already have its Security property set.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.DocumentBounds Property

WpfAnnotationCanvasDocumentBounds Property

Gets or sets the bounding rectangle of the document being annotated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect DocumentBounds { get; set; }
Public Property DocumentBounds As Rect
    Get
    Set

Property Value

Type: Rect
The bounds of the document.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Factories Property

WpfAnnotationCanvasFactories Property

Gets the WpfAnnotationUIFactoryCollection used when deserializing annotation data.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUIFactoryCollection Factories { get; }
Public ReadOnly Property Factories As WpfAnnotationUIFactoryCollection
    Get

Property Value

Type: WpfAnnotationUIFactoryCollection
The WpfAnnotationUIFactoryCollection used when deserializing annotation data.
Remarks
All custom annotations must add a factory for itself before they can be deserialized.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.GripClip Property

WpfAnnotationCanvasGripClip Property

Gets or sets a clipping region for the annotation grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Geometry GripClip { get; set; }
Public Property GripClip As Geometry
    Get
    Set

Property Value

Type: Geometry
A clipping region for the grips.
Remarks
Because annotation grips are in the AdornerLayer they render over normal element. Set this property to prevent them from rendering over parts of your application that may overlay the annotation viewer.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.InteractMode Property

WpfAnnotationCanvasInteractMode Property

Gets or sets the mouse interaction mode for annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateInteractMode InteractMode { get; set; }
Public Property InteractMode As AnnotateInteractMode
    Get
    Set

Property Value

Type: AnnotateInteractMode
The mouse interaction mode for annotations.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.IsDirty Property

WpfAnnotationCanvasIsDirty Property

Gets a value indicating whether there have been any changes since the last call to Save.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDirty { get; }
Public ReadOnly Property IsDirty As Boolean
    Get

Property Value

Type: Boolean
Indicates whether there have been any changes since the last save.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Layers Property

WpfAnnotationCanvasLayers Property

Gets the WpfLayerCollection used by the canvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerCollection Layers { get; }
Public ReadOnly Property Layers As WpfLayerCollection
    Get

Property Value

Type: WpfLayerCollection
The layer collection for the canvas.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Resolution Property

WpfAnnotationCanvasResolution Property

Gets or sets the resolution of the document.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Resolution { get; set; }
Public Property Resolution As Point
    Get
    Set

Property Value

Type: Point
The resolution of the document.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotationSnapInterval Property

WpfAnnotationCanvasRotationSnapInterval Property

Gets or sets the interval used for snapping interactive rotation to degrees. This is used to help users when rotating an annotation, making it easier to stop at whole degrees. The snap area is determined by the RotationSnapThreshold property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double RotationSnapInterval { get; set; }
Public Property RotationSnapInterval As Double
    Get
    Set

Property Value

Type: Double
The degree interval used for interactive rotation snapping.
Remarks
This value must be from 0 to 180 and evenly divisible into 360. When setting this property the value will automatically be converted into a valid value.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotationSnapThreshold Property

WpfAnnotationCanvasRotationSnapThreshold Property

Gets or sets the amount of deviation from the RotationSnapInterval that will be used to snap to the rotation interval.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double RotationSnapThreshold { get; set; }
Public Property RotationSnapThreshold As Double
    Get
    Set

Property Value

Type: Double
The amount of deviation from the RotationSnapInterval.
Remarks
This value must be from 0 to half the RotationSnapInterval. If the property is set to an invalid value it will be automatically corrected.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ScaledResolutionHeightFactor Property

WpfAnnotationCanvasScaledResolutionHeightFactor Property

Gets or sets the scaled resolution height factor used for image with different X and Y resolution values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ScaledResolutionHeightFactor { get; set; }
Public Property ScaledResolutionHeightFactor As Double
    Get
    Set

Property Value

Type: Double
The scaled height factor of the image.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ScrollPosition Property

WpfAnnotationCanvasScrollPosition Property

Gets or sets the scrollbar position.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; set; }
Public Property ScrollPosition As Point
    Get
    Set

Property Value

Type: Point
The scrollbar position.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectedAnnotations Property

WpfAnnotationCanvasSelectedAnnotations Property

Gets a read-only collection of the currently selected annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUICollection SelectedAnnotations { get; }
Public ReadOnly Property SelectedAnnotations As WpfAnnotationUICollection
    Get

Property Value

Type: WpfAnnotationUICollection
A read-only collection of the selected annotations.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectionMode Property

WpfAnnotationCanvasSelectionMode Property

Gets or sets the selection mode to use when a mouse is clicked on an annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationSelectionMode SelectionMode { get; set; }
Public Property SelectionMode As WpfAnnotationSelectionMode
    Get
    Set

Property Value

Type: WpfAnnotationSelectionMode
The selection mode for annotations.
Remarks
When this property is set to Multiple, multiple annotations can be selected by simply clicking on them. If you click on an annotation that is already selected, it will unselect the annotation.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.WaitingToCreate Property

WpfAnnotationCanvasWaitingToCreate Property

Gets a value indicating whether the WpfAnnotationCanvas is waiting for the user to create an annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WaitingToCreate { get; }
Public ReadOnly Property WaitingToCreate As Boolean
    Get

Property Value

Type: Boolean
Indicates whether we are waiting for the user to create an annotation.
Remarks
The ExitCreateMode method can be used to break out of creation mode.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Zoom Property

WpfAnnotationCanvasZoom Property

Gets or sets the zoom level for the document.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
The zoom level for the document.
Remarks
This value must be greater than zero.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas Methods

The WpfAnnotationCanvas type exposes the following members.

Methods
 | Name | Description
Public method | ActivateControlElement | Adds a child element to the canvas.
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AnnotationFromPoint | Finds the annotation at the specified point.
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Protected method | AttachGrips | Attaches the grip adorner of the specified annotation to the WpfAnnotationCanvas.
Protected method | AttachLayerGrips | Attaches the grip adorners of annotations in the provided layer to the WpfAnnotationCanvas.
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
 | Burn(BitmapSource) | Burns all annotations and BitmapSource together, returning the combined image.
 | Burn(WpfAnnotationUI, BitmapSource) | Burns the provided annotation and BitmapSource together, returning the combined image.
 | Burn(WpfAnnotationUICollection, BitmapSource) | Burns annotations in the provided WpfAnnotationUICollection along with the provided BitmapSource and returns the combined image.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearSelection | Clears the currently selected annotations.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the selected annotations to the clipboard as XMP annotation data.
Public method | CountAnnotations | Counts the number of annotations in this canvas.
Public method | CountAnnotations(WpfLayerAnnotation) | Counts the number of annotations in the provided layer.
Public method | CreateAnnotation | Use this method to enter "create" mode where the user will create the provided annotation using the mouse.
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | CreateViewerMatrix | Returns a Matrix used when rendering annotations to the viewer.
 | CreateVisual | Returns a Visual object of the annotations. This is useful for printing annotations or saving them to XPS documents.
 | CreateVisual(BitmapSource) | Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
 | CreateVisual(BitmapSource, Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
 | CreateVisual(WpfAnnotationUICollection, BitmapSource, Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the specified annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
Public method | Cut | Copies the selected annotations to the clipboard as XMP annotation data, then removes the selected annotations from the viewer.
Public method | DeactivateControlElement | Removes a child control from the canvas.
Protected method | DetachGrips | Detaches the annotation grips from the WpfAnnotationCanvas.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | ExitCreateMode | Use this method to exit out of "create" mode.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetConfinedLocation | This method can be used to determine a valid location for an annotation with regard to the confinement area.
Public method | GetConfinedRotation | This method can be used to determine whether the provided rotation value is valid for the annotation with regard to the confinement area.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a clipping geometry that indicates the area that will be clipped if the ClipToBounds property is set to true. (Inherited from Canvas.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetTopLevelLayer | Returns the top level layer for the provided annotation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Public method | Group | Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.
Public method | Group(WpfAnnotationUI) | Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Overrides UIElementHitTestCore(PointHitTestParameters).)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Load(Byte, AnnotationDataFormat) | Loads annotations from a byte array with the specified data format.
Public method | Load(Byte, IFormatter) | Loads annotations from a byte array into the layer collection.
Public method | Load(Stream, AnnotationDataFormat) | Loads annotations from a stream with the specified data format.
Public method | Load(Stream, IFormatter) | Loads annotations from a stream into the layer collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotations from a file with the specified data format.
Public method | Load(String, IFormatter) | Loads annotations from a file into the layers collection.
Public method | Load(Byte, WpfLayerAnnotation, IFormatter) | Loads annotations from a byte array into the provided layer.
Public method | Load(Stream, WpfLayerAnnotation, IFormatter) | Loads annotations from a stream into the provided layer.
Public method | Load(String, WpfLayerAnnotation, IFormatter) | Loads annotations from a file into the provided layer.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAnnotationCreated | Raises the AnnotationCreated event.
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseUp(MouseButtonEventArgs).)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Overrides PanelOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes annotations from the clipboard into the current layer.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RenderAllLayers | Renders all annotations using the provided environment.
 | RenderLayer | Renders a single layer of annotations using the WpfRenderEnvironment provided.
Public method | ReplaceGrips | Replaces the grips of an annotation with new grips.
Public method | RotateDocument(DocumentRotation) | Rotates the annotations in 90 degree increments.
Public method | RotateDocument(DocumentRotation, WpfLayerAnnotation) | Rotates the annotations in 90 degree increments for the specified layer.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the annotations in 90 degree increments for the specified layer index.
Public method | Save(IFormatter) | Serializes all annotations into a byte array.
Public method | Save(AnnotationDataFormat) | Serializes all annotations into a byte array using the specified format.
Public method | Save(Stream, AnnotationDataFormat) | Saves all loaded annotations to a stream with the specified data format.
Public method | Save(Stream, IFormatter) | Saves all loaded annotations to a stream.
Public method | Save(String, AnnotationDataFormat) | Saves all loaded annotations to a file with the specified data format.
Public method | Save(String, IFormatter) | Saves all loaded annotations to a file.
Public method | Save(WpfLayerAnnotation, IFormatter) | Serializes the provided layer into a byte array.
Public method | Save(Stream, WpfLayerAnnotation, IFormatter) | Saves the provided layer to a stream.
Public method | Save(String, WpfLayerAnnotation, IFormatter) | Saves the provided layer to a file.
Public method | SelectAll(Boolean) | Selects all of the annotations on the current layer or all layers.
Public method | SelectAll(WpfLayerAnnotation) | Selects all of the annotations in the specified layer.
Public method | SelectAnnotation(WpfAnnotationUI, Boolean) | Selects the specified annotation optionally replacing the current selection.
Public method | SelectAnnotation(WpfAnnotationUI, Boolean) | Selects one or more annotations with the option of replacing the current selection.
Public method | SelectFromBounds(Rect, Boolean) | Selects annotations that are partially or fully within a rectangular area.
Public method | SelectFromBounds(WpfLayerAnnotation, Rect, Boolean) | Selects annotations from a layer that are without a bounding region.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Ungroup | Ungroups the currently selected annotation into the CurrentLayer.
Public method | Ungroup(WpfLayerAnnotation, WpfLayerAnnotation) | Removes annotations from one layer and adds them to another.
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ActivateControlElement Method

WpfAnnotationCanvasActivateControlElement Method

Adds a child element to the canvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ActivateControlElement(
    WpfAnnotationUI parentAnnotation,
    UIElement element
)
Public Sub ActivateControlElement (
    parentAnnotation As WpfAnnotationUI,
    element As UIElement
)

Parameters

parentAnnotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation associated with this element.
element
Type: System.WindowsUIElement
The element to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AnnotationFromPoint Method

WpfAnnotationCanvasAnnotationFromPoint Method

Finds the annotation at the specified point.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI AnnotationFromPoint(
    Point point,
    bool pointInControlSpace
)
Public Function AnnotationFromPoint (
    point As Point,
    pointInControlSpace As Boolean
) As WpfAnnotationUI

Parameters

point
Type: System.WindowsPoint
The point to look for an annotation.
pointInControlSpace
Type: SystemBoolean
Indicates whether the point is in Viewer (control) space or document space.

Return Value

Type: WpfAnnotationUI
The annotation found at the provided location or null (Nothing in VB) if an annotation is not found.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AttachGrips Method

WpfAnnotationCanvasAttachGrips Method

Attaches the grip adorner of the specified annotation to the WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void AttachGrips(
    WpfAnnotationUI annotation
)
Protected Sub AttachGrips (
    annotation As WpfAnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to attach.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AttachLayerGrips Method

WpfAnnotationCanvasAttachLayerGrips Method

Attaches the grip adorners of annotations in the provided layer to the WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void AttachLayerGrips(
    WpfLayerAnnotation layer
)
Protected Sub AttachLayerGrips (
    layer As WpfLayerAnnotation
)

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer containing annotations to attach.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Burn Method

WpfAnnotationCanvasBurn Method

These methods are used to burn annotations onto a BitmapSource.
Overload List
Name | Description
Burn(BitmapSource) | Burns all annotations and BitmapSource together, returning the combined image.
Burn(WpfAnnotationUI, BitmapSource) | Burns the provided annotation and BitmapSource together, returning the combined image.
Burn(WpfAnnotationUICollection, BitmapSource) | Burns annotations in the provided WpfAnnotationUICollection along with the provided BitmapSource and returns the combined image.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Burn Method (BitmapSource)

WpfAnnotationCanvasBurn Method (BitmapSource)

Burns all annotations and BitmapSource together, returning the combined image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapSource Burn(
    BitmapSource source
)
Public Function Burn (
    source As BitmapSource
) As BitmapSource

Parameters

source
Type: System.Windows.Media.ImagingBitmapSource
A BitmapSource onto which annotations will burn.

Return Value

Type: BitmapSource
A new image of the combined source image and annotations.
Exceptions
Exception | Condition
 | Thrown if the source argument is null (Nothing in VB).
Examples
Burn Method
See Also

Reference

WpfAnnotationCanvas Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Burn Method (WpfAnnotationUI, BitmapSource)

WpfAnnotationCanvasBurn Method (WpfAnnotationUI, BitmapSource)

Burns the provided annotation and BitmapSource together, returning the combined image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapSource Burn(
    WpfAnnotationUI annotation,
    BitmapSource source
)
Public Function Burn (
    annotation As WpfAnnotationUI,
    source As BitmapSource
) As BitmapSource

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to burn.
source
Type: System.Windows.Media.ImagingBitmapSource
A BitmapSource onto which the annotation will burn.

Return Value

Type: BitmapSource
A new image of the combined source image and annotation.
Exceptions
Exception | Condition
 | Thrown if any arguments are null (Nothing in VB).
Examples
Burn Method
See Also

Reference

WpfAnnotationCanvas Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Burn Method (WpfAnnotationUICollection, BitmapSource)

WpfAnnotationCanvasBurn Method (WpfAnnotationUICollection, BitmapSource)

Burns annotations in the provided WpfAnnotationUICollection along with the provided BitmapSource and returns the combined image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapSource Burn(
    WpfAnnotationUICollection annotations,
    BitmapSource source
)
Public Function Burn (
    annotations As WpfAnnotationUICollection,
    source As BitmapSource
) As BitmapSource

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUICollection
A WpfAnnotationUICollection containing annotations to burn.
source
Type: System.Windows.Media.ImagingBitmapSource
A BitmapSource onto which annotations will burn.

Return Value

Type: BitmapSource
A new image of the combined source image and annotations.
Exceptions
Exception | Condition
 | Thrown if any arguments are null (Nothing in VB).
Examples
Burn Method
See Also

Reference

WpfAnnotationCanvas Class
Burn Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ClearSelection Method

WpfAnnotationCanvasClearSelection Method

Clears the currently selected annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearSelection()
Public Sub ClearSelection
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Copy Method

WpfAnnotationCanvasCopy Method

Copies the selected annotations to the clipboard as XMP annotation data.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Copy()
Public Sub Copy
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CountAnnotations Method

WpfAnnotationCanvasCountAnnotations Method

These methods count the annotations in all layers or only a single layer.
Overload List
 | Name | Description
Public method | CountAnnotations | Counts the number of annotations in this canvas.
Public method | CountAnnotations(WpfLayerAnnotation) | Counts the number of annotations in the provided layer.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CountAnnotations Method

WpfAnnotationCanvasCountAnnotations Method

Counts the number of annotations in this canvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CountAnnotations()
Public Function CountAnnotations As Integer

Return Value

Type: Int32
The number of annotations found.
Remarks
Group annotations will only count as 1 annotation.
Remarks
Group annotations will only count as 1 annotation.
See Also

Reference

WpfAnnotationCanvas Class
CountAnnotations Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CountAnnotations Method (WpfLayerAnnotation)

WpfAnnotationCanvasCountAnnotations Method (WpfLayerAnnotation)

Counts the number of annotations in the provided layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CountAnnotations(
    WpfLayerAnnotation layer
)
Public Function CountAnnotations (
    layer As WpfLayerAnnotation
) As Integer

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to count annotations from.

Return Value

Type: Int32
The number of annotations found in the layer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer argument is null (Nothing in VB).
Remarks
Group annotations will only count as 1 annotation.
See Also

Reference

WpfAnnotationCanvas Class
CountAnnotations Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateAnnotation Method

WpfAnnotationCanvasCreateAnnotation Method

Use this method to enter "create" mode where the user will create the provided annotation using the mouse.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CreateAnnotation(
    WpfAnnotationUI annotationToCreate
)
Public Sub CreateAnnotation (
    annotationToCreate As WpfAnnotationUI
)

Parameters

annotationToCreate
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to create.
Remarks
Create mode is automatically existed when the user has finished creating the annotation. To force 'create' mode to exit, call ExitCreateMode.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateViewerMatrix Method

WpfAnnotationCanvasCreateViewerMatrix Method

Returns a Matrix used when rendering annotations to the viewer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix CreateViewerMatrix()
Public Function CreateViewerMatrix As Matrix

Return Value

Type: Matrix
The Matrix used when rendering annotations to the viewer.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateVisual Method

WpfAnnotationCanvasCreateVisual Method

These methods are used to create a Visual of the annotations.
Overload List
Name | Description
CreateVisual | Returns a Visual object of the annotations. This is useful for printing annotations or saving them to XPS documents.
CreateVisual(BitmapSource) | Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
CreateVisual(BitmapSource, Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
CreateVisual(WpfAnnotationUICollection, BitmapSource, Size, WpfVisualScaleMode, Thickness) | Returns a Visual object of the specified annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateVisual Method

WpfAnnotationCanvasCreateVisual Method

Returns a Visual object of the annotations. This is useful for printing annotations or saving them to XPS documents.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Visual CreateVisual()
Public Function CreateVisual As Visual

Return Value

Type: Visual
A Visual object of the annotations.
Examples
CreateVisual Method
See Also

Reference

WpfAnnotationCanvas Class
CreateVisual Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateVisual Method (BitmapSource)

WpfAnnotationCanvasCreateVisual Method (BitmapSource)

Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Visual CreateVisual(
    BitmapSource source
)
Public Function CreateVisual (
    source As BitmapSource
) As Visual

Parameters

source
Type: System.Windows.Media.ImagingBitmapSource
A source image the annotations will render over. This may be null (Nothing in VB).

Return Value

Type: Visual
A Visual object of the annotations and image.
Remarks
When a source image is provided, the annotation rendering will be clipped to the image area.
Examples
CreateVisual Method
See Also

Reference

WpfAnnotationCanvas Class
CreateVisual Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateVisual Method (BitmapSource, Size, WpfVisualScaleMode, Thickness)

WpfAnnotationCanvasCreateVisual Method (BitmapSource, Size, WpfVisualScaleMode, Thickness)

Returns a Visual object of the annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Visual CreateVisual(
    BitmapSource source,
    Size pageSize,
    WpfVisualScaleMode scaleMode,
    Thickness padding
)
Public Function CreateVisual (
    source As BitmapSource,
    pageSize As Size,
    scaleMode As WpfVisualScaleMode,
    padding As Thickness
) As Visual

Parameters

source
Type: System.Windows.Media.ImagingBitmapSource
A source image the annotations will render over. This may be null (Nothing in VB).
pageSize
Type: System.WindowsSize
The page size used to scale the annotation and image rendering.
scaleMode
Type: Atalasoft.Annotate.WpfWpfVisualScaleMode
The type of scaling to perform.
padding
Type: System.WindowsThickness
The padding around the annotations and image.

Return Value

Type: Visual
A Visual object of the annotations and image.
Remarks
When a source image is provided, the annotation rendering will be clipped to the image area.
Examples
CreateVisual Method
See Also

Reference

WpfAnnotationCanvas Class
CreateVisual Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateVisual Method (WpfAnnotationUICollection, BitmapSource, Size, WpfVisualScaleMode, Thickness)

WpfAnnotationCanvasCreateVisual Method (WpfAnnotationUICollection, BitmapSource, Size, WpfVisualScaleMode, Thickness)

Returns a Visual object of the specified annotations and optional source image using the specified parameters. This is useful for printing annotations or saving them to XPS documents.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Visual CreateVisual(
    WpfAnnotationUICollection annotations,
    BitmapSource source,
    Size pageSize,
    WpfVisualScaleMode scaleMode,
    Thickness padding
)
Public Function CreateVisual (
    annotations As WpfAnnotationUICollection,
    source As BitmapSource,
    pageSize As Size,
    scaleMode As WpfVisualScaleMode,
    padding As Thickness
) As Visual

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUICollection
A collection of WpfAnnotationUI object.
source
Type: System.Windows.Media.ImagingBitmapSource
A source image the annotations will render over. This may be null (Nothing in VB).
pageSize
Type: System.WindowsSize
The page size used to scale the annotation and image rendering.
scaleMode
Type: Atalasoft.Annotate.WpfWpfVisualScaleMode
The type of scaling to perform.
padding
Type: System.WindowsThickness
The padding around the annotations and image.

Return Value

Type: Visual
A Visual object of the annotations and image.
Exceptions
Exception | Condition
 | Thrown if the annotations argument is null (Nothing in VB).
Remarks
When a source image is provided, the annotation rendering will be clipped to the image area.
Examples
CreateVisual Method
See Also

Reference

WpfAnnotationCanvas Class
CreateVisual Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Cut Method

WpfAnnotationCanvasCut Method

Copies the selected annotations to the clipboard as XMP annotation data, then removes the selected annotations from the viewer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Cut()
Public Sub Cut
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.DeactivateControlElement Method

WpfAnnotationCanvasDeactivateControlElement Method

Removes a child control from the canvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DeactivateControlElement(
    UIElement element
)
Public Sub DeactivateControlElement (
    element As UIElement
)

Parameters

element
Type: System.WindowsUIElement
The element to remove.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the element argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.DetachGrips Method

WpfAnnotationCanvasDetachGrips Method

Detaches the annotation grips from the WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void DetachGrips(
    WpfAnnotationUI annotation
)
Protected Sub DetachGrips (
    annotation As WpfAnnotationUI
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to detach from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ExitCreateMode Method

WpfAnnotationCanvasExitCreateMode Method

Use this method to exit out of "create" mode.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ExitCreateMode()
Public Sub ExitCreateMode
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.GetConfinedLocation Method

WpfAnnotationCanvasGetConfinedLocation Method

This method can be used to determine a valid location for an annotation with regard to the confinement area.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point GetConfinedLocation(
    WpfAnnotationUI annotation,
    Point requestedLocation
)
Public Function GetConfinedLocation (
    annotation As WpfAnnotationUI,
    requestedLocation As Point
) As Point

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation this new location will be used with.
requestedLocation
Type: System.WindowsPoint
The requested location to test.

Return Value

Type: Point
A valid location for this annotation, keeping it within the confined bounds.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.GetConfinedRotation Method

WpfAnnotationCanvasGetConfinedRotation Method

This method can be used to determine whether the provided rotation value is valid for the annotation with regard to the confinement area.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetConfinedRotation(
    WpfAnnotationUI annotation,
    double requestedRotation
)
Public Function GetConfinedRotation (
    annotation As WpfAnnotationUI,
    requestedRotation As Double
) As Double

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation this rotation would be used with.
requestedRotation
Type: SystemDouble
The requested rotation for the annotation.

Return Value

Type: Double
A valid rotation for this annotation, keeping it within the confined bounds.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.GetTopLevelLayer Method

WpfAnnotationCanvasGetTopLevelLayer Method

Returns the top level layer for the provided annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation GetTopLevelLayer(
    WpfAnnotationUI annotation
)
Public Function GetTopLevelLayer (
    annotation As WpfAnnotationUI
) As WpfLayerAnnotation

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to work with.

Return Value

Type: WpfLayerAnnotation
The top level layer containing the provided annotation or null (Nothing in VB) if a layer cannot be found.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Group Method

WpfAnnotationCanvasGroup Method

Overload List
 | Name | Description
Public method | Group | Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.
Public method | Group(WpfAnnotationUI) | Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Group Method

WpfAnnotationCanvasGroup Method

Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation Group()
Public Function Group As WpfLayerAnnotation

Return Value

Type: WpfLayerAnnotation
Remarks
This method will remove the annotations from the current layer they are in and place them into a new WpfLayerAnnotation.
See Also

Reference

WpfAnnotationCanvas Class
Group Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Group Method (WpfAnnotationUI[])

WpfAnnotationCanvasGroup Method (WpfAnnotationUI)

Combines annotations into a WpfLayerAnnotation and adds it to the CurrentLayer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation Group(
    WpfAnnotationUI[] annotations
)
Public Function Group (
    annotations As WpfAnnotationUI()
) As WpfLayerAnnotation

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
An array of annotations to group.

Return Value

Type: WpfLayerAnnotation
Remarks
This method will remove the annotations from the current layer they are in and place them into a new WpfLayerAnnotation.
See Also

Reference

WpfAnnotationCanvas Class
Group Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.HitTestCore Method

WpfAnnotationCanvasHitTestCore Method

Overload List
 | Name | Description
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Overrides UIElementHitTestCore(PointHitTestParameters).)
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.HitTestCore Method (PointHitTestParameters)

WpfAnnotationCanvasHitTestCore Method (PointHitTestParameters)

Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult).

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override HitTestResult HitTestCore(
    PointHitTestParameters hitTestParameters
)
Protected Overrides Function HitTestCore (
    hitTestParameters As PointHitTestParameters
) As HitTestResult

Parameters

hitTestParameters
Type: System.Windows.MediaPointHitTestParameters
Describes the hit test to perform, including the initial hit point.

Return Value

Type: HitTestResult
Results of the test, including the evaluated point.
See Also

Reference

WpfAnnotationCanvas Class
HitTestCore Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method

WpfAnnotationCanvasLoad Method

Overload List
 | Name | Description
Public method | Load(Byte, AnnotationDataFormat) | Loads annotations from a byte array with the specified data format.
Public method | Load(Byte, IFormatter) | Loads annotations from a byte array into the layer collection.
Public method | Load(Stream, AnnotationDataFormat) | Loads annotations from a stream with the specified data format.
Public method | Load(Stream, IFormatter) | Loads annotations from a stream into the layer collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotations from a file with the specified data format.
Public method | Load(String, IFormatter) | Loads annotations from a file into the layers collection.
Public method | Load(Byte, WpfLayerAnnotation, IFormatter) | Loads annotations from a byte array into the provided layer.
Public method | Load(Stream, WpfLayerAnnotation, IFormatter) | Loads annotations from a stream into the provided layer.
Public method | Load(String, WpfLayerAnnotation, IFormatter) | Loads annotations from a file into the provided layer.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (Byte[], AnnotationDataFormat)

WpfAnnotationCanvasLoad Method (Byte, AnnotationDataFormat)

Loads annotations from a byte array with the specified data format.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] data,
    AnnotationDataFormat format
)
Public Sub Load (
    data As Byte(),
    format As AnnotationDataFormat
)

Parameters

data
Type: SystemByte
The byte array containing annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
SerializationException | Thrown if there is an error during deserialization.
ArgumentException | Thrown if the data format is unknown.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (Byte[], IFormatter)

WpfAnnotationCanvasLoad Method (Byte, IFormatter)

Loads annotations from a byte array into the layer collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] data,
    IFormatter formatter
)
Public Sub Load (
    data As Byte(),
    formatter As IFormatter
)

Parameters

data
Type: SystemByte
The byte array containing annotation data.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
SerializationException | Thrown if there is an error during deserialization.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (Stream, AnnotationDataFormat)

WpfAnnotationCanvasLoad Method (Stream, AnnotationDataFormat)

Loads annotations from a stream with the specified data format.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    AnnotationDataFormat format
)
Public Sub Load (
    stream As Stream,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
The stream containing annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
ArgumentException | Thrown if the stream does not have read access.
SerializationException | Thrown if there is an error during deserialization.
ArgumentException | Thrown if the data format is unknown.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (Stream, IFormatter)

WpfAnnotationCanvasLoad Method (Stream, IFormatter)

Loads annotations from a stream into the layer collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    IFormatter formatter
)
Public Sub Load (
    stream As Stream,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
The stream containing annotation data.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
ArgumentException | Thrown if the stream does not have read access.
SerializationException | Thrown if there is an error during deserialization.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (String, AnnotationDataFormat)

WpfAnnotationCanvasLoad Method (String, AnnotationDataFormat)

Loads annotations from a file with the specified data format.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    AnnotationDataFormat format
)
Public Sub Load (
    fileName As String,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The filename where annotation data is stored.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The format of the annotation data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
FileNotFoundException | Thrown if the file does not exist.
SerializationException | Thrown if there is an error during deserialization.
ArgumentException | Thrown if the data format is unknown.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (String, IFormatter)

WpfAnnotationCanvasLoad Method (String, IFormatter)

Loads annotations from a file into the layers collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    IFormatter formatter
)
Public Sub Load (
    fileName As String,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The filename where annotation data is stored.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
FileNotFoundException | Thrown if the file does not exist.
SerializationException | Thrown if there is an error during deserialization.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (Byte[], WpfLayerAnnotation, IFormatter)

WpfAnnotationCanvasLoad Method (Byte, WpfLayerAnnotation, IFormatter)

Loads annotations from a byte array into the provided layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    byte[] data,
    WpfLayerAnnotation layer,
    IFormatter formatter
)
Public Sub Load (
    data As Byte(),
    layer As WpfLayerAnnotation,
    formatter As IFormatter
)

Parameters

data
Type: SystemByte
A byte array containing annotation data.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to which the annotations will be added.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
SerializationException | Thrown if there is an error during deserialization.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (Stream, WpfLayerAnnotation, IFormatter)

WpfAnnotationCanvasLoad Method (Stream, WpfLayerAnnotation, IFormatter)

Loads annotations from a stream into the provided layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    WpfLayerAnnotation layer,
    IFormatter formatter
)
Public Sub Load (
    stream As Stream,
    layer As WpfLayerAnnotation,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
A stream containing annotation data.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to which the annotations will be added.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
ArgumentException | Thrown if the stream does not have read access.
SerializationException | Thrown if there is an error during deserialization.
Remarks
If the annotation data is a collection of layers, each layer will be added as a child item supplied layer. If the data is a single layer, all annotations within the deserialized layer will be added to the supplied layer.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Load Method (String, WpfLayerAnnotation, IFormatter)

WpfAnnotationCanvasLoad Method (String, WpfLayerAnnotation, IFormatter)

Loads annotations from a file into the provided layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    WpfLayerAnnotation layer,
    IFormatter formatter
)
Public Sub Load (
    fileName As String,
    layer As WpfLayerAnnotation,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The filename where annotation data is stored.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to which the annotations will be added.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to deserialize the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
FileNotFoundException | Thrown if the file does not exist.
SerializationException | Thrown if there is an error during deserialization.
Remarks
If the annotation data is a collection of layers, each layer will be added as a child item supplied layer. If the data is a single layer, all annotations within the deserialized layer will be added to the supplied layer.
See Also

Reference

WpfAnnotationCanvas Class
Load Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.OnAnnotationCreated Method

WpfAnnotationCanvasOnAnnotationCreated Method

Raises the AnnotationCreated event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationCreated(
    EventArgs<WpfAnnotationUI> e
)
Protected Overridable Sub OnAnnotationCreated (
    e As EventArgs(Of WpfAnnotationUI)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationUI
The EventArgs <WpfAnnotationUI>instance containing the event data.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.OnMouseDown Method

WpfAnnotationCanvasOnMouseDown Method

Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.OnMouseMove Method

WpfAnnotationCanvasOnMouseMove Method

Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.OnMouseUp Method

WpfAnnotationCanvasOnMouseUp Method

Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. The event data reports that the mouse button was released.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.OnPropertyChanged Method

WpfAnnotationCanvasOnPropertyChanged Method

Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs).

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The event data that describes the property that changed, as well as old and new values.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.OnRender Method

WpfAnnotationCanvasOnRender Method

Draws the content of a DrawingContext object during the render pass of a Panel element.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext dc
)
Protected Overrides Sub OnRender (
    dc As DrawingContext
)

Parameters

dc
Type: System.Windows.MediaDrawingContext
The DrawingContext object to draw.
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Paste Method

WpfAnnotationCanvasPaste Method

Pastes annotations from the clipboard into the current layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Paste()
Public Sub Paste
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RenderAllLayers Method

WpfAnnotationCanvasRenderAllLayers Method

Renders all annotations using the provided environment.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RenderAllLayers(
    WpfRenderEnvironment environment
)
Public Sub RenderAllLayers (
    environment As WpfRenderEnvironment
)

Parameters

environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A render environment containing information needed to perform this action.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the environment argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RenderLayer Method

WpfAnnotationCanvasRenderLayer Method

Renders a single layer of annotations using the WpfRenderEnvironment provided.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void RenderLayer(
    WpfLayerAnnotation layer,
    WpfRenderEnvironment environment
)
Public Shared Sub RenderLayer (
    layer As WpfLayerAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer containing annotations to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A render environment containing information needed to perform this action.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ReplaceGrips Method

WpfAnnotationCanvasReplaceGrips Method

Replaces the grips of an annotation with new grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ReplaceGrips(
    WpfAnnotationUI annotation,
    WpfAnnotationGrips newGrips
)
Public Sub ReplaceGrips (
    annotation As WpfAnnotationUI,
    newGrips As WpfAnnotationGrips
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation for which grips will be replaced.
newGrips
Type: Atalasoft.Annotate.WpfWpfAnnotationGrips
The new grips. This can be null (Nothing in VB).
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotateDocument Method

WpfAnnotationCanvasRotateDocument Method

Overload List
 | Name | Description
Public method | RotateDocument(DocumentRotation) | Rotates the annotations in 90 degree increments.
Public method | RotateDocument(DocumentRotation, WpfLayerAnnotation) | Rotates the annotations in 90 degree increments for the specified layer.
Public method | RotateDocument(DocumentRotation, Int32) | Rotates the annotations in 90 degree increments for the specified layer index.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotateDocument Method (DocumentRotation)

WpfAnnotationCanvasRotateDocument Method (DocumentRotation)

Rotates the annotations in 90 degree increments.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation
)
Public Sub RotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation amount.
See Also

Reference

WpfAnnotationCanvas Class
RotateDocument Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotateDocument Method (DocumentRotation, WpfLayerAnnotation)

WpfAnnotationCanvasRotateDocument Method (DocumentRotation, WpfLayerAnnotation)

Rotates the annotations in 90 degree increments for the specified layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    WpfLayerAnnotation layer
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layer As WpfLayerAnnotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation amount.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to rotate or null (Nothing in VB) to rotate all layers.
See Also

Reference

WpfAnnotationCanvas Class
RotateDocument Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotateDocument Method (DocumentRotation, Int32)

WpfAnnotationCanvasRotateDocument Method (DocumentRotation, Int32)

Rotates the annotations in 90 degree increments for the specified layer index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateDocument(
    DocumentRotation rotation,
    int layerIndex
)
Public Sub RotateDocument (
    rotation As DocumentRotation,
    layerIndex As Integer
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The rotation amount.
layerIndex
Type: SystemInt32
The index of the layer to rotate.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for the layer collection.
See Also

Reference

WpfAnnotationCanvas Class
RotateDocument Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method

WpfAnnotationCanvasSave Method

Overload List
 | Name | Description
Public method | Save(IFormatter) | Serializes all annotations into a byte array.
Public method | Save(AnnotationDataFormat) | Serializes all annotations into a byte array using the specified format.
Public method | Save(Stream, AnnotationDataFormat) | Saves all loaded annotations to a stream with the specified data format.
Public method | Save(Stream, IFormatter) | Saves all loaded annotations to a stream.
Public method | Save(String, AnnotationDataFormat) | Saves all loaded annotations to a file with the specified data format.
Public method | Save(String, IFormatter) | Saves all loaded annotations to a file.
Public method | Save(WpfLayerAnnotation, IFormatter) | Serializes the provided layer into a byte array.
Public method | Save(Stream, WpfLayerAnnotation, IFormatter) | Saves the provided layer to a stream.
Public method | Save(String, WpfLayerAnnotation, IFormatter) | Saves the provided layer to a file.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (IFormatter)

WpfAnnotationCanvasSave Method (IFormatter)

Serializes all annotations into a byte array.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Save(
    IFormatter formatter
)
Public Function Save (
    formatter As IFormatter
) As Byte()

Parameters

formatter
Type: System.Runtime.SerializationIFormatter
The formatter used for serialization.

Return Value

Type: Byte
A byte array containing the serialized data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the formatter is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (AnnotationDataFormat)

WpfAnnotationCanvasSave Method (AnnotationDataFormat)

Serializes all annotations into a byte array using the specified format.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Save(
    AnnotationDataFormat format
)
Public Function Save (
    format As AnnotationDataFormat
) As Byte()

Parameters

format
Type: Atalasoft.AnnotateAnnotationDataFormat
The data format to use.

Return Value

Type: Byte
A byte array containing the serialized data.
Exceptions
Exception | Condition
ArgumentException | Thrown if the data format is unknown.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (Stream, AnnotationDataFormat)

WpfAnnotationCanvasSave Method (Stream, AnnotationDataFormat)

Saves all loaded annotations to a stream with the specified data format.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    AnnotationDataFormat format
)
Public Sub Save (
    stream As Stream,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
The stream to which the data will be saved.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The data format to use.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB).
ArgumentException | Thrown if the stream does not have write access.
ArgumentException | Thrown if the data format is unknown.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (Stream, IFormatter)

WpfAnnotationCanvasSave Method (Stream, IFormatter)

Saves all loaded annotations to a stream.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    IFormatter formatter
)
Public Sub Save (
    stream As Stream,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
The stream to which the data will be saved.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to save the annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB).
ArgumentException | Thrown if the stream does not have write access.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (String, AnnotationDataFormat)

WpfAnnotationCanvasSave Method (String, AnnotationDataFormat)

Saves all loaded annotations to a file with the specified data format.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    AnnotationDataFormat format
)
Public Sub Save (
    fileName As String,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The filename to which the data will be saved.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The data format to use.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB) or if the filename is zero length.
ArgumentException | Thrown if the data format is unknown.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (String, IFormatter)

WpfAnnotationCanvasSave Method (String, IFormatter)

Saves all loaded annotations to a file.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    IFormatter formatter
)
Public Sub Save (
    fileName As String,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The filename to which the data will be saved.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to save the annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB) or if the filename is zero length.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (WpfLayerAnnotation, IFormatter)

WpfAnnotationCanvasSave Method (WpfLayerAnnotation, IFormatter)

Serializes the provided layer into a byte array.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Save(
    WpfLayerAnnotation layer,
    IFormatter formatter
)
Public Function Save (
    layer As WpfLayerAnnotation,
    formatter As IFormatter
) As Byte()

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to serialize.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used for serialization.

Return Value

Type: Byte
A byte array containing the serialized data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (Stream, WpfLayerAnnotation, IFormatter)

WpfAnnotationCanvasSave Method (Stream, WpfLayerAnnotation, IFormatter)

Saves the provided layer to a stream.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    WpfLayerAnnotation layer,
    IFormatter formatter
)
Public Sub Save (
    stream As Stream,
    layer As WpfLayerAnnotation,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
The stream to which the data will be saved.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to save.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to save the annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB).
ArgumentException | Thrown if the stream does not have write access.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Save Method (String, WpfLayerAnnotation, IFormatter)

WpfAnnotationCanvasSave Method (String, WpfLayerAnnotation, IFormatter)

Saves the provided layer to a file.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    WpfLayerAnnotation layer,
    IFormatter formatter
)
Public Sub Save (
    fileName As String,
    layer As WpfLayerAnnotation,
    formatter As IFormatter
)

Parameters

fileName
Type: SystemString
The filename to which the data will be saved.
layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to save.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to save the annotations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any parameters passed in are null (Nothing in VB) or if the filename is zero length.
See Also

Reference

WpfAnnotationCanvas Class
Save Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectAll Method

WpfAnnotationCanvasSelectAll Method

Overload List
 | Name | Description
Public method | SelectAll(Boolean) | Selects all of the annotations on the current layer or all layers.
Public method | SelectAll(WpfLayerAnnotation) | Selects all of the annotations in the specified layer.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectAll Method (Boolean)

WpfAnnotationCanvasSelectAll Method (Boolean)

Selects all of the annotations on the current layer or all layers.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAll(
    bool allLayers
)
Public Sub SelectAll (
    allLayers As Boolean
)

Parameters

allLayers
Type: SystemBoolean
Indicates whether to select annotations on all of the layers. If this is false, only the current layer annotations are selected.
See Also

Reference

WpfAnnotationCanvas Class
SelectAll Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectAll Method (WpfLayerAnnotation)

WpfAnnotationCanvasSelectAll Method (WpfLayerAnnotation)

Selects all of the annotations in the specified layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAll(
    WpfLayerAnnotation layer
)
Public Sub SelectAll (
    layer As WpfLayerAnnotation
)

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer containing annotations to select.
See Also

Reference

WpfAnnotationCanvas Class
SelectAll Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectAnnotation Method

WpfAnnotationCanvasSelectAnnotation Method

These methods are used to select one or more annotations with the option is replacing the current selection.
Overload List
 | Name | Description
Public method | SelectAnnotation(WpfAnnotationUI, Boolean) | Selects the specified annotation optionally replacing the current selection.
Public method | SelectAnnotation(WpfAnnotationUI, Boolean) | Selects one or more annotations with the option of replacing the current selection.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectAnnotation Method (WpfAnnotationUI, Boolean)

WpfAnnotationCanvasSelectAnnotation Method (WpfAnnotationUI, Boolean)

Selects the specified annotation optionally replacing the current selection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAnnotation(
    WpfAnnotationUI annotation,
    bool replaceCurrentSelection
)
Public Sub SelectAnnotation (
    annotation As WpfAnnotationUI,
    replaceCurrentSelection As Boolean
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to select.
replaceCurrentSelection
Type: SystemBoolean
Indicates whether the current selection should be replaced.
Exceptions
Exception | Condition
 | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
SelectAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectAnnotation Method (WpfAnnotationUI[], Boolean)

WpfAnnotationCanvasSelectAnnotation Method (WpfAnnotationUI, Boolean)

Selects one or more annotations with the option of replacing the current selection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAnnotation(
    WpfAnnotationUI[] annotations,
    bool replaceCurrentSelection
)
Public Sub SelectAnnotation (
    annotations As WpfAnnotationUI(),
    replaceCurrentSelection As Boolean
)

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
An array of annotations to select.
replaceCurrentSelection
Type: SystemBoolean
Indicates whether the current selection should be replaced.
Exceptions
Exception | Condition
 | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
SelectAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectFromBounds Method

WpfAnnotationCanvasSelectFromBounds Method

Overload List
 | Name | Description
Public method | SelectFromBounds(Rect, Boolean) | Selects annotations that are partially or fully within a rectangular area.
Public method | SelectFromBounds(WpfLayerAnnotation, Rect, Boolean) | Selects annotations from a layer that are without a bounding region.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectFromBounds Method (Rect, Boolean)

WpfAnnotationCanvasSelectFromBounds Method (Rect, Boolean)

Selects annotations that are partially or fully within a rectangular area.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectFromBounds(
    Rect bounds,
    bool fullyContained
)
Public Sub SelectFromBounds (
    bounds As Rect,
    fullyContained As Boolean
)

Parameters

bounds
Type: System.WindowsRect
The bounding rectangle to look for annotations. This value must be specified in document space.
fullyContained
Type: SystemBoolean
Indicates if the annotation has to be fully within the bounds before it's selected.
See Also

Reference

WpfAnnotationCanvas Class
SelectFromBounds Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectFromBounds Method (WpfLayerAnnotation, Rect, Boolean)

WpfAnnotationCanvasSelectFromBounds Method (WpfLayerAnnotation, Rect, Boolean)

Selects annotations from a layer that are without a bounding region.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectFromBounds(
    WpfLayerAnnotation layer,
    Rect bounds,
    bool fullyContained
)
Public Sub SelectFromBounds (
    layer As WpfLayerAnnotation,
    bounds As Rect,
    fullyContained As Boolean
)

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to search for annotations.
bounds
Type: System.WindowsRect
The bounding rectangle to search. This value must be specified in document space.
fullyContained
Type: SystemBoolean
Indicates if the annotation has to be fully within the bounds before it's selected.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationCanvas Class
SelectFromBounds Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Ungroup Method

WpfAnnotationCanvasUngroup Method

Overload List
 | Name | Description
Public method | Ungroup | Ungroups the currently selected annotation into the CurrentLayer.
Public method | Ungroup(WpfLayerAnnotation, WpfLayerAnnotation) | Removes annotations from one layer and adds them to another.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Ungroup Method

WpfAnnotationCanvasUngroup Method

Ungroups the currently selected annotation into the CurrentLayer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Ungroup()
Public Sub Ungroup
Remarks
This method will do nothing if the currently selected annotation is not a group.
See Also

Reference

WpfAnnotationCanvas Class
Ungroup Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.Ungroup Method (WpfLayerAnnotation, WpfLayerAnnotation)

WpfAnnotationCanvasUngroup Method (WpfLayerAnnotation, WpfLayerAnnotation)

Removes annotations from one layer and adds them to another.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Ungroup(
    WpfLayerAnnotation groupLayer,
    WpfLayerAnnotation hostLayer
)
Public Sub Ungroup (
    groupLayer As WpfLayerAnnotation,
    hostLayer As WpfLayerAnnotation
)

Parameters

groupLayer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer containing annotations to ungroup.
hostLayer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer where annotation will be added.
Remarks
If the groupLayer is contained within a layer currently in the LayerCollection it will be removed from the collection.
See Also

Reference

WpfAnnotationCanvas Class
Ungroup Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas Events

The WpfAnnotationCanvas type exposes the following members.

Events
 | Name | Description
Public event | AnnotationCreated | This event is raised when a user has finished creating an annotation.
Public event | AnnotationDeserialization | This event is raised after annotation have been deserialized, providing an option to replace the annotation objects.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | GripsAttached | This event is raised when grips have been attached to an annotation.
Public event | HotSpotClicked | This event is raised when a hot spot annotation is clicked.
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | This event is raised when a property has changed.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectedAnnotationsChanged | This event is raised when the annoation selection has changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AnnotationCreated Event

WpfAnnotationCanvasAnnotationCreated Event

This event is raised when a user has finished creating an annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<EventArgs<WpfAnnotationUI>> AnnotationCreated
Public Event AnnotationCreated As EventHandler(Of EventArgs(Of WpfAnnotationUI))

Value

Type: SystemEventHandler EventArgs WpfAnnotationUI
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AnnotationDeserialization Event

WpfAnnotationCanvasAnnotationDeserialization Event

This event is raised after annotation have been deserialized, providing an option to replace the annotation objects.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<AnnotationDeserializationEventArgs<WpfAnnotationCanvas>> AnnotationDeserialization
Public Event AnnotationDeserialization As EventHandler(Of AnnotationDeserializationEventArgs(Of WpfAnnotationCanvas))

Value

Type: SystemEventHandler AnnotationDeserializationEventArgs WpfAnnotationCanvas
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.GripsAttached Event

WpfAnnotationCanvasGripsAttached Event

This event is raised when grips have been attached to an annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<EventArgs<WpfAnnotationUI>> GripsAttached
Public Event GripsAttached As EventHandler(Of EventArgs(Of WpfAnnotationUI))

Value

Type: SystemEventHandler EventArgs WpfAnnotationUI
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.HotSpotClicked Event

WpfAnnotationCanvasHotSpotClicked Event

This event is raised when a hot spot annotation is clicked.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<EventArgs<WpfAnnotationUI>> HotSpotClicked
Public Event HotSpotClicked As EventHandler(Of EventArgs(Of WpfAnnotationUI))

Value

Type: SystemEventHandler EventArgs WpfAnnotationUI
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.PropertyChanged Event

WpfAnnotationCanvasPropertyChanged Event

This event is raised when a property has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DependencyPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As DependencyPropertyChangedEventHandler

Value

Type: System.WindowsDependencyPropertyChangedEventHandler
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectedAnnotationsChanged Event

WpfAnnotationCanvasSelectedAnnotationsChanged Event

This event is raised when the annoation selection has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectedAnnotationsChanged
Public Event SelectedAnnotationsChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas Fields

The WpfAnnotationCanvas type exposes the following members.

Fields
Name | Description
ActiveAnnotationProperty | Identifies the ActiveAnnotation dependency property.
AnnotationConfinementProperty | Identifies the AnnotationConfinement dependency property.
ClipToDocumentProperty | Identifies the ClipToDocument dependency property.
CreateMouseButtonProperty | Identifies the CreateMouseButton dependency property.
CurrentLayerProperty | Identifies the CurrentLayer dependency property.
DefaultSecurityProperty | Identifies the DefaultSecurity dependency property.
DocumentBoundsProperty | Identifies the DocumentBounds dependency property.
GripClipProperty | Identifies the GripClip dependency property.
InteractModeProperty | Identifies the InteractMode dependency property.
IsDirtyProperty | Identifies the IsDirty dependency property.
ResolutionProperty | Identifies the Resolution dependency property.
RotationSnapIntervalProperty | Identifies the RotationSnapInterval dependency property.
RotationSnapThresholdProperty | Identifies the RotationSnapThreshold dependency property.
ScaledResolutionHeightFactorProperty | Identifies the ScaledResolutionHeightFactor dependency property.
ScrollPositionProperty | Identifies the ScrollPosition dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.
ZoomProperty | Identifies the Zoom dependency property.
Top
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ActiveAnnotationProperty Field

WpfAnnotationCanvasActiveAnnotationProperty Field

Identifies the ActiveAnnotation dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveAnnotationProperty
Public Shared ReadOnly ActiveAnnotationProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.AnnotationConfinementProperty Field

WpfAnnotationCanvasAnnotationConfinementProperty Field

Identifies the AnnotationConfinement dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AnnotationConfinementProperty
Public Shared ReadOnly AnnotationConfinementProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ClipToDocumentProperty Field

WpfAnnotationCanvasClipToDocumentProperty Field

Identifies the ClipToDocument dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClipToDocumentProperty
Public Shared ReadOnly ClipToDocumentProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CreateMouseButtonProperty Field

WpfAnnotationCanvasCreateMouseButtonProperty Field

Identifies the CreateMouseButton dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CreateMouseButtonProperty
Public Shared ReadOnly CreateMouseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.CurrentLayerProperty Field

WpfAnnotationCanvasCurrentLayerProperty Field

Identifies the CurrentLayer dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CurrentLayerProperty
Public Shared ReadOnly CurrentLayerProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.DefaultSecurityProperty Field

WpfAnnotationCanvasDefaultSecurityProperty Field

Identifies the DefaultSecurity dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultSecurityProperty
Public Shared ReadOnly DefaultSecurityProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.DocumentBoundsProperty Field

WpfAnnotationCanvasDocumentBoundsProperty Field

Identifies the DocumentBounds dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentBoundsProperty
Public Shared ReadOnly DocumentBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.GripClipProperty Field

WpfAnnotationCanvasGripClipProperty Field

Identifies the GripClip dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty GripClipProperty
Public Shared ReadOnly GripClipProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.InteractModeProperty Field

WpfAnnotationCanvasInteractModeProperty Field

Identifies the InteractMode dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty InteractModeProperty
Public Shared ReadOnly InteractModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.IsDirtyProperty Field

WpfAnnotationCanvasIsDirtyProperty Field

Identifies the IsDirty dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDirtyProperty
Public Shared ReadOnly IsDirtyProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ResolutionProperty Field

WpfAnnotationCanvasResolutionProperty Field

Identifies the Resolution dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolutionProperty
Public Shared ReadOnly ResolutionProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotationSnapIntervalProperty Field

WpfAnnotationCanvasRotationSnapIntervalProperty Field

Identifies the RotationSnapInterval dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotationSnapIntervalProperty
Public Shared ReadOnly RotationSnapIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.RotationSnapThresholdProperty Field

WpfAnnotationCanvasRotationSnapThresholdProperty Field

Identifies the RotationSnapThreshold dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotationSnapThresholdProperty
Public Shared ReadOnly RotationSnapThresholdProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ScaledResolutionHeightFactorProperty Field

WpfAnnotationCanvasScaledResolutionHeightFactorProperty Field

Identifies the ScaledResolutionHeightFactor dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScaledResolutionHeightFactorProperty
Public Shared ReadOnly ScaledResolutionHeightFactorProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ScrollPositionProperty Field

WpfAnnotationCanvasScrollPositionProperty Field

Identifies the ScrollPosition dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollPositionProperty
Public Shared ReadOnly ScrollPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.SelectionModeProperty Field

WpfAnnotationCanvasSelectionModeProperty Field

Identifies the SelectionMode dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionModeProperty
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCanvas.ZoomProperty Field

WpfAnnotationCanvasZoomProperty Field

Identifies the Zoom dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomProperty
Public Shared ReadOnly ZoomProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationCanvas Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors Class

AnnotationCursors is a used to hold all of the Cursor objects for the annotations. This simplifies changing the appearance of the cursors.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationCursors

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class WpfAnnotationCursors
Public NotInheritable Class WpfAnnotationCursors

The WpfAnnotationCursors type exposes the following members.

Fields
Name | Description
DefaultCursor | Gets or sets the default cursor used when the pointer is not over an annotation or grip.
EastWestCursor | Gets or sets the cursor used when over the left or right center grip.
HotSpotCursor | Gets or sets the cursor used for hot spots. This is only shown when InteractMode is set to View.
MoveCursor | Gets or sets the cursor used to indicate a move operation.
NortheastSouthwestCursor | Gets or sets the cursor used for the top-right and bottom-left grips.
NorthSouthCursor | Gets or sets the cursor used for the top and bottom center grips.
NorthwestSoutheastCursor | Gets or sets the cursor used for the top-left and bottom-right grips.
RotateCursor | Gets or sets the cursor used for the rotation grip.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors Fields

The WpfAnnotationCursors type exposes the following members.

Fields
Name | Description
DefaultCursor | Gets or sets the default cursor used when the pointer is not over an annotation or grip.
EastWestCursor | Gets or sets the cursor used when over the left or right center grip.
HotSpotCursor | Gets or sets the cursor used for hot spots. This is only shown when InteractMode is set to View.
MoveCursor | Gets or sets the cursor used to indicate a move operation.
NortheastSouthwestCursor | Gets or sets the cursor used for the top-right and bottom-left grips.
NorthSouthCursor | Gets or sets the cursor used for the top and bottom center grips.
NorthwestSoutheastCursor | Gets or sets the cursor used for the top-left and bottom-right grips.
RotateCursor | Gets or sets the cursor used for the rotation grip.
Top
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.DefaultCursor Field

WpfAnnotationCursorsDefaultCursor Field

Gets or sets the default cursor used when the pointer is not over an annotation or grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor DefaultCursor
Public Shared DefaultCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.EastWestCursor Field

WpfAnnotationCursorsEastWestCursor Field

Gets or sets the cursor used when over the left or right center grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor EastWestCursor
Public Shared EastWestCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.HotSpotCursor Field

WpfAnnotationCursorsHotSpotCursor Field

Gets or sets the cursor used for hot spots. This is only shown when InteractMode is set to View.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor HotSpotCursor
Public Shared HotSpotCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.MoveCursor Field

WpfAnnotationCursorsMoveCursor Field

Gets or sets the cursor used to indicate a move operation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor MoveCursor
Public Shared MoveCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.NortheastSouthwestCursor Field

WpfAnnotationCursorsNortheastSouthwestCursor Field

Gets or sets the cursor used for the top-right and bottom-left grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor NortheastSouthwestCursor
Public Shared NortheastSouthwestCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.NorthSouthCursor Field

WpfAnnotationCursorsNorthSouthCursor Field

Gets or sets the cursor used for the top and bottom center grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor NorthSouthCursor
Public Shared NorthSouthCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.NorthwestSoutheastCursor Field

WpfAnnotationCursorsNorthwestSoutheastCursor Field

Gets or sets the cursor used for the top-left and bottom-right grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor NorthwestSoutheastCursor
Public Shared NorthwestSoutheastCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationCursors.RotateCursor Field

WpfAnnotationCursorsRotateCursor Field

Gets or sets the cursor used for the rotation grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Cursor RotateCursor
Public Shared RotateCursor As Cursor

Field Value

Type: Cursor
See Also

Reference

WpfAnnotationCursors Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Class

This class represents a single grip.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationGrip

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationGrip
Public Class WpfAnnotationGrip

The WpfAnnotationGrip type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationGrip | Creates a new instance of WpfAnnotationGrip.
Public method | WpfAnnotationGrip(Point, Size, WpfAnnotationGripAction, String, WpfRectangleGrip) | Creates a new instance of WpfAnnotationGrip specifying its properties.
Public method | WpfAnnotationGrip(Point, Size, WpfAnnotationGripAction, String, WpfRectangleGrip, Boolean, Boolean) | Creates a new instance of WpfAnnotationGrip specifying its properties.
Top
Properties
 | Name | Description
Public property | Action | Gets or sets the grip action.
Public property | IsRotationIndependent | Gets a value indicating whether the grip is affected by the rotation of the annotation.
Public property | IsZone | Gets a value indicating whether this grip is a zone or a visible grip.
Public property | Name | Gets or sets a name for the grip.
Public property | Position | Gets or sets the position of the grip in document space.
Public property | RectangleGrip | Gets or sets the rectangle grip usage.
Public property | Size | Gets or sets the size of the grip.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultSize | Gets or sets the default size used for annotation grips.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Constructor

Overload List
 | Name | Description
Public method | WpfAnnotationGrip | Creates a new instance of WpfAnnotationGrip.
Public method | WpfAnnotationGrip(Point, Size, WpfAnnotationGripAction, String, WpfRectangleGrip) | Creates a new instance of WpfAnnotationGrip specifying its properties.
Public method | WpfAnnotationGrip(Point, Size, WpfAnnotationGripAction, String, WpfRectangleGrip, Boolean, Boolean) | Creates a new instance of WpfAnnotationGrip specifying its properties.
Top
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Constructor

Creates a new instance of WpfAnnotationGrip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGrip()
Public Sub New
See Also

Reference

WpfAnnotationGrip Class
WpfAnnotationGrip Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Constructor (Point, Size, WpfAnnotationGripAction, String, WpfRectangleGrip)

Creates a new instance of WpfAnnotationGrip specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGrip(
    Point position,
    Size size,
    WpfAnnotationGripAction action,
    string name,
    WpfRectangleGrip rectangleGrip
)
Public Sub New (
    position As Point,
    size As Size,
    action As WpfAnnotationGripAction,
    name As String,
    rectangleGrip As WpfRectangleGrip
)

Parameters

position
Type: System.WindowsPoint
The position of the grip in document space.
size
Type: System.WindowsSize
The size of the grip.
action
Type: Atalasoft.Annotate.WpfWpfAnnotationGripAction
The action the grip will perform.
name
Type: SystemString
A name for the grip. This can be null (Nothing in VB).
rectangleGrip
Type: Atalasoft.Annotate.WpfWpfRectangleGrip
Indicates the rectangle grip usage, if any.
See Also

Reference

WpfAnnotationGrip Class
WpfAnnotationGrip Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Constructor (Point, Size, WpfAnnotationGripAction, String, WpfRectangleGrip, Boolean, Boolean)

Creates a new instance of WpfAnnotationGrip specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGrip(
    Point position,
    Size size,
    WpfAnnotationGripAction action,
    string name,
    WpfRectangleGrip rectangleGrip,
    bool isZone,
    bool isRotationIndependent
)
Public Sub New (
    position As Point,
    size As Size,
    action As WpfAnnotationGripAction,
    name As String,
    rectangleGrip As WpfRectangleGrip,
    isZone As Boolean,
    isRotationIndependent As Boolean
)

Parameters

position
Type: System.WindowsPoint
The position of the grip in document space.
size
Type: System.WindowsSize
The size of the grip.
action
Type: Atalasoft.Annotate.WpfWpfAnnotationGripAction
The action the grip will perform.
name
Type: SystemString
A name for the grip. This can be null (Nothing in VB).
rectangleGrip
Type: Atalasoft.Annotate.WpfWpfRectangleGrip
Indicates the rectangle grip usage, if any.
isZone
Type: SystemBoolean
Indicates whether this grip is a zone or a visible grip.
isRotationIndependent
Type: SystemBoolean
Indicates whether this grip is affected by the rotation of the annotation.
See Also

Reference

WpfAnnotationGrip Class
WpfAnnotationGrip Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Properties

The WpfAnnotationGrip type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets or sets the grip action.
Public property | IsRotationIndependent | Gets a value indicating whether the grip is affected by the rotation of the annotation.
Public property | IsZone | Gets a value indicating whether this grip is a zone or a visible grip.
Public property | Name | Gets or sets a name for the grip.
Public property | Position | Gets or sets the position of the grip in document space.
Public property | RectangleGrip | Gets or sets the rectangle grip usage.
Public property | Size | Gets or sets the size of the grip.
Top
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.Action Property

WpfAnnotationGripAction Property

Gets or sets the grip action.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGripAction Action { get; set; }
Public Property Action As WpfAnnotationGripAction
    Get
    Set

Property Value

Type: WpfAnnotationGripAction
The grip action.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.IsRotationIndependent Property

WpfAnnotationGripIsRotationIndependent Property

Gets a value indicating whether the grip is affected by the rotation of the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRotationIndependent { get; }
Public ReadOnly Property IsRotationIndependent As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the grip is affected by the rotation of the annotation.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.IsZone Property

WpfAnnotationGripIsZone Property

Gets a value indicating whether this grip is a zone or a visible grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsZone { get; }
Public ReadOnly Property IsZone As Boolean
    Get

Property Value

Type: Boolean
Indicates whether this grip is a zone.
Remarks
A zone grip acts like a normal grip, but it is not rendered.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.Name Property

WpfAnnotationGripName Property

Gets or sets a name for the grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
A name for the grip.
Remarks
This property is not required and may be null (Nothing in VB).
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.Position Property

WpfAnnotationGripPosition Property

Gets or sets the position of the grip in document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The position of the grip.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.RectangleGrip Property

WpfAnnotationGripRectangleGrip Property

Gets or sets the rectangle grip usage.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleGrip RectangleGrip { get; set; }
Public Property RectangleGrip As WpfRectangleGrip
    Get
    Set

Property Value

Type: WpfRectangleGrip
The rectangle grip usage.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.Size Property

WpfAnnotationGripSize Property

Gets or sets the size of the grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The size of the grip.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Methods

The WpfAnnotationGrip type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip Fields

The WpfAnnotationGrip type exposes the following members.

Fields
Name | Description
DefaultSize | Gets or sets the default size used for annotation grips.
Top
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrip.DefaultSize Field

WpfAnnotationGripDefaultSize Field

Gets or sets the default size used for annotation grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size DefaultSize
Public Shared DefaultSize As Size

Field Value

Type: Size
The default grip size. This value defaults to an 8x8 grip.
See Also

Reference

WpfAnnotationGrip Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGripAction Enumeration

Indicates the action performed by a grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfAnnotationGripAction
Public Enumeration WpfAnnotationGripAction
Members
Member name | Description
Move | The grip is used for moving the annotation.
Resize | The grip is used to resize the annotation.
Rotate | The grip is used to rotate the annotation.
Independent | The grip is moved independently.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGripMode Enumeration

Indicates whether rectangular or point grips are used for point based annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfAnnotationGripMode
Public Enumeration WpfAnnotationGripMode
Members
Member name | Description
Rectangular | Rectangular grips will be used.
Points | Individual point grips will be used.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips Class

This is the base grips class used for annotations.
This is the base grips class used for annotations.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.DocumentsAdorner
Atalasoft.Annotate.WpfWpfAnnotationGrips
Atalasoft.Annotate.WpfWpfRectangleGrips

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationGrips : Adorner
Public Class WpfAnnotationGrips
    Inherits Adorner

The WpfAnnotationGrips type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationGrips | Creates a new instance of WpfAnnotationGrips.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedElement | Gets the UIElement that this adorner is bound to. (Inherited from Adorner.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Annotation | Gets the annotation for these grips.
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | Bounds | Gets the bounding rectangle of the grips.
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Canvas | Gets the WpfAnnotationCanvas that hosts the grips.
Public property | CenterOfRotation | Gets the center of rotation for the grips.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsClipEnabled | Gets or sets a value that indicates whether clipping of the adorner is enabled. (Inherited from Adorner.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRotatedOnRender | Gets or sets a value indicating whether the grip is rendered rotated when the annotation is rotated.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Items | Gets a list of WpfAnnotationGrip.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | MaintainGripSize | Gets or sets a value indicating whether the grip size is visually maintained or resized along with the zoom level.
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PositionBounds | Gets the bounding rectangle of the grip positions.
Public property | Renderer | Gets or sets the renderer used for the grips.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CalculateGripPercentages | Calculates percentage values for the grips to fit within the specified bounds.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindGrip(String) | Looks up a grip by its name.
Public method | FindGrip(WpfRectangleGrip) | Looks up a grip by its WpfRectangleGrip status.
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDesiredTransform | Returns a Transform for the adorner, based on the transform that is currently applied to the adorned element. (Inherited from Adorner.)
Protected method | GetGripCursor | Returns the cursor for the specified grip with respect to the current rotation.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | For a description of this member, see GetLayoutClip(Size). (Inherited from Adorner.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Protected method | GetUnRotatedPoint | Calculates the un-rotated point from a provided point.
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | GripFromPoint | Find a grip at the specified point in document space.
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(PointHitTestParameters) | Tests whether a specified point is on the grips or annotation. (Overrides UIElementHitTestCore(PointHitTestParameters).)
Protected method | InitiateGrips | Called when the grips need to be generated.
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Implements any custom measuring behavior for the adorner. (Overrides AdornerMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MirrorApplied | Called when the annotation is mirrored to allow the grips to mirror.
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | MoveGrips | Called to force the grips to move by a specified offset.
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGripPositionChanged | Called when a grip's position has changed and raises the GripPositionChanged event.
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMirrorApplied | Called when the annotation is mirrored to allow the grips to mirror.
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseUp(MouseButtonEventArgs).)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Protected method | UpdateGripPositions | Called when the grip positions need to be updated.
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | ValidateGripMove | Called when a grip is being moved to allow for validation of this action. This method will raise an OperationRequest(OperationRequestInformation) on the annotation.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | GripPositionChanged | This event is raised when a grip's position has changed.
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips Constructor

Creates a new instance of WpfAnnotationGrips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGrips(
    WpfAnnotationCanvas canvas,
    WpfAnnotationUI annotation,
    IWpfGripRenderer renderer
)
Public Sub New (
    canvas As WpfAnnotationCanvas,
    annotation As WpfAnnotationUI,
    renderer As IWpfGripRenderer
)

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas used as the grip's host element.
annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation the grip is used for.
renderer
Type: Atalasoft.Annotate.Wpf.RendererIWpfGripRenderer
The grip renderer for these grips.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the canvas or annotation arguemnts are null (Nothing in VB).
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips Properties

The WpfAnnotationGrips type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedElement | Gets the UIElement that this adorner is bound to. (Inherited from Adorner.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Annotation | Gets the annotation for these grips.
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | Bounds | Gets the bounding rectangle of the grips.
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Canvas | Gets the WpfAnnotationCanvas that hosts the grips.
Public property | CenterOfRotation | Gets the center of rotation for the grips.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsClipEnabled | Gets or sets a value that indicates whether clipping of the adorner is enabled. (Inherited from Adorner.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRotatedOnRender | Gets or sets a value indicating whether the grip is rendered rotated when the annotation is rotated.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Items | Gets a list of WpfAnnotationGrip.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | MaintainGripSize | Gets or sets a value indicating whether the grip size is visually maintained or resized along with the zoom level.
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PositionBounds | Gets the bounding rectangle of the grip positions.
Public property | Renderer | Gets or sets the renderer used for the grips.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.Annotation Property

WpfAnnotationGripsAnnotation Property

Gets the annotation for these grips.
Gets the annotation for these grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI Annotation { get; }
Public ReadOnly Property Annotation As WpfAnnotationUI
    Get

Property Value

Type: WpfAnnotationUI
The annotation for theses grips.

Property Value

Type: WpfAnnotationUI
The annotation for these grips.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.Bounds Property

WpfAnnotationGripsBounds Property

Gets the bounding rectangle of the grips.
Gets the bounding rectangle of the grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect Bounds { get; }
Public ReadOnly Property Bounds As Rect
    Get

Property Value

Type: Rect
The bounding rectangle of the grips.

Property Value

Type: Rect
The bounding rectangle of the grips.
Remarks
This property includes the annotation outline width in its calculation. To get the bounds based only on the grip positions, use the PositionBounds property.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.Canvas Property

WpfAnnotationGripsCanvas Property

Gets the WpfAnnotationCanvas that hosts the grips.
Gets the WpfAnnotationCanvas that hosts the grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationCanvas Canvas { get; }
Public ReadOnly Property Canvas As WpfAnnotationCanvas
    Get

Property Value

Type: WpfAnnotationCanvas
The WpfAnnotationCanvas hosting the grips.

Property Value

Type: WpfAnnotationCanvas
The WpfAnnotationCanvas hosting the grips.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.CenterOfRotation Property

WpfAnnotationGripsCenterOfRotation Property

Gets the center of rotation for the grips.
Gets the center of rotation for the grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Point CenterOfRotation { get; }
Public Overridable ReadOnly Property CenterOfRotation As Point
    Get

Property Value

Type: Point
The center of rotation for the grips.

Property Value

Type: Point
The center of rotation for the grips.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.IsRotatedOnRender Property

WpfAnnotationGripsIsRotatedOnRender Property

Gets or sets a value indicating whether the grip is rendered rotated when the annotation is rotated.
Gets or sets a value indicating whether the grip is rendered rotated when the annotation is rotated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRotatedOnRender { get; set; }
Public Property IsRotatedOnRender As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the grip is rendered rotated.

Property Value

Type: Boolean
A value indicating whether the grip is rendered rotated.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.Items Property

WpfAnnotationGripsItems Property

Gets a list of WpfAnnotationGrip.
Gets a list of WpfAnnotationGrip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Collection<WpfAnnotationGrip> Items { get; }
Public ReadOnly Property Items As Collection(Of WpfAnnotationGrip)
    Get

Property Value

Type: Collection WpfAnnotationGrip
The collection of WpfAnnotationGrip objects.

Property Value

Type: Collection WpfAnnotationGrip
The collection of WpfAnnotationGrip objects.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.MaintainGripSize Property

WpfAnnotationGripsMaintainGripSize Property

Gets or sets a value indicating whether the grip size is visually maintained or resized along with the zoom level.
Gets or sets a value indicating whether the grip size is visually maintained or resized along with the zoom level.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MaintainGripSize { get; set; }
Public Property MaintainGripSize As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the grip size is maintained or resized along with the zoom level.

Property Value

Type: Boolean
Indicates whether the grip size is maintained or resized along with the zoom level.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.PositionBounds Property

WpfAnnotationGripsPositionBounds Property

Gets the bounding rectangle of the grip positions.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect PositionBounds { get; }
Public ReadOnly Property PositionBounds As Rect
    Get

Property Value

Type: Rect
The bounding rectangle of the grips.
Remarks
This is different from the Bounds property which includes the pen width of the annotation in its calculation.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.Renderer Property

WpfAnnotationGripsRenderer Property

Gets or sets the renderer used for the grips.
Gets or sets the renderer used for the grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IWpfGripRenderer Renderer { get; set; }
Public Property Renderer As IWpfGripRenderer
    Get
    Set

Property Value

Type: IWpfGripRenderer
The renderer used for the grips.

Property Value

Type: IWpfGripRenderer
The renderer used for the grips.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips Methods

The WpfAnnotationGrips type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CalculateGripPercentages | Calculates percentage values for the grips to fit within the specified bounds.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindGrip(String) | Looks up a grip by its name.
Public method | FindGrip(WpfRectangleGrip) | Looks up a grip by its WpfRectangleGrip status.
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDesiredTransform | Returns a Transform for the adorner, based on the transform that is currently applied to the adorned element. (Inherited from Adorner.)
Protected method | GetGripCursor | Returns the cursor for the specified grip with respect to the current rotation.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | For a description of this member, see GetLayoutClip(Size). (Inherited from Adorner.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Protected method | GetUnRotatedPoint | Calculates the un-rotated point from a provided point.
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | GripFromPoint | Find a grip at the specified point in document space.
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(PointHitTestParameters) | Tests whether a specified point is on the grips or annotation. (Overrides UIElementHitTestCore(PointHitTestParameters).)
Protected method | InitiateGrips | Called when the grips need to be generated.
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Implements any custom measuring behavior for the adorner. (Overrides AdornerMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MirrorApplied | Called when the annotation is mirrored to allow the grips to mirror.
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | MoveGrips | Called to force the grips to move by a specified offset.
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGripPositionChanged | Called when a grip's position has changed and raises the GripPositionChanged event.
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMirrorApplied | Called when the annotation is mirrored to allow the grips to mirror.
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseUp(MouseButtonEventArgs).)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Protected method | UpdateGripPositions | Called when the grip positions need to be updated.
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | ValidateGripMove | Called when a grip is being moved to allow for validation of this action. This method will raise an OperationRequest(OperationRequestInformation) on the annotation.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.CalculateGripPercentages Method

WpfAnnotationGripsCalculateGripPercentages Method

Calculates percentage values for the grips to fit within the specified bounds.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Point[] CalculateGripPercentages(
    Rect bounds
)
Protected Function CalculateGripPercentages (
    bounds As Rect
) As Point()

Parameters

bounds
Type: System.WindowsRect
The bounds for the grips.

Return Value

Type: Point
An array of Point, one for each grip, indicating their percentage values.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the bounds contains a zero width or height.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.FindGrip Method

WpfAnnotationGripsFindGrip Method

Theses methods are used to find a specific grip.
Overload List
 | Name | Description
Public method | FindGrip(String) | Looks up a grip by its name.
Public method | FindGrip(WpfRectangleGrip) | Looks up a grip by its WpfRectangleGrip status.
Top
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.FindGrip Method (String)

WpfAnnotationGripsFindGrip Method (String)

Looks up a grip by its name.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual WpfAnnotationGrip FindGrip(
    string name
)
Public Overridable Function FindGrip (
    name As String
) As WpfAnnotationGrip

Parameters

name
Type: SystemString
The name used for the grip.

Return Value

Type: WpfAnnotationGrip
A grip with the name provided or null (Nothing in VB) if a grip with that name could not be found.
See Also

Reference

WpfAnnotationGrips Class
FindGrip Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.FindGrip Method (WpfRectangleGrip)

WpfAnnotationGripsFindGrip Method (WpfRectangleGrip)

Looks up a grip by its WpfRectangleGrip status.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual WpfAnnotationGrip FindGrip(
    WpfRectangleGrip rectangleGrip
)
Public Overridable Function FindGrip (
    rectangleGrip As WpfRectangleGrip
) As WpfAnnotationGrip

Parameters

rectangleGrip
Type: Atalasoft.Annotate.WpfWpfRectangleGrip
The WpfRectangleGrip setting for the grip.

Return Value

Type: WpfAnnotationGrip
A grip with a matching WpfRectangleGrip value or null (Nothing in VB) if a grip with that name could not be found.
See Also

Reference

WpfAnnotationGrips Class
FindGrip Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.GetGripCursor Method

WpfAnnotationGripsGetGripCursor Method

Returns the cursor for the specified grip with respect to the current rotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Cursor GetGripCursor(
    WpfAnnotationGrip grip
)
Protected Overridable Function GetGripCursor (
    grip As WpfAnnotationGrip
) As Cursor

Parameters

grip
Type: Atalasoft.Annotate.WpfWpfAnnotationGrip
The grip to get the cursor for.

Return Value

Type: Cursor
The cursor for the grip.
Remarks
When the annotation is rotated, this method will find the best cursor for the specified grip. For instance, if the top-center grip is pass in and the annotation is rotated 90 degrees, this method will return WpfAnnotationCursors.EastWestCursor since that cursor more closely matches the grip movement.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.GetUnRotatedPoint Method

WpfAnnotationGripsGetUnRotatedPoint Method

Calculates the un-rotated point from a provided point.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Point GetUnRotatedPoint(
    Point dsPoint
)
Protected Function GetUnRotatedPoint (
    dsPoint As Point
) As Point

Parameters

dsPoint
Type: System.WindowsPoint
The rotated point in document space.

Return Value

Type: Point
The un-rotated point.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.GripFromPoint Method

WpfAnnotationGripsGripFromPoint Method

Find a grip at the specified point in document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual WpfAnnotationGrip GripFromPoint(
    Point dsPoint
)
Protected Overridable Function GripFromPoint (
    dsPoint As Point
) As WpfAnnotationGrip

Parameters

dsPoint
Type: System.WindowsPoint
The point in document space to search for a grip.

Return Value

Type: WpfAnnotationGrip
The grip found at that point or null (Nothing in VB) if a grip was not found.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.HitTestCore Method

WpfAnnotationGripsHitTestCore Method

Overload List
 | Name | Description
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(PointHitTestParameters) | Tests whether a specified point is on the grips or annotation. (Overrides UIElementHitTestCore(PointHitTestParameters).)
Top
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.HitTestCore Method (PointHitTestParameters)

WpfAnnotationGripsHitTestCore Method (PointHitTestParameters)

Tests whether a specified point is on the grips or annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override HitTestResult HitTestCore(
    PointHitTestParameters hitTestParameters
)
Protected Overrides Function HitTestCore (
    hitTestParameters As PointHitTestParameters
) As HitTestResult

Parameters

hitTestParameters
Type: System.Windows.MediaPointHitTestParameters
A PointHitTestParameters argument containing the hit test point.

Return Value

Type: HitTestResult
A HitTestResult if the point is over a grip or annotation. Null (Nothing in VB) is returned if there was no hit.
See Also

Reference

WpfAnnotationGrips Class
HitTestCore Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.InitiateGrips Method

WpfAnnotationGripsInitiateGrips Method

Called when the grips need to be generated.
Called when the grips need to be generated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void InitiateGrips()
Protected Overridable Sub InitiateGrips
Remarks
This method is also called when a Measure is performed on the WpfAnnotationGrips.
Remarks
This method is also called when a Measure is performed on the WpfAnnotationGrips.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.MeasureOverride Method

WpfAnnotationGripsMeasureOverride Method

Implements any custom measuring behavior for the adorner.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size constraint
)
Protected Overrides Function MeasureOverride (
    constraint As Size
) As Size

Parameters

constraint
Type: System.WindowsSize
A size to constrain the adorner to.

Return Value

Type: Size
A Size object representing the amount of layout space needed by the adorner.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.MirrorApplied Method

WpfAnnotationGripsMirrorApplied Method

Called when the annotation is mirrored to allow the grips to mirror.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MirrorApplied(
    MirrorDirection direction,
    bool maintainPosition
)
Public Sub MirrorApplied (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The mirror direction.
maintainPosition
Type: SystemBoolean
Indicates whether the annotation position is maintained or if the mirror pivots along the zero axis.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.MoveGrips Method

WpfAnnotationGripsMoveGrips Method

Called to force the grips to move by a specified offset.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void MoveGrips(
    Point offset
)
Protected Overridable Sub MoveGrips (
    offset As Point
)

Parameters

offset
Type: System.WindowsPoint
The offset to move each grip.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnGripPositionChanged Method

WpfAnnotationGripsOnGripPositionChanged Method

Called when a grip's position has changed and raises the GripPositionChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overridable Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
The EventArgslt;WpfAnnotationGripgt; passed to the GripPositionChanged event.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnInitialized Method

WpfAnnotationGripsOnInitialized Method

Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInitialized(
    EventArgs e
)
Protected Overrides Sub OnInitialized (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnMirrorApplied Method

WpfAnnotationGripsOnMirrorApplied Method

Called when the annotation is mirrored to allow the grips to mirror.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMirrorApplied(
    MirrorDirection direction,
    bool maintainPosition
)
Protected Overridable Sub OnMirrorApplied (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The mirror direction.
maintainPosition
Type: SystemBoolean
Indicates whether the annotation position is maintained or if the mirror pivots along the zero axis.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnMouseDown Method

WpfAnnotationGripsOnMouseDown Method

Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnMouseMove Method

WpfAnnotationGripsOnMouseMove Method

Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs that contains the event data.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnMouseUp Method

WpfAnnotationGripsOnMouseUp Method

Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. The event data reports that the mouse button was released.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.OnRender Method

WpfAnnotationGripsOnRender Method

When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
The drawing instructions for a specific element. This context is provided to the layout system.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.UpdateGripPositions Method

WpfAnnotationGripsUpdateGripPositions Method

Called when the grip positions need to be updated.
Called when the grip positions need to be updated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void UpdateGripPositions()
Protected Overridable Sub UpdateGripPositions
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.ValidateGripMove Method

WpfAnnotationGripsValidateGripMove Method

Called when a grip is being moved to allow for validation of this action. This method will raise an OperationRequest(OperationRequestInformation) on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual WpfAnnotationGrip ValidateGripMove(
    WpfAnnotationGrip grip,
    Point newPosition
)
Protected Overridable Function ValidateGripMove (
    grip As WpfAnnotationGrip,
    newPosition As Point
) As WpfAnnotationGrip

Parameters

grip
Type: Atalasoft.Annotate.WpfWpfAnnotationGrip
The grip being moved.
newPosition
Type: System.WindowsPoint
The requested new position of the grip.

Return Value

Type: WpfAnnotationGrip
The grip to be moved or null (Nothing in VB) to reject this action.
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips Events

The WpfAnnotationGrips type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | GripPositionChanged | This event is raised when a grip's position has changed.
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationGrips.GripPositionChanged Event

WpfAnnotationGripsGripPositionChanged Event

This event is raised when a grip's position has changed.
This event is raised when a grip's position has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<EventArgs<WpfAnnotationGrip>> GripPositionChanged
Public Event GripPositionChanged As EventHandler(Of EventArgs(Of WpfAnnotationGrip))

Value

Type: SystemEventHandler EventArgs WpfAnnotationGrip
See Also

Reference

WpfAnnotationGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationOperationRequests Enumeration

Indicates the operation requested on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum WpfAnnotationOperationRequests
<FlagsAttribute>
Public Enumeration WpfAnnotationOperationRequests
Members
Member name | Description
Move | A move request.
Rotate | A rotate request.
GripMove | A grip move request.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSelectionMode Enumeration

Indicates whether the WpfAnnotationCanvas should perform single or multiple selections.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfAnnotationSelectionMode
Public Enumeration WpfAnnotationSelectionMode
Members
Member name | Description
Single | Only select on annotation at a time.
Multiple | Select multiple annotations.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter Class

This class is used to convert between viewer, document and annotation space.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationSpaceConverter

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationSpaceConverter
Public Class WpfAnnotationSpaceConverter

The WpfAnnotationSpaceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationSpaceConverter | Creates a new instance of WpfAnnotationSpaceConverter.
Top
Methods
 | Name | Description
Public method | AnnotationToDocumentSpace(Point) | Converts a point from annotation space to document space.
Public method | AnnotationToDocumentSpace(Point) | Converts an array of Point from annotation space to document space.
Public method | AnnotationToViewportSpace(Point) | Converts a point from annotation space to viewer space.
Public method | AnnotationToViewportSpace(Point) | Converts an array of Point from annotation space to viewer space.
Public method | DocumentToAnnotationSpace(Point) | Converts a point from document space to annotation space.
Public method | DocumentToAnnotationSpace(Point) | Converts an array of Point from document space to annotation space.
Public method | DocumentToViewportSpace(Point) | Converts a point from document space to viewer space.
Public method | DocumentToViewportSpace(Point) | Converts an array of Point from document space to viewer space.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ViewportToAnnotationSpace(Point) | Converts a point from viewer space into annotation space.
Public method | ViewportToAnnotationSpace(Point) | Converts an array of Point from viewer space to annotation space.
Public method | ViewportToDocumentSpace(Point) | Converts a point from viewer space to document space.
Public method | ViewportToDocumentSpace(Point) | Converts an array of Point from viewer space to document space.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter Constructor

Creates a new instance of WpfAnnotationSpaceConverter.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationSpaceConverter(
    Matrix viewerMatrix,
    Matrix annotationMatrix
)
Public Sub New (
    viewerMatrix As Matrix,
    annotationMatrix As Matrix
)

Parameters

viewerMatrix
Type: System.Windows.MediaMatrix
The viewer matrix.
annotationMatrix
Type: System.Windows.MediaMatrix
The annotation rendering matrix.
Remarks
The viewer matrix can be created using the WpfAnnotationCanvas.CreateViewerMatrix method and the annotation matrix can be retrieved from [annotation].RenderTransform.Value.
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter Methods

The WpfAnnotationSpaceConverter type exposes the following members.

Methods
 | Name | Description
Public method | AnnotationToDocumentSpace(Point) | Converts a point from annotation space to document space.
Public method | AnnotationToDocumentSpace(Point) | Converts an array of Point from annotation space to document space.
Public method | AnnotationToViewportSpace(Point) | Converts a point from annotation space to viewer space.
Public method | AnnotationToViewportSpace(Point) | Converts an array of Point from annotation space to viewer space.
Public method | DocumentToAnnotationSpace(Point) | Converts a point from document space to annotation space.
Public method | DocumentToAnnotationSpace(Point) | Converts an array of Point from document space to annotation space.
Public method | DocumentToViewportSpace(Point) | Converts a point from document space to viewer space.
Public method | DocumentToViewportSpace(Point) | Converts an array of Point from document space to viewer space.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ViewportToAnnotationSpace(Point) | Converts a point from viewer space into annotation space.
Public method | ViewportToAnnotationSpace(Point) | Converts an array of Point from viewer space to annotation space.
Public method | ViewportToDocumentSpace(Point) | Converts a point from viewer space to document space.
Public method | ViewportToDocumentSpace(Point) | Converts an array of Point from viewer space to document space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.AnnotationToDocumentSpace Method

WpfAnnotationSpaceConverterAnnotationToDocumentSpace Method

Overload List
 | Name | Description
Public method | AnnotationToDocumentSpace(Point) | Converts a point from annotation space to document space.
Public method | AnnotationToDocumentSpace(Point) | Converts an array of Point from annotation space to document space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.AnnotationToDocumentSpace Method (Point)

WpfAnnotationSpaceConverterAnnotationToDocumentSpace Method (Point)

Converts a point from annotation space to document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point AnnotationToDocumentSpace(
    Point point
)
Public Function AnnotationToDocumentSpace (
    point As Point
) As Point

Parameters

point
Type: System.WindowsPoint
The point to convert.

Return Value

Type: Point
The converted point.
See Also

Reference

WpfAnnotationSpaceConverter Class
AnnotationToDocumentSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.AnnotationToDocumentSpace Method (Point[])

WpfAnnotationSpaceConverterAnnotationToDocumentSpace Method (Point)

Converts an array of Point from annotation space to document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AnnotationToDocumentSpace(
    Point[] points
)
Public Sub AnnotationToDocumentSpace (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
An array of points to convert.
See Also

Reference

WpfAnnotationSpaceConverter Class
AnnotationToDocumentSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.AnnotationToViewportSpace Method

WpfAnnotationSpaceConverterAnnotationToViewportSpace Method

Overload List
 | Name | Description
Public method | AnnotationToViewportSpace(Point) | Converts a point from annotation space to viewer space.
Public method | AnnotationToViewportSpace(Point) | Converts an array of Point from annotation space to viewer space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.AnnotationToViewportSpace Method (Point)

WpfAnnotationSpaceConverterAnnotationToViewportSpace Method (Point)

Converts a point from annotation space to viewer space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point AnnotationToViewportSpace(
    Point point
)
Public Function AnnotationToViewportSpace (
    point As Point
) As Point

Parameters

point
Type: System.WindowsPoint
The point to convert.

Return Value

Type: Point
The converted point.
See Also

Reference

WpfAnnotationSpaceConverter Class
AnnotationToViewportSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.AnnotationToViewportSpace Method (Point[])

WpfAnnotationSpaceConverterAnnotationToViewportSpace Method (Point)

Converts an array of Point from annotation space to viewer space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AnnotationToViewportSpace(
    Point[] points
)
Public Sub AnnotationToViewportSpace (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
An array of points to convert.
See Also

Reference

WpfAnnotationSpaceConverter Class
AnnotationToViewportSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.DocumentToAnnotationSpace Method

WpfAnnotationSpaceConverterDocumentToAnnotationSpace Method

Overload List
 | Name | Description
Public method | DocumentToAnnotationSpace(Point) | Converts a point from document space to annotation space.
Public method | DocumentToAnnotationSpace(Point) | Converts an array of Point from document space to annotation space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.DocumentToAnnotationSpace Method (Point)

WpfAnnotationSpaceConverterDocumentToAnnotationSpace Method (Point)

Converts a point from document space to annotation space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point DocumentToAnnotationSpace(
    Point point
)
Public Function DocumentToAnnotationSpace (
    point As Point
) As Point

Parameters

point
Type: System.WindowsPoint
The point to convert.

Return Value

Type: Point
The converted point.
See Also

Reference

WpfAnnotationSpaceConverter Class
DocumentToAnnotationSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.DocumentToAnnotationSpace Method (Point[])

WpfAnnotationSpaceConverterDocumentToAnnotationSpace Method (Point)

Converts an array of Point from document space to annotation space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DocumentToAnnotationSpace(
    Point[] points
)
Public Sub DocumentToAnnotationSpace (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
The array of points to convert.
See Also

Reference

WpfAnnotationSpaceConverter Class
DocumentToAnnotationSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.DocumentToViewportSpace Method

WpfAnnotationSpaceConverterDocumentToViewportSpace Method

Overload List
 | Name | Description
Public method | DocumentToViewportSpace(Point) | Converts a point from document space to viewer space.
Public method | DocumentToViewportSpace(Point) | Converts an array of Point from document space to viewer space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.DocumentToViewportSpace Method (Point)

WpfAnnotationSpaceConverterDocumentToViewportSpace Method (Point)

Converts a point from document space to viewer space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point DocumentToViewportSpace(
    Point point
)
Public Function DocumentToViewportSpace (
    point As Point
) As Point

Parameters

point
Type: System.WindowsPoint
The point to convert.

Return Value

Type: Point
The converted point.
See Also

Reference

WpfAnnotationSpaceConverter Class
DocumentToViewportSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.DocumentToViewportSpace Method (Point[])

WpfAnnotationSpaceConverterDocumentToViewportSpace Method (Point)

Converts an array of Point from document space to viewer space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DocumentToViewportSpace(
    Point[] points
)
Public Sub DocumentToViewportSpace (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
An array of points to convert.
See Also

Reference

WpfAnnotationSpaceConverter Class
DocumentToViewportSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.ViewportToAnnotationSpace Method

WpfAnnotationSpaceConverterViewportToAnnotationSpace Method

Overload List
 | Name | Description
Public method | ViewportToAnnotationSpace(Point) | Converts a point from viewer space into annotation space.
Public method | ViewportToAnnotationSpace(Point) | Converts an array of Point from viewer space to annotation space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.ViewportToAnnotationSpace Method (Point)

WpfAnnotationSpaceConverterViewportToAnnotationSpace Method (Point)

Converts a point from viewer space into annotation space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ViewportToAnnotationSpace(
    Point point
)
Public Function ViewportToAnnotationSpace (
    point As Point
) As Point

Parameters

point
Type: System.WindowsPoint
The point to convert.

Return Value

Type: Point
The converted point.
See Also

Reference

WpfAnnotationSpaceConverter Class
ViewportToAnnotationSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.ViewportToAnnotationSpace Method (Point[])

WpfAnnotationSpaceConverterViewportToAnnotationSpace Method (Point)

Converts an array of Point from viewer space to annotation space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ViewportToAnnotationSpace(
    Point[] points
)
Public Sub ViewportToAnnotationSpace (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
The array of points to convert.
See Also

Reference

WpfAnnotationSpaceConverter Class
ViewportToAnnotationSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.ViewportToDocumentSpace Method

WpfAnnotationSpaceConverterViewportToDocumentSpace Method

Overload List
 | Name | Description
Public method | ViewportToDocumentSpace(Point) | Converts a point from viewer space to document space.
Public method | ViewportToDocumentSpace(Point) | Converts an array of Point from viewer space to document space.
Top
See Also

Reference

WpfAnnotationSpaceConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.ViewportToDocumentSpace Method (Point)

WpfAnnotationSpaceConverterViewportToDocumentSpace Method (Point)

Converts a point from viewer space to document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ViewportToDocumentSpace(
    Point point
)
Public Function ViewportToDocumentSpace (
    point As Point
) As Point

Parameters

point
Type: System.WindowsPoint
The point to convert.

Return Value

Type: Point
The converted point.
See Also

Reference

WpfAnnotationSpaceConverter Class
ViewportToDocumentSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationSpaceConverter.ViewportToDocumentSpace Method (Point[])

WpfAnnotationSpaceConverterViewportToDocumentSpace Method (Point)

Converts an array of Point from viewer space to document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ViewportToDocumentSpace(
    Point[] points
)
Public Sub ViewportToDocumentSpace (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
The array of points to convert.
See Also

Reference

WpfAnnotationSpaceConverter Class
ViewportToDocumentSpace Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Class

This is the base class for all WPF annotations.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
More...

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class WpfAnnotationUI : Visual
Public MustInherit Class WpfAnnotationUI
    Inherits Visual

The WpfAnnotationUI type exposes the following members.

Constructors
 | Name | Description
Protected method | WpfAnnotationUI | The default constructor.
Protected method | WpfAnnotationUI(AnnotationData) | Constructs an annotation using the specified AnnotationData object.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation.
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user.
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user.
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user.
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user.
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user.
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation.
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation.
Public property | ChildElement | Gets the child UIElement of the annotation, if any.
Public property | CreationTime | Gets or sets the creation time of the annotation.
 | DefaultFill | Gets or sets the default brush used for annotation backgrounds.
 | DefaultOutline | Gets or sets the default outline used for annotations.
 | DefaultShadow | Gets or sets the default shadow brush used for annotations.
 | DefaultShadowOffset | Gets or sets the default shadow offset used for annotations.
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary.
Public property | Geometry | Gets a Geometry representing the annotation.
Public property | Grips | Gets the grips for this annotation.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally.
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible.
Public property | Location | Gets or sets the location of the annotation in document space.
Public property | ModifiedTime | Gets or sets the last time the annotation was modified.
Public property | Name | Gets or sets the name for the annotation.
Public property | ParentLayer | Gets the parent layer of this annotation, if any.
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering.
Public property | RenderTransform | Gets the transform used when rendering the annotation.
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation.
Public property | Security | Gets or sets the security for the annotation.
Public property | Selected | Gets or sets a value indicating whether the annotation is selected.
Public property | Size | Gets or sets the size of the annotation.
Public property | State | Gets or sets the annotation state.
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation.
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer.
Public property | UserName | Gets or sets the username for this annotation.
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation.
Protected method | AttachGripsOverride | Called when the annotation grips need to be created.
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation.
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself.
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization.
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation.
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Overrides VisualHitTestCore(PointHitTestParameters).)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction.
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed.
Protected method | OnAnnotationCreated | Called after the annotation has been created.
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed.
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed.
Protected method | OnCanvasChanged | Called when the Canvas property has changed.
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved.
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation.
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation.
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation.
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Overrides DependencyObjectOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated.
Protected method | OnSelectedChanged | Called when the Selected property has been changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed.
Public method | RaiseEvent | This method is used to force an event in the annotation.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips.
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring.
Public method | Rotate | This method will append a rotation to the annotation's current rotation.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation.
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation.
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation.
Public event | PropertyChanged | This event is raised when a property of the annotation has changed.
Top
Fields
Name | Description
BoundsProperty | Identifies the Bounds dependency property.
CanMirrorProperty | Identifies the CanMirror dependency property.
CanMoveProperty | Identifies the CanMove dependency property.
CanResizeProperty | Identifies the CanResize dependency property.
CanRotateProperty | Identifies the CanRotate dependency property.
CanSelectProperty | Identifies the CanSelect dependency property.
CreationTimeProperty | Identifies the CreationTime dependency property.
ExtraPropertiesProperty | Identifies the ExtraProperties dependency property.
FillProperty | Identifies the Fill dependency property.
IsVisibleProperty | Identifies the IsVisible dependency property.
LocationProperty | Identifies the Location dependency property.
ModifiedTimeProperty | Identifies the ModifiedTime dependency property.
NameProperty | Identifies the Name dependency property.
OutlineProperty | Identifies the Outline dependency property.
RotationProperty | Identifies the Rotation dependency property.
SecurityProperty | Identifies the Security dependency property.
SelectedProperty | Identifies the Selected dependency property.
ShadowOffsetProperty | Identifies the ShadowOffset dependency property.
ShadowProperty | Identifies the Shadow dependency property.
SizeProperty | Identifies the Size dependency property.
StateProperty | Identifies the State dependency property.
ToolTipProperty | Identifies the ToolTip dependency property.
UserNameProperty | Identifies the UserName dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.Wpf.PdfWpfPdfAnnotation
Atalasoft.Annotate.WpfWpfCalloutAnnotation
Atalasoft.Annotate.WpfWpfEllipseAnnotation
Atalasoft.Annotate.WpfWpfEmbeddedImageAnnotation
Atalasoft.Annotate.WpfWpfHotSpotAnnotation
Atalasoft.Annotate.WpfWpfLayerAnnotation
Atalasoft.Annotate.WpfWpfLineAnnotation
Atalasoft.Annotate.WpfWpfPointBaseAnnotation
Atalasoft.Annotate.WpfWpfRectangleAnnotation
Atalasoft.Annotate.WpfWpfReferencedImageAnnotation
Atalasoft.Annotate.WpfWpfRubberStampAnnotation
Atalasoft.Annotate.WpfWpfTextAnnotation


WpfAnnotationUI Constructor

Overload List
 | Name | Description
Protected method | WpfAnnotationUI | The default constructor.
Protected method | WpfAnnotationUI(AnnotationData) | Constructs an annotation using the specified AnnotationData object.
Top
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Constructor

The default constructor.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfAnnotationUI()
Protected Sub New
See Also

Reference

WpfAnnotationUI Class
WpfAnnotationUI Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Constructor (AnnotationData)

Constructs an annotation using the specified AnnotationData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfAnnotationUI(
    AnnotationData data
)
Protected Sub New (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The AnnotationData object this annotation will be created from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUI Class
WpfAnnotationUI Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Properties

The WpfAnnotationUI type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation.
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user.
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user.
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user.
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user.
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user.
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation.
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation.
Public property | ChildElement | Gets the child UIElement of the annotation, if any.
Public property | CreationTime | Gets or sets the creation time of the annotation.
 | DefaultFill | Gets or sets the default brush used for annotation backgrounds.
 | DefaultOutline | Gets or sets the default outline used for annotations.
 | DefaultShadow | Gets or sets the default shadow brush used for annotations.
 | DefaultShadowOffset | Gets or sets the default shadow offset used for annotations.
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary.
Public property | Geometry | Gets a Geometry representing the annotation.
Public property | Grips | Gets the grips for this annotation.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group.
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally.
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible.
Public property | Location | Gets or sets the location of the annotation in document space.
Public property | ModifiedTime | Gets or sets the last time the annotation was modified.
Public property | Name | Gets or sets the name for the annotation.
Public property | ParentLayer | Gets the parent layer of this annotation, if any.
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering.
Public property | RenderTransform | Gets the transform used when rendering the annotation.
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation.
Public property | Security | Gets or sets the security for the annotation.
Public property | Selected | Gets or sets a value indicating whether the annotation is selected.
Public property | Size | Gets or sets the size of the annotation.
Public property | State | Gets or sets the annotation state.
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation.
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer.
Public property | UserName | Gets or sets the username for this annotation.
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Bounds Property

WpfAnnotationUIBounds Property

Gets the bounding rectangle of this annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect Bounds { get; }
Public ReadOnly Property Bounds As Rect
    Get

Property Value

Type: Rect
The bounding rectangle of this annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanMirror Property

WpfAnnotationUICanMirror Property

Gets or sets a value indicating whether the annotation can be mirrored by the end-user.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanMirror { get; set; }
Public Property CanMirror As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation can be mirrored by the end-user.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanMove Property

WpfAnnotationUICanMove Property

Gets or sets a value indicating whether the annotation can be moved by the end-user.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanMove { get; set; }
Public Property CanMove As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation can be moved by the end-user.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanResize Property

WpfAnnotationUICanResize Property

Gets or sets a value indicating whether the annotation can be resized by the end-user.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanResize { get; set; }
Public Property CanResize As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation can be resized by the end-user.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanRotate Property

WpfAnnotationUICanRotate Property

Gets or sets a value indicating whether the annotation can be rotated by the end-user.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanRotate { get; set; }
Public Property CanRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation can be rotated by the end-user.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanSelect Property

WpfAnnotationUICanSelect Property

Gets or sets a value indicating whether the annotation can be selected by the end-user.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanSelect { get; set; }
Public Property CanSelect As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation can be selected by the end-user.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Canvas Property

WpfAnnotationUICanvas Property

Gets the WpfAnnotationCanvas class hosting this annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationCanvas Canvas { get; }
Public ReadOnly Property Canvas As WpfAnnotationCanvas
    Get

Property Value

Type: WpfAnnotationCanvas
The WpfAnnotationCanvas class hosting this annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CenterOfRotation Property

WpfAnnotationUICenterOfRotation Property

Gets the point used as center of rotation for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point CenterOfRotation { get; }
Public ReadOnly Property CenterOfRotation As Point
    Get

Property Value

Type: Point
The point used for the center of rotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ChildElement Property

WpfAnnotationUIChildElement Property

Gets the child UIElement of the annotation, if any.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual UIElement ChildElement { get; }
Public Overridable ReadOnly Property ChildElement As UIElement
    Get

Property Value

Type: UIElement
The child UIElement of the annotation or null (Nothing in VB).
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CreationTime Property

WpfAnnotationUICreationTime Property

Gets or sets the creation time of the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationTime { get; set; }
Public Property CreationTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The creation time of the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.DefaultFill Property

WpfAnnotationUIDefaultFill Property

Gets or sets the default brush used for annotation backgrounds.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationBrush DefaultFill { get; set; }
Public Shared Property DefaultFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The default brush used for annotation backgrounds.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.DefaultOutline Property

WpfAnnotationUIDefaultOutline Property

Gets or sets the default outline used for annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationPen DefaultOutline { get; set; }
Public Shared Property DefaultOutline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The default outline for annotations.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.DefaultShadow Property

WpfAnnotationUIDefaultShadow Property

Gets or sets the default shadow brush used for annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationBrush DefaultShadow { get; set; }
Public Shared Property DefaultShadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The default shadow brush for annotations.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.DefaultShadowOffset Property

WpfAnnotationUIDefaultShadowOffset Property

Gets or sets the default shadow offset used for annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Point DefaultShadowOffset { get; set; }
Public Shared Property DefaultShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The default shadow offset used for annotations.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ExtraProperties Property

WpfAnnotationUIExtraProperties Property

Gets the annotation extra properties dictionary.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary<string, string> ExtraProperties { get; }
Public ReadOnly Property ExtraProperties As AtalaObservableDictionary(Of String, String)
    Get

Property Value

Type: AtalaObservableDictionary String, String
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Geometry Property

WpfAnnotationUIGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Geometry Geometry { get; }
Public Overridable ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
Remarks
The Geometry is presented in annotation space. Derived classes should override this property if the geometry of the annotation is not rectangular.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Grips Property

WpfAnnotationUIGrips Property

Gets the grips for this annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationGrips Grips { get; }
Public ReadOnly Property Grips As WpfAnnotationGrips
    Get

Property Value

Type: WpfAnnotationGrips
The grips for this annotation.
Remarks
Derived classes can override the AttachGripsOverride method to set the annotation grips.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.IsGrouped Property

WpfAnnotationUIIsGrouped Property

Gets a value indicating whether the annotation is being hosted within a group.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsGrouped { get; }
Public ReadOnly Property IsGrouped As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation is being hosted within a group.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.IsMirroredHorizontally Property

WpfAnnotationUIIsMirroredHorizontally Property

Gets a value indicating whether the annotation is mirrored horizontally.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMirroredHorizontally { get; }
Public ReadOnly Property IsMirroredHorizontally As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation is mirrored horizontally.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.IsMirroredVertically Property

WpfAnnotationUIIsMirroredVertically Property

Gets a value indicating whether the annotation is mirrored vertically.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMirroredVertically { get; }
Public ReadOnly Property IsMirroredVertically As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation is mirrored vertically.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.IsVisible Property

WpfAnnotationUIIsVisible Property

Gets or sets a value indicating whether the annotation is visible.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation is visible.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Location Property

WpfAnnotationUILocation Property

Gets or sets the location of the annotation in document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set

Property Value

Type: Point
The location of the annotation in document space.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ModifiedTime Property

WpfAnnotationUIModifiedTime Property

Gets or sets the last time the annotation was modified.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime ModifiedTime { get; set; }
Public Property ModifiedTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The last time the annotation was modified.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Name Property

WpfAnnotationUIName Property

Gets or sets the name for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
A name for the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ParentLayer Property

WpfAnnotationUIParentLayer Property

Gets the parent layer of this annotation, if any.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation ParentLayer { get; }
Public ReadOnly Property ParentLayer As WpfLayerAnnotation
    Get

Property Value

Type: WpfLayerAnnotation
The parent layer of this annotation or null (Nothing in VB).
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.RenderedBounds Property

WpfAnnotationUIRenderedBounds Property

Gets the bounding rectangle of the annotation including any transformations applied for rendering.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rect RenderedBounds { get; }
Public Overridable ReadOnly Property RenderedBounds As Rect
    Get

Property Value

Type: Rect
The bounding rectangle of the annotation with render transformations.
Remarks
The bounds is calculated from the Geometry, outline pen, RenderTransform and any shadow the annotation may have.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.RenderTransform Property

WpfAnnotationUIRenderTransform Property

Gets the transform used when rendering the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Transform RenderTransform { get; }
Public ReadOnly Property RenderTransform As Transform
    Get

Property Value

Type: Transform
The transform used to render the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Rotation Property

WpfAnnotationUIRotation Property

Gets or sets the amount of rotation applied to the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set

Property Value

Type: Double
The amount of rotation applied to the annotation.
Remarks
Valid values are from 0 to 360.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Security Property

WpfAnnotationUISecurity Property

Gets or sets the security for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAnnotationLock Security { get; set; }
Public Property Security As IAnnotationLock
    Get
    Set

Property Value

Type: IAnnotationLock
The security for the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Selected Property

WpfAnnotationUISelected Property

Gets or sets a value indicating whether the annotation is selected.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation is selected.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Size Property

WpfAnnotationUISize Property

Gets or sets the size of the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The size of the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.State Property

WpfAnnotationUIState Property

Gets or sets the annotation state.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationState State { get; set; }
Public Property State As AnnotationState
    Get
    Set

Property Value

Type: AnnotationState
The annotation state.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.SupportsMultiClickCreation Property

WpfAnnotationUISupportsMultiClickCreation Property

Gets a value indicating whether the annotation supports being created from multiple mouse clicks.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool SupportsMultiClickCreation { get; }
Public Overridable ReadOnly Property SupportsMultiClickCreation As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation supports being created from multiple mouse clicks.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ToolTip Property

WpfAnnotationUIToolTip Property

Gets or sets a tooltip to use for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set

Property Value

Type: String
A tooltip for the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.UserHasCreated Property

WpfAnnotationUIUserHasCreated Property

Gets a value indicating if the annotation was end-user created or added directly to a layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UserHasCreated { get; }
Public ReadOnly Property UserHasCreated As Boolean
    Get

Property Value

Type: Boolean
Indicates if the annotation was end-user created.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.UserName Property

WpfAnnotationUIUserName Property

Gets or sets the username for this annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set

Property Value

Type: String
The username for this annotation.
Remarks
This property is mainly used with PDF annotations to indicate the user that created the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Methods

The WpfAnnotationUI type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation.
Protected method | AttachGripsOverride | Called when the annotation grips need to be created.
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation.
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself.
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization.
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation.
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Overrides VisualHitTestCore(PointHitTestParameters).)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself.
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction.
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed.
Protected method | OnAnnotationCreated | Called after the annotation has been created.
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed.
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed.
Protected method | OnCanvasChanged | Called when the Canvas property has changed.
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved.
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation.
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation.
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation.
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Overrides DependencyObjectOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated.
Protected method | OnSelectedChanged | Called when the Selected property has been changed.
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed.
Public method | RaiseEvent | This method is used to force an event in the annotation.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer.
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips.
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring.
Public method | Rotate | This method will append a rotation to the annotation's current rotation.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation.
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.AttachGrips Method

WpfAnnotationUIAttachGrips Method

This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AttachGrips(
    WpfAnnotationCanvas canvas
)
Public Sub AttachGrips (
    canvas As WpfAnnotationCanvas
)

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the canvas argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.AttachGripsOverride Method

WpfAnnotationUIAttachGripsOverride Method

Called when the annotation grips need to be created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual WpfAnnotationGrips AttachGripsOverride(
    WpfAnnotationCanvas canvas
)
Protected Overridable Function AttachGripsOverride (
    canvas As WpfAnnotationCanvas
) As WpfAnnotationGrips

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.

Return Value

Type: WpfAnnotationGrips
The grips for the annotation.
Remarks
My default, WpfRectangleGrips will be created for the annotation. Override this method if other grips are required.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CalculateGeometry Method

WpfAnnotationUICalculateGeometry Method

Calculates the geometry of the annotation with the specified parameters.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Geometry CalculateGeometry(
    Geometry fillGeometry,
    AnnotationBrush fill,
    Geometry outlineGeometry,
    AnnotationPen outline
)
Protected Function CalculateGeometry (
    fillGeometry As Geometry,
    fill As AnnotationBrush,
    outlineGeometry As Geometry,
    outline As AnnotationPen
) As Geometry

Parameters

fillGeometry
Type: System.Windows.MediaGeometry
The Geometry for the fill.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation. This may be null (Nothing in VB).
outlineGeometry
Type: System.Windows.MediaGeometry
The Geometry for the outline.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation. This may be null (Nothing in VB).

Return Value

Type: Geometry
A PathGeometry for the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Clone Method

WpfAnnotationUIClone Method

Creates a copy of the anotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI Clone()
Public Function Clone As WpfAnnotationUI

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CloneOverride Method

WpfAnnotationUICloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected MustOverride Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
Remarks
This method is called from Clone to allow additional properties to be set. The WpfAnnotationUI properties of the clone will be filled before this method is called.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CreateDataSnapshot Method

WpfAnnotationUICreateDataSnapshot Method

This method creates an AnnotationData copy of this annotation for serialization.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData CreateDataSnapshot()
Public Function CreateDataSnapshot As AnnotationData

Return Value

Type: AnnotationData
The AnnotationData for this annotation.
Remarks
Derived classes should override the CreateDataSnapshotOverride method to create a specific AnnotationData class.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CreateDataSnapshotOverride Method

WpfAnnotationUICreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract AnnotationData CreateDataSnapshotOverride()
Protected MustOverride Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.HitTest Method

WpfAnnotationUIHitTest Method

This method will determine whether the specified point is on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool HitTest(
    Point dsPoint
)
Public Overridable Function HitTest (
    dsPoint As Point
) As Boolean

Parameters

dsPoint
Type: System.WindowsPoint
The point to hit test.

Return Value

Type: Boolean
True if the point is on the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.HitTestCore Method

WpfAnnotationUIHitTestCore Method

Overload List
 | Name | Description
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Overrides VisualHitTestCore(PointHitTestParameters).)
Top
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.HitTestCore Method (PointHitTestParameters)

WpfAnnotationUIHitTestCore Method (PointHitTestParameters)

Determines whether a point coordinate value is within the bounds of the visual object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override HitTestResult HitTestCore(
    PointHitTestParameters hitTestParameters
)
Protected Overrides Function HitTestCore (
    hitTestParameters As PointHitTestParameters
) As HitTestResult

Parameters

hitTestParameters
Type: System.Windows.MediaPointHitTestParameters
A PointHitTestParameters object that specifies the Point to hit test against.

Return Value

Type: HitTestResult
A HitTestResult that represents the Visual that is returned from a hit test.
See Also

Reference

WpfAnnotationUI Class
HitTestCore Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.InvalidateVisual Method

WpfAnnotationUIInvalidateVisual Method

Forces the annotation to redraw itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void InvalidateVisual()
Protected Overridable Sub InvalidateVisual
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Mirror Method

WpfAnnotationUIMirror Method

Mirrors the annotation in the specified direction.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Mirror(
    MirrorDirection direction,
    bool maintainPosition
)
Public Overridable Sub Mirror (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The direction to mirror.
maintainPosition
Type: SystemBoolean
Indicates whether the annotation keeps its current position or pivots along its zero axis.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnAnnotationBrushChanged Method

WpfAnnotationUIOnAnnotationBrushChanged Method

Called when the FillProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationBrushChanged(
    AnnotationBrush annotationBrush
)
Protected Overridable Sub OnAnnotationBrushChanged (
    annotationBrush As AnnotationBrush
)

Parameters

annotationBrush
Type: Atalasoft.AnnotateAnnotationBrush
The new AnnotationBrush for the fill.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnAnnotationCreated Method

WpfAnnotationUIOnAnnotationCreated Method

Called after the annotation has been created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationCreated(
    RoutedEventArgs e
)
Protected Overridable Sub OnAnnotationCreated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs for this event.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnAnnotationFontChanged Method

WpfAnnotationUIOnAnnotationFontChanged Method

Called when the FontProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationFontChanged(
    AnnotationFont annotationFont
)
Protected Overridable Sub OnAnnotationFontChanged (
    annotationFont As AnnotationFont
)

Parameters

annotationFont
Type: Atalasoft.AnnotateAnnotationFont
The new AnnotationFont.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnAnnotationPenChanged Method

WpfAnnotationUIOnAnnotationPenChanged Method

Called when the OutlineProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationPenChanged(
    AnnotationPen annotationPen
)
Protected Overridable Sub OnAnnotationPenChanged (
    annotationPen As AnnotationPen
)

Parameters

annotationPen
Type: Atalasoft.AnnotateAnnotationPen
The new AnnotationPen for the outline.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnCanvasChanged Method

WpfAnnotationUIOnCanvasChanged Method

Called when the Canvas property has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCanvasChanged(
    ValueChangedEventArgs<WpfAnnotationCanvas> e
)
Protected Overridable Sub OnCanvasChanged (
    e As ValueChangedEventArgs(Of WpfAnnotationCanvas)
)

Parameters

e
Type: Atalasoft.Annotate.WpfValueChangedEventArgs WpfAnnotationCanvas
An EventArgs for this change.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnGripPositionChanged Method

WpfAnnotationUIOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overridable Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnMouseDown Method

WpfAnnotationUIOnMouseDown Method

Called when a MouseDown event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overridable Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs for the event.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnMouseMove Method

WpfAnnotationUIOnMouseMove Method

Called when a MouseMove event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseMove(
    MouseEventArgs e
)
Protected Overridable Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for the event.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnMouseUp Method

WpfAnnotationUIOnMouseUp Method

Called when a MouseUp event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overridable Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for the event.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnPropertyChanged Method

WpfAnnotationUIOnPropertyChanged Method

Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
Event data that will contain the dependency property identifier of interest, the property metadata for the type, and old and new values.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnRotateDocument Method

WpfAnnotationUIOnRotateDocument Method

Called when the document has been rotated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRotateDocument(
    DocumentRotation rotation
)
Protected Overridable Sub OnRotateDocument (
    rotation As DocumentRotation
)

Parameters

rotation
Type: Atalasoft.AnnotateDocumentRotation
The type of rotation for the document.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OnSelectedChanged Method

WpfAnnotationUIOnSelectedChanged Method

Called when the Selected property has been changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectedChanged(
    EventArgs e
)
Protected Overridable Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OperationRequest Method

WpfAnnotationUIOperationRequest Method

Called when a request operation has been raised on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OperationRequest(
    OperationRequestInformation request
)
Protected Overridable Sub OperationRequest (
    request As OperationRequestInformation
)

Parameters

request
Type: Atalasoft.Annotate.WpfOperationRequestInformation
A OperationRequestInformation for this event.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.PredetermineRenderBounds Method

WpfAnnotationUIPredetermineRenderBounds Method

This method is used to calculate the expected render bounds of an annotation if its rotation was changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rect PredetermineRenderBounds(
    double rotation
)
Public Overridable Function PredetermineRenderBounds (
    rotation As Double
) As Rect

Parameters

rotation
Type: SystemDouble
The new rotation of the annotation.

Return Value

Type: Rect
A rectangle containing the expected bounds.
Remarks
The annotation grips and canvas use this method to confine annotations within the current confinement bounds.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.RaiseEvent Method

WpfAnnotationUIRaiseEvent Method

This method is used to force an event in the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RaiseEvent(
    RoutedEventArgs e
)
Public Sub RaiseEvent (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
The RoutedEventArgs of the event to raise.
Remarks
This method is only supported for the AnnotationCreated, MouseDown, MouseMove and MouseUp events.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Remove Method

WpfAnnotationUIRemove Method

This method will remove the annotation from its parent layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove()
Public Sub Remove
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ReplaceGrips Method

WpfAnnotationUIReplaceGrips Method

Call this method to replace the current annotation grips with new grips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ReplaceGrips(
    WpfAnnotationGrips newGrips
)
Protected Sub ReplaceGrips (
    newGrips As WpfAnnotationGrips
)

Parameters

newGrips
Type: Atalasoft.Annotate.WpfWpfAnnotationGrips
The new grips for the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ResetMirrorVariables Method

WpfAnnotationUIResetMirrorVariables Method

This method will reset the internal Matrix used for mirroring.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ResetMirrorVariables()
Public Sub ResetMirrorVariables
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.Rotate Method

WpfAnnotationUIRotate Method

This method will append a rotation to the annotation's current rotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Rotate(
    double degrees
)
Public Sub Rotate (
    degrees As Double
)

Parameters

degrees
Type: SystemDouble
The amount of rotation to append.
Remarks
To set the annotation to a specific rotation, set the Rotation property.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.SetTransparency Method

WpfAnnotationUISetTransparency Method

Sets the alpha values for the Fill and Outline of the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetTransparency(
    int value
)
Public Sub SetTransparency (
    value As Integer
)

Parameters

value
Type: SystemInt32
The alpha value to use. This must be a value from 0 to 255.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the value is less than 0 or greater than 255.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.SetUserHasCreated Method

WpfAnnotationUISetUserHasCreated Method

Derived class should call this method to indicate that their creation process has completed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetUserHasCreated(
    bool hasCreated
)
Protected Sub SetUserHasCreated (
    hasCreated As Boolean
)

Parameters

hasCreated
Type: SystemBoolean
Indicates whether the user has finished creating the annotation.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Events

The WpfAnnotationUI type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation.
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation.
Public event | PropertyChanged | This event is raised when a property of the annotation has changed.
Top
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.MouseDown Event

WpfAnnotationUIMouseDown Event

Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MouseButtonEventHandler MouseDown
Public Event MouseDown As MouseButtonEventHandler

Value

Type: System.Windows.InputMouseButtonEventHandler
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.MouseUp Event

WpfAnnotationUIMouseUp Event

Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MouseButtonEventHandler MouseUp
Public Event MouseUp As MouseButtonEventHandler

Value

Type: System.Windows.InputMouseButtonEventHandler
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.PropertyChanged Event

WpfAnnotationUIPropertyChanged Event

This event is raised when a property of the annotation has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DependencyPropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As DependencyPropertyChangedEventHandler

Value

Type: System.WindowsDependencyPropertyChangedEventHandler
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI Fields

The WpfAnnotationUI type exposes the following members.

Fields
Name | Description
BoundsProperty | Identifies the Bounds dependency property.
CanMirrorProperty | Identifies the CanMirror dependency property.
CanMoveProperty | Identifies the CanMove dependency property.
CanResizeProperty | Identifies the CanResize dependency property.
CanRotateProperty | Identifies the CanRotate dependency property.
CanSelectProperty | Identifies the CanSelect dependency property.
CreationTimeProperty | Identifies the CreationTime dependency property.
ExtraPropertiesProperty | Identifies the ExtraProperties dependency property.
FillProperty | Identifies the Fill dependency property.
IsVisibleProperty | Identifies the IsVisible dependency property.
LocationProperty | Identifies the Location dependency property.
ModifiedTimeProperty | Identifies the ModifiedTime dependency property.
NameProperty | Identifies the Name dependency property.
OutlineProperty | Identifies the Outline dependency property.
RotationProperty | Identifies the Rotation dependency property.
SecurityProperty | Identifies the Security dependency property.
SelectedProperty | Identifies the Selected dependency property.
ShadowOffsetProperty | Identifies the ShadowOffset dependency property.
ShadowProperty | Identifies the Shadow dependency property.
SizeProperty | Identifies the Size dependency property.
StateProperty | Identifies the State dependency property.
ToolTipProperty | Identifies the ToolTip dependency property.
UserNameProperty | Identifies the UserName dependency property.
Top
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.BoundsProperty Field

WpfAnnotationUIBoundsProperty Field

Identifies the Bounds dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty BoundsProperty
Public Shared ReadOnly BoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
Remarks
Bounds is a read only property that is automatically set when the Location and Size properties are changed.
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanMirrorProperty Field

WpfAnnotationUICanMirrorProperty Field

Identifies the CanMirror dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanMirrorProperty
Public Shared ReadOnly CanMirrorProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanMoveProperty Field

WpfAnnotationUICanMoveProperty Field

Identifies the CanMove dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanMoveProperty
Public Shared ReadOnly CanMoveProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanResizeProperty Field

WpfAnnotationUICanResizeProperty Field

Identifies the CanResize dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanResizeProperty
Public Shared ReadOnly CanResizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanRotateProperty Field

WpfAnnotationUICanRotateProperty Field

Identifies the CanRotate dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRotateProperty
Public Shared ReadOnly CanRotateProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CanSelectProperty Field

WpfAnnotationUICanSelectProperty Field

Identifies the CanSelect dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanSelectProperty
Public Shared ReadOnly CanSelectProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.CreationTimeProperty Field

WpfAnnotationUICreationTimeProperty Field

Identifies the CreationTime dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CreationTimeProperty
Public Shared ReadOnly CreationTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ExtraPropertiesProperty Field

WpfAnnotationUIExtraPropertiesProperty Field

Identifies the ExtraProperties dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ExtraPropertiesProperty
Public Shared ReadOnly ExtraPropertiesProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.FillProperty Field

WpfAnnotationUIFillProperty Field

Identifies the Fill dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FillProperty
Public Shared ReadOnly FillProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.IsVisibleProperty Field

WpfAnnotationUIIsVisibleProperty Field

Identifies the IsVisible dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsVisibleProperty
Public Shared ReadOnly IsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.LocationProperty Field

WpfAnnotationUILocationProperty Field

Identifies the Location dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LocationProperty
Public Shared ReadOnly LocationProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ModifiedTimeProperty Field

WpfAnnotationUIModifiedTimeProperty Field

Identifies the ModifiedTime dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ModifiedTimeProperty
Public Shared ReadOnly ModifiedTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.NameProperty Field

WpfAnnotationUINameProperty Field

Identifies the Name dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameProperty
Public Shared ReadOnly NameProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.OutlineProperty Field

WpfAnnotationUIOutlineProperty Field

Identifies the Outline dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty OutlineProperty
Public Shared ReadOnly OutlineProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.RotationProperty Field

WpfAnnotationUIRotationProperty Field

Identifies the Rotation dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotationProperty
Public Shared ReadOnly RotationProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.SecurityProperty Field

WpfAnnotationUISecurityProperty Field

Identifies the Security dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecurityProperty
Public Shared ReadOnly SecurityProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.SelectedProperty Field

WpfAnnotationUISelectedProperty Field

Identifies the Selected dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedProperty
Public Shared ReadOnly SelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ShadowOffsetProperty Field

WpfAnnotationUIShadowOffsetProperty Field

Identifies the ShadowOffset dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShadowOffsetProperty
Public Shared ReadOnly ShadowOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ShadowProperty Field

WpfAnnotationUIShadowProperty Field

Identifies the Shadow dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShadowProperty
Public Shared ReadOnly ShadowProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.SizeProperty Field

WpfAnnotationUISizeProperty Field

Identifies the Size dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeProperty
Public Shared ReadOnly SizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.StateProperty Field

WpfAnnotationUIStateProperty Field

Identifies the State dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.ToolTipProperty Field

WpfAnnotationUIToolTipProperty Field

Identifies the ToolTip dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolTipProperty
Public Shared ReadOnly ToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUI.UserNameProperty Field

WpfAnnotationUIUserNameProperty Field

Identifies the UserName dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty UserNameProperty
Public Shared ReadOnly UserNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfAnnotationUI Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Class

This class is a collection of WpfAnnotationUI objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationUICollection

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationUICollection : ICollection<WpfAnnotationUI>,
    IEnumerable<WpfAnnotationUI>, IEnumerable
Public Class WpfAnnotationUICollection
    Implements ICollection(Of WpfAnnotationUI), IEnumerable(Of WpfAnnotationUI),
    IEnumerable

The WpfAnnotationUICollection type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationUICollection | Creates a new instance of WpfAnnotationUICollection.
Public method | WpfAnnotationUICollection(WpfAnnotationUI) | Creates a new instance of WpfAnnotationUICollection with the specified annoations.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of annotation in the collection.
Public property | IsReadOnly | Gets a value indicating whether this collection is read-only.
Public property | Item | Gets the annotation at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds an annotation to the end of the collection.
Public method | AddRange | Adds a group of annotations to the collection.
Public method | AsReadOnly | Returns a read-only version of this collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether an annotation is contained in the collection.
Public method | CopyTo | Copies the annotations into the supplied array starting at the specified index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of the specified annotation.
Public method | Insert | Inserts an annotation into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Called when the collection has been changed and raises the CollectionChanged event.
Public method | Remove | Removes the specified annotation from the collection.
Public method | RemoveAt | Removes the annotation at the specified index from the collection.
Public method | ToArray | Returns an array of WpfAnnotationUI containing the annotations in this collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Raised when the collection has been changed.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Constructor

Overload List
 | Name | Description
Public method | WpfAnnotationUICollection | Creates a new instance of WpfAnnotationUICollection.
Public method | WpfAnnotationUICollection(WpfAnnotationUI) | Creates a new instance of WpfAnnotationUICollection with the specified annoations.
Top
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Constructor

Creates a new instance of WpfAnnotationUICollection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUICollection()
Public Sub New
See Also

Reference

WpfAnnotationUICollection Class
WpfAnnotationUICollection Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Constructor (WpfAnnotationUI[])

WpfAnnotationUICollection Constructor (WpfAnnotationUI)

Creates a new instance of WpfAnnotationUICollection with the specified annoations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUICollection(
    WpfAnnotationUI[] annotations
)
Public Sub New (
    annotations As WpfAnnotationUI()
)

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The initial annotation for the collection.
Exceptions
Exception | Condition
NullReferenceException | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
WpfAnnotationUICollection Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Properties

The WpfAnnotationUICollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of annotation in the collection.
Public property | IsReadOnly | Gets a value indicating whether this collection is read-only.
Public property | Item | Gets the annotation at the specified index.
Top
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Count Property

WpfAnnotationUICollectionCount Property

Gets the number of annotation in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of annotation in the collection.

Implements

ICollectionTCount
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.IsReadOnly Property

WpfAnnotationUICollectionIsReadOnly Property

Gets a value indicating whether this collection is read-only.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the collection is read-only.

Implements

ICollectionTIsReadOnly
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Item Property

WpfAnnotationUICollectionItem Property

Gets the annotation at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As WpfAnnotationUI
    Get

Parameters

index
Type: SystemInt32
The index of the annotation to get.

Return Value

Type: WpfAnnotationUI
The annotation at the specified index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Methods

The WpfAnnotationUICollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an annotation to the end of the collection.
Public method | AddRange | Adds a group of annotations to the collection.
Public method | AsReadOnly | Returns a read-only version of this collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether an annotation is contained in the collection.
Public method | CopyTo | Copies the annotations into the supplied array starting at the specified index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of the specified annotation.
Public method | Insert | Inserts an annotation into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Called when the collection has been changed and raises the CollectionChanged event.
Public method | Remove | Removes the specified annotation from the collection.
Public method | RemoveAt | Removes the annotation at the specified index from the collection.
Public method | ToArray | Returns an array of WpfAnnotationUI containing the annotations in this collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Add Method

WpfAnnotationUICollectionAdd Method

Adds an annotation to the end of the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    WpfAnnotationUI item
)
Public Sub Add (
    item As WpfAnnotationUI
)

Parameters

item
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to add.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the item argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.AddRange Method

WpfAnnotationUICollectionAddRange Method

Adds a group of annotations to the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    IEnumerable<WpfAnnotationUI> annotations
)
Public Sub AddRange (
    annotations As IEnumerable(Of WpfAnnotationUI)
)

Parameters

annotations
Type: System.Collections.GenericIEnumerable WpfAnnotationUI
The annotation to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.AsReadOnly Method

WpfAnnotationUICollectionAsReadOnly Method

Returns a read-only version of this collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUICollection AsReadOnly()
Public Function AsReadOnly As WpfAnnotationUICollection

Return Value

Type: WpfAnnotationUICollection
A read-only collection.
Remarks
This does not clone the annotations.
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Clear Method

WpfAnnotationUICollectionClear Method

Removes all items from the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Contains Method

WpfAnnotationUICollectionContains Method

Determines whether an annotation is contained in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    WpfAnnotationUI item
)
Public Function Contains (
    item As WpfAnnotationUI
) As Boolean

Parameters

item
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to search for.

Return Value

Type: Boolean
True if the annotation is in the collection.

Implements

ICollectionTContains(T)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the item argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.CopyTo Method

WpfAnnotationUICollectionCopyTo Method

Copies the annotations into the supplied array starting at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    WpfAnnotationUI[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As WpfAnnotationUI(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The array annotations will be copied into.
arrayIndex
Type: SystemInt32
The starting index in the array to begin copying.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the array argument is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the arrayIndex argument is invalid for the provided array.
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.GetEnumerator Method

WpfAnnotationUICollectionGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<WpfAnnotationUI> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of WpfAnnotationUI)

Return Value

Type: IEnumerator WpfAnnotationUI
An enumerator for the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.IndexOf Method

WpfAnnotationUICollectionIndexOf Method

Returns the index of the specified annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    WpfAnnotationUI annotation
)
Public Function IndexOf (
    annotation As WpfAnnotationUI
) As Integer

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to search for.

Return Value

Type: Int32
The index of the annotation or -1 if the annotation does not exist in the collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Insert Method

WpfAnnotationUICollectionInsert Method

Inserts an annotation into the collection at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    WpfAnnotationUI annotation
)
Public Sub Insert (
    index As Integer,
    annotation As WpfAnnotationUI
)

Parameters

index
Type: SystemInt32
The index where the annotation will be placed.
annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to insert.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is valid for the collection.
ArgumentNullException | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.OnCollectionChanged Method

WpfAnnotationUICollectionOnCollectionChanged Method

Called when the collection has been changed and raises the CollectionChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCollectionChanged(
    CollectionChangedEventArgs<WpfAnnotationUI> e
)
Protected Overridable Sub OnCollectionChanged (
    e As CollectionChangedEventArgs(Of WpfAnnotationUI)
)

Parameters

e
Type: Atalasoft.Annotate.WpfCollectionChangedEventArgs WpfAnnotationUI
A CollectionChangedEventArgs<WpfAnnotationUI> containing information about the change.
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.Remove Method

WpfAnnotationUICollectionRemove Method

Removes the specified annotation from the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    WpfAnnotationUI item
)
Public Function Remove (
    item As WpfAnnotationUI
) As Boolean

Parameters

item
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to remove.

Return Value

Type: Boolean
True if the annotation was removed from the collection; False if the annotation does not exist in the collection.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the item argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.RemoveAt Method

WpfAnnotationUICollectionRemoveAt Method

Removes the annotation at the specified index from the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the annotation to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.ToArray Method

WpfAnnotationUICollectionToArray Method

Returns an array of WpfAnnotationUI containing the annotations in this collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI[] ToArray()
Public Function ToArray As WpfAnnotationUI()

Return Value

Type: WpfAnnotationUI
An array of annotation in this collection.
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection Events

The WpfAnnotationUICollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Raised when the collection has been changed.
Top
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUICollection.CollectionChanged Event

WpfAnnotationUICollectionCollectionChanged Event

Raised when the collection has been changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangedEventArgs<WpfAnnotationUI>> CollectionChanged
Public Event CollectionChanged As EventHandler(Of CollectionChangedEventArgs(Of WpfAnnotationUI))

Value

Type: SystemEventHandler CollectionChangedEventArgs WpfAnnotationUI
See Also

Reference

WpfAnnotationUICollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator Class

This class is returned by WpfAnnotationUICollection.GetEnumerator to enumerate through the annotation collection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationUIEnumerator

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationUIEnumerator : IEnumerator
Public Class WpfAnnotationUIEnumerator
    Implements IEnumerator

The WpfAnnotationUIEnumerator type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationUIEnumerator | Creates a new instance of WpfAnnotationUIEnumerator using the specified annotations.
Top
Properties
 | Name | Description
Public property | Current | Gets the current element in the collection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves the IEnumerator to the next item.
Public method | Reset | Resets the IEnumerator to before the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator Constructor

Creates a new instance of WpfAnnotationUIEnumerator using the specified annotations.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUIEnumerator(
    WpfAnnotationUI[] annotations
)
Public Sub New (
    annotations As WpfAnnotationUI()
)

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotations that will be enumerated.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotations argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUIEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator Properties

The WpfAnnotationUIEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current element in the collection.
Top
See Also

Reference

WpfAnnotationUIEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator.Current Property

WpfAnnotationUIEnumeratorCurrent Property

Gets the current element in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI Current { get; }
Public ReadOnly Property Current As WpfAnnotationUI
    Get

Return Value

Type: WpfAnnotationUI
The current element in the collection.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element.
See Also

Reference

WpfAnnotationUIEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator Methods

The WpfAnnotationUIEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves the IEnumerator to the next item.
Public method | Reset | Resets the IEnumerator to before the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfAnnotationUIEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator.MoveNext Method

WpfAnnotationUIEnumeratorMoveNext Method

Moves the IEnumerator to the next item.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MoveNext()
Public Function MoveNext As Boolean

Return Value

Type: Boolean
True if the move was successful; False if there are no more items.

Implements

IEnumeratorMoveNext
See Also

Reference

WpfAnnotationUIEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIEnumerator.Reset Method

WpfAnnotationUIEnumeratorReset Method

Resets the IEnumerator to before the beginning.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset

Implements

IEnumeratorReset
Remarks
After calling Reset, MoveNext must be called before accessing the Current property.
See Also

Reference

WpfAnnotationUIEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData) Class

WpfAnnotationUIFactoryT, TData Class

This class is the default annotation factory used by all WPF annotations provided.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationUIFactoryT, TData

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationUIFactory<T, TData> : IWpfAnnotationUIFactory
where T : WpfAnnotationUI
where TData : AnnotationData

Public Class WpfAnnotationUIFactory(Of T As WpfAnnotationUI, TData As AnnotationData)
    Implements IWpfAnnotationUIFactory

Type Parameters

T
The WpfAnnotationUI the factory will create.
TData
The AnnotationData the factory will use to create the annotation.

The WpfAnnotationUIFactoryT, TData type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationUIFactoryT, TData | Creates a new instance of WpfAnnotationUIFactory.
Top
Properties
 | Name | Description
Public property | AnnotationType | Gets the type of annotation the factory can create.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a new annotation from an AnnotationData class.
Protected method | GetAnnotationUIOverride | Called when the factory cannot find a constructor taking the AnnotationData passed into GetAnnotationUI.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData) Constructor

WpfAnnotationUIFactoryT, TData Constructor

Creates a new instance of WpfAnnotationUIFactory.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUIFactory()
Public Sub New
See Also

Reference

WpfAnnotationUIFactoryT, TData Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData) Properties

WpfAnnotationUIFactoryT, TData Properties

The WpfAnnotationUIFactoryT, TData generic type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationType | Gets the type of annotation the factory can create.
Top
See Also

Reference

WpfAnnotationUIFactoryT, TData Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData).AnnotationType Property

WpfAnnotationUIFactoryT, TDataAnnotationType Property

Gets the type of annotation the factory can create.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Type AnnotationType { get; }
Public ReadOnly Property AnnotationType As Type
    Get

Property Value

Type: Type
The annotation type created by the factory.

Implements

IWpfAnnotationUIFactoryAnnotationType
See Also

Reference

WpfAnnotationUIFactoryT, TData Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData) Methods

WpfAnnotationUIFactoryT, TData Methods

The WpfAnnotationUIFactoryT, TData generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationUI | Returns a new annotation from an AnnotationData class.
Protected method | GetAnnotationUIOverride | Called when the factory cannot find a constructor taking the AnnotationData passed into GetAnnotationUI.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfAnnotationUIFactoryT, TData Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData).GetAnnotationUI Method

WpfAnnotationUIFactoryT, TDataGetAnnotationUI Method

Returns a new annotation from an AnnotationData class.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As WpfAnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data used to construct the annotation.

Return Value

Type: WpfAnnotationUI
A new annotation or null (Nothing in VB) if the annotation could not be created by the factory.

Implements

IWpfAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

WpfAnnotationUIFactoryT, TData Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactory(T, TData).GetAnnotationUIOverride Method

WpfAnnotationUIFactoryT, TDataGetAnnotationUIOverride Method

Called when the factory cannot find a constructor taking the AnnotationData passed into GetAnnotationUI.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual WpfAnnotationUI GetAnnotationUIOverride(
    TData data
)
Protected Overridable Function GetAnnotationUIOverride (
    data As TData
) As WpfAnnotationUI

Parameters

data
Type: TData
The annotation data to create an annotation for.

Return Value

Type: WpfAnnotationUI
A new annotation or null (Nothing in VB) if the annotation could not be created.
See Also

Reference

WpfAnnotationUIFactoryT, TData Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection Class

This class holds the annotation UI factories used when deserializing AnnotationData objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfAnnotationUIFactoryCollection

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationUIFactoryCollection
Public Class WpfAnnotationUIFactoryCollection

The WpfAnnotationUIFactoryCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationUIFactoryCollection | Creates a new instance of WpfAnnotationUIFactoryCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of factories in the collection.
Public property | ItemInt32 | Gets the factory at the specified index.
Public property | ItemType | Gets the factory for the specified type.
Top
Methods
 | Name | Description
Public method | Add | Adds to the collection.
Public method | Clear | Clears the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationFromData | Creates an annotation from the provided annotation data.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts a factory into the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a factory from the collection.
Public method | RemoveAt | Removes a factory from the collection at the specified index.
Public method | Replace | Replaces an existing factory with a new one. If the oldFactory argument does not exist in the collection, the new factory is added to the end of the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection Constructor

Creates a new instance of WpfAnnotationUIFactoryCollection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUIFactoryCollection()
Public Sub New
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection Properties

The WpfAnnotationUIFactoryCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of factories in the collection.
Public property | ItemInt32 | Gets the factory at the specified index.
Public property | ItemType | Gets the factory for the specified type.
Top
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Count Property

WpfAnnotationUIFactoryCollectionCount Property

Gets the number of factories in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The factory count.
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Item Property

WpfAnnotationUIFactoryCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets the factory at the specified index.
Public property | ItemType | Gets the factory for the specified type.
Top
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Item Property (Int32)

WpfAnnotationUIFactoryCollectionItem Property (Int32)

Gets the factory at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IWpfAnnotationUIFactory this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IWpfAnnotationUIFactory
    Get

Parameters

index
Type: SystemInt32
The index of the factory to get.

Return Value

Type: IWpfAnnotationUIFactory
The factory at the specified index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Item Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Item Property (Type)

WpfAnnotationUIFactoryCollectionItem Property (Type)

Gets the factory for the specified type.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IWpfAnnotationUIFactory this[
    Type annotationType
] { get; }
Public ReadOnly Default Property Item (
    annotationType As Type
) As IWpfAnnotationUIFactory
    Get

Parameters

annotationType
Type: SystemType
The annotation type for the factory.

Return Value

Type: IWpfAnnotationUIFactory
The factory for the type or null (Nothing in VB) if there is no factory for the specified type.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotationType argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Item Overload
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection Methods

The WpfAnnotationUIFactoryCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds to the collection.
Public method | Clear | Clears the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnotationFromData | Creates an annotation from the provided annotation data.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts a factory into the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a factory from the collection.
Public method | RemoveAt | Removes a factory from the collection at the specified index.
Public method | Replace | Replaces an existing factory with a new one. If the oldFactory argument does not exist in the collection, the new factory is added to the end of the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Add Method

WpfAnnotationUIFactoryCollectionAdd Method

Adds to the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    IWpfAnnotationUIFactory factory
)
Public Sub Add (
    factory As IWpfAnnotationUIFactory
)

Parameters

factory
Type: Atalasoft.Annotate.WpfIWpfAnnotationUIFactory
The factory to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the factory is null (Nothing in VB).
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Clear Method

WpfAnnotationUIFactoryCollectionClear Method

Clears the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.GetAnnotationFromData Method

WpfAnnotationUIFactoryCollectionGetAnnotationFromData Method

Creates an annotation from the provided annotation data.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI GetAnnotationFromData(
    AnnotationData data
)
Public Function GetAnnotationFromData (
    data As AnnotationData
) As WpfAnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data used to generate the annotation.

Return Value

Type: WpfAnnotationUI
A new annotation created from the AnnotationData or null (Nothing in VB) if there is no factory for the data.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Insert Method

WpfAnnotationUIFactoryCollectionInsert Method

Inserts a factory into the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    IWpfAnnotationUIFactory factory
)
Public Sub Insert (
    index As Integer,
    factory As IWpfAnnotationUIFactory
)

Parameters

index
Type: SystemInt32
The index location to insert the factory.
factory
Type: Atalasoft.Annotate.WpfIWpfAnnotationUIFactory
The factory to insert.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the factory is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Remove Method

WpfAnnotationUIFactoryCollectionRemove Method

Removes a factory from the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    IWpfAnnotationUIFactory factory
)
Public Sub Remove (
    factory As IWpfAnnotationUIFactory
)

Parameters

factory
Type: Atalasoft.Annotate.WpfIWpfAnnotationUIFactory
The factory to remove.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the factory is null (Nothing in VB).
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.RemoveAt Method

WpfAnnotationUIFactoryCollectionRemoveAt Method

Removes a factory from the collection at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the factory to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfAnnotationUIFactoryCollection.Replace Method

WpfAnnotationUIFactoryCollectionReplace Method

Replaces an existing factory with a new one. If the oldFactory argument does not exist in the collection, the new factory is added to the end of the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    IWpfAnnotationUIFactory oldFactory,
    IWpfAnnotationUIFactory newFactory
)
Public Sub Replace (
    oldFactory As IWpfAnnotationUIFactory,
    newFactory As IWpfAnnotationUIFactory
)

Parameters

oldFactory
Type: Atalasoft.Annotate.WpfIWpfAnnotationUIFactory
The factory to replace.
newFactory
Type: Atalasoft.Annotate.WpfIWpfAnnotationUIFactory
The new factory that will be inserted into the collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationUIFactoryCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Class

This annotation is designed to provide additional information on a specific area of the document. It contains an editable text area and a leader line used to point to the area of the document. When creating this annotation, the first click sets the target for the leader and centers the annotation over the target. With the mouse still pressed, drag the annotation to the desired location. Both annotation and leader point can be repositioned independently after the annotation has been created.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfCalloutAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfCalloutAnnotation : WpfAnnotationUI
Public Class WpfCalloutAnnotation
    Inherits WpfAnnotationUI

The WpfCalloutAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfCalloutAnnotation | Creates a new instance WpfCalloutAnnotation using default values.
Public method | WpfCalloutAnnotation(CalloutData) | Creates a new instance of WpfCalloutAnnotation from a CalloutData object.
Public method | WpfCalloutAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationPen, Double, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfCalloutAnnotation specifying its more common properties.
Public method | WpfCalloutAnnotation(Rect, Point, String, AnnotationFont, AnnotationBrush, AnnotationPen, Double, AnnotationBrush, AnnotationPen, AnnotationBrush, Point, Double, StringAlignment, StringAlignment) | Creates a new instance of WpfCalloutAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal text alignment.
Public property | AllowEditing | Gets or sets a value indicating whether the annotation text can be edited by double-clicking on the annotation.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanEditMirrored | Gets or sets a value indicating whether the text can be edited mirrored.
Public property | CanEditRotated | Gets or sets a value indicating whether the text can be edited rotated.
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Overrides WpfAnnotationUIChildElement.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditMode | Gets or sets a value indicating whether the annotation is in 'Edit Mode'.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the font.
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Leader | Gets or sets the pen used for the leader line.
Public property | LeaderFlatLength | Gets or sets the length of the leader line to the bend.
Public property | LineAlignment | Gets or sets the vertical text alignment.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | Padding | Gets or sets the amount of padding around the text.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | TargetPosition | Gets or sets the position of the target in document space.
Public property | Text | Gets or sets the annotation text.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLeaderPoints | Returns an array of Point used to render the leader line.
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Protected method | HideEditBox | Called when the edit box needs to be hidden from the user.
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Overrides WpfAnnotationUIOnAnnotationBrushChanged(AnnotationBrush).)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Overrides WpfAnnotationUIOnAnnotationFontChanged(AnnotationFont).)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Overrides WpfAnnotationUIOnAnnotationPenChanged(AnnotationPen).)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Overrides WpfAnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Overrides WpfAnnotationUIOperationRequest(OperationRequestInformation).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Protected method | ShowEditBox | Called when the edit box needs to be shown, allowing the end-user to modify the annotation text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AllowEditingProperty | Identifies the AllowEditing dependency property.
CanEditMirroredProperty | Identifies the CanEditMirrored dependency property.
CanEditRotatedProperty | Identifies the CanEditRotated dependency property.
EditModeProperty | Identifies the EditMode dependency property.
FontBrushProperty | Identifies the FontBrush dependency property.
FontProperty | Identifies the Font dependency property.
LeaderFlatLengthProperty | Identifies the LeaderFlatLength dependency property.
LeaderProperty | Identifies the Leader dependency property.
LineAlignmentProperty | Identifies the LineAlignment dependency property.
PaddingProperty | Identifies the Padding dependency property.
TargetPositionProperty | Identifies the TargetPosition dependency property.
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfCalloutAnnotation | Creates a new instance WpfCalloutAnnotation using default values.
Public method | WpfCalloutAnnotation(CalloutData) | Creates a new instance of WpfCalloutAnnotation from a CalloutData object.
Public method | WpfCalloutAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationPen, Double, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfCalloutAnnotation specifying its more common properties.
Public method | WpfCalloutAnnotation(Rect, Point, String, AnnotationFont, AnnotationBrush, AnnotationPen, Double, AnnotationBrush, AnnotationPen, AnnotationBrush, Point, Double, StringAlignment, StringAlignment) | Creates a new instance of WpfCalloutAnnotation specifying its properties.
Top
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Constructor

Creates a new instance WpfCalloutAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfCalloutAnnotation()
Public Sub New
Remarks
The default font used is Arial 12 with a black font brush.
See Also

Reference

WpfCalloutAnnotation Class
WpfCalloutAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Constructor (CalloutData)

Creates a new instance of WpfCalloutAnnotation from a CalloutData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfCalloutAnnotation(
    CalloutData data
)
Public Sub New (
    data As CalloutData
)

Parameters

data
Type: Atalasoft.AnnotateCalloutData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfCalloutAnnotation Class
WpfCalloutAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationPen, Double, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfCalloutAnnotation specifying its more common properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfCalloutAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationPen leader,
    double leaderFlatLength,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    leader As AnnotationPen,
    leaderFlatLength As Double,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

text
Type: SystemString
The text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used by the annotation.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
leader
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the leader.
leaderFlatLength
Type: SystemDouble
The length of the leader line to the bend.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the annotation outline. This can be null (Nothing in VB).
See Also

Reference

WpfCalloutAnnotation Class
WpfCalloutAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Constructor (Rect, Point, String, AnnotationFont, AnnotationBrush, AnnotationPen, Double, AnnotationBrush, AnnotationPen, AnnotationBrush, Point, Double, StringAlignment, StringAlignment)

Creates a new instance of WpfCalloutAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfCalloutAnnotation(
    Rect bounds,
    Point targetPosition,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationPen leader,
    double leaderFlatLength,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset,
    double padding,
    StringAlignment alignement,
    StringAlignment lineAlignment
)
Public Sub New (
    bounds As Rect,
    targetPosition As Point,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    leader As AnnotationPen,
    leaderFlatLength As Double,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point,
    padding As Double,
    alignement As StringAlignment,
    lineAlignment As StringAlignment
)

Parameters

bounds
Type: System.WindowsRect
The bounds for the annotation.
targetPosition
Type: System.WindowsPoint
The target position for the callout.
text
Type: SystemString
The text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used by the annotation.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
leader
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the leader.
leaderFlatLength
Type: SystemDouble
The length of the leader line to the bend.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the annotation outline. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
The offset of the shadow from the annotation.
padding
Type: SystemDouble
The amount of padding around the annotation text.
alignement
Type: System.DrawingStringAlignment
The horizontal text alignment.
lineAlignment
Type: System.DrawingStringAlignment
The vertical text alignment.
See Also

Reference

WpfCalloutAnnotation Class
WpfCalloutAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Properties

The WpfCalloutAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal text alignment.
Public property | AllowEditing | Gets or sets a value indicating whether the annotation text can be edited by double-clicking on the annotation.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanEditMirrored | Gets or sets a value indicating whether the text can be edited mirrored.
Public property | CanEditRotated | Gets or sets a value indicating whether the text can be edited rotated.
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Overrides WpfAnnotationUIChildElement.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditMode | Gets or sets a value indicating whether the annotation is in 'Edit Mode'.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the font.
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Leader | Gets or sets the pen used for the leader line.
Public property | LeaderFlatLength | Gets or sets the length of the leader line to the bend.
Public property | LineAlignment | Gets or sets the vertical text alignment.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | Padding | Gets or sets the amount of padding around the text.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | TargetPosition | Gets or sets the position of the target in document space.
Public property | Text | Gets or sets the annotation text.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Alignment Property

WpfCalloutAnnotationAlignment Property

Gets or sets the horizontal text alignment.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment Alignment { get; set; }
Public Property Alignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The horizontal text alignment.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.AllowEditing Property

WpfCalloutAnnotationAllowEditing Property

Gets or sets a value indicating whether the annotation text can be edited by double-clicking on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation text can be edited by the end-user.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.CanEditMirrored Property

WpfCalloutAnnotationCanEditMirrored Property

Gets or sets a value indicating whether the text can be edited mirrored.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanEditMirrored { get; set; }
Public Property CanEditMirrored As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the text can be edited mirrored.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.CanEditRotated Property

WpfCalloutAnnotationCanEditRotated Property

Gets or sets a value indicating whether the text can be edited rotated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanEditRotated { get; set; }
Public Property CanEditRotated As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the text can be edited rotated.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.ChildElement Property

WpfCalloutAnnotationChildElement Property

Gets the child UIElement of the annotation, if any.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UIElement ChildElement { get; }
Public Overrides ReadOnly Property ChildElement As UIElement
    Get

Property Value

Type: UIElement
The child UIElement of the annotation or null (Nothing in VB).
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.EditMode Property

WpfCalloutAnnotationEditMode Property

Gets or sets a value indicating whether the annotation is in 'Edit Mode'.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EditMode { get; set; }
Public Property EditMode As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation is in 'Edit Mode'.
Remarks
When EditMode is true, a TextBox is displayed to allow the end-user to modify the annotation text.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Fill Property

WpfCalloutAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Font Property

WpfCalloutAnnotationFont Property

Gets or sets the font used to render the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used to render the text.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.FontBrush Property

WpfCalloutAnnotationFontBrush Property

Gets or sets the brush used to render the font.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to render the font.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Geometry Property

WpfCalloutAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Leader Property

WpfCalloutAnnotationLeader Property

Gets or sets the pen used for the leader line.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Leader { get; set; }
Public Property Leader As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the leader line.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.LeaderFlatLength Property

WpfCalloutAnnotationLeaderFlatLength Property

Gets or sets the length of the leader line to the bend.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LeaderFlatLength { get; set; }
Public Property LeaderFlatLength As Double
    Get
    Set

Property Value

Type: Double
The length of the leader line to the bend.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.LineAlignment Property

WpfCalloutAnnotationLineAlignment Property

Gets or sets the vertical text alignment.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment LineAlignment { get; set; }
Public Property LineAlignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The vertical text alignment.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Outline Property

WpfCalloutAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Padding Property

WpfCalloutAnnotationPadding Property

Gets or sets the amount of padding around the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Padding { get; set; }
Public Property Padding As Double
    Get
    Set

Property Value

Type: Double
The amount of padding around the text.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Shadow Property

WpfCalloutAnnotationShadow Property

Gets or sets the brush used for the annotation shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
Remarks
Set this property to null (Nothing in VB) to remove the shadow.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.ShadowOffset Property

WpfCalloutAnnotationShadowOffset Property

Gets or sets the offset used to position the shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The offset used to position the shadow.
Remarks
A negative value will move the shadow to up and to the left. Positive values will move the shadow down and to the right.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.TargetPosition Property

WpfCalloutAnnotationTargetPosition Property

Gets or sets the position of the target in document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point TargetPosition { get; set; }
Public Property TargetPosition As Point
    Get
    Set

Property Value

Type: Point
The target position in document space.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.Text Property

WpfCalloutAnnotationText Property

Gets or sets the annotation text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The annotation text.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Methods

The WpfCalloutAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLeaderPoints | Returns an array of Point used to render the leader line.
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Protected method | HideEditBox | Called when the edit box needs to be hidden from the user.
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Overrides WpfAnnotationUIOnAnnotationBrushChanged(AnnotationBrush).)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Overrides WpfAnnotationUIOnAnnotationFontChanged(AnnotationFont).)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Overrides WpfAnnotationUIOnAnnotationPenChanged(AnnotationPen).)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Overrides WpfAnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Overrides WpfAnnotationUIOperationRequest(OperationRequestInformation).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Protected method | ShowEditBox | Called when the edit box needs to be shown, allowing the end-user to modify the annotation text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.AttachGripsOverride Method

WpfCalloutAnnotationAttachGripsOverride Method

Called when the annotation grips need to be created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationGrips AttachGripsOverride(
    WpfAnnotationCanvas canvas
)
Protected Overrides Function AttachGripsOverride (
    canvas As WpfAnnotationCanvas
) As WpfAnnotationGrips

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.

Return Value

Type: WpfAnnotationGrips
The grips for the annotation.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.CloneOverride Method

WpfCalloutAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.CreateDataSnapshotOverride Method

WpfCalloutAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.GetLeaderPoints Method

WpfCalloutAnnotationGetLeaderPoints Method

Returns an array of Point used to render the leader line.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point[] GetLeaderPoints()
Public Function GetLeaderPoints As Point()

Return Value

Type: Point
An array of Point for the leader line.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.HideEditBox Method

WpfCalloutAnnotationHideEditBox Method

Called when the edit box needs to be hidden from the user.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void HideEditBox()
Protected Overridable Sub HideEditBox
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnAnnotationBrushChanged Method

WpfCalloutAnnotationOnAnnotationBrushChanged Method

Called when the FillProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationBrushChanged(
    AnnotationBrush annotationBrush
)
Protected Overrides Sub OnAnnotationBrushChanged (
    annotationBrush As AnnotationBrush
)

Parameters

annotationBrush
Type: Atalasoft.AnnotateAnnotationBrush
The new AnnotationBrush for the fill.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnAnnotationFontChanged Method

WpfCalloutAnnotationOnAnnotationFontChanged Method

Called when the FontProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationFontChanged(
    AnnotationFont annotationFont
)
Protected Overrides Sub OnAnnotationFontChanged (
    annotationFont As AnnotationFont
)

Parameters

annotationFont
Type: Atalasoft.AnnotateAnnotationFont
The new AnnotationFont.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnAnnotationPenChanged Method

WpfCalloutAnnotationOnAnnotationPenChanged Method

Called when the OutlineProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationPenChanged(
    AnnotationPen annotationPen
)
Protected Overrides Sub OnAnnotationPenChanged (
    annotationPen As AnnotationPen
)

Parameters

annotationPen
Type: Atalasoft.AnnotateAnnotationPen
The new AnnotationPen for the outline.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnGripPositionChanged Method

WpfCalloutAnnotationOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overrides Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnMouseDown Method

WpfCalloutAnnotationOnMouseDown Method

Called when a MouseDown event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs for the event.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnMouseMove Method

WpfCalloutAnnotationOnMouseMove Method

Called when a MouseMove event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for the event.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnMouseUp Method

WpfCalloutAnnotationOnMouseUp Method

Called when a MouseUp event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for the event.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnPropertyChanged Method

WpfCalloutAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OnSelectedChanged Method

WpfCalloutAnnotationOnSelectedChanged Method

Called when the Selected property has been changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSelectedChanged(
    EventArgs e
)
Protected Overrides Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.OperationRequest Method

WpfCalloutAnnotationOperationRequest Method

Called when a request operation has been raised on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OperationRequest(
    OperationRequestInformation request
)
Protected Overrides Sub OperationRequest (
    request As OperationRequestInformation
)

Parameters

request
Type: Atalasoft.Annotate.WpfOperationRequestInformation
A OperationRequestInformation for this event.
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.ShowEditBox Method

WpfCalloutAnnotationShowEditBox Method

Called when the edit box needs to be shown, allowing the end-user to modify the annotation text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ShowEditBox()
Protected Overridable Sub ShowEditBox
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Events

The WpfCalloutAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation Fields

The WpfCalloutAnnotation type exposes the following members.

Fields
Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AllowEditingProperty | Identifies the AllowEditing dependency property.
CanEditMirroredProperty | Identifies the CanEditMirrored dependency property.
CanEditRotatedProperty | Identifies the CanEditRotated dependency property.
EditModeProperty | Identifies the EditMode dependency property.
FontBrushProperty | Identifies the FontBrush dependency property.
FontProperty | Identifies the Font dependency property.
LeaderFlatLengthProperty | Identifies the LeaderFlatLength dependency property.
LeaderProperty | Identifies the Leader dependency property.
LineAlignmentProperty | Identifies the LineAlignment dependency property.
PaddingProperty | Identifies the Padding dependency property.
TargetPositionProperty | Identifies the TargetPosition dependency property.
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.AlignmentProperty Field

WpfCalloutAnnotationAlignmentProperty Field

Identifies the Alignment dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AlignmentProperty
Public Shared ReadOnly AlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.AllowEditingProperty Field

WpfCalloutAnnotationAllowEditingProperty Field

Identifies the AllowEditing dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AllowEditingProperty
Public Shared ReadOnly AllowEditingProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.CanEditMirroredProperty Field

WpfCalloutAnnotationCanEditMirroredProperty Field

Identifies the CanEditMirrored dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanEditMirroredProperty
Public Shared ReadOnly CanEditMirroredProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.CanEditRotatedProperty Field

WpfCalloutAnnotationCanEditRotatedProperty Field

Identifies the CanEditRotated dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanEditRotatedProperty
Public Shared ReadOnly CanEditRotatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.EditModeProperty Field

WpfCalloutAnnotationEditModeProperty Field

Identifies the EditMode dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty EditModeProperty
Public Shared ReadOnly EditModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.FontBrushProperty Field

WpfCalloutAnnotationFontBrushProperty Field

Identifies the FontBrush dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontBrushProperty
Public Shared ReadOnly FontBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.FontProperty Field

WpfCalloutAnnotationFontProperty Field

Identifies the Font dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontProperty
Public Shared ReadOnly FontProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.LeaderFlatLengthProperty Field

WpfCalloutAnnotationLeaderFlatLengthProperty Field

Identifies the LeaderFlatLength dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LeaderFlatLengthProperty
Public Shared ReadOnly LeaderFlatLengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.LeaderProperty Field

WpfCalloutAnnotationLeaderProperty Field

Identifies the Leader dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LeaderProperty
Public Shared ReadOnly LeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.LineAlignmentProperty Field

WpfCalloutAnnotationLineAlignmentProperty Field

Identifies the LineAlignment dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineAlignmentProperty
Public Shared ReadOnly LineAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.PaddingProperty Field

WpfCalloutAnnotationPaddingProperty Field

Identifies the Padding dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingProperty
Public Shared ReadOnly PaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.TargetPositionProperty Field

WpfCalloutAnnotationTargetPositionProperty Field

Identifies the TargetPosition dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty TargetPositionProperty
Public Shared ReadOnly TargetPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfCalloutAnnotation.TextProperty Field

WpfCalloutAnnotationTextProperty Field

Identifies the Text dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfCalloutAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Class

This class is used to create an elliptical annotation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfEllipseAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfEllipseAnnotation : WpfAnnotationUI
Public Class WpfEllipseAnnotation
    Inherits WpfAnnotationUI

The WpfEllipseAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfEllipseAnnotation | Creates a new instance of WpfEllipseAnnotation using default values.
Public method | WpfEllipseAnnotation(EllipseData) | Creates a new instance of WpfEllipseAnnotation from an EllipseData object.
Public method | WpfEllipseAnnotation(Rect, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfEllipseAnnotation specifying its bounding rectangle, fill and outline.
Public method | WpfEllipseAnnotation(Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfEllipseAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Overrides WpfAnnotationUIHitTest(Point).)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfEllipseAnnotation | Creates a new instance of WpfEllipseAnnotation using default values.
Public method | WpfEllipseAnnotation(EllipseData) | Creates a new instance of WpfEllipseAnnotation from an EllipseData object.
Public method | WpfEllipseAnnotation(Rect, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfEllipseAnnotation specifying its bounding rectangle, fill and outline.
Public method | WpfEllipseAnnotation(Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfEllipseAnnotation specifying its properties.
Top
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Constructor

Creates a new instance of WpfEllipseAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEllipseAnnotation()
Public Sub New
See Also

Reference

WpfEllipseAnnotation Class
WpfEllipseAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Constructor (EllipseData)

Creates a new instance of WpfEllipseAnnotation from an EllipseData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEllipseAnnotation(
    EllipseData data
)
Public Sub New (
    data As EllipseData
)

Parameters

data
Type: Atalasoft.AnnotateEllipseData
The ellipse data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfEllipseAnnotation Class
WpfEllipseAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Constructor (Rect, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfEllipseAnnotation specifying its bounding rectangle, fill and outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEllipseAnnotation(
    Rect rectangle,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    rectangle As Rect,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.WindowsRect
The bounding rectangle of the ellipse in document space.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the annotation outline.
See Also

Reference

WpfEllipseAnnotation Class
WpfEllipseAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Constructor (Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, Point)

Creates a new instance of WpfEllipseAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEllipseAnnotation(
    Rect rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    rectangle As Rect,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

rectangle
Type: System.WindowsRect
The bounding rectangle of the ellipse in document space.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the annotation outline. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
The offset used for the shadow.
See Also

Reference

WpfEllipseAnnotation Class
WpfEllipseAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Properties

The WpfEllipseAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.Fill Property

WpfEllipseAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.Geometry Property

WpfEllipseAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.Outline Property

WpfEllipseAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.Shadow Property

WpfEllipseAnnotationShadow Property

Gets or sets the brush used for the annotation shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
Remarks
Set this property to null (Nothing in VB) to remove the shadow.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.ShadowOffset Property

WpfEllipseAnnotationShadowOffset Property

Gets or sets the offset used to position the shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The offset used to position the shadow.
Remarks
A negative value will move the shadow to up and to the left. Positive values will move the shadow down and to the right.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Methods

The WpfEllipseAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Overrides WpfAnnotationUIHitTest(Point).)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.CloneOverride Method

WpfEllipseAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.CreateDataSnapshotOverride Method

WpfEllipseAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation.HitTest Method

WpfEllipseAnnotationHitTest Method

This method will determine whether the specified point is on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool HitTest(
    Point dsPoint
)
Public Overrides Function HitTest (
    dsPoint As Point
) As Boolean

Parameters

dsPoint
Type: System.WindowsPoint
The point to hit test.

Return Value

Type: Boolean
True if the point is on the annotation.
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEllipseAnnotation Events

The WpfEllipseAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfEllipseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Class

This is an image annotation that will embed the image into the serialized XMP or WANG data.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfEmbeddedImageAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfEmbeddedImageAnnotation : WpfAnnotationUI,
    IDisposable
Public Class WpfEmbeddedImageAnnotation
    Inherits WpfAnnotationUI
    Implements IDisposable

The WpfEmbeddedImageAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfEmbeddedImageAnnotation | Creates a new instance of WpfEmbeddedImageAnnotation.
Public method | WpfEmbeddedImageAnnotation(EmbeddedImageData) | Creates a new instance of WpfEmbeddedImageAnnotation from an EmbeddedImageData object.
Public method | WpfEmbeddedImageAnnotation(AnnotationImage, Point, AnnotationBrush, Point) | Creates a new instance of WpfEmbeddedImageAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | Image | Gets or sets the image for the annotation.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | Source | Gets the BitmapSource for the annotation image.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the WpfEmbeddedImageAnnotation is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfEmbeddedImageAnnotation | Creates a new instance of WpfEmbeddedImageAnnotation.
Public method | WpfEmbeddedImageAnnotation(EmbeddedImageData) | Creates a new instance of WpfEmbeddedImageAnnotation from an EmbeddedImageData object.
Public method | WpfEmbeddedImageAnnotation(AnnotationImage, Point, AnnotationBrush, Point) | Creates a new instance of WpfEmbeddedImageAnnotation specifying its properties.
Top
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Constructor

Creates a new instance of WpfEmbeddedImageAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEmbeddedImageAnnotation()
Public Sub New
See Also

Reference

WpfEmbeddedImageAnnotation Class
WpfEmbeddedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Constructor (EmbeddedImageData)

Creates a new instance of WpfEmbeddedImageAnnotation from an EmbeddedImageData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEmbeddedImageAnnotation(
    EmbeddedImageData data
)
Public Sub New (
    data As EmbeddedImageData
)

Parameters

data
Type: Atalasoft.AnnotateEmbeddedImageData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfEmbeddedImageAnnotation Class
WpfEmbeddedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Constructor (AnnotationImage, Point, AnnotationBrush, Point)

Creates a new instance of WpfEmbeddedImageAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEmbeddedImageAnnotation(
    AnnotationImage image,
    Point location,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    image As AnnotationImage,
    location As Point,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The image for the annotation.
location
Type: System.WindowsPoint
The location of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
The offset of the shadow.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image argument is null (Nothing in VB).
See Also

Reference

WpfEmbeddedImageAnnotation Class
WpfEmbeddedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Properties

The WpfEmbeddedImageAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | Image | Gets or sets the image for the annotation.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | Source | Gets the BitmapSource for the annotation image.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Image Property

WpfEmbeddedImageAnnotationImage Property

Gets or sets the image for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationImage Image { get; set; }
Public Property Image As AnnotationImage
    Get
    Set

Property Value

Type: AnnotationImage
The image for the annotation.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Shadow Property

WpfEmbeddedImageAnnotationShadow Property

Gets or sets the brush used for the annotation shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
Remarks
Set this property to null (Nothing in VB) to remove the shadow.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.ShadowOffset Property

WpfEmbeddedImageAnnotationShadowOffset Property

Gets or sets the offset used to position the shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The offset used to position the shadow.
Remarks
A negative value will move the shadow to up and to the left. Positive values will move the shadow down and to the right.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Source Property

WpfEmbeddedImageAnnotationSource Property

Gets the BitmapSource for the annotation image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapSource Source { get; }
Public ReadOnly Property Source As BitmapSource
    Get

Property Value

Type: BitmapSource
The BitmapSource used to render the annotation.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Methods

The WpfEmbeddedImageAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the WpfEmbeddedImageAnnotation is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.CloneOverride Method

WpfEmbeddedImageAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.CreateDataSnapshotOverride Method

WpfEmbeddedImageAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Dispose Method

WpfEmbeddedImageAnnotationDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Top
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Dispose Method

WpfEmbeddedImageAnnotationDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

WpfEmbeddedImageAnnotation Class
Dispose Overload
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Dispose Method (Boolean)

WpfEmbeddedImageAnnotationDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

WpfEmbeddedImageAnnotation Class
Dispose Overload
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation.Finalize Method

WpfEmbeddedImageAnnotationFinalize Method

Releases unmanaged resources and performs other cleanup operations before the WpfEmbeddedImageAnnotation is reclaimed by garbage collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfEmbeddedImageAnnotation Events

The WpfEmbeddedImageAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfEmbeddedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Class

This class is used for a freehand annotation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfPointBaseAnnotation
Atalasoft.Annotate.WpfWpfFreehandAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfFreehandAnnotation : WpfPointBaseAnnotation
Public Class WpfFreehandAnnotation
    Inherits WpfPointBaseAnnotation

The WpfFreehandAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfFreehandAnnotation | Creates a new instance of WpfFreehandAnnotation.
Public method | WpfFreehandAnnotation(FreehandData) | Creates a new instance of WpfFreehandAnnotation from a FreehandData object.
Public method | WpfFreehandAnnotation(AnnotationPen, WpfFreehandLineType, Boolean) | Creates a new WpfFreehandAnnotation specifying its outline, line type and whether or not to close the shape.
Public method | WpfFreehandAnnotation(AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean) | Creates a new instance of WpfFreehandAnnotation specifying its fill, outline and line type.
Public method | WpfFreehandAnnotation(Point, AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean) | Creates a new instance of WpfFreehandAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsClosed | Gets or sets a value indicating whether the shape is closed.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | LineType | Gets or sets the line type used to connect the points.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
IsClosedProperty | Identifies the IsClosed dependency property.
LineTypeProperty | Identifies the LineType dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfFreehandAnnotation | Creates a new instance of WpfFreehandAnnotation.
Public method | WpfFreehandAnnotation(FreehandData) | Creates a new instance of WpfFreehandAnnotation from a FreehandData object.
Public method | WpfFreehandAnnotation(AnnotationPen, WpfFreehandLineType, Boolean) | Creates a new WpfFreehandAnnotation specifying its outline, line type and whether or not to close the shape.
Public method | WpfFreehandAnnotation(AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean) | Creates a new instance of WpfFreehandAnnotation specifying its fill, outline and line type.
Public method | WpfFreehandAnnotation(Point, AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean) | Creates a new instance of WpfFreehandAnnotation specifying its properties.
Top
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Constructor

Creates a new instance of WpfFreehandAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandAnnotation()
Public Sub New
See Also

Reference

WpfFreehandAnnotation Class
WpfFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Constructor (FreehandData)

Creates a new instance of WpfFreehandAnnotation from a FreehandData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandAnnotation(
    FreehandData data
)
Public Sub New (
    data As FreehandData
)

Parameters

data
Type: Atalasoft.AnnotateFreehandData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfFreehandAnnotation Class
WpfFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Constructor (AnnotationPen, WpfFreehandLineType, Boolean)

Creates a new WpfFreehandAnnotation specifying its outline, line type and whether or not to close the shape.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandAnnotation(
    AnnotationPen outline,
    WpfFreehandLineType lineType,
    bool isClosed
)
Public Sub New (
    outline As AnnotationPen,
    lineType As WpfFreehandLineType,
    isClosed As Boolean
)

Parameters

outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the freehand line. This can be null (Nothing in VB).
lineType
Type: Atalasoft.Annotate.WpfWpfFreehandLineType
The line type used to connect the points.
isClosed
Type: SystemBoolean
Indicates whether the freehand will be closed.
See Also

Reference

WpfFreehandAnnotation Class
WpfFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Constructor (AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean)

Creates a new instance of WpfFreehandAnnotation specifying its fill, outline and line type.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    WpfFreehandLineType lineType,
    bool isClosed
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    lineType As WpfFreehandLineType,
    isClosed As Boolean
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the freehand when IsClose is true. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the freehand line. This can be null (Nothing in VB).
lineType
Type: Atalasoft.Annotate.WpfWpfFreehandLineType
The line type used to connect the points.
isClosed
Type: SystemBoolean
Indicates whether the freehand will be closed.
See Also

Reference

WpfFreehandAnnotation Class
WpfFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Constructor (Point[], AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean)

WpfFreehandAnnotation Constructor (Point, AnnotationBrush, AnnotationPen, WpfFreehandLineType, Boolean)

Creates a new instance of WpfFreehandAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandAnnotation(
    Point[] points,
    AnnotationBrush fill,
    AnnotationPen outline,
    WpfFreehandLineType lineType,
    bool isClosed
)
Public Sub New (
    points As Point(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    lineType As WpfFreehandLineType,
    isClosed As Boolean
)

Parameters

points
Type: System.WindowsPoint
The points for the freehand lines.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the freehand when IsClose is true. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the freehand line. This can be null (Nothing in VB).
lineType
Type: Atalasoft.Annotate.WpfWpfFreehandLineType
The line type used to connect the points.
isClosed
Type: SystemBoolean
Indicates whether the freehand will be closed.
See Also

Reference

WpfFreehandAnnotation Class
WpfFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Properties

The WpfFreehandAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsClosed | Gets or sets a value indicating whether the shape is closed.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | LineType | Gets or sets the line type used to connect the points.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.Fill Property

WpfFreehandAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.Geometry Property

WpfFreehandAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.IsClosed Property

WpfFreehandAnnotationIsClosed Property

Gets or sets a value indicating whether the shape is closed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the shape is closed.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.LineType Property

WpfFreehandAnnotationLineType Property

Gets or sets the line type used to connect the points.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandLineType LineType { get; set; }
Public Property LineType As WpfFreehandLineType
    Get
    Set

Property Value

Type: WpfFreehandLineType
The line type used to connect the points.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.Outline Property

WpfFreehandAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Methods

The WpfFreehandAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.CloneOverride Method

WpfFreehandAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.CreateDataSnapshotOverride Method

WpfFreehandAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Events

The WpfFreehandAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation Fields

The WpfFreehandAnnotation type exposes the following members.

Fields
Name | Description
IsClosedProperty | Identifies the IsClosed dependency property.
LineTypeProperty | Identifies the LineType dependency property.
Top
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.IsClosedProperty Field

WpfFreehandAnnotationIsClosedProperty Field

Identifies the IsClosed dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsClosedProperty
Public Shared ReadOnly IsClosedProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandAnnotation.LineTypeProperty Field

WpfFreehandAnnotationLineTypeProperty Field

Identifies the LineType dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineTypeProperty
Public Shared ReadOnly LineTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfFreehandLineType Enumeration

Indicates the freehand line style.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfFreehandLineType
Public Enumeration WpfFreehandLineType
Members
Member name | Description
Straight | The points are joined with straight lines.
Bezier | The points are used for bezier curves.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfGripHotZoneAction Enumeration

Indicates the action for a zone grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfGripHotZoneAction
Public Enumeration WpfGripHotZoneAction
Members
Member name | Description
Default | The default grip action is performed.
Ignore | No action should be taken.
MoveAnnotation | The annotation should be moved.
MoveGrip | The grip should be moved.
RotateAnnotation | The annotation should be rotated.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Class

This annotations can be used to add rectangular hot spots on a document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked. For a non-rectangular area use the WpfHotSpotFreehandAnnotation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfHotSpotAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfHotSpotAnnotation : WpfAnnotationUI
Public Class WpfHotSpotAnnotation
    Inherits WpfAnnotationUI

The WpfHotSpotAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfHotSpotAnnotation | Creates a new instance of WpfHotSpotAnnotation with default values.
Public method | WpfHotSpotAnnotation(HotSpotData) | Creates a new instance of WpfHotSpotAnnotation from a HotSpotData object.
Public method | WpfHotSpotAnnotation(AnnotationBrush, AnnotationPen) | Creates a new intance of WpfHotSpotAnnotation specifying its fill and outline.
Public method | WpfHotSpotAnnotation(Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfHotSpotAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the annotation is currently active.
Public property | ActiveFill | Gets or sets the brush used to fill the annotation when Active is true.
Public property | ActiveOutline | Gets or sets the pen used to render the outline when Active is true.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
ActiveFillProperty | Identifies the ActiveFill dependency property.
ActiveOutlineProperty | Identifies the ActiveOutline dependency property.
ActiveProperty | Identifies the Active dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfHotSpotAnnotation | Creates a new instance of WpfHotSpotAnnotation with default values.
Public method | WpfHotSpotAnnotation(HotSpotData) | Creates a new instance of WpfHotSpotAnnotation from a HotSpotData object.
Public method | WpfHotSpotAnnotation(AnnotationBrush, AnnotationPen) | Creates a new intance of WpfHotSpotAnnotation specifying its fill and outline.
Public method | WpfHotSpotAnnotation(Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfHotSpotAnnotation specifying its properties.
Top
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Constructor

Creates a new instance of WpfHotSpotAnnotation with default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotAnnotation()
Public Sub New
See Also

Reference

WpfHotSpotAnnotation Class
WpfHotSpotAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Constructor (HotSpotData)

Creates a new instance of WpfHotSpotAnnotation from a HotSpotData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotAnnotation(
    HotSpotData data
)
Public Sub New (
    data As HotSpotData
)

Parameters

data
Type: Atalasoft.AnnotateHotSpotData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfHotSpotAnnotation Class
WpfHotSpotAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Constructor (AnnotationBrush, AnnotationPen)

Creates a new intance of WpfHotSpotAnnotation specifying its fill and outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the annotation outline.
See Also

Reference

WpfHotSpotAnnotation Class
WpfHotSpotAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Constructor (Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfHotSpotAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotAnnotation(
    Rect rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush activeFill,
    AnnotationPen activeOutline
)
Public Sub New (
    rectangle As Rect,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    activeFill As AnnotationBrush,
    activeOutline As AnnotationPen
)

Parameters

rectangle
Type: System.WindowsRect
The bounding rectangle for the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the annotation outline.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation when its Active property is true.
activeOutline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for render the outline when its Active property is true.
See Also

Reference

WpfHotSpotAnnotation Class
WpfHotSpotAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Properties

The WpfHotSpotAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the annotation is currently active.
Public property | ActiveFill | Gets or sets the brush used to fill the annotation when Active is true.
Public property | ActiveOutline | Gets or sets the pen used to render the outline when Active is true.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.Active Property

WpfHotSpotAnnotationActive Property

Gets or sets a value indicating whether the annotation is currently active.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation is active.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.ActiveFill Property

WpfHotSpotAnnotationActiveFill Property

Gets or sets the brush used to fill the annotation when Active is true.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush ActiveFill { get; set; }
Public Property ActiveFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation when Active is true.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.ActiveOutline Property

WpfHotSpotAnnotationActiveOutline Property

Gets or sets the pen used to render the outline when Active is true.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen ActiveOutline { get; set; }
Public Property ActiveOutline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used to render the outline when Active is true.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.Fill Property

WpfHotSpotAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.Outline Property

WpfHotSpotAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Methods

The WpfHotSpotAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.CloneOverride Method

WpfHotSpotAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.CreateDataSnapshotOverride Method

WpfHotSpotAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Events

The WpfHotSpotAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation Fields

The WpfHotSpotAnnotation type exposes the following members.

Fields
Name | Description
ActiveFillProperty | Identifies the ActiveFill dependency property.
ActiveOutlineProperty | Identifies the ActiveOutline dependency property.
ActiveProperty | Identifies the Active dependency property.
Top
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.ActiveFillProperty Field

WpfHotSpotAnnotationActiveFillProperty Field

Identifies the ActiveFill dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveFillProperty
Public Shared ReadOnly ActiveFillProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.ActiveOutlineProperty Field

WpfHotSpotAnnotationActiveOutlineProperty Field

Identifies the ActiveOutline dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveOutlineProperty
Public Shared ReadOnly ActiveOutlineProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotAnnotation.ActiveProperty Field

WpfHotSpotAnnotationActiveProperty Field

Identifies the Active dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveProperty
Public Shared ReadOnly ActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfHotSpotAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Class

This annotation can be used to create a freehand hot spot area on the document. When the InteractMode is set to View the hot spot annotations will be invisible but the cursor will change when hovering over it to indicate that area can be clicked. For a rectangular hot spot use the WpfHotSpotAnnotation.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfPointBaseAnnotation
Atalasoft.Annotate.WpfWpfHotSpotFreehandAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfHotSpotFreehandAnnotation : WpfPointBaseAnnotation
Public Class WpfHotSpotFreehandAnnotation
    Inherits WpfPointBaseAnnotation

The WpfHotSpotFreehandAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfHotSpotFreehandAnnotation | Creates a new instance of WpfHotSpotFreehandAnnotation using default values.
Public method | WpfHotSpotFreehandAnnotation(HotSpotFreehandData) | Creates a new instance of WpfHotSpotFreehandAnnotation from an HotSpotFreehandData object.
Public method | WpfHotSpotFreehandAnnotation(AnnotationBrush, WpfFreehandLineType) | Creates a new instance of WpfHotSpotFreehandAnnotation specifying the fill and line type.
Public method | WpfHotSpotFreehandAnnotation(Point, AnnotationBrush, AnnotationBrush, WpfFreehandLineType) | Creates a new instance of WpfHotSpotFreehandAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the annotation is active.
Public property | ActiveFill | Gets or sets the brush used to fill the annotation when Active is true.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | LineType | Gets or sets the line type used to connection the points.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
ActiveFillProperty | Identifies the ActiveFill dependency property.
ActiveProperty | Identifies the Active dependency property.
LineTypeProperty | Identifies the LineType dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfHotSpotFreehandAnnotation | Creates a new instance of WpfHotSpotFreehandAnnotation using default values.
Public method | WpfHotSpotFreehandAnnotation(HotSpotFreehandData) | Creates a new instance of WpfHotSpotFreehandAnnotation from an HotSpotFreehandData object.
Public method | WpfHotSpotFreehandAnnotation(AnnotationBrush, WpfFreehandLineType) | Creates a new instance of WpfHotSpotFreehandAnnotation specifying the fill and line type.
Public method | WpfHotSpotFreehandAnnotation(Point, AnnotationBrush, AnnotationBrush, WpfFreehandLineType) | Creates a new instance of WpfHotSpotFreehandAnnotation specifying its properties.
Top
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Constructor

Creates a new instance of WpfHotSpotFreehandAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotFreehandAnnotation()
Public Sub New
See Also

Reference

WpfHotSpotFreehandAnnotation Class
WpfHotSpotFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Constructor (HotSpotFreehandData)

Creates a new instance of WpfHotSpotFreehandAnnotation from an HotSpotFreehandData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotFreehandAnnotation(
    HotSpotFreehandData data
)
Public Sub New (
    data As HotSpotFreehandData
)

Parameters

data
Type: Atalasoft.AnnotateHotSpotFreehandData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfHotSpotFreehandAnnotation Class
WpfHotSpotFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Constructor (AnnotationBrush, WpfFreehandLineType)

Creates a new instance of WpfHotSpotFreehandAnnotation specifying the fill and line type.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotFreehandAnnotation(
    AnnotationBrush fill,
    WpfFreehandLineType lineType
)
Public Sub New (
    fill As AnnotationBrush,
    lineType As WpfFreehandLineType
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
lineType
Type: Atalasoft.Annotate.WpfWpfFreehandLineType
The line type used to connect the points.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
WpfHotSpotFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Constructor (Point[], AnnotationBrush, AnnotationBrush, WpfFreehandLineType)

WpfHotSpotFreehandAnnotation Constructor (Point, AnnotationBrush, AnnotationBrush, WpfFreehandLineType)

Creates a new instance of WpfHotSpotFreehandAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotFreehandAnnotation(
    Point[] points,
    AnnotationBrush fill,
    AnnotationBrush activeFill,
    WpfFreehandLineType lineType
)
Public Sub New (
    points As Point(),
    fill As AnnotationBrush,
    activeFill As AnnotationBrush,
    lineType As WpfFreehandLineType
)

Parameters

points
Type: System.WindowsPoint
The points of the freehand line.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
activeFill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation when its Active property is true.
lineType
Type: Atalasoft.Annotate.WpfWpfFreehandLineType
The line type used to connect the points.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
WpfHotSpotFreehandAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Properties

The WpfHotSpotFreehandAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the annotation is active.
Public property | ActiveFill | Gets or sets the brush used to fill the annotation when Active is true.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | LineType | Gets or sets the line type used to connection the points.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.Active Property

WpfHotSpotFreehandAnnotationActive Property

Gets or sets a value indicating whether the annotation is active.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the annotation is active.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.ActiveFill Property

WpfHotSpotFreehandAnnotationActiveFill Property

Gets or sets the brush used to fill the annotation when Active is true.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush ActiveFill { get; set; }
Public Property ActiveFill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation when Active is true.
Remarks
Set this property to null (Nothing in VB) to remove the active fill.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.Fill Property

WpfHotSpotFreehandAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.Geometry Property

WpfHotSpotFreehandAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.LineType Property

WpfHotSpotFreehandAnnotationLineType Property

Gets or sets the line type used to connection the points.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandLineType LineType { get; set; }
Public Property LineType As WpfFreehandLineType
    Get
    Set

Property Value

Type: WpfFreehandLineType
The line type used to connection the points.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Methods

The WpfHotSpotFreehandAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.CloneOverride Method

WpfHotSpotFreehandAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.CreateDataSnapshotOverride Method

WpfHotSpotFreehandAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Events

The WpfHotSpotFreehandAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation Fields

The WpfHotSpotFreehandAnnotation type exposes the following members.

Fields
Name | Description
ActiveFillProperty | Identifies the ActiveFill dependency property.
ActiveProperty | Identifies the Active dependency property.
LineTypeProperty | Identifies the LineType dependency property.
Top
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.ActiveFillProperty Field

WpfHotSpotFreehandAnnotationActiveFillProperty Field

Identifies the ActiveFill dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveFillProperty
Public Shared ReadOnly ActiveFillProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.ActiveProperty Field

WpfHotSpotFreehandAnnotationActiveProperty Field

Identifies the Active dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveProperty
Public Shared ReadOnly ActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfHotSpotFreehandAnnotation.LineTypeProperty Field

WpfHotSpotFreehandAnnotationLineTypeProperty Field

Identifies the LineType dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineTypeProperty
Public Shared ReadOnly LineTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfHotSpotFreehandAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Class

A WpfLayerAnnotation is a collection of other annotations, including other WpfLayerAnnotation objects.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfLayerAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLayerAnnotation : WpfAnnotationUI
Public Class WpfLayerAnnotation
    Inherits WpfAnnotationUI

The WpfLayerAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLayerAnnotation | Creates a new instance of WpfLayerAnnotation.
Public method | WpfLayerAnnotation(LayerData) | Creates a new instance of WpfLayerAnnotation from a LayerData object.
Public method | WpfLayerAnnotation(WpfAnnotationUICollection, Boolean) | Creates a new instance of WpfLayerAnnotation using the annotations in the provided WpfAnnotationUICollection.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGroup | Gets a value indicating whether this layer is a group annotation.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Items | Gets a WpfAnnotationUICollection containing the annotations for this layer.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AnnotationFromPoint | Returns the annotation located at the specified point in document space.
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateAnnotationUIObjects | This method is used to generate WpfAnnotationUI objects for each AnnotationData object. The only time this method should be called is when the WpfLayerAnnotation is created by passing in a LayerData object to its constructor.
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Overrides WpfAnnotationUIHitTest(Point).)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Overrides WpfAnnotationUIOnCanvasChanged(ValueChangedEventArgsWpfAnnotationCanvas).)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfLayerAnnotation | Creates a new instance of WpfLayerAnnotation.
Public method | WpfLayerAnnotation(LayerData) | Creates a new instance of WpfLayerAnnotation from a LayerData object.
Public method | WpfLayerAnnotation(WpfAnnotationUICollection, Boolean) | Creates a new instance of WpfLayerAnnotation using the annotations in the provided WpfAnnotationUICollection.
Top
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Constructor

Creates a new instance of WpfLayerAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation()
Public Sub New
See Also

Reference

WpfLayerAnnotation Class
WpfLayerAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Constructor (LayerData)

Creates a new instance of WpfLayerAnnotation from a LayerData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation(
    LayerData data
)
Public Sub New (
    data As LayerData
)

Parameters

data
Type: Atalasoft.AnnotateLayerData
The LayerData object for this annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfLayerAnnotation Class
WpfLayerAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Constructor (WpfAnnotationUICollection, Boolean)

Creates a new instance of WpfLayerAnnotation using the annotations in the provided WpfAnnotationUICollection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation(
    WpfAnnotationUICollection annotations,
    bool isGroup
)
Public Sub New (
    annotations As WpfAnnotationUICollection,
    isGroup As Boolean
)

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfAnnotationUICollection
The WpfAnnotationUICollection that will be used by this layer.
isGroup
Type: SystemBoolean
A value indicating whether this layer is a group annotation.
See Also

Reference

WpfLayerAnnotation Class
WpfLayerAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Properties

The WpfLayerAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGroup | Gets a value indicating whether this layer is a group annotation.
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Items | Gets a WpfAnnotationUICollection containing the annotations for this layer.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.Geometry Property

WpfLayerAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.IsGroup Property

WpfLayerAnnotationIsGroup Property

Gets a value indicating whether this layer is a group annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsGroup { get; }
Public ReadOnly Property IsGroup As Boolean
    Get

Property Value

Type: Boolean
Indicates if this layer is a group annotation.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.Items Property

WpfLayerAnnotationItems Property

Gets a WpfAnnotationUICollection containing the annotations for this layer.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUICollection Items { get; }
Public ReadOnly Property Items As WpfAnnotationUICollection
    Get

Property Value

Type: WpfAnnotationUICollection
A WpfAnnotationUICollection for this layer.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Methods

The WpfLayerAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AnnotationFromPoint | Returns the annotation located at the specified point in document space.
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateAnnotationUIObjects | This method is used to generate WpfAnnotationUI objects for each AnnotationData object. The only time this method should be called is when the WpfLayerAnnotation is created by passing in a LayerData object to its constructor.
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Overrides WpfAnnotationUIHitTest(Point).)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Overrides WpfAnnotationUIOnCanvasChanged(ValueChangedEventArgsWpfAnnotationCanvas).)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.AnnotationFromPoint Method

WpfLayerAnnotationAnnotationFromPoint Method

Returns the annotation located at the specified point in document space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationUI AnnotationFromPoint(
    Point dsPoint
)
Public Function AnnotationFromPoint (
    dsPoint As Point
) As WpfAnnotationUI

Parameters

dsPoint
Type: System.WindowsPoint
The point to look at in document space.

Return Value

Type: WpfAnnotationUI
The annotation found at the point or null (Nothing in VB) of there is no annotation at that position.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.CloneOverride Method

WpfLayerAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.CreateAnnotationUIObjects Method

WpfLayerAnnotationCreateAnnotationUIObjects Method

This method is used to generate WpfAnnotationUI objects for each AnnotationData object. The only time this method should be called is when the WpfLayerAnnotation is created by passing in a LayerData object to its constructor.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CreateAnnotationUIObjects(
    WpfAnnotationUIFactoryCollection factories
)
Public Sub CreateAnnotationUIObjects (
    factories As WpfAnnotationUIFactoryCollection
)

Parameters

factories
Type: Atalasoft.Annotate.WpfWpfAnnotationUIFactoryCollection
The factories used to create the WpfAnnotationUI objects.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.CreateDataSnapshotOverride Method

WpfLayerAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.HitTest Method

WpfLayerAnnotationHitTest Method

This method will determine whether the specified point is on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool HitTest(
    Point dsPoint
)
Public Overrides Function HitTest (
    dsPoint As Point
) As Boolean

Parameters

dsPoint
Type: System.WindowsPoint
The point to hit test.

Return Value

Type: Boolean
True if the point is on the annotation.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.OnCanvasChanged Method

WpfLayerAnnotationOnCanvasChanged Method

Called when the Canvas property has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnCanvasChanged(
    ValueChangedEventArgs<WpfAnnotationCanvas> e
)
Protected Overrides Sub OnCanvasChanged (
    e As ValueChangedEventArgs(Of WpfAnnotationCanvas)
)

Parameters

e
Type: Atalasoft.Annotate.WpfValueChangedEventArgs WpfAnnotationCanvas
An EventArgs for this change.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation.OnPropertyChanged Method

WpfLayerAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotation Events

The WpfLayerAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfLayerAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator Class

This class is used to enumerate the WpfLayerCollection.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfLayerAnnotationEnumerator

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLayerAnnotationEnumerator : IEnumerator
Public Class WpfLayerAnnotationEnumerator
    Implements IEnumerator

The WpfLayerAnnotationEnumerator type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLayerAnnotationEnumerator | Creates a new instance of WpfLayerAnnotationEnumerator.
Top
Properties
 | Name | Description
Public property | Current | Gets the current element in the collection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves to the next item. The first time this method is used, or after Reset has been called, the Current item will be set to the first item in the enumeration.
Public method | Reset | Resets the enumeration position to before the first item. MoveNext must be called to move to the first item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator Constructor

Creates a new instance of WpfLayerAnnotationEnumerator.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotationEnumerator(
    WpfLayerAnnotation[] annotations
)
Public Sub New (
    annotations As WpfLayerAnnotation()
)

Parameters

annotations
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
An array of annotation to enumerate.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotations argument was null (Nothing in VB).
See Also

Reference

WpfLayerAnnotationEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator Properties

The WpfLayerAnnotationEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current element in the collection.
Top
See Also

Reference

WpfLayerAnnotationEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator.Current Property

WpfLayerAnnotationEnumeratorCurrent Property

Gets the current element in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation Current { get; }
Public ReadOnly Property Current As WpfLayerAnnotation
    Get

Return Value

Type: WpfLayerAnnotation
The current element in the collection.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element.
See Also

Reference

WpfLayerAnnotationEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator Methods

The WpfLayerAnnotationEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves to the next item. The first time this method is used, or after Reset has been called, the Current item will be set to the first item in the enumeration.
Public method | Reset | Resets the enumeration position to before the first item. MoveNext must be called to move to the first item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfLayerAnnotationEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator.MoveNext Method

WpfLayerAnnotationEnumeratorMoveNext Method

Moves to the next item. The first time this method is used, or after Reset has been called, the Current item will be set to the first item in the enumeration.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MoveNext()
Public Function MoveNext As Boolean

Return Value

Type: Boolean
True on success; False if there are no more items.

Implements

IEnumeratorMoveNext
See Also

Reference

WpfLayerAnnotationEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerAnnotationEnumerator.Reset Method

WpfLayerAnnotationEnumeratorReset Method

Resets the enumeration position to before the first item. MoveNext must be called to move to the first item.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset

Implements

IEnumeratorReset
See Also

Reference

WpfLayerAnnotationEnumerator Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection Class

This class holds a collection of WpfLayerAnnotation objects, each containing the visible annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfLayerCollection

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLayerCollection : ICollection<WpfLayerAnnotation>,
    IEnumerable<WpfLayerAnnotation>, IEnumerable
Public Class WpfLayerCollection
    Implements ICollection(Of WpfLayerAnnotation), IEnumerable(Of WpfLayerAnnotation),
    IEnumerable

The WpfLayerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLayerCollection | Creates a new instance of WpfLayerCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of layers in the collection.
Public property | IsReadOnly | Gets a value indicating whether this collection is read-only.
Public property | Item | Gets the layer at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds a layer to the collection.
Public method | AddRange | Adds an array of layers to the collection.
Public method | AsReadOnly | Returns a read-only collection of the layers.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether an element is in the collection.
Public method | CopyTo | Copies the entire collection into the array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the collection index of the specified WpfLayerAnnotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Called when there has been a change in the collection.
Public method | Remove | Removes a layer from the collection.
Public method | RemoveAt | Removes a layer at the specified index.
Public method | ToArray | Returns an array of all WpfLayerAnnotation items in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | This event is raised when there has been a changed in the collection.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection Constructor

Creates a new instance of WpfLayerCollection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerCollection()
Public Sub New
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection Properties

The WpfLayerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of layers in the collection.
Public property | IsReadOnly | Gets a value indicating whether this collection is read-only.
Public property | Item | Gets the layer at the specified index.
Top
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.Count Property

WpfLayerCollectionCount Property

Gets the number of layers in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of layers in the collection.

Implements

ICollectionTCount
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.IsReadOnly Property

WpfLayerCollectionIsReadOnly Property

Gets a value indicating whether this collection is read-only.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the collection is read-only.

Implements

ICollectionTIsReadOnly
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.Item Property

WpfLayerCollectionItem Property

Gets the layer at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As WpfLayerAnnotation
    Get

Parameters

index
Type: SystemInt32
The index of the layer to retrieve.

Return Value

Type: WpfLayerAnnotation
The layer at the specified index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection Methods

The WpfLayerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a layer to the collection.
Public method | AddRange | Adds an array of layers to the collection.
Public method | AsReadOnly | Returns a read-only collection of the layers.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether an element is in the collection.
Public method | CopyTo | Copies the entire collection into the array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the collection index of the specified WpfLayerAnnotation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Called when there has been a change in the collection.
Public method | Remove | Removes a layer from the collection.
Public method | RemoveAt | Removes a layer at the specified index.
Public method | ToArray | Returns an array of all WpfLayerAnnotation items in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.Add Method

WpfLayerCollectionAdd Method

Adds a layer to the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    WpfLayerAnnotation item
)
Public Sub Add (
    item As WpfLayerAnnotation
)

Parameters

item
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to add.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the item argument is null (Nothing in VB).
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.AddRange Method

WpfLayerCollectionAddRange Method

Adds an array of layers to the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    WpfLayerAnnotation[] layers
)
Public Sub AddRange (
    layers As WpfLayerAnnotation()
)

Parameters

layers
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The array of layers to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layers argument is null (Nothing in VB).
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.AsReadOnly Method

WpfLayerCollectionAsReadOnly Method

Returns a read-only collection of the layers.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerCollection AsReadOnly()
Public Function AsReadOnly As WpfLayerCollection

Return Value

Type: WpfLayerCollection
A read-only collection of layers.
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.Clear Method

WpfLayerCollectionClear Method

Removes all items from the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.Contains Method

WpfLayerCollectionContains Method

Determines whether an element is in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    WpfLayerAnnotation item
)
Public Function Contains (
    item As WpfLayerAnnotation
) As Boolean

Parameters

item
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to search for.

Return Value

Type: Boolean
True if the layer is within the collection.

Implements

ICollectionTContains(T)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the item argument is null (Nothing in VB).
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.CopyTo Method

WpfLayerCollectionCopyTo Method

Copies the entire collection into the array, starting at the specified index of the target array.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    WpfLayerAnnotation[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As WpfLayerAnnotation(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The array of copy items into.
arrayIndex
Type: SystemInt32
The index in the array at which to begin.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the array is null (Nothing in VB).
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.GetEnumerator Method

WpfLayerCollectionGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<WpfLayerAnnotation> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of WpfLayerAnnotation)

Return Value

Type: IEnumerator WpfLayerAnnotation
An enumerator for the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.IndexOf Method

WpfLayerCollectionIndexOf Method

Returns the collection index of the specified WpfLayerAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    WpfLayerAnnotation layer
)
Public Function IndexOf (
    layer As WpfLayerAnnotation
) As Integer

Parameters

layer
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer or search for.

Return Value

Type: Int32
The index of the layer or -1 if the layer is not contained within this collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the layer argument is null (Nothing in VB).
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.OnCollectionChanged Method

WpfLayerCollectionOnCollectionChanged Method

Called when there has been a change in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCollectionChanged(
    CollectionChangedEventArgs<WpfLayerAnnotation> e
)
Protected Overridable Sub OnCollectionChanged (
    e As CollectionChangedEventArgs(Of WpfLayerAnnotation)
)

Parameters

e
Type: Atalasoft.Annotate.WpfCollectionChangedEventArgs WpfLayerAnnotation
A CollectionChangedEventArgs containing information about the change.
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.Remove Method

WpfLayerCollectionRemove Method

Removes a layer from the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    WpfLayerAnnotation item
)
Public Function Remove (
    item As WpfLayerAnnotation
) As Boolean

Parameters

item
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The layer to remove.

Return Value

Type: Boolean
True if the remove was a success.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the item argument is null (Nothing in VB).
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.RemoveAt Method

WpfLayerCollectionRemoveAt Method

Removes a layer at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the layer to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.ToArray Method

WpfLayerCollectionToArray Method

Returns an array of all WpfLayerAnnotation items in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotation[] ToArray()
Public Function ToArray As WpfLayerAnnotation()

Return Value

Type: WpfLayerAnnotation
An array of WpfLayerAnnotation or an empty array if the collection is empty.
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection Events

The WpfLayerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | This event is raised when there has been a changed in the collection.
Top
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLayerCollection.CollectionChanged Event

WpfLayerCollectionCollectionChanged Event

This event is raised when there has been a changed in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangedEventArgs<WpfLayerAnnotation>> CollectionChanged
Public Event CollectionChanged As EventHandler(Of CollectionChangedEventArgs(Of WpfLayerAnnotation))

Value

Type: SystemEventHandler CollectionChangedEventArgs WpfLayerAnnotation
See Also

Reference

WpfLayerCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Class

This is a single line annotation from StartPoint to EndPoint.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfLineAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLineAnnotation : WpfAnnotationUI
Public Class WpfLineAnnotation
    Inherits WpfAnnotationUI

The WpfLineAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLineAnnotation | Creates a new instance of WpfLineAnnotation.
Public method | WpfLineAnnotation(LineData) | Creates a new instance of WpfLineAnnotation from an LineData object.
Public method | WpfLineAnnotation(Point, Point, AnnotationPen) | Creates a new instance of WpfLineAnnotation specifying the start point, end point and outline.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndPoint | Gets or sets the end point of the line in annotation space.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the line.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | StartPoint | Gets or sets the start point of the line in annotation space.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
EndPointProperty | Identifies the EndPoint dependency property.
StartPointProperty | Identifies the StartPoint dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfLineAnnotation | Creates a new instance of WpfLineAnnotation.
Public method | WpfLineAnnotation(LineData) | Creates a new instance of WpfLineAnnotation from an LineData object.
Public method | WpfLineAnnotation(Point, Point, AnnotationPen) | Creates a new instance of WpfLineAnnotation specifying the start point, end point and outline.
Top
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Constructor

Creates a new instance of WpfLineAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLineAnnotation()
Public Sub New
See Also

Reference

WpfLineAnnotation Class
WpfLineAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Constructor (LineData)

Creates a new instance of WpfLineAnnotation from an LineData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLineAnnotation(
    LineData data
)
Public Sub New (
    data As LineData
)

Parameters

data
Type: Atalasoft.AnnotateLineData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfLineAnnotation Class
WpfLineAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Constructor (Point, Point, AnnotationPen)

Creates a new instance of WpfLineAnnotation specifying the start point, end point and outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLineAnnotation(
    Point startPoint,
    Point endPoint,
    AnnotationPen outline
)
Public Sub New (
    startPoint As Point,
    endPoint As Point,
    outline As AnnotationPen
)

Parameters

startPoint
Type: System.WindowsPoint
The start point of the line in annotation space.
endPoint
Type: System.WindowsPoint
The end point of the line in annotation space.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the line.
See Also

Reference

WpfLineAnnotation Class
WpfLineAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Properties

The WpfLineAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EndPoint | Gets or sets the end point of the line in annotation space.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the line.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | StartPoint | Gets or sets the start point of the line in annotation space.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.EndPoint Property

WpfLineAnnotationEndPoint Property

Gets or sets the end point of the line in annotation space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point EndPoint { get; set; }
Public Property EndPoint As Point
    Get
    Set

Property Value

Type: Point
The end point of the line in annotation space.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.Geometry Property

WpfLineAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.Outline Property

WpfLineAnnotationOutline Property

Gets or sets the pen used to draw the line.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used to draw the line.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.StartPoint Property

WpfLineAnnotationStartPoint Property

Gets or sets the start point of the line in annotation space.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point StartPoint { get; set; }
Public Property StartPoint As Point
    Get
    Set

Property Value

Type: Point
The start point of the line in annotation space.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.SupportsMultiClickCreation Property

WpfLineAnnotationSupportsMultiClickCreation Property

Gets a value indicating whether the annotation supports being created from multiple mouse clicks.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool SupportsMultiClickCreation { get; }
Public Overrides ReadOnly Property SupportsMultiClickCreation As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation supports being created from multiple mouse clicks.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Methods

The WpfLineAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.AttachGripsOverride Method

WpfLineAnnotationAttachGripsOverride Method

Called when the annotation grips need to be created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationGrips AttachGripsOverride(
    WpfAnnotationCanvas canvas
)
Protected Overrides Function AttachGripsOverride (
    canvas As WpfAnnotationCanvas
) As WpfAnnotationGrips

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.

Return Value

Type: WpfAnnotationGrips
The grips for the annotation.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.CloneOverride Method

WpfLineAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.CreateDataSnapshotOverride Method

WpfLineAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.OnGripPositionChanged Method

WpfLineAnnotationOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overrides Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.OnMouseDown Method

WpfLineAnnotationOnMouseDown Method

Called when a MouseDown event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs for the event.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.OnMouseMove Method

WpfLineAnnotationOnMouseMove Method

Called when a MouseMove event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for the event.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.OnMouseUp Method

WpfLineAnnotationOnMouseUp Method

Called when a MouseUp event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for the event.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.OnPropertyChanged Method

WpfLineAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Events

The WpfLineAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation Fields

The WpfLineAnnotation type exposes the following members.

Fields
Name | Description
EndPointProperty | Identifies the EndPoint dependency property.
StartPointProperty | Identifies the StartPoint dependency property.
Top
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.EndPointProperty Field

WpfLineAnnotationEndPointProperty Field

Identifies the EndPoint dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndPointProperty
Public Shared ReadOnly EndPointProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLineAnnotation.StartPointProperty Field

WpfLineAnnotationStartPointProperty Field

Identifies the StartPoint dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartPointProperty
Public Shared ReadOnly StartPointProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfLineAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Class

The WpfLinesAnnoation represents a series of points connected by straight lines.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfPointBaseAnnotation
Atalasoft.Annotate.WpfWpfLinesAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLinesAnnotation : WpfPointBaseAnnotation
Public Class WpfLinesAnnotation
    Inherits WpfPointBaseAnnotation

The WpfLinesAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLinesAnnotation | Creates a new instance of WpfLinesAnnotation.
Public method | WpfLinesAnnotation(LinesData) | Creates a new instance of WpfLinesAnnotation from an LinesData object.
Public method | WpfLinesAnnotation(Point, AnnotationPen) | Creates a new instance of WpfLinesAnnotation specifying the points and outline.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the lines.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfLinesAnnotation | Creates a new instance of WpfLinesAnnotation.
Public method | WpfLinesAnnotation(LinesData) | Creates a new instance of WpfLinesAnnotation from an LinesData object.
Public method | WpfLinesAnnotation(Point, AnnotationPen) | Creates a new instance of WpfLinesAnnotation specifying the points and outline.
Top
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Constructor

Creates a new instance of WpfLinesAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLinesAnnotation()
Public Sub New
See Also

Reference

WpfLinesAnnotation Class
WpfLinesAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Constructor (LinesData)

Creates a new instance of WpfLinesAnnotation from an LinesData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLinesAnnotation(
    LinesData data
)
Public Sub New (
    data As LinesData
)

Parameters

data
Type: Atalasoft.AnnotateLinesData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfLinesAnnotation Class
WpfLinesAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Constructor (Point[], AnnotationPen)

WpfLinesAnnotation Constructor (Point, AnnotationPen)

Creates a new instance of WpfLinesAnnotation specifying the points and outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLinesAnnotation(
    Point[] points,
    AnnotationPen outline
)
Public Sub New (
    points As Point(),
    outline As AnnotationPen
)

Parameters

points
Type: System.WindowsPoint
The points for the lines. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the lines.
See Also

Reference

WpfLinesAnnotation Class
WpfLinesAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Properties

The WpfLinesAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the lines.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation.Geometry Property

WpfLinesAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation.Outline Property

WpfLinesAnnotationOutline Property

Gets or sets the pen used to draw the lines.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used to draw the lines.
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation.SupportsMultiClickCreation Property

WpfLinesAnnotationSupportsMultiClickCreation Property

Gets a value indicating whether the annotation supports being created from multiple mouse clicks.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool SupportsMultiClickCreation { get; }
Public Overrides ReadOnly Property SupportsMultiClickCreation As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation supports being created from multiple mouse clicks.
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Methods

The WpfLinesAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation.CloneOverride Method

WpfLinesAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation.CreateDataSnapshotOverride Method

WpfLinesAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfLinesAnnotation Events

The WpfLinesAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfLinesAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter Class

This class contains helpful methods for converting between System.Drawing and System.Windows.Media objects. There are also methods for converting DotImage classes into System.Windows.Media objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.WpfWpfObjectConverter

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class WpfObjectConverter
Public NotInheritable Class WpfObjectConverter

The WpfObjectConverter type exposes the following members.

Methods
Name | Description
ConvertAnnotationBrush | Converts an AnnotationBrush into a System.Windows.Media.Brush.
ConvertAnnotationFont | Converts an AnnotationFont to a System.Windows.Media.Typeface.
ConvertAnnotationImage(BitmapSource) | Converts a System.Windows.Media.Imaging.BitmapSource to an AnnotationImage.
ConvertAnnotationImage(AnnotationImage) | Converts a AnnotationImage to a System.Windows.Media.Imaging.BitmapSource.
ConvertAnnotationPen | Converts a AnnotationPen to a System.Windows.Media.Pen.
ConvertBitmap(Bitmap) | Converts a System.Drawing.Bitmap to a System.Windows.Media.Imaging.BitmapSource.
ConvertBitmap(BitmapSource) | Converts a System.Windows.Media.Imaging.BitmapSource to a System.Drawing.Bitmap.
ConvertColor(Color) | Converts a System.Drawing.Color to a System.Windows.Media.Color.
ConvertColor(Color) | Converts a System.Windows.Media.Color to a System.Drawing.Color.
ConvertMatrix(Matrix) | Converts a System.Drawing.Drawing2D.Matrix to a System.Windows.Media.Matrix.
ConvertMatrix(Matrix) | Converts a System.Windows.Media.Matrix to a System.Drawing.Drawing2D.Matrix.
ConvertPointF(PointF) | Converts a System.Drawing.PointF to a System.Windows.Point.
ConvertPointF(PointF) | Converts an array of System.Drawing.PointF to an array of System.Windows.Point.
ConvertPointF(Point) | Converts a System.Windows.Point to a System.Drawing.PointF.
ConvertPointF(Point) | Converts an array of System.Windows.Point to an array of System.Drawing.PointF.
ConvertRectangleF(RectangleF) | Converts a System.Drawing.RectangleF to a System.Windows.Rect.
ConvertRectangleF(Rect) | Converts a System.Windows.Rect to a System.Drawing.RectangleF.
ConvertSizeF(SizeF) | Converts a System.Drawing.SizeF to a System.Windows.Size.
ConvertSizeF(Size) | Converts a System.Windows.Size to a System.Drawing.SizeF.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter Methods

The WpfObjectConverter type exposes the following members.

Methods
Name | Description
ConvertAnnotationBrush | Converts an AnnotationBrush into a System.Windows.Media.Brush.
ConvertAnnotationFont | Converts an AnnotationFont to a System.Windows.Media.Typeface.
ConvertAnnotationImage(BitmapSource) | Converts a System.Windows.Media.Imaging.BitmapSource to an AnnotationImage.
ConvertAnnotationImage(AnnotationImage) | Converts a AnnotationImage to a System.Windows.Media.Imaging.BitmapSource.
ConvertAnnotationPen | Converts a AnnotationPen to a System.Windows.Media.Pen.
ConvertBitmap(Bitmap) | Converts a System.Drawing.Bitmap to a System.Windows.Media.Imaging.BitmapSource.
ConvertBitmap(BitmapSource) | Converts a System.Windows.Media.Imaging.BitmapSource to a System.Drawing.Bitmap.
ConvertColor(Color) | Converts a System.Drawing.Color to a System.Windows.Media.Color.
ConvertColor(Color) | Converts a System.Windows.Media.Color to a System.Drawing.Color.
ConvertMatrix(Matrix) | Converts a System.Drawing.Drawing2D.Matrix to a System.Windows.Media.Matrix.
ConvertMatrix(Matrix) | Converts a System.Windows.Media.Matrix to a System.Drawing.Drawing2D.Matrix.
ConvertPointF(PointF) | Converts a System.Drawing.PointF to a System.Windows.Point.
ConvertPointF(PointF) | Converts an array of System.Drawing.PointF to an array of System.Windows.Point.
ConvertPointF(Point) | Converts a System.Windows.Point to a System.Drawing.PointF.
ConvertPointF(Point) | Converts an array of System.Windows.Point to an array of System.Drawing.PointF.
ConvertRectangleF(RectangleF) | Converts a System.Drawing.RectangleF to a System.Windows.Rect.
ConvertRectangleF(Rect) | Converts a System.Windows.Rect to a System.Drawing.RectangleF.
ConvertSizeF(SizeF) | Converts a System.Drawing.SizeF to a System.Windows.Size.
ConvertSizeF(Size) | Converts a System.Windows.Size to a System.Drawing.SizeF.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertAnnotationBrush Method

WpfObjectConverterConvertAnnotationBrush Method

Converts an AnnotationBrush into a System.Windows.Media.Brush.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Brush ConvertAnnotationBrush(
    AnnotationBrush brush
)
Public Shared Function ConvertAnnotationBrush (
    brush As AnnotationBrush
) As Brush

Parameters

brush
Type: Atalasoft.AnnotateAnnotationBrush
The brush to convert. If this argument is null (Nothing in VB) the return value will be null.

Return Value

Type: Brush
A System.Windows.Media.Brush representing the AnnotationBrush.
Remarks
Since WPF does not have a HatchBrush class, it will be converted into a SolidColorBrush.
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertAnnotationFont Method

WpfObjectConverterConvertAnnotationFont Method

Converts an AnnotationFont to a System.Windows.Media.Typeface.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Typeface ConvertAnnotationFont(
    AnnotationFont font
)
Public Shared Function ConvertAnnotationFont (
    font As AnnotationFont
) As Typeface

Parameters

font
Type: Atalasoft.AnnotateAnnotationFont
The AnnotationFont to convert.

Return Value

Type: Typeface
A System.Windows.Media.Typeface for the font.
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertAnnotationImage Method

WpfObjectConverterConvertAnnotationImage Method

Overload List
Name | Description
ConvertAnnotationImage(BitmapSource) | Converts a System.Windows.Media.Imaging.BitmapSource to an AnnotationImage.
ConvertAnnotationImage(AnnotationImage) | Converts a AnnotationImage to a System.Windows.Media.Imaging.BitmapSource.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertAnnotationImage Method (BitmapSource)

WpfObjectConverterConvertAnnotationImage Method (BitmapSource)

Converts a System.Windows.Media.Imaging.BitmapSource to an AnnotationImage.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AnnotationImage ConvertAnnotationImage(
    BitmapSource image
)
Public Shared Function ConvertAnnotationImage (
    image As BitmapSource
) As AnnotationImage

Parameters

image
Type: System.Windows.Media.ImagingBitmapSource
The System.Windows.Media.Imaging.BitmapSource to convert.

Return Value

Type: AnnotationImage
An AnnotationImage for the BitmapSource.
See Also

Reference

WpfObjectConverter Class
ConvertAnnotationImage Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertAnnotationImage Method (AnnotationImage)

WpfObjectConverterConvertAnnotationImage Method (AnnotationImage)

Converts a AnnotationImage to a System.Windows.Media.Imaging.BitmapSource.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static BitmapSource ConvertAnnotationImage(
    AnnotationImage image
)
Public Shared Function ConvertAnnotationImage (
    image As AnnotationImage
) As BitmapSource

Parameters

image
Type: Atalasoft.AnnotateAnnotationImage
The AnnotationImage to convert.

Return Value

Type: BitmapSource
A System.Windows.Media.Imaging.BitmapSource of the image.
See Also

Reference

WpfObjectConverter Class
ConvertAnnotationImage Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertAnnotationPen Method

WpfObjectConverterConvertAnnotationPen Method

Converts a AnnotationPen to a System.Windows.Media.Pen.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Pen ConvertAnnotationPen(
    AnnotationPen pen
)
Public Shared Function ConvertAnnotationPen (
    pen As AnnotationPen
) As Pen

Parameters

pen
Type: Atalasoft.AnnotateAnnotationPen
The AnnotationPen to convert.

Return Value

Type: Pen
A System.Windows.Media.Pen.
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertBitmap Method

WpfObjectConverterConvertBitmap Method

Overload List
Name | Description
ConvertBitmap(Bitmap) | Converts a System.Drawing.Bitmap to a System.Windows.Media.Imaging.BitmapSource.
ConvertBitmap(BitmapSource) | Converts a System.Windows.Media.Imaging.BitmapSource to a System.Drawing.Bitmap.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertBitmap Method (Bitmap)

WpfObjectConverterConvertBitmap Method (Bitmap)

Converts a System.Drawing.Bitmap to a System.Windows.Media.Imaging.BitmapSource.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static BitmapSource ConvertBitmap(
    Bitmap bitmap
)
Public Shared Function ConvertBitmap (
    bitmap As Bitmap
) As BitmapSource

Parameters

bitmap
Type: System.DrawingBitmap
The System.Drawing.Bitmap to convert.

Return Value

Type: BitmapSource
A System.Windows.Media.Imaging.BitmapSource for the Bitmap.
See Also

Reference

WpfObjectConverter Class
ConvertBitmap Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertBitmap Method (BitmapSource)

WpfObjectConverterConvertBitmap Method (BitmapSource)

Converts a System.Windows.Media.Imaging.BitmapSource to a System.Drawing.Bitmap.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Bitmap ConvertBitmap(
    BitmapSource image
)
Public Shared Function ConvertBitmap (
    image As BitmapSource
) As Bitmap

Parameters

image
Type: System.Windows.Media.ImagingBitmapSource
The System.Windows.Media.Imaging.BitmapSource to convert.

Return Value

Type: Bitmap
A System.Drawing.Bitmap for the BitmapSource.
See Also

Reference

WpfObjectConverter Class
ConvertBitmap Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertColor Method

WpfObjectConverterConvertColor Method

Overload List
Name | Description
ConvertColor(Color) | Converts a System.Drawing.Color to a System.Windows.Media.Color.
ConvertColor(Color) | Converts a System.Windows.Media.Color to a System.Drawing.Color.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertColor Method (Color)

WpfObjectConverterConvertColor Method (Color)

Converts a System.Drawing.Color to a System.Windows.Media.Color.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Color ConvertColor(
    Color color
)
Public Shared Function ConvertColor (
    color As Color
) As Color

Parameters

color
Type: System.DrawingColor
The System.Drawing.Color to convert.

Return Value

Type: Color
A System.Windows.Media.Color.
See Also

Reference

WpfObjectConverter Class
ConvertColor Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertColor Method (Color)

WpfObjectConverterConvertColor Method (Color)

Converts a System.Windows.Media.Color to a System.Drawing.Color.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Color ConvertColor(
    Color color
)
Public Shared Function ConvertColor (
    color As Color
) As Color

Parameters

color
Type: System.Windows.MediaColor
The System.Windows.Media.Color to convert.

Return Value

Type: Color
A System.Drawing.Color.
See Also

Reference

WpfObjectConverter Class
ConvertColor Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertMatrix Method

WpfObjectConverterConvertMatrix Method

Overload List
Name | Description
ConvertMatrix(Matrix) | Converts a System.Drawing.Drawing2D.Matrix to a System.Windows.Media.Matrix.
ConvertMatrix(Matrix) | Converts a System.Windows.Media.Matrix to a System.Drawing.Drawing2D.Matrix.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertMatrix Method (Matrix)

WpfObjectConverterConvertMatrix Method (Matrix)

Converts a System.Drawing.Drawing2D.Matrix to a System.Windows.Media.Matrix.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Matrix ConvertMatrix(
    Matrix matrix
)
Public Shared Function ConvertMatrix (
    matrix As Matrix
) As Matrix

Parameters

matrix
Type: System.Drawing.Drawing2DMatrix
The System.Drawing.Drawing2D.Matrix to convert.

Return Value

Type: Matrix
A System.Windows.Media.Matrix.
See Also

Reference

WpfObjectConverter Class
ConvertMatrix Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertMatrix Method (Matrix)

WpfObjectConverterConvertMatrix Method (Matrix)

Converts a System.Windows.Media.Matrix to a System.Drawing.Drawing2D.Matrix.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Matrix ConvertMatrix(
    Matrix matrix
)
Public Shared Function ConvertMatrix (
    matrix As Matrix
) As Matrix

Parameters

matrix
Type: System.Windows.MediaMatrix
The System.Windows.Media.Matrix to convert.

Return Value

Type: Matrix
A System.Drawing.Drawing2D.Matrix.
See Also

Reference

WpfObjectConverter Class
ConvertMatrix Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertPointF Method

WpfObjectConverterConvertPointF Method

Overload List
Name | Description
ConvertPointF(PointF) | Converts a System.Drawing.PointF to a System.Windows.Point.
ConvertPointF(PointF) | Converts an array of System.Drawing.PointF to an array of System.Windows.Point.
ConvertPointF(Point) | Converts a System.Windows.Point to a System.Drawing.PointF.
ConvertPointF(Point) | Converts an array of System.Windows.Point to an array of System.Drawing.PointF.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertPointF Method (PointF)

WpfObjectConverterConvertPointF Method (PointF)

Converts a System.Drawing.PointF to a System.Windows.Point.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Point ConvertPointF(
    PointF point
)
Public Shared Function ConvertPointF (
    point As PointF
) As Point

Parameters

point
Type: System.DrawingPointF
The System.Drawing.PointF to convert.

Return Value

Type: Point
A System.Windows.Point.
See Also

Reference

WpfObjectConverter Class
ConvertPointF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertPointF Method (PointF[])

WpfObjectConverterConvertPointF Method (PointF)

Converts an array of System.Drawing.PointF to an array of System.Windows.Point.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Point[] ConvertPointF(
    PointF[] points
)
Public Shared Function ConvertPointF (
    points As PointF()
) As Point()

Parameters

points
Type: System.DrawingPointF
An array of System.Drawing.PointF.

Return Value

Type: Point
An array of System.Windows.Point.
See Also

Reference

WpfObjectConverter Class
ConvertPointF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertPointF Method (Point)

WpfObjectConverterConvertPointF Method (Point)

Converts a System.Windows.Point to a System.Drawing.PointF.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF ConvertPointF(
    Point point
)
Public Shared Function ConvertPointF (
    point As Point
) As PointF

Parameters

point
Type: System.WindowsPoint
The System.Windows.Point to convert.

Return Value

Type: PointF
A System.Drawing.PointF.
See Also

Reference

WpfObjectConverter Class
ConvertPointF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertPointF Method (Point[])

WpfObjectConverterConvertPointF Method (Point)

Converts an array of System.Windows.Point to an array of System.Drawing.PointF.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PointF[] ConvertPointF(
    Point[] points
)
Public Shared Function ConvertPointF (
    points As Point()
) As PointF()

Parameters

points
Type: System.WindowsPoint
An array of System.Windows.Point to convert.

Return Value

Type: PointF
An array of System.Drawing.PointF.
See Also

Reference

WpfObjectConverter Class
ConvertPointF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertRectangleF Method

WpfObjectConverterConvertRectangleF Method

Overload List
Name | Description
ConvertRectangleF(RectangleF) | Converts a System.Drawing.RectangleF to a System.Windows.Rect.
ConvertRectangleF(Rect) | Converts a System.Windows.Rect to a System.Drawing.RectangleF.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertRectangleF Method (RectangleF)

WpfObjectConverterConvertRectangleF Method (RectangleF)

Converts a System.Drawing.RectangleF to a System.Windows.Rect.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Rect ConvertRectangleF(
    RectangleF rectangle
)
Public Shared Function ConvertRectangleF (
    rectangle As RectangleF
) As Rect

Parameters

rectangle
Type: System.DrawingRectangleF
The System.Drawing.RectangleF to convert.

Return Value

Type: Rect
A System.Windows.Rect.
See Also

Reference

WpfObjectConverter Class
ConvertRectangleF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertRectangleF Method (Rect)

WpfObjectConverterConvertRectangleF Method (Rect)

Converts a System.Windows.Rect to a System.Drawing.RectangleF.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RectangleF ConvertRectangleF(
    Rect rectangle
)
Public Shared Function ConvertRectangleF (
    rectangle As Rect
) As RectangleF

Parameters

rectangle
Type: System.WindowsRect
The System.Windows.Rect to convert.

Return Value

Type: RectangleF
A System.Drawing.RectangleF.
See Also

Reference

WpfObjectConverter Class
ConvertRectangleF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertSizeF Method

WpfObjectConverterConvertSizeF Method

Overload List
Name | Description
ConvertSizeF(SizeF) | Converts a System.Drawing.SizeF to a System.Windows.Size.
ConvertSizeF(Size) | Converts a System.Windows.Size to a System.Drawing.SizeF.
Top
See Also

Reference

WpfObjectConverter Class
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertSizeF Method (SizeF)

WpfObjectConverterConvertSizeF Method (SizeF)

Converts a System.Drawing.SizeF to a System.Windows.Size.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size ConvertSizeF(
    SizeF size
)
Public Shared Function ConvertSizeF (
    size As SizeF
) As Size

Parameters

size
Type: System.DrawingSizeF
The System.Drawing.SizeF to convert.

Return Value

Type: Size
A System.Windows.Size.
See Also

Reference

WpfObjectConverter Class
ConvertSizeF Overload
Atalasoft.Annotate.Wpf Namespace


WpfObjectConverter.ConvertSizeF Method (Size)

WpfObjectConverterConvertSizeF Method (Size)

Converts a System.Windows.Size to a System.Drawing.SizeF.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static SizeF ConvertSizeF(
    Size size
)
Public Shared Function ConvertSizeF (
    size As Size
) As SizeF

Parameters

size
Type: System.WindowsSize
The System.Windows.Size to convert.

Return Value

Type: SizeF
A System.Drawing.SizeF.
See Also

Reference

WpfObjectConverter Class
ConvertSizeF Overload
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Class

WpfPointBaseAnnotation is an abstract class from which all point base annotations derive. This reduces the amount of code required to create this annotations.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfPointBaseAnnotation
Atalasoft.Annotate.WpfWpfFreehandAnnotation
Atalasoft.Annotate.WpfWpfHotSpotFreehandAnnotation
Atalasoft.Annotate.WpfWpfLinesAnnotation
Atalasoft.Annotate.WpfWpfPolygonAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class WpfPointBaseAnnotation : WpfAnnotationUI
Public MustInherit Class WpfPointBaseAnnotation
    Inherits WpfAnnotationUI

The WpfPointBaseAnnotation type exposes the following members.

Constructors
 | Name | Description
Protected method | WpfPointBaseAnnotation(Int32, PointBaseData) | Called by derived classes to create an instance from annotation data. This constructor is used when deserializing annotation data.
Protected method | WpfPointBaseAnnotation(Int32, Point) | Called by derived classes to specify the maximum number of points to allow during creation or a collection of points.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation.
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse.
Protected property | Points | Returns a list of points for the annotation.
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Inherited from WpfAnnotationUI.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Inherited from WpfAnnotationUI.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GeometryFromPoints | Returns a Geometry object from an array of points and line information.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection.
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Overrides WpfAnnotationUIOnAnnotationCreated(RoutedEventArgs).)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed.
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size.
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions.
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values.
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Constructor

Overload List
 | Name | Description
Protected method | WpfPointBaseAnnotation(Int32, PointBaseData) | Called by derived classes to create an instance from annotation data. This constructor is used when deserializing annotation data.
Protected method | WpfPointBaseAnnotation(Int32, Point) | Called by derived classes to specify the maximum number of points to allow during creation or a collection of points.
Top
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Constructor (Int32, PointBaseData)

Called by derived classes to create an instance from annotation data. This constructor is used when deserializing annotation data.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfPointBaseAnnotation(
    int maximumPointCount,
    PointBaseData data
)
Protected Sub New (
    maximumPointCount As Integer,
    data As PointBaseData
)

Parameters

maximumPointCount
Type: SystemInt32
The maximum number of points to allow for this annotation during end-user creation. Pass 0 for an unlimited number of points.
data
Type: Atalasoft.AnnotatePointBaseData
The PointBaseData class containing property information for this annotation.
See Also

Reference

WpfPointBaseAnnotation Class
WpfPointBaseAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Constructor (Int32, Point[])

WpfPointBaseAnnotation Constructor (Int32, Point)

Called by derived classes to specify the maximum number of points to allow during creation or a collection of points.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfPointBaseAnnotation(
    int maximumPointCount,
    Point[] points
)
Protected Sub New (
    maximumPointCount As Integer,
    points As Point()
)

Parameters

maximumPointCount
Type: SystemInt32
The maximum number of points to allow for this annotation during end-user creation. Pass 0 for an unlimited number of points.
points
Type: System.WindowsPoint
An array of points for this annotation. This argument can be null (Nothing in VB).
See Also

Reference

WpfPointBaseAnnotation Class
WpfPointBaseAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Properties

The WpfPointBaseAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation.
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse.
Protected property | Points | Returns a list of points for the annotation.
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.FreehandStyleCreation Property

WpfPointBaseAnnotationFreehandStyleCreation Property

Gets or sets a value indicating whether the annotation will be created using freehand style.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool FreehandStyleCreation { get; set; }
Protected Property FreehandStyleCreation As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation will be created using freehand style.
Remarks
If this property is true, the annotation is created using a click-and-drag method, where points are added as the mouse is moved. Setting this property to false indicates that the annotation is created using multiple clicks.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.GripMode Property

WpfPointBaseAnnotationGripMode Property

Gets or sets the type of grips to use for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationGripMode GripMode { get; set; }
Public Property GripMode As AnnotationGripMode
    Get
    Set

Property Value

Type: AnnotationGripMode
A value indicating whether point or rectangle grips are used.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.PointCreationDistanceThreshold Property

WpfPointBaseAnnotationPointCreationDistanceThreshold Property

Gets or sets the minimum distance between points when creating the annotation with a mouse.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PointCreationDistanceThreshold { get; set; }
Public Property PointCreationDistanceThreshold As Double
    Get
    Set

Property Value

Type: Double
The minimum distance between points when creating the annotation.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the value being set is less than zero.
Remarks
This value is used to reduce the number of points added when creating the annotation with a mouse. Setting this property to zero will cause a point to be added each time the annotation receives a MouseMove event.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.Points Property

WpfPointBaseAnnotationPoints Property

Returns a list of points for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfPointCollection Points { get; }
Protected ReadOnly Property Points As WpfPointCollection
    Get

Property Value

Type: WpfPointCollection
A List<Point> containing the points of the annotation.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Methods

The WpfPointBaseAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Inherited from WpfAnnotationUI.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Inherited from WpfAnnotationUI.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation.
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
 | GeometryFromPoints | Returns a Geometry object from an array of points and line information.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection.
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Overrides WpfAnnotationUIOnAnnotationCreated(RoutedEventArgs).)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed.
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size.
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions.
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values.
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.AttachGripsOverride Method

WpfPointBaseAnnotationAttachGripsOverride Method

Called when the annotation grips need to be created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationGrips AttachGripsOverride(
    WpfAnnotationCanvas canvas
)
Protected Overrides Function AttachGripsOverride (
    canvas As WpfAnnotationCanvas
) As WpfAnnotationGrips

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.

Return Value

Type: WpfAnnotationGrips
The grips for the annotation.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.EndUserCreation Method

WpfPointBaseAnnotationEndUserCreation Method

Ends the "create" mode for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void EndUserCreation()
Protected Sub EndUserCreation
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.GeometryFromPoints Method

WpfPointBaseAnnotationGeometryFromPoints Method

Returns a Geometry object from an array of points and line information.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Geometry GeometryFromPoints(
    Point[] points,
    WpfFreehandLineType lineType,
    bool isClosed,
    bool isFilled
)
Public Shared Function GeometryFromPoints (
    points As Point(),
    lineType As WpfFreehandLineType,
    isClosed As Boolean,
    isFilled As Boolean
) As Geometry

Parameters

points
Type: System.WindowsPoint
An array of points for the object.
lineType
Type: Atalasoft.Annotate.WpfWpfFreehandLineType
The type of line used to connect the points.
isClosed
Type: SystemBoolean
Indicates whether the figure is closed.
isFilled
Type: SystemBoolean
Indicates whether the figure is filled.

Return Value

Type: Geometry
A Geometry for the points.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the points array is null.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.GetPointArray Method

WpfPointBaseAnnotationGetPointArray Method

returns the Point objects as an array.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point[] GetPointArray()
Public Function GetPointArray As Point()

Return Value

Type: Point
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.NormalizePoints Method

WpfPointBaseAnnotationNormalizePoints Method

Overload List
 | Name | Description
Protected method | NormalizePoints | This method will correct any negative points in the collection.
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection
Top
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.NormalizePoints Method

WpfPointBaseAnnotationNormalizePoints Method

This method will correct any negative points in the collection.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void NormalizePoints()
Protected Sub NormalizePoints
See Also

Reference

WpfPointBaseAnnotation Class
NormalizePoints Overload
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.NormalizePoints Method (Point[])

WpfPointBaseAnnotationNormalizePoints Method (Point)

corrects any negitive points in the collection

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void NormalizePoints(
    Point[] points
)
Protected Sub NormalizePoints (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
The points.
See Also

Reference

WpfPointBaseAnnotation Class
NormalizePoints Overload
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnAnnotationCreated Method

WpfPointBaseAnnotationOnAnnotationCreated Method

Called after the annotation has been created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationCreated(
    RoutedEventArgs e
)
Protected Overrides Sub OnAnnotationCreated (
    e As RoutedEventArgs
)

Parameters

e
Type: System.WindowsRoutedEventArgs
A RoutedEventArgs for this event.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnGripModeChanged Method

WpfPointBaseAnnotationOnGripModeChanged Method

Called when the GripMode property has been changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnGripModeChanged()
Protected Overridable Sub OnGripModeChanged
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnGripPositionChanged Method

WpfPointBaseAnnotationOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overrides Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnMouseDown Method

WpfPointBaseAnnotationOnMouseDown Method

Called when a MouseDown event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs for the event.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnMouseMove Method

WpfPointBaseAnnotationOnMouseMove Method

Called when a MouseMove event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for the event.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnMouseUp Method

WpfPointBaseAnnotationOnMouseUp Method

Called when a MouseUp event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for the event.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.OnPropertyChanged Method

WpfPointBaseAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.ResizePoints Method

WpfPointBaseAnnotationResizePoints Method

This method will update the Point values to fill the provided size.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ResizePoints(
    Size size
)
Protected Sub ResizePoints (
    size As Size
)

Parameters

size
Type: System.WindowsSize
The size all points will fit into.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.RotatePoints Method

WpfPointBaseAnnotationRotatePoints Method

Puts the array of points through a matrix rotation transform

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RotatePoints(
    Point[] points
)
Protected Sub RotatePoints (
    points As Point()
)

Parameters

points
Type: System.WindowsPoint
The points.
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.SetGripPositions Method

WpfPointBaseAnnotationSetGripPositions Method

Call this method to add or update the grip positions.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetGripPositions()
Protected Sub SetGripPositions
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation.SetLocationAndSize Method

WpfPointBaseAnnotationSetLocationAndSize Method

This method will update the Location and Size properties based on the point values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetLocationAndSize()
Protected Sub SetLocationAndSize
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointBaseAnnotation Events

The WpfPointBaseAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfPointBaseAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection Class

A Collection of Point objects for use in WPF
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection Point
Atalasoft.Annotate.WpfWpfPointCollection

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPointCollection : Collection<Point>
Public Class WpfPointCollection
    Inherits Collection(Of Point)

The WpfPointCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPointCollection | Initializes a new instance of the WpfPointCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Point .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection Point .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Point .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Point .)
Public method | AddRange | Adds points from the supplied IEnumerable.
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Point .)
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides CollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection Point .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Point .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Point .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Point .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Point .)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event.
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Point .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Point .)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToArray | Converts the Collection to a Point array
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection of points changes.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfPointCollection Constructor

Initializes a new instance of the WpfPointCollection class.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPointCollection()
Public Sub New
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection Properties

The WpfPointCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Point .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection Point .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Point .)
Top
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection Methods

The WpfPointCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Point .)
Public method | AddRange | Adds points from the supplied IEnumerable.
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Point .)
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides CollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection Point .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Point .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Point .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Point .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Point .)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event.
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Point .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Point .)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToArray | Converts the Collection to a Point array
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.AddRange Method

WpfPointCollectionAddRange Method

Adds points from the supplied IEnumerable.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    IEnumerable<Point> points
)
Public Sub AddRange (
    points As IEnumerable(Of Point)
)

Parameters

points
Type: System.Collections.GenericIEnumerable Point
The points.
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.ClearItems Method

WpfPointCollectionClearItems Method

Removes all elements from the CollectionT.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.InsertItem Method

WpfPointCollectionInsertItem Method

Inserts an element into the CollectionT at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    Point item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As Point
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: System.WindowsPoint
The object to insert. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.OnCollectionChanged Method

WpfPointCollectionOnCollectionChanged Method

Raises the CollectionChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCollectionChanged(
    CollectionChangedEventArgs<Point> e
)
Protected Overridable Sub OnCollectionChanged (
    e As CollectionChangedEventArgs(Of Point)
)

Parameters

e
Type: Atalasoft.Annotate.WpfCollectionChangedEventArgs Point
The CollectionChangedEventArgs instance of type Point containing the event data.
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.RemoveItem Method

WpfPointCollectionRemoveItem Method

Removes the element at the specified index of the CollectionT.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.SetItem Method

WpfPointCollectionSetItem Method

Replaces the element at the specified index.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    Point item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As Point
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: System.WindowsPoint
The new value for the element at the specified index. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.ToArray Method

WpfPointCollectionToArray Method

Converts the Collection to a Point array

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point[] ToArray()
Public Function ToArray As Point()

Return Value

Type: Point
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection Events

The WpfPointCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection of points changes.
Top
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPointCollection.CollectionChanged Event

WpfPointCollectionCollectionChanged Event

Occurs when the collection of points changes.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangedEventArgs<Point>> CollectionChanged
Public Event CollectionChanged As EventHandler(Of CollectionChangedEventArgs(Of Point))

Value

Type: SystemEventHandler CollectionChangedEventArgs Point
See Also

Reference

WpfPointCollection Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Class

A WpfPolygonAnnotation is a series of points used to draw a polygon with an optional fill.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfPointBaseAnnotation
Atalasoft.Annotate.WpfWpfPolygonAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPolygonAnnotation : WpfPointBaseAnnotation
Public Class WpfPolygonAnnotation
    Inherits WpfPointBaseAnnotation

The WpfPolygonAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPolygonAnnotation | Creates a new instance of WpfPolygonAnnotation using default values.
Public method | WpfPolygonAnnotation(PolygonData) | Creates a new instance of WpfPolygonAnnotation from an PolygonData object.
Public method | WpfPolygonAnnotation(Point, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfPolygonAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfPolygonAnnotation | Creates a new instance of WpfPolygonAnnotation using default values.
Public method | WpfPolygonAnnotation(PolygonData) | Creates a new instance of WpfPolygonAnnotation from an PolygonData object.
Public method | WpfPolygonAnnotation(Point, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfPolygonAnnotation specifying its properties.
Top
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Constructor

Creates a new instance of WpfPolygonAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPolygonAnnotation()
Public Sub New
See Also

Reference

WpfPolygonAnnotation Class
WpfPolygonAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Constructor (PolygonData)

Creates a new instance of WpfPolygonAnnotation from an PolygonData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPolygonAnnotation(
    PolygonData data
)
Public Sub New (
    data As PolygonData
)

Parameters

data
Type: Atalasoft.AnnotatePolygonData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfPolygonAnnotation Class
WpfPolygonAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Constructor (Point[], AnnotationBrush, AnnotationPen, AnnotationBrush, Point)

WpfPolygonAnnotation Constructor (Point, AnnotationBrush, AnnotationPen, AnnotationBrush, Point)

Creates a new instance of WpfPolygonAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPolygonAnnotation(
    Point[] points,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    points As Point(),
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

points
Type: System.WindowsPoint
The points for the polygon. This can be null (Nothing in VB).
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the outline of the annotation. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
The offset for the shadow.
See Also

Reference

WpfPolygonAnnotation Class
WpfPolygonAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Properties

The WpfPolygonAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Protected property | FreehandStyleCreation | Gets or sets a value indicating whether the annotation will be created using freehand style. (Inherited from WpfPointBaseAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | GripMode | Gets or sets the type of grips to use for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | PointCreationDistanceThreshold | Gets or sets the minimum distance between points when creating the annotation with a mouse. (Inherited from WpfPointBaseAnnotation.)
Protected property | Points | Returns a list of points for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.Fill Property

WpfPolygonAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.Geometry Property

WpfPolygonAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.Outline Property

WpfPolygonAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.Shadow Property

WpfPolygonAnnotationShadow Property

Gets or sets the brush used for the annotation shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
Remarks
Set this property to null (Nothing in VB) to remove the shadow.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.ShadowOffset Property

WpfPolygonAnnotationShadowOffset Property

Gets or sets the offset used to position the shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The offset used to position the shadow.
Remarks
A negative value will move the shadow to up and to the left. Positive values will move the shadow down and to the right.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.SupportsMultiClickCreation Property

WpfPolygonAnnotationSupportsMultiClickCreation Property

Gets a value indicating whether the annotation supports being created from multiple mouse clicks.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool SupportsMultiClickCreation { get; }
Public Overrides ReadOnly Property SupportsMultiClickCreation As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation supports being created from multiple mouse clicks.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Methods

The WpfPolygonAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfPointBaseAnnotation.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Protected method | EndUserCreation | Ends the "create" mode for the annotation. (Inherited from WpfPointBaseAnnotation.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPointArray | returns the Point objects as an array. (Inherited from WpfPointBaseAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | NormalizePoints | This method will correct any negative points in the collection. (Inherited from WpfPointBaseAnnotation.)
Protected method | NormalizePoints(Point) | corrects any negitive points in the collection (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripModeChanged | Called when the GripMode property has been changed. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from WpfPointBaseAnnotation.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Protected method | ResizePoints | This method will update the Point values to fill the provided size. (Inherited from WpfPointBaseAnnotation.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Protected method | RotatePoints | Puts the array of points through a matrix rotation transform (Inherited from WpfPointBaseAnnotation.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetGripPositions | Call this method to add or update the grip positions. (Inherited from WpfPointBaseAnnotation.)
Protected method | SetLocationAndSize | This method will update the Location and Size properties based on the point values. (Inherited from WpfPointBaseAnnotation.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.CloneOverride Method

WpfPolygonAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation.CreateDataSnapshotOverride Method

WpfPolygonAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfPolygonAnnotation Events

The WpfPolygonAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfPolygonAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Class

This is a rectangular annotation with an optional shadow brush.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfRectangleAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfRectangleAnnotation : WpfAnnotationUI
Public Class WpfRectangleAnnotation
    Inherits WpfAnnotationUI

The WpfRectangleAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfRectangleAnnotation | Creates a new instance of WpfRectangleAnnotation using default values.
Public method | WpfRectangleAnnotation(RectangleData) | Creates a new instance of WpfRectangleAnnotation from an RectangleData object.
Public method | WpfRectangleAnnotation(Rect, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfRectangleAnnotation specifying its bounding rectangle, fill and outline.
Public method | WpfRectangleAnnotation(Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfRectangleAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Overrides WpfAnnotationUIHitTest(Point).)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfRectangleAnnotation | Creates a new instance of WpfRectangleAnnotation using default values.
Public method | WpfRectangleAnnotation(RectangleData) | Creates a new instance of WpfRectangleAnnotation from an RectangleData object.
Public method | WpfRectangleAnnotation(Rect, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfRectangleAnnotation specifying its bounding rectangle, fill and outline.
Public method | WpfRectangleAnnotation(Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfRectangleAnnotation specifying its properties.
Top
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Constructor

Creates a new instance of WpfRectangleAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleAnnotation()
Public Sub New
See Also

Reference

WpfRectangleAnnotation Class
WpfRectangleAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Constructor (RectangleData)

Creates a new instance of WpfRectangleAnnotation from an RectangleData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleAnnotation(
    RectangleData data
)
Public Sub New (
    data As RectangleData
)

Parameters

data
Type: Atalasoft.AnnotateRectangleData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfRectangleAnnotation Class
WpfRectangleAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Constructor (Rect, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfRectangleAnnotation specifying its bounding rectangle, fill and outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleAnnotation(
    Rect rectangle,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    rectangle As Rect,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

rectangle
Type: System.WindowsRect
The bounding rectangle of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for filling the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the annotation outline. This can be null (Nothing in VB).
See Also

Reference

WpfRectangleAnnotation Class
WpfRectangleAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Constructor (Rect, AnnotationBrush, AnnotationPen, AnnotationBrush, Point)

Creates a new instance of WpfRectangleAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleAnnotation(
    Rect rectangle,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    rectangle As Rect,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

rectangle
Type: System.WindowsRect
The bounding rectangle of the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for filling the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the annotation outline. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
The offset of the shadow.
See Also

Reference

WpfRectangleAnnotation Class
WpfRectangleAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Properties

The WpfRectangleAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.Fill Property

WpfRectangleAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.Outline Property

WpfRectangleAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.Shadow Property

WpfRectangleAnnotationShadow Property

Gets or sets the brush used for the annotation shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
Remarks
Set this property to null (Nothing in VB) to remove the shadow.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.ShadowOffset Property

WpfRectangleAnnotationShadowOffset Property

Gets or sets the offset used to position the shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The offset used to position the shadow.
Remarks
A negative value will move the shadow to up and to the left. Positive values will move the shadow down and to the right.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Methods

The WpfRectangleAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Overrides WpfAnnotationUIHitTest(Point).)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.CloneOverride Method

WpfRectangleAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.CreateDataSnapshotOverride Method

WpfRectangleAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation.HitTest Method

WpfRectangleAnnotationHitTest Method

This method will determine whether the specified point is on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool HitTest(
    Point dsPoint
)
Public Overrides Function HitTest (
    dsPoint As Point
) As Boolean

Parameters

dsPoint
Type: System.WindowsPoint
The point to hit test.

Return Value

Type: Boolean
True if the point is on the annotation.
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleAnnotation Events

The WpfRectangleAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfRectangleAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrip Enumeration

Identifies the rectangular grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfRectangleGrip
Public Enumeration WpfRectangleGrip
Members
Member name | Description
None | The grip is not one of the standard rectangle grips.
TopLeft | The grip is at the top-left of the rectangle.
TopCenter | The grip is centered along the top of the rectangle.
TopRight | The grip is at teh top-right of the rectangle.
CenterLeft | The grip is centered along the left side of the rectangle.
CenterRight | The grip is centered along the right side of the rectangle.
BottomLeft | The grip is at the bottom-left of the rectangle.
BottomCenter | The grip is centered along the bottom of the rectangle.
BottomRight | The grip is at the bottom-right of the rectangle.
Rotation | The grip is used for rotating the rectangle.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfRectangleGripRotationMode Enumeration

Indicates the grip rotation behavior.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfRectangleGripRotationMode
Public Enumeration WpfRectangleGripRotationMode
Members
Member name | Description
None | No rotation is performed.
Grip | The normal rotation grip is displayed.
Zone | An invisible grip is used for rotation. The cursor will change when over the grip area to indicate a rotation action.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips Class

This class represents a group of WpfAnnotationGrip objects for rectangular shaped annotations.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.DocumentsAdorner
Atalasoft.Annotate.WpfWpfAnnotationGrips
Atalasoft.Annotate.WpfWpfRectangleGrips

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfRectangleGrips : WpfAnnotationGrips
Public Class WpfRectangleGrips
    Inherits WpfAnnotationGrips

The WpfRectangleGrips type exposes the following members.

Constructors
 | Name | Description
Public method | WpfRectangleGrips | Creates a new instance of WpfRectangleGrips.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedElement | Gets the UIElement that this adorner is bound to. (Inherited from Adorner.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Annotation | Gets the annotation for these grips. (Inherited from WpfAnnotationGrips.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AspectRatio | Gets or sets the aspect ratio to maintain when the user is resizing the annotation.
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | Bounds | Gets the bounding rectangle of the grips. (Inherited from WpfAnnotationGrips.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Canvas | Gets the WpfAnnotationCanvas that hosts the grips. (Inherited from WpfAnnotationGrips.)
Public property | CenterOfRotation | Gets the center of rotation for the grips. (Inherited from WpfAnnotationGrips.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GripsToDisplay | Gets or sets the grips to display.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsClipEnabled | Gets or sets a value that indicates whether clipping of the adorner is enabled. (Inherited from Adorner.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRotatedOnRender | Gets or sets a value indicating whether the grip is rendered rotated when the annotation is rotated. (Inherited from WpfAnnotationGrips.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Items | Gets a list of WpfAnnotationGrip. (Inherited from WpfAnnotationGrips.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | MaintainGripSize | Gets or sets a value indicating whether the grip size is visually maintained or resized along with the zoom level. (Inherited from WpfAnnotationGrips.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PositionBounds | Gets the bounding rectangle of the grip positions. (Inherited from WpfAnnotationGrips.)
Public property | Renderer | Gets or sets the renderer used for the grips. (Inherited from WpfAnnotationGrips.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotationMode | Gets or sets the mode used for the rotation grip.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CalculateGripPercentages | Calculates percentage values for the grips to fit within the specified bounds. (Inherited from WpfAnnotationGrips.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindGrip(String) | Looks up a grip by its name. (Inherited from WpfAnnotationGrips.)
Public method | FindGrip(WpfRectangleGrip) | Looks up a grip by its WpfRectangleGrip status. (Inherited from WpfAnnotationGrips.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDesiredTransform | Returns a Transform for the adorner, based on the transform that is currently applied to the adorned element. (Inherited from Adorner.)
Protected method | GetGripCursor | Returns the cursor for the specified grip with respect to the current rotation. (Inherited from WpfAnnotationGrips.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | For a description of this member, see GetLayoutClip(Size). (Inherited from Adorner.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Protected method | GetUnRotatedPoint | Calculates the un-rotated point from a provided point. (Inherited from WpfAnnotationGrips.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | GripFromPoint | Find a grip at the specified point in document space. (Inherited from WpfAnnotationGrips.)
Protected method | HitTestCore(PointHitTestParameters) | Tests whether a specified point is on the grips or annotation. (Inherited from WpfAnnotationGrips.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | InitiateGrips | Called when the grips need to be generated. (Overrides WpfAnnotationGripsInitiateGrips.)
Protected method | InitiateRotationGrips | Called when the rotation grip needs to be created.
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Implements any custom measuring behavior for the adorner. (Inherited from WpfAnnotationGrips.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MirrorApplied | Called when the annotation is mirrored to allow the grips to mirror. (Inherited from WpfAnnotationGrips.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | MoveGrips | Called to force the grips to move by a specified offset. (Overrides WpfAnnotationGripsMoveGrips(Point).)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGripPositionChanged | Called when a grip's position has changed and raises the GripPositionChanged event. (Inherited from WpfAnnotationGrips.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from WpfAnnotationGrips.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMirrorApplied | Called when the annotation is mirrored to allow the grips to mirror. (Overrides WpfAnnotationGripsOnMirrorApplied(MirrorDirection, Boolean).)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from WpfAnnotationGrips.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from WpfAnnotationGrips.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from WpfAnnotationGrips.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from WpfAnnotationGrips.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Protected method | UpdateGripPositions | Called when the grip positions need to be updated. (Overrides WpfAnnotationGripsUpdateGripPositions.)
Protected method | UpdateGripPositions(Point, Size) | Called when the grip positions need to be updated to fit a new annotation location and size.
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | ValidateGripMove | Called when a grip is being moved to allow for validation of this action. This method will raise an OperationRequest on the annotation. (Overrides WpfAnnotationGripsValidateGripMove(WpfAnnotationGrip, Point).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | GripPositionChanged | This event is raised when a grip's position has changed. (Inherited from WpfAnnotationGrips.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips Constructor

Creates a new instance of WpfRectangleGrips.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleGrips(
    WpfAnnotationCanvas canvas,
    WpfAnnotationUI annotation,
    IWpfGripRenderer renderer
)
Public Sub New (
    canvas As WpfAnnotationCanvas,
    annotation As WpfAnnotationUI,
    renderer As IWpfGripRenderer
)

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the grips.
annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation associated with the grips.
renderer
Type: Atalasoft.Annotate.Wpf.RendererIWpfGripRenderer
The renderer used to render the grips.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the canvas or annotation arguemnts are null (Nothing in VB).
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips Properties

The WpfRectangleGrips type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedElement | Gets the UIElement that this adorner is bound to. (Inherited from Adorner.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Annotation | Gets the annotation for these grips. (Inherited from WpfAnnotationGrips.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AspectRatio | Gets or sets the aspect ratio to maintain when the user is resizing the annotation.
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | Bounds | Gets the bounding rectangle of the grips. (Inherited from WpfAnnotationGrips.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Canvas | Gets the WpfAnnotationCanvas that hosts the grips. (Inherited from WpfAnnotationGrips.)
Public property | CenterOfRotation | Gets the center of rotation for the grips. (Inherited from WpfAnnotationGrips.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | GripsToDisplay | Gets or sets the grips to display.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsClipEnabled | Gets or sets a value that indicates whether clipping of the adorner is enabled. (Inherited from Adorner.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRotatedOnRender | Gets or sets a value indicating whether the grip is rendered rotated when the annotation is rotated. (Inherited from WpfAnnotationGrips.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Items | Gets a list of WpfAnnotationGrip. (Inherited from WpfAnnotationGrips.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | MaintainGripSize | Gets or sets a value indicating whether the grip size is visually maintained or resized along with the zoom level. (Inherited from WpfAnnotationGrips.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PositionBounds | Gets the bounding rectangle of the grip positions. (Inherited from WpfAnnotationGrips.)
Public property | Renderer | Gets or sets the renderer used for the grips. (Inherited from WpfAnnotationGrips.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotationMode | Gets or sets the mode used for the rotation grip.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.AspectRatio Property

WpfRectangleGripsAspectRatio Property

Gets or sets the aspect ratio to maintain when the user is resizing the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double AspectRatio { get; set; }
Public Property AspectRatio As Double
    Get
    Set

Property Value

Type: Double
The aspect ratio to maintain when the user is resizing the annotation.
Remarks
Setting this property to zero will disable the aspect ratio.
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.GripsToDisplay Property

WpfRectangleGripsGripsToDisplay Property

Gets or sets the grips to display.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleGripDisplay GripsToDisplay { get; set; }
Public Property GripsToDisplay As RectangleGripDisplay
    Get
    Set

Property Value

Type: RectangleGripDisplay
The grips to display.
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.RotationMode Property

WpfRectangleGripsRotationMode Property

Gets or sets the mode used for the rotation grip.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleGripRotationMode RotationMode { get; set; }
Public Property RotationMode As WpfRectangleGripRotationMode
    Get
    Set

Property Value

Type: WpfRectangleGripRotationMode
The mode used for the rotation grip.
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips Methods

The WpfRectangleGrips type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CalculateGripPercentages | Calculates percentage values for the grips to fit within the specified bounds. (Inherited from WpfAnnotationGrips.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindGrip(String) | Looks up a grip by its name. (Inherited from WpfAnnotationGrips.)
Public method | FindGrip(WpfRectangleGrip) | Looks up a grip by its WpfRectangleGrip status. (Inherited from WpfAnnotationGrips.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDesiredTransform | Returns a Transform for the adorner, based on the transform that is currently applied to the adorned element. (Inherited from Adorner.)
Protected method | GetGripCursor | Returns the cursor for the specified grip with respect to the current rotation. (Inherited from WpfAnnotationGrips.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | For a description of this member, see GetLayoutClip(Size). (Inherited from Adorner.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Protected method | GetUnRotatedPoint | Calculates the un-rotated point from a provided point. (Inherited from WpfAnnotationGrips.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | GripFromPoint | Find a grip at the specified point in document space. (Inherited from WpfAnnotationGrips.)
Protected method | HitTestCore(PointHitTestParameters) | Tests whether a specified point is on the grips or annotation. (Inherited from WpfAnnotationGrips.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | InitiateGrips | Called when the grips need to be generated. (Overrides WpfAnnotationGripsInitiateGrips.)
Protected method | InitiateRotationGrips | Called when the rotation grip needs to be created.
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Implements any custom measuring behavior for the adorner. (Inherited from WpfAnnotationGrips.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MirrorApplied | Called when the annotation is mirrored to allow the grips to mirror. (Inherited from WpfAnnotationGrips.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | MoveGrips | Called to force the grips to move by a specified offset. (Overrides WpfAnnotationGripsMoveGrips(Point).)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGripPositionChanged | Called when a grip's position has changed and raises the GripPositionChanged event. (Inherited from WpfAnnotationGrips.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from WpfAnnotationGrips.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMirrorApplied | Called when the annotation is mirrored to allow the grips to mirror. (Overrides WpfAnnotationGripsOnMirrorApplied(MirrorDirection, Boolean).)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from WpfAnnotationGrips.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from WpfAnnotationGrips.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from WpfAnnotationGrips.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from WpfAnnotationGrips.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Protected method | UpdateGripPositions | Called when the grip positions need to be updated. (Overrides WpfAnnotationGripsUpdateGripPositions.)
Protected method | UpdateGripPositions(Point, Size) | Called when the grip positions need to be updated to fit a new annotation location and size.
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | ValidateGripMove | Called when a grip is being moved to allow for validation of this action. This method will raise an OperationRequest on the annotation. (Overrides WpfAnnotationGripsValidateGripMove(WpfAnnotationGrip, Point).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.InitiateGrips Method

WpfRectangleGripsInitiateGrips Method

Called when the grips need to be generated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void InitiateGrips()
Protected Overrides Sub InitiateGrips
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.InitiateRotationGrips Method

WpfRectangleGripsInitiateRotationGrips Method

Called when the rotation grip needs to be created.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void InitiateRotationGrips()
Protected Overridable Sub InitiateRotationGrips
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.MoveGrips Method

WpfRectangleGripsMoveGrips Method

Called to force the grips to move by a specified offset.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void MoveGrips(
    Point offset
)
Protected Overrides Sub MoveGrips (
    offset As Point
)

Parameters

offset
Type: System.WindowsPoint
The offset to move each grip.
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.OnMirrorApplied Method

WpfRectangleGripsOnMirrorApplied Method

Called when the annotation is mirrored to allow the grips to mirror.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMirrorApplied(
    MirrorDirection direction,
    bool maintainPosition
)
Protected Overrides Sub OnMirrorApplied (
    direction As MirrorDirection,
    maintainPosition As Boolean
)

Parameters

direction
Type: Atalasoft.AnnotateMirrorDirection
The mirror direction.
maintainPosition
Type: SystemBoolean
Indicates whether the annotation position is maintained or if the mirror pivots along the zero axis.
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.UpdateGripPositions Method

WpfRectangleGripsUpdateGripPositions Method

Overload List
 | Name | Description
Protected method | UpdateGripPositions | Called when the grip positions need to be updated. (Overrides WpfAnnotationGripsUpdateGripPositions.)
Protected method | UpdateGripPositions(Point, Size) | Called when the grip positions need to be updated to fit a new annotation location and size.
Top
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.UpdateGripPositions Method

WpfRectangleGripsUpdateGripPositions Method

Called when the grip positions need to be updated.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void UpdateGripPositions()
Protected Overrides Sub UpdateGripPositions
See Also

Reference

WpfRectangleGrips Class
UpdateGripPositions Overload
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.UpdateGripPositions Method (Point, Size)

WpfRectangleGripsUpdateGripPositions Method (Point, Size)

Called when the grip positions need to be updated to fit a new annotation location and size.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void UpdateGripPositions(
    Point location,
    Size size
)
Protected Overridable Sub UpdateGripPositions (
    location As Point,
    size As Size
)

Parameters

location
Type: System.WindowsPoint
The new location of the annotation.
size
Type: System.WindowsSize
The new size of the annotation.
See Also

Reference

WpfRectangleGrips Class
UpdateGripPositions Overload
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips.ValidateGripMove Method

WpfRectangleGripsValidateGripMove Method

Called when a grip is being moved to allow for validation of this action. This method will raise an OperationRequest on the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationGrip ValidateGripMove(
    WpfAnnotationGrip grip,
    Point newPosition
)
Protected Overrides Function ValidateGripMove (
    grip As WpfAnnotationGrip,
    newPosition As Point
) As WpfAnnotationGrip

Parameters

grip
Type: Atalasoft.Annotate.WpfWpfAnnotationGrip
The grip being moved.
newPosition
Type: System.WindowsPoint
The requested new position of the grip.

Return Value

Type: WpfAnnotationGrip
The grip to be moved or null (Nothing in VB) to reject this action.
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfRectangleGrips Events

The WpfRectangleGrips type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | GripPositionChanged | This event is raised when a grip's position has changed. (Inherited from WpfAnnotationGrips.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

WpfRectangleGrips Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Class

This annotation references a local image by filename. When viewing this annotation on multiple systems, the image file must be provided at the same location of each system.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfReferencedImageAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfReferencedImageAnnotation : WpfAnnotationUI
Public Class WpfReferencedImageAnnotation
    Inherits WpfAnnotationUI

The WpfReferencedImageAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfReferencedImageAnnotation | Creates a new instance of WpfReferencedImageAnnotation.
Public method | WpfReferencedImageAnnotation(String) | Creates a new instance of WpfReferencedImageAnnotation specifying the image filename.
Public method | WpfReferencedImageAnnotation(ReferencedImageData) | Creates a new instance of WpfReferencedImageAnnotation from an ReferencedImageData object.
Public method | WpfReferencedImageAnnotation(String, Point, AnnotationBrush, Point) | Creates a new instance of WpfReferencedImageAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | FileName | Gets or sets the filename of the image.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | Source | Gets the BitmapSource used to render the image.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
FileNameProperty | Identifies the FileName dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfReferencedImageAnnotation | Creates a new instance of WpfReferencedImageAnnotation.
Public method | WpfReferencedImageAnnotation(String) | Creates a new instance of WpfReferencedImageAnnotation specifying the image filename.
Public method | WpfReferencedImageAnnotation(ReferencedImageData) | Creates a new instance of WpfReferencedImageAnnotation from an ReferencedImageData object.
Public method | WpfReferencedImageAnnotation(String, Point, AnnotationBrush, Point) | Creates a new instance of WpfReferencedImageAnnotation specifying its properties.
Top
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Constructor

Creates a new instance of WpfReferencedImageAnnotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfReferencedImageAnnotation()
Public Sub New
See Also

Reference

WpfReferencedImageAnnotation Class
WpfReferencedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Constructor (String)

Creates a new instance of WpfReferencedImageAnnotation specifying the image filename.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfReferencedImageAnnotation(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The filename of the image.
Exceptions
Exception | Condition
FileNotFoundException | Thrown if the filename cannot be found.
See Also

Reference

WpfReferencedImageAnnotation Class
WpfReferencedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Constructor (ReferencedImageData)

Creates a new instance of WpfReferencedImageAnnotation from an ReferencedImageData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfReferencedImageAnnotation(
    ReferencedImageData data
)
Public Sub New (
    data As ReferencedImageData
)

Parameters

data
Type: Atalasoft.AnnotateReferencedImageData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfReferencedImageAnnotation Class
WpfReferencedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Constructor (String, Point, AnnotationBrush, Point)

Creates a new instance of WpfReferencedImageAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfReferencedImageAnnotation(
    string fileName,
    Point location,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    fileName As String,
    location As Point,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

fileName
Type: SystemString
The filename of the image.
location
Type: System.WindowsPoint
The location of the annotation.
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow.
shadowOffset
Type: System.WindowsPoint
The offset of the shadow.
Exceptions
Exception | Condition
FileNotFoundException | Thrown if the filename cannot be found.
See Also

Reference

WpfReferencedImageAnnotation Class
WpfReferencedImageAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Properties

The WpfReferencedImageAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | FileName | Gets or sets the filename of the image.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow.
Public property | ShadowOffset | Gets or sets the offset used to position the shadow.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | Source | Gets the BitmapSource used to render the image.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.FileName Property

WpfReferencedImageAnnotationFileName Property

Gets or sets the filename of the image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The filename of the image.
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.Shadow Property

WpfReferencedImageAnnotationShadow Property

Gets or sets the brush used for the annotation shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
Remarks
Set this property to null (Nothing in VB) to remove the shadow.
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.ShadowOffset Property

WpfReferencedImageAnnotationShadowOffset Property

Gets or sets the offset used to position the shadow.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The offset used to position the shadow.
Remarks
A negative value will move the shadow to up and to the left. Positive values will move the shadow down and to the right.
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.Source Property

WpfReferencedImageAnnotationSource Property

Gets the BitmapSource used to render the image.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapSource Source { get; }
Public ReadOnly Property Source As BitmapSource
    Get

Property Value

Type: BitmapSource
The BitmapSource used to render the image or null (Nothing in VB) if the image cannot be created.
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Methods

The WpfReferencedImageAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.CloneOverride Method

WpfReferencedImageAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.CreateDataSnapshotOverride Method

WpfReferencedImageAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Events

The WpfReferencedImageAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation Fields

The WpfReferencedImageAnnotation type exposes the following members.

Fields
Name | Description
FileNameProperty | Identifies the FileName dependency property.
Top
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfReferencedImageAnnotation.FileNameProperty Field

WpfReferencedImageAnnotationFileNameProperty Field

Identifies the FileName dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FileNameProperty
Public Shared ReadOnly FileNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfReferencedImageAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Class

This annotation provides a text message with a rounded rectangle outline similar to a rubber stamp.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfRubberStampAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfRubberStampAnnotation : WpfAnnotationUI
Public Class WpfRubberStampAnnotation
    Inherits WpfAnnotationUI

The WpfRubberStampAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfRubberStampAnnotation | Creates a new instance of WpfRubberStampAnnotation using default values.
Public method | WpfRubberStampAnnotation(RubberStampData) | Creates a new instance of WpfRubberStampAnnotation from an RubberStampData object.
Public method | WpfRubberStampAnnotation(String, AnnotationFont, AnnotationBrush) | Creates a new instance of WpfRubberStampAnnotation specifying its text, font and font brush.
Public method | WpfRubberStampAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfRubberStampAnnotation specifying its text, font, font brush, fill and outline.
Public method | WpfRubberStampAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Double, Double) | Creates a new instance of WpfRubberStampAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CornerRadius | Gets or sets the radius used to render rounded corners.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | Padding | Gets or sets the amount of padding around the text.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FontBrushProperty | Identifies the FontBrush dependency property.
FontProperty | Identifies the Font dependency property.
PaddingProperty | Identifies the Padding dependency property.
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfRubberStampAnnotation | Creates a new instance of WpfRubberStampAnnotation using default values.
Public method | WpfRubberStampAnnotation(RubberStampData) | Creates a new instance of WpfRubberStampAnnotation from an RubberStampData object.
Public method | WpfRubberStampAnnotation(String, AnnotationFont, AnnotationBrush) | Creates a new instance of WpfRubberStampAnnotation specifying its text, font and font brush.
Public method | WpfRubberStampAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfRubberStampAnnotation specifying its text, font, font brush, fill and outline.
Public method | WpfRubberStampAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Double, Double) | Creates a new instance of WpfRubberStampAnnotation specifying its properties.
Top
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Constructor

Creates a new instance of WpfRubberStampAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRubberStampAnnotation()
Public Sub New
Remarks
The default font used is Arial 12 with a black font brush.
See Also

Reference

WpfRubberStampAnnotation Class
WpfRubberStampAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Constructor (RubberStampData)

Creates a new instance of WpfRubberStampAnnotation from an RubberStampData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRubberStampAnnotation(
    RubberStampData data
)
Public Sub New (
    data As RubberStampData
)

Parameters

data
Type: Atalasoft.AnnotateRubberStampData
The data object for the annotation.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfRubberStampAnnotation Class
WpfRubberStampAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Constructor (String, AnnotationFont, AnnotationBrush)

Creates a new instance of WpfRubberStampAnnotation specifying its text, font and font brush.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRubberStampAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush
)

Parameters

text
Type: SystemString
The text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
See Also

Reference

WpfRubberStampAnnotation Class
WpfRubberStampAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfRubberStampAnnotation specifying its text, font, font brush, fill and outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRubberStampAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

text
Type: SystemString
The text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the annotation outline.
See Also

Reference

WpfRubberStampAnnotation Class
WpfRubberStampAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, Double, Double)

Creates a new instance of WpfRubberStampAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRubberStampAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    double cornerRadius,
    double padding
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    cornerRadius As Double,
    padding As Double
)

Parameters

text
Type: SystemString
The text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used to render the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to render the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to render the annotation outline.
cornerRadius
Type: SystemDouble
The radius for the annotation corners.
padding
Type: SystemDouble
The amount of padding around the text.
See Also

Reference

WpfRubberStampAnnotation Class
WpfRubberStampAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Properties

The WpfRubberStampAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CornerRadius | Gets or sets the radius used to render rounded corners.
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Font | Gets or sets the font used to render the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline.
Public property | Padding | Gets or sets the amount of padding around the text.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.CornerRadius Property

WpfRubberStampAnnotationCornerRadius Property

Gets or sets the radius used to render rounded corners.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double CornerRadius { get; set; }
Public Property CornerRadius As Double
    Get
    Set

Property Value

Type: Double
The radius used to render rounded corners.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.Fill Property

WpfRubberStampAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
Remarks
Set this property to null (Nothing in VB) to remove the fill.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.Font Property

WpfRubberStampAnnotationFont Property

Gets or sets the font used to render the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used to render the text.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.FontBrush Property

WpfRubberStampAnnotationFontBrush Property

Gets or sets the brush used to render the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to render the text.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.Outline Property

WpfRubberStampAnnotationOutline Property

Gets or sets the pen used for the annotation outline.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The annotation outline.
Remarks
Set this property to null (Nothing in VB) to remove the outline.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.Padding Property

WpfRubberStampAnnotationPadding Property

Gets or sets the amount of padding around the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Padding { get; set; }
Public Property Padding As Double
    Get
    Set

Property Value

Type: Double
The amount of padding around the text.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.Text Property

WpfRubberStampAnnotationText Property

Gets or sets the text for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text for the annotation.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Methods

The WpfRubberStampAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from WpfAnnotationUI.)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.CloneOverride Method

WpfRubberStampAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.CreateDataSnapshotOverride Method

WpfRubberStampAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Events

The WpfRubberStampAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation Fields

The WpfRubberStampAnnotation type exposes the following members.

Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FontBrushProperty | Identifies the FontBrush dependency property.
FontProperty | Identifies the Font dependency property.
PaddingProperty | Identifies the Padding dependency property.
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.CornerRadiusProperty Field

WpfRubberStampAnnotationCornerRadiusProperty Field

Identifies the CornerRadius dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.FontBrushProperty Field

WpfRubberStampAnnotationFontBrushProperty Field

Identifies the FontBrush dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontBrushProperty
Public Shared ReadOnly FontBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.FontProperty Field

WpfRubberStampAnnotationFontProperty Field

Identifies the Font dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontProperty
Public Shared ReadOnly FontProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.PaddingProperty Field

WpfRubberStampAnnotationPaddingProperty Field

Identifies the Padding dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingProperty
Public Shared ReadOnly PaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfRubberStampAnnotation.TextProperty Field

WpfRubberStampAnnotationTextProperty Field

Identifies the Text dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfRubberStampAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Class

This annotation displays text which can be edited by the user.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.WpfWpfTextAnnotation

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfTextAnnotation : WpfAnnotationUI
Public Class WpfTextAnnotation
    Inherits WpfAnnotationUI

The WpfTextAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfTextAnnotation | Creates an instance of WpfTextAnnotation using default property values.
Public method | WpfTextAnnotation(String) | Creates a new instance of WpfTextAnnotation using the specified string.
Public method | WpfTextAnnotation(TextData) | Creates an instance of WpfTextAnnotation from a TextData object.
Public method | WpfTextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfTextAnnotation using the specified arguments.
Public method | WpfTextAnnotation(Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfTextAnnotation with the specified bounds and property values.
Public method | WpfTextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfTextAnnotation using the specified arguments.
Public method | WpfTextAnnotation(Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfTextAnnotation with the specified bounds and property values.
Public method | WpfTextAnnotation(Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point, Double, StringAlignment, StringAlignment) | Creates a new instance of WpfTextAnnotation with the specified bounds and property values.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text.
Public property | AllowEditing | Gets or sets a value indicating whether the text can be modified by double-clicking the annotation.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanEditMirrored | Gets or sets a value indicating whether the text will show mirrored while editing.
Public property | CanEditRotated | Gets or sets a value indicating whether the text will show rotated while editing.
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Overrides WpfAnnotationUIChildElement.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditMode | Gets or sets a value indicating whether the annotation is in edit mode.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation background.
Public property | Font | Gets or sets the font used for rendering the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | LineAlignment | Gets or sets the vertical alignment of the text.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline. This can be null (Nothing in VB).
Public property | Padding | Gets or sets the amount of padding used around the text.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow. This can be null (Nothing in VB).
Public property | ShadowOffset | Gets or sets the shadow offset from the annotation location.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the annotation text.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Protected method | HideEditBox | This method is called when the annotation is leaving "edit" mode.
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Overrides WpfAnnotationUIOnAnnotationBrushChanged(AnnotationBrush).)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Overrides WpfAnnotationUIOnAnnotationFontChanged(AnnotationFont).)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Overrides WpfAnnotationUIOnAnnotationPenChanged(AnnotationPen).)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Overrides WpfAnnotationUIOnCanvasChanged(ValueChangedEventArgsWpfAnnotationCanvas).)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Overrides WpfAnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Protected method | ShowEditBox | This method is called when the annotation is entering "edit" mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AllowEditingProperty | Identifies the AllowEditing dependency property.
CanEditMirroredProperty | Identifies the CanEditMirrored dependency property.
CanEditRotatedProperty | Identifies the CanEditRotated dependency property.
EditModeProperty | Identifies the EditMode dependency property.
FontBrushProperty | Identifies the FontBrush dependency property.
FontProperty | Identifies the Font dependency property.
LineAlignmentProperty | Identifies the LineAlignment dependency property.
PaddingProperty | Identifies the Padding dependency property.
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfTextAnnotation | Creates an instance of WpfTextAnnotation using default property values.
Public method | WpfTextAnnotation(String) | Creates a new instance of WpfTextAnnotation using the specified string.
Public method | WpfTextAnnotation(TextData) | Creates an instance of WpfTextAnnotation from a TextData object.
Public method | WpfTextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfTextAnnotation using the specified arguments.
Public method | WpfTextAnnotation(Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfTextAnnotation with the specified bounds and property values.
Public method | WpfTextAnnotation(String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfTextAnnotation using the specified arguments.
Public method | WpfTextAnnotation(Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point) | Creates a new instance of WpfTextAnnotation with the specified bounds and property values.
Public method | WpfTextAnnotation(Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point, Double, StringAlignment, StringAlignment) | Creates a new instance of WpfTextAnnotation with the specified bounds and property values.
Top
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor

Creates an instance of WpfTextAnnotation using default property values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation()
Public Sub New
Remarks
The default properties used are an Arial 12px font, black text, a white background with black outline.
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (String)

Creates a new instance of WpfTextAnnotation using the specified string.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The default text for the annotation.
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (TextData)

Creates an instance of WpfTextAnnotation from a TextData object.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    TextData data
)
Public Sub New (
    data As TextData
)

Parameters

data
Type: Atalasoft.AnnotateTextData
The TextData object to pull property values from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the data argument is null (Nothing in VB).
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfTextAnnotation using the specified arguments.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

text
Type: SystemString
The default text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the outline. This can be null (Nothing in VB).
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfTextAnnotation with the specified bounds and property values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    Rect bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    bounds As Rect,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

bounds
Type: System.WindowsRect
The bounding rectangle of the annotation.
text
Type: SystemString
The default text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the outline. This can be null (Nothing in VB).
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point)

Creates a new instance of WpfTextAnnotation using the specified arguments.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

text
Type: SystemString
The default text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the outline. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
A point specifying the shadow placement relative to the annotation.
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point)

Creates a new instance of WpfTextAnnotation with the specified bounds and property values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    Rect bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset
)
Public Sub New (
    bounds As Rect,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point
)

Parameters

bounds
Type: System.WindowsRect
The bounding rectangle of the annotation.
text
Type: SystemString
The default text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the outline. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
A point specifying the shadow placement relative to the annotation.
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Constructor (Rect, String, AnnotationFont, AnnotationBrush, AnnotationBrush, AnnotationPen, AnnotationBrush, Point, Double, StringAlignment, StringAlignment)

Creates a new instance of WpfTextAnnotation with the specified bounds and property values.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotation(
    Rect bounds,
    string text,
    AnnotationFont font,
    AnnotationBrush fontBrush,
    AnnotationBrush fill,
    AnnotationPen outline,
    AnnotationBrush shadow,
    Point shadowOffset,
    double padding,
    StringAlignment alignement,
    StringAlignment lineAlignment
)
Public Sub New (
    bounds As Rect,
    text As String,
    font As AnnotationFont,
    fontBrush As AnnotationBrush,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    shadow As AnnotationBrush,
    shadowOffset As Point,
    padding As Double,
    alignement As StringAlignment,
    lineAlignment As StringAlignment
)

Parameters

bounds
Type: System.WindowsRect
The bounding rectangle of the annotation.
text
Type: SystemString
The default text of the annotation.
font
Type: Atalasoft.AnnotateAnnotationFont
The font used for the text.
fontBrush
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the text.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This can be null (Nothing in VB).
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the outline. This can be null (Nothing in VB).
shadow
Type: Atalasoft.AnnotateAnnotationBrush
The brush used for the annotation shadow. This can be null (Nothing in VB).
shadowOffset
Type: System.WindowsPoint
A point specifying the shadow placement relative to the annotation.
padding
Type: SystemDouble
The amount of padding between the annotation border and its text.
alignement
Type: System.DrawingStringAlignment
The horizontal alignment of the text.
lineAlignment
Type: System.DrawingStringAlignment
The vertical alignment of the text.
See Also

Reference

WpfTextAnnotation Class
WpfTextAnnotation Overload
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Properties

The WpfTextAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text.
Public property | AllowEditing | Gets or sets a value indicating whether the text can be modified by double-clicking the annotation.
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanEditMirrored | Gets or sets a value indicating whether the text will show mirrored while editing.
Public property | CanEditRotated | Gets or sets a value indicating whether the text will show rotated while editing.
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Overrides WpfAnnotationUIChildElement.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | EditMode | Gets or sets a value indicating whether the annotation is in edit mode.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation background.
Public property | Font | Gets or sets the font used for rendering the text.
Public property | FontBrush | Gets or sets the brush used to render the text.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | LineAlignment | Gets or sets the vertical alignment of the text.
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used for the annotation outline. This can be null (Nothing in VB).
Public property | Padding | Gets or sets the amount of padding used around the text.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Shadow | Gets or sets the brush used for the annotation shadow. This can be null (Nothing in VB).
Public property | ShadowOffset | Gets or sets the shadow offset from the annotation location.
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the annotation text.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Alignment Property

WpfTextAnnotationAlignment Property

Gets or sets the horizontal alignment of the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment Alignment { get; set; }
Public Property Alignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The horizontal alignment of the text.
Remarks
This property defaults to System.Drawing.StringAlignment.Near.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.AllowEditing Property

WpfTextAnnotationAllowEditing Property

Gets or sets a value indicating whether the text can be modified by double-clicking the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEditing { get; set; }
Public Property AllowEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the text can be modified by double-clicking the annotation.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.CanEditMirrored Property

WpfTextAnnotationCanEditMirrored Property

Gets or sets a value indicating whether the text will show mirrored while editing.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanEditMirrored { get; set; }
Public Property CanEditMirrored As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the text will show mirrored while editing.
Remarks
If this property is false, the TextBox used for editing will display the text without the mirror effect.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.CanEditRotated Property

WpfTextAnnotationCanEditRotated Property

Gets or sets a value indicating whether the text will show rotated while editing.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanEditRotated { get; set; }
Public Property CanEditRotated As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the text will show rotated while editing.
Remarks
If this property is false, the TextBox used for editing will display unrotated.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.ChildElement Property

WpfTextAnnotationChildElement Property

Gets the child UIElement of the annotation, if any.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UIElement ChildElement { get; }
Public Overrides ReadOnly Property ChildElement As UIElement
    Get

Property Value

Type: UIElement
The child UIElement of the annotation or null (Nothing in VB).
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.EditMode Property

WpfTextAnnotationEditMode Property

Gets or sets a value indicating whether the annotation is in edit mode.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EditMode { get; set; }
Public Property EditMode As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the annotation is in edit mode.
Remarks
When the annotation is in edit mode, a TextBox control is shown to allow the end-user to modify the text.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Fill Property

WpfTextAnnotationFill Property

Gets or sets the brush used to fill the annotation background.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation background.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Font Property

WpfTextAnnotationFont Property

Gets or sets the font used for rendering the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationFont Font { get; set; }
Public Property Font As AnnotationFont
    Get
    Set

Property Value

Type: AnnotationFont
The font used for rendering the text.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.FontBrush Property

WpfTextAnnotationFontBrush Property

Gets or sets the brush used to render the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush FontBrush { get; set; }
Public Property FontBrush As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to render the text.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.LineAlignment Property

WpfTextAnnotationLineAlignment Property

Gets or sets the vertical alignment of the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment LineAlignment { get; set; }
Public Property LineAlignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The vertical alignment of the text.
Remarks
This property defaults to System.Drawing.StringAlignment.Near.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Outline Property

WpfTextAnnotationOutline Property

Gets or sets the pen used for the annotation outline. This can be null (Nothing in VB).

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the annotation outline.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Padding Property

WpfTextAnnotationPadding Property

Gets or sets the amount of padding used around the text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Padding { get; set; }
Public Property Padding As Double
    Get
    Set

Property Value

Type: Double
The amount of padding around the text.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Shadow Property

WpfTextAnnotationShadow Property

Gets or sets the brush used for the annotation shadow. This can be null (Nothing in VB).

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Shadow { get; set; }
Public Property Shadow As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used for the annotation shadow.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.ShadowOffset Property

WpfTextAnnotationShadowOffset Property

Gets or sets the shadow offset from the annotation location.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ShadowOffset { get; set; }
Public Property ShadowOffset As Point
    Get
    Set

Property Value

Type: Point
The shadow offset from the annotation location.
Remarks
A negative value will move the shadow to the left and up while a positive value moves the shadow to the right and down.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.Text Property

WpfTextAnnotationText Property

Gets or sets the annotation text.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The annotation text.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Methods

The WpfTextAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Protected method | HideEditBox | This method is called when the annotation is leaving "edit" mode.
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Overrides WpfAnnotationUIOnAnnotationBrushChanged(AnnotationBrush).)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Overrides WpfAnnotationUIOnAnnotationFontChanged(AnnotationFont).)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Overrides WpfAnnotationUIOnAnnotationPenChanged(AnnotationPen).)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Overrides WpfAnnotationUIOnCanvasChanged(ValueChangedEventArgsWpfAnnotationCanvas).)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Overrides WpfAnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Protected method | ShowEditBox | This method is called when the annotation is entering "edit" mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.CloneOverride Method

WpfTextAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.CreateDataSnapshotOverride Method

WpfTextAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.HideEditBox Method

WpfTextAnnotationHideEditBox Method

This method is called when the annotation is leaving "edit" mode.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void HideEditBox()
Protected Overridable Sub HideEditBox
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnAnnotationBrushChanged Method

WpfTextAnnotationOnAnnotationBrushChanged Method

Called when the FillProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationBrushChanged(
    AnnotationBrush annotationBrush
)
Protected Overrides Sub OnAnnotationBrushChanged (
    annotationBrush As AnnotationBrush
)

Parameters

annotationBrush
Type: Atalasoft.AnnotateAnnotationBrush
The new AnnotationBrush for the fill.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnAnnotationFontChanged Method

WpfTextAnnotationOnAnnotationFontChanged Method

Called when the FontProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationFontChanged(
    AnnotationFont annotationFont
)
Protected Overrides Sub OnAnnotationFontChanged (
    annotationFont As AnnotationFont
)

Parameters

annotationFont
Type: Atalasoft.AnnotateAnnotationFont
The new AnnotationFont.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnAnnotationPenChanged Method

WpfTextAnnotationOnAnnotationPenChanged Method

Called when the OutlineProperty has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnAnnotationPenChanged(
    AnnotationPen annotationPen
)
Protected Overrides Sub OnAnnotationPenChanged (
    annotationPen As AnnotationPen
)

Parameters

annotationPen
Type: Atalasoft.AnnotateAnnotationPen
The new AnnotationPen for the outline.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnCanvasChanged Method

WpfTextAnnotationOnCanvasChanged Method

Called when the Canvas property has changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnCanvasChanged(
    ValueChangedEventArgs<WpfAnnotationCanvas> e
)
Protected Overrides Sub OnCanvasChanged (
    e As ValueChangedEventArgs(Of WpfAnnotationCanvas)
)

Parameters

e
Type: Atalasoft.Annotate.WpfValueChangedEventArgs WpfAnnotationCanvas
An EventArgs for this change.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnMouseDown Method

WpfTextAnnotationOnMouseDown Method

Called when a MouseDown event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs for the event.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnMouseUp Method

WpfTextAnnotationOnMouseUp Method

Called when a MouseUp event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for the event.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnPropertyChanged Method

WpfTextAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.OnSelectedChanged Method

WpfTextAnnotationOnSelectedChanged Method

Called when the Selected property has been changed.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSelectedChanged(
    EventArgs e
)
Protected Overrides Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.ShowEditBox Method

WpfTextAnnotationShowEditBox Method

This method is called when the annotation is entering "edit" mode.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ShowEditBox()
Protected Overridable Sub ShowEditBox
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Events

The WpfTextAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation Fields

The WpfTextAnnotation type exposes the following members.

Fields
Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AllowEditingProperty | Identifies the AllowEditing dependency property.
CanEditMirroredProperty | Identifies the CanEditMirrored dependency property.
CanEditRotatedProperty | Identifies the CanEditRotated dependency property.
EditModeProperty | Identifies the EditMode dependency property.
FontBrushProperty | Identifies the FontBrush dependency property.
FontProperty | Identifies the Font dependency property.
LineAlignmentProperty | Identifies the LineAlignment dependency property.
PaddingProperty | Identifies the Padding dependency property.
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.AlignmentProperty Field

WpfTextAnnotationAlignmentProperty Field

Identifies the Alignment dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AlignmentProperty
Public Shared ReadOnly AlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.AllowEditingProperty Field

WpfTextAnnotationAllowEditingProperty Field

Identifies the AllowEditing dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AllowEditingProperty
Public Shared ReadOnly AllowEditingProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.CanEditMirroredProperty Field

WpfTextAnnotationCanEditMirroredProperty Field

Identifies the CanEditMirrored dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanEditMirroredProperty
Public Shared ReadOnly CanEditMirroredProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.CanEditRotatedProperty Field

WpfTextAnnotationCanEditRotatedProperty Field

Identifies the CanEditRotated dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanEditRotatedProperty
Public Shared ReadOnly CanEditRotatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.EditModeProperty Field

WpfTextAnnotationEditModeProperty Field

Identifies the EditMode dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty EditModeProperty
Public Shared ReadOnly EditModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.FontBrushProperty Field

WpfTextAnnotationFontBrushProperty Field

Identifies the FontBrush dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontBrushProperty
Public Shared ReadOnly FontBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.FontProperty Field

WpfTextAnnotationFontProperty Field

Identifies the Font dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FontProperty
Public Shared ReadOnly FontProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.LineAlignmentProperty Field

WpfTextAnnotationLineAlignmentProperty Field

Identifies the LineAlignment dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineAlignmentProperty
Public Shared ReadOnly LineAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.PaddingProperty Field

WpfTextAnnotationPaddingProperty Field

Identifies the Padding dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingProperty
Public Shared ReadOnly PaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfTextAnnotation.TextProperty Field

WpfTextAnnotationTextProperty Field

Identifies the Text dependency property.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfTextAnnotation Class
Atalasoft.Annotate.Wpf Namespace


WpfVisualScaleMode Enumeration

Indicates the type of scaling performed by the GenerateVisual and CreateVisual methods.

Namespace: Atalasoft.Annotate.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WpfVisualScaleMode
Public Enumeration WpfVisualScaleMode
Members
Member name | Description
None | No scaling is performed.
ScaleToFit | The annotations are scaled to fit the specified area.
ScaleToFill | The annotations are scaled to fill the area, which may result in some annotations rendering outside the bounds.
StretchToFill | The annotations are stretched to fill the area, ignoring the annotation aspect ratio.
See Also

Reference

Atalasoft.Annotate.Wpf Namespace


Atalasoft.Annotate.Wpf.Pdf Namespace

Classes
 | Class | Description
Public class | WpfPdfAnnotation | This is the base PDF annotation class all WPF PDF annotations derive from. This class should not be created directly.
Public class | WpfPdfLineAnnotation | This class represents a PDF line annotation. While similar to a standard line annotation, the PDF version includes a caption which is centered within or above the line (if the text is too long to fit within).
Public class | WpfPdfLineAnnotationRenderingEngine | This class is the rendering engine for a WpfPdfLineAnnotation.
Public class | WpfPdfMarkupAnnotation | This class represents a PDF markup annotation, such as underline, squiggly, strikeout and highlight.
Public class | WpfPdfMarkupAnnotationRenderingEngine | This class is used to render the WpfPdfMarkupAnnotation.
Public class | WpfPdfPopupWindow | Interaction logic for WpfPdfPopupWindow.xaml


WpfPdfAnnotation Class

This is the base PDF annotation class all WPF PDF annotations derive from. This class should not be created directly.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.Wpf.PdfWpfPdfAnnotation
Atalasoft.Annotate.Wpf.PdfWpfPdfLineAnnotation
Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class WpfPdfAnnotation : WpfAnnotationUI
Public MustInherit Class WpfPdfAnnotation
    Inherits WpfAnnotationUI

The WpfPdfAnnotation type exposes the following members.

Constructors
 | Name | Description
Protected method | WpfPdfAnnotation | Creates a new instance of WpfPdfAnnotation.
Protected method | WpfPdfAnnotation(PdfAnnotationData) | Creates a new instance of WpfPdfAnnotation from a PdfAnnotationData class.
Protected method | WpfPdfAnnotation(AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of WpfPdfAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Inherited from WpfAnnotationUI.)
Public method | ClosePopup | This method is called to close the popup dialog.
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Inherited from WpfAnnotationUI.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Overrides WpfAnnotationUIOnCanvasChanged(ValueChangedEventArgsWpfAnnotationCanvas).)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPopupClosing | This method is called when the default dialog is closing.
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShowPopup | This method is called to display a popup dialog for the PDF annotation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateToolTip | Sets the ToolTip property for the annotation.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Constructor

Overload List
 | Name | Description
Protected method | WpfPdfAnnotation | Creates a new instance of WpfPdfAnnotation.
Protected method | WpfPdfAnnotation(PdfAnnotationData) | Creates a new instance of WpfPdfAnnotation from a PdfAnnotationData class.
Protected method | WpfPdfAnnotation(AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of WpfPdfAnnotation specifying its properties.
Top
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Constructor

Creates a new instance of WpfPdfAnnotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfPdfAnnotation()
Protected Sub New
See Also

Reference

WpfPdfAnnotation Class
WpfPdfAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Constructor (PdfAnnotationData)

Creates a new instance of WpfPdfAnnotation from a PdfAnnotationData class.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfPdfAnnotation(
    PdfAnnotationData data
)
Protected Sub New (
    data As PdfAnnotationData
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfAnnotationData
The annotation data for this object.
See Also

Reference

WpfPdfAnnotation Class
WpfPdfAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Constructor (AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of WpfPdfAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WpfPdfAnnotation(
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Protected Sub New (
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

fill
Type: Atalasoft.AnnotateAnnotationBrush
The fill for the annotation.
outline
Type: Atalasoft.AnnotateAnnotationPen
The outline for the annotation.
text
Type: SystemString
The text of the annotation.
username
Type: SystemString
The name of the user that created/modified the annotation.
modifiedDate
Type: SystemDateTime
The last modified date for the annotation.
See Also

Reference

WpfPdfAnnotation Class
WpfPdfAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Properties

The WpfPdfAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation.
Public property | Geometry | Gets a Geometry representing the annotation. (Inherited from WpfAnnotationUI.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the annotation outline.
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the text for the annotation.
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.Fill Property

WpfPdfAnnotationFill Property

Gets or sets the brush used to fill the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBrush Fill { get; set; }
Public Property Fill As AnnotationBrush
    Get
    Set

Property Value

Type: AnnotationBrush
The brush used to fill the annotation.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.Outline Property

WpfPdfAnnotationOutline Property

Gets or sets the pen used to draw the annotation outline.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPen Outline { get; set; }
Public Property Outline As AnnotationPen
    Get
    Set

Property Value

Type: AnnotationPen
The pen used for the outline.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.Text Property

WpfPdfAnnotationText Property

Gets or sets the text for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text for the annotation.
Remarks
This text is displayed in tooltips and as the WpfPdfLineAnnotation's caption. The default popup dialog does not update this value until the dialog has been closed.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Methods

The WpfPdfAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Inherited from WpfAnnotationUI.)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Inherited from WpfAnnotationUI.)
Public method | ClosePopup | This method is called to close the popup dialog.
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Inherited from WpfAnnotationUI.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Overrides WpfAnnotationUIOnCanvasChanged(ValueChangedEventArgsWpfAnnotationCanvas).)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfAnnotationUIOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Called when a MouseDown event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Inherited from WpfAnnotationUI.)
Protected method | OnMouseUp | Called when a MouseUp event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPopupClosing | This method is called when the default dialog is closing.
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfAnnotationUIOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShowPopup | This method is called to display a popup dialog for the PDF annotation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateToolTip | Sets the ToolTip property for the annotation.
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.ClosePopup Method

WpfPdfAnnotationClosePopup Method

This method is called to close the popup dialog.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ClosePopup()
Public Overridable Sub ClosePopup
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.OnCanvasChanged Method

WpfPdfAnnotationOnCanvasChanged Method

Called when the Canvas property has changed.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnCanvasChanged(
    ValueChangedEventArgs<WpfAnnotationCanvas> e
)
Protected Overrides Sub OnCanvasChanged (
    e As ValueChangedEventArgs(Of WpfAnnotationCanvas)
)

Parameters

e
Type: Atalasoft.Annotate.WpfValueChangedEventArgs WpfAnnotationCanvas
An EventArgs for this change.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.OnGripPositionChanged Method

WpfPdfAnnotationOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overrides Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.OnMouseDown Method

WpfPdfAnnotationOnMouseDown Method

Called when a MouseDown event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs for the event.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.OnMouseUp Method

WpfPdfAnnotationOnMouseUp Method

Called when a MouseUp event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for the event.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.OnPopupClosing Method

WpfPdfAnnotationOnPopupClosing Method

This method is called when the default dialog is closing.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPopupClosing(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnPopupClosing (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
The dialog being closed.
e
Type: SystemEventArgs
An event args for this event.
Remarks
This is called by the default popup dialog. If a custom dialog is used, this method will not be called.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.OnPropertyChanged Method

WpfPdfAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.ShowPopup Method

WpfPdfAnnotationShowPopup Method

This method is called to display a popup dialog for the PDF annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ShowPopup()
Public Overridable Sub ShowPopup
Remarks
The default dialog is a simply tool window with a textbox for editing.
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.UpdateToolTip Method

WpfPdfAnnotationUpdateToolTip Method

Sets the ToolTip property for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void UpdateToolTip()
Protected Sub UpdateToolTip
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Events

The WpfPdfAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation Fields

The WpfPdfAnnotation type exposes the following members.

Fields
Name | Description
TextProperty | Identifies the Text dependency property.
Top
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfAnnotation.TextProperty Field

WpfPdfAnnotationTextProperty Field

Identifies the Text dependency property.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfPdfAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Class

This class represents a PDF line annotation. While similar to a standard line annotation, the PDF version includes a caption which is centered within or above the line (if the text is too long to fit within).
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.Wpf.PdfWpfPdfAnnotation
Atalasoft.Annotate.Wpf.PdfWpfPdfLineAnnotation

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPdfLineAnnotation : WpfPdfAnnotation
Public Class WpfPdfLineAnnotation
    Inherits WpfPdfAnnotation

The WpfPdfLineAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPdfLineAnnotation | Creates a new instance of WpfPdfLineAnnotation using the WpfAnnotationUI.DefaultOutline.
Public method | WpfPdfLineAnnotation(PdfLineData) | Creates a new instance of WpfPdfLineAnnotation from a PdfLineData object.
Public method | WpfPdfLineAnnotation(Point, Point, Boolean, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfPdfLineAnnotation specifying its points, fill and outline.
Public method | WpfPdfLineAnnotation(Point, Point, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of WpfPdfLineAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayCaption | Gets or sets a value indicating whether the text caption will be shown.
Public property | EndPoint | Gets or sets the ending point of the line.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation. (Inherited from WpfPdfAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the annotation outline. (Inherited from WpfPdfAnnotation.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | StartPoint | Gets or sets the starting point of the line.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from WpfPdfAnnotation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | ClosePopup | This method is called to close the popup dialog. (Inherited from WpfPdfAnnotation.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfPdfAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfPdfAnnotationOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides WpfPdfAnnotationOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides WpfPdfAnnotationOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPopupClosing | This method is called when the default dialog is closing. (Inherited from WpfPdfAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfPdfAnnotationOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShowPopup | This method is called to display a popup dialog for the PDF annotation. (Inherited from WpfPdfAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateToolTip | Sets the ToolTip property for the annotation. (Inherited from WpfPdfAnnotation.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
DisplayCaptionProperty | Identifies the DisplayCaption dependency property.
EndPointProperty | Identifies the EndPoint dependency property.
StartPointProperty | Identifies the StartPoint dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfPdfLineAnnotation | Creates a new instance of WpfPdfLineAnnotation using the WpfAnnotationUI.DefaultOutline.
Public method | WpfPdfLineAnnotation(PdfLineData) | Creates a new instance of WpfPdfLineAnnotation from a PdfLineData object.
Public method | WpfPdfLineAnnotation(Point, Point, Boolean, AnnotationBrush, AnnotationPen) | Creates a new instance of WpfPdfLineAnnotation specifying its points, fill and outline.
Public method | WpfPdfLineAnnotation(Point, Point, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of WpfPdfLineAnnotation specifying its properties.
Top
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Constructor

Creates a new instance of WpfPdfLineAnnotation using the WpfAnnotationUI.DefaultOutline.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfLineAnnotation()
Public Sub New
See Also

Reference

WpfPdfLineAnnotation Class
WpfPdfLineAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Constructor (PdfLineData)

Creates a new instance of WpfPdfLineAnnotation from a PdfLineData object.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfLineAnnotation(
    PdfLineData data
)
Public Sub New (
    data As PdfLineData
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfLineData
The data object for this annotation.
See Also

Reference

WpfPdfLineAnnotation Class
WpfPdfLineAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Constructor (Point, Point, Boolean, AnnotationBrush, AnnotationPen)

Creates a new instance of WpfPdfLineAnnotation specifying its points, fill and outline.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfLineAnnotation(
    Point startPoint,
    Point endPoint,
    bool displayCaption,
    AnnotationBrush fill,
    AnnotationPen outline
)
Public Sub New (
    startPoint As Point,
    endPoint As Point,
    displayCaption As Boolean,
    fill As AnnotationBrush,
    outline As AnnotationPen
)

Parameters

startPoint
Type: System.WindowsPoint
The starting point of the line in annotation space.
endPoint
Type: System.WindowsPoint
The ending point of the line in annotation space.
displayCaption
Type: SystemBoolean
Indicates whether the caption will be displayed.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the line cap. This can be null.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the line.
See Also

Reference

WpfPdfLineAnnotation Class
WpfPdfLineAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Constructor (Point, Point, Boolean, AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of WpfPdfLineAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfLineAnnotation(
    Point startPoint,
    Point endPoint,
    bool displayCaption,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    startPoint As Point,
    endPoint As Point,
    displayCaption As Boolean,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

startPoint
Type: System.WindowsPoint
The starting point of the line in annotation space.
endPoint
Type: System.WindowsPoint
The ending point of the line in annotation space.
displayCaption
Type: SystemBoolean
Indicates whether the caption will be displayed.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the line cap. This can be null.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used for the line.
text
Type: SystemString
The text for the caption.
username
Type: SystemString
The name of the creator.
modifiedDate
Type: SystemDateTime
The last modified date for the annotation.
See Also

Reference

WpfPdfLineAnnotation Class
WpfPdfLineAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Properties

The WpfPdfLineAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayCaption | Gets or sets a value indicating whether the text caption will be shown.
Public property | EndPoint | Gets or sets the ending point of the line.
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation. (Inherited from WpfPdfAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the annotation outline. (Inherited from WpfPdfAnnotation.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | StartPoint | Gets or sets the starting point of the line.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Overrides WpfAnnotationUISupportsMultiClickCreation.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from WpfPdfAnnotation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.DisplayCaption Property

WpfPdfLineAnnotationDisplayCaption Property

Gets or sets a value indicating whether the text caption will be shown.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayCaption { get; set; }
Public Property DisplayCaption As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the caption will be shown.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.EndPoint Property

WpfPdfLineAnnotationEndPoint Property

Gets or sets the ending point of the line.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point EndPoint { get; set; }
Public Property EndPoint As Point
    Get
    Set

Property Value

Type: Point
The ending point of the line.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.Geometry Property

WpfPdfLineAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.StartPoint Property

WpfPdfLineAnnotationStartPoint Property

Gets or sets the starting point of the line.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point StartPoint { get; set; }
Public Property StartPoint As Point
    Get
    Set

Property Value

Type: Point
The starting point of the line.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.SupportsMultiClickCreation Property

WpfPdfLineAnnotationSupportsMultiClickCreation Property

Gets a value indicating whether the annotation supports being created from multiple mouse clicks.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool SupportsMultiClickCreation { get; }
Public Overrides ReadOnly Property SupportsMultiClickCreation As Boolean
    Get

Property Value

Type: Boolean
Indicates whether the annotation supports being created from multiple mouse clicks.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Methods

The WpfPdfLineAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | ClosePopup | This method is called to close the popup dialog. (Inherited from WpfPdfAnnotation.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfPdfAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfPdfAnnotationOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides WpfPdfAnnotationOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides WpfPdfAnnotationOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPopupClosing | This method is called when the default dialog is closing. (Inherited from WpfPdfAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfPdfAnnotationOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Inherited from WpfAnnotationUI.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Inherited from WpfAnnotationUI.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShowPopup | This method is called to display a popup dialog for the PDF annotation. (Inherited from WpfPdfAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateToolTip | Sets the ToolTip property for the annotation. (Inherited from WpfPdfAnnotation.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.AttachGripsOverride Method

WpfPdfLineAnnotationAttachGripsOverride Method

Called when the annotation grips need to be created.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationGrips AttachGripsOverride(
    WpfAnnotationCanvas canvas
)
Protected Overrides Function AttachGripsOverride (
    canvas As WpfAnnotationCanvas
) As WpfAnnotationGrips

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.

Return Value

Type: WpfAnnotationGrips
The grips for the annotation.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.CloneOverride Method

WpfPdfLineAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.CreateDataSnapshotOverride Method

WpfPdfLineAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.OnGripPositionChanged Method

WpfPdfLineAnnotationOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overrides Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.OnMouseDown Method

WpfPdfLineAnnotationOnMouseDown Method

Raises the MouseDown event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs instance containing the event data.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.OnMouseMove Method

WpfPdfLineAnnotationOnMouseMove Method

Called when a MouseMove event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for the event.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.OnMouseUp Method

WpfPdfLineAnnotationOnMouseUp Method

Raises the MouseUp event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs instance containing the event data.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.OnPropertyChanged Method

WpfPdfLineAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Events

The WpfPdfLineAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation Fields

The WpfPdfLineAnnotation type exposes the following members.

Fields
Name | Description
DisplayCaptionProperty | Identifies the DisplayCaption dependency property.
EndPointProperty | Identifies the EndPoint dependency property.
StartPointProperty | Identifies the StartPoint dependency property.
Top
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.DisplayCaptionProperty Field

WpfPdfLineAnnotationDisplayCaptionProperty Field

Identifies the DisplayCaption dependency property.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayCaptionProperty
Public Shared ReadOnly DisplayCaptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.EndPointProperty Field

WpfPdfLineAnnotationEndPointProperty Field

Identifies the EndPoint dependency property.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndPointProperty
Public Shared ReadOnly EndPointProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotation.StartPointProperty Field

WpfPdfLineAnnotationStartPointProperty Field

Identifies the StartPoint dependency property.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartPointProperty
Public Shared ReadOnly StartPointProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfPdfLineAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotationRenderingEngine Class

This class is the rendering engine for a WpfPdfLineAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfPdfLineAnnotation
Atalasoft.Annotate.Wpf.PdfWpfPdfLineAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPdfLineAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfPdfLineAnnotation>
Public Class WpfPdfLineAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfPdfLineAnnotation)

The WpfPdfLineAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPdfLineAnnotationRenderingEngine | Creates a new instance of WpfPdfLineAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotationRenderingEngine Constructor

Creates a new instance of WpfPdfLineAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfLineAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfPdfLineAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotationRenderingEngine Methods

The WpfPdfLineAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfPdfLineAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfLineAnnotationRenderingEngine.OnRenderAnnotation Method

WpfPdfLineAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfPdfLineAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfPdfLineAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfLineAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfPdfLineAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Class

This class represents a PDF markup annotation, such as underline, squiggly, strikeout and highlight.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
Atalasoft.Annotate.WpfWpfAnnotationUI
Atalasoft.Annotate.Wpf.PdfWpfPdfAnnotation
Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPdfMarkupAnnotation : WpfPdfAnnotation
Public Class WpfPdfMarkupAnnotation
    Inherits WpfPdfAnnotation

The WpfPdfMarkupAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPdfMarkupAnnotation | Creates a new instance of WpfPdfMarkupAnnotation using default values.
Public method | WpfPdfMarkupAnnotation(PdfMarkupData) | Creates a new instance of WpfPdfMarkupAnnotation from a PdfMarkupData object.
Public method | WpfPdfMarkupAnnotation(QuadrilateralF, PdfMarkupType) | Creates a new instance of WpfPdfMarkupAnnotation specifying the QuadrilateralF array and markup type.
Public method | WpfPdfMarkupAnnotation(QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of WpfPdfMarkupAnnotation specifying its properties.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation. (Inherited from WpfPdfAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | MarkupType | Gets or sets the annotation markup type.
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the annotation outline. (Inherited from WpfPdfAnnotation.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | Quadrilaterals | Gets the QuadrilateralFCollection holding the quadrilaterals for the annotation.
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | SquigglyHeight | Gets or set the height of the squiggly line.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from WpfPdfAnnotation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UnSelectedGeometry | Gets the geometry of the annotation without the selection dashes.
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | ClosePopup | This method is called to close the popup dialog. (Inherited from WpfPdfAnnotation.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfPdfAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfPdfAnnotationOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides WpfPdfAnnotationOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides WpfPdfAnnotationOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPopupClosing | This method is called when the default dialog is closing. (Inherited from WpfPdfAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfPdfAnnotationOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Overrides WpfAnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Overrides WpfAnnotationUIOperationRequest(OperationRequestInformation).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShowPopup | This method is called to display a popup dialog for the PDF annotation. (Inherited from WpfPdfAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateToolTip | Sets the ToolTip property for the annotation. (Inherited from WpfPdfAnnotation.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
Fields
Name | Description
MarkupTypeProperty | Identifies the MarkupType dependency property.
SquigglyHeightProperty | Identifies the SquigglyHeight dependency property.
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Constructor

Overload List
 | Name | Description
Public method | WpfPdfMarkupAnnotation | Creates a new instance of WpfPdfMarkupAnnotation using default values.
Public method | WpfPdfMarkupAnnotation(PdfMarkupData) | Creates a new instance of WpfPdfMarkupAnnotation from a PdfMarkupData object.
Public method | WpfPdfMarkupAnnotation(QuadrilateralF, PdfMarkupType) | Creates a new instance of WpfPdfMarkupAnnotation specifying the QuadrilateralF array and markup type.
Public method | WpfPdfMarkupAnnotation(QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime) | Creates a new instance of WpfPdfMarkupAnnotation specifying its properties.
Top
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Constructor

Creates a new instance of WpfPdfMarkupAnnotation using default values.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfMarkupAnnotation()
Public Sub New
Remarks
PdfMarkupType.Underline, WpfAnnotationUI.DefaultFill and WpfAnnotationUI.DefaultOutline will be used for the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
WpfPdfMarkupAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Constructor (PdfMarkupData)

Creates a new instance of WpfPdfMarkupAnnotation from a PdfMarkupData object.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfMarkupAnnotation(
    PdfMarkupData data
)
Public Sub New (
    data As PdfMarkupData
)

Parameters

data
Type: Atalasoft.Annotate.PdfPdfMarkupData
The data object used to create the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
WpfPdfMarkupAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Constructor (QuadrilateralF[], PdfMarkupType)

WpfPdfMarkupAnnotation Constructor (QuadrilateralF, PdfMarkupType)

Creates a new instance of WpfPdfMarkupAnnotation specifying the QuadrilateralF array and markup type.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfMarkupAnnotation(
    QuadrilateralF[] quads,
    PdfMarkupType markup
)
Public Sub New (
    quads As QuadrilateralF(),
    markup As PdfMarkupType
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
An array of QuadrilateralF for the annotation.
markup
Type: Atalasoft.Annotate.PdfPdfMarkupType
The markup type for the annotation.
Remarks
WpfAnnotationUI.DefaultFill and WpfAnnotationUI.DefaultOutline will be used for the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
WpfPdfMarkupAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Constructor (QuadrilateralF[], PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime)

WpfPdfMarkupAnnotation Constructor (QuadrilateralF, PdfMarkupType, AnnotationBrush, AnnotationPen, String, String, DateTime)

Creates a new instance of WpfPdfMarkupAnnotation specifying its properties.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfMarkupAnnotation(
    QuadrilateralF[] quads,
    PdfMarkupType markup,
    AnnotationBrush fill,
    AnnotationPen outline,
    string text,
    string username,
    DateTime modifiedDate
)
Public Sub New (
    quads As QuadrilateralF(),
    markup As PdfMarkupType,
    fill As AnnotationBrush,
    outline As AnnotationPen,
    text As String,
    username As String,
    modifiedDate As DateTime
)

Parameters

quads
Type: Atalasoft.Utils.GeometryQuadrilateralF
An array of QuadrilateralF for the annotation.
markup
Type: Atalasoft.Annotate.PdfPdfMarkupType
The markup type for the annotation.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the annotation. This may be null.
outline
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the outline of the annotation. This may be null.
text
Type: SystemString
The text for the annotation.
username
Type: SystemString
The user that created the annotation.
modifiedDate
Type: SystemDateTime
The last modified date of the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
WpfPdfMarkupAnnotation Overload
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Properties

The WpfPdfMarkupAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of this annotation. (Inherited from WpfAnnotationUI.)
Public property | CanMirror | Gets or sets a value indicating whether the annotation can be mirrored by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanMove | Gets or sets a value indicating whether the annotation can be moved by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanResize | Gets or sets a value indicating whether the annotation can be resized by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanRotate | Gets or sets a value indicating whether the annotation can be rotated by the end-user. (Inherited from WpfAnnotationUI.)
Public property | CanSelect | Gets or sets a value indicating whether the annotation can be selected by the end-user. (Inherited from WpfAnnotationUI.)
Public property | Canvas | Gets the WpfAnnotationCanvas class hosting this annotation. (Inherited from WpfAnnotationUI.)
Public property | CenterOfRotation | Gets the point used as center of rotation for the annotation. (Inherited from WpfAnnotationUI.)
Public property | ChildElement | Gets the child UIElement of the annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | CreationTime | Gets or sets the creation time of the annotation. (Inherited from WpfAnnotationUI.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | ExtraProperties | Gets the annotation extra properties dictionary. (Inherited from WpfAnnotationUI.)
Public property | Fill | Gets or sets the brush used to fill the annotation. (Inherited from WpfPdfAnnotation.)
Public property | Geometry | Gets a Geometry representing the annotation. (Overrides WpfAnnotationUIGeometry.)
Public property | Grips | Gets the grips for this annotation. (Inherited from WpfAnnotationUI.)
Public property | IsGrouped | Gets a value indicating whether the annotation is being hosted within a group. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredHorizontally | Gets a value indicating whether the annotation is mirrored horizontally. (Inherited from WpfAnnotationUI.)
Public property | IsMirroredVertically | Gets a value indicating whether the annotation is mirrored vertically. (Inherited from WpfAnnotationUI.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsVisible | Gets or sets a value indicating whether the annotation is visible. (Inherited from WpfAnnotationUI.)
Public property | Location | Gets or sets the location of the annotation in document space. (Inherited from WpfAnnotationUI.)
Public property | MarkupType | Gets or sets the annotation markup type.
Public property | ModifiedTime | Gets or sets the last time the annotation was modified. (Inherited from WpfAnnotationUI.)
Public property | Name | Gets or sets the name for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Outline | Gets or sets the pen used to draw the annotation outline. (Inherited from WpfPdfAnnotation.)
Public property | ParentLayer | Gets the parent layer of this annotation, if any. (Inherited from WpfAnnotationUI.)
Public property | Quadrilaterals | Gets the QuadrilateralFCollection holding the quadrilaterals for the annotation.
Public property | RenderedBounds | Gets the bounding rectangle of the annotation including any transformations applied for rendering. (Inherited from WpfAnnotationUI.)
Public property | RenderTransform | Gets the transform used when rendering the annotation. (Inherited from WpfAnnotationUI.)
Public property | Rotation | Gets or sets the amount of rotation applied to the annotation. (Inherited from WpfAnnotationUI.)
Public property | Security | Gets or sets the security for the annotation. (Inherited from WpfAnnotationUI.)
Public property | Selected | Gets or sets a value indicating whether the annotation is selected. (Inherited from WpfAnnotationUI.)
Public property | Size | Gets or sets the size of the annotation. (Inherited from WpfAnnotationUI.)
Public property | SquigglyHeight | Gets or set the height of the squiggly line.
Public property | State | Gets or sets the annotation state. (Inherited from WpfAnnotationUI.)
Public property | SupportsMultiClickCreation | Gets a value indicating whether the annotation supports being created from multiple mouse clicks. (Inherited from WpfAnnotationUI.)
Public property | Text | Gets or sets the text for the annotation. (Inherited from WpfPdfAnnotation.)
Public property | ToolTip | Gets or sets a tooltip to use for the annotation. (Inherited from WpfAnnotationUI.)
Public property | UnSelectedGeometry | Gets the geometry of the annotation without the selection dashes.
Public property | UserHasCreated | Gets a value indicating if the annotation was end-user created or added directly to a layer. (Inherited from WpfAnnotationUI.)
Public property | UserName | Gets or sets the username for this annotation. (Inherited from WpfAnnotationUI.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child elements for the Visual. (Inherited from Visual.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.Geometry Property

WpfPdfMarkupAnnotationGeometry Property

Gets a Geometry representing the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Geometry Geometry { get; }
Public Overrides ReadOnly Property Geometry As Geometry
    Get

Property Value

Type: Geometry
A Geometry representing the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.MarkupType Property

WpfPdfMarkupAnnotationMarkupType Property

Gets or sets the annotation markup type.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkupType MarkupType { get; set; }
Public Property MarkupType As PdfMarkupType
    Get
    Set

Property Value

Type: PdfMarkupType
The type of markup for this annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.Quadrilaterals Property

WpfPdfMarkupAnnotationQuadrilaterals Property

Gets the QuadrilateralFCollection holding the quadrilaterals for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralFCollection Quadrilaterals { get; }
Public ReadOnly Property Quadrilaterals As QuadrilateralFCollection
    Get

Property Value

Type: QuadrilateralFCollection
The quadrilaterals for the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.SquigglyHeight Property

WpfPdfMarkupAnnotationSquigglyHeight Property

Gets or set the height of the squiggly line.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SquigglyHeight { get; set; }
Public Property SquigglyHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the squiggly line.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.UnSelectedGeometry Property

WpfPdfMarkupAnnotationUnSelectedGeometry Property

Gets the geometry of the annotation without the selection dashes.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PathGeometry UnSelectedGeometry { get; }
Public Overridable ReadOnly Property UnSelectedGeometry As PathGeometry
    Get

Property Value

Type: PathGeometry
A PathGeometry for the annotation without the selection dashes.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Methods

The WpfPdfMarkupAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AttachGrips | This method is called by the WpfAnnotationCanvas to ask the annotation for Grip creation. (Inherited from WpfAnnotationUI.)
Protected method | AttachGripsOverride | Called when the annotation grips need to be created. (Overrides WpfAnnotationUIAttachGripsOverride(WpfAnnotationCanvas).)
Protected method | CalculateGeometry | Calculates the geometry of the annotation with the specified parameters. (Inherited from WpfAnnotationUI.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a copy of the anotation. (Inherited from WpfAnnotationUI.)
Protected method | CloneOverride | Derived classes must override this method and return a copy of itself. (Overrides WpfAnnotationUICloneOverride(WpfAnnotationUI).)
Public method | ClosePopup | This method is called to close the popup dialog. (Inherited from WpfPdfAnnotation.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDataSnapshot | This method creates an AnnotationData copy of this annotation for serialization. (Inherited from WpfAnnotationUI.)
Protected method | CreateDataSnapshotOverride | This method is used to serialize the annotation. (Overrides WpfAnnotationUICreateDataSnapshotOverride.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the specified Visual in the parent VisualCollection. (Inherited from Visual.)
Public method | HitTest | This method will determine whether the specified point is on the annotation. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(PointHitTestParameters) | Determines whether a point coordinate value is within the bounds of the visual object. (Inherited from WpfAnnotationUI.)
Protected method | HitTestCore(GeometryHitTestParameters) | Determines whether a geometry value is within the bounds of the visual object. (Inherited from Visual.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisual | Forces the annotation to redraw itself. (Inherited from WpfAnnotationUI.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mirror | Mirrors the annotation in the specified direction. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationBrushChanged | Called when the FillProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationCreated | Called after the annotation has been created. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationFontChanged | Called when the FontProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnAnnotationPenChanged | Called when the OutlineProperty has changed. (Inherited from WpfAnnotationUI.)
Protected method | OnCanvasChanged | Called when the Canvas property has changed. (Inherited from WpfPdfAnnotation.)
Protected method | OnGripPositionChanged | Called when a grip for the annotation has moved. (Overrides WpfPdfAnnotationOnGripPositionChanged(EventArgsWpfAnnotationGrip).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides WpfPdfAnnotationOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when a MouseMove event has been raised for the annotation. (Overrides WpfAnnotationUIOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides WpfPdfAnnotationOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPopupClosing | This method is called when the default dialog is closing. (Inherited from WpfPdfAnnotation.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides WpfPdfAnnotationOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnRotateDocument | Called when the document has been rotated. (Inherited from WpfAnnotationUI.)
Protected method | OnSelectedChanged | Called when the Selected property has been changed. (Overrides WpfAnnotationUIOnSelectedChanged(EventArgs).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual object is changed. (Inherited from Visual.)
Protected method | OperationRequest | Called when a request operation has been raised on the annotation. (Overrides WpfAnnotationUIOperationRequest(OperationRequestInformation).)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredetermineRenderBounds | This method is used to calculate the expected render bounds of an annotation if its rotation was changed. (Inherited from WpfAnnotationUI.)
Public method | RaiseEvent | This method is used to force an event in the annotation. (Inherited from WpfAnnotationUI.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Remove | This method will remove the annotation from its parent layer. (Inherited from WpfAnnotationUI.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ReplaceGrips | Call this method to replace the current annotation grips with new grips. (Inherited from WpfAnnotationUI.)
Public method | ResetMirrorVariables | This method will reset the internal Matrix used for mirroring. (Inherited from WpfAnnotationUI.)
Public method | Rotate | This method will append a rotation to the annotation's current rotation. (Inherited from WpfAnnotationUI.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetTransparency | Sets the alpha values for the Fill and Outline of the annotation. (Inherited from WpfAnnotationUI.)
Protected method | SetUserHasCreated | Derived class should call this method to indicate that their creation process has completed. (Inherited from WpfAnnotationUI.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShowPopup | This method is called to display a popup dialog for the PDF annotation. (Inherited from WpfPdfAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Protected method | UpdateToolTip | Sets the ToolTip property for the annotation. (Inherited from WpfPdfAnnotation.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.AttachGripsOverride Method

WpfPdfMarkupAnnotationAttachGripsOverride Method

Called when the annotation grips need to be created.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationGrips AttachGripsOverride(
    WpfAnnotationCanvas canvas
)
Protected Overrides Function AttachGripsOverride (
    canvas As WpfAnnotationCanvas
) As WpfAnnotationGrips

Parameters

canvas
Type: Atalasoft.Annotate.WpfWpfAnnotationCanvas
The WpfAnnotationCanvas that will host the annotation.

Return Value

Type: WpfAnnotationGrips
The grips for the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.CloneOverride Method

WpfPdfMarkupAnnotationCloneOverride Method

Derived classes must override this method and return a copy of itself.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override WpfAnnotationUI CloneOverride(
    WpfAnnotationUI clone
)
Protected Overrides Function CloneOverride (
    clone As WpfAnnotationUI
) As WpfAnnotationUI

Parameters

clone
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The new clone to add additional properties values.

Return Value

Type: WpfAnnotationUI
A copy of the annotation.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.CreateDataSnapshotOverride Method

WpfPdfMarkupAnnotationCreateDataSnapshotOverride Method

This method is used to serialize the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AnnotationData CreateDataSnapshotOverride()
Protected Overrides Function CreateDataSnapshotOverride As AnnotationData

Return Value

Type: AnnotationData
An AnnotationData object with the current annotation settings.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OnGripPositionChanged Method

WpfPdfMarkupAnnotationOnGripPositionChanged Method

Called when a grip for the annotation has moved.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnGripPositionChanged(
    EventArgs<WpfAnnotationGrip> e
)
Protected Overrides Sub OnGripPositionChanged (
    e As EventArgs(Of WpfAnnotationGrip)
)

Parameters

e
Type: Atalasoft.Annotate.WpfEventArgs WpfAnnotationGrip
An EventArgs containing the grip that was moved.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OnMouseDown Method

WpfPdfMarkupAnnotationOnMouseDown Method

Raises the MouseDown event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs instance containing the event data.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OnMouseMove Method

WpfPdfMarkupAnnotationOnMouseMove Method

Called when a MouseMove event has been raised for the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for the event.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OnMouseUp Method

WpfPdfMarkupAnnotationOnMouseUp Method

Raises the MouseUp event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs instance containing the event data.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OnPropertyChanged Method

WpfPdfMarkupAnnotationOnPropertyChanged Method

Raises the PropertyChanged event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As DependencyPropertyChangedEventArgs
)

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OnSelectedChanged Method

WpfPdfMarkupAnnotationOnSelectedChanged Method

Called when the Selected property has been changed.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSelectedChanged(
    EventArgs e
)
Protected Overrides Sub OnSelectedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.OperationRequest Method

WpfPdfMarkupAnnotationOperationRequest Method

Called when a request operation has been raised on the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OperationRequest(
    OperationRequestInformation request
)
Protected Overrides Sub OperationRequest (
    request As OperationRequestInformation
)

Parameters

request
Type: Atalasoft.Annotate.WpfOperationRequestInformation
A OperationRequestInformation for this event.
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Events

The WpfPdfMarkupAnnotation type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Event is raised when the left mouse button transitions from up to down while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | MouseUp | Event is raised when the left mouse button transitions from down to up while the cursor is over the annotation. (Inherited from WpfAnnotationUI.)
Public event | PropertyChanged | This event is raised when a property of the annotation has changed. (Inherited from WpfAnnotationUI.)
Top
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation Fields

The WpfPdfMarkupAnnotation type exposes the following members.

Fields
Name | Description
MarkupTypeProperty | Identifies the MarkupType dependency property.
SquigglyHeightProperty | Identifies the SquigglyHeight dependency property.
Top
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.MarkupTypeProperty Field

WpfPdfMarkupAnnotationMarkupTypeProperty Field

Identifies the MarkupType dependency property.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkupTypeProperty
Public Shared ReadOnly MarkupTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotation.SquigglyHeightProperty Field

WpfPdfMarkupAnnotationSquigglyHeightProperty Field

Identifies the SquigglyHeight dependency property.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SquigglyHeightProperty
Public Shared ReadOnly SquigglyHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WpfPdfMarkupAnnotation Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine Class

This class is used to render the WpfPdfMarkupAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfPdfMarkupAnnotation
Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPdfMarkupAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfPdfMarkupAnnotation>
Public Class WpfPdfMarkupAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfPdfMarkupAnnotation)

The WpfPdfMarkupAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPdfMarkupAnnotationRenderingEngine | Creates a new instance of WpfPdfMarkupAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Protected method | DrawSelectedOutline | This method is used to render the selected dash outline.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderHighlighter | This method is used to render a highlighter markup annotation.
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderSelectionRectangle | This method is used to render the selection rectangle used when creating the markup annotation.
Protected method | RenderSquiggly | This method is used to render a squiggly markup annotation.
Protected method | RenderStrikeOut | This method is used to render a strikeout markup annotation.
Protected method | RenderUnderline | This method is used to render an underline markup annotation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine Constructor

Creates a new instance of WpfPdfMarkupAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfMarkupAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine Methods

The WpfPdfMarkupAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Protected method | DrawSelectedOutline | This method is used to render the selected dash outline.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderHighlighter | This method is used to render a highlighter markup annotation.
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderSelectionRectangle | This method is used to render the selection rectangle used when creating the markup annotation.
Protected method | RenderSquiggly | This method is used to render a squiggly markup annotation.
Protected method | RenderStrikeOut | This method is used to render a strikeout markup annotation.
Protected method | RenderUnderline | This method is used to render an underline markup annotation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.DrawSelectedOutline Method

WpfPdfMarkupAnnotationRenderingEngineDrawSelectedOutline Method

This method is used to render the selected dash outline.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DrawSelectedOutline(
    Pen pen,
    QuadrilateralF quad,
    WpfRenderEnvironment e
)
Protected Overridable Sub DrawSelectedOutline (
    pen As Pen,
    quad As QuadrilateralF,
    e As WpfRenderEnvironment
)

Parameters

pen
Type: System.Windows.MediaPen
The pen used to render the annotation.
quad
Type: Atalasoft.Utils.GeometryQuadrilateralF
The QuadrilateralF for the annotation.
e
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
The render environment used for rendering this annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.OnRenderAnnotation Method

WpfPdfMarkupAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfPdfMarkupAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfPdfMarkupAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.RenderHighlighter Method

WpfPdfMarkupAnnotationRenderingEngineRenderHighlighter Method

This method is used to render a highlighter markup annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderHighlighter(
    WpfPdfMarkupAnnotation annotation,
    Brush fill,
    Pen pen,
    WpfRenderEnvironment e
)
Protected Overridable Sub RenderHighlighter (
    annotation As WpfPdfMarkupAnnotation,
    fill As Brush,
    pen As Pen,
    e As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation
The annotation to render.
fill
Type: System.Windows.MediaBrush
The brush used for a fill. This may be null.
pen
Type: System.Windows.MediaPen
The pen used for the outline. This may be null.
e
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
The render environment used for rendering this annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.RenderSelectionRectangle Method

WpfPdfMarkupAnnotationRenderingEngineRenderSelectionRectangle Method

This method is used to render the selection rectangle used when creating the markup annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderSelectionRectangle(
    WpfPdfMarkupAnnotation annotation,
    Pen pen,
    WpfRenderEnvironment e
)
Protected Overridable Sub RenderSelectionRectangle (
    annotation As WpfPdfMarkupAnnotation,
    pen As Pen,
    e As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation
The annotation being created.
pen
Type: System.Windows.MediaPen
The outline for the annotation.
e
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
The render environment used for rendering this annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.RenderSquiggly Method

WpfPdfMarkupAnnotationRenderingEngineRenderSquiggly Method

This method is used to render a squiggly markup annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderSquiggly(
    WpfPdfMarkupAnnotation annotation,
    Pen pen,
    WpfRenderEnvironment e
)
Protected Overridable Sub RenderSquiggly (
    annotation As WpfPdfMarkupAnnotation,
    pen As Pen,
    e As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation
The annotation to render.
pen
Type: System.Windows.MediaPen
The pen used for the outline. This may be null.
e
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
The render environment used for rendering this annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.RenderStrikeOut Method

WpfPdfMarkupAnnotationRenderingEngineRenderStrikeOut Method

This method is used to render a strikeout markup annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderStrikeOut(
    WpfPdfMarkupAnnotation annotation,
    Pen pen,
    WpfRenderEnvironment e
)
Protected Overridable Sub RenderStrikeOut (
    annotation As WpfPdfMarkupAnnotation,
    pen As Pen,
    e As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation
The annotation to render.
pen
Type: System.Windows.MediaPen
The pen used for the outline. This may be null.
e
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
The render environment used for rendering this annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfMarkupAnnotationRenderingEngine.RenderUnderline Method

WpfPdfMarkupAnnotationRenderingEngineRenderUnderline Method

This method is used to render an underline markup annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderUnderline(
    WpfPdfMarkupAnnotation annotation,
    Pen pen,
    WpfRenderEnvironment e
)
Protected Overridable Sub RenderUnderline (
    annotation As WpfPdfMarkupAnnotation,
    pen As Pen,
    e As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotation
The annotation to render.
pen
Type: System.Windows.MediaPen
The pen used for the outline. This may be null.
e
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
The render environment used for rendering this annotation.
See Also

Reference

WpfPdfMarkupAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow Class

Interaction logic for WpfPdfPopupWindow.xaml

This class is the window used for PDF annotations to allow their text to be modified.

The window is shown when the user double-clicks on a PDF annotation. When the window is closed, the Text property of the annotation is updated.

WpfPdfPopupWindow
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Atalasoft.Annotate.Wpf.PdfWpfPdfPopupWindow

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPdfPopupWindow : Window,
    IComponentConnector
Public Class WpfPdfPopupWindow
    Inherits Window
    Implements IComponentConnector

The WpfPdfPopupWindow type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPdfPopupWindow | Creates a new instance of WpfPdfPopupWindow for the specified annotation.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RefreshData | Reloads the dialog text data.
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow Constructor

Creates a new instance of WpfPdfPopupWindow for the specified annotation.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPdfPopupWindow(
    WpfPdfAnnotation annotation,
    EventHandler windowClosingHandler
)
Public Sub New (
    annotation As WpfPdfAnnotation,
    windowClosingHandler As EventHandler
)

Parameters

annotation
Type: Atalasoft.Annotate.Wpf.PdfWpfPdfAnnotation
The annotation for this dialog.
windowClosingHandler
Type: SystemEventHandler
An EventHandler called when the window is closing. This can be null (Nothing in VB).
Exceptions
Exception | Condition
 | Thrown if the annotation argument is null (Nothing in VB).
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow Properties

The WpfPdfPopupWindow type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow Methods

The WpfPdfPopupWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RefreshData | Reloads the dialog text data.
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow.InitializeComponent Method

WpfPdfPopupWindowInitializeComponent Method

InitializeComponent

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void InitializeComponent()
Public Sub InitializeComponent

Implements

IComponentConnectorInitializeComponent
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow.OnClosing Method

WpfPdfPopupWindowOnClosing Method

Raises the Closing event.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClosing(
    CancelEventArgs e
)
Protected Overrides Sub OnClosing (
    e As CancelEventArgs
)

Parameters

e
Type: System.ComponentModelCancelEventArgs
A CancelEventArgs that contains the event data.
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow.RefreshData Method

WpfPdfPopupWindowRefreshData Method

Reloads the dialog text data.
Reloads the dialog text data.

Namespace: Atalasoft.Annotate.Wpf.Pdf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RefreshData()
Public Sub RefreshData
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


WpfPdfPopupWindow Events

The WpfPdfPopupWindow type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

WpfPdfPopupWindow Class
Atalasoft.Annotate.Wpf.Pdf Namespace


Atalasoft.Annotate.Wpf.Renderer Namespace

Classes
 | Class | Description
Public class | WpfAnnotationRenderers | This class holds all of the annotation renderers used for drawing the annotations. When a custom annotation is created, its IWpfAnnotationRenderer should be added to this collection to allow the WpfAnnotationCanvas to render the object.
Public class | WpfAnnotationRenderingEngineT | This is the base class used to render annotations.
Public class | WpfCalloutAnnotationRenderingEngine | This class is used to render a WpfCalloutAnnotation.
Public class | WpfEllipseAnnotationRenderingEngine | This class is used to render a WpfEllipseAnnotation.
Public class | WpfEmbeddedImageAnnotationRenderingEngine | This class is used to render a WpfEmbeddedImageAnnotation.
Public class | WpfFreehandAnnotationRenderingEngine | This class is used to render a WpfFreehandAnnotation.
Public class | WpfGripRenderer | This class is the default grip renderer for annotations.
Public class | WpfHotSpotAnnotationRenderingEngine | This class is used to render a WpfHotSpotAnnotation.
Public class | WpfHotSpotFreehandAnnotationRenderingEngine | This class is used to render a WpfHotSpotFreehandAnnotation.
Public class | WpfLayerAnnotationRenderingEngine | This class is used to render a WpfLayerAnnotation.
Public class | WpfLineAnnotationRenderingEngine | This class is used to render a WpfLineAnnotation.
Public class | WpfLinesAnnotationRenderingEngine | This class is used to render a WpfLinesAnnotation.
Public class | WpfPolygonAnnotationRenderingEngine | This class is used to render a WpfPolygonAnnotation.
Public class | WpfRectangleAnnotationRenderingEngine | This class is used to render a WpfRectangleAnnotation.
Public class | WpfReferencedImageAnnotationRenderingEngine | This class is used to render a WpfReferencedImageAnnotation.
Public class | WpfRenderEnvironment | This class is used to hold information required for rendering the annotations and grips.
Public class | WpfRubberStampAnnotationRenderingEngine | This class is used to render a WpfRubberStampAnnotation.
Public class | WpfTextAnnotationRenderingEngine | This class is used to render a WpfTextAnnotation.
Interfaces
 | Interface | Description
Public interface | IWpfAnnotationRenderer | This interface must be implemented by classes that will be used to render WPF annotations.
Public interface | IWpfGripRenderer | This interface must be implemented by classes used to render annotation grips.


IWpfAnnotationRenderer Interface

This interface must be implemented by classes that will be used to render WPF annotations.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWpfAnnotationRenderer
Public Interface IWpfAnnotationRenderer

The IWpfAnnotationRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderAnnotation | Called to render the annotation.
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


IWpfAnnotationRenderer Methods

The IWpfAnnotationRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderAnnotation | Called to render the annotation.
Top
See Also

Reference

IWpfAnnotationRenderer Interface
Atalasoft.Annotate.Wpf.Renderer Namespace


IWpfAnnotationRenderer.RenderAnnotation Method

IWpfAnnotationRendererRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void RenderAnnotation(
    WpfAnnotationUI annotation,
    WpfRenderEnvironment environment
)
Sub RenderAnnotation (
    annotation As WpfAnnotationUI,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

IWpfAnnotationRenderer Interface
Atalasoft.Annotate.Wpf.Renderer Namespace


IWpfGripRenderer Interface

This interface must be implemented by classes used to render annotation grips.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWpfGripRenderer
Public Interface IWpfGripRenderer

The IWpfGripRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderGrips | Called to render grips for an annotation.
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


IWpfGripRenderer Methods

The IWpfGripRenderer type exposes the following members.

Methods
 | Name | Description
Public method | RenderGrips | Called to render grips for an annotation.
Top
See Also

Reference

IWpfGripRenderer Interface
Atalasoft.Annotate.Wpf.Renderer Namespace


IWpfGripRenderer.RenderGrips Method

IWpfGripRendererRenderGrips Method

Called to render grips for an annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void RenderGrips(
    WpfAnnotationGrips grips,
    WpfRenderEnvironment environment
)
Sub RenderGrips (
    grips As WpfAnnotationGrips,
    environment As WpfRenderEnvironment
)

Parameters

grips
Type: Atalasoft.Annotate.WpfWpfAnnotationGrips
The grips to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the grips.
See Also

Reference

IWpfGripRenderer Interface
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderers Class

This class holds all of the annotation renderers used for drawing the annotations. When a custom annotation is created, its IWpfAnnotationRenderer should be added to this collection to allow the WpfAnnotationCanvas to render the object.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderers

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class WpfAnnotationRenderers
Public NotInheritable Class WpfAnnotationRenderers

The WpfAnnotationRenderers type exposes the following members.

Methods
Name | Description
Add | Adds or replaces a rendering engine for the specified annotation type.
Contains | Returns a value indicating whether the specified annotation type is in the collection.
Get | Gets the renderer for the specified type.
GetAnnotationTypes | Returns an array of Type for each annotation in the collection.
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderers Methods

The WpfAnnotationRenderers type exposes the following members.

Methods
Name | Description
Add | Adds or replaces a rendering engine for the specified annotation type.
Contains | Returns a value indicating whether the specified annotation type is in the collection.
Get | Gets the renderer for the specified type.
GetAnnotationTypes | Returns an array of Type for each annotation in the collection.
Top
See Also

Reference

WpfAnnotationRenderers Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderers.Add Method

WpfAnnotationRenderersAdd Method

Adds or replaces a rendering engine for the specified annotation type.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Add(
    Type annotationType,
    IWpfAnnotationRenderer renderer
)
Public Shared Sub Add (
    annotationType As Type,
    renderer As IWpfAnnotationRenderer
)

Parameters

annotationType
Type: SystemType
The annotation type for this renderer.
renderer
Type: Atalasoft.Annotate.Wpf.RendererIWpfAnnotationRenderer
The renderer to use for the specified type.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationRenderers Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderers.Contains Method

WpfAnnotationRenderersContains Method

Returns a value indicating whether the specified annotation type is in the collection.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool Contains(
    Type annotationType
)
Public Shared Function Contains (
    annotationType As Type
) As Boolean

Parameters

annotationType
Type: SystemType
The annotation type to search for.

Return Value

Type: Boolean
True if the annotation type is in the collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotationType argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationRenderers Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderers.Get Method

WpfAnnotationRenderersGet Method

Gets the renderer for the specified type.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IWpfAnnotationRenderer Get(
    Type annotationType
)
Public Shared Function Get (
    annotationType As Type
) As IWpfAnnotationRenderer

Parameters

annotationType
Type: SystemType
The annotation type.

Return Value

Type: IWpfAnnotationRenderer
The renderer for the annotation type or a default renderer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the annotationType argument is null (Nothing in VB).
See Also

Reference

WpfAnnotationRenderers Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderers.GetAnnotationTypes Method

WpfAnnotationRenderersGetAnnotationTypes Method

Returns an array of Type for each annotation in the collection.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Type[] GetAnnotationTypes()
Public Shared Function GetAnnotationTypes As Type()

Return Value

Type: Type
An array of Type for each annotation or Type.EmptyTypes if the collection is empty.
See Also

Reference

WpfAnnotationRenderers Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderingEngine(T) Class

WpfAnnotationRenderingEngineT Class

This is the base class used to render annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngineT
More...

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfAnnotationRenderingEngine<T> : IWpfAnnotationRenderer
where T : WpfAnnotationUI

Public Class WpfAnnotationRenderingEngine(Of T As WpfAnnotationUI)
    Implements IWpfAnnotationRenderer

Type Parameters

T
The annotation type this renderer is used for.

The WpfAnnotationRenderingEngineT type exposes the following members.

Constructors
 | Name | Description
Public method | WpfAnnotationRenderingEngineT | Creates a new instance of WpfAnnotationRenderingEngine.
Top
Methods
 | Name | Description
 | CreateLineCapGeometry | Creates the line cap geometry.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation.
Public method | RenderAnnotation | Called to render the annotation.
Protected method | RenderLineCap | This method is called to render the a single line cap.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngineT
Atalasoft.Annotate.Wpf.PdfWpfPdfLineAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.PdfWpfPdfMarkupAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfCalloutAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfEllipseAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfEmbeddedImageAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfFreehandAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfHotSpotAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfHotSpotFreehandAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfLayerAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfLineAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfLinesAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfPolygonAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfRectangleAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfReferencedImageAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfRubberStampAnnotationRenderingEngine
Atalasoft.Annotate.Wpf.RendererWpfTextAnnotationRenderingEngine


WpfAnnotationRenderingEngine(T) Constructor

WpfAnnotationRenderingEngineT Constructor

Creates a new instance of WpfAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfAnnotationRenderingEngineT Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderingEngine(T) Methods

WpfAnnotationRenderingEngineT Methods

The WpfAnnotationRenderingEngineT generic type exposes the following members.

Methods
 | Name | Description
 | CreateLineCapGeometry | Creates the line cap geometry.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation.
Public method | RenderAnnotation | Called to render the annotation.
Protected method | RenderLineCap | This method is called to render the a single line cap.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfAnnotationRenderingEngineT Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderingEngine(T).CreateLineCapGeometry Method

WpfAnnotationRenderingEngineTCreateLineCapGeometry Method

Creates the line cap geometry.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Geometry CreateLineCapGeometry(
    Point startingPoint,
    Point endingPoint,
    AnnotationLineCap lineCap,
    AnnotationPen pen
)
Public Shared Function CreateLineCapGeometry (
    startingPoint As Point,
    endingPoint As Point,
    lineCap As AnnotationLineCap,
    pen As AnnotationPen
) As Geometry

Parameters

startingPoint
Type: System.WindowsPoint
The starting point.
endingPoint
Type: System.WindowsPoint
The ending point.
lineCap
Type: Atalasoft.AnnotateAnnotationLineCap
The line cap.
pen
Type: Atalasoft.AnnotateAnnotationPen
The pen.

Return Value

Type: Geometry
See Also

Reference

WpfAnnotationRenderingEngineT Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderingEngine(T).OnRenderAnnotation Method

WpfAnnotationRenderingEngineTOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRenderAnnotation(
    T annotation,
    WpfRenderEnvironment environment
)
Protected Overridable Sub OnRenderAnnotation (
    annotation As T,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: T
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
Remarks
The annotation and environment arguments have already be verified as non-null and the annotation rendering transform has been applied to the environment.DrawingContext before this method is called.
See Also

Reference

WpfAnnotationRenderingEngineT Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderingEngine(T).RenderAnnotation Method

WpfAnnotationRenderingEngineTRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void RenderAnnotation(
    WpfAnnotationUI annotation,
    WpfRenderEnvironment environment
)
Public Overridable Sub RenderAnnotation (
    annotation As WpfAnnotationUI,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfAnnotationUI
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.

Implements

IWpfAnnotationRendererRenderAnnotation(WpfAnnotationUI, WpfRenderEnvironment)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the arguments are null (Nothing in VB).
Remarks
This method will validate the arguments and setup the rendering transform on the DrawingContext before calling OnRenderAnnotation.
See Also

Reference

WpfAnnotationRenderingEngineT Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfAnnotationRenderingEngine(T).RenderLineCap Method

WpfAnnotationRenderingEngineTRenderLineCap Method

This method is called to render the a single line cap.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderLineCap(
    Point startingPoint,
    Point endingPoint,
    AnnotationLineCap lineCap,
    AnnotationBrush fill,
    AnnotationPen pen,
    WpfRenderEnvironment environment
)
Protected Overridable Sub RenderLineCap (
    startingPoint As Point,
    endingPoint As Point,
    lineCap As AnnotationLineCap,
    fill As AnnotationBrush,
    pen As AnnotationPen,
    environment As WpfRenderEnvironment
)

Parameters

startingPoint
Type: System.WindowsPoint
The starting point of the line.
endingPoint
Type: System.WindowsPoint
The ending point of the line.
lineCap
Type: Atalasoft.AnnotateAnnotationLineCap
The line cap for the end point.
fill
Type: Atalasoft.AnnotateAnnotationBrush
The brush used to fill the line cap.
pen
Type: Atalasoft.AnnotateAnnotationPen
The pen used to draw the line cap
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A render environment used to draw the line cap.
See Also

Reference

WpfAnnotationRenderingEngineT Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfCalloutAnnotationRenderingEngine Class

This class is used to render a WpfCalloutAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfCalloutAnnotation
Atalasoft.Annotate.Wpf.RendererWpfCalloutAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfCalloutAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfCalloutAnnotation>
Public Class WpfCalloutAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfCalloutAnnotation)

The WpfCalloutAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfCalloutAnnotationRenderingEngine | Creates a new instance of WpfCalloutAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfCalloutAnnotationRenderingEngine Constructor

Creates a new instance of WpfCalloutAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfCalloutAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfCalloutAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfCalloutAnnotationRenderingEngine Methods

The WpfCalloutAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfCalloutAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfCalloutAnnotationRenderingEngine.OnRenderAnnotation Method

WpfCalloutAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfCalloutAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfCalloutAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfCalloutAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfCalloutAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEllipseAnnotationRenderingEngine Class

This class is used to render a WpfEllipseAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfEllipseAnnotation
Atalasoft.Annotate.Wpf.RendererWpfEllipseAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfEllipseAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfEllipseAnnotation>
Public Class WpfEllipseAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfEllipseAnnotation)

The WpfEllipseAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfEllipseAnnotationRenderingEngine | Creates a new instance of WpfEllipseAnnotation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEllipseAnnotationRenderingEngine Constructor

Creates a new instance of WpfEllipseAnnotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEllipseAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfEllipseAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEllipseAnnotationRenderingEngine Methods

The WpfEllipseAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfEllipseAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEllipseAnnotationRenderingEngine.OnRenderAnnotation Method

WpfEllipseAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfEllipseAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfEllipseAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfEllipseAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfEllipseAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEmbeddedImageAnnotationRenderingEngine Class

This class is used to render a WpfEmbeddedImageAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfEmbeddedImageAnnotation
Atalasoft.Annotate.Wpf.RendererWpfEmbeddedImageAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfEmbeddedImageAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfEmbeddedImageAnnotation>
Public Class WpfEmbeddedImageAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfEmbeddedImageAnnotation)

The WpfEmbeddedImageAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfEmbeddedImageAnnotationRenderingEngine | Creates a new instance of WpfEmbeddedImageAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEmbeddedImageAnnotationRenderingEngine Constructor

Creates a new instance of WpfEmbeddedImageAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfEmbeddedImageAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfEmbeddedImageAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEmbeddedImageAnnotationRenderingEngine Methods

The WpfEmbeddedImageAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfEmbeddedImageAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfEmbeddedImageAnnotationRenderingEngine.OnRenderAnnotation Method

WpfEmbeddedImageAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfEmbeddedImageAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfEmbeddedImageAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfEmbeddedImageAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfEmbeddedImageAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfFreehandAnnotationRenderingEngine Class

This class is used to render a WpfFreehandAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfFreehandAnnotation
Atalasoft.Annotate.Wpf.RendererWpfFreehandAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfFreehandAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfFreehandAnnotation>
Public Class WpfFreehandAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfFreehandAnnotation)

The WpfFreehandAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfFreehandAnnotationRenderingEngine | Creates a new instance of WpfFreehandAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfFreehandAnnotationRenderingEngine Constructor

Creates a new instance of WpfFreehandAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfFreehandAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfFreehandAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfFreehandAnnotationRenderingEngine Methods

The WpfFreehandAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfFreehandAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfFreehandAnnotationRenderingEngine.OnRenderAnnotation Method

WpfFreehandAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfFreehandAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfFreehandAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfFreehandAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfFreehandAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer Class

This class is the default grip renderer for annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfGripRenderer

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfGripRenderer : IWpfGripRenderer
Public Class WpfGripRenderer
    Implements IWpfGripRenderer

The WpfGripRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | WpfGripRenderer | Creates a new instance of WpfGripRenderer.
Top
Properties
 | Name | Description
Public property | Fill | Gets or sets the brush used to fill the grips.
Public property | Outline | Gets or sets the pen used to draw the grip outline.
Public property | RotationFill | Gets or sets the brush used to fill the rotation grip.
Public property | RotationOutline | Gets or sets the pen used to render the rotation outline.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderGrips | Renders the specified grips.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer Constructor

Creates a new instance of WpfGripRenderer.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfGripRenderer()
Public Sub New
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer Properties

The WpfGripRenderer type exposes the following members.

Properties
 | Name | Description
Public property | Fill | Gets or sets the brush used to fill the grips.
Public property | Outline | Gets or sets the pen used to draw the grip outline.
Public property | RotationFill | Gets or sets the brush used to fill the rotation grip.
Public property | RotationOutline | Gets or sets the pen used to render the rotation outline.
Top
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer.Fill Property

WpfGripRendererFill Property

Gets or sets the brush used to fill the grips.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Brush Fill { get; set; }
Public Property Fill As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill the grips.
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer.Outline Property

WpfGripRendererOutline Property

Gets or sets the pen used to draw the grip outline.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pen Outline { get; set; }
Public Property Outline As Pen
    Get
    Set

Property Value

Type: Pen
The pen used for the grip outline.
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer.RotationFill Property

WpfGripRendererRotationFill Property

Gets or sets the brush used to fill the rotation grip.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Brush RotationFill { get; set; }
Public Property RotationFill As Brush
    Get
    Set

Property Value

Type: Brush
The brush used for the rotation grip.
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer.RotationOutline Property

WpfGripRendererRotationOutline Property

Gets or sets the pen used to render the rotation outline.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pen RotationOutline { get; set; }
Public Property RotationOutline As Pen
    Get
    Set

Property Value

Type: Pen
The pen used to render the rotation outline.
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer Methods

The WpfGripRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderGrips | Renders the specified grips.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfGripRenderer.RenderGrips Method

WpfGripRendererRenderGrips Method

Renders the specified grips.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RenderGrips(
    WpfAnnotationGrips grips,
    WpfRenderEnvironment environment
)
Public Sub RenderGrips (
    grips As WpfAnnotationGrips,
    environment As WpfRenderEnvironment
)

Parameters

grips
Type: Atalasoft.Annotate.WpfWpfAnnotationGrips
The grips to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment used to render the grips.

Implements

IWpfGripRendererRenderGrips(WpfAnnotationGrips, WpfRenderEnvironment)
See Also

Reference

WpfGripRenderer Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotAnnotationRenderingEngine Class

This class is used to render a WpfHotSpotAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfHotSpotAnnotation
Atalasoft.Annotate.Wpf.RendererWpfHotSpotAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfHotSpotAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfHotSpotAnnotation>
Public Class WpfHotSpotAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfHotSpotAnnotation)

The WpfHotSpotAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfHotSpotAnnotationRenderingEngine | Creates a new instance of WpfHotSpotAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotAnnotationRenderingEngine Constructor

Creates a new instance of WpfHotSpotAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfHotSpotAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotAnnotationRenderingEngine Methods

The WpfHotSpotAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfHotSpotAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotAnnotationRenderingEngine.OnRenderAnnotation Method

WpfHotSpotAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfHotSpotAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfHotSpotAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfHotSpotAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfHotSpotAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotFreehandAnnotationRenderingEngine Class

This class is used to render a WpfHotSpotFreehandAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfHotSpotFreehandAnnotation
Atalasoft.Annotate.Wpf.RendererWpfHotSpotFreehandAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfHotSpotFreehandAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfHotSpotFreehandAnnotation>
Public Class WpfHotSpotFreehandAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfHotSpotFreehandAnnotation)

The WpfHotSpotFreehandAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfHotSpotFreehandAnnotationRenderingEngine | Creates a new instance of WpfHotSpotFreehandAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotFreehandAnnotationRenderingEngine Constructor

Creates a new instance of WpfHotSpotFreehandAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfHotSpotFreehandAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfHotSpotFreehandAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotFreehandAnnotationRenderingEngine Methods

The WpfHotSpotFreehandAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfHotSpotFreehandAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfHotSpotFreehandAnnotationRenderingEngine.OnRenderAnnotation Method

WpfHotSpotFreehandAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfHotSpotFreehandAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfHotSpotFreehandAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfHotSpotFreehandAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfHotSpotFreehandAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLayerAnnotationRenderingEngine Class

This class is used to render a WpfLayerAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfLayerAnnotation
Atalasoft.Annotate.Wpf.RendererWpfLayerAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLayerAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfLayerAnnotation>
Public Class WpfLayerAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfLayerAnnotation)

The WpfLayerAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLayerAnnotationRenderingEngine | Creates a new instance of WpfLayerAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLayerAnnotationRenderingEngine Constructor

Creates a new instance of WpfLayerAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLayerAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfLayerAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLayerAnnotationRenderingEngine Methods

The WpfLayerAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfLayerAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLayerAnnotationRenderingEngine.OnRenderAnnotation Method

WpfLayerAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfLayerAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfLayerAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfLayerAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfLayerAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLineAnnotationRenderingEngine Class

This class is used to render a WpfLineAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfLineAnnotation
Atalasoft.Annotate.Wpf.RendererWpfLineAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLineAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfLineAnnotation>
Public Class WpfLineAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfLineAnnotation)

The WpfLineAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLineAnnotationRenderingEngine | Creates a new instance of WpfLineAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLineAnnotationRenderingEngine Constructor

Creates a new instance of WpfLineAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLineAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfLineAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLineAnnotationRenderingEngine Methods

The WpfLineAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfLineAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLineAnnotationRenderingEngine.OnRenderAnnotation Method

WpfLineAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfLineAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfLineAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfLineAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfLineAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLinesAnnotationRenderingEngine Class

This class is used to render a WpfLinesAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfLinesAnnotation
Atalasoft.Annotate.Wpf.RendererWpfLinesAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfLinesAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfLinesAnnotation>
Public Class WpfLinesAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfLinesAnnotation)

The WpfLinesAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfLinesAnnotationRenderingEngine | Creates a new instance of WpfLinesAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLinesAnnotationRenderingEngine Constructor

Creates a new instance of WpfLinesAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfLinesAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfLinesAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLinesAnnotationRenderingEngine Methods

The WpfLinesAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfLinesAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfLinesAnnotationRenderingEngine.OnRenderAnnotation Method

WpfLinesAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfLinesAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfLinesAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfLinesAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfLinesAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfPolygonAnnotationRenderingEngine Class

This class is used to render a WpfPolygonAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfPolygonAnnotation
Atalasoft.Annotate.Wpf.RendererWpfPolygonAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfPolygonAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfPolygonAnnotation>
Public Class WpfPolygonAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfPolygonAnnotation)

The WpfPolygonAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfPolygonAnnotationRenderingEngine | Creates a new instance of WpfPolygonAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfPolygonAnnotationRenderingEngine Constructor

Creates a new instance of WpfPolygonAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfPolygonAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfPolygonAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfPolygonAnnotationRenderingEngine Methods

The WpfPolygonAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfPolygonAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfPolygonAnnotationRenderingEngine.OnRenderAnnotation Method

WpfPolygonAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfPolygonAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfPolygonAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfPolygonAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfPolygonAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRectangleAnnotationRenderingEngine Class

This class is used to render a WpfRectangleAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfRectangleAnnotation
Atalasoft.Annotate.Wpf.RendererWpfRectangleAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfRectangleAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfRectangleAnnotation>
Public Class WpfRectangleAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfRectangleAnnotation)

The WpfRectangleAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfRectangleAnnotationRenderingEngine | Creates a new instance of WpfRectangleAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRectangleAnnotationRenderingEngine Constructor

Creates a new instance of WpfRectangleAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRectangleAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfRectangleAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRectangleAnnotationRenderingEngine Methods

The WpfRectangleAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfRectangleAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRectangleAnnotationRenderingEngine.OnRenderAnnotation Method

WpfRectangleAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfRectangleAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfRectangleAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfRectangleAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfRectangleAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfReferencedImageAnnotationRenderingEngine Class

This class is used to render a WpfReferencedImageAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfReferencedImageAnnotation
Atalasoft.Annotate.Wpf.RendererWpfReferencedImageAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfReferencedImageAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfReferencedImageAnnotation>
Public Class WpfReferencedImageAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfReferencedImageAnnotation)

The WpfReferencedImageAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfReferencedImageAnnotationRenderingEngine | Creates a new instance of WpfReferencedImageAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfReferencedImageAnnotationRenderingEngine Constructor

Creates a new instance of WpfReferencedImageAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfReferencedImageAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfReferencedImageAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfReferencedImageAnnotationRenderingEngine Methods

The WpfReferencedImageAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfReferencedImageAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfReferencedImageAnnotationRenderingEngine.OnRenderAnnotation Method

WpfReferencedImageAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfReferencedImageAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfReferencedImageAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfReferencedImageAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfReferencedImageAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment Class

This class is used to hold information required for rendering the annotations and grips.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfRenderEnvironment
Public Class WpfRenderEnvironment

The WpfRenderEnvironment type exposes the following members.

Constructors
 | Name | Description
Public method | WpfRenderEnvironment | Creates a new instance of WpfRenderEnvironment.
Top
Properties
 | Name | Description
Public property | Device | Gets the target device for this render session.
Public property | DrawingContext | Gets the DrawingContext used to draw the annotations.
Public property | InteractMode | Gets the current interaction mode of the WpfAnnotationCanvas.
Public property | Resolution | Gets the resolution of the WpfAnnotationCanvas.
Public property | ScaledResolutionHeightFactor | Gets the scaled resolution height factor.
Public property | Zoom | Gets the zoom of the WpfAnnotationCanvas.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment Constructor

Creates a new instance of WpfRenderEnvironment.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRenderEnvironment(
    RenderDevice device,
    DrawingContext drawingContext,
    double zoom,
    Point resolution,
    AnnotateInteractMode interactMode,
    double scaledResolutionHeightFactor
)
Public Sub New (
    device As RenderDevice,
    drawingContext As DrawingContext,
    zoom As Double,
    resolution As Point,
    interactMode As AnnotateInteractMode,
    scaledResolutionHeightFactor As Double
)

Parameters

device
Type: Atalasoft.AnnotateRenderDevice
The target device for this render session.
drawingContext
Type: System.Windows.MediaDrawingContext
The DrawingContext used for drawing the annotations.
zoom
Type: SystemDouble
The zoom of the WpfAnnotationCanvas.
resolution
Type: System.WindowsPoint
The resolution of the WpfAnnotationCanvas.
interactMode
Type: Atalasoft.AnnotateAnnotateInteractMode
The interaction mode of the WpfAnnotationCanvas.
scaledResolutionHeightFactor
Type: SystemDouble
the resolution's scale height factor. Default 1.0
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the drawingContext argument is null (Nothing in VB).
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment Properties

The WpfRenderEnvironment type exposes the following members.

Properties
 | Name | Description
Public property | Device | Gets the target device for this render session.
Public property | DrawingContext | Gets the DrawingContext used to draw the annotations.
Public property | InteractMode | Gets the current interaction mode of the WpfAnnotationCanvas.
Public property | Resolution | Gets the resolution of the WpfAnnotationCanvas.
Public property | ScaledResolutionHeightFactor | Gets the scaled resolution height factor.
Public property | Zoom | Gets the zoom of the WpfAnnotationCanvas.
Top
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment.Device Property

WpfRenderEnvironmentDevice Property

Gets the target device for this render session.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderDevice Device { get; }
Public ReadOnly Property Device As RenderDevice
    Get

Property Value

Type: RenderDevice
The target device for this render session.
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment.DrawingContext Property

WpfRenderEnvironmentDrawingContext Property

Gets the DrawingContext used to draw the annotations.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DrawingContext DrawingContext { get; }
Public ReadOnly Property DrawingContext As DrawingContext
    Get

Property Value

Type: DrawingContext
The DrawingContext used for drawing the annotations.
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment.InteractMode Property

WpfRenderEnvironmentInteractMode Property

Gets the current interaction mode of the WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotateInteractMode InteractMode { get; }
Public ReadOnly Property InteractMode As AnnotateInteractMode
    Get

Property Value

Type: AnnotateInteractMode
The interaction mode of the WpfAnnotationCanvas.
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment.Resolution Property

WpfRenderEnvironmentResolution Property

Gets the resolution of the WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Resolution { get; }
Public ReadOnly Property Resolution As Point
    Get

Property Value

Type: Point
The resolution of the WpfAnnotationCanvas.
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment.ScaledResolutionHeightFactor Property

WpfRenderEnvironmentScaledResolutionHeightFactor Property

Gets the scaled resolution height factor.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ScaledResolutionHeightFactor { get; }
Public ReadOnly Property ScaledResolutionHeightFactor As Double
    Get

Property Value

Type: Double
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment.Zoom Property

WpfRenderEnvironmentZoom Property

Gets the zoom of the WpfAnnotationCanvas.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; }
Public ReadOnly Property Zoom As Double
    Get

Property Value

Type: Double
The zoom of the WpfAnnotationCanvas.
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRenderEnvironment Methods

The WpfRenderEnvironment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfRenderEnvironment Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRubberStampAnnotationRenderingEngine Class

This class is used to render a WpfRubberStampAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfRubberStampAnnotation
Atalasoft.Annotate.Wpf.RendererWpfRubberStampAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfRubberStampAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfRubberStampAnnotation>
Public Class WpfRubberStampAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfRubberStampAnnotation)

The WpfRubberStampAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfRubberStampAnnotationRenderingEngine | Creates a new instance of WpfRubberStampAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRubberStampAnnotationRenderingEngine Constructor

Creates a new instance of WpfRubberStampAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfRubberStampAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfRubberStampAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRubberStampAnnotationRenderingEngine Methods

The WpfRubberStampAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfRubberStampAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfRubberStampAnnotationRenderingEngine.OnRenderAnnotation Method

WpfRubberStampAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfRubberStampAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfRubberStampAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfRubberStampAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfRubberStampAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfTextAnnotationRenderingEngine Class

This class is used to render a WpfTextAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.Annotate.Wpf.RendererWpfAnnotationRenderingEngine WpfTextAnnotation
Atalasoft.Annotate.Wpf.RendererWpfTextAnnotationRenderingEngine

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WpfTextAnnotationRenderingEngine : WpfAnnotationRenderingEngine<WpfTextAnnotation>
Public Class WpfTextAnnotationRenderingEngine
    Inherits WpfAnnotationRenderingEngine(Of WpfTextAnnotation)

The WpfTextAnnotationRenderingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | WpfTextAnnotationRenderingEngine | Creates a new instance of WpfTextAnnotationRenderingEngine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Annotate.Wpf.Renderer Namespace


WpfTextAnnotationRenderingEngine Constructor

Creates a new instance of WpfTextAnnotationRenderingEngine.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WpfTextAnnotationRenderingEngine()
Public Sub New
See Also

Reference

WpfTextAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfTextAnnotationRenderingEngine Methods

The WpfTextAnnotationRenderingEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRenderAnnotation | Called to render the annotation. (Overrides WpfAnnotationRenderingEngineTOnRenderAnnotation(T, WpfRenderEnvironment).)
Public method | RenderAnnotation | Called to render the annotation. (Inherited from WpfAnnotationRenderingEngineT.)
Protected method | RenderLineCap | This method is called to render the a single line cap. (Inherited from WpfAnnotationRenderingEngineT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WpfTextAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


WpfTextAnnotationRenderingEngine.OnRenderAnnotation Method

WpfTextAnnotationRenderingEngineOnRenderAnnotation Method

Called to render the annotation.

Namespace: Atalasoft.Annotate.Wpf.Renderer
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderAnnotation(
    WpfTextAnnotation annotation,
    WpfRenderEnvironment environment
)
Protected Overrides Sub OnRenderAnnotation (
    annotation As WpfTextAnnotation,
    environment As WpfRenderEnvironment
)

Parameters

annotation
Type: Atalasoft.Annotate.WpfWpfTextAnnotation
The annotation to render.
environment
Type: Atalasoft.Annotate.Wpf.RendererWpfRenderEnvironment
A WpfRenderEnvironment containing information used to render the annotation.
See Also

Reference

WpfTextAnnotationRenderingEngine Class
Atalasoft.Annotate.Wpf.Renderer Namespace


Atalasoft.Barcoding.Reading Namespace

Contains classes and interfaces related to barcode recognition.
Classes
 | Class | Description
Public class | AztecOptions | Extra options that apply specifically to the Aztec symbology.
Public class | BarCode | Describes a barcode symbol found within an image.
Public class | BarCodeEventArgs | Provides data for the ReadBarCode event in the BarCodeReader class.
Public class | BarCodeReader | A barcode reader. To read barcodes from an image, create an instance of this class, associate it with the image, and invoke its ReadBars method.
Public class | BarCodeReaderBase | An abstract base class for barcode reading that implements many of the core features.
Public class | BarcodeReaderLicense | This class is used for licensing purposes, or for inspecting the current Edition.
Public class | CodabarOptions | Extra options that apply specifically to the Codabar symbology.
Public class | Pdf417Options | Extra options that apply specifically to the PDF417 symbology.
Public class | QRCodeOptions | Extra options that apply specifically to the QRCode symbology.
Public class | ReadOpts | Encapsulates the options for reading barcodes from images.
Public class | StructuredAppend | Structured Append barcode data
Interfaces
 | Interface | Description
Public interface | BarImageable | Specification for an image data provider.
Delegates
 | Delegate | Description
Public delegate | BarCodeEventHandler | Event handler for events that require a BarCode object.
Enumerations
 | Enumeration | Description
Public enumeration | AztecParsingQuality | Represents the quality of Aztec barcode detection, validation and decoding.
Public enumeration | BarcodeReaderEdition | Defined the type of BarcodeReader license.
Public enumeration | Code39Options | This enumeration represents a set of flags that will affect how Code39 barcodes are read. If you need to read other symbologies in addition to Code39, you should always use the None setting.
Public enumeration | Directions | Read direction identifiers. Flagged.
Public enumeration | ReadingQuality | ReadingQuality balances speed and accuracy of the BarCodeReader object.
Public enumeration | Symbologies | Barcode symbology identifiers. Flagged.


AztecOptions Class

Extra options that apply specifically to the Aztec symbology.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingAztecOptions

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AztecOptions
Public Class AztecOptions

The AztecOptions type exposes the following members.

Properties
 | Name | Description
Public property | AztecParsingQuality | A setting that represents the quality of Aztec barcode detection, validation and decoding.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


AztecOptions Properties

The AztecOptions type exposes the following members.

Properties
 | Name | Description
Public property | AztecParsingQuality | A setting that represents the quality of Aztec barcode detection, validation and decoding.
Top
See Also

Reference

AztecOptions Class
Atalasoft.Barcoding.Reading Namespace


AztecOptions.AztecParsingQuality Property

AztecOptionsAztecParsingQuality Property

A setting that represents the quality of Aztec barcode detection, validation and decoding.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AztecParsingQuality AztecParsingQuality { get; set; }
Public Property AztecParsingQuality As AztecParsingQuality
    Get
    Set

Property Value

Type: AztecParsingQuality
See Also

Reference

AztecOptions Class
Atalasoft.Barcoding.Reading Namespace


AztecOptions Methods

The AztecOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AztecOptions Class
Atalasoft.Barcoding.Reading Namespace


AztecParsingQuality Enumeration

Represents the quality of Aztec barcode detection, validation and decoding.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AztecParsingQuality
Public Enumeration AztecParsingQuality
Members
Member name | Description
Normal | An optimal balance between quality and speed
High | Increases quality a little compared to Normal, but at a considerable cost in speed. Recommended to use only when the Normal setting fails to parse a barcode
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarCode Class

Describes a barcode symbol found within an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingBarCode

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class BarCode
Public NotInheritable Class BarCode

The BarCode type exposes the following members.

Properties
 | Name | Description
Public property | BoundingRect | The bounding rectangle of the barcode.
Public property | CheckCharPos | The index of the check character in the DataString, or -1 if not present.
Public property | Confidence | Represents the detected barcode recognition confidence.
Public property | Data | The raw barcode data as an array of bytes.
Public property | DataString | The data encoded by this barcode, as a String
Public property | EndEdgePoints | Two points delimiting the trailing edge of the barcode.
Public property | ErrorCorrectionLevel | Obsolete. The error correction level.
Public property | HasSupplemental | true if this barcode has a supplemental barcode.
Public property | ReadDirection | The direction in which the barcode was read.
Public property | StartEdgePoints | Two points delimiting the leading edge of the barcode.
Public property | StructAppend | The Structured Append data for this barcode if applicable, else null.
Public property | Supplemental | The supplemental barcode associated with this barcode, or null if none.
Public property | Supplmental | Obsolete. old misspelling of 'Supplemental'.
Public property | Symbology | The symbology of this barcode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The ReadBars method of BarCodeReader returns an array of these. The methods of this class return details of the barcode, including encodation, symbology, and postion within the image.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarCode Properties

The BarCode type exposes the following members.

Properties
 | Name | Description
Public property | BoundingRect | The bounding rectangle of the barcode.
Public property | CheckCharPos | The index of the check character in the DataString, or -1 if not present.
Public property | Confidence | Represents the detected barcode recognition confidence.
Public property | Data | The raw barcode data as an array of bytes.
Public property | DataString | The data encoded by this barcode, as a String
Public property | EndEdgePoints | Two points delimiting the trailing edge of the barcode.
Public property | ErrorCorrectionLevel | Obsolete. The error correction level.
Public property | HasSupplemental | true if this barcode has a supplemental barcode.
Public property | ReadDirection | The direction in which the barcode was read.
Public property | StartEdgePoints | Two points delimiting the leading edge of the barcode.
Public property | StructAppend | The Structured Append data for this barcode if applicable, else null.
Public property | Supplemental | The supplemental barcode associated with this barcode, or null if none.
Public property | Supplmental | Obsolete. old misspelling of 'Supplemental'.
Public property | Symbology | The symbology of this barcode.
Top
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.BoundingRect Property

BarCodeBoundingRect Property

The bounding rectangle of the barcode.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle BoundingRect { get; }
Public ReadOnly Property BoundingRect As Rectangle
    Get

Property Value

Type: Rectangle
A Rectangle that bounds the position within the image of the detected barcode.
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.CheckCharPos Property

BarCodeCheckCharPos Property

The index of the check character in the DataString, or -1 if not present.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CheckCharPos { get; }
Public ReadOnly Property CheckCharPos As Integer
    Get

Property Value

Type: Int32
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.Confidence Property

BarCodeConfidence Property

Represents the detected barcode recognition confidence.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Confidence { get; }
Public ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
The higher the value the better recognition quality is.
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.Data Property

BarCodeData Property

The raw barcode data as an array of bytes.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Data { get; }
Public ReadOnly Property Data As Byte()
    Get

Property Value

Type: Byte
An array of bytes representing the barcode.
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.DataString Property

BarCodeDataString Property

The data encoded by this barcode, as a String

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DataString { get; }
Public ReadOnly Property DataString As String
    Get

Property Value

Type: String
Remarks
Check or stop/start characters may or may not be included depending on the symbology and the EnforceChecksum option setting. The check character is included for symbologies that encode just numeric data, and is not included for other symbologies. Examine CheckCharPos to determine if the check character is included in the DataString.
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.EndEdgePoints Property

BarCodeEndEdgePoints Property

Two points delimiting the trailing edge of the barcode.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point[] EndEdgePoints { get; }
Public ReadOnly Property EndEdgePoints As Point()
    Get

Property Value

Type: Point
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.ErrorCorrectionLevel Property

BarCodeErrorCorrectionLevel Property

Note: This API is now obsolete.

The error correction level.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("BarCode.ErrorCorrectionLevel property is not longer supported and will be removed in future releases.")]
public int ErrorCorrectionLevel { get; }
<ObsoleteAttribute("BarCode.ErrorCorrectionLevel property is not longer supported and will be removed in future releases.")>
Public ReadOnly Property ErrorCorrectionLevel As Integer
    Get

Property Value

Type: Int32
The error correction level, or -1 if the symbology does not have more than one error correction level.
Remarks
If the symbology's error correction level is specified by a character (i.e. QR Code: L, M, H or Q) then cast the return value to a char.
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.HasSupplemental Property

BarCodeHasSupplemental Property

true if this barcode has a supplemental barcode.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasSupplemental { get; }
Public ReadOnly Property HasSupplemental As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.ReadDirection Property

BarCodeReadDirection Property

The direction in which the barcode was read.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Directions ReadDirection { get; }
Public ReadOnly Property ReadDirection As Directions
    Get

Property Value

Type: Directions
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.StartEdgePoints Property

BarCodeStartEdgePoints Property

Two points delimiting the leading edge of the barcode.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point[] StartEdgePoints { get; }
Public ReadOnly Property StartEdgePoints As Point()
    Get

Property Value

Type: Point
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.StructAppend Property

BarCodeStructAppend Property

The Structured Append data for this barcode if applicable, else null.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StructuredAppend StructAppend { get; }
Public ReadOnly Property StructAppend As StructuredAppend
    Get

Property Value

Type: StructuredAppend
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.Supplemental Property

BarCodeSupplemental Property

The supplemental barcode associated with this barcode, or null if none.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCode Supplemental { get; }
Public ReadOnly Property Supplemental As BarCode
    Get

Property Value

Type: BarCode
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.Supplmental Property

BarCodeSupplmental Property

Note: This API is now obsolete.

old misspelling of 'Supplemental'.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("use Supplemental instead")]
public BarCode Supplmental { get; }
<ObsoleteAttribute("use Supplemental instead")>
Public ReadOnly Property Supplmental As BarCode
    Get

Property Value

Type: BarCode
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode.Symbology Property

BarCodeSymbology Property

The symbology of this barcode.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Symbologies Symbology { get; }
Public ReadOnly Property Symbology As Symbologies
    Get

Property Value

Type: Symbologies
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCode Methods

The BarCode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarCode Class
Atalasoft.Barcoding.Reading Namespace


BarCodeEventArgs Class

Provides data for the ReadBarCode event in the BarCodeReader class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Barcoding.ReadingBarCodeEventArgs

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BarCodeEventArgs : EventArgs
Public Class BarCodeEventArgs
    Inherits EventArgs

The BarCodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeEventArgs | Creates a new instance of BarCodeEventArgs.
Top
Properties
 | Name | Description
Public property | BarCode | The BarCode associated with this event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarCodeEventArgs Constructor

Creates a new instance of BarCodeEventArgs.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeEventArgs(
    BarCode barCode
)
Public Sub New (
    barCode As BarCode
)

Parameters

barCode
Type: Atalasoft.Barcoding.ReadingBarCode
The associated BarCode
See Also

Reference

BarCodeEventArgs Class
Atalasoft.Barcoding.Reading Namespace


BarCodeEventArgs Properties

The BarCodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BarCode | The BarCode associated with this event
Top
See Also

Reference

BarCodeEventArgs Class
Atalasoft.Barcoding.Reading Namespace


BarCodeEventArgs.BarCode Property

BarCodeEventArgsBarCode Property

The BarCode associated with this event

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCode BarCode { get; set; }
Public Property BarCode As BarCode
    Get
    Set

Property Value

Type: BarCode
See Also

Reference

BarCodeEventArgs Class
Atalasoft.Barcoding.Reading Namespace


BarCodeEventArgs Methods

The BarCodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarCodeEventArgs Class
Atalasoft.Barcoding.Reading Namespace


BarCodeEventHandler Delegate

Event handler for events that require a BarCode object.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void BarCodeEventHandler(
    Object sender,
    BarCodeEventArgs e
)
Public Delegate Sub BarCodeEventHandler (
    sender As Object,
    e As BarCodeEventArgs
)

Parameters

sender
Type: SystemObject
The originating object of the event (typically BarCodeReader).
e
Type: Atalasoft.Barcoding.ReadingBarCodeEventArgs
The event args.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarCodeReader Class

A barcode reader. To read barcodes from an image, create an instance of this class, associate it with the image, and invoke its ReadBars method.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingBarCodeReaderBase
Atalasoft.Barcoding.ReadingBarCodeReader

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class BarCodeReader : BarCodeReaderBase,
    IDisposable
Public NotInheritable Class BarCodeReader
    Inherits BarCodeReaderBase
    Implements IDisposable

The BarCodeReader type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeReader | Initializes a new instance of the BarCodeReader class
Public method | BarCodeReader(AtalaImage) | Creates a BarCodeReader for a specified AtalaImage image.
Public method | BarCodeReader(BarImageable) | Creates a BarCodeReader for an image represented by the specified image data provider.
Public method | BarCodeReader(AtalaImage, ImageCommand) | Construct a new BarCodeReader with the supplied image and apply the thresholdCommand to the image.
Public method | BarCodeReader(AtalaImage, Boolean) | Create a BarCodeReader for a specified AtalaImage image and conditionally threshold the image.
Top
Properties
 | Name | Description
Public property | AutoDetect1D | Obsolete. AutoDetect1D
Public property | SupportedSymbologies | Returns all the licensed and supported symbologies for the BarCodeReader. (Inherited from BarCodeReaderBase.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BarCodeReader
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSymbologySupported | Indicates is a symbology is supported by a BarCodeReader. (Inherited from BarCodeReaderBase.)
Public method | ReadBars | Read barcodes in the image. (Inherited from BarCodeReaderBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ReadBarCode | This event is fired after a barcode is found (Inherited from BarCodeReaderBase.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarCodeReader Constructor

Constructs a new BarCodeReader class.
Overload List
 | Name | Description
Public method | BarCodeReader | Initializes a new instance of the BarCodeReader class
Public method | BarCodeReader(AtalaImage) | Creates a BarCodeReader for a specified AtalaImage image.
Public method | BarCodeReader(BarImageable) | Creates a BarCodeReader for an image represented by the specified image data provider.
Public method | BarCodeReader(AtalaImage, ImageCommand) | Construct a new BarCodeReader with the supplied image and apply the thresholdCommand to the image.
Public method | BarCodeReader(AtalaImage, Boolean) | Create a BarCodeReader for a specified AtalaImage image and conditionally threshold the image.
Top
See Also

Reference

BarCodeReader Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Constructor

Initializes a new instance of the BarCodeReader class

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReader()
Public Sub New
See Also

Reference

BarCodeReader Class
BarCodeReader Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Constructor (AtalaImage)

Creates a BarCodeReader for a specified AtalaImage image.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReader(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage image.

Return Value

Type:
Use this constructor if the image is available as a AtalaImage. T his is the preferred constructor because this class is optimized for rapid access to AtalaImage pixel data.
See Also

Reference

BarCodeReader Class
BarCodeReader Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Constructor (BarImageable)

Creates a BarCodeReader for an image represented by the specified image data provider.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReader(
    BarImageable image
)
Public Sub New (
    image As BarImageable
)

Parameters

image
Type: Atalasoft.Barcoding.ReadingBarImageable
An image data provider.
Remarks
Use this constructor if the image data is in some private or proprietory format and it is not convenient to create an AtalaImage from the data.
See Also

Reference

BarCodeReader Class
BarCodeReader Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Constructor (AtalaImage, ImageCommand)

Construct a new BarCodeReader with the supplied image and apply the thresholdCommand to the image.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReader(
    AtalaImage image,
    ImageCommand thresholdCommand
)
Public Sub New (
    image As AtalaImage,
    thresholdCommand As ImageCommand
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage image.
thresholdCommand
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand to perform conversion to black and white.
Remarks
If the image passed in is 1-bit, the thresholdCommand is ignored. If the resulting image from applying the threshold command is not Pixel1bppIndexed, it will be ignored.
See Also

Reference

BarCodeReader Class
BarCodeReader Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Constructor (AtalaImage, Boolean)

Create a BarCodeReader for a specified AtalaImage image and conditionally threshold the image.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReader(
    AtalaImage image,
    bool autoThreshold
)
Public Sub New (
    image As AtalaImage,
    autoThreshold As Boolean
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage
autoThreshold
Type: SystemBoolean
If true, the image will be converted to black and white using the DynamicThreshold command if it is licensed (DocumentImaging) or the ThresholdCommand otherwise.
Remarks
This is the preferred constructor to use as it will result in the fastest barcode reading.
See Also

Reference

BarCodeReader Class
BarCodeReader Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Properties

The BarCodeReader type exposes the following members.

Properties
 | Name | Description
Public property | AutoDetect1D | Obsolete. AutoDetect1D
Public property | SupportedSymbologies | Returns all the licensed and supported symbologies for the BarCodeReader. (Inherited from BarCodeReaderBase.)
Top
See Also

Reference

BarCodeReader Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReader.AutoDetect1D Property

BarCodeReaderAutoDetect1D Property

Note: This API is now obsolete.

AutoDetect1D

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("AutoDetect1D property is no longer supported and will be removed in future releases.")]
public bool AutoDetect1D { get; set; }
<ObsoleteAttribute("AutoDetect1D property is no longer supported and will be removed in future releases.")>
Public Property AutoDetect1D As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

BarCodeReader Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Methods

The BarCodeReader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSymbologySupported | Indicates is a symbology is supported by a BarCodeReader. (Inherited from BarCodeReaderBase.)
Public method | ReadBars | Read barcodes in the image. (Inherited from BarCodeReaderBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarCodeReader Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReader.Dispose Method

BarCodeReaderDispose Method

Releases all resources used by the BarCodeReader

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
The BarCodeReader holds onto a number of resources that need to be disposed. It is strongly advised that you dispose any BarCodeReader objects as soon as you are done with them.
See Also

Reference

BarCodeReader Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReader Events

The BarCodeReader type exposes the following members.

Events
 | Name | Description
Public event | ReadBarCode | This event is fired after a barcode is found (Inherited from BarCodeReaderBase.)
Top
See Also

Reference

BarCodeReader Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Class

An abstract base class for barcode reading that implements many of the core features.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingBarCodeReaderBase
Atalasoft.Barcoding.ReadingBarCodeReader

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BarCodeReaderBase
Public MustInherit Class BarCodeReaderBase

The BarCodeReaderBase type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeReaderBase | Default constructor for the BarCodeReaderBase class
Public method | BarCodeReaderBase(AtalaImage) | Constructor for the BarCodeReaderBase class
Public method | BarCodeReaderBase(BarImageable) | Constructor for the BarCodeReaderBase class
Top
Properties
 | Name | Description
Protected property | Image | AtalaImage being searched by this barcode reader
Protected property | LLSupportedSymbologies | (virtual) property: symbologies implemented by this reader, whether or not licensed.
Public property | SupportedSymbologies | Returns all the licensed and supported symbologies for the BarCodeReader.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Has1DOtherThanCode39 | test if symbology set contains any 1D symbologies other than Code39
Protected method | HasAny1D | test if symbology set contains any 1D symbologies
Protected method | HasAny2D | test if symbology set contains any 2D symbologies
Protected method | IsJust1D | test if symbology set contains 1D symbologies but no 2D
Protected method | IsJust2D | test if symbology set contains 2D symbologies but no 1D
Public method | IsSymbologySupported | Indicates is a symbology is supported by a BarCodeReader.
Protected method | LLReadBars | (virtual) low-level barcode reading function
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnReadBarCode | virtual method to fire barcode event
Public method | ReadBars | Read barcodes in the image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ReadBarCode | This event is fired after a barcode is found
Top
Fields
Name | Description
LOG_NAME |
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Constructor

Overload List
 | Name | Description
Public method | BarCodeReaderBase | Default constructor for the BarCodeReaderBase class
Public method | BarCodeReaderBase(AtalaImage) | Constructor for the BarCodeReaderBase class
Public method | BarCodeReaderBase(BarImageable) | Constructor for the BarCodeReaderBase class
Top
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Constructor

Default constructor for the BarCodeReaderBase class

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReaderBase()
Public Sub New
See Also

Reference

BarCodeReaderBase Class
BarCodeReaderBase Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Constructor (AtalaImage)

Constructor for the BarCodeReaderBase class

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReaderBase(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
AtalaImage to search for barcodes
See Also

Reference

BarCodeReaderBase Class
BarCodeReaderBase Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Constructor (BarImageable)

Constructor for the BarCodeReaderBase class

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeReaderBase(
    BarImageable image
)
Public Sub New (
    image As BarImageable
)

Parameters

image
Type: Atalasoft.Barcoding.ReadingBarImageable
BarImageable image to search for barcodes
See Also

Reference

BarCodeReaderBase Class
BarCodeReaderBase Overload
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Properties

The BarCodeReaderBase type exposes the following members.

Properties
 | Name | Description
Protected property | Image | AtalaImage being searched by this barcode reader
Protected property | LLSupportedSymbologies | (virtual) property: symbologies implemented by this reader, whether or not licensed.
Public property | SupportedSymbologies | Returns all the licensed and supported symbologies for the BarCodeReader.
Top
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.Image Property

BarCodeReaderBaseImage Property

AtalaImage being searched by this barcode reader

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage Image { get; set; }
Protected Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.LLSupportedSymbologies Property

BarCodeReaderBaseLLSupportedSymbologies Property

(virtual) property: symbologies implemented by this reader, whether or not licensed.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract Symbologies LLSupportedSymbologies { get; }
Protected MustOverride ReadOnly Property LLSupportedSymbologies As Symbologies
    Get

Property Value

Type: Symbologies
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.SupportedSymbologies Property

BarCodeReaderBaseSupportedSymbologies Property

Returns all the licensed and supported symbologies for the BarCodeReader.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Symbologies SupportedSymbologies { get; }
Public ReadOnly Property SupportedSymbologies As Symbologies
    Get

Property Value

Type: Symbologies
A Symbologies enumeration representing all the supported symbologies for the BarCodeReader. Symbologies not licensed will not be reported.
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Methods

The BarCodeReaderBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Has1DOtherThanCode39 | test if symbology set contains any 1D symbologies other than Code39
Protected method | HasAny1D | test if symbology set contains any 1D symbologies
Protected method | HasAny2D | test if symbology set contains any 2D symbologies
Protected method | IsJust1D | test if symbology set contains 1D symbologies but no 2D
Protected method | IsJust2D | test if symbology set contains 2D symbologies but no 1D
Public method | IsSymbologySupported | Indicates is a symbology is supported by a BarCodeReader.
Protected method | LLReadBars | (virtual) low-level barcode reading function
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnReadBarCode | virtual method to fire barcode event
Public method | ReadBars | Read barcodes in the image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.Has1DOtherThanCode39 Method

BarCodeReaderBaseHas1DOtherThanCode39 Method

test if symbology set contains any 1D symbologies other than Code39

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool Has1DOtherThanCode39(
    Symbologies sym
)
Protected Function Has1DOtherThanCode39 (
    sym As Symbologies
) As Boolean

Parameters

sym
Type: Atalasoft.Barcoding.ReadingSymbologies
symbology set

Return Value

Type: Boolean
true if sym contains at least one 1D symbology OTHER THAN Code39
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.HasAny1D Method

BarCodeReaderBaseHasAny1D Method

test if symbology set contains any 1D symbologies

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool HasAny1D(
    Symbologies sym
)
Protected Function HasAny1D (
    sym As Symbologies
) As Boolean

Parameters

sym
Type: Atalasoft.Barcoding.ReadingSymbologies
symbology set

Return Value

Type: Boolean
true if sym contains at least one 1D symbology
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.HasAny2D Method

BarCodeReaderBaseHasAny2D Method

test if symbology set contains any 2D symbologies

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool HasAny2D(
    Symbologies sym
)
Protected Function HasAny2D (
    sym As Symbologies
) As Boolean

Parameters

sym
Type: Atalasoft.Barcoding.ReadingSymbologies
symbology set

Return Value

Type: Boolean
true if sym contains at least one 2D symbology
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.IsJust1D Method

BarCodeReaderBaseIsJust1D Method

test if symbology set contains 1D symbologies but no 2D

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsJust1D(
    Symbologies sym
)
Protected Function IsJust1D (
    sym As Symbologies
) As Boolean

Parameters

sym
Type: Atalasoft.Barcoding.ReadingSymbologies
symbology set

Return Value

Type: Boolean
true if sym contains 1D but no 2D symbologies
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.IsJust2D Method

BarCodeReaderBaseIsJust2D Method

test if symbology set contains 2D symbologies but no 1D

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsJust2D(
    Symbologies sym
)
Protected Function IsJust2D (
    sym As Symbologies
) As Boolean

Parameters

sym
Type: Atalasoft.Barcoding.ReadingSymbologies
symbology set

Return Value

Type: Boolean
true if sym contains 2D but no 1D symbologies
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.IsSymbologySupported Method

BarCodeReaderBaseIsSymbologySupported Method

Indicates is a symbology is supported by a BarCodeReader.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSymbologySupported(
    Symbologies sym
)
Public Function IsSymbologySupported (
    sym As Symbologies
) As Boolean

Parameters

sym
Type: Atalasoft.Barcoding.ReadingSymbologies
The symbology or symbologies to check support for.

Return Value

Type: Boolean
True if the symbology is supported, false otherwise.
Remarks

IsSymbologySupported will only report what the barcode reader is licensed to support. If the license is only for 1D, it will return true only for 1D barcodes.

IsSymbologySupported will check for multiple symbologies at once, returning true only if all requested symbologies are supported.

If a symbology is not supported, ReadBars(ReadOpts) will ignore it.

See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.LLReadBars Method

BarCodeReaderBaseLLReadBars Method

(virtual) low-level barcode reading function

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract BarCode[] LLReadBars(
    ReadOpts readOpts
)
Protected MustOverride Function LLReadBars (
    readOpts As ReadOpts
) As BarCode()

Parameters

readOpts
Type: Atalasoft.Barcoding.ReadingReadOpts
recognition options

Return Value

Type: BarCode
array of recognized symbols
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.OnReadBarCode Method

BarCodeReaderBaseOnReadBarCode Method

virtual method to fire barcode event

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnReadBarCode(
    BarCodeEventArgs e
)
Protected Overridable Sub OnReadBarCode (
    e As BarCodeEventArgs
)

Parameters

e
Type: Atalasoft.Barcoding.ReadingBarCodeEventArgs
event to fire (a recognized symbol)
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.ReadBars Method

BarCodeReaderBaseReadBars Method

Read barcodes in the image.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCode[] ReadBars(
    ReadOpts readOpts
)
Public Function ReadBars (
    readOpts As ReadOpts
) As BarCode()

Parameters

readOpts
Type: Atalasoft.Barcoding.ReadingReadOpts
Specifying the options to use in reading the image.

Return Value

Type: BarCode
An array of BarCode instances. Each element represents a barcode read from the image. The size of the collection is zero if no barcodes are read.
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Events

The BarCodeReaderBase type exposes the following members.

Events
 | Name | Description
Public event | ReadBarCode | This event is fired after a barcode is found
Top
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.ReadBarCode Event

BarCodeReaderBaseReadBarCode Event

This event is fired after a barcode is found

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event BarCodeEventHandler ReadBarCode
Public Event ReadBarCode As BarCodeEventHandler

Value

Type: Atalasoft.Barcoding.ReadingBarCodeEventHandler
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase Fields

The BarCodeReaderBase type exposes the following members.

Fields
Name | Description
LOG_NAME |
Top
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarCodeReaderBase.LOG_NAME Field

BarCodeReaderBaseLOG_NAME Field

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected const string LOG_NAME = "BarCodeReader"
Protected Const LOG_NAME As String = "BarCodeReader"

Field Value

Type: String
See Also

Reference

BarCodeReaderBase Class
Atalasoft.Barcoding.Reading Namespace


BarcodeReaderEdition Enumeration

Defined the type of BarcodeReader license.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BarcodeReaderEdition
Public Enumeration BarcodeReaderEdition
Members
Member name | Description
Code39 | Supports recognizing only Code39.
All1D | Supports recognizing all 1-D barcodes.
All1Dand2D | Supports recognizing all 1-D barcodes and all 2-D barcodes.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarcodeReaderLicense Class

This class is used for licensing purposes, or for inspecting the current Edition.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingBarcodeReaderLicense

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class BarcodeReaderLicense
Public NotInheritable Class BarcodeReaderLicense

The BarcodeReaderLicense type exposes the following members.

Properties
Name | Description
Edition | Gets the license edition for the BarCodeReader.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarcodeReaderLicense Properties

The BarcodeReaderLicense type exposes the following members.

Properties
Name | Description
Edition | Gets the license edition for the BarCodeReader.
Top
See Also

Reference

BarcodeReaderLicense Class
Atalasoft.Barcoding.Reading Namespace


BarcodeReaderLicense.Edition Property

BarcodeReaderLicenseEdition Property

Gets the license edition for the BarCodeReader.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static BarcodeReaderEdition Edition { get; }
Public Shared ReadOnly Property Edition As BarcodeReaderEdition
    Get

Property Value

Type: BarcodeReaderEdition
See Also

Reference

BarcodeReaderLicense Class
Atalasoft.Barcoding.Reading Namespace


BarcodeReaderLicense Methods

The BarcodeReaderLicense type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarcodeReaderLicense Class
Atalasoft.Barcoding.Reading Namespace


BarImageable Interface

Specification for an image data provider.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface BarImageable
Public Interface BarImageable

The BarImageable type exposes the following members.

Properties
 | Name | Description
Public property | Height | Determines the height of the image.
Public property | Width | Determines the width of the image.
Top
Methods
 | Name | Description
Public method | GetColumnIntensities | Get the intensities of a pixel column.
Public method | GetIntensity | Gets a pixel intensity.
Public method | GetRowIntensities | Get the intensities of a pixel row.
Public method | Lock | Invoked by ReadBars before it gets pixel data by invoking any of GetIntensity(Int32, Int32), GetColumnIntensities(Int32, Int32), and GetRowIntensities(Int32, Int32).
Public method | Unlock | Invoked by ReadBars after it has obtained pixel data through invocations of GetIntensity(Int32, Int32), GetColumnIntensities(Int32, Int32), or GetRowIntensities(Int32, Int32).
Top
Remarks
A class that encapsulates image data, and which is not an AtalaImage can implement this interface in order to provide image data. An application whose image data is represented by some other class can define an equivalent implementation of this interface with which to invoke the BarCodeReader constructor.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


BarImageable Properties

The BarImageable type exposes the following members.

Properties
 | Name | Description
Public property | Height | Determines the height of the image.
Public property | Width | Determines the width of the image.
Top
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.Height Property

BarImageableHeight Property

Determines the height of the image.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Height { get; }
ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
The height of the image in pixels.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.Width Property

BarImageableWidth Property

Determines the width of the image.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Width { get; }
ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
The width of the image in pixels.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable Methods

The BarImageable type exposes the following members.

Methods
 | Name | Description
Public method | GetColumnIntensities | Get the intensities of a pixel column.
Public method | GetIntensity | Gets a pixel intensity.
Public method | GetRowIntensities | Get the intensities of a pixel row.
Public method | Lock | Invoked by ReadBars before it gets pixel data by invoking any of GetIntensity(Int32, Int32), GetColumnIntensities(Int32, Int32), and GetRowIntensities(Int32, Int32).
Public method | Unlock | Invoked by ReadBars after it has obtained pixel data through invocations of GetIntensity(Int32, Int32), GetColumnIntensities(Int32, Int32), or GetRowIntensities(Int32, Int32).
Top
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.GetColumnIntensities Method

BarImageableGetColumnIntensities Method

Get the intensities of a pixel column.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void GetColumnIntensities(
    int column,
    int[] columnIntensities
)
Sub GetColumnIntensities (
    column As Integer,
    columnIntensities As Integer()
)

Parameters

column
Type: SystemInt32
The pixel column number.
columnIntensities
Type: SystemInt32
An array (of length not less than Height) to be populated with the intensity (0-255) of each pixel in the specified column.

Return Value

Type:
The intensity (0-255) of each pixel in the specified column.
Remarks
This method is time critical: its execution time can impact significantly on the time taken by ReadBars to execute.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.GetIntensity Method

BarImageableGetIntensity Method

Gets a pixel intensity.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int GetIntensity(
    int x,
    int y
)
Function GetIntensity (
    x As Integer,
    y As Integer
) As Integer

Parameters

x
Type: SystemInt32
The horizontal coordinate of a pixel in the image.
y
Type: SystemInt32
The vertical coordinate of a pixel in the image.

Return Value

Type: Int32
The intensity (0-255) of the pixel.
Remarks
This method is time critical: its execution time impacts significantly on the time taken by ReadBars to execute.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.GetRowIntensities Method

BarImageableGetRowIntensities Method

Get the intensities of a pixel row.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int GetRowIntensities(
    int row,
    int[] rowIntensities
)
Function GetRowIntensities (
    row As Integer,
    rowIntensities As Integer()
) As Integer

Parameters

row
Type: SystemInt32
The pixel row number.
rowIntensities
Type: SystemInt32
An array (of length not less than Width) to be populated with the intensity (0-255) of each pixel in the specified row.

Return Value

Type: Int32
The intensity (0-255) of each pixel in the specified row.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.Lock Method

BarImageableLock Method

Invoked by ReadBars before it gets pixel data by invoking any of GetIntensity(Int32, Int32), GetColumnIntensities(Int32, Int32), and GetRowIntensities(Int32, Int32).

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Lock()
Sub Lock
Remarks
If, for example, the position of the image data in memory needs to be temporarily fixed before it is accessed, then this method is the appropriate place to do it.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


BarImageable.Unlock Method

BarImageableUnlock Method

Invoked by ReadBars after it has obtained pixel data through invocations of GetIntensity(Int32, Int32), GetColumnIntensities(Int32, Int32), or GetRowIntensities(Int32, Int32).

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Unlock()
Sub Unlock
Remarks
If, for example, the position of the image data in memory has been fixed in Lock(), then this method is the appropriate place to release it.
See Also

Reference

BarImageable Interface
Atalasoft.Barcoding.Reading Namespace


CodabarOptions Class

Extra options that apply specifically to the Codabar symbology.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingCodabarOptions

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CodabarOptions
Public Class CodabarOptions

The CodabarOptions type exposes the following members.

Properties
 | Name | Description
Public property | IncludeStartStopToDataString | Indicates whether or not the Codabar parser should include start and stop markers to the result data string.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


CodabarOptions Properties

The CodabarOptions type exposes the following members.

Properties
 | Name | Description
Public property | IncludeStartStopToDataString | Indicates whether or not the Codabar parser should include start and stop markers to the result data string.
Top
See Also

Reference

CodabarOptions Class
Atalasoft.Barcoding.Reading Namespace


CodabarOptions.IncludeStartStopToDataString Property

CodabarOptionsIncludeStartStopToDataString Property

Indicates whether or not the Codabar parser should include start and stop markers to the result data string.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncludeStartStopToDataString { get; set; }
Public Property IncludeStartStopToDataString As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
The alphabet characters A, B, C, D (in some specifications, E, N, asterisk, and T) are used to mark the beginning and end of the barcode. Usually they do not appear in the body of a Codabar string.
See Also

Reference

CodabarOptions Class
Atalasoft.Barcoding.Reading Namespace


CodabarOptions Methods

The CodabarOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodabarOptions Class
Atalasoft.Barcoding.Reading Namespace


Code39Options Enumeration

This enumeration represents a set of flags that will affect how Code39 barcodes are read. If you need to read other symbologies in addition to Code39, you should always use the None setting.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum Code39Options
<FlagsAttribute>
Public Enumeration Code39Options
Members
Member name | Description
None | No options set.
DontRequireStartStop | Do not require start/stop marks when reading Code39 symbols. This may produce false positives when reading barcodes.
DisableFullASCII | Disable full ASCII encoding in Code 39 barcodes - decode 43-char basic Code39.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


Directions Enumeration

Read direction identifiers. Flagged.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum Directions
<FlagsAttribute>
Public Enumeration Directions
Members
Member name | Description
None | Represents no directions. Not recommended in general use.
East | Easterly scan (horizontally, left to right).
South | Southerly scan (vertically, top to bottom).
West | Westerly scan (horizontally, right to left).
North | Northerly scan (vertically, bottom to top).
NorthEast | Northeasterly scan (diagonally, lower left to upper right).
SouthEast | Southeasterly scan (diagonally, upper right to lower left).
SouthWest | Southwesterly scan (diagonally, upper right to lower left).
NorthWest | Northwesterly scan (diagonally, lower right to upper left).
All | Represents all supported directions.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


Pdf417Options Class

Extra options that apply specifically to the PDF417 symbology.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingPdf417Options

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Pdf417Options
Public Class Pdf417Options

The Pdf417Options type exposes the following members.

Properties
 | Name | Description
Public property | EnhancedBoundaryLocation | Indicates whether or not the PDF417 parser should enable an additional routine to help it find the locations and boundaries of individual blocks/strips within the barcode more accurately.
Public property | IgnoreStartRowIndicatorErrors | Indicates whether or not the PDF417 parser should ignore potential errors during start row indicator analyzing. Enabled by default.
Public property | OutputMacroPdf417Header | Indicates whether or not the PDF417 parser should output data from the Macro PDF417 header at the end of the barcode, should one be found.
Public property | ReadTruncatedPdf417 | Indicates whether or not the PDF417 parser should also search for truncated PDF417.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


Pdf417Options Properties

The Pdf417Options type exposes the following members.

Properties
 | Name | Description
Public property | EnhancedBoundaryLocation | Indicates whether or not the PDF417 parser should enable an additional routine to help it find the locations and boundaries of individual blocks/strips within the barcode more accurately.
Public property | IgnoreStartRowIndicatorErrors | Indicates whether or not the PDF417 parser should ignore potential errors during start row indicator analyzing. Enabled by default.
Public property | OutputMacroPdf417Header | Indicates whether or not the PDF417 parser should output data from the Macro PDF417 header at the end of the barcode, should one be found.
Public property | ReadTruncatedPdf417 | Indicates whether or not the PDF417 parser should also search for truncated PDF417.
Top
See Also

Reference

Pdf417Options Class
Atalasoft.Barcoding.Reading Namespace


Pdf417Options.EnhancedBoundaryLocation Property

Pdf417OptionsEnhancedBoundaryLocation Property

Indicates whether or not the PDF417 parser should enable an additional routine to help it find the locations and boundaries of individual blocks/strips within the barcode more accurately.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnhancedBoundaryLocation { get; set; }
Public Property EnhancedBoundaryLocation As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
The aformentioned routine, when enabled, typically improves recognition performance for PDF417 barcodes. However in rare cases this routine may have a deleterious effect and prevent a barcode from being recognized successfully. If a seemingly fine barcode isn't being detected, try disabling this option to see if it helps. Enabled by default.
See Also

Reference

Pdf417Options Class
Atalasoft.Barcoding.Reading Namespace


Pdf417Options.IgnoreStartRowIndicatorErrors Property

Pdf417OptionsIgnoreStartRowIndicatorErrors Property

Indicates whether or not the PDF417 parser should ignore potential errors during start row indicator analyzing. Enabled by default.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IgnoreStartRowIndicatorErrors { get; set; }
Public Property IgnoreStartRowIndicatorErrors As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Disabling this option may lead to reducing false positive or corrupted results but at same time low quality barcodes will not be detected.
See Also

Reference

Pdf417Options Class
Atalasoft.Barcoding.Reading Namespace


Pdf417Options.OutputMacroPdf417Header Property

Pdf417OptionsOutputMacroPdf417Header Property

Indicates whether or not the PDF417 parser should output data from the Macro PDF417 header at the end of the barcode, should one be found.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OutputMacroPdf417Header { get; set; }
Public Property OutputMacroPdf417Header As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Macro PDF417 is an extention to the PDF417 standard allowing content to be spread out over multiple PDF417 barcodes. It takes the form of an optional special header that's present right at the end of a standard PDF417 barcode. This header contains meta-information about what series of barcodes this particular barcode belongs to, and what its position in the order is. Our barcode framework does not support the output of concatonated content from multiple barcodes, but it is quite feasable for a client of our API to implement such functionality manually. Thus the existence of this option - causing the output of this data, and therefore allowing for its interpretation by outside code. Disabled by default.
See Also

Reference

Pdf417Options Class
Atalasoft.Barcoding.Reading Namespace


Pdf417Options.ReadTruncatedPdf417 Property

Pdf417OptionsReadTruncatedPdf417 Property

Indicates whether or not the PDF417 parser should also search for truncated PDF417.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ReadTruncatedPdf417 { get; set; }
Public Property ReadTruncatedPdf417 As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Truncated PDF417 is a variant of the PDF417 symbology where the stop pattern at the end of the code can be omitted to save space. Searching for truncated PDF417 can be time-consuming, particularly when searching poor quality images. If you only expect to encounter standard PDF417 barcodes, disabling this option may speed up recognition. Enabled by default.
See Also

Reference

Pdf417Options Class
Atalasoft.Barcoding.Reading Namespace


Pdf417Options Methods

The Pdf417Options type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pdf417Options Class
Atalasoft.Barcoding.Reading Namespace


QRCodeOptions Class

Extra options that apply specifically to the QRCode symbology.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingQRCodeOptions

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class QRCodeOptions
Public Class QRCodeOptions

The QRCodeOptions type exposes the following members.

Properties
 | Name | Description
Public property | Blur | Enables additional detection procedure with BlurCommand preprocessing. By default the value is True.
Public property | DetectMirroredQRCodes | Enables attempt to recognize QRCode barcodes on the mirrored image. By default the value is False.
Public property | DetectNonSquareQRCodes | Enables attempt to recognize "non-square" QRCode barcodes. By default the value is False.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


QRCodeOptions Properties

The QRCodeOptions type exposes the following members.

Properties
 | Name | Description
Public property | Blur | Enables additional detection procedure with BlurCommand preprocessing. By default the value is True.
Public property | DetectMirroredQRCodes | Enables attempt to recognize QRCode barcodes on the mirrored image. By default the value is False.
Public property | DetectNonSquareQRCodes | Enables attempt to recognize "non-square" QRCode barcodes. By default the value is False.
Top
See Also

Reference

QRCodeOptions Class
Atalasoft.Barcoding.Reading Namespace


QRCodeOptions.Blur Property

QRCodeOptionsBlur Property

Enables additional detection procedure with BlurCommand preprocessing. By default the value is True.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Blur { get; set; }
Public Property Blur As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

QRCodeOptions Class
Atalasoft.Barcoding.Reading Namespace


QRCodeOptions.DetectMirroredQRCodes Property

QRCodeOptionsDetectMirroredQRCodes Property

Enables attempt to recognize QRCode barcodes on the mirrored image. By default the value is False.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DetectMirroredQRCodes { get; set; }
Public Property DetectMirroredQRCodes As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Enabling this property leads to the additional detection routines which increases barcodes detection time.
See Also

Reference

QRCodeOptions Class
Atalasoft.Barcoding.Reading Namespace


QRCodeOptions.DetectNonSquareQRCodes Property

QRCodeOptionsDetectNonSquareQRCodes Property

Enables attempt to recognize "non-square" QRCode barcodes. By default the value is False.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DetectNonSquareQRCodes { get; set; }
Public Property DetectNonSquareQRCodes As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Enabling this property leads to the additional detection routines which can increase barcodes detection time and possible false positive results.
See Also

Reference

QRCodeOptions Class
Atalasoft.Barcoding.Reading Namespace


QRCodeOptions Methods

The QRCodeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QRCodeOptions Class
Atalasoft.Barcoding.Reading Namespace


ReadingQuality Enumeration

ReadingQuality balances speed and accuracy of the BarCodeReader object.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ReadingQuality
Public Enumeration ReadingQuality
Members
Member name | Description
Default | This setting attempts to balance speed and accuracy.
MostAccurate | This setting sacrifices speed for accuracy.
Fastest | This setting sacrifices accuracy in favor of speed.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


ReadOpts Class

Encapsulates the options for reading barcodes from images.
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingReadOpts

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ReadOpts
Public Class ReadOpts

The ReadOpts type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOpts | Creates an instance with each property initialised as described in the Public Instance Properties section.
Public method | ReadOpts(ReadOpts) | Creates a new instance, initialized to match the values of the specified ReadOpts.
Top
Properties
 | Name | Description
Public property | AztecOptions | Additional options specific to the Aztec symbology.
Public property | CodabarOptions | Additional options specific to the Codabar symbology.
Public property | Code39Options | Reading options specific to the Code39 symbology
Public property | Direction | Enabled barcode orientations
Public property | EnableRescan | Enable/Disable rescan procedure on the local region for detection results with low confidence. Default value: true.
Public property | EnforceChecksum | Enforce the checksum in those symbologies in which a checksum character is optional. Initialized to false by constructor.
Public property | Pdf417Options | Additional options specific to the PDF417 symbology.
Public property | QRCodeOptions | Additional options specific to the QRCode symbology.
Public property | QuietZoneTolerance | How strongly to enforce quiet zone requirements, from 0.0 (ignore them) to 1.0 (enforce strictly). Default: 1.0
Public property | ReadingQuality | Gets or sets the speed or accuracy of the BarCodeReader.
Public property | RectOfInterest | Gets or sets a rectangular region of the image to look for barcodes.
Public property | ScanBarsToRead | Gets or sets the number of bars to attempt to read. The value of this field is not significant when searching two color (e.g. black and white) images for one-dimensional or stacked symbols. Initialised to Int32.MaxValue by constructor.
Public property | ScanInterval | Gets or sets the scan interval. Initialized to 5 by constructor.
Public property | SkipAllValidation | Sets or gets whether or not the barcode reader should skip validation.
Public property | Symbology | Gets or sets the barcode symbology
Public property | XOptions | Obsolete. Extra options for configuring the reader.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


ReadOpts Constructor

Constructs a new ReadOpts object.
Overload List
 | Name | Description
Public method | ReadOpts | Creates an instance with each property initialised as described in the Public Instance Properties section.
Public method | ReadOpts(ReadOpts) | Creates a new instance, initialized to match the values of the specified ReadOpts.
Top
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts Constructor

Creates an instance with each property initialised as described in the Public Instance Properties section.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOpts()
Public Sub New
See Also

Reference

ReadOpts Class
ReadOpts Overload
Atalasoft.Barcoding.Reading Namespace


ReadOpts Constructor (ReadOpts)

Creates a new instance, initialized to match the values of the specified ReadOpts.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOpts(
    ReadOpts opts
)
Public Sub New (
    opts As ReadOpts
)

Parameters

opts
Type: Atalasoft.Barcoding.ReadingReadOpts
The ReadOpts from which to copy initial values to a newly constructed ReadOpts.
See Also

Reference

ReadOpts Class
ReadOpts Overload
Atalasoft.Barcoding.Reading Namespace


ReadOpts Properties

The ReadOpts type exposes the following members.

Properties
 | Name | Description
Public property | AztecOptions | Additional options specific to the Aztec symbology.
Public property | CodabarOptions | Additional options specific to the Codabar symbology.
Public property | Code39Options | Reading options specific to the Code39 symbology
Public property | Direction | Enabled barcode orientations
Public property | EnableRescan | Enable/Disable rescan procedure on the local region for detection results with low confidence. Default value: true.
Public property | EnforceChecksum | Enforce the checksum in those symbologies in which a checksum character is optional. Initialized to false by constructor.
Public property | Pdf417Options | Additional options specific to the PDF417 symbology.
Public property | QRCodeOptions | Additional options specific to the QRCode symbology.
Public property | QuietZoneTolerance | How strongly to enforce quiet zone requirements, from 0.0 (ignore them) to 1.0 (enforce strictly). Default: 1.0
Public property | ReadingQuality | Gets or sets the speed or accuracy of the BarCodeReader.
Public property | RectOfInterest | Gets or sets a rectangular region of the image to look for barcodes.
Public property | ScanBarsToRead | Gets or sets the number of bars to attempt to read. The value of this field is not significant when searching two color (e.g. black and white) images for one-dimensional or stacked symbols. Initialised to Int32.MaxValue by constructor.
Public property | ScanInterval | Gets or sets the scan interval. Initialized to 5 by constructor.
Public property | SkipAllValidation | Sets or gets whether or not the barcode reader should skip validation.
Public property | Symbology | Gets or sets the barcode symbology
Public property | XOptions | Obsolete. Extra options for configuring the reader.
Top
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.AztecOptions Property

ReadOptsAztecOptions Property

Additional options specific to the Aztec symbology.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AztecOptions AztecOptions { get; }
Public ReadOnly Property AztecOptions As AztecOptions
    Get

Property Value

Type: AztecOptions
Remarks
These options are only relevant if Aztec is one of the selected symbologies.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.CodabarOptions Property

ReadOptsCodabarOptions Property

Additional options specific to the Codabar symbology.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodabarOptions CodabarOptions { get; }
Public ReadOnly Property CodabarOptions As CodabarOptions
    Get

Property Value

Type: CodabarOptions
Remarks
These options are only relevant if Codabar is one of the selected symbologies.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.Code39Options Property

ReadOptsCode39Options Property

Reading options specific to the Code39 symbology

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Code39Options Code39Options { get; set; }
Public Property Code39Options As Code39Options
    Get
    Set

Property Value

Type: Code39Options
Remarks
Must be Code39Options.None if any none-Code39 symbology is in use. Code39Options.DontRequireStartStop is not fully implemented and should not be relied on. Code39Options.DisableFullASCII can be used to select 'basic' or 43-character Code39, otherwise Full ASCII Code 39 is assumed.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.Direction Property

ReadOptsDirection Property

Enabled barcode orientations

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Directions Direction { get; set; }
Public Property Direction As Directions
    Get
    Set

Property Value

Type: Directions
The direction(s) in which to scan the image.
Remarks

Different Directions may be logically OR'd to read in more than one direction.

Using all read directions will slow down the reading process.

See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.EnableRescan Property

ReadOptsEnableRescan Property

Enable/Disable rescan procedure on the local region for detection results with low confidence. Default value: true.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableRescan { get; set; }
Public Property EnableRescan As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Rescan procedure is applied only to 1D barcode types.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.EnforceChecksum Property

ReadOptsEnforceChecksum Property

Enforce the checksum in those symbologies in which a checksum character is optional. Initialized to false by constructor.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnforceChecksum { get; set; }
Public Property EnforceChecksum As Boolean
    Get
    Set

Property Value

Type: Boolean
Enforce the checksum in those symbologies in which a checksum character is optional.
Remarks
Affected symbologies are: Code 11 (first 'C' checksum always enforced, second 'K' checksum optional)Code 39Code 93 (2 check characters)Interleaved 2 of 5

If set to false then a checksum is not carried out and the character that would otherwise be the checksum character is just a character in the encodation string. If set to true then a checksum is performed and the barcode is only recognized if the checksum is valid.

Initialized to false by constructor.

See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.Pdf417Options Property

ReadOptsPdf417Options Property

Additional options specific to the PDF417 symbology.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pdf417Options Pdf417Options { get; }
Public ReadOnly Property Pdf417Options As Pdf417Options
    Get

Property Value

Type: Pdf417Options
Remarks
These options are only relevant if PDF417 is one of the selected symbologies.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.QRCodeOptions Property

ReadOptsQRCodeOptions Property

Additional options specific to the QRCode symbology.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QRCodeOptions QRCodeOptions { get; }
Public ReadOnly Property QRCodeOptions As QRCodeOptions
    Get

Property Value

Type: QRCodeOptions
Remarks
These options are only relevant if QRCode is one of the selected symbologies.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.QuietZoneTolerance Property

ReadOptsQuietZoneTolerance Property

How strongly to enforce quiet zone requirements, from 0.0 (ignore them) to 1.0 (enforce strictly). Default: 1.0

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float QuietZoneTolerance { get; set; }
Public Property QuietZoneTolerance As Single
    Get
    Set

Property Value

Type: Single
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if this property is set to a value outside the range 0.0 to 1.0
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.ReadingQuality Property

ReadOptsReadingQuality Property

Gets or sets the speed or accuracy of the BarCodeReader.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadingQuality ReadingQuality { get; set; }
Public Property ReadingQuality As ReadingQuality
    Get
    Set

Property Value

Type: ReadingQuality
Remarks

This setting has high-level influence over the performance and accuracy of the barcode engine. Settings this property will change the default value used by some other options, as well as affect some of the internal decisions made by the engine. For example:

Setting this property to Fastest will cause the engine to do coarser scanning of a document for barcode features and give up earlier without finding all of the requested barcodes.

Setting this property to MostAccurate will cause the engine to do fine-grained scanning for barcode features and repeat scans under different configurations to try and detect barcodes that are difficult to recognize. This option can be very slow if you ask the barcode engine to find more barcodes than exist in the source document, or ask for symbologies that are not present, as the engine will make all efforts to fulfill your request.

The default value of Default will try to compromise between the other settings. The engine will make "reasonable decisions" on when to give up scanning if it hasn't fulfilled your requested barcode count.

This option was ignored between DotImage 7.0b and DotImage 10.3.

See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.RectOfInterest Property

ReadOptsRectOfInterest Property

Gets or sets a rectangular region of the image to look for barcodes.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle RectOfInterest { get; set; }
Public Property RectOfInterest As Rectangle
    Get
    Set

Property Value

Type: Rectangle
Remarks
Default is Empty which will inspect the entire image.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.ScanBarsToRead Property

ReadOptsScanBarsToRead Property

Gets or sets the number of bars to attempt to read. The value of this field is not significant when searching two color (e.g. black and white) images for one-dimensional or stacked symbols. Initialised to Int32.MaxValue by constructor.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ScanBarsToRead { get; set; }
Public Property ScanBarsToRead As Integer
    Get
    Set

Property Value

Type: Int32
The number of bars to attempt to read.
Remarks

Setting this value to the actual number of bars in the image can significantly improve performance when the image has more than two colors, or when searching for two-dimensional (i.e. Data Matrix) symbols.

Default value is Int32.MaxValue.

See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.ScanInterval Property

ReadOptsScanInterval Property

Gets or sets the scan interval. Initialized to 5 by constructor.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ScanInterval { get; set; }
Public Property ScanInterval As Integer
    Get
    Set

Property Value

Type: Int32
The scan interval.
Remarks
This option was ignored between DotImage 7.0b and DotImage 10.3.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.SkipAllValidation Property

ReadOptsSkipAllValidation Property

Sets or gets whether or not the barcode reader should skip validation.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SkipAllValidation { get; set; }
Public Property SkipAllValidation As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
This property is useful in reading barcodes that are damaged or malformed. Barcodes read with this property set to true should not be considered to be reliable.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.Symbology Property

ReadOptsSymbology Property

Gets or sets the barcode symbology

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Symbologies Symbology { get; set; }
Public Property Symbology As Symbologies
    Get
    Set

Property Value

Type: Symbologies
The symbology of the barcodes to search for in the image.
Remarks

Different Symbologies may be logically OR'd to search for more than one barcode type.

Searching for more symbologies will slow down reading. Notably, searching for multiple 2D barcodes will have a greater effect than searching for multiple 1D barcodes.

See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts.XOptions Property

ReadOptsXOptions Property

Note: This API is now obsolete.

Extra options for configuring the reader.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("XOptions are no longer supported.")]
public Hashtable XOptions { get; set; }
<ObsoleteAttribute("XOptions are no longer supported.")>
Public Property XOptions As Hashtable
    Get
    Set

Property Value

Type: Hashtable
Remarks
As of DotImage 7.0b, XOptions are ignored and no longer supported.
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


ReadOpts Methods

The ReadOpts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadOpts Class
Atalasoft.Barcoding.Reading Namespace


StructuredAppend Class

Structured Append barcode data
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.ReadingStructuredAppend

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StructuredAppend
Public Class StructuredAppend

The StructuredAppend type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Identifier | so-called 'file identifier' for the group
Public field | Position | position (index) of symbol within structured-append sequence (counts from 0).
Public field | Symbols | total number of symbols in the structured-append sequence
Top
Remarks
This object holds 'structured append' mode information for one symbol that is part of a multiple-symbol group. This feature is supported for example by QR code and Data Matrix.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


StructuredAppend Methods

The StructuredAppend type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StructuredAppend Class
Atalasoft.Barcoding.Reading Namespace


StructuredAppend Fields

The StructuredAppend type exposes the following members.

Fields
 | Name | Description
Public field | Identifier | so-called 'file identifier' for the group
Public field | Position | position (index) of symbol within structured-append sequence (counts from 0).
Public field | Symbols | total number of symbols in the structured-append sequence
Top
See Also

Reference

StructuredAppend Class
Atalasoft.Barcoding.Reading Namespace


StructuredAppend.Identifier Field

StructuredAppendIdentifier Field

so-called 'file identifier' for the group

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Identifier
Public Identifier As Integer

Field Value

Type: Int32
See Also

Reference

StructuredAppend Class
Atalasoft.Barcoding.Reading Namespace


StructuredAppend.Position Field

StructuredAppendPosition Field

position (index) of symbol within structured-append sequence (counts from 0).

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Position
Public Position As Integer

Field Value

Type: Int32
See Also

Reference

StructuredAppend Class
Atalasoft.Barcoding.Reading Namespace


StructuredAppend.Symbols Field

StructuredAppendSymbols Field

total number of symbols in the structured-append sequence

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Symbols
Public Symbols As Integer

Field Value

Type: Int32
See Also

Reference

StructuredAppend Class
Atalasoft.Barcoding.Reading Namespace


Symbologies Enumeration

Barcode symbology identifiers. Flagged.

Namespace: Atalasoft.Barcoding.Reading
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum Symbologies
<FlagsAttribute>
Public Enumeration Symbologies
Members
Member name | Description
None | Empty set of symbologies
AustraliaPost Australia Post

The DataString property is a string consisting of:

the two digit Format Control Code, then a space, followed bythe eight digit Delivery Point Identifier, then a space, followed bythe data in the Customer Information Field, if this field is present. This data is represented by a sequence of digits 0-3 specifying the 4-state values of the individual bars in the field. The XOptions property's "australiaTable" key may be used to specify the use of the C or N table to interpret the data in the field.a final space then eight digits of error correction data.
Codabar | Codabar
Code11 | Code 11
Code128 | Code 128. For more information see http://en.wikipedia.org/wiki/Code_128
Code32

also known as: Base 32, Pharma 32/39, and Italian Pharmacode. Note, not the same as Pharmacode-Laetus.

Code 32 barcodes are similar to Code 39 barcodes with a different encodation.

If both Code39 and Code32 are enabled, some symbols (barcodes) can be returned twice, once for each symbology.

Code39 | Code 39
Code93 | Code 93
Datamatrix | Data Matrix
Ean13 | EAN13
Ean8 | EAN8
I2of5 | Interleaved 2 of 5
IntelligentMail | Intelligent Mail
Itf14 | ITF-14 (the GS1 implementation of I2of5 to encode a Global Trade Item Number)
MicroQr | Micro QR Code
Patch | Patch
Pdf417 | PDF417
Planet | Planet
Postnet | Postnet
Plus2 | 2-digit supplementals associated with EAN and UPC symbology barcodes.
Plus5 | 5-digit supplementals associated with EAN and UPC symbology barcodes.
Qr | QR Code
Rm4scc | RM4SCC (Royal Mail 4-State Customer Code)
Rss14 RSS-14

RSS-14 alternate formats are read as well as the regular format. The alternate formats are truncated, stacked, and stacked omnidirectional. It is recommended that the alignment of truncated and stacked symbols be close to horizontal or vertical.

RssLimited RSS Limited

It is recommended that symbols whose height is near to the specified minimum be aligned close to horizontal or vertical.

Telepen | Telepen
Upca UPC A

UPC A barcodes are identical to EAN13 barcodes with the same encodation except for an additional leading zero on the latter. If both Ean13 and Upca are specified then ReadBars can return two BarCode instances, one for each symbology, for the one barcode.

Upce UPC E

UPC E encodations are a compressed form of UPC A. The DataString property holds the full uncompressed UPC A encodation for this symbology.

Aztec | Aztec Barcode
All2D | A combination of all the 2D symbologies.
All1D | A combination of all the 1D symbologies.
All | A combination of all the symbologies.
See Also

Reference

Atalasoft.Barcoding.Reading Namespace


Atalasoft.Barcoding.Reading.BarcodeLib Namespace

Classes
 | Class | Description
Public class | Codeword4StatData | Codeword4StatData
Public class | CodewordModuleStatData | CodewordModuleStatData
Public class | CodewordStatData | CodewordStatData
Public class | FindPatternStatData | FindPatternStatData
Public class | LineStatData | LineStatData
Public class | QuadStatData | QuadStatData
Public class | SampleSetStatData | SampleSetStatData
Public class | SampleStatData | SampleStatData
Public class | StatFrame | object holding logging/statistics for a 'frame' of activity
Public class | StatLog | Statistics collection and logging for barcode development


Codeword4StatData Class

Codeword4StatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibCodeword4StatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Codeword4StatData
Public Class Codeword4StatData

The Codeword4StatData type exposes the following members.

Constructors
 | Name | Description
Public method | Codeword4StatData | Initializes a new instance of the Codeword4StatData class
Top
Properties
 | Name | Description
Public property | BarWidths | BarWidths
Public property | Candidates | Candidates
Public property | Col | Column
Public property | Confidence | Confidence
Public property | DeltaNormalized | DeltaNormalized
Public property | EdgeIndexes | EdgeIndexes
Public property | EdgePositionAdj | EdgePositionAdj
Public property | EX0 | EX0
Public property | EX1 | EX1
Public property | EY0 | EY0
Public property | EY1 | EY1
Public property | LeadSampleCount | LeadSampleCount
Public property | Row | Row
Public property | SignalNormalized | SignalNormalized
Public property | TailSampleCount | TailSampleCount
Public property | Valid | Valid
Public property | X0 | X0
Public property | X1 | X1
Public property | Y0 | Y0
Public property | Y1 | Y1
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData Constructor

Initializes a new instance of the Codeword4StatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Codeword4StatData()
Public Sub New
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData Properties

The Codeword4StatData type exposes the following members.

Properties
 | Name | Description
Public property | BarWidths | BarWidths
Public property | Candidates | Candidates
Public property | Col | Column
Public property | Confidence | Confidence
Public property | DeltaNormalized | DeltaNormalized
Public property | EdgeIndexes | EdgeIndexes
Public property | EdgePositionAdj | EdgePositionAdj
Public property | EX0 | EX0
Public property | EX1 | EX1
Public property | EY0 | EY0
Public property | EY1 | EY1
Public property | LeadSampleCount | LeadSampleCount
Public property | Row | Row
Public property | SignalNormalized | SignalNormalized
Public property | TailSampleCount | TailSampleCount
Public property | Valid | Valid
Public property | X0 | X0
Public property | X1 | X1
Public property | Y0 | Y0
Public property | Y1 | Y1
Top
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.BarWidths Property

Codeword4StatDataBarWidths Property

BarWidths

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<int> BarWidths { get; set; }
Public Property BarWidths As List(Of Integer)
    Get
    Set

Property Value

Type: List Int32
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Candidates Property

Codeword4StatDataCandidates Property

Candidates

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<KeyValuePair<int, float>> Candidates { get; set; }
Public Property Candidates As List(Of KeyValuePair(Of Integer, Single))
    Get
    Set

Property Value

Type: List KeyValuePair Int32, Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Col Property

Codeword4StatDataCol Property

Column

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Col { get; set; }
Public Property Col As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Confidence Property

Codeword4StatDataConfidence Property

Confidence

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Confidence { get; set; }
Public Property Confidence As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.DeltaNormalized Property

Codeword4StatDataDeltaNormalized Property

DeltaNormalized

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<float> DeltaNormalized { get; set; }
Public Property DeltaNormalized As List(Of Single)
    Get
    Set

Property Value

Type: List Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.EdgeIndexes Property

Codeword4StatDataEdgeIndexes Property

EdgeIndexes

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<int> EdgeIndexes { get; set; }
Public Property EdgeIndexes As List(Of Integer)
    Get
    Set

Property Value

Type: List Int32
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.EdgePositionAdj Property

Codeword4StatDataEdgePositionAdj Property

EdgePositionAdj

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<float> EdgePositionAdj { get; set; }
Public Property EdgePositionAdj As List(Of Single)
    Get
    Set

Property Value

Type: List Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.EX0 Property

Codeword4StatDataEX0 Property

EX0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float EX0 { get; set; }
Public Property EX0 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.EX1 Property

Codeword4StatDataEX1 Property

EX1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float EX1 { get; set; }
Public Property EX1 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.EY0 Property

Codeword4StatDataEY0 Property

EY0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float EY0 { get; set; }
Public Property EY0 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.EY1 Property

Codeword4StatDataEY1 Property

EY1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float EY1 { get; set; }
Public Property EY1 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.LeadSampleCount Property

Codeword4StatDataLeadSampleCount Property

LeadSampleCount

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LeadSampleCount { get; set; }
Public Property LeadSampleCount As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Row Property

Codeword4StatDataRow Property

Row

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Row { get; set; }
Public Property Row As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.SignalNormalized Property

Codeword4StatDataSignalNormalized Property

SignalNormalized

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<float> SignalNormalized { get; set; }
Public Property SignalNormalized As List(Of Single)
    Get
    Set

Property Value

Type: List Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.TailSampleCount Property

Codeword4StatDataTailSampleCount Property

TailSampleCount

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TailSampleCount { get; set; }
Public Property TailSampleCount As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Valid Property

Codeword4StatDataValid Property

Valid

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.X0 Property

Codeword4StatDataX0 Property

X0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float X0 { get; set; }
Public Property X0 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.X1 Property

Codeword4StatDataX1 Property

X1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float X1 { get; set; }
Public Property X1 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Y0 Property

Codeword4StatDataY0 Property

Y0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Y0 { get; set; }
Public Property Y0 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData.Y1 Property

Codeword4StatDataY1 Property

Y1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Y1 { get; set; }
Public Property Y1 As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Codeword4StatData Methods

The Codeword4StatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Codeword4StatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordModuleStatData Class

CodewordModuleStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibCodewordModuleStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CodewordModuleStatData
Public Class CodewordModuleStatData

The CodewordModuleStatData type exposes the following members.

Constructors
 | Name | Description
Public method | CodewordModuleStatData | Initializes a new instance of the CodewordModuleStatData class
Top
Properties
 | Name | Description
Public property | Line | Line - LineStatData
Public property | MetaWidth | MetaWidth (?)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordModuleStatData Constructor

Initializes a new instance of the CodewordModuleStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodewordModuleStatData()
Public Sub New
See Also

Reference

CodewordModuleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordModuleStatData Properties

The CodewordModuleStatData type exposes the following members.

Properties
 | Name | Description
Public property | Line | Line - LineStatData
Public property | MetaWidth | MetaWidth (?)
Top
See Also

Reference

CodewordModuleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordModuleStatData.Line Property

CodewordModuleStatDataLine Property

Line - LineStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineStatData Line { get; set; }
Public Property Line As LineStatData
    Get
    Set

Property Value

Type: LineStatData
See Also

Reference

CodewordModuleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordModuleStatData.MetaWidth Property

CodewordModuleStatDataMetaWidth Property

MetaWidth (?)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MetaWidth { get; set; }
Public Property MetaWidth As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

CodewordModuleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordModuleStatData Methods

The CodewordModuleStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodewordModuleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordStatData Class

CodewordStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibCodewordStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CodewordStatData
Public Class CodewordStatData

The CodewordStatData type exposes the following members.

Constructors
 | Name | Description
Public method | CodewordStatData | Initializes a new instance of the CodewordStatData class
Top
Properties
 | Name | Description
Public property | Modules | Modules
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordStatData Constructor

Initializes a new instance of the CodewordStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodewordStatData()
Public Sub New
See Also

Reference

CodewordStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordStatData Properties

The CodewordStatData type exposes the following members.

Properties
 | Name | Description
Public property | Modules | Modules
Top
See Also

Reference

CodewordStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordStatData.Modules Property

CodewordStatDataModules Property

Modules

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodewordModuleStatData[] Modules { get; set; }
Public Property Modules As CodewordModuleStatData()
    Get
    Set

Property Value

Type: CodewordModuleStatData
See Also

Reference

CodewordStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


CodewordStatData Methods

The CodewordStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodewordStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData Class

FindPatternStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibFindPatternStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FindPatternStatData
Public Class FindPatternStatData

The FindPatternStatData type exposes the following members.

Constructors
 | Name | Description
Public method | FindPatternStatData | Initializes a new instance of the FindPatternStatData class
Top
Properties
 | Name | Description
Public property | Angle | Angle
Public property | LowerAveWidth | LowerAveWidth
Public property | SideLineX0 | SideLineX0
Public property | SideLineX1 | SideLineX1
Public property | SideLineY0 | SideLineY0
Public property | SideLineY1 | SideLineY1
Public property | UpperAveWidth | UpperAveWidth
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData Constructor

Initializes a new instance of the FindPatternStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FindPatternStatData()
Public Sub New
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData Properties

The FindPatternStatData type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Angle
Public property | LowerAveWidth | LowerAveWidth
Public property | SideLineX0 | SideLineX0
Public property | SideLineX1 | SideLineX1
Public property | SideLineY0 | SideLineY0
Public property | SideLineY1 | SideLineY1
Public property | UpperAveWidth | UpperAveWidth
Top
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.Angle Property

FindPatternStatDataAngle Property

Angle

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.LowerAveWidth Property

FindPatternStatDataLowerAveWidth Property

LowerAveWidth

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LowerAveWidth { get; set; }
Public Property LowerAveWidth As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.SideLineX0 Property

FindPatternStatDataSideLineX0 Property

SideLineX0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SideLineX0 { get; set; }
Public Property SideLineX0 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.SideLineX1 Property

FindPatternStatDataSideLineX1 Property

SideLineX1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SideLineX1 { get; set; }
Public Property SideLineX1 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.SideLineY0 Property

FindPatternStatDataSideLineY0 Property

SideLineY0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SideLineY0 { get; set; }
Public Property SideLineY0 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.SideLineY1 Property

FindPatternStatDataSideLineY1 Property

SideLineY1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SideLineY1 { get; set; }
Public Property SideLineY1 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData.UpperAveWidth Property

FindPatternStatDataUpperAveWidth Property

UpperAveWidth

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double UpperAveWidth { get; set; }
Public Property UpperAveWidth As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


FindPatternStatData Methods

The FindPatternStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindPatternStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData Class

LineStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibLineStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LineStatData
Public Class LineStatData

The LineStatData type exposes the following members.

Constructors
 | Name | Description
Public method | LineStatData | Initializes a new instance of the LineStatData class
Top
Properties
 | Name | Description
Public property | X0 | X0
Public property | X1 | X1
Public property | Y0 | Y0
Public property | Y1 | Y1
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData Constructor

Initializes a new instance of the LineStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineStatData()
Public Sub New
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData Properties

The LineStatData type exposes the following members.

Properties
 | Name | Description
Public property | X0 | X0
Public property | X1 | X1
Public property | Y0 | Y0
Public property | Y1 | Y1
Top
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData.X0 Property

LineStatDataX0 Property

X0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X0 { get; set; }
Public Property X0 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData.X1 Property

LineStatDataX1 Property

X1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X1 { get; set; }
Public Property X1 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData.Y0 Property

LineStatDataY0 Property

Y0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y0 { get; set; }
Public Property Y0 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData.Y1 Property

LineStatDataY1 Property

Y1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y1 { get; set; }
Public Property Y1 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


LineStatData Methods

The LineStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData Class

QuadStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibQuadStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class QuadStatData
Public Class QuadStatData

The QuadStatData type exposes the following members.

Constructors
 | Name | Description
Public method | QuadStatData | Initializes a new instance of the QuadStatData class
Top
Properties
 | Name | Description
Public property | X0 | X0
Public property | X1 | X1
Public property | X2 | X2
Public property | X3 | X3
Public property | Y0 | Y0
Public property | Y1 | Y1
Public property | Y2 | Y2
Public property | Y3 | Y3
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData Constructor

Initializes a new instance of the QuadStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadStatData()
Public Sub New
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData Properties

The QuadStatData type exposes the following members.

Properties
 | Name | Description
Public property | X0 | X0
Public property | X1 | X1
Public property | X2 | X2
Public property | X3 | X3
Public property | Y0 | Y0
Public property | Y1 | Y1
Public property | Y2 | Y2
Public property | Y3 | Y3
Top
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.X0 Property

QuadStatDataX0 Property

X0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X0 { get; set; }
Public Property X0 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.X1 Property

QuadStatDataX1 Property

X1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X1 { get; set; }
Public Property X1 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.X2 Property

QuadStatDataX2 Property

X2

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X2 { get; set; }
Public Property X2 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.X3 Property

QuadStatDataX3 Property

X3

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X3 { get; set; }
Public Property X3 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.Y0 Property

QuadStatDataY0 Property

Y0

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y0 { get; set; }
Public Property Y0 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.Y1 Property

QuadStatDataY1 Property

Y1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y1 { get; set; }
Public Property Y1 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.Y2 Property

QuadStatDataY2 Property

Y2

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y2 { get; set; }
Public Property Y2 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData.Y3 Property

QuadStatDataY3 Property

Y3

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y3 { get; set; }
Public Property Y3 As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


QuadStatData Methods

The QuadStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QuadStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleSetStatData Class

SampleSetStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibSampleSetStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SampleSetStatData
Public Class SampleSetStatData

The SampleSetStatData type exposes the following members.

Constructors
 | Name | Description
Public method | SampleSetStatData | Initializes a new instance of the SampleSetStatData class
Top
Properties
 | Name | Description
Public property | Samples | Samples
Public property | Valid | Valid
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleSetStatData Constructor

Initializes a new instance of the SampleSetStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SampleSetStatData()
Public Sub New
See Also

Reference

SampleSetStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleSetStatData Properties

The SampleSetStatData type exposes the following members.

Properties
 | Name | Description
Public property | Samples | Samples
Public property | Valid | Valid
Top
See Also

Reference

SampleSetStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleSetStatData.Samples Property

SampleSetStatDataSamples Property

Samples

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SampleStatData[] Samples { get; set; }
Public Property Samples As SampleStatData()
    Get
    Set

Property Value

Type: SampleStatData
See Also

Reference

SampleSetStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleSetStatData.Valid Property

SampleSetStatDataValid Property

Valid

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SampleSetStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleSetStatData Methods

The SampleSetStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SampleSetStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData Class

SampleStatData
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibSampleStatData

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SampleStatData
Public Class SampleStatData

The SampleStatData type exposes the following members.

Constructors
 | Name | Description
Public method | SampleStatData | Initializes a new instance of the SampleStatData class
Top
Properties
 | Name | Description
Public property | Confident | Confident
Public property | White | White
Public property | X | X
Public property | Y | Y
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData Constructor

Initializes a new instance of the SampleStatData class

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SampleStatData()
Public Sub New
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData Properties

The SampleStatData type exposes the following members.

Properties
 | Name | Description
Public property | Confident | Confident
Public property | White | White
Public property | X | X
Public property | Y | Y
Top
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData.Confident Property

SampleStatDataConfident Property

Confident

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Confident { get; set; }
Public Property Confident As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData.White Property

SampleStatDataWhite Property

White

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool White { get; set; }
Public Property White As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData.X Property

SampleStatDataX Property

X

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X { get; set; }
Public Property X As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData.Y Property

SampleStatDataY Property

Y

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


SampleStatData Methods

The SampleStatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SampleStatData Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame Class

object holding logging/statistics for a 'frame' of activity
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibStatFrame

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StatFrame
Public Class StatFrame

The StatFrame type exposes the following members.

Constructors
 | Name | Description
Public method | StatFrame | statistics frame
Top
Properties
 | Name | Description
Public property | Counters | string-keyed set of integer counters
Public property | DataSets | string-keyed set of datasets
Public property | Frames | string-keyed set of frames
Public property | Info | string-keyed 'info' dictionary
Public property | Name | name of this frame
Public property | Timings | string-keyed set of timings (double)
Top
Methods
 | Name | Description
Public method | Add | add value to counter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount | get value of named counter
Public method | GetDataSet | get dataset by name
Public method | GetFrame | get related (keyed?) frame
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | increment counter by 1
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Record | add data to named dataset
Public method | RecordInfo | set value of info by name
Public method | TakeAutoName | TakeAutoName
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame Constructor

statistics frame

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StatFrame(
    string name,
    StatFrame parent
)
Public Sub New (
    name As String,
    parent As StatFrame
)

Parameters

name
Type: SystemString
name of frame
parent
Type: Atalasoft.Barcoding.Reading.BarcodeLibStatFrame
parent frame
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame Properties

The StatFrame type exposes the following members.

Properties
 | Name | Description
Public property | Counters | string-keyed set of integer counters
Public property | DataSets | string-keyed set of datasets
Public property | Frames | string-keyed set of frames
Public property | Info | string-keyed 'info' dictionary
Public property | Name | name of this frame
Public property | Timings | string-keyed set of timings (double)
Top
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Counters Property

StatFrameCounters Property

string-keyed set of integer counters

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<KeyValuePair<string, int>> Counters { get; }
Public ReadOnly Property Counters As IEnumerable(Of KeyValuePair(Of String, Integer))
    Get

Property Value

Type: IEnumerable KeyValuePair String, Int32
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.DataSets Property

StatFrameDataSets Property

string-keyed set of datasets

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<KeyValuePair<string, List<Object>>> DataSets { get; }
Public ReadOnly Property DataSets As IEnumerable(Of KeyValuePair(Of String, List(Of Object)))
    Get

Property Value

Type: IEnumerable KeyValuePair String, List Object
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Frames Property

StatFrameFrames Property

string-keyed set of frames

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<KeyValuePair<string, StatFrame>> Frames { get; }
Public ReadOnly Property Frames As IEnumerable(Of KeyValuePair(Of String, StatFrame))
    Get

Property Value

Type: IEnumerable KeyValuePair String, StatFrame
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Info Property

StatFrameInfo Property

string-keyed 'info' dictionary

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<KeyValuePair<string, string>> Info { get; }
Public ReadOnly Property Info As IEnumerable(Of KeyValuePair(Of String, String))
    Get

Property Value

Type: IEnumerable KeyValuePair String, String
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Name Property

StatFrameName Property

name of this frame

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Timings Property

StatFrameTimings Property

string-keyed set of timings (double)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<KeyValuePair<string, double>> Timings { get; }
Public ReadOnly Property Timings As IEnumerable(Of KeyValuePair(Of String, Double))
    Get

Property Value

Type: IEnumerable KeyValuePair String, Double
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame Methods

The StatFrame type exposes the following members.

Methods
 | Name | Description
Public method | Add | add value to counter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount | get value of named counter
Public method | GetDataSet | get dataset by name
Public method | GetFrame | get related (keyed?) frame
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | increment counter by 1
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Record | add data to named dataset
Public method | RecordInfo | set value of info by name
Public method | TakeAutoName | TakeAutoName
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Add Method

StatFrameAdd Method

add value to counter

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string key,
    int value
)
Public Sub Add (
    key As String,
    value As Integer
)

Parameters

key
Type: SystemString
name of counter
value
Type: SystemInt32
amount to add to counter
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.GetCount Method

StatFrameGetCount Method

get value of named counter

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetCount(
    string key
)
Public Function GetCount (
    key As String
) As Integer

Parameters

key
Type: SystemString
counter name

Return Value

Type: Int32
current counter value
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.GetDataSet Method

StatFrameGetDataSet Method

get dataset by name

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<Object> GetDataSet(
    string key
)
Public Function GetDataSet (
    key As String
) As List(Of Object)

Parameters

key
Type: SystemString
name of dataset

Return Value

Type: List Object
the named dataset
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.GetFrame Method

StatFrameGetFrame Method

get related (keyed?) frame

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StatFrame GetFrame(
    string key
)
Public Function GetFrame (
    key As String
) As StatFrame

Parameters

key
Type: SystemString
key (index)

Return Value

Type: StatFrame
the frame with that key
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Increment Method

StatFrameIncrement Method

increment counter by 1

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Increment(
    string key
)
Public Sub Increment (
    key As String
)

Parameters

key
Type: SystemString
name of counter
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.Record Method

StatFrameRecord Method

add data to named dataset

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Record(
    string key,
    Object data
)
Public Sub Record (
    key As String,
    data As Object
)

Parameters

key
Type: SystemString
name of dataset
data
Type: SystemObject
set of data to add
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.RecordInfo Method

StatFrameRecordInfo Method

set value of info by name

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RecordInfo(
    string key,
    string value
)
Public Sub RecordInfo (
    key As String,
    value As String
)

Parameters

key
Type: SystemString
key (name)
value
Type: SystemString
new value
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatFrame.TakeAutoName Method

StatFrameTakeAutoName Method

TakeAutoName

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TakeAutoName(
    string key
)
Public Function TakeAutoName (
    key As String
) As Integer

Parameters

key
Type: SystemString
key

Return Value

Type: Int32
count associated with key (pre-increment)
See Also

Reference

StatFrame Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog Class

Statistics collection and logging for barcode development
Inheritance Hierarchy
SystemObject
Atalasoft.Barcoding.Reading.BarcodeLibStatLog

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StatLog
Public Class StatLog

The StatLog type exposes the following members.

Constructors
 | Name | Description
Public method | StatLog | default constructor
Top
Properties
 | Name | Description
Public property | CurrentFrame | the current frame (?)
Public property | Enabled | whether or not statistics collection is enabled
Public property | RootFrame | the root frame (?)
Top
Methods
 | Name | Description
Public method | Add | Add key-value to log
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | increment key in log
Public method | Info | set key-value info in log (current frame?)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Record | record key-data pair to log
Public method | StartCountedFrame | start of a counted frame (?)
Public method | StartFrame | the start frame (?)
Public method | StopFrame | end of a frame
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog Constructor

default constructor

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StatLog()
Public Sub New
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog Properties

The StatLog type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFrame | the current frame (?)
Public property | Enabled | whether or not statistics collection is enabled
Public property | RootFrame | the root frame (?)
Top
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.CurrentFrame Property

StatLogCurrentFrame Property

the current frame (?)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StatFrame CurrentFrame { get; }
Public ReadOnly Property CurrentFrame As StatFrame
    Get

Property Value

Type: StatFrame
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.Enabled Property

StatLogEnabled Property

whether or not statistics collection is enabled

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.RootFrame Property

StatLogRootFrame Property

the root frame (?)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StatFrame RootFrame { get; }
Public ReadOnly Property RootFrame As StatFrame
    Get

Property Value

Type: StatFrame
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog Methods

The StatLog type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add key-value to log
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | increment key in log
Public method | Info | set key-value info in log (current frame?)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Record | record key-data pair to log
Public method | StartCountedFrame | start of a counted frame (?)
Public method | StartFrame | the start frame (?)
Public method | StopFrame | end of a frame
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.Add Method

StatLogAdd Method

Add key-value to log

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string key,
    int value
)
Public Sub Add (
    key As String,
    value As Integer
)

Parameters

key
Type: SystemString
value
Type: SystemInt32
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.Increment Method

StatLogIncrement Method

increment key in log

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Increment(
    string key
)
Public Sub Increment (
    key As String
)

Parameters

key
Type: SystemString
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.Info Method

StatLogInfo Method

set key-value info in log (current frame?)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Info(
    string key,
    string value
)
Public Sub Info (
    key As String,
    value As String
)

Parameters

key
Type: SystemString
parameter
value
Type: SystemString
value
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.Record Method

StatLogRecord Method

record key-data pair to log

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Record(
    string key,
    Object data
)
Public Sub Record (
    key As String,
    data As Object
)

Parameters

key
Type: SystemString
data
Type: SystemObject
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.StartCountedFrame Method

StatLogStartCountedFrame Method

start of a counted frame (?)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void StartCountedFrame(
    string name
)
Public Sub StartCountedFrame (
    name As String
)

Parameters

name
Type: SystemString
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.StartFrame Method

StatLogStartFrame Method

the start frame (?)

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void StartFrame(
    string name
)
Public Sub StartFrame (
    name As String
)

Parameters

name
Type: SystemString
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


StatLog.StopFrame Method

StatLogStopFrame Method

end of a frame

Namespace: Atalasoft.Barcoding.Reading.BarcodeLib
Assembly: Atalasoft.dotImage.Barcoding.Reading (in Atalasoft.dotImage.Barcoding.Reading.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void StopFrame()
Public Sub StopFrame
See Also

Reference

StatLog Class
Atalasoft.Barcoding.Reading.BarcodeLib Namespace


Atalasoft.Barcoding.Writing Namespace

Classes
 | Class | Description
Public class | BarcodeControl | A Windows Forms control that renders linear barcodes
Public class | BarcodeControlDesigner |
Public class | BarcodeWriter | The BarcodeWriter class allows creation of one-dimensional barcodes on Graphics objects.
Public class | DataMatrixBarcodeControl | BarcodeControl is a Windows Forms control that allows authoring of Data Matrix two-dimensional barcodes. Data Matrix is a compact format that can encode binary data as well as text.
Public class | DataMatrixBarcodeWriter | The DataMatrixBarcodeWriter class allows creation of Data Matrix two-dimensional barcodes on Graphics objects.
Public class | Pdf417BarcodeControl | BarcodeControl is a Windows Forms control that allows authoring of PDF 417 two-dimensional barcodes. PDF 417 is a format that can encode binary data as well as text and can includes extensive protection from symbol damage.
Public class | Pdf417BarcodeWriter | The Pdf417BarcodeWriter class allows creation of PDF 417 two-dimensional barcodes on Graphics objects.
Interfaces
 | Interface | Description
Public interface | IBarGraphics | An interface for integrating custom drawing of barcodes other than the System.Windows.Graphics object.
Enumerations
 | Enumeration | Description
Public enumeration | BarcodeAlignment | Possible alignment values of the bar code symbol relative to its layout rectangle. BarcodeOrientation
Public enumeration | BarcodeOrientation | Possible orientation values for the bar code symbol. Specifies in what direction the bar code symbol is drawn.
Public enumeration | BarcodeStyle | Different styles or bar code symbologies to use. The style determines the supported character set.
Public enumeration | DataMatrixSymbolEncoding | DataMatrix supports six different encoding schemes or modes. Each scheme has its native character set for which achieves maximum efficiency.
Public enumeration | DataMatrixSymbolOrientation | Possible orientations for the DataMatrix bar code symbol.
Public enumeration | DataMatrixSymbolSize | DataMatrix supports square symbols with sizes from 10x10 up to 144x144 as well as six different rectangular symbols from 8x18 to 16x48. If SymbolSize.Auto is selected then the smaller symbol fr the given amount of data is automatically selected.
Public enumeration | LayoutMode | Describes how the ModuleWidth and ModuleRatio of the bar code are handled: calculated automatically trying to fit the Rectangle supplied in Render or following the user's settings. If set to auto, the module width and ratio are computed for you.
Public enumeration | Pdf417SymbolOrientation | Possible orientations for the PDF417 bar code symbol.


BarcodeAlignment Enumeration

Possible alignment values of the bar code symbol relative to its layout rectangle. BarcodeOrientation
Determines how barcodes will be aligned within a bounding rectangle

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BarcodeAlignment
Public Enumeration BarcodeAlignment
Members
Member name | Description
Near | Barcodes will be drawn starting from the near edge (left edge for left to right layout)
Center | Barcodes will be drawn centered within the bounds
Far | Barcodes will be drawn starting from the far edge (right edge for left to right layout)
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


BarcodeControl Class

A Windows Forms control that renders linear barcodes
BarcodeControl is a Windows Forms control that allows authoring of one-dimensional barcodes.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Barcoding.WritingBarcodeControl

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BarcodeControl : Control
Public Class BarcodeControl
    Inherits Control

The BarcodeControl type exposes the following members.

Constructors
Name | Description
BarcodeControl | Creates a new BarcodeControl instance
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Alignment | Determines the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BarcodeBounds | Contains the Rectanglethat bounds the rendered bar code.
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFont | The Font used to display the Caption if enabled (see DisplayCaption).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayCaption | Determines whether the caption should be drawn as part of the barcode.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EncodedText | Contains the string finally encoded. This may include check sum digits or start/stop codes not painted by the control.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutMode | Determines whether the module width and ratio should be calculated automatically or manually. Default is LayoutMode.Auto
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModuleRatio | Determines the ratio of the wide to the narrow module in bar code styles with two module widths. Default is 1.5.
Public property | ModuleWidth | Determines the width of the bar code module. Default is 2.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Determines the BarcodeOrientation of the barcode. Default is BarcodeOrientation.Right
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Style | Determines the BarcodeStyle or Symbology for the bar code. This determines the supported character set. Default is BarcodeStyle.Code39
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Overrides ControlOnBackColorChanged(EventArgs).)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Overrides ControlOnForeColorChanged(EventArgs).)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Renders the barcode in the control. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides ControlOnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
 | Validate | Validates the passed text against the selected bar code style.
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


BarcodeControl Constructor

Creates a new BarcodeControl instance

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeControl()
Public Sub New
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl Properties

The BarcodeControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | Alignment | Determines the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BarcodeBounds | Contains the Rectanglethat bounds the rendered bar code.
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFont | The Font used to display the Caption if enabled (see DisplayCaption).
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayCaption | Determines whether the caption should be drawn as part of the barcode.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EncodedText | Contains the string finally encoded. This may include check sum digits or start/stop codes not painted by the control.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutMode | Determines whether the module width and ratio should be calculated automatically or manually. Default is LayoutMode.Auto
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModuleRatio | Determines the ratio of the wide to the narrow module in bar code styles with two module widths. Default is 1.5.
Public property | ModuleWidth | Determines the width of the bar code module. Default is 2.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Determines the BarcodeOrientation of the barcode. Default is BarcodeOrientation.Right
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Style | Determines the BarcodeStyle or Symbology for the bar code. This determines the supported character set. Default is BarcodeStyle.Code39
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.Alignment Property

BarcodeControlAlignment Property

Determines the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeAlignment Alignment { get; set; }
Public Property Alignment As BarcodeAlignment
    Get
    Set

Property Value

Type: BarcodeAlignment
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.BarcodeBounds Property

BarcodeControlBarcodeBounds Property

Contains the Rectanglethat bounds the rendered bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle BarcodeBounds { get; }
Public ReadOnly Property BarcodeBounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.CaptionFont Property

BarcodeControlCaptionFont Property

The Font used to display the Caption if enabled (see DisplayCaption).

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font CaptionFont { get; set; }
Public Property CaptionFont As Font
    Get
    Set

Property Value

Type: Font
Remarks
If no Font is supplied a default "Arial" 8pt is used.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.DisplayCaption Property

BarcodeControlDisplayCaption Property

Determines whether the caption should be drawn as part of the barcode.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayCaption { get; set; }
Public Property DisplayCaption As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
The Caption property shows the original string without any additional characters that might be appended to the final encoded string, such as check digits.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.EncodedText Property

BarcodeControlEncodedText Property

Contains the string finally encoded. This may include check sum digits or start/stop codes not painted by the control.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EncodedText { get; }
Public ReadOnly Property EncodedText As String
    Get

Property Value

Type: String
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.LayoutMode Property

BarcodeControlLayoutMode Property

Determines whether the module width and ratio should be calculated automatically or manually. Default is LayoutMode.Auto

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayoutMode LayoutMode { get; set; }
Public Property LayoutMode As LayoutMode
    Get
    Set

Property Value

Type: LayoutMode
Remarks
When set to Auto, the control will determine the best size and proportions for the barcode.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.ModuleRatio Property

BarcodeControlModuleRatio Property

Determines the ratio of the wide to the narrow module in bar code styles with two module widths. Default is 1.5.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ModuleRatio { get; set; }
Public Property ModuleRatio As Single
    Get
    Set

Property Value

Type: Single
Exceptions
Exception | Condition
ArgumentException | Thrown if the value is less than 1.
Remarks
Will throw if the value is set to a number less than 1.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.ModuleWidth Property

BarcodeControlModuleWidth Property

Determines the width of the bar code module. Default is 2.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleWidth { get; set; }
Public Property ModuleWidth As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | Thrown if the value is zero or negative.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.Orientation Property

BarcodeControlOrientation Property

Determines the BarcodeOrientation of the barcode. Default is BarcodeOrientation.Right

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeOrientation Orientation { get; set; }
Public Property Orientation As BarcodeOrientation
    Get
    Set

Property Value

Type: BarcodeOrientation
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.Style Property

BarcodeControlStyle Property

Determines the BarcodeStyle or Symbology for the bar code. This determines the supported character set. Default is BarcodeStyle.Code39

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeStyle Style { get; set; }
Public Property Style As BarcodeStyle
    Get
    Set

Property Value

Type: BarcodeStyle
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl Methods

The BarcodeControl type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Overrides ControlOnBackColorChanged(EventArgs).)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Overrides ControlOnForeColorChanged(EventArgs).)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Renders the barcode in the control. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides ControlOnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
 | Validate | Validates the passed text against the selected bar code style.
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.Dispose Method

BarcodeControlDispose Method

Disposes the BarcodeControl object.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.Dispose Method (Boolean)

BarcodeControlDispose Method (Boolean)

Clean up any resources being used.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

BarcodeControl Class
Dispose Overload
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.OnBackColorChanged Method

BarcodeControlOnBackColorChanged Method

Raises the BackColorChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnBackColorChanged(
    EventArgs e
)
Protected Overrides Sub OnBackColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.OnForeColorChanged Method

BarcodeControlOnForeColorChanged Method

Raises the ForeColorChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnForeColorChanged(
    EventArgs e
)
Protected Overrides Sub OnForeColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.OnPaint Method

BarcodeControlOnPaint Method

Renders the barcode in the control.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs pe
)
Protected Overrides Sub OnPaint (
    pe As PaintEventArgs
)

Parameters

pe
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs that contains the vent data.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.OnTextChanged Method

BarcodeControlOnTextChanged Method

Raises the TextChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnTextChanged(
    EventArgs e
)
Protected Overrides Sub OnTextChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl.Validate Method

BarcodeControlValidate Method

Validates the passed text against the selected bar code style.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Validate(
    string text,
    bool allowExceptions
)
Public Function Validate (
    text As String,
    allowExceptions As Boolean
) As Boolean

Parameters

text
Type: SystemString
Text to validate.
allowExceptions
Type: SystemBoolean

Return Value

Type: Boolean
True if the supplied text is compatible with the selected bar code stype or false otherwise.

Return Value

Type: Boolean
Returns true if the barcode is valid, false if allowExceptions is set to false.
Exceptions
Exception | Condition
ArgumentException | Thrown if there are characters not compatible with the selected bar code style.
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControl Events

The BarcodeControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner Class

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
Atalasoft.Barcoding.WritingBarcodeControlDesigner

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BarcodeControlDesigner : ControlDesigner
Public Class BarcodeControlDesigner
    Inherits ControlDesigner

The BarcodeControlDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | BarcodeControlDesigner | Initializes a new instance of the BarcodeControlDesigner class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles can be drawn on this designer component. (Inherited from ControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
Methods
 | Name | Description
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ControlDesigner and optionally releases the managed resources. (Inherited from ControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControlGlyph | Returns a ControlBodyGlyph representing the bounds of this control. (Inherited from ControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ControlDesigner.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | Initializes a newly created component. (Inherited from ControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Receives a call to clean up a drag-and-drop operation. (Inherited from ControlDesigner.)
Protected method | OnDragDrop | Receives a call when a drag-and-drop object is dropped onto the control designer view. (Inherited from ControlDesigner.)
Protected method | OnDragEnter | Receives a call when a drag-and-drop operation enters the control designer view. (Inherited from ControlDesigner.)
Protected method | OnDragLeave | Receives a call when a drag-and-drop operation leaves the control designer view. (Inherited from ControlDesigner.)
Protected method | OnDragOver | Receives a call when a drag-and-drop object is dragged over the control designer view. (Inherited from ControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Receives a call in response to the left mouse button being pressed and held while over the component. (Inherited from ControlDesigner.)
Protected method | OnMouseDragEnd | Receives a call at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ControlDesigner.)
Protected method | OnMouseDragMove | Receives a call for each movement of the mouse during a drag-and-drop operation. (Inherited from ControlDesigner.)
Protected method | OnMouseEnter | (Overrides ControlDesignerOnMouseEnter.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | (Overrides ControlDesignerOnMouseLeave.)
Protected method | OnPaintAdornments | (Overrides ControlDesignerOnPaintAdornments(PaintEventArgs).)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Receives a call each time the cursor needs to be set. (Inherited from ControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Adjusts the set of properties the component exposes through a TypeDescriptor. (Inherited from ControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner Constructor

Initializes a new instance of the BarcodeControlDesigner class

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeControlDesigner()
Public Sub New
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner Properties

The BarcodeControlDesigner type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles can be drawn on this designer component. (Inherited from ControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner Methods

The BarcodeControlDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ControlDesigner and optionally releases the managed resources. (Inherited from ControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControlGlyph | Returns a ControlBodyGlyph representing the bounds of this control. (Inherited from ControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ControlDesigner.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | Initializes a newly created component. (Inherited from ControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Receives a call to clean up a drag-and-drop operation. (Inherited from ControlDesigner.)
Protected method | OnDragDrop | Receives a call when a drag-and-drop object is dropped onto the control designer view. (Inherited from ControlDesigner.)
Protected method | OnDragEnter | Receives a call when a drag-and-drop operation enters the control designer view. (Inherited from ControlDesigner.)
Protected method | OnDragLeave | Receives a call when a drag-and-drop operation leaves the control designer view. (Inherited from ControlDesigner.)
Protected method | OnDragOver | Receives a call when a drag-and-drop object is dragged over the control designer view. (Inherited from ControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Receives a call in response to the left mouse button being pressed and held while over the component. (Inherited from ControlDesigner.)
Protected method | OnMouseDragEnd | Receives a call at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ControlDesigner.)
Protected method | OnMouseDragMove | Receives a call for each movement of the mouse during a drag-and-drop operation. (Inherited from ControlDesigner.)
Protected method | OnMouseEnter | (Overrides ControlDesignerOnMouseEnter.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | (Overrides ControlDesignerOnMouseLeave.)
Protected method | OnPaintAdornments | (Overrides ControlDesignerOnPaintAdornments(PaintEventArgs).)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Receives a call each time the cursor needs to be set. (Inherited from ControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Adjusts the set of properties the component exposes through a TypeDescriptor. (Inherited from ControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner.OnMouseEnter Method

BarcodeControlDesignerOnMouseEnter Method

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseEnter()
Protected Overrides Sub OnMouseEnter
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner.OnMouseLeave Method

BarcodeControlDesignerOnMouseLeave Method

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseLeave()
Protected Overrides Sub OnMouseLeave
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner.OnPaintAdornments Method

BarcodeControlDesignerOnPaintAdornments Method

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaintAdornments(
    PaintEventArgs pe
)
Protected Overrides Sub OnPaintAdornments (
    pe As PaintEventArgs
)

Parameters

pe
Type: System.Windows.FormsPaintEventArgs
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeControlDesigner Fields

The BarcodeControlDesigner type exposes the following members.

Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

BarcodeControlDesigner Class
Atalasoft.Barcoding.Writing Namespace


BarcodeOrientation Enumeration

Possible orientation values for the bar code symbol. Specifies in what direction the bar code symbol is drawn.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BarcodeOrientation
Public Enumeration BarcodeOrientation
Members
Member name | Description
Right | The symbol is drawn from Left to Right.
Left | The symbol is drawn from Right to Left.
Up | The symbol is drawn from Bottom to Top.
Down | The symbol is drawn from Top to Bottom.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


BarcodeStyle Enumeration

Different styles or bar code symbologies to use. The style determines the supported character set.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BarcodeStyle
Public Enumeration BarcodeStyle
Members
Member name | Description
MsiPlessey | MSI/Plessey Symbology. Variable length numeric symbology. A modulo 10 check digit is always appended to the encoded string.
Interleaved2of5 | Interleaved 2 of 5 Symbology. Variable length numeric symbology. A leading zero is appended to make the total number of characters even if necessary.
Interleaved2of5Chk | Interleaved 2 of 5 with Check Digit. The same as the Interleaved 2 of 5 with an appended modulo 10 check digit.
Codabar | Codabar Symbology. Variable length symbology. Supports digits 0-9 and six special alphanumeric characters, capital letters A through D.
Code39 | Code 39 or Code 3 of 9. Variable length alphanumeric symbology. It supports 26 uppercase letters, 10 digits and 7 special characters (space, -, ., $, %, / and +). The asterisk * is used as start/stop character.
Code39Chk | The same as Code 39 with a modulo 43 Check Digit.
Code39Ext | Code 39 Extended. Supports the full 128 ASCII character set.
Code39ExtChk | The same as Code 39 Extended with a module 43 Check Digit appended.
Code93 | Code 93. Encodes digits 0?9, capital letters A through Z, and characters -, ., $, %, /, + and ' ' (space) . Two weighted modulo 47 check digits are appended to the encoded string.
Code93Ext | Extended Code 93. Encodes the full 128 ASCII character set. Two weighted modulo 47 check digits are appended.
Code128A | Code 128-A. Variable length alphanumeric symbology. Character supported include capital letters A-Z, digits 0-9, punctuation marks, signs and special control characters. A modulo 103 check digit is always appended.
Code128B | Code 128 B. Similar to Code 128 A but with the inclusion of lower case latters replacing some of the signs.
Code128C | Code 128 C. High density numeric symbology.. The total number of digits must be even. A leading zero is appended if necessary. A modulo 103 check digit is appended.
UpcA | UPC A. Fixed length numeric symbology. Only 11 digits can be supplied and an check digit will be always appended to make the total number of digits 12.
UpcE | UPC E. Fixed length seven digit numeric bar code. Six digits must be supplied and a check digit will be appended. If an 11 digit UPC A string is supplied the translation will be performed if possible.
Ean13 | EAN 13. Fixed length 13 digits (including the check digit) numeric code similar to UPC A.
Ean8 | EAN 8. Fixed length 8 digits (including the check digit) numeric code.
Postnet | Postnet. Numeric symbology. As used by the U.S. Postal Service has a fixed length (not enforced by Sax.Barcodes) and an modulo 10 check digit that is appended automatically.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


BarcodeWriter Class

The BarcodeWriter class allows creation of one-dimensional barcodes on Graphics objects.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.Barcoding.WritingBarcodeWriter

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BarcodeWriter : MarshalByRefObject,
    IDisposable
Public Class BarcodeWriter
    Inherits MarshalByRefObject
    Implements IDisposable

The BarcodeWriter type exposes the following members.

Constructors
 | Name | Description
 | BarcodeWriter | Constructs a new BarcodeWriter object that will create Code 39 barcodes.
Public method | BarcodeWriter(BarcodeStyle) | Creates a bar code with a given style.
Top
Properties
 | Name | Description
Public property | Alignment | Determines the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.
 | BackColor | Determines the color used to draw the background. Default is white.
 | Bounds | After a call to Render(String, Graphics, Rectangle) contains the Rectanglethat bounds the rendered bar code.
Public property | CaptionFont | The Font used to display the Caption if enabled (see DisplayCaption). Default is 8 point Arial.
Public property | DisplayCaption | Determines whether the caption should be drawn as part of the barcode.
 | EncodedText | After a call to Render(String, Graphics, Rectangle) gets the text that was rendered in the barcode. This may include check sum digits or start/stop codes not contained in the text passed to render.
Public property | ForeColor | Determines the color used to draw the barcode. Default is black.
Public property | LayoutMode | Determines whether the module width and ratio should be calculated automatically or manually. Default is LayoutMode.Auto
Public property | ModuleRatio | Sets or gets the ratio of wide bars to narrow bars in the barcode in barcodes that use wide and narrow strips. Default is 1.5.
Public property | ModuleWidth | Determines the widths of narrow bars in a barcode with both narrow and wide bars. Default is 2.
Public property | Orientation | Specifies the BarcodeOrientation of the bar code. Default is BarcodeOrientation.Right
Public property | Style | Specifies the BarcodeStyle or Symbology for the bar code. This determines the supported character set. Default is BarcodeStyle.Code39
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Frees all resources associated with the LinearBarcode
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor. Called by the GC only if the user does not call Dispose() (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Render(String, IBarGraphics, Rectangle) | Renders the barcode in the supplied layout rectangle.
 | Render(String, Graphics, Rectangle) | Renders the bar code in the supplied layout rectangle.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Validate | Validates the passed text against the selected bar code style.
Top
Remarks
Implements IDisposable. The user should call Dispose() when the object instance in no more necessary.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


BarcodeWriter Constructor

Constructs a new BarcodeWriter object
Examples
Copy
BarcodeWriter writer = new BarcodeWriter(BarcodeStyle.Code128A);
Overload List
 | Name | Description
 | BarcodeWriter | Constructs a new BarcodeWriter object that will create Code 39 barcodes.
Public method | BarcodeWriter(BarcodeStyle) | Creates a bar code with a given style.
Top
Examples
Copy
BarcodeWriter writer = new BarcodeWriter(BarcodeStyle.Code128A);
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter Constructor

Constructs a new BarcodeWriter object that will create Code 39 barcodes.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeWriter()
Public Sub New
Remarks
The default constructor creates a bar code with a Code39 style.
See Also

Reference

BarcodeWriter Class
BarcodeWriter Overload
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter Constructor (BarcodeStyle)

Creates a bar code with a given style.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeWriter(
    BarcodeStyle style
)
Public Sub New (
    style As BarcodeStyle
)

Parameters

style
Type: Atalasoft.Barcoding.WritingBarcodeStyle
The symbology of the barcodes that will be written.
See Also

Reference

BarcodeWriter Class
BarcodeWriter Overload
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter Properties

The BarcodeWriter type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Determines the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.
 | BackColor | Determines the color used to draw the background. Default is white.
 | Bounds | After a call to Render(String, Graphics, Rectangle) contains the Rectanglethat bounds the rendered bar code.
Public property | CaptionFont | The Font used to display the Caption if enabled (see DisplayCaption). Default is 8 point Arial.
Public property | DisplayCaption | Determines whether the caption should be drawn as part of the barcode.
 | EncodedText | After a call to Render(String, Graphics, Rectangle) gets the text that was rendered in the barcode. This may include check sum digits or start/stop codes not contained in the text passed to render.
Public property | ForeColor | Determines the color used to draw the barcode. Default is black.
Public property | LayoutMode | Determines whether the module width and ratio should be calculated automatically or manually. Default is LayoutMode.Auto
Public property | ModuleRatio | Sets or gets the ratio of wide bars to narrow bars in the barcode in barcodes that use wide and narrow strips. Default is 1.5.
Public property | ModuleWidth | Determines the widths of narrow bars in a barcode with both narrow and wide bars. Default is 2.
Public property | Orientation | Specifies the BarcodeOrientation of the bar code. Default is BarcodeOrientation.Right
Public property | Style | Specifies the BarcodeStyle or Symbology for the bar code. This determines the supported character set. Default is BarcodeStyle.Code39
Top
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Alignment Property

BarcodeWriterAlignment Property

Determines the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeAlignment Alignment { get; set; }
Public Property Alignment As BarcodeAlignment
    Get
    Set

Property Value

Type: BarcodeAlignment
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.BackColor Property

BarcodeWriterBackColor Property

Determines the color used to draw the background. Default is white.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
A Color object
Remarks
Usually White
Examples
Copy
myBarcodeWriter.BackColor = Color.Wheat;
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Bounds Property

BarcodeWriterBounds Property

After a call to Render(String, Graphics, Rectangle) contains the Rectanglethat bounds the rendered bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
Examples
Copy
 myBarcodeWriter.Render("123456", g, targetRect);
Rectangle finalRect = myBarcodeWriter.Bounds;
Console.WriteLine("Barcode rendered within " + finalRect);
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.CaptionFont Property

BarcodeWriterCaptionFont Property

The Font used to display the Caption if enabled (see DisplayCaption). Default is 8 point Arial.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font CaptionFont { get; set; }
Public Property CaptionFont As Font
    Get
    Set

Property Value

Type: Font
Remarks
If no Font is supplied a default "Arial" 8pt is used.
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.DisplayCaption Property

BarcodeWriterDisplayCaption Property

Determines whether the caption should be drawn as part of the barcode.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayCaption { get; set; }
Public Property DisplayCaption As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
The Caption property shows the original string without any additional characters that might be appended to the final encoded string, such as check digits.
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.EncodedText Property

BarcodeWriterEncodedText Property

After a call to Render(String, Graphics, Rectangle) gets the text that was rendered in the barcode. This may include check sum digits or start/stop codes not contained in the text passed to render.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EncodedText { get; }
Public ReadOnly Property EncodedText As String
    Get

Property Value

Type: String
Examples
Copy
 myBarcodeWriter.Style = BarcodeStyle.Code39;
myBarcodeWriter.Render("1234", g, targetBounds);
// should start and end with '*', the start/stop char for Code 39
string encodedText = myBarcodeWriter.EncodedText;
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.ForeColor Property

BarcodeWriterForeColor Property

Determines the color used to draw the barcode. Default is black.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

Property Value

Type: Color
A Color object
Remarks
Usually Black
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.LayoutMode Property

BarcodeWriterLayoutMode Property

Determines whether the module width and ratio should be calculated automatically or manually. Default is LayoutMode.Auto

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayoutMode LayoutMode { get; set; }
Public Property LayoutMode As LayoutMode
    Get
    Set

Property Value

Type: LayoutMode
Remarks
When set to Auto, the control will determine the best size and proportions for the barcode.
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.ModuleRatio Property

BarcodeWriterModuleRatio Property

Sets or gets the ratio of wide bars to narrow bars in the barcode in barcodes that use wide and narrow strips. Default is 1.5.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ModuleRatio { get; set; }
Public Property ModuleRatio As Single
    Get
    Set

Property Value

Type: Single
Exceptions
Exception | Condition
ArgumentException | Thrown if the value is less than 1.
Remarks
Will throw if the value is set to a number less than 1.
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.ModuleWidth Property

BarcodeWriterModuleWidth Property

Determines the widths of narrow bars in a barcode with both narrow and wide bars. Default is 2.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleWidth { get; set; }
Public Property ModuleWidth As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | Thrown if the value is zero or negative.
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Orientation Property

BarcodeWriterOrientation Property

Specifies the BarcodeOrientation of the bar code. Default is BarcodeOrientation.Right

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeOrientation Orientation { get; set; }
Public Property Orientation As BarcodeOrientation
    Get
    Set

Property Value

Type: BarcodeOrientation
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Style Property

BarcodeWriterStyle Property

Specifies the BarcodeStyle or Symbology for the bar code. This determines the supported character set. Default is BarcodeStyle.Code39

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeStyle Style { get; set; }
Public Property Style As BarcodeStyle
    Get
    Set

Property Value

Type: BarcodeStyle
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter Methods

The BarcodeWriter type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Frees all resources associated with the LinearBarcode
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor. Called by the GC only if the user does not call Dispose() (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Render(String, IBarGraphics, Rectangle) | Renders the barcode in the supplied layout rectangle.
 | Render(String, Graphics, Rectangle) | Renders the bar code in the supplied layout rectangle.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Validate | Validates the passed text against the selected bar code style.
Top
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Dispose Method

BarcodeWriterDispose Method

Frees all resources associated with the LinearBarcode

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Finalize Method

BarcodeWriterFinalize Method

Destructor. Called by the GC only if the user does not call Dispose()

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Render Method

BarcodeWriterRender Method

Examples
Copy
 AtalaImage image = new AtalaImage(200, 50, PixelFormat.Pixel24bppBgr, Color.White);
BarcodeWriter bc = new BarcodeWriter(BarcodeStyle.Codabar);
Graphics g = image.GetGraphics();
bc.Render("0123456789", g, new Rectangle(0, 0, image.Width, image.Height));
Overload List
 | Name | Description
Public method | Render(String, IBarGraphics, Rectangle) | Renders the barcode in the supplied layout rectangle.
 | Render(String, Graphics, Rectangle) | Renders the bar code in the supplied layout rectangle.
Top
Examples
Copy
 AtalaImage image = new AtalaImage(200, 50, PixelFormat.Pixel24bppBgr, Color.White);
BarcodeWriter bc = new BarcodeWriter(BarcodeStyle.Codabar);
Graphics g = image.GetGraphics();
bc.Render("0123456789", g, new Rectangle(0, 0, image.Width, image.Height));
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Render Method (String, IBarGraphics, Rectangle)

BarcodeWriterRender Method (String, IBarGraphics, Rectangle)

Renders the barcode in the supplied layout rectangle.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    string text,
    IBarGraphics graphics,
    Rectangle rect
)
Public Sub Render (
    text As String,
    graphics As IBarGraphics,
    rect As Rectangle
)

Parameters

text
Type: SystemString
The text to encode.
graphics
Type: Atalasoft.Barcoding.WritingIBarGraphics
The concrete IBarGraphics to use to render the barcode.
rect
Type: System.DrawingRectangle
The rectangle to draw the barcode inside.
See Also

Reference

BarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Render Method (String, Graphics, Rectangle)

BarcodeWriterRender Method (String, Graphics, Rectangle)

Renders the bar code in the supplied layout rectangle.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    string text,
    Graphics graphics,
    Rectangle rect
)
Public Sub Render (
    text As String,
    graphics As Graphics,
    rect As Rectangle
)

Parameters

text
Type: SystemString
Text to encode.
graphics
Type: System.DrawingGraphics
Graphics object where the bar code will be rendered.
rect
Type: System.DrawingRectangle
Layout rectangle for the bar code.
Exceptions
Exception | Condition
ArgumentException | Thrown when one or more characters are not supported with the selected style.
Remarks
Note that the Rectangle argument is passed by reference. When returning, the variable will hold the exact rectangle where the bar code symbol was rendered. This is usefull if some other information has to be displayed in a position relative to the symbol.
Remarks
Although any string may be passed in, not all characters may be representable in the barcode. Use Validate(String, Boolean)() to ensure that all text is renderable.
Examples
Copy
//Consider a Form with a PictureBox pictureBox1 on it.

//Create the Barcode object (Style defaults to Code39).
Barcode bc = new Barcode();

//Get a Graphic object from the PictureBox (The image has to be created first!).
Graphics g = Graphics.FromImage(pictureBox1.Image);

//Render the bar code.
bc.Render("123456", g, pictureBox1.ClientRectangle);

//Dispose resources.
g.Dispose();
bc.Dispose();
See Also

Reference

BarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


BarcodeWriter.Validate Method

BarcodeWriterValidate Method

Validates the passed text against the selected bar code style.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Validate(
    string text,
    bool allowExceptions
)
Public Function Validate (
    text As String,
    allowExceptions As Boolean
) As Boolean

Parameters

text
Type: SystemString
Text to validate.
allowExceptions
Type: SystemBoolean

Return Value

Type: Boolean
True if the supplied text is compatible with the selected bar code stype or false otherwise.
Exceptions
Exception | Condition
ArgumentException | Thrown if there are characters not compatible with the selected bar code style.
See Also

Reference

BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl Class

BarcodeControl is a Windows Forms control that allows authoring of Data Matrix two-dimensional barcodes. Data Matrix is a compact format that can encode binary data as well as text.
BarcodeControl is a Windows Forms control that allows authoring of Data Matrix two-dimensional barcodes. Data Matrix is a compact format that can encode binary data as well as text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Barcoding.WritingDataMatrixBarcodeControl

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DataMatrixBarcodeControl : Control
Public Class DataMatrixBarcodeControl
    Inherits Control

The DataMatrixBarcodeControl type exposes the following members.

Constructors
Name | Description
DataMatrixBarcodeControl | Constructs a Windows Forms control that renders two-dimensional barcodes using the DataMatrix symbology.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Columns | After a call to Render(byte, Graphics, Rectangle) returns how many Columns has the resulting symbol.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InnerBounds | Returns the Rectangle bounding the PDF417 Symbol.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModuleSize | Gets or set the size of the smallest square element in the symbol. Defaults to 20 mils.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Sets the orientation of the barcode. Default is DataMatrixSymbolOrientation.Horizontal
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rows | After a call to Render(byte, Graphics, Rectangle) returns how many Rows has the resulting symbol.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SymbolEncoding | Gets and Set the Encoding scheme to use. Defaults to Auto.
Public property | SymbolSize | Gets or set the DataMatrixSymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Overrides ControlOnBackColorChanged(EventArgs).)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Overrides ControlOnForeColorChanged(EventArgs).)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Renders the two-dimensional barcode using the DataMatrix symbology. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides ControlOnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl Constructor

Constructs a Windows Forms control that renders two-dimensional barcodes using the DataMatrix symbology.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixBarcodeControl()
Public Sub New
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl Properties

The DataMatrixBarcodeControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Columns | After a call to Render(byte, Graphics, Rectangle) returns how many Columns has the resulting symbol.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InnerBounds | Returns the Rectangle bounding the PDF417 Symbol.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModuleSize | Gets or set the size of the smallest square element in the symbol. Defaults to 20 mils.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Sets the orientation of the barcode. Default is DataMatrixSymbolOrientation.Horizontal
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rows | After a call to Render(byte, Graphics, Rectangle) returns how many Rows has the resulting symbol.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SymbolEncoding | Gets and Set the Encoding scheme to use. Defaults to Auto.
Public property | SymbolSize | Gets or set the DataMatrixSymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.Columns Property

DataMatrixBarcodeControlColumns Property

After a call to Render(byte, Graphics, Rectangle) returns how many Columns has the resulting symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get

Property Value

Type: Int32
Remarks
Read only.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.InnerBounds Property

DataMatrixBarcodeControlInnerBounds Property

Returns the Rectangle bounding the PDF417 Symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle InnerBounds { get; }
Public ReadOnly Property InnerBounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.ModuleSize Property

DataMatrixBarcodeControlModuleSize Property

Gets or set the size of the smallest square element in the symbol. Defaults to 20 mils.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleSize { get; set; }
Public Property ModuleSize As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.Orientation Property

DataMatrixBarcodeControlOrientation Property

Sets the orientation of the barcode. Default is DataMatrixSymbolOrientation.Horizontal

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixSymbolOrientation Orientation { get; set; }
Public Property Orientation As DataMatrixSymbolOrientation
    Get
    Set

Property Value

Type: DataMatrixSymbolOrientation
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.Rows Property

DataMatrixBarcodeControlRows Property

After a call to Render(byte, Graphics, Rectangle) returns how many Rows has the resulting symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
Remarks
Read only.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.SymbolEncoding Property

DataMatrixBarcodeControlSymbolEncoding Property

Gets and Set the Encoding scheme to use. Defaults to Auto.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixSymbolEncoding SymbolEncoding { get; set; }
Public Property SymbolEncoding As DataMatrixSymbolEncoding
    Get
    Set

Property Value

Type: DataMatrixSymbolEncoding
Remarks
If in the data supplied in Render(byte, Graphics, Rectangle) are characters incompatible with the selected encoding mode an Exception is thrown.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.SymbolSize Property

DataMatrixBarcodeControlSymbolSize Property

Gets or set the DataMatrixSymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixSymbolSize SymbolSize { get; set; }
Public Property SymbolSize As DataMatrixSymbolSize
    Get
    Set

Property Value

Type: DataMatrixSymbolSize
Remarks
Auto will select the smallest symbol size that will contain the data supplied.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl Methods

The DataMatrixBarcodeControl type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Overrides ControlOnBackColorChanged(EventArgs).)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Overrides ControlOnForeColorChanged(EventArgs).)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Renders the two-dimensional barcode using the DataMatrix symbology. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides ControlOnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.Dispose Method

DataMatrixBarcodeControlDispose Method

Disposes the DataMatrixBarcodeControl object.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.Dispose Method (Boolean)

DataMatrixBarcodeControlDispose Method (Boolean)

Clean up any resources being used.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

DataMatrixBarcodeControl Class
Dispose Overload
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.OnBackColorChanged Method

DataMatrixBarcodeControlOnBackColorChanged Method

Raises the BackColorChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnBackColorChanged(
    EventArgs e
)
Protected Overrides Sub OnBackColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.OnForeColorChanged Method

DataMatrixBarcodeControlOnForeColorChanged Method

Raises the ForeColorChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnForeColorChanged(
    EventArgs e
)
Protected Overrides Sub OnForeColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.OnPaint Method

DataMatrixBarcodeControlOnPaint Method

Renders the two-dimensional barcode using the DataMatrix symbology.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs pe
)
Protected Overrides Sub OnPaint (
    pe As PaintEventArgs
)

Parameters

pe
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs that contains the event data.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl.OnTextChanged Method

DataMatrixBarcodeControlOnTextChanged Method

Raises the TextChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnTextChanged(
    EventArgs e
)
Protected Overrides Sub OnTextChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeControl Events

The DataMatrixBarcodeControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DataMatrixBarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter Class

The DataMatrixBarcodeWriter class allows creation of Data Matrix two-dimensional barcodes on Graphics objects.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.Barcoding.WritingDataMatrixBarcodeWriter

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DataMatrixBarcodeWriter : MarshalByRefObject,
    IDisposable
Public Class DataMatrixBarcodeWriter
    Inherits MarshalByRefObject
    Implements IDisposable

The DataMatrixBarcodeWriter type exposes the following members.

Constructors
 | Name | Description
Public method | DataMatrixBarcodeWriter | Constructs a new DataMatrixBarcodeWriter object.
Top
Properties
 | Name | Description
Public property | BackColor | DataMatrix supports both dark-on-light and light-on-dark symbols. BackColor defaults to white.
 | Bounds | After a call to Render(Byte, Graphics, Rectangle) returns the exact position of the bidimensional bar code.
Public property | Columns | After a call to Render(Byte, Graphics, Rectangle) returns how many Columns has the resulting symbol.
Public property | Encoding | Gets and Set the Encoding scheme to use. Defaults to Auto.
Public property | ForeColor | DataMatrix supports both dark-on-light and light-on-dark symbols. ForeColor defaults to black.
Public property | ModuleSize | Gets or set the size of the smalles square element in the symbol. Defaults to 20 mils.
Public property | Orientation | Gets, set the Orientation of the DataMatrix symbol. Default is DataMatrixSymbolOrientation.Horizontal
Public property | Rows | After a call to Render(Byte, Graphics, Rectangle) returns how many Rows has the resulting symbol.
Public property | Size | Gets or set the DataMatrixSymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Disposes the instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Instance Finalizer. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Render(Byte, IBarGraphics, Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Public method | Render(Byte, Graphics, Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Public method | Render(String, IBarGraphics, Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.
Public method | Render(String, Graphics, Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter Constructor

Constructs a new DataMatrixBarcodeWriter object.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixBarcodeWriter()
Public Sub New
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter Properties

The DataMatrixBarcodeWriter type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | DataMatrix supports both dark-on-light and light-on-dark symbols. BackColor defaults to white.
 | Bounds | After a call to Render(Byte, Graphics, Rectangle) returns the exact position of the bidimensional bar code.
Public property | Columns | After a call to Render(Byte, Graphics, Rectangle) returns how many Columns has the resulting symbol.
Public property | Encoding | Gets and Set the Encoding scheme to use. Defaults to Auto.
Public property | ForeColor | DataMatrix supports both dark-on-light and light-on-dark symbols. ForeColor defaults to black.
Public property | ModuleSize | Gets or set the size of the smalles square element in the symbol. Defaults to 20 mils.
Public property | Orientation | Gets, set the Orientation of the DataMatrix symbol. Default is DataMatrixSymbolOrientation.Horizontal
Public property | Rows | After a call to Render(Byte, Graphics, Rectangle) returns how many Rows has the resulting symbol.
Public property | Size | Gets or set the DataMatrixSymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.
Top
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.BackColor Property

DataMatrixBarcodeWriterBackColor Property

DataMatrix supports both dark-on-light and light-on-dark symbols. BackColor defaults to white.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Bounds Property

DataMatrixBarcodeWriterBounds Property

After a call to Render(Byte, Graphics, Rectangle) returns the exact position of the bidimensional bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
Examples
Copy
 myBarcodeWriter.Render("DotImage", g, targetRect);
Rectangle finalRect = myBarcodeWriter.Bounds;
Console.WriteLine("Barcode rendered within " + finalRect);
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Columns Property

DataMatrixBarcodeWriterColumns Property

After a call to Render(Byte, Graphics, Rectangle) returns how many Columns has the resulting symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get

Property Value

Type: Int32
Remarks
Read only.
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Encoding Property

DataMatrixBarcodeWriterEncoding Property

Gets and Set the Encoding scheme to use. Defaults to Auto.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixSymbolEncoding Encoding { get; set; }
Public Property Encoding As DataMatrixSymbolEncoding
    Get
    Set

Property Value

Type: DataMatrixSymbolEncoding
Remarks
If in the data supplied in Render(Byte, Graphics, Rectangle) are characters incompatible with the selected encoding mode an Exception is thrown.
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.ForeColor Property

DataMatrixBarcodeWriterForeColor Property

DataMatrix supports both dark-on-light and light-on-dark symbols. ForeColor defaults to black.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.ModuleSize Property

DataMatrixBarcodeWriterModuleSize Property

Gets or set the size of the smalles square element in the symbol. Defaults to 20 mils.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleSize { get; set; }
Public Property ModuleSize As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Orientation Property

DataMatrixBarcodeWriterOrientation Property

Gets, set the Orientation of the DataMatrix symbol. Default is DataMatrixSymbolOrientation.Horizontal

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixSymbolOrientation Orientation { get; set; }
Public Property Orientation As DataMatrixSymbolOrientation
    Get
    Set

Property Value

Type: DataMatrixSymbolOrientation
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Rows Property

DataMatrixBarcodeWriterRows Property

After a call to Render(Byte, Graphics, Rectangle) returns how many Rows has the resulting symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
Remarks
Read only.
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Size Property

DataMatrixBarcodeWriterSize Property

Gets or set the DataMatrixSymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixSymbolSize Size { get; set; }
Public Property Size As DataMatrixSymbolSize
    Get
    Set

Property Value

Type: DataMatrixSymbolSize
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter Methods

The DataMatrixBarcodeWriter type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Disposes the instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Instance Finalizer. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Render(Byte, IBarGraphics, Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Public method | Render(Byte, Graphics, Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Public method | Render(String, IBarGraphics, Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.
Public method | Render(String, Graphics, Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Dispose Method

DataMatrixBarcodeWriterDispose Method

Disposes the instance.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Finalize Method

DataMatrixBarcodeWriterFinalize Method

Instance Finalizer.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Render Method

DataMatrixBarcodeWriterRender Method

Draws the Data Matrix barcode on a Graphics object.
Overload List
 | Name | Description
Public method | Render(Byte, IBarGraphics, Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Public method | Render(Byte, Graphics, Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Public method | Render(String, IBarGraphics, Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.
Public method | Render(String, Graphics, Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.
Top
See Also

Reference

DataMatrixBarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Render Method (Byte[], IBarGraphics, Rectangle)

DataMatrixBarcodeWriterRender Method (Byte, IBarGraphics, Rectangle)

Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    byte[] buffer,
    IBarGraphics g,
    Rectangle rect
)
Public Sub Render (
    buffer As Byte(),
    g As IBarGraphics,
    rect As Rectangle
)

Parameters

buffer
Type: SystemByte
The stream of bytes to be encoded in the DataMatrix symbol.
g
Type: Atalasoft.Barcoding.WritingIBarGraphics
A graphics object that can be overloaded to accept custom data output.
rect
Type: System.DrawingRectangle
The target rectangle where the symbol will be drawn.
See Also

Reference

DataMatrixBarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Render Method (Byte[], Graphics, Rectangle)

DataMatrixBarcodeWriterRender Method (Byte, Graphics, Rectangle)

Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    byte[] buffer,
    Graphics g,
    Rectangle rect
)
Public Sub Render (
    buffer As Byte(),
    g As Graphics,
    rect As Rectangle
)

Parameters

buffer
Type: SystemByte
The stream of bytes to be encoded in the DataMatrix symbol.
g
Type: System.DrawingGraphics
The Graphics object where the symbol will be rendered.
rect
Type: System.DrawingRectangle
The Rectangle where the DataMatrix symbol will be centered.
Remarks
The Encoding setting is ignored when calling this method.
See Also

Reference

DataMatrixBarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Render Method (String, IBarGraphics, Rectangle)

DataMatrixBarcodeWriterRender Method (String, IBarGraphics, Rectangle)

Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    string text,
    IBarGraphics g,
    Rectangle rect
)
Public Sub Render (
    text As String,
    g As IBarGraphics,
    rect As Rectangle
)

Parameters

text
Type: SystemString
The string of characters to be encoded in the DataMatrix symbol.
g
Type: Atalasoft.Barcoding.WritingIBarGraphics
The concrete implementation of the IBarGraphics object to draw the symbol to.
rect
Type: System.DrawingRectangle
The Rectangle where the DataMatrix symbol will be centered.
See Also

Reference

DataMatrixBarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


DataMatrixBarcodeWriter.Render Method (String, Graphics, Rectangle)

DataMatrixBarcodeWriterRender Method (String, Graphics, Rectangle)

Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected DataMatrixSymbolEncoding.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    string text,
    Graphics g,
    Rectangle rect
)
Public Sub Render (
    text As String,
    g As Graphics,
    rect As Rectangle
)

Parameters

text
Type: SystemString
The string of characters to be encoded in the DataMatrix symbol.
g
Type: System.DrawingGraphics
The Graphics object where the symbol will be rendered.
rect
Type: System.DrawingRectangle
The Rectangle where the DataMatrix symbol will be centered.
See Also

Reference

DataMatrixBarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


DataMatrixSymbolEncoding Enumeration

DataMatrix supports six different encoding schemes or modes. Each scheme has its native character set for which achieves maximum efficiency.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DataMatrixSymbolEncoding
Public Enumeration DataMatrixSymbolEncoding
Members
Member name | Description
Auto | The data is encoded in the best possible way using all the available encodation modes. Auto is the default mode.
ASCII | Encodes all 127 standard ASCII characters as well as the extended ASCII character set 128-255.
C40 | Encodes all characters from the standard and extended ASCII sets. Is more efficient than ASCII encodation for upper-case alphabetic and numeric characters.
Text | Encodes all characters from the standard and extended ASCII sets. Is more efficient than ASCII encodation for lower-case alphabetic and numeric characters.
X12 | Encodes only A-Z, 0-9, space and X12 control characters with ASCII values 13, 42 and 62.
EDIFACT | Encodes characters from the standard ASCII set in the range 32 through 94 which includes all upper and lower case alphabetic letters, numbers 0-9, the space as well as many symbols and punctuation characters.
Base256 | Encodes characters in the range 0-255. Adecuate for the encodation of binary data.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


DataMatrixSymbolOrientation Enumeration

Possible orientations for the DataMatrix bar code symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DataMatrixSymbolOrientation
Public Enumeration DataMatrixSymbolOrientation
Members
Member name | Description
Horizontal | The DataMatrix bar code will be rendered horizontally.
Vertical | The DataMatrix will be rendered vertically.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


DataMatrixSymbolSize Enumeration

DataMatrix supports square symbols with sizes from 10x10 up to 144x144 as well as six different rectangular symbols from 8x18 to 16x48. If SymbolSize.Auto is selected then the smaller symbol fr the given amount of data is automatically selected.
Used to control the size of the Data Matrix symbols. S members are square (equal rows and columns), R members are ordered row x column.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DataMatrixSymbolSize
Public Enumeration DataMatrixSymbolSize
Members
Member name | Description
Auto | The size is determined by the length of the data supplied.
S010x010 | 10 rows x 10 columns.
S012x012 | 12 rows x 12 columns.
S014x014 | 14 rows x 14 columns.
S016x016 | 16 rows x 16 columns.
S018x018 | 18 rows x 18 columns.
S020x020 | 20 rows x 20 columns.
S022x022 | 22 rows x 22 columns.
S024x024 | 24 rows x 24 columns.
S026x026 | 26 rows x 26 columns.
S032x032 | 32 rows x 32 columns.
S036x036 | 36 rows x 36 columns.
S040x040 | 40 rows x 40 columns.
S044x044 | 44 rows x 44 columns.
S048x048 | 48 rows x 48 columns.
S052x052 | 52 rows x 52 columns.
S064x064 | 64 rows x 64 columns.
S072x072 | 72 rows x 72 columns.
S080x080 | 80 rows x 80 columns.
S088x088 | 88 rows x 88 columns.
S096x096 | 96 rows x 96 columns.
S104x104 | 104 rows x 104 columns.
S120x120 | 120 rows x 120 columns.
S132x132 | 132 rows x 132 columns.
S144x144 | 144 rows x 144 columns.
R008x018 | 8 rows x 18 columns.
R008x032 | 8 rows x 32 columns.
R012x026 | 12 rows x 26 columns.
R012x036 | 12 rows x 36 columns.
R016x036 | 16 rows x 36 columns.
R016x048 | 16 rows x 48 columns.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


IBarGraphics Interface

An interface for integrating custom drawing of barcodes other than the System.Windows.Graphics object.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IBarGraphics
Public Interface IBarGraphics

The IBarGraphics type exposes the following members.

Properties
 | Name | Description
Public property | DpiX | Gets the dpi in the X direction.
Public property | DpiY | Gets the dpi in the Y direction.
Top
Methods
 | Name | Description
Public method | DrawString(String, Font, Brush, Rectangle, StringFormat) | Draws the string.
Public method | DrawString(String, Font, Brush, RectangleF, StringFormat) | Draws a string.
Public method | FillRectangle | Fills the rectangle.
Public method | MeasureString | Measures the string.
Public method | Restore | Restores the specified GraphicsState.
Public method | RotateTransform | Use a rotate transform to rotate the render canvas.
Public method | Save | Saves the instance of GraphicsState.
Public method | TranslateTransform | Use a translate transform to move the render point
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


IBarGraphics Properties

The IBarGraphics type exposes the following members.

Properties
 | Name | Description
Public property | DpiX | Gets the dpi in the X direction.
Public property | DpiY | Gets the dpi in the Y direction.
Top
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.DpiX Property

IBarGraphicsDpiX Property

Gets the dpi in the X direction.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float DpiX { get; }
ReadOnly Property DpiX As Single
    Get

Property Value

Type: Single
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.DpiY Property

IBarGraphicsDpiY Property

Gets the dpi in the Y direction.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float DpiY { get; }
ReadOnly Property DpiY As Single
    Get

Property Value

Type: Single
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics Methods

The IBarGraphics type exposes the following members.

Methods
 | Name | Description
Public method | DrawString(String, Font, Brush, Rectangle, StringFormat) | Draws the string.
Public method | DrawString(String, Font, Brush, RectangleF, StringFormat) | Draws a string.
Public method | FillRectangle | Fills the rectangle.
Public method | MeasureString | Measures the string.
Public method | Restore | Restores the specified GraphicsState.
Public method | RotateTransform | Use a rotate transform to rotate the render canvas.
Public method | Save | Saves the instance of GraphicsState.
Public method | TranslateTransform | Use a translate transform to move the render point
Top
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.DrawString Method

IBarGraphicsDrawString Method

Overload List
 | Name | Description
Public method | DrawString(String, Font, Brush, Rectangle, StringFormat) | Draws the string.
Public method | DrawString(String, Font, Brush, RectangleF, StringFormat) | Draws a string.
Top
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.DrawString Method (String, Font, Brush, Rectangle, StringFormat)

IBarGraphicsDrawString Method (String, Font, Brush, Rectangle, StringFormat)

Draws the string.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DrawString(
    string text,
    Font font,
    Brush foreground,
    Rectangle r,
    StringFormat format
)
Sub DrawString (
    text As String,
    font As Font,
    foreground As Brush,
    r As Rectangle,
    format As StringFormat
)

Parameters

text
Type: SystemString
The text to draw.
font
Type: System.DrawingFont
The font to use to draw the text.
foreground
Type: System.DrawingBrush
The brush to draw the text with.
r
Type: System.DrawingRectangle
The rectangle to write the text in.
format
Type: System.DrawingStringFormat
The format to use to draw the text.
See Also

Reference

IBarGraphics Interface
DrawString Overload
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

IBarGraphicsDrawString Method (String, Font, Brush, RectangleF, StringFormat)

Draws a string.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DrawString(
    string text,
    Font f,
    Brush b,
    RectangleF rf,
    StringFormat fmt
)
Sub DrawString (
    text As String,
    f As Font,
    b As Brush,
    rf As RectangleF,
    fmt As StringFormat
)

Parameters

text
Type: SystemString
The text to draw.
f
Type: System.DrawingFont
The font to use.
b
Type: System.DrawingBrush
The brush to use to draw the text.
rf
Type: System.DrawingRectangleF
The rectangle to contain the text.
fmt
Type: System.DrawingStringFormat
The StringFormat.
See Also

Reference

IBarGraphics Interface
DrawString Overload
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.FillRectangle Method

IBarGraphicsFillRectangle Method

Fills the rectangle.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void FillRectangle(
    Brush backBrush,
    Rectangle r
)
Sub FillRectangle (
    backBrush As Brush,
    r As Rectangle
)

Parameters

backBrush
Type: System.DrawingBrush
The fill brush.
r
Type: System.DrawingRectangle
The rectangle to fill.
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.MeasureString Method

IBarGraphicsMeasureString Method

Measures the string.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
SizeF MeasureString(
    string text,
    Font font
)
Function MeasureString (
    text As String,
    font As Font
) As SizeF

Parameters

text
Type: SystemString
The text to measure.
font
Type: System.DrawingFont
The font used.

Return Value

Type: SizeF
Returns the space needed to render the text with the font
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.Restore Method

IBarGraphicsRestore Method

Restores the specified GraphicsState.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Restore(
    GraphicsState gState
)
Sub Restore (
    gState As GraphicsState
)

Parameters

gState
Type: System.Drawing.Drawing2DGraphicsState
the GraphicsState to restore to.
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.RotateTransform Method

IBarGraphicsRotateTransform Method

Use a rotate transform to rotate the render canvas.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void RotateTransform(
    float degrees
)
Sub RotateTransform (
    degrees As Single
)

Parameters

degrees
Type: SystemSingle
The amount to rotate, in degrees.
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.Save Method

IBarGraphicsSave Method

Saves the instance of GraphicsState.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
GraphicsState Save()
Function Save As GraphicsState

Return Value

Type: GraphicsState
Returns the GraphicsState
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


IBarGraphics.TranslateTransform Method

IBarGraphicsTranslateTransform Method

Use a translate transform to move the render point

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void TranslateTransform(
    float x,
    float y
)
Sub TranslateTransform (
    x As Single,
    y As Single
)

Parameters

x
Type: SystemSingle
The x direction translation.
y
Type: SystemSingle
The y direction translation.
See Also

Reference

IBarGraphics Interface
Atalasoft.Barcoding.Writing Namespace


LayoutMode Enumeration

Describes how the ModuleWidth and ModuleRatio of the bar code are handled: calculated automatically trying to fit the Rectangle supplied in Render or following the user's settings. If set to auto, the module width and ratio are computed for you.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum LayoutMode
Public Enumeration LayoutMode
Members
Member name | Description
Auto | ModuleWidth and ModuleRatio are calculated automatically from the information supplied in the Render method.
Manual | ModuleWidth and ModuleRatio have to be set by the user.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl Class

BarcodeControl is a Windows Forms control that allows authoring of PDF 417 two-dimensional barcodes. PDF 417 is a format that can encode binary data as well as text and can includes extensive protection from symbol damage.
BarcodeControl is a Windows Forms control that allows authoring of PDF 417 two-dimensional barcodes. PDF 417 is a format that can encode binary data as well as text and can includes extensive protection from symbol damage.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Barcoding.WritingPdf417BarcodeControl

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Pdf417BarcodeControl : Control
Public Class Pdf417BarcodeControl
    Inherits Control

The Pdf417BarcodeControl type exposes the following members.

Constructors
 | Name | Description
Public method | Pdf417BarcodeControl | Constructs a Windows Forms control that renders two-dimensional barcodes using the PDF417 symbology.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Columns | Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | ErrorCorrectionLevel | Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InnerBounds | Returns the Rectangle bounding the PDF417 Symbol.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutMode | Determines the value of the Layout. Default is LayoutMode.Auto
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModuleHeight | Determines the height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | ModuleWidth | Determines the width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Determines the orientation of the barcode. Default is Pdf417SymbolOrientation.Horizontal
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rows | Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Truncated | Determines whether the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Overrides ControlOnBackColorChanged(EventArgs).)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Overrides ControlOnForeColorChanged(EventArgs).)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Renders the two-dimensional barcode using the PDF417 symbology. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides ControlOnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl Constructor

Constructs a Windows Forms control that renders two-dimensional barcodes using the PDF417 symbology.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pdf417BarcodeControl()
Public Sub New
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl Properties

The Pdf417BarcodeControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Columns | Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | ErrorCorrectionLevel | Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InnerBounds | Returns the Rectangle bounding the PDF417 Symbol.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutMode | Determines the value of the Layout. Default is LayoutMode.Auto
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModuleHeight | Determines the height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | ModuleWidth | Determines the width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Determines the orientation of the barcode. Default is Pdf417SymbolOrientation.Horizontal
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rows | Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Truncated | Determines whether the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.Columns Property

Pdf417BarcodeControlColumns Property

Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; set; }
Public Property Columns As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.ErrorCorrectionLevel Property

Pdf417BarcodeControlErrorCorrectionLevel Property

Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ErrorCorrectionLevel { get; set; }
Public Property ErrorCorrectionLevel As Integer
    Get
    Set

Property Value

Type: Int32
A value within the range 0-8 inclusive.
Remarks
Only values in the range 0-8 are valid. Depending on the value of the Error Correction Level different number of Error Correction Codewords (ECC) are appended. In any LayoutMode if the User selects a valid Error Correction Level that value is respected.
Error Correction Level | Codewords
0 | 2
1 | 4
2 | 8
3 | 16
4 | 32
5 | 64
6 | 128
7 | 256
8 | 512
AIM (Automatic Identification Manufacturers) Standard for PDF417 recommends the following EC Levels depending on the amount of Data:
Data Codewords | Recommended EC Level
1-40 | 2
41-160 | 3
161-320 | 4
321-863 | 5
Remarks
This value determines how many error correction code words will be included in the barcode. The correspondence is exponential. A value of 0 yields 21 code words, 1 yields 22 code words. In general a value of n yields 2n+1 code words.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.InnerBounds Property

Pdf417BarcodeControlInnerBounds Property

Returns the Rectangle bounding the PDF417 Symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle InnerBounds { get; }
Public ReadOnly Property InnerBounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.LayoutMode Property

Pdf417BarcodeControlLayoutMode Property

Determines the value of the Layout. Default is LayoutMode.Auto

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayoutMode LayoutMode { get; set; }
Public Property LayoutMode As LayoutMode
    Get
    Set

Property Value

Type: LayoutMode
Remarks
If LayoutMode is set to Manual, ModuleWidth and ModuleHeight need to be set by client code.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.ModuleHeight Property

Pdf417BarcodeControlModuleHeight Property

Determines the height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleHeight { get; set; }
Public Property ModuleHeight As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Using ScaleTransform(Single, Single)PageScale any desired ModuleWidth value can be obtained.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.ModuleWidth Property

Pdf417BarcodeControlModuleWidth Property

Determines the width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleWidth { get; set; }
Public Property ModuleWidth As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Using ScaleTransform(Single, Single)PageScale any desired ModuleWidth value can be obtained.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.Orientation Property

Pdf417BarcodeControlOrientation Property

Determines the orientation of the barcode. Default is Pdf417SymbolOrientation.Horizontal

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pdf417SymbolOrientation Orientation { get; set; }
Public Property Orientation As Pdf417SymbolOrientation
    Get
    Set

Property Value

Type: Pdf417SymbolOrientation
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.Rows Property

Pdf417BarcodeControlRows Property

Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; set; }
Public Property Rows As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.Truncated Property

Pdf417BarcodeControlTruncated Property

Determines whether the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Truncated { get; set; }
Public Property Truncated As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl Methods

The Pdf417BarcodeControl type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Overrides ControlOnBackColorChanged(EventArgs).)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Overrides ControlOnForeColorChanged(EventArgs).)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Renders the two-dimensional barcode using the PDF417 symbology. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides ControlOnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.Dispose Method

Pdf417BarcodeControlDispose Method

Disposes the Pdf417BarcodeControl object.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.Dispose Method (Boolean)

Pdf417BarcodeControlDispose Method (Boolean)

Clean up any resources being used.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

Pdf417BarcodeControl Class
Dispose Overload
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.OnBackColorChanged Method

Pdf417BarcodeControlOnBackColorChanged Method

Raises the BackColorChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnBackColorChanged(
    EventArgs e
)
Protected Overrides Sub OnBackColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.OnForeColorChanged Method

Pdf417BarcodeControlOnForeColorChanged Method

Raises the ForeColorChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnForeColorChanged(
    EventArgs e
)
Protected Overrides Sub OnForeColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.OnPaint Method

Pdf417BarcodeControlOnPaint Method

Renders the two-dimensional barcode using the PDF417 symbology.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs pe
)
Protected Overrides Sub OnPaint (
    pe As PaintEventArgs
)

Parameters

pe
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs that contains the event data.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl.OnTextChanged Method

Pdf417BarcodeControlOnTextChanged Method

Raises the TextChanged event.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnTextChanged(
    EventArgs e
)
Protected Overrides Sub OnTextChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeControl Events

The Pdf417BarcodeControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Pdf417BarcodeControl Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter Class

The Pdf417BarcodeWriter class allows creation of PDF 417 two-dimensional barcodes on Graphics objects.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.Barcoding.WritingPdf417BarcodeWriter

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Pdf417BarcodeWriter : MarshalByRefObject,
    IDisposable
Public Class Pdf417BarcodeWriter
    Inherits MarshalByRefObject
    Implements IDisposable

The Pdf417BarcodeWriter type exposes the following members.

Constructors
 | Name | Description
Public method | Pdf417BarcodeWriter | Default constructor.
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets color of the background of the barcode.
 | Bounds | After a call to Render(Byte, Graphics, Rectangle), returns the Rectangle bounding the PDF417 Symbol.
Public property | Columns | Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.
Public property | ErrorCorrectionLevel | Error Correction Level. Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.
Public property | ForeColor | Gets or sets the the color of the barcode.
Public property | Layout | Determines how the PDF 417 modules are presented. Default is LayoutMode.Auto
Public property | ModuleHeight | The height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | ModuleWidth | The width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | Orientation | Sets or gets the orientation of the barcode. Default is Pdf417SymbolOrientation.Horizontal
Public property | Rows | Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.
Public property | Truncated | Indicates whether the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Implementation of IDisposable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor. Should never be called. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Render(Byte, IBarGraphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(Byte, Graphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(String, IBarGraphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(String, Graphics, Rectangle) | Creates the PDF417 bar code.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter Constructor

Default constructor.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pdf417BarcodeWriter()
Public Sub New
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter Properties

The Pdf417BarcodeWriter type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets color of the background of the barcode.
 | Bounds | After a call to Render(Byte, Graphics, Rectangle), returns the Rectangle bounding the PDF417 Symbol.
Public property | Columns | Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.
Public property | ErrorCorrectionLevel | Error Correction Level. Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.
Public property | ForeColor | Gets or sets the the color of the barcode.
Public property | Layout | Determines how the PDF 417 modules are presented. Default is LayoutMode.Auto
Public property | ModuleHeight | The height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | ModuleWidth | The width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.
Public property | Orientation | Sets or gets the orientation of the barcode. Default is Pdf417SymbolOrientation.Horizontal
Public property | Rows | Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.
Public property | Truncated | Indicates whether the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.
Top
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.BackColor Property

Pdf417BarcodeWriterBackColor Property

Gets or sets color of the background of the barcode.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The color of the background of the barcode.
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Bounds Property

Pdf417BarcodeWriterBounds Property

After a call to Render(Byte, Graphics, Rectangle), returns the Rectangle bounding the PDF417 Symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
Examples
Copy
 myBarcodeWriter.Render("DotImage", g, targetRect);
Rectangle finalRect = myBarcodeWriter.Bounds;
Console.WriteLine("Barcode rendered within " + finalRect);
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Columns Property

Pdf417BarcodeWriterColumns Property

Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; set; }
Public Property Columns As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.ErrorCorrectionLevel Property

Pdf417BarcodeWriterErrorCorrectionLevel Property

Error Correction Level. Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ErrorCorrectionLevel { get; set; }
Public Property ErrorCorrectionLevel As Integer
    Get
    Set

Property Value

Type: Int32
A value within the range 0-8 inclusive.
Remarks
Only values in the range 0-8 are valid. Depending on the value of the Error Correction Level different number of Error Correction Codewords (ECC) are appended. In any Layout if the User selects a valid Error Correction Level that value is respected.
Error Correction Level | Codewords
0 | 2
1 | 4
2 | 8
3 | 16
4 | 32
5 | 64
6 | 128
7 | 256
8 | 512
AIM (Automatic Identification Manufacturers) Standard for PDF417 recommends the following EC Levels depending on the amount of Data:
Data Codewords | Recommended EC Level
1-40 | 2
41-160 | 3
161-320 | 4
321-863 | 5
Remarks
This value determines how many error correction code words will be included in the barcode. The correspondence is exponential. A value of 0 yields 21 code words, 1 yields 22 code words. In general a value of n yields 2n+1 code words.
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.ForeColor Property

Pdf417BarcodeWriterForeColor Property

Gets or sets the the color of the barcode.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

Property Value

Type: Color
The color of the barcode.
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Layout Property

Pdf417BarcodeWriterLayout Property

Determines how the PDF 417 modules are presented. Default is LayoutMode.Auto

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayoutMode Layout { get; set; }
Public Property Layout As LayoutMode
    Get
    Set

Property Value

Type: LayoutMode
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.ModuleHeight Property

Pdf417BarcodeWriterModuleHeight Property

The height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleHeight { get; set; }
Public Property ModuleHeight As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Using ScaleTransform(Single, Single)PageScale any desired ModuleWidth value can be obtained.
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.ModuleWidth Property

Pdf417BarcodeWriterModuleWidth Property

The width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render(byte, Graphics, Rectangle). By default for printing the units are Document which corresponds to 10 mils per unit.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ModuleWidth { get; set; }
Public Property ModuleWidth As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Using ScaleTransform(Single, Single)PageScale any desired ModuleWidth value can be obtained.
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Orientation Property

Pdf417BarcodeWriterOrientation Property

Sets or gets the orientation of the barcode. Default is Pdf417SymbolOrientation.Horizontal

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pdf417SymbolOrientation Orientation { get; set; }
Public Property Orientation As Pdf417SymbolOrientation
    Get
    Set

Property Value

Type: Pdf417SymbolOrientation
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Rows Property

Pdf417BarcodeWriterRows Property

Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; set; }
Public Property Rows As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Truncated Property

Pdf417BarcodeWriterTruncated Property

Indicates whether the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Truncated { get; set; }
Public Property Truncated As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter Methods

The Pdf417BarcodeWriter type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Implementation of IDisposable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Destructor. Should never be called. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Render(Byte, IBarGraphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(Byte, Graphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(String, IBarGraphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(String, Graphics, Rectangle) | Creates the PDF417 bar code.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Dispose Method

Pdf417BarcodeWriterDispose Method

Implementation of IDisposable

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Finalize Method

Pdf417BarcodeWriterFinalize Method

Destructor. Should never be called.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Render Method

Pdf417BarcodeWriterRender Method

Draws the PDF 417 barcode on a Graphics object.
Overload List
 | Name | Description
Public method | Render(Byte, IBarGraphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(Byte, Graphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(String, IBarGraphics, Rectangle) | Creates the PDF417 bar code.
Public method | Render(String, Graphics, Rectangle) | Creates the PDF417 bar code.
Top
See Also

Reference

Pdf417BarcodeWriter Class
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Render Method (Byte[], IBarGraphics, Rectangle)

Pdf417BarcodeWriterRender Method (Byte, IBarGraphics, Rectangle)

Creates the PDF417 bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    byte[] bytes,
    IBarGraphics g,
    Rectangle rect
)
Public Sub Render (
    bytes As Byte(),
    g As IBarGraphics,
    rect As Rectangle
)

Parameters

bytes
Type: SystemByte
The Array of bytes to encode.
g
Type: Atalasoft.Barcoding.WritingIBarGraphics
The concrete IBarGraphics to draw the barcode to.
rect
Type: System.DrawingRectangle
The Layout rectangle in the graphic object where the bar code symbol will be centered.
See Also

Reference

Pdf417BarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Render Method (Byte[], Graphics, Rectangle)

Pdf417BarcodeWriterRender Method (Byte, Graphics, Rectangle)

Creates the PDF417 bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    byte[] bytes,
    Graphics g,
    Rectangle rect
)
Public Sub Render (
    bytes As Byte(),
    g As Graphics,
    rect As Rectangle
)

Parameters

bytes
Type: SystemByte
Array of bytes to encode.
g
Type: System.DrawingGraphics
Graphic object where the bar code will be rendered.
rect
Type: System.DrawingRectangle
Layout rectangle in the graphic object where the bar code symbol will be centered.
See Also

Reference

Pdf417BarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Render Method (String, IBarGraphics, Rectangle)

Pdf417BarcodeWriterRender Method (String, IBarGraphics, Rectangle)

Creates the PDF417 bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    string text,
    IBarGraphics g,
    Rectangle rect
)
Public Sub Render (
    text As String,
    g As IBarGraphics,
    rect As Rectangle
)

Parameters

text
Type: SystemString
The characters to encode. If text consists only of digits then Numeric Encoding is used, otherwise Text Encoding is used.
g
Type: Atalasoft.Barcoding.WritingIBarGraphics
The concrete implementation of IBarGraphics which to draw the barcode to
rect
Type: System.DrawingRectangle
Layout rectangle in the graphic object where the bar code symbol will be centered.
See Also

Reference

Pdf417BarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


Pdf417BarcodeWriter.Render Method (String, Graphics, Rectangle)

Pdf417BarcodeWriterRender Method (String, Graphics, Rectangle)

Creates the PDF417 bar code.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    string text,
    Graphics g,
    Rectangle rect
)
Public Sub Render (
    text As String,
    g As Graphics,
    rect As Rectangle
)

Parameters

text
Type: SystemString
The characters to encode. If text consists only of digits then Numeric Encoding is used, otherwise Text Encoding is used.
g
Type: System.DrawingGraphics
Graphic object where the bar code will be rendered.
rect
Type: System.DrawingRectangle
Layout rectangle in the graphic object where the bar code symbol will be centered.
See Also

Reference

Pdf417BarcodeWriter Class
Render Overload
Atalasoft.Barcoding.Writing Namespace


Pdf417SymbolOrientation Enumeration

Possible orientations for the PDF417 bar code symbol.

Namespace: Atalasoft.Barcoding.Writing
Assembly: Atalasoft.dotImage.Barcoding.Writing (in Atalasoft.dotImage.Barcoding.Writing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Pdf417SymbolOrientation
Public Enumeration Pdf417SymbolOrientation
Members
Member name | Description
Horizontal | The PDF417 bar code will be rendered horizontally.
Vertical | The PDF417 will be rendered vertically.
See Also

Reference

Atalasoft.Barcoding.Writing Namespace


Atalasoft.Converters Namespace

Classes
 | Class | Description
Public class | PointFTypeConverter | A TypeConverter for a PointF object.
Public class | RectangleFTypeConverter | A TypeConverter for the RectangleF object.
Public class | SizeFTypeConverter | A TypeConverter for a SizeF object.


PointFTypeConverter Class

A TypeConverter for a PointF object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelExpandableObjectConverter
Atalasoft.ConvertersPointFTypeConverter

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PointFTypeConverter : ExpandableObjectConverter
Public Class PointFTypeConverter
    Inherits ExpandableObjectConverter

The PointFTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PointFTypeConverter | Creates a new instance of PointFTypeConverter.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Converters Namespace


PointFTypeConverter Constructor

Creates a new instance of PointFTypeConverter.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointFTypeConverter()
Public Sub New
See Also

Reference

PointFTypeConverter Class
Atalasoft.Converters Namespace


PointFTypeConverter Methods

The PointFTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PointFTypeConverter Class
Atalasoft.Converters Namespace


PointFTypeConverter.CanConvertFrom Method

PointFTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

PointFTypeConverter Class
Atalasoft.Converters Namespace


PointFTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

PointFTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

PointFTypeConverter Class
CanConvertFrom Overload
Atalasoft.Converters Namespace


PointFTypeConverter.ConvertFrom Method

PointFTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

PointFTypeConverter Class
Atalasoft.Converters Namespace


PointFTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

PointFTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

PointFTypeConverter Class
ConvertFrom Overload
Atalasoft.Converters Namespace


PointFTypeConverter.ConvertTo Method

PointFTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

PointFTypeConverter Class
Atalasoft.Converters Namespace


PointFTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

PointFTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

PointFTypeConverter Class
ConvertTo Overload
Atalasoft.Converters Namespace


RectangleFTypeConverter Class

A TypeConverter for the RectangleF object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelExpandableObjectConverter
Atalasoft.ConvertersRectangleFTypeConverter

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RectangleFTypeConverter : ExpandableObjectConverter
Public Class RectangleFTypeConverter
    Inherits ExpandableObjectConverter

The RectangleFTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleFTypeConverter | Creates a new instance of RectangleFTypeConverter.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Converters Namespace


RectangleFTypeConverter Constructor

Creates a new instance of RectangleFTypeConverter.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleFTypeConverter()
Public Sub New
See Also

Reference

RectangleFTypeConverter Class
Atalasoft.Converters Namespace


RectangleFTypeConverter Methods

The RectangleFTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RectangleFTypeConverter Class
Atalasoft.Converters Namespace


RectangleFTypeConverter.CanConvertFrom Method

RectangleFTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

RectangleFTypeConverter Class
Atalasoft.Converters Namespace


RectangleFTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

RectangleFTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

RectangleFTypeConverter Class
CanConvertFrom Overload
Atalasoft.Converters Namespace


RectangleFTypeConverter.ConvertFrom Method

RectangleFTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

RectangleFTypeConverter Class
Atalasoft.Converters Namespace


RectangleFTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

RectangleFTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

RectangleFTypeConverter Class
ConvertFrom Overload
Atalasoft.Converters Namespace


RectangleFTypeConverter.ConvertTo Method

RectangleFTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

RectangleFTypeConverter Class
Atalasoft.Converters Namespace


RectangleFTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

RectangleFTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

RectangleFTypeConverter Class
ConvertTo Overload
Atalasoft.Converters Namespace


SizeFTypeConverter Class

A TypeConverter for a SizeF object.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelExpandableObjectConverter
Atalasoft.ConvertersSizeFTypeConverter

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SizeFTypeConverter : ExpandableObjectConverter
Public Class SizeFTypeConverter
    Inherits ExpandableObjectConverter

The SizeFTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SizeFTypeConverter | Creates a new instance of SizeFConverter.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Converters Namespace


SizeFTypeConverter Constructor

Creates a new instance of SizeFConverter.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeFTypeConverter()
Public Sub New
See Also

Reference

SizeFTypeConverter Class
Atalasoft.Converters Namespace


SizeFTypeConverter Methods

The SizeFTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SizeFTypeConverter Class
Atalasoft.Converters Namespace


SizeFTypeConverter.CanConvertFrom Method

SizeFTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

SizeFTypeConverter Class
Atalasoft.Converters Namespace


SizeFTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

SizeFTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean

True if this converter can perform the conversion; otherwise, false.

See Also

Reference

SizeFTypeConverter Class
CanConvertFrom Overload
Atalasoft.Converters Namespace


SizeFTypeConverter.ConvertFrom Method

SizeFTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

SizeFTypeConverter Class
Atalasoft.Converters Namespace


SizeFTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

SizeFTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

SizeFTypeConverter Class
ConvertFrom Overload
Atalasoft.Converters Namespace


SizeFTypeConverter.ConvertTo Method

SizeFTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

SizeFTypeConverter Class
Atalasoft.Converters Namespace


SizeFTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

SizeFTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Atalasoft.Converters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

SizeFTypeConverter Class
ConvertTo Overload
Atalasoft.Converters Namespace


Atalasoft.dotImage.PdfDoc.Bridge Namespace

Classes
 | Class | Description
Public class | AtalaImageCompressor | AtalaImageCompressor is a class that can be added to a PdfGeneratedDocuments Image Resources object to provide compression services for AtalaImage objects. This object is used to add AtalaImage objects into PDF documents.
Public class | AtalaImageCompressorAtalaImageDataProvider | AtalaImageDataProvider is a class for providing sequential access to data in 1-bit AtalaImages.
Public class | AtalaImageCoordinateConverter | AtalaImageCoordinateConverter is used to convert coordinates in AtalaImage space to coordinates in PDF space and vice versa.
Public class | AtalaImageExtractor | The AtalaImageExtractor class is designed to extract images and pages from PDF document.
Public class | AtalaJpegStreamCompressor | AtalaJpegStreamCompressor is a utility class that provides pass-through use of JPEG data in PDF images. This will prevent artificating that may result from repeated decompression and compression of JPEG images.
Public class | PdfAAtalaImageCompressor | The class that can be added to a PdfGeneratedDocuments Image Resources object to provide compression services for AtalaImage objects according to PDF/A standard.


AtalaImageCompressor Class

AtalaImageCompressor is a class that can be added to a PdfGeneratedDocuments Image Resources object to provide compression services for AtalaImage objects. This object is used to add AtalaImage objects into PDF documents.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.BridgeAtalaImageCompressor
Atalasoft.dotImage.PdfDoc.BridgePdfAAtalaImageCompressor

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageCompressor : IPdfImageCompressor
Public Class AtalaImageCompressor
    Implements IPdfImageCompressor

The AtalaImageCompressor type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageCompressor | Initializes a new instance of the AtalaImageCompressor class.
Public method | AtalaImageCompressor(ImageEncoder, ImageEncoder) | Initializes a new instance of the AtalaImageCompressor class with default advanced compressors.
Top
Methods
 | Name | Description
 | AddImageResource | Utility method to add the image to the resources respecting the color profile of the image (if any). This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.
Public method | CanCompress | Determines whether this instance can compress the specified object.
Public method | Compress | Compresses the specified object to the stored stream provided.
 | CreateDocument | This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed. This also installs an AtalaJpegStreamCompressor which will allow pass-through of Stream objects which represent JPEG images without decoding/recompressing them.
 | CreateDocument(ImageEncoder, ImageEncoder) | This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed adding the ability to compress using JPEG2000 and/or JBIG2 compression.
 | CreateImageShape | Utility method to create an image shape using the provided image. This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.
 | CreateImageShapeAt | Utility method to create an image shape using the provided image. This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | Gets the image information for the supplied image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImageSize | Returns the size of the image in PDF space, respecting resolution
 | ImageSizeAt | Returns the size of the image in PDF space, respecting resolution
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerfectCanCompress |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor Constructor

Overload List
 | Name | Description
Public method | AtalaImageCompressor | Initializes a new instance of the AtalaImageCompressor class.
Public method | AtalaImageCompressor(ImageEncoder, ImageEncoder) | Initializes a new instance of the AtalaImageCompressor class with default advanced compressors.
Top
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor Constructor

Initializes a new instance of the AtalaImageCompressor class.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageCompressor()
Public Sub New
See Also

Reference

AtalaImageCompressor Class
AtalaImageCompressor Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor Constructor (ImageEncoder, ImageEncoder)

Initializes a new instance of the AtalaImageCompressor class with default advanced compressors.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageCompressor(
    ImageEncoder jp2Encoder,
    ImageEncoder jbig2Encoder
)
Public Sub New (
    jp2Encoder As ImageEncoder,
    jbig2Encoder As ImageEncoder
)

Parameters

jp2Encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The jpeg2000 encoder to use for color images.
jbig2Encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The jbig2 encoder to use for 1-bit images.
See Also

Reference

AtalaImageCompressor Class
AtalaImageCompressor Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor Methods

The AtalaImageCompressor type exposes the following members.

Methods
 | Name | Description
 | AddImageResource | Utility method to add the image to the resources respecting the color profile of the image (if any). This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.
Public method | CanCompress | Determines whether this instance can compress the specified object.
Public method | Compress | Compresses the specified object to the stored stream provided.
 | CreateDocument | This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed. This also installs an AtalaJpegStreamCompressor which will allow pass-through of Stream objects which represent JPEG images without decoding/recompressing them.
 | CreateDocument(ImageEncoder, ImageEncoder) | This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed adding the ability to compress using JPEG2000 and/or JBIG2 compression.
 | CreateImageShape | Utility method to create an image shape using the provided image. This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.
 | CreateImageShapeAt | Utility method to create an image shape using the provided image. This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | Gets the image information for the supplied image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImageSize | Returns the size of the image in PDF space, respecting resolution
 | ImageSizeAt | Returns the size of the image in PDF space, respecting resolution
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerfectCanCompress |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AddImageResource Method

AtalaImageCompressorAddImageResource Method

Utility method to add the image to the resources respecting the color profile of the image (if any). This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string[] AddImageResource(
    GlobalResources gr,
    AtalaImage image
)
Public Shared Function AddImageResource (
    gr As GlobalResources,
    image As AtalaImage
) As String()

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources to add to.
image
Type: Atalasoft.ImagingAtalaImage
The image to add to the resources.

Return Value

Type: String
An array of strings with the resource names arr[0] is the image resource name and arr[1] is the colorspace resource name (if any)
Remarks
After calling this method the AtalaImage will no longer be needed and can be disposed.
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.CanCompress Method

AtalaImageCompressorCanCompress Method

Determines whether this instance can compress the specified object.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfImageCodec> CanCompress(
    Object o,
    ImageHandlingSkill skill
)
Public Function CanCompress (
    o As Object,
    skill As ImageHandlingSkill
) As IList(Of PdfImageCodec)

Parameters

o
Type: SystemObject
The object to compress.
skill
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesImageHandlingSkill
The skill of compression requested.

Return Value

Type: IListPdfImageCodec
A collection of codecs that can compress the object, null if there are none

Implements

IPdfImageCompressorCanCompress(Object, ImageHandlingSkill)
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.Compress Method

AtalaImageCompressorCompress Method

Compresses the specified object to the stored stream provided.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PdfCompressedImageStreamProvider Compress(
    Object o,
    IStoredStreamProvider streamProvider,
    PdfImageCompression compression
)
Public Overridable Function Compress (
    o As Object,
    streamProvider As IStoredStreamProvider,
    compression As PdfImageCompression
) As PdfCompressedImageStreamProvider

Parameters

o
Type: SystemObject
The object to compress.
streamProvider
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesIStoredStreamProvider
The stream provider.
compression
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
The compression settings to use.

Return Value

Type: PdfCompressedImageStreamProvider
A compressed image stream provider with the compressed image data

Implements

IPdfImageCompressorCompress(Object, IStoredStreamProvider, PdfImageCompression)
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.CreateDocument Method

AtalaImageCompressorCreateDocument Method

Overload List
Name | Description
CreateDocument | This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed. This also installs an AtalaJpegStreamCompressor which will allow pass-through of Stream objects which represent JPEG images without decoding/recompressing them.
CreateDocument(ImageEncoder, ImageEncoder) | This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed adding the ability to compress using JPEG2000 and/or JBIG2 compression.
Top
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.CreateDocument Method

AtalaImageCompressorCreateDocument Method

This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed. This also installs an AtalaJpegStreamCompressor which will allow pass-through of Stream objects which represent JPEG images without decoding/recompressing them.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedDocument CreateDocument()
Public Shared Function CreateDocument As PdfGeneratedDocument

Return Value

Type: PdfGeneratedDocument
A new PdfGeneratedDocument
See Also

Reference

AtalaImageCompressor Class
CreateDocument Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.CreateDocument Method (ImageEncoder, ImageEncoder)

AtalaImageCompressorCreateDocument Method (ImageEncoder, ImageEncoder)

This is a utility method to create a new PdfGeneratedDocument with an AtalaImageCompressor already installed adding the ability to compress using JPEG2000 and/or JBIG2 compression.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedDocument CreateDocument(
    ImageEncoder jp2Encoder,
    ImageEncoder jbig2Encoder
)
Public Shared Function CreateDocument (
    jp2Encoder As ImageEncoder,
    jbig2Encoder As ImageEncoder
) As PdfGeneratedDocument

Parameters

jp2Encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The jpeg2000 encoder to use for color images.
jbig2Encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The jbig2 encoder to use for 1-bit images.

Return Value

Type: PdfGeneratedDocument
A new PdfGeneratedDocument
See Also

Reference

AtalaImageCompressor Class
CreateDocument Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.CreateImageShape Method

AtalaImageCompressorCreateImageShape Method

Utility method to create an image shape using the provided image. This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfImageShape CreateImageShape(
    GlobalResources gr,
    AtalaImage image
)
Public Shared Function CreateImageShape (
    gr As GlobalResources,
    image As AtalaImage
) As PdfImageShape

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources to which the image will be added.
image
Type: Atalasoft.ImagingAtalaImage
The image from which the shape will be made.

Return Value

Type: PdfImageShape
A new PdfImageShape representing the image supplied
Remarks
After calling this method the AtalaImage will no longer be needed and can be disposed.
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.CreateImageShapeAt Method

AtalaImageCompressorCreateImageShapeAt Method

Utility method to create an image shape using the provided image. This method will throw a PDFException if AtalaImageCompressor was not added as a compressor in the passed GlobalResources parameter.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfImageShape CreateImageShapeAt(
    GlobalResources gr,
    AtalaImage image,
    double x,
    double y
)
Public Shared Function CreateImageShapeAt (
    gr As GlobalResources,
    image As AtalaImage,
    x As Double,
    y As Double
) As PdfImageShape

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources to which the image will be added.
image
Type: Atalasoft.ImagingAtalaImage
The image from which the shape will be made.
x
Type: SystemDouble
The x coordinate of the resulting PdfImageShape in PDF space.
y
Type: SystemDouble
The y coordinate of the resulting PdfImageShape in PDF space.

Return Value

Type: PdfImageShape
A new PdfImageShape representing the image supplied
Remarks
After calling this method the AtalaImage will no longer be needed and can be disposed.
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.GetImageInformation Method

AtalaImageCompressorGetImageInformation Method

Gets the image information for the supplied image.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PdfImageInformation GetImageInformation(
    Object o,
    string colorSpaceResourceName
)
Public Overridable Function GetImageInformation (
    o As Object,
    colorSpaceResourceName As String
) As PdfImageInformation

Parameters

o
Type: SystemObject
The object for compression.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.

Return Value

Type: PdfImageInformation
A new PdfImageInformation object representing the object to compress

Implements

IPdfImageCompressorGetImageInformation(Object, String)
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.ImageSize Method

AtalaImageCompressorImageSize Method

Returns the size of the image in PDF space, respecting resolution

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfBounds ImageSize(
    AtalaImage image
)
Public Shared Function ImageSize (
    image As AtalaImage
) As PdfBounds

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to measure.

Return Value

Type: PdfBounds
A PdfBounds in the form (0, 0, width, height) where width and height are in PDF space
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.ImageSizeAt Method

AtalaImageCompressorImageSizeAt Method

Returns the size of the image in PDF space, respecting resolution

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfBounds ImageSizeAt(
    AtalaImage image,
    double x,
    double y
)
Public Shared Function ImageSizeAt (
    image As AtalaImage,
    x As Double,
    y As Double
) As PdfBounds

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to measure.
x
Type: SystemDouble
The desired output left edge of the PdfBounds.
y
Type: SystemDouble
The desired output bottom edge of the PdfBounds.

Return Value

Type: PdfBounds
A PdfBounds in the form (x, y, width, height) where width and height are in PDF space
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.PerfectCanCompress Method

AtalaImageCompressorPerfectCanCompress Method

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IList<PdfImageCodec> PerfectCanCompress(
    AtalaImage image
)
Protected Overridable Function PerfectCanCompress (
    image As AtalaImage
) As IList(Of PdfImageCodec)

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: IListPdfImageCodec
See Also

Reference

AtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider Class

AtalaImageCompressorAtalaImageDataProvider Class

AtalaImageDataProvider is a class for providing sequential access to data in 1-bit AtalaImages.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.BridgeAtalaImageCompressorAtalaImageDataProvider

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageDataProvider
Public Class AtalaImageDataProvider

The AtalaImageCompressorAtalaImageDataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageCompressorAtalaImageDataProvider(AtalaImage, Boolean) | Initializes a new instance of the AtalaImageCompressorAtalaImageDataProvider class.
Public method | AtalaImageCompressorAtalaImageDataProvider(PixelAccessor, Int32) | Initializes a new instance of the AtalaImageCompressorAtalaImageDataProvider class.
Top
Properties
 | Name | Description
Public property | Height | Gets or sets the height of the image data in pixels
Public property | Width | Gets or sets the width of the image data in pixels
Top
Methods
 | Name | Description
Public method | Begin | Initializes for access to data
Public method | End | Cleans up after access.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow | Gets a row of image data
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageDataProvider Constructor

Overload List
 | Name | Description
Public method | AtalaImageCompressorAtalaImageDataProvider(AtalaImage, Boolean) | Initializes a new instance of the AtalaImageCompressorAtalaImageDataProvider class.
Public method | AtalaImageCompressorAtalaImageDataProvider(PixelAccessor, Int32) | Initializes a new instance of the AtalaImageCompressorAtalaImageDataProvider class.
Top
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider Constructor (AtalaImage, Boolean)

AtalaImageCompressorAtalaImageDataProvider Constructor (AtalaImage, Boolean)

Initializes a new instance of the AtalaImageCompressorAtalaImageDataProvider class.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageDataProvider(
    AtalaImage image,
    bool invert
)
Public Sub New (
    image As AtalaImage,
    invert As Boolean
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to use as a data source.
invert
Type: SystemBoolean
if set to true [invert] the data.
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
AtalaImageCompressorAtalaImageDataProvider Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider Constructor (PixelAccessor, Int32)

AtalaImageCompressorAtalaImageDataProvider Constructor (PixelAccessor, Int32)

Initializes a new instance of the AtalaImageCompressorAtalaImageDataProvider class.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageDataProvider(
    PixelAccessor pa,
    int width
)
Public Sub New (
    pa As PixelAccessor,
    width As Integer
)

Parameters

pa
Type: Atalasoft.Imaging.MemoryPixelAccessor
The PixelAccessor to use for image data.
width
Type: SystemInt32
The width of the image data in pixels.
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
AtalaImageCompressorAtalaImageDataProvider Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageDataProvider Properties

The AtalaImageCompressorAtalaImageDataProvider type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets or sets the height of the image data in pixels
Public property | Width | Gets or sets the width of the image data in pixels
Top
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider.Height Property

AtalaImageCompressorAtalaImageDataProviderHeight Property

Gets or sets the height of the image data in pixels

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set

Property Value

Type: Int32
The height.
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider.Width Property

AtalaImageCompressorAtalaImageDataProviderWidth Property

Gets or sets the width of the image data in pixels

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set

Property Value

Type: Int32
The width.
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageDataProvider Methods

The AtalaImageCompressorAtalaImageDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | Begin | Initializes for access to data
Public method | End | Cleans up after access.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow | Gets a row of image data
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider.Begin Method

AtalaImageCompressorAtalaImageDataProviderBegin Method

Initializes for access to data

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Begin()
Public Sub Begin
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider.End Method

AtalaImageCompressorAtalaImageDataProviderEnd Method

Cleans up after access.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCompressor.AtalaImageDataProvider.GetRow Method

AtalaImageCompressorAtalaImageDataProviderGetRow Method

Gets a row of image data

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetRow(
    int y,
    byte[] destBuffer,
    int destOffset,
    int totalBytes
)
Public Sub GetRow (
    y As Integer,
    destBuffer As Byte(),
    destOffset As Integer,
    totalBytes As Integer
)

Parameters

y
Type: SystemInt32
The y coordinate of the scanline to get.
destBuffer
Type: SystemByte
The destination buffer.
destOffset
Type: SystemInt32
The offset in the destination buffer.
totalBytes
Type: SystemInt32
The total bytes to copy.
See Also

Reference

AtalaImageCompressorAtalaImageDataProvider Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter Class

AtalaImageCoordinateConverter is used to convert coordinates in AtalaImage space to coordinates in PDF space and vice versa.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.BridgeAtalaImageCoordinateConverter

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageCoordinateConverter
Public Class AtalaImageCoordinateConverter

The AtalaImageCoordinateConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageCoordinateConverter(AtalaImage) | Initializes a new instance of the AtalaImageCoordinateConverter class. This image must have a valid Resolution property. Image resolution is used for the transformation and compound resolution is supported.
Public method | AtalaImageCoordinateConverter(Dpi, SizeF) | Initializes a new instance of the AtalaImageCoordinateConverter class. This must have a valid resolution and size. Resolution is used for the transformation and compound resolution is supported.
Top
Methods
Name Description
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToImage(PdfBounds)
Converts the input PdfBounds in PDF coordinates to image coordinates
Public method ToImage(PdfPoint)
Converts the input PdfPoint in PDF coordinates to image coordinates.
Public method ToImageI(PdfBounds)
Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, rounding the values
Public method ToImageI(PdfPoint)
Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, rounding the values
Public method ToImageITruncated(PdfBounds)
Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, truncating the values
Public method ToImageITruncated(PdfPoint)
Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, truncating the values
Public method ToPdf(Point)
Converts the input Point in image coordinates to PDF coordinates
Public method ToPdf(Rectangle)
Converts the input Rectangle in image coordinates to PDF coordinates
Public method ToPdf(RectangleF)
Converts the input Rectangle in image coordinates to PDF coordinates
Public method ToPdfImageSize
Converts the image size to the equivalent size in PDF space.
ToPdfImageSize(AtalaImage)
Converts the image size to the equivalent size in PDF space. This is equivalent to
Copy
new AtalaImageCoordinateConverter(image).ToPdfImageSize()
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter Constructor

Overload List
 | Name | Description
Public method | AtalaImageCoordinateConverter(AtalaImage) | Initializes a new instance of the AtalaImageCoordinateConverter class. This image must have a valid Resolution property. Image resolution is used for the transformation and compound resolution is supported.
Public method | AtalaImageCoordinateConverter(Dpi, SizeF) | Initializes a new instance of the AtalaImageCoordinateConverter class. This must have a valid resolution and size. Resolution is used for the transformation and compound resolution is supported.
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter Constructor (AtalaImage)

Initializes a new instance of the AtalaImageCoordinateConverter class. This image must have a valid Resolution property. Image resolution is used for the transformation and compound resolution is supported.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageCoordinateConverter(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image used for building transformations.
See Also

Reference

AtalaImageCoordinateConverter Class
AtalaImageCoordinateConverter Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter Constructor (Dpi, SizeF)

Initializes a new instance of the AtalaImageCoordinateConverter class. This must have a valid resolution and size. Resolution is used for the transformation and compound resolution is supported.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageCoordinateConverter(
    Dpi resolution,
    SizeF size
)
Public Sub New (
    resolution As Dpi,
    size As SizeF
)

Parameters

resolution
Type: Atalasoft.ImagingDpi
The Dpi used for building transformations.
size
Type: System.DrawingSizeF
The size of the image used for building transformations.
See Also

Reference

AtalaImageCoordinateConverter Class
AtalaImageCoordinateConverter Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter Methods

The AtalaImageCoordinateConverter type exposes the following members.

Methods
Name Description
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToImage(PdfBounds)
Converts the input PdfBounds in PDF coordinates to image coordinates
Public method ToImage(PdfPoint)
Converts the input PdfPoint in PDF coordinates to image coordinates.
Public method ToImageI(PdfBounds)
Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, rounding the values
Public method ToImageI(PdfPoint)
Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, rounding the values
Public method ToImageITruncated(PdfBounds)
Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, truncating the values
Public method ToImageITruncated(PdfPoint)
Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, truncating the values
Public method ToPdf(Point)
Converts the input Point in image coordinates to PDF coordinates
Public method ToPdf(Rectangle)
Converts the input Rectangle in image coordinates to PDF coordinates
Public method ToPdf(RectangleF)
Converts the input Rectangle in image coordinates to PDF coordinates
Public method ToPdfImageSize
Converts the image size to the equivalent size in PDF space.
ToPdfImageSize(AtalaImage)
Converts the image size to the equivalent size in PDF space. This is equivalent to
Copy
new AtalaImageCoordinateConverter(image).ToPdfImageSize()
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImage Method

AtalaImageCoordinateConverterToImage Method

Overload List
 | Name | Description
Public method | ToImage(PdfBounds) | Converts the input PdfBounds in PDF coordinates to image coordinates
Public method | ToImage(PdfPoint) | Converts the input PdfPoint in PDF coordinates to image coordinates.
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImage Method (PdfBounds)

AtalaImageCoordinateConverterToImage Method (PdfBounds)

Converts the input PdfBounds in PDF coordinates to image coordinates

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF ToImage(
    PdfBounds r
)
Public Function ToImage (
    r As PdfBounds
) As RectangleF

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The rectangle to convert

Return Value

Type: RectangleF
a RectangleF in image coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToImage Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImage Method (PdfPoint)

AtalaImageCoordinateConverterToImage Method (PdfPoint)

Converts the input PdfPoint in PDF coordinates to image coordinates.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ToImage(
    PdfPoint pt
)
Public Function ToImage (
    pt As PdfPoint
) As PointF

Parameters

pt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The PdfPoint to convert

Return Value

Type: PointF
a PointF in image coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToImage Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImageI Method

AtalaImageCoordinateConverterToImageI Method

Overload List
 | Name | Description
Public method | ToImageI(PdfBounds) | Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, rounding the values
Public method | ToImageI(PdfPoint) | Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, rounding the values
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImageI Method (PdfBounds)

AtalaImageCoordinateConverterToImageI Method (PdfBounds)

Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, rounding the values

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ToImageI(
    PdfBounds r
)
Public Function ToImageI (
    r As PdfBounds
) As Rectangle

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The rectangle to convert

Return Value

Type: Rectangle
a Rectangle in image coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToImageI Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImageI Method (PdfPoint)

AtalaImageCoordinateConverterToImageI Method (PdfPoint)

Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, rounding the values

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ToImageI(
    PdfPoint pt
)
Public Function ToImageI (
    pt As PdfPoint
) As Point

Parameters

pt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The PdfPoint to convert

Return Value

Type: Point
a Point in image coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToImageI Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImageITruncated Method

AtalaImageCoordinateConverterToImageITruncated Method

Overload List
 | Name | Description
Public method | ToImageITruncated(PdfBounds) | Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, truncating the values
Public method | ToImageITruncated(PdfPoint) | Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, truncating the values
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImageITruncated Method (PdfBounds)

AtalaImageCoordinateConverterToImageITruncated Method (PdfBounds)

Converts the input PdfBounds in PDF coordinates to integer-based image coordinates, truncating the values

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ToImageITruncated(
    PdfBounds r
)
Public Function ToImageITruncated (
    r As PdfBounds
) As Rectangle

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The rectangle to convert

Return Value

Type: Rectangle
a Rectangle in image coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToImageITruncated Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToImageITruncated Method (PdfPoint)

AtalaImageCoordinateConverterToImageITruncated Method (PdfPoint)

Converts the input PdfPoint in PDF coordinates to integer-based image coordinates, truncating the values

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ToImageITruncated(
    PdfPoint pt
)
Public Function ToImageITruncated (
    pt As PdfPoint
) As Point

Parameters

pt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The PdfPoint to convert

Return Value

Type: Point
a Point in image coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToImageITruncated Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdf Method

AtalaImageCoordinateConverterToPdf Method

Overload List
 | Name | Description
Public method | ToPdf(Point) | Converts the input Point in image coordinates to PDF coordinates
Public method | ToPdf(Rectangle) | Converts the input Rectangle in image coordinates to PDF coordinates
Public method | ToPdf(RectangleF) | Converts the input Rectangle in image coordinates to PDF coordinates
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdf Method (Point)

AtalaImageCoordinateConverterToPdf Method (Point)

Converts the input Point in image coordinates to PDF coordinates

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint ToPdf(
    Point p
)
Public Function ToPdf (
    p As Point
) As PdfPoint

Parameters

p
Type: System.DrawingPoint
The point to convert

Return Value

Type: PdfPoint
a PdfPoint in PDF coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToPdf Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdf Method (Rectangle)

AtalaImageCoordinateConverterToPdf Method (Rectangle)

Converts the input Rectangle in image coordinates to PDF coordinates

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds ToPdf(
    Rectangle r
)
Public Function ToPdf (
    r As Rectangle
) As PdfBounds

Parameters

r
Type: System.DrawingRectangle
The rectangle to convert.

Return Value

Type: PdfBounds
a PdfBounds in PDF coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToPdf Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdf Method (RectangleF)

AtalaImageCoordinateConverterToPdf Method (RectangleF)

Converts the input Rectangle in image coordinates to PDF coordinates

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds ToPdf(
    RectangleF r
)
Public Function ToPdf (
    r As RectangleF
) As PdfBounds

Parameters

r
Type: System.DrawingRectangleF
The rectangle to convert.

Return Value

Type: PdfBounds
a PdfBounds in PDF coordinates
See Also

Reference

AtalaImageCoordinateConverter Class
ToPdf Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdfImageSize Method

AtalaImageCoordinateConverterToPdfImageSize Method

Overload List
Name Description
Public method ToPdfImageSize
Converts the image size to the equivalent size in PDF space.
ToPdfImageSize(AtalaImage)
Converts the image size to the equivalent size in PDF space. This is equivalent to
Copy
new AtalaImageCoordinateConverter(image).ToPdfImageSize()
Top
See Also

Reference

AtalaImageCoordinateConverter Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdfImageSize Method

AtalaImageCoordinateConverterToPdfImageSize Method

Converts the image size to the equivalent size in PDF space.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds ToPdfImageSize()
Public Function ToPdfImageSize As PdfBounds

Return Value

Type: PdfBounds
a PdfBounds object set to (0, 0, width, height)
See Also

Reference

AtalaImageCoordinateConverter Class
ToPdfImageSize Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageCoordinateConverter.ToPdfImageSize Method (AtalaImage)

AtalaImageCoordinateConverterToPdfImageSize Method (AtalaImage)

Converts the image size to the equivalent size in PDF space. This is equivalent to
Copy
new AtalaImageCoordinateConverter(image).ToPdfImageSize()

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfBounds ToPdfImageSize(
    AtalaImage image
)
Public Shared Function ToPdfImageSize (
    image As AtalaImage
) As PdfBounds

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to use for coverting the size

Return Value

Type: PdfBounds
See Also

Reference

AtalaImageCoordinateConverter Class
ToPdfImageSize Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor Class

The AtalaImageExtractor class is designed to extract images and pages from PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.BridgeAtalaImageExtractor

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageExtractor : IPdfImageExtractor<AtalaImage>,
    IPdfImageExtractor, IDisposable
Public Class AtalaImageExtractor
    Implements IPdfImageExtractor(Of AtalaImage), IPdfImageExtractor,
    IDisposable

The AtalaImageExtractor type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageExtractor | Initializes a new instance of the AtalaImageExtractor class.
Top
Properties
 | Name | Description
Public property | UseTempFile | Gets or sets a value indicating whether temporary files will be used.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AtalaImageExtractor
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AtalaImageExtractor and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExtractPages | Extracts the pages from the PdfGeneratedDocument object as images.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor Constructor

Initializes a new instance of the AtalaImageExtractor class.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageExtractor(
    PdfDecoder decoder = null
)
Public Sub New (
    Optional decoder As PdfDecoder = Nothing
)

Parameters

decoder (Optional)
Type: Atalasoft.Imaging.Codec.PdfPdfDecoder
PdfDecoder, that will be used to extract pages. If it is null, a default decoder will be created.
See Also

Reference

AtalaImageExtractor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor Properties

The AtalaImageExtractor type exposes the following members.

Properties
 | Name | Description
Public property | UseTempFile | Gets or sets a value indicating whether temporary files will be used.
Top
See Also

Reference

AtalaImageExtractor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor.UseTempFile Property

AtalaImageExtractorUseTempFile Property

Gets or sets a value indicating whether temporary files will be used.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseTempFile { get; set; }
Public Property UseTempFile As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AtalaImageExtractor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor Methods

The AtalaImageExtractor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExtractPages | Extracts the pages from the PdfGeneratedDocument object as images.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaImageExtractor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor.Dispose Method

AtalaImageExtractorDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the AtalaImageExtractor
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AtalaImageExtractor and optionally releases the managed resources
Top
See Also

Reference

AtalaImageExtractor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor.Dispose Method

AtalaImageExtractorDispose Method

Releases all resources used by the AtalaImageExtractor

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AtalaImageExtractor Class
Dispose Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor.Dispose Method (Boolean)

AtalaImageExtractorDispose Method (Boolean)

Releases the unmanaged resources used by the AtalaImageExtractor and optionally releases the managed resources

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

AtalaImageExtractor Class
Dispose Overload
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaImageExtractor.ExtractPages Method

AtalaImageExtractorExtractPages Method

Extracts the pages from the PdfGeneratedDocument object as images.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<AtalaImage> ExtractPages(
    PdfGeneratedDocument doc,
    IEnumerable<int> pageIndexes = null
)
Public Function ExtractPages (
    doc As PdfGeneratedDocument,
    Optional pageIndexes As IEnumerable(Of Integer) = Nothing
) As IEnumerable(Of AtalaImage)

Parameters

doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
PdfGeneratedDocument object.
pageIndexes (Optional)
Type: System.Collections.GenericIEnumerableInt32
Indexes of pages to be extracted. If is , then all pages will be extracted.

Return Value

Type: IEnumerableAtalaImage
Extracted page images.

Implements

IPdfImageExtractorTExtractPages(PdfGeneratedDocument, IEnumerableInt32)
See Also

Reference

AtalaImageExtractor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaJpegStreamCompressor Class

AtalaJpegStreamCompressor is a utility class that provides pass-through use of JPEG data in PDF images. This will prevent artificating that may result from repeated decompression and compression of JPEG images.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.BridgeAtalaJpegStreamCompressor

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaJpegStreamCompressor : IPdfImageCompressor
Public Class AtalaJpegStreamCompressor
    Implements IPdfImageCompressor

The AtalaJpegStreamCompressor type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaJpegStreamCompressor | Initializes a new instance of the AtalaJpegStreamCompressor class
Top
Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified object.
Public method | Compress | Compresses the specified object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | Gets the image information for the supplied image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaJpegStreamCompressor Constructor

Initializes a new instance of the AtalaJpegStreamCompressor class

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaJpegStreamCompressor()
Public Sub New
See Also

Reference

AtalaJpegStreamCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaJpegStreamCompressor Methods

The AtalaJpegStreamCompressor type exposes the following members.

Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified object.
Public method | Compress | Compresses the specified object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | Gets the image information for the supplied image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaJpegStreamCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaJpegStreamCompressor.CanCompress Method

AtalaJpegStreamCompressorCanCompress Method

Determines whether this instance can compress the specified object.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfImageCodec> CanCompress(
    Object o,
    ImageHandlingSkill skill
)
Public Function CanCompress (
    o As Object,
    skill As ImageHandlingSkill
) As IList(Of PdfImageCodec)

Parameters

o
Type: SystemObject
The object to compress - this should be a Stream object.
skill
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesImageHandlingSkill
The skill which is requested for compressing the image.

Return Value

Type: IListPdfImageCodec

Implements

IPdfImageCompressorCanCompress(Object, ImageHandlingSkill)
See Also

Reference

AtalaJpegStreamCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaJpegStreamCompressor.Compress Method

AtalaJpegStreamCompressorCompress Method

Compresses the specified object.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressedImageStreamProvider Compress(
    Object o,
    IStoredStreamProvider streamProvider,
    PdfImageCompression compression
)
Public Function Compress (
    o As Object,
    streamProvider As IStoredStreamProvider,
    compression As PdfImageCompression
) As PdfCompressedImageStreamProvider

Parameters

o
Type: SystemObject
The o.
streamProvider
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesIStoredStreamProvider
The stream provider for image data.
compression
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
The compression information to use.

Return Value

Type: PdfCompressedImageStreamProvider
A PdfCompressedStreamProvider for this image

Implements

IPdfImageCompressorCompress(Object, IStoredStreamProvider, PdfImageCompression)
Remarks
This is a pass-through for JPEG image data. The JPEG image data is passed through as is with the exception that JPEG markers are stripped out since they are not valid within PDF files
See Also

Reference

AtalaJpegStreamCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


AtalaJpegStreamCompressor.GetImageInformation Method

AtalaJpegStreamCompressorGetImageInformation Method

Gets the image information for the supplied image.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageInformation GetImageInformation(
    Object o,
    string colorSpaceResourceName
)
Public Function GetImageInformation (
    o As Object,
    colorSpaceResourceName As String
) As PdfImageInformation

Parameters

o
Type: SystemObject
The object for compression.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.

Return Value

Type: PdfImageInformation
A new PdfImageInformation object representing the object to compress

Implements

IPdfImageCompressorGetImageInformation(Object, String)
See Also

Reference

AtalaJpegStreamCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


PdfAAtalaImageCompressor Class

The class that can be added to a PdfGeneratedDocuments Image Resources object to provide compression services for AtalaImage objects according to PDF/A standard.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.BridgeAtalaImageCompressor
Atalasoft.dotImage.PdfDoc.BridgePdfAAtalaImageCompressor

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfAAtalaImageCompressor : AtalaImageCompressor
Public Class PdfAAtalaImageCompressor
    Inherits AtalaImageCompressor

The PdfAAtalaImageCompressor type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAAtalaImageCompressor | Initializes a new instance of the PdfAAtalaImageCompressor class with default advanced compressors.
Top
Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified object. (Inherited from AtalaImageCompressor.)
Public method | Compress | Converts image to RGB color space and compresses the specified object to the stored stream provided. (Overrides AtalaImageCompressorCompress(Object, IStoredStreamProvider, PdfImageCompression).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | (Overrides AtalaImageCompressorGetImageInformation(Object, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerfectCanCompress | (Overrides AtalaImageCompressorPerfectCanCompress(AtalaImage).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge Namespace


PdfAAtalaImageCompressor Constructor

Initializes a new instance of the PdfAAtalaImageCompressor class with default advanced compressors.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAAtalaImageCompressor(
    ImageEncoder jbig2Encoder = null
)
Public Sub New (
    Optional jbig2Encoder As ImageEncoder = Nothing
)

Parameters

jbig2Encoder (Optional)
Type: Atalasoft.Imaging.CodecImageEncoder
The jbig2 encoder to use for 1-bit images.
See Also

Reference

PdfAAtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


PdfAAtalaImageCompressor Methods

The PdfAAtalaImageCompressor type exposes the following members.

Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified object. (Inherited from AtalaImageCompressor.)
Public method | Compress | Converts image to RGB color space and compresses the specified object to the stored stream provided. (Overrides AtalaImageCompressorCompress(Object, IStoredStreamProvider, PdfImageCompression).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | (Overrides AtalaImageCompressorGetImageInformation(Object, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerfectCanCompress | (Overrides AtalaImageCompressorPerfectCanCompress(AtalaImage).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAAtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


PdfAAtalaImageCompressor.Compress Method

PdfAAtalaImageCompressorCompress Method

Converts image to RGB color space and compresses the specified object to the stored stream provided.

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfCompressedImageStreamProvider Compress(
    Object o,
    IStoredStreamProvider streamProvider,
    PdfImageCompression compression
)
Public Overrides Function Compress (
    o As Object,
    streamProvider As IStoredStreamProvider,
    compression As PdfImageCompression
) As PdfCompressedImageStreamProvider

Parameters

o
Type: SystemObject
The object to compress.
streamProvider
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesIStoredStreamProvider
The stream provider.
compression
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
The compression settings to use.

Return Value

Type: PdfCompressedImageStreamProvider
A compressed image stream provider with the compressed image data

Implements

IPdfImageCompressorCompress(Object, IStoredStreamProvider, PdfImageCompression)
See Also

Reference

PdfAAtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


PdfAAtalaImageCompressor.GetImageInformation Method

PdfAAtalaImageCompressorGetImageInformation Method

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfImageInformation GetImageInformation(
    Object o,
    string colorSpaceResourceName
)
Public Overrides Function GetImageInformation (
    o As Object,
    colorSpaceResourceName As String
) As PdfImageInformation

Parameters

o
Type: SystemObject
colorSpaceResourceName
Type: SystemString

Return Value

Type: PdfImageInformation

Implements

IPdfImageCompressorGetImageInformation(Object, String)
See Also

Reference

PdfAAtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


PdfAAtalaImageCompressor.PerfectCanCompress Method

PdfAAtalaImageCompressorPerfectCanCompress Method

Namespace: Atalasoft.dotImage.PdfDoc.Bridge
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IList<PdfImageCodec> PerfectCanCompress(
    AtalaImage image
)
Protected Overrides Function PerfectCanCompress (
    image As AtalaImage
) As IList(Of PdfImageCodec)

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: IListPdfImageCodec
See Also

Reference

PdfAAtalaImageCompressor Class
Atalasoft.dotImage.PdfDoc.Bridge Namespace


Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace

Classes
 | Class | Description
Public class | PdfAnnotationDataConverter | The PdfAnnotationDataConverter object is capable of taking DotImage Annotation objects and translating them into a format suitable for PDF.


PdfAnnotationDataConverter Class

The PdfAnnotationDataConverter object is capable of taking DotImage Annotation objects and translating them into a format suitable for PDF.
Inheritance Hierarchy
SystemObject
Atalasoft.dotImage.PdfDoc.Bridge.AnnotatePdfAnnotationDataConverter

Namespace: Atalasoft.dotImage.PdfDoc.Bridge.Annotate
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class PdfAnnotationDataConverter
Public NotInheritable Class PdfAnnotationDataConverter

The PdfAnnotationDataConverter type exposes the following members.

Methods
Name Description
ConvertAnnotationDataToPdf(AnnotationDataCollection, AnnotationUnit, Dpi, PdfDocumentSigner, PdfUnknownAnnotationHandler)
Converts a multiple pages of annotations for PdfDocumentSigner.
Examples
In the following example, annotations are converted for use in the PdfDocumentSigner.
ConvertAnnotationsForPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

var pagesOfAnnots =
    PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(collection, AnnotationUnit.Pixel, dpis,
        signer);

for (var i = 0; i < pagesOfAnnots.Count; i++)
    foreach (var annotation in pagesOfAnnots[i])
        signer.PagesOfAnnotations[i].Add(annotation);

signer.AppendChangesFinal(true);
ConvertAnnotationDataToPdf(LayerData, AnnotationUnit, Dpi, PdfGeneratedPage, GlobalResources, PdfUnknownAnnotationHandler)
Converts a page of annotations to PDF annotations.
Examples
In the following example, annotations are converted for use in the PdfGeneratedPage.
ConvertAnnotationsForPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var annotations =
        PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel, dpi, page,
            doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);
ConvertAnnotationDataToPdf(LayerData, AnnotationUnit, Dpi, RectangleF, PdfPageRotation, GlobalResources, PdfUnknownAnnotationHandler)
Converts a page of annotations to PDF annotations.
Examples
ConvertAnnotationsToPdfAnnotationsExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var cropBox = page.CropBox.IsEmpty() ? page.MediaBox.ToRectangleF() : page.CropBox.ToRectangleF();
    var rotation = page.Rotation;
    var annotations = PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel,
        dpi, cropBox, rotation, doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);
ExportToPdfDocumentSigner
Exports a multiple pages of annotations to PdfDocumentSigner.
Examples
In the following example, annotations are exported to PdfDocumentSigner.
ExportAnnotationsToPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

PdfAnnotationDataConverter.ExportToPdfDocumentSigner(collection, AnnotationUnit.Pixel, dpis, signer);

signer.AppendChangesFinal(true);
ExportToPdfGeneratedPage
Exports a page of annotations to PdfGeneratedPage.
Examples
In the following example, annotations are exported to PdfGeneratedPage.
ExportAnnotationsToPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
    PdfAnnotationDataConverter.ExportToPdfGeneratedPage(layer, AnnotationUnit.Pixel, dpi,
        page, doc.Resources);

doc.Save(pdfStream);
Top
See Also

Reference

Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter Methods

The PdfAnnotationDataConverter type exposes the following members.

Methods
Name Description
ConvertAnnotationDataToPdf(AnnotationDataCollection, AnnotationUnit, Dpi, PdfDocumentSigner, PdfUnknownAnnotationHandler)
Converts a multiple pages of annotations for PdfDocumentSigner.
Examples
In the following example, annotations are converted for use in the PdfDocumentSigner.
ConvertAnnotationsForPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

var pagesOfAnnots =
    PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(collection, AnnotationUnit.Pixel, dpis,
        signer);

for (var i = 0; i < pagesOfAnnots.Count; i++)
    foreach (var annotation in pagesOfAnnots[i])
        signer.PagesOfAnnotations[i].Add(annotation);

signer.AppendChangesFinal(true);
ConvertAnnotationDataToPdf(LayerData, AnnotationUnit, Dpi, PdfGeneratedPage, GlobalResources, PdfUnknownAnnotationHandler)
Converts a page of annotations to PDF annotations.
Examples
In the following example, annotations are converted for use in the PdfGeneratedPage.
ConvertAnnotationsForPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var annotations =
        PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel, dpi, page,
            doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);
ConvertAnnotationDataToPdf(LayerData, AnnotationUnit, Dpi, RectangleF, PdfPageRotation, GlobalResources, PdfUnknownAnnotationHandler)
Converts a page of annotations to PDF annotations.
Examples
ConvertAnnotationsToPdfAnnotationsExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var cropBox = page.CropBox.IsEmpty() ? page.MediaBox.ToRectangleF() : page.CropBox.ToRectangleF();
    var rotation = page.Rotation;
    var annotations = PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel,
        dpi, cropBox, rotation, doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);
ExportToPdfDocumentSigner
Exports a multiple pages of annotations to PdfDocumentSigner.
Examples
In the following example, annotations are exported to PdfDocumentSigner.
ExportAnnotationsToPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

PdfAnnotationDataConverter.ExportToPdfDocumentSigner(collection, AnnotationUnit.Pixel, dpis, signer);

signer.AppendChangesFinal(true);
ExportToPdfGeneratedPage
Exports a page of annotations to PdfGeneratedPage.
Examples
In the following example, annotations are exported to PdfGeneratedPage.
ExportAnnotationsToPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
    PdfAnnotationDataConverter.ExportToPdfGeneratedPage(layer, AnnotationUnit.Pixel, dpi,
        page, doc.Resources);

doc.Save(pdfStream);
Top
See Also

Reference

PdfAnnotationDataConverter Class
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter.ConvertAnnotationDataToPdf Method

PdfAnnotationDataConverterConvertAnnotationDataToPdf Method

Overload List
Name Description
ConvertAnnotationDataToPdf(AnnotationDataCollection, AnnotationUnit, Dpi, PdfDocumentSigner, PdfUnknownAnnotationHandler)
Converts a multiple pages of annotations for PdfDocumentSigner.
Examples
In the following example, annotations are converted for use in the PdfDocumentSigner.
ConvertAnnotationsForPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

var pagesOfAnnots =
    PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(collection, AnnotationUnit.Pixel, dpis,
        signer);

for (var i = 0; i < pagesOfAnnots.Count; i++)
    foreach (var annotation in pagesOfAnnots[i])
        signer.PagesOfAnnotations[i].Add(annotation);

signer.AppendChangesFinal(true);
ConvertAnnotationDataToPdf(LayerData, AnnotationUnit, Dpi, PdfGeneratedPage, GlobalResources, PdfUnknownAnnotationHandler)
Converts a page of annotations to PDF annotations.
Examples
In the following example, annotations are converted for use in the PdfGeneratedPage.
ConvertAnnotationsForPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var annotations =
        PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel, dpi, page,
            doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);
ConvertAnnotationDataToPdf(LayerData, AnnotationUnit, Dpi, RectangleF, PdfPageRotation, GlobalResources, PdfUnknownAnnotationHandler)
Converts a page of annotations to PDF annotations.
Examples
ConvertAnnotationsToPdfAnnotationsExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var cropBox = page.CropBox.IsEmpty() ? page.MediaBox.ToRectangleF() : page.CropBox.ToRectangleF();
    var rotation = page.Rotation;
    var annotations = PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel,
        dpi, cropBox, rotation, doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);
Top
See Also

Reference

PdfAnnotationDataConverter Class
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter.ConvertAnnotationDataToPdf Method (AnnotationDataCollection, AnnotationUnit, Dpi[], PdfDocumentSigner, PdfUnknownAnnotationHandler)

PdfAnnotationDataConverterConvertAnnotationDataToPdf Method (AnnotationDataCollection, AnnotationUnit, Dpi, PdfDocumentSigner, PdfUnknownAnnotationHandler)

Converts a multiple pages of annotations for PdfDocumentSigner.
Examples
In the following example, annotations are converted for use in the PdfDocumentSigner.
ConvertAnnotationsForPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

var pagesOfAnnots =
    PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(collection, AnnotationUnit.Pixel, dpis,
        signer);

for (var i = 0; i < pagesOfAnnots.Count; i++)
    foreach (var annotation in pagesOfAnnots[i])
        signer.PagesOfAnnotations[i].Add(annotation);

signer.AppendChangesFinal(true);

Namespace: Atalasoft.dotImage.PdfDoc.Bridge.Annotate
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static List<List<BaseAnnotation>> ConvertAnnotationDataToPdf(
    AnnotationDataCollection layers,
    AnnotationUnit units,
    Dpi[] resolutions,
    PdfDocumentSigner signer,
    PdfUnknownAnnotationHandler handler = null
)
Public Shared Function ConvertAnnotationDataToPdf (
    layers As AnnotationDataCollection,
    units As AnnotationUnit,
    resolutions As Dpi(),
    signer As PdfDocumentSigner,
    Optional handler As PdfUnknownAnnotationHandler = Nothing
) As List(Of List(Of BaseAnnotation))

Parameters

layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
signer
Type: Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentSigner
The original source stream for the document.
handler (Optional)
Type: Atalasoft.Annotate.ExportersPdfUnknownAnnotationHandler
The handler for unknown annotation type.

Return Value

Type: ListListBaseAnnotation
The PDF annotation list. Each element represents a page in the document in order. If a page has no annotations, it will contain an empty collection.
Remarks
To create a page with no annotations, add an empty LayerData to the collection.
See Also

Reference

PdfAnnotationDataConverter Class
ConvertAnnotationDataToPdf Overload
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter.ConvertAnnotationDataToPdf Method (LayerData, AnnotationUnit, Dpi, PdfGeneratedPage, GlobalResources, PdfUnknownAnnotationHandler)

PdfAnnotationDataConverterConvertAnnotationDataToPdf Method (LayerData, AnnotationUnit, Dpi, PdfGeneratedPage, GlobalResources, PdfUnknownAnnotationHandler)

Converts a page of annotations to PDF annotations.
Examples
In the following example, annotations are converted for use in the PdfGeneratedPage.
ConvertAnnotationsForPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var annotations =
        PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel, dpi, page,
            doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);

Namespace: Atalasoft.dotImage.PdfDoc.Bridge.Annotate
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static List<BaseAnnotation> ConvertAnnotationDataToPdf(
    LayerData layer,
    AnnotationUnit units,
    Dpi resolution,
    PdfGeneratedPage pdfPage,
    GlobalResources resources,
    PdfUnknownAnnotationHandler handler = null
)
Public Shared Function ConvertAnnotationDataToPdf (
    layer As LayerData,
    units As AnnotationUnit,
    resolution As Dpi,
    pdfPage As PdfGeneratedPage,
    resources As GlobalResources,
    Optional handler As PdfUnknownAnnotationHandler = Nothing
) As List(Of BaseAnnotation)

Parameters

layer
Type: Atalasoft.AnnotateLayerData
A page of annotations.
units
Type: Atalasoft.AnnotateAnnotationUnit
An units in which the page size are expressed.
resolution
Type: Atalasoft.ImagingDpi
A resolutions of the page.
pdfPage
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
The target PDF page.
resources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
Resources that are used by PDF annotations will be placed in this container.
handler (Optional)
Type: Atalasoft.Annotate.ExportersPdfUnknownAnnotationHandler
The handler for unknown annotation type.

Return Value

Type: ListBaseAnnotation
The list of PDF annotations.
See Also

Reference

PdfAnnotationDataConverter Class
ConvertAnnotationDataToPdf Overload
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter.ConvertAnnotationDataToPdf Method (LayerData, AnnotationUnit, Dpi, RectangleF, PdfPageRotation, GlobalResources, PdfUnknownAnnotationHandler)

PdfAnnotationDataConverterConvertAnnotationDataToPdf Method (LayerData, AnnotationUnit, Dpi, RectangleF, PdfPageRotation, GlobalResources, PdfUnknownAnnotationHandler)

Converts a page of annotations to PDF annotations.
Examples
ConvertAnnotationsToPdfAnnotationsExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
{
    var cropBox = page.CropBox.IsEmpty() ? page.MediaBox.ToRectangleF() : page.CropBox.ToRectangleF();
    var rotation = page.Rotation;
    var annotations = PdfAnnotationDataConverter.ConvertAnnotationDataToPdf(layer, AnnotationUnit.Pixel,
        dpi, cropBox, rotation, doc.Resources);
    page.Annotations.AddRange(annotations);
}

doc.Save(pdfStream);

Namespace: Atalasoft.dotImage.PdfDoc.Bridge.Annotate
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static List<BaseAnnotation> ConvertAnnotationDataToPdf(
    LayerData layer,
    AnnotationUnit units,
    Dpi resolution,
    RectangleF pdfPageBox,
    PdfPageRotation rotation,
    GlobalResources resources,
    PdfUnknownAnnotationHandler handler = null
)
Public Shared Function ConvertAnnotationDataToPdf (
    layer As LayerData,
    units As AnnotationUnit,
    resolution As Dpi,
    pdfPageBox As RectangleF,
    rotation As PdfPageRotation,
    resources As GlobalResources,
    Optional handler As PdfUnknownAnnotationHandler = Nothing
) As List(Of BaseAnnotation)

Parameters

layer
Type: Atalasoft.AnnotateLayerData
A page of annotations.
units
Type: Atalasoft.AnnotateAnnotationUnit
An units in which the page size are expressed.
resolution
Type: Atalasoft.ImagingDpi
A resolutions of the page.
pdfPageBox
Type: System.DrawingRectangleF
The PDF page box (CropBox or MediaBox).
rotation
Type: Atalasoft.PdfDocPdfPageRotation
The rotation of PDF page.
resources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
Resources that are used by PDF annotations will be placed in this container.
handler (Optional)
Type: Atalasoft.Annotate.ExportersPdfUnknownAnnotationHandler
The handler for unknown annotation type.

Return Value

Type: ListBaseAnnotation
The list of PDF annotations.
See Also

Reference

PdfAnnotationDataConverter Class
ConvertAnnotationDataToPdf Overload
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter.ExportToPdfDocumentSigner Method

PdfAnnotationDataConverterExportToPdfDocumentSigner Method

Exports a multiple pages of annotations to PdfDocumentSigner.
Examples
In the following example, annotations are exported to PdfDocumentSigner.
ExportAnnotationsToPdfDocumentSignerExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var collection = new AnnotationDataCollection() { new LayerData() { Items = { rectData, polyData } } };
var dpis = new[] { new Dpi(96, 96, ResolutionUnit.DotsPerInch) };
var signer = new PdfDocumentSigner(pdfStream, null);

PdfAnnotationDataConverter.ExportToPdfDocumentSigner(collection, AnnotationUnit.Pixel, dpis, signer);

signer.AppendChangesFinal(true);

Namespace: Atalasoft.dotImage.PdfDoc.Bridge.Annotate
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ExportToPdfDocumentSigner(
    AnnotationDataCollection layers,
    AnnotationUnit units,
    Dpi[] resolutions,
    PdfDocumentSigner signer,
    PdfUnknownAnnotationHandler handler = null
)
Public Shared Sub ExportToPdfDocumentSigner (
    layers As AnnotationDataCollection,
    units As AnnotationUnit,
    resolutions As Dpi(),
    signer As PdfDocumentSigner,
    Optional handler As PdfUnknownAnnotationHandler = Nothing
)

Parameters

layers
Type: Atalasoft.AnnotateAnnotationDataCollection
A collection of pages of annotations.
units
Type: Atalasoft.AnnotateAnnotationUnit
An array of units in which the page sizes are expressed.
resolutions
Type: Atalasoft.ImagingDpi
An array of resolutions of the pages.
signer
Type: Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentSigner
The original source stream for the document.
handler (Optional)
Type: Atalasoft.Annotate.ExportersPdfUnknownAnnotationHandler
The handler for unknown annotation type.
Remarks
To create a page with no annotations, add an empty LayerData to the collection.
See Also

Reference

PdfAnnotationDataConverter Class
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


PdfAnnotationDataConverter.ExportToPdfGeneratedPage Method

PdfAnnotationDataConverterExportToPdfGeneratedPage Method

Exports a page of annotations to PdfGeneratedPage.
Examples
In the following example, annotations are exported to PdfGeneratedPage.
ExportAnnotationsToPdfGeneratedPageExample
Copy
var rectData = new RectangleData()
{
    Size = new SizeF(123, 345),
    Location = new PointF(123, 321),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
var polyData = new PolygonData()
{
    Size = new SizeF(100, 200),
    Location = new PointF(10, 11),
    Fill = new AnnotationBrush(Color.FromArgb(255, 64, 128, 255)),
    Outline = new AnnotationPen(Color.FromArgb(255, 128, 128, 128))
};
polyData.Points.AddRange(new[] { new PointF(1, 1), new PointF(50, 50), new PointF(1, 50) });

var layer = new LayerData() { Items = { rectData, polyData } };
var dpi = new Dpi(96, 96, ResolutionUnit.DotsPerInch);
var doc = new PdfGeneratedDocument(source);
var page = doc.Pages[0] as PdfGeneratedPage;

if (page != null)
    PdfAnnotationDataConverter.ExportToPdfGeneratedPage(layer, AnnotationUnit.Pixel, dpi,
        page, doc.Resources);

doc.Save(pdfStream);

Namespace: Atalasoft.dotImage.PdfDoc.Bridge.Annotate
Assembly: Atalasoft.dotImage.PdfDoc.Bridge (in Atalasoft.dotImage.PdfDoc.Bridge.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ExportToPdfGeneratedPage(
    LayerData layer,
    AnnotationUnit units,
    Dpi resolution,
    PdfGeneratedPage pdfPage,
    GlobalResources resources,
    PdfUnknownAnnotationHandler handler = null
)
Public Shared Sub ExportToPdfGeneratedPage (
    layer As LayerData,
    units As AnnotationUnit,
    resolution As Dpi,
    pdfPage As PdfGeneratedPage,
    resources As GlobalResources,
    Optional handler As PdfUnknownAnnotationHandler = Nothing
)

Parameters

layer
Type: Atalasoft.AnnotateLayerData
A page of annotations.
units
Type: Atalasoft.AnnotateAnnotationUnit
An units in which the page size are expressed.
resolution
Type: Atalasoft.ImagingDpi
A resolutions of the page.
pdfPage
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
The target PDF page.
resources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
Resources that are used by PDF annotations will be placed in this container.
handler (Optional)
Type: Atalasoft.Annotate.ExportersPdfUnknownAnnotationHandler
The handler for unknown annotation type.
See Also

Reference

PdfAnnotationDataConverter Class
Atalasoft.dotImage.PdfDoc.Bridge.Annotate Namespace


Atalasoft.Exceptions Namespace

Classes
 | Class | Description
Public class | AtalaException | DotImage exceptions base class.


AtalaException Class

DotImage exceptions base class.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ExceptionsAtalaException
Atalasoft.Imaging.Codec.OfficeOfficeDecoderException
Atalasoft.Imaging.WebControls.ExceptionsImageSourceException
Atalasoft.Imaging.WebControls.ExceptionsResolveUriException
Atalasoft.Imaging.WebControls.ExceptionsWebDocumentException

Namespace: Atalasoft.Exceptions
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AtalaException : Exception
<SerializableAttribute>
Public Class AtalaException
    Inherits Exception

The AtalaException type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaException | Initializes a new instance of the AtalaException class.
Public method | AtalaException(String) | Initializes a new instance of the AtalaException class.
Protected method | AtalaException(SerializationInfo, StreamingContext) | Initializes a new instance of the AtalaException class.
Public method | AtalaException(String, Exception) | Initializes a new instance of the AtalaException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Exceptions Namespace


AtalaException Constructor

Overload List
 | Name | Description
Public method | AtalaException | Initializes a new instance of the AtalaException class.
Public method | AtalaException(String) | Initializes a new instance of the AtalaException class.
Protected method | AtalaException(SerializationInfo, StreamingContext) | Initializes a new instance of the AtalaException class.
Public method | AtalaException(String, Exception) | Initializes a new instance of the AtalaException class.
Top
See Also

Reference

AtalaException Class
Atalasoft.Exceptions Namespace


AtalaException Constructor

Initializes a new instance of the AtalaException class.

Namespace: Atalasoft.Exceptions
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaException()
Public Sub New
See Also

Reference

AtalaException Class
AtalaException Overload
Atalasoft.Exceptions Namespace


AtalaException Constructor (String)

Initializes a new instance of the AtalaException class.

Namespace: Atalasoft.Exceptions
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

AtalaException Class
AtalaException Overload
Atalasoft.Exceptions Namespace


AtalaException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AtalaException class.

Namespace: Atalasoft.Exceptions
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

AtalaException Class
AtalaException Overload
Atalasoft.Exceptions Namespace


AtalaException Constructor (String, Exception)

Initializes a new instance of the AtalaException class.

Namespace: Atalasoft.Exceptions
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

AtalaException Class
AtalaException Overload
Atalasoft.Exceptions Namespace


AtalaException Properties

The AtalaException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AtalaException Class
Atalasoft.Exceptions Namespace


AtalaException Methods

The AtalaException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AtalaException Class
Atalasoft.Exceptions Namespace


AtalaException Events

The AtalaException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AtalaException Class
Atalasoft.Exceptions Namespace


Atalasoft.FormsProcessing Namespace

Classes
 | Class | Description
Public class | FormsProcessingException | The base class for all exceptions thrown from the FormsProcessing assembly.


FormsProcessingException Class

The base class for all exceptions thrown from the FormsProcessing assembly.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.FormsProcessingFormsProcessingException
Atalasoft.FormsProcessing.AlignmentPageFingerprintGeneratorException
Atalasoft.FormsProcessing.OmrOmrException

Namespace: Atalasoft.FormsProcessing
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FormsProcessingException : Exception
Public Class FormsProcessingException
    Inherits Exception

The FormsProcessingException type exposes the following members.

Constructors
 | Name | Description
Public method | FormsProcessingException | Creates a new FormsProcessingException with the given message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.FormsProcessing Namespace


FormsProcessingException Constructor

Creates a new FormsProcessingException with the given message.

Namespace: Atalasoft.FormsProcessing
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormsProcessingException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

FormsProcessingException Class
Atalasoft.FormsProcessing Namespace


FormsProcessingException Properties

The FormsProcessingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FormsProcessingException Class
Atalasoft.FormsProcessing Namespace


FormsProcessingException Methods

The FormsProcessingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

FormsProcessingException Class
Atalasoft.FormsProcessing Namespace


FormsProcessingException Events

The FormsProcessingException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FormsProcessingException Class
Atalasoft.FormsProcessing Namespace


Atalasoft.FormsProcessing.Alignment Namespace

Classes
 | Class | Description
Public class | AlignmentRejector | This class is used to validate the results of DocumentAligner. It does this by compairing the similarity of PageFingerprints in various ways.
Public class | AlignmentRejectorResult | This class is used by the AlignmentRejector class to report its results.
Public class | AlignmentResult | This class is used by the DocumentAligner class to report its results.
Public class | BadAlignmentException | This type of Exception is thrown when the AlignmentRejector class rejects a document with poor alignment.
Public class | DocumentAligner | The DocumentAligner class attempts to find the best possible alignment transform between two images.
Public class | IntermediateResultFoundEventArgs | This class is used by DocumentAligner's IntermediateResultFound event to report the result of each alignment step.
Public class | PageFingerprint | The data used to represent the structural layout of a specific document. Implementation details are hidden as they may change in the future.
Public class | PageFingerprintGenerator | This class is used to generate PageFingerprint.
Public class | PageFingerprintGeneratorException | Thrown when something has gone wrong generating a PageFingerprint with PageFingerprintGenerator.
Interfaces
 | Interface | Description
Public interface | IAlignmentRejector | An interface representation of AlignmentRejector. This allows you to test your implementation without an actual AlignmentRejector instance.
Public interface | IDocumentAligner | An interface representation of DocumentAligner. This allows you to test your implementation without an actual DocumentAligner instance.
Enumerations
 | Enumeration | Description
Public enumeration | AlignmentRejectionHeuristics | This is an enumeration of the heuristics used by the AlignmentRejector class.


AlignmentRejectionHeuristics Enumeration

This is an enumeration of the heuristics used by the AlignmentRejector class.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum AlignmentRejectionHeuristics
<FlagsAttribute>
Public Enumeration AlignmentRejectionHeuristics
Members
Member name | Description
None | No heuristics.
AlignmentConfidence | The confidence returned by the DocumentAligner class.
PercentTargetStructuresOverlapping | The percentage of the target structures which have corresponding overlapping template structures.
PercentTemplateStructuresOverlapping | The percentage of the template structures which have corresponding overlapping target structures.
PercentTargetAreaOverlapping | The percentage of the total target area which overlaps the template.
PercentTemplateAreaOverlapping | The percentage of the total template area which overlaps the target.
All | Every heuristic.
Default | Default heuristics.
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
Atalasoft.FormsProcessing.AlignmentAlignmentRejector


AlignmentRejector Class

This class is used to validate the results of DocumentAligner. It does this by compairing the similarity of PageFingerprints in various ways.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.AlignmentAlignmentRejector

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AlignmentRejector : IAlignmentRejector
Public Class AlignmentRejector
    Implements IAlignmentRejector

The AlignmentRejector type exposes the following members.

Constructors
 | Name | Description
Public method | AlignmentRejector | Creates a new instance of AlignmentRejector with default settings for each property.
Top
Properties
 | Name | Description
Public property | AlignmentRejectionHeuristics | The heuristics to use to detect poor alignment. Default: AlignmentRejectionHeuristics
Public property | HeuristicThreshold | The minimum accepted value for heuristic results. This value should be between 0 and 1.0. Default: 0.5
Public property | ThrowOnAlignmentResultBelowThreshold | If this is set to true the failure of any heuristic will cause a BadAlignmentException to be thrown. Default: true
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TestAlignmentResult | Tests the AlignmentResult against the given PageFingerprint.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
Atalasoft.FormsProcessing.AlignmentDocumentAligner
Atalasoft.FormsProcessing.AlignmentAlignmentRejectorResult
Atalasoft.FormsProcessing.AlignmentAlignmentResult


AlignmentRejector Constructor

Creates a new instance of AlignmentRejector with default settings for each property.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentRejector()
Public Sub New
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejector Properties

The AlignmentRejector type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentRejectionHeuristics | The heuristics to use to detect poor alignment. Default: AlignmentRejectionHeuristics
Public property | HeuristicThreshold | The minimum accepted value for heuristic results. This value should be between 0 and 1.0. Default: 0.5
Public property | ThrowOnAlignmentResultBelowThreshold | If this is set to true the failure of any heuristic will cause a BadAlignmentException to be thrown. Default: true
Top
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejector.AlignmentRejectionHeuristics Property

AlignmentRejectorAlignmentRejectionHeuristics Property

The heuristics to use to detect poor alignment.

Default: AlignmentRejectionHeuristics

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentRejectionHeuristics AlignmentRejectionHeuristics { get; set; }
Public Property AlignmentRejectionHeuristics As AlignmentRejectionHeuristics
    Get
    Set

Property Value

Type: AlignmentRejectionHeuristics

Implements

IAlignmentRejectorAlignmentRejectionHeuristics
Remarks
If you find a particular heuristic is incorrectly rejecting documents, remove it from this enumeration.
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejector.HeuristicThreshold Property

AlignmentRejectorHeuristicThreshold Property

The minimum accepted value for heuristic results. This value should be between 0 and 1.0.

Default: 0.5

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HeuristicThreshold { get; set; }
Public Property HeuristicThreshold As Double
    Get
    Set

Property Value

Type: Double

Implements

IAlignmentRejectorHeuristicThreshold
Remarks
You can make the AlignmentRejector more strict by increasing this value and more liberal by lowering it.
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejector.ThrowOnAlignmentResultBelowThreshold Property

AlignmentRejectorThrowOnAlignmentResultBelowThreshold Property

If this is set to true the failure of any heuristic will cause a BadAlignmentException to be thrown.

Default: true

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ThrowOnAlignmentResultBelowThreshold { get; set; }
Public Property ThrowOnAlignmentResultBelowThreshold As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IAlignmentRejectorThrowOnAlignmentResultBelowThreshold
Remarks
In some cases you may find it best to inspect the AlignmentRejectorResult manually. In these cases set this property to false so that it will be returned even if the results are poor.
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejector Methods

The AlignmentRejector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TestAlignmentResult | Tests the AlignmentResult against the given PageFingerprint.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejector.TestAlignmentResult Method

AlignmentRejectorTestAlignmentResult Method

Tests the AlignmentResult against the given PageFingerprint.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentRejectorResult TestAlignmentResult(
    AlignmentResult alignmentResult
)
Public Function TestAlignmentResult (
    alignmentResult As AlignmentResult
) As AlignmentRejectorResult

Parameters

alignmentResult
Type: Atalasoft.FormsProcessing.AlignmentAlignmentResult
The result of DocumentAligner

Return Value

Type: AlignmentRejectorResult
An instance of AlignmentRejectorResult which contains the results of each heurisitc used.

Implements

IAlignmentRejectorTestAlignmentResult(AlignmentResult)
Exceptions
Exception | Condition
 | Thrown when ThrowOnAlignmentResultBelowThreshold is true and the a heurisitc returned a result below HeuristicThreshold.
See Also

Reference

AlignmentRejector Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejectorResult Class

This class is used by the AlignmentRejector class to report its results.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.AlignmentAlignmentRejectorResult

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AlignmentRejectorResult
Public Class AlignmentRejectorResult

The AlignmentRejectorResult type exposes the following members.

Constructors
 | Name | Description
Public method | AlignmentRejectorResult | Creates a new AlignmentRejectorResult with the specified result dictionary and enumeration of failed heuristics.
Top
Properties
 | Name | Description
Public property | FailedHeuristics | An enumeration failed heuristics.
Public property | HeuristicResults | The returned scores for each heuristic.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Lists the contents of HeuristicResults (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
Atalasoft.FormsProcessing.AlignmentAlignmentRejector


AlignmentRejectorResult Constructor

Creates a new AlignmentRejectorResult with the specified result dictionary and enumeration of failed heuristics.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentRejectorResult(
    Dictionary<AlignmentRejectionHeuristics, double> heuristicResults,
    AlignmentRejectionHeuristics failedHeuristics
)
Public Sub New (
    heuristicResults As Dictionary(Of AlignmentRejectionHeuristics, Double),
    failedHeuristics As AlignmentRejectionHeuristics
)

Parameters

heuristicResults
Type: System.Collections.GenericDictionaryAlignmentRejectionHeuristics, Double
The result dictionary of heuristics and returned scores.
failedHeuristics
Type: Atalasoft.FormsProcessing.AlignmentAlignmentRejectionHeuristics
An enumeration containing the failed heuristics.
See Also

Reference

AlignmentRejectorResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejectorResult Properties

The AlignmentRejectorResult type exposes the following members.

Properties
 | Name | Description
Public property | FailedHeuristics | An enumeration failed heuristics.
Public property | HeuristicResults | The returned scores for each heuristic.
Top
See Also

Reference

AlignmentRejectorResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejectorResult.FailedHeuristics Property

AlignmentRejectorResultFailedHeuristics Property

An enumeration failed heuristics.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentRejectionHeuristics FailedHeuristics { get; }
Public ReadOnly Property FailedHeuristics As AlignmentRejectionHeuristics
    Get

Property Value

Type: AlignmentRejectionHeuristics
Remarks
Will be AlignmentRejectionHeuristics when alignment was not rejected.
See Also

Reference

AlignmentRejectorResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejectorResult.HeuristicResults Property

AlignmentRejectorResultHeuristicResults Property

The returned scores for each heuristic.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dictionary<AlignmentRejectionHeuristics, double> HeuristicResults { get; }
Public ReadOnly Property HeuristicResults As Dictionary(Of AlignmentRejectionHeuristics, Double)
    Get

Property Value

Type: DictionaryAlignmentRejectionHeuristics, Double
See Also

Reference

AlignmentRejectorResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejectorResult Methods

The AlignmentRejectorResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Lists the contents of HeuristicResults (Overrides ObjectToString.)
Top
See Also

Reference

AlignmentRejectorResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentRejectorResult.ToString Method

AlignmentRejectorResultToString Method

Lists the contents of HeuristicResults

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

AlignmentRejectorResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentResult Class

This class is used by the DocumentAligner class to report its results.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.AlignmentAlignmentResult

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AlignmentResult
Public Class AlignmentResult

The AlignmentResult type exposes the following members.

Constructors
 | Name | Description
Public method | AlignmentResult | Creates a new AlignmentResult instance with the specified amount of overlap and transform.
Top
Properties
 | Name | Description
Public property | PercentOverlap | The closeness of overlap as reported by DocumentAligner's internal alignment algorithm.
Public property | Transform | The best possible geometric transform as reported by DocumentAligner's internal alignment algorithm.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
DocumentAligner Class


AlignmentResult Constructor

Creates a new AlignmentResult instance with the specified amount of overlap and transform.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentResult(
    double percentMatch,
    ImmutableMatrix transform
)
Public Sub New (
    percentMatch As Double,
    transform As ImmutableMatrix
)

Parameters

percentMatch
Type: SystemDouble
The amount of overlap.
transform
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
The template to image transform.
See Also

Reference

AlignmentResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentResult Properties

The AlignmentResult type exposes the following members.

Properties
 | Name | Description
Public property | PercentOverlap | The closeness of overlap as reported by DocumentAligner's internal alignment algorithm.
Public property | Transform | The best possible geometric transform as reported by DocumentAligner's internal alignment algorithm.
Top
See Also

Reference

AlignmentResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentResult.PercentOverlap Property

AlignmentResultPercentOverlap Property

The closeness of overlap as reported by DocumentAligner's internal alignment algorithm.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PercentOverlap { get; }
Public ReadOnly Property PercentOverlap As Double
    Get

Property Value

Type: Double
See Also

Reference

AlignmentResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentResult.Transform Property

AlignmentResultTransform Property

The best possible geometric transform as reported by DocumentAligner's internal alignment algorithm.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImmutableMatrix Transform { get; }
Public ReadOnly Property Transform As ImmutableMatrix
    Get

Property Value

Type: ImmutableMatrix
See Also

Reference

AlignmentResult Class
Atalasoft.FormsProcessing.Alignment Namespace


AlignmentResult Methods

The AlignmentResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AlignmentResult Class
Atalasoft.FormsProcessing.Alignment Namespace


BadAlignmentException Class

This type of Exception is thrown when the AlignmentRejector class rejects a document with poor alignment.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.FormsProcessing.AlignmentBadAlignmentException

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BadAlignmentException : Exception
Public Class BadAlignmentException
    Inherits Exception

The BadAlignmentException type exposes the following members.

Constructors
 | Name | Description
Public method | BadAlignmentException | Creates a new BadAlignmentException with the specified message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace


BadAlignmentException Constructor

Creates a new BadAlignmentException with the specified message.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BadAlignmentException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message to be contained within this exception.
See Also

Reference

BadAlignmentException Class
Atalasoft.FormsProcessing.Alignment Namespace


BadAlignmentException Properties

The BadAlignmentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

BadAlignmentException Class
Atalasoft.FormsProcessing.Alignment Namespace


BadAlignmentException Methods

The BadAlignmentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

BadAlignmentException Class
Atalasoft.FormsProcessing.Alignment Namespace


BadAlignmentException Events

The BadAlignmentException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

BadAlignmentException Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner Class

The DocumentAligner class attempts to find the best possible alignment transform between two images.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.AlignmentDocumentAligner

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentAligner : IDocumentAligner
Public Class DocumentAligner
    Implements IDocumentAligner

The DocumentAligner type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentAligner | Creates a new instance of DocumentAligner with the default property values.
Top
Properties
 | Name | Description
Public property | TargetObjectSize | Gets or sets the approximate size (in pixels) of the primary feature to be considered for alignment. In the case of OMR this would be the size of the marks. Default: 35, 35
Top
Methods
 | Name | Description
Public method | Align(PageFingerprint, PageFingerprint) | Finds the best transform from template to sourceImage based on the given document's fingerprints.
Public method | Align(PageFingerprint, PageFingerprint, ImmutableMatrix) | Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | IntermediateResultFound | This event is fired at the end of each alignment step. Its primary use is to visualize how the alignment algorithm is working for debugging purposes.
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
AlignmentRejector Class
AlignmentResult Class


DocumentAligner Constructor

Creates a new instance of DocumentAligner with the default property values.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentAligner()
Public Sub New
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner Properties

The DocumentAligner type exposes the following members.

Properties
 | Name | Description
Public property | TargetObjectSize | Gets or sets the approximate size (in pixels) of the primary feature to be considered for alignment. In the case of OMR this would be the size of the marks. Default: 35, 35
Top
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner.TargetObjectSize Property

DocumentAlignerTargetObjectSize Property

Gets or sets the approximate size (in pixels) of the primary feature to be considered for alignment. In the case of OMR this would be the size of the marks.

Default: 35, 35

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF TargetObjectSize { get; set; }
Public Property TargetObjectSize As SizeF
    Get
    Set

Property Value

Type: SizeF

Implements

IDocumentAlignerTargetObjectSize
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner Methods

The DocumentAligner type exposes the following members.

Methods
 | Name | Description
Public method | Align(PageFingerprint, PageFingerprint) | Finds the best transform from template to sourceImage based on the given document's fingerprints.
Public method | Align(PageFingerprint, PageFingerprint, ImmutableMatrix) | Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner.Align Method

DocumentAlignerAlign Method

Finds the best transform from source to target based on a given pair of PageFingerprints.

Overload List
 | Name | Description
Public method | Align(PageFingerprint, PageFingerprint) | Finds the best transform from template to sourceImage based on the given document's fingerprints.
Public method | Align(PageFingerprint, PageFingerprint, ImmutableMatrix) | Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.
Top
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner.Align Method (PageFingerprint, PageFingerprint)

DocumentAlignerAlign Method (PageFingerprint, PageFingerprint)

Finds the best transform from template to sourceImage based on the given document's fingerprints.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentResult Align(
    PageFingerprint sourceFingerprint,
    PageFingerprint targetFingerprint
)
Public Function Align (
    sourceFingerprint As PageFingerprint,
    targetFingerprint As PageFingerprint
) As AlignmentResult

Parameters

sourceFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint
targetFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint

Return Value

Type: AlignmentResult
An AlignmentResult instance containing a transform from template to document and the closeness of overlap provided by that transform.
See Also

Reference

DocumentAligner Class
Align Overload
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner.Align Method (PageFingerprint, PageFingerprint, ImmutableMatrix)

DocumentAlignerAlign Method (PageFingerprint, PageFingerprint, ImmutableMatrix)

Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentResult Align(
    PageFingerprint sourceFingerprint,
    PageFingerprint targetFingerprint,
    ImmutableMatrix initialAlignment
)
Public Function Align (
    sourceFingerprint As PageFingerprint,
    targetFingerprint As PageFingerprint,
    initialAlignment As ImmutableMatrix
) As AlignmentResult

Parameters

sourceFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint
The source fingerprint
targetFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint
The target fingerprint
initialAlignment
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
The initial document alignment matrix

Return Value

Type: AlignmentResult
The result of the alignment process which includes a transformation matrix from the source to the target.

Implements

IDocumentAlignerAlign(PageFingerprint, PageFingerprint, ImmutableMatrix)
Remarks
Expects sourceFingerprint's image to have been previously modified to be the same size in pixels as the the template.
See Also

Reference

DocumentAligner Class
Align Overload
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner Events

The DocumentAligner type exposes the following members.

Events
 | Name | Description
Public event | IntermediateResultFound | This event is fired at the end of each alignment step. Its primary use is to visualize how the alignment algorithm is working for debugging purposes.
Top
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


DocumentAligner.IntermediateResultFound Event

DocumentAlignerIntermediateResultFound Event

This event is fired at the end of each alignment step. Its primary use is to visualize how the alignment algorithm is working for debugging purposes.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<IntermediateResultFoundEventArgs> IntermediateResultFound
Public Event IntermediateResultFound As EventHandler(Of IntermediateResultFoundEventArgs)

Value

Type: SystemEventHandlerIntermediateResultFoundEventArgs

Implements

IDocumentAlignerIntermediateResultFound
See Also

Reference

DocumentAligner Class
Atalasoft.FormsProcessing.Alignment Namespace


IAlignmentRejector Interface

An interface representation of AlignmentRejector. This allows you to test your implementation without an actual AlignmentRejector instance.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAlignmentRejector
Public Interface IAlignmentRejector

The IAlignmentRejector type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentRejectionHeuristics | See: AlignmentRejectionHeuristics
Public property | HeuristicThreshold | See: HeuristicThreshold
Public property | ThrowOnAlignmentResultBelowThreshold | See: ThrowOnAlignmentResultBelowThreshold
Top
Methods
 | Name | Description
Public method | TestAlignmentResult | See: TestAlignmentResult(AlignmentResult)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
Atalasoft.FormsProcessing.AlignmentAlignmentRejector


IAlignmentRejector Properties

The IAlignmentRejector type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentRejectionHeuristics | See: AlignmentRejectionHeuristics
Public property | HeuristicThreshold | See: HeuristicThreshold
Public property | ThrowOnAlignmentResultBelowThreshold | See: ThrowOnAlignmentResultBelowThreshold
Top
See Also

Reference

IAlignmentRejector Interface
Atalasoft.FormsProcessing.Alignment Namespace


IAlignmentRejector.AlignmentRejectionHeuristics Property

IAlignmentRejectorAlignmentRejectionHeuristics Property

See: AlignmentRejectionHeuristics

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AlignmentRejectionHeuristics AlignmentRejectionHeuristics { get; set; }
Property AlignmentRejectionHeuristics As AlignmentRejectionHeuristics
    Get
    Set

Property Value

Type: AlignmentRejectionHeuristics
See Also

Reference

IAlignmentRejector Interface
Atalasoft.FormsProcessing.Alignment Namespace


IAlignmentRejector.HeuristicThreshold Property

IAlignmentRejectorHeuristicThreshold Property

See: HeuristicThreshold

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double HeuristicThreshold { get; set; }
Property HeuristicThreshold As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

IAlignmentRejector Interface
Atalasoft.FormsProcessing.Alignment Namespace


IAlignmentRejector.ThrowOnAlignmentResultBelowThreshold Property

IAlignmentRejectorThrowOnAlignmentResultBelowThreshold Property

See: ThrowOnAlignmentResultBelowThreshold

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool ThrowOnAlignmentResultBelowThreshold { get; set; }
Property ThrowOnAlignmentResultBelowThreshold As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IAlignmentRejector Interface
Atalasoft.FormsProcessing.Alignment Namespace


IAlignmentRejector Methods

The IAlignmentRejector type exposes the following members.

Methods
 | Name | Description
Public method | TestAlignmentResult | See: TestAlignmentResult(AlignmentResult)
Top
See Also

Reference

IAlignmentRejector Interface
Atalasoft.FormsProcessing.Alignment Namespace


IAlignmentRejector.TestAlignmentResult Method

IAlignmentRejectorTestAlignmentResult Method

See: TestAlignmentResult(AlignmentResult)

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AlignmentRejectorResult TestAlignmentResult(
    AlignmentResult alignmentResult
)
Function TestAlignmentResult (
    alignmentResult As AlignmentResult
) As AlignmentRejectorResult

Parameters

alignmentResult
Type: Atalasoft.FormsProcessing.AlignmentAlignmentResult

Return Value

Type: AlignmentRejectorResult
See Also

Reference

IAlignmentRejector Interface
Atalasoft.FormsProcessing.Alignment Namespace


IDocumentAligner Interface

An interface representation of DocumentAligner. This allows you to test your implementation without an actual DocumentAligner instance.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IDocumentAligner
Public Interface IDocumentAligner

The IDocumentAligner type exposes the following members.

Properties
 | Name | Description
Public property | TargetObjectSize | Gets or sets the approximate size (in pixels) of the primary feature to be considered for alignment. In the case of OMR this would be the size of the marks. Default: 35, 35
Top
Methods
 | Name | Description
Public method | Align | Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.
Top
Events
 | Name | Description
Public event | IntermediateResultFound | This event is fired at the end of each alignment step. Its primary use is to visualize how the alignment algorithm is working for debugging purposes.
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
DocumentAligner Class


IDocumentAligner Properties

The IDocumentAligner type exposes the following members.

Properties
 | Name | Description
Public property | TargetObjectSize | Gets or sets the approximate size (in pixels) of the primary feature to be considered for alignment. In the case of OMR this would be the size of the marks. Default: 35, 35
Top
See Also

Reference

IDocumentAligner Interface
Atalasoft.FormsProcessing.Alignment Namespace


IDocumentAligner.TargetObjectSize Property

IDocumentAlignerTargetObjectSize Property

Gets or sets the approximate size (in pixels) of the primary feature to be considered for alignment. In the case of OMR this would be the size of the marks.

Default: 35, 35

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
SizeF TargetObjectSize { get; set; }
Property TargetObjectSize As SizeF
    Get
    Set

Property Value

Type: SizeF
See Also

Reference

IDocumentAligner Interface
Atalasoft.FormsProcessing.Alignment Namespace


IDocumentAligner Methods

The IDocumentAligner type exposes the following members.

Methods
 | Name | Description
Public method | Align | Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.
Top
See Also

Reference

IDocumentAligner Interface
Atalasoft.FormsProcessing.Alignment Namespace


IDocumentAligner.Align Method

IDocumentAlignerAlign Method

Finds the best transform from source to target based on a given pair of PageFingerprints and an initial alignment estimate.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AlignmentResult Align(
    PageFingerprint sourceFingerprint,
    PageFingerprint targetFingerprint,
    ImmutableMatrix initialAlignment
)
Function Align (
    sourceFingerprint As PageFingerprint,
    targetFingerprint As PageFingerprint,
    initialAlignment As ImmutableMatrix
) As AlignmentResult

Parameters

sourceFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint
The source fingerprint
targetFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint
The target fingerprint
initialAlignment
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
The initial document alignment matrix

Return Value

Type: AlignmentResult
The result of the alignment process which includes a transformation matrix from the source to the target.
Remarks
Expects sourceFingerprint's image to have been previously modified to be the same size in pixels as the the template.
See Also

Reference

IDocumentAligner Interface
Atalasoft.FormsProcessing.Alignment Namespace


IDocumentAligner Events

The IDocumentAligner type exposes the following members.

Events
 | Name | Description
Public event | IntermediateResultFound | This event is fired at the end of each alignment step. Its primary use is to visualize how the alignment algorithm is working for debugging purposes.
Top
See Also

Reference

IDocumentAligner Interface
Atalasoft.FormsProcessing.Alignment Namespace


IDocumentAligner.IntermediateResultFound Event

IDocumentAlignerIntermediateResultFound Event

This event is fired at the end of each alignment step. Its primary use is to visualize how the alignment algorithm is working for debugging purposes.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<IntermediateResultFoundEventArgs> IntermediateResultFound
Event IntermediateResultFound As EventHandler(Of IntermediateResultFoundEventArgs)

Value

Type: SystemEventHandlerIntermediateResultFoundEventArgs
See Also

Reference

IDocumentAligner Interface
Atalasoft.FormsProcessing.Alignment Namespace


IntermediateResultFoundEventArgs Class

This class is used by DocumentAligner's IntermediateResultFound event to report the result of each alignment step.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.AlignmentIntermediateResultFoundEventArgs

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IntermediateResultFoundEventArgs : EventArgs
Public Class IntermediateResultFoundEventArgs
    Inherits EventArgs

The IntermediateResultFoundEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IntermediateResultFoundEventArgs | Creates a new IntermediateResultFoundEventArgs with the specified alignment result.
Top
Properties
 | Name | Description
Public property | IntermediateResult | The result of the previous alignment step.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace
AlignmentResult Class


IntermediateResultFoundEventArgs Constructor

Creates a new IntermediateResultFoundEventArgs with the specified alignment result.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntermediateResultFoundEventArgs(
    AlignmentResult intermediateResult
)
Public Sub New (
    intermediateResult As AlignmentResult
)

Parameters

intermediateResult
Type: Atalasoft.FormsProcessing.AlignmentAlignmentResult
The result of the previous alignment step.
See Also

Reference

IntermediateResultFoundEventArgs Class
Atalasoft.FormsProcessing.Alignment Namespace


IntermediateResultFoundEventArgs Properties

The IntermediateResultFoundEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IntermediateResult | The result of the previous alignment step.
Top
See Also

Reference

IntermediateResultFoundEventArgs Class
Atalasoft.FormsProcessing.Alignment Namespace


IntermediateResultFoundEventArgs.IntermediateResult Property

IntermediateResultFoundEventArgsIntermediateResult Property

The result of the previous alignment step.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentResult IntermediateResult { get; }
Public ReadOnly Property IntermediateResult As AlignmentResult
    Get

Property Value

Type: AlignmentResult
See Also

Reference

IntermediateResultFoundEventArgs Class
Atalasoft.FormsProcessing.Alignment Namespace


IntermediateResultFoundEventArgs Methods

The IntermediateResultFoundEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntermediateResultFoundEventArgs Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprint Class

The data used to represent the structural layout of a specific document. Implementation details are hidden as they may change in the future.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.AlignmentPageFingerprint

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PageFingerprint
<SerializableAttribute>
Public Class PageFingerprint

The PageFingerprint type exposes the following members.

Constructors
 | Name | Description
Public method | PageFingerprint | Creates a dummy PageFingerprint which may be useful for testing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load | Loads a PageFingerprint from a stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves this PageFingerprint to the given stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprint Constructor

Creates a dummy PageFingerprint which may be useful for testing.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageFingerprint()
Public Sub New
See Also

Reference

PageFingerprint Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprint Methods

The PageFingerprint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load | Loads a PageFingerprint from a stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves this PageFingerprint to the given stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageFingerprint Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprint.Load Method

PageFingerprintLoad Method

Loads a PageFingerprint from a stream.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PageFingerprint Load(
    Stream stream
)
Public Shared Function Load (
    stream As Stream
) As PageFingerprint

Parameters

stream
Type: System.IOStream
The stream to load the PageFingerprint from.

Return Value

Type: PageFingerprint
The loaded PageFingerprint
See Also

Reference

PageFingerprint Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprint.Save Method

PageFingerprintSave Method

Saves this PageFingerprint to the given stream.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream
)
Public Sub Save (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream to save the PageFingerprint to.
See Also

Reference

PageFingerprint Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGenerator Class

This class is used to generate PageFingerprint.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.AlignmentPageFingerprintGenerator

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageFingerprintGenerator
Public Class PageFingerprintGenerator

The PageFingerprintGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | PageFingerprintGenerator | Creates a new PageFingerprintGenerator with the default property values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateFingerprint | Call to generate a PageFingerprint from a given document image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGenerator Constructor

Creates a new PageFingerprintGenerator with the default property values.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageFingerprintGenerator()
Public Sub New
See Also

Reference

PageFingerprintGenerator Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGenerator Methods

The PageFingerprintGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateFingerprint | Call to generate a PageFingerprint from a given document image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageFingerprintGenerator Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGenerator.GenerateFingerprint Method

PageFingerprintGeneratorGenerateFingerprint Method

Call to generate a PageFingerprint from a given document image.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageFingerprint GenerateFingerprint(
    AtalaImage image
)
Public Function GenerateFingerprint (
    image As AtalaImage
) As PageFingerprint

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to generate the PageFingerprint from.

Return Value

Type: PageFingerprint
A PageFingerprint represeting the given image.
See Also

Reference

PageFingerprintGenerator Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGeneratorException Class

Thrown when something has gone wrong generating a PageFingerprint with PageFingerprintGenerator.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.FormsProcessingFormsProcessingException
Atalasoft.FormsProcessing.AlignmentPageFingerprintGeneratorException

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageFingerprintGeneratorException : FormsProcessingException
Public Class PageFingerprintGeneratorException
    Inherits FormsProcessingException

The PageFingerprintGeneratorException type exposes the following members.

Constructors
 | Name | Description
Public method | PageFingerprintGeneratorException | Creates a new instance of PageFingerprintGeneratorException.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGeneratorException Constructor

Creates a new instance of PageFingerprintGeneratorException.

Namespace: Atalasoft.FormsProcessing.Alignment
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageFingerprintGeneratorException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

PageFingerprintGeneratorException Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGeneratorException Properties

The PageFingerprintGeneratorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PageFingerprintGeneratorException Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGeneratorException Methods

The PageFingerprintGeneratorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PageFingerprintGeneratorException Class
Atalasoft.FormsProcessing.Alignment Namespace


PageFingerprintGeneratorException Events

The PageFingerprintGeneratorException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PageFingerprintGeneratorException Class
Atalasoft.FormsProcessing.Alignment Namespace


Atalasoft.FormsProcessing.Geometry Namespace

Classes
 | Class | Description
Public class | AtalaImageWindow | AtalaImageWindow is a way to look at the pixels of an image through a convex polygon window and matrix transform. This allows a small portion of an image to be viewed through a transformation without having to keep around an intermediate image.
Public class | DisposableAtalaImageWindow | A version of AtalaImageWindow which disposes of its internal image when Dispose() is called.
Structures
 | Structure | Description
Public structure | ImmutableMatrix | This class represents an 2D geometry transform matrix. This is quite similar to System.Drawing.Drawing2D.Matrix. However, this struct is both faster and immutable.


AtalaImageWindow Class

AtalaImageWindow is a way to look at the pixels of an image through a convex polygon window and matrix transform. This allows a small portion of an image to be viewed through a transformation without having to keep around an intermediate image.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.GeometryAtalaImageWindow
Atalasoft.FormsProcessing.GeometryDisposableAtalaImageWindow

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageWindow : IDisposable
Public Class AtalaImageWindow
    Implements IDisposable

The AtalaImageWindow type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageWindow(AtalaImage) | Creates a new AtalaImageWindow based on an image. This AtalaImageWindow is bounded by the image size and is not transformed.
Public method | AtalaImageWindow(AtalaImage, ImmutableMatrix) | Creates a new AtalaImageWindow based on an image, and a transformation matrix. This is done by transforming the bounds of the image with the given ImmutableMatrix to create convex polygon. This polygon is the "window" through which the given image is viewed.
Public method | AtalaImageWindow(AtalaImage, RectangleF) | Creates a new AtalaImageWindow based on an image, and a RectangleF. This AtalaImageWindow is bounded by the RectangleF but not transformed in any way.
Public method | AtalaImageWindow(AtalaImage, RectangleF, ImmutableMatrix) | Creates a new bounded AtalaImageWindow based on an image, a bounding rectangle and a transformation matrix. This is done by transforming the given RectangleF with the ImmutableMatrix to create convex quadrilateral. This quadrilateral is the "window" through which the given image is viewed.
Top
Properties
 | Name | Description
Public property | PixelFormat | The PixelFormat of this AtalaImageWindow's underlying image data.
Public property | Size | The size (in Pixels) of this AtalaImageWindow.
Top
Methods
 | Name | Description
Public method | ApplyCommand | Apply the given ImageCommand to this AtalaImageWindow.
Public method | Dispose | Only so that subtypes will dispose properly. Does not actually dispose anything.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRelativeSubWindow | Gets a new AtalaImageWindow which represents a sub window of the current AtalaImageWindow.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToAtalaImage | Converts this IAtalaImageWindow into an AtalaImage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class will not dispose of it's contained image when Disposed is called.
See Also

Reference

Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Constructor

Creates a new AtalaImageWindow.
Overload List
 | Name | Description
Public method | AtalaImageWindow(AtalaImage) | Creates a new AtalaImageWindow based on an image. This AtalaImageWindow is bounded by the image size and is not transformed.
Public method | AtalaImageWindow(AtalaImage, ImmutableMatrix) | Creates a new AtalaImageWindow based on an image, and a transformation matrix. This is done by transforming the bounds of the image with the given ImmutableMatrix to create convex polygon. This polygon is the "window" through which the given image is viewed.
Public method | AtalaImageWindow(AtalaImage, RectangleF) | Creates a new AtalaImageWindow based on an image, and a RectangleF. This AtalaImageWindow is bounded by the RectangleF but not transformed in any way.
Public method | AtalaImageWindow(AtalaImage, RectangleF, ImmutableMatrix) | Creates a new bounded AtalaImageWindow based on an image, a bounding rectangle and a transformation matrix. This is done by transforming the given RectangleF with the ImmutableMatrix to create convex quadrilateral. This quadrilateral is the "window" through which the given image is viewed.
Top
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Constructor (AtalaImage)

Creates a new AtalaImageWindow based on an image. This AtalaImageWindow is bounded by the image size and is not transformed.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this AtalaImageWindow.
See Also

Reference

AtalaImageWindow Class
AtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Constructor (AtalaImage, ImmutableMatrix)

Creates a new AtalaImageWindow based on an image, and a transformation matrix. This is done by transforming the bounds of the image with the given ImmutableMatrix to create convex polygon. This polygon is the "window" through which the given image is viewed.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow(
    AtalaImage image,
    ImmutableMatrix matrix
)
Public Sub New (
    image As AtalaImage,
    matrix As ImmutableMatrix
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this AtalaImageWindow.
matrix
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
A matrix representing a transform of the given image.
See Also

Reference

AtalaImageWindow Class
AtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Constructor (AtalaImage, RectangleF)

Creates a new AtalaImageWindow based on an image, and a RectangleF. This AtalaImageWindow is bounded by the RectangleF but not transformed in any way.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow(
    AtalaImage image,
    RectangleF box
)
Public Sub New (
    image As AtalaImage,
    box As RectangleF
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this AtalaImageWindow.
box
Type: System.DrawingRectangleF
A RectangleF representing the to-be-windowed area of the image.
See Also

Reference

AtalaImageWindow Class
AtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Constructor (AtalaImage, RectangleF, ImmutableMatrix)

Creates a new bounded AtalaImageWindow based on an image, a bounding rectangle and a transformation matrix. This is done by transforming the given RectangleF with the ImmutableMatrix to create convex quadrilateral. This quadrilateral is the "window" through which the given image is viewed.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow(
    AtalaImage image,
    RectangleF box,
    ImmutableMatrix matrix
)
Public Sub New (
    image As AtalaImage,
    box As RectangleF,
    matrix As ImmutableMatrix
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this AtalaImageWindow.
box
Type: System.DrawingRectangleF
A RectangleF representing the to-be-windowed area of the image.
matrix
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
A matrix representing a transform of the given RectangleF.
See Also

Reference

AtalaImageWindow Class
AtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Properties

The AtalaImageWindow type exposes the following members.

Properties
 | Name | Description
Public property | PixelFormat | The PixelFormat of this AtalaImageWindow's underlying image data.
Public property | Size | The size (in Pixels) of this AtalaImageWindow.
Top
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow.PixelFormat Property

AtalaImageWindowPixelFormat Property

The PixelFormat of this AtalaImageWindow's underlying image data.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat PixelFormat { get; }
Public ReadOnly Property PixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow.Size Property

AtalaImageWindowSize Property

The size (in Pixels) of this AtalaImageWindow.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF Size { get; }
Public ReadOnly Property Size As SizeF
    Get

Property Value

Type: SizeF
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow Methods

The AtalaImageWindow type exposes the following members.

Methods
 | Name | Description
Public method | ApplyCommand | Apply the given ImageCommand to this AtalaImageWindow.
Public method | Dispose | Only so that subtypes will dispose properly. Does not actually dispose anything.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRelativeSubWindow | Gets a new AtalaImageWindow which represents a sub window of the current AtalaImageWindow.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToAtalaImage | Converts this IAtalaImageWindow into an AtalaImage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow.ApplyCommand Method

AtalaImageWindowApplyCommand Method

Apply the given ImageCommand to this AtalaImageWindow.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableAtalaImageWindow ApplyCommand(
    ImageCommand command
)
Public Function ApplyCommand (
    command As ImageCommand
) As DisposableAtalaImageWindow

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The ImageCommand to apply.

Return Value

Type: DisposableAtalaImageWindow
An instance of AtalaImageWindow which should be disposed of when finished with.
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow.Dispose Method

AtalaImageWindowDispose Method

Only so that subtypes will dispose properly. Does not actually dispose anything.
Only so that subtypes will dispose properly. Does not actually dispose anything.
Only so that subtypes will dispose properly. Does not actually dispose anything.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Dispose()
Public Overridable Sub Dispose

Implements

IDisposableDispose
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow.GetRelativeSubWindow Method

AtalaImageWindowGetRelativeSubWindow Method

Gets a new AtalaImageWindow which represents a sub window of the current AtalaImageWindow.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow GetRelativeSubWindow(
    RectangleF subRect
)
Public Function GetRelativeSubWindow (
    subRect As RectangleF
) As AtalaImageWindow

Parameters

subRect
Type: System.DrawingRectangleF
A subrectangle bounding the pixels to be in the new AtalaImageWindow

Return Value

Type: AtalaImageWindow
An instance of AtalaImageWindow which should be disposed of when finished with.
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


AtalaImageWindow.ToAtalaImage Method

AtalaImageWindowToAtalaImage Method

Converts this IAtalaImageWindow into an AtalaImage.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ToAtalaImage()
Public Function ToAtalaImage As AtalaImage

Return Value

Type: AtalaImage
The AtalaImage representation of this AtalaImageWindow. Please dispose of this AtalaImage when finished with it.
See Also

Reference

AtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Class

A version of AtalaImageWindow which disposes of its internal image when Dispose() is called.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.GeometryAtalaImageWindow
Atalasoft.FormsProcessing.GeometryDisposableAtalaImageWindow

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DisposableAtalaImageWindow : AtalaImageWindow,
    IDisposable
Public Class DisposableAtalaImageWindow
    Inherits AtalaImageWindow
    Implements IDisposable

The DisposableAtalaImageWindow type exposes the following members.

Constructors
 | Name | Description
Public method | DisposableAtalaImageWindow(AtalaImage) | Creates a new DisposableAtalaImageWindow based on an image. This DisposableAtalaImageWindow is neither bounded nor transformed.
Public method | DisposableAtalaImageWindow(AtalaImage, ImmutableMatrix) | Initializes a new instance of the DisposableAtalaImageWindow class
Public method | DisposableAtalaImageWindow(AtalaImage, RectangleF) | DisposableAtalaImageWindow is bounded by the RectangleF but not transformed in any way.
Public method | DisposableAtalaImageWindow(AtalaImage, RectangleF, ImmutableMatrix) | Creates a new bounded DisposableAtalaImageWindow based on an image, a bounding rectangle and a transformation matrix. This is done by transforming the given RectangleF with the ImmutableMatrix to create convex quadrilateral. This quadrilateral is the "window" through which the given image is viewed.
Top
Properties
 | Name | Description
Public property | PixelFormat | The PixelFormat of this AtalaImageWindow's underlying image data. (Inherited from AtalaImageWindow.)
Public property | Size | The size (in Pixels) of this AtalaImageWindow. (Inherited from AtalaImageWindow.)
Top
Methods
 | Name | Description
Public method | ApplyCommand | Apply the given ImageCommand to this AtalaImageWindow. (Inherited from AtalaImageWindow.)
Public method | Dispose | Disposes the contained AtalaImage (Overrides AtalaImageWindowDispose.)
Protected method | Dispose(Boolean) | A special version of Dispose which ensures Dispose() is only called on managed object once.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRelativeSubWindow | Gets a new AtalaImageWindow which represents a sub window of the current AtalaImageWindow. (Inherited from AtalaImageWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToAtalaImage | Converts this IAtalaImageWindow into an AtalaImage. (Inherited from AtalaImageWindow.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Constructor

Creates a new DisposableAtalaImageWindow instance.
Overload List
 | Name | Description
Public method | DisposableAtalaImageWindow(AtalaImage) | Creates a new DisposableAtalaImageWindow based on an image. This DisposableAtalaImageWindow is neither bounded nor transformed.
Public method | DisposableAtalaImageWindow(AtalaImage, ImmutableMatrix) | Initializes a new instance of the DisposableAtalaImageWindow class
Public method | DisposableAtalaImageWindow(AtalaImage, RectangleF) | DisposableAtalaImageWindow is bounded by the RectangleF but not transformed in any way.
Public method | DisposableAtalaImageWindow(AtalaImage, RectangleF, ImmutableMatrix) | Creates a new bounded DisposableAtalaImageWindow based on an image, a bounding rectangle and a transformation matrix. This is done by transforming the given RectangleF with the ImmutableMatrix to create convex quadrilateral. This quadrilateral is the "window" through which the given image is viewed.
Top
See Also

Reference

DisposableAtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Constructor (AtalaImage)

Creates a new DisposableAtalaImageWindow based on an image. This DisposableAtalaImageWindow is neither bounded nor transformed.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableAtalaImageWindow(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this DisposableAtalaImageWindow.
See Also

Reference

DisposableAtalaImageWindow Class
DisposableAtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Constructor (AtalaImage, ImmutableMatrix)

Initializes a new instance of the DisposableAtalaImageWindow class

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableAtalaImageWindow(
    AtalaImage image,
    ImmutableMatrix matrix
)
Public Sub New (
    image As AtalaImage,
    matrix As ImmutableMatrix
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this DisposableAtalaImageWindow.
matrix
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
A matrix representing a transform of the given image.
See Also

Reference

DisposableAtalaImageWindow Class
DisposableAtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Constructor (AtalaImage, RectangleF)

DisposableAtalaImageWindow is bounded by the RectangleF but not transformed in any way.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableAtalaImageWindow(
    AtalaImage image,
    RectangleF rect
)
Public Sub New (
    image As AtalaImage,
    rect As RectangleF
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this DisposableAtalaImageWindow.
rect
Type: System.DrawingRectangleF
A RectangleF representing the to-be-windowed area of the image.
See Also

Reference

DisposableAtalaImageWindow Class
DisposableAtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Constructor (AtalaImage, RectangleF, ImmutableMatrix)

Creates a new bounded DisposableAtalaImageWindow based on an image, a bounding rectangle and a transformation matrix. This is done by transforming the given RectangleF with the ImmutableMatrix to create convex quadrilateral. This quadrilateral is the "window" through which the given image is viewed.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableAtalaImageWindow(
    AtalaImage image,
    RectangleF box,
    ImmutableMatrix matrix
)
Public Sub New (
    image As AtalaImage,
    box As RectangleF,
    matrix As ImmutableMatrix
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The underlying AtalaImage to be used as the base of this DisposableAtalaImageWindow.
box
Type: System.DrawingRectangleF
A RectangleF representing the to-be-windowed area of the image.
matrix
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
A matrix representing a transform of the given RectangleF.
See Also

Reference

DisposableAtalaImageWindow Class
DisposableAtalaImageWindow Overload
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Properties

The DisposableAtalaImageWindow type exposes the following members.

Properties
 | Name | Description
Public property | PixelFormat | The PixelFormat of this AtalaImageWindow's underlying image data. (Inherited from AtalaImageWindow.)
Public property | Size | The size (in Pixels) of this AtalaImageWindow. (Inherited from AtalaImageWindow.)
Top
See Also

Reference

DisposableAtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow Methods

The DisposableAtalaImageWindow type exposes the following members.

Methods
 | Name | Description
Public method | ApplyCommand | Apply the given ImageCommand to this AtalaImageWindow. (Inherited from AtalaImageWindow.)
Public method | Dispose | Disposes the contained AtalaImage (Overrides AtalaImageWindowDispose.)
Protected method | Dispose(Boolean) | A special version of Dispose which ensures Dispose() is only called on managed object once.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRelativeSubWindow | Gets a new AtalaImageWindow which represents a sub window of the current AtalaImageWindow. (Inherited from AtalaImageWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToAtalaImage | Converts this IAtalaImageWindow into an AtalaImage. (Inherited from AtalaImageWindow.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisposableAtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow.Dispose Method

DisposableAtalaImageWindowDispose Method

Disposes the contained AtalaImage.
Overload List
 | Name | Description
Public method | Dispose | Disposes the contained AtalaImage (Overrides AtalaImageWindowDispose.)
Protected method | Dispose(Boolean) | A special version of Dispose which ensures Dispose() is only called on managed object once.
Top
See Also

Reference

DisposableAtalaImageWindow Class
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow.Dispose Method

DisposableAtalaImageWindowDispose Method

Disposes the contained AtalaImage

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Dispose()
Public Overrides Sub Dispose

Implements

IDisposableDispose
IDisposableDispose
See Also

Reference

DisposableAtalaImageWindow Class
Dispose Overload
Atalasoft.FormsProcessing.Geometry Namespace


DisposableAtalaImageWindow.Dispose Method (Boolean)

DisposableAtalaImageWindowDispose Method (Boolean)

A special version of Dispose which ensures Dispose() is only called on managed object once.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Should be true when called from Dispose()
See Also

Reference

DisposableAtalaImageWindow Class
Dispose Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix Structure

This class represents an 2D geometry transform matrix. This is quite similar to System.Drawing.Drawing2D.Matrix. However, this struct is both faster and immutable.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public struct ImmutableMatrix
Public Structure ImmutableMatrix

The ImmutableMatrix type exposes the following members.

Constructors
 | Name | Description
Public method | ImmutableMatrix(Single) | Creates a new ImmutableMatrix instance with the values provided in the given array. [ xScale, xShear, xT ] [ yShear, yScale, yT ] [ 0, 0, 1 ]
Public method | ImmutableMatrix(Single, Single, Single, Single, Single, Single) | Creates a new ImmutableMatrix instance with the following values. [ xScale, xShear, xT ] [ yShear, yScale, yT ] [ 0, 0, 1 ]
Top
Properties
 | Name | Description
 | Identity | Returns an new instance of an identity Matrix.
Public property | Type | A text description of the type of this Matrix.
Public property | XScale | The upper left value of the matrix (0,0). Indicates scaling on the X-Axis.
Public property | XShear | The upper-middle value of the matrix (1,0). Indicates shearing parallel to the X-Axis.
Public property | XTranslation | The upper-right value of the matrix (2,0). Indicates translation along the X-Axis.
Public property | YScale | The middle value of the matrix (1,1). Indicates scaling on the Y-Axis.
Public property | YShear | The left-middle value of the matrix (0,1). Indicates shearing parallel to the Y-Axis.
Public property | YTranslation | The middle-right value of the matrix (2,1). Indicates translation along the Y-Axis.
Top
Methods
 | Name | Description
Public method | ApproximateTransform(RectangleF) |
Public method | ApproximateTransform(RectangleF) | Creates a new set of RectangleFs based on the transformation of the given RectangleFs by this Matrix. This is done by performing transformation on the centerpoint of the RectangleF and scaling its size.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetDrawing2DMatrix | Creates a System.Drawing.Drawing2D.Matrix from this Matrix.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetPostTransformBoundedRectangle | Creates a new RectangleF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding RectangleF.
Public method | GetRectangleBoundedPostTransformSize(PointF) | Creates a new SizeF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding SizeF.
Public method | GetRectangleBoundedPostTransformSize(SizeF) | Creates a new SizeF based on the transformation of the given SizeF by this Matrix. The SizeF is first converted to points. After transformation, the resulting points are then fitted with a bounding SizeF.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Used to find the product of two ImmutableMatricies.
 | RotationMatrix(Single) | Returns a new instance of a rotation matrix (around 0,0)
 | RotationMatrix(PointF, Single) | Returns a new instance of a rotation matrix (around x,y)
 | RotationMatrix(Single, Single, Single) | Returns a new instance of a rotation matrix (around x,y)
 | ScaleMatrix | Returns a new instance of a scale matrix
 | ShearMatrix | Returns a new instance of a shear matrix
Public method | ToString | Returns a text description of what this ImmutableMatrix represents. (Overrides ValueTypeToString.)
Public method | Transform(PointF) | Creates a new PointF based on the transformation of the given PointF by this Matrix.
Public method | Transform(PointF) | Creates a new set of PointFs based on the transformation of the given PointFs by this Matrix.
 | TranslationMatrix | Returns a new instance of a translation matrix
Top
See Also

Reference

Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix Constructor

Creates a new ImmutableMatrix instance.
Overload List
 | Name | Description
Public method | ImmutableMatrix(Single) | Creates a new ImmutableMatrix instance with the values provided in the given array. [ xScale, xShear, xT ] [ yShear, yScale, yT ] [ 0, 0, 1 ]
Public method | ImmutableMatrix(Single, Single, Single, Single, Single, Single) | Creates a new ImmutableMatrix instance with the following values. [ xScale, xShear, xT ] [ yShear, yScale, yT ] [ 0, 0, 1 ]
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix Constructor (Single[,])

ImmutableMatrix Constructor (Single)

Creates a new ImmutableMatrix instance with the values provided in the given array.
[ xScale, xShear, xT ]
[ yShear, yScale, yT ]
[      0,      0,  1 ]

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImmutableMatrix(
    float[,] matrix
)
Public Sub New (
    matrix As Single(,)
)

Parameters

matrix
Type: SystemSingle
A 2x3 array containing the values of the matrix.
See Also

Reference

ImmutableMatrix Structure
ImmutableMatrix Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix Constructor (Single, Single, Single, Single, Single, Single)

Creates a new ImmutableMatrix instance with the following values. [ xScale, xShear, xT ] [ yShear, yScale, yT ] [ 0, 0, 1 ]

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImmutableMatrix(
    float xScale,
    float xShear,
    float xTranslation,
    float yShear,
    float yScale,
    float yTranslation
)
Public Sub New (
    xScale As Single,
    xShear As Single,
    xTranslation As Single,
    yShear As Single,
    yScale As Single,
    yTranslation As Single
)

Parameters

xScale
Type: SystemSingle
(0,0)
xShear
Type: SystemSingle
(1,0)
xTranslation
Type: SystemSingle
(2,0)
yShear
Type: SystemSingle
(0,1)
yScale
Type: SystemSingle
(1,1)
yTranslation
Type: SystemSingle
(2,1)
See Also

Reference

ImmutableMatrix Structure
ImmutableMatrix Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix Properties

The ImmutableMatrix type exposes the following members.

Properties
 | Name | Description
 | Identity | Returns an new instance of an identity Matrix.
Public property | Type | A text description of the type of this Matrix.
Public property | XScale | The upper left value of the matrix (0,0). Indicates scaling on the X-Axis.
Public property | XShear | The upper-middle value of the matrix (1,0). Indicates shearing parallel to the X-Axis.
Public property | XTranslation | The upper-right value of the matrix (2,0). Indicates translation along the X-Axis.
Public property | YScale | The middle value of the matrix (1,1). Indicates scaling on the Y-Axis.
Public property | YShear | The left-middle value of the matrix (0,1). Indicates shearing parallel to the Y-Axis.
Public property | YTranslation | The middle-right value of the matrix (2,1). Indicates translation along the Y-Axis.
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.Identity Property

ImmutableMatrixIdentity Property

Returns an new instance of an identity Matrix.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix Identity { get; }
Public Shared ReadOnly Property Identity As ImmutableMatrix
    Get

Property Value

Type: ImmutableMatrix
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.Type Property

ImmutableMatrixType Property

A text description of the type of this Matrix.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get

Property Value

Type: String
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.XScale Property

ImmutableMatrixXScale Property

The upper left value of the matrix (0,0). Indicates scaling on the X-Axis.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float XScale { get; }
Public ReadOnly Property XScale As Single
    Get

Property Value

Type: Single
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.XShear Property

ImmutableMatrixXShear Property

The upper-middle value of the matrix (1,0). Indicates shearing parallel to the X-Axis.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float XShear { get; }
Public ReadOnly Property XShear As Single
    Get

Property Value

Type: Single
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.XTranslation Property

ImmutableMatrixXTranslation Property

The upper-right value of the matrix (2,0). Indicates translation along the X-Axis.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float XTranslation { get; }
Public ReadOnly Property XTranslation As Single
    Get

Property Value

Type: Single
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.YScale Property

ImmutableMatrixYScale Property

The middle value of the matrix (1,1). Indicates scaling on the Y-Axis.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float YScale { get; }
Public ReadOnly Property YScale As Single
    Get

Property Value

Type: Single
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.YShear Property

ImmutableMatrixYShear Property

The left-middle value of the matrix (0,1). Indicates shearing parallel to the Y-Axis.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float YShear { get; }
Public ReadOnly Property YShear As Single
    Get

Property Value

Type: Single
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.YTranslation Property

ImmutableMatrixYTranslation Property

The middle-right value of the matrix (2,1). Indicates translation along the Y-Axis.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float YTranslation { get; }
Public ReadOnly Property YTranslation As Single
    Get

Property Value

Type: Single
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix Methods

The ImmutableMatrix type exposes the following members.

Methods
 | Name | Description
Public method | ApproximateTransform(RectangleF) |
Public method | ApproximateTransform(RectangleF) | Creates a new set of RectangleFs based on the transformation of the given RectangleFs by this Matrix. This is done by performing transformation on the centerpoint of the RectangleF and scaling its size.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetDrawing2DMatrix | Creates a System.Drawing.Drawing2D.Matrix from this Matrix.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetPostTransformBoundedRectangle | Creates a new RectangleF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding RectangleF.
Public method | GetRectangleBoundedPostTransformSize(PointF) | Creates a new SizeF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding SizeF.
Public method | GetRectangleBoundedPostTransformSize(SizeF) | Creates a new SizeF based on the transformation of the given SizeF by this Matrix. The SizeF is first converted to points. After transformation, the resulting points are then fitted with a bounding SizeF.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Used to find the product of two ImmutableMatricies.
 | RotationMatrix(Single) | Returns a new instance of a rotation matrix (around 0,0)
 | RotationMatrix(PointF, Single) | Returns a new instance of a rotation matrix (around x,y)
 | RotationMatrix(Single, Single, Single) | Returns a new instance of a rotation matrix (around x,y)
 | ScaleMatrix | Returns a new instance of a scale matrix
 | ShearMatrix | Returns a new instance of a shear matrix
Public method | ToString | Returns a text description of what this ImmutableMatrix represents. (Overrides ValueTypeToString.)
Public method | Transform(PointF) | Creates a new PointF based on the transformation of the given PointF by this Matrix.
Public method | Transform(PointF) | Creates a new set of PointFs based on the transformation of the given PointFs by this Matrix.
 | TranslationMatrix | Returns a new instance of a translation matrix
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.ApproximateTransform Method

ImmutableMatrixApproximateTransform Method

Overload List
 | Name | Description
Public method | ApproximateTransform(RectangleF) |
Public method | ApproximateTransform(RectangleF) | Creates a new set of RectangleFs based on the transformation of the given RectangleFs by this Matrix. This is done by performing transformation on the centerpoint of the RectangleF and scaling its size.
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.ApproximateTransform Method (RectangleF)

ImmutableMatrixApproximateTransform Method (RectangleF)

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF ApproximateTransform(
    RectangleF rect
)
Public Function ApproximateTransform (
    rect As RectangleF
) As RectangleF

Parameters

rect
Type: System.DrawingRectangleF
The RectangleF to be transformed.

Return Value

Type: RectangleF
A new RectangleF which has had this transform applied.
Remarks
This transform is not pure. It is done by performing transformation on the centerpoint of the RectangleF and scaling its size.
See Also

Reference

ImmutableMatrix Structure
ApproximateTransform Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.ApproximateTransform Method (RectangleF[])

ImmutableMatrixApproximateTransform Method (RectangleF)

Creates a new set of RectangleFs based on the transformation of the given RectangleFs by this Matrix. This is done by performing transformation on the centerpoint of the RectangleF and scaling its size.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF[] ApproximateTransform(
    RectangleF[] rects
)
Public Function ApproximateTransform (
    rects As RectangleF()
) As RectangleF()

Parameters

rects
Type: System.DrawingRectangleF
The array of RectangleFs to be transformed.

Return Value

Type: RectangleF
A new array of RectangleFs which have had this transform applied.
Remarks
This transform is not pure. It is done by performing transformation on the centerpoint of each RectangleF and scaling its size.
See Also

Reference

ImmutableMatrix Structure
ApproximateTransform Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.GetDrawing2DMatrix Method

ImmutableMatrixGetDrawing2DMatrix Method

Creates a System.Drawing.Drawing2D.Matrix from this Matrix.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix GetDrawing2DMatrix()
Public Function GetDrawing2DMatrix As Matrix

Return Value

Type: Matrix
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.GetPostTransformBoundedRectangle Method

ImmutableMatrixGetPostTransformBoundedRectangle Method

Creates a new RectangleF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding RectangleF.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF GetPostTransformBoundedRectangle(
    PointF[] preTransformPoints
)
Public Function GetPostTransformBoundedRectangle (
    preTransformPoints As PointF()
) As RectangleF

Parameters

preTransformPoints
Type: System.DrawingPointF
The set of points to be transformed.

Return Value

Type: RectangleF
A rectangle bounding the resulting transformed points.
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.GetRectangleBoundedPostTransformSize Method

ImmutableMatrixGetRectangleBoundedPostTransformSize Method

Creates a bounding SizeF based on the transformation of the given construct.
Overload List
 | Name | Description
Public method | GetRectangleBoundedPostTransformSize(PointF) | Creates a new SizeF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding SizeF.
Public method | GetRectangleBoundedPostTransformSize(SizeF) | Creates a new SizeF based on the transformation of the given SizeF by this Matrix. The SizeF is first converted to points. After transformation, the resulting points are then fitted with a bounding SizeF.
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.GetRectangleBoundedPostTransformSize Method (PointF[])

ImmutableMatrixGetRectangleBoundedPostTransformSize Method (PointF)

Creates a new SizeF based on the transformation of the given set of points by this Matrix. After transformation, the resulting points are then fitted with a bounding SizeF.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF GetRectangleBoundedPostTransformSize(
    PointF[] preTransformPoints
)
Public Function GetRectangleBoundedPostTransformSize (
    preTransformPoints As PointF()
) As SizeF

Parameters

preTransformPoints
Type: System.DrawingPointF
The set of points to be transformed.

Return Value

Type: SizeF
The rectangle-bounded size of these points after transformation.
See Also

Reference

ImmutableMatrix Structure
GetRectangleBoundedPostTransformSize Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.GetRectangleBoundedPostTransformSize Method (SizeF)

ImmutableMatrixGetRectangleBoundedPostTransformSize Method (SizeF)

Creates a new SizeF based on the transformation of the given SizeF by this Matrix. The SizeF is first converted to points. After transformation, the resulting points are then fitted with a bounding SizeF.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF GetRectangleBoundedPostTransformSize(
    SizeF pretransformSize
)
Public Function GetRectangleBoundedPostTransformSize (
    pretransformSize As SizeF
) As SizeF

Parameters

pretransformSize
Type: System.DrawingSizeF
The rectangle-bounded size of the object before transformation.

Return Value

Type: SizeF
The rectangle-bounded size of the object after transformation.
See Also

Reference

ImmutableMatrix Structure
GetRectangleBoundedPostTransformSize Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.Multiply Method

ImmutableMatrixMultiply Method

Used to find the product of two ImmutableMatricies.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImmutableMatrix Multiply(
    ImmutableMatrix o
)
Public Function Multiply (
    o As ImmutableMatrix
) As ImmutableMatrix

Parameters

o
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
The matrix to perform multiplication with.

Return Value

Type: ImmutableMatrix
A new matrix which is the result of this matix multiplied with the passed-in matrix.
Remarks
The multiplication order is (This) x (Passed-In).
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.RotationMatrix Method

ImmutableMatrixRotationMatrix Method

Returns a new instance of a rotation matrix.
Overload List
Name | Description
RotationMatrix(Single) | Returns a new instance of a rotation matrix (around 0,0)
RotationMatrix(PointF, Single) | Returns a new instance of a rotation matrix (around x,y)
RotationMatrix(Single, Single, Single) | Returns a new instance of a rotation matrix (around x,y)
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.RotationMatrix Method (Single)

ImmutableMatrixRotationMatrix Method (Single)

Returns a new instance of a rotation matrix (around 0,0)

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix RotationMatrix(
    float degrees
)
Public Shared Function RotationMatrix (
    degrees As Single
) As ImmutableMatrix

Parameters

degrees
Type: SystemSingle
The amount of rotation, in degrees.

Return Value

Type: ImmutableMatrix
A new rotation matrix
Remarks
This rotation matrix will rotate around the upper left hand corner of your image.
See Also

Reference

ImmutableMatrix Structure
RotationMatrix Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.RotationMatrix Method (PointF, Single)

ImmutableMatrixRotationMatrix Method (PointF, Single)

Returns a new instance of a rotation matrix (around x,y)

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix RotationMatrix(
    PointF point,
    float degrees
)
Public Shared Function RotationMatrix (
    point As PointF,
    degrees As Single
) As ImmutableMatrix

Parameters

point
Type: System.DrawingPointF
Point to rotate around
degrees
Type: SystemSingle
The amount of rotation, in degrees

Return Value

Type: ImmutableMatrix
A new rotation matrix
See Also

Reference

ImmutableMatrix Structure
RotationMatrix Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.RotationMatrix Method (Single, Single, Single)

ImmutableMatrixRotationMatrix Method (Single, Single, Single)

Returns a new instance of a rotation matrix (around x,y)

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix RotationMatrix(
    float x,
    float y,
    float degrees
)
Public Shared Function RotationMatrix (
    x As Single,
    y As Single,
    degrees As Single
) As ImmutableMatrix

Parameters

x
Type: SystemSingle
The X coordinate to rotate around.
y
Type: SystemSingle
The Y coordinate to rotate around.
degrees
Type: SystemSingle
The amount of rotation, in degrees.

Return Value

Type: ImmutableMatrix
A new rotation matrix.
Remarks

Remember that the upper left hand corner of your image is 0,0. So, if you want to rotate around the center of your image, X should be half of your image wifth and Y should be half of your image height. For example,

ImmutableMatrix.RotationMatrix( image.Width / 2.0, image.Height / 2.0, degrees );

See Also

Reference

ImmutableMatrix Structure
RotationMatrix Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.ScaleMatrix Method

ImmutableMatrixScaleMatrix Method

Returns a new instance of a scale matrix

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix ScaleMatrix(
    float x,
    float y
)
Public Shared Function ScaleMatrix (
    x As Single,
    y As Single
) As ImmutableMatrix

Parameters

x
Type: SystemSingle
Scaling magnitude on the X-Axis
y
Type: SystemSingle
Scaling magnitude on the Y-Axis

Return Value

Type: ImmutableMatrix
A new instance of a scale matrix.
Remarks

The X and Y values are scaling magnitudes in the X and Y direction. For example, a value of 1.0 will leave the geometry the same while a value of 1.1 will increase the scale by 10%.

See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.ShearMatrix Method

ImmutableMatrixShearMatrix Method

Returns a new instance of a shear matrix

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix ShearMatrix(
    float x,
    float y
)
Public Shared Function ShearMatrix (
    x As Single,
    y As Single
) As ImmutableMatrix

Parameters

x
Type: SystemSingle
Shear parallel to the X axis
y
Type: SystemSingle
Shear parallel to the Y axis

Return Value

Type: ImmutableMatrix
A new shear matrix
Remarks
Shearing is visually similar to slanting.
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.ToString Method

ImmutableMatrixToString Method

Returns a text description of what this ImmutableMatrix represents.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.Transform Method

ImmutableMatrixTransform Method

Transforms the geometry of the given construct based on this matrix.
Overload List
 | Name | Description
Public method | Transform(PointF) | Creates a new PointF based on the transformation of the given PointF by this Matrix.
Public method | Transform(PointF) | Creates a new set of PointFs based on the transformation of the given PointFs by this Matrix.
Top
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.Transform Method (PointF)

ImmutableMatrixTransform Method (PointF)

Creates a new PointF based on the transformation of the given PointF by this Matrix.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Transform(
    PointF p
)
Public Function Transform (
    p As PointF
) As PointF

Parameters

p
Type: System.DrawingPointF
The PointF to be transformed.

Return Value

Type: PointF
A new PointF which has had this transform applied.
Remarks
This transform is 'pure' as the transform is applied directly to the point and the result is returned.
See Also

Reference

ImmutableMatrix Structure
Transform Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.Transform Method (PointF[])

ImmutableMatrixTransform Method (PointF)

Creates a new set of PointFs based on the transformation of the given PointFs by this Matrix.

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF[] Transform(
    PointF[] pa
)
Public Function Transform (
    pa As PointF()
) As PointF()

Parameters

pa
Type: System.DrawingPointF
The set of PointFs to be transformed.

Return Value

Type: PointF
A new set of PointFs which have had this transform applied.
Remarks
This transform is 'pure' as the transform is applied directly to each point and the results are returned.
See Also

Reference

ImmutableMatrix Structure
Transform Overload
Atalasoft.FormsProcessing.Geometry Namespace


ImmutableMatrix.TranslationMatrix Method

ImmutableMatrixTranslationMatrix Method

Returns a new instance of a translation matrix

Namespace: Atalasoft.FormsProcessing.Geometry
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImmutableMatrix TranslationMatrix(
    float x,
    float y
)
Public Shared Function TranslationMatrix (
    x As Single,
    y As Single
) As ImmutableMatrix

Parameters

x
Type: SystemSingle
Translation in the X direction
y
Type: SystemSingle
Translation in the Y direction

Return Value

Type: ImmutableMatrix
A new Translation matrix.
Remarks
Translation matrices offset location by X pixels in the X direction and Y pixels in the Y direction.
See Also

Reference

ImmutableMatrix Structure
Atalasoft.FormsProcessing.Geometry Namespace


Atalasoft.FormsProcessing.Omr Namespace

Classes
 | Class | Description
Public class | OmrAlignmentException | Thrown when the OmrEngine is unable to correctly align a document to the specified template.
Public class | OmrDocument | A class which represents the aggregated results of processing a document with the OmrEngine.
Public class | OmrDocumentProgressEventArgs | This class is passed to the user when OmrEngine's DocumentProgress event is fired.
Public class | OmrEngine | The primary class interface for doing Optical Mark Recognition.
Public class | OmrException | The base class for all OmrEngine exceptions.
Public class | OmrGroup | A class which represents the results of processing a group of marks with the OmrEngine.
Public class | OmrImagePreprocessedEventArgs | This class is passed to the user when OmrEngine's ImagePreprocessed event is fired.
Public class | OmrImagePreprocessingEventArgs | This class is passed to the user when OmrEngine's ImagePreprocessing event is fired.
Public class | OmrMark | A class which represents the results of processing a single mark with the OmrEngine.
Public class | OmrMarksDetectedEventArgs | This class is passed to the user when OmrEngine's MarksDetected event is fired.
Public class | OmrMarksDetectingEventArgs | This class is passed to the user when OmrEngine's MarksDetecting event is fired.
Public class | OmrPage | A class representing the results of OMR on a single page.
Public class | OmrPageProgressEventArgs | This class is passed to the user when OmrEngine's PageProgress event is fired.
Public class | OmrTemplateAlignedEventArgs | This class is passed to the user when OmrEngine's TemplateAligned event is fired.
Public class | OmrTemplateAligningEventArgs | This class is passed to the user when OmrEngine's TemplateAligning event is fired.
Public class | OmrTemplateDocument | A Savable/Loadable collection of OmrTemplatePage instances.
Public class | OmrTemplateGroup | This class is used to describe related groups of marks.
Public class | OmrTemplateMark | This class is used to describe locations on the page where marks will be expected.
Public class | OmrTemplatePage | This class is used to describe the pages on which marks will be expected.
Interfaces
 | Interface | Description
Public interface | IOmrEngine | An interface representation of OmrEngine. This allows you to test your implementation without an actual OmrEngine instance.
Enumerations
 | Enumeration | Description
Public enumeration | OmrDocumentStage | The current stage in OMR document-wide processing.
Public enumeration | OmrPageStage | The current stage in OMR page-wide processing.


IOmrEngine Interface

An interface representation of OmrEngine. This allows you to test your implementation without an actual OmrEngine instance.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IOmrEngine
Public Interface IOmrEngine

The IOmrEngine type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentConfidenceThreshold | AlignmentConfidenceThreshold
Public property | MarkConfidenceThreshold | MarkConfidenceThreshold
Top
Methods
 | Name | Description
Public method | RecognizeDocument | RecognizeDocument(ImageSource, OmrTemplateDocument)
Public method | RecognizePage | RecognizePage(AtalaImage, OmrTemplatePage)
Top
Events
 | Name | Description
Public event | DocumentProgress | DocumentProgress
Public event | ImagePreprocessed | ImagePreprocessed
Public event | ImagePreprocessing | ImagePreprocessing
Public event | MarksDetected | MarksDetected
Public event | MarksDetecting | MarksDetecting
Public event | PageProgress | PageProgress
Public event | TemplateAligned | TemplateAligned
Public event | TemplateAligning | TemplateAligning
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine Properties

The IOmrEngine type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentConfidenceThreshold | AlignmentConfidenceThreshold
Public property | MarkConfidenceThreshold | MarkConfidenceThreshold
Top
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.AlignmentConfidenceThreshold Property

IOmrEngineAlignmentConfidenceThreshold Property

AlignmentConfidenceThreshold

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float AlignmentConfidenceThreshold { get; set; }
Property AlignmentConfidenceThreshold As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.MarkConfidenceThreshold Property

IOmrEngineMarkConfidenceThreshold Property

MarkConfidenceThreshold

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float MarkConfidenceThreshold { get; set; }
Property MarkConfidenceThreshold As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine Methods

The IOmrEngine type exposes the following members.

Methods
 | Name | Description
Public method | RecognizeDocument | RecognizeDocument(ImageSource, OmrTemplateDocument)
Public method | RecognizePage | RecognizePage(AtalaImage, OmrTemplatePage)
Top
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.RecognizeDocument Method

IOmrEngineRecognizeDocument Method

RecognizeDocument(ImageSource, OmrTemplateDocument)

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OmrDocument RecognizeDocument(
    ImageSource source,
    OmrTemplateDocument template
)
Function RecognizeDocument (
    source As ImageSource,
    template As OmrTemplateDocument
) As OmrDocument

Parameters

source
Type: Atalasoft.ImagingImageSource
template
Type: Atalasoft.FormsProcessing.OmrOmrTemplateDocument

Return Value

Type: OmrDocument
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.RecognizePage Method

IOmrEngineRecognizePage Method

RecognizePage(AtalaImage, OmrTemplatePage)

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OmrPage RecognizePage(
    AtalaImage sourceImage,
    OmrTemplatePage template
)
Function RecognizePage (
    sourceImage As AtalaImage,
    template As OmrTemplatePage
) As OmrPage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
template
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage

Return Value

Type: OmrPage
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine Events

The IOmrEngine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | DocumentProgress
Public event | ImagePreprocessed | ImagePreprocessed
Public event | ImagePreprocessing | ImagePreprocessing
Public event | MarksDetected | MarksDetected
Public event | MarksDetecting | MarksDetecting
Public event | PageProgress | PageProgress
Public event | TemplateAligned | TemplateAligned
Public event | TemplateAligning | TemplateAligning
Top
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.DocumentProgress Event

IOmrEngineDocumentProgress Event

DocumentProgress

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrDocumentProgressEventArgs> DocumentProgress
Event DocumentProgress As EventHandler(Of OmrDocumentProgressEventArgs)

Value

Type: SystemEventHandlerOmrDocumentProgressEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.ImagePreprocessed Event

IOmrEngineImagePreprocessed Event

ImagePreprocessed

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrImagePreprocessedEventArgs> ImagePreprocessed
Event ImagePreprocessed As EventHandler(Of OmrImagePreprocessedEventArgs)

Value

Type: SystemEventHandlerOmrImagePreprocessedEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.ImagePreprocessing Event

IOmrEngineImagePreprocessing Event

ImagePreprocessing

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrImagePreprocessingEventArgs> ImagePreprocessing
Event ImagePreprocessing As EventHandler(Of OmrImagePreprocessingEventArgs)

Value

Type: SystemEventHandlerOmrImagePreprocessingEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.MarksDetected Event

IOmrEngineMarksDetected Event

MarksDetected

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrMarksDetectedEventArgs> MarksDetected
Event MarksDetected As EventHandler(Of OmrMarksDetectedEventArgs)

Value

Type: SystemEventHandlerOmrMarksDetectedEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.MarksDetecting Event

IOmrEngineMarksDetecting Event

MarksDetecting

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrMarksDetectingEventArgs> MarksDetecting
Event MarksDetecting As EventHandler(Of OmrMarksDetectingEventArgs)

Value

Type: SystemEventHandlerOmrMarksDetectingEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.PageProgress Event

IOmrEnginePageProgress Event

PageProgress

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrPageProgressEventArgs> PageProgress
Event PageProgress As EventHandler(Of OmrPageProgressEventArgs)

Value

Type: SystemEventHandlerOmrPageProgressEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.TemplateAligned Event

IOmrEngineTemplateAligned Event

TemplateAligned

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrTemplateAlignedEventArgs> TemplateAligned
Event TemplateAligned As EventHandler(Of OmrTemplateAlignedEventArgs)

Value

Type: SystemEventHandlerOmrTemplateAlignedEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


IOmrEngine.TemplateAligning Event

IOmrEngineTemplateAligning Event

TemplateAligning

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
event EventHandler<OmrTemplateAligningEventArgs> TemplateAligning
Event TemplateAligning As EventHandler(Of OmrTemplateAligningEventArgs)

Value

Type: SystemEventHandlerOmrTemplateAligningEventArgs
See Also

Reference

IOmrEngine Interface
Atalasoft.FormsProcessing.Omr Namespace


OmrAlignmentException Class

Thrown when the OmrEngine is unable to correctly align a document to the specified template.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.FormsProcessingFormsProcessingException
Atalasoft.FormsProcessing.OmrOmrException
Atalasoft.FormsProcessing.OmrOmrAlignmentException

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrAlignmentException : OmrException
Public Class OmrAlignmentException
    Inherits OmrException

The OmrAlignmentException type exposes the following members.

Constructors
 | Name | Description
Public method | OmrAlignmentException | Creates a new OmrAlignmentException with the specified message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrAlignmentException Constructor

Creates a new OmrAlignmentException with the specified message.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrAlignmentException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

OmrAlignmentException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrAlignmentException Properties

The OmrAlignmentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OmrAlignmentException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrAlignmentException Methods

The OmrAlignmentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OmrAlignmentException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrAlignmentException Events

The OmrAlignmentException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OmrAlignmentException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument Class

A class which represents the aggregated results of processing a document with the OmrEngine.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrDocument

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrDocument
<SerializableAttribute>
Public Class OmrDocument

The OmrDocument type exposes the following members.

Properties
 | Name | Description
Public property | Pages | The resulting Pages of the document, in order.
Public property | Template | The OmrTemplateDocument used when performing OMR on this document.
Top
Methods
 | Name | Description
Public method | DrawFoundMarksOntoPage(Int32, Color, AtalaImage) | Draws the marks from a page onto a provided image
Public method | DrawFoundMarksOntoPage(Int32, Color, AtalaImage, Double) | Draws the marks from a page onto a provided image
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrDocument Properties

The OmrDocument type exposes the following members.

Properties
 | Name | Description
Public property | Pages | The resulting Pages of the document, in order.
Public property | Template | The OmrTemplateDocument used when performing OMR on this document.
Top
See Also

Reference

OmrDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument.Pages Property

OmrDocumentPages Property

The resulting Pages of the document, in order.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOnlyCollection<OmrPage> Pages { get; }
Public ReadOnly Property Pages As ReadOnlyCollection(Of OmrPage)
    Get

Property Value

Type: ReadOnlyCollectionOmrPage
See Also

Reference

OmrDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument.Template Property

OmrDocumentTemplate Property

The OmrTemplateDocument used when performing OMR on this document.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateDocument Template { get; }
Public ReadOnly Property Template As OmrTemplateDocument
    Get

Property Value

Type: OmrTemplateDocument
See Also

Reference

OmrDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument Methods

The OmrDocument type exposes the following members.

Methods
 | Name | Description
Public method | DrawFoundMarksOntoPage(Int32, Color, AtalaImage) | Draws the marks from a page onto a provided image
Public method | DrawFoundMarksOntoPage(Int32, Color, AtalaImage, Double) | Draws the marks from a page onto a provided image
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument.DrawFoundMarksOntoPage Method

OmrDocumentDrawFoundMarksOntoPage Method

Overload List
 | Name | Description
Public method | DrawFoundMarksOntoPage(Int32, Color, AtalaImage) | Draws the marks from a page onto a provided image
Public method | DrawFoundMarksOntoPage(Int32, Color, AtalaImage, Double) | Draws the marks from a page onto a provided image
Top
See Also

Reference

OmrDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument.DrawFoundMarksOntoPage Method (Int32, Color, AtalaImage)

OmrDocumentDrawFoundMarksOntoPage Method (Int32, Color, AtalaImage)

Draws the marks from a page onto a provided image

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawFoundMarksOntoPage(
    int page,
    Color c,
    AtalaImage sourceImage
)
Public Function DrawFoundMarksOntoPage (
    page As Integer,
    c As Color,
    sourceImage As AtalaImage
) As AtalaImage

Parameters

page
Type: SystemInt32
The page number of the document
c
Type: System.DrawingColor
The color to draw the marks
sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to draw them on, the return is a clone of this image

Return Value

Type: AtalaImage
A clone of the sourceImage with marks from the page drawn on it
See Also

Reference

OmrDocument Class
DrawFoundMarksOntoPage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrDocument.DrawFoundMarksOntoPage Method (Int32, Color, AtalaImage, Double)

OmrDocumentDrawFoundMarksOntoPage Method (Int32, Color, AtalaImage, Double)

Draws the marks from a page onto a provided image

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawFoundMarksOntoPage(
    int page,
    Color c,
    AtalaImage sourceImage,
    double probability
)
Public Function DrawFoundMarksOntoPage (
    page As Integer,
    c As Color,
    sourceImage As AtalaImage,
    probability As Double
) As AtalaImage

Parameters

page
Type: SystemInt32
The page number of the document
c
Type: System.DrawingColor
The color to draw the marks
sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to draw them on, the return is a clone of this image
probability
Type: SystemDouble
The minimum probability a found mark must have to be drawn

Return Value

Type: AtalaImage
A clone of the sourceImage with marks from the page drawn on it
See Also

Reference

OmrDocument Class
DrawFoundMarksOntoPage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs Class

This class is passed to the user when OmrEngine's DocumentProgress event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
Atalasoft.FormsProcessing.OmrOmrDocumentProgressEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrDocumentProgressEventArgs : CancelEventArgs
Public Class OmrDocumentProgressEventArgs
    Inherits CancelEventArgs

The OmrDocumentProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrDocumentProgressEventArgs | Creates a new OmrDocumentProgressEventArgs instance with the following Stage, CurrentPage and TotalPages values.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CurrentPage | The current page being processed, counting from 0.
Public property | Progress | A number between 0 and 100 which represents the progress done in document processing. This will be null if the ImageSource provided does not report the total number of pages.
Public property | ProgressIsValid | True if the progress reported by this event is valid. False if it is not.
Public property | Stage | The current stage in OMR document-wide processing.
Public property | TotalPages | The total number of pages being processed. This will be null if the ImageSource provided does not report the total number of pages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs Constructor

Creates a new OmrDocumentProgressEventArgs instance with the following Stage, CurrentPage and TotalPages values.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrDocumentProgressEventArgs(
    OmrDocumentStage stage,
    int currentPage,
    Nullable<int> totalPages
)
Public Sub New (
    stage As OmrDocumentStage,
    currentPage As Integer,
    totalPages As Nullable(Of Integer)
)

Parameters

stage
Type: Atalasoft.FormsProcessing.OmrOmrDocumentStage
The stage shown in the Stage property.
currentPage
Type: SystemInt32
The currentPage shown in the CurrentPage property.
totalPages
Type: SystemNullableInt32
The TotalPages shown in the TotalPages property. If null, ProgressIsValid will be false and Progress will be null.
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs Properties

The OmrDocumentProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CurrentPage | The current page being processed, counting from 0.
Public property | Progress | A number between 0 and 100 which represents the progress done in document processing. This will be null if the ImageSource provided does not report the total number of pages.
Public property | ProgressIsValid | True if the progress reported by this event is valid. False if it is not.
Public property | Stage | The current stage in OMR document-wide processing.
Public property | TotalPages | The total number of pages being processed. This will be null if the ImageSource provided does not report the total number of pages.
Top
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs.CurrentPage Property

OmrDocumentProgressEventArgsCurrentPage Property

The current page being processed, counting from 0.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentPage { get; }
Public ReadOnly Property CurrentPage As Integer
    Get

Property Value

Type: Int32
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs.Progress Property

OmrDocumentProgressEventArgsProgress Property

A number between 0 and 100 which represents the progress done in document processing. This will be null if the ImageSource provided does not report the total number of pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<int> Progress { get; }
Public ReadOnly Property Progress As Nullable(Of Integer)
    Get

Property Value

Type: NullableInt32
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs.ProgressIsValid Property

OmrDocumentProgressEventArgsProgressIsValid Property

True if the progress reported by this event is valid. False if it is not.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ProgressIsValid { get; }
Public ReadOnly Property ProgressIsValid As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs.Stage Property

OmrDocumentProgressEventArgsStage Property

The current stage in OMR document-wide processing.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrDocumentStage Stage { get; }
Public ReadOnly Property Stage As OmrDocumentStage
    Get

Property Value

Type: OmrDocumentStage
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs.TotalPages Property

OmrDocumentProgressEventArgsTotalPages Property

The total number of pages being processed. This will be null if the ImageSource provided does not report the total number of pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<int> TotalPages { get; }
Public ReadOnly Property TotalPages As Nullable(Of Integer)
    Get

Property Value

Type: NullableInt32
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentProgressEventArgs Methods

The OmrDocumentProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrDocumentProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrDocumentStage Enumeration

The current stage in OMR document-wide processing.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OmrDocumentStage
Public Enumeration OmrDocumentStage
Members
Member name | Description
BeginDocument | Beginning document-wide OMR.
BeginPage | Beginning page-wide OMR.
EndPage | Ending page-wide OMR.
EndDocument | Ending document-wide OMR.
Remarks
Used by the DocumentProgress.
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace
OmrDocumentProgressEventArgs Class
DocumentProgress Event


OmrEngine Class

The primary class interface for doing Optical Mark Recognition.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrEngine

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrEngine : IOmrEngine
Public Class OmrEngine
    Implements IOmrEngine

The OmrEngine type exposes the following members.

Constructors
 | Name | Description
Public method | OmrEngine | Creates a new instance of OmrEngine with the default property values.
Top
Properties
 | Name | Description
Public property | AlignmentConfidenceThreshold | The threshold at which document alignment will be considered accessable. This is compared against the results of every alignment rejection heuristic. (Should be between 0 and 1)
Public property | MarkConfidenceThreshold | The threshold at which mark templates will be considered marked. (Should be between 0 and 1)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RecognizeDocument | Performs document-wide Optical Mark Recognition.
Public method | RecognizePage | Performs page-wide Optical Mark Recognition.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is fired at each stage of document processing. It is used for progress and allows the processing to be canceled. This event is only invoked when RecognizeDocument is called with an ImageSource and a OmrTemplateDocument.
Public event | ImagePreprocessed | This event is fired when page and template preprocessing has been completed.
Public event | ImagePreprocessing | This event is fired before page and template preprocessing begins.
Public event | MarksDetected | This event is fired when page-wide mark detection has been completed.
Public event | MarksDetecting | This event is fired when page-wide mark detection begins.
Public event | PageProgress | This event is fired at each stage of page processing. It is used for progress and allows the prcoessing to be canceled.
Public event | TemplateAligned | This event is fired when template to page alignment has been completed.
Public event | TemplateAligning | This event is fired before template to page alignment begins.
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrEngine Constructor

Creates a new instance of OmrEngine with the default property values.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrEngine()
Public Sub New
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine Properties

The OmrEngine type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentConfidenceThreshold | The threshold at which document alignment will be considered accessable. This is compared against the results of every alignment rejection heuristic. (Should be between 0 and 1)
Public property | MarkConfidenceThreshold | The threshold at which mark templates will be considered marked. (Should be between 0 and 1)
Top
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.AlignmentConfidenceThreshold Property

OmrEngineAlignmentConfidenceThreshold Property

The threshold at which document alignment will be considered accessable. This is compared against the results of every alignment rejection heuristic. (Should be between 0 and 1)

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float AlignmentConfidenceThreshold { get; set; }
Public Property AlignmentConfidenceThreshold As Single
    Get
    Set

Property Value

Type: Single

Implements

IOmrEngineAlignmentConfidenceThreshold
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.MarkConfidenceThreshold Property

OmrEngineMarkConfidenceThreshold Property

The threshold at which mark templates will be considered marked. (Should be between 0 and 1)

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float MarkConfidenceThreshold { get; set; }
Public Property MarkConfidenceThreshold As Single
    Get
    Set

Property Value

Type: Single

Implements

IOmrEngineMarkConfidenceThreshold
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine Methods

The OmrEngine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RecognizeDocument | Performs document-wide Optical Mark Recognition.
Public method | RecognizePage | Performs page-wide Optical Mark Recognition.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.RecognizeDocument Method

OmrEngineRecognizeDocument Method

Performs document-wide Optical Mark Recognition.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrDocument RecognizeDocument(
    ImageSource imageSource,
    OmrTemplateDocument template
)
Public Function RecognizeDocument (
    imageSource As ImageSource,
    template As OmrTemplateDocument
) As OmrDocument

Parameters

imageSource
Type: Atalasoft.ImagingImageSource
An ImageSource containing the marked pages of the to-be-recognized document.
template
Type: Atalasoft.FormsProcessing.OmrOmrTemplateDocument
A template which specifies the marks to be found.

Return Value

Type: OmrDocument
The results of mark detection.

Implements

IOmrEngineRecognizeDocument(ImageSource, OmrTemplateDocument)
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.RecognizePage Method

OmrEngineRecognizePage Method

Performs page-wide Optical Mark Recognition.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrPage RecognizePage(
    AtalaImage omrImage,
    OmrTemplatePage templatePage
)
Public Function RecognizePage (
    omrImage As AtalaImage,
    templatePage As OmrTemplatePage
) As OmrPage

Parameters

omrImage
Type: Atalasoft.ImagingAtalaImage
An image containing the marked document
templatePage
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage
A template which specifies the marks to be found.

Return Value

Type: OmrPage
The results of mark detection.

Implements

IOmrEngineRecognizePage(AtalaImage, OmrTemplatePage)
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine Events

The OmrEngine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is fired at each stage of document processing. It is used for progress and allows the processing to be canceled. This event is only invoked when RecognizeDocument is called with an ImageSource and a OmrTemplateDocument.
Public event | ImagePreprocessed | This event is fired when page and template preprocessing has been completed.
Public event | ImagePreprocessing | This event is fired before page and template preprocessing begins.
Public event | MarksDetected | This event is fired when page-wide mark detection has been completed.
Public event | MarksDetecting | This event is fired when page-wide mark detection begins.
Public event | PageProgress | This event is fired at each stage of page processing. It is used for progress and allows the prcoessing to be canceled.
Public event | TemplateAligned | This event is fired when template to page alignment has been completed.
Public event | TemplateAligning | This event is fired before template to page alignment begins.
Top
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.DocumentProgress Event

OmrEngineDocumentProgress Event

This event is fired at each stage of document processing. It is used for progress and allows the processing to be canceled. This event is only invoked when RecognizeDocument is called with an ImageSource and a OmrTemplateDocument.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrDocumentProgressEventArgs> DocumentProgress
Public Event DocumentProgress As EventHandler(Of OmrDocumentProgressEventArgs)

Value

Type: SystemEventHandlerOmrDocumentProgressEventArgs

Implements

IOmrEngineDocumentProgress
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.ImagePreprocessed Event

OmrEngineImagePreprocessed Event

This event is fired when page and template preprocessing has been completed.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrImagePreprocessedEventArgs> ImagePreprocessed
Public Event ImagePreprocessed As EventHandler(Of OmrImagePreprocessedEventArgs)

Value

Type: SystemEventHandlerOmrImagePreprocessedEventArgs

Implements

IOmrEngineImagePreprocessed
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.ImagePreprocessing Event

OmrEngineImagePreprocessing Event

This event is fired before page and template preprocessing begins.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrImagePreprocessingEventArgs> ImagePreprocessing
Public Event ImagePreprocessing As EventHandler(Of OmrImagePreprocessingEventArgs)

Value

Type: SystemEventHandlerOmrImagePreprocessingEventArgs

Implements

IOmrEngineImagePreprocessing
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.MarksDetected Event

OmrEngineMarksDetected Event

This event is fired when page-wide mark detection has been completed.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrMarksDetectedEventArgs> MarksDetected
Public Event MarksDetected As EventHandler(Of OmrMarksDetectedEventArgs)

Value

Type: SystemEventHandlerOmrMarksDetectedEventArgs

Implements

IOmrEngineMarksDetected
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.MarksDetecting Event

OmrEngineMarksDetecting Event

This event is fired when page-wide mark detection begins.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrMarksDetectingEventArgs> MarksDetecting
Public Event MarksDetecting As EventHandler(Of OmrMarksDetectingEventArgs)

Value

Type: SystemEventHandlerOmrMarksDetectingEventArgs

Implements

IOmrEngineMarksDetecting
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.PageProgress Event

OmrEnginePageProgress Event

This event is fired at each stage of page processing. It is used for progress and allows the prcoessing to be canceled.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrPageProgressEventArgs> PageProgress
Public Event PageProgress As EventHandler(Of OmrPageProgressEventArgs)

Value

Type: SystemEventHandlerOmrPageProgressEventArgs

Implements

IOmrEnginePageProgress
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.TemplateAligned Event

OmrEngineTemplateAligned Event

This event is fired when template to page alignment has been completed.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrTemplateAlignedEventArgs> TemplateAligned
Public Event TemplateAligned As EventHandler(Of OmrTemplateAlignedEventArgs)

Value

Type: SystemEventHandlerOmrTemplateAlignedEventArgs

Implements

IOmrEngineTemplateAligned
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrEngine.TemplateAligning Event

OmrEngineTemplateAligning Event

This event is fired before template to page alignment begins.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<OmrTemplateAligningEventArgs> TemplateAligning
Public Event TemplateAligning As EventHandler(Of OmrTemplateAligningEventArgs)

Value

Type: SystemEventHandlerOmrTemplateAligningEventArgs

Implements

IOmrEngineTemplateAligning
See Also

Reference

OmrEngine Class
Atalasoft.FormsProcessing.Omr Namespace


OmrException Class

The base class for all OmrEngine exceptions.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.FormsProcessingFormsProcessingException
Atalasoft.FormsProcessing.OmrOmrException
Atalasoft.FormsProcessing.OmrOmrAlignmentException

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrException : FormsProcessingException
Public Class OmrException
    Inherits FormsProcessingException

The OmrException type exposes the following members.

Constructors
 | Name | Description
Public method | OmrException | Creates a new OmrException with the specified message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrException Constructor

Creates a new OmrException with the specified message.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

OmrException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrException Properties

The OmrException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OmrException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrException Methods

The OmrException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OmrException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrException Events

The OmrException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OmrException Class
Atalasoft.FormsProcessing.Omr Namespace


OmrGroup Class

A class which represents the results of processing a group of marks with the OmrEngine.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrGroup

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrGroup
<SerializableAttribute>
Public Class OmrGroup

The OmrGroup type exposes the following members.

Properties
 | Name | Description
Public property | Image | The bounding window of this group of marks.
Public property | Marks | The collection of marks contained within this group.
Public property | Template | The template used to find this group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrGroup Properties

The OmrGroup type exposes the following members.

Properties
 | Name | Description
Public property | Image | The bounding window of this group of marks.
Public property | Marks | The collection of marks contained within this group.
Public property | Template | The template used to find this group.
Top
See Also

Reference

OmrGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrGroup.Image Property

OmrGroupImage Property

The bounding window of this group of marks.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow Image { get; }
Public ReadOnly Property Image As AtalaImageWindow
    Get

Property Value

Type: AtalaImageWindow
See Also

Reference

OmrGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrGroup.Marks Property

OmrGroupMarks Property

The collection of marks contained within this group.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOnlyCollection<OmrMark> Marks { get; }
Public ReadOnly Property Marks As ReadOnlyCollection(Of OmrMark)
    Get

Property Value

Type: ReadOnlyCollectionOmrMark
See Also

Reference

OmrGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrGroup.Template Property

OmrGroupTemplate Property

The template used to find this group.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateGroup Template { get; }
Public ReadOnly Property Template As OmrTemplateGroup
    Get

Property Value

Type: OmrTemplateGroup
See Also

Reference

OmrGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrGroup Methods

The OmrGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs Class

This class is passed to the user when OmrEngine's ImagePreprocessed event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.OmrOmrImagePreprocessedEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrImagePreprocessedEventArgs : EventArgs
Public Class OmrImagePreprocessedEventArgs
    Inherits EventArgs

The OmrImagePreprocessedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrImagePreprocessedEventArgs | Creates a new instance of OmrImagePreprocessedEventArgs.
Top
Properties
 | Name | Description
Public property | OutMarkedImage | Obsolete. The final marked image result which will be used in all proceeding steps
Public property | OutMarkedImageForAlignment | The final marked image result to be used as source in the alignment step
Public property | OutMarkedImageForMarkExtraction | The final marked image result to be used as source in the mark extraction step
Public property | OutTemplateImage | The final template image result which will be used in all proceeding steps
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs Constructor

Creates a new instance of OmrImagePreprocessedEventArgs.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrImagePreprocessedEventArgs(
    AtalaImage outMarkedImageForAlignment,
    AtalaImage outMarkedImageForMarkExtraction,
    AtalaImage outTemplateImage
)
Public Sub New (
    outMarkedImageForAlignment As AtalaImage,
    outMarkedImageForMarkExtraction As AtalaImage,
    outTemplateImage As AtalaImage
)

Parameters

outMarkedImageForAlignment
Type: Atalasoft.ImagingAtalaImage
The image shown in the outMarkedImageForAlignment property.
outMarkedImageForMarkExtraction
Type: Atalasoft.ImagingAtalaImage
The image shown in the outMarkedImageForMarkExtraction property.
outTemplateImage
Type: Atalasoft.ImagingAtalaImage
The image shown in the OutTemplateImage property.
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs Properties

The OmrImagePreprocessedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutMarkedImage | Obsolete. The final marked image result which will be used in all proceeding steps
Public property | OutMarkedImageForAlignment | The final marked image result to be used as source in the alignment step
Public property | OutMarkedImageForMarkExtraction | The final marked image result to be used as source in the mark extraction step
Public property | OutTemplateImage | The final template image result which will be used in all proceeding steps
Top
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs.OutMarkedImage Property

OmrImagePreprocessedEventArgsOutMarkedImage Property

Note: This API is now obsolete.

The final marked image result which will be used in all proceeding steps

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use OutMarkedImageForAlignment and/or OutMarkedImageForMarkExtraction instead.",
    true)]
public AtalaImage OutMarkedImage { get; set; }
<ObsoleteAttribute("Please use OutMarkedImageForAlignment and/or OutMarkedImageForMarkExtraction instead.",
    true)>
Public Property OutMarkedImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs.OutMarkedImageForAlignment Property

OmrImagePreprocessedEventArgsOutMarkedImageForAlignment Property

The final marked image result to be used as source in the alignment step

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OutMarkedImageForAlignment { get; set; }
Public Property OutMarkedImageForAlignment As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs.OutMarkedImageForMarkExtraction Property

OmrImagePreprocessedEventArgsOutMarkedImageForMarkExtraction Property

The final marked image result to be used as source in the mark extraction step

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OutMarkedImageForMarkExtraction { get; set; }
Public Property OutMarkedImageForMarkExtraction As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs.OutTemplateImage Property

OmrImagePreprocessedEventArgsOutTemplateImage Property

The final template image result which will be used in all proceeding steps

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OutTemplateImage { get; set; }
Public Property OutTemplateImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessedEventArgs Methods

The OmrImagePreprocessedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrImagePreprocessedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs Class

This class is passed to the user when OmrEngine's ImagePreprocessing event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.OmrOmrImagePreprocessingEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrImagePreprocessingEventArgs : EventArgs
Public Class OmrImagePreprocessingEventArgs
    Inherits EventArgs

The OmrImagePreprocessingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrImagePreprocessingEventArgs | Creates a new instance of OmrImagePreprocessingEventArgs.
Top
Properties
 | Name | Description
Public property | InMarkedImage | The initially passed-in marked image. The image in this value will be preprocessed as long as OutMarkedImage is not set.
Public property | InTemplateImage | The initially passed-in template image. The image in this value will be preprocessed as long as OutTemplateImage is not set.
Public property | OutMarkedImage | Obsolete. If set, page preprocessing is skipped and this image is used instead.
Public property | OutMarkedImageForAlignment | If set, page preprocessing for alignment is skipped and this image is used instead.
Public property | OutMarkedImageForMarkExtraction | If set, page preprocessing for mark detection is skipped and this image is used instead.
Public property | OutTemplateImage | If set, template preprocessing is skipped and this image is used instead. If this has a value when the event fires, it's the template's cache.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs Constructor

Creates a new instance of OmrImagePreprocessingEventArgs.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrImagePreprocessingEventArgs(
    AtalaImage inMarkedImage,
    AtalaImage inTemplateImage
)
Public Sub New (
    inMarkedImage As AtalaImage,
    inTemplateImage As AtalaImage
)

Parameters

inMarkedImage
Type: Atalasoft.ImagingAtalaImage
The image shown in the InMarkedImage property.
inTemplateImage
Type: Atalasoft.ImagingAtalaImage
The image shown in the InTemplateImage property.
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs Properties

The OmrImagePreprocessingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | InMarkedImage | The initially passed-in marked image. The image in this value will be preprocessed as long as OutMarkedImage is not set.
Public property | InTemplateImage | The initially passed-in template image. The image in this value will be preprocessed as long as OutTemplateImage is not set.
Public property | OutMarkedImage | Obsolete. If set, page preprocessing is skipped and this image is used instead.
Public property | OutMarkedImageForAlignment | If set, page preprocessing for alignment is skipped and this image is used instead.
Public property | OutMarkedImageForMarkExtraction | If set, page preprocessing for mark detection is skipped and this image is used instead.
Public property | OutTemplateImage | If set, template preprocessing is skipped and this image is used instead. If this has a value when the event fires, it's the template's cache.
Top
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs.InMarkedImage Property

OmrImagePreprocessingEventArgsInMarkedImage Property

The initially passed-in marked image. The image in this value will be preprocessed as long as OutMarkedImage is not set.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage InMarkedImage { get; set; }
Public Property InMarkedImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs.InTemplateImage Property

OmrImagePreprocessingEventArgsInTemplateImage Property

The initially passed-in template image. The image in this value will be preprocessed as long as OutTemplateImage is not set.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage InTemplateImage { get; set; }
Public Property InTemplateImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs.OutMarkedImage Property

OmrImagePreprocessingEventArgsOutMarkedImage Property

Note: This API is now obsolete.

If set, page preprocessing is skipped and this image is used instead.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use OutMarkedImageForAlignment and/or OutMarkedImageForMarkExtraction instead.")]
public AtalaImage OutMarkedImage { get; set; }
<ObsoleteAttribute("Please use OutMarkedImageForAlignment and/or OutMarkedImageForMarkExtraction instead.")>
Public Property OutMarkedImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs.OutMarkedImageForAlignment Property

OmrImagePreprocessingEventArgsOutMarkedImageForAlignment Property

If set, page preprocessing for alignment is skipped and this image is used instead.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OutMarkedImageForAlignment { get; set; }
Public Property OutMarkedImageForAlignment As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs.OutMarkedImageForMarkExtraction Property

OmrImagePreprocessingEventArgsOutMarkedImageForMarkExtraction Property

If set, page preprocessing for mark detection is skipped and this image is used instead.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OutMarkedImageForMarkExtraction { get; set; }
Public Property OutMarkedImageForMarkExtraction As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs.OutTemplateImage Property

OmrImagePreprocessingEventArgsOutTemplateImage Property

If set, template preprocessing is skipped and this image is used instead. If this has a value when the event fires, it's the template's cache.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OutTemplateImage { get; set; }
Public Property OutTemplateImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrImagePreprocessingEventArgs Methods

The OmrImagePreprocessingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrImagePreprocessingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMark Class

A class which represents the results of processing a single mark with the OmrEngine.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrMark

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrMark
<SerializableAttribute>
Public Class OmrMark

The OmrMark type exposes the following members.

Properties
 | Name | Description
Public property | Image | The bounding image window of this mark.
Public property | IsMarked | True if this should be considered marked, false if not.
Public property | Probability | The likelyhood of this being marked.
Public property | Template | The template instance used to detect this mark.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrMark Properties

The OmrMark type exposes the following members.

Properties
 | Name | Description
Public property | Image | The bounding image window of this mark.
Public property | IsMarked | True if this should be considered marked, false if not.
Public property | Probability | The likelyhood of this being marked.
Public property | Template | The template instance used to detect this mark.
Top
See Also

Reference

OmrMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMark.Image Property

OmrMarkImage Property

The bounding image window of this mark.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow Image { get; }
Public ReadOnly Property Image As AtalaImageWindow
    Get

Property Value

Type: AtalaImageWindow
See Also

Reference

OmrMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMark.IsMarked Property

OmrMarkIsMarked Property

True if this should be considered marked, false if not.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMarked { get; }
Public ReadOnly Property IsMarked As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

OmrMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMark.Probability Property

OmrMarkProbability Property

The likelyhood of this being marked.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Probability { get; }
Public ReadOnly Property Probability As Double
    Get

Property Value

Type: Double
See Also

Reference

OmrMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMark.Template Property

OmrMarkTemplate Property

The template instance used to detect this mark.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateMark Template { get; }
Public ReadOnly Property Template As OmrTemplateMark
    Get

Property Value

Type: OmrTemplateMark
See Also

Reference

OmrMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMark Methods

The OmrMark type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs Class

This class is passed to the user when OmrEngine's MarksDetected event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.OmrOmrMarksDetectedEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrMarksDetectedEventArgs : EventArgs
Public Class OmrMarksDetectedEventArgs
    Inherits EventArgs

The OmrMarksDetectedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrMarksDetectedEventArgs | Creates a new instance of OmrMarksDetectedEventArgs.
Top
Properties
 | Name | Description
Public property | MarkedImageWindow | An aligned version of the marked image.
Public property | Marks | The results of mark detection.
Public property | Template | The template used for mark detection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs Constructor

Creates a new instance of OmrMarksDetectedEventArgs.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrMarksDetectedEventArgs(
    AtalaImageWindow markedImageWindow,
    OmrTemplatePage template,
    OmrPage marks
)
Public Sub New (
    markedImageWindow As AtalaImageWindow,
    template As OmrTemplatePage,
    marks As OmrPage
)

Parameters

markedImageWindow
Type: Atalasoft.FormsProcessing.GeometryAtalaImageWindow
The object shown in the MarkedImageWindow property.
template
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage
The object shown in the Template property.
marks
Type: Atalasoft.FormsProcessing.OmrOmrPage
The object shown in the Marks property.
See Also

Reference

OmrMarksDetectedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs Properties

The OmrMarksDetectedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MarkedImageWindow | An aligned version of the marked image.
Public property | Marks | The results of mark detection.
Public property | Template | The template used for mark detection.
Top
See Also

Reference

OmrMarksDetectedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs.MarkedImageWindow Property

OmrMarksDetectedEventArgsMarkedImageWindow Property

An aligned version of the marked image.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow MarkedImageWindow { get; }
Public ReadOnly Property MarkedImageWindow As AtalaImageWindow
    Get

Property Value

Type: AtalaImageWindow
See Also

Reference

OmrMarksDetectedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs.Marks Property

OmrMarksDetectedEventArgsMarks Property

The results of mark detection.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrPage Marks { get; set; }
Public Property Marks As OmrPage
    Get
    Set

Property Value

Type: OmrPage
See Also

Reference

OmrMarksDetectedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs.Template Property

OmrMarksDetectedEventArgsTemplate Property

The template used for mark detection.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage Template { get; }
Public ReadOnly Property Template As OmrTemplatePage
    Get

Property Value

Type: OmrTemplatePage
See Also

Reference

OmrMarksDetectedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectedEventArgs Methods

The OmrMarksDetectedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrMarksDetectedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectingEventArgs Class

This class is passed to the user when OmrEngine's MarksDetecting event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.OmrOmrMarksDetectingEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrMarksDetectingEventArgs : EventArgs
Public Class OmrMarksDetectingEventArgs
    Inherits EventArgs

The OmrMarksDetectingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrMarksDetectingEventArgs | Creates a new instance of OmrMarksDetectingEventArgs.
Top
Properties
 | Name | Description
Public property | MarkedImageWindow | An aligned version of the marked image.
Public property | Template | The template containing the marks to be detected.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectingEventArgs Constructor

Creates a new instance of OmrMarksDetectingEventArgs.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrMarksDetectingEventArgs(
    AtalaImageWindow markedImageWindow,
    OmrTemplatePage template
)
Public Sub New (
    markedImageWindow As AtalaImageWindow,
    template As OmrTemplatePage
)

Parameters

markedImageWindow
Type: Atalasoft.FormsProcessing.GeometryAtalaImageWindow
The object shown in the MarkedImageWindow property.
template
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage
The object shown in the Template property.
See Also

Reference

OmrMarksDetectingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectingEventArgs Properties

The OmrMarksDetectingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MarkedImageWindow | An aligned version of the marked image.
Public property | Template | The template containing the marks to be detected.
Top
See Also

Reference

OmrMarksDetectingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectingEventArgs.MarkedImageWindow Property

OmrMarksDetectingEventArgsMarkedImageWindow Property

An aligned version of the marked image.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow MarkedImageWindow { get; set; }
Public Property MarkedImageWindow As AtalaImageWindow
    Get
    Set

Property Value

Type: AtalaImageWindow
See Also

Reference

OmrMarksDetectingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectingEventArgs.Template Property

OmrMarksDetectingEventArgsTemplate Property

The template containing the marks to be detected.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage Template { get; set; }
Public Property Template As OmrTemplatePage
    Get
    Set

Property Value

Type: OmrTemplatePage
See Also

Reference

OmrMarksDetectingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrMarksDetectingEventArgs Methods

The OmrMarksDetectingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrMarksDetectingEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage Class

A class representing the results of OMR on a single page.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrPage

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrPage
<SerializableAttribute>
Public Class OmrPage

The OmrPage type exposes the following members.

Properties
 | Name | Description
Public property | Groups | The mark groups on this page.
Public property | Image | A post alignment and preprocessing representation of the passed-in page's image.
Public property | Template | The template used to process this page.
Public property | TemplateToImageTransform | The matrix used to align this page
Top
Methods
 | Name | Description
Public method | DrawFoundMarksOntoPage(Color, AtalaImage) | Draws the marks from a page onto a provided image
Public method | DrawFoundMarksOntoPage(Color, AtalaImage, Double) | Draws the marks from a page onto a provided image
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrPage Properties

The OmrPage type exposes the following members.

Properties
 | Name | Description
Public property | Groups | The mark groups on this page.
Public property | Image | A post alignment and preprocessing representation of the passed-in page's image.
Public property | Template | The template used to process this page.
Public property | TemplateToImageTransform | The matrix used to align this page
Top
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.Groups Property

OmrPageGroups Property

The mark groups on this page.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOnlyCollection<OmrGroup> Groups { get; }
Public ReadOnly Property Groups As ReadOnlyCollection(Of OmrGroup)
    Get

Property Value

Type: ReadOnlyCollectionOmrGroup
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.Image Property

OmrPageImage Property

A post alignment and preprocessing representation of the passed-in page's image.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageWindow Image { get; }
Public ReadOnly Property Image As AtalaImageWindow
    Get

Property Value

Type: AtalaImageWindow
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.Template Property

OmrPageTemplate Property

The template used to process this page.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage Template { get; }
Public ReadOnly Property Template As OmrTemplatePage
    Get

Property Value

Type: OmrTemplatePage
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.TemplateToImageTransform Property

OmrPageTemplateToImageTransform Property

The matrix used to align this page

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImmutableMatrix TemplateToImageTransform { get; }
Public ReadOnly Property TemplateToImageTransform As ImmutableMatrix
    Get

Property Value

Type: ImmutableMatrix
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage Methods

The OmrPage type exposes the following members.

Methods
 | Name | Description
Public method | DrawFoundMarksOntoPage(Color, AtalaImage) | Draws the marks from a page onto a provided image
Public method | DrawFoundMarksOntoPage(Color, AtalaImage, Double) | Draws the marks from a page onto a provided image
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.DrawFoundMarksOntoPage Method

OmrPageDrawFoundMarksOntoPage Method

Overload List
 | Name | Description
Public method | DrawFoundMarksOntoPage(Color, AtalaImage) | Draws the marks from a page onto a provided image
Public method | DrawFoundMarksOntoPage(Color, AtalaImage, Double) | Draws the marks from a page onto a provided image
Top
See Also

Reference

OmrPage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.DrawFoundMarksOntoPage Method (Color, AtalaImage)

OmrPageDrawFoundMarksOntoPage Method (Color, AtalaImage)

Draws the marks from a page onto a provided image

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawFoundMarksOntoPage(
    Color c,
    AtalaImage sourceImage
)
Public Function DrawFoundMarksOntoPage (
    c As Color,
    sourceImage As AtalaImage
) As AtalaImage

Parameters

c
Type: System.DrawingColor
The color to draw the marks
sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to draw them on, the return is a clone of this image

Return Value

Type: AtalaImage
A clone of the sourceImage with marks from the page drawn on it
See Also

Reference

OmrPage Class
DrawFoundMarksOntoPage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrPage.DrawFoundMarksOntoPage Method (Color, AtalaImage, Double)

OmrPageDrawFoundMarksOntoPage Method (Color, AtalaImage, Double)

Draws the marks from a page onto a provided image

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawFoundMarksOntoPage(
    Color c,
    AtalaImage sourceImage,
    double probability
)
Public Function DrawFoundMarksOntoPage (
    c As Color,
    sourceImage As AtalaImage,
    probability As Double
) As AtalaImage

Parameters

c
Type: System.DrawingColor
The color to draw the marks
sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to draw them on, the return is a clone of this image
probability
Type: SystemDouble
The minimum probability a found mark must have to be drawn

Return Value

Type: AtalaImage
A clone of the sourceImage with marks from the page drawn on it
See Also

Reference

OmrPage Class
DrawFoundMarksOntoPage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs Class

This class is passed to the user when OmrEngine's PageProgress event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
Atalasoft.FormsProcessing.OmrOmrPageProgressEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrPageProgressEventArgs : CancelEventArgs
Public Class OmrPageProgressEventArgs
    Inherits CancelEventArgs

The OmrPageProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrPageProgressEventArgs | Creates a new OmrDocumentProgressEventArgs instance with the following Stage, CurrentPage and TotalPages values.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CurrentPage | The current page being processed, counting from 0.
Public property | Progress | A number between 0 and 100 which represents the progress done in document processing. This will be null if the ImageSource provided does not report the total number of pages.
Public property | ProgressIsValid | True if the progress reported by this event is valid. False if it is not.
Public property | Stage | The current stage in OMR page-wide processing.
Public property | TotalPages | The total number of pages being processed. This will be null if the ImageSource provided does not report the total number of pages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs Constructor

Creates a new OmrDocumentProgressEventArgs instance with the following Stage, CurrentPage and TotalPages values.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrPageProgressEventArgs(
    OmrPageStage stage,
    int currentPage,
    Nullable<int> totalPages
)
Public Sub New (
    stage As OmrPageStage,
    currentPage As Integer,
    totalPages As Nullable(Of Integer)
)

Parameters

stage
Type: Atalasoft.FormsProcessing.OmrOmrPageStage
The stage shown in the Stage property.
currentPage
Type: SystemInt32
The currentPage shown in the CurrentPage property.
totalPages
Type: SystemNullableInt32
The TotalPages shown in the TotalPages property. If null, ProgressIsValid will be false and Progress will be null.
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs Properties

The OmrPageProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CurrentPage | The current page being processed, counting from 0.
Public property | Progress | A number between 0 and 100 which represents the progress done in document processing. This will be null if the ImageSource provided does not report the total number of pages.
Public property | ProgressIsValid | True if the progress reported by this event is valid. False if it is not.
Public property | Stage | The current stage in OMR page-wide processing.
Public property | TotalPages | The total number of pages being processed. This will be null if the ImageSource provided does not report the total number of pages.
Top
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs.CurrentPage Property

OmrPageProgressEventArgsCurrentPage Property

The current page being processed, counting from 0.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentPage { get; }
Public ReadOnly Property CurrentPage As Integer
    Get

Property Value

Type: Int32
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs.Progress Property

OmrPageProgressEventArgsProgress Property

A number between 0 and 100 which represents the progress done in document processing. This will be null if the ImageSource provided does not report the total number of pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<int> Progress { get; }
Public ReadOnly Property Progress As Nullable(Of Integer)
    Get

Property Value

Type: NullableInt32
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs.ProgressIsValid Property

OmrPageProgressEventArgsProgressIsValid Property

True if the progress reported by this event is valid. False if it is not.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ProgressIsValid { get; }
Public ReadOnly Property ProgressIsValid As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs.Stage Property

OmrPageProgressEventArgsStage Property

The current stage in OMR page-wide processing.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrPageStage Stage { get; }
Public ReadOnly Property Stage As OmrPageStage
    Get

Property Value

Type: OmrPageStage
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs.TotalPages Property

OmrPageProgressEventArgsTotalPages Property

The total number of pages being processed. This will be null if the ImageSource provided does not report the total number of pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<int> TotalPages { get; }
Public ReadOnly Property TotalPages As Nullable(Of Integer)
    Get

Property Value

Type: NullableInt32
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageProgressEventArgs Methods

The OmrPageProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrPageProgressEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrPageStage Enumeration

The current stage in OMR page-wide processing.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OmrPageStage
Public Enumeration OmrPageStage
Members
Member name | Description
Preprocessing | The preprocessing stage is when the image is deskewed, cleaned up and converted to an appropriate PixelFormat.
Aligning | The aligning stage is when the template is aligned to the given page.
Recognizing | The recognizing stage is when the marks are detected.
Finishing | The finishing stage is when the process has been completed.
Remarks
Used by PageProgress.
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace
OmrEnginePageProgress
Atalasoft.FormsProcessing.OmrOmrPageProgressEventArgs


OmrTemplateAlignedEventArgs Class

This class is passed to the user when OmrEngine's TemplateAligned event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.OmrOmrTemplateAlignedEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrTemplateAlignedEventArgs : EventArgs
Public Class OmrTemplateAlignedEventArgs
    Inherits EventArgs

The OmrTemplateAlignedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrTemplateAlignedEventArgs | Creates a new instance of OmrTemplateAlignedEventArgs.
Top
Properties
 | Name | Description
Public property | AlignmentRejectorResult | The result of the alignment rejection process.
Public property | AlignmentResult | The result of the alignment process.
Public property | IsAlignmentAcceptable | True if the alignment was considered acceptable by the alignment rejection process. False if not. Set to override the results.
Public property | MarkedImage | The preprocessed marked image.
Public property | Template | The template which was aligned to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs Constructor

Creates a new instance of OmrTemplateAlignedEventArgs.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateAlignedEventArgs(
    AlignmentResult alignmentResult,
    AlignmentRejectorResult rejectorResult,
    AtalaImage markedImage,
    OmrTemplatePage templatePage,
    bool isAlignmentAcceptable
)
Public Sub New (
    alignmentResult As AlignmentResult,
    rejectorResult As AlignmentRejectorResult,
    markedImage As AtalaImage,
    templatePage As OmrTemplatePage,
    isAlignmentAcceptable As Boolean
)

Parameters

alignmentResult
Type: Atalasoft.FormsProcessing.AlignmentAlignmentResult
The object shown in the AlignmentResult property.
rejectorResult
Type: Atalasoft.FormsProcessing.AlignmentAlignmentRejectorResult
The object shown in the AlignmentRejectorResult property.
markedImage
Type: Atalasoft.ImagingAtalaImage
The object shown in the MarkedImage property.
templatePage
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage
The object shown in the Template property.
isAlignmentAcceptable
Type: SystemBoolean
The value shown in the IsAlignmentAcceptable property.
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs Properties

The OmrTemplateAlignedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentRejectorResult | The result of the alignment rejection process.
Public property | AlignmentResult | The result of the alignment process.
Public property | IsAlignmentAcceptable | True if the alignment was considered acceptable by the alignment rejection process. False if not. Set to override the results.
Public property | MarkedImage | The preprocessed marked image.
Public property | Template | The template which was aligned to.
Top
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs.AlignmentRejectorResult Property

OmrTemplateAlignedEventArgsAlignmentRejectorResult Property

The result of the alignment rejection process.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentRejectorResult AlignmentRejectorResult { get; }
Public ReadOnly Property AlignmentRejectorResult As AlignmentRejectorResult
    Get

Property Value

Type: AlignmentRejectorResult
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs.AlignmentResult Property

OmrTemplateAlignedEventArgsAlignmentResult Property

The result of the alignment process.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlignmentResult AlignmentResult { get; }
Public ReadOnly Property AlignmentResult As AlignmentResult
    Get

Property Value

Type: AlignmentResult
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs.IsAlignmentAcceptable Property

OmrTemplateAlignedEventArgsIsAlignmentAcceptable Property

True if the alignment was considered acceptable by the alignment rejection process. False if not. Set to override the results.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsAlignmentAcceptable { get; set; }
Public Property IsAlignmentAcceptable As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs.MarkedImage Property

OmrTemplateAlignedEventArgsMarkedImage Property

The preprocessed marked image.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage MarkedImage { get; }
Public ReadOnly Property MarkedImage As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs.Template Property

OmrTemplateAlignedEventArgsTemplate Property

The template which was aligned to.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage Template { get; }
Public ReadOnly Property Template As OmrTemplatePage
    Get

Property Value

Type: OmrTemplatePage
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAlignedEventArgs Methods

The OmrTemplateAlignedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrTemplateAlignedEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs Class

This class is passed to the user when OmrEngine's TemplateAligning event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.FormsProcessing.OmrOmrTemplateAligningEventArgs

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrTemplateAligningEventArgs : EventArgs
Public Class OmrTemplateAligningEventArgs
    Inherits EventArgs

The OmrTemplateAligningEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OmrTemplateAligningEventArgs | Creates a new instance of OmrTemplateAligningEventArgs.
Top
Properties
 | Name | Description
Public property | AlignmentRejector | The object which rejects documents if their alignment is poor.
Public property | DocumentAligner | The object which does the document alignment.
Public property | InitialAlignmentMatrix | The initial alignment from which the active alignment process will begin.
Public property | MarkedImage | The preprocessed marked image.
Public property | MarkedImageFingerprint | The marked page fingerprint used for alignment.
Public property | SkipAlignment | If this is set to true, the alignment process will be skipped and the InitialAlignmentMatrix will be used instead.
Public property | Template | The template being aligned to.
Public property | TemplateFingerprint | The template fingerprint used for alignment.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs Constructor

Creates a new instance of OmrTemplateAligningEventArgs.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateAligningEventArgs(
    IDocumentAligner aligner,
    IAlignmentRejector rejector,
    PageFingerprint templateFingerprint,
    AtalaImage image,
    OmrTemplatePage template
)
Public Sub New (
    aligner As IDocumentAligner,
    rejector As IAlignmentRejector,
    templateFingerprint As PageFingerprint,
    image As AtalaImage,
    template As OmrTemplatePage
)

Parameters

aligner
Type: Atalasoft.FormsProcessing.AlignmentIDocumentAligner
The object shown in the DocumentAligner property.
rejector
Type: Atalasoft.FormsProcessing.AlignmentIAlignmentRejector
The object shown in the AlignmentRejector property.
templateFingerprint
Type: Atalasoft.FormsProcessing.AlignmentPageFingerprint
The object shown in the TemplateFingerprint property.
image
Type: Atalasoft.ImagingAtalaImage
The image shown in the MarkedImage property.
template
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage
The object shown in the Template property.
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs Properties

The OmrTemplateAligningEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentRejector | The object which rejects documents if their alignment is poor.
Public property | DocumentAligner | The object which does the document alignment.
Public property | InitialAlignmentMatrix | The initial alignment from which the active alignment process will begin.
Public property | MarkedImage | The preprocessed marked image.
Public property | MarkedImageFingerprint | The marked page fingerprint used for alignment.
Public property | SkipAlignment | If this is set to true, the alignment process will be skipped and the InitialAlignmentMatrix will be used instead.
Public property | Template | The template being aligned to.
Public property | TemplateFingerprint | The template fingerprint used for alignment.
Top
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.AlignmentRejector Property

OmrTemplateAligningEventArgsAlignmentRejector Property

The object which rejects documents if their alignment is poor.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IAlignmentRejector AlignmentRejector { get; }
Public ReadOnly Property AlignmentRejector As IAlignmentRejector
    Get

Property Value

Type: IAlignmentRejector
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.DocumentAligner Property

OmrTemplateAligningEventArgsDocumentAligner Property

The object which does the document alignment.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDocumentAligner DocumentAligner { get; }
Public ReadOnly Property DocumentAligner As IDocumentAligner
    Get

Property Value

Type: IDocumentAligner
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.InitialAlignmentMatrix Property

OmrTemplateAligningEventArgsInitialAlignmentMatrix Property

The initial alignment from which the active alignment process will begin.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImmutableMatrix InitialAlignmentMatrix { get; set; }
Public Property InitialAlignmentMatrix As ImmutableMatrix
    Get
    Set

Property Value

Type: ImmutableMatrix
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.MarkedImage Property

OmrTemplateAligningEventArgsMarkedImage Property

The preprocessed marked image.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage MarkedImage { get; }
Public ReadOnly Property MarkedImage As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.MarkedImageFingerprint Property

OmrTemplateAligningEventArgsMarkedImageFingerprint Property

The marked page fingerprint used for alignment.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageFingerprint MarkedImageFingerprint { get; set; }
Public Property MarkedImageFingerprint As PageFingerprint
    Get
    Set

Property Value

Type: PageFingerprint
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.SkipAlignment Property

OmrTemplateAligningEventArgsSkipAlignment Property

If this is set to true, the alignment process will be skipped and the InitialAlignmentMatrix will be used instead.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SkipAlignment { get; set; }
Public Property SkipAlignment As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.Template Property

OmrTemplateAligningEventArgsTemplate Property

The template being aligned to.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage Template { get; }
Public ReadOnly Property Template As OmrTemplatePage
    Get

Property Value

Type: OmrTemplatePage
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs.TemplateFingerprint Property

OmrTemplateAligningEventArgsTemplateFingerprint Property

The template fingerprint used for alignment.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageFingerprint TemplateFingerprint { get; set; }
Public Property TemplateFingerprint As PageFingerprint
    Get
    Set

Property Value

Type: PageFingerprint
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateAligningEventArgs Methods

The OmrTemplateAligningEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrTemplateAligningEventArgs Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Class

A Savable/Loadable collection of OmrTemplatePage instances.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrTemplateDocument

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrTemplateDocument
<SerializableAttribute>
Public Class OmrTemplateDocument

The OmrTemplateDocument type exposes the following members.

Constructors
 | Name | Description
Public method | OmrTemplateDocument | Creates a new OmrTemplateDocument with an empty collection of pages.
Public method | OmrTemplateDocument(OmrTemplatePage) | Creates a new OmrTemplateDocument with the given pages.
Public method | OmrTemplateDocument(IEnumerableOmrTemplatePage) | Creates a new OmrTemplateDocument with the given pages.
Top
Properties
 | Name | Description
Public property | Pages | An instance of OmrTemplatePage for each page contained within this template.
Top
Methods
 | Name | Description
Public method | DrawTemplateOntoAlignedPage(Int32, Color, AtalaImage, AlignmentResult) | Returns an image of the given page's template drawn onto a provided aligned page
Public method | DrawTemplateOntoAlignedPage(Int32, Color, AtalaImage, ImmutableMatrix) | Returns an image of the given page's template drawn onto a provided Transform
Public method | DrawTemplateOntoPage | Returns an image of the given page with the template drawn onto it
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load(Stream) | Load a template from the given stream.
 | Load(String) | Load a template from the given file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save this template (and all of it's pages, groups and marks) into the given stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Constructor

Creates a new OmrTemplateDocument instance.
Overload List
 | Name | Description
Public method | OmrTemplateDocument | Creates a new OmrTemplateDocument with an empty collection of pages.
Public method | OmrTemplateDocument(OmrTemplatePage) | Creates a new OmrTemplateDocument with the given pages.
Public method | OmrTemplateDocument(IEnumerableOmrTemplatePage) | Creates a new OmrTemplateDocument with the given pages.
Top
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Constructor

Creates a new OmrTemplateDocument with an empty collection of pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateDocument()
Public Sub New
See Also

Reference

OmrTemplateDocument Class
OmrTemplateDocument Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Constructor (OmrTemplatePage[])

OmrTemplateDocument Constructor (OmrTemplatePage)

Creates a new OmrTemplateDocument with the given pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateDocument(
    params OmrTemplatePage[] pages
)
Public Sub New (
    ParamArray pages As OmrTemplatePage()
)

Parameters

pages
Type: Atalasoft.FormsProcessing.OmrOmrTemplatePage
The pages to use when creating the OmrTemplateDocument
See Also

Reference

OmrTemplateDocument Class
OmrTemplateDocument Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Constructor (IEnumerable(OmrTemplatePage))

OmrTemplateDocument Constructor (IEnumerableOmrTemplatePage)

Creates a new OmrTemplateDocument with the given pages.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateDocument(
    IEnumerable<OmrTemplatePage> pages
)
Public Sub New (
    pages As IEnumerable(Of OmrTemplatePage)
)

Parameters

pages
Type: System.Collections.GenericIEnumerableOmrTemplatePage
The pages to use when creating the OmrTemplateDocument
See Also

Reference

OmrTemplateDocument Class
OmrTemplateDocument Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Properties

The OmrTemplateDocument type exposes the following members.

Properties
 | Name | Description
Public property | Pages | An instance of OmrTemplatePage for each page contained within this template.
Top
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.Pages Property

OmrTemplateDocumentPages Property

An instance of OmrTemplatePage for each page contained within this template.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<OmrTemplatePage> Pages { get; }
Public ReadOnly Property Pages As List(Of OmrTemplatePage)
    Get

Property Value

Type: ListOmrTemplatePage
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument Methods

The OmrTemplateDocument type exposes the following members.

Methods
 | Name | Description
Public method | DrawTemplateOntoAlignedPage(Int32, Color, AtalaImage, AlignmentResult) | Returns an image of the given page's template drawn onto a provided aligned page
Public method | DrawTemplateOntoAlignedPage(Int32, Color, AtalaImage, ImmutableMatrix) | Returns an image of the given page's template drawn onto a provided Transform
Public method | DrawTemplateOntoPage | Returns an image of the given page with the template drawn onto it
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load(Stream) | Load a template from the given stream.
 | Load(String) | Load a template from the given file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save this template (and all of it's pages, groups and marks) into the given stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.DrawTemplateOntoAlignedPage Method

OmrTemplateDocumentDrawTemplateOntoAlignedPage Method

Overload List
 | Name | Description
Public method | DrawTemplateOntoAlignedPage(Int32, Color, AtalaImage, AlignmentResult) | Returns an image of the given page's template drawn onto a provided aligned page
Public method | DrawTemplateOntoAlignedPage(Int32, Color, AtalaImage, ImmutableMatrix) | Returns an image of the given page's template drawn onto a provided Transform
Top
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.DrawTemplateOntoAlignedPage Method (Int32, Color, AtalaImage, AlignmentResult)

OmrTemplateDocumentDrawTemplateOntoAlignedPage Method (Int32, Color, AtalaImage, AlignmentResult)

Returns an image of the given page's template drawn onto a provided aligned page

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawTemplateOntoAlignedPage(
    int page,
    Color c,
    AtalaImage original,
    AlignmentResult alignment
)
Public Function DrawTemplateOntoAlignedPage (
    page As Integer,
    c As Color,
    original As AtalaImage,
    alignment As AlignmentResult
) As AtalaImage

Parameters

page
Type: SystemInt32
c
Type: System.DrawingColor
original
Type: Atalasoft.ImagingAtalaImage
alignment
Type: Atalasoft.FormsProcessing.AlignmentAlignmentResult

Return Value

Type: AtalaImage
See Also

Reference

OmrTemplateDocument Class
DrawTemplateOntoAlignedPage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.DrawTemplateOntoAlignedPage Method (Int32, Color, AtalaImage, ImmutableMatrix)

OmrTemplateDocumentDrawTemplateOntoAlignedPage Method (Int32, Color, AtalaImage, ImmutableMatrix)

Returns an image of the given page's template drawn onto a provided Transform

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawTemplateOntoAlignedPage(
    int page,
    Color c,
    AtalaImage original,
    ImmutableMatrix transform
)
Public Function DrawTemplateOntoAlignedPage (
    page As Integer,
    c As Color,
    original As AtalaImage,
    transform As ImmutableMatrix
) As AtalaImage

Parameters

page
Type: SystemInt32
c
Type: System.DrawingColor
original
Type: Atalasoft.ImagingAtalaImage
transform
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix

Return Value

Type: AtalaImage
See Also

Reference

OmrTemplateDocument Class
DrawTemplateOntoAlignedPage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.DrawTemplateOntoPage Method

OmrTemplateDocumentDrawTemplateOntoPage Method

Returns an image of the given page with the template drawn onto it

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage DrawTemplateOntoPage(
    int page,
    Color c
)
Public Function DrawTemplateOntoPage (
    page As Integer,
    c As Color
) As AtalaImage

Parameters

page
Type: SystemInt32
c
Type: System.DrawingColor

Return Value

Type: AtalaImage
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.Load Method

OmrTemplateDocumentLoad Method

Overload List
Name | Description
Load(Stream) | Load a template from the given stream.
Load(String) | Load a template from the given file.
Top
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.Load Method (Stream)

OmrTemplateDocumentLoad Method (Stream)

Load a template from the given stream.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static OmrTemplateDocument Load(
    Stream stream
)
Public Shared Function Load (
    stream As Stream
) As OmrTemplateDocument

Parameters

stream
Type: System.IOStream

Return Value

Type: OmrTemplateDocument
See Also

Reference

OmrTemplateDocument Class
Load Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.Load Method (String)

OmrTemplateDocumentLoad Method (String)

Load a template from the given file.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static OmrTemplateDocument Load(
    string path
)
Public Shared Function Load (
    path As String
) As OmrTemplateDocument

Parameters

path
Type: SystemString

Return Value

Type: OmrTemplateDocument
See Also

Reference

OmrTemplateDocument Class
Load Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateDocument.Save Method

OmrTemplateDocumentSave Method

Save this template (and all of it's pages, groups and marks) into the given stream.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream
)
Public Sub Save (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream to load the template from
See Also

Reference

OmrTemplateDocument Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Class

This class is used to describe related groups of marks.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrTemplateGroup

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrTemplateGroup
<SerializableAttribute>
Public Class OmrTemplateGroup

The OmrTemplateGroup type exposes the following members.

Constructors
 | Name | Description
Public method | OmrTemplateGroup(String) | Creates a new OmrTemplateGroup based on the given name, and with an empty Marks collection.
Public method | OmrTemplateGroup(String, OmrTemplateMark) | Creates a new OmrTemplateGroup based on the given name, and with the given marks, in order.
Public method | OmrTemplateGroup(String, IEnumerableOmrTemplateMark) | Creates a new OmrTemplateGroup based on the given name, and with the given marks.
Top
Properties
 | Name | Description
Public property | Marks | A collection of OmrTemplateMark instances, each representing a mark within this group.
Public property | Name | The name of this mark group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Constructor

Creates a new OmrTemplateGroup instance.
Overload List
 | Name | Description
Public method | OmrTemplateGroup(String) | Creates a new OmrTemplateGroup based on the given name, and with an empty Marks collection.
Public method | OmrTemplateGroup(String, OmrTemplateMark) | Creates a new OmrTemplateGroup based on the given name, and with the given marks, in order.
Public method | OmrTemplateGroup(String, IEnumerableOmrTemplateMark) | Creates a new OmrTemplateGroup based on the given name, and with the given marks.
Top
See Also

Reference

OmrTemplateGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Constructor (String)

Creates a new OmrTemplateGroup based on the given name, and with an empty Marks collection.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateGroup(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The name of this group.
See Also

Reference

OmrTemplateGroup Class
OmrTemplateGroup Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Constructor (String, OmrTemplateMark[])

OmrTemplateGroup Constructor (String, OmrTemplateMark)

Creates a new OmrTemplateGroup based on the given name, and with the given marks, in order.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateGroup(
    string name,
    params OmrTemplateMark[] marks
)
Public Sub New (
    name As String,
    ParamArray marks As OmrTemplateMark()
)

Parameters

name
Type: SystemString
The name of this group.
marks
Type: Atalasoft.FormsProcessing.OmrOmrTemplateMark
Instances of OmrTemplateMark which will be added to this group.
See Also

Reference

OmrTemplateGroup Class
OmrTemplateGroup Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Constructor (String, IEnumerable(OmrTemplateMark))

OmrTemplateGroup Constructor (String, IEnumerableOmrTemplateMark)

Creates a new OmrTemplateGroup based on the given name, and with the given marks.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateGroup(
    string name,
    IEnumerable<OmrTemplateMark> marks
)
Public Sub New (
    name As String,
    marks As IEnumerable(Of OmrTemplateMark)
)

Parameters

name
Type: SystemString
The name of this group.
marks
Type: System.Collections.GenericIEnumerableOmrTemplateMark
Instances of OmrTemplateMark which will be added to this group.
See Also

Reference

OmrTemplateGroup Class
OmrTemplateGroup Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Properties

The OmrTemplateGroup type exposes the following members.

Properties
 | Name | Description
Public property | Marks | A collection of OmrTemplateMark instances, each representing a mark within this group.
Public property | Name | The name of this mark group.
Top
See Also

Reference

OmrTemplateGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup.Marks Property

OmrTemplateGroupMarks Property

A collection of OmrTemplateMark instances, each representing a mark within this group.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<OmrTemplateMark> Marks { get; }
Public ReadOnly Property Marks As List(Of OmrTemplateMark)
    Get

Property Value

Type: ListOmrTemplateMark
See Also

Reference

OmrTemplateGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup.Name Property

OmrTemplateGroupName Property

The name of this mark group.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

OmrTemplateGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateGroup Methods

The OmrTemplateGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrTemplateGroup Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateMark Class

This class is used to describe locations on the page where marks will be expected.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrTemplateMark

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrTemplateMark
<SerializableAttribute>
Public Class OmrTemplateMark

The OmrTemplateMark type exposes the following members.

Constructors
 | Name | Description
Public method | OmrTemplateMark | Create a new OmrTemplateMark based on a Name and a bounding RectangleF.
Top
Properties
 | Name | Description
Public property | Name | The mark's identifier.
Public property | Rectangle | The mark's bounding rectangle.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateMark Constructor

Create a new OmrTemplateMark based on a Name and a bounding RectangleF.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplateMark(
    string name,
    Rectangle rectangle
)
Public Sub New (
    name As String,
    rectangle As Rectangle
)

Parameters

name
Type: SystemString
An identifier for this mark
rectangle
Type: System.DrawingRectangle
The bounding rectangle for this mark
See Also

Reference

OmrTemplateMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateMark Properties

The OmrTemplateMark type exposes the following members.

Properties
 | Name | Description
Public property | Name | The mark's identifier.
Public property | Rectangle | The mark's bounding rectangle.
Top
See Also

Reference

OmrTemplateMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateMark.Name Property

OmrTemplateMarkName Property

The mark's identifier.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

OmrTemplateMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateMark.Rectangle Property

OmrTemplateMarkRectangle Property

The mark's bounding rectangle.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Rectangle { get; }
Public ReadOnly Property Rectangle As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

OmrTemplateMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplateMark Methods

The OmrTemplateMark type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrTemplateMark Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Class

This class is used to describe the pages on which marks will be expected.
Inheritance Hierarchy
SystemObject
Atalasoft.FormsProcessing.OmrOmrTemplatePage

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OmrTemplatePage
<SerializableAttribute>
Public Class OmrTemplatePage

The OmrTemplatePage type exposes the following members.

Constructors
 | Name | Description
Public method | OmrTemplatePage(AtalaImage) | Creates a new OmrTemplatePage with the given image and an empty collection of groups
Public method | OmrTemplatePage(AtalaImage, OmrTemplateGroup) | Creates a new OmrTemplatePage with the given image and marks
Public method | OmrTemplatePage(AtalaImage, IEnumerableOmrTemplateGroup) | Creates a new OmrTemplatePage with the given image and marks
Top
Properties
 | Name | Description
Public property | Groups | The mark groups contained within this page
Public property | Image | The template image for this page. Do not modify after object construction.
Top
Methods
 | Name | Description
Public method | DrawTemplateOntoImage(Color, AtalaImage) | Draws the template zones onto an image for diagnostic purposes. Doesn't transform the regions.
Public method | DrawTemplateOntoImage(Color, AtalaImage, ImmutableMatrix) | Draws the template zones onto an image for diagnostic purposes
Public method | DrawTemplateOntoImage(Color, AtalaImage, Matrix) | Draws the template zones onto an image for diagnostic purposes
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Constructor

Creates a new OmrTemplatePage instance.
Overload List
 | Name | Description
Public method | OmrTemplatePage(AtalaImage) | Creates a new OmrTemplatePage with the given image and an empty collection of groups
Public method | OmrTemplatePage(AtalaImage, OmrTemplateGroup) | Creates a new OmrTemplatePage with the given image and marks
Public method | OmrTemplatePage(AtalaImage, IEnumerableOmrTemplateGroup) | Creates a new OmrTemplatePage with the given image and marks
Top
See Also

Reference

OmrTemplatePage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Constructor (AtalaImage)

Creates a new OmrTemplatePage with the given image and an empty collection of groups

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The template image for this page
See Also

Reference

OmrTemplatePage Class
OmrTemplatePage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Constructor (AtalaImage, OmrTemplateGroup[])

OmrTemplatePage Constructor (AtalaImage, OmrTemplateGroup)

Creates a new OmrTemplatePage with the given image and marks

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage(
    AtalaImage image,
    params OmrTemplateGroup[] groups
)
Public Sub New (
    image As AtalaImage,
    ParamArray groups As OmrTemplateGroup()
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The template image for this page
groups
Type: Atalasoft.FormsProcessing.OmrOmrTemplateGroup
The mark groups contained within this page
See Also

Reference

OmrTemplatePage Class
OmrTemplatePage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Constructor (AtalaImage, IEnumerable(OmrTemplateGroup))

OmrTemplatePage Constructor (AtalaImage, IEnumerableOmrTemplateGroup)

Creates a new OmrTemplatePage with the given image and marks

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrTemplatePage(
    AtalaImage image,
    IEnumerable<OmrTemplateGroup> groups
)
Public Sub New (
    image As AtalaImage,
    groups As IEnumerable(Of OmrTemplateGroup)
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The template image for this page
groups
Type: System.Collections.GenericIEnumerableOmrTemplateGroup
The mark groups contained within this page
See Also

Reference

OmrTemplatePage Class
OmrTemplatePage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Properties

The OmrTemplatePage type exposes the following members.

Properties
 | Name | Description
Public property | Groups | The mark groups contained within this page
Public property | Image | The template image for this page. Do not modify after object construction.
Top
See Also

Reference

OmrTemplatePage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage.Groups Property

OmrTemplatePageGroups Property

The mark groups contained within this page

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<OmrTemplateGroup> Groups { get; }
Public ReadOnly Property Groups As List(Of OmrTemplateGroup)
    Get

Property Value

Type: ListOmrTemplateGroup
See Also

Reference

OmrTemplatePage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage.Image Property

OmrTemplatePageImage Property

The template image for this page. Do not modify after object construction.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

OmrTemplatePage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage Methods

The OmrTemplatePage type exposes the following members.

Methods
 | Name | Description
Public method | DrawTemplateOntoImage(Color, AtalaImage) | Draws the template zones onto an image for diagnostic purposes. Doesn't transform the regions.
Public method | DrawTemplateOntoImage(Color, AtalaImage, ImmutableMatrix) | Draws the template zones onto an image for diagnostic purposes
Public method | DrawTemplateOntoImage(Color, AtalaImage, Matrix) | Draws the template zones onto an image for diagnostic purposes
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrTemplatePage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage.DrawTemplateOntoImage Method

OmrTemplatePageDrawTemplateOntoImage Method

Overload List
 | Name | Description
Public method | DrawTemplateOntoImage(Color, AtalaImage) | Draws the template zones onto an image for diagnostic purposes. Doesn't transform the regions.
Public method | DrawTemplateOntoImage(Color, AtalaImage, ImmutableMatrix) | Draws the template zones onto an image for diagnostic purposes
Public method | DrawTemplateOntoImage(Color, AtalaImage, Matrix) | Draws the template zones onto an image for diagnostic purposes
Top
See Also

Reference

OmrTemplatePage Class
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage.DrawTemplateOntoImage Method (Color, AtalaImage)

OmrTemplatePageDrawTemplateOntoImage Method (Color, AtalaImage)

Draws the template zones onto an image for diagnostic purposes. Doesn't transform the regions.

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawTemplateOntoImage(
    Color c,
    AtalaImage img
)
Public Sub DrawTemplateOntoImage (
    c As Color,
    img As AtalaImage
)

Parameters

c
Type: System.DrawingColor
The color to draw with
img
Type: Atalasoft.ImagingAtalaImage
The image to draw on
See Also

Reference

OmrTemplatePage Class
DrawTemplateOntoImage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage.DrawTemplateOntoImage Method (Color, AtalaImage, ImmutableMatrix)

OmrTemplatePageDrawTemplateOntoImage Method (Color, AtalaImage, ImmutableMatrix)

Draws the template zones onto an image for diagnostic purposes

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawTemplateOntoImage(
    Color c,
    AtalaImage img,
    ImmutableMatrix m
)
Public Sub DrawTemplateOntoImage (
    c As Color,
    img As AtalaImage,
    m As ImmutableMatrix
)

Parameters

c
Type: System.DrawingColor
The color to draw with
img
Type: Atalasoft.ImagingAtalaImage
The image to draw on
m
Type: Atalasoft.FormsProcessing.GeometryImmutableMatrix
A matrix to use on template regions before drawing. Use identity for the template image and the alignment transform for the marked image.
See Also

Reference

OmrTemplatePage Class
DrawTemplateOntoImage Overload
Atalasoft.FormsProcessing.Omr Namespace


OmrTemplatePage.DrawTemplateOntoImage Method (Color, AtalaImage, Matrix)

OmrTemplatePageDrawTemplateOntoImage Method (Color, AtalaImage, Matrix)

Draws the template zones onto an image for diagnostic purposes

Namespace: Atalasoft.FormsProcessing.Omr
Assembly: Atalasoft.dotImage.FormsProcessing (in Atalasoft.dotImage.FormsProcessing.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawTemplateOntoImage(
    Color c,
    AtalaImage img,
    Matrix m
)
Public Sub DrawTemplateOntoImage (
    c As Color,
    img As AtalaImage,
    m As Matrix
)

Parameters

c
Type: System.DrawingColor
The color to draw with
img
Type: Atalasoft.ImagingAtalaImage
The image to draw on
m
Type: System.Drawing.Drawing2DMatrix
A matrix to use on template regions before drawing. Use identity for the template image and the alignment transform for the marked image.
See Also

Reference

OmrTemplatePage Class
DrawTemplateOntoImage Overload
Atalasoft.FormsProcessing.Omr Namespace


Atalasoft.Imaging Namespace

Classes
 | Class | Description
Public class | AtalaFileStream | A custom Stream object that is used to read and write images to a file. This is the default stream object used when specifying filenames for images. Deprecated, use AtalaFile64Stream in preferance to this class.
 | AtalaImage | The AtalaImage object holds the raw image data, a Palette, and methods used to access this data.
Public class | AtalaImageEditor | Allows visual designers to add AtalaImage objects in design time.
Public class | AtalaInt128Collection | A collection of AtalaInt128 structures.
Public class | AtalaPixelFormatChanger | This is the standard PixelFormat changer class.
Public class | AtalasoftLicenseException | Summary description for AtalasoftLicenseException.
Public class | BinaryPaletteEnforcer | A ResourceReleaserT that inverts a 1BPP AtalaImage on creation if it does not have the desired photometric interpretation, and inverts it again at the end of its lifetime.
Public class | BinaryPaletteEnforcerEnforcerState | The internal state of a BinaryPaletteEnforcer instance.
Public class | ChangedImageEventArgs | This class is used to indicate when an AtalaImage has changed.
Public class | ExceptionEventArgs | Provides data for the ProcessError event.
Public class | FileMapIOException | This exception is thrown when an error occurs when allocating an image with file memory mapping.
Public class | FileReloader | FileReloader is an implementation of the IImageReloader interface. It encapsulates information about an image stored in a file system and can reload that image at any point.
Public class | FileSystemImageSource | This is an implementation of an ImageSource using a file system as a provider of images.
Public class | FileSystemImageSourceEventArgs | This object is used for events fired by a FileSystemImageSource.
Public class | FormDataCollection | The FormDataCollection is used with the HttpPost class to send form information to a web server.
Public class | GdiException | This exception is thrown when a GDI function fails.
 | HttpPost | This class allows you to post data to a server without user interaction. The data is posted as if it were being sent from an HTML Form, allowing any form handling component to be used on the server.
Public class | ImageCancelEventArgs | Provides data for the event which allow an operation using an image to be cancelled.
Public class | ImageCollection | This collection holds multiple AtalaImage objects useful for various features like working with multi-paged images, animations, and layering.
Public class | ImageCollectionEventArgs | Provides data for the Workspace NewImage and ChangedImage events.
Public class | ImageCollectionImageSource | ImageCollectionImageSource is an adapter class to make an ImageCollection compatible with the ImageSource class.
Public class | ImageEventArgs | Provides data for the NewImage and Workspace.ImageChanged events.
Public class | ImageMemory | Obsolete. This class handles memory associated with an image. It controls how the memory is allocated and freed. Use this class to enable memory file mapping. This class is no longer used in DotImage. Please use PixelMemory instead.
Public class | ImageProcessException | This exception is thrown when an error occurs during processing of an image
Public class | ImageSource | An abstract class that is used to define a flexible mechanism for managing large quantities of images without having to keep them all in memory at once.
Public class | ImageSourceNode | This is an object used to hold AtalaImage objects in the ImageSource. This object is only of interest if you are writing your own ImageSource implementation.
Public class | ImageStreamEventArgs | Provides data for the ImageStreamCompleted event.
Public class | IncompatiblePixelFormatException | This exception is thrown when the image to be processed does not contain a %PixelFormat% compatible with the function of interest.
Public class | IndirectionImageSource | The IndirectionImageSource class is used to provide an ImageSource which can be modified after its initial creation. The ThumbnailImageViewerSynchronizer uses this class to handle changes to the original ImageSource.
Public class | InternalErrorException | This exception is for generic errors within the DotImage codebase.
Public class | InternetConnectException | This exception is thrown when there is an error opening an internet connection.
Public class | InternetInvalidPasswordException | This exception is thrown when an invalid password was detected while attempting to connect to an HTTP or FTP site to download an image.
Public class | MarshalByRefCollectionBase | A base abstract (MustInherit in Visual Basic) collection class intended for strongly typed collections containing unmanaged data.
Public class | MarshalByRefReadOnlyCollectionBase | A base abstract (MustInherit in Visual Basic) collection class intended for strongly typed read-only collections containing unmanaged data.
Public class | OperationCancelledException | This class is used to cancel running operations.
Public class | Palette | The palette contains color information that is applied to colormapped images. Use this object to modify and read the palette colors.
Public class | PixelFormatChangeEventArgs | Provides data for the PixelFormatChange event.
Public class | PixelFormatChanger | This is an abstract class that defines how an image should be changed from one pixel format to another.
Public class | PixelFormatUtilities | PixelFormatUtilities is a toolbox of utilities for manipulating and asking questions about PixelFormat enumerated values.
Public class | PixelMemoryException | This exception is thrown when an error occurs that is related to PixelMemory
Public class | ProcessQueue | Holds a collection of ProcessQueue that are awaiting asynchronous processing.
Public class | ProcessQueuedItem | This class contains information regarding the image processing function that is to be run when the ProcessQueue is ready.
Public class | ProcessUndo | Contains information about an undo level that will be used in the %ProcessQueue%.
Public class | ProgressEventArgs | Provides data for the Progress event.
Public class | RandomAccessImageSource | This is an abstract class which is used to define ImageSource objects that can be accessed in any order.
Public class | ReleasingImageSourceNodeEventArgs | This class is passed in the Releasing event to provide the ImageSourceNode that has been released.
 | ResourceReleaserT | This is a tool that can be used for managing the automatic releasing of resources via the using statement.
Public class | SerializationHelper | SerializationHelper is a set of static methods to help in the process of deserialization of an object graph.
 | UndoCollection | The UndoCollection class is used to manage operations that need undo/redo functinality. The collection contains properties to specify the number of allowed operations to undo or redo.
Public class | UndoLevel | The UndoLevel class is used to store a single operation, in an UndoCollection, that can be un-done or re-done. Every instance of this class holds an ImageCollection which are the set of images that will be restored to 'undo' the operation that this UndoLevel represents.
 | Workspace | The workspace object is the container that is used to manage changes to images and provide an interface to open, save, and manipulate images either synchronously or asynchronously.
Structures
 | Structure | Description
Public structure | AtalaInt128 | A 128 bit Integer value type used in JPEG2000 metadata.
Public structure | CmykColor | CmykColor defines a color that consists of cyan, magenta, yellow, and black components.
Public structure | Dpi | Holds the Resolution information.
Interfaces
 | Interface | Description
Public interface | IImageReloader | IImageReloader provides a mechanism to bring unloaded images back into memory. This interface is used by ImageSource.
Delegates
 | Delegate | Description
Public delegate | ChangedImageEventHandler | This EventHandler is used to update AtalaImage objects in various classes.
Public delegate | ExceptionEventHandler | This EventHandler is used to pass along an exception during an image processing operation.
Public delegate | FileSystemImageSourceFileEventHandler | This event is used for tracking when a file or a frame within a file has been loaded.
Public delegate | FileSystemImageSourceFileFilterDelegate | The FileFilterDelegate is used within the FileSystemImageSource to provide a means of filtering out files or pages within files
Public delegate | ImageCancelEventHandler | Handles canceling operations.
Public delegate | ImageEventHandler | Event Handler for events requiring the image information.
Public delegate | ImageFileIOEventHandler | Event Handler requiring the a Stream object.
Public delegate | PixelFormatChangeEventHandler | Handles operations that require the PixelFormat of an image to change.
Public delegate | ProgressEventHandler | Handles the progress event for operations.
Public delegate | ReleasingImageSourceNodeEventHandler | Reports when an ImageSourceNode has been released.
Enumerations
 | Enumeration | Description
Public enumeration | FlipDirection | Specifies the flip direction.
Public enumeration | LicenseEdition | This enumeration indicates the type of license found by DotImage.
Public enumeration | PaletteType | Contains the standard palette types that a palette can be set to.
Public enumeration | PixelFormat | Specifies the format of the color data for each pixel in the image.
Public enumeration | ResolutionUnit | Defines the units associated with Resolution, or Dpi.


AtalaFileStream Class

A custom Stream object that is used to read and write images to a file. This is the default stream object used when specifying filenames for images. Deprecated, use AtalaFile64Stream in preferance to this class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
Atalasoft.ImagingAtalaFileStream

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaFileStream : Stream
Public Class AtalaFileStream
    Inherits Stream

The AtalaFileStream type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaFileStream | Initializes a new instance of AtalaFileStream.
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating if the stream can be read. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value indicating if the steam is seekable. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating if the stream can be written to. (Overrides StreamCanWrite.)
Public property | Handle | Gets or sets the unmanaged handle to the file stream.
Public property | Length | Gets the length of the stream in bytes. (Overrides StreamLength.)
Public property | Name | Gets the name of the file for this stream.
Public property | Position | Gets the current position of the stream pointer. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the stream. (Overrides StreamClose.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | This will dispose of any resources used by the stream.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any unwritten data to be committed. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads data from the stream into a byte array. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | Moves the file pointer to the beginning of the stream.
Public method | Seek(Int64, SeekOrigin) | Moves the file pointer to a specific position within the stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | Sets the size of the stream. (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes data to the stream. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Fields
 | Name | Description
Protected field | Access | Determines whether this stream is a source or destination stream.
Protected field | CanReadAFS | Gets a value indicating if the stream can be read.
Protected field | CanSeekAFS | Gets a value indicating if the steam is seekable.
Protected field | CanWriteAFS | Gets a value indicating if the stream can be written to.
Protected field | Source | Gets the unmanaged handle to the file stream.
Top
Remarks
This File Stream object is approximately 20% faster than the System.IO.FileStream object for loading images.
See Also

Reference

Atalasoft.Imaging Namespace


AtalaFileStream Constructor

Initializes a new instance of AtalaFileStream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaFileStream(
    string fileName,
    FileMode fileMode,
    FileAccess fileAccess
)
Public Sub New (
    fileName As String,
    fileMode As FileMode,
    fileAccess As FileAccess
)

Parameters

fileName
Type: SystemString
The file name that this stream will write to or read from.
fileMode
Type: System.IOFileMode
Specifies how the operating system should open the file to read or write.
fileAccess
Type: System.IOFileAccess
Specified if the file is read, write, or read/write.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream Properties

The AtalaFileStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating if the stream can be read. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value indicating if the steam is seekable. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating if the stream can be written to. (Overrides StreamCanWrite.)
Public property | Handle | Gets or sets the unmanaged handle to the file stream.
Public property | Length | Gets the length of the stream in bytes. (Overrides StreamLength.)
Public property | Name | Gets the name of the file for this stream.
Public property | Position | Gets the current position of the stream pointer. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.CanRead Property

AtalaFileStreamCanRead Property

Gets a value indicating if the stream can be read.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the stream can be read.

Property Value

Type: Boolean
A value indicating whether the stream can be read.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.CanSeek Property

AtalaFileStreamCanSeek Property

Gets a value indicating if the steam is seekable.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the steam is seekable.

Property Value

Type: Boolean
A value indicating whether the stream can seek.
Remarks
This property also indicates whether the Length and Position properties can be used.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.CanWrite Property

AtalaFileStreamCanWrite Property

Gets a value indicating if the stream can be written to.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the stream can be written to.

Property Value

Type: Boolean
A value indicating whether the stream can be written to.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Handle Property

AtalaFileStreamHandle Property

Gets or sets the unmanaged handle to the file stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
    Get

Property Value

Type: IntPtr
The unmanaged handle to the file stream.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Length Property

AtalaFileStreamLength Property

Gets the length of the stream in bytes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get

Property Value

Type: Int64
The length of the stream in bytes, up to a maximum value of 2^31 - 1.
Remarks
The CanSeek property must return true before you can get the length of the stream.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Name Property

AtalaFileStreamName Property

Gets the name of the file for this stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the file for this stream.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Position Property

AtalaFileStreamPosition Property

Gets the current position of the stream pointer.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set

Property Value

Type: Int64
The current position of the stream pointer, up to a maximum value of 2^31 - 1.
Remarks
The CanSeek property must return true before you can access the Position of the stream.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream Methods

The AtalaFileStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the stream. (Overrides StreamClose.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | This will dispose of any resources used by the stream.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Forces any unwritten data to be committed. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads data from the stream into a byte array. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | Moves the file pointer to the beginning of the stream.
Public method | Seek(Int64, SeekOrigin) | Moves the file pointer to a specific position within the stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | Sets the size of the stream. (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes data to the stream. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Close Method

AtalaFileStreamClose Method

Closes the stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Dispose Method

AtalaFileStreamDispose Method

Overload List
 | Name | Description
Public method | Dispose | This will dispose of any resources used by the stream.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Top
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Dispose Method

AtalaFileStreamDispose Method

This will dispose of any resources used by the stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose
See Also

Reference

AtalaFileStream Class
Dispose Overload
Atalasoft.Imaging Namespace


AtalaFileStream.Flush Method

AtalaFileStreamFlush Method

Forces any unwritten data to be committed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Flush()
Public Overrides Sub Flush
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Read Method

AtalaFileStreamRead Method

Reads data from the stream into a byte array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer

Parameters

buffer
Type: SystemByte
The byte array that will hold the image data.
offset
Type: SystemInt32
The starting position in the byte array to begin storing data.
count
Type: SystemInt32
The number of bytes to read.

Return Value

Type: Int32
The number of bytes read.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Seek Method

AtalaFileStreamSeek Method

Moves the file pointer for an open stream.
Overload List
 | Name | Description
Public method | Seek | Moves the file pointer to the beginning of the stream.
Public method | Seek(Int64, SeekOrigin) | Moves the file pointer to a specific position within the stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Top
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Seek Method

AtalaFileStreamSeek Method

Moves the file pointer to the beginning of the stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual long Seek()
Public Overridable Function Seek As Long

Return Value

Type: Int64
The new position within the file.
See Also

Reference

AtalaFileStream Class
Seek Overload
Atalasoft.Imaging Namespace


AtalaFileStream.Seek Method (Int64, SeekOrigin)

AtalaFileStreamSeek Method (Int64, SeekOrigin)

Moves the file pointer to a specific position within the stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long

Parameters

offset
Type: SystemInt64
The number of bytes to move the pointer, up to a maximum value of 2^31 - 1.
origin
Type: System.IOSeekOrigin
Specifies whether the offset is from the beginning, end or current position.

Return Value

Type: Int64
The new position within the file.
See Also

Reference

AtalaFileStream Class
Seek Overload
Atalasoft.Imaging Namespace


AtalaFileStream.SetLength Method

AtalaFileStreamSetLength Method

Sets the size of the stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)

Parameters

value
Type: SystemInt64
Remarks
If the length is less than the current stream size, data on the end of the stream will be truncated.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Write Method

AtalaFileStreamWrite Method

Writes data to the stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)

Parameters

buffer
Type: SystemByte
A byte array containing the data to write.
offset
Type: SystemInt32
The starting position within the buffer to begin writing from.
count
Type: SystemInt32
The number of bytes to write.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream Fields

The AtalaFileStream type exposes the following members.

Fields
 | Name | Description
Protected field | Access | Determines whether this stream is a source or destination stream.
Protected field | CanReadAFS | Gets a value indicating if the stream can be read.
Protected field | CanSeekAFS | Gets a value indicating if the steam is seekable.
Protected field | CanWriteAFS | Gets a value indicating if the stream can be written to.
Protected field | Source | Gets the unmanaged handle to the file stream.
Top
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Access Field

AtalaFileStreamAccess Field

Determines whether this stream is a source or destination stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FileAccess Access
Protected Access As FileAccess

Field Value

Type: FileAccess
The read-only, source or read/write, destination nature of the stream.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.CanReadAFS Field

AtalaFileStreamCanReadAFS Field

Gets a value indicating if the stream can be read.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool CanReadAFS
Protected CanReadAFS As Boolean

Field Value

Type: Boolean
A value indicating if the stream can be read.

Field Value

Type: Boolean
A value indicating whether the stream can be read.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.CanSeekAFS Field

AtalaFileStreamCanSeekAFS Field

Gets a value indicating if the steam is seekable.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool CanSeekAFS
Protected CanSeekAFS As Boolean

Field Value

Type: Boolean
A value indicating if the steam is seekable.

Field Value

Type: Boolean
A value indicating whether the stream can seek.
Remarks
This property also indicates whether the Length and Position properties can be used.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.CanWriteAFS Field

AtalaFileStreamCanWriteAFS Field

Gets a value indicating if the stream can be written to.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool CanWriteAFS
Protected CanWriteAFS As Boolean

Field Value

Type: Boolean
A value indicating if the stream can be written to.

Field Value

Type: Boolean
A value indicating whether the stream can be written to.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaFileStream.Source Field

AtalaFileStreamSource Field

Gets the unmanaged handle to the file stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IntPtr Source
Protected Source As IntPtr

Field Value

Type: IntPtr
The unmanaged handle to the file stream.
See Also

Reference

AtalaFileStream Class
Atalasoft.Imaging Namespace


AtalaImage Class

The AtalaImage object holds the raw image data, a Palette, and methods used to access this data.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingAtalaImage

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AtalaImage : MarshalByRefObject, IDisposable,
    ICloneable, ISerializable
<SerializableAttribute>
Public Class AtalaImage
    Inherits MarshalByRefObject
    Implements IDisposable, ICloneable, ISerializable

The AtalaImage type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImage | Initializes a new instance of the AtalaImage class.
Public method | AtalaImage(Stream) | Initialize a new instance of a AtalaImage class specifying a Stream.
Public method | AtalaImage(String) | Initialize a new instance of a AtalaImage class specifying the file of the image to open.
Public method | AtalaImage(Stream, ProgressEventHandler) | Initialize a new instance of a %AtalaImage% class specifying a Stream and a progress delegate.
Protected method | AtalaImage(SerializationInfo, StreamingContext) | Creates an instance of an AtalaImage, with serialization info.
Public method | AtalaImage(String, ProgressEventHandler) | Initialize a new instance of a AtalaImage class specifying the file of the image to open.
Public method | AtalaImage(Int32, Int32, PixelFormat) | Initialize a new instance of the AtalaImage class specifying the Width, Height, and PixelFormat.
Public method | AtalaImage(Stream, Int32, ProgressEventHandler) | Initialize a new instance of an AtalaImage class specifying an image Stream and a page index to decode.
Public method | AtalaImage(String, Int32, ProgressEventHandler) | Initialize a new instance of an AtalaImage class specifying an image file and a page index to decode.
Public method | AtalaImage(Int32, Int32, PixelFormat, Byte) | Initializes a new instance of the AtalaImage class.
Public method | AtalaImage(Int32, Int32, PixelFormat, Color) | Initialize a new instance of the AtalaImage class specifying the Width, Height, PixelFormat, and Color to initialize the image background to.
Public method | AtalaImage(IntPtr, Int32, Int32, PixelFormat) | Initialize a new instance of the %AtalaImage% class specifying the image pointer, Width, Height, and PixelFormat. This method is obsolete. Please use the constructor that takes a PixelMemory object instead.
Public method | AtalaImage(Stream, Int32, ImageDecoder, ProgressEventHandler) | Initialize a new instance of an AtalaImage class specifying a Stream, ImageDecoder to use for decoding the image, and a progress delegate.
Public method | AtalaImage(PixelMemory, Int32, Int32, PixelFormat) | Initialize a new instance of the %AtalaImage% class specifying the PixelMemory, Width, Height, and PixelFormat.
Top
Properties
 | Name | Description
Public property | BitmapMirror | Obsolete. Gets the Bitmap mirror of this %AtalaImage%.
Public property | ColorDepth | Returns the number of bits per pixel of this AtalaImage.
Public property | ColorProfile | Gets or sets the ColorProfile associated with this AtalaImage.
 | DitherErrorMax | Obsolete. Gets or sets the diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.
 | Edition | Gets the type of license being used.
Public property | Height | Gets the height of this AtalaImage in pixels.
 | ImageData | Obsolete. Gets the memory address of this AtalaImage. This property is unsupported. Using it will cause a compilation error. Use PixelMemory instead.
Public property | Palette | Returns the palette object of this AtalaImage.
Public property | PixelFormat | Sets or returns the PixelFormat of this AtalaImage.
 | PixelFormatChanger | Get or set the class used to convert image pixel formats.
Public property | PixelMemory | Provides access to the memory that represents an image.
Public property | Resolution | Get or set the Resolution of this AtalaImage object
Public property | RowStride | Get the number of bytes in each row of this AtalaImage.
Public property | Size | Gets the size of this AtalaImage in pixels.
Public property | Width | Returns the width of this AtalaImage in pixels.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep copy of this AtalaImage.
 | CombineChannels | Combines the channels.
Public method | CopyToClipboard | Copies the image data onto the clipboard.
Public method | CountColors | Count the number of unique colors in this AtalaImage.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Call this method to destroy this AtalaImage data and free memory.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Draw(Graphics, Rectangle) | Draws this AtalaImage onto a System.Drawing.Graphics object at a specified location and size.
Public method | Draw(Graphics, Rectangle, Rectangle) | Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.
Public method | Draw(Graphics, Rectangle, Rectangle, Boolean) | Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillRectangle(Rectangle, Color) | Fills a specified rectangle in this image with a specified solid color.
Public method | FillRectangle(Rectangle, Int32) | Fills a specified rectangle in this image with a specified index.
Protected method | Finalize | The Destructor that will automatically be called by the garbage collector (Overrides ObjectFinalize.)
Public method | Flip | Flips the image in the specified direction.
 | FromBitmap(Bitmap) | Returns an AtalaImage containing a copy of the Bitmap.
 | FromBitmap(Bitmap, Boolean) | Converts a specified Bitmap into an AtalaImage by taking ownership of the Bitmap data, or returning a copy of the Bitmap data.
 | FromBitmapData | Obsolete. Returns an %AtalaImage% that contains the same image pointer that's in the specified BitmapData object.
 | FromByteArray(Byte) | Creates a new AtalaImage from a byte array containing an encoded image.
 | FromByteArray(Byte, ProgressEventHandler) | Creates a new AtalaImage from a byte array containing an encoded image.
 | FromDib | Returns an AtalaImage from a DIB (Device Independent Bitmap) pointer.
 | FromHBitmap | Returns an AtalaImage from an hBitmap handle.
 | FromURL(String, Boolean, ProgressEventHandler) | Returns an AtalaImage loaded from the url.
 | FromURL(String, Int32, Boolean, ProgressEventHandler) | Returns an AtalaImage loaded from the url.
Public method | GetBitmap | Obsolete. Returns a System.Drawing.Bitmap object copied from this %AtalaImage%.
Public method | GetChangedPixelFormat(PixelFormat) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.
 | GetChangedPixelFormat(PixelFormat, ColorProfile) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.
Public method | GetChangedPixelFormat(PixelFormat, ColorProfile, Boolean) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage specifying a ColorProfile and if the ChangedPixelFormat event should fire.
Public method | GetGraphics | Returns a System.Drawing.Graphics object allowing GDI+ operations to draw onto this AtalaImage.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetObjectData | Used to serialize this AtalaImage.
 | GetPackedBuffer | Gets the packed buffer.
Public method | GetPixelCmykColor | Get the color of a pixel in CMYK space
Public method | GetPixelColor | Returns the System.Drawing.Color of the specified pixel in this AtalaImage.
 | GetPixelFormatDepth | Obsolete. Returns the color depth in bits per pixels associated with a specified PixelFormat.
Public method | GetPixelIndex | Gets the palette index of the specified pixel in this AtalaImage.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImageFromClipboard | Creates a new AtalaImage from data on the clipboard.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnChangePixelFormat | Raises the [E:ChangePixelFormat] event.
 | PixelFormatHasAlpha | Obsolete. Returns true if the specified PixelFormat contains an alpha channel.
 | PixelFormatIsColormapped | Obsolete. Returns true if the specified PixelFormat contains a palette.
 | PixelFormatIsContinuous | Obsolete. Returns true if the PixelFormat passed in is a continuous-tone format.
 | PixelFormatIsTwoBytePerComponent | Obsolete. This method can be used to determine if a PixelFormat is a "Two Byte Per Component" image format.
 | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves this AtalaImage to a Stream object specifying an ImageType.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves this %AtalaImage% to a file specifying an ImageEncoder and progress callback.
 | Save(String, ImageType, ProgressEventHandler) | Obsolete. Saves this AtalaImage to a file specifying an ImageType and a PixelFormat.
Public method | SetPixelCmykColor | Set the color of a pixel in CMYK space
Public method | SetPixelColor | Sets the color of the pixel.
Public method | SetPixelIndex | Sets the index of the pixel.
Public method | SplitChannels | Returns an array of grayscale AtalaImage objects representing each 8-bit or 16-bit channel in the source image.
Public method | SplitChannels(ChannelFlags) | Returns an array of grayscale %AtalaImage% objects representing specified 8-bit or 16-bit channels in the source image.
Public method | ToBitmap | Returns a Bitmap object from this AtalaImage data.
Public method | ToByteArray(ImageEncoder) | Returns a byte array containing an encoded image.
Public method | ToByteArray(ImageEncoder, ProgressEventHandler) | Returns a byte array containing an encoded image.
Public method | ToDib | Returns a pointer to a DIB (Device Independent Bitmap) copied from this AtalaImage.
Public method | ToDib(Stream) | Fills the given stream with a DIB (Device Independent Bitmap) copied from this AtalaImage.
Public method | ToString | Returns a textual description of this AtalaImage object. (Overrides ObjectToString.)
 | UnregisteredWatermark | Unregistereds the watermark.
Top
Events
Name | Description
ChangePixelFormat | Occurs when the image data changes PixelFormats.
Top
Remarks

Image data is stored in a 32-bit row aligned buffer. See ToDib and FromDib(IntPtr, Boolean) for methods that will export or import from a DIB (Device Independent Bitmap).

The AtalaImage is used throughout DotImage and is similar to the Bitmap object in .NET.

Examples
Create an AtalaImage from a file (C#)
Copy
AtalaImage image = new AtalaImage("image.png");
Create an AtalaImage from a file (Visual Basic)
Copy
Dim image As AtalaImage = New AtalaImage("image.png")
See Also

Reference

Atalasoft.Imaging Namespace


AtalaImage Constructor

Creates a new instance of AtalaImage.
Overload List
 | Name | Description
Public method | AtalaImage | Initializes a new instance of the AtalaImage class.
Public method | AtalaImage(Stream) | Initialize a new instance of a AtalaImage class specifying a Stream.
Public method | AtalaImage(String) | Initialize a new instance of a AtalaImage class specifying the file of the image to open.
Public method | AtalaImage(Stream, ProgressEventHandler) | Initialize a new instance of a %AtalaImage% class specifying a Stream and a progress delegate.
Protected method | AtalaImage(SerializationInfo, StreamingContext) | Creates an instance of an AtalaImage, with serialization info.
Public method | AtalaImage(String, ProgressEventHandler) | Initialize a new instance of a AtalaImage class specifying the file of the image to open.
Public method | AtalaImage(Int32, Int32, PixelFormat) | Initialize a new instance of the AtalaImage class specifying the Width, Height, and PixelFormat.
Public method | AtalaImage(Stream, Int32, ProgressEventHandler) | Initialize a new instance of an AtalaImage class specifying an image Stream and a page index to decode.
Public method | AtalaImage(String, Int32, ProgressEventHandler) | Initialize a new instance of an AtalaImage class specifying an image file and a page index to decode.
Public method | AtalaImage(Int32, Int32, PixelFormat, Byte) | Initializes a new instance of the AtalaImage class.
Public method | AtalaImage(Int32, Int32, PixelFormat, Color) | Initialize a new instance of the AtalaImage class specifying the Width, Height, PixelFormat, and Color to initialize the image background to.
Public method | AtalaImage(IntPtr, Int32, Int32, PixelFormat) | Initialize a new instance of the %AtalaImage% class specifying the image pointer, Width, Height, and PixelFormat. This method is obsolete. Please use the constructor that takes a PixelMemory object instead.
Public method | AtalaImage(Stream, Int32, ImageDecoder, ProgressEventHandler) | Initialize a new instance of an AtalaImage class specifying a Stream, ImageDecoder to use for decoding the image, and a progress delegate.
Public method | AtalaImage(PixelMemory, Int32, Int32, PixelFormat) | Initialize a new instance of the %AtalaImage% class specifying the PixelMemory, Width, Height, and PixelFormat.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage Constructor

Initializes a new instance of the AtalaImage class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage()
Public Sub New
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (Stream)

Initialize a new instance of a AtalaImage class specifying a Stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
Remarks
The stream passed in can be a FileStream, MemoryStream, or other seekable stream. The appropriate ImageDecoder will be used to read the image.
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (String)

Initialize a new instance of a AtalaImage class specifying the file of the image to open.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The path of the file to open.
Remarks
A URL formatted string can be passed to download a file. If the address is pointing to an FTP site, you may need to include the username and password in the URL to allow access to the file.
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (Stream, ProgressEventHandler)

Initialize a new instance of a %AtalaImage% class specifying a Stream and a progress delegate.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    Stream stream,
    ProgressEventHandler progress
)
Public Sub New (
    stream As Stream,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (SerializationInfo, StreamingContext)

Creates an instance of an AtalaImage, with serialization info.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (String, ProgressEventHandler)

Initialize a new instance of a AtalaImage class specifying the file of the image to open.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    string fileName,
    ProgressEventHandler progress
)
Public Sub New (
    fileName As String,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The path of the file to open.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
Remarks
A URL formatted string can be passed to download a file. If the address is pointing to an FTP site, you may need to include the username and password in the URL to allow access to the file.
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (Int32, Int32, PixelFormat)

Initialize a new instance of the AtalaImage class specifying the Width, Height, and PixelFormat.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    int width,
    int height,
    PixelFormat pixelFormat
)
Public Sub New (
    width As Integer,
    height As Integer,
    pixelFormat As PixelFormat
)

Parameters

width
Type: SystemInt32
Width of the image.
height
Type: SystemInt32
Height of the image.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
PixelFormat of the image.
Remarks
The image data is not set to a particular color and might end up with some noise in the image. See the overload with a specific color or palette index to fill the background with a specified color.
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (Stream, Int32, ProgressEventHandler)

Initialize a new instance of an AtalaImage class specifying an image Stream and a page index to decode.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Sub New (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to load.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (String, Int32, ProgressEventHandler)

Initialize a new instance of an AtalaImage class specifying an image file and a page index to decode.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    string fileName,
    int frameIndex,
    ProgressEventHandler progress
)
Public Sub New (
    fileName As String,
    frameIndex As Integer,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The path of the file to open.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to load.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (Int32, Int32, PixelFormat, Byte)

Initializes a new instance of the AtalaImage class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    int width,
    int height,
    PixelFormat pixelFormat,
    byte fillPaletteIndex
)
Public Sub New (
    width As Integer,
    height As Integer,
    pixelFormat As PixelFormat,
    fillPaletteIndex As Byte
)

Parameters

width
Type: SystemInt32
The width.
height
Type: SystemInt32
The height.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
The pixel format.
fillPaletteIndex
Type: SystemByte
Index of the fill palette.
Exceptions
Exception | Condition
ArgumentException | Pixel Format must contain a palette when specifying the palette index to fill the image with. or Palette Index must be 0 or 1 for 1-bit images;fillPaletteIndex
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (Int32, Int32, PixelFormat, Color)

Initialize a new instance of the AtalaImage class specifying the Width, Height, PixelFormat, and Color to initialize the image background to.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    int width,
    int height,
    PixelFormat pixelFormat,
    Color fillColor
)
Public Sub New (
    width As Integer,
    height As Integer,
    pixelFormat As PixelFormat,
    fillColor As Color
)

Parameters

width
Type: SystemInt32
Width of the image.
height
Type: SystemInt32
Height of the image.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
PixelFormat of the image.
fillColor
Type: System.DrawingColor
The color to fill the image with.
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (IntPtr, Int32, Int32, PixelFormat)

Initialize a new instance of the %AtalaImage% class specifying the image pointer, Width, Height, and PixelFormat.

This method is obsolete. Please use the constructor that takes a PixelMemory object instead.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    IntPtr imageData,
    int width,
    int height,
    PixelFormat pixelFormat
)
Public Sub New (
    imageData As IntPtr,
    width As Integer,
    height As Integer,
    pixelFormat As PixelFormat
)

Parameters

imageData
Type: SystemIntPtr
The memory pointer of the image bits of an unpacked DIB (Device Independent Bitmap).
width
Type: SystemInt32
Width of the image.
height
Type: SystemInt32
Height of the image.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
PixelFormat of the image.
Remarks

This constructor can be used to create an AtalaImage object from existing image data. The memory pointer will be managed by the AtalaImage object, so do not free the memory once the pointer is assigned to this object.

The RowStride of the image data must be 32-bit (DWORD) aligned.

See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace
FromDib Method


AtalaImage Constructor (Stream, Int32, ImageDecoder, ProgressEventHandler)

Initialize a new instance of an AtalaImage class specifying a Stream, ImageDecoder to use for decoding the image, and a progress delegate.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    Stream stream,
    int frameIndex,
    ImageDecoder decoder,
    ProgressEventHandler progress
)
Public Sub New (
    stream As Stream,
    frameIndex As Integer,
    decoder As ImageDecoder,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to load.
decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to use for loading the specified encoded image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Constructor (PixelMemory, Int32, Int32, PixelFormat)

Initialize a new instance of the %AtalaImage% class specifying the PixelMemory, Width, Height, and PixelFormat.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage(
    PixelMemory memory,
    int width,
    int height,
    PixelFormat pixelFormat
)
Public Sub New (
    memory As PixelMemory,
    width As Integer,
    height As Integer,
    pixelFormat As PixelFormat
)

Parameters

memory
Type: Atalasoft.Imaging.MemoryPixelMemory
A PixelMemory object that represents an image's memory
width
Type: SystemInt32
Width of the image.
height
Type: SystemInt32
Height of the image.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
PixelFormat of the image.
See Also

Reference

AtalaImage Class
AtalaImage Overload
Atalasoft.Imaging Namespace


AtalaImage Properties

The AtalaImage type exposes the following members.

Properties
 | Name | Description
Public property | BitmapMirror | Obsolete. Gets the Bitmap mirror of this %AtalaImage%.
Public property | ColorDepth | Returns the number of bits per pixel of this AtalaImage.
Public property | ColorProfile | Gets or sets the ColorProfile associated with this AtalaImage.
 | DitherErrorMax | Obsolete. Gets or sets the diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.
 | Edition | Gets the type of license being used.
Public property | Height | Gets the height of this AtalaImage in pixels.
 | ImageData | Obsolete. Gets the memory address of this AtalaImage. This property is unsupported. Using it will cause a compilation error. Use PixelMemory instead.
Public property | Palette | Returns the palette object of this AtalaImage.
Public property | PixelFormat | Sets or returns the PixelFormat of this AtalaImage.
 | PixelFormatChanger | Get or set the class used to convert image pixel formats.
Public property | PixelMemory | Provides access to the memory that represents an image.
Public property | Resolution | Get or set the Resolution of this AtalaImage object
Public property | RowStride | Get the number of bytes in each row of this AtalaImage.
Public property | Size | Gets the size of this AtalaImage in pixels.
Public property | Width | Returns the width of this AtalaImage in pixels.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.BitmapMirror Property

AtalaImageBitmapMirror Property

Note: This API is now obsolete.

Gets the Bitmap mirror of this %AtalaImage%.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("BitmapMirror is obsolete.  Please use ToBitmap() instead which creates a GDI+ Bitmap copy of the AtalaImage")]
public Bitmap BitmapMirror { get; }
<ObsoleteAttribute("BitmapMirror is obsolete.  Please use ToBitmap() instead which creates a GDI+ Bitmap copy of the AtalaImage")>
Public ReadOnly Property BitmapMirror As Bitmap
    Get

Property Value

Type: Bitmap
A Bitmap object mirroring this AtalaImage.
Remarks
The image data is tied to the AtalaImage object from which the Bitmap was created. As long as the AtalaImage is still in scope, the Bitmap may be used. The intension of this property is to call and methods that require a Bitmap object such as DrawImage(Image, PointF).
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace
AtalaImageGetBitmap


AtalaImage.ColorDepth Property

AtalaImageColorDepth Property

Returns the number of bits per pixel of this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ColorDepth { get; }
Public ReadOnly Property ColorDepth As Integer
    Get

Property Value

Type: Int32
The number of bits per pixel of this AtalaImage.

Return Value

Type: Int32
The number of bits per pixel of this AtalaImage.
Remarks
The Colordepth can be changed by setting PixelFormat property to the appropriate format.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.ColorProfile Property

AtalaImageColorProfile Property

Gets or sets the ColorProfile associated with this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile ColorProfile { get; set; }
Public Property ColorProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
The ColorProfile associated with this AtalaImage.
Remarks

Any conversions to a colorspace to and from CMYK and RGB will use this profile for the conversion.

Image Formats that can contain an embedded profile such as Tiff, Jpeg, and Png will use this profile to embed into the image. Likewise, when images are loaded containing a color profile, this property will contain that profile.

See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.DitherErrorMax Property

AtalaImageDitherErrorMax Property

Note: This API is now obsolete.

Gets or sets the diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has moved to the AtalaPixelFormatChanger and is set to the static PixelFormatChanger property in AtalaImage.  AtalaImage.PixelFormatChanger must be cast to AtalaPixelFormatChanger where you can then access the DitherErrorMax property.",
    false)]
public static int DitherErrorMax { get; set; }
<ObsoleteAttribute("This method has moved to the AtalaPixelFormatChanger and is set to the static PixelFormatChanger property in AtalaImage.  AtalaImage.PixelFormatChanger must be cast to AtalaPixelFormatChanger where you can then access the DitherErrorMax property.",
    false)>
Public Shared Property DitherErrorMax As Integer
    Get
    Set

Property Value

Type: Int32
The diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.
Remarks

This value can be from 0 to 127 where 0 is with no error diffusion and 127 is maximum error diffusion.

See the Dithering topic for more information.

See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace
Dithering


AtalaImage.Edition Property

AtalaImageEdition Property

Gets the type of license being used.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static LicenseEdition Edition { get; }
Public Shared ReadOnly Property Edition As LicenseEdition
    Get

Property Value

Type: LicenseEdition
The type of license being used.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Height Property

AtalaImageHeight Property

Gets the height of this AtalaImage in pixels.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
The height of this image.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace
AtalaImageSize
AtalaImageWidth


AtalaImage.ImageData Property

AtalaImageImageData Property

Note: This API is now obsolete.

Gets the memory address of this AtalaImage. This property is unsupported. Using it will cause a compilation error. Use PixelMemory instead.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("ImageData is no longer supported.  Use PixelMemory instead.",
    true)]
public IntPtr ImageData { get; }
<ObsoleteAttribute("ImageData is no longer supported.  Use PixelMemory instead.",
    true)>
Public ReadOnly Property ImageData As IntPtr
    Get

Property Value

Type: IntPtr

This property is unsupported. Using it will cause a compilation error. Use PixelMemory instead.

Remarks
Similarly to the GDI+ Bitmap object, the memory bits AtalaImage can be directly manipulated with this pointer. There is no need to Lock the pointer.
Examples

This example shows how to use unsafe C# code to manipulate the image data directly. The /unsafe compiler directive must be used.

Directly Manipulate Pixels (C#)
Copy
  See Also
Reference
AtalaImage Class
Atalasoft.Imaging Namespace
Copyright 2000-2023 Kofax. All rights reserved.
Send comments on this topic to
        Atalasoft Development Team


AtalaImage.Palette Property

AtalaImagePalette Property

Returns the palette object of this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette Palette { get; set; }
Public Property Palette As Palette
    Get
    Set

Property Value

Type: Palette
The palette of this image.
Remarks
If the image does not contain a palette, this property will return null (Nothing in VB).
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.PixelFormat Property

AtalaImagePixelFormat Property

Sets or returns the PixelFormat of this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat PixelFormat { get; }
Public ReadOnly Property PixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat
The PixelFormat of this AtalaImage.
Remarks
See ChangePixelFormatCommand for changing the PixelFormat.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.PixelFormatChanger Property

AtalaImagePixelFormatChanger Property

Get or set the class used to convert image pixel formats.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PixelFormatChanger PixelFormatChanger { get; set; }
Public Shared Property PixelFormatChanger As PixelFormatChanger
    Get
    Set

Property Value

Type: PixelFormatChanger
An object of type PixelFormatChanger that can be used to convert images from one PixelFormat to another.
Remarks

This class is used by AtalaImage.GetChangedPixelFormat(PixelFormat) as well as by all DotImage image commands. By changing this property, a client can control how all pixel format conversions are manager.

By default this property is set to an instance of AtalaPixelFormatChanger.

See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace
DocumentPixelFormatChanger Class
AtalaPixelFormatChanger Class


AtalaImage.PixelMemory Property

AtalaImagePixelMemory Property

Provides access to the memory that represents an image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemory PixelMemory { get; }
Public ReadOnly Property PixelMemory As PixelMemory
    Get

Property Value

Type: PixelMemory
An object of type PixelMemory that encapsulates the representation of an image's memory.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Resolution Property

AtalaImageResolution Property

Get or set the Resolution of this AtalaImage object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; set; }
Public Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
The resolution, usually in Dots Per Inch of this AtalaImage object.
Remarks
If the image is loaded from a file, Resolution will contain the value stored in the file. The resolution will be persisted into new AtalaImage objects that are based off of this one.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.RowStride Property

AtalaImageRowStride Property

Get the number of bytes in each row of this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RowStride { get; }
Public ReadOnly Property RowStride As Integer
    Get

Property Value

Type: Int32
The number of bytes in each row of this image.

Return Value

Type: Int32
The number of bytes in each row of this AtalaImage.
Remarks
DIB images, which AtalaImage is based on, require the image data to be 32-bit aligned. If the width is not divisible by 4 bytes, then padding will be added to the width. This property returns the width including pixel data and padding.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Size Property

AtalaImageSize Property

Gets the size of this AtalaImage in pixels.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get

Property Value

Type: Size
The size of this AtalaImage in pixels.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace
AtalaImageWidth
AtalaImageHeight


AtalaImage.Width Property

AtalaImageWidth Property

Returns the width of this AtalaImage in pixels.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
The width of this AtalaImage in pixels.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace
AtalaImageSize
AtalaImageHeight


AtalaImage Methods

The AtalaImage type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep copy of this AtalaImage.
 | CombineChannels | Combines the channels.
Public method | CopyToClipboard | Copies the image data onto the clipboard.
Public method | CountColors | Count the number of unique colors in this AtalaImage.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Call this method to destroy this AtalaImage data and free memory.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Draw(Graphics, Rectangle) | Draws this AtalaImage onto a System.Drawing.Graphics object at a specified location and size.
Public method | Draw(Graphics, Rectangle, Rectangle) | Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.
Public method | Draw(Graphics, Rectangle, Rectangle, Boolean) | Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillRectangle(Rectangle, Color) | Fills a specified rectangle in this image with a specified solid color.
Public method | FillRectangle(Rectangle, Int32) | Fills a specified rectangle in this image with a specified index.
Protected method | Finalize | The Destructor that will automatically be called by the garbage collector (Overrides ObjectFinalize.)
Public method | Flip | Flips the image in the specified direction.
 | FromBitmap(Bitmap) | Returns an AtalaImage containing a copy of the Bitmap.
 | FromBitmap(Bitmap, Boolean) | Converts a specified Bitmap into an AtalaImage by taking ownership of the Bitmap data, or returning a copy of the Bitmap data.
 | FromBitmapData | Obsolete. Returns an %AtalaImage% that contains the same image pointer that's in the specified BitmapData object.
 | FromByteArray(Byte) | Creates a new AtalaImage from a byte array containing an encoded image.
 | FromByteArray(Byte, ProgressEventHandler) | Creates a new AtalaImage from a byte array containing an encoded image.
 | FromDib | Returns an AtalaImage from a DIB (Device Independent Bitmap) pointer.
 | FromHBitmap | Returns an AtalaImage from an hBitmap handle.
 | FromURL(String, Boolean, ProgressEventHandler) | Returns an AtalaImage loaded from the url.
 | FromURL(String, Int32, Boolean, ProgressEventHandler) | Returns an AtalaImage loaded from the url.
Public method | GetBitmap | Obsolete. Returns a System.Drawing.Bitmap object copied from this %AtalaImage%.
Public method | GetChangedPixelFormat(PixelFormat) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.
 | GetChangedPixelFormat(PixelFormat, ColorProfile) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.
Public method | GetChangedPixelFormat(PixelFormat, ColorProfile, Boolean) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage specifying a ColorProfile and if the ChangedPixelFormat event should fire.
Public method | GetGraphics | Returns a System.Drawing.Graphics object allowing GDI+ operations to draw onto this AtalaImage.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetObjectData | Used to serialize this AtalaImage.
 | GetPackedBuffer | Gets the packed buffer.
Public method | GetPixelCmykColor | Get the color of a pixel in CMYK space
Public method | GetPixelColor | Returns the System.Drawing.Color of the specified pixel in this AtalaImage.
 | GetPixelFormatDepth | Obsolete. Returns the color depth in bits per pixels associated with a specified PixelFormat.
Public method | GetPixelIndex | Gets the palette index of the specified pixel in this AtalaImage.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImageFromClipboard | Creates a new AtalaImage from data on the clipboard.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnChangePixelFormat | Raises the [E:ChangePixelFormat] event.
 | PixelFormatHasAlpha | Obsolete. Returns true if the specified PixelFormat contains an alpha channel.
 | PixelFormatIsColormapped | Obsolete. Returns true if the specified PixelFormat contains a palette.
 | PixelFormatIsContinuous | Obsolete. Returns true if the PixelFormat passed in is a continuous-tone format.
 | PixelFormatIsTwoBytePerComponent | Obsolete. This method can be used to determine if a PixelFormat is a "Two Byte Per Component" image format.
 | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves this AtalaImage to a Stream object specifying an ImageType.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves this %AtalaImage% to a file specifying an ImageEncoder and progress callback.
 | Save(String, ImageType, ProgressEventHandler) | Obsolete. Saves this AtalaImage to a file specifying an ImageType and a PixelFormat.
Public method | SetPixelCmykColor | Set the color of a pixel in CMYK space
Public method | SetPixelColor | Sets the color of the pixel.
Public method | SetPixelIndex | Sets the index of the pixel.
Public method | SplitChannels | Returns an array of grayscale AtalaImage objects representing each 8-bit or 16-bit channel in the source image.
Public method | SplitChannels(ChannelFlags) | Returns an array of grayscale %AtalaImage% objects representing specified 8-bit or 16-bit channels in the source image.
Public method | ToBitmap | Returns a Bitmap object from this AtalaImage data.
Public method | ToByteArray(ImageEncoder) | Returns a byte array containing an encoded image.
Public method | ToByteArray(ImageEncoder, ProgressEventHandler) | Returns a byte array containing an encoded image.
Public method | ToDib | Returns a pointer to a DIB (Device Independent Bitmap) copied from this AtalaImage.
Public method | ToDib(Stream) | Fills the given stream with a DIB (Device Independent Bitmap) copied from this AtalaImage.
Public method | ToString | Returns a textual description of this AtalaImage object. (Overrides ObjectToString.)
 | UnregisteredWatermark | Unregistereds the watermark.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Clone Method

AtalaImageClone Method

Returns a deep copy of this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A deep copy of this AtalaImage.

Implements

ICloneableClone
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.CombineChannels Method

AtalaImageCombineChannels Method

Combines the channels.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage CombineChannels(
    PixelFormat desiredPixelFormat,
    params AtalaImage[] channels
)
Public Shared Function CombineChannels (
    desiredPixelFormat As PixelFormat,
    ParamArray channels As AtalaImage()
) As AtalaImage

Parameters

desiredPixelFormat
Type: Atalasoft.ImagingPixelFormat
The desired pixel format.
channels
Type: Atalasoft.ImagingAtalaImage
The channels.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
ArgumentException | Must contain between 2 and 4 images;channels or All channel images must be of equal size;channels or All channel images must be grayscale;channels or PixelFormat does not match number of channels;desiredPixelFormat or PixelFormat does not match number of channels;desiredPixelFormat
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.CopyToClipboard Method

AtalaImageCopyToClipboard Method

Copies the image data onto the clipboard.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyToClipboard(
    IntPtr ownerHandle
)
Public Sub CopyToClipboard (
    ownerHandle As IntPtr
)

Parameters

ownerHandle
Type: SystemIntPtr
Handle to a window which will act as the clipboard parent.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.CountColors Method

AtalaImageCountColors Method

Count the number of unique colors in this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long CountColors()
Public Function CountColors As Long

Return Value

Type: Int64
The number of unique colors in this AtalaImage.
Remarks
For colormapped images, this method could return a different number of colors then what's stored in the Colors property. That is because this method actually loops through each pixel in the image to count the unique number of colors. However these colors might occupy more then the first x colors in the palette.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Dispose Method

AtalaImageDispose Method

Overload List
 | Name | Description
Public method | Dispose | Call this method to destroy this AtalaImage data and free memory.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Dispose Method

AtalaImageDispose Method

Call this method to destroy this AtalaImage data and free memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks

The garbage collector will eventually free this memory if dispose is not called. By calling Dispose the memory is freed immediately, important for images occupying many kilobytes of memory.

After the image is disposed, any function calls that access the AtalaImage.ImageData will result in an ObjectIsDisposedException.

See Also

Reference

AtalaImage Class
Dispose Overload
Atalasoft.Imaging Namespace


AtalaImage.Dispose Method (Boolean)

AtalaImageDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

AtalaImage Class
Dispose Overload
Atalasoft.Imaging Namespace


AtalaImage.Draw Method

AtalaImageDraw Method

Draws this AtalaImage to a graphics object.
Overload List
 | Name | Description
Public method | Draw(Graphics, Rectangle) | Draws this AtalaImage onto a System.Drawing.Graphics object at a specified location and size.
Public method | Draw(Graphics, Rectangle, Rectangle) | Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.
Public method | Draw(Graphics, Rectangle, Rectangle, Boolean) | Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Draw Method (Graphics, Rectangle)

AtalaImageDraw Method (Graphics, Rectangle)

Draws this AtalaImage onto a System.Drawing.Graphics object at a specified location and size.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Draw(
    Graphics graphics,
    Rectangle destRect
)
Public Sub Draw (
    graphics As Graphics,
    destRect As Rectangle
)

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object to draw on.
destRect
Type: System.DrawingRectangle
The rectangular area of the Graphics object to draw on.
Remarks
Unlike GDI+, this Draw method will not convert the image to 32-bit when drawing to a Graphics object.
See Also

Reference

AtalaImage Class
Draw Overload
Atalasoft.Imaging Namespace


AtalaImage.Draw Method (Graphics, Rectangle, Rectangle)

AtalaImageDraw Method (Graphics, Rectangle, Rectangle)

Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Draw(
    Graphics graphics,
    Rectangle destRect,
    Rectangle srcRect
)
Public Sub Draw (
    graphics As Graphics,
    destRect As Rectangle,
    srcRect As Rectangle
)

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object to draw on.
destRect
Type: System.DrawingRectangle
The rectangular area of the Graphics object to draw on.
srcRect
Type: System.DrawingRectangle
The rectangular area of the source image to draw.
See Also

Reference

AtalaImage Class
Draw Overload
Atalasoft.Imaging Namespace


AtalaImage.Draw Method (Graphics, Rectangle, Rectangle, Boolean)

AtalaImageDraw Method (Graphics, Rectangle, Rectangle, Boolean)

Draws a specified area of this AtalaImage onto a System.Drawing.Graphics object at the specified location and size.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Draw(
    Graphics graphics,
    Rectangle destRect,
    Rectangle srcRect,
    bool renderBottomTop
)
Public Sub Draw (
    graphics As Graphics,
    destRect As Rectangle,
    srcRect As Rectangle,
    renderBottomTop As Boolean
)

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object to draw on.
destRect
Type: System.DrawingRectangle
The rectangular area of the Graphics object to draw on.
srcRect
Type: System.DrawingRectangle
The rectangular area of the source image to draw.
renderBottomTop
Type: SystemBoolean
When true, the image will be forced to draw bottom to top.
Remarks
This method will draw the image onto a graphics object and convert to a bottom-top Bitmap if necessary. Some devices such as printers will fail when drawing a top-bottom image such as those internally stored in DotImage and .NET.
See Also

Reference

AtalaImage Class
Draw Overload
Atalasoft.Imaging Namespace


AtalaImage.FillRectangle Method

AtalaImageFillRectangle Method

Fills a rectangular area of an AtalaImage with a solid color.
Overload List
 | Name | Description
Public method | FillRectangle(Rectangle, Color) | Fills a specified rectangle in this image with a specified solid color.
Public method | FillRectangle(Rectangle, Int32) | Fills a specified rectangle in this image with a specified index.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FillRectangle Method (Rectangle, Color)

AtalaImageFillRectangle Method (Rectangle, Color)

Fills a specified rectangle in this image with a specified solid color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void FillRectangle(
    Rectangle rect,
    Color fillColor
)
Public Sub FillRectangle (
    rect As Rectangle,
    fillColor As Color
)

Parameters

rect
Type: System.DrawingRectangle
The rectangular area to fill.
fillColor
Type: System.DrawingColor
The color of the fill area.
Remarks
This method is faster then using the Drawing namespace to draw a simple solid rectangle.
See Also

Reference

AtalaImage Class
FillRectangle Overload
Atalasoft.Imaging Namespace


AtalaImage.FillRectangle Method (Rectangle, Int32)

AtalaImageFillRectangle Method (Rectangle, Int32)

Fills a specified rectangle in this image with a specified index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void FillRectangle(
    Rectangle rect,
    int fillIndex
)
Public Sub FillRectangle (
    rect As Rectangle,
    fillIndex As Integer
)

Parameters

rect
Type: System.DrawingRectangle
The rectangular area to fill.
fillIndex
Type: SystemInt32
The palette index or grayscale value to fill.
See Also

Reference

AtalaImage Class
FillRectangle Overload
Atalasoft.Imaging Namespace


AtalaImage.Finalize Method

AtalaImageFinalize Method

The Destructor that will automatically be called by the garbage collector

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Flip Method

AtalaImageFlip Method

Flips the image in the specified direction.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Flip(
    FlipDirection direction
)
Public Sub Flip (
    direction As FlipDirection
)

Parameters

direction
Type: Atalasoft.ImagingFlipDirection
The direction.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromBitmap Method

AtalaImageFromBitmap Method

Converts a specified Bitmap into an AtalaImage.
Overload List
Name | Description
FromBitmap(Bitmap) | Returns an AtalaImage containing a copy of the Bitmap.
FromBitmap(Bitmap, Boolean) | Converts a specified Bitmap into an AtalaImage by taking ownership of the Bitmap data, or returning a copy of the Bitmap data.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromBitmap Method (Bitmap)

AtalaImageFromBitmap Method (Bitmap)

Returns an AtalaImage containing a copy of the Bitmap.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromBitmap(
    Bitmap bitmap
)
Public Shared Function FromBitmap (
    bitmap As Bitmap
) As AtalaImage

Parameters

bitmap
Type: System.DrawingBitmap
The bitmap to create a copy from.

Return Value

Type: AtalaImage
A copy of the Bitmap data in the form of an AtalaImage object.
Remarks
It's up to the caller to dispose the Bitmap. The AtalaImage object does not own the bitmap data.
See Also

Reference

AtalaImage Class
FromBitmap Overload
Atalasoft.Imaging Namespace


AtalaImage.FromBitmap Method (Bitmap, Boolean)

AtalaImageFromBitmap Method (Bitmap, Boolean)

Converts a specified Bitmap into an AtalaImage by taking ownership of the Bitmap data, or returning a copy of the Bitmap data.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromBitmap(
    Bitmap bitmap,
    bool atalaImageWillOwnBitmap
)
Public Shared Function FromBitmap (
    bitmap As Bitmap,
    atalaImageWillOwnBitmap As Boolean
) As AtalaImage

Parameters

bitmap
Type: System.DrawingBitmap
The source Bitmap to convert
atalaImageWillOwnBitmap
Type: SystemBoolean
When true, the Bitmap data will be owned by the AtalaImage.

Return Value

Type: AtalaImage
A copy of a GDI+ System.Drawing.Bitmap object in the form of an AtalaImage object.
Remarks

When setting atalaImageWillOwnBitmap to true, do not Dispose the Bitmap. The AtalaImage object holds onto a reference to the Bitmap object, so the garbage collector will not free the Bitmap data until the host AtalaImage goes out of scope or is disposed.

When atalaImageWillOwnBitmap is false, a copy is returned and it's up to the caller to dispose the Bitmap.

See Also

Reference

AtalaImage Class
FromBitmap Overload
Atalasoft.Imaging Namespace


AtalaImage.FromBitmapData Method

AtalaImageFromBitmapData Method

Note: This API is now obsolete.

Returns an %AtalaImage% that contains the same image pointer that's in the specified BitmapData object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated.  Please use FromBitmap")]
public static AtalaImage FromBitmapData(
    BitmapData bd,
    ColorPalette palette
)
<ObsoleteAttribute("This method has been deprecated.  Please use FromBitmap")>
Public Shared Function FromBitmapData (
    bd As BitmapData,
    palette As ColorPalette
) As AtalaImage

Parameters

bd
Type: System.Drawing.ImagingBitmapData
The BitmapData created from a Bitmap by locking the bits.
palette
Type: System.Drawing.ImagingColorPalette
The palette of the Bitmap. Set to null (Nothing in Visual Basic) if the Bitmap doesn't contain a palette.

Return Value

Type: AtalaImage
An %AtalaImage% that contains the same image pointer that's in the specified BitmapData object.
Remarks
Use this method to set an existing Bitmap object to an AtalaImage without copying the data. This method should be used with care as the source Bitmap will always control the image memory, and can be disposed by the garbage collector if all references are removed.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromByteArray Method

AtalaImageFromByteArray Method

Creates a new AtalaImage from an image stored in a byte array.
Overload List
Name | Description
FromByteArray(Byte) | Creates a new AtalaImage from a byte array containing an encoded image.
FromByteArray(Byte, ProgressEventHandler) | Creates a new AtalaImage from a byte array containing an encoded image.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromByteArray Method (Byte[])

AtalaImageFromByteArray Method (Byte)

Creates a new AtalaImage from a byte array containing an encoded image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromByteArray(
    byte[] buffer
)
Public Shared Function FromByteArray (
    buffer As Byte()
) As AtalaImage

Parameters

buffer
Type: SystemByte
A byte array containing the encoded image.

Return Value

Type: AtalaImage
Remarks
Another method of accomplishing the same thing would be to create a MemoryStream from the byte array, and passing it into the AtalaImage constructor with a stream. This method was added for convenience.
See Also

Reference

AtalaImage Class
FromByteArray Overload
Atalasoft.Imaging Namespace


AtalaImage.FromByteArray Method (Byte[], ProgressEventHandler)

AtalaImageFromByteArray Method (Byte, ProgressEventHandler)

Creates a new AtalaImage from a byte array containing an encoded image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromByteArray(
    byte[] buffer,
    ProgressEventHandler progress
)
Public Shared Function FromByteArray (
    buffer As Byte(),
    progress As ProgressEventHandler
) As AtalaImage

Parameters

buffer
Type: SystemByte
A byte array containing the encoded image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

AtalaImage Class
FromByteArray Overload
Atalasoft.Imaging Namespace


AtalaImage.FromDib Method

AtalaImageFromDib Method

Returns an AtalaImage from a DIB (Device Independent Bitmap) pointer.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromDib(
    IntPtr dibPointer,
    bool copy
)
Public Shared Function FromDib (
    dibPointer As IntPtr,
    copy As Boolean
) As AtalaImage

Parameters

dibPointer
Type: SystemIntPtr
The DIB (device independent bitmap) pointer.
copy
Type: SystemBoolean
Indicates if the DIB data is copied into the AtalaImage .

Return Value

Type: AtalaImage
An AtalaImage from a DIB (Device Independent Bitmap) pointer.
Remarks
The memory will be handled and disposed by the returned AtalaImage object if copy is set to true.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromHBitmap Method

AtalaImageFromHBitmap Method

Returns an AtalaImage from an hBitmap handle.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromHBitmap(
    IntPtr hBitmap
)
Public Shared Function FromHBitmap (
    hBitmap As IntPtr
) As AtalaImage

Parameters

hBitmap
Type: SystemIntPtr
The hBitmap handle

Return Value

Type: AtalaImage
An AtalaImage from an hBitmap handle.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromURL Method

AtalaImageFromURL Method

Returns an AtalaImage decoded from a specified URL path.
Overload List
Name | Description
FromURL(String, Boolean, ProgressEventHandler) | Returns an AtalaImage loaded from the url.
FromURL(String, Int32, Boolean, ProgressEventHandler) | Returns an AtalaImage loaded from the url.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.FromURL Method (String, Boolean, ProgressEventHandler)

AtalaImageFromURL Method (String, Boolean, ProgressEventHandler)

Returns an AtalaImage loaded from the url.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromURL(
    string url,
    bool cacheOnClient,
    ProgressEventHandler progress
)
Public Shared Function FromURL (
    url As String,
    cacheOnClient As Boolean,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

url
Type: SystemString
The URL string
cacheOnClient
Type: SystemBoolean
When true, will cache the data on the client, using the IE Local cache
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress delegate

Return Value

Type: AtalaImage
The AtalaImage loaded from this URL.
See Also

Reference

AtalaImage Class
FromURL Overload
Atalasoft.Imaging Namespace


AtalaImage.FromURL Method (String, Int32, Boolean, ProgressEventHandler)

AtalaImageFromURL Method (String, Int32, Boolean, ProgressEventHandler)

Returns an AtalaImage loaded from the url.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage FromURL(
    string url,
    int frameIndex,
    bool cacheOnClient,
    ProgressEventHandler progress
)
Public Shared Function FromURL (
    url As String,
    frameIndex As Integer,
    cacheOnClient As Boolean,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

url
Type: SystemString
A URL to an image
frameIndex
Type: SystemInt32
The frame of the image to load from a multi-framed image.
cacheOnClient
Type: SystemBoolean
true if you want to cache the image in the local Windows Temporary Internet Files folder.
progress
Type: Atalasoft.ImagingProgressEventHandler
A handler to receive progress events while loading the image.

Return Value

Type: AtalaImage
The AtalaImage loaded from this URL.
See Also

Reference

AtalaImage Class
FromURL Overload
Atalasoft.Imaging Namespace


AtalaImage.GetBitmap Method

AtalaImageGetBitmap Method

Note: This API is now obsolete.

Returns a System.Drawing.Bitmap object copied from this %AtalaImage%.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetBitmap is obsolete.  Please use ToBitmap() instead.")]
public Bitmap GetBitmap()
<ObsoleteAttribute("GetBitmap is obsolete.  Please use ToBitmap() instead.")>
Public Function GetBitmap As Bitmap

Return Value

Type: Bitmap
A Bitmap object from this AtalaImage data.

Return Value

Type: Bitmap
A System.Drawing.Bitmap object copied from this %AtalaImage%.
Remarks
This method will always copy the image data into a new Bitmap object.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetChangedPixelFormat Method

AtalaImageGetChangedPixelFormat Method

Examples
GetChangedPixelFormat Example (C#)
Copy
// Load an image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");
AtalaImage converted = null;

// Convert the image to 8-bit Grayscale.
// Be sure the image is a different PixelFormat or an exception is thrown.
if (image.PixelFormat != PixelFormat.Pixel8bppGrayscale)
{
    converted = image.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale);
    image.Dispose();
}
else
    converted = image;
GetChangedPixelFormat Example (Visual Basic)
Copy
' Load an image.
Dim image As AtalaImage = New AtalaImage("D:\Test Images\1.jpg")
Dim converted As AtalaImage = Nothing

' Convert the image to 8-bit Grayscale.
' Be sure the image is a different PixelFormat or an exception is thrown.
If image.PixelFormat <> PixelFormat.Pixel8bppGrayscale Then
    converted = image.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale)
    image.Dispose()
Else
    converted = image
End If
This function converts an AtalaImage from one PixelFormat to another.
Overload List
 | Name | Description
Public method | GetChangedPixelFormat(PixelFormat) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.
 | GetChangedPixelFormat(PixelFormat, ColorProfile) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.
Public method | GetChangedPixelFormat(PixelFormat, ColorProfile, Boolean) | Returns a new AtalaImage object with a different PixelFormat from this AtalaImage specifying a ColorProfile and if the ChangedPixelFormat event should fire.
Top
Examples
GetChangedPixelFormat Example (C#)
Copy
// Load an image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");
AtalaImage converted = null;

// Convert the image to 8-bit Grayscale.
// Be sure the image is a different PixelFormat or an exception is thrown.
if (image.PixelFormat != PixelFormat.Pixel8bppGrayscale)
{
    converted = image.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale);
    image.Dispose();
}
else
    converted = image;
GetChangedPixelFormat Example (Visual Basic)
Copy
' Load an image.
Dim image As AtalaImage = New AtalaImage("D:\Test Images\1.jpg")
Dim converted As AtalaImage = Nothing

' Convert the image to 8-bit Grayscale.
' Be sure the image is a different PixelFormat or an exception is thrown.
If image.PixelFormat <> PixelFormat.Pixel8bppGrayscale Then
    converted = image.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale)
    image.Dispose()
Else
    converted = image
End If
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetChangedPixelFormat Method (PixelFormat)

AtalaImageGetChangedPixelFormat Method (PixelFormat)

Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetChangedPixelFormat(
    PixelFormat newPixelFormat
)
Public Function GetChangedPixelFormat (
    newPixelFormat As PixelFormat
) As AtalaImage

Parameters

newPixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat that the new AtalaImage will contain.

Return Value

Type: AtalaImage
An AtalaImage object from a Bitmap object.
See Also

Reference

AtalaImage Class
GetChangedPixelFormat Overload
Atalasoft.Imaging Namespace


AtalaImage.GetChangedPixelFormat Method (PixelFormat, ColorProfile)

AtalaImageGetChangedPixelFormat Method (PixelFormat, ColorProfile)

Returns a new AtalaImage object with a different PixelFormat from this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetChangedPixelFormat(
    PixelFormat newPixelFormat,
    ColorProfile destProfile
)
Public Function GetChangedPixelFormat (
    newPixelFormat As PixelFormat,
    destProfile As ColorProfile
) As AtalaImage

Parameters

newPixelFormat
Type: Atalasoft.ImagingPixelFormat
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile

Return Value

Type: AtalaImage
A new AtalaImage object with a different %PixelFormat% from this AtalaImage.
Remarks
The ChangePixelFormatCommand can also be used to change the pixelformat, using a Command.
See Also

Reference

AtalaImage Class
GetChangedPixelFormat Overload
Atalasoft.Imaging Namespace


AtalaImage.GetChangedPixelFormat Method (PixelFormat, ColorProfile, Boolean)

AtalaImageGetChangedPixelFormat Method (PixelFormat, ColorProfile, Boolean)

Returns a new AtalaImage object with a different PixelFormat from this AtalaImage specifying a ColorProfile and if the ChangedPixelFormat event should fire.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetChangedPixelFormat(
    PixelFormat newPixelFormat,
    ColorProfile destProfile,
    bool fireChangedPixelFormatEvent
)
Public Function GetChangedPixelFormat (
    newPixelFormat As PixelFormat,
    destProfile As ColorProfile,
    fireChangedPixelFormatEvent As Boolean
) As AtalaImage

Parameters

newPixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat that the new AtalaImage will contain.
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile
The color profile to use when converting to and from the CMYK colorspace.
fireChangedPixelFormatEvent
Type: SystemBoolean
Speicifies if the ChangedPixelFormat should fire.

Return Value

Type: AtalaImage
An AtalaImage object with a different PixelFormat from this AtalaImage.
See Also

Reference

AtalaImage Class
GetChangedPixelFormat Overload
Atalasoft.Imaging Namespace


AtalaImage.GetGraphics Method

AtalaImageGetGraphics Method

Returns a System.Drawing.Graphics object allowing GDI+ operations to draw onto this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Graphics GetGraphics()
Public Function GetGraphics As Graphics

Return Value

Type: Graphics
A System.Drawing.Graphics object allowing GDI+ operations to draw onto this AtalaImage.
Exceptions
Exception | Condition
 | Thrown by the .NET Framework if the Graphics object does not support an image of the source AtalaImage PixelFormat.
 | Thrown if the PixelFormat of this AtalaImage is not supported by a System.Drawing.Bitmap.
Remarks
A Graphics object can only be obtained with PixelFormats that support GDI+ drawing such as 24-bit RGB and 32-bit RGBA.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetObjectData Method

AtalaImageGetObjectData Method

Used to serialize this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo object used to store this AtalaImage.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Remarks
AtalaImage objects are serialized as PNG images.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetPackedBuffer Method

AtalaImageGetPackedBuffer Method

Gets the packed buffer.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage GetPackedBuffer(
    AtalaImage image
)
Public Shared Function GetPackedBuffer (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
ArgumentNullException | image
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetPixelCmykColor Method

AtalaImageGetPixelCmykColor Method

Get the color of a pixel in CMYK space

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmykColor GetPixelCmykColor(
    int x,
    int y
)
Public Function GetPixelCmykColor (
    x As Integer,
    y As Integer
) As CmykColor

Parameters

x
Type: SystemInt32
The x coordinate of the pixel
y
Type: SystemInt32
The y coordinate of the pixel

Return Value

Type: CmykColor
A structure of type CmykColor representing the color of the pixel.
Remarks
If the original image is not in CMYK, the color value will be converted to CMYK.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetPixelColor Method

AtalaImageGetPixelColor Method

Returns the System.Drawing.Color of the specified pixel in this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color GetPixelColor(
    int x,
    int y
)
Public Function GetPixelColor (
    x As Integer,
    y As Integer
) As Color

Parameters

x
Type: SystemInt32
x coordinate in the image.
y
Type: SystemInt32
y coordinate in the image.

Return Value

Type: Color
The System.Drawing.Color of the specified pixel.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetPixelFormatDepth Method

AtalaImageGetPixelFormatDepth Method

Note: This API is now obsolete.

Returns the color depth in bits per pixels associated with a specified PixelFormat.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use PixelFormatUtilities.BitsPerPixel")]
public static int GetPixelFormatDepth(
    PixelFormat pixelFormat
)
<ObsoleteAttribute("Please use PixelFormatUtilities.BitsPerPixel")>
Public Shared Function GetPixelFormatDepth (
    pixelFormat As PixelFormat
) As Integer

Parameters

pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat to retrieve the color depth from.

Return Value

Type: Int32
The color depth in bits per pixels associated with a specified PixelFormat.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.GetPixelIndex Method

AtalaImageGetPixelIndex Method

Gets the palette index of the specified pixel in this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte GetPixelIndex(
    int x,
    int y
)
Public Function GetPixelIndex (
    x As Integer,
    y As Integer
) As Byte

Parameters

x
Type: SystemInt32
x coordinate in the image.
y
Type: SystemInt32
y coordinate in the image.

Return Value

Type: Byte
The palette index of the specified pixel.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.ImageFromClipboard Method

AtalaImageImageFromClipboard Method

Creates a new AtalaImage from data on the clipboard.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage ImageFromClipboard(
    IntPtr ownerHandle
)
Public Shared Function ImageFromClipboard (
    ownerHandle As IntPtr
) As AtalaImage

Parameters

ownerHandle
Type: SystemIntPtr
Handle to a window which will act as the clipboard parent.

Return Value

Type: AtalaImage
An AtalaImage object or null on failure.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.OnChangePixelFormat Method

AtalaImageOnChangePixelFormat Method

Raises the [E:ChangePixelFormat] event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnChangePixelFormat(
    PixelFormatChangeEventArgs e
)
Protected Sub OnChangePixelFormat (
    e As PixelFormatChangeEventArgs
)

Parameters

e
Type: Atalasoft.ImagingPixelFormatChangeEventArgs
The PixelFormatChangeEventArgs instance containing the event data.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.PixelFormatHasAlpha Method

AtalaImagePixelFormatHasAlpha Method

Note: This API is now obsolete.

Returns true if the specified PixelFormat contains an alpha channel.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use PixelFormatUtilities.HasAlpha")]
public static bool PixelFormatHasAlpha(
    PixelFormat pixelFormat
)
<ObsoleteAttribute("Please use PixelFormatUtilities.HasAlpha")>
Public Shared Function PixelFormatHasAlpha (
    pixelFormat As PixelFormat
) As Boolean

Parameters

pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat to use when determining if there is an alpha channel.

Return Value

Type: Boolean
True if this AtalaImage contains an alpha channel.
Remarks
If this image is colormapped, the palette might contain an alpha value less than 255. If so the mapped pixel value will contain alpha even though this function returns false. Check if the palette has alpha to be sure.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.PixelFormatIsColormapped Method

AtalaImagePixelFormatIsColormapped Method

Note: This API is now obsolete.

Returns true if the specified PixelFormat contains a palette.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use PixelFormatUtilities.IsColorMapped")]
public static bool PixelFormatIsColormapped(
    PixelFormat pixelFormat
)
<ObsoleteAttribute("Please use PixelFormatUtilities.IsColorMapped")>
Public Shared Function PixelFormatIsColormapped (
    pixelFormat As PixelFormat
) As Boolean

Parameters

pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat to use when determining if there is an palette.

Return Value

Type: Boolean
True if this AtalaImage contains a palette, false if it does not.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.PixelFormatIsContinuous Method

AtalaImagePixelFormatIsContinuous Method

Note: This API is now obsolete.

Returns true if the PixelFormat passed in is a continuous-tone format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use PixelFormatUtilities.IsContinuous")]
public static bool PixelFormatIsContinuous(
    PixelFormat pixelFormat
)
<ObsoleteAttribute("Please use PixelFormatUtilities.IsContinuous")>
Public Shared Function PixelFormatIsContinuous (
    pixelFormat As PixelFormat
) As Boolean

Parameters

pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat to test for continuous-tone.

Return Value

Type: Boolean
true if continuous, false if not.
Remarks

A continuous-tone pixel format means that the pixel value is the intentity of the color or channel value. Colormapped images are not continuous.

See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.PixelFormatIsTwoBytePerComponent Method

AtalaImagePixelFormatIsTwoBytePerComponent Method

Note: This API is now obsolete.

This method can be used to determine if a PixelFormat is a "Two Byte Per Component" image format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use PixelFormatUtilities.IsMultiByte")]
public static bool PixelFormatIsTwoBytePerComponent(
    PixelFormat pixelFormat
)
<ObsoleteAttribute("Please use PixelFormatUtilities.IsMultiByte")>
Public Shared Function PixelFormatIsTwoBytePerComponent (
    pixelFormat As PixelFormat
) As Boolean

Parameters

pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat to test.

Return Value

Type: Boolean
True if the pixelFormat parameter is a "Two Byte Per Component" image format.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Save Method

AtalaImageSave Method

Saves this AtalaImage to a file or stream.
Examples
[New Example] (C#)
Copy
AtalaImage image = new AtalaImage(100, 100, PixelFormat.Pixel24bppBgr);
image.Save("c:\\test.jpg", new JpegEncoder(80), null);
[New Example] (Visual Basic)
Copy
AtalaImage image = New AtalaImage(100, 100, PixelFormat.Pixel24bppBgr)
image.Save("c:\test.jpg", New JpegEncoder(80), Nothing)
Overload List
 | Name | Description
 | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves this AtalaImage to a Stream object specifying an ImageType.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves this %AtalaImage% to a file specifying an ImageEncoder and progress callback.
 | Save(String, ImageType, ProgressEventHandler) | Obsolete. Saves this AtalaImage to a file specifying an ImageType and a PixelFormat.
Top
Examples
[New Example] (C#)
Copy
AtalaImage image = new AtalaImage(100, 100, PixelFormat.Pixel24bppBgr);
image.Save("c:\\test.jpg", new JpegEncoder(80), null);
[New Example] (Visual Basic)
Copy
AtalaImage image = New AtalaImage(100, 100, PixelFormat.Pixel24bppBgr)
image.Save("c:\test.jpg", New JpegEncoder(80), Nothing)
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.Save Method (Stream, ImageEncoder, ProgressEventHandler)

AtalaImageSave Method (Stream, ImageEncoder, ProgressEventHandler)

Saves this AtalaImage to a Stream object specifying an ImageType.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long Save(
    Stream stream,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Function Save (
    stream As Stream,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream containing the file which the image will be encoded to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Int64
The number of bytes saved to the file.
See Also

Reference

AtalaImage Class
Save Overload
Atalasoft.Imaging Namespace


AtalaImage.Save Method (String, ImageEncoder, ProgressEventHandler)

AtalaImageSave Method (String, ImageEncoder, ProgressEventHandler)

Saves this %AtalaImage% to a file specifying an ImageEncoder and progress callback.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long Save(
    string fileName,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Function Save (
    fileName As String,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
) As Long

Parameters

fileName
Type: SystemString
The filename to save this %AtalaImage% to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Int64
Remarks
This method can be used to save an image to an FTP server. If the fileName is pointing to an FTP server, you may need to include the username and password in the URL to allow the file to be saved.
See Also

Reference

AtalaImage Class
Save Overload
Atalasoft.Imaging Namespace


AtalaImage.Save Method (String, ImageType, ProgressEventHandler)

AtalaImageSave Method (String, ImageType, ProgressEventHandler)

Note: This API is now obsolete.

Saves this AtalaImage to a file specifying an ImageType and a PixelFormat.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)]
public long Save(
    string fileName,
    ImageType type,
    ProgressEventHandler progress
)
<ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)>
Public Function Save (
    fileName As String,
    type As ImageType,
    progress As ProgressEventHandler
) As Long

Parameters

fileName
Type: SystemString
The filename to save this %AtalaImage% to.
type
Type: Atalasoft.Imaging.CodecImageType
The image type to save this image as.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Int64
The number of bytes saved to the file.
Remarks

To specify encoder settings, use the overload containing the ImageEncoder parameter.

This method can be used to save an image to an FTP server. If the fileName is pointing to an FTP server, you may need to include the username and password in the URL to allow the file to be saved.

Examples
Save Method
See Also

Reference

AtalaImage Class
Save Overload
Atalasoft.Imaging Namespace


AtalaImage.SetPixelCmykColor Method

AtalaImageSetPixelCmykColor Method

Set the color of a pixel in CMYK space

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetPixelCmykColor(
    int x,
    int y,
    CmykColor newColor
)
Public Sub SetPixelCmykColor (
    x As Integer,
    y As Integer,
    newColor As CmykColor
)

Parameters

x
Type: SystemInt32
The X coordinate of the pixel
y
Type: SystemInt32
The Y coordinate of the pixel
newColor
Type: Atalasoft.ImagingCmykColor
The color to set
Remarks
If the image is not a CMYK image, newColor will be converted to the proper color space.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.SetPixelColor Method

AtalaImageSetPixelColor Method

Sets the color of the pixel.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetPixelColor(
    int x,
    int y,
    Color newColor
)
Public Sub SetPixelColor (
    x As Integer,
    y As Integer,
    newColor As Color
)

Parameters

x
Type: SystemInt32
The x.
y
Type: SystemInt32
The y.
newColor
Type: System.DrawingColor
The new color.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | x, y;One or more parameters are invalid for this image.
IncompatiblePixelFormatException | Pixel Format not compatible with SetPixelColor.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.SetPixelIndex Method

AtalaImageSetPixelIndex Method

Sets the index of the pixel.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetPixelIndex(
    int x,
    int y,
    byte value
)
Public Sub SetPixelIndex (
    x As Integer,
    y As Integer,
    value As Byte
)

Parameters

x
Type: SystemInt32
The x.
y
Type: SystemInt32
The y.
value
Type: SystemByte
The value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | x, y;One or more parameters are invalid for this image.
IncompatiblePixelFormatException | Image must be colormapped to use GetPixelIndex.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.SplitChannels Method

AtalaImageSplitChannels Method

Splits each color channel of this AtalaImage into separate images.
Overload List
 | Name | Description
Public method | SplitChannels | Returns an array of grayscale AtalaImage objects representing each 8-bit or 16-bit channel in the source image.
Public method | SplitChannels(ChannelFlags) | Returns an array of grayscale %AtalaImage% objects representing specified 8-bit or 16-bit channels in the source image.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.SplitChannels Method

AtalaImageSplitChannels Method

Returns an array of grayscale AtalaImage objects representing each 8-bit or 16-bit channel in the source image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage[] SplitChannels()
Public Function SplitChannels As AtalaImage()

Return Value

Type: AtalaImage
An array of grayscale AtalaImage objects composing of individual channels of the source image.
Remarks
The returned array contains grayscale images representing the source image channels in the same order as the channels are in the image. Keep in mind that this means a Pixel24bitRgb contains channels in the order of blue, green, and red.
See Also

Reference

AtalaImage Class
SplitChannels Overload
Atalasoft.Imaging Namespace


AtalaImage.SplitChannels Method (ChannelFlags)

AtalaImageSplitChannels Method (ChannelFlags)

Returns an array of grayscale %AtalaImage% objects representing specified 8-bit or 16-bit channels in the source image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage[] SplitChannels(
    ChannelFlags channels
)
Public Function SplitChannels (
    channels As ChannelFlags
) As AtalaImage()

Parameters

channels
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channels mask to apply. The returned array will contain a null AtalaImage if that particular channel's bit flag is not set.

Return Value

Type: AtalaImage
An array of grayscale %AtalaImage% objects representing specified 8-bit or 16-bit channels in the source image.
See Also

Reference

AtalaImage Class
SplitChannels Overload
Atalasoft.Imaging Namespace


AtalaImage.ToBitmap Method

AtalaImageToBitmap Method

Returns a Bitmap object from this AtalaImage data.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Bitmap ToBitmap()
Public Function ToBitmap As Bitmap

Return Value

Type: Bitmap
A Bitmap object from this AtalaImage data.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.ToByteArray Method

AtalaImageToByteArray Method

Saves this AtalaImage into a byte array.
Overload List
 | Name | Description
Public method | ToByteArray(ImageEncoder) | Returns a byte array containing an encoded image.
Public method | ToByteArray(ImageEncoder, ProgressEventHandler) | Returns a byte array containing an encoded image.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.ToByteArray Method (ImageEncoder)

AtalaImageToByteArray Method (ImageEncoder)

Returns a byte array containing an encoded image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray(
    ImageEncoder encoder
)
Public Function ToByteArray (
    encoder As ImageEncoder
) As Byte()

Parameters

encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.

Return Value

Type: Byte
A byte array containing an encoded image.
See Also

Reference

AtalaImage Class
ToByteArray Overload
Atalasoft.Imaging Namespace


AtalaImage.ToByteArray Method (ImageEncoder, ProgressEventHandler)

AtalaImageToByteArray Method (ImageEncoder, ProgressEventHandler)

Returns a byte array containing an encoded image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray(
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Function ToByteArray (
    encoder As ImageEncoder,
    progress As ProgressEventHandler
) As Byte()

Parameters

encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Byte
A byte array containing an encoded image.
See Also

Reference

AtalaImage Class
ToByteArray Overload
Atalasoft.Imaging Namespace


AtalaImage.ToDib Method

AtalaImageToDib Method

Generates a DIB (Device Independent Bitmap) from this AtalaImage.
Overload List
 | Name | Description
Public method | ToDib | Returns a pointer to a DIB (Device Independent Bitmap) copied from this AtalaImage.
Public method | ToDib(Stream) | Fills the given stream with a DIB (Device Independent Bitmap) copied from this AtalaImage.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.ToDib Method

AtalaImageToDib Method

Returns a pointer to a DIB (Device Independent Bitmap) copied from this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr ToDib()
Public Function ToDib As IntPtr

Return Value

Type: IntPtr
A DIB (device independent bitmap) pointer.
Remarks
The pointer must be freed by the calling application with GlobalFree or Marshal.FreeHGlobal.
See Also

Reference

AtalaImage Class
ToDib Overload
Atalasoft.Imaging Namespace


AtalaImage.ToDib Method (Stream)

AtalaImageToDib Method (Stream)

Fills the given stream with a DIB (Device Independent Bitmap) copied from this AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ToDib(
    Stream stream
)
Public Sub ToDib (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream which will be filled with the DIB
See Also

Reference

AtalaImage Class
ToDib Overload
Atalasoft.Imaging Namespace


AtalaImage.ToString Method

AtalaImageToString Method

Returns a textual description of this AtalaImage object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string containing the width, height and pixel format of this image.
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.UnregisteredWatermark Method

AtalaImageUnregisteredWatermark Method

Unregistereds the watermark.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage UnregisteredWatermark(
    AtalaImage image
)
Public Shared Function UnregisteredWatermark (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: AtalaImage
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage Events

The AtalaImage type exposes the following members.

Events
Name | Description
ChangePixelFormat | Occurs when the image data changes PixelFormats.
Top
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImage.ChangePixelFormat Event

AtalaImageChangePixelFormat Event

Occurs when the image data changes PixelFormats.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static event PixelFormatChangeEventHandler ChangePixelFormat
Public Shared Event ChangePixelFormat As PixelFormatChangeEventHandler

Value

Type: Atalasoft.ImagingPixelFormatChangeEventHandler
Remarks
This static event is usually fired when a particular method is not compatible with the current PixelFormat and it needs to be changed. By handling this event, you may show a dialog to the user that the current PixelFormat will be changed and allow that operation to be cancelled by setting the Cancel property in the PixelFormatChangeEventArgs to true.
Examples
ChangePixelFormat Example (C#)
Copy
// Setup the event handler.
AtalaImage.ChangePixelFormat += new PixelFormatChangeEventHandler(OnPixelFormatChange);

// Force the handler to cancel the operation.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");
AtalaImage gray = image.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale, null, true);

image.Dispose();
if (gray != null)
    gray.Dispose();

private void OnPixelFormatChange(object sender, PixelFormatChangeEventArgs e)
{
    // Don't allow a 24-bit image to be converted to 8-bit grayscale.
    if (e.CurrentPixelFormat == PixelFormat.Pixel24bppBgr && e.NewPixelFormat == PixelFormat.Pixel8bppGrayscale)
        e.Cancel = true;
}
ChangePixelFormat Example (Visual Basic)
Copy
Private  Sub OnPixelFormatChange(ByVal sender As Object, ByVal e As PixelFormatChangeEventArgs) Handles AtalaImage.ChangePixelFormat
    ' Don't allow a 24-bit image to be converted to 8-bit grayscale.
    If e.CurrentPixelFormat = PixelFormat.Pixel24bppBgr And e.NewPixelFormat = PixelFormat.Pixel8bppGrayscale Then
        e.Cancel = True
    End If
End Sub

' Force the handler to cancel the operation.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")
Dim gray As AtalaImage =  image.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale, Nothing, True)

image.Dispose()
If Not gray Is Nothing Then
    gray.Dispose()
End If
See Also

Reference

AtalaImage Class
Atalasoft.Imaging Namespace


AtalaImageEditor Class

Allows visual designers to add AtalaImage objects in design time.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
Atalasoft.ImagingAtalaImageEditor

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageEditor : UITypeEditor
Public Class AtalaImageEditor
    Inherits UITypeEditor

The AtalaImageEditor type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageEditor | Initializes a new instance of the AtalaImageEditor class.
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle method. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditorGetPaintValueSupported(ITypeDescriptorContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditorPaintValue(PaintValueEventArgs).)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


AtalaImageEditor Constructor

Initializes a new instance of the AtalaImageEditor class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageEditor()
Public Sub New
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor Properties

The AtalaImageEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor Methods

The AtalaImageEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle method. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditorGetPaintValueSupported(ITypeDescriptorContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditorPaintValue(PaintValueEventArgs).)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor.EditValue Method

AtalaImageEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object's value using the editor style indicated by the GetEditStyle method. (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

AtalaImageEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Edits the specified object's value using the editor style indicated by the GetEditStyle method.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.
provider
Type: SystemIServiceProvider
An IServiceProvider that this editor can use to obtain services.
value
Type: SystemObject
The object to edit.

Return Value

Type: Object
The new value of the object. If the value of the object has not changed, this should return the same object it was passed.
Exceptions
Exception | Condition
ArgumentNullException | provider;provider cannot be null
See Also

Reference

AtalaImageEditor Class
EditValue Overload
Atalasoft.Imaging Namespace


AtalaImageEditor.GetEditStyle Method

AtalaImageEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor.GetEditStyle Method (ITypeDescriptorContext)

AtalaImageEditorGetEditStyle Method (ITypeDescriptorContext)

Gets the editor style used by the EditValue(IServiceProvider, Object) method.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: UITypeEditorEditStyle
A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue(IServiceProvider, Object) method. If the UITypeEditor does not support this method, then GetEditStyle will return None.
See Also

Reference

AtalaImageEditor Class
GetEditStyle Overload
Atalasoft.Imaging Namespace


AtalaImageEditor.GetPaintValueSupported Method

AtalaImageEditorGetPaintValueSupported Method

Overload List
 | Name | Description
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Overrides UITypeEditorGetPaintValueSupported(ITypeDescriptorContext).)
Top
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor.GetPaintValueSupported Method (ITypeDescriptorContext)

AtalaImageEditorGetPaintValueSupported Method (ITypeDescriptorContext)

Indicates whether the specified context supports painting a representation of an object's value within the specified context.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool GetPaintValueSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPaintValueSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

Type: Boolean
true if PaintValue(Object, Graphics, Rectangle) is implemented; otherwise, false.
See Also

Reference

AtalaImageEditor Class
GetPaintValueSupported Overload
Atalasoft.Imaging Namespace


AtalaImageEditor.PaintValue Method

AtalaImageEditorPaintValue Method

Overload List
 | Name | Description
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Overrides UITypeEditorPaintValue(PaintValueEventArgs).)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Top
See Also

Reference

AtalaImageEditor Class
Atalasoft.Imaging Namespace


AtalaImageEditor.PaintValue Method (PaintValueEventArgs)

AtalaImageEditorPaintValue Method (PaintValueEventArgs)

Paints a representation of the value of an object using the specified PaintValueEventArgs.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void PaintValue(
    PaintValueEventArgs e
)
Public Overrides Sub PaintValue (
    e As PaintValueEventArgs
)

Parameters

e
Type: System.Drawing.DesignPaintValueEventArgs
A PaintValueEventArgs that indicates what to paint and where to paint it.
See Also

Reference

AtalaImageEditor Class
PaintValue Overload
Atalasoft.Imaging Namespace


AtalaInt128 Structure

A 128 bit Integer value type used in JPEG2000 metadata.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public struct AtalaInt128
Public Structure AtalaInt128

The AtalaInt128 type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaInt128(Byte) | Creates a new instance of AtalaInt128 from an array of bytes.
Public method | AtalaInt128(Int64) | Creates a new instance of AtalaInt128 from a long.
Public method | AtalaInt128(AtalaInt128) | Creates a new copy of an AtalaInt128.
Public method | AtalaInt128(Byte, Int32) | Creates a new instance of AtalaInt128 from an array of bytes.
Public method | AtalaInt128(String, Int32) | Creates a new instance of AtalaInt128 from a string.
Top
Methods
 | Name | Description
 | Add | Performs an addition of two AtalaInt128 objects.
 | BitwiseAnd | Performs a bitwise AND of two AtalaInt128 objects.
 | BitwiseOr | Performs a bitwise OR on two AtalaInt128 objects.
 | Compare | Compares two AtalaInt128 objects.
 | Decrement | Reduces the value by 1.
 | Divide | Performs a division on two AtalaInt128 objects.
Public method | Equals(Object) | Returns a value indicating whether another AtalaInt128 is equal to this instance. (Overrides ValueTypeEquals(Object).)
 | Equals(AtalaInt128, AtalaInt128) | Returns true if both AtalaInt128 objects are equal.
Public method | GetHashCode | Returns the hash code for this AtalaInt128. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Increment | Increments the AtalaInt128.
Public method | IntValue | Returns the lowest 4 bytes of the AtalaInt128 as an Integer.
 | LeftShift | Performs a left bit shift on an AtalaInt128.
Public method | LongValue | Returns the lowest 8 bytes of the AtalaInt128 as a Long.
 | Modulus | Performs a modulus calculation on two AtalaInt128 objects.
 | Multiply | Performs a multiplication operation on two AtalaInt128 objects.
 | Negate | Negates an AtalaInt128 object.
 | OnesComplement | Performs a bitwise complement on an AtalaInt128.
 | RightShift | Performs a right bit shift on an AtalaInt128.
 | Subtract | Performs a subtraction of two AtalaInt128 objects.
Public method | ToHexString | Returns a hex string with the contents of the AtalaInt128.
Public method | ToString | Returns a string representing the AtalaInt128 in base 10. (Overrides ValueTypeToString.)
Public method | ToString(Int32) | Returns a string representing the AtalaInt128 in sign-and-magnitude format in the specified radix.
 | Xor | Performs an XOR operation on two AtalaInt128 objects.
Top
Operators
Name | Description
Addition | operator overloading +
BitwiseAnd | Calculates the bit-wise AND of the two values
BitwiseOr | Calculates the bit-wise OR of the two values
Decrement | Decrements the specified value.
Division | Calculates the quotient of the two values
Equality | Calculates if the two values are equal.
ExclusiveOr | Calculates the bit-wise XOR of the two values
GreaterThan | Calculates if the first value is greater than the other.
GreaterThanOrEqual | Calculates if the first value is greater than or equal to the other.
(Int32 to AtalaInt128) | Overloading of the typecast operator
(Int64 to AtalaInt128) | Overloading of the typecast operator
Increment | increments the value
Inequality | Calculates if the two values are not equal.
LeftShift | Calculates the left shift the values
LessThan | Calculates if the first value is less than the other.
LessThanOrEqual | Calculates if the first value is less than or equal to the other.
Modulus | Calculates the remainder of the quotient of the two values
Multiply | Calculates the product between the two values
OnesComplement | Calculates the 1-s complement of the value
RightShift | Calculates the right shift the values
Subtraction | Calculates the difference between the two values
UnaryNegation | Calculates the 2-s compplement of the value
Top
See Also

Reference

Atalasoft.Imaging Namespace


AtalaInt128 Constructor

Overload List
 | Name | Description
Public method | AtalaInt128(Byte) | Creates a new instance of AtalaInt128 from an array of bytes.
Public method | AtalaInt128(Int64) | Creates a new instance of AtalaInt128 from a long.
Public method | AtalaInt128(AtalaInt128) | Creates a new copy of an AtalaInt128.
Public method | AtalaInt128(Byte, Int32) | Creates a new instance of AtalaInt128 from an array of bytes.
Public method | AtalaInt128(String, Int32) | Creates a new instance of AtalaInt128 from a string.
Top
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128 Constructor (Byte[])

AtalaInt128 Constructor (Byte)

Creates a new instance of AtalaInt128 from an array of bytes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128(
    byte[] inData
)
Public Sub New (
    inData As Byte()
)

Parameters

inData
Type: SystemByte

The byte values.

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Exceptions
Exception | Condition
 | Thrown if the inData argument is null (Nothing in VB).
 | Thrown if the inData argument contains too many bytes.
Remarks
Note that this method of initialization does not allow the sign to be specified.
See Also

Reference

AtalaInt128 Structure
AtalaInt128 Overload
Atalasoft.Imaging Namespace


AtalaInt128 Constructor (Int64)

Creates a new instance of AtalaInt128 from a long.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128(
    long value
)
Public Sub New (
    value As Long
)

Parameters

value
Type: SystemInt64
The value to use for the AtalaInt128.
See Also

Reference

AtalaInt128 Structure
AtalaInt128 Overload
Atalasoft.Imaging Namespace


AtalaInt128 Constructor (AtalaInt128)

Creates a new copy of an AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128(
    AtalaInt128 i128
)
Public Sub New (
    i128 As AtalaInt128
)

Parameters

i128
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to create a copy of.
See Also

Reference

AtalaInt128 Structure
AtalaInt128 Overload
Atalasoft.Imaging Namespace


AtalaInt128 Constructor (Byte[], Int32)

AtalaInt128 Constructor (Byte, Int32)

Creates a new instance of AtalaInt128 from an array of bytes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128(
    byte[] inData,
    int inLen
)
Public Sub New (
    inData As Byte(),
    inLen As Integer
)

Parameters

inData
Type: SystemByte

The byte values.

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

inLen
Type: SystemInt32
The number of bytes from the inData to use.
Exceptions
Exception | Condition
 | Thrown if the inLen is greater than the inData length or if inLen is greater than 4.
See Also

Reference

AtalaInt128 Structure
AtalaInt128 Overload
Atalasoft.Imaging Namespace


AtalaInt128 Constructor (String, Int32)

Creates a new instance of AtalaInt128 from a string.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128(
    string value,
    int radix
)
Public Sub New (
    value As String,
    radix As Integer
)

Parameters

value
Type: SystemString
The numeric string to build the AtalaInt128 from.
radix
Type: SystemInt32
The numeric base. Values of 10 and 16 are common.
Exceptions
Exception | Condition
 | Thrown if the value argument is null (Nothing in VB).
 | Thrown if the string value is invalid.
Remarks
Note that string values are specified in the lt;signgt;lt;magnitudegt; format.
See Also

Reference

AtalaInt128 Structure
AtalaInt128 Overload
Atalasoft.Imaging Namespace


AtalaInt128 Methods

The AtalaInt128 type exposes the following members.

Methods
 | Name | Description
 | Add | Performs an addition of two AtalaInt128 objects.
 | BitwiseAnd | Performs a bitwise AND of two AtalaInt128 objects.
 | BitwiseOr | Performs a bitwise OR on two AtalaInt128 objects.
 | Compare | Compares two AtalaInt128 objects.
 | Decrement | Reduces the value by 1.
 | Divide | Performs a division on two AtalaInt128 objects.
Public method | Equals(Object) | Returns a value indicating whether another AtalaInt128 is equal to this instance. (Overrides ValueTypeEquals(Object).)
 | Equals(AtalaInt128, AtalaInt128) | Returns true if both AtalaInt128 objects are equal.
Public method | GetHashCode | Returns the hash code for this AtalaInt128. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Increment | Increments the AtalaInt128.
Public method | IntValue | Returns the lowest 4 bytes of the AtalaInt128 as an Integer.
 | LeftShift | Performs a left bit shift on an AtalaInt128.
Public method | LongValue | Returns the lowest 8 bytes of the AtalaInt128 as a Long.
 | Modulus | Performs a modulus calculation on two AtalaInt128 objects.
 | Multiply | Performs a multiplication operation on two AtalaInt128 objects.
 | Negate | Negates an AtalaInt128 object.
 | OnesComplement | Performs a bitwise complement on an AtalaInt128.
 | RightShift | Performs a right bit shift on an AtalaInt128.
 | Subtract | Performs a subtraction of two AtalaInt128 objects.
Public method | ToHexString | Returns a hex string with the contents of the AtalaInt128.
Public method | ToString | Returns a string representing the AtalaInt128 in base 10. (Overrides ValueTypeToString.)
Public method | ToString(Int32) | Returns a string representing the AtalaInt128 in sign-and-magnitude format in the specified radix.
 | Xor | Performs an XOR operation on two AtalaInt128 objects.
Top
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Add Method

AtalaInt128Add Method

Performs an addition of two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Add(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Add (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.BitwiseAnd Method

AtalaInt128BitwiseAnd Method

Performs a bitwise AND of two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 BitwiseAnd(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function BitwiseAnd (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard AND operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.BitwiseOr Method

AtalaInt128BitwiseOr Method

Performs a bitwise OR on two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 BitwiseOr(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function BitwiseOr (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard OR operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Compare Method

AtalaInt128Compare Method

Compares two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int Compare(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Compare (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Integer

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 to compare.
bi2
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to compare against.

Return Value

Type: Int32
Returns -1 if bi1 is less than bi2, 1 of bi1 is greater than bi2 or 0 if the values are equal.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Decrement Method

AtalaInt128Decrement Method

Reduces the value by 1.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Decrement(
    AtalaInt128 bi1
)
Public Shared Function Decrement (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to decrement.

Return Value

Type: AtalaInt128
The new value.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Divide Method

AtalaInt128Divide Method

Performs a division on two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Divide(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Divide (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Divition operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Equals Method

AtalaInt128Equals Method

These methods are used to determine if two AtalaInt128 values are equal.
Overload List
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether another AtalaInt128 is equal to this instance. (Overrides ValueTypeEquals(Object).)
 | Equals(AtalaInt128, AtalaInt128) | Returns true if both AtalaInt128 objects are equal.
Top
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Equals Method (Object)

AtalaInt128Equals Method (Object)

Returns a value indicating whether another AtalaInt128 is equal to this instance.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An AtalaInt128 to test against.

Return Value

Type: Boolean
True if the value is equal to the AtalaInt128.
See Also

Reference

AtalaInt128 Structure
Equals Overload
Atalasoft.Imaging Namespace


AtalaInt128.Equals Method (AtalaInt128, AtalaInt128)

AtalaInt128Equals Method (AtalaInt128, AtalaInt128)

Returns true if both AtalaInt128 objects are equal.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool Equals(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Equals (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 to test.
bi2
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to test against.

Return Value

Type: Boolean
True if the values are equal.
See Also

Reference

AtalaInt128 Structure
Equals Overload
Atalasoft.Imaging Namespace


AtalaInt128.GetHashCode Method

AtalaInt128GetHashCode Method

Returns the hash code for this AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
The AtalaInt128 hash code.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Increment Method

AtalaInt128Increment Method

Increments the AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Increment(
    AtalaInt128 bi1
)
Public Shared Function Increment (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to increment.

Return Value

Type: AtalaInt128
The new value.
Remarks
The standard Increment operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.IntValue Method

AtalaInt128IntValue Method

Returns the lowest 4 bytes of the AtalaInt128 as an Integer.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IntValue()
Public Function IntValue As Integer

Return Value

Type: Int32
The lowest 4 bytes of the value.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.LeftShift Method

AtalaInt128LeftShift Method

Performs a left bit shift on an AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 LeftShift(
    AtalaInt128 bi1,
    int shiftVal
)
Public Shared Function LeftShift (
    bi1 As AtalaInt128,
    shiftVal As Integer
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to shift.
shiftVal
Type: SystemInt32
The amount to shift.

Return Value

Type: AtalaInt128
Remarks
The standard Left-Shift operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.LongValue Method

AtalaInt128LongValue Method

Returns the lowest 8 bytes of the AtalaInt128 as a Long.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long LongValue()
Public Function LongValue As Long

Return Value

Type: Int64
The lowest 8 bytes of the value.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Modulus Method

AtalaInt128Modulus Method

Performs a modulus calculation on two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Modulus(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Modulus (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Modulus operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Multiply Method

AtalaInt128Multiply Method

Performs a multiplication operation on two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Multiply(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Multiply (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Multiplication operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Negate Method

AtalaInt128Negate Method

Negates an AtalaInt128 object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Negate(
    AtalaInt128 bi1
)
Public Shared Function Negate (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to negate.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Negate operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.OnesComplement Method

AtalaInt128OnesComplement Method

Performs a bitwise complement on an AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 OnesComplement(
    AtalaInt128 bi1
)
Public Shared Function OnesComplement (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 for this calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Bitwise Complement operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.RightShift Method

AtalaInt128RightShift Method

Performs a right bit shift on an AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 RightShift(
    AtalaInt128 bi1,
    int shiftVal
)
Public Shared Function RightShift (
    bi1 As AtalaInt128,
    shiftVal As Integer
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The AtalaInt128 to shift.
shiftVal
Type: SystemInt32
The amount of shifting to apply.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Right-Shift operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Subtract Method

AtalaInt128Subtract Method

Performs a subtraction of two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Subtract(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Subtract (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.ToHexString Method

AtalaInt128ToHexString Method

Returns a hex string with the contents of the AtalaInt128.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToHexString()
Public Function ToHexString As String

Return Value

Type: String
A hex string representation of the AtalaInt128.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.ToString Method

AtalaInt128ToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string representing the AtalaInt128 in base 10. (Overrides ValueTypeToString.)
Public method | ToString(Int32) | Returns a string representing the AtalaInt128 in sign-and-magnitude format in the specified radix.
Top
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.ToString Method

AtalaInt128ToString Method

Returns a string representing the AtalaInt128 in base 10.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representing the AtalaInt128 in base 10.
See Also

Reference

AtalaInt128 Structure
ToString Overload
Atalasoft.Imaging Namespace


AtalaInt128.ToString Method (Int32)

AtalaInt128ToString Method (Int32)

Returns a string representing the AtalaInt128 in sign-and-magnitude format in the specified radix.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToString(
    int radix
)
Public Function ToString (
    radix As Integer
) As String

Parameters

radix
Type: SystemInt32
The numeric base to use in the string.

Return Value

Type: String
A string representing the AtalaInt128 in sign-and-magnitude format in the specified radix.
See Also

Reference

AtalaInt128 Structure
ToString Overload
Atalasoft.Imaging Namespace


AtalaInt128.Xor Method

AtalaInt128Xor Method

Performs an XOR operation on two AtalaInt128 objects.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 Xor(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Function Xor (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The first AtalaInt128 in the calculation.
bi2
Type: Atalasoft.ImagingAtalaInt128
The second AtalaInt128 in the calculation.

Return Value

Type: AtalaInt128
The results of the calculation.
Remarks
The standard Exclusive Or operator can be used on AtalaInt128 object instead of calling this method.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128 Operators and Type Conversions

The AtalaInt128 type exposes the following members.

Operators
Name | Description
Addition | operator overloading +
BitwiseAnd | Calculates the bit-wise AND of the two values
BitwiseOr | Calculates the bit-wise OR of the two values
Decrement | Decrements the specified value.
Division | Calculates the quotient of the two values
Equality | Calculates if the two values are equal.
ExclusiveOr | Calculates the bit-wise XOR of the two values
GreaterThan | Calculates if the first value is greater than the other.
GreaterThanOrEqual | Calculates if the first value is greater than or equal to the other.
(Int32 to AtalaInt128) | Overloading of the typecast operator
(Int64 to AtalaInt128) | Overloading of the typecast operator
Increment | increments the value
Inequality | Calculates if the two values are not equal.
LeftShift | Calculates the left shift the values
LessThan | Calculates if the first value is less than the other.
LessThanOrEqual | Calculates if the first value is less than or equal to the other.
Modulus | Calculates the remainder of the quotient of the two values
Multiply | Calculates the product between the two values
OnesComplement | Calculates the 1-s complement of the value
RightShift | Calculates the right shift the values
Subtraction | Calculates the difference between the two values
UnaryNegation | Calculates the 2-s compplement of the value
Top
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Addition Operator

AtalaInt128Addition Operator

operator overloading +

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator +(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator + (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
AtalaInt128
bi2
Type: Atalasoft.ImagingAtalaInt128
AtalaInt128

Return Value

Type: AtalaInt128
AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.BitwiseAnd Operator

AtalaInt128BitwiseAnd Operator

Calculates the bit-wise AND of the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator &(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator And (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.BitwiseOr Operator

AtalaInt128BitwiseOr Operator

Calculates the bit-wise OR of the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator |(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator Or (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Decrement Operator

AtalaInt128Decrement Operator

Decrements the specified value.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator --(
    AtalaInt128 bi1
)
Public Shared Operator -- (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.

Return Value

Type: AtalaInt128
Exceptions
Exception | Condition
ArithmeticException | Underflow in --.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Division Operator

AtalaInt128Division Operator

Calculates the quotient of the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator /(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator / (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Equality Operator

AtalaInt128Equality Operator

Calculates if the two values are equal.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator = (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: Boolean
true if equal, false otherwise
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.ExclusiveOr Operator

AtalaInt128ExclusiveOr Operator

Calculates the bit-wise XOR of the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator ^(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator Xor (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.GreaterThan Operator

AtalaInt128GreaterThan Operator

Calculates if the first value is greater than the other.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator >(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator > (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: Boolean
true if the first is greater, false otherwise
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.GreaterThanOrEqual Operator

AtalaInt128GreaterThanOrEqual Operator

Calculates if the first value is greater than or equal to the other.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator >=(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator >= (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: Boolean
true if the first is greater than or equal, false otherwise
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128 Implicit Conversion Operators

AtalaInt128 Conversion Operators

Overload List
Name | Description
(Int32 to AtalaInt128) | Overloading of the typecast operator
(Int64 to AtalaInt128) | Overloading of the typecast operator
Top
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128 Implicit Conversion (Int32 to AtalaInt128)

AtalaInt128 Conversion (Int32 to AtalaInt128)

Overloading of the typecast operator

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static implicit operator AtalaInt128 (
    int value
)
Public Shared Widening Operator CType (
    value As Integer
) As AtalaInt128

Parameters

value
Type: SystemInt32
int

Return Value

Type: AtalaInt128
AtalaInt128
See Also

Reference

AtalaInt128 Structure
Overload
Atalasoft.Imaging Namespace


AtalaInt128 Implicit Conversion (Int64 to AtalaInt128)

AtalaInt128 Conversion (Int64 to AtalaInt128)

Overloading of the typecast operator

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static implicit operator AtalaInt128 (
    long value
)
Public Shared Widening Operator CType (
    value As Long
) As AtalaInt128

Parameters

value
Type: SystemInt64
long

Return Value

Type: AtalaInt128
AtalaInt128
See Also

Reference

AtalaInt128 Structure
Overload
Atalasoft.Imaging Namespace


AtalaInt128.Increment Operator

AtalaInt128Increment Operator

increments the value

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator ++(
    AtalaInt128 bi1
)
Public Shared Operator ++ (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Inequality Operator

AtalaInt128Inequality Operator

Calculates if the two values are not equal.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator <> (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: Boolean
true if not equal, false otherwise
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.LeftShift Operator

AtalaInt128LeftShift Operator

Calculates the left shift the values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator <<(
    AtalaInt128 bi1,
    int shiftVal
)
Public Shared Operator << (
    bi1 As AtalaInt128,
    shiftVal As Integer
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
shiftVal
Type: SystemInt32
The shift.

Return Value

Type: AtalaInt128
Exceptions
Exception | Condition
ArithmeticException | Multiplication overflow. or Multiplication overflow.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.LessThan Operator

AtalaInt128LessThan Operator

Calculates if the first value is less than the other.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator <(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator < (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: Boolean
true if the first is less, false otherwise
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.LessThanOrEqual Operator

AtalaInt128LessThanOrEqual Operator

Calculates if the first value is less than or equal to the other.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator <=(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator <= (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As Boolean

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: Boolean
true if the first is less than or equal, false otherwise
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Modulus Operator

AtalaInt128Modulus Operator

Calculates the remainder of the quotient of the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator %(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator Mod (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Multiply Operator

AtalaInt128Multiply Operator

Calculates the product between the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator *(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator * (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
Exceptions
Exception | Condition
ArithmeticException | Multiplication overflow. or Multiplication overflow.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.OnesComplement Operator

AtalaInt128OnesComplement Operator

Calculates the 1-s complement of the value

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator ~(
    AtalaInt128 bi1
)
Public Shared Operator ~ (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.RightShift Operator

AtalaInt128RightShift Operator

Calculates the right shift the values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator >>(
    AtalaInt128 bi1,
    int shiftVal
)
Public Shared Operator >> (
    bi1 As AtalaInt128,
    shiftVal As Integer
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
shiftVal
Type: SystemInt32
The shift.

Return Value

Type: AtalaInt128
Exceptions
Exception | Condition
ArithmeticException | Multiplication overflow. or Multiplication overflow.
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.Subtraction Operator

AtalaInt128Subtraction Operator

Calculates the difference between the two values

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator -(
    AtalaInt128 bi1,
    AtalaInt128 bi2
)
Public Shared Operator - (
    bi1 As AtalaInt128,
    bi2 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.
bi2
Type: Atalasoft.ImagingAtalaInt128
The bi2.

Return Value

Type: AtalaInt128
Exceptions
Exception | Condition
ArithmeticException |
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128.UnaryNegation Operator

AtalaInt128UnaryNegation Operator

Calculates the 2-s compplement of the value

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaInt128 operator -(
    AtalaInt128 bi1
)
Public Shared Operator - (
    bi1 As AtalaInt128
) As AtalaInt128

Parameters

bi1
Type: Atalasoft.ImagingAtalaInt128
The bi1.

Return Value

Type: AtalaInt128
See Also

Reference

AtalaInt128 Structure
Atalasoft.Imaging Namespace


AtalaInt128Collection Class

A collection of AtalaInt128 structures.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.ImagingAtalaInt128Collection

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaInt128Collection : CollectionBase
Public Class AtalaInt128Collection
    Inherits CollectionBase

The AtalaInt128Collection type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaInt128Collection | Constructor
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Indexer
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds 'source' to the end of the CollectionBase.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the CollectionBase contains 'source'.
Public method | CopyTo | Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.
Public method | Insert | Inserts 'source' into the CollectionBase at 'index'.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of 'source' from the CollectionBase.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


AtalaInt128Collection Constructor

Constructor

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128Collection()
Public Sub New
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection Properties

The AtalaInt128Collection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Indexer
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.Item Property

AtalaInt128CollectionItem Property

Indexer

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaInt128 this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As AtalaInt128
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: AtalaInt128
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection Methods

The AtalaInt128Collection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds 'source' to the end of the CollectionBase.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the CollectionBase contains 'source'.
Public method | CopyTo | Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.
Public method | Insert | Inserts 'source' into the CollectionBase at 'index'.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of 'source' from the CollectionBase.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.Add Method

AtalaInt128CollectionAdd Method

Adds 'source' to the end of the CollectionBase.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AtalaInt128 source
)
Public Sub Add (
    source As AtalaInt128
)

Parameters

source
Type: Atalasoft.ImagingAtalaInt128
given object of UuidBox
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.Contains Method

AtalaInt128CollectionContains Method

Determines whether the CollectionBase contains 'source'.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    AtalaInt128 source
)
Public Function Contains (
    source As AtalaInt128
) As Boolean

Parameters

source
Type: Atalasoft.ImagingAtalaInt128
given object of UuidBox

Return Value

Type: Boolean
boolean
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.CopyTo Method

AtalaInt128CollectionCopyTo Method

Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    AtalaInt128[] dest,
    int index
)
Public Sub CopyTo (
    dest As AtalaInt128(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.ImagingAtalaInt128
target array of UuidBox
index
Type: SystemInt32
index of target array
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.IndexOf Method

AtalaInt128CollectionIndexOf Method

Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    AtalaInt128 source
)
Public Function IndexOf (
    source As AtalaInt128
) As Integer

Parameters

source
Type: Atalasoft.ImagingAtalaInt128
given object of UuidBox

Return Value

Type: Int32
the zero-based index of the first occurrence
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.Insert Method

AtalaInt128CollectionInsert Method

Inserts 'source' into the CollectionBase at 'index'.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AtalaInt128 source
)
Public Sub Insert (
    index As Integer,
    source As AtalaInt128
)

Parameters

index
Type: SystemInt32
specified index
source
Type: Atalasoft.ImagingAtalaInt128
given object of UuidBox
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaInt128Collection.Remove Method

AtalaInt128CollectionRemove Method

Removes the first occurrence of 'source' from the CollectionBase.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AtalaInt128 source
)
Public Sub Remove (
    source As AtalaInt128
)

Parameters

source
Type: Atalasoft.ImagingAtalaInt128
given object of UuidBox
See Also

Reference

AtalaInt128Collection Class
Atalasoft.Imaging Namespace


AtalaPixelFormatChanger Class

This is the standard PixelFormat changer class.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingPixelFormatChanger
Atalasoft.ImagingAtalaPixelFormatChanger

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaPixelFormatChanger : PixelFormatChanger
Public Class AtalaPixelFormatChanger
    Inherits PixelFormatChanger

The AtalaPixelFormatChanger type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaPixelFormatChanger | Initializes a new instance of the AtalaPixelFormatChanger class
Top
Properties
 | Name | Description
Public property | DitherErrorMax | Gets or sets the diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.
Top
Methods
 | Name | Description
Public method | ChangePixelFormat | Allocate a new AtalaImage based on the sourceImage, using the requested pixel format. (Inherited from PixelFormatChanger.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LowLevelChangePixelFormat | Lows level implementation to change pixel format. (Overrides PixelFormatChangerLowLevelChangePixelFormat(AtalaImage, PixelFormat, ColorProfile).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

The AtalaPixelFormatChanger does standard conversion between all differing pixel formats. Note that when converting from a pixel format that represents a large amount of data to a pixel format that represents a lesser amount of data, information will be lost. Therefore, it is not possible to perform an accurate round trip conversion.

When converting to a palette image (8-bit indexed or less) this will use Floyd Steinberg Dithering. See DocumentPixelFormatChanger for converting document images.

See Also

Reference

Atalasoft.Imaging Namespace
DocumentPixelFormatChanger Class


AtalaPixelFormatChanger Constructor

Initializes a new instance of the AtalaPixelFormatChanger class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPixelFormatChanger()
Public Sub New
See Also

Reference

AtalaPixelFormatChanger Class
Atalasoft.Imaging Namespace


AtalaPixelFormatChanger Properties

The AtalaPixelFormatChanger type exposes the following members.

Properties
 | Name | Description
Public property | DitherErrorMax | Gets or sets the diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.
Top
See Also

Reference

AtalaPixelFormatChanger Class
Atalasoft.Imaging Namespace


AtalaPixelFormatChanger.DitherErrorMax Property

AtalaPixelFormatChangerDitherErrorMax Property

Gets or sets the diffusion or dither error that's applied to an image when converting to from a continuous tone to colormapped format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DitherErrorMax { get; set; }
Public Property DitherErrorMax As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

AtalaPixelFormatChanger Class
Atalasoft.Imaging Namespace


AtalaPixelFormatChanger Methods

The AtalaPixelFormatChanger type exposes the following members.

Methods
 | Name | Description
Public method | ChangePixelFormat | Allocate a new AtalaImage based on the sourceImage, using the requested pixel format. (Inherited from PixelFormatChanger.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LowLevelChangePixelFormat | Lows level implementation to change pixel format. (Overrides PixelFormatChangerLowLevelChangePixelFormat(AtalaImage, PixelFormat, ColorProfile).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaPixelFormatChanger Class
Atalasoft.Imaging Namespace


AtalaPixelFormatChanger.LowLevelChangePixelFormat Method

AtalaPixelFormatChangerLowLevelChangePixelFormat Method

Lows level implementation to change pixel format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage LowLevelChangePixelFormat(
    AtalaImage sourceImage,
    PixelFormat newPixelFormat,
    ColorProfile destProfile
)
Protected Overrides Function LowLevelChangePixelFormat (
    sourceImage As AtalaImage,
    newPixelFormat As PixelFormat,
    destProfile As ColorProfile
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
newPixelFormat
Type: Atalasoft.ImagingPixelFormat
The new pixel format.
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile
The dest profile.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
IncompatiblePixelFormatException |
See Also

Reference

AtalaPixelFormatChanger Class
Atalasoft.Imaging Namespace


AtalasoftLicenseException Class

Summary description for AtalasoftLicenseException.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingAtalasoftLicenseException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public sealed class AtalasoftLicenseException : Exception
<SerializableAttribute>
Public NotInheritable Class AtalasoftLicenseException
    Inherits Exception

The AtalasoftLicenseException type exposes the following members.

Constructors
 | Name | Description
Public method | AtalasoftLicenseException | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(String) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(String, Exception) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type, Object) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type, Object, String) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type, Object, String, Exception) | Initializes a new instance of the AtalasoftLicenseException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Instance |
Public property | LicensedType |
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor

Overload List
 | Name | Description
Public method | AtalasoftLicenseException | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(String) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(String, Exception) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type, Object) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type, Object, String) | Initializes a new instance of the AtalasoftLicenseException class
Public method | AtalasoftLicenseException(Type, Object, String, Exception) | Initializes a new instance of the AtalasoftLicenseException class
Top
See Also

Reference

AtalasoftLicenseException Class
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException()
Public Sub New
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor (String)

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor (Type)

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException(
    Type type
)
Public Sub New (
    type As Type
)

Parameters

type
Type: SystemType
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor (String, Exception)

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor (Type, Object)

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException(
    Type type,
    Object instance
)
Public Sub New (
    type As Type,
    instance As Object
)

Parameters

type
Type: SystemType
instance
Type: SystemObject
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor (Type, Object, String)

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException(
    Type type,
    Object instance,
    string message
)
Public Sub New (
    type As Type,
    instance As Object,
    message As String
)

Parameters

type
Type: SystemType
instance
Type: SystemObject
message
Type: SystemString
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Constructor (Type, Object, String, Exception)

Initializes a new instance of the AtalasoftLicenseException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftLicenseException(
    Type type,
    Object instance,
    string message,
    Exception innerException
)
Public Sub New (
    type As Type,
    instance As Object,
    message As String,
    innerException As Exception
)

Parameters

type
Type: SystemType
instance
Type: SystemObject
message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

AtalasoftLicenseException Class
AtalasoftLicenseException Overload
Atalasoft.Imaging Namespace


AtalasoftLicenseException Properties

The AtalasoftLicenseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Instance |
Public property | LicensedType |
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AtalasoftLicenseException Class
Atalasoft.Imaging Namespace


AtalasoftLicenseException.Instance Property

AtalasoftLicenseExceptionInstance Property

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Instance { get; }
Public ReadOnly Property Instance As Object
    Get

Property Value

Type: Object
See Also

Reference

AtalasoftLicenseException Class
Atalasoft.Imaging Namespace


AtalasoftLicenseException.LicensedType Property

AtalasoftLicenseExceptionLicensedType Property

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Type LicensedType { get; }
Public ReadOnly Property LicensedType As Type
    Get

Property Value

Type: Type
See Also

Reference

AtalasoftLicenseException Class
Atalasoft.Imaging Namespace


AtalasoftLicenseException Methods

The AtalasoftLicenseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AtalasoftLicenseException Class
Atalasoft.Imaging Namespace


AtalasoftLicenseException.GetObjectData Method

AtalasoftLicenseExceptionGetObjectData Method

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AtalasoftLicenseException Class
Atalasoft.Imaging Namespace


BinaryPaletteEnforcer Class

A ResourceReleaserT that inverts a 1BPP AtalaImage on creation if it does not have the desired photometric interpretation, and inverts it again at the end of its lifetime.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingResourceReleaser BinaryPaletteEnforcerEnforcerState
Atalasoft.ImagingBinaryPaletteEnforcer

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BinaryPaletteEnforcer : ResourceReleaser<BinaryPaletteEnforcerEnforcerState>
Public Class BinaryPaletteEnforcer
    Inherits ResourceReleaser(Of BinaryPaletteEnforcerEnforcerState)

The BinaryPaletteEnforcer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser. (Inherited from ResourceReleaserT.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ResourceReleaserT.)
 | EnforceMinIsBlack | Returns an instance of a BinaryPaletteEnforcer that enforces a MinIsBlack photometric interpretation of the image until it is released.
 | EnforceMinIsWhite | Returns an instance of a BinaryPaletteEnforcer that enforces a MinIsWhite photometric interpretation of the image until it is released.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ResourceReleaserT class. (Inherited from ResourceReleaserT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | mVal | The backing field for the val parameter. (Inherited from ResourceReleaserT.)
Top
Remarks
The photometric interpretation of a 1BPP image corresponds to the order of its two palette entries. MinIsWhite corresponds to the 0-index representing white pixels, and MinIsBlack corresponds to the 0-index representing black pixels.
See Also

Reference

Atalasoft.Imaging Namespace


BinaryPaletteEnforcer Methods

The BinaryPaletteEnforcer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser. (Inherited from ResourceReleaserT.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ResourceReleaserT.)
 | EnforceMinIsBlack | Returns an instance of a BinaryPaletteEnforcer that enforces a MinIsBlack photometric interpretation of the image until it is released.
 | EnforceMinIsWhite | Returns an instance of a BinaryPaletteEnforcer that enforces a MinIsWhite photometric interpretation of the image until it is released.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ResourceReleaserT class. (Inherited from ResourceReleaserT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BinaryPaletteEnforcer Class
Atalasoft.Imaging Namespace


BinaryPaletteEnforcer.EnforceMinIsBlack Method

BinaryPaletteEnforcerEnforceMinIsBlack Method

Returns an instance of a BinaryPaletteEnforcer that enforces a MinIsBlack photometric interpretation of the image until it is released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static BinaryPaletteEnforcer EnforceMinIsBlack(
    AtalaImage image
)
Public Shared Function EnforceMinIsBlack (
    image As AtalaImage
) As BinaryPaletteEnforcer

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to enforce upon.

Return Value

Type: BinaryPaletteEnforcer
An auto-releasing ResourceReleaserT.
See Also

Reference

BinaryPaletteEnforcer Class
Atalasoft.Imaging Namespace


BinaryPaletteEnforcer.EnforceMinIsWhite Method

BinaryPaletteEnforcerEnforceMinIsWhite Method

Returns an instance of a BinaryPaletteEnforcer that enforces a MinIsWhite photometric interpretation of the image until it is released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static BinaryPaletteEnforcer EnforceMinIsWhite(
    AtalaImage image
)
Public Shared Function EnforceMinIsWhite (
    image As AtalaImage
) As BinaryPaletteEnforcer

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to enforce upon.

Return Value

Type: BinaryPaletteEnforcer
An auto-releasing ResourceReleaserT.
See Also

Reference

BinaryPaletteEnforcer Class
Atalasoft.Imaging Namespace


BinaryPaletteEnforcer Fields

The BinaryPaletteEnforcer type exposes the following members.

Fields
 | Name | Description
Protected field | mVal | The backing field for the val parameter. (Inherited from ResourceReleaserT.)
Top
See Also

Reference

BinaryPaletteEnforcer Class
Atalasoft.Imaging Namespace


BinaryPaletteEnforcer.EnforcerState Class

BinaryPaletteEnforcerEnforcerState Class

The internal state of a BinaryPaletteEnforcer instance.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingBinaryPaletteEnforcerEnforcerState

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EnforcerState
Public Class EnforcerState

The BinaryPaletteEnforcerEnforcerState type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryPaletteEnforcerEnforcerState | Creates a new instance of a BinaryPaletteEnforcer state object with a given image and enforcement.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | Releases the image from enforcement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


BinaryPaletteEnforcer.EnforcerState Constructor

BinaryPaletteEnforcerEnforcerState Constructor

Creates a new instance of a BinaryPaletteEnforcer state object with a given image and enforcement.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EnforcerState(
    AtalaImage image,
    bool enforceMinIsWhite
)
Public Sub New (
    image As AtalaImage,
    enforceMinIsWhite As Boolean
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to enforce upon.
enforceMinIsWhite
Type: SystemBoolean
The interpretation to enforce.
See Also

Reference

BinaryPaletteEnforcerEnforcerState Class
Atalasoft.Imaging Namespace


EnforcerState Methods

The BinaryPaletteEnforcerEnforcerState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | Releases the image from enforcement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BinaryPaletteEnforcerEnforcerState Class
Atalasoft.Imaging Namespace


BinaryPaletteEnforcer.EnforcerState.Release Method

BinaryPaletteEnforcerEnforcerStateRelease Method

Releases the image from enforcement.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Release()
Public Sub Release
See Also

Reference

BinaryPaletteEnforcerEnforcerState Class
Atalasoft.Imaging Namespace


ChangedImageEventArgs Class

This class is used to indicate when an AtalaImage has changed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingChangedImageEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ChangedImageEventArgs : EventArgs
Public Class ChangedImageEventArgs
    Inherits EventArgs

The ChangedImageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedImageEventArgs | Constructs a new ChangedImageEventArgs object
Top
Properties
 | Name | Description
Public property | NewImage | Gets the new AtalaImage that will replace the old image.
Public property | OriginalImage | Gets the AtalaImage that represents an image to be replaced.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ChangedImageEventArgs Constructor

Constructs a new ChangedImageEventArgs object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChangedImageEventArgs(
    AtalaImage originalImage,
    AtalaImage newImage
)
Public Sub New (
    originalImage As AtalaImage,
    newImage As AtalaImage
)

Parameters

originalImage
Type: Atalasoft.ImagingAtalaImage
The original image
newImage
Type: Atalasoft.ImagingAtalaImage
The image that is replacing the original image.
See Also

Reference

ChangedImageEventArgs Class
Atalasoft.Imaging Namespace


ChangedImageEventArgs Properties

The ChangedImageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewImage | Gets the new AtalaImage that will replace the old image.
Public property | OriginalImage | Gets the AtalaImage that represents an image to be replaced.
Top
See Also

Reference

ChangedImageEventArgs Class
Atalasoft.Imaging Namespace


ChangedImageEventArgs.NewImage Property

ChangedImageEventArgsNewImage Property

Gets the new AtalaImage that will replace the old image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage NewImage { get; }
Public ReadOnly Property NewImage As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

ChangedImageEventArgs Class
Atalasoft.Imaging Namespace


ChangedImageEventArgs.OriginalImage Property

ChangedImageEventArgsOriginalImage Property

Gets the AtalaImage that represents an image to be replaced.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage OriginalImage { get; }
Public ReadOnly Property OriginalImage As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

ChangedImageEventArgs Class
Atalasoft.Imaging Namespace


ChangedImageEventArgs Methods

The ChangedImageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChangedImageEventArgs Class
Atalasoft.Imaging Namespace


ChangedImageEventHandler Delegate

This EventHandler is used to update AtalaImage objects in various classes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ChangedImageEventHandler(
    Object sender,
    ChangedImageEventArgs e
)
Public Delegate Sub ChangedImageEventHandler (
    sender As Object,
    e As ChangedImageEventArgs
)

Parameters

sender
Type: SystemObject
The object in which the exception occurred.
e
Type: Atalasoft.ImagingChangedImageEventArgs
The ChangedImageEventArgs containing information about the images.
See Also

Reference

Atalasoft.Imaging Namespace
ChangedImageEventArgs Class


CmykColor Structure

CmykColor defines a color that consists of cyan, magenta, yellow, and black components.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct CmykColor
<SerializableAttribute>
Public Structure CmykColor

The CmykColor type exposes the following members.

Constructors
 | Name | Description
Public method | CmykColor(Color) | Construct a new CmykColor from the RGB color.
Public method | CmykColor(Int32) | Construct a new CmykColor from the 32-bit integer provided.
Public method | CmykColor(Int32, Int32, Int32, Int32) | Construct a new CmykColor from the four components provided
Top
Properties
 | Name | Description
Public property | C | Set or get the cyan component of this color.
Public property | K | Set or get the black component of this color.
Public property | M | Set or get the magenta component of this color.
Public property | Rgb | Gets the value of the color an RGB Color object.
Public property | Y | Set or get the yellow component of this color.
Top
Methods
 | Name | Description
Public method | Equals | Test for equality with another object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Get the hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Implements the equality operator.
Inequality | Implements the not-equals operator
Top
Remarks
This class represents a color with 8-bit components.
See Also

Reference

Atalasoft.Imaging Namespace


CmykColor Constructor

Construct a new CmykColor structure
Overload List
 | Name | Description
Public method | CmykColor(Color) | Construct a new CmykColor from the RGB color.
Public method | CmykColor(Int32) | Construct a new CmykColor from the 32-bit integer provided.
Public method | CmykColor(Int32, Int32, Int32, Int32) | Construct a new CmykColor from the four components provided
Top
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor Constructor (Color)

Construct a new CmykColor from the RGB color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmykColor(
    Color col
)
Public Sub New (
    col As Color
)

Parameters

col
Type: System.DrawingColor
See Also

Reference

CmykColor Structure
CmykColor Overload
Atalasoft.Imaging Namespace


CmykColor Constructor (Int32)

Construct a new CmykColor from the 32-bit integer provided.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmykColor(
    int packedCmyk
)
Public Sub New (
    packedCmyk As Integer
)

Parameters

packedCmyk
Type: SystemInt32
PackedCmyk represents the 4 components as 4 8 bit values with c in the upper byte, followed by m, y, and k.
See Also

Reference

CmykColor Structure
CmykColor Overload
Atalasoft.Imaging Namespace


CmykColor Constructor (Int32, Int32, Int32, Int32)

Construct a new CmykColor from the four components provided

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmykColor(
    int c,
    int m,
    int y,
    int k
)
Public Sub New (
    c As Integer,
    m As Integer,
    y As Integer,
    k As Integer
)

Parameters

c
Type: SystemInt32
The cyan component of this color.
m
Type: SystemInt32
The magenta component of this color.
y
Type: SystemInt32
The yellow component of this color.
k
Type: SystemInt32
The black component of this color.
Remarks
Each value must be in the range 0-255.
See Also

Reference

CmykColor Structure
CmykColor Overload
Atalasoft.Imaging Namespace


CmykColor Properties

The CmykColor type exposes the following members.

Properties
 | Name | Description
Public property | C | Set or get the cyan component of this color.
Public property | K | Set or get the black component of this color.
Public property | M | Set or get the magenta component of this color.
Public property | Rgb | Gets the value of the color an RGB Color object.
Public property | Y | Set or get the yellow component of this color.
Top
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.C Property

CmykColorC Property

Set or get the cyan component of this color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int C { get; }
Public ReadOnly Property C As Integer
    Get

Property Value

Type: Int32
Remarks
Must be in the range 0-255.
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.K Property

CmykColorK Property

Set or get the black component of this color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int K { get; }
Public ReadOnly Property K As Integer
    Get

Property Value

Type: Int32
Remarks
Must be in the range 0-255.
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.M Property

CmykColorM Property

Set or get the magenta component of this color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int M { get; }
Public ReadOnly Property M As Integer
    Get

Property Value

Type: Int32
Remarks
Must be in the range 0-255.
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.Rgb Property

CmykColorRgb Property

Gets the value of the color an RGB Color object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Rgb { get; }
Public ReadOnly Property Rgb As Color
    Get

Property Value

Type: Color
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.Y Property

CmykColorY Property

Set or get the yellow component of this color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get

Property Value

Type: Int32
Remarks
Must be in the range 0-255.
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor Methods

The CmykColor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Test for equality with another object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Get the hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.Equals Method

CmykColorEquals Method

Test for equality with another object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The compare to compare against.

Return Value

Type: Boolean
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.GetHashCode Method

CmykColorGetHashCode Method

Get the hash code for this object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor Operators

The CmykColor type exposes the following members.

Operators
Name | Description
Equality | Implements the equality operator.
Inequality | Implements the not-equals operator
Top
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.Equality Operator

CmykColorEquality Operator

Implements the equality operator.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    CmykColor c1,
    CmykColor c2
)
Public Shared Operator = (
    c1 As CmykColor,
    c2 As CmykColor
) As Boolean

Parameters

c1
Type: Atalasoft.ImagingCmykColor
The first color to compare
c2
Type: Atalasoft.ImagingCmykColor
The second color to compare

Return Value

Type: Boolean
True if the objects represent the same color, false otherwise.
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


CmykColor.Inequality Operator

CmykColorInequality Operator

Implements the not-equals operator

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    CmykColor c1,
    CmykColor c2
)
Public Shared Operator <> (
    c1 As CmykColor,
    c2 As CmykColor
) As Boolean

Parameters

c1
Type: Atalasoft.ImagingCmykColor
The first color to compare
c2
Type: Atalasoft.ImagingCmykColor
The second color to compare

Return Value

Type: Boolean
True if the colors are different, false otherwise.
See Also

Reference

CmykColor Structure
Atalasoft.Imaging Namespace


Dpi Structure

Holds the Resolution information.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct Dpi
<SerializableAttribute>
Public Structure Dpi

The Dpi type exposes the following members.

Constructors
 | Name | Description
Public method | Dpi(Double, Double, ResolutionUnit) | Initializes a new instance of the Dpi struct.
Public method | Dpi(Int32, Int32, ResolutionUnit) | Create a new Dpi structure at a specified resolution.
Top
Properties
 | Name | Description
Public property | Units | Gets the resolution Units.
Public property | X | Gets the horizontal resolution.
Public property | Y | Gets the vertical resolution.
Top
Methods
 | Name | Description
 | Compare | Compares the specified value1.
Public method | ConvertTo | Converts to the new units.
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Compares the two Dpi objects for equality.
Inequality | Compares the two Dpi objects for inequality.
Top
See Also

Reference

Atalasoft.Imaging Namespace


Dpi Constructor

Overload List
 | Name | Description
Public method | Dpi(Double, Double, ResolutionUnit) | Initializes a new instance of the Dpi struct.
Public method | Dpi(Int32, Int32, ResolutionUnit) | Create a new Dpi structure at a specified resolution.
Top
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi Constructor (Double, Double, ResolutionUnit)

Initializes a new instance of the Dpi struct.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi(
    double x,
    double y,
    ResolutionUnit units
)
Public Sub New (
    x As Double,
    y As Double,
    units As ResolutionUnit
)

Parameters

x
Type: SystemDouble
The x resolution.
y
Type: SystemDouble
The y resoltion.
units
Type: Atalasoft.ImagingResolutionUnit
The resolution units.
See Also

Reference

Dpi Structure
Dpi Overload
Atalasoft.Imaging Namespace


Dpi Constructor (Int32, Int32, ResolutionUnit)

Create a new Dpi structure at a specified resolution.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi(
    int x,
    int y,
    ResolutionUnit units
)
Public Sub New (
    x As Integer,
    y As Integer,
    units As ResolutionUnit
)

Parameters

x
Type: SystemInt32
Horizontal Resolution.
y
Type: SystemInt32
Vertical Resolution.
units
Type: Atalasoft.ImagingResolutionUnit
Resolution Units.
See Also

Reference

Dpi Structure
Dpi Overload
Atalasoft.Imaging Namespace


Dpi Properties

The Dpi type exposes the following members.

Properties
 | Name | Description
Public property | Units | Gets the resolution Units.
Public property | X | Gets the horizontal resolution.
Public property | Y | Gets the vertical resolution.
Top
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.Units Property

DpiUnits Property

Gets the resolution Units.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolutionUnit Units { get; }
Public ReadOnly Property Units As ResolutionUnit
    Get

Property Value

Type: ResolutionUnit
The resolution Units.
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.X Property

DpiX Property

Gets the horizontal resolution.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X { get; }
Public ReadOnly Property X As Double
    Get

Property Value

Type: Double
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.Y Property

DpiY Property

Gets the vertical resolution.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y { get; }
Public ReadOnly Property Y As Double
    Get

Property Value

Type: Double
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi Methods

The Dpi type exposes the following members.

Methods
 | Name | Description
 | Compare | Compares the specified value1.
Public method | ConvertTo | Converts to the new units.
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.Compare Method

DpiCompare Method

Compares the specified value1.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool Compare(
    Dpi value1,
    Dpi value2
)
Public Shared Function Compare (
    value1 As Dpi,
    value2 As Dpi
) As Boolean

Parameters

value1
Type: Atalasoft.ImagingDpi
The value1.
value2
Type: Atalasoft.ImagingDpi
The value2.

Return Value

Type: Boolean
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.ConvertTo Method

DpiConvertTo Method

Converts to the new units.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi ConvertTo(
    ResolutionUnit newUnit
)
Public Function ConvertTo (
    newUnit As ResolutionUnit
) As Dpi

Parameters

newUnit
Type: Atalasoft.ImagingResolutionUnit
The new unit.

Return Value

Type: Dpi
Exceptions
Exception | Condition
NotImplementedException | Internal error - unknown unit conversion
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.Equals Method

DpiEquals Method

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.GetHashCode Method

DpiGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.ToString Method

DpiToString Method

Returns a String that represents this instance.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi Operators

The Dpi type exposes the following members.

Operators
Name | Description
Equality | Compares the two Dpi objects for equality.
Inequality | Compares the two Dpi objects for inequality.
Top
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.Equality Operator

DpiEquality Operator

Compares the two Dpi objects for equality.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    Dpi x,
    Dpi y
)
Public Shared Operator = (
    x As Dpi,
    y As Dpi
) As Boolean

Parameters

x
Type: Atalasoft.ImagingDpi
The x.
y
Type: Atalasoft.ImagingDpi
The y.

Return Value

Type: Boolean
true if the objects are equal, false otherwise
Remarks
The compares the x and y resolutions and the units, but not compare for equivalence across different units
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


Dpi.Inequality Operator

DpiInequality Operator

Compares the two Dpi objects for inequality.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    Dpi x,
    Dpi y
)
Public Shared Operator <> (
    x As Dpi,
    y As Dpi
) As Boolean

Parameters

x
Type: Atalasoft.ImagingDpi
The x.
y
Type: Atalasoft.ImagingDpi
The y.

Return Value

Type: Boolean
true if the objects are not equal, false otherwise
Remarks
The compares the x and y resolutions and the units, but not compare for equivalence across different units
See Also

Reference

Dpi Structure
Atalasoft.Imaging Namespace


ExceptionEventArgs Class

Provides data for the ProcessError event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingExceptionEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ExceptionEventArgs : EventArgs
Public Class ExceptionEventArgs
    Inherits EventArgs

The ExceptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionEventArgs | Creates a new instance of ExceptionEventArgs.
Public method | ExceptionEventArgs(Exception) | Creates a new instance of ExceptionEventArgs specifying the Exception that was thrown.
Top
Properties
 | Name | Description
Public property | Exception | Gets the Exception that was thrown.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ExceptionEventArgs Constructor

Creates a new instance of ExceptionEventArgs.
Overload List
 | Name | Description
Public method | ExceptionEventArgs | Creates a new instance of ExceptionEventArgs.
Public method | ExceptionEventArgs(Exception) | Creates a new instance of ExceptionEventArgs specifying the Exception that was thrown.
Top
See Also

Reference

ExceptionEventArgs Class
Atalasoft.Imaging Namespace


ExceptionEventArgs Constructor

Creates a new instance of ExceptionEventArgs.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExceptionEventArgs()
Public Sub New
See Also

Reference

ExceptionEventArgs Class
ExceptionEventArgs Overload
Atalasoft.Imaging Namespace


ExceptionEventArgs Constructor (Exception)

Creates a new instance of ExceptionEventArgs specifying the Exception that was thrown.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExceptionEventArgs(
    Exception exception
)
Public Sub New (
    exception As Exception
)

Parameters

exception
Type: SystemException
The Exception that was thrown.
See Also

Reference

ExceptionEventArgs Class
ExceptionEventArgs Overload
Atalasoft.Imaging Namespace


ExceptionEventArgs Properties

The ExceptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets the Exception that was thrown.
Top
See Also

Reference

ExceptionEventArgs Class
Atalasoft.Imaging Namespace


ExceptionEventArgs.Exception Property

ExceptionEventArgsException Property

Gets the Exception that was thrown.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get

Property Value

Type: Exception
The Exception that was thrown.
See Also

Reference

ExceptionEventArgs Class
Atalasoft.Imaging Namespace


ExceptionEventArgs Methods

The ExceptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExceptionEventArgs Class
Atalasoft.Imaging Namespace


ExceptionEventHandler Delegate

This EventHandler is used to pass along an exception during an image processing operation.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ExceptionEventHandler(
    Object sender,
    ExceptionEventArgs e
)
Public Delegate Sub ExceptionEventHandler (
    sender As Object,
    e As ExceptionEventArgs
)

Parameters

sender
Type: SystemObject
The object in which the exception occurred.
e
Type: Atalasoft.ImagingExceptionEventArgs
An ExceptionEventArgs object containing information about the exception.
See Also

Reference

Atalasoft.Imaging Namespace
ExceptionEventArgs Class


FileMapIOException Class

This exception is thrown when an error occurs when allocating an image with file memory mapping.
Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.IOIOException
Atalasoft.ImagingFileMapIOException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FileMapIOException : IOException
<SerializableAttribute>
Public Class FileMapIOException
    Inherits IOException

The FileMapIOException type exposes the following members.

Constructors
 | Name | Description
Public method | FileMapIOException | Initializes a new instance of the FileMapIOException class
Public method | FileMapIOException(Int32) | Creates a new instance of FileMapIOException specifying the Windows API error code.
Public method | FileMapIOException(String) | Creates a new instance of FileMapIOException specifying the Exception message.
Protected method | FileMapIOException(SerializationInfo, StreamingContext) | Initializes a new instance of the FileMapIOException class.
Public method | FileMapIOException(String, Exception) | Creates an instance of FileMapIOException specifying the Exception message and inner Exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a description about the Exception. (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | Win32ErrorCode | Gets the Windows API error code for this Exception.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Remarks
Represents an exception occured as a result of an invalid IO operation on any of the File mapping classes It wraps the error message and the underlying Win32 error code that caused the error.
See Also

Reference

Atalasoft.Imaging Namespace


FileMapIOException Constructor

Creates a new instance of FileMapIOException.
Overload List
 | Name | Description
Public method | FileMapIOException | Initializes a new instance of the FileMapIOException class
Public method | FileMapIOException(Int32) | Creates a new instance of FileMapIOException specifying the Windows API error code.
Public method | FileMapIOException(String) | Creates a new instance of FileMapIOException specifying the Exception message.
Protected method | FileMapIOException(SerializationInfo, StreamingContext) | Initializes a new instance of the FileMapIOException class.
Public method | FileMapIOException(String, Exception) | Creates an instance of FileMapIOException specifying the Exception message and inner Exception.
Top
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileMapIOException Constructor

Initializes a new instance of the FileMapIOException class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileMapIOException()
Public Sub New
See Also

Reference

FileMapIOException Class
FileMapIOException Overload
Atalasoft.Imaging Namespace


FileMapIOException Constructor (Int32)

Creates a new instance of FileMapIOException specifying the Windows API error code.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileMapIOException(
    int error
)
Public Sub New (
    error As Integer
)

Parameters

error
Type: SystemInt32
The Windows API error code.
See Also

Reference

FileMapIOException Class
FileMapIOException Overload
Atalasoft.Imaging Namespace


FileMapIOException Constructor (String)

Creates a new instance of FileMapIOException specifying the Exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileMapIOException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
A description of the exception.
See Also

Reference

FileMapIOException Class
FileMapIOException Overload
Atalasoft.Imaging Namespace


FileMapIOException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FileMapIOException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FileMapIOException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The data for serializing or deserializing the object.
context
Type: System.Runtime.SerializationStreamingContext
The source and destination for the object.
See Also

Reference

FileMapIOException Class
FileMapIOException Overload
Atalasoft.Imaging Namespace


FileMapIOException Constructor (String, Exception)

Creates an instance of FileMapIOException specifying the Exception message and inner Exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileMapIOException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
A description of the exception.
innerException
Type: SystemException
The inner exception.
See Also

Reference

FileMapIOException Class
FileMapIOException Overload
Atalasoft.Imaging Namespace


FileMapIOException Properties

The FileMapIOException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a description about the Exception. (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | Win32ErrorCode | Gets the Windows API error code for this Exception.
Top
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileMapIOException.Message Property

FileMapIOExceptionMessage Property

Gets a description about the Exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String
A description of the exception.

Implements

_ExceptionMessage
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileMapIOException.Win32ErrorCode Property

FileMapIOExceptionWin32ErrorCode Property

Gets the Windows API error code for this Exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Win32ErrorCode { get; }
Public ReadOnly Property Win32ErrorCode As Integer
    Get

Property Value

Type: Int32
The Windows API error code.
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileMapIOException Methods

The FileMapIOException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileMapIOException.GetObjectData Method

FileMapIOExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;Argument 'info' cannot be null.
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileMapIOException Events

The FileMapIOException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FileMapIOException Class
Atalasoft.Imaging Namespace


FileReloader Class

FileReloader is an implementation of the IImageReloader interface. It encapsulates information about an image stored in a file system and can reload that image at any point.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingFileReloader

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FileReloader : IImageReloader,
    IDisposable
Public Class FileReloader
    Implements IImageReloader, IDisposable

The FileReloader type exposes the following members.

Constructors
 | Name | Description
Public method | FileReloader(AtalaImage) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(String, Int32) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(AtalaImage, ImageEncoder) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(AtalaImage, String) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(AtalaImage, String, ImageEncoder) | Constructs a new FileReloader object.
Top
Properties
 | Name | Description
Public property | Path | Gets the path to the file referenced by this reloader.
Top
Methods
 | Name | Description
Public method | Dispose | Dispose releases resources associated with this class.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reload | Reload the image into memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class is used by the FileSystemImageSource object, but any ImageSource that wants to implement a file system cache could use this object.
See Also

Reference

Atalasoft.Imaging Namespace


FileReloader Constructor

Overload List
 | Name | Description
Public method | FileReloader(AtalaImage) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(String, Int32) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(AtalaImage, ImageEncoder) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(AtalaImage, String) | Initializes a new instance of the FileReloader class.
Public method | FileReloader(AtalaImage, String, ImageEncoder) | Constructs a new FileReloader object.
Top
See Also

Reference

FileReloader Class
Atalasoft.Imaging Namespace


FileReloader Constructor (AtalaImage)

Initializes a new instance of the FileReloader class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileReloader(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.
See Also

Reference

FileReloader Class
FileReloader Overload
Atalasoft.Imaging Namespace


FileReloader Constructor (String, Int32)

Initializes a new instance of the FileReloader class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileReloader(
    string path,
    int frameIndex
)
Public Sub New (
    path As String,
    frameIndex As Integer
)

Parameters

path
Type: SystemString
The path representing the mage.
frameIndex
Type: SystemInt32
Index of the frame.
See Also

Reference

FileReloader Class
FileReloader Overload
Atalasoft.Imaging Namespace


FileReloader Constructor (AtalaImage, ImageEncoder)

Initializes a new instance of the FileReloader class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileReloader(
    AtalaImage image,
    ImageEncoder encoder
)
Public Sub New (
    image As AtalaImage,
    encoder As ImageEncoder
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The encoder to use for this image.
See Also

Reference

FileReloader Class
FileReloader Overload
Atalasoft.Imaging Namespace


FileReloader Constructor (AtalaImage, String)

Initializes a new instance of the FileReloader class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileReloader(
    AtalaImage image,
    string path
)
Public Sub New (
    image As AtalaImage,
    path As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.
path
Type: SystemString
The path to the temporary file for reloading.
See Also

Reference

FileReloader Class
FileReloader Overload
Atalasoft.Imaging Namespace


FileReloader Constructor (AtalaImage, String, ImageEncoder)

Constructs a new FileReloader object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileReloader(
    AtalaImage image,
    string path,
    ImageEncoder encoder
)
Public Sub New (
    image As AtalaImage,
    path As String,
    encoder As ImageEncoder
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
path
Type: SystemString
encoder
Type: Atalasoft.Imaging.CodecImageEncoder

Return Value

Type:
A new AtalaImage or null if the image can't be loaded.
See Also

Reference

FileReloader Class
FileReloader Overload
Atalasoft.Imaging Namespace


FileReloader Properties

The FileReloader type exposes the following members.

Properties
 | Name | Description
Public property | Path | Gets the path to the file referenced by this reloader.
Top
See Also

Reference

FileReloader Class
Atalasoft.Imaging Namespace


FileReloader.Path Property

FileReloaderPath Property

Gets the path to the file referenced by this reloader.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
A string representing the path referenced by this reloader.
See Also

Reference

FileReloader Class
Atalasoft.Imaging Namespace


FileReloader Methods

The FileReloader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose releases resources associated with this class.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reload | Reload the image into memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileReloader Class
Atalasoft.Imaging Namespace


FileReloader.Dispose Method

FileReloaderDispose Method

Dispose releases resources associated with this class.
Overload List
 | Name | Description
Public method | Dispose | Dispose releases resources associated with this class.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

FileReloader Class
Atalasoft.Imaging Namespace


FileReloader.Dispose Method

FileReloaderDispose Method

Dispose releases resources associated with this class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

FileReloader Class
Dispose Overload
Atalasoft.Imaging Namespace


FileReloader.Dispose Method (Boolean)

FileReloaderDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FileReloader Class
Dispose Overload
Atalasoft.Imaging Namespace


FileReloader.Reload Method

FileReloaderReload Method

Reload the image into memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Reload()
Public Function Reload As AtalaImage

Return Value

Type: AtalaImage
A new AtalaImage or null if the image can't be loaded.

Implements

IImageReloaderReload
See Also

Reference

FileReloader Class
Atalasoft.Imaging Namespace


FileSystemImageSource Class

This is an implementation of an ImageSource using a file system as a provider of images.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.ImagingFileSystemImageSource

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FileSystemImageSource : RandomAccessImageSource,
    ISerializable, IImageStreamSource
<SerializableAttribute>
Public Class FileSystemImageSource
    Inherits RandomAccessImageSource
    Implements ISerializable, IImageStreamSource

The FileSystemImageSource type exposes the following members.

Constructors
 | Name | Description
Protected method | FileSystemImageSource(SerializationInfo, StreamingContext) | Creates a new instance of FileSystemImageSource from serialization information.
Public method | FileSystemImageSource(String, Boolean) | Provides access to all image files from a directory or file
Public method | FileSystemImageSource(String, Boolean) | Provides access to a list of image files.
Public method | FileSystemImageSource(String, String, Boolean) | Provides access to all image files from a directory that match a pattern or from a single file.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | FileFilter | Gets or sets a delegate that is invoked for each file, allowing the files to be filtered with custom rules.
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Protected method | AllowFile | Called to determine whether a file is allowed.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetFrameCount | Returns the number of frames in for an image in a FileSystemImageSource.
Public method | GetFrameNumber | Return the frame index of an image in the FileSystemImageSource.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetImageStream | Returns an object that contains information about the stream that contains the requested image. When you call this, the ImageStream member of the returned object will be open and the caller is responsible for closing it.
Public method | GetObjectData | Fills a SerializationInfo object with object information. (Overrides RandomAccessImageSourceGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPath | Returns the path of the image in a FileSystemImageSource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Performs an acquire of an indexed image. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Low level implementation to replace an image. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Lows level implementation of reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToPath | Retrieves the path associated with a previously acquired image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | ImageAcquired | Invoked when an image is acquired into memory.
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
Remarks
This class can be used to open a large multi-page TIFF document. Create an instance of the FileSystemImageSource setting the doAllFrames parameter to true.
See Also

Reference

Atalasoft.Imaging Namespace


FileSystemImageSource Constructor

Constructs a new FileSystemImageSource object.
Overload List
 | Name | Description
Protected method | FileSystemImageSource(SerializationInfo, StreamingContext) | Creates a new instance of FileSystemImageSource from serialization information.
Public method | FileSystemImageSource(String, Boolean) | Provides access to all image files from a directory or file
Public method | FileSystemImageSource(String, Boolean) | Provides access to a list of image files.
Public method | FileSystemImageSource(String, String, Boolean) | Provides access to all image files from a directory that match a pattern or from a single file.
Top
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FileSystemImageSource from serialization information.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FileSystemImageSource(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

FileSystemImageSource Class
FileSystemImageSource Overload
Atalasoft.Imaging Namespace


FileSystemImageSource Constructor (String, Boolean)

Provides access to all image files from a directory or file

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileSystemImageSource(
    string path,
    bool doAllFrames
)
Public Sub New (
    path As String,
    doAllFrames As Boolean
)

Parameters

path
Type: SystemString
A path to a directory or file containing image files.
doAllFrames
Type: SystemBoolean
If true, this image source will provide access to every available frame in every file.

Return Value

Type:
A new FileSystemImageSource object.
Exceptions
Exception | Condition
 | Thrown if the path is null (Nothing in VB).
Remarks

This will provide access only to image files for which there is an existing registered codec.

Because there is a codec available for a file does not mean that it can be loaded.

See Also

Reference

FileSystemImageSource Class
FileSystemImageSource Overload
Atalasoft.Imaging Namespace


FileSystemImageSource Constructor (String[], Boolean)

FileSystemImageSource Constructor (String, Boolean)

Provides access to a list of image files.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileSystemImageSource(
    string[] fileNames,
    bool doAllFrames
)
Public Sub New (
    fileNames As String(),
    doAllFrames As Boolean
)

Parameters

fileNames
Type: SystemString
A list of file names to be loaded as images.
doAllFrames
Type: SystemBoolean
If true, this image source will provide access to every available frame in every file.
Exceptions
Exception | Condition
 | Thrown if the fileNames argument is null (Nothing in VB).
Remarks

This will provide access only to image files for which there is an existing registered codec.

Because there is a codec available for a file does not mean that it can be loaded.

See Also

Reference

FileSystemImageSource Class
FileSystemImageSource Overload
Atalasoft.Imaging Namespace


FileSystemImageSource Constructor (String, String, Boolean)

Provides access to all image files from a directory that match a pattern or from a single file.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileSystemImageSource(
    string path,
    string pattern,
    bool doAllFrames
)
Public Sub New (
    path As String,
    pattern As String,
    doAllFrames As Boolean
)

Parameters

path
Type: SystemString
A path to a directory containing image files or to a single file.
pattern
Type: SystemString
A regular expression used to match files in the directory.
doAllFrames
Type: SystemBoolean
If true, this image source will provide access to every available frame in every file.
Exceptions
Exception | Condition
 | Thrown if the path or pattern is null (Nothing in VB).
Remarks

This will provide access only to image files for which there is an existing registered codec.

Because there is a codec available for a file does not mean that it can be loaded.

If path is a single file, the pattern will be ignored.

See Also

Reference

FileSystemImageSource Class
FileSystemImageSource Overload
Atalasoft.Imaging Namespace


FileSystemImageSource Properties

The FileSystemImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | FileFilter | Gets or sets a delegate that is invoked for each file, allowing the files to be filtered with custom rules.
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.FileFilter Property

FileSystemImageSourceFileFilter Property

Gets or sets a delegate that is invoked for each file, allowing the files to be filtered with custom rules.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileSystemImageSourceFileFilterDelegate FileFilter { get; set; }
Public Property FileFilter As FileSystemImageSourceFileFilterDelegate
    Get
    Set

Property Value

Type: FileSystemImageSourceFileFilterDelegate
A delegate that is invoked for each file.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource Methods

The FileSystemImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Protected method | AllowFile | Called to determine whether a file is allowed.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetFrameCount | Returns the number of frames in for an image in a FileSystemImageSource.
Public method | GetFrameNumber | Return the frame index of an image in the FileSystemImageSource.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetImageStream | Returns an object that contains information about the stream that contains the requested image. When you call this, the ImageStream member of the returned object will be open and the caller is responsible for closing it.
Public method | GetObjectData | Fills a SerializationInfo object with object information. (Overrides RandomAccessImageSourceGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetPath | Returns the path of the image in a FileSystemImageSource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Performs an acquire of an indexed image. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Low level implementation to replace an image. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Lows level implementation of reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToPath | Retrieves the path associated with a previously acquired image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.AllowFile Method

FileSystemImageSourceAllowFile Method

Called to determine whether a file is allowed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool AllowFile(
    string path,
    int frameIndex,
    int frameCount
)
Protected Overridable Function AllowFile (
    path As String,
    frameIndex As Integer,
    frameCount As Integer
) As Boolean

Parameters

path
Type: SystemString
The filename of the file.
frameIndex
Type: SystemInt32
The index of the frame.
frameCount
Type: SystemInt32
The number of frames to allow.

Return Value

Type: Boolean
Remarks
By default, all files are allowed. Set the FileFilter property or override this method to control which files to allow.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.GetFrameCount Method

FileSystemImageSourceGetFrameCount Method

Returns the number of frames in for an image in a FileSystemImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetFrameCount(
    int index
)
Public Function GetFrameCount (
    index As Integer
) As Integer

Parameters

index
Type: SystemInt32
The index of the file to return a frame count.

Return Value

Type: Int32
The number of frames in the image.
Exceptions
Exception | Condition
 | Thrown if the index is invalid for the FileSystemImageSource.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.GetFrameNumber Method

FileSystemImageSourceGetFrameNumber Method

Return the frame index of an image in the FileSystemImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetFrameNumber(
    int index
)
Public Function GetFrameNumber (
    index As Integer
) As Integer

Parameters

index
Type: SystemInt32
The index of the image in the ImageSource.

Return Value

Type: Int32
The frame index of the image.
Exceptions
Exception | Condition
 | Thrown if the index is invalid for the FileSystemImageSource.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.GetImageStream Method

FileSystemImageSourceGetImageStream Method

Returns an object that contains information about the stream that contains the requested image. When you call this, the ImageStream member of the returned object will be open and the caller is responsible for closing it.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceStreamInfo GetImageStream(
    int index
)
Public Function GetImageStream (
    index As Integer
) As ImageSourceStreamInfo

Parameters

index
Type: SystemInt32
The index of the image within the ImageSource.

Return Value

Type: ImageSourceStreamInfo
An object that contains the stream and information for finding the requested image within it.

Implements

IImageStreamSourceGetImageStream(Int32)
Examples
Requesting a Stream from an ImageSource (C#)
Copy
public Size GetSize(RandomAccessImageSource src, int index)
{
    if (src is IImageStreamSource)
    {
       ImageSourceStreamInfo info = ((IImageStreamSource)src).GetImageStream(index);
       // caller is responsible for disposing info.ImageStream
       using (Stream s = info.ImageStream)
       {
          // reads size from meta-data, doesn't decode image
          return RegisteredDecoders.GetImageInfo(s, info.Frame).Size;
       }
    } else {
        return src[index].Size; // reads the whole image into memory
    }
}
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.GetObjectData Method

FileSystemImageSourceGetObjectData Method

Fills a SerializationInfo object with object information.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.GetPath Method

FileSystemImageSourceGetPath Method

Returns the path of the image in a FileSystemImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetPath(
    int index
)
Public Function GetPath (
    index As Integer
) As String

Parameters

index
Type: SystemInt32
The index of the image.

Return Value

Type: String
The path of the image file.
Exceptions
Exception | Condition
 | Thrown if the index is invalid for the FileSystemImageSource.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelAcquire Method

FileSystemImageSourceLowLevelAcquire Method

Performs an acquire of an indexed image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquire(
    int index
)
Protected Overrides Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32
The index of the image to acquire.

Return Value

Type: ImageSourceNode
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelAcquireNextImage Method

FileSystemImageSourceLowLevelAcquireNextImage Method

Lows level implementation to acquire next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquireNextImage()
Protected Overrides Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelDispose Method

FileSystemImageSourceLowLevelDispose Method

Lows level implementation to dispose the ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelDispose()
Protected Overrides Sub LowLevelDispose
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelFlushOnReset Method

FileSystemImageSourceLowLevelFlushOnReset Method

Lows level implementation to determine if there should be a flush on reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelFlushOnReset()
Protected Overrides Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
true if the ImageSource needs a flush on reset, false otherwise.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelHasMoreImages Method

FileSystemImageSourceLowLevelHasMoreImages Method

Lows level implementation to determine if the ImageSource has more images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelHasMoreImages()
Protected Overrides Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
true if there are more image, false otherwise.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelReplaceImage Method

FileSystemImageSourceLowLevelReplaceImage Method

Low level implementation to replace an image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReplaceImage(
    ImageSourceNode node,
    AtalaImage newImage
)
Protected Overrides Sub LowLevelReplaceImage (
    node As ImageSourceNode,
    newImage As AtalaImage
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node.
newImage
Type: Atalasoft.ImagingAtalaImage
The new image.
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelReset Method

FileSystemImageSourceLowLevelReset Method

Lows level implementation of reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReset()
Protected Overrides Sub LowLevelReset
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelSkipNextImage Method

FileSystemImageSourceLowLevelSkipNextImage Method

Lows level implementation to skip next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelSkipNextImage()
Protected Overrides Sub LowLevelSkipNextImage
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.LowLevelTotalImages Method

FileSystemImageSourceLowLevelTotalImages Method

Lows level implementation that returns the total number of images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LowLevelTotalImages()
Protected Overrides Function LowLevelTotalImages As Integer

Return Value

Type: Int32
the total number of images
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.ToPath Method

FileSystemImageSourceToPath Method

Retrieves the path associated with a previously acquired image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToPath(
    AtalaImage image
)
Public Function ToPath (
    image As AtalaImage
) As String

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An image that had been previously acquired by the FileSystemImageSource

Return Value

Type: String
A string representing the path to the file from which the image was derived. If the image had not been previously acquired by the FileSystemImage source, ToPath will return null.
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource Events

The FileSystemImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | ImageAcquired | Invoked when an image is acquired into memory.
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.ImageAcquired Event

FileSystemImageSourceImageAcquired Event

Invoked when an image is acquired into memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event FileSystemImageSourceFileEventHandler ImageAcquired
Public Event ImageAcquired As FileSystemImageSourceFileEventHandler

Value

Type: Atalasoft.ImagingFileSystemImageSourceFileEventHandler
See Also

Reference

FileSystemImageSource Class
Atalasoft.Imaging Namespace


FileSystemImageSource.FileEventHandler Delegate

FileSystemImageSourceFileEventHandler Delegate

This event is used for tracking when a file or a frame within a file has been loaded.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void FileEventHandler(
    Object sender,
    FileSystemImageSourceEventArgs e
)
Public Delegate Sub FileEventHandler (
    sender As Object,
    e As FileSystemImageSourceEventArgs
)

Parameters

sender
Type: SystemObject
The sender of this event.
e
Type: Atalasoft.ImagingFileSystemImageSourceEventArgs
Information about the files and frame being loaded.
See Also

Reference

Atalasoft.Imaging Namespace


FileSystemImageSource.FileFilterDelegate Delegate

FileSystemImageSourceFileFilterDelegate Delegate

The FileFilterDelegate is used within the FileSystemImageSource to provide a means of filtering out files or pages within files

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate bool FileFilterDelegate(
    string pathName,
    int frameIndex,
    int frameCount
)
Public Delegate Function FileFilterDelegate (
    pathName As String,
    frameIndex As Integer,
    frameCount As Integer
) As Boolean

Parameters

pathName
Type: SystemString
The full path to the file to be loaded
frameIndex
Type: SystemInt32
The current frame being considered
frameCount
Type: SystemInt32
The total number of frames within this file

Return Value

Type: Boolean
Returns true if the file is to be included, false otherwise.
See Also

Reference

Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs Class

This object is used for events fired by a FileSystemImageSource.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingFileSystemImageSourceEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FileSystemImageSourceEventArgs : EventArgs
Public Class FileSystemImageSourceEventArgs
    Inherits EventArgs

The FileSystemImageSourceEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FileSystemImageSourceEventArgs | Constructs a new FileSystemImageSourceEventArgs object.
Top
Properties
 | Name | Description
Public property | FrameCount | The total number of frames in this image file.
Public property | FrameIndex | The index of this frame in the image file.
Public property | Image | The image that has been acquired.
Public property | Path | The path to the image file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs Constructor

Constructs a new FileSystemImageSourceEventArgs object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileSystemImageSourceEventArgs(
    string path,
    int frameIndex,
    int frameCount,
    AtalaImage image
)
Public Sub New (
    path As String,
    frameIndex As Integer,
    frameCount As Integer,
    image As AtalaImage
)

Parameters

path
Type: SystemString
The path to the image file.
frameIndex
Type: SystemInt32
The frame index of the image.
frameCount
Type: SystemInt32
The total number of frames in this files.
image
Type: Atalasoft.ImagingAtalaImage
The image that was loaded.
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs Properties

The FileSystemImageSourceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FrameCount | The total number of frames in this image file.
Public property | FrameIndex | The index of this frame in the image file.
Public property | Image | The image that has been acquired.
Public property | Path | The path to the image file.
Top
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs.FrameCount Property

FileSystemImageSourceEventArgsFrameCount Property

The total number of frames in this image file.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameCount { get; }
Public ReadOnly Property FrameCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs.FrameIndex Property

FileSystemImageSourceEventArgsFrameIndex Property

The index of this frame in the image file.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameIndex { get; }
Public ReadOnly Property FrameIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs.Image Property

FileSystemImageSourceEventArgsImage Property

The image that has been acquired.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs.Path Property

FileSystemImageSourceEventArgsPath Property

The path to the image file.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FileSystemImageSourceEventArgs Methods

The FileSystemImageSourceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileSystemImageSourceEventArgs Class
Atalasoft.Imaging Namespace


FlipDirection Enumeration

Specifies the flip direction.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FlipDirection
Public Enumeration FlipDirection
Members
Member name | Description
Vertical | Flip Vertically.
Horizontal | Flip Horizontally.
See Also

Reference

Atalasoft.Imaging Namespace


FormDataCollection Class

The FormDataCollection is used with the HttpPost class to send form information to a web server.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.ImagingFormDataCollection

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FormDataCollection : CollectionBase
Public Class FormDataCollection
    Inherits CollectionBase

The FormDataCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets or sets the element at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add(String, AtalaImage) | Adds an image to the collection.
Public method | Add(String, String) | Adds form data to the collection.
Public method | Add(String, AtalaImage, String) | Adds an image to the collection specifying the filename.
Public method | Add(String, Stream, String, String) | Adds an image to the collection specifying the filename.
Public method | AddFromBrowser | Adds an image or form field to the collection. You must use this method when posting from a web browser.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether [contains] [the specified image].
Public method | CopyTo | Copies to the array
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of the image
Public method | Insert | Inserts the image at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified image.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


FormDataCollection Properties

The FormDataCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets or sets the element at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.Item Property

FormDataCollectionItem Property

Gets or sets the element at the specified index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As AtalaImage
    Get

Parameters

index
Type: SystemInt32
The index.

Return Value

Type: AtalaImage
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection Methods

The FormDataCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(String, AtalaImage) | Adds an image to the collection.
Public method | Add(String, String) | Adds form data to the collection.
Public method | Add(String, AtalaImage, String) | Adds an image to the collection specifying the filename.
Public method | Add(String, Stream, String, String) | Adds an image to the collection specifying the filename.
Public method | AddFromBrowser | Adds an image or form field to the collection. You must use this method when posting from a web browser.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether [contains] [the specified image].
Public method | CopyTo | Copies to the array
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of the image
Public method | Insert | Inserts the image at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the specified image.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.Add Method

FormDataCollectionAdd Method

Adds a new item to the collection.
Overload List
 | Name | Description
Public method | Add(String, AtalaImage) | Adds an image to the collection.
Public method | Add(String, String) | Adds form data to the collection.
Public method | Add(String, AtalaImage, String) | Adds an image to the collection specifying the filename.
Public method | Add(String, Stream, String, String) | Adds an image to the collection specifying the filename.
Top
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.Add Method (String, AtalaImage)

FormDataCollectionAdd Method (String, AtalaImage)

Adds an image to the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fieldName,
    AtalaImage image
)
Public Sub Add (
    fieldName As String,
    image As AtalaImage
)

Parameters

fieldName
Type: SystemString
The form field name used to identify the image.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to add.
See Also

Reference

FormDataCollection Class
Add Overload
Atalasoft.Imaging Namespace


FormDataCollection.Add Method (String, String)

FormDataCollectionAdd Method (String, String)

Adds form data to the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fieldName,
    string fieldValue
)
Public Sub Add (
    fieldName As String,
    fieldValue As String
)

Parameters

fieldName
Type: SystemString
The field name of the form object.
fieldValue
Type: SystemString
The value of the field object.
Remarks
Use this to add data other than images that might be needed for any server-side scripting.
See Also

Reference

FormDataCollection Class
Add Overload
Atalasoft.Imaging Namespace


FormDataCollection.Add Method (String, AtalaImage, String)

FormDataCollectionAdd Method (String, AtalaImage, String)

Adds an image to the collection specifying the filename.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fieldName,
    AtalaImage image,
    string fileName
)
Public Sub Add (
    fieldName As String,
    image As AtalaImage,
    fileName As String
)

Parameters

fieldName
Type: SystemString
The form field name used to identify this image.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to add.
fileName
Type: SystemString
The original filename of this image.
See Also

Reference

FormDataCollection Class
Add Overload
Atalasoft.Imaging Namespace


FormDataCollection.Add Method (String, Stream, String, String)

FormDataCollectionAdd Method (String, Stream, String, String)

Adds an image to the collection specifying the filename.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fieldName,
    Stream data,
    string fileName,
    string contextType
)
Public Sub Add (
    fieldName As String,
    data As Stream,
    fileName As String,
    contextType As String
)

Parameters

fieldName
Type: SystemString
The form field name used to identify this image.
data
Type: System.IOStream
The data stream
fileName
Type: SystemString
The original filename of this image.
contextType
Type: SystemString
Also known as mime type, for example "image\jpeg".
See Also

Reference

FormDataCollection Class
Add Overload
Atalasoft.Imaging Namespace


FormDataCollection.AddFromBrowser Method

FormDataCollectionAddFromBrowser Method

Adds an image or form field to the collection.

You must use this method when posting from a web browser.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddFromBrowser(
    string fieldName,
    Object image,
    string fieldValue
)
Public Sub AddFromBrowser (
    fieldName As String,
    image As Object,
    fieldValue As String
)

Parameters

fieldName
Type: SystemString
The field name of the form object.
image
Type: SystemObject
The image you want to upload.
fieldValue
Type: SystemString
The value of the field object or the filename of the image.
Remarks
When adding an image, set the fieldValue to the filename of the image. When adding a form field entry, set the image to null.
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.Contains Method

FormDataCollectionContains Method

Determines whether [contains] [the specified image].

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    AtalaImage image
)
Public Function Contains (
    image As AtalaImage
) As Boolean

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: Boolean
true if the image is in the collection, false otherwise
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.CopyTo Method

FormDataCollectionCopyTo Method

Copies to the array

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    AtalaImage[] images,
    int index
)
Public Sub CopyTo (
    images As AtalaImage(),
    index As Integer
)

Parameters

images
Type: Atalasoft.ImagingAtalaImage
The images.
index
Type: SystemInt32
The index.
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.IndexOf Method

FormDataCollectionIndexOf Method

Returns the index of the image

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    AtalaImage image
)
Public Function IndexOf (
    image As AtalaImage
) As Integer

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: Int32
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.Insert Method

FormDataCollectionInsert Method

Inserts the image at the specified index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AtalaImage image
)
Public Sub Insert (
    index As Integer,
    image As AtalaImage
)

Parameters

index
Type: SystemInt32
The index.
image
Type: Atalasoft.ImagingAtalaImage
The image.
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


FormDataCollection.Remove Method

FormDataCollectionRemove Method

Removes the specified image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    AtalaImage image
)
Public Sub Remove (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.
See Also

Reference

FormDataCollection Class
Atalasoft.Imaging Namespace


GdiException Class

This exception is thrown when a GDI function fails.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingGdiException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GdiException : Exception
<SerializableAttribute>
Public Class GdiException
    Inherits Exception

The GdiException type exposes the following members.

Constructors
 | Name | Description
Public method | GdiException | Creates a new instance of GdiException.
Public method | GdiException(String) | Creates a new instance of GdiException specifying the exception message.
Protected method | GdiException(SerializationInfo, StreamingContext) | Initializes a new instance of the GdiException class.
Public method | GdiException(String, Exception) | Creates a new instance of GdiException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


GdiException Constructor

Creates an instance of GdiException.
Overload List
 | Name | Description
Public method | GdiException | Creates a new instance of GdiException.
Public method | GdiException(String) | Creates a new instance of GdiException specifying the exception message.
Protected method | GdiException(SerializationInfo, StreamingContext) | Initializes a new instance of the GdiException class.
Public method | GdiException(String, Exception) | Creates a new instance of GdiException specifying the exception message and inner exception.
Top
See Also

Reference

GdiException Class
Atalasoft.Imaging Namespace


GdiException Constructor

Creates a new instance of GdiException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GdiException()
Public Sub New
See Also

Reference

GdiException Class
GdiException Overload
Atalasoft.Imaging Namespace


GdiException Constructor (String)

Creates a new instance of GdiException specifying the exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GdiException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

GdiException Class
GdiException Overload
Atalasoft.Imaging Namespace


GdiException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the GdiException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GdiException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

GdiException Class
GdiException Overload
Atalasoft.Imaging Namespace


GdiException Constructor (String, Exception)

Creates a new instance of GdiException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GdiException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

GdiException Class
GdiException Overload
Atalasoft.Imaging Namespace


GdiException Properties

The GdiException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

GdiException Class
Atalasoft.Imaging Namespace


GdiException Methods

The GdiException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GdiException Class
Atalasoft.Imaging Namespace


GdiException Events

The GdiException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GdiException Class
Atalasoft.Imaging Namespace


HttpPost Class

This class allows you to post data to a server without user interaction.

The data is posted as if it were being sent from an HTML Form, allowing any form handling component to be used on the server.

Inheritance Hierarchy
SystemObject
Atalasoft.ImagingHttpPost

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HttpPost
Public Class HttpPost

The HttpPost type exposes the following members.

Constructors
 | Name | Description
Public method | HttpPost | Creates a new instance of HttpPost.
Public method | HttpPost(ImageEncoder) | Creates a new instance of HttpPost specifying the ImageEncoder to use.
Public method | HttpPost(ImageEncoder, Boolean) | Creates a new instance of HttpPost specifying the ImageEncoder to use and whether or not to combine multiple images into one post.
Top
Properties
 | Name | Description
Public property | CombineImages | Sets or gets whether or not multiple images will be combined into one post.
Public property | FormData | Gets the FormDataCollection object that will be posted to the server.
Public property | SessionCookies | Gets or sets the session cookies.
Public property | Timeout | Gets or sets the timeout.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | This method can be used to retrieve information from a server.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostData | This method will send the internal FormDataCollection entries to a server for processing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Posting an image (C#)
Copy
// Load the image we want to upload.
Bitmap bmp = new Bitmap(@"C:\myimage.jpg");

// We are going to save the image as JPEG on the server.
HttpPost post = new HttpPost(System.Drawing.Imaging.ImageFormat.Jpeg);
post.FormData.Add("image1", bmp, "myimage.jpg");

// Now lets add the additional information set by the client.
post.FormData.Add("comment", this.textComment.Text);
post.FormData.Add("author", this.textAuthor.Text);

// Upload the image and check the return value to see if it worked.
string retVal = post.PostData("http://www.mysite.com/handleupload.aspx");
if (retVal != "Success")
    MessageBox.Show(this, retVal, "Upload Error");

// Free the image.
bmp.Dispose();
Posting an image (Visual Basic)
Copy
' Load the image we want to upload.
Dim bmp As Bitmap = New Bitmap("C:\myimage.jpg")

' We are going to save the image as JPEG on the server.
Dim post As HttpPost = New HttpPost(System.Drawing.Imaging.ImageFormat.Jpeg)
post.FormData.Add("image1", bmp, "myimage.jpg")

' Now lets add the additional information set by the client.
post.FormData.Add("comment", Me.textComment.Text)
post.FormData.Add("author", Me.textAuthor.Text)

' Upload the image and check the return value to see if it worked.
Dim retVal As String =  post.PostData("http://www.mysite.com/handleupload.aspx")
If retVal <> "Success" Then
    MessageBox.Show(this, retVal, "Upload Error")
End If

' Free the image.
bmp.Dispose()

This example will show you how to acquire an image from a web page and post it to the server.

Posting from a browser (JScript)
Copy
<!-- The main Acquisition object. -->
<object id="Twain" height="1" width="1" classid="Atalasoft.Imaging.dll#Atalasoft.Imaging.Acquisition" VIEWASTEXT>
</object>

<!-- Create an instance of the HttpPost object -->
<object id="PostIt" height="1" width="1" classid="Atalasoft.Imaging.dll#Atalasoft.Imaging.HttpPost" VIEWASTEXT>
</object>

...

<script type="text/javascript">
var count = 0;
function AcquireImage()
{
    // Acquire the image.
    var img = document.Twain.AcquireModal(false);
    if (img == null)
    {
        alert('Image was not acquired.');
        return;
    }

    // Send the image to the server.
    count++;
    var filename = 'image' + count + '.png';
    document.PostIt.FormData.AddFromBrowser('postImage', img, filename);

    var response = "";
    response = document.PostIt.PostData('http://localhost/TwainDemo/savepost.aspx');

    // Free the form data.
    document.PostIt.FormData.Clear();

    // Update the image.
    if (response.length > 0)
    {
        var el = document.getElementById('preview');
        el.src = response;
    } else {
        alert("PostDataFromBrowser failed");
    }
}
</script>
See Also

Reference

Atalasoft.Imaging Namespace
Atalasoft.ImagingFormDataCollection


HttpPost Constructor

Creates an instance of HttpPost.
Overload List
 | Name | Description
Public method | HttpPost | Creates a new instance of HttpPost.
Public method | HttpPost(ImageEncoder) | Creates a new instance of HttpPost specifying the ImageEncoder to use.
Public method | HttpPost(ImageEncoder, Boolean) | Creates a new instance of HttpPost specifying the ImageEncoder to use and whether or not to combine multiple images into one post.
Top
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost Constructor

Creates a new instance of HttpPost.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HttpPost()
Public Sub New
See Also

Reference

HttpPost Class
HttpPost Overload
Atalasoft.Imaging Namespace


HttpPost Constructor (ImageEncoder)

Creates a new instance of HttpPost specifying the ImageEncoder to use.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HttpPost(
    ImageEncoder encoder
)
Public Sub New (
    encoder As ImageEncoder
)

Parameters

encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use when posting images to the server.
See Also

Reference

HttpPost Class
HttpPost Overload
Atalasoft.Imaging Namespace


HttpPost Constructor (ImageEncoder, Boolean)

Creates a new instance of HttpPost specifying the ImageEncoder to use and whether or not to combine multiple images into one post.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HttpPost(
    ImageEncoder encoder,
    bool combineImages
)
Public Sub New (
    encoder As ImageEncoder,
    combineImages As Boolean
)

Parameters

encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use when posting images to the server.
combineImages
Type: SystemBoolean
Whether or not to combine multiple images into one post.
See Also

Reference

HttpPost Class
HttpPost Overload
Atalasoft.Imaging Namespace


HttpPost Properties

The HttpPost type exposes the following members.

Properties
 | Name | Description
Public property | CombineImages | Sets or gets whether or not multiple images will be combined into one post.
Public property | FormData | Gets the FormDataCollection object that will be posted to the server.
Public property | SessionCookies | Gets or sets the session cookies.
Public property | Timeout | Gets or sets the timeout.
Top
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost.CombineImages Property

HttpPostCombineImages Property

Sets or gets whether or not multiple images will be combined into one post.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CombineImages { get; set; }
Public Property CombineImages As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost.FormData Property

HttpPostFormData Property

Gets the FormDataCollection object that will be posted to the server.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormDataCollection FormData { get; }
Public ReadOnly Property FormData As FormDataCollection
    Get

Property Value

Type: FormDataCollection
The FormDataCollection object that will be posted to the server.
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost.SessionCookies Property

HttpPostSessionCookies Property

Gets or sets the session cookies.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SessionCookies { get; set; }
Public Property SessionCookies As String
    Get
    Set

Property Value

Type: String
The session cookies.
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost.Timeout Property

HttpPostTimeout Property

Gets or sets the timeout.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set

Property Value

Type: Int32
The timeout.
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost Methods

The HttpPost type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | This method can be used to retrieve information from a server.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostData | This method will send the internal FormDataCollection entries to a server for processing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost.GetData Method

HttpPostGetData Method

This method can be used to retrieve information from a server.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetData(
    string url
)
Public Function GetData (
    url As String
) As String

Parameters

url
Type: SystemString
A web address to request data from.

Return Value

Type: String
A string containing the data returned by the server.
Remarks
Use this method when you only want to retrieve information. You can send parameters to the server by adding query string values to the url.
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


HttpPost.PostData Method

HttpPostPostData Method

This method will send the internal FormDataCollection entries to a server for processing.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PostData(
    string url
)
Public Function PostData (
    url As String
) As String

Parameters

url
Type: SystemString
The web address to send the data to.

Return Value

Type: String
A string containing returned data from the server.
See Also

Reference

HttpPost Class
Atalasoft.Imaging Namespace


IImageReloader Interface

IImageReloader provides a mechanism to bring unloaded images back into memory. This interface is used by ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IImageReloader : IDisposable
Public Interface IImageReloader
    Inherits IDisposable

The IImageReloader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Reload | Reload an image into memory.
Top
Remarks
Typically, an IImageReloader is created at the same time that an image is first loaded into physical memory. That way the IImageReloader can encapsulate all the information needed to bring that image back into memory at a later time.
See Also

Reference

Atalasoft.Imaging Namespace


IImageReloader Methods

The IImageReloader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Reload | Reload an image into memory.
Top
See Also

Reference

IImageReloader Interface
Atalasoft.Imaging Namespace


IImageReloader.Reload Method

IImageReloaderReload Method

Reload an image into memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AtalaImage Reload()
Function Reload As AtalaImage

Return Value

Type: AtalaImage
An AtalaImage representing a previously loaded image.
See Also

Reference

IImageReloader Interface
Atalasoft.Imaging Namespace


ImageCancelEventArgs Class

Provides data for the event which allow an operation using an image to be cancelled.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingImageEventArgs
Atalasoft.ImagingImageCancelEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageCancelEventArgs : ImageEventArgs
Public Class ImageCancelEventArgs
    Inherits ImageEventArgs

The ImageCancelEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCancelEventArgs | Creates a new instance of ImageCancelEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value that when true will cancel the current operation.
Public property | Image | Gets or sets the AtalaImage. (Inherited from ImageEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageCancelEventArgs Constructor

Creates a new instance of ImageCancelEventArgs.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCancelEventArgs(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image being processed.
See Also

Reference

ImageCancelEventArgs Class
Atalasoft.Imaging Namespace


ImageCancelEventArgs Properties

The ImageCancelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value that when true will cancel the current operation.
Public property | Image | Gets or sets the AtalaImage. (Inherited from ImageEventArgs.)
Top
See Also

Reference

ImageCancelEventArgs Class
Atalasoft.Imaging Namespace


ImageCancelEventArgs.Cancel Property

ImageCancelEventArgsCancel Property

Gets or sets a value that when true will cancel the current operation.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value that when true will cancel the current operation.
See Also

Reference

ImageCancelEventArgs Class
Atalasoft.Imaging Namespace


ImageCancelEventArgs Methods

The ImageCancelEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageCancelEventArgs Class
Atalasoft.Imaging Namespace


ImageCancelEventHandler Delegate

Handles canceling operations.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ImageCancelEventHandler(
    Object sender,
    ImageCancelEventArgs e
)
Public Delegate Sub ImageCancelEventHandler (
    sender As Object,
    e As ImageCancelEventArgs
)

Parameters

sender
Type: SystemObject
The object raising the event.
e
Type: Atalasoft.ImagingImageCancelEventArgs
An ImageCancelEventArgs object for this event.
See Also

Reference

Atalasoft.Imaging Namespace


ImageCollection Class

This collection holds multiple AtalaImage objects useful for various features like working with multi-paged images, animations, and layering.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.ImagingImageCollection

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageCollection : CollectionBase,
    IList, ICollection, IEnumerable, IDisposable
Public Class ImageCollection
    Inherits CollectionBase
    Implements IList, ICollection, IEnumerable, IDisposable

The ImageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCollection | Initializes a new instance of the ImageCollection class.
Public method | ImageCollection(AtalaImage) | Initializes a new instance of the %ImageCollection% object specifying one or multiple %AtalaImage% objects to add to the collection.
Public method | ImageCollection(Stream, ProgressEventHandler) | Initializes a new instance of the %ImageCollection% object specifying a Stream containing image data to load.
Public method | ImageCollection(String, ProgressEventHandler) | Initializes a new instance of the %ImageCollection% object specifying a filename containing image data to load.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Current | Gets or sets the current image in this collection.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows the image collection to be accessed through an indexer and enumerated with foreach.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an AtalaImage to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value Indicating if a specified image exists within this collection.
Public method | CopyTo | Copy this ImageCollection into an existing AtalaImage array.
Public method | Dispose | Remove unmanaged resources in each AtalaImage in the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified image in the collection.
Public method | Insert | Insert an AtalaImage at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Set the Current image to the next image in the collection.
Public method | MovePrevious | Set the Current image to the previous image in the collection.
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | ReadImages | Read all images from a multipage image file into this image collection.
Public method | Remove | Removes a specified AtalaImage from this ImageCollection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Replace | Replaces the Current image in the collection with a new image.
Public method | Save(Stream, ImageEncoder, ProgressEventHandler) | Save the images in this ImageCollection to a stream specifying the %ImageEncoder% to use for encoding the image data.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Save each ImageCollection in a multipaged or multiframed format.
Public method | Save(String, ImageType, ProgressEventHandler) | Obsolete. Save each ImageCollection in a multipaged or multiframed format.
Public method | ToByteArray | Saves the image into a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageCollection Constructor

Overload List
 | Name | Description
Public method | ImageCollection | Initializes a new instance of the ImageCollection class.
Public method | ImageCollection(AtalaImage) | Initializes a new instance of the %ImageCollection% object specifying one or multiple %AtalaImage% objects to add to the collection.
Public method | ImageCollection(Stream, ProgressEventHandler) | Initializes a new instance of the %ImageCollection% object specifying a Stream containing image data to load.
Public method | ImageCollection(String, ProgressEventHandler) | Initializes a new instance of the %ImageCollection% object specifying a filename containing image data to load.
Top
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection Constructor

Initializes a new instance of the ImageCollection class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection()
Public Sub New
See Also

Reference

ImageCollection Class
ImageCollection Overload
Atalasoft.Imaging Namespace


ImageCollection Constructor (AtalaImage[])

ImageCollection Constructor (AtalaImage)

Initializes a new instance of the %ImageCollection% object specifying one or multiple %AtalaImage% objects to add to the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection(
    params AtalaImage[] images
)
Public Sub New (
    ParamArray images As AtalaImage()
)

Parameters

images
Type: Atalasoft.ImagingAtalaImage
A parameter array of one or many %AtalaImage% objects.
See Also

Reference

ImageCollection Class
ImageCollection Overload
Atalasoft.Imaging Namespace


ImageCollection Constructor (Stream, ProgressEventHandler)

Initializes a new instance of the %ImageCollection% object specifying a Stream containing image data to load.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection(
    Stream stream,
    ProgressEventHandler progress
)
Public Sub New (
    stream As Stream,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A Stream of image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

ImageCollection Class
ImageCollection Overload
Atalasoft.Imaging Namespace


ImageCollection Constructor (String, ProgressEventHandler)

Initializes a new instance of the %ImageCollection% object specifying a filename containing image data to load.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection(
    string fileName,
    ProgressEventHandler progress
)
Public Sub New (
    fileName As String,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The filename of the image (or images) to load into the %ImageCollection%.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

ImageCollection Class
ImageCollection Overload
Atalasoft.Imaging Namespace


ImageCollection Properties

The ImageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Current | Gets or sets the current image in this collection.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows the image collection to be accessed through an indexer and enumerated with foreach.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Current Property

ImageCollectionCurrent Property

Gets or sets the current image in this collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Current { get; set; }
Public Property Current As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
This is the image that is processed by any commands and displayed in the WorkspaceViewer.
Remarks
The Current image in the collection is the image that is considered active if there is an associated Workspace that has a reference to this collection. Any image processing commands will be applied to the Current image.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Item Property

ImageCollectionItem Property

Allows the image collection to be accessed through an indexer and enumerated with foreach.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As AtalaImage
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the image.

Property Value

Type: AtalaImage
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection Methods

The ImageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an AtalaImage to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value Indicating if a specified image exists within this collection.
Public method | CopyTo | Copy this ImageCollection into an existing AtalaImage array.
Public method | Dispose | Remove unmanaged resources in each AtalaImage in the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified image in the collection.
Public method | Insert | Insert an AtalaImage at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Set the Current image to the next image in the collection.
Public method | MovePrevious | Set the Current image to the previous image in the collection.
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | ReadImages | Read all images from a multipage image file into this image collection.
Public method | Remove | Removes a specified AtalaImage from this ImageCollection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Replace | Replaces the Current image in the collection with a new image.
Public method | Save(Stream, ImageEncoder, ProgressEventHandler) | Save the images in this ImageCollection to a stream specifying the %ImageEncoder% to use for encoding the image data.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Save each ImageCollection in a multipaged or multiframed format.
Public method | Save(String, ImageType, ProgressEventHandler) | Obsolete. Save each ImageCollection in a multipaged or multiframed format.
Public method | ToByteArray | Saves the image into a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Add Method

ImageCollectionAdd Method

Adds an AtalaImage to the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AtalaImage image
)
Public Sub Add (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to add.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Contains Method

ImageCollectionContains Method

Returns a value Indicating if a specified image exists within this collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    AtalaImage image
)
Public Overridable Function Contains (
    image As AtalaImage
) As Boolean

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to test.

Return Value

Type: Boolean
A value Indicating if a specified image exists within this collection.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.CopyTo Method

ImageCollectionCopyTo Method

Copy this ImageCollection into an existing AtalaImage array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    AtalaImage[] images,
    int index
)
Public Overridable Sub CopyTo (
    images As AtalaImage(),
    index As Integer
)

Parameters

images
Type: Atalasoft.ImagingAtalaImage
The existing AtalaImage array.
index
Type: SystemInt32
The index in the array begin copying.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Dispose Method

ImageCollectionDispose Method

Overload List
 | Name | Description
Public method | Dispose | Remove unmanaged resources in each AtalaImage in the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Dispose Method

ImageCollectionDispose Method

Remove unmanaged resources in each AtalaImage in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ImageCollection Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageCollection.Dispose Method (Boolean)

ImageCollectionDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImageCollection Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageCollection.IndexOf Method

ImageCollectionIndexOf Method

Returns the index of a specified image in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    AtalaImage image
)
Public Overridable Function IndexOf (
    image As AtalaImage
) As Integer

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to test.

Return Value

Type: Int32
The index of a specified image in the collection.
Remarks
Returns -1 if the image doesn't exist in the collection.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Insert Method

ImageCollectionInsert Method

Insert an AtalaImage at the specified index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    AtalaImage image
)
Public Overridable Sub Insert (
    index As Integer,
    image As AtalaImage
)

Parameters

index
Type: SystemInt32
The index to insert the image after.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to insert into the collection.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.MoveNext Method

ImageCollectionMoveNext Method

Set the Current image to the next image in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MoveNext()
Public Sub MoveNext
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.MovePrevious Method

ImageCollectionMovePrevious Method

Set the Current image to the previous image in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MovePrevious()
Public Sub MovePrevious
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.OnClearComplete Method

ImageCollectionOnClearComplete Method

Performs additional custom processes after clearing the contents of the CollectionBase instance.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.OnRemoveComplete Method

ImageCollectionOnRemoveComplete Method

Performs additional custom processes after removing an element from the CollectionBase instance.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which value can be found.
value
Type: SystemObject
The value of the element to remove from index.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.ReadImages Method

ImageCollectionReadImages Method

Read all images from a multipage image file into this image collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ReadImages(
    Stream stream,
    ProgressEventHandler progress
)
Public Sub ReadImages (
    stream As Stream,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
Remarks
If the source image doens't support multiple images, only a single image will be loaded into the collection.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Remove Method

ImageCollectionRemove Method

Removes a specified AtalaImage from this ImageCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    AtalaImage image
)
Public Overridable Sub Remove (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image in the collection to remove.
Remarks
The image that is being removed, will not be automatically disposed by the Workspace. To immediatly free memory, the image that's being removed must be disposed.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Replace Method

ImageCollectionReplace Method

Replaces the Current image in the collection with a new image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Replace(
    AtalaImage image
)
Public Overridable Sub Replace (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage

The new image.

Remarks
The image that is being removed, will not be automatically disposed by the Workspace. To immediately free memory, the image that's being removed must be disposed. See the Workspace.Image property in the Workspace class to replace an image, and add it to the UndoCollection, and dispose of it automatically.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace
Image Property


ImageCollection.Save Method

ImageCollectionSave Method

Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder, ProgressEventHandler) | Save the images in this ImageCollection to a stream specifying the %ImageEncoder% to use for encoding the image data.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Save each ImageCollection in a multipaged or multiframed format.
Public method | Save(String, ImageType, ProgressEventHandler) | Obsolete. Save each ImageCollection in a multipaged or multiframed format.
Top
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollection.Save Method (Stream, ImageEncoder, ProgressEventHandler)

ImageCollectionSave Method (Stream, ImageEncoder, ProgressEventHandler)

Save the images in this ImageCollection to a stream specifying the %ImageEncoder% to use for encoding the image data.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long Save(
    Stream stream,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Function Save (
    stream As Stream,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream containing the file which the image will be encoded to. This stream must have FileAccess.ReadWrite set or else only the first image will be saved.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Int64
Remarks
The ImageEncoder must have the IAppendable interface in order to save multiple images in one file.
See Also

Reference

ImageCollection Class
Save Overload
Atalasoft.Imaging Namespace


ImageCollection.Save Method (String, ImageEncoder, ProgressEventHandler)

ImageCollectionSave Method (String, ImageEncoder, ProgressEventHandler)

Save each ImageCollection in a multipaged or multiframed format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long Save(
    string fileName,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Function Save (
    fileName As String,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
) As Long

Parameters

fileName
Type: SystemString
The name of the file to save.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Int64
See Also

Reference

ImageCollection Class
Save Overload
Atalasoft.Imaging Namespace


ImageCollection.Save Method (String, ImageType, ProgressEventHandler)

ImageCollectionSave Method (String, ImageType, ProgressEventHandler)

Note: This API is now obsolete.

Save each ImageCollection in a multipaged or multiframed format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)]
public long Save(
    string fileName,
    ImageType imageType,
    ProgressEventHandler progress
)
<ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)>
Public Function Save (
    fileName As String,
    imageType As ImageType,
    progress As ProgressEventHandler
) As Long

Parameters

fileName
Type: SystemString
The name of the file to save.
imageType
Type: Atalasoft.Imaging.CodecImageType
The image format to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in VB).

Return Value

Type: Int64
Filesize of saved image.
See Also

Reference

ImageCollection Class
Save Overload
Atalasoft.Imaging Namespace


ImageCollection.ToByteArray Method

ImageCollectionToByteArray Method

Saves the image into a byte array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray(
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Function ToByteArray (
    encoder As ImageEncoder,
    progress As ProgressEventHandler
) As Byte()

Parameters

encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress event handler used during the save process.

Return Value

Type: Byte
A byte array containing the image data.
See Also

Reference

ImageCollection Class
Atalasoft.Imaging Namespace


ImageCollectionEventArgs Class

Provides data for the Workspace NewImage and ChangedImage events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingImageEventArgs
Atalasoft.ImagingImageCollectionEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageCollectionEventArgs : ImageEventArgs
Public Class ImageCollectionEventArgs
    Inherits ImageEventArgs

The ImageCollectionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCollectionEventArgs | Creates a new instance of ImageCollectionEventArgs.
Public method | ImageCollectionEventArgs(ImageCollection) | Creates a new instance of ImageCollectionEventArgs specifying the ImageCollection.
Top
Properties
 | Name | Description
Public property | Image | Gets or sets the AtalaImage. (Inherited from ImageEventArgs.)
Public property | Images | Gets or sets the ImageCollection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageCollectionEventArgs Constructor

Creates an ImageCollectionEventArgs object.
Overload List
 | Name | Description
Public method | ImageCollectionEventArgs | Creates a new instance of ImageCollectionEventArgs.
Public method | ImageCollectionEventArgs(ImageCollection) | Creates a new instance of ImageCollectionEventArgs specifying the ImageCollection.
Top
See Also

Reference

ImageCollectionEventArgs Class
Atalasoft.Imaging Namespace


ImageCollectionEventArgs Constructor

Creates a new instance of ImageCollectionEventArgs.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollectionEventArgs()
Public Sub New
See Also

Reference

ImageCollectionEventArgs Class
ImageCollectionEventArgs Overload
Atalasoft.Imaging Namespace


ImageCollectionEventArgs Constructor (ImageCollection)

Creates a new instance of ImageCollectionEventArgs specifying the ImageCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollectionEventArgs(
    ImageCollection images
)
Public Sub New (
    images As ImageCollection
)

Parameters

images
Type: Atalasoft.ImagingImageCollection
The ImageCollection for this event.
See Also

Reference

ImageCollectionEventArgs Class
ImageCollectionEventArgs Overload
Atalasoft.Imaging Namespace


ImageCollectionEventArgs Properties

The ImageCollectionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets or sets the AtalaImage. (Inherited from ImageEventArgs.)
Public property | Images | Gets or sets the ImageCollection.
Top
See Also

Reference

ImageCollectionEventArgs Class
Atalasoft.Imaging Namespace


ImageCollectionEventArgs.Images Property

ImageCollectionEventArgsImages Property

Gets or sets the ImageCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection Images { get; set; }
Public Property Images As ImageCollection
    Get
    Set

Property Value

Type: ImageCollection
The ImageCollection for this event.
See Also

Reference

ImageCollectionEventArgs Class
Atalasoft.Imaging Namespace


ImageCollectionEventArgs Methods

The ImageCollectionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageCollectionEventArgs Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource Class

ImageCollectionImageSource is an adapter class to make an ImageCollection compatible with the ImageSource class.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.ImagingImageCollectionImageSource

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageCollectionImageSource : RandomAccessImageSource
Public Class ImageCollectionImageSource
    Inherits RandomAccessImageSource

The ImageCollectionImageSource type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCollectionImageSource | Constructs a new ImageCollectionImageSource with the given ImageCollection.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from RandomAccessImageSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Lows the level acquire. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows the level acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows the level dispose. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows the level flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows the level has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows the level replace image. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Lows the level reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows the level skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows the level total images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Overrides RandomAccessImageSourceLowLevelTotalImagesKnown.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageCollectionImageSource Constructor

Constructs a new ImageCollectionImageSource with the given ImageCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollectionImageSource(
    ImageCollection collection
)
Public Sub New (
    collection As ImageCollection
)

Parameters

collection
Type: Atalasoft.ImagingImageCollection
The collection to be used in the ImageSource.
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource Properties

The ImageCollectionImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource Methods

The ImageCollectionImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from RandomAccessImageSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Lows the level acquire. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows the level acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows the level dispose. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows the level flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows the level has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows the level replace image. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Lows the level reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows the level skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows the level total images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Overrides RandomAccessImageSourceLowLevelTotalImagesKnown.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelAcquire Method

ImageCollectionImageSourceLowLevelAcquire Method

Lows the level acquire.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquire(
    int index
)
Protected Overrides Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32
The index.

Return Value

Type: ImageSourceNode
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelAcquireNextImage Method

ImageCollectionImageSourceLowLevelAcquireNextImage Method

Lows the level acquire next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquireNextImage()
Protected Overrides Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelDispose Method

ImageCollectionImageSourceLowLevelDispose Method

Lows the level dispose.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelDispose()
Protected Overrides Sub LowLevelDispose
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelFlushOnReset Method

ImageCollectionImageSourceLowLevelFlushOnReset Method

Lows the level flush on reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelFlushOnReset()
Protected Overrides Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelHasMoreImages Method

ImageCollectionImageSourceLowLevelHasMoreImages Method

Lows the level has more images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelHasMoreImages()
Protected Overrides Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelReplaceImage Method

ImageCollectionImageSourceLowLevelReplaceImage Method

Lows the level replace image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReplaceImage(
    ImageSourceNode node,
    AtalaImage newImage
)
Protected Overrides Sub LowLevelReplaceImage (
    node As ImageSourceNode,
    newImage As AtalaImage
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node.
newImage
Type: Atalasoft.ImagingAtalaImage
The new image.
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelReset Method

ImageCollectionImageSourceLowLevelReset Method

Lows the level reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReset()
Protected Overrides Sub LowLevelReset
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelSkipNextImage Method

ImageCollectionImageSourceLowLevelSkipNextImage Method

Lows the level skip next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelSkipNextImage()
Protected Overrides Sub LowLevelSkipNextImage
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelTotalImages Method

ImageCollectionImageSourceLowLevelTotalImages Method

Lows the level total images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LowLevelTotalImages()
Protected Overrides Function LowLevelTotalImages As Integer

Return Value

Type: Int32
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource.LowLevelTotalImagesKnown Method

ImageCollectionImageSourceLowLevelTotalImagesKnown Method

Returns if the total images is known.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelTotalImagesKnown()
Protected Overrides Function LowLevelTotalImagesKnown As Boolean

Return Value

Type: Boolean
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageCollectionImageSource Events

The ImageCollectionImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

ImageCollectionImageSource Class
Atalasoft.Imaging Namespace


ImageEventArgs Class

Provides data for the NewImage and Workspace.ImageChanged events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingImageEventArgs
Atalasoft.Imaging.Codec.Jpeg2000ProgressiveImageEventArgs
Atalasoft.ImagingImageCancelEventArgs
Atalasoft.ImagingImageCollectionEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageEventArgs : EventArgs
Public Class ImageEventArgs
    Inherits EventArgs

The ImageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageEventArgs | Creates a new instance of ImageEventArgs.
Public method | ImageEventArgs(AtalaImage) | Creates a new instance of ImageEventArgs specifying the AtalaImage for this event.
Top
Properties
 | Name | Description
Public property | Image | Gets or sets the AtalaImage.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageEventArgs Constructor

Creates an ImageEventArgs object.
Overload List
 | Name | Description
Public method | ImageEventArgs | Creates a new instance of ImageEventArgs.
Public method | ImageEventArgs(AtalaImage) | Creates a new instance of ImageEventArgs specifying the AtalaImage for this event.
Top
See Also

Reference

ImageEventArgs Class
Atalasoft.Imaging Namespace


ImageEventArgs Constructor

Creates a new instance of ImageEventArgs.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageEventArgs()
Public Sub New
See Also

Reference

ImageEventArgs Class
ImageEventArgs Overload
Atalasoft.Imaging Namespace


ImageEventArgs Constructor (AtalaImage)

Creates a new instance of ImageEventArgs specifying the AtalaImage for this event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageEventArgs(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage for this event.
See Also

Reference

ImageEventArgs Class
ImageEventArgs Overload
Atalasoft.Imaging Namespace


ImageEventArgs Properties

The ImageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets or sets the AtalaImage.
Top
See Also

Reference

ImageEventArgs Class
Atalasoft.Imaging Namespace


ImageEventArgs.Image Property

ImageEventArgsImage Property

Gets or sets the AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage.

Property Value

Type: AtalaImage
The AtalaImage for this event.
See Also

Reference

ImageEventArgs Class
Atalasoft.Imaging Namespace


ImageEventArgs Methods

The ImageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageEventArgs Class
Atalasoft.Imaging Namespace


ImageEventHandler Delegate

Event Handler for events requiring the image information.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ImageEventHandler(
    Object sender,
    ImageEventArgs e
)
Public Delegate Sub ImageEventHandler (
    sender As Object,
    e As ImageEventArgs
)

Parameters

sender
Type: SystemObject
The object raising the event.
e
Type: Atalasoft.ImagingImageEventArgs
An ImageEventArgs object for this event.
See Also

Reference

Atalasoft.Imaging Namespace


ImageFileIOEventHandler Delegate

Event Handler requiring the a Stream object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ImageFileIOEventHandler(
    Object sender,
    ImageStreamEventArgs e
)
Public Delegate Sub ImageFileIOEventHandler (
    sender As Object,
    e As ImageStreamEventArgs
)

Parameters

sender
Type: SystemObject
The object raising the event.
e
Type: Atalasoft.ImagingImageStreamEventArgs
an ImageStreamEventArgs object for this event.
See Also

Reference

Atalasoft.Imaging Namespace


ImageMemory Class

Note: This API is now obsolete.

This class handles memory associated with an image. It controls how the memory is allocated and freed. Use this class to enable memory file mapping.

This class is no longer used in DotImage. Please use PixelMemory instead.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingImageMemory

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")]
public class ImageMemory : MarshalByRefObject,
    IDisposable
<ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")>
Public Class ImageMemory
    Inherits MarshalByRefObject
    Implements IDisposable

The ImageMemory type exposes the following members.

Constructors
 | Name | Description
Public method | ImageMemory | Obsolete. Initializes a new instance of the ImageMemory class.
Public method | ImageMemory(Int32) | Obsolete. Initializes a new instance of ImageMemory indicating the number of bytes to allocate.
Public method | ImageMemory(IntPtr) | Obsolete. Initializes a new instance of ImageMemory setting the pre allocated memory pointer.
Public method | ImageMemory(Int32, Boolean) | Obsolete. Initializes a new instance of ImageMemory indicating the number of bytes to allocate and if this object should handle the freeing of that memory.
Public method | ImageMemory(IntPtr, Boolean) | Obsolete. Initializes a new instance of ImageMemory setting the pre allocated memory pointer and if this object should handle the freeing of that memory.
Top
Properties
 | Name | Description
 | EnableMemoryFileMapping | Obsolete. File mapping is no longer supported. This property will throw on set.
Public property | FileMapped | Obsolete. File mapping is no longer supported.
Public property | Handle | Gets the pointer to the memory handled by this object.
 | MemoryMapTempPath | Obsolete. File mapping is no longer supported. This property will throw on set.
 | MemoryMapThreshold | Obsolete. File mapping is no longer supported. This property will throw on set.
Public property | PreventDispose | Gets or sets a value indicating if the memory should be freed when disposing.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the ImageMemory
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageMemory class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
File Mapped memory can greatly increase performance when working with extremely large images or when system resources are limited.
See Also

Reference

Atalasoft.Imaging Namespace
Introduction to Memory Management


ImageMemory Constructor

Overload List
 | Name | Description
Public method | ImageMemory | Obsolete. Initializes a new instance of the ImageMemory class.
Public method | ImageMemory(Int32) | Obsolete. Initializes a new instance of ImageMemory indicating the number of bytes to allocate.
Public method | ImageMemory(IntPtr) | Obsolete. Initializes a new instance of ImageMemory setting the pre allocated memory pointer.
Public method | ImageMemory(Int32, Boolean) | Obsolete. Initializes a new instance of ImageMemory indicating the number of bytes to allocate and if this object should handle the freeing of that memory.
Public method | ImageMemory(IntPtr, Boolean) | Obsolete. Initializes a new instance of ImageMemory setting the pre allocated memory pointer and if this object should handle the freeing of that memory.
Top
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory Constructor

Note: This API is now obsolete.

Initializes a new instance of the ImageMemory class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been deprecated.")]
public ImageMemory()
<ObsoleteAttribute("This constructor has been deprecated.")>
Public Sub New
See Also

Reference

ImageMemory Class
ImageMemory Overload
Atalasoft.Imaging Namespace


ImageMemory Constructor (Int32)

Note: This API is now obsolete.

Initializes a new instance of ImageMemory indicating the number of bytes to allocate.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")]
public ImageMemory(
    int bytes
)
<ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")>
Public Sub New (
    bytes As Integer
)

Parameters

bytes
Type: SystemInt32
number of bytes to allocate
See Also

Reference

ImageMemory Class
ImageMemory Overload
Atalasoft.Imaging Namespace


ImageMemory Constructor (IntPtr)

Note: This API is now obsolete.

Initializes a new instance of ImageMemory setting the pre allocated memory pointer.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")]
public ImageMemory(
    IntPtr imagePointer
)
<ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")>
Public Sub New (
    imagePointer As IntPtr
)

Parameters

imagePointer
Type: SystemIntPtr
The memory pointer
See Also

Reference

ImageMemory Class
ImageMemory Overload
Atalasoft.Imaging Namespace


ImageMemory Constructor (Int32, Boolean)

Note: This API is now obsolete.

Initializes a new instance of ImageMemory indicating the number of bytes to allocate and if this object should handle the freeing of that memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")]
public ImageMemory(
    int bytes,
    bool zeroMemory
)
<ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")>
Public Sub New (
    bytes As Integer,
    zeroMemory As Boolean
)

Parameters

bytes
Type: SystemInt32
number of bytes to allocate
zeroMemory
Type: SystemBoolean
indicates if the memory should be freed when disposing
See Also

Reference

ImageMemory Class
ImageMemory Overload
Atalasoft.Imaging Namespace


ImageMemory Constructor (IntPtr, Boolean)

Note: This API is now obsolete.

Initializes a new instance of ImageMemory setting the pre allocated memory pointer and if this object should handle the freeing of that memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")]
public ImageMemory(
    IntPtr imagePointer,
    bool preventDispose
)
<ObsoleteAttribute("This class is deprecated.  Please use PixelMemory instead.")>
Public Sub New (
    imagePointer As IntPtr,
    preventDispose As Boolean
)

Parameters

imagePointer
Type: SystemIntPtr
The memory pointer
preventDispose
Type: SystemBoolean
indicates if the memory should be freed when disposing
See Also

Reference

ImageMemory Class
ImageMemory Overload
Atalasoft.Imaging Namespace


ImageMemory Properties

The ImageMemory type exposes the following members.

Properties
 | Name | Description
 | EnableMemoryFileMapping | Obsolete. File mapping is no longer supported. This property will throw on set.
Public property | FileMapped | Obsolete. File mapping is no longer supported.
Public property | Handle | Gets the pointer to the memory handled by this object.
 | MemoryMapTempPath | Obsolete. File mapping is no longer supported. This property will throw on set.
 | MemoryMapThreshold | Obsolete. File mapping is no longer supported. This property will throw on set.
Public property | PreventDispose | Gets or sets a value indicating if the memory should be freed when disposing.
Top
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.EnableMemoryFileMapping Property

ImageMemoryEnableMemoryFileMapping Property

Note: This API is now obsolete.

File mapping is no longer supported. This property will throw on set.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("EnableMemoryFileMapping is no longer supported.",
    true)]
public static bool EnableMemoryFileMapping { get; set; }
<ObsoleteAttribute("EnableMemoryFileMapping is no longer supported.",
    true)>
Public Shared Property EnableMemoryFileMapping As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns false.
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.FileMapped Property

ImageMemoryFileMapped Property

Note: This API is now obsolete.

File mapping is no longer supported.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("FileMapped is no longer supported.", true)]
public bool FileMapped { get; }
<ObsoleteAttribute("FileMapped is no longer supported.", true)>
Public ReadOnly Property FileMapped As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.Handle Property

ImageMemoryHandle Property

Gets the pointer to the memory handled by this object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
    Get

Property Value

Type: IntPtr
The pointer to the memory handled by this object.
Remarks
This class is no longer used in DotImage. Please use PixelMemory instead.
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.MemoryMapTempPath Property

ImageMemoryMemoryMapTempPath Property

Note: This API is now obsolete.

File mapping is no longer supported. This property will throw on set.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("MemoryMapTempPath is no longer supported.", true)]
public static string MemoryMapTempPath { get; set; }
<ObsoleteAttribute("MemoryMapTempPath is no longer supported.", true)>
Public Shared Property MemoryMapTempPath As String
    Get
    Set

Property Value

Type: String
Get returns the empty string.
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.MemoryMapThreshold Property

ImageMemoryMemoryMapThreshold Property

Note: This API is now obsolete.

File mapping is no longer supported. This property will throw on set.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("MemoryMapThreshold is no longer supported.", true)]
public static int MemoryMapThreshold { get; set; }
<ObsoleteAttribute("MemoryMapThreshold is no longer supported.", true)>
Public Shared Property MemoryMapThreshold As Integer
    Get
    Set

Property Value

Type: Int32
Get returns 0.
Remarks
The default threshold is 30,000 bytes, but the optimal threshold is highly dependant on the client system and it's available memory.
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.PreventDispose Property

ImageMemoryPreventDispose Property

Gets or sets a value indicating if the memory should be freed when disposing.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PreventDispose { get; set; }
Public Property PreventDispose As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the memory should be freed when disposing.
Remarks

This class is no longer used in DotImage. Please use PixelMemory instead.

This should only be set to true if the same memory is being handled somewhere else.

See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory Methods

The ImageMemory type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose |
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageMemory class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.Dispose Method

ImageMemoryDispose Method

Free the memory associated with this object.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the ImageMemory
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageMemory.Dispose Method

ImageMemoryDispose Method

Releases all resources used by the ImageMemory

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ImageMemory Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageMemory.Dispose Method (Boolean)

ImageMemoryDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImageMemory Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageMemory.Finalize Method

ImageMemoryFinalize Method

Finalizes an instance of the ImageMemory class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ImageMemory Class
Atalasoft.Imaging Namespace


ImageProcessException Class

This exception is thrown when an error occurs during processing of an image
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingImageProcessException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImageProcessException : Exception
<SerializableAttribute>
Public Class ImageProcessException
    Inherits Exception

The ImageProcessException type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProcessException | Creates a new instance of ImageProcessException.
Public method | ImageProcessException(String) | Creates a new instance of ImageProcessException specifying the exception message.
Protected method | ImageProcessException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageProcessException class.
Public method | ImageProcessException(String, AtalaImage) | Creates a new instance of ImageProcessException specifying the exception message and AtalaImage.
Public method | ImageProcessException(String, Exception) | Creates a new instance of ImageProcessException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | Image | Gets or sets the AtalaImage object which is causing the error.
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Provide serialization information (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageProcessException Constructor

Creates an ImageProcessException.
Overload List
 | Name | Description
Public method | ImageProcessException | Creates a new instance of ImageProcessException.
Public method | ImageProcessException(String) | Creates a new instance of ImageProcessException specifying the exception message.
Protected method | ImageProcessException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageProcessException class.
Public method | ImageProcessException(String, AtalaImage) | Creates a new instance of ImageProcessException specifying the exception message and AtalaImage.
Public method | ImageProcessException(String, Exception) | Creates a new instance of ImageProcessException specifying the exception message and inner exception.
Top
See Also

Reference

ImageProcessException Class
Atalasoft.Imaging Namespace


ImageProcessException Constructor

Creates a new instance of ImageProcessException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageProcessException()
Public Sub New
See Also

Reference

ImageProcessException Class
ImageProcessException Overload
Atalasoft.Imaging Namespace


ImageProcessException Constructor (String)

Creates a new instance of ImageProcessException specifying the exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageProcessException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

ImageProcessException Class
ImageProcessException Overload
Atalasoft.Imaging Namespace


ImageProcessException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageProcessException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageProcessException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

ImageProcessException Class
ImageProcessException Overload
Atalasoft.Imaging Namespace


ImageProcessException Constructor (String, AtalaImage)

Creates a new instance of ImageProcessException specifying the exception message and AtalaImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageProcessException(
    string message,
    AtalaImage image
)
Public Sub New (
    message As String,
    image As AtalaImage
)

Parameters

message
Type: SystemString
The exception message.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage causing this exception.
See Also

Reference

ImageProcessException Class
ImageProcessException Overload
Atalasoft.Imaging Namespace


ImageProcessException Constructor (String, Exception)

Creates a new instance of ImageProcessException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageProcessException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

ImageProcessException Class
ImageProcessException Overload
Atalasoft.Imaging Namespace


ImageProcessException Properties

The ImageProcessException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | Image | Gets or sets the AtalaImage object which is causing the error.
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageProcessException Class
Atalasoft.Imaging Namespace


ImageProcessException.Image Property

ImageProcessExceptionImage Property

Gets or sets the AtalaImage object which is causing the error.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage object which is causing the error.

Property Value

Type: AtalaImage
The AtalaImage causing this exception.
See Also

Reference

ImageProcessException Class
Atalasoft.Imaging Namespace


ImageProcessException Methods

The ImageProcessException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Provide serialization information (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageProcessException Class
Atalasoft.Imaging Namespace


ImageProcessException.GetObjectData Method

ImageProcessExceptionGetObjectData Method

Provide serialization information

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information for this object.
context
Type: System.Runtime.SerializationStreamingContext
The context in which this object is being streamed.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ImageProcessException Class
Atalasoft.Imaging Namespace


ImageProcessException Events

The ImageProcessException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ImageProcessException Class
Atalasoft.Imaging Namespace


ImageSource Class

An abstract class that is used to define a flexible mechanism for managing large quantities of images without having to keep them all in memory at once.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ImageSource : IDisposable
Public MustInherit Class ImageSource
    Implements IDisposable

The ImageSource type exposes the following members.

Constructors
 | Name | Description
Protected method | ImageSource | Initializes a new instance of the ImageSource class.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images.
Protected property | CulledImages | Gets the culled images.
Public property | Current | Returns the index of the current image.
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately.
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource.
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit.
Public property | TotalImages | Returns the total number of available images in this ImageSource.
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known.
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead.
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead.
Public method | AcquireNext | Acquire the next available image from the ImageSource.
Protected method | AllImagesAreReleased | Determines if all the images have been released.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image.
Protected method | CullNode | Culls the node from the ImageSource
Protected method | CullReleasedImages | Culls all released images.
Public method | Dispose | Free up resources used by this ImageSource
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Overrides ObjectFinalize.)
Protected method | Find | Finds the specified image.
Public method | Flush | Flush all released images out of memory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load.
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image.
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource.
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset.
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images.
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image.
Protected method | LowLevelReset | Lows level implementation of reset.
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image.
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images.
Protected method | LowLevelTotalImagesKnown | Lows level implemtation to return if the total number of images are known.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed.
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed.
Protected method | OnChangedImage | Raises the [E:ChangedImage] event.
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode.
Public method | ReAcquire(Int32) | Acquire a previous image by index.
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired.
Public method | Release | Release a previously acquired image.
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed.
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed.
Public method | Reset | Resets the ImageSource to start over again.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced.
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode.
Top
Remarks
ImageSource objects are configurable for memory usage or for aggressive unloading of images and can be built with a cache to allow transient data sources such as live video to be treated as if they were persistent.
See Also

Reference

Atalasoft.Imaging Namespace


ImageSource Constructor

Initializes a new instance of the ImageSource class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageSource()
Protected Sub New
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource Properties

The ImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images.
Protected property | CulledImages | Gets the culled images.
Public property | Current | Returns the index of the current image.
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately.
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource.
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit.
Public property | TotalImages | Returns the total number of available images in this ImageSource.
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ActiveImages Property

ImageSourceActiveImages Property

Gets the active images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IDictionary ActiveImages { get; }
Protected ReadOnly Property ActiveImages As IDictionary
    Get

Property Value

Type: IDictionary
The active images.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.CulledImages Property

ImageSourceCulledImages Property

Gets the culled images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IList CulledImages { get; }
Protected ReadOnly Property CulledImages As IList
    Get

Property Value

Type: IList
The culled images.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Current Property

ImageSourceCurrent Property

Returns the index of the current image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Current { get; }
Public ReadOnly Property Current As Integer
    Get

Property Value

Type: Int32
Remarks
This property represents the index of the next image to be acquired, not the index of the most recently acquired image. If an ImageSource has just been constructed or Reset has been invoked, Current will be 0.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ImmediateUnload Property

ImageSourceImmediateUnload Property

Determines if an image should be unloaded from memory immediately.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ImmediateUnload { get; set; }
Public Property ImmediateUnload As Boolean
    Get
    Set

Property Value

Type: Boolean
This is set to true by default. Even if this is set to true, it does not mean that the memory for an image will be immediately released, nor does it mean that garbage collection will happen.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.MemoryInUse Property

ImageSourceMemoryInUse Property

Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MemoryInUse { get; set; }
Public Property MemoryInUse As Integer
    Get
    Set

Property Value

Type: Int32
An integer representing an estimate of the number of bytes of memory currently in use by images in this ImageSource.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.MemoryLimit Property

ImageSourceMemoryLimit Property

This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MemoryLimit { get; set; }
Public Property MemoryLimit As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.TotalImages Property

ImageSourceTotalImages Property

Returns the total number of available images in this ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TotalImages { get; }
Public ReadOnly Property TotalImages As Integer
    Get

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Thrown if this method is invoked when TotalImagesKnown is false.
Remarks
Always check that TotalImagesKnown is true before accessing this property.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.TotalImagesKnown Property

ImageSourceTotalImagesKnown Property

Gets a value indicating whether or not the total number of images in this image source can be known.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TotalImagesKnown { get; }
Public ReadOnly Property TotalImagesKnown As Boolean
    Get

Property Value

Type: Boolean
True if the total number of images can be known, false otherwise.
Remarks
Always check this property before accessing the TotalImages property.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource Methods

The ImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead.
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead.
Public method | AcquireNext | Acquire the next available image from the ImageSource.
Protected method | AllImagesAreReleased | Determines if all the images have been released.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image.
Protected method | CullNode | Culls the node from the ImageSource
Protected method | CullReleasedImages | Culls all released images.
Public method | Dispose | Free up resources used by this ImageSource
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Overrides ObjectFinalize.)
Protected method | Find | Finds the specified image.
Public method | Flush | Flush all released images out of memory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load.
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image.
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource.
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset.
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images.
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image.
Protected method | LowLevelReset | Lows level implementation of reset.
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image.
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images.
Protected method | LowLevelTotalImagesKnown | Lows level implemtation to return if the total number of images are known.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed.
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed.
Protected method | OnChangedImage | Raises the [E:ChangedImage] event.
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode.
Public method | ReAcquire(Int32) | Acquire a previous image by index.
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired.
Public method | Release | Release a previously acquired image.
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed.
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed.
Public method | Reset | Resets the ImageSource to start over again.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Acquire Method

ImageSourceAcquire Method

Acquire an AtalaImage for use.
Overload List
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead.
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Acquire Method (Int32)

ImageSourceAcquire Method (Int32)

Note: This API is now obsolete.

This method has been deprecated. Use ReAcquire(AtalaImage) instead.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been replaced with ReAcquire.",
    false)]
public virtual AtalaImage Acquire(
    int index
)
<ObsoleteAttribute("This method has been replaced with ReAcquire.",
    false)>
Public Overridable Function Acquire (
    index As Integer
) As AtalaImage

Parameters

index
Type: SystemInt32
The index of the image to acquire.

Return Value

Type: AtalaImage
The acquired image.
Remarks
Acquire a previous image by index.
See Also

Reference

ImageSource Class
Acquire Overload
Atalasoft.Imaging Namespace


ImageSource.Acquire Method (AtalaImage)

ImageSourceAcquire Method (AtalaImage)

Note: This API is now obsolete.

This method has been deprecated. Use ReAcquire(AtalaImage) instead.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been replaced with ReAcquire.",
    false)]
public bool Acquire(
    AtalaImage image
)
<ObsoleteAttribute("This method has been replaced with ReAcquire.",
    false)>
Public Function Acquire (
    image As AtalaImage
) As Boolean

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to acquire.

Return Value

Type: Boolean
True if the image has successfully acquired.
Remarks

These versions of Acquire are used to put an additional request to hold onto an AtalaImage.

Acquire an AtalaImage that has been previously acquired.

See Also

Reference

ImageSource Class
Acquire Overload
Atalasoft.Imaging Namespace


ImageSource.AcquireNext Method

ImageSourceAcquireNext Method

Acquire the next available image from the ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage AcquireNext()
Public Function AcquireNext As AtalaImage

Return Value

Type: AtalaImage
A new AtalaImage or null if the image can't be loaded or there is no image to load.
Remarks

This method may throw an exception on certain load failures, but that will depend on the concrete implementation of ImageSource.

A call to Release(AtalaImage) should be made for every Acquire.

See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.AllImagesAreReleased Method

ImageSourceAllImagesAreReleased Method

Determines if all the images have been released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool AllImagesAreReleased()
Protected Function AllImagesAreReleased As Boolean

Return Value

Type: Boolean
true if all the images have been released, false otherwise.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ContainsImage Method

ImageSourceContainsImage Method

Determines whether this ImageSource contains the specified image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ContainsImage(
    AtalaImage image
)
Public Function ContainsImage (
    image As AtalaImage
) As Boolean

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: Boolean
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.CullNode Method

ImageSourceCullNode Method

Culls the node from the ImageSource

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void CullNode(
    ImageSourceNode node
)
Protected Sub CullNode (
    node As ImageSourceNode
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node.
Exceptions
Exception | Condition
ArgumentNullException | node
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.CullReleasedImages Method

ImageSourceCullReleasedImages Method

Culls all released images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void CullReleasedImages(
    bool obeyMemoryLimit
)
Protected Sub CullReleasedImages (
    obeyMemoryLimit As Boolean
)

Parameters

obeyMemoryLimit
Type: SystemBoolean
if set to true [obey memory limit].
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Dispose Method

ImageSourceDispose Method

Free up resources used by this ImageSource
Overload List
 | Name | Description
Public method | Dispose | Free up resources used by this ImageSource
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Dispose Method

ImageSourceDispose Method

Free up resources used by this ImageSource

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ImageSource Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageSource.Dispose Method (Boolean)

ImageSourceDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImageSource Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageSource.Finalize Method

ImageSourceFinalize Method

Finalizes an instance of the ImageSource class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Find Method

ImageSourceFind Method

Finds the specified image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageSourceNode Find(
    AtalaImage image
)
Protected Function Find (
    image As AtalaImage
) As ImageSourceNode

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: ImageSourceNode
An image source node containing the image, null if it is not present.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Flush Method

ImageSourceFlush Method

Flush all released images out of memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Flush()
Public Sub Flush
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.HasMoreImages Method

ImageSourceHasMoreImages Method

Determines if there are more images to load.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasMoreImages()
Public Function HasMoreImages As Boolean

Return Value

Type: Boolean
True if there are more images to load, false otherwise.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelAcquireNextImage Method

ImageSourceLowLevelAcquireNextImage Method

Lows level implementation to acquire next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract ImageSourceNode LowLevelAcquireNextImage()
Protected MustOverride Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelDispose Method

ImageSourceLowLevelDispose Method

Lows level implementation to dispose the ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LowLevelDispose()
Protected MustOverride Sub LowLevelDispose
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelFlushOnReset Method

ImageSourceLowLevelFlushOnReset Method

Lows level implementation to determine if there should be a flush on reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract bool LowLevelFlushOnReset()
Protected MustOverride Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
true if the ImageSource needs a flush on reset, false otherwise.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelHasMoreImages Method

ImageSourceLowLevelHasMoreImages Method

Lows level implementation to determine if the ImageSource has more images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract bool LowLevelHasMoreImages()
Protected MustOverride Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
true if there are more image, false otherwise.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelReplaceImage Method

ImageSourceLowLevelReplaceImage Method

Lows level implementation to replace an image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LowLevelReplaceImage(
    ImageSourceNode node,
    AtalaImage newImage
)
Protected Overridable Sub LowLevelReplaceImage (
    node As ImageSourceNode,
    newImage As AtalaImage
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node.
newImage
Type: Atalasoft.ImagingAtalaImage
The new image.
Exceptions
Exception | Condition
ArgumentException | Unable to find original image in ImageSource for replacement.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelReset Method

ImageSourceLowLevelReset Method

Lows level implementation of reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LowLevelReset()
Protected MustOverride Sub LowLevelReset
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelSkipNextImage Method

ImageSourceLowLevelSkipNextImage Method

Lows level implementation to skip next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LowLevelSkipNextImage()
Protected MustOverride Sub LowLevelSkipNextImage
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelTotalImages Method

ImageSourceLowLevelTotalImages Method

Lows level implementation that returns the total number of images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LowLevelTotalImages()
Protected MustOverride Function LowLevelTotalImages As Integer

Return Value

Type: Int32
the total number of images
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.LowLevelTotalImagesKnown Method

ImageSourceLowLevelTotalImagesKnown Method

Lows level implemtation to return if the total number of images are known.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract bool LowLevelTotalImagesKnown()
Protected MustOverride Function LowLevelTotalImagesKnown As Boolean

Return Value

Type: Boolean
true if the total number of images is known, false otherwise.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.NotifyChangedImage Method

ImageSourceNotifyChangedImage Method

This method is used to inform an ImageSource that one of its current acquired images has changed.
Overload List
 | Name | Description
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed.
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.NotifyChangedImage Method (AtalaImage)

ImageSourceNotifyChangedImage Method (AtalaImage)

This method is used to inform an ImageSource that one of its current acquired images has changed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyChangedImage(
    AtalaImage originalImage
)
Public Sub NotifyChangedImage (
    originalImage As AtalaImage
)

Parameters

originalImage
Type: Atalasoft.ImagingAtalaImage
The original image acquired through one of Acquire methods.
See Also

Reference

ImageSource Class
NotifyChangedImage Overload
Atalasoft.Imaging Namespace


ImageSource.NotifyChangedImage Method (AtalaImage, AtalaImage)

ImageSourceNotifyChangedImage Method (AtalaImage, AtalaImage)

This method is used to inform an ImageSource that one of its current acquired images has changed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyChangedImage(
    AtalaImage originalImage,
    AtalaImage newImage
)
Public Sub NotifyChangedImage (
    originalImage As AtalaImage,
    newImage As AtalaImage
)

Parameters

originalImage
Type: Atalasoft.ImagingAtalaImage
The original image acquired through one of Acquire methods.
newImage
Type: Atalasoft.ImagingAtalaImage
An entirely new image that will replace the original image.
Remarks

If an ImageSource is used by several clients, it is useful to be able to have one client change an image and be able to notify any other client that a change has been made so that it can track the changes.

For example, if there are two open views on the same image, changes in one can be reflected in the other by calling NotifyChangedImage and by subscribing to the ChangedImage event.

See Also

Reference

ImageSource Class
NotifyChangedImage Overload
Atalasoft.Imaging Namespace


ImageSource.OnChangedImage Method

ImageSourceOnChangedImage Method

Raises the [E:ChangedImage] event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnChangedImage(
    ChangedImageEventArgs e
)
Protected Overridable Sub OnChangedImage (
    e As ChangedImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingChangedImageEventArgs
The ChangedImageEventArgs instance containing the event data.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.OnReleasing Method

ImageSourceOnReleasing Method

Called when Release(AtalaImage) was performed on an ImageSourceNode.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnReleasing(
    ReleasingImageSourceNodeEventArgs e
)
Protected Overridable Sub OnReleasing (
    e As ReleasingImageSourceNodeEventArgs
)

Parameters

e
Type: Atalasoft.ImagingReleasingImageSourceNodeEventArgs
A ReleasingImageSourceNodeEventArgs containing the node that was released.
Remarks
This method will raise the Releasing event.
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ReAcquire Method

ImageSourceReAcquire Method

Acquire an AtalaImage for use which has been previously acquired.
Overload List
 | Name | Description
Public method | ReAcquire(Int32) | Acquire a previous image by index.
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ReAcquire Method (Int32)

ImageSourceReAcquire Method (Int32)

Acquire a previous image by index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage ReAcquire(
    int index
)
Public Overridable Function ReAcquire (
    index As Integer
) As AtalaImage

Parameters

index
Type: SystemInt32
The index of the image to re-acquire.

Return Value

Type: AtalaImage
The acquired image or null (Nothing in VB) if the image was not previously acquired.
See Also

Reference

ImageSource Class
ReAcquire Overload
Atalasoft.Imaging Namespace


ImageSource.ReAcquire Method (AtalaImage)

ImageSourceReAcquire Method (AtalaImage)

Acquire an AtalaImage that has been previously acquired.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ReAcquire(
    AtalaImage image
)
Public Function ReAcquire (
    image As AtalaImage
) As Boolean

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to re-acquire.

Return Value

Type: Boolean
True if the image has successfully acquired.
Remarks
These versions of Acquire are used to put an additional request to hold onto an AtalaImage.
See Also

Reference

ImageSource Class
ReAcquire Overload
Atalasoft.Imaging Namespace


ImageSource.Release Method

ImageSourceRelease Method

Release a previously acquired image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Release(
    AtalaImage image
)
Public Function Release (
    image As AtalaImage
) As Boolean

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to release.

Return Value

Type: Boolean
True if the image was fully released, false otherwise.
Remarks

If asked to release an object that has not been previously acquired, Release will return true.

This method will call the OnReleasing(ReleasingImageSourceNodeEventArgs) method to notify derived classes about this action.

See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ReleaseChangedImage Method

ImageSourceReleaseChangedImage Method

Release an image that has changed, notifying other clients that the image has changed.
Overload List
 | Name | Description
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed.
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ReleaseChangedImage Method (AtalaImage)

ImageSourceReleaseChangedImage Method (AtalaImage)

Release an image that has changed, notifying other clients that the image has changed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ReleaseChangedImage(
    AtalaImage originalImage
)
Public Sub ReleaseChangedImage (
    originalImage As AtalaImage
)

Parameters

originalImage
Type: Atalasoft.ImagingAtalaImage
The original image acquired through one of Acquire methods.
See Also

Reference

ImageSource Class
ReleaseChangedImage Overload
Atalasoft.Imaging Namespace


ImageSource.ReleaseChangedImage Method (AtalaImage, AtalaImage)

ImageSourceReleaseChangedImage Method (AtalaImage, AtalaImage)

Release an image that has changed, notifying other clients that the image has changed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ReleaseChangedImage(
    AtalaImage originalImage,
    AtalaImage newImage
)
Public Sub ReleaseChangedImage (
    originalImage As AtalaImage,
    newImage As AtalaImage
)

Parameters

originalImage
Type: Atalasoft.ImagingAtalaImage
The original image acquired through one of Acquire methods.
newImage
Type: Atalasoft.ImagingAtalaImage
An entirely new image that will replace the original image.
See Also

Reference

ImageSource Class
ReleaseChangedImage Overload
Atalasoft.Imaging Namespace


ImageSource.Reset Method

ImageSourceReset Method

Resets the ImageSource to start over again.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset
Remarks

Some subclasses of ImageSource will require that all previously acquired images must be released before a Reset.

It will not always be the case that the first image acquired will be the same after a reset. This is highly dependent on the nature of the concrete implementation of ImageSource.

See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource Events

The ImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced.
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode.
Top
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.ChangedImage Event

ImageSourceChangedImage Event

This event is fired whenever an image has been replaced.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ChangedImageEventHandler ChangedImage
Public Event ChangedImage As ChangedImageEventHandler

Value

Type: Atalasoft.ImagingChangedImageEventHandler
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSource.Releasing Event

ImageSourceReleasing Event

Raised when the Release(AtalaImage) method is called on an ImageSourceNode.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ReleasingImageSourceNodeEventHandler Releasing
Public Event Releasing As ReleasingImageSourceNodeEventHandler

Value

Type: Atalasoft.ImagingReleasingImageSourceNodeEventHandler
See Also

Reference

ImageSource Class
Atalasoft.Imaging Namespace


ImageSourceNode Class

This is an object used to hold AtalaImage objects in the ImageSource. This object is only of interest if you are writing your own ImageSource implementation.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSourceNode

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageSourceNode : IDisposable
Public Class ImageSourceNode
    Implements IDisposable

The ImageSourceNode type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSourceNode | Constructs a new ImageSourceNode using the supplied image and reloader.
Top
Properties
 | Name | Description
Public property | Image | The image in this node.
Public property | ImageSize | The number of bytes used by this image when in memory.
Public property | Index | The index of this image in the ImageSource.
Public property | ReferenceCount | Gets the reference count for this node.
Public property | Released | Determines if this image is fully released.
Public property | Reloader | Gets the reloader, if any, associated with this node.
Top
Methods
 | Name | Description
Public method | Acquire | Acquire a lock on this node.
Public method | Dispose | Release resources used by this node.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSourceNode class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LetGo | Unload the image from memory.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | Release a lock on this image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageSourceNode Constructor

Constructs a new ImageSourceNode using the supplied image and reloader.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceNode(
    AtalaImage image,
    IImageReloader reloader
)
Public Sub New (
    image As AtalaImage,
    reloader As IImageReloader
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to hold onto.
reloader
Type: Atalasoft.ImagingIImageReloader
An IImageReloader to load the object back into memory. This can be null.
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode Properties

The ImageSourceNode type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image in this node.
Public property | ImageSize | The number of bytes used by this image when in memory.
Public property | Index | The index of this image in the ImageSource.
Public property | ReferenceCount | Gets the reference count for this node.
Public property | Released | Determines if this image is fully released.
Public property | Reloader | Gets the reloader, if any, associated with this node.
Top
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Image Property

ImageSourceNodeImage Property

The image in this node.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
If Image is null, the image has been unloaded.
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.ImageSize Property

ImageSourceNodeImageSize Property

The number of bytes used by this image when in memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ImageSize { get; set; }
Public Property ImageSize As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Index Property

ImageSourceNodeIndex Property

The index of this image in the ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.ReferenceCount Property

ImageSourceNodeReferenceCount Property

Gets the reference count for this node.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ReferenceCount { get; }
Public ReadOnly Property ReferenceCount As Integer
    Get

Property Value

Type: Int32
The reference count.
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Released Property

ImageSourceNodeReleased Property

Determines if this image is fully released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Released { get; }
Public ReadOnly Property Released As Boolean
    Get

Property Value

Type: Boolean
True if released, false otherwise.
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Reloader Property

ImageSourceNodeReloader Property

Gets the reloader, if any, associated with this node.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IImageReloader Reloader { get; }
Public ReadOnly Property Reloader As IImageReloader
    Get

Property Value

Type: IImageReloader
An object of type IImageReloader which can be used to reload a previously unloaded image.
Remarks
This property may return null. It is entirely valid for there to be no image reloader for any given image.
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode Methods

The ImageSourceNode type exposes the following members.

Methods
 | Name | Description
Public method | Acquire | Acquire a lock on this node.
Public method | Dispose | Release resources used by this node.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSourceNode class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LetGo | Unload the image from memory.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | Release a lock on this image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Acquire Method

ImageSourceNodeAcquire Method

Acquire a lock on this node.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Acquire()
Public Sub Acquire
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Dispose Method

ImageSourceNodeDispose Method

Release resources used by this node.
Overload List
 | Name | Description
Public method | Dispose | Release resources used by this node.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Dispose Method

ImageSourceNodeDispose Method

Release resources used by this node.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ImageSourceNode Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageSourceNode.Dispose Method (Boolean)

ImageSourceNodeDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImageSourceNode Class
Dispose Overload
Atalasoft.Imaging Namespace


ImageSourceNode.Finalize Method

ImageSourceNodeFinalize Method

Finalizes an instance of the ImageSourceNode class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.LetGo Method

ImageSourceNodeLetGo Method

Unload the image from memory.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LetGo()
Public Sub LetGo
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageSourceNode.Release Method

ImageSourceNodeRelease Method

Release a lock on this image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Release()
Public Sub Release
See Also

Reference

ImageSourceNode Class
Atalasoft.Imaging Namespace


ImageStreamEventArgs Class

Provides data for the ImageStreamCompleted event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingImageStreamEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageStreamEventArgs : EventArgs
Public Class ImageStreamEventArgs
    Inherits EventArgs

The ImageStreamEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageStreamEventArgs | Creates a new ImageStreamEventArgs object.
Public method | ImageStreamEventArgs(Stream, Int64) | Creates a new instance of ImageStreamEventArgs specifying the stream and number of bytes.
Top
Properties
 | Name | Description
Public property | Bytes | Gets the number of bytes written to or read from the image stream.
Public property | Stream | Gets the Steam object of interest.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ImageStreamEventArgs Constructor

Creates an ImageStreamEventArgs object.
Overload List
 | Name | Description
Public method | ImageStreamEventArgs | Creates a new ImageStreamEventArgs object.
Public method | ImageStreamEventArgs(Stream, Int64) | Creates a new instance of ImageStreamEventArgs specifying the stream and number of bytes.
Top
See Also

Reference

ImageStreamEventArgs Class
Atalasoft.Imaging Namespace


ImageStreamEventArgs Constructor

Creates a new ImageStreamEventArgs object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageStreamEventArgs()
Public Sub New
See Also

Reference

ImageStreamEventArgs Class
ImageStreamEventArgs Overload
Atalasoft.Imaging Namespace


ImageStreamEventArgs Constructor (Stream, Int64)

Creates a new instance of ImageStreamEventArgs specifying the stream and number of bytes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageStreamEventArgs(
    Stream stream,
    long bytes
)
Public Sub New (
    stream As Stream,
    bytes As Long
)

Parameters

stream
Type: System.IOStream
The stream for this event.
bytes
Type: SystemInt64
The number of bytes for this event.
See Also

Reference

ImageStreamEventArgs Class
ImageStreamEventArgs Overload
Atalasoft.Imaging Namespace


ImageStreamEventArgs Properties

The ImageStreamEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Gets the number of bytes written to or read from the image stream.
Public property | Stream | Gets the Steam object of interest.
Top
See Also

Reference

ImageStreamEventArgs Class
Atalasoft.Imaging Namespace


ImageStreamEventArgs.Bytes Property

ImageStreamEventArgsBytes Property

Gets the number of bytes written to or read from the image stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long Bytes { get; }
Public ReadOnly Property Bytes As Long
    Get

Property Value

Type: Int64
The number of bytes written to or read from the image stream.
See Also

Reference

ImageStreamEventArgs Class
Atalasoft.Imaging Namespace


ImageStreamEventArgs.Stream Property

ImageStreamEventArgsStream Property

Gets the Steam object of interest.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
The Steam object of interest.
See Also

Reference

ImageStreamEventArgs Class
Atalasoft.Imaging Namespace


ImageStreamEventArgs Methods

The ImageStreamEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageStreamEventArgs Class
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Class

This exception is thrown when the image to be processed does not contain a %PixelFormat% compatible with the function of interest.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingIncompatiblePixelFormatException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IncompatiblePixelFormatException : Exception
<SerializableAttribute>
Public Class IncompatiblePixelFormatException
    Inherits Exception

The IncompatiblePixelFormatException type exposes the following members.

Constructors
 | Name | Description
Public method | IncompatiblePixelFormatException | Creates a new instance of IncompatiblePixelFormatException.
Public method | IncompatiblePixelFormatException(String) | Creates a new instance of IncompatiblePixelFormatException specifying the exception message.
Protected method | IncompatiblePixelFormatException(SerializationInfo, StreamingContext) | Initializes a new instance of the IncompatiblePixelFormatException class.
Public method | IncompatiblePixelFormatException(String, Exception) | Creates a new instance of IncompatiblePixelFormatException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Constructor

Creates an IncompatiblePixelFormatException object.
Overload List
 | Name | Description
Public method | IncompatiblePixelFormatException | Creates a new instance of IncompatiblePixelFormatException.
Public method | IncompatiblePixelFormatException(String) | Creates a new instance of IncompatiblePixelFormatException specifying the exception message.
Protected method | IncompatiblePixelFormatException(SerializationInfo, StreamingContext) | Initializes a new instance of the IncompatiblePixelFormatException class.
Public method | IncompatiblePixelFormatException(String, Exception) | Creates a new instance of IncompatiblePixelFormatException specifying the exception message and inner exception.
Top
See Also

Reference

IncompatiblePixelFormatException Class
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Constructor

Creates a new instance of IncompatiblePixelFormatException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IncompatiblePixelFormatException()
Public Sub New
See Also

Reference

IncompatiblePixelFormatException Class
IncompatiblePixelFormatException Overload
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Constructor (String)

Creates a new instance of IncompatiblePixelFormatException specifying the exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IncompatiblePixelFormatException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

IncompatiblePixelFormatException Class
IncompatiblePixelFormatException Overload
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the IncompatiblePixelFormatException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IncompatiblePixelFormatException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

IncompatiblePixelFormatException Class
IncompatiblePixelFormatException Overload
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Constructor (String, Exception)

Creates a new instance of IncompatiblePixelFormatException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IncompatiblePixelFormatException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
See Also

Reference

IncompatiblePixelFormatException Class
IncompatiblePixelFormatException Overload
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Properties

The IncompatiblePixelFormatException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

IncompatiblePixelFormatException Class
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Methods

The IncompatiblePixelFormatException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

IncompatiblePixelFormatException Class
Atalasoft.Imaging Namespace


IncompatiblePixelFormatException Events

The IncompatiblePixelFormatException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

IncompatiblePixelFormatException Class
Atalasoft.Imaging Namespace


IndirectionImageSource Class

The IndirectionImageSource class is used to provide an ImageSource which can be modified after its initial creation. The ThumbnailImageViewerSynchronizer uses this class to handle changes to the original ImageSource.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.ImagingIndirectionImageSource

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IndirectionImageSource : RandomAccessImageSource
Public Class IndirectionImageSource
    Inherits RandomAccessImageSource

The IndirectionImageSource type exposes the following members.

Constructors
 | Name | Description
Public method | IndirectionImageSource | Creates a new instance of IndirectionImageSource specifying the initial RandomAccessImageSource to use.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | RetainInMemory | Gets or sets a value indicating whether the images should remain in memory once read.
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Public method | Add(AtalaImage) | Adds an AtalaImage to the end of the image source.
Public method | Add(Stream, Int32) | Adds an image to the end of the image source from a stream.
Public method | Add(String, Int32) | Adds an image to the end of the image source from a filename.
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | Clear | Removes all items from the image source.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Overrides ImageSourceDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from RandomAccessImageSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Public method | Insert(Int32, AtalaImage) | Inserts the image at the specified index.
Public method | Insert(Int32, Stream, Int32) | Adds or inserts one or more images from a stream.
Public method | Insert(Int32, String, Int32) | Adds or inserts one or more images from a file.
Protected method | LowLevelAcquire | Performs an acquire of an indexed image. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Lows level implementation of reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | Called when the index of a node is modified. (Overrides RandomAccessImageSourceOnNodeIndexSet(ImageSourceNode).)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Overrides ImageSourceOnReleasing(ReleasingImageSourceNodeEventArgs).)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Overrides ImageSourceReAcquire(Int32).)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | RemoveAt | Removes an image from the IndirectionImageSource at the specified index.
Public method | ReorderIndex | Moves one item to a different position within the IndirectionImageSource.
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


IndirectionImageSource Constructor

Creates a new instance of IndirectionImageSource specifying the initial RandomAccessImageSource to use.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndirectionImageSource(
    RandomAccessImageSource imageSource
)
Public Sub New (
    imageSource As RandomAccessImageSource
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The initial RandomAccessImageSource to use.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource Properties

The IndirectionImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | RetainInMemory | Gets or sets a value indicating whether the images should remain in memory once read.
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.RetainInMemory Property

IndirectionImageSourceRetainInMemory Property

Gets or sets a value indicating whether the images should remain in memory once read.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RetainInMemory { get; set; }
Public Property RetainInMemory As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the images should remain in memory.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource Methods

The IndirectionImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Public method | Add(AtalaImage) | Adds an AtalaImage to the end of the image source.
Public method | Add(Stream, Int32) | Adds an image to the end of the image source from a stream.
Public method | Add(String, Int32) | Adds an image to the end of the image source from a filename.
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | Clear | Removes all items from the image source.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Overrides ImageSourceDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from RandomAccessImageSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Public method | Insert(Int32, AtalaImage) | Inserts the image at the specified index.
Public method | Insert(Int32, Stream, Int32) | Adds or inserts one or more images from a stream.
Public method | Insert(Int32, String, Int32) | Adds or inserts one or more images from a file.
Protected method | LowLevelAcquire | Performs an acquire of an indexed image. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Lows level implementation of reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | Called when the index of a node is modified. (Overrides RandomAccessImageSourceOnNodeIndexSet(ImageSourceNode).)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Overrides ImageSourceOnReleasing(ReleasingImageSourceNodeEventArgs).)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Overrides ImageSourceReAcquire(Int32).)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | RemoveAt | Removes an image from the IndirectionImageSource at the specified index.
Public method | ReorderIndex | Moves one item to a different position within the IndirectionImageSource.
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.Add Method

IndirectionImageSourceAdd Method

Adds an image to the image source.
Overload List
 | Name | Description
Public method | Add(AtalaImage) | Adds an AtalaImage to the end of the image source.
Public method | Add(Stream, Int32) | Adds an image to the end of the image source from a stream.
Public method | Add(String, Int32) | Adds an image to the end of the image source from a filename.
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.Add Method (AtalaImage)

IndirectionImageSourceAdd Method (AtalaImage)

Adds an AtalaImage to the end of the image source.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AtalaImage image
)
Public Sub Add (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to add.
Exceptions
Exception | Condition
 | Thrown if the image is null (Nothing in VB).
See Also

Reference

IndirectionImageSource Class
Add Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.Add Method (Stream, Int32)

IndirectionImageSourceAdd Method (Stream, Int32)

Adds an image to the end of the image source from a stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    Stream stream,
    int frameIndex
)
Public Sub Add (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
The stream containing the image.
frameIndex
Type: SystemInt32
The frame index to add. If this value is -1, all pages will be added to the image source.
Exceptions
Exception | Condition
 | Thrown if the stream is null (Nothing in VB).
See Also

Reference

IndirectionImageSource Class
Add Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.Add Method (String, Int32)

IndirectionImageSourceAdd Method (String, Int32)

Adds an image to the end of the image source from a filename.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fileName,
    int frameIndex
)
Public Sub Add (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The filename of the image to add.
frameIndex
Type: SystemInt32
The frame index to add. If this value is -1, all pages will be added to the image source.
Exceptions
Exception | Condition
 | Thrown if the filename is null (Nothing in VB) or empty.
 | Thrown if the file is not found.
See Also

Reference

IndirectionImageSource Class
Add Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.Clear Method

IndirectionImageSourceClear Method

Removes all items from the image source.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
Remarks
This does not modify the original ImageSource provided in the IndirectionImageSource constructor.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.Dispose Method

IndirectionImageSourceDispose Method

Free up resources used by this ImageSource
Overload List
 | Name | Description
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Overrides ImageSourceDispose(Boolean).)
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.Dispose Method (Boolean)

IndirectionImageSourceDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

IndirectionImageSource Class
Dispose Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.Insert Method

IndirectionImageSourceInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, AtalaImage) | Inserts the image at the specified index.
Public method | Insert(Int32, Stream, Int32) | Adds or inserts one or more images from a stream.
Public method | Insert(Int32, String, Int32) | Adds or inserts one or more images from a file.
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.Insert Method (Int32, AtalaImage)

IndirectionImageSourceInsert Method (Int32, AtalaImage)

Inserts the image at the specified index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AtalaImage image
)
Public Sub Insert (
    index As Integer,
    image As AtalaImage
)

Parameters

index
Type: SystemInt32
The index.
image
Type: Atalasoft.ImagingAtalaImage
The image.
Exceptions
Exception | Condition
ArgumentNullException | image
See Also

Reference

IndirectionImageSource Class
Insert Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.Insert Method (Int32, Stream, Int32)

IndirectionImageSourceInsert Method (Int32, Stream, Int32)

Adds or inserts one or more images from a stream.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Stream stream,
    int frameIndex
)
Public Sub Insert (
    index As Integer,
    stream As Stream,
    frameIndex As Integer
)

Parameters

index
Type: SystemInt32
The index where the image should be inserted or -1 to add the image to the end of the collection.
stream
Type: System.IOStream

A stream containing the image(s). This stream must be seekable.

frameIndex
Type: SystemInt32
The frame index to insert or -1 to insert all pages of a multipage document.
Exceptions
Exception | Condition
 | Thrown if the stream argument is null (Nothing in VB).
See Also

Reference

IndirectionImageSource Class
Insert Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.Insert Method (Int32, String, Int32)

IndirectionImageSourceInsert Method (Int32, String, Int32)

Adds or inserts one or more images from a file.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    string fileName,
    int frameIndex
)
Public Sub Insert (
    index As Integer,
    fileName As String,
    frameIndex As Integer
)

Parameters

index
Type: SystemInt32
The index where the image should be inserted or -1 to add the image to the end of the collection.
fileName
Type: SystemString
The full path and filename of the image to insert.
frameIndex
Type: SystemInt32
The frame index to insert or -1 to insert all pages of a multipage document.
Exceptions
Exception | Condition
 | Thrown if the fileName argument is null.
 | Thrown if the fileName is invalid.
See Also

Reference

IndirectionImageSource Class
Insert Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelAcquire Method

IndirectionImageSourceLowLevelAcquire Method

Performs an acquire of an indexed image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquire(
    int index
)
Protected Overrides Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32
The index of the image to acquire.

Return Value

Type: ImageSourceNode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index;Invalid index for this image source.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelAcquireNextImage Method

IndirectionImageSourceLowLevelAcquireNextImage Method

Lows level implementation to acquire next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquireNextImage()
Protected Overrides Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelDispose Method

IndirectionImageSourceLowLevelDispose Method

Lows level implementation to dispose the ImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelDispose()
Protected Overrides Sub LowLevelDispose
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelFlushOnReset Method

IndirectionImageSourceLowLevelFlushOnReset Method

Lows level implementation to determine if there should be a flush on reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelFlushOnReset()
Protected Overrides Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
true if the ImageSource needs a flush on reset, false otherwise.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelHasMoreImages Method

IndirectionImageSourceLowLevelHasMoreImages Method

Lows level implementation to determine if the ImageSource has more images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelHasMoreImages()
Protected Overrides Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
true if there are more image, false otherwise.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelReplaceImage Method

IndirectionImageSourceLowLevelReplaceImage Method

Lows level implementation to replace an image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReplaceImage(
    ImageSourceNode node,
    AtalaImage newImage
)
Protected Overrides Sub LowLevelReplaceImage (
    node As ImageSourceNode,
    newImage As AtalaImage
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node.
newImage
Type: Atalasoft.ImagingAtalaImage
The new image.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelReset Method

IndirectionImageSourceLowLevelReset Method

Lows level implementation of reset.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReset()
Protected Overrides Sub LowLevelReset
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelSkipNextImage Method

IndirectionImageSourceLowLevelSkipNextImage Method

Lows level implementation to skip next image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelSkipNextImage()
Protected Overrides Sub LowLevelSkipNextImage
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.LowLevelTotalImages Method

IndirectionImageSourceLowLevelTotalImages Method

Lows level implementation that returns the total number of images.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LowLevelTotalImages()
Protected Overrides Function LowLevelTotalImages As Integer

Return Value

Type: Int32
the total number of images
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.OnNodeIndexSet Method

IndirectionImageSourceOnNodeIndexSet Method

Called when the index of a node is modified.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnNodeIndexSet(
    ImageSourceNode node
)
Protected Overrides Sub OnNodeIndexSet (
    node As ImageSourceNode
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node being modified.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.OnReleasing Method

IndirectionImageSourceOnReleasing Method

Called when Release(AtalaImage) was performed on an ImageSourceNode.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnReleasing(
    ReleasingImageSourceNodeEventArgs e
)
Protected Overrides Sub OnReleasing (
    e As ReleasingImageSourceNodeEventArgs
)

Parameters

e
Type: Atalasoft.ImagingReleasingImageSourceNodeEventArgs
A ReleasingImageSourceNodeEventArgs containing the node that was released.
Remarks
This method will raise the Releasing event.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.ReAcquire Method

IndirectionImageSourceReAcquire Method

Acquire an AtalaImage for use which has been previously acquired.
Overload List
 | Name | Description
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Overrides ImageSourceReAcquire(Int32).)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.ReAcquire Method (Int32)

IndirectionImageSourceReAcquire Method (Int32)

Acquire a previous image by index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage ReAcquire(
    int index
)
Public Overrides Function ReAcquire (
    index As Integer
) As AtalaImage

Parameters

index
Type: SystemInt32
The index of the image to re-acquire.

Return Value

Type: AtalaImage
The acquired image or null (Nothing in VB) if the image was not previously acquired.
See Also

Reference

IndirectionImageSource Class
ReAcquire Overload
Atalasoft.Imaging Namespace


IndirectionImageSource.RemoveAt Method

IndirectionImageSourceRemoveAt Method

Removes an image from the IndirectionImageSource at the specified index.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
Exceptions
Exception | Condition
 | Thrown if the index argument is invalid for this IndirectionImageSource.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource.ReorderIndex Method

IndirectionImageSourceReorderIndex Method

Moves one item to a different position within the IndirectionImageSource.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ReorderIndex(
    int currentIndex,
    int newIndex
)
Public Sub ReorderIndex (
    currentIndex As Integer,
    newIndex As Integer
)

Parameters

currentIndex
Type: SystemInt32
The index of the item to move.
newIndex
Type: SystemInt32
The new index for the item.
Exceptions
Exception | Condition
 | Thrown if the currentIndex or newIndex values are invalid for this IndirectionImageSource.
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


IndirectionImageSource Events

The IndirectionImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

IndirectionImageSource Class
Atalasoft.Imaging Namespace


InternalErrorException Class

This exception is for generic errors within the DotImage codebase.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingInternalErrorException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InternalErrorException : Exception
<SerializableAttribute>
Public Class InternalErrorException
    Inherits Exception

The InternalErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | InternalErrorException | Creates a new instance of InternalErrorException.
Public method | InternalErrorException(String) | Creates a new instance of InternalErrorException specifying the error message.
Protected method | InternalErrorException(SerializationInfo, StreamingContext) | Initializes a new instance of the InternalErrorException class.
Public method | InternalErrorException(String, Exception) | Creates a new instance of InternalErrorException specifying the error message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


InternalErrorException Constructor

Creates a new instance of InternalErrorException.
Overload List
 | Name | Description
Public method | InternalErrorException | Creates a new instance of InternalErrorException.
Public method | InternalErrorException(String) | Creates a new instance of InternalErrorException specifying the error message.
Protected method | InternalErrorException(SerializationInfo, StreamingContext) | Initializes a new instance of the InternalErrorException class.
Public method | InternalErrorException(String, Exception) | Creates a new instance of InternalErrorException specifying the error message and inner exception.
Top
See Also

Reference

InternalErrorException Class
Atalasoft.Imaging Namespace


InternalErrorException Constructor

Creates a new instance of InternalErrorException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternalErrorException()
Public Sub New
See Also

Reference

InternalErrorException Class
InternalErrorException Overload
Atalasoft.Imaging Namespace


InternalErrorException Constructor (String)

Creates a new instance of InternalErrorException specifying the error message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternalErrorException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

InternalErrorException Class
InternalErrorException Overload
Atalasoft.Imaging Namespace


InternalErrorException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InternalErrorException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected InternalErrorException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InternalErrorException Class
InternalErrorException Overload
Atalasoft.Imaging Namespace


InternalErrorException Constructor (String, Exception)

Creates a new instance of InternalErrorException specifying the error message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternalErrorException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

InternalErrorException Class
InternalErrorException Overload
Atalasoft.Imaging Namespace


InternalErrorException Properties

The InternalErrorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternalErrorException Class
Atalasoft.Imaging Namespace


InternalErrorException Methods

The InternalErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternalErrorException Class
Atalasoft.Imaging Namespace


InternalErrorException Events

The InternalErrorException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InternalErrorException Class
Atalasoft.Imaging Namespace


InternetConnectException Class

This exception is thrown when there is an error opening an internet connection.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingInternetConnectException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InternetConnectException : Exception
<SerializableAttribute>
Public Class InternetConnectException
    Inherits Exception

The InternetConnectException type exposes the following members.

Constructors
 | Name | Description
Public method | InternetConnectException | Creates a new instance of InternetConnectException.
Public method | InternetConnectException(String) | Creates a new instance of InternetConnectException specifying the exception message.
Protected method | InternetConnectException(SerializationInfo, StreamingContext) | Initializes a new instance of the InternetConnectException class.
Public method | InternetConnectException(String, Exception) | Creates a new instance of InternetConnectException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


InternetConnectException Constructor

Creates an InternetConnectException object.
Overload List
 | Name | Description
Public method | InternetConnectException | Creates a new instance of InternetConnectException.
Public method | InternetConnectException(String) | Creates a new instance of InternetConnectException specifying the exception message.
Protected method | InternetConnectException(SerializationInfo, StreamingContext) | Initializes a new instance of the InternetConnectException class.
Public method | InternetConnectException(String, Exception) | Creates a new instance of InternetConnectException specifying the exception message and inner exception.
Top
See Also

Reference

InternetConnectException Class
Atalasoft.Imaging Namespace


InternetConnectException Constructor

Creates a new instance of InternetConnectException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternetConnectException()
Public Sub New
See Also

Reference

InternetConnectException Class
InternetConnectException Overload
Atalasoft.Imaging Namespace


InternetConnectException Constructor (String)

Creates a new instance of InternetConnectException specifying the exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternetConnectException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

InternetConnectException Class
InternetConnectException Overload
Atalasoft.Imaging Namespace


InternetConnectException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InternetConnectException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected InternetConnectException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InternetConnectException Class
InternetConnectException Overload
Atalasoft.Imaging Namespace


InternetConnectException Constructor (String, Exception)

Creates a new instance of InternetConnectException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternetConnectException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

InternetConnectException Class
InternetConnectException Overload
Atalasoft.Imaging Namespace


InternetConnectException Properties

The InternetConnectException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternetConnectException Class
Atalasoft.Imaging Namespace


InternetConnectException Methods

The InternetConnectException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternetConnectException Class
Atalasoft.Imaging Namespace


InternetConnectException Events

The InternetConnectException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InternetConnectException Class
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Class

This exception is thrown when an invalid password was detected while attempting to connect to an HTTP or FTP site to download an image.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingInternetInvalidPasswordException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InternetInvalidPasswordException : Exception
<SerializableAttribute>
Public Class InternetInvalidPasswordException
    Inherits Exception

The InternetInvalidPasswordException type exposes the following members.

Constructors
 | Name | Description
Public method | InternetInvalidPasswordException | Creates a new instance of InternetInvalidPasswordException.
Public method | InternetInvalidPasswordException(String) | Creates a new instance of InternetInvalidPasswordException specifying the exception message.
Protected method | InternetInvalidPasswordException(SerializationInfo, StreamingContext) | Initializes a new instance of the InternetInvalidPasswordException class.
Public method | InternetInvalidPasswordException(String, Exception) | Creates a new instance of InternetInvalidPasswordException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


InternetInvalidPasswordException Constructor

Creates an InternetInvalidPasswordException object.
Overload List
 | Name | Description
Public method | InternetInvalidPasswordException | Creates a new instance of InternetInvalidPasswordException.
Public method | InternetInvalidPasswordException(String) | Creates a new instance of InternetInvalidPasswordException specifying the exception message.
Protected method | InternetInvalidPasswordException(SerializationInfo, StreamingContext) | Initializes a new instance of the InternetInvalidPasswordException class.
Public method | InternetInvalidPasswordException(String, Exception) | Creates a new instance of InternetInvalidPasswordException specifying the exception message and inner exception.
Top
See Also

Reference

InternetInvalidPasswordException Class
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Constructor

Creates a new instance of InternetInvalidPasswordException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternetInvalidPasswordException()
Public Sub New
See Also

Reference

InternetInvalidPasswordException Class
InternetInvalidPasswordException Overload
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Constructor (String)

Creates a new instance of InternetInvalidPasswordException specifying the exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternetInvalidPasswordException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

InternetInvalidPasswordException Class
InternetInvalidPasswordException Overload
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InternetInvalidPasswordException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected InternetInvalidPasswordException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InternetInvalidPasswordException Class
InternetInvalidPasswordException Overload
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Constructor (String, Exception)

Creates a new instance of InternetInvalidPasswordException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InternetInvalidPasswordException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for the error.
See Also

Reference

InternetInvalidPasswordException Class
InternetInvalidPasswordException Overload
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Properties

The InternetInvalidPasswordException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternetInvalidPasswordException Class
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Methods

The InternetInvalidPasswordException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternetInvalidPasswordException Class
Atalasoft.Imaging Namespace


InternetInvalidPasswordException Events

The InternetInvalidPasswordException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InternetInvalidPasswordException Class
Atalasoft.Imaging Namespace


LicenseEdition Enumeration

This enumeration indicates the type of license found by DotImage.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum LicenseEdition
Public Enumeration LicenseEdition
Members
Member name | Description
Photo | DotImage Photo
PhotoPro | DotImage Photo Pro
Document | DotImage Document Imaging
Standard | DotImage Photo (deprecated)
Professional | DotImage Photo Professional (deprecated)
Remarks
Use the static Edition property to get the license edition.
See Also

Reference

Atalasoft.Imaging Namespace


MarshalByRefCollectionBase Class

A base abstract (MustInherit in Visual Basic) collection class intended for strongly typed collections containing unmanaged data.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingMarshalByRefCollectionBase

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class MarshalByRefCollectionBase : MarshalByRefObject,
    ICollection, IEnumerable
Public MustInherit Class MarshalByRefCollectionBase
    Inherits MarshalByRefObject
    Implements ICollection, IEnumerable

The MarshalByRefCollectionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MarshalByRefCollectionBase | Initializes a new instance of the MarshalByRefCollectionBase class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection.
Protected property | InnerList | Gets the ArrayList stored within the collection.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
Methods
 | Name | Description
Public method | Clear | Clears the collection.
Public method | CopyTo | Copies the collection items into an array.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


MarshalByRefCollectionBase Constructor

Initializes a new instance of the MarshalByRefCollectionBase class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MarshalByRefCollectionBase()
Protected Sub New
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase Properties

The MarshalByRefCollectionBase type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the collection.
Protected property | InnerList | Gets the ArrayList stored within the collection.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.Count Property

MarshalByRefCollectionBaseCount Property

Gets the number of items in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of items in the collection.

Implements

ICollectionCount
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.InnerList Property

MarshalByRefCollectionBaseInnerList Property

Gets the ArrayList stored within the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ArrayList InnerList { get; }
Protected ReadOnly Property InnerList As ArrayList
    Get

Property Value

Type: ArrayList
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.IsSynchronized Property

MarshalByRefCollectionBaseIsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether access to the collection is synchronized.

Implements

ICollectionIsSynchronized
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.SyncRoot Property

MarshalByRefCollectionBaseSyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

An object that can be used to synchronize access to the collection.

Implements

ICollectionSyncRoot
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase Methods

The MarshalByRefCollectionBase type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the collection.
Public method | CopyTo | Copies the collection items into an array.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.Clear Method

MarshalByRefCollectionBaseClear Method

Clears the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.CopyTo Method

MarshalByRefCollectionBaseCopyTo Method

Copies the collection items into an array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)

Parameters

array
Type: SystemArray
The array that will hold the collection items.
index
Type: SystemInt32
The index in the array where the copies will start.

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefCollectionBase.GetEnumerator Method

MarshalByRefCollectionBaseGetEnumerator Method

Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
A reference to an IEnumerator interface.

Implements

IEnumerableGetEnumerator
Remarks
When GetEnumerator is called, it constructs an enumerator object containing the current version number in the collection and a reference to the collection's items. Every time the enumerator is accessed, it compares the version of the enumerator with the version of the collection. If the versions do not match, it means that the collection has changed; an exception then occurs.
See Also

Reference

MarshalByRefCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase Class

A base abstract (MustInherit in Visual Basic) collection class intended for strongly typed read-only collections containing unmanaged data.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingMarshalByRefReadOnlyCollectionBase
Atalasoft.ImagingUndoCollection

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class MarshalByRefReadOnlyCollectionBase : MarshalByRefObject,
    ICollection, IEnumerable
Public MustInherit Class MarshalByRefReadOnlyCollectionBase
    Inherits MarshalByRefObject
    Implements ICollection, IEnumerable

The MarshalByRefReadOnlyCollectionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MarshalByRefReadOnlyCollectionBase | Initializes a new instance of the MarshalByRefReadOnlyCollectionBase class
Top
Properties
 | Name | Description
Public property | Count | The number of items in the collection.
Protected property | InnerList | Gets the ArrayList stored within the collection.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
Methods
 | Name | Description
Public method | CopyTo | Copies the collection items into an array.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase Constructor

Initializes a new instance of the MarshalByRefReadOnlyCollectionBase class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MarshalByRefReadOnlyCollectionBase()
Protected Sub New
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase Properties

The MarshalByRefReadOnlyCollectionBase type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of items in the collection.
Protected property | InnerList | Gets the ArrayList stored within the collection.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase.Count Property

MarshalByRefReadOnlyCollectionBaseCount Property

The number of items in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of items in the collection.

Implements

ICollectionCount
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase.InnerList Property

MarshalByRefReadOnlyCollectionBaseInnerList Property

Gets the ArrayList stored within the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ArrayList InnerList { get; }
Protected ReadOnly Property InnerList As ArrayList
    Get

Property Value

Type: ArrayList
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase.IsSynchronized Property

MarshalByRefReadOnlyCollectionBaseIsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether access to the collection is synchronized.

Implements

ICollectionIsSynchronized
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase.SyncRoot Property

MarshalByRefReadOnlyCollectionBaseSyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

An object that can be used to synchronize access to the collection.

Implements

ICollectionSyncRoot
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase Methods

The MarshalByRefReadOnlyCollectionBase type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies the collection items into an array.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase.CopyTo Method

MarshalByRefReadOnlyCollectionBaseCopyTo Method

Copies the collection items into an array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)

Parameters

array
Type: SystemArray
The array that will hold the collection items.
index
Type: SystemInt32
The index in the array where the copies will start.

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


MarshalByRefReadOnlyCollectionBase.GetEnumerator Method

MarshalByRefReadOnlyCollectionBaseGetEnumerator Method

Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
A reference to an IEnumerator interface.

Implements

IEnumerableGetEnumerator
See Also

Reference

MarshalByRefReadOnlyCollectionBase Class
Atalasoft.Imaging Namespace


OperationCancelledException Class

This class is used to cancel running operations.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingOperationCancelledException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OperationCancelledException : Exception
<SerializableAttribute>
Public Class OperationCancelledException
    Inherits Exception

The OperationCancelledException type exposes the following members.

Constructors
 | Name | Description
Public method | OperationCancelledException | Creates a new instance of OperationCancelledException.
Public method | OperationCancelledException(String) | Creates a new instance of OperationCancelledException specifying the exception message.
Protected method | OperationCancelledException(SerializationInfo, StreamingContext) | Initializes a new instance of the OperationCancelledException class.
Public method | OperationCancelledException(String, Exception) | Creates a new instance of OperationCancelledException specifying an exception message and the inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


OperationCancelledException Constructor

Creates an OperationCancelledException object.
Overload List
 | Name | Description
Public method | OperationCancelledException | Creates a new instance of OperationCancelledException.
Public method | OperationCancelledException(String) | Creates a new instance of OperationCancelledException specifying the exception message.
Protected method | OperationCancelledException(SerializationInfo, StreamingContext) | Initializes a new instance of the OperationCancelledException class.
Public method | OperationCancelledException(String, Exception) | Creates a new instance of OperationCancelledException specifying an exception message and the inner exception.
Top
See Also

Reference

OperationCancelledException Class
Atalasoft.Imaging Namespace


OperationCancelledException Constructor

Creates a new instance of OperationCancelledException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OperationCancelledException()
Public Sub New
See Also

Reference

OperationCancelledException Class
OperationCancelledException Overload
Atalasoft.Imaging Namespace


OperationCancelledException Constructor (String)

Creates a new instance of OperationCancelledException specifying the exception message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OperationCancelledException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
A text description of the exception.
See Also

Reference

OperationCancelledException Class
OperationCancelledException Overload
Atalasoft.Imaging Namespace


OperationCancelledException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the OperationCancelledException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OperationCancelledException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

OperationCancelledException Class
OperationCancelledException Overload
Atalasoft.Imaging Namespace


OperationCancelledException Constructor (String, Exception)

Creates a new instance of OperationCancelledException specifying an exception message and the inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OperationCancelledException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
A text description of the exception.
innerException
Type: SystemException
The inner exception.
See Also

Reference

OperationCancelledException Class
OperationCancelledException Overload
Atalasoft.Imaging Namespace


OperationCancelledException Properties

The OperationCancelledException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OperationCancelledException Class
Atalasoft.Imaging Namespace


OperationCancelledException Methods

The OperationCancelledException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OperationCancelledException Class
Atalasoft.Imaging Namespace


OperationCancelledException Events

The OperationCancelledException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OperationCancelledException Class
Atalasoft.Imaging Namespace


Palette Class

The palette contains color information that is applied to colormapped images. Use this object to modify and read the palette colors.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingPalette

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Palette : MarshalByRefObject, IDisposable,
    ICloneable, ISerializable
<SerializableAttribute>
Public Class Palette
    Inherits MarshalByRefObject
    Implements IDisposable, ICloneable, ISerializable

The Palette type exposes the following members.

Constructors
 | Name | Description
Public method | Palette | Initializes a new instance of the Palette class.
Public method | Palette(Color) | Creates a new instance of Palette specifying the colors of the palette.
Public method | Palette(ColorPalette) | Initializes a new instance of the Palette class.
Public method | Palette(Int32) | Initialize a new instance of a Palette specifying the number of colors to start with.
Public method | Palette(PaletteType) | Initialize a new instance of a Palette class specifying the PaletteType.
Protected method | Palette(SerializationInfo, StreamingContext) | Initializes a new instance of the Palette class.
Top
Properties
 | Name | Description
Public property | Colors | Returns the number of colors in the palette.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep copy of this Palette.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the Palette class. (Overrides ObjectFinalize.)
Public method | GetClosestPaletteIndex(Color) | Returns the palette index that best matches a specified color.
Public method | GetClosestPaletteIndex(Color, Boolean) | Returns the palette index that best matches a specified color, returning a value if there was an exact match.
Public method | GetEntry | Returns the color of a particular index entry in the palette. See SetEntry(Int32, Color) to change the color of a palette entry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetObjectData | Provide information for object serialization.
 | GetSystemPalette | Returns the system palette of the current display if it's an 8-bit device, null (Nothing in Visual Basic) if the device is greater then 8 bits.
 | GetSystemPalette(IntPtr) | Returns the system palette of the specified device if it's 8-bit, null (Nothing in Visual Basic) if the device is greater then 8 bits.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAlpha | Determines whether this instance has alpha.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsGray | Determines whether this instance is gray.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | SetEntry | Sets the color of a particular index entry in the palette. See GetEntry(Int32) to retreive the color of the palette entry.
Public method | SetPalette | Change the palette to a standard PaletteType.
Public method | ToArray | To the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
A palette consists of 256 colors, each index is a byte value of R, G, B, and sometimes Alpha values.
See Also

Reference

Atalasoft.Imaging Namespace


Palette Constructor

Overload List
 | Name | Description
Public method | Palette | Initializes a new instance of the Palette class.
Public method | Palette(Color) | Creates a new instance of Palette specifying the colors of the palette.
Public method | Palette(ColorPalette) | Initializes a new instance of the Palette class.
Public method | Palette(Int32) | Initialize a new instance of a Palette specifying the number of colors to start with.
Public method | Palette(PaletteType) | Initialize a new instance of a Palette class specifying the PaletteType.
Protected method | Palette(SerializationInfo, StreamingContext) | Initializes a new instance of the Palette class.
Top
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette Constructor

Initializes a new instance of the Palette class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette()
Public Sub New
See Also

Reference

Palette Class
Palette Overload
Atalasoft.Imaging Namespace


Palette Constructor (Color[])

Palette Constructor (Color)

Creates a new instance of Palette specifying the colors of the palette.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette(
    params Color[] colors
)
Public Sub New (
    ParamArray colors As Color()
)

Parameters

colors
Type: System.DrawingColor
An array of System.Drawing.Color objects used to fill the palette.
See Also

Reference

Palette Class
Palette Overload
Atalasoft.Imaging Namespace


Palette Constructor (ColorPalette)

Initializes a new instance of the Palette class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette(
    ColorPalette col
)
Public Sub New (
    col As ColorPalette
)

Parameters

col
Type: System.Drawing.ImagingColorPalette
The col.
See Also

Reference

Palette Class
Palette Overload
Atalasoft.Imaging Namespace


Palette Constructor (Int32)

Initialize a new instance of a Palette specifying the number of colors to start with.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette(
    int colors
)
Public Sub New (
    colors As Integer
)

Parameters

colors
Type: SystemInt32
The number of colors in the palette.
See Also

Reference

Palette Class
Palette Overload
Atalasoft.Imaging Namespace


Palette Constructor (PaletteType)

Initialize a new instance of a Palette class specifying the PaletteType.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette(
    PaletteType palType
)
Public Sub New (
    palType As PaletteType
)

Parameters

palType
Type: Atalasoft.ImagingPaletteType
The type of palette to create.
See Also

Reference

Palette Class
Palette Overload
Atalasoft.Imaging Namespace


Palette Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Palette class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Palette(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

Palette Class
Palette Overload
Atalasoft.Imaging Namespace


Palette Properties

The Palette type exposes the following members.

Properties
 | Name | Description
Public property | Colors | Returns the number of colors in the palette.
Top
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.Colors Property

PaletteColors Property

Returns the number of colors in the palette.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Colors { get; }
Public ReadOnly Property Colors As Integer
    Get

Property Value

Type: Int32
The number of colors in the palette.
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette Methods

The Palette type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep copy of this Palette.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the Palette class. (Overrides ObjectFinalize.)
Public method | GetClosestPaletteIndex(Color) | Returns the palette index that best matches a specified color.
Public method | GetClosestPaletteIndex(Color, Boolean) | Returns the palette index that best matches a specified color, returning a value if there was an exact match.
Public method | GetEntry | Returns the color of a particular index entry in the palette. See SetEntry(Int32, Color) to change the color of a palette entry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetObjectData | Provide information for object serialization.
 | GetSystemPalette | Returns the system palette of the current display if it's an 8-bit device, null (Nothing in Visual Basic) if the device is greater then 8 bits.
 | GetSystemPalette(IntPtr) | Returns the system palette of the specified device if it's 8-bit, null (Nothing in Visual Basic) if the device is greater then 8 bits.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAlpha | Determines whether this instance has alpha.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsGray | Determines whether this instance is gray.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | SetEntry | Sets the color of a particular index entry in the palette. See GetEntry(Int32) to retreive the color of the palette entry.
Public method | SetPalette | Change the palette to a standard PaletteType.
Public method | ToArray | To the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.Clone Method

PaletteClone Method

Returns a deep copy of this Palette.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A deep copy of this Palette.

Implements

ICloneableClone
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.Dispose Method

PaletteDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.Dispose Method

PaletteDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Palette Class
Dispose Overload
Atalasoft.Imaging Namespace


Palette.Dispose Method (Boolean)

PaletteDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

Palette Class
Dispose Overload
Atalasoft.Imaging Namespace


Palette.Finalize Method

PaletteFinalize Method

Finalizes an instance of the Palette class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.GetClosestPaletteIndex Method

PaletteGetClosestPaletteIndex Method

Overload List
 | Name | Description
Public method | GetClosestPaletteIndex(Color) | Returns the palette index that best matches a specified color.
Public method | GetClosestPaletteIndex(Color, Boolean) | Returns the palette index that best matches a specified color, returning a value if there was an exact match.
Top
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.GetClosestPaletteIndex Method (Color)

PaletteGetClosestPaletteIndex Method (Color)

Returns the palette index that best matches a specified color.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte GetClosestPaletteIndex(
    Color color
)
Public Function GetClosestPaletteIndex (
    color As Color
) As Byte

Parameters

color
Type: System.DrawingColor
The color to look up in the palette.

Return Value

Type: Byte
See Also

Reference

Palette Class
GetClosestPaletteIndex Overload
Atalasoft.Imaging Namespace


Palette.GetClosestPaletteIndex Method (Color, Boolean)

PaletteGetClosestPaletteIndex Method (Color, Boolean)

Returns the palette index that best matches a specified color, returning a value if there was an exact match.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte GetClosestPaletteIndex(
    Color color,
    ref bool exact
)
Public Function GetClosestPaletteIndex (
    color As Color,
    ByRef exact As Boolean
) As Byte

Parameters

color
Type: System.DrawingColor
The color to look up in the palette.
exact
Type: SystemBoolean
This value is set to true if there is an exact match, otherwise false.

Return Value

Type: Byte
See Also

Reference

Palette Class
GetClosestPaletteIndex Overload
Atalasoft.Imaging Namespace


Palette.GetEntry Method

PaletteGetEntry Method

Returns the color of a particular index entry in the palette. See SetEntry(Int32, Color) to change the color of a palette entry.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color GetEntry(
    int index
)
Public Function GetEntry (
    index As Integer
) As Color

Parameters

index
Type: SystemInt32
The palette index (0 - 255).

Return Value

Type: Color
The color of the palette entry.
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.GetObjectData Method

PaletteGetObjectData Method

Provide information for object serialization.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object that will hold the serialization information.
context
Type: System.Runtime.SerializationStreamingContext
The context into which this object is being streamed.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.GetSystemPalette Method

PaletteGetSystemPalette Method

Returns the system palette.
Overload List
Name | Description
GetSystemPalette | Returns the system palette of the current display if it's an 8-bit device, null (Nothing in Visual Basic) if the device is greater then 8 bits.
GetSystemPalette(IntPtr) | Returns the system palette of the specified device if it's 8-bit, null (Nothing in Visual Basic) if the device is greater then 8 bits.
Top
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.GetSystemPalette Method

PaletteGetSystemPalette Method

Returns the system palette of the current display if it's an 8-bit device, null (Nothing in Visual Basic) if the device is greater then 8 bits.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Palette GetSystemPalette()
Public Shared Function GetSystemPalette As Palette

Return Value

Type: Palette
A Palette containing the system palette colors.
See Also

Reference

Palette Class
GetSystemPalette Overload
Atalasoft.Imaging Namespace


Palette.GetSystemPalette Method (IntPtr)

PaletteGetSystemPalette Method (IntPtr)

Returns the system palette of the specified device if it's 8-bit, null (Nothing in Visual Basic) if the device is greater then 8 bits.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Palette GetSystemPalette(
    IntPtr device
)
Public Shared Function GetSystemPalette (
    device As IntPtr
) As Palette

Parameters

device
Type: SystemIntPtr
A handle to the device context.

Return Value

Type: Palette
A Palette containing the system palette colors.
See Also

Reference

Palette Class
GetSystemPalette Overload
Atalasoft.Imaging Namespace


Palette.HasAlpha Method

PaletteHasAlpha Method

Determines whether this instance has alpha.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasAlpha()
Public Function HasAlpha As Boolean

Return Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | Palette
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.IsGray Method

PaletteIsGray Method

Determines whether this instance is gray.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsGray()
Public Function IsGray As Boolean

Return Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | Palette
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.SetEntry Method

PaletteSetEntry Method

Sets the color of a particular index entry in the palette. See GetEntry(Int32) to retreive the color of the palette entry.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetEntry(
    int index,
    Color newColor
)
Public Sub SetEntry (
    index As Integer,
    newColor As Color
)

Parameters

index
Type: SystemInt32
The palette index (0 - 255).
newColor
Type: System.DrawingColor
The color to set the Palette index to.
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.SetPalette Method

PaletteSetPalette Method

Change the palette to a standard PaletteType.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetPalette(
    PaletteType palType
)
Public Sub SetPalette (
    palType As PaletteType
)

Parameters

palType
Type: Atalasoft.ImagingPaletteType
The type of palette to change to.
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


Palette.ToArray Method

PaletteToArray Method

To the array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color[] ToArray()
Public Function ToArray As Color()

Return Value

Type: Color
Exceptions
Exception | Condition
ObjectDisposedException | Palette
See Also

Reference

Palette Class
Atalasoft.Imaging Namespace


PaletteType Enumeration

Contains the standard palette types that a palette can be set to.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PaletteType
Public Enumeration PaletteType
Members
Member name | Description
Grayscale | The standard grayscale palette with gray colors. Entry 0 corresponds to Black and entry 255 corresponds with white, with gray shades between.
Web | A palette where each primitive is a multiple of 51. (0, 51, 102, 153, 204, 255). With six possible values per primitive and 3 primitives (red, green and blue) the maximum colors are 216. (6^3=216)
SixteenColor | Standard windows 16 color palette.
BlackAndWhite | Two color black and white palette
WebExtended | Includes all colors of the 215 color web palette with the addition of 40 grayscale colors.
See Also

Reference

Atalasoft.Imaging Namespace


PixelFormat Enumeration

Specifies the format of the color data for each pixel in the image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PixelFormat
Public Enumeration PixelFormat
Members
Member name | Description
Pixel1bppIndexed | One bit per pixel. A two color palette defines the colors associated with bit values of 0 and 1.
Pixel4bppIndexed | Four bits per pixel. A 16 color palette defines the colors associated with each pixel.
Pixel8bppIndexed | Eight bits per pixel. A palette of up to 256 colors may be used. Can contain alpha palette values.
Pixel24bppBgr | Twenty-four bits per pixel with pixel channels containing Blue, Green, and Red values in that order. This is also called an RGB image despite the order of the channels.
Pixel32bppBgra | Thirty-two bits per pixel with pixel channels containing Blue, Green, Red, and Alpha values in that order. This is also called an RGBA image despite the order of the channels.
Pixel32bppBgr | Thirty-two bits per pixel with pixel channels containing Blue, Green, and Red values in that order. This is also called an RGB image despite the order of the channels. The last channel is unused.
Pixel8bppGrayscale | Eight bits per pixel. Each pixel is a shade of gray, from 0 (black) to 255 (white).
Pixel16bppGrayscaleAlpha | Sixteen bits per pixel. A standard grayscale palette is used where pal(0)=RGB(0,0,0) up to pal(255)=RGB(255,255,255). The second channel contains an alpha (transparency) value for each pixel.
Pixel32bppCmyk | Thirty-Two bits per pixel with pixels containing the colors Cyan, Magenta, Yellow, and Black. This is a subtractive colorspace with 0, 0, 0, 0 corresponding to pure white and 255, 255, 255, 255 corresponding to pure black.
Pixel16bppGrayscale | Sixteen bits per component. This format allows for greater detailed grayscale images. Each pixel can have a value from 0 (black) to 65535 (white).
Pixel48bppBgr | Fourty-Eight bits per pixel with pixel channels containing Blue, Green and Red. This is a two byte per component image with values ranging from 0 to 65535 for each color component.
Pixel64bppBgra | Sixty-Four bits per pixel with pixel channels containing Blue, Green, Red and Alpha values in that order. This is a two byte per component image with values ranging from 0 to 65535 for each color component.
Remarks

The pixel format defines the number of bits of memory associated with one pixel of data. The format also defines the order of the color components within a single pixel of data.

Many of the pixel formats are identical to the GDI+ System.Drawing.PixelFormat types. DotImage is compatible with some of the GDI+ formats as well as including a few others not compatible with GDI+.

See Also

Reference

Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs Class

Provides data for the PixelFormatChange event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingPixelFormatChangeEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PixelFormatChangeEventArgs : EventArgs
Public Class PixelFormatChangeEventArgs
    Inherits EventArgs

The PixelFormatChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PixelFormatChangeEventArgs | Initializes a new instance of the PixelFormatChangeEventArgs class.
Public method | PixelFormatChangeEventArgs(PixelFormat, PixelFormat) | Initializes a new instance of the PixelFormatChangeEventArgs class specifying the current and new PixelFormat.
Top
Properties
 | Name | Description
Public property | Cancel | When setting this property to true, the current operation will be cancelled.
Public property | CurrentPixelFormat | Gets the PixelFormat of the current image.
Public property | NewPixelFormat | Gets the PixelFormat to change the image to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs Constructor

Creates a PixelFormatChangeEventArgs object.
Overload List
 | Name | Description
Public method | PixelFormatChangeEventArgs | Initializes a new instance of the PixelFormatChangeEventArgs class.
Public method | PixelFormatChangeEventArgs(PixelFormat, PixelFormat) | Initializes a new instance of the PixelFormatChangeEventArgs class specifying the current and new PixelFormat.
Top
See Also

Reference

PixelFormatChangeEventArgs Class
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs Constructor

Initializes a new instance of the PixelFormatChangeEventArgs class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormatChangeEventArgs()
Public Sub New
See Also

Reference

PixelFormatChangeEventArgs Class
PixelFormatChangeEventArgs Overload
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs Constructor (PixelFormat, PixelFormat)

Initializes a new instance of the PixelFormatChangeEventArgs class specifying the current and new PixelFormat.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormatChangeEventArgs(
    PixelFormat currentPixelFormat,
    PixelFormat newPixelFormat
)
Public Sub New (
    currentPixelFormat As PixelFormat,
    newPixelFormat As PixelFormat
)

Parameters

currentPixelFormat
Type: Atalasoft.ImagingPixelFormat
The current PixelFormat.
newPixelFormat
Type: Atalasoft.ImagingPixelFormat
The new PixelFormat.
See Also

Reference

PixelFormatChangeEventArgs Class
PixelFormatChangeEventArgs Overload
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs Properties

The PixelFormatChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | When setting this property to true, the current operation will be cancelled.
Public property | CurrentPixelFormat | Gets the PixelFormat of the current image.
Public property | NewPixelFormat | Gets the PixelFormat to change the image to.
Top
See Also

Reference

PixelFormatChangeEventArgs Class
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs.Cancel Property

PixelFormatChangeEventArgsCancel Property

When setting this property to true, the current operation will be cancelled.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this change should be canceled.
See Also

Reference

PixelFormatChangeEventArgs Class
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs.CurrentPixelFormat Property

PixelFormatChangeEventArgsCurrentPixelFormat Property

Gets the PixelFormat of the current image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat CurrentPixelFormat { get; }
Public ReadOnly Property CurrentPixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat
The current PixelFormat of the image.
See Also

Reference

PixelFormatChangeEventArgs Class
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs.NewPixelFormat Property

PixelFormatChangeEventArgsNewPixelFormat Property

Gets the PixelFormat to change the image to.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat NewPixelFormat { get; set; }
Public Property NewPixelFormat As PixelFormat
    Get
    Set

Property Value

Type: PixelFormat
The new PixelFormat of the image.
See Also

Reference

PixelFormatChangeEventArgs Class
Atalasoft.Imaging Namespace


PixelFormatChangeEventArgs Methods

The PixelFormatChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PixelFormatChangeEventArgs Class
Atalasoft.Imaging Namespace


PixelFormatChangeEventHandler Delegate

Handles operations that require the PixelFormat of an image to change.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PixelFormatChangeEventHandler(
    Object sender,
    PixelFormatChangeEventArgs e
)
Public Delegate Sub PixelFormatChangeEventHandler (
    sender As Object,
    e As PixelFormatChangeEventArgs
)

Parameters

sender
Type: SystemObject
The object raising the event.
e
Type: Atalasoft.ImagingPixelFormatChangeEventArgs
The PixelFormatChangeEventArgs for this event.
See Also

Reference

Atalasoft.Imaging Namespace
Atalasoft.ImagingPixelFormatChangeEventArgs


PixelFormatChanger Class

This is an abstract class that defines how an image should be changed from one pixel format to another.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingPixelFormatChanger
Atalasoft.ImagingAtalaPixelFormatChanger
Atalasoft.Imaging.ImageProcessing.DocumentDocumentPixelFormatChanger

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PixelFormatChanger
Public MustInherit Class PixelFormatChanger

The PixelFormatChanger type exposes the following members.

Constructors
 | Name | Description
Protected method | PixelFormatChanger | Initializes a new instance of the PixelFormatChanger class
Top
Methods
 | Name | Description
Public method | ChangePixelFormat | Allocate a new AtalaImage based on the sourceImage, using the requested pixel format.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LowLevelChangePixelFormat | Lows level implementatin to change pixel format.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


PixelFormatChanger Constructor

Initializes a new instance of the PixelFormatChanger class

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PixelFormatChanger()
Protected Sub New
See Also

Reference

PixelFormatChanger Class
Atalasoft.Imaging Namespace


PixelFormatChanger Methods

The PixelFormatChanger type exposes the following members.

Methods
 | Name | Description
Public method | ChangePixelFormat | Allocate a new AtalaImage based on the sourceImage, using the requested pixel format.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LowLevelChangePixelFormat | Lows level implementatin to change pixel format.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PixelFormatChanger Class
Atalasoft.Imaging Namespace


PixelFormatChanger.ChangePixelFormat Method

PixelFormatChangerChangePixelFormat Method

Allocate a new AtalaImage based on the sourceImage, using the requested pixel format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ChangePixelFormat(
    AtalaImage sourceImage,
    PixelFormat targetPixelFormat,
    ColorProfile destProfile
)
Public Function ChangePixelFormat (
    sourceImage As AtalaImage,
    targetPixelFormat As PixelFormat,
    destProfile As ColorProfile
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to be converted to a new format.
targetPixelFormat
Type: Atalasoft.ImagingPixelFormat
The requested PixelFormat
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile
An optional color profile to use for the conversion.

Return Value

Type: AtalaImage
A new AtalaImage of the requested PixelFormat.
Remarks
If targetPixelFormat is the same as the PixelFormat of sourceImage, this method will throw an IncompatiblePixelFormat exception.
See Also

Reference

PixelFormatChanger Class
Atalasoft.Imaging Namespace


PixelFormatChanger.LowLevelChangePixelFormat Method

PixelFormatChangerLowLevelChangePixelFormat Method

Lows level implementatin to change pixel format.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract AtalaImage LowLevelChangePixelFormat(
    AtalaImage sourceImage,
    PixelFormat targetPixelFormat,
    ColorProfile destProfile
)
Protected MustOverride Function LowLevelChangePixelFormat (
    sourceImage As AtalaImage,
    targetPixelFormat As PixelFormat,
    destProfile As ColorProfile
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
targetPixelFormat
Type: Atalasoft.ImagingPixelFormat
The target pixel format.
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile
The dest profile.

Return Value

Type: AtalaImage
See Also

Reference

PixelFormatChanger Class
Atalasoft.Imaging Namespace


PixelFormatUtilities Class

PixelFormatUtilities is a toolbox of utilities for manipulating and asking questions about PixelFormat enumerated values.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingPixelFormatUtilities

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class PixelFormatUtilities
Public NotInheritable Class PixelFormatUtilities

The PixelFormatUtilities type exposes the following members.

Methods
Name Description
BitsPerChannel
Returns the number of bits in each channel of this image.
BitsPerPixel
Returns the number of bits used per pixel in total.
ChannelsPerPixel
Returns the number of channels in this pixel format
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
HasAlpha
Returns true if the pixel format contains an alpha channel
ImageSize
Given a pixel format, ImageSize will return the number of bytes necessary to represent that image.
IsColor
Indicates whether or not a pixel format represents a color image
IsColorMapped
Indicated whether or not the pixel format represents a color mapped format
IsContinuous
Indicates whether or not the pixel format represents a continuous pixel format
IsGray
Indicates whether or not the pixel format represents a gray image.
IsMultiByte
Indicates whether or not any channel in this image requires multiple bytes.
IsRGBColor
Returns
Copy
true
if the pixel format represents an RGB color,
Copy
false
otherwise.
IsValid(PixelFormat)
IsValid(Int32)
RowStride(Int32, Int32)
Calculates the width in bytes of a row in an image.
RowStride(PixelFormat, Int32)
Calculates the width in bytes of a row in an image.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


PixelFormatUtilities Methods

The PixelFormatUtilities type exposes the following members.

Methods
Name Description
BitsPerChannel
Returns the number of bits in each channel of this image.
BitsPerPixel
Returns the number of bits used per pixel in total.
ChannelsPerPixel
Returns the number of channels in this pixel format
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
HasAlpha
Returns true if the pixel format contains an alpha channel
ImageSize
Given a pixel format, ImageSize will return the number of bytes necessary to represent that image.
IsColor
Indicates whether or not a pixel format represents a color image
IsColorMapped
Indicated whether or not the pixel format represents a color mapped format
IsContinuous
Indicates whether or not the pixel format represents a continuous pixel format
IsGray
Indicates whether or not the pixel format represents a gray image.
IsMultiByte
Indicates whether or not any channel in this image requires multiple bytes.
IsRGBColor
Returns
Copy
true
if the pixel format represents an RGB color,
Copy
false
otherwise.
IsValid(PixelFormat)
IsValid(Int32)
RowStride(Int32, Int32)
Calculates the width in bytes of a row in an image.
RowStride(PixelFormat, Int32)
Calculates the width in bytes of a row in an image.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.BitsPerChannel Method

PixelFormatUtilitiesBitsPerChannel Method

Returns the number of bits in each channel of this image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int BitsPerChannel(
    PixelFormat pf
)
Public Shared Function BitsPerChannel (
    pf As PixelFormat
) As Integer

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Int32
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.BitsPerPixel Method

PixelFormatUtilitiesBitsPerPixel Method

Returns the number of bits used per pixel in total.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int BitsPerPixel(
    PixelFormat pf
)
Public Shared Function BitsPerPixel (
    pf As PixelFormat
) As Integer

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Int32
Remarks
Note than some pixel formats do not use all the bits for image data. For example, Pixel32bppBgr only uses 24 bits for image data, but BitsPerPixel will return 32 for this format.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.ChannelsPerPixel Method

PixelFormatUtilitiesChannelsPerPixel Method

Returns the number of channels in this pixel format

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int ChannelsPerPixel(
    PixelFormat pf
)
Public Shared Function ChannelsPerPixel (
    pf As PixelFormat
) As Integer

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Int32
Remarks
Note that for pixel formats with colormaps, this method will always return 1.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.HasAlpha Method

PixelFormatUtilitiesHasAlpha Method

Returns true if the pixel format contains an alpha channel

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool HasAlpha(
    PixelFormat pf
)
Public Shared Function HasAlpha (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Boolean
Remarks
This will return false for color mapped pixel formats since it is impossible to know from the pixel format value alone if the colors have any alpha values.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.ImageSize Method

PixelFormatUtilitiesImageSize Method

Given a pixel format, ImageSize will return the number of bytes necessary to represent that image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int ImageSize(
    PixelFormat pf,
    int w,
    int h
)
Public Shared Function ImageSize (
    pf As PixelFormat,
    w As Integer,
    h As Integer
) As Integer

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat
w
Type: SystemInt32
The width of the image
h
Type: SystemInt32
The height of the image

Return Value

Type: Int32
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsColor Method

PixelFormatUtilitiesIsColor Method

Indicates whether or not a pixel format represents a color image

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsColor(
    PixelFormat pf
)
Public Shared Function IsColor (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Boolean
True if the pixel format is a color format, false if it is gray or colormapped.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsColorMapped Method

PixelFormatUtilitiesIsColorMapped Method

Indicated whether or not the pixel format represents a color mapped format

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsColorMapped(
    PixelFormat pf
)
Public Shared Function IsColorMapped (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Boolean
True if the pixel format will use a color map, false otherwise.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsContinuous Method

PixelFormatUtilitiesIsContinuous Method

Indicates whether or not the pixel format represents a continuous pixel format

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsContinuous(
    PixelFormat pf
)
Public Shared Function IsContinuous (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Boolean
True if the pixel format is continuous, false otherwise.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsGray Method

PixelFormatUtilitiesIsGray Method

Indicates whether or not the pixel format represents a gray image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsGray(
    PixelFormat pf
)
Public Shared Function IsGray (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Boolean
Returns true if the image format is gray, false otherwise.
Remarks
1 bit per pixel images are not considered gray since it is impossible to tell without a color map.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsMultiByte Method

PixelFormatUtilitiesIsMultiByte Method

Indicates whether or not any channel in this image requires multiple bytes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsMultiByte(
    PixelFormat pf
)
Public Shared Function IsMultiByte (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat

Return Value

Type: Boolean
Returns true if a channels needs multiple bytes, false otherwise.
Remarks
To find out how many bytes a channel requires, use BitsPerChannel(pf)/8
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsRGBColor Method

PixelFormatUtilitiesIsRGBColor Method

Returns
Copy
true
if the pixel format represents an RGB color,
Copy
false
otherwise.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsRGBColor(
    PixelFormat pf
)
Public Shared Function IsRGBColor (
    pf As PixelFormat
) As Boolean

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat.

Return Value

Type: Boolean
Copy
true
if the pixel format represents an RGB color,
Copy
false
otherwise.
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsValid Method

PixelFormatUtilitiesIsValid Method

Indicates whether or not a value or a .NET PixelFormat is valid as an Atalasoft.Image.PixelFormat type
Overload List
Name | Description
IsValid(PixelFormat) |
IsValid(Int32) |
Top
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsValid Method (PixelFormat)

PixelFormatUtilitiesIsValid Method (PixelFormat)

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsValid(
    PixelFormat bpf
)
Public Shared Function IsValid (
    bpf As PixelFormat
) As Boolean

Parameters

bpf
Type: System.Drawing.ImagingPixelFormat
A .NET PixelFormat type

Return Value

Type: Boolean
Returns true if the value is valid, false otherwise.
See Also

Reference

PixelFormatUtilities Class
IsValid Overload
Atalasoft.Imaging Namespace


PixelFormatUtilities.IsValid Method (Int32)

PixelFormatUtilitiesIsValid Method (Int32)

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsValid(
    int ipf
)
Public Shared Function IsValid (
    ipf As Integer
) As Boolean

Parameters

ipf
Type: SystemInt32
An integer representing a pixel format

Return Value

Type: Boolean
Returns true if the value is valid, false otherwise.
Remarks
Returns true if the value is valid, false otherwise.
See Also

Reference

PixelFormatUtilities Class
IsValid Overload
Atalasoft.Imaging Namespace


PixelFormatUtilities.RowStride Method

PixelFormatUtilitiesRowStride Method

Calculates the width in bytes of a row in an image.
Overload List
Name | Description
RowStride(Int32, Int32) | Calculates the width in bytes of a row in an image.
RowStride(PixelFormat, Int32) | Calculates the width in bytes of a row in an image.
Top
See Also

Reference

PixelFormatUtilities Class
Atalasoft.Imaging Namespace


PixelFormatUtilities.RowStride Method (Int32, Int32)

PixelFormatUtilitiesRowStride Method (Int32, Int32)

Calculates the width in bytes of a row in an image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int RowStride(
    int bitsPerPixel,
    int w
)
Public Shared Function RowStride (
    bitsPerPixel As Integer,
    w As Integer
) As Integer

Parameters

bitsPerPixel
Type: SystemInt32
The number of bits per pixel
w
Type: SystemInt32
The width of an image in pixels

Return Value

Type: Int32
See Also

Reference

PixelFormatUtilities Class
RowStride Overload
Atalasoft.Imaging Namespace


PixelFormatUtilities.RowStride Method (PixelFormat, Int32)

PixelFormatUtilitiesRowStride Method (PixelFormat, Int32)

Calculates the width in bytes of a row in an image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int RowStride(
    PixelFormat pf,
    int w
)
Public Shared Function RowStride (
    pf As PixelFormat,
    w As Integer
) As Integer

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
An input PixelFormat
w
Type: SystemInt32
The width of an image in pixels

Return Value

Type: Int32
See Also

Reference

PixelFormatUtilities Class
RowStride Overload
Atalasoft.Imaging Namespace


PixelMemoryException Class

This exception is thrown when an error occurs that is related to PixelMemory
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ImagingPixelMemoryException

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PixelMemoryException : Exception
<SerializableAttribute>
Public Class PixelMemoryException
    Inherits Exception

The PixelMemoryException type exposes the following members.

Constructors
 | Name | Description
Public method | PixelMemoryException | Creates a new instance of PixelMemoryException.
Public method | PixelMemoryException(String) | Creates a new instance of PixelMemoryException specifying the error message.
Protected method | PixelMemoryException(SerializationInfo, StreamingContext) | Initializes a new instance of the PixelMemoryException class.
Public method | PixelMemoryException(String, Exception) | Creates a new instance of PixelMemoryException specifying the error message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


PixelMemoryException Constructor

Creates a new instance of PixelMemoryException.
Overload List
 | Name | Description
Public method | PixelMemoryException | Creates a new instance of PixelMemoryException.
Public method | PixelMemoryException(String) | Creates a new instance of PixelMemoryException specifying the error message.
Protected method | PixelMemoryException(SerializationInfo, StreamingContext) | Initializes a new instance of the PixelMemoryException class.
Public method | PixelMemoryException(String, Exception) | Creates a new instance of PixelMemoryException specifying the error message and inner exception.
Top
See Also

Reference

PixelMemoryException Class
Atalasoft.Imaging Namespace


PixelMemoryException Constructor

Creates a new instance of PixelMemoryException.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryException()
Public Sub New
See Also

Reference

PixelMemoryException Class
PixelMemoryException Overload
Atalasoft.Imaging Namespace


PixelMemoryException Constructor (String)

Creates a new instance of PixelMemoryException specifying the error message.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

PixelMemoryException Class
PixelMemoryException Overload
Atalasoft.Imaging Namespace


PixelMemoryException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PixelMemoryException class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PixelMemoryException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

PixelMemoryException Class
PixelMemoryException Overload
Atalasoft.Imaging Namespace


PixelMemoryException Constructor (String, Exception)

Creates a new instance of PixelMemoryException specifying the error message and inner exception.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

PixelMemoryException Class
PixelMemoryException Overload
Atalasoft.Imaging Namespace


PixelMemoryException Properties

The PixelMemoryException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PixelMemoryException Class
Atalasoft.Imaging Namespace


PixelMemoryException Methods

The PixelMemoryException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PixelMemoryException Class
Atalasoft.Imaging Namespace


PixelMemoryException Events

The PixelMemoryException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PixelMemoryException Class
Atalasoft.Imaging Namespace


ProcessQueue Class

Holds a collection of ProcessQueue that are awaiting asynchronous processing.
Inheritance Hierarchy
SystemObject
System.CollectionsQueue
Atalasoft.ImagingProcessQueue

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProcessQueue : Queue
Public Class ProcessQueue
    Inherits Queue

The ProcessQueue type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessQueue | Create a instance of the ProcessQueue.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the Queue. (Inherited from Queue.)
Public property | CurrentItem | Gets the ProcessQueuedItem that is currently being processed.
Public property | IsSynchronized | Gets a value indicating whether access to the Queue is synchronized (thread safe). (Inherited from Queue.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Queue. (Inherited from Queue.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all objects from the Queue. (Inherited from Queue.)
Public method | Clone | Creates a shallow copy of the Queue. (Inherited from Queue.)
Public method | Contains | Determines whether an element is in the Queue. (Inherited from Queue.)
Public method | CopyTo(Array, Int32) | Copies the Queue elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from Queue.)
Public method | CopyTo(ProcessQueuedItem, Int32) | Copies ProcessQueuedItems from this collection to an array.
Public method | Dequeue | Remove the next item from the queue.
Public method | Enqueue(Object) | Adds an object to the end of the Queue. (Inherited from Queue.)
Public method | Enqueue(ProcessQueuedItem) | Add a new item into the process queue.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Queue. (Inherited from Queue.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Return the next item in the process queue without removing it.
Public method | ToArray | Copies the Queue elements to a new array. (Inherited from Queue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the Queue. (Inherited from Queue.)
Top
Remarks
When the Workspace is runing in asynchronous mode all image processing calls through the Workspace.ProcessImage method or the read and save methods will put the process into this queue. The purpose is to process images sequentially and prevent threading issues. Each workspace object can process only one image at a time, but as long as Workspace.IsAsynchronous is true, the processing will be performed in a separate thread.
See Also

Reference

Atalasoft.Imaging Namespace


ProcessQueue Constructor

Create a instance of the ProcessQueue.
Create a instance of the ProcessQueue.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessQueue()
Public Sub New
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue Properties

The ProcessQueue type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the Queue. (Inherited from Queue.)
Public property | CurrentItem | Gets the ProcessQueuedItem that is currently being processed.
Public property | IsSynchronized | Gets a value indicating whether access to the Queue is synchronized (thread safe). (Inherited from Queue.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Queue. (Inherited from Queue.)
Top
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue.CurrentItem Property

ProcessQueueCurrentItem Property

Gets the ProcessQueuedItem that is currently being processed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessQueuedItem CurrentItem { get; }
Public ReadOnly Property CurrentItem As ProcessQueuedItem
    Get

Property Value

Type: ProcessQueuedItem
The ProcessQueuedItem that is currently being processed.

Property Value

Type: ProcessQueuedItem
The current ProcessQueuedItem.
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue Methods

The ProcessQueue type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all objects from the Queue. (Inherited from Queue.)
Public method | Clone | Creates a shallow copy of the Queue. (Inherited from Queue.)
Public method | Contains | Determines whether an element is in the Queue. (Inherited from Queue.)
Public method | CopyTo(Array, Int32) | Copies the Queue elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from Queue.)
Public method | CopyTo(ProcessQueuedItem, Int32) | Copies ProcessQueuedItems from this collection to an array.
Public method | Dequeue | Remove the next item from the queue.
Public method | Enqueue(Object) | Adds an object to the end of the Queue. (Inherited from Queue.)
Public method | Enqueue(ProcessQueuedItem) | Add a new item into the process queue.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Queue. (Inherited from Queue.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Return the next item in the process queue without removing it.
Public method | ToArray | Copies the Queue elements to a new array. (Inherited from Queue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the Queue. (Inherited from Queue.)
Top
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue.CopyTo Method

ProcessQueueCopyTo Method

Copies items from the collection to an array.
Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) | Copies the Queue elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from Queue.)
Public method | CopyTo(ProcessQueuedItem, Int32) | Copies ProcessQueuedItems from this collection to an array.
Top
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue.CopyTo Method (ProcessQueuedItem[], Int32)

ProcessQueueCopyTo Method (ProcessQueuedItem, Int32)

Copies ProcessQueuedItems from this collection to an array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    ProcessQueuedItem[] queuedItems,
    int index
)
Public Sub CopyTo (
    queuedItems As ProcessQueuedItem(),
    index As Integer
)

Parameters

queuedItems
Type: Atalasoft.ImagingProcessQueuedItem
The array to copy the items into.
index
Type: SystemInt32
The starting index in the array where the items will be copied.
See Also

Reference

ProcessQueue Class
CopyTo Overload
Atalasoft.Imaging Namespace


ProcessQueue.Dequeue Method

ProcessQueueDequeue Method

Remove the next item from the queue.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessQueuedItem Dequeue()
Public Function Dequeue As ProcessQueuedItem

Return Value

Type: ProcessQueuedItem
The queued item that was removed.
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue.Enqueue Method

ProcessQueueEnqueue Method

Adds a new item to the queue.
Overload List
 | Name | Description
Public method | Enqueue(Object) | Adds an object to the end of the Queue. (Inherited from Queue.)
Public method | Enqueue(ProcessQueuedItem) | Add a new item into the process queue.
Top
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueue.Enqueue Method (ProcessQueuedItem)

ProcessQueueEnqueue Method (ProcessQueuedItem)

Add a new item into the process queue.
Add a new item into the process queue.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Enqueue(
    ProcessQueuedItem item
)
Public Sub Enqueue (
    item As ProcessQueuedItem
)

Parameters

item
Type: Atalasoft.ImagingProcessQueuedItem
The ProcessQueuedItem containing the thread information to process.
See Also

Reference

ProcessQueue Class
Enqueue Overload
Atalasoft.Imaging Namespace


ProcessQueue.Peek Method

ProcessQueuePeek Method

Return the next item in the process queue without removing it.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessQueuedItem Peek()
Public Function Peek As ProcessQueuedItem

Return Value

Type: ProcessQueuedItem
The next item in the process queue.
See Also

Reference

ProcessQueue Class
Atalasoft.Imaging Namespace


ProcessQueuedItem Class

This class contains information regarding the image processing function that is to be run when the ProcessQueue is ready.

Inheritance Hierarchy
SystemObject
Atalasoft.ImagingProcessQueuedItem

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProcessQueuedItem
Public Class ProcessQueuedItem

The ProcessQueuedItem type exposes the following members.

Properties
 | Name | Description
Public property | ProcessingClass | The instance of a class that will be processed in a new thread.
Public property | ProcessUndo | Indicates if an undo should be created before the thread begins.
Public property | Thread | Gets or sets the thread that the process is running in.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ProcessQueuedItem Properties

The ProcessQueuedItem type exposes the following members.

Properties
 | Name | Description
Public property | ProcessingClass | The instance of a class that will be processed in a new thread.
Public property | ProcessUndo | Indicates if an undo should be created before the thread begins.
Public property | Thread | Gets or sets the thread that the process is running in.
Top
See Also

Reference

ProcessQueuedItem Class
Atalasoft.Imaging Namespace


ProcessQueuedItem.ProcessingClass Property

ProcessQueuedItemProcessingClass Property

The instance of a class that will be processed in a new thread.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object ProcessingClass { get; }
Public ReadOnly Property ProcessingClass As Object
    Get

Property Value

Type: Object
See Also

Reference

ProcessQueuedItem Class
Atalasoft.Imaging Namespace


ProcessQueuedItem.ProcessUndo Property

ProcessQueuedItemProcessUndo Property

Indicates if an undo should be created before the thread begins.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessUndo ProcessUndo { get; set; }
Public Property ProcessUndo As ProcessUndo
    Get
    Set

Property Value

Type: ProcessUndo
See Also

Reference

ProcessQueuedItem Class
Atalasoft.Imaging Namespace


ProcessQueuedItem.Thread Property

ProcessQueuedItemThread Property

Gets or sets the thread that the process is running in.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thread Thread { get; }
Public ReadOnly Property Thread As Thread
    Get

Property Value

Type: Thread
The thread that the process is running in.
See Also

Reference

ProcessQueuedItem Class
Atalasoft.Imaging Namespace


ProcessQueuedItem Methods

The ProcessQueuedItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProcessQueuedItem Class
Atalasoft.Imaging Namespace


ProcessUndo Class

Contains information about an undo level that will be used in the %ProcessQueue%.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingProcessUndo

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProcessUndo
Public Class ProcessUndo

The ProcessUndo type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessUndo | Initialize a new instance of %ProcessUndo%.
Public method | ProcessUndo(String, Boolean) | Initialize a new instance of %ProcessUndo% specifying the Undo Description and if the image should be copied.
Top
Properties
 | Name | Description
Public property | CopyCurrent | If true, the image will be copied before placing into the undo.
Public property | UndoDescription | The description of the undo level.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ProcessUndo Constructor

Overload List
 | Name | Description
Public method | ProcessUndo | Initialize a new instance of %ProcessUndo%.
Public method | ProcessUndo(String, Boolean) | Initialize a new instance of %ProcessUndo% specifying the Undo Description and if the image should be copied.
Top
See Also

Reference

ProcessUndo Class
Atalasoft.Imaging Namespace


ProcessUndo Constructor

Initialize a new instance of %ProcessUndo%.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessUndo()
Public Sub New
See Also

Reference

ProcessUndo Class
ProcessUndo Overload
Atalasoft.Imaging Namespace


ProcessUndo Constructor (String, Boolean)

Initialize a new instance of %ProcessUndo% specifying the Undo Description and if the image should be copied.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessUndo(
    string undoDescription,
    bool copyCurrent
)
Public Sub New (
    undoDescription As String,
    copyCurrent As Boolean
)

Parameters

undoDescription
Type: SystemString
The undo description.
copyCurrent
Type: SystemBoolean
Specifies if the image should be copied before undoing.
See Also

Reference

ProcessUndo Class
ProcessUndo Overload
Atalasoft.Imaging Namespace


ProcessUndo Properties

The ProcessUndo type exposes the following members.

Properties
 | Name | Description
Public property | CopyCurrent | If true, the image will be copied before placing into the undo.
Public property | UndoDescription | The description of the undo level.
Top
See Also

Reference

ProcessUndo Class
Atalasoft.Imaging Namespace


ProcessUndo.CopyCurrent Property

ProcessUndoCopyCurrent Property

If true, the image will be copied before placing into the undo.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CopyCurrent { get; set; }
Public Property CopyCurrent As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ProcessUndo Class
Atalasoft.Imaging Namespace


ProcessUndo.UndoDescription Property

ProcessUndoUndoDescription Property

The description of the undo level.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UndoDescription { get; set; }
Public Property UndoDescription As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ProcessUndo Class
Atalasoft.Imaging Namespace


ProcessUndo Methods

The ProcessUndo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProcessUndo Class
Atalasoft.Imaging Namespace


ProgressEventArgs Class

Provides data for the Progress event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingProgressEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProgressEventArgs : EventArgs
Public Class ProgressEventArgs
    Inherits EventArgs

The ProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressEventArgs | Creates a new instance of ProgressEventArgs.
Public method | ProgressEventArgs(Int32, Int32) | Creates a new instance of ProgressEventArgs specifying the current and total progress values.
Public method | ProgressEventArgs(Int32, Int32, String) | Creates a new instance of ProgressEventArgs specifying the current and total values, and the name of the method.
Top
Properties
 | Name | Description
Public property | Cancel | When set to true, allows the current image processing function to be cancelled.
Public property | Current | Gets the current value of the progress operation.
Public property | MethodName | The name of the method calling the progress event.
Public property | Total | Gets the total number of units for this operation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging Namespace


ProgressEventArgs Constructor

Creates a ProgressEventArgs object.
Overload List
 | Name | Description
Public method | ProgressEventArgs | Creates a new instance of ProgressEventArgs.
Public method | ProgressEventArgs(Int32, Int32) | Creates a new instance of ProgressEventArgs specifying the current and total progress values.
Public method | ProgressEventArgs(Int32, Int32, String) | Creates a new instance of ProgressEventArgs specifying the current and total values, and the name of the method.
Top
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventArgs Constructor

Creates a new instance of ProgressEventArgs.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventArgs()
Public Sub New
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Overload
Atalasoft.Imaging Namespace


ProgressEventArgs Constructor (Int32, Int32)

Creates a new instance of ProgressEventArgs specifying the current and total progress values.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventArgs(
    int current,
    int total
)
Public Sub New (
    current As Integer,
    total As Integer
)

Parameters

current
Type: SystemInt32
The current progress value.
total
Type: SystemInt32
The total progress value at 100% completion.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Overload
Atalasoft.Imaging Namespace


ProgressEventArgs Constructor (Int32, Int32, String)

Creates a new instance of ProgressEventArgs specifying the current and total values, and the name of the method.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventArgs(
    int current,
    int total,
    string methodName
)
Public Sub New (
    current As Integer,
    total As Integer,
    methodName As String
)

Parameters

current
Type: SystemInt32
The current progress value.
total
Type: SystemInt32
The total progress value at 100% completion.
methodName
Type: SystemString
The name of the method raising the progress event.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Overload
Atalasoft.Imaging Namespace


ProgressEventArgs Properties

The ProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | When set to true, allows the current image processing function to be cancelled.
Public property | Current | Gets the current value of the progress operation.
Public property | MethodName | The name of the method calling the progress event.
Public property | Total | Gets the total number of units for this operation.
Top
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventArgs.Cancel Property

ProgressEventArgsCancel Property

When set to true, allows the current image processing function to be cancelled.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether to cancel the operation.
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventArgs.Current Property

ProgressEventArgsCurrent Property

Gets the current value of the progress operation.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Current { get; set; }
Public Property Current As Integer
    Get
    Set

Property Value

Type: Int32
The current value of the progress operation.
Remarks
When processing an image, this value is usually the current row of the image in pixels. When downloading a file via HTTP, it's the number of bytes downloaded.
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventArgs.MethodName Property

ProgressEventArgsMethodName Property

The name of the method calling the progress event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MethodName { get; set; }
Public Property MethodName As String
    Get
    Set

Property Value

Type: String
The method name raising the progress event.
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventArgs.Total Property

ProgressEventArgsTotal Property

Gets the total number of units for this operation.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Total { get; set; }
Public Property Total As Integer
    Get
    Set

Property Value

Type: Int32
The total number of units for this operation.
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventArgs Methods

The ProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProgressEventArgs Class
Atalasoft.Imaging Namespace


ProgressEventHandler Delegate

Handles the progress event for operations.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ProgressEventHandler(
    Object sender,
    ProgressEventArgs e
)
Public Delegate Sub ProgressEventHandler (
    sender As Object,
    e As ProgressEventArgs
)

Parameters

sender
Type: SystemObject
The object raising the event.
e
Type: Atalasoft.ImagingProgressEventArgs
The ProgressEventArgs for this event.
Remarks
The progress callback can be handled to show progress while an image is being loaded, saved, or processed. Current and Total usually signifies the image row in pixels. When downloading a file, Current and Total represents the number of bytes. It can also be used to cancel the current action. When handling a progress event, the percentage can be calculated by dividing Current by Total. Some actions will cause multiple progresses (0 - 100%) to be called.
See Also

Reference

Atalasoft.Imaging Namespace
Atalasoft.ImagingProgressEventHandler


RandomAccessImageSource Class

This is an abstract class which is used to define ImageSource objects that can be accessed in any order.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
More...

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class RandomAccessImageSource : ImageSource,
    ISerializable
<SerializableAttribute>
Public MustInherit Class RandomAccessImageSource
    Inherits ImageSource
    Implements ISerializable

The RandomAccessImageSource type exposes the following members.

Constructors
 | Name | Description
Protected method | RandomAccessImageSource | Initializes a new instance of the RandomAccessImageSource class.
Protected method | RandomAccessImageSource(SerializationInfo, StreamingContext) | Initializes a new instance of the RandomAccessImageSource class.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source.
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it.
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Performs an acquire of an indexed image.
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Inherited from ImageSource.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Inherited from ImageSource.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Inherited from ImageSource.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Inherited from ImageSource.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Inherited from ImageSource.)
Protected method | LowLevelReset | Lows level implementation of reset. (Inherited from ImageSource.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Inherited from ImageSource.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Inherited from ImageSource.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Overrides ImageSourceLowLevelTotalImagesKnown.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value.
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

Atalasoft.Imaging Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.ImagingFileSystemImageSource
Atalasoft.ImagingImageCollectionImageSource
Atalasoft.Imaging.ImageSourcesDbImageSource
Atalasoft.Imaging.ImageSourcesMergedImageSource
Atalasoft.Imaging.ImageSourcesPdfImageSource
Atalasoft.ImagingIndirectionImageSource


RandomAccessImageSource Constructor

Overload List
 | Name | Description
Protected method | RandomAccessImageSource | Initializes a new instance of the RandomAccessImageSource class.
Protected method | RandomAccessImageSource(SerializationInfo, StreamingContext) | Initializes a new instance of the RandomAccessImageSource class.
Top
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource Constructor

Initializes a new instance of the RandomAccessImageSource class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RandomAccessImageSource()
Protected Sub New
See Also

Reference

RandomAccessImageSource Class
RandomAccessImageSource Overload
Atalasoft.Imaging Namespace


RandomAccessImageSource Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the RandomAccessImageSource class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RandomAccessImageSource(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

RandomAccessImageSource Class
RandomAccessImageSource Overload
Atalasoft.Imaging Namespace


RandomAccessImageSource Properties

The RandomAccessImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source.
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it.
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource.Count Property

RandomAccessImageSourceCount Property

Returns the total number of images in the image source.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource.Item Property

RandomAccessImageSourceItem Property

Acquires the image at location i within the image source and returns it.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage this[
    int i
] { get; }
Public ReadOnly Default Property Item (
    i As Integer
) As AtalaImage
    Get

Parameters

i
Type: SystemInt32
The index of the image to be acquired.

Property Value

Type: AtalaImage
Remarks
Note that this operation performs an Acquire on the image. It is still the responsibility of the caller to perform a Release on the image when finished with it.
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource Methods

The RandomAccessImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Performs an acquire of an indexed image.
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Inherited from ImageSource.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Inherited from ImageSource.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Inherited from ImageSource.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Inherited from ImageSource.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Inherited from ImageSource.)
Protected method | LowLevelReset | Lows level implementation of reset. (Inherited from ImageSource.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Inherited from ImageSource.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Inherited from ImageSource.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Overrides ImageSourceLowLevelTotalImagesKnown.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value.
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource.GetObjectData Method

RandomAccessImageSourceGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource.LowLevelAcquire Method

RandomAccessImageSourceLowLevelAcquire Method

Performs an acquire of an indexed image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract ImageSourceNode LowLevelAcquire(
    int index
)
Protected MustOverride Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32
The index of the image to acquire.

Return Value

Type: ImageSourceNode
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource.LowLevelTotalImagesKnown Method

RandomAccessImageSourceLowLevelTotalImagesKnown Method

Returns if the total images is known.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelTotalImagesKnown()
Protected Overrides Function LowLevelTotalImagesKnown As Boolean

Return Value

Type: Boolean
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource.OnNodeIndexSet Method

RandomAccessImageSourceOnNodeIndexSet Method

This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnNodeIndexSet(
    ImageSourceNode node
)
Protected Overridable Sub OnNodeIndexSet (
    node As ImageSourceNode
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The node returned by LowLevelAcquire(Int32) after its Index has been changed.
Remarks
Override this method to customize the index value for the ImageSourceNode used by the base ImageSource class when reloading.
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


RandomAccessImageSource Events

The RandomAccessImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

RandomAccessImageSource Class
Atalasoft.Imaging Namespace


ReleasingImageSourceNodeEventArgs Class

This class is passed in the Releasing event to provide the ImageSourceNode that has been released.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingReleasingImageSourceNodeEventArgs

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ReleasingImageSourceNodeEventArgs : EventArgs
Public Class ReleasingImageSourceNodeEventArgs
    Inherits EventArgs

The ReleasingImageSourceNodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ReleasingImageSourceNodeEventArgs | Creates a new instance of ReleasingImageSourceNodeEventArgs with the ImageSourceNode that has been released.
Top
Properties
 | Name | Description
Public property | Node | Gets the ImageSourceNode that has been released.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
If the ImageSourceNode was acquired multiple times, it may still require additional calls to the Release(AtalaImage) method before it is fully released.
See Also

Reference

Atalasoft.Imaging Namespace


ReleasingImageSourceNodeEventArgs Constructor

Creates a new instance of ReleasingImageSourceNodeEventArgs with the ImageSourceNode that has been released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleasingImageSourceNodeEventArgs(
    ImageSourceNode node
)
Public Sub New (
    node As ImageSourceNode
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
The ImageSourceNode that has been released.
See Also

Reference

ReleasingImageSourceNodeEventArgs Class
Atalasoft.Imaging Namespace


ReleasingImageSourceNodeEventArgs Properties

The ReleasingImageSourceNodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | Gets the ImageSourceNode that has been released.
Top
See Also

Reference

ReleasingImageSourceNodeEventArgs Class
Atalasoft.Imaging Namespace


ReleasingImageSourceNodeEventArgs.Node Property

ReleasingImageSourceNodeEventArgsNode Property

Gets the ImageSourceNode that has been released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceNode Node { get; }
Public ReadOnly Property Node As ImageSourceNode
    Get

Property Value

Type: ImageSourceNode
The ImageSourceNode that has been released.
See Also

Reference

ReleasingImageSourceNodeEventArgs Class
Atalasoft.Imaging Namespace


ReleasingImageSourceNodeEventArgs Methods

The ReleasingImageSourceNodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReleasingImageSourceNodeEventArgs Class
Atalasoft.Imaging Namespace


ReleasingImageSourceNodeEventHandler Delegate

Reports when an ImageSourceNode has been released.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ReleasingImageSourceNodeEventHandler(
    Object sender,
    ReleasingImageSourceNodeEventArgs e
)
Public Delegate Sub ReleasingImageSourceNodeEventHandler (
    sender As Object,
    e As ReleasingImageSourceNodeEventArgs
)

Parameters

sender
Type: SystemObject
The sender.
e
Type: Atalasoft.ImagingReleasingImageSourceNodeEventArgs
The ReleasingImageSourceNodeEventArgs instance containing the event data.
See Also

Reference

Atalasoft.Imaging Namespace


ResolutionUnit Enumeration

Defines the units associated with Resolution, or Dpi.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResolutionUnit
Public Enumeration ResolutionUnit
Members
Member name | Description
Undefined | Units are not defined.
DotsPerInch | Units are expressed in inches.
DotsPerCentimeters | Units are expressed in centimeters.
See Also

Reference

Atalasoft.Imaging Namespace


ResourceReleaser(T) Class

ResourceReleaserT Class

This is a tool that can be used for managing the automatic releasing of resources via the using statement.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingResourceReleaserT
Atalasoft.ImagingBinaryPaletteEnforcer
Atalasoft.Imaging.MemoryPixelMemoryLocker

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResourceReleaser<T> : IDisposable

Public Class ResourceReleaser(Of T)
    Implements IDisposable

Type Parameters

T

The ResourceReleaserT type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceReleaserT | Constructs a new ResourceReleaser object with the value and action given.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ResourceReleaserT class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | mVal | The backing field for the val parameter.
Top
Remarks
See PixelMemoryLock for a concrete example of this class.
Examples
C#
Copy
  See Also
Reference
Atalasoft.Imaging Namespace
Copyright 2000-2023 Kofax. All rights reserved.
Send comments on this topic to
        Atalasoft Development Team


ResourceReleaser(T) Constructor

ResourceReleaserT Constructor

Constructs a new ResourceReleaser object with the value and action given.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResourceReleaser(
    T val,
    Action<T> action
)
Public Sub New (
    val As T,
    action As Action(Of T)
)

Parameters

val
Type: T
Val is an object that should be managed by the ResourceReleaser
action
Type: SystemActionT
Action is an action that will be executed upon disposal of the ResourceReleaser. Action will be passed val when it is executed.
See Also

Reference

ResourceReleaserT Class
Atalasoft.Imaging Namespace


ResourceReleaser(T) Methods

ResourceReleaserT Methods

The ResourceReleaserT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ResourceReleaserT class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResourceReleaserT Class
Atalasoft.Imaging Namespace


ResourceReleaser(T).Dispose Method

ResourceReleaserTDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

ResourceReleaserT Class
Atalasoft.Imaging Namespace


ResourceReleaser(T).Dispose Method

ResourceReleaserTDispose Method

Disposes the ResourceReleaser.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
Upon disposal, the ResourceReleaser will invoke the original action passed to it in the construction, passing in the original val from the constructor. ResourceReleaser does not check val for null. That is up to the action.
See Also

Reference

ResourceReleaserT Class
Dispose Overload
Atalasoft.Imaging Namespace


ResourceReleaser(T).Dispose Method (Boolean)

ResourceReleaserTDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ResourceReleaserT Class
Dispose Overload
Atalasoft.Imaging Namespace


ResourceReleaser(T).Finalize Method

ResourceReleaserTFinalize Method

Finalizes an instance of the ResourceReleaserT class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ResourceReleaserT Class
Atalasoft.Imaging Namespace


ResourceReleaser(T) Fields

ResourceReleaserT Fields

The ResourceReleaserT generic type exposes the following members.

Fields
 | Name | Description
Protected field | mVal | The backing field for the val parameter.
Top
See Also

Reference

ResourceReleaserT Class
Atalasoft.Imaging Namespace


ResourceReleaser(T).mVal Field

ResourceReleaserTmVal Field

The backing field for the val parameter.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected T mVal
Protected mVal As T

Field Value

Type: T
See Also

Reference

ResourceReleaserT Class
Atalasoft.Imaging Namespace


SerializationHelper Class

SerializationHelper is a set of static methods to help in the process of deserialization of an object graph.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingSerializationHelper

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class SerializationHelper
Public NotInheritable Class SerializationHelper

The SerializationHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(SerializationInfo, String, Boolean) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Byte) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Char) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, DateTime) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Decimal) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Double) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Int16) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Int32) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Int64) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Single) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Type) | Get an object from a SerializationInfo object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
In the current .NET model, one must ask for a field within a serialization object acting under the assumption that it will be there. If the field isn't there, an Exception is thrown. An object is deserializable if and only if all fields of an object have been serialized. In the dotImage model, an object is constructed with default values which are then replaced by the information in the SerializationInfo object. In dotImage this makes more sense since several objects' underlying data is optional or mutually exclusive. To retrieve a scalar, pass GetValue() the SerializationInfo object, the name of the field, and a reference to the variable that will hold the value. GetValue() will return true if it performed an assignment to the variable. To retrieve a non-scalar type, pass GetValue() the SerializationInfo object, the name of the field and its expected Type. GetValue will return the object if it found it, null otherwise.
See Also

Reference

Atalasoft.Imaging Namespace


SerializationHelper Methods

The SerializationHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(SerializationInfo, String, Boolean) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Byte) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Char) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, DateTime) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Decimal) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Double) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Int16) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Int32) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Int64) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Single) | Get a value from a SerializationInfo object
 | GetValue(SerializationInfo, String, Type) | Get an object from a SerializationInfo object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SerializationHelper Class
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method

SerializationHelperGetValue Method

Get a value from a SerializationInfo object.
Overload List
Name | Description
GetValue(SerializationInfo, String, Boolean) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Byte) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Char) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, DateTime) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Decimal) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Double) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Int16) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Int32) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Int64) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Single) | Get a value from a SerializationInfo object
GetValue(SerializationInfo, String, Type) | Get an object from a SerializationInfo object.
Top
See Also

Reference

SerializationHelper Class
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Boolean)

SerializationHelperGetValue Method (SerializationInfo, String, Boolean)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref bool val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Boolean
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemBoolean
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Byte)

SerializationHelperGetValue Method (SerializationInfo, String, Byte)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref byte val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Byte
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemByte
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Char)

SerializationHelperGetValue Method (SerializationInfo, String, Char)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref char val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Char
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemChar
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, DateTime)

SerializationHelperGetValue Method (SerializationInfo, String, DateTime)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref DateTime val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As DateTime
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemDateTime
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Decimal)

SerializationHelperGetValue Method (SerializationInfo, String, Decimal)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref decimal val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Decimal
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemDecimal
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Double)

SerializationHelperGetValue Method (SerializationInfo, String, Double)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref double val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Double
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemDouble
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Int16)

SerializationHelperGetValue Method (SerializationInfo, String, Int16)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref short val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Short
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemInt16
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Int32)

SerializationHelperGetValue Method (SerializationInfo, String, Int32)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref int val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Integer
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemInt32
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Int64)

SerializationHelperGetValue Method (SerializationInfo, String, Int64)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref long val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Long
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemInt64
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Single)

SerializationHelperGetValue Method (SerializationInfo, String, Single)

Get a value from a SerializationInfo object

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GetValue(
    SerializationInfo info,
    string name,
    ref float val
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    ByRef val As Single
) As Boolean

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
val
Type: SystemSingle
The place to store the retrieved value.

Return Value

Type: Boolean
true if the value was found, false otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


SerializationHelper.GetValue Method (SerializationInfo, String, Type)

SerializationHelperGetValue Method (SerializationInfo, String, Type)

Get an object from a SerializationInfo object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Object GetValue(
    SerializationInfo info,
    string name,
    Type type
)
Public Shared Function GetValue (
    info As SerializationInfo,
    name As String,
    type As Type
) As Object

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object in which to look for the value.
name
Type: SystemString
The name of the value.
type
Type: SystemType
The expected type of the object.

Return Value

Type: Object
an object of the Type specified if found, null otherwise

Return Value

Type: Object
An object of the Type specified if found, null otherwise.
See Also

Reference

SerializationHelper Class
GetValue Overload
Atalasoft.Imaging Namespace


UndoCollection Class

The UndoCollection class is used to manage operations that need undo/redo functinality. The collection contains properties to specify the number of allowed operations to undo or redo.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingMarshalByRefReadOnlyCollectionBase
Atalasoft.ImagingUndoCollection

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UndoCollection : MarshalByRefReadOnlyCollectionBase,
    IDisposable
Public Class UndoCollection
    Inherits MarshalByRefReadOnlyCollectionBase
    Implements IDisposable

The UndoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of items in the collection. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Protected property | InnerList | Gets the ArrayList stored within the collection. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe). (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public property | Item | Gets the undo item.
Public property | Levels | Gets or set the number of Undo levels in this collection.
Public property | NumRedos | Gets the current number of redos in the collection.
Public property | NumUndos | Gets the current number of undos in the collection.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Add a new undo level to the undo collection specifying the description and if the Image is copied.
Public method | Clear | Clears the undo/redo collection items.
Public method | CopyTo(Array, Int32) | Copies the collection items into an array. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public method | CopyTo(UndoLevel, Int32) | Copies the UndoLevels into an array.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Clean up unmanaged resources by disposing each AtalaImage in the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the UndoCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGetCurrentImageCollection | Raises the [E:GetCurrentImageCollection] event.
Protected method | OnNewImageCollection | Raises the [E:NewImageCollection] event.
 | Redo | The Redo method redo's the most recent udno in this UndoCollection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Undo | The Undo method undo's the most recently added item to this UndoCollection.
Top
Remarks

NOTE: The UndoCollection class is intended for use in the Workspace class only, and should not be used on its own. The UndoCollection relies on the Workspace'sImageCollection in order to save the current images.

The undo collection may be used to create an Undo/Redo menu in your project. The Add method should be called at the point you want to save as the 'undo point' (for examble, BEFORE an ImageCommand is applied). To undo or redo an operation, simply call the Undo or Redo methods. You can access the Description property to determine what the next undo or redo will accomplish. The following code example shows how this is done.

Examples

Accessing the description of the next operation to undo/redo.

UndoDescriptionCS (C#)
Copy
WorkspaceViewer Viewer;
...
string undoDescription = Viewer.Undos[Viewer.Undos.Count - Viewer.Undos.NumUndos].Description;
string redoDescription = Viewer.Undos[Viewer.Undos.Count - Viewer.Undos.NumUndos - 1].Description;
UndoDescriptionVB (Visual Basic)
Copy
Dim Viewer As WorkspaceViewer
...
Dim undoDescription As String = Viewer.Undos(Viewer.Undos.Count - Viewer.Undos.NumUndos).Description
Dim redoDescription As String = Viewer.Undos(Viewer.Undos.Count - Viewer.Undos.NumUndos - 1).Description
See Also

Reference

Atalasoft.Imaging Namespace


UndoCollection Properties

The UndoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of items in the collection. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Protected property | InnerList | Gets the ArrayList stored within the collection. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe). (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public property | Item | Gets the undo item.
Public property | Levels | Gets or set the number of Undo levels in this collection.
Public property | NumRedos | Gets the current number of redos in the collection.
Public property | NumUndos | Gets the current number of undos in the collection.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Top
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Item Property

UndoCollectionItem Property

Gets the undo item.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoLevel this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As UndoLevel
    Get

Parameters

index
Type: SystemInt32
Zero based Index of the undo item.

Property Value

Type: UndoLevel
The UndoLevel at this index.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Levels Property

UndoCollectionLevels Property

Gets or set the number of Undo levels in this collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Levels { get; set; }
Public Property Levels As Integer
    Get
    Set

Property Value

Type: Int32
Remarks

The Levels property limits the number of undo's or redo's that are saved. For example, to limit the Workspace to only be able to undo a single operation, set the Levels property to 1.

See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.NumRedos Property

UndoCollectionNumRedos Property

Gets the current number of redos in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int NumRedos { get; }
Public ReadOnly Property NumRedos As Integer
    Get

Property Value

Type: Int32
An integer representing the number of redo operations that may be performed at this instant.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.NumUndos Property

UndoCollectionNumUndos Property

Gets the current number of undos in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int NumUndos { get; }
Public ReadOnly Property NumUndos As Integer
    Get

Property Value

Type: Int32
An integer represending the number of operations that are able to be undone.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection Methods

The UndoCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a new undo level to the undo collection specifying the description and if the Image is copied.
Public method | Clear | Clears the undo/redo collection items.
Public method | CopyTo(Array, Int32) | Copies the collection items into an array. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public method | CopyTo(UndoLevel, Int32) | Copies the UndoLevels into an array.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Clean up unmanaged resources by disposing each AtalaImage in the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the UndoCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns a reference to an IEnumerator interface, whose purpose is to grant access to an enumeration's items. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGetCurrentImageCollection | Raises the [E:GetCurrentImageCollection] event.
Protected method | OnNewImageCollection | Raises the [E:NewImageCollection] event.
 | Redo | The Redo method redo's the most recent udno in this UndoCollection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Undo | The Undo method undo's the most recently added item to this UndoCollection.
Top
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Add Method

UndoCollectionAdd Method

Add a new undo level to the undo collection specifying the description and if the Image is copied.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string undoDescription,
    bool copyCurrent
)
Public Sub Add (
    undoDescription As String,
    copyCurrent As Boolean
)

Parameters

undoDescription
Type: SystemString
The textual description of this undo level.
copyCurrent
Type: SystemBoolean
If true, the image will be copied into the undo collection.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Clear Method

UndoCollectionClear Method

Clears the undo/redo collection items.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Return Value

Type:
Clears the collection.
Remarks
Use this method to release all undo and redo items.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.CopyTo Method

UndoCollectionCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) | Copies the collection items into an array. (Inherited from MarshalByRefReadOnlyCollectionBase.)
Public method | CopyTo(UndoLevel, Int32) | Copies the UndoLevels into an array.
Top
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.CopyTo Method (UndoLevel[], Int32)

UndoCollectionCopyTo Method (UndoLevel, Int32)

Copies the UndoLevels into an array.

Copies the UndoLevels into an array.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    UndoLevel[] undos,
    int index
)
Public Sub CopyTo (
    undos As UndoLevel(),
    index As Integer
)

Parameters

undos
Type: Atalasoft.ImagingUndoLevel
An array of UndoLevel where the collection items will be stored.
index
Type: SystemInt32
An index in the array where items will be stored.
See Also

Reference

UndoCollection Class
CopyTo Overload
Atalasoft.Imaging Namespace


UndoCollection.Dispose Method

UndoCollectionDispose Method

Overload List
 | Name | Description
Public method | Dispose | Clean up unmanaged resources by disposing each AtalaImage in the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Dispose Method

UndoCollectionDispose Method

Clean up unmanaged resources by disposing each AtalaImage in the collection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

UndoCollection Class
Dispose Overload
Atalasoft.Imaging Namespace


UndoCollection.Dispose Method (Boolean)

UndoCollectionDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

UndoCollection Class
Dispose Overload
Atalasoft.Imaging Namespace


UndoCollection.Finalize Method

UndoCollectionFinalize Method

Finalizes an instance of the UndoCollection class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.OnGetCurrentImageCollection Method

UndoCollectionOnGetCurrentImageCollection Method

Raises the [E:GetCurrentImageCollection] event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnGetCurrentImageCollection(
    ImageCollectionEventArgs e
)
Protected Sub OnGetCurrentImageCollection (
    e As ImageCollectionEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageCollectionEventArgs
The ImageCollectionEventArgs instance containing the event data.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.OnNewImageCollection Method

UndoCollectionOnNewImageCollection Method

Raises the [E:NewImageCollection] event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnNewImageCollection(
    ImageCollectionEventArgs e
)
Protected Sub OnNewImageCollection (
    e As ImageCollectionEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageCollectionEventArgs
The ImageCollectionEventArgs instance containing the event data.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Redo Method

UndoCollectionRedo Method

The Redo method redo's the most recent udno in this UndoCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Redo()
Public Sub Redo
Remarks
If there are no redo's to be undone (NumRedos lt; 1), then this method does nothing.
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoCollection.Undo Method

UndoCollectionUndo Method

The Undo method undo's the most recently added item to this UndoCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Undo()
Public Sub Undo
See Also

Reference

UndoCollection Class
Atalasoft.Imaging Namespace


UndoLevel Class

The UndoLevel class is used to store a single operation, in an UndoCollection, that can be un-done or re-done. Every instance of this class holds an ImageCollection which are the set of images that will be restored to 'undo' the operation that this UndoLevel represents.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingUndoLevel

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UndoLevel
Public Class UndoLevel

The UndoLevel type exposes the following members.

Constructors
 | Name | Description
Public method | UndoLevel | Creates a new instance of UndoLevel.
Public method | UndoLevel(ImageCollection, String) | Creates a new instance of UndoLevel specifying the ImageCollection and undo Description.
Top
Properties
 | Name | Description
Public property | Description | Gets the undo description associated with this UndoLevel.
Public property | Images | Gets the undo image collection associated with this UndoLevel.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The UndoLevel class is not usualy accessed directly, but is used by the UndoCollection to keep track of operations.
See Also

Reference

Atalasoft.Imaging Namespace


UndoLevel Constructor

Overload List
 | Name | Description
Public method | UndoLevel | Creates a new instance of UndoLevel.
Public method | UndoLevel(ImageCollection, String) | Creates a new instance of UndoLevel specifying the ImageCollection and undo Description.
Top
See Also

Reference

UndoLevel Class
Atalasoft.Imaging Namespace


UndoLevel Constructor

Creates a new instance of UndoLevel.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoLevel()
Public Sub New
See Also

Reference

UndoLevel Class
UndoLevel Overload
Atalasoft.Imaging Namespace


UndoLevel Constructor (ImageCollection, String)

Creates a new instance of UndoLevel specifying the ImageCollection and undo Description.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoLevel(
    ImageCollection images,
    string description
)
Public Sub New (
    images As ImageCollection,
    description As String
)

Parameters

images
Type: Atalasoft.ImagingImageCollection
The ImageCollection that this undo level will contain.
description
Type: SystemString
The description of this undo level.
See Also

Reference

UndoLevel Class
UndoLevel Overload
Atalasoft.Imaging Namespace


UndoLevel Properties

The UndoLevel type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the undo description associated with this UndoLevel.
Public property | Images | Gets the undo image collection associated with this UndoLevel.
Top
See Also

Reference

UndoLevel Class
Atalasoft.Imaging Namespace


UndoLevel.Description Property

UndoLevelDescription Property

Gets the undo description associated with this UndoLevel.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
A string containing the undo description.
See Also

Reference

UndoLevel Class
Atalasoft.Imaging Namespace


UndoLevel.Images Property

UndoLevelImages Property

Gets the undo image collection associated with this UndoLevel.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection Images { get; }
Public ReadOnly Property Images As ImageCollection
    Get

Property Value

Type: ImageCollection
An ImageCollection for this UndoLevel.
See Also

Reference

UndoLevel Class
Atalasoft.Imaging Namespace


UndoLevel Methods

The UndoLevel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UndoLevel Class
Atalasoft.Imaging Namespace


Workspace Class

The workspace object is the container that is used to manage changes to images and provide an interface to open, save, and manipulate images either synchronously or asynchronously.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.ImagingWorkspace

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Workspace : MarshalByRefObject, IDisposable
Public Class Workspace
    Inherits MarshalByRefObject
    Implements IDisposable

The Workspace type exposes the following members.

Constructors
 | Name | Description
Public method | Workspace | Creates a new instance of dotImage
Top
Properties
 | Name | Description
Public property | Asynchronous | Gets or sets a value indicating if method calls through this Workspace object are processed asynchronously in a background thread.
Public property | AutoDispose | Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized.
Public property | Image | Gets or sets the current AtalaImage that is active in this Workspace.
Public property | Images | Gets the ImageCollection of this Workspace object.
Public property | Queue | Gets the ProcessQueue containing queued items that this Workspace object is currently processing.
Public property | Undos | Gets the UndoCollection object containing the undo history of this Workspace.
Top
Methods
 | Name | Description
 | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image in order to process it.
Public method | ApplyCommand(ImageCommand, String) | Creates an undo level, then applies an ImageCommand to the current image in order to process it.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Cleans up all resources held by this Workspace including all images in the ImageCollection and undos in the UndoCollection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the Workspace class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposeImage | Invoked when pixel data in the current image changes without setting a new image. Fires the DisposeImage event.
Protected method | OnImageChanged | Raises the [E:ImageChanged] event.
Protected method | OnImageStreamCompleted | Invoked after an image has been read or saved signifying that the Stream which was passed in can be closed. Fires the ImageStreamCompleted event.
Protected method | OnNewImage |
Protected method | OnProcessCompleted | Invoked when an asynchronous process has completed. Fires the ProcessCompleted event.
Protected method | OnProcessError | Invoked when an error occurs in a separate thread when being processed asynchronously. Fires the ProcessError event.
Public method | Open(Stream) | Decodes an image from a stream and sets it to the current image.
Public method | Open(String) | Decodes an image from a file and sets it to the current image.
Public method | Open(Stream, Int32) | Decodes an image from a stream specifying the frame index of a multipaged file, and sets it to the current image.
Public method | Open(String, Int32) | Decodes an image from a file specifying the frame index of a multipaged file, and sets it to the current image.
Public method | Save(Stream, ImageEncoder) | Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image.
Public method | Save(String, ImageEncoder) | Writes the current AtalaImage or ImageCollection to a file specifying the ImageEncoder to use to encode the image.
Public method | Save(String, ImageType) | Obsolete. Writes the current AtalaImage or ImageCollection to a file specifying the ImageType to use to encode the image.
Public method | Save(Stream, ImageEncoder, Int32) | Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image and the image index in the collection to save.
Public method | Save(String, ImageEncoder, Int32) | Writes the current %AtalaImage% or %ImageCollection% to a file specifying the ImageEncoder to use to encode the image and the image index in the collection to save.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DisposeImage | Fired when an image in the ImageCollection or UndoCollection is disposed.
Public event | ImageChanged | Occurs when the current image in the ImageCollection changes.
Public event | ImageStreamCompleted | Fires after an image has been read or saved signifying that the Stream which was passed in can be closed.
Public event | ProcessCompleted | Fires when an asynchronous process has completed.
Public event | ProcessError | Fires when an error occurs in a separate thread when being processed asynchronously.
Public event | Progress | Fires while an image is being processed.
Top
Remarks

The Workspace object, part of the Atalasoft.Imaging namespace, provides a container that allows for intuitive image processing and management of AtalaImage and ImageCollection objects. The Workspace can be used to manage changes to AtalaImage objects and access methods to open, save, and manipulate images.

Many image processing functions may create new AtalaImage objects. The Workspace manages the creation of these objects by keeping a single current image and providing events when the image changes. The Workspace also disposes of old images when they are no longer needed. You can access the current AtalaImage with the Image property of the Workspace object.

The Workspace is designed to operate either synchronously or asynchronously for multi-threading operations. This behavior is set by the Asynchronous property.

See the WinForm's WorkspaceViewer for a Workspace object with a user interface for displaying images.

Examples

This example demonstrates how to create a new workspace, open an image, resample it, then save it to a file.

Simple Example (C#)
Copy
Workspace myWorkspace = new Workspace();
myWorkspace.Open("image.png");
myWorkspace.ApplyCommand(new ResampleCommand((int)(myWorkspace.Width / 2), (int)(myWorkspace.Height / 2)));
myWorkspace.Save("newImage.png", new PngEncoder());
myWorkspace.Dispose();
Simple Example (Visual Basic)
Copy
Dim myWorkspace As Workspace = New Workspace()
myWorkspace.Open("image.png")
myWorkspace.ApplyCommand(New ResampleCommand(myWorkspace.Width / 2, myWorkspace.Height / 2))
myWorkspace.Save("newImage.png", New PngEncoder())
myWorkspace.Dispose()
See Also

Reference

Atalasoft.Imaging Namespace


Workspace Constructor

Creates a new instance of dotImage

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Workspace()
Public Sub New
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace Properties

The Workspace type exposes the following members.

Properties
 | Name | Description
Public property | Asynchronous | Gets or sets a value indicating if method calls through this Workspace object are processed asynchronously in a background thread.
Public property | AutoDispose | Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized.
Public property | Image | Gets or sets the current AtalaImage that is active in this Workspace.
Public property | Images | Gets the ImageCollection of this Workspace object.
Public property | Queue | Gets the ProcessQueue containing queued items that this Workspace object is currently processing.
Public property | Undos | Gets the UndoCollection object containing the undo history of this Workspace.
Top
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Asynchronous Property

WorkspaceAsynchronous Property

Gets or sets a value indicating if method calls through this Workspace object are processed asynchronously in a background thread.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Asynchronous { get; set; }
Public Property Asynchronous As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if method calls through this Workspace object are processed asynchronously in a background thread.
Remarks

By default, this value is false. When this value is true the workspace is operating in asynchronous mode and the ProcessQueue is used to queue each command that is applied to the image. If the AtalaImage is accessed directly, unexpected threading issues might occur.

See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace
Asynchronous Image Processing


Workspace.AutoDispose Property

WorkspaceAutoDispose Property

Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoDispose { get; set; }
Public Property AutoDispose As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the Workspace should dispose all images it contains when finalized.
Remarks
This value is true by default. Setting this value to false is useful when using an Images from another location. This only prevents images from being disposed when the associated Workspace object is disposed or finalized. To prevent images from being disposed when processing, handle the DisposeImage event and set the cancel property in the event args to true. Also consider using Replace(AtalaImage) instead of the Image property when setting a new image.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Image Property

WorkspaceImage Property

Gets or sets the current AtalaImage that is active in this Workspace.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
Remarks

When the image that is being set already exists in the ImageCollection, then that image is set as the current, and the ChangedImage event fires. When the image being set does not exist in the collection, the current image is replaced with the new image, and the current image is either added to the UndoCollection, or disposed.

To replace the current image, without disposing it, or placing it into the UndoCollection, use the Replace(AtalaImage) method in the ImageCollection by calling myWorkspace.Images.Replace(newImage) instead of myWorkspace.Image = newImage.

See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace
Replace Method


Workspace.Images Property

WorkspaceImages Property

Gets the ImageCollection of this Workspace object.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection Images { get; }
Public ReadOnly Property Images As ImageCollection
    Get

Property Value

Type: ImageCollection
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Queue Property

WorkspaceQueue Property

Gets the ProcessQueue containing queued items that this Workspace object is currently processing.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessQueue Queue { get; }
Public ReadOnly Property Queue As ProcessQueue
    Get

Property Value

Type: ProcessQueue
The ProcessQueue containing queued items that this Workspace object is currently processing.
Remarks
The ProcessQueue only contains items if the Workspace is running in Asynchronous mode.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Undos Property

WorkspaceUndos Property

Gets the UndoCollection object containing the undo history of this Workspace.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoCollection Undos { get; }
Public ReadOnly Property Undos As UndoCollection
    Get

Property Value

Type: UndoCollection
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace Methods

The Workspace type exposes the following members.

Methods
 | Name | Description
 | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image in order to process it.
Public method | ApplyCommand(ImageCommand, String) | Creates an undo level, then applies an ImageCommand to the current image in order to process it.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Cleans up all resources held by this Workspace including all images in the ImageCollection and undos in the UndoCollection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the Workspace class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposeImage | Invoked when pixel data in the current image changes without setting a new image. Fires the DisposeImage event.
Protected method | OnImageChanged | Raises the [E:ImageChanged] event.
Protected method | OnImageStreamCompleted | Invoked after an image has been read or saved signifying that the Stream which was passed in can be closed. Fires the ImageStreamCompleted event.
Protected method | OnNewImage |
Protected method | OnProcessCompleted | Invoked when an asynchronous process has completed. Fires the ProcessCompleted event.
Protected method | OnProcessError | Invoked when an error occurs in a separate thread when being processed asynchronously. Fires the ProcessError event.
Public method | Open(Stream) | Decodes an image from a stream and sets it to the current image.
Public method | Open(String) | Decodes an image from a file and sets it to the current image.
Public method | Open(Stream, Int32) | Decodes an image from a stream specifying the frame index of a multipaged file, and sets it to the current image.
Public method | Open(String, Int32) | Decodes an image from a file specifying the frame index of a multipaged file, and sets it to the current image.
Public method | Save(Stream, ImageEncoder) | Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image.
Public method | Save(String, ImageEncoder) | Writes the current AtalaImage or ImageCollection to a file specifying the ImageEncoder to use to encode the image.
Public method | Save(String, ImageType) | Obsolete. Writes the current AtalaImage or ImageCollection to a file specifying the ImageType to use to encode the image.
Public method | Save(Stream, ImageEncoder, Int32) | Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image and the image index in the collection to save.
Public method | Save(String, ImageEncoder, Int32) | Writes the current %AtalaImage% or %ImageCollection% to a file specifying the ImageEncoder to use to encode the image and the image index in the collection to save.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.ApplyCommand Method

WorkspaceApplyCommand Method

Examples

This example demonstrates how to apply a command in VB.

Apply a Command (Visual Basic)
Copy
myWorkspace.ApplyCommand(new BlurGaussian(10))

This example demonstrates how to apply a command in C#.

Apply a Command (C#)
Copy
myWorkspace.ApplyCommand(new BlurGaussian(10));
Overload List
 | Name | Description
 | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image in order to process it.
Public method | ApplyCommand(ImageCommand, String) | Creates an undo level, then applies an ImageCommand to the current image in order to process it.
Top
Examples

This example demonstrates how to apply a command in VB.

Apply a Command (Visual Basic)
Copy
myWorkspace.ApplyCommand(new BlurGaussian(10))

This example demonstrates how to apply a command in C#.

Apply a Command (C#)
Copy
myWorkspace.ApplyCommand(new BlurGaussian(10));
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.ApplyCommand Method (ImageCommand)

WorkspaceApplyCommand Method (ImageCommand)

Applies an ImageCommand to the current image in order to process it.
Applies an ImageCommand to the current image in order to process it.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command
)
Public Sub ApplyCommand (
    command As ImageCommand
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The Command to apply. Any object that inherits ImageCommand can be passed into this method.
Remarks
If Asynchronous is true, the command will be processed in a background thread.
See Also

Reference

Workspace Class
ApplyCommand Overload
Atalasoft.Imaging Namespace


Workspace.ApplyCommand Method (ImageCommand, String)

WorkspaceApplyCommand Method (ImageCommand, String)

Creates an undo level, then applies an ImageCommand to the current image in order to process it.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command,
    string undoDescription
)
Public Sub ApplyCommand (
    command As ImageCommand,
    undoDescription As String
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The Command to apply. Any object that inherits ImageCommand can be passed into this method.
undoDescription
Type: SystemString
A description of the undo level that will be added before processing.
See Also

Reference

Workspace Class
ApplyCommand Overload
Atalasoft.Imaging Namespace


Workspace.Dispose Method

WorkspaceDispose Method

Overload List
 | Name | Description
Public method | Dispose | Cleans up all resources held by this Workspace including all images in the ImageCollection and undos in the UndoCollection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Dispose Method

WorkspaceDispose Method

Cleans up all resources held by this Workspace including all images in the ImageCollection and undos in the UndoCollection.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Workspace Class
Dispose Overload
Atalasoft.Imaging Namespace


Workspace.Dispose Method (Boolean)

WorkspaceDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

Workspace Class
Dispose Overload
Atalasoft.Imaging Namespace


Workspace.Finalize Method

WorkspaceFinalize Method

Finalizes an instance of the Workspace class.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.OnDisposeImage Method

WorkspaceOnDisposeImage Method

Invoked when pixel data in the current image changes without setting a new image. Fires the DisposeImage event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnDisposeImage(
    ImageCancelEventArgs e
)
Protected Sub OnDisposeImage (
    e As ImageCancelEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageCancelEventArgs
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.OnImageChanged Method

WorkspaceOnImageChanged Method

Raises the [E:ImageChanged] event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnImageChanged(
    ImageEventArgs e
)
Protected Sub OnImageChanged (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
The ImageEventArgs instance containing the event data.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.OnImageStreamCompleted Method

WorkspaceOnImageStreamCompleted Method

Invoked after an image has been read or saved signifying that the Stream which was passed in can be closed. Fires the ImageStreamCompleted event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnImageStreamCompleted(
    ImageStreamEventArgs e
)
Protected Sub OnImageStreamCompleted (
    e As ImageStreamEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageStreamEventArgs
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.OnNewImage Method

WorkspaceOnNewImage Method

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnNewImage(
    ImageEventArgs e
)
Protected Sub OnNewImage (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.OnProcessCompleted Method

WorkspaceOnProcessCompleted Method

Invoked when an asynchronous process has completed. Fires the ProcessCompleted event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnProcessCompleted(
    ImageEventArgs e
)
Protected Sub OnProcessCompleted (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.OnProcessError Method

WorkspaceOnProcessError Method

Invoked when an error occurs in a separate thread when being processed asynchronously. Fires the ProcessError event.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnProcessError(
    ExceptionEventArgs e
)
Protected Sub OnProcessError (
    e As ExceptionEventArgs
)

Parameters

e
Type: Atalasoft.ImagingExceptionEventArgs
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Open Method

WorkspaceOpen Method

Overload List
 | Name | Description
Public method | Open(Stream) | Decodes an image from a stream and sets it to the current image.
Public method | Open(String) | Decodes an image from a file and sets it to the current image.
Public method | Open(Stream, Int32) | Decodes an image from a stream specifying the frame index of a multipaged file, and sets it to the current image.
Public method | Open(String, Int32) | Decodes an image from a file specifying the frame index of a multipaged file, and sets it to the current image.
Top
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Open Method (Stream)

WorkspaceOpen Method (Stream)

Decodes an image from a stream and sets it to the current image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream
)
Public Sub Open (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
See Also

Reference

Workspace Class
Open Overload
Atalasoft.Imaging Namespace


Workspace.Open Method (String)

WorkspaceOpen Method (String)

Decodes an image from a file and sets it to the current image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName
)
Public Sub Open (
    fileName As String
)

Parameters

fileName
Type: SystemString
The path of the file to open.
Remarks
A URL formatted string can be passed to download a file. If the address is pointing to an FTP site, you may need to include the username and password in the URL to allow access to the file.
See Also

Reference

Workspace Class
Open Overload
Atalasoft.Imaging Namespace


Workspace.Open Method (Stream, Int32)

WorkspaceOpen Method (Stream, Int32)

Decodes an image from a stream specifying the frame index of a multipaged file, and sets it to the current image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to load.
See Also

Reference

Workspace Class
Open Overload
Atalasoft.Imaging Namespace


Workspace.Open Method (String, Int32)

WorkspaceOpen Method (String, Int32)

Decodes an image from a file specifying the frame index of a multipaged file, and sets it to the current image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The path of the file to open.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to load.
Remarks
Opening an image with this method when the Workspace is in Asynchronous mode will add this operation to the ProcessQueue and open Asynchronously.
See Also

Reference

Workspace Class
Open Overload
Atalasoft.Imaging Namespace


Workspace.Save Method

WorkspaceSave Method

Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder) | Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image.
Public method | Save(String, ImageEncoder) | Writes the current AtalaImage or ImageCollection to a file specifying the ImageEncoder to use to encode the image.
Public method | Save(String, ImageType) | Obsolete. Writes the current AtalaImage or ImageCollection to a file specifying the ImageType to use to encode the image.
Public method | Save(Stream, ImageEncoder, Int32) | Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image and the image index in the collection to save.
Public method | Save(String, ImageEncoder, Int32) | Writes the current %AtalaImage% or %ImageCollection% to a file specifying the ImageEncoder to use to encode the image and the image index in the collection to save.
Top
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Save Method (Stream, ImageEncoder)

WorkspaceSave Method (Stream, ImageEncoder)

Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder
)

Parameters

stream
Type: System.IOStream
A stream containing the file which the current image will be encoded to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
See Also

Reference

Workspace Class
Save Overload
Atalasoft.Imaging Namespace


Workspace.Save Method (String, ImageEncoder)

WorkspaceSave Method (String, ImageEncoder)

Writes the current AtalaImage or ImageCollection to a file specifying the ImageEncoder to use to encode the image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder
)

Parameters

fileName
Type: SystemString
The filename to save the current image to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
Remarks
This method can be used to save an image to an FTP server. If the fileName is pointing to an FTP server, you may need to include the username and password in the URL to allow the file to be saved.
See Also

Reference

Workspace Class
Save Overload
Atalasoft.Imaging Namespace


Workspace.Save Method (String, ImageType)

WorkspaceSave Method (String, ImageType)

Note: This API is now obsolete.

Writes the current AtalaImage or ImageCollection to a file specifying the ImageType to use to encode the image.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)]
public void Save(
    string fileName,
    ImageType imageType
)
<ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)>
Public Sub Save (
    fileName As String,
    imageType As ImageType
)

Parameters

fileName
Type: SystemString
The filename to save the current image to.
imageType
Type: Atalasoft.Imaging.CodecImageType
The image type to save this image as.
Remarks
This method can be used to save an image to an FTP server. If the fileName is pointing to an FTP server, you may need to include the username and password in the URL to allow the file to be saved.
See Also

Reference

Workspace Class
Save Overload
Atalasoft.Imaging Namespace


Workspace.Save Method (Stream, ImageEncoder, Int32)

WorkspaceSave Method (Stream, ImageEncoder, Int32)

Writes the current AtalaImage or ImageCollection to a stream specifying the ImageEncoder to use to encode the image and the image index in the collection to save.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder,
    int frameIndex
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
A stream containing the file which the current image will be encoded to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
frameIndex
Type: SystemInt32
The index in the ImageCollection to save.
See Also

Reference

Workspace Class
Save Overload
Atalasoft.Imaging Namespace


Workspace.Save Method (String, ImageEncoder, Int32)

WorkspaceSave Method (String, ImageEncoder, Int32)

Writes the current %AtalaImage% or %ImageCollection% to a file specifying the ImageEncoder to use to encode the image and the image index in the collection to save.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder,
    int frameIndex
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The filename to save the current image to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder which will be used to encode the image.
frameIndex
Type: SystemInt32
The index in the ImageCollection to save.
Remarks

This method can be used to save an image to an FTP server. If the fileName is pointing to an FTP server, you may need to include the username and password in the URL to allow the file to be saved.

Saving an image with this method when the Workspace is in synchronous mode will add this operation to the ProcessQueue and save Asynchronously.

Remarks
Saving an image with this method when the Workspace is in %Asynchronous% mode will add this operation to the %ProcessQueue% and save Asynchronously.
See Also

Reference

Workspace Class
Save Overload
Atalasoft.Imaging Namespace


Workspace Events

The Workspace type exposes the following members.

Events
 | Name | Description
Public event | DisposeImage | Fired when an image in the ImageCollection or UndoCollection is disposed.
Public event | ImageChanged | Occurs when the current image in the ImageCollection changes.
Public event | ImageStreamCompleted | Fires after an image has been read or saved signifying that the Stream which was passed in can be closed.
Public event | ProcessCompleted | Fires when an asynchronous process has completed.
Public event | ProcessError | Fires when an error occurs in a separate thread when being processed asynchronously.
Public event | Progress | Fires while an image is being processed.
Top
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.DisposeImage Event

WorkspaceDisposeImage Event

Fired when an image in the ImageCollection or UndoCollection is disposed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageCancelEventHandler DisposeImage
Public Event DisposeImage As ImageCancelEventHandler

Value

Type: Atalasoft.ImagingImageCancelEventHandler
Remarks
This even should be handled if images are being shared. If this event contains an image that shouldn't be disposed, set the Cancel property to true.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.ImageChanged Event

WorkspaceImageChanged Event

Occurs when the current image in the ImageCollection changes.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageEventHandler ImageChanged
Public Event ImageChanged As ImageEventHandler

Value

Type: Atalasoft.ImagingImageEventHandler
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.ImageStreamCompleted Event

WorkspaceImageStreamCompleted Event

Fires after an image has been read or saved signifying that the Stream which was passed in can be closed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageFileIOEventHandler ImageStreamCompleted
Public Event ImageStreamCompleted As ImageFileIOEventHandler

Value

Type: Atalasoft.ImagingImageFileIOEventHandler
Remarks
This event only fires if the stream was created outside dotImage.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.ProcessCompleted Event

WorkspaceProcessCompleted Event

Fires when an asynchronous process has completed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageEventHandler ProcessCompleted
Public Event ProcessCompleted As ImageEventHandler

Value

Type: Atalasoft.ImagingImageEventHandler
Remarks
This is fired when processing commands, opening, or saving images.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.ProcessError Event

WorkspaceProcessError Event

Fires when an error occurs in a separate thread when being processed asynchronously.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ExceptionEventHandler ProcessError
Public Event ProcessError As ExceptionEventHandler

Value

Type: Atalasoft.ImagingExceptionEventHandler
Remarks
This event can be handled to react to an exception when it occurs in another thread. Typically a message box with exception details is displayed to the user. When this event is not handled, and the Asynchronous property is true, errors can go un-noticed, and without any error messages displayed.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Workspace.Progress Event

WorkspaceProgress Event

Fires while an image is being processed.

Namespace: Atalasoft.Imaging
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ProgressEventHandler Progress
Public Event Progress As ProgressEventHandler

Value

Type: Atalasoft.ImagingProgressEventHandler
Remarks
Handle this event to show a progress bar or to cancel an operation while in progress. Some operations will fire this event from 0 - 100% multiple times.
See Also

Reference

Workspace Class
Atalasoft.Imaging Namespace


Atalasoft.Imaging.Codec Namespace

Classes
 | Class | Description
Public class | AsTiff |
Public class | AsTiffPageInfo |
Public class | BmpDecoder | An ImageDecoder used to read Windows Bitmap (BMP) images from a Stream.
 | BmpEncoder | An ImageEncoder that will write Windows Bitmap (BMP) images to a Stream.
Public class | CameraInfo | Stores detailed camera information such as make, model, and data size.
Public class | CodecCompression | Derive from this class for any codec's specific compression type.
Public class | CodecErrorEventArgs | This class is used for encapsulating errors encountered while encoding or decoding image files.
Public class | CodecException | This exception is thrown when there is an error in the codec (decoder or encoder).
Public class | DecoderCollection | A collection of ImageDecoder.
Public class | DecoderDictionary | A dictionary of ImageDecoder objects.
Public class | EmfDecoder | An ImageDecoder used to read Enhanced Metafiles (EMF) images from a Stream.
Public class | EmfEncoder | Summary description for EmfEncoder.
Public class | EncoderCompressionEventArgs | This object is used for events fired by an MultiFramedImageEncoder when requesting a compression type.
Public class | EpsEncoder | An ImageEncoder that will write Adobe Encapsulated PostScript images to a Stream.
 | GifDecoder | An ImageDecoder used to read Compuserve Graphics Interchange (GIF) images from a Stream.
 | GifEncoder | An ImageEncoder that will write Compuserve Graphics Interchange (GIF) images to a Stream.
Public class | GifFrame | The GifFrame class holds information about a single frame in an animated GIF file.
Public class | GifFrameCollection | The GifFrameCollection class represents an animated GIF file. It contains all of the frames and properties for the animation.
Public class | GifImageInfo | Summary description for PngImageInfo.
Public class | HeifDecoder | Decoder for HEIF files.
 | ImageDecoder | An abstract (MustInherit in Visual Basic) base class that defines a file format decoder to read an image from a Stream. All image decoders used in dotImage must inherit this class.
Public class | ImageEncoder | An abstract (MustInherit in Visual Basic) base class that defines a file format encoder to save an image to a file. All image encoders used in dotImage must inherit this class.
Public class | ImageInfo | Contains information from an encoded image file.
Public class | ImageReadException | This exception is thrown when there is a problem reading an image
Public class | ImageWriteException | This exception is thrown when there is a problem writing an image
Public class | JpegDecoder | An ImageDecoder used to read JPEG images from a Stream.
Public class | JpegEncoder | An ImageEncoder that will write JPEG images to a Stream.
Public class | JpegImageInfo | Summary description for JpegImageInfo.
Public class | JpegXrDecoder | The JpegXrDecoder class is a decoder for Microsoft Windows Media Photo encoded images.
Public class | JpegXrEncoder | The JpegXrEncoder class is an encoder that is used to encode an AtalaImage to Microsoft Windows Media Photo images.
Public class | LibRawException | This exception is thrown when there is a problem reading an image by LibRaw library.
Public class | LzwNotLicensedException | This exception is fired when LZW is not licensed yet an attempt is made to use LZW functionality.
Public class | MultiFramedImageDecoder | A decoder for multiframed images such as multiple page TIFF's and animiated GIF's.
Public class | MultiFramedImageEncoder | An encoder for multiframed formats such as PDF and animated GIF's.
Public class | PcdDecoder | An ImageDecoder used to read Kodak Photo CD (PCD) images from a Stream.
Public class | PcxDecoder | An ImageDecoder used to read Zsoft Paintbrush (PCX) images from a %System.IO.Stream%.
Public class | PcxEncoder | An ImageEncoder that will write ZSoft Paintbrush (PCX) images to a %System.IO.Stream%.
Public class | PngDecoder | An ImageDecoder used to read Portable Network Graphics (PNG) images from a Stream.
Public class | PngEncoder | An ImageEncoder that will write Portable Network Graphics (PNG) images to a Stream.
Public class | PngImageInfo | Summary description for PngImageInfo.
Public class | PnmDecoder | An ImageDecoder used to read PNM/PBM/PGM/PPM images from a Stream.
Public class | PnmEncoder | Encodes an AtalaImage into a PNM image file.
Public class | PnmImageInfo | Information about a PNM Image.
Public class | PsdDecoder | An ImageDecoder used to read Adobe Photoshop (PSD) images from a Stream.
Public class | PsdEncoder | An ImageEncoder that will write Adobe Photoshop (PSD) images to a Stream.
Public class | RawDecoder | Decoder for Digital Camera RAW Format Images.
Public class | RawImageInfo |
Public class | RegisteredDecoders | This class includes static members containing information on image decoders to use in the project when reading images as well as methods to obtain a an appropriate decoder based on an image stream or filename.
Public class | TgaDecoder | An ImageDecoder used to read Truevision Targa (TGA) images from a Stream.
Public class | TgaEncoder | Summary description for TgaEncoder.
Public class | TiffCodecCompression | This class represents the compression for a TIFF image.
 | TiffDecoder | An ImageDecoder used to read Tagged Image File Format (TIFF) images from an image Stream.
 | TiffEncoder | An ImageEncoder that will write Tagged Image File Format (TIFF) images to a Stream.
Public class | TlaDecoder | An ImageDecoder used to read Tla images from a Stream.
Public class | TlaEncoder | An ImageEncoder that will write TLA images to a %System.IO.Stream%.
Public class | WbmpDecoder | An ImageDecoder used to read Wireless Bitmap (Wbmp) images from a Stream.
Public class | WbmpEncoder | An ImageEncoder that will write Wireless Bitmap (WBMP) images to a Stream.
Public class | WmfDecoder | An ImageDecoder used to read Windows Metafile (WMF) images from a Stream.
Public class | WmfEncoder | An ImageEncoder that will write Windows Metafile (WMF) images to a Stream.
Public class | XpsDecoder | Decodes an XPS document into an AtalaImage object.
Interfaces
 | Interface | Description
Public interface | IAnnotationEncoder | Used with encoders that support saving XMP data.
Public interface | IAppendable | An interface that an ImageEncoder can implement when it supports appending an image to the end of an existing file.
Public interface | IMultiFramedVectorDecoder | Represents a codec that specializes in decoding a vector image file that can have multiple pages.
Public interface | IRegionReadable | This interface is applied to ImageDecoders to enable them to read a specified region of the image without decoding the entire image.
Public interface | IScaledDecoder | This interface is applied to ImageDecoders that have the ability to decode an image stream to a specified scale.
Public interface | IVectorDecoder | Represents a codec that specializes in decoding a vector image file.
Delegates
 | Delegate | Description
Public delegate | AsTiffAsTiffProgressDelegate |
Public delegate | CodecErrorEventHandler | Event handler when errors occur when reading images.
Public delegate | EncoderCompressionEventHandler | Event handler used when specifying compression in the MultiFramedImageEncoder.
Enumerations
 | Enumeration | Description
Public enumeration | AsTiffInternalTiffCompression |
Public enumeration | AsTiffStreamOpenMode |
Public enumeration | BmpCompression | Contains the various compression types available for Bmp images.
Public enumeration | ErrorLevel |
Public enumeration | GifFrameDisposal | The frame disposal method to use for animated GIF images.
Public enumeration | ImageType | Obsolete. The supported image file formats that dotImage can either read or write.
Public enumeration | JpegDctMode | The DCT compression used when saving a JPEG image.
Public enumeration | JpegScaleFactor | The scaling factor to use when reading a Jpeg image.
Public enumeration | LoadingPolicy | Dictates how safe our raw codec should be when trying to load files.
Public enumeration | PcdResolution | PhotoCD Resolution (image size) to load.
Public enumeration | PnmImageType | The type of Pnm image
Public enumeration | RawColorSpace | (Deprecated) Indicates the color space of the Raw image.
Public enumeration | RawInterpolationMethods | The RAW format has one color per pixel due to BAYER transformation performed inside D.C. RawInterpolationMethod indicates the type of interpolation performed, if any, to transform the image into the desired colorspace.
Public enumeration | RawWhiteBalanceMethods | Indicates the type of white balance correction, if any, to apply.
Public enumeration | TiffCompression | Contains the various compression types available for TIFF images.


AsTiff Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecAsTiff

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AsTiff
Public Class AsTiff

The AsTiff type exposes the following members.

Constructors
 | Name | Description
Public method | AsTiff | Initializes a new instance of the AsTiff class
Top
Methods
 | Name | Description
 | CreateTiffFileReadingObject |
 | CreateTiffFileStructures |
 | CreateTiffStreamReadingObject(IntPtr, AsTiffStreamOpenMode) |
 | CreateTiffStreamReadingObject(IntPtr, AsTiffStreamOpenMode, Boolean) |
 | DestroyTiffFileReadingObject |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllTiffPagesInfo(IntPtr) |
 | GetAllTiffPagesInfo(IntPtr, Boolean) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetImageInfo |
 | GetNewPageIfd |
 | GetPageCount |
 | GetPageIfd |
 | GetTiffBinaryTag |
 | GetTiffTag |
 | GetTileSize(IntPtr, Int32, Int32, Int32) |
 | GetTileSize(IntPtr, IntPtr, Int32, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IfdTagWritingBegin |
 | IfdTagWritingEnd |
 | LoadIntoImage(IntPtr, Int32, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object) |
 | LoadIntoImage(IntPtr, IntPtr, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object) |
 | LoadRegionIntoImage |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetSoftwareString |
 | SetTiffTag(IntPtr, IntPtr, Int32, Double) |
 | SetTiffTag(IntPtr, IntPtr, Int32, Single) |
 | SetTiffTag(IntPtr, IntPtr, Int32, String) |
 | SetTiffTag(IntPtr, IntPtr, Int32, Int32, Int32) |
 | SetTiffTag(IntPtr, IntPtr, Int32, Int64, Int32, Boolean) |
 | SetTiffTagBytes(IntPtr, IntPtr, Int32, IntPtr, Int32, Boolean) |
 | SetTiffTagBytes(IntPtr, IntPtr, Int32, IntPtr, Int32, Int32, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteImageToIfd |
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


AsTiff Constructor

Initializes a new instance of the AsTiff class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AsTiff()
Public Sub New
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff Methods

The AsTiff type exposes the following members.

Methods
 | Name | Description
 | CreateTiffFileReadingObject |
 | CreateTiffFileStructures |
 | CreateTiffStreamReadingObject(IntPtr, AsTiffStreamOpenMode) |
 | CreateTiffStreamReadingObject(IntPtr, AsTiffStreamOpenMode, Boolean) |
 | DestroyTiffFileReadingObject |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllTiffPagesInfo(IntPtr) |
 | GetAllTiffPagesInfo(IntPtr, Boolean) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetImageInfo |
 | GetNewPageIfd |
 | GetPageCount |
 | GetPageIfd |
 | GetTiffBinaryTag |
 | GetTiffTag |
 | GetTileSize(IntPtr, Int32, Int32, Int32) |
 | GetTileSize(IntPtr, IntPtr, Int32, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IfdTagWritingBegin |
 | IfdTagWritingEnd |
 | LoadIntoImage(IntPtr, Int32, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object) |
 | LoadIntoImage(IntPtr, IntPtr, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object) |
 | LoadRegionIntoImage |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetSoftwareString |
 | SetTiffTag(IntPtr, IntPtr, Int32, Double) |
 | SetTiffTag(IntPtr, IntPtr, Int32, Single) |
 | SetTiffTag(IntPtr, IntPtr, Int32, String) |
 | SetTiffTag(IntPtr, IntPtr, Int32, Int32, Int32) |
 | SetTiffTag(IntPtr, IntPtr, Int32, Int64, Int32, Boolean) |
 | SetTiffTagBytes(IntPtr, IntPtr, Int32, IntPtr, Int32, Boolean) |
 | SetTiffTagBytes(IntPtr, IntPtr, Int32, IntPtr, Int32, Int32, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteImageToIfd |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.CreateTiffFileReadingObject Method

AsTiffCreateTiffFileReadingObject Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr CreateTiffFileReadingObject(
    string fileName
)
Public Shared Function CreateTiffFileReadingObject (
    fileName As String
) As IntPtr

Parameters

fileName
Type: SystemString

Return Value

Type: IntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.CreateTiffFileStructures Method

AsTiffCreateTiffFileStructures Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void CreateTiffFileStructures(
    IntPtr p
)
Public Shared Sub CreateTiffFileStructures (
    p As IntPtr
)

Parameters

p
Type: SystemIntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.CreateTiffStreamReadingObject Method

AsTiffCreateTiffStreamReadingObject Method

Overload List
Name | Description
CreateTiffStreamReadingObject(IntPtr, AsTiffStreamOpenMode) |
CreateTiffStreamReadingObject(IntPtr, AsTiffStreamOpenMode, Boolean) |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.CreateTiffStreamReadingObject Method (IntPtr, AsTiff.StreamOpenMode)

AsTiffCreateTiffStreamReadingObject Method (IntPtr, AsTiffStreamOpenMode)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr CreateTiffStreamReadingObject(
    IntPtr streamHandle,
    AsTiffStreamOpenMode openMode
)
Public Shared Function CreateTiffStreamReadingObject (
    streamHandle As IntPtr,
    openMode As AsTiffStreamOpenMode
) As IntPtr

Parameters

streamHandle
Type: SystemIntPtr
openMode
Type: Atalasoft.Imaging.CodecAsTiffStreamOpenMode

Return Value

Type: IntPtr
See Also

Reference

AsTiff Class
CreateTiffStreamReadingObject Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.CreateTiffStreamReadingObject Method (IntPtr, AsTiff.StreamOpenMode, Boolean)

AsTiffCreateTiffStreamReadingObject Method (IntPtr, AsTiffStreamOpenMode, Boolean)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr CreateTiffStreamReadingObject(
    IntPtr streamHandle,
    AsTiffStreamOpenMode openMode,
    bool accelerate
)
Public Shared Function CreateTiffStreamReadingObject (
    streamHandle As IntPtr,
    openMode As AsTiffStreamOpenMode,
    accelerate As Boolean
) As IntPtr

Parameters

streamHandle
Type: SystemIntPtr
openMode
Type: Atalasoft.Imaging.CodecAsTiffStreamOpenMode
accelerate
Type: SystemBoolean

Return Value

Type: IntPtr
See Also

Reference

AsTiff Class
CreateTiffStreamReadingObject Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.DestroyTiffFileReadingObject Method

AsTiffDestroyTiffFileReadingObject Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void DestroyTiffFileReadingObject(
    IntPtr p
)
Public Shared Sub DestroyTiffFileReadingObject (
    p As IntPtr
)

Parameters

p
Type: SystemIntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetAllTiffPagesInfo Method

AsTiffGetAllTiffPagesInfo Method

Overload List
Name | Description
GetAllTiffPagesInfo(IntPtr) |
GetAllTiffPagesInfo(IntPtr, Boolean) |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetAllTiffPagesInfo Method (IntPtr)

AsTiffGetAllTiffPagesInfo Method (IntPtr)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ArrayList GetAllTiffPagesInfo(
    IntPtr p
)
Public Shared Function GetAllTiffPagesInfo (
    p As IntPtr
) As ArrayList

Parameters

p
Type: SystemIntPtr

Return Value

Type: ArrayList
See Also

Reference

AsTiff Class
GetAllTiffPagesInfo Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.GetAllTiffPagesInfo Method (IntPtr, Boolean)

AsTiffGetAllTiffPagesInfo Method (IntPtr, Boolean)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ArrayList GetAllTiffPagesInfo(
    IntPtr p,
    bool tolerateBadTiffStructure
)
Public Shared Function GetAllTiffPagesInfo (
    p As IntPtr,
    tolerateBadTiffStructure As Boolean
) As ArrayList

Parameters

p
Type: SystemIntPtr
tolerateBadTiffStructure
Type: SystemBoolean

Return Value

Type: ArrayList
See Also

Reference

AsTiff Class
GetAllTiffPagesInfo Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.GetImageInfo Method

AsTiffGetImageInfo Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void GetImageInfo(
    IntPtr p,
    int frame,
    out int w,
    out int h,
    out int colorDepth,
    out int internalPixelFormat,
    out int internalResUnit,
    out double xres,
    out double yres,
    out int frameCount,
    out IntPtr palettePtr,
    out int paletteCount,
    out int orientation
)
Public Shared Sub GetImageInfo (
    p As IntPtr,
    frame As Integer,
    <OutAttribute> ByRef w As Integer,
    <OutAttribute> ByRef h As Integer,
    <OutAttribute> ByRef colorDepth As Integer,
    <OutAttribute> ByRef internalPixelFormat As Integer,
    <OutAttribute> ByRef internalResUnit As Integer,
    <OutAttribute> ByRef xres As Double,
    <OutAttribute> ByRef yres As Double,
    <OutAttribute> ByRef frameCount As Integer,
    <OutAttribute> ByRef palettePtr As IntPtr,
    <OutAttribute> ByRef paletteCount As Integer,
    <OutAttribute> ByRef orientation As Integer
)

Parameters

p
Type: SystemIntPtr
frame
Type: SystemInt32
w
Type: SystemInt32
h
Type: SystemInt32
colorDepth
Type: SystemInt32
internalPixelFormat
Type: SystemInt32
internalResUnit
Type: SystemInt32
xres
Type: SystemDouble
yres
Type: SystemDouble
frameCount
Type: SystemInt32
palettePtr
Type: SystemIntPtr
paletteCount
Type: SystemInt32
orientation
Type: SystemInt32
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetNewPageIfd Method

AsTiffGetNewPageIfd Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr GetNewPageIfd(
    IntPtr p
)
Public Shared Function GetNewPageIfd (
    p As IntPtr
) As IntPtr

Parameters

p
Type: SystemIntPtr

Return Value

Type: IntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetPageCount Method

AsTiffGetPageCount Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetPageCount(
    IntPtr p
)
Public Shared Function GetPageCount (
    p As IntPtr
) As Integer

Parameters

p
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetPageIfd Method

AsTiffGetPageIfd Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr GetPageIfd(
    IntPtr p,
    int frame
)
Public Shared Function GetPageIfd (
    p As IntPtr,
    frame As Integer
) As IntPtr

Parameters

p
Type: SystemIntPtr
frame
Type: SystemInt32

Return Value

Type: IntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetTiffBinaryTag Method

AsTiffGetTiffBinaryTag Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static byte[] GetTiffBinaryTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID
)
Public Shared Function GetTiffBinaryTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer
) As Byte()

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32

Return Value

Type: Byte
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetTiffTag Method

AsTiffGetTiffTag Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Object GetTiffTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    out int pRetval
)
Public Shared Function GetTiffTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    <OutAttribute> ByRef pRetval As Integer
) As Object

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
pRetval
Type: SystemInt32

Return Value

Type: Object
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetTileSize Method

AsTiffGetTileSize Method

Overload List
Name | Description
GetTileSize(IntPtr, Int32, Int32, Int32) |
GetTileSize(IntPtr, IntPtr, Int32, Int32) |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.GetTileSize Method (IntPtr, Int32, Int32, Int32)

AsTiffGetTileSize Method (IntPtr, Int32, Int32, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void GetTileSize(
    IntPtr p,
    int frame,
    out int width,
    out int height
)
Public Shared Sub GetTileSize (
    p As IntPtr,
    frame As Integer,
    <OutAttribute> ByRef width As Integer,
    <OutAttribute> ByRef height As Integer
)

Parameters

p
Type: SystemIntPtr
frame
Type: SystemInt32
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

AsTiff Class
GetTileSize Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.GetTileSize Method (IntPtr, IntPtr, Int32, Int32)

AsTiffGetTileSize Method (IntPtr, IntPtr, Int32, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void GetTileSize(
    IntPtr p,
    IntPtr ifdPtr,
    out int width,
    out int height
)
Public Shared Sub GetTileSize (
    p As IntPtr,
    ifdPtr As IntPtr,
    <OutAttribute> ByRef width As Integer,
    <OutAttribute> ByRef height As Integer
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

AsTiff Class
GetTileSize Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.IfdTagWritingBegin Method

AsTiffIfdTagWritingBegin Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void IfdTagWritingBegin(
    IntPtr p,
    IntPtr ifdPtr
)
Public Shared Sub IfdTagWritingBegin (
    p As IntPtr,
    ifdPtr As IntPtr
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.IfdTagWritingEnd Method

AsTiffIfdTagWritingEnd Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void IfdTagWritingEnd(
    IntPtr p,
    IntPtr ifdPtr
)
Public Shared Sub IfdTagWritingEnd (
    p As IntPtr,
    ifdPtr As IntPtr
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.LoadIntoImage Method

AsTiffLoadIntoImage Method

Overload List
Name | Description
LoadIntoImage(IntPtr, Int32, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object) |
LoadIntoImage(IntPtr, IntPtr, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object) |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.LoadIntoImage Method (IntPtr, Int32, IntPtr, Int32, Int32, Int32, AsTiff.AsTiffProgressDelegate, Object)

AsTiffLoadIntoImage Method (IntPtr, Int32, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void LoadIntoImage(
    IntPtr p,
    int frame,
    IntPtr imagePtr,
    int rowstride,
    int unpaddedStride,
    int height,
    AsTiffAsTiffProgressDelegate progress,
    Object userObject
)
Public Shared Sub LoadIntoImage (
    p As IntPtr,
    frame As Integer,
    imagePtr As IntPtr,
    rowstride As Integer,
    unpaddedStride As Integer,
    height As Integer,
    progress As AsTiffAsTiffProgressDelegate,
    userObject As Object
)

Parameters

p
Type: SystemIntPtr
frame
Type: SystemInt32
imagePtr
Type: SystemIntPtr
rowstride
Type: SystemInt32
unpaddedStride
Type: SystemInt32
height
Type: SystemInt32
progress
Type: Atalasoft.Imaging.CodecAsTiffAsTiffProgressDelegate
userObject
Type: SystemObject
See Also

Reference

AsTiff Class
LoadIntoImage Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.LoadIntoImage Method (IntPtr, IntPtr, IntPtr, Int32, Int32, Int32, AsTiff.AsTiffProgressDelegate, Object)

AsTiffLoadIntoImage Method (IntPtr, IntPtr, IntPtr, Int32, Int32, Int32, AsTiffAsTiffProgressDelegate, Object)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void LoadIntoImage(
    IntPtr p,
    IntPtr ifdPtr,
    IntPtr imagePtr,
    int rowstride,
    int unpaddedStride,
    int height,
    AsTiffAsTiffProgressDelegate progress,
    Object userObject
)
Public Shared Sub LoadIntoImage (
    p As IntPtr,
    ifdPtr As IntPtr,
    imagePtr As IntPtr,
    rowstride As Integer,
    unpaddedStride As Integer,
    height As Integer,
    progress As AsTiffAsTiffProgressDelegate,
    userObject As Object
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
imagePtr
Type: SystemIntPtr
rowstride
Type: SystemInt32
unpaddedStride
Type: SystemInt32
height
Type: SystemInt32
progress
Type: Atalasoft.Imaging.CodecAsTiffAsTiffProgressDelegate
userObject
Type: SystemObject
See Also

Reference

AsTiff Class
LoadIntoImage Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.LoadRegionIntoImage Method

AsTiffLoadRegionIntoImage Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void LoadRegionIntoImage(
    IntPtr p,
    IntPtr ifdPtr,
    int leftStrile,
    int topStrile,
    int strilesWidth,
    int strilesHeight,
    IntPtr imagePtr,
    int rowstride,
    int unpaddedStride,
    int rowsToSkip,
    int height,
    AsTiffAsTiffProgressDelegate progress,
    Object userObject
)
Public Shared Sub LoadRegionIntoImage (
    p As IntPtr,
    ifdPtr As IntPtr,
    leftStrile As Integer,
    topStrile As Integer,
    strilesWidth As Integer,
    strilesHeight As Integer,
    imagePtr As IntPtr,
    rowstride As Integer,
    unpaddedStride As Integer,
    rowsToSkip As Integer,
    height As Integer,
    progress As AsTiffAsTiffProgressDelegate,
    userObject As Object
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
leftStrile
Type: SystemInt32
topStrile
Type: SystemInt32
strilesWidth
Type: SystemInt32
strilesHeight
Type: SystemInt32
imagePtr
Type: SystemIntPtr
rowstride
Type: SystemInt32
unpaddedStride
Type: SystemInt32
rowsToSkip
Type: SystemInt32
height
Type: SystemInt32
progress
Type: Atalasoft.Imaging.CodecAsTiffAsTiffProgressDelegate
userObject
Type: SystemObject
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.SetSoftwareString Method

AsTiffSetSoftwareString Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetSoftwareString(
    IntPtr p,
    IntPtr ifdPtr,
    string softwareString
)
Public Shared Sub SetSoftwareString (
    p As IntPtr,
    ifdPtr As IntPtr,
    softwareString As String
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
softwareString
Type: SystemString
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTag Method

AsTiffSetTiffTag Method

Overload List
Name | Description
SetTiffTag(IntPtr, IntPtr, Int32, Double) |
SetTiffTag(IntPtr, IntPtr, Int32, Single) |
SetTiffTag(IntPtr, IntPtr, Int32, String) |
SetTiffTag(IntPtr, IntPtr, Int32, Int32, Int32) |
SetTiffTag(IntPtr, IntPtr, Int32, Int64, Int32, Boolean) |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTag Method (IntPtr, IntPtr, Int32, Double)

AsTiffSetTiffTag Method (IntPtr, IntPtr, Int32, Double)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    double value
)
Public Shared Sub SetTiffTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    value As Double
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
value
Type: SystemDouble
See Also

Reference

AsTiff Class
SetTiffTag Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTag Method (IntPtr, IntPtr, Int32, Single)

AsTiffSetTiffTag Method (IntPtr, IntPtr, Int32, Single)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    float value
)
Public Shared Sub SetTiffTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    value As Single
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
value
Type: SystemSingle
See Also

Reference

AsTiff Class
SetTiffTag Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTag Method (IntPtr, IntPtr, Int32, String)

AsTiffSetTiffTag Method (IntPtr, IntPtr, Int32, String)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    string s
)
Public Shared Sub SetTiffTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    s As String
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
s
Type: SystemString
See Also

Reference

AsTiff Class
SetTiffTag Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTag Method (IntPtr, IntPtr, Int32, Int32, Int32)

AsTiffSetTiffTag Method (IntPtr, IntPtr, Int32, Int32, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    int numerator,
    int denominator
)
Public Shared Sub SetTiffTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    numerator As Integer,
    denominator As Integer
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
numerator
Type: SystemInt32
denominator
Type: SystemInt32
See Also

Reference

AsTiff Class
SetTiffTag Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTag Method (IntPtr, IntPtr, Int32, Int64, Int32, Boolean)

AsTiffSetTiffTag Method (IntPtr, IntPtr, Int32, Int64, Int32, Boolean)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTag(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    long data,
    int sizeInBytes,
    bool isSigned
)
Public Shared Sub SetTiffTag (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    data As Long,
    sizeInBytes As Integer,
    isSigned As Boolean
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
data
Type: SystemInt64
sizeInBytes
Type: SystemInt32
isSigned
Type: SystemBoolean
See Also

Reference

AsTiff Class
SetTiffTag Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTagBytes Method

AsTiffSetTiffTagBytes Method

Overload List
Name | Description
SetTiffTagBytes(IntPtr, IntPtr, Int32, IntPtr, Int32, Boolean) |
SetTiffTagBytes(IntPtr, IntPtr, Int32, IntPtr, Int32, Int32, Boolean) |
Top
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTagBytes Method (IntPtr, IntPtr, Int32, IntPtr, Int32, Boolean)

AsTiffSetTiffTagBytes Method (IntPtr, IntPtr, Int32, IntPtr, Int32, Boolean)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTagBytes(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    IntPtr data,
    int length,
    bool isSigned
)
Public Shared Sub SetTiffTagBytes (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    data As IntPtr,
    length As Integer,
    isSigned As Boolean
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
data
Type: SystemIntPtr
length
Type: SystemInt32
isSigned
Type: SystemBoolean
See Also

Reference

AsTiff Class
SetTiffTagBytes Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.SetTiffTagBytes Method (IntPtr, IntPtr, Int32, IntPtr, Int32, Int32, Boolean)

AsTiffSetTiffTagBytes Method (IntPtr, IntPtr, Int32, IntPtr, Int32, Int32, Boolean)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void SetTiffTagBytes(
    IntPtr p,
    IntPtr ifdPtr,
    int tagID,
    IntPtr data,
    int length,
    int dataSize,
    bool isSigned
)
Public Shared Sub SetTiffTagBytes (
    p As IntPtr,
    ifdPtr As IntPtr,
    tagID As Integer,
    data As IntPtr,
    length As Integer,
    dataSize As Integer,
    isSigned As Boolean
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
tagID
Type: SystemInt32
data
Type: SystemIntPtr
length
Type: SystemInt32
dataSize
Type: SystemInt32
isSigned
Type: SystemBoolean
See Also

Reference

AsTiff Class
SetTiffTagBytes Overload
Atalasoft.Imaging.Codec Namespace


AsTiff.WriteImageToIfd Method

AsTiffWriteImageToIfd Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void WriteImageToIfd(
    IntPtr p,
    IntPtr ifdPtr,
    IntPtr imagePtr,
    int width,
    int height,
    int resolutionUnits,
    double resx,
    double resy,
    int bitsPerPixel,
    int rowstride,
    int unpaddedStride,
    int colorspaceId,
    int paletteSize,
    IntPtr palettePtr,
    int tileWidth,
    int tileHeight,
    AsTiffInternalTiffCompression compression,
    bool useLzwPredictor,
    int jpegQuality
)
Public Shared Sub WriteImageToIfd (
    p As IntPtr,
    ifdPtr As IntPtr,
    imagePtr As IntPtr,
    width As Integer,
    height As Integer,
    resolutionUnits As Integer,
    resx As Double,
    resy As Double,
    bitsPerPixel As Integer,
    rowstride As Integer,
    unpaddedStride As Integer,
    colorspaceId As Integer,
    paletteSize As Integer,
    palettePtr As IntPtr,
    tileWidth As Integer,
    tileHeight As Integer,
    compression As AsTiffInternalTiffCompression,
    useLzwPredictor As Boolean,
    jpegQuality As Integer
)

Parameters

p
Type: SystemIntPtr
ifdPtr
Type: SystemIntPtr
imagePtr
Type: SystemIntPtr
width
Type: SystemInt32
height
Type: SystemInt32
resolutionUnits
Type: SystemInt32
resx
Type: SystemDouble
resy
Type: SystemDouble
bitsPerPixel
Type: SystemInt32
rowstride
Type: SystemInt32
unpaddedStride
Type: SystemInt32
colorspaceId
Type: SystemInt32
paletteSize
Type: SystemInt32
palettePtr
Type: SystemIntPtr
tileWidth
Type: SystemInt32
tileHeight
Type: SystemInt32
compression
Type: Atalasoft.Imaging.CodecAsTiffInternalTiffCompression
useLzwPredictor
Type: SystemBoolean
jpegQuality
Type: SystemInt32
See Also

Reference

AsTiff Class
Atalasoft.Imaging.Codec Namespace


AsTiff.AsTiffProgressDelegate Delegate

AsTiffAsTiffProgressDelegate Delegate

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AsTiffProgressDelegate(
    int current,
    int total,
    Object userObject
)
Public Delegate Sub AsTiffProgressDelegate (
    current As Integer,
    total As Integer,
    userObject As Object
)

Parameters

current
Type: SystemInt32
total
Type: SystemInt32
userObject
Type: SystemObject
See Also

Reference

Atalasoft.Imaging.Codec Namespace


AsTiff.InternalTiffCompression Enumeration

AsTiffInternalTiffCompression Enumeration

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum InternalTiffCompression
Public Enumeration InternalTiffCompression
Members
Member name | Description
None |
CcittRle |
CcittRleW |
CcittT4 |
CcittT6 |
Lzw |
Jpeg |
Packbits |
Flate |
OldJpeg |
See Also

Reference

Atalasoft.Imaging.Codec Namespace


AsTiff.StreamOpenMode Enumeration

AsTiffStreamOpenMode Enumeration

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum StreamOpenMode
Public Enumeration StreamOpenMode
Members
Member name | Description
New |
Readonly |
Update |
See Also

Reference

Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecAsTiffPageInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AsTiffPageInfo
Public Class AsTiffPageInfo

The AsTiffPageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | AsTiffPageInfo | Initializes a new instance of the AsTiffPageInfo class
Top
Properties
 | Name | Description
Public property | Height |
Public property | InternalPixelFormat |
Public property | InternalUnits |
Public property | Width |
Public property | XRes |
Public property | YRes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo Constructor

Initializes a new instance of the AsTiffPageInfo class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AsTiffPageInfo(
    int width,
    int height,
    int internalPixelFormat,
    double xres,
    double yres,
    int internalUnits
)
Public Sub New (
    width As Integer,
    height As Integer,
    internalPixelFormat As Integer,
    xres As Double,
    yres As Double,
    internalUnits As Integer
)

Parameters

width
Type: SystemInt32
height
Type: SystemInt32
internalPixelFormat
Type: SystemInt32
xres
Type: SystemDouble
yres
Type: SystemDouble
internalUnits
Type: SystemInt32
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo Properties

The AsTiffPageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | InternalPixelFormat |
Public property | InternalUnits |
Public property | Width |
Public property | XRes |
Public property | YRes |
Top
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo.Height Property

AsTiffPageInfoHeight Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo.InternalPixelFormat Property

AsTiffPageInfoInternalPixelFormat Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InternalPixelFormat { get; }
Public ReadOnly Property InternalPixelFormat As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo.InternalUnits Property

AsTiffPageInfoInternalUnits Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InternalUnits { get; }
Public ReadOnly Property InternalUnits As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo.Width Property

AsTiffPageInfoWidth Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo.XRes Property

AsTiffPageInfoXRes Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double XRes { get; }
Public ReadOnly Property XRes As Double
    Get

Property Value

Type: Double
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo.YRes Property

AsTiffPageInfoYRes Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double YRes { get; }
Public ReadOnly Property YRes As Double
    Get

Property Value

Type: Double
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


AsTiffPageInfo Methods

The AsTiffPageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AsTiffPageInfo Class
Atalasoft.Imaging.Codec Namespace


BmpCompression Enumeration

Contains the various compression types available for Bmp images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BmpCompression
Public Enumeration BmpCompression
Members
Member name | Description
None | No compression.
Rle | Run Length Compression, only valid for 8-bit image saves.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


BmpDecoder Class

An ImageDecoder used to read Windows Bitmap (BMP) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecBmpDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BmpDecoder : ImageDecoder
Public Class BmpDecoder
    Inherits ImageDecoder

The BmpDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | BmpDecoder | Initializes a new instance of a %BmpDecoder%.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Bmp ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Bmp image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Bmp image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an %AtalaImage% from a Stream containing a Bmp encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
By default, when opening a Bmp image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the %RegisteredDecoders% and does not have to be explicitly set.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


BmpDecoder Constructor

Initializes a new instance of a %BmpDecoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BmpDecoder()
Public Sub New
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpDecoder Properties

The BmpDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Bmp ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpDecoder.SupportedImageType Property

BmpDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Bmp ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
A Bmp ImageType enumeration value.

Property Value

Type: ImageType
ImageType.Bmp
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpDecoder Methods

The BmpDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Bmp image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Bmp image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an %AtalaImage% from a Stream containing a Bmp encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpDecoder.GetImageInfo Method

BmpDecoderGetImageInfo Method

Retreive information from a Bmp image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpDecoder.IsValidFormat Method

BmpDecoderIsValidFormat Method

Returns true if the specified Stream contains a Bmp image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpDecoder.Read Method

BmpDecoderRead Method

Returns an %AtalaImage% from a Stream containing a Bmp encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the image data.
See Also

Reference

BmpDecoder Class
Atalasoft.Imaging.Codec Namespace


BmpEncoder Class

An ImageEncoder that will write Windows Bitmap (BMP) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecBmpEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BmpEncoder : ImageEncoder
Public Class BmpEncoder
    Inherits ImageEncoder

The BmpEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | BmpEncoder | Initializes a new instance of a BmpEncoder.
Public method | BmpEncoder(BmpCompression) | Initializes a new instance of BmpEncoder specifying the compression to use.
Top
Properties
 | Name | Description
Public property | Compression | The compression to use when writing Bmp images.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Bmp image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a BMP image.
Examples

This example demonstrates how to save the current image in a workspace to a Bmp file.

Saving a Bmp Image (Visual Basic)
Copy
myWorkspace.Save("c:\image.bmp", New BmpEncoder())
Saving a Bmp Image (C#)
Copy
myWorkspace.Save("c:\\image.bmp", new BmpEncoder());
See Also

Reference

Atalasoft.Imaging.Codec Namespace


BmpEncoder Constructor

Overload List
 | Name | Description
Public method | BmpEncoder | Initializes a new instance of a BmpEncoder.
Public method | BmpEncoder(BmpCompression) | Initializes a new instance of BmpEncoder specifying the compression to use.
Top
See Also

Reference

BmpEncoder Class
Atalasoft.Imaging.Codec Namespace


BmpEncoder Constructor

Initializes a new instance of a BmpEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BmpEncoder()
Public Sub New
See Also

Reference

BmpEncoder Class
BmpEncoder Overload
Atalasoft.Imaging.Codec Namespace


BmpEncoder Constructor (BmpCompression)

Initializes a new instance of BmpEncoder specifying the compression to use.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BmpEncoder(
    BmpCompression compression
)
Public Sub New (
    compression As BmpCompression
)

Parameters

compression
Type: Atalasoft.Imaging.CodecBmpCompression
The compression to use when writing Bmp images.
See Also

Reference

BmpEncoder Class
BmpEncoder Overload
Atalasoft.Imaging.Codec Namespace


BmpEncoder Properties

The BmpEncoder type exposes the following members.

Properties
 | Name | Description
Public property | Compression | The compression to use when writing Bmp images.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

BmpEncoder Class
Atalasoft.Imaging.Codec Namespace


BmpEncoder.Compression Property

BmpEncoderCompression Property

The compression to use when writing Bmp images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BmpCompression Compression { get; set; }
Public Property Compression As BmpCompression
    Get
    Set

Property Value

Type: BmpCompression
See Also

Reference

BmpEncoder Class
Atalasoft.Imaging.Codec Namespace


BmpEncoder.SupportedPixelFormats Property

BmpEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

BmpEncoder Class
Atalasoft.Imaging.Codec Namespace


BmpEncoder Methods

The BmpEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Bmp image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BmpEncoder Class
Atalasoft.Imaging.Codec Namespace


BmpEncoder.Save Method

BmpEncoderSave Method

Encode an AtalaImage as a Bmp image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

BmpEncoder Class
Atalasoft.Imaging.Codec Namespace


CameraInfo Class

Stores detailed camera information such as make, model, and data size.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecCameraInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CameraInfo
Public Class CameraInfo

The CameraInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CameraInfo | Instantiates a new instance of CameraInfo.
Public method | CameraInfo(String, String, String, String) | Instantiates a new instance of CameraInfo.
Top
Properties
 | Name | Description
Public property | DataSize |
Public property | Make | Gets the camera make.
Public property | Model | Gets the camera model.
Public property | ModelExtended | Gets extended information on the camera model if available.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This information is contained within the [!:RawImageInfo] class from the [!:RawDecoder.GetImageInfo] method of the RawDecoder.
See Also

Reference

Atalasoft.Imaging.Codec Namespace
RawImageInfo Class


CameraInfo Constructor

Instantiates a new instance of CameraInfo.
Overload List
 | Name | Description
Public method | CameraInfo | Instantiates a new instance of CameraInfo.
Public method | CameraInfo(String, String, String, String) | Instantiates a new instance of CameraInfo.
Top
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CameraInfo Constructor

Instantiates a new instance of CameraInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CameraInfo()
Public Sub New
See Also

Reference

CameraInfo Class
CameraInfo Overload
Atalasoft.Imaging.Codec Namespace


CameraInfo Constructor (String, String, String, String)

Instantiates a new instance of CameraInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CameraInfo(
    string make,
    string model,
    string modelExtended,
    string software
)
Public Sub New (
    make As String,
    model As String,
    modelExtended As String,
    software As String
)

Parameters

make
Type: SystemString
camera make
model
Type: SystemString
camera model
modelExtended
Type: SystemString
extended information for the camera model
software
Type: SystemString
See Also

Reference

CameraInfo Class
CameraInfo Overload
Atalasoft.Imaging.Codec Namespace


CameraInfo Properties

The CameraInfo type exposes the following members.

Properties
 | Name | Description
Public property | DataSize |
Public property | Make | Gets the camera make.
Public property | Model | Gets the camera model.
Public property | ModelExtended | Gets extended information on the camera model if available.
Top
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CameraInfo.DataSize Property

CameraInfoDataSize Property

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DataSize { get; set; }
Public Property DataSize As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CameraInfo.Make Property

CameraInfoMake Property

Gets the camera make.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Make { get; set; }
Public Property Make As String
    Get
    Set

Property Value

Type: String
The camera make.
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CameraInfo.Model Property

CameraInfoModel Property

Gets the camera model.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Model { get; set; }
Public Property Model As String
    Get
    Set

Property Value

Type: String
The camera model.
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CameraInfo.ModelExtended Property

CameraInfoModelExtended Property

Gets extended information on the camera model if available.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ModelExtended { get; set; }
Public Property ModelExtended As String
    Get
    Set

Property Value

Type: String
Extended information on the camera model if available.
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CameraInfo Methods

The CameraInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CameraInfo Class
Atalasoft.Imaging.Codec Namespace


CodecCompression Class

Derive from this class for any codec's specific compression type.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecCodecCompression
Atalasoft.Imaging.Codec.PdfPdfCodecCompression
Atalasoft.Imaging.CodecTiffCodecCompression

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class CodecCompression
Public MustInherit Class CodecCompression

The CodecCompression type exposes the following members.

Constructors
 | Name | Description
Protected method | CodecCompression | Initializes a new instance of the CodecCompression class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
For use with the SetEncoderCompression event in MultiFramedImageEncoder.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


CodecCompression Constructor

Initializes a new instance of the CodecCompression class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CodecCompression()
Protected Sub New
See Also

Reference

CodecCompression Class
Atalasoft.Imaging.Codec Namespace


CodecCompression Methods

The CodecCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodecCompression Class
Atalasoft.Imaging.Codec Namespace


CodecErrorEventArgs Class

This class is used for encapsulating errors encountered while encoding or decoding image files.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.CodecCodecErrorEventArgs

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CodecErrorEventArgs : EventArgs
Public Class CodecErrorEventArgs
    Inherits EventArgs

The CodecErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CodecErrorEventArgs | Construct a new set CodecErrorEventArgs object.
Top
Properties
 | Name | Description
Public property | Description | Get the description of the error that has occurred.
Public property | ErrorLevel | Get the severity of the error that has occurred.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


CodecErrorEventArgs Constructor

Construct a new set CodecErrorEventArgs object.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodecErrorEventArgs(
    string description,
    ErrorLevel level
)
Public Sub New (
    description As String,
    level As ErrorLevel
)

Parameters

description
Type: SystemString
A string description of the error that has occurred.
level
Type: Atalasoft.Imaging.CodecErrorLevel
The severity of the error that has occurred.
See Also

Reference

CodecErrorEventArgs Class
Atalasoft.Imaging.Codec Namespace


CodecErrorEventArgs Properties

The CodecErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Description | Get the description of the error that has occurred.
Public property | ErrorLevel | Get the severity of the error that has occurred.
Top
See Also

Reference

CodecErrorEventArgs Class
Atalasoft.Imaging.Codec Namespace


CodecErrorEventArgs.Description Property

CodecErrorEventArgsDescription Property

Get the description of the error that has occurred.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

CodecErrorEventArgs Class
Atalasoft.Imaging.Codec Namespace


CodecErrorEventArgs.ErrorLevel Property

CodecErrorEventArgsErrorLevel Property

Get the severity of the error that has occurred.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ErrorLevel ErrorLevel { get; }
Public ReadOnly Property ErrorLevel As ErrorLevel
    Get

Property Value

Type: ErrorLevel
See Also

Reference

CodecErrorEventArgs Class
Atalasoft.Imaging.Codec Namespace


CodecErrorEventArgs Methods

The CodecErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodecErrorEventArgs Class
Atalasoft.Imaging.Codec Namespace


CodecErrorEventHandler Delegate

Event handler when errors occur when reading images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void CodecErrorEventHandler(
    Object sender,
    CodecErrorEventArgs e
)
Public Delegate Sub CodecErrorEventHandler (
    sender As Object,
    e As CodecErrorEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.CodecCodecErrorEventArgs
See Also

Reference

Atalasoft.Imaging.Codec Namespace


CodecException Class

This exception is thrown when there is an error in the codec (decoder or encoder).
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.CodecCodecException

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CodecException : Exception
<SerializableAttribute>
Public Class CodecException
    Inherits Exception

The CodecException type exposes the following members.

Constructors
 | Name | Description
Public method | CodecException | Creates a new instance of CodecException.
Public method | CodecException(String) | Creates a new instance of CodecException specifying the error message.
Protected method | CodecException(SerializationInfo, StreamingContext) | Initializes a new instance of the CodecException class.
Public method | CodecException(String, Exception) | Creates a new instance of CodecException specifying the error message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


CodecException Constructor

Creates a new instance of CodecException.
Overload List
 | Name | Description
Public method | CodecException | Creates a new instance of CodecException.
Public method | CodecException(String) | Creates a new instance of CodecException specifying the error message.
Protected method | CodecException(SerializationInfo, StreamingContext) | Initializes a new instance of the CodecException class.
Public method | CodecException(String, Exception) | Creates a new instance of CodecException specifying the error message and inner exception.
Top
See Also

Reference

CodecException Class
Atalasoft.Imaging.Codec Namespace


CodecException Constructor

Creates a new instance of CodecException.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodecException()
Public Sub New
See Also

Reference

CodecException Class
CodecException Overload
Atalasoft.Imaging.Codec Namespace


CodecException Constructor (String)

Creates a new instance of CodecException specifying the error message.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodecException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

CodecException Class
CodecException Overload
Atalasoft.Imaging.Codec Namespace


CodecException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the CodecException class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CodecException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

CodecException Class
CodecException Overload
Atalasoft.Imaging.Codec Namespace


CodecException Constructor (String, Exception)

Creates a new instance of CodecException specifying the error message and inner exception.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodecException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

CodecException Class
CodecException Overload
Atalasoft.Imaging.Codec Namespace


CodecException Properties

The CodecException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CodecException Class
Atalasoft.Imaging.Codec Namespace


CodecException Methods

The CodecException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CodecException Class
Atalasoft.Imaging.Codec Namespace


CodecException Events

The CodecException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CodecException Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection Class

A collection of ImageDecoder.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.CodecDecoderCollection

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DecoderCollection : CollectionBase
Public Class DecoderCollection
    Inherits CollectionBase

The DecoderCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DecoderCollection | Creates a new instance of DecoderCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | The indexer of this collection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an ImageDecoder to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines if a specific ImageDecoder is contained within the collection.
Public method | CopyTo | Copies the decoders to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specific ImageDecoder within the collection.
Public method | Insert | Inserts an ImageDecoder into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes an ImageDecoder from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


DecoderCollection Constructor

Creates a new instance of DecoderCollection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DecoderCollection()
Public Sub New
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection Properties

The DecoderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | The indexer of this collection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.Item Property

DecoderCollectionItem Property

The indexer of this collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageDecoder this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ImageDecoder
    Get

Parameters

index
Type: SystemInt32
The index of the ImageDecoder to retrieve.

Property Value

Type: ImageDecoder
The ImageDecoder at the specified index.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection Methods

The DecoderCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an ImageDecoder to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines if a specific ImageDecoder is contained within the collection.
Public method | CopyTo | Copies the decoders to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specific ImageDecoder within the collection.
Public method | Insert | Inserts an ImageDecoder into the collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes an ImageDecoder from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.Add Method

DecoderCollectionAdd Method

Adds an ImageDecoder to the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    ImageDecoder decoder
)
Public Sub Add (
    decoder As ImageDecoder
)

Parameters

decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to add.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.Contains Method

DecoderCollectionContains Method

Determines if a specific ImageDecoder is contained within the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    ImageDecoder decoder
)
Public Function Contains (
    decoder As ImageDecoder
) As Boolean

Parameters

decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to search for.

Return Value

Type: Boolean
True if the decoder is in the collection.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.CopyTo Method

DecoderCollectionCopyTo Method

Copies the decoders to an array.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    ImageDecoder[] decoders,
    int index
)
Public Sub CopyTo (
    decoders As ImageDecoder(),
    index As Integer
)

Parameters

decoders
Type: Atalasoft.Imaging.CodecImageDecoder
An array to hold the ImageDecoders.
index
Type: SystemInt32
The starting index in the array to start copying data.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.IndexOf Method

DecoderCollectionIndexOf Method

Returns the index of a specific ImageDecoder within the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    ImageDecoder decoder
)
Public Function IndexOf (
    decoder As ImageDecoder
) As Integer

Parameters

decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to look for.

Return Value

Type: Int32
The index of the ImageDecoder or -1 if the decoder is not in the collection.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.Insert Method

DecoderCollectionInsert Method

Inserts an ImageDecoder into the collection at the specified index.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    ImageDecoder decoder
)
Public Sub Insert (
    index As Integer,
    decoder As ImageDecoder
)

Parameters

index
Type: SystemInt32
The index to place the ImageDecoder.
decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to insert.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderCollection.Remove Method

DecoderCollectionRemove Method

Removes an ImageDecoder from the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    ImageDecoder decoder
)
Public Sub Remove (
    decoder As ImageDecoder
)

Parameters

decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to remove.
See Also

Reference

DecoderCollection Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary Class

A dictionary of ImageDecoder objects.
Inheritance Hierarchy
SystemObject
System.CollectionsDictionaryBase
Atalasoft.Imaging.CodecDecoderDictionary

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DecoderDictionary : DictionaryBase
Public Class DecoderDictionary
    Inherits DictionaryBase

The DecoderDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | DecoderDictionary | Initializes a new instance of the DecoderDictionary class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected property | Dictionary | Gets the list of elements contained in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected property | InnerHashtable | Gets the list of elements contained in the DictionaryBase instance. (Inherited from DictionaryBase.)
Public property | Item | Allows the decoders to be enumerated.
Top
Methods
 | Name | Description
Public method | Add | Add a decoder to the project.
Public method | Clear | Clears the contents of the DictionaryBase instance. (Inherited from DictionaryBase.)
Public method | Contains | Determines if a decoder is in the dictionary.
Public method | CopyTo(Array, Int32) | Copies the DictionaryBase elements to a one-dimensional Array at the specified index. (Inherited from DictionaryBase.)
Public method | CopyTo(DictionaryEntry, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator that iterates through the DictionaryBase instance. (Inherited from DictionaryBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes before clearing the contents of the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnGet | Gets the element with the specified key and value in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnRemove | Performs additional custom processes before removing an element from the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnValidate | Performs additional custom processes when validating the element with the specified key and value. (Inherited from DictionaryBase.)
Public method | Remove | Removes a decoder from the dictionary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Use this static class to add plug-ins to the project, and enumerate through the current plugins that are set.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


DecoderDictionary Constructor

Initializes a new instance of the DecoderDictionary class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DecoderDictionary()
Public Sub New
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary Properties

The DecoderDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected property | Dictionary | Gets the list of elements contained in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected property | InnerHashtable | Gets the list of elements contained in the DictionaryBase instance. (Inherited from DictionaryBase.)
Public property | Item | Allows the decoders to be enumerated.
Top
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary.Item Property

DecoderDictionaryItem Property

Allows the decoders to be enumerated.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageDecoder this[
    ImageType index
] { get; set; }
Public Default Property Item (
    index As ImageType
) As ImageDecoder
    Get
    Set

Parameters

index
Type: Atalasoft.Imaging.CodecImageType
The index of the item to retrieve.

Property Value

Type: ImageDecoder
The ImageDecoder at that index.
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary Methods

The DecoderDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a decoder to the project.
Public method | Clear | Clears the contents of the DictionaryBase instance. (Inherited from DictionaryBase.)
Public method | Contains | Determines if a decoder is in the dictionary.
Public method | CopyTo(Array, Int32) | Copies the DictionaryBase elements to a one-dimensional Array at the specified index. (Inherited from DictionaryBase.)
Public method | CopyTo(DictionaryEntry, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator that iterates through the DictionaryBase instance. (Inherited from DictionaryBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes before clearing the contents of the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnGet | Gets the element with the specified key and value in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnRemove | Performs additional custom processes before removing an element from the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the DictionaryBase instance. (Inherited from DictionaryBase.)
Protected method | OnValidate | Performs additional custom processes when validating the element with the specified key and value. (Inherited from DictionaryBase.)
Public method | Remove | Removes a decoder from the dictionary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary.Add Method

DecoderDictionaryAdd Method

Add a decoder to the project.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    ImageType imageType,
    ImageDecoder decoder
)
Public Sub Add (
    imageType As ImageType,
    decoder As ImageDecoder
)

Parameters

imageType
Type: Atalasoft.Imaging.CodecImageType
The image type for the decoder.
decoder
Type: Atalasoft.Imaging.CodecImageDecoder
The ImageDecoder to add.
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary.Contains Method

DecoderDictionaryContains Method

Determines if a decoder is in the dictionary.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    ImageType imageType
)
Public Overridable Function Contains (
    imageType As ImageType
) As Boolean

Parameters

imageType
Type: Atalasoft.Imaging.CodecImageType
The image decoder type.

Return Value

Type: Boolean
True if the dictionary contains the decoder.
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary.CopyTo Method

DecoderDictionaryCopyTo Method

Copies items from the dictionary to an array.
Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) | Copies the DictionaryBase elements to a one-dimensional Array at the specified index. (Inherited from DictionaryBase.)
Public method | CopyTo(DictionaryEntry, Int32) |
Top
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


DecoderDictionary.CopyTo Method (DictionaryEntry[], Int32)

DecoderDictionaryCopyTo Method (DictionaryEntry, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    DictionaryEntry[] decoders,
    int index
)
Public Sub CopyTo (
    decoders As DictionaryEntry(),
    index As Integer
)

Parameters

decoders
Type: System.CollectionsDictionaryEntry
index
Type: SystemInt32
See Also

Reference

DecoderDictionary Class
CopyTo Overload
Atalasoft.Imaging.Codec Namespace


DecoderDictionary.Remove Method

DecoderDictionaryRemove Method

Removes a decoder from the dictionary.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    ImageType imageType
)
Public Overridable Sub Remove (
    imageType As ImageType
)

Parameters

imageType
Type: Atalasoft.Imaging.CodecImageType
The image type to remove.
See Also

Reference

DecoderDictionary Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder Class

An ImageDecoder used to read Enhanced Metafiles (EMF) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecEmfDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EmfDecoder : ImageDecoder
Public Class EmfDecoder
    Inherits ImageDecoder

The EmfDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | EmfDecoder | Initializes a new instance of the EmfDecoder class.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns an Emf ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from an Emf image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an %AtalaImage% from a Stream containing an Emf encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening an Emf image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the %RegisteredDecoders% and does not have to be explicitly set.

Any vectorized entities saved in the Metafile will be converted to a raster format.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


EmfDecoder Constructor

Initializes a new instance of the EmfDecoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmfDecoder()
Public Sub New
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder Properties

The EmfDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns an Emf ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder.SupportedImageType Property

EmfDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns an Emf ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
ImageType.Emf
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder Methods

The EmfDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from an Emf image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an %AtalaImage% from a Stream containing an Emf encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder.GetImageInfo Method

EmfDecoderGetImageInfo Method

Retreive information from an Emf image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder.IsValidFormat Method

EmfDecoderIsValidFormat Method

Checks the stream to determine if the image can be read by the decoder that derives this class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
Returns if the specified Stream contains an Emf image, otherwise .
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfDecoder.Read Method

EmfDecoderRead Method

Returns an %AtalaImage% from a Stream containing an Emf encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

EmfDecoder Class
Atalasoft.Imaging.Codec Namespace


EmfEncoder Class

Summary description for EmfEncoder.

An ImageEncoder that will write Enhanced Metafiles (EMF) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecEmfEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EmfEncoder : ImageEncoder
Public Class EmfEncoder
    Inherits ImageEncoder

The EmfEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | EmfEncoder | Initializes a new instance of a EmfEncoder.
Top
Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Emf image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a EMF image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


EmfEncoder Constructor

Initializes a new instance of a EmfEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmfEncoder()
Public Sub New
See Also

Reference

EmfEncoder Class
Atalasoft.Imaging.Codec Namespace


EmfEncoder Properties

The EmfEncoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

EmfEncoder Class
Atalasoft.Imaging.Codec Namespace


EmfEncoder.SupportedPixelFormats Property

EmfEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

EmfEncoder Class
Atalasoft.Imaging.Codec Namespace


EmfEncoder Methods

The EmfEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Emf image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmfEncoder Class
Atalasoft.Imaging.Codec Namespace


EmfEncoder.Save Method

EmfEncoderSave Method

Encode an %AtalaImage% as a Emf image to a stream.
Encode an %AtalaImage% as an Emf image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

EmfEncoder Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs Class

This object is used for events fired by an MultiFramedImageEncoder when requesting a compression type.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.CodecEncoderCompressionEventArgs

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EncoderCompressionEventArgs : EventArgs
Public Class EncoderCompressionEventArgs
    Inherits EventArgs

The EncoderCompressionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EncoderCompressionEventArgs | Creates a new instance of EncoderCompressionEventArgs.
Top
Properties
 | Name | Description
Public property | Compression | Gets or sets the compression that will be used to encode the image.
Public property | FrameIndex | Gets the zero based frame index that will be encoded.
Public property | Image | Gets the AtalaImage that will be encoded.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs Constructor

Creates a new instance of EncoderCompressionEventArgs.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EncoderCompressionEventArgs(
    AtalaImage image,
    int frameIndex,
    CodecCompression compression
)
Public Sub New (
    image As AtalaImage,
    frameIndex As Integer,
    compression As CodecCompression
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage that is to be encoded.
frameIndex
Type: SystemInt32
The zero-based frame index that will be encoded.
compression
Type: Atalasoft.Imaging.CodecCodecCompression
The compression that will be used to encode the image.
See Also

Reference

EncoderCompressionEventArgs Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs Properties

The EncoderCompressionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Compression | Gets or sets the compression that will be used to encode the image.
Public property | FrameIndex | Gets the zero based frame index that will be encoded.
Public property | Image | Gets the AtalaImage that will be encoded.
Top
See Also

Reference

EncoderCompressionEventArgs Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs.Compression Property

EncoderCompressionEventArgsCompression Property

Gets or sets the compression that will be used to encode the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CodecCompression Compression { get; set; }
Public Property Compression As CodecCompression
    Get
    Set

Property Value

Type: CodecCompression
See Also

Reference

EncoderCompressionEventArgs Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs.FrameIndex Property

EncoderCompressionEventArgsFrameIndex Property

Gets the zero based frame index that will be encoded.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameIndex { get; }
Public ReadOnly Property FrameIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

EncoderCompressionEventArgs Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs.Image Property

EncoderCompressionEventArgsImage Property

Gets the AtalaImage that will be encoded.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

EncoderCompressionEventArgs Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventArgs Methods

The EncoderCompressionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EncoderCompressionEventArgs Class
Atalasoft.Imaging.Codec Namespace


EncoderCompressionEventHandler Delegate

Event handler used when specifying compression in the MultiFramedImageEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void EncoderCompressionEventHandler(
    Object sender,
    EncoderCompressionEventArgs e
)
Public Delegate Sub EncoderCompressionEventHandler (
    sender As Object,
    e As EncoderCompressionEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.CodecEncoderCompressionEventArgs
See Also

Reference

Atalasoft.Imaging.Codec Namespace


EpsEncoder Class

An ImageEncoder that will write Adobe Encapsulated PostScript images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecEpsEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EpsEncoder : ImageEncoder
Public Class EpsEncoder
    Inherits ImageEncoder

The EpsEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | EpsEncoder | Initializes a new instance of EpsEncoder.
Top
Properties
 | Name | Description
Public property | Creator | This property represents the creator field in the header of the resulting EPS image.
Public property | IgnoreColorProfile | Allow the EPS encoder to ignore the color profile provided by an image.
Public property | ImageLocation | This sets the relative location of the image in page space in units of points.
Public property | IncludeShowPage | Determines whether or not this image will include the PostScript showpage command.
Public property | InvertBW | Switches the sense of black and white in 1 bit-per-pixel images
Public property | Resolution | Sets the output resolution of the image.
Public property | Scale | Sets the output scale of the image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | Title | Set the title of the image in the EPS header
Public property | UseImageResolution | Determine whether or not to use the resolution of the image to be saved.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as an EPS image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify an EPS image. The output format conforms to the Adobe Encapsulated PostScript 3.0 specification.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


EpsEncoder Constructor

Initializes a new instance of EpsEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EpsEncoder()
Public Sub New
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder Properties

The EpsEncoder type exposes the following members.

Properties
 | Name | Description
Public property | Creator | This property represents the creator field in the header of the resulting EPS image.
Public property | IgnoreColorProfile | Allow the EPS encoder to ignore the color profile provided by an image.
Public property | ImageLocation | This sets the relative location of the image in page space in units of points.
Public property | IncludeShowPage | Determines whether or not this image will include the PostScript showpage command.
Public property | InvertBW | Switches the sense of black and white in 1 bit-per-pixel images
Public property | Resolution | Sets the output resolution of the image.
Public property | Scale | Sets the output scale of the image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | Title | Set the title of the image in the EPS header
Public property | UseImageResolution | Determine whether or not to use the resolution of the image to be saved.
Top
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.Creator Property

EpsEncoderCreator Property

This property represents the creator field in the header of the resulting EPS image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set

Property Value

Type: String
Remarks
If the string contains carriage return or new line characters, the resulting image may not work properly. By default, this property is set to "%%company-full%%"
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.IgnoreColorProfile Property

EpsEncoderIgnoreColorProfile Property

Allow the EPS encoder to ignore the color profile provided by an image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IgnoreColorProfile { get; set; }
Public Property IgnoreColorProfile As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
If IgnoreColorProfile is set to false and the image contains a color profile, the resulting EPS will contain an embedded color profile. If IgnoreColorProfile is set to true the color profile will be ignored.
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.ImageLocation Property

EpsEncoderImageLocation Property

This sets the relative location of the image in page space in units of points.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ImageLocation { get; set; }
Public Property ImageLocation As PointF
    Get
    Set

Property Value

Type: PointF
Remarks

This sets where the image will be rendered on the virtual EPS page. In page space, the lower left corner of the page is (0, 0), as in a conventional Cartesian coordinate system. ImageLocation is the point at which the lower left corner of the image will be placed.

In EPS, the notion of a page doesn't fully apply, but since EPS can also be rendered on a PostScript device, if this point isn't chosen carefully, the image may get clipped.

By default, ImageLocation is (72, 72), or one inch up and to the right of the lower left corner of a page.

See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.IncludeShowPage Property

EpsEncoderIncludeShowPage Property

Determines whether or not this image will include the PostScript showpage command.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncludeShowPage { get; set; }
Public Property IncludeShowPage As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

Some applications that consume EPS do not handle the showpage command gracefully. Suppressing it may help incompatible application handle the image correctly.

Setting this property to false will prevent the image from displaying if it is sent directly to a PostScript device.

The default value is true.

See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.InvertBW Property

EpsEncoderInvertBW Property

Switches the sense of black and white in 1 bit-per-pixel images

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool InvertBW { get; set; }
Public Property InvertBW As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is true.
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.Resolution Property

EpsEncoderResolution Property

Sets the output resolution of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; set; }
Public Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
Remarks

This property is ignored if UseImageResolution is set to true.

The default value is 72 pixels per inch.

See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.Scale Property

EpsEncoderScale Property

Sets the output scale of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Scale { get; set; }
Public Property Scale As PointF
    Get
    Set

Property Value

Type: PointF
Remarks

Use this to change the scale of the image in the EPS image. It is initially set to (1, 1), which represents no change in scale. To reduce the image, set this property to values less than 1 but greater than 0. To enlarge the image, set this property to values greater than 1.

Scale does not need to be uniform. In other words, an image can be enlarged in either the x or y directions independently.

Negative values will flip the image as well as scale it.

See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.SupportedPixelFormats Property

EpsEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.Title Property

EpsEncoderTitle Property

Set the title of the image in the EPS header

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
Remarks
Default value is "Untitled"
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.UseImageResolution Property

EpsEncoderUseImageResolution Property

Determine whether or not to use the resolution of the image to be saved.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseImageResolution { get; set; }
Public Property UseImageResolution As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

If this property is set to true, then the resolution off the image will be used for conversion to EPS. If the image resolution has no units or the resolution is invalid, it will be treated as 72 pixels per inch.

Default value is true.

See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder Methods

The EpsEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as an EPS image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


EpsEncoder.Save Method

EpsEncoderSave Method

Encode an AtalaImage as an EPS image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

EpsEncoder Class
Atalasoft.Imaging.Codec Namespace


ErrorLevel Enumeration

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ErrorLevel
Public Enumeration ErrorLevel
Members
Member name | Description
None | This value denotes that there is no error present. While it is not presently used, it is included for the sake of completeness.
Warning | This value denotes that a problem of very mild severity has been detected in a codec.
Error | This value denotes that a problem of moderate to high severity has been detected in a codec.
Fatal | This value denotes that there a severe error has occurred that could be fatal to the CLR or the current application. This severity should never be used in released software.
Remarks
This enumeration is used in the CodecErrorEventArgs class in order to denote the severity of an error.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifDecoder Class

An ImageDecoder used to read Compuserve Graphics Interchange (GIF) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.CodecGifDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GifDecoder : MultiFramedImageDecoder, IDisposable
Public Class GifDecoder
    Inherits MultiFramedImageDecoder
    Implements IDisposable

The GifDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | GifDecoder | Initializes a new instance of a %GifDecoder%.
Top
Properties
 | Name | Description
Public property | Frames | Gets a GifFrameCollection from an animated GIF.
Public property | SupportedImageType | Obsolete. Returns a Gif ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the GifDecoder class. (Overrides ObjectFinalize.)
Public method | GetFrameCount | Gets the number of frames in a GIF. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from a Gif image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Retreive information from a specified frame in a Gif image stored in a Stream without decoding the image data. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Gif image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Returns an %AtalaImage% from a Stream containing a Gif encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Returns a specified frame to an %AtalaImage% from a Stream containing an animated Gif encoded image. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Gif image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.

Examples
Animated (C#)
Copy
// Open the file for reading.
FileStream fs = new FileStream(this.fileName, FileMode.Open, FileAccess.Read);

// Make sure it's a valid GIF.
GifDecoder gif = new GifDecoder();
if (gif.IsValidFormat(fs) == false)
{
    fs.Close();
    return;
}

// Seek back to the beginning of the file.
fs.Seek(0, SeekOrigin.Begin);

// The first time you access the GetFrameCount property,
// all of the frames are read into memory and are waiting
// for you to access them.
int count = gif.GetFrameCount(fs);

// Use the GifFrame properties to reconstruct the animation.
GifFrameCollection col = gif.Frames;

// Close the file.
fs.Close();
AnimatedVB (Visual Basic)
Copy
' Open the file for reading.
Dim fs As FileStream =  New FileStream(Me.fileName,FileMode.Open,FileAccess.Read)

' Make sure it's a valid GIF.
Dim gif As GifDecoder =  New GifDecoder()
If gif.IsValidFormat(fs) = False Then
    fs.Close()
    Return
End If

' Seek back to the beginning of the file.
fs.Seek(0, SeekOrigin.Begin)

' The first time you access the GetFrameCount property,
' all of the frames are read into memory and are waiting
' for you to access them.
Dim count As Integer =  gif.GetFrameCount(fs)

' Use the GifFrame properties to reconstruct the animation.
Dim col As GifFrameCollection =  gif.Frames

' Close the file.
fs.Close()
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifDecoder Constructor

Initializes a new instance of a %GifDecoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifDecoder()
Public Sub New
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder Properties

The GifDecoder type exposes the following members.

Properties
 | Name | Description
Public property | Frames | Gets a GifFrameCollection from an animated GIF.
Public property | SupportedImageType | Obsolete. Returns a Gif ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.Frames Property

GifDecoderFrames Property

Gets a GifFrameCollection from an animated GIF.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrameCollection Frames { get; }
Public ReadOnly Property Frames As GifFrameCollection
    Get

Property Value

Type: GifFrameCollection
A GifFrameCollection containing information about the annimated GIF.
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.SupportedImageType Property

GifDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Gif ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
ImageType.Gif
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder Methods

The GifDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the GifDecoder class. (Overrides ObjectFinalize.)
Public method | GetFrameCount | Gets the number of frames in a GIF. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from a Gif image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Retreive information from a specified frame in a Gif image stored in a Stream without decoding the image data. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Gif image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Returns an %AtalaImage% from a Stream containing a Gif encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Returns a specified frame to an %AtalaImage% from a Stream containing an animated Gif encoded image. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.Dispose Method

GifDecoderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.Dispose Method

GifDecoderDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

GifDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec Namespace


GifDecoder.Dispose Method (Boolean)

GifDecoderDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

GifDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec Namespace


GifDecoder.Finalize Method

GifDecoderFinalize Method

Finalizes an instance of the GifDecoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.GetFrameCount Method

GifDecoderGetFrameCount Method

Gets the number of frames in a GIF.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Int32
The number of frames in a GIF.
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.GetImageInfo Method

GifDecoderGetImageInfo Method

Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retreive information from a Gif image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Retreive information from a specified frame in a Gif image stored in a Stream without decoding the image data. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.GetImageInfo Method (Stream)

GifDecoderGetImageInfo Method (Stream)

Retreive information from a Gif image stored in a Stream without decoding the image data.
Retreive information from a Gif image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

GifDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


GifDecoder.GetImageInfo Method (Stream, Int32)

GifDecoderGetImageInfo Method (Stream, Int32)

Retreive information from a specified frame in a Gif image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
The zero based frame index to load from an animated GIF.

Return Value

Type: ImageInfo
See Also

Reference

GifDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


GifDecoder.IsValidFormat Method

GifDecoderIsValidFormat Method

Returns true if the specified Stream contains a Gif image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.Read Method

GifDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Returns an %AtalaImage% from a Stream containing a Gif encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Returns a specified frame to an %AtalaImage% from a Stream containing an animated Gif encoded image. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

GifDecoder Class
Atalasoft.Imaging.Codec Namespace


GifDecoder.Read Method (Stream, ProgressEventHandler)

GifDecoderRead Method (Stream, ProgressEventHandler)

Returns an %AtalaImage% from a Stream containing a Gif encoded image.
Returns an %AtalaImage% from a Stream containing a Gif encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

GifDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


GifDecoder.Read Method (Stream, Int32, ProgressEventHandler)

GifDecoderRead Method (Stream, Int32, ProgressEventHandler)

Returns a specified frame to an %AtalaImage% from a Stream containing an animated Gif encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
The zero based frame index to load from an animated GIF.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

GifDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


GifEncoder Class

An ImageEncoder that will write Compuserve Graphics Interchange (GIF) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecGifEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GifEncoder : ImageEncoder
Public Class GifEncoder
    Inherits ImageEncoder

The GifEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | GifEncoder | Initializes a new instance of a %GifEncoder%.
Public method | GifEncoder(Boolean) | Initializes a new instance of a %BmpEncoder% specifying the interlace setting.
Public method | GifEncoder(Boolean, Boolean) | Creates a new instance of GifEncoder specifying whether to interlace the image and optimize color depth.
Top
Properties
 | Name | Description
Public property | BackgroundIndex | Gets or sets the background index to store in the GIF file.
Public property | Interlace | Gets or sets a value indicating if the image is saved with a pixel row interlacing pattern. Default false
Public property | OptimizeColorDepth | Gets or sets a value indicating if the bitdepth is optimized based on the number of colors in the palette. Default true.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Gif image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, GifFrameCollection, ProgressEventHandler) | Saves an animated GIF image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a GIF image.

Gif Images typicaly have one color which is transparent. When saving with a GifFrameCollection object, this is indicated by the TransparentIndex property of each GifFrame.

When saving with a regular AtalaImage or ImageCollection, the transparent index is determined automaticaly. Each color in the palette can have an alpha value between 0 and 255. The GifEncoder will chose (as the transparent color) the first fully transparent color in the palette, that is the first color with an alpha value of 255.

Examples
SaveAnimatedGif (C#)
Copy
private void CreateAnimatedGif(string fileName, ImageCollection images)
{
    // Find the maximum size of the animation.
    int width = 0;
    int height = 0;
    foreach(AtalaImage img in images)
    {
        if (img.Width > width)
            width = img.Width;

        if (img.Height > height)
            height = img.Height;
    }

    // Create the frame collection.
    GifFrameCollection col = new GifFrameCollection();
    col.Width = width;
    col.Height = height;
    col.LoopCount = 0;  // infinite
    col.TransparentIndex = -1;  // no transparency

    // Center each image.
    foreach(AtalaImage img in images)
    {
        GifFrame frame = new GifFrame(img, new Point((width - img.Width) / 2, (height - img.Height) / 2));
        col.Add(frame);
    }

    // Save the image.
    FileStream fs = new FileStream(fileName, FileMode.Create, FileAccess.Write);
    GifEncoder encoder = new GifEncoder();
    encoder.Save(fs, col, null);
    fs.Close();

    // Free the collection.
    col.Dispose();
}
SaveAnimatedGifVB (Visual Basic)
Copy
Private  Sub CreateAnimatedGif(ByVal fileName As String, ByVal images As ImageCollection)
    ' Find the maximum size of the animation.
    Dim width As Integer =  0
    Dim height As Integer =  0
    Dim img As AtalaImage
    For Each img In images
        If img.Width > width Then
            width = img.Width
        End If

        If img.Height > height Then
            height = img.Height
        End If
    Next

    ' Create the frame collection.
    Dim col As GifFrameCollection =  New GifFrameCollection()
    col.Width = width
    col.Height = height
    col.LoopCount = 0  ' infinite
    col.TransparentIndex = -1  ' no transparency

    ' Center each image.
    Dim img As AtalaImage
    For Each img In images
        Dim frame As GifFrame =  New GifFrame(img, New Point((width - img.Width) / 2,(height - img.Height) / 2))
        col.Add(frame)
    Next

    ' Save the image.
    Dim fs As FileStream =  New FileStream(fileName,FileMode.Create,FileAccess.Write)
    Dim encoder As GifEncoder =  New GifEncoder()
    encoder.Save(fs, col, Nothing)
    fs.Close()

    ' Free the collection.
    col.Dispose()
End Sub
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifEncoder Constructor

Overload List
 | Name | Description
Public method | GifEncoder | Initializes a new instance of a %GifEncoder%.
Public method | GifEncoder(Boolean) | Initializes a new instance of a %BmpEncoder% specifying the interlace setting.
Public method | GifEncoder(Boolean, Boolean) | Creates a new instance of GifEncoder specifying whether to interlace the image and optimize color depth.
Top
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder Constructor

Initializes a new instance of a %GifEncoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifEncoder()
Public Sub New
See Also

Reference

GifEncoder Class
GifEncoder Overload
Atalasoft.Imaging.Codec Namespace


GifEncoder Constructor (Boolean)

Initializes a new instance of a %BmpEncoder% specifying the interlace setting.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifEncoder(
    bool interlace
)
Public Sub New (
    interlace As Boolean
)

Parameters

interlace
Type: SystemBoolean
A value indicating if the image is saved with a pixel row interlacing pattern.
See Also

Reference

GifEncoder Class
GifEncoder Overload
Atalasoft.Imaging.Codec Namespace


GifEncoder Constructor (Boolean, Boolean)

Creates a new instance of GifEncoder specifying whether to interlace the image and optimize color depth.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifEncoder(
    bool interlace,
    bool optimizeColorDepth
)
Public Sub New (
    interlace As Boolean,
    optimizeColorDepth As Boolean
)

Parameters

interlace
Type: SystemBoolean
A value indicating if the image is saved with a pixel row interlacing pattern.
optimizeColorDepth
Type: SystemBoolean
A value indicating whether to optimize the color depth.
See Also

Reference

GifEncoder Class
GifEncoder Overload
Atalasoft.Imaging.Codec Namespace


GifEncoder Properties

The GifEncoder type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundIndex | Gets or sets the background index to store in the GIF file.
Public property | Interlace | Gets or sets a value indicating if the image is saved with a pixel row interlacing pattern. Default false
Public property | OptimizeColorDepth | Gets or sets a value indicating if the bitdepth is optimized based on the number of colors in the palette. Default true.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder.BackgroundIndex Property

GifEncoderBackgroundIndex Property

Gets or sets the background index to store in the GIF file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BackgroundIndex { get; set; }
Public Property BackgroundIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder.Interlace Property

GifEncoderInterlace Property

Gets or sets a value indicating if the image is saved with a pixel row interlacing pattern. Default false

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Interlace { get; set; }
Public Property Interlace As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the image is saved with a pixel row interlacing pattern.
Remarks
Interlacing is a technique that allows a Gif to be displayed gradually. It first displays a blocky image which becomes finer and more clear as the image loads.
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder.OptimizeColorDepth Property

GifEncoderOptimizeColorDepth Property

Gets or sets a value indicating if the bitdepth is optimized based on the number of colors in the palette. Default true.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OptimizeColorDepth { get; set; }
Public Property OptimizeColorDepth As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the bitdepth is optimized.
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder.SupportedPixelFormats Property

GifEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder Methods

The GifEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Gif image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, GifFrameCollection, ProgressEventHandler) | Saves an animated GIF image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder.Save Method

GifEncoderSave Method

Overload List
 | Name | Description
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Gif image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, GifFrameCollection, ProgressEventHandler) | Saves an animated GIF image.
Top
See Also

Reference

GifEncoder Class
Atalasoft.Imaging.Codec Namespace


GifEncoder.Save Method (Stream, AtalaImage, ProgressEventHandler)

GifEncoderSave Method (Stream, AtalaImage, ProgressEventHandler)

Encode an AtalaImage as a Gif image to a stream.
Encode an AtalaImage as a Gif image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

GifEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


GifEncoder.Save Method (Stream, GifFrameCollection, ProgressEventHandler)

GifEncoderSave Method (Stream, GifFrameCollection, ProgressEventHandler)

Saves an animated GIF image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    GifFrameCollection frameCollection,
    ProgressEventHandler progress
)
Public Sub Save (
    stream As Stream,
    frameCollection As GifFrameCollection,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
The stream to save the image into.
frameCollection
Type: Atalasoft.Imaging.CodecGifFrameCollection
The GifFrameCollection containing information about each frame in the animation.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

GifEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


GifFrame Class

The GifFrame class holds information about a single frame in an animated GIF file.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecGifFrame

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GifFrame : IDisposable
Public Class GifFrame
    Implements IDisposable

The GifFrame type exposes the following members.

Constructors
 | Name | Description
Public method | GifFrame | Initializes a new instance of the GifFrame class.
Public method | GifFrame(AtalaImage) | Creates a new instance of GifFrame specifying the frame image.
Public method | GifFrame(AtalaImage, Point) | Creates a new instance of GifFrame specifying the frame image and location.
Public method | GifFrame(AtalaImage, Point, Int32) | Creates a new instance of GifFrame specifying the frame image, location and delay time.
Public method | GifFrame(AtalaImage, Point, Int32, Boolean, GifFrameDisposal, Int32, Boolean) | Creates a new instance of GifFrame specifying the frame image, location, delay time, interlaced, frame disposal, transparent index and local palette settings.
Top
Properties
 | Name | Description
Public property | DelayTime | Gets or sets the number of milliseconds this frame should be displayed.
Public property | FrameDisposal | Gets or sets the method of frame disposal to use before rendering the next frame.
Public property | Image | Gets or sets the image for this frame.
Public property | Interlaced | Gets or sets a value indicating whether the image is interlaced.
Public property | Location | Gets or sets the location to render the image on the animated canvas.
Public property | TransparentIndex | Gets or sets the transparent index for this image.
Public property | UseLocalPalette | Gets or sets a value indicating whether this image uses the global palette or it's own palette.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the GifFrame class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifFrame Constructor

Creates a new instance of GifFrame.
Overload List
 | Name | Description
Public method | GifFrame | Initializes a new instance of the GifFrame class.
Public method | GifFrame(AtalaImage) | Creates a new instance of GifFrame specifying the frame image.
Public method | GifFrame(AtalaImage, Point) | Creates a new instance of GifFrame specifying the frame image and location.
Public method | GifFrame(AtalaImage, Point, Int32) | Creates a new instance of GifFrame specifying the frame image, location and delay time.
Public method | GifFrame(AtalaImage, Point, Int32, Boolean, GifFrameDisposal, Int32, Boolean) | Creates a new instance of GifFrame specifying the frame image, location, delay time, interlaced, frame disposal, transparent index and local palette settings.
Top
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame Constructor

Initializes a new instance of the GifFrame class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrame()
Public Sub New
See Also

Reference

GifFrame Class
GifFrame Overload
Atalasoft.Imaging.Codec Namespace


GifFrame Constructor (AtalaImage)

Creates a new instance of GifFrame specifying the frame image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrame(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image for this frame.
See Also

Reference

GifFrame Class
GifFrame Overload
Atalasoft.Imaging.Codec Namespace


GifFrame Constructor (AtalaImage, Point)

Creates a new instance of GifFrame specifying the frame image and location.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrame(
    AtalaImage image,
    Point location
)
Public Sub New (
    image As AtalaImage,
    location As Point
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image for this frame.
location
Type: System.DrawingPoint
The location to render the image on the animated canvas.
See Also

Reference

GifFrame Class
GifFrame Overload
Atalasoft.Imaging.Codec Namespace


GifFrame Constructor (AtalaImage, Point, Int32)

Creates a new instance of GifFrame specifying the frame image, location and delay time.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrame(
    AtalaImage image,
    Point location,
    int delayTime
)
Public Sub New (
    image As AtalaImage,
    location As Point,
    delayTime As Integer
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image for this frame.
location
Type: System.DrawingPoint
The location to render the image on the animated canvas.
delayTime
Type: SystemInt32
The number of milliseconds this frame should be displayed.
See Also

Reference

GifFrame Class
GifFrame Overload
Atalasoft.Imaging.Codec Namespace


GifFrame Constructor (AtalaImage, Point, Int32, Boolean, GifFrameDisposal, Int32, Boolean)

Creates a new instance of GifFrame specifying the frame image, location, delay time, interlaced, frame disposal, transparent index and local palette settings.
Creates a new instance of GifFrame.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrame(
    AtalaImage image,
    Point location,
    int delayTime,
    bool interlaced,
    GifFrameDisposal frameDisposal,
    int transparentIndex,
    bool useLocalPalette
)
Public Sub New (
    image As AtalaImage,
    location As Point,
    delayTime As Integer,
    interlaced As Boolean,
    frameDisposal As GifFrameDisposal,
    transparentIndex As Integer,
    useLocalPalette As Boolean
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image for this frame.
location
Type: System.DrawingPoint
The location to render the image on the animated canvas.
delayTime
Type: SystemInt32
The number of milliseconds this frame should be displayed.
interlaced
Type: SystemBoolean
A value indicating whether the image is interlaced.
frameDisposal
Type: Atalasoft.Imaging.CodecGifFrameDisposal
The method of frame disposal to use before rendering the next frame.
transparentIndex
Type: SystemInt32
The transparent index for this image.
useLocalPalette
Type: SystemBoolean
A value indicating whether this image uses the global palette or it's own palette.
See Also

Reference

GifFrame Class
GifFrame Overload
Atalasoft.Imaging.Codec Namespace


GifFrame Properties

The GifFrame type exposes the following members.

Properties
 | Name | Description
Public property | DelayTime | Gets or sets the number of milliseconds this frame should be displayed.
Public property | FrameDisposal | Gets or sets the method of frame disposal to use before rendering the next frame.
Public property | Image | Gets or sets the image for this frame.
Public property | Interlaced | Gets or sets a value indicating whether the image is interlaced.
Public property | Location | Gets or sets the location to render the image on the animated canvas.
Public property | TransparentIndex | Gets or sets the transparent index for this image.
Public property | UseLocalPalette | Gets or sets a value indicating whether this image uses the global palette or it's own palette.
Top
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.DelayTime Property

GifFrameDelayTime Property

Gets or sets the number of milliseconds this frame should be displayed.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DelayTime { get; set; }
Public Property DelayTime As Integer
    Get
    Set

Property Value

Type: Int32
The number of milliseconds this frame should be displayed.
Remarks
The time is measured in 1/100 of a second.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.FrameDisposal Property

GifFrameFrameDisposal Property

Gets or sets the method of frame disposal to use before rendering the next frame.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrameDisposal FrameDisposal { get; set; }
Public Property FrameDisposal As GifFrameDisposal
    Get
    Set

Property Value

Type: GifFrameDisposal
The method of frame disposal to use before rendering the next frame.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.Image Property

GifFrameImage Property

Gets or sets the image for this frame.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage for this frame.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.Interlaced Property

GifFrameInterlaced Property

Gets or sets a value indicating whether the image is interlaced.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Interlaced { get; set; }
Public Property Interlaced As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the image is interlaced.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.Location Property

GifFrameLocation Property

Gets or sets the location to render the image on the animated canvas.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set

Property Value

Type: Point
The location to render the image on the animated canvas.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.TransparentIndex Property

GifFrameTransparentIndex Property

Gets or sets the transparent index for this image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TransparentIndex { get; set; }
Public Property TransparentIndex As Integer
    Get
    Set

Property Value

Type: Int32
The transparent index for this image.
Remarks
If UseLocalPalette is true, this is an index from the palette for this frame. Otherwise this is an index from the global palette. A value of -1 turns off transparency.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.UseLocalPalette Property

GifFrameUseLocalPalette Property

Gets or sets a value indicating whether this image uses the global palette or it's own palette.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseLocalPalette { get; set; }
Public Property UseLocalPalette As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this image uses the global palette or it's own palette.
Remarks
Using a global palette for all of the images will reduce the file size.
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame Methods

The GifFrame type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the GifFrame class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.Dispose Method

GifFrameDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrame.Dispose Method

GifFrameDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

GifFrame Class
Dispose Overload
Atalasoft.Imaging.Codec Namespace


GifFrame.Dispose Method (Boolean)

GifFrameDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

GifFrame Class
Dispose Overload
Atalasoft.Imaging.Codec Namespace


GifFrame.Finalize Method

GifFrameFinalize Method

Finalizes an instance of the GifFrame class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

GifFrame Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection Class

The GifFrameCollection class represents an animated GIF file. It contains all of the frames and properties for the animation.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.CodecGifFrameCollection

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GifFrameCollection : CollectionBase,
    IDisposable
Public Class GifFrameCollection
    Inherits CollectionBase
    Implements IDisposable

The GifFrameCollection type exposes the following members.

Constructors
 | Name | Description
Public method | GifFrameCollection | Creates a new instance of GifFrameCollection.
Top
Properties
 | Name | Description
Public property | BackgroundColorIndex | Gets or sets the index in the global palette used as the background color for the animation canvas.
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | GlobalPalette | Gets or sets the palette used by frames in the GIF.
Public property | Height | Gets or sets the height of the animation canvas.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a GifFrame at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | LoopCount | Gets or sets the number of times to loop through the animation.
Public property | TransparentIndex | Gets or sets the index in the global palette which represents the transparent color.
Public property | Width | Gets or sets the width of the animation canvas.
Top
Methods
 | Name | Description
Public method | Add | Adds a frame to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Checks to see if a specific frame already exists in the collection.
Public method | CopyTo | Copies the GifFrames into an array.
Public method | Dispose | Releases all of the frames from the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the GifFrameCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Looks up the index for a specific frame.
Public method | Insert | Inserts a frame into the collection at the specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a frame from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifFrameCollection Constructor

Creates a new instance of GifFrameCollection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrameCollection()
Public Sub New
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection Properties

The GifFrameCollection type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColorIndex | Gets or sets the index in the global palette used as the background color for the animation canvas.
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | GlobalPalette | Gets or sets the palette used by frames in the GIF.
Public property | Height | Gets or sets the height of the animation canvas.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets a GifFrame at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | LoopCount | Gets or sets the number of times to loop through the animation.
Public property | TransparentIndex | Gets or sets the index in the global palette which represents the transparent color.
Public property | Width | Gets or sets the width of the animation canvas.
Top
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.BackgroundColorIndex Property

GifFrameCollectionBackgroundColorIndex Property

Gets or sets the index in the global palette used as the background color for the animation canvas.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BackgroundColorIndex { get; set; }
Public Property BackgroundColorIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index in the global palette used as the background color for the animation canvas.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.GlobalPalette Property

GifFrameCollectionGlobalPalette Property

Gets or sets the palette used by frames in the GIF.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette GlobalPalette { get; set; }
Public Property GlobalPalette As Palette
    Get
    Set

Property Value

Type: Palette
The palette used by frames in the GIF.
Remarks

Using a global palette can decrease the overall size of the animated GIF.

While it's possible to use a separate palette for each image, it's recommended that you only use the global palette.

See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Height Property

GifFrameCollectionHeight Property

Gets or sets the height of the animation canvas.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set

Property Value

Type: Int32
The height of the animation canvas.
Remarks

All images added to the collection must be equal to or less than this size.

This is the height of the final output. All frames must fit inside this area.

See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Item Property

GifFrameCollectionItem Property

Gets a GifFrame at the specified index.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrame this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As GifFrame
    Get

Parameters

index
Type: SystemInt32
The index of the GifFrame to retrieve.

Property Value

Type: GifFrame
A GifFrame at the specified index.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.LoopCount Property

GifFrameCollectionLoopCount Property

Gets or sets the number of times to loop through the animation.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LoopCount { get; set; }
Public Property LoopCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of times to loop through the animation.
Remarks
If this value is 0, the animation loop is infinite.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.TransparentIndex Property

GifFrameCollectionTransparentIndex Property

Gets or sets the index in the global palette which represents the transparent color.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TransparentIndex { get; set; }
Public Property TransparentIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index in the global palette which represents the transparent color.
Remarks
A value of -1 disables transparency.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Width Property

GifFrameCollectionWidth Property

Gets or sets the width of the animation canvas.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set

Property Value

Type: Int32
The width of the animation canvas.
Remarks
This is the width of the final output. All frames must fit inside this area.
Remarks

This is the width of the final output. All frames must fit inside this area.

All images added to the collection must be equal or less than this size.

See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection Methods

The GifFrameCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a frame to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Checks to see if a specific frame already exists in the collection.
Public method | CopyTo | Copies the GifFrames into an array.
Public method | Dispose | Releases all of the frames from the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the GifFrameCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Looks up the index for a specific frame.
Public method | Insert | Inserts a frame into the collection at the specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a frame from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Add Method

GifFrameCollectionAdd Method

Adds a frame to the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    GifFrame frame
)
Public Sub Add (
    frame As GifFrame
)

Parameters

frame
Type: Atalasoft.Imaging.CodecGifFrame
The GifFrame to add.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Contains Method

GifFrameCollectionContains Method

Checks to see if a specific frame already exists in the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    GifFrame frame
)
Public Function Contains (
    frame As GifFrame
) As Boolean

Parameters

frame
Type: Atalasoft.Imaging.CodecGifFrame
The GifFrame to look for.

Return Value

Type: Boolean
True if the frame exists.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.CopyTo Method

GifFrameCollectionCopyTo Method

Copies the GifFrames into an array.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    GifFrame[] frames,
    int index
)
Public Sub CopyTo (
    frames As GifFrame(),
    index As Integer
)

Parameters

frames
Type: Atalasoft.Imaging.CodecGifFrame
An array of GifFrame in which the collection will be copied.
index
Type: SystemInt32
The index in the frames array to begin copying to.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Dispose Method

GifFrameCollectionDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all of the frames from the collection.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Dispose Method

GifFrameCollectionDispose Method

Releases all of the frames from the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

GifFrameCollection Class
Dispose Overload
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Dispose Method (Boolean)

GifFrameCollectionDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

GifFrameCollection Class
Dispose Overload
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Finalize Method

GifFrameCollectionFinalize Method

Finalizes an instance of the GifFrameCollection class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.IndexOf Method

GifFrameCollectionIndexOf Method

Looks up the index for a specific frame.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    GifFrame frame
)
Public Function IndexOf (
    frame As GifFrame
) As Integer

Parameters

frame
Type: Atalasoft.Imaging.CodecGifFrame
The GifFrame to look for.

Return Value

Type: Int32
The index of the frame.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Insert Method

GifFrameCollectionInsert Method

Inserts a frame into the collection at the specified position.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    GifFrame frame
)
Public Sub Insert (
    index As Integer,
    frame As GifFrame
)

Parameters

index
Type: SystemInt32
The index position which the frame should be placed.
frame
Type: Atalasoft.Imaging.CodecGifFrame
The GifFrame to insert.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameCollection.Remove Method

GifFrameCollectionRemove Method

Removes a frame from the collection.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    GifFrame frame
)
Public Sub Remove (
    frame As GifFrame
)

Parameters

frame
Type: Atalasoft.Imaging.CodecGifFrame
The GifFrame to remove.
See Also

Reference

GifFrameCollection Class
Atalasoft.Imaging.Codec Namespace


GifFrameDisposal Enumeration

The frame disposal method to use for animated GIF images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum GifFrameDisposal
Public Enumeration GifFrameDisposal
Members
Member name | Description
None | No action is taken.
LeaveImage | Leaves the image in place when the next frame is drawn.
RestorePrevious | Restores the previous frame.
RestoreBackgroundColor | Restores the area occupied by the image with the animation background color.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifImageInfo Class

Summary description for PngImageInfo.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.CodecGifImageInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GifImageInfo : ImageInfo
Public Class GifImageInfo
    Inherits ImageInfo

The GifImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | GifImageInfo | Initializes a new instance of %GifImageInfo%.
Public method | GifImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Int32) | Initialize a new instance of %GifImageInfo% specifying it's properties.
Top
Properties
 | Name | Description
Public property | BackgroundIndex | Gets the background index in the GIF file.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | DelayTime | Gets or sets the amount of time to display this frame in milliseconds.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | FrameDisposal | Gets or sets the frame disposal method to use for this frame.
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | Interlaced | Gets a value indicating if the GIF is interlaced.
Public property | LeftOffset | Gets or sets the pixel offset from the left side of the animated screen area.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | TopOffset | Gets or sets the pixel offset from the top of the animated screen area.
Public property | TransparentIndex | Gets the transparent index of the Gif.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


GifImageInfo Constructor

Creates a GifImageInfo object.
Overload List
 | Name | Description
Public method | GifImageInfo | Initializes a new instance of %GifImageInfo%.
Public method | GifImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Int32) | Initialize a new instance of %GifImageInfo% specifying it's properties.
Top
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo Constructor

Initializes a new instance of %GifImageInfo%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifImageInfo()
Public Sub New
See Also

Reference

GifImageInfo Class
GifImageInfo Overload
Atalasoft.Imaging.Codec Namespace


GifImageInfo Constructor (Size, Int32, ImageType, Dpi, PixelFormat, Int32)

Initialize a new instance of %GifImageInfo% specifying it's properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifImageInfo(
    Size size,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat,
    int transIndex
)
Public Sub New (
    size As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat,
    transIndex As Integer
)

Parameters

size
Type: System.DrawingSize
The width and height of the image.
colorDepth
Type: SystemInt32
The bits per pixel of the image.
imageType
Type: Atalasoft.Imaging.CodecImageType
The image type.
resolution
Type: Atalasoft.ImagingDpi
The image resolution, usually expressed in dots per inch.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat which will be returned when the image is read.
transIndex
Type: SystemInt32
The transparent pixel index.
See Also

Reference

GifImageInfo Class
GifImageInfo Overload
Atalasoft.Imaging.Codec Namespace


GifImageInfo Properties

The GifImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundIndex | Gets the background index in the GIF file.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | DelayTime | Gets or sets the amount of time to display this frame in milliseconds.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | FrameDisposal | Gets or sets the frame disposal method to use for this frame.
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | Interlaced | Gets a value indicating if the GIF is interlaced.
Public property | LeftOffset | Gets or sets the pixel offset from the left side of the animated screen area.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | TopOffset | Gets or sets the pixel offset from the top of the animated screen area.
Public property | TransparentIndex | Gets the transparent index of the Gif.
Top
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.BackgroundIndex Property

GifImageInfoBackgroundIndex Property

Gets the background index in the GIF file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BackgroundIndex { get; }
Public ReadOnly Property BackgroundIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.DelayTime Property

GifImageInfoDelayTime Property

Gets or sets the amount of time to display this frame in milliseconds.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DelayTime { get; }
Public ReadOnly Property DelayTime As Integer
    Get

Property Value

Type: Int32
The amount of time to display this frame in milliseconds.
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.FrameDisposal Property

GifImageInfoFrameDisposal Property

Gets or sets the frame disposal method to use for this frame.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GifFrameDisposal FrameDisposal { get; }
Public ReadOnly Property FrameDisposal As GifFrameDisposal
    Get

Property Value

Type: GifFrameDisposal
The frame disposal method to use for this frame.
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.Interlaced Property

GifImageInfoInterlaced Property

Gets a value indicating if the GIF is interlaced.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Interlaced { get; }
Public ReadOnly Property Interlaced As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.LeftOffset Property

GifImageInfoLeftOffset Property

Gets or sets the pixel offset from the left side of the animated screen area.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LeftOffset { get; }
Public ReadOnly Property LeftOffset As Integer
    Get

Property Value

Type: Int32
The pixel offset from the left side of the animated screen area.
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.TopOffset Property

GifImageInfoTopOffset Property

Gets or sets the pixel offset from the top of the animated screen area.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TopOffset { get; }
Public ReadOnly Property TopOffset As Integer
    Get

Property Value

Type: Int32
The pixel offset from the top of the animated screen area.
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo.TransparentIndex Property

GifImageInfoTransparentIndex Property

Gets the transparent index of the Gif.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TransparentIndex { get; }
Public ReadOnly Property TransparentIndex As Integer
    Get

Property Value

Type: Int32
The transparent index of the Gif.
Remarks
This value may be -1 if no transparent index is used.
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


GifImageInfo Methods

The GifImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

GifImageInfo Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder Class

Decoder for HEIF files.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.CodecHeifDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HeifDecoder : MultiFramedImageDecoder
Public Class HeifDecoder
    Inherits MultiFramedImageDecoder

The HeifDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | HeifDecoder | Initializes a new instance of HeifDecoder class.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHeifDocument | Provides an access to HEIF files data.
Public method | GetImageInfo(Stream) | Retrieves information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
HeifDecoder allows to read master images from HEIF files the same way as other decoders provided by the SDK:
Using as regular decoder
Copy
var imagesCount = heifDecoder.GetFrameCount(stream);
for (int i = 0; i < imagesCount; i++)
{
    using (var atalaImage = heifDecoder.Read(stream, i, null))
    {
        // .. process image here
    }
}
or HEIF images can be loaded indirectly using AtalaImage class constructor:
Loading HEIF images indirectly
Copy
RegisteredDecoders.Decoders.Add(heifDecoder);

using (var atalaImage = new AtalaImage(stream))
{
    // .. process image here
}
In order to get access to auxiliary images, thumbnails, etc. GetHeifDocument(Stream, ProgressEventHandler) method should be used:
Getting additional info from HEIF
Copy
var heifDocument = heifDecoder.GetHeifDocument(stream, null);
foreach (var heifImage in heifDocument.HeifImages)
{
    // reading auxiliary images
    foreach (var auxiliaryImage in heifImage.AuxiliaryImages)
    {
        // process auxiliary image
    }

    // retrieve AtalaImage
    var atalaImage = heifImage.GetImage();
}
The following sample illustrates how to print exif and XML metadata.
Print exif and XMP metadata
Copy
using (var document = heifDecoder.GetHeifDocument(stream, null))
{
    foreach (var heifImage in document.HeifImages)
    {
        foreach (var metadata in heifImage.Metadata)
        {
            if (metadata.Type.Equals("exif", StringComparison.CurrentCultureIgnoreCase))
            {
                var exifCollection = metadata.AsExifCollection();
                foreach (ExifTag exifTag in exifCollection)
                {
                    Console.WriteLine(exifTag.ToString());
                }
            } else if (metadata.Type.Equals("mime", StringComparison.CurrentCultureIgnoreCase) &&
                       metadata.ContentType.Equals("application/rdf+xml",
                           StringComparison.CurrentCultureIgnoreCase))
            {
                var doc = new XmlDocument();
                doc.LoadXml(System.Text.Encoding.UTF8.GetString(metadata.Data));

                StringWriter sw = new StringWriter();
                doc.Save(sw);

                Console.WriteLine(sw.ToString());
            }
        }
    }
}
See Also

Reference

Atalasoft.Imaging.Codec Namespace


HeifDecoder Constructor

Initializes a new instance of HeifDecoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HeifDecoder()
Public Sub New
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder Properties

The HeifDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder Methods

The HeifDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHeifDocument | Provides an access to HEIF files data.
Public method | GetImageInfo(Stream) | Retrieves information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder.GetFrameCount Method

HeifDecoderGetFrameCount Method

Returns the number of frames in the image

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The input Stream.

Return Value

Type: Int32
The number of frames in the image
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder.GetHeifDocument Method

HeifDecoderGetHeifDocument Method

Provides an access to HEIF files data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HeifDocument GetHeifDocument(
    Stream stream,
    ProgressEventHandler progress
)
Public Function GetHeifDocument (
    stream As Stream,
    progress As ProgressEventHandler
) As HeifDocument

Parameters

stream
Type: System.IOStream
Stream that contains HEIF data.
progress
Type: Atalasoft.ImagingProgressEventHandler
Progress event handler.

Return Value

Type: HeifDocument
Instance of HeifDocument class.
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder.GetImageInfo Method

HeifDecoderGetImageInfo Method

Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retrieves information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder.GetImageInfo Method (Stream)

HeifDecoderGetImageInfo Method (Stream)

Retrieves information from an image stored in a file without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image such as size and bitdepth.
See Also

Reference

HeifDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


HeifDecoder.GetImageInfo Method (Stream, Int32)

HeifDecoderGetImageInfo Method (Stream, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.

Return Value

Type: ImageInfo
See Also

Reference

HeifDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


HeifDecoder.IsValidFormat Method

HeifDecoderIsValidFormat Method

Checks the stream to determine if the image can be read by the decoder that derives this class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
True if the encoded image can be read by this decoder, otherwise false.
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder.Read Method

HeifDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

HeifDecoder Class
Atalasoft.Imaging.Codec Namespace


HeifDecoder.Read Method (Stream, ProgressEventHandler)

HeifDecoderRead Method (Stream, ProgressEventHandler)

Decode an image in a specified image Stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the decoded image.
See Also

Reference

HeifDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


HeifDecoder.Read Method (Stream, Int32, ProgressEventHandler)

HeifDecoderRead Method (Stream, Int32, ProgressEventHandler)

Read a given frame in an encoded image using this decoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

HeifDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


IAnnotationEncoder Interface

Used with encoders that support saving XMP data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAnnotationEncoder
Public Interface IAnnotationEncoder
See Also

Reference

Atalasoft.Imaging.Codec Namespace


IAppendable Interface

An interface that an ImageEncoder can implement when it supports appending an image to the end of an existing file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IAppendable
Public Interface IAppendable

The IAppendable type exposes the following members.

Properties
 | Name | Description
Public property | Append | Gets or sets a value indicating if the image will be appended to the end of a file.
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


IAppendable Properties

The IAppendable type exposes the following members.

Properties
 | Name | Description
Public property | Append | Gets or sets a value indicating if the image will be appended to the end of a file.
Top
See Also

Reference

IAppendable Interface
Atalasoft.Imaging.Codec Namespace


IAppendable.Append Property

IAppendableAppend Property

Gets or sets a value indicating if the image will be appended to the end of a file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Append { get; set; }
Property Append As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the image will be appended to the end of a file.
See Also

Reference

IAppendable Interface
Atalasoft.Imaging.Codec Namespace


ImageDecoder Class

An abstract (MustInherit in Visual Basic) base class that defines a file format decoder to read an image from a Stream. All image decoders used in dotImage must inherit this class.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
More...

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ImageDecoder
Public MustInherit Class ImageDecoder

The ImageDecoder type exposes the following members.

Constructors
 | Name | Description
Protected method | ImageDecoder | Initializes a new instance of the ImageDecoder class.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retrieves information from an image stored in a file without decoding the image data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Decode an image in a specified image Stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
To load an image from a stream, the AtalaImage constructor may be used, and passing in a string filename, or a Stream. See the examples below
Examples

Load an image from a Stream

Load an image from a Stream (C#)
Copy
FileStream fs = System.IO.File.OpenRead(@"c:\test.tif");
AtalaImage image = new AtalaImage(fs);
Load an image from a Stream (Visual Basic)
Copy
Dim fs As FileStream = System.IO.File.OpenRead("c:\test.tif")
Dim image As AtalaImage = New AtalaImage(fs);

Load an image from a file

Load an image from a file (C#)
Copy
AtalaImage image = new AtalaImage(@"c:\test.tif");
Load an image from a file (Visual Basic)
Copy
Dim image As AtalaImage = New AtalaImage("c:\test.tif");
See Also

Reference

Atalasoft.Imaging.Codec Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecBmpDecoder
Atalasoft.Imaging.CodecEmfDecoder
Atalasoft.Imaging.Codec.Jpeg2000Jp2Decoder
Atalasoft.Imaging.CodecJpegDecoder
Atalasoft.Imaging.CodecJpegXrDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.CodecPcdDecoder
Atalasoft.Imaging.CodecPcxDecoder
Atalasoft.Imaging.CodecPngDecoder
Atalasoft.Imaging.CodecPnmDecoder
Atalasoft.Imaging.CodecPsdDecoder
Atalasoft.Imaging.CodecRawDecoder
Atalasoft.Imaging.CodecTgaDecoder
Atalasoft.Imaging.CodecTlaDecoder
Atalasoft.Imaging.CodecWbmpDecoder
Atalasoft.Imaging.CodecWmfDecoder


ImageDecoder Constructor

Initializes a new instance of the ImageDecoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageDecoder()
Protected Sub New
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageDecoder Properties

The ImageDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports.
Top
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageDecoder.SupportedImageType Property

ImageDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns the ImageType that the implemented decoder class supports.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public virtual ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overridable ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
The ImageType that the implemented decoder class supports.
Remarks
If the decoder supports a format not included with dotImage, then this will return Unknown.
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageDecoder Methods

The ImageDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retrieves information from an image stored in a file without decoding the image data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Decode an image in a specified image Stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageDecoder.GetImageInfo Method

ImageDecoderGetImageInfo Method

Retrieves information from an image stored in a file without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract ImageInfo GetImageInfo(
    Stream stream
)
Public MustOverride Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image such as size and bitdepth.
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageDecoder.IsValidFormat Method

ImageDecoderIsValidFormat Method

Checks the stream to determine if the image can be read by the decoder that derives this class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool IsValidFormat(
    Stream stream
)
Public MustOverride Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
True if the encoded image can be read by this decoder, otherwise false.
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageDecoder.Read Method

ImageDecoderRead Method

Decode an image in a specified image Stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public MustOverride Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the decoded image.
See Also

Reference

ImageDecoder Class
Atalasoft.Imaging.Codec Namespace


ImageEncoder Class

An abstract (MustInherit in Visual Basic) base class that defines a file format encoder to save an image to a file. All image encoders used in dotImage must inherit this class.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
More...

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ImageEncoder
Public MustInherit Class ImageEncoder

The ImageEncoder type exposes the following members.

Constructors
 | Name | Description
Protected method | ImageEncoder | Initializes a new instance of the ImageEncoder class
Top
Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save an image using this encoder.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecBmpEncoder
Atalasoft.Imaging.CodecEmfEncoder
Atalasoft.Imaging.CodecEpsEncoder
Atalasoft.Imaging.CodecGifEncoder
Atalasoft.Imaging.Codec.Jpeg2000Jp2Encoder
Atalasoft.Imaging.Codec.Jpeg2000Jpeg2000Encoder
Atalasoft.Imaging.CodecJpegEncoder
Atalasoft.Imaging.CodecJpegXrEncoder
Atalasoft.Imaging.CodecMultiFramedImageEncoder
Atalasoft.Imaging.CodecPcxEncoder
Atalasoft.Imaging.CodecPngEncoder
Atalasoft.Imaging.CodecPnmEncoder
Atalasoft.Imaging.CodecPsdEncoder
Atalasoft.Imaging.CodecTgaEncoder
Atalasoft.Imaging.CodecTlaEncoder
Atalasoft.Imaging.CodecWbmpEncoder
Atalasoft.Imaging.CodecWmfEncoder


ImageEncoder Constructor

Initializes a new instance of the ImageEncoder class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageEncoder()
Protected Sub New
See Also

Reference

ImageEncoder Class
Atalasoft.Imaging.Codec Namespace


ImageEncoder Properties

The ImageEncoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder.
Top
See Also

Reference

ImageEncoder Class
Atalasoft.Imaging.Codec Namespace


ImageEncoder.SupportedPixelFormats Property

ImageEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract PixelFormat[] SupportedPixelFormats { get; }
Public MustOverride ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ImageEncoder Class
Atalasoft.Imaging.Codec Namespace


ImageEncoder Methods

The ImageEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save an image using this encoder.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageEncoder Class
Atalasoft.Imaging.Codec Namespace


ImageEncoder.IsPixelFormatSupported Method

ImageEncoderIsPixelFormatSupported Method

Returns true if the given PixelFormat can be encoded with the derived encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPixelFormatSupported(
    PixelFormat format
)
Public Function IsPixelFormatSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat
The PixelFormat

Return Value

Type: Boolean
See Also

Reference

ImageEncoder Class
Atalasoft.Imaging.Codec Namespace


ImageEncoder.Save Method

ImageEncoderSave Method

Save an image using this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public MustOverride Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream containing the file which the image will be encoded to.
image
Type: Atalasoft.ImagingAtalaImage
The image to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The number of bytes written to the file.
See Also

Reference

ImageEncoder Class
Atalasoft.Imaging.Codec Namespace


ImageInfo Class

Contains information from an encoded image file.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
More...

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageInfo
Public Class ImageInfo

The ImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageInfo(Size, Int32, ImageType, Dpi, PixelFormat) | Initialize a new instance of ImageInfo specifying its properties.
Public method | ImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Int32) | Initialize a new instance of ImageInfo specifying its properties for a multi-frame image.
Top
Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded.
Public property | FrameCount | The number of frames/images/pages in the file.
Public property | ImageType | Obsolete. The file format.
Public property | PixelFormat | The PixelFormat of the image, as loaded.
Public property | Resolution | The image resolution, usually in dots per inch.
Public property | Size | The width and height of the image, as loaded.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.Codec.CadCamDwgImageInfo
Atalasoft.Imaging.CodecGifImageInfo
Atalasoft.Imaging.Codec.Jpeg2000Jp2ImageInfo
Atalasoft.Imaging.CodecJpegImageInfo
Atalasoft.Imaging.Codec.OfficeOfficeImageInfo
Atalasoft.Imaging.Codec.PdfPdfImageInfo
Atalasoft.Imaging.CodecPngImageInfo
Atalasoft.Imaging.CodecPnmImageInfo
Atalasoft.Imaging.CodecRawImageInfo


ImageInfo Constructor

Overload List
 | Name | Description
Public method | ImageInfo(Size, Int32, ImageType, Dpi, PixelFormat) | Initialize a new instance of ImageInfo specifying its properties.
Public method | ImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Int32) | Initialize a new instance of ImageInfo specifying its properties for a multi-frame image.
Top
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo Constructor (Size, Int32, ImageType, Dpi, PixelFormat)

Initialize a new instance of ImageInfo specifying its properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInfo(
    Size size,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat
)
Public Sub New (
    size As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat
)

Parameters

size
Type: System.DrawingSize
The width and height of the image, as loaded.
colorDepth
Type: SystemInt32
The bits per pixel of the image, as loaded.
imageType
Type: Atalasoft.Imaging.CodecImageType
The format of the image file.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the image (usually expressed in dots per inch).
pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat of the image, as loaded.
See Also

Reference

ImageInfo Class
ImageInfo Overload
Atalasoft.Imaging.Codec Namespace


ImageInfo Constructor (Size, Int32, ImageType, Dpi, PixelFormat, Int32)

Initialize a new instance of ImageInfo specifying its properties for a multi-frame image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInfo(
    Size size,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat,
    int frameCount
)
Public Sub New (
    size As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat,
    frameCount As Integer
)

Parameters

size
Type: System.DrawingSize
The width and height of the image, as loaded.
colorDepth
Type: SystemInt32
The bits per pixel of the image, as loaded.
imageType
Type: Atalasoft.Imaging.CodecImageType
The format of the image file.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the image (usually expressed in dots per inch).
pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat of the image, as loaded.
frameCount
Type: SystemInt32

The number of frames/images/pages in the file.

See Also

Reference

ImageInfo Class
ImageInfo Overload
Atalasoft.Imaging.Codec Namespace


ImageInfo Properties

The ImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded.
Public property | FrameCount | The number of frames/images/pages in the file.
Public property | ImageType | Obsolete. The file format.
Public property | PixelFormat | The PixelFormat of the image, as loaded.
Public property | Resolution | The image resolution, usually in dots per inch.
Public property | Size | The width and height of the image, as loaded.
Top
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.ColorDepth Property

ImageInfoColorDepth Property

The bits per pixel of the image, as loaded.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ColorDepth { get; }
Public ReadOnly Property ColorDepth As Integer
    Get

Property Value

Type: Int32
The bits per pixel of the image, as loaded.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.FrameCount Property

ImageInfoFrameCount Property

The number of frames/images/pages in the file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameCount { get; }
Public ReadOnly Property FrameCount As Integer
    Get

Property Value

Type: Int32
The number of frames/images/pages in the file.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.ImageType Property

ImageInfoImageType Property

Note: This API is now obsolete.

The file format.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ImageType enumeration has been deprecated. It is not a reliable way to get information about image type. Use RegisteredDecoders.GetDecoder(stream) to retrieve information about decoder that can read an image.",
    false)]
public ImageType ImageType { get; }
<ObsoleteAttribute("The ImageType enumeration has been deprecated. It is not a reliable way to get information about image type. Use RegisteredDecoders.GetDecoder(stream) to retrieve information about decoder that can read an image.",
    false)>
Public ReadOnly Property ImageType As ImageType
    Get

Property Value

Type: ImageType
The file format.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.PixelFormat Property

ImageInfoPixelFormat Property

The PixelFormat of the image, as loaded.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat PixelFormat { get; }
Public ReadOnly Property PixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat
The PixelFormat of the image (as loaded).
Remarks
The pixel format as loaded might be different then the format of the image in the file. dotImage will do its best to read to the native pixel format and colordepth.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.Resolution Property

ImageInfoResolution Property

The image resolution, usually in dots per inch.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; }
Public ReadOnly Property Resolution As Dpi
    Get

Property Value

Type: Dpi
The image resolution. Usually units == DotsPerInch but not always.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.Size Property

ImageInfoSize Property

The width and height of the image, as loaded.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get

Property Value

Type: Size
The width and height of the image.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo Methods

The ImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageInfo.ToString Method

ImageInfoToString Method

Returns a String that represents this instance.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

ImageInfo Class
Atalasoft.Imaging.Codec Namespace


ImageReadException Class

This exception is thrown when there is a problem reading an image
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.CodecImageReadException

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImageReadException : Exception
<SerializableAttribute>
Public Class ImageReadException
    Inherits Exception

The ImageReadException type exposes the following members.

Constructors
 | Name | Description
Public method | ImageReadException | Creates a new instance of ImageReadException.
Public method | ImageReadException(String) | Creates a new instance of ImageReadException specifying the exception message.
Protected method | ImageReadException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageReadException class.
Public method | ImageReadException(String, Exception) | Creates a new instance of ImageReadException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


ImageReadException Constructor

Creates an ImageReadException object.
Overload List
 | Name | Description
Public method | ImageReadException | Creates a new instance of ImageReadException.
Public method | ImageReadException(String) | Creates a new instance of ImageReadException specifying the exception message.
Protected method | ImageReadException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageReadException class.
Public method | ImageReadException(String, Exception) | Creates a new instance of ImageReadException specifying the exception message and inner exception.
Top
See Also

Reference

ImageReadException Class
Atalasoft.Imaging.Codec Namespace


ImageReadException Constructor

Creates a new instance of ImageReadException.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageReadException()
Public Sub New
See Also

Reference

ImageReadException Class
ImageReadException Overload
Atalasoft.Imaging.Codec Namespace


ImageReadException Constructor (String)

Creates a new instance of ImageReadException specifying the exception message.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageReadException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

ImageReadException Class
ImageReadException Overload
Atalasoft.Imaging.Codec Namespace


ImageReadException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageReadException class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageReadException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

ImageReadException Class
ImageReadException Overload
Atalasoft.Imaging.Codec Namespace


ImageReadException Constructor (String, Exception)

Creates a new instance of ImageReadException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageReadException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
See Also

Reference

ImageReadException Class
ImageReadException Overload
Atalasoft.Imaging.Codec Namespace


ImageReadException Properties

The ImageReadException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageReadException Class
Atalasoft.Imaging.Codec Namespace


ImageReadException Methods

The ImageReadException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageReadException Class
Atalasoft.Imaging.Codec Namespace


ImageReadException Events

The ImageReadException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ImageReadException Class
Atalasoft.Imaging.Codec Namespace


ImageType Enumeration

Note: This API is now obsolete.

The supported image file formats that dotImage can either read or write.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ImageType enumeration has been deprecated. Use it only if you must for backward compatibility reasons. ImageType is not extensible and does not contain entries for all supported image formats. DotImage toolkit usually provides better API alternatives that use ImageEncoder and ImageDecoder subclasses instead.",
    false)]
public enum ImageType
<ObsoleteAttribute("The ImageType enumeration has been deprecated. Use it only if you must for backward compatibility reasons. ImageType is not extensible and does not contain entries for all supported image formats. DotImage toolkit usually provides better API alternatives that use ImageEncoder and ImageDecoder subclasses instead.",
    false)>
Public Enumeration ImageType
Members
Member name | Description
Unknown | Image file format is undefined
Jpeg | Joint Photographic Experts Group. Uses lossy compression commonly used for Photographic type images. Read and Write.
Png | Portable Network Graphic supporting lossless compression. Read and Write.
Tiff | Tagged Image File. This is a universal and well known format for many uses inluding FAX and multipaged images. Read and Write.
Pcx | ZSoft PaintBrush. Read and Write.
Tga | Truevision Targa. May include an alpha channel. Read and Write.
Bmp | Windows Bitmap. Read and Write.
Wmf | Windows Meta File. Read and Write (raster only).
Emf | Enhanced Windows Meta File. Read and Write (raster only).
Psd | Adobe (tm) Photoshop format. Read and Write (flattened image only).
Wbmp | Wireless Bitmap. Black and White format used with portable devices. Read and Write
Gif | Graphics Interchange Format (LZW license required). Read and Write.
Tla | A lossless compressed image format similar to PNG with optional encryption. It can store 32, 24, 16, or 8-bit data.
Pcd | Kodak (tm) PhotoCD. Read only.
J2k | Jpeg2000. Separate Plug-In requred to read and write.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


ImageWriteException Class

This exception is thrown when there is a problem writing an image
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.CodecImageWriteException

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImageWriteException : Exception
<SerializableAttribute>
Public Class ImageWriteException
    Inherits Exception

The ImageWriteException type exposes the following members.

Constructors
 | Name | Description
Public method | ImageWriteException | Creates a new instance of ImageWriteException.
Public method | ImageWriteException(String) | Creates a new instance of ImageWriteException specifying the exception message.
Protected method | ImageWriteException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageWriteException class.
Public method | ImageWriteException(String, Exception) | Creates a new instance of ImageWriteException specifying the exception message and inner exception.
Public method | ImageWriteException(String, Int32) | Creates a new instance of ImageWriteException specifying the exception message and HResult.
Public method | ImageWriteException(String, Exception, Int32) | Creates a new instance of ImageWriteException specifying the exception message, inner exception and HResult.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor

Creates an ImageWriteException.
Overload List
 | Name | Description
Public method | ImageWriteException | Creates a new instance of ImageWriteException.
Public method | ImageWriteException(String) | Creates a new instance of ImageWriteException specifying the exception message.
Protected method | ImageWriteException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageWriteException class.
Public method | ImageWriteException(String, Exception) | Creates a new instance of ImageWriteException specifying the exception message and inner exception.
Public method | ImageWriteException(String, Int32) | Creates a new instance of ImageWriteException specifying the exception message and HResult.
Public method | ImageWriteException(String, Exception, Int32) | Creates a new instance of ImageWriteException specifying the exception message, inner exception and HResult.
Top
See Also

Reference

ImageWriteException Class
Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor

Creates a new instance of ImageWriteException.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageWriteException()
Public Sub New
See Also

Reference

ImageWriteException Class
ImageWriteException Overload
Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor (String)

Creates a new instance of ImageWriteException specifying the exception message.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageWriteException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

ImageWriteException Class
ImageWriteException Overload
Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageWriteException class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageWriteException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

ImageWriteException Class
ImageWriteException Overload
Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor (String, Exception)

Creates a new instance of ImageWriteException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageWriteException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
See Also

Reference

ImageWriteException Class
ImageWriteException Overload
Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor (String, Int32)

Creates a new instance of ImageWriteException specifying the exception message and HResult.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageWriteException(
    string message,
    int hresult
)
Public Sub New (
    message As String,
    hresult As Integer
)

Parameters

message
Type: SystemString
The exception message.
hresult
Type: SystemInt32
Exception HResult.
See Also

Reference

ImageWriteException Class
ImageWriteException Overload
Atalasoft.Imaging.Codec Namespace


ImageWriteException Constructor (String, Exception, Int32)

Creates a new instance of ImageWriteException specifying the exception message, inner exception and HResult.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageWriteException(
    string message,
    Exception innerException,
    int hresult
)
Public Sub New (
    message As String,
    innerException As Exception,
    hresult As Integer
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
hresult
Type: SystemInt32
Exception HResult.
See Also

Reference

ImageWriteException Class
ImageWriteException Overload
Atalasoft.Imaging.Codec Namespace


ImageWriteException Properties

The ImageWriteException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageWriteException Class
Atalasoft.Imaging.Codec Namespace


ImageWriteException Methods

The ImageWriteException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageWriteException Class
Atalasoft.Imaging.Codec Namespace


ImageWriteException Events

The ImageWriteException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ImageWriteException Class
Atalasoft.Imaging.Codec Namespace


IMultiFramedVectorDecoder Interface

Represents a codec that specializes in decoding a vector image file that can have multiple pages.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IMultiFramedVectorDecoder : IVectorDecoder
Public Interface IMultiFramedVectorDecoder
    Inherits IVectorDecoder
Methods
 | Name | Description
Public method | RasterizeScaledRegion(Stream, RectangleF, SizeF, ProgressEventHandler) | Renders a section of the file from the source rectangle into the destination rectangle. (Inherited from IVectorDecoder.)
Public method | RasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler) | Renders a section of the file from the source rectangle into the destination rectangle.
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


IMultiFramedVectorDecoder Methods

Methods
 | Name | Description
Public method | RasterizeScaledRegion(Stream, RectangleF, SizeF, ProgressEventHandler) | Renders a section of the file from the source rectangle into the destination rectangle. (Inherited from IVectorDecoder.)
Public method | RasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler) | Renders a section of the file from the source rectangle into the destination rectangle.
Top
See Also

Reference

IMultiFramedVectorDecoder Interface
Atalasoft.Imaging.Codec Namespace


IMultiFramedVectorDecoder.RasterizeScaledRegion Method

IMultiFramedVectorDecoderRasterizeScaledRegion Method

Overload List
 | Name | Description
Public method | RasterizeScaledRegion(Stream, RectangleF, SizeF, ProgressEventHandler) | Renders a section of the file from the source rectangle into the destination rectangle. (Inherited from IVectorDecoder.)
Public method | RasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler) | Renders a section of the file from the source rectangle into the destination rectangle.
Top
See Also

Reference

IMultiFramedVectorDecoder Interface
Atalasoft.Imaging.Codec Namespace


IMultiFramedVectorDecoder.RasterizeScaledRegion Method (Stream, Int32, RectangleF, SizeF, ProgressEventHandler)

IMultiFramedVectorDecoderRasterizeScaledRegion Method (Stream, Int32, RectangleF, SizeF, ProgressEventHandler)

Renders a section of the file from the source rectangle into the destination rectangle.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AtalaImage RasterizeScaledRegion(
    Stream stream,
    int frameIndex,
    RectangleF srcRect,
    SizeF dstSize,
    ProgressEventHandler progress
)
Function RasterizeScaledRegion (
    stream As Stream,
    frameIndex As Integer,
    srcRect As RectangleF,
    dstSize As SizeF,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream containing the vector file.
frameIndex
Type: SystemInt32
Index of the frame to render.
srcRect
Type: System.DrawingRectangleF
The source rectangle.
dstSize
Type: System.DrawingSizeF
Size of the destination rectangle.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress handler.

Return Value

Type: AtalaImage
See Also

Reference

IMultiFramedVectorDecoder Interface
RasterizeScaledRegion Overload
Atalasoft.Imaging.Codec Namespace


IRegionReadable Interface

This interface is applied to ImageDecoders to enable them to read a specified region of the image without decoding the entire image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IRegionReadable
Public Interface IRegionReadable

The IRegionReadable type exposes the following members.

Methods
 | Name | Description
Public method | ReadRegion | Decodes the specified region and returns an AtalaImage object representing the image data.
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


IRegionReadable Methods

The IRegionReadable type exposes the following members.

Methods
 | Name | Description
Public method | ReadRegion | Decodes the specified region and returns an AtalaImage object representing the image data.
Top
See Also

Reference

IRegionReadable Interface
Atalasoft.Imaging.Codec Namespace


IRegionReadable.ReadRegion Method

IRegionReadableReadRegion Method

Decodes the specified region and returns an AtalaImage object representing the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AtalaImage ReadRegion(
    Stream stream,
    Rectangle region,
    int frameIndex,
    ProgressEventHandler progress
)
Function ReadRegion (
    stream As Stream,
    region As Rectangle,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The encoded image stream.
region
Type: System.DrawingRectangle
The rectangular image to read.
frameIndex
Type: SystemInt32
The zero based frame index if the image supports multiple frames.
progress
Type: Atalasoft.ImagingProgressEventHandler
Progress Delegate

Return Value

Type: AtalaImage
See Also

Reference

IRegionReadable Interface
Atalasoft.Imaging.Codec Namespace


IScaledDecoder Interface

This interface is applied to ImageDecoders that have the ability to decode an image stream to a specified scale.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IScaledDecoder
Public Interface IScaledDecoder

The IScaledDecoder type exposes the following members.

Methods
 | Name | Description
Public method | GetBestScale | If the codec can efficiently generate a scaled image without actually resampling, this will return the closest scale given an input scale factor.
Public method | ReadScaled | Decodes an image to a specified scale.
Top
Remarks
Decoders that apply this interface are capable of reading extremely large images without loading the full size image into memory.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


IScaledDecoder Methods

The IScaledDecoder type exposes the following members.

Methods
 | Name | Description
Public method | GetBestScale | If the codec can efficiently generate a scaled image without actually resampling, this will return the closest scale given an input scale factor.
Public method | ReadScaled | Decodes an image to a specified scale.
Top
See Also

Reference

IScaledDecoder Interface
Atalasoft.Imaging.Codec Namespace


IScaledDecoder.GetBestScale Method

IScaledDecoderGetBestScale Method

If the codec can efficiently generate a scaled image without actually resampling, this will return the closest scale given an input scale factor.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double GetBestScale(
    Stream stream,
    int frameIndex,
    double requestedScale
)
Function GetBestScale (
    stream As Stream,
    frameIndex As Integer,
    requestedScale As Double
) As Double

Parameters

stream
Type: System.IOStream
The encoded image stream
frameIndex
Type: SystemInt32
The zero based frame index if the source image is multiframed
requestedScale
Type: SystemDouble
The scale to request

Return Value

Type: Double
The closest stored scale greater than or equal to the requested scale.
Remarks
This is most useful for images that have multiple resolutions stored within. JPEG's can quickly generate a scaled image 1/2, 1/4, 1/8, and 1/16 the original size and thus will return one of these sizes.
See Also

Reference

IScaledDecoder Interface
Atalasoft.Imaging.Codec Namespace


IScaledDecoder.ReadScaled Method

IScaledDecoderReadScaled Method

Decodes an image to a specified scale.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AtalaImage ReadScaled(
    Stream stream,
    int frameIndex,
    double scaleFactor,
    ProgressEventHandler progress
)
Function ReadScaled (
    stream As Stream,
    frameIndex As Integer,
    scaleFactor As Double,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The encoded image
frameIndex
Type: SystemInt32
The zero based frame index if the source image is multiframed
scaleFactor
Type: SystemDouble
The scale factor to request (ie. 0.5 is 1/2 scale, 1 is full scale)
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress callback

Return Value

Type: AtalaImage
See Also

Reference

IScaledDecoder Interface
Atalasoft.Imaging.Codec Namespace


IVectorDecoder Interface

Represents a codec that specializes in decoding a vector image file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IVectorDecoder
Public Interface IVectorDecoder

The IVectorDecoder type exposes the following members.

Methods
 | Name | Description
Public method | RasterizeScaledRegion | Renders a section of the file from the source rectangle into the destination rectangle.
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


IVectorDecoder Methods

The IVectorDecoder type exposes the following members.

Methods
 | Name | Description
Public method | RasterizeScaledRegion | Renders a section of the file from the source rectangle into the destination rectangle.
Top
See Also

Reference

IVectorDecoder Interface
Atalasoft.Imaging.Codec Namespace


IVectorDecoder.RasterizeScaledRegion Method

IVectorDecoderRasterizeScaledRegion Method

Renders a section of the file from the source rectangle into the destination rectangle.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
AtalaImage RasterizeScaledRegion(
    Stream stream,
    RectangleF srcRect,
    SizeF dstSize,
    ProgressEventHandler progress
)
Function RasterizeScaledRegion (
    stream As Stream,
    srcRect As RectangleF,
    dstSize As SizeF,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream containing the vector file.
srcRect
Type: System.DrawingRectangleF
The source rectangle.
dstSize
Type: System.DrawingSizeF
Size of the destination rectangle.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress handler.

Return Value

Type: AtalaImage
See Also

Reference

IVectorDecoder Interface
Atalasoft.Imaging.Codec Namespace


JpegDctMode Enumeration

The DCT compression used when saving a JPEG image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum JpegDctMode
Public Enumeration JpegDctMode
Members
Member name | Description
Default | The default compression; usually Slow.
Slow | Slow but accurate integer algorithm.
Fast | Faster, less accurate integer method.
FloatingPoint | Floating-point method.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegDecoder Class

An ImageDecoder used to read JPEG images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecJpegDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegDecoder : ImageDecoder,
    IScaledDecoder
Public Class JpegDecoder
    Inherits ImageDecoder
    Implements IScaledDecoder

The JpegDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | JpegDecoder | Initializes a new instance of a JpegDecoder.
Public method | JpegDecoder(JpegScaleFactor) | Initializes a new instance of a JpegDecoder specifying the Jpeg scaling factor.
Top
Properties
 | Name | Description
Public property | ScaleFactor | Gets or sets a value indicating the scale factor to use when reading Jpeg's.
Public property | SupportedImageType | Obsolete. Returns a Jpeg ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestScale | Gets the best scale given a requested scale factor. For a JPEG, this would result in either 1, 1/2, 1/4, 1/16, or 1/32
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Jpeg image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Jpeg image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Jpeg encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ReadScaled | Gets an AtalaImage of the requested scale.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Jpeg image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the %RegisteredDecoders% and does not have to be explicitly set.

Jpeg images can store metadata such as EXIF and IPTC into the images. See the %Atalasoft.Imaging.Metadata% namespace for more information on reading this information from a Jpeg image.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegDecoder Constructor

Creates a new JpegDecoder.
Overload List
 | Name | Description
Public method | JpegDecoder | Initializes a new instance of a JpegDecoder.
Public method | JpegDecoder(JpegScaleFactor) | Initializes a new instance of a JpegDecoder specifying the Jpeg scaling factor.
Top
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder Constructor

Initializes a new instance of a JpegDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegDecoder()
Public Sub New
See Also

Reference

JpegDecoder Class
JpegDecoder Overload
Atalasoft.Imaging.Codec Namespace


JpegDecoder Constructor (JpegScaleFactor)

Initializes a new instance of a JpegDecoder specifying the Jpeg scaling factor.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegDecoder(
    JpegScaleFactor scaleFactor
)
Public Sub New (
    scaleFactor As JpegScaleFactor
)

Parameters

scaleFactor
Type: Atalasoft.Imaging.CodecJpegScaleFactor
The Jpeg scaling factor to use when reading the image.
See Also

Reference

JpegDecoder Class
JpegDecoder Overload
Atalasoft.Imaging.Codec Namespace


JpegDecoder Properties

The JpegDecoder type exposes the following members.

Properties
 | Name | Description
Public property | ScaleFactor | Gets or sets a value indicating the scale factor to use when reading Jpeg's.
Public property | SupportedImageType | Obsolete. Returns a Jpeg ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.ScaleFactor Property

JpegDecoderScaleFactor Property

Gets or sets a value indicating the scale factor to use when reading Jpeg's.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegScaleFactor ScaleFactor { get; set; }
Public Property ScaleFactor As JpegScaleFactor
    Get
    Set

Property Value

Type: JpegScaleFactor
The scale factor to use when reading Jpeg's.
Remarks
The scale factor allows a Jpeg image to be read to a smaller sized image. This is a good quick way of creating thumbnails out of Jpeg images.
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.SupportedImageType Property

JpegDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Jpeg ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
ImageType.Jpeg
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder Methods

The JpegDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestScale | Gets the best scale given a requested scale factor. For a JPEG, this would result in either 1, 1/2, 1/4, 1/16, or 1/32
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Jpeg image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Jpeg image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Jpeg encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ReadScaled | Gets an AtalaImage of the requested scale.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.GetBestScale Method

JpegDecoderGetBestScale Method

Gets the best scale given a requested scale factor. For a JPEG, this would result in either 1, 1/2, 1/4, 1/16, or 1/32

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetBestScale(
    Stream stream,
    int frameIndex,
    double requestedScale
)
Public Function GetBestScale (
    stream As Stream,
    frameIndex As Integer,
    requestedScale As Double
) As Double

Parameters

stream
Type: System.IOStream
The encoded image stream
frameIndex
Type: SystemInt32
not used for JPEG's
requestedScale
Type: SystemDouble
The scale to request

Return Value

Type: Double

Implements

IScaledDecoderGetBestScale(Stream, Int32, Double)
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.GetImageInfo Method

JpegDecoderGetImageInfo Method

Retreive information from a Jpeg image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
Remarks
Many JPEG images do not contain valid resolution information. In these cases, the image info will contain a resolution of 96 pixels per inch.
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.IsValidFormat Method

JpegDecoderIsValidFormat Method

Returns true if the specified Stream contains a Jpeg image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.Read Method

JpegDecoderRead Method

Returns an AtalaImage from a Stream containing a Jpeg encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Remarks
Many JPEG images do not contain valid resolution information. In these cases, the image info will contain a resolution of 96 pixels per inch.
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegDecoder.ReadScaled Method

JpegDecoderReadScaled Method

Gets an AtalaImage of the requested scale.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ReadScaled(
    Stream stream,
    int frameIndex,
    double scaleFactor,
    ProgressEventHandler progress
)
Public Function ReadScaled (
    stream As Stream,
    frameIndex As Integer,
    scaleFactor As Double,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The encoded image
frameIndex
Type: SystemInt32
Not used for JPEG's
scaleFactor
Type: SystemDouble
The scale factor
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress delegate

Return Value

Type: AtalaImage

Implements

IScaledDecoderReadScaled(Stream, Int32, Double, ProgressEventHandler)
See Also

Reference

JpegDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder Class

An ImageEncoder that will write JPEG images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecJpegEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegEncoder : ImageEncoder,
    IAnnotationEncoder
Public Class JpegEncoder
    Inherits ImageEncoder
    Implements IAnnotationEncoder

The JpegEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | JpegEncoder | Initializes a new instance of a JpegEncoder.
Public method | JpegEncoder(Int32) | Initializes a new instance of the JpegEncoder specifying the quality.
Public method | JpegEncoder(Int32, Int32) | Initializes a new instance of a JpegEncoder specifying the quality and smoothing.
Public method | JpegEncoder(Int32, Int32, Boolean) | Initializes a new instance of a JpegEncoder specifying the quality, smoothing, and progressive value.
Top
Properties
 | Name | Description
Public property | AppMarkers | Gets or sets the JPEG APPn Markers that will be saved with the image.
Public property | ComText | Gets or sets COM Text Markers that are to be saved with the image.
Public property | DctMode | Gets or sets the DCT compression mode used for encoding.
Public property | ImageType | Get the ImageType associated with this Encoder Setting.
Public property | IptcTags | Gets or sets IPTC Metadata that will be saved with the image.
Public property | PhotoshopResources | Gets or sets Photoshop resources to be saved with the image.
Public property | Progressive | Gets or sets a value indicating if the image is saved progressively.
Public property | Quality | Gets or sets the quality level of the Jpeg as it's encoded to a file. Valid values are 1 - 100 with a default of 75.
Public property | Smoothing | Gets or sets the smoothing level when saving a Jpeg image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | Xmp | Gets or sets a byte array containing XMP data.
Top
Methods
 | Name | Description
 | CopyJpegWithNewMarkers(Stream, Stream) | Performs a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
 | CopyJpegWithNewMarkers(String, String) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
 | CopyJpegWithNewMarkers(Stream, Stream, JpegMarkerCopyFlags) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
 | CopyJpegWithNewMarkers(String, String, JpegMarkerCopyFlags) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Jpeg image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
 | SetDownsamplingFactors | Sets the downsampling factors used when compressing the image data. This will affect both quality and file size of the saved image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a JPEG image.

Metadata can be written with the JPEG image including EXIF, IPTC and COM Comments. See the Atalasoft.Imaging.Metadata namespace for more information.

If the image being saved contains a ColorProfile, it will be embedded within the file.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegEncoder Constructor

Creates a JpegEncoder.
Overload List
 | Name | Description
Public method | JpegEncoder | Initializes a new instance of a JpegEncoder.
Public method | JpegEncoder(Int32) | Initializes a new instance of the JpegEncoder specifying the quality.
Public method | JpegEncoder(Int32, Int32) | Initializes a new instance of a JpegEncoder specifying the quality and smoothing.
Public method | JpegEncoder(Int32, Int32, Boolean) | Initializes a new instance of a JpegEncoder specifying the quality, smoothing, and progressive value.
Top
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder Constructor

Initializes a new instance of a JpegEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegEncoder()
Public Sub New
See Also

Reference

JpegEncoder Class
JpegEncoder Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder Constructor (Int32)

Initializes a new instance of the JpegEncoder specifying the quality.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegEncoder(
    int quality
)
Public Sub New (
    quality As Integer
)

Parameters

quality
Type: SystemInt32
The quality level.
See Also

Reference

JpegEncoder Class
JpegEncoder Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder Constructor (Int32, Int32)

Initializes a new instance of a JpegEncoder specifying the quality and smoothing.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegEncoder(
    int quality,
    int smoothing
)
Public Sub New (
    quality As Integer,
    smoothing As Integer
)

Parameters

quality
Type: SystemInt32
The quality level.
smoothing
Type: SystemInt32
The smoothing level.
See Also

Reference

JpegEncoder Class
JpegEncoder Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder Constructor (Int32, Int32, Boolean)

Initializes a new instance of a JpegEncoder specifying the quality, smoothing, and progressive value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegEncoder(
    int quality,
    int smoothing,
    bool progressive
)
Public Sub New (
    quality As Integer,
    smoothing As Integer,
    progressive As Boolean
)

Parameters

quality
Type: SystemInt32
The quality level.
smoothing
Type: SystemInt32
The smoothing level.
progressive
Type: SystemBoolean
A value indicating if the image is saved progressively.
See Also

Reference

JpegEncoder Class
JpegEncoder Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder Properties

The JpegEncoder type exposes the following members.

Properties
 | Name | Description
Public property | AppMarkers | Gets or sets the JPEG APPn Markers that will be saved with the image.
Public property | ComText | Gets or sets COM Text Markers that are to be saved with the image.
Public property | DctMode | Gets or sets the DCT compression mode used for encoding.
Public property | ImageType | Get the ImageType associated with this Encoder Setting.
Public property | IptcTags | Gets or sets IPTC Metadata that will be saved with the image.
Public property | PhotoshopResources | Gets or sets Photoshop resources to be saved with the image.
Public property | Progressive | Gets or sets a value indicating if the image is saved progressively.
Public property | Quality | Gets or sets the quality level of the Jpeg as it's encoded to a file. Valid values are 1 - 100 with a default of 75.
Public property | Smoothing | Gets or sets the smoothing level when saving a Jpeg image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | Xmp | Gets or sets a byte array containing XMP data.
Top
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.AppMarkers Property

JpegEncoderAppMarkers Property

Gets or sets the JPEG APPn Markers that will be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarkerCollection AppMarkers { get; set; }
Public Property AppMarkers As JpegMarkerCollection
    Get
    Set

Property Value

Type: JpegMarkerCollection
The JPEG APPn Markers that will be saved with the image.
Remarks
Metadata can be preserved in the new image by setting this property to the JPEG Marker collection from the source image.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.ComText Property

JpegEncoderComText Property

Gets or sets COM Text Markers that are to be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextCollection ComText { get; set; }
Public Property ComText As ComTextCollection
    Get
    Set

Property Value

Type: ComTextCollection
COM Text Markers that are to be saved with the image.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.DctMode Property

JpegEncoderDctMode Property

Gets or sets the DCT compression mode used for encoding.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegDctMode DctMode { get; set; }
Public Property DctMode As JpegDctMode
    Get
    Set

Property Value

Type: JpegDctMode
The DCT compression.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.ImageType Property

JpegEncoderImageType Property

Get the ImageType associated with this Encoder Setting.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageType ImageType { get; }
Public ReadOnly Property ImageType As ImageType
    Get

Property Value

Type: ImageType
The ImageType associated with this Encoder Setting.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.IptcTags Property

JpegEncoderIptcTags Property

Gets or sets IPTC Metadata that will be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection IptcTags { get; set; }
Public Property IptcTags As IptcCollection
    Get
    Set

Property Value

Type: IptcCollection
IPTC Metadata that will be saved with the image.
Remarks
Setting this property to an IptcCollection allows IPTC tags to be added or inserted into a new JPEG image.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.PhotoshopResources Property

JpegEncoderPhotoshopResources Property

Gets or sets Photoshop resources to be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection PhotoshopResources { get; set; }
Public Property PhotoshopResources As PhotoshopResourceCollection
    Get
    Set

Property Value

Type: PhotoshopResourceCollection
Photoshop resources to be saved with the image.
Remarks
Photoshop saves information to the APP13 Jpeg Marker. This information can be parsed with the PhotoshopResourceParser. When PhotoshopResources and IptcTags are set to a value other than null, IptcData will be added to the PhotoshopResource when saved.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.Progressive Property

JpegEncoderProgressive Property

Gets or sets a value indicating if the image is saved progressively.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Progressive { get; set; }
Public Property Progressive As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the image is saved progressively.
Remarks
A progressive Jpeg will be displayed while it's being loaded from top down in supported viewers such as web browsers.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.Quality Property

JpegEncoderQuality Property

Gets or sets the quality level of the Jpeg as it's encoded to a file. Valid values are 1 - 100 with a default of 75.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Quality { get; set; }
Public Property Quality As Integer
    Get
    Set

Property Value

Type: Int32
The quality level of the Jpeg as it's encoded to a file.
Remarks
The lower the quality, the smaller the filesize. A good range of values is between 70 and 95.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.Smoothing Property

JpegEncoderSmoothing Property

Gets or sets the smoothing level when saving a Jpeg image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Smoothing { get; set; }
Public Property Smoothing As Integer
    Get
    Set

Property Value

Type: Int32
The smoothing level when saving a Jpeg image.
Remarks
Valid values are 0 to 100 with a default of 0. Increasing the smoothing value will tend to create smaller Jpeg files, however the image is blurred while saving.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.SupportedPixelFormats Property

JpegEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.Xmp Property

JpegEncoderXmp Property

Gets or sets a byte array containing XMP data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Xmp { get; set; }
Public Property Xmp As Byte()
    Get
    Set

Property Value

Type: Byte
A byte array containing XMP data.
Remarks
This property can be used to save XMP Annotation data created with DotImage, our full featured Annotations toolkit for the Microsoft .NET Framework.
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder Methods

The JpegEncoder type exposes the following members.

Methods
 | Name | Description
 | CopyJpegWithNewMarkers(Stream, Stream) | Performs a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
 | CopyJpegWithNewMarkers(String, String) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
 | CopyJpegWithNewMarkers(Stream, Stream, JpegMarkerCopyFlags) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
 | CopyJpegWithNewMarkers(String, String, JpegMarkerCopyFlags) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Jpeg image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
 | SetDownsamplingFactors | Sets the downsampling factors used when compressing the image data. This will affect both quality and file size of the saved image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.CopyJpegWithNewMarkers Method

JpegEncoderCopyJpegWithNewMarkers Method

These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
Examples
[New Example] (C#)
Copy
IptcCollection iptc = new IptcCollection();
iptc.Add(new IptcTag(2, 25, 0, "Testing CopyJpegMarkers"));
FileStream fsIn = new FileStream("myimageIn.jpg", FileMode.Open, FileAccess.Read);
FileStream fsOut = new FileStream("myimageOut.jpg", FileMode.Create, FileAccess.Write);
JpegEncoder jpeg = new JpegEncoder();
jpeg.IptcTags = iptc;
jpeg.CopyJpegWithNewMarkers(fsIn,fsOut);
fsIn.Close();
fsOut.Close();
[New Example] (Visual Basic)
Copy
Dim iptc As IptcCollection = new IptcCollection()
iptc.Add(New IptcTag(2, 25, 0, "Testing CopyJpegMarkers"))
Dim fsIn As FileStream = New FileStream("myimageIn.jpg", FileMode.Open, FileAccess.Read)
Dim fsOut As FileStream = New FileStream("myimageOut.jpg", FileMode.Create, FileAccess.Write)
Dim jpeg As JpegEncoder = New JpegEncoder()
jpeg.IptcTags = iptc
jpeg.CopyJpegWithNewMarkers(fsIn, fsOut)
fsIn.Close()
fsOut.Close()
Overload List
Name | Description
CopyJpegWithNewMarkers(Stream, Stream) | Performs a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
CopyJpegWithNewMarkers(String, String) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
CopyJpegWithNewMarkers(Stream, Stream, JpegMarkerCopyFlags) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
CopyJpegWithNewMarkers(String, String, JpegMarkerCopyFlags) | These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.
Top
Examples
[New Example] (C#)
Copy
IptcCollection iptc = new IptcCollection();
iptc.Add(new IptcTag(2, 25, 0, "Testing CopyJpegMarkers"));
FileStream fsIn = new FileStream("myimageIn.jpg", FileMode.Open, FileAccess.Read);
FileStream fsOut = new FileStream("myimageOut.jpg", FileMode.Create, FileAccess.Write);
JpegEncoder jpeg = new JpegEncoder();
jpeg.IptcTags = iptc;
jpeg.CopyJpegWithNewMarkers(fsIn,fsOut);
fsIn.Close();
fsOut.Close();
[New Example] (Visual Basic)
Copy
Dim iptc As IptcCollection = new IptcCollection()
iptc.Add(New IptcTag(2, 25, 0, "Testing CopyJpegMarkers"))
Dim fsIn As FileStream = New FileStream("myimageIn.jpg", FileMode.Open, FileAccess.Read)
Dim fsOut As FileStream = New FileStream("myimageOut.jpg", FileMode.Create, FileAccess.Write)
Dim jpeg As JpegEncoder = New JpegEncoder()
jpeg.IptcTags = iptc
jpeg.CopyJpegWithNewMarkers(fsIn, fsOut)
fsIn.Close()
fsOut.Close()
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.CopyJpegWithNewMarkers Method (Stream, Stream)

JpegEncoderCopyJpegWithNewMarkers Method (Stream, Stream)

Performs a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyJpegWithNewMarkers(
    Stream source,
    Stream dest
)
Public Sub CopyJpegWithNewMarkers (
    source As Stream,
    dest As Stream
)

Parameters

source
Type: System.IOStream
The source image stream to copy from.
dest
Type: System.IOStream
The destintation image stream to copy to.
Remarks
By saving the APP1 Jpeg marker, EXIF, IPTC, and COM data can be copied to existing images, without the need to recompress the image data. This method does not overwrite existing JPEG images, but creates a copy of the existing JPEG data. The original image could be deleted if this method succeeds.
Examples
CopyJpegWithNewMarkers Method
See Also

Reference

JpegEncoder Class
CopyJpegWithNewMarkers Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder.CopyJpegWithNewMarkers Method (String, String)

JpegEncoderCopyJpegWithNewMarkers Method (String, String)

These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyJpegWithNewMarkers(
    string source,
    string dest
)
Public Sub CopyJpegWithNewMarkers (
    source As String,
    dest As String
)

Parameters

source
Type: SystemString
The source image filename to copy from.
dest
Type: SystemString
The destintation image filename to copy to.
Remarks
By saving the APP1 Jpeg marker, EXIF, IPTC, and COM data can be copied to existing images, without the need to recompress the image data. This method does not overwrite existing JPEG images, but creates a copy of the existing JPEG data. The original image could be deleted if this method succeeds.
Remarks
By saving the APP1 Jpeg marker, EXIF, IPTC, and COM data can be copied to existing images, without the need to recompress the image data. This method does not overwrite existing JPEG images, but creates a copy of the existing JPEG data. The original image could be deleted if this method succeeds.
Examples
CopyJpegWithNewMarkers Method
See Also

Reference

JpegEncoder Class
CopyJpegWithNewMarkers Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder.CopyJpegWithNewMarkers Method (Stream, Stream, JpegMarkerCopyFlags)

JpegEncoderCopyJpegWithNewMarkers Method (Stream, Stream, JpegMarkerCopyFlags)

These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyJpegWithNewMarkers(
    Stream source,
    Stream dest,
    JpegMarkerCopyFlags flags
)
Public Sub CopyJpegWithNewMarkers (
    source As Stream,
    dest As Stream,
    flags As JpegMarkerCopyFlags
)

Parameters

source
Type: System.IOStream
The source image stream to copy from.
dest
Type: System.IOStream
The destintation image stream to copy to.
flags
Type: Atalasoft.Imaging.MetadataJpegMarkerCopyFlags
Specifies the metadata to copy into the new image.
Remarks
By saving the APP1 Jpeg marker, EXIF, IPTC, and COM data can be copied to existing images, without the need to recompress the image data. This method does not overwrite existing JPEG images, but creates a copy of the existing JPEG data. The original image could be deleted if this method succeeds.
Examples
CopyJpegWithNewMarkers Method
See Also

Reference

JpegEncoder Class
CopyJpegWithNewMarkers Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder.CopyJpegWithNewMarkers Method (String, String, JpegMarkerCopyFlags)

JpegEncoderCopyJpegWithNewMarkers Method (String, String, JpegMarkerCopyFlags)

These methods perform a lossless copy of the JPEG image data into a new image while replacing the JPEG metadata with new metadata.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyJpegWithNewMarkers(
    string source,
    string dest,
    JpegMarkerCopyFlags flags
)
Public Sub CopyJpegWithNewMarkers (
    source As String,
    dest As String,
    flags As JpegMarkerCopyFlags
)

Parameters

source
Type: SystemString
The source image filename to copy from.
dest
Type: SystemString
The destintation image filename to copy to.
flags
Type: Atalasoft.Imaging.MetadataJpegMarkerCopyFlags
Specifies the metadata to copy into the new image.
Remarks
By saving the APP1 Jpeg marker, EXIF, IPTC, and COM data can be copied to existing images, without the need to recompress the image data. This method does not overwrite existing JPEG images, but creates a copy of the existing JPEG data. The original image could be deleted if this method succeeds.
Examples
CopyJpegWithNewMarkers Method
See Also

Reference

JpegEncoder Class
CopyJpegWithNewMarkers Overload
Atalasoft.Imaging.Codec Namespace


JpegEncoder.Save Method

JpegEncoderSave Method

Encode an AtalaImage as a Jpeg image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegEncoder.SetDownsamplingFactors Method

JpegEncoderSetDownsamplingFactors Method

Sets the downsampling factors used when compressing the image data. This will affect both quality and file size of the saved image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetDownsamplingFactors(
    int[] horizontalFactors,
    int[] verticalFactors
)
Public Sub SetDownsamplingFactors (
    horizontalFactors As Integer(),
    verticalFactors As Integer()
)

Parameters

horizontalFactors
Type: SystemInt32
An array of horizontal factors used. This can be null (Nothing in VB) to use the default settings. See remarks below for more information.
verticalFactors
Type: SystemInt32
An array of vertical factors used. This can be null (Nothing in VB) to use the default settings. See remarks below for more information.
Remarks

The horizontal and vertical arrays represent the factors for each color channel. If the image is 8-bit there should only be a single element in the array. For 24-bit images there will be three elements.

The values of these factors range from 1 to 4, but not all value combinations will work. Those that do not work will throw an exception when saving the image.

See Also

Reference

JpegEncoder Class
Atalasoft.Imaging.Codec Namespace
DctMode Property


JpegImageInfo Class

Summary description for JpegImageInfo.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.CodecJpegImageInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegImageInfo : ImageInfo
Public Class JpegImageInfo
    Inherits ImageInfo

The JpegImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JpegImageInfo | Initialize a new instance of a %JpegImageInfo%.
Public method | JpegImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Boolean, Boolean) | Initialize a new instance of a JpegImageInfo specifying it's properties.
Top
Properties
 | Name | Description
Public property | Arithmetic | Gets a value indicating if the Jpeg is encoded with arithmetic compression.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Progressive | Gets a value indicating if the Jpeg is encoded progressively.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegImageInfo Constructor

Creates a JpegImageInfo object.
Overload List
 | Name | Description
Public method | JpegImageInfo | Initialize a new instance of a %JpegImageInfo%.
Public method | JpegImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Boolean, Boolean) | Initialize a new instance of a JpegImageInfo specifying it's properties.
Top
See Also

Reference

JpegImageInfo Class
Atalasoft.Imaging.Codec Namespace


JpegImageInfo Constructor

Initialize a new instance of a %JpegImageInfo%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegImageInfo()
Public Sub New
See Also

Reference

JpegImageInfo Class
JpegImageInfo Overload
Atalasoft.Imaging.Codec Namespace


JpegImageInfo Constructor (Size, Int32, ImageType, Dpi, PixelFormat, Boolean, Boolean)

Initialize a new instance of a JpegImageInfo specifying it's properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegImageInfo(
    Size size,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat,
    bool progressive,
    bool arithmetic
)
Public Sub New (
    size As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat,
    progressive As Boolean,
    arithmetic As Boolean
)

Parameters

size
Type: System.DrawingSize
The width and height of the image.
colorDepth
Type: SystemInt32
The bits per pixel of the image.
imageType
Type: Atalasoft.Imaging.CodecImageType
The image type.
resolution
Type: Atalasoft.ImagingDpi
The image resolution, usually expressed in dots per inch.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat which will be returned when the image is read.
progressive
Type: SystemBoolean
A value indicating if the Jpeg is encoded progressively.
arithmetic
Type: SystemBoolean
A value indicating if the Jpeg is encoded with arithmetic compression.
See Also

Reference

JpegImageInfo Class
JpegImageInfo Overload
Atalasoft.Imaging.Codec Namespace


JpegImageInfo Properties

The JpegImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Arithmetic | Gets a value indicating if the Jpeg is encoded with arithmetic compression.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Progressive | Gets a value indicating if the Jpeg is encoded progressively.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
See Also

Reference

JpegImageInfo Class
Atalasoft.Imaging.Codec Namespace


JpegImageInfo.Arithmetic Property

JpegImageInfoArithmetic Property

Gets a value indicating if the Jpeg is encoded with arithmetic compression.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Arithmetic { get; }
Public ReadOnly Property Arithmetic As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the Jpeg is encoded with arithmetic compression.
See Also

Reference

JpegImageInfo Class
Atalasoft.Imaging.Codec Namespace


JpegImageInfo.Progressive Property

JpegImageInfoProgressive Property

Gets a value indicating if the Jpeg is encoded progressively.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Progressive { get; }
Public ReadOnly Property Progressive As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the Jpeg is encoded progressively.
See Also

Reference

JpegImageInfo Class
Atalasoft.Imaging.Codec Namespace


JpegImageInfo Methods

The JpegImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

JpegImageInfo Class
Atalasoft.Imaging.Codec Namespace


JpegScaleFactor Enumeration

The scaling factor to use when reading a Jpeg image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum JpegScaleFactor
Public Enumeration JpegScaleFactor
Members
Member name | Description
Full | The full encoded size.
Half | 1/2 the encoded size.
Quarter | 1/4 the encoded size.
Eighth | 1/8 the encoded size.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegXrDecoder Class

The JpegXrDecoder class is a decoder for Microsoft Windows Media Photo encoded images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecJpegXrDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegXrDecoder : ImageDecoder
Public Class JpegXrDecoder
    Inherits ImageDecoder

The JpegXrDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | JpegXrDecoder | Creates a new instance of JpegXrDecoder.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColorProfile | Returns the color profile for this image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegXrDecoder Constructor

Creates a new instance of JpegXrDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegXrDecoder()
Public Sub New
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrDecoder Properties

The JpegXrDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrDecoder Methods

The JpegXrDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColorProfile | Returns the color profile for this image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrDecoder.GetColorProfile Method

JpegXrDecoderGetColorProfile Method

Returns the color profile for this image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile GetColorProfile(
    Stream stream
)
Public Function GetColorProfile (
    stream As Stream
) As ColorProfile

Parameters

stream
Type: System.IOStream
A stream containing the image.

Return Value

Type: ColorProfile
A ColorProfile for this image or null (Nothing in VB) if there is no profile.
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrDecoder.GetImageInfo Method

JpegXrDecoderGetImageInfo Method

Retreive information from an image stored in a file without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image such as size and bitdepth.
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream must have read access.;stream
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrDecoder.IsValidFormat Method

JpegXrDecoderIsValidFormat Method

Checks the stream to determine if the image can be read by the decoder that derives this class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
True if the encoded image can be read by this decoder, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream must have read access.;stream
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrDecoder.Read Method

JpegXrDecoderRead Method

Decode an image in a specified image Stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the decoded image.
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream must have read access.;stream
See Also

Reference

JpegXrDecoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder Class

The JpegXrEncoder class is an encoder that is used to encode an AtalaImage to Microsoft Windows Media Photo images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecJpegXrEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegXrEncoder : ImageEncoder
Public Class JpegXrEncoder
    Inherits ImageEncoder

The JpegXrEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | JpegXrEncoder | Creates a new instance of JpegXrEncoder.
Top
Properties
 | Name | Description
Public property | AlphaDataDiscardLevel | Gets or sets the level of alpha frequency data to discard during a compressed domain transcode.
Public property | AlphaQualityLevel | Gets or sets the compression quality for a planar alpha channel.
Public property | CompressedDomainTranscode | Gets or sets a value that indicates whether compressed domain operations can be used. Compressed domain operations are transformation operations that are done without decoding the image data.
Public property | FlipHorizontal | Gets or sets a value indicating whether to flip the image horizontally.
Public property | FlipVertical | Gets or sets a value that indicates whether to flip the image vertically.
Public property | FrequencyOrder | Gets or sets a value that indicates whether to encoding in frequency order.
Public property | HorizontalTileSlices | Gets or sets the number of horizontal divisions to use during compression encoding. A single division creates two horizontal regions.
Public property | IgnoreOverlap | Gets or sets a value that indicates whether to ignore region overlap pixels in sub-region compressed domain encoding. This feature is not currently implemented.
Public property | ImageDataDiscardLevel | Gets or sets the level of image data to discard during a compressed domain transcode.
Public property | ImageQualityLevel | Gets or sets the image quality level.
Public property | InterleavedAlpha | Gets or sets a value that indicates whether to encode the alpha channel data as an additional interleaved channel.
Public property | Lossless | Gets or sets a value that indicates whether to encode using lossless compression.
Public property | OverlapLevel | Gets or sets the overlap processing level.
Public property | QualityLevel | Gets or sets the compression quality for the main image.
Public property | Rotation | Gets or sets the Rotation of the image.
Public property | SubsamplingLevel | Gets or sets the sub sampling level for RGB image encoding.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | UseCodecOptions | Gets or sets a value that indicates codec options are to be used.
Public property | VerticalTileSlices | Gets or sets the number of vertical divisions to use during compression encoding. A single division creates two vertical regions.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save an image using this encoder. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


JpegXrEncoder Constructor

Creates a new instance of JpegXrEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegXrEncoder()
Public Sub New
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder Properties

The JpegXrEncoder type exposes the following members.

Properties
 | Name | Description
Public property | AlphaDataDiscardLevel | Gets or sets the level of alpha frequency data to discard during a compressed domain transcode.
Public property | AlphaQualityLevel | Gets or sets the compression quality for a planar alpha channel.
Public property | CompressedDomainTranscode | Gets or sets a value that indicates whether compressed domain operations can be used. Compressed domain operations are transformation operations that are done without decoding the image data.
Public property | FlipHorizontal | Gets or sets a value indicating whether to flip the image horizontally.
Public property | FlipVertical | Gets or sets a value that indicates whether to flip the image vertically.
Public property | FrequencyOrder | Gets or sets a value that indicates whether to encoding in frequency order.
Public property | HorizontalTileSlices | Gets or sets the number of horizontal divisions to use during compression encoding. A single division creates two horizontal regions.
Public property | IgnoreOverlap | Gets or sets a value that indicates whether to ignore region overlap pixels in sub-region compressed domain encoding. This feature is not currently implemented.
Public property | ImageDataDiscardLevel | Gets or sets the level of image data to discard during a compressed domain transcode.
Public property | ImageQualityLevel | Gets or sets the image quality level.
Public property | InterleavedAlpha | Gets or sets a value that indicates whether to encode the alpha channel data as an additional interleaved channel.
Public property | Lossless | Gets or sets a value that indicates whether to encode using lossless compression.
Public property | OverlapLevel | Gets or sets the overlap processing level.
Public property | QualityLevel | Gets or sets the compression quality for the main image.
Public property | Rotation | Gets or sets the Rotation of the image.
Public property | SubsamplingLevel | Gets or sets the sub sampling level for RGB image encoding.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | UseCodecOptions | Gets or sets a value that indicates codec options are to be used.
Public property | VerticalTileSlices | Gets or sets the number of vertical divisions to use during compression encoding. A single division creates two vertical regions.
Top
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.AlphaDataDiscardLevel Property

JpegXrEncoderAlphaDataDiscardLevel Property

Gets or sets the level of alpha frequency data to discard during a compressed domain transcode.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte AlphaDataDiscardLevel { get; set; }
Public Property AlphaDataDiscardLevel As Byte
    Get
    Set

Property Value

Type: Byte
The level of alpha data to discard when encoding the image. The value range is 0 to 4. The default value is 1.
Remarks
This parameter is only valid if CompressedDomainTranscode is set to true and the image contains either a planar or interleaved alpha channel; otherwise it is ignored.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.AlphaQualityLevel Property

JpegXrEncoderAlphaQualityLevel Property

Gets or sets the compression quality for a planar alpha channel.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte AlphaQualityLevel { get; set; }
Public Property AlphaQualityLevel As Byte
    Get
    Set

Property Value

Type: Byte
The compression quality for a planar alpha channel image. A value of 1 is considered lossless and increasing values result in higher compression ratios and lower image quality. The value range is 0 to 255. The default value is 1.
Remarks
This parameter is only valid if InterleavedAlpha is false.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.CompressedDomainTranscode Property

JpegXrEncoderCompressedDomainTranscode Property

Gets or sets a value that indicates whether compressed domain operations can be used. Compressed domain operations are transformation operations that are done without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CompressedDomainTranscode { get; set; }
Public Property CompressedDomainTranscode As Boolean
    Get
    Set

Property Value

Type: Boolean
True if compressed domain operations can be used; otherwise, false. The default value is true.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.FlipHorizontal Property

JpegXrEncoderFlipHorizontal Property

Gets or sets a value indicating whether to flip the image horizontally.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FlipHorizontal { get; set; }
Public Property FlipHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
True if the image is to be flipped horizontally; otherwise, false.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.FlipVertical Property

JpegXrEncoderFlipVertical Property

Gets or sets a value that indicates whether to flip the image vertically.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FlipVertical { get; set; }
Public Property FlipVertical As Boolean
    Get
    Set

Property Value

Type: Boolean
True if the image is to be flipped vertically; otherwise, false.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.FrequencyOrder Property

JpegXrEncoderFrequencyOrder Property

Gets or sets a value that indicates whether to encoding in frequency order.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FrequencyOrder { get; set; }
Public Property FrequencyOrder As Boolean
    Get
    Set

Property Value

Type: Boolean
True to encode the image in frequency order; false to encode the image by its spatial orientation. The default value is true.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.HorizontalTileSlices Property

JpegXrEncoderHorizontalTileSlices Property

Gets or sets the number of horizontal divisions to use during compression encoding. A single division creates two horizontal regions.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public short HorizontalTileSlices { get; set; }
Public Property HorizontalTileSlices As Short
    Get
    Set

Property Value

Type: Int16
The number of horizontal divisions to use during compression encoding. The value range is 0 to 4095. The default value is 0.
Remarks

If CompressedDomainTranscode is true, HorizontalTileSlices must be set to 0.

A tile created by the division can never be smaller than 16 pixels. The value will be adjusted to maintain the minimum tile size.

When used in combination with VerticalTileSlices, a grid of tiles is formed. For example, if both property has one division, the image will be divided into 4 tiles.

See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.IgnoreOverlap Property

JpegXrEncoderIgnoreOverlap Property

Gets or sets a value that indicates whether to ignore region overlap pixels in sub-region compressed domain encoding. This feature is not currently implemented.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IgnoreOverlap { get; set; }
Public Property IgnoreOverlap As Boolean
    Get
    Set

Property Value

Type: Boolean
True if overlap is ignored; otherwise, false. The default value is false.
Remarks
This value is only valid when CompressedDomainTranscode is true and a sub-region encode is requested.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.ImageDataDiscardLevel Property

JpegXrEncoderImageDataDiscardLevel Property

Gets or sets the level of image data to discard during a compressed domain transcode.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte ImageDataDiscardLevel { get; set; }
Public Property ImageDataDiscardLevel As Byte
    Get
    Set

Property Value

Type: Byte
The level of image data to discard during a compressed domain encoding of the image. The value range is 0 to 3. The default value is 1.
Remarks
This parameter is only valid if CompressedDomainTranscode is set to true; otherwise it is ignored.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.ImageQualityLevel Property

JpegXrEncoderImageQualityLevel Property

Gets or sets the image quality level.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ImageQualityLevel { get; set; }
Public Property ImageQualityLevel As Single
    Get
    Set

Property Value

Type: Single
The image quality level. The range is 0 to 1.0. The default value is 0.9. A value of 1.0 represents a lossless image quality.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.InterleavedAlpha Property

JpegXrEncoderInterleavedAlpha Property

Gets or sets a value that indicates whether to encode the alpha channel data as an additional interleaved channel.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool InterleavedAlpha { get; set; }
Public Property InterleavedAlpha As Boolean
    Get
    Set

Property Value

Type: Boolean
True if the image is encoded with an additional interleaved alpha channel; false if planar alpha channel is used. The default value is false.
Remarks
Interleaved alpha channels are only supported by certain pixel formats.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.Lossless Property

JpegXrEncoderLossless Property

Gets or sets a value that indicates whether to encode using lossless compression.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Lossless { get; set; }
Public Property Lossless As Boolean
    Get
    Set

Property Value

Type: Boolean
True to use lossless compression; otherwise, false. The default value is false.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.OverlapLevel Property

JpegXrEncoderOverlapLevel Property

Gets or sets the overlap processing level.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte OverlapLevel { get; set; }
Public Property OverlapLevel As Byte
    Get
    Set

Property Value

Type: Byte
The overlap processing level. The default value is 1.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.QualityLevel Property

JpegXrEncoderQualityLevel Property

Gets or sets the compression quality for the main image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte QualityLevel { get; set; }
Public Property QualityLevel As Byte
    Get
    Set

Property Value

Type: Byte
The compression quality for the main image. A value of 1 is considered lossless and higher values indicate a high compression ratio and lower image quality. The range is 0 to 255. The default value is 1.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.Rotation Property

JpegXrEncoderRotation Property

Gets or sets the Rotation of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rotation Rotation { get; set; }
Public Property Rotation As Rotation
    Get
    Set

Property Value

Type: Rotation
The rotation of the image.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.SubsamplingLevel Property

JpegXrEncoderSubsamplingLevel Property

Gets or sets the sub sampling level for RGB image encoding.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte SubsamplingLevel { get; set; }
Public Property SubsamplingLevel As Byte
    Get
    Set

Property Value

Type: Byte
The sub sampling level for RGB image encoding. The range is 0 to 3. The default value is 3.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.SupportedPixelFormats Property

JpegXrEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.UseCodecOptions Property

JpegXrEncoderUseCodecOptions Property

Gets or sets a value that indicates codec options are to be used.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseCodecOptions { get; set; }
Public Property UseCodecOptions As Boolean
    Get
    Set

Property Value

Type: Boolean
True if codec options are to be used; otherwise, false. The default value is false. When true, QualityLevel, OverlapLevel, and SubsamplingLevel are used in place of the ImageQualityLevel. When false, QualityLevel, OverlapLevel, and SubsamplingLevel are set based on ImageQualityLevel.
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.VerticalTileSlices Property

JpegXrEncoderVerticalTileSlices Property

Gets or sets the number of vertical divisions to use during compression encoding. A single division creates two vertical regions.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public short VerticalTileSlices { get; set; }
Public Property VerticalTileSlices As Short
    Get
    Set

Property Value

Type: Int16
The number of vertical divisions to use during compression encoding. The value range is 0 to 4095. The default value is 0.
Remarks

If CompressedDomainTranscode is true, VerticalTileSlices must be set to 0.

A tile created by the division can never be smaller than 16 pixels. The value will be adjusted to maintain the minimum tile size.

When used in combination with HorizontalTileSlices, a grid of tiles is formed. For example, if both properties are set to 1, the image will be divided into 4 tiles.

See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder Methods

The JpegXrEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save an image using this encoder. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


JpegXrEncoder.Save Method

JpegXrEncoderSave Method

Save an image using this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream containing the file which the image will be encoded to.
image
Type: Atalasoft.ImagingAtalaImage
The image to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The number of bytes written to the file.
Exceptions
Exception | Condition
ArgumentNullException | stream or image
ArgumentException | The stream must have write access.;stream or The stream must be seekable.;stream
See Also

Reference

JpegXrEncoder Class
Atalasoft.Imaging.Codec Namespace


LibRawException Class

This exception is thrown when there is a problem reading an image by LibRaw library.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.CodecLibRawException

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LibRawException : Exception
<SerializableAttribute>
Public Class LibRawException
    Inherits Exception

The LibRawException type exposes the following members.

Constructors
 | Name | Description
Public method | LibRawException | Creates a new instance of LibRawException.
Public method | LibRawException(String) | Creates a new instance of LibRawException specifying the exception message.
Protected method | LibRawException(SerializationInfo, StreamingContext) | Initializes a new instance of the LibRawException class.
Public method | LibRawException(String, Exception) | Creates a new instance of LibRawException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


LibRawException Constructor

Creates an LibRawException object.
Overload List
 | Name | Description
Public method | LibRawException | Creates a new instance of LibRawException.
Public method | LibRawException(String) | Creates a new instance of LibRawException specifying the exception message.
Protected method | LibRawException(SerializationInfo, StreamingContext) | Initializes a new instance of the LibRawException class.
Public method | LibRawException(String, Exception) | Creates a new instance of LibRawException specifying the exception message and inner exception.
Top
See Also

Reference

LibRawException Class
Atalasoft.Imaging.Codec Namespace


LibRawException Constructor

Creates a new instance of LibRawException.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LibRawException()
Public Sub New
See Also

Reference

LibRawException Class
LibRawException Overload
Atalasoft.Imaging.Codec Namespace


LibRawException Constructor (String)

Creates a new instance of LibRawException specifying the exception message.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LibRawException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

LibRawException Class
LibRawException Overload
Atalasoft.Imaging.Codec Namespace


LibRawException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LibRawException class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LibRawException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The [!:T:System.Runtime.Serialization.SerializationInfo] that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The [!:T:System.Runtime.Serialization.StreamingContext] that contains contextual information about the source or destination.
See Also

Reference

LibRawException Class
LibRawException Overload
Atalasoft.Imaging.Codec Namespace


LibRawException Constructor (String, Exception)

Creates a new instance of LibRawException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LibRawException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
See Also

Reference

LibRawException Class
LibRawException Overload
Atalasoft.Imaging.Codec Namespace


LibRawException Properties

The LibRawException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

LibRawException Class
Atalasoft.Imaging.Codec Namespace


LibRawException Methods

The LibRawException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

LibRawException Class
Atalasoft.Imaging.Codec Namespace


LibRawException Events

The LibRawException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

LibRawException Class
Atalasoft.Imaging.Codec Namespace


LoadingPolicy Enumeration

Dictates how safe our raw codec should be when trying to load files.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum LoadingPolicy
<FlagsAttribute>
Public Enumeration LoadingPolicy
Members
Member name | Description
Safest | This offers the most protection but may not work with some files.
IgnoreFileBounds | Will ignore seeks which go outside of the file bounds instead of throwing an exception. This is the default value.
IgnoreCorruption | Will ignore corruption in images and make the corrupt pixels black instead of throwing an exception.
LibralIsValidChecking | Will use the highest compatibility mode for isValid checks.
MostCompatible | This will work with the most files but offers the least amount of protection.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Class

This exception is fired when LZW is not licensed yet an attempt is made to use LZW functionality.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.CodecLzwNotLicensedException

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LzwNotLicensedException : Exception
<SerializableAttribute>
Public Class LzwNotLicensedException
    Inherits Exception

The LzwNotLicensedException type exposes the following members.

Constructors
 | Name | Description
Public method | LzwNotLicensedException | Creates a new instance of LzwNotLicensedException.
Public method | LzwNotLicensedException(String) | Creates a new instance of LzwNotLicensedException specifying the exception message.
Protected method | LzwNotLicensedException(SerializationInfo, StreamingContext) | Initializes a new instance of the LzwNotLicensedException class.
Public method | LzwNotLicensedException(String, Exception) | Creates a new instance of LzwNotLicensedException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Remarks
This exception is no longer thrown as the LZW patents have expired in all countries.
See Also

Reference

Atalasoft.Imaging.Codec Namespace
LZW/GIF License


LzwNotLicensedException Constructor

Creates an LzwNotLicensedException.
Overload List
 | Name | Description
Public method | LzwNotLicensedException | Creates a new instance of LzwNotLicensedException.
Public method | LzwNotLicensedException(String) | Creates a new instance of LzwNotLicensedException specifying the exception message.
Protected method | LzwNotLicensedException(SerializationInfo, StreamingContext) | Initializes a new instance of the LzwNotLicensedException class.
Public method | LzwNotLicensedException(String, Exception) | Creates a new instance of LzwNotLicensedException specifying the exception message and inner exception.
Top
See Also

Reference

LzwNotLicensedException Class
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Constructor

Creates a new instance of LzwNotLicensedException.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LzwNotLicensedException()
Public Sub New
See Also

Reference

LzwNotLicensedException Class
LzwNotLicensedException Overload
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Constructor (String)

Creates a new instance of LzwNotLicensedException specifying the exception message.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LzwNotLicensedException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

LzwNotLicensedException Class
LzwNotLicensedException Overload
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LzwNotLicensedException class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LzwNotLicensedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

LzwNotLicensedException Class
LzwNotLicensedException Overload
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Constructor (String, Exception)

Creates a new instance of LzwNotLicensedException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LzwNotLicensedException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
See Also

Reference

LzwNotLicensedException Class
LzwNotLicensedException Overload
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Properties

The LzwNotLicensedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

LzwNotLicensedException Class
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Methods

The LzwNotLicensedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

LzwNotLicensedException Class
Atalasoft.Imaging.Codec Namespace


LzwNotLicensedException Events

The LzwNotLicensedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

LzwNotLicensedException Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder Class

A decoder for multiframed images such as multiple page TIFF's and animiated GIF's.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
More...

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class MultiFramedImageDecoder : ImageDecoder
Public MustInherit Class MultiFramedImageDecoder
    Inherits ImageDecoder

The MultiFramedImageDecoder type exposes the following members.

Constructors
 | Name | Description
Protected method | MultiFramedImageDecoder | Initializes a new instance of the MultiFramedImageDecoder class
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retrieves information from an image stored in a file without decoding the image data. (Inherited from ImageDecoder.)
Public method | GetImageInfo(Stream, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Inherited from ImageDecoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Inherited from ImageDecoder.)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.CadCamDwgDecoder
Atalasoft.Imaging.Codec.DicomDicomDecoder
Atalasoft.Imaging.CodecGifDecoder
Atalasoft.Imaging.CodecHeifDecoder
Atalasoft.Imaging.Codec.Jbig2Jb2Decoder
Atalasoft.Imaging.Codec.OfficeOfficeAdapterDecoder
Atalasoft.Imaging.Codec.OfficeOfficeDecoder
Atalasoft.Imaging.Codec.PdfPdfDecoder
Atalasoft.Imaging.CodecTiffDecoder
Atalasoft.Imaging.CodecXpsDecoder


MultiFramedImageDecoder Constructor

Initializes a new instance of the MultiFramedImageDecoder class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MultiFramedImageDecoder()
Protected Sub New
See Also

Reference

MultiFramedImageDecoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder Properties

The MultiFramedImageDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

MultiFramedImageDecoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder Methods

The MultiFramedImageDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retrieves information from an image stored in a file without decoding the image data. (Inherited from ImageDecoder.)
Public method | GetImageInfo(Stream, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Inherited from ImageDecoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Inherited from ImageDecoder.)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MultiFramedImageDecoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder.GetFrameCount Method

MultiFramedImageDecoderGetFrameCount Method

Returns the number of frames in the image

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract int GetFrameCount(
    Stream stream
)
Public MustOverride Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The input Stream.

Return Value

Type: Int32
The number of frames in the image
See Also

Reference

MultiFramedImageDecoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder.GetImageInfo Method

MultiFramedImageDecoderGetImageInfo Method

Retreive information in an image stored in a file without decoding the image data.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retrieves information from an image stored in a file without decoding the image data. (Inherited from ImageDecoder.)
Public method | GetImageInfo(Stream, Int32) |
Top
See Also

Reference

MultiFramedImageDecoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder.GetImageInfo Method (Stream, Int32)

MultiFramedImageDecoderGetImageInfo Method (Stream, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public MustOverride Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.

Return Value

Type: ImageInfo
See Also

Reference

MultiFramedImageDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder.Read Method

MultiFramedImageDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Inherited from ImageDecoder.)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder.
Top
See Also

Reference

MultiFramedImageDecoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageDecoder.Read Method (Stream, Int32, ProgressEventHandler)

MultiFramedImageDecoderRead Method (Stream, Int32, ProgressEventHandler)

Read a given frame in an encoded image using this decoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public MustOverride Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

MultiFramedImageDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder Class

An encoder for multiframed formats such as PDF and animated GIF's.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecMultiFramedImageEncoder
Atalasoft.Imaging.Codec.Jbig2Jb2Encoder
Atalasoft.Imaging.Codec.PdfPdfEncoder
Atalasoft.Imaging.CodecTiffEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class MultiFramedImageEncoder : ImageEncoder
Public MustInherit Class MultiFramedImageEncoder
    Inherits ImageEncoder

The MultiFramedImageEncoder type exposes the following members.

Constructors
 | Name | Description
Protected method | MultiFramedImageEncoder | Initializes a new instance of the MultiFramedImageEncoder class
Top
Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Inherited from ImageEncoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression.
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Save an image using this encoder. (Inherited from ImageEncoder.)
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves the image.
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves the images to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression.
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder Constructor

Initializes a new instance of the MultiFramedImageEncoder class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MultiFramedImageEncoder()
Protected Sub New
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder Properties

The MultiFramedImageEncoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Inherited from ImageEncoder.)
Top
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder Methods

The MultiFramedImageEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression.
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Save an image using this encoder. (Inherited from ImageEncoder.)
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves the image.
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves the images to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder.OnSetEncoderCompression Method

MultiFramedImageEncoderOnSetEncoderCompression Method

Called when the encoder needs to select a compression.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSetEncoderCompression(
    Object sender,
    EncoderCompressionEventArgs e
)
Protected Overridable Sub OnSetEncoderCompression (
    sender As Object,
    e As EncoderCompressionEventArgs
)

Parameters

sender
Type: SystemObject
The sender.
e
Type: Atalasoft.Imaging.CodecEncoderCompressionEventArgs
The EncoderCompressionEventArgs instance containing the event data.
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder.Save Method

MultiFramedImageEncoderSave Method

Saves a multi-framed image.
Overload List
 | Name | Description
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Save an image using this encoder. (Inherited from ImageEncoder.)
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves the image.
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves the images to the specified stream.
Top
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder.Save Method (Stream, ImageCollection, ProgressEventHandler)

MultiFramedImageEncoderSave Method (Stream, ImageCollection, ProgressEventHandler)

Saves the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract long Save(
    Stream stream,
    ImageCollection images,
    ProgressEventHandler progress
)
Public MustOverride Function Save (
    stream As Stream,
    images As ImageCollection,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
images
Type: Atalasoft.ImagingImageCollection
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: Int64
See Also

Reference

MultiFramedImageEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder.Save Method (Stream, ImageSource, ProgressEventHandler)

MultiFramedImageEncoderSave Method (Stream, ImageSource, ProgressEventHandler)

Saves the images to the specified stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual long Save(
    Stream stream,
    ImageSource images,
    ProgressEventHandler progress
)
Public Overridable Function Save (
    stream As Stream,
    images As ImageSource,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream.
images
Type: Atalasoft.ImagingImageSource
The images to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress handler.

Return Value

Type: Int64
Exceptions
Exception | Condition
NotImplementedException | Saving an ImageSource is not implemented in this decoder
See Also

Reference

MultiFramedImageEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder Events

The MultiFramedImageEncoder type exposes the following members.

Events
 | Name | Description
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression.
Top
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


MultiFramedImageEncoder.SetEncoderCompression Event

MultiFramedImageEncoderSetEncoderCompression Event

Occurs when the encoder needs to select a compression.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EncoderCompressionEventHandler SetEncoderCompression
Public Event SetEncoderCompression As EncoderCompressionEventHandler

Value

Type: Atalasoft.Imaging.CodecEncoderCompressionEventHandler
See Also

Reference

MultiFramedImageEncoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder Class

An ImageDecoder used to read Kodak Photo CD (PCD) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecPcdDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PcdDecoder : ImageDecoder
Public Class PcdDecoder
    Inherits ImageDecoder

The PcdDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PcdDecoder | Initializes a new instance of a %PcdDecoder%.
Public method | PcdDecoder(PcdResolution) | Initializes a new instance of a PcdDecoder specifying a resolution.
Top
Properties
 | Name | Description
Public property | Resolution | Gets or sets the resolution to read in a PhotoCD image.
Public property | SupportedImageType | Obsolete. Returns a PhotoCD ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a PhotoCD image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a PhotoCD image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a PhotoCD encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a PhotoCD image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.

A PhotoCD image contains the same image stored at multiple resolutions. By specifying the Resolution property, you can choose which resolution image to load.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


PcdDecoder Constructor

Creates a PcdDecoder.
Overload List
 | Name | Description
Public method | PcdDecoder | Initializes a new instance of a %PcdDecoder%.
Public method | PcdDecoder(PcdResolution) | Initializes a new instance of a PcdDecoder specifying a resolution.
Top
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder Constructor

Initializes a new instance of a %PcdDecoder%.
Initializes a new instance of a PcdDecoder with a default resolution of 768 x 512 pixels.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PcdDecoder()
Public Sub New
See Also

Reference

PcdDecoder Class
PcdDecoder Overload
Atalasoft.Imaging.Codec Namespace


PcdDecoder Constructor (PcdResolution)

Initializes a new instance of a PcdDecoder specifying a resolution.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PcdDecoder(
    PcdResolution resolution
)
Public Sub New (
    resolution As PcdResolution
)

Parameters

resolution
Type: Atalasoft.Imaging.CodecPcdResolution

Sets the resolution to read in a PhotoCD image.

See Also

Reference

PcdDecoder Class
PcdDecoder Overload
Atalasoft.Imaging.Codec Namespace


PcdDecoder Properties

The PcdDecoder type exposes the following members.

Properties
 | Name | Description
Public property | Resolution | Gets or sets the resolution to read in a PhotoCD image.
Public property | SupportedImageType | Obsolete. Returns a PhotoCD ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder.Resolution Property

PcdDecoderResolution Property

Gets or sets the resolution to read in a PhotoCD image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PcdResolution Resolution { get; set; }
Public Property Resolution As PcdResolution
    Get
    Set

Property Value

Type: PcdResolution

The resolution to read in a PhotoCD image.

See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder.SupportedImageType Property

PcdDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a PhotoCD ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder Methods

The PcdDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a PhotoCD image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a PhotoCD image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a PhotoCD encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder.GetImageInfo Method

PcdDecoderGetImageInfo Method

Retreive information from a PhotoCD image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder.IsValidFormat Method

PcdDecoderIsValidFormat Method

Returns true if the specified Stream contains a PhotoCD image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The input Stream.

Return Value

Type: Boolean
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdDecoder.Read Method

PcdDecoderRead Method

Returns an AtalaImage from a Stream containing a PhotoCD encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

PcdDecoder Class
Atalasoft.Imaging.Codec Namespace


PcdResolution Enumeration

PhotoCD Resolution (image size) to load.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PcdResolution
Public Enumeration PcdResolution
Members
Member name | Description
BaseQuarter | 1/4 the size and 1/16 the memory of the base image. 192 x 128 pixels
BaseHalf | 1/2 the size and 1/4 the memory of the base image. 384 x 256 pixels
Base | The base size of the PCD image. 768 x 512 pixels
BaseX2 | Double the size and 4 times the memory of the base image. 1536 x 1024 pixels
BaseX4 | 4 times the size and 16 times the memory of the base image. 3072 x 2048 pixels
BaseX8 | 8 times the size and 64 times the memory of the base image. 6144 x 4096 pixels
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PcxDecoder Class

An ImageDecoder used to read Zsoft Paintbrush (PCX) images from a %System.IO.Stream%.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecPcxDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PcxDecoder : ImageDecoder
Public Class PcxDecoder
    Inherits ImageDecoder

The PcxDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PcxDecoder | Initializes a new instance of a PcxDecoder.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Pcx ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Pcx image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Pcx image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Pcx encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
By default, when opening a Pcx image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the %RegisteredDecoders% and does not have to be explicitly set.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PcxDecoder Constructor

Initializes a new instance of a PcxDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PcxDecoder()
Public Sub New
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxDecoder Properties

The PcxDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Pcx ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxDecoder.SupportedImageType Property

PcxDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Pcx ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxDecoder Methods

The PcxDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Pcx image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains a Pcx image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Pcx encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxDecoder.GetImageInfo Method

PcxDecoderGetImageInfo Method

Retreive information from a Pcx image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxDecoder.IsValidFormat Method

PcxDecoderIsValidFormat Method

Returns true if the specified Stream contains a Pcx image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxDecoder.Read Method

PcxDecoderRead Method

Returns an AtalaImage from a Stream containing a Pcx encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream containing the image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

PcxDecoder Class
Atalasoft.Imaging.Codec Namespace


PcxEncoder Class

An ImageEncoder that will write ZSoft Paintbrush (PCX) images to a %System.IO.Stream%.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecPcxEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PcxEncoder : ImageEncoder
Public Class PcxEncoder
    Inherits ImageEncoder

The PcxEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PcxEncoder | Initializes a new instance of a %PcxEncoder%.
Top
Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Pcx image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a PCX image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PcxEncoder Constructor

Initializes a new instance of a %PcxEncoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PcxEncoder()
Public Sub New
See Also

Reference

PcxEncoder Class
Atalasoft.Imaging.Codec Namespace


PcxEncoder Properties

The PcxEncoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

PcxEncoder Class
Atalasoft.Imaging.Codec Namespace


PcxEncoder.SupportedPixelFormats Property

PcxEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

PcxEncoder Class
Atalasoft.Imaging.Codec Namespace


PcxEncoder Methods

The PcxEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Pcx image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PcxEncoder Class
Atalasoft.Imaging.Codec Namespace


PcxEncoder.Save Method

PcxEncoderSave Method

Encode an %AtalaImage% as a Pcx image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

PcxEncoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder Class

An ImageDecoder used to read Portable Network Graphics (PNG) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecPngDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PngDecoder : ImageDecoder
Public Class PngDecoder
    Inherits ImageDecoder

The PngDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PngDecoder | Initializes a new instance of a PngDecoder.
Public method | PngDecoder(Double) | Initializes a new instance of a PcdDecoder with a specified screen gamma.
Top
Properties
 | Name | Description
Public property | ScreenGamma | Gets or sets the screen gamma value that will be used to adjust the colors of a PNG image when read if the image contains gamma.
Public property | SetAlphaFromTransparentColor | Indicates whether or not the PngDcoder should set the alpha channel in the image using the Png file's transparent color.
Public property | SupportedImageType | Obsolete. Returns a Png ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Public property | TwoBytePerComponentSupport | Gets or sets a value indicating whether 16-bit per component images are read as 16 or 8-bit per component images.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Png image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Png image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Png encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
By default, when opening a Png image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PngDecoder Constructor

Overload List
 | Name | Description
Public method | PngDecoder | Initializes a new instance of a PngDecoder.
Public method | PngDecoder(Double) | Initializes a new instance of a PcdDecoder with a specified screen gamma.
Top
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder Constructor

Initializes a new instance of a PngDecoder.
Initializes a new instance of a PngDecoder using the default screen gamma.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngDecoder()
Public Sub New
See Also

Reference

PngDecoder Class
PngDecoder Overload
Atalasoft.Imaging.Codec Namespace


PngDecoder Constructor (Double)

Initializes a new instance of a PcdDecoder with a specified screen gamma.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngDecoder(
    double screenGamma
)
Public Sub New (
    screenGamma As Double
)

Parameters

screenGamma
Type: SystemDouble
The screen gamma value that will be used to adjust the colors of a PNG image when read if the image contains gamma.
See Also

Reference

PngDecoder Class
PngDecoder Overload
Atalasoft.Imaging.Codec Namespace


PngDecoder Properties

The PngDecoder type exposes the following members.

Properties
 | Name | Description
Public property | ScreenGamma | Gets or sets the screen gamma value that will be used to adjust the colors of a PNG image when read if the image contains gamma.
Public property | SetAlphaFromTransparentColor | Indicates whether or not the PngDcoder should set the alpha channel in the image using the Png file's transparent color.
Public property | SupportedImageType | Obsolete. Returns a Png ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Public property | TwoBytePerComponentSupport | Gets or sets a value indicating whether 16-bit per component images are read as 16 or 8-bit per component images.
Top
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.ScreenGamma Property

PngDecoderScreenGamma Property

Gets or sets the screen gamma value that will be used to adjust the colors of a PNG image when read if the image contains gamma.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ScreenGamma { get; set; }
Public Property ScreenGamma As Double
    Get
    Set

Property Value

Type: Double
The screen gamma value that will be used to adjust the colors of a PNG image when read if the image contains gamma.
Remarks
A value of 0 will ignore the gamma of the image. A value of 2.2 is typical for PC's. Default 0.
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.SetAlphaFromTransparentColor Property

PngDecoderSetAlphaFromTransparentColor Property

Indicates whether or not the PngDcoder should set the alpha channel in the image using the Png file's transparent color.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetAlphaFromTransparentColor { get; set; }
Public Property SetAlphaFromTransparentColor As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns true if the decoder should set the alpha channel, false otherwise. Default value is false.
Remarks
GetImageInfo will always return the pixel format appropriate to the file without alpha. If the SetAlphaFromTransparentColor is true, the returned image may be in a different pixel format. For example, an image with a pixel format of Pixel24BppBgr will be Pixel32BppBgra if SetAlphaFromTransparentColor is true and there is a transparent color in the png.
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.SupportedImageType Property

PngDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Png ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.TwoBytePerComponentSupport Property

PngDecoderTwoBytePerComponentSupport Property

Gets or sets a value indicating whether 16-bit per component images are read as 16 or 8-bit per component images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TwoBytePerComponentSupport { get; set; }
Public Property TwoBytePerComponentSupport As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether 16-bit per component images are read as 16 or 8-bit per component images.
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder Methods

The PngDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Png image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Png image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Png encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.GetImageInfo Method

PngDecoderGetImageInfo Method

Retreive information from a Png image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.IsValidFormat Method

PngDecoderIsValidFormat Method

Returns true if the specified Stream contains an Png image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngDecoder.Read Method

PngDecoderRead Method

Returns an AtalaImage from a Stream containing a Png encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

PngDecoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder Class

An ImageEncoder that will write Portable Network Graphics (PNG) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecPngEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PngEncoder : ImageEncoder
Public Class PngEncoder
    Inherits ImageEncoder

The PngEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PngEncoder | Initializes a new instance of the PngEncoder class.
Public method | PngEncoder(ComTextCollection) | Initializes a new instance of a PngEncoder specifying the COM Text metadata to save.
Public method | PngEncoder(Color, Double, Boolean, ComTextCollection) | Initializes a new instance of a %PngEncoder% specifying the background color, gamma, interlace, and COM Text value to save.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the color to use as the default background color for Png images with alpha.
Public property | BackgroundIndex | Gets or sets the palette index or grayscale value to use as the default background color for colormapped Png images with alpha.
Public property | ComText | Gets or sets the COM text metadata to save with the image.
Public property | Gamma | Gets or sets the gamma value to write to a PNG image. 0 will not write any value, 2.2 is a typical value for PC's. Default 0.
Public property | Interlace | Gets or sets whether Png files are saved with a pixel row interlacing pattern. Defaults False.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Png image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a PNG image.

If the image being saved contains a ColorProfile, it will be embedded within the file.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


PngEncoder Constructor

Creates a PngEncoder.
Overload List
 | Name | Description
Public method | PngEncoder | Initializes a new instance of the PngEncoder class.
Public method | PngEncoder(ComTextCollection) | Initializes a new instance of a PngEncoder specifying the COM Text metadata to save.
Public method | PngEncoder(Color, Double, Boolean, ComTextCollection) | Initializes a new instance of a %PngEncoder% specifying the background color, gamma, interlace, and COM Text value to save.
Top
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder Constructor

Initializes a new instance of the PngEncoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngEncoder()
Public Sub New
See Also

Reference

PngEncoder Class
PngEncoder Overload
Atalasoft.Imaging.Codec Namespace


PngEncoder Constructor (ComTextCollection)

Initializes a new instance of a PngEncoder specifying the COM Text metadata to save.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngEncoder(
    ComTextCollection comText
)
Public Sub New (
    comText As ComTextCollection
)

Parameters

comText
Type: Atalasoft.Imaging.MetadataComTextCollection
The COM text metadata to save with the image.
See Also

Reference

PngEncoder Class
PngEncoder Overload
Atalasoft.Imaging.Codec Namespace


PngEncoder Constructor (Color, Double, Boolean, ComTextCollection)

Initializes a new instance of a %PngEncoder% specifying the background color, gamma, interlace, and COM Text value to save.
Initializes a new instance of a PngEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngEncoder(
    Color backgroundColor,
    double gamma,
    bool interlaced,
    ComTextCollection comText
)
Public Sub New (
    backgroundColor As Color,
    gamma As Double,
    interlaced As Boolean,
    comText As ComTextCollection
)

Parameters

backgroundColor
Type: System.DrawingColor
The color to use as the default background color for Png images with alpha.
gamma
Type: SystemDouble
The gamma value to write to a PNG image.
interlaced
Type: SystemBoolean
The Png Interlace setting.
comText
Type: Atalasoft.Imaging.MetadataComTextCollection
The COM text metadata to save with the image.
See Also

Reference

PngEncoder Class
PngEncoder Overload
Atalasoft.Imaging.Codec Namespace


PngEncoder Properties

The PngEncoder type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the color to use as the default background color for Png images with alpha.
Public property | BackgroundIndex | Gets or sets the palette index or grayscale value to use as the default background color for colormapped Png images with alpha.
Public property | ComText | Gets or sets the COM text metadata to save with the image.
Public property | Gamma | Gets or sets the gamma value to write to a PNG image. 0 will not write any value, 2.2 is a typical value for PC's. Default 0.
Public property | Interlace | Gets or sets whether Png files are saved with a pixel row interlacing pattern. Defaults False.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder.BackgroundColor Property

PngEncoderBackgroundColor Property

Gets or sets the color to use as the default background color for Png images with alpha.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The color to use as the default background color for Png images with alpha.
Remarks
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace
BackgroundIndex
PngEncoderBackgroundIndex


PngEncoder.BackgroundIndex Property

PngEncoderBackgroundIndex Property

Gets or sets the palette index or grayscale value to use as the default background color for colormapped Png images with alpha.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BackgroundIndex { get; set; }
Public Property BackgroundIndex As Integer
    Get
    Set

Property Value

Type: Int32
The palette index or grayscale value to use as the default background color for colormapped Png images with alpha.
Remarks
Set this value to -1 in order to use the closest color to BackgroundColor.
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder.ComText Property

PngEncoderComText Property

Gets or sets the COM text metadata to save with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextCollection ComText { get; set; }
Public Property ComText As ComTextCollection
    Get
    Set

Property Value

Type: ComTextCollection
The COM text metadata to save with the image.
Remarks
See ComTextCollection for more information.
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace
COM Text Metadata


PngEncoder.Gamma Property

PngEncoderGamma Property

Gets or sets the gamma value to write to a PNG image. 0 will not write any value, 2.2 is a typical value for PC's. Default 0.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Gamma { get; set; }
Public Property Gamma As Double
    Get
    Set

Property Value

Type: Double
The gamma value to write to a PNG image.
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder.Interlace Property

PngEncoderInterlace Property

Gets or sets whether Png files are saved with a pixel row interlacing pattern. Defaults False.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Interlace { get; set; }
Public Property Interlace As Boolean
    Get
    Set

Property Value

Type: Boolean
The Png Interlace setting.
Remarks
Interlacing is a technique that allows a PNG to be displayed gradually. It first displays a blocky image which becomes finer and more clear as the image loads.
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder.SupportedPixelFormats Property

PngEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder Methods

The PngEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Png image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngEncoder.Save Method

PngEncoderSave Method

Encode an %AtalaImage% as a Png image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

PngEncoder Class
Atalasoft.Imaging.Codec Namespace


PngImageInfo Class

Summary description for PngImageInfo.
Information from a PNG Image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.CodecPngImageInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PngImageInfo : ImageInfo
Public Class PngImageInfo
    Inherits ImageInfo

The PngImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PngImageInfo | Initialize a new instance of a PngImageInfo.
Public method | PngImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Boolean) | Initialize a new instance of a %PngImageInfo% specifying it's properties.
Top
Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | HasTransparentColor | Indicates that the image contains a transparency color.
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | PngInterlaced | Gets a value indicating if the PNG is interlaced.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | TransparentColor | Gets or sets the transparent color for the PNG image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PngImageInfo Constructor

Creates a PngImageInfo object.
Overload List
 | Name | Description
Public method | PngImageInfo | Initialize a new instance of a PngImageInfo.
Public method | PngImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, Boolean) | Initialize a new instance of a %PngImageInfo% specifying it's properties.
Top
See Also

Reference

PngImageInfo Class
Atalasoft.Imaging.Codec Namespace


PngImageInfo Constructor

Initialize a new instance of a PngImageInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngImageInfo()
Public Sub New
See Also

Reference

PngImageInfo Class
PngImageInfo Overload
Atalasoft.Imaging.Codec Namespace


PngImageInfo Constructor (Size, Int32, ImageType, Dpi, PixelFormat, Boolean)

Initialize a new instance of a %PngImageInfo% specifying it's properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PngImageInfo(
    Size size,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat,
    bool pngInterlaced
)
Public Sub New (
    size As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat,
    pngInterlaced As Boolean
)

Parameters

size
Type: System.DrawingSize
The width and height of the image.
colorDepth
Type: SystemInt32
The bits per pixel of the image.
imageType
Type: Atalasoft.Imaging.CodecImageType
The image type.
resolution
Type: Atalasoft.ImagingDpi
The image resolution, usually expressed in dots per inch.
pixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat which will be returned when the image is read.
pngInterlaced
Type: SystemBoolean
A value indicating if the PNG is interlaced.
See Also

Reference

PngImageInfo Class
PngImageInfo Overload
Atalasoft.Imaging.Codec Namespace


PngImageInfo Properties

The PngImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | HasTransparentColor | Indicates that the image contains a transparency color.
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | PngInterlaced | Gets a value indicating if the PNG is interlaced.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | TransparentColor | Gets or sets the transparent color for the PNG image.
Top
See Also

Reference

PngImageInfo Class
Atalasoft.Imaging.Codec Namespace


PngImageInfo.HasTransparentColor Property

PngImageInfoHasTransparentColor Property

Indicates that the image contains a transparency color.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasTransparentColor { get; set; }
Public Property HasTransparentColor As Boolean
    Get
    Set

Property Value

Type: Boolean
When HasTransparenctColor is set to true then TransparentColor will be set to a color value for the image that is supposed to be transparent.
See Also

Reference

PngImageInfo Class
Atalasoft.Imaging.Codec Namespace


PngImageInfo.PngInterlaced Property

PngImageInfoPngInterlaced Property

Gets a value indicating if the PNG is interlaced.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PngInterlaced { get; }
Public ReadOnly Property PngInterlaced As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the PNG is interlaced.
See Also

Reference

PngImageInfo Class
Atalasoft.Imaging.Codec Namespace


PngImageInfo.TransparentColor Property

PngImageInfoTransparentColor Property

Gets or sets the transparent color for the PNG image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color TransparentColor { get; set; }
Public Property TransparentColor As Color
    Get
    Set

Property Value

Type: Color
The transparent color.
See Also

Reference

PngImageInfo Class
Atalasoft.Imaging.Codec Namespace


PngImageInfo Methods

The PngImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

PngImageInfo Class
Atalasoft.Imaging.Codec Namespace


PnmDecoder Class

An ImageDecoder used to read PNM/PBM/PGM/PPM images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecPnmDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PnmDecoder : ImageDecoder
Public Class PnmDecoder
    Inherits ImageDecoder

The PnmDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PnmDecoder | Initializes an instance of the PnmDecoder.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Gets image information from a PNM image given an encoded image stream. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true of the given stream is a PNM image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Decodes a PNG image stream into an AtalaImage. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PnmDecoder Constructor

Initializes an instance of the PnmDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PnmDecoder()
Public Sub New
See Also

Reference

PnmDecoder Class
Atalasoft.Imaging.Codec Namespace


PnmDecoder Properties

The PnmDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

PnmDecoder Class
Atalasoft.Imaging.Codec Namespace


PnmDecoder Methods

The PnmDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Gets image information from a PNM image given an encoded image stream. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true of the given stream is a PNM image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Decodes a PNG image stream into an AtalaImage. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PnmDecoder Class
Atalasoft.Imaging.Codec Namespace


PnmDecoder.GetImageInfo Method

PnmDecoderGetImageInfo Method

Gets image information from a PNM image given an encoded image stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
The encoded image stream

Return Value

Type: ImageInfo
See Also

Reference

PnmDecoder Class
Atalasoft.Imaging.Codec Namespace


PnmDecoder.IsValidFormat Method

PnmDecoderIsValidFormat Method

Returns true of the given stream is a PNM image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The encoded image stream

Return Value

Type: Boolean
See Also

Reference

PnmDecoder Class
Atalasoft.Imaging.Codec Namespace


PnmDecoder.Read Method

PnmDecoderRead Method

Decodes a PNG image stream into an AtalaImage.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

PnmDecoder Class
Atalasoft.Imaging.Codec Namespace


PnmEncoder Class

Encodes an AtalaImage into a PNM image file.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecPnmEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PnmEncoder : ImageEncoder
Public Class PnmEncoder
    Inherits ImageEncoder

The PnmEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PnmEncoder | Initializes a new instance of the PnmEncoder class.
Public method | PnmEncoder(Int32) | Initializes a new instance of the PnmEncoder class.
Top
Properties
 | Name | Description
Public property | MaxValue | Gets or sets the maximum value.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Method that encodes an AtalaImage into a PNM image file given an Atalaimage and stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PnmEncoder Constructor

Overload List
 | Name | Description
Public method | PnmEncoder | Initializes a new instance of the PnmEncoder class.
Public method | PnmEncoder(Int32) | Initializes a new instance of the PnmEncoder class.
Top
See Also

Reference

PnmEncoder Class
Atalasoft.Imaging.Codec Namespace


PnmEncoder Constructor

Initializes a new instance of the PnmEncoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PnmEncoder()
Public Sub New
See Also

Reference

PnmEncoder Class
PnmEncoder Overload
Atalasoft.Imaging.Codec Namespace


PnmEncoder Constructor (Int32)

Initializes a new instance of the PnmEncoder class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PnmEncoder(
    int maxValue
)
Public Sub New (
    maxValue As Integer
)

Parameters

maxValue
Type: SystemInt32
The maximum value.
See Also

Reference

PnmEncoder Class
PnmEncoder Overload
Atalasoft.Imaging.Codec Namespace


PnmEncoder Properties

The PnmEncoder type exposes the following members.

Properties
 | Name | Description
Public property | MaxValue | Gets or sets the maximum value.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

PnmEncoder Class
Atalasoft.Imaging.Codec Namespace


PnmEncoder.MaxValue Property

PnmEncoderMaxValue Property

Gets or sets the maximum value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxValue { get; set; }
Public Property MaxValue As Integer
    Get
    Set

Property Value

Type: Int32
The maximum value.
See Also

Reference

PnmEncoder Class
Atalasoft.Imaging.Codec Namespace


PnmEncoder.SupportedPixelFormats Property

PnmEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

PnmEncoder Class
Atalasoft.Imaging.Codec Namespace


PnmEncoder Methods

The PnmEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Method that encodes an AtalaImage into a PNM image file given an Atalaimage and stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PnmEncoder Class
Atalasoft.Imaging.Codec Namespace


PnmEncoder.Save Method

PnmEncoderSave Method

Method that encodes an AtalaImage into a PNM image file given an Atalaimage and stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
Stream to encode the image into
image
Type: Atalasoft.ImagingAtalaImage

AtalaImage to encode

progress
Type: Atalasoft.ImagingProgressEventHandler
Progress delegate

Return Value

Type: Int64
See Also

Reference

PnmEncoder Class
Atalasoft.Imaging.Codec Namespace


PnmImageInfo Class

Information about a PNM Image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.CodecPnmImageInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PnmImageInfo : ImageInfo
Public Class PnmImageInfo
    Inherits ImageInfo

The PnmImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PnmImageInfo | Creates a new instance of PnmImageInfo.
Top
Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | Format | Gets the PNM Format.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | MaxValue | Gets the maximum pixel value, as specified in the file.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PnmImageInfo Constructor

Creates a new instance of PnmImageInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PnmImageInfo(
    Size size,
    int colorDepth,
    PixelFormat pixelFormat,
    PnmImageType format,
    int maxValue
)
Public Sub New (
    size As Size,
    colorDepth As Integer,
    pixelFormat As PixelFormat,
    format As PnmImageType,
    maxValue As Integer
)

Parameters

size
Type: System.DrawingSize
colorDepth
Type: SystemInt32
pixelFormat
Type: Atalasoft.ImagingPixelFormat
format
Type: Atalasoft.Imaging.CodecPnmImageType
maxValue
Type: SystemInt32
See Also

Reference

PnmImageInfo Class
Atalasoft.Imaging.Codec Namespace


PnmImageInfo Properties

The PnmImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | Format | Gets the PNM Format.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | MaxValue | Gets the maximum pixel value, as specified in the file.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
See Also

Reference

PnmImageInfo Class
Atalasoft.Imaging.Codec Namespace


PnmImageInfo.Format Property

PnmImageInfoFormat Property

Gets the PNM Format.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PnmImageType Format { get; }
Public ReadOnly Property Format As PnmImageType
    Get

Property Value

Type: PnmImageType
See Also

Reference

PnmImageInfo Class
Atalasoft.Imaging.Codec Namespace


PnmImageInfo.MaxValue Property

PnmImageInfoMaxValue Property

Gets the maximum pixel value, as specified in the file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxValue { get; }
Public ReadOnly Property MaxValue As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PnmImageInfo Class
Atalasoft.Imaging.Codec Namespace


PnmImageInfo Methods

The PnmImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

PnmImageInfo Class
Atalasoft.Imaging.Codec Namespace


PnmImageType Enumeration

The type of Pnm image

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PnmImageType
Public Enumeration PnmImageType
Members
Member name | Description
PbmAscii | Blak and White image, ASCII encoded
PbmBinary | Black and White image
PgmAscii | Grayscale image, ASCII encoded
Pgmbinary | Grayscale image
PpmAscii | RGB image, ASCII encoded
PpmBinary | RGB image
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PsdDecoder Class

An ImageDecoder used to read Adobe Photoshop (PSD) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecPsdDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PsdDecoder : ImageDecoder
Public Class PsdDecoder
    Inherits ImageDecoder

The PsdDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PsdDecoder | Initializes a new instance of a PsdDecoder.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Gets a Psd ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Psd image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetThumbnail | Gets the thumbnail image stored in the Photoshop Resource of the image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Psd image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Psd encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Color, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Psd encoded image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Psd image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.

Any layering information saved in the PSD image will be lost when read. This information is read into a merged RGB format.

For obtaining Photoshop Resources from a PSD image, see the PhotoshopResourceParser class.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


PsdDecoder Constructor

Initializes a new instance of a PsdDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PsdDecoder()
Public Sub New
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder Properties

The PsdDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Gets a Psd ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder.SupportedImageType Property

PsdDecoderSupportedImageType Property

Note: This API is now obsolete.

Gets a Psd ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder Methods

The PsdDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Psd image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetThumbnail | Gets the thumbnail image stored in the Photoshop Resource of the image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Psd image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Psd encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Color, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Psd encoded image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder.GetImageInfo Method

PsdDecoderGetImageInfo Method

Retreive information from a Psd image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder.GetThumbnail Method

PsdDecoderGetThumbnail Method

Gets the thumbnail image stored in the Photoshop Resource of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetThumbnail(
    Stream stream
)
Public Function GetThumbnail (
    stream As Stream
) As AtalaImage

Parameters

stream
Type: System.IOStream
The PSD image stream.

Return Value

Type: AtalaImage
An AtalaImage containing the thumbnail image.
Remarks
See the PhotoshopResourceParser for obtaining the RAW thumbnail data and other photoshop specific information.
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace
PhotoshopResourceParser Class


PsdDecoder.IsValidFormat Method

PsdDecoderIsValidFormat Method

Returns true if the specified Stream contains an Psd image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder.Read Method

PsdDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Psd encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Color, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Psd encoded image.
Top
See Also

Reference

PsdDecoder Class
Atalasoft.Imaging.Codec Namespace


PsdDecoder.Read Method (Stream, ProgressEventHandler)

PsdDecoderRead Method (Stream, ProgressEventHandler)

Returns an AtalaImage from a Stream containing a Psd encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

PsdDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


PsdDecoder.Read Method (Stream, Color, ProgressEventHandler)

PsdDecoderRead Method (Stream, Color, ProgressEventHandler)

Returns an AtalaImage from a Stream containing a Psd encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Read(
    Stream stream,
    Color backgroundColor,
    ProgressEventHandler progress
)
Public Function Read (
    stream As Stream,
    backgroundColor As Color,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
backgroundColor
Type: System.DrawingColor
Background color to use during rendering.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

PsdDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


PsdEncoder Class

An ImageEncoder that will write Adobe Photoshop (PSD) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecPsdEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PsdEncoder : ImageEncoder
Public Class PsdEncoder
    Inherits ImageEncoder

The PsdEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PsdEncoder | Initializes a new instance of a %PsdEncoder%.
Top
Properties
 | Name | Description
Public property | IptcTags | Gets or sets IPTC Tags that will be saved with the image.
Public property | PhotoshopResources | Gets or sets Photoshop resources to be saved with the image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Psd image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a PSD image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


PsdEncoder Constructor

Initializes a new instance of a %PsdEncoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PsdEncoder()
Public Sub New
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


PsdEncoder Properties

The PsdEncoder type exposes the following members.

Properties
 | Name | Description
Public property | IptcTags | Gets or sets IPTC Tags that will be saved with the image.
Public property | PhotoshopResources | Gets or sets Photoshop resources to be saved with the image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


PsdEncoder.IptcTags Property

PsdEncoderIptcTags Property

Gets or sets IPTC Tags that will be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection IptcTags { get; set; }
Public Property IptcTags As IptcCollection
    Get
    Set

Property Value

Type: IptcCollection
IPTC Tags that will be saved with the image.
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


PsdEncoder.PhotoshopResources Property

PsdEncoderPhotoshopResources Property

Gets or sets Photoshop resources to be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection PhotoshopResources { get; set; }
Public Property PhotoshopResources As PhotoshopResourceCollection
    Get
    Set

Property Value

Type: PhotoshopResourceCollection
Photoshop resources to be saved with the image.
Remarks
Photoshop resource information can be parsed with the PhotoshopResourceParser. When PhotoshopResources and IptcTags are set to a value other than null, IptcData will be added to the PhotoshopResource when saved.
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


PsdEncoder.SupportedPixelFormats Property

PsdEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


PsdEncoder Methods

The PsdEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an %AtalaImage% as a Psd image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


PsdEncoder.Save Method

PsdEncoderSave Method

Encode an %AtalaImage% as a Psd image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

PsdEncoder Class
Atalasoft.Imaging.Codec Namespace


RawColorSpace Enumeration

(Deprecated) Indicates the color space of the Raw image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RawColorSpace
Public Enumeration RawColorSpace
Members
Member name | Description
GrayScale | Resulting image is single channel grayscale.
Rgb | Resulting image is RGB.
FourColors | Resulting image is CMYK or GBRG.
Default | RawDecoder will automatically determine the color depth of the resulting image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


RawDecoder Class

Decoder for Digital Camera RAW Format Images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecRawDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RawDecoder : ImageDecoder, IScaledDecoder
Public Class RawDecoder
    Inherits ImageDecoder
    Implements IScaledDecoder

The RawDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | RawDecoder | Creates an instance of RawDecoder with default properties.
Public method | RawDecoder(Double, Double, Double) | Creates an instance of RawDecoder, specifying properties.
Public method | RawDecoder(Double, Double, Double, Boolean) | Obsolete. Creates an instance of RawDecoder, specifying properties.
Public method | RawDecoder(RawInterpolationMethods, RawWhiteBalanceMethods, Boolean, LoadingPolicy, Double, Double, Double) | Creates an instance of RawDecoder, specifying properties.
Public method | RawDecoder(RawInterpolationMethods, RawWhiteBalanceMethods, Boolean, LoadingPolicy, Double, Double, Double, Boolean) | Obsolete. Creates an instance of RawDecoder, specifying properties.
Top
Properties
 | Name | Description
Public property | BlueAberration | Gets or sets a value controlling the blue aberration of the image.
Public property | Brightness | Gets or sets a value controlling the brightness of the decoded image.
Public property | Interpolation | Gets or sets the interpolation method used for color enhancement.
Public property | Policy | Determines the level of safety the raw codec will try to enforce.
Public property | RedAberration | Gets or sets a value controlling the red aberration of the image.
Public property | SkipCameraInfoValidation | Gets or sets a value which determines whether camera info validation is skipped.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Public property | UseCameraMatrix | Gets or sets a value which determines if the raw codec uses the embedded color matrix in a raw image (if it exists).
Public property | WhiteBalance | Gets or sets the color balance of the image reflecting the lighting conditions under which the photo was taken.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestScale | Gets the most efficient scale factor, based on the codec's internal data handling.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Returns information about the RAW image passed as the input stream. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetPreviewImage | Returns an RGB preview image if one exists in the RAW stream.
Public method | GetThumbnail | Returns an AtalaImage containing the thumbnail image stored in the RAW stream.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the input stream is a valid RAW format. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage containing the decoded RAW image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ReadScaled | Similar to Read(Stream, ProgressEventHandler) but also scales the output in the most efficient way possible.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

To integrate the RawDecoder into DotImage, add an instance of RawDecoder to the DecoderCollection class. See the example in the RawDecoder class for more details.

The RAW Decoder supports over 250 digital camera RAW formats including but not limited to:

Adobe Digital Negative (DNG);

AgfaPhoto: DC-833m;

Apple: QuickTake 100, QuickTake 150, QuickTake 200;

ARRIRAW format;

AVT: F-080C, F-145C, F-201C ,F-510C, F-810C;

Canon: PowerShot 600, PowerShot A5, PowerShot A5 Zoom, PowerShot A50, PowerShot Pro70, PowerShot Pro90 IS, PowerShot G1, PowerShot G2, PowerShot G3, PowerShot G5, PowerShot G6, PowerShot G9, PowerShot G10, PowerShot G11, PowerShot G12, PowerShot S30, PowerShot S40, PowerShot S45, PowerShot S50, PowerShot S60, PowerShot S70, PowerShot S90, PowerShot S95, PowerShot S100, PowerShot Pro1, PowerShot SX1 IS, EOS D30, EOS D60, EOS 5D, EOS 5D Mark II, EOS 7D, EOS 10D, EOS 20D, EOS 30D, EOS 40D, EOS 50D, EOS 60D, EOS 300D / Digital Rebel / Kiss Digital, EOS 350D / Digital Rebel XT / Kiss Digital N, EOS 400D / Digital Rebel XTi / Kiss Digital X, EOS 450D / Digital Rebel XSi / Kiss Digital X2, EOS 500D / Digital Rebel T1i / Kiss Digital X3, EOS 550D / Digital Rebel T2i / Kiss Digital X4, EOS 600D / Digital Rebel T3i / Kiss Digital X5, EOS 1000D / Digital Rebel XS / Kiss Digital F, EOS 1100D / Digital Rebel T3 / Kiss Digital X50, EOS D2000C, EOS-1D, EOS-1DS, EOS-1D Mark II, EOS-1D Mark III, EOS-1D Mark IV, EOS-1D Mark II N, EOS-1Ds Mark II, EOS-1Ds Mark III;

Casio: QV-2000UX, QV-3000EX, QV-3500EX, QV-4000, QV-5700, QV-R41, QV-R51, QV-R61, EX-S20, EX-S100, EX-Z4, EX-Z50, EX-Z500, EX-Z55, EX-Z60, EX-Z75, EX-Z750, EX-Z850, EX-Z1050, EX-Z1080, Exlim Pro 505, Exlim Pro 600, Exlim Pro 700;

Contax N Digital;

Creative PC-CAM 600;

Epson R-D1;

Foculus 531C;

Fuji: FinePix E550, FinePix E900, FinePix F700, FinePix F710, FinePix F800, FinePix F810, FinePix S2Pro, FinePix S3Pro, FinePix S5Pro, FinePix S20Pro, FinePix S100FS, FinePix S5000, FinePix S5100/S5500, FinePix S5200/S5600, FinePix S6000fd, FinePix S7000, FinePix S9000/S9500, FinePix S9100/S9600, FinePix S200EXR, FinePix HS10/HS11, FinePix HS20EXR, FinePix F550EXR, FinePix X100, X10, IS-1;

Hasselblad: CFV, H3D, H4D, V96C;

Imacon: Ixpress 16-megapixel, Ixpress 22-megapixel, Ixpress 39-megapixel;

ISG 2020x1520;

Kodak: DC20, DC25, DC40, DC50, DCS200, DCS315C, DCS330C, DCS420, DCS460, DCS460A, DCS520C, DCS560C, DCS620C, DCS620X, DCS660C, DCS660M, DCS720X, DCS760C, DCS760M, EOSDCS1, EOSDCS3B, NC2000F, ProBack, PB645C, PB645H, PB645M, DCS Pro 14n, DCS Pro 14nx, DCS Pro SLR/c, DCS Pro SLR/n, C330, C603, P850, P880, Z980, Z981, Z990, Z1015, KAI-0340;

Konica: KD-400Z, KD-510Z;

Leaf: AFi 7, AFi-II 12, Aptus 17, Aptus 22, Aptus 54S, Aptus 65, Aptus 75, Aptus 75S, Cantare, CatchLight, CMost, DCB2, Valeo 6, Valeo 11, Valeo 17, Valeo 22, Volare;

Leica: Digilux 2, Digilux 3, D-LUX2, D-LUX3, D-LUX4, D-LUX5, V-LUX1, V-LUX2;

Logitech Fotoman Pixtura;

Mamiya ZD;

Micron 2010;

Minolta: RD175, DiMAGE 5, DiMAGE 7, DiMAGE 7i, DiMAGE 7Hi, DiMAGE A1, DiMAGE A2, DiMAGE A200, DiMAGE G400, DiMAGE G500, DiMAGE G530, DiMAGE G600, DiMAGE Z2, Alpha/Dynax/Maxxum 5D, Alpha/Dynax/Maxxum 7D;

Motorola PIXL;

Nikon: D1, D1H, D1X, D2H, D2Hs, D2X, D2Xs, D3, D3s, D3X, D40, D40X, D50, D60, D70, D70s, D80, D90, D100, D200, D300, D300s, D700, D3000, D3100, D5000, D5100, D7000, 1 J1, 1 V1, E5000, E5400, E5700, E8400, E8700, E8800, Coolpix P6000, Coolpix P7000;

Nokia: N95, X2;

Olympus: C3030Z, C5050Z, C5060WZ, C7070WZ, C70Z,C7000Z, C740UZ, C770UZ, C8080WZ, X200,D560Z,C350Z, E-1, E-3, E-5, E-10, E-20, E-30, E-300, E-330, E-400, E-410, E-420, E-500, E-510, E-520, E-620, E-P1, E-P2, E-P3, E-PL1, E-PL1s, E-PL2, E-PL3, E-PM1, SP310, SP320, SP350, SP500UZ, SP510UZ, SP550UZ, SP560UZ, SP570UZ, XZ-1;

Panasonic: DMC-FZ8, DMC-FZ18, DMC-FZ28, DMC-FZ30, DMC-FZ35/FZ38, DMC-FZ40, DMC-FZ50, DMC-FZ100, DMC-FZ150, DMC-FX150, DMC-G1, DMC-G2, DMC-G3, DMC-GF1, DMC-GF2, DMC-GF3, DMC-GH1, DMC-GH2, DMC-GX1DMC-L1, DMC-L10, DMC-LC1, DMC-LX1, DMC-LX2, DMC-LX3, DMC-LX5;

Pentax: *ist D, *ist DL, *ist DL2, *ist DS, *ist DS2, K10D, K20D, K100D, K100D Super, K200D, K2000/K-m, K-x, K-r, K-5, K-7, Optio S, Optio S4, Optio 33WR, Optio 750Z, 645D;

Phase One: LightPhase, H 10, H 20, H 25, P 20, P 25, P 30, P 45, P 45+;

Pixelink A782;

Polaroid x530;

Redcode R3D format;

Rollei d530flex;

RoverShot 3320af;

Samsung: EX1, GX-1S, GX-10, GX20, NX10, NX11, NX100, NX200, WB550, WB2000;

Sarnoff 4096x5440;

Sigma: SD9, SD10, SD14;

Sinar: 3072x2048 , 4080x4080 , 4080x5440 , STI format;

SMaL: Ultra-Pocket 3 , Ultra-Pocket 4 , Ultra-Pocket 5;

Sony: DSC-F828 , DSC-R1 , DSC-V3, DSLR-A100, DSLR-A200, DSLR-A230, DSLR-A290, DSLR-A300, DSLR-A330, DSLR-A350, DSLR-A380, DSLR-A450, DSLR-A500, DSLR-A550, DSLR-A580, DSLR-A700, DSLR-A850, DSLR-A900, NEX-3, NEX-5, NEX-5N, NEX-C3, SLT-A33, SLT-A35, SLT-A55V, SLT-A65V, SLT-A77V, XCD-SX910CR;

STV680 VGA.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


RawDecoder Constructor

Creates an instance of RawDecoder.
Overload List
 | Name | Description
Public method | RawDecoder | Creates an instance of RawDecoder with default properties.
Public method | RawDecoder(Double, Double, Double) | Creates an instance of RawDecoder, specifying properties.
Public method | RawDecoder(Double, Double, Double, Boolean) | Obsolete. Creates an instance of RawDecoder, specifying properties.
Public method | RawDecoder(RawInterpolationMethods, RawWhiteBalanceMethods, Boolean, LoadingPolicy, Double, Double, Double) | Creates an instance of RawDecoder, specifying properties.
Public method | RawDecoder(RawInterpolationMethods, RawWhiteBalanceMethods, Boolean, LoadingPolicy, Double, Double, Double, Boolean) | Obsolete. Creates an instance of RawDecoder, specifying properties.
Top
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder Constructor

Creates an instance of RawDecoder with default properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawDecoder()
Public Sub New
See Also

Reference

RawDecoder Class
RawDecoder Overload
Atalasoft.Imaging.Codec Namespace


RawDecoder Constructor (Double, Double, Double)

Creates an instance of RawDecoder, specifying properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawDecoder(
    double brightness,
    double redAber,
    double blueAber
)
Public Sub New (
    brightness As Double,
    redAber As Double,
    blueAber As Double
)

Parameters

brightness
Type: SystemDouble
Controls the brightness of the decoded image.
redAber
Type: SystemDouble
Red color multiplier.
blueAber
Type: SystemDouble
Blue color multiplier.
See Also

Reference

RawDecoder Class
RawDecoder Overload
Atalasoft.Imaging.Codec Namespace


RawDecoder Constructor (Double, Double, Double, Boolean)

Note: This API is now obsolete.

Creates an instance of RawDecoder, specifying properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed in next release.",
    false)]
public RawDecoder(
    double brightness,
    double redAber,
    double blueAber,
    bool gamm
)
<ObsoleteAttribute("This property is obsolete and will be removed in next release.",
    false)>
Public Sub New (
    brightness As Double,
    redAber As Double,
    blueAber As Double,
    gamm As Boolean
)

Parameters

brightness
Type: SystemDouble
Controls the brightness of the decoded image.
redAber
Type: SystemDouble
Red color multiplier.
blueAber
Type: SystemDouble
Blue color multiplier.
gamm
Type: SystemBoolean
Image processing parameter, controling pixel value within color range.
See Also

Reference

RawDecoder Class
RawDecoder Overload
Atalasoft.Imaging.Codec Namespace


RawDecoder Constructor (RawInterpolationMethods, RawWhiteBalanceMethods, Boolean, LoadingPolicy, Double, Double, Double)

Creates an instance of RawDecoder, specifying properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawDecoder(
    RawInterpolationMethods interp,
    RawWhiteBalanceMethods whiteBalance,
    bool cameraMatrix,
    LoadingPolicy policy,
    double brightness,
    double redAber,
    double blueAber
)
Public Sub New (
    interp As RawInterpolationMethods,
    whiteBalance As RawWhiteBalanceMethods,
    cameraMatrix As Boolean,
    policy As LoadingPolicy,
    brightness As Double,
    redAber As Double,
    blueAber As Double
)

Parameters

interp
Type: Atalasoft.Imaging.CodecRawInterpolationMethods
Raw interpolation method
whiteBalance
Type: Atalasoft.Imaging.CodecRawWhiteBalanceMethods
White balance correction method
cameraMatrix
Type: SystemBoolean
Color space of the resulting image
policy
Type: Atalasoft.Imaging.CodecLoadingPolicy
Loading safety policy
brightness
Type: SystemDouble
Controls the brightness of the resulting image
redAber
Type: SystemDouble
Red color multiplier
blueAber
Type: SystemDouble
Blue color multiplier
See Also

Reference

RawDecoder Class
RawDecoder Overload
Atalasoft.Imaging.Codec Namespace


RawDecoder Constructor (RawInterpolationMethods, RawWhiteBalanceMethods, Boolean, LoadingPolicy, Double, Double, Double, Boolean)

Note: This API is now obsolete.

Creates an instance of RawDecoder, specifying properties.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete and and will be removed in next release.",
    false)]
public RawDecoder(
    RawInterpolationMethods interp,
    RawWhiteBalanceMethods whiteBalance,
    bool cameraMatrix,
    LoadingPolicy policy,
    double brightness,
    double redAber,
    double blueAber,
    bool gamm
)
<ObsoleteAttribute("This constructor is obsolete and and will be removed in next release.",
    false)>
Public Sub New (
    interp As RawInterpolationMethods,
    whiteBalance As RawWhiteBalanceMethods,
    cameraMatrix As Boolean,
    policy As LoadingPolicy,
    brightness As Double,
    redAber As Double,
    blueAber As Double,
    gamm As Boolean
)

Parameters

interp
Type: Atalasoft.Imaging.CodecRawInterpolationMethods
Raw interpolation method
whiteBalance
Type: Atalasoft.Imaging.CodecRawWhiteBalanceMethods
White balance correction method
cameraMatrix
Type: SystemBoolean
Color space of the resulting image
policy
Type: Atalasoft.Imaging.CodecLoadingPolicy
Loading safety policy
brightness
Type: SystemDouble
Controls the brightness of the resulting image
redAber
Type: SystemDouble
Red color multiplier
blueAber
Type: SystemDouble
Blue color multiplier
gamm
Type: SystemBoolean
Image processing parameter, controlling pixel value within color range
See Also

Reference

RawDecoder Class
RawDecoder Overload
Atalasoft.Imaging.Codec Namespace


RawDecoder Properties

The RawDecoder type exposes the following members.

Properties
 | Name | Description
Public property | BlueAberration | Gets or sets a value controlling the blue aberration of the image.
Public property | Brightness | Gets or sets a value controlling the brightness of the decoded image.
Public property | Interpolation | Gets or sets the interpolation method used for color enhancement.
Public property | Policy | Determines the level of safety the raw codec will try to enforce.
Public property | RedAberration | Gets or sets a value controlling the red aberration of the image.
Public property | SkipCameraInfoValidation | Gets or sets a value which determines whether camera info validation is skipped.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Public property | UseCameraMatrix | Gets or sets a value which determines if the raw codec uses the embedded color matrix in a raw image (if it exists).
Public property | WhiteBalance | Gets or sets the color balance of the image reflecting the lighting conditions under which the photo was taken.
Top
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.BlueAberration Property

RawDecoderBlueAberration Property

Gets or sets a value controlling the blue aberration of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BlueAberration { get; set; }
Public Property BlueAberration As Double
    Get
    Set

Property Value

Type: Double
Remarks
Defaults to 1.0.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.Brightness Property

RawDecoderBrightness Property

Gets or sets a value controlling the brightness of the decoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
A value controlling the brightness of the decoded image.
Remarks
Default value is 1.0.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.Interpolation Property

RawDecoderInterpolation Property

Gets or sets the interpolation method used for color enhancement.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawInterpolationMethods Interpolation { get; set; }
Public Property Interpolation As RawInterpolationMethods
    Get
    Set

Property Value

Type: RawInterpolationMethods
The interpolation method used for color enhancement.
Remarks
Default method is Bilinear and VNG.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.Policy Property

RawDecoderPolicy Property

Determines the level of safety the raw codec will try to enforce.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LoadingPolicy Policy { get; set; }
Public Property Policy As LoadingPolicy
    Get
    Set

Property Value

Type: LoadingPolicy
Remarks
Default is IgnoreFileBounds.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.RedAberration Property

RawDecoderRedAberration Property

Gets or sets a value controlling the red aberration of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double RedAberration { get; set; }
Public Property RedAberration As Double
    Get
    Set

Property Value

Type: Double
Remarks
Defaults to 1.0.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.SkipCameraInfoValidation Property

RawDecoderSkipCameraInfoValidation Property

Gets or sets a value which determines whether camera info validation is skipped.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SkipCameraInfoValidation { get; set; }
Public Property SkipCameraInfoValidation As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Defaults to false. If the property is set to true then validation that the source image camera maker and model are supported isn't performed which could leave to the errors.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.UseCameraMatrix Property

RawDecoderUseCameraMatrix Property

Gets or sets a value which determines if the raw codec uses the embedded color matrix in a raw image (if it exists).

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseCameraMatrix { get; set; }
Public Property UseCameraMatrix As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Defaults to false
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.WhiteBalance Property

RawDecoderWhiteBalance Property

Gets or sets the color balance of the image reflecting the lighting conditions under which the photo was taken.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawWhiteBalanceMethods WhiteBalance { get; set; }
Public Property WhiteBalance As RawWhiteBalanceMethods
    Get
    Set

Property Value

Type: RawWhiteBalanceMethods
The color balance of the image reflecting the lighting conditions under which the photo was taken.
Remarks
Default is RawWhiteBalanceMethod.None.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder Methods

The RawDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestScale | Gets the most efficient scale factor, based on the codec's internal data handling.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Returns information about the RAW image passed as the input stream. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetPreviewImage | Returns an RGB preview image if one exists in the RAW stream.
Public method | GetThumbnail | Returns an AtalaImage containing the thumbnail image stored in the RAW stream.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the input stream is a valid RAW format. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage containing the decoded RAW image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ReadScaled | Similar to Read(Stream, ProgressEventHandler) but also scales the output in the most efficient way possible.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.GetBestScale Method

RawDecoderGetBestScale Method

Gets the most efficient scale factor, based on the codec's internal data handling.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GetBestScale(
    Stream stream,
    int frameIndex,
    double requestedScale
)
Public Overridable Function GetBestScale (
    stream As Stream,
    frameIndex As Integer,
    requestedScale As Double
) As Double

Parameters

stream
Type: System.IOStream
A stream containing the image data on which you would like to perform this operation on.
frameIndex
Type: SystemInt32
A zero based integer which determines which frame you would like to perform this operation on.
requestedScale
Type: SystemDouble
The scale factor you would like.

Return Value

Type: Double
The closest scale factor which is efficient to use.

Implements

IScaledDecoderGetBestScale(Stream, Int32, Double)
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.GetImageInfo Method

RawDecoderGetImageInfo Method

Returns information about the RAW image passed as the input stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
Input stream

Return Value

Type: ImageInfo
Information about the RAW image passed as the input stream.
Remarks
Cast the returned ImageInfo object to a RawImageInfo object in order to obtain detailed RAW information.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace
Atalasoft.Imaging.CodecRawImageInfo


RawDecoder.GetPreviewImage Method

RawDecoderGetPreviewImage Method

Returns an RGB preview image if one exists in the RAW stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetPreviewImage(
    Stream stream
)
Public Function GetPreviewImage (
    stream As Stream
) As AtalaImage

Parameters

stream
Type: System.IOStream
The RAW image stream

Return Value

Type: AtalaImage
Returns null when there is no preview image, or an AtalaImage containing the image if one exists.
Remarks
Usually, this image is larger than a thumbnail, and stored within the RAW image to viewers can quickly view the image data without processing the RAW image.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.GetThumbnail Method

RawDecoderGetThumbnail Method

Returns an AtalaImage containing the thumbnail image stored in the RAW stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetThumbnail(
    Stream stream
)
Public Function GetThumbnail (
    stream As Stream
) As AtalaImage

Parameters

stream
Type: System.IOStream
Input stream

Return Value

Type: AtalaImage
Returns the thumbnail image if one exists, or null (Nothing in VB) if there is no thumbnail.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.IsValidFormat Method

RawDecoderIsValidFormat Method

Returns true if the input stream is a valid RAW format.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The input stream.

Return Value

Type: Boolean
True if the input stream is a valid Raw format.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.Read Method

RawDecoderRead Method

Returns an AtalaImage containing the decoded RAW image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
Input stream
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB) to ignore progress events.

Return Value

Type: AtalaImage
An AtalaImage containing the decoded RAW image.
Remarks
The RawDecoder's Policy property determines the safety of this function.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawDecoder.ReadScaled Method

RawDecoderReadScaled Method

Similar to Read(Stream, ProgressEventHandler) but also scales the output in the most efficient way possible.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage ReadScaled(
    Stream stream,
    int frameIndex,
    double scaleFactor,
    ProgressEventHandler progress
)
Public Overridable Function ReadScaled (
    stream As Stream,
    frameIndex As Integer,
    scaleFactor As Double,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
Input stream
frameIndex
Type: SystemInt32
frame which to read
scaleFactor
Type: SystemDouble
desired scale factor
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB) to ignore progress events.

Return Value

Type: AtalaImage
An AtalaImage containing the decoded RAW image.

Implements

IScaledDecoderReadScaled(Stream, Int32, Double, ProgressEventHandler)
Remarks
The RawDecoder's Policy property determines the safety of this function.
See Also

Reference

RawDecoder Class
Atalasoft.Imaging.Codec Namespace


RawImageInfo Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.CodecRawImageInfo

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RawImageInfo : ImageInfo
Public Class RawImageInfo
    Inherits ImageInfo

The RawImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | RawImageInfo(ImageInfo) | Initializes an instance of RawImageInfo.
Public method | RawImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, CameraInfo) | Initializes an instance of RawImageInfo.
Public method | RawImageInfo(Size, Size, Int32, ImageType, Dpi, PixelFormat, CameraInfo) | Initializes an instance of RawImageInfo.
Top
Properties
 | Name | Description
Public property | CameraInfo | Gets detailed camera information.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | DataSize | Gets the size of the RAW data in bytes
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | RawImageSize | Gets the size in pixels of the original RAW image including margins.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec Namespace


RawImageInfo Constructor

Initializes an instance of RawImageInfo.
Overload List
 | Name | Description
Public method | RawImageInfo(ImageInfo) | Initializes an instance of RawImageInfo.
Public method | RawImageInfo(Size, Int32, ImageType, Dpi, PixelFormat, CameraInfo) | Initializes an instance of RawImageInfo.
Public method | RawImageInfo(Size, Size, Int32, ImageType, Dpi, PixelFormat, CameraInfo) | Initializes an instance of RawImageInfo.
Top
See Also

Reference

RawImageInfo Class
Atalasoft.Imaging.Codec Namespace


RawImageInfo Constructor (ImageInfo)

Initializes an instance of RawImageInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawImageInfo(
    ImageInfo info
)
Public Sub New (
    info As ImageInfo
)

Parameters

info
Type: Atalasoft.Imaging.CodecImageInfo
info
See Also

Reference

RawImageInfo Class
RawImageInfo Overload
Atalasoft.Imaging.Codec Namespace


RawImageInfo Constructor (Size, Int32, ImageType, Dpi, PixelFormat, CameraInfo)

Initializes an instance of RawImageInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawImageInfo(
    Size imageSize,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat,
    CameraInfo cameraInfo
)
Public Sub New (
    imageSize As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat,
    cameraInfo As CameraInfo
)

Parameters

imageSize
Type: System.DrawingSize
image size
colorDepth
Type: SystemInt32
bits per pixel of the image
imageType
Type: Atalasoft.Imaging.CodecImageType
supported image file formats that dotImage can either read or write
resolution
Type: Atalasoft.ImagingDpi
resolution of image
pixelFormat
Type: Atalasoft.ImagingPixelFormat
specifies the format of the color data for each pixel in the image
cameraInfo
Type: Atalasoft.Imaging.CodecCameraInfo
information on digital camera by which raw image was taken
See Also

Reference

RawImageInfo Class
RawImageInfo Overload
Atalasoft.Imaging.Codec Namespace


RawImageInfo Constructor (Size, Size, Int32, ImageType, Dpi, PixelFormat, CameraInfo)

Initializes an instance of RawImageInfo.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawImageInfo(
    Size imageSize,
    Size rawImageSize,
    int colorDepth,
    ImageType imageType,
    Dpi resolution,
    PixelFormat pixelFormat,
    CameraInfo cameraInfo
)
Public Sub New (
    imageSize As Size,
    rawImageSize As Size,
    colorDepth As Integer,
    imageType As ImageType,
    resolution As Dpi,
    pixelFormat As PixelFormat,
    cameraInfo As CameraInfo
)

Parameters

imageSize
Type: System.DrawingSize
processed size of output image
rawImageSize
Type: System.DrawingSize
original size of raw image
colorDepth
Type: SystemInt32
bits per pixel of the image
imageType
Type: Atalasoft.Imaging.CodecImageType
supported image file formats that dotImage can either read or write
resolution
Type: Atalasoft.ImagingDpi
resolution of image
pixelFormat
Type: Atalasoft.ImagingPixelFormat
specifies the format of the color data for each pixel in the image
cameraInfo
Type: Atalasoft.Imaging.CodecCameraInfo
information on digital camera by which raw image was taken
See Also

Reference

RawImageInfo Class
RawImageInfo Overload
Atalasoft.Imaging.Codec Namespace


RawImageInfo Properties

The RawImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | CameraInfo | Gets detailed camera information.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | DataSize | Gets the size of the RAW data in bytes
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | RawImageSize | Gets the size in pixels of the original RAW image including margins.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
See Also

Reference

RawImageInfo Class
Atalasoft.Imaging.Codec Namespace


RawImageInfo.CameraInfo Property

RawImageInfoCameraInfo Property

Gets detailed camera information.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CameraInfo CameraInfo { get; set; }
Public Property CameraInfo As CameraInfo
    Get
    Set

Property Value

Type: CameraInfo
Detailed camera information.
See Also

Reference

RawImageInfo Class
Atalasoft.Imaging.Codec Namespace


RawImageInfo.DataSize Property

RawImageInfoDataSize Property

Gets the size of the RAW data in bytes

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DataSize { get; }
Public ReadOnly Property DataSize As Integer
    Get

Property Value

Type: Int32
The size of the RAW data in bytes
See Also

Reference

RawImageInfo Class
Atalasoft.Imaging.Codec Namespace


RawImageInfo.RawImageSize Property

RawImageInfoRawImageSize Property

Gets the size in pixels of the original RAW image including margins.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size RawImageSize { get; set; }
Public Property RawImageSize As Size
    Get
    Set

Property Value

Type: Size
The size in pixels of the original RAW image including margins.
See Also

Reference

RawImageInfo Class
Atalasoft.Imaging.Codec Namespace


RawImageInfo Methods

The RawImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

RawImageInfo Class
Atalasoft.Imaging.Codec Namespace


RawInterpolationMethods Enumeration

The RAW format has one color per pixel due to BAYER transformation performed inside D.C. RawInterpolationMethod indicates the type of interpolation performed, if any, to transform the image into the desired colorspace.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum RawInterpolationMethods
<FlagsAttribute>
Public Enumeration RawInterpolationMethods
Members
Member name | Description
None | Does not interpolate colors, provides RAW image data.
BiLinear | Performs Bi-Linear interpolation.
Vng | Performs VNG interpolation.
Ahd | Performs AHD interpolation.
See Also

Reference

Atalasoft.Imaging.Codec Namespace
[!:RawDecoder.Interpolation]


RawWhiteBalanceMethods Enumeration

Indicates the type of white balance correction, if any, to apply.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Raw (in Atalasoft.dotImage.Raw.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum RawWhiteBalanceMethods
<FlagsAttribute>
Public Enumeration RawWhiteBalanceMethods
Members
Member name | Description
None | Do not correct for white balance.
AutoWhiteBalance | Performs auto white balance correction.
CameraWhiteBalance | Performs white balance correction based on camera settings.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


RegisteredDecoders Class

This class includes static members containing information on image decoders to use in the project when reading images as well as methods to obtain a an appropriate decoder based on an image stream or filename.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecRegisteredDecoders

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class RegisteredDecoders
Public NotInheritable Class RegisteredDecoders

The RegisteredDecoders type exposes the following members.

Properties
Name | Description
Decoders | Gets a static collection of Image Decoders that will be used to decode any arbitrary image.
KnownTypeDecoders | Obsolete. Gets the known type decoders.
UnknownTypeDecoders | Obsolete. Returns a reference to the decoders that are used for reading images that dotImage doesn't recognize as a standard ImageType.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetDecoder | Returns an ImageDecoderthat can be used to decode the given stream.
 | GetDecoderFromType | Returns an ImageDecoder that matches a specific type.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetImageInfo(Stream) | Returns information about an encoded image file specifying a stream.
 | GetImageInfo(String) | Returns information about an encoded image file specifying a filename.
 | GetImageInfo(Stream, Int32) | Returns information about an encoded image file specifying a stream and frame index.
 | GetImageInfo(String, Int32) | Returns information about an encoded image file specifying a filename and frame index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Any file format extensions, such as the DotImage Jpeg2000 should be registered using this class by adding the decoders to the Decoders collection.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


RegisteredDecoders Properties

The RegisteredDecoders type exposes the following members.

Properties
Name | Description
Decoders | Gets a static collection of Image Decoders that will be used to decode any arbitrary image.
KnownTypeDecoders | Obsolete. Gets the known type decoders.
UnknownTypeDecoders | Obsolete. Returns a reference to the decoders that are used for reading images that dotImage doesn't recognize as a standard ImageType.
Top
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.Decoders Property

RegisteredDecodersDecoders Property

Gets a static collection of Image Decoders that will be used to decode any arbitrary image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DecoderCollection Decoders { get; }
Public Shared ReadOnly Property Decoders As DecoderCollection
    Get

Property Value

Type: DecoderCollection
Remarks
Add any custom decoders to this collection so that the AtalaImage constructor and Workspace.Open will use that decoder when attempting to load an image. DotImage will loop through each decoder testing the IsValidFormat until it returns true. The decoders collection is order dependent.
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.KnownTypeDecoders Property

RegisteredDecodersKnownTypeDecoders Property

Note: This API is now obsolete.

Gets the known type decoders.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions. Use the 'Decoders' property instead.",
    false)]
public static DecoderDictionary KnownTypeDecoders { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions. Use the 'Decoders' property instead.",
    false)>
Public Shared ReadOnly Property KnownTypeDecoders As DecoderDictionary
    Get

Property Value

Type: DecoderDictionary
The known type decoders.
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.UnknownTypeDecoders Property

RegisteredDecodersUnknownTypeDecoders Property

Note: This API is now obsolete.

Returns a reference to the decoders that are used for reading images that dotImage doesn't recognize as a standard ImageType.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions. Use the 'Decoders' property instead.",
    false)]
public static DecoderCollection UnknownTypeDecoders { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions. Use the 'Decoders' property instead.",
    false)>
Public Shared ReadOnly Property UnknownTypeDecoders As DecoderCollection
    Get

Property Value

Type: DecoderCollection
A reference to the decoders that are used for reading images that dotImage doesn't recognize as a standard ImageType.
Remarks

An unlimited number of formats not natively supported by dotImage can be added by including the decoders in this collection.

See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders Methods

The RegisteredDecoders type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetDecoder | Returns an ImageDecoderthat can be used to decode the given stream.
 | GetDecoderFromType | Returns an ImageDecoder that matches a specific type.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetImageInfo(Stream) | Returns information about an encoded image file specifying a stream.
 | GetImageInfo(String) | Returns information about an encoded image file specifying a filename.
 | GetImageInfo(Stream, Int32) | Returns information about an encoded image file specifying a stream and frame index.
 | GetImageInfo(String, Int32) | Returns information about an encoded image file specifying a filename and frame index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetDecoder Method

RegisteredDecodersGetDecoder Method

Returns an ImageDecoderthat can be used to decode the given stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImageDecoder GetDecoder(
    Stream stream
)
Public Shared Function GetDecoder (
    stream As Stream
) As ImageDecoder

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageDecoder
Remarks
Use this method for obtaining the file format of an image saved to a file. See %GetImageInfo% for obtaining the file format and extended information.
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetDecoderFromType Method

RegisteredDecodersGetDecoderFromType Method

Returns an ImageDecoder that matches a specific type.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImageDecoder GetDecoderFromType(
    Type codecType
)
Public Shared Function GetDecoderFromType (
    codecType As Type
) As ImageDecoder

Parameters

codecType
Type: SystemType
The type of decoder to retreive.

Return Value

Type: ImageDecoder
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetImageInfo Method

RegisteredDecodersGetImageInfo Method

Overload List
Name | Description
GetImageInfo(Stream) | Returns information about an encoded image file specifying a stream.
GetImageInfo(String) | Returns information about an encoded image file specifying a filename.
GetImageInfo(Stream, Int32) | Returns information about an encoded image file specifying a stream and frame index.
GetImageInfo(String, Int32) | Returns information about an encoded image file specifying a filename and frame index.
Top
See Also

Reference

RegisteredDecoders Class
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetImageInfo Method (Stream)

RegisteredDecodersGetImageInfo Method (Stream)

Returns information about an encoded image file specifying a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImageInfo GetImageInfo(
    Stream stream
)
Public Shared Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

RegisteredDecoders Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetImageInfo Method (String)

RegisteredDecodersGetImageInfo Method (String)

Returns information about an encoded image file specifying a filename.
Returns information about an encoded image file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImageInfo GetImageInfo(
    string fileName
)
Public Shared Function GetImageInfo (
    fileName As String
) As ImageInfo

Parameters

fileName
Type: SystemString
A file name containing the encoded image data.

Return Value

Type: ImageInfo
The ImageInfo from an existing file.
See Also

Reference

RegisteredDecoders Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetImageInfo Method (Stream, Int32)

RegisteredDecodersGetImageInfo Method (Stream, Int32)

Returns information about an encoded image file specifying a stream and frame index.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Shared Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to retreive information from.

Return Value

Type: ImageInfo
See Also

Reference

RegisteredDecoders Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


RegisteredDecoders.GetImageInfo Method (String, Int32)

RegisteredDecodersGetImageInfo Method (String, Int32)

Returns information about an encoded image file specifying a filename and frame index.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ImageInfo GetImageInfo(
    string fileName,
    int frameIndex
)
Public Shared Function GetImageInfo (
    fileName As String,
    frameIndex As Integer
) As ImageInfo

Parameters

fileName
Type: SystemString
A file name containing the encoded image data.
frameIndex
Type: SystemInt32
If the image contains multiple frames, this is the zero based index to retreive information from.

Return Value

Type: ImageInfo
The ImageInfo from an existing file.
See Also

Reference

RegisteredDecoders Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


TgaDecoder Class

An ImageDecoder used to read Truevision Targa (TGA) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecTgaDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TgaDecoder : ImageDecoder
Public Class TgaDecoder
    Inherits ImageDecoder

The TgaDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | TgaDecoder | Initializes a new instance of a TgaDecoder.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Tga ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Targa image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Targa image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Targa encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Targa image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.

Because there is no identifier when reading Tga images, it is up to the developer to detect the file extension, and if "tga" then specify this decoder directly. In many cases, dotImage cannot guess an image is encoded as a TGA.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


TgaDecoder Constructor

Initializes a new instance of a TgaDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TgaDecoder()
Public Sub New
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaDecoder Properties

The TgaDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Tga ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaDecoder.SupportedImageType Property

TgaDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Tga ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaDecoder Methods

The TgaDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Targa image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Targa image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Returns an AtalaImage from a Stream containing a Targa encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaDecoder.GetImageInfo Method

TgaDecoderGetImageInfo Method

Retreive information from a Targa image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaDecoder.IsValidFormat Method

TgaDecoderIsValidFormat Method

Returns true if the specified Stream contains an Targa image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaDecoder.Read Method

TgaDecoderRead Method

Returns an AtalaImage from a Stream containing a Targa encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
See Also

Reference

TgaDecoder Class
Atalasoft.Imaging.Codec Namespace


TgaEncoder Class

Summary description for TgaEncoder.

An ImageEncoder that will write Truevision Targa (TGA) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecTgaEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TgaEncoder : ImageEncoder
Public Class TgaEncoder
    Inherits ImageEncoder

The TgaEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | TgaEncoder | Initializes a new instance of a %TgaEncoder%.
Top
Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Tga image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a TGA image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


TgaEncoder Constructor

Initializes a new instance of a %TgaEncoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TgaEncoder()
Public Sub New
See Also

Reference

TgaEncoder Class
Atalasoft.Imaging.Codec Namespace


TgaEncoder Properties

The TgaEncoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

TgaEncoder Class
Atalasoft.Imaging.Codec Namespace


TgaEncoder.SupportedPixelFormats Property

TgaEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

TgaEncoder Class
Atalasoft.Imaging.Codec Namespace


TgaEncoder Methods

The TgaEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Tga image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TgaEncoder Class
Atalasoft.Imaging.Codec Namespace


TgaEncoder.Save Method

TgaEncoderSave Method

Encode an AtalaImage as a Tga image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

TgaEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Class

This class represents the compression for a TIFF image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecCodecCompression
Atalasoft.Imaging.CodecTiffCodecCompression

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffCodecCompression : CodecCompression
Public Class TiffCodecCompression
    Inherits CodecCompression

The TiffCodecCompression type exposes the following members.

Constructors
 | Name | Description
Public method | TiffCodecCompression(TiffCompression) | Creates a new instance of TiffCodecCompression specifying the compression type.
Public method | TiffCodecCompression(TiffCompression, Int32) | Creates a new instance of TiffCodecCompression specifying the compression type and JPEG quality.
Public method | TiffCodecCompression(TiffCompression, Int32, Boolean) | Creates a new instance of TiffCodecCompression specifying the compression type, JPEG Quality, and LZW Predictor.
Public method | TiffCodecCompression(TiffCompression, Int32, Boolean, Boolean) | Creates a new instance of TiffCodecCompression specifying the compression type, JPEG Quality, and LZW Predictor, and whether to use old style JPEG compression.
Top
Properties
 | Name | Description
Public property | Compression | Gets or sets the TIFF compression to use.
Public property | JpegQuality | Gets or sets the JPEG quality when Compression is set to JPEG.
Public property | UseLzwPredictor | Gets or sets the LZW predictor value.
Public property | UseOldJpegCompression | Obsolete. Gets or sets a value indicating if Old Style JPEG compression should be used when Compression is set to JPEG.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Used in the MultiFramedImageEncoder when saving a multipage image to indicate the compression settings for each page in a TIFF.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Constructor

Creates a new instance of TiffCodecCompression.
Overload List
 | Name | Description
Public method | TiffCodecCompression(TiffCompression) | Creates a new instance of TiffCodecCompression specifying the compression type.
Public method | TiffCodecCompression(TiffCompression, Int32) | Creates a new instance of TiffCodecCompression specifying the compression type and JPEG quality.
Public method | TiffCodecCompression(TiffCompression, Int32, Boolean) | Creates a new instance of TiffCodecCompression specifying the compression type, JPEG Quality, and LZW Predictor.
Public method | TiffCodecCompression(TiffCompression, Int32, Boolean, Boolean) | Creates a new instance of TiffCodecCompression specifying the compression type, JPEG Quality, and LZW Predictor, and whether to use old style JPEG compression.
Top
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Constructor (TiffCompression)

Creates a new instance of TiffCodecCompression specifying the compression type.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffCodecCompression(
    TiffCompression compression
)
Public Sub New (
    compression As TiffCompression
)

Parameters

compression
Type: Atalasoft.Imaging.CodecTiffCompression
See Also

Reference

TiffCodecCompression Class
TiffCodecCompression Overload
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Constructor (TiffCompression, Int32)

Creates a new instance of TiffCodecCompression specifying the compression type and JPEG quality.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffCodecCompression(
    TiffCompression compression,
    int jpegQuality
)
Public Sub New (
    compression As TiffCompression,
    jpegQuality As Integer
)

Parameters

compression
Type: Atalasoft.Imaging.CodecTiffCompression
jpegQuality
Type: SystemInt32
See Also

Reference

TiffCodecCompression Class
TiffCodecCompression Overload
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Constructor (TiffCompression, Int32, Boolean)

Creates a new instance of TiffCodecCompression specifying the compression type, JPEG Quality, and LZW Predictor.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffCodecCompression(
    TiffCompression compression,
    int jpegQuality,
    bool useLzwPredictor
)
Public Sub New (
    compression As TiffCompression,
    jpegQuality As Integer,
    useLzwPredictor As Boolean
)

Parameters

compression
Type: Atalasoft.Imaging.CodecTiffCompression
jpegQuality
Type: SystemInt32
useLzwPredictor
Type: SystemBoolean
See Also

Reference

TiffCodecCompression Class
TiffCodecCompression Overload
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Constructor (TiffCompression, Int32, Boolean, Boolean)

Creates a new instance of TiffCodecCompression specifying the compression type, JPEG Quality, and LZW Predictor, and whether to use old style JPEG compression.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffCodecCompression(
    TiffCompression compression,
    int jpegQuality,
    bool useLzwPredictor,
    bool useOldJpegCompression
)
Public Sub New (
    compression As TiffCompression,
    jpegQuality As Integer,
    useLzwPredictor As Boolean,
    useOldJpegCompression As Boolean
)

Parameters

compression
Type: Atalasoft.Imaging.CodecTiffCompression
jpegQuality
Type: SystemInt32
useLzwPredictor
Type: SystemBoolean
useOldJpegCompression
Type: SystemBoolean
See Also

Reference

TiffCodecCompression Class
TiffCodecCompression Overload
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Properties

The TiffCodecCompression type exposes the following members.

Properties
 | Name | Description
Public property | Compression | Gets or sets the TIFF compression to use.
Public property | JpegQuality | Gets or sets the JPEG quality when Compression is set to JPEG.
Public property | UseLzwPredictor | Gets or sets the LZW predictor value.
Public property | UseOldJpegCompression | Obsolete. Gets or sets a value indicating if Old Style JPEG compression should be used when Compression is set to JPEG.
Top
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression.Compression Property

TiffCodecCompressionCompression Property

Gets or sets the TIFF compression to use.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffCompression Compression { get; set; }
Public Property Compression As TiffCompression
    Get
    Set

Property Value

Type: TiffCompression
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression.JpegQuality Property

TiffCodecCompressionJpegQuality Property

Gets or sets the JPEG quality when Compression is set to JPEG.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression.UseLzwPredictor Property

TiffCodecCompressionUseLzwPredictor Property

Gets or sets the LZW predictor value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseLzwPredictor { get; set; }
Public Property UseLzwPredictor As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression.UseOldJpegCompression Property

TiffCodecCompressionUseOldJpegCompression Property

Note: This API is now obsolete.

Gets or sets a value indicating if Old Style JPEG compression should be used when Compression is set to JPEG.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Warning - using old-style jpeg compression will create TIFF images that are non-standard and will work with very few applications.",
    false)]
public bool UseOldJpegCompression { get; set; }
<ObsoleteAttribute("Warning - using old-style jpeg compression will create TIFF images that are non-standard and will work with very few applications.",
    false)>
Public Property UseOldJpegCompression As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCodecCompression Methods

The TiffCodecCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffCodecCompression Class
Atalasoft.Imaging.Codec Namespace


TiffCompression Enumeration

Contains the various compression types available for TIFF images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TiffCompression
Public Enumeration TiffCompression
Members
Member name | Description
NoCompression | Specify no compression.
Group3FaxEncoding | CCITT Group 3 fax encoding. Used on 1-bit images only, otherwise uses no compression.
Group4FaxEncoding | CCITT Group 4 fax encoding. Used on 1-bit images only, otherwise uses no compression.
JpegCompression | Lossy JPEG compression. Used on 8-bit grayscale and 24-bit RGB images only, otherwise uses no compression.
MacintoshPackbits | A modified RLE (run length encoding) style of compression
Deflate | ZIPLib compression, similar to PNG and WinZip
Lzw | LZW compression.
ModifiedHuffman | CCITT modified Huffman RLE. Used on 1-bit images only, otherwise uses no compression.
Default | Chooses the most appropriate compression depending on the pixel format. 1-bpp image will be saved with CCITG4 compression, and everything else will use LZW.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


TiffDecoder Class

An ImageDecoder used to read Tagged Image File Format (TIFF) images from an image Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.CodecTiffDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffDecoder : MultiFramedImageDecoder,
    IRegionReadable, IScaledDecoder
Public Class TiffDecoder
    Inherits MultiFramedImageDecoder
    Implements IRegionReadable, IScaledDecoder

The TiffDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | TiffDecoder | Initializes a new instance of a %TiffDecoder%.
Top
Properties
 | Name | Description
Public property | CorrectOrientation | Gets or sets a value that when true (the default) will automatically correct the image orientation by rotating and/or flipping based on the TIFF_ORIENTATION tag setting.
Public property | ScaledResampleMethod | Gets or sets the resampling method to use for ReadScaled.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestScale | Gets the most effiicient image scale stored within the codec.
Public method | GetFrameCount | Returns the number of pages in an Encoded Tiff file. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from a Tiff image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Retreive information from a Tiff image stored in a Stream without decoding the image data. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
 | GetTiffTag(Int32, Stream, Int32) | Gets a TIFF Tag from a TIFF image stream.
 | GetTiffTag(Int32, String, Int32) | Gets a TIFF Tag from a TIFF file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an TIFF image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(Stream, ProgressEventHandler) | Decodes an image from a supplied TIFF image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
 | Read(Stream, Int32, ProgressEventHandler) | Decodes an image from a supplied TIFF image Stream specifying a frame index. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ReadRegion | Decodes a specified region of a TIFF image given a source Stream.
Public method | ReadScaled | Decodes an image to a specified scale.
Public method | ReadStrip | Decodes a specified strip from a TIFF image stream that is encoded with strips.
Public method | ReadTile | Decodes a specified tile from a TIFF image stream that is encoded with strips.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a TIFF image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the Decoders collection and does not have to be explicitly set.

TIFF images can contain multiple pages in one file. You may wish to specify which page to read or get information about by specifying the frameindex in the associated Read methods.

TIFF images can store metadata such as EXIF, IPTC, XMP, and other TIFF tags. See the %Atalasoft.Imaging.Metadata% namespace for more information on reading this information.

Examples

Split a multi-page TIFF into individual pages

[New Example] (C#)
Copy
//initialize an instance of a TiffDecoder
TiffDecoder tiffReader = new TiffDecoder();
//open the file stream
FileStream fs = File.OpenRead(@"C:\Development\Image Database\Tiff\1_multi.tif");
//get the number of pages in the TIFF
int pageCount = tiffReader.GetFrameCount(fs);
//loop through each page in the TIFF
for (int i = 0; i < pageCount; i++)
{
    //seek to the beginning of the file
    fs.Seek(0, SeekOrigin.Begin);
    //read the specified frameindex
    AtalaImage page = tiffReader.Read(fs, i, null);
    //save the page as a standalone TIFF in the working directory
    page.Save(Path.GetFileNameWithoutExtension(fs.Name) + "_" + i + ".tif", new TiffEncoder(), null);
    //dispose of uneeded image
    page.Dispose();
}
[New Example] (Visual Basic)
Copy
'initialize an instance of a TiffDecoder
Dim tiffReader As TiffDecoder = New TiffDecoder()
'open the file stream
Dim fs As FileStream =  File.OpenRead("C:\Development\Image Database\Tiff\1_multi.tif")
'get the number of pages in the TIFF
Dim pageCount As Integer =  tiffReader.GetFrameCount(fs)
'loop through each page in the TIFF
Dim i As Integer
For  i = 0 To pageCount - 1
    'seek to the beginning of the file
    fs.Seek(0, SeekOrigin.Begin)
    'read the specified frameindex
    Dim page As AtalaImage = tiffReader.Read(fs, i, Nothing)
    'save the page as a standalone TIFF in the working directory
    page.Save(Path.GetFileNameWithoutExtension(fs.Name) & "_" & i & ".tif", New TiffEncoder(), Nothing)
    'dispose of uneeded image
    page.Dispose()
Next
See Also

Reference

Atalasoft.Imaging.Codec Namespace


TiffDecoder Constructor

Initializes a new instance of a %TiffDecoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDecoder()
Public Sub New
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder Properties

The TiffDecoder type exposes the following members.

Properties
 | Name | Description
Public property | CorrectOrientation | Gets or sets a value that when true (the default) will automatically correct the image orientation by rotating and/or flipping based on the TIFF_ORIENTATION tag setting.
Public property | ScaledResampleMethod | Gets or sets the resampling method to use for ReadScaled.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.CorrectOrientation Property

TiffDecoderCorrectOrientation Property

Gets or sets a value that when true (the default) will automatically correct the image orientation by rotating and/or flipping based on the TIFF_ORIENTATION tag setting.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CorrectOrientation { get; set; }
Public Property CorrectOrientation As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Speed can be improved when setting this value to false on large images where the orientation is a value other than 1, however the resulting image will be rotated and/or flipped. The methods ReadRegion(Stream, Rectangle, Int32, ProgressEventHandler), ReadTile(Stream, Point, Int32, ProgressEventHandler), and ReadStrip(Stream, Int32, Int32, ProgressEventHandler) ignore this setting and will never correct for orientation.
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.ScaledResampleMethod Property

TiffDecoderScaledResampleMethod Property

Gets or sets the resampling method to use for ReadScaled.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleDocumentMethod ScaledResampleMethod { get; set; }
Public Property ScaledResampleMethod As ResampleDocumentMethod
    Get
    Set

Property Value

Type: ResampleDocumentMethod
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.SupportedImageType Property

TiffDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns the ImageType that the implemented decoder class supports.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
The ImageType that the implemented decoder class supports.
Remarks
If the decoder supports a format not included with dotImage, then this will return Unknown.
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder Methods

The TiffDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBestScale | Gets the most effiicient image scale stored within the codec.
Public method | GetFrameCount | Returns the number of pages in an Encoded Tiff file. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from a Tiff image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Retreive information from a Tiff image stored in a Stream without decoding the image data. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
 | GetTiffTag(Int32, Stream, Int32) | Gets a TIFF Tag from a TIFF image stream.
 | GetTiffTag(Int32, String, Int32) | Gets a TIFF Tag from a TIFF file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an TIFF image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(Stream, ProgressEventHandler) | Decodes an image from a supplied TIFF image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
 | Read(Stream, Int32, ProgressEventHandler) | Decodes an image from a supplied TIFF image Stream specifying a frame index. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ReadRegion | Decodes a specified region of a TIFF image given a source Stream.
Public method | ReadScaled | Decodes an image to a specified scale.
Public method | ReadStrip | Decodes a specified strip from a TIFF image stream that is encoded with strips.
Public method | ReadTile | Decodes a specified tile from a TIFF image stream that is encoded with strips.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetBestScale Method

TiffDecoderGetBestScale Method

Gets the most effiicient image scale stored within the codec.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetBestScale(
    Stream stream,
    int frameIndex,
    double requestedScale
)
Public Function GetBestScale (
    stream As Stream,
    frameIndex As Integer,
    requestedScale As Double
) As Double

Parameters

stream
Type: System.IOStream
encoded image stream
frameIndex
Type: SystemInt32
Zero based frame index
requestedScale
Type: SystemDouble
Requested image scale.

Return Value

Type: Double
Always returns 1.0.

Implements

IScaledDecoderGetBestScale(Stream, Int32, Double)
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetFrameCount Method

TiffDecoderGetFrameCount Method

Returns the number of pages in an Encoded Tiff file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream

Encoded image stream

Return Value

Type: Int32
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetImageInfo Method

TiffDecoderGetImageInfo Method

Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retreive information from a Tiff image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Retreive information from a Tiff image stored in a Stream without decoding the image data. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetImageInfo Method (Stream)

TiffDecoderGetImageInfo Method (Stream)

Retreive information from a Tiff image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
Exceptions
Exception | Condition
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
See Also

Reference

TiffDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetImageInfo Method (Stream, Int32)

TiffDecoderGetImageInfo Method (Stream, Int32)

Retreive information from a Tiff image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
frameIndex
Type: SystemInt32
The zero based frame index.

Return Value

Type: ImageInfo
Exceptions
Exception | Condition
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
See Also

Reference

TiffDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetTiffTag Method

TiffDecoderGetTiffTag Method

Gets a TIFF Tag from a file or stream.
Examples

This example demonstrates how to obtain a simple TIFF Tag from a TIFF image.

[New Example] (C#)
Copy
TiffTag tag = TiffDecoder.GetTiffTag((int)TiffTagID.Software, "myimage.tif", 0);
if (tag != null)
  MessageBox.Show(tag.ToString(), this);
[New Example] (Visual Basic)
Copy
Dim tag As TiffTag = TiffDecoder.GetTiffTag(TiffTagID.Software, "myimage.tif", 0)
If Not tag Is Nothing Then
  MessageBox.Show(tag.ToString(), Me)
End If
Overload List
Name | Description
GetTiffTag(Int32, Stream, Int32) | Gets a TIFF Tag from a TIFF image stream.
GetTiffTag(Int32, String, Int32) | Gets a TIFF Tag from a TIFF file.
Top
Examples

This example demonstrates how to obtain a simple TIFF Tag from a TIFF image.

[New Example] (C#)
Copy
TiffTag tag = TiffDecoder.GetTiffTag((int)TiffTagID.Software, "myimage.tif", 0);
if (tag != null)
  MessageBox.Show(tag.ToString(), this);
[New Example] (Visual Basic)
Copy
Dim tag As TiffTag = TiffDecoder.GetTiffTag(TiffTagID.Software, "myimage.tif", 0)
If Not tag Is Nothing Then
  MessageBox.Show(tag.ToString(), Me)
End If
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.GetTiffTag Method (Int32, Stream, Int32)

TiffDecoderGetTiffTag Method (Int32, Stream, Int32)

Gets a TIFF Tag from a TIFF image stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static TiffTag GetTiffTag(
    int tagID,
    Stream source,
    int frameIndex
)
Public Shared Function GetTiffTag (
    tagID As Integer,
    source As Stream,
    frameIndex As Integer
) As TiffTag

Parameters

tagID
Type: SystemInt32
The tag ID to retrieve data from.
source
Type: System.IOStream
The TIFF file stream.
frameIndex
Type: SystemInt32
The zero based frame index of the page to query.

Return Value

Type: TiffTag
Returns a TiffTag object containing the tag data, or null if the tag does not exist in the image.
See Also

Reference

TiffDecoder Class
GetTiffTag Overload
Atalasoft.Imaging.Codec Namespace
Atalasoft.Imaging.MetadataTiffTag


TiffDecoder.GetTiffTag Method (Int32, String, Int32)

TiffDecoderGetTiffTag Method (Int32, String, Int32)

Gets a TIFF Tag from a TIFF file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static TiffTag GetTiffTag(
    int tagID,
    string fileName,
    int frameIndex
)
Public Shared Function GetTiffTag (
    tagID As Integer,
    fileName As String,
    frameIndex As Integer
) As TiffTag

Parameters

tagID
Type: SystemInt32
The tag ID to retrieve data from.
fileName
Type: SystemString
The TIFF filename
frameIndex
Type: SystemInt32
The zero based frame index of the page to query.

Return Value

Type: TiffTag
Returns a TiffTag object containing the tag data, or null if the tag does not exist in the image.

Return Value

Type: TiffTag
Returns a TiffTag object containing the tag data, or null if the tag does not exist in the image.
Remarks

Information stored in a TIFF file can be obtained with this method. A TiffTag is class containing the object data, data type, and tag id. The data is typically a string value.

Not all TIFF Tags are currently supported. See TIFF Tags for a list of supported tags.

This method can be used to obtain WANG Annotations data saved as TagID 32932.

For more comprehensive TIFF Tag handling, see the "/> for a list of supported tags.

This method can be used to obtain WANG Annotations data saved as TagID 32932.

For more comprehensive TIFF Tag handling, see the TiffFile class in the Atalasoft.dotImage assembly.

See Also

Reference

TiffDecoder Class
GetTiffTag Overload
Atalasoft.Imaging.Codec Namespace
Atalasoft.Imaging.MetadataTiffTag
Atalasoft.Imaging.Codec.TiffTiffFile


TiffDecoder.IsValidFormat Method

TiffDecoderIsValidFormat Method

Returns true if the specified Stream contains an TIFF image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.Read Method

TiffDecoderRead Method

Decodes an image from a supplied TIFF image Stream.
Overload List
Name | Description
Read(Stream, ProgressEventHandler) | Decodes an image from a supplied TIFF image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Read(Stream, Int32, ProgressEventHandler) | Decodes an image from a supplied TIFF image Stream specifying a frame index. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.Read Method (Stream, ProgressEventHandler)

TiffDecoderRead Method (Stream, ProgressEventHandler)

Decodes an image from a supplied TIFF image Stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A Stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Returns an decoded AtalaImage from a Stream containing a TIFF encoded image.
Exceptions
Exception | Condition
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
Examples
TiffDecoder Class
See Also

Reference

TiffDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


TiffDecoder.Read Method (Stream, Int32, ProgressEventHandler)

TiffDecoderRead Method (Stream, Int32, ProgressEventHandler)

Decodes an image from a supplied TIFF image Stream specifying a frame index.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A Stream containing the encoded image data.
frameIndex
Type: SystemInt32
The zero based frame index to load from a multi-page TIFF file.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Returns an decoded AtalaImage from a Stream containing a TIFF encoded image.

Return Value

Type: AtalaImage
Returns an decoded AtalaImage from a Stream containing a TIFF encoded image.
Exceptions
Exception | Condition
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
Examples
TiffDecoder Class
See Also

Reference

TiffDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


TiffDecoder.ReadRegion Method

TiffDecoderReadRegion Method

Decodes a specified region of a TIFF image given a source Stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ReadRegion(
    Stream stream,
    Rectangle region,
    int frameIndex,
    ProgressEventHandler progress
)
Public Function ReadRegion (
    stream As Stream,
    region As Rectangle,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A Stream containing the encoded image data.
region
Type: System.DrawingRectangle
A rectangular region of the image to decode.
frameIndex
Type: SystemInt32
The zero based frame index to load from a multi-page Tiff file.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage

Implements

IRegionReadableReadRegion(Stream, Rectangle, Int32, ProgressEventHandler)
Exceptions
Exception | Condition
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
 | Thrown if the region parameter is outside the image bounds.
Remarks

This method will read only the strips or tiles that it needs in order to compose and image of the indicated rectangular region, and trim any excess data. This can be significantly faster than reading the entire image if only a specified region needs to be decoded. To maximize benefit of this method, use multiple tiles or strips per image.

For reading only a single strip or tile, see ReadStrip(Stream, Int32, Int32, ProgressEventHandler) or ReadTile(Stream, Point, Int32, ProgressEventHandler).

Note that the image data is not corrected for orientation even when CorrectOrientation is true.

See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace
TiffDecoderReadStrip(Stream, Int32, Int32, ProgressEventHandler)
TiffDecoderReadTile(Stream, Point, Int32, ProgressEventHandler)


TiffDecoder.ReadScaled Method

TiffDecoderReadScaled Method

Decodes an image to a specified scale.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ReadScaled(
    Stream stream,
    int frameIndex,
    double scaleFactor,
    ProgressEventHandler progress
)
Public Function ReadScaled (
    stream As Stream,
    frameIndex As Integer,
    scaleFactor As Double,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The encoded image
frameIndex
Type: SystemInt32
The zero based frame index if the source image is multiframed
scaleFactor
Type: SystemDouble
The scale factor to request (ie. 0.5 is 1/2 scale, 1 is full scale)
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress callback

Return Value

Type: AtalaImage

Implements

IScaledDecoderReadScaled(Stream, Int32, Double, ProgressEventHandler)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | scaleFactor
See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffDecoder.ReadStrip Method

TiffDecoderReadStrip Method

Decodes a specified strip from a TIFF image stream that is encoded with strips.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ReadStrip(
    Stream stream,
    int stripIndex,
    int frameIndex,
    ProgressEventHandler progress
)
Public Function ReadStrip (
    stream As Stream,
    stripIndex As Integer,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A Stream containing the encoded image data.
stripIndex
Type: SystemInt32
The zero based strip index to decode.
frameIndex
Type: SystemInt32
The zero based frame index to load from a multi-page Tiff file.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
 | Thrown when the strip index doesn't exist within the image.
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
Remarks

This method differs from ReadRegion(Stream, Rectangle, Int32, ProgressEventHandler) in that it doesn't check that the source image is stripped. For reading multiple strips at once, ReadRegion is more efficient. To determine the strip height, query the tag TIFFTAG_ROWSPERSTRIP (278). To determine if an image is stripped, make sure TIFFTAG_TILELENGTH (323) or TIFFTAG_TILEWIDTH (322) doesn't exist.

Note that the image data is not corrected for orientation even when CorrectOrientation is true.

See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace
TiffDecoderReadTile(Stream, Point, Int32, ProgressEventHandler)
TiffDecoderReadRegion(Stream, Rectangle, Int32, ProgressEventHandler)


TiffDecoder.ReadTile Method

TiffDecoderReadTile Method

Decodes a specified tile from a TIFF image stream that is encoded with strips.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ReadTile(
    Stream stream,
    Point location,
    int frameIndex,
    ProgressEventHandler progress
)
Public Function ReadTile (
    stream As Stream,
    location As Point,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A Stream containing the encoded image data.
location
Type: System.DrawingPoint
The pixel location of the top left location of the tile.
frameIndex
Type: SystemInt32
The zero based frame index to load from a multi-page Tiff file.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
 | Thrown when the top-left corner of a tile doesn't exist at the location specified.
 | Thrown if the image stream is not located at the beginning of a valid TIFF file.
Remarks

This method differs from ReadRegion(Stream, Rectangle, Int32, ProgressEventHandler) in that it doesn't check that the source image is tiled. For reading multiple tiles at once, ReadRegion is more efficient. To determine the tile size, query the tag TIFFTAG_TILELENGTH (323) or TIFFTAG_TILEWIDTH (322). If those tags do not exist, then the image is stripped in which case see ReadStrip(Stream, Int32, Int32, ProgressEventHandler).

Note that the image data is not corrected for orientation even when CorrectOrientation is true.

See Also

Reference

TiffDecoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder Class

An ImageEncoder that will write Tagged Image File Format (TIFF) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecMultiFramedImageEncoder
Atalasoft.Imaging.CodecTiffEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffEncoder : MultiFramedImageEncoder,
    IAppendable, IAnnotationEncoder
Public Class TiffEncoder
    Inherits MultiFramedImageEncoder
    Implements IAppendable, IAnnotationEncoder

The TiffEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | TiffEncoder | Initializes a new instance of a TiffEncoder.
Public method | TiffEncoder(TiffCompression) | Initializes a new instance of a TiffEncoder specifying the compression.
Public method | TiffEncoder(TiffCompression, Boolean) | Initializes a new instance of a TiffEncoder specifying the compression and if the image should be appended to the end of an existing file.
Top
Properties
 | Name | Description
Public property | Append | Get or sets a value indicating if the image should be appended to the end of an existing file.
Public property | Compression | Gets or sets a value indicating the compression algorithm used when encoding to a file.
Public property | IptcTags | Gets or sets IPTC Metadata that will be saved with the image.
Public property | JpegQuality | Gets or sets the quality level used when saving the image.
Public property | PhotoshopResources | Gets or sets Photoshop resources to be saved with the image.
Public property | SaveRichTiffIptc | Gets or sets a value indicating that IPTC data will be stored in the TIFFTAG_RICHTIFFIPTC Tag rather than the TIFFTAG_PHOTOSHOP tag.
Public property | StripSize | Gets or sets the strip size used when saving the image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | TiffTags | Gets or sets a collection of TIFF Tags that will be encoded with the image when writing.
Public property | TileSize | Gets or sets the size of tiles that are saved when WriteTiled is true.
Public property | UseLzwPredictor | Gets or sets a value indicating LZW predictor.
Public property | UseOldJpegCompression | Obsolete. When true, JPEG compression will generate old style JPEG in TIFF compression (compression value 6).
Public property | WriteImageColorProfile | Controls how the TiffEncoder writes color profiles.
Public property | WriteTiled | Gets or sets a value that when true, will cause TIFF images to be encoded tiled.
Public property | Xmp | Gets or sets XMP data to encode with the image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Tiff image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves a collection of images to a multi-page TIFF. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves the images to the specified stream. (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Top
Remarks

This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a TIFF image.

Metadata can be written with the TIFF image including EXIF, IPTC, XMP, and Photoshop Resources. See the %Atalasoft.Imaging.Metadata% namespace for more information.

If the image being saved contains a ColorProfile, it will be embedded within the file.

If the image being saved is 1-bit, and palette index 0 is black and palette index 1 is white, the image will be saved with the photometric value of MINISBLACK. If other viewers mistakingly view the image reversed, invert the image and palette data prior to saving.

When compressing TIFF images, it's sometimes useful to adjust the StripSize to something other than the default. In particular, Deflate and LZW compression work better with larger chunks of data.

Examples
Append (C#)
Copy
// Load the image you want to append.
AtalaImage image = new AtalaImage(@"D:\Test Images\TIFF\1-bit.tif");

// Create the TiffEncoder and tell it to append to an existing file.
TiffEncoder tiff = new TiffEncoder(TiffCompression.Group4FaxEncoding, true);

// Append the image.
image.Save(@"D:\Test Images\TIFF\append.tif", tiff, null);

image.Dispose();
AppendVB (Visual Basic)
Copy
' Load the image you want to append.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\TIFF\1-bit.tif")

' Create the TiffEncoder and tell it to append to an existing file.
Dim tiff As TiffEncoder =  New TiffEncoder(TiffCompression.Group4FaxEncoding, True)

' Append the image.
image.Save("D:\Test Images\TIFF\append.tif", tiff, Nothing)

image.Dispose()
See Also

Reference

Atalasoft.Imaging.Codec Namespace


TiffEncoder Constructor

Creates a TiffEncoder.
Overload List
 | Name | Description
Public method | TiffEncoder | Initializes a new instance of a TiffEncoder.
Public method | TiffEncoder(TiffCompression) | Initializes a new instance of a TiffEncoder specifying the compression.
Public method | TiffEncoder(TiffCompression, Boolean) | Initializes a new instance of a TiffEncoder specifying the compression and if the image should be appended to the end of an existing file.
Top
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder Constructor

Initializes a new instance of a TiffEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffEncoder()
Public Sub New
See Also

Reference

TiffEncoder Class
TiffEncoder Overload
Atalasoft.Imaging.Codec Namespace


TiffEncoder Constructor (TiffCompression)

Initializes a new instance of a TiffEncoder specifying the compression.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffEncoder(
    TiffCompression compression
)
Public Sub New (
    compression As TiffCompression
)

Parameters

compression
Type: Atalasoft.Imaging.CodecTiffCompression
A value indicating the compression algorithm used when encoding to a file.
See Also

Reference

TiffEncoder Class
TiffEncoder Overload
Atalasoft.Imaging.Codec Namespace


TiffEncoder Constructor (TiffCompression, Boolean)

Initializes a new instance of a TiffEncoder specifying the compression and if the image should be appended to the end of an existing file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffEncoder(
    TiffCompression compression,
    bool append
)
Public Sub New (
    compression As TiffCompression,
    append As Boolean
)

Parameters

compression
Type: Atalasoft.Imaging.CodecTiffCompression
A value indicating the compression algorithm used when encoding to a file.
append
Type: SystemBoolean
A value indicating if the image should be appended to the end of an existing file.
See Also

Reference

TiffEncoder Class
TiffEncoder Overload
Atalasoft.Imaging.Codec Namespace


TiffEncoder Properties

The TiffEncoder type exposes the following members.

Properties
 | Name | Description
Public property | Append | Get or sets a value indicating if the image should be appended to the end of an existing file.
Public property | Compression | Gets or sets a value indicating the compression algorithm used when encoding to a file.
Public property | IptcTags | Gets or sets IPTC Metadata that will be saved with the image.
Public property | JpegQuality | Gets or sets the quality level used when saving the image.
Public property | PhotoshopResources | Gets or sets Photoshop resources to be saved with the image.
Public property | SaveRichTiffIptc | Gets or sets a value indicating that IPTC data will be stored in the TIFFTAG_RICHTIFFIPTC Tag rather than the TIFFTAG_PHOTOSHOP tag.
Public property | StripSize | Gets or sets the strip size used when saving the image.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | TiffTags | Gets or sets a collection of TIFF Tags that will be encoded with the image when writing.
Public property | TileSize | Gets or sets the size of tiles that are saved when WriteTiled is true.
Public property | UseLzwPredictor | Gets or sets a value indicating LZW predictor.
Public property | UseOldJpegCompression | Obsolete. When true, JPEG compression will generate old style JPEG in TIFF compression (compression value 6).
Public property | WriteImageColorProfile | Controls how the TiffEncoder writes color profiles.
Public property | WriteTiled | Gets or sets a value that when true, will cause TIFF images to be encoded tiled.
Public property | Xmp | Gets or sets XMP data to encode with the image.
Top
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.Append Property

TiffEncoderAppend Property

Get or sets a value indicating if the image should be appended to the end of an existing file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Append { get; set; }
Public Property Append As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the image should be appended to the end of an existing file.

Implements

IAppendableAppend
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.Compression Property

TiffEncoderCompression Property

Gets or sets a value indicating the compression algorithm used when encoding to a file.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffCompression Compression { get; set; }
Public Property Compression As TiffCompression
    Get
    Set

Property Value

Type: TiffCompression
A value indicating the compression algorithm used when encoding to a file.
Remarks
When setting the compression, be aware of the PixelFormat. Some compression types will result in no compression when used with an incompatible PixelFormat. See the TiffCompression enumeration for more information.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.IptcTags Property

TiffEncoderIptcTags Property

Gets or sets IPTC Metadata that will be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection IptcTags { get; set; }
Public Property IptcTags As IptcCollection
    Get
    Set

Property Value

Type: IptcCollection
IPTC Metadata that will be saved with the image.
Remarks
Setting this property to an IptcCollection allows IPTC tags to be added or inserted into a new TIFF image.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.JpegQuality Property

TiffEncoderJpegQuality Property

Gets or sets the quality level used when saving the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
The quality level.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.PhotoshopResources Property

TiffEncoderPhotoshopResources Property

Gets or sets Photoshop resources to be saved with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection PhotoshopResources { get; set; }
Public Property PhotoshopResources As PhotoshopResourceCollection
    Get
    Set

Property Value

Type: PhotoshopResourceCollection
Photoshop resources to be saved with the image.
Remarks
Photoshop saves information to a specific TIFF Tag. This information can be parsed with the PhotoshopResourceParser. When PhotoshopResources and IptcTags are set to a value other than null, IptcData will be added to the PhotoshopResource when saved.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.SaveRichTiffIptc Property

TiffEncoderSaveRichTiffIptc Property

Gets or sets a value indicating that IPTC data will be stored in the TIFFTAG_RICHTIFFIPTC Tag rather than the TIFFTAG_PHOTOSHOP tag.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SaveRichTiffIptc { get; set; }
Public Property SaveRichTiffIptc As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating that IPTC data will be stored in the TIFFTAG_RICHTIFFIPTC Tag rather than the TIFFTAG_PHOTOSHOP tag.
Remarks
Some readers support reading IPTC only in the RICHTIFFIPTC TiffTag. By default, IPTC data is saved as a photoshop tag.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.StripSize Property

TiffEncoderStripSize Property

Gets or sets the strip size used when saving the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int StripSize { get; set; }
Public Property StripSize As Integer
    Get
    Set

Property Value

Type: Int32
The strip size used when saving the image.
Exceptions
Exception | Condition
 | The strip size must be a value greater than or equal to -1.
Remarks

The strip size is the number of image rows saved as a single strip in the TIFF. The default value is -1, which will automatically calculate a strip size equal to about 8Kb of uncompressed data. For higher compression, it often makes sense to increase this number.

If the StripSize is greater than the image height, the actual strip size will equal the image height.

See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.SupportedPixelFormats Property

TiffEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.TiffTags Property

TiffEncoderTiffTags Property

Gets or sets a collection of TIFF Tags that will be encoded with the image when writing.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTagCollection TiffTags { get; set; }
Public Property TiffTags As TiffTagCollection
    Get
    Set

Property Value

Type: TiffTagCollection
A collection of TIFF Tags that will be encoded with the image when writing.
Remarks

Not all TIFF Tags are supported. See TIFF Tags for a list of supported tags. Some standard tags included in this list would be dangerous to modify and will be ignored if an attempt is made to add them. Those exceptions include:

IMAGEWIDTH, IMAGELENGTH, BITSPERSAMPLE, COMPRESSION, PHOTOMETRIC, STRIPOFFSETS, SAMPLESPERPIXEL, ROWSPERSTRIP, STRIPBYTECOUNTS, PLANARCONFIG, JPEGTABLES, JPEGPROC, JPEGIFOFFSET, JPEGIFBYTECOUNT, JPEGRESTARTINTERVAL, JPEGLOSSLESSPREDICTORS, JPEGPOINTTRANSFORM, JPEGQTABLES, JPEGDCTABLES, JPEGACTABLES, YCBCRCOEFFICIENTS, YCBCRSUBSAMPLING, YCBCRPOSITIONING

For more comprehensive TIFF Tag handling, see the TiffFile class in the Atalasoft.dotImage assembly.

See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace
Atalasoft.Imaging.Codec.TiffTiffFile


TiffEncoder.TileSize Property

TiffEncoderTileSize Property

Gets or sets the size of tiles that are saved when WriteTiled is true.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size TileSize { get; set; }
Public Property TileSize As Size
    Get
    Set

Property Value

Type: Size
The size of tiles that are saved when WriteTiled is true.
Remarks

The size of tiles that are saved when WriteTiled is true. The default value is 256, 256.

The tile size must be a multiple of 16. Actual sizes used may be subject to modification based on compression type.

See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace
WriteTiled Property


TiffEncoder.UseLzwPredictor Property

TiffEncoderUseLzwPredictor Property

Gets or sets a value indicating LZW predictor.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseLzwPredictor { get; set; }
Public Property UseLzwPredictor As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When this value it true and image uses LZW compression, images are generally compressed more.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.UseOldJpegCompression Property

TiffEncoderUseOldJpegCompression Property

Note: This API is now obsolete.

When true, JPEG compression will generate old style JPEG in TIFF compression (compression value 6).

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Warning - using old-style jpeg compression will create TIFF images that are non-standard and will work with very few applications.",
    false)]
public bool UseOldJpegCompression { get; set; }
<ObsoleteAttribute("Warning - using old-style jpeg compression will create TIFF images that are non-standard and will work with very few applications.",
    false)>
Public Property UseOldJpegCompression As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
USE WITH CAUTION!!
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.WriteImageColorProfile Property

TiffEncoderWriteImageColorProfile Property

Controls how the TiffEncoder writes color profiles.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WriteImageColorProfile { get; set; }
Public Property WriteImageColorProfile As Boolean
    Get
    Set

Property Value

Type: Boolean

When set to true, if an image contains a non-null ColorProfile objects, the ColorProfile will be embedded within the Tiff file.

Default value is false.

Remarks
ColorProfile objects are not written when the DotImage license is Photo.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.WriteTiled Property

TiffEncoderWriteTiled Property

Gets or sets a value that when true, will cause TIFF images to be encoded tiled.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WriteTiled { get; set; }
Public Property WriteTiled As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Tiled TIFF images are useful when the image is large, and the reader is capable of reading individual tiles. See TileSize for setting the tile width and length.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace
TileSize Property


TiffEncoder.Xmp Property

TiffEncoderXmp Property

Gets or sets XMP data to encode with the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Xmp { get; set; }
Public Property Xmp As Byte()
    Get
    Set

Property Value

Type: Byte
A byte array containing XMP data.
Remarks
This property can be used to save XMP Annotation data created with DotImage, our full featured Annotations toolkit for the Microsoft .NET Framework.
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder Methods

The TiffEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Tiff image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves a collection of images to a multi-page TIFF. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves the images to the specified stream. (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.Save Method

TiffEncoderSave Method

Overload List
 | Name | Description
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Tiff image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves a collection of images to a multi-page TIFF. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves the images to the specified stream. (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Top
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TiffEncoder.Save Method (Stream, AtalaImage, ProgressEventHandler)

TiffEncoderSave Method (Stream, AtalaImage, ProgressEventHandler)

Encode an AtalaImage as a Tiff image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The total number of bytes written to the provided stream.
See Also

Reference

TiffEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


TiffEncoder.Save Method (Stream, ImageCollection, ProgressEventHandler)

TiffEncoderSave Method (Stream, ImageCollection, ProgressEventHandler)

Saves a collection of images to a multi-page TIFF.
Encode an AtalaImage as a Tiff image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    ImageCollection images,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    images As ImageCollection,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to. This stream must have FileAccess.ReadWrite set or else only the first image will be saved.
images
Type: Atalasoft.ImagingImageCollection
The ImageCollection containing the images to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The total number of bytes written to the provided stream.
See Also

Reference

TiffEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


TiffEncoder.Save Method (Stream, ImageSource, ProgressEventHandler)

TiffEncoderSave Method (Stream, ImageSource, ProgressEventHandler)

Saves the images to the specified stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    ImageSource images,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    images As ImageSource,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream.
images
Type: Atalasoft.ImagingImageSource
The images to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress handler.

Return Value

Type: Int64
The total number of bytes written to the provided stream.
See Also

Reference

TiffEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


TiffEncoder Events

The TiffEncoder type exposes the following members.

Events
 | Name | Description
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Top
See Also

Reference

TiffEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder Class

An ImageDecoder used to read Tla images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecTlaDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TlaDecoder : ImageDecoder
Public Class TlaDecoder
    Inherits ImageDecoder

The TlaDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | TlaDecoder | Initializes a new instance of a TlaDecoder.
Public method | TlaDecoder(String) | Obsolete. Initializes a new instance of a TlaDecoder specifying the password.
Top
Properties
 | Name | Description
Public property | Password | Obsolete. Gets or sets the password to use for reading encrypted Tla images.
Public property | SupportedImageType | Obsolete. Returns a Tla ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from a Tla image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, SecureString) | Retreive information from a Tla image stored in a Stream without decoding the image data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Tla image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Tla encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, SecureString, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Tla encoded image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Tla image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.

A TLA image can save images in an encrypted format. A password needs to be supplied for opening these image formats.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


TlaDecoder Constructor

Creates a TlaDecoder.
Overload List
 | Name | Description
Public method | TlaDecoder | Initializes a new instance of a TlaDecoder.
Public method | TlaDecoder(String) | Obsolete. Initializes a new instance of a TlaDecoder specifying the password.
Top
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder Constructor

Initializes a new instance of a TlaDecoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TlaDecoder()
Public Sub New
See Also

Reference

TlaDecoder Class
TlaDecoder Overload
Atalasoft.Imaging.Codec Namespace


TlaDecoder Constructor (String)

Note: This API is now obsolete.

Initializes a new instance of a TlaDecoder specifying the password.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor will be removed in a future release. Please use the default constructor and GetImageInfo and Read methods with password as a parameter.",
    false)]
public TlaDecoder(
    string password
)
<ObsoleteAttribute("This constructor will be removed in a future release. Please use the default constructor and GetImageInfo and Read methods with password as a parameter.",
    false)>
Public Sub New (
    password As String
)

Parameters

password
Type: SystemString
The password to use for reading encrypted Tla images.
See Also

Reference

TlaDecoder Class
TlaDecoder Overload
Atalasoft.Imaging.Codec Namespace


TlaDecoder Properties

The TlaDecoder type exposes the following members.

Properties
 | Name | Description
Public property | Password | Obsolete. Gets or sets the password to use for reading encrypted Tla images.
Public property | SupportedImageType | Obsolete. Returns a Tla ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder.Password Property

TlaDecoderPassword Property

Note: This API is now obsolete.

Gets or sets the password to use for reading encrypted Tla images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property will be removed in a future release. Please use the default constructor and GetImageInfo and Read methods with password as a parameter.",
    false)]
public string Password { get; set; }
<ObsoleteAttribute("This property will be removed in a future release. Please use the default constructor and GetImageInfo and Read methods with password as a parameter.",
    false)>
Public Property Password As String
    Get
    Set

Property Value

Type: String
The password to use for reading encrypted Tla images.
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder.SupportedImageType Property

TlaDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Tla ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType

ImageType.Tla

See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder Methods

The TlaDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from a Tla image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, SecureString) | Retreive information from a Tla image stored in a Stream without decoding the image data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Tla image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Tla encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, SecureString, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Tla encoded image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder.GetImageInfo Method

TlaDecoderGetImageInfo Method

Returns an ImageInfo object containing information about the image.
Returns an ImageInfo object containing information about the image.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retreive information from a Tla image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, SecureString) | Retreive information from a Tla image stored in a Stream without decoding the image data.
Top
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder.GetImageInfo Method (Stream)

TlaDecoderGetImageInfo Method (Stream)

Retreive information from a Tla image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image.
Remarks
This method currently uses obsolete property Password for reading. If password for reading is nesessary then please use GetImageInfo method with password as a parameter. If obsolete property Password is not set then no password is used.
See Also

Reference

TlaDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


TlaDecoder.GetImageInfo Method (Stream, SecureString)

TlaDecoderGetImageInfo Method (Stream, SecureString)

Retreive information from a Tla image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInfo GetImageInfo(
    Stream stream,
    SecureString password
)
Public Function GetImageInfo (
    stream As Stream,
    password As SecureString
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
password
Type: System.SecuritySecureString

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image.
See Also

Reference

TlaDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


TlaDecoder.IsValidFormat Method

TlaDecoderIsValidFormat Method

Returns true if the specified Stream contains an Tla image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder.Read Method

TlaDecoderRead Method

Reads the image data into an AtalaImage object.
Reads the image data into an AtalaImage object.
Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Tla encoded image. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, SecureString, ProgressEventHandler) | Returns an AtalaImage from a Stream containing a Tla encoded image.
Top
See Also

Reference

TlaDecoder Class
Atalasoft.Imaging.Codec Namespace


TlaDecoder.Read Method (Stream, ProgressEventHandler)

TlaDecoderRead Method (Stream, ProgressEventHandler)

Returns an AtalaImage from a Stream containing a Tla encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The ProgressEventHandler for this process.

Return Value

Type: AtalaImage
Returns an AtalaImage from a Stream containing a Tla encoded image.
Remarks
This method currently uses obsolete property Password for reading. If password for reading is nesessary then please use Read method with password as a parameter. If obsolete property Password is not set then no password is used.
See Also

Reference

TlaDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


TlaDecoder.Read Method (Stream, SecureString, ProgressEventHandler)

TlaDecoderRead Method (Stream, SecureString, ProgressEventHandler)

Returns an AtalaImage from a Stream containing a Tla encoded image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Read(
    Stream stream,
    SecureString password,
    ProgressEventHandler progress
)
Public Function Read (
    stream As Stream,
    password As SecureString,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
password
Type: System.SecuritySecureString
The password to use for reading encrypted Tla images.
progress
Type: Atalasoft.ImagingProgressEventHandler
The ProgressEventHandler for this process.

Return Value

Type: AtalaImage
Returns an AtalaImage from a Stream containing a Tla encoded image.
See Also

Reference

TlaDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


TlaEncoder Class

An ImageEncoder that will write TLA images to a %System.IO.Stream%.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecTlaEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TlaEncoder : ImageEncoder
Public Class TlaEncoder
    Inherits ImageEncoder

The TlaEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | TlaEncoder | Initializes a new instance of a TiffEncoder.
Public method | TlaEncoder(String) | Obsolete. Initializes a new instance of a TlaEncoder specifying the password to encrypt with.
Top
Properties
 | Name | Description
Public property | Password | Obsolete. Gets or sets the password to use for reading, writing, or obtaining information on encrypted TLA images.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Tla image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, AtalaImage, SecureString, ProgressEventHandler) | Encode an AtalaImage as a Tla image to a stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a TLA image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


TlaEncoder Constructor

Overload List
 | Name | Description
Public method | TlaEncoder | Initializes a new instance of a TiffEncoder.
Public method | TlaEncoder(String) | Obsolete. Initializes a new instance of a TlaEncoder specifying the password to encrypt with.
Top
See Also

Reference

TlaEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaEncoder Constructor

Initializes a new instance of a TiffEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TlaEncoder()
Public Sub New
See Also

Reference

TlaEncoder Class
TlaEncoder Overload
Atalasoft.Imaging.Codec Namespace


TlaEncoder Constructor (String)

Note: This API is now obsolete.

Initializes a new instance of a TlaEncoder specifying the password to encrypt with.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor will be removed in a future release. Please use the default constructor and Save method with password as a parameter.",
    false)]
public TlaEncoder(
    string password
)
<ObsoleteAttribute("This constructor will be removed in a future release. Please use the default constructor and Save method with password as a parameter.",
    false)>
Public Sub New (
    password As String
)

Parameters

password
Type: SystemString
The password to use for reading, writing, or obtaining information on encrypted TLA images.
See Also

Reference

TlaEncoder Class
TlaEncoder Overload
Atalasoft.Imaging.Codec Namespace


TlaEncoder Properties

The TlaEncoder type exposes the following members.

Properties
 | Name | Description
Public property | Password | Obsolete. Gets or sets the password to use for reading, writing, or obtaining information on encrypted TLA images.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

TlaEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaEncoder.Password Property

TlaEncoderPassword Property

Note: This API is now obsolete.

Gets or sets the password to use for reading, writing, or obtaining information on encrypted TLA images.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property will be removed in a future release. Please use the default constructor and Save method with password as a parameter.",
    false)]
public string Password { get; set; }
<ObsoleteAttribute("This property will be removed in a future release. Please use the default constructor and Save method with password as a parameter.",
    false)>
Public Property Password As String
    Get
    Set

Property Value

Type: String
The password to use for reading, writing, or obtaining information on encrypted TLA images.
See Also

Reference

TlaEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaEncoder.SupportedPixelFormats Property

TlaEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

TlaEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaEncoder Methods

The TlaEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Tla image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, AtalaImage, SecureString, ProgressEventHandler) | Encode an AtalaImage as a Tla image to a stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TlaEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaEncoder.Save Method

TlaEncoderSave Method

Overload List
 | Name | Description
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Encode an AtalaImage as a Tla image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, AtalaImage, SecureString, ProgressEventHandler) | Encode an AtalaImage as a Tla image to a stream.
Top
See Also

Reference

TlaEncoder Class
Atalasoft.Imaging.Codec Namespace


TlaEncoder.Save Method (Stream, AtalaImage, ProgressEventHandler)

TlaEncoderSave Method (Stream, AtalaImage, ProgressEventHandler)

Encode an AtalaImage as a Tla image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The number of bytes written to the file.
Remarks
This method currently uses obsolete property Password for saving. If password for saving is nesessary then please use Save method with password as a parameter. If obsolete property Password is not set then empty password is used (i.e. no encryption).
See Also

Reference

TlaEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


TlaEncoder.Save Method (Stream, AtalaImage, SecureString, ProgressEventHandler)

TlaEncoderSave Method (Stream, AtalaImage, SecureString, ProgressEventHandler)

Encode an AtalaImage as a Tla image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Save(
    Stream stream,
    AtalaImage image,
    SecureString password,
    ProgressEventHandler progress
)
Public Function Save (
    stream As Stream,
    image As AtalaImage,
    password As SecureString,
    progress As ProgressEventHandler
) As Integer

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
password
Type: System.SecuritySecureString
The password to use for reading, writing, or obtaining information on encrypted TLA images.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int32
The number of bytes written to the file.
See Also

Reference

TlaEncoder Class
Save Overload
Atalasoft.Imaging.Codec Namespace


WbmpDecoder Class

An ImageDecoder used to read Wireless Bitmap (Wbmp) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecWbmpDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WbmpDecoder : ImageDecoder
Public Class WbmpDecoder
    Inherits ImageDecoder

The WbmpDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | WbmpDecoder | Initializes a new instance of a %WbmpDecoder%.
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Wbmp ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Wbmp image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Wbmp image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Wbmp image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the RegisteredDecoders and does not have to be explicitly set.

A WBMP image is commonly used in PDA devices and is always black and white.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


WbmpDecoder Constructor

Initializes a new instance of a %WbmpDecoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WbmpDecoder()
Public Sub New
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpDecoder Properties

The WbmpDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns a Wbmp ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpDecoder.SupportedImageType Property

WbmpDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Wbmp ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpDecoder Methods

The WbmpDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Wbmp image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Wbmp image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpDecoder.GetImageInfo Method

WbmpDecoderGetImageInfo Method

Retreive information from a Wbmp image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpDecoder.IsValidFormat Method

WbmpDecoderIsValidFormat Method

Returns true if the specified Stream contains an Wbmp image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpDecoder.Read Method

WbmpDecoderRead Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Remarks
Returns an AtalaImage from a Stream containing a Wbmp encoded image.
See Also

Reference

WbmpDecoder Class
Atalasoft.Imaging.Codec Namespace


WbmpEncoder Class

An ImageEncoder that will write Wireless Bitmap (WBMP) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecWbmpEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WbmpEncoder : ImageEncoder
Public Class WbmpEncoder
    Inherits ImageEncoder

The WbmpEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | WbmpEncoder | Initializes a new instance of a %WbmpEncoder%.
Top
Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Wbmp image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a WBMP image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


WbmpEncoder Constructor

Initializes a new instance of a %WbmpEncoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WbmpEncoder()
Public Sub New
See Also

Reference

WbmpEncoder Class
Atalasoft.Imaging.Codec Namespace


WbmpEncoder Properties

The WbmpEncoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

WbmpEncoder Class
Atalasoft.Imaging.Codec Namespace


WbmpEncoder.SupportedPixelFormats Property

WbmpEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

WbmpEncoder Class
Atalasoft.Imaging.Codec Namespace


WbmpEncoder Methods

The WbmpEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Wbmp image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WbmpEncoder Class
Atalasoft.Imaging.Codec Namespace


WbmpEncoder.Save Method

WbmpEncoderSave Method

Encode an AtalaImage as a Wbmp image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

WbmpEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder Class

An ImageDecoder used to read Windows Metafile (WMF) images from a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecWmfDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WmfDecoder : ImageDecoder
Public Class WmfDecoder
    Inherits ImageDecoder

The WmfDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | WmfDecoder | Initializes a new instance of a %WmfDecoder%.
Public method | WmfDecoder(Size) | Initializes a new instance of a WmfDecoder specifying the size of the image.
Top
Properties
 | Name | Description
Public property | DefaultSize | Obsolete. Gets or sets the default Size when reading a windows metafile.
Public property | SupportedImageType | Obsolete. Returns a Wmf ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Wmf image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Wmf image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

By default, when opening a Wmf image using the AtalaImage or Workspace objects, this decoder will automatically be selected from the %RegisteredDecoders% and does not have to be explicitly set.

Any vectorized entities saved in the Metafile will be converted to a raster format.

See Also

Reference

Atalasoft.Imaging.Codec Namespace


WmfDecoder Constructor

Overload List
 | Name | Description
Public method | WmfDecoder | Initializes a new instance of a %WmfDecoder%.
Public method | WmfDecoder(Size) | Initializes a new instance of a WmfDecoder specifying the size of the image.
Top
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder Constructor

Initializes a new instance of a %WmfDecoder%.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WmfDecoder()
Public Sub New
See Also

Reference

WmfDecoder Class
WmfDecoder Overload
Atalasoft.Imaging.Codec Namespace


WmfDecoder Constructor (Size)

Initializes a new instance of a WmfDecoder specifying the size of the image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WmfDecoder(
    Size defaultSize
)
Public Sub New (
    defaultSize As Size
)

Parameters

defaultSize
Type: System.DrawingSize
The default Size when reading a windows metafile.
See Also

Reference

WmfDecoder Class
WmfDecoder Overload
Atalasoft.Imaging.Codec Namespace


WmfDecoder Properties

The WmfDecoder type exposes the following members.

Properties
 | Name | Description
Public property | DefaultSize | Obsolete. Gets or sets the default Size when reading a windows metafile.
Public property | SupportedImageType | Obsolete. Returns a Wmf ImageType enumeration value. (Overrides ImageDecoderSupportedImageType.)
Top
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder.DefaultSize Property

WmfDecoderDefaultSize Property

Note: This API is now obsolete.

Gets or sets the default Size when reading a windows metafile.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is not used anymore. To change image size please use ResampleCommand.")]
public Size DefaultSize { get; set; }
<ObsoleteAttribute("This property is not used anymore. To change image size please use ResampleCommand.")>
Public Property DefaultSize As Size
    Get
    Set

Property Value

Type: Size
The default System.Drawing.Size when reading a windows metafile.
Remarks
Windows metafiles may or may not have dimensions associated with them. If not, then this attribute defines the size that will be used. If this value is empty, it will use information that might be stored in the file or a default of 640 x 480 pixels.
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder.SupportedImageType Property

WmfDecoderSupportedImageType Property

Note: This API is now obsolete.

Returns a Wmf ImageType enumeration value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)]
public override ImageType SupportedImageType { get; }
<ObsoleteAttribute("This property is obsolete and will be removed from future versions.",
    false)>
Public Overrides ReadOnly Property SupportedImageType As ImageType
    Get

Property Value

Type: ImageType
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder Methods

The WmfDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Retreive information from a Wmf image stored in a Stream without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream contains an Wmf image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder.GetImageInfo Method

WmfDecoderGetImageInfo Method

Retreive information from a Wmf image stored in a Stream without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder.IsValidFormat Method

WmfDecoderIsValidFormat Method

Returns true if the specified Stream contains an Wmf image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfDecoder.Read Method

WmfDecoderRead Method

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Remarks
Returns an AtalaImage from a Stream containing a Wmf encoded image.
See Also

Reference

WmfDecoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder Class

An ImageEncoder that will write Windows Metafile (WMF) images to a Stream.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecWmfEncoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WmfEncoder : ImageEncoder
Public Class WmfEncoder
    Inherits ImageEncoder

The WmfEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | WmfEncoder | Initializes a new instance of a WmfEncoder.
Public method | WmfEncoder(Boolean) | Initializes a new instance of a WmfEncoder specifying the placeable value.
Top
Properties
 | Name | Description
Public property | ImageType | Returns the ImageType associated with thie Encoder Setting.
Public property | Placeable | Gets or sets a value indicating if an Aldus placeable metafile will be written.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Wmf image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This ImageEncoder can be passed into the the AtalaImage or Workspace objects when saving to specify a WMF image.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


WmfEncoder Constructor

Overload List
 | Name | Description
Public method | WmfEncoder | Initializes a new instance of a WmfEncoder.
Public method | WmfEncoder(Boolean) | Initializes a new instance of a WmfEncoder specifying the placeable value.
Top
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder Constructor

Initializes a new instance of a WmfEncoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WmfEncoder()
Public Sub New
See Also

Reference

WmfEncoder Class
WmfEncoder Overload
Atalasoft.Imaging.Codec Namespace


WmfEncoder Constructor (Boolean)

Initializes a new instance of a WmfEncoder specifying the placeable value.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WmfEncoder(
    bool placeable
)
Public Sub New (
    placeable As Boolean
)

Parameters

placeable
Type: SystemBoolean
A value indicating if an Aldus placeable metafile will be written.
See Also

Reference

WmfEncoder Class
WmfEncoder Overload
Atalasoft.Imaging.Codec Namespace


WmfEncoder Properties

The WmfEncoder type exposes the following members.

Properties
 | Name | Description
Public property | ImageType | Returns the ImageType associated with thie Encoder Setting.
Public property | Placeable | Gets or sets a value indicating if an Aldus placeable metafile will be written.
Public property | SupportedPixelFormats | Returns an array of pixel formats supported by this encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Top
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder.ImageType Property

WmfEncoderImageType Property

Returns the ImageType associated with thie Encoder Setting.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageType ImageType { get; }
Public ReadOnly Property ImageType As ImageType
    Get

Property Value

Type: ImageType
The ImageType associated with thie Encoder Setting.
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder.Placeable Property

WmfEncoderPlaceable Property

Gets or sets a value indicating if an Aldus placeable metafile will be written.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Placeable { get; set; }
Public Property Placeable As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if an Aldus placeable metafile will be written.
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder.SupportedPixelFormats Property

WmfEncoderSupportedPixelFormats Property

Returns an array of pixel formats supported by this encoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder Methods

The WmfEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Encode an AtalaImage as a Wmf image to a stream. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


WmfEncoder.Save Method

WmfEncoderSave Method

Encode an AtalaImage as a Wmf image to a stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
A stream that the encoded image data will be saved to.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
See Also

Reference

WmfEncoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder Class

Decodes an XPS document into an AtalaImage object.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.CodecXpsDecoder

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class XpsDecoder : MultiFramedImageDecoder
Public Class XpsDecoder
    Inherits MultiFramedImageDecoder

The XpsDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | XpsDecoder | Initializes a new instance of the XpsDecoder class
Top
Properties
 | Name | Description
Public property | DpiX | Gets or sets the X-Resolution value used when reading to an image.
Public property | DpiY | Gets or sets the Y-Resolution used when reading to an image.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
XpsDecoder does not support OXPS documents under Windows 7 and Windows Server 2008 R2.
See Also

Reference

Atalasoft.Imaging.Codec Namespace


XpsDecoder Constructor

Initializes a new instance of the XpsDecoder class

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XpsDecoder()
Public Sub New
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder Properties

The XpsDecoder type exposes the following members.

Properties
 | Name | Description
Public property | DpiX | Gets or sets the X-Resolution value used when reading to an image.
Public property | DpiY | Gets or sets the Y-Resolution used when reading to an image.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.DpiX Property

XpsDecoderDpiX Property

Gets or sets the X-Resolution value used when reading to an image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DpiX { get; set; }
Public Property DpiX As Integer
    Get
    Set

Property Value

Type: Int32
The X-Resolution used when reading to an image.
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.DpiY Property

XpsDecoderDpiY Property

Gets or sets the Y-Resolution used when reading to an image.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DpiY { get; set; }
Public Property DpiY As Integer
    Get
    Set

Property Value

Type: Int32
The Y-Resolution used when reading to an image.
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder Methods

The XpsDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retreive information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.GetFrameCount Method

XpsDecoderGetFrameCount Method

Returns the number of frames in the image

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The input Stream.

Return Value

Type: Int32
The number of frames in the image
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream does not have read access.;stream
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.GetImageInfo Method

XpsDecoderGetImageInfo Method

Retreive information in an image stored in a file without decoding the image data.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retreive information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.GetImageInfo Method (Stream)

XpsDecoderGetImageInfo Method (Stream)

Retreive information from an image stored in a file without decoding the image data.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image such as size and bitdepth.
See Also

Reference

XpsDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


XpsDecoder.GetImageInfo Method (Stream, Int32)

XpsDecoderGetImageInfo Method (Stream, Int32)

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.

Return Value

Type: ImageInfo
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream does not have read access.;stream
See Also

Reference

XpsDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec Namespace


XpsDecoder.IsValidFormat Method

XpsDecoderIsValidFormat Method

Checks the stream to determine if the image can be read by the decoder that derives this class.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
True if the encoded image can be read by this decoder, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream does not have read access.;stream
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.Read Method

XpsDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

XpsDecoder Class
Atalasoft.Imaging.Codec Namespace


XpsDecoder.Read Method (Stream, ProgressEventHandler)

XpsDecoderRead Method (Stream, ProgressEventHandler)

Decode an image in a specified image Stream.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the decoded image.
See Also

Reference

XpsDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


XpsDecoder.Read Method (Stream, Int32, ProgressEventHandler)

XpsDecoderRead Method (Stream, Int32, ProgressEventHandler)

Read a given frame in an encoded image using this decoder.

Namespace: Atalasoft.Imaging.Codec
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream inStream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    inStream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

inStream
Type: System.IOStream
frameIndex
Type: SystemInt32
The zero based frame index.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
ArgumentNullException | stream
ArgumentException | The stream does not have read access.;stream
See Also

Reference

XpsDecoder Class
Read Overload
Atalasoft.Imaging.Codec Namespace


Atalasoft.Imaging.Codec.CadCam Namespace

Classes
Class | Description
Public class DwgDecoder
The DwgDecoder provides the ability to rasterize AutoCAD DWG files
Public class | DwgDecoderImpl
Public class DwgImageInfo
An object representing information about a DWG image
Public class DwgTextStyle
This class represents the style of a block of text in a document
GeometryHandler

GeometryHandler is a class that is used for extracting geometry from a DWG file. It consists of a series of methods that are called for each shape type in the as well as for changes in color and line style.

Nearly all of the OnBegin... methods return an enumerated value. This is to indicate to Distill whether or not the user GeometryHandler wants the geometry to be reduced further or not. The GeometryHandler base class implements all OnBegin... methods for shapes such that they return DwgReduction.Reduce. The GeometryHandler base class therefore causes a model to be fully reduced to primitives. Client code should subclass GeomtryHandler and override the methods they wish to intercept.

For example, an application that wishes to extract text from a DWG file would only need to override OnBeginText.

OnBeginPage should return true if the client wishes to process the page.

OnBeginDocument does not have a return value.

OnPolygon and OnPolyline represent primitives for which there is no further reduction.

All the OnBeginShape and OnEndShape methods take a shape ID parameter. This is unique ID that is assigned to every shape. This is to make it easier to identify when all reduction is done for a particular shape.

Many of the routines take arrays of double precision floating point numbers. These represent 3D coordinates of the shapes in the order X, Y, Z. The length of each array will always be a multiple of 3. At present, the Z coordinate is ignored since the shapes are projected onto a 2D sheet.

Enumerations
 | Enumeration | Description
Public enumeration | DwgArcType | Defines how arcs are filled
Public enumeration | DwgFillMode | Describes how shapes are filled
Public enumeration | DwgReduction | Enumeration used by OnBegin... methods in GeometryHandler to determine if a non-primitive shape should be reduced further


DwgArcType Enumeration

Defines how arcs are filled

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DwgArcType
Public Enumeration DwgArcType
Members
Member name | Description
Unfilled | Arcs are not filled
CenterFilled | Arcs are filled by connection the ends of the arc to the center
ChordFilled | Arcs are filled by connected the ends of the arc
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder Class

The DwgDecoder provides the ability to rasterize AutoCAD DWG files
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.CadCamDwgDecoder

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DwgDecoder : MultiFramedImageDecoder, IDisposable
Public Class DwgDecoder
    Inherits MultiFramedImageDecoder
    Implements IDisposable

The DwgDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | DwgDecoder | Constructs a new DwgDecoder object.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Sets or gets the background color that will be used for a given drawing
Public property | DefaultSize | Sets or gets the default page size in inches.
Public property | FitToPage | Sets or gets how the drawing is fit to the page.
Public property | OutsidePageSize | Sets or gets the size of resulting images in pixels
Public property | Resolution | Sets or gets the resolution of resulting images.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Public property | UseOutsidePageSize | Sets or gets a flag indicating whether or not the files page size should be overridden.
Public property | Zoom | Gets or sets zoom factor.
Public property | ZoomPoint | Sets or gets the point from which zooming should be done on the image.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DwgDecoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DwgDecoder and optionally releases the managed resources
 | Distill | Scans through a document, extracts the geometry with each page, and optionally reduces it to primitives.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of conceptual frames in a DWG file. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Returns information about an image in the file. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about an image in the file. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks to see if a stream contains a DWG image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Reads an image from a stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Reads an image from a stream. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MAXRESOLUTION | A constant representing the maximum resolution for rasterizing an image.
MINRESOLUTION | A constant representing the minimum resolution for rasterizing an image.
Top
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder Constructor

Constructs a new DwgDecoder object.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DwgDecoder()
Public Sub New
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder Properties

The DwgDecoder type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Sets or gets the background color that will be used for a given drawing
Public property | DefaultSize | Sets or gets the default page size in inches.
Public property | FitToPage | Sets or gets how the drawing is fit to the page.
Public property | OutsidePageSize | Sets or gets the size of resulting images in pixels
Public property | Resolution | Sets or gets the resolution of resulting images.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Public property | UseOutsidePageSize | Sets or gets a flag indicating whether or not the files page size should be overridden.
Public property | Zoom | Gets or sets zoom factor.
Public property | ZoomPoint | Sets or gets the point from which zooming should be done on the image.
Top
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.BackgroundColor Property

DwgDecoderBackgroundColor Property

Sets or gets the background color that will be used for a given drawing

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.DefaultSize Property

DwgDecoderDefaultSize Property

Sets or gets the default page size in inches.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF DefaultSize { get; set; }
Public Property DefaultSize As SizeF
    Get
    Set

Property Value

Type: SizeF
Remarks

The default value is 11 inches wide by 8.5 high (landscape letter).

If a frame has no specified page size, the default will be used instead.

See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.FitToPage Property

DwgDecoderFitToPage Property

Sets or gets how the drawing is fit to the page.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FitToPage { get; set; }
Public Property FitToPage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.OutsidePageSize Property

DwgDecoderOutsidePageSize Property

Sets or gets the size of resulting images in pixels

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size OutsidePageSize { get; set; }
Public Property OutsidePageSize As Size
    Get
    Set

Property Value

Type: Size
The size of the resulting image in pixels
Remarks
OutsidePageSize is always substituted for the page size in the file or the DefaultSize property. Unlike DefaultSize, OutsidePageSize is in pixels.
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Resolution Property

DwgDecoderResolution Property

Sets or gets the resolution of resulting images.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.UseOutsidePageSize Property

DwgDecoderUseOutsidePageSize Property

Sets or gets a flag indicating whether or not the files page size should be overridden.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseOutsidePageSize { get; set; }
Public Property UseOutsidePageSize As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Zoom Property

DwgDecoderZoom Property

Gets or sets zoom factor.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
Remarks
Default value is 1.0.
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.ZoomPoint Property

DwgDecoderZoomPoint Property

Sets or gets the point from which zooming should be done on the image.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ZoomPoint { get; set; }
Public Property ZoomPoint As PointF
    Get
    Set

Property Value

Type: PointF
Remarks
Default value is (0.0, 0.0). The origin is the center of the page.
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder Methods

The DwgDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
 | Distill | Scans through a document, extracts the geometry with each page, and optionally reduces it to primitives.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of conceptual frames in a DWG file. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Returns information about an image in the file. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about an image in the file. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks to see if a stream contains a DWG image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Reads an image from a stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Reads an image from a stream. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Dispose Method

DwgDecoderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the DwgDecoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DwgDecoder and optionally releases the managed resources
Top
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Dispose Method

DwgDecoderDispose Method

Releases all resources used by the DwgDecoder

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DwgDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Dispose Method (Boolean)

DwgDecoderDispose Method (Boolean)

Releases the unmanaged resources used by the DwgDecoder and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

DwgDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Distill Method

DwgDecoderDistill Method

Scans through a document, extracts the geometry with each page, and optionally reduces it to primitives.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Distill(
    Stream stream,
    GeometryHandler userHandler,
    ProgressEventHandler progress
)
Public Sub Distill (
    stream As Stream,
    userHandler As GeometryHandler,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing a DWG file
userHandler
Type: Atalasoft.Imaging.Codec.CadCamGeometryHandler
A GeometryHandler object for responding to geometry in the file.
progress
Type: Atalasoft.ImagingProgressEventHandler
A callback for progress events
Examples
Calling Distill (C#)
Copy
using (FileStream stm = new FileStream(pathToDWG, FileMode.Open) {
    DwgDecoder decoder = new DwgDecoder();
    GeometryHandler handler = new MyGeometryHandler();
    handler.Distill(stm, handler, null);
}
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.GetFrameCount Method

DwgDecoderGetFrameCount Method

Returns the number of conceptual frames in a DWG file.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
A non-null stream containing a DWG file

Return Value

Type: Int32
The number of conceptual frames in a DWG file.
Remarks
Frames has no specific meaning in DWG. In this case, frames are considered to be layouts.
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.GetImageInfo Method

DwgDecoderGetImageInfo Method

Returns information about an image in the file.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Returns information about an image in the file. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about an image in the file. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.GetImageInfo Method (Stream)

DwgDecoderGetImageInfo Method (Stream)

Returns information about an image in the file.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A non-null stream containing a DWG file

Return Value

Type: ImageInfo
GetImageInfo returns a DwgImageInfo object which contains extended information the frames in the file.
Remarks
GetImageInfo returns a DwgImageInfo object which contains extended information the frames in the file.
See Also

Reference

DwgDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.GetImageInfo Method (Stream, Int32)

DwgDecoderGetImageInfo Method (Stream, Int32)

Returns information about an image in the file.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
A non-null stream containing a DWG file
frameIndex
Type: SystemInt32
A zero-based index to a frame in the file

Return Value

Type: ImageInfo
GetImageInfo returns a DwgImageInfo object which contains extended information the frames in the file.
See Also

Reference

DwgDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.IsValidFormat Method

DwgDecoderIsValidFormat Method

Checks to see if a stream contains a DWG image.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A non-null stream containing a DWG file

Return Value

Type: Boolean
Returns true if the image contains a DWG, false otherwise.
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Read Method

DwgDecoderRead Method

Reads an image from a stream.
Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Reads an image from a stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Reads an image from a stream. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Read Method (Stream, ProgressEventHandler)

DwgDecoderRead Method (Stream, ProgressEventHandler)

Reads an image from a stream.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A non-null stream containing a DWG file
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress event handler to monitor image loading

Return Value

Type: AtalaImage
See Also

Reference

DwgDecoder Class
Read Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.Read Method (Stream, Int32, ProgressEventHandler)

DwgDecoderRead Method (Stream, Int32, ProgressEventHandler)

Reads an image from a stream.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A non-null stream containing a DWG file
frameIndex
Type: SystemInt32
The zero-based index of the page to read
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress event handler to monitor image loading

Return Value

Type: AtalaImage
See Also

Reference

DwgDecoder Class
Read Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder Fields

The DwgDecoder type exposes the following members.

Fields
Name | Description
MAXRESOLUTION | A constant representing the maximum resolution for rasterizing an image.
MINRESOLUTION | A constant representing the minimum resolution for rasterizing an image.
Top
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.MAXRESOLUTION Field

DwgDecoderMAXRESOLUTION Field

A constant representing the maximum resolution for rasterizing an image.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int MAXRESOLUTION
Public Shared MAXRESOLUTION As Integer

Field Value

Type: Int32
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoder.MINRESOLUTION Field

DwgDecoderMINRESOLUTION Field

A constant representing the minimum resolution for rasterizing an image.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int MINRESOLUTION
Public Shared MINRESOLUTION As Integer

Field Value

Type: Int32
See Also

Reference

DwgDecoder Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.CadCamDwgDecoderImpl

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DwgDecoderImpl
Public Class DwgDecoderImpl

The DwgDecoderImpl type exposes the following members.

Constructors
 | Name | Description
Public method | DwgDecoderImpl | Initializes a new instance of the DwgDecoderImpl class
Top
Properties
 | Name | Description
Public property | BackgroundColor |
Public property | DefaultSize |
Public property | FitToPage |
Public property | OutsidePageSize |
Public property | Resolution |
Public property | UseOutsidePageSize |
Public property | Zoom |
Public property | ZoomPoint |
Top
Methods
 | Name | Description
Public method | Distill |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) |
Public method | GetImageInfo(Stream, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeOpenDwg |
Public method | IsValidFormat |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) |
Public method | Read(Stream, Int32, ProgressEventHandler) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl Constructor

Initializes a new instance of the DwgDecoderImpl class

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DwgDecoderImpl(
    int minResolution,
    int maxResolution
)
Public Sub New (
    minResolution As Integer,
    maxResolution As Integer
)

Parameters

minResolution
Type: SystemInt32
maxResolution
Type: SystemInt32
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl Properties

The DwgDecoderImpl type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor |
Public property | DefaultSize |
Public property | FitToPage |
Public property | OutsidePageSize |
Public property | Resolution |
Public property | UseOutsidePageSize |
Public property | Zoom |
Public property | ZoomPoint |
Top
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.BackgroundColor Property

DwgDecoderImplBackgroundColor Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.DefaultSize Property

DwgDecoderImplDefaultSize Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF DefaultSize { get; set; }
Public Property DefaultSize As SizeF
    Get
    Set

Property Value

Type: SizeF
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.FitToPage Property

DwgDecoderImplFitToPage Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FitToPage { get; set; }
Public Property FitToPage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.OutsidePageSize Property

DwgDecoderImplOutsidePageSize Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size OutsidePageSize { get; set; }
Public Property OutsidePageSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.Resolution Property

DwgDecoderImplResolution Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.UseOutsidePageSize Property

DwgDecoderImplUseOutsidePageSize Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseOutsidePageSize { get; set; }
Public Property UseOutsidePageSize As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.Zoom Property

DwgDecoderImplZoom Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.ZoomPoint Property

DwgDecoderImplZoomPoint Property

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ZoomPoint { get; set; }
Public Property ZoomPoint As PointF
    Get
    Set

Property Value

Type: PointF
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl Methods

The DwgDecoderImpl type exposes the following members.

Methods
 | Name | Description
Public method | Distill |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) |
Public method | GetImageInfo(Stream, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeOpenDwg |
Public method | IsValidFormat |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) |
Public method | Read(Stream, Int32, ProgressEventHandler) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.Distill Method

DwgDecoderImplDistill Method

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Distill(
    Stream stream,
    GeometryHandler userHandler,
    ProgressEventHandler progress
)
Public Sub Distill (
    stream As Stream,
    userHandler As GeometryHandler,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
userHandler
Type: Atalasoft.Imaging.Codec.CadCamGeometryHandler
progress
Type: Atalasoft.ImagingProgressEventHandler
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.GetFrameCount Method

DwgDecoderImplGetFrameCount Method

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetFrameCount(
    Stream stream
)
Public Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream

Return Value

Type: Int32
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.GetImageInfo Method

DwgDecoderImplGetImageInfo Method

Overload List
 | Name | Description
Public method | GetImageInfo(Stream) |
Public method | GetImageInfo(Stream, Int32) |
Top
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.GetImageInfo Method (Stream)

DwgDecoderImplGetImageInfo Method (Stream)

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInfo GetImageInfo(
    Stream stream
)
Public Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream

Return Value

Type: ImageInfo
See Also

Reference

DwgDecoderImpl Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.GetImageInfo Method (Stream, Int32)

DwgDecoderImplGetImageInfo Method (Stream, Int32)

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
frameIndex
Type: SystemInt32

Return Value

Type: ImageInfo
See Also

Reference

DwgDecoderImpl Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.InitializeOpenDwg Method

DwgDecoderImplInitializeOpenDwg Method

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void InitializeOpenDwg()
Public Shared Sub InitializeOpenDwg
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.IsValidFormat Method

DwgDecoderImplIsValidFormat Method

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsValidFormat(
    Stream stream
)
Public Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream

Return Value

Type: Boolean
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.Read Method

DwgDecoderImplRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) |
Public method | Read(Stream, Int32, ProgressEventHandler) |
Top
See Also

Reference

DwgDecoderImpl Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.Read Method (Stream, ProgressEventHandler)

DwgDecoderImplRead Method (Stream, ProgressEventHandler)

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

DwgDecoderImpl Class
Read Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgDecoderImpl.Read Method (Stream, Int32, ProgressEventHandler)

DwgDecoderImplRead Method (Stream, Int32, ProgressEventHandler)

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
frameIndex
Type: SystemInt32
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

DwgDecoderImpl Class
Read Overload
Atalasoft.Imaging.Codec.CadCam Namespace


DwgFillMode Enumeration

Describes how shapes are filled

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DwgFillMode
Public Enumeration DwgFillMode
Members
Member name | Description
Filled | Shapes will be filled
Unfilled | Shapes will not be filled
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgImageInfo Class

An object representing information about a DWG image
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.Codec.CadCamDwgImageInfo

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DwgImageInfo : ImageInfo
Public Class DwgImageInfo
    Inherits ImageInfo

The DwgImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DwgImageInfo | Constructs a new DwgImageInfoObject
Top
Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | FrameNames | Gets a collection of names associated with frames in the file
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgImageInfo Constructor

Constructs a new DwgImageInfoObject

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DwgImageInfo(
    Size size,
    Dpi resolution,
    int frameCount
)
Public Sub New (
    size As Size,
    resolution As Dpi,
    frameCount As Integer
)

Parameters

size
Type: System.DrawingSize
The size of the image in pixels
resolution
Type: Atalasoft.ImagingDpi
The resolution of the image
frameCount
Type: SystemInt32
The number of frames in the file
See Also

Reference

DwgImageInfo Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgImageInfo Properties

The DwgImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | FrameNames | Gets a collection of names associated with frames in the file
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
See Also

Reference

DwgImageInfo Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgImageInfo.FrameNames Property

DwgImageInfoFrameNames Property

Gets a collection of names associated with frames in the file

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] FrameNames { get; }
Public ReadOnly Property FrameNames As String()
    Get

Property Value

Type: String
Remarks
In DWG files, every layout has a name associated with it. This string collection returns the names of the layouts. This may be useful in finding a particular view of a model.
See Also

Reference

DwgImageInfo Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgImageInfo Methods

The DwgImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

DwgImageInfo Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgReduction Enumeration

Enumeration used by OnBegin... methods in GeometryHandler to determine if a non-primitive shape should be reduced further

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DwgReduction
Public Enumeration DwgReduction
Members
Member name | Description
Reduce | Indicated that a shape should be reduced
DontReduce | Indicates that a shape should not be reduced
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle Class

This class represents the style of a block of text in a document
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.CadCamDwgTextStyle

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DwgTextStyle
Public Class DwgTextStyle

The DwgTextStyle type exposes the following members.

Constructors
 | Name | Description
Public method | DwgTextStyle | Constructs a DwgTextStyle object
Top
Properties
 | Name | Description
Public property | Font | Sets or gets a Font object representing the font used for a block of text
Public property | FontName | Sets or gets the name of the font requested
Public property | Style | Sets or gets the font style for the object
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle Constructor

Constructs a DwgTextStyle object

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DwgTextStyle()
Public Sub New
Remarks
You will not normally need to construct this object type. It is constructed for you and passed to the OnBeginText method of GeometryHandler.
See Also

Reference

DwgTextStyle Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle Properties

The DwgTextStyle type exposes the following members.

Properties
 | Name | Description
Public property | Font | Sets or gets a Font object representing the font used for a block of text
Public property | FontName | Sets or gets the name of the font requested
Public property | Style | Sets or gets the font style for the object
Top
See Also

Reference

DwgTextStyle Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle.Font Property

DwgTextStyleFont Property

Sets or gets a Font object representing the font used for a block of text

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set

Property Value

Type: Font
Remarks
The Font value may be null if it is not possible to construct the requested font. The FontName will indicate the name of the font that was requested
See Also

Reference

DwgTextStyle Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle.FontName Property

DwgTextStyleFontName Property

Sets or gets the name of the font requested

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set

Property Value

Type: String
Remarks
Changing the FontName property in no way affects the Font property
See Also

Reference

DwgTextStyle Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle.Style Property

DwgTextStyleStyle Property

Sets or gets the font style for the object

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontStyle Style { get; set; }
Public Property Style As FontStyle
    Get
    Set

Property Value

Type: FontStyle
Remarks
This style is reflected directly from the DWG file. If font substitution occurs while constructing the Font object then the Font.Style property may be different.
See Also

Reference

DwgTextStyle Class
Atalasoft.Imaging.Codec.CadCam Namespace


DwgTextStyle Methods

The DwgTextStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DwgTextStyle Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler Class

GeometryHandler is a class that is used for extracting geometry from a DWG file. It consists of a series of methods that are called for each shape type in the as well as for changes in color and line style.

Nearly all of the OnBegin... methods return an enumerated value. This is to indicate to Distill whether or not the user GeometryHandler wants the geometry to be reduced further or not. The GeometryHandler base class implements all OnBegin... methods for shapes such that they return DwgReduction.Reduce. The GeometryHandler base class therefore causes a model to be fully reduced to primitives. Client code should subclass GeomtryHandler and override the methods they wish to intercept.

For example, an application that wishes to extract text from a DWG file would only need to override OnBeginText.

OnBeginPage should return true if the client wishes to process the page.

OnBeginDocument does not have a return value.

OnPolygon and OnPolyline represent primitives for which there is no further reduction.

All the OnBeginShape and OnEndShape methods take a shape ID parameter. This is unique ID that is assigned to every shape. This is to make it easier to identify when all reduction is done for a particular shape.

Many of the routines take arrays of double precision floating point numbers. These represent 3D coordinates of the shapes in the order X, Y, Z. The length of each array will always be a multiple of 3. At present, the Z coordinate is ignored since the shapes are projected onto a 2D sheet.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.CadCamGeometryHandler

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GeometryHandler
Public Class GeometryHandler

The GeometryHandler type exposes the following members.

Constructors
 | Name | Description
Public method | GeometryHandler | Initializes a new instance of the GeometryHandler class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeginCircle | This method is called when a circle has been encountered.
Public method | OnBeginCircularArc3Point | Describes a circular using three points.
Public method | OnBeginCircularArcCenterRadius | Describes a circular arc via a circle's center, radius and sweep angle.
 | OnBeginDocument | Constructs a new default GeometryHandler.
Public method | OnBeginEllipticalArc | Describes an elliptical arc
 | OnBeginPage | Called when page processing starts.
Public method | OnBeginPolygon | Describes a closed polygon
Public method | OnBeginRay | Describes an infinite mathematical ray.
Public method | OnBeginSimplePolyline | Describes an open polygon to be drawn.
Public method | OnBeginText | Describes text presented on the page
Public method | OnBeginXLine | Describes a mathematical infinite line
Public method | OnEndCircle | Describes completion of a circle
Public method | OnEndCircularArc3Point | Describes completion of a circular arc
Public method | OnEndCircularArcCenterRadius | Describes completion of a circular arc
Public method | OnEndDocument | Describes completion of the document
Public method | OnEndEllipticalArc | Describes completion of an elliptical arc
Public method | OnEndPage | Describes completion of a page
Public method | OnEndPolygon | Describes completion of a polygon
Public method | OnEndRay |
Public method | OnEndSimplePolyline | Describes completion of a simple polyline
Public method | OnEndText | Describes completion of text
Public method | OnEndXLine | Describes completion of a line
Public method | OnPolygon | Describes a request to render a primitive closed polygon
Public method | OnPolyline | Describes a request to render a primitive open polygon
Public method | OnSetColor | Represents a request to change the color of subsequent objects
Public method | OnSetFillMode | Represents a request to set the fill mode of subsequent filled shapes
Public method | OnSetLineWidth | Represents a request to set the line characteristics of subsequent shapes
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Extracting Fonts (C#)
Copy
public class FontExtractorHandler : GeometryHandler {
    private List<Font> _fonts = new List<Font>();
    public override DwgReduction OnBeginText(int shapeId, double[] position,
        double[] direction, double[] up, string text, bool raw,
        DwgTextStyle textStyle, double[] extrusion)
    {
        if (textStyle.Font != null) {
            _fonts.Add(textStyle.Font);
        }
        return DwgReduction.DontReduce;
    }
    public List<Font> Fonts { get { return _fonts; } }
}
See Also

Reference

Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler Constructor

Initializes a new instance of the GeometryHandler class

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GeometryHandler()
Public Sub New
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler Methods

The GeometryHandler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeginCircle | This method is called when a circle has been encountered.
Public method | OnBeginCircularArc3Point | Describes a circular using three points.
Public method | OnBeginCircularArcCenterRadius | Describes a circular arc via a circle's center, radius and sweep angle.
 | OnBeginDocument | Constructs a new default GeometryHandler.
Public method | OnBeginEllipticalArc | Describes an elliptical arc
 | OnBeginPage | Called when page processing starts.
Public method | OnBeginPolygon | Describes a closed polygon
Public method | OnBeginRay | Describes an infinite mathematical ray.
Public method | OnBeginSimplePolyline | Describes an open polygon to be drawn.
Public method | OnBeginText | Describes text presented on the page
Public method | OnBeginXLine | Describes a mathematical infinite line
Public method | OnEndCircle | Describes completion of a circle
Public method | OnEndCircularArc3Point | Describes completion of a circular arc
Public method | OnEndCircularArcCenterRadius | Describes completion of a circular arc
Public method | OnEndDocument | Describes completion of the document
Public method | OnEndEllipticalArc | Describes completion of an elliptical arc
Public method | OnEndPage | Describes completion of a page
Public method | OnEndPolygon | Describes completion of a polygon
Public method | OnEndRay |
Public method | OnEndSimplePolyline | Describes completion of a simple polyline
Public method | OnEndText | Describes completion of text
Public method | OnEndXLine | Describes completion of a line
Public method | OnPolygon | Describes a request to render a primitive closed polygon
Public method | OnPolyline | Describes a request to render a primitive open polygon
Public method | OnSetColor | Represents a request to change the color of subsequent objects
Public method | OnSetFillMode | Represents a request to set the fill mode of subsequent filled shapes
Public method | OnSetLineWidth | Represents a request to set the line characteristics of subsequent shapes
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginCircle Method

GeometryHandlerOnBeginCircle Method

This method is called when a circle has been encountered.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginCircle(
    int shapeId,
    double[] center,
    double radius,
    double[] normalVector,
    double[] extrusionVector
)
Public Overridable Function OnBeginCircle (
    shapeId As Integer,
    center As Double(),
    radius As Double,
    normalVector As Double(),
    extrusionVector As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
center
Type: SystemDouble
The center of the circle in Cartesian coordinates
radius
Type: SystemDouble
The radius of the circle.
normalVector
Type: SystemDouble
The normal vector from the surface of the shape in 3D coordinates in the order X, Y, Z.
extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginCircularArc3Point Method

GeometryHandlerOnBeginCircularArc3Point Method

Describes a circular using three points.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginCircularArc3Point(
    int shapeId,
    double[] firstPoint,
    double[] secondPoint,
    double[] thirdPoint,
    DwgArcType arcType,
    double[] extrusionVector
)
Public Overridable Function OnBeginCircularArc3Point (
    shapeId As Integer,
    firstPoint As Double(),
    secondPoint As Double(),
    thirdPoint As Double(),
    arcType As DwgArcType,
    extrusionVector As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
firstPoint
Type: SystemDouble
The starting point of the arc
secondPoint
Type: SystemDouble
A third point on the arc between the first and third
thirdPoint
Type: SystemDouble
The ending point of the arc
arcType
Type: Atalasoft.Imaging.Codec.CadCamDwgArcType
Indicates how the arc is to be drawn.
extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginCircularArcCenterRadius Method

GeometryHandlerOnBeginCircularArcCenterRadius Method

Describes a circular arc via a circle's center, radius and sweep angle.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginCircularArcCenterRadius(
    int shapeId,
    double[] center,
    double radius,
    double[] normalVector,
    double[] startVector,
    double sweepAngle,
    DwgArcType arcType,
    double[] extrusionVector
)
Public Overridable Function OnBeginCircularArcCenterRadius (
    shapeId As Integer,
    center As Double(),
    radius As Double,
    normalVector As Double(),
    startVector As Double(),
    sweepAngle As Double,
    arcType As DwgArcType,
    extrusionVector As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
center
Type: SystemDouble
The center of the circle in Cartesian coordinates
radius
Type: SystemDouble
The radius of the circle.
normalVector
Type: SystemDouble
The normal vector from the surface of the shape in 3D coordinates in the order X, Y, Z.
startVector
Type: SystemDouble
Defines the start of the circular arc
sweepAngle
Type: SystemDouble
Defines the angle of the arc in radians
arcType
Type: Atalasoft.Imaging.Codec.CadCamDwgArcType
Indicates how the arc is to be drawn.
extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginDocument Method

GeometryHandlerOnBeginDocument Method

Constructs a new default GeometryHandler.
Called when document processing starts.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnBeginDocument(
    int pageCount
)
Public Overridable Sub OnBeginDocument (
    pageCount As Integer
)

Parameters

pageCount
Type: SystemInt32
The total number of pages expected.
Remarks
Since the GeometryHandler does nothing on its own, the default constructor does nothing.
Remarks
BeginDocument will be matched with a call to EndDocument.
Examples
Tracking Pages (C#)
Copy
public class PageTrackingHandler : GeometryHandler {
    private int _total, _current;
    public override void OnBeginDocument(int pageCount)
    {
        _total = pageCount;
        Console.WriteLine("Starting a " + _total + " page document.");
    }
    public override bool OnBeginPage(int page, SizeF pageSize)
    {
        Console.WriteLine("Processing page " + (page + 1) + " of " + _total);
    }
}
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginEllipticalArc Method

GeometryHandlerOnBeginEllipticalArc Method

Describes an elliptical arc

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginEllipticalArc(
    int shapeId,
    double[] center,
    double[] majorAxisVector,
    double[] minorAxisVector,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle,
    double[] endPointsOverrides,
    DwgArcType arcType,
    double[] extrusionVector
)
Public Overridable Function OnBeginEllipticalArc (
    shapeId As Integer,
    center As Double(),
    majorAxisVector As Double(),
    minorAxisVector As Double(),
    majorRadius As Double,
    minorRadius As Double,
    startAngle As Double,
    endAngle As Double,
    endPointsOverrides As Double(),
    arcType As DwgArcType,
    extrusionVector As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
center
Type: SystemDouble
The center of the circle in Cartesian coordinates
majorAxisVector
Type: SystemDouble
The direction of the major axis of the ellipise
minorAxisVector
Type: SystemDouble
The direction of the minor axis of the ellipise
majorRadius
Type: SystemDouble
The size of the major radius of the ellipse
minorRadius
Type: SystemDouble
The size of the minor radius of the ellipse
startAngle
Type: SystemDouble
The starting angle of the arc in radians.
endAngle
Type: SystemDouble
The ending angle of the arc in radians. The end an
endPointsOverrides
Type: SystemDouble
An array of points to be used as the first and last points of the arc
arcType
Type: Atalasoft.Imaging.Codec.CadCamDwgArcType
Indicates how the arc is to be drawn.
extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginPage Method

GeometryHandlerOnBeginPage Method

Called when page processing starts.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool OnBeginPage(
    int page,
    SizeF pageSizeInInches
)
Public Overridable Function OnBeginPage (
    page As Integer,
    pageSizeInInches As SizeF
) As Boolean

Parameters

page
Type: SystemInt32
The zero-based index of the page
pageSizeInInches
Type: System.DrawingSizeF
The dimensions of the page in inches.

Return Value

Type: Boolean
OnBeginPage should return true to indicate that the page should be processed.
Examples
Coversheet Handling (C#)
Copy
public class CoverSheetHandler : GeometryHandler {
    public bool OnBeginPage(int page, SizeF pageSizeInInches)
    {
        return page == 0;
    }
}
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginPolygon Method

GeometryHandlerOnBeginPolygon Method

Describes a closed polygon

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginPolygon(
    int shapeId,
    double[] vertices,
    double[] normalVector,
    double[] extrusionVector
)
Public Overridable Function OnBeginPolygon (
    shapeId As Integer,
    vertices As Double(),
    normalVector As Double(),
    extrusionVector As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
vertices
Type: SystemDouble
An array of three dimensional points describing the polygon to be drawn. The polygon should be closed by connecting the first and last points.
normalVector
Type: SystemDouble
The normal vector from the surface of the shape in 3D coordinates in the order X, Y, Z.
extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginRay Method

GeometryHandlerOnBeginRay Method

Describes an infinite mathematical ray.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginRay(
    int shapeId,
    double[] basePoint,
    double[] throughPoint
)
Public Overridable Function OnBeginRay (
    shapeId As Integer,
    basePoint As Double(),
    throughPoint As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
basePoint
Type: SystemDouble
A three dimensional point describing the start of the ray
throughPoint
Type: SystemDouble
A point through which the ray travels.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginSimplePolyline Method

GeometryHandlerOnBeginSimplePolyline Method

Describes an open polygon to be drawn.

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginSimplePolyline(
    int shapeId,
    double[] vertices,
    double[] normalVector,
    double[] extrusionVector,
    int baseSubEntMarker
)
Public Overridable Function OnBeginSimplePolyline (
    shapeId As Integer,
    vertices As Double(),
    normalVector As Double(),
    extrusionVector As Double(),
    baseSubEntMarker As Integer
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
vertices
Type: SystemDouble
An array of three dimensional points describing the polygon to be drawn.
normalVector
Type: SystemDouble
The normal vector from the surface of the shape in 3D coordinates in the order X, Y, Z.
extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.
baseSubEntMarker
Type: SystemInt32

This parameter is currently unusued.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginText Method

GeometryHandlerOnBeginText Method

Describes text presented on the page

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginText(
    int shapeId,
    double[] position,
    double[] directionVector,
    double[] upVector,
    string msg,
    bool raw,
    DwgTextStyle textStyle,
    double[] extrusionVector
)
Public Overridable Function OnBeginText (
    shapeId As Integer,
    position As Double(),
    directionVector As Double(),
    upVector As Double(),
    msg As String,
    raw As Boolean,
    textStyle As DwgTextStyle,
    extrusionVector As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
position
Type: SystemDouble
The location of the text on the sheet.
directionVector
Type: SystemDouble
The direction of the text flow
upVector
Type: SystemDouble
The up vector specifying orientation along the direction vector
msg
Type: SystemString

The text to render

raw
Type: SystemBoolean
Indicates whether or not DWG escape sequences have been expanded.
textStyle
Type: Atalasoft.Imaging.Codec.CadCamDwgTextStyle

Styling information, including the Font

extrusionVector
Type: SystemDouble
A vector describing direction and length of how this object should be extruded.

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
Remarks
If this method returns false, text will be reduced to polylines and polygons
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnBeginXLine Method

GeometryHandlerOnBeginXLine Method

Describes a mathematical infinite line

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DwgReduction OnBeginXLine(
    int shapeId,
    double[] firstPoint,
    double[] secondPoint
)
Public Overridable Function OnBeginXLine (
    shapeId As Integer,
    firstPoint As Double(),
    secondPoint As Double()
) As DwgReduction

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
firstPoint
Type: SystemDouble
The first of two points to represent the line
secondPoint
Type: SystemDouble
The second of two points to represent the line

Return Value

Type: DwgReduction
Return DwgReduction.Reduce to request that the shape should be reduced further, DwgReduction.DontReduce otherwise.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndCircle Method

GeometryHandlerOnEndCircle Method

Describes completion of a circle

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndCircle(
    int shapeId
)
Public Overridable Sub OnEndCircle (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndCircularArc3Point Method

GeometryHandlerOnEndCircularArc3Point Method

Describes completion of a circular arc

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndCircularArc3Point(
    int shapeId
)
Public Overridable Sub OnEndCircularArc3Point (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndCircularArcCenterRadius Method

GeometryHandlerOnEndCircularArcCenterRadius Method

Describes completion of a circular arc

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndCircularArcCenterRadius(
    int shapeId
)
Public Overridable Sub OnEndCircularArcCenterRadius (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. When Distill is done reducing a shape, OnEnd... will be called with this shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndDocument Method

GeometryHandlerOnEndDocument Method

Describes completion of the document

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndDocument()
Public Overridable Sub OnEndDocument
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndEllipticalArc Method

GeometryHandlerOnEndEllipticalArc Method

Describes completion of an elliptical arc

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndEllipticalArc(
    int shapeId
)
Public Overridable Sub OnEndEllipticalArc (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. At the time when OnEnd... is called, the was a prior call to OnBegin... with a matching shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndPage Method

GeometryHandlerOnEndPage Method

Describes completion of a page

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndPage(
    int page
)
Public Overridable Sub OnEndPage (
    page As Integer
)

Parameters

page
Type: SystemInt32
The zero-based index of the page
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndPolygon Method

GeometryHandlerOnEndPolygon Method

Describes completion of a polygon

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndPolygon(
    int shapeId
)
Public Overridable Sub OnEndPolygon (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. At the time when OnEnd... is called, the was a prior call to OnBegin... with a matching shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndRay Method

GeometryHandlerOnEndRay Method

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndRay(
    int shapeId
)
Public Overridable Sub OnEndRay (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndSimplePolyline Method

GeometryHandlerOnEndSimplePolyline Method

Describes completion of a simple polyline

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndSimplePolyline(
    int shapeId
)
Public Overridable Sub OnEndSimplePolyline (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. At the time when OnEnd... is called, the was a prior call to OnBegin... with a matching shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndText Method

GeometryHandlerOnEndText Method

Describes completion of text

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndText(
    int shapeId
)
Public Overridable Sub OnEndText (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. At the time when OnEnd... is called, the was a prior call to OnBegin... with a matching shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnEndXLine Method

GeometryHandlerOnEndXLine Method

Describes completion of a line

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnEndXLine(
    int shapeId
)
Public Overridable Sub OnEndXLine (
    shapeId As Integer
)

Parameters

shapeId
Type: SystemInt32
A unique identifier for this shape. At the time when OnEnd... is called, the was a prior call to OnBegin... with a matching shape identifier.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnPolygon Method

GeometryHandlerOnPolygon Method

Describes a request to render a primitive closed polygon

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnPolygon(
    double[] vertices,
    double[] normal
)
Public Overridable Sub OnPolygon (
    vertices As Double(),
    normal As Double()
)

Parameters

vertices
Type: SystemDouble
An array of points representing a polygon. This is a primitive shape and can not be reduced further
normal
Type: SystemDouble
The normal vector from the surface of the shape in 3D coordinates in the order X, Y, Z.
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnPolyline Method

GeometryHandlerOnPolyline Method

Describes a request to render a primitive open polygon

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnPolyline(
    double[] vertices
)
Public Overridable Sub OnPolyline (
    vertices As Double()
)

Parameters

vertices
Type: SystemDouble
An array of points representing a polygon. This is a primitive shape and can not be reduced further
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnSetColor Method

GeometryHandlerOnSetColor Method

Represents a request to change the color of subsequent objects

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnSetColor(
    int r,
    int g,
    int b
)
Public Overridable Sub OnSetColor (
    r As Integer,
    g As Integer,
    b As Integer
)

Parameters

r
Type: SystemInt32
The red value for the color, ranged from 0 - 255
g
Type: SystemInt32
The green value for the color, ranged from 0 - 255
b
Type: SystemInt32
The blue value for the color, ranged from 0 - 255
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnSetFillMode Method

GeometryHandlerOnSetFillMode Method

Represents a request to set the fill mode of subsequent filled shapes

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnSetFillMode(
    DwgFillMode fillMode
)
Public Overridable Sub OnSetFillMode (
    fillMode As DwgFillMode
)

Parameters

fillMode
Type: Atalasoft.Imaging.Codec.CadCamDwgFillMode
The fill mode of the shape
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


GeometryHandler.OnSetLineWidth Method

GeometryHandlerOnSetLineWidth Method

Represents a request to set the line characteristics of subsequent shapes

Namespace: Atalasoft.Imaging.Codec.CadCam
Assembly: Atalasoft.dotImage.Dwg (in Atalasoft.dotImage.Dwg.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void OnSetLineWidth(
    int weightInMMTenths,
    int pixelLineWidth
)
Public Overridable Sub OnSetLineWidth (
    weightInMMTenths As Integer,
    pixelLineWidth As Integer
)

Parameters

weightInMMTenths
Type: SystemInt32
Line width in tenths of a millimeter
pixelLineWidth
Type: SystemInt32
Approximate line width in pixels
See Also

Reference

GeometryHandler Class
Atalasoft.Imaging.Codec.CadCam Namespace


Atalasoft.Imaging.Codec.Dicom Namespace

Classes
Class | Description
Public class DicomDataset

DicomDataset is an object that encapsulates and models the data set structures of a Dicom file. From this object, client code can request images from within the file. The DicomDataset object implements the IDisposable interface because it contains system resources that need to be freed. It should be noted that all DicomDataset objects should be disposed before an application exits. Failure to do so may cause the application to throw an exception.

There are three forms of images that can be retrieved from a DicomDataset:

RawModalityTransformedPresentation

Raw images have had little or no processing performed on them. If an image is not representable by a DotImage PixelFormat, it will be transformed into the nearest matching Dicom color space.

ModalityTransformed images have been transformed as with Raw images and then with the Modality Look Up Table for the image.

Presentation images have been transformed as with ModalityTransformed images, but if gray have had the implicit window and leveling applied if present, or have had the a derived window and leveling applied.

Public class | DicomDecoder
Public class DicomHeaderParser
Use this class to read the meta-data from a DICOM encoded image
Public class DicomImage

DicomImage is a representation of raw or processed DicomImage data. DicomImage is meant to be used by those who need to do efficient and repeated window and leveling processing of image data.

The DicomImage object implements the IDisposable interface because it contains system resources that need to be freed. It should be noted that all DicomImage objects should be disposed before an application exits. Failure to do so may cause the application to throw an exception.

Enumerations
 | Enumeration | Description
Public enumeration | DicomGroup | Represents a Group in the DICOM meta-data
Public enumeration | DicomTag | Represents a Tag in the DICOM meta-data


DicomDataset Class

DicomDataset is an object that encapsulates and models the data set structures of a Dicom file. From this object, client code can request images from within the file. The DicomDataset object implements the IDisposable interface because it contains system resources that need to be freed. It should be noted that all DicomDataset objects should be disposed before an application exits. Failure to do so may cause the application to throw an exception.

There are three forms of images that can be retrieved from a DicomDataset:

RawModalityTransformedPresentation

Raw images have had little or no processing performed on them. If an image is not representable by a DotImage PixelFormat, it will be transformed into the nearest matching Dicom color space.

ModalityTransformed images have been transformed as with Raw images and then with the Modality Look Up Table for the image.

Presentation images have been transformed as with ModalityTransformed images, but if gray have had the implicit window and leveling applied if present, or have had the a derived window and leveling applied.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.DicomDicomDataset

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DicomDataset : IDisposable
Public Class DicomDataset
    Implements IDisposable

The DicomDataset type exposes the following members.

Constructors
 | Name | Description
Public method | DicomDataset | Constructs a new DicomDataset object from the Stream provided.
Top
Properties
 | Name | Description
Public property | FrameCount | Returns the total number of frames in the DicomDataset object.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomDataset
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomDataset and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetModalityTransformedImage | Retrieves a DicomImage for the given frameIndex representing the raw image data transformed through the modality look up table.
Public method | GetPresentationImage | Retrieves a DicomImage for the given frameIndex representing the raw data transformed into a Presentation Image.
Public method | GetRawImage | Retrieves a DicomImage for the given frameIndex representing the raw image data contained in the file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset Constructor

Constructs a new DicomDataset object from the Stream provided.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DicomDataset(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
A seekable stream from which the DicomDataset will be constructed.
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset Properties

The DicomDataset type exposes the following members.

Properties
 | Name | Description
Public property | FrameCount | Returns the total number of frames in the DicomDataset object.
Top
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.FrameCount Property

DicomDatasetFrameCount Property

Returns the total number of frames in the DicomDataset object.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameCount { get; }
Public ReadOnly Property FrameCount As Integer
    Get

Property Value

Type: Int32
A non-negative integer representing the number of images in the dataset.
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset Methods

The DicomDataset type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetModalityTransformedImage | Retrieves a DicomImage for the given frameIndex representing the raw image data transformed through the modality look up table.
Public method | GetPresentationImage | Retrieves a DicomImage for the given frameIndex representing the raw data transformed into a Presentation Image.
Public method | GetRawImage | Retrieves a DicomImage for the given frameIndex representing the raw image data contained in the file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.Dispose Method

DicomDatasetDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomDataset
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomDataset and optionally releases the managed resources
Top
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.Dispose Method

DicomDatasetDispose Method

Releases all resources used by the DicomDataset

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DicomDataset Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.Dispose Method (Boolean)

DicomDatasetDispose Method (Boolean)

Releases the unmanaged resources used by the DicomDataset and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

DicomDataset Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.GetModalityTransformedImage Method

DicomDatasetGetModalityTransformedImage Method

Retrieves a DicomImage for the given frameIndex representing the raw image data transformed through the modality look up table.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DicomImage GetModalityTransformedImage(
    int frameIndex
)
Public Function GetModalityTransformedImage (
    frameIndex As Integer
) As DicomImage

Parameters

frameIndex
Type: SystemInt32
An integer greater than or equal to zero representing the index of the frame to load. FrameIndex must be less than the FrameCount property for the dataset.

Return Value

Type: DicomImage
A new DicomImage object representing the raw image data transformed through the modality look up table.
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.GetPresentationImage Method

DicomDatasetGetPresentationImage Method

Retrieves a DicomImage for the given frameIndex representing the raw data transformed into a Presentation Image.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DicomImage GetPresentationImage(
    int frameIndex
)
Public Function GetPresentationImage (
    frameIndex As Integer
) As DicomImage

Parameters

frameIndex
Type: SystemInt32
An integer greater than or equal to zero representing the index of the frame to load. FrameIndex must be less than the FrameCount property for the dataset.

Return Value

Type: DicomImage
A new DicomImage object representing the raw data transformed into a Presentation Image.
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDataset.GetRawImage Method

DicomDatasetGetRawImage Method

Retrieves a DicomImage for the given frameIndex representing the raw image data contained in the file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DicomImage GetRawImage(
    int frameIndex
)
Public Function GetRawImage (
    frameIndex As Integer
) As DicomImage

Parameters

frameIndex
Type: SystemInt32
An integer greater than or equal to zero representing the index of the frame to load. FrameIndex must be less than the FrameCount property for the dataset.

Return Value

Type: DicomImage
A new DicomImage object representing the raw image data contained in the file.
See Also

Reference

DicomDataset Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.DicomDicomDecoder

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DicomDecoder : MultiFramedImageDecoder,
    IDisposable
Public Class DicomDecoder
    Inherits MultiFramedImageDecoder
    Implements IDisposable

The DicomDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | DicomDecoder | Initializes a new instance of the DicomDecoder class
Top
Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomDecoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomDecoder and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDefaultResolution |
Public method | GetFrameCount | Gets the number of images stored in a DICOM file. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Gets an ImageInfo object representing information about the first image in a DICOM file. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Gets an ImageInfo object representing information about a specific image in a DICOM file. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | This method will determine if a stream is DICOM file. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | This method will decode the first image from a DICOM file. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | This method will decode a single image from a DICOM file. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder Constructor

Initializes a new instance of the DicomDecoder class

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DicomDecoder()
Public Sub New
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder Properties

The DicomDecoder type exposes the following members.

Properties
 | Name | Description
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder Methods

The DicomDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDefaultResolution |
Public method | GetFrameCount | Gets the number of images stored in a DICOM file. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Gets an ImageInfo object representing information about the first image in a DICOM file. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Gets an ImageInfo object representing information about a specific image in a DICOM file. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | This method will determine if a stream is DICOM file. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | This method will decode the first image from a DICOM file. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | This method will decode a single image from a DICOM file. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.Dispose Method

DicomDecoderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomDecoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomDecoder and optionally releases the managed resources
Top
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.Dispose Method

DicomDecoderDispose Method

Releases all resources used by the DicomDecoder

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DicomDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.Dispose Method (Boolean)

DicomDecoderDispose Method (Boolean)

Releases the unmanaged resources used by the DicomDecoder and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

DicomDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.GetDefaultResolution Method

DicomDecoderGetDefaultResolution Method

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int GetDefaultResolution()
Protected Function GetDefaultResolution As Integer

Return Value

Type: Int32
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.GetFrameCount Method

DicomDecoderGetFrameCount Method

Gets the number of images stored in a DICOM file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
A stream to a DICOM file.

Return Value

Type: Int32
The number of images stored in the DICOM file.
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.GetImageInfo Method

DicomDecoderGetImageInfo Method

Gets an ImageInfo object representing information about a specific image in a DICOM file.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Gets an ImageInfo object representing information about the first image in a DICOM file. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Gets an ImageInfo object representing information about a specific image in a DICOM file. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.GetImageInfo Method (Stream)

DicomDecoderGetImageInfo Method (Stream)

Gets an ImageInfo object representing information about the first image in a DICOM file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream to a DICOM file.

Return Value

Type: ImageInfo
An ImageInfo object with the information about the first page in the file.
See Also

Reference

DicomDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.GetImageInfo Method (Stream, Int32)

DicomDecoderGetImageInfo Method (Stream, Int32)

Gets an ImageInfo object representing information about a specific image in a DICOM file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream to a DICOM file.
frameIndex
Type: SystemInt32
A zero based index for the page to get information about.

Return Value

Type: ImageInfo
An ImageInfo object with the information about the page in the file.
See Also

Reference

DicomDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.IsValidFormat Method

DicomDecoderIsValidFormat Method

This method will determine if a stream is DICOM file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The stream to read.

Return Value

Type: Boolean
True if the stream represents a valid DICOM file, false otherwise.
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.Read Method

DicomDecoderRead Method

This method will decode a single image from a DICOM file.
Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | This method will decode the first image from a DICOM file. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | This method will decode a single image from a DICOM file. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

DicomDecoder Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.Read Method (Stream, ProgressEventHandler)

DicomDecoderRead Method (Stream, ProgressEventHandler)

This method will decode the first image from a DICOM file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream representing a valid DICOM file.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the given page.
See Also

Reference

DicomDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomDecoder.Read Method (Stream, Int32, ProgressEventHandler)

DicomDecoderRead Method (Stream, Int32, ProgressEventHandler)

This method will decode a single image from a DICOM file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream representing a valid DICOM file.
frameIndex
Type: SystemInt32
The index of the image to decode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the given page.
See Also

Reference

DicomDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomGroup Enumeration

Represents a Group in the DICOM meta-data

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum DicomGroup
<FlagsAttribute>
Public Enumeration DicomGroup
Members
Member name | Description
Command |
Identifying |
Patient |
Acquisition |
Relationship |
ImagePresentation |
Text |
PixelData |
See Also

Reference

Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser Class

Use this class to read the meta-data from a DICOM encoded image
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.DicomDicomHeaderParser

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DicomHeaderParser : IDisposable
Public Class DicomHeaderParser
    Implements IDisposable

The DicomHeaderParser type exposes the following members.

Constructors
Name | Description
DicomHeaderParser | Construct a DicomHeaderParser object with a stream that is pointing to the beginning of a DICOM encoded image
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomHeaderParser
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomHeaderParser and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataType(UInt32, UInt32, DicomTag) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(UInt32, UInt32, UInt32) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(DicomGroup, UInt32, DicomTag) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(DicomGroup, UInt32, UInt32) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDouble(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a double
Public method | GetGroups |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSignedLong(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetString(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetTags(UInt32, UInt32) |
Public method | GetTags(DicomGroup, UInt32) | Get the tags of the meta-data given a group and order
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnicodeString(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnsignedLong(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as an unsigned long
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser Constructor

Construct a DicomHeaderParser object with a stream that is pointing to the beginning of a DICOM encoded image

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DicomHeaderParser(
    Stream s
)
Public Sub New (
    s As Stream
)

Parameters

s
Type: System.IOStream
A readable stream that is pointing to the beginning of a DICOM encoded image
Examples
Read data from header (C#)
Copy
using (FileStream fs = new FileStream("xray.dcm", FileMode.Open, FileAccess.Read, FileShare.Read))
{
   using (DicomHeaderParser parser = new DicomHeaderParser(fs))
   {
      String imageType = parser.GetString(DicomGroup.Identifying,
         0, DicomTag.IdentifyingImageType, 0);

      uint numFrames = parser.GetUnsignedLong(DicomGroup.ImagePresentation,
         0, DicomTag.ImagePresentationNumberOfFrames, 0), 0);
   }
}
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser Methods

The DicomHeaderParser type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataType(UInt32, UInt32, DicomTag) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(UInt32, UInt32, UInt32) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(DicomGroup, UInt32, DicomTag) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(DicomGroup, UInt32, UInt32) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDouble(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a double
Public method | GetGroups |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSignedLong(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetString(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetTags(UInt32, UInt32) |
Public method | GetTags(DicomGroup, UInt32) | Get the tags of the meta-data given a group and order
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnicodeString(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnsignedLong(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as an unsigned long
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.Dispose Method

DicomHeaderParserDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomHeaderParser
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomHeaderParser and optionally releases the managed resources
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.Dispose Method

DicomHeaderParserDispose Method

Releases all resources used by the DicomHeaderParser

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DicomHeaderParser Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.Dispose Method (Boolean)

DicomHeaderParserDispose Method (Boolean)

Releases the unmanaged resources used by the DicomHeaderParser and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

DicomHeaderParser Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDataType Method

DicomHeaderParserGetDataType Method

Returns the datatype of a meta-data value specified by the group, order and tag
Overload List
 | Name | Description
Public method | GetDataType(UInt32, UInt32, DicomTag) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(UInt32, UInt32, UInt32) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(DicomGroup, UInt32, DicomTag) | Returns the datatype of a meta-data value specified by the group, order and tag
Public method | GetDataType(DicomGroup, UInt32, UInt32) | Returns the datatype of a meta-data value specified by the group, order and tag
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDataType Method (UInt32, UInt32, DicomTag)

DicomHeaderParserGetDataType Method (UInt32, UInt32, DicomTag)

Returns the datatype of a meta-data value specified by the group, order and tag

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetDataType(
    uint groupId,
    uint order,
    DicomTag tagId
)
Public Function GetDataType (
    groupId As UInteger,
    order As UInteger,
    tagId As DicomTag
) As String

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetDataType Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDataType Method (UInt32, UInt32, UInt32)

DicomHeaderParserGetDataType Method (UInt32, UInt32, UInt32)

Returns the datatype of a meta-data value specified by the group, order and tag

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetDataType(
    uint groupId,
    uint order,
    uint tagId
)
Public Function GetDataType (
    groupId As UInteger,
    order As UInteger,
    tagId As UInteger
) As String

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetDataType Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDataType Method (DicomGroup, UInt32, DicomTag)

DicomHeaderParserGetDataType Method (DicomGroup, UInt32, DicomTag)

Returns the datatype of a meta-data value specified by the group, order and tag

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetDataType(
    DicomGroup groupId,
    uint order,
    DicomTag tagId
)
Public Function GetDataType (
    groupId As DicomGroup,
    order As UInteger,
    tagId As DicomTag
) As String

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetDataType Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDataType Method (DicomGroup, UInt32, UInt32)

DicomHeaderParserGetDataType Method (DicomGroup, UInt32, UInt32)

Returns the datatype of a meta-data value specified by the group, order and tag

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetDataType(
    DicomGroup groupId,
    uint order,
    uint tagId
)
Public Function GetDataType (
    groupId As DicomGroup,
    order As UInteger,
    tagId As UInteger
) As String

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetDataType Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDouble Method

DicomHeaderParserGetDouble Method

Gets the value of a meta-data value as a double
Overload List
 | Name | Description
Public method | GetDouble(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a double
Public method | GetDouble(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a double
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDouble Method (UInt32, UInt32, DicomTag, UInt32)

DicomHeaderParserGetDouble Method (UInt32, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a double

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetDouble(
    uint groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetDouble (
    groupId As UInteger,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As Double

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Double
See Also

Reference

DicomHeaderParser Class
GetDouble Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDouble Method (UInt32, UInt32, UInt32, UInt32)

DicomHeaderParserGetDouble Method (UInt32, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a double

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetDouble(
    uint groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetDouble (
    groupId As UInteger,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As Double

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Double
See Also

Reference

DicomHeaderParser Class
GetDouble Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDouble Method (DicomGroup, UInt32, DicomTag, UInt32)

DicomHeaderParserGetDouble Method (DicomGroup, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a double

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetDouble(
    DicomGroup groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetDouble (
    groupId As DicomGroup,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As Double

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Double
See Also

Reference

DicomHeaderParser Class
GetDouble Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetDouble Method (DicomGroup, UInt32, UInt32, UInt32)

DicomHeaderParserGetDouble Method (DicomGroup, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a double

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetDouble(
    DicomGroup groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetDouble (
    groupId As DicomGroup,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As Double

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Double
See Also

Reference

DicomHeaderParser Class
GetDouble Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetGroups Method

DicomHeaderParserGetGroups Method

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint[] GetGroups()
Public Function GetGroups As UInteger()

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetSignedLong Method

DicomHeaderParserGetSignedLong Method

Gets the value of a meta-data value as a signed long
Overload List
 | Name | Description
Public method | GetSignedLong(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a signed long
Public method | GetSignedLong(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a signed long
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetSignedLong Method (UInt32, UInt32, DicomTag, UInt32)

DicomHeaderParserGetSignedLong Method (UInt32, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a signed long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetSignedLong(
    uint groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetSignedLong (
    groupId As UInteger,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As Integer

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Int32
See Also

Reference

DicomHeaderParser Class
GetSignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetSignedLong Method (UInt32, UInt32, UInt32, UInt32)

DicomHeaderParserGetSignedLong Method (UInt32, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a signed long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetSignedLong(
    uint groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetSignedLong (
    groupId As UInteger,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As Integer

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Int32
See Also

Reference

DicomHeaderParser Class
GetSignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetSignedLong Method (DicomGroup, UInt32, DicomTag, UInt32)

DicomHeaderParserGetSignedLong Method (DicomGroup, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a signed long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetSignedLong(
    DicomGroup groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetSignedLong (
    groupId As DicomGroup,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As Integer

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Int32
See Also

Reference

DicomHeaderParser Class
GetSignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetSignedLong Method (DicomGroup, UInt32, UInt32, UInt32)

DicomHeaderParserGetSignedLong Method (DicomGroup, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a signed long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetSignedLong(
    DicomGroup groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetSignedLong (
    groupId As DicomGroup,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As Integer

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: Int32
See Also

Reference

DicomHeaderParser Class
GetSignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetString Method

DicomHeaderParserGetString Method

Gets the value of a meta-data value as a string
Overload List
 | Name | Description
Public method | GetString(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetString(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetString Method (UInt32, UInt32, DicomTag, UInt32)

DicomHeaderParserGetString Method (UInt32, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetString(
    uint groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetString (
    groupId As UInteger,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetString Method (UInt32, UInt32, UInt32, UInt32)

DicomHeaderParserGetString Method (UInt32, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetString(
    uint groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetString (
    groupId As UInteger,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetString Method (DicomGroup, UInt32, DicomTag, UInt32)

DicomHeaderParserGetString Method (DicomGroup, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetString(
    DicomGroup groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetString (
    groupId As DicomGroup,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetString Method (DicomGroup, UInt32, UInt32, UInt32)

DicomHeaderParserGetString Method (DicomGroup, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetString(
    DicomGroup groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetString (
    groupId As DicomGroup,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetTags Method

DicomHeaderParserGetTags Method

Overload List
 | Name | Description
Public method | GetTags(UInt32, UInt32) |
Public method | GetTags(DicomGroup, UInt32) | Get the tags of the meta-data given a group and order
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetTags Method (UInt32, UInt32)

DicomHeaderParserGetTags Method (UInt32, UInt32)

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint[] GetTags(
    uint groupId,
    uint order
)
Public Function GetTags (
    groupId As UInteger,
    order As UInteger
) As UInteger()

Parameters

groupId
Type: SystemUInt32
order
Type: SystemUInt32

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
GetTags Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetTags Method (DicomGroup, UInt32)

DicomHeaderParserGetTags Method (DicomGroup, UInt32)

Get the tags of the meta-data given a group and order

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint[] GetTags(
    DicomGroup groupId,
    uint order
)
Public Function GetTags (
    groupId As DicomGroup,
    order As UInteger
) As UInteger()

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
GetTags Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnicodeString Method

DicomHeaderParserGetUnicodeString Method

Gets the value of a meta-data value as a string
Overload List
 | Name | Description
Public method | GetUnicodeString(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as a string
Public method | GetUnicodeString(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as a string
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnicodeString Method (UInt32, UInt32, DicomTag, UInt32)

DicomHeaderParserGetUnicodeString Method (UInt32, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetUnicodeString(
    uint groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetUnicodeString (
    groupId As UInteger,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetUnicodeString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnicodeString Method (UInt32, UInt32, UInt32, UInt32)

DicomHeaderParserGetUnicodeString Method (UInt32, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetUnicodeString(
    uint groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetUnicodeString (
    groupId As UInteger,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetUnicodeString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnicodeString Method (DicomGroup, UInt32, DicomTag, UInt32)

DicomHeaderParserGetUnicodeString Method (DicomGroup, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetUnicodeString(
    DicomGroup groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetUnicodeString (
    groupId As DicomGroup,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetUnicodeString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnicodeString Method (DicomGroup, UInt32, UInt32, UInt32)

DicomHeaderParserGetUnicodeString Method (DicomGroup, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as a string

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetUnicodeString(
    DicomGroup groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetUnicodeString (
    groupId As DicomGroup,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As String

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: String
See Also

Reference

DicomHeaderParser Class
GetUnicodeString Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnsignedLong Method

DicomHeaderParserGetUnsignedLong Method

Gets the value of a meta-data value as an unsigned long
Overload List
 | Name | Description
Public method | GetUnsignedLong(UInt32, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(UInt32, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(DicomGroup, UInt32, DicomTag, UInt32) | Gets the value of a meta-data value as an unsigned long
Public method | GetUnsignedLong(DicomGroup, UInt32, UInt32, UInt32) | Gets the value of a meta-data value as an unsigned long
Top
See Also

Reference

DicomHeaderParser Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnsignedLong Method (UInt32, UInt32, DicomTag, UInt32)

DicomHeaderParserGetUnsignedLong Method (UInt32, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as an unsigned long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint GetUnsignedLong(
    uint groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetUnsignedLong (
    groupId As UInteger,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As UInteger

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
GetUnsignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnsignedLong Method (UInt32, UInt32, UInt32, UInt32)

DicomHeaderParserGetUnsignedLong Method (UInt32, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as an unsigned long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint GetUnsignedLong(
    uint groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetUnsignedLong (
    groupId As UInteger,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As UInteger

Parameters

groupId
Type: SystemUInt32
A UINT representing the group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
GetUnsignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnsignedLong Method (DicomGroup, UInt32, DicomTag, UInt32)

DicomHeaderParserGetUnsignedLong Method (DicomGroup, UInt32, DicomTag, UInt32)

Gets the value of a meta-data value as an unsigned long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint GetUnsignedLong(
    DicomGroup groupId,
    uint order,
    DicomTag tagId,
    uint elementNumber
)
Public Function GetUnsignedLong (
    groupId As DicomGroup,
    order As UInteger,
    tagId As DicomTag,
    elementNumber As UInteger
) As UInteger

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: Atalasoft.Imaging.Codec.DicomDicomTag
The tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
GetUnsignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomHeaderParser.GetUnsignedLong Method (DicomGroup, UInt32, UInt32, UInt32)

DicomHeaderParserGetUnsignedLong Method (DicomGroup, UInt32, UInt32, UInt32)

Gets the value of a meta-data value as an unsigned long

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint GetUnsignedLong(
    DicomGroup groupId,
    uint order,
    uint tagId,
    uint elementNumber
)
Public Function GetUnsignedLong (
    groupId As DicomGroup,
    order As UInteger,
    tagId As UInteger,
    elementNumber As UInteger
) As UInteger

Parameters

groupId
Type: Atalasoft.Imaging.Codec.DicomDicomGroup
The group of the meta-data value you are trying to access
order
Type: SystemUInt32
The order of the meta-data value you are trying to access
tagId
Type: SystemUInt32
A UINT representing the tag of the meta-data value you are trying to access
elementNumber
Type: SystemUInt32
The element number of the meta-data value you are trying to access

Return Value

Type: UInt32
See Also

Reference

DicomHeaderParser Class
GetUnsignedLong Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage Class

DicomImage is a representation of raw or processed DicomImage data. DicomImage is meant to be used by those who need to do efficient and repeated window and leveling processing of image data.

The DicomImage object implements the IDisposable interface because it contains system resources that need to be freed. It should be noted that all DicomImage objects should be disposed before an application exits. Failure to do so may cause the application to throw an exception.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.DicomDicomImage

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DicomImage : IDisposable
Public Class DicomImage
    Implements IDisposable

The DicomImage type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLeveling | An integer representing the default leveling as specified by the Dicom file.
Public property | DefaultWindow | An integer representing the default window center as specified by the Dicom file.
Public property | Height | The height of the DicomImage in pixels.
Public property | ImageCameFromSignedSamples | Indicates whether or not the image data came from signed samples.
Public property | ImageDataShiftedBy | An integer representing how the image samples were transformed if they had been signed.
Public property | PixelFormat | The PixelFormat of the image.
Public property | Width | The width of the image in pixels
Top
Methods
 | Name | Description
 | AllocateAtalaImage | Allocates an AtalaImage object into which this DicomImage could be transformed.
Public method | Dispose | Releases all resources used by the DicomImage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomImage and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAtalaImage | Transforms the DicomImage into a new AtalaImage object.
Public method | GetAtalaImage(AtalaImage) | Transforms the DicomImage into the supplied AtalaImage object.
Public method | GetAtalaImage(Int32, Int32) | Allocates a new AtalaImage object and transforms the DicomImage data into it using the window and leveling values.
Public method | GetAtalaImage(AtalaImage, Int32, Int32) | Transforms the DicomImage into the given AtalaImage, applying the window and leveling.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

DicomImage objects reflect a few of the internal quirks of the DicomStandard. Very often DicomImages have been stored with samples that were signed rather than unsigned data. It is necessary to know this information when applying window and leveling as it affects how the data is interpreted.

DicomImage objects cannot be constructed directly. Instead, DicomImage objects are constructed through the DicomDataset object via the Get...Image() methods. It should be noted that calling a Get...Image() method will make unique copies of each image and will consume a commensurate amount of memory.

If an image was built from signed samples, the property ImageCameFromSignedSamples will be true and the property ImageDataShiftedBy will be set to the value that was added to the samples to put them into the signed range. This value should be added to the window value before window and leveling is applied.

See Also

Reference

Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage Properties

The DicomImage type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLeveling | An integer representing the default leveling as specified by the Dicom file.
Public property | DefaultWindow | An integer representing the default window center as specified by the Dicom file.
Public property | Height | The height of the DicomImage in pixels.
Public property | ImageCameFromSignedSamples | Indicates whether or not the image data came from signed samples.
Public property | ImageDataShiftedBy | An integer representing how the image samples were transformed if they had been signed.
Public property | PixelFormat | The PixelFormat of the image.
Public property | Width | The width of the image in pixels
Top
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.DefaultLeveling Property

DicomImageDefaultLeveling Property

An integer representing the default leveling as specified by the Dicom file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DefaultLeveling { get; }
Public ReadOnly Property DefaultLeveling As Integer
    Get

Property Value

Type: Int32
Remarks
This is the value of the signed long tag 0x1051 in group 0x28 from the Dicom metadata.
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.DefaultWindow Property

DicomImageDefaultWindow Property

An integer representing the default window center as specified by the Dicom file.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DefaultWindow { get; }
Public ReadOnly Property DefaultWindow As Integer
    Get

Property Value

Type: Int32
Remarks

This is the value of the signed long tag 0x1050 in group 0x28 from the Dicom metadata.

In order to correctly apply this value, it might be necessary to add the property ImageDataShiftedBy to it if ImageCameFromSignedSamples is true.

See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.Height Property

DicomImageHeight Property

The height of the DicomImage in pixels.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.ImageCameFromSignedSamples Property

DicomImageImageCameFromSignedSamples Property

Indicates whether or not the image data came from signed samples.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ImageCameFromSignedSamples { get; }
Public ReadOnly Property ImageCameFromSignedSamples As Boolean
    Get

Property Value

Type: Boolean
Returns true if the image data came from signed samples in the file. If this value is true, then the property ImageDataShiftedBy is the amount added to the image data to make is unsigned samples. This value should be added to the window value before applying window and leveling.
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.ImageDataShiftedBy Property

DicomImageImageDataShiftedBy Property

An integer representing how the image samples were transformed if they had been signed.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ImageDataShiftedBy { get; }
Public ReadOnly Property ImageDataShiftedBy As Integer
    Get

Property Value

Type: Int32
A non-negative integer, 0 if ImageCameFromSignedSamples is false, a positive number otherwise.
Remarks
Image data in Dicom files may have been signed. This value represents how much the data had been shifted to normalize the samples to unsigned values. This value is useful if it is necessary to transform the samples back into signed samples. It should also be applied to a window before applying window and leveling.
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.PixelFormat Property

DicomImagePixelFormat Property

The PixelFormat of the image.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PixelFormat { get; }
Public ReadOnly Property PixelFormat As Integer
    Get

Property Value

Type: Int32
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.Width Property

DicomImageWidth Property

The width of the image in pixels

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage Methods

The DicomImage type exposes the following members.

Methods
 | Name | Description
 | AllocateAtalaImage | Allocates an AtalaImage object into which this DicomImage could be transformed.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAtalaImage | Transforms the DicomImage into a new AtalaImage object.
Public method | GetAtalaImage(AtalaImage) | Transforms the DicomImage into the supplied AtalaImage object.
Public method | GetAtalaImage(Int32, Int32) | Allocates a new AtalaImage object and transforms the DicomImage data into it using the window and leveling values.
Public method | GetAtalaImage(AtalaImage, Int32, Int32) | Transforms the DicomImage into the given AtalaImage, applying the window and leveling.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.AllocateAtalaImage Method

DicomImageAllocateAtalaImage Method

Allocates an AtalaImage object into which this DicomImage could be transformed.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage AllocateAtalaImage()
Public Function AllocateAtalaImage As AtalaImage

Return Value

Type: AtalaImage
A new AtalaImage that matches the correct size and PixelFormat appropriate for this DicomImage.
Examples
This method is useful for creating a single AtalaImage into which transforms of the DicomImage can be placed. For example, you might want to encode multiple transforms of a DicomImage into a TIFF file:
C# example
Copy
TiffEncoder encoder = new TiffEncoder();
encoder.Append = true;
// get dataset
using (var dataset = new DicomDataset(inputStream))
{
    // get modality transformed dicom image
    using (var dicomImage = dataset.GetModalityTransformedImage(0))
    {
        // make the AtalaImage
        var atalaImage = dicomImage.AllocateAtalaImage();
        for (int window = 0; window < 200; window += 10) {
            int normalizedWindow = window + dicomImage.DefaultWindow;
            if (dicomImage.ImageCameFromSignedSamples)
                normalizedWindow += dicomImage.ImageDataShiftedBy;
            // transform the dicom image into our AtalaImage
            dicomImage.GetAtalaImage(atalaImage, normalizedWindow, dicomImage.DefaultLeveling);
            // append to the tiff file
            encoder.Save(outputStream, atalaImage, null);
        }
        atalaImage.Dispose();
    }
}
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.Dispose Method

DicomImageDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the DicomImage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DicomImage and optionally releases the managed resources
Top
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.Dispose Method

DicomImageDispose Method

Releases all resources used by the DicomImage

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DicomImage Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.Dispose Method (Boolean)

DicomImageDispose Method (Boolean)

Releases the unmanaged resources used by the DicomImage and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

DicomImage Class
Dispose Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.GetAtalaImage Method

DicomImageGetAtalaImage Method

Transforms the DicomImage into a possible new AtalaImage.
Overload List
 | Name | Description
Public method | GetAtalaImage | Transforms the DicomImage into a new AtalaImage object.
Public method | GetAtalaImage(AtalaImage) | Transforms the DicomImage into the supplied AtalaImage object.
Public method | GetAtalaImage(Int32, Int32) | Allocates a new AtalaImage object and transforms the DicomImage data into it using the window and leveling values.
Public method | GetAtalaImage(AtalaImage, Int32, Int32) | Transforms the DicomImage into the given AtalaImage, applying the window and leveling.
Top
Remarks
The variants of this method that take an AtalaImage as an argument write directly into the AtalaImage. This will be more efficient that repeatedly allocating new AtalaImage objects if the transformations need to be done several times.
See Also

Reference

DicomImage Class
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.GetAtalaImage Method

DicomImageGetAtalaImage Method

Transforms the DicomImage into a new AtalaImage object.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetAtalaImage()
Public Function GetAtalaImage As AtalaImage

Return Value

Type: AtalaImage
Remarks
There is very little done to the image data as it is transformed into the AtalaImage. If the DicomImage came from DicomDataset.GetRawImage, the resulting AtalaImage will be as close to the actual raw data as possible. To get the actual raw values, it might be necessary to subtract out the property ImageDataShiftedBy from each sample in the AtalaImage if the property ImageCameFromSignedSamples is true.
See Also

Reference

DicomImage Class
GetAtalaImage Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.GetAtalaImage Method (AtalaImage)

DicomImageGetAtalaImage Method (AtalaImage)

Transforms the DicomImage into the supplied AtalaImage object.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetAtalaImage(
    AtalaImage image
)
Public Sub GetAtalaImage (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
A non-null AtalaImage into which the image data will be transformed. The image must match the Width, Height and PixelFormat properties of the DicomImage object.
Remarks
There is very little done to the image data as it is transformed into the AtalaImage. If the DicomImage came from DicomDataset.GetRawImage, the resulting AtalaImage will be as close to the actual raw data as possible. To get the actual raw values, it might be necessary to subtract out the property ImageDataShiftedBy from each sample in the AtalaImage if the property ImageCameFromSignedSamples is true.
See Also

Reference

DicomImage Class
GetAtalaImage Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.GetAtalaImage Method (Int32, Int32)

DicomImageGetAtalaImage Method (Int32, Int32)

Allocates a new AtalaImage object and transforms the DicomImage data into it using the window and leveling values.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetAtalaImage(
    int window,
    int leveling
)
Public Function GetAtalaImage (
    window As Integer,
    leveling As Integer
) As AtalaImage

Parameters

window
Type: SystemInt32
An integer representing the center point of the window.
leveling
Type: SystemInt32
An integer representing the size of the window.

Return Value

Type: AtalaImage
See Also

Reference

DicomImage Class
GetAtalaImage Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomImage.GetAtalaImage Method (AtalaImage, Int32, Int32)

DicomImageGetAtalaImage Method (AtalaImage, Int32, Int32)

Transforms the DicomImage into the given AtalaImage, applying the window and leveling.

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetAtalaImage(
    AtalaImage image,
    int window,
    int leveling
)
Public Sub GetAtalaImage (
    image As AtalaImage,
    window As Integer,
    leveling As Integer
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
A non-null AtalaImage into which the image data will be transformed. The image must match the Width, Height and PixelFormat properties of the DicomImage object.
window
Type: SystemInt32
An integer representing the center point of the window.
leveling
Type: SystemInt32
An integer representing the size of the window.
Remarks
If ImageCameFromSignedSamples is true, in most cases it is best to add ImageDataShiftedBy to the window value.
See Also

Reference

DicomImage Class
GetAtalaImage Overload
Atalasoft.Imaging.Codec.Dicom Namespace


DicomTag Enumeration

Represents a Tag in the DICOM meta-data

Namespace: Atalasoft.Imaging.Codec.Dicom
Assembly: Atalasoft.dotImage.Dicom (in Atalasoft.dotImage.Dicom.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum DicomTag
<FlagsAttribute>
Public Enumeration DicomTag
Members
Member name | Description
GroupLength |
GroupComments |
IdentifyingImageType |
IdentifyingRecognitionCode |
IdentifyingCreationDate |
IdentifyingCreationTime |
IdentifyingStudyDate |
IdentifyingSeriesDate |
IdentifyingAcquisitionDate |
IdentifyingImageDate |
IdentifyingStudyTime |
IdentifyingSeriesTime |
IdentifyingAcquisitionTime |
IdentifyingImageTime |
IdentifyingModality |
PatientName |
PatientID |
PatientBirthdate |
PatientSex |
PatientAge |
AcquisitionContrastBolusAgent |
AcquisitionRadionuclide |
AcquisitionSliceThickness |
AcquisitionKVP |
AcquisitionRepetitionTime |
AcquisitionEchoTime |
AcquisitionInversionTime |
AcquisitionGantryTilt |
RelationshipPositionReference |
RelationshipSliceLocation |
ImagePresentationNumberOfFrames |
ImagePresentationRows |
ImagePresentationColumns |
ImagePresentationPixelSize |
ImagePresentationBitsAllocated |
ImagePresentationBitsStored |
ImagePresentationHighBit |
ImagePresentationPixelRepresentation |
See Also

Reference

Atalasoft.Imaging.Codec.Dicom Namespace


Atalasoft.Imaging.Codec.Heif Namespace

Classes
 | Class | Description
Public class | HeifColorProfile | Describes HEIF color profile.
Public class | HeifDocument | Represents HEIF document and provides an access to a document's images and metadata.
Public class | HeifImage | Represents HEIF images.
Public class | HeifMetadata | Describes HEIF metadata.
Public class | NclxColorProfile | Describes NCLX color profile.
Public class | RawColorProfile | Describes raw color profile data.
Enumerations
 | Enumeration | Description
Public enumeration | heif_color_primaries | Represents color primaries values.
Public enumeration | heif_matrix_coefficients | Represents matrix coefficients for NCLX color profile.
Public enumeration | heif_transfer_characteristics | Transfer characteristics values.
Public enumeration | HeifColorProfileType | Describes supported color profiles.


heif_color_primaries Enumeration

Represents color primaries values.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum heif_color_primaries
Public Enumeration heif_color_primaries
Members
Member name | Description
heif_color_primaries_ITU_R_BT_709_5 | ITU-R BT.709-5.
heif_color_primaries_unspecified | Not specified.
heif_color_primaries_ITU_R_BT_470_6_System_M | ITU-R BT.470-6 System M.
heif_color_primaries_ITU_R_BT_470_6_System_B_G | ITU-R BT.470-6 System B or G.
heif_color_primaries_ITU_R_BT_601_6 | ITU-R BT.601-6.
heif_color_primaries_SMPTE_240M | SMPTE 240M.
heif_color_primaries_generic_film | Generic film.
heif_color_primaries_ITU_R_BT_2020_2_and_2100_0 | ITU-R BT.2020-2 and BT.2100-0.
heif_color_primaries_SMPTE_ST_428_1 | SMPTE ST 428-1.
heif_color_primaries_SMPTE_RP_431_2 | SMPTE RP 431-2.
heif_color_primaries_SMPTE_EG_432_1 | SMPTE EG 432-1.
heif_color_primaries_EBU_Tech_3213_E | EBU Tech. 3213-E.
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


heif_matrix_coefficients Enumeration

Represents matrix coefficients for NCLX color profile.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum heif_matrix_coefficients
Public Enumeration heif_matrix_coefficients
Members
Member name | Description
heif_matrix_coefficients_RGB_GBR | Order of coefficients is actually GBR.
heif_matrix_coefficients_ITU_R_BT_709_5 | ITU-R BT.709-5 coefficients.
heif_matrix_coefficients_unspecified | Coefficients not specified.
heif_matrix_coefficients_US_FCC_T47 | US FCC Title 47 coefficients.
heif_matrix_coefficients_ITU_R_BT_470_6_System_B_G | ITU-R BT.470-6 System B or G coefficients.
heif_matrix_coefficients_ITU_R_BT_601_6 | ITU-R BT.601-6 coefficients.
heif_matrix_coefficients_SMPTE_240M | SMPTE 240M coefficients.
heif_matrix_coefficients_YCgCo | YCgCo coefficients.
heif_matrix_coefficients_ITU_R_BT_2020_2_non_constant_luminance | ITU-R BT.2020-2 non constant luminance coefficients.
heif_matrix_coefficients_ITU_R_BT_2020_2_constant_luminance | ITU-R BT.2020-2 constant luminance coefficients.
heif_matrix_coefficients_SMPTE_ST_2085 | SMPTE ST 2085 coefficients.
heif_matrix_coefficients_chromaticity_derived_non_constant_luminance | Chromaticity derived non constant luminance coefficients.
heif_matrix_coefficients_chromaticity_derived_constant_luminance | Chromaticity derived constant luminance coefficients.
heif_matrix_coefficients_ICtCp | ICtCp coefficients.
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


heif_transfer_characteristics Enumeration

Transfer characteristics values.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum heif_transfer_characteristics
Public Enumeration heif_transfer_characteristics
Members
Member name | Description
heif_transfer_characteristic_ITU_R_BT_709_5 | ITU-R BT.709-1.
heif_transfer_characteristic_unspecified | Not specified.
heif_transfer_characteristic_ITU_R_BT_470_6_System_M | ITU-R BT.470-6 System M.
heif_transfer_characteristic_ITU_R_BT_470_6_System_B_G | ITU-R BT.470-6 System B or G.
heif_transfer_characteristic_ITU_R_BT_601_6 | ITU-R BT.601-6.
heif_transfer_characteristic_SMPTE_240M | SMPTE 240M.
heif_transfer_characteristic_linear | Linear.
heif_transfer_characteristic_logarithmic_100 | Logarithmic 100.
heif_transfer_characteristic_logarithmic_100_sqrt10 | Logarithmic 100 sqrt 10.
heif_transfer_characteristic_IEC_61966_2_4 | IEC 61966-2-4.
heif_transfer_characteristic_ITU_R_BT_1361 | ITU-R BT.1361.
heif_transfer_characteristic_IEC_61966_2_1 | IEC 61966-2-1.
heif_transfer_characteristic_ITU_R_BT_2020_2_10bit | ITU-R BT.2020-2 10bit.
heif_transfer_characteristic_ITU_R_BT_2020_2_12bit | ITU-R BT.2020-2 12bit.
heif_transfer_characteristic_ITU_R_BT_2100_0_PQ | ITU-R BT.2100-0 PQ.
heif_transfer_characteristic_SMPTE_ST_428_1 | SMPTE ST 428-1.
heif_transfer_characteristic_ITU_R_BT_2100_0_HLG | ITU-R BT.2100-0 HLG.
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


HeifColorProfile Class

Describes HEIF color profile.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.HeifHeifColorProfile
Atalasoft.Imaging.Codec.HeifNclxColorProfile
Atalasoft.Imaging.Codec.HeifRawColorProfile

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class HeifColorProfile
Public MustInherit Class HeifColorProfile

The HeifColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | Type | Gets HEIF color profile type name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


HeifColorProfile Properties

The HeifColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | Type | Gets HEIF color profile type name.
Top
See Also

Reference

HeifColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifColorProfile.Type Property

HeifColorProfileType Property

Gets HEIF color profile type name.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HeifColorProfileType Type { get; }
Public ReadOnly Property Type As HeifColorProfileType
    Get

Property Value

Type: HeifColorProfileType
See Also

Reference

HeifColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifColorProfile Methods

The HeifColorProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeifColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifColorProfileType Enumeration

Describes supported color profiles.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum HeifColorProfileType
Public Enumeration HeifColorProfileType
Members
Member name | Description
Nclx | NCLX color profile.
rICC | Restricted ICC profile.
ICC | Unrestricted ICC profile
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument Class

Represents HEIF document and provides an access to a document's images and metadata.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.HeifHeifDocument

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HeifDocument : IDisposable
Public Class HeifDocument
    Implements IDisposable

The HeifDocument type exposes the following members.

Properties
 | Name | Description
Public property | HeifImages | Gets collection of master images.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Performs resources disposing.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument Properties

The HeifDocument type exposes the following members.

Properties
 | Name | Description
Public property | HeifImages | Gets collection of master images.
Top
See Also

Reference

HeifDocument Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument.HeifImages Property

HeifDocumentHeifImages Property

Gets collection of master images.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<HeifImage> HeifImages { get; }
Public ReadOnly Property HeifImages As IList(Of HeifImage)
    Get

Property Value

Type: IListHeifImage
See Also

Reference

HeifDocument Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument Methods

The HeifDocument type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Performs resources disposing.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeifDocument Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument.Dispose Method

HeifDocumentDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Performs resources disposing.
Top
See Also

Reference

HeifDocument Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument.Dispose Method

HeifDocumentDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

HeifDocument Class
Dispose Overload
Atalasoft.Imaging.Codec.Heif Namespace


HeifDocument.Dispose Method (Boolean)

HeifDocumentDispose Method (Boolean)

Performs resources disposing.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether or not the method is called from Dispose method.
See Also

Reference

HeifDocument Class
Dispose Overload
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage Class

Represents HEIF images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.HeifHeifImage

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HeifImage
Public Class HeifImage

The HeifImage type exposes the following members.

Properties
 | Name | Description
Public property | AuxiliaryImages | Gets the list of associated auxiliary images.
Public property | ColorProfile | Gets associated color profile.
Public property | Height | Gets image height.
Public property | IsPrimary | Gets a value indicating whether the image is a primary HEIF image.
Public property | Metadata | Gets the list of associated metadata objects.
Public property | ThumbnailImages | Gets the list of associated thumbnail images.
Public property | Width | Gets image width.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Converts HEIF image into AtalaImage object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


HeifImage Properties

The HeifImage type exposes the following members.

Properties
 | Name | Description
Public property | AuxiliaryImages | Gets the list of associated auxiliary images.
Public property | ColorProfile | Gets associated color profile.
Public property | Height | Gets image height.
Public property | IsPrimary | Gets a value indicating whether the image is a primary HEIF image.
Public property | Metadata | Gets the list of associated metadata objects.
Public property | ThumbnailImages | Gets the list of associated thumbnail images.
Public property | Width | Gets image width.
Top
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.AuxiliaryImages Property

HeifImageAuxiliaryImages Property

Gets the list of associated auxiliary images.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<HeifImage> AuxiliaryImages { get; }
Public ReadOnly Property AuxiliaryImages As IList(Of HeifImage)
    Get

Property Value

Type: IListHeifImage
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.ColorProfile Property

HeifImageColorProfile Property

Gets associated color profile.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HeifColorProfile ColorProfile { get; }
Public ReadOnly Property ColorProfile As HeifColorProfile
    Get

Property Value

Type: HeifColorProfile
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.Height Property

HeifImageHeight Property

Gets image height.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.IsPrimary Property

HeifImageIsPrimary Property

Gets a value indicating whether the image is a primary HEIF image.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPrimary { get; }
Public ReadOnly Property IsPrimary As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.Metadata Property

HeifImageMetadata Property

Gets the list of associated metadata objects.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<HeifMetadata> Metadata { get; }
Public ReadOnly Property Metadata As IList(Of HeifMetadata)
    Get

Property Value

Type: IListHeifMetadata
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.ThumbnailImages Property

HeifImageThumbnailImages Property

Gets the list of associated thumbnail images.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<HeifImage> ThumbnailImages { get; }
Public ReadOnly Property ThumbnailImages As IList(Of HeifImage)
    Get

Property Value

Type: IListHeifImage
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.Width Property

HeifImageWidth Property

Gets image width.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage Methods

The HeifImage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Converts HEIF image into AtalaImage object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifImage.GetImage Method

HeifImageGetImage Method

Converts HEIF image into AtalaImage object.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetImage()
Public Function GetImage As AtalaImage

Return Value

Type: AtalaImage
Instance of AtalaImage class.
See Also

Reference

HeifImage Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata Class

Describes HEIF metadata.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.HeifHeifMetadata

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HeifMetadata
Public Class HeifMetadata

The HeifMetadata type exposes the following members.

Properties
 | Name | Description
Public property | ContentType | Gets the name of metadata content type.
Public property | Data | Gets metadata buffer.
Public property | Size | Gets metadata buffer size.
Public property | Type | Gets the name of metadata type.
Top
Methods
 | Name | Description
Public method | AsExifCollection | Converts metadata to ExifCollection object if possible.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata Properties

The HeifMetadata type exposes the following members.

Properties
 | Name | Description
Public property | ContentType | Gets the name of metadata content type.
Public property | Data | Gets metadata buffer.
Public property | Size | Gets metadata buffer size.
Public property | Type | Gets the name of metadata type.
Top
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata.ContentType Property

HeifMetadataContentType Property

Gets the name of metadata content type.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ContentType { get; }
Public ReadOnly Property ContentType As String
    Get

Property Value

Type: String
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata.Data Property

HeifMetadataData Property

Gets metadata buffer.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Data { get; }
Public ReadOnly Property Data As Byte()
    Get

Property Value

Type: Byte
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata.Size Property

HeifMetadataSize Property

Gets metadata buffer size.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get

Property Value

Type: Int32
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata.Type Property

HeifMetadataType Property

Gets the name of metadata type.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get

Property Value

Type: String
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata Methods

The HeifMetadata type exposes the following members.

Methods
 | Name | Description
Public method | AsExifCollection | Converts metadata to ExifCollection object if possible.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


HeifMetadata.AsExifCollection Method

HeifMetadataAsExifCollection Method

Converts metadata to ExifCollection object if possible.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifCollection AsExifCollection()
Public Function AsExifCollection As ExifCollection

Return Value

Type: ExifCollection
Object of ExifCollection if the metadata is of Exif type, otherwise .
See Also

Reference

HeifMetadata Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile Class

Describes NCLX color profile.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.HeifHeifColorProfile
Atalasoft.Imaging.Codec.HeifNclxColorProfile

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class NclxColorProfile : HeifColorProfile
Public Class NclxColorProfile
    Inherits HeifColorProfile

The NclxColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | ColorPrimaries | Gets color primaries.
Public property | ColorPrimaryBlueX | Gets primary blue X color value.
Public property | ColorPrimaryBlueY | Gets primary blue Y color value.
Public property | ColorPrimaryGreenX | Gets primary green X color value.
Public property | ColorPrimaryGreenY | Gets primary green Y color value.
Public property | ColorPrimaryRedX | Gets primary red X color value.
Public property | ColorPrimaryRedY | Gets primary red Y color value.
Public property | ColorPrimaryWhiteX | Gets primary white X color value.
Public property | ColorPrimaryWhiteY | Gets primary white Y color value.
Public property | FullRangeFlag | Gets full range flag.
Public property | MatrixCoefficients | Gets matrix coefficients.
Public property | TransferCharacteristics | Gets transfer characteristics.
Public property | Type | Gets HEIF color profile type name. (Inherited from HeifColorProfile.)
Public property | Version | Gets color profile version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile Properties

The NclxColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | ColorPrimaries | Gets color primaries.
Public property | ColorPrimaryBlueX | Gets primary blue X color value.
Public property | ColorPrimaryBlueY | Gets primary blue Y color value.
Public property | ColorPrimaryGreenX | Gets primary green X color value.
Public property | ColorPrimaryGreenY | Gets primary green Y color value.
Public property | ColorPrimaryRedX | Gets primary red X color value.
Public property | ColorPrimaryRedY | Gets primary red Y color value.
Public property | ColorPrimaryWhiteX | Gets primary white X color value.
Public property | ColorPrimaryWhiteY | Gets primary white Y color value.
Public property | FullRangeFlag | Gets full range flag.
Public property | MatrixCoefficients | Gets matrix coefficients.
Public property | TransferCharacteristics | Gets transfer characteristics.
Public property | Type | Gets HEIF color profile type name. (Inherited from HeifColorProfile.)
Public property | Version | Gets color profile version.
Top
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaries Property

NclxColorProfileColorPrimaries Property

Gets color primaries.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public heif_color_primaries ColorPrimaries { get; }
Public ReadOnly Property ColorPrimaries As heif_color_primaries
    Get

Property Value

Type: heif_color_primaries
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryBlueX Property

NclxColorProfileColorPrimaryBlueX Property

Gets primary blue X color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryBlueX { get; }
Public ReadOnly Property ColorPrimaryBlueX As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryBlueY Property

NclxColorProfileColorPrimaryBlueY Property

Gets primary blue Y color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryBlueY { get; }
Public ReadOnly Property ColorPrimaryBlueY As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryGreenX Property

NclxColorProfileColorPrimaryGreenX Property

Gets primary green X color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryGreenX { get; }
Public ReadOnly Property ColorPrimaryGreenX As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryGreenY Property

NclxColorProfileColorPrimaryGreenY Property

Gets primary green Y color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryGreenY { get; }
Public ReadOnly Property ColorPrimaryGreenY As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryRedX Property

NclxColorProfileColorPrimaryRedX Property

Gets primary red X color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryRedX { get; }
Public ReadOnly Property ColorPrimaryRedX As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryRedY Property

NclxColorProfileColorPrimaryRedY Property

Gets primary red Y color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryRedY { get; }
Public ReadOnly Property ColorPrimaryRedY As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryWhiteX Property

NclxColorProfileColorPrimaryWhiteX Property

Gets primary white X color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryWhiteX { get; }
Public ReadOnly Property ColorPrimaryWhiteX As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.ColorPrimaryWhiteY Property

NclxColorProfileColorPrimaryWhiteY Property

Gets primary white Y color value.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float ColorPrimaryWhiteY { get; }
Public ReadOnly Property ColorPrimaryWhiteY As Single
    Get

Property Value

Type: Single
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.FullRangeFlag Property

NclxColorProfileFullRangeFlag Property

Gets full range flag.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sbyte FullRangeFlag { get; }
Public ReadOnly Property FullRangeFlag As SByte
    Get

Property Value

Type: SByte
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.MatrixCoefficients Property

NclxColorProfileMatrixCoefficients Property

Gets matrix coefficients.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public heif_matrix_coefficients MatrixCoefficients { get; }
Public ReadOnly Property MatrixCoefficients As heif_matrix_coefficients
    Get

Property Value

Type: heif_matrix_coefficients
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.TransferCharacteristics Property

NclxColorProfileTransferCharacteristics Property

Gets transfer characteristics.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public heif_transfer_characteristics TransferCharacteristics { get; }
Public ReadOnly Property TransferCharacteristics As heif_transfer_characteristics
    Get

Property Value

Type: heif_transfer_characteristics
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile.Version Property

NclxColorProfileVersion Property

Gets color profile version.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sbyte Version { get; }
Public ReadOnly Property Version As SByte
    Get

Property Value

Type: SByte
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


NclxColorProfile Methods

The NclxColorProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NclxColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


RawColorProfile Class

Describes raw color profile data.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.HeifHeifColorProfile
Atalasoft.Imaging.Codec.HeifRawColorProfile

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RawColorProfile : HeifColorProfile
Public Class RawColorProfile
    Inherits HeifColorProfile

The RawColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | Data | Color profile data.
Public property | Type | Gets HEIF color profile type name. (Inherited from HeifColorProfile.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Heif Namespace


RawColorProfile Properties

The RawColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | Data | Color profile data.
Public property | Type | Gets HEIF color profile type name. (Inherited from HeifColorProfile.)
Top
See Also

Reference

RawColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


RawColorProfile.Data Property

RawColorProfileData Property

Color profile data.

Namespace: Atalasoft.Imaging.Codec.Heif
Assembly: Atalasoft.dotImage.Heif (in Atalasoft.dotImage.Heif.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Data { get; }
Public ReadOnly Property Data As Byte()
    Get

Property Value

Type: Byte
See Also

Reference

RawColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


RawColorProfile Methods

The RawColorProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RawColorProfile Class
Atalasoft.Imaging.Codec.Heif Namespace


Atalasoft.Imaging.Codec.Jbig2 Namespace

Classes
Class | Description
Jb2Decoder | The class derives from ImageDecoder and decodes JBIG2 images. Jb2Decoder may access to an existing JBIG2 file or JBIG2 embedded stream (StreamForPdf, refer to Jb2ExportFileFormat).
Jb2Encoder | This class, derived from MultiFramedImageEncoder, compresses a bi-tonal (black and white) image using JBIG2 compression.
Enumerations
 | Enumeration | Description
Public enumeration | Jb2EncodingMode | Property to set the mode to be used during encoding.
Public enumeration | Jb2ExportFormat | Compressed file format for exported documents.
Public enumeration | Jb2GenericBitmapCoder | Type to specify the bitmap coder to be used during compression.
Public enumeration | Jb2GenericTemplate | Context template to use when coding generic region using arithmetic coder.
Public enumeration | Jb2SymbolDictionary | Context template to use when coding dictionary symbols using arithmetic coder.
Public enumeration | Jb2SymbolTemplate | Template to use when encoding dictionary symbols using arithmetic coder.


Jb2Decoder Class

The class derives from ImageDecoder and decodes JBIG2 images. Jb2Decoder may access to an existing JBIG2 file or JBIG2 embedded stream (StreamForPdf, refer to Jb2ExportFileFormat).
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.Jbig2Jb2Decoder

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jb2Decoder : MultiFramedImageDecoder, IDisposable
Public Class Jb2Decoder
    Inherits MultiFramedImageDecoder
    Implements IDisposable

The Jb2Decoder type exposes the following members.

Constructors
 | Name | Description
Public method | Jb2Decoder | Creates a gcnew instance of a Jb2Decoder.
Top
Properties
 | Name | Description
Protected property | ScaleDownFactor |
Protected property | SpaceUpFactor |
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Jb2Decoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Jb2Decoder and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Returns information about a JBIG2 image such as width, height, and resolution. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about a JBIG2 image such as width, height, and resolution. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream is a JBIG2 image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(Stream, ProgressEventHandler) | Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
 | ReadRegion | Decodes a specified region of a JBIG2 image given a source Stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
To add the ability to decode JBIG2 images, simply add an instance of the Jb2Decoder to the DecoderDictionary collection in the RegisteredDecoders class. See the below example.
Examples
Jb2 decoder C# (C#)
Copy
using Atalasoft.Imaging.Codec.Jpeg2000;
...
Jp2Decoder jp2 = new Jp2Decoder();
RegisteredDecoders.Decoders.Add(jp2);
Jb2 Decoder VB (Visual Basic)
Copy
Imports Atalasoft.Imaging.Codec.Jpeg2000
...
Dim jp2 As Jp2Decoder = New Jp2Decoder()
RegisteredDecoders.Decoders.Add(jp2)
Jb2 Decoder C++ (CPP)
Copy
using namespace Atalasoft::Imaging::Codec;
...
Jb2Decoder jb2 = new Jb2Decoder();
RegisteredDecoders::Decoders::Add(jb2);
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder Constructor

Creates a gcnew instance of a Jb2Decoder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2Decoder()
Public Sub New
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder Properties

The Jb2Decoder type exposes the following members.

Properties
 | Name | Description
Protected property | ScaleDownFactor |
Protected property | SpaceUpFactor |
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.ScaleDownFactor Property

Jb2DecoderScaleDownFactor Property

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int ScaleDownFactor { get; }
Protected ReadOnly Property ScaleDownFactor As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.SpaceUpFactor Property

Jb2DecoderSpaceUpFactor Property

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int SpaceUpFactor { get; }
Protected ReadOnly Property SpaceUpFactor As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder Methods

The Jb2Decoder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Returns information about a JBIG2 image such as width, height, and resolution. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about a JBIG2 image such as width, height, and resolution. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream is a JBIG2 image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(Stream, ProgressEventHandler) | Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
 | ReadRegion | Decodes a specified region of a JBIG2 image given a source Stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.Dispose Method

Jb2DecoderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Jb2Decoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Jb2Decoder and optionally releases the managed resources
Top
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.Dispose Method

Jb2DecoderDispose Method

Releases all resources used by the Jb2Decoder

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Jb2Decoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.Dispose Method (Boolean)

Jb2DecoderDispose Method (Boolean)

Releases the unmanaged resources used by the Jb2Decoder and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Jb2Decoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.GetFrameCount Method

Jb2DecoderGetFrameCount Method

Returns the number of frames in the image

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
JBIG2 stream.

Return Value

Type: Int32
The number of pages in the JBIG2 stream.
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.GetImageInfo Method

Jb2DecoderGetImageInfo Method

Returns information about a JBIG2 image such as width, height, and resolution.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Returns information about a JBIG2 image such as width, height, and resolution. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about a JBIG2 image such as width, height, and resolution. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.GetImageInfo Method (Stream)

Jb2DecoderGetImageInfo Method (Stream)

Returns information about a JBIG2 image such as width, height, and resolution.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
JBIG2 stream.

Return Value

Type: ImageInfo
Returns ImageInfo of the first page of the given image.
See Also

Reference

Jb2Decoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.GetImageInfo Method (Stream, Int32)

Jb2DecoderGetImageInfo Method (Stream, Int32)

Returns information about a JBIG2 image such as width, height, and resolution.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
JBIG2 stream
frameIndex
Type: SystemInt32
zero based page index of multi-paged JBIG2 stream.

Return Value

Type: ImageInfo
Returns ImageInfo of the given page.
See Also

Reference

Jb2Decoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.IsValidFormat Method

Jb2DecoderIsValidFormat Method

Returns true if the specified Stream is a JBIG2 image.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The input stream.

Return Value

Type: Boolean
Returns true if the image is detected to be JBIG2, otherwise returns false.
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.Read Method

Jb2DecoderRead Method

Override methods from the MultiFramedImageDecoder class.
Overload List
 | Name | Description
 | Read(Stream, ProgressEventHandler) | Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.Read Method (Stream, ProgressEventHandler)

Jb2DecoderRead Method (Stream, ProgressEventHandler)

Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream to read.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB, 0 in C++) to ignore progress events.

Return Value

Type: AtalaImage
Returns an AtalaImage containing the decoded JBIG2 image.
Exceptions
Exception | Condition
 | Thrown if there is an error reading the image data.
Remarks
Overrides an abstract method in ImageDecoder.
Examples
decode single C# (C#)
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec.Jbig2;
...

FileStream fs = new FileStream(sourceFilename, FileMode.Open);
Jb2Decoder jb2d = new Jb2Decoder();
AtalaImage target = jb2d.Read(fs, null);
decode single C++ (CPP)
Copy
using namespace Atalasoft::Imaging;
using namespace Atalasoft::Imaging::Codec::Jbig2;
...

FileStream* fs = new FileStream(sourceFilename, FileMode::Open);
Jb2Decoder* jb2d = new Jb2Decoder();
AtalaImage* target = jb2d->Read(fs, i, 0);
decode single image VB (Visual Basic)
Copy
Imports Atalasoft.Imaging
Imports Atalasoft.Imaging.Codec.Jbig2
...

Dim fs As FileStream = New FileStream(sourceFilename, FileMode.Open)
Dim jb2d As Jb2Decoder = New Jb2Decoder()
Dim target As AtalaImage = jb2d.Read(fs, Nothing)
See Also

Reference

Jb2Decoder Class
Read Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.Read Method (Stream, Int32, ProgressEventHandler)

Jb2DecoderRead Method (Stream, Int32, ProgressEventHandler)

Decodes a JBIG2 image from a stream and returns an AtalaImage with the decoded image data.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream to read.
frameIndex
Type: SystemInt32
The zero based frame index.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB, 0 in C++) to ignore progress events.

Return Value

Type: AtalaImage
Returns an AtalaImage containing the decoded JBIG2 image.
Exceptions
Exception | Condition
 | Thrown if there is an error reading the image data.
Remarks
Overrides an abstract method in MultiFramedImageDecoder.
See Also

Reference

Jb2Decoder Class
Read Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Decoder.ReadRegion Method

Jb2DecoderReadRegion Method

Decodes a specified region of a JBIG2 image given a source Stream.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage ReadRegion(
    Stream stream,
    Rectangle region,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overridable Function ReadRegion (
    stream As Stream,
    region As Rectangle,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream to read.
region
Type: System.DrawingRectangle
A rectangular region of the image to decode.
frameIndex
Type: SystemInt32
The zero based frame index to load from a multi-page JBIG2 file.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB, 0 in C++) to ignore progress events.

Return Value

Type: AtalaImage
Returns an AtalaImage containing the decoded JBIG2 image.
Remarks
If rectangle region is not set, then the full region will be decoded.
Examples
region decoding C# (C#)
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec.Jbig2;
....
FileStream fs = new FileStream(sourceFilename, FileMode.Open);
Jb2Decoder jb2d = new Jb2Decoder();
// assume that region and frameindex are set
AtalaImage target = jb2d.ReadRegion(fs, region, frameIndex, null);
....
region decoding C++ (CPP)
Copy
using namespace Atalasoft::Imaging;
using namespace Atalasoft::Imaging::Codec::Jbig2;
....
FileStream* fs = new FileStream(sourceFilename, FileMode.Open);
Jb2Decoder* jb2d = new Jb2Decoder();
// assume that region and frameindex are set
AtalaImage* target = jb2d->ReadRegion(fs, region, frameIndex, null);
....
See Also

Reference

Jb2Decoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Class

This class, derived from MultiFramedImageEncoder, compresses a bi-tonal (black and white) image using JBIG2 compression.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecMultiFramedImageEncoder
Atalasoft.Imaging.Codec.Jbig2Jb2Encoder

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jb2Encoder : MultiFramedImageEncoder, IAppendable,
    IDisposable
Public Class Jb2Encoder
    Inherits MultiFramedImageEncoder
    Implements IAppendable, IDisposable

The Jb2Encoder type exposes the following members.

Constructors
 | Name | Description
Public method | Jb2Encoder | Creates a gcnew instance of a Jb2Encoder.
Public method | Jb2Encoder(Jb2EncodingMode) | Creates a gcnew instance of a Jb2Encoder.
Top
Properties
 | Name | Description
Public property | Append | Get or sets a value indicating if the image should be appended to the end of an existing file.
Public property | BitmapCoder | Gets or sets the bitmap coder to be used during compression.
 | EncodingMode | Gets or sets a value indicating if the encoded image will be lossless or lossy.
Public property | ExportFormat | Gets or sets a value indicating the file format for compressed data (JBIG2, PDF, or PDF Stream).
Public property | GenericTemplate | Gets or sets the context template to use when coding generic region using arithmetic coder.
Public property | SupportedPixelFormats | (Overrides ImageEncoderSupportedPixelFormats.)
Public property | SymbolDictionary | Gets or sets the context template to use when coding dictionary symbols using arithmetic coder.
Public property | SymbolTemplate | Gets or sets the template to use when coding dictionary symbols using arithmetic coder.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Jb2Encoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Jb2Encoder and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
 | Save(Stream, AtalaImage, ProgressEventHandler) | Compresses a single AtalaImage as a JBIG2 encoded file. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
 | Save(Stream, ImageCollection, ProgressEventHandler) | Compresses an ImageCollection as a JBIG2 encoded file. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Top
Examples
[New Example] (C#)
Copy
using Atalasoft.Imaging.Codec.Jbig2
...
AtalaImage image = new AtalaImage("image.tif");
image.Save("image.jb2", new Jbig2Encoder(Jb2EncodingMode.Lossy), null);
[New Example] (Visual Basic)
Copy
Imports Atalasoft.Imaging.Codec.Jbig2
...
Dim image As AtalaImage = New AtalaImage("image.tif")
image.Save("image.jb2", New Jbig2Encoder(Jb2EncodingMode.Lossy), Nothing)
[New Example] (CPP)
Copy
using namespace Atalasoft::Imaging::Codec::Jbig2;
...
AtalaImage* image = new AtalaImage(S"image.tif");
image->Save(S"image.jb2", new Jbig2Encoder(Jb2EncodingMode::Lossy), 0);
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Constructor

Creates a gcnew instance of a Jb2Encoder.
Overload List
 | Name | Description
Public method | Jb2Encoder | Creates a gcnew instance of a Jb2Encoder.
Public method | Jb2Encoder(Jb2EncodingMode) | Creates a gcnew instance of a Jb2Encoder.
Top
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Constructor

Creates a gcnew instance of a Jb2Encoder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2Encoder()
Public Sub New
See Also

Reference

Jb2Encoder Class
Jb2Encoder Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Constructor (Jb2EncodingMode)

Creates a gcnew instance of a Jb2Encoder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2Encoder(
    Jb2EncodingMode encodingMode
)
Public Sub New (
    encodingMode As Jb2EncodingMode
)

Parameters

encodingMode
Type: Atalasoft.Imaging.Codec.Jbig2Jb2EncodingMode
See Also

Reference

Jb2Encoder Class
Jb2Encoder Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Properties

The Jb2Encoder type exposes the following members.

Properties
 | Name | Description
Public property | Append | Get or sets a value indicating if the image should be appended to the end of an existing file.
Public property | BitmapCoder | Gets or sets the bitmap coder to be used during compression.
 | EncodingMode | Gets or sets a value indicating if the encoded image will be lossless or lossy.
Public property | ExportFormat | Gets or sets a value indicating the file format for compressed data (JBIG2, PDF, or PDF Stream).
Public property | GenericTemplate | Gets or sets the context template to use when coding generic region using arithmetic coder.
Public property | SupportedPixelFormats | (Overrides ImageEncoderSupportedPixelFormats.)
Public property | SymbolDictionary | Gets or sets the context template to use when coding dictionary symbols using arithmetic coder.
Public property | SymbolTemplate | Gets or sets the template to use when coding dictionary symbols using arithmetic coder.
Top
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Append Property

Jb2EncoderAppend Property

Get or sets a value indicating if the image should be appended to the end of an existing file.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Append { get; set; }
Public Overridable Property Append As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IAppendableAppend
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.BitmapCoder Property

Jb2EncoderBitmapCoder Property

Gets or sets the bitmap coder to be used during compression.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2GenericBitmapCoder BitmapCoder { get; set; }
Public Property BitmapCoder As Jb2GenericBitmapCoder
    Get
    Set

Property Value

Type: Jb2GenericBitmapCoder
Remarks
Arithmetic is slower than Mmr but offers higher compression. Default is Arithmetic.
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.EncodingMode Property

Jb2EncoderEncodingMode Property

Gets or sets a value indicating if the encoded image will be lossless or lossy.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2EncodingMode EncodingMode { get; set; }
Public Property EncodingMode As Jb2EncodingMode
    Get
    Set

Property Value

Type: Jb2EncodingMode
Remarks
Lossy encoding is only possible with symbol dictionary and symbol matching. Default is lossless.
Examples
Adding EncodingMode to Jb2Encoder (C#)
Copy
Jb2Encoder jb2 = new Jb2Encoder();
jb2.EncodingMode = Jb2EncodingMode.Lossless;
Adding EncodingMode C++ (CPP)
Copy
Jb2Encoder* jb2 = new Jb2Encoder();
jb2->EncodingMode = Jb2EncodingMode::Lossless;
[New Example] (Visual Basic)
Copy
Dim jb2 As Jb2Encoder = New Jb2Encoder()
jb2.EncodingMode = Jb2EncodingMode.Lossless
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.ExportFormat Property

Jb2EncoderExportFormat Property

Gets or sets a value indicating the file format for compressed data (JBIG2, PDF, or PDF Stream).

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2ExportFormat ExportFormat { get; set; }
Public Property ExportFormat As Jb2ExportFormat
    Get
    Set

Property Value

Type: Jb2ExportFormat
Remarks
StreamForPDF is only supported when exporting single page documents. Both Jb2 and Pdf can be used when exporting multi-page document. Refer to the PDF documentation from Adobe for full details on embedding a JBIG2 image in a PDF document. Default is Jb2.
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.GenericTemplate Property

Jb2EncoderGenericTemplate Property

Gets or sets the context template to use when coding generic region using arithmetic coder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2GenericTemplate GenericTemplate { get; set; }
Public Property GenericTemplate As Jb2GenericTemplate
    Get
    Set

Property Value

Type: Jb2GenericTemplate
Remarks
Default is ThreeLine16Pixels
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.SupportedPixelFormats Property

Jb2EncoderSupportedPixelFormats Property

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.SymbolDictionary Property

Jb2EncoderSymbolDictionary Property

Gets or sets the context template to use when coding dictionary symbols using arithmetic coder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2SymbolDictionary SymbolDictionary { get; set; }
Public Property SymbolDictionary As Jb2SymbolDictionary
    Get
    Set

Property Value

Type: Jb2SymbolDictionary
Remarks
Default is Use.
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.SymbolTemplate Property

Jb2EncoderSymbolTemplate Property

Gets or sets the template to use when coding dictionary symbols using arithmetic coder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jb2SymbolTemplate SymbolTemplate { get; set; }
Public Property SymbolTemplate As Jb2SymbolTemplate
    Get
    Set

Property Value

Type: Jb2SymbolTemplate
Remarks
Default is 3 line, 16 pixel context.
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Methods

The Jb2Encoder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
 | Save(Stream, AtalaImage, ProgressEventHandler) | Compresses a single AtalaImage as a JBIG2 encoded file. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
 | Save(Stream, ImageCollection, ProgressEventHandler) | Compresses an ImageCollection as a JBIG2 encoded file. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Dispose Method

Jb2EncoderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Jb2Encoder
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Jb2Encoder and optionally releases the managed resources
Top
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Dispose Method

Jb2EncoderDispose Method

Releases all resources used by the Jb2Encoder

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Jb2Encoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Dispose Method (Boolean)

Jb2EncoderDispose Method (Boolean)

Releases the unmanaged resources used by the Jb2Encoder and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Jb2Encoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Save Method

Jb2EncoderSave Method

Overrided the MultiFramedImageEncoder class.
Overload List
 | Name | Description
 | Save(Stream, AtalaImage, ProgressEventHandler) | Compresses a single AtalaImage as a JBIG2 encoded file. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
 | Save(Stream, ImageCollection, ProgressEventHandler) | Compresses an ImageCollection as a JBIG2 encoded file. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Top
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Save Method (Stream, AtalaImage, ProgressEventHandler)

Jb2EncoderSave Method (Stream, AtalaImage, ProgressEventHandler)

Compresses a single AtalaImage as a JBIG2 encoded file.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The input stream.
image
Type: Atalasoft.ImagingAtalaImage
AtalaImage to be written as JBIG2, PDF or embedded stream to PDF.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB, 0 in C++) to ignore progress events.

Return Value

Type: Int64
Returns the number of bytes encoded.
Exceptions
Exception | Condition
ImageWriteException | Thrown if there is an error when compressing the image data.
IncompatiblePixelFormatException | Thrown if the source image is not 1-bit.
ArgumentException | Thrown if Lossy compression is not used with symbols.
Remarks
To append to an existing image, set Append to true.
Examples
Save single C# (C#)
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec.Jbig2;
...

// example of encoding a single image
FileStream fs = new FileStream(targetFileName, FileMode.Create);
AtalaImage image = new AtalaImage(sourceFilename);
Jb2Encoder jb2e = new Jb2Encoder();
jb2e.ExportFormat = Jb2ExportFormat.Jb2;
jb2e.Save(fs, image, null);
Save single C++ (CPP)
Copy
using namespace Atalasoft::Imaging;
using namespace Atalasoft::Imaging::Codec::Jbig2;
...

// example of encoding a single page image
FileStream* fs = new FileStream(targetFilename, FileMode::Create);
AtalaImage* image = new AtalaImage(sourcefilename);
Jb2Encoder* jb2e = new Jb2Encoder();
jb2e->ExportFormat = Jb2ExportFormat::Jb2;
jb2e->Save(fs, image, null);
Save Single VB (Visual Basic)
Copy
Imports Atalasoft.Imaging
Imports Atalasoft.Imaging.Codec.Jbig2
...

' example of encoding a Single image
Dim fs As FileStream = New FileStream(targetFileName, FileMode.Create)
Dim image As AtalaImage = New AtalaImage(sourceFilename)
Dim jb2e As Jb2Encoder = New Jb2Encoder()
jb2e.ExportFormat = Jb2ExportFormat.Jb2
jb2e.Save(fs, image, null)
See Also

Reference

Jb2Encoder Class
Save Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Save Method (Stream, ImageCollection, ProgressEventHandler)

Jb2EncoderSave Method (Stream, ImageCollection, ProgressEventHandler)

Compresses an ImageCollection as a JBIG2 encoded file.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    ImageCollection images,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    images As ImageCollection,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The input stream.
images
Type: Atalasoft.ImagingImageCollection
AtalaImage to be written as JBIG2, PDF or embedded stream to PDF.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB, 0 in C++) to ignore progress events.

Return Value

Type: Int64
Returns the number of bytes encoded.
Exceptions
Exception | Condition
 | Thrown if there is an error when compressing the image data.
 | Thrown if the source image is not 1-bit.
 | Thrown if Lossy compression is not used with symbols.
Remarks
To append to an existing image, set Append to true and save using the Save overload that takes an AtalaImage.
Examples
Save Multi C# (C#)
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec.Jbig2;
...

// example of encoding a multi-page image
FileStream fs = new FileStream(targetFilename, FileMode.Create);
ImageCollection image = new ImageCollection(sourceFilename, null);
Jb2Encoder jb2e = new Jb2Encoder();
jb2e.ExportFormat = Jb2ExportFormat.Jb2;
jb2e.Save(fs, image, null);
Save Multi C++ (CPP)
Copy
using namespace Atalasoft::Imaging;
using namespace Atalasoft::Imaging::Codec::Jbig2;
...

// example of encoding a multi-page image
FileStream* fs = new FileStream(targetFilename,FileMode::Create);
ImageCollection* image = new ImageCollection(sourceFilename, 0);
Jb2e* jb2Encoder = new Jb2Encoder();
jb2e->ExportFormat = Jb2ExportFormat::Jb2;
jb2e->Save(fs, image, 0);
Save Multi VB (Visual Basic)
Copy
Imports Atalasoft.Imaging
Imports Atalasoft.Imaging.Codec.Jbig2
...

' example of encoding a multi-page image
Dim fs As FileStream = New FileStream(targetFilename, FileMode.Create)
Dim image As ImageCollection = New ImageCollection(sourceFilename, null)
Dim jb2e As Jb2Encoder = New Jb2Encoder()
jb2e.ExportFormat = Jb2ExportFormat.Jb2
jb2e.Save(fs, image, null)
See Also

Reference

Jb2Encoder Class
Save Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder.Save Method (Stream, ImageSource, ProgressEventHandler)

Jb2EncoderSave Method (Stream, ImageSource, ProgressEventHandler)

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    ImageSource imgSrc,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    imgSrc As ImageSource,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
imgSrc
Type: Atalasoft.ImagingImageSource
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: Int64
See Also

Reference

Jb2Encoder Class
Save Overload
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2Encoder Events

The Jb2Encoder type exposes the following members.

Events
 | Name | Description
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Top
See Also

Reference

Jb2Encoder Class
Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2EncodingMode Enumeration

Property to set the mode to be used during encoding.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jb2EncodingMode
Public Enumeration Jb2EncodingMode
Members
Member name | Description
Lossless | Lossless encoding
Lossy | Lossy encoding
Remarks
Lossy encoding is only possible with symbol dictionary and symbol matching. Default is Lossless.
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2ExportFormat Enumeration

Compressed file format for exported documents.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jb2ExportFormat
Public Enumeration Jb2ExportFormat
Members
Member name | Description
Jb2 | JBIG2 file format as described in ISO.
Pdf | JBIG2 embedded in a PDF file.
StreamForPdf | JBIG2 stream suitable for embedding in a PDF file.
Remarks
StreamForPDF is only supported when exporting single page documents. Both Jb2 and Pdf can be used when exporting multi-page documents. Refer to the PDF documentation from Adobe for full details on embedding a JBIG2 image in a PDF document.
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2GenericBitmapCoder Enumeration

Type to specify the bitmap coder to be used during compression.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jb2GenericBitmapCoder
Public Enumeration Jb2GenericBitmapCoder
Members
Member name | Description
Mmr | Simple, fast run-length based coder
Arithmetic | Efficient arithmetic coder
Remarks
The default is Arithmetic.
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2GenericTemplate Enumeration

Context template to use when coding generic region using arithmetic coder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jb2GenericTemplate
Public Enumeration Jb2GenericTemplate
Members
Member name | Description
ThreeLine16Pixel |
ThreeLine13Pixel |
ThreeLine10Pixel |
TwoLine10Pixel |
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2SymbolDictionary Enumeration

Context template to use when coding dictionary symbols using arithmetic coder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jb2SymbolDictionary
Public Enumeration Jb2SymbolDictionary
Members
Member name | Description
NotUse | Do not use symbol dictionary with symbol matching.
Use | Use symbol dictionary with symbol matching.
Remarks
Property to specify whether symbol dictionary and symbol matching should be used during compression symbol dictionary usage may slow down compression but offers higher compression rates and is essential for lossy encoding. Default is Use.
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Jb2SymbolTemplate Enumeration

Template to use when encoding dictionary symbols using arithmetic coder.

Namespace: Atalasoft.Imaging.Codec.Jbig2
Assembly: Atalasoft.dotImage.Jbig2 (in Atalasoft.dotImage.Jbig2.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jb2SymbolTemplate
Public Enumeration Jb2SymbolTemplate
Members
Member name | Description
ThreeLine16Pixel | 3 line, 16 pixel context.
ThreeLine13Pixel | 3 line, 13 pixel context.
Remarks
Default is ThreeLine13Pixel.
See Also

Reference

Atalasoft.Imaging.Codec.Jbig2 Namespace


Atalasoft.Imaging.Codec.Jpeg2000 Namespace

Classes
 | Class | Description
 | Jp2Decoder | The class derives from ImageDecoder and decodes JPEG2000 images.
Public class | Jp2Encoder | Obsolete. The class derived from ImageEncoder that encodes JPEG2000 images.
Public class | Jp2EncoderOptions | This class specifies encoder options that can be applied to the entire image, a specific tile, or a specific component.
Public class | Jp2EnhancedRegion | Region of interest in the JPEG2000 standard
Public class | Jp2EnhancedRegionCollection | Regions of interest which shall be compressed at a different quality than the rest of the image.
Public class | Jp2ImageInfo | This class derives from ImageInfo, and contains information about the JPEG2000 image such as width, height, and colordepth.
Public class | Jp2IptcParser | This class parses IPTC data from an image stream, adds JPEG2000 to the supported image formats for IPTC parsing.
Public class | Jp2License | Class that allows assembly tied embedded component licensing.
Public class | Jp2Palette |
Public class | Jp2ResolutionParams | Resolution structure for DPI information. Note that resolution information may only be stored in Jp2 file format images. Plain codestream format images can not store resolution information. The image resolution is calculated by: [DPM] = ( xNum / xDenom ) * 10 ^ xExp
Public class | Jp2XmlParser |
Public class | Jpeg2000Encoder | The class derived from ImageEncoder that encodes JPEG2000 images.
Public class | Jpeg2000EncoderOptions | This class specifies encoder options that can be applied to the entire image, a specific tile, or a specific component.
Public class | ProgressiveImageEventArgs | This class contains information when a [!:E:Atalasoft.Imaging.Codec.Jpeg2000.Jp2Decoder.ProgressiveImage] event is fired.
Public class | UuidBox | A UUID box contains vendor specific data other than that data defined within International Standard. There may be multiple UUID boxes within the file
Public class | UuidBoxCollection | This class contains a collection of UuidBox objects.
Public class | UuidBoxParser | This class parses UUID information from JPEG2000 images.
Public class | UuidInfoBox | This class contains a UUID Info Box, as defined in the JPEG2000 specification.
Public class | UuidInfoBoxCollection | This class holds a collection of UuidInfoBox objects
Public class | UuidInfoBoxParser | This class will parse a JPEG2000 image stream for UuidInfoBoxes
Public class | UuidUrlBox | This class contains URL UUID information.
Delegates
 | Delegate | Description
Public delegate | Jp2EncoderOptionsCallback |
Public delegate | Jpeg2000EncoderOptionsCallback |
Public delegate | ProgressiveImageEventHandler | Delegate that handles Progressive Reading.
Enumerations
 | Enumeration | Description
Public enumeration | Jp2ByteOrder | Byte order for input/output of image data.
Public enumeration | Jp2CacheOption | Decompression internal read cache usage.
Public enumeration | Jp2CoderOptions | Coder option bit masks. Flagged.
Public enumeration | Jp2CompressionMode | Two compression modes are supported: using compression rates (CompressionSize) and quality (only when the 9-7 filter is used)
Public enumeration | Jp2FileFormat | Available JPEG2000 codestreams
Public enumeration | Jp2LicenseEdition |
Public enumeration | Jp2PacketMarkers | Error recovery markers in bit stream. Flagged
Public enumeration | Jp2Precision | Wavelet Precision
Public enumeration | Jp2ProgressionOrder | For a given tile, the packets contain data from a specific component, a specific resolution, and a specific precinct. The order in which these packets are interleaved is called the progression order. The interleaving of the packets can progress along four axes: layer (L), component (C), resolution (R) and precinct (P).
Public enumeration | Jp2QualityStyle | Quality styles are used to set the quality mode to be used during lossy compression. The quality may be optimized for PSNR or for visual quality.
Public enumeration | Jp2QuantizationStyle | Obsolete. The quantization steps can either be derived from a base quantization step, Derived, or calculated for each image sub-band, Expounded.
Public enumeration | Jp2ResolutionTypes |
Public enumeration | Jp2ResolutionUnits |
Public enumeration | Jp2SpeedMode | Values for setting the encoding speed.
Public enumeration | Jp2WaveletFilter | Obsolete. Wavelet filtering method.
Public enumeration | JPEG2000QuantizationStyle | The quantization steps can either be derived from a base quantization step, Derived, or calculated for each image sub-band, Expounded.
Public enumeration | JPEG2000WaveletFilter | Wavelet filtering method.
Public enumeration | JpxStandardFeatures | Standard Reader Requirement Features


Jp2ByteOrder Enumeration

Byte order for input/output of image data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2ByteOrder
Public Enumeration Jp2ByteOrder
Members
Member name | Description
EndianLittle | little endian
EndianBig | big endian
MachineNative | machine native order. default
Remarks
Default is MachineNative order.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2CacheOption Enumeration

Decompression internal read cache usage.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2CacheOption
Public Enumeration Jp2CacheOption
Members
Member name | Description
UseInternalCache | Compressed data should be stored in internal cache. default.
NoInternalCache | Do not use internal cache.
Remarks
This property specifies whether the compressed data should be stored in an internal cache. Default is UseInternalCache.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace
CacheOption Property


Jp2CoderOptions Enumeration

Coder option bit masks. Flagged.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum Jp2CoderOptions
<FlagsAttribute>
Public Enumeration Jp2CoderOptions
Members
Member name | Description
None |
ContextReset |
AllPassTerminate | Only for decompression
VerticalCausalContext |
Predictable |
SegmentationSymbols |
Remarks
These options may be combined to create error resilent Jpeg2000 streams or for special codecs (e.g. hardware coder) for a faster compression/decompression. These option wil increases the file size slightly when generating a code stream with the same image quality.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2CompressionMode Enumeration

Two compression modes are supported: using compression rates (CompressionSize) and quality (only when the 9-7 filter is used)

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2CompressionMode
Public Enumeration Jp2CompressionMode
Members
Member name | Description
Size | The maximum file size for lossy compression can be set. For rate 1:n, size = width * height * channels * bits_per_channel / 8 / n
Quality | Compression to a particular quality is possible only when using 9-7 filter and expounded quantization. A compression quality may be specified between 1 (low) and 100 (high). The size of reaulting Jpeg2000 file will depend of the image content.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder Class

The class derives from ImageDecoder and decodes JPEG2000 images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.Codec.Jpeg2000Jp2Decoder

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2Decoder : ImageDecoder
Public Class Jp2Decoder
    Inherits ImageDecoder

The Jp2Decoder type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2Decoder | Creates a new instance of a Jp2Decoder.
Top
Properties
 | Name | Description
Public property | ByteOrder | Gets or sets the byte order of the decoded data from one of little endian, big endian, or machine automatic.
Public property | CacheOption | Gets or sets a value specifying whether the compress data should be stored in an internal cache.
Public property | EnableProgressiveDecompression | Gets or sets a value enabling the ability to progressively decode the image.
Public property | Precision | Gets or sets a value indicating the precision of the wavelet coefficients.
Public property | ProgressiveDecodeSteps | Gets or sets the number of progressive decompression steps.
Public property | ScaleDown | Gets or sets a factor that is used to scale downwards the image as it's decoded.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Returns information about a JPEG2000 image such as width, height, and bit depth. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream is a JPEG2000 image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NetworkRead |
Protected method | NormalRead |
Protected method | ProgressiveRead |
Public method | Read | Decodes a JPEG2000 image from a stream and returns an AtalaImage with the decoded image data. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ProgressiveImage | Fired for each intermediate step when decoding an image progressively.
Top
Remarks
To add the ability to decode JP2 images, simply add an instance of the Jp2Decoder to the DecoderDictionary collection in the RegisteredDecoders class. See the below example.
Examples
Usage example (VB)
Copy
Imports Atalasoft.Imaging.Codec.Jpeg2000
...
Dim jp2 As Jp2Decoder = New Jp2Decoder()
RegisteredDecoders.Decoders.Add(jp2)
Usage example (C#)
Copy
using Atalasoft.Imaging.Codec.Jpeg2000;
...
Jp2Decoder jp2 = new Jp2Decoder();
RegisteredDecoders.Decoders.Add(jp2);
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder Constructor

Creates a new instance of a Jp2Decoder.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Decoder()
Public Sub New
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder Properties

The Jp2Decoder type exposes the following members.

Properties
 | Name | Description
Public property | ByteOrder | Gets or sets the byte order of the decoded data from one of little endian, big endian, or machine automatic.
Public property | CacheOption | Gets or sets a value specifying whether the compress data should be stored in an internal cache.
Public property | EnableProgressiveDecompression | Gets or sets a value enabling the ability to progressively decode the image.
Public property | Precision | Gets or sets a value indicating the precision of the wavelet coefficients.
Public property | ProgressiveDecodeSteps | Gets or sets the number of progressive decompression steps.
Public property | ScaleDown | Gets or sets a factor that is used to scale downwards the image as it's decoded.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.ByteOrder Property

Jp2DecoderByteOrder Property

Gets or sets the byte order of the decoded data from one of little endian, big endian, or machine automatic.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ByteOrder ByteOrder { get; set; }
Public Property ByteOrder As Jp2ByteOrder
    Get
    Set

Property Value

Type: Jp2ByteOrder
Remarks
Default value is Jp2ByteOrder.MachineNative.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.CacheOption Property

Jp2DecoderCacheOption Property

Gets or sets a value specifying whether the compress data should be stored in an internal cache.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2CacheOption CacheOption { get; set; }
Public Property CacheOption As Jp2CacheOption
    Get
    Set

Property Value

Type: Jp2CacheOption
Remarks
The default value is Jp2CacheOption.UseInternalCache.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.EnableProgressiveDecompression Property

Jp2DecoderEnableProgressiveDecompression Property

Gets or sets a value enabling the ability to progressively decode the image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableProgressiveDecompression { get; set; }
Public Property EnableProgressiveDecompression As Boolean
    Get
    Set

Property Value

Type: Boolean
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if using the Standard edition.
Remarks
The default value is false. This setting when true causes the Decoder to raise the ProgressiveImage event. That event can be handled to display the image at intervals defined in the ProgressiveDecodeSteps property. Enabling progressive decoding does reduce performance, and is best suited for very large images, or streaming images over a network stream.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace
ProgressiveDecodeSteps Property


Jp2Decoder.Precision Property

Jp2DecoderPrecision Property

Gets or sets a value indicating the precision of the wavelet coefficients.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Precision Precision { get; set; }
Public Property Precision As Jp2Precision
    Get
    Set

Property Value

Type: Jp2Precision
Remarks
Default value is Jp2Precision.Automatic. For improved efficiency, the library automatically, depending on the image depth, uses either 16 or 32 bit representation for wavelet coefficients. The use of 32 bit values may slightly improve image quality and the expense of speed and memory requirements.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.ProgressiveDecodeSteps Property

Jp2DecoderProgressiveDecodeSteps Property

Gets or sets the number of progressive decompression steps.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ProgressiveDecodeSteps { get; set; }
Public Property ProgressiveDecodeSteps As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if set to a value less than 1.
Remarks

The default value is 16. Depending on [!:Jpeg2000EncoderOptions::ProgressionOrder] in the [!:Atalasoft::Imaging::Codec::Jpeg2000::Jp2Encoder::EncoderOptions] property of the encoded source image, progressive output images will update either linearly (for PCRL, CPRL) or exponentially (otherwise). ProgressiveDecodeSteps must be greater than 0. Be aware that the number of useful steps is related to the image dimensions and component size. Large numbers of steps add little benefit to smaller images.

See EnableProgressiveDecompression for enabling progressive reading.

See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.ScaleDown Property

Jp2DecoderScaleDown Property

Gets or sets a factor that is used to scale downwards the image as it's decoded.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ScaleDown { get; set; }
Public Property ScaleDown As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the input value is not power of 2.
Remarks
The default value is 1. Values must be a power of two. For example, a value of 2 will reduce the image data by 1/2. A value of 8 reduces by 1/8. Valid values are 1, 2, 4, 8, 16, 32, etc...
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder Methods

The Jp2Decoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo | Returns information about a JPEG2000 image such as width, height, and bit depth. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if the specified Stream is a JPEG2000 image. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NetworkRead |
Protected method | NormalRead |
Protected method | ProgressiveRead |
Public method | Read | Decodes a JPEG2000 image from a stream and returns an AtalaImage with the decoded image data. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.GetImageInfo Method

Jp2DecoderGetImageInfo Method

Returns information about a JPEG2000 image such as width, height, and bit depth.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
JPEG2000 stream

Return Value

Type: ImageInfo
Jp2ImageInfo (derived class from ImageInfo)
Exceptions
Exception | Condition
ImageReadException | Thrown if the stream is not located at the beginning of a JPEG2000 image.
Remarks
The returned ImageInfo must be cast to a Jp2ImageInfo to access FileFormat and Jp2ImageInfo properties.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.IsValidFormat Method

Jp2DecoderIsValidFormat Method

Returns true if the specified Stream is a JPEG2000 image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The input stream.

Return Value

Type: Boolean
Returns true if the image is detected to be JPEG2000, otherwise returns false.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.NetworkRead Method

Jp2DecoderNetworkRead Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage NetworkRead(
    Stream stream,
    ProgressEventHandler progress
)
Protected Overridable Function NetworkRead (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.NormalRead Method

Jp2DecoderNormalRead Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage NormalRead(
    Stream stream,
    ProgressEventHandler progress
)
Protected Overridable Function NormalRead (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.ProgressiveRead Method

Jp2DecoderProgressiveRead Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage ProgressiveRead(
    Stream stream,
    ProgressEventHandler progress
)
Protected Overridable Function ProgressiveRead (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.Read Method

Jp2DecoderRead Method

Decodes a JPEG2000 image from a stream and returns an AtalaImage with the decoded image data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream to read.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB) to ignore progress events.

Return Value

Type: AtalaImage
Returns an AtalaImage containing the decoded JPEG2000 image.
Exceptions
Exception | Condition
ImageReadException | Thrown is the stream is not at the beginning of a JPEG2000 stream.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder Events

The Jp2Decoder type exposes the following members.

Events
 | Name | Description
Public event | ProgressiveImage | Fired for each intermediate step when decoding an image progressively.
Top
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Decoder.ProgressiveImage Event

Jp2DecoderProgressiveImage Event

Fired for each intermediate step when decoding an image progressively.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ProgressiveImageEventHandler ProgressiveImage
Public Event ProgressiveImage As ProgressiveImageEventHandler

Value

Type: Atalasoft.Imaging.Codec.Jpeg2000ProgressiveImageEventHandler
Remarks
See EnableProgressiveDecompression to enable progressive reading.
See Also

Reference

Jp2Decoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace
EnableProgressiveDecompression Property


Jp2Encoder Class

Note: This API is now obsolete.

The class derived from ImageEncoder that encodes JPEG2000 images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.Codec.Jpeg2000Jp2Encoder

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Jpeg2000Encoder should be used.", true)]
public class Jp2Encoder : ImageEncoder
<ObsoleteAttribute("Jpeg2000Encoder should be used.", true)>
Public Class Jp2Encoder
    Inherits ImageEncoder

The Jp2Encoder type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2Encoder | Creates a new instance of a Jp2Encoder.
Public method | Jp2Encoder(Double) | Creates a new instance of a Jp2Encoder specifying the compression rate.
Top
Properties
 | Name | Description
Public property | Compression |
Public property | CompressionMode | Gets or Sets the Jp2CompressionMode to use when compressing an image.
Public property | EncoderOptions | Gets or sets encoder specific options that will be used by default for the entire image.
Public property | EnhancedRegions | Gets a collection of Enhanced Regions that can be set at a higher quality level than the rest of the image during compression.
Public property | FileFormat | Gets or sets the file format to generate (JP2, JPEG2000 codestream, or JPX).
Public property | IPData | Gets or sets intellectual property rights data to be encoded with the image.
Public property | IptcTags | Gets or sets IPTC data that will be stored in the encoded image.
Public property | Precision | Gets or sets a value indicating the precision of the wavelet coefficients.
Public property | QualityStyle | Gets or sets a value indicating the quality mode during lossy compression.
Public property | ResolutionParams | Set property for storing information of resolution. Refer to definition of Jp2ResolutionParams.
Public property | SpeedMode | Gets or sets the speed mode (Fast or Accurate) to use during lossy compression.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by the Jp2Encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | TileSize | Gets or sets the size in pixels of each individual tile.
Public property | UuidBoxes | Gets or sets UuidBox metadata to be stored in the encoded image.
Public property | UuidInfoBoxes | Gets or sets UuidInfoBox metadata to be stored in the encoded image.
Public property | WriteTileLengthMarker | Gets or sets a value indicating if a tile length marker is written to the encoded image.
Public property | XmlBoxes | Gets or sets XML metadata to be stored with the image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEncoderOptions | Returns the encoder options for a specific tile and component.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PixelFormatIsSupported |
Public method | Save | Encodes an AtalaImage into the specified stream as a JPEG2000 image. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

To encode JPEG2000 images, invoke the [!:Jp2Encoder.Save] method of the Jp2Encoder or create an instance of a Jp2Encoder, and pass it into one of the save methods in an AtalaImage, Workspace, or [!:WorkspaceViewer] object.

To specify compression, set the [!:Jp2Encoder.Compression] property to a value between 0.0 and 100.0.

See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder Constructor

Creates a new instance of a Jp2Encoder.
Overload List
 | Name | Description
Public method | Jp2Encoder | Creates a new instance of a Jp2Encoder.
Public method | Jp2Encoder(Double) | Creates a new instance of a Jp2Encoder specifying the compression rate.
Top
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder Constructor

Creates a new instance of a Jp2Encoder.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Encoder()
Public Sub New
See Also

Reference

Jp2Encoder Class
Jp2Encoder Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder Constructor (Double)

Creates a new instance of a Jp2Encoder specifying the compression rate.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Encoder(
    double compression
)
Public Sub New (
    compression As Double
)

Parameters

compression
Type: SystemDouble
Compression rates ranging 1 (maximum compression) to 100 (lossless). A value of 0 is equivalent to 100.
See Also

Reference

Jp2Encoder Class
Jp2Encoder Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder Properties

The Jp2Encoder type exposes the following members.

Properties
 | Name | Description
Public property | Compression |
Public property | CompressionMode | Gets or Sets the Jp2CompressionMode to use when compressing an image.
Public property | EncoderOptions | Gets or sets encoder specific options that will be used by default for the entire image.
Public property | EnhancedRegions | Gets a collection of Enhanced Regions that can be set at a higher quality level than the rest of the image during compression.
Public property | FileFormat | Gets or sets the file format to generate (JP2, JPEG2000 codestream, or JPX).
Public property | IPData | Gets or sets intellectual property rights data to be encoded with the image.
Public property | IptcTags | Gets or sets IPTC data that will be stored in the encoded image.
Public property | Precision | Gets or sets a value indicating the precision of the wavelet coefficients.
Public property | QualityStyle | Gets or sets a value indicating the quality mode during lossy compression.
Public property | ResolutionParams | Set property for storing information of resolution. Refer to definition of Jp2ResolutionParams.
Public property | SpeedMode | Gets or sets the speed mode (Fast or Accurate) to use during lossy compression.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by the Jp2Encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | TileSize | Gets or sets the size in pixels of each individual tile.
Public property | UuidBoxes | Gets or sets UuidBox metadata to be stored in the encoded image.
Public property | UuidInfoBoxes | Gets or sets UuidInfoBox metadata to be stored in the encoded image.
Public property | WriteTileLengthMarker | Gets or sets a value indicating if a tile length marker is written to the encoded image.
Public property | XmlBoxes | Gets or sets XML metadata to be stored with the image.
Top
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.Compression Property

Jp2EncoderCompression Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Compression { get; set; }
Public Property Compression As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.CompressionMode Property

Jp2EncoderCompressionMode Property

Gets or Sets the Jp2CompressionMode to use when compressing an image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2CompressionMode CompressionMode { get; set; }
Public Property CompressionMode As Jp2CompressionMode
    Get
    Set

Property Value

Type: Jp2CompressionMode
The current Jp2CompressionMode.
Remarks
This property specifies how the Compression property will be used. If the CompressionMode is set to Jp2CompressionMode.Size, the encoder will attempt to make the output stream the same size as the value of Compression. If the CompressionMode is set to Jp2CompressionMode.Quality, the Compression property is treated like a percentage where the target output size will try to be Compression% of the original image size.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.EncoderOptions Property

Jp2EncoderEncoderOptions Property

Gets or sets encoder specific options that will be used by default for the entire image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EncoderOptions EncoderOptions { get; set; }
Public Property EncoderOptions As Jp2EncoderOptions
    Get
    Set

Property Value

Type: Jp2EncoderOptions
Remarks
If the [!:Jp2Encoder.GetEncoderOptions] is not overridden to supply specific encoder options for tiles or components, then this property will be used for encoder options for the entire encoded image.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.EnhancedRegions Property

Jp2EncoderEnhancedRegions Property

Gets a collection of Enhanced Regions that can be set at a higher quality level than the rest of the image during compression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EnhancedRegionCollection EnhancedRegions { get; }
Public ReadOnly Property EnhancedRegions As Jp2EnhancedRegionCollection
    Get

Property Value

Type: Jp2EnhancedRegionCollection
Default is null.
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
The maximum number of regions is 16.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.FileFormat Property

Jp2EncoderFileFormat Property

Gets or sets the file format to generate (JP2, JPEG2000 codestream, or JPX).

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2FileFormat FileFormat { get; set; }
Public Property FileFormat As Jp2FileFormat
    Get
    Set

Property Value

Type: Jp2FileFormat
The default value is Jp2
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown when set to codestream, without a professional license.
Remarks

Default is Jp2. The JP2 and JPX format allow additional information, including resolution and meta-data, to be saved. The use of plain codestream is not recommended. The JPX file format is required to store CMYK and CIE Lab images as well as using unrestricted ICC profile.

The codestream format requires the professional edition.

See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.IPData Property

Jp2EncoderIPData Property

Gets or sets intellectual property rights data to be encoded with the image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IPData { get; set; }
Public Property IPData As String
    Get
    Set

Property Value

Type: String
Remarks
Note that the IP data is not checked or parsed by the library. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.IptcTags Property

Jp2EncoderIptcTags Property

Gets or sets IPTC data that will be stored in the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection IptcTags { get; set; }
Public Property IptcTags As IptcCollection
    Get
    Set

Property Value

Type: IptcCollection
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
IptcCollection is a collection of IptcTags defined in the Atalasoft.Imaging.MetaData namespace. Further details of the IPTC format may be found at www.iptc.org. IPTC data is stored in a UUID data block with a reserved IPTC UUID.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.Precision Property

Jp2EncoderPrecision Property

Gets or sets a value indicating the precision of the wavelet coefficients.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Precision Precision { get; set; }
Public Property Precision As Jp2Precision
    Get
    Set

Property Value

Type: Jp2Precision
Default is Automatic (automatically select appropriate precision).
Remarks
Default value is Jp2Precision.Automatic. For improved efficiency, the library automatically, depending on the image depth, uses either 16 or 32 bit representation for wavelet coefficients. The use of 32 bit values may slightly improve image quality and the expense of speed and memory requirements.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.QualityStyle Property

Jp2EncoderQualityStyle Property

Gets or sets a value indicating the quality mode during lossy compression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2QualityStyle QualityStyle { get; set; }
Public Property QualityStyle As Jp2QualityStyle
    Get
    Set

Property Value

Type: Jp2QualityStyle
Remarks
Default value is PSNR. For normal images (1:1 pixel display, up to 20 inches viewing distance) VisualSmall or PSNR is recommended. For technical and medical images, PSNR is recommended.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.ResolutionParams Property

Jp2EncoderResolutionParams Property

Set property for storing information of resolution. Refer to definition of Jp2ResolutionParams.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ResolutionParams ResolutionParams { get; set; }
Public Property ResolutionParams As Jp2ResolutionParams
    Get
    Set

Property Value

Type: Jp2ResolutionParams
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.SpeedMode Property

Jp2EncoderSpeedMode Property

Gets or sets the speed mode (Fast or Accurate) to use during lossy compression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2SpeedMode SpeedMode { get; set; }
Public Property SpeedMode As Jp2SpeedMode
    Get
    Set

Property Value

Type: Jp2SpeedMode
Remarks
Default value is Fast. Fast provides high speed compression but may create images with a lower quality. Accurate produces optimal quality but slower speed.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.SupportedPixelFormats Property

Jp2EncoderSupportedPixelFormats Property

Returns an array of PixelFormats supported by the Jp2Encoder.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
Remarks

The Jp2Encoder supports the following pixel formats:

PixelFormat.PixelPixel8bppGrayscalePixelFormat.Pixel16bppGrayscalePixelFormat.Pixel24bppBgrPixelFormat.Pixel32bppBgraPixelFormat.Pixel32bppCmykPixelFormat.Pixel48bppBgrPixelFormat.Pixel64bppBgra
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.TileSize Property

Jp2EncoderTileSize Property

Gets or sets the size in pixels of each individual tile.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size TileSize { get; set; }
Public Property TileSize As Size
    Get
    Set

Property Value

Type: Size
Remarks

An image can be split into smaller tiles, with each tile independently compressed. The basic tile size can be set using this property. Depending on the tile size specified by this property, tiling will be performed automatically inside library.

To encode the image with just one tile, specify (0, 0) or Size.Empty for TileSize.

See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.UuidBoxes Property

Jp2EncoderUuidBoxes Property

Gets or sets UuidBox metadata to be stored in the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidBoxCollection UuidBoxes { get; set; }
Public Property UuidBoxes As UuidBoxCollection
    Get
    Set

Property Value

Type: UuidBoxCollection
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
This property holds UUIDs with associated data in a JPEG2000 format file. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.UuidInfoBoxes Property

Jp2EncoderUuidInfoBoxes Property

Gets or sets UuidInfoBox metadata to be stored in the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidInfoBoxCollection UuidInfoBoxes { get; set; }
Public Property UuidInfoBoxes As UuidInfoBoxCollection
    Get
    Set

Property Value

Type: UuidInfoBoxCollection
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
This property associates a URL with a list of UUIDs. The URL points to information describing the usage and format of the listed UUIDs. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.WriteTileLengthMarker Property

Jp2EncoderWriteTileLengthMarker Property

Gets or sets a value indicating if a tile length marker is written to the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WriteTileLengthMarker { get; set; }
Public Property WriteTileLengthMarker As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false. The efficiency of decoding regions in a tiled image may be improved by the usage of tile length markers. Tile length markers contain the position of each tile in the JPEG2000 code stream, enabling faster access to tiled image.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.XmlBoxes Property

Jp2EncoderXmlBoxes Property

Gets or sets XML metadata to be stored with the image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] XmlBoxes { get; set; }
Public Property XmlBoxes As String()
    Get
    Set

Property Value

Type: String
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
In Jp2 format file, note that the XML data is not checked for XML compliance or parsed by the library. Adobe XMP data can be stored in this box. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder Methods

The Jp2Encoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEncoderOptions | Returns the encoder options for a specific tile and component.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PixelFormatIsSupported |
Public method | Save | Encodes an AtalaImage into the specified stream as a JPEG2000 image. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.GetEncoderOptions Method

Jp2EncoderGetEncoderOptions Method

Returns the encoder options for a specific tile and component.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Jp2EncoderOptions GetEncoderOptions(
    int tileLocation,
    int channel
)
Protected Overridable Function GetEncoderOptions (
    tileLocation As Integer,
    channel As Integer
) As Jp2EncoderOptions

Parameters

tileLocation
Type: SystemInt32
index of tile counting from left-top
channel
Type: SystemInt32
index of color component

Return Value

Type: Jp2EncoderOptions
Returns the encoder options for a specific tile and component.
Remarks
Override this method to set encoder options for a specific tile and component. This method by default will use the [!:Jp2Encoder.EncoderOptions] as specified in this Jp2Encoder class. Normally, this method does not need to be overriden.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.PixelFormatIsSupported Method

Jp2EncoderPixelFormatIsSupported Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool PixelFormatIsSupported(
    PixelFormat format
)
Protected Function PixelFormatIsSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat

Return Value

Type: Boolean
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Encoder.Save Method

Jp2EncoderSave Method

Encodes an AtalaImage into the specified stream as a JPEG2000 image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream to encode to.
image
Type: Atalasoft.ImagingAtalaImage
The image to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB) to ignore progress events

Return Value

Type: Int64
The number of bytes written to the output stream.
Remarks
This method is invoked when using save methods in an AtalaImage, Workspace, or [!:WorkspaceViewer] object. In the professional edition, an ICC color profile is stored with the image if the [!:ColorProfile] object of the AtalaImage object is set.
See Also

Reference

Jp2Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions Class

This class specifies encoder options that can be applied to the entire image, a specific tile, or a specific component.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jp2EncoderOptions

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2EncoderOptions
Public Class Jp2EncoderOptions

The Jp2EncoderOptions type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2EncoderOptions | Creates a new instance of Jp2EncoderOptions.
Top
Properties
 | Name | Description
Public property | CodeBlockSize | Gets or sets the size of the blocks of coded data.
Public property | CoderOptions | Gets or sets the coder options for faster compression / decompression.
Protected property | GuardBits |
Public property | PacketMarkers | Gets or sets a value that creates special markers at the beginning and/or at the end of each block of a coded area.
Public property | ProgressionOrder | Gets or sets the organization of the coded data.
Public property | QualityLayers | Gets or sets the number of quality layers in the code stream for use with progressive decoding.
Public property | QuantizationStyle | Gets or sets the quantization steps.
Public property | WaveletFilterMethod | Gets or sets a value selecting reversible (WaveletFiveThree) or irreversible (WaveletNineSeven) wavelet filters.
Public property | WaveletLevels | Gets or sets the number of wavelet transformation levels.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _codeBlockSize |
Protected field | _qualityLayers |
Protected field | _waveletLevels |
Top
Remarks

See the [!:Jp2Encoder.EncoderOptions] property in the [!:Jp2Encoder] to set these options for the entire encoded image. To specify different options for different tiles or components, override the [!:Jp2Encoder.GetEncoderOptions] method in the Jp2Encoder class.

QualityLayer, ProgressionOrder, and PacketMarkers are the options which can be set for each tile. WaveletFilterMethod, WaveletLevels, QuantizationStyle, codeBlockSize, and coderOptions are the options which can be set for each component in a given tile.

See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions Constructor

Creates a new instance of Jp2EncoderOptions.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EncoderOptions()
Public Sub New
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions Properties

The Jp2EncoderOptions type exposes the following members.

Properties
 | Name | Description
Public property | CodeBlockSize | Gets or sets the size of the blocks of coded data.
Public property | CoderOptions | Gets or sets the coder options for faster compression / decompression.
Protected property | GuardBits |
Public property | PacketMarkers | Gets or sets a value that creates special markers at the beginning and/or at the end of each block of a coded area.
Public property | ProgressionOrder | Gets or sets the organization of the coded data.
Public property | QualityLayers | Gets or sets the number of quality layers in the code stream for use with progressive decoding.
Public property | QuantizationStyle | Gets or sets the quantization steps.
Public property | WaveletFilterMethod | Gets or sets a value selecting reversible (WaveletFiveThree) or irreversible (WaveletNineSeven) wavelet filters.
Public property | WaveletLevels | Gets or sets the number of wavelet transformation levels.
Top
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.CodeBlockSize Property

Jp2EncoderOptionsCodeBlockSize Property

Gets or sets the size of the blocks of coded data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size CodeBlockSize { get; set; }
Public Property CodeBlockSize As Size
    Get
    Set

Property Value

Type: Size
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown is the width or height is less than 1 or greater than 4096
Remarks

The default value is 64 x 64. Smaller code blocks can aid the decoding of regions of an image and error resilience. A code block may contain no more than 4096 samples, i.e. Size.Width * Size.Height <= 4096.

The code block can be set independently for each component in each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.CoderOptions Property

Jp2EncoderOptionsCoderOptions Property

Gets or sets the coder options for faster compression / decompression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2CoderOptions CoderOptions { get; set; }
Public Property CoderOptions As Jp2CoderOptions
    Get
    Set

Property Value

Type: Jp2CoderOptions
Remarks

The default value is Jp2CoderOptions.Predictable. These options may be combined to create error resilient JPEG2000 streams or for special codec (e.g. hardware coder) for a faster compression / decompression. These options will increase the file size slightly when generating a code stream with the same image quality. We recommend usage of Jp2CoderOptions.Predictable if fault tolerance is important.

The coder options can be set independently for each component in each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.GuardBits Property

Jp2EncoderOptionsGuardBits Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int GuardBits { get; set; }
Protected Property GuardBits As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.PacketMarkers Property

Jp2EncoderOptionsPacketMarkers Property

Gets or sets a value that creates special markers at the beginning and/or at the end of each block of a coded area.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2PacketMarkers PacketMarkers { get; set; }
Public Property PacketMarkers As Jp2PacketMarkers
    Get
    Set

Property Value

Type: Jp2PacketMarkers
Remarks

Default value is Jp2PacketMarkers.Sop | Jp2PacketMarkers.Eph. These markers improve error resilience and improve the speed of decoding a region of an image.

Packet markets can be set independently for each component in each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.ProgressionOrder Property

Jp2EncoderOptionsProgressionOrder Property

Gets or sets the organization of the coded data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ProgressionOrder ProgressionOrder { get; set; }
Public Property ProgressionOrder As Jp2ProgressionOrder
    Get
    Set

Property Value

Type: Jp2ProgressionOrder
Remarks

Default value is LRCP. The setting LRCP (quality) is most useful when used with several layers. PCRL (position) should be used with precincts.

This value can be independently set for each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.QualityLayers Property

Jp2EncoderOptionsQualityLayers Property

Gets or sets the number of quality layers in the code stream for use with progressive decoding.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int QualityLayers { get; set; }
Public Property QualityLayers As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when set to a value less than 1 or greater than 31.
Remarks

Supports from 1 to 31 quality layers. A higher number of quality layers results in a finer progressive quality improvement. The number of layers can be set for each individual tile.

This value can be independently set for each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.QuantizationStyle Property

Jp2EncoderOptionsQuantizationStyle Property

Gets or sets the quantization steps.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2QuantizationStyle QuantizationStyle { get; set; }
Public Property QuantizationStyle As Jp2QuantizationStyle
    Get
    Set

Property Value

Type: Jp2QuantizationStyle
Remarks

The default value is Jp2QuantizationStyle.Expound. Note that this property may only be set when the irreversible filter (Jp2WaveletFilter.WaveletNineSeven) is used. The quantization steps can either be derived from a bases quantization step (Jp2QuantizationStyle.Derived) or calculated for each image sub-band (Jp2QuantizationStyle.Expound). Expound style is recommended.

Quantization style can be independently set for each component in each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.WaveletFilterMethod Property

Jp2EncoderOptionsWaveletFilterMethod Property

Gets or sets a value selecting reversible (WaveletFiveThree) or irreversible (WaveletNineSeven) wavelet filters.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2WaveletFilter WaveletFilterMethod { get; set; }
Public Property WaveletFilterMethod As Jp2WaveletFilter
    Get
    Set

Property Value

Type: Jp2WaveletFilter
Remarks

Default value is WaveletNineSeven.

The wavelet filter can be set independently for each component in each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions.WaveletLevels Property

Jp2EncoderOptionsWaveletLevels Property

Gets or sets the number of wavelet transformation levels.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int WaveletLevels { get; set; }
Public Property WaveletLevels As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 16.
Remarks

Default value is 5. Valid values are in the range 0 (no wavelet analysis) to 16. The memory requirements and compression time increase with the number of transformation levels. A reasonable number of transformation levels are in the range of 4 to 6.

Wavelet levels can be set independently for each component in each tile.

See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions Methods

The Jp2EncoderOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions Fields

The Jp2EncoderOptions type exposes the following members.

Fields
 | Name | Description
Protected field | _codeBlockSize |
Protected field | _qualityLayers |
Protected field | _waveletLevels |
Top
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions._codeBlockSize Field

Jp2EncoderOptions_codeBlockSize Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Size _codeBlockSize
Protected _codeBlockSize As Size

Field Value

Type: Size
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions._qualityLayers Field

Jp2EncoderOptions_qualityLayers Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _qualityLayers
Protected _qualityLayers As Integer

Field Value

Type: Int32
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptions._waveletLevels Field

Jp2EncoderOptions_waveletLevels Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _waveletLevels
Protected _waveletLevels As Integer

Field Value

Type: Int32
See Also

Reference

Jp2EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EncoderOptionsCallback Delegate

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate Jp2EncoderOptions Jp2EncoderOptionsCallback(
    int tileLocation,
    int channel
)
Public Delegate Function Jp2EncoderOptionsCallback (
    tileLocation As Integer,
    channel As Integer
) As Jp2EncoderOptions

Parameters

tileLocation
Type: SystemInt32
channel
Type: SystemInt32

Return Value

Type: Jp2EncoderOptions
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Class

Region of interest in the JPEG2000 standard
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2EnhancedRegion
Public Class Jp2EnhancedRegion

The Jp2EnhancedRegion type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2EnhancedRegion | Create an instance of R.O.I.
Public method | Jp2EnhancedRegion(Rectangle) | Create an instance of R.O.I.
Top
Properties
 | Name | Description
Public property | Rectangle | ROI shall be compressed in a higher quality than the rest of image.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRoiCornersCompatibleWithLura |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Constructor

Overload List
 | Name | Description
Public method | Jp2EnhancedRegion | Create an instance of R.O.I.
Public method | Jp2EnhancedRegion(Rectangle) | Create an instance of R.O.I.
Top
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Constructor

Create an instance of R.O.I.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EnhancedRegion()
Public Sub New
See Also

Reference

Jp2EnhancedRegion Class
Jp2EnhancedRegion Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Constructor (Rectangle)

Create an instance of R.O.I.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EnhancedRegion(
    Rectangle rectRoi
)
Public Sub New (
    rectRoi As Rectangle
)

Parameters

rectRoi
Type: System.DrawingRectangle
a R.O.I. rectangle
See Also

Reference

Jp2EnhancedRegion Class
Jp2EnhancedRegion Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Properties

The Jp2EnhancedRegion type exposes the following members.

Properties
 | Name | Description
Public property | Rectangle | ROI shall be compressed in a higher quality than the rest of image.
Top
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion.Rectangle Property

Jp2EnhancedRegionRectangle Property

ROI shall be compressed in a higher quality than the rest of image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Rectangle { get; set; }
Public Property Rectangle As Rectangle
    Get
    Set

Property Value

Type: Rectangle
Remarks
Maximum of 16 ROI may be defined.
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Methods

The Jp2EnhancedRegion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRoiCornersCompatibleWithLura |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion.Equals Method

Jp2EnhancedRegionEquals Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion.GetHashCode Method

Jp2EnhancedRegionGetHashCode Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion.SetRoiCornersCompatibleWithLura Method

Jp2EnhancedRegionSetRoiCornersCompatibleWithLura Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SetRoiCornersCompatibleWithLura(
    Size imageSize
)
Public Function SetRoiCornersCompatibleWithLura (
    imageSize As Size
) As Rectangle

Parameters

imageSize
Type: System.DrawingSize

Return Value

Type: Rectangle
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion Operators

The Jp2EnhancedRegion type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion.Equality Operator

Jp2EnhancedRegionEquality Operator

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    Jp2EnhancedRegion roi1,
    Jp2EnhancedRegion roi2
)
Public Shared Operator = (
    roi1 As Jp2EnhancedRegion,
    roi2 As Jp2EnhancedRegion
) As Boolean

Parameters

roi1
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion
roi2
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion

Return Value

Type: Boolean
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegion.Inequality Operator

Jp2EnhancedRegionInequality Operator

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    Jp2EnhancedRegion roi1,
    Jp2EnhancedRegion roi2
)
Public Shared Operator <> (
    roi1 As Jp2EnhancedRegion,
    roi2 As Jp2EnhancedRegion
) As Boolean

Parameters

roi1
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion
roi2
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion

Return Value

Type: Boolean
See Also

Reference

Jp2EnhancedRegion Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection Class

Regions of interest which shall be compressed at a different quality than the rest of the image.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegionCollection

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2EnhancedRegionCollection : CollectionBase
Public Class Jp2EnhancedRegionCollection
    Inherits CollectionBase

Field Value

Type:
Default is null.

The Jp2EnhancedRegionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2EnhancedRegionCollection | Creates a new instance of a Jp2EnhancedRegionCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | EnhancementLevel | Gets or sets the a value controlling the level of enhanced quality for the enhanced regions.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | JItem |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds a Jp2EnhancedRegion to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | CopyTo | Copies the collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index in the collection that contains the given Jp2EnhancedRegion.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove the given Jp2EnhancedRegion from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This property sets a collection of Jp2RegionOfInterest objects which shall be compressed at a different quality than the rest of image. A maximum of 16 regions of interest may be defined. A detailed discussion of Jp2RegionOfInterest class is described in A.1.3.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection Constructor

Creates a new instance of a Jp2EnhancedRegionCollection.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EnhancedRegionCollection()
Public Sub New
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection Properties

The Jp2EnhancedRegionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | EnhancementLevel | Gets or sets the a value controlling the level of enhanced quality for the enhanced regions.
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | JItem |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection.EnhancementLevel Property

Jp2EnhancedRegionCollectionEnhancementLevel Property

Gets or sets the a value controlling the level of enhanced quality for the enhanced regions.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int EnhancementLevel { get; set; }
Public Property EnhancementLevel As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 10.
Remarks
The enhancement factor must be an integer between 0 and 10, where 0 implies no quality enhancement and 10 implies maximal quality enhancement. The quality enhancement factor applies to all regions of interest. If this property is not set then the maximum quality enhancement will be used by default.
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection.JItem Property

Jp2EnhancedRegionCollectionJItem Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EnhancedRegion this[
    int index
] { get; set; }
Public Default Property JItem (
    index As Integer
) As Jp2EnhancedRegion
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: Jp2EnhancedRegion
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection Methods

The Jp2EnhancedRegionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a Jp2EnhancedRegion to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | CopyTo | Copies the collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index in the collection that contains the given Jp2EnhancedRegion.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove the given Jp2EnhancedRegion from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection.Add Method

Jp2EnhancedRegionCollectionAdd Method

Adds a Jp2EnhancedRegion to the collection.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    Jp2EnhancedRegion roi
)
Public Sub Add (
    roi As Jp2EnhancedRegion
)

Parameters

roi
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection.CopyTo Method

Jp2EnhancedRegionCollectionCopyTo Method

Copies the collection into an array.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Jp2EnhancedRegion[] resources,
    int index
)
Public Sub CopyTo (
    resources As Jp2EnhancedRegion(),
    index As Integer
)

Parameters

resources
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion
index
Type: SystemInt32
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection.IndexOf Method

Jp2EnhancedRegionCollectionIndexOf Method

Returns the index in the collection that contains the given Jp2EnhancedRegion.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    Jp2EnhancedRegion roi
)
Public Function IndexOf (
    roi As Jp2EnhancedRegion
) As Integer

Parameters

roi
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion

Return Value

Type: Int32
Returns -1 if the object doesn't exist in the collection.
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2EnhancedRegionCollection.Remove Method

Jp2EnhancedRegionCollectionRemove Method

Remove the given Jp2EnhancedRegion from the collection.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    Jp2EnhancedRegion roi
)
Public Sub Remove (
    roi As Jp2EnhancedRegion
)

Parameters

roi
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2EnhancedRegion
See Also

Reference

Jp2EnhancedRegionCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2FileFormat Enumeration

Available JPEG2000 codestreams

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2FileFormat
Public Enumeration Jp2FileFormat
Members
Member name | Description
Codestream | JPEG2000 codestream: *.jpc, *.j2c, *.j2k.
Jp2 | JPEG2000 Part1 format file: *.jp2.
Jpx | JPEG2000 Part2 format file: *.jpf.
Remarks
This specifies whether a JP2 format file, a plain JPEG2000 codestream or an extended JPX format file should be generated.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo Class

This class derives from ImageInfo, and contains information about the JPEG2000 image such as width, height, and colordepth.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.Codec.Jpeg2000Jp2ImageInfo

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2ImageInfo : ImageInfo
Public Class Jp2ImageInfo
    Inherits ImageInfo

The Jp2ImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2ImageInfo | Creates a new instance of Jp2ImageInfo.
Top
Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FileFormat | Gets the JPEG2000 codestream of the source image data.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | IPData | Gets the Intellectual Property Rights Information (IPData) stored in the source data stream.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsJpx |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFileFormat |
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
Fields
 | Name | Description
Protected field | _fileFormat |
Protected field | _ipData |
Protected field | feature |
Top
Remarks
To obtain information specific to JPEG2000 such as FileType and , the returned ImageInfo class must be cast to a Jp2ImageInfo object.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo Constructor

Creates a new instance of Jp2ImageInfo.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ImageInfo(
    ImageInfo imageInfo,
    string ipData,
    Jp2FileFormat fileFormat
)
Public Sub New (
    imageInfo As ImageInfo,
    ipData As String,
    fileFormat As Jp2FileFormat
)

Parameters

imageInfo
Type: Atalasoft.Imaging.CodecImageInfo
The base ImageInfo class to apply properties from.
ipData
Type: SystemString
fileFormat
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2FileFormat
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo Properties

The Jp2ImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FileFormat | Gets the JPEG2000 codestream of the source image data.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | IPData | Gets the Intellectual Property Rights Information (IPData) stored in the source data stream.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Top
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo.FileFormat Property

Jp2ImageInfoFileFormat Property

Gets the JPEG2000 codestream of the source image data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Jp2FileFormat FileFormat { get; }
Public Overridable ReadOnly Property FileFormat As Jp2FileFormat
    Get

Property Value

Type: Jp2FileFormat
The JPEG2000 codestream of the source image data.
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo.IPData Property

Jp2ImageInfoIPData Property

Gets the Intellectual Property Rights Information (IPData) stored in the source data stream.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string IPData { get; }
Public Overridable ReadOnly Property IPData As String
    Get

Property Value

Type: String
The Intellectual Property Rights Information (IPData) stored in the source data stream.
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo Methods

The Jp2ImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsJpx |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFileFormat |
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo.IsJpx Method

Jp2ImageInfoIsJpx Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsJpx(
    Stream stream
)
Public Function IsJpx (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream

Return Value

Type: Boolean
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo.SetFileFormat Method

Jp2ImageInfoSetFileFormat Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetFileFormat(
    Jp2FileFormat value
)
Public Sub SetFileFormat (
    value As Jp2FileFormat
)

Parameters

value
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2FileFormat
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo Fields

The Jp2ImageInfo type exposes the following members.

Fields
 | Name | Description
Protected field | _fileFormat |
Protected field | _ipData |
Protected field | feature |
Top
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo._fileFormat Field

Jp2ImageInfo_fileFormat Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Jp2FileFormat _fileFormat
Protected _fileFormat As Jp2FileFormat

Field Value

Type: Jp2FileFormat
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo._ipData Field

Jp2ImageInfo_ipData Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string _ipData
Protected _ipData As String

Field Value

Type: String
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ImageInfo.feature Field

Jp2ImageInfofeature Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected JpxStandardFeatures feature
Protected feature As JpxStandardFeatures

Field Value

Type: JpxStandardFeatures
See Also

Reference

Jp2ImageInfo Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser Class

This class parses IPTC data from an image stream, adds JPEG2000 to the supported image formats for IPTC parsing.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataIptcParser
Atalasoft.Imaging.Codec.Jpeg2000Jp2IptcParser

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2IptcParser : IptcParser
Public Class Jp2IptcParser
    Inherits IptcParser

The Jp2IptcParser type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2IptcParser | Creates a new instance of Jp2IptcParser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromByteArray | Parses IPTC data from a byte array. (Inherited from IptcParser.)
Public method | ParseFromImage(Stream) | Returns a collection of IPTC data from the specified image stream.
Public method | ParseFromImage(String) |
Public method | ParseFromImage(Stream, Int32) | (Overrides IptcParserParseFromImage(Stream, Int32).)
Public method | ParseFromImage(String, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser Constructor

Creates a new instance of Jp2IptcParser.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2IptcParser()
Public Sub New
Exceptions
Exception | Condition
 | Thrown if the current license is not Professional.
See Also

Reference

Jp2IptcParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser Methods

The Jp2IptcParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromByteArray | Parses IPTC data from a byte array. (Inherited from IptcParser.)
Public method | ParseFromImage(Stream) | Returns a collection of IPTC data from the specified image stream.
Public method | ParseFromImage(String) |
Public method | ParseFromImage(Stream, Int32) | (Overrides IptcParserParseFromImage(Stream, Int32).)
Public method | ParseFromImage(String, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2IptcParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser.ParseFromImage Method

Jp2IptcParserParseFromImage Method

Overload List
 | Name | Description
Public method | ParseFromImage(Stream) | Returns a collection of IPTC data from the specified image stream.
Public method | ParseFromImage(String) |
Public method | ParseFromImage(Stream, Int32) | (Overrides IptcParserParseFromImage(Stream, Int32).)
Public method | ParseFromImage(String, Int32) |
Top
See Also

Reference

Jp2IptcParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser.ParseFromImage Method (Stream)

Jp2IptcParserParseFromImage Method (Stream)

Returns a collection of IPTC data from the specified image stream.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IptcCollection ParseFromImage(
    Stream stream
)
Public Overridable Function ParseFromImage (
    stream As Stream
) As IptcCollection

Parameters

stream
Type: System.IOStream
The JPEG2000 stream

Return Value

Type: IptcCollection
IptcCollection
See Also

Reference

Jp2IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser.ParseFromImage Method (String)

Jp2IptcParserParseFromImage Method (String)

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IptcCollection ParseFromImage(
    string filename
)
Public Overridable Function ParseFromImage (
    filename As String
) As IptcCollection

Parameters

filename
Type: SystemString

Return Value

Type: IptcCollection
See Also

Reference

Jp2IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser.ParseFromImage Method (Stream, Int32)

Jp2IptcParserParseFromImage Method (Stream, Int32)

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override IptcCollection ParseFromImage(
    Stream stream,
    int frameIndex
)
Public Overrides Function ParseFromImage (
    stream As Stream,
    frameIndex As Integer
) As IptcCollection

Parameters

stream
Type: System.IOStream
frameIndex
Type: SystemInt32

Return Value

Type: IptcCollection
See Also

Reference

Jp2IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2IptcParser.ParseFromImage Method (String, Int32)

Jp2IptcParserParseFromImage Method (String, Int32)

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IptcCollection ParseFromImage(
    string filename,
    int frameIndex
)
Public Overridable Function ParseFromImage (
    filename As String,
    frameIndex As Integer
) As IptcCollection

Parameters

filename
Type: SystemString
frameIndex
Type: SystemInt32

Return Value

Type: IptcCollection
See Also

Reference

Jp2IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2License Class

Class that allows assembly tied embedded component licensing.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jp2License

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class Jp2License
Public NotInheritable Class Jp2License

The Jp2License type exposes the following members.

Properties
Name | Description
AssemblyLicense | Gets or sets the assembly tied license to unlock this component for special licensing.
Edition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2License Properties

The Jp2License type exposes the following members.

Properties
Name | Description
AssemblyLicense | Gets or sets the assembly tied license to unlock this component for special licensing.
Edition |
Top
See Also

Reference

Jp2License Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2License.AssemblyLicense Property

Jp2LicenseAssemblyLicense Property

Gets or sets the assembly tied license to unlock this component for special licensing.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string AssemblyLicense { get; set; }
Public Shared Property AssemblyLicense As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Jp2License Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2License.Edition Property

Jp2LicenseEdition Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Jp2LicenseEdition Edition { get; }
Public Shared ReadOnly Property Edition As Jp2LicenseEdition
    Get

Property Value

Type: Jp2LicenseEdition
See Also

Reference

Jp2License Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2License Methods

The Jp2License type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2License Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2LicenseEdition Enumeration

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2LicenseEdition
Public Enumeration Jp2LicenseEdition
Members
Member name | Description
Standard |
Professional |
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2PacketMarkers Enumeration

Error recovery markers in bit stream. Flagged

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum Jp2PacketMarkers
<FlagsAttribute>
Public Enumeration Jp2PacketMarkers
Members
Member name | Description
None | No packet markers
Sop | Start of packet marker
Eph | End of packet header
Remarks
These markers improve error resilence and improve the speed of decoding a region of an image. Default is None.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jp2Palette

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2Palette : IDisposable
Public Class Jp2Palette
    Implements IDisposable

The Jp2Palette type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2Palette | Initializes a new instance of the Jp2Palette class
Top
Properties
 | Name | Description
Public property | BitsPerSample |
Public property | NumChannels |
Public property | NumEntries |
Public property | Palette |
Public property | SignedSample |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Jp2Palette
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Jp2Palette and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPalette |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _numChannels |
Protected field | _numEntries |
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette Constructor

Initializes a new instance of the Jp2Palette class

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Palette()
Public Sub New
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette Properties

The Jp2Palette type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerSample |
Public property | NumChannels |
Public property | NumEntries |
Public property | Palette |
Public property | SignedSample |
Top
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.BitsPerSample Property

Jp2PaletteBitsPerSample Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] BitsPerSample { get; set; }
Public Property BitsPerSample As Byte()
    Get
    Set

Property Value

Type: Byte
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.NumChannels Property

Jp2PaletteNumChannels Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int NumChannels { get; set; }
Public Property NumChannels As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.NumEntries Property

Jp2PaletteNumEntries Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int NumEntries { get; set; }
Public Property NumEntries As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.Palette Property

Jp2PalettePalette Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[,] Palette { get; set; }
Public Property Palette As Integer(,)
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.SignedSample Property

Jp2PaletteSignedSample Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] SignedSample { get; set; }
Public Property SignedSample As Byte()
    Get
    Set

Property Value

Type: Byte
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette Methods

The Jp2Palette type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPalette |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.Dispose Method

Jp2PaletteDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Jp2Palette
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Jp2Palette and optionally releases the managed resources
Top
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.Dispose Method

Jp2PaletteDispose Method

Releases all resources used by the Jp2Palette

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Jp2Palette Class
Dispose Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.Dispose Method (Boolean)

Jp2PaletteDispose Method (Boolean)

Releases the unmanaged resources used by the Jp2Palette and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Jp2Palette Class
Dispose Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette.GetPalette Method

Jp2PaletteGetPalette Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetPalette(
    int* pHandle
)
Visual Basic does not support APIs that consume or return unsafe types.

Parameters

pHandle
Type: SystemInt32*
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette Fields

The Jp2Palette type exposes the following members.

Fields
 | Name | Description
Protected field | _numChannels |
Protected field | _numEntries |
Top
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette._numChannels Field

Jp2Palette_numChannels Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _numChannels
Protected _numChannels As Integer

Field Value

Type: Int32
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Palette._numEntries Field

Jp2Palette_numEntries Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _numEntries
Protected _numEntries As Integer

Field Value

Type: Int32
See Also

Reference

Jp2Palette Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2Precision Enumeration

Wavelet Precision

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2Precision
Public Enumeration Jp2Precision
Members
Member name | Description
Automatic | Automatically use either 16 or 32 bit representation for wavelet coeff's. Default.
Force32Bit | Force to use 32 bits.
Remarks
Either set automatically depending on color depth or to force the library to use 32 bit representation. Default is Automatic.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ProgressionOrder Enumeration

For a given tile, the packets contain data from a specific component, a specific resolution, and a specific precinct. The order in which these packets are interleaved is called the progression order. The interleaving of the packets can progress along four axes: layer (L), component (C), resolution (R) and precinct (P).

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2ProgressionOrder
Public Enumeration Jp2ProgressionOrder
Members
Member name | Description
Lrcp | LRCP Quality progressive
Rlcp | RLCP Resolution then quality progressive
Rpcl | RPCL Resolution then position progressive
Pcrl | PCRL Position progressive
Cprl | CPRL Color/channel progressive
Remarks
The setting Lrcp is most useful when used with several layers. Pcrl should be used with precinct. Default is Lrcp.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2QualityStyle Enumeration

Quality styles are used to set the quality mode to be used during lossy compression. The quality may be optimized for PSNR or for visual quality.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2QualityStyle
Public Enumeration Jp2QualityStyle
Members
Member name | Description
Psnr | Quality optimized for Psnr.
VisualXXSmall | Quality optimized for small viewing distance, small images, zoomed in views, OCR.
VisualXSmall | Quality optimized for small viewing distance, small images, zoomed in views, OCR.
VisualSmall | Quality optimized for small viewing distance, small images, zoomed in views, OCR.
VisualMedium | Quality optimized for medium viewing distance.
VisualLarge | Quality optimized for large viewing distance, large images, zoomed out views.
VisualXLarge | Quality optimized for large viewing distance, large images, zoomed out views.
VisualXXLarge | Quality optimized for large viewing distance, large images, zoomed out views.
Remarks

The visual quality may be optimized for viewing from small, medium and large distance.

For normal images and situations (1:1 pixel display, ~50 cm (20 in) viewing difference) we recommend VisualSmall or Psnr, but you should test different settings for yourself.

For technical and medical images we recommend Psnr. For quality measurement only Psnr should be used.

Default is Psnr.

See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2QuantizationStyle Enumeration

Note: This API is now obsolete.

The quantization steps can either be derived from a base quantization step, Derived, or calculated for each image sub-band, Expounded.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("JPEG2000QuantizationStyle enum should be used.")]
public enum Jp2QuantizationStyle
<ObsoleteAttribute("JPEG2000QuantizationStyle enum should be used.")>
Public Enumeration Jp2QuantizationStyle
Members
Member name | Description
Derived | derived from a bases quantization step
Expounded | calculated for each image sub-band
Remarks

Expounded style is recommended when using the irreversible filter. The default is Expounded

JPEG2000QuantizationStyle enum should be used instead.

See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams Class

Resolution structure for DPI information. Note that resolution information may only be stored in Jp2 file format images. Plain codestream format images can not store resolution information. The image resolution is calculated by: [DPM] = ( xNum / xDenom ) * 10 ^ xExp
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jp2ResolutionParams

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2ResolutionParams
Public Class Jp2ResolutionParams

The Jp2ResolutionParams type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2ResolutionParams | Constructor
Top
Properties
 | Name | Description
Public property | ResolutionHorizontal |
Public property | ResolutionType |
Public property | ResolutionUnit |
Public property | ResolutionVertical |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams Constructor

Constructor

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ResolutionParams()
Public Sub New
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams Properties

The Jp2ResolutionParams type exposes the following members.

Properties
 | Name | Description
Public property | ResolutionHorizontal |
Public property | ResolutionType |
Public property | ResolutionUnit |
Public property | ResolutionVertical |
Top
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams.ResolutionHorizontal Property

Jp2ResolutionParamsResolutionHorizontal Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ResolutionHorizontal { get; set; }
Public Property ResolutionHorizontal As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams.ResolutionType Property

Jp2ResolutionParamsResolutionType Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ResolutionTypes ResolutionType { get; set; }
Public Property ResolutionType As Jp2ResolutionTypes
    Get
    Set

Property Value

Type: Jp2ResolutionTypes
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams.ResolutionUnit Property

Jp2ResolutionParamsResolutionUnit Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ResolutionUnits ResolutionUnit { get; set; }
Public Property ResolutionUnit As Jp2ResolutionUnits
    Get
    Set

Property Value

Type: Jp2ResolutionUnits
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams.ResolutionVertical Property

Jp2ResolutionParamsResolutionVertical Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ResolutionVertical { get; set; }
Public Property ResolutionVertical As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionParams Methods

The Jp2ResolutionParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2ResolutionParams Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionTypes Enumeration

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2ResolutionTypes
Public Enumeration Jp2ResolutionTypes
Members
Member name | Description
Capture | For scan resolution
Display |
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2ResolutionUnits Enumeration

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2ResolutionUnits
Public Enumeration Jp2ResolutionUnits
Members
Member name | Description
DotsPerInch |
DotsPerCentimeter |
DotsPerMeter |
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2SpeedMode Enumeration

Values for setting the encoding speed.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Jp2SpeedMode
Public Enumeration Jp2SpeedMode
Members
Member name | Description
Fast | Encoding speed mode. Fast but lower quality. Default.
Accurate | Encoding speed mode. Higher quality but slower.
Remarks
Fast mode offers higher speed but may create images with lower quality. Default is Fast.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2WaveletFilter Enumeration

Note: This API is now obsolete.

Wavelet filtering method.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("JPEG2000WaveletFilter enum should be used.")]
public enum Jp2WaveletFilter
<ObsoleteAttribute("JPEG2000WaveletFilter enum should be used.")>
Public Enumeration Jp2WaveletFilter
Members
Member name | Description
FiveThree | Reversible filter
NineSeven | Irreversible filter
Remarks
JPEG2000WaveletFilter enum should be used instead.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2XmlParser Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jp2XmlParser

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jp2XmlParser
Public Class Jp2XmlParser

The Jp2XmlParser type exposes the following members.

Constructors
 | Name | Description
Public method | Jp2XmlParser | Initializes a new instance of the Jp2XmlParser class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage | XML data stored in JPEG2000 stream will be obtained.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2XmlParser Constructor

Initializes a new instance of the Jp2XmlParser class

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2XmlParser()
Public Sub New
See Also

Reference

Jp2XmlParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2XmlParser Methods

The Jp2XmlParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage | XML data stored in JPEG2000 stream will be obtained.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jp2XmlParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jp2XmlParser.ParseFromImage Method

Jp2XmlParserParseFromImage Method

XML data stored in JPEG2000 stream will be obtained.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string[] ParseFromImage(
    Stream stream
)
Public Overridable Function ParseFromImage (
    stream As Stream
) As String()

Parameters

stream
Type: System.IOStream
JPEG2000 stream

Return Value

Type: String
XmlBoxCollection
See Also

Reference

Jp2XmlParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder Class

The class derived from ImageEncoder that encodes JPEG2000 images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.Codec.Jpeg2000Jpeg2000Encoder

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jpeg2000Encoder : ImageEncoder
Public Class Jpeg2000Encoder
    Inherits ImageEncoder

The Jpeg2000Encoder type exposes the following members.

Constructors
 | Name | Description
Public method | Jpeg2000Encoder | Creates a new instance of a Jpeg2000Encoder.
Public method | Jpeg2000Encoder(Jp2CompressionMode, UInt32) | Creates a new instance of a Jpeg2000Encoder specifying the compression rate.
Top
Properties
 | Name | Description
Public property | CompressionMode | Gets or Sets the Jp2CompressionMode to use when compressing an image.
 | CompressionQuality | Gets or sets the compression quality to use when compressing an image if CompressionMode = Quality.
 | CompressionSize | Gets or sets the compression size to use when compressing an image if CompressionMode = Size.
Public property | EncoderOptions | Gets or sets encoder specific options that will be used by default for the entire image.
Public property | EnhancedRegions | Gets a collection of Enhanced Regions that can be set at a higher quality level than the rest of the image during compression.
Public property | FileFormat | Gets or sets the file format to generate (JP2, JPEG2000 codestream, or JPX).
Public property | IPData | Gets or sets intellectual property rights data to be encoded with the image.
Public property | IptcTags | Gets or sets IPTC data that will be stored in the encoded image.
Public property | Precision | Gets or sets a value indicating the precision of the wavelet coefficients.
Public property | QualityStyle | Gets or sets a value indicating the quality mode during lossy compression.
Public property | ResolutionParams | Set property for storing information of resolution. Refer to definition of Jp2ResolutionParams.
Public property | SpeedMode | Gets or sets the speed mode (Fast or Accurate) to use during lossy compression.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by the Jpeg2000Encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | TileSize | Gets or sets the size in pixels of each individual tile.
Public property | UuidBoxes | Gets or sets UuidBox metadata to be stored in the encoded image.
Public property | UuidInfoBoxes | Gets or sets UuidInfoBox metadata to be stored in the encoded image.
Public property | WriteTileLengthMarker | Gets or sets a value indicating if a tile length marker is written to the encoded image.
Public property | XmlBoxes | Gets or sets XML metadata to be stored with the image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEncoderOptions | Returns the encoder options for a specific tile and component.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PixelFormatIsSupported |
Public method | Save | Encodes an AtalaImage into the specified stream as a JPEG2000 image. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

To encode JPEG2000 images, invoke the Save(Stream, AtalaImage, ProgressEventHandler) method of the Jpeg2000Encoder or create an instance of a Jpeg2000Encoder, and pass it into one of the save methods in an AtalaImage, Workspace, or WorkspaceViewer object.

See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder Constructor

Creates a new instance of a Jpeg2000Encoder.
Overload List
 | Name | Description
Public method | Jpeg2000Encoder | Creates a new instance of a Jpeg2000Encoder.
Public method | Jpeg2000Encoder(Jp2CompressionMode, UInt32) | Creates a new instance of a Jpeg2000Encoder specifying the compression rate.
Top
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder Constructor

Creates a new instance of a Jpeg2000Encoder.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jpeg2000Encoder()
Public Sub New
See Also

Reference

Jpeg2000Encoder Class
Jpeg2000Encoder Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder Constructor (Jp2CompressionMode, UInt32)

Creates a new instance of a Jpeg2000Encoder specifying the compression rate.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jpeg2000Encoder(
    Jp2CompressionMode compressionMode,
    uint compressionVal
)
Public Sub New (
    compressionMode As Jp2CompressionMode,
    compressionVal As UInteger
)

Parameters

compressionMode
Type: Atalasoft.Imaging.Codec.Jpeg2000Jp2CompressionMode
Compression mode: Size or Quality.
compressionVal
Type: SystemUInt32
For Quality case: compression rates ranging 1 (maximum compression) to 100 (lossless). For Size case: maximum file size (in bytes) for lossy compression. In general the final size will be exactly the requested size or a few bytes lower. The minumum value is 500 bytes, which is required for hearder information.
See Also

Reference

Jpeg2000Encoder Class
Jpeg2000Encoder Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder Properties

The Jpeg2000Encoder type exposes the following members.

Properties
 | Name | Description
Public property | CompressionMode | Gets or Sets the Jp2CompressionMode to use when compressing an image.
 | CompressionQuality | Gets or sets the compression quality to use when compressing an image if CompressionMode = Quality.
 | CompressionSize | Gets or sets the compression size to use when compressing an image if CompressionMode = Size.
Public property | EncoderOptions | Gets or sets encoder specific options that will be used by default for the entire image.
Public property | EnhancedRegions | Gets a collection of Enhanced Regions that can be set at a higher quality level than the rest of the image during compression.
Public property | FileFormat | Gets or sets the file format to generate (JP2, JPEG2000 codestream, or JPX).
Public property | IPData | Gets or sets intellectual property rights data to be encoded with the image.
Public property | IptcTags | Gets or sets IPTC data that will be stored in the encoded image.
Public property | Precision | Gets or sets a value indicating the precision of the wavelet coefficients.
Public property | QualityStyle | Gets or sets a value indicating the quality mode during lossy compression.
Public property | ResolutionParams | Set property for storing information of resolution. Refer to definition of Jp2ResolutionParams.
Public property | SpeedMode | Gets or sets the speed mode (Fast or Accurate) to use during lossy compression.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by the Jpeg2000Encoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | TileSize | Gets or sets the size in pixels of each individual tile.
Public property | UuidBoxes | Gets or sets UuidBox metadata to be stored in the encoded image.
Public property | UuidInfoBoxes | Gets or sets UuidInfoBox metadata to be stored in the encoded image.
Public property | WriteTileLengthMarker | Gets or sets a value indicating if a tile length marker is written to the encoded image.
Public property | XmlBoxes | Gets or sets XML metadata to be stored with the image.
Top
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.CompressionMode Property

Jpeg2000EncoderCompressionMode Property

Gets or Sets the Jp2CompressionMode to use when compressing an image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2CompressionMode CompressionMode { get; set; }
Public Property CompressionMode As Jp2CompressionMode
    Get
    Set

Property Value

Type: Jp2CompressionMode
The current Jp2CompressionMode.
Remarks

This property specifies how the Compression property will be used. If the CompressionMode is set to Jp2CompressionMode.Size, the encoder will attempt to make the output stream the same size as the value of CompressionSize. If the CompressionMode is set to Jp2CompressionMode.Quality, the CompressionQuality property is used as a percentage where the target output size will try to be Compression% of the original image size. ranging 1 (maximum compression) to 100 (lossless). A value of 0 of the both properties is for lossless.

Jp2CompressionMode.Quality cannot be used with with JPEG2000WaveletFilter.FiveThree, with JPEG2000QuantizationStyle.Derived or with regions of interest.

See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.CompressionQuality Property

Jpeg2000EncoderCompressionQuality Property

Gets or sets the compression quality to use when compressing an image if CompressionMode = Quality.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint CompressionQuality { get; set; }
Public Property CompressionQuality As UInteger
    Get
    Set

Property Value

Type: UInt32
A percentage of quality (greater or equal to 1 and less than or equal to 100 or 0 for losslesss). If CompressionQuality is set to 99, the image will be visually lossless. If the CompressionQuality is set to 100, the image will be numerically lossless. A value of 1 corresponds to maximum compression, while 0 has the same effect as 100.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the value is less than 0 or greater than 100.
Examples
C#:
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec;
...
AtalaImage myImage = new AtalaImage("imagefile.jpg");
myImage.Save("imagefile.jp2", new Jpeg2000Encoder(Jp2CompressionMode.Quality, 77), null);
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.CompressionSize Property

Jpeg2000EncoderCompressionSize Property

Gets or sets the compression size to use when compressing an image if CompressionMode = Size.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public uint CompressionSize { get; set; }
Public Property CompressionSize As UInteger
    Get
    Set

Property Value

Type: UInt32
The maximum file size (in bytes) for lossy compression. In general the final size will be exactly the requested size or a few bytes lower. The minumum value is 500 bytes, which is required for hearder information. Default value 0 means lossless.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the value is not equal to 0 and less than 500.
Examples
C#:
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec;
...
AtalaImage myImage = new AtalaImage("imagefile.jpg");
myImage.Save("imagefile.jp2", new Jpeg2000Encoder(Jp2CompressionMode.Size, 131072), null);
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.EncoderOptions Property

Jpeg2000EncoderEncoderOptions Property

Gets or sets encoder specific options that will be used by default for the entire image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jpeg2000EncoderOptions EncoderOptions { get; set; }
Public Property EncoderOptions As Jpeg2000EncoderOptions
    Get
    Set

Property Value

Type: Jpeg2000EncoderOptions
Remarks
If the GetEncoderOptions(Int32, Int32) is not overridden to supply specific encoder options for tiles or components, then this property will be used for encoder options for the entire encoded image.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.EnhancedRegions Property

Jpeg2000EncoderEnhancedRegions Property

Gets a collection of Enhanced Regions that can be set at a higher quality level than the rest of the image during compression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2EnhancedRegionCollection EnhancedRegions { get; }
Public ReadOnly Property EnhancedRegions As Jp2EnhancedRegionCollection
    Get

Property Value

Type: Jp2EnhancedRegionCollection
Default is null.
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
The maximum number of regions is 16.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.FileFormat Property

Jpeg2000EncoderFileFormat Property

Gets or sets the file format to generate (JP2, JPEG2000 codestream, or JPX).

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2FileFormat FileFormat { get; set; }
Public Property FileFormat As Jp2FileFormat
    Get
    Set

Property Value

Type: Jp2FileFormat
The default value is Jp2
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown when set to codestream, without a professional license.
Remarks

Default is Jp2. The JP2 and JPX format allow additional information, including resolution and meta-data, to be saved. The use of plain codestream is not recommended. The JPX file format is required to store CMYK and CIE Lab images as well as using unrestricted ICC profile.

The codestream format requires the professional edition.

See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.IPData Property

Jpeg2000EncoderIPData Property

Gets or sets intellectual property rights data to be encoded with the image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IPData { get; set; }
Public Property IPData As String
    Get
    Set

Property Value

Type: String
Remarks
Note that the IP data is not checked or parsed by the library. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.IptcTags Property

Jpeg2000EncoderIptcTags Property

Gets or sets IPTC data that will be stored in the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection IptcTags { get; set; }
Public Property IptcTags As IptcCollection
    Get
    Set

Property Value

Type: IptcCollection
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
IptcCollection is a collection of IptcTags defined in the Atalasoft.Imaging.MetaData namespace. Further details of the IPTC format may be found at www.iptc.org. IPTC data is stored in a UUID data block with a reserved IPTC UUID.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.Precision Property

Jpeg2000EncoderPrecision Property

Gets or sets a value indicating the precision of the wavelet coefficients.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2Precision Precision { get; set; }
Public Property Precision As Jp2Precision
    Get
    Set

Property Value

Type: Jp2Precision
Default is Automatic (automatically select appropriate precision).
Remarks
Default value is Jp2Precision.Automatic. For improved efficiency, the library automatically, depending on the image depth, uses either 16 or 32 bit representation for wavelet coefficients. The use of 32 bit values may slightly improve image quality and the expense of speed and memory requirements.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.QualityStyle Property

Jpeg2000EncoderQualityStyle Property

Gets or sets a value indicating the quality mode during lossy compression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2QualityStyle QualityStyle { get; set; }
Public Property QualityStyle As Jp2QualityStyle
    Get
    Set

Property Value

Type: Jp2QualityStyle
Remarks
Default value is PSNR. For normal images (1:1 pixel display, up to 20 inches viewing distance) VisualSmall or PSNR is recommended. For technical and medical images, PSNR is recommended.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.ResolutionParams Property

Jpeg2000EncoderResolutionParams Property

Set property for storing information of resolution. Refer to definition of Jp2ResolutionParams.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ResolutionParams ResolutionParams { get; set; }
Public Property ResolutionParams As Jp2ResolutionParams
    Get
    Set

Property Value

Type: Jp2ResolutionParams
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.SpeedMode Property

Jpeg2000EncoderSpeedMode Property

Gets or sets the speed mode (Fast or Accurate) to use during lossy compression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2SpeedMode SpeedMode { get; set; }
Public Property SpeedMode As Jp2SpeedMode
    Get
    Set

Property Value

Type: Jp2SpeedMode
Remarks
Default value is Fast. Fast provides high speed compression but may create images with a lower quality. Accurate produces optimal quality but slower speed.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.SupportedPixelFormats Property

Jpeg2000EncoderSupportedPixelFormats Property

Returns an array of PixelFormats supported by the Jpeg2000Encoder.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
Remarks

The Jpeg2000Encoder supports the following pixel formats:

PixelFormat.PixelPixel8bppGrayscalePixelFormat.Pixel16bppGrayscalePixelFormat.Pixel24bppBgrPixelFormat.Pixel32bppBgraPixelFormat.Pixel32bppCmykPixelFormat.Pixel48bppBgrPixelFormat.Pixel64bppBgra
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.TileSize Property

Jpeg2000EncoderTileSize Property

Gets or sets the size in pixels of each individual tile.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size TileSize { get; set; }
Public Property TileSize As Size
    Get
    Set

Property Value

Type: Size
Remarks

An image can be split into smaller tiles, with each tile independently compressed. The basic tile size can be set using this property. Depending on the tile size specified by this property, tiling will be performed automatically inside library.

To encode the image with just one tile, specify (0, 0) or Size.Empty for TileSize.

See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.UuidBoxes Property

Jpeg2000EncoderUuidBoxes Property

Gets or sets UuidBox metadata to be stored in the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidBoxCollection UuidBoxes { get; set; }
Public Property UuidBoxes As UuidBoxCollection
    Get
    Set

Property Value

Type: UuidBoxCollection
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
This property holds UUIDs with associated data in a JPEG2000 format file. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.UuidInfoBoxes Property

Jpeg2000EncoderUuidInfoBoxes Property

Gets or sets UuidInfoBox metadata to be stored in the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidInfoBoxCollection UuidInfoBoxes { get; set; }
Public Property UuidInfoBoxes As UuidInfoBoxCollection
    Get
    Set

Property Value

Type: UuidInfoBoxCollection
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
This property associates a URL with a list of UUIDs. The URL points to information describing the usage and format of the listed UUIDs. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.WriteTileLengthMarker Property

Jpeg2000EncoderWriteTileLengthMarker Property

Gets or sets a value indicating if a tile length marker is written to the encoded image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WriteTileLengthMarker { get; set; }
Public Property WriteTileLengthMarker As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false. The efficiency of decoding regions in a tiled image may be improved by the usage of tile length markers. Tile length markers contain the position of each tile in the JPEG2000 code stream, enabling faster access to tiled image.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.XmlBoxes Property

Jpeg2000EncoderXmlBoxes Property

Gets or sets XML metadata to be stored with the image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] XmlBoxes { get; set; }
Public Property XmlBoxes As String()
    Get
    Set

Property Value

Type: String
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if the current license is not Professional.
Remarks
In Jp2 format file, note that the XML data is not checked for XML compliance or parsed by the library. Adobe XMP data can be stored in this box. See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder Methods

The Jpeg2000Encoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetEncoderOptions | Returns the encoder options for a specific tile and component.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PixelFormatIsSupported |
Public method | Save | Encodes an AtalaImage into the specified stream as a JPEG2000 image. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.GetEncoderOptions Method

Jpeg2000EncoderGetEncoderOptions Method

Returns the encoder options for a specific tile and component.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Jpeg2000EncoderOptions GetEncoderOptions(
    int tileLocation,
    int channel
)
Protected Overridable Function GetEncoderOptions (
    tileLocation As Integer,
    channel As Integer
) As Jpeg2000EncoderOptions

Parameters

tileLocation
Type: SystemInt32
index of tile counting from left-top
channel
Type: SystemInt32
index of color component

Return Value

Type: Jpeg2000EncoderOptions
Returns the encoder options for a specific tile and component.
Remarks
Override this method to set encoder options for a specific tile and component. This method by default will use the EncoderOptions as specified in this Jpeg2000Encoder class. Normally, this method does not need to be overriden.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.PixelFormatIsSupported Method

Jpeg2000EncoderPixelFormatIsSupported Method

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool PixelFormatIsSupported(
    PixelFormat format
)
Protected Function PixelFormatIsSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat

Return Value

Type: Boolean
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000Encoder.Save Method

Jpeg2000EncoderSave Method

Encodes an AtalaImage into the specified stream as a JPEG2000 image.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream to encode to.
image
Type: Atalasoft.ImagingAtalaImage
The image to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress Delegate. Pass in null (Nothing in VB) to ignore progress events

Return Value

Type: Int64
The number of bytes written to the output stream.
Remarks
This method is invoked when using save methods in an AtalaImage, Workspace, or WorkspaceViewer object. In the professional edition, an ICC color profile is stored with the image if the ColorProfile object of the AtalaImage object is set.
See Also

Reference

Jpeg2000Encoder Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions Class

This class specifies encoder options that can be applied to the entire image, a specific tile, or a specific component.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000Jpeg2000EncoderOptions

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Jpeg2000EncoderOptions
Public Class Jpeg2000EncoderOptions

The Jpeg2000EncoderOptions type exposes the following members.

Constructors
 | Name | Description
Public method | Jpeg2000EncoderOptions | Creates a new instance of Jpeg2000EncoderOptions.
Top
Properties
 | Name | Description
Public property | CodeBlockSize | Gets or sets the size of the blocks of coded data.
Public property | CoderOptions | Gets or sets the coder options for faster compression / decompression.
Protected property | GuardBits |
Public property | PacketMarkers | Gets or sets a value that creates special markers at the beginning and/or at the end of each block of a coded area.
Public property | ProgressionOrder | Gets or sets the organization of the coded data.
Public property | QualityLayers | Gets or sets the number of quality layers in the code stream for use with progressive decoding.
Public property | QuantizationStyle | Gets or sets the quantization steps.
Public property | WaveletFilterMethod | Gets or sets a value selecting reversible (WaveletFiveThree) or irreversible (WaveletNineSeven) wavelet filters.
Public property | WaveletLevels | Gets or sets the number of wavelet transformation levels.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _codeBlockSize |
Protected field | _qualityLayers |
Protected field | _waveletLevels |
Top
Remarks

See the [!:Jpeg2000Encoder::EncoderOptions] property in the [!:Atalasoft::Imaging::Codec::Jpeg2000::Jpeg2000Encoder] to set these options for the entire encoded image. To specify different options for different tiles or components, override the [!:Jpeg2000Encoder::GetEncoderOptions] method in the Jp2Encoder class.

QualityLayer, ProgressionOrder, and PacketMarkers are the options which can be set for each tile. WaveletFilterMethod, WaveletLevels, QuantizationStyle, codeBlockSize, and coderOptions are the options which can be set for each component in a given tile.

See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions Constructor

Creates a new instance of Jpeg2000EncoderOptions.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jpeg2000EncoderOptions()
Public Sub New
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions Properties

The Jpeg2000EncoderOptions type exposes the following members.

Properties
 | Name | Description
Public property | CodeBlockSize | Gets or sets the size of the blocks of coded data.
Public property | CoderOptions | Gets or sets the coder options for faster compression / decompression.
Protected property | GuardBits |
Public property | PacketMarkers | Gets or sets a value that creates special markers at the beginning and/or at the end of each block of a coded area.
Public property | ProgressionOrder | Gets or sets the organization of the coded data.
Public property | QualityLayers | Gets or sets the number of quality layers in the code stream for use with progressive decoding.
Public property | QuantizationStyle | Gets or sets the quantization steps.
Public property | WaveletFilterMethod | Gets or sets a value selecting reversible (WaveletFiveThree) or irreversible (WaveletNineSeven) wavelet filters.
Public property | WaveletLevels | Gets or sets the number of wavelet transformation levels.
Top
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.CodeBlockSize Property

Jpeg2000EncoderOptionsCodeBlockSize Property

Gets or sets the size of the blocks of coded data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size CodeBlockSize { get; set; }
Public Property CodeBlockSize As Size
    Get
    Set

Property Value

Type: Size
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown is the width or height is less than 1 or greater than 4096
Remarks

The default value is 64 x 64. Smaller code blocks can aid the decoding of regions of an image and error resilience. A code block may contain no more than 4096 samples, i.e. Size.Width * Size.Height <= 4096.

The code block can be set independently for each component in each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.CoderOptions Property

Jpeg2000EncoderOptionsCoderOptions Property

Gets or sets the coder options for faster compression / decompression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2CoderOptions CoderOptions { get; set; }
Public Property CoderOptions As Jp2CoderOptions
    Get
    Set

Property Value

Type: Jp2CoderOptions
Remarks

The default value is Jp2CoderOptions.Predictable. These options may be combined to create error resilient JPEG2000 streams or for special codec (e.g. hardware coder) for a faster compression / decompression. These options will increase the file size slightly when generating a code stream with the same image quality. We recommend usage of Jp2CoderOptions.Predictable if fault tolerance is important.

The coder options can be set independently for each component in each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.GuardBits Property

Jpeg2000EncoderOptionsGuardBits Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int GuardBits { get; set; }
Protected Property GuardBits As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.PacketMarkers Property

Jpeg2000EncoderOptionsPacketMarkers Property

Gets or sets a value that creates special markers at the beginning and/or at the end of each block of a coded area.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2PacketMarkers PacketMarkers { get; set; }
Public Property PacketMarkers As Jp2PacketMarkers
    Get
    Set

Property Value

Type: Jp2PacketMarkers
Remarks

Default value is Jp2PacketMarkers.Sop | Jp2PacketMarkers.Eph. These markers improve error resilience and improve the speed of decoding a region of an image.

Packet markets can be set independently for each component in each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.ProgressionOrder Property

Jpeg2000EncoderOptionsProgressionOrder Property

Gets or sets the organization of the coded data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Jp2ProgressionOrder ProgressionOrder { get; set; }
Public Property ProgressionOrder As Jp2ProgressionOrder
    Get
    Set

Property Value

Type: Jp2ProgressionOrder
Remarks

Default value is LRCP. The setting LRCP (quality) is most useful when used with several layers. PCRL (position) should be used with precincts.

This value can be independently set for each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.QualityLayers Property

Jpeg2000EncoderOptionsQualityLayers Property

Gets or sets the number of quality layers in the code stream for use with progressive decoding.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int QualityLayers { get; set; }
Public Property QualityLayers As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when set to a value less than 1 or greater than 31.
Remarks

Supports from 1 to 31 quality layers. A higher number of quality layers results in a finer progressive quality improvement. The number of layers can be set for each individual tile.

This value can be independently set for each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.QuantizationStyle Property

Jpeg2000EncoderOptionsQuantizationStyle Property

Gets or sets the quantization steps.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JPEG2000QuantizationStyle QuantizationStyle { get; set; }
Public Property QuantizationStyle As JPEG2000QuantizationStyle
    Get
    Set

Property Value

Type: JPEG2000QuantizationStyle
Remarks

The default value is JPEG2000QuantizationStyle.None. Note that this property may only be set when the irreversible filter (JPEG2000WaveletFilter.FiveThree) is used. The quantization steps can either be derived from a bases quantization step (JPEG2000QuantizationStyle.Derived) or calculated for each image sub-band (JPEG2000QuantizationStyle.Expound). Expound style is recommended.

Quantization style can be independently set for each component in each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.WaveletFilterMethod Property

Jpeg2000EncoderOptionsWaveletFilterMethod Property

Gets or sets a value selecting reversible (WaveletFiveThree) or irreversible (WaveletNineSeven) wavelet filters.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JPEG2000WaveletFilter WaveletFilterMethod { get; set; }
Public Property WaveletFilterMethod As JPEG2000WaveletFilter
    Get
    Set

Property Value

Type: JPEG2000WaveletFilter
Remarks

Default value is WaveletFiveThree.

The wavelet filter can be set independently for each component in each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions.WaveletLevels Property

Jpeg2000EncoderOptionsWaveletLevels Property

Gets or sets the number of wavelet transformation levels.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int WaveletLevels { get; set; }
Public Property WaveletLevels As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 16.
Remarks

Default value is 5. Valid values are in the range 0 (no wavelet analysis) to 16. The memory requirements and compression time increase with the number of transformation levels. A reasonable number of transformation levels are in the range of 4 to 6.

Wavelet levels can be set independently for each component in each tile.

See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions Methods

The Jpeg2000EncoderOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions Fields

The Jpeg2000EncoderOptions type exposes the following members.

Fields
 | Name | Description
Protected field | _codeBlockSize |
Protected field | _qualityLayers |
Protected field | _waveletLevels |
Top
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions._codeBlockSize Field

Jpeg2000EncoderOptions_codeBlockSize Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Size _codeBlockSize
Protected _codeBlockSize As Size

Field Value

Type: Size
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions._qualityLayers Field

Jpeg2000EncoderOptions_qualityLayers Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _qualityLayers
Protected _qualityLayers As Integer

Field Value

Type: Int32
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptions._waveletLevels Field

Jpeg2000EncoderOptions_waveletLevels Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _waveletLevels
Protected _waveletLevels As Integer

Field Value

Type: Int32
See Also

Reference

Jpeg2000EncoderOptions Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Jpeg2000EncoderOptionsCallback Delegate

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate Jpeg2000EncoderOptions Jpeg2000EncoderOptionsCallback(
    int tileLocation,
    int channel
)
Public Delegate Function Jpeg2000EncoderOptionsCallback (
    tileLocation As Integer,
    channel As Integer
) As Jpeg2000EncoderOptions

Parameters

tileLocation
Type: SystemInt32
channel
Type: SystemInt32

Return Value

Type: Jpeg2000EncoderOptions
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


JPEG2000QuantizationStyle Enumeration

The quantization steps can either be derived from a base quantization step, Derived, or calculated for each image sub-band, Expounded.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum JPEG2000QuantizationStyle
Public Enumeration JPEG2000QuantizationStyle
Members
Member name | Description
None | None
Derived | Derived from a bases quantization step
Expounded | Calculated for each image sub-band
Remarks
Expounded style is recommended when using the irreversible filter. The default is None
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


JPEG2000WaveletFilter Enumeration

Wavelet filtering method.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum JPEG2000WaveletFilter
Public Enumeration JPEG2000WaveletFilter
Members
Member name | Description
NineSeven | Irreversible filter
FiveThree | Reversible filter
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


JpxStandardFeatures Enumeration

Standard Reader Requirement Features

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum JpxStandardFeatures
<FlagsAttribute>
Public Enumeration JpxStandardFeatures
Members
Member name | Description
None |
RoiMetadata |
ContentMetadata |
HistoryMetadata |
CreationMetadata |
DigitallySigned |
Checksummed |
GmlMetadata |
Remarks
The Jpx file format contains a box, the Reader Requirements box, specifying the features contained within the file. Many of these features, including the colorspace and existence of IP data, are set automatically by the library during compression. The following additional features are not automatically detected by the library and the JP2CompressSetFeature function may be called to add these features to the Reader Requirement box of a Jpx format file. The function JP2_Decompress_ContainsFeature can be used to check whether one of these features is found in a file. Details of additional features, including the colorspace and existence of IP data, can be obtained using Get Property from Jp2Decoder
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs Class

This class contains information when a [!:E:Atalasoft.Imaging.Codec.Jpeg2000.Jp2Decoder.ProgressiveImage] event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.ImagingImageEventArgs
Atalasoft.Imaging.Codec.Jpeg2000ProgressiveImageEventArgs

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProgressiveImageEventArgs : ImageEventArgs
Public Class ProgressiveImageEventArgs
    Inherits ImageEventArgs

The ProgressiveImageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressiveImageEventArgs | Creates a new instance of ProgressiveImageEventArgs.
Public method | ProgressiveImageEventArgs(AtalaImage) | Creates a new instance of ProgressiveImageEventArgs.
Top
Properties
 | Name | Description
Public property | BytesRead | The number of bytes read from the source stream
Public property | Cancel | Gets or sets a value indicating if the decoding should be cancelled.
Public property | CurrentStep | Gets or sets the current step of progressive decompression.
Public property | Image | Gets or sets the AtalaImage. (Inherited from ImageEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs Constructor

Creates a new instance of ProgressiveImageEventArgs.
Overload List
 | Name | Description
Public method | ProgressiveImageEventArgs | Creates a new instance of ProgressiveImageEventArgs.
Public method | ProgressiveImageEventArgs(AtalaImage) | Creates a new instance of ProgressiveImageEventArgs.
Top
See Also

Reference

ProgressiveImageEventArgs Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs Constructor

Creates a new instance of ProgressiveImageEventArgs.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressiveImageEventArgs()
Public Sub New
See Also

Reference

ProgressiveImageEventArgs Class
ProgressiveImageEventArgs Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs Constructor (AtalaImage)

Creates a new instance of ProgressiveImageEventArgs.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressiveImageEventArgs(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

ProgressiveImageEventArgs Class
ProgressiveImageEventArgs Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs Properties

The ProgressiveImageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BytesRead | The number of bytes read from the source stream
Public property | Cancel | Gets or sets a value indicating if the decoding should be cancelled.
Public property | CurrentStep | Gets or sets the current step of progressive decompression.
Public property | Image | Gets or sets the AtalaImage. (Inherited from ImageEventArgs.)
Top
See Also

Reference

ProgressiveImageEventArgs Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs.BytesRead Property

ProgressiveImageEventArgsBytesRead Property

The number of bytes read from the source stream

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BytesRead { get; set; }
Public Property BytesRead As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ProgressiveImageEventArgs Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs.Cancel Property

ProgressiveImageEventArgsCancel Property

Gets or sets a value indicating if the decoding should be cancelled.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the decoding should be cancelled.
Remarks
This value should be set to true in the event handler to stop loading the image.
See Also

Reference

ProgressiveImageEventArgs Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs.CurrentStep Property

ProgressiveImageEventArgsCurrentStep Property

Gets or sets the current step of progressive decompression.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentStep { get; set; }
Public Property CurrentStep As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ProgressiveImageEventArgs Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventArgs Methods

The ProgressiveImageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProgressiveImageEventArgs Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


ProgressiveImageEventHandler Delegate

Delegate that handles Progressive Reading.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ProgressiveImageEventHandler(
    Object sender,
    ProgressiveImageEventArgs e
)
Public Delegate Sub ProgressiveImageEventHandler (
    sender As Object,
    e As ProgressiveImageEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.Codec.Jpeg2000ProgressiveImageEventArgs
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox Class

A UUID box contains vendor specific data other than that data defined within International Standard. There may be multiple UUID boxes within the file
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000UuidBox

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidBox : IDisposable
Public Class UuidBox
    Implements IDisposable

The UuidBox type exposes the following members.

Constructors
 | Name | Description
Public method | UuidBox | Initializes a new instance of the UuidBox class
Public method | UuidBox(AtalaInt128, Byte) | Creates a new instance of UuidBox.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets vendor specific data.
Public property | Uuid | Gets or sets the UUID value associated with this UUID Box.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UuidBox
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UuidBox and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The existence of any UUID boxes is optional for conforming files. Also, any UUID box shall not contain any information necessary for decoding the image to the extent that is defined within International Standard, and the interpretation of the data in any UUID box shall not change the visual appearance of the image. All readers may ignore any UUID box.
Copy
----------------------------------
 Field Name   Size (bits)   Value
----------------------------------
 UUID          128          varies
 DATA          varies       varies
----------------------------------
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox Constructor

Creates a new instance of UuidBox.
Creates a new instance of UuidBox.
Overload List
 | Name | Description
Public method | UuidBox | Initializes a new instance of the UuidBox class
Public method | UuidBox(AtalaInt128, Byte) | Creates a new instance of UuidBox.
Top
See Also

Reference

UuidBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox Constructor

Initializes a new instance of the UuidBox class

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidBox()
Public Sub New
See Also

Reference

UuidBox Class
UuidBox Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox Constructor (AtalaInt128, Byte[])

UuidBox Constructor (AtalaInt128, Byte)

Creates a new instance of UuidBox.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidBox(
    AtalaInt128 uuid,
    byte[] data
)
Public Sub New (
    uuid As AtalaInt128,
    data As Byte()
)

Parameters

uuid
Type: Atalasoft.ImagingAtalaInt128
128 bit uuid
data
Type: SystemByte
uuid data
See Also

Reference

UuidBox Class
UuidBox Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox Properties

The UuidBox type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets vendor specific data.
Public property | Uuid | Gets or sets the UUID value associated with this UUID Box.
Top
See Also

Reference

UuidBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox.Data Property

UuidBoxData Property

Gets or sets vendor specific data.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual byte[] Data { get; set; }
Public Overridable Property Data As Byte()
    Get
    Set

Property Value

Type: Byte
Remarks
The format of this data is indicated by the value of the UUID field.
See Also

Reference

UuidBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox.Uuid Property

UuidBoxUuid Property

Gets or sets the UUID value associated with this UUID Box.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaInt128 Uuid { get; set; }
Public Overridable Property Uuid As AtalaInt128
    Get
    Set

Property Value

Type: AtalaInt128
Remarks
This field contains 1 16-byte UUID as specified by ISO/IEC 11578:1996. The value of this UUID specifies the format of the vendor specific data stored in the DATA field and the interpretation of that data.
See Also

Reference

UuidBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox Methods

The UuidBox type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox.Dispose Method

UuidBoxDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the UuidBox
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UuidBox and optionally releases the managed resources
Top
See Also

Reference

UuidBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox.Dispose Method

UuidBoxDispose Method

Releases all resources used by the UuidBox

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

UuidBox Class
Dispose Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBox.Dispose Method (Boolean)

UuidBoxDispose Method (Boolean)

Releases the unmanaged resources used by the UuidBox and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

UuidBox Class
Dispose Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection Class

This class contains a collection of UuidBox objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.Codec.Jpeg2000UuidBoxCollection

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidBoxCollection : CollectionBase
Public Class UuidBoxCollection
    Inherits CollectionBase

The UuidBoxCollection type exposes the following members.

Constructors
 | Name | Description
Public method | UuidBoxCollection | Constructor
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | UItem |
Top
Methods
 | Name | Description
Public method | Add | Adds 'source' to the end of the CollectionBase.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the CollectionBase contains 'source'.
Public method | CopyTo | Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.
Public method | Insert | Inserts 'source' into the CollectionBase at 'index'.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of 'source' from the CollectionBase.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection Constructor

Constructor

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidBoxCollection()
Public Sub New
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection Properties

The UuidBoxCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | UItem |
Top
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.UItem Property

UuidBoxCollectionUItem Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual UuidBox this[
    int index
] { get; }
Public Overridable ReadOnly Default Property UItem (
    index As Integer
) As UuidBox
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: UuidBox
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection Methods

The UuidBoxCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds 'source' to the end of the CollectionBase.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the CollectionBase contains 'source'.
Public method | CopyTo | Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.
Public method | Insert | Inserts 'source' into the CollectionBase at 'index'.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of 'source' from the CollectionBase.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.Add Method

UuidBoxCollectionAdd Method

Adds 'source' to the end of the CollectionBase.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    UuidBox source
)
Public Overridable Sub Add (
    source As UuidBox
)

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidBox
given object of UuidBox
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.Contains Method

UuidBoxCollectionContains Method

Determines whether the CollectionBase contains 'source'.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    UuidBox source
)
Public Overridable Function Contains (
    source As UuidBox
) As Boolean

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidBox
given object of UuidBox

Return Value

Type: Boolean
boolean
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.CopyTo Method

UuidBoxCollectionCopyTo Method

Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    UuidBox[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As UuidBox(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidBox
target array of UuidBox
index
Type: SystemInt32
index of target array
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.IndexOf Method

UuidBoxCollectionIndexOf Method

Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    UuidBox source
)
Public Overridable Function IndexOf (
    source As UuidBox
) As Integer

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidBox
given object of UuidBox

Return Value

Type: Int32
the zero-based index of the first occurrence
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.Insert Method

UuidBoxCollectionInsert Method

Inserts 'source' into the CollectionBase at 'index'.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    UuidBox source
)
Public Overridable Sub Insert (
    index As Integer,
    source As UuidBox
)

Parameters

index
Type: SystemInt32
specified index
source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidBox
given object of UuidBox
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxCollection.Remove Method

UuidBoxCollectionRemove Method

Removes the first occurrence of 'source' from the CollectionBase.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    UuidBox source
)
Public Overridable Sub Remove (
    source As UuidBox
)

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidBox
given object of UuidBox
See Also

Reference

UuidBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxParser Class

This class parses UUID information from JPEG2000 images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000UuidBoxParser

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidBoxParser
Public Class UuidBoxParser

The UuidBoxParser type exposes the following members.

Constructors
 | Name | Description
Public method | UuidBoxParser | Creates an instance of a UuidBoxParser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage | Returns metadata containing UUID Box information within a JP2 image stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxParser Constructor

Creates an instance of a UuidBoxParser.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidBoxParser()
Public Sub New
Exceptions
Exception | Condition
[!:AtalasoftLicenseException] | Thrown if the current license is not Professional.
See Also

Reference

UuidBoxParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxParser Methods

The UuidBoxParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage | Returns metadata containing UUID Box information within a JP2 image stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidBoxParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidBoxParser.ParseFromImage Method

UuidBoxParserParseFromImage Method

Returns metadata containing UUID Box information within a JP2 image stream.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual UuidBoxCollection ParseFromImage(
    Stream stream
)
Public Overridable Function ParseFromImage (
    stream As Stream
) As UuidBoxCollection

Parameters

stream
Type: System.IOStream
Jp2 stream

Return Value

Type: UuidBoxCollection
Collection of UUID boxes
See Also

Reference

UuidBoxParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Class

This class contains a UUID Info Box, as defined in the JPEG2000 specification.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidInfoBox : IDisposable
Public Class UuidInfoBox
    Implements IDisposable

The UuidInfoBox type exposes the following members.

Constructors
 | Name | Description
Public method | UuidInfoBox | Creates a new instance of a UuidInfoBox.
Public method | UuidInfoBox(AtalaInt128Collection, UuidUrlBox) | Initializes a new instance of the UuidInfoBox class
Top
Properties
 | Name | Description
Public property | ListBox | Gets a collection of UUID's.
Public property | UrlBox |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UuidInfoBox
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UuidInfoBox and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _listBox |
Protected field | _urlBox |
Top
Remarks
See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Constructor

Overload List
 | Name | Description
Public method | UuidInfoBox | Creates a new instance of a UuidInfoBox.
Public method | UuidInfoBox(AtalaInt128Collection, UuidUrlBox) | Initializes a new instance of the UuidInfoBox class
Top
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Constructor

Creates a new instance of a UuidInfoBox.
Creates a new instance of a UuidInfoBox.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidInfoBox()
Public Sub New
See Also

Reference

UuidInfoBox Class
UuidInfoBox Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Constructor (AtalaInt128Collection, UuidUrlBox)

Initializes a new instance of the UuidInfoBox class

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidInfoBox(
    AtalaInt128Collection listBox,
    UuidUrlBox urlBox
)
Public Sub New (
    listBox As AtalaInt128Collection,
    urlBox As UuidUrlBox
)

Parameters

listBox
Type: Atalasoft.ImagingAtalaInt128Collection
urlBox
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidUrlBox
See Also

Reference

UuidInfoBox Class
UuidInfoBox Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Properties

The UuidInfoBox type exposes the following members.

Properties
 | Name | Description
Public property | ListBox | Gets a collection of UUID's.
Public property | UrlBox |
Top
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox.ListBox Property

UuidInfoBoxListBox Property

Gets a collection of UUID's.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaInt128Collection ListBox { get; }
Public Overridable ReadOnly Property ListBox As AtalaInt128Collection
    Get

Property Value

Type: AtalaInt128Collection
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox.UrlBox Property

UuidInfoBoxUrlBox Property

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual UuidUrlBox UrlBox { get; }
Public Overridable ReadOnly Property UrlBox As UuidUrlBox
    Get

Property Value

Type: UuidUrlBox
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Methods

The UuidInfoBox type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox.Dispose Method

UuidInfoBoxDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the UuidInfoBox
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UuidInfoBox and optionally releases the managed resources
Top
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox.Dispose Method

UuidInfoBoxDispose Method

Releases all resources used by the UuidInfoBox

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

UuidInfoBox Class
Dispose Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox.Dispose Method (Boolean)

UuidInfoBoxDispose Method (Boolean)

Releases the unmanaged resources used by the UuidInfoBox and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

UuidInfoBox Class
Dispose Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox Fields

The UuidInfoBox type exposes the following members.

Fields
 | Name | Description
Protected field | _listBox |
Protected field | _urlBox |
Top
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox._listBox Field

UuidInfoBox_listBox Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaInt128Collection _listBox
Protected _listBox As AtalaInt128Collection

Field Value

Type: AtalaInt128Collection
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBox._urlBox Field

UuidInfoBox_urlBox Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected UuidUrlBox _urlBox
Protected _urlBox As UuidUrlBox

Field Value

Type: UuidUrlBox
See Also

Reference

UuidInfoBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection Class

This class holds a collection of UuidInfoBox objects
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBoxCollection

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidInfoBoxCollection : CollectionBase
Public Class UuidInfoBoxCollection
    Inherits CollectionBase

The UuidInfoBoxCollection type exposes the following members.

Constructors
 | Name | Description
Public method | UuidInfoBoxCollection | Creates a new instance of UuidInfoBoxCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Indexer
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds 'source' to the end of the CollectionBase.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the CollectionBase contains 'source'.
Public method | CopyTo | Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.
Public method | Insert | Inserts 'source' into the CollectionBase at 'index'.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of 'source' from the CollectionBase.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection Constructor

Creates a new instance of UuidInfoBoxCollection.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidInfoBoxCollection()
Public Sub New
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection Properties

The UuidInfoBoxCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Indexer
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.Item Property

UuidInfoBoxCollectionItem Property

Indexer

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Object this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As Object
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Object
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection Methods

The UuidInfoBoxCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds 'source' to the end of the CollectionBase.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the CollectionBase contains 'source'.
Public method | CopyTo | Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.
Public method | Insert | Inserts 'source' into the CollectionBase at 'index'.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of 'source' from the CollectionBase.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.Add Method

UuidInfoBoxCollectionAdd Method

Adds 'source' to the end of the CollectionBase.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    UuidInfoBox source
)
Public Overridable Sub Add (
    source As UuidInfoBox
)

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox
given object of UuidInfoBox
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.Contains Method

UuidInfoBoxCollectionContains Method

Determines whether the CollectionBase contains 'source'.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    UuidInfoBox source
)
Public Overridable Function Contains (
    source As UuidInfoBox
) As Boolean

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox
given object of UuidInfoBox

Return Value

Type: Boolean
boolean
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.CopyTo Method

UuidInfoBoxCollectionCopyTo Method

Copies the entire CollectionBase to 'dest', starting at 'index' of the target array.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    UuidInfoBox[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As UuidInfoBox(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox
target array of UuidInfoBox
index
Type: SystemInt32
index of target array
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.IndexOf Method

UuidInfoBoxCollectionIndexOf Method

Searches for 'source' and returns the zero-based index of the first occurrence within the entire CollectionBase.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    UuidInfoBox source
)
Public Overridable Function IndexOf (
    source As UuidInfoBox
) As Integer

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox
given object of UuidInfoBox

Return Value

Type: Int32
the zero-based index of the first occurrence
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.Insert Method

UuidInfoBoxCollectionInsert Method

Inserts 'source' into the CollectionBase at 'index'.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    UuidInfoBox source
)
Public Overridable Sub Insert (
    index As Integer,
    source As UuidInfoBox
)

Parameters

index
Type: SystemInt32
specified index
source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox
given object of UuidInfoBox
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxCollection.Remove Method

UuidInfoBoxCollectionRemove Method

Removes the first occurrence of 'source' from the CollectionBase.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    UuidInfoBox source
)
Public Overridable Sub Remove (
    source As UuidInfoBox
)

Parameters

source
Type: Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBox
given object of UuidInfoBox
See Also

Reference

UuidInfoBoxCollection Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxParser Class

This class will parse a JPEG2000 image stream for UuidInfoBoxes
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000UuidInfoBoxParser

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidInfoBoxParser
Public Class UuidInfoBoxParser

The UuidInfoBoxParser type exposes the following members.

Constructors
 | Name | Description
Public method | UuidInfoBoxParser | Creates a new instance of UuidInfoBoxParser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage | Get meta-data containing UUID Info Box information within JP2 file format. http://www.jpeg.org/cd15444-1.pdf
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxParser Constructor

Creates a new instance of UuidInfoBoxParser.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidInfoBoxParser()
Public Sub New
Exceptions
Exception | Condition
[!:AtalasoftLicenseException] | Thrown if the current license is not Professional.
See Also

Reference

UuidInfoBoxParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxParser Methods

The UuidInfoBoxParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage | Get meta-data containing UUID Info Box information within JP2 file format. http://www.jpeg.org/cd15444-1.pdf
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidInfoBoxParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidInfoBoxParser.ParseFromImage Method

UuidInfoBoxParserParseFromImage Method

Get meta-data containing UUID Info Box information within JP2 file format. http://www.jpeg.org/cd15444-1.pdf

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual UuidInfoBoxCollection ParseFromImage(
    Stream stream
)
Public Overridable Function ParseFromImage (
    stream As Stream
) As UuidInfoBoxCollection

Parameters

stream
Type: System.IOStream
Jp2 stream

Return Value

Type: UuidInfoBoxCollection
Collection of UUID Info boxes
See Also

Reference

UuidInfoBoxParser Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Class

This class contains URL UUID information.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Jpeg2000UuidUrlBox

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UuidUrlBox
Public Class UuidUrlBox

The UuidUrlBox type exposes the following members.

Constructors
 | Name | Description
Public method | UuidUrlBox | Creates an instance of UuidUrlBox.
Public method | UuidUrlBox(String) | Creates an instance of UuidUrlBox specifying a Url.
Top
Properties
 | Name | Description
Public property | Flag | ReadOnly. This field is reserved for other use.
Public property | Url | This field specifies the URL of the additional information associated with the UUID's contained in the UUID List Box within the same UUID Info Box.
Public property | Vers | ReadOnly property. Version number of the format of this box.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _flag |
Protected field | _vers |
Top
Remarks
See ISO/IEC CD15444-1, Information technology - JPEG2000 image coding system, for more information.
See Also

Reference

Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Constructor

Overload List
 | Name | Description
Public method | UuidUrlBox | Creates an instance of UuidUrlBox.
Public method | UuidUrlBox(String) | Creates an instance of UuidUrlBox specifying a Url.
Top
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Constructor

Creates an instance of UuidUrlBox.
Creates an instance of UuidUrlBox.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidUrlBox()
Public Sub New
See Also

Reference

UuidUrlBox Class
UuidUrlBox Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Constructor (String)

Creates an instance of UuidUrlBox specifying a Url.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UuidUrlBox(
    string url
)
Public Sub New (
    url As String
)

Parameters

url
Type: SystemString
The Url to create the UuidUrlBox with.
See Also

Reference

UuidUrlBox Class
UuidUrlBox Overload
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Properties

The UuidUrlBox type exposes the following members.

Properties
 | Name | Description
Public property | Flag | ReadOnly. This field is reserved for other use.
Public property | Url | This field specifies the URL of the additional information associated with the UUID's contained in the UUID List Box within the same UUID Info Box.
Public property | Vers | ReadOnly property. Version number of the format of this box.
Top
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox.Flag Property

UuidUrlBoxFlag Property

ReadOnly. This field is reserved for other use.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Flag { get; }
Public Overridable ReadOnly Property Flag As Integer
    Get

Property Value

Type: Int32
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox.Url Property

UuidUrlBoxUrl Property

This field specifies the URL of the additional information associated with the UUID's contained in the UUID List Box within the same UUID Info Box.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string Url { get; set; }
Public Overridable Property Url As String
    Get
    Set

Property Value

Type: String
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox.Vers Property

UuidUrlBoxVers Property

ReadOnly property. Version number of the format of this box.

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual byte Vers { get; }
Public Overridable ReadOnly Property Vers As Byte
    Get

Property Value

Type: Byte
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Methods

The UuidUrlBox type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox Fields

The UuidUrlBox type exposes the following members.

Fields
 | Name | Description
Protected field | _flag |
Protected field | _vers |
Top
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox._flag Field

UuidUrlBox_flag Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int _flag
Protected _flag As Integer

Field Value

Type: Int32
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


UuidUrlBox._vers Field

UuidUrlBox_vers Field

Namespace: Atalasoft.Imaging.Codec.Jpeg2000
Assembly: Atalasoft.dotImage.Jpeg2000 (in Atalasoft.dotImage.Jpeg2000.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected byte _vers
Protected _vers As Byte

Field Value

Type: Byte
See Also

Reference

UuidUrlBox Class
Atalasoft.Imaging.Codec.Jpeg2000 Namespace


Atalasoft.Imaging.Codec.Office Namespace

Classes
 | Class | Description
Public class | MsExcelRenderSettings | MsExcel specific render settings.
Public class | MsWordRenderSettings | MsWord specific render settings.
Public class | OfficeAdapterDecoder | An implementation of the MultiFramedImageDecoder class which uses Microsoft Office to render AtalaImages.
 | OfficeDecoder | An implementation of the MultiFramedImageDecoder class allows to render MS Office documents without MS Office installed.
Public class | OfficeDecoderException | Thrown in case of problems in OfficeDecoder.
Public class | OfficeImageInfo | A class containing information about an image that was created by the OfficeAdapterDecoder.
 | OfficeSession | Creates a disposable Office session for use with the OfficeAdapterDecoder for decoding a batch of images.
Public class | RenderSettings | Render settings.
Delegates
 | Delegate | Description
Public delegate | OfficeDisposableTempFileFactory | A delegate for producing DisposableTempFile used by various stages of Office decoding.
Enumerations
 | Enumeration | Description
Public enumeration | OfficeApplicationType | An identifier for a product of the Microsoft Office suite which the OfficeAdapterDecoder is capable of reading.


MsExcelRenderSettings Class

MsExcel specific render settings.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.OfficeMsExcelRenderSettings

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MsExcelRenderSettings
Public Class MsExcelRenderSettings

The MsExcelRenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MsExcelRenderSettings | Initializes the MsExcelRenderSettings class.
Top
Properties
 | Name | Description
Public property | RenderHiddenElements | Hidden elements (rows, columns, sheets) render option. Default value is true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


MsExcelRenderSettings Constructor

Initializes the MsExcelRenderSettings class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MsExcelRenderSettings()
Public Sub New
See Also

Reference

MsExcelRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsExcelRenderSettings Properties

The MsExcelRenderSettings type exposes the following members.

Properties
 | Name | Description
Public property | RenderHiddenElements | Hidden elements (rows, columns, sheets) render option. Default value is true.
Top
See Also

Reference

MsExcelRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsExcelRenderSettings.RenderHiddenElements Property

MsExcelRenderSettingsRenderHiddenElements Property

Hidden elements (rows, columns, sheets) render option. Default value is true.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RenderHiddenElements { get; set; }
Public Property RenderHiddenElements As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

MsExcelRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsExcelRenderSettings Methods

The MsExcelRenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MsExcelRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsWordRenderSettings Class

MsWord specific render settings.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.OfficeMsWordRenderSettings

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MsWordRenderSettings
Public Class MsWordRenderSettings

The MsWordRenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MsWordRenderSettings | Initializes the MsWordRenderSettings class.
Top
Properties
 | Name | Description
Public property | RenderMarkUp | Markup elements (comments, text changes, format changes, etc.) render option. Default value is false.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


MsWordRenderSettings Constructor

Initializes the MsWordRenderSettings class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MsWordRenderSettings()
Public Sub New
See Also

Reference

MsWordRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsWordRenderSettings Properties

The MsWordRenderSettings type exposes the following members.

Properties
 | Name | Description
Public property | RenderMarkUp | Markup elements (comments, text changes, format changes, etc.) render option. Default value is false.
Top
See Also

Reference

MsWordRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsWordRenderSettings.RenderMarkUp Property

MsWordRenderSettingsRenderMarkUp Property

Markup elements (comments, text changes, format changes, etc.) render option. Default value is false.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RenderMarkUp { get; set; }
Public Property RenderMarkUp As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

MsWordRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


MsWordRenderSettings Methods

The MsWordRenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MsWordRenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Class

An implementation of the MultiFramedImageDecoder class which uses Microsoft Office to render AtalaImages.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.OfficeOfficeAdapterDecoder

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OfficeAdapterDecoder : MultiFramedImageDecoder
Public Class OfficeAdapterDecoder
    Inherits MultiFramedImageDecoder

The OfficeAdapterDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | OfficeAdapterDecoder | Initializes a new instance of the OfficeAdapterDecoder class.
Public method | OfficeAdapterDecoder(ICacheStream, DisposableTempFile) | Initializes a new instance of the OfficeAdapterDecoder class.
Public method | OfficeAdapterDecoder(OfficeSession) | Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.
Public method | OfficeAdapterDecoder(OfficeSession, ICacheStream, DisposableTempFile) | Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.
Public method | OfficeAdapterDecoder(ICacheStream, DisposableTempFile, OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory) | Initializes a new instance of the OfficeAdapterDecoder class.
Public method | OfficeAdapterDecoder(OfficeSession, ICacheStream, DisposableTempFile, OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory) | Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.
Top
Properties
 | Name | Description
Public property | PreventInteractivity | Gets or sets a value indicating whether any possible interactive prompts should be prevented during rendering.
Public property | Resolution | Gets or sets the resolution which this decoder will use to render documents. The unit of measure is DPI (dots-per-inch). Default value: 96
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Gets the number of frames in the document contained in the stream. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Gets an OfficeImageInfo object, containing information about the first frame. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Gets an OfficeImageInfo object, containing information about the specified frame. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if this MultiFramedImageDecoder is capable of decoding the data contained within a specified stream. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decodes the first frame of the document. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Decodes the specified frame of the document. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Microsoft Office 2010 or higher must be installed to use this class.
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor

Overload List
 | Name | Description
Public method | OfficeAdapterDecoder | Initializes a new instance of the OfficeAdapterDecoder class.
Public method | OfficeAdapterDecoder(ICacheStream, DisposableTempFile) | Initializes a new instance of the OfficeAdapterDecoder class.
Public method | OfficeAdapterDecoder(OfficeSession) | Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.
Public method | OfficeAdapterDecoder(OfficeSession, ICacheStream, DisposableTempFile) | Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.
Public method | OfficeAdapterDecoder(ICacheStream, DisposableTempFile, OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory) | Initializes a new instance of the OfficeAdapterDecoder class.
Public method | OfficeAdapterDecoder(OfficeSession, ICacheStream, DisposableTempFile, OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory) | Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.
Top
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor

Initializes a new instance of the OfficeAdapterDecoder class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeAdapterDecoder()
Public Sub New
See Also

Reference

OfficeAdapterDecoder Class
OfficeAdapterDecoder Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor (ICache(Stream, DisposableTempFile))

OfficeAdapterDecoder Constructor (ICacheStream, DisposableTempFile)

Initializes a new instance of the OfficeAdapterDecoder class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeAdapterDecoder(
    ICache<Stream, DisposableTempFile> fileCache
)
Public Sub New (
    fileCache As ICache(Of Stream, DisposableTempFile)
)

Parameters

fileCache
Type: Atalasoft.Imaging.Codec.Office.CachingICache Stream, DisposableTempFile
A cache responsible for managing the temporary PDFs generated by Office.
See Also

Reference

OfficeAdapterDecoder Class
OfficeAdapterDecoder Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor (OfficeSession)

Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeAdapterDecoder(
    OfficeSession officeSession
)
Public Sub New (
    officeSession As OfficeSession
)

Parameters

officeSession
Type: Atalasoft.Imaging.Codec.OfficeOfficeSession
The instance of OfficeSession to use.
Exceptions
Exception Condition
ArgumentNullException Thrown when the OfficeSession argument is
Copy
null
.
See Also

Reference

OfficeAdapterDecoder Class
OfficeAdapterDecoder Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor (OfficeSession, ICache(Stream, DisposableTempFile))

OfficeAdapterDecoder Constructor (OfficeSession, ICacheStream, DisposableTempFile)

Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeAdapterDecoder(
    OfficeSession officeSession,
    ICache<Stream, DisposableTempFile> fileCache
)
Public Sub New (
    officeSession As OfficeSession,
    fileCache As ICache(Of Stream, DisposableTempFile)
)

Parameters

officeSession
Type: Atalasoft.Imaging.Codec.OfficeOfficeSession
The instance of OfficeSession to use.
fileCache
Type: Atalasoft.Imaging.Codec.Office.CachingICache Stream, DisposableTempFile
A cache responsible for managing the temporary PDFs generated by Office.
Exceptions
Exception Condition
ArgumentNullException Thrown when the OfficeSession argument is
Copy
null
.
See Also

Reference

OfficeAdapterDecoder Class
OfficeAdapterDecoder Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor (ICache(Stream, DisposableTempFile), OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory)

OfficeAdapterDecoder Constructor (ICacheStream, DisposableTempFile, OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory)

Initializes a new instance of the OfficeAdapterDecoder class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeAdapterDecoder(
    ICache<Stream, DisposableTempFile> fileCache,
    OfficeDisposableTempFileFactory inputDocumentTempFileFactory,
    OfficeDisposableTempFileFactory outputPdfTempFileFactory
)
Public Sub New (
    fileCache As ICache(Of Stream, DisposableTempFile),
    inputDocumentTempFileFactory As OfficeDisposableTempFileFactory,
    outputPdfTempFileFactory As OfficeDisposableTempFileFactory
)

Parameters

fileCache
Type: Atalasoft.Imaging.Codec.Office.CachingICache Stream, DisposableTempFile
A cache responsible for managing the temporary PDFs generated by Office.
inputDocumentTempFileFactory
Type: Atalasoft.Imaging.Codec.OfficeOfficeDisposableTempFileFactory
A factory delegate for creating the DisposableTempFile which will be used to store the input document for Office to open.
outputPdfTempFileFactory
Type: Atalasoft.Imaging.Codec.OfficeOfficeDisposableTempFileFactory
A factory delegate for creating the DisposableTempFile which will be used to store the output intermediary PDF for Office to export.
See Also

Reference

OfficeAdapterDecoder Class
OfficeAdapterDecoder Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Constructor (OfficeSession, ICache(Stream, DisposableTempFile), OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory)

OfficeAdapterDecoder Constructor (OfficeSession, ICacheStream, DisposableTempFile, OfficeDisposableTempFileFactory, OfficeDisposableTempFileFactory)

Initializes a new instance of the OfficeAdapterDecoder class using the provided OfficeSession.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeAdapterDecoder(
    OfficeSession officeSession,
    ICache<Stream, DisposableTempFile> fileCache,
    OfficeDisposableTempFileFactory inputDocumentTempFileFactory,
    OfficeDisposableTempFileFactory outputPdfTempFileFactory
)
Public Sub New (
    officeSession As OfficeSession,
    fileCache As ICache(Of Stream, DisposableTempFile),
    inputDocumentTempFileFactory As OfficeDisposableTempFileFactory,
    outputPdfTempFileFactory As OfficeDisposableTempFileFactory
)

Parameters

officeSession
Type: Atalasoft.Imaging.Codec.OfficeOfficeSession
The instance of OfficeSession to use.
fileCache
Type: Atalasoft.Imaging.Codec.Office.CachingICache Stream, DisposableTempFile
A cache responsible for managing the temporary PDFs generated by Office.
inputDocumentTempFileFactory
Type: Atalasoft.Imaging.Codec.OfficeOfficeDisposableTempFileFactory
A factory delegate for creating the DisposableTempFile which will be used to store the input document for Office to open.
outputPdfTempFileFactory
Type: Atalasoft.Imaging.Codec.OfficeOfficeDisposableTempFileFactory
A factory delegate for creating the DisposableTempFile which will be used to store the output intermediary PDF for Office to export.
Exceptions
Exception Condition
ArgumentNullException Thrown when the OfficeSession argument is
Copy
null
.
See Also

Reference

OfficeAdapterDecoder Class
OfficeAdapterDecoder Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Properties

The OfficeAdapterDecoder type exposes the following members.

Properties
 | Name | Description
Public property | PreventInteractivity | Gets or sets a value indicating whether any possible interactive prompts should be prevented during rendering.
Public property | Resolution | Gets or sets the resolution which this decoder will use to render documents. The unit of measure is DPI (dots-per-inch). Default value: 96
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.PreventInteractivity Property

OfficeAdapterDecoderPreventInteractivity Property

Gets or sets a value indicating whether any possible interactive prompts should be prevented during rendering.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PreventInteractivity { get; set; }
Public Property PreventInteractivity As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Microsoft Word Fill-In fields is an example of interactive content that shows message boxes during rendering. It may be unacceptable for unattended scenarios, so this property could be used to disable such fields during rendering.
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.Resolution Property

OfficeAdapterDecoderResolution Property

Gets or sets the resolution which this decoder will use to render documents. The unit of measure is DPI (dots-per-inch). Default value: 96

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder Methods

The OfficeAdapterDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Gets the number of frames in the document contained in the stream. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Gets an OfficeImageInfo object, containing information about the first frame. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Gets an OfficeImageInfo object, containing information about the specified frame. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Determines if this MultiFramedImageDecoder is capable of decoding the data contained within a specified stream. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decodes the first frame of the document. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Decodes the specified frame of the document. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.GetFrameCount Method

OfficeAdapterDecoderGetFrameCount Method

Gets the number of frames in the document contained in the stream.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The stream containing the document.

Return Value

Type: Int32
The number of frames the document contains.
Remarks
For Word, this refers to the pages in the document. For Excel, this refers to the worksheets in the workbook. For PowerPoint, this refers to the slides in the presentation.
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.GetImageInfo Method

OfficeAdapterDecoderGetImageInfo Method

Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Gets an OfficeImageInfo object, containing information about the first frame. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Gets an OfficeImageInfo object, containing information about the specified frame. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.GetImageInfo Method (Stream)

OfficeAdapterDecoderGetImageInfo Method (Stream)

Gets an OfficeImageInfo object, containing information about the first frame.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
The stream containing the document.

Return Value

Type: ImageInfo
An OfficeImageInfo object, containing information about the first image frame.
See Also

Reference

OfficeAdapterDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.GetImageInfo Method (Stream, Int32)

OfficeAdapterDecoderGetImageInfo Method (Stream, Int32)

Gets an OfficeImageInfo object, containing information about the specified frame.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
The stream containing the document.
frameIndex
Type: SystemInt32
The index of the image frame to obtain information about.

Return Value

Type: ImageInfo
An OfficeImageInfo object, containing information about the specified image frame.
See Also

Reference

OfficeAdapterDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.IsValidFormat Method

OfficeAdapterDecoderIsValidFormat Method

Determines if this MultiFramedImageDecoder is capable of decoding the data contained within a specified stream.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The stream to check the contents of.

Return Value

Type: Boolean
Copy
true
, if this decoder can read the data contained in the stream, otherwise
Copy
false
.
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.Read Method

OfficeAdapterDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Decodes the first frame of the document. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Decodes the specified frame of the document. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

OfficeAdapterDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.Read Method (Stream, ProgressEventHandler)

OfficeAdapterDecoderRead Method (Stream, ProgressEventHandler)

Decodes the first frame of the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream containing the document.
progress
Type: Atalasoft.ImagingProgressEventHandler
A delegate for receiving progress notifications.

Return Value

Type: AtalaImage
An AtalaImage representation of the first frame of the document.
See Also

Reference

OfficeAdapterDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeAdapterDecoder.Read Method (Stream, Int32, ProgressEventHandler)

OfficeAdapterDecoderRead Method (Stream, Int32, ProgressEventHandler)

Decodes the specified frame of the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream containing the document.
frameIndex
Type: SystemInt32
The index of the frame to decode.
progress
Type: Atalasoft.ImagingProgressEventHandler
A delegate for receiving progress notifications.

Return Value

Type: AtalaImage
An AtalaImage representation of the specified frame of the document.
See Also

Reference

OfficeAdapterDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeApplicationType Enumeration

An identifier for a product of the Microsoft Office suite which the OfficeAdapterDecoder is capable of reading.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OfficeApplicationType
Public Enumeration OfficeApplicationType
Members
Member name | Description
Word | Microsoft Office Word.
Excel | Microsoft Office Excel.
PowerPoint | Microsoft Office PowerPoint.
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder Class

An implementation of the MultiFramedImageDecoder class allows to render MS Office documents without MS Office installed.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.OfficeOfficeDecoder

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OfficeDecoder : MultiFramedImageDecoder,
    ITextFormatDecoder
Public Class OfficeDecoder
    Inherits MultiFramedImageDecoder
    Implements ITextFormatDecoder

The OfficeDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | OfficeDecoder | Initializes a new instance of the OfficeDecoder class.
Top
Properties
 | Name | Description
Public property | RenderSettings | Gets or sets render settings.
Public property | Resolution | Gets or sets a value that specifies the DPI to use when rendering a document. Default value is 96.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retrieve information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetTextDocument | Creates the text document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
By default this decoder renders only 3000 pages. To extend this limit see the 'example section.
Examples
To configure page limit, you should add the next line to app.config file:
Copy
<Atalasoft>
    <OfficeDecoder LimitsPageCount="3000"/>
    <!-- Components sections -->
    ...
</Atalasoft>
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace
Atalasoft.SharedAtalasoftConfigSection


OfficeDecoder Constructor

Initializes a new instance of the OfficeDecoder class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeDecoder()
Public Sub New
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder Properties

The OfficeDecoder type exposes the following members.

Properties
 | Name | Description
Public property | RenderSettings | Gets or sets render settings.
Public property | Resolution | Gets or sets a value that specifies the DPI to use when rendering a document. Default value is 96.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Top
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.RenderSettings Property

OfficeDecoderRenderSettings Property

Gets or sets render settings.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderSettings RenderSettings { get; set; }
Public Property RenderSettings As RenderSettings
    Get
    Set

Property Value

Type: RenderSettings
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.Resolution Property

OfficeDecoderResolution Property

Gets or sets a value that specifies the DPI to use when rendering a document. Default value is 96.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder Methods

The OfficeDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameCount | Returns the number of frames in the image (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Retrieve information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetTextDocument | Creates the text document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Checks the stream to determine if the image can be read by the decoder that derives this class. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.GetFrameCount Method

OfficeDecoderGetFrameCount Method

Returns the number of frames in the image

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The input Stream.

Return Value

Type: Int32
The number of frames in the image
Exceptions
Exception | Condition
ArgumentException | stream is null.
OfficeDecoderException | error decoding MS Office document.
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.GetImageInfo Method

OfficeDecoderGetImageInfo Method

Retrieve information in an image stored in a file without decoding the image data.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Retrieve information from an image stored in a file without decoding the image data. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.GetImageInfo Method (Stream)

OfficeDecoderGetImageInfo Method (Stream)

Retrieve information from an image stored in a file without decoding the image data.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image such as size and color depth.
Exceptions
Exception | Condition
ArgumentException | stream is null.
OfficeDecoderException | error decoding MS Office document.
See Also

Reference

OfficeDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.GetImageInfo Method (Stream, Int32)

OfficeDecoderGetImageInfo Method (Stream, Int32)

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.

Return Value

Type: ImageInfo
An ImageInfo object containing information about the image such as size and color depth.
Exceptions
Exception | Condition
ArgumentException | stream is null.
ArgumentOutOfRangeException | frameIndex is not in range [0, frameCount] (See GetFrameCount(Stream) for details.).
OfficeDecoderException | error decoding MS Office document.
See Also

Reference

OfficeDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.GetTextDocument Method

OfficeDecoderGetTextDocument Method

Creates the text document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ITextDocument GetTextDocument(
    Stream stream
)
Public Function GetTextDocument (
    stream As Stream
) As ITextDocument

Parameters

stream
Type: System.IOStream
The document stream.

Return Value

Type: ITextDocument
ITextDocument that allows text information extraction.

Implements

ITextFormatDecoderGetTextDocument(Stream)
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.IsValidFormat Method

OfficeDecoderIsValidFormat Method

Checks the stream to determine if the image can be read by the decoder that derives this class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.

Return Value

Type: Boolean
True if the encoded image can be read by this decoder, otherwise false.
Exceptions
Exception | Condition
ArgumentException | stream is null.
OfficeDecoderException | error decoding MS Office document.
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.Read Method

OfficeDecoderRead Method

Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Decode an image in a specified image Stream. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a given frame in an encoded image using this decoder. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

OfficeDecoder Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.Read Method (Stream, ProgressEventHandler)

OfficeDecoderRead Method (Stream, ProgressEventHandler)

Decode an image in a specified image Stream.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream containing the encoded image data.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the decoded image.
Exceptions
Exception | Condition
ArgumentException | stream is null.
OfficeDecoderException | error decoding MS Office document.
See Also

Reference

OfficeDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoder.Read Method (Stream, Int32, ProgressEventHandler)

OfficeDecoderRead Method (Stream, Int32, ProgressEventHandler)

Read a given frame in an encoded image using this decoder.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The input Stream.
frameIndex
Type: SystemInt32
The zero based frame index.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
An AtalaImage containing the decoded image.
Exceptions
Exception | Condition
ArgumentException | stream is null.
ArgumentOutOfRangeException | frameIndex is not in range [0, frameCount] (See GetFrameCount(Stream) for details.).
OfficeDecoderException | error decoding MS Office document. incorrect file format.
See Also

Reference

OfficeDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Class

Thrown in case of problems in OfficeDecoder.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ExceptionsAtalaException
Atalasoft.Imaging.Codec.OfficeOfficeDecoderException

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OfficeDecoderException : AtalaException
<SerializableAttribute>
Public Class OfficeDecoderException
    Inherits AtalaException

The OfficeDecoderException type exposes the following members.

Constructors
 | Name | Description
Public method | OfficeDecoderException | Initializes a new instance of the OfficeDecoderException class.
Public method | OfficeDecoderException(String) | Initializes a new instance of the OfficeDecoderException class.
Protected method | OfficeDecoderException(SerializationInfo, StreamingContext) | Initializes a new instance of the OfficeDecoderException class.
Public method | OfficeDecoderException(String, Exception) | Initializes a new instance of the OfficeDecoderException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Constructor

Overload List
 | Name | Description
Public method | OfficeDecoderException | Initializes a new instance of the OfficeDecoderException class.
Public method | OfficeDecoderException(String) | Initializes a new instance of the OfficeDecoderException class.
Protected method | OfficeDecoderException(SerializationInfo, StreamingContext) | Initializes a new instance of the OfficeDecoderException class.
Public method | OfficeDecoderException(String, Exception) | Initializes a new instance of the OfficeDecoderException class.
Top
See Also

Reference

OfficeDecoderException Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Constructor

Initializes a new instance of the OfficeDecoderException class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeDecoderException()
Public Sub New
See Also

Reference

OfficeDecoderException Class
OfficeDecoderException Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Constructor (String)

Initializes a new instance of the OfficeDecoderException class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeDecoderException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

OfficeDecoderException Class
OfficeDecoderException Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the OfficeDecoderException class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OfficeDecoderException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

OfficeDecoderException Class
OfficeDecoderException Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Constructor (String, Exception)

Initializes a new instance of the OfficeDecoderException class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeDecoderException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

OfficeDecoderException Class
OfficeDecoderException Overload
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Properties

The OfficeDecoderException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OfficeDecoderException Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Methods

The OfficeDecoderException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OfficeDecoderException Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDecoderException Events

The OfficeDecoderException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OfficeDecoderException Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeDisposableTempFileFactory Delegate

A delegate for producing DisposableTempFile used by various stages of Office decoding.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate DisposableTempFile OfficeDisposableTempFileFactory(
    OfficeApplicationType officeApplicationType,
    Stream stream
)
Public Delegate Function OfficeDisposableTempFileFactory (
    officeApplicationType As OfficeApplicationType,
    stream As Stream
) As DisposableTempFile

Parameters

officeApplicationType
Type: Atalasoft.Imaging.Codec.OfficeOfficeApplicationType
stream
Type: System.IOStream
The stream containing the document which is being decoded.

Return Value

Type: DisposableTempFile
An instance of DisposableTempFile containing information for a unique, empty temp file.
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo Class

A class containing information about an image that was created by the OfficeAdapterDecoder.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.Codec.OfficeOfficeImageInfo

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class OfficeImageInfo : ImageInfo
Public NotInheritable Class OfficeImageInfo
    Inherits ImageInfo

The OfficeImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets the name of the application which created the document.
Public property | Author | Gets the author of the document.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | OfficeApplicationType | Gets the type of Office application which decoded this image.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | Subject | Gets the subject of the document.
Public property | Tags | Gets the keywords for the document.
Public property | Title | Gets the title of the document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo Properties

The OfficeImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets the name of the application which created the document.
Public property | Author | Gets the author of the document.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | OfficeApplicationType | Gets the type of Office application which decoded this image.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | Subject | Gets the subject of the document.
Public property | Tags | Gets the keywords for the document.
Public property | Title | Gets the title of the document.
Top
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo.ApplicationName Property

OfficeImageInfoApplicationName Property

Gets the name of the application which created the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ApplicationName { get; }
Public ReadOnly Property ApplicationName As String
    Get

Property Value

Type: String
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo.Author Property

OfficeImageInfoAuthor Property

Gets the author of the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; }
Public ReadOnly Property Author As String
    Get

Property Value

Type: String
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo.OfficeApplicationType Property

OfficeImageInfoOfficeApplicationType Property

Gets the type of Office application which decoded this image.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeApplicationType OfficeApplicationType { get; }
Public ReadOnly Property OfficeApplicationType As OfficeApplicationType
    Get

Property Value

Type: OfficeApplicationType
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo.Subject Property

OfficeImageInfoSubject Property

Gets the subject of the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get

Property Value

Type: String
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo.Tags Property

OfficeImageInfoTags Property

Gets the keywords for the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Tags { get; }
Public ReadOnly Property Tags As String
    Get

Property Value

Type: String
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo.Title Property

OfficeImageInfoTitle Property

Gets the title of the document.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeImageInfo Methods

The OfficeImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

OfficeImageInfo Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeSession Class

Creates a disposable Office session for use with the OfficeAdapterDecoder for decoding a batch of images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.OfficeOfficeSession

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class OfficeSession : IDisposable
Public NotInheritable Class OfficeSession
    Implements IDisposable

The OfficeSession type exposes the following members.

Constructors
 | Name | Description
Public method | OfficeSession | Initializes a new instance of the OfficeSession class
Top
Methods
 | Name | Description
Public method | Close | Closes the OfficeSession, releasing any open Office applications.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the OfficeSession is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Open | Opens a new OfficeSession. This session must be Disposed or Closed when it is no longer needed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Using the OfficeSession with the OfficeAdapterDecoder to decode a batch of various documents:
Copy
// By default, the office decoder will create a new session for each document decoded.
// This leads to performance degradation if the same decoder is used to decode several files.
// To remedy this, the OfficeSession class was created, which encapulates a set of running Office
// applications, leaving them open for as long as they are needed.
// The session implements IDisposable, and must be disposed or have the Close method called when it is no longer needed.
using(OfficeSession officeSession = OfficeSession.Open())
{
    OfficeDecoder officeDecoder = new OfficeDecoder(officeSession);

    // With the OfficeDecoder created using the session, we now decode images as usual.
    // The decoder will now use the Office applications provided by the OfficeSession.

    using(Stream wordDocumentStream = File.OpenRead("wordDocument.doc"))
    {
        AtalaImage wordDocumentImage = officeDecoder.Read(wordDocumentStream, null);
    }
    using(Stream wordXmlDocumentStream = File.OpenRead("wordXmlDocument.docx"))
    {
        AtalaImage wordXmlDocumentImage = officeDecoder.Read(wordXmlDocumentStream, null);
    }
    using(Stream excelDocumentStream = File.OpenRead("excelDocument.ppt"))
    {
        AtalaImage excelDocumentImage = officeDecoder.Read(excelDocumentStream, null);
    }
    using(Stream excelXmlDocumentStream = File.OpenRead("excelXmlDocument.pptx"))
    {
        AtalaImage excelXmlDocumentImage = officeDecoder.Read(excelXmlDocumentStream, null);
    }
}
Thread Safety
Static members of this type are not safe for multi-threaded operations. Instance members of this type are safe for multi-threaded operations.
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


OfficeSession Constructor

Initializes a new instance of the OfficeSession class

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeSession()
Public Sub New
See Also

Reference

OfficeSession Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeSession Methods

The OfficeSession type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the OfficeSession, releasing any open Office applications.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the OfficeSession is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Open | Opens a new OfficeSession. This session must be Disposed or Closed when it is no longer needed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OfficeSession Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeSession.Close Method

OfficeSessionClose Method

Closes the OfficeSession, releasing any open Office applications.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

OfficeSession Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeSession.Finalize Method

OfficeSessionFinalize Method

Releases unmanaged resources and performs other cleanup operations before the OfficeSession is reclaimed by garbage collection.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

OfficeSession Class
Atalasoft.Imaging.Codec.Office Namespace


OfficeSession.Open Method

OfficeSessionOpen Method

Opens a new OfficeSession. This session must be Disposed or Closed when it is no longer needed.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static OfficeSession Open()
Public Shared Function Open As OfficeSession

Return Value

Type: OfficeSession
An instance of OfficeSession.
See Also

Reference

OfficeSession Class
Atalasoft.Imaging.Codec.Office Namespace


RenderSettings Class

Render settings.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.OfficeRenderSettings

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RenderSettings
Public Class RenderSettings

The RenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RenderSettings | Initializes the RenderSettings class.
Top
Properties
 | Name | Description
Public property | MsExcelSettings | MsExcel specific render settings.
Public property | MsWordSettings | MsWord specific render settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office Namespace


RenderSettings Constructor

Initializes the RenderSettings class.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderSettings()
Public Sub New
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


RenderSettings Properties

The RenderSettings type exposes the following members.

Properties
 | Name | Description
Public property | MsExcelSettings | MsExcel specific render settings.
Public property | MsWordSettings | MsWord specific render settings.
Top
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


RenderSettings.MsExcelSettings Property

RenderSettingsMsExcelSettings Property

MsExcel specific render settings.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MsExcelRenderSettings MsExcelSettings { get; set; }
Public Property MsExcelSettings As MsExcelRenderSettings
    Get
    Set

Property Value

Type: MsExcelRenderSettings
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


RenderSettings.MsWordSettings Property

RenderSettingsMsWordSettings Property

MsWord specific render settings.

Namespace: Atalasoft.Imaging.Codec.Office
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MsWordRenderSettings MsWordSettings { get; set; }
Public Property MsWordSettings As MsWordRenderSettings
    Get
    Set

Property Value

Type: MsWordRenderSettings
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


RenderSettings Methods

The RenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Office Namespace


Atalasoft.Imaging.Codec.Office.Caching Namespace

Classes
 | Class | Description
Public class | DisposableValueCacheTKey, TValue | An implementation of ICacheTKey, TValue for storing TValue which implement IDisposable. When items are removed from this cache they will automatically be disposed.
Public class | LruDisposableValueCacheTKey, TValue | An implementation of DisposableValueCacheTKey, TValue which stores a fixed number of entries. After this capacity has been reached, the Least Recently Used (LRU) entry will be removed before new ones are added.
Interfaces
 | Interface | Description
Public interface | ICacheTKey, TValue | An interface for a cache.


DisposableValueCache(TKey, TValue) Class

DisposableValueCacheTKey, TValue Class

An implementation of ICacheTKey, TValue for storing TValue which implement IDisposable. When items are removed from this cache they will automatically be disposed.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Office.CachingDisposableValueCacheTKey, TValue
Atalasoft.Imaging.Codec.Office.CachingLruDisposableValueCacheTKey, TValue

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DisposableValueCache<TKey, TValue> : ICache<TKey, TValue>,
    IDisposable
where TValue : IDisposable

Public Class DisposableValueCache(Of TKey, TValue As IDisposable)
    Implements ICache(Of TKey, TValue), IDisposable

Type Parameters

TKey
The type to use as a key to access values in the cache.
TValue
The type to use as a value to store in the cache.

The DisposableValueCacheTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | DisposableValueCacheTKey, TValue | Initializes a new instance of the DisposableValueCacheTKey, TValue class
Top
Properties
 | Name | Description
Protected property | Count | Gets the number of entries in this cache.
Top
Methods
 | Name | Description
Public method | Add | Adds an entry to the cache.
Public method | Clear | Clears all entries from this cache.
Public method | Contains | Gets a value indicating if this cache contains an entry for the given key.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the DisposableValueCacheTKey, TValue is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value associated with the given key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an entry for a given key from this cache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue) Constructor

DisposableValueCacheTKey, TValue Constructor

Initializes a new instance of the DisposableValueCacheTKey, TValue class

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableValueCache()
Public Sub New
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue) Properties

DisposableValueCacheTKey, TValue Properties

The DisposableValueCacheTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Protected property | Count | Gets the number of entries in this cache.
Top
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).Count Property

DisposableValueCacheTKey, TValueCount Property

Gets the number of entries in this cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int Count { get; }
Protected ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue) Methods

DisposableValueCacheTKey, TValue Methods

The DisposableValueCacheTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an entry to the cache.
Public method | Clear | Clears all entries from this cache.
Public method | Contains | Gets a value indicating if this cache contains an entry for the given key.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the DisposableValueCacheTKey, TValue is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value associated with the given key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an entry for a given key from this cache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).Add Method

DisposableValueCacheTKey, TValueAdd Method

Adds an entry to the cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    TKey key,
    TValue value
)
Public Overridable Sub Add (
    key As TKey,
    value As TValue
)

Parameters

key
Type: TKey
The key for the entry.
value
Type: TValue
The value to cache for the key.

Implements

ICacheTKey, TValueAdd(TKey, TValue)
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).Clear Method

DisposableValueCacheTKey, TValueClear Method

Clears all entries from this cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).Contains Method

DisposableValueCacheTKey, TValueContains Method

Gets a value indicating if this cache contains an entry for the given key.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    TKey key
)
Public Function Contains (
    key As TKey
) As Boolean

Parameters

key
Type: TKey
The key for the entry.

Return Value

Type: Boolean
Copy
true
if an entry was found for the key, otherwise
Copy
false
.

Implements

ICacheTKey, TValueContains(TKey)
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).Finalize Method

DisposableValueCacheTKey, TValueFinalize Method

Releases unmanaged resources and performs other cleanup operations before the DisposableValueCacheTKey, TValue is reclaimed by garbage collection.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).GetValue Method

DisposableValueCacheTKey, TValueGetValue Method

Gets the value associated with the given key.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual TValue GetValue(
    TKey key
)
Public Overridable Function GetValue (
    key As TKey
) As TValue

Parameters

key
Type: TKey
The key for the entry.

Return Value

Type: TValue
The value stored in the cache for the given key.

Implements

ICacheTKey, TValueGetValue(TKey)
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


DisposableValueCache(TKey, TValue).Remove Method

DisposableValueCacheTKey, TValueRemove Method

Removes an entry for a given key from this cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    TKey key
)
Public Overridable Sub Remove (
    key As TKey
)

Parameters

key
Type: TKey
The key for the entry.

Implements

ICacheTKey, TValueRemove(TKey)
See Also

Reference

DisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


ICache(TKey, TValue) Interface

ICacheTKey, TValue Interface

An interface for a cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ICache<TKey, TValue> : IDisposable

Public Interface ICache(Of TKey, TValue)
    Inherits IDisposable

Type Parameters

TKey
The type to use as a key to access values in the cache.
TValue
The type to use as a value to store in the cache.

The ICacheTKey, TValue type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an entry to the cache.
Public method | Contains | Gets a value indicating if this cache contains an entry for the given key.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetValue | Gets the value associated with the given key.
Public method | Remove | Removes an entry for a given key from this cache.
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office.Caching Namespace


ICache(TKey, TValue) Methods

ICacheTKey, TValue Methods

The ICacheTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an entry to the cache.
Public method | Contains | Gets a value indicating if this cache contains an entry for the given key.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetValue | Gets the value associated with the given key.
Public method | Remove | Removes an entry for a given key from this cache.
Top
See Also

Reference

ICacheTKey, TValue Interface
Atalasoft.Imaging.Codec.Office.Caching Namespace


ICache(TKey, TValue).Add Method

ICacheTKey, TValueAdd Method

Adds an entry to the cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Add(
    TKey key,
    TValue value
)
Sub Add (
    key As TKey,
    value As TValue
)

Parameters

key
Type: TKey
The key for the entry.
value
Type: TValue
The value to cache for the key.
See Also

Reference

ICacheTKey, TValue Interface
Atalasoft.Imaging.Codec.Office.Caching Namespace


ICache(TKey, TValue).Contains Method

ICacheTKey, TValueContains Method

Gets a value indicating if this cache contains an entry for the given key.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Contains(
    TKey key
)
Function Contains (
    key As TKey
) As Boolean

Parameters

key
Type: TKey
The key for the entry.

Return Value

Type: Boolean
Copy
true
if an entry was found for the key, otherwise
Copy
false
.
See Also

Reference

ICacheTKey, TValue Interface
Atalasoft.Imaging.Codec.Office.Caching Namespace


ICache(TKey, TValue).GetValue Method

ICacheTKey, TValueGetValue Method

Gets the value associated with the given key.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
TValue GetValue(
    TKey key
)
Function GetValue (
    key As TKey
) As TValue

Parameters

key
Type: TKey
The key for the entry.

Return Value

Type: TValue
The value stored in the cache for the given key.
See Also

Reference

ICacheTKey, TValue Interface
Atalasoft.Imaging.Codec.Office.Caching Namespace


ICache(TKey, TValue).Remove Method

ICacheTKey, TValueRemove Method

Removes an entry for a given key from this cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Remove(
    TKey key
)
Sub Remove (
    key As TKey
)

Parameters

key
Type: TKey
The key for the entry.
See Also

Reference

ICacheTKey, TValue Interface
Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue) Class

LruDisposableValueCacheTKey, TValue Class

An implementation of DisposableValueCacheTKey, TValue which stores a fixed number of entries. After this capacity has been reached, the Least Recently Used (LRU) entry will be removed before new ones are added.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.Office.CachingDisposableValueCache TKey, TValue
Atalasoft.Imaging.Codec.Office.CachingLruDisposableValueCacheTKey, TValue

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LruDisposableValueCache<TKey, TValue> : DisposableValueCache<TKey, TValue>
where TValue : IDisposable

Public Class LruDisposableValueCache(Of TKey, TValue As IDisposable)
    Inherits DisposableValueCache(Of TKey, TValue)

Type Parameters

TKey
The type to use as a key to access values in the cache.
TValue
The type to use as a value to store in the cache.

The LruDisposableValueCacheTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | LruDisposableValueCacheTKey, TValue | Initializes a new instance of LruDisposableValueCacheTKey, TValue.
Top
Properties
 | Name | Description
Protected property | Count | Gets the number of entries in this cache. (Inherited from DisposableValueCacheTKey, TValue.)
Top
Methods
 | Name | Description
Public method | Add | Adds an entry to the cache. (Overrides DisposableValueCacheTKey, TValueAdd(TKey, TValue).)
Public method | Clear | Clears all entries from this cache. (Inherited from DisposableValueCacheTKey, TValue.)
Public method | Contains | Gets a value indicating if this cache contains an entry for the given key. (Inherited from DisposableValueCacheTKey, TValue.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the DisposableValueCacheTKey, TValue is reclaimed by garbage collection. (Inherited from DisposableValueCacheTKey, TValue.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value associated with the given key. (Overrides DisposableValueCacheTKey, TValueGetValue(TKey).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an entry for a given key from this cache. (Overrides DisposableValueCacheTKey, TValueRemove(TKey).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue) Constructor

LruDisposableValueCacheTKey, TValue Constructor

Initializes a new instance of LruDisposableValueCacheTKey, TValue.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LruDisposableValueCache(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The maximum number of entries to be stored in this cache.
See Also

Reference

LruDisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue) Properties

LruDisposableValueCacheTKey, TValue Properties

The LruDisposableValueCacheTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Protected property | Count | Gets the number of entries in this cache. (Inherited from DisposableValueCacheTKey, TValue.)
Top
See Also

Reference

LruDisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue) Methods

LruDisposableValueCacheTKey, TValue Methods

The LruDisposableValueCacheTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an entry to the cache. (Overrides DisposableValueCacheTKey, TValueAdd(TKey, TValue).)
Public method | Clear | Clears all entries from this cache. (Inherited from DisposableValueCacheTKey, TValue.)
Public method | Contains | Gets a value indicating if this cache contains an entry for the given key. (Inherited from DisposableValueCacheTKey, TValue.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the DisposableValueCacheTKey, TValue is reclaimed by garbage collection. (Inherited from DisposableValueCacheTKey, TValue.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value associated with the given key. (Overrides DisposableValueCacheTKey, TValueGetValue(TKey).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an entry for a given key from this cache. (Overrides DisposableValueCacheTKey, TValueRemove(TKey).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LruDisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue).Add Method

LruDisposableValueCacheTKey, TValueAdd Method

Adds an entry to the cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Add(
    TKey key,
    TValue value
)
Public Overrides Sub Add (
    key As TKey,
    value As TValue
)

Parameters

key
Type: TKey
The key for the entry.
value
Type: TValue
The value to cache for the key.

Implements

ICacheTKey, TValueAdd(TKey, TValue)
See Also

Reference

LruDisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue).GetValue Method

LruDisposableValueCacheTKey, TValueGetValue Method

Gets the value associated with the given key.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override TValue GetValue(
    TKey key
)
Public Overrides Function GetValue (
    key As TKey
) As TValue

Parameters

key
Type: TKey
The key for the entry.

Return Value

Type: TValue
The value stored in the cache for the given key.

Implements

ICacheTKey, TValueGetValue(TKey)
See Also

Reference

LruDisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


LruDisposableValueCache(TKey, TValue).Remove Method

LruDisposableValueCacheTKey, TValueRemove Method

Removes an entry for a given key from this cache.

Namespace: Atalasoft.Imaging.Codec.Office.Caching
Assembly: Atalasoft.dotImage.Office (in Atalasoft.dotImage.Office.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Remove(
    TKey key
)
Public Overrides Sub Remove (
    key As TKey
)

Parameters

key
Type: TKey
The key for the entry.

Implements

ICacheTKey, TValueRemove(TKey)
See Also

Reference

LruDisposableValueCacheTKey, TValue Class
Atalasoft.Imaging.Codec.Office.Caching Namespace


Atalasoft.Imaging.Codec.Pdf Namespace

Contains classes that give DotImage PDF Encode functionality.
Classes
 | Class | Description
Public class | ColorRenderSettings | Represents a color render settings. For example, this class can be used to setup a background color for PDF document.
Public class | Document | The Document class is the top-level class that represents an existing PDF document.
 | ExtractedImageInfo | Represents a single occurrence of an image on a PDF page. Encapsulates both the image and its location on the page.
Public class | FontSubstitutionMap | Gets a value that lets you define which external fonts are used to render fonts that are not embedded.
Public class | JpegToPdfEncoder | This class is used to convert one or more JPEG files into a single PDF document. This is a lossless process: JPEG image data is rewritten directly into the output PDF without decoding/re-encoding it.
Public class | JpegToPdfPageEventArgs | Represents data present when a JPEG image has been acquired and is about to be translated into a PDF page.
Public class | Page | A page inside an existing PDF document. Obtained through the [!:Pages::Item] property of the Pages class.
Public class | PageCollection | A collection of Page objects.
Public class | Pages | Collection of pages inside a PDF document. Non-creatable. Obtained through the [!:Document::Pages] property of the Document class.
Public class | PdfCodecCompression | PdfCodecCompression is a container class that encapsulates compression settings for a PDF image.
 | PdfDecoder | A MultiFramedImageDecoder used to read PDF pages as images from a Stream.
Public class | PdfEncoder | An ImageEncoder that will write one or more images to a PDF file.
Public class | PdfImage | Contains information about a single image or file to be added to the PDF.
Public class | PdfImageCollection | Contains a collection of PdfImage objects to be saved to PDF.
Public class | PdfImageInfo | Includes information about an image that is created from a PDF page using the PdfDecoder.
Public class | PdfMetadata | Contains general information about the PDF file.
Public class | RenderSettings | Encapsulates all settings that control the render process.
Public class | SegmentProcessEventArgs | Defines an event that is used to process segment images.
Public class | Summary | Provides a summary of the rasterization process. This class is currently empty and has been added for future extension.
Public class | WrongPasswordException | This exception is thrown if a PDF is opened with the wrong password
Enumerations
 | Enumeration | Description
Public enumeration | AnnotationRenderSettings | Settings that control how annotations are rendered.
Public enumeration | ColorTransformationMode | This class is unused now, but may be used in a future version
Public enumeration | PageBoundary | Different PDF page boundaries that each correspond to a specific imaging or finishing process.
Public enumeration | PdfCompressionMode | Describes PDF compression algorithm.
Public enumeration | PdfCompressionType | The type of compression used on the image data.
Public enumeration | PdfPageSizeMode | Used to set the page SizeMode of a PDF document created with PdfEncoder.
Public enumeration | SegmentColorType | Describes color types of pdf segments.
Remarks
Access to PDF encode functionality requires DotImage Document Imaging.


AnnotationRenderSettings Enumeration

Settings that control how annotations are rendered.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum AnnotationRenderSettings
<FlagsAttribute>
Public Enumeration AnnotationRenderSettings
Members
Member name | Description
None |
Render3DAnnotation | Obsolete. Render 3D annotations.
RenderCaretAnnotation | Obsolete. Render Caret annotations.
RenderCircleAnnotation | Obsolete. Render Circle annotations.
RenderFileAttachmentAnnotation | Obsolete. Render FileAttachment annotations.
RenderFreeTextAnnotation | Obsolete. Render FreeText annotations.
RenderHighlightAnnotation | Obsolete. Render Highlight annotations.
RenderInkAnnotation | Obsolete. Render Ink annotations.
RenderLineAnnotation | Obsolete. Render Line annotations.
RenderLinkAnnotation | Obsolete. Render Link annotations.
RenderMovieAnnotation | Obsolete. Render Movie annotations.
RenderPolygonAnnotation | Obsolete. Render Polygon annotations.
RenderPolylineAnnotation | Obsolete. Render Polyline annotations.
RenderPopupAnnotation | Obsolete. Render Popup annotations.
RenderPrinterMarkAnnotation | Obsolete. Render PrinterMark annotations.
RenderRubberStampAnnotation | Obsolete. Render RubberStamp annotations.
RenderScreenAnnotation | Obsolete. Render Screen annotations.
RenderSoundAnnotation | Obsolete. Render Sound annotations.
RenderSquareAnnotation | Obsolete. Render Square annotations.
RenderSquigglyUnderlineAnnotation | Obsolete. Render SquigglyUnderline annotations.
RenderStrikeOutAnnotation | Obsolete. Render StrikeOut annotations.
RenderTextAnnotation | Obsolete. Render Text annotations.
RenderTrapNetAnnotation | Obsolete. Render TrapNet annotations.
RenderUnderlineAnnotation | Obsolete. Render Underline annotations.
RenderWatermarkAnnotation | Obsolete. Render Watermark annotations.
RenderWidgetAnnotation | Render Widget annotations.
RenderNone | Render no annotations.
RenderAll | Render all annotations.
Remarks
These fields can be OR'ed together to combine more than one setting.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


ColorRenderSettings Class

Represents a color render settings. For example, this class can be used to setup a background color for PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfColorRenderSettings

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ColorRenderSettings
Public Class ColorRenderSettings

The ColorRenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ColorRenderSettings | Initializes a new instance of the ColorRenderSettings class.
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets a background color for PDF document.
Public property | RenderMode | This class is unused now, but may be used in a future version
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


ColorRenderSettings Constructor

Initializes a new instance of the ColorRenderSettings class.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorRenderSettings()
Public Sub New
See Also

Reference

ColorRenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


ColorRenderSettings Properties

The ColorRenderSettings type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets a background color for PDF document.
Public property | RenderMode | This class is unused now, but may be used in a future version
Top
See Also

Reference

ColorRenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


ColorRenderSettings.BackColor Property

ColorRenderSettingsBackColor Property

Gets or sets a background color for PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

ColorRenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


ColorRenderSettings.RenderMode Property

ColorRenderSettingsRenderMode Property

This class is unused now, but may be used in a future version

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorTransformationMode RenderMode { get; set; }
Public Property RenderMode As ColorTransformationMode
    Get
    Set

Property Value

Type: ColorTransformationMode
See Also

Reference

ColorRenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


ColorRenderSettings Methods

The ColorRenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorRenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


ColorTransformationMode Enumeration

This class is unused now, but may be used in a future version

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ColorTransformationMode
Public Enumeration ColorTransformationMode
Members
Member name | Description
HighSpeed | This class is unused now, but may be used in a future version
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


Document Class

The Document class is the top-level class that represents an existing PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfDocument

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Document : IDisposable
Public Class Document
    Implements IDisposable

The Document type exposes the following members.

Constructors
 | Name | Description
 | Document(BinaryReader) | Opens an existing document using a BinaryReader.
Public method | Document(Stream) | Opens an existing document using a Stream.
Public method | Document(BinaryReader, String) | Opens an existing password-protected document using a BinaryReader.
Public method | Document(Stream, String) | Opens an existing password-protected document using a Stream.
Top
Properties
 | Name | Description
 | Author | The person who authored this document.
 | Creator | The application that created this document before it was converted to PDF.
 | Keywords | Keywords of this document.
 | Pages | Collection of pages in this document.
 | Producer | The application that converted this document to PDF.
Public property | Resolution | Resolution of this document.
 | Subject | Subject of this document.
 | Title | Title of this document.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Document
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Document and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPageSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


Document Constructor

Overload List
 | Name | Description
 | Document(BinaryReader) | Opens an existing document using a BinaryReader.
Public method | Document(Stream) | Opens an existing document using a Stream.
Public method | Document(BinaryReader, String) | Opens an existing password-protected document using a BinaryReader.
Public method | Document(Stream, String) | Opens an existing password-protected document using a Stream.
Top
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document Constructor (BinaryReader)

Opens an existing document using a BinaryReader.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)

Parameters

reader
Type: System.IOBinaryReader
The reader from which the document is read.
Examples
C#
Copy
using ( FileStream file = new FileStream( path, FileMode.Open, FileAccess.Read ) )
{
   byte[] buffer = new byte[ file.Length ];
   file.Read( buffer, 0, buffer.Length );
   document = <b>new Document( new BinaryReader( new MemoryStream( buffer ) ) )</b>;
}
See Also

Reference

Document Class
Document Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Document Constructor (Stream)

Opens an existing document using a Stream.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A Stream containing a PDF Document
See Also

Reference

Document Class
Document Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Document Constructor (BinaryReader, String)

Opens an existing password-protected document using a BinaryReader.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document(
    BinaryReader reader,
    string password
)
Public Sub New (
    reader As BinaryReader,
    password As String
)

Parameters

reader
Type: System.IOBinaryReader
The reader from which the document is read.
password
Type: SystemString
Password that is required to open this document.
See Also

Reference

Document Class
Document Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Document Constructor (Stream, String)

Opens an existing password-protected document using a Stream.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document(
    Stream stream,
    string password
)
Public Sub New (
    stream As Stream,
    password As String
)

Parameters

stream
Type: System.IOStream
A Stream containing a PDF Document
password
Type: SystemString
Password that is required to open this document.
See Also

Reference

Document Class
Document Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
 | Author | The person who authored this document.
 | Creator | The application that created this document before it was converted to PDF.
 | Keywords | Keywords of this document.
 | Pages | Collection of pages in this document.
 | Producer | The application that converted this document to PDF.
Public property | Resolution | Resolution of this document.
 | Subject | Subject of this document.
 | Title | Title of this document.
Top
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Author Property

DocumentAuthor Property

The person who authored this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; }
Public ReadOnly Property Author As String
    Get

Property Value

Type: String
Examples
C#
Copy
using (FileStream file = new FileStream(path, FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   Console.WriteLine("Author: " + document.Author);
}
Example 1 (VB) (Visual Basic)
Copy
Dim file As FileStream = New FileStream(path, FileMode.Open, FileAccess.Read)
Dim document As Document = New Document(file)
Console.WriteLine("Author: " & document.Author)
file.Close()
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Creator Property

DocumentCreator Property

The application that created this document before it was converted to PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; }
Public ReadOnly Property Creator As String
    Get

Property Value

Type: String
Examples
C#
Copy
using (FileStream file = new FileStream(path, FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   Console.WriteLine("Creator: " + document.Creator);
}
Example 1 (VB) (Visual Basic)
Copy
Dim file As FileStream = New FileStream(path, FileMode.Open, FileAccess.Read)
Dim document As Document = New Document(file)
Console.WriteLine("Author: " & document.Creator)
file.Close()
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Keywords Property

DocumentKeywords Property

Keywords of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Keywords { get; }
Public ReadOnly Property Keywords As String
    Get

Property Value

Type: String
Examples
C#
Copy
using (FileStream file = new FileStream(path, FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   Console.WriteLine("Keywords: " + document.Keywords);
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream(path, FileMode.Open, FileAccess.Read)
Dim document As Document = New Document(file)
Console.WriteLine("Keywords: " & document.Keywords)
file.Close()
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Pages Property

DocumentPages Property

Collection of pages in this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageCollection Pages { get; }
Public ReadOnly Property Pages As PageCollection
    Get

Property Value

Type: PageCollection
Examples
C#
Copy
for (int i=0; i&lt;document.Pages.Count; i++)
{
   pagesListBox.Items.Add( "Page " + (i + 1));
}
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Producer Property

DocumentProducer Property

The application that converted this document to PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Producer { get; }
Public ReadOnly Property Producer As String
    Get

Property Value

Type: String
Examples
C#
Copy
using (FileStream file = new FileStream(path, FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   Console.WriteLine("Producer: " + document.Producer);
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream(path, FileMode.Open, FileAccess.Read)
Dim document As Document = New Document(file)
Console.WriteLine("Producer: " & document.Producer)
file.Close()
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Resolution Property

DocumentResolution Property

Resolution of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; set; }
Public Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Subject Property

DocumentSubject Property

Subject of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get

Property Value

Type: String
Examples
C#
Copy
using (FileStream file = new FileStream(path, FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   Console.WriteLine("Subject: " + document.Subject);
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream(path, FileMode.Open, FileAccess.Read)
Dim document As Document = New Document(file)
Console.WriteLine("Subject: " & document.Subject)
file.Close()
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Title Property

DocumentTitle Property

Title of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
Examples
C#
Copy
using (FileStream file = new FileStream(path, FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   Console.WriteLine("Title: " + document.Title);
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream(path, FileMode.Open, FileAccess.Read)
Dim document As Document = New Document(file)
Console.WriteLine("Title: " & document.Title)
file.Close()
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPageSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Dispose Method

DocumentDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Document
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Document and optionally releases the managed resources
Top
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Dispose Method

DocumentDispose Method

Releases all resources used by the Document

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Document Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Document.Dispose Method (Boolean)

DocumentDispose Method (Boolean)

Releases the unmanaged resources used by the Document and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Document Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Document.GetPageSize Method

DocumentGetPageSize Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size GetPageSize(
    int pageIndex,
    int resolution
)
Public Function GetPageSize (
    pageIndex As Integer,
    resolution As Integer
) As Size

Parameters

pageIndex
Type: SystemInt32
resolution
Type: SystemInt32

Return Value

Type: Size
See Also

Reference

Document Class
Atalasoft.Imaging.Codec.Pdf Namespace


ExtractedImageInfo Class

Represents a single occurrence of an image on a PDF page. Encapsulates both the image and its location on the page.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfExtractedImageInfo

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ExtractedImageInfo
Public Class ExtractedImageInfo

The ExtractedImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExtractedImageInfo | Initializes a new instance of the ExtractedImageInfo class
Top
Properties
 | Name | Description
Public property | Image | Gets the extracted image.
Public property | Transformation | Gets the transformation required to draw the image at the right location.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
C#
Copy
using (FileStream file = new FileStream(
   string.Format(@"in.pdf", fileName), FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   for (int pageIndex=0; pageIndex&lt;document.Pages.Count; pageIndex++)
   {
      Page page = document.Pages[pageIndex];
      ExtractedImageInfo[] images = page.ExtractImages();
      for (int imageIndex = 0; null!=images &amp;&amp; imageIndex&lt;images.Length; imageIndex++)
      {
         images[imageIndex].Image.Save(
            string.Format( @"..\..\out_{0}_{1}.bmp", pageIndex, imageIndex),
            new BmpEncoder(), null);
      }
   }
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream( _
   String.Format("in.pdf", fileName), FileMode.Open, FileAccess.Read))
Dim document As Document = New Document(file)
For pageIndex As Integer = 0 To document.Pages.Count - 1)
      Dim page As Page = document.Pages(pageIndex)
      Dim images() As ExtractedImageInfo = page.ExtractImages()
      For imageIndex As Integer = 0 To images.Length - 1)
         images(imageIndex).Bitmap.Save( _
            String.Format( "..\..\out_{0}_{1}.bmp", pageIndex, imageIndex _
            New BmpEncoder(), Nothing))
      Next
Next
Examples
C#
Copy
using (FileStream file = new FileStream(
   string.Format(@"in.pdf", fileName), FileMode.Open, FileAccess.Read))
{
   Document document = new Document(file);
   for (int pageIndex=0; pageIndex&lt;document.Pages.Count; pageIndex++)
   {
      Page page = document.Pages[pageIndex];
      ExtractedImageInfo[] images = page.ExtractImages();
      for (int imageIndex = 0; null!=images &amp;&amp; imageIndex&lt;images.Length; imageIndex++)
      {
         images[imageIndex].Image.Save(
            string.Format( @"..\..\out_{0}_{1}.bmp", pageIndex, imageIndex),
            new BmpEncoder(), null);
      }
   }
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream( _
   String.Format("in.pdf", fileName), FileMode.Open, FileAccess.Read))
Dim document As Document = New Document(file)
For pageIndex As Integer = 0 To document.Pages.Count - 1)
      Dim page As Page = document.Pages(pageIndex)
      Dim images() As ExtractedImageInfo = page.ExtractImages()
      For imageIndex As Integer = 0 To images.Length - 1)
         images(imageIndex).Bitmap.Save( _
            String.Format( "..\..\out_{0}_{1}.bmp", pageIndex, imageIndex _
            New BmpEncoder(), Nothing))
      Next
Next
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


ExtractedImageInfo Constructor

Initializes a new instance of the ExtractedImageInfo class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExtractedImageInfo(
    AtalaImage image,
    Matrix transformation
)
Public Sub New (
    image As AtalaImage,
    transformation As Matrix
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
transformation
Type: System.Drawing.Drawing2DMatrix
See Also

Reference

ExtractedImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


ExtractedImageInfo Properties

The ExtractedImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets the extracted image.
Public property | Transformation | Gets the transformation required to draw the image at the right location.
Top
See Also

Reference

ExtractedImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


ExtractedImageInfo.Image Property

ExtractedImageInfoImage Property

Gets the extracted image.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

ExtractedImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


ExtractedImageInfo.Transformation Property

ExtractedImageInfoTransformation Property

Gets the transformation required to draw the image at the right location.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Matrix Transformation { get; }
Public ReadOnly Property Transformation As Matrix
    Get

Property Value

Type: Matrix
Remarks

This transformation assumes that the original coordinate system has its origin at the lower-left corner and a unit corresponds to a point (1/72 inch). It also assumes that the image is drawn at the origin of the transformed coordinate system as a unit rectangle.

See Also

Reference

ExtractedImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


ExtractedImageInfo Methods

The ExtractedImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtractedImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap Class

Gets a value that lets you define which external fonts are used to render fonts that are not embedded.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfFontSubstitutionMap

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FontSubstitutionMap
Public Class FontSubstitutionMap

The FontSubstitutionMap type exposes the following members.

Constructors
 | Name | Description
Public method | FontSubstitutionMap | Initializes a new instance of the FontSubstitutionMap class
Top
Properties
 | Name | Description
Public property | FontNames | Gets all the font names included in this map.
Public property | SearchPathA | Gets or sets a semi-colon separated list of folders to search for font files that are included in the substitution map. The folders are searched from left to right until the font file is found.
Top
Methods
 | Name | Description
Public method | Add(String, Stream) | Add a new entry to the map.
Public method | Add(String, String) | Add a new entry to the map.
Public method | Clear | Remove all entries.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap Constructor

Initializes a new instance of the FontSubstitutionMap class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontSubstitutionMap()
Public Sub New
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap Properties

The FontSubstitutionMap type exposes the following members.

Properties
 | Name | Description
Public property | FontNames | Gets all the font names included in this map.
Public property | SearchPathA | Gets or sets a semi-colon separated list of folders to search for font files that are included in the substitution map. The folders are searched from left to right until the font file is found.
Top
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.FontNames Property

FontSubstitutionMapFontNames Property

Gets all the font names included in this map.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ICollection FontNames { get; }
Public ReadOnly Property FontNames As ICollection
    Get

Property Value

Type: ICollection
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.SearchPathA Property

FontSubstitutionMapSearchPathA Property

Gets or sets a semi-colon separated list of folders to search for font files that are included in the substitution map. The folders are searched from left to right until the font file is found.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SearchPathA { get; set; }
Public Property SearchPathA As String
    Get
    Set

Property Value

Type: String
Remarks
The default value is ".;%FONTDIR%". This means that by default font files will be searched in the current folder first and then in the system font directory (typically c:\windows\fonts).
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap Methods

The FontSubstitutionMap type exposes the following members.

Methods
 | Name | Description
Public method | Add(String, Stream) | Add a new entry to the map.
Public method | Add(String, String) | Add a new entry to the map.
Public method | Clear | Remove all entries.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.Add Method

FontSubstitutionMapAdd Method

Add a new entry to the map.
Overload List
 | Name | Description
Public method | Add(String, Stream) | Add a new entry to the map.
Public method | Add(String, String) | Add a new entry to the map.
Top
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.Add Method (String, Stream)

FontSubstitutionMapAdd Method (String, Stream)

Add a new entry to the map.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fontName,
    Stream stream
)
Public Sub Add (
    fontName As String,
    stream As Stream
)

Parameters

fontName
Type: SystemString
The name of the font to map.
stream
Type: System.IOStream
The stream that holds the font program.
See Also

Reference

FontSubstitutionMap Class
Add Overload
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.Add Method (String, String)

FontSubstitutionMapAdd Method (String, String)

Add a new entry to the map.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fontName,
    string file
)
Public Sub Add (
    fontName As String,
    file As String
)

Parameters

fontName
Type: SystemString
The name of the font to map.
file
Type: SystemString

The file that holds the font program.

See Also

Reference

FontSubstitutionMap Class
Add Overload
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.Clear Method

FontSubstitutionMapClear Method

Remove all entries.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


FontSubstitutionMap.Find Method

FontSubstitutionMapFind Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte Find(
    string fontName
)
Public Function Find (
    fontName As String
) As Byte

Parameters

fontName
Type: SystemString

Return Value

Type: Byte
See Also

Reference

FontSubstitutionMap Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder Class

This class is used to convert one or more JPEG files into a single PDF document. This is a lossless process: JPEG image data is rewritten directly into the output PDF without decoding/re-encoding it.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfJpegToPdfEncoder

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegToPdfEncoder
Public Class JpegToPdfEncoder

The JpegToPdfEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | JpegToPdfEncoder | Constructs a new JpegToPdfEncoder object.
Top
Properties
 | Name | Description
Public property | BookmarkTree | Sets or gets a tree of Bookmarks to set for the PDF document created by the Save(Stream, IEnumerableStream) method.
Public property | CreateSelfPrintingPdf | Gets or sets a boolean indicating if the output PDF file should be self-printing
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata should be encrypted. Default is false.
Public property | ErrorRecovery | Sets or gets how to recover from errors.
Public property | Metadata | Gets or sets the metadata information used for this PDF.
Public property | OwnerPassword | Obsolete. Sets or gets an owner password to use for the document. Default value is null (no password).
Public property | PageBorder | Gets or sets the amount of border space around the image in PDF Page Units.
Public property | PageSize | Gets or sets the size of the PDF pages in PDF Page Units.
Public property | Permissions |
Public property | SelfPrintingShowsPrintOptions | When set to true, self-printing shows the print options dialog.
Public property | SelfPrintingShrinksToFitPage | When set to true, self-printing adjusts the content to fit the page size.
Public property | SizeMode | Gets or sets the page size mode for this PDF.
Public property | UserPassword | Obsolete. Sets or gets a user password to use for the document. Default value is null (no password).
Public property | Xmp | Metadata in the Adobe XMP format
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnJpegAquired | Fires the JpegAcquired event
Public method | Save(Stream, IEnumerableStream) | Saves the set of JPEG images into a single multipage PDF document.
Public method | Save(Stream, Stream) | Save the single JPEG image into a single page PDF document.
Public method | Save(Stream, IEnumerableStream, SecureString, SecureString) | Saves the set of JPEG images into a single multipage PDF document.
Public method | Save(Stream, Stream, SecureString, SecureString) | Save the single JPEG image into a single page PDF document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | JpegAquired | This event is used to indicate that a JPEG image has been acquired and is ready to be embedded within a PDF.
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder Constructor

Constructs a new JpegToPdfEncoder object.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegToPdfEncoder()
Public Sub New
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder Properties

The JpegToPdfEncoder type exposes the following members.

Properties
 | Name | Description
Public property | BookmarkTree | Sets or gets a tree of Bookmarks to set for the PDF document created by the Save(Stream, IEnumerableStream) method.
Public property | CreateSelfPrintingPdf | Gets or sets a boolean indicating if the output PDF file should be self-printing
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata should be encrypted. Default is false.
Public property | ErrorRecovery | Sets or gets how to recover from errors.
Public property | Metadata | Gets or sets the metadata information used for this PDF.
Public property | OwnerPassword | Obsolete. Sets or gets an owner password to use for the document. Default value is null (no password).
Public property | PageBorder | Gets or sets the amount of border space around the image in PDF Page Units.
Public property | PageSize | Gets or sets the size of the PDF pages in PDF Page Units.
Public property | Permissions |
Public property | SelfPrintingShowsPrintOptions | When set to true, self-printing shows the print options dialog.
Public property | SelfPrintingShrinksToFitPage | When set to true, self-printing adjusts the content to fit the page size.
Public property | SizeMode | Gets or sets the page size mode for this PDF.
Public property | UserPassword | Obsolete. Sets or gets a user password to use for the document. Default value is null (no password).
Public property | Xmp | Metadata in the Adobe XMP format
Top
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.BookmarkTree Property

JpegToPdfEncoderBookmarkTree Property

Sets or gets a tree of Bookmarks to set for the PDF document created by the Save(Stream, IEnumerableStream) method.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkTree BookmarkTree { get; set; }
Public Property BookmarkTree As PdfBookmarkTree
    Get
    Set

Property Value

Type: PdfBookmarkTree
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.CreateSelfPrintingPdf Property

JpegToPdfEncoderCreateSelfPrintingPdf Property

Gets or sets a boolean indicating if the output PDF file should be self-printing

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CreateSelfPrintingPdf { get; set; }
Public Property CreateSelfPrintingPdf As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.EncryptMetadata Property

JpegToPdfEncoderEncryptMetadata Property

Sets or gets a boolean indicating that metadata should be encrypted. Default is false.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EncryptMetadata { get; set; }
Public Property EncryptMetadata As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.ErrorRecovery Property

JpegToPdfEncoderErrorRecovery Property

Sets or gets how to recover from errors.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegToPdfErrorRecovery ErrorRecovery { get; set; }
Public Property ErrorRecovery As JpegToPdfErrorRecovery
    Get
    Set

Property Value

Type: JpegToPdfErrorRecovery
Remarks
JPEG streams a scanned to pull out meta information, such as size and resolution (if present). If this operation fails, the conversion process can either be aborted or the failing image can be skipped without affecting the output.
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Metadata Property

JpegToPdfEncoderMetadata Property

Gets or sets the metadata information used for this PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentMetadata Metadata { get; set; }
Public Property Metadata As PdfDocumentMetadata
    Get
    Set

Property Value

Type: PdfDocumentMetadata
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.OwnerPassword Property

JpegToPdfEncoderOwnerPassword Property

Note: This API is now obsolete.

Sets or gets an owner password to use for the document. Default value is null (no password).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use Save method with user and owner passwords parameters.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use Save method with user and owner passwords parameters.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.PageBorder Property

JpegToPdfEncoderPageBorder Property

Gets or sets the amount of border space around the image in PDF Page Units.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float PageBorder { get; set; }
Public Property PageBorder As Single
    Get
    Set

Property Value

Type: Single
Set to a value greater than 0, this will create a page with a blank border around the image in PDF Page units (72nds of an inch).
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.PageSize Property

JpegToPdfEncoderPageSize Property

Gets or sets the size of the PDF pages in PDF Page Units.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF PageSize { get; set; }
Public Property PageSize As SizeF
    Get
    Set

Property Value

Type: SizeF
The size of the PDF pages in PDF Page Units.
Remarks

PDF uses an internal resolution of 72dpi, so an 8.5 x 11 inch page would be 612 x 792 pixels.

This value is only used if PdfPageSizeMode is FitToPage.
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Permissions Property

JpegToPdfEncoderPermissions Property

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAccessPermissions Permissions { get; set; }
Public Property Permissions As PdfAccessPermissions
    Get
    Set

Property Value

Type: PdfAccessPermissions
Sets or gets the set of allowable actions for this PDF.
Remarks
PdfAccessPermissions refer to permissions that are allowed within a PDF document. Permissions are granted by allowing actions rather than preventing them.
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.SelfPrintingShowsPrintOptions Property

JpegToPdfEncoderSelfPrintingShowsPrintOptions Property

When set to true, self-printing shows the print options dialog.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfPrintingShowsPrintOptions { get; set; }
Public Property SelfPrintingShowsPrintOptions As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.SelfPrintingShrinksToFitPage Property

JpegToPdfEncoderSelfPrintingShrinksToFitPage Property

When set to true, self-printing adjusts the content to fit the page size.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfPrintingShrinksToFitPage { get; set; }
Public Property SelfPrintingShrinksToFitPage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.SizeMode Property

JpegToPdfEncoderSizeMode Property

Gets or sets the page size mode for this PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageSizeMode SizeMode { get; set; }
Public Property SizeMode As PdfPageSizeMode
    Get
    Set

Property Value

Type: PdfPageSizeMode
The page size mode for this PDF.
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.UserPassword Property

JpegToPdfEncoderUserPassword Property

Note: This API is now obsolete.

Sets or gets a user password to use for the document. Default value is null (no password).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use Save method with user and owner passwords parameters.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use Save method with user and owner passwords parameters.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Xmp Property

JpegToPdfEncoderXmp Property

Metadata in the Adobe XMP format

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Xmp { get; set; }
Public Property Xmp As Byte()
    Get
    Set

Property Value

Type: Byte
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder Methods

The JpegToPdfEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnJpegAquired | Fires the JpegAcquired event
Public method | Save(Stream, IEnumerableStream) | Saves the set of JPEG images into a single multipage PDF document.
Public method | Save(Stream, Stream) | Save the single JPEG image into a single page PDF document.
Public method | Save(Stream, IEnumerableStream, SecureString, SecureString) | Saves the set of JPEG images into a single multipage PDF document.
Public method | Save(Stream, Stream, SecureString, SecureString) | Save the single JPEG image into a single page PDF document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.OnJpegAquired Method

JpegToPdfEncoderOnJpegAquired Method

Fires the JpegAcquired event

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnJpegAquired(
    JpegToPdfPageEventArgs e
)
Protected Overridable Sub OnJpegAquired (
    e As JpegToPdfPageEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.Codec.PdfJpegToPdfPageEventArgs
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Save Method

JpegToPdfEncoderSave Method

Saves the supplied JPEG stream or streams to the give output stream.
Saves the supplied JPEG stream or streams to the give output stream.
Overload List
 | Name | Description
Public method | Save(Stream, IEnumerableStream) | Saves the set of JPEG images into a single multipage PDF document.
Public method | Save(Stream, Stream) | Save the single JPEG image into a single page PDF document.
Public method | Save(Stream, IEnumerableStream, SecureString, SecureString) | Saves the set of JPEG images into a single multipage PDF document.
Public method | Save(Stream, Stream, SecureString, SecureString) | Save the single JPEG image into a single page PDF document.
Top
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Save Method (Stream, IEnumerable(Stream))

JpegToPdfEncoderSave Method (Stream, IEnumerableStream)

Saves the set of JPEG images into a single multipage PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outputStream,
    IEnumerable<Stream> streams
)
Public Sub Save (
    outputStream As Stream,
    streams As IEnumerable(Of Stream)
)

Parameters

outputStream
Type: System.IOStream
The stream where the PDF document will be saved.
streams
Type: System.Collections.GenericIEnumerableStream
An enumerable set of streams that represent JPEG images.
See Also

Reference

JpegToPdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Save Method (Stream, Stream)

JpegToPdfEncoderSave Method (Stream, Stream)

Save the single JPEG image into a single page PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outputStream,
    Stream sourceStream
)
Public Sub Save (
    outputStream As Stream,
    sourceStream As Stream
)

Parameters

outputStream
Type: System.IOStream
The stream where the PDF document will be saved.
sourceStream
Type: System.IOStream
A stream containing a source JPEG image
See Also

Reference

JpegToPdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Save Method (Stream, IEnumerable(Stream), SecureString, SecureString)

JpegToPdfEncoderSave Method (Stream, IEnumerableStream, SecureString, SecureString)

Saves the set of JPEG images into a single multipage PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outputStream,
    IEnumerable<Stream> streams,
    SecureString userPassword,
    SecureString ownerPassword = null
)
Public Sub Save (
    outputStream As Stream,
    streams As IEnumerable(Of Stream),
    userPassword As SecureString,
    Optional ownerPassword As SecureString = Nothing
)

Parameters

outputStream
Type: System.IOStream
The stream where the PDF document will be saved.
streams
Type: System.Collections.GenericIEnumerableStream
An enumerable set of streams that represent JPEG images.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password.
See Also

Reference

JpegToPdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.Save Method (Stream, Stream, SecureString, SecureString)

JpegToPdfEncoderSave Method (Stream, Stream, SecureString, SecureString)

Save the single JPEG image into a single page PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outputStream,
    Stream sourceStream,
    SecureString userPassword,
    SecureString ownerPassword = null
)
Public Sub Save (
    outputStream As Stream,
    sourceStream As Stream,
    userPassword As SecureString,
    Optional ownerPassword As SecureString = Nothing
)

Parameters

outputStream
Type: System.IOStream
The stream where the PDF document will be saved.
sourceStream
Type: System.IOStream
A stream containing a source JPEG image
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password.
See Also

Reference

JpegToPdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder Events

The JpegToPdfEncoder type exposes the following members.

Events
 | Name | Description
Public event | JpegAquired | This event is used to indicate that a JPEG image has been acquired and is ready to be embedded within a PDF.
Top
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfEncoder.JpegAquired Event

JpegToPdfEncoderJpegAquired Event

This event is used to indicate that a JPEG image has been acquired and is ready to be embedded within a PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<JpegToPdfPageEventArgs> JpegAquired
Public Event JpegAquired As EventHandler(Of JpegToPdfPageEventArgs)

Value

Type: SystemEventHandlerJpegToPdfPageEventArgs
Remarks
By modifying the elements of the JpegToPdfPageEventArgs, client code can change the output page size, size mode or border on a page-by-page basis.
See Also

Reference

JpegToPdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs Class

Represents data present when a JPEG image has been acquired and is about to be translated into a PDF page.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.Codec.PdfJpegToPdfPageEventArgs

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegToPdfPageEventArgs : EventArgs
Public Class JpegToPdfPageEventArgs
    Inherits EventArgs

The JpegToPdfPageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | JpegToPdfPageEventArgs | Constructs a new JpegToPdfPageEventArgs class.
Top
Properties
 | Name | Description
Public property | ImageSize | Gets the size of the image in PDF page units (1/72 of an inch).
Public property | PageBorder | The border around the image on the page in PDF page units (1/72 of an inch).
Public property | PageSize | The size of the resulting page in PDF page units (1/72 of an inch).
Public property | SizeMode | Sets or gets how the image will sit in the page.
Public property | Stream | Gets the stream that contains the JPEG image being translated.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs Constructor

Constructs a new JpegToPdfPageEventArgs class.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegToPdfPageEventArgs(
    Stream stm,
    SizeF imageSize
)
Public Sub New (
    stm As Stream,
    imageSize As SizeF
)

Parameters

stm
Type: System.IOStream
The stream that contains the JPEG to be encoded.
imageSize
Type: System.DrawingSizeF
The size of the image in PDF units.
See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs Properties

The JpegToPdfPageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ImageSize | Gets the size of the image in PDF page units (1/72 of an inch).
Public property | PageBorder | The border around the image on the page in PDF page units (1/72 of an inch).
Public property | PageSize | The size of the resulting page in PDF page units (1/72 of an inch).
Public property | SizeMode | Sets or gets how the image will sit in the page.
Public property | Stream | Gets the stream that contains the JPEG image being translated.
Top
See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs.ImageSize Property

JpegToPdfPageEventArgsImageSize Property

Gets the size of the image in PDF page units (1/72 of an inch).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF ImageSize { get; }
Public ReadOnly Property ImageSize As SizeF
    Get

Property Value

Type: SizeF
See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs.PageBorder Property

JpegToPdfPageEventArgsPageBorder Property

The border around the image on the page in PDF page units (1/72 of an inch).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float PageBorder { get; set; }
Public Property PageBorder As Single
    Get
    Set

Property Value

Type: Single
Remarks

Default value is 0.

This property is initialized to the value of PageBorder in the sender. If client code changes this value, it will be reflected in the output PDF but will not affect the sender.

See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs.PageSize Property

JpegToPdfPageEventArgsPageSize Property

The size of the resulting page in PDF page units (1/72 of an inch).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF PageSize { get; set; }
Public Property PageSize As SizeF
    Get
    Set

Property Value

Type: SizeF
Remarks

This property is initialized to the calculated page size for this image. If client code changes this value, it will be reflected in the output PDF but will not affect the sender.

See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs.SizeMode Property

JpegToPdfPageEventArgsSizeMode Property

Sets or gets how the image will sit in the page.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageSizeMode SizeMode { get; set; }
Public Property SizeMode As PdfPageSizeMode
    Get
    Set

Property Value

Type: PdfPageSizeMode
Remarks
If client code changes this value, it will be reflected in the output PDF but will not affect the sender.
See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs.Stream Property

JpegToPdfPageEventArgsStream Property

Gets the stream that contains the JPEG image being translated.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
Remarks
The Position of the stream will be 0. If any stream access is done, the Position must be returned to 0.
See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


JpegToPdfPageEventArgs Methods

The JpegToPdfPageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegToPdfPageEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page Class

A page inside an existing PDF document. Obtained through the [!:Pages::Item] property of the Pages class.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfPage

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Page : IDisposable
Public Class Page
    Implements IDisposable

The Page type exposes the following members.

Properties
 | Name | Description
Public property | ArtBox | Gets the the dimensions of the page's meaningful content intended by the page's creator.
Public property | BleedBox | Gets the dimensions to which the page should be clipped in a production environment.
Public property | CropBox | Gets the maximum imageable area of the physical medium on which the page is to be printed.
 | Height | Gets the viewer height of this page in points.
Public property | MediaBox | Gets the maximum imageable area of the physical medium.
Public property | Rotate | Gets the counter-clockwise rotation in degrees that the viewer should apply to the page.
Public property | SingleImageOnly | Gets a value indicating if the content of this PDF page consists of a single image only.
Public property | TrimBox | Gets the dimensions of the finished page after trimming.
 | Width | Gets the viewer width of this page in points.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Page
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Page and optionally releases the managed resources
 | Draw(Graphics) | Draws the page content using default page boundary and render settings.
Public method | Draw(Graphics, PageBoundary) | Draws the page content using default render settings.
Public method | Draw(Graphics, RenderSettings) | Draws the page content using default page boundary.
Public method | Draw(Graphics, PageBoundary, RenderSettings) | Draws the page content.
Public method | Draw(Graphics, PageBoundary, RenderSettings, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExtractImages | Extracts all images on this page.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


Page Properties

The Page type exposes the following members.

Properties
 | Name | Description
Public property | ArtBox | Gets the the dimensions of the page's meaningful content intended by the page's creator.
Public property | BleedBox | Gets the dimensions to which the page should be clipped in a production environment.
Public property | CropBox | Gets the maximum imageable area of the physical medium on which the page is to be printed.
 | Height | Gets the viewer height of this page in points.
Public property | MediaBox | Gets the maximum imageable area of the physical medium.
Public property | Rotate | Gets the counter-clockwise rotation in degrees that the viewer should apply to the page.
Public property | SingleImageOnly | Gets a value indicating if the content of this PDF page consists of a single image only.
Public property | TrimBox | Gets the dimensions of the finished page after trimming.
 | Width | Gets the viewer width of this page in points.
Top
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.ArtBox Property

PageArtBox Property

Gets the the dimensions of the page's meaningful content intended by the page's creator.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF ArtBox { get; }
Public ReadOnly Property ArtBox As RectangleF
    Get

Property Value

Type: RectangleF
Remarks
Default to the crop box.
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.BleedBox Property

PageBleedBox Property

Gets the dimensions to which the page should be clipped in a production environment.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF BleedBox { get; }
Public ReadOnly Property BleedBox As RectangleF
    Get

Property Value

Type: RectangleF
Remarks
Defaults to the crop box.
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.CropBox Property

PageCropBox Property

Gets the maximum imageable area of the physical medium on which the page is to be printed.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF CropBox { get; }
Public ReadOnly Property CropBox As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Height Property

PageHeight Property

Gets the viewer height of this page in points.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get

Property Value

Type: Double
Examples
C#
Copy
Page page = document.Pages[selectedPage];

const float DPI = 300;
bitmap = new Bitmap(
  (int) ( page.Width / 72 * DPI ),
  (int) ( page.Height / 72 * DPI ) );
Graphics graphics = Graphics.FromImage( bitmap );

float scale = DPI / 72;
graphics.ScaleTransform( scale, scale );

page.Draw( graphics );
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.MediaBox Property

PageMediaBox Property

Gets the maximum imageable area of the physical medium.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF MediaBox { get; }
Public ReadOnly Property MediaBox As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Rotate Property

PageRotate Property

Gets the counter-clockwise rotation in degrees that the viewer should apply to the page.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rotate { get; }
Public ReadOnly Property Rotate As Integer
    Get

Property Value

Type: Int32
Remarks
If the page does not have an explicit viewer rotation set, 0 is returned.
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.SingleImageOnly Property

PageSingleImageOnly Property

Gets a value indicating if the content of this PDF page consists of a single image only.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SingleImageOnly { get; }
Public ReadOnly Property SingleImageOnly As Boolean
    Get

Property Value

Type: Boolean
Remarks
When this value is true, the ExtractImages method is more efficient than rendering the PDF as a Page.
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.TrimBox Property

PageTrimBox Property

Gets the dimensions of the finished page after trimming.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF TrimBox { get; }
Public ReadOnly Property TrimBox As RectangleF
    Get

Property Value

Type: RectangleF
Remarks
Defaults to the crop box.
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Width Property

PageWidth Property

Gets the viewer width of this page in points.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get

Property Value

Type: Double
Examples
C#
Copy
Page page = document.Pages[selectedPage];

const float DPI = 300;
bitmap = new Bitmap(
  (int) ( page.Width / 72 * DPI ),
  (int) ( page.Height / 72 * DPI ) );
Graphics graphics = Graphics.FromImage( bitmap );

float scale = DPI / 72;
graphics.ScaleTransform( scale, scale );

page.Draw( graphics );
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page Methods

The Page type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
 | Draw(Graphics) | Draws the page content using default page boundary and render settings.
Public method | Draw(Graphics, PageBoundary) | Draws the page content using default render settings.
Public method | Draw(Graphics, RenderSettings) | Draws the page content using default page boundary.
Public method | Draw(Graphics, PageBoundary, RenderSettings) | Draws the page content.
Public method | Draw(Graphics, PageBoundary, RenderSettings, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExtractImages | Extracts all images on this page.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Dispose Method

PageDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Page
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Page and optionally releases the managed resources
Top
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Dispose Method

PageDispose Method

Releases all resources used by the Page

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Page Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Dispose Method (Boolean)

PageDispose Method (Boolean)

Releases the unmanaged resources used by the Page and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Page Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Draw Method

PageDraw Method

Draws the page context onto a graphics object.
Overload List
 | Name | Description
 | Draw(Graphics) | Draws the page content using default page boundary and render settings.
Public method | Draw(Graphics, PageBoundary) | Draws the page content using default render settings.
Public method | Draw(Graphics, RenderSettings) | Draws the page content using default page boundary.
Public method | Draw(Graphics, PageBoundary, RenderSettings) | Draws the page content.
Public method | Draw(Graphics, PageBoundary, RenderSettings, Int32) |
Top
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Draw Method (Graphics)

PageDraw Method (Graphics)

Draws the page content using default page boundary and render settings.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Summary Draw(
    Graphics graphics
)
Public Function Draw (
    graphics As Graphics
) As Summary

Parameters

graphics
Type: System.DrawingGraphics
Graphics object to which content is drawn.

Return Value

Type: Summary
Examples
C#
Copy
Page page = document.Pages[selectedPage];

const float DPI = 300;
bitmap = new Bitmap(
  (int) (page.Width / 72 * DPI),
  (int) (page.Height / 72 * DPI));
Graphics graphics = Graphics.FromImage(bitmap);

float scale = DPI / 72;
graphics.ScaleTransform(scale, scale);

page.Draw(graphics);
[New Example] (Visual Basic)
Copy
Dim page As Page = document.Pages(selectedPage];

Dim DPI As Double = 300
bitmap = New Bitmap( _
  (page.Width / 72 * DPI), _
  (page.Height / 72 * DPI))
Dim graphics As Graphics = Graphics.FromImage(bitmap)

Dim scale As Double = DPI / 72
graphics.ScaleTransform(scale, scale)

page.Draw(graphics)
See Also

Reference

Page Class
Draw Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Draw Method (Graphics, PageBoundary)

PageDraw Method (Graphics, PageBoundary)

Draws the page content using default render settings.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Summary Draw(
    Graphics graphics,
    PageBoundary pageBoundary
)
Public Function Draw (
    graphics As Graphics,
    pageBoundary As PageBoundary
) As Summary

Parameters

graphics
Type: System.DrawingGraphics
Graphics object to which content is drawn.
pageBoundary
Type: Atalasoft.Imaging.Codec.PdfPageBoundary
The page boundary that is used to draw the PDF page.

Return Value

Type: Summary
See Also

Reference

Page Class
Draw Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Draw Method (Graphics, RenderSettings)

PageDraw Method (Graphics, RenderSettings)

Draws the page content using default page boundary.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Summary Draw(
    Graphics graphics,
    RenderSettings renderSettings
)
Public Function Draw (
    graphics As Graphics,
    renderSettings As RenderSettings
) As Summary

Parameters

graphics
Type: System.DrawingGraphics
Graphics object to which content is drawn.
renderSettings
Type: Atalasoft.Imaging.Codec.PdfRenderSettings
Settings that control the render process.

Return Value

Type: Summary
See Also

Reference

Page Class
Draw Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Draw Method (Graphics, PageBoundary, RenderSettings)

PageDraw Method (Graphics, PageBoundary, RenderSettings)

Draws the page content.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Summary Draw(
    Graphics graphics,
    PageBoundary pageBoundary,
    RenderSettings renderSettings
)
Public Function Draw (
    graphics As Graphics,
    pageBoundary As PageBoundary,
    renderSettings As RenderSettings
) As Summary

Parameters

graphics
Type: System.DrawingGraphics
Graphics object to which content is drawn.
pageBoundary
Type: Atalasoft.Imaging.Codec.PdfPageBoundary
The page boundary that is used to draw the PDF page.
renderSettings
Type: Atalasoft.Imaging.Codec.PdfRenderSettings
Settings that control the render process.

Return Value

Type: Summary
See Also

Reference

Page Class
Draw Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.Draw Method (Graphics, PageBoundary, RenderSettings, Int32)

PageDraw Method (Graphics, PageBoundary, RenderSettings, Int32)

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Summary Draw(
    Graphics graphics,
    PageBoundary pageBoundary,
    RenderSettings renderSettings,
    int bandSize
)
Public Function Draw (
    graphics As Graphics,
    pageBoundary As PageBoundary,
    renderSettings As RenderSettings,
    bandSize As Integer
) As Summary

Parameters

graphics
Type: System.DrawingGraphics
pageBoundary
Type: Atalasoft.Imaging.Codec.PdfPageBoundary
renderSettings
Type: Atalasoft.Imaging.Codec.PdfRenderSettings
bandSize
Type: SystemInt32

Return Value

Type: Summary
See Also

Reference

Page Class
Draw Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Page.ExtractImages Method

PageExtractImages Method

Extracts all images on this page.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExtractedImageInfo[] ExtractImages()
Public Function ExtractImages As ExtractedImageInfo()

Return Value

Type: ExtractedImageInfo
Extracted images. Can be of zero length.
Remarks
This method will extract each image embedded in a specified page. The method is more efficient for single image PDF pages as it does not resample the image to fit in the indicated resolution.
Examples
C#
Copy
using (FileStream file = new FileStream(
   string.Format(@"in.pdf", fileName), FileMode.Open, FileAccess.Read))
{
   Document document = new Document(new BinaryReader(file));
   for (int pageIndex=0; pageIndex&lt;document.Pages.Count; pageIndex++)
   {
      Page page = document.Pages[pageIndex];
      ExtractedImageInfo[] images = page.ExtractImages();
      for (int imageIndex=0; null!=images &amp;&amp; imageIndex&lt;images.Length; imageIndex++)
      {
         images[imageIndex].Bitmap.Save(
            string.Format(@"..\..\out_{0}_{1}.bmp", pageIndex, imageIndex));
      }
   }
}
[New Example] (Visual Basic)
Copy
Dim file As FileStream = New FileStream( _
   String.Format("in.pdf", fileName), FileMode.Open, FileAccess.Read))
Document document = New Document(New BinaryReader(file))
For pageIndex As Integer = 0 To document.Pages.Count - 1
      Dim page As Page = document.Pages(pageIndex)
      Dim images() As ExtractedImageInfo = page.ExtractImages()
      For imageIndex As Integer = 0 To images.Length)
         images(imageIndex).Bitmap.Save( _
            String.Format( "..\..\out_{0}_{1}.bmp", pageIndex, imageIndex))
     Next
Next
file.Close()
See Also

Reference

Page Class
Atalasoft.Imaging.Codec.Pdf Namespace


PageBoundary Enumeration

Different PDF page boundaries that each correspond to a specific imaging or finishing process.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum PageBoundary
<FlagsAttribute>
Public Enumeration PageBoundary
Members
Member name | Description
ArtBox | The dimensions of the page's meaningful content as intended by the page's creator. Default to the crop box.
BleedBox | The dimensions to which the page should be clipped in a production environment. Defaults to the crop box.
CropBox | The dimension to which the page should be clipped when displayed or printed. Defaults to the media box.
Default | The dimensions of the intersection of the media box and the crop box. If the crop box is not present, the visible box is set to the media box.
MediaBox | The maximum imageable area of the physical medium on which the page is to be printed.
TrimBox | The dimensions of the finished page after trimming. Defaults to the crop box.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PageCollection Class

A collection of Page objects.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.Imaging.Codec.PdfPages
Atalasoft.Imaging.Codec.PdfPageCollection

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageCollection : Pages
Public Class PageCollection
    Inherits Pages

The PageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PageCollection | Creates a PageCollection from a Stream containing a PDF and password
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | (Inherited from Pages.)
Top
Methods
 | Name | Description
Public method | Contains | (Inherited from Pages.)
Public method | CopyTo | (Inherited from Pages.)
Public method | Dispose | (Inherited from Pages.)
Protected method | Dispose(Boolean) | (Inherited from Pages.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | (Inherited from Pages.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PageCollection Constructor

Creates a PageCollection from a Stream containing a PDF and password

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageCollection(
    Stream stream,
    string password
)
Public Sub New (
    stream As Stream,
    password As String
)

Parameters

stream
Type: System.IOStream
A stream that must be positioned to the beginning of a PDF
password
Type: SystemString
The password to use to open the PDF
See Also

Reference

PageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PageCollection Properties

The PageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | (Inherited from Pages.)
Top
See Also

Reference

PageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PageCollection Methods

The PageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | (Inherited from Pages.)
Public method | CopyTo | (Inherited from Pages.)
Public method | Dispose | (Inherited from Pages.)
Protected method | Dispose(Boolean) | (Inherited from Pages.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | (Inherited from Pages.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages Class

Collection of pages inside a PDF document. Non-creatable. Obtained through the [!:Document::Pages] property of the Document class.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.Imaging.Codec.PdfPages
Atalasoft.Imaging.Codec.PdfPageCollection

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Pages : ReadOnlyCollectionBase, IDisposable
Public Class Pages
    Inherits ReadOnlyCollectionBase
    Implements IDisposable

The Pages type exposes the following members.

Constructors
 | Name | Description
Public method | Pages | Obsolete. Initializes a new instance of the Pages class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item |
Top
Methods
 | Name | Description
Public method | Contains |
Public method | CopyTo |
Public method | Dispose | Releases all resources used by the Pages
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Pages and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


Pages Constructor

Note: This API is now obsolete.

Initializes a new instance of the Pages class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use PageCollection object", true)]
public Pages(
    Stream stream,
    string password
)
<ObsoleteAttribute("Please use PageCollection object", true)>
Public Sub New (
    stream As Stream,
    password As String
)

Parameters

stream
Type: System.IOStream
password
Type: SystemString
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages Properties

The Pages type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item |
Top
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.Item Property

PagesItem Property

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Page this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Page
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Page
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages Methods

The Pages type exposes the following members.

Methods
 | Name | Description
Public method | Contains |
Public method | CopyTo |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.Contains Method

PagesContains Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    Page page
)
Public Function Contains (
    page As Page
) As Boolean

Parameters

page
Type: Atalasoft.Imaging.Codec.PdfPage

Return Value

Type: Boolean
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.CopyTo Method

PagesCopyTo Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    Page[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As Page(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.Codec.PdfPage
index
Type: SystemInt32
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.Dispose Method

PagesDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Pages
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Pages and optionally releases the managed resources
Top
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.Dispose Method

PagesDispose Method

Releases all resources used by the Pages

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Pages Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.Dispose Method (Boolean)

PagesDispose Method (Boolean)

Releases the unmanaged resources used by the Pages and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Pages Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


Pages.IndexOf Method

PagesIndexOf Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    Page page
)
Public Function IndexOf (
    page As Page
) As Integer

Parameters

page
Type: Atalasoft.Imaging.Codec.PdfPage

Return Value

Type: Int32
See Also

Reference

Pages Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Class

PdfCodecCompression is a container class that encapsulates compression settings for a PDF image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecCodecCompression
Atalasoft.Imaging.Codec.PdfPdfCodecCompression

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCodecCompression : CodecCompression
Public Class PdfCodecCompression
    Inherits CodecCompression

The PdfCodecCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCodecCompression(PdfCompressionType) | Constructs a new PdfCodecCompression object with the specified PdfCompressionType.
Public method | PdfCodecCompression(PdfCompressionType, Double) | Constructs a new PdfCodecCompression object with the specified PdfCompressionType and default Jpeg2000 compression factor.
Public method | PdfCodecCompression(PdfCompressionType, Int32) | Constructs a new PdfCodecCompression object with the specified PdfCompressionType and default quality.
Top
Properties
 | Name | Description
Public property | Compression | Gets a value representing one of the standard PDF compression values.
Public property | Jpeg2000CompressionFactor | Gets or sets a value representing the compression factor to use for Jpeg2000 compression.
Public property | JpegQuality | Gets or sets the quality level of the Jpeg as it's encoded to a file. Valid values are 1 - 100 with a default value of 80.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This container class is passed via the SetEncoderCompression event. Clients of the event can retrieve the compression settings for an image being compressed by a MultiFramedImageEncoder and can change them on the fly if needed.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Constructor

Constructs a new PdfCodecCompression object
Overload List
 | Name | Description
Public method | PdfCodecCompression(PdfCompressionType) | Constructs a new PdfCodecCompression object with the specified PdfCompressionType.
Public method | PdfCodecCompression(PdfCompressionType, Double) | Constructs a new PdfCodecCompression object with the specified PdfCompressionType and default Jpeg2000 compression factor.
Public method | PdfCodecCompression(PdfCompressionType, Int32) | Constructs a new PdfCodecCompression object with the specified PdfCompressionType and default quality.
Top
See Also

Reference

PdfCodecCompression Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Constructor (PdfCompressionType)

Constructs a new PdfCodecCompression object with the specified PdfCompressionType.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCodecCompression(
    PdfCompressionType type
)
Public Sub New (
    type As PdfCompressionType
)

Parameters

type
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
A value specifying one of the standard PDF compressions.
Remarks
This class is normally constructed by the PdfEncoder object prior to firing the SetEncoderCompression event. Clients rarely, if ever, need to construct this object on their own.
See Also

Reference

PdfCodecCompression Class
PdfCodecCompression Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Constructor (PdfCompressionType, Double)

Constructs a new PdfCodecCompression object with the specified PdfCompressionType and default Jpeg2000 compression factor.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCodecCompression(
    PdfCompressionType type,
    double jpeg2000CompressionFactor
)
Public Sub New (
    type As PdfCompressionType,
    jpeg2000CompressionFactor As Double
)

Parameters

type
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
A value specifying one of the standard PDF compressions.
jpeg2000CompressionFactor
Type: SystemDouble
Specifies the jpeg2000 compression factor to use when the type is PdfCompressionType.Jpeg2000.
See Also

Reference

PdfCodecCompression Class
PdfCodecCompression Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Constructor (PdfCompressionType, Int32)

Constructs a new PdfCodecCompression object with the specified PdfCompressionType and default quality.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCodecCompression(
    PdfCompressionType type,
    int jpegQuality
)
Public Sub New (
    type As PdfCompressionType,
    jpegQuality As Integer
)

Parameters

type
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
A value specifying one of the standard PDF compressions.
jpegQuality
Type: SystemInt32
A value between 0 and 100 specifying jpeg quality. 1 is best compression and least quality, 100 is least compression and best quality.
See Also

Reference

PdfCodecCompression Class
PdfCodecCompression Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Properties

The PdfCodecCompression type exposes the following members.

Properties
 | Name | Description
Public property | Compression | Gets a value representing one of the standard PDF compression values.
Public property | Jpeg2000CompressionFactor | Gets or sets a value representing the compression factor to use for Jpeg2000 compression.
Public property | JpegQuality | Gets or sets the quality level of the Jpeg as it's encoded to a file. Valid values are 1 - 100 with a default value of 80.
Top
See Also

Reference

PdfCodecCompression Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression.Compression Property

PdfCodecCompressionCompression Property

Gets a value representing one of the standard PDF compression values.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressionType Compression { get; set; }
Public Property Compression As PdfCompressionType
    Get
    Set

Property Value

Type: PdfCompressionType
See Also

Reference

PdfCodecCompression Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression.Jpeg2000CompressionFactor Property

PdfCodecCompressionJpeg2000CompressionFactor Property

Gets or sets a value representing the compression factor to use for Jpeg2000 compression.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Jpeg2000CompressionFactor { get; set; }
Public Property Jpeg2000CompressionFactor As Double
    Get
    Set

Property Value

Type: Double
Remarks
This value is an approximation of the compression factor as a percentage of the original image size. A value of 10.0 should approximate a compressed image that is 10% of the size of the original image.
See Also

Reference

PdfCodecCompression Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression.JpegQuality Property

PdfCodecCompressionJpegQuality Property

Gets or sets the quality level of the Jpeg as it's encoded to a file. Valid values are 1 - 100 with a default value of 80.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
The lower the quality, the smaller the filesize. A good range of values is between 70 and 95.
See Also

Reference

PdfCodecCompression Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCodecCompression Methods

The PdfCodecCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCodecCompression Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfCompressionMode Enumeration

Describes PDF compression algorithm.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfCompressionMode
Public Enumeration PdfCompressionMode
Members
Member name | Description
WholePage | Indicates that each image passed to encoder will be compressed entirely using an appropriate image compression algorithm..
Segmented | Indicates that segmentation algorithm will be applied to images.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfCompressionType Enumeration

The type of compression used on the image data.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfCompressionType
Public Enumeration PdfCompressionType
Members
Member name | Description
None | No compression.
CcittGroup4 | Uses CCITT Group4 Fax compression on the image data. This can only be used on 1-bit images. If you attempt to use this compression on an image of another type, it will default to Auto compression mode.
Jpeg | The image is saved as a JPEG. You may also want to set the JpegQuality of the PdfEncoder.
Deflate | Uses Deflate compression on the image data.
Auto | This will tell the PdfEncoder to automatically determine which compression to use.
Jbig2 | Use Jbig2 compression on the image data. This compression is only available for 1 bit per pixel images.
Jpeg2000 | Use Jpeg2000 compression on the image data. This setting works only for RGB color or grayscale images.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder Class

A MultiFramedImageDecoder used to read PDF pages as images from a Stream.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageDecoder
Atalasoft.Imaging.CodecMultiFramedImageDecoder
Atalasoft.Imaging.Codec.PdfPdfDecoder

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDecoder : MultiFramedImageDecoder, IDisposable,
    IMultiFramedVectorDecoder, IRegionReadable, ITextFormatDecoder
Public Class PdfDecoder
    Inherits MultiFramedImageDecoder
    Implements IDisposable, IMultiFramedVectorDecoder, IRegionReadable, ITextFormatDecoder

The PdfDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDecoder | Initializes a new instance of a PdfDecoder.
Top
Properties
 | Name | Description
Public property | Password | The password for the PDF or null for no password
 | PathToResources |
Public property | RenderSettings | Used to indicate how to render the PDF. For example, whether to show Annotations and which ones to show.
Public property | Resolution | Gets or sets the resolution at which to render a PDF page.
Public property | SmoothingMode | Obsolete. Gets or sets a value specifying whether and how smoothing (antialiasing) is applied to lines, curves, and edges of filled areas and text.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Public property | TileThreshold | Gets or sets the threshold value in pixels. When the width or height of the expected image exceeds the threshold value, the image is rendered in parts (tiles) and merged into a single image. Default: 31000 pixels.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources managed by this object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfDecoder and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDefaultResolution |
Public method | GetFrameCount | Returns the number of pages in a PDF document. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Returns information about the first page of the PDF document. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about the given page of the PDF document. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetTextDocument | Creates the text document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if and only if the specified Stream contains a PDF document. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RasterizeScaledRegion(Stream, RectangleF, SizeF, ProgressEventHandler) |
Public method | RasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler) |
Public method | Read(Stream, ProgressEventHandler) | Read a PDF document and return the first page as an AtalaImage. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a PDF document and return the given page as an AtalaImage. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ReadRegion | Reads a rectangle region from the PDF. This uses memory proportional to the size of the region.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MAXRESOLUTION | The maximum resolution that PDF's can be read at.
MINRESOLUTION | The minimum resolution that PDF's can be read at.
Top
Remarks
To support reading JPEG2000 and JBIG2 compressed PDF files, you must distribute the Atalasoft.dotImage.Jbig2.dll and Atalasoft.dotImage.Jpeg2000.dll alongside your Atalasoft.dotImage.PdfReader.dll. However you are not required to distribute these dependencies if you do not wish to support JP2 or JBIG images within PDF files. This decoder unpacks PDFium engine library in %TEMP% directory by default. To set custom location see the example section.
Examples
[New Example] (C#)
Copy
using Atalasoft.Imaging;
using Atalasoft.Imaging.Codec;
using Atalasoft.Imaging.Codec.Pdf;
...
PdfDecoder pdf = new PdfDecoder();
pdf.Resolution = 150;
RegisteredDecoders.Decoders.Add(pdf);
Workspace myWorkspace = new Workspace();
myWorkspace.Open("document.pdf");
[New Example] (Visual Basic)
Copy
Imports Atalasoft.Imaging
Imports Atalasoft.Imaging.Codec
Imports Atalasoft.Imaging.Codec.Pdf
...
Dim pdf As PdfDecoder = New PdfDecoder()
pdf.Resolution = 150
RegisteredDecoders.Decoders.Add(pdf)
Dim myWorkspace As Workspace = New Workspace()
myWorkspace.Open("document.pdf");
Examples
To configure Pdfium library location, you should add the next line to app.config file:
Copy
<Atalasoft>
    <PdfDecoder PdfiumLocation="C:\Folder\Subfolder\SubSubFolder"/>
    <!-- Components sections -->
    ...
</Atalasoft>
You can also use a relaive path
Copy
<Atalasoft>
    <PdfDecoder PdfiumLocation="..\Another\Sub\Folder"/>
    <!-- Components sections -->
    ...
</Atalasoft>
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace
Atalasoft.SharedAtalasoftConfigSection


PdfDecoder Constructor

Initializes a new instance of a PdfDecoder.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDecoder()
Public Sub New
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder Properties

The PdfDecoder type exposes the following members.

Properties
 | Name | Description
Public property | Password | The password for the PDF or null for no password
 | PathToResources |
Public property | RenderSettings | Used to indicate how to render the PDF. For example, whether to show Annotations and which ones to show.
Public property | Resolution | Gets or sets the resolution at which to render a PDF page.
Public property | SmoothingMode | Obsolete. Gets or sets a value specifying whether and how smoothing (antialiasing) is applied to lines, curves, and edges of filled areas and text.
Public property | SupportedImageType | Obsolete. Returns the ImageType that the implemented decoder class supports. (Inherited from ImageDecoder.)
Public property | TileThreshold | Gets or sets the threshold value in pixels. When the width or height of the expected image exceeds the threshold value, the image is rendered in parts (tiles) and merged into a single image. Default: 31000 pixels.
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Password Property

PdfDecoderPassword Property

The password for the PDF or null for no password

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.PathToResources Property

PdfDecoderPathToResources Property

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string PathToResources { get; set; }
Public Shared Property PathToResources As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.RenderSettings Property

PdfDecoderRenderSettings Property

Used to indicate how to render the PDF. For example, whether to show Annotations and which ones to show.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderSettings RenderSettings { get; set; }
Public Property RenderSettings As RenderSettings
    Get
    Set

Property Value

Type: RenderSettings
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Resolution Property

PdfDecoderResolution Property

Gets or sets the resolution at which to render a PDF page.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set

Property Value

Type: Int32
The resolution at which to render a PDF page.
Remarks
Note that in general rendering a PDF page will cause embedded images to be up- or down-sampled. To retrieve embedded images at their original sample rate, use the ExtractImages method.
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.SmoothingMode Property

PdfDecoderSmoothingMode Property

Note: This API is now obsolete.

Gets or sets a value specifying whether and how smoothing (antialiasing) is applied to lines, curves, and edges of filled areas and text.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is ignored.", false)]
public SmoothingMode SmoothingMode { get; set; }
<ObsoleteAttribute("This property is ignored.", false)>
Public Property SmoothingMode As SmoothingMode
    Get
    Set

Property Value

Type: SmoothingMode
Remarks
In contrast to GDI+, the smoothing mode does effect text. This follows from the fact that the PDF decoder draws text as bezier curves.
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.TileThreshold Property

PdfDecoderTileThreshold Property

Gets or sets the threshold value in pixels. When the width or height of the expected image exceeds the threshold value, the image is rendered in parts (tiles) and merged into a single image. Default: 31000 pixels.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TileThreshold { get; set; }
Public Property TileThreshold As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder Methods

The PdfDecoder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources managed by this object.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDefaultResolution |
Public method | GetFrameCount | Returns the number of pages in a PDF document. (Overrides MultiFramedImageDecoderGetFrameCount(Stream).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInfo(Stream) | Returns information about the first page of the PDF document. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about the given page of the PDF document. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Public method | GetTextDocument | Creates the text document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormat | Returns true if and only if the specified Stream contains a PDF document. (Overrides ImageDecoderIsValidFormat(Stream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RasterizeScaledRegion(Stream, RectangleF, SizeF, ProgressEventHandler) |
Public method | RasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler) |
Public method | Read(Stream, ProgressEventHandler) | Read a PDF document and return the first page as an AtalaImage. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a PDF document and return the given page as an AtalaImage. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Public method | ReadRegion | Reads a rectangle region from the PDF. This uses memory proportional to the size of the region.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Dispose Method

PdfDecoderDispose Method

Releases all resources managed by this object.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources managed by this object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfDecoder and optionally releases the managed resources
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Dispose Method

PdfDecoderDispose Method

Releases all resources managed by this object.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Dispose Method (Boolean)

PdfDecoderDispose Method (Boolean)

Releases the unmanaged resources used by the PdfDecoder and optionally releases the managed resources

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfDecoder Class
Dispose Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.GetDefaultResolution Method

PdfDecoderGetDefaultResolution Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int GetDefaultResolution()
Protected Function GetDefaultResolution As Integer

Return Value

Type: Int32
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.GetFrameCount Method

PdfDecoderGetFrameCount Method

Returns the number of pages in a PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetFrameCount(
    Stream stream
)
Public Overrides Function GetFrameCount (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The Stream that holds the PDF document. It is assumed that the Stream position points is at the start of the PDF document.

Return Value

Type: Int32
Number of pages.
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.GetImageInfo Method

PdfDecoderGetImageInfo Method

Returns information about the PDF without decoding it.
Overload List
 | Name | Description
Public method | GetImageInfo(Stream) | Returns information about the first page of the PDF document. (Overrides ImageDecoderGetImageInfo(Stream).)
Public method | GetImageInfo(Stream, Int32) | Returns information about the given page of the PDF document. (Overrides MultiFramedImageDecoderGetImageInfo(Stream, Int32).)
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.GetImageInfo Method (Stream)

PdfDecoderGetImageInfo Method (Stream)

Returns information about the first page of the PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream
)
Public Overrides Function GetImageInfo (
    stream As Stream
) As ImageInfo

Parameters

stream
Type: System.IOStream
The Stream that holds the PDF document. It is assumed that the Stream position points is at the start of the PDF document.

Return Value

Type: ImageInfo
An instance of a PdfImageInfo.
Remarks
To obtain the PDF specific information, the ImageInfo return value must be cast to a PdfImageInfo.
See Also

Reference

PdfDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.GetImageInfo Method (Stream, Int32)

PdfDecoderGetImageInfo Method (Stream, Int32)

Returns information about the given page of the PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageInfo GetImageInfo(
    Stream stream,
    int frameIndex
)
Public Overrides Function GetImageInfo (
    stream As Stream,
    frameIndex As Integer
) As ImageInfo

Parameters

stream
Type: System.IOStream
The Stream that holds the PDF document. It is assumed that the Stream position points is at the start of the PDF document.
frameIndex
Type: SystemInt32
The zero-based index of the page from which to return information.

Return Value

Type: ImageInfo
An instance of a PdfImageInfo.
Remarks
To obtain the PDF specific information, the ImageInfo return value must be cast to a PdfImageInfo.
See Also

Reference

PdfDecoder Class
GetImageInfo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.GetTextDocument Method

PdfDecoderGetTextDocument Method

Creates the text document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ITextDocument GetTextDocument(
    Stream stream
)
Public Overridable Function GetTextDocument (
    stream As Stream
) As ITextDocument

Parameters

stream
Type: System.IOStream
The document stream.

Return Value

Type: ITextDocument
ITextDocument that allows text information extraction.

Implements

ITextFormatDecoderGetTextDocument(Stream)
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.IsValidFormat Method

PdfDecoderIsValidFormat Method

Returns true if and only if the specified Stream contains a PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidFormat(
    Stream stream
)
Public Overrides Function IsValidFormat (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
The Stream that holds the PDF document to verify. It is assumed that the stream position points is at the start of the PDF document.

Return Value

Type: Boolean
True if and only if the specified Stream contains a PDF document.
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.RasterizeScaledRegion Method

PdfDecoderRasterizeScaledRegion Method

Overload List
 | Name | Description
Public method | RasterizeScaledRegion(Stream, RectangleF, SizeF, ProgressEventHandler) |
Public method | RasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler) |
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.RasterizeScaledRegion Method (Stream, RectangleF, SizeF, ProgressEventHandler)

PdfDecoderRasterizeScaledRegion Method (Stream, RectangleF, SizeF, ProgressEventHandler)

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage RasterizeScaledRegion(
    Stream stream,
    RectangleF srcRect,
    SizeF dstSize,
    ProgressEventHandler progress
)
Public Overridable Function RasterizeScaledRegion (
    stream As Stream,
    srcRect As RectangleF,
    dstSize As SizeF,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
srcRect
Type: System.DrawingRectangleF
dstSize
Type: System.DrawingSizeF
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage
See Also

Reference

PdfDecoder Class
RasterizeScaledRegion Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.RasterizeScaledRegion Method (Stream, Int32, RectangleF, SizeF, ProgressEventHandler)

PdfDecoderRasterizeScaledRegion Method (Stream, Int32, RectangleF, SizeF, ProgressEventHandler)

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage RasterizeScaledRegion(
    Stream stream,
    int frameIndex,
    RectangleF srcRect,
    SizeF dstSize,
    ProgressEventHandler progress
)
Public Overridable Function RasterizeScaledRegion (
    stream As Stream,
    frameIndex As Integer,
    srcRect As RectangleF,
    dstSize As SizeF,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
frameIndex
Type: SystemInt32
srcRect
Type: System.DrawingRectangleF
dstSize
Type: System.DrawingSizeF
progress
Type: Atalasoft.ImagingProgressEventHandler

Return Value

Type: AtalaImage

Implements

IMultiFramedVectorDecoderRasterizeScaledRegion(Stream, Int32, RectangleF, SizeF, ProgressEventHandler)
See Also

Reference

PdfDecoder Class
RasterizeScaledRegion Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Read Method

PdfDecoderRead Method

Read a PDF document as an AtalaImage.
Overload List
 | Name | Description
Public method | Read(Stream, ProgressEventHandler) | Read a PDF document and return the first page as an AtalaImage. (Overrides ImageDecoderRead(Stream, ProgressEventHandler).)
Public method | Read(Stream, Int32, ProgressEventHandler) | Read a PDF document and return the given page as an AtalaImage. (Overrides MultiFramedImageDecoderRead(Stream, Int32, ProgressEventHandler).)
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Read Method (Stream, ProgressEventHandler)

PdfDecoderRead Method (Stream, ProgressEventHandler)

Read a PDF document and return the first page as an AtalaImage.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream that holds the PDF document. It is assumed that the stream position points is at the start of the PDF document.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
AtalaImage containing the first page.
See Also

Reference

PdfDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.Read Method (Stream, Int32, ProgressEventHandler)

PdfDecoderRead Method (Stream, Int32, ProgressEventHandler)

Read a PDF document and return the given page as an AtalaImage.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Read(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overrides Function Read (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
The stream that holds the PDF document. It is assumed that the stream position points is at the start of the PDF document.
frameIndex
Type: SystemInt32
The zero-based index of the page from which to return information.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: AtalaImage
AtalaImage containing the given page.
See Also

Reference

PdfDecoder Class
Read Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.ReadRegion Method

PdfDecoderReadRegion Method

Reads a rectangle region from the PDF. This uses memory proportional to the size of the region.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage ReadRegion(
    Stream stream,
    Rectangle region,
    int frameIndex,
    ProgressEventHandler progress
)
Public Overridable Function ReadRegion (
    stream As Stream,
    region As Rectangle,
    frameIndex As Integer,
    progress As ProgressEventHandler
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream positioned to the beginning of a PDF
region
Type: System.DrawingRectangle
A rectangle region to render.
frameIndex
Type: SystemInt32
The page number of the PDF to render starting from zero
progress
Type: Atalasoft.ImagingProgressEventHandler
A progress handler

Return Value

Type: AtalaImage
An image that is the size of the region passed in with only a portion of the PDF rendered to it.

Implements

IRegionReadableReadRegion(Stream, Rectangle, Int32, ProgressEventHandler)
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder Fields

The PdfDecoder type exposes the following members.

Fields
Name | Description
MAXRESOLUTION | The maximum resolution that PDF's can be read at.
MINRESOLUTION | The minimum resolution that PDF's can be read at.
Top
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.MAXRESOLUTION Field

PdfDecoderMAXRESOLUTION Field

The maximum resolution that PDF's can be read at.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int MAXRESOLUTION
Public Shared MAXRESOLUTION As Integer

Field Value

Type: Int32
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfDecoder.MINRESOLUTION Field

PdfDecoderMINRESOLUTION Field

The minimum resolution that PDF's can be read at.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int MINRESOLUTION
Public Shared MINRESOLUTION As Integer

Field Value

Type: Int32
See Also

Reference

PdfDecoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Class

An ImageEncoder that will write one or more images to a PDF file.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageEncoder
Atalasoft.Imaging.CodecMultiFramedImageEncoder
Atalasoft.Imaging.Codec.PdfPdfEncoder

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfEncoder : MultiFramedImageEncoder
Public Class PdfEncoder
    Inherits MultiFramedImageEncoder

The PdfEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PdfEncoder | Creates a new instance of PdfEncoder.
Public method | PdfEncoder(PdfDocumentType) | Creates a new instance of PdfEncoder specifying the document type.
Public method | PdfEncoder(PdfMetadata) | Creates a new instance of PdfEncoder specifying metadata.
Public method | PdfEncoder(PdfPageSizeMode, Size, Int32, PdfMetadata) | Creates a new instance of PdfEncoder specifying sizeMode, pageSize, pageBorder and metadata.
Public method | PdfEncoder(Int32, PdfPageSizeMode, Size, Int32, PdfMetadata) | Creates an instance of PdfEncoder specifying jpegQuality, sizeMode, pageSize, pageBorder and metadata.
Public method | PdfEncoder(PdfPageSizeMode, Size, Int32, PdfMetadata, PdfDocumentType) | Creates a new instance of PdfEncoder specifying sizeMode, pageSize, pageBorder, metadata and document type.
Top
Properties
 | Name | Description
Public property | AdjustPdfVersionAsNeeded | Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.
Public property | BookmarkTree | Gets or sets the PDF bookmark tree that will be used with this document. Default value is null (no tree).
Public property | CreateSelfPrintingPdf | Gets or sets a boolean indicating if the output PDF file should be self-printing
Public property | DocumentType | Specifies the type of PDF document that will be produced, including PDF-A.
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata stream should be encrypted. Default is true.
Public property | Jpeg2000Quality | Gets or sets Jpeg2000 quality value.
Public property | JpegQuality | Gets or sets the JPEG quality used when the image compression is set to Jpeg.
Public property | Linearized | Gets or sets a value indicating whether the PDF document will be saved as linearized.
Public property | Metadata | Gets or sets the metadata information used for this PDF.
Public property | Mode | Gets or sets a value indicating how to compress each page.
Public property | OwnerPassword | Obsolete. Sets or gets an owner password to use for the document. Default value is null (no password).
Public property | PageBorder | Gets or sets the amount of border space around the image in PDF Page Units.
Public property | PageSize | Gets or sets the size of the PDF pages in PDF Page Units. PDF uses an internal resolution of 72dpi, so an 8.5 x 11 inch page would be 612 x 792 pixels.
Public property | PdfVersion | Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.
Public property | Permissions | Sets or gets the set of allowable actions for this PDF.
Public property | SelfPrintingShowsPrintOptions | When set to true, self-printing shows the print options dialog.
Public property | SelfPrintingShrinksToFitPage | When set to true, self-printing adjusts the content to fit the page size.
Public property | SizeMode |
Public property | SupportedPixelFormats | Returns an array of the legal pixel formats accepted by the PdfEncoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | UseAdvancedImageCompression | Allows the PdfEncoder to use JPEG2000 or JBIG2 image compression for color and black and white documents respectively.
Public property | UseCompressedObjectStreams | Gets or sets a value indicating whether the PDF document contains compressed object streams.
Public property | UseJbig2LossyCompression | Gets or sets a value indicating whether to use Lossy mode in case of Jbig2 compression.
Public property | UserPassword | Obsolete. Sets or gets a user password to use for the document. Default value is null (no password).
Public property | Xmp | Gets or sets a byte array containing XMP data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetGrayImage |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetOneBitImage |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessSegment |
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Saves an image to a PDF file. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, PdfImage, ProgressEventHandler) | Creates a single or multipage page PDF file from the specified PdfImage object.
Public method | Save(Stream, PdfImageCollection, ProgressEventHandler) | Saves one or more images to a PDF file.
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves all of the images in an ImageCollection to a PDF file. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves all of the images in an ImageSource to a PDF file. Only one Image of the ImageSource is in memory at any one time. (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | Save(Stream, AtalaImage, PdfCompressionType, ProgressEventHandler) | Creates a single page PDF file from the specified image and compression.
Public method | SetOneTimePasswords | Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after calling Save method.
Public method | ToByteArray(AtalaImage, ProgressEventHandler) | Saves a single image as a PDF to a byte array.
Public method | ToByteArray(ImageCollection, ProgressEventHandler) | Save an ImageCollection as PDF to a byte array.
Public method | ToByteArray(PdfImageCollection, ProgressEventHandler) | Saves a PdfImageCollection as PDF to a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ProcessSegment | With this event users may control color type of each segment and even set desired color type for the segments found by PdfEncoder during saving PDFs when segmentation algorithm is used to compress PDFs (see Mode).
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Top
Remarks

To use the PdfEncoder, simply pass an instance of the PdfEncoder to the Save(Stream, ImageEncoder) or Save(String, ImageEncoder, ProgressEventHandler) method and it will save all images from the Images Property of the Workspace object into the PDF File. To compose a multipage PDF document from images not in memory all at once, or at a specified compression format, follow the steps in the example above.

DotImage Document Imaging is required for PDF Encode functionality.

See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor

Creates a PdfEncoder object.
Overload List
 | Name | Description
Public method | PdfEncoder | Creates a new instance of PdfEncoder.
Public method | PdfEncoder(PdfDocumentType) | Creates a new instance of PdfEncoder specifying the document type.
Public method | PdfEncoder(PdfMetadata) | Creates a new instance of PdfEncoder specifying metadata.
Public method | PdfEncoder(PdfPageSizeMode, Size, Int32, PdfMetadata) | Creates a new instance of PdfEncoder specifying sizeMode, pageSize, pageBorder and metadata.
Public method | PdfEncoder(Int32, PdfPageSizeMode, Size, Int32, PdfMetadata) | Creates an instance of PdfEncoder specifying jpegQuality, sizeMode, pageSize, pageBorder and metadata.
Public method | PdfEncoder(PdfPageSizeMode, Size, Int32, PdfMetadata, PdfDocumentType) | Creates a new instance of PdfEncoder specifying sizeMode, pageSize, pageBorder, metadata and document type.
Top
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor

Creates a new instance of PdfEncoder.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfEncoder()
Public Sub New
Remarks
As of DotImage 7.0 it is possible to create PDF-A/1b compliant documents by setting the DocumentType property in the PdfEncoder object.
See Also

Reference

PdfEncoder Class
PdfEncoder Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor (PdfDocumentType)

Creates a new instance of PdfEncoder specifying the document type.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfEncoder(
    PdfDocumentType docType
)
Public Sub New (
    docType As PdfDocumentType
)

Parameters

docType
Type: Atalasoft.PdfDocPdfDocumentType
The document type for the resulting PDF
See Also

Reference

PdfEncoder Class
PdfEncoder Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor (PdfMetadata)

Creates a new instance of PdfEncoder specifying metadata.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfEncoder(
    PdfMetadata metadata
)
Public Sub New (
    metadata As PdfMetadata
)

Parameters

metadata
Type: Atalasoft.Imaging.Codec.PdfPdfMetadata
The metadata for this PDF file.
See Also

Reference

PdfEncoder Class
PdfEncoder Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor (PdfPageSizeMode, Size, Int32, PdfMetadata)

Creates a new instance of PdfEncoder specifying sizeMode, pageSize, pageBorder and metadata.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfEncoder(
    PdfPageSizeMode sizeMode,
    Size pageSize,
    int pageBorder,
    PdfMetadata metadata
)
Public Sub New (
    sizeMode As PdfPageSizeMode,
    pageSize As Size,
    pageBorder As Integer,
    metadata As PdfMetadata
)

Parameters

sizeMode
Type: Atalasoft.Imaging.Codec.PdfPdfPageSizeMode
The size method used when creating the page.
pageSize
Type: System.DrawingSize
The page size in pixels.
pageBorder
Type: SystemInt32
The page border used for this image.
metadata
Type: Atalasoft.Imaging.Codec.PdfPdfMetadata
The metadata for this PDF file.
See Also

Reference

PdfEncoder Class
PdfEncoder Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor (Int32, PdfPageSizeMode, Size, Int32, PdfMetadata)

Creates an instance of PdfEncoder specifying jpegQuality, sizeMode, pageSize, pageBorder and metadata.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfEncoder(
    int jpegQuality,
    PdfPageSizeMode sizeMode,
    Size pageSize,
    int pageBorder,
    PdfMetadata metadata
)
Public Sub New (
    jpegQuality As Integer,
    sizeMode As PdfPageSizeMode,
    pageSize As Size,
    pageBorder As Integer,
    metadata As PdfMetadata
)

Parameters

jpegQuality
Type: SystemInt32
The Jpeg quality used when the image compression is set to Jpeg. The value can range from 1 to 100 where 1 provides the best compression, but least image quality and 100 provides the least compression, but best image quality.
sizeMode
Type: Atalasoft.Imaging.Codec.PdfPdfPageSizeMode
The size method used when creating the page.
pageSize
Type: System.DrawingSize
The page size in pixels.
pageBorder
Type: SystemInt32
The page border used for this image. Set to a value greater than 0, this will create a page with a blank border around the image in PDF Page units (72nds of an inch).
metadata
Type: Atalasoft.Imaging.Codec.PdfPdfMetadata
The metadata for this PDF file.
See Also

Reference

PdfEncoder Class
PdfEncoder Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Constructor (PdfPageSizeMode, Size, Int32, PdfMetadata, PdfDocumentType)

Creates a new instance of PdfEncoder specifying sizeMode, pageSize, pageBorder, metadata and document type.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfEncoder(
    PdfPageSizeMode sizeMode,
    Size pageSize,
    int pageBorder,
    PdfMetadata metadata,
    PdfDocumentType docType
)
Public Sub New (
    sizeMode As PdfPageSizeMode,
    pageSize As Size,
    pageBorder As Integer,
    metadata As PdfMetadata,
    docType As PdfDocumentType
)

Parameters

sizeMode
Type: Atalasoft.Imaging.Codec.PdfPdfPageSizeMode
The size method used when creating the page.
pageSize
Type: System.DrawingSize
The page size in pixels.
pageBorder
Type: SystemInt32
The page border used for this image. Set to a value greater than 0, this will create a page with a blank border around the image in PDF Page units (72nds of an inch).
metadata
Type: Atalasoft.Imaging.Codec.PdfPdfMetadata
The metadata for this PDF file.
docType
Type: Atalasoft.PdfDocPdfDocumentType
The document type for the resulting PDF
See Also

Reference

PdfEncoder Class
PdfEncoder Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Properties

The PdfEncoder type exposes the following members.

Properties
 | Name | Description
Public property | AdjustPdfVersionAsNeeded | Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.
Public property | BookmarkTree | Gets or sets the PDF bookmark tree that will be used with this document. Default value is null (no tree).
Public property | CreateSelfPrintingPdf | Gets or sets a boolean indicating if the output PDF file should be self-printing
Public property | DocumentType | Specifies the type of PDF document that will be produced, including PDF-A.
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata stream should be encrypted. Default is true.
Public property | Jpeg2000Quality | Gets or sets Jpeg2000 quality value.
Public property | JpegQuality | Gets or sets the JPEG quality used when the image compression is set to Jpeg.
Public property | Linearized | Gets or sets a value indicating whether the PDF document will be saved as linearized.
Public property | Metadata | Gets or sets the metadata information used for this PDF.
Public property | Mode | Gets or sets a value indicating how to compress each page.
Public property | OwnerPassword | Obsolete. Sets or gets an owner password to use for the document. Default value is null (no password).
Public property | PageBorder | Gets or sets the amount of border space around the image in PDF Page Units.
Public property | PageSize | Gets or sets the size of the PDF pages in PDF Page Units. PDF uses an internal resolution of 72dpi, so an 8.5 x 11 inch page would be 612 x 792 pixels.
Public property | PdfVersion | Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.
Public property | Permissions | Sets or gets the set of allowable actions for this PDF.
Public property | SelfPrintingShowsPrintOptions | When set to true, self-printing shows the print options dialog.
Public property | SelfPrintingShrinksToFitPage | When set to true, self-printing adjusts the content to fit the page size.
Public property | SizeMode |
Public property | SupportedPixelFormats | Returns an array of the legal pixel formats accepted by the PdfEncoder. (Overrides ImageEncoderSupportedPixelFormats.)
Public property | UseAdvancedImageCompression | Allows the PdfEncoder to use JPEG2000 or JBIG2 image compression for color and black and white documents respectively.
Public property | UseCompressedObjectStreams | Gets or sets a value indicating whether the PDF document contains compressed object streams.
Public property | UseJbig2LossyCompression | Gets or sets a value indicating whether to use Lossy mode in case of Jbig2 compression.
Public property | UserPassword | Obsolete. Sets or gets a user password to use for the document. Default value is null (no password).
Public property | Xmp | Gets or sets a byte array containing XMP data.
Top
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.AdjustPdfVersionAsNeeded Property

PdfEncoderAdjustPdfVersionAsNeeded Property

Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AdjustPdfVersionAsNeeded { get; set; }
Public Property AdjustPdfVersionAsNeeded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [adjust PDF version as needed]; otherwise, false.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.BookmarkTree Property

PdfEncoderBookmarkTree Property

Gets or sets the PDF bookmark tree that will be used with this document. Default value is null (no tree).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkTree BookmarkTree { get; set; }
Public Property BookmarkTree As PdfBookmarkTree
    Get
    Set

Property Value

Type: PdfBookmarkTree
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.CreateSelfPrintingPdf Property

PdfEncoderCreateSelfPrintingPdf Property

Gets or sets a boolean indicating if the output PDF file should be self-printing

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CreateSelfPrintingPdf { get; set; }
Public Property CreateSelfPrintingPdf As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When set to true, PDF files generated will contain an JavaScript action that requests the PDF document viewer to print the document after opening. This has the effect of creating a self-printing document. The user can typically cancel this operation.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.DocumentType Property

PdfEncoderDocumentType Property

Specifies the type of PDF document that will be produced, including PDF-A.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentType DocumentType { get; set; }
Public Property DocumentType As PdfDocumentType
    Get
    Set

Property Value

Type: PdfDocumentType
A value indicating the type of PDF document that will be produced.
Remarks

The default value is PdfDocumentType.Default which allows the encoder the greatest latitude in creating PDF files.

When using PDFA1b, the user must provide appropriate ColorSpaces for all images.

See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.EncryptMetadata Property

PdfEncoderEncryptMetadata Property

Sets or gets a boolean indicating that metadata stream should be encrypted. Default is true.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EncryptMetadata { get; set; }
Public Property EncryptMetadata As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

When a PDF document is encrypted, nearly all embedded strings and stream data are encrypted. Metadata stream do not have to be encrypted. This allows indexing software to retrieve metadata without needing to know document passwords.

This value is ignored for the PDF versions below 2.0.

See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Jpeg2000Quality Property

PdfEncoderJpeg2000Quality Property

Gets or sets Jpeg2000 quality value.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Jpeg2000Quality { get; set; }
Public Property Jpeg2000Quality As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Valid values are from 1 to 100.
Remarks
Default: 50.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.JpegQuality Property

PdfEncoderJpegQuality Property

Gets or sets the JPEG quality used when the image compression is set to Jpeg.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Valid values are from 1 to 100.
Remarks
Default: 80.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Linearized Property

PdfEncoderLinearized Property

Gets or sets a value indicating whether the PDF document will be saved as linearized.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Linearized { get; set; }
Public Property Linearized As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Metadata Property

PdfEncoderMetadata Property

Gets or sets the metadata information used for this PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMetadata Metadata { get; set; }
Public Property Metadata As PdfMetadata
    Get
    Set

Property Value

Type: PdfMetadata
The metadata information used for this PDF.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Mode Property

PdfEncoderMode Property

Gets or sets a value indicating how to compress each page.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressionMode Mode { get; set; }
Public Property Mode As PdfCompressionMode
    Get
    Set

Property Value

Type: PdfCompressionMode
Remarks
Default: WholePage
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.OwnerPassword Property

PdfEncoderOwnerPassword Property

Note: This API is now obsolete.

Sets or gets an owner password to use for the document. Default value is null (no password).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.PageBorder Property

PdfEncoderPageBorder Property

Gets or sets the amount of border space around the image in PDF Page Units.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageBorder { get; set; }
Public Property PageBorder As Integer
    Get
    Set

Property Value

Type: Int32
Set to a value greater than 0, this will create a page with a blank border around the image in PDF Page units (72nds of an inch).
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.PageSize Property

PdfEncoderPageSize Property

Gets or sets the size of the PDF pages in PDF Page Units.

PDF uses an internal resolution of 72dpi, so an 8.5 x 11 inch page would be 612 x 792 pixels.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size PageSize { get; set; }
Public Property PageSize As Size
    Get
    Set

Property Value

Type: Size
The size of the PDF pages in PDF Page Units.
Remarks
This value is only used if PdfPageSizeMode is FitToPage.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.PdfVersion Property

PdfEncoderPdfVersion Property

Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PdfVersion { get; set; }
Public Property PdfVersion As Double
    Get
    Set

Property Value

Type: Double
The PDF version of the output document.
Remarks
Setting this value indicates the maximum version desired. It is possible that the output document could be read under earlier versions of the PDF standard, but it will be marked as the number specified. AdjustPdfVersionAsNeeded can be used to make an automatic setting.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Permissions Property

PdfEncoderPermissions Property

Sets or gets the set of allowable actions for this PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAccessPermissions Permissions { get; set; }
Public Property Permissions As PdfAccessPermissions
    Get
    Set

Property Value

Type: PdfAccessPermissions
Remarks
PdfAccessPermissions refer to permissions that are allowed within a PDF document. Permissions are granted by allowing actions rather than preventing them.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.SelfPrintingShowsPrintOptions Property

PdfEncoderSelfPrintingShowsPrintOptions Property

When set to true, self-printing shows the print options dialog.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfPrintingShowsPrintOptions { get; set; }
Public Property SelfPrintingShowsPrintOptions As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.SelfPrintingShrinksToFitPage Property

PdfEncoderSelfPrintingShrinksToFitPage Property

When set to true, self-printing adjusts the content to fit the page size.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfPrintingShrinksToFitPage { get; set; }
Public Property SelfPrintingShrinksToFitPage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.SizeMode Property

PdfEncoderSizeMode Property

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageSizeMode SizeMode { get; set; }
Public Property SizeMode As PdfPageSizeMode
    Get
    Set

Property Value

Type: PdfPageSizeMode
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.SupportedPixelFormats Property

PdfEncoderSupportedPixelFormats Property

Returns an array of the legal pixel formats accepted by the PdfEncoder.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.UseAdvancedImageCompression Property

PdfEncoderUseAdvancedImageCompression Property

Allows the PdfEncoder to use JPEG2000 or JBIG2 image compression for color and black and white documents respectively.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseAdvancedImageCompression { get; set; }
Public Property UseAdvancedImageCompression As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Documents created with advanced image compression are typically smaller than without, but may not be openable by all versions of Acrobat and will not meet PDF/A compliance. When set to true, this is considered a request to use the DotImage Jpeg2000 encoder for color images and the DotImage JBig2 encoder. These codecs are used only if the associated assemblies are present and if the encoders are licensed.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.UseCompressedObjectStreams Property

PdfEncoderUseCompressedObjectStreams Property

Gets or sets a value indicating whether the PDF document contains compressed object streams.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseCompressedObjectStreams { get; set; }
Public Property UseCompressedObjectStreams As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

PDF/A-1b does not support compressed object streams.

PdfEncoder does not support compressed object streams in linearized PDF.

See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.UseJbig2LossyCompression Property

PdfEncoderUseJbig2LossyCompression Property

Gets or sets a value indicating whether to use Lossy mode in case of Jbig2 compression.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseJbig2LossyCompression { get; set; }
Public Property UseJbig2LossyCompression As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default: false.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.UserPassword Property

PdfEncoderUserPassword Property

Note: This API is now obsolete.

Sets or gets a user password to use for the document. Default value is null (no password).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Xmp Property

PdfEncoderXmp Property

Gets or sets a byte array containing XMP data.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Xmp { get; set; }
Public Property Xmp As Byte()
    Get
    Set

Property Value

Type: Byte
A byte array containing XMP data.
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Methods

The PdfEncoder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetGrayImage |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetOneBitImage |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Returns true if the given PixelFormat can be encoded with the derived encoder. (Inherited from ImageEncoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessSegment |
Protected method | OnSetEncoderCompression | Called when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Saves an image to a PDF file. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, PdfImage, ProgressEventHandler) | Creates a single or multipage page PDF file from the specified PdfImage object.
Public method | Save(Stream, PdfImageCollection, ProgressEventHandler) | Saves one or more images to a PDF file.
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves all of the images in an ImageCollection to a PDF file. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves all of the images in an ImageSource to a PDF file. Only one Image of the ImageSource is in memory at any one time. (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | Save(Stream, AtalaImage, PdfCompressionType, ProgressEventHandler) | Creates a single page PDF file from the specified image and compression.
Public method | SetOneTimePasswords | Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after calling Save method.
Public method | ToByteArray(AtalaImage, ProgressEventHandler) | Saves a single image as a PDF to a byte array.
Public method | ToByteArray(ImageCollection, ProgressEventHandler) | Save an ImageCollection as PDF to a byte array.
Public method | ToByteArray(PdfImageCollection, ProgressEventHandler) | Saves a PdfImageCollection as PDF to a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.GetGrayImage Method

PdfEncoderGetGrayImage Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage GetGrayImage(
    AtalaImage source
)
Protected Overridable Function GetGrayImage (
    source As AtalaImage
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.GetOneBitImage Method

PdfEncoderGetOneBitImage Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage GetOneBitImage(
    AtalaImage source
)
Protected Overridable Function GetOneBitImage (
    source As AtalaImage
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.OnProcessSegment Method

PdfEncoderOnProcessSegment Method

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnProcessSegment(
    SegmentProcessEventArgs args
)
Protected Overridable Sub OnProcessSegment (
    args As SegmentProcessEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.Codec.PdfSegmentProcessEventArgs
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method

PdfEncoderSave Method

Overload List
 | Name | Description
Public method | Save(Stream, AtalaImage, ProgressEventHandler) | Saves an image to a PDF file. (Overrides ImageEncoderSave(Stream, AtalaImage, ProgressEventHandler).)
Public method | Save(Stream, PdfImage, ProgressEventHandler) | Creates a single or multipage page PDF file from the specified PdfImage object.
Public method | Save(Stream, PdfImageCollection, ProgressEventHandler) | Saves one or more images to a PDF file.
Public method | Save(Stream, ImageCollection, ProgressEventHandler) | Saves all of the images in an ImageCollection to a PDF file. (Overrides MultiFramedImageEncoderSave(Stream, ImageCollection, ProgressEventHandler).)
Public method | Save(Stream, ImageSource, ProgressEventHandler) | Saves all of the images in an ImageSource to a PDF file. Only one Image of the ImageSource is in memory at any one time. (Overrides MultiFramedImageEncoderSave(Stream, ImageSource, ProgressEventHandler).)
Public method | Save(Stream, AtalaImage, PdfCompressionType, ProgressEventHandler) | Creates a single page PDF file from the specified image and compression.
Top
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method (Stream, AtalaImage, ProgressEventHandler)

PdfEncoderSave Method (Stream, AtalaImage, ProgressEventHandler)

Saves an image to a PDF file.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    AtalaImage image,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    image As AtalaImage,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream to write the PDF into.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The event handler used for progress events.

Return Value

Type: Int64
The number of bytes written.
Remarks
Uses the default compression (Auto) when saving individual images.
See Also

Reference

PdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method (Stream, PdfImage, ProgressEventHandler)

PdfEncoderSave Method (Stream, PdfImage, ProgressEventHandler)

Creates a single or multipage page PDF file from the specified PdfImage object.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Save(
    Stream stream,
    PdfImage image,
    ProgressEventHandler progress
)
Public Function Save (
    stream As Stream,
    image As PdfImage,
    progress As ProgressEventHandler
) As Integer

Parameters

stream
Type: System.IOStream
The stream to write the PDF file into. This stream must be seekable.
image
Type: Atalasoft.Imaging.Codec.PdfPdfImage
The PdfImage to encode.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int32

The number of bytes written to the output stream.

See Also

Reference

PdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method (Stream, PdfImageCollection, ProgressEventHandler)

PdfEncoderSave Method (Stream, PdfImageCollection, ProgressEventHandler)

Saves one or more images to a PDF file.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Save(
    Stream stream,
    PdfImageCollection images,
    ProgressEventHandler progress
)
Public Function Save (
    stream As Stream,
    images As PdfImageCollection,
    progress As ProgressEventHandler
) As Integer

Parameters

stream
Type: System.IOStream
The stream to save the PDF into. This stream must be seekable.
images
Type: Atalasoft.Imaging.Codec.PdfPdfImageCollection
The PdfImageCollection of images to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. May be null (Nothing in Visual Basic).

Return Value

Type: Int32
The number of bytes written to the stream.
See Also

Reference

PdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method (Stream, ImageCollection, ProgressEventHandler)

PdfEncoderSave Method (Stream, ImageCollection, ProgressEventHandler)

Saves all of the images in an ImageCollection to a PDF file.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    ImageCollection images,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    images As ImageCollection,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream to write the PDF into. This stream must be seekable.
images
Type: Atalasoft.ImagingImageCollection
An ImageCollection containing all of the images to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The number of bytes written.
See Also

Reference

PdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method (Stream, ImageSource, ProgressEventHandler)

PdfEncoderSave Method (Stream, ImageSource, ProgressEventHandler)

Saves all of the images in an ImageSource to a PDF file. Only one Image of the ImageSource is in memory at any one time.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override long Save(
    Stream stream,
    ImageSource images,
    ProgressEventHandler progress
)
Public Overrides Function Save (
    stream As Stream,
    images As ImageSource,
    progress As ProgressEventHandler
) As Long

Parameters

stream
Type: System.IOStream
The stream to write the PDF file into. This stream must be seekable.
images
Type: Atalasoft.ImagingImageSource
An image source representing a set of images to be written to the PDF Document.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int64
The number of bytes written to the output stream.
See Also

Reference

PdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.Save Method (Stream, AtalaImage, PdfCompressionType, ProgressEventHandler)

PdfEncoderSave Method (Stream, AtalaImage, PdfCompressionType, ProgressEventHandler)

Creates a single page PDF file from the specified image and compression.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Save(
    Stream stream,
    AtalaImage image,
    PdfCompressionType compression,
    ProgressEventHandler progress
)
Public Function Save (
    stream As Stream,
    image As AtalaImage,
    compression As PdfCompressionType,
    progress As ProgressEventHandler
) As Integer

Parameters

stream
Type: System.IOStream
The stream to write the PDF file into. This stream must be seekable.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to encode.
compression
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
The standard PDF compression to use on the image in the PDF.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Int32
The number of bytes written to the output stream.
Exceptions
Exception | Condition
CodecException | When segmentation algorithm is selected.
See Also

Reference

PdfEncoder Class
Save Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.SetOneTimePasswords Method

PdfEncoderSetOneTimePasswords Method

Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after calling Save method.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetOneTimePasswords(
    SecureString userPassword,
    SecureString ownerPassword = null
)
Public Sub SetOneTimePasswords (
    userPassword As SecureString,
    Optional ownerPassword As SecureString = Nothing
)

Parameters

userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password.
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.ToByteArray Method

PdfEncoderToByteArray Method

Saves the Pdf to a byte array.
Overload List
 | Name | Description
Public method | ToByteArray(AtalaImage, ProgressEventHandler) | Saves a single image as a PDF to a byte array.
Public method | ToByteArray(ImageCollection, ProgressEventHandler) | Save an ImageCollection as PDF to a byte array.
Public method | ToByteArray(PdfImageCollection, ProgressEventHandler) | Saves a PdfImageCollection as PDF to a byte array.
Top
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.ToByteArray Method (AtalaImage, ProgressEventHandler)

PdfEncoderToByteArray Method (AtalaImage, ProgressEventHandler)

Saves a single image as a PDF to a byte array.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray(
    AtalaImage image,
    ProgressEventHandler progress
)
Public Function ToByteArray (
    image As AtalaImage,
    progress As ProgressEventHandler
) As Byte()

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Byte
See Also

Reference

PdfEncoder Class
ToByteArray Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.ToByteArray Method (ImageCollection, ProgressEventHandler)

PdfEncoderToByteArray Method (ImageCollection, ProgressEventHandler)

Save an ImageCollection as PDF to a byte array.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray(
    ImageCollection images,
    ProgressEventHandler progress
)
Public Function ToByteArray (
    images As ImageCollection,
    progress As ProgressEventHandler
) As Byte()

Parameters

images
Type: Atalasoft.ImagingImageCollection
The ImageCollection to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Byte
See Also

Reference

PdfEncoder Class
ToByteArray Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.ToByteArray Method (PdfImageCollection, ProgressEventHandler)

PdfEncoderToByteArray Method (PdfImageCollection, ProgressEventHandler)

Saves a PdfImageCollection as PDF to a byte array.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray(
    PdfImageCollection images,
    ProgressEventHandler progress
)
Public Function ToByteArray (
    images As PdfImageCollection,
    progress As ProgressEventHandler
) As Byte()

Parameters

images
Type: Atalasoft.Imaging.Codec.PdfPdfImageCollection
The PdfImageCollection to save.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress delegate. Can be set to null (Nothing in Visual Basic).

Return Value

Type: Byte
See Also

Reference

PdfEncoder Class
ToByteArray Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder Events

The PdfEncoder type exposes the following members.

Events
 | Name | Description
Public event | ProcessSegment | With this event users may control color type of each segment and even set desired color type for the segments found by PdfEncoder during saving PDFs when segmentation algorithm is used to compress PDFs (see Mode).
Public event | SetEncoderCompression | Occurs when the encoder needs to select a compression. (Inherited from MultiFramedImageEncoder.)
Top
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfEncoder.ProcessSegment Event

PdfEncoderProcessSegment Event

With this event users may control color type of each segment and even set desired color type for the segments found by PdfEncoder during saving PDFs when segmentation algorithm is used to compress PDFs (see Mode).

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<SegmentProcessEventArgs> ProcessSegment
Public Event ProcessSegment As EventHandler(Of SegmentProcessEventArgs)

Value

Type: SystemEventHandlerSegmentProcessEventArgs
See Also

Reference

PdfEncoder Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Class

Contains information about a single image or file to be added to the PDF.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfPdfImage

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImage
Public Class PdfImage

The PdfImage type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImage(AtalaImage, PdfCompressionType) | Creates a new PdfImage specifying image and compression.
Public method | PdfImage(Stream, Int32, PdfCompressionType) | Creates an instance of PdfImage from a stream, frameIndex and compression.
Public method | PdfImage(String, Int32, PdfCompressionType) | Creates a new PdfImage specifying fileName, frameIndex and compression.
Top
Properties
 | Name | Description
Public property | Compression | Gets the compression used on the image data.
Public property | FileName | Gets the filename or url for the image.
Public property | Frame | Gets the frame of image to be saved from either a filename or a stream. -1 indicates that this image represents every image in the stream or file.
Public property | Image | Gets the AtalaImage that will be saved to the PDF.
Public property | Stream | Gets the stream containing an image to be saved into PDF
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This object is used for more low level control when saving a PDF image using the PdfEncoder.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Constructor

Overload List
 | Name | Description
Public method | PdfImage(AtalaImage, PdfCompressionType) | Creates a new PdfImage specifying image and compression.
Public method | PdfImage(Stream, Int32, PdfCompressionType) | Creates an instance of PdfImage from a stream, frameIndex and compression.
Public method | PdfImage(String, Int32, PdfCompressionType) | Creates a new PdfImage specifying fileName, frameIndex and compression.
Top
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Constructor (AtalaImage, PdfCompressionType)

Creates a new PdfImage specifying image and compression.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImage(
    AtalaImage image,
    PdfCompressionType compression
)
Public Sub New (
    image As AtalaImage,
    compression As PdfCompressionType
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage represented by this.
compression
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
The PdfCompressionType to use when saving this.
See Also

Reference

PdfImage Class
PdfImage Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Constructor (Stream, Int32, PdfCompressionType)

Creates an instance of PdfImage from a stream, frameIndex and compression.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImage(
    Stream stream,
    int frameIndex,
    PdfCompressionType compression
)
Public Sub New (
    stream As Stream,
    frameIndex As Integer,
    compression As PdfCompressionType
)

Parameters

stream
Type: System.IOStream
A stream containing an image file.
frameIndex
Type: SystemInt32
The frame index within the stream. -1 means "all frames".
compression
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
The type of compression to use when saving this.
See Also

Reference

PdfImage Class
PdfImage Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Constructor (String, Int32, PdfCompressionType)

Creates a new PdfImage specifying fileName, frameIndex and compression.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImage(
    string fileName,
    int frameIndex,
    PdfCompressionType compression
)
Public Sub New (
    fileName As String,
    frameIndex As Integer,
    compression As PdfCompressionType
)

Parameters

fileName
Type: SystemString
The full path and filename of an image file.
frameIndex
Type: SystemInt32
The page index, for a multipage file. -1 means "all frames".
compression
Type: Atalasoft.Imaging.Codec.PdfPdfCompressionType
The PdfCompressionType to use when saving this.
See Also

Reference

PdfImage Class
PdfImage Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Properties

The PdfImage type exposes the following members.

Properties
 | Name | Description
Public property | Compression | Gets the compression used on the image data.
Public property | FileName | Gets the filename or url for the image.
Public property | Frame | Gets the frame of image to be saved from either a filename or a stream. -1 indicates that this image represents every image in the stream or file.
Public property | Image | Gets the AtalaImage that will be saved to the PDF.
Public property | Stream | Gets the stream containing an image to be saved into PDF
Top
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage.Compression Property

PdfImageCompression Property

Gets the compression used on the image data.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressionType Compression { get; set; }
Public Property Compression As PdfCompressionType
    Get
    Set

Property Value

Type: PdfCompressionType
The compression used on the image data.
Remarks
If you specify a compression that is unsupported for a specific image, it will be replaced with a compatible compression.
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage.FileName Property

PdfImageFileName Property

Gets the filename or url for the image.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The filename of an image to be saved to PDF.
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage.Frame Property

PdfImageFrame Property

Gets the frame of image to be saved from either a filename or a stream. -1 indicates that this image represents every image in the stream or file.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Frame { get; }
Public ReadOnly Property Frame As Integer
    Get

Property Value

Type: Int32
The frame of image to be saved from either a filename or a stream. -1 indicates that this image represents every image in the stream or file.
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage.Image Property

PdfImageImage Property

Gets the AtalaImage that will be saved to the PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
The AtalaImage that will be saved to the PDF.
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage.Stream Property

PdfImageStream Property

Gets the stream containing an image to be saved into PDF

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
The stream containing an image to be saved into PDF.
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImage Methods

The PdfImage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImage Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection Class

Contains a collection of PdfImage objects to be saved to PDF.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.Codec.PdfPdfImageCollection

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageCollection : CollectionBase
Public Class PdfImageCollection
    Inherits CollectionBase

The PdfImageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageCollection | Creates an instance of PdfImageCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the PdfImage at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds a PdfImage to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns true if a PdfImage is located in the collection.
Public method | CopyTo(PdfImage) |
Public method | CopyTo(PdfImage, Int32) | Copies the current PdfCollection into an array starting at the specified index.
Public method | CopyTo(Int32, PdfImage, Int32, Int32) | Copies the current PdfCollection into an array
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of the specified PdfImage.
Public method | Insert | Inserts a PdfImage into this collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified PdfImage from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection Constructor

Creates an instance of PdfImageCollection.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageCollection()
Public Sub New
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection Properties

The PdfImageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the PdfImage at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.Item Property

PdfImageCollectionItem Property

Gets the PdfImage at the specified index.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImage this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PdfImage
    Get

Parameters

index
Type: SystemInt32
The zero-based index of the PdfImage to get.

Property Value

Type: PdfImage
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection Methods

The PdfImageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a PdfImage to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns true if a PdfImage is located in the collection.
Public method | CopyTo(PdfImage) |
Public method | CopyTo(PdfImage, Int32) | Copies the current PdfCollection into an array starting at the specified index.
Public method | CopyTo(Int32, PdfImage, Int32, Int32) | Copies the current PdfCollection into an array
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of the specified PdfImage.
Public method | Insert | Inserts a PdfImage into this collection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified PdfImage from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.Add Method

PdfImageCollectionAdd Method

Adds a PdfImage to the collection.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    PdfImage image
)
Public Sub Add (
    image As PdfImage
)

Parameters

image
Type: Atalasoft.Imaging.Codec.PdfPdfImage
The PdfImage to add.
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.Contains Method

PdfImageCollectionContains Method

Returns true if a PdfImage is located in the collection.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PdfImage image
)
Public Function Contains (
    image As PdfImage
) As Boolean

Parameters

image
Type: Atalasoft.Imaging.Codec.PdfPdfImage
The PdfImage to search for.

Return Value

Type: Boolean
True if the PdfImage exists, otherwise false.
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.CopyTo Method

PdfImageCollectionCopyTo Method

Copies the current PdfCollection into an array.
Overload List
 | Name | Description
Public method | CopyTo(PdfImage) |
Public method | CopyTo(PdfImage, Int32) | Copies the current PdfCollection into an array starting at the specified index.
Public method | CopyTo(Int32, PdfImage, Int32, Int32) | Copies the current PdfCollection into an array
Top
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.CopyTo Method (PdfImage[])

PdfImageCollectionCopyTo Method (PdfImage)

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    PdfImage[] array
)
Public Sub CopyTo (
    array As PdfImage()
)

Parameters

array
Type: Atalasoft.Imaging.Codec.PdfPdfImage
See Also

Reference

PdfImageCollection Class
CopyTo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.CopyTo Method (PdfImage[], Int32)

PdfImageCollectionCopyTo Method (PdfImage, Int32)

Copies the current PdfCollection into an array starting at the specified index.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    PdfImage[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As PdfImage(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.Imaging.Codec.PdfPdfImage
Destination array of PdfImage objects.
arrayIndex
Type: SystemInt32
The zero-based index at which copying begins.
See Also

Reference

PdfImageCollection Class
CopyTo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.CopyTo Method (Int32, PdfImage[], Int32, Int32)

PdfImageCollectionCopyTo Method (Int32, PdfImage, Int32, Int32)

Copies the current PdfCollection into an array

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    int index,
    PdfImage[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    index As Integer,
    array As PdfImage(),
    arrayIndex As Integer,
    count As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index in the source PdfCollection at which copying begins.
array
Type: Atalasoft.Imaging.Codec.PdfPdfImage
Destination array of PdfImage objects.
arrayIndex
Type: SystemInt32
The zero-based index at which copying begins.
count
Type: SystemInt32
The nubmer of elements to copy.
See Also

Reference

PdfImageCollection Class
CopyTo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.IndexOf Method

PdfImageCollectionIndexOf Method

Returns the index of the specified PdfImage.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    PdfImage image
)
Public Function IndexOf (
    image As PdfImage
) As Integer

Parameters

image
Type: Atalasoft.Imaging.Codec.PdfPdfImage
The PdfImage to search for.

Return Value

Type: Int32
Returns the zero based index of the collection, or -1 if the item doesn't exist.
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.Insert Method

PdfImageCollectionInsert Method

Inserts a PdfImage into this collection at the specified index.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    PdfImage image
)
Public Sub Insert (
    index As Integer,
    image As PdfImage
)

Parameters

index
Type: SystemInt32
The index to insert into.
image
Type: Atalasoft.Imaging.Codec.PdfPdfImage
The PdfImage to insert.
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageCollection.Remove Method

PdfImageCollectionRemove Method

Remove a specified PdfImage from the collection.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    PdfImage image
)
Public Sub Remove (
    image As PdfImage
)

Parameters

image
Type: Atalasoft.Imaging.Codec.PdfPdfImage
The PdfImage to remove.
See Also

Reference

PdfImageCollection Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo Class

Includes information about an image that is created from a PDF page using the PdfDecoder.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.CodecImageInfo
Atalasoft.Imaging.Codec.PdfPdfImageInfo

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageInfo : ImageInfo
Public Class PdfImageInfo
    Inherits ImageInfo

The PdfImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageInfo(Int32, Document) | Initializes a new instance of the PdfImageInfo class
Public method | PdfImageInfo(Int32, Document, Int32) | Initializes a new instance of the PdfImageInfo class
Top
Properties
 | Name | Description
Public property | Author | Gets the person who authored this document.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | Creator | Gets the application that created this document before it was converted to PDF.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | Keywords | Gets the keywords of this document.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Producer | Gets the application or module that created this PDF document.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | Subject | Gets the subject of this document.
Public property | Title | Gets the title of this document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo Constructor

Overload List
 | Name | Description
Public method | PdfImageInfo(Int32, Document) | Initializes a new instance of the PdfImageInfo class
Public method | PdfImageInfo(Int32, Document, Int32) | Initializes a new instance of the PdfImageInfo class
Top
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo Constructor (Int32, Document)

Initializes a new instance of the PdfImageInfo class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageInfo(
    int resolution,
    Document document
)
Public Sub New (
    resolution As Integer,
    document As Document
)

Parameters

resolution
Type: SystemInt32
document
Type: Atalasoft.Imaging.Codec.PdfDocument
See Also

Reference

PdfImageInfo Class
PdfImageInfo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo Constructor (Int32, Document, Int32)

Initializes a new instance of the PdfImageInfo class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageInfo(
    int resolution,
    Document document,
    int pageIndex
)
Public Sub New (
    resolution As Integer,
    document As Document,
    pageIndex As Integer
)

Parameters

resolution
Type: SystemInt32
document
Type: Atalasoft.Imaging.Codec.PdfDocument
pageIndex
Type: SystemInt32
See Also

Reference

PdfImageInfo Class
PdfImageInfo Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo Properties

The PdfImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets the person who authored this document.
Public property | ColorDepth | The bits per pixel of the image, as loaded. (Inherited from ImageInfo.)
Public property | Creator | Gets the application that created this document before it was converted to PDF.
Public property | FrameCount | The number of frames/images/pages in the file. (Inherited from ImageInfo.)
Public property | ImageType | Obsolete. The file format. (Inherited from ImageInfo.)
Public property | Keywords | Gets the keywords of this document.
Public property | PixelFormat | The PixelFormat of the image, as loaded. (Inherited from ImageInfo.)
Public property | Producer | Gets the application or module that created this PDF document.
Public property | Resolution | The image resolution, usually in dots per inch. (Inherited from ImageInfo.)
Public property | Size | The width and height of the image, as loaded. (Inherited from ImageInfo.)
Public property | Subject | Gets the subject of this document.
Public property | Title | Gets the title of this document.
Top
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo.Author Property

PdfImageInfoAuthor Property

Gets the person who authored this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; }
Public ReadOnly Property Author As String
    Get

Property Value

Type: String
The person who authored this document.
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo.Creator Property

PdfImageInfoCreator Property

Gets the application that created this document before it was converted to PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; }
Public ReadOnly Property Creator As String
    Get

Property Value

Type: String
The application that created this document before it was converted to PDF.
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo.Keywords Property

PdfImageInfoKeywords Property

Gets the keywords of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Keywords { get; }
Public ReadOnly Property Keywords As String
    Get

Property Value

Type: String
The keywords of this document.
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo.Producer Property

PdfImageInfoProducer Property

Gets the application or module that created this PDF document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Producer { get; }
Public ReadOnly Property Producer As String
    Get

Property Value

Type: String
The application or module that created this PDF document.
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo.Subject Property

PdfImageInfoSubject Property

Gets the subject of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get

Property Value

Type: String
The subject of this document.
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo.Title Property

PdfImageInfoTitle Property

Gets the title of this document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
The title of this document.
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfImageInfo Methods

The PdfImageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from ImageInfo.)
Top
See Also

Reference

PdfImageInfo Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata Class

Contains general information about the PDF file.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfPdfMetadata

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfMetadata
Public Class PdfMetadata

The PdfMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | PdfMetadata | Creates a new instance of PdfMetadata.
Public method | PdfMetadata(String, String, String, String, String, String, DateTime, DateTime) | Creates a new instance of PdfMetadata specifying title, author, subject, keywords, creator, producer, creationDate and modifiedDate.
Top
Properties
 | Name | Description
Public property | Author | Gets or sets the author of this PDF.
Public property | CreationDate | Gets or sets the creation date of this PDF.
Public property | Creator | Gets or sets the application that created the original document if the document was converted to PDF from another format.
Public property | Keywords | Gets or sets keywords associated with the document.
Public property | ModifiedDate | Gets or sets the date and time the document was most recently modified.
Public property | Producer | Gets or sets the name of the application that produced this document if the document was converted to PDF from another format.
Public property | Subject | Gets or sets the subject of the document.
Public property | Title | Gets or sets the document's title.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToPdfDateValue | Convert a System.DateTime to a PDF date value: D:YYYYMMDDhhmmssZ
 | ToSecondsPrecision | Round a DateTime down to the nearest second i.e. strip off Milliseconds
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

If the strings in metadata contain a parentheses or backslash, the character must be escaped with a backslash.

PDF Metadata is used in the PdfEncoder to indicate information such as Author, Creator, Keywords, etc.

See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata Constructor

Overload List
 | Name | Description
Public method | PdfMetadata | Creates a new instance of PdfMetadata.
Public method | PdfMetadata(String, String, String, String, String, String, DateTime, DateTime) | Creates a new instance of PdfMetadata specifying title, author, subject, keywords, creator, producer, creationDate and modifiedDate.
Top
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata Constructor

Creates a new instance of PdfMetadata.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMetadata()
Public Sub New
See Also

Reference

PdfMetadata Class
PdfMetadata Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata Constructor (String, String, String, String, String, String, DateTime, DateTime)

Creates a new instance of PdfMetadata specifying title, author, subject, keywords, creator, producer, creationDate and modifiedDate.
Creates a new instance of PdfMetadata.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMetadata(
    string title,
    string author,
    string subject,
    string keywords,
    string creator,
    string producer,
    DateTime creationDate,
    DateTime modifiedDate
)
Public Sub New (
    title As String,
    author As String,
    subject As String,
    keywords As String,
    creator As String,
    producer As String,
    creationDate As DateTime,
    modifiedDate As DateTime
)

Parameters

title
Type: SystemString
The document's title.
author
Type: SystemString
The author of this PDF.
subject
Type: SystemString
The subject of the document.
keywords
Type: SystemString
Keywords associated with the document.
creator
Type: SystemString
The application that created the original document if the document was converted to PDF from another format.
producer
Type: SystemString
The name of the application that produced this document if the document was converted to PDF from another format.
creationDate
Type: SystemDateTime
The creation date of this PDF.
modifiedDate
Type: SystemDateTime
The date and time the document was most recently modified.
See Also

Reference

PdfMetadata Class
PdfMetadata Overload
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata Properties

The PdfMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets or sets the author of this PDF.
Public property | CreationDate | Gets or sets the creation date of this PDF.
Public property | Creator | Gets or sets the application that created the original document if the document was converted to PDF from another format.
Public property | Keywords | Gets or sets keywords associated with the document.
Public property | ModifiedDate | Gets or sets the date and time the document was most recently modified.
Public property | Producer | Gets or sets the name of the application that produced this document if the document was converted to PDF from another format.
Public property | Subject | Gets or sets the subject of the document.
Public property | Title | Gets or sets the document's title.
Top
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.Author Property

PdfMetadataAuthor Property

Gets or sets the author of this PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set

Property Value

Type: String
The author of this PDF.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.CreationDate Property

PdfMetadataCreationDate Property

Gets or sets the creation date of this PDF.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
The creation date of this PDF.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.Creator Property

PdfMetadataCreator Property

Gets or sets the application that created the original document if the document was converted to PDF from another format.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set

Property Value

Type: String
The application that created the original document if the document was converted to PDF from another format.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.Keywords Property

PdfMetadataKeywords Property

Gets or sets keywords associated with the document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set

Property Value

Type: String
Keywords associated with the document.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.ModifiedDate Property

PdfMetadataModifiedDate Property

Gets or sets the date and time the document was most recently modified.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime ModifiedDate { get; set; }
Public Property ModifiedDate As DateTime
    Get
    Set

Property Value

Type: DateTime
The date and time the document was most recently modified.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.Producer Property

PdfMetadataProducer Property

Gets or sets the name of the application that produced this document if the document was converted to PDF from another format.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Producer { get; set; }
Public Property Producer As String
    Get
    Set

Property Value

Type: String
The name of the application that produced this document if the document was converted to PDF from another format.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.Subject Property

PdfMetadataSubject Property

Gets or sets the subject of the document.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set

Property Value

Type: String
The subject of the document.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.Title Property

PdfMetadataTitle Property

Gets or sets the document's title.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The document's title.
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata Methods

The PdfMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToPdfDateValue | Convert a System.DateTime to a PDF date value: D:YYYYMMDDhhmmssZ
 | ToSecondsPrecision | Round a DateTime down to the nearest second i.e. strip off Milliseconds
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.ToPdfDateValue Method

PdfMetadataToPdfDateValue Method

Convert a System.DateTime to a PDF date value: D:YYYYMMDDhhmmssZ

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string ToPdfDateValue(
    DateTime t
)
Public Shared Function ToPdfDateValue (
    t As DateTime
) As String

Parameters

t
Type: SystemDateTime
a System.DateTime value

Return Value

Type: String
the corresponding PDF date value: D:YYYYMMDDhhmmssZ
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfMetadata.ToSecondsPrecision Method

PdfMetadataToSecondsPrecision Method

Round a DateTime down to the nearest second i.e. strip off Milliseconds

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DateTime ToSecondsPrecision(
    DateTime t
)
Public Shared Function ToSecondsPrecision (
    t As DateTime
) As DateTime

Parameters

t
Type: SystemDateTime
arbitrary DateTime

Return Value

Type: DateTime
input value but with Millisecond set to 0
See Also

Reference

PdfMetadata Class
Atalasoft.Imaging.Codec.Pdf Namespace


PdfPageSizeMode Enumeration

Used to set the page SizeMode of a PDF document created with PdfEncoder.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPageSizeMode
Public Enumeration PdfPageSizeMode
Members
Member name | Description
FitToImage | This will cause each page to be resized to the size of the image, plus any PageBorder.
FitToPage | This will make each page in the PDF the same PageSize. If an image is too large to fit in the page, it will be rendered smaller in order to fit. If the image is smaller than the page, it will be centered.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings Class

Encapsulates all settings that control the render process.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfRenderSettings

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RenderSettings
Public Class RenderSettings

The RenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RenderSettings | Initializes a new instance of the RenderSettings class
Top
Properties
 | Name | Description
Public property | AnnotationSettings | All settings related to annotation rendering.
Public property | ColorSettings | Gets a render process color settings.
Public property | FontSubstitutionMap | Not used
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings Constructor

Initializes a new instance of the RenderSettings class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderSettings()
Public Sub New
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings Properties

The RenderSettings type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationSettings | All settings related to annotation rendering.
Public property | ColorSettings | Gets a render process color settings.
Public property | FontSubstitutionMap | Not used
Top
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings.AnnotationSettings Property

RenderSettingsAnnotationSettings Property

All settings related to annotation rendering.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRenderSettings AnnotationSettings { get; set; }
Public Property AnnotationSettings As AnnotationRenderSettings
    Get
    Set

Property Value

Type: AnnotationRenderSettings
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings.ColorSettings Property

RenderSettingsColorSettings Property

Gets a render process color settings.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorRenderSettings ColorSettings { get; }
Public ReadOnly Property ColorSettings As ColorRenderSettings
    Get

Property Value

Type: ColorRenderSettings
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings.FontSubstitutionMap Property

RenderSettingsFontSubstitutionMap Property

Not used

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontSubstitutionMap FontSubstitutionMap { get; }
Public ReadOnly Property FontSubstitutionMap As FontSubstitutionMap
    Get

Property Value

Type: FontSubstitutionMap
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


RenderSettings Methods

The RenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RenderSettings Class
Atalasoft.Imaging.Codec.Pdf Namespace


SegmentColorType Enumeration

Describes color types of pdf segments.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SegmentColorType
Public Enumeration SegmentColorType
Members
Member name | Description
BlackAndWhite | Indicates that the specified segment is black and white.
Gray | Indicates that the specified segment is gray.
Color | Indicates that the specified segment is color.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


SegmentProcessEventArgs Class

Defines an event that is used to process segment images.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.Codec.PdfSegmentProcessEventArgs

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SegmentProcessEventArgs : EventArgs
Public Class SegmentProcessEventArgs
    Inherits EventArgs

The SegmentProcessEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentProcessEventArgs | Initializes a new instance of the SegmentProcessEventArgs class
Top
Properties
 | Name | Description
Public property | ColorType | Gets or sets segment color type.
Public property | Segment | Gets or sets segment image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


SegmentProcessEventArgs Constructor

Initializes a new instance of the SegmentProcessEventArgs class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentProcessEventArgs()
Public Sub New
See Also

Reference

SegmentProcessEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


SegmentProcessEventArgs Properties

The SegmentProcessEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ColorType | Gets or sets segment color type.
Public property | Segment | Gets or sets segment image.
Top
See Also

Reference

SegmentProcessEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


SegmentProcessEventArgs.ColorType Property

SegmentProcessEventArgsColorType Property

Gets or sets segment color type.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentColorType ColorType { get; set; }
Public Property ColorType As SegmentColorType
    Get
    Set

Property Value

Type: SegmentColorType
See Also

Reference

SegmentProcessEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


SegmentProcessEventArgs.Segment Property

SegmentProcessEventArgsSegment Property

Gets or sets segment image.

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.Pdf (in Atalasoft.dotImage.Pdf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Segment { get; set; }
Public Property Segment As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

SegmentProcessEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


SegmentProcessEventArgs Methods

The SegmentProcessEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SegmentProcessEventArgs Class
Atalasoft.Imaging.Codec.Pdf Namespace


Summary Class

Provides a summary of the rasterization process. This class is currently empty and has been added for future extension.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.PdfSummary

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Summary
Public Class Summary

The Summary type exposes the following members.

Constructors
 | Name | Description
Public method | Summary | Initializes a new instance of the Summary class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
An instance of this class is returned by the [!:Page::Draw] method.
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


Summary Constructor

Initializes a new instance of the Summary class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Summary()
Public Sub New
See Also

Reference

Summary Class
Atalasoft.Imaging.Codec.Pdf Namespace


Summary Methods

The Summary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Summary Class
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Class

This exception is thrown if a PDF is opened with the wrong password
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.Codec.PdfWrongPasswordException

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class WrongPasswordException : Exception
<SerializableAttribute>
Public Class WrongPasswordException
    Inherits Exception

The WrongPasswordException type exposes the following members.

Constructors
 | Name | Description
Public method | WrongPasswordException | Creates a WrongPasswordException
Public method | WrongPasswordException(String) | Creates a WrongPasswordException with the given message
Protected method | WrongPasswordException(SerializationInfo, StreamingContext) | Initializes a new instance of the WrongPasswordException class
Public method | WrongPasswordException(String, Exception) | Creates a WrongPasswordException with the given message and chains it to the given exception
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Constructor

Create a WrongPasswordException
Overload List
 | Name | Description
Public method | WrongPasswordException | Creates a WrongPasswordException
Public method | WrongPasswordException(String) | Creates a WrongPasswordException with the given message
Protected method | WrongPasswordException(SerializationInfo, StreamingContext) | Initializes a new instance of the WrongPasswordException class
Public method | WrongPasswordException(String, Exception) | Creates a WrongPasswordException with the given message and chains it to the given exception
Top
See Also

Reference

WrongPasswordException Class
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Constructor

Creates a WrongPasswordException

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WrongPasswordException()
Public Sub New
See Also

Reference

WrongPasswordException Class
WrongPasswordException Overload
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Constructor (String)

Creates a WrongPasswordException with the given message

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WrongPasswordException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

WrongPasswordException Class
WrongPasswordException Overload
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the WrongPasswordException class

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WrongPasswordException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

WrongPasswordException Class
WrongPasswordException Overload
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Constructor (String, Exception)

Creates a WrongPasswordException with the given message and chains it to the given exception

Namespace: Atalasoft.Imaging.Codec.Pdf
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WrongPasswordException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

WrongPasswordException Class
WrongPasswordException Overload
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Properties

The WrongPasswordException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongPasswordException Class
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Methods

The WrongPasswordException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongPasswordException Class
Atalasoft.Imaging.Codec.Pdf Namespace


WrongPasswordException Events

The WrongPasswordException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

WrongPasswordException Class
Atalasoft.Imaging.Codec.Pdf Namespace


Atalasoft.Imaging.Codec.Tiff Namespace

Classes
 | Class | Description
Public class | TiffDirectory | Represents a single TIFF page.
Public class | TiffDirectoryCollection | For use as part of a TiffFile. Holds the collection of images that make up the pages in a TIFF.
Public class | TiffDocument | The TiffDocument class is used to represent an entire TIFF file in a way that makes it convenient to manipulate the pages of the document. Pages can be reordered, inserted, added, and removed. The final document can then be saved to a new file. TiffDocument keeps as little in memory at one time as possible.
 | TiffFile | TiffFile is a class that allows access to a TIFF image file directly, without loading the image into memory. It represents a single TIFF document which can contain multiple pages.
Public class | TiffPage | An object that represents a page within a TiffDocument.
Public class | TiffPageCollection | A collection object used to hold a set of TiffPage objects.


TiffDirectory Class

Represents a single TIFF page.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.TiffTiffDirectory

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffDirectory : IDisposable
Public Class TiffDirectory
    Implements IDisposable

The TiffDirectory type exposes the following members.

Constructors
 | Name | Description
Public method | TiffDirectory(AtalaImage) | Creates a new TiffDirectory from an AtalaImage
Public method | TiffDirectory(AtalaImage, TiffCompression) | Creates a new TiffDirectory using the specified compression.
Public method | TiffDirectory(AtalaImage, TiffEncoder) | Creates a new TiffDirectory with the specified Tiff Encoder.
Top
Properties
 | Name | Description
Public property | AllowVitalTagChanges | Sets or gets a flag determining if changes should be allowed in vital TIFF tags.
Public property | ExifTags | Gets or sets a collection of EXIF Tags that will be saved with the image.
 | Tags | Gets the collection of TiffTag objects associated with the image.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the TiffDirectory.
Protected method | Dispose(Boolean) | Disposes the TiffDirectory.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the TiffDirectory class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Fires the Error event
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CodecError | This event is raised an a non critical error exists when reading a TIFF File.
Top
Remarks
A TiffDirectory represents a single page in a TiffFile. It can be constructed by the TiffFile class internally, returning an object that contains all the TIFF tags with no binary image data, or it can be constructed by the developer and represent actual image data and tag information that will be saved into an existing TiffFile.
See Also

Reference

Atalasoft.Imaging.Codec.Tiff Namespace
TiffFile Class


TiffDirectory Constructor

Creates a new TiffDirectory instance.
Overload List
 | Name | Description
Public method | TiffDirectory(AtalaImage) | Creates a new TiffDirectory from an AtalaImage
Public method | TiffDirectory(AtalaImage, TiffCompression) | Creates a new TiffDirectory using the specified compression.
Public method | TiffDirectory(AtalaImage, TiffEncoder) | Creates a new TiffDirectory with the specified Tiff Encoder.
Top
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory Constructor (AtalaImage)

Creates a new TiffDirectory from an AtalaImage

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDirectory(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image data that the TiffDirectory will represent.
See Also

Reference

TiffDirectory Class
TiffDirectory Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory Constructor (AtalaImage, TiffCompression)

Creates a new TiffDirectory using the specified compression.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDirectory(
    AtalaImage image,
    TiffCompression compression
)
Public Sub New (
    image As AtalaImage,
    compression As TiffCompression
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image data that the TiffDirectory will represent.
compression
Type: Atalasoft.Imaging.CodecTiffCompression
The compression to use when the image data is encoded
See Also

Reference

TiffDirectory Class
TiffDirectory Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory Constructor (AtalaImage, TiffEncoder)

Creates a new TiffDirectory with the specified Tiff Encoder.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDirectory(
    AtalaImage image,
    TiffEncoder tiff
)
Public Sub New (
    image As AtalaImage,
    tiff As TiffEncoder
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image data that the TiffDirectory will represent.
tiff
Type: Atalasoft.Imaging.CodecTiffEncoder
The encoding settings to use when the image data is encoded
See Also

Reference

TiffDirectory Class
TiffDirectory Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory Properties

The TiffDirectory type exposes the following members.

Properties
 | Name | Description
Public property | AllowVitalTagChanges | Sets or gets a flag determining if changes should be allowed in vital TIFF tags.
Public property | ExifTags | Gets or sets a collection of EXIF Tags that will be saved with the image.
 | Tags | Gets the collection of TiffTag objects associated with the image.
Top
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.AllowVitalTagChanges Property

TiffDirectoryAllowVitalTagChanges Property

Sets or gets a flag determining if changes should be allowed in vital TIFF tags.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowVitalTagChanges { get; set; }
Public Property AllowVitalTagChanges As Boolean
    Get
    Set

Property Value

Type: Boolean
True if client code is allowed to change vital tags
Remarks

When certain tags are modified indiscriminantly, it is possible to permanently damage a TIFF file. In dotImage 5.0 and earlier, it was not possible to modify these tags as doing so was considered an error.

In the 6.0 and above, these tags are now accessible. The list of vital tags includes:

Strip Byte Counts, Strip Offsets, Tile Byte Counts, Tile Offsets, Bits Per Sample, Rows Per Strip

See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.ExifTags Property

TiffDirectoryExifTags Property

Gets or sets a collection of EXIF Tags that will be saved with the image.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifCollection ExifTags { get; set; }
Public Property ExifTags As ExifCollection
    Get
    Set

Property Value

Type: ExifCollection
Remarks
See ExifParser for obtaining EXIF Tags from a TIFF (or JPEG) image. When this property is set, the subsequent Save(Stream) will store the EXIF information contained within this property to the file.
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.Tags Property

TiffDirectoryTags Property

Gets the collection of TiffTag objects associated with the image.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTagCollection Tags { get; }
Public ReadOnly Property Tags As TiffTagCollection
    Get

Property Value

Type: TiffTagCollection
A TiffTagCollection representing all TIFF Tags in the image.
Exceptions
Exception | Condition
 | Thrown when the TiffFile's stream is closed when accessing a tag that is originally loaded as a data pointer. This usually is the case for string and binary data.
Remarks

WARNING!!!

TIFF Tags can be edited, added, and removed using this collection property. However the developer is expected to have full understanding of the TIFF specification. Editing tags in ways that are not supported by the TIFF specification can create a corrupt file.

For example, changing the ImageWidth, ImageHeight, Compression, Photometric, and others to an unexpected value will result in a corrupt TIFF file.

When reading TIFF Tags, the TiffFile stream must remain open to read some tags that are populated only when accessing the Data property.

Examples

Displays all TIFF Tags from a TIFF document.

GetAllTagsCS (C#)
Copy
TiffFile file = new TiffFile();
using (Stream fs1 = new FileStream("file1.tif", FileMode.Open, FileAccess.Read, FileShare.Read))
{
        file.Read(fs1);
        foreach (TiffDirectory image in file.Images)
        {
                foreach (TiffTag tag in image.Tags)
                {
                        Console.WriteLine(tag.ToString());
                }
        }
}
GetAllTagsVB (Visual Basic)
Copy
Dim file As TiffFile = New TiffFile()
Dim fs1 As Stream = New FileStream("file1.tif", FileMode.Open, FileAccess.Read, FileShare.Read)
Try
        file.Read(fs1)
        ForEach image As TiffDirectory In file.Images
                ForEach tag As TiffTag In image.Tags
                        Console.WriteLine(tag.ToString())
                Next
        Next
Finally
    fs1.Close()
End Try

Adds a new ImageDescription tag to a TIFF File.

AddNewTagCS (C#)
Copy
TiffFile file = new TiffFile("multi.tif");
file.Images[0].Tags.Add(
            new TiffTag(TiffTagID.ImageDescription,
            "Created with the DotImage Example Code",
            TiffTagDataType.Ascii));
file.Save("multi_newtag.tif");
AddNewTagVB (Visual Basic)
Copy
Dim file As TiffFile = New TiffFile("multi.tif")
file.Images(0).Tags.Add( _
            New TiffTag(TiffTagID.ImageDescription, _
            "Created with the DotImage Example Code", _
            TiffTagDataType.Ascii))
file.Save("multi_newtag.tif")
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory Methods

The TiffDirectory type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the TiffDirectory.
Protected method | Dispose(Boolean) | Disposes the TiffDirectory.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the TiffDirectory class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Fires the Error event
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.Dispose Method

TiffDirectoryDispose Method

Disposes the TiffDirectory.
Overload List
 | Name | Description
Public method | Dispose | Disposes the TiffDirectory.
Protected method | Dispose(Boolean) | Disposes the TiffDirectory.
Top
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.Dispose Method

TiffDirectoryDispose Method

Disposes the TiffDirectory.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

TiffDirectory Class
Dispose Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.Dispose Method (Boolean)

TiffDirectoryDispose Method (Boolean)

Disposes the TiffDirectory.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether or not the object is being disposed via the Dispose method (true) or the finalize method (false)
See Also

Reference

TiffDirectory Class
Dispose Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.Finalize Method

TiffDirectoryFinalize Method

Finalizes an instance of the TiffDirectory class.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.OnError Method

TiffDirectoryOnError Method

Fires the Error event

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnError(
    CodecErrorEventArgs e
)
Protected Overridable Sub OnError (
    e As CodecErrorEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.CodecCodecErrorEventArgs
A CodecErrorEventArgs object specifying the error
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory Events

The TiffDirectory type exposes the following members.

Events
 | Name | Description
Public event | CodecError | This event is raised an a non critical error exists when reading a TIFF File.
Top
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectory.CodecError Event

TiffDirectoryCodecError Event

This event is raised an a non critical error exists when reading a TIFF File.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CodecErrorEventHandler CodecError
Public Event CodecError As CodecErrorEventHandler

Value

Type: Atalasoft.Imaging.CodecCodecErrorEventHandler
See Also

Reference

TiffDirectory Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection Class

For use as part of a TiffFile. Holds the collection of images that make up the pages in a TIFF.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.Codec.TiffTiffDirectoryCollection

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffDirectoryCollection : CollectionBase
Public Class TiffDirectoryCollection
    Inherits CollectionBase

The TiffDirectoryCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TiffDirectoryCollection | Creates a new TiffDirectoryCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the TiffDirectory at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds a TiffDirectory to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Checks for the Existance of an entry in the collection.
Public method | CopyTo | Copies an entry of the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified TiffDirectory and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Adds a TiffDirectory at a specified index to the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a TiffDirectory from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Swap | Swaps two entries in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Tiff Namespace
TiffFile Class


TiffDirectoryCollection Constructor

Creates a new TiffDirectoryCollection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDirectoryCollection()
Public Sub New
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection Properties

The TiffDirectoryCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the TiffDirectory at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.Item Property

TiffDirectoryCollectionItem Property

Gets the TiffDirectory at the specified index.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDirectory this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As TiffDirectory
    Get
    Set

Parameters

index
Type: SystemInt32
The zero-based index to get the entry from.

Property Value

Type: TiffDirectory
The TiffDirectory located at the specified index.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection Methods

The TiffDirectoryCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a TiffDirectory to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Checks for the Existance of an entry in the collection.
Public method | CopyTo | Copies an entry of the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified TiffDirectory and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | Adds a TiffDirectory at a specified index to the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a TiffDirectory from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Swap | Swaps two entries in the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.Add Method

TiffDirectoryCollectionAdd Method

Adds a TiffDirectory to the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Add(
    TiffDirectory value
)
Public Overridable Function Add (
    value As TiffDirectory
) As Integer

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffDirectory
The TiffDirectory to add.

Return Value

Type: Int32
The index the TiffDirectory was added at.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.Contains Method

TiffDirectoryCollectionContains Method

Checks for the Existance of an entry in the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    TiffDirectory value
)
Public Overridable Function Contains (
    value As TiffDirectory
) As Boolean

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffDirectory
The TiffDirectory to look for.

Return Value

Type: Boolean
True if the object exists in the collection, false otherwise.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.CopyTo Method

TiffDirectoryCollectionCopyTo Method

Copies an entry of the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    TiffDirectory[] value,
    int index
)
Public Overridable Sub CopyTo (
    value As TiffDirectory(),
    index As Integer
)

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffDirectory
The TiffDirectory to copy to.
index
Type: SystemInt32
The index of the entry in the collection to copy.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.IndexOf Method

TiffDirectoryCollectionIndexOf Method

Searches for the specified TiffDirectory and returns the zero-based index of the first occurrence within the entire collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    TiffDirectory value
)
Public Overridable Function IndexOf (
    value As TiffDirectory
) As Integer

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffDirectory
The TiffDirectory to search for.

Return Value

Type: Int32
The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.Insert Method

TiffDirectoryCollectionInsert Method

Adds a TiffDirectory at a specified index to the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    TiffDirectory value
)
Public Overridable Sub Insert (
    index As Integer,
    value As TiffDirectory
)

Parameters

index
Type: SystemInt32
The zero-based index to add the TiffDirectory at.
value
Type: Atalasoft.Imaging.Codec.TiffTiffDirectory
The TiffDirectory to add.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.Remove Method

TiffDirectoryCollectionRemove Method

Removes a TiffDirectory from the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    TiffDirectory value
)
Public Overridable Sub Remove (
    value As TiffDirectory
)

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffDirectory
The TiffDirectory to remove.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDirectoryCollection.Swap Method

TiffDirectoryCollectionSwap Method

Swaps two entries in the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Swap(
    int m,
    int n
)
Public Overridable Sub Swap (
    m As Integer,
    n As Integer
)

Parameters

m
Type: SystemInt32
The zero-based index of the first TiffDirectory to swap.
n
Type: SystemInt32
The zero-based index of the second TiffDirectory to swap.
See Also

Reference

TiffDirectoryCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Class

The TiffDocument class is used to represent an entire TIFF file in a way that makes it convenient to manipulate the pages of the document. Pages can be reordered, inserted, added, and removed. The final document can then be saved to a new file. TiffDocument keeps as little in memory at one time as possible.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.TiffTiffDocument

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffDocument
Public Class TiffDocument

The TiffDocument type exposes the following members.

Constructors
 | Name | Description
Public method | TiffDocument | Constructs a new empty TiffDocument.
Public method | TiffDocument(Stream) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given stream.
Public method | TiffDocument(String) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given file.
Public method | TiffDocument(Stream, Boolean) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given stream.
Public method | TiffDocument(String, Boolean) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given file.
Top
Properties
 | Name | Description
Public property | Pages | A collection of TiffPage objects that represent the contents of the Tiff file.
Top
Methods
 | Name | Description
 | Combine(Stream, Stream) | Combines a set of TIFF Streams into a single output TIFF Stream
 | Combine(Stream, String) | Combines a set of TIFF files into a single output TIFF Stream
 | Combine(String, String) | Combines a set of TIFF files into a single output TIFF file
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream) | Saves the contents of this TiffDocument into a new stream.
Public method | Save(String) | Saves every TiffPage within the TiffDocument object into a new TIFF file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidOutputStream | Test a stream to see if it can be used as an output stream for this TiffDocument.
Top
Remarks
When saving, TiffDocument does not recompress image data.
See Also

Reference

Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Constructor

Constructs a new TiffDocument object.
Overload List
 | Name | Description
Public method | TiffDocument | Constructs a new empty TiffDocument.
Public method | TiffDocument(Stream) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given stream.
Public method | TiffDocument(String) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given file.
Public method | TiffDocument(Stream, Boolean) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given stream.
Public method | TiffDocument(String, Boolean) | Constructs a new TiffDocument class, populated the Pages property with the contents of the given file.
Top
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Constructor

Constructs a new empty TiffDocument.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDocument()
Public Sub New
See Also

Reference

TiffDocument Class
TiffDocument Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Constructor (Stream)

Constructs a new TiffDocument class, populated the Pages property with the contents of the given stream.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDocument(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A seekable stream whose contents is a TIFF.
Remarks
The constructor will throw an exception if the stream is null or does not represent a TIFF stream.
See Also

Reference

TiffDocument Class
TiffDocument Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Constructor (String)

Constructs a new TiffDocument class, populated the Pages property with the contents of the given file.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDocument(
    string filename
)
Public Sub New (
    filename As String
)

Parameters

filename
Type: SystemString
A path to a TIFF file.
Remarks
The constructor will throw an exception if the file is null or does not represent a TIFF.
See Also

Reference

TiffDocument Class
TiffDocument Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Constructor (Stream, Boolean)

Constructs a new TiffDocument class, populated the Pages property with the contents of the given stream.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDocument(
    Stream stream,
    bool tolerateBadTiffStructure
)
Public Sub New (
    stream As Stream,
    tolerateBadTiffStructure As Boolean
)

Parameters

stream
Type: System.IOStream
A seekable stream whose contents is a TIFF.
tolerateBadTiffStructure
Type: SystemBoolean
The value indicating whether to process truncated tiff files.
Remarks
The constructor will throw an exception if the stream is null or does not represent a TIFF stream.
See Also

Reference

TiffDocument Class
TiffDocument Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Constructor (String, Boolean)

Constructs a new TiffDocument class, populated the Pages property with the contents of the given file.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDocument(
    string filename,
    bool tolerateBadTiffStructure
)
Public Sub New (
    filename As String,
    tolerateBadTiffStructure As Boolean
)

Parameters

filename
Type: SystemString
A path to a TIFF file.
tolerateBadTiffStructure
Type: SystemBoolean
The value indicating whether to process truncated tiff files.
Remarks
The constructor will throw an exception if the file is null or does not represent a TIFF.
See Also

Reference

TiffDocument Class
TiffDocument Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Properties

The TiffDocument type exposes the following members.

Properties
 | Name | Description
Public property | Pages | A collection of TiffPage objects that represent the contents of the Tiff file.
Top
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Pages Property

TiffDocumentPages Property

A collection of TiffPage objects that represent the contents of the Tiff file.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffPageCollection Pages { get; }
Public ReadOnly Property Pages As TiffPageCollection
    Get

Property Value

Type: TiffPageCollection
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument Methods

The TiffDocument type exposes the following members.

Methods
 | Name | Description
 | Combine(Stream, Stream) | Combines a set of TIFF Streams into a single output TIFF Stream
 | Combine(Stream, String) | Combines a set of TIFF files into a single output TIFF Stream
 | Combine(String, String) | Combines a set of TIFF files into a single output TIFF file
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream) | Saves the contents of this TiffDocument into a new stream.
Public method | Save(String) | Saves every TiffPage within the TiffDocument object into a new TIFF file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidOutputStream | Test a stream to see if it can be used as an output stream for this TiffDocument.
Top
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Combine Method

TiffDocumentCombine Method

Combines two or more TIFF files or streams into a single output stream.
Overload List
Name | Description
Combine(Stream, Stream) | Combines a set of TIFF Streams into a single output TIFF Stream
Combine(Stream, String) | Combines a set of TIFF files into a single output TIFF Stream
Combine(String, String) | Combines a set of TIFF files into a single output TIFF file
Top
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Combine Method (Stream, Stream[])

TiffDocumentCombine Method (Stream, Stream)

Combines a set of TIFF Streams into a single output TIFF Stream

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    Stream output,
    params Stream[] sources
)
Public Shared Sub Combine (
    output As Stream,
    ParamArray sources As Stream()
)

Parameters

output
Type: System.IOStream
The output stream that will contain the combined TIFF.
sources
Type: System.IOStream
An array of input streams that will be combined into a single output.
Remarks
Each of these methods use a params array as the final argument so that they can be invoked with or without the array object (ie, Combine(outputStream, file1, file2, file2)).
See Also

Reference

TiffDocument Class
Combine Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Combine Method (Stream, String[])

TiffDocumentCombine Method (Stream, String)

Combines a set of TIFF files into a single output TIFF Stream

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    Stream output,
    params string[] sourceFiles
)
Public Shared Sub Combine (
    output As Stream,
    ParamArray sourceFiles As String()
)

Parameters

output
Type: System.IOStream
The output stream that will contain the combined TIFF.
sourceFiles
Type: SystemString
An array of input file names that will be combined into a single output.
See Also

Reference

TiffDocument Class
Combine Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Combine Method (String, String[])

TiffDocumentCombine Method (String, String)

Combines a set of TIFF files into a single output TIFF file

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    string outputFile,
    params string[] sourceFiles
)
Public Shared Sub Combine (
    outputFile As String,
    ParamArray sourceFiles As String()
)

Parameters

outputFile
Type: SystemString
The output file that will contain the combined TIFF.
sourceFiles
Type: SystemString
An array of input file names that will be combined into a single output.
See Also

Reference

TiffDocument Class
Combine Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Save Method

TiffDocumentSave Method

Overload List
 | Name | Description
Public method | Save(Stream) | Saves the contents of this TiffDocument into a new stream.
Public method | Save(String) | Saves every TiffPage within the TiffDocument object into a new TIFF file.
Top
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Save Method (Stream)

TiffDocumentSave Method (Stream)

Saves the contents of this TiffDocument into a new stream.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outputStream
)
Public Sub Save (
    outputStream As Stream
)

Parameters

outputStream
Type: System.IOStream
The stream where the file will be saved. The outputStream object may not be the source of one or more of the TiffDocument's TiffPage objects. This condition will cause TiffDocument to throw an ArgumentException. The outputStream may not be null.
See Also

Reference

TiffDocument Class
Save Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.Save Method (String)

TiffDocumentSave Method (String)

Saves every TiffPage within the TiffDocument object into a new TIFF file.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName
)
Public Sub Save (
    fileName As String
)

Parameters

fileName
Type: SystemString
The non-null path to the file to be saved. The Save method to a path does not check to see if the output path is the same as any of the input paths. If it is, the results will be unpredictable and most likely will result in a damaged TIFF file.
See Also

Reference

TiffDocument Class
Save Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffDocument.ValidOutputStream Method

TiffDocumentValidOutputStream Method

Test a stream to see if it can be used as an output stream for this TiffDocument.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ValidOutputStream(
    Stream stm
)
Public Function ValidOutputStream (
    stm As Stream
) As Boolean

Parameters

stm
Type: System.IOStream
The stream to write to.

Return Value

Type: Boolean
Returns true if the stream is different from the streams used by each of the TiffPage objects contained within this TiffDocument.
See Also

Reference

TiffDocument Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile Class

TiffFile is a class that allows access to a TIFF image file directly, without loading the image into memory. It represents a single TIFF document which can contain multiple pages.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.TiffTiffFile

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffFile
Public Class TiffFile

The TiffFile type exposes the following members.

Constructors
 | Name | Description
Public method | TiffFile | Creates a new TiffFile instance.
Top
Properties
 | Name | Description
Public property | Images | Gets the image collection that is part of this TiffFile.
Public property | TolerateBadTiffStructure | Gets or sets a value indicating whether to accept truncated tiff files or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPageCount | Returns the number of pages in a TIFF
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Fires the Error event
Public method | Read(Stream) | Reads directories and tags for all pages.
Public method | Read(Stream, Int32) | Reads directories and tags for a specific page.
Public method | Save(Stream) | Saves the TiffFile to a Stream.
Public method | Save(String) | Saves the TiffFile to a file path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CodecError | This event is used by the TiffFile object to report errors that occur when parsing a TiffDirectory.
Top
Examples
Add an arbitrary TIFF tag.
C#
Copy
TiffFile oneTiff = new TiffFile();
oneTiff.Read(inputStream);
// access a TiffDirectory
TiffDirectory image = oneTiff.Images[0];
// access TiffTagCollection
TiffTagCollection tags = image.Tags;
// add Tiff Tags (add copy-right)
tags.Add(new TiffTag(TiffTagID.Copyright, "DotImage"));
// add Tiff Tags
string datetime = "2005:07:26 09:31:23";
tags.Add(new TiffTag(TiffTagID.DateTime, datetime, TiffTagDataType.Ascii));
// save
oneTiff.Save(targetStream);
Demonstrates how to insert a page into an existing TIFF
C#
Copy
string sourceFileName = "1_multi.tif";
string tempFileName = "multi_.tif";

using (Stream fs = File.OpenRead(sourceFileName))
{
    TiffFile tFile = new TiffFile();
    tFile.Read(fs);
    using (TiffDirectory tImage = new TiffDirectory(new AtalaImage(100, 100, PixelFormat.Pixel24bppBgr),
        TiffCompression.JpegCompression))
    {
        tFile.Images.Insert(1, tImage);
        tFile.Save(tempFileName);
    }
}

File.Delete(sourceFileName);
System.IO.File.Move(tempFileName, sourceFileName);
See Also

Reference

Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile Constructor

Creates a new TiffFile instance.
Initializes a new instance of TiffFile

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffFile()
Public Sub New
Remarks
The initialized TiffFIle contains no pages. See the Read(Stream) method to populate the Tags and images.
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile Properties

The TiffFile type exposes the following members.

Properties
 | Name | Description
Public property | Images | Gets the image collection that is part of this TiffFile.
Public property | TolerateBadTiffStructure | Gets or sets a value indicating whether to accept truncated tiff files or not.
Top
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Images Property

TiffFileImages Property

Gets the image collection that is part of this TiffFile.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffDirectoryCollection Images { get; }
Public ReadOnly Property Images As TiffDirectoryCollection
    Get

Property Value

Type: TiffDirectoryCollection
A TiffDirectoryCollection representing each image in the file.
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.TolerateBadTiffStructure Property

TiffFileTolerateBadTiffStructure Property

Gets or sets a value indicating whether to accept truncated tiff files or not.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TolerateBadTiffStructure { get; set; }
Public Property TolerateBadTiffStructure As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile Methods

The TiffFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPageCount | Returns the number of pages in a TIFF
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Fires the Error event
Public method | Read(Stream) | Reads directories and tags for all pages.
Public method | Read(Stream, Int32) | Reads directories and tags for a specific page.
Public method | Save(Stream) | Saves the TiffFile to a Stream.
Public method | Save(String) | Saves the TiffFile to a file path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.GetPageCount Method

TiffFileGetPageCount Method

Returns the number of pages in a TIFF

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetPageCount(
    Stream source
)
Public Shared Function GetPageCount (
    source As Stream
) As Integer

Parameters

source
Type: System.IOStream
Encoded image stream

Return Value

Type: Int32
number of pages
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.OnError Method

TiffFileOnError Method

Fires the Error event

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnError(
    CodecErrorEventArgs e
)
Protected Overridable Sub OnError (
    e As CodecErrorEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.CodecCodecErrorEventArgs
A CodecErrorEventArgs object specifying the error
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Read Method

TiffFileRead Method

Read will populate the Tags and TiffIfdCollection.
Overload List
 | Name | Description
Public method | Read(Stream) | Reads directories and tags for all pages.
Public method | Read(Stream, Int32) | Reads directories and tags for a specific page.
Top
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Read Method (Stream)

TiffFileRead Method (Stream)

Reads directories and tags for all pages.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Read(
    Stream stream
)
Public Sub Read (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
Encoded image stream
See Also

Reference

TiffFile Class
Read Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Read Method (Stream, Int32)

TiffFileRead Method (Stream, Int32)

Reads directories and tags for a specific page.
Open an existing TIFF Document, parsing the tags for each directory.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Read(
    Stream stream,
    int frameIndex
)
Public Sub Read (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
Encoded image stream
frameIndex
Type: SystemInt32
Frame index to read
Remarks

The same stream or path cannot be used to read and save a TiffFile object. To overwrite an existing TIFF, save the TIFF into a new file, then overwrite the original.

The stream must remain open while accessing TIFF Tags and managing IFD's.

See Also

Reference

TiffFile Class
Read Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Save Method

TiffFileSave Method

Saves the TiffFile.
Overload List
 | Name | Description
Public method | Save(Stream) | Saves the TiffFile to a Stream.
Public method | Save(String) | Saves the TiffFile to a file path.
Top
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Save Method (Stream)

TiffFileSave Method (Stream)

Saves the TiffFile to a Stream.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream target
)
Public Sub Save (
    target As Stream
)

Parameters

target
Type: System.IOStream
The Stream to save the TiffFile to.
Remarks
The target stream must be different from the stream or filepath that was used to open the TiffFile.
Remarks
The same stream or path cannot be used to open and save a TiffFile object. To overwrite an existing TIFF, save the TIFF into a new file, then overwrite the original.
See Also

Reference

TiffFile Class
Save Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.Save Method (String)

TiffFileSave Method (String)

Saves the TiffFile to a file path.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string path
)
Public Sub Save (
    path As String
)

Parameters

path
Type: SystemString
The file path to save the TiffFile to.
Remarks
The target stream must be different from the stream or filepath that was used to open the TiffFile.
See Also

Reference

TiffFile Class
Save Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile Events

The TiffFile type exposes the following members.

Events
 | Name | Description
Public event | CodecError | This event is used by the TiffFile object to report errors that occur when parsing a TiffDirectory.
Top
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffFile.CodecError Event

TiffFileCodecError Event

This event is used by the TiffFile object to report errors that occur when parsing a TiffDirectory.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CodecErrorEventHandler CodecError
Public Event CodecError As CodecErrorEventHandler

Value

Type: Atalasoft.Imaging.CodecCodecErrorEventHandler
Remarks
The DotImage Tiff decoder is aggressive in suppressing errors encountered while parsing damaged or somewhat malformed Tiff files. Normally these errors are not reported. This event provides a mechanism for an application to record, report, or abort in the event of an error.
See Also

Reference

TiffFile Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage Class

An object that represents a page within a TiffDocument.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.Codec.TiffTiffPage

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffPage
Public Class TiffPage

The TiffPage type exposes the following members.

Constructors
 | Name | Description
Public method | TiffPage(AtalaImage) | Constructs a new TiffPage object from the given image.
Public method | TiffPage(AtalaImage, TiffCompression) | Constructs a new TiffPage object from the given image, using the specified compression.
Top
Properties
 | Name | Description
Public property | Frame | Gets the original frame number of this page within its stream
Public property | PixelFormat | Returns the PixelFormat of the page.
Public property | Resolution | Returns the resolution of the page.
Public property | Size | Returns the dimensions of the page in pixels.
Public property | Stream | Returns the stream from which the TiffPage originally came.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage Constructor

Overload List
 | Name | Description
Public method | TiffPage(AtalaImage) | Constructs a new TiffPage object from the given image.
Public method | TiffPage(AtalaImage, TiffCompression) | Constructs a new TiffPage object from the given image, using the specified compression.
Top
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage Constructor (AtalaImage)

Constructs a new TiffPage object from the given image.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffPage(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage object to use for a TiffPage
Remarks
Non-destructive compression for the image will be automatically selected.
See Also

Reference

TiffPage Class
TiffPage Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage Constructor (AtalaImage, TiffCompression)

Constructs a new TiffPage object from the given image, using the specified compression.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffPage(
    AtalaImage image,
    TiffCompression compression
)
Public Sub New (
    image As AtalaImage,
    compression As TiffCompression
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage object to use for a TiffPage
compression
Type: Atalasoft.Imaging.CodecTiffCompression

Compression to use for the image

See Also

Reference

TiffPage Class
TiffPage Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage Properties

The TiffPage type exposes the following members.

Properties
 | Name | Description
Public property | Frame | Gets the original frame number of this page within its stream
Public property | PixelFormat | Returns the PixelFormat of the page.
Public property | Resolution | Returns the resolution of the page.
Public property | Size | Returns the dimensions of the page in pixels.
Public property | Stream | Returns the stream from which the TiffPage originally came.
Top
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage.Frame Property

TiffPageFrame Property

Gets the original frame number of this page within its stream

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Frame { get; }
Public ReadOnly Property Frame As Integer
    Get

Property Value

Type: Int32
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage.PixelFormat Property

TiffPagePixelFormat Property

Returns the PixelFormat of the page.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat PixelFormat { get; }
Public ReadOnly Property PixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage.Resolution Property

TiffPageResolution Property

Returns the resolution of the page.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; }
Public ReadOnly Property Resolution As Dpi
    Get

Property Value

Type: Dpi
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage.Size Property

TiffPageSize Property

Returns the dimensions of the page in pixels.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get

Property Value

Type: Size
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage.Stream Property

TiffPageStream Property

Returns the stream from which the TiffPage originally came.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
Remarks
Modifying the stream object (or the contents of the stream) will create unpredictable results.
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPage Methods

The TiffPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffPage Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection Class

A collection object used to hold a set of TiffPage objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.Codec.TiffTiffPageCollection

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffPageCollection : CollectionBase
Public Class TiffPageCollection
    Inherits CollectionBase

The TiffPageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TiffPageCollection | Constructs a new TiffPageCollection
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Sets or gets the nth item in this collection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add(TiffPage) | Adds the TiffPage to the end of this collection.
Public method | Add(TiffPageCollection) | Adds the entire contents of the TiffPageCollection to the end of this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Indicates if a TiffPage is contained in this collection
Public method | CopyTo | Copies the contents of this collection into a given array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a given TiffPage object.
Public method | Insert | Inserts a TiffPage into this collection at the given location.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a given TiffPage from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection Constructor

Constructs a new TiffPageCollection

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffPageCollection()
Public Sub New
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection Properties

The TiffPageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Sets or gets the nth item in this collection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Item Property

TiffPageCollectionItem Property

Sets or gets the nth item in this collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffPage this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As TiffPage
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to get or set.

Property Value

Type: TiffPage
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection Methods

The TiffPageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(TiffPage) | Adds the TiffPage to the end of this collection.
Public method | Add(TiffPageCollection) | Adds the entire contents of the TiffPageCollection to the end of this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Indicates if a TiffPage is contained in this collection
Public method | CopyTo | Copies the contents of this collection into a given array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a given TiffPage object.
Public method | Insert | Inserts a TiffPage into this collection at the given location.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a given TiffPage from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Add Method

TiffPageCollectionAdd Method

Adds a new page to the end
Overload List
 | Name | Description
Public method | Add(TiffPage) | Adds the TiffPage to the end of this collection.
Public method | Add(TiffPageCollection) | Adds the entire contents of the TiffPageCollection to the end of this collection.
Top
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Add Method (TiffPage)

TiffPageCollectionAdd Method (TiffPage)

Adds the TiffPage to the end of this collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    TiffPage value
)
Public Function Add (
    value As TiffPage
) As Integer

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffPage
A TiffPage to add.

Return Value

Type: Int32
See Also

Reference

TiffPageCollection Class
Add Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Add Method (TiffPageCollection)

TiffPageCollectionAdd Method (TiffPageCollection)

Adds the entire contents of the TiffPageCollection to the end of this collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    TiffPageCollection other
)
Public Sub Add (
    other As TiffPageCollection
)

Parameters

other
Type: Atalasoft.Imaging.Codec.TiffTiffPageCollection
A collection of TiffPage objects to add.
See Also

Reference

TiffPageCollection Class
Add Overload
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Contains Method

TiffPageCollectionContains Method

Indicates if a TiffPage is contained in this collection

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    TiffPage value
)
Public Function Contains (
    value As TiffPage
) As Boolean

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffPage
The TiffPage to look for.

Return Value

Type: Boolean
True if the TiffPage is contained in this collection, false otherwise.
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.CopyTo Method

TiffPageCollectionCopyTo Method

Copies the contents of this collection into a given array.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    TiffPage[] array,
    int index
)
Public Sub CopyTo (
    array As TiffPage(),
    index As Integer
)

Parameters

array
Type: Atalasoft.Imaging.Codec.TiffTiffPage
An non-null array of TiffPage objects
index
Type: SystemInt32
The index in the array where the collection elements will be put
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.IndexOf Method

TiffPageCollectionIndexOf Method

Returns the index of a given TiffPage object.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    TiffPage value
)
Public Function IndexOf (
    value As TiffPage
) As Integer

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffPage
The TiffPage to look for.

Return Value

Type: Int32
An integer >= 0 if the TiffPage is in this collection, -1 otherwise.
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Insert Method

TiffPageCollectionInsert Method

Inserts a TiffPage into this collection at the given location.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    TiffPage value
)
Public Sub Insert (
    index As Integer,
    value As TiffPage
)

Parameters

index
Type: SystemInt32
The location where the given TiffPage will be inserted.
value
Type: Atalasoft.Imaging.Codec.TiffTiffPage
The TiffPage object to insert.
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


TiffPageCollection.Remove Method

TiffPageCollectionRemove Method

Removes a given TiffPage from the collection.

Namespace: Atalasoft.Imaging.Codec.Tiff
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    TiffPage value
)
Public Sub Remove (
    value As TiffPage
)

Parameters

value
Type: Atalasoft.Imaging.Codec.TiffTiffPage
The TiffPage to remove.
See Also

Reference

TiffPageCollection Class
Atalasoft.Imaging.Codec.Tiff Namespace


Atalasoft.Imaging.ColorManagement Namespace

Classes
 | Class | Description
Public class | AtalaLittleCms |
Public class | ColorProfile | A color profile that is used for translating colors.
Public class | ColorTransform | Contains a color transform object and methods to convert from one colorspace to another using a ColorProfile.
Public class | InvalidColorProfileException | This exception fires when the ColorProfile used for a ColorTransform are invalid.
Enumerations
 | Enumeration | Description
Public enumeration | AtalaCmsPixelFormat |
Public enumeration | AtalaColorSpaceSignature |
Public enumeration | AtalaHeaderFlags |
Public enumeration | AtalaPlatformSignature |
Public enumeration | AtalaProfileClassSignature |
Public enumeration | AtalaRenderingIntent |
Public enumeration | AtalaTransformFlags |
Public enumeration | ColorSpace | A value that indicates the color space in which profile data is defined.
Public enumeration | ColorType | Describes the general color type
Public enumeration | Platform | Indicates the platform that the profile is intended for.
Public enumeration | ProfileClass | Indicates the profile class.
Public enumeration | ProfileFlags | Bit flags containing hints that the CMM uses to interpret the profile data.
Public enumeration | RenderingIntent | Indicates different methods to create a color rendering as defined by the International Color Consortium (ICC).


AtalaCmsPixelFormat Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AtalaCmsPixelFormat
Public Enumeration AtalaCmsPixelFormat
Members
Member name | Description
Gray8 |
Gray16 |
GrayAlpha |
Bgr24 |
Bgra |
Cmyk |
Bgr48 |
Bgra64 |
Cmyk16 |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaColorSpaceSignature Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AtalaColorSpaceSignature
Public Enumeration AtalaColorSpaceSignature
Members
Member name | Description
SigXYZData |
SigLabData |
SigLuvData |
SigYCbCrData |
SigYxyData |
SigRgbData |
SigGrayData |
SigHsvData |
SigHlsData |
SigCmykData |
SigCmyData |
Sig2colorData |
Sig3colorData |
Sig4colorData |
Sig5colorData |
Sig6colorData |
Sig7colorData |
Sig8colorData |
Sig9colorData |
Sig10colorData |
Sig11colorData |
Sig12colorData |
Sig13colorData |
Sig14colorData |
Sig15colorData |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaHeaderFlags Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum AtalaHeaderFlags
<FlagsAttribute>
Public Enumeration AtalaHeaderFlags
Members
Member name | Description
EmbeddedProfile |
DependentOnData |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ColorManagementAtalaLittleCms

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaLittleCms
Public Class AtalaLittleCms

The AtalaLittleCms type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaLittleCms | Initializes a new instance of the AtalaLittleCms class
Top
Methods
 | Name | Description
 | CloseColorProfile |
 | CreateColorTransform |
 | CreateProofingTransform |
 | DeleteColorTransform |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCmmType |
 | GetColorProfileVersion |
 | GetColorSpace |
 | GetCopyright |
 | GetCreator |
 | GetDescription |
 | GetDeviceClass |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHeaderFlags |
 | GetManufacturer |
 | GetModel |
 | GetPCS |
 | GetPlatform |
 | GetProductInfo |
 | GetRenderingIntent |
 | GetSRGBProfile |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenColorProfile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TransformImage |
Top
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms Constructor

Initializes a new instance of the AtalaLittleCms class

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaLittleCms()
Public Sub New
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms Methods

The AtalaLittleCms type exposes the following members.

Methods
 | Name | Description
 | CloseColorProfile |
 | CreateColorTransform |
 | CreateProofingTransform |
 | DeleteColorTransform |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCmmType |
 | GetColorProfileVersion |
 | GetColorSpace |
 | GetCopyright |
 | GetCreator |
 | GetDescription |
 | GetDeviceClass |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHeaderFlags |
 | GetManufacturer |
 | GetModel |
 | GetPCS |
 | GetPlatform |
 | GetProductInfo |
 | GetRenderingIntent |
 | GetSRGBProfile |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenColorProfile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TransformImage |
Top
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.CloseColorProfile Method

AtalaLittleCmsCloseColorProfile Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool CloseColorProfile(
    IntPtr handle
)
Public Shared Function CloseColorProfile (
    handle As IntPtr
) As Boolean

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Boolean
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.CreateColorTransform Method

AtalaLittleCmsCreateColorTransform Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr CreateColorTransform(
    IntPtr inputProfile,
    AtalaCmsPixelFormat inputFormat,
    IntPtr outputProfile,
    AtalaCmsPixelFormat outputFormat,
    AtalaRenderingIntent intent,
    AtalaTransformFlags flags
)
Public Shared Function CreateColorTransform (
    inputProfile As IntPtr,
    inputFormat As AtalaCmsPixelFormat,
    outputProfile As IntPtr,
    outputFormat As AtalaCmsPixelFormat,
    intent As AtalaRenderingIntent,
    flags As AtalaTransformFlags
) As IntPtr

Parameters

inputProfile
Type: SystemIntPtr
inputFormat
Type: Atalasoft.Imaging.ColorManagementAtalaCmsPixelFormat
outputProfile
Type: SystemIntPtr
outputFormat
Type: Atalasoft.Imaging.ColorManagementAtalaCmsPixelFormat
intent
Type: Atalasoft.Imaging.ColorManagementAtalaRenderingIntent
flags
Type: Atalasoft.Imaging.ColorManagementAtalaTransformFlags

Return Value

Type: IntPtr
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.CreateProofingTransform Method

AtalaLittleCmsCreateProofingTransform Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr CreateProofingTransform(
    IntPtr inputProfile,
    AtalaCmsPixelFormat inputFormat,
    IntPtr outputProfile,
    AtalaCmsPixelFormat outputFormat,
    IntPtr proofingProfile,
    AtalaRenderingIntent intent,
    AtalaRenderingIntent proofingIntent,
    AtalaTransformFlags flags
)
Public Shared Function CreateProofingTransform (
    inputProfile As IntPtr,
    inputFormat As AtalaCmsPixelFormat,
    outputProfile As IntPtr,
    outputFormat As AtalaCmsPixelFormat,
    proofingProfile As IntPtr,
    intent As AtalaRenderingIntent,
    proofingIntent As AtalaRenderingIntent,
    flags As AtalaTransformFlags
) As IntPtr

Parameters

inputProfile
Type: SystemIntPtr
inputFormat
Type: Atalasoft.Imaging.ColorManagementAtalaCmsPixelFormat
outputProfile
Type: SystemIntPtr
outputFormat
Type: Atalasoft.Imaging.ColorManagementAtalaCmsPixelFormat
proofingProfile
Type: SystemIntPtr
intent
Type: Atalasoft.Imaging.ColorManagementAtalaRenderingIntent
proofingIntent
Type: Atalasoft.Imaging.ColorManagementAtalaRenderingIntent
flags
Type: Atalasoft.Imaging.ColorManagementAtalaTransformFlags

Return Value

Type: IntPtr
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.DeleteColorTransform Method

AtalaLittleCmsDeleteColorTransform Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void DeleteColorTransform(
    IntPtr handle
)
Public Shared Sub DeleteColorTransform (
    handle As IntPtr
)

Parameters

handle
Type: SystemIntPtr
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetCmmType Method

AtalaLittleCmsGetCmmType Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetCmmType(
    IntPtr handle
)
Public Shared Function GetCmmType (
    handle As IntPtr
) As Integer

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetColorProfileVersion Method

AtalaLittleCmsGetColorProfileVersion Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetColorProfileVersion(
    IntPtr handle
)
Public Shared Function GetColorProfileVersion (
    handle As IntPtr
) As Integer

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetColorSpace Method

AtalaLittleCmsGetColorSpace Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaColorSpaceSignature GetColorSpace(
    IntPtr handle
)
Public Shared Function GetColorSpace (
    handle As IntPtr
) As AtalaColorSpaceSignature

Parameters

handle
Type: SystemIntPtr

Return Value

Type: AtalaColorSpaceSignature
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetCopyright Method

AtalaLittleCmsGetCopyright Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string GetCopyright(
    IntPtr hProfile
)
Public Shared Function GetCopyright (
    hProfile As IntPtr
) As String

Parameters

hProfile
Type: SystemIntPtr

Return Value

Type: String
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetCreator Method

AtalaLittleCmsGetCreator Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetCreator(
    IntPtr handle
)
Public Shared Function GetCreator (
    handle As IntPtr
) As Integer

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetDescription Method

AtalaLittleCmsGetDescription Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string GetDescription(
    IntPtr hProfile
)
Public Shared Function GetDescription (
    hProfile As IntPtr
) As String

Parameters

hProfile
Type: SystemIntPtr

Return Value

Type: String
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetDeviceClass Method

AtalaLittleCmsGetDeviceClass Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaProfileClassSignature GetDeviceClass(
    IntPtr handle
)
Public Shared Function GetDeviceClass (
    handle As IntPtr
) As AtalaProfileClassSignature

Parameters

handle
Type: SystemIntPtr

Return Value

Type: AtalaProfileClassSignature
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetHeaderFlags Method

AtalaLittleCmsGetHeaderFlags Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaHeaderFlags GetHeaderFlags(
    IntPtr handle
)
Public Shared Function GetHeaderFlags (
    handle As IntPtr
) As AtalaHeaderFlags

Parameters

handle
Type: SystemIntPtr

Return Value

Type: AtalaHeaderFlags
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetManufacturer Method

AtalaLittleCmsGetManufacturer Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetManufacturer(
    IntPtr handle
)
Public Shared Function GetManufacturer (
    handle As IntPtr
) As Integer

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetModel Method

AtalaLittleCmsGetModel Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetModel(
    IntPtr handle
)
Public Shared Function GetModel (
    handle As IntPtr
) As Integer

Parameters

handle
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetPCS Method

AtalaLittleCmsGetPCS Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaColorSpaceSignature GetPCS(
    IntPtr handle
)
Public Shared Function GetPCS (
    handle As IntPtr
) As AtalaColorSpaceSignature

Parameters

handle
Type: SystemIntPtr

Return Value

Type: AtalaColorSpaceSignature
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetPlatform Method

AtalaLittleCmsGetPlatform Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaPlatformSignature GetPlatform(
    IntPtr handle
)
Public Shared Function GetPlatform (
    handle As IntPtr
) As AtalaPlatformSignature

Parameters

handle
Type: SystemIntPtr

Return Value

Type: AtalaPlatformSignature
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetProductInfo Method

AtalaLittleCmsGetProductInfo Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string GetProductInfo(
    IntPtr hProfile
)
Public Shared Function GetProductInfo (
    hProfile As IntPtr
) As String

Parameters

hProfile
Type: SystemIntPtr

Return Value

Type: String
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetRenderingIntent Method

AtalaLittleCmsGetRenderingIntent Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaRenderingIntent GetRenderingIntent(
    IntPtr handle
)
Public Shared Function GetRenderingIntent (
    handle As IntPtr
) As AtalaRenderingIntent

Parameters

handle
Type: SystemIntPtr

Return Value

Type: AtalaRenderingIntent
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.GetSRGBProfile Method

AtalaLittleCmsGetSRGBProfile Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr GetSRGBProfile()
Public Shared Function GetSRGBProfile As IntPtr

Return Value

Type: IntPtr
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.OpenColorProfile Method

AtalaLittleCmsOpenColorProfile Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr OpenColorProfile(
    byte[] array
)
Public Shared Function OpenColorProfile (
    array As Byte()
) As IntPtr

Parameters

array
Type: SystemByte

Return Value

Type: IntPtr
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaLittleCms.TransformImage Method

AtalaLittleCmsTransformImage Method

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void TransformImage(
    IntPtr transform,
    IntPtr InputBuffer,
    int inputRowStride,
    IntPtr OutputBuffer,
    int outputRowStride,
    int Height,
    int Width
)
Public Shared Sub TransformImage (
    transform As IntPtr,
    InputBuffer As IntPtr,
    inputRowStride As Integer,
    OutputBuffer As IntPtr,
    outputRowStride As Integer,
    Height As Integer,
    Width As Integer
)

Parameters

transform
Type: SystemIntPtr
InputBuffer
Type: SystemIntPtr
inputRowStride
Type: SystemInt32
OutputBuffer
Type: SystemIntPtr
outputRowStride
Type: SystemInt32
Height
Type: SystemInt32
Width
Type: SystemInt32
See Also

Reference

AtalaLittleCms Class
Atalasoft.Imaging.ColorManagement Namespace


AtalaPlatformSignature Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AtalaPlatformSignature
Public Enumeration AtalaPlatformSignature
Members
Member name | Description
SigMacintosh |
SigMicrosoft |
SigSolaris |
SigSGI |
SigTaligent |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaProfileClassSignature Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AtalaProfileClassSignature
Public Enumeration AtalaProfileClassSignature
Members
Member name | Description
SigInputClass |
SigDisplayClass |
SigOutputClass |
SigLinkClass |
SigAbstractClass |
SigColorSpaceClass |
SigNamedColorClass |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaRenderingIntent Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AtalaRenderingIntent
Public Enumeration AtalaRenderingIntent
Members
Member name | Description
Perceptual |
RelativeColorimetric |
Saturation |
AbsoluteColorimetric |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


AtalaTransformFlags Enumeration

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage.Lib (in Atalasoft.dotImage.Lib.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum AtalaTransformFlags
<FlagsAttribute>
Public Enumeration AtalaTransformFlags
Members
Member name | Description
None |
BlackPointCompensation |
PreserveBlack |
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Class

A color profile that is used for translating colors.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ColorManagementColorProfile

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ColorProfile : IDisposable
Public Class ColorProfile
    Implements IDisposable

The ColorProfile type exposes the following members.

Constructors
 | Name | Description
Public method | ColorProfile(Byte) | Initializes a new instance of ColorProfile specifying a byte array containing the profile memory.
Public method | ColorProfile(Stream) | Initializes a new instance of ColorProfile specifying a stream containing the profile memory.
Public method | ColorProfile(String) | Initializes a new instance of ColorProfile specifying the filename containing a color profile.
Public method | ColorProfile(IntPtr, Int32) | Initializes a new instance of ColorProfile specifying a pointer to the profile memory and the size of this memory.
Top
Properties
 | Name | Description
Public property | Class | Gets the profile class.
Public property | CmmType | Gets the identification number of the CMM that is used in the profile. Identification numbers are registered with the ICC.
Public property | ColorSpace | Gets a value that indicates the color space in which the profile data is defined.
Public property | ConnectionColorSpace | Gets a value that indicates the color space in which the profile connection space (PCS) is defined.
Public property | Copyright | Gets the copyright information stored within the color profile.
Public property | Creator | Gets a signature of the software that created the profile. Signatures are registered with the ICC.
Public property | Description | Gets the description value stored within the color profile.
Public property | Flags | Gets bit flags containing hints that the CMM uses to interpret the profile data.
Public property | Manufacturer | Gets the identification number of the device profile manufacturer. All manufacturer identification numbers are registered with the ICC.
Public property | Model | Gets the device manufacturer's device model number. All model identification numbers are registered with the ICC.
Public property | Platform | Gets the primary platform for which the profile was created.
Public property | RenderingIntent | Gets the profile rendering intent.
Public property | Version | Gets the version number of this color profile.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ColorProfile class. (Overrides ObjectFinalize.)
 | FromEmbedded(Stream) | Returns a ColorProfile embedded within an image given the image stream.
 | FromEmbedded(String) | Returns a ColorProfile embedded within an image given the image file name.
 | FromSrgb | Returns the standard sRGB Color Profile.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProfileBytes | Gets the profile bytes.
 | GetProfileDirectory | Returns the path of the color profile directory.
 | GetProfileFromGraphics | Returns the color profile assigned to a specified Graphics object.
 | GetProfileFromScreen | Returns the default color profile assigned to the screen.
 | GetScreenProfileName | Returns the name of the color profile associated with the current display.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save this ColorProfile to a file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

Currently, dotImage will read and embed a color profile into a JPEG, TIFF, or PNG image. The profile is used when converting to different color spaces such as CMYK to RGB and RGB to CMYK.

See www.color.org for a detailed explanation of the ICC and color profiles.

See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Constructor

Overload List
 | Name | Description
Public method | ColorProfile(Byte) | Initializes a new instance of ColorProfile specifying a byte array containing the profile memory.
Public method | ColorProfile(Stream) | Initializes a new instance of ColorProfile specifying a stream containing the profile memory.
Public method | ColorProfile(String) | Initializes a new instance of ColorProfile specifying the filename containing a color profile.
Public method | ColorProfile(IntPtr, Int32) | Initializes a new instance of ColorProfile specifying a pointer to the profile memory and the size of this memory.
Top
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Constructor (Byte[])

ColorProfile Constructor (Byte)

Initializes a new instance of ColorProfile specifying a byte array containing the profile memory.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile(
    byte[] data
)
Public Sub New (
    data As Byte()
)

Parameters

data
Type: SystemByte
The bytes that contain the color profile.
See Also

Reference

ColorProfile Class
ColorProfile Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Constructor (Stream)

Initializes a new instance of ColorProfile specifying a stream containing the profile memory.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing a color profile.
See Also

Reference

ColorProfile Class
ColorProfile Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Constructor (String)

Initializes a new instance of ColorProfile specifying the filename containing a color profile.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The file name of the color profile (usually with the ICM or ICC extension).
See Also

Reference

ColorProfile Class
ColorProfile Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Constructor (IntPtr, Int32)

Initializes a new instance of ColorProfile specifying a pointer to the profile memory and the size of this memory.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile(
    IntPtr mempointer,
    int size
)
Public Sub New (
    mempointer As IntPtr,
    size As Integer
)

Parameters

mempointer
Type: SystemIntPtr
A pointer to the memory containing a color profile.
size
Type: SystemInt32
The size of the memory pointer in bytes.
See Also

Reference

ColorProfile Class
ColorProfile Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Properties

The ColorProfile type exposes the following members.

Properties
 | Name | Description
Public property | Class | Gets the profile class.
Public property | CmmType | Gets the identification number of the CMM that is used in the profile. Identification numbers are registered with the ICC.
Public property | ColorSpace | Gets a value that indicates the color space in which the profile data is defined.
Public property | ConnectionColorSpace | Gets a value that indicates the color space in which the profile connection space (PCS) is defined.
Public property | Copyright | Gets the copyright information stored within the color profile.
Public property | Creator | Gets a signature of the software that created the profile. Signatures are registered with the ICC.
Public property | Description | Gets the description value stored within the color profile.
Public property | Flags | Gets bit flags containing hints that the CMM uses to interpret the profile data.
Public property | Manufacturer | Gets the identification number of the device profile manufacturer. All manufacturer identification numbers are registered with the ICC.
Public property | Model | Gets the device manufacturer's device model number. All model identification numbers are registered with the ICC.
Public property | Platform | Gets the primary platform for which the profile was created.
Public property | RenderingIntent | Gets the profile rendering intent.
Public property | Version | Gets the version number of this color profile.
Top
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Class Property

ColorProfileClass Property

Gets the profile class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProfileClass Class { get; }
Public ReadOnly Property Class As ProfileClass
    Get

Property Value

Type: ProfileClass
The profile class.
Remarks
The profile class indicates a type of profile. For example Input, Display, Color Space Conversion, etc.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.CmmType Property

ColorProfileCmmType Property

Gets the identification number of the CMM that is used in the profile. Identification numbers are registered with the ICC.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CmmType { get; }
Public ReadOnly Property CmmType As Integer
    Get

Property Value

Type: Int32
The identification number of the CMM that is used in the profile.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.ColorSpace Property

ColorProfileColorSpace Property

Gets a value that indicates the color space in which the profile data is defined.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorSpace ColorSpace { get; }
Public ReadOnly Property ColorSpace As ColorSpace
    Get

Property Value

Type: ColorSpace
A value that indicates the color space in which the profile data is defined.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.ConnectionColorSpace Property

ColorProfileConnectionColorSpace Property

Gets a value that indicates the color space in which the profile connection space (PCS) is defined.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorSpace ConnectionColorSpace { get; }
Public ReadOnly Property ConnectionColorSpace As ColorSpace
    Get

Property Value

Type: ColorSpace
The color space in which the profile connection space (PCS) is defined.
Remarks
Can be either XYZ or Lab.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Copyright Property

ColorProfileCopyright Property

Gets the copyright information stored within the color profile.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Copyright { get; }
Public ReadOnly Property Copyright As String
    Get

Property Value

Type: String
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Creator Property

ColorProfileCreator Property

Gets a signature of the software that created the profile. Signatures are registered with the ICC.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Creator { get; }
Public ReadOnly Property Creator As Integer
    Get

Property Value

Type: Int32
A signature of the software that created the profile.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Description Property

ColorProfileDescription Property

Gets the description value stored within the color profile.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Flags Property

ColorProfileFlags Property

Gets bit flags containing hints that the CMM uses to interpret the profile data.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProfileFlags Flags { get; }
Public ReadOnly Property Flags As ProfileFlags
    Get

Property Value

Type: ProfileFlags
Bit flags containing hints that the CMM uses to interpret the profile data.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Manufacturer Property

ColorProfileManufacturer Property

Gets the identification number of the device profile manufacturer. All manufacturer identification numbers are registered with the ICC.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Manufacturer { get; }
Public ReadOnly Property Manufacturer As Integer
    Get

Property Value

Type: Int32
The identification number of the device profile manufacturer.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Model Property

ColorProfileModel Property

Gets the device manufacturer's device model number. All model identification numbers are registered with the ICC.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Model { get; }
Public ReadOnly Property Model As Integer
    Get

Property Value

Type: Int32
The device manufacturer's device model number.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Platform Property

ColorProfilePlatform Property

Gets the primary platform for which the profile was created.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Platform Platform { get; }
Public ReadOnly Property Platform As Platform
    Get

Property Value

Type: Platform
The primary platform for which the profile was created.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.RenderingIntent Property

ColorProfileRenderingIntent Property

Gets the profile rendering intent.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent RenderingIntent { get; }
Public ReadOnly Property RenderingIntent As RenderingIntent
    Get

Property Value

Type: RenderingIntent
The profile rendering intent.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Version Property

ColorProfileVersion Property

Gets the version number of this color profile.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get

Property Value

Type: String
The version number of this color profile.
Remarks

The string returned is in the format of "0.0.0" where the first number if the major version, the second is the minor version, and the last is the bug fix version.

See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile Methods

The ColorProfile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ColorProfile class. (Overrides ObjectFinalize.)
 | FromEmbedded(Stream) | Returns a ColorProfile embedded within an image given the image stream.
 | FromEmbedded(String) | Returns a ColorProfile embedded within an image given the image file name.
 | FromSrgb | Returns the standard sRGB Color Profile.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProfileBytes | Gets the profile bytes.
 | GetProfileDirectory | Returns the path of the color profile directory.
 | GetProfileFromGraphics | Returns the color profile assigned to a specified Graphics object.
 | GetProfileFromScreen | Returns the default color profile assigned to the screen.
 | GetScreenProfileName | Returns the name of the color profile associated with the current display.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save this ColorProfile to a file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Dispose Method

ColorProfileDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Dispose Method

ColorProfileDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ColorProfile Class
Dispose Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Dispose Method (Boolean)

ColorProfileDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ColorProfile Class
Dispose Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Finalize Method

ColorProfileFinalize Method

Finalizes an instance of the ColorProfile class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.FromEmbedded Method

ColorProfileFromEmbedded Method

Overload List
Name | Description
FromEmbedded(Stream) | Returns a ColorProfile embedded within an image given the image stream.
FromEmbedded(String) | Returns a ColorProfile embedded within an image given the image file name.
Top
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.FromEmbedded Method (Stream)

ColorProfileFromEmbedded Method (Stream)

Returns a ColorProfile embedded within an image given the image stream.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ColorProfile FromEmbedded(
    Stream imageStream
)
Public Shared Function FromEmbedded (
    imageStream As Stream
) As ColorProfile

Parameters

imageStream
Type: System.IOStream
The encoded image stream.

Return Value

Type: ColorProfile
A ColorProfile embedded within an image.
See Also

Reference

ColorProfile Class
FromEmbedded Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.FromEmbedded Method (String)

ColorProfileFromEmbedded Method (String)

Returns a ColorProfile embedded within an image given the image file name.
Returns a ColorProfile embedded within an image.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ColorProfile FromEmbedded(
    string fileName
)
Public Shared Function FromEmbedded (
    fileName As String
) As ColorProfile

Parameters

fileName
Type: SystemString
The filename of the image.

Return Value

Type: ColorProfile
A ColorProfile embedded within an image.

Return Value

Type: ColorProfile
A ColorProfile embedded within an image.
Remarks
Can be a PNG, TIFF, or JPEG image.
See Also

Reference

ColorProfile Class
FromEmbedded Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.FromSrgb Method

ColorProfileFromSrgb Method

Returns the standard sRGB Color Profile.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ColorProfile FromSrgb()
Public Shared Function FromSrgb As ColorProfile

Return Value

Type: ColorProfile
The standard sRGB Color Profile.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.GetProfileBytes Method

ColorProfileGetProfileBytes Method

Gets the profile bytes.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] GetProfileBytes()
Public Function GetProfileBytes As Byte()

Return Value

Type: Byte
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.GetProfileDirectory Method

ColorProfileGetProfileDirectory Method

Returns the path of the color profile directory.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string GetProfileDirectory()
Public Shared Function GetProfileDirectory As String

Return Value

Type: String
The path of the color profile directory.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.GetProfileFromGraphics Method

ColorProfileGetProfileFromGraphics Method

Returns the color profile assigned to a specified Graphics object.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ColorProfile GetProfileFromGraphics(
    Graphics graphics
)
Public Shared Function GetProfileFromGraphics (
    graphics As Graphics
) As ColorProfile

Parameters

graphics
Type: System.DrawingGraphics
A graphics object.

Return Value

Type: ColorProfile
The color profile assigned to a specified Graphics object.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.GetProfileFromScreen Method

ColorProfileGetProfileFromScreen Method

Returns the default color profile assigned to the screen.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ColorProfile GetProfileFromScreen()
Public Shared Function GetProfileFromScreen As ColorProfile

Return Value

Type: ColorProfile
The default color profile assigned to the screen.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.GetScreenProfileName Method

ColorProfileGetScreenProfileName Method

Returns the name of the color profile associated with the current display.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string GetScreenProfileName()
Public Shared Function GetScreenProfileName As String

Return Value

Type: String
The name of the color profile associated with the current display.
See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorProfile.Save Method

ColorProfileSave Method

Save this ColorProfile to a file.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName
)
Public Sub Save (
    fileName As String
)

Parameters

fileName
Type: SystemString

The filename of the colorprofile to save.

See Also

Reference

ColorProfile Class
Atalasoft.Imaging.ColorManagement Namespace


ColorSpace Enumeration

A value that indicates the color space in which profile data is defined.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ColorSpace
Public Enumeration ColorSpace
Members
Member name | Description
Xyz | The xyz ColorSpace
Lab | The lab ColorSpace
Luv | The luv ColorSpace
YCbCr | The y cb cr ColorSpace
Yxy | The yxy ColorSpace
Rgb | The RGB ColorSpace
Gray | The gray ColorSpace
Hsv | The HSV ColorSpace
Hls | The HLS ColorSpace
Cmyk | The cmyk ColorSpace
Cmy | The cmy ColorSpace
TwoChannel | The two channel ColorSpace
ThreeChannel | The three channel ColorSpace
FourChannel | The four channel ColorSpace
FiveChannel | The five channel ColorSpace
SixChannel | The six channel ColorSpace
SevenChannel | The seven channel ColorSpace
EightChannel | The eight channel ColorSpace
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


ColorTransform Class

Contains a color transform object and methods to convert from one colorspace to another using a ColorProfile.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ColorManagementColorTransform

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ColorTransform : IDisposable
Public Class ColorTransform
    Implements IDisposable

The ColorTransform type exposes the following members.

Constructors
 | Name | Description
Public method | ColorTransform(ColorProfile, ColorProfile) | Initializes a new instance of ColorTransform specifying a source and destination %ColorProfile%.
Public method | ColorTransform(ColorProfile, ColorProfile, RenderingIntent) | Initializes a new instance of ColorTransform specifying a source and destination %ColorProfile% and the rendering intent of the translation.
Public method | ColorTransform(ColorProfile, ColorProfile, ColorProfile, RenderingIntent, RenderingIntent) | Initializes a new instance of ColorTransform specifying a source,. destination, and target %ColorProfile% and the rendering intents of the translation.
Top
Properties
 | Name | Description
Public property | BlackPointCompensation | Sets or gets a flag indicating whether or not black point compensation will be used
Top
Methods
 | Name | Description
Public method | ConvertColors | Obsolete. This method converts an array of colors using this ColorTransform .
Public method | ConvertColorSpace | Returns a new image with a translated colorspace.
Public method | Dispose | Clean up unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class can be used to translate the colorspace of images or colors. It is used by the controls to view CMYK images and when color management is enabled. See Atalasoft.Imaging.ColorManagement for more information.
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace
Color Management in WinControls


ColorTransform Constructor

Overload List
 | Name | Description
Public method | ColorTransform(ColorProfile, ColorProfile) | Initializes a new instance of ColorTransform specifying a source and destination %ColorProfile%.
Public method | ColorTransform(ColorProfile, ColorProfile, RenderingIntent) | Initializes a new instance of ColorTransform specifying a source and destination %ColorProfile% and the rendering intent of the translation.
Public method | ColorTransform(ColorProfile, ColorProfile, ColorProfile, RenderingIntent, RenderingIntent) | Initializes a new instance of ColorTransform specifying a source,. destination, and target %ColorProfile% and the rendering intents of the translation.
Top
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform Constructor (ColorProfile, ColorProfile)

Initializes a new instance of ColorTransform specifying a source and destination %ColorProfile%.
Initializes a new instance of ColorTransform.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorTransform(
    ColorProfile source,
    ColorProfile dest
)
Public Sub New (
    source As ColorProfile,
    dest As ColorProfile
)

Parameters

source
Type: Atalasoft.Imaging.ColorManagementColorProfile
The source color profile.
dest
Type: Atalasoft.Imaging.ColorManagementColorProfile
The destination color profile.
See Also

Reference

ColorTransform Class
ColorTransform Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform Constructor (ColorProfile, ColorProfile, RenderingIntent)

Initializes a new instance of ColorTransform specifying a source and destination %ColorProfile% and the rendering intent of the translation.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorTransform(
    ColorProfile source,
    ColorProfile dest,
    RenderingIntent renderingIntent
)
Public Sub New (
    source As ColorProfile,
    dest As ColorProfile,
    renderingIntent As RenderingIntent
)

Parameters

source
Type: Atalasoft.Imaging.ColorManagementColorProfile
The source color profile.
dest
Type: Atalasoft.Imaging.ColorManagementColorProfile
The destination color profile.
renderingIntent
Type: Atalasoft.Imaging.ColorManagementRenderingIntent
The rendering intent of the translation.
See Also

Reference

ColorTransform Class
ColorTransform Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform Constructor (ColorProfile, ColorProfile, ColorProfile, RenderingIntent, RenderingIntent)

Initializes a new instance of ColorTransform specifying a source,. destination, and target %ColorProfile% and the rendering intents of the translation.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorTransform(
    ColorProfile source,
    ColorProfile dest,
    ColorProfile target,
    RenderingIntent displayIntent,
    RenderingIntent proofIntent
)
Public Sub New (
    source As ColorProfile,
    dest As ColorProfile,
    target As ColorProfile,
    displayIntent As RenderingIntent,
    proofIntent As RenderingIntent
)

Parameters

source
Type: Atalasoft.Imaging.ColorManagementColorProfile
The source color profile.
dest
Type: Atalasoft.Imaging.ColorManagementColorProfile
The destination color profile.
target
Type: Atalasoft.Imaging.ColorManagementColorProfile
The target output device color profile.
displayIntent
Type: Atalasoft.Imaging.ColorManagementRenderingIntent
The rendering intent to use for the display.
proofIntent
Type: Atalasoft.Imaging.ColorManagementRenderingIntent
The rendering intent to use for the target device.
Remarks
This constructor is used for proofing images.
See Also

Reference

ColorTransform Class
ColorTransform Overload
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform Properties

The ColorTransform type exposes the following members.

Properties
 | Name | Description
Public property | BlackPointCompensation | Sets or gets a flag indicating whether or not black point compensation will be used
Top
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform.BlackPointCompensation Property

ColorTransformBlackPointCompensation Property

Sets or gets a flag indicating whether or not black point compensation will be used

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool BlackPointCompensation { get; set; }
Public Property BlackPointCompensation As Boolean
    Get
    Set

Property Value

Type: Boolean
True if black point compensation will be used, false otherwise
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform Methods

The ColorTransform type exposes the following members.

Methods
 | Name | Description
Public method | ConvertColors | Obsolete. This method converts an array of colors using this ColorTransform .
Public method | ConvertColorSpace | Returns a new image with a translated colorspace.
Public method | Dispose | Clean up unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform.ConvertColors Method

ColorTransformConvertColors Method

Note: This API is now obsolete.

This method converts an array of colors using this ColorTransform .

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("this method is no longer supported and will only work on RGB",
    false)]
public Color[] ConvertColors(
    ColorType inputColorType,
    ColorType outputColorType,
    params Color[] inputColors
)
<ObsoleteAttribute("this method is no longer supported and will only work on RGB",
    false)>
Public Function ConvertColors (
    inputColorType As ColorType,
    outputColorType As ColorType,
    ParamArray inputColors As Color()
) As Color()

Parameters

inputColorType
Type: Atalasoft.Imaging.ColorManagementColorType
The ColorType of the input colors.
outputColorType
Type: Atalasoft.Imaging.ColorManagementColorType
The ColorType of the output colors.
inputColors
Type: System.DrawingColor

A parameterr array of color values.

Return Value

Type: Color
An array of Colors.
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform.ConvertColorSpace Method

ColorTransformConvertColorSpace Method

Returns a new image with a translated colorspace.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ConvertColorSpace(
    AtalaImage image,
    PixelFormat destPixelFormat
)
Public Function ConvertColorSpace (
    image As AtalaImage,
    destPixelFormat As PixelFormat
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to translate.
destPixelFormat
Type: Atalasoft.ImagingPixelFormat
The desired PixelFormat of the returned image.

Return Value

Type: AtalaImage
A new image with a translated colorspace.
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorTransform.Dispose Method

ColorTransformDispose Method

Clean up unmanaged resources.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ColorTransform Class
Atalasoft.Imaging.ColorManagement Namespace


ColorType Enumeration

Describes the general color type

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ColorType
Public Enumeration ColorType
Members
Member name | Description
Gray | The gray ColorType
Rgb | The RGB ColorType
Xyz | The xyz ColorType
Yxy | The yxy ColorType
Lab | The lab ColorType
ThreeChannel | The three channel ColorType
Cmyk | The cmyk ColorType
FiveChannel | The five channel ColorType
SixChannel | The six channel ColorType
SevenChannel | The seven channel ColorType
EightChannel | The eight channel ColorType
Named | The named ColorType
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Class

This exception fires when the ColorProfile used for a ColorTransform are invalid.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.ColorManagementInvalidColorProfileException

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvalidColorProfileException : Exception
<SerializableAttribute>
Public Class InvalidColorProfileException
    Inherits Exception

The InvalidColorProfileException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidColorProfileException | Initializes a new instance of the InvalidColorProfileException class.
Public method | InvalidColorProfileException(String) | Initializes a new instance of the InvalidColorProfileException class.
Protected method | InvalidColorProfileException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidColorProfileException class.
Public method | InvalidColorProfileException(String, Exception) | Initializes a new instance of the InvalidColorProfileException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Remarks
This exception usually means that the appropriate tag for the desired conversion doesn't exist in the color profile.
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Constructor

Overload List
 | Name | Description
Public method | InvalidColorProfileException | Initializes a new instance of the InvalidColorProfileException class.
Public method | InvalidColorProfileException(String) | Initializes a new instance of the InvalidColorProfileException class.
Protected method | InvalidColorProfileException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidColorProfileException class.
Public method | InvalidColorProfileException(String, Exception) | Initializes a new instance of the InvalidColorProfileException class.
Top
See Also

Reference

InvalidColorProfileException Class
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Constructor

Initializes a new instance of the InvalidColorProfileException class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InvalidColorProfileException()
Public Sub New
See Also

Reference

InvalidColorProfileException Class
InvalidColorProfileException Overload
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Constructor (String)

Initializes a new instance of the InvalidColorProfileException class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InvalidColorProfileException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidColorProfileException Class
InvalidColorProfileException Overload
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidColorProfileException class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected InvalidColorProfileException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InvalidColorProfileException Class
InvalidColorProfileException Overload
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Constructor (String, Exception)

Initializes a new instance of the InvalidColorProfileException class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InvalidColorProfileException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidColorProfileException Class
InvalidColorProfileException Overload
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Properties

The InvalidColorProfileException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidColorProfileException Class
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Methods

The InvalidColorProfileException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidColorProfileException Class
Atalasoft.Imaging.ColorManagement Namespace


InvalidColorProfileException Events

The InvalidColorProfileException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidColorProfileException Class
Atalasoft.Imaging.ColorManagement Namespace


Platform Enumeration

Indicates the platform that the profile is intended for.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Platform
Public Enumeration Platform
Members
Member name | Description
Apple | The apple platform
Microsoft | The microsoft platform
SiliconGraphics | The silicon graphics platform
Sun | The sun platform
Taligent | The taligent platform
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


ProfileClass Enumeration

Indicates the profile class.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ProfileClass
Public Enumeration ProfileClass
Members
Member name | Description
Monitor | Display Device Profile
Printer | Output Device Profile
Scanner | Input Device Profile
Link | Device Link Profile
Abstract | Abstract Profile
ColorSpace | Color Space Conversion Profile
Named | Named Color Profile
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


ProfileFlags Enumeration

Bit flags containing hints that the CMM uses to interpret the profile data.

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum ProfileFlags
<FlagsAttribute>
Public Enumeration ProfileFlags
Members
Member name | Description
EmbeddedProfile | The profile is embedded in a bitmap file.
DependentOnData | The profile can't be used independently of the embedded color data. Used for profiles that are embedded in bitmap files
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace


RenderingIntent Enumeration

Indicates different methods to create a color rendering as defined by the International Color Consortium (ICC).

Namespace: Atalasoft.Imaging.ColorManagement
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RenderingIntent
Public Enumeration RenderingIntent
Members
Member name | Description
Pictures | Known as perceptual intent in the ICC specification, causes the full gamut to be compressed or expanded to full the gamut of the destination device. Most suitable for photographic images and is usually the default intent.
Proof | Known as the colorimetric intent in the ICC specification, causes colors that fall outside the range of the output device to be set to the nearest color while leaving the other colors unchanged. Does not preserve the white point and is commonly used for proofing printed material.
Graphics | Known as the Saturation intent in the ICC specification, it preserves the saturation of colors as the expense of hue and lightness. Commonly used for business graphics.
Match | Known as the absolute colorimetric intent in the ICC specification, causes colors that fall outside the range of the output device to be set to the nearest color while leaving the other colors unchanged. Preserves the white point.
Remarks
See http://msdn.microsoft.com for more information on rendering intents.
See Also

Reference

Atalasoft.Imaging.ColorManagement Namespace
MSDN Rending Intents


Atalasoft.Imaging.ConnectedComponents Namespace

Classes
 | Class | Description
Public class | ConnectedComponentCollection |
Structures
 | Structure | Description
Public structure | ConnectedComponent |


ConnectedComponent Structure

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public struct ConnectedComponent
Public Structure ConnectedComponent

The ConnectedComponent type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectedComponent | Initializes a new instance of the ConnectedComponent class
Top
Properties
 | Name | Description
Public property | Area |
Public property | BoundingBox |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponent Constructor

Initializes a new instance of the ConnectedComponent class

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConnectedComponent(
    Rectangle bounds,
    int area
)
Public Sub New (
    bounds As Rectangle,
    area As Integer
)

Parameters

bounds
Type: System.DrawingRectangle
area
Type: SystemInt32
See Also

Reference

ConnectedComponent Structure
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponent Properties

The ConnectedComponent type exposes the following members.

Properties
 | Name | Description
Public property | Area |
Public property | BoundingBox |
Top
See Also

Reference

ConnectedComponent Structure
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponent.Area Property

ConnectedComponentArea Property

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Area { get; }
Public ReadOnly Property Area As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ConnectedComponent Structure
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponent.BoundingBox Property

ConnectedComponentBoundingBox Property

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle BoundingBox { get; }
Public ReadOnly Property BoundingBox As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

ConnectedComponent Structure
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponent Methods

The ConnectedComponent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ConnectedComponent Structure
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ConnectedComponentsConnectedComponentCollection

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ConnectedComponentCollection : IEnumerable,
    IDisposable
Public Class ConnectedComponentCollection
    Implements IEnumerable, IDisposable

The ConnectedComponentCollection type exposes the following members.

Properties
 | Name | Description
Public property | Area |
Public property | Bounds |
Public property | Count |
 | Empty |
Top
Methods
 | Name | Description
 | Build(AtalaImage) |
 | Build(AtalaImage, Byte) |
 | Build(AtalaImage, Byte, Rectangle) |
Public method | Contains |
Public method | Dilate |
Public method | Dispose | Releases all resources used by the ConnectedComponentCollection
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConnectedComponentCollection and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArea |
Public method | GetBounds |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects |
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Paint(AtalaImage, Color) |
Public method | Paint(AtalaImage, Color, Point) |
Public method | Paint(AtalaImage, Color, Point, Int32) |
Public method | ToList |
Public method | ToRectangleFArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Union |
Top
See Also

Reference

Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection Properties

The ConnectedComponentCollection type exposes the following members.

Properties
 | Name | Description
Public property | Area |
Public property | Bounds |
Public property | Count |
 | Empty |
Top
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Area Property

ConnectedComponentCollectionArea Property

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Area { get; }
Public ReadOnly Property Area As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Bounds Property

ConnectedComponentCollectionBounds Property

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Count Property

ConnectedComponentCollectionCount Property

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Empty Property

ConnectedComponentCollectionEmpty Property

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ConnectedComponentCollection Empty { get; }
Public Shared ReadOnly Property Empty As ConnectedComponentCollection
    Get

Property Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection Methods

The ConnectedComponentCollection type exposes the following members.

Methods
 | Name | Description
 | Build(AtalaImage) |
 | Build(AtalaImage, Byte) |
 | Build(AtalaImage, Byte, Rectangle) |
Public method | Contains |
Public method | Dilate |
Public method | Dispose | Releases all resources used by the ConnectedComponentCollection
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConnectedComponentCollection and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArea |
Public method | GetBounds |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects |
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Paint(AtalaImage, Color) |
Public method | Paint(AtalaImage, Color, Point) |
Public method | Paint(AtalaImage, Color, Point, Int32) |
Public method | ToList |
Public method | ToRectangleFArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Union |
Top
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Build Method

ConnectedComponentCollectionBuild Method

Overload List
Name | Description
Build(AtalaImage) |
Build(AtalaImage, Byte) |
Build(AtalaImage, Byte, Rectangle) |
Top
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Build Method (AtalaImage)

ConnectedComponentCollectionBuild Method (AtalaImage)

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ConnectedComponentCollection Build(
    AtalaImage image
)
Public Shared Function Build (
    image As AtalaImage
) As ConnectedComponentCollection

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Build Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Build Method (AtalaImage, Byte)

ConnectedComponentCollectionBuild Method (AtalaImage, Byte)

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ConnectedComponentCollection Build(
    AtalaImage image,
    byte thresholdValue
)
Public Shared Function Build (
    image As AtalaImage,
    thresholdValue As Byte
) As ConnectedComponentCollection

Parameters

image
Type: Atalasoft.ImagingAtalaImage
thresholdValue
Type: SystemByte

Return Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Build Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Build Method (AtalaImage, Byte, Rectangle)

ConnectedComponentCollectionBuild Method (AtalaImage, Byte, Rectangle)

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ConnectedComponentCollection Build(
    AtalaImage image,
    byte thresholdValue,
    Rectangle bounds
)
Public Shared Function Build (
    image As AtalaImage,
    thresholdValue As Byte,
    bounds As Rectangle
) As ConnectedComponentCollection

Parameters

image
Type: Atalasoft.ImagingAtalaImage
thresholdValue
Type: SystemByte
bounds
Type: System.DrawingRectangle

Return Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Build Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Contains Method

ConnectedComponentCollectionContains Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    Point p
)
Public Function Contains (
    p As Point
) As Boolean

Parameters

p
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Dilate Method

ConnectedComponentCollectionDilate Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConnectedComponentCollection Dilate()
Public Function Dilate As ConnectedComponentCollection

Return Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Dispose Method

ConnectedComponentCollectionDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectedComponentCollection
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConnectedComponentCollection and optionally releases the managed resources
Top
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Dispose Method

ConnectedComponentCollectionDispose Method

Releases all resources used by the ConnectedComponentCollection

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ConnectedComponentCollection Class
Dispose Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Dispose Method (Boolean)

ConnectedComponentCollectionDispose Method (Boolean)

Releases the unmanaged resources used by the ConnectedComponentCollection and optionally releases the managed resources

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

ConnectedComponentCollection Class
Dispose Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Fill Method

ConnectedComponentCollectionFill Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConnectedComponentCollection Fill()
Public Function Fill As ConnectedComponentCollection

Return Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.GetArea Method

ConnectedComponentCollectionGetArea Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetArea(
    int index
)
Public Function GetArea (
    index As Integer
) As Integer

Parameters

index
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.GetBounds Method

ConnectedComponentCollectionGetBounds Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle GetBounds(
    int index
)
Public Function GetBounds (
    index As Integer
) As Rectangle

Parameters

index
Type: SystemInt32

Return Value

Type: Rectangle
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.GetEnumerator Method

ConnectedComponentCollectionGetEnumerator Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Intersects Method

ConnectedComponentCollectionIntersects Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Intersects(
    ConnectedComponentCollection other
)
Public Function Intersects (
    other As ConnectedComponentCollection
) As Boolean

Parameters

other
Type: Atalasoft.Imaging.ConnectedComponentsConnectedComponentCollection

Return Value

Type: Boolean
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.IsEmpty Method

ConnectedComponentCollectionIsEmpty Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Paint Method

ConnectedComponentCollectionPaint Method

Overload List
 | Name | Description
Public method | Paint(AtalaImage, Color) |
Public method | Paint(AtalaImage, Color, Point) |
Public method | Paint(AtalaImage, Color, Point, Int32) |
Top
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Paint Method (AtalaImage, Color)

ConnectedComponentCollectionPaint Method (AtalaImage, Color)

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Paint(
    AtalaImage image,
    Color c
)
Public Sub Paint (
    image As AtalaImage,
    c As Color
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
c
Type: System.DrawingColor
See Also

Reference

ConnectedComponentCollection Class
Paint Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Paint Method (AtalaImage, Color, Point)

ConnectedComponentCollectionPaint Method (AtalaImage, Color, Point)

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Paint(
    AtalaImage image,
    Color c,
    Point offset
)
Public Sub Paint (
    image As AtalaImage,
    c As Color,
    offset As Point
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
c
Type: System.DrawingColor
offset
Type: System.DrawingPoint
See Also

Reference

ConnectedComponentCollection Class
Paint Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Paint Method (AtalaImage, Color, Point, Int32)

ConnectedComponentCollectionPaint Method (AtalaImage, Color, Point, Int32)

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Paint(
    AtalaImage image,
    Color c,
    Point offset,
    int index
)
Public Sub Paint (
    image As AtalaImage,
    c As Color,
    offset As Point,
    index As Integer
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
c
Type: System.DrawingColor
offset
Type: System.DrawingPoint
index
Type: SystemInt32
See Also

Reference

ConnectedComponentCollection Class
Paint Overload
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.ToList Method

ConnectedComponentCollectionToList Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual List<ConnectedComponent> ToList()
Public Overridable Function ToList As List(Of ConnectedComponent)

Return Value

Type: ListConnectedComponent
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.ToRectangleFArray Method

ConnectedComponentCollectionToRectangleFArray Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RectangleF[] ToRectangleFArray()
Public Overridable Function ToRectangleFArray As RectangleF()

Return Value

Type: RectangleF
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


ConnectedComponentCollection.Union Method

ConnectedComponentCollectionUnion Method

Namespace: Atalasoft.Imaging.ConnectedComponents
Assembly: Atalasoft.dotImage.ConnectedComponents (in Atalasoft.dotImage.ConnectedComponents.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConnectedComponentCollection Union(
    ConnectedComponentCollection other
)
Public Function Union (
    other As ConnectedComponentCollection
) As ConnectedComponentCollection

Parameters

other
Type: Atalasoft.Imaging.ConnectedComponentsConnectedComponentCollection

Return Value

Type: ConnectedComponentCollection
See Also

Reference

ConnectedComponentCollection Class
Atalasoft.Imaging.ConnectedComponents Namespace


Atalasoft.Imaging.Drawing Namespace

Classes
 | Class | Description
Public class | AtalaPen | The AtalaPen is used to define a line or border used when drawing primitives onto a Canvas.
Public class | AtalaPenConverter | AtalaPenConverter i s utility for serialization of objects to AtalaPen
Public class | Canvas | This class is used to draw primitives and text onto an AtalaImage, Bitmap, or Graphics object.
Public class | Fill | The base class which all Fill objects inherit. A Fill contains the color of the entity being drawn.
Public class | HatchedFill | A Fill containing hatched lines.
Public class | SolidFill | A Fill containing a solid color.
Public class | TextFormat | Contains extended properties for use with drawing text onto a Canvas.
Enumerations
 | Enumeration | Description
Public enumeration | Alignment | Specifies the line position.
Public enumeration | CornerJoin | Corner style used where lines join.
Public enumeration | EndCap | Drawing style for the end of lines.
Public enumeration | FontQuality | Font quality style when using the DrawText method.
Public enumeration | Hatch | The style of Hatch to use when FillStyle is Hatched.
Public enumeration | LineStyle | The type of line to draw.
Public enumeration | TextAlignment | The horizontal alignment of the text.


Alignment Enumeration

Specifies the line position.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Alignment
Public Enumeration Alignment
Members
Member name | Description
Center | Center the line on the region.
Inset | Draw the line inside the region.
Outset | Draw the line outside the region.
Remarks
The alignment will is ignored and always centered with %DrawLine%, %DrawLines%, and %DrawPolygon%.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


AtalaPen Class

The AtalaPen is used to define a line or border used when drawing primitives onto a Canvas.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.DrawingAtalaPen

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(AtalaPenConverter))]
public class AtalaPen : ICloneable
<SerializableAttribute>
<TypeConverterAttribute(GetType(AtalaPenConverter))>
Public Class AtalaPen
    Implements ICloneable

The AtalaPen type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaPen | Initializes a new instance of the AtalaPen class with the object defaults:,Width = 1
Public method | AtalaPen(Color) | Initializes a new instance of the AtalaPen class with the specified color. Using a constructor that specifies the color implies a fill type of solid
Public method | AtalaPen(Fill) | Initializes a new instance of the AtalaPen class with a specified fill.
Public method | AtalaPen(Color, Int32) | Initializes a new instance of the AtalaPen class with a specified color and width.
Public method | AtalaPen(Fill, Int32) | Initializes a new instance of the AtalaPen class with a specified Fill and width.
Public method | AtalaPen(Color, Int32, LineStyle) | Initializes a new instance of the AtalaPen class with a specified color, width, and LineStyle.
Public method | AtalaPen(Fill, Int32, LineStyle) | Initializes a new instance of the AtalaPen class with a specified Fill, width, and LineStyle.
Public method | AtalaPen(Color, Int32, LineStyle, EndCap, CornerJoin) | Initializes a new instance of the AtalaPen class with a specified color, width, LineStyle, EndCap, and CornerJoin.
Public method | AtalaPen(Fill, Int32, LineStyle, EndCap, CornerJoin) | Initializes a new instance of the AtalaPen class with a specified Fill, width, LineStyle, EndCap, and CornerJoin.
Public method | AtalaPen(Color, Int32, LineStyle, EndCap, CornerJoin, Alignment) | Creates a new instance of AtalaPen specifying color, width, LineStyle, EndCap, CornerJoin and Alignment.
Public method | AtalaPen(Fill, Int32, LineStyle, EndCap, CornerJoin, Alignment) | Creates a new instance of AtalaPen specifying the Fill, width, LineStyle, EndCap, CornerJoin and Alignment.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets a value indicating the line positioning relative to the coordinates.
Public property | Color | Gets or sets the color of the pen.
Public property | CornerJoin | Gets or sets the style of corners used for this pen.
Public property | CustomDashPattern | Gets or sets an array of int's indicating the dash pattern when the LineStyle is set to Custom.
Public property | EndCap | Gets or sets the pen EndCap used when drawing.
Public property | Fill | Gets or sets the Fill used when drawing with this pen.
Public property | LineStyle | Gets or sets the type of line drawn with this pen.
Public property | Width | Gets or sets the width of the pen in pixels.
Top
Methods
 | Name | Description
Public method | Clone | Create a copy of this AtalaPen.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor

Creates an AtalaPen object.
Overload List
 | Name | Description
Public method | AtalaPen | Initializes a new instance of the AtalaPen class with the object defaults:,Width = 1
Public method | AtalaPen(Color) | Initializes a new instance of the AtalaPen class with the specified color. Using a constructor that specifies the color implies a fill type of solid
Public method | AtalaPen(Fill) | Initializes a new instance of the AtalaPen class with a specified fill.
Public method | AtalaPen(Color, Int32) | Initializes a new instance of the AtalaPen class with a specified color and width.
Public method | AtalaPen(Fill, Int32) | Initializes a new instance of the AtalaPen class with a specified Fill and width.
Public method | AtalaPen(Color, Int32, LineStyle) | Initializes a new instance of the AtalaPen class with a specified color, width, and LineStyle.
Public method | AtalaPen(Fill, Int32, LineStyle) | Initializes a new instance of the AtalaPen class with a specified Fill, width, and LineStyle.
Public method | AtalaPen(Color, Int32, LineStyle, EndCap, CornerJoin) | Initializes a new instance of the AtalaPen class with a specified color, width, LineStyle, EndCap, and CornerJoin.
Public method | AtalaPen(Fill, Int32, LineStyle, EndCap, CornerJoin) | Initializes a new instance of the AtalaPen class with a specified Fill, width, LineStyle, EndCap, and CornerJoin.
Public method | AtalaPen(Color, Int32, LineStyle, EndCap, CornerJoin, Alignment) | Creates a new instance of AtalaPen specifying color, width, LineStyle, EndCap, CornerJoin and Alignment.
Public method | AtalaPen(Fill, Int32, LineStyle, EndCap, CornerJoin, Alignment) | Creates a new instance of AtalaPen specifying the Fill, width, LineStyle, EndCap, CornerJoin and Alignment.
Top
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor

Initializes a new instance of the AtalaPen class with the object defaults:,Width = 1

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen()
Public Sub New
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Color)

Initializes a new instance of the AtalaPen class with the specified color. Using a constructor that specifies the color implies a fill type of solid

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor
The color of the pen.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Fill)

Initializes a new instance of the AtalaPen class with a specified fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Fill fill
)
Public Sub New (
    fill As Fill
)

Parameters

fill
Type: Atalasoft.Imaging.DrawingFill
The Fill defining the fill characteristics of the line drawn with the pen.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Color, Int32)

Initializes a new instance of the AtalaPen class with a specified color and width.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Color color,
    int width
)
Public Sub New (
    color As Color,
    width As Integer
)

Parameters

color
Type: System.DrawingColor
The color of the fill.
width
Type: SystemInt32
The width of the pen in pixels.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Fill, Int32)

Initializes a new instance of the AtalaPen class with a specified Fill and width.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Fill fill,
    int width
)
Public Sub New (
    fill As Fill,
    width As Integer
)

Parameters

fill
Type: Atalasoft.Imaging.DrawingFill
The Fill defining the fill characteristics of the line drawn with the pen.
width
Type: SystemInt32
The width of the pen in pixels.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Color, Int32, LineStyle)

Initializes a new instance of the AtalaPen class with a specified color, width, and LineStyle.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Color color,
    int width,
    LineStyle lineStyle
)
Public Sub New (
    color As Color,
    width As Integer,
    lineStyle As LineStyle
)

Parameters

color
Type: System.DrawingColor
The color of the fill.
width
Type: SystemInt32
The width of the pen in pixels.
lineStyle
Type: Atalasoft.Imaging.DrawingLineStyle
The style of the line.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Fill, Int32, LineStyle)

Initializes a new instance of the AtalaPen class with a specified Fill, width, and LineStyle.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Fill fill,
    int width,
    LineStyle lineStyle
)
Public Sub New (
    fill As Fill,
    width As Integer,
    lineStyle As LineStyle
)

Parameters

fill
Type: Atalasoft.Imaging.DrawingFill
The Fill defining the fill characteristics of the line drawn with the pen.
width
Type: SystemInt32
The width of the pen in pixels.
lineStyle
Type: Atalasoft.Imaging.DrawingLineStyle
The style of the line.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Color, Int32, LineStyle, EndCap, CornerJoin)

Initializes a new instance of the AtalaPen class with a specified color, width, LineStyle, EndCap, and CornerJoin.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Color color,
    int width,
    LineStyle lineStyle,
    EndCap endCap,
    CornerJoin cornerJoin
)
Public Sub New (
    color As Color,
    width As Integer,
    lineStyle As LineStyle,
    endCap As EndCap,
    cornerJoin As CornerJoin
)

Parameters

color
Type: System.DrawingColor
The color of the pen.
width
Type: SystemInt32
The width of the pen in pixels.
lineStyle
Type: Atalasoft.Imaging.DrawingLineStyle
The style of the line.
endCap
Type: Atalasoft.Imaging.DrawingEndCap
The pen EndCap used when drawing.
cornerJoin
Type: Atalasoft.Imaging.DrawingCornerJoin
The style of corners used for this pen.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Fill, Int32, LineStyle, EndCap, CornerJoin)

Initializes a new instance of the AtalaPen class with a specified Fill, width, LineStyle, EndCap, and CornerJoin.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Fill fill,
    int width,
    LineStyle lineStyle,
    EndCap endCap,
    CornerJoin cornerJoin
)
Public Sub New (
    fill As Fill,
    width As Integer,
    lineStyle As LineStyle,
    endCap As EndCap,
    cornerJoin As CornerJoin
)

Parameters

fill
Type: Atalasoft.Imaging.DrawingFill
The Fill defining the fill characteristics of the line drawn with the pen.
width
Type: SystemInt32
The width of the pen in pixels.
lineStyle
Type: Atalasoft.Imaging.DrawingLineStyle
The style of the line.
endCap
Type: Atalasoft.Imaging.DrawingEndCap
The pen EndCap used when drawing.
cornerJoin
Type: Atalasoft.Imaging.DrawingCornerJoin
The style of corners used for this pen.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Color, Int32, LineStyle, EndCap, CornerJoin, Alignment)

Creates a new instance of AtalaPen specifying color, width, LineStyle, EndCap, CornerJoin and Alignment.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Color color,
    int width,
    LineStyle lineStyle,
    EndCap endCap,
    CornerJoin cornerJoin,
    Alignment alignment
)
Public Sub New (
    color As Color,
    width As Integer,
    lineStyle As LineStyle,
    endCap As EndCap,
    cornerJoin As CornerJoin,
    alignment As Alignment
)

Parameters

color
Type: System.DrawingColor
The color of the pen.
width
Type: SystemInt32
The width of the pen in pixels.
lineStyle
Type: Atalasoft.Imaging.DrawingLineStyle
The style of the line.
endCap
Type: Atalasoft.Imaging.DrawingEndCap
The pen EndCap used when drawing.
cornerJoin
Type: Atalasoft.Imaging.DrawingCornerJoin
The style of corners used for this pen.
alignment
Type: Atalasoft.Imaging.DrawingAlignment
The pen alignment.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Constructor (Fill, Int32, LineStyle, EndCap, CornerJoin, Alignment)

Creates a new instance of AtalaPen specifying the Fill, width, LineStyle, EndCap, CornerJoin and Alignment.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen(
    Fill fill,
    int width,
    LineStyle lineStyle,
    EndCap endCap,
    CornerJoin cornerJoin,
    Alignment alignment
)
Public Sub New (
    fill As Fill,
    width As Integer,
    lineStyle As LineStyle,
    endCap As EndCap,
    cornerJoin As CornerJoin,
    alignment As Alignment
)

Parameters

fill
Type: Atalasoft.Imaging.DrawingFill
The Fill defining the fill characteristics of the line drawn with the pen.
width
Type: SystemInt32
The width of the pen in pixels.
lineStyle
Type: Atalasoft.Imaging.DrawingLineStyle
The style of the line.
endCap
Type: Atalasoft.Imaging.DrawingEndCap
The pen EndCap used when drawing.
cornerJoin
Type: Atalasoft.Imaging.DrawingCornerJoin
The style of corners used for this pen.
alignment
Type: Atalasoft.Imaging.DrawingAlignment
The pen alignment.
See Also

Reference

AtalaPen Class
AtalaPen Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPen Properties

The AtalaPen type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets a value indicating the line positioning relative to the coordinates.
Public property | Color | Gets or sets the color of the pen.
Public property | CornerJoin | Gets or sets the style of corners used for this pen.
Public property | CustomDashPattern | Gets or sets an array of int's indicating the dash pattern when the LineStyle is set to Custom.
Public property | EndCap | Gets or sets the pen EndCap used when drawing.
Public property | Fill | Gets or sets the Fill used when drawing with this pen.
Public property | LineStyle | Gets or sets the type of line drawn with this pen.
Public property | Width | Gets or sets the width of the pen in pixels.
Top
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.Alignment Property

AtalaPenAlignment Property

Gets or sets a value indicating the line positioning relative to the coordinates.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Alignment Alignment { get; set; }
Public Property Alignment As Alignment
    Get
    Set

Property Value

Type: Alignment
A value indicating the line positioning relative to the coordinates
Remarks
The property is ignored when drawing a line, lines, or polygon.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.Color Property

AtalaPenColor Property

Gets or sets the color of the pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color of the pen.
Remarks
This property references the Fill.Color property
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.CornerJoin Property

AtalaPenCornerJoin Property

Gets or sets the style of corners used for this pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CornerJoin CornerJoin { get; set; }
Public Property CornerJoin As CornerJoin
    Get
    Set

Property Value

Type: CornerJoin
The style of corners used for this pen.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.CustomDashPattern Property

AtalaPenCustomDashPattern Property

Gets or sets an array of int's indicating the dash pattern when the LineStyle is set to Custom.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] CustomDashPattern { get; set; }
Public Property CustomDashPattern As Integer()
    Get
    Set

Property Value

Type: Int32
An array of int's indicating the dash pattern when the LineStyle is set to Custom.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.EndCap Property

AtalaPenEndCap Property

Gets or sets the pen EndCap used when drawing.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EndCap EndCap { get; set; }
Public Property EndCap As EndCap
    Get
    Set

Property Value

Type: EndCap
The pen EndCap used when drawing.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.Fill Property

AtalaPenFill Property

Gets or sets the Fill used when drawing with this pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Fill Fill { get; set; }
Public Property Fill As Fill
    Get
    Set

Property Value

Type: Fill
The Brush object used when drawing with this pen.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.LineStyle Property

AtalaPenLineStyle Property

Gets or sets the type of line drawn with this pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineStyle LineStyle { get; set; }
Public Property LineStyle As LineStyle
    Get
    Set

Property Value

Type: LineStyle
The type of line drawn with this pen.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.Width Property

AtalaPenWidth Property

Gets or sets the width of the pen in pixels.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set

Property Value

Type: Int32
The width of the pen in pixels.
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen Methods

The AtalaPen type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Create a copy of this AtalaPen.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPen.Clone Method

AtalaPenClone Method

Create a copy of this AtalaPen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
Pen object

Implements

ICloneableClone
See Also

Reference

AtalaPen Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter Class

AtalaPenConverter i s utility for serialization of objects to AtalaPen
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelExpandableObjectConverter
Atalasoft.Imaging.DrawingAtalaPenConverter

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaPenConverter : ExpandableObjectConverter
Public Class AtalaPenConverter
    Inherits ExpandableObjectConverter

The AtalaPenConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaPenConverter | Initializes a new instance of the AtalaPenConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter Constructor

Initializes a new instance of the AtalaPenConverter class

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPenConverter()
Public Sub New
See Also

Reference

AtalaPenConverter Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter Methods

The AtalaPenConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaPenConverter Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.CanConvertFrom Method

AtalaPenConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AtalaPenConverter Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

AtalaPenConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

AtalaPenConverter Class
CanConvertFrom Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.CanConvertTo Method

AtalaPenConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

AtalaPenConverter Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

AtalaPenConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

AtalaPenConverter Class
CanConvertTo Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.ConvertFrom Method

AtalaPenConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

AtalaPenConverter Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

AtalaPenConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AtalaPenConverter Class
ConvertFrom Overload
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.ConvertTo Method

AtalaPenConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

AtalaPenConverter Class
Atalasoft.Imaging.Drawing Namespace


AtalaPenConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

AtalaPenConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

AtalaPenConverter Class
ConvertTo Overload
Atalasoft.Imaging.Drawing Namespace


Canvas Class

This class is used to draw primitives and text onto an AtalaImage, Bitmap, or Graphics object.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.DrawingCanvas

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Canvas
Public Class Canvas

The Canvas type exposes the following members.

Constructors
 | Name | Description
Public method | Canvas(Graphics) | Initializes a new instance of a Canvas object specifying a Graphics to draw on.
Public method | Canvas(AtalaImage) | Initializes a new instance of a Canvas object specifying an AtalaImage to draw on.
Top
Properties
 | Name | Description
Public property | FontQuality | Gets or sets the quality for font rendering.
Public property | InvertedOnGraphics | Gets or sets a value indicating if entities being drawn on a graphics object will be inverted.
Public property | SmoothingLevel | Gets or sets the amount of antialiasing applied to the entity being drawn onto this canvas.
Top
Methods
 | Name | Description
 | CalculateTextSize(String, Font) | Calculates the pixel size required to draw text using a specific font.
 | CalculateTextSize(String, Font, TextFormat) | Calculates the pixel size required to draw text using a specific font and text format.
 | CalculateTextSize(String, Size, Font, TextFormat) | Calculates the size of bound text without actually drawing it.
Public method | DrawEllipse(Rectangle, AtalaPen) | Draws an ellipse onto this canvas specifying the border pen.
Public method | DrawEllipse(Rectangle, Fill) | Draws an ellipse onto this canvas specifying the Fill.
Public method | DrawEllipse(Rectangle, AtalaPen, Fill) | Draws an ellipse onto this canvas specifying the border pen and Fill.
Public method | DrawLine | Draw a line onto this canvas.
Public method | DrawLines | Draws multiple connected lines onto this canvas.
Public method | DrawPolygon(Point, AtalaPen) | Draw a series of connected lines that form a closed polygon specifying the border pen.
Public method | DrawPolygon(Point, Fill) | Draw a series of connected lines that form a closed polygon specifying the inside fill.
Public method | DrawPolygon(Point, AtalaPen, Fill) | Draw a series of connected lines that form a closed polygon specifying the border pen and inside fill.
Public method | DrawRectangle(Rectangle, AtalaPen) | Draws a rectangle onto this canvas specifying the border pen.
Public method | DrawRectangle(Rectangle, Fill) | Draws a rectangle onto this canvas specifying the fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Fill) | Draws a rectangle onto this canvas specifying the border pen and fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Size) | Draws a rounded rectangle onto this canvas specifying the border pen.
Public method | DrawRectangle(Rectangle, Fill, Size) | Draws a rounded rectangle onto this canvas specifying the fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Fill, Size) | Draws a rounded rectangle onto this canvas specifying the border pen and fill.
Public method | DrawRegion | Draws a filled region.
 | DrawText(String, Point, Font, Fill) | Draw a single line text string onto this canvas specifying the upper left corner position.
Public method | DrawText(String, Rectangle, Font, Fill) | Draw multiline text onto this canvas specifying the rectangular bound area of the string.
Public method | DrawText(String, Point, Font, Fill, SolidFill) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | DrawText(String, Point, Font, Fill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and text formatting.
Public method | DrawText(String, Rectangle, Font, Fill, TextFormat) | Draw multiline text onto this canvas specifying the rectangular bound area of the string and text formatting.
Public method | DrawText(String, Point, Font, Fill, SolidFill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | DrawText(String, Rectangle, Font, Fill, SolidFill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

To use the canvas class, create an instance specifying the object that will be drawn on in the constructor. If you're using the WorkspaceViewer WinControl, you will have to invoke ClearCache to show the changes to the image.

The drawing class has some advantages over using the Graphics object in GDI+. You may draw directly onto grayscale, colormapped, and 1-bit document images. In addition, you can choose the border color and line type with an AtalaPen, and if the drawing entity supports it, a Fill to use to fill the inside of the entity. The various Fill objects can be used for solid, hatched, gradient, or textured filled areas for both the border and inside of the entity.

A smoothingLevel can be specified in the canvas object which can be configured to enable antialising of the drawn objects.

In addition, when drawing onto a graphics object, you may specify an inverted pen, using the XOR algorithm when drawing any entity onto the device. This property is ignored

See Also

Reference

Atalasoft.Imaging.Drawing Namespace


Canvas Constructor

Overload List
 | Name | Description
Public method | Canvas(Graphics) | Initializes a new instance of a Canvas object specifying a Graphics to draw on.
Public method | Canvas(AtalaImage) | Initializes a new instance of a Canvas object specifying an AtalaImage to draw on.
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas Constructor (Graphics)

Initializes a new instance of a Canvas object specifying a Graphics to draw on.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Canvas(
    Graphics graphics
)
Public Sub New (
    graphics As Graphics
)

Parameters

graphics
Type: System.DrawingGraphics
The device to draw on.
See Also

Reference

Canvas Class
Canvas Overload
Atalasoft.Imaging.Drawing Namespace


Canvas Constructor (AtalaImage)

Initializes a new instance of a Canvas object specifying an AtalaImage to draw on.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Canvas(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to draw on.
See Also

Reference

Canvas Class
Canvas Overload
Atalasoft.Imaging.Drawing Namespace


Canvas Properties

The Canvas type exposes the following members.

Properties
 | Name | Description
Public property | FontQuality | Gets or sets the quality for font rendering.
Public property | InvertedOnGraphics | Gets or sets a value indicating if entities being drawn on a graphics object will be inverted.
Public property | SmoothingLevel | Gets or sets the amount of antialiasing applied to the entity being drawn onto this canvas.
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.FontQuality Property

CanvasFontQuality Property

Gets or sets the quality for font rendering.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontQuality FontQuality { get; set; }
Public Property FontQuality As FontQuality
    Get
    Set

Property Value

Type: FontQuality
The rendering quality of the font.
Remarks
ClearType is only available on Windows XP and above.
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.InvertedOnGraphics Property

CanvasInvertedOnGraphics Property

Gets or sets a value indicating if entities being drawn on a graphics object will be inverted.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool InvertedOnGraphics { get; set; }
Public Property InvertedOnGraphics As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if entities being drawn on a graphics object will be inverted.
Remarks
Setting this property to true will cause the pixels beneath the entity to be negated with the XOR algorithm. This is useful when drawing rubber-bands that can quickly be erased be drawing over the same location twice. The selection rectangle in the WinForm Viewport control by default draws on an inverted canvas.
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.SmoothingLevel Property

CanvasSmoothingLevel Property

Gets or sets the amount of antialiasing applied to the entity being drawn onto this canvas.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SmoothingLevel { get; set; }
Public Property SmoothingLevel As Double
    Get
    Set

Property Value

Type: Double
The amount of antialiasing applied to the entity being drawn onto this canvas.
Remarks

Smoothing only works on continuous tone images (grayscale, RGB, or RGBA generally) and will be ignored with colormapped images. By default, all canvas objects start with a smoothing level of 0. The greater the smoothing level the more washed out the entity being drawn will appear. There is no upper limit to the smoothing level but it must be greater than or equal to zero.

See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas Methods

The Canvas type exposes the following members.

Methods
 | Name | Description
 | CalculateTextSize(String, Font) | Calculates the pixel size required to draw text using a specific font.
 | CalculateTextSize(String, Font, TextFormat) | Calculates the pixel size required to draw text using a specific font and text format.
 | CalculateTextSize(String, Size, Font, TextFormat) | Calculates the size of bound text without actually drawing it.
Public method | DrawEllipse(Rectangle, AtalaPen) | Draws an ellipse onto this canvas specifying the border pen.
Public method | DrawEllipse(Rectangle, Fill) | Draws an ellipse onto this canvas specifying the Fill.
Public method | DrawEllipse(Rectangle, AtalaPen, Fill) | Draws an ellipse onto this canvas specifying the border pen and Fill.
Public method | DrawLine | Draw a line onto this canvas.
Public method | DrawLines | Draws multiple connected lines onto this canvas.
Public method | DrawPolygon(Point, AtalaPen) | Draw a series of connected lines that form a closed polygon specifying the border pen.
Public method | DrawPolygon(Point, Fill) | Draw a series of connected lines that form a closed polygon specifying the inside fill.
Public method | DrawPolygon(Point, AtalaPen, Fill) | Draw a series of connected lines that form a closed polygon specifying the border pen and inside fill.
Public method | DrawRectangle(Rectangle, AtalaPen) | Draws a rectangle onto this canvas specifying the border pen.
Public method | DrawRectangle(Rectangle, Fill) | Draws a rectangle onto this canvas specifying the fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Fill) | Draws a rectangle onto this canvas specifying the border pen and fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Size) | Draws a rounded rectangle onto this canvas specifying the border pen.
Public method | DrawRectangle(Rectangle, Fill, Size) | Draws a rounded rectangle onto this canvas specifying the fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Fill, Size) | Draws a rounded rectangle onto this canvas specifying the border pen and fill.
Public method | DrawRegion | Draws a filled region.
 | DrawText(String, Point, Font, Fill) | Draw a single line text string onto this canvas specifying the upper left corner position.
Public method | DrawText(String, Rectangle, Font, Fill) | Draw multiline text onto this canvas specifying the rectangular bound area of the string.
Public method | DrawText(String, Point, Font, Fill, SolidFill) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | DrawText(String, Point, Font, Fill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and text formatting.
Public method | DrawText(String, Rectangle, Font, Fill, TextFormat) | Draw multiline text onto this canvas specifying the rectangular bound area of the string and text formatting.
Public method | DrawText(String, Point, Font, Fill, SolidFill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | DrawText(String, Rectangle, Font, Fill, SolidFill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.CalculateTextSize Method

CanvasCalculateTextSize Method

Overload List
Name | Description
CalculateTextSize(String, Font) | Calculates the pixel size required to draw text using a specific font.
CalculateTextSize(String, Font, TextFormat) | Calculates the pixel size required to draw text using a specific font and text format.
CalculateTextSize(String, Size, Font, TextFormat) | Calculates the size of bound text without actually drawing it.
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.CalculateTextSize Method (String, Font)

CanvasCalculateTextSize Method (String, Font)

Calculates the pixel size required to draw text using a specific font.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size CalculateTextSize(
    string text,
    Font font
)
Public Shared Function CalculateTextSize (
    text As String,
    font As Font
) As Size

Parameters

text
Type: SystemString
The text to draw.
font
Type: System.DrawingFont
The font used for the text.

Return Value

Type: Size
The size in pixel.
See Also

Reference

Canvas Class
CalculateTextSize Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.CalculateTextSize Method (String, Font, TextFormat)

CanvasCalculateTextSize Method (String, Font, TextFormat)

Calculates the pixel size required to draw text using a specific font and text format.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size CalculateTextSize(
    string text,
    Font font,
    TextFormat format
)
Public Shared Function CalculateTextSize (
    text As String,
    font As Font,
    format As TextFormat
) As Size

Parameters

text
Type: SystemString
The text string to evaluate.
font
Type: System.DrawingFont
The text font.
format
Type: Atalasoft.Imaging.DrawingTextFormat
The text formatting to apply.

Return Value

Type: Size
Returns the size of single line text without actually drawing it.
See Also

Reference

Canvas Class
CalculateTextSize Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.CalculateTextSize Method (String, Size, Font, TextFormat)

CanvasCalculateTextSize Method (String, Size, Font, TextFormat)

Calculates the size of bound text without actually drawing it.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size CalculateTextSize(
    string text,
    Size boundSize,
    Font font,
    TextFormat format
)
Public Shared Function CalculateTextSize (
    text As String,
    boundSize As Size,
    font As Font,
    format As TextFormat
) As Size

Parameters

text
Type: SystemString
The text string to evaluate.
boundSize
Type: System.DrawingSize
The size of the bound
font
Type: System.DrawingFont
The text font.
format
Type: Atalasoft.Imaging.DrawingTextFormat
The text formatting to apply.

Return Value

Type: Size
Returns the size of bound text without actually drawing it.
See Also

Reference

Canvas Class
CalculateTextSize Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawEllipse Method

CanvasDrawEllipse Method

Overload List
 | Name | Description
Public method | DrawEllipse(Rectangle, AtalaPen) | Draws an ellipse onto this canvas specifying the border pen.
Public method | DrawEllipse(Rectangle, Fill) | Draws an ellipse onto this canvas specifying the Fill.
Public method | DrawEllipse(Rectangle, AtalaPen, Fill) | Draws an ellipse onto this canvas specifying the border pen and Fill.
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawEllipse Method (Rectangle, AtalaPen)

CanvasDrawEllipse Method (Rectangle, AtalaPen)

Draws an ellipse onto this canvas specifying the border pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawEllipse(
    Rectangle rect,
    AtalaPen pen
)
Public Sub DrawEllipse (
    rect As Rectangle,
    pen As AtalaPen
)

Parameters

rect
Type: System.DrawingRectangle
The bounding rectangle of the ellipse.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
See Also

Reference

Canvas Class
DrawEllipse Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawEllipse Method (Rectangle, Fill)

CanvasDrawEllipse Method (Rectangle, Fill)

Draws an ellipse onto this canvas specifying the Fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawEllipse(
    Rectangle rect,
    Fill fill
)
Public Sub DrawEllipse (
    rect As Rectangle,
    fill As Fill
)

Parameters

rect
Type: System.DrawingRectangle
The bounding rectangle of the ellipse.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
See Also

Reference

Canvas Class
DrawEllipse Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawEllipse Method (Rectangle, AtalaPen, Fill)

CanvasDrawEllipse Method (Rectangle, AtalaPen, Fill)

Draws an ellipse onto this canvas specifying the border pen and Fill.
Draws an ellipse onto this canvas.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawEllipse(
    Rectangle rect,
    AtalaPen pen,
    Fill fill
)
Public Sub DrawEllipse (
    rect As Rectangle,
    pen As AtalaPen,
    fill As Fill
)

Parameters

rect
Type: System.DrawingRectangle
The bounding rectangle of the ellipse.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
See Also

Reference

Canvas Class
DrawEllipse Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawLine Method

CanvasDrawLine Method

Draw a line onto this canvas.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawLine(
    Point startPoint,
    Point endPoint,
    AtalaPen pen
)
Public Sub DrawLine (
    startPoint As Point,
    endPoint As Point,
    pen As AtalaPen
)

Parameters

startPoint
Type: System.DrawingPoint
The start point of the line in image pixel coordinates.
endPoint
Type: System.DrawingPoint
The end point of the line in image pixel coordinates.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controling the line characteristics.
Remarks
The line is specified from a start point to an end point and a pen to control it's color, thickness, line style, and fill style.
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawLines Method

CanvasDrawLines Method

Draws multiple connected lines onto this canvas.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawLines(
    Point[] points,
    AtalaPen pen
)
Public Sub DrawLines (
    points As Point(),
    pen As AtalaPen
)

Parameters

points
Type: System.DrawingPoint
An array of points that straight lines are drawn through.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the line characteristics.
Remarks
The lines are specifyied with a series of points. To connect the last point with the first point see DrawPolygon.
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawPolygon Method

CanvasDrawPolygon Method

Overload List
 | Name | Description
Public method | DrawPolygon(Point, AtalaPen) | Draw a series of connected lines that form a closed polygon specifying the border pen.
Public method | DrawPolygon(Point, Fill) | Draw a series of connected lines that form a closed polygon specifying the inside fill.
Public method | DrawPolygon(Point, AtalaPen, Fill) | Draw a series of connected lines that form a closed polygon specifying the border pen and inside fill.
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawPolygon Method (Point[], AtalaPen)

CanvasDrawPolygon Method (Point, AtalaPen)

Draw a series of connected lines that form a closed polygon specifying the border pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawPolygon(
    Point[] points,
    AtalaPen pen
)
Public Sub DrawPolygon (
    points As Point(),
    pen As AtalaPen
)

Parameters

points
Type: System.DrawingPoint
An array of points forming a polygon that straight lines are drawn through.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
Remarks
The first and last points are connected, forming the closed polygon.
See Also

Reference

Canvas Class
DrawPolygon Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawPolygon Method (Point[], Fill)

CanvasDrawPolygon Method (Point, Fill)

Draw a series of connected lines that form a closed polygon specifying the inside fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawPolygon(
    Point[] points,
    Fill fill
)
Public Sub DrawPolygon (
    points As Point(),
    fill As Fill
)

Parameters

points
Type: System.DrawingPoint
An array of points forming a polygon that straight lines are drawn through.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
Remarks
The first and last points are connected, forming the closed polygon.
See Also

Reference

Canvas Class
DrawPolygon Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawPolygon Method (Point[], AtalaPen, Fill)

CanvasDrawPolygon Method (Point, AtalaPen, Fill)

Draw a series of connected lines that form a closed polygon specifying the border pen and inside fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawPolygon(
    Point[] points,
    AtalaPen pen,
    Fill fill
)
Public Sub DrawPolygon (
    points As Point(),
    pen As AtalaPen,
    fill As Fill
)

Parameters

points
Type: System.DrawingPoint
An array of points forming a polygon that straight lines are drawn through.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The %AtalaPen% controlling the border characteristics.
fill
Type: Atalasoft.Imaging.DrawingFill
The %Fill% specifying the fill characteristics.
Remarks
The first and last points are connected, forming the closed polygon.
See Also

Reference

Canvas Class
DrawPolygon Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method

CanvasDrawRectangle Method

Overload List
 | Name | Description
Public method | DrawRectangle(Rectangle, AtalaPen) | Draws a rectangle onto this canvas specifying the border pen.
Public method | DrawRectangle(Rectangle, Fill) | Draws a rectangle onto this canvas specifying the fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Fill) | Draws a rectangle onto this canvas specifying the border pen and fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Size) | Draws a rounded rectangle onto this canvas specifying the border pen.
Public method | DrawRectangle(Rectangle, Fill, Size) | Draws a rounded rectangle onto this canvas specifying the fill.
Public method | DrawRectangle(Rectangle, AtalaPen, Fill, Size) | Draws a rounded rectangle onto this canvas specifying the border pen and fill.
Top
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method (Rectangle, AtalaPen)

CanvasDrawRectangle Method (Rectangle, AtalaPen)

Draws a rectangle onto this canvas specifying the border pen.
Draws a rectangle onto this canvas.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRectangle(
    Rectangle rect,
    AtalaPen pen
)
Public Sub DrawRectangle (
    rect As Rectangle,
    pen As AtalaPen
)

Parameters

rect
Type: System.DrawingRectangle
The position and size of the rectangle.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
See Also

Reference

Canvas Class
DrawRectangle Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method (Rectangle, Fill)

CanvasDrawRectangle Method (Rectangle, Fill)

Draws a rectangle onto this canvas specifying the fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRectangle(
    Rectangle rect,
    Fill fill
)
Public Sub DrawRectangle (
    rect As Rectangle,
    fill As Fill
)

Parameters

rect
Type: System.DrawingRectangle
The position and size of the rectangle.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
See Also

Reference

Canvas Class
DrawRectangle Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method (Rectangle, AtalaPen, Fill)

CanvasDrawRectangle Method (Rectangle, AtalaPen, Fill)

Draws a rectangle onto this canvas specifying the border pen and fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRectangle(
    Rectangle rect,
    AtalaPen pen,
    Fill fill
)
Public Sub DrawRectangle (
    rect As Rectangle,
    pen As AtalaPen,
    fill As Fill
)

Parameters

rect
Type: System.DrawingRectangle
The position and size of the rectangle.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
See Also

Reference

Canvas Class
DrawRectangle Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method (Rectangle, AtalaPen, Size)

CanvasDrawRectangle Method (Rectangle, AtalaPen, Size)

Draws a rounded rectangle onto this canvas specifying the border pen.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRectangle(
    Rectangle rect,
    AtalaPen pen,
    Size cornerRadius
)
Public Sub DrawRectangle (
    rect As Rectangle,
    pen As AtalaPen,
    cornerRadius As Size
)

Parameters

rect
Type: System.DrawingRectangle
The position and size of the rectangle.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
cornerRadius
Type: System.DrawingSize
The radius in pixels of the corners.
See Also

Reference

Canvas Class
DrawRectangle Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method (Rectangle, Fill, Size)

CanvasDrawRectangle Method (Rectangle, Fill, Size)

Draws a rounded rectangle onto this canvas specifying the fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRectangle(
    Rectangle rect,
    Fill fill,
    Size cornerRadius
)
Public Sub DrawRectangle (
    rect As Rectangle,
    fill As Fill,
    cornerRadius As Size
)

Parameters

rect
Type: System.DrawingRectangle
The position and size of the rectangle.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
cornerRadius
Type: System.DrawingSize
The radius in pixels of the corners.
See Also

Reference

Canvas Class
DrawRectangle Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRectangle Method (Rectangle, AtalaPen, Fill, Size)

CanvasDrawRectangle Method (Rectangle, AtalaPen, Fill, Size)

Draws a rounded rectangle onto this canvas specifying the border pen and fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRectangle(
    Rectangle rect,
    AtalaPen pen,
    Fill fill,
    Size cornerRadius
)
Public Sub DrawRectangle (
    rect As Rectangle,
    pen As AtalaPen,
    fill As Fill,
    cornerRadius As Size
)

Parameters

rect
Type: System.DrawingRectangle
The position and size of the rectangle.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
The AtalaPen controlling the border characteristics.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
cornerRadius
Type: System.DrawingSize
The radius in pixels of the corners.
See Also

Reference

Canvas Class
DrawRectangle Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawRegion Method

CanvasDrawRegion Method

Draws a filled region.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawRegion(
    Region region,
    Fill fill
)
Public Sub DrawRegion (
    region As Region,
    fill As Fill
)

Parameters

region
Type: System.DrawingRegion
The region to fill.
fill
Type: Atalasoft.Imaging.DrawingFill
The Fill specifying the fill characteristics.
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method

CanvasDrawText Method

Examples
Centered (C#)
Copy
// Load the image to work with.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Create a Canvas for this image.
Canvas canv = new Canvas(image);

// Setup the text font options.
Font fnt = new Font("Verdana", 36, FontStyle.Bold);

// Find out the rendered size of the text.
Size textSize = Canvas.CalculateTextSize("%%company%% DotImage", fnt);

// Draw the text centered on the image.
Point pt = new Point((image.Width - textSize.Width) / 2, (image.Height - textSize.Height) / 2);
canv.DrawText("%%company%% DotImage", pt, fnt, new SolidFill(Color.Red), new SolidFill(Color.Transparent));
CenteredVB (Visual Basic)
Copy
' Load the image to work with.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Create a Canvas for this image.
Dim canv As Canvas =  New Canvas(image)

' Setup the text font options.
Dim fnt As Font =  New Font("Verdana", 36, FontStyle.Bold)

' Find out the rendered size of the text.
Dim textSize As Size =  Canvas.CalculateTextSize("%%company%% DotImage", fnt)

' Draw the text centered on the image.
Dim pt As Point =  New Point((image.Width - textSize.Width) / 2,(image.Height - textSize.Height) / 2)
canv.DrawText("%%company%% DotImage", pt, fnt, New SolidFill(Color.Red), New SolidFill(Color.Transparent))
Overload List
 | Name | Description
 | DrawText(String, Point, Font, Fill) | Draw a single line text string onto this canvas specifying the upper left corner position.
Public method | DrawText(String, Rectangle, Font, Fill) | Draw multiline text onto this canvas specifying the rectangular bound area of the string.
Public method | DrawText(String, Point, Font, Fill, SolidFill) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | DrawText(String, Point, Font, Fill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and text formatting.
Public method | DrawText(String, Rectangle, Font, Fill, TextFormat) | Draw multiline text onto this canvas specifying the rectangular bound area of the string and text formatting.
Public method | DrawText(String, Point, Font, Fill, SolidFill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Public method | DrawText(String, Rectangle, Font, Fill, SolidFill, TextFormat) | Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.
Top
Examples
Centered (C#)
Copy
// Load the image to work with.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Create a Canvas for this image.
Canvas canv = new Canvas(image);

// Setup the text font options.
Font fnt = new Font("Verdana", 36, FontStyle.Bold);

// Find out the rendered size of the text.
Size textSize = Canvas.CalculateTextSize("%%company%% DotImage", fnt);

// Draw the text centered on the image.
Point pt = new Point((image.Width - textSize.Width) / 2, (image.Height - textSize.Height) / 2);
canv.DrawText("%%company%% DotImage", pt, fnt, new SolidFill(Color.Red), new SolidFill(Color.Transparent));
CenteredVB (Visual Basic)
Copy
' Load the image to work with.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Create a Canvas for this image.
Dim canv As Canvas =  New Canvas(image)

' Setup the text font options.
Dim fnt As Font =  New Font("Verdana", 36, FontStyle.Bold)

' Find out the rendered size of the text.
Dim textSize As Size =  Canvas.CalculateTextSize("%%company%% DotImage", fnt)

' Draw the text centered on the image.
Dim pt As Point =  New Point((image.Width - textSize.Width) / 2,(image.Height - textSize.Height) / 2)
canv.DrawText("%%company%% DotImage", pt, fnt, New SolidFill(Color.Red), New SolidFill(Color.Transparent))
See Also

Reference

Canvas Class
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Point, Font, Fill)

CanvasDrawText Method (String, Point, Font, Fill)

Draw a single line text string onto this canvas specifying the upper left corner position.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Point position,
    Font font,
    Fill foreColor
)
Public Function DrawText (
    text As String,
    position As Point,
    font As Font,
    foreColor As Fill
) As Size

Parameters

text
Type: SystemString
The text string to draw.
position
Type: System.DrawingPoint
The position of the upper left corner of the text rectangle to draw.
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.

Return Value

Type: Size
The actual size of the text drawn.
Remarks
By default, text is drawn relative to the system DPI. To draw text relative to another DPI, such as the image DPI, see the ScaleToDpi property of TextFormat.
See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Rectangle, Font, Fill)

CanvasDrawText Method (String, Rectangle, Font, Fill)

Draw multiline text onto this canvas specifying the rectangular bound area of the string.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Rectangle boundRectangle,
    Font font,
    Fill foreColor
)
Public Function DrawText (
    text As String,
    boundRectangle As Rectangle,
    font As Font,
    foreColor As Fill
) As Size

Parameters

text
Type: SystemString
The text string to draw.
boundRectangle
Type: System.DrawingRectangle
The bounding rectangle of the text to draw. Specify 0 height to prevent clipping the text.
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.

Return Value

Type: Size
The actual size of the text drawn.
Remarks

The rectangular width must be specified. Specify a value for the rectangular height to clip the text, or 0 to prevent clipping the text.

See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Point, Font, Fill, SolidFill)

CanvasDrawText Method (String, Point, Font, Fill, SolidFill)

Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Point position,
    Font font,
    Fill foreColor,
    SolidFill backColor
)
Public Function DrawText (
    text As String,
    position As Point,
    font As Font,
    foreColor As Fill,
    backColor As SolidFill
) As Size

Parameters

text
Type: SystemString
The text string to draw.
position
Type: System.DrawingPoint
The position of the upper left corner of the text rectangle to draw.
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.
backColor
Type: Atalasoft.Imaging.DrawingSolidFill
The background color.

Return Value

Type: Size
See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Point, Font, Fill, TextFormat)

CanvasDrawText Method (String, Point, Font, Fill, TextFormat)

Draw a single line text string onto this canvas specifying the upper left corner position and text formatting.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Point position,
    Font font,
    Fill foreColor,
    TextFormat format
)
Public Function DrawText (
    text As String,
    position As Point,
    font As Font,
    foreColor As Fill,
    format As TextFormat
) As Size

Parameters

text
Type: SystemString
The text string to draw.
position
Type: System.DrawingPoint
The position of the upper left corner of the text rectangle to draw.
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.
format
Type: Atalasoft.Imaging.DrawingTextFormat
The text formatting to apply.

Return Value

Type: Size
The actual size of the text drawn.
See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Rectangle, Font, Fill, TextFormat)

CanvasDrawText Method (String, Rectangle, Font, Fill, TextFormat)

Draw multiline text onto this canvas specifying the rectangular bound area of the string and text formatting.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Rectangle boundRectangle,
    Font font,
    Fill foreColor,
    TextFormat format
)
Public Function DrawText (
    text As String,
    boundRectangle As Rectangle,
    font As Font,
    foreColor As Fill,
    format As TextFormat
) As Size

Parameters

text
Type: SystemString
The text string to draw.
boundRectangle
Type: System.DrawingRectangle
The bounding rectangle of the text to draw. Specify 0 height to prevent clipping the text
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.
format
Type: Atalasoft.Imaging.DrawingTextFormat
The text formatting to apply.

Return Value

Type: Size
The actual size of the text drawn.
Remarks

The rectangular width must be specified. Specify a value for the rectangular height to clip the text, or 0 to prevent clipping the text.

See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Point, Font, Fill, SolidFill, TextFormat)

CanvasDrawText Method (String, Point, Font, Fill, SolidFill, TextFormat)

Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Point position,
    Font font,
    Fill foreColor,
    SolidFill backColor,
    TextFormat format
)
Public Function DrawText (
    text As String,
    position As Point,
    font As Font,
    foreColor As Fill,
    backColor As SolidFill,
    format As TextFormat
) As Size

Parameters

text
Type: SystemString
The text string to draw.
position
Type: System.DrawingPoint
The position of the upper left corner of the text rectangle to draw.
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.
backColor
Type: Atalasoft.Imaging.DrawingSolidFill
The background color.
format
Type: Atalasoft.Imaging.DrawingTextFormat
The text formatting to apply.

Return Value

Type: Size
See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


Canvas.DrawText Method (String, Rectangle, Font, Fill, SolidFill, TextFormat)

CanvasDrawText Method (String, Rectangle, Font, Fill, SolidFill, TextFormat)

Draw a single line text string onto this canvas specifying the upper left corner position and a solid background color.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DrawText(
    string text,
    Rectangle boundRectangle,
    Font font,
    Fill foreColor,
    SolidFill backColor,
    TextFormat format
)
Public Function DrawText (
    text As String,
    boundRectangle As Rectangle,
    font As Font,
    foreColor As Fill,
    backColor As SolidFill,
    format As TextFormat
) As Size

Parameters

text
Type: SystemString
The text string to draw.
boundRectangle
Type: System.DrawingRectangle
The bounding rectangle of the text to draw. Specify 0 height to prevent clipping the text.
font
Type: System.DrawingFont
The text font.
foreColor
Type: Atalasoft.Imaging.DrawingFill
The text fill.
backColor
Type: Atalasoft.Imaging.DrawingSolidFill
The background color.
format
Type: Atalasoft.Imaging.DrawingTextFormat
The text formatting to apply.

Return Value

Type: Size
See Also

Reference

Canvas Class
DrawText Overload
Atalasoft.Imaging.Drawing Namespace


CornerJoin Enumeration

Corner style used where lines join.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CornerJoin
Public Enumeration CornerJoin
Members
Member name | Description
Miter | Joins are mitred.
Bevel | Joins are beveled.
Round | Joins are round.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


EndCap Enumeration

Drawing style for the end of lines.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum EndCap
Public Enumeration EndCap
Members
Member name | Description
Flat | End caps are flat.
Round | End caps are round.
Square | End caps are square.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


Fill Class

The base class which all Fill objects inherit. A Fill contains the color of the entity being drawn.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.DrawingFill
Atalasoft.Imaging.DrawingHatchedFill
Atalasoft.Imaging.DrawingSolidFill

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class Fill : ICloneable
Public MustInherit Class Fill
    Implements ICloneable

The Fill type exposes the following members.

Constructors
 | Name | Description
Protected method | Fill | Initializes a new instance of the Fill class
Top
Properties
 | Name | Description
Public property | Color | Gets or sets the color of the fill.
Public property | PaletteIndex | Gets or sets the palette index used for the color.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this Fill.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushHandle | Returns a GDI handle to the brush (for internal use only).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The DotImage Fill object is equivalent to the GDI+ Brush.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


Fill Constructor

Initializes a new instance of the Fill class

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Fill()
Protected Sub New
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


Fill Properties

The Fill type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets or sets the color of the fill.
Public property | PaletteIndex | Gets or sets the palette index used for the color.
Top
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


Fill.Color Property

FillColor Property

Gets or sets the color of the fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color

The color of the fill.

Remarks
Specify the alpha value to draw with transparency onto a continuous tone image.
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


Fill.PaletteIndex Property

FillPaletteIndex Property

Gets or sets the palette index used for the color.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PaletteIndex { get; set; }
Public Property PaletteIndex As Integer
    Get
    Set

Property Value

Type: Int32
The palette index used for the color.
Remarks
This is only valid when drawing onto an 8-bit image.
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


Fill Methods

The Fill type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this Fill.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushHandle | Returns a GDI handle to the brush (for internal use only).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


Fill.Clone Method

FillClone Method

Returns a copy of this Fill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract Object Clone()
Public MustOverride Function Clone As Object

Return Value

Type: Object
A copy of this Fill.

Implements

ICloneableClone
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


Fill.GetBrushHandle Method

FillGetBrushHandle Method

Returns a GDI handle to the brush (for internal use only).

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract IntPtr GetBrushHandle()
Public MustOverride Function GetBrushHandle As IntPtr

Return Value

Type: IntPtr
See Also

Reference

Fill Class
Atalasoft.Imaging.Drawing Namespace


FontQuality Enumeration

Font quality style when using the DrawText method.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FontQuality
Public Enumeration FontQuality
Members
Member name | Description
Default | Appearance of the font does not matter. System settings will determine its quality.
Draft | Appearance of the font is less important than when Proof is used. For raster fonts, scaling is enabled, which means that more font sizes are available, but the quality may be lower. Bold, italic, underline, and strikeout fonts are synthesized if necessary.
Proof | Character quality of the font is more important than exact matching of the logical-font attributes. For raster fonts, scaling is disabled and the font closest in size is chosen.
NonAntialiased | Font is never antialiased.
Antialiased | Font is always antialiased if the font supports it and the size of the font is not too small or too large.
ClearType | If set, text is rendered (when possible) using ClearType antialiasing method. Windows XP or above is requred.
Remarks
The following situations do not support ClearType antialiasing: Text is rendered on a printer.Display set for 256 colors or less.Text is rendered to a terminal server client.The font is not a TrueType font or an OpenType font with TrueType outlines. For example, the following do not support ClearType antialiasing: Type 1 fonts, Postscript OpenType fonts without TrueType outlines, bitmap fonts, vector fonts, and device fonts.The font has tuned embedded bitmaps, for any font sizes that contain the embedded bitmaps. For example, this occurs commonly in East Asian fonts.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


Hatch Enumeration

The style of Hatch to use when FillStyle is Hatched.
The style of Hatch to use with a %HatchedFill%.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Hatch
Public Enumeration Hatch
Members
Member name | Description
Cross | Horizontal and vertical cross-hatch
DiagonalCross | 45-degree crosshatch
DiagonalDown | A 45-degree downward, left-to-right hatch
DiagonalUp | A 45-degree upward, left-to-right hatch
Horizontal | Horizontal hatch
Vertical | Vertical hatch
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


HatchedFill Class

A Fill containing hatched lines.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.DrawingFill
Atalasoft.Imaging.DrawingHatchedFill

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class HatchedFill : Fill
Public NotInheritable Class HatchedFill
    Inherits Fill

The HatchedFill type exposes the following members.

Constructors
 | Name | Description
Public method | HatchedFill(Hatch) | Initializes a new instance of HatchedFill with a black hatch and specified hatch style.
Public method | HatchedFill(Hatch, Color) | Initializes a new instance of HatchedFill with a specified hatch style and color.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets the color of the fill. (Inherited from Fill.)
Public property | HatchStyle |
Public property | PaletteIndex | Gets or sets the palette index used for the color. (Inherited from Fill.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this HatchedFill. (Overrides FillClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrushHandle | Returns a GDI brush handle. (Overrides FillGetBrushHandle.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


HatchedFill Constructor

Creates a HatchedFill object.
Overload List
 | Name | Description
Public method | HatchedFill(Hatch) | Initializes a new instance of HatchedFill with a black hatch and specified hatch style.
Public method | HatchedFill(Hatch, Color) | Initializes a new instance of HatchedFill with a specified hatch style and color.
Top
See Also

Reference

HatchedFill Class
Atalasoft.Imaging.Drawing Namespace


HatchedFill Constructor (Hatch)

Initializes a new instance of HatchedFill with a black hatch and specified hatch style.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HatchedFill(
    Hatch style
)
Public Sub New (
    style As Hatch
)

Parameters

style
Type: Atalasoft.Imaging.DrawingHatch
The type of hatch.
See Also

Reference

HatchedFill Class
HatchedFill Overload
Atalasoft.Imaging.Drawing Namespace


HatchedFill Constructor (Hatch, Color)

Initializes a new instance of HatchedFill with a specified hatch style and color.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HatchedFill(
    Hatch style,
    Color color
)
Public Sub New (
    style As Hatch,
    color As Color
)

Parameters

style
Type: Atalasoft.Imaging.DrawingHatch
The type of hatch.
color
Type: System.DrawingColor
The hatch color.
See Also

Reference

HatchedFill Class
HatchedFill Overload
Atalasoft.Imaging.Drawing Namespace


HatchedFill Properties

The HatchedFill type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets or sets the color of the fill. (Inherited from Fill.)
Public property | HatchStyle |
Public property | PaletteIndex | Gets or sets the palette index used for the color. (Inherited from Fill.)
Top
See Also

Reference

HatchedFill Class
Atalasoft.Imaging.Drawing Namespace


HatchedFill.HatchStyle Property

HatchedFillHatchStyle Property

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Hatch HatchStyle { get; set; }
Public Property HatchStyle As Hatch
    Get
    Set

Property Value

Type: Hatch
The hatch style that will be drawn.
See Also

Reference

HatchedFill Class
Atalasoft.Imaging.Drawing Namespace


HatchedFill Methods

The HatchedFill type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this HatchedFill. (Overrides FillClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrushHandle | Returns a GDI brush handle. (Overrides FillGetBrushHandle.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HatchedFill Class
Atalasoft.Imaging.Drawing Namespace


HatchedFill.Clone Method

HatchedFillClone Method

Returns a copy of this HatchedFill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this HatchedFill.

Implements

ICloneableClone
See Also

Reference

HatchedFill Class
Atalasoft.Imaging.Drawing Namespace


HatchedFill.GetBrushHandle Method

HatchedFillGetBrushHandle Method

Returns a GDI brush handle.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override IntPtr GetBrushHandle()
Public Overrides Function GetBrushHandle As IntPtr

Return Value

Type: IntPtr
See Also

Reference

HatchedFill Class
Atalasoft.Imaging.Drawing Namespace


LineStyle Enumeration

The type of line to draw.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum LineStyle
Public Enumeration LineStyle
Members
Member name | Description
Solid | The pen is solid.
Dash | The pen is dashed.
Dot | The pen is dotted.
DashDot | The pen has alternating dashes and dots.
DashDotDot | The pen has alternating dashes and double dots.
Custom | Allows for a custom dash/dot combination.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


SolidFill Class

A Fill containing a solid color.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.DrawingFill
Atalasoft.Imaging.DrawingSolidFill

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class SolidFill : Fill
Public NotInheritable Class SolidFill
    Inherits Fill

The SolidFill type exposes the following members.

Constructors
 | Name | Description
Public method | SolidFill | Initializes a new instance of SolidFill with the color black.
Public method | SolidFill(Color) | Initializes a new instance of SolidFill with a specified color.
Top
Properties
 | Name | Description
Public property | Color | Gets or sets the color of the fill. (Inherited from Fill.)
Public property | PaletteIndex | Gets or sets the palette index used for the color. (Inherited from Fill.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this SolidFill. (Overrides FillClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrushHandle | Returns a GDI brush handle. (Overrides FillGetBrushHandle.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


SolidFill Constructor

Creates a SolidFill object.
Overload List
 | Name | Description
Public method | SolidFill | Initializes a new instance of SolidFill with the color black.
Public method | SolidFill(Color) | Initializes a new instance of SolidFill with a specified color.
Top
See Also

Reference

SolidFill Class
Atalasoft.Imaging.Drawing Namespace


SolidFill Constructor

Initializes a new instance of SolidFill with the color black.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SolidFill()
Public Sub New
See Also

Reference

SolidFill Class
SolidFill Overload
Atalasoft.Imaging.Drawing Namespace


SolidFill Constructor (Color)

Initializes a new instance of SolidFill with a specified color.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SolidFill(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor
The Fill color.
See Also

Reference

SolidFill Class
SolidFill Overload
Atalasoft.Imaging.Drawing Namespace


SolidFill Properties

The SolidFill type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets or sets the color of the fill. (Inherited from Fill.)
Public property | PaletteIndex | Gets or sets the palette index used for the color. (Inherited from Fill.)
Top
See Also

Reference

SolidFill Class
Atalasoft.Imaging.Drawing Namespace


SolidFill Methods

The SolidFill type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this SolidFill. (Overrides FillClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrushHandle | Returns a GDI brush handle. (Overrides FillGetBrushHandle.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SolidFill Class
Atalasoft.Imaging.Drawing Namespace


SolidFill.Clone Method

SolidFillClone Method

Returns a copy of this SolidFill.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Clone()
Public Overrides Function Clone As Object

Return Value

Type: Object
A copy of this SoldFill.

Implements

ICloneableClone
See Also

Reference

SolidFill Class
Atalasoft.Imaging.Drawing Namespace


SolidFill.GetBrushHandle Method

SolidFillGetBrushHandle Method

Returns a GDI brush handle.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override IntPtr GetBrushHandle()
Public Overrides Function GetBrushHandle As IntPtr

Return Value

Type: IntPtr
See Also

Reference

SolidFill Class
Atalasoft.Imaging.Drawing Namespace


TextAlignment Enumeration

The horizontal alignment of the text.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TextAlignment
Public Enumeration TextAlignment
Members
Member name | Description
Left | Left aligned text.
Center | Centered text.
Right | Right aligned text.
Justify | Justified text.
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


TextFormat Class

Contains extended properties for use with drawing text onto a Canvas.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.DrawingTextFormat

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextFormat : ICloneable
Public Class TextFormat
    Implements ICloneable

The TextFormat type exposes the following members.

Constructors
 | Name | Description
Public method | TextFormat | Initializes a new instance of TextFormat with default settings.
Public method | TextFormat(TextAlignment) | Initializes a new instance of TextFormat specifying the horizontal alignment.
Public method | TextFormat(TextAlignment, Double) | Initializes a new instance of TextFormat specifying the horizontal alignment and angle.
Public method | TextFormat(TextAlignment, Double, Int32) | Initializes a new instance of TextFormat specifying the horizontal alignment, angle, and inter-character spacing.
Public method | TextFormat(TextAlignment, Double, Int32, Dpi) | Initializes a new instance of the TextFormat class.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text to draw.
Public property | Angle | Gets or sets the angle in degrees of the text to draw.
Public property | CharacterWidth | Gets or sets the width of the characters
Public property | InterCharacterSpace | Gets or sets the number of additional pixels to add between characters.
Public property | ScaleToDpi | Causes text to be drawn relative to the specified DPI.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Drawing Namespace


TextFormat Constructor

Creates a TextFormat object.
Overload List
 | Name | Description
Public method | TextFormat | Initializes a new instance of TextFormat with default settings.
Public method | TextFormat(TextAlignment) | Initializes a new instance of TextFormat specifying the horizontal alignment.
Public method | TextFormat(TextAlignment, Double) | Initializes a new instance of TextFormat specifying the horizontal alignment and angle.
Public method | TextFormat(TextAlignment, Double, Int32) | Initializes a new instance of TextFormat specifying the horizontal alignment, angle, and inter-character spacing.
Public method | TextFormat(TextAlignment, Double, Int32, Dpi) | Initializes a new instance of the TextFormat class.
Top
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat Constructor

Initializes a new instance of TextFormat with default settings.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextFormat()
Public Sub New
See Also

Reference

TextFormat Class
TextFormat Overload
Atalasoft.Imaging.Drawing Namespace


TextFormat Constructor (TextAlignment)

Initializes a new instance of TextFormat specifying the horizontal alignment.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextFormat(
    TextAlignment alignment
)
Public Sub New (
    alignment As TextAlignment
)

Parameters

alignment
Type: Atalasoft.Imaging.DrawingTextAlignment
The horizontal alignment of the drawn text.
See Also

Reference

TextFormat Class
TextFormat Overload
Atalasoft.Imaging.Drawing Namespace


TextFormat Constructor (TextAlignment, Double)

Initializes a new instance of TextFormat specifying the horizontal alignment and angle.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextFormat(
    TextAlignment alignment,
    double angle
)
Public Sub New (
    alignment As TextAlignment,
    angle As Double
)

Parameters

alignment
Type: Atalasoft.Imaging.DrawingTextAlignment
The horizontal alignment of the drawn text.
angle
Type: SystemDouble
The angle in degrees of the drawn text.
See Also

Reference

TextFormat Class
TextFormat Overload
Atalasoft.Imaging.Drawing Namespace


TextFormat Constructor (TextAlignment, Double, Int32)

Initializes a new instance of TextFormat specifying the horizontal alignment, angle, and inter-character spacing.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextFormat(
    TextAlignment alignment,
    double angle,
    int interCharacterSpace
)
Public Sub New (
    alignment As TextAlignment,
    angle As Double,
    interCharacterSpace As Integer
)

Parameters

alignment
Type: Atalasoft.Imaging.DrawingTextAlignment
The horizontal alignment of the drawn text.
angle
Type: SystemDouble
The angle in degrees of the drawn text.
interCharacterSpace
Type: SystemInt32
Number of additional pixels to add between characters.
See Also

Reference

TextFormat Class
TextFormat Overload
Atalasoft.Imaging.Drawing Namespace


TextFormat Constructor (TextAlignment, Double, Int32, Dpi)

Initializes a new instance of the TextFormat class.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextFormat(
    TextAlignment alignment,
    double angle,
    int interCharacterSpace,
    Dpi scaleToDpi
)
Public Sub New (
    alignment As TextAlignment,
    angle As Double,
    interCharacterSpace As Integer,
    scaleToDpi As Dpi
)

Parameters

alignment
Type: Atalasoft.Imaging.DrawingTextAlignment
The alignment.
angle
Type: SystemDouble
The angle.
interCharacterSpace
Type: SystemInt32
The inter character space.
scaleToDpi
Type: Atalasoft.ImagingDpi
The scale to dpi.
See Also

Reference

TextFormat Class
TextFormat Overload
Atalasoft.Imaging.Drawing Namespace


TextFormat Properties

The TextFormat type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the horizontal alignment of the text to draw.
Public property | Angle | Gets or sets the angle in degrees of the text to draw.
Public property | CharacterWidth | Gets or sets the width of the characters
Public property | InterCharacterSpace | Gets or sets the number of additional pixels to add between characters.
Public property | ScaleToDpi | Causes text to be drawn relative to the specified DPI.
Top
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat.Alignment Property

TextFormatAlignment Property

Gets or sets the horizontal alignment of the text to draw.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextAlignment Alignment { get; set; }
Public Property Alignment As TextAlignment
    Get
    Set

Property Value

Type: TextAlignment
The horizontal alignment of the text to draw.
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat.Angle Property

TextFormatAngle Property

Gets or sets the angle in degrees of the text to draw.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle in degrees of the text to draw.
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat.CharacterWidth Property

TextFormatCharacterWidth Property

Gets or sets the width of the characters

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CharacterWidth { get; set; }
Public Property CharacterWidth As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat.InterCharacterSpace Property

TextFormatInterCharacterSpace Property

Gets or sets the number of additional pixels to add between characters.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InterCharacterSpace { get; set; }
Public Property InterCharacterSpace As Integer
    Get
    Set

Property Value

Type: Int32
The number of additional pixels to add between characters.
Remarks
This value may be negative to reduce the intercharacter spacing.
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat.ScaleToDpi Property

TextFormatScaleToDpi Property

Causes text to be drawn relative to the specified DPI.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi ScaleToDpi { get; set; }
Public Property ScaleToDpi As Dpi
    Get
    Set

Property Value

Type: Dpi
The DPI value to scale drawn text to.
Remarks

When drawing text on a canvas, the text will be drawn relative to the system's DPI by default. To draw text relative to the DPI of the canvas's target surface, set this property to the target surface's DPI.

The target surface DPI can be found in the Resolution property for AtalaImage sources, and can be created from the DpiX and DpiY properties of Graphics sources.

See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat Methods

The TextFormat type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


TextFormat.Clone Method

TextFormatClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.Imaging.Drawing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
See Also

Reference

TextFormat Class
Atalasoft.Imaging.Drawing Namespace


Atalasoft.Imaging.ImageProcessing Namespace

Classes
 | Class | Description
Public class | ApplyPaletteCommand | Summary description for ApplyPaletteCommand.
Public class | AutoConfigurableAttribute | When applied to a property in an ImageCommand, allows is to be an Auto Configurable.
Public class | AutoCropCommand | Automatically crops an image by removing borders around the edge of an image with a solid color.
Public class | ChangePixelFormatCommand | Changes the image to a new PixelFormat.
Public class | ColormatchedMask | This class is used to get a mask image matching a specified color or contiguous pixels at a specified point.
Public class | CropCommand | Creates a new image from a rectangular section in the source image.
Public class | Histogram | Summary description for Histogram.
Public class | ImageAnalyzerT | The ImageAnalyzer class is a generic class to perform analysis on an image reducing it to a single type.
Public class | ImageCommand | Represents the base class for all image processing routines that modify image data.
Public class | ImageRegionCommand | Derives from ImageCommand and adds region of interest capability to ImageCommands.
Public class | ImageResults | This class is used to contain information generated during the processing of an ImageCommand.
 | LosslessJpeg | Summary description for LosslessJpeg.
Public class | NoiseGenerator | Summary description for NoiseGenerator.
 | OverlayCommand | Summary description for tmpOverlay.
 | OverlayMaskedCommand | Overlay a specified image onto the source image using an 8-bit grayscale mask image to control the transparency of the overlay.
 | OverlayMergedCommand | Summary description for OverlayMergedCommand.
 | RegionOfInterest | This object can be passed into most ImageCommands to indicate a region of the image to process. Any shaped region can be used by specifying a Region object or a simple Rectangle.
Public class | ResampleColormappedToRgbCommand | Summary description for ResampleColormappedToRgbCommand.
Public class | ResampleCommand | Summary description for ResampleCommand.
Public class | ResampleMaskedCommand | Summary description for ResampleMaskedCommand.
Public class | ThreadedCommand | ThreadedCommand is a proxy command that will induce ImageCommands that support multithreading to run in on multiple threads.
Public class | Thumbnail | Summary description for Thumbnail.
Interfaces
 | Interface | Description
Public interface | IPropertiesAutoConfigurable | This interface when applied to an ImageCommand allowing the command to have properties that the algorithm will automatically determine based on image metrics.
Public interface | IThreadableCommand | This interface is applied to an ImageCommand to support parallelization.
Enumerations
 | Enumeration | Description
Public enumeration | AlphaMergeType | When images are combined, the alpha channels may be merged in one of many ways as listed in this enumeration.
Public enumeration | ChannelFlags | Bit flags used by some methods to specify which channels to work with.
Public enumeration | ColorMatchMode | Specifies the type of colormatching to use when using FloodFillCommand.
Public enumeration | DitheringMode | Specifies the dithering algorithm to use when converting an image to colormapped.
Public enumeration | InterpolationMode | Specifies the interpolation to use with various image processing commands.
Public enumeration | JpegTransformFlags |
Public enumeration | JpegTransformType |
Public enumeration | MergeOption | Image overlay merge options.
Public enumeration | NoiseGeneratorMode | Specifies the type of noise.
Public enumeration | ResampleMethod | Specifies the type of resampling method to apply when using the %ResampleCommand%, %ResampleColormappedToRgbCommand% or the %Atalasoft.Imaging.ImageProcessing.Document.ResampleDocumentCommand%.


AlphaMergeType Enumeration

When images are combined, the alpha channels may be merged in one of many ways as listed in this enumeration.
When images are combined, the alpha channels may be merged in one of many ways as listed in this enumeration.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AlphaMergeType
Public Enumeration AlphaMergeType
Members
Member name | Description
Replace | Replace the bottom alpha value with the top.
UseMostOpaque | Use the higher of the bottom and top values.
UseMostTransparent | Use the lower of the bottom and top values.
Add | Add the bottom and top values. The maximum value is 255.
Subtract | Subtract the top value from the bottom. The minimum value is 0.
LogicalAnd | Perform a bitwise logical AND on the bottom and top values.
LogicalOR | Perform a bitwise logical OR on the bottom and top values.
LogicalXOR | Perform a bitwise logical XOR on the bottom and top values.
UseOriginal | Ignore the top value.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Class

Summary description for ApplyPaletteCommand.
Maps an image into a specified palette, creating an 8-bit colormapped image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingApplyPaletteCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ApplyPaletteCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ApplyPaletteCommand
    Inherits ImageCommand
    Implements ISerializable

The ApplyPaletteCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ApplyPaletteCommand | Initializes a new instance of the ApplyPaletteCommand class.
Public method | ApplyPaletteCommand(Palette) | Initializes a new instance of ApplyPaletteCommand specifying the Palette.
Protected method | ApplyPaletteCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %ApplyPaletteCommand%.
Public method | ApplyPaletteCommand(Palette, DitheringMode) | Initializes a new instance of ApplyPaletteCommand specifying the Palette and dithering mode.
Public method | ApplyPaletteCommand(Palette, DitheringMode, Int32) | Initializes a new instance of ApplyPaletteCommand specifying the palette, dithering mode, and dither error.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DitherErrorMax | Gets or sets the amount of dithering to apply.
Public property | DitherMode | Gets or sets the value of ditherMode
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Palette | Gets or sets the value of palette
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
Remarks
This command uses various dithering algorithms to create a colormapped image that can very closely represent a full color image. A Palette containing up to 256 colors can be applied.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
Palette


ApplyPaletteCommand Constructor

Creates an ApplyPaletteCommand object used to modify an AtalaImage Palette.
Overload List
 | Name | Description
Public method | ApplyPaletteCommand | Initializes a new instance of the ApplyPaletteCommand class.
Public method | ApplyPaletteCommand(Palette) | Initializes a new instance of ApplyPaletteCommand specifying the Palette.
Protected method | ApplyPaletteCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %ApplyPaletteCommand%.
Public method | ApplyPaletteCommand(Palette, DitheringMode) | Initializes a new instance of ApplyPaletteCommand specifying the Palette and dithering mode.
Public method | ApplyPaletteCommand(Palette, DitheringMode, Int32) | Initializes a new instance of ApplyPaletteCommand specifying the palette, dithering mode, and dither error.
Top
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Constructor

Initializes a new instance of the ApplyPaletteCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyPaletteCommand()
Public Sub New
See Also

Reference

ApplyPaletteCommand Class
ApplyPaletteCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Constructor (Palette)

Initializes a new instance of ApplyPaletteCommand specifying the Palette.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyPaletteCommand(
    Palette palette
)
Public Sub New (
    palette As Palette
)

Parameters

palette
Type: Atalasoft.ImagingPalette

The Palette to map the image to.

See Also

Reference

ApplyPaletteCommand Class
ApplyPaletteCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of %ApplyPaletteCommand%.
Creates a new instance of ApplyPaletteCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ApplyPaletteCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ApplyPaletteCommand Class
ApplyPaletteCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Constructor (Palette, DitheringMode)

Initializes a new instance of ApplyPaletteCommand specifying the Palette and dithering mode.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyPaletteCommand(
    Palette palette,
    DitheringMode ditherMode
)
Public Sub New (
    palette As Palette,
    ditherMode As DitheringMode
)

Parameters

palette
Type: Atalasoft.ImagingPalette

The Palette to map the image to.

ditherMode
Type: Atalasoft.Imaging.ImageProcessingDitheringMode
The dithering mode to use when mapping the image to a palette.
See Also

Reference

ApplyPaletteCommand Class
ApplyPaletteCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Constructor (Palette, DitheringMode, Int32)

Initializes a new instance of ApplyPaletteCommand specifying the palette, dithering mode, and dither error.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyPaletteCommand(
    Palette palette,
    DitheringMode ditherMode,
    int ditherErrorMax
)
Public Sub New (
    palette As Palette,
    ditherMode As DitheringMode,
    ditherErrorMax As Integer
)

Parameters

palette
Type: Atalasoft.ImagingPalette

The palette to map the image to.

ditherMode
Type: Atalasoft.Imaging.ImageProcessingDitheringMode
The dithering mode to use when mapping the image to a palette.
ditherErrorMax
Type: SystemInt32
The amount of dithering. (0 - 127)
See Also

Reference

ApplyPaletteCommand Class
ApplyPaletteCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Properties

The ApplyPaletteCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DitherErrorMax | Gets or sets the amount of dithering to apply.
Public property | DitherMode | Gets or sets the value of ditherMode
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Palette | Gets or sets the value of palette
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.DitherErrorMax Property

ApplyPaletteCommandDitherErrorMax Property

Gets or sets the amount of dithering to apply.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DitherErrorMax { get; set; }
Public Property DitherErrorMax As Integer
    Get
    Set

Property Value

Type: Int32
The amount of dithering.
Exceptions
Exception | Condition
 | Thrown if the value is less than 0 or greater than 127.
Remarks

Valid values are between 0 and 127 with 0 being little to no dithering and 127 the full amount of possible dithering. Defaults to 127.

For converting a color or grayscale image to 1-bit black and white without dithering, see the SimpleThresholdCommand, GlobalThresholdCommand, and AdaptiveThresholdCommand.

See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.DitherMode Property

ApplyPaletteCommandDitherMode Property

Gets or sets the value of ditherMode

Gets or sets the dithering mode to use when mapping the image to a palette.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DitheringMode DitherMode { get; set; }
Public Property DitherMode As DitheringMode
    Get
    Set

Property Value

Type: DitheringMode
The type of dithering to apply.

Property Value

Type: DitheringMode
The dithering mode to use when mapping the image to a palette.
Remarks
Default value is DitheringMode.None.
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.Palette Property

ApplyPaletteCommandPalette Property

Gets or sets the value of palette

Gets or sets the Palette to map the image to.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Palette Palette { get; set; }
Public Property Palette As Palette
    Get
    Set

Property Value

Type: Palette
The palette to apply.

Property Value

Type: Palette
The Palette to map the image to.
Remarks
The palette must be set before invoking ApplyToImage.
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.SupportedPixelFormats Property

ApplyPaletteCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand Methods

The ApplyPaletteCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.ConstructFinalImage Method

ApplyPaletteCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.GetObjectData Method

ApplyPaletteCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.PerformActualCommand Method

ApplyPaletteCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.SelectPreferredPixelFormat Method

ApplyPaletteCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ApplyPaletteCommand.VerifyProperties Method

ApplyPaletteCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentNullException | Palette;The palette must be set before calling Apply.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ApplyPaletteCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoConfigurableAttribute Class

When applied to a property in an ImageCommand, allows is to be an Auto Configurable.
Inheritance Hierarchy
SystemObject
SystemAttribute
Atalasoft.Imaging.ImageProcessingAutoConfigurableAttribute

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class AutoConfigurableAttribute : Attribute
Public NotInheritable Class AutoConfigurableAttribute
    Inherits Attribute

The AutoConfigurableAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AutoConfigurableAttribute | Creates a new instance of AutoConfigurableAttribute specifying the bit value.
Top
Properties
 | Name | Description
Public property | BitValue | Gets the value to associate this property in unmanaged code.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GenerateCommandBitField | Generates a bit field from a command.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See IPropertiesAutoConfigurable for more information. This is intended to be for internal use only, and used primarily in Atalasoft.dotImage.AdvancedDocClean.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


AutoConfigurableAttribute Constructor

Creates a new instance of AutoConfigurableAttribute specifying the bit value.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoConfigurableAttribute(
    int bitValue
)
Public Sub New (
    bitValue As Integer
)

Parameters

bitValue
Type: SystemInt32
The value to associate with unmanaged code.
See Also

Reference

AutoConfigurableAttribute Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoConfigurableAttribute Properties

The AutoConfigurableAttribute type exposes the following members.

Properties
 | Name | Description
Public property | BitValue | Gets the value to associate this property in unmanaged code.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AutoConfigurableAttribute Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoConfigurableAttribute.BitValue Property

AutoConfigurableAttributeBitValue Property

Gets the value to associate this property in unmanaged code.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BitValue { get; }
Public ReadOnly Property BitValue As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AutoConfigurableAttribute Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoConfigurableAttribute Methods

The AutoConfigurableAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | GenerateCommandBitField | Generates a bit field from a command.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutoConfigurableAttribute Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoConfigurableAttribute.GenerateCommandBitField Method

AutoConfigurableAttributeGenerateCommandBitField Method

Generates a bit field from a command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GenerateCommandBitField(
    ImageCommand command
)
Public Shared Function GenerateCommandBitField (
    command As ImageCommand
) As Integer

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The command.

Return Value

Type: Int32
See Also

Reference

AutoConfigurableAttribute Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Class

Automatically crops an image by removing borders around the edge of an image with a solid color.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingAutoCropCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoCropCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class AutoCropCommand
    Inherits ImageCommand
    Implements ISerializable

The AutoCropCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCropCommand | Creates a new instance of AutoCropCommand.
Public method | AutoCropCommand(Double) | Initializes a new instance of AutoCropCommand specifying a tolerance.
Public method | AutoCropCommand(Double, Color) | Initializes a new instance of AutoCropCommand specifying a tolerance and override color.
Public method | AutoCropCommand(Double, Int32) | Initializes a new instance of AutoCropCommand specifying a tolerance and override index.
Protected method | AutoCropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of AutoCropCommand with 0 tolerance.
Public method | AutoCropCommand(Double, Color, Boolean) | Initializes a new instance of AutoCropCommand specifying a tolerance, override color, and if uses median filter.
Public method | AutoCropCommand(Double, Int32, Boolean) | Initializes a new instance of AutoCropCommand specifying a tolerance, override index, and if uses median filter.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | OverrideColor | Gets or sets a specific color to represent the image 'whitespace'.
Public property | OverrideIndex | Gets or sets a palette index value containing the color to represent image 'whitespace'.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the percentage tolerance used to locate the edges, from 0 to 100.
Public property | UseMedianFilter | Gets or sets a value indicating if the noise is removed prior to getting the crop dimensions.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder | Returns a Rectangle of the border to remove.
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor

Creates an AutoCropCommand object used to remove extra spacing around an image.
Overload List
 | Name | Description
Public method | AutoCropCommand | Creates a new instance of AutoCropCommand.
Public method | AutoCropCommand(Double) | Initializes a new instance of AutoCropCommand specifying a tolerance.
Public method | AutoCropCommand(Double, Color) | Initializes a new instance of AutoCropCommand specifying a tolerance and override color.
Public method | AutoCropCommand(Double, Int32) | Initializes a new instance of AutoCropCommand specifying a tolerance and override index.
Protected method | AutoCropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of AutoCropCommand with 0 tolerance.
Public method | AutoCropCommand(Double, Color, Boolean) | Initializes a new instance of AutoCropCommand specifying a tolerance, override color, and if uses median filter.
Public method | AutoCropCommand(Double, Int32, Boolean) | Initializes a new instance of AutoCropCommand specifying a tolerance, override index, and if uses median filter.
Top
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor

Creates a new instance of AutoCropCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoCropCommand()
Public Sub New
See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor (Double)

Initializes a new instance of AutoCropCommand specifying a tolerance.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoCropCommand(
    double tolerance
)
Public Sub New (
    tolerance As Double
)

Parameters

tolerance
Type: SystemDouble

The tolerance used to locate the edges. (0 - 100)

See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor (Double, Color)

Initializes a new instance of AutoCropCommand specifying a tolerance and override color.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoCropCommand(
    double tolerance,
    Color overrideColor
)
Public Sub New (
    tolerance As Double,
    overrideColor As Color
)

Parameters

tolerance
Type: SystemDouble

The tolerance used to locate the edges. (0 - 100)

overrideColor
Type: System.DrawingColor

A specific color to represent the image 'whitespace'.

See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor (Double, Int32)

Initializes a new instance of AutoCropCommand specifying a tolerance and override index.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoCropCommand(
    double tolerance,
    int overrideIndex
)
Public Sub New (
    tolerance As Double,
    overrideIndex As Integer
)

Parameters

tolerance
Type: SystemDouble

The tolerance used to locate the edges. (0 - 100)

overrideIndex
Type: SystemInt32

A palette index value containing the color to represent image 'whitespace'.

See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of AutoCropCommand with 0 tolerance.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoCropCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor (Double, Color, Boolean)

Initializes a new instance of AutoCropCommand specifying a tolerance, override color, and if uses median filter.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoCropCommand(
    double tolerance,
    Color overrideColor,
    bool useMedianFilter
)
Public Sub New (
    tolerance As Double,
    overrideColor As Color,
    useMedianFilter As Boolean
)

Parameters

tolerance
Type: SystemDouble

The tolerance used to locate the edges. (0 - 100)

overrideColor
Type: System.DrawingColor

A specific color to represent the image 'whitespace'.

useMedianFilter
Type: SystemBoolean
If true, removed noise from the image prior to getting crop dimensions.
See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Constructor (Double, Int32, Boolean)

Initializes a new instance of AutoCropCommand specifying a tolerance, override index, and if uses median filter.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoCropCommand(
    double tolerance,
    int overrideIndex,
    bool useMedianFilter
)
Public Sub New (
    tolerance As Double,
    overrideIndex As Integer,
    useMedianFilter As Boolean
)

Parameters

tolerance
Type: SystemDouble

The tolerance used to locate the edges. (0 - 100)

overrideIndex
Type: SystemInt32

A specific color to represent the image 'whitespace'.

useMedianFilter
Type: SystemBoolean
If true, removed noise from the image prior to getting crop dimensions.
See Also

Reference

AutoCropCommand Class
AutoCropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Properties

The AutoCropCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | OverrideColor | Gets or sets a specific color to represent the image 'whitespace'.
Public property | OverrideIndex | Gets or sets a palette index value containing the color to represent image 'whitespace'.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the percentage tolerance used to locate the edges, from 0 to 100.
Public property | UseMedianFilter | Gets or sets a value indicating if the noise is removed prior to getting the crop dimensions.
Top
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.OverrideColor Property

AutoCropCommandOverrideColor Property

Gets or sets a specific color to represent the image 'whitespace'.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OverrideColor { get; set; }
Public Property OverrideColor As Color
    Get
    Set

Property Value

Type: Color

A specific color to represent the image 'whitespace'.

Remarks
Default value is Color.Empty.
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.OverrideIndex Property

AutoCropCommandOverrideIndex Property

Gets or sets a palette index value containing the color to represent image 'whitespace'.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int OverrideIndex { get; set; }
Public Property OverrideIndex As Integer
    Get
    Set

Property Value

Type: Int32

A palette index value containing the color to represent image 'whitespace'.

Exceptions
Exception | Condition
 | Thrown when the value is less than -1 or greater than 255.
Remarks
Default value is -1. A value greater than -1 will override the OverrideColor property.
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.SupportedPixelFormats Property

AutoCropCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.Tolerance Property

AutoCropCommandTolerance Property

Gets or sets the percentage tolerance used to locate the edges, from 0 to 100.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set

Property Value

Type: Double

The tolerance used to locate the edges.

Exceptions
Exception | Condition
 | Thrown when the value is less than 0 or greater than 100.
Remarks
Default value is 0.
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.UseMedianFilter Property

AutoCropCommandUseMedianFilter Property

Gets or sets a value indicating if the noise is removed prior to getting the crop dimensions.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseMedianFilter { get; set; }
Public Property UseMedianFilter As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the noise is removed prior to getting the crop dimensions.
Remarks
Default value is false.
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand Methods

The AutoCropCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder | Returns a Rectangle of the border to remove.
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.ConstructFinalImage Method

AutoCropCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.GetBorder Method

AutoCropCommandGetBorder Method

Returns a Rectangle of the border to remove.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle GetBorder(
    AtalaImage sourceImage
)
Public Function GetBorder (
    sourceImage As AtalaImage
) As Rectangle

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The AtalaImage that will be evaluated.

Return Value

Type: Rectangle
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.GetObjectData Method

AutoCropCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.PerformActualCommand Method

AutoCropCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.SelectPreferredPixelFormat Method

AutoCropCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


AutoCropCommand.VerifyProperties Method

AutoCropCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AutoCropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Class

Changes the image to a new PixelFormat.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingChangePixelFormatCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ChangePixelFormatCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ChangePixelFormatCommand
    Inherits ImageCommand
    Implements ISerializable

The ChangePixelFormatCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ChangePixelFormatCommand | Initializes a new instance of the ChangePixelFormatCommand class.
Public method | ChangePixelFormatCommand(PixelFormat) | Initializes a new instance of ChangePixelFormatCommand specifying the new pixel format.
Protected method | ChangePixelFormatCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ChangePixelFormatCommand.
Public method | ChangePixelFormatCommand(PixelFormat, ColorProfile) | Initializes a new instance of ChangePixelFormatCommand specifying the new pixel format and color profile.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestProfile | Gets or sets the color profile to use when converting the image to a new colorspace.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | NewPixelFormat | Gets or sets the PixelFormat of the new image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This is equivalent to the GetChangedPixelFormat(PixelFormat) in the AtalaImage class, but in a Command form. Using this command will not raise the ChangePixelFormat event.

See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
GetChangedPixelFormat Method


ChangePixelFormatCommand Constructor

Creates a ChangePixelFormatCommand object used to change the current pixel format of an image to a different format.
Overload List
 | Name | Description
Public method | ChangePixelFormatCommand | Initializes a new instance of the ChangePixelFormatCommand class.
Public method | ChangePixelFormatCommand(PixelFormat) | Initializes a new instance of ChangePixelFormatCommand specifying the new pixel format.
Protected method | ChangePixelFormatCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ChangePixelFormatCommand.
Public method | ChangePixelFormatCommand(PixelFormat, ColorProfile) | Initializes a new instance of ChangePixelFormatCommand specifying the new pixel format and color profile.
Top
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Constructor

Initializes a new instance of the ChangePixelFormatCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChangePixelFormatCommand()
Public Sub New
See Also

Reference

ChangePixelFormatCommand Class
ChangePixelFormatCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Constructor (PixelFormat)

Initializes a new instance of ChangePixelFormatCommand specifying the new pixel format.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChangePixelFormatCommand(
    PixelFormat newPixelFormat
)
Public Sub New (
    newPixelFormat As PixelFormat
)

Parameters

newPixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat of the new image.
See Also

Reference

ChangePixelFormatCommand Class
ChangePixelFormatCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of ChangePixelFormatCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ChangePixelFormatCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ChangePixelFormatCommand Class
ChangePixelFormatCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Constructor (PixelFormat, ColorProfile)

Initializes a new instance of ChangePixelFormatCommand specifying the new pixel format and color profile.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChangePixelFormatCommand(
    PixelFormat newPixelFormat,
    ColorProfile destProfile
)
Public Sub New (
    newPixelFormat As PixelFormat,
    destProfile As ColorProfile
)

Parameters

newPixelFormat
Type: Atalasoft.ImagingPixelFormat
The PixelFormat of the new image.
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile
This is the destination colorprofile to use when changing colorspaces.
See Also

Reference

ChangePixelFormatCommand Class
ChangePixelFormatCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Properties

The ChangePixelFormatCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestProfile | Gets or sets the color profile to use when converting the image to a new colorspace.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | NewPixelFormat | Gets or sets the PixelFormat of the new image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.DestProfile Property

ChangePixelFormatCommandDestProfile Property

Gets or sets the color profile to use when converting the image to a new colorspace.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile DestProfile { get; set; }
Public Property DestProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
The color profile to use when converting the image to a new colorspace.
Remarks
This profile will be used as the destination device. By default the screen profile will be used. If specifying a CMYK image, a CMYK profile should be set.
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.NewPixelFormat Property

ChangePixelFormatCommandNewPixelFormat Property

Gets or sets the PixelFormat of the new image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormat NewPixelFormat { get; set; }
Public Property NewPixelFormat As PixelFormat
    Get
    Set

Property Value

Type: PixelFormat
The PixelFormat of the new image.
Remarks
If the source and destination pixel formats are equal, ApplyToImage will return null.
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.SupportedPixelFormats Property

ChangePixelFormatCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand Methods

The ChangePixelFormatCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.ConstructFinalImage Method

ChangePixelFormatCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.GetObjectData Method

ChangePixelFormatCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | ChangePixelFormatCommand does not support serialization
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.PerformActualCommand Method

ChangePixelFormatCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChangePixelFormatCommand.VerifyProperties Method

ChangePixelFormatCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
IncompatiblePixelFormatException | Source and destination pixel formats cannot be equal
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ChangePixelFormatCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ChannelFlags Enumeration

Bit flags used by some methods to specify which channels to work with.
Bit flags used by some methods to specify which channels to work with.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum ChannelFlags
<FlagsAttribute>
Public Enumeration ChannelFlags
Members
Member name | Description
Channel1 | The first channel in the image. For a RGB or RGBA image this is the Blue color channel.
Channel2 | The second channel in the image. For a RGB or RGBA image this is the Green color channel.
Channel3 | The third channel in the image. For a RGB or RGBA image this is the Red color channel.
Channel4 | The fourth channel in the image. For a RGBA image this is the Alpha channel.
AllChannels | Specifies all channels in the image (Channel1 | Channel2 | Channel3 | Channel4).
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask Class

This class is used to get a mask image matching a specified color or contiguous pixels at a specified point.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingColormatchedMask

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ColormatchedMask
Public Class ColormatchedMask

The ColormatchedMask type exposes the following members.

Constructors
 | Name | Description
Public method | ColormatchedMask(AtalaImage) | Initializes a new instance of ColormatchedMask.
Public method | ColormatchedMask(AtalaImage, ProgressEventHandler) | Initializes a new instance of %ColormatchedMask% specifying the AtalaImage to evaluate and a progress callback.
Top
Properties
 | Name | Description
Public property | Image | Gets or sets the AtalaImage to apply the colormatching to.
Public property | Progress | Gets or sets the progress callback.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEdgeColorMatchedMask | Mask area is bounded by pixels matching the edgeColor parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSurfaceColorMatchedMask | All contiguous pixels matching the pixel at the center point are returned as on in resulting mask.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class can be used for a "magic wand" tool.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask Constructor

Creates a ColormatchedMask object.
Overload List
 | Name | Description
Public method | ColormatchedMask(AtalaImage) | Initializes a new instance of ColormatchedMask.
Public method | ColormatchedMask(AtalaImage, ProgressEventHandler) | Initializes a new instance of %ColormatchedMask% specifying the AtalaImage to evaluate and a progress callback.
Top
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask Constructor (AtalaImage)

Initializes a new instance of ColormatchedMask.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColormatchedMask(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to return apply the colormatching to.
See Also

Reference

ColormatchedMask Class
ColormatchedMask Overload
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask Constructor (AtalaImage, ProgressEventHandler)

Initializes a new instance of %ColormatchedMask% specifying the AtalaImage to evaluate and a progress callback.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColormatchedMask(
    AtalaImage image,
    ProgressEventHandler progress
)
Public Sub New (
    image As AtalaImage,
    progress As ProgressEventHandler
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to return apply the colormatching to.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress callback.
See Also

Reference

ColormatchedMask Class
ColormatchedMask Overload
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask Properties

The ColormatchedMask type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets or sets the AtalaImage to apply the colormatching to.
Public property | Progress | Gets or sets the progress callback.
Top
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask.Image Property

ColormatchedMaskImage Property

Gets or sets the AtalaImage to apply the colormatching to.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage to return apply the colormatching to.
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask.Progress Property

ColormatchedMaskProgress Property

Gets or sets the progress callback.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventHandler Progress { get; set; }
Public Property Progress As ProgressEventHandler
    Get
    Set

Property Value

Type: ProgressEventHandler
The progress callback.
Remarks
Defaults value is null.
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask Methods

The ColormatchedMask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEdgeColorMatchedMask | Mask area is bounded by pixels matching the edgeColor parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSurfaceColorMatchedMask | All contiguous pixels matching the pixel at the center point are returned as on in resulting mask.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask.GetEdgeColorMatchedMask Method

ColormatchedMaskGetEdgeColorMatchedMask Method

Mask area is bounded by pixels matching the edgeColor parameter.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetEdgeColorMatchedMask(
    Point center,
    Color edgeColor,
    double tolerance
)
Public Function GetEdgeColorMatchedMask (
    center As Point,
    edgeColor As Color,
    tolerance As Double
) As AtalaImage

Parameters

center
Type: System.DrawingPoint
The point to begin the colormatch.
edgeColor
Type: System.DrawingColor
The color of the edge to find.
tolerance
Type: SystemDouble
The tolerance (0 - 100)

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
 | Thrown if tolerance is less than 0 or greater than 100.
 | Thrown if the center point if outside the image boundary.
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColormatchedMask.GetSurfaceColorMatchedMask Method

ColormatchedMaskGetSurfaceColorMatchedMask Method

All contiguous pixels matching the pixel at the center point are returned as on in resulting mask.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetSurfaceColorMatchedMask(
    Point center,
    double tolerance
)
Public Function GetSurfaceColorMatchedMask (
    center As Point,
    tolerance As Double
) As AtalaImage

Parameters

center
Type: System.DrawingPoint
The point to begin the colormatch.
tolerance
Type: SystemDouble
The tolerance (0 - 100)

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
 | Thrown if tolerance is less than 0 or greater than 100.
 | Thrown if the center point if outside the image boundary.
See Also

Reference

ColormatchedMask Class
Atalasoft.Imaging.ImageProcessing Namespace


ColorMatchMode Enumeration

Specifies the type of colormatching to use when using FloodFillCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ColorMatchMode
Public Enumeration ColorMatchMode
Members
Member name | Description
Edge | Indicates that the colormatching will occur up to a border of the specified color.
Surface | Indicates that the colormatching will occur with all contingous pixels from the starting point.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Class

Creates a new image from a rectangular section in the source image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingCropCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CropCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class CropCommand
    Inherits ImageCommand
    Implements ISerializable

The CropCommand type exposes the following members.

Constructors
 | Name | Description
Public method | CropCommand | Initializes a new instance of the CropCommand class.
Public method | CropCommand(Rectangle) | Creates a new instance of CropCommand specifying the crop rectangle.
Protected method | CropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of CropCommand specifying the crop rectangle.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CropRect | Gets or sets the rectangular portion of the source image to copy into a new image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | PerformActualCommand4Bit | Performs the actual command4 bit.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command is equivalent to overlaying the original image onto a new image at the size and position of the crop rectangle.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Constructor

Overload List
 | Name | Description
Public method | CropCommand | Initializes a new instance of the CropCommand class.
Public method | CropCommand(Rectangle) | Creates a new instance of CropCommand specifying the crop rectangle.
Protected method | CropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of CropCommand specifying the crop rectangle.
Top
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Constructor

Initializes a new instance of the CropCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CropCommand()
Public Sub New
See Also

Reference

CropCommand Class
CropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Constructor (Rectangle)

Creates a new instance of CropCommand specifying the crop rectangle.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CropCommand(
    Rectangle cropRect
)
Public Sub New (
    cropRect As Rectangle
)

Parameters

cropRect
Type: System.DrawingRectangle
The rectangular portion of the source image to copy into a new image.
See Also

Reference

CropCommand Class
CropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of CropCommand specifying the crop rectangle.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CropCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

CropCommand Class
CropCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Properties

The CropCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CropRect | Gets or sets the rectangular portion of the source image to copy into a new image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.CropRect Property

CropCommandCropRect Property

Gets or sets the rectangular portion of the source image to copy into a new image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle CropRect { get; set; }
Public Property CropRect As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular portion of the source image to copy into a new image.
Exceptions
Exception | Condition
 | Thrown if the width or height of the crop rectangle is less than or equal to 0.
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.SupportedPixelFormats Property

CropCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand Methods

The CropCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | PerformActualCommand4Bit | Performs the actual command4 bit.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.ConstructFinalImage Method

CropCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.GetObjectData Method

CropCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.PerformActualCommand Method

CropCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.PerformActualCommand4Bit Method

CropCommandPerformActualCommand4Bit Method

Performs the actual command4 bit.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool PerformActualCommand4Bit(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Function PerformActualCommand4Bit (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As Boolean

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: Boolean
See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


CropCommand.VerifyProperties Method

CropCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | CropRect;The left position cannot be greater than or equal to the image width. or CropRect;The top position cannot be greater than or equal to the image height.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

CropCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


DitheringMode Enumeration

Specifies the dithering algorithm to use when converting an image to colormapped.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DitheringMode
Public Enumeration DitheringMode
Members
Member name | Description
None | Specifies a best fit method with no dithering.
TwoValue | Specifies a simple 2-value style of dithering.
FloydSteinberg | Specifies Floyd-Steinberg dithering. This method of dithering uses error diffusion and produces the best dithered image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


Histogram Class

Summary description for Histogram.

This command is used to represent the number of unique color channel values or brightness values be returning an array containing the number of pixels at the value signified by the array index.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingHistogram

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Histogram
Public Class Histogram

The Histogram type exposes the following members.

Constructors
 | Name | Description
Public method | Histogram(AtalaImage) | Initializes a new instance of the Histogram object.
Public method | Histogram(AtalaImage, ProgressEventHandler) | Initializes a new instance of the Histogram object.
Public method | Histogram(AtalaImage, Rectangle) | Creates a new instance of Histogram specifying the image to examine and a specific rectangular area of the image to work with.
Public method | Histogram(AtalaImage, Rectangle, ProgressEventHandler) | Creates an instance of Histogram specifying the image to examine, a selection of the image to work with and the progress event handler.
Top
Properties
 | Name | Description
Public property | Area | Gets or sets a rectangular area of the image the histogram methods will work with.
Public property | Image | Gets or sets the image to evaluate.
Public property | Progress | Gets or sets the progress delegate.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrightnessHistogram | Returns an array containing a histogram of brightness values in the image.
Public method | GetChannelHistogram | Returns an array containing a histogram of color values from a particular channel in the image.
Public method | GetDocumentHistogram | Returns a two element array containing the number of black and white pixels in a binary image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
For 8-bit per component images, the array contains 256 values. 16-bit per component images returns an array of 65536 values.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


Histogram Constructor

Creates a Histogram object used to get brightness and channel histogram information from an AtalaImage.
Overload List
 | Name | Description
Public method | Histogram(AtalaImage) | Initializes a new instance of the Histogram object.
Public method | Histogram(AtalaImage, ProgressEventHandler) | Initializes a new instance of the Histogram object.
Public method | Histogram(AtalaImage, Rectangle) | Creates a new instance of Histogram specifying the image to examine and a specific rectangular area of the image to work with.
Public method | Histogram(AtalaImage, Rectangle, ProgressEventHandler) | Creates an instance of Histogram specifying the image to examine, a selection of the image to work with and the progress event handler.
Top
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram Constructor (AtalaImage)

Initializes a new instance of the Histogram object.
Initializes a new instance of the Histogram object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Histogram(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to evaluate.
See Also

Reference

Histogram Class
Histogram Overload
Atalasoft.Imaging.ImageProcessing Namespace


Histogram Constructor (AtalaImage, ProgressEventHandler)

Initializes a new instance of the Histogram object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Histogram(
    AtalaImage image,
    ProgressEventHandler progress
)
Public Sub New (
    image As AtalaImage,
    progress As ProgressEventHandler
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to evaluate.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress callback.
See Also

Reference

Histogram Class
Histogram Overload
Atalasoft.Imaging.ImageProcessing Namespace


Histogram Constructor (AtalaImage, Rectangle)

Creates a new instance of Histogram specifying the image to examine and a specific rectangular area of the image to work with.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Histogram(
    AtalaImage image,
    Rectangle area
)
Public Sub New (
    image As AtalaImage,
    area As Rectangle
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to examine.
area
Type: System.DrawingRectangle
A rectangular area of the image to work with.
See Also

Reference

Histogram Class
Histogram Overload
Atalasoft.Imaging.ImageProcessing Namespace


Histogram Constructor (AtalaImage, Rectangle, ProgressEventHandler)

Creates an instance of Histogram specifying the image to examine, a selection of the image to work with and the progress event handler.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Histogram(
    AtalaImage image,
    Rectangle area,
    ProgressEventHandler progress
)
Public Sub New (
    image As AtalaImage,
    area As Rectangle,
    progress As ProgressEventHandler
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to examine.
area
Type: System.DrawingRectangle
A rectangular area of the image to work with.
progress
Type: Atalasoft.ImagingProgressEventHandler
The progress callback.
See Also

Reference

Histogram Class
Histogram Overload
Atalasoft.Imaging.ImageProcessing Namespace


Histogram Properties

The Histogram type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets or sets a rectangular area of the image the histogram methods will work with.
Public property | Image | Gets or sets the image to evaluate.
Public property | Progress | Gets or sets the progress delegate.
Top
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram.Area Property

HistogramArea Property

Gets or sets a rectangular area of the image the histogram methods will work with.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Area { get; set; }
Public Property Area As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle specifying the area of the image to work with.
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram.Image Property

HistogramImage Property

Gets or sets the image to evaluate.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image to evaluate.
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram.Progress Property

HistogramProgress Property

Gets or sets the progress delegate.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventHandler Progress { get; set; }
Public Property Progress As ProgressEventHandler
    Get
    Set

Property Value

Type: ProgressEventHandler
The progress delegate.
Remarks
Can be null (Nothing in Visual Basic).
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram Methods

The Histogram type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrightnessHistogram | Returns an array containing a histogram of brightness values in the image.
Public method | GetChannelHistogram | Returns an array containing a histogram of color values from a particular channel in the image.
Public method | GetDocumentHistogram | Returns a two element array containing the number of black and white pixels in a binary image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram.GetBrightnessHistogram Method

HistogramGetBrightnessHistogram Method

Returns an array containing a histogram of brightness values in the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetBrightnessHistogram()
Public Function GetBrightnessHistogram As Integer()

Return Value

Type: Int32
An array containing a histogram of brightness values in the image.
Exceptions
Exception | Condition
 | Thrown if the Image property is null.
 | Thrown if the pixel format is colormapped, or CMYK.
Remarks
Returns the gray channel with grayscale images.
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram.GetChannelHistogram Method

HistogramGetChannelHistogram Method

Returns an array containing a histogram of color values from a particular channel in the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetChannelHistogram(
    int channelIndex
)
Public Function GetChannelHistogram (
    channelIndex As Integer
) As Integer()

Parameters

channelIndex
Type: SystemInt32
The zero based channel index to evaluate. (0 - 3)

Return Value

Type: Int32
An array containing a histogram of color values from a particular channel in the image.
Exceptions
Exception | Condition
 | Thrown if the pixel format of the source image is colormapped.
 | Thrown if the Image property is null.
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


Histogram.GetDocumentHistogram Method

HistogramGetDocumentHistogram Method

Returns a two element array containing the number of black and white pixels in a binary image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetDocumentHistogram()
Public Function GetDocumentHistogram As Integer()

Return Value

Type: Int32
An array containing the number of black and white pixels in a binary image.
Exceptions
Exception | Condition
 | Thrown if the image pixelformat is other than Pixel1bppIndexed.
 | Thrown if the image is null.
 | Thrown is the current license is not DotImage Document Imaging.
Remarks
In a typical binary image, the first pixel value is white, and second is black (known as MinIsWhite). Occassionally this is swapped. Check the palette index color value to be certain.
See Also

Reference

Histogram Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T) Class

ImageAnalyzerT Class

The ImageAnalyzer class is a generic class to perform analysis on an image reducing it to a single type.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageAnalyzerT

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ImageAnalyzer<T>

Public MustInherit Class ImageAnalyzer(Of T)

Type Parameters

T
The type of the analysis.

The ImageAnalyzerT type exposes the following members.

Constructors
 | Name | Description
Protected method | ImageAnalyzerT | Initializes a new instance of the ImageAnalyzerT class
Top
Properties
 | Name | Description
Public property | Progress | Gets or sets the progress event handler.
Public property | SupportedPixelFormats | Gets the supported pixel formats.
Top
Methods
 | Name | Description
Public method | Analyze | Analyzes the specified image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Determines whether the pixel format is supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualAnalysis | Performs the actual analysis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T) Constructor

ImageAnalyzerT Constructor

Initializes a new instance of the ImageAnalyzerT class

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageAnalyzer()
Protected Sub New
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T) Properties

ImageAnalyzerT Properties

The ImageAnalyzerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Progress | Gets or sets the progress event handler.
Public property | SupportedPixelFormats | Gets the supported pixel formats.
Top
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T).Progress Property

ImageAnalyzerTProgress Property

Gets or sets the progress event handler.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventHandler Progress { get; set; }
Public Property Progress As ProgressEventHandler
    Get
    Set

Property Value

Type: ProgressEventHandler
The progress event handler.
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T).SupportedPixelFormats Property

ImageAnalyzerTSupportedPixelFormats Property

Gets the supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract PixelFormat[] SupportedPixelFormats { get; }
Public MustOverride ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
The supported pixel formats.
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T) Methods

ImageAnalyzerT Methods

The ImageAnalyzerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Analyze | Analyzes the specified image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPixelFormatSupported | Determines whether the pixel format is supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualAnalysis | Performs the actual analysis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T).Analyze Method

ImageAnalyzerTAnalyze Method

Analyzes the specified image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Analyze(
    AtalaImage image
)
Public Function Analyze (
    image As AtalaImage
) As T

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: T
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T).IsPixelFormatSupported Method

ImageAnalyzerTIsPixelFormatSupported Method

Determines whether the pixel format is supported.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsPixelFormatSupported(
    PixelFormat format
)
Public Overridable Function IsPixelFormatSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat
The format.

Return Value

Type: Boolean
true if the PixelFormat is supported, false otherwise.
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageAnalyzer(T).PerformActualAnalysis Method

ImageAnalyzerTPerformActualAnalysis Method

Performs the actual analysis.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract T PerformActualAnalysis(
    AtalaImage image
)
Protected MustOverride Function PerformActualAnalysis (
    image As AtalaImage
) As T

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.

Return Value

Type: T
The value of the analysis
See Also

Reference

ImageAnalyzerT Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand Class

Represents the base class for all image processing routines that modify image data.
Represents the base class for all image processing routines that modify image data.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
More...

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ImageCommand
Public MustInherit Class ImageCommand

The ImageCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCommand | Initializes a new instance of the ImageCommand class.
Protected method | ImageCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageCommand class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat.
 | GlobalAutoThread | Determines if all ImageCommands that support multithreaded processing will be multithreaded.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats.
Top
Methods
 | Name | Description
 | AllocatePixelFormatArray | Allocate an array of PixelFormat enums.
Public method | Apply | Apply the command to the given image.
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.
Protected method | ConstructImageResults | Constructs the results object for this command.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image.
 | GetContinuousFormatImage | A utility method for determining the best matching continuous tone pixel format and converting the given image to that format.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command.
 | ProxyConstructChangedSourceImage | Calls the ConstructChangedSourceImage method on the supplied ImageCommand.
 | ProxyConstructFinalImage |
 | ProxyConstructImageResults |
 | ProxyGetChangedPixelFormat |
 | ProxySelectBestAlternatePixelFormat |
 | ProxySelectPreferredPixelFormat |
 | ProxyVerifyProperties |
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable.
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage.
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image.
Top
Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand method in the Workspace.

See Extending ImageCommands for more information on creating custom commands.

Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand(ImageCommand) method in the Workspace.

See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
Extending ImageCommands
Extending ImageCommands
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingApplyPaletteCommand
Atalasoft.Imaging.ImageProcessingAutoCropCommand
Atalasoft.Imaging.ImageProcessingChangePixelFormatCommand
Atalasoft.Imaging.ImageProcessing.ChannelsFlattenAlphaCommand
Atalasoft.Imaging.ImageProcessing.ChannelsReplaceChannelCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSetAlphaColorCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSetAlphaFromMaskCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSetAlphaValueCommand
Atalasoft.Imaging.ImageProcessingCropCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoBorderCropCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoDeskewCommand
Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalCommand
Atalasoft.Imaging.ImageProcessing.DocumentDitherCommand
Atalasoft.Imaging.ImageProcessing.DocumentMarginCropCommand
Atalasoft.Imaging.ImageProcessing.DocumentOverlayMaskedDocumentCommand
Atalasoft.Imaging.ImageProcessing.DocumentResampleDocumentCommand
Atalasoft.Imaging.ImageProcessing.EffectsBevelEdgeCommand
Atalasoft.Imaging.ImageProcessing.EffectsDropShadowCommand
Atalasoft.Imaging.ImageProcessing.EffectsNDGradFilterCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorMagicCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorMultiplyCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoPortraitCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoShadowBoostCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoSkinTonesCommand
Atalasoft.Imaging.ImageProcessing.EffectsReduceColorsCommand
Atalasoft.Imaging.ImageProcessing.EffectsRoundedBevelCommand
Atalasoft.Imaging.ImageProcessing.EffectsScribbleCommand
Atalasoft.Imaging.ImageProcessing.EffectsTintGrayscaleCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FiltersColorizeCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessingOverlayCommand
Atalasoft.Imaging.ImageProcessingOverlayMaskedCommand
Atalasoft.Imaging.ImageProcessingOverlayMergedCommand
Atalasoft.Imaging.ImageProcessingResampleColormappedToRgbCommand
Atalasoft.Imaging.ImageProcessingResampleCommand
Atalasoft.Imaging.ImageProcessingResampleMaskedCommand
Atalasoft.Imaging.ImageProcessingThreadedCommand
Atalasoft.Imaging.ImageProcessing.TransformsFlipCommand
Atalasoft.Imaging.ImageProcessing.TransformsPushCommand
Atalasoft.Imaging.ImageProcessing.TransformsQuadrilateralWarpCommand
Atalasoft.Imaging.ImageProcessing.TransformsResizeCanvasCommand
Atalasoft.Imaging.ImageProcessing.TransformsRotateCommand
Atalasoft.Imaging.ImageProcessing.TransformsSkewCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsTransformChainCommand


ImageCommand Constructor

Overload List
 | Name | Description
Public method | ImageCommand | Initializes a new instance of the ImageCommand class.
Protected method | ImageCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageCommand class.
Top
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand Constructor

Initializes a new instance of the ImageCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCommand()
Public Sub New
See Also

Reference

ImageCommand Class
ImageCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ImageCommand Class
ImageCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand Properties

The ImageCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat.
 | GlobalAutoThread | Determines if all ImageCommands that support multithreaded processing will be multithreaded.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats.
Top
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ApplyToAnyPixelFormat Property

ImageCommandApplyToAnyPixelFormat Property

Reports whether or not this command will be applied to any supplied PixelFormat image

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool ApplyToAnyPixelFormat { get; set; }
Public Overridable Property ApplyToAnyPixelFormat As Boolean
    Get
    Set

Property Value

Type: Boolean
When set to true, the command will perform automatic PixelFormat conversion of the source image to a PixelFormat suitable for the command. By default this property is set to false.
Remarks

Note that not all commands will support this property. If a command returns true in the property CanApplyToAnyPixelFormat, then ApplyToAnyPixelFormat can be either true or false.

If a command reports false in the property CanApplyToAnyPixelFormat, then ApplyToAnyPixelFormat can only be false and will throw a NotSupportedException if set to true.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.CanApplyToAnyPixelFormat Property

ImageCommandCanApplyToAnyPixelFormat Property

Returns true if the command can be applied to any PixelFormat.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool CanApplyToAnyPixelFormat { get; }
Public Overridable ReadOnly Property CanApplyToAnyPixelFormat As Boolean
    Get

Property Value

Type: Boolean
A boolean representing if this command can be applied to any PixelFormat.
Remarks

Many commands have the ability to take advantage of automatic PixelFormat conversion so that they can operate on all the PixelFormats instead of a select few. This capability comes at the cost of time and memory.

If CanApplyToAnyPixelFormat is true, then it is possible to set the property ApplyToAnyPixelFormat to true, to cause automatic conversion. If CanApplyToAnyPixelFormat is false, then it is incorrect to set ApplyToAnyPixelFormat to true.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.GlobalAutoThread Property

ImageCommandGlobalAutoThread Property

Determines if all ImageCommands that support multithreaded processing will be multithreaded.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool GlobalAutoThread { get; set; }
Public Shared Property GlobalAutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns true if ImageCommands that support multithreaded processing will be multithreaded. Default value is false.
Remarks
Many ImageCommands can be run in a multithreaded manner that will improve the performance of the command without affecting the output. Speed improvements are especially apparent on multicore processors.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.InPlaceProcessing Property

ImageCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool InPlaceProcessing { get; }
Public Overridable ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.Progress Property

ImageCommandProgress Property

Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProgressEventHandler Progress { get; set; }
Public Property Progress As ProgressEventHandler
    Get
    Set

Property Value

Type: ProgressEventHandler
The ProgressEventHandler delegate which can be used to view or cancel the progress of the current process.
Remarks
A null value will ignore progress.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.SupportedPixelFormats Property

ImageCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract PixelFormat[] SupportedPixelFormats { get; }
Public MustOverride ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace
IsPixelFormatSupported Method


ImageCommand Methods

The ImageCommand type exposes the following members.

Methods
 | Name | Description
 | AllocatePixelFormatArray | Allocate an array of PixelFormat enums.
Public method | Apply | Apply the command to the given image.
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.
Protected method | ConstructImageResults | Constructs the results object for this command.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image.
 | GetContinuousFormatImage | A utility method for determining the best matching continuous tone pixel format and converting the given image to that format.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command.
 | ProxyConstructChangedSourceImage | Calls the ConstructChangedSourceImage method on the supplied ImageCommand.
 | ProxyConstructFinalImage |
 | ProxyConstructImageResults |
 | ProxyGetChangedPixelFormat |
 | ProxySelectBestAlternatePixelFormat |
 | ProxySelectPreferredPixelFormat |
 | ProxyVerifyProperties |
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable.
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage.
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image.
Top
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.AllocatePixelFormatArray Method

ImageCommandAllocatePixelFormatArray Method

Allocate an array of PixelFormat enums.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static PixelFormat[] AllocatePixelFormatArray(
    int len
)
Protected Shared Function AllocatePixelFormatArray (
    len As Integer
) As PixelFormat()

Parameters

len
Type: SystemInt32
The number of elements to allocate.

Return Value

Type: PixelFormat
Remarks
This method was added to work around a bug in Managed C++ that made it impossible to correctly allocate an array of enums. In general, most client code will never need to call this method.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.Apply Method

ImageCommandApply Method

Apply the command to the given image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ImageResults Apply(
    AtalaImage image
)
Public Overridable Function Apply (
    image As AtalaImage
) As ImageResults

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image which will by processed by the command.

Return Value

Type: ImageResults
A new object of type ImageResults.
Remarks
The ImageResults object will always contain a valid Image property which represents the output of the command. This property may be the same as the input image.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ApplyToImage Method

ImageCommandApplyToImage Method

Note: This API is now obsolete.

Applies the command to the source AtalaImage.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("ApplyToImage is obsolete.  Please use Apply instead.")]
public virtual AtalaImage ApplyToImage(
    AtalaImage sourceImage
)
<ObsoleteAttribute("ApplyToImage is obsolete.  Please use Apply instead.")>
Public Overridable Function ApplyToImage (
    sourceImage As AtalaImage
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source AtalaImage which will be processed. For command types that do not require a source image, set this to null.

Return Value

Type: AtalaImage
A new AtalaImage containing the processed image. For commandTypes that do not return an image, set this to null.
Exceptions
Exception | Condition
 | Thrown if the source image is null (Nothing in Visual Basic).
 | Thrown if the source image contains no data.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ConstructChangedSourceImage Method

ImageCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overridable Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ConstructFinalImage Method

ImageCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overridable Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ConstructImageResults Method

ImageCommandConstructImageResults Method

Constructs the results object for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual ImageResults ConstructImageResults()
Protected Overridable Function ConstructImageResults As ImageResults

Return Value

Type: ImageResults
A new object of type ImageResults representing the results for this command.
Remarks

The default implementation returns an object of type ImageResults. If your command requires an object with more information, subclass ImageResults and add in the information you need. Your command will override ConstructImageResults and return your new object.

The object allocated here is passed to PerformActualCommand as a reference parameter, meaning the entire object can be changed at that point too.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.GetChangedPixelFormat Method

ImageCommandGetChangedPixelFormat Method

This method is called to change the pixel format of the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage GetChangedPixelFormat(
    AtalaImage sourceImage,
    PixelFormat newFormat
)
Protected Overridable Function GetChangedPixelFormat (
    sourceImage As AtalaImage,
    newFormat As PixelFormat
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
newFormat
Type: Atalasoft.ImagingPixelFormat
The new pixel format.

Return Value

Type: AtalaImage
A new image in the new pixel format, with image data translated from the source image.
Remarks
The default implementation uses the built-in AtalaImage.GetChangedPixelFormat method, which in turn uses the PixelFormatChanger installed in AtalaImage. By overriding this method, you can bypass the built-in pixel format translation and supply your own and isolate it to an individual command.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.GetContinuousFormatImage Method

ImageCommandGetContinuousFormatImage Method

A utility method for determining the best matching continuous tone pixel format and converting the given image to that format.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static AtalaImage GetContinuousFormatImage(
    AtalaImage image
)
Protected Shared Function GetContinuousFormatImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
A non-continuous (ie, color-mapped) image

Return Value

Type: AtalaImage
If the image is already a continuous image format, this method will return null. Otherwise it will return a new image.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ImageCommandGetObjectData Method

ImageCommandImageCommandGetObjectData Method

Aggregates ImageCommand data into the supplied SerializationInfo object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ImageCommandGetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub ImageCommandGetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A serialization info object which will hold image command data
context
Type: System.Runtime.SerializationStreamingContext
The streaming context for the serialization.
Remarks
This method is only needs by child classes of image command which implement ISerializable. This method should be called to serialize all the base class information.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.IsPixelFormatSupported Method

ImageCommandIsPixelFormatSupported Method

Returns a value indicating if the specified pixel format is supported.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsPixelFormatSupported(
    PixelFormat format
)
Public Overridable Function IsPixelFormatSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat
The pixel format to query.

Return Value

Type: Boolean
Remarks
All derived commands must override this property.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace
SupportedPixelFormats Property


ImageCommand.PerformActualCommand Method

ImageCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected MustOverride Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxyConstructChangedSourceImage Method

ImageCommandProxyConstructChangedSourceImage Method

Calls the ConstructChangedSourceImage method on the supplied ImageCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static AtalaImage ProxyConstructChangedSourceImage(
    ImageCommand command,
    AtalaImage image
)
Protected Shared Function ProxyConstructChangedSourceImage (
    command As ImageCommand,
    image As AtalaImage
) As AtalaImage

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.
image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage to be passed to ConstructChangedSourceImage.

Return Value

Type: AtalaImage
Remarks
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxyConstructFinalImage Method

ImageCommandProxyConstructFinalImage Method

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static AtalaImage ProxyConstructFinalImage(
    ImageCommand command,
    AtalaImage image
)
Protected Shared Function ProxyConstructFinalImage (
    command As ImageCommand,
    image As AtalaImage
) As AtalaImage

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.
image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage to be passed to ConstructFinalImage.

Return Value

Type: AtalaImage
Remarks
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxyConstructImageResults Method

ImageCommandProxyConstructImageResults Method

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static ImageResults ProxyConstructImageResults(
    ImageCommand command
)
Protected Shared Function ProxyConstructImageResults (
    command As ImageCommand
) As ImageResults

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.

Return Value

Type: ImageResults
Remarks
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxyGetChangedPixelFormat Method

ImageCommandProxyGetChangedPixelFormat Method

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static AtalaImage ProxyGetChangedPixelFormat(
    ImageCommand command,
    AtalaImage sourceImage,
    PixelFormat newFormat
)
Protected Shared Function ProxyGetChangedPixelFormat (
    command As ImageCommand,
    sourceImage As AtalaImage,
    newFormat As PixelFormat
) As AtalaImage

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.
sourceImage
Type: Atalasoft.ImagingAtalaImage
An AtalaImage to be passed to GetChangedPixelFormat.
newFormat
Type: Atalasoft.ImagingPixelFormat
The new target pixel format

Return Value

Type: AtalaImage
Remarks
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxySelectBestAlternatePixelFormat Method

ImageCommandProxySelectBestAlternatePixelFormat Method

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static PixelFormat ProxySelectBestAlternatePixelFormat(
    ImageCommand command,
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Shared Function ProxySelectBestAlternatePixelFormat (
    command As ImageCommand,
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.
sourceImage
Type: Atalasoft.ImagingAtalaImage
An AtalaImage to be passed to SelectBestAlternatePixelFormat.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The source image pixel format
formats
Type: Atalasoft.ImagingPixelFormat
A set of supported pixel formats for the command

Return Value

Type: PixelFormat
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxySelectPreferredPixelFormat Method

ImageCommandProxySelectPreferredPixelFormat Method

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static PixelFormat ProxySelectPreferredPixelFormat(
    ImageCommand command,
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Shared Function ProxySelectPreferredPixelFormat (
    command As ImageCommand,
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.
sourceImage
Type: Atalasoft.ImagingAtalaImage
An AtalaImage to be passed to SelectPreferredPixelFormat.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The source image pixel format
formats
Type: Atalasoft.ImagingPixelFormat
A set of supported pixel formats for the command

Return Value

Type: PixelFormat
Remarks
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.ProxyVerifyProperties Method

ImageCommandProxyVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static void ProxyVerifyProperties(
    ImageCommand command,
    AtalaImage image
)
Protected Shared Sub ProxyVerifyProperties (
    command As ImageCommand,
    image As AtalaImage
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
An ImageCommand that will be called.
image
Type: Atalasoft.ImagingAtalaImage
The source image for the command
Remarks
This method (and all the Proxy...() methods are meant for meta image commands, such as ThreadedCommand, which need to operate on existing ImageCommands by proxy.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.SelectBestAlternatePixelFormat Method

ImageCommandSelectBestAlternatePixelFormat Method

Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual PixelFormat SelectBestAlternatePixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overridable Function SelectBestAlternatePixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image to be processed.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The source image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
The pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format for the command. This new pixel format must be one of the pixel formats in the supported pixel formats.
Remarks
The default implementation returns the 0th element of the formats array.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.SelectPreferredPixelFormat Method

ImageCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overridable Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.VerifyImage Method

ImageCommandVerifyImage Method

Verify the integrity of an AtalaImage.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void VerifyImage(
    AtalaImage image
)
Protected Sub VerifyImage (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage.
Remarks
Throws an ArgumentNullException if the image is null and an ArgumentException if the image's PixelMemory is null or disposed.
See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageCommand.VerifyProperties Method

ImageCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void VerifyProperties(
    AtalaImage image
)
Protected MustOverride Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ImageCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand Class

Derives from ImageCommand and adds region of interest capability to ImageCommands.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
More...

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class ImageRegionCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public MustInherit Class ImageRegionCommand
    Inherits ImageCommand
    Implements ISerializable

The ImageRegionCommand type exposes the following members.

Constructors
 | Name | Description
Protected method | ImageRegionCommand | Initializes a new instance of the ImageRegionCommand class.
Protected method | ImageRegionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageRegionCommand class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from ImageCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from ImageCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from ImageCommand.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsAdjustChannelCommand
Atalasoft.Imaging.ImageProcessing.ChannelsAdjustHslCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.ChannelsShiftChannelsCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSwapChannelsCommand
Atalasoft.Imaging.ImageProcessing.DocumentAdaptiveThresholdCommand
Atalasoft.Imaging.ImageProcessing.DocumentAdvancedBorderRemovalCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoInvertTextCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoNegateCommand
Atalasoft.Imaging.ImageProcessing.DocumentBinarizeCommand
Atalasoft.Imaging.ImageProcessing.DocumentBlankPageDetectionCommand
Atalasoft.Imaging.ImageProcessing.DocumentBlobRemovalCommand
Atalasoft.Imaging.ImageProcessing.DocumentColorExtractionCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentDespeckleCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentHitOrMissCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentMedianCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentThinningCommand
Atalasoft.Imaging.ImageProcessing.DocumentDynamicThresholdCommand
Atalasoft.Imaging.ImageProcessing.DocumentGlobalThresholdCommand
Atalasoft.Imaging.ImageProcessing.DocumentHalftoneRemovalCommand
Atalasoft.Imaging.ImageProcessing.DocumentHolePunchRemovalCommand
Atalasoft.Imaging.ImageProcessing.DocumentLineRemovalCommand
Atalasoft.Imaging.ImageProcessing.DocumentMorphoDocumentCommand
Atalasoft.Imaging.ImageProcessing.DocumentSegmentationCommand
Atalasoft.Imaging.ImageProcessing.DocumentSimpleThresholdCommand
Atalasoft.Imaging.ImageProcessing.DocumentSpeckRemovalCommand
Atalasoft.Imaging.ImageProcessing.EffectsAdjustTintCommand
Atalasoft.Imaging.ImageProcessing.EffectsAutoWhiteBalanceCommand
Atalasoft.Imaging.ImageProcessing.EffectsBrightnessContrastCommand
Atalasoft.Imaging.ImageProcessing.EffectsBrightnessHistogramEqualizeCommand
Atalasoft.Imaging.ImageProcessing.EffectsBrightnessHistogramStretchCommand
Atalasoft.Imaging.ImageProcessing.EffectsCrackleCommand
Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceCommand
Atalasoft.Imaging.ImageProcessing.EffectsDuotoneCommand
Atalasoft.Imaging.ImageProcessing.EffectsFingerprintCommand
Atalasoft.Imaging.ImageProcessing.EffectsFloodFillCommand
Atalasoft.Imaging.ImageProcessing.EffectsGammaCommand
Atalasoft.Imaging.ImageProcessing.EffectsGauzyCommand
Atalasoft.Imaging.ImageProcessing.EffectsHalftoneCommand
Atalasoft.Imaging.ImageProcessing.EffectsHistogramEqualizeCommand
Atalasoft.Imaging.ImageProcessing.EffectsHistogramStretchCommand
Atalasoft.Imaging.ImageProcessing.EffectsMosaicCommand
Atalasoft.Imaging.ImageProcessing.EffectsMotionBlurCommand
Atalasoft.Imaging.ImageProcessing.EffectsOilPaintCommand
Atalasoft.Imaging.ImageProcessing.EffectsPosterizeCommand
Atalasoft.Imaging.ImageProcessing.EffectsRedEyeRemovalCommand
Atalasoft.Imaging.ImageProcessing.EffectsReplaceColorCommand
Atalasoft.Imaging.ImageProcessing.EffectsSaturationCommand
Atalasoft.Imaging.ImageProcessing.EffectsSolarizeCommand
Atalasoft.Imaging.ImageProcessing.EffectsStippleCommand
Atalasoft.Imaging.ImageProcessing.EffectsWatercolorTintCommand
Atalasoft.Imaging.ImageProcessing.FiltersAdaptiveUnsharpMaskCommand
Atalasoft.Imaging.ImageProcessing.FiltersAddNoiseCommand
Atalasoft.Imaging.ImageProcessing.FiltersBlurCommand
Atalasoft.Imaging.ImageProcessing.FiltersBlurGaussianCommand
Atalasoft.Imaging.ImageProcessing.FiltersCannyEdgeDetectorCommand
Atalasoft.Imaging.ImageProcessing.FiltersConvolutionFilterCommand
Atalasoft.Imaging.ImageProcessing.FiltersConvolutionMatrixCommand
Atalasoft.Imaging.ImageProcessing.FiltersDespeckleCommand
Atalasoft.Imaging.ImageProcessing.FiltersDustAndScratchRemovalCommand
Atalasoft.Imaging.ImageProcessing.FiltersEdgeDetectionCommand
Atalasoft.Imaging.ImageProcessing.FiltersEmbossCommand
Atalasoft.Imaging.ImageProcessing.FiltersHighPassCommand
Atalasoft.Imaging.ImageProcessing.FiltersIntensifyCommand
Atalasoft.Imaging.ImageProcessing.FiltersMaximumCommand
Atalasoft.Imaging.ImageProcessing.FiltersMeanCommand
Atalasoft.Imaging.ImageProcessing.FiltersMedianCommand
Atalasoft.Imaging.ImageProcessing.FiltersMidpointCommand
Atalasoft.Imaging.ImageProcessing.FiltersMinimumCommand
Atalasoft.Imaging.ImageProcessing.FiltersMorphoGrayCommand
Atalasoft.Imaging.ImageProcessing.FiltersSharpenCommand
Atalasoft.Imaging.ImageProcessing.FiltersThresholdCommand
Atalasoft.Imaging.ImageProcessing.FiltersUnsharpMaskCommand


ImageRegionCommand Constructor

Overload List
 | Name | Description
Protected method | ImageRegionCommand | Initializes a new instance of the ImageRegionCommand class.
Protected method | ImageRegionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageRegionCommand class.
Top
See Also

Reference

ImageRegionCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand Constructor

Initializes a new instance of the ImageRegionCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageRegionCommand()
Protected Sub New
See Also

Reference

ImageRegionCommand Class
ImageRegionCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageRegionCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageRegionCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ImageRegionCommand Class
ImageRegionCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand Properties

The ImageRegionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from ImageCommand.)
Top
See Also

Reference

ImageRegionCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand.RegionOfInterest Property

ImageRegionCommandRegionOfInterest Property

Gets or sets a RegionOfInterest which will only process the indicated region of the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RegionOfInterest RegionOfInterest { get; set; }
Public Property RegionOfInterest As RegionOfInterest
    Get
    Set

Property Value

Type: RegionOfInterest
A RegionOfInterest which will only process the indicated region of the image.

Property Value

Type: RegionOfInterest
A RegionOfInterest specifying the area of the image to process.
See Also

Reference

ImageRegionCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand Methods

The ImageRegionCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from ImageCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from ImageCommand.)
Top
See Also

Reference

ImageRegionCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageRegionCommand.GetObjectData Method

ImageRegionCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ImageRegionCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults Class

This class is used to contain information generated during the processing of an ImageCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
More...

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageResults
Public Class ImageResults

The ImageResults type exposes the following members.

Constructors
 | Name | Description
Public method | ImageResults | Construct a new ImageResults object with default values.
Public method | ImageResults(Boolean) | Construct a new ImageResults object with the supplied values.
Public method | ImageResults(AtalaImage, Boolean) | Construct a new ImageResults object with the supplied values.
Top
Properties
 | Name | Description
Public property | Image | The image that was the result of processing
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentAutoBorderCropResults
Atalasoft.Imaging.ImageProcessing.DocumentAutoDeskewResults
Atalasoft.Imaging.ImageProcessing.DocumentAutoNegateResults
Atalasoft.Imaging.ImageProcessing.DocumentBlankPageDetectionResults
Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalResults
Atalasoft.Imaging.ImageProcessing.DocumentColorExtractionResults
Atalasoft.Imaging.ImageProcessing.DocumentHalftoneRemovalResults
Atalasoft.Imaging.ImageProcessing.DocumentHolePunchRemovalResults
Atalasoft.Imaging.ImageProcessing.DocumentLineRemovalResults
Atalasoft.Imaging.ImageProcessing.DocumentMarginCropResults
Atalasoft.Imaging.ImageProcessing.DocumentSegmentationResults


ImageResults Constructor

Constructs a new ImageResults object
Overload List
 | Name | Description
Public method | ImageResults | Construct a new ImageResults object with default values.
Public method | ImageResults(Boolean) | Construct a new ImageResults object with the supplied values.
Public method | ImageResults(AtalaImage, Boolean) | Construct a new ImageResults object with the supplied values.
Top
See Also

Reference

ImageResults Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults Constructor

Construct a new ImageResults object with default values.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageResults()
Public Sub New
See Also

Reference

ImageResults Class
ImageResults Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults Constructor (Boolean)

Construct a new ImageResults object with the supplied values.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageResults(
    bool isImageSourceImage
)
Public Sub New (
    isImageSourceImage As Boolean
)

Parameters

isImageSourceImage
Type: SystemBoolean
An indicator as to whether or not image is the same AtalaImage as the original image.
See Also

Reference

ImageResults Class
ImageResults Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults Constructor (AtalaImage, Boolean)

Construct a new ImageResults object with the supplied values.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageResults(
    AtalaImage image,
    bool isImageSourceImage
)
Public Sub New (
    image As AtalaImage,
    isImageSourceImage As Boolean
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image that was the result of processing
isImageSourceImage
Type: SystemBoolean
An indicator as to whether or not image is the same AtalaImage as the original image.
See Also

Reference

ImageResults Class
ImageResults Overload
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults Properties

The ImageResults type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that was the result of processing
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image.
Top
See Also

Reference

ImageResults Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults.Image Property

ImageResultsImage Property

The image that was the result of processing

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ImageResults Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults.IsImageSourceImage Property

ImageResultsIsImageSourceImage Property

An indicator as to whether or not image is the same AtalaImage as the original image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsImageSourceImage { get; set; }
Public Property IsImageSourceImage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImageResults Class
Atalasoft.Imaging.ImageProcessing Namespace


ImageResults Methods

The ImageResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageResults Class
Atalasoft.Imaging.ImageProcessing Namespace


InterpolationMode Enumeration

Specifies the interpolation to use with various image processing commands.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum InterpolationMode
Public Enumeration InterpolationMode
Members
Member name | Description
None | No interpolation.
BiLinear | Uses standard bi-linear interpolation.
BiCubic | Slowest, but most accurate interpolation.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


IPropertiesAutoConfigurable Interface

This interface when applied to an ImageCommand allowing the command to have properties that the algorithm will automatically determine based on image metrics.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPropertiesAutoConfigurable
Public Interface IPropertiesAutoConfigurable

The IPropertiesAutoConfigurable type exposes the following members.

Properties
 | Name | Description
Public property | AutoPropertyConfigurationEnabled | Gets or sets a property that when true will automatically determine property values as listed in PropertiesToAutoConfigure based on image metrics
Public property | PropertiesToAutoConfigure | Gets or sets a collection of property names that will be auto configured when applying the command.
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


IPropertiesAutoConfigurable Properties

The IPropertiesAutoConfigurable type exposes the following members.

Properties
 | Name | Description
Public property | AutoPropertyConfigurationEnabled | Gets or sets a property that when true will automatically determine property values as listed in PropertiesToAutoConfigure based on image metrics
Public property | PropertiesToAutoConfigure | Gets or sets a collection of property names that will be auto configured when applying the command.
Top
See Also

Reference

IPropertiesAutoConfigurable Interface
Atalasoft.Imaging.ImageProcessing Namespace


IPropertiesAutoConfigurable.AutoPropertyConfigurationEnabled Property

IPropertiesAutoConfigurableAutoPropertyConfigurationEnabled Property

Gets or sets a property that when true will automatically determine property values as listed in PropertiesToAutoConfigure based on image metrics

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool AutoPropertyConfigurationEnabled { get; set; }
Property AutoPropertyConfigurationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IPropertiesAutoConfigurable Interface
Atalasoft.Imaging.ImageProcessing Namespace


IPropertiesAutoConfigurable.PropertiesToAutoConfigure Property

IPropertiesAutoConfigurablePropertiesToAutoConfigure Property

Gets or sets a collection of property names that will be auto configured when applying the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
StringCollection PropertiesToAutoConfigure { get; }
ReadOnly Property PropertiesToAutoConfigure As StringCollection
    Get

Property Value

Type: StringCollection
See Also

Reference

IPropertiesAutoConfigurable Interface
Atalasoft.Imaging.ImageProcessing Namespace


IThreadableCommand Interface

This interface is applied to an ImageCommand to support parallelization.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IThreadableCommand
Public Interface IThreadableCommand

The IThreadableCommand type exposes the following members.

Properties
 | Name | Description
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Top
Remarks
ImageCommand objects with this interface applied perform faster with multiple core processors and systems with multiple processors.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
ImageCommand Class


IThreadableCommand Properties

The IThreadableCommand type exposes the following members.

Properties
 | Name | Description
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Top
See Also

Reference

IThreadableCommand Interface
Atalasoft.Imaging.ImageProcessing Namespace


IThreadableCommand.AutoThread Property

IThreadableCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool AutoThread { get; set; }
Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IThreadableCommand Interface
Atalasoft.Imaging.ImageProcessing Namespace


IThreadableCommand Methods

The IThreadableCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Top
See Also

Reference

IThreadableCommand Interface
Atalasoft.Imaging.ImageProcessing Namespace


IThreadableCommand.AdjustBands Method

IThreadableCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle

An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.
Remarks

Each band defines an area on which the IThreadableCommand will operate in an independent thread.

See Also

Reference

IThreadableCommand Interface
Atalasoft.Imaging.ImageProcessing Namespace


IThreadableCommand.PerformSectionCommand Method

IThreadableCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

IThreadableCommand Interface
Atalasoft.Imaging.ImageProcessing Namespace


JpegTransformFlags Enumeration

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum JpegTransformFlags
<FlagsAttribute>
Public Enumeration JpegTransformFlags
Members
Member name | Description
Grayscale | Discard the chrominance channels in standard (YCbCr encoded) JPEGs. This leaves just the luminance which gives you a grayscale JPEG.
NoExcessMcuBlocks | Do not remove excess MCU blocks.
Progressive | Set or remove the progressive display option.
Remarks

Lossless Transform options

See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


JpegTransformType Enumeration

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum JpegTransformType
Public Enumeration JpegTransformType
Members
Member name | Description
None | No Transform.
FlipHorizontal | Flip the image horizontally.
FlipVertical | Flip the image vertically.
Transverse | Transpose across upper-right to lower-left axis.
Transpose | Transpose across upper-leftto lower-right axis.
Rotate90 | Rotate the image 90 degrees.
Rotate180 | Rotate the image 180 degrees.
Rotate270 | Rotate the image 270 degrees.
Remarks
The specific type of JPEG transform.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg Class

Summary description for LosslessJpeg.
This class performs lossless transformations on JPEG images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingLosslessJpeg

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class LosslessJpeg
Public NotInheritable Class LosslessJpeg

The LosslessJpeg type exposes the following members.

Methods
 | Name | Description
 | CanDoLosslessTransform(Stream, JpegTransformType) | Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
 | CanDoLosslessTransform(String, JpegTransformType) | Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
 | Crop(Stream, Stream, Rectangle) | Performs a lossless crop on a JPEG image.
 | Crop(String, String, Rectangle) | Performs a lossless crop on a JPEG image.
 | Crop(Stream, Stream, Rectangle, JpegTransformFlags) | Performs a lossless crop on a JPEG image.
 | Crop(String, String, Rectangle, JpegTransformFlags) | Performs a lossless crop on a JPEG image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMcuBlockSize(Stream) | Get the compression block size for a JPG file.
 | GetMcuBlockSize(String) | Get the compression block size for a JPG file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Transform(Stream, Stream, JpegTransformType) | Perform a lossless transform on a JPEG image.
 | Transform(String, String, JpegTransformType) | Perform a lossless transform on a JPEG image.
 | Transform(Stream, Stream, JpegTransformType, JpegTransformFlags) | Perform a lossless transform on a JPEG image.
 | Transform(String, String, JpegTransformType, JpegTransformFlags) | Perform a lossless transform on a JPEG image.
Top
Remarks

JPEG images are compressed with lossy compression, meaning that each time the image is saved, quality is lost. Some operations, such as rotate, crop, and convert to grayscale can be performed without re-encoding the data.

Do determine of the image can be operated on losslessly, check the CanDoLosslessTransform(String, JpegTransformType) method. JPEG images are divided into rectangular sections called MCU blocks that are typically 8x8 pixels. If the width and height are both divisible by 8, then it usually means that lossless operations can be performed without losing or cropping the edges. However some JPEG images have MCU blocks other than 8.

Examples
LosslessJpeg Example (C#)
Copy
// Load a JPEG image.
FileStream fs = new FileStream(@"D:\Test Images\1.jpg", FileMode.Open, FileAccess.Read);

// See if the file can use the lossless transform.
if (LosslessJpeg.CanDoLosslessTransform(fs, JpegTransformType.Rotate90))
{
    FileStream fsSave = new FileStream(@"D:\Test Images\1transform.jpg", FileMode.Create, FileAccess.Write);
    fs.Seek(0, SeekOrigin.Begin);
    LosslessJpeg.Transform(fs, fsSave, JpegTransformType.Rotate90);
    fsSave.Close();
}
else
{
    // Use the normal rotate command.
    fs.Seek(0, SeekOrigin.Begin);
    AtalaImage image = new AtalaImage(fs, null);

    RotateCommand cmd = new RotateCommand(90);
    AtalaImage result = cmd.ApplyToImage(image);
    result.Save(@"D:\Test Images\1transform.jpg", new JpegEncoder(85), null);

    image.Dispose();
    result.Dispose();
}

fs.Close();
LosslessJpeg Example (Visual Basic)
Copy
' Load a JPEG image.
Dim fs As FileStream = New FileStream("D:\Test Images\1.jpg", FileMode.Open,FileAccess.Read)

' See if the file can use the lossless transform.
If LosslessJpeg.CanDoLosslessTransform(fs,JpegTransformType.Rotate90) Then
    Dim fsSave As FileStream = New FileStream("D:\Test Images\1transform.jpg", FileMode.Create, FileAccess.Write)
    fs.Seek(0, SeekOrigin.Begin)
    LosslessJpeg.Transform(fs, fsSave, JpegTransformType.Rotate90)
    fsSave.Close()
Else
    ' Use the normal rotate command.
    fs.Seek(0, SeekOrigin.Begin)
    Dim image As AtalaImage = New AtalaImage(fs,Nothing)

    Dim cmd As RotateCommand = New RotateCommand(90)
    Dim result As AtalaImage = cmd.ApplyToImage(image)
    result.Save("D:\Test Images\1transform.jpg",New JpegEncoder(85),Nothing)

    image.Dispose()
    result.Dispose()
End If

fs.Close()
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg Methods

The LosslessJpeg type exposes the following members.

Methods
 | Name | Description
 | CanDoLosslessTransform(Stream, JpegTransformType) | Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
 | CanDoLosslessTransform(String, JpegTransformType) | Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
 | Crop(Stream, Stream, Rectangle) | Performs a lossless crop on a JPEG image.
 | Crop(String, String, Rectangle) | Performs a lossless crop on a JPEG image.
 | Crop(Stream, Stream, Rectangle, JpegTransformFlags) | Performs a lossless crop on a JPEG image.
 | Crop(String, String, Rectangle, JpegTransformFlags) | Performs a lossless crop on a JPEG image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMcuBlockSize(Stream) | Get the compression block size for a JPG file.
 | GetMcuBlockSize(String) | Get the compression block size for a JPG file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Transform(Stream, Stream, JpegTransformType) | Perform a lossless transform on a JPEG image.
 | Transform(String, String, JpegTransformType) | Perform a lossless transform on a JPEG image.
 | Transform(Stream, Stream, JpegTransformType, JpegTransformFlags) | Perform a lossless transform on a JPEG image.
 | Transform(String, String, JpegTransformType, JpegTransformFlags) | Perform a lossless transform on a JPEG image.
Top
See Also

Reference

LosslessJpeg Class
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.CanDoLosslessTransform Method

LosslessJpegCanDoLosslessTransform Method

Overload List
Name | Description
CanDoLosslessTransform(Stream, JpegTransformType) | Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
CanDoLosslessTransform(String, JpegTransformType) | Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
Top
See Also

Reference

LosslessJpeg Class
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.CanDoLosslessTransform Method (Stream, JpegTransformType)

LosslessJpegCanDoLosslessTransform Method (Stream, JpegTransformType)

Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool CanDoLosslessTransform(
    Stream source,
    JpegTransformType transform
)
Public Shared Function CanDoLosslessTransform (
    source As Stream,
    transform As JpegTransformType
) As Boolean

Parameters

source
Type: System.IOStream
The source image Stream.
transform
Type: Atalasoft.Imaging.ImageProcessingJpegTransformType
The transform to test.

Return Value

Type: Boolean
See Also

Reference

LosslessJpeg Class
CanDoLosslessTransform Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.CanDoLosslessTransform Method (String, JpegTransformType)

LosslessJpegCanDoLosslessTransform Method (String, JpegTransformType)

Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.
Returns a value indicating the the MCU blocks are arranged such that a lossless transformation can be performed without cropping the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool CanDoLosslessTransform(
    string source,
    JpegTransformType transform
)
Public Shared Function CanDoLosslessTransform (
    source As String,
    transform As JpegTransformType
) As Boolean

Parameters

source
Type: SystemString
The source image file.
transform
Type: Atalasoft.Imaging.ImageProcessingJpegTransformType
The transform to test.

Return Value

Type: Boolean
See Also

Reference

LosslessJpeg Class
CanDoLosslessTransform Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Crop Method

LosslessJpegCrop Method

Overload List
Name | Description
Crop(Stream, Stream, Rectangle) | Performs a lossless crop on a JPEG image.
Crop(String, String, Rectangle) | Performs a lossless crop on a JPEG image.
Crop(Stream, Stream, Rectangle, JpegTransformFlags) | Performs a lossless crop on a JPEG image.
Crop(String, String, Rectangle, JpegTransformFlags) | Performs a lossless crop on a JPEG image.
Top
See Also

Reference

LosslessJpeg Class
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Crop Method (Stream, Stream, Rectangle)

LosslessJpegCrop Method (Stream, Stream, Rectangle)

Performs a lossless crop on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Crop(
    Stream source,
    Stream dest,
    Rectangle cropRectangle
)
Public Shared Sub Crop (
    source As Stream,
    dest As Stream,
    cropRectangle As Rectangle
)

Parameters

source
Type: System.IOStream
The source image Stream.
dest
Type: System.IOStream
The destination image Stream.
cropRectangle
Type: System.DrawingRectangle
The crop rectangle.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
See Also

Reference

LosslessJpeg Class
Crop Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Crop Method (String, String, Rectangle)

LosslessJpegCrop Method (String, String, Rectangle)

Performs a lossless crop on a JPEG image.
Performs a lossless crop on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Crop(
    string source,
    string dest,
    Rectangle cropRectangle
)
Public Shared Sub Crop (
    source As String,
    dest As String,
    cropRectangle As Rectangle
)

Parameters

source
Type: SystemString
The source image file.
dest
Type: SystemString
The destination image filename.
cropRectangle
Type: System.DrawingRectangle
The crop rectangle.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
Remarks

Perform a lossless crop on the image in a JPG file, without decompressing the JPG data. By not decompressing, you don't have to re-compress, thus avoiding adding additional JPG artifacts to the output image.

This works by rearranging the compressed data (DCT coefficients), without ever fully decoding the image. Therefore, its transformations are lossless: there is no image degradation at all, which is not the case if you were to read the image to RGB, transform, and save again as JPG.

Note:,JPG files are compressed in rectangular blocks. The dimensions of these blocks are always a multiple of 8 pixels: 8x8 and 16x16 are common.

Because the compression blocks on the top and left edges cannot be split during a crop, the size of these blocks affects the crops that this function can perform. This inability to split blocks means that the top-left corner of the crop rect you specify will always be rounded down to the next lowest multiple of the MCU size (see GetMcuBlackSize). The bottom right corner you specify is unaffected.

See Also

Reference

LosslessJpeg Class
Crop Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Crop Method (Stream, Stream, Rectangle, JpegTransformFlags)

LosslessJpegCrop Method (Stream, Stream, Rectangle, JpegTransformFlags)

Performs a lossless crop on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Crop(
    Stream source,
    Stream dest,
    Rectangle cropRectangle,
    JpegTransformFlags flags
)
Public Shared Sub Crop (
    source As Stream,
    dest As Stream,
    cropRectangle As Rectangle,
    flags As JpegTransformFlags
)

Parameters

source
Type: System.IOStream
The source image Stream.
dest
Type: System.IOStream
The destination image Stream.
cropRectangle
Type: System.DrawingRectangle
The crop rectangle.
flags
Type: Atalasoft.Imaging.ImageProcessingJpegTransformFlags
The transform flags.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
See Also

Reference

LosslessJpeg Class
Crop Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Crop Method (String, String, Rectangle, JpegTransformFlags)

LosslessJpegCrop Method (String, String, Rectangle, JpegTransformFlags)

Performs a lossless crop on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Crop(
    string source,
    string dest,
    Rectangle cropRectangle,
    JpegTransformFlags flags
)
Public Shared Sub Crop (
    source As String,
    dest As String,
    cropRectangle As Rectangle,
    flags As JpegTransformFlags
)

Parameters

source
Type: SystemString
The source image file.
dest
Type: SystemString
The destination image filename.
cropRectangle
Type: System.DrawingRectangle
The crop rectangle.
flags
Type: Atalasoft.Imaging.ImageProcessingJpegTransformFlags
The transform flags.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
See Also

Reference

LosslessJpeg Class
Crop Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.GetMcuBlockSize Method

LosslessJpegGetMcuBlockSize Method

Overload List
Name | Description
GetMcuBlockSize(Stream) | Get the compression block size for a JPG file.
GetMcuBlockSize(String) | Get the compression block size for a JPG file.
Top
See Also

Reference

LosslessJpeg Class
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.GetMcuBlockSize Method (Stream)

LosslessJpegGetMcuBlockSize Method (Stream)

Get the compression block size for a JPG file.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size GetMcuBlockSize(
    Stream source
)
Public Shared Function GetMcuBlockSize (
    source As Stream
) As Size

Parameters

source
Type: System.IOStream
The source image Stream.

Return Value

Type: Size
Remarks
This can be used in conjunction with a lossless crop to determine the range of crop rectangles that are possible.
See Also

Reference

LosslessJpeg Class
GetMcuBlockSize Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.GetMcuBlockSize Method (String)

LosslessJpegGetMcuBlockSize Method (String)

Get the compression block size for a JPG file.
Get the compression block size for a JPG file.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Size GetMcuBlockSize(
    string source
)
Public Shared Function GetMcuBlockSize (
    source As String
) As Size

Parameters

source
Type: SystemString
The source image file.

Return Value

Type: Size
Remarks
This can be used in conjunction with a lossless crop to determine the range of crop rectangles that are possible.
Remarks
This can be used in conjunction with a lossless crop to determine the range of crop rectangles that are possible.
See Also

Reference

LosslessJpeg Class
GetMcuBlockSize Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Transform Method

LosslessJpegTransform Method

Overload List
Name | Description
Transform(Stream, Stream, JpegTransformType) | Perform a lossless transform on a JPEG image.
Transform(String, String, JpegTransformType) | Perform a lossless transform on a JPEG image.
Transform(Stream, Stream, JpegTransformType, JpegTransformFlags) | Perform a lossless transform on a JPEG image.
Transform(String, String, JpegTransformType, JpegTransformFlags) | Perform a lossless transform on a JPEG image.
Top
See Also

Reference

LosslessJpeg Class
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Transform Method (Stream, Stream, JpegTransformType)

LosslessJpegTransform Method (Stream, Stream, JpegTransformType)

Perform a lossless transform on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Transform(
    Stream source,
    Stream dest,
    JpegTransformType type
)
Public Shared Sub Transform (
    source As Stream,
    dest As Stream,
    type As JpegTransformType
)

Parameters

source
Type: System.IOStream
The source image Stream.
dest
Type: System.IOStream
The destination image Stream.
type
Type: Atalasoft.Imaging.ImageProcessingJpegTransformType
The transform type to apply.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
Examples
LosslessJpeg Class
See Also

Reference

LosslessJpeg Class
Transform Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Transform Method (String, String, JpegTransformType)

LosslessJpegTransform Method (String, String, JpegTransformType)

Perform a lossless transform on a JPEG image.
Perform a lossless transform on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Transform(
    string source,
    string dest,
    JpegTransformType type
)
Public Shared Sub Transform (
    source As String,
    dest As String,
    type As JpegTransformType
)

Parameters

source
Type: SystemString
The source image file.
dest
Type: SystemString
The destination image filename.
type
Type: Atalasoft.Imaging.ImageProcessingJpegTransformType
The transform type to apply.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
Remarks

This can be used to perform one of a set of simple transformations without decompressing the JPEG data. By not decompressing, you don't have to re-compress, thus avoiding adding additional JPG artifacts to the output image.

This works by rearranging the compressed data (DCT coefficients), without ever fully decoding the image. Therefore, its transformations are lossless: there is no image degradation at all, which is not the case if you were to read the image to RGB, transform, and save again as JPG.

The transpose transformation has no restrictions regarding image dimensions. The other transformations operate rather oddly if the image dimensions are not a multiple of the iMCU size (usually 8 or 16 pixels, though sometimes 32 or 48), because they can only transform complete blocks of DCT coefficient data in the desired way.

The default behavior is to discard these "extra" blocks. This prevents ugly strips of unmodified data along one edge. So, strictly speaking, these transformations are not lossless for all images: they are lossless only for images with dimensions that are multiples of 8 or 16. You can override this discarding the extra blocks, though it is not recommended.

Examples
LosslessJpeg Class
Examples
LosslessJpeg Class
See Also

Reference

LosslessJpeg Class
Transform Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Transform Method (Stream, Stream, JpegTransformType, JpegTransformFlags)

LosslessJpegTransform Method (Stream, Stream, JpegTransformType, JpegTransformFlags)

Perform a lossless transform on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Transform(
    Stream source,
    Stream dest,
    JpegTransformType type,
    JpegTransformFlags flags
)
Public Shared Sub Transform (
    source As Stream,
    dest As Stream,
    type As JpegTransformType,
    flags As JpegTransformFlags
)

Parameters

source
Type: System.IOStream
The source image Stream.
dest
Type: System.IOStream
The destination image Stream.
type
Type: Atalasoft.Imaging.ImageProcessingJpegTransformType
The transform type to apply.
flags
Type: Atalasoft.Imaging.ImageProcessingJpegTransformFlags
The transform flags.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
Examples
LosslessJpeg Class
See Also

Reference

LosslessJpeg Class
Transform Overload
Atalasoft.Imaging.ImageProcessing Namespace


LosslessJpeg.Transform Method (String, String, JpegTransformType, JpegTransformFlags)

LosslessJpegTransform Method (String, String, JpegTransformType, JpegTransformFlags)

Perform a lossless transform on a JPEG image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Transform(
    string source,
    string dest,
    JpegTransformType type,
    JpegTransformFlags flags
)
Public Shared Sub Transform (
    source As String,
    dest As String,
    type As JpegTransformType,
    flags As JpegTransformFlags
)

Parameters

source
Type: SystemString
The source image file.
dest
Type: SystemString
The destination image filename.
type
Type: Atalasoft.Imaging.ImageProcessingJpegTransformType
The transform type to apply.
flags
Type: Atalasoft.Imaging.ImageProcessingJpegTransformFlags
The transform flags.
Exceptions
Exception | Condition
 | Thrown is the current license is not DotImage Photo Pro, or DotImage Document Imaging.
Examples
LosslessJpeg Class
See Also

Reference

LosslessJpeg Class
Transform Overload
Atalasoft.Imaging.ImageProcessing Namespace


MergeOption Enumeration

Image overlay merge options.
Image overlay merge options.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MergeOption
Public Enumeration MergeOption
Members
Member name | Description
FastBlend | Fast Blend. Uses factor parameter as opacity.
AccurateBlend | Slower, more accurate blend. Uses factor parameter as opacity.
LogicalAnd | Pixels are combined with logical AND.
LogicalOR | Pixels are combined with logical OR.
LogicalXOR | Pixels are combined with logical XOR.
Max | Output pixels is max of top and bottom.
Min | Output pixel is min of top and bottom.
Sum | Output pixel is sum of top and bottom.
Difference | Output pixel is difference of top and bottom.
GreaterThanFactor | If top pixel value > factor, output top pixel value, otherwise output factor.
LessThanFactor | If top pixel value < factor, output top pixel value, otherwise output factor.
AbsoluteValueOfDifference | Absolute value of the differnce of top and bottom pixel.
Multiply | Multiply bottom pixel value by top pixel value and divide by 255 (top * bottom) / 255.
MultiplyWidthFactor | Multiply bottom pixel value by top pixel value and by a factor and divide by 255 (top * bottom * factor) / 255.
Screen | 255-(((255-top)*(255-bottom)) / 255).
PlusFactor | bottom = bottom + top - factor
MinusFactor | bottom = bottom - top - factor
NegativeAnd | Performs a negative Logical AND. This can only be used with 1-bit images.
NegativeOR | Performs a negative Logical OR. This can only be used with 1-bit images.
NegativeXOR | Performs a negative Logical XOR. This can only be used with 1-bit images.
Copy | Performs a copy operation
ColorDodge | Color dodge
ColorBurn | Color burn
SoftDodge | Soft Dodge
SoftBurn | Soft Burn
Photoshop | Photoshop "overlay"
SoftLight | soft light (similar but not identical to Photoshop)
HardLight | Hard light
XFaderReflect | XFader reflect
XFaderGlow | XFader glow
XFaderFreeze | XFader freeze
XFaderHeat | XFader heat
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Class

Summary description for NoiseGenerator.
Creates a new image containing noise.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingNoiseGenerator

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class NoiseGenerator : ISerializable
<SerializableAttribute>
Public Class NoiseGenerator
    Implements ISerializable

The NoiseGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | NoiseGenerator | Initializes a new instance of the NoiseGenerator class.
Public method | NoiseGenerator(Size) | Initializes a new instance of NoiseGenerator specifying the resulting image size.
Public method | NoiseGenerator(Size, Double) | Initializes a new instance of NoiseGenerator specifying the resulting image size and scale.
Protected method | NoiseGenerator(SerializationInfo, StreamingContext) | Initializes a new instance of NoiseGenerator.
Public method | NoiseGenerator(Size, Double, NoiseGeneratorMode) | Initializes a new instance of NoiseGenerator specifying the resulting image size, scale and mode.
Public method | NoiseGenerator(Size, Double, NoiseGeneratorMode, Color) | Initializes a new instance of NoiseGenerator specifying the resulting image size, scale, mode and base color.
Top
Properties
 | Name | Description
Public property | BaseColor | Gets or sets the base color of the noise.
Public property | ImageSize | Gets or sets the size of the resulting image.
Public property | Mode | Gets or sets the type of noise to generate.
Public property | Scale | Gets or sets the size of the noise.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateImage | Generates a new AtalaImage containing the noise.
Public method | GenerateImage(Double) | Generates a new AtalaImage containing the noise.
Public method | GenerateImage(Int32, Double) | Generates a new AtalaImage containing the noise.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This function has many uses. One is to generate Perlin or Hugo noise, resize it large, and then use that as random clouds. There are many different types of noise you can generate.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor

Creates a NoiseGenerator object used for creating images of random noise patterns.
Overload List
 | Name | Description
Public method | NoiseGenerator | Initializes a new instance of the NoiseGenerator class.
Public method | NoiseGenerator(Size) | Initializes a new instance of NoiseGenerator specifying the resulting image size.
Public method | NoiseGenerator(Size, Double) | Initializes a new instance of NoiseGenerator specifying the resulting image size and scale.
Protected method | NoiseGenerator(SerializationInfo, StreamingContext) | Initializes a new instance of NoiseGenerator.
Public method | NoiseGenerator(Size, Double, NoiseGeneratorMode) | Initializes a new instance of NoiseGenerator specifying the resulting image size, scale and mode.
Public method | NoiseGenerator(Size, Double, NoiseGeneratorMode, Color) | Initializes a new instance of NoiseGenerator specifying the resulting image size, scale, mode and base color.
Top
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor

Initializes a new instance of the NoiseGenerator class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseGenerator()
Public Sub New
See Also

Reference

NoiseGenerator Class
NoiseGenerator Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor (Size)

Initializes a new instance of NoiseGenerator specifying the resulting image size.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseGenerator(
    Size imageSize
)
Public Sub New (
    imageSize As Size
)

Parameters

imageSize
Type: System.DrawingSize
The size of the resulting image containing noise.
See Also

Reference

NoiseGenerator Class
NoiseGenerator Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor (Size, Double)

Initializes a new instance of NoiseGenerator specifying the resulting image size and scale.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseGenerator(
    Size imageSize,
    double scale
)
Public Sub New (
    imageSize As Size,
    scale As Double
)

Parameters

imageSize
Type: System.DrawingSize
The size of the resulting image containing noise.
scale
Type: SystemDouble
The size of the noise.
See Also

Reference

NoiseGenerator Class
NoiseGenerator Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of NoiseGenerator.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected NoiseGenerator(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

NoiseGenerator Class
NoiseGenerator Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor (Size, Double, NoiseGeneratorMode)

Initializes a new instance of NoiseGenerator specifying the resulting image size, scale and mode.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseGenerator(
    Size imageSize,
    double scale,
    NoiseGeneratorMode mode
)
Public Sub New (
    imageSize As Size,
    scale As Double,
    mode As NoiseGeneratorMode
)

Parameters

imageSize
Type: System.DrawingSize
The size of the resulting image containing noise.
scale
Type: SystemDouble
The size of the noise.
mode
Type: Atalasoft.Imaging.ImageProcessingNoiseGeneratorMode

The type of noise to create.

See Also

Reference

NoiseGenerator Class
NoiseGenerator Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Constructor (Size, Double, NoiseGeneratorMode, Color)

Initializes a new instance of NoiseGenerator specifying the resulting image size, scale, mode and base color.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseGenerator(
    Size imageSize,
    double scale,
    NoiseGeneratorMode mode,
    Color baseColor
)
Public Sub New (
    imageSize As Size,
    scale As Double,
    mode As NoiseGeneratorMode,
    baseColor As Color
)

Parameters

imageSize
Type: System.DrawingSize
The size of the resulting image containing noise.
scale
Type: SystemDouble
The size of the noise.
mode
Type: Atalasoft.Imaging.ImageProcessingNoiseGeneratorMode

The type of noise to create.

baseColor
Type: System.DrawingColor
The color of the image prior to adding noise.
See Also

Reference

NoiseGenerator Class
NoiseGenerator Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Properties

The NoiseGenerator type exposes the following members.

Properties
 | Name | Description
Public property | BaseColor | Gets or sets the base color of the noise.
Public property | ImageSize | Gets or sets the size of the resulting image.
Public property | Mode | Gets or sets the type of noise to generate.
Public property | Scale | Gets or sets the size of the noise.
Top
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.BaseColor Property

NoiseGeneratorBaseColor Property

Gets or sets the base color of the noise.
Gets or sets the color of the image prior to adding noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BaseColor { get; set; }
Public Property BaseColor As Color
    Get
    Set

Property Value

Type: Color
The base color of the noise.

Property Value

Type: Color
The color of the image prior to adding noise.
Remarks
The DimensionalSlice noise will always be grayscale.
Remarks
Default value is Color.Empty, which will result in a grayscale image. Ignored by DimensionalSlice noise, which is always grayscale.
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.ImageSize Property

NoiseGeneratorImageSize Property

Gets or sets the size of the resulting image.

Gets or sets the size of the resulting image containing noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ImageSize { get; set; }
Public Property ImageSize As Size
    Get
    Set

Property Value

Type: Size
The size of the resulting image.

Property Value

Type: Size
The size of the resulting image containing noise.
Exceptions
Exception | Condition
 | Thrown if the width or height is less than 1.
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.Mode Property

NoiseGeneratorMode Property

Gets or sets the type of noise to generate.

Gets or sets the type of noise to create.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseGeneratorMode Mode { get; set; }
Public Property Mode As NoiseGeneratorMode
    Get
    Set

Property Value

Type: NoiseGeneratorMode
The type of noise to generate.

Property Value

Type: NoiseGeneratorMode

The type of noise to create.

See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.Scale Property

NoiseGeneratorScale Property

Gets or sets the size of the noise.
Gets or sets the size of the noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set

Property Value

Type: Double
The size of the noise.

Property Value

Type: Double

The size of the noise.

Exceptions
Exception | Condition
 | Thrown if the scale is less than 0 or greater than 100.
Remarks
Default value is 50.
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator Methods

The NoiseGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateImage | Generates a new AtalaImage containing the noise.
Public method | GenerateImage(Double) | Generates a new AtalaImage containing the noise.
Public method | GenerateImage(Int32, Double) | Generates a new AtalaImage containing the noise.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.GenerateImage Method

NoiseGeneratorGenerateImage Method

Overload List
 | Name | Description
Public method | GenerateImage | Generates a new AtalaImage containing the noise.
Public method | GenerateImage(Double) | Generates a new AtalaImage containing the noise.
Public method | GenerateImage(Int32, Double) | Generates a new AtalaImage containing the noise.
Top
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.GenerateImage Method

NoiseGeneratorGenerateImage Method

Generates a new AtalaImage containing the noise.
Create a new image containing noise.
Create a new image containing noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GenerateImage()
Public Function GenerateImage As AtalaImage

Return Value

Type: AtalaImage
A new AtalaImage containing the noise.
See Also

Reference

NoiseGenerator Class
GenerateImage Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.GenerateImage Method (Double)

NoiseGeneratorGenerateImage Method (Double)

Generates a new AtalaImage containing the noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GenerateImage(
    double zOffset
)
Public Function GenerateImage (
    zOffset As Double
) As AtalaImage

Parameters

zOffset
Type: SystemDouble
The z-axis offset used for DimensionSlice noise.

Return Value

Type: AtalaImage
A new AtalaImage containing the noise.
See Also

Reference

NoiseGenerator Class
GenerateImage Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.GenerateImage Method (Int32, Double)

NoiseGeneratorGenerateImage Method (Int32, Double)

Generates a new AtalaImage containing the noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GenerateImage(
    int octaves,
    double persistence
)
Public Function GenerateImage (
    octaves As Integer,
    persistence As Double
) As AtalaImage

Parameters

octaves
Type: SystemInt32
The number of waves contributing to the noise.
persistence
Type: SystemDouble
Controls the smoothness. (0 to 10)

Return Value

Type: AtalaImage
A new AtalaImage containing the noise.
See Also

Reference

NoiseGenerator Class
GenerateImage Overload
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGenerator.GetObjectData Method

NoiseGeneratorGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

NoiseGenerator Class
Atalasoft.Imaging.ImageProcessing Namespace


NoiseGeneratorMode Enumeration

Specifies the type of noise.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum NoiseGeneratorMode
Public Enumeration NoiseGeneratorMode
Members
Member name | Description
Perlin | Generate an image filled with Perlin noise.
Hugo | Generate an image filled with Hugo Elias's implementation of Perlin noise.
Gaussian | Specifies the type of noise.
NegativeExponential | Generate an image using negative exponential noise.
Rayleigh | Generate an image filled with rayleigh noise.
Uniform | Generate an image filled with uniform noise.
DimensionalSlice | Create a single 2D plane of Perlin noise producing a single slice through a volume of noise at a given Z offset.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Class

Summary description for tmpOverlay.
Overlays a specified image on top of the source image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingOverlayCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OverlayCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class OverlayCommand
    Inherits ImageCommand
    Implements ISerializable

The OverlayCommand type exposes the following members.

Constructors
 | Name | Description
Public method | OverlayCommand | Initializes a new instance of the OverlayCommand class.
Protected method | OverlayCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %OverlayCommand%.
Public method | OverlayCommand(AtalaImage, Point) | Overlay one image onto another.
Public method | OverlayCommand(AtalaImage, Point, Double) | Overlay one image onto another.
Public method | OverlayCommand(AtalaImage, Point, Color) | Overlay one image onto another.
Public method | OverlayCommand(AtalaImage, Point, Int32) | Overlay an 8-bit image onto another.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating whether the command returns a new image or modified the source image passed into the command. (Overrides ImageCommandInPlaceProcessing.)
Public property | Opacity | Gets or sets the opacity of the top image.
Public property | Position | Gets or sets the position of the top image with respect to the source image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the image that will be overlayed onto the source image.
Public property | TransparentColor | Gets or sets the color that will be used as a transparent mask for the top image.
Public property | TransparentIndex | Gets or sets the palette index that will be used as a transparent mask for the top image.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

If the top image has an alpha channel, that alpha will be used to control the transparency of the overlay and will override the %TransparentColor% and %Opacity% values.

When overlaying one image with alpha, on top of another image with alpha, the alpha channels will be merged to take the maximum pixel value of each alpha channel. See OverlayMergedCommand for more specific options.

The top image will always be converted to the pixel format of the bottom image, unless the top image has an alpha channel, which it will then use for alpha blending.

This command supports all pixel formats with the exception of 4-bit Indexed.

This command processes the source image in-place, and ApplyToImage always returns null.

Examples
OverlayCommand (C#)
Copy
private AtalaImage OverlayImage(string bottomFile, string topFile, Point position)
{
    // Make sure the files exist.
    if (!File.Exists(bottomFile))
        throw new FileNotFoundException("The bottom image file could not be found.", bottomFile);

    if (!File.Exists(topFile))
        throw new FileNotFoundException("The file to overlay could not be found.", topFile);

    // Load the bottom image.
    AtalaImage tmpImage = new AtalaImage(bottomFile);

    // Overlay does not support 4-bit bottom images.
    AtalaImage bottomImage = null;
    if (tmpImage.PixelFormat == PixelFormat.Pixel4bppIndexed)
    {
        bottomImage = tmpImage.GetChangedPixelFormat(PixelFormat.Pixel8bppIndexed);
        tmpImage.Dispose();
    }
    else
        bottomImage = tmpImage;

    // Load the top image.
    tmpImage = new AtalaImage(topFile);

    // If the bottom image is 16-bit per component, the top image must be the same.
    AtalaImage topImage = null;
    if (AtalaImage.PixelFormatIsTwoBytePerComponent(bottomImage.PixelFormat) && topImage.PixelFormat != bottomImage.PixelFormat)
    {
        topImage = tmpImage.GetChangedPixelFormat(bottomImage.PixelFormat);
        tmpImage.Dispose();
    }
    else
        topImage = tmpImage;

    OverlayCommand cmd = new OverlayCommand(topImage, position);
    cmd.ApplyToImage(bottomImage);

    // We are done with the top image.
    topImage.Dispose();

    return bottomImage;
}
OverlayCommandVB (Visual Basic)
Copy
Private Function OverlayImage(ByVal bottomFile As String, ByVal topFile As String, ByVal position As Point) As AtalaImage
    ' Make sure the files exist.
    If Not File.Exists(bottomFile) Then
        Throw New FileNotFoundException("The bottom image file could not be found.", bottomFile)
    End If

    If Not File.Exists(topFile) Then
        Throw New FileNotFoundException("The file to overlay could not be found.", topFile)
    End If

    ' Load the bottom image.
    Dim tmpImage As AtalaImage =  New AtalaImage(bottomFile)

    ' Overlay does not support 4-bit bottom images.
    Dim bottomImage As AtalaImage =  Nothing
    If tmpImage.PixelFormat = PixelFormat.Pixel4bppIndexed Then
        bottomImage = tmpImage.GetChangedPixelFormat(PixelFormat.Pixel8bppIndexed)
        tmpImage.Dispose()
    Else
        bottomImage = tmpImage
    End If

    ' Load the top image.
    tmpImage = New AtalaImage(topFile)

    ' If the bottom image is 16-bit per component, the top image must be the same.
    Dim topImage As AtalaImage =  Nothing
    If AtalaImage.PixelFormatIsTwoBytePerComponent(bottomImage.PixelFormat) And topImage.PixelFormat <> bottomImage.PixelFormat Then
        topImage = tmpImage.GetChangedPixelFormat(bottomImage.PixelFormat)
        tmpImage.Dispose()
    Else
        topImage = tmpImage
    End If

    Dim cmd As OverlayCommand =  New OverlayCommand(topImage,position)
    cmd.ApplyToImage(bottomImage)

    ' We are done with the top image.
    topImage.Dispose()

    Return bottomImage
End Function
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
OverlayMergedCommand
OverlayMaskedCommand


OverlayCommand Constructor

Create an OverlayCommand used to overlay one image onto another.
Overload List
 | Name | Description
Public method | OverlayCommand | Initializes a new instance of the OverlayCommand class.
Protected method | OverlayCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %OverlayCommand%.
Public method | OverlayCommand(AtalaImage, Point) | Overlay one image onto another.
Public method | OverlayCommand(AtalaImage, Point, Double) | Overlay one image onto another.
Public method | OverlayCommand(AtalaImage, Point, Color) | Overlay one image onto another.
Public method | OverlayCommand(AtalaImage, Point, Int32) | Overlay an 8-bit image onto another.
Top
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Constructor

Initializes a new instance of the OverlayCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayCommand()
Public Sub New
See Also

Reference

OverlayCommand Class
OverlayCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of %OverlayCommand%.
Creates a new instance of OverlayCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OverlayCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

OverlayCommand Class
OverlayCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Constructor (AtalaImage, Point)

Overlay one image onto another.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayCommand(
    AtalaImage topImage,
    Point position
)
Public Sub New (
    topImage As AtalaImage,
    position As Point
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image to place onto the bottom image.
position
Type: System.DrawingPoint
Position on the bottom image to place the overlay.
See Also

Reference

OverlayCommand Class
OverlayCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Constructor (AtalaImage, Point, Double)

Overlay one image onto another.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayCommand(
    AtalaImage topImage,
    Point position,
    double opacity
)
Public Sub New (
    topImage As AtalaImage,
    position As Point,
    opacity As Double
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image to place onto the bottom image.
position
Type: System.DrawingPoint
Position on the bottom image to place the overlay.
opacity
Type: SystemDouble
The amount of transparency used for the top image.
See Also

Reference

OverlayCommand Class
OverlayCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Constructor (AtalaImage, Point, Color)

Overlay one image onto another.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayCommand(
    AtalaImage topImage,
    Point position,
    Color transparentColor
)
Public Sub New (
    topImage As AtalaImage,
    position As Point,
    transparentColor As Color
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image to place onto the bottom image.
position
Type: System.DrawingPoint
Position on the bottom image to place the overlay.
transparentColor
Type: System.DrawingColor
The color in the top image to set as transparent when overlaying.
See Also

Reference

OverlayCommand Class
OverlayCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Constructor (AtalaImage, Point, Int32)

Overlay an 8-bit image onto another.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayCommand(
    AtalaImage topImage,
    Point position,
    int transparentIndex
)
Public Sub New (
    topImage As AtalaImage,
    position As Point,
    transparentIndex As Integer
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image to place onto the bottom image.
position
Type: System.DrawingPoint
Position on the bottom image to place the overlay.
transparentIndex
Type: SystemInt32
The palette index of the color to set as transparent when overlaying.
See Also

Reference

OverlayCommand Class
OverlayCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Properties

The OverlayCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating whether the command returns a new image or modified the source image passed into the command. (Overrides ImageCommandInPlaceProcessing.)
Public property | Opacity | Gets or sets the opacity of the top image.
Public property | Position | Gets or sets the position of the top image with respect to the source image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the image that will be overlayed onto the source image.
Public property | TransparentColor | Gets or sets the color that will be used as a transparent mask for the top image.
Public property | TransparentIndex | Gets or sets the palette index that will be used as a transparent mask for the top image.
Top
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.InPlaceProcessing Property

OverlayCommandInPlaceProcessing Property

Gets a value indicating whether the command returns a new image or modified the source image passed into the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Returns true for this command.
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.Opacity Property

OverlayCommandOpacity Property

Gets or sets the opacity of the top image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Opacity { get; set; }
Public Property Opacity As Double
    Get
    Set

Property Value

Type: Double
The opacity of the top image.
Exceptions
Exception | Condition
 | Thrown if the opacity is less than 0.0 or greater than 1.0.
Remarks

Valid values are 0.0 for fully transparent through 1.0 for fully opaque.

If the image has an alpha channel, the alpha channel will be used for the opacity of each pixel in the top image.

See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.Position Property

OverlayCommandPosition Property

Gets or sets the position of the top image with respect to the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The position of the top image onto the source image.
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.SupportedPixelFormats Property

OverlayCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.TopImage Property

OverlayCommandTopImage Property

Gets or sets the image that will be overlayed onto the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage TopImage { get; set; }
Public Property TopImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image that will be overlayed onto the source image.
Exceptions
Exception | Condition
 | Thrown if the image is null.
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.TransparentColor Property

OverlayCommandTransparentColor Property

Gets or sets the color that will be used as a transparent mask for the top image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color TransparentColor { get; set; }
Public Property TransparentColor As Color
    Get
    Set

Property Value

Type: Color
The color that will be used as a transparent mask for the top image.
Remarks
By default, this color is set to Color.Transparent and ignored. If the top image has an alpha channel, this value is ignored.
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.TransparentIndex Property

OverlayCommandTransparentIndex Property

Gets or sets the palette index that will be used as a transparent mask for the top image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TransparentIndex { get; set; }
Public Property TransparentIndex As Integer
    Get
    Set

Property Value

Type: Int32
The palette index that will be used as a transparent mask for the top image.
Exceptions
Exception | Condition
 | Thrown if the value is less than -1 or greater than 255.
Remarks
By default, this color is set to -1 and ignored. It is also ignored if the top image has an alpha channel.
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand Methods

The OverlayCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.GetObjectData Method

OverlayCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | OverlayCommand does not support serialization
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.PerformActualCommand Method

OverlayCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage bottomImage,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    bottomImage As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

bottomImage
Type: Atalasoft.ImagingAtalaImage
The bottom image.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayCommand.VerifyProperties Method

OverlayCommandVerifyProperties Method

Verifies the properties.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage bottomImage
)
Protected Overrides Sub VerifyProperties (
    bottomImage As AtalaImage
)

Parameters

bottomImage
Type: Atalasoft.ImagingAtalaImage
The bottom image.
See Also

Reference

OverlayCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Class

Overlay a specified image onto the source image using an 8-bit grayscale mask image to control the transparency of the overlay.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingOverlayMaskedCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OverlayMaskedCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class OverlayMaskedCommand
    Inherits ImageCommand
    Implements ISerializable

The OverlayMaskedCommand type exposes the following members.

Constructors
 | Name | Description
Public method | OverlayMaskedCommand | Initializes a new instance of the OverlayMaskedCommand class.
Protected method | OverlayMaskedCommand(SerializationInfo, StreamingContext) | Initializes a new instance of OverlayMaskedCommand.
Public method | OverlayMaskedCommand(AtalaImage, AtalaImage) | Initializes a new instance of %OverlayMaskedCommand% specifying the top image and alpha mask.
Public method | OverlayMaskedCommand(AtalaImage, AtalaImage, Point) | Initializes a new instance of %OverlayMaskedCommand% specifying the top image and alpha mask and position of the top image.
Top
Properties
 | Name | Description
Public property | AlphaMask | Gets or sets the 8-bit grayscale image representing the transparency mask of the overlay.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating whether the command returns a new image or modified the source image passed into the command. (Overrides ImageCommandInPlaceProcessing.)
Public property | Position | Gets or sets the position of the top image onto the source image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the image that will be overlayed onto the source image.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

If the top image already contains an alpha channel, use OverlayCommand, which will alpha blend the images automatically.

The bottom image must be a continuous format, such as 8-bit grayscale or 24-bit RGB. See OverlayMaskedDocumentCommand for masking 1-bit binary images.

This command processes the source image in-place, and ApplyToImage always returns null.

Examples
OverlayMasked (C#)
Copy
private AtalaImage OverlayImage(string bottomFile, string topFile, string maskFile)
{
    // Make sure the files exist.
    if (!File.Exists(bottomFile))
        throw new FileNotFoundException("The bottom image file could not be found.", bottomFile);

    if (!File.Exists(topFile))
        throw new FileNotFoundException("The file to overlay could not be found.", topFile);

    if (!File.Exists(maskFile))
        throw new FileNotFoundException("The mask file could not be found.", maskFile);

    // Load the bottom image.
    AtalaImage tmpImage = new AtalaImage(bottomFile);

    // Overlay does not support 4-bit bottom images.
    AtalaImage bottomImage = null;
    if (tmpImage.PixelFormat == PixelFormat.Pixel4bppIndexed)
    {
        bottomImage = tmpImage.GetChangedPixelFormat(PixelFormat.Pixel8bppIndexed);
        tmpImage.Dispose();
    }
    else
        bottomImage = tmpImage;

    // Load the top image.
    tmpImage = new AtalaImage(topFile);

    // If the bottom image is 16-bit per component, the top image must be the same.
    AtalaImage topImage = null;
    if (AtalaImage.PixelFormatIsTwoBytePerComponent(bottomImage.PixelFormat) && topImage.PixelFormat != bottomImage.PixelFormat)
    {
        topImage = tmpImage.GetChangedPixelFormat(bottomImage.PixelFormat);
        tmpImage.Dispose();
    }
    else
        topImage = tmpImage;

    // Load the mask image that will describe the alpha values.
    tmpImage = new AtalaImage(maskFile);

    // The mask must be 8-bit grayscale.
    AtalaImage mask = null;
    if (tmpImage.PixelFormat != PixelFormat.Pixel8bppGrayscale)
    {
        mask = tmpImage.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale);
        tmpImage.Dispose();
    }
    else
        mask = tmpImage;

    // The mask must also be the same size as the top image.
    if (mask.Size != topImage.Size)
    {
        ResampleCommand resample = new ResampleCommand(topImage.Size);
        tmpImage = resample.ApplyToImage(mask);
        mask.Dispose();
        mask = tmpImage;
    }

    OverlayMaskedCommand cmd = new OverlayMaskedCommand(topImage, mask);
    cmd.ApplyToImage(bottomImage);

    // We are done with the top image and mask.
    topImage.Dispose();
    mask.Dispose();

    return bottomImage;
}
OverlayMaskedVB (Visual Basic)
Copy
Private Function OverlayImage(ByVal bottomFile As String, ByVal topFile As String, ByVal maskFile As String) As AtalaImage
    ' Make sure the files exist.
    If Not File.Exists(bottomFile) Then
        Throw New FileNotFoundException("The bottom image file could not be found.", bottomFile)
    End If

    If Not File.Exists(topFile) Then
        Throw New FileNotFoundException("The file to overlay could not be found.", topFile)
    End If

    If Not File.Exists(maskFile) Then
        Throw New FileNotFoundException("The mask file could not be found.", maskFile)
    End If

    ' Load the bottom image.
    Dim tmpImage As AtalaImage =  New AtalaImage(bottomFile)

    ' Overlay does not support 4-bit bottom images.
    Dim bottomImage As AtalaImage =  Nothing
    If tmpImage.PixelFormat = PixelFormat.Pixel4bppIndexed Then
        bottomImage = tmpImage.GetChangedPixelFormat(PixelFormat.Pixel8bppIndexed)
        tmpImage.Dispose()
    Else
        bottomImage = tmpImage
    End If

    ' Load the top image.
    tmpImage = New AtalaImage(topFile)

    ' If the bottom image is 16-bit per component, the top image must be the same.
    Dim topImage As AtalaImage =  Nothing
    If AtalaImage.PixelFormatIsTwoBytePerComponent(bottomImage.PixelFormat) And topImage.PixelFormat <> bottomImage.PixelFormat Then
        topImage = tmpImage.GetChangedPixelFormat(bottomImage.PixelFormat)
        tmpImage.Dispose()
    Else
        topImage = tmpImage
    End If

    ' Load the mask image that will describe the alpha values.
    tmpImage = New AtalaImage(maskFile)

    ' The mask must be 8-bit grayscale.
    Dim mask As AtalaImage =  Nothing
    If tmpImage.PixelFormat <> PixelFormat.Pixel8bppGrayscale Then
        mask = tmpImage.GetChangedPixelFormat(PixelFormat.Pixel8bppGrayscale)
        tmpImage.Dispose()
    Else
        mask = tmpImage
    End If

    ' The mask must also be the same size as the top image.
    If mask.Size <> topImage.Size Then
        Dim resample As ResampleCommand =  New ResampleCommand(topImage.Size)
        tmpImage = resample.ApplyToImage(mask)
        mask.Dispose()
        mask = tmpImage
    End If

    Dim cmd As OverlayMaskedCommand =  New OverlayMaskedCommand(topImage,mask)
    cmd.ApplyToImage(bottomImage)

    ' We are done with the top image and mask.
    topImage.Dispose()
    mask.Dispose()

    Return bottomImage
End Function
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
OverlayCommand
OverlayMaskedCommand
OverlayMaskedDocumentCommand Class


OverlayMaskedCommand Constructor

Create an OverlayMaskedCommand object that will use a mask image to filter the image overlay.
Overload List
 | Name | Description
Public method | OverlayMaskedCommand | Initializes a new instance of the OverlayMaskedCommand class.
Protected method | OverlayMaskedCommand(SerializationInfo, StreamingContext) | Initializes a new instance of OverlayMaskedCommand.
Public method | OverlayMaskedCommand(AtalaImage, AtalaImage) | Initializes a new instance of %OverlayMaskedCommand% specifying the top image and alpha mask.
Public method | OverlayMaskedCommand(AtalaImage, AtalaImage, Point) | Initializes a new instance of %OverlayMaskedCommand% specifying the top image and alpha mask and position of the top image.
Top
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Constructor

Initializes a new instance of the OverlayMaskedCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMaskedCommand()
Public Sub New
See Also

Reference

OverlayMaskedCommand Class
OverlayMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of OverlayMaskedCommand.
Creates a new instance of OverlayCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OverlayMaskedCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

OverlayMaskedCommand Class
OverlayMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Constructor (AtalaImage, AtalaImage)

Initializes a new instance of %OverlayMaskedCommand% specifying the top image and alpha mask.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMaskedCommand(
    AtalaImage topImage,
    AtalaImage alphaMask
)
Public Sub New (
    topImage As AtalaImage,
    alphaMask As AtalaImage
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image that will be overlayed onto the source image.
alphaMask
Type: Atalasoft.ImagingAtalaImage
The 8-bit grayscale image representing the transparency of the overlay.
See Also

Reference

OverlayMaskedCommand Class
OverlayMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Constructor (AtalaImage, AtalaImage, Point)

Initializes a new instance of %OverlayMaskedCommand% specifying the top image and alpha mask and position of the top image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMaskedCommand(
    AtalaImage topImage,
    AtalaImage alphaMask,
    Point position
)
Public Sub New (
    topImage As AtalaImage,
    alphaMask As AtalaImage,
    position As Point
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image that will be overlayed onto the source image.
alphaMask
Type: Atalasoft.ImagingAtalaImage
The 8-bit grayscale image representing the transparency of the overlay.
position
Type: System.DrawingPoint
The position of the top image onto the source image.
See Also

Reference

OverlayMaskedCommand Class
OverlayMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Properties

The OverlayMaskedCommand type exposes the following members.

Properties
 | Name | Description
Public property | AlphaMask | Gets or sets the 8-bit grayscale image representing the transparency mask of the overlay.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating whether the command returns a new image or modified the source image passed into the command. (Overrides ImageCommandInPlaceProcessing.)
Public property | Position | Gets or sets the position of the top image onto the source image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the image that will be overlayed onto the source image.
Top
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.AlphaMask Property

OverlayMaskedCommandAlphaMask Property

Gets or sets the 8-bit grayscale image representing the transparency mask of the overlay.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage AlphaMask { get; set; }
Public Property AlphaMask As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The 8-bit grayscale image representing the transparency of the overlay.
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.InPlaceProcessing Property

OverlayMaskedCommandInPlaceProcessing Property

Gets a value indicating whether the command returns a new image or modified the source image passed into the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
True if the command will modify the source image passed into the ApplyToImage(AtalaImage) method.
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.Position Property

OverlayMaskedCommandPosition Property

Gets or sets the position of the top image onto the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The position of the top image onto the source image.
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.SupportedPixelFormats Property

OverlayMaskedCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.TopImage Property

OverlayMaskedCommandTopImage Property

Gets or sets the image that will be overlayed onto the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage TopImage { get; set; }
Public Property TopImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image that will be overlayed onto the source image.
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand Methods

The OverlayMaskedCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.GetObjectData Method

OverlayMaskedCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | OverlayMaskedCommand does not support serialization
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.PerformActualCommand Method

OverlayMaskedCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage bottomImage,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    bottomImage As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

bottomImage
Type: Atalasoft.ImagingAtalaImage
The bottom image.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
ArgumentException | Internal error: illegal pixel format slipped into OverlayMaskedCommand.
See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMaskedCommand.VerifyProperties Method

OverlayMaskedCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentNullException | Alpha mask is null.
ArgumentException | The alpha mask contains no image data. or The alpha mask must be the same size as the top image.
IncompatiblePixelFormatException | The top image must be Continuous. or The alpha mask must be a grayscale image.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

OverlayMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Class

Summary description for OverlayMergedCommand.

Merge two images of the same PixelFormat together specifying various merge types.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingOverlayMergedCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OverlayMergedCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class OverlayMergedCommand
    Inherits ImageCommand
    Implements ISerializable

The OverlayMergedCommand type exposes the following members.

Constructors
 | Name | Description
Public method | OverlayMergedCommand | Initializes a new instance of the OverlayMergedCommand class.
Protected method | OverlayMergedCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %OverlayMergedCommand%.
Public method | OverlayMergedCommand(AtalaImage, MergeOption) | Initializes a new instance of %OverlayMergedCommand% specifying the top image, and the merge option.
Public method | OverlayMergedCommand(AtalaImage, Point, MergeOption) | Initializes a new instance of %OverlayMergedCommand% specifying the top image, position of the image, and the merge option.
Public method | OverlayMergedCommand(AtalaImage, Point, MergeOption, Double) | Initializes a new instance of %OverlayMergedCommand% specifying the top image, position of the image, the merge option, and a factor used for some merge options.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Factor | Gets or sets the value of factor
Public property | InPlaceProcessing | Gets a value indicating whether the command returns a new image or modified the source image passed into the command. (Overrides ImageCommandInPlaceProcessing.)
Public property | MergeOption | Gets or sets the value of mergeOption
Public property | Position | Gets or sets the value of position
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the value of topImage
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException
Remarks

This functionality is especially useful when combining alpha channels with options other than the default "maximum" used in the OverlayCommand when overlaying two RGBA images.

This command processes the source image in-place, and ApplyToImage always returns null.

Examples
Overlay (C#)
Copy
// Load the images to work with.
AtalaImage bottomImage = new AtalaImage(@"D:\Test Images\1.jpg");
AtalaImage topImage = new AtalaImage(@"D:\Test Images\1save.jpg");

// Overlay the top image into the bottom image with 50% opacity.
OverlayMergedCommand cmd = new OverlayMergedCommand(topImage, Point.Empty, MergeOption.FastBlend, 0.5);
cmd.ApplyToImage(bottomImage);
OverlayVB (Visual Basic)
Copy
' Load the images to work with.
Dim bottomImage As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")
Dim topImage As AtalaImage =  New AtalaImage("D:\Test Images\1save.jpg")

' Overlay the top image into the bottom image with 50% opacity.
Dim cmd As OverlayMergedCommand =  New OverlayMergedCommand(topImage,PoInteger.Empty, MergeOption.FastBlend, 0.5)
cmd.ApplyToImage(bottomImage)
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace
OverlayCommand
OverlayMaskedCommand


OverlayMergedCommand Constructor

Create an OverlayMergedCommand that will overlay one image onto another using a merging algorithm to determine the output pixel.
Overload List
 | Name | Description
Public method | OverlayMergedCommand | Initializes a new instance of the OverlayMergedCommand class.
Protected method | OverlayMergedCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %OverlayMergedCommand%.
Public method | OverlayMergedCommand(AtalaImage, MergeOption) | Initializes a new instance of %OverlayMergedCommand% specifying the top image, and the merge option.
Public method | OverlayMergedCommand(AtalaImage, Point, MergeOption) | Initializes a new instance of %OverlayMergedCommand% specifying the top image, position of the image, and the merge option.
Public method | OverlayMergedCommand(AtalaImage, Point, MergeOption, Double) | Initializes a new instance of %OverlayMergedCommand% specifying the top image, position of the image, the merge option, and a factor used for some merge options.
Top
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Constructor

Initializes a new instance of the OverlayMergedCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMergedCommand()
Public Sub New
See Also

Reference

OverlayMergedCommand Class
OverlayMergedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of %OverlayMergedCommand%.
Creates a new instance of OverlayMergedCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OverlayMergedCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

OverlayMergedCommand Class
OverlayMergedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Constructor (AtalaImage, MergeOption)

Initializes a new instance of %OverlayMergedCommand% specifying the top image, and the merge option.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMergedCommand(
    AtalaImage topImage,
    MergeOption mergeOption
)
Public Sub New (
    topImage As AtalaImage,
    mergeOption As MergeOption
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image that will be overlayed onto the source image.
mergeOption
Type: Atalasoft.Imaging.ImageProcessingMergeOption
Specifies how the top and bottom pixels wil be merged together.
See Also

Reference

OverlayMergedCommand Class
OverlayMergedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Constructor (AtalaImage, Point, MergeOption)

Initializes a new instance of %OverlayMergedCommand% specifying the top image, position of the image, and the merge option.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMergedCommand(
    AtalaImage topImage,
    Point position,
    MergeOption mergeOption
)
Public Sub New (
    topImage As AtalaImage,
    position As Point,
    mergeOption As MergeOption
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image that will be overlayed onto the source image.
position
Type: System.DrawingPoint
The position of the top image onto the source image.
mergeOption
Type: Atalasoft.Imaging.ImageProcessingMergeOption
Specifies how the top and bottom pixels wil be merged together.
See Also

Reference

OverlayMergedCommand Class
OverlayMergedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Constructor (AtalaImage, Point, MergeOption, Double)

Initializes a new instance of %OverlayMergedCommand% specifying the top image, position of the image, the merge option, and a factor used for some merge options.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMergedCommand(
    AtalaImage topImage,
    Point position,
    MergeOption mergeOption,
    double factor
)
Public Sub New (
    topImage As AtalaImage,
    position As Point,
    mergeOption As MergeOption,
    factor As Double
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The image that will be overlayed onto the source image.
position
Type: System.DrawingPoint
The position of the top image onto the source image.
mergeOption
Type: Atalasoft.Imaging.ImageProcessingMergeOption
Specifies how the top and bottom pixels wil be merged together.
factor
Type: SystemDouble
A factor applied to some of the merge options. For example when using the Fast merge option, this value would be opacity (0 to 1).
See Also

Reference

OverlayMergedCommand Class
OverlayMergedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Properties

The OverlayMergedCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Factor | Gets or sets the value of factor
Public property | InPlaceProcessing | Gets a value indicating whether the command returns a new image or modified the source image passed into the command. (Overrides ImageCommandInPlaceProcessing.)
Public property | MergeOption | Gets or sets the value of mergeOption
Public property | Position | Gets or sets the value of position
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the value of topImage
Top
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.Factor Property

OverlayMergedCommandFactor Property

Gets or sets the value of factor
Gets or sets a factor applied to some of the merge options.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Factor { get; set; }
Public Property Factor As Double
    Get
    Set

Property Value

Type: Double
This value depends on which MergeOption is used.

Property Value

Type: Double
A factor applied to some of the merge options.
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.InPlaceProcessing Property

OverlayMergedCommandInPlaceProcessing Property

Gets a value indicating whether the command returns a new image or modified the source image passed into the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
True if the command will modify the source image passed into the ApplyToImage(AtalaImage) method.
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.MergeOption Property

OverlayMergedCommandMergeOption Property

Gets or sets the value of mergeOption
Gets or sets a value indicating how the top and bottom pixels wil be merged together.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MergeOption MergeOption { get; set; }
Public Property MergeOption As MergeOption
    Get
    Set

Property Value

Type: MergeOption
The type of process used to place the top image onto the bottom.

Property Value

Type: MergeOption
A value indicating how the top and bottom pixels wil be merged together.
Remarks
For 1-bit images, this option can only be LogicalAnd, LogicalOR, LogicalXOR, NegativeAnd, NegativeOR or NegativeXOR. NegativeAnd, NegativeOR, and NegativeXOR can only be used with 1-bit images.
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.Position Property

OverlayMergedCommandPosition Property

Gets or sets the value of position
Gets or sets the position of the top image onto the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The position where to topImage should be placed.

Property Value

Type: Point
The position of the top image onto the source image.
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.SupportedPixelFormats Property

OverlayMergedCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.TopImage Property

OverlayMergedCommandTopImage Property

Gets or sets the value of topImage
Gets or sets the image that will be overlayed onto the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage TopImage { get; set; }
Public Property TopImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image to overlay onto the source image.

Property Value

Type: AtalaImage
The image that will be overlayed onto the source image.
Exceptions
Exception | Condition
 | Thrown if the image null (Nothing in Visual Basic).
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand Methods

The OverlayMergedCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.GetObjectData Method

OverlayMergedCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | OverlayMergedCommand does not support serialization
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.PerformActualCommand Method

OverlayMergedCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


OverlayMergedCommand.VerifyProperties Method

OverlayMergedCommandVerifyProperties Method

Verifies the properties.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage sourceImage
)
Protected Overrides Sub VerifyProperties (
    sourceImage As AtalaImage
)

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
Exceptions
Exception | Condition
ArgumentException | The bottomImage and topImage must have the same bit depth. or The merge option selected can only be used with 1-bit images.
See Also

Reference

OverlayMergedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Class

This object can be passed into most ImageCommands to indicate a region of the image to process. Any shaped region can be used by specifying a Region object or a simple Rectangle.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingRegionOfInterest

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RegionOfInterest : ISerializable
<SerializableAttribute>
Public Class RegionOfInterest
    Implements ISerializable

The RegionOfInterest type exposes the following members.

Constructors
 | Name | Description
Public method | RegionOfInterest(Rectangle) | Initializes a new instance of %RegionOfInterest% specifying a simple rectangle to use as the region.
Public method | RegionOfInterest(Region) | Initializes a new instance of %RegionOfInterest% specifying a .NET Region object to use as the region.
Protected method | RegionOfInterest(SerializationInfo, StreamingContext) | Initializes a new instance of %RegionOfInterest%.
Top
Properties
 | Name | Description
Public property | Region | Gets or sets the System.Drawing.Region used to specify the portion of an image to process.
Public property | SmoothingLevel | Gets or sets the smoothing level of the region.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSimpleRegion | Returns true if the Region is a simple rectangle.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Mosaic (C#)
Copy
// Load the image to work with.
AtalaImage image = new AtalaImage(@"D:\Test Images\1save.jpg");

// Apply a mosaic effect to the middle of the image.
Rectangle rc = new Rectangle(20, 20, image.Width - 40, image.Height - 40);
MosaicCommand mos = new MosaicCommand(10);
mos.RegionOfInterest = new RegionOfInterest(rc);
mos.ApplyToImage(image);
MosaicVB (Visual Basic)
Copy
' Load the image to work with.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1save.jpg")

' Apply a mosaic effect to the middle of the image.
Dim rc As Rectangle =  New Rectangle(20,20,image.Width - 40,image.Height - 40)
Dim mos As MosaicCommand =  New MosaicCommand(10)
mos.RegionOfInterest = New RegionOfInterest(rc)
mos.ApplyToImage(image)
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Constructor

Create a RegionOfInterest used by several ImageCommands to specify the area of an image to process.
Overload List
 | Name | Description
Public method | RegionOfInterest(Rectangle) | Initializes a new instance of %RegionOfInterest% specifying a simple rectangle to use as the region.
Public method | RegionOfInterest(Region) | Initializes a new instance of %RegionOfInterest% specifying a .NET Region object to use as the region.
Protected method | RegionOfInterest(SerializationInfo, StreamingContext) | Initializes a new instance of %RegionOfInterest%.
Top
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Constructor (Rectangle)

Initializes a new instance of %RegionOfInterest% specifying a simple rectangle to use as the region.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RegionOfInterest(
    Rectangle rect
)
Public Sub New (
    rect As Rectangle
)

Parameters

rect
Type: System.DrawingRectangle

The rectangular area of the image to process.

Exceptions
Exception | Condition
 | Thrown if the current license is not DotImage Photo Pro or Document Imaging.
See Also

Reference

RegionOfInterest Class
RegionOfInterest Overload
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Constructor (Region)

Initializes a new instance of %RegionOfInterest% specifying a .NET Region object to use as the region.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RegionOfInterest(
    Region region
)
Public Sub New (
    region As Region
)

Parameters

region
Type: System.DrawingRegion
The Region used to specify the portion of an image to process.
Exceptions
Exception | Condition
 | Thrown if the current license is not DotImage Photo Pro or Document Imaging.
See Also

Reference

RegionOfInterest Class
RegionOfInterest Overload
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of %RegionOfInterest%.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RegionOfInterest(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
Exceptions
Exception | Condition
 | Thrown if the current license is not DotImage Photo Pro or Document Imaging.
 | Thrown if the current license is not DotImage Photo Pro or Document Imaging.
See Also

Reference

RegionOfInterest Class
RegionOfInterest Overload
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Properties

The RegionOfInterest type exposes the following members.

Properties
 | Name | Description
Public property | Region | Gets or sets the System.Drawing.Region used to specify the portion of an image to process.
Public property | SmoothingLevel | Gets or sets the smoothing level of the region.
Top
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest.Region Property

RegionOfInterestRegion Property

Gets or sets the System.Drawing.Region used to specify the portion of an image to process.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Region Region { get; }
Public ReadOnly Property Region As Region
    Get

Property Value

Type: Region
The Region used to specify the portion of an image to process.
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest.SmoothingLevel Property

RegionOfInterestSmoothingLevel Property

Gets or sets the smoothing level of the region.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SmoothingLevel { get; set; }
Public Property SmoothingLevel As Double
    Get
    Set

Property Value

Type: Double
the smoothing level of the region.
Exceptions
Exception | Condition
 | Thrown is the value is less than 0.
Remarks
By default this is 0. Can be any value greater than 0, and is the standard deviation of the gaussian kernel.
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest Methods

The RegionOfInterest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSimpleRegion | Returns true if the Region is a simple rectangle.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest.Equals Method

RegionOfInterestEquals Method

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest.GetHashCode Method

RegionOfInterestGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest.GetObjectData Method

RegionOfInterestGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


RegionOfInterest.IsSimpleRegion Method

RegionOfInterestIsSimpleRegion Method

Returns true if the Region is a simple rectangle.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSimpleRegion()
Public Function IsSimpleRegion As Boolean

Return Value

Type: Boolean
true if the Region is a simple rectangle.
See Also

Reference

RegionOfInterest Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Class

Summary description for ResampleColormappedToRgbCommand.
Resamples the source 8-bit colormapped image to a 24-bit RGB to a specified size.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingResampleColormappedToRgbCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ResampleColormappedToRgbCommand : ImageCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class ResampleColormappedToRgbCommand
    Inherits ImageCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The ResampleColormappedToRgbCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ResampleColormappedToRgbCommand | Initializes a new instance of the ResampleColormappedToRgbCommand class.
Public method | ResampleColormappedToRgbCommand(Size) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and using the the default resampling method.
Public method | ResampleColormappedToRgbCommand(Int32) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the maximum width or height using the defailt resampling method.
Public method | ResampleColormappedToRgbCommand(Size, ResampleMethod) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and resampling method.
Public method | ResampleColormappedToRgbCommand(Int32, ResampleMethod) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and resampling method.
Protected method | ResampleColormappedToRgbCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the source rectangle, destination size, and resampling method.
Public method | ResampleColormappedToRgbCommand(Rectangle, Size, ResampleMethod) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the source rectangle, destination size, and resampling method.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestSize | Gets or sets the value of destSize
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxSize | Gets or sets the maximum width or height value for resizing while maintaining the aspect ratio.
Public property | Method | Gets or sets the value of method
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceRect | Gets or sets the value of sourceRect
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
Remarks
This command is used when viewing a colormapped image in the controls when Antialiasing. It will smooth the lines and create better displays of colormapped images by efficiently converting the image from 8-bit colormapped to 24-bit RGB while it's resampling.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor

Create a ResampleColormappedToRgbCommand that will resize an indexed image directly to a 24-bit image.
Overload List
 | Name | Description
Public method | ResampleColormappedToRgbCommand | Initializes a new instance of the ResampleColormappedToRgbCommand class.
Public method | ResampleColormappedToRgbCommand(Size) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and using the the default resampling method.
Public method | ResampleColormappedToRgbCommand(Int32) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the maximum width or height using the defailt resampling method.
Public method | ResampleColormappedToRgbCommand(Size, ResampleMethod) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and resampling method.
Public method | ResampleColormappedToRgbCommand(Int32, ResampleMethod) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and resampling method.
Protected method | ResampleColormappedToRgbCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the source rectangle, destination size, and resampling method.
Public method | ResampleColormappedToRgbCommand(Rectangle, Size, ResampleMethod) | Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the source rectangle, destination size, and resampling method.
Top
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor

Initializes a new instance of the ResampleColormappedToRgbCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleColormappedToRgbCommand()
Public Sub New
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor (Size)

Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and using the the default resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleColormappedToRgbCommand(
    Size destSize
)
Public Sub New (
    destSize As Size
)

Parameters

destSize
Type: System.DrawingSize
The final size of the image.
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor (Int32)

Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the maximum width or height using the defailt resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleColormappedToRgbCommand(
    int maxSize
)
Public Sub New (
    maxSize As Integer
)

Parameters

maxSize
Type: SystemInt32
The maximum width or height of the final image while maintaining the aspect ratio.
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor (Size, ResampleMethod)

Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleColormappedToRgbCommand(
    Size destSize,
    ResampleMethod method
)
Public Sub New (
    destSize As Size,
    method As ResampleMethod
)

Parameters

destSize
Type: System.DrawingSize
The final size of the image.
method
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The resampling algorithm to apply.
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor (Int32, ResampleMethod)

Initializes a new instance of %ResampleColormappedToRgbCommand% specifying final size and resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleColormappedToRgbCommand(
    int maxSize,
    ResampleMethod method
)
Public Sub New (
    maxSize As Integer,
    method As ResampleMethod
)

Parameters

maxSize
Type: SystemInt32
The maximum width or height of the final image while maintaining the aspect ratio.
method
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The resampling algorithm to apply.
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the source rectangle, destination size, and resampling method.
Creates a new instance of ResampleColormappedToRgbCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ResampleColormappedToRgbCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Constructor (Rectangle, Size, ResampleMethod)

Initializes a new instance of %ResampleColormappedToRgbCommand% specifying the source rectangle, destination size, and resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleColormappedToRgbCommand(
    Rectangle sourceRect,
    Size destSize,
    ResampleMethod method
)
Public Sub New (
    sourceRect As Rectangle,
    destSize As Size,
    method As ResampleMethod
)

Parameters

sourceRect
Type: System.DrawingRectangle
The rectangular region of the source image that will be resized.
destSize
Type: System.DrawingSize
The final size of the image.
method
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The resampling algorithm to apply.
See Also

Reference

ResampleColormappedToRgbCommand Class
ResampleColormappedToRgbCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Properties

The ResampleColormappedToRgbCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestSize | Gets or sets the value of destSize
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxSize | Gets or sets the maximum width or height value for resizing while maintaining the aspect ratio.
Public property | Method | Gets or sets the value of method
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceRect | Gets or sets the value of sourceRect
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.AutoThread Property

ResampleColormappedToRgbCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.DestSize Property

ResampleColormappedToRgbCommandDestSize Property

Gets or sets the value of destSize
Gets or sets the final width and height of the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DestSize { get; set; }
Public Property DestSize As Size
    Get
    Set

Property Value

Type: Size
The final size of the image.

Property Value

Type: Size
The final size of the image.
Exceptions
Exception | Condition
 | Thrown when the width or height is less than or equal to 0.
Remarks
Ignored when the MaxSize property is set to a value greater than 0.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.MaxSize Property

ResampleColormappedToRgbCommandMaxSize Property

Gets or sets the maximum width or height value for resizing while maintaining the aspect ratio.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxSize { get; set; }
Public Property MaxSize As Integer
    Get
    Set

Property Value

Type: Int32
The width of height value for resizing while maintaining the aspect ratio.
Exceptions
Exception | Condition
 | Thrown if the value is less than 0.
Remarks
When this value is 0 (the default), it is ignored and DestSize is used instead. Use this value to automatically calculate the new width and height, keeping the same aspect ratio as the original image.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.Method Property

ResampleColormappedToRgbCommandMethod Property

Gets or sets the value of method
Gets or sets the resampling algorithm to apply.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMethod Method { get; set; }
Public Property Method As ResampleMethod
    Get
    Set

Property Value

Type: ResampleMethod
The resampling algorithn to apply.

Property Value

Type: ResampleMethod
The resampling algorithn to apply.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.SourceRect Property

ResampleColormappedToRgbCommandSourceRect Property

Gets or sets the value of sourceRect
Gets or sets the rectangular region of the source image that will be resized.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SourceRect { get; set; }
Public Property SourceRect As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular region of the source image that will be resized.

Property Value

Type: Rectangle
The rectangular region of the source image that will be resized.
Remarks
The default value is Rectangle.Empty, in which case the entire image is resized.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.SupportedPixelFormats Property

ResampleColormappedToRgbCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand Methods

The ResampleColormappedToRgbCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.AdjustBands Method

ResampleColormappedToRgbCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.Clone Method

ResampleColormappedToRgbCommandClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.ConstructFinalImage Method

ResampleColormappedToRgbCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.GetObjectData Method

ResampleColormappedToRgbCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.PerformActualCommand Method

ResampleColormappedToRgbCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dstImage,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dstImage As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
dstImage
Type: Atalasoft.ImagingAtalaImage
The DST image.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.PerformSectionCommand Method

ResampleColormappedToRgbCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleColormappedToRgbCommand.VerifyProperties Method

ResampleColormappedToRgbCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | Cannot perform AreaAverage resize method when increasing the size of the image, use default instead or The requested MaxSize cannot be used because it would result in a zero length width or height.;MaxSize or AreaAverage requires the destination image to be the same size or smaller than the source image. or Invalid resize method;method
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ResampleColormappedToRgbCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Class

Summary description for ResampleCommand.
Resamples the source image to the specified dimensions.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingResampleCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ResampleCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ResampleCommand
    Inherits ImageCommand
    Implements ISerializable

The ResampleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ResampleCommand | Initializes a new instance of the ResampleCommand class.
Public method | ResampleCommand(Size) | Creates a new instance of ResampleCommand specifying final size and using the default resampling method.
Public method | ResampleCommand(Int32) | Creates a new instance of ResampleCommand specifying the maximum width or height and resampling method.
Public method | ResampleCommand(Size, ResampleMethod) | Creates a new instance of ResampleCommand specifying final size and resampling method.
Public method | ResampleCommand(Int32, ResampleMethod) | Creates a new instance of ResampleCommand specifying final size and resampling method.
Protected method | ResampleCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %ResampleCommand%.
Public method | ResampleCommand(Rectangle, Size, ResampleMethod) | Creates a new instance of ResampleCommand specifying sourceRect, destSize, and method.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestSize | Gets or sets the value of destSize
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxSize | Gets or sets the width of height value for resizing while maintaining the aspect ratio.
Public property | Method | Gets or sets the value of method
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceRect | Gets or sets the value of sourceRect
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
Remarks
This object is capable of resampling continuous and 8-bit colormapped images. For resizing 1-bit document images see %Atalasoft.Imaging.ImageProcessing.Document.ResampleDocumentCommand%.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor

Create a ResampleCommand used to resize AtalaImage objects.
Overload List
 | Name | Description
Public method | ResampleCommand | Initializes a new instance of the ResampleCommand class.
Public method | ResampleCommand(Size) | Creates a new instance of ResampleCommand specifying final size and using the default resampling method.
Public method | ResampleCommand(Int32) | Creates a new instance of ResampleCommand specifying the maximum width or height and resampling method.
Public method | ResampleCommand(Size, ResampleMethod) | Creates a new instance of ResampleCommand specifying final size and resampling method.
Public method | ResampleCommand(Int32, ResampleMethod) | Creates a new instance of ResampleCommand specifying final size and resampling method.
Protected method | ResampleCommand(SerializationInfo, StreamingContext) | Initializes a new instance of %ResampleCommand%.
Public method | ResampleCommand(Rectangle, Size, ResampleMethod) | Creates a new instance of ResampleCommand specifying sourceRect, destSize, and method.
Top
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor

Initializes a new instance of the ResampleCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleCommand()
Public Sub New
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor (Size)

Creates a new instance of ResampleCommand specifying final size and using the default resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleCommand(
    Size destSize
)
Public Sub New (
    destSize As Size
)

Parameters

destSize
Type: System.DrawingSize
The final size of the image.
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor (Int32)

Creates a new instance of ResampleCommand specifying the maximum width or height and resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleCommand(
    int maxSize
)
Public Sub New (
    maxSize As Integer
)

Parameters

maxSize
Type: SystemInt32
The maximum width or height of the final image while maintaining the aspect ratio.
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor (Size, ResampleMethod)

Creates a new instance of ResampleCommand specifying final size and resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleCommand(
    Size destSize,
    ResampleMethod method
)
Public Sub New (
    destSize As Size,
    method As ResampleMethod
)

Parameters

destSize
Type: System.DrawingSize
The final size of the image.
method
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The resampling algorithm to apply.
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor (Int32, ResampleMethod)

Creates a new instance of ResampleCommand specifying final size and resampling method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleCommand(
    int maxSize,
    ResampleMethod method
)
Public Sub New (
    maxSize As Integer,
    method As ResampleMethod
)

Parameters

maxSize
Type: SystemInt32
The maximum width or height of the final image while maintaining the aspect ratio.
method
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The resampling algorithm to apply.
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of %ResampleCommand%.
Creates a new instance of ResampleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ResampleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Constructor (Rectangle, Size, ResampleMethod)

Creates a new instance of ResampleCommand specifying sourceRect, destSize, and method.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleCommand(
    Rectangle sourceRect,
    Size destSize,
    ResampleMethod method
)
Public Sub New (
    sourceRect As Rectangle,
    destSize As Size,
    method As ResampleMethod
)

Parameters

sourceRect
Type: System.DrawingRectangle
The rectangular region of the source image that will be resized.
destSize
Type: System.DrawingSize
The final size of the image.
method
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The resampling algorithm to apply.
See Also

Reference

ResampleCommand Class
ResampleCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Properties

The ResampleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestSize | Gets or sets the value of destSize
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxSize | Gets or sets the width of height value for resizing while maintaining the aspect ratio.
Public property | Method | Gets or sets the value of method
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceRect | Gets or sets the value of sourceRect
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.DestSize Property

ResampleCommandDestSize Property

Gets or sets the value of destSize
Gets or sets the final size of the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DestSize { get; set; }
Public Property DestSize As Size
    Get
    Set

Property Value

Type: Size
The final size of the image.

Property Value

Type: Size
The final size of the image.
Exceptions
Exception | Condition
 | Thrown if either value.width or value.height is amp;lt; 1.
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.MaxSize Property

ResampleCommandMaxSize Property

Gets or sets the width of height value for resizing while maintaining the aspect ratio.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxSize { get; set; }
Public Property MaxSize As Integer
    Get
    Set

Property Value

Type: Int32
The width of height value for resizing while maintaining the aspect ratio.
Exceptions
Exception | Condition
 | Thrown if value is amp;lt; 1.
Remarks
When this value is 0, it is ignored.
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.Method Property

ResampleCommandMethod Property

Gets or sets the value of method
Gets or sets the the resampling algorithm to apply.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMethod Method { get; set; }
Public Property Method As ResampleMethod
    Get
    Set

Property Value

Type: ResampleMethod
The resampling algorithn to apply.

Property Value

Type: ResampleMethod
The resampling algorithm to apply.
Exceptions
Exception | Condition
 | Thrown if value is amp;lt; 0.
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.SourceRect Property

ResampleCommandSourceRect Property

Gets or sets the value of sourceRect
Gets or sets the rectangular region of the source image that will be resized.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SourceRect { get; set; }
Public Property SourceRect As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular region of the source image that will be resized.

Property Value

Type: Rectangle
The rectangular region of the source image that will be resized.
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.SupportedPixelFormats Property

ResampleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand Methods

The ResampleCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.ConstructFinalImage Method

ResampleCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.GetObjectData Method

ResampleCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.PerformActualCommand Method

ResampleCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
NotSupportedException | ResampleCommand method mismatch. Please report to support if you see this message.
IncompatiblePixelFormatException | AreaAverage can't be used with the + image.PixelFormat.ToString() + pixel format. or Filter resampling not supported in 16-bit per component images.
See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.SelectPreferredPixelFormat Method

ResampleCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleCommand.VerifyProperties Method

ResampleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | Cannot perform AreaAverage resize method when increasing the size of the image, use default instead or The requested MaxSize cannot be used because it would result in a zero length width or height.;MaxSize
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ResampleCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Class

Summary description for ResampleMaskedCommand.
Resample an 8 bit image honoring one color value as a mask.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingResampleMaskedCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResampleMaskedCommand : ImageCommand,
    ISerializable
Public Class ResampleMaskedCommand
    Inherits ImageCommand
    Implements ISerializable

The ResampleMaskedCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ResampleMaskedCommand | Initializes a new instance of the ResampleMaskedCommand class.
Public method | ResampleMaskedCommand(Size, Int32) | Construct a new ResampleMaskedCommand with the provided destination size and mask index.
Public method | ResampleMaskedCommand(Int32, Int32) | Construct a new ResampleMaskedCommand with the provided size and mask index.
Protected method | ResampleMaskedCommand(SerializationInfo, StreamingContext) | Construct a new ResampleMaskedCommand with default properties.
Public method | ResampleMaskedCommand(Rectangle, Size, Int32) | Construct a new ResampleMaskedCommand with the provided source rectangle, destination size, and mask index.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestSize | Sets or gets the destination size of the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaskIndex | Gets or sets the index of the color of the mask.
Public property | MaxSize | Sets or gets the maximum dimension of the final image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceRect | Sets or gets the area to be resampled.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Constructor

Construct a new ResampleMaskedCommand with the provided information.
Overload List
 | Name | Description
Public method | ResampleMaskedCommand | Initializes a new instance of the ResampleMaskedCommand class.
Public method | ResampleMaskedCommand(Size, Int32) | Construct a new ResampleMaskedCommand with the provided destination size and mask index.
Public method | ResampleMaskedCommand(Int32, Int32) | Construct a new ResampleMaskedCommand with the provided size and mask index.
Protected method | ResampleMaskedCommand(SerializationInfo, StreamingContext) | Construct a new ResampleMaskedCommand with default properties.
Public method | ResampleMaskedCommand(Rectangle, Size, Int32) | Construct a new ResampleMaskedCommand with the provided source rectangle, destination size, and mask index.
Top
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Constructor

Initializes a new instance of the ResampleMaskedCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMaskedCommand()
Public Sub New
See Also

Reference

ResampleMaskedCommand Class
ResampleMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Constructor (Size, Int32)

Construct a new ResampleMaskedCommand with the provided destination size and mask index.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMaskedCommand(
    Size destSize,
    int maskIndex
)
Public Sub New (
    destSize As Size,
    maskIndex As Integer
)

Parameters

destSize
Type: System.DrawingSize
In color index to treat as a mask.
maskIndex
Type: SystemInt32
In color index to treat as a mask.
See Also

Reference

ResampleMaskedCommand Class
ResampleMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Constructor (Int32, Int32)

Construct a new ResampleMaskedCommand with the provided size and mask index.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMaskedCommand(
    int maxSize,
    int maskIndex
)
Public Sub New (
    maxSize As Integer,
    maskIndex As Integer
)

Parameters

maxSize
Type: SystemInt32
The maximum size for either dimension of the final image.
maskIndex
Type: SystemInt32
In color index to treat as a mask.
See Also

Reference

ResampleMaskedCommand Class
ResampleMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Constructor (SerializationInfo, StreamingContext)

Construct a new ResampleMaskedCommand with default properties.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ResampleMaskedCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ResampleMaskedCommand Class
ResampleMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Constructor (Rectangle, Size, Int32)

Construct a new ResampleMaskedCommand with the provided source rectangle, destination size, and mask index.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMaskedCommand(
    Rectangle sourceRect,
    Size destSize,
    int maskIndex
)
Public Sub New (
    sourceRect As Rectangle,
    destSize As Size,
    maskIndex As Integer
)

Parameters

sourceRect
Type: System.DrawingRectangle
The rectangle describing the pixels to resample.
destSize
Type: System.DrawingSize
In color index to treat as a mask.
maskIndex
Type: SystemInt32
In color index to treat as a mask.
See Also

Reference

ResampleMaskedCommand Class
ResampleMaskedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Properties

The ResampleMaskedCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestSize | Sets or gets the destination size of the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaskIndex | Gets or sets the index of the color of the mask.
Public property | MaxSize | Sets or gets the maximum dimension of the final image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceRect | Sets or gets the area to be resampled.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.DestSize Property

ResampleMaskedCommandDestSize Property

Sets or gets the destination size of the image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DestSize { get; set; }
Public Property DestSize As Size
    Get
    Set

Property Value

Type: Size
Exceptions
Exception | Condition
 | Thrown if the width or height is less than 1.
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.MaskIndex Property

ResampleMaskedCommandMaskIndex Property

Gets or sets the index of the color of the mask.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaskIndex { get; set; }
Public Property MaskIndex As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Thrown if the value is less than zero or greater than 255.
Remarks
MaskIndex must be a value between 0 and 255.
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.MaxSize Property

ResampleMaskedCommandMaxSize Property

Sets or gets the maximum dimension of the final image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxSize { get; set; }
Public Property MaxSize As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Thrown if the value is less than 1.
Remarks
MaxSize must be greater than zero.
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.SourceRect Property

ResampleMaskedCommandSourceRect Property

Sets or gets the area to be resampled.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SourceRect { get; set; }
Public Property SourceRect As Rectangle
    Get
    Set

Property Value

Type: Rectangle
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.SupportedPixelFormats Property

ResampleMaskedCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand Methods

The ResampleMaskedCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.ConstructFinalImage Method

ResampleMaskedCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.GetObjectData Method

ResampleMaskedCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.PerformActualCommand Method

ResampleMaskedCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dstImage,
    Rectangle area,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dstImage As AtalaImage,
    area As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
dstImage
Type: Atalasoft.ImagingAtalaImage
The DST image.
area
Type: System.DrawingRectangle
The area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMaskedCommand.VerifyProperties Method

ResampleMaskedCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | ResampleMaskedCommand can only be used with 8-bit indexed images.;sourceImage or The requested MaxSize cannot be used because it would result in a zero length width or height.;sourceImage
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ResampleMaskedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ResampleMethod Enumeration

Specifies the type of resampling method to apply when using the %ResampleCommand%, %ResampleColormappedToRgbCommand% or the %Atalasoft.Imaging.ImageProcessing.Document.ResampleDocumentCommand%.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResampleMethod
Public Enumeration ResampleMethod
Members
Member name | Description
Default | Uses a predefined resampling method depending on the image PixelFormat and final size. Uses Nearest Neighbor resampling for 1-bit and 8-bit colormapped images, BiLinear when increasing the size of continuous tone images. and AreaAverage when reducing continuous tone images.
NearestNeighbor | Use the nearest pixel value. This is the fastest algorithm.
BiLinear | Uses bi-linear resampling. Yields good results when enlarging images, and fairly fast.
BiCubic | Uses bi-cubic interpolation. Better quality then bi-linear but slower.
AreaAverage | Average the pixel values when reducing image size. Will cause an exception to be thrown if increasing image size.
BoxFilter | BoxFilter resize algorithm.
TriangleFilter | TriangleFilter resize algorithm.
HammingFilter | HammingFilter resize algorithm.
GaussianFilter | GaussianFilter resize algorithm.
BellFilter | BellFilter resize algorithm.
BsplineFilter | BsplineFilter resize algorithm.
Cubic1Filter | CubicFilter resize algorithm.
Cubic2Filter | Cubic2Filter resize algorithm.
LanczosFilter | Generally yields the best results for photographic images at the expense of speed. Very similar to Photoshop's Bi-cubic reductions.
MitchellFilter | MitchellFilter resize algorithm.
SincFilter | SincFilter resize algorithm.
HermiteFilter | HermiteFilter resize algorithm.
HanningFilter | HanningFilter resize algorithm.
CatromFilter | CatromFilter resize algorithm.
See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Class

ThreadedCommand is a proxy command that will induce ImageCommands that support multithreading to run in on multiple threads.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingThreadedCommand

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThreadedCommand : ImageCommand
Public Class ThreadedCommand
    Inherits ImageCommand

The ThreadedCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadedCommand | Initializes a new instance of the ThreadedCommand class
Public method | ThreadedCommand(ImageCommand) | Initializes a new instance of the ThreadedCommand class
Public method | ThreadedCommand(ImageCommand, Int32) | Initializes a new instance of the ThreadedCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Sets or gets the value of AppyToAnyPixelFormat in the underlying command. (Overrides ImageCommandApplyToAnyPixelFormat.)
Public property | CanApplyToAnyPixelFormat | Returns the value of CanApplyToAnyPixelFormat in the underlying command. (Overrides ImageCommandCanApplyToAnyPixelFormat.)
Public property | Command | Sets or gets the underlying command that will be multithreaded.
Public property | InPlaceProcessing | Returns the InPlaceProcessing value of the underlying command. (Overrides ImageCommandInPlaceProcessing.)
 | OptimalThreadCount | Returns the best number of threads to use for the current system.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | StripSize | Gets or sets the size of strips that will be processed by individual threads.
Public property | SupportedPixelFormats | Returns the value of SupportedPixelFormats of the underlying command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | ThreadCount | The total number of threads that will be used for this command.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Overrides ImageCommandGetChangedPixelFormat(AtalaImage, PixelFormat).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Overrides ImageCommandIsPixelFormatSupported(PixelFormat).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Overrides ImageCommandSelectBestAlternatePixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Fields
 | Name | Description
Protected field | MinimumStripSizeInBytes | The minimum strip size in bytes
Top
Remarks

Only ImageCommands that implement the IThreadableCommand and ICloneable interfaces can be used with ThreadedCommand. ThreadedCommand manages all thread creation and synchronization, proxy management of ImageCommand operations and so on.

Once a ThreadedCommand has been created and given a valid ImageCommand, it can be used any place that ImageCommand can be used.

See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Constructor

Constructs a new ThreadedCommand.
Overload List
 | Name | Description
Public method | ThreadedCommand | Initializes a new instance of the ThreadedCommand class
Public method | ThreadedCommand(ImageCommand) | Initializes a new instance of the ThreadedCommand class
Public method | ThreadedCommand(ImageCommand, Int32) | Initializes a new instance of the ThreadedCommand class
Top
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Constructor

Initializes a new instance of the ThreadedCommand class

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThreadedCommand()
Public Sub New
Remarks
ThreadedCommand is not an image processing command itself. It applies multithreading to other commands that support multithreading.
See Also

Reference

ThreadedCommand Class
ThreadedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Constructor (ImageCommand)

Initializes a new instance of the ThreadedCommand class

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThreadedCommand(
    ImageCommand command
)
Public Sub New (
    command As ImageCommand
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The image command to perform in a multithreaded manner.
See Also

Reference

ThreadedCommand Class
ThreadedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Constructor (ImageCommand, Int32)

Initializes a new instance of the ThreadedCommand class

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThreadedCommand(
    ImageCommand command,
    int threadCount
)
Public Sub New (
    command As ImageCommand,
    threadCount As Integer
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The image command to perform in a multithreaded manner.
threadCount
Type: SystemInt32
The total number of threads to use for this command.
See Also

Reference

ThreadedCommand Class
ThreadedCommand Overload
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Properties

The ThreadedCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Sets or gets the value of AppyToAnyPixelFormat in the underlying command. (Overrides ImageCommandApplyToAnyPixelFormat.)
Public property | CanApplyToAnyPixelFormat | Returns the value of CanApplyToAnyPixelFormat in the underlying command. (Overrides ImageCommandCanApplyToAnyPixelFormat.)
Public property | Command | Sets or gets the underlying command that will be multithreaded.
Public property | InPlaceProcessing | Returns the InPlaceProcessing value of the underlying command. (Overrides ImageCommandInPlaceProcessing.)
 | OptimalThreadCount | Returns the best number of threads to use for the current system.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | StripSize | Gets or sets the size of strips that will be processed by individual threads.
Public property | SupportedPixelFormats | Returns the value of SupportedPixelFormats of the underlying command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | ThreadCount | The total number of threads that will be used for this command.
Top
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.ApplyToAnyPixelFormat Property

ThreadedCommandApplyToAnyPixelFormat Property

Sets or gets the value of AppyToAnyPixelFormat in the underlying command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool ApplyToAnyPixelFormat { get; set; }
Public Overrides Property ApplyToAnyPixelFormat As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.CanApplyToAnyPixelFormat Property

ThreadedCommandCanApplyToAnyPixelFormat Property

Returns the value of CanApplyToAnyPixelFormat in the underlying command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanApplyToAnyPixelFormat { get; }
Public Overrides ReadOnly Property CanApplyToAnyPixelFormat As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.Command Property

ThreadedCommandCommand Property

Sets or gets the underlying command that will be multithreaded.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCommand Command { get; set; }
Public Property Command As ImageCommand
    Get
    Set

Property Value

Type: ImageCommand
Remarks
In addition to being an ImageCommand, the given command must implement the IThreadableCommand and ICloneable interfaces.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.InPlaceProcessing Property

ThreadedCommandInPlaceProcessing Property

Returns the InPlaceProcessing value of the underlying command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.OptimalThreadCount Property

ThreadedCommandOptimalThreadCount Property

Returns the best number of threads to use for the current system.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int OptimalThreadCount { get; }
Public Shared ReadOnly Property OptimalThreadCount As Integer
    Get

Property Value

Type: Int32
Remarks
This is typically the number of CPUs available times two. The number of CPUs is not always the number of physical CPUs chips in the computer. For example, a computer with two dual core CPUs may report 8 for its OptimalThreadCount. Other variables like hyperthreading will affect the final count.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.StripSize Property

ThreadedCommandStripSize Property

Gets or sets the size of strips that will be processed by individual threads.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int StripSize { get; set; }
Public Property StripSize As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
If this value is -1, ThreadedCommand will calculate the optimal size for you.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.SupportedPixelFormats Property

ThreadedCommandSupportedPixelFormats Property

Returns the value of SupportedPixelFormats of the underlying command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.ThreadCount Property

ThreadedCommandThreadCount Property

The total number of threads that will be used for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ThreadCount { get; set; }
Public Property ThreadCount As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
By default, this is initialized to ThreadedCommand.OptimalThreadCount.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Methods

The ThreadedCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Overrides ImageCommandGetChangedPixelFormat(AtalaImage, PixelFormat).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Overrides ImageCommandIsPixelFormatSupported(PixelFormat).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Overrides ImageCommandSelectBestAlternatePixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.ConstructChangedSourceImage Method

ThreadedCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.ConstructFinalImage Method

ThreadedCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.ConstructImageResults Method

ThreadedCommandConstructImageResults Method

Constructs the results object for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageResults ConstructImageResults()
Protected Overrides Function ConstructImageResults As ImageResults

Return Value

Type: ImageResults
A new object of type ImageResults representing the results for this command.
Remarks

The default implementation returns an object of type ImageResults. If your command requires an object with more information, subclass ImageResults and add in the information you need. Your command will override ConstructImageResults and return your new object.

The object allocated here is passed to PerformActualCommand as a reference parameter, meaning the entire object can be changed at that point too.

See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.GetChangedPixelFormat Method

ThreadedCommandGetChangedPixelFormat Method

This method is called to change the pixel format of the source image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage GetChangedPixelFormat(
    AtalaImage sourceImage,
    PixelFormat newFormat
)
Protected Overrides Function GetChangedPixelFormat (
    sourceImage As AtalaImage,
    newFormat As PixelFormat
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
newFormat
Type: Atalasoft.ImagingPixelFormat
The new pixel format.

Return Value

Type: AtalaImage
A new image in the new pixel format, with image data translated from the source image.
Remarks
The default implementation uses the built-in AtalaImage.GetChangedPixelFormat method, which in turn uses the PixelFormatChanger installed in AtalaImage. By overriding this method, you can bypass the built-in pixel format translation and supply your own and isolate it to an individual command.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.IsPixelFormatSupported Method

ThreadedCommandIsPixelFormatSupported Method

Returns a value indicating if the specified pixel format is supported.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsPixelFormatSupported(
    PixelFormat format
)
Public Overrides Function IsPixelFormatSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat
The pixel format to query.

Return Value

Type: Boolean
Remarks
All derived commands must override this property.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace
SupportedPixelFormats Property


ThreadedCommand.PerformActualCommand Method

ThreadedCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ImageProcessException | ThreadedCommands can't be embedded in themselves.
ArgumentNullException | source;cannot process a null image.
ArgumentOutOfRangeException | adjustedBands;an image cannot be processed with zero bands
Exception |
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.SelectBestAlternatePixelFormat Method

ThreadedCommandSelectBestAlternatePixelFormat Method

Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectBestAlternatePixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectBestAlternatePixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image to be processed.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The source image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
The pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format for the command. This new pixel format must be one of the pixel formats in the supported pixel formats.
Remarks
The default implementation returns the 0th element of the formats array.
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.SelectPreferredPixelFormat Method

ThreadedCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.VerifyProperties Method

ThreadedCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand Fields

The ThreadedCommand type exposes the following members.

Fields
 | Name | Description
Protected field | MinimumStripSizeInBytes | The minimum strip size in bytes
Top
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


ThreadedCommand.MinimumStripSizeInBytes Field

ThreadedCommandMinimumStripSizeInBytes Field

The minimum strip size in bytes

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int MinimumStripSizeInBytes
Protected MinimumStripSizeInBytes As Integer

Field Value

Type: Int32
See Also

Reference

ThreadedCommand Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail Class

Summary description for Thumbnail.
Creates a high speed and high quality thumbnail image from a source file.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingThumbnail

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Thumbnail
Public Class Thumbnail

The Thumbnail type exposes the following members.

Constructors
 | Name | Description
Public method | Thumbnail | Constructs a new Thumbnail object with default properties.
Public method | Thumbnail(Size) | Constructs a new Thumbnail object with the provided size.
Top
Properties
 | Name | Description
Public property | AllowEnlarge | Gets or sets a value indicating whether [allow enlarge].
Public property | Size | Gets or sets the maximum X and Y dimensions of the thumbnail to be created.
Public property | ThrowOnZeroDimensions | Gets or sets a value that will thrown an exception if the resized image ends up with zero dimensions.
Top
Methods
 | Name | Description
Public method | Create(AtalaImage) | Creates a new thumbnail image from the supplied image.
Public method | Create(Stream, Int32) | Creates a new thumbnail image from the supplied stream and frame index.
Public method | Create(String, Int32) | Creates a new thumbnail image from the supplied file and frame index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

This class uses optimized image decoding and scaling to create a high quality thumbnail from a source image. It will used scaled loading when the source file is a JPEG, utilize scale to gray resampling when the source image is 1-bit with a document imaging license, and use area average otherwise.

This class can be conveniently used to generate thumbnail preview images.

note: when using DotImage Photo or Photo Pro, making a thumbnail out of a 1-bit image will take much more memory and be less efficient as it will convert to grayscale first, then resample the image.

See Also

Reference

Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail Constructor

Constructs a new Thumbnail object.
Overload List
 | Name | Description
Public method | Thumbnail | Constructs a new Thumbnail object with default properties.
Public method | Thumbnail(Size) | Constructs a new Thumbnail object with the provided size.
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail Constructor

Constructs a new Thumbnail object with default properties.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail()
Public Sub New
See Also

Reference

Thumbnail Class
Thumbnail Overload
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail Constructor (Size)

Constructs a new Thumbnail object with the provided size.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail(
    Size size
)
Public Sub New (
    size As Size
)

Parameters

size
Type: System.DrawingSize
See Also

Reference

Thumbnail Class
Thumbnail Overload
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail Properties

The Thumbnail type exposes the following members.

Properties
 | Name | Description
Public property | AllowEnlarge | Gets or sets a value indicating whether [allow enlarge].
Public property | Size | Gets or sets the maximum X and Y dimensions of the thumbnail to be created.
Public property | ThrowOnZeroDimensions | Gets or sets a value that will thrown an exception if the resized image ends up with zero dimensions.
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.AllowEnlarge Property

ThumbnailAllowEnlarge Property

Gets or sets a value indicating whether [allow enlarge].

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowEnlarge { get; set; }
Public Property AllowEnlarge As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [allow enlarge]; otherwise, false.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.Size Property

ThumbnailSize Property

Gets or sets the maximum X and Y dimensions of the thumbnail to be created.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
Remarks
The actual thumbnail size will be calculated based on the Size value, maintaining the aspect ratio from the original image. For example, if the source image is 640x480 and the size is 100x100 the resulting thumbnail size will be 100x75.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.ThrowOnZeroDimensions Property

ThumbnailThrowOnZeroDimensions Property

Gets or sets a value that will thrown an exception if the resized image ends up with zero dimensions.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ThrowOnZeroDimensions { get; set; }
Public Property ThrowOnZeroDimensions As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false. In this case the smallest dimension is always 1 pixel.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail Methods

The Thumbnail type exposes the following members.

Methods
 | Name | Description
Public method | Create(AtalaImage) | Creates a new thumbnail image from the supplied image.
Public method | Create(Stream, Int32) | Creates a new thumbnail image from the supplied stream and frame index.
Public method | Create(String, Int32) | Creates a new thumbnail image from the supplied file and frame index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.Create Method

ThumbnailCreate Method

Creates a new thumbnail image from the supplied image.
Overload List
 | Name | Description
Public method | Create(AtalaImage) | Creates a new thumbnail image from the supplied image.
Public method | Create(Stream, Int32) | Creates a new thumbnail image from the supplied stream and frame index.
Public method | Create(String, Int32) | Creates a new thumbnail image from the supplied file and frame index.
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.Create Method (AtalaImage)

ThumbnailCreate Method (AtalaImage)

Creates a new thumbnail image from the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Create(
    AtalaImage image
)
Public Function Create (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The name of the file from where the image will be taken.

Return Value

Type: AtalaImage
See Also

Reference

Thumbnail Class
Create Overload
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.Create Method (Stream, Int32)

ThumbnailCreate Method (Stream, Int32)

Creates a new thumbnail image from the supplied stream and frame index.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Create(
    Stream stream,
    int frameIndex
)
Public Function Create (
    stream As Stream,
    frameIndex As Integer
) As AtalaImage

Parameters

stream
Type: System.IOStream
A stream from which an image can be loaded.
frameIndex
Type: SystemInt32
The index of the frame to be loaded.

Return Value

Type: AtalaImage
See Also

Reference

Thumbnail Class
Create Overload
Atalasoft.Imaging.ImageProcessing Namespace


Thumbnail.Create Method (String, Int32)

ThumbnailCreate Method (String, Int32)

Creates a new thumbnail image from the supplied file and frame index.

Namespace: Atalasoft.Imaging.ImageProcessing
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Create(
    string fileName,
    int frameIndex
)
Public Function Create (
    fileName As String,
    frameIndex As Integer
) As AtalaImage

Parameters

fileName
Type: SystemString
The name of the file from where the image will be taken.
frameIndex
Type: SystemInt32
The index of the frame to be loaded.

Return Value

Type: AtalaImage
See Also

Reference

Thumbnail Class
Create Overload
Atalasoft.Imaging.ImageProcessing Namespace


Atalasoft.Imaging.ImageProcessing.Channels Namespace

Classes
 | Class | Description
Public class | AdjustChannelCommand | This method may be used to adjust a channel by adding or subtracting a literal value or percentage. A negative value will reduce the amount of that channel and a positive value will increase it. A value of 0 will have no effect.
Public class | AdjustHslCommand | This method may be used to adjust the hue, saturation and luminance by adding or subtracting a literal value or percentage. A negative value will reduce the amount of that channel and a positive value will increase it. A value of 0 will have no effect.
 | ApplyLutCommand | Apply a Look-Up-Table to an image. A Look-Up-Table is an array of 256 byte values which are used to substitute for the image pixel data. This allows you to modify each pixel component value.
Public class | ApplyLutCommandBase | This is a base-class for creating look up table commands. This class is abstract and cannot be instantiated on its own.
Public class | FlattenAlphaCommand | This command will remove the alpha information from an image by blending the transparent areas with a solid color.
Public class | InvertCommand | Use this command to invert the image.
Public class | ReplaceChannelCommand | This command allows you to replace the channels of an existing image by substituting the channel values with those of an 8-bit grayscale image.
Public class | SetAlphaColorCommand | This command will create an alpha channel for an image based on a color value. If the image already contains alpha information, the color will be blended into it.
 | SetAlphaFromMaskCommand | Creates an alpha channel for an image using an 8-bit grayscale mask image to control transparency.
Public class | SetAlphaValueCommand | This command will create an alpha channel based on a numeric value.
Public class | ShiftChannelsCommand | This command will shift individual image channels.
 | SwapChannelsCommand | Swaps one channel with another channel within the same image.


AdjustChannelCommand Class

This method may be used to adjust a channel by adding or subtracting a literal value or percentage. A negative value will reduce the amount of that channel and a positive value will increase it. A value of 0 will have no effect.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsAdjustChannelCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdjustChannelCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class AdjustChannelCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The AdjustChannelCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdjustChannelCommand | Initializes a new instance of the AdjustChannelCommand class.
Public method | AdjustChannelCommand(Boolean, Double) | Initializes a new instance of the AdjustChannelCommand class.
Protected method | AdjustChannelCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdjustChannelCommand from serialization information.
Public method | AdjustChannelCommand(Boolean, Double, Double) | Initializes a new instance of the AdjustChannelCommand class.
Public method | AdjustChannelCommand(Boolean, Double, Double, Double) | Initializes a new instance of the AdjustChannelCommand class.
Public method | AdjustChannelCommand(Boolean, Double, Double, Double, Double) | Initializes a new instance of the AdjustChannelCommand class.
Top
Properties
 | Name | Description
Public property | AdjustByPercentage | Gets or sets the value which determines if the channel values are considered a percentage rather than a literal value.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channel1 | Gets or sets the amount to adjust the first channel.
Public property | Channel2 | Gets or sets the amount to adjust the second channel.
Public property | Channel3 | Gets or sets the amount to adjust the third channel.
Public property | Channel4 | Gets or sets the amount to adjust the fourth channel.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor

Initializes a new instance of the AdjustChannelCommand class, used to modify each channel value of an image.
Overload List
 | Name | Description
Public method | AdjustChannelCommand | Initializes a new instance of the AdjustChannelCommand class.
Public method | AdjustChannelCommand(Boolean, Double) | Initializes a new instance of the AdjustChannelCommand class.
Protected method | AdjustChannelCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdjustChannelCommand from serialization information.
Public method | AdjustChannelCommand(Boolean, Double, Double) | Initializes a new instance of the AdjustChannelCommand class.
Public method | AdjustChannelCommand(Boolean, Double, Double, Double) | Initializes a new instance of the AdjustChannelCommand class.
Public method | AdjustChannelCommand(Boolean, Double, Double, Double, Double) | Initializes a new instance of the AdjustChannelCommand class.
Top
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor

Initializes a new instance of the AdjustChannelCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustChannelCommand()
Public Sub New
See Also

Reference

AdjustChannelCommand Class
AdjustChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor (Boolean, Double)

Initializes a new instance of the AdjustChannelCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustChannelCommand(
    bool adjustByPercentage,
    double channel1
)
Public Sub New (
    adjustByPercentage As Boolean,
    channel1 As Double
)

Parameters

adjustByPercentage
Type: SystemBoolean
Determines if the channel values are considered a percentage rather than a literal value.
channel1
Type: SystemDouble
Amount to adjust the first channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel1 Property.
See Also

Reference

AdjustChannelCommand Class
AdjustChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AdjustChannelCommand from serialization information.
Creates a new instance of AdjustChannelCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdjustChannelCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AdjustChannelCommand Class
AdjustChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor (Boolean, Double, Double)

Initializes a new instance of the AdjustChannelCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustChannelCommand(
    bool adjustByPercentage,
    double channel1,
    double channel2
)
Public Sub New (
    adjustByPercentage As Boolean,
    channel1 As Double,
    channel2 As Double
)

Parameters

adjustByPercentage
Type: SystemBoolean
Determines if the channel values are considered a percentage rather than a literal value.
channel1
Type: SystemDouble
Amount to adjust the first channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel1 Property.
channel2
Type: SystemDouble
Amount to adjust the second channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel2 Property.
See Also

Reference

AdjustChannelCommand Class
AdjustChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor (Boolean, Double, Double, Double)

Initializes a new instance of the AdjustChannelCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustChannelCommand(
    bool adjustByPercentage,
    double channel1,
    double channel2,
    double channel3
)
Public Sub New (
    adjustByPercentage As Boolean,
    channel1 As Double,
    channel2 As Double,
    channel3 As Double
)

Parameters

adjustByPercentage
Type: SystemBoolean
Determines if the channel values are considered a percentage rather than a literal value.
channel1
Type: SystemDouble
Amount to adjust the first channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel1 Property.
channel2
Type: SystemDouble
Amount to adjust the second channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel2 Property.
channel3
Type: SystemDouble
Amount to adjust the third channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel3 Property.
See Also

Reference

AdjustChannelCommand Class
AdjustChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Constructor (Boolean, Double, Double, Double, Double)

Initializes a new instance of the AdjustChannelCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustChannelCommand(
    bool adjustByPercentage,
    double channel1,
    double channel2,
    double channel3,
    double channel4
)
Public Sub New (
    adjustByPercentage As Boolean,
    channel1 As Double,
    channel2 As Double,
    channel3 As Double,
    channel4 As Double
)

Parameters

adjustByPercentage
Type: SystemBoolean
Determines if the channel values are considered a percentage rather than a literal value.
channel1
Type: SystemDouble
Amount to adjust the first channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel1 Property.
channel2
Type: SystemDouble
Amount to adjust the second channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel2 Property.
channel3
Type: SystemDouble
Amount to adjust the third channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel3 Property.
channel4
Type: SystemDouble
Amount to adjust the fourth channel. Valid values are -100 to 100 when using percentage and -255 to 255 when using literal. This can be changed later via the Channel4 Property.
See Also

Reference

AdjustChannelCommand Class
AdjustChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Properties

The AdjustChannelCommand type exposes the following members.

Properties
 | Name | Description
Public property | AdjustByPercentage | Gets or sets the value which determines if the channel values are considered a percentage rather than a literal value.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channel1 | Gets or sets the amount to adjust the first channel.
Public property | Channel2 | Gets or sets the amount to adjust the second channel.
Public property | Channel3 | Gets or sets the amount to adjust the third channel.
Public property | Channel4 | Gets or sets the amount to adjust the fourth channel.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.AdjustByPercentage Property

AdjustChannelCommandAdjustByPercentage Property

Gets or sets the value which determines if the channel values are considered a percentage rather than a literal value.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AdjustByPercentage { get; set; }
Public Property AdjustByPercentage As Boolean
    Get
    Set

Property Value

Type: Boolean
The value which determines if the channel values are considered a percentage rather than a literal value.
Remarks

When this is set to true the value contained within each of the Channel properties is considered to be based on a percentage. When it is false it is considered to be a literal byte value change.

Defaults to false.

See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.AutoThread Property

AdjustChannelCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
Remarks
Defaults to false.
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.Channel1 Property

AdjustChannelCommandChannel1 Property

Gets or sets the amount to adjust the first channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Channel1 { get; set; }
Public Property Channel1 As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the first channel.
Remarks
Valid values are -100 to 100 when AdjustByPercentage is true and -255 to 255 when it is false.
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.Channel2 Property

AdjustChannelCommandChannel2 Property

Gets or sets the amount to adjust the second channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Channel2 { get; set; }
Public Property Channel2 As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the second channel.
Remarks
Valid values are -100 to 100 when AdjustByPercentage is true and -255 to 255 when it is false.
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.Channel3 Property

AdjustChannelCommandChannel3 Property

Gets or sets the amount to adjust the third channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Channel3 { get; set; }
Public Property Channel3 As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the third channel.
Remarks
Valid values are -100 to 100 when AdjustByPercentage is true and -255 to 255 when it is false.
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.Channel4 Property

AdjustChannelCommandChannel4 Property

Gets or sets the amount to adjust the fourth channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Channel4 { get; set; }
Public Property Channel4 As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the fourth channel.
Remarks
Valid values are -100 to 100 when AdjustByPercentage is true and -255 to 255 when it is false.
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.InPlaceProcessing Property

AdjustChannelCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean

Is always true.

See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.SupportedPixelFormats Property

AdjustChannelCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

An Array Containing:

PixelFormat.Pixel8bppGrayscale,PixelFormat.Pixel24bppBgr,PixelFormat.Pixel32bppBgr, PixelFormat.Pixel16bppGrayscaleAlpha,PixelFormat.Pixel32bppBgra,PixelFormat.Pixel32bppCmyk

See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand Methods

The AdjustChannelCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.AdjustBands Method

AdjustChannelCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which processing will be restricted to.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.,

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.Clone Method

AdjustChannelCommandClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
Remarks

Clone can be implemented either as a deep copy or a shallow copy. In a deep copy, all objects are duplicated; whereas, in a shallow copy, only the top-level objects are duplicated and the lower levels contain references.

The resulting clone must be of the same type as or a compatible type to the original instance.

See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.GetObjectData Method

AdjustChannelCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
Remarks

Any objects included in the SerializationInfo are automatically tracked and serialized by the formatter.

Code that calls GetObjectData requires the SecurityPermission for providing serialization services. Associated enumeration: SecurityPermissionFlag.SerializationFormatter.

See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.PerformActualCommand Method

AdjustChannelCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentException | This pixel format is not supported.;image
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.PerformSectionCommand Method

AdjustChannelCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustChannelCommand.VerifyProperties Method

AdjustChannelCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Channel1;When using literal values, the channel must be a value from -255 to 255. or Channel2;When using literal values, the channel must be a value from -255 to 255. or Channel3;When using literal values, the channel must be a value from -255 to 255. or Channel4;When using literal values, the channel must be a value from -255 to 255.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AdjustChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Class

This method may be used to adjust the hue, saturation and luminance by adding or subtracting a literal value or percentage. A negative value will reduce the amount of that channel and a positive value will increase it. A value of 0 will have no effect.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsAdjustHslCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdjustHslCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class AdjustHslCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The AdjustHslCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdjustHslCommand | Creates a new instance of AdjustHslCommand.
Protected method | AdjustHslCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdjustHslCommand from serialization information.
Public method | AdjustHslCommand(Boolean, Double, Double, Double) | Creates a new instance of AdjustHslCommand specifying the Hue, Saturation and Luminance values.
Top
Properties
 | Name | Description
Public property | AdjustByPercentage | Gets or sets a value to indicate if the hue, saturation and luminance values will be considered percentages instead of literal values.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Hue | Gets or sets the value of hue.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Luminance | Gets or sets the value of luminance.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Saturation | Gets or sets the value of saturation.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Constructor

Overload List
 | Name | Description
Public method | AdjustHslCommand | Creates a new instance of AdjustHslCommand.
Protected method | AdjustHslCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdjustHslCommand from serialization information.
Public method | AdjustHslCommand(Boolean, Double, Double, Double) | Creates a new instance of AdjustHslCommand specifying the Hue, Saturation and Luminance values.
Top
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Constructor

Creates a new instance of AdjustHslCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustHslCommand()
Public Sub New
See Also

Reference

AdjustHslCommand Class
AdjustHslCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AdjustHslCommand from serialization information.
Creates a new instance of AdjustHslCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdjustHslCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AdjustHslCommand Class
AdjustHslCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Constructor (Boolean, Double, Double, Double)

Creates a new instance of AdjustHslCommand specifying the Hue, Saturation and Luminance values.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustHslCommand(
    bool adjustByPercentage,
    double hue,
    double saturation,
    double luminance
)
Public Sub New (
    adjustByPercentage As Boolean,
    hue As Double,
    saturation As Double,
    luminance As Double
)

Parameters

adjustByPercentage
Type: SystemBoolean
Set to true if you want the hue, saturation and luminance values to be considered percentages.
hue
Type: SystemDouble
Amount to adjust the Hue. Valid values are -100 to 100 when using percentage and -240 to 240 when using literal.
saturation
Type: SystemDouble
Amount to adjust the Saturation. Valid values are -100 to 100 when using percentage and -240 to 240 when using literal.
luminance
Type: SystemDouble
Amount to adjust the Luminance. Valid values are -100 to 100 when using percentage and -240 to 240 when using literal.
See Also

Reference

AdjustHslCommand Class
AdjustHslCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Properties

The AdjustHslCommand type exposes the following members.

Properties
 | Name | Description
Public property | AdjustByPercentage | Gets or sets a value to indicate if the hue, saturation and luminance values will be considered percentages instead of literal values.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Hue | Gets or sets the value of hue.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Luminance | Gets or sets the value of luminance.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Saturation | Gets or sets the value of saturation.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.AdjustByPercentage Property

AdjustHslCommandAdjustByPercentage Property

Gets or sets a value to indicate if the hue, saturation and luminance values will be considered percentages instead of literal values.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AdjustByPercentage { get; set; }
Public Property AdjustByPercentage As Boolean
    Get
    Set

Property Value

Type: Boolean
A value to indicate if the hue, saturation and luminance values will be considered percentages instead of literal values.
Remarks
Defaults to false.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.AutoThread Property

AdjustHslCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
Remarks
Defaults to false.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.Hue Property

AdjustHslCommandHue Property

Gets or sets the value of hue.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the Hue.
Exceptions
Exception | Condition
 | Thrown if value is not between -240 and 240, inclusive.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.InPlaceProcessing Property

AdjustHslCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Is always true.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.Luminance Property

AdjustHslCommandLuminance Property

Gets or sets the value of luminance.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Luminance { get; set; }
Public Property Luminance As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the Luminance.
Exceptions
Exception | Condition
 | Thrown if value is not between -240 and 240, inclusive.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.Saturation Property

AdjustHslCommandSaturation Property

Gets or sets the value of saturation.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
Amount to adjust the Saturation.
Exceptions
Exception | Condition
 | Thrown if value is not between -240 and 240, inclusive.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.SupportedPixelFormats Property

AdjustHslCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

An Array Containing:

PixelFormat.Pixel24bppBgr,PixelFormat.Pixel32bppBgr,PixelFormat.Pixel32bppBgra,PixelFormat.Pixel32bppCmyk

See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand Methods

The AdjustHslCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.AdjustBands Method

AdjustHslCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which processing will be restricted to.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.Clone Method

AdjustHslCommandClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object

A new object that is a copy of this instance.

Implements

ICloneableClone
Remarks

Clone can be implemented either as a deep copy or a shallow copy. In a deep copy, all objects are duplicated; whereas, in a shallow copy, only the top-level objects are duplicated and the lower levels contain references.

The resulting clone must be of the same type as or a compatible type to the original instance.

See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.GetObjectData Method

AdjustHslCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext

The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
Remarks

Any objects that are included in the SerializationInfo are automatically tracked and serialized by the formatter.

Code that calls GetObjectData requires the SecurityPermission for providing serialization services. Associated enumeration: SecurityPermissionFlag.SerializationFormatter.

See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.PerformActualCommand Method

AdjustHslCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.PerformSectionCommand Method

AdjustHslCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


AdjustHslCommand.VerifyProperties Method

AdjustHslCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AdjustHslCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Class

Apply a Look-Up-Table to an image. A Look-Up-Table is an array of 256 byte values which are used to substitute for the image pixel data. This allows you to modify each pixel component value.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ApplyLutCommand : ApplyLutCommandBase,
    IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class ApplyLutCommand
    Inherits ApplyLutCommandBase
    Implements IThreadableCommand, ICloneable

The ApplyLutCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ApplyLutCommand | Creates a new instance of ApplyLutCommand.
Public method | ApplyLutCommand(Byte) | Creates a new instance of ApplyLutCommand specifying channel1.
Public method | ApplyLutCommand(Int32) | Creates a new instance of ApplyLutCommand specifying channel1 for two byte per pixel images.
Public method | ApplyLutCommand(Byte, Byte) | Creates a new instance of ApplyLutCommand specifying channel1 and channel2.
Protected method | ApplyLutCommand(SerializationInfo, StreamingContext) | Creates a new instance of ApplyLutCommand from serialization information.
Public method | ApplyLutCommand(Byte, Byte, Byte) | Creates a new instance of ApplyLutCommand specifying channel1, channel2 and channel3.
Public method | ApplyLutCommand(Int32, Int32, Int32) | Creates a new instance of ApplyLutCommand specifying channel1, channel2 and channel3 for two byte per pixel images.
Public method | ApplyLutCommand(Byte, Byte, Byte, Byte) | Creates a new instance of ApplyLutCommand specifying channel1, channel2, channel3, and channel4.
Public method | ApplyLutCommand(Int32, Int32, Int32, Int32) | Creates a new instance of ApplyLutCommand specifying channel1, channel2, channel3, and channel4 for two byte per pixel images.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Inherited from ApplyLutCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from ApplyLutCommandBase.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetChannelLut | Returns the look-up-table for a single channel.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Protected method | InternalActualCommand | InternalActualCommand does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | SetChannelLut(ChannelFlags, Byte) | Sets a lookup table for a single channel.
Public method | SetChannelLut(ChannelFlags, Int32) | Sets a lookup table for a single channel.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from ApplyLutCommandBase.)
Top
Remarks
This command will not work on 1-bit or 4-bit images.
Examples
ApplyLut (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage("in.jpg");

// Create a negative LUT.
byte[] lut = new byte[256];
for (int i = 0; i < 256; i++)
    lut[i] = (byte)(255 - i);

// Apply this LUT to the Blue and Red channels.
ApplyLutCommand cmd = new ApplyLutCommand(lut, null, lut);
ImageResults results = cmd.Apply(image);
results.Image.Save("out.jpg", new JpegEncoder(), null);
ApplyLutVB (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage = New AtalaImage("in.jpg")

' Create a negative LUT.
Dim lut(255) As Byte
For i As Integer = 0 To 255
    lut(i) = 255 - i
Next

' Apply this LUT to the Blue and Red channels.
Dim cmd As ApplyLutCommand = New ApplyLutCommand(lut, Nothing, lut)
Dim results As ImageResults = cmd.Apply(image)
results.Image.Save("out.jpg", New Atalasoft.Imaging.Codec.JpegEncoder(), Nothing)
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor

Create an ApplyLutCommand used to modify the Look-up-table of an image.
Overload List
 | Name | Description
Public method | ApplyLutCommand | Creates a new instance of ApplyLutCommand.
Public method | ApplyLutCommand(Byte) | Creates a new instance of ApplyLutCommand specifying channel1.
Public method | ApplyLutCommand(Int32) | Creates a new instance of ApplyLutCommand specifying channel1 for two byte per pixel images.
Public method | ApplyLutCommand(Byte, Byte) | Creates a new instance of ApplyLutCommand specifying channel1 and channel2.
Protected method | ApplyLutCommand(SerializationInfo, StreamingContext) | Creates a new instance of ApplyLutCommand from serialization information.
Public method | ApplyLutCommand(Byte, Byte, Byte) | Creates a new instance of ApplyLutCommand specifying channel1, channel2 and channel3.
Public method | ApplyLutCommand(Int32, Int32, Int32) | Creates a new instance of ApplyLutCommand specifying channel1, channel2 and channel3 for two byte per pixel images.
Public method | ApplyLutCommand(Byte, Byte, Byte, Byte) | Creates a new instance of ApplyLutCommand specifying channel1, channel2, channel3, and channel4.
Public method | ApplyLutCommand(Int32, Int32, Int32, Int32) | Creates a new instance of ApplyLutCommand specifying channel1, channel2, channel3, and channel4 for two byte per pixel images.
Top
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor

Creates a new instance of ApplyLutCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand()
Public Sub New
See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Byte[])

ApplyLutCommand Constructor (Byte)

Creates a new instance of ApplyLutCommand specifying channel1.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    byte[] channel1
)
Public Sub New (
    channel1 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the first color channel. This can be null (Nothing in Visual Basic).
See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Int32[])

ApplyLutCommand Constructor (Int32)

Creates a new instance of ApplyLutCommand specifying channel1 for two byte per pixel images.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    int[] channel1
)
Public Sub New (
    channel1 As Integer()
)

Parameters

channel1
Type: SystemInt32

An array of 65536 Int32s, representing the first color channel. This can be null (Nothing in Visual Basic).

See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Byte[], Byte[])

ApplyLutCommand Constructor (Byte, Byte)

Creates a new instance of ApplyLutCommand specifying channel1 and channel2.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    byte[] channel1,
    byte[] channel2
)
Public Sub New (
    channel1 As Byte(),
    channel2 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the first color channel. This can be null (Nothing in Visual Basic).
channel2
Type: SystemByte
An array of 256 bytes, representing the second color channel. This can be null (Nothing in Visual Basic).
See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ApplyLutCommand from serialization information.
Creates a new instance of ApplyLutCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ApplyLutCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Byte[], Byte[], Byte[])

ApplyLutCommand Constructor (Byte, Byte, Byte)

Creates a new instance of ApplyLutCommand specifying channel1, channel2 and channel3.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    byte[] channel1,
    byte[] channel2,
    byte[] channel3
)
Public Sub New (
    channel1 As Byte(),
    channel2 As Byte(),
    channel3 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the first color channel. This can be null (Nothing in Visual Basic).
channel2
Type: SystemByte
An array of 256 bytes, representing the second color channel. This can be null (Nothing in Visual Basic).
channel3
Type: SystemByte
An array of 256 bytes, representing the third color channel. This can be null (Nothing in Visual Basic).
See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Int32[], Int32[], Int32[])

ApplyLutCommand Constructor (Int32, Int32, Int32)

Creates a new instance of ApplyLutCommand specifying channel1, channel2 and channel3 for two byte per pixel images.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    int[] channel1,
    int[] channel2,
    int[] channel3
)
Public Sub New (
    channel1 As Integer(),
    channel2 As Integer(),
    channel3 As Integer()
)

Parameters

channel1
Type: SystemInt32

An array of 65536 Int32s, representing the first color channel. This can be null (Nothing in Visual Basic).

channel2
Type: SystemInt32

An array of 65536 Int32s, representing the second color channel. This can be null (Nothing in Visual Basic).

channel3
Type: SystemInt32

An array of 65536 Int32s, representing the third color channel. This can be null (Nothing in Visual Basic).

See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Byte[], Byte[], Byte[], Byte[])

ApplyLutCommand Constructor (Byte, Byte, Byte, Byte)

Creates a new instance of ApplyLutCommand specifying channel1, channel2, channel3, and channel4.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    byte[] channel1,
    byte[] channel2,
    byte[] channel3,
    byte[] channel4
)
Public Sub New (
    channel1 As Byte(),
    channel2 As Byte(),
    channel3 As Byte(),
    channel4 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the first color channel. This can be null (Nothing in Visual Basic).
channel2
Type: SystemByte
An array of 256 bytes, representing the second color channel. This can be null (Nothing in Visual Basic).
channel3
Type: SystemByte
An array of 256 bytes, representing the third color channel. This can be null (Nothing in Visual Basic).
channel4
Type: SystemByte
An array of 256 bytes, representing the fourth color channel. This can be null (Nothing in Visual Basic).
See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Constructor (Int32[], Int32[], Int32[], Int32[])

ApplyLutCommand Constructor (Int32, Int32, Int32, Int32)

Creates a new instance of ApplyLutCommand specifying channel1, channel2, channel3, and channel4 for two byte per pixel images.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommand(
    int[] channel1,
    int[] channel2,
    int[] channel3,
    int[] channel4
)
Public Sub New (
    channel1 As Integer(),
    channel2 As Integer(),
    channel3 As Integer(),
    channel4 As Integer()
)

Parameters

channel1
Type: SystemInt32

An array of 65536 Int32s, representing the first color channel. This can be null (Nothing in Visual Basic).

channel2
Type: SystemInt32

An array of 65536 Int32s, representing the second color channel. This can be null (Nothing in Visual Basic).

channel3
Type: SystemInt32

An array of 65536 Int32s, representing the third color channel. This can be null (Nothing in Visual Basic).

channel4
Type: SystemInt32

An array of 65536 Int32s, representing the fourth color channel. This can be null (Nothing in Visual Basic).

See Also

Reference

ApplyLutCommand Class
ApplyLutCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Properties

The ApplyLutCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Inherited from ApplyLutCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from ApplyLutCommandBase.)
Top
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.AutoThread Property

ApplyLutCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
Remarks
Defaults to false.
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand Methods

The ApplyLutCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetChannelLut | Returns the look-up-table for a single channel.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Protected method | InternalActualCommand | InternalActualCommand does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | SetChannelLut(ChannelFlags, Byte) | Sets a lookup table for a single channel.
Public method | SetChannelLut(ChannelFlags, Int32) | Sets a lookup table for a single channel.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from ApplyLutCommandBase.)
Top
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.AdjustBands Method

ApplyLutCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread for processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which processing will be restricted to.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.Clone Method

ApplyLutCommandClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
Remarks

Clone can be implemented either as a deep copy or a shallow copy. In a deep copy, all objects are duplicated; whereas, in a shallow copy, only the top-level objects are duplicated and the lower levels contain references.

The resulting clone must be of the same type as or a compatible type to the original instance.

See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.GetChannelLut Method

ApplyLutCommandGetChannelLut Method

Returns the look-up-table for a single channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] GetChannelLut(
    ChannelFlags channel
)
Public Function GetChannelLut (
    channel As ChannelFlags
) As Byte()

Parameters

channel
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channel you want to retrieve the look-up-table from.

Return Value

Type: Byte
The look-up-table for the specified channel.
Exceptions
Exception | Condition
 | Thrown if an attempt is made to select more than 1 channel.
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.GetObjectData Method

ApplyLutCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo

The SerializationInfo to populate with data.

context
Type: System.Runtime.SerializationStreamingContext

The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
Remarks

Any objects that are included in the SerializationInfo are automatically tracked and serialized by the formatter.

Code that calls GetObjectData requires the SecurityPermission for providing serialization services. Associated enumeration: SecurityPermissionFlag.SerializationFormatter

See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.ImplementMe Method

ApplyLutCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.InternalActualCommand Method

ApplyLutCommandInternalActualCommand Method

InternalActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage InternalActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Function InternalActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
Null (Nothing in VB)
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.PerformActualCommand Method

ApplyLutCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.PerformSectionCommand Method

ApplyLutCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.SetChannelLut Method

ApplyLutCommandSetChannelLut Method

Overload List
 | Name | Description
Public method | SetChannelLut(ChannelFlags, Byte) | Sets a lookup table for a single channel.
Public method | SetChannelLut(ChannelFlags, Int32) | Sets a lookup table for a single channel.
Top
See Also

Reference

ApplyLutCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.SetChannelLut Method (ChannelFlags, Byte[])

ApplyLutCommandSetChannelLut Method (ChannelFlags, Byte)

Sets a lookup table for a single channel.
Sets the look-up-table for a single channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetChannelLut(
    ChannelFlags channel,
    byte[] lut
)
Public Sub SetChannelLut (
    channel As ChannelFlags,
    lut As Byte()
)

Parameters

channel
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channel you want to set.
lut
Type: SystemByte
The look-up-table byte array.
Exceptions
Exception | Condition
 | Thrown if the LUT does not have 256 elements.
 | Thrown if an attempt is made to select more than 1 channel.
Remarks
The byte array must have 256 elements.
See Also

Reference

ApplyLutCommand Class
SetChannelLut Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommand.SetChannelLut Method (ChannelFlags, Int32[])

ApplyLutCommandSetChannelLut Method (ChannelFlags, Int32)

Sets a lookup table for a single channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetChannelLut(
    ChannelFlags channel,
    int[] lut
)
Public Sub SetChannelLut (
    channel As ChannelFlags,
    lut As Integer()
)

Parameters

channel
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channel you want to set.
lut
Type: SystemInt32
The look-up-table array.
Remarks
This method is for transforming two byte per pixel images. It must be given a table of 65536 Int32s.
See Also

Reference

ApplyLutCommand Class
SetChannelLut Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Class

This is a base-class for creating look up table commands. This class is abstract and cannot be instantiated on its own.
This is a base-class for creating look up table commands. This class is abstract and cannot be instantiated on its own.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
More...

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class ApplyLutCommandBase : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public MustInherit Class ApplyLutCommandBase
    Inherits ImageRegionCommand
    Implements ISerializable

The ApplyLutCommandBase type exposes the following members.

Constructors
 | Name | Description
Public method | ApplyLutCommandBase | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1.
Public method | ApplyLutCommandBase(Int32) | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte, Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1 and channel2.
Protected method | ApplyLutCommandBase(SerializationInfo, StreamingContext) | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte, Byte, Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1, channel2 and channel3.
Public method | ApplyLutCommandBase(Int32, Int32, Int32) | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte, Byte, Byte, Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1, channel2, channel3, and channel4.
Public method | ApplyLutCommandBase(Int32, Int32, Int32, Int32) | Initializes a new instance of the ApplyLutCommandBase class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table.
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel.
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel.
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommand
Atalasoft.Imaging.ImageProcessing.ChannelsInvertCommand
Atalasoft.Imaging.ImageProcessing.EffectsAdvancedLevelsCommand
Atalasoft.Imaging.ImageProcessing.EffectsAutoColorCommand
Atalasoft.Imaging.ImageProcessing.EffectsAutoContrastCommand
Atalasoft.Imaging.ImageProcessing.EffectsAutoLevelsCommand
Atalasoft.Imaging.ImageProcessing.EffectsCurvesCommand
Atalasoft.Imaging.ImageProcessing.EffectsLevelsCommand


ApplyLutCommandBase Constructor

Overload List
 | Name | Description
Public method | ApplyLutCommandBase | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1.
Public method | ApplyLutCommandBase(Int32) | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte, Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1 and channel2.
Protected method | ApplyLutCommandBase(SerializationInfo, StreamingContext) | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte, Byte, Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1, channel2 and channel3.
Public method | ApplyLutCommandBase(Int32, Int32, Int32) | Initializes a new instance of the ApplyLutCommandBase class.
Public method | ApplyLutCommandBase(Byte, Byte, Byte, Byte) | Creates a new instance of ApplyLutCommandBase specifying channel1, channel2, channel3, and channel4.
Public method | ApplyLutCommandBase(Int32, Int32, Int32, Int32) | Initializes a new instance of the ApplyLutCommandBase class.
Top
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor

Initializes a new instance of the ApplyLutCommandBase class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase()
Public Sub New
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Byte[])

ApplyLutCommandBase Constructor (Byte)

Creates a new instance of ApplyLutCommandBase specifying channel1.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    byte[] channel1
)
Public Sub New (
    channel1 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the 1st color channel. This can be null.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Int32[])

ApplyLutCommandBase Constructor (Int32)

Initializes a new instance of the ApplyLutCommandBase class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    int[] channel1
)
Public Sub New (
    channel1 As Integer()
)

Parameters

channel1
Type: SystemInt32
The channel1.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Byte[], Byte[])

ApplyLutCommandBase Constructor (Byte, Byte)

Creates a new instance of ApplyLutCommandBase specifying channel1 and channel2.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    byte[] channel1,
    byte[] channel2
)
Public Sub New (
    channel1 As Byte(),
    channel2 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the 1st color channel. This can be null.
channel2
Type: SystemByte
An array of 256 bytes, representing the 2nd color channel. This can be null.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ApplyLutCommandBase class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ApplyLutCommandBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Byte[], Byte[], Byte[])

ApplyLutCommandBase Constructor (Byte, Byte, Byte)

Creates a new instance of ApplyLutCommandBase specifying channel1, channel2 and channel3.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    byte[] channel1,
    byte[] channel2,
    byte[] channel3
)
Public Sub New (
    channel1 As Byte(),
    channel2 As Byte(),
    channel3 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the 1st color channel. This can be null.
channel2
Type: SystemByte
An array of 256 bytes, representing the 2nd color channel. This can be null.
channel3
Type: SystemByte
An array of 256 bytes, representing the 3rd color channel. This can be null.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Int32[], Int32[], Int32[])

ApplyLutCommandBase Constructor (Int32, Int32, Int32)

Initializes a new instance of the ApplyLutCommandBase class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    int[] channel1,
    int[] channel2,
    int[] channel3
)
Public Sub New (
    channel1 As Integer(),
    channel2 As Integer(),
    channel3 As Integer()
)

Parameters

channel1
Type: SystemInt32
The channel1.
channel2
Type: SystemInt32
The channel2.
channel3
Type: SystemInt32
The channel3.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Byte[], Byte[], Byte[], Byte[])

ApplyLutCommandBase Constructor (Byte, Byte, Byte, Byte)

Creates a new instance of ApplyLutCommandBase specifying channel1, channel2, channel3, and channel4.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    byte[] channel1,
    byte[] channel2,
    byte[] channel3,
    byte[] channel4
)
Public Sub New (
    channel1 As Byte(),
    channel2 As Byte(),
    channel3 As Byte(),
    channel4 As Byte()
)

Parameters

channel1
Type: SystemByte
An array of 256 bytes, representing the 1st color channel. This can be null.
channel2
Type: SystemByte
An array of 256 bytes, representing the 2nd color channel. This can be null.
channel3
Type: SystemByte
An array of 256 bytes, representing the 3rd color channel. This can be null.
channel4
Type: SystemByte
An array of 256 bytes, representing the 4th color channel. This can be null.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Constructor (Int32[], Int32[], Int32[], Int32[])

ApplyLutCommandBase Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of the ApplyLutCommandBase class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ApplyLutCommandBase(
    int[] channel1,
    int[] channel2,
    int[] channel3,
    int[] channel4
)
Public Sub New (
    channel1 As Integer(),
    channel2 As Integer(),
    channel3 As Integer(),
    channel4 As Integer()
)

Parameters

channel1
Type: SystemInt32
The channel1.
channel2
Type: SystemInt32
The channel2.
channel3
Type: SystemInt32
The channel3.
channel4
Type: SystemInt32
The channel4.
See Also

Reference

ApplyLutCommandBase Class
ApplyLutCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Properties

The ApplyLutCommandBase type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.InPlaceProcessing Property

ApplyLutCommandBaseInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.SupportedPixelFormats Property

ApplyLutCommandBaseSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

An Array Containing:

PixelFormat.Pixel24bppBgr, PixelFormat.Pixel8bppGrayscale,PixelFormat.Pixel8bppIndexed,PixelFormat.Pixel32bppBgr, PixelFormatPixelFormat.Pixel32bppCmyk,PixelFormat.Pixel16bppGrayscale,PixelFormat.Pixel16bppGrayscaleAlpha, PixelFormat.Pixel48bppBgr,PixelFormat.Pixel64bppBgra

See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase Methods

The ApplyLutCommandBase type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table.
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel.
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel.
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.GetObjectData Method

ApplyLutCommandBaseGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
Remarks

Any objects that are included in the SerializationInfo are automatically tracked and serialized by the formatter.

Code that calls GetObjectData requires the SecurityPermission for providing serialization services. Associated enumeration: SecurityPermissionFlag.SerializationFormatter.

See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.ImplementMe Method

ApplyLutCommandBaseImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void ImplementMe()
Protected MustOverride Sub ImplementMe
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.LLClearChannelLut Method

ApplyLutCommandBaseLLClearChannelLut Method

Low-level implementation to clear the channel lookup table.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void LLClearChannelLut()
Protected Sub LLClearChannelLut
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.LLGetChannelLut Method

ApplyLutCommandBaseLLGetChannelLut Method

Returns the loop-up-table for a single channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected byte[] LLGetChannelLut(
    ChannelFlags channel
)
Protected Function LLGetChannelLut (
    channel As ChannelFlags
) As Byte()

Parameters

channel
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channel you want to retrieve the loop-up-table from.

Return Value

Type: Byte
A 256 element byte array containing the loop-up-table.
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.LLSetChannelLut Method

ApplyLutCommandBaseLLSetChannelLut Method

Overload List
 | Name | Description
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel.
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table.
Top
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.LLSetChannelLut Method (ChannelFlags, Byte[])

ApplyLutCommandBaseLLSetChannelLut Method (ChannelFlags, Byte)

Sets the loop-up-table for a single channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void LLSetChannelLut(
    ChannelFlags channel,
    byte[] lut
)
Protected Sub LLSetChannelLut (
    channel As ChannelFlags,
    lut As Byte()
)

Parameters

channel
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channel to set the loop-up-table for.
lut
Type: SystemByte
The loop-up-table byte array.
Remarks
The array must have 256 elements.
See Also

Reference

ApplyLutCommandBase Class
LLSetChannelLut Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.LLSetChannelLut Method (ChannelFlags, Int32[])

ApplyLutCommandBaseLLSetChannelLut Method (ChannelFlags, Int32)

Low-level implementation of set channel look up table.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void LLSetChannelLut(
    ChannelFlags channel,
    int[] lut
)
Protected Sub LLSetChannelLut (
    channel As ChannelFlags,
    lut As Integer()
)

Parameters

channel
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channel.
lut
Type: SystemInt32
The lut.
Exceptions
Exception | Condition
ArgumentException | The lut array must have 65536 elements.;lut or You must select a single channel.;channel
See Also

Reference

ApplyLutCommandBase Class
LLSetChannelLut Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.PerformActualCommand Method

ApplyLutCommandBasePerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentNullException | source or channel1;channel1 null in 8bbpGrayscale or channel1;channel1 null inside 16bppGrayscale
See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ApplyLutCommandBase.VerifyProperties Method

ApplyLutCommandBaseVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ApplyLutCommandBase Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Class

This command will remove the alpha information from an image by blending the transparent areas with a solid color.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.ChannelsFlattenAlphaCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FlattenAlphaCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class FlattenAlphaCommand
    Inherits ImageCommand
    Implements ISerializable

The FlattenAlphaCommand type exposes the following members.

Constructors
 | Name | Description
Public method | FlattenAlphaCommand | Creates a new instance of FlattenAlphaCommand.
Public method | FlattenAlphaCommand(Color) | Creates a new instance of FlattenAlphaCommand specifying the color used to replace the alpha.
Protected method | FlattenAlphaCommand(SerializationInfo, StreamingContext) | Creates a new instance of FlattenAlphaCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Color | Gets or sets the color to use for the transparent areas of the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command requires an image containing alpha information.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Constructor

Creates a FlattenAlphaCommand that can be used to remove alpha information from an image.
Overload List
 | Name | Description
Public method | FlattenAlphaCommand | Creates a new instance of FlattenAlphaCommand.
Public method | FlattenAlphaCommand(Color) | Creates a new instance of FlattenAlphaCommand specifying the color used to replace the alpha.
Protected method | FlattenAlphaCommand(SerializationInfo, StreamingContext) | Creates a new instance of FlattenAlphaCommand from serialization information.
Top
See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Constructor

Creates a new instance of FlattenAlphaCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlattenAlphaCommand()
Public Sub New
See Also

Reference

FlattenAlphaCommand Class
FlattenAlphaCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Constructor (Color)

Creates a new instance of FlattenAlphaCommand specifying the color used to replace the alpha.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlattenAlphaCommand(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor
The background color to blend with.
See Also

Reference

FlattenAlphaCommand Class
FlattenAlphaCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FlattenAlphaCommand from serialization information.
Creates a new instance of FlattenAlphaCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FlattenAlphaCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

FlattenAlphaCommand Class
FlattenAlphaCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Properties

The FlattenAlphaCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Color | Gets or sets the color to use for the transparent areas of the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand.Color Property

FlattenAlphaCommandColor Property

Gets or sets the color to use for the transparent areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color to use for the transparent areas of the image.
See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand.SupportedPixelFormats Property

FlattenAlphaCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

An Array Containing:

PixelFormat.Pixel8bppIndexed,PixelFormat.Pixel16bppGrayscaleAlpha,PixelFormat.Pixel32bppBgra

See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand Methods

The FlattenAlphaCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand.ConstructFinalImage Method

FlattenAlphaCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand.GetObjectData Method

FlattenAlphaCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo

The SerializationInfo to populate with data.

context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
Remarks

Any objects that are included in the SerializationInfo are automatically tracked and serialized by the formatter.

Code that calls GetObjectData requires the SecurityPermission for providing serialization services. Associated enumeration:

See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand.PerformActualCommand Method

FlattenAlphaCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


FlattenAlphaCommand.VerifyProperties Method

FlattenAlphaCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

FlattenAlphaCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand Class

Use this command to invert the image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.ChannelsInvertCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvertCommand : ApplyLutCommandBase,
    IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class InvertCommand
    Inherits ApplyLutCommandBase
    Implements IThreadableCommand, ICloneable

The InvertCommand type exposes the following members.

Constructors
 | Name | Description
Public method | InvertCommand | Creates a new instance of InvertCommand.
Protected method | InvertCommand(SerializationInfo, StreamingContext) | Creates a new instance of InvertCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag specifying which channels to process.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Protected method | InternalActualCommand | Internals the actual command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
Remarks

Uses a highly optimized invert routine on RGB images when AllChannels are included. You may specify any or all channels to invert.

Inverting an image creates a photo negative by subtracting 255 from each channel value.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand Constructor

Overload List
 | Name | Description
Public method | InvertCommand | Creates a new instance of InvertCommand.
Protected method | InvertCommand(SerializationInfo, StreamingContext) | Creates a new instance of InvertCommand from serialization information.
Top
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand Constructor

Creates a new instance of InvertCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InvertCommand()
Public Sub New
See Also

Reference

InvertCommand Class
InvertCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of InvertCommand from serialization information.
Creates a new instance of the InvertCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected InvertCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

InvertCommand Class
InvertCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand Properties

The InvertCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag specifying which channels to process.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.AutoThread Property

InvertCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.ChannelsToProcess Property

InvertCommandChannelsToProcess Property

Gets or sets a bit flag specifying which channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag specifying which channels to process.
Remarks
Default value is ChannelFlags.AllChannels
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.InPlaceProcessing Property

InvertCommandInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.SupportedPixelFormats Property

InvertCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand Methods

The InvertCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Protected method | InternalActualCommand | Internals the actual command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.AdjustBands Method

InvertCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.Clone Method

InvertCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the InvertCommand.

Implements

ICloneableClone
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.GetObjectData Method

InvertCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.ImplementMe Method

InvertCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.InternalActualCommand Method

InvertCommandInternalActualCommand Method

Internals the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage InternalActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Function InternalActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
ArgumentNullException | source
ArgumentException | internal error - invalid pixel format slipped by InvertCommand
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.PerformActualCommand Method

InvertCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.PerformSectionCommand Method

InvertCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


InvertCommand.VerifyProperties Method

InvertCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
IncompatiblePixelFormatException | Invert does not function with 1, 4 or 8 bits per pixel and a region of interest.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

InvertCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Class

This command allows you to replace the channels of an existing image by substituting the channel values with those of an 8-bit grayscale image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.ChannelsReplaceChannelCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ReplaceChannelCommand : ImageCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class ReplaceChannelCommand
    Inherits ImageCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The ReplaceChannelCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ReplaceChannelCommand | Creates a new instance of ReplaceChannelCommand.
Public method | ReplaceChannelCommand(AtalaImage) | Creates a new instance of ReplaceChannelCommand specifying the channel images.
Protected method | ReplaceChannelCommand(SerializationInfo, StreamingContext) | Creates a new instance of ReplaceChannelCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channel1Image | Gets or sets a grayscale image to represent the first channel. Set this to null if you want to skip this channel.
Public property | Channel2Image | Gets or sets an 8-bit image to represent the second channel. Set this to null if you want to skip this channel.
Public property | Channel3Image | Gets or sets an 8-bit image to represent the third channel. Set this to null if you want to skip this channel.
Public property | Channel4Image | Gets or sets an 8-bit image to represent the fourth channel. Set this to null if you want to skip this channel.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Constructor

Creates a new instance of the ReplaceChannelCommand object specifying a param array of channels.
Overload List
 | Name | Description
Public method | ReplaceChannelCommand | Creates a new instance of ReplaceChannelCommand.
Public method | ReplaceChannelCommand(AtalaImage) | Creates a new instance of ReplaceChannelCommand specifying the channel images.
Protected method | ReplaceChannelCommand(SerializationInfo, StreamingContext) | Creates a new instance of ReplaceChannelCommand from serialization information.
Top
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Constructor

Creates a new instance of ReplaceChannelCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplaceChannelCommand()
Public Sub New
See Also

Reference

ReplaceChannelCommand Class
ReplaceChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Constructor (AtalaImage[])

ReplaceChannelCommand Constructor (AtalaImage)

Creates a new instance of ReplaceChannelCommand specifying the channel images.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplaceChannelCommand(
    params AtalaImage[] channelImage
)
Public Sub New (
    ParamArray channelImage As AtalaImage()
)

Parameters

channelImage
Type: Atalasoft.ImagingAtalaImage
A parameter array of grayscale AtalaImage's representing each channel in the image.
Exceptions
Exception | Condition
 | Thrown if the channelImages argument is null (Nothing in VB).
 | Thrown if channelImage is an empty array.
See Also

Reference

ReplaceChannelCommand Class
ReplaceChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ReplaceChannelCommand from serialization information.
Creates a new instance of ReplaceChannelCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ReplaceChannelCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ReplaceChannelCommand Class
ReplaceChannelCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Properties

The ReplaceChannelCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channel1Image | Gets or sets a grayscale image to represent the first channel. Set this to null if you want to skip this channel.
Public property | Channel2Image | Gets or sets an 8-bit image to represent the second channel. Set this to null if you want to skip this channel.
Public property | Channel3Image | Gets or sets an 8-bit image to represent the third channel. Set this to null if you want to skip this channel.
Public property | Channel4Image | Gets or sets an 8-bit image to represent the fourth channel. Set this to null if you want to skip this channel.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.AutoThread Property

ReplaceChannelCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.Channel1Image Property

ReplaceChannelCommandChannel1Image Property

Gets or sets a grayscale image to represent the first channel. Set this to null if you want to skip this channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Channel1Image { get; set; }
Public Property Channel1Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
A grayscale image to represent the first channel. Set this to null if you want to skip this channel.
Exceptions
Exception | Condition
 | Thrown if the channel is not 8-bit or 16-bit grayscale or null (Nothing in Visual Basic).
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.Channel2Image Property

ReplaceChannelCommandChannel2Image Property

Gets or sets an 8-bit image to represent the second channel. Set this to null if you want to skip this channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Channel2Image { get; set; }
Public Property Channel2Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
An 8-bit image to represent the second channel. Set this to null if you want to skip this channel.
Exceptions
Exception | Condition
 | Thrown if the channel is not 8-bit or 16-bit grayscale or null (Nothing in Visual Basic).
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.Channel3Image Property

ReplaceChannelCommandChannel3Image Property

Gets or sets an 8-bit image to represent the third channel. Set this to null if you want to skip this channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Channel3Image { get; set; }
Public Property Channel3Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
An 8-bit image to represent the third channel. Set this to null if you want to skip this channel.
Exceptions
Exception | Condition
 | Thrown if the channel is not 8-bit or 16-bit grayscale or null (Nothing in Visual Basic).
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.Channel4Image Property

ReplaceChannelCommandChannel4Image Property

Gets or sets an 8-bit image to represent the fourth channel. Set this to null if you want to skip this channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Channel4Image { get; set; }
Public Property Channel4Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
An 8-bit image to represent the fourth channel. Set this to null if you want to skip this channel.
Exceptions
Exception | Condition
 | Thrown if the channel is not 8-bit or 16-bit grayscale or null (Nothing in Visual Basic).
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.InPlaceProcessing Property

ReplaceChannelCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.SupportedPixelFormats Property

ReplaceChannelCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand Methods

The ReplaceChannelCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.AdjustBands Method

ReplaceChannelCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.Clone Method

ReplaceChannelCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the ReplaceChannelCommand.

Implements

ICloneableClone
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.GetObjectData Method

ReplaceChannelCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.PerformActualCommand Method

ReplaceChannelCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.PerformSectionCommand Method

ReplaceChannelCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ReplaceChannelCommand.VerifyProperties Method

ReplaceChannelCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | ReplaceChannel command requires at least one image;Channel1Image or All images must have the image width and height.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ReplaceChannelCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Class

This command will create an alpha channel for an image based on a color value. If the image already contains alpha information, the color will be blended into it.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSetAlphaColorCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SetAlphaColorCommand : ImageCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class SetAlphaColorCommand
    Inherits ImageCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The SetAlphaColorCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SetAlphaColorCommand | Creates a new instance of SetAlphaColorCommand.
Public method | SetAlphaColorCommand(Color) | Creates a new instance of SetAlphaColorCommand specifying color.
Public method | SetAlphaColorCommand(Color, Double) | Creates a new instance of SetAlphaColorCommand specifying color and tolerance.
Protected method | SetAlphaColorCommand(SerializationInfo, StreamingContext) | Creates a new instance of SetAlphaColorCommand from serialization information.
Public method | SetAlphaColorCommand(Color, Double, AlphaMergeType) | Creates a new instance of SetAlphaColorCommand specifying color, tolerance, and merge type.
Public method | SetAlphaColorCommand(Color, Double, AlphaMergeType, Int32, Int32) | Creates a new instance of SetAlphaColorCommand specifying color, tolerance, merge type, matching alpha, and non-matching alpha.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Color | Gets or sets the color used to create the alpha channel.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MatchAlpha | Gets or sets the alpha value to use when a match of the color is found.
Public property | MergeType | Gets or sets the type of merge performed.
Public property | NonMatchAlpha | Gets or sets the alpha value to use when a match of the color is not found.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the tolerance percentage for finding matching colors.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This method will convert 1-bit, 4-bit and 8-bit grayscale images to 8-bit indexed. 24-bit images will be converted to 32-bit.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor

Creates a new instance of the SetAlphaColorCommand object.
Overload List
 | Name | Description
Public method | SetAlphaColorCommand | Creates a new instance of SetAlphaColorCommand.
Public method | SetAlphaColorCommand(Color) | Creates a new instance of SetAlphaColorCommand specifying color.
Public method | SetAlphaColorCommand(Color, Double) | Creates a new instance of SetAlphaColorCommand specifying color and tolerance.
Protected method | SetAlphaColorCommand(SerializationInfo, StreamingContext) | Creates a new instance of SetAlphaColorCommand from serialization information.
Public method | SetAlphaColorCommand(Color, Double, AlphaMergeType) | Creates a new instance of SetAlphaColorCommand specifying color, tolerance, and merge type.
Public method | SetAlphaColorCommand(Color, Double, AlphaMergeType, Int32, Int32) | Creates a new instance of SetAlphaColorCommand specifying color, tolerance, merge type, matching alpha, and non-matching alpha.
Top
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor

Creates a new instance of SetAlphaColorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaColorCommand()
Public Sub New
See Also

Reference

SetAlphaColorCommand Class
SetAlphaColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor (Color)

Creates a new instance of SetAlphaColorCommand specifying color.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaColorCommand(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor
Color used to create the alpha channel.
See Also

Reference

SetAlphaColorCommand Class
SetAlphaColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor (Color, Double)

Creates a new instance of SetAlphaColorCommand specifying color and tolerance.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaColorCommand(
    Color color,
    double tolerance
)
Public Sub New (
    color As Color,
    tolerance As Double
)

Parameters

color
Type: System.DrawingColor
Color used to create the alpha channel.
tolerance
Type: SystemDouble
Tolerance percentage for finding matching colors. (0 - 100)
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100.
See Also

Reference

SetAlphaColorCommand Class
SetAlphaColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SetAlphaColorCommand from serialization information.
Creates a new instance of SetAlphaColorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SetAlphaColorCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SetAlphaColorCommand Class
SetAlphaColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor (Color, Double, AlphaMergeType)

Creates a new instance of SetAlphaColorCommand specifying color, tolerance, and merge type.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaColorCommand(
    Color color,
    double tolerance,
    AlphaMergeType mergeType
)
Public Sub New (
    color As Color,
    tolerance As Double,
    mergeType As AlphaMergeType
)

Parameters

color
Type: System.DrawingColor
Color used to create the alpha channel.
tolerance
Type: SystemDouble
Tolerance percentage for finding matching colors. (0 - 100)
mergeType
Type: Atalasoft.Imaging.ImageProcessingAlphaMergeType
The type of merge performed.
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100.
See Also

Reference

SetAlphaColorCommand Class
SetAlphaColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Constructor (Color, Double, AlphaMergeType, Int32, Int32)

Creates a new instance of SetAlphaColorCommand specifying color, tolerance, merge type, matching alpha, and non-matching alpha.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaColorCommand(
    Color color,
    double tolerance,
    AlphaMergeType mergeType,
    int matchAlpha,
    int nonMatchAlpha
)
Public Sub New (
    color As Color,
    tolerance As Double,
    mergeType As AlphaMergeType,
    matchAlpha As Integer,
    nonMatchAlpha As Integer
)

Parameters

color
Type: System.DrawingColor
Color used to create the alpha channel.
tolerance
Type: SystemDouble
Tolerance percentage for finding matching colors. (0 - 100)
mergeType
Type: Atalasoft.Imaging.ImageProcessingAlphaMergeType
The type of merge performed.
matchAlpha
Type: SystemInt32
The alpha value to use when a match of the color is found. (0 - 255)
nonMatchAlpha
Type: SystemInt32
The alpha value to use when a match of the color is not found. (0 - 255)
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100, of if the matchAlpha or nonMatchAlpha values are less than 0.
See Also

Reference

SetAlphaColorCommand Class
SetAlphaColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Properties

The SetAlphaColorCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Color | Gets or sets the color used to create the alpha channel.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MatchAlpha | Gets or sets the alpha value to use when a match of the color is found.
Public property | MergeType | Gets or sets the type of merge performed.
Public property | NonMatchAlpha | Gets or sets the alpha value to use when a match of the color is not found.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the tolerance percentage for finding matching colors.
Top
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.AutoThread Property

SetAlphaColorCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.Color Property

SetAlphaColorCommandColor Property

Gets or sets the color used to create the alpha channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
Color used to create the alpha channel.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.MatchAlpha Property

SetAlphaColorCommandMatchAlpha Property

Gets or sets the alpha value to use when a match of the color is found.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MatchAlpha { get; set; }
Public Property MatchAlpha As Integer
    Get
    Set

Property Value

Type: Int32
The alpha value to use when a match of the color is found.
Exceptions
Exception | Condition
 | Thrown if value is amp;lt; 0.
Remarks
Valid values are from 0 to 255.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.MergeType Property

SetAlphaColorCommandMergeType Property

Gets or sets the type of merge performed.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlphaMergeType MergeType { get; set; }
Public Property MergeType As AlphaMergeType
    Get
    Set

Property Value

Type: AlphaMergeType
The type of merge performed.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace
AlphaMergeType


SetAlphaColorCommand.NonMatchAlpha Property

SetAlphaColorCommandNonMatchAlpha Property

Gets or sets the alpha value to use when a match of the color is not found.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int NonMatchAlpha { get; set; }
Public Property NonMatchAlpha As Integer
    Get
    Set

Property Value

Type: Int32
The alpha value to use when a match of the color is not found.
Exceptions
Exception | Condition
 | Thrown if value is amp;lt; 0.
Remarks
Valid values are from 0 to 255.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.SupportedPixelFormats Property

SetAlphaColorCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.Tolerance Property

SetAlphaColorCommandTolerance Property

Gets or sets the tolerance percentage for finding matching colors.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set

Property Value

Type: Double
Tolerance percentage for finding matching colors.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100, inclusive.
Remarks
Valid values are from 0 to 100.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand Methods

The SetAlphaColorCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.AdjustBands Method

SetAlphaColorCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.Clone Method

SetAlphaColorCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the SetAlphaColorCommand.

Implements

ICloneableClone
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.ConstructFinalImage Method

SetAlphaColorCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Exceptions
Exception | Condition
NullReferenceException | unable to construct destination image
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.GetObjectData Method

SetAlphaColorCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.PerformActualCommand Method

SetAlphaColorCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dstImage,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dstImage As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
dstImage
Type: Atalasoft.ImagingAtalaImage
The DST image.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.PerformSectionCommand Method

SetAlphaColorCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaColorCommand.VerifyProperties Method

SetAlphaColorCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SetAlphaColorCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Class

Creates an alpha channel for an image using an 8-bit grayscale mask image to control transparency.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSetAlphaFromMaskCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SetAlphaFromMaskCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class SetAlphaFromMaskCommand
    Inherits ImageCommand
    Implements ISerializable

The SetAlphaFromMaskCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SetAlphaFromMaskCommand | Creates a new instance of SetAlphaFromMaskCommand.
Protected method | SetAlphaFromMaskCommand(SerializationInfo, StreamingContext) | Creates a new instance of SetAlphaFromMaskCommand from serialization information.
Public method | SetAlphaFromMaskCommand(AtalaImage, Boolean, AlphaMergeType) | Creates a new instance of SetAlphaFromMask specifying maskImage, resizeMask and mergeType.
Public method | SetAlphaFromMaskCommand(AtalaImage, Boolean, AlphaMergeType, Point) | Creates a new instance of SetAlphaFromMask specifying maskImage, resizeMask, mergeType and position.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaskImage | Gets or sets an 8-bit image used to generate the alpha channel.
Public property | MergeType | Gets or sets the type of merge performed.
Public property | Position | Gets or sets the left, top position of the mask image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ResizeMask | Gets or sets a valid to indicate if the mask should be resized to fit the image.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command will result in a 16-bit grayscale-alpha or 32-bit RGBA image.
Examples
SetAlphaFromMask (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Load the 8-bit grayscale mask.
AtalaImage mask = new AtalaImage(@"D:\Test Images\JPG\8-bit alpha mask.jpg");

// Apply the mask to the image and create the new 32-bit image.
SetAlphaFromMaskCommand cmd = new SetAlphaFromMaskCommand(mask, true, AlphaMergeType.UseMostTransparent);
AtalaImage result = cmd.Apply(image).Image;

// Free the image and mask.
image.Dispose();
mask.Dispose();
SetAlphaFromMask (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage = New AtalaImage("D:\Test Images\1.jpg")

' Load the 8-bit grayscale mask.
Dim mask As AtalaImage = New AtalaImage("D:\Test Images\JPG\8-bit alpha mask.jpg")

' Apply the mask to the image and create the new 32-bit image.
Dim cmd As SetAlphaFromMaskCommand = New SetAlphaFromMaskCommand(mask, True, AlphaMergeType.UseMostTransparent)
Dim result As AtalaImage = cmd.Apply(image).Image

' Free the image and mask.
image.Dispose()
mask.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Constructor

Creates a new instance of the SetAlphaFromMaskCommand object, used to create an image with alpha by setting the alpha values to the corresponding pixel value in a mask image.
Overload List
 | Name | Description
Public method | SetAlphaFromMaskCommand | Creates a new instance of SetAlphaFromMaskCommand.
Protected method | SetAlphaFromMaskCommand(SerializationInfo, StreamingContext) | Creates a new instance of SetAlphaFromMaskCommand from serialization information.
Public method | SetAlphaFromMaskCommand(AtalaImage, Boolean, AlphaMergeType) | Creates a new instance of SetAlphaFromMask specifying maskImage, resizeMask and mergeType.
Public method | SetAlphaFromMaskCommand(AtalaImage, Boolean, AlphaMergeType, Point) | Creates a new instance of SetAlphaFromMask specifying maskImage, resizeMask, mergeType and position.
Top
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Constructor

Creates a new instance of SetAlphaFromMaskCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaFromMaskCommand()
Public Sub New
See Also

Reference

SetAlphaFromMaskCommand Class
SetAlphaFromMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SetAlphaFromMaskCommand from serialization information.
Creates a new instance of SetAlphaFromMaskCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SetAlphaFromMaskCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SetAlphaFromMaskCommand Class
SetAlphaFromMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Constructor (AtalaImage, Boolean, AlphaMergeType)

Creates a new instance of SetAlphaFromMask specifying maskImage, resizeMask and mergeType.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaFromMaskCommand(
    AtalaImage maskImage,
    bool resizeMask,
    AlphaMergeType mergeType
)
Public Sub New (
    maskImage As AtalaImage,
    resizeMask As Boolean,
    mergeType As AlphaMergeType
)

Parameters

maskImage
Type: Atalasoft.ImagingAtalaImage
An 8-bit image used to generate the alpha channel.
resizeMask
Type: SystemBoolean
Set to true if the mask should be resized to fit the image.
mergeType
Type: Atalasoft.Imaging.ImageProcessingAlphaMergeType
The type of merge performed.
See Also

Reference

SetAlphaFromMaskCommand Class
SetAlphaFromMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Constructor (AtalaImage, Boolean, AlphaMergeType, Point)

Creates a new instance of SetAlphaFromMask specifying maskImage, resizeMask, mergeType and position.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaFromMaskCommand(
    AtalaImage maskImage,
    bool resizeMask,
    AlphaMergeType mergeType,
    Point position
)
Public Sub New (
    maskImage As AtalaImage,
    resizeMask As Boolean,
    mergeType As AlphaMergeType,
    position As Point
)

Parameters

maskImage
Type: Atalasoft.ImagingAtalaImage
An 8-bit image used to generate the alpha channel.
resizeMask
Type: SystemBoolean
Set to true if the mask should be resized to fit the image.
mergeType
Type: Atalasoft.Imaging.ImageProcessingAlphaMergeType
The type of merge performed.
position
Type: System.DrawingPoint
The x,y position to place the mask image.
See Also

Reference

SetAlphaFromMaskCommand Class
SetAlphaFromMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Properties

The SetAlphaFromMaskCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaskImage | Gets or sets an 8-bit image used to generate the alpha channel.
Public property | MergeType | Gets or sets the type of merge performed.
Public property | Position | Gets or sets the left, top position of the mask image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ResizeMask | Gets or sets a valid to indicate if the mask should be resized to fit the image.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.MaskImage Property

SetAlphaFromMaskCommandMaskImage Property

Gets or sets an 8-bit image used to generate the alpha channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage MaskImage { get; set; }
Public Property MaskImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
An 8-bit image used to generate the alpha channel.
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.MergeType Property

SetAlphaFromMaskCommandMergeType Property

Gets or sets the type of merge performed.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlphaMergeType MergeType { get; set; }
Public Property MergeType As AlphaMergeType
    Get
    Set

Property Value

Type: AlphaMergeType
The type of merge performed.
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace
AlphaMergeType


SetAlphaFromMaskCommand.Position Property

SetAlphaFromMaskCommandPosition Property

Gets or sets the left, top position of the mask image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The left, top position of the mask image.
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.ResizeMask Property

SetAlphaFromMaskCommandResizeMask Property

Gets or sets a valid to indicate if the mask should be resized to fit the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ResizeMask { get; set; }
Public Property ResizeMask As Boolean
    Get
    Set

Property Value

Type: Boolean
Set to true if the mask should be resized to fit the image.
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.SupportedPixelFormats Property

SetAlphaFromMaskCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand Methods

The SetAlphaFromMaskCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.ConstructFinalImage Method

SetAlphaFromMaskCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.GetObjectData Method

SetAlphaFromMaskCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.PerformActualCommand Method

SetAlphaFromMaskCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.SelectPreferredPixelFormat Method

SetAlphaFromMaskCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaFromMaskCommand.VerifyProperties Method

SetAlphaFromMaskCommandVerifyProperties Method

Verifies the properties.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage sourceImage
)
Protected Overrides Sub VerifyProperties (
    sourceImage As AtalaImage
)

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
Exceptions
Exception | Condition
ArgumentNullException | MaskImage
ArgumentException | MaskImage contains no image data or is disposed.;MaskImage
See Also

Reference

SetAlphaFromMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Class

This command will create an alpha channel based on a numeric value.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSetAlphaValueCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SetAlphaValueCommand : ImageCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class SetAlphaValueCommand
    Inherits ImageCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The SetAlphaValueCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SetAlphaValueCommand | Creates a new instance of SetAlphaValueCommand.
Public method | SetAlphaValueCommand(Byte, AlphaMergeType) | Creates a new instance of SetAlphaValueCommand specifying the alpha value and merge type.
Protected method | SetAlphaValueCommand(SerializationInfo, StreamingContext) | Creates a new instance of SetAlphaValueCommand from serialization information.
Top
Properties
 | Name | Description
Public property | AlphaValue | Gets or sets a value of 0 to 255 indicating the opacity to use on the alpha channel.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MergeType | Gets or sets the type of merge performed.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | InternalActualCommand | InternalActualCommand does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This method will convert 1-bit, 4-bit and 8-bit grayscale images to 8-bit indexed. 24-bit images will be converted to 32-bit.

This method requires a 8-bit Indexed, 16-bit or 32-bit image. All other images will throw an exception.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Constructor

Creates a new instance of SetAlphaValueCommand.
Overload List
 | Name | Description
Public method | SetAlphaValueCommand | Creates a new instance of SetAlphaValueCommand.
Public method | SetAlphaValueCommand(Byte, AlphaMergeType) | Creates a new instance of SetAlphaValueCommand specifying the alpha value and merge type.
Protected method | SetAlphaValueCommand(SerializationInfo, StreamingContext) | Creates a new instance of SetAlphaValueCommand from serialization information.
Top
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Constructor

Creates a new instance of SetAlphaValueCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaValueCommand()
Public Sub New
See Also

Reference

SetAlphaValueCommand Class
SetAlphaValueCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Constructor (Byte, AlphaMergeType)

Creates a new instance of SetAlphaValueCommand specifying the alpha value and merge type.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SetAlphaValueCommand(
    byte alphaValue,
    AlphaMergeType mergeType
)
Public Sub New (
    alphaValue As Byte,
    mergeType As AlphaMergeType
)

Parameters

alphaValue
Type: SystemByte
A value of 0 to 255 indicating the opacity to use on the alpha channel.
mergeType
Type: Atalasoft.Imaging.ImageProcessingAlphaMergeType
The type of merge performed.
Exceptions
Exception | Condition
 | Thrown if the alphaValue is less than 0 or greater than 255.
See Also

Reference

SetAlphaValueCommand Class
SetAlphaValueCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SetAlphaValueCommand from serialization information.
Creates a new instance of SetAlphaValueCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SetAlphaValueCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SetAlphaValueCommand Class
SetAlphaValueCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Properties

The SetAlphaValueCommand type exposes the following members.

Properties
 | Name | Description
Public property | AlphaValue | Gets or sets a value of 0 to 255 indicating the opacity to use on the alpha channel.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MergeType | Gets or sets the type of merge performed.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.AlphaValue Property

SetAlphaValueCommandAlphaValue Property

Gets or sets a value of 0 to 255 indicating the opacity to use on the alpha channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte AlphaValue { get; set; }
Public Property AlphaValue As Byte
    Get
    Set

Property Value

Type: Byte
A value of 0 to 255 indicating the opacity to use on the alpha channel.
Exceptions
Exception | Condition
 | Thrown ifvalue is not between 0 and 255, inclusive.
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.AutoThread Property

SetAlphaValueCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.MergeType Property

SetAlphaValueCommandMergeType Property

Gets or sets the type of merge performed.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlphaMergeType MergeType { get; set; }
Public Property MergeType As AlphaMergeType
    Get
    Set

Property Value

Type: AlphaMergeType
The type of merge performed.
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace
Atalasoft.Imaging.ImageProcessingAlphaMergeType


SetAlphaValueCommand.SupportedPixelFormats Property

SetAlphaValueCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand Methods

The SetAlphaValueCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | InternalActualCommand | InternalActualCommand does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.AdjustBands Method

SetAlphaValueCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.Apply Method

SetAlphaValueCommandApply Method

Apply the command to the given image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageResults Apply(
    AtalaImage image
)
Public Overrides Function Apply (
    image As AtalaImage
) As ImageResults

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image which will by processed by the command.

Return Value

Type: ImageResults
A new object of type ImageResults.
Remarks
The ImageResults object will always contain a valid Image property which represents the output of the command. This property may be the same as the input image.
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.Clone Method

SetAlphaValueCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the SetAlphaValueCommand.

Implements

ICloneableClone
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.ConstructFinalImage Method

SetAlphaValueCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Exceptions
Exception | Condition
NullReferenceException | Unable to construct a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.GetObjectData Method

SetAlphaValueCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.InternalActualCommand Method

SetAlphaValueCommandInternalActualCommand Method

InternalActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage InternalActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea
)
Protected Function InternalActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.

Return Value

Type: AtalaImage
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.PerformActualCommand Method

SetAlphaValueCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.PerformSectionCommand Method

SetAlphaValueCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SetAlphaValueCommand.VerifyProperties Method

SetAlphaValueCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SetAlphaValueCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Class

This command will shift individual image channels.
This command will shift individual image channels.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsShiftChannelsCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ShiftChannelsCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class ShiftChannelsCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The ShiftChannelsCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ShiftChannelsCommand | Creates a new instance of ShiftChannelsCommand.
Protected method | ShiftChannelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of ShiftChannelsCommand from serialization information.
Public method | ShiftChannelsCommand(Int32, Int32, ChannelFlags) | Creates a new instance of ShiftChannelsCommand specifying offsetX, offsetY and channelsToProcess.
Public method | ShiftChannelsCommand(Int32, Int32, ChannelFlags, Int32) | Creates a new instance of ShiftChannelsCommand specifying offsetX, offsetY, channelsToProcess and backgroundValue.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundValue | Gets or set a channel value to use for uncovered channel areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | OffsetX | Gets or sets the number of pixels to horizontally offset the channels.
Public property | OffsetY | Gets or sets the number of pixels to vertically offset the channels.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException

This command requires an image with at least 2 channels. If the image does not contain at least 2 channels, the PixelFormat will be changed to a compatible format.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Constructor

Creates a new instance of the ShiftChannelsCommand class, used to offset individual channels in an image.
Overload List
 | Name | Description
Public method | ShiftChannelsCommand | Creates a new instance of ShiftChannelsCommand.
Protected method | ShiftChannelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of ShiftChannelsCommand from serialization information.
Public method | ShiftChannelsCommand(Int32, Int32, ChannelFlags) | Creates a new instance of ShiftChannelsCommand specifying offsetX, offsetY and channelsToProcess.
Public method | ShiftChannelsCommand(Int32, Int32, ChannelFlags, Int32) | Creates a new instance of ShiftChannelsCommand specifying offsetX, offsetY, channelsToProcess and backgroundValue.
Top
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Constructor

Creates a new instance of ShiftChannelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ShiftChannelsCommand()
Public Sub New
See Also

Reference

ShiftChannelsCommand Class
ShiftChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ShiftChannelsCommand from serialization information.
Creates a new instance of ShiftChannelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ShiftChannelsCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ShiftChannelsCommand Class
ShiftChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Constructor (Int32, Int32, ChannelFlags)

Creates a new instance of ShiftChannelsCommand specifying offsetX, offsetY and channelsToProcess.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ShiftChannelsCommand(
    int offsetX,
    int offsetY,
    ChannelFlags channelsToProcess
)
Public Sub New (
    offsetX As Integer,
    offsetY As Integer,
    channelsToProcess As ChannelFlags
)

Parameters

offsetX
Type: SystemInt32
Number of pixels to horizontally offset the channels.
offsetY
Type: SystemInt32
Number of pixels to vertically offset the channels.
channelsToProcess
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channels you want to shift.
See Also

Reference

ShiftChannelsCommand Class
ShiftChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Constructor (Int32, Int32, ChannelFlags, Int32)

Creates a new instance of ShiftChannelsCommand specifying offsetX, offsetY, channelsToProcess and backgroundValue.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ShiftChannelsCommand(
    int offsetX,
    int offsetY,
    ChannelFlags channelsToProcess,
    int backgroundValue
)
Public Sub New (
    offsetX As Integer,
    offsetY As Integer,
    channelsToProcess As ChannelFlags,
    backgroundValue As Integer
)

Parameters

offsetX
Type: SystemInt32
Number of pixels to horizontally offset the channels.
offsetY
Type: SystemInt32
Number of pixels to vertically offset the channels.
channelsToProcess
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The channels you want to shift.
backgroundValue
Type: SystemInt32
A value used for uncovered areas of the image. (0 - 255)
Exceptions
Exception | Condition
 | Thrown if the backgroundValue is less than 0 or greater than 255.
See Also

Reference

ShiftChannelsCommand Class
ShiftChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Properties

The ShiftChannelsCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundValue | Gets or set a channel value to use for uncovered channel areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | OffsetX | Gets or sets the number of pixels to horizontally offset the channels.
Public property | OffsetY | Gets or sets the number of pixels to vertically offset the channels.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.BackgroundValue Property

ShiftChannelsCommandBackgroundValue Property

Gets or set a channel value to use for uncovered channel areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BackgroundValue { get; set; }
Public Property BackgroundValue As Integer
    Get
    Set

Property Value

Type: Int32
A value to use for uncovered channel areas of the image.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks
This value should be between 0 and 255 inclusive.
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.ChannelsToProcess Property

ShiftChannelsCommandChannelsToProcess Property

Gets or sets the ChannelFlags specifying which channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The ChannelFlags specifying which channels to process.
Remarks
The default value is AllChannels.
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.OffsetX Property

ShiftChannelsCommandOffsetX Property

Gets or sets the number of pixels to horizontally offset the channels.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int OffsetX { get; set; }
Public Property OffsetX As Integer
    Get
    Set

Property Value

Type: Int32
Number of pixels to horizontally offset the channels.
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.OffsetY Property

ShiftChannelsCommandOffsetY Property

Gets or sets the number of pixels to vertically offset the channels.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int OffsetY { get; set; }
Public Property OffsetY As Integer
    Get
    Set

Property Value

Type: Int32
Number of pixels to vertically offset the channels.
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.SupportedPixelFormats Property

ShiftChannelsCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand Methods

The ShiftChannelsCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.ConstructFinalImage Method

ShiftChannelsCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.GetObjectData Method

ShiftChannelsCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.PerformActualCommand Method

ShiftChannelsCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | OffsetX;The offset cannot be greater than the image or region. or OffsetY;The offset cannot be greater than the image or region.
See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.SelectPreferredPixelFormat Method

ShiftChannelsCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


ShiftChannelsCommand.VerifyProperties Method

ShiftChannelsCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ShiftChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Class

Swaps one channel with another channel within the same image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsSwapChannelsCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SwapChannelsCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class SwapChannelsCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The SwapChannelsCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SwapChannelsCommand | Creates a new instance of SwapChannelsCommand.
Public method | SwapChannelsCommand(Int32) | Creates a new instance of SwapChannelsCommand specifying the channels to swap.
Protected method | SwapChannelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of SwapChannelsCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channel1 | Gets or sets the first channel in the image. Valid values are 1-4.
Public property | Channel2 | Gets or sets the second channel in the image. Valid values are 1-4.
Public property | Channel3 | Gets or sets the third channel in the image. Valid values are 1-4.
Public property | Channel4 | Gets or sets the fourth channel in the image. Valid values are 1-4.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException

This command requires an image with at least 2 channels. If the image does not contain at least 2 channels, the PixelFormat will be changed to a compatible format.

Examples
SwapChannelsCommand (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Swap the Red and Green channels.
// Remember, the image data is stored in BGR (Blue, Green, Red) format.
SwapChannelsCommand cmd = new SwapChannelsCommand(1, 3, 2);
AtalaImage tmp = cmd.Apply(image).Image;
SwapChannelsCommandVB (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Swap the Red and Green channels.
' Remember, the image data is stored in BGR (Blue, Green, Red) format.
Dim cmd As SwapChannelsCommand =  New SwapChannelsCommand(1,3,2)
Dim tmp As AtalaImage =  cmd.Apply(image).Image
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Constructor

Overload List
 | Name | Description
Public method | SwapChannelsCommand | Creates a new instance of SwapChannelsCommand.
Public method | SwapChannelsCommand(Int32) | Creates a new instance of SwapChannelsCommand specifying the channels to swap.
Protected method | SwapChannelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of SwapChannelsCommand from serialization information.
Top
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Constructor

Creates a new instance of SwapChannelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SwapChannelsCommand()
Public Sub New
See Also

Reference

SwapChannelsCommand Class
SwapChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Constructor (Int32[])

SwapChannelsCommand Constructor (Int32)

Creates a new instance of SwapChannelsCommand specifying the channels to swap.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SwapChannelsCommand(
    params int[] channel
)
Public Sub New (
    ParamArray channel As Integer()
)

Parameters

channel
Type: SystemInt32
A parameter array of the channel orders. Values must be between 1 and 4.
Exceptions
Exception | Condition
 | Thrown if the array contains less than 2 entries or if the channel value is less than 1 or greater than 4.
See Also

Reference

SwapChannelsCommand Class
SwapChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SwapChannelsCommand from serialization information.
Creates a new instance of the SwapChannelsCommand object.,Creates a new instance of SwapChannel specifying channel1, channel2 and channel3. ,Creates a new instance of SwapChannel specifying channel1, channel2, channel3, and channel4.,Creates a new instance of SwapChannel specifying a param array of channels.
Creates a new instance of SwapChannelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SwapChannelsCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SwapChannelsCommand Class
SwapChannelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Properties

The SwapChannelsCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channel1 | Gets or sets the first channel in the image. Valid values are 1-4.
Public property | Channel2 | Gets or sets the second channel in the image. Valid values are 1-4.
Public property | Channel3 | Gets or sets the third channel in the image. Valid values are 1-4.
Public property | Channel4 | Gets or sets the fourth channel in the image. Valid values are 1-4.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.Channel1 Property

SwapChannelsCommandChannel1 Property

Gets or sets the first channel in the image. Valid values are 1-4.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channel1 { get; set; }
Public Property Channel1 As Integer
    Get
    Set

Property Value

Type: Int32
The first channel in the image. Valid values are 1-4.
Exceptions
Exception | Condition
 | Thrown if value is not between 1 and 4, inclusive.
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.Channel2 Property

SwapChannelsCommandChannel2 Property

Gets or sets the second channel in the image. Valid values are 1-4.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channel2 { get; set; }
Public Property Channel2 As Integer
    Get
    Set

Property Value

Type: Int32
The second channel in the image. Valid values are 1-4.
Exceptions
Exception | Condition
 | Thrown if the value is not between 1 and 4, inclusive.
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.Channel3 Property

SwapChannelsCommandChannel3 Property

Gets or sets the third channel in the image. Valid values are 1-4.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channel3 { get; set; }
Public Property Channel3 As Integer
    Get
    Set

Property Value

Type: Int32
The third channel in the image. Valid values are 1-4.
Exceptions
Exception | Condition
 | Thrown if the value is not between 1 and 4, inclusive.
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.Channel4 Property

SwapChannelsCommandChannel4 Property

Gets or sets the fourth channel in the image. Valid values are 1-4.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channel4 { get; set; }
Public Property Channel4 As Integer
    Get
    Set

Property Value

Type: Int32
The fourth channel in the image. Valid values are 1-4.
Exceptions
Exception | Condition
 | Thrown if the value is not between 1 and 4, inclusive.
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.SupportedPixelFormats Property

SwapChannelsCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel64bppBgra
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand Methods

The SwapChannelsCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.ConstructFinalImage Method

SwapChannelsCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.GetObjectData Method

SwapChannelsCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo where the data will be stored.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.PerformActualCommand Method

SwapChannelsCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.SelectPreferredPixelFormat Method

SwapChannelsCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


SwapChannelsCommand.VerifyProperties Method

SwapChannelsCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Channels
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | The channel values are invalid for this image. or The channel values are invalid for this image. or The channel values are invalid for this image. or The channel values are invalid for this image. or Region of interest cannot be used with 48-bit images. or The channel values are invalid for this image. or Region of interest cannot be used with 64-bit images. or The source image must be at least 16-bit.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SwapChannelsCommand Class
Atalasoft.Imaging.ImageProcessing.Channels Namespace


Atalasoft.Imaging.ImageProcessing.Document Namespace

Contains classes that are designed to be used with 1-bit document (binary) images. These classes are enabled in the professional edition.
Classes
 | Class | Description
Public class | AdaptiveThresholdCommand | An ImageCommand used to convert a grayscale or color image into black and white using a weighted thresholding technique.
 | AdvancedBorderRemovalCommand | Automatically removes black borders from a bi-tonal image using a sophisticated object detection algorithm.
Public class | AdvancedDocCleanException |
 | AutoBorderCropCommand | Crops black borders from the edges of a bi-tonal image.
Public class | AutoBorderCropResults | Provides custom ImageResults for AutoBorderCropCommand.
Public class | AutoDeskewCommand | The AutoDeskewCommand automatically deskews a binary image using %%company%%'s patent pending auto-deskew algorithm.
Public class | AutoDeskewResults | This class represents the results of applying the AutoDeskewCommand on an image.
 | AutoInvertTextCommand | Automatically inverts regions of text that are inverted (white on black) on a bi-tonal image.
 | AutoNegateCommand | Inspects an bi-tonal image to determine if the image is negated. Will automatically invert the image if InvertWhenWhiteOnBlack.
Public class | AutoNegateResults | Provides a custom ImageResults for the AutoNegateCommand.
 | BinarizeCommand | Converts a grayscale or color image to black and white using one of the available Binarize methods.
 | BlankPageDetectionCommand | Detect whether a given image (or a region of interest in the image) is blank.
Public class | BlankPageDetectionResults | Provides a custom ImageResults for BlankPageDetectionCommand.
 | BlobRemovalCommand | A generic object removal command for bi-tonal images.
 | BorderRemovalCommand | An ImageCommand that removes solid borders from document images.
Public class | BorderRemovalResults | This class represents the results of applying the BorderRemovalCommand on an image.
 | ColorExtractionCommand | This command detects color regions from a color document resulting in an image with grayscale and bi-tonal areas masked with transparent alpha, and notification if the document contains any color.
Public class | ColorExtractionResults | Provides custom ImageResults for ColorExtractionCommand.
Public class | DitherCommand | This command is used for converting color or gray images to black and white using halftoning techniques to simulate gray in the final image. This command operates best on photographic images. Dithering is done using either Ordered Dithering or Floyd-Steinberg Error Diffusion dithering. With Ordered Dithering, the dithering matrix is fully replaceable and can be made to simulate custom halftone screens.
Public class | DocumentDespeckleCommand | The DocumentDespeckleCommand is useful for removing small isolated features in a bitonal image without eroding solid features. The most common use is as a despeckle filter for document images.
Public class | DocumentHitOrMissCommand | Perform a hit-or-miss transformation on a binary image.
Public class | DocumentMedianCommand | Applies a median filter to a binary image.
Public class | DocumentPixelFormatChanger | This PixelFormatChanger is suited for document images and can be set to PixelFormatChanger.
Public class | DocumentThinningCommand | Apply morphological thinning to a 1-bit image.
Public class | DynamicThresholdCommand | Converts a multi-bit image (color or grayscale) to a single bit black and white image.
Public class | Geometry | A member of Segment class, spatial information with collection of polgons is provided
 | GlobalThresholdCommand | An ImageCommand used to convert a grayscale or color image into black and white using a global thresholding technique.
Public class | Halftone | Represents a halftone region in an image.
Public class | HalftoneCollection | Represents a collection of Halftone objects.
 | HalftoneRemovalCommand | Detects and removes shaded regions from bi-tonal images.
Public class | HalftoneRemovalResults | Provides custom ImageResults for HalftoneRemovalCommand.
Public class | HolePunch | Represents a single hole punch in an image.
Public class | HolePunchCollection | Represents a collection of HolePunch objects.
 | HolePunchRemovalCommand | Removes circular hole punch artifacts from an image.
Public class | HolePunchRemovalResults | Provides custom ImageResults for HolePunchRemovalCommand.
Public class | Line | Represents a single line in an image.
Public class | LineCollection | Represents a collection of Line objects.
 | LineRemovalCommand | This class removes horizontal and/or vertical lines in a bi-tonal image.
Public class | LineRemovalResults | Provides custom ImageResults for LineRemovalCommand.
 | MarginCropCommand | Crops excess white borders from a bi-tonal image.
Public class | MarginCropResults | Provides custom ImageResults for MarginCropCommand.
Public class | MorphoDocumentCommand | This class will perform a mathematical morphological operation to a binary image.
Public class | OverlayMaskedDocumentCommand | Overlay an image using an alpha mask.
Public class | ResampleDocumentCommand | Resamples a binary image.
Public class | Segment | This class is designed to store spatial and qualitative information of the results of the document image segmentation algorithm for document images.
Public class | SegmentationCommand |
Public class | SegmentationResults |
Public class | SegmentCollection |
Public class | SegmentsLocatedEventArgs |
Public class | SimpleThresholdCommand | This command converts a continuous RGB or grayscale image to a 1-bit black and white image, given a threshold value.
 | SpeckRemovalCommand | Removes specks of a specified size from a bi-tonal image.
Interfaces
 | Interface | Description
Public interface | IProcessSpeedConfig | Interface that when applied to a class is used to control the sampling factor useful in improving performance possibly at the expense of accuracy.
Delegates
 | Delegate | Description
Public delegate | OnSegmentsLocatedEventHandler |
Enumerations
 | Enumeration | Description
Public enumeration | AutoDeskewCropMode | The crop mode to use in the AutoDeskewCommand.
Public enumeration | BinarizeMethod | Lists the supported binarization methods used in the BinarizeCommand
Public enumeration | BorderRemovalEdges | Specifies the edges to remove when using BorderRemovalCommand.
Public enumeration | DitheringMethod | Specifies the technique used for dithering in a DitherCommand.
Public enumeration | ErrorNo |
Public enumeration | ImageEdges | Indicates the edge of the image to inspect for commands such as HolePunchRemovalCommand.
Public enumeration | LineOrientations | Controls the Line Orientation used in LineRemovalCommand.
Public enumeration | MorphoDocumentMode | The type of morphological filter to use in the MorphoDocumentCommand.
Public enumeration | ResampleDocumentMethod | Specifies the resampling method to apply using the ResampleDocumentCommand.
Public enumeration | RunSpeed | Defines the speed of processing at the expense of quality
Public enumeration | SegmentType |
Public enumeration | ThresholdMethod | Thresholding Method.


AdaptiveThresholdCommand Class

An ImageCommand used to convert a grayscale or color image into black and white using a weighted thresholding technique.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentAdaptiveThresholdCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdaptiveThresholdCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class AdaptiveThresholdCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The AdaptiveThresholdCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdaptiveThresholdCommand | Creates a new instance of AdaptiveThresholdCommand.
Public method | AdaptiveThresholdCommand(Int32) | Initializes a new instance of AdaptiveThresholdCommand specifying the window size.
Public method | AdaptiveThresholdCommand(Int32, Int32) | Initializes a new instance of AdaptiveThresholdCommand specifying the window size and difference threshold.
Protected method | AdaptiveThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdaptiveThresholdCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DifferenceThreshold | Gets or sets a value used for improving the thresholding results.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | WindowSize | Gets or sets the size of local window acting on each pixel to find local statistics.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

The AdaptiveThresholdCommand can be used to cleanup a color or grayscale image when converting to black and white. It results in an image that generally renders text and objects intact, while removing effects from color shades.

Like global thresholding, adaptive thresholding is used to separate desirable foreground image objects from the background. This is based on the difference in pixel intensities of each region, while global thresholding uses a fixed threshold for all pixels and therefore works only if the intensity histogram of the input image contains obviously separated peaks corresponding to the desired subjects and backgrounds. Hence it cannot deal with images containing, for example, a strong illumination gradient. Local adaptive thresholding selects an individual threshold for each pixel. This allows for thresholding of an image whose global intensity histogram doesn't contain distinctive peaks.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Constructor

Initializes a new instance of AdaptiveThresholdCommand.
Overload List
 | Name | Description
Public method | AdaptiveThresholdCommand | Creates a new instance of AdaptiveThresholdCommand.
Public method | AdaptiveThresholdCommand(Int32) | Initializes a new instance of AdaptiveThresholdCommand specifying the window size.
Public method | AdaptiveThresholdCommand(Int32, Int32) | Initializes a new instance of AdaptiveThresholdCommand specifying the window size and difference threshold.
Protected method | AdaptiveThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdaptiveThresholdCommand from serialization information.
Top
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Constructor

Creates a new instance of AdaptiveThresholdCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveThresholdCommand()
Public Sub New
See Also

Reference

AdaptiveThresholdCommand Class
AdaptiveThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Constructor (Int32)

Initializes a new instance of AdaptiveThresholdCommand specifying the window size.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveThresholdCommand(
    int windowSize
)
Public Sub New (
    windowSize As Integer
)

Parameters

windowSize
Type: SystemInt32

The size of the examination window surround the current pixel

Exceptions
Exception | Condition
 | Thrown if the windowSize is less than 2.
See Also

Reference

AdaptiveThresholdCommand Class
AdaptiveThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Constructor (Int32, Int32)

Initializes a new instance of AdaptiveThresholdCommand specifying the window size and difference threshold.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveThresholdCommand(
    int windowSize,
    int differenceThreshold
)
Public Sub New (
    windowSize As Integer,
    differenceThreshold As Integer
)

Parameters

windowSize
Type: SystemInt32

The size of the examination window surround the current pixel

differenceThreshold
Type: SystemInt32
The value used for improving the thresholding results.
Exceptions
Exception | Condition
 | Thrown if the windowSize is less than 2.
See Also

Reference

AdaptiveThresholdCommand Class
AdaptiveThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AdaptiveThresholdCommand from serialization information.
Initializes a new instance of AdaptiveThresholdCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdaptiveThresholdCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AdaptiveThresholdCommand Class
AdaptiveThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Properties

The AdaptiveThresholdCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DifferenceThreshold | Gets or sets a value used for improving the thresholding results.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | WindowSize | Gets or sets the size of local window acting on each pixel to find local statistics.
Top
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.AutoThread Property

AdaptiveThresholdCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.DifferenceThreshold Property

AdaptiveThresholdCommandDifferenceThreshold Property

Gets or sets a value used for improving the thresholding results.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DifferenceThreshold { get; set; }
Public Property DifferenceThreshold As Integer
    Get
    Set

Property Value

Type: Int32
A value used for improving the thresholding results.
Remarks
In local adaptive thresholding, an individual threshold for each pixel is based on the range of intensity values in its local neighborhood. In this class, a local mean value is used as the threshold. The situation can be improved if the threshold employed is not the mean, but "mean - DifferenceThreshold". The default value is 7.
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.SupportedPixelFormats Property

AdaptiveThresholdCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.WindowSize Property

AdaptiveThresholdCommandWindowSize Property

Gets or sets the size of local window acting on each pixel to find local statistics.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int WindowSize { get; set; }
Public Property WindowSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of local window acting on each pixel to find local statistics.
Exceptions
Exception | Condition
 | Thrown if value is amp;lt; 2.
Remarks
Default value is 15.
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand Methods

The AdaptiveThresholdCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.AdjustBands Method

AdaptiveThresholdCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.Clone Method

AdaptiveThresholdCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the AdaptiveThresholdCommand.

Implements

ICloneableClone
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.ConstructChangedSourceImage Method

AdaptiveThresholdCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.ConstructFinalImage Method

AdaptiveThresholdCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.GetObjectData Method

AdaptiveThresholdCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.PerformActualCommand Method

AdaptiveThresholdCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage destImage,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    destImage As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
destImage
Type: Atalasoft.ImagingAtalaImage
The dest image.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.PerformSectionCommand Method

AdaptiveThresholdCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Exceptions
Exception | Condition
ImageProcessException | adaptive thresholding failed
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdaptiveThresholdCommand.VerifyProperties Method

AdaptiveThresholdCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AdaptiveThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand Class

Automatically removes black borders from a bi-tonal image using a sophisticated object detection algorithm.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentAdvancedBorderRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdvancedBorderRemovalCommand : ImageRegionCommand,
    IProcessSpeedConfig, IPropertiesAutoConfigurable, ISerializable
<SerializableAttribute>
Public Class AdvancedBorderRemovalCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, IPropertiesAutoConfigurable, ISerializable

The AdvancedBorderRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedBorderRemovalCommand | Creates a new instance of AdvancedBorderRemovalCommand.
Protected method | AdvancedBorderRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AdvancedBorderRemovalCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoPropertyConfigurationEnabled | Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise | When true, will denoise the image prior to detecting the border.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxBorderThickness | Gets or sets the maximum border thickness, in pixels, that will be removed.
Public property | MinBorderThickness | Gets or sets the minimum border thickness, in pixels, that will be removed.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | PropertiesToAutoConfigure |
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Unlike AutoBorderCropCommand, black border pixels will be turned to white instead of being cropped off.

This command also differs from the BorderRemovalCommand included with DotImage Document Imaging, which is a simpler version of AutoBorderCropCommand.

Examples
Apply Command (C#)
Copy
AdvancedBorderRemovalCommand cmd = new AdvancedBorderRemovalCommand();
ImageResults results = cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
Apply Command (Visual Basic)
Copy
Dim cmd As AdvancedBorderRemovalCommand = New AdvancedBorderRemovalCommand()
Dim results As ImageResults = cmd.Apply(sourceImage)
Dim newImage As AtalaImage = results.Image
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand Constructor

Overload List
 | Name | Description
Public method | AdvancedBorderRemovalCommand | Creates a new instance of AdvancedBorderRemovalCommand.
Protected method | AdvancedBorderRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AdvancedBorderRemovalCommand class
Top
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand Constructor

Creates a new instance of AdvancedBorderRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedBorderRemovalCommand()
Public Sub New
See Also

Reference

AdvancedBorderRemovalCommand Class
AdvancedBorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AdvancedBorderRemovalCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdvancedBorderRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AdvancedBorderRemovalCommand Class
AdvancedBorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand Properties

The AdvancedBorderRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoPropertyConfigurationEnabled | Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise | When true, will denoise the image prior to detecting the border.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxBorderThickness | Gets or sets the maximum border thickness, in pixels, that will be removed.
Public property | MinBorderThickness | Gets or sets the minimum border thickness, in pixels, that will be removed.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | PropertiesToAutoConfigure |
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.AutoPropertyConfigurationEnabled Property

AdvancedBorderRemovalCommandAutoPropertyConfigurationEnabled Property

Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool AutoPropertyConfigurationEnabled { get; set; }
Public Overridable Property AutoPropertyConfigurationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IPropertiesAutoConfigurableAutoPropertyConfigurationEnabled
Remarks
Set this to false when hand tweaking auto configurable properties. Default value is true.
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.Denoise Property

AdvancedBorderRemovalCommandDenoise Property

When true, will denoise the image prior to detecting the border.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Denoise { get; set; }
Public Overridable Property Denoise As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false. When set to true, there is a lower chance of removing useful data when the image is highly noised.
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.MaxBorderThickness Property

AdvancedBorderRemovalCommandMaxBorderThickness Property

Gets or sets the maximum border thickness, in pixels, that will be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaxBorderThickness { get; set; }
Public Overridable Property MaxBorderThickness As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Default value is 50.
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.MinBorderThickness Property

AdvancedBorderRemovalCommandMinBorderThickness Property

Gets or sets the minimum border thickness, in pixels, that will be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MinBorderThickness { get; set; }
Public Overridable Property MinBorderThickness As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Raised when value is less than 1.
Remarks
Default value is 5.
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.PropertiesToAutoConfigure Property

AdvancedBorderRemovalCommandPropertiesToAutoConfigure Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual StringCollection PropertiesToAutoConfigure { get; }
Public Overridable ReadOnly Property PropertiesToAutoConfigure As StringCollection
    Get

Property Value

Type: StringCollection

Implements

IPropertiesAutoConfigurablePropertiesToAutoConfigure
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.SpeedFactor Property

AdvancedBorderRemovalCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Fast.
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.SupportedPixelFormats Property

AdvancedBorderRemovalCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand Methods

The AdvancedBorderRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.GetObjectData Method

AdvancedBorderRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.PerformActualCommand Method

AdvancedBorderRemovalCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedBorderRemovalCommand.VerifyProperties Method

AdvancedBorderRemovalCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

AdvancedBorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Class

Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.ImageProcessing.DocumentAdvancedDocCleanException

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdvancedDocCleanException : Exception
<SerializableAttribute>
Public Class AdvancedDocCleanException
    Inherits Exception

The AdvancedDocCleanException type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedDocCleanException | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Public method | AdvancedDocCleanException(String) | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Protected method | AdvancedDocCleanException(SerializationInfo, StreamingContext) | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Public method | AdvancedDocCleanException(String, Exception) | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Constructor

Overload List
 | Name | Description
Public method | AdvancedDocCleanException | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Public method | AdvancedDocCleanException(String) | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Protected method | AdvancedDocCleanException(SerializationInfo, StreamingContext) | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Public method | AdvancedDocCleanException(String, Exception) | This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.
Top
See Also

Reference

AdvancedDocCleanException Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Constructor

This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedDocCleanException()
Public Sub New
See Also

Reference

AdvancedDocCleanException Class
AdvancedDocCleanException Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Constructor (String)

This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedDocCleanException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

AdvancedDocCleanException Class
AdvancedDocCleanException Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Constructor (SerializationInfo, StreamingContext)

This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdvancedDocCleanException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AdvancedDocCleanException Class
AdvancedDocCleanException Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Constructor (String, Exception)

This exeption is thrown when an error occurs while processing an Advanced Document Cleanup command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedDocCleanException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

AdvancedDocCleanException Class
AdvancedDocCleanException Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Properties

The AdvancedDocCleanException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AdvancedDocCleanException Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Methods

The AdvancedDocCleanException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AdvancedDocCleanException Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AdvancedDocCleanException Events

The AdvancedDocCleanException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AdvancedDocCleanException Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand Class

Crops black borders from the edges of a bi-tonal image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoBorderCropCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoBorderCropCommand : ImageCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class AutoBorderCropCommand
    Inherits ImageCommand
    Implements IProcessSpeedConfig, ISerializable

The AutoBorderCropCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoBorderCropCommand | Creates a new instance of AutoBorderCropCommand.
Protected method | AutoBorderCropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AutoBorderCropCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BorderNoiseTolerance | The acceptable percentage of white pixel "noise" within the black border area.
Public property | BorderStreakTolerance | The acceptable percentage of white streaks within the black border area.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxBorderThickness | Gets or sets the maximum border thickness, in pixels, that will be removed.
Public property | MaxBoundaryWhitespace | The maximum amount of white space in pixels from the edge of the image to the start of the border.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Similar to AdvancedBorderRemovalCommand, but crops the image as opposed to making the border white. This command is much faster than AdvancedBorderRemoval.

Uses a more advanced algorithm than AutoCropCommand and BorderRemovalCommand included with DotImage Document Imaging.

When applying this command, the resulting ImageResults is an instance of AutoBorderCropResults containing the coordinates of the detected border.

Examples
[New Example] (C#)
Copy
AutoBorderCropCommand cmd = new AutoBorderCropCommand();
AutoBorderCropResults results = (AutoBorderCropResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
Rectangle borderRect = results.BorderRectangle;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As AutoBorderCropCommand = New AutoBorderCropCommand()
Dim results As AutoBorderCropResults = CType(cmd.Apply(sourceImage), TypeOf(AutoBorderCropResults))
Dim newImage As AtalaImage = results.Image
Dim borderRect As Rectangle = results.BorderRectangle
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
AdvancedBorderRemovalCommand Class
AutoBorderCropResults Class


AutoBorderCropCommand Constructor

Overload List
 | Name | Description
Public method | AutoBorderCropCommand | Creates a new instance of AutoBorderCropCommand.
Protected method | AutoBorderCropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AutoBorderCropCommand class
Top
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand Constructor

Creates a new instance of AutoBorderCropCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoBorderCropCommand()
Public Sub New
See Also

Reference

AutoBorderCropCommand Class
AutoBorderCropCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AutoBorderCropCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoBorderCropCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AutoBorderCropCommand Class
AutoBorderCropCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand Properties

The AutoBorderCropCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BorderNoiseTolerance | The acceptable percentage of white pixel "noise" within the black border area.
Public property | BorderStreakTolerance | The acceptable percentage of white streaks within the black border area.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxBorderThickness | Gets or sets the maximum border thickness, in pixels, that will be removed.
Public property | MaxBoundaryWhitespace | The maximum amount of white space in pixels from the edge of the image to the start of the border.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.BorderNoiseTolerance Property

AutoBorderCropCommandBorderNoiseTolerance Property

The acceptable percentage of white pixel "noise" within the black border area.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double BorderNoiseTolerance { get; set; }
Public Overridable Property BorderNoiseTolerance As Double
    Get
    Set

Property Value

Type: Double
Exceptions
Exception | Condition
 | Thrown when value is less than 0 or greater than 1.
Remarks
Valid values are from 0 to 1, with default of 0.15. A value of 0 indicates zero tolerance for noise where the entire border must be completely black.
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.BorderStreakTolerance Property

AutoBorderCropCommandBorderStreakTolerance Property

The acceptable percentage of white streaks within the black border area.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double BorderStreakTolerance { get; set; }
Public Overridable Property BorderStreakTolerance As Double
    Get
    Set

Property Value

Type: Double
Exceptions
Exception | Condition
 | Thrown when value is less than 0 or greater than 1.
Remarks
A "streak" is a solid white scanline when inspecting the border area. A set of white streaks with its thickness less than a number of MaxBorderThickness * StreakTolerance will be considered a part of the black border. Valid values are from 0 to 1, with a default value of 0.1.
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.MaxBorderThickness Property

AutoBorderCropCommandMaxBorderThickness Property

Gets or sets the maximum border thickness, in pixels, that will be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaxBorderThickness { get; set; }
Public Overridable Property MaxBorderThickness As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Thrown when value is less than 1.
Remarks
Default value is 60. The algorithm will only scan lines that are within this many pixels from the edge of the image.
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.MaxBoundaryWhitespace Property

AutoBorderCropCommandMaxBoundaryWhitespace Property

The maximum amount of white space in pixels from the edge of the image to the start of the border.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaxBoundaryWhitespace { get; set; }
Public Overridable Property MaxBoundaryWhitespace As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Thrown when value is less than 0.
Remarks
Default value is 16.
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.SpeedFactor Property

AutoBorderCropCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.SupportedPixelFormats Property

AutoBorderCropCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand Methods

The AutoBorderCropCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.ConstructFinalImage Method

AutoBorderCropCommandConstructFinalImage Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.GetObjectData Method

AutoBorderCropCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.PerformActualCommand Method

AutoBorderCropCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropCommand.VerifyProperties Method

AutoBorderCropCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

AutoBorderCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults Class

Provides custom ImageResults for AutoBorderCropCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentAutoBorderCropResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AutoBorderCropResults : ImageResults
Public Class AutoBorderCropResults
    Inherits ImageResults

The AutoBorderCropResults type exposes the following members.

Constructors
 | Name | Description
Public method | AutoBorderCropResults | Creates a new instance of AutoBorderCropResults.
Public method | AutoBorderCropResults(Rectangle) | Creates a new instance of AutoBorderCropResults specifying the boundary coordinates.
Top
Properties
 | Name | Description
Public property | BorderRectangle | Gets the rectangular coordinates of the detected border.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults Constructor

Overload List
 | Name | Description
Public method | AutoBorderCropResults | Creates a new instance of AutoBorderCropResults.
Public method | AutoBorderCropResults(Rectangle) | Creates a new instance of AutoBorderCropResults specifying the boundary coordinates.
Top
See Also

Reference

AutoBorderCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults Constructor

Creates a new instance of AutoBorderCropResults.
Creates a new instance of AutoBorderCropResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoBorderCropResults()
Public Sub New
See Also

Reference

AutoBorderCropResults Class
AutoBorderCropResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults Constructor (Rectangle)

Creates a new instance of AutoBorderCropResults specifying the boundary coordinates.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoBorderCropResults(
    Rectangle A_0
)
Public Sub New (
    A_0 As Rectangle
)

Parameters

A_0
Type: System.DrawingRectangle
See Also

Reference

AutoBorderCropResults Class
AutoBorderCropResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults Properties

The AutoBorderCropResults type exposes the following members.

Properties
 | Name | Description
Public property | BorderRectangle | Gets the rectangular coordinates of the detected border.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

AutoBorderCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults.BorderRectangle Property

AutoBorderCropResultsBorderRectangle Property

Gets the rectangular coordinates of the detected border.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle BorderRectangle { get; }
Public Overridable ReadOnly Property BorderRectangle As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

AutoBorderCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoBorderCropResults Methods

The AutoBorderCropResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutoBorderCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Class

The AutoDeskewCommand automatically deskews a binary image using %%company%%'s patent pending auto-deskew algorithm.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoDeskewCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoDeskewCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class AutoDeskewCommand
    Inherits ImageCommand
    Implements ISerializable

The AutoDeskewCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoDeskewCommand | Creates a new instance of AutoDeskewCommand.
Public method | AutoDeskewCommand(Rectangle) | Initializes a new instance of the AutoDeskewCommand with default settings and a rectangular area to process.
Public method | AutoDeskewCommand(Int32, Int32) | Initializes a new instance of the AutoDeskewCommand specifying the precision and limit angle.
Protected method | AutoDeskewCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoDeskewCommand from serialization information.
Public method | AutoDeskewCommand(Int32, Int32, Rectangle) | Initializes a new instance of the AutoDeskewCommand specifying the precision, limit angle, and rectangular area to process.
Public method | AutoDeskewCommand(Int32, Int32, AutoDeskewCropMode, Color, Rectangle) | Initializes a new instance of the AutoDeskewCommand specifying the precision, limit angle, crop mode, background color, and rectangular area to process.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | Area | Gets or sets rectangular area that will be used for determining the skew angle.
Public property | BackgroundColor | Gets or sets the background color to use when de-skewing the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Coverage | Represents the percentage of the image that will be randomly sampled when determining the skew angle.
Public property | CropMode | Gets or sets a value indicating the method of cropping the resulting de-skewed image.
Public property | ExtractBoundary | Gets or sets a value which will pre-process the image by removing solid filled areas of the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | LimitAngle | Gets or sets the maximum skew angle in degrees.
Public property | Precision | Gets or sets the precision of the de-skew angle calculation.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SkewAngle | Obsolete. Gets a value indicating the last detected skew angle.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetDeskewAngle | GetDeskewAngle returns the skew angle of the image without changing the image at all.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandIsPixelFormatSupported(PixelFormat).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This command works best with images containing horizontal text.

There are a few ways to improve performance. Decrease the LimitAngle and Precision or pass in a smaller rectangular area containing the horizontally aligned text area. The Coverage property can be decreased to increase performance, however it will result in loss accuracy. For guaranteed accuracy, set the Coverage property to 100.

The SkewAngle property is set to the last detected skew angle. See GetDeskewAngle(AtalaImage) to determine the skew angle without actually rotating the image.

As of 6.0 AutoDeskewCommnd now additionally supports the following image formats: ,Pixel8bppGrayscale, Pixel24bppBgr, Pixel32bppBgr and Pixel32bppBgra.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor

Create an AutoDeskewCommand that will attempt to calculate the amount of skewing in an image, then rotate the image to correct the skew.
Overload List
 | Name | Description
Public method | AutoDeskewCommand | Creates a new instance of AutoDeskewCommand.
Public method | AutoDeskewCommand(Rectangle) | Initializes a new instance of the AutoDeskewCommand with default settings and a rectangular area to process.
Public method | AutoDeskewCommand(Int32, Int32) | Initializes a new instance of the AutoDeskewCommand specifying the precision and limit angle.
Protected method | AutoDeskewCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoDeskewCommand from serialization information.
Public method | AutoDeskewCommand(Int32, Int32, Rectangle) | Initializes a new instance of the AutoDeskewCommand specifying the precision, limit angle, and rectangular area to process.
Public method | AutoDeskewCommand(Int32, Int32, AutoDeskewCropMode, Color, Rectangle) | Initializes a new instance of the AutoDeskewCommand specifying the precision, limit angle, crop mode, background color, and rectangular area to process.
Top
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor

Creates a new instance of AutoDeskewCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewCommand()
Public Sub New
See Also

Reference

AutoDeskewCommand Class
AutoDeskewCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor (Rectangle)

Initializes a new instance of the AutoDeskewCommand with default settings and a rectangular area to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewCommand(
    Rectangle area
)
Public Sub New (
    area As Rectangle
)

Parameters

area
Type: System.DrawingRectangle
A rectangular area that will be used for determining the deskew angle.
See Also

Reference

AutoDeskewCommand Class
AutoDeskewCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor (Int32, Int32)

Initializes a new instance of the AutoDeskewCommand specifying the precision and limit angle.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewCommand(
    int precision,
    int limitAngle
)
Public Sub New (
    precision As Integer,
    limitAngle As Integer
)

Parameters

precision
Type: SystemInt32
The precision of the deskew angle calculation. This value is the inverse of the degree precision.
limitAngle
Type: SystemInt32
The maximum deskew angle in degrees. (-360 to 360 excluding 0)
Exceptions
Exception | Condition
 | Thrown if the percision is less than 1 or if limitAngle is less than -360, greater than 360 or equal to 0.
See Also

Reference

AutoDeskewCommand Class
AutoDeskewCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AutoDeskewCommand from serialization information.
Initializes a new instance of the AutoDeskewCommand. Initializes a new instance of the AutoDeskewCommand with default settings

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoDeskewCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AutoDeskewCommand Class
AutoDeskewCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor (Int32, Int32, Rectangle)

Initializes a new instance of the AutoDeskewCommand specifying the precision, limit angle, and rectangular area to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewCommand(
    int precision,
    int limitAngle,
    Rectangle area
)
Public Sub New (
    precision As Integer,
    limitAngle As Integer,
    area As Rectangle
)

Parameters

precision
Type: SystemInt32
The precision of the deskew angle calculation. This value is the inverse of the degree precision.
limitAngle
Type: SystemInt32
The maximum deskew angle in degrees. (-360 to 360 excluding 0)
area
Type: System.DrawingRectangle
The rectangular area that will be used for determing the deskew angle.
Exceptions
Exception | Condition
 | Thrown if the percision is less than 1 or if limitAngle is less than -360, greater than 360 or equal to 0.
See Also

Reference

AutoDeskewCommand Class
AutoDeskewCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Constructor (Int32, Int32, AutoDeskewCropMode, Color, Rectangle)

Initializes a new instance of the AutoDeskewCommand specifying the precision, limit angle, crop mode, background color, and rectangular area to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewCommand(
    int precision,
    int limitAngle,
    AutoDeskewCropMode cropMode,
    Color backgroundColor,
    Rectangle area
)
Public Sub New (
    precision As Integer,
    limitAngle As Integer,
    cropMode As AutoDeskewCropMode,
    backgroundColor As Color,
    area As Rectangle
)

Parameters

precision
Type: SystemInt32
The precision of the deskew angle calculation. This value is the inverse of the degree precision.
limitAngle
Type: SystemInt32
The maximum deskew angle in degrees. (-360 to 360 excluding 0)
cropMode
Type: Atalasoft.Imaging.ImageProcessing.DocumentAutoDeskewCropMode
The method of cropping the resulting deskewed image.
backgroundColor
Type: System.DrawingColor
The background color to use when deskewing the image.
area
Type: System.DrawingRectangle
The rectangular area that will be used for determining the deskew angle.
Exceptions
Exception | Condition
 | Thrown if the percision is less than 1 or if limitAngle is less than -360, greater than 360 or equal to 0.
See Also

Reference

AutoDeskewCommand Class
AutoDeskewCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Properties

The AutoDeskewCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | Area | Gets or sets rectangular area that will be used for determining the skew angle.
Public property | BackgroundColor | Gets or sets the background color to use when de-skewing the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Coverage | Represents the percentage of the image that will be randomly sampled when determining the skew angle.
Public property | CropMode | Gets or sets a value indicating the method of cropping the resulting de-skewed image.
Public property | ExtractBoundary | Gets or sets a value which will pre-process the image by removing solid filled areas of the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | LimitAngle | Gets or sets the maximum skew angle in degrees.
Public property | Precision | Gets or sets the precision of the de-skew angle calculation.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SkewAngle | Obsolete. Gets a value indicating the last detected skew angle.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.Area Property

AutoDeskewCommandArea Property

Gets or sets rectangular area that will be used for determining the skew angle.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Area { get; set; }
Public Property Area As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular area that will be used for determining the skew angle.
Remarks
This value by default is Rectangle.Empty and will use the entire image for calculating the angle.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.BackgroundColor Property

AutoDeskewCommandBackgroundColor Property

Gets or sets the background color to use when de-skewing the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use when de-skewing the image.
Remarks
The background color is only relevant when the CropMode is set to None or OriginalSize. The default value is White.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.Coverage Property

AutoDeskewCommandCoverage Property

Represents the percentage of the image that will be randomly sampled when determining the skew angle.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Coverage { get; set; }
Public Property Coverage As Double
    Get
    Set

Property Value

Type: Double
A value representing the percent of coverage from 0 to 100.
Exceptions
Exception | Condition
 | Thrown if the value is less than 0 or greater than 100.
Remarks

Given the random nature of the coverage, low values result in must faster performance than 100% coverage with generally the same results. A default value of 8 was derived after tests with many images. This results in accurate skew angle detection with fast speed. This property is exposed for edge cases where 8 is not sufficient. When accuracy is of utmost importance at the expense of speed, set this value to 100.

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.CropMode Property

AutoDeskewCommandCropMode Property

Gets or sets a value indicating the method of cropping the resulting de-skewed image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewCropMode CropMode { get; set; }
Public Property CropMode As AutoDeskewCropMode
    Get
    Set

Property Value

Type: AutoDeskewCropMode
A value indicating the method of cropping the resulting de-skewed image. The default value is FullCrop.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.ExtractBoundary Property

AutoDeskewCommandExtractBoundary Property

Gets or sets a value which will pre-process the image by removing solid filled areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ExtractBoundary { get; set; }
Public Property ExtractBoundary As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Setting this value to false will improve performance at the expense of accuracy. If the image is known not to have solid filled areas, then it's safe to set this property to false, for an approximate 50% performance gain. The default value is true.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.LimitAngle Property

AutoDeskewCommandLimitAngle Property

Gets or sets the maximum skew angle in degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LimitAngle { get; set; }
Public Property LimitAngle As Integer
    Get
    Set

Property Value

Type: Int32
The maximum skew angle in degrees.
Exceptions
Exception | Condition
 | Thrown when value is not between -360 and 360 or is equal to 0.
Remarks
Decreasing this value improves performance, while increasing improves the chance that a drastically skewed image will be straightened. The default value is 20 degrees.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.Precision Property

AutoDeskewCommandPrecision Property

Gets or sets the precision of the de-skew angle calculation.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Precision { get; set; }
Public Property Precision As Integer
    Get
    Set

Property Value

Type: Int32
The precision of the de-skew angle calculation.
Exceptions
Exception | Condition
 | Thrown if the value is less than 1.
Remarks
This value is the inverse of the smallest angle increment that it will find. For example, a value of 1 = 1 degree precision, 2 = 1/2 degree precision, 4 = 1/4 degree precision, etc. The smaller the value the more time it takes to calculate the de-skew angle. The default value is 2 (or 1/2 a degree).
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.SkewAngle Property

AutoDeskewCommandSkewAngle Property

Note: This API is now obsolete.

Gets a value indicating the last detected skew angle.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use AutoDeskewResults from the Apply method instead")]
public double SkewAngle { get; }
<ObsoleteAttribute("Please use AutoDeskewResults from the Apply method instead")>
Public ReadOnly Property SkewAngle As Double
    Get

Property Value

Type: Double
A value indicating the last detected skew angle.
Remarks
Query this read-only property to determine the last detected skew angle.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.SupportedPixelFormats Property

AutoDeskewCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override sealed PixelFormat[] SupportedPixelFormats { get; }
Public Overrides NotOverridable ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand Methods

The AutoDeskewCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetDeskewAngle | GetDeskewAngle returns the skew angle of the image without changing the image at all.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandIsPixelFormatSupported(PixelFormat).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Represents the base class for all image processing routines that modify image data. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.ConstructFinalImage Method

AutoDeskewCommandConstructFinalImage Method

Represents the base class for all image processing routines that modify image data.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand method in the Workspace.

See Extending ImageCommands for more information on creating custom commands.

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace
Extending ImageCommands
Extending ImageCommands


AutoDeskewCommand.ConstructImageResults Method

AutoDeskewCommandConstructImageResults Method

Represents the base class for all image processing routines that modify image data.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageResults ConstructImageResults()
Protected Overrides Function ConstructImageResults As ImageResults

Return Value

Type: ImageResults
Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand method in the Workspace.

See Extending ImageCommands for more information on creating custom commands.

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace
Extending ImageCommands
Extending ImageCommands


AutoDeskewCommand.GetDeskewAngle Method

AutoDeskewCommandGetDeskewAngle Method

GetDeskewAngle returns the skew angle of the image without changing the image at all.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetDeskewAngle(
    AtalaImage sourceImage
)
Public Function GetDeskewAngle (
    sourceImage As AtalaImage
) As Double

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to calculate the skew angle from.

Return Value

Type: Double
The skew angle (in degrees) of the image.

Return Value

Type: Double
The deskew angle in degrees.
Exceptions
Exception | Condition
 | Thrown if the source image is not 1 bit per pixel.
Remarks
See the SkewAngle property for determining the skew angle after processing the image.
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.GetObjectData Method

AutoDeskewCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewCommand.IsPixelFormatSupported Method

AutoDeskewCommandIsPixelFormatSupported Method

Represents the base class for all image processing routines that modify image data.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override sealed bool IsPixelFormatSupported(
    PixelFormat format
)
Public Overrides NotOverridable Function IsPixelFormatSupported (
    format As PixelFormat
) As Boolean

Parameters

format
Type: Atalasoft.ImagingPixelFormat

Return Value

Type: Boolean
Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand method in the Workspace.

See Extending ImageCommands for more information on creating custom commands.

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace
Extending ImageCommands
Extending ImageCommands


AutoDeskewCommand.PerformActualCommand Method

AutoDeskewCommandPerformActualCommand Method

Represents the base class for all image processing routines that modify image data.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand method in the Workspace.

See Extending ImageCommands for more information on creating custom commands.

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace
Extending ImageCommands
Extending ImageCommands


AutoDeskewCommand.VerifyProperties Method

AutoDeskewCommandVerifyProperties Method

Represents the base class for all image processing routines that modify image data.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
Remarks

An ImageCommand can be used to apply any type of effect onto an existing image. The Apply method can be used to process the command. Classes that inherit ImageCommand can be used in the ApplyCommand method in the Workspace.

See Extending ImageCommands for more information on creating custom commands.

See Also

Reference

AutoDeskewCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace
Extending ImageCommands
Extending ImageCommands


AutoDeskewCropMode Enumeration

The crop mode to use in the AutoDeskewCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AutoDeskewCropMode
Public Enumeration AutoDeskewCropMode
Members
Member name | Description
None | Do not crop the deskewed image. The resulting image will be larger then the source image.
FullCrop | Crop all of the excess rotated area. The resulting image will be smaller then the source image.
OriginalSize | Crop the deskewed image to the original size.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults Class

This class represents the results of applying the AutoDeskewCommand on an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentAutoDeskewResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AutoDeskewResults : ImageResults
Public Class AutoDeskewResults
    Inherits ImageResults

The AutoDeskewResults type exposes the following members.

Constructors
 | Name | Description
Public method | AutoDeskewResults | Constructs a new AutoDeskewImageResults object.
Public method | AutoDeskewResults(Double) | Constructs a new AutoDeskewImageResults object.
Top
Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | SkewAngle | Gets the detected angle of rotation in the image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults Constructor

Constructs a new AutoDeskewImageResults object.
Overload List
 | Name | Description
Public method | AutoDeskewResults | Constructs a new AutoDeskewImageResults object.
Public method | AutoDeskewResults(Double) | Constructs a new AutoDeskewImageResults object.
Top
See Also

Reference

AutoDeskewResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults Constructor

Constructs a new AutoDeskewImageResults object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewResults()
Public Sub New
See Also

Reference

AutoDeskewResults Class
AutoDeskewResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults Constructor (Double)

Constructs a new AutoDeskewImageResults object.
Constructs a new AutoDeskewImageResults object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDeskewResults(
    double skewAngle
)
Public Sub New (
    skewAngle As Double
)

Parameters

skewAngle
Type: SystemDouble
The detected skew angle.
Remarks
This class is created by calling the AutoDeskewCommand.Apply() method. You don't need to construct one normally.
See Also

Reference

AutoDeskewResults Class
AutoDeskewResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults Properties

The AutoDeskewResults type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | SkewAngle | Gets the detected angle of rotation in the image.
Top
See Also

Reference

AutoDeskewResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults.SkewAngle Property

AutoDeskewResultsSkewAngle Property

Gets the detected angle of rotation in the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SkewAngle { get; }
Public ReadOnly Property SkewAngle As Double
    Get

Property Value

Type: Double
The detected angle of rotation in the image
See Also

Reference

AutoDeskewResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoDeskewResults Methods

The AutoDeskewResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutoDeskewResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand Class

Automatically inverts regions of text that are inverted (white on black) on a bi-tonal image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoInvertTextCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoInvertTextCommand : ImageRegionCommand,
    IPropertiesAutoConfigurable, ISerializable
<SerializableAttribute>
Public Class AutoInvertTextCommand
    Inherits ImageRegionCommand
    Implements IPropertiesAutoConfigurable, ISerializable

The AutoInvertTextCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoInvertTextCommand | Creates an instance of AutoInverseTextCorrectionCommand.
Protected method | AutoInvertTextCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AutoInvertTextCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoPropertyConfigurationEnabled | Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | InvertedRegionSizeMaximum | Obsolete. Maximum size in pixels of the inverted text region.
Public property | InvertedRegionSizeMinimum | Obsolete. Minimum size limit of of inverted text region in pixels.
Public property | MaxInvertedRegionSize |
Public property | MinInvertedRegionSize |
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | PropertiesToAutoConfigure | Gets a collection of property names that will be auto configured when AutoPropertyConfigurationEnabled is true.
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor |
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command is useful when pre-processing documents prior to OCR, as many OCR engines do not recognize inverted text areas.
Examples
[New Example] (C#)
Copy
AutoInvertTextCommand cmd = new AutoInvertTextCommand();
ImageResults results = cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As AutoInvertTextCommand = New AutoInvertTextCommand()
Dim results As ImageResults = cmd.Apply(sourceImage)
Dim newImage As AtalaImage = results.Image
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand Constructor

Overload List
 | Name | Description
Public method | AutoInvertTextCommand | Creates an instance of AutoInverseTextCorrectionCommand.
Protected method | AutoInvertTextCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AutoInvertTextCommand class
Top
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand Constructor

Creates an instance of AutoInverseTextCorrectionCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoInvertTextCommand()
Public Sub New
See Also

Reference

AutoInvertTextCommand Class
AutoInvertTextCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AutoInvertTextCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoInvertTextCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AutoInvertTextCommand Class
AutoInvertTextCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand Properties

The AutoInvertTextCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoPropertyConfigurationEnabled | Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | InvertedRegionSizeMaximum | Obsolete. Maximum size in pixels of the inverted text region.
Public property | InvertedRegionSizeMinimum | Obsolete. Minimum size limit of of inverted text region in pixels.
Public property | MaxInvertedRegionSize |
Public property | MinInvertedRegionSize |
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | PropertiesToAutoConfigure | Gets a collection of property names that will be auto configured when AutoPropertyConfigurationEnabled is true.
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor |
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.AutoPropertyConfigurationEnabled Property

AutoInvertTextCommandAutoPropertyConfigurationEnabled Property

Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool AutoPropertyConfigurationEnabled { get; set; }
Public Overridable Property AutoPropertyConfigurationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IPropertiesAutoConfigurableAutoPropertyConfigurationEnabled
Remarks
Set this to false when hand tweaking auto configurable properties. Default value is true.
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.InvertedRegionSizeMaximum Property

AutoInvertTextCommandInvertedRegionSizeMaximum Property

Note: This API is now obsolete.

Maximum size in pixels of the inverted text region.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use MaxInvertedRegionSize")]
public virtual Size InvertedRegionSizeMaximum { get; set; }
<ObsoleteAttribute("Use MaxInvertedRegionSize")>
Public Overridable Property InvertedRegionSizeMaximum As Size
    Get
    Set

Property Value

Type: Size
Size
Remarks
Auto configurable. Default value is 400, 400.
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.InvertedRegionSizeMinimum Property

AutoInvertTextCommandInvertedRegionSizeMinimum Property

Note: This API is now obsolete.

Minimum size limit of of inverted text region in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use MinInvertedRegionSize")]
public virtual Size InvertedRegionSizeMinimum { get; set; }
<ObsoleteAttribute("Use MinInvertedRegionSize")>
Public Overridable Property InvertedRegionSizeMinimum As Size
    Get
    Set

Property Value

Type: Size
Size
Remarks
Auto configurable. Default size is 40, 40.
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.MaxInvertedRegionSize Property

AutoInvertTextCommandMaxInvertedRegionSize Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MaxInvertedRegionSize { get; set; }
Public Overridable Property MaxInvertedRegionSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.MinInvertedRegionSize Property

AutoInvertTextCommandMinInvertedRegionSize Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinInvertedRegionSize { get; set; }
Public Overridable Property MinInvertedRegionSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.PropertiesToAutoConfigure Property

AutoInvertTextCommandPropertiesToAutoConfigure Property

Gets a collection of property names that will be auto configured when AutoPropertyConfigurationEnabled is true.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual StringCollection PropertiesToAutoConfigure { get; }
Public Overridable ReadOnly Property PropertiesToAutoConfigure As StringCollection
    Get

Property Value

Type: StringCollection

Implements

IPropertiesAutoConfigurablePropertiesToAutoConfigure
Remarks
This collection can be modified by adding or removing property names to be auto configured. Properties must have the AutoConfigurableAttribute to be added to this collection. All AutoConfigurable properties are added to this collection by default including InvertedRegionSizeMinimum, InvertedRegionSizeMaximum, and TextThickness.
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.SpeedFactor Property

AutoInvertTextCommandSpeedFactor Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.SupportedPixelFormats Property

AutoInvertTextCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand Methods

The AutoInvertTextCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.GetObjectData Method

AutoInvertTextCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.PerformActualCommand Method

AutoInvertTextCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoInvertTextCommand.VerifyProperties Method

AutoInvertTextCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

AutoInvertTextCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand Class

Inspects an bi-tonal image to determine if the image is negated. Will automatically invert the image if InvertWhenWhiteOnBlack.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentAutoNegateCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoNegateCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class AutoNegateCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The AutoNegateCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoNegateCommand | Creates a new instance of AutoNegateCommand.
Public method | AutoNegateCommand(Boolean) | Initializes a new instance of AutoNegateCommand specifying if the command should invert the image, or just report results.
Protected method | AutoNegateCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AutoNegateCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Returns true because this command will process the image in-place and not allocate a new block of memory. (Overrides ImageCommandInPlaceProcessing.)
Public property | InvertWhenWhiteOnBlack | When true will automatically invert the image when the resulting IsInverted property is true.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

When applying this command, the resulting ImageResults is an instance of AutoNegateResults containing a boolean IsInverted property.

When RegionOfInterest is specified, it is used for detection purpose only. Invert image process is applying on whole image if necessary.

Examples
[New Example] (C#)
Copy
AutoNegateCommand cmd = new AutoNegateCommand();
AutoNegateResults results = (AutoNegateResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image; //the negated image
bool inverted = results.IsInverted;
[New Example] (Visual Basic)
Copy
Dim cmd As AutoNegateCommand New AutoNegateCommand()
Dim results As AutoNegateResults = CType(cmd.Apply(sourceImage), TypeOf(AutoNegateResults))
Dim newImage As AtalaImage = results.Image 'the negated image
Dim inverted As Boolean = results.IsInverted
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
AutoNegateResults Class


AutoNegateCommand Constructor

Overload List
 | Name | Description
Public method | AutoNegateCommand | Creates a new instance of AutoNegateCommand.
Public method | AutoNegateCommand(Boolean) | Initializes a new instance of AutoNegateCommand specifying if the command should invert the image, or just report results.
Protected method | AutoNegateCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AutoNegateCommand class
Top
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand Constructor

Creates a new instance of AutoNegateCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoNegateCommand()
Public Sub New
See Also

Reference

AutoNegateCommand Class
AutoNegateCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand Constructor (Boolean)

Initializes a new instance of AutoNegateCommand specifying if the command should invert the image, or just report results.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoNegateCommand(
    bool invertWhenWhiteOnBlack
)
Public Sub New (
    invertWhenWhiteOnBlack As Boolean
)

Parameters

invertWhenWhiteOnBlack
Type: SystemBoolean
See Also

Reference

AutoNegateCommand Class
AutoNegateCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AutoNegateCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoNegateCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AutoNegateCommand Class
AutoNegateCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand Properties

The AutoNegateCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Returns true because this command will process the image in-place and not allocate a new block of memory. (Overrides ImageCommandInPlaceProcessing.)
Public property | InvertWhenWhiteOnBlack | When true will automatically invert the image when the resulting IsInverted property is true.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.InPlaceProcessing Property

AutoNegateCommandInPlaceProcessing Property

Returns true because this command will process the image in-place and not allocate a new block of memory.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.InvertWhenWhiteOnBlack Property

AutoNegateCommandInvertWhenWhiteOnBlack Property

When true will automatically invert the image when the resulting IsInverted property is true.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool InvertWhenWhiteOnBlack { get; set; }
Public Overridable Property InvertWhenWhiteOnBlack As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.SpeedFactor Property

AutoNegateCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.SupportedPixelFormats Property

AutoNegateCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand Methods

The AutoNegateCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.GetObjectData Method

AutoNegateCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.PerformActualCommand Method

AutoNegateCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateCommand.VerifyProperties Method

AutoNegateCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

AutoNegateCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateResults Class

Provides a custom ImageResults for the AutoNegateCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentAutoNegateResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AutoNegateResults : ImageResults
Public Class AutoNegateResults
    Inherits ImageResults

The AutoNegateResults type exposes the following members.

Constructors
 | Name | Description
Public method | AutoNegateResults | Creates a new instance of AutoNegateResults.
Public method | AutoNegateResults(Boolean) | Creates a new instance of AutoNegateResults specifying the value of IsInverted.
Top
Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | IsInverted | Gets a value indicating if the given image is inverted (White on Black).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
AutoNegateCommand Class


AutoNegateResults Constructor

Overload List
 | Name | Description
Public method | AutoNegateResults | Creates a new instance of AutoNegateResults.
Public method | AutoNegateResults(Boolean) | Creates a new instance of AutoNegateResults specifying the value of IsInverted.
Top
See Also

Reference

AutoNegateResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateResults Constructor

Creates a new instance of AutoNegateResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoNegateResults()
Public Sub New
See Also

Reference

AutoNegateResults Class
AutoNegateResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateResults Constructor (Boolean)

Creates a new instance of AutoNegateResults specifying the value of IsInverted.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoNegateResults(
    bool A_0
)
Public Sub New (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
See Also

Reference

AutoNegateResults Class
AutoNegateResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateResults Properties

The AutoNegateResults type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | IsInverted | Gets a value indicating if the given image is inverted (White on Black).
Top
See Also

Reference

AutoNegateResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateResults.IsInverted Property

AutoNegateResultsIsInverted Property

Gets a value indicating if the given image is inverted (White on Black).

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsInverted { get; }
Public Overridable ReadOnly Property IsInverted As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

AutoNegateResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


AutoNegateResults Methods

The AutoNegateResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutoNegateResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Class

Converts a grayscale or color image to black and white using one of the available Binarize methods.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentBinarizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BinarizeCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class BinarizeCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The BinarizeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BinarizeCommand | Creates a new instance of BinarizeCommand.
Public method | BinarizeCommand(BinarizeMethod) | Creates a new instance of BinarizeCommand specifying the binarization method.
Protected method | BinarizeCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the BinarizeCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BinarizationMethod | Gets or sets a value indicating the type of binarization to use.
Public property | BlackGrouping | A percentile indication of how tightly grouped black pixels need to be.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InitialThreshold | Gets or sets the seed threshold value to use for GlobalThreshold and the actual threshold value to use for SimpleThreshold methods.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaskWindowSize |
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports all continuous tone pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Public property | ThresholdDifferencing | Gets or sets the thresholding differencing used for the AdaptiveThreshold method.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Examples
C#
Copy
BinarizeCommand cmd = new BinarizeCommand(BinarizeMethod.AdaptiveThreshold);
ImageResults results = cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As BinarizeCommand = New BinarizeCommand(BinarizeMethod.AdaptiveThreshold)
Dim results As ImageResults = cmd.Apply(sourceImage)
Dim newImage As AtalaImage = results.Image
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Constructor

Overload List
 | Name | Description
Public method | BinarizeCommand | Creates a new instance of BinarizeCommand.
Public method | BinarizeCommand(BinarizeMethod) | Creates a new instance of BinarizeCommand specifying the binarization method.
Protected method | BinarizeCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the BinarizeCommand class
Top
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Constructor

Creates a new instance of BinarizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BinarizeCommand()
Public Sub New
See Also

Reference

BinarizeCommand Class
BinarizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Constructor (BinarizeMethod)

Creates a new instance of BinarizeCommand specifying the binarization method.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BinarizeCommand(
    BinarizeMethod binarizationMethod
)
Public Sub New (
    binarizationMethod As BinarizeMethod
)

Parameters

binarizationMethod
Type: Atalasoft.Imaging.ImageProcessing.DocumentBinarizeMethod
See Also

Reference

BinarizeCommand Class
BinarizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the BinarizeCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BinarizeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BinarizeCommand Class
BinarizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Properties

The BinarizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BinarizationMethod | Gets or sets a value indicating the type of binarization to use.
Public property | BlackGrouping | A percentile indication of how tightly grouped black pixels need to be.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InitialThreshold | Gets or sets the seed threshold value to use for GlobalThreshold and the actual threshold value to use for SimpleThreshold methods.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaskWindowSize |
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports all continuous tone pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Public property | ThresholdDifferencing | Gets or sets the thresholding differencing used for the AdaptiveThreshold method.
Top
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.BinarizationMethod Property

BinarizeCommandBinarizationMethod Property

Gets or sets a value indicating the type of binarization to use.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual BinarizeMethod BinarizationMethod { get; set; }
Public Overridable Property BinarizationMethod As BinarizeMethod
    Get
    Set

Property Value

Type: BinarizeMethod
Remarks
Default value is AdaptiveThreshold.
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.BlackGrouping Property

BinarizeCommandBlackGrouping Property

A percentile indication of how tightly grouped black pixels need to be.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double BlackGrouping { get; set; }
Public Overridable Property BlackGrouping As Double
    Get
    Set

Property Value

Type: Double
Remarks
A value from 0 to 1. Default is 0.25. 0.4 is roughly equivalent to the AdaptiveThresholding command
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.InitialThreshold Property

BinarizeCommandInitialThreshold Property

Gets or sets the seed threshold value to use for GlobalThreshold and the actual threshold value to use for SimpleThreshold methods.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int InitialThreshold { get; set; }
Public Overridable Property InitialThreshold As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Throws when value is less than 1 or greater than 255.
Remarks
Default value is 127.
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.MaskWindowSize Property

BinarizeCommandMaskWindowSize Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaskWindowSize { get; set; }
Public Overridable Property MaskWindowSize As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.SupportedPixelFormats Property

BinarizeCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports all continuous tone pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.ThresholdDifferencing Property

BinarizeCommandThresholdDifferencing Property

Gets or sets the thresholding differencing used for the AdaptiveThreshold method.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int ThresholdDifferencing { get; set; }
Public Overridable Property ThresholdDifferencing As Integer
    Get
    Set

Property Value

Type: Int32
Exceptions
Exception | Condition
 | Throws when value is less than 1 or greater than 255.
Remarks
Default is 7.
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand Methods

The BinarizeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.ConstructChangedSourceImage Method

BinarizeCommandConstructChangedSourceImage Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.ConstructFinalImage Method

BinarizeCommandConstructFinalImage Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.GetObjectData Method

BinarizeCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.PerformActualCommand Method

BinarizeCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeCommand.VerifyProperties Method

BinarizeCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

BinarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BinarizeMethod Enumeration

Lists the supported binarization methods used in the BinarizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BinarizeMethod
Public Enumeration BinarizeMethod
Members
Member name | Description
SimpleThreshold | Simple, fast thresholding with level determined by user.
GlobalThreshold | Threshold level determined from entire image. Useful for removing shaded regions, but could remove light colored content such as watermarks.
AdaptiveThreshold | Adapts to surrounding pixels, highlights subtle changes in intensity. Most forgiving thresholding method but can produce noisy images.
DynamicThreshold | Dynamically adapts to surrounding pixels, highlights subtle changes in intensity. More faithful to large dark areas.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand Class

Detect whether a given image (or a region of interest in the image) is blank.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentBlankPageDetectionCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BlankPageDetectionCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class BlankPageDetectionCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The BlankPageDetectionCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BlankPageDetectionCommand | Creates a new instance of BlankPageDetectionCommand.
Protected method | BlankPageDetectionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the BlankPageDetectionCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise | Will remove noise in the image prior to detecting blank page when true.
Public property | InPlaceProcessing | Returns true because this command doesn't actually return a new image, just returns the source image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MinObjectSize | Objects that are smaller than this size will be ignored when detecting blank pages.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | RemoveBorder | Will remove black borders in the image prior to detecting blank page when true.
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

A custom ImageResults is returned called BlankPageDetectionResults with the property IsImageBlank. Use this property to determine if the image is blank or not.

Note that this command supports bitonal images only, however it can be used with color images as well by setting ApplyToAnyPixelFormat to true. When doing this, be sure to set the DefaultPixelFormatChanger to one that uses a Document Thresholding method.

Examples

Simple example of determining if an image is blank.

C#
VB
Copy
BlankPageDetectionCommand bpd = new BlankPageDetectionCommand();
BlankPageDetectionResults results = bpd.Apply(image) as BlankPageDetectionResults;
bool isBlank = results.IsImageBlank;
Dim bpd As BlankPageDetectionCommand = New BlankPageDetectionCommand()
Dim results As BlankPageDetectionResults = CType(bpd.Apply(image), Typeof(BlankPageDetectionResults))
Dim isBlank As Boolean = results.IsImageBlank
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
BlankPageDetectionResults Class


BlankPageDetectionCommand Constructor

Overload List
 | Name | Description
Public method | BlankPageDetectionCommand | Creates a new instance of BlankPageDetectionCommand.
Protected method | BlankPageDetectionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the BlankPageDetectionCommand class
Top
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand Constructor

Creates a new instance of BlankPageDetectionCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlankPageDetectionCommand()
Public Sub New
See Also

Reference

BlankPageDetectionCommand Class
BlankPageDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the BlankPageDetectionCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BlankPageDetectionCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BlankPageDetectionCommand Class
BlankPageDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand Properties

The BlankPageDetectionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise | Will remove noise in the image prior to detecting blank page when true.
Public property | InPlaceProcessing | Returns true because this command doesn't actually return a new image, just returns the source image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MinObjectSize | Objects that are smaller than this size will be ignored when detecting blank pages.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | RemoveBorder | Will remove black borders in the image prior to detecting blank page when true.
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.Denoise Property

BlankPageDetectionCommandDenoise Property

Will remove noise in the image prior to detecting blank page when true.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Denoise { get; set; }
Public Overridable Property Denoise As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is true.
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.InPlaceProcessing Property

BlankPageDetectionCommandInPlaceProcessing Property

Returns true because this command doesn't actually return a new image, just returns the source image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.MinObjectSize Property

BlankPageDetectionCommandMinObjectSize Property

Objects that are smaller than this size will be ignored when detecting blank pages.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinObjectSize { get; set; }
Public Overridable Property MinObjectSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is (10, 20).
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.RemoveBorder Property

BlankPageDetectionCommandRemoveBorder Property

Will remove black borders in the image prior to detecting blank page when true.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool RemoveBorder { get; set; }
Public Overridable Property RemoveBorder As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false.
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.SpeedFactor Property

BlankPageDetectionCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Fast.
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.SupportedPixelFormats Property

BlankPageDetectionCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand Methods

The BlankPageDetectionCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.GetObjectData Method

BlankPageDetectionCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.PerformActualCommand Method

BlankPageDetectionCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionCommand.VerifyProperties Method

BlankPageDetectionCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

BlankPageDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionResults Class

Provides a custom ImageResults for BlankPageDetectionCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentBlankPageDetectionResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BlankPageDetectionResults : ImageResults
Public Class BlankPageDetectionResults
    Inherits ImageResults

The BlankPageDetectionResults type exposes the following members.

Constructors
 | Name | Description
Public method | BlankPageDetectionResults | Creates a new instance of BlankPageDetectionResults.
Public method | BlankPageDetectionResults(Boolean) | Creates a new instance of BlankPageDetectionResults specifying IsImageBlank.
Top
Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageBlank | Gets a value that when true indicates the image (or region of interest of the image) is blank as a result of BlankPageDetectionCommand.
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
BlankPageDetectionCommand Class


BlankPageDetectionResults Constructor

Overload List
 | Name | Description
Public method | BlankPageDetectionResults | Creates a new instance of BlankPageDetectionResults.
Public method | BlankPageDetectionResults(Boolean) | Creates a new instance of BlankPageDetectionResults specifying IsImageBlank.
Top
See Also

Reference

BlankPageDetectionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionResults Constructor

Creates a new instance of BlankPageDetectionResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlankPageDetectionResults()
Public Sub New
See Also

Reference

BlankPageDetectionResults Class
BlankPageDetectionResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionResults Constructor (Boolean)

Creates a new instance of BlankPageDetectionResults specifying IsImageBlank.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlankPageDetectionResults(
    bool A_0
)
Public Sub New (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
See Also

Reference

BlankPageDetectionResults Class
BlankPageDetectionResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionResults Properties

The BlankPageDetectionResults type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageBlank | Gets a value that when true indicates the image (or region of interest of the image) is blank as a result of BlankPageDetectionCommand.
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

BlankPageDetectionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionResults.IsImageBlank Property

BlankPageDetectionResultsIsImageBlank Property

Gets a value that when true indicates the image (or region of interest of the image) is blank as a result of BlankPageDetectionCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsImageBlank { get; }
Public Overridable ReadOnly Property IsImageBlank As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

BlankPageDetectionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlankPageDetectionResults Methods

The BlankPageDetectionResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BlankPageDetectionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand Class

A generic object removal command for bi-tonal images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentBlobRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BlobRemovalCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class BlobRemovalCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The BlobRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BlobRemovalCommand | Creates a new instance of BlobRemovalCommand.
Protected method | BlobRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the BlobRemovalCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxObjectSize |
Public property | MinObjectSize | Minimum size of the object to remove.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Objects of which sizes are between minium and maximum user-input size will be removed out of a given image.

Other commands such as HolePunchRemovalCommand are specialized versions of BlobRemovalCommand.

Examples
[New Example] (C#)
Copy
BlobRemovalCommand cmd = new BlobRemovalCommand();
cmd.MaxObjectSize = new Size(300, 300);
ImageResults results = cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As BlobRemovalCommand = New BlobRemovalCommand()
cmd.MaxObjectSize = New Size(300, 300)
Dim results As ImageResults = cmd.Apply(sourceImage)
Dim newImage As AtalaImage = results.Image
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand Constructor

Overload List
 | Name | Description
Public method | BlobRemovalCommand | Creates a new instance of BlobRemovalCommand.
Protected method | BlobRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the BlobRemovalCommand class
Top
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand Constructor

Creates a new instance of BlobRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlobRemovalCommand()
Public Sub New
See Also

Reference

BlobRemovalCommand Class
BlobRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the BlobRemovalCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BlobRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BlobRemovalCommand Class
BlobRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand Properties

The BlobRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxObjectSize |
Public property | MinObjectSize | Minimum size of the object to remove.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.MaxObjectSize Property

BlobRemovalCommandMaxObjectSize Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MaxObjectSize { get; set; }
Public Overridable Property MaxObjectSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.MinObjectSize Property

BlobRemovalCommandMinObjectSize Property

Minimum size of the object to remove.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinObjectSize { get; set; }
Public Overridable Property MinObjectSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
An object is a set of connected pixels.
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.SpeedFactor Property

BlobRemovalCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.SupportedPixelFormats Property

BlobRemovalCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand Methods

The BlobRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.GetObjectData Method

BlobRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.PerformActualCommand Method

BlobRemovalCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BlobRemovalCommand.VerifyProperties Method

BlobRemovalCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

BlobRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Class

An ImageCommand that removes solid borders from document images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BorderRemovalCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class BorderRemovalCommand
    Inherits ImageCommand
    Implements ISerializable

The BorderRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BorderRemovalCommand | Creates a new instance of BorderRemovalCommand.
Public method | BorderRemovalCommand(BorderRemovalEdges) | Initializes a new instance of BorderRemovalCommand specifying the edges to remove.
Protected method | BorderRemovalCommand(SerializationInfo, StreamingContext) | Creates a new instance of BorderRemovalCommand from serialization information.
Public method | BorderRemovalCommand(BorderRemovalEdges, Double) | Initializes a new instance of BorderRemovalCommand specifying the edges to remove, and tolerance.
Public method | BorderRemovalCommand(BorderRemovalEdges, Double, Boolean) | Initializes a new instance of BorderRemovalCommand specifying the edges to remove, tolerance, and despeckling.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Despeckle | Gets or sets a value indicating if the calculated border will be despeckled first.
Public property | Edges | Gets or sets a value indicating which of the 4 sides are to be removed.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets a value indicating the tolerance of the border detection.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder | Calculates the border of the image that is used in the BorderRemovalCommand to remove the borders.
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This command can be used to remove black solid borders from the edges of images. A Tolerance of 0 will only work with perfect solid borders. Use a tolerance between 0 and 100 to account for minor noise in the border. Set Edges is true, the image will be despeckled prior to calculating the border, only if the image is binary. Note that the image that's returned from Apple will not be despeckled, only the image used in the calculation.

To calculate the border of the image, without cropping, use the GetBorder(AtalaImage) method. GetBorder ignores the Edges property and returns the border from all sides.

Examples
VB
Copy
Dim cmd As New BorderRemovalCommand()
Dim results As BorderRemovalResults = CType(cmd.Apply(sourceImage), BorderRemovalCommandResults)
Dim newImage As AtalaImage = results.Image
Dim borderRect As Rectangle = results.Border
If (Not results.IsImageSourceImage) Then
 sourceImage.Dispose() 'free memory
End If
C# (C#)
Copy
BorderRemovalCommand cmd = new BorderRemovalCommand();
BorderRemovalResults results = (BorderRemovalCommandResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
Rectangle borderRect = results.Border;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Constructor

Initializes a new instance of BorderRemovalCommand.
Overload List
 | Name | Description
Public method | BorderRemovalCommand | Creates a new instance of BorderRemovalCommand.
Public method | BorderRemovalCommand(BorderRemovalEdges) | Initializes a new instance of BorderRemovalCommand specifying the edges to remove.
Protected method | BorderRemovalCommand(SerializationInfo, StreamingContext) | Creates a new instance of BorderRemovalCommand from serialization information.
Public method | BorderRemovalCommand(BorderRemovalEdges, Double) | Initializes a new instance of BorderRemovalCommand specifying the edges to remove, and tolerance.
Public method | BorderRemovalCommand(BorderRemovalEdges, Double, Boolean) | Initializes a new instance of BorderRemovalCommand specifying the edges to remove, tolerance, and despeckling.
Top
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Constructor

Creates a new instance of BorderRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderRemovalCommand()
Public Sub New
See Also

Reference

BorderRemovalCommand Class
BorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Constructor (BorderRemovalEdges)

Initializes a new instance of BorderRemovalCommand specifying the edges to remove.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderRemovalCommand(
    BorderRemovalEdges edges
)
Public Sub New (
    edges As BorderRemovalEdges
)

Parameters

edges
Type: Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalEdges
Indicates which of the 4 sides are to be removed.
See Also

Reference

BorderRemovalCommand Class
BorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BorderRemovalCommand from serialization information.
Initializes a new instance of BorderRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BorderRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BorderRemovalCommand Class
BorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Constructor (BorderRemovalEdges, Double)

Initializes a new instance of BorderRemovalCommand specifying the edges to remove, and tolerance.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderRemovalCommand(
    BorderRemovalEdges edges,
    double tolerance
)
Public Sub New (
    edges As BorderRemovalEdges,
    tolerance As Double
)

Parameters

edges
Type: Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalEdges
Indicates which of the 4 sides are to be removed.
tolerance
Type: SystemDouble
Indicates the tolerance of the border detection. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100.
See Also

Reference

BorderRemovalCommand Class
BorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Constructor (BorderRemovalEdges, Double, Boolean)

Initializes a new instance of BorderRemovalCommand specifying the edges to remove, tolerance, and despeckling.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderRemovalCommand(
    BorderRemovalEdges edges,
    double tolerance,
    bool despeckle
)
Public Sub New (
    edges As BorderRemovalEdges,
    tolerance As Double,
    despeckle As Boolean
)

Parameters

edges
Type: Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalEdges
Indicates which of the 4 sides are to be removed.
tolerance
Type: SystemDouble
Indicates the tolerance of the border detection. (0 to 100)
despeckle
Type: SystemBoolean
Indicates if the calculated border will be despeckled first.
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100.
See Also

Reference

BorderRemovalCommand Class
BorderRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Properties

The BorderRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Despeckle | Gets or sets a value indicating if the calculated border will be despeckled first.
Public property | Edges | Gets or sets a value indicating which of the 4 sides are to be removed.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets a value indicating the tolerance of the border detection.
Top
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.Despeckle Property

BorderRemovalCommandDespeckle Property

Gets or sets a value indicating if the calculated border will be despeckled first.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Despeckle { get; set; }
Public Property Despeckle As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the calculated border will be despeckled first.
Remarks
Defaults to true.
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.Edges Property

BorderRemovalCommandEdges Property

Gets or sets a value indicating which of the 4 sides are to be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderRemovalEdges Edges { get; set; }
Public Property Edges As BorderRemovalEdges
    Get
    Set

Property Value

Type: BorderRemovalEdges
A value indicating which of the 4 sides are to be removed.
Remarks
Values may be or'ed together to account for more than one side. Defaults to AllSides.
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.SupportedPixelFormats Property

BorderRemovalCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel4bppIndexed
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.Tolerance Property

BorderRemovalCommandTolerance Property

Gets or sets a value indicating the tolerance of the border detection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set

Property Value

Type: Double
A value indicating the tolerance of the border detection.
Exceptions
Exception | Condition
 | Thrown if value is less than 0 or greater than 100.
Remarks
The default value is 0. Valid values range from 0 to 100.
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand Methods

The BorderRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder | Calculates the border of the image that is used in the BorderRemovalCommand to remove the borders.
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.ConstructFinalImage Method

BorderRemovalCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.ConstructImageResults Method

BorderRemovalCommandConstructImageResults Method

Constructs the results object for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageResults ConstructImageResults()
Protected Overrides Function ConstructImageResults As ImageResults

Return Value

Type: ImageResults
A new object of type ImageResults representing the results for this command.
Remarks

The default implementation returns an object of type ImageResults. If your command requires an object with more information, subclass ImageResults and add in the information you need. Your command will override ConstructImageResults and return your new object.

The object allocated here is passed to PerformActualCommand as a reference parameter, meaning the entire object can be changed at that point too.

See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.GetBorder Method

BorderRemovalCommandGetBorder Method

Calculates the border of the image that is used in the BorderRemovalCommand to remove the borders.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle GetBorder(
    AtalaImage sourceImage
)
Public Function GetBorder (
    sourceImage As AtalaImage
) As Rectangle

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The image to calculate the borders from.

Return Value

Type: Rectangle
A rectangle containing the position, and size of the image with the borders removed.
Exceptions
Exception | Condition
 | Thrown if the sourceImage is null (Nothing in VB).
Remarks
Use this method to calculate the borders of an image, without actually removing them.
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.GetObjectData Method

BorderRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.PerformActualCommand Method

BorderRemovalCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.SelectPreferredPixelFormat Method

BorderRemovalCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalCommand.VerifyProperties Method

BorderRemovalCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Tolerance;Tolerance must be from 0 to 100.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BorderRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalEdges Enumeration

Specifies the edges to remove when using BorderRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum BorderRemovalEdges
<FlagsAttribute>
Public Enumeration BorderRemovalEdges
Members
Member name | Description
Left | The left edge of the image.
Right | The right edge of the image.
Top | The top edge of the image.
Bottom | The bottom edge of the image.
Vertical | The left and right edges of the image.
Horizontal | The top and bottom edges of the image.
AllSides | The left, right, top, and bottom edges of the image.
Remarks
Values can be or'ed together.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalResults Class

This class represents the results of applying the BorderRemovalCommand on an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentBorderRemovalResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BorderRemovalResults : ImageResults
Public Class BorderRemovalResults
    Inherits ImageResults

The BorderRemovalResults type exposes the following members.

Constructors
 | Name | Description
Public method | BorderRemovalResults | Constructs a new BorderRemovalResults object
Top
Properties
 | Name | Description
Public property | Border | Gets the detected border.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalResults Constructor

Constructs a new BorderRemovalResults object

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderRemovalResults()
Public Sub New
Remarks
This class is created by calling the BorderRemovalCommand.Apply() method. You don't need to construct one normally.
See Also

Reference

BorderRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalResults Properties

The BorderRemovalResults type exposes the following members.

Properties
 | Name | Description
Public property | Border | Gets the detected border.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

BorderRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalResults.Border Property

BorderRemovalResultsBorder Property

Gets the detected border.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Border { get; set; }
Public Property Border As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The detected border.
See Also

Reference

BorderRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


BorderRemovalResults Methods

The BorderRemovalResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BorderRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand Class

This command detects color regions from a color document resulting in an image with grayscale and bi-tonal areas masked with transparent alpha, and notification if the document contains any color.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentColorExtractionCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ColorExtractionCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class ColorExtractionCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The ColorExtractionCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ColorExtractionCommand | Creates a new instance of ColorExtractionCommand.
Protected method | ColorExtractionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the ColorExtractionCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DetectColorMarkings | When true, color markings will be detected.
Public property | DetectPhotos | When true, color and gray photos will be detected.
Public property | GrayscaleSaturation | This value controls the saturation threshold where a saturation less than the given value will be regarded as gray.
Public property | GrayscaleTolerance | This value controls the amount in percent that any given pixel color is off of pure gray.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MinMarkingSize | Minimum size limit of color markings in pixels.
Public property | MinPhotoSize | Minimum size limit of photo regions in pixels.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports color images only. (Overrides ImageCommandSupportedPixelFormats.)
Public property | VisualActivityThreshold | Controls the percentage of entropy threshold that factors in the photo detection algoithm.
Public property | VisualActivityWindowSize | Specifies the masking window for estimating visual color activity used in photo region detection.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This command is very useful for scanning documents as color, and automatically detecting when a document has no color so that it can be converted to black and white for better compression. The Apply method will result in an instance of ColorExtractionResults that contains a HasColor property. When HasColor is false, the document has only gray shades and can be converted to black and white with little to no loss in quality. When HasColor is true, it generally means that the document has color regions and that it should remain a color document to retain this color information.

The resulting Image in ColorExtractionResults is always a 32-bit BGRA with a transparent alpha channel masking the non-color areas. When no color is detected the resulting Image is a 1x1 pixel transparent image.

There are two distinct types of color areas in a document. A color marking can be a highlight region, red pen, or other solid colors. A photo region is an area with a lot of visual activity usually represented in a color or grayscale photograph. This command has the ability to detect color markings, photos, or both.

The default values are optimized for detecting color in scanned documents. By adjusting GrayscaleTolerance to a higher level, this command can be used for other purposes such as detecting grayscale or color magazine scans.

Examples
[New Example] (C#)
Copy
public AtalaImage ColorDetection(AtalaImage colorImage)
{
   if (colorImage.PixelFormat == PixelFormat.Pixel1bppIndexed)
       return colorImage;

   ColorExtractionCommand cmd = new ColorExtractionCommand();
   ColorExtractionResults results = (ColorExtractionResults)cmd.Apply(colorImage);
   if (!results.HasColor)
   {
      BinarizeCommand binarize = new BinarizeCommand(BinarizeMethod.AdaptiveThreshold);
      AtalaImage bwImage = binarize.Apply(colorImage).Image;
      colorImage.Dispose();
      return bwImage;
   }
   else
   {
      return colorImage;
   }
}
[New Example] (Visual Basic)
Copy
Public Function ColorDetection(ByVal colorImage As AtalaImage) As AtalaImage
   If colorImage.PixelFormat = PixelFormat.Pixel1bppIndexed Then
      Return colorImage
   End If

   Dim cmd As ColorExtractionCommand =  New ColorExtractionCommand()
   Dim results As ColorExtractionResults = CType(cmd.Apply(colorImage), ColorExtractionResults)
   If results.HasColor = False Then
      Dim binarize As BinarizeCommand =  New BinarizeCommand(BinarizeMethod.AdaptiveThreshold)
      Dim bwImage As AtalaImage =  binarize.Apply(colorImage).Image
      colorImage.Dispose()
      Return bwImage
   Else
      Return colorImage
   End If
End Function
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
ColorExtractionResults Class


ColorExtractionCommand Constructor

Overload List
 | Name | Description
Public method | ColorExtractionCommand | Creates a new instance of ColorExtractionCommand.
Protected method | ColorExtractionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the ColorExtractionCommand class
Top
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand Constructor

Creates a new instance of ColorExtractionCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorExtractionCommand()
Public Sub New
See Also

Reference

ColorExtractionCommand Class
ColorExtractionCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ColorExtractionCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ColorExtractionCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ColorExtractionCommand Class
ColorExtractionCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand Properties

The ColorExtractionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DetectColorMarkings | When true, color markings will be detected.
Public property | DetectPhotos | When true, color and gray photos will be detected.
Public property | GrayscaleSaturation | This value controls the saturation threshold where a saturation less than the given value will be regarded as gray.
Public property | GrayscaleTolerance | This value controls the amount in percent that any given pixel color is off of pure gray.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MinMarkingSize | Minimum size limit of color markings in pixels.
Public property | MinPhotoSize | Minimum size limit of photo regions in pixels.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports color images only. (Overrides ImageCommandSupportedPixelFormats.)
Public property | VisualActivityThreshold | Controls the percentage of entropy threshold that factors in the photo detection algoithm.
Public property | VisualActivityWindowSize | Specifies the masking window for estimating visual color activity used in photo region detection.
Top
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.DetectColorMarkings Property

ColorExtractionCommandDetectColorMarkings Property

When true, color markings will be detected.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool DetectColorMarkings { get; set; }
Public Overridable Property DetectColorMarkings As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
A color marking can be a highlight region, red pen, or other solid colors. Default value is true.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.DetectPhotos Property

ColorExtractionCommandDetectPhotos Property

When true, color and gray photos will be detected.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool DetectPhotos { get; set; }
Public Overridable Property DetectPhotos As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
A photo region is an area with a lot of visual activity usually represented in a color or grayscale photograph. Default value is true.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.GrayscaleSaturation Property

ColorExtractionCommandGrayscaleSaturation Property

This value controls the saturation threshold where a saturation less than the given value will be regarded as gray.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GrayscaleSaturation { get; set; }
Public Overridable Property GrayscaleSaturation As Double
    Get
    Set

Property Value

Type: Double
Remarks
Valid values are from 0 to 1.0, with a default of 0.2.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.GrayscaleTolerance Property

ColorExtractionCommandGrayscaleTolerance Property

This value controls the amount in percent that any given pixel color is off of pure gray.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GrayscaleTolerance { get; set; }
Public Overridable Property GrayscaleTolerance As Double
    Get
    Set

Property Value

Type: Double
Remarks
The higher the value, the more sensitive the command is to color. Lower values reduces color sensitivity. Valid values are from 0 to 1.0 with a default value of 0.036.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.MinMarkingSize Property

ColorExtractionCommandMinMarkingSize Property

Minimum size limit of color markings in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinMarkingSize { get; set; }
Public Overridable Property MinMarkingSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is (10,10).
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.MinPhotoSize Property

ColorExtractionCommandMinPhotoSize Property

Minimum size limit of photo regions in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinPhotoSize { get; set; }
Public Overridable Property MinPhotoSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is (100, 100).
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.SpeedFactor Property

ColorExtractionCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Faster.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.SupportedPixelFormats Property

ColorExtractionCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports color images only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.VisualActivityThreshold Property

ColorExtractionCommandVisualActivityThreshold Property

Controls the percentage of entropy threshold that factors in the photo detection algoithm.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double VisualActivityThreshold { get; set; }
Public Overridable Property VisualActivityThreshold As Double
    Get
    Set

Property Value

Type: Double
Remarks
Valid values are from 0 to 1.0 with a default of 0.02.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.VisualActivityWindowSize Property

ColorExtractionCommandVisualActivityWindowSize Property

Specifies the masking window for estimating visual color activity used in photo region detection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int VisualActivityWindowSize { get; set; }
Public Overridable Property VisualActivityWindowSize As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Default value is 3.
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand Methods

The ColorExtractionCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.ConstructFinalImage Method

ColorExtractionCommandConstructFinalImage Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.ConstructImageResults Method

ColorExtractionCommandConstructImageResults Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageResults ConstructImageResults()
Protected Overrides Function ConstructImageResults As ImageResults

Return Value

Type: ImageResults
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.GetObjectData Method

ColorExtractionCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.PerformActualCommand Method

ColorExtractionCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionCommand.VerifyProperties Method

ColorExtractionCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

ColorExtractionCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Class

Provides custom ImageResults for ColorExtractionCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentColorExtractionResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ColorExtractionResults : ImageResults
Public Class ColorExtractionResults
    Inherits ImageResults

The ColorExtractionResults type exposes the following members.

Constructors
 | Name | Description
Public method | ColorExtractionResults | Creates a new instance of ColorExtractionResults.
Public method | ColorExtractionResults(Boolean) | Creates a new instance of ColorExtractionResults specifying if the image has color.
Public method | ColorExtractionResults(AtalaImage, Boolean) | Creates a new instance of ColorExtractionResults specifying the resulting Image and HasColor.
Top
Properties
 | Name | Description
Public property | HasColor | Gets a value specifiying if the source image contains color.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Constructor

Overload List
 | Name | Description
Public method | ColorExtractionResults | Creates a new instance of ColorExtractionResults.
Public method | ColorExtractionResults(Boolean) | Creates a new instance of ColorExtractionResults specifying if the image has color.
Public method | ColorExtractionResults(AtalaImage, Boolean) | Creates a new instance of ColorExtractionResults specifying the resulting Image and HasColor.
Top
See Also

Reference

ColorExtractionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Constructor

Creates a new instance of ColorExtractionResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorExtractionResults()
Public Sub New
See Also

Reference

ColorExtractionResults Class
ColorExtractionResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Constructor (Boolean)

Creates a new instance of ColorExtractionResults specifying if the image has color.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorExtractionResults(
    bool hasColor
)
Public Sub New (
    hasColor As Boolean
)

Parameters

hasColor
Type: SystemBoolean
See Also

Reference

ColorExtractionResults Class
ColorExtractionResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Constructor (AtalaImage, Boolean)

Creates a new instance of ColorExtractionResults specifying the resulting Image and HasColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorExtractionResults(
    AtalaImage image,
    bool hasColor
)
Public Sub New (
    image As AtalaImage,
    hasColor As Boolean
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
hasColor
Type: SystemBoolean
See Also

Reference

ColorExtractionResults Class
ColorExtractionResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Properties

The ColorExtractionResults type exposes the following members.

Properties
 | Name | Description
Public property | HasColor | Gets a value specifiying if the source image contains color.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

ColorExtractionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults.HasColor Property

ColorExtractionResultsHasColor Property

Gets a value specifiying if the source image contains color.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool HasColor { get; }
Public Overridable ReadOnly Property HasColor As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ColorExtractionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ColorExtractionResults Methods

The ColorExtractionResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorExtractionResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Class

This command is used for converting color or gray images to black and white using halftoning techniques to simulate gray in the final image. This command operates best on photographic images.

Dithering is done using either Ordered Dithering or Floyd-Steinberg Error Diffusion dithering.

With Ordered Dithering, the dithering matrix is fully replaceable and can be made to simulate custom halftone screens.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentDitherCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DitherCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class DitherCommand
    Inherits ImageCommand
    Implements ISerializable

The DitherCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DitherCommand | Constructs a new DitherCommand to convert multi-bit images to 1 bit per pixel images using ordered dithering as the method.
Public method | DitherCommand(DitheringMethod) | Constructs a new DitherCommand to convert multi-bit images to 1 bit per pixel images using the supplied method.
Protected method | DitherCommand(SerializationInfo, StreamingContext) | Creates a new instance of DitherCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Matrix | Gets or sets the matrix to use for ordered dithering. The matrix must have either 4, 16, 64, or 256 elements in it representing 2x2, 4x4, 8x8 or 16x16 matrices, respectively.
Public property | Method | Set or get the method to be used for dithering.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Serpentine | Set or get whether or not Floyd Steinberg dithering will operate in alternating left to right/right to left patterns or simply left to right.
 | Standard16x16 | Returns a standard 16x16 ordered dithering matrix.
 | Standard2x2 | Returns a standard 2x2 ordered dithering matrix.
 | Standard4x4 | Returns a standard 4x4 ordered dithering matrix.
 | Standard8x8 | Returns a standard 8x8 ordered dithering matrix.
Public property | SupportedPixelFormats | Returns the set of PixelFormats that are supported by this image command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Constructor

Overload List
 | Name | Description
Public method | DitherCommand | Constructs a new DitherCommand to convert multi-bit images to 1 bit per pixel images using ordered dithering as the method.
Public method | DitherCommand(DitheringMethod) | Constructs a new DitherCommand to convert multi-bit images to 1 bit per pixel images using the supplied method.
Protected method | DitherCommand(SerializationInfo, StreamingContext) | Creates a new instance of DitherCommand from serialization information.
Top
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Constructor

Constructs a new DitherCommand to convert multi-bit images to 1 bit per pixel images using ordered dithering as the method.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DitherCommand()
Public Sub New
Remarks
The default dithering matrix will be a 16x16 matrix with evenly distributed gray levels.
See Also

Reference

DitherCommand Class
DitherCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Constructor (DitheringMethod)

Constructs a new DitherCommand to convert multi-bit images to 1 bit per pixel images using the supplied method.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DitherCommand(
    DitheringMethod method
)
Public Sub New (
    method As DitheringMethod
)

Parameters

method
Type: Atalasoft.Imaging.ImageProcessing.DocumentDitheringMethod
The method to be used for dithering.
See Also

Reference

DitherCommand Class
DitherCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DitherCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DitherCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DitherCommand Class
DitherCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Properties

The DitherCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Matrix | Gets or sets the matrix to use for ordered dithering. The matrix must have either 4, 16, 64, or 256 elements in it representing 2x2, 4x4, 8x8 or 16x16 matrices, respectively.
Public property | Method | Set or get the method to be used for dithering.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Serpentine | Set or get whether or not Floyd Steinberg dithering will operate in alternating left to right/right to left patterns or simply left to right.
 | Standard16x16 | Returns a standard 16x16 ordered dithering matrix.
 | Standard2x2 | Returns a standard 2x2 ordered dithering matrix.
 | Standard4x4 | Returns a standard 4x4 ordered dithering matrix.
 | Standard8x8 | Returns a standard 8x8 ordered dithering matrix.
Public property | SupportedPixelFormats | Returns the set of PixelFormats that are supported by this image command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Matrix Property

DitherCommandMatrix Property

Gets or sets the matrix to use for ordered dithering. The matrix must have either 4, 16, 64, or 256 elements in it representing 2x2, 4x4, 8x8 or 16x16 matrices, respectively.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Matrix { get; set; }
Public Property Matrix As Byte()
    Get
    Set

Property Value

Type: Byte
The matrix to use for ordered dithering.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Method Property

DitherCommandMethod Property

Set or get the method to be used for dithering.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DitheringMethod Method { get; set; }
Public Property Method As DitheringMethod
    Get
    Set

Property Value

Type: DitheringMethod
The method to be used for dithering.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Serpentine Property

DitherCommandSerpentine Property

Set or get whether or not Floyd Steinberg dithering will operate in alternating left to right/right to left patterns or simply left to right.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Serpentine { get; set; }
Public Property Serpentine As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether or not Floyd Steinberg dithering will operate in alternating left to right/right to left patterns or simply left to right.
Remarks
Default value is true. Using serpentine set to true can eliminate certain artifacting common in Floyd Steinberg dithering.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Standard16x16 Property

DitherCommandStandard16x16 Property

Returns a standard 16x16 ordered dithering matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static byte[] Standard16x16 { get; }
Public Shared ReadOnly Property Standard16x16 As Byte()
    Get

Property Value

Type: Byte
A standard 16x16 ordered dithering matrix.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Standard2x2 Property

DitherCommandStandard2x2 Property

Returns a standard 2x2 ordered dithering matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static byte[] Standard2x2 { get; }
Public Shared ReadOnly Property Standard2x2 As Byte()
    Get

Property Value

Type: Byte
A standard 2x2 ordered dithering matrix.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Standard4x4 Property

DitherCommandStandard4x4 Property

Returns a standard 4x4 ordered dithering matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static byte[] Standard4x4 { get; }
Public Shared ReadOnly Property Standard4x4 As Byte()
    Get

Property Value

Type: Byte
A standard 4x4 ordered dithering matrix.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.Standard8x8 Property

DitherCommandStandard8x8 Property

Returns a standard 8x8 ordered dithering matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static byte[] Standard8x8 { get; }
Public Shared ReadOnly Property Standard8x8 As Byte()
    Get

Property Value

Type: Byte
A standard 8x8 ordered dithering matrix.
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.SupportedPixelFormats Property

DitherCommandSupportedPixelFormats Property

Returns the set of PixelFormats that are supported by this image command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand Methods

The DitherCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.ConstructFinalImage Method

DitherCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Exceptions
Exception | Condition
OutOfMemoryException |
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.GetObjectData Method

DitherCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.PerformActualCommand Method

DitherCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentNullException | source or dest
See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitherCommand.VerifyProperties Method

DitherCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DitherCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DitheringMethod Enumeration

Specifies the technique used for dithering in a DitherCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DitheringMethod
Public Enumeration DitheringMethod
Members
Member name | Description
FloydSteinberg | Use Floyd-Steinberg error diffusion
Ordered | Use matrix-based ordered dithering
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand Class

The DocumentDespeckleCommand is useful for removing small isolated features in a bitonal image without eroding solid features. The most common use is as a despeckle filter for document images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentDespeckleCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DocumentDespeckleCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class DocumentDespeckleCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The DocumentDespeckleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentDespeckleCommand | Creates a new instance of DocumentDespeckleCommand.
Protected method | DocumentDespeckleCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentDespeckleCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | InternalActualCommand | Does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyDest | Called to verify the dest provided to PerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Protected method | VerifySource | Call to verify the source image provided to PerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand Constructor

Overload List
 | Name | Description
Public method | DocumentDespeckleCommand | Creates a new instance of DocumentDespeckleCommand.
Protected method | DocumentDespeckleCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentDespeckleCommand from serialization information.
Top
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand Constructor

Creates a new instance of DocumentDespeckleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentDespeckleCommand()
Public Sub New
See Also

Reference

DocumentDespeckleCommand Class
DocumentDespeckleCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DocumentDespeckleCommand from serialization information.
Initializes a new instance of DocumentDespeckleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DocumentDespeckleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DocumentDespeckleCommand Class
DocumentDespeckleCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand Properties

The DocumentDespeckleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.AutoThread Property

DocumentDespeckleCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.SupportedPixelFormats Property

DocumentDespeckleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand Methods

The DocumentDespeckleCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | InternalActualCommand | Does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyDest | Called to verify the dest provided to PerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Protected method | VerifySource | Call to verify the source image provided to PerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).
Top
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.AdjustBands Method

DocumentDespeckleCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.Clone Method

DocumentDespeckleCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the DocumentDespeckleCommand.

Implements

ICloneableClone
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.GetObjectData Method

DocumentDespeckleCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.InternalActualCommand Method

DocumentDespeckleCommandInternalActualCommand Method

Does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage InternalActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea
)
Protected Function InternalActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.

Return Value

Type: AtalaImage
Null (Nothing in VB).
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.PerformActualCommand Method

DocumentDespeckleCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.PerformSectionCommand Method

DocumentDespeckleCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.VerifyDest Method

DocumentDespeckleCommandVerifyDest Method

Called to verify the dest provided to PerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void VerifyDest(
    AtalaImage dest
)
Protected Sub VerifyDest (
    dest As AtalaImage
)

Parameters

dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
Exceptions
Exception | Condition
 | Thrown if the image is null (Nothing in VB).
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.VerifyProperties Method

DocumentDespeckleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentDespeckleCommand.VerifySource Method

DocumentDespeckleCommandVerifySource Method

Call to verify the source image provided to PerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void VerifySource(
    AtalaImage source
)
Protected Sub VerifySource (
    source As AtalaImage
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
See Also

Reference

DocumentDespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Class

Perform a hit-or-miss transformation on a binary image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentHitOrMissCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DocumentHitOrMissCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class DocumentHitOrMissCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The DocumentHitOrMissCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentHitOrMissCommand | Creates a new instance of DocumentHitOrMissCommand.
Protected method | DocumentHitOrMissCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentHitOrMissCommand from serialization information.
Public method | DocumentHitOrMissCommand(IntegerMatrix, IntegerMatrix) | Creates a new instance of DocumentHitOrMissCommand specifying the foreground and background masks.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundMask | Gets or sets a matrix of integer values to act as the background mask.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ForegroundMask | Gets or sets a matrix of integer values to act as the foreground mask.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Hit or Miss is a basic tool for finding geometric shapes within an image. The masks used determine the shapes that are detected.

The foreground mask operates on foreground features and the background mask on background features. Together they detect foreground-background transitions in the input image.

The two masks used are normally the same size and must contain mutually-exclusive elements: if a mask position in A contains a 1, the corresponding position in B must contain a 0.

For example, these masks will find vertical edges on the left sides of the foreground image.

mask A: mask B:, 0 0 0 0 0 0 , 0 1 1 1 0 0, 0 0 0 0 0 0

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Constructor

Overload List
 | Name | Description
Public method | DocumentHitOrMissCommand | Creates a new instance of DocumentHitOrMissCommand.
Protected method | DocumentHitOrMissCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentHitOrMissCommand from serialization information.
Public method | DocumentHitOrMissCommand(IntegerMatrix, IntegerMatrix) | Creates a new instance of DocumentHitOrMissCommand specifying the foreground and background masks.
Top
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Constructor

Creates a new instance of DocumentHitOrMissCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentHitOrMissCommand()
Public Sub New
See Also

Reference

DocumentHitOrMissCommand Class
DocumentHitOrMissCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DocumentHitOrMissCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DocumentHitOrMissCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DocumentHitOrMissCommand Class
DocumentHitOrMissCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Constructor (IntegerMatrix, IntegerMatrix)

Creates a new instance of DocumentHitOrMissCommand specifying the foreground and background masks.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentHitOrMissCommand(
    IntegerMatrix foregroundMask,
    IntegerMatrix backgroundMask
)
Public Sub New (
    foregroundMask As IntegerMatrix,
    backgroundMask As IntegerMatrix
)

Parameters

foregroundMask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A matrix of integer values to act as the foreground mask.
backgroundMask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A matrix of integer values to act as the background mask.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the masks have no rows or if the number of columns/rows do not match.
See Also

Reference

DocumentHitOrMissCommand Class
DocumentHitOrMissCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Properties

The DocumentHitOrMissCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundMask | Gets or sets a matrix of integer values to act as the background mask.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ForegroundMask | Gets or sets a matrix of integer values to act as the foreground mask.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand.BackgroundMask Property

DocumentHitOrMissCommandBackgroundMask Property

Gets or sets a matrix of integer values to act as the background mask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix BackgroundMask { get; set; }
Public Property BackgroundMask As IntegerMatrix
    Get
    Set

Property Value

Type: IntegerMatrix
A matrix of integer values to act as the background mask.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if value matrix is not N x N.
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand.ForegroundMask Property

DocumentHitOrMissCommandForegroundMask Property

Gets or sets a matrix of integer values to act as the foreground mask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix ForegroundMask { get; set; }
Public Property ForegroundMask As IntegerMatrix
    Get
    Set

Property Value

Type: IntegerMatrix
A matrix of integer values to act as the foreground mask.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if value matrix is not N x N.
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand.SupportedPixelFormats Property

DocumentHitOrMissCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand Methods

The DocumentHitOrMissCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand.GetObjectData Method

DocumentHitOrMissCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
SecurityException | The caller does not have the required permission.
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand.PerformActualCommand Method

DocumentHitOrMissCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentHitOrMissCommand.VerifyProperties Method

DocumentHitOrMissCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DocumentHitOrMissCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Class

Applies a median filter to a binary image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentMedianCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DocumentMedianCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class DocumentMedianCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The DocumentMedianCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentMedianCommand | Creates a new instance of DocumentMedianCommand.
Public method | DocumentMedianCommand(Int32) | Creates a new instance of DocumentMedianCommand specifying filterSize.
Protected method | DocumentMedianCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentMedianCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FilterSize | Gets or sets the size of the filter to use for this command.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
A median filter will smooth out the image and remove dots and noise. This makes a good despeckle filter for a binary image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Constructor

Overload List
 | Name | Description
Public method | DocumentMedianCommand | Creates a new instance of DocumentMedianCommand.
Public method | DocumentMedianCommand(Int32) | Creates a new instance of DocumentMedianCommand specifying filterSize.
Protected method | DocumentMedianCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentMedianCommand from serialization information.
Top
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Constructor

Creates a new instance of DocumentMedianCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentMedianCommand()
Public Sub New
See Also

Reference

DocumentMedianCommand Class
DocumentMedianCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Constructor (Int32)

Creates a new instance of DocumentMedianCommand specifying filterSize.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentMedianCommand(
    int filterSize
)
Public Sub New (
    filterSize As Integer
)

Parameters

filterSize
Type: SystemInt32
The size of the filter to use for this command. (3, 5, 7, etc)
See Also

Reference

DocumentMedianCommand Class
DocumentMedianCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DocumentMedianCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DocumentMedianCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DocumentMedianCommand Class
DocumentMedianCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Properties

The DocumentMedianCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FilterSize | Gets or sets the size of the filter to use for this command.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand.FilterSize Property

DocumentMedianCommandFilterSize Property

Gets or sets the size of the filter to use for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the filter to use for this command.
Remarks
Should be an odd positive value. The default value is 3.
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand.SupportedPixelFormats Property

DocumentMedianCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand Methods

The DocumentMedianCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand.ConstructChangedSourceImage Method

DocumentMedianCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand.GetObjectData Method

DocumentMedianCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
SecurityException | The caller does not have the required permission.
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand.PerformActualCommand Method

DocumentMedianCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentMedianCommand.VerifyProperties Method

DocumentMedianCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DocumentMedianCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger Class

This PixelFormatChanger is suited for document images and can be set to PixelFormatChanger.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingPixelFormatChanger
Atalasoft.Imaging.ImageProcessing.DocumentDocumentPixelFormatChanger

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentPixelFormatChanger : PixelFormatChanger
Public Class DocumentPixelFormatChanger
    Inherits PixelFormatChanger

The DocumentPixelFormatChanger type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentPixelFormatChanger | Creates a new instance of DocumentPixelFormatChanger.
Top
Properties
 | Name | Description
Public property | AdaptiveThresholdCommand | Gets the AdaptiveThresholdCommand used by the DocumentPixelFormatChanger.
Public property | BasePixelChanger | Gets the base PixelFormatChanger passed into the DocumentPixelChanger constructor.
Public property | GlobalThresholdCommand | Gets the GlobalThresholdCommand used by the DocumentPixelFormatChanger.
Public property | SimpleThresholdCommand | Gets the SimpleThresholdCommand that used by the DocumentPixelFormatChanger.
Public property | ThresholdMethod | Gets or sets the threshold method to use when converting to 1-bit images.
Top
Methods
 | Name | Description
Public method | ChangePixelFormat | Allocate a new AtalaImage based on the sourceImage, using the requested pixel format. (Inherited from PixelFormatChanger.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetThresholdCommand | Returns the threshold command used based on the value of ThresholdMethod.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LowLevelChangePixelFormat | Lows the level change pixel format. (Overrides PixelFormatChangerLowLevelChangePixelFormat(AtalaImage, PixelFormat, ColorProfile).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger Constructor

Creates a new instance of DocumentPixelFormatChanger.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentPixelFormatChanger(
    PixelFormatChanger basePixelChanger
)
Public Sub New (
    basePixelChanger As PixelFormatChanger
)

Parameters

basePixelChanger
Type: Atalasoft.ImagingPixelFormatChanger
The base PixelFormatChanger that will be used when the target pixel format is not PixelFormat.Pixel1bppIndexed.
Exceptions
Exception | Condition
 | Thrown if the basePixelChanger is null (Nothing in VB).
 | Thrown if the basePixelChanger is a DocumentPixelFormatChanger.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger Properties

The DocumentPixelFormatChanger type exposes the following members.

Properties
 | Name | Description
Public property | AdaptiveThresholdCommand | Gets the AdaptiveThresholdCommand used by the DocumentPixelFormatChanger.
Public property | BasePixelChanger | Gets the base PixelFormatChanger passed into the DocumentPixelChanger constructor.
Public property | GlobalThresholdCommand | Gets the GlobalThresholdCommand used by the DocumentPixelFormatChanger.
Public property | SimpleThresholdCommand | Gets the SimpleThresholdCommand that used by the DocumentPixelFormatChanger.
Public property | ThresholdMethod | Gets or sets the threshold method to use when converting to 1-bit images.
Top
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.AdaptiveThresholdCommand Property

DocumentPixelFormatChangerAdaptiveThresholdCommand Property

Gets the AdaptiveThresholdCommand used by the DocumentPixelFormatChanger.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveThresholdCommand AdaptiveThresholdCommand { get; }
Public ReadOnly Property AdaptiveThresholdCommand As AdaptiveThresholdCommand
    Get

Property Value

Type: AdaptiveThresholdCommand
The AdaptiveThresholdCommand used by the DocumentPixelFormatChanger.
Remarks
This command is used when ThresholdMethod is set to Adaptive.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.BasePixelChanger Property

DocumentPixelFormatChangerBasePixelChanger Property

Gets the base PixelFormatChanger passed into the DocumentPixelChanger constructor.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelFormatChanger BasePixelChanger { get; }
Public ReadOnly Property BasePixelChanger As PixelFormatChanger
    Get

Property Value

Type: PixelFormatChanger
The base PixelFormatChanger passed into the DocumentPixelChanger constructor.
Remarks
This PixelFormatChanger will be used when the target pixel format is not 1-bit.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.GlobalThresholdCommand Property

DocumentPixelFormatChangerGlobalThresholdCommand Property

Gets the GlobalThresholdCommand used by the DocumentPixelFormatChanger.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalThresholdCommand GlobalThresholdCommand { get; }
Public ReadOnly Property GlobalThresholdCommand As GlobalThresholdCommand
    Get

Property Value

Type: GlobalThresholdCommand
The GlobalThresholdCommand used by the DocumentPixelFormatChanger.
Remarks
This command is used when ThresholdMethod is set to Global.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.SimpleThresholdCommand Property

DocumentPixelFormatChangerSimpleThresholdCommand Property

Gets the SimpleThresholdCommand that used by the DocumentPixelFormatChanger.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SimpleThresholdCommand SimpleThresholdCommand { get; }
Public ReadOnly Property SimpleThresholdCommand As SimpleThresholdCommand
    Get

Property Value

Type: SimpleThresholdCommand
The SimpleThresholdCommand that used by the DocumentPixelFormatChanger.
Remarks
This command is used when ThresholdMethod is set to Simple.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.ThresholdMethod Property

DocumentPixelFormatChangerThresholdMethod Property

Gets or sets the threshold method to use when converting to 1-bit images.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThresholdMethod ThresholdMethod { get; set; }
Public Property ThresholdMethod As ThresholdMethod
    Get
    Set

Property Value

Type: ThresholdMethod
The threshold method to use when converting to 1-bit images.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger Methods

The DocumentPixelFormatChanger type exposes the following members.

Methods
 | Name | Description
Public method | ChangePixelFormat | Allocate a new AtalaImage based on the sourceImage, using the requested pixel format. (Inherited from PixelFormatChanger.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetThresholdCommand | Returns the threshold command used based on the value of ThresholdMethod.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LowLevelChangePixelFormat | Lows the level change pixel format. (Overrides PixelFormatChangerLowLevelChangePixelFormat(AtalaImage, PixelFormat, ColorProfile).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.GetThresholdCommand Method

DocumentPixelFormatChangerGetThresholdCommand Method

Returns the threshold command used based on the value of ThresholdMethod.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual ImageCommand GetThresholdCommand()
Protected Overridable Function GetThresholdCommand As ImageCommand

Return Value

Type: ImageCommand
The threshold command to use.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentPixelFormatChanger.LowLevelChangePixelFormat Method

DocumentPixelFormatChangerLowLevelChangePixelFormat Method

Lows the level change pixel format.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage LowLevelChangePixelFormat(
    AtalaImage sourceImage,
    PixelFormat targetPixelFormat,
    ColorProfile destProfile
)
Protected Overrides Function LowLevelChangePixelFormat (
    sourceImage As AtalaImage,
    targetPixelFormat As PixelFormat,
    destProfile As ColorProfile
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
targetPixelFormat
Type: Atalasoft.ImagingPixelFormat
The target pixel format.
destProfile
Type: Atalasoft.Imaging.ColorManagementColorProfile
The dest profile.

Return Value

Type: AtalaImage
Exceptions
Exception | Condition
ArgumentNullException | command;Internal error making getting threshold command.
FormatException | Internal error: threshold command did not return a 1bpp image.
See Also

Reference

DocumentPixelFormatChanger Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Class

Apply morphological thinning to a 1-bit image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentDocumentThinningCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DocumentThinningCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class DocumentThinningCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The DocumentThinningCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentThinningCommand | Creates a new instance of DocumentThinningCommand.
Protected method | DocumentThinningCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentThinningCommand from serialization information.
Public method | DocumentThinningCommand(IntegerMatrix, IntegerMatrix) | Creates a new instance of DocumentThinningCommand specifying foregroundMask and backgroundMask.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxIterations | Gets or sets the maximum number of iterations to use when processing the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBackgroundMask | Returns the background mask.
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetForegroundMask | Returns the foreground mask.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | SetBackgroundMask |
Public method | SetForegroundMask |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This will reduce the geometric size of an image, leaving only a skeletonized frame behind.

This function requires two sets of masks. The foreground masks represents foreground matching masks and the background masks should be the compliments of the foreground masks. (swap ones and zeros).

A typical set of foreground masks is:

0 0 0 1 0 0 1 1 0 1 1 1 1 1 1 1 1 1 0 1 1 0 0 1, 1 1 1 1 1 0 1 1 0 1 1 0 1 1 1 0 1 1 0 1 1 0 1 1, 1 1 1 1 1 1 1 1 0 1 0 0 0 0 0 0 0 1 0 1 1 1 1 1

The background masks are compliments of these (1 and 0 reversed).

Note that the content of each mask is the preceding mask, rotated 45 deg.

The process works by applying each of these masks in pairs (A[x], B[x]) for all pairs, until MaxIterations has been reached or until there is no change in the image. This can be a long process.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Constructor

Overload List
 | Name | Description
Public method | DocumentThinningCommand | Creates a new instance of DocumentThinningCommand.
Protected method | DocumentThinningCommand(SerializationInfo, StreamingContext) | Creates a new instance of DocumentThinningCommand from serialization information.
Public method | DocumentThinningCommand(IntegerMatrix, IntegerMatrix) | Creates a new instance of DocumentThinningCommand specifying foregroundMask and backgroundMask.
Top
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Constructor

Creates a new instance of DocumentThinningCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentThinningCommand()
Public Sub New
See Also

Reference

DocumentThinningCommand Class
DocumentThinningCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DocumentThinningCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DocumentThinningCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DocumentThinningCommand Class
DocumentThinningCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Constructor (IntegerMatrix[], IntegerMatrix[])

DocumentThinningCommand Constructor (IntegerMatrix, IntegerMatrix)

Creates a new instance of DocumentThinningCommand specifying foregroundMask and backgroundMask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentThinningCommand(
    IntegerMatrix[] foregroundMask,
    IntegerMatrix[] backgroundMask
)
Public Sub New (
    foregroundMask As IntegerMatrix(),
    backgroundMask As IntegerMatrix()
)

Parameters

foregroundMask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A matrix array of integer values to act as the foreground mask.
backgroundMask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A matrix array of integer values to act as the background mask.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if either mask is an empty array of if the number of columns does not equal the number of rows.
See Also

Reference

DocumentThinningCommand Class
DocumentThinningCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Properties

The DocumentThinningCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxIterations | Gets or sets the maximum number of iterations to use when processing the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.MaxIterations Property

DocumentThinningCommandMaxIterations Property

Gets or sets the maximum number of iterations to use when processing the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxIterations { get; set; }
Public Property MaxIterations As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of iterations to use when processing the image.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the value is less than 1.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.SupportedPixelFormats Property

DocumentThinningCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand Methods

The DocumentThinningCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBackgroundMask | Returns the background mask.
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetForegroundMask | Returns the foreground mask.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | SetBackgroundMask |
Public method | SetForegroundMask |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.GetBackgroundMask Method

DocumentThinningCommandGetBackgroundMask Method

Returns the background mask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix[] GetBackgroundMask()
Public Function GetBackgroundMask As IntegerMatrix()

Return Value

Type: IntegerMatrix
A IntegerMatrix object containing the mask values.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.GetForegroundMask Method

DocumentThinningCommandGetForegroundMask Method

Returns the foreground mask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix[] GetForegroundMask()
Public Function GetForegroundMask As IntegerMatrix()

Return Value

Type: IntegerMatrix
A IntegerMatrix object containing the mask values.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.GetObjectData Method

DocumentThinningCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
SecurityException | The caller does not have the required permission.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.PerformActualCommand Method

DocumentThinningCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.SetBackgroundMask Method

DocumentThinningCommandSetBackgroundMask Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetBackgroundMask(
    IntegerMatrix[] mask
)
Public Sub SetBackgroundMask (
    mask As IntegerMatrix()
)

Parameters

mask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A IntegerMatrix object containing the mask values.

Return Value

Type:
Sets the background mask to use.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if value is an empty array or value matrix is not of form N x N.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.SetForegroundMask Method

DocumentThinningCommandSetForegroundMask Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetForegroundMask(
    IntegerMatrix[] mask
)
Public Sub SetForegroundMask (
    mask As IntegerMatrix()
)

Parameters

mask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A IntegerMatrix object containing the mask values.

Return Value

Type:
Sets the foreground mask to use.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if value is an empty array or value matrix is not of from N x N.
See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DocumentThinningCommand.VerifyProperties Method

DocumentThinningCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DocumentThinningCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Class

Converts a multi-bit image (color or grayscale) to a single bit black and white image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentDynamicThresholdCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DynamicThresholdCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class DynamicThresholdCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The DynamicThresholdCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicThresholdCommand | Constructs a new DynamicThresholdCommand object
Public method | DynamicThresholdCommand(Int32) | Constructs a new DynamicThresholdCommand object
Protected method | DynamicThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of DynamicThresholdCommand from serialization information.
Public method | DynamicThresholdCommand(Int32, Int32, Double) | Creates a new instance of DynamicThresholdCommand specifying the window size, difference threshold and black grouping.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | BlackGrouping | A percentile indication of how tightly grouped black pixels need to be.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DifferenceThreshold | Gets or sets a value used to improving the thresholding results.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | WindowSize | Gets or sets the size of local window acting on each pixel to find local statistics.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Constructor

Constructs a new DynamicThresholdCommand object
Overload List
 | Name | Description
Public method | DynamicThresholdCommand | Constructs a new DynamicThresholdCommand object
Public method | DynamicThresholdCommand(Int32) | Constructs a new DynamicThresholdCommand object
Protected method | DynamicThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of DynamicThresholdCommand from serialization information.
Public method | DynamicThresholdCommand(Int32, Int32, Double) | Creates a new instance of DynamicThresholdCommand specifying the window size, difference threshold and black grouping.
Top
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Constructor

Constructs a new DynamicThresholdCommand object

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DynamicThresholdCommand()
Public Sub New
See Also

Reference

DynamicThresholdCommand Class
DynamicThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Constructor (Int32)

Constructs a new DynamicThresholdCommand object

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DynamicThresholdCommand(
    int windowSize
)
Public Sub New (
    windowSize As Integer
)

Parameters

windowSize
Type: SystemInt32

The size of the examination window surround the current pixel.

Exceptions
Exception | Condition
 | Thrown if the windowSize is less than 1.
See Also

Reference

DynamicThresholdCommand Class
DynamicThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DynamicThresholdCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DynamicThresholdCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DynamicThresholdCommand Class
DynamicThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Constructor (Int32, Int32, Double)

Creates a new instance of DynamicThresholdCommand specifying the window size, difference threshold and black grouping.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DynamicThresholdCommand(
    int windowSize,
    int differenceThreshold,
    double blackGrouping
)
Public Sub New (
    windowSize As Integer,
    differenceThreshold As Integer,
    blackGrouping As Double
)

Parameters

windowSize
Type: SystemInt32

The size of the examination window surround the current pixel

differenceThreshold
Type: SystemInt32
Value used to improving the thresholding results.
blackGrouping
Type: SystemDouble
A percentile indication of how tightly grouped black pixels need to be. Default value is 0.25.
Exceptions
Exception | Condition
 | Thrown if the windowSize is less than 1 or if blackGrouping is less than 0 or greater than 1.
See Also

Reference

DynamicThresholdCommand Class
DynamicThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Properties

The DynamicThresholdCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | BlackGrouping | A percentile indication of how tightly grouped black pixels need to be.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DifferenceThreshold | Gets or sets a value used to improving the thresholding results.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | WindowSize | Gets or sets the size of local window acting on each pixel to find local statistics.
Top
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.AutoThread Property

DynamicThresholdCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.BlackGrouping Property

DynamicThresholdCommandBlackGrouping Property

A percentile indication of how tightly grouped black pixels need to be.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BlackGrouping { get; set; }
Public Property BlackGrouping As Double
    Get
    Set

Property Value

Type: Double
A value from 0 to 1. Default is 0.25. 0.4 is roughly equivalent to the AdaptiveThresholding command
Exceptions
Exception | Condition
 | Thrown if the value is less than 0 or greater than 1.
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.DifferenceThreshold Property

DynamicThresholdCommandDifferenceThreshold Property

Gets or sets a value used to improving the thresholding results.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DifferenceThreshold { get; set; }
Public Property DifferenceThreshold As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
In local adaptive thresholding, an individual threshold for each pixel is based on the range of intensity values in its local neighborhood. In this class, a local mean value is used as the threshold. The situation can be improved if the threshold employed is not the mean, but "mean - DifferenceThreshold". The default value is 7.
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.SupportedPixelFormats Property

DynamicThresholdCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.WindowSize Property

DynamicThresholdCommandWindowSize Property

Gets or sets the size of local window acting on each pixel to find local statistics.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int WindowSize { get; set; }
Public Property WindowSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of local window acting on each pixel to find local statistics. Must be greater than 1.
Exceptions
Exception | Condition
 | Thrown if the value is less than 1.
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand Methods

The DynamicThresholdCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.AdjustBands Method

DynamicThresholdCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.Clone Method

DynamicThresholdCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the DynamicThresholdCommand.

Implements

ICloneableClone
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.ConstructChangedSourceImage Method

DynamicThresholdCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.ConstructFinalImage Method

DynamicThresholdCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.GetObjectData Method

DynamicThresholdCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.PerformActualCommand Method

DynamicThresholdCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage destImage,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    destImage As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The source image.
destImage
Type: Atalasoft.ImagingAtalaImage
The dest image.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.PerformSectionCommand Method

DynamicThresholdCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Exceptions
Exception | Condition
ImageProcessException | dynamic thresholding failed
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


DynamicThresholdCommand.VerifyProperties Method

DynamicThresholdCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DynamicThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ErrorNo Enumeration

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ErrorNo
Public Enumeration ErrorNo
Members
Member name | Description
NoError |
InvalidUnmanagedResHandle |
UndefinedMemAllocCallback |
UndefinedMemReleaseCallback |
IncompleteMemAllocation |
IncompleteMemRelease |
InvalidPointerAddress |
OutOfRange |
OutOfMemory |
NullImage |
NullRoi |
TooMnayConnectedComponents |
FWLabelingError |
TransitiveMatrix |
DomainDecomposition |
TranslationInvariant |
ExtractLines |
LineLengthThreshold |
ReconnectBrokenTexts |
AmbigousBackGroundColor |
StatisticsOnDomain |
Preprocessing |
FeatureExtraction |
DecisionModel |
FeatureRemoval |
PolygonApproximation |
Resizer |
InvalidDimension |
InvalidCast |
FailureCrop |
NotImplemented |
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Class

A member of Segment class, spatial information with collection of polgons is provided
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.DocumentGeometry

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Geometry : ISerializable, ICloneable
<SerializableAttribute>
Public Class Geometry
    Implements ISerializable, ICloneable

The Geometry type exposes the following members.

Constructors
 | Name | Description
Public method | Geometry | Initializes a new instance of the Geometry class
Public method | Geometry(SerializationInfo, StreamingContext) | Initializes a new instance of the Geometry class
Public method | Geometry(Rectangle, Boolean, PolygonFCollection) | Initializes a new instance of the Geometry class
Top
Properties
 | Name | Description
Public property | Bounds | Rectangular region bounding all of SubRegions
Public property | IsRectangular | Indicator whether the geometry of interest is rectangle
Public property | SubRegions |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Contains(Point) |
Public method | Contains(PointF) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects(Rectangle) |
Public method | Intersects(Geometry) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo |
Public method | Offset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Constructor

Overload List
 | Name | Description
Public method | Geometry | Initializes a new instance of the Geometry class
Public method | Geometry(SerializationInfo, StreamingContext) | Initializes a new instance of the Geometry class
Public method | Geometry(Rectangle, Boolean, PolygonFCollection) | Initializes a new instance of the Geometry class
Top
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Constructor

Initializes a new instance of the Geometry class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Geometry()
Public Sub New
See Also

Reference

Geometry Class
Geometry Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Geometry class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Geometry(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

Geometry Class
Geometry Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Constructor (Rectangle, Boolean, PolygonFCollection)

Initializes a new instance of the Geometry class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Geometry(
    Rectangle bound,
    bool isRectangular,
    PolygonFCollection subRegions
)
Public Sub New (
    bound As Rectangle,
    isRectangular As Boolean,
    subRegions As PolygonFCollection
)

Parameters

bound
Type: System.DrawingRectangle
isRectangular
Type: SystemBoolean
subRegions
Type: Atalasoft.Utils.GeometryPolygonFCollection
See Also

Reference

Geometry Class
Geometry Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Properties

The Geometry type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Rectangular region bounding all of SubRegions
Public property | IsRectangular | Indicator whether the geometry of interest is rectangle
Public property | SubRegions |
Top
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Bounds Property

GeometryBounds Property

Rectangular region bounding all of SubRegions

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; }
Public Overridable ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
Rectangle
Remarks
Rectangular bounding box of a segmented region
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.IsRectangular Property

GeometryIsRectangular Property

Indicator whether the geometry of interest is rectangle

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsRectangular { get; }
Public Overridable ReadOnly Property IsRectangular As Boolean
    Get

Property Value

Type: Boolean
bool
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.SubRegions Property

GeometrySubRegions Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PolygonFCollection SubRegions { get; set; }
Public Overridable Property SubRegions As PolygonFCollection
    Get
    Set

Property Value

Type: PolygonFCollection
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry Methods

The Geometry type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Contains(Point) |
Public method | Contains(PointF) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects(Rectangle) |
Public method | Intersects(Geometry) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo |
Public method | Offset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Clone Method

GeometryClone Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Contains Method

GeometryContains Method

Overload List
 | Name | Description
Public method | Contains(Point) |
Public method | Contains(PointF) |
Top
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Contains Method (Point)

GeometryContains Method (Point)

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    Point p
)
Public Overridable Function Contains (
    p As Point
) As Boolean

Parameters

p
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

Geometry Class
Contains Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Contains Method (PointF)

GeometryContains Method (PointF)

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    PointF p
)
Public Overridable Function Contains (
    p As PointF
) As Boolean

Parameters

p
Type: System.DrawingPointF

Return Value

Type: Boolean
See Also

Reference

Geometry Class
Contains Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.GetClonedObject Method

GeometryGetClonedObject Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Geometry GetClonedObject()
Protected Overridable Function GetClonedObject As Geometry

Return Value

Type: Geometry
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.GetHashCode Method

GeometryGetHashCode Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.GetObjectData Method

GeometryGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Intersects Method

GeometryIntersects Method

Overload List
 | Name | Description
Public method | Intersects(Rectangle) |
Public method | Intersects(Geometry) |
Top
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Intersects Method (Rectangle)

GeometryIntersects Method (Rectangle)

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Intersects(
    Rectangle r
)
Public Overridable Function Intersects (
    r As Rectangle
) As Boolean

Parameters

r
Type: System.DrawingRectangle

Return Value

Type: Boolean
See Also

Reference

Geometry Class
Intersects Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Intersects Method (Geometry)

GeometryIntersects Method (Geometry)

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Intersects(
    Geometry g
)
Public Overridable Function Intersects (
    g As Geometry
) As Boolean

Parameters

g
Type: Atalasoft.Imaging.ImageProcessing.DocumentGeometry

Return Value

Type: Boolean
See Also

Reference

Geometry Class
Intersects Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.MoveTo Method

GeometryMoveTo Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool MoveTo(
    Point p
)
Public Overridable Function MoveTo (
    p As Point
) As Boolean

Parameters

p
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Geometry.Offset Method

GeometryOffset Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Offset(
    Point p
)
Public Overridable Function Offset (
    p As Point
) As Boolean

Parameters

p
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

Geometry Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Class

An ImageCommand used to convert a grayscale or color image into black and white using a global thresholding technique.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentGlobalThresholdCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GlobalThresholdCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class GlobalThresholdCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The GlobalThresholdCommand type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalThresholdCommand | Creates a new instance of GlobalThresholdCommand.
Public method | GlobalThresholdCommand(Int32) | Initializes a new instance of GlobalThresholdCommand specifying the initial threshold value.
Protected method | GlobalThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of GlobalThresholdCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InitThreshold | Gets or sets the initial threshold value.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
Global thresholding is the simplest of all thresholding techniques. It will partition the image histogram by using a single global threshold. Segmentation is then accomplished by scanning the image pixel by pixel and labelling each pixel as object or background. The success of this method depends entirely on how well the histogram can be partitioned.
Examples
VB
Copy
Dim image As AtalaImage = New AtalaImage(....)
Dim gtm As GlobalThresholdCommand New GlobalThresholdCommand()
Dim segmentedImage As AtalaImage = gtm.Appy(image).Image
image.Dispose()
CS (C#)
Copy
AtalaImage image = new AtalaImage(....);
GlobalThresholdCommand gtm = new GlobalThresholdCommand();
AtalaImage segmentedImage = gtm.Appy(image).Image;
image.Dispose();
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Constructor

Initializes a new instance of GlobalThresholdCommand.
Overload List
 | Name | Description
Public method | GlobalThresholdCommand | Creates a new instance of GlobalThresholdCommand.
Public method | GlobalThresholdCommand(Int32) | Initializes a new instance of GlobalThresholdCommand specifying the initial threshold value.
Protected method | GlobalThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of GlobalThresholdCommand from serialization information.
Top
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Constructor

Creates a new instance of GlobalThresholdCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalThresholdCommand()
Public Sub New
See Also

Reference

GlobalThresholdCommand Class
GlobalThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Constructor (Int32)

Initializes a new instance of GlobalThresholdCommand specifying the initial threshold value.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalThresholdCommand(
    int initThreshold
)
Public Sub New (
    initThreshold As Integer
)

Parameters

initThreshold
Type: SystemInt32
The initial threshold value.
Exceptions
Exception | Condition
 | Thrown if the initThreshold is less than 0 or greater than 255.
See Also

Reference

GlobalThresholdCommand Class
GlobalThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of GlobalThresholdCommand from serialization information.
Initializes a new instance of GlobalThresholdCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GlobalThresholdCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

GlobalThresholdCommand Class
GlobalThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Properties

The GlobalThresholdCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InitThreshold | Gets or sets the initial threshold value.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.InitThreshold Property

GlobalThresholdCommandInitThreshold Property

Gets or sets the initial threshold value.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InitThreshold { get; set; }
Public Property InitThreshold As Integer
    Get
    Set

Property Value

Type: Int32
The initial threshold value.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255 inclusive.
Remarks
When there is reason to believe that the background and object occupy comparable areas in the image, a good initial value for InitThreshold is the average gray level of the image.
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.SupportedPixelFormats Property

GlobalThresholdCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand Methods

The GlobalThresholdCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.ConstructFinalImage Method

GlobalThresholdCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.GetObjectData Method

GlobalThresholdCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.PerformActualCommand Method

GlobalThresholdCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.SelectPreferredPixelFormat Method

GlobalThresholdCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


GlobalThresholdCommand.VerifyProperties Method

GlobalThresholdCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

GlobalThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone Class

Represents a halftone region in an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.DocumentHalftone

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Halftone
Public Class Halftone

The Halftone type exposes the following members.

Constructors
 | Name | Description
Public method | Halftone | Creates a new instance of Halftone.
Public method | Halftone(Rectangle) | Creates a new instance of Halftone specifying the bounds.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the rectangular boundary of the halftone region.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
A halftone is a screen of dots that are used in a black and white image to simulate levels of gray.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone Constructor

Overload List
 | Name | Description
Public method | Halftone | Creates a new instance of Halftone.
Public method | Halftone(Rectangle) | Creates a new instance of Halftone specifying the bounds.
Top
See Also

Reference

Halftone Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone Constructor

Creates a new instance of Halftone.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Halftone()
Public Sub New
See Also

Reference

Halftone Class
Halftone Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone Constructor (Rectangle)

Creates a new instance of Halftone specifying the bounds.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Halftone(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The rectangular bounds of the halftone on the image.
See Also

Reference

Halftone Class
Halftone Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone Properties

The Halftone type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the rectangular boundary of the halftone region.
Top
See Also

Reference

Halftone Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone.Bounds Property

HalftoneBounds Property

Gets the rectangular boundary of the halftone region.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

Halftone Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Halftone Methods

The Halftone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Halftone Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection Class

Represents a collection of Halftone objects.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.Imaging.ImageProcessing.DocumentHalftoneCollection

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HalftoneCollection : ReadOnlyCollectionBase
Public Class HalftoneCollection
    Inherits ReadOnlyCollectionBase

The HalftoneCollection type exposes the following members.

Constructors
 | Name | Description
Public method | HalftoneCollection | Creates a new instance of HalftoneCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Returns the Halftone object at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds a new Halftone item to the collection.
Public method | Contains | Returns true if the specified Halftone object exists in the collection.
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches the collection for the specified Halftone object and returns the index in the array, or -1 if it's not found.
Public method | Insert | Inserts a Halftone object in at the specifed index in the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified Halftone object from the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection Constructor

Creates a new instance of HalftoneCollection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HalftoneCollection()
Public Sub New
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection Properties

The HalftoneCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Returns the Halftone object at the specified index.
Top
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.Item Property

HalftoneCollectionItem Property

Returns the Halftone object at the specified index.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Halftone this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As Halftone
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Halftone
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection Methods

The HalftoneCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new Halftone item to the collection.
Public method | Contains | Returns true if the specified Halftone object exists in the collection.
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches the collection for the specified Halftone object and returns the index in the array, or -1 if it's not found.
Public method | Insert | Inserts a Halftone object in at the specifed index in the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified Halftone object from the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.Add Method

HalftoneCollectionAdd Method

Adds a new Halftone item to the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    Halftone item
)
Public Overridable Sub Add (
    item As Halftone
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftone
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.Contains Method

HalftoneCollectionContains Method

Returns true if the specified Halftone object exists in the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    Halftone item
)
Public Overridable Function Contains (
    item As Halftone
) As Boolean

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftone

Return Value

Type: Boolean
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.CopyTo Method

HalftoneCollectionCopyTo Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    Halftone[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As Halftone(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftone
index
Type: SystemInt32
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.IndexOf Method

HalftoneCollectionIndexOf Method

Searches the collection for the specified Halftone object and returns the index in the array, or -1 if it's not found.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    Halftone item
)
Public Overridable Function IndexOf (
    item As Halftone
) As Integer

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftone

Return Value

Type: Int32
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.Insert Method

HalftoneCollectionInsert Method

Inserts a Halftone object in at the specifed index in the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    Halftone item
)
Public Overridable Sub Insert (
    index As Integer,
    item As Halftone
)

Parameters

index
Type: SystemInt32
item
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftone
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneCollection.Remove Method

HalftoneCollectionRemove Method

Removes the specified Halftone object from the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    Halftone item
)
Public Overridable Sub Remove (
    item As Halftone
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftone
See Also

Reference

HalftoneCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand Class

Detects and removes shaded regions from bi-tonal images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentHalftoneRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HalftoneRemovalCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class HalftoneRemovalCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The HalftoneRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | HalftoneRemovalCommand | Creates a new instance of HalftoneRemovalCommand.
Protected method | HalftoneRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the HalftoneRemovalCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MinRegionSize | The minimum region size that will be detected as halftone.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Halftone removal is designed for regions that originate as shaded color or grayscale areas that when thresholded to black and white, end up with a halftone texture. OCR engines generally cannot recognize text that is surrounded by halftoning. This command can be used as pre-processing prior to OCR for improved OCR accuracy.

When applying this command, the resulting ImageResults is an instance of HalftoneRemovalResults containing the rectangular boundary of each detected halftone region.

Examples
[New Example] (C#)
Copy
HalftoneRemovalCommand cmd = new HalftoneRemovalCommand();
HalftoneRemovalResults results = (HalftoneRemovalResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
foreach (Haltfone tones in results.Halftones)
{
    Console.WriteLine(tones.Bounds);
}
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As HalftoneRemovalCommand =  New HalftoneRemovalCommand()
Dim results As HalftoneRemovalResults = CType(cmd.Apply(sourceImage), HalftoneRemovalResults)
Dim NewImage As AtalaImage =  results.Image
Dim tones As Haltfone
For Each tones In results.Halftones
    Console.WriteLine(tones.Bounds)
Next
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
HalftoneRemovalResults Class


HalftoneRemovalCommand Constructor

Overload List
 | Name | Description
Public method | HalftoneRemovalCommand | Creates a new instance of HalftoneRemovalCommand.
Protected method | HalftoneRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the HalftoneRemovalCommand class
Top
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand Constructor

Creates a new instance of HalftoneRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HalftoneRemovalCommand()
Public Sub New
See Also

Reference

HalftoneRemovalCommand Class
HalftoneRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the HalftoneRemovalCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HalftoneRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

HalftoneRemovalCommand Class
HalftoneRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand Properties

The HalftoneRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MinRegionSize | The minimum region size that will be detected as halftone.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand.MinRegionSize Property

HalftoneRemovalCommandMinRegionSize Property

The minimum region size that will be detected as halftone.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinRegionSize { get; set; }
Public Overridable Property MinRegionSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is 100, 20.
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand.SpeedFactor Property

HalftoneRemovalCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand.SupportedPixelFormats Property

HalftoneRemovalCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand Methods

The HalftoneRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand.GetObjectData Method

HalftoneRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand.PerformActualCommand Method

HalftoneRemovalCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalCommand.VerifyProperties Method

HalftoneRemovalCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

HalftoneRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults Class

Provides custom ImageResults for HalftoneRemovalCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentHalftoneRemovalResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HalftoneRemovalResults : ImageResults
Public Class HalftoneRemovalResults
    Inherits ImageResults

The HalftoneRemovalResults type exposes the following members.

Constructors
 | Name | Description
Public method | HalftoneRemovalResults | Creates a new instance of HalftoneRemovalResults.
Public method | HalftoneRemovalResults(HalftoneCollection) | Creates a new instance of HalftoneRemovalResults specifying the Halftones.
Top
Properties
 | Name | Description
Public property | Halftones | Gets a collection of Halftone objects that are located in the applied image.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults Constructor

Overload List
 | Name | Description
Public method | HalftoneRemovalResults | Creates a new instance of HalftoneRemovalResults.
Public method | HalftoneRemovalResults(HalftoneCollection) | Creates a new instance of HalftoneRemovalResults specifying the Halftones.
Top
See Also

Reference

HalftoneRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults Constructor

Creates a new instance of HalftoneRemovalResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HalftoneRemovalResults()
Public Sub New
See Also

Reference

HalftoneRemovalResults Class
HalftoneRemovalResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults Constructor (HalftoneCollection)

Creates a new instance of HalftoneRemovalResults specifying the Halftones.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HalftoneRemovalResults(
    HalftoneCollection halftones
)
Public Sub New (
    halftones As HalftoneCollection
)

Parameters

halftones
Type: Atalasoft.Imaging.ImageProcessing.DocumentHalftoneCollection
See Also

Reference

HalftoneRemovalResults Class
HalftoneRemovalResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults Properties

The HalftoneRemovalResults type exposes the following members.

Properties
 | Name | Description
Public property | Halftones | Gets a collection of Halftone objects that are located in the applied image.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

HalftoneRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults.Halftones Property

HalftoneRemovalResultsHalftones Property

Gets a collection of Halftone objects that are located in the applied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual HalftoneCollection Halftones { get; }
Public Overridable ReadOnly Property Halftones As HalftoneCollection
    Get

Property Value

Type: HalftoneCollection
See Also

Reference

HalftoneRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HalftoneRemovalResults Methods

The HalftoneRemovalResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HalftoneRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Class

Represents a single hole punch in an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.DocumentHolePunch

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HolePunch : ISerializable
<SerializableAttribute>
Public Class HolePunch
    Implements ISerializable

The HolePunch type exposes the following members.

Constructors
 | Name | Description
Public method | HolePunch | Creates a new instance of HolePunch.
Public method | HolePunch(Rectangle) | Creates a new instance of HolePunch specifying the hole punch bounds.
Public method | HolePunch(SerializationInfo, StreamingContext) | Creates a new instance of HolePunch specifying the hole punch bounds.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the rectangular boundary of the hole punch.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality |
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Constructor

Overload List
 | Name | Description
Public method | HolePunch | Creates a new instance of HolePunch.
Public method | HolePunch(Rectangle) | Creates a new instance of HolePunch specifying the hole punch bounds.
Public method | HolePunch(SerializationInfo, StreamingContext) | Creates a new instance of HolePunch specifying the hole punch bounds.
Top
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Constructor

Creates a new instance of HolePunch.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunch()
Public Sub New
See Also

Reference

HolePunch Class
HolePunch Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Constructor (Rectangle)

Creates a new instance of HolePunch specifying the hole punch bounds.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunch(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
See Also

Reference

HolePunch Class
HolePunch Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HolePunch specifying the hole punch bounds.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunch(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

HolePunch Class
HolePunch Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Properties

The HolePunch type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the rectangular boundary of the hole punch.
Top
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch.Bounds Property

HolePunchBounds Property

Gets the rectangular boundary of the hole punch.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; }
Public Overridable ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Methods

The HolePunch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch.Equals Method

HolePunchEquals Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object rhs
)
Public Overrides Function Equals (
    rhs As Object
) As Boolean

Parameters

rhs
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch.GetObjectData Method

HolePunchGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch Operators

The HolePunch type exposes the following members.

Operators
Name | Description
Equality |
Top
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunch.Equality Operator

HolePunchEquality Operator

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    HolePunch lhs,
    HolePunch rhs
)
Public Shared Operator = (
    lhs As HolePunch,
    rhs As HolePunch
) As Boolean

Parameters

lhs
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch
rhs
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch

Return Value

Type: Boolean
See Also

Reference

HolePunch Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection Class

Represents a collection of HolePunch objects.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.Imaging.ImageProcessing.DocumentHolePunchCollection

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HolePunchCollection : ReadOnlyCollectionBase
Public Class HolePunchCollection
    Inherits ReadOnlyCollectionBase

The HolePunchCollection type exposes the following members.

Constructors
 | Name | Description
Public method | HolePunchCollection | Creates a new instance of HolePunchCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Returns the HolePunch object at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds a new HolePunch object to the collection.
Public method | Contains | Returns true if the specified HolePunch object exists in the collection.
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches the collection for the specified HolePunch object and returns the index in the array, or -1 if it's not found.
Public method | Insert | Inserts a HolePunch object in at the specifed index in the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified HolePunch object from the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection Constructor

Creates a new instance of HolePunchCollection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunchCollection()
Public Sub New
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection Properties

The HolePunchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Returns the HolePunch object at the specified index.
Top
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.Item Property

HolePunchCollectionItem Property

Returns the HolePunch object at the specified index.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual HolePunch this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As HolePunch
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: HolePunch
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection Methods

The HolePunchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new HolePunch object to the collection.
Public method | Contains | Returns true if the specified HolePunch object exists in the collection.
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches the collection for the specified HolePunch object and returns the index in the array, or -1 if it's not found.
Public method | Insert | Inserts a HolePunch object in at the specifed index in the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified HolePunch object from the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.Add Method

HolePunchCollectionAdd Method

Adds a new HolePunch object to the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    HolePunch source
)
Public Overridable Sub Add (
    source As HolePunch
)

Parameters

source
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.Contains Method

HolePunchCollectionContains Method

Returns true if the specified HolePunch object exists in the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    HolePunch source
)
Public Overridable Function Contains (
    source As HolePunch
) As Boolean

Parameters

source
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch

Return Value

Type: Boolean
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.CopyTo Method

HolePunchCollectionCopyTo Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    HolePunch[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As HolePunch(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch
index
Type: SystemInt32
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.IndexOf Method

HolePunchCollectionIndexOf Method

Searches the collection for the specified HolePunch object and returns the index in the array, or -1 if it's not found.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    HolePunch source
)
Public Overridable Function IndexOf (
    source As HolePunch
) As Integer

Parameters

source
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch

Return Value

Type: Int32
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.Insert Method

HolePunchCollectionInsert Method

Inserts a HolePunch object in at the specifed index in the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    HolePunch source
)
Public Overridable Sub Insert (
    index As Integer,
    source As HolePunch
)

Parameters

index
Type: SystemInt32
source
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchCollection.Remove Method

HolePunchCollectionRemove Method

Removes the specified HolePunch object from the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    HolePunch source
)
Public Overridable Sub Remove (
    source As HolePunch
)

Parameters

source
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunch
See Also

Reference

HolePunchCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand Class

Removes circular hole punch artifacts from an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentHolePunchRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HolePunchRemovalCommand : ImageRegionCommand,
    IProcessSpeedConfig, IPropertiesAutoConfigurable, ISerializable
<SerializableAttribute>
Public Class HolePunchRemovalCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, IPropertiesAutoConfigurable, ISerializable

The HolePunchRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | HolePunchRemovalCommand | Creates a new instance of HolePunchRemovalCommand.
Protected method | HolePunchRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the HolePunchRemovalCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoPropertyConfigurationEnabled | Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ContentClusteringHint | The minimum distance in pixels between the hole punch boundary, and the text body.
Public property | HolePunchLocation | The location of hole punches on the image (Left, Top, Right, Bottom).
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxHolePunchSize | The maximum size hole punch that will be removed in pixels.
Public property | MinHolePunchSize | The minimum size hole punch that will be removed in pixels.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | PropertiesToAutoConfigure | Gets a collection of property names that will be auto configured when AutoPropertyConfigurationEnabled is true.
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

When applying this command, the resulting ImageResults is an instance of HolePunchRemovalResults containing the rectangular boundary of each detected hole punch.

Examples
Example
Copy
var cmd = new HolePunchRemovalCommand {HolePunchLocation = ImageEdges.Left | ImageEdges.Right};
var results = (HolePunchRemovalResults) cmd.Apply(sourceImage);
var newImage = results.Image;
foreach (HolePunch hole in results.HolePunches)
{
    Console.WriteLine(hole.Bounds);
}

if (!results.IsImageSourceImage)
    sourceImage.Dispose(); //free memory
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
HolePunchRemovalResults Class


HolePunchRemovalCommand Constructor

Overload List
 | Name | Description
Public method | HolePunchRemovalCommand | Creates a new instance of HolePunchRemovalCommand.
Protected method | HolePunchRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the HolePunchRemovalCommand class
Top
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand Constructor

Creates a new instance of HolePunchRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunchRemovalCommand()
Public Sub New
See Also

Reference

HolePunchRemovalCommand Class
HolePunchRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the HolePunchRemovalCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HolePunchRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

HolePunchRemovalCommand Class
HolePunchRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand Properties

The HolePunchRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoPropertyConfigurationEnabled | Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ContentClusteringHint | The minimum distance in pixels between the hole punch boundary, and the text body.
Public property | HolePunchLocation | The location of hole punches on the image (Left, Top, Right, Bottom).
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxHolePunchSize | The maximum size hole punch that will be removed in pixels.
Public property | MinHolePunchSize | The minimum size hole punch that will be removed in pixels.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | PropertiesToAutoConfigure | Gets a collection of property names that will be auto configured when AutoPropertyConfigurationEnabled is true.
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.AutoPropertyConfigurationEnabled Property

HolePunchRemovalCommandAutoPropertyConfigurationEnabled Property

Gets or sets a value indicating if properties in the PropertiesToAutoConfigure property will be automatically determined by the command when processed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool AutoPropertyConfigurationEnabled { get; set; }
Public Overridable Property AutoPropertyConfigurationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IPropertiesAutoConfigurableAutoPropertyConfigurationEnabled
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.ContentClusteringHint Property

HolePunchRemovalCommandContentClusteringHint Property

The minimum distance in pixels between the hole punch boundary, and the text body.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int ContentClusteringHint { get; set; }
Public Overridable Property ContentClusteringHint As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
This property is useful when holepunches are located near the text body. Default value is 20.
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.HolePunchLocation Property

HolePunchRemovalCommandHolePunchLocation Property

The location of hole punches on the image (Left, Top, Right, Bottom).

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ImageEdges HolePunchLocation { get; set; }
Public Overridable Property HolePunchLocation As ImageEdges
    Get
    Set

Property Value

Type: ImageEdges
Remarks
Default value is Left. ImageEdges can be or'ed together for the algorithm to search more than one edge.
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.MaxHolePunchSize Property

HolePunchRemovalCommandMaxHolePunchSize Property

The maximum size hole punch that will be removed in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MaxHolePunchSize { get; set; }
Public Overridable Property MaxHolePunchSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is 80. This property is auto configurable.
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.MinHolePunchSize Property

HolePunchRemovalCommandMinHolePunchSize Property

The minimum size hole punch that will be removed in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinHolePunchSize { get; set; }
Public Overridable Property MinHolePunchSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is 10. This property is auto configurable.
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.PropertiesToAutoConfigure Property

HolePunchRemovalCommandPropertiesToAutoConfigure Property

Gets a collection of property names that will be auto configured when AutoPropertyConfigurationEnabled is true.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual StringCollection PropertiesToAutoConfigure { get; }
Public Overridable ReadOnly Property PropertiesToAutoConfigure As StringCollection
    Get

Property Value

Type: StringCollection

Implements

IPropertiesAutoConfigurablePropertiesToAutoConfigure
Remarks
This collection can be modified by adding or removing property names to be auto configured. Properties must have the AutoConfigurableAttribute to be added to this collection. All AutoConfigurable properties are added to this collection by default which include MaxHolePunchSize and MinHolePunchSize.
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.SpeedFactor Property

HolePunchRemovalCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Fast.
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.SupportedPixelFormats Property

HolePunchRemovalCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand Methods

The HolePunchRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.GetObjectData Method

HolePunchRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.PerformActualCommand Method

HolePunchRemovalCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalCommand.VerifyProperties Method

HolePunchRemovalCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

HolePunchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults Class

Provides custom ImageResults for HolePunchRemovalCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentHolePunchRemovalResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HolePunchRemovalResults : ImageResults
Public Class HolePunchRemovalResults
    Inherits ImageResults

The HolePunchRemovalResults type exposes the following members.

Constructors
 | Name | Description
Public method | HolePunchRemovalResults | Creates a new instance of HolePunchRemovalResults.
Public method | HolePunchRemovalResults(HolePunchCollection) | Creates a new instance of HolePunchRemovalResults specifying a collection of hole punches.
Top
Properties
 | Name | Description
Public property | HolePunches | Gets a collection of HolePunch objects.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults Constructor

Overload List
 | Name | Description
Public method | HolePunchRemovalResults | Creates a new instance of HolePunchRemovalResults.
Public method | HolePunchRemovalResults(HolePunchCollection) | Creates a new instance of HolePunchRemovalResults specifying a collection of hole punches.
Top
See Also

Reference

HolePunchRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults Constructor

Creates a new instance of HolePunchRemovalResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunchRemovalResults()
Public Sub New
See Also

Reference

HolePunchRemovalResults Class
HolePunchRemovalResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults Constructor (HolePunchCollection)

Creates a new instance of HolePunchRemovalResults specifying a collection of hole punches.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HolePunchRemovalResults(
    HolePunchCollection holePunches
)
Public Sub New (
    holePunches As HolePunchCollection
)

Parameters

holePunches
Type: Atalasoft.Imaging.ImageProcessing.DocumentHolePunchCollection
See Also

Reference

HolePunchRemovalResults Class
HolePunchRemovalResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults Properties

The HolePunchRemovalResults type exposes the following members.

Properties
 | Name | Description
Public property | HolePunches | Gets a collection of HolePunch objects.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

HolePunchRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults.HolePunches Property

HolePunchRemovalResultsHolePunches Property

Gets a collection of HolePunch objects.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual HolePunchCollection HolePunches { get; }
Public Overridable ReadOnly Property HolePunches As HolePunchCollection
    Get

Property Value

Type: HolePunchCollection
See Also

Reference

HolePunchRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


HolePunchRemovalResults Methods

The HolePunchRemovalResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HolePunchRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ImageEdges Enumeration

Indicates the edge of the image to inspect for commands such as HolePunchRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum ImageEdges
<FlagsAttribute>
Public Enumeration ImageEdges
Members
Member name | Description
None |
Left | Left side of the image
Right | Right side of the image
Top | Top of the image
Bottom | Bottom of the image
Remarks
This enumeration uses the FlagAttribute allowing each item to be OR'ed together to combine sides.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


IProcessSpeedConfig Interface

Interface that when applied to a class is used to control the sampling factor useful in improving performance possibly at the expense of accuracy.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IProcessSpeedConfig
Public Interface IProcessSpeedConfig

The IProcessSpeedConfig type exposes the following members.

Properties
 | Name | Description
Public property | SpeedFactor | Gets or sets the sample size of the image to process, affecting quality and speed.
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


IProcessSpeedConfig Properties

The IProcessSpeedConfig type exposes the following members.

Properties
 | Name | Description
Public property | SpeedFactor | Gets or sets the sample size of the image to process, affecting quality and speed.
Top
See Also

Reference

IProcessSpeedConfig Interface
Atalasoft.Imaging.ImageProcessing.Document Namespace


IProcessSpeedConfig.SpeedFactor Property

IProcessSpeedConfigSpeedFactor Property

Gets or sets the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
RunSpeed SpeedFactor { get; set; }
Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed
See Also

Reference

IProcessSpeedConfig Interface
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Class

Represents a single line in an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.DocumentLine

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Line : ISerializable, ICloneable
<SerializableAttribute>
Public Class Line
    Implements ISerializable, ICloneable

The Line type exposes the following members.

Constructors
 | Name | Description
Public method | Line | Creates a new instance of Line.
Public method | Line(SerializationInfo, StreamingContext) | Initializes a new instance of the Line class
Public method | Line(Point, Point, Int32) | Creates a new instance of Line specifying the start point, end point, and thickness.
Top
Properties
 | Name | Description
Public property | Endpoint | Gets or sets the end point of the line relative to the image.
Public property | Startpoint | Gets or sets the start point of the line relative to the image.
Public property | Thickness | Gets or sets the thickness of the line in pixels.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality |
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Constructor

Overload List
 | Name | Description
Public method | Line | Creates a new instance of Line.
Public method | Line(SerializationInfo, StreamingContext) | Initializes a new instance of the Line class
Public method | Line(Point, Point, Int32) | Creates a new instance of Line specifying the start point, end point, and thickness.
Top
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Constructor

Creates a new instance of Line.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Line()
Public Sub New
See Also

Reference

Line Class
Line Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Line class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Line(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

Line Class
Line Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Constructor (Point, Point, Int32)

Creates a new instance of Line specifying the start point, end point, and thickness.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Line(
    Point startpoint,
    Point endpoint,
    int thickness
)
Public Sub New (
    startpoint As Point,
    endpoint As Point,
    thickness As Integer
)

Parameters

startpoint
Type: System.DrawingPoint
start point of the line relative to the image
endpoint
Type: System.DrawingPoint
end point of the line relative to the image
thickness
Type: SystemInt32
the thickness of the line in pixels
See Also

Reference

Line Class
Line Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Properties

The Line type exposes the following members.

Properties
 | Name | Description
Public property | Endpoint | Gets or sets the end point of the line relative to the image.
Public property | Startpoint | Gets or sets the start point of the line relative to the image.
Public property | Thickness | Gets or sets the thickness of the line in pixels.
Top
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.Endpoint Property

LineEndpoint Property

Gets or sets the end point of the line relative to the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Point Endpoint { get; set; }
Public Overridable Property Endpoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.Startpoint Property

LineStartpoint Property

Gets or sets the start point of the line relative to the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Point Startpoint { get; set; }
Public Overridable Property Startpoint As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.Thickness Property

LineThickness Property

Gets or sets the thickness of the line in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Thickness { get; set; }
Public Overridable Property Thickness As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Methods

The Line type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.Clone Method

LineClone Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.Equals Method

LineEquals Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object rhs
)
Public Overrides Function Equals (
    rhs As Object
) As Boolean

Parameters

rhs
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.GetClonedObject Method

LineGetClonedObject Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Line GetClonedObject()
Protected Overridable Function GetClonedObject As Line

Return Value

Type: Line
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.GetHashCode Method

LineGetHashCode Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.GetObjectData Method

LineGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line Operators

The Line type exposes the following members.

Operators
Name | Description
Equality |
Top
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Line.Equality Operator

LineEquality Operator

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    Line lhs,
    Line rhs
)
Public Shared Operator = (
    lhs As Line,
    rhs As Line
) As Boolean

Parameters

lhs
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine
rhs
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine

Return Value

Type: Boolean
See Also

Reference

Line Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection Class

Represents a collection of Line objects.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.Imaging.ImageProcessing.DocumentLineCollection

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LineCollection : ReadOnlyCollectionBase
Public Class LineCollection
    Inherits ReadOnlyCollectionBase

The LineCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LineCollection | Creates a new instance of LineCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item |
Top
Methods
 | Name | Description
Public method | Add |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection Constructor

Creates a new instance of LineCollection.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineCollection()
Public Sub New
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection Properties

The LineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item |
Top
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.Item Property

LineCollectionItem Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Line this[
    int index
] { get; }
Public Overridable ReadOnly Default Property Item (
    index As Integer
) As Line
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Line
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection Methods

The LineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.Add Method

LineCollectionAdd Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    Line item
)
Public Overridable Sub Add (
    item As Line
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.Contains Method

LineCollectionContains Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    Line item
)
Public Overridable Function Contains (
    item As Line
) As Boolean

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine

Return Value

Type: Boolean
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.CopyTo Method

LineCollectionCopyTo Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    Line[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As Line(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine
index
Type: SystemInt32
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.IndexOf Method

LineCollectionIndexOf Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    Line item
)
Public Overridable Function IndexOf (
    item As Line
) As Integer

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine

Return Value

Type: Int32
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.Insert Method

LineCollectionInsert Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    Line item
)
Public Overridable Sub Insert (
    index As Integer,
    item As Line
)

Parameters

index
Type: SystemInt32
item
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineCollection.Remove Method

LineCollectionRemove Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    Line item
)
Public Overridable Sub Remove (
    item As Line
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentLine
See Also

Reference

LineCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineOrientations Enumeration

Controls the Line Orientation used in LineRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum LineOrientations
<FlagsAttribute>
Public Enumeration LineOrientations
Members
Member name | Description
None | None
Horizontal | Horizontal
Vertical | Vertical
Orthogonal | Both Horizontal and Vertical. Same as Vertical | Horizontal.
Remarks
This enum is flagged and can be OR'ed to combine multiple options.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand Class

This class removes horizontal and/or vertical lines in a bi-tonal image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentLineRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LineRemovalCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class LineRemovalCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The LineRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | LineRemovalCommand | Creates a new instance of LineRemovalCommand.
Protected method | LineRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the LineRemovalCommand class
Top
Properties
 | Name | Description
Public property | AngleTolerance | The tolerance in degrees offset from vertical or horizontal.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxLineGap | Lines detected will have a gap no greater than this value in pixels.
Public property | MaxLineThickness | Maximum thickness in pixels of the line to be removed.
Public property | MinLineLength | Minimum size limit of the lines to be removed in pixels.
Public property | MinLineThickness | Minimum thickness in pixels of the line to be removed.
Public property | Orientation | Orientation of the line to be removed: horizontal, vertical, or both.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ReconnectBrokenCharacters | When true, reconnects characters that are damaged when intersecting a line that is removed.
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

When applying this command, the resulting ImageResults is an instance of LineRemovalResults containing the start point, end point, and thickness of each detected line.

Examples
[New Example] (C#)
Copy
LineRemovalCommand cmd = new LineRemovalCommand();
cmd.Orientation = LineOrientation.Horizontal;
LineRemovalResults results = (LineRemovalResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
foreach (Line line in results.Lines)
{
    Console.WriteLine(new Rectangle(line.StartPoint, line.EndPoint).ToString());
}
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As LineRemovalCommand =  New LineRemovalCommand()
cmd.Orientation = LineOrientation.Horizontal
Dim results As LineRemovalResults = CType(cmd.Apply(sourceImage), LineRemovalResults)
Dim NewImage As AtalaImage =  results.Image
Dim line As Line
For Each line In results.Lines
    Console.WriteLine(New Rectangle(line.StartPoint, line.EndPoint).ToString())
Next
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() ' free memory
End If
Examples
[New Example] (C#)
Copy
LineRemovalCommand cmd = new LineRemovalCommand();
cmd.Orientation = LineOrientation.Horizontal;
LineRemovalResults results = (LineRemovalResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
foreach (Line line in results.Lines)
{
    Console.WriteLine(new Rectangle(line.StartPoint, line.EndPoint).ToString());
}
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As LineRemovalCommand =  New LineRemovalCommand()
cmd.Orientation = LineOrientation.Horizontal
Dim results As LineRemovalResults = CType(cmd.Apply(sourceImage), LineRemovalResults)
Dim NewImage As AtalaImage =  results.Image
Dim line As Line
For Each line In results.Lines
    Console.WriteLine(New Rectangle(line.StartPoint, line.EndPoint).ToString())
Next
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() ' free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
LineRemovalResults Class


LineRemovalCommand Constructor

Overload List
 | Name | Description
Public method | LineRemovalCommand | Creates a new instance of LineRemovalCommand.
Protected method | LineRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the LineRemovalCommand class
Top
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand Constructor

Creates a new instance of LineRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineRemovalCommand()
Public Sub New
See Also

Reference

LineRemovalCommand Class
LineRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LineRemovalCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LineRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

LineRemovalCommand Class
LineRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand Properties

The LineRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | The tolerance in degrees offset from vertical or horizontal.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxLineGap | Lines detected will have a gap no greater than this value in pixels.
Public property | MaxLineThickness | Maximum thickness in pixels of the line to be removed.
Public property | MinLineLength | Minimum size limit of the lines to be removed in pixels.
Public property | MinLineThickness | Minimum thickness in pixels of the line to be removed.
Public property | Orientation | Orientation of the line to be removed: horizontal, vertical, or both.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ReconnectBrokenCharacters | When true, reconnects characters that are damaged when intersecting a line that is removed.
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.AngleTolerance Property

LineRemovalCommandAngleTolerance Property

The tolerance in degrees offset from vertical or horizontal.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual float AngleTolerance { get; set; }
Public Overridable Property AngleTolerance As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.MaxLineGap Property

LineRemovalCommandMaxLineGap Property

Lines detected will have a gap no greater than this value in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaxLineGap { get; set; }
Public Overridable Property MaxLineGap As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Default value is 20. A value greater than 20 will remove broken lines.
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.MaxLineThickness Property

LineRemovalCommandMaxLineThickness Property

Maximum thickness in pixels of the line to be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaxLineThickness { get; set; }
Public Overridable Property MaxLineThickness As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Default value is 14.
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.MinLineLength Property

LineRemovalCommandMinLineLength Property

Minimum size limit of the lines to be removed in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinLineLength { get; set; }
Public Overridable Property MinLineLength As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is (100, 100).
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.MinLineThickness Property

LineRemovalCommandMinLineThickness Property

Minimum thickness in pixels of the line to be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MinLineThickness { get; set; }
Public Overridable Property MinLineThickness As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Default value is 0.
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.Orientation Property

LineRemovalCommandOrientation Property

Orientation of the line to be removed: horizontal, vertical, or both.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual LineOrientations Orientation { get; set; }
Public Overridable Property Orientation As LineOrientations
    Get
    Set

Property Value

Type: LineOrientations
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.ReconnectBrokenCharacters Property

LineRemovalCommandReconnectBrokenCharacters Property

When true, reconnects characters that are damaged when intersecting a line that is removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool ReconnectBrokenCharacters { get; set; }
Public Overridable Property ReconnectBrokenCharacters As Boolean
    Get
    Set

Property Value

Type: Boolean
bool
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.SpeedFactor Property

LineRemovalCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.SupportedPixelFormats Property

LineRemovalCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand Methods

The LineRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.GetObjectData Method

LineRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.PerformActualCommand Method

LineRemovalCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalCommand.VerifyProperties Method

LineRemovalCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

LineRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults Class

Provides custom ImageResults for LineRemovalCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentLineRemovalResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LineRemovalResults : ImageResults
Public Class LineRemovalResults
    Inherits ImageResults

The LineRemovalResults type exposes the following members.

Constructors
 | Name | Description
Public method | LineRemovalResults | Creates a new instance of LineRemovalResults.
Public method | LineRemovalResults(LineCollection) | Creates a new instance of LineRemovalResults specifying a collection of Lines.
Top
Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | Lines | A collection of Line objects.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults Constructor

Overload List
 | Name | Description
Public method | LineRemovalResults | Creates a new instance of LineRemovalResults.
Public method | LineRemovalResults(LineCollection) | Creates a new instance of LineRemovalResults specifying a collection of Lines.
Top
See Also

Reference

LineRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults Constructor

Creates a new instance of LineRemovalResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineRemovalResults()
Public Sub New
See Also

Reference

LineRemovalResults Class
LineRemovalResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults Constructor (LineCollection)

Creates a new instance of LineRemovalResults specifying a collection of Lines.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineRemovalResults(
    LineCollection lines
)
Public Sub New (
    lines As LineCollection
)

Parameters

lines
Type: Atalasoft.Imaging.ImageProcessing.DocumentLineCollection
See Also

Reference

LineRemovalResults Class
LineRemovalResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults Properties

The LineRemovalResults type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | Lines | A collection of Line objects.
Top
See Also

Reference

LineRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults.Lines Property

LineRemovalResultsLines Property

A collection of Line objects.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual LineCollection Lines { get; }
Public Overridable ReadOnly Property Lines As LineCollection
    Get

Property Value

Type: LineCollection
See Also

Reference

LineRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


LineRemovalResults Methods

The LineRemovalResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineRemovalResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand Class

Crops excess white borders from a bi-tonal image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentMarginCropCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MarginCropCommand : ImageCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class MarginCropCommand
    Inherits ImageCommand
    Implements IProcessSpeedConfig, ISerializable

The MarginCropCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MarginCropCommand | Creates a new instance of MarginCropCommand.
Protected method | MarginCropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the MarginCropCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise | When true, will remove noise before detecting the margin.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

When scanned images contain large white borders or margins, this will automatically crop the image leaving only the interesting document features.

When applying this command, the resulting ImageResults is an instance of MarginCropResults containing the margin boundary.

Examples
[New Example] (C#)
Copy
MarginCropCommand cmd = new MarginCropCommand();
MarginCropResults results = (MarginCropResults)cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
Rectangle borderRect = results.BorderRectangle;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As MarginCropCommand =  New MarginCropCommand()
Dim results As MarginCropResults = CType(cmd.Apply(sourceImage), MarginCropResults)
Dim NewImage As AtalaImage =  results.Image
Dim borderRect As Rectangle =  results.BorderRectangle
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace
MarginCropResults Class


MarginCropCommand Constructor

Overload List
 | Name | Description
Public method | MarginCropCommand | Creates a new instance of MarginCropCommand.
Protected method | MarginCropCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the MarginCropCommand class
Top
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand Constructor

Creates a new instance of MarginCropCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarginCropCommand()
Public Sub New
See Also

Reference

MarginCropCommand Class
MarginCropCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the MarginCropCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MarginCropCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

MarginCropCommand Class
MarginCropCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand Properties

The MarginCropCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise | When true, will remove noise before detecting the margin.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.Denoise Property

MarginCropCommandDenoise Property

When true, will remove noise before detecting the margin.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Denoise { get; set; }
Public Overridable Property Denoise As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false.
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.SpeedFactor Property

MarginCropCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.SupportedPixelFormats Property

MarginCropCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand Methods

The MarginCropCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.ConstructFinalImage Method

MarginCropCommandConstructFinalImage Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.GetObjectData Method

MarginCropCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.PerformActualCommand Method

MarginCropCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropCommand.VerifyProperties Method

MarginCropCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

MarginCropCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Class

Provides custom ImageResults for MarginCropCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentMarginCropResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MarginCropResults : ImageResults
Public Class MarginCropResults
    Inherits ImageResults

The MarginCropResults type exposes the following members.

Constructors
 | Name | Description
Public method | MarginCropResults | Creates a new instance of MarginCropResults.
Public method | MarginCropResults(Rectangle) | Creates a new instance of MarginCropResults given the border rectangle.
Public method | MarginCropResults(Rectangle, Rectangle) | Initializes a new instance of the MarginCropResults class
Top
Properties
 | Name | Description
Public property | BorderRectangle | Gets the rectangular coordinates of the detected border.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Constructor

Overload List
 | Name | Description
Public method | MarginCropResults | Creates a new instance of MarginCropResults.
Public method | MarginCropResults(Rectangle) | Creates a new instance of MarginCropResults given the border rectangle.
Public method | MarginCropResults(Rectangle, Rectangle) | Initializes a new instance of the MarginCropResults class
Top
See Also

Reference

MarginCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Constructor

Creates a new instance of MarginCropResults.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarginCropResults()
Public Sub New
See Also

Reference

MarginCropResults Class
MarginCropResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Constructor (Rectangle)

Creates a new instance of MarginCropResults given the border rectangle.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarginCropResults(
    Rectangle cropRegion
)
Public Sub New (
    cropRegion As Rectangle
)

Parameters

cropRegion
Type: System.DrawingRectangle
See Also

Reference

MarginCropResults Class
MarginCropResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Constructor (Rectangle, Rectangle)

Initializes a new instance of the MarginCropResults class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarginCropResults(
    Rectangle cropRegion,
    Rectangle roi
)
Public Sub New (
    cropRegion As Rectangle,
    roi As Rectangle
)

Parameters

cropRegion
Type: System.DrawingRectangle
roi
Type: System.DrawingRectangle
See Also

Reference

MarginCropResults Class
MarginCropResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Properties

The MarginCropResults type exposes the following members.

Properties
 | Name | Description
Public property | BorderRectangle | Gets the rectangular coordinates of the detected border.
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Top
See Also

Reference

MarginCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults.BorderRectangle Property

MarginCropResultsBorderRectangle Property

Gets the rectangular coordinates of the detected border.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle BorderRectangle { get; }
Public Overridable ReadOnly Property BorderRectangle As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

MarginCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MarginCropResults Methods

The MarginCropResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarginCropResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Class

This class will perform a mathematical morphological operation to a binary image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentMorphoDocumentCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MorphoDocumentCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MorphoDocumentCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MorphoDocumentCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MorphoDocumentCommand | Creates a new instance of MorphoDocumentCommand.
Public method | MorphoDocumentCommand(MorphoDocumentMode) | Create a new instance of MorphoDocumentCommand specifying mode.
Protected method | MorphoDocumentCommand(SerializationInfo, StreamingContext) | Creates a new instance of MorphoDocumentCommand from serialization information.
Public method | MorphoDocumentCommand(MorphoDocumentMode, IntegerMatrix) | Create a new instance of MorphoDocumentCommand specifying mode and mask.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mask | Gets or sets a matrix of integers controlling the behavior and depth of the filter.
Public property | Mode | Gets or set the type of morphological filter to perform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Morphology is the study of form and structure. In image processing, it encompasses a set of techniques that merge traditional image processing with set theory from mathematics.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Constructor

Overload List
 | Name | Description
Public method | MorphoDocumentCommand | Creates a new instance of MorphoDocumentCommand.
Public method | MorphoDocumentCommand(MorphoDocumentMode) | Create a new instance of MorphoDocumentCommand specifying mode.
Protected method | MorphoDocumentCommand(SerializationInfo, StreamingContext) | Creates a new instance of MorphoDocumentCommand from serialization information.
Public method | MorphoDocumentCommand(MorphoDocumentMode, IntegerMatrix) | Create a new instance of MorphoDocumentCommand specifying mode and mask.
Top
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Constructor

Creates a new instance of MorphoDocumentCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoDocumentCommand()
Public Sub New
See Also

Reference

MorphoDocumentCommand Class
MorphoDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Constructor (MorphoDocumentMode)

Create a new instance of MorphoDocumentCommand specifying mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoDocumentCommand(
    MorphoDocumentMode mode
)
Public Sub New (
    mode As MorphoDocumentMode
)

Parameters

mode
Type: Atalasoft.Imaging.ImageProcessing.DocumentMorphoDocumentMode
The type of morphological filter to perform.
See Also

Reference

MorphoDocumentCommand Class
MorphoDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MorphoDocumentCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MorphoDocumentCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

MorphoDocumentCommand Class
MorphoDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Constructor (MorphoDocumentMode, IntegerMatrix)

Create a new instance of MorphoDocumentCommand specifying mode and mask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoDocumentCommand(
    MorphoDocumentMode mode,
    IntegerMatrix mask
)
Public Sub New (
    mode As MorphoDocumentMode,
    mask As IntegerMatrix
)

Parameters

mode
Type: Atalasoft.Imaging.ImageProcessing.DocumentMorphoDocumentMode
The type of morphological filter to perform.
mask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
A matrix of integers controlling the behavior and depth of the filter.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the number of rows and columns in mask is not equal, or is even.
See Also

Reference

MorphoDocumentCommand Class
MorphoDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Properties

The MorphoDocumentCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mask | Gets or sets a matrix of integers controlling the behavior and depth of the filter.
Public property | Mode | Gets or set the type of morphological filter to perform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand.Mask Property

MorphoDocumentCommandMask Property

Gets or sets a matrix of integers controlling the behavior and depth of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix Mask { get; set; }
Public Property Mask As IntegerMatrix
    Get
    Set

Property Value

Type: IntegerMatrix
A matrix of integers controlling the behavior and depth of the filter.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if number of rows and cols is not equal, or is even.
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand.Mode Property

MorphoDocumentCommandMode Property

Gets or set the type of morphological filter to perform.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoDocumentMode Mode { get; set; }
Public Property Mode As MorphoDocumentMode
    Get
    Set

Property Value

Type: MorphoDocumentMode
The type of morphological filter to perform.
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand.SupportedPixelFormats Property

MorphoDocumentCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand Methods

The MorphoDocumentCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand.GetObjectData Method

MorphoDocumentCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the info argument is null (Nothing in VB).
SecurityException | The caller does not have the required permission.
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand.PerformActualCommand Method

MorphoDocumentCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentCommand.VerifyProperties Method

MorphoDocumentCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MorphoDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


MorphoDocumentMode Enumeration

The type of morphological filter to use in the MorphoDocumentCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MorphoDocumentMode
Public Enumeration MorphoDocumentMode
Members
Member name | Description
Dilation | Used to smooth small dark regions tending to enhance black features in the image.
Erosion | Used to smooth small light regions tending to reduce black features in the image.
Open | The dilation of the erosion of the image used to reduce small black regions within the image.
Close | The erosion of the dilation of the image used to reduce small white regions within the image.
BoundaryExtraction | Perform a boundary detection/extraction on a binary image. This will generate an outline of the foreground features of the input image
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


OnSegmentsLocatedEventHandler Delegate

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OnSegmentsLocatedEventHandler(
    Object sender,
    SegmentsLocatedEventArgs e
)
Public Delegate Sub OnSegmentsLocatedEventHandler (
    sender As Object,
    e As SegmentsLocatedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegmentsLocatedEventArgs
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Class

Overlay an image using an alpha mask.
Overlay an image using an alpha mask.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentOverlayMaskedDocumentCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OverlayMaskedDocumentCommand : ImageCommand,
    ISerializable
Public Class OverlayMaskedDocumentCommand
    Inherits ImageCommand
    Implements ISerializable

The OverlayMaskedDocumentCommand type exposes the following members.

Constructors
 | Name | Description
Public method | OverlayMaskedDocumentCommand | Creates a new instance of OverlayMaskedDocumentCommand.
Protected method | OverlayMaskedDocumentCommand(SerializationInfo, StreamingContext) | Creates a new instance of OverlayMaskedDocumentCommand from serialization information.
Public method | OverlayMaskedDocumentCommand(AtalaImage, AtalaImage) | Creates a new instance of OverlayMaskedDocumentCommand specifying topImage and mask.
Public method | OverlayMaskedDocumentCommand(AtalaImage, AtalaImage, Point) | Creates a new instance of OverlayMaskedDocumentCommand specifying topImage, mask and position.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the image is processed in place instead of generating a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mask | Gets or sets the 1-bit image indicating the transparent and opaque regions of the overlay.
Public property | Position | Gets or sets the position of the top image on the bottom image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the top 1-bit image to overlay.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Constructor

Overload List
 | Name | Description
Public method | OverlayMaskedDocumentCommand | Creates a new instance of OverlayMaskedDocumentCommand.
Protected method | OverlayMaskedDocumentCommand(SerializationInfo, StreamingContext) | Creates a new instance of OverlayMaskedDocumentCommand from serialization information.
Public method | OverlayMaskedDocumentCommand(AtalaImage, AtalaImage) | Creates a new instance of OverlayMaskedDocumentCommand specifying topImage and mask.
Public method | OverlayMaskedDocumentCommand(AtalaImage, AtalaImage, Point) | Creates a new instance of OverlayMaskedDocumentCommand specifying topImage, mask and position.
Top
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Constructor

Creates a new instance of OverlayMaskedDocumentCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMaskedDocumentCommand()
Public Sub New
See Also

Reference

OverlayMaskedDocumentCommand Class
OverlayMaskedDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of OverlayMaskedDocumentCommand from serialization information.
Creates a new instance of OverlayMaskedDocumentCommand. Creates a new instance of OverlayMaskedDocumentCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OverlayMaskedDocumentCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

OverlayMaskedDocumentCommand Class
OverlayMaskedDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Constructor (AtalaImage, AtalaImage)

Creates a new instance of OverlayMaskedDocumentCommand specifying topImage and mask.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMaskedDocumentCommand(
    AtalaImage topImage,
    AtalaImage mask
)
Public Sub New (
    topImage As AtalaImage,
    mask As AtalaImage
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The top binary image to overlay.
mask
Type: Atalasoft.ImagingAtalaImage
A binary image indicating the transparent and opaque regions of the overlay.
Exceptions
Exception | Condition
 | Thrown if the topImage or mask is not a 1-bit image.
See Also

Reference

OverlayMaskedDocumentCommand Class
OverlayMaskedDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Constructor (AtalaImage, AtalaImage, Point)

Creates a new instance of OverlayMaskedDocumentCommand specifying topImage, mask and position.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverlayMaskedDocumentCommand(
    AtalaImage topImage,
    AtalaImage mask,
    Point position
)
Public Sub New (
    topImage As AtalaImage,
    mask As AtalaImage,
    position As Point
)

Parameters

topImage
Type: Atalasoft.ImagingAtalaImage
The top binary image to overlay.
mask
Type: Atalasoft.ImagingAtalaImage
A binary image indicating the transparent and opaque regions of the overlay.
position
Type: System.DrawingPoint
The position of the top image on the bottom image.
Exceptions
Exception | Condition
 | Thrown if the topImage or mask is not a 1-bit image.
See Also

Reference

OverlayMaskedDocumentCommand Class
OverlayMaskedDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Properties

The OverlayMaskedDocumentCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the image is processed in place instead of generating a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mask | Gets or sets the 1-bit image indicating the transparent and opaque regions of the overlay.
Public property | Position | Gets or sets the position of the top image on the bottom image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopImage | Gets or sets the top 1-bit image to overlay.
Top
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.InPlaceProcessing Property

OverlayMaskedDocumentCommandInPlaceProcessing Property

Gets a value indicating if the image is processed in place instead of generating a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the image is processed in place instead of generating a new image.
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.Mask Property

OverlayMaskedDocumentCommandMask Property

Gets or sets the 1-bit image indicating the transparent and opaque regions of the overlay.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Mask { get; set; }
Public Property Mask As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The 1-bit image indicating the transparent and opaque regions of the overlay.
Exceptions
Exception | Condition
 | Thrown if the image is not 1 bit black and white.
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.Position Property

OverlayMaskedDocumentCommandPosition Property

Gets or sets the position of the top image on the bottom image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The position of the top image on the bottom image.
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.SupportedPixelFormats Property

OverlayMaskedDocumentCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.TopImage Property

OverlayMaskedDocumentCommandTopImage Property

Gets or sets the top 1-bit image to overlay.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage TopImage { get; set; }
Public Property TopImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The top 1-bit image to overlay.
Exceptions
Exception | Condition
 | Thrown if image is not 1 bit black and white.
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand Methods

The OverlayMaskedDocumentCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | Performs the actual command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.GetObjectData Method

OverlayMaskedDocumentCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with command information.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.PerformActualCommand Method

OverlayMaskedDocumentCommandPerformActualCommand Method

Performs the actual command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage bottomImage,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    bottomImage As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

bottomImage
Type: Atalasoft.ImagingAtalaImage
The bottom image.
dest
Type: Atalasoft.ImagingAtalaImage
The dest.
imageArea
Type: System.DrawingRectangle
The image area.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results.

Return Value

Type: AtalaImage
See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


OverlayMaskedDocumentCommand.VerifyProperties Method

OverlayMaskedDocumentCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | alphaMask must be the same size as the top image.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

OverlayMaskedDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Class

Resamples a binary image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.DocumentResampleDocumentCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ResampleDocumentCommand : ImageCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class ResampleDocumentCommand
    Inherits ImageCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The ResampleDocumentCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ResampleDocumentCommand | Creates a new instance of ResampleDocumentCommand.
Protected method | ResampleDocumentCommand(SerializationInfo, StreamingContext) | Creates a new instance of ResampleDocumentCommand from serialization information.
Public method | ResampleDocumentCommand(Rectangle, Size, ResampleDocumentMethod) | Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize and documentMethod.
Public method | ResampleDocumentCommand(Rectangle, Size, ResampleMethod) | Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize and scaleToGrayMethod.
Public method | ResampleDocumentCommand(Rectangle, Size, ResampleDocumentMethod, Int32) | Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize, documentMethod and cutOff.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CutOff | Gets or sets the grayscale value which is the cutoff value for a black pixel when using AreaAverage.
Public property | DestSize | Gets or sets the final size of the image.
Public property | DocumentMethod | Gets or sets the 1-bit specialized resampling method to apply.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ScaleToGrayMethod | Gets or sets the %ResampleMethod% to apply when the DocumentMethod is ScaleToGray.
Public property | SourceRect | Gets or sets the rectangular region of the source image which will be resized.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command can be used to efficiently perform a "scale to gray" resample on a document image as well as "favor to black" using the AreaAverage method and specifying the cut-off value.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Constructor

Overload List
 | Name | Description
Public method | ResampleDocumentCommand | Creates a new instance of ResampleDocumentCommand.
Protected method | ResampleDocumentCommand(SerializationInfo, StreamingContext) | Creates a new instance of ResampleDocumentCommand from serialization information.
Public method | ResampleDocumentCommand(Rectangle, Size, ResampleDocumentMethod) | Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize and documentMethod.
Public method | ResampleDocumentCommand(Rectangle, Size, ResampleMethod) | Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize and scaleToGrayMethod.
Public method | ResampleDocumentCommand(Rectangle, Size, ResampleDocumentMethod, Int32) | Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize, documentMethod and cutOff.
Top
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Constructor

Creates a new instance of ResampleDocumentCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleDocumentCommand()
Public Sub New
See Also

Reference

ResampleDocumentCommand Class
ResampleDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ResampleDocumentCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ResampleDocumentCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for the command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ResampleDocumentCommand Class
ResampleDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Constructor (Rectangle, Size, ResampleDocumentMethod)

Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize and documentMethod.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleDocumentCommand(
    Rectangle sourceRect,
    Size destSize,
    ResampleDocumentMethod documentMethod
)
Public Sub New (
    sourceRect As Rectangle,
    destSize As Size,
    documentMethod As ResampleDocumentMethod
)

Parameters

sourceRect
Type: System.DrawingRectangle
The rectangular region of the source image which will be resized.
destSize
Type: System.DrawingSize
The final size of the image.
documentMethod
Type: Atalasoft.Imaging.ImageProcessing.DocumentResampleDocumentMethod
The 1-bit specialized resampling method to apply.
Exceptions
Exception | Condition
 | Thrown if destSize width or height is less than 1.
See Also

Reference

ResampleDocumentCommand Class
ResampleDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Constructor (Rectangle, Size, ResampleMethod)

Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize and scaleToGrayMethod.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleDocumentCommand(
    Rectangle sourceRect,
    Size destSize,
    ResampleMethod scaleToGrayMethod
)
Public Sub New (
    sourceRect As Rectangle,
    destSize As Size,
    scaleToGrayMethod As ResampleMethod
)

Parameters

sourceRect
Type: System.DrawingRectangle
The rectangular region of the source image which will be resized.
destSize
Type: System.DrawingSize
The final size of the image.
scaleToGrayMethod
Type: Atalasoft.Imaging.ImageProcessingResampleMethod
The ResampleMethod to apply when the ResampleDocumentMethod is ScaleToGray.
Exceptions
Exception | Condition
 | Thrown if destSize width or height is less than 1.
See Also

Reference

ResampleDocumentCommand Class
ResampleDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Constructor (Rectangle, Size, ResampleDocumentMethod, Int32)

Creates a new instance of ResampleDocumentCommand specifying sourceRect, destSize, documentMethod and cutOff.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleDocumentCommand(
    Rectangle sourceRect,
    Size destSize,
    ResampleDocumentMethod documentMethod,
    int cutOff
)
Public Sub New (
    sourceRect As Rectangle,
    destSize As Size,
    documentMethod As ResampleDocumentMethod,
    cutOff As Integer
)

Parameters

sourceRect
Type: System.DrawingRectangle
The rectangular region of the source image which will be resized.
destSize
Type: System.DrawingSize
The final size of the image.
documentMethod
Type: Atalasoft.Imaging.ImageProcessing.DocumentResampleDocumentMethod
The 1-bit specialized resampling method to apply.
cutOff
Type: SystemInt32
The grayscale value which is the cutoff value for a black pixel when using AreaAverage.
Exceptions
Exception | Condition
 | Thrown if destSize width or height is less than 1, or if cutOff is less than 0.
See Also

Reference

ResampleDocumentCommand Class
ResampleDocumentCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Properties

The ResampleDocumentCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CutOff | Gets or sets the grayscale value which is the cutoff value for a black pixel when using AreaAverage.
Public property | DestSize | Gets or sets the final size of the image.
Public property | DocumentMethod | Gets or sets the 1-bit specialized resampling method to apply.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ScaleToGrayMethod | Gets or sets the %ResampleMethod% to apply when the DocumentMethod is ScaleToGray.
Public property | SourceRect | Gets or sets the rectangular region of the source image which will be resized.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.AutoThread Property

ResampleDocumentCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.CutOff Property

ResampleDocumentCommandCutOff Property

Gets or sets the grayscale value which is the cutoff value for a black pixel when using AreaAverage.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CutOff { get; set; }
Public Property CutOff As Integer
    Get
    Set

Property Value

Type: Int32
The grayscale value which is the cutoff value for a black pixel when using AreaAverage.
Exceptions
Exception | Condition
 | Thrown if value is < 0.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.DestSize Property

ResampleDocumentCommandDestSize Property

Gets or sets the final size of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DestSize { get; set; }
Public Property DestSize As Size
    Get
    Set

Property Value

Type: Size
The final size of the image.
Exceptions
Exception | Condition
 | Thrown if the height or width is amp;lt; 1.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.DocumentMethod Property

ResampleDocumentCommandDocumentMethod Property

Gets or sets the 1-bit specialized resampling method to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleDocumentMethod DocumentMethod { get; set; }
Public Property DocumentMethod As ResampleDocumentMethod
    Get
    Set

Property Value

Type: ResampleDocumentMethod
The 1-bit specialized resampling method to apply.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.ScaleToGrayMethod Property

ResampleDocumentCommandScaleToGrayMethod Property

Gets or sets the %ResampleMethod% to apply when the DocumentMethod is ScaleToGray.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResampleMethod ScaleToGrayMethod { get; set; }
Public Property ScaleToGrayMethod As ResampleMethod
    Get
    Set

Property Value

Type: ResampleMethod
The ResampleMethod to apply when the DocumentMethod is ScaleToGray.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.SourceRect Property

ResampleDocumentCommandSourceRect Property

Gets or sets the rectangular region of the source image which will be resized.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SourceRect { get; set; }
Public Property SourceRect As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular region of the source image which will be resized.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.SupportedPixelFormats Property

ResampleDocumentCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel1bppIndexed
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand Methods

The ResampleDocumentCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.AdjustBands Method

ResampleDocumentCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.Clone Method

ResampleDocumentCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the ResampleDocumentCommand.

Implements

ICloneableClone
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.ConstructFinalImage Method

ResampleDocumentCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.GetObjectData Method

ResampleDocumentCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info;The parameter 'info' can't be null.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.PerformActualCommand Method

ResampleDocumentCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.PerformSectionCommand Method

ResampleDocumentCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentCommand.VerifyProperties Method

ResampleDocumentCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | You must provide a destination size.;destSize or Cannot perform AreaAverage resize method when increasing the size of the image,\nuse BiLinear or the scale to gray default instead. or Cannot perform EnlargeFast resize method when decreasing the size of the image,\nuse BiLinear, AreaAverage, or ScaleToGray instead.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ResampleDocumentCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ResampleDocumentMethod Enumeration

Specifies the resampling method to apply using the ResampleDocumentCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResampleDocumentMethod
Public Enumeration ResampleDocumentMethod
Members
Member name | Description
BiLinear | Uses bi-linear resampling. Yields good results when enlarging images, and fairly fast. Not"e: This was previously incorrectly named NearestNeighbor.
ScaleToGray | Converts the 1-bit binary image to grayscale as it resizes which retains the visual detail of the image.
AreaAverage | Performs an area average of the binary image with a specified "cut-off" factor that will favor black or white pixels. Valid for reductions only.
EnlargeFast | Performs a quick pixel mapping when enlarging speed is more important than quality.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


RunSpeed Enumeration

Defines the speed of processing at the expense of quality

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RunSpeed
Public Enumeration RunSpeed
Members
Member name | Description
Normal | No sampling performed.
Fast | Image is sampled by 1/2 for analysis.
Faster | Image is sampled by 1/4 for analysis.
Fastest | Image is sampled by 1/8 for analysis.
Remarks
Heuristically speaking, Fast and Faster option enhance speed 4 and 16 times compared to Normal, respectively.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Class

This class is designed to store spatial and qualitative information of the results of the document image segmentation algorithm for document images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.DocumentSegment

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Segment : ISerializable, ICloneable
<SerializableAttribute>
Public Class Segment
    Implements ISerializable, ICloneable

The Segment type exposes the following members.

Constructors
 | Name | Description
Public method | Segment | Initializes a new instance of the Segment class
Public method | Segment(SerializationInfo, StreamingContext) | Initializes a new instance of the Segment class
Public method | Segment(Geometry, SegmentType) | Initializes a new instance of the Segment class
Top
Properties
 | Name | Description
Public property | Regions |
Public property | RegionType |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Constructor

Overload List
 | Name | Description
Public method | Segment | Initializes a new instance of the Segment class
Public method | Segment(SerializationInfo, StreamingContext) | Initializes a new instance of the Segment class
Public method | Segment(Geometry, SegmentType) | Initializes a new instance of the Segment class
Top
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Constructor

Initializes a new instance of the Segment class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Segment()
Public Sub New
See Also

Reference

Segment Class
Segment Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Segment class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Segment(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

Segment Class
Segment Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Constructor (Geometry, SegmentType)

Initializes a new instance of the Segment class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Segment(
    Geometry regions,
    SegmentType sType
)
Public Sub New (
    regions As Geometry,
    sType As SegmentType
)

Parameters

regions
Type: Atalasoft.Imaging.ImageProcessing.DocumentGeometry
sType
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegmentType
See Also

Reference

Segment Class
Segment Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Properties

The Segment type exposes the following members.

Properties
 | Name | Description
Public property | Regions |
Public property | RegionType |
Top
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment.Regions Property

SegmentRegions Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Geometry Regions { get; set; }
Public Overridable Property Regions As Geometry
    Get
    Set

Property Value

Type: Geometry
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment.RegionType Property

SegmentRegionType Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual SegmentType RegionType { get; set; }
Public Overridable Property RegionType As SegmentType
    Get
    Set

Property Value

Type: SegmentType
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment Methods

The Segment type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment.Clone Method

SegmentClone Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment.GetClonedObject Method

SegmentGetClonedObject Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Segment GetClonedObject()
Protected Overridable Function GetClonedObject As Segment

Return Value

Type: Segment
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


Segment.GetObjectData Method

SegmentGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Segment Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentSegmentationCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SegmentationCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class SegmentationCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The SegmentationCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentationCommand | Initializes a new instance of the SegmentationCommand class
Protected method | SegmentationCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the SegmentationCommand class
Top
Properties
 | Name | Description
Public property | AdjustedSegmentingThreshold |
Public property | AdjustSegmentedRegion |
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AreasToIdentify |
Public property | AreasToIgnore |
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise |
Public property | DenoiseFilterSize |
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxSegmentedRegions |
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SegmentingThreshold |
Public property | SegmentOnly |
Public property | SpeedFactor |
Public property | SupportedPixelFormats | (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSegmentsLocated |
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Events
 | Name | Description
Public event | SegmentsLocated |
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Constructor

Overload List
 | Name | Description
Public method | SegmentationCommand | Initializes a new instance of the SegmentationCommand class
Protected method | SegmentationCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the SegmentationCommand class
Top
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Constructor

Initializes a new instance of the SegmentationCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentationCommand()
Public Sub New
See Also

Reference

SegmentationCommand Class
SegmentationCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SegmentationCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SegmentationCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

SegmentationCommand Class
SegmentationCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Properties

The SegmentationCommand type exposes the following members.

Properties
 | Name | Description
Public property | AdjustedSegmentingThreshold |
Public property | AdjustSegmentedRegion |
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AreasToIdentify |
Public property | AreasToIgnore |
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Denoise |
Public property | DenoiseFilterSize |
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxSegmentedRegions |
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SegmentingThreshold |
Public property | SegmentOnly |
Public property | SpeedFactor |
Public property | SupportedPixelFormats | (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.AdjustedSegmentingThreshold Property

SegmentationCommandAdjustedSegmentingThreshold Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int AdjustedSegmentingThreshold { get; set; }
Public Overridable Property AdjustedSegmentingThreshold As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.AdjustSegmentedRegion Property

SegmentationCommandAdjustSegmentedRegion Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool AdjustSegmentedRegion { get; set; }
Public Overridable Property AdjustSegmentedRegion As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.AreasToIdentify Property

SegmentationCommandAreasToIdentify Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual SegmentCollection AreasToIdentify { get; set; }
Public Overridable Property AreasToIdentify As SegmentCollection
    Get
    Set

Property Value

Type: SegmentCollection
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.AreasToIgnore Property

SegmentationCommandAreasToIgnore Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual SegmentCollection AreasToIgnore { get; set; }
Public Overridable Property AreasToIgnore As SegmentCollection
    Get
    Set

Property Value

Type: SegmentCollection
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.Denoise Property

SegmentationCommandDenoise Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Denoise { get; set; }
Public Overridable Property Denoise As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.DenoiseFilterSize Property

SegmentationCommandDenoiseFilterSize Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int DenoiseFilterSize { get; set; }
Public Overridable Property DenoiseFilterSize As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.MaxSegmentedRegions Property

SegmentationCommandMaxSegmentedRegions Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int MaxSegmentedRegions { get; set; }
Public Overridable Property MaxSegmentedRegions As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.SegmentingThreshold Property

SegmentationCommandSegmentingThreshold Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int SegmentingThreshold { get; set; }
Public Overridable Property SegmentingThreshold As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.SegmentOnly Property

SegmentationCommandSegmentOnly Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool SegmentOnly { get; set; }
Public Overridable Property SegmentOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.SpeedFactor Property

SegmentationCommandSpeedFactor Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.SupportedPixelFormats Property

SegmentationCommandSupportedPixelFormats Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Methods

The SegmentationCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | (Overrides ImageCommandConstructImageResults.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSegmentsLocated |
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.ConstructFinalImage Method

SegmentationCommandConstructFinalImage Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.ConstructImageResults Method

SegmentationCommandConstructImageResults Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageResults ConstructImageResults()
Protected Overrides Function ConstructImageResults As ImageResults

Return Value

Type: ImageResults
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.GetObjectData Method

SegmentationCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.OnSegmentsLocated Method

SegmentationCommandOnSegmentsLocated Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSegmentsLocated(
    SegmentsLocatedEventArgs e
)
Protected Overridable Sub OnSegmentsLocated (
    e As SegmentsLocatedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegmentsLocatedEventArgs
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.PerformActualCommand Method

SegmentationCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.VerifyProperties Method

SegmentationCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand Events

The SegmentationCommand type exposes the following members.

Events
 | Name | Description
Public event | SegmentsLocated |
Top
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationCommand.SegmentsLocated Event

SegmentationCommandSegmentsLocated Event

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OnSegmentsLocatedEventHandler SegmentsLocated
Public Event SegmentsLocated As OnSegmentsLocatedEventHandler

Value

Type: Atalasoft.Imaging.ImageProcessing.DocumentOnSegmentsLocatedEventHandler
See Also

Reference

SegmentationCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageResults
Atalasoft.Imaging.ImageProcessing.DocumentSegmentationResults

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SegmentationResults : ImageResults
Public Class SegmentationResults
    Inherits ImageResults

The SegmentationResults type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentationResults | Initializes a new instance of the SegmentationResults class
Public method | SegmentationResults(SegmentCollection) | Initializes a new instance of the SegmentationResults class
Top
Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | Segments |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults Constructor

Overload List
 | Name | Description
Public method | SegmentationResults | Initializes a new instance of the SegmentationResults class
Public method | SegmentationResults(SegmentCollection) | Initializes a new instance of the SegmentationResults class
Top
See Also

Reference

SegmentationResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults Constructor

Initializes a new instance of the SegmentationResults class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentationResults()
Public Sub New
See Also

Reference

SegmentationResults Class
SegmentationResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults Constructor (SegmentCollection)

Initializes a new instance of the SegmentationResults class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentationResults(
    SegmentCollection segments
)
Public Sub New (
    segments As SegmentCollection
)

Parameters

segments
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegmentCollection
See Also

Reference

SegmentationResults Class
SegmentationResults Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults Properties

The SegmentationResults type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that was the result of processing (Inherited from ImageResults.)
Public property | IsImageSourceImage | An indicator as to whether or not image is the same AtalaImage as the original image. (Inherited from ImageResults.)
Public property | Segments |
Top
See Also

Reference

SegmentationResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults.Segments Property

SegmentationResultsSegments Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual SegmentCollection Segments { get; set; }
Public Overridable Property Segments As SegmentCollection
    Get
    Set

Property Value

Type: SegmentCollection
See Also

Reference

SegmentationResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentationResults Methods

The SegmentationResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SegmentationResults Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection Class

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.ImageProcessing.DocumentSegmentCollection

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SegmentCollection : CollectionBase,
    ISerializable, ICloneable
<SerializableAttribute>
Public Class SegmentCollection
    Inherits CollectionBase
    Implements ISerializable, ICloneable

The SegmentCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentCollection | Initializes a new instance of the SegmentCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection Constructor

Initializes a new instance of the SegmentCollection class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentCollection()
Public Sub New
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection Properties

The SegmentCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item |
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.Item Property

SegmentCollectionItem Property

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: Object
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection Methods

The SegmentCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Clone |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetClonedObject |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.Add Method

SegmentCollectionAdd Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Add(
    Segment item
)
Public Overridable Sub Add (
    item As Segment
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegment
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.AddRange Method

SegmentCollectionAddRange Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void AddRange(
    SegmentCollection item,
    int startIndex,
    int endIndex
)
Public Overridable Sub AddRange (
    item As SegmentCollection,
    startIndex As Integer,
    endIndex As Integer
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegmentCollection
startIndex
Type: SystemInt32
endIndex
Type: SystemInt32
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.Clone Method

SegmentCollectionClone Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.Contains Method

SegmentCollectionContains Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool Contains(
    Segment item
)
Public Overridable Function Contains (
    item As Segment
) As Boolean

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegment

Return Value

Type: Boolean
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.CopyTo Method

SegmentCollectionCopyTo Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void CopyTo(
    Segment[] dest,
    int index
)
Public Overridable Sub CopyTo (
    dest As Segment(),
    index As Integer
)

Parameters

dest
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegment
index
Type: SystemInt32
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.GetClonedObject Method

SegmentCollectionGetClonedObject Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual SegmentCollection GetClonedObject()
Protected Overridable Function GetClonedObject As SegmentCollection

Return Value

Type: SegmentCollection
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.GetObjectData Method

SegmentCollectionGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.IndexOf Method

SegmentCollectionIndexOf Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int IndexOf(
    Segment item
)
Public Overridable Function IndexOf (
    item As Segment
) As Integer

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegment

Return Value

Type: Int32
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.Insert Method

SegmentCollectionInsert Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    Segment item
)
Public Overridable Sub Insert (
    index As Integer,
    item As Segment
)

Parameters

index
Type: SystemInt32
item
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegment
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentCollection.Remove Method

SegmentCollectionRemove Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Remove(
    Segment item
)
Public Overridable Sub Remove (
    item As Segment
)

Parameters

item
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegment
See Also

Reference

SegmentCollection Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.ImageProcessing.DocumentSegmentsLocatedEventArgs

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SegmentsLocatedEventArgs : EventArgs
Public Class SegmentsLocatedEventArgs
    Inherits EventArgs

The SegmentsLocatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentsLocatedEventArgs | Initializes a new instance of the SegmentsLocatedEventArgs class
Public method | SegmentsLocatedEventArgs(SegmentCollection) | Initializes a new instance of the SegmentsLocatedEventArgs class
Top
Properties
 | Name | Description
Public property | SegmentsIn | All the segments that have been identified
Public property | SegmentsOut | Gets or sets the segments which will be identified
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs Constructor

Overload List
 | Name | Description
Public method | SegmentsLocatedEventArgs | Initializes a new instance of the SegmentsLocatedEventArgs class
Public method | SegmentsLocatedEventArgs(SegmentCollection) | Initializes a new instance of the SegmentsLocatedEventArgs class
Top
See Also

Reference

SegmentsLocatedEventArgs Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs Constructor

Initializes a new instance of the SegmentsLocatedEventArgs class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentsLocatedEventArgs()
Public Sub New
See Also

Reference

SegmentsLocatedEventArgs Class
SegmentsLocatedEventArgs Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs Constructor (SegmentCollection)

Initializes a new instance of the SegmentsLocatedEventArgs class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentsLocatedEventArgs(
    SegmentCollection segmentsIn
)
Public Sub New (
    segmentsIn As SegmentCollection
)

Parameters

segmentsIn
Type: Atalasoft.Imaging.ImageProcessing.DocumentSegmentCollection
See Also

Reference

SegmentsLocatedEventArgs Class
SegmentsLocatedEventArgs Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs Properties

The SegmentsLocatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SegmentsIn | All the segments that have been identified
Public property | SegmentsOut | Gets or sets the segments which will be identified
Top
See Also

Reference

SegmentsLocatedEventArgs Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs.SegmentsIn Property

SegmentsLocatedEventArgsSegmentsIn Property

All the segments that have been identified

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual SegmentCollection SegmentsIn { get; }
Public Overridable ReadOnly Property SegmentsIn As SegmentCollection
    Get

Property Value

Type: SegmentCollection
See Also

Reference

SegmentsLocatedEventArgs Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs.SegmentsOut Property

SegmentsLocatedEventArgsSegmentsOut Property

Gets or sets the segments which will be identified

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual SegmentCollection SegmentsOut { get; set; }
Public Overridable Property SegmentsOut As SegmentCollection
    Get
    Set

Property Value

Type: SegmentCollection
See Also

Reference

SegmentsLocatedEventArgs Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentsLocatedEventArgs Methods

The SegmentsLocatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SegmentsLocatedEventArgs Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SegmentType Enumeration

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SegmentType
Public Enumeration SegmentType
Members
Member name | Description
None |
Unknown |
Text |
Image |
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand Class

This command converts a continuous RGB or grayscale image to a 1-bit black and white image, given a threshold value.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentSimpleThresholdCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SimpleThresholdCommand : ImageRegionCommand,
    IThreadableCommand, ICloneable
Public Class SimpleThresholdCommand
    Inherits ImageRegionCommand
    Implements IThreadableCommand, ICloneable

The SimpleThresholdCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleThresholdCommand | Creates a new instance of SimpleThresholdCommand.
Public method | SimpleThresholdCommand(Int32) | Creates a new instance of SimpleThresholdCommand indicating the threshold value.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | InputThreshold | Gets or sets the threshold value.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ImageRegionCommand.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
SimpleThresholdCommand can result in considerably better performance over the GetChangedPixelFormat(PixelFormat) method in AtalaImage or ApplyPaletteCommand when converting color or grayscale images to black and white. however the quality of the conversion can vary, and offers no dithering.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand Constructor

Creates a new instance of SimpleThresholdCommand.
Overload List
 | Name | Description
Public method | SimpleThresholdCommand | Creates a new instance of SimpleThresholdCommand.
Public method | SimpleThresholdCommand(Int32) | Creates a new instance of SimpleThresholdCommand indicating the threshold value.
Top
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand Constructor

Creates a new instance of SimpleThresholdCommand.
Creates a new instance of SimpleThresholdCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SimpleThresholdCommand()
Public Sub New
See Also

Reference

SimpleThresholdCommand Class
SimpleThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand Constructor (Int32)

Creates a new instance of SimpleThresholdCommand indicating the threshold value.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SimpleThresholdCommand(
    int inputThreshold
)
Public Sub New (
    inputThreshold As Integer
)

Parameters

inputThreshold
Type: SystemInt32
The threshold value.
Exceptions
Exception | Condition
 | Thrown if inputThreshold is not between 0 and 255 inclusive.
See Also

Reference

SimpleThresholdCommand Class
SimpleThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand Properties

The SimpleThresholdCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | InputThreshold | Gets or sets the threshold value.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.AutoThread Property

SimpleThresholdCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.InputThreshold Property

SimpleThresholdCommandInputThreshold Property

Gets or sets the threshold value.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InputThreshold { get; set; }
Public Property InputThreshold As Integer
    Get
    Set

Property Value

Type: Int32
The threshold value.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255 inclusive.
Remarks
This is the value from 0 - 255 of which any pixel that with a brightness greater then the value will be converted to white, and any pixel with a brightness less than this value will be converted to black. Default value is 127.
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.SupportedPixelFormats Property

SimpleThresholdCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand Methods

The SimpleThresholdCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ImageRegionCommand.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.AdjustBands Method

SimpleThresholdCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.Clone Method

SimpleThresholdCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the SimpleThresholdCommand.

Implements

ICloneableClone
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.ConstructFinalImage Method

SimpleThresholdCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.PerformActualCommand Method

SimpleThresholdCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.PerformSectionCommand Method

SimpleThresholdCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.SelectPreferredPixelFormat Method

SimpleThresholdCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SimpleThresholdCommand.VerifyProperties Method

SimpleThresholdCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SimpleThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand Class

Removes specks of a specified size from a bi-tonal image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.DocumentSpeckRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SpeckRemovalCommand : ImageRegionCommand,
    IProcessSpeedConfig, ISerializable
<SerializableAttribute>
Public Class SpeckRemovalCommand
    Inherits ImageRegionCommand
    Implements IProcessSpeedConfig, ISerializable

The SpeckRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SpeckRemovalCommand | Creates a new instance of SpeckRemovalCommand.
Protected method | SpeckRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the SpeckRemovalCommand class
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxObjectSize | The maximum speck size that will be removed.
Public property | MinObjectSize | The minimum speck size that will be removed.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Examples
[New Example] (C#)
Copy
SpeckRemovalCommand cmd = new SpeckRemovalCommand();
cmd.MaxObjectSize = new Size(3, 3);
ImageResults results = cmd.Apply(sourceImage);
AtalaImage newImage = results.Image;
if (!results.IsImageSourceImage)
  sourceImage.Dispose(); //free memory
[New Example] (Visual Basic)
Copy
Dim cmd As SpeckRemovalCommand =  New SpeckRemovalCommand()
cmd.MaxObjectSize = New Size(3, 3)
Dim results As ImageResults =  cmd.Apply(sourceImage)
Dim NewImage As AtalaImage =  results.Image
If Not results.IsImageSourceImage Then
  sourceImage.Dispose() 'free memory
End If
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand Constructor

Overload List
 | Name | Description
Public method | SpeckRemovalCommand | Creates a new instance of SpeckRemovalCommand.
Protected method | SpeckRemovalCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the SpeckRemovalCommand class
Top
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand Constructor

Creates a new instance of SpeckRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpeckRemovalCommand()
Public Sub New
See Also

Reference

SpeckRemovalCommand Class
SpeckRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SpeckRemovalCommand class

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SpeckRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

SpeckRemovalCommand Class
SpeckRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand Properties

The SpeckRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxObjectSize | The maximum speck size that will be removed.
Public property | MinObjectSize | The minimum speck size that will be removed.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SpeedFactor | Determines the sample size of the image to process, affecting quality and speed.
Public property | SupportedPixelFormats | Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.MaxObjectSize Property

SpeckRemovalCommandMaxObjectSize Property

The maximum speck size that will be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MaxObjectSize { get; set; }
Public Overridable Property MaxObjectSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is (5, 5).
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.MinObjectSize Property

SpeckRemovalCommandMinObjectSize Property

The minimum speck size that will be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Size MinObjectSize { get; set; }
Public Overridable Property MinObjectSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Default value is (0, 0).
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.SpeedFactor Property

SpeckRemovalCommandSpeedFactor Property

Determines the sample size of the image to process, affecting quality and speed.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual RunSpeed SpeedFactor { get; set; }
Public Overridable Property SpeedFactor As RunSpeed
    Get
    Set

Property Value

Type: RunSpeed

Implements

IProcessSpeedConfigSpeedFactor
Remarks
This algorithm will resample the source image by 1 (Normal), 1/2 (Fast), 1/4 (Faster), or 1/8 (Fastest) prior to object detection. This setting can can heavily influence performance, sometimes at the expense of quality. Default value is Normal.
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.SupportedPixelFormats Property

SpeckRemovalCommandSupportedPixelFormats Property

Gets a list of PixelFormats that this command will support without throwing an exception. This command supports Pixel1bppIndexed only.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand Methods

The SpeckRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.GetObjectData Method

SpeckRemovalCommandGetObjectData Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.PerformActualCommand Method

SpeckRemovalCommandPerformActualCommand Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
results
Type: Atalasoft.Imaging.ImageProcessingImageResults

Return Value

Type: AtalaImage
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


SpeckRemovalCommand.VerifyProperties Method

SpeckRemovalCommandVerifyProperties Method

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage.AdvancedDocClean (in Atalasoft.dotImage.AdvancedDocClean.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

SpeckRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Document Namespace


ThresholdMethod Enumeration

Thresholding Method.

Namespace: Atalasoft.Imaging.ImageProcessing.Document
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ThresholdMethod
Public Enumeration ThresholdMethod
Members
Member name | Description
Simple | Simple Thresholding
Global | Global Thresholding
Adaptive | Adaptive Thresholding
Remarks
Used in DocumentPixelFormatChanger.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Document Namespace


Atalasoft.Imaging.ImageProcessing.Effects Namespace

Namespace where all Advanced Photo Effect classes are located.
Classes
Class Description
Public class AdjustTintCommand

Adjusts the tint of an image by specifying a value.

Public class AdvancedLevelsCommand
Corrects the tonal range and color balance by adjusting the shadow, midtone, and highlights of an image.
Public class AutoColorCommand
Automatically corrects the color and contrast of an image. A combination of AutoLevelsCommand and AutoContrastCommand.
Public class AutoContrastCommand
Adjusts the overall contrast of an image automatically.
Public class AutoLevelsCommand
Enhances the contrast of an image by automatically defining the light and dark pixels, then redistributing the histogram proportionately.
Public class AutoWhiteBalanceCommand
Automatically adjusts the white point in an image.
BevelEdgeCommand

Apply a bevel effect to the edges of an image.

Public class BrightnessContrastCommand
Modifies the brightness and/or contrast of an image.
Public class BrightnessHistogramEqualizeCommand
Perform histogram equalization on an image while preventing colors from shifting.
Public class BrightnessHistogramStretchCommand
Performs a histogram stretch on an image while preventing colors from shifting.
Public class CrackleCommand

Generates an image which looks like a cracked ceramic glaze.

CurvesCommand

Applies a color curve to an image, similar to the Photoshop Curves method.

The curves are defined by an array of one or more objects.

Public class DeInterlaceCommand

This command will de-interlace an image.

Public class DropShadowCommand
Apply a drop shadow behind the image.
Public class DuotoneCommand
The DuotoneCommand processes an image from its current color space into a two color space.
Public class FingerprintCommand
Creates an effect which looks like fingerprint smuges on the image.
FloodFillCommand
Performs a flood fill on an image. You can use it to fill an area of an image surrounded by FillColor by setting Mode to Edge, or you can fill the pixel color at Position with FillColor.
Public class GammaCommand
Increases or decreases the gamma value of an image.
Public class GauzyCommand
Generate a soft focus, gauzed image.
Public class HalftoneCommand
Generates a black and white image dithered to "halftone" dots.
Public class HistogramEqualizeCommand
Performs histogram equalization on an image.
Public class HistogramStretchCommand
Performs a histogram stretch on an image.
Public class LevelsCommand
Corrects the tonal range and color balance by adjusting the shadow, midtone, and highlights of an image.
MosaicCommand

Generate a mosaic (large pixel) image.

Public class MotionBlurCommand
Create an effect to simulate motion blur on an image
Public class NDGradFilterCommand
Neutral Density (ND) Graduated Filter, Flexible in Location, Hardness and Density.

ND filters are used by photographers to compress the dynamic range of high contrast scenes into a smaller range which can be better viewed or printed. These filters feature a 'dark' half and a clear half, with the transition either soft or hard depending on the effect desired. The dark half is typically either 2 or 3 "f-stops" darker. Multiple filters can be applied to achieve a greater or more complex effect.

A typical use for an ND filter is to darken the bright skies in an image to bring its tonal values more in line with those of the darker foreground. Sunrises, sunsets, horizon shots, canyons and other contrasty landscapes are good candidates for an ND filter.

The PhotoEffects ND Graduated is incredibly flexible, allowing you to adjust where in the image you want the effect applied (using the Location property), how dramatic you want the effect (using the Density parameter), how hard or soft you want the transition (using the Hardness property), how large an area you want the effect portion of the filter to cover (using the Radius property), and the angle at which you want the effect (using the Angle property). Angled effects are important if you have a diagonal sun/shade line or other non-horizontal dark/light division in your image.

The PhotoEffects ND filter can even provide "impossible" effects by allowing you to set the density of the "light" side of the filter. With traditional filters this is always transparent (a value of 1) but with the PhotoEffects filter you can set the starting density to be brighter or darker.

Public class OilPaintCommand
This effect makes an image appear as if it's an oil painting.
Public class PhotoColorCoolerCommand
Makes an image appear cooler by adding blue and reducing red without affecting the overall tone or contrast of the image. This is similar to correcting the White Balance setting on a digital camera. The amount of cooling is controlled using the Effect parameter.

By default the command cools by about 20% (1.2), which is the equivalent at daylight color temperatures of about 800-1000 degrees of color temperature.

Public class PhotoColorCorrectCommand
Allows color correction by enhancing or reducing specific colors without affecting image tone.

Specifically, Red, Green, Blue and Yellow can be enhanced or reduced by setting the corresponding effects properties to values >1 for enhancing and <1 for reducing. In all cases the overall tone and contrast of the image is preserved and only the color component of the image is altered.

This command is excellent for removing specific color casts or creating a slightly different effect in an image by changing the relative balance of colors.

It can also be used as a customized color enhancement filter by manually setting the values of the 4 color effect properties to increase the overall color of the image. This is similar to the underlying component of the Automatic Color Correction filters.

Public class PhotoColorCorrectCommandBase
Base class for photo color correction filters.
Public class PhotoColorMagicCommand
PhotoEffects Color Magic is an Automated or semi-Automated Color Enhancement filter. It features a Proprietary Algorithm for improving the existing colors in most digital images.
Public class PhotoColorMultiplyCommand
ColorMultiply uses a proprietary algorithm to uniformly enhance the color components of an image without changing the overall color balance of the image or affecting the tones and tonal distribution.

By controlling the Multiple property you can determine the amount of the effect. 1 is no effect, values of 2 to 3 are more useful and values of 5 and above are fairly extreme.

Note that this command is not "intelligent" so using it on an image which already has saturated colors will result in a somewhat garish look. If you want to more safely correct images or use a color correction in batch mode then use the Color Magic command.

Public class PhotoColorWarmerCommand
Makes an image appear 'warmer' by adding red and reducing blue, without affecting the overall tone or contrast of the image. This is similar to correcting the White Balance setting on a digital camera. The amount of warming is controlled using the Effect parameter.

By default the command warms by about 20% (1.2), which is the equivalent at daylight color temperatures of about 1000-1500 degrees of color temperature.

Public class PhotoPortraitCommand
Enhance Portraits Authored by David Cardinal
Public class PhotoShadowBoostCommand
Boost Visibility of Shadows. Authored by David Cardinal
Public class PhotoSkinTonesCommand
Enhance Skin Tones Authored by David Cardinal
Public class PosterizeCommand
Generate an image made up of primary and secondary colors of the source image.
Public class RedEyeRemovalCommand
Attempts to eliminate "red-eye" from a region of an RGB image.
Public class ReduceColorsCommand
Use this command to convert an image into an 8-bit indexed image with a specified number of colors.
Public class ReplaceColorCommand
Replaces a color in an image with another using the specified color tolerance.
Public class RoundedBevelCommand
Create an artistic embossing of an image.
Public class SaturationCommand
Modify the saturation levels of an image.
Public class ScribbleCommand
Generate an image that looks like it was drawn with paint and a heavy outline pen.
Public class SolarizeCommand

Use this command to adjust the curves to generate a classic "solarize" effect.

Public class StippleCommand

This command generates a bumped image effect.

Public class TintGrayscaleCommand

Converts a grayscale image into a RGB or RGBA image and applies a color tint in the same process.

Public class WatercolorTintCommand
This command modifies an image to appear as if it was drawn using watercolors.
Structures
 | Structure | Description
Public structure | GammaColor | This structure is used with WatercolorTintCommand to specify the gamma levels used during the command process.
Enumerations
 | Enumeration | Description
Public enumeration | BrightnessContrastCurveType | Indicates the curve type used in the BrightnessContrastCommand.
Public enumeration | CrackleMode | Specifies the crackle mode to use in the CrackleCommand.
Public enumeration | DeInterlaceMergeMethod | Specifies the merge method used by DeInterlaceCommand when the Merge method is used.
Public enumeration | DeInterlaceMethod | Specifies the method used by the DeInterlaceCommand.
Public enumeration | DeInterlaceRetention | Specifies the retention used in DeInterlaceCommand when DeInterlaceMethod or DeInterlaceMethod methods are used.
Public enumeration | GauzyMode | Indicates the type of effect to apply in the GauzyCommand.
Public enumeration | MotionBlurMode | Defines the manner of blur for the MotionBlurCommand
Public enumeration | NDGradFilterCommandFilterOfType | Type of the Neutral Density Graduated filter.
Public enumeration | ScribbleMode | Indicates the type of blurring to use on the ScribbleCommand.
Public enumeration | StippleFilterType | Indicates the type of blurring to use in the StippleCommand.
Public enumeration | StippleMode | Indicates how to process the image in the StippleCommand.
Public enumeration | WatercolorTintMode | Specifies the tint mode for WatercolorTintCommand.


AdjustTintCommand Class

Adjusts the tint of an image by specifying a value.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsAdjustTintCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdjustTintCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class AdjustTintCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The AdjustTintCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdjustTintCommand | Creates a new instance of AdjustTintCommand.
Public method | AdjustTintCommand(Int32) | Creates a new instance of AdjustTintCommand specifying the tint value.
Protected method | AdjustTintCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdjustTintCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tint | Gets or sets a value from -180 to +180. Positive values enhance green, negative values enhance red.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires an RGB or RGBA image. It will throw the ArgumentException if it is not RGB or RGBA
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
MosaicCommand Example


AdjustTintCommand Constructor

Overload List
 | Name | Description
Public method | AdjustTintCommand | Creates a new instance of AdjustTintCommand.
Public method | AdjustTintCommand(Int32) | Creates a new instance of AdjustTintCommand specifying the tint value.
Protected method | AdjustTintCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdjustTintCommand from serialization information.
Top
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand Constructor

Creates a new instance of AdjustTintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustTintCommand()
Public Sub New
See Also

Reference

AdjustTintCommand Class
AdjustTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand Constructor (Int32)

Creates a new instance of AdjustTintCommand specifying the tint value.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdjustTintCommand(
    int tint
)
Public Sub New (
    tint As Integer
)

Parameters

tint
Type: SystemInt32
A value from -180 to +180. Positive values enhance green, negative values enhance red.
See Also

Reference

AdjustTintCommand Class
AdjustTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AdjustTintCommand from serialization information.
Creates a new instance of AdjustTintCommand specifying tint. Creates a new instance of AdjustTintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdjustTintCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for the information.
Exceptions
Exception | Condition
 | Thrown if the 'info' argument is null (Nothing in VB).
See Also

Reference

AdjustTintCommand Class
AdjustTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand Properties

The AdjustTintCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tint | Gets or sets a value from -180 to +180. Positive values enhance green, negative values enhance red.
Top
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.AutoThread Property

AdjustTintCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.InPlaceProcessing Property

AdjustTintCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.SupportedPixelFormats Property

AdjustTintCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

PixelFormat.Pixel24bppBgr, ,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra

See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.Tint Property

AdjustTintCommandTint Property

Gets or sets a value from -180 to +180. Positive values enhance green, negative values enhance red.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Tint { get; set; }
Public Property Tint As Integer
    Get
    Set

Property Value

Type: Int32
A value from -180 to +180. Positive values enhance green, negative values enhance red.
Exceptions
Exception | Condition
 | Thrown if value is not between -180 and 180.
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand Methods

The AdjustTintCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.AdjustBands Method

AdjustTintCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.Clone Method

AdjustTintCommandClone Method

Creates a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the AdjustTintCommand.

Implements

ICloneableClone
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.GetObjectData Method

AdjustTintCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object data will be filled into.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.PerformActualCommand Method

AdjustTintCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.PerformSectionCommand Method

AdjustTintCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdjustTintCommand.VerifyProperties Method

AdjustTintCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AdjustTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Class

Corrects the tonal range and color balance by adjusting the shadow, midtone, and highlights of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsAdvancedLevelsCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdvancedLevelsCommand : ApplyLutCommandBase
<SerializableAttribute>
Public Class AdvancedLevelsCommand
    Inherits ApplyLutCommandBase

The AdvancedLevelsCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedLevelsCommand | Initializes a new instance of the AdvancedLevelsCommand class.
Protected method | AdvancedLevelsCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AdvancedLevelsCommand class with serialized data.
Public method | AdvancedLevelsCommand(Color, Color, Color, Color) | Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, highlight, low and high output range colors.
Public method | AdvancedLevelsCommand(Color, Color, Color, Color, GammaColor) | Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, highlight low and high output range colors, and gamma.
Public method | AdvancedLevelsCommand(Color, Color, Color, Color, Color) | Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, midtone, highlight, low and high output range colors.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter. Default GammaColor.Default.
Public property | HighlightColor | Gets or sets the white point in the image used as an input clipping point. Default Color.White.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | MidtoneColor | Gets or sets the gray point in the image used as a gamma adjustment. Gamma is used by default.
Public property | OutputRangeHigh | Gets or sets the light color value to stretch the histogram to. Default Color.White.
Public property | OutputRangeLow | Gets or sets the dark color value to stretch the histogram to. Default Color.Black.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | ShadowColor | Gets or sets the black point in the image used as an input clipping point. Default Color.Black.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHighThreshold | Calculates the high threshold value.
 | GetLowThreshold | Calculates the low threshold value.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
Remarks
The shadow, midtone, and highlights are often manually determined from an "eyedropper" tool.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Constructor

Overload List
 | Name | Description
Public method | AdvancedLevelsCommand | Initializes a new instance of the AdvancedLevelsCommand class.
Protected method | AdvancedLevelsCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the AdvancedLevelsCommand class with serialized data.
Public method | AdvancedLevelsCommand(Color, Color, Color, Color) | Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, highlight, low and high output range colors.
Public method | AdvancedLevelsCommand(Color, Color, Color, Color, GammaColor) | Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, highlight low and high output range colors, and gamma.
Public method | AdvancedLevelsCommand(Color, Color, Color, Color, Color) | Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, midtone, highlight, low and high output range colors.
Top
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Constructor

Initializes a new instance of the AdvancedLevelsCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedLevelsCommand()
Public Sub New
See Also

Reference

AdvancedLevelsCommand Class
AdvancedLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AdvancedLevelsCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdvancedLevelsCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

AdvancedLevelsCommand Class
AdvancedLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Constructor (Color, Color, Color, Color)

Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, highlight, low and high output range colors.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedLevelsCommand(
    Color shadowColor,
    Color highlightColor,
    Color outputRangeLow,
    Color outputRangeHigh
)
Public Sub New (
    shadowColor As Color,
    highlightColor As Color,
    outputRangeLow As Color,
    outputRangeHigh As Color
)

Parameters

shadowColor
Type: System.DrawingColor
Color of the shadow.
highlightColor
Type: System.DrawingColor
Color of the highlight.
outputRangeLow
Type: System.DrawingColor
Low output range color.
outputRangeHigh
Type: System.DrawingColor
High output range color.
See Also

Reference

AdvancedLevelsCommand Class
AdvancedLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Constructor (Color, Color, Color, Color, GammaColor)

Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, highlight low and high output range colors, and gamma.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedLevelsCommand(
    Color shadowColor,
    Color highlightColor,
    Color outputRangeLow,
    Color outputRangeHigh,
    GammaColor gamma
)
Public Sub New (
    shadowColor As Color,
    highlightColor As Color,
    outputRangeLow As Color,
    outputRangeHigh As Color,
    gamma As GammaColor
)

Parameters

shadowColor
Type: System.DrawingColor
Color of the shadow.
highlightColor
Type: System.DrawingColor
Color of the highlight.
outputRangeLow
Type: System.DrawingColor
Low output range color.
outputRangeHigh
Type: System.DrawingColor
High output range color.
gamma
Type: Atalasoft.Imaging.ImageProcessing.EffectsGammaColor
The gamma.
See Also

Reference

AdvancedLevelsCommand Class
AdvancedLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Constructor (Color, Color, Color, Color, Color)

Initializes a new instance of the AdvancedLevelsCommand class with specified shadow, midtone, highlight, low and high output range colors.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedLevelsCommand(
    Color shadowColor,
    Color midtoneColor,
    Color highlightColor,
    Color outputRangeLow,
    Color outputRangeHigh
)
Public Sub New (
    shadowColor As Color,
    midtoneColor As Color,
    highlightColor As Color,
    outputRangeLow As Color,
    outputRangeHigh As Color
)

Parameters

shadowColor
Type: System.DrawingColor
Color of the shadow.
midtoneColor
Type: System.DrawingColor
Color of the midtone.
highlightColor
Type: System.DrawingColor
Color of the highlight.
outputRangeLow
Type: System.DrawingColor
Low output range color.
outputRangeHigh
Type: System.DrawingColor
High output range color.
See Also

Reference

AdvancedLevelsCommand Class
AdvancedLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Properties

The AdvancedLevelsCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter. Default GammaColor.Default.
Public property | HighlightColor | Gets or sets the white point in the image used as an input clipping point. Default Color.White.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | MidtoneColor | Gets or sets the gray point in the image used as a gamma adjustment. Gamma is used by default.
Public property | OutputRangeHigh | Gets or sets the light color value to stretch the histogram to. Default Color.White.
Public property | OutputRangeLow | Gets or sets the dark color value to stretch the histogram to. Default Color.Black.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | ShadowColor | Gets or sets the black point in the image used as an input clipping point. Default Color.Black.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.Gamma Property

AdvancedLevelsCommandGamma Property

Gets or sets the gamma adjustment to apply when running the filter. Default GammaColor.Default.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaColor Gamma { get; set; }
Public Property Gamma As GammaColor
    Get
    Set

Property Value

Type: GammaColor
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.HighlightColor Property

AdvancedLevelsCommandHighlightColor Property

Gets or sets the white point in the image used as an input clipping point. Default Color.White.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HighlightColor { get; set; }
Public Property HighlightColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.InPlaceProcessing Property

AdvancedLevelsCommandInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.MidtoneColor Property

AdvancedLevelsCommandMidtoneColor Property

Gets or sets the gray point in the image used as a gamma adjustment. Gamma is used by default.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color MidtoneColor { get; set; }
Public Property MidtoneColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.OutputRangeHigh Property

AdvancedLevelsCommandOutputRangeHigh Property

Gets or sets the light color value to stretch the histogram to. Default Color.White.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OutputRangeHigh { get; set; }
Public Property OutputRangeHigh As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.OutputRangeLow Property

AdvancedLevelsCommandOutputRangeLow Property

Gets or sets the dark color value to stretch the histogram to. Default Color.Black.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OutputRangeLow { get; set; }
Public Property OutputRangeLow As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.ShadowColor Property

AdvancedLevelsCommandShadowColor Property

Gets or sets the black point in the image used as an input clipping point. Default Color.Black.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ShadowColor { get; set; }
Public Property ShadowColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.SupportedPixelFormats Property

AdvancedLevelsCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat

An Array Containing:

PixelFormat.Pixel8bppGrayscale,PixelFormat.Pixel24bppBgr,PixelFormat.Pixel32bppBgr, PixelFormatPixelFormat.Pixel16bppGrayscaleAlpha,PixelFormat.Pixel32bppBgra,PixelFormat.Pixel32bppCmyk

See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand Methods

The AdvancedLevelsCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHighThreshold | Calculates the high threshold value.
 | GetLowThreshold | Calculates the low threshold value.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.GetHighThreshold Method

AdvancedLevelsCommandGetHighThreshold Method

Calculates the high threshold value.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetHighThreshold(
    int[] channel,
    double clip
)
Public Shared Function GetHighThreshold (
    channel As Integer(),
    clip As Double
) As Integer

Parameters

channel
Type: SystemInt32
The channels to use for calculation.
clip
Type: SystemDouble
The clip value.

Return Value

Type: Int32
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.GetLowThreshold Method

AdvancedLevelsCommandGetLowThreshold Method

Calculates the low threshold value.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetLowThreshold(
    int[] channel,
    double clip
)
Public Shared Function GetLowThreshold (
    channel As Integer(),
    clip As Double
) As Integer

Parameters

channel
Type: SystemInt32
The channels to use for calculation.
clip
Type: SystemDouble
The clip value.

Return Value

Type: Int32
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.GetObjectData Method

AdvancedLevelsCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
SecurityException | The caller does not have the required permission.
Remarks

Any objects that are included in the SerializationInfo are automatically tracked and serialized by the formatter.

Code that calls GetObjectData requires the SecurityPermission for providing serialization services. Associated enumeration: SecurityPermissionFlag.SerializationFormatter.

See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.ImplementMe Method

AdvancedLevelsCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.PerformActualCommand Method

AdvancedLevelsCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentNullException | source or channel1;channel1 null in 8bbpGrayscale or channel1;channel1 null inside 16bppGrayscale
See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AdvancedLevelsCommand.VerifyProperties Method

AdvancedLevelsCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AdvancedLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Class

Automatically corrects the color and contrast of an image. A combination of AutoLevelsCommand and AutoContrastCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsAutoColorCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoColorCommand : ApplyLutCommandBase
<SerializableAttribute>
Public Class AutoColorCommand
    Inherits ApplyLutCommandBase

The AutoColorCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoColorCommand | Creates a new instance of AutoColorCommand.
Public method | AutoColorCommand(Double) | Creates a new instance of AutoColorCommand specifying the clip amount.
Protected method | AutoColorCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoColorCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clip | Gets or sets the percentage of pixels to ignore when calculating the white and black points.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Constructor

Overload List
 | Name | Description
Public method | AutoColorCommand | Creates a new instance of AutoColorCommand.
Public method | AutoColorCommand(Double) | Creates a new instance of AutoColorCommand specifying the clip amount.
Protected method | AutoColorCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoColorCommand from serialization information.
Top
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Constructor

Creates a new instance of AutoColorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoColorCommand()
Public Sub New
See Also

Reference

AutoColorCommand Class
AutoColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Constructor (Double)

Creates a new instance of AutoColorCommand specifying the clip amount.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoColorCommand(
    double clip
)
Public Sub New (
    clip As Double
)

Parameters

clip
Type: SystemDouble
The percentage of pixels to ignore when calculating the white and black points.
Exceptions
Exception | Condition
 | Thrown if the clip is less than 0 or greater than 100.
See Also

Reference

AutoColorCommand Class
AutoColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AutoColorCommand from serialization information.
Creates a new instance of AutoColorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoColorCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the 'info' argument is null (Nothing in VB).
See Also

Reference

AutoColorCommand Class
AutoColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Properties

The AutoColorCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clip | Gets or sets the percentage of pixels to ignore when calculating the white and black points.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.Clip Property

AutoColorCommandClip Property

Gets or sets the percentage of pixels to ignore when calculating the white and black points.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Clip { get; set; }
Public Property Clip As Double
    Get
    Set

Property Value

Type: Double
The percentage of pixels to ignore when calculating the white and black points. Defaults to 0.1.
Exceptions
Exception | Condition
 | Thrown if value is not greater than 0.0 and 100.0.
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.InPlaceProcessing Property

AutoColorCommandInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.SupportedPixelFormats Property

AutoColorCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr, ,PixelFormat.Pixel32bppBgr, ,PixelFormat.Pixel32bppBgra
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand Methods

The AutoColorCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.GetObjectData Method

AutoColorCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object data will be filled into.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the 'info' argument is null (Nothing in VB).
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.ImplementMe Method

AutoColorCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.PerformActualCommand Method

AutoColorCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoColorCommand.VerifyProperties Method

AutoColorCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AutoColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Class

Adjusts the overall contrast of an image automatically.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsAutoContrastCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoContrastCommand : ApplyLutCommandBase
<SerializableAttribute>
Public Class AutoContrastCommand
    Inherits ApplyLutCommandBase

The AutoContrastCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoContrastCommand | Creates a new instance of AutoContrastCommand.
Public method | AutoContrastCommand(Int32, Int32) | Creates a new instance of AutoContrastCommand specifying the output range.
Protected method | AutoContrastCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoContrastCommand from serialization information.
Public method | AutoContrastCommand(Int32, Int32, Double) | Creates a new instance of AutoContrastCommand specifying the output range and gamma.
Public method | AutoContrastCommand(Int32, Int32, Double, Double) | Creates a new instance of AutoContrastCommand specifying the output range, gamma and clip values.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clip | Gets or sets the percentage of pixels to ignore when calculating the white and black points.
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | OutputRangeHigh | Gets or sets the high pixel value to stretch the histogram to.
Public property | OutputRangeLow | Gets or sets the low pixel value to stretch the histogram to.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Placeholder for future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
Remarks
Similar to auto levels, but it doesn't not introduce color casts.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Constructor

Creates a new instance of AutoConstrastCommand.
Overload List
 | Name | Description
Public method | AutoContrastCommand | Creates a new instance of AutoContrastCommand.
Public method | AutoContrastCommand(Int32, Int32) | Creates a new instance of AutoContrastCommand specifying the output range.
Protected method | AutoContrastCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoContrastCommand from serialization information.
Public method | AutoContrastCommand(Int32, Int32, Double) | Creates a new instance of AutoContrastCommand specifying the output range and gamma.
Public method | AutoContrastCommand(Int32, Int32, Double, Double) | Creates a new instance of AutoContrastCommand specifying the output range, gamma and clip values.
Top
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Constructor

Creates a new instance of AutoContrastCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoContrastCommand()
Public Sub New
See Also

Reference

AutoContrastCommand Class
AutoContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Constructor (Int32, Int32)

Creates a new instance of AutoContrastCommand specifying the output range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoContrastCommand(
    int outputRangeLow,
    int outputRangeHigh
)
Public Sub New (
    outputRangeLow As Integer,
    outputRangeHigh As Integer
)

Parameters

outputRangeLow
Type: SystemInt32
The low pixel value to stretch the histogram to. (0 to 255)
outputRangeHigh
Type: SystemInt32
The high pixel value to stretch the histogram to. (0 to 255)
Exceptions
Exception | Condition
 | Thrown if the arguments are less than 0 or greater than 255.
See Also

Reference

AutoContrastCommand Class
AutoContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AutoContrastCommand from serialization information.
Creates a new instance of AutoConstrastCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoContrastCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the 'info' argument is null (Nothing in VB).
See Also

Reference

AutoContrastCommand Class
AutoContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Constructor (Int32, Int32, Double)

Creates a new instance of AutoContrastCommand specifying the output range and gamma.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoContrastCommand(
    int outputRangeLow,
    int outputRangeHigh,
    double gamma
)
Public Sub New (
    outputRangeLow As Integer,
    outputRangeHigh As Integer,
    gamma As Double
)

Parameters

outputRangeLow
Type: SystemInt32
The low pixel value to stretch the histogram to. (0 to 255)
outputRangeHigh
Type: SystemInt32
The high pixel value to stretch the histogram to. (0 to 255)
gamma
Type: SystemDouble
The gamma adjustment to apply when running the filter.
Exceptions
Exception | Condition
 | Thrown if the outputRangeLow or outputRangeHigh value is less than 0 or greater than 255.
See Also

Reference

AutoContrastCommand Class
AutoContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Constructor (Int32, Int32, Double, Double)

Creates a new instance of AutoContrastCommand specifying the output range, gamma and clip values.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoContrastCommand(
    int outputRangeLow,
    int outputRangeHigh,
    double gamma,
    double clip
)
Public Sub New (
    outputRangeLow As Integer,
    outputRangeHigh As Integer,
    gamma As Double,
    clip As Double
)

Parameters

outputRangeLow
Type: SystemInt32
The low pixel value to stretch the histogram to. (0 to 255)
outputRangeHigh
Type: SystemInt32
The high pixel value to stretch the histogram to. (0 to 255)
gamma
Type: SystemDouble
The gamma adjustment to apply when running the filter.
clip
Type: SystemDouble
The percentage of pixels to ignore when calculating the white and black points. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the outputRangeLow or outputRangeHigh is less than 0 or greater than 255, or if the clip value is less than 0 or greater than 100.
See Also

Reference

AutoContrastCommand Class
AutoContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Properties

The AutoContrastCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clip | Gets or sets the percentage of pixels to ignore when calculating the white and black points.
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | OutputRangeHigh | Gets or sets the high pixel value to stretch the histogram to.
Public property | OutputRangeLow | Gets or sets the low pixel value to stretch the histogram to.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.Clip Property

AutoContrastCommandClip Property

Gets or sets the percentage of pixels to ignore when calculating the white and black points.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Clip { get; set; }
Public Property Clip As Double
    Get
    Set

Property Value

Type: Double
The percentage of pixels to ignore when calculating the white and black points. Defaults to 0.1.
Exceptions
Exception | Condition
 | Thrown if value is not between 0.0 and 100.0.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.Gamma Property

AutoContrastCommandGamma Property

Gets or sets the gamma adjustment to apply when running the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Gamma { get; set; }
Public Property Gamma As Double
    Get
    Set

Property Value

Type: Double
The gamma adjustment to apply when running the filter.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.InPlaceProcessing Property

AutoContrastCommandInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.OutputRangeHigh Property

AutoContrastCommandOutputRangeHigh Property

Gets or sets the high pixel value to stretch the histogram to.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int OutputRangeHigh { get; set; }
Public Property OutputRangeHigh As Integer
    Get
    Set

Property Value

Type: Int32
The high pixel value to stretch the histogram to.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.OutputRangeLow Property

AutoContrastCommandOutputRangeLow Property

Gets or sets the low pixel value to stretch the histogram to.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int OutputRangeLow { get; set; }
Public Property OutputRangeLow As Integer
    Get
    Set

Property Value

Type: Int32
The low pixel value to stretch the histogram to.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.SupportedPixelFormats Property

AutoContrastCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr, ,PixelFormat.Pixel8bppGrayscale, ,PixelFormat.Pixel32bppBgr, ,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand Methods

The AutoContrastCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Placeholder for future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verifies the properties. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.GetObjectData Method

AutoContrastCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object data will be filled into.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the 'info' argument is null (Nothing in VB).
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.ImplementMe Method

AutoContrastCommandImplementMe Method

Placeholder for future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.PerformActualCommand Method

AutoContrastCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoContrastCommand.VerifyProperties Method

AutoContrastCommandVerifyProperties Method

Verifies the properties.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image.
See Also

Reference

AutoContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Class

Enhances the contrast of an image by automatically defining the light and dark pixels, then redistributing the histogram proportionately.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsAutoLevelsCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoLevelsCommand : ApplyLutCommandBase,
    IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class AutoLevelsCommand
    Inherits ApplyLutCommandBase
    Implements IThreadableCommand, ICloneable

The AutoLevelsCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoLevelsCommand | Creates a new instance of AutoLevelsCommand.
Public method | AutoLevelsCommand(Color, Color) | Creates a new instance of AutoLevelsCommand specifying the output range.
Protected method | AutoLevelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoLevelsCommand from serialization information.
Public method | AutoLevelsCommand(Color, Color, Double) | Creates a new instance of AutoLevelsCommand specifying the output range and gamma.
Public method | AutoLevelsCommand(Color, Color, Double, Double) | Creates a new instance of AutoLevelsCommand specifying the output range, gamma and clip.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clip | Gets or sets the percentage of pixels to ignore when calculating the white and black points.
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | OutputRangeHigh | Gets or sets the high pixel value to stretch the histogram to.
Public property | OutputRangeLow | Gets or sets the low pixel value to stretch the histogram to.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Constructor

Creates a new instance of AutoLevelsCommand.
Overload List
 | Name | Description
Public method | AutoLevelsCommand | Creates a new instance of AutoLevelsCommand.
Public method | AutoLevelsCommand(Color, Color) | Creates a new instance of AutoLevelsCommand specifying the output range.
Protected method | AutoLevelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoLevelsCommand from serialization information.
Public method | AutoLevelsCommand(Color, Color, Double) | Creates a new instance of AutoLevelsCommand specifying the output range and gamma.
Public method | AutoLevelsCommand(Color, Color, Double, Double) | Creates a new instance of AutoLevelsCommand specifying the output range, gamma and clip.
Top
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Constructor

Creates a new instance of AutoLevelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoLevelsCommand()
Public Sub New
See Also

Reference

AutoLevelsCommand Class
AutoLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Constructor (Color, Color)

Creates a new instance of AutoLevelsCommand specifying the output range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoLevelsCommand(
    Color outputRangeLow,
    Color outputRangeHigh
)
Public Sub New (
    outputRangeLow As Color,
    outputRangeHigh As Color
)

Parameters

outputRangeLow
Type: System.DrawingColor
The low pixel value to stretch the histogram to.
outputRangeHigh
Type: System.DrawingColor
The high pixel value to stretch the histogram to.
See Also

Reference

AutoLevelsCommand Class
AutoLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AutoLevelsCommand from serialization information.
Creates a new instance of AutoLevelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoLevelsCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AutoLevelsCommand Class
AutoLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Constructor (Color, Color, Double)

Creates a new instance of AutoLevelsCommand specifying the output range and gamma.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoLevelsCommand(
    Color outputRangeLow,
    Color outputRangeHigh,
    double gamma
)
Public Sub New (
    outputRangeLow As Color,
    outputRangeHigh As Color,
    gamma As Double
)

Parameters

outputRangeLow
Type: System.DrawingColor
The low pixel value to stretch the histogram to.
outputRangeHigh
Type: System.DrawingColor
The high pixel value to stretch the histogram to.
gamma
Type: SystemDouble
The gamma adjustment to apply when running the filter.
See Also

Reference

AutoLevelsCommand Class
AutoLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Constructor (Color, Color, Double, Double)

Creates a new instance of AutoLevelsCommand specifying the output range, gamma and clip.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoLevelsCommand(
    Color outputRangeLow,
    Color outputRangeHigh,
    double gamma,
    double clip
)
Public Sub New (
    outputRangeLow As Color,
    outputRangeHigh As Color,
    gamma As Double,
    clip As Double
)

Parameters

outputRangeLow
Type: System.DrawingColor
The low pixel value to stretch the histogram to.
outputRangeHigh
Type: System.DrawingColor
The high pixel value to stretch the histogram to.
gamma
Type: SystemDouble
The gamma adjustment to apply when running the filter.
clip
Type: SystemDouble
The percentage of pixels to ignore when calculating the white and black points.
Exceptions
Exception | Condition
 | Thrown if the 'clip' argument is less than 0 or greater than 100.
See Also

Reference

AutoLevelsCommand Class
AutoLevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Properties

The AutoLevelsCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clip | Gets or sets the percentage of pixels to ignore when calculating the white and black points.
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | OutputRangeHigh | Gets or sets the high pixel value to stretch the histogram to.
Public property | OutputRangeLow | Gets or sets the low pixel value to stretch the histogram to.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.AutoThread Property

AutoLevelsCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.Clip Property

AutoLevelsCommandClip Property

Gets or sets the percentage of pixels to ignore when calculating the white and black points.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Clip { get; set; }
Public Property Clip As Double
    Get
    Set

Property Value

Type: Double
The percentage of pixels to ignore when calculating the white and black points. Defaults to 0.1.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.Gamma Property

AutoLevelsCommandGamma Property

Gets or sets the gamma adjustment to apply when running the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Gamma { get; set; }
Public Property Gamma As Double
    Get
    Set

Property Value

Type: Double
The gamma adjustment to apply when running the filter.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.InPlaceProcessing Property

AutoLevelsCommandInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.OutputRangeHigh Property

AutoLevelsCommandOutputRangeHigh Property

Gets or sets the high pixel value to stretch the histogram to.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OutputRangeHigh { get; set; }
Public Property OutputRangeHigh As Color
    Get
    Set

Property Value

Type: Color
The high pixel value to stretch the histogram to.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.OutputRangeLow Property

AutoLevelsCommandOutputRangeLow Property

Gets or sets the low pixel value to stretch the histogram to.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OutputRangeLow { get; set; }
Public Property OutputRangeLow As Color
    Get
    Set

Property Value

Type: Color
The low pixel value to stretch the histogram to.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.SupportedPixelFormats Property

AutoLevelsCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel64bppBgra
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand Methods

The AutoLevelsCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.AdjustBands Method

AutoLevelsCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.Clone Method

AutoLevelsCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the AutoLevelsCommand.

Implements

ICloneableClone
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.GetObjectData Method

AutoLevelsCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.ImplementMe Method

AutoLevelsCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.PerformActualCommand Method

AutoLevelsCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.PerformSectionCommand Method

AutoLevelsCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoLevelsCommand.VerifyProperties Method

AutoLevelsCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AutoLevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Class

Automatically adjusts the white point in an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsAutoWhiteBalanceCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AutoWhiteBalanceCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class AutoWhiteBalanceCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The AutoWhiteBalanceCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AutoWhiteBalanceCommand | Creates a new instance of AutoWhiteBalanceCommand.
Public method | AutoWhiteBalanceCommand(Double) | Creates a new instance of AutoWhiteBalanceCommand specifying dampening.
Protected method | AutoWhiteBalanceCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoWhiteBalanceCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Dampening | Gets or sets a value indicating the amount of dampening to use.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
Auto White Balance is based on "Gray World" algorithm and balances the source image. It is best applied after the translation to gamma-corrected RGB space.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Constructor

Creates a new instance of AutoWhiteBalanceCommand.
Overload List
 | Name | Description
Public method | AutoWhiteBalanceCommand | Creates a new instance of AutoWhiteBalanceCommand.
Public method | AutoWhiteBalanceCommand(Double) | Creates a new instance of AutoWhiteBalanceCommand specifying dampening.
Protected method | AutoWhiteBalanceCommand(SerializationInfo, StreamingContext) | Creates a new instance of AutoWhiteBalanceCommand from serialization information.
Top
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Constructor

Creates a new instance of AutoWhiteBalanceCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoWhiteBalanceCommand()
Public Sub New
See Also

Reference

AutoWhiteBalanceCommand Class
AutoWhiteBalanceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Constructor (Double)

Creates a new instance of AutoWhiteBalanceCommand specifying dampening.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoWhiteBalanceCommand(
    double dampening
)
Public Sub New (
    dampening As Double
)

Parameters

dampening
Type: SystemDouble

The amount of dampening to use.

Exceptions
Exception | Condition
 | Thrown if dampening is less than 1.
See Also

Reference

AutoWhiteBalanceCommand Class
AutoWhiteBalanceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AutoWhiteBalanceCommand from serialization information.
Creates a new instance of AutoWhiteBalanceCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AutoWhiteBalanceCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AutoWhiteBalanceCommand Class
AutoWhiteBalanceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Properties

The AutoWhiteBalanceCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Dampening | Gets or sets a value indicating the amount of dampening to use.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand.Dampening Property

AutoWhiteBalanceCommandDampening Property

Gets or sets a value indicating the amount of dampening to use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Dampening { get; set; }
Public Property Dampening As Double
    Get
    Set

Property Value

Type: Double
The amount of dampening.
Exceptions
Exception | Condition
 | Thrown when value < 1.
Remarks
Dampening is used to mitigate the algorithm since full correction is often too extreme for real world scenes.
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand.InPlaceProcessing Property

AutoWhiteBalanceCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand.SupportedPixelFormats Property

AutoWhiteBalanceCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand Methods

The AutoWhiteBalanceCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand.GetObjectData Method

AutoWhiteBalanceCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand.PerformActualCommand Method

AutoWhiteBalanceCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


AutoWhiteBalanceCommand.VerifyProperties Method

AutoWhiteBalanceCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AutoWhiteBalanceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Class

Apply a bevel effect to the edges of an image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsBevelEdgeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BevelEdgeCommand : ImageCommand,
    ISerializable
Public Class BevelEdgeCommand
    Inherits ImageCommand
    Implements ISerializable

The BevelEdgeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BevelEdgeCommand | Creates a new instance of BevelEdgeCommand.
Protected method | BevelEdgeCommand(SerializationInfo, StreamingContext) | Creates a new instance of BevelEdgeCommand from serialization information.
Public method | BevelEdgeCommand(Int32, Double, Double, Double, Double, Double) | Creates a new instance of BevelEdgeCommand specifying the bevel size and brightness levels.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BevelSize | Gets or sets the size of the bevel along the edge, in pixels.
Public property | BottomBrightness | Gets or sets the brightness level of the bottom facet. (0-255)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LeftBrightness | Gets or sets the brightness level of the left facet. (0-255)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RightBrightness | Gets or sets the brightness level of the right facet. (0-255)
Public property | SmoothFactor | Gets or sets the smooth the bevel edge. (0-500)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopBrightness | Gets or sets the brightness level of the top facet. (0-255)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image.
Examples
BevelEdge Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Apply a 10 pixel bevel with a light source from the right.
BevelEdgeCommand cmd = new BevelEdgeCommand(10, 60, 170, 200, 40, 200);
cmd.Apply(image);
BevelEdge Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Apply a 10 pixel bevel with a light source from the right.
Dim cmd As BevelEdgeCommand =  New BevelEdgeCommand(10,60,170,200,40,200)
cmd.Apply(image)
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Constructor

Overload List
 | Name | Description
Public method | BevelEdgeCommand | Creates a new instance of BevelEdgeCommand.
Protected method | BevelEdgeCommand(SerializationInfo, StreamingContext) | Creates a new instance of BevelEdgeCommand from serialization information.
Public method | BevelEdgeCommand(Int32, Double, Double, Double, Double, Double) | Creates a new instance of BevelEdgeCommand specifying the bevel size and brightness levels.
Top
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Constructor

Creates a new instance of BevelEdgeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BevelEdgeCommand()
Public Sub New
See Also

Reference

BevelEdgeCommand Class
BevelEdgeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BevelEdgeCommand from serialization information.
Creates a new instance of BevelEdgeCommand. Creates a new instance of BevelEdgeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BevelEdgeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BevelEdgeCommand Class
BevelEdgeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Constructor (Int32, Double, Double, Double, Double, Double)

Creates a new instance of BevelEdgeCommand specifying the bevel size and brightness levels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BevelEdgeCommand(
    int bevelSize,
    double leftBrightness,
    double topBrightness,
    double rightBrightness,
    double bottomBrightness,
    double smoothFactor
)
Public Sub New (
    bevelSize As Integer,
    leftBrightness As Double,
    topBrightness As Double,
    rightBrightness As Double,
    bottomBrightness As Double,
    smoothFactor As Double
)

Parameters

bevelSize
Type: SystemInt32
Size of the bevel along the edge, in pixels.
leftBrightness
Type: SystemDouble
Brightness level of the left facet. (0-255)
topBrightness
Type: SystemDouble
Brightness level of the top facet. (0-255)
rightBrightness
Type: SystemDouble
Brightness level of the right facet. (0-255)
bottomBrightness
Type: SystemDouble
Brightness level of the bottom facet. (0-255)
smoothFactor
Type: SystemDouble
Smooth the bevel edge. (0-500)
Exceptions
Exception | Condition
 | Thrown if any of the arguments are invalid.
See Also

Reference

BevelEdgeCommand Class
BevelEdgeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Properties

The BevelEdgeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BevelSize | Gets or sets the size of the bevel along the edge, in pixels.
Public property | BottomBrightness | Gets or sets the brightness level of the bottom facet. (0-255)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LeftBrightness | Gets or sets the brightness level of the left facet. (0-255)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RightBrightness | Gets or sets the brightness level of the right facet. (0-255)
Public property | SmoothFactor | Gets or sets the smooth the bevel edge. (0-500)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TopBrightness | Gets or sets the brightness level of the top facet. (0-255)
Top
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.BevelSize Property

BevelEdgeCommandBevelSize Property

Gets or sets the size of the bevel along the edge, in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BevelSize { get; set; }
Public Property BevelSize As Integer
    Get
    Set

Property Value

Type: Int32
Size of the bevel along the edge, in pixels.
Exceptions
Exception | Condition
 | Thrown if value is not gt; 0.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.BottomBrightness Property

BevelEdgeCommandBottomBrightness Property

Gets or sets the brightness level of the bottom facet. (0-255)

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BottomBrightness { get; set; }
Public Property BottomBrightness As Double
    Get
    Set

Property Value

Type: Double
Brightness level of the bottom facet. (0-255)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.InPlaceProcessing Property

BevelEdgeCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.LeftBrightness Property

BevelEdgeCommandLeftBrightness Property

Gets or sets the brightness level of the left facet. (0-255)

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LeftBrightness { get; set; }
Public Property LeftBrightness As Double
    Get
    Set

Property Value

Type: Double
Brightness level of the left facet. (0-255)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.RightBrightness Property

BevelEdgeCommandRightBrightness Property

Gets or sets the brightness level of the right facet. (0-255)

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double RightBrightness { get; set; }
Public Property RightBrightness As Double
    Get
    Set

Property Value

Type: Double
Brightness level of the right facet. (0-255)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.SmoothFactor Property

BevelEdgeCommandSmoothFactor Property

Gets or sets the smooth the bevel edge. (0-500)

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SmoothFactor { get; set; }
Public Property SmoothFactor As Double
    Get
    Set

Property Value

Type: Double
Smooth the bevel edge. (0-500)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 500.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.SupportedPixelFormats Property

BevelEdgeCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.TopBrightness Property

BevelEdgeCommandTopBrightness Property

Gets or sets the brightness level of the top facet. (0-255)

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double TopBrightness { get; set; }
Public Property TopBrightness As Double
    Get
    Set

Property Value

Type: Double
Brightness level of the top facet. (0-255)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand Methods

The BevelEdgeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.GetObjectData Method

BevelEdgeCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.PerformActualCommand Method

BevelEdgeCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BevelEdgeCommand.VerifyProperties Method

BevelEdgeCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BevelEdgeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Class

Modifies the brightness and/or contrast of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsBrightnessContrastCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BrightnessContrastCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class BrightnessContrastCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The BrightnessContrastCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BrightnessContrastCommand | Creates a new instance of BrightnessContrastCommand.
Public method | BrightnessContrastCommand(Double, Double) | Initializes a new instance of BrightnessContrastCommand specifying the brightness and contrast.
Protected method | BrightnessContrastCommand(SerializationInfo, StreamingContext) | Creates a new instance of BrightnessContrastCommand from serialization information.
Public method | BrightnessContrastCommand(Double, Double, BrightnessContrastCurveType) | Initializes a new instance of BrightnessContrastCommand specifying the brightness, contrast, and curve shape.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CurveShape | Gets or sets a value indicating the curve shape.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | NewBrightness | Gets or sets the percent to increase or decrease brightness.
Public property | NewContrast | Gets or sets the percent to increase or decrease contrast.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Constructor

Overload List
 | Name | Description
Public method | BrightnessContrastCommand | Creates a new instance of BrightnessContrastCommand.
Public method | BrightnessContrastCommand(Double, Double) | Initializes a new instance of BrightnessContrastCommand specifying the brightness and contrast.
Protected method | BrightnessContrastCommand(SerializationInfo, StreamingContext) | Creates a new instance of BrightnessContrastCommand from serialization information.
Public method | BrightnessContrastCommand(Double, Double, BrightnessContrastCurveType) | Initializes a new instance of BrightnessContrastCommand specifying the brightness, contrast, and curve shape.
Top
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Constructor

Creates a new instance of BrightnessContrastCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessContrastCommand()
Public Sub New
See Also

Reference

BrightnessContrastCommand Class
BrightnessContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Constructor (Double, Double)

Initializes a new instance of BrightnessContrastCommand specifying the brightness and contrast.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessContrastCommand(
    double newBrightness,
    double newContrast
)
Public Sub New (
    newBrightness As Double,
    newContrast As Double
)

Parameters

newBrightness
Type: SystemDouble
The percent to increase or decrease brightness. (-100 to 100)
newContrast
Type: SystemDouble
The percent to increate or decrease the contrast. (-100 to 100)
Exceptions
Exception | Condition
 | Thrown if either argument is less than -100 or greater than 100.
See Also

Reference

BrightnessContrastCommand Class
BrightnessContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BrightnessContrastCommand from serialization information.
Initializes a new instance of BrightnessContrastCommand. Creates a new instance of BrightnessContrastCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BrightnessContrastCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BrightnessContrastCommand Class
BrightnessContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Constructor (Double, Double, BrightnessContrastCurveType)

Initializes a new instance of BrightnessContrastCommand specifying the brightness, contrast, and curve shape.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessContrastCommand(
    double newBrightness,
    double newContrast,
    BrightnessContrastCurveType curveShape
)
Public Sub New (
    newBrightness As Double,
    newContrast As Double,
    curveShape As BrightnessContrastCurveType
)

Parameters

newBrightness
Type: SystemDouble
The percent to increase or decrease brightness. (-100 to 100)
newContrast
Type: SystemDouble
The percent to increase or decrease contrast. (-100 to 100)
curveShape
Type: Atalasoft.Imaging.ImageProcessing.EffectsBrightnessContrastCurveType
The curve shape.
Exceptions
Exception | Condition
 | Thrown if the newBrightness or newContrast values are less than -100 or greater than 100.
See Also

Reference

BrightnessContrastCommand Class
BrightnessContrastCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Properties

The BrightnessContrastCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CurveShape | Gets or sets a value indicating the curve shape.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | NewBrightness | Gets or sets the percent to increase or decrease brightness.
Public property | NewContrast | Gets or sets the percent to increase or decrease contrast.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.AutoThread Property

BrightnessContrastCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.CurveShape Property

BrightnessContrastCommandCurveShape Property

Gets or sets a value indicating the curve shape.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessContrastCurveType CurveShape { get; set; }
Public Property CurveShape As BrightnessContrastCurveType
    Get
    Set

Property Value

Type: BrightnessContrastCurveType
A value indicating the curve shape.
Remarks

See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.InPlaceProcessing Property

BrightnessContrastCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.NewBrightness Property

BrightnessContrastCommandNewBrightness Property

Gets or sets the percent to increase or decrease brightness.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double NewBrightness { get; set; }
Public Property NewBrightness As Double
    Get
    Set

Property Value

Type: Double
The percent to increase or decrease brightness.
Exceptions
Exception | Condition
 | Thrown if value is not between -100 and 100.
Remarks
Valid values are from -100 to 100.
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.NewContrast Property

BrightnessContrastCommandNewContrast Property

Gets or sets the percent to increase or decrease contrast.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double NewContrast { get; set; }
Public Property NewContrast As Double
    Get
    Set

Property Value

Type: Double
The percent to increase or decrease contrast.
Exceptions
Exception | Condition
 | Thrown if value is not between -100 and 100.
Remarks
Valid values are from -100 to 100.
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.SupportedPixelFormats Property

BrightnessContrastCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand Methods

The BrightnessContrastCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Creates a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.AdjustBands Method

BrightnessContrastCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.Clone Method

BrightnessContrastCommandClone Method

Creates a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the BrightnessContrastCommand.

Implements

ICloneableClone
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.GetObjectData Method

BrightnessContrastCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.PerformActualCommand Method

BrightnessContrastCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.PerformSectionCommand Method

BrightnessContrastCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCommand.VerifyProperties Method

BrightnessContrastCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BrightnessContrastCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessContrastCurveType Enumeration

Indicates the curve type used in the BrightnessContrastCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BrightnessContrastCurveType
Public Enumeration BrightnessContrastCurveType
Members
Member name | Description
ThreePoint | The three point curve emphasizes mid-tones more than the five or seven point curves. This is closest to the brightness / contrast that Adobe Photoshop uses.
FivePoint | The default curve type for traditional Brightness/Contrast adjustment.
SevenPoint | The seven point curve forces pixels in the extreme dark and light ranges to black or white faster than the five point curve.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
BrightnessContrastCommand


BrightnessHistogramEqualizeCommand Class

Perform histogram equalization on an image while preventing colors from shifting.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsBrightnessHistogramEqualizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BrightnessHistogramEqualizeCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class BrightnessHistogramEqualizeCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The BrightnessHistogramEqualizeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BrightnessHistogramEqualizeCommand | Creates a new instance of BrightnessHistogramEqualizeCommand.
Public method | BrightnessHistogramEqualizeCommand(Int32, Int32) | Creates a new instance of BrightnessHistogramEqualizeCommand specifying the threshold levels.
Protected method | BrightnessHistogramEqualizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of BrightnessHistogramEqualizeCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighThreshold | Gets or sets a high threshold value above which pixels are uneffected.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowThreshold | Gets or sets a low threshold value below which pixels are uneffected.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This function will re-distribute the pixel values across the given range so that there will be (approximately) equal numbers of pixels with each pixel value (0 to 255). Input pixels with values above or below the threshold values are not modified in the output.

Can be used to extend the dynamic range of an image.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
HistogramEqualizeCommand


BrightnessHistogramEqualizeCommand Constructor

Overload List
 | Name | Description
Public method | BrightnessHistogramEqualizeCommand | Creates a new instance of BrightnessHistogramEqualizeCommand.
Public method | BrightnessHistogramEqualizeCommand(Int32, Int32) | Creates a new instance of BrightnessHistogramEqualizeCommand specifying the threshold levels.
Protected method | BrightnessHistogramEqualizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of BrightnessHistogramEqualizeCommand from serialization information.
Top
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand Constructor

Creates a new instance of BrightnessHistogramEqualizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessHistogramEqualizeCommand()
Public Sub New
See Also

Reference

BrightnessHistogramEqualizeCommand Class
BrightnessHistogramEqualizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand Constructor (Int32, Int32)

Creates a new instance of BrightnessHistogramEqualizeCommand specifying the threshold levels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessHistogramEqualizeCommand(
    int lowThreshold,
    int highThreshold
)
Public Sub New (
    lowThreshold As Integer,
    highThreshold As Integer
)

Parameters

lowThreshold
Type: SystemInt32
Pixels are uneffected below this value. (0 - 255)
highThreshold
Type: SystemInt32
Pixels are uneffected above this value. (0 - 255)
Exceptions
Exception | Condition
 | Thrown if the arguments are less than 0 or greater than 255.
See Also

Reference

BrightnessHistogramEqualizeCommand Class
BrightnessHistogramEqualizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BrightnessHistogramEqualizeCommand from serialization information.
Creates a new instance of BrightnessHistogramEqualizeCommand specifying the threshold values. Creates a new instance of BrightnessHistogramEqualizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BrightnessHistogramEqualizeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BrightnessHistogramEqualizeCommand Class
BrightnessHistogramEqualizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand Properties

The BrightnessHistogramEqualizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighThreshold | Gets or sets a high threshold value above which pixels are uneffected.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowThreshold | Gets or sets a low threshold value below which pixels are uneffected.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.HighThreshold Property

BrightnessHistogramEqualizeCommandHighThreshold Property

Gets or sets a high threshold value above which pixels are uneffected.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int HighThreshold { get; set; }
Public Property HighThreshold As Integer
    Get
    Set

Property Value

Type: Int32
A high threshold value above which pixels are uneffected.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks
Valid values are from 0 to 255.
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.InPlaceProcessing Property

BrightnessHistogramEqualizeCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.LowThreshold Property

BrightnessHistogramEqualizeCommandLowThreshold Property

Gets or sets a low threshold value below which pixels are uneffected.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LowThreshold { get; set; }
Public Property LowThreshold As Integer
    Get
    Set

Property Value

Type: Int32
A low threshold value below which pixels are uneffected.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255
Remarks
Valid values are from 0 to 255.
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.SupportedPixelFormats Property

BrightnessHistogramEqualizeCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand Methods

The BrightnessHistogramEqualizeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.GetObjectData Method

BrightnessHistogramEqualizeCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.PerformActualCommand Method

BrightnessHistogramEqualizeCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramEqualizeCommand.VerifyProperties Method

BrightnessHistogramEqualizeCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BrightnessHistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Class

Performs a histogram stretch on an image while preventing colors from shifting.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsBrightnessHistogramStretchCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BrightnessHistogramStretchCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class BrightnessHistogramStretchCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The BrightnessHistogramStretchCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BrightnessHistogramStretchCommand | Creates a new instance of BrightnessHistogramStretchCommand.
Public method | BrightnessHistogramStretchCommand(Double, Double) | Creates a new instance of BrightnessHistogramStretchCommand specifying the limit values.
Protected method | BrightnessHistogramStretchCommand(SerializationInfo, StreamingContext) | Creates a new instance of BrightnessHistogramStretchCommand from serialization information.
Public method | BrightnessHistogramStretchCommand(Double, Double, Boolean) | Creates a new instance of BrightnessHistogramStretchCommand specifying the limit values and if the HSL colorspace should be used.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighLimit | Gets or sets the percent of pixels to set to 255.
Public property | HslColorSpace | Gets or sets a value indicating if the Histogram Stretch is performed in the HSL colorspace.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowLimit | Gets or sets the percent of pixels to set to 0.
Public property | MidPoint | Gets or sets the pixel value to set to middle intensity. This value must be from 1 to 254.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | UseMidPoint | Gets or sets a value indicating whether the MidPoint property will be used to divide output range.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Re-distribute the pixel values across the given range by first setting values above and below the thresholds to zero and 255 respectively and then scaling the remaining values to span the entire zero to 255 range.

This can be used to increase the contrast and extend the dynamic range of an image.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Constructor

Overload List
 | Name | Description
Public method | BrightnessHistogramStretchCommand | Creates a new instance of BrightnessHistogramStretchCommand.
Public method | BrightnessHistogramStretchCommand(Double, Double) | Creates a new instance of BrightnessHistogramStretchCommand specifying the limit values.
Protected method | BrightnessHistogramStretchCommand(SerializationInfo, StreamingContext) | Creates a new instance of BrightnessHistogramStretchCommand from serialization information.
Public method | BrightnessHistogramStretchCommand(Double, Double, Boolean) | Creates a new instance of BrightnessHistogramStretchCommand specifying the limit values and if the HSL colorspace should be used.
Top
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Constructor

Creates a new instance of BrightnessHistogramStretchCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessHistogramStretchCommand()
Public Sub New
See Also

Reference

BrightnessHistogramStretchCommand Class
BrightnessHistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Constructor (Double, Double)

Creates a new instance of BrightnessHistogramStretchCommand specifying the limit values.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessHistogramStretchCommand(
    double lowLimit,
    double highLimit
)
Public Sub New (
    lowLimit As Double,
    highLimit As Double
)

Parameters

lowLimit
Type: SystemDouble
Percent of pixels to set to 0. (0 to 100)
highLimit
Type: SystemDouble
Percent of pixels to set to 255. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the arguments are less than 0 or greater than 100.
See Also

Reference

BrightnessHistogramStretchCommand Class
BrightnessHistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BrightnessHistogramStretchCommand from serialization information.
Creates a new instance of BrightnessHistogramStretchCommand. Creates a new instance of BrightnessHistogramStretchCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BrightnessHistogramStretchCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BrightnessHistogramStretchCommand Class
BrightnessHistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Constructor (Double, Double, Boolean)

Creates a new instance of BrightnessHistogramStretchCommand specifying the limit values and if the HSL colorspace should be used.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BrightnessHistogramStretchCommand(
    double lowLimit,
    double highLimit,
    bool hslColorSpace
)
Public Sub New (
    lowLimit As Double,
    highLimit As Double,
    hslColorSpace As Boolean
)

Parameters

lowLimit
Type: SystemDouble
Percent of pixels to set to 0. (0 to 100)
highLimit
Type: SystemDouble
Percent of pixels to set to 255. (0 to 100)
hslColorSpace
Type: SystemBoolean
Indicates if the Histogram Stretch is performed in the HSL colorspace.
Exceptions
Exception | Condition
 | Thrown if the lowLimit or highLimit arguments are less than 0 or greater than 100.
See Also

Reference

BrightnessHistogramStretchCommand Class
BrightnessHistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Properties

The BrightnessHistogramStretchCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighLimit | Gets or sets the percent of pixels to set to 255.
Public property | HslColorSpace | Gets or sets a value indicating if the Histogram Stretch is performed in the HSL colorspace.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowLimit | Gets or sets the percent of pixels to set to 0.
Public property | MidPoint | Gets or sets the pixel value to set to middle intensity. This value must be from 1 to 254.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | UseMidPoint | Gets or sets a value indicating whether the MidPoint property will be used to divide output range.
Top
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.AutoThread Property

BrightnessHistogramStretchCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.HighLimit Property

BrightnessHistogramStretchCommandHighLimit Property

Gets or sets the percent of pixels to set to 255.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HighLimit { get; set; }
Public Property HighLimit As Double
    Get
    Set

Property Value

Type: Double
Percent of pixels to set to 255.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.HslColorSpace Property

BrightnessHistogramStretchCommandHslColorSpace Property

Gets or sets a value indicating if the Histogram Stretch is performed in the HSL colorspace.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HslColorSpace { get; set; }
Public Property HslColorSpace As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the Histogram Stretch is performed in the HSL colorspace.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.InPlaceProcessing Property

BrightnessHistogramStretchCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.LowLimit Property

BrightnessHistogramStretchCommandLowLimit Property

Gets or sets the percent of pixels to set to 0.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LowLimit { get; set; }
Public Property LowLimit As Double
    Get
    Set

Property Value

Type: Double
Percent of pixels to set to 0.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.MidPoint Property

BrightnessHistogramStretchCommandMidPoint Property

Gets or sets the pixel value to set to middle intensity. This value must be from 1 to 254.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MidPoint { get; set; }
Public Property MidPoint As Integer
    Get
    Set

Property Value

Type: Int32
The middle intensity value.
Exceptions
Exception | Condition
 | Thrown if the value is less than 1 or greater than 254.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.SupportedPixelFormats Property

BrightnessHistogramStretchCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.UseMidPoint Property

BrightnessHistogramStretchCommandUseMidPoint Property

Gets or sets a value indicating whether the MidPoint property will be used to divide output range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseMidPoint { get; set; }
Public Property UseMidPoint As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the MidPoint property is used.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand Methods

The BrightnessHistogramStretchCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.AdjustBands Method

BrightnessHistogramStretchCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.Clone Method

BrightnessHistogramStretchCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of this BrightnessHistogramStretchCommand.

Implements

ICloneableClone
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.GetObjectData Method

BrightnessHistogramStretchCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.PerformActualCommand Method

BrightnessHistogramStretchCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.PerformSectionCommand Method

BrightnessHistogramStretchCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


BrightnessHistogramStretchCommand.VerifyProperties Method

BrightnessHistogramStretchCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BrightnessHistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Class

Generates an image which looks like a cracked ceramic glaze.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsCrackleCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CrackleCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class CrackleCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The CrackleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | CrackleCommand | Creates a new instance of CrackleCommand.
Protected method | CrackleCommand(SerializationInfo, StreamingContext) | Creates a new instance of CrackleCommand from serialization information.
Public method | CrackleCommand(CrackleMode, Int32) | Creates a new instance of CrackleCommand specifying the crackle mode and definition.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Definition | Gets or sets a value which controls sharpness of cracks.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the crackle mode.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a compatible format.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Constructor

Overload List
 | Name | Description
Public method | CrackleCommand | Creates a new instance of CrackleCommand.
Protected method | CrackleCommand(SerializationInfo, StreamingContext) | Creates a new instance of CrackleCommand from serialization information.
Public method | CrackleCommand(CrackleMode, Int32) | Creates a new instance of CrackleCommand specifying the crackle mode and definition.
Top
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Constructor

Creates a new instance of CrackleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CrackleCommand()
Public Sub New
See Also

Reference

CrackleCommand Class
CrackleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of CrackleCommand from serialization information.
Initalize a new instance of the CrackleCommand class. Creates a new instance of CrackleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CrackleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

CrackleCommand Class
CrackleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Constructor (CrackleMode, Int32)

Creates a new instance of CrackleCommand specifying the crackle mode and definition.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CrackleCommand(
    CrackleMode mode,
    int definition
)
Public Sub New (
    mode As CrackleMode,
    definition As Integer
)

Parameters

mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsCrackleMode
The crackle mode.
definition
Type: SystemInt32
A value which controls sharpness of cracks. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the definition is less than 0 or greater than 100.
See Also

Reference

CrackleCommand Class
CrackleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Properties

The CrackleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Definition | Gets or sets a value which controls sharpness of cracks.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the crackle mode.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.Definition Property

CrackleCommandDefinition Property

Gets or sets a value which controls sharpness of cracks.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Definition { get; set; }
Public Property Definition As Integer
    Get
    Set

Property Value

Type: Int32
A value which controls sharpness of cracks.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.Mode Property

CrackleCommandMode Property

Gets or sets the crackle mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CrackleMode Mode { get; set; }
Public Property Mode As CrackleMode
    Get
    Set

Property Value

Type: CrackleMode

The crackle mode.

See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.SupportedPixelFormats Property

CrackleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand Methods

The CrackleCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.GetObjectData Method

CrackleCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.PerformActualCommand Method

CrackleCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.SelectPreferredPixelFormat Method

CrackleCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleCommand.VerifyProperties Method

CrackleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

CrackleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CrackleMode Enumeration

Specifies the crackle mode to use in the CrackleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CrackleMode
Public Enumeration CrackleMode
Members
Member name | Description
PaintChips | Creates an effect of dried paint chipping off.
TinPunch | Makes the image appear to be punched out onto a tin surface.
Erosion | Creates the effect of erosion on the image.
PaintChips2 | A more intense version of the PaintChips effect.
Erosion2 | A more intense version of the Erosion effect.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Class

Applies a color curve to an image, similar to the Photoshop Curves method.

The curves are defined by an array of one or more objects.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsCurvesCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CurvesCommand : ApplyLutCommandBase,
    IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class CurvesCommand
    Inherits ApplyLutCommandBase
    Implements IThreadableCommand, ICloneable

The CurvesCommand type exposes the following members.

Constructors
 | Name | Description
Public method | CurvesCommand | Creates a new instance of CurvesCommand.
 | CurvesCommand(PointF, ChannelFlags) | Creates a new instance of CurvesCommand specifying the points of the curve and channels to process.
 | CurvesCommand(SerializationInfo, StreamingContext) | Creates a new instance of CurvesCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channels | Gets or sets the channel flags that specify which color channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
 | Points | Gets or sets the points that define the curve.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
Examples
CurvesCommandCS (C#)
Copy
// Load an image.
AtalaImage myImage = new AtalaImage("C:\\mytestimage.jpg");

// Apply a simple curve.
PointF[] points = new PointF[2];
points[0] = new PointF(0.3, 0.6);
points[1] = new PointF(0.6, 0.8);

CurvesCommand cmd = new CurvesCommand(points, ChannelFlags.AllChannels);
cmd.Apply(myImage);
CurvesCommandVB (Visual Basic)
Copy
' Load an image.
Dim myImage As AtalaImage =  New AtalaImage("C:\\mytestimage.jpg")

' Apply a simple curve.
Dim points() As PointF =  New PointF(1) {}
points(0) = New PointF(0.3, 0.6)
points(1) = New PointF(0.6, 0.8)

Dim cmd As CurvesCommand =  New CurvesCommand(points,ChannelFlags.AllChannels)
cmd.Apply(myImage)
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Constructor

Creates a CurvesCommand object that can be used to apply a color curve to an image.
Overload List
 | Name | Description
Public method | CurvesCommand | Creates a new instance of CurvesCommand.
 | CurvesCommand(PointF, ChannelFlags) | Creates a new instance of CurvesCommand specifying the points of the curve and channels to process.
 | CurvesCommand(SerializationInfo, StreamingContext) | Creates a new instance of CurvesCommand from serialization information.
Top
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Constructor

Creates a new instance of CurvesCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CurvesCommand()
Public Sub New
See Also

Reference

CurvesCommand Class
CurvesCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Constructor (PointF[], ChannelFlags)

CurvesCommand Constructor (PointF, ChannelFlags)

Creates a new instance of CurvesCommand specifying the points of the curve and channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CurvesCommand(
    PointF[] points,
    ChannelFlags channels
)
Public Sub New (
    points As PointF(),
    channels As ChannelFlags
)

Parameters

points
Type: System.DrawingPointF
An array of PointF objects specifying the curve.
channels
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
A channel mask containing the channels to process.
Exceptions
Exception | Condition
 | Occurs if null is passed as the points parameter or if an empty array is passed in.
 | Occurs if the array has more than 256 elements or a duplicate X value was found.
 | Occurs if the points array contains invalid values.
Examples
CurvesCommand Class
See Also

Reference

CurvesCommand Class
CurvesCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of CurvesCommand from serialization information.
Creates a new instance of CurvesCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CurvesCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
Examples
CurvesCommand Class
See Also

Reference

CurvesCommand Class
CurvesCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Properties

The CurvesCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Channels | Gets or sets the channel flags that specify which color channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
 | Points | Gets or sets the points that define the curve.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.AutoThread Property

CurvesCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.Channels Property

CurvesCommandChannels Property

Gets or sets the channel flags that specify which color channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags Channels { get; set; }
Public Property Channels As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The channels to process.
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.InPlaceProcessing Property

CurvesCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
True
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.Points Property

CurvesCommandPoints Property

Gets or sets the points that define the curve.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF[] Points { get; set; }
Public Property Points As PointF()
    Get
    Set

Property Value

Type: PointF
The points that define the curve.
Exceptions
Exception | Condition
 | Occurs if null is passed as the points parameter or if an empty array is passed in.
 | Occurs if the array has more than 256 elements or a duplicate X value was found.
 | Occurs if the points array contains invalid values.
Remarks

At least one point must be provided, with a maximum of 256 points.

Each point value must have a range from 0.0 to 1.0. There can be no duplicate PointF.X values can be in the array.

Examples
CurvesCommand Class
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.SupportedPixelFormats Property

CurvesCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand Methods

The CurvesCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.AdjustBands Method

CurvesCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.Clone Method

CurvesCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of this CurvesCommand.

Implements

ICloneableClone
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.GetObjectData Method

CurvesCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.ImplementMe Method

CurvesCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.PerformActualCommand Method

CurvesCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.PerformSectionCommand Method

CurvesCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


CurvesCommand.VerifyProperties Method

CurvesCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | Points array must contain at least one entry whose X value is not 0 and is not 1;Points or Points array must contain at least one entry whose X value is not 0 and is not 1;Points or The points array contains invalid data.;points
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

CurvesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Class

This command will de-interlace an image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DeInterlaceCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class DeInterlaceCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The DeInterlaceCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DeInterlaceCommand | Creates a new instance of DeInterlaceCommand.
Public method | DeInterlaceCommand(DeInterlaceMethod) | Initializes a new instance of DeInterlaceCommand specifying the method.
Protected method | DeInterlaceCommand(SerializationInfo, StreamingContext) | Creates a new instance of DeInterlaceCommand from serialization information.
Public method | DeInterlaceCommand(DeInterlaceMethod, DeInterlaceMergeMethod) | Initializes a new instance of DeInterlaceCommand specifying the de-interlace method and merging mode.
Public method | DeInterlaceCommand(DeInterlaceMethod, DeInterlaceRetention) | Initializes a new instance of DeInterlaceCommand specifying the de-interlace method and which lines to retain.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MergeMethod | Gets or sets the merge method to use when merging the odd and even interpolated images.
Public property | Method | Gets or sets the method used to de-interlace the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Retention | Gets or sets the odd or even line to retain.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Interlacing is when two frames, usually in video, are mixed together in one frame with odd lines being from one frame and even lines being from the other frame. De-Interlacing can fix this with one of three options:

Duplicating every other lineInterpolating every other lineMerging the odd and even lines
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
MosaicCommand Example


DeInterlaceCommand Constructor

Overload List
 | Name | Description
Public method | DeInterlaceCommand | Creates a new instance of DeInterlaceCommand.
Public method | DeInterlaceCommand(DeInterlaceMethod) | Initializes a new instance of DeInterlaceCommand specifying the method.
Protected method | DeInterlaceCommand(SerializationInfo, StreamingContext) | Creates a new instance of DeInterlaceCommand from serialization information.
Public method | DeInterlaceCommand(DeInterlaceMethod, DeInterlaceMergeMethod) | Initializes a new instance of DeInterlaceCommand specifying the de-interlace method and merging mode.
Public method | DeInterlaceCommand(DeInterlaceMethod, DeInterlaceRetention) | Initializes a new instance of DeInterlaceCommand specifying the de-interlace method and which lines to retain.
Top
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Constructor

Creates a new instance of DeInterlaceCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceCommand()
Public Sub New
See Also

Reference

DeInterlaceCommand Class
DeInterlaceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Constructor (DeInterlaceMethod)

Initializes a new instance of DeInterlaceCommand specifying the method.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceCommand(
    DeInterlaceMethod method
)
Public Sub New (
    method As DeInterlaceMethod
)

Parameters

method
Type: Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceMethod
The de-interlace method.
See Also

Reference

DeInterlaceCommand Class
DeInterlaceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DeInterlaceCommand from serialization information.

Initializes a new instance of DeInterlaceCommand .

Initializes a new instance of DeInterlaceCommand with default settings.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DeInterlaceCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DeInterlaceCommand Class
DeInterlaceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Constructor (DeInterlaceMethod, DeInterlaceMergeMethod)

Initializes a new instance of DeInterlaceCommand specifying the de-interlace method and merging mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceCommand(
    DeInterlaceMethod method,
    DeInterlaceMergeMethod mergeMethod
)
Public Sub New (
    method As DeInterlaceMethod,
    mergeMethod As DeInterlaceMergeMethod
)

Parameters

method
Type: Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceMethod
The de-interlace method.
mergeMethod
Type: Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceMergeMethod
The merge method used when merging the odd and even interpolated images.
See Also

Reference

DeInterlaceCommand Class
DeInterlaceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Constructor (DeInterlaceMethod, DeInterlaceRetention)

Initializes a new instance of DeInterlaceCommand specifying the de-interlace method and which lines to retain.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceCommand(
    DeInterlaceMethod method,
    DeInterlaceRetention retention
)
Public Sub New (
    method As DeInterlaceMethod,
    retention As DeInterlaceRetention
)

Parameters

method
Type: Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceMethod
The de-interlace method.
retention
Type: Atalasoft.Imaging.ImageProcessing.EffectsDeInterlaceRetention

Specifies which lines to retain.

See Also

Reference

DeInterlaceCommand Class
DeInterlaceCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Properties

The DeInterlaceCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MergeMethod | Gets or sets the merge method to use when merging the odd and even interpolated images.
Public property | Method | Gets or sets the method used to de-interlace the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Retention | Gets or sets the odd or even line to retain.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.InPlaceProcessing Property

DeInterlaceCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.MergeMethod Property

DeInterlaceCommandMergeMethod Property

Gets or sets the merge method to use when merging the odd and even interpolated images.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceMergeMethod MergeMethod { get; set; }
Public Property MergeMethod As DeInterlaceMergeMethod
    Get
    Set

Property Value

Type: DeInterlaceMergeMethod
The merge method to use when merging the odd and even interpolated images.
Remarks
Only used for the Merge method.
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.Method Property

DeInterlaceCommandMethod Property

Gets or sets the method used to de-interlace the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceMethod Method { get; set; }
Public Property Method As DeInterlaceMethod
    Get
    Set

Property Value

Type: DeInterlaceMethod
The method used to de-interlace the image.
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.Retention Property

DeInterlaceCommandRetention Property

Gets or sets the odd or even line to retain.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeInterlaceRetention Retention { get; set; }
Public Property Retention As DeInterlaceRetention
    Get
    Set

Property Value

Type: DeInterlaceRetention
The odd or even line to retain.
Remarks
Only used for the Duplicate and Interpolate methods.
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.SupportedPixelFormats Property

DeInterlaceCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand Methods

The DeInterlaceCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.GetObjectData Method

DeInterlaceCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.PerformActualCommand Method

DeInterlaceCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceCommand.VerifyProperties Method

DeInterlaceCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | source image must have an even number of rows;image
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DeInterlaceCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceMergeMethod Enumeration

Specifies the merge method used by DeInterlaceCommand when the Merge method is used.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DeInterlaceMergeMethod
Public Enumeration DeInterlaceMergeMethod
Members
Member name | Description
BiLinear | BiLinear filter is applied.
BiCubic | BiCubic filter is applied.
Lanczos | Lanczos filter is applied.
Hanning | Hanning filter is applied.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceMethod Enumeration

Specifies the method used by the DeInterlaceCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DeInterlaceMethod
Public Enumeration DeInterlaceMethod
Members
Member name | Description
Duplicate | Duplicates the interlaced lines.
Interpolate | Uses interpolation when the image is de-interlaced.
Merge | Merges the interlaced lines together.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


DeInterlaceRetention Enumeration

Specifies the retention used in DeInterlaceCommand when DeInterlaceMethod or DeInterlaceMethod methods are used.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DeInterlaceRetention
Public Enumeration DeInterlaceRetention
Members
Member name | Description
EvenLines | Even lines are retained.
OddLines | Odd lines are retained.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Class

Apply a drop shadow behind the image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsDropShadowCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DropShadowCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class DropShadowCommand
    Inherits ImageCommand
    Implements ISerializable

The DropShadowCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DropShadowCommand | Creates a new instance of DropShadowCommand.
Public method | DropShadowCommand(Point) | Initialize a new instance of DropShadowCommand specifying offset.
Public method | DropShadowCommand(Int32) | Initializes a new instance of DropShadowCommand specifying offset.
Public method | DropShadowCommand(Point, Color) | Creates a new instance of DropShadowCommand specifying offset and shadowColor.
Protected method | DropShadowCommand(SerializationInfo, StreamingContext) | Creates a new instance of DropShadowCommand from serialization information.
Public method | DropShadowCommand(Point, Color, Double) | Initialize a new instance of DropShadowCommand specifying offset, shadowColor and blurLevel.
Public method | DropShadowCommand(Point, Color, Double, Boolean) | Initialize a new instance of DropShadowCommand specifying offset, shadowColor, blurLevel and increaseCanvas.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlurLevel | Gets or sets the amount of blur to add to the shadow.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | IncreaseCanvas | Gets or sets a value to indicate if you want the canvas to be increased to include the shadow.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or set the number of pixels to offset the the shadow.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ShadowColor | Gets or sets the color to use for the shadow.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a compatible format.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor

Overload List
 | Name | Description
Public method | DropShadowCommand | Creates a new instance of DropShadowCommand.
Public method | DropShadowCommand(Point) | Initialize a new instance of DropShadowCommand specifying offset.
Public method | DropShadowCommand(Int32) | Initializes a new instance of DropShadowCommand specifying offset.
Public method | DropShadowCommand(Point, Color) | Creates a new instance of DropShadowCommand specifying offset and shadowColor.
Protected method | DropShadowCommand(SerializationInfo, StreamingContext) | Creates a new instance of DropShadowCommand from serialization information.
Public method | DropShadowCommand(Point, Color, Double) | Initialize a new instance of DropShadowCommand specifying offset, shadowColor and blurLevel.
Public method | DropShadowCommand(Point, Color, Double, Boolean) | Initialize a new instance of DropShadowCommand specifying offset, shadowColor, blurLevel and increaseCanvas.
Top
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor

Creates a new instance of DropShadowCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DropShadowCommand()
Public Sub New
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor (Point)

Initialize a new instance of DropShadowCommand specifying offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DropShadowCommand(
    Point offset
)
Public Sub New (
    offset As Point
)

Parameters

offset
Type: System.DrawingPoint
The number of pixels to offset the the shadow.
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor (Int32)

Initializes a new instance of DropShadowCommand specifying offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DropShadowCommand(
    int offset
)
Public Sub New (
    offset As Integer
)

Parameters

offset
Type: SystemInt32
The number of pixels to offset the the shadow.
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor (Point, Color)

Creates a new instance of DropShadowCommand specifying offset and shadowColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DropShadowCommand(
    Point offset,
    Color shadowColor
)
Public Sub New (
    offset As Point,
    shadowColor As Color
)

Parameters

offset
Type: System.DrawingPoint
The number of pixels to offset the the shadow.
shadowColor
Type: System.DrawingColor
The color to use for the shadow.
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DropShadowCommand from serialization information.
Initialize a new instance of the DropShadowCommand class. Creates a new instance of DropShadowCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DropShadowCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor (Point, Color, Double)

Initialize a new instance of DropShadowCommand specifying offset, shadowColor and blurLevel.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DropShadowCommand(
    Point offset,
    Color shadowColor,
    double blurLevel
)
Public Sub New (
    offset As Point,
    shadowColor As Color,
    blurLevel As Double
)

Parameters

offset
Type: System.DrawingPoint
The number of pixels to offset the the shadow.
shadowColor
Type: System.DrawingColor
The color to use for the shadow.
blurLevel
Type: SystemDouble
The amount of blur to add to the shadow.
Exceptions
Exception | Condition
 | Thrown if blurLevel is not greater than 0.
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Constructor (Point, Color, Double, Boolean)

Initialize a new instance of DropShadowCommand specifying offset, shadowColor, blurLevel and increaseCanvas.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DropShadowCommand(
    Point offset,
    Color shadowColor,
    double blurLevel,
    bool increaseCanvas
)
Public Sub New (
    offset As Point,
    shadowColor As Color,
    blurLevel As Double,
    increaseCanvas As Boolean
)

Parameters

offset
Type: System.DrawingPoint
The number of pixels to offset the the shadow.
shadowColor
Type: System.DrawingColor
The color to use for the shadow.
blurLevel
Type: SystemDouble
The amount of blur to add to the shadow.
increaseCanvas
Type: SystemBoolean
A value to indicate if you want the canvas to be increased to include the shadow.
Exceptions
Exception | Condition
 | Thrown if 'blurLevel' is not greater than 0.
See Also

Reference

DropShadowCommand Class
DropShadowCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Properties

The DropShadowCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlurLevel | Gets or sets the amount of blur to add to the shadow.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | IncreaseCanvas | Gets or sets a value to indicate if you want the canvas to be increased to include the shadow.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or set the number of pixels to offset the the shadow.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | ShadowColor | Gets or sets the color to use for the shadow.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.BlurLevel Property

DropShadowCommandBlurLevel Property

Gets or sets the amount of blur to add to the shadow.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BlurLevel { get; set; }
Public Property BlurLevel As Double
    Get
    Set

Property Value

Type: Double
The amount of blur to add to the shadow.
Exceptions
Exception | Condition
 | Thrown if value is not greater than 0.
Remarks
This is the standard deviation of the gaussian kernal.
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.IncreaseCanvas Property

DropShadowCommandIncreaseCanvas Property

Gets or sets a value to indicate if you want the canvas to be increased to include the shadow.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncreaseCanvas { get; set; }
Public Property IncreaseCanvas As Boolean
    Get
    Set

Property Value

Type: Boolean
A value to indicate if you want the canvas to be increased to include the shadow.
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.Offset Property

DropShadowCommandOffset Property

Gets or set the number of pixels to offset the the shadow.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The number of pixels to offset the shadow.
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.ShadowColor Property

DropShadowCommandShadowColor Property

Gets or sets the color to use for the shadow.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ShadowColor { get; set; }
Public Property ShadowColor As Color
    Get
    Set

Property Value

Type: Color
The color to use for the shadow.
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.SupportedPixelFormats Property

DropShadowCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand Methods

The DropShadowCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.ConstructFinalImage Method

DropShadowCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.GetObjectData Method

DropShadowCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.PerformActualCommand Method

DropShadowCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.SelectPreferredPixelFormat Method

DropShadowCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DropShadowCommand.VerifyProperties Method

DropShadowCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DropShadowCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Class

The DuotoneCommand processes an image from its current color space into a two color space.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsDuotoneCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DuotoneCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class DuotoneCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The DuotoneCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DuotoneCommand | Creates a new instance of DuotoneCommand.
Public method | DuotoneCommand(Color) | Construct a new DuotoneCommand using the supplied color as the tint.
Protected method | DuotoneCommand(SerializationInfo, StreamingContext) | Creates a new instance of DuotoneCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Indicates whether or not this command will act on the given or image or allocate a new one. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tint | The color that will be used for the "light" tones of the duotoned image.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Constructor

Constructs a new DuotoneCommand object.
Overload List
 | Name | Description
Public method | DuotoneCommand | Creates a new instance of DuotoneCommand.
Public method | DuotoneCommand(Color) | Construct a new DuotoneCommand using the supplied color as the tint.
Protected method | DuotoneCommand(SerializationInfo, StreamingContext) | Creates a new instance of DuotoneCommand from serialization information.
Top
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Constructor

Creates a new instance of DuotoneCommand.
Construct a new DuotoneCommand with default properties.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DuotoneCommand()
Public Sub New
See Also

Reference

DuotoneCommand Class
DuotoneCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Constructor (Color)

Construct a new DuotoneCommand using the supplied color as the tint.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DuotoneCommand(
    Color tint
)
Public Sub New (
    tint As Color
)

Parameters

tint
Type: System.DrawingColor
The tint that will be used for the duotone color space.
See Also

Reference

DuotoneCommand Class
DuotoneCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DuotoneCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DuotoneCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DuotoneCommand Class
DuotoneCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Properties

The DuotoneCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Indicates whether or not this command will act on the given or image or allocate a new one. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tint | The color that will be used for the "light" tones of the duotoned image.
Top
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.AutoThread Property

DuotoneCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.InPlaceProcessing Property

DuotoneCommandInPlaceProcessing Property

Indicates whether or not this command will act on the given or image or allocate a new one.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Returns true for the DuotoneCommand
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.SupportedPixelFormats Property

DuotoneCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.Tint Property

DuotoneCommandTint Property

The color that will be used for the "light" tones of the duotoned image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Tint { get; set; }
Public Property Tint As Color
    Get
    Set

Property Value

Type: Color
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand Methods

The DuotoneCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.AdjustBands Method

DuotoneCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.Clone Method

DuotoneCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the DuotoneCommand.

Implements

ICloneableClone
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.GetObjectData Method

DuotoneCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.PerformActualCommand Method

DuotoneCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.PerformSectionCommand Method

DuotoneCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


DuotoneCommand.VerifyProperties Method

DuotoneCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DuotoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Class

Creates an effect which looks like fingerprint smuges on the image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsFingerprintCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FingerprintCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class FingerprintCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The FingerprintCommand type exposes the following members.

Constructors
 | Name | Description
Public method | FingerprintCommand | Creates a new instance of FingerprintCommand.
Public method | FingerprintCommand(Double) | Creates a new instance of FingerprintCommand specifying depth.
Protected method | FingerprintCommand(SerializationInfo, StreamingContext) | Creates a new instance of FingerprintCommand from serialization information.
Public method | FingerprintCommand(Double, Int32, Boolean) | Creates a new instance of FingerprintCommand specifying depth, filterSize and dilation.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Depth | Gets or sets a positive number indicating the depth of the effect.
Public property | Dilation | Gets or sets a value indicating if dilation mode should be used.
Public property | FilterSize | Gets or sets the filter size of the effect.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires an 8-bit grayscale. If the source image is of a different format, it will raise the ChangePixelFormat event and convert the image to a compatible format.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Constructor

Overload List
 | Name | Description
Public method | FingerprintCommand | Creates a new instance of FingerprintCommand.
Public method | FingerprintCommand(Double) | Creates a new instance of FingerprintCommand specifying depth.
Protected method | FingerprintCommand(SerializationInfo, StreamingContext) | Creates a new instance of FingerprintCommand from serialization information.
Public method | FingerprintCommand(Double, Int32, Boolean) | Creates a new instance of FingerprintCommand specifying depth, filterSize and dilation.
Top
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Constructor

Creates a new instance of FingerprintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FingerprintCommand()
Public Sub New
See Also

Reference

FingerprintCommand Class
FingerprintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Constructor (Double)

Creates a new instance of FingerprintCommand specifying depth.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FingerprintCommand(
    double depth
)
Public Sub New (
    depth As Double
)

Parameters

depth
Type: SystemDouble
A positive number indicating the depth of the effect.
Exceptions
Exception | Condition
 | Thrown if the depth is less than or equal to 0.
See Also

Reference

FingerprintCommand Class
FingerprintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FingerprintCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FingerprintCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

FingerprintCommand Class
FingerprintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Constructor (Double, Int32, Boolean)

Creates a new instance of FingerprintCommand specifying depth, filterSize and dilation.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FingerprintCommand(
    double depth,
    int filterSize,
    bool dilation
)
Public Sub New (
    depth As Double,
    filterSize As Integer,
    dilation As Boolean
)

Parameters

depth
Type: SystemDouble
A positive number indicating the depth of the effect.
filterSize
Type: SystemInt32
Gets or sets the filter size of the effect. Should be an odd number greater than or equal to 3.
dilation
Type: SystemBoolean
Indicates if dilation should be used.
Exceptions
Exception | Condition
 | Thrown if the depth is less than or equal to 0, or if filterSize is less than 3.
See Also

Reference

FingerprintCommand Class
FingerprintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Properties

The FingerprintCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Depth | Gets or sets a positive number indicating the depth of the effect.
Public property | Dilation | Gets or sets a value indicating if dilation mode should be used.
Public property | FilterSize | Gets or sets the filter size of the effect.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.Depth Property

FingerprintCommandDepth Property

Gets or sets a positive number indicating the depth of the effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Depth { get; set; }
Public Property Depth As Double
    Get
    Set

Property Value

Type: Double
A positive number indicating the depth of the effect.
Exceptions
Exception | Condition
 | Thrown if value is not greater than 0.
Remarks
50 is a good number to start with.
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.Dilation Property

FingerprintCommandDilation Property

Gets or sets a value indicating if dilation mode should be used.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Dilation { get; set; }
Public Property Dilation As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if dilation mode should be used.
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.FilterSize Property

FingerprintCommandFilterSize Property

Gets or sets the filter size of the effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The filter size of the effect, must be an odd number greater than or equal to 3.
Exceptions
Exception | Condition
 | Thrown if value is less than 3.
Remarks
Values of 3, 5 and 7 are good choices.
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.SupportedPixelFormats Property

FingerprintCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand Methods

The FingerprintCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.ConstructFinalImage Method

FingerprintCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.GetObjectData Method

FingerprintCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.PerformActualCommand Method

FingerprintCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.SelectPreferredPixelFormat Method

FingerprintCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FingerprintCommand.VerifyProperties Method

FingerprintCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

FingerprintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Class

Performs a flood fill on an image. You can use it to fill an area of an image surrounded by FillColor by setting Mode to Edge, or you can fill the pixel color at Position with FillColor.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsFloodFillCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FloodFillCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class FloodFillCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The FloodFillCommand type exposes the following members.

Constructors
 | Name | Description
Public method | FloodFillCommand | Creates a new instance of FloodFillCommand.
Protected method | FloodFillCommand(SerializationInfo, StreamingContext) | Creates a new instance of FloodFillCommand from serialization information.
Public method | FloodFillCommand(Point, Color, Double, ColorMatchMode) | Creates a new instance of FloodFillCommand specifying the position, fill color, tolerance and color match mode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FillColor | Gets or sets the Color used for the fill.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mode | Gets or sets the ColorMatchMode used for the fill.
Public property | Position | Gets or sets the X, Y pixel position where the fill should start.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the percentage of color variation.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This command requires one of the following image formats:

PixelFormat24bppBgrPixelFormat32bppBgrPixelFormat32bppBgra

If any other image format is passed, you will receive a System.ArgumentException.

Examples
FloodFill Example (C#)
Copy
Rectangle rc;

if (this.viewer.Selection.Visible)
    rc = this.viewer.Selection.Bounds;
else
    rc = new Rectangle(Point.Empty, this.viewer.Image.Size);

Point pos = new Point(rc.Width / 2 + rc.Left, rc.Height / 2 + rc.Top);
FloodFillCommand cmd = new FloodFillCommand(pos, Color.Red, 5, ColorMatchMode.Surface);
cmd.RegionOfInterest = new RegionOfInterest(rc);

this.viewer.ApplyCommand(cmd);
FloodFill Example (Visual Basic)
Copy
Dim rc As Rectangle

If Me.viewer.Selection.Visible Then
    rc = Me.viewer.Selection.Bounds
Else
    rc = New Rectangle(PoInteger.Empty, Me.viewer.Image.Size)
End If

Dim pos As Point =  New Point(rc.Width / 2 + rc.Left, rc.Height / 2 + rc.Top)
Dim cmd As FloodFillCommand =  New FloodFillCommand(pos, Color.Red, 5, ColorMatchMode.Surface)
cmd.RegionOfInterest = New RegionOfInterest(rc)

Me.viewer.ApplyCommand(cmd)
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Constructor

Overload List
 | Name | Description
Public method | FloodFillCommand | Creates a new instance of FloodFillCommand.
Protected method | FloodFillCommand(SerializationInfo, StreamingContext) | Creates a new instance of FloodFillCommand from serialization information.
Public method | FloodFillCommand(Point, Color, Double, ColorMatchMode) | Creates a new instance of FloodFillCommand specifying the position, fill color, tolerance and color match mode.
Top
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Constructor

Creates a new instance of FloodFillCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FloodFillCommand()
Public Sub New
See Also

Reference

FloodFillCommand Class
FloodFillCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FloodFillCommand from serialization information.
Creates a new instance of FloodFillCommand specifying position, fillColor, tolerance and mode.
Creates a new instance of FloodFillCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FloodFillCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

FloodFillCommand Class
FloodFillCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Constructor (Point, Color, Double, ColorMatchMode)

Creates a new instance of FloodFillCommand specifying the position, fill color, tolerance and color match mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FloodFillCommand(
    Point position,
    Color fillColor,
    double tolerance,
    ColorMatchMode mode
)
Public Sub New (
    position As Point,
    fillColor As Color,
    tolerance As Double,
    mode As ColorMatchMode
)

Parameters

position
Type: System.DrawingPoint
The X, Y pixel position where the fill should start.
fillColor
Type: System.DrawingColor
The color used for the fill.
tolerance
Type: SystemDouble
The percentage of color variation. (0 to 100)
mode
Type: Atalasoft.Imaging.ImageProcessingColorMatchMode
The ColorMatchMode used for the fill.
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100.
See Also

Reference

FloodFillCommand Class
FloodFillCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Properties

The FloodFillCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FillColor | Gets or sets the Color used for the fill.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mode | Gets or sets the ColorMatchMode used for the fill.
Public property | Position | Gets or sets the X, Y pixel position where the fill should start.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the percentage of color variation.
Top
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.FillColor Property

FloodFillCommandFillColor Property

Gets or sets the Color used for the fill.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set

Property Value

Type: Color
The color used for the fill.
Remarks

If Mode is Edge, this color also represents the the edge color and will fill the area until it finds the edge color.

If Mode is Surface, this color will be used to fill the pixel color located at Position until it reaches a different color.

See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.InPlaceProcessing Property

FloodFillCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.Mode Property

FloodFillCommandMode Property

Gets or sets the ColorMatchMode used for the fill.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorMatchMode Mode { get; set; }
Public Property Mode As ColorMatchMode
    Get
    Set

Property Value

Type: ColorMatchMode
The ColorMatchMode used for the fill.
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.Position Property

FloodFillCommandPosition Property

Gets or sets the X, Y pixel position where the fill should start.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The X, Y pixel position where the fill should start.
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.SupportedPixelFormats Property

FloodFillCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.Tolerance Property

FloodFillCommandTolerance Property

Gets or sets the percentage of color variation.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set

Property Value

Type: Double
The percentage of color variation.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are 0 to 100. A value of 0 requires an exact color match, where a value of 100 will match any color.
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand Methods

The FloodFillCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.GetObjectData Method

FloodFillCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.PerformActualCommand Method

FloodFillCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Position;The starting position must be inside the image or region.
See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


FloodFillCommand.VerifyProperties Method

FloodFillCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

FloodFillCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Structure

This structure is used with WatercolorTintCommand to specify the gamma levels used during the command process.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct GammaColor
<SerializableAttribute>
Public Structure GammaColor

The GammaColor type exposes the following members.

Constructors
 | Name | Description
Public method | GammaColor(Double) | Creates a new instance of GammaColor specifying a single value for all channels.
Public method | GammaColor(Double, Double, Double) | Creates a new instance of GammaColor specifying the gamma value for blue, green and red channels.
Public method | GammaColor(Double, Double, Double, Double) | Creates a new instance of GammaColor specifying the gamma value for blue, green, red and alpha channels.
Top
Properties
Name | Description
Default | Gets the default GammaColor object.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | A | The alpha channel.
Public field | B | The blue channel.
Public field | G | The green channel.
Public field | R | The red channel.
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Constructor

Create a GammaColor object for use with WatercolorTintCommand.
Overload List
 | Name | Description
Public method | GammaColor(Double) | Creates a new instance of GammaColor specifying a single value for all channels.
Public method | GammaColor(Double, Double, Double) | Creates a new instance of GammaColor specifying the gamma value for blue, green and red channels.
Public method | GammaColor(Double, Double, Double, Double) | Creates a new instance of GammaColor specifying the gamma value for blue, green, red and alpha channels.
Top
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Constructor (Double)

Creates a new instance of GammaColor specifying a single value for all channels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaColor(
    double gamma
)
Public Sub New (
    gamma As Double
)

Parameters

gamma
Type: SystemDouble
The gamma value.
See Also

Reference

GammaColor Structure
GammaColor Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Constructor (Double, Double, Double)

Creates a new instance of GammaColor specifying the gamma value for blue, green and red channels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaColor(
    double blue,
    double green,
    double red
)
Public Sub New (
    blue As Double,
    green As Double,
    red As Double
)

Parameters

blue
Type: SystemDouble
The blue gamma value.
green
Type: SystemDouble
The green gamma value.
red
Type: SystemDouble
The red gamma value.
See Also

Reference

GammaColor Structure
GammaColor Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Constructor (Double, Double, Double, Double)

Creates a new instance of GammaColor specifying the gamma value for blue, green, red and alpha channels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaColor(
    double blue,
    double green,
    double red,
    double alpha
)
Public Sub New (
    blue As Double,
    green As Double,
    red As Double,
    alpha As Double
)

Parameters

blue
Type: SystemDouble
The blue gamma value.
green
Type: SystemDouble
The green gamma value.
red
Type: SystemDouble
The red gamma value.
alpha
Type: SystemDouble
The alpha gamma value.
See Also

Reference

GammaColor Structure
GammaColor Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Properties

The GammaColor type exposes the following members.

Properties
Name | Description
Default | Gets the default GammaColor object.
Top
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor.Default Property

GammaColorDefault Property

Gets the default GammaColor object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static GammaColor Default { get; }
Public Shared ReadOnly Property Default As GammaColor
    Get

Property Value

Type: GammaColor
A GammaColor object with blue, green, red and alpha set to 1.
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Methods

The GammaColor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor Fields

The GammaColor type exposes the following members.

Fields
 | Name | Description
Public field | A | The alpha channel.
Public field | B | The blue channel.
Public field | G | The green channel.
Public field | R | The red channel.
Top
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor.A Field

GammaColorA Field

The alpha channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double A
Public A As Double

Field Value

Type: Double
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor.B Field

GammaColorB Field

The blue channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double B
Public B As Double

Field Value

Type: Double
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor.G Field

GammaColorG Field

The green channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double G
Public G As Double

Field Value

Type: Double
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaColor.R Field

GammaColorR Field

The red channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double R
Public R As Double

Field Value

Type: Double
See Also

Reference

GammaColor Structure
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand Class

Increases or decreases the gamma value of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsGammaCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GammaCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class GammaCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The GammaCommand type exposes the following members.

Constructors
 | Name | Description
Public method | GammaCommand | Creates a new instance of GammaCommand.
Public method | GammaCommand(Double) | Creates a new instance of GammaCommand specifying the gamma level.
Protected method | GammaCommand(SerializationInfo, StreamingContext) | Creates a new instance of GammaCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | GammaLevel | Gets or sets the gamma correction level.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
Atalasoft.Imaging.ImageProcessing.EffectsMosaicCommand


GammaCommand Constructor

Overload List
 | Name | Description
Public method | GammaCommand | Creates a new instance of GammaCommand.
Public method | GammaCommand(Double) | Creates a new instance of GammaCommand specifying the gamma level.
Protected method | GammaCommand(SerializationInfo, StreamingContext) | Creates a new instance of GammaCommand from serialization information.
Top
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand Constructor

Creates a new instance of GammaCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaCommand()
Public Sub New
See Also

Reference

GammaCommand Class
GammaCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand Constructor (Double)

Creates a new instance of GammaCommand specifying the gamma level.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaCommand(
    double gammaLevel
)
Public Sub New (
    gammaLevel As Double
)

Parameters

gammaLevel
Type: SystemDouble
The gamma correction level. A value < 1 decreases brightness and a value >1 increases brightness.
Exceptions
Exception | Condition
 | Thrown if gammaLevel is less than 0.
See Also

Reference

GammaCommand Class
GammaCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of GammaCommand from serialization information.
Creates a new instance of the GammaCommand object.
Creates a new instance of GammaCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GammaCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

GammaCommand Class
GammaCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand Properties

The GammaCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | GammaLevel | Gets or sets the gamma correction level.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.AutoThread Property

GammaCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.GammaLevel Property

GammaCommandGammaLevel Property

Gets or sets the gamma correction level.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GammaLevel { get; set; }
Public Property GammaLevel As Double
    Get
    Set

Property Value

Type: Double
The gamma correction level.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks

This value must be greater than or equal to 0. The effect of this value is as follows:

<1 - decreases brightness >1 - increases brightness =1 - no change.
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.InPlaceProcessing Property

GammaCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.SupportedPixelFormats Property

GammaCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand Methods

The GammaCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.AdjustBands Method

GammaCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.Clone Method

GammaCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the GammaCommand.

Implements

ICloneableClone
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.GetObjectData Method

GammaCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.PerformActualCommand Method

GammaCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.PerformSectionCommand Method

GammaCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GammaCommand.VerifyProperties Method

GammaCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

GammaCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Class

Generate a soft focus, gauzed image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsGauzyCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GauzyCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class GauzyCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The GauzyCommand type exposes the following members.

Constructors
 | Name | Description
Public method | GauzyCommand | Creates a new instance of GauzyCommand.
Protected method | GauzyCommand(SerializationInfo, StreamingContext) | Creates a new instance of GauzyCommand from serialization information.
Public method | GauzyCommand(Double, Double, Double, GauzyMode) | Creates a new instance of GauzyCommand specifying the blur and sharpen amounts.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlurAmount | Gets or sets the amount of blur to apply.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clarity | Gets or sets the amount to clarify the result.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the GauzyMode to use.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SharpAmount | Gets or sets the amount of original pixels in the image.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a compatible format.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Constructor

Overload List
 | Name | Description
Public method | GauzyCommand | Creates a new instance of GauzyCommand.
Protected method | GauzyCommand(SerializationInfo, StreamingContext) | Creates a new instance of GauzyCommand from serialization information.
Public method | GauzyCommand(Double, Double, Double, GauzyMode) | Creates a new instance of GauzyCommand specifying the blur and sharpen amounts.
Top
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Constructor

Creates a new instance of GauzyCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GauzyCommand()
Public Sub New
See Also

Reference

GauzyCommand Class
GauzyCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of GauzyCommand from serialization information.
Creates a new instance of GauzyCommand specifying blurAmount, sharpAmount, clarity, mode and regionOfInterest.
Creates a new instance of GauzyCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GauzyCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

GauzyCommand Class
GauzyCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Constructor (Double, Double, Double, GauzyMode)

Creates a new instance of GauzyCommand specifying the blur and sharpen amounts.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GauzyCommand(
    double blurAmount,
    double sharpAmount,
    double clarity,
    GauzyMode mode
)
Public Sub New (
    blurAmount As Double,
    sharpAmount As Double,
    clarity As Double,
    mode As GauzyMode
)

Parameters

blurAmount
Type: SystemDouble

The amount of blur to apply. (0 to 100)

sharpAmount
Type: SystemDouble
The amount of original pixels in the image. (0 to 100)
clarity
Type: SystemDouble
The amount to clarify the result. (0 to 100)
mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsGauzyMode

The GauzyMode to use.

Exceptions
Exception | Condition
 | Thrown if blurAmount, sharpAmount or clarity values are less than 0 or greater than 100.
See Also

Reference

GauzyCommand Class
GauzyCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Properties

The GauzyCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlurAmount | Gets or sets the amount of blur to apply.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Clarity | Gets or sets the amount to clarify the result.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the GauzyMode to use.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SharpAmount | Gets or sets the amount of original pixels in the image.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.BlurAmount Property

GauzyCommandBlurAmount Property

Gets or sets the amount of blur to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BlurAmount { get; set; }
Public Property BlurAmount As Double
    Get
    Set

Property Value

Type: Double

The amount of blur to apply.

Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.Clarity Property

GauzyCommandClarity Property

Gets or sets the amount to clarify the result.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Clarity { get; set; }
Public Property Clarity As Double
    Get
    Set

Property Value

Type: Double
The amount to clarify the result.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.Mode Property

GauzyCommandMode Property

Gets or sets the GauzyMode to use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GauzyMode Mode { get; set; }
Public Property Mode As GauzyMode
    Get
    Set

Property Value

Type: GauzyMode

The GauzyMode to use.

See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.SharpAmount Property

GauzyCommandSharpAmount Property

Gets or sets the amount of original pixels in the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SharpAmount { get; set; }
Public Property SharpAmount As Double
    Get
    Set

Property Value

Type: Double
The amount of original pixels in the image.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.SupportedPixelFormats Property

GauzyCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand Methods

The GauzyCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.GetObjectData Method

GauzyCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.PerformActualCommand Method

GauzyCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.SelectPreferredPixelFormat Method

GauzyCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyCommand.VerifyProperties Method

GauzyCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

GauzyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


GauzyMode Enumeration

Indicates the type of effect to apply in the GauzyCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum GauzyMode
Public Enumeration GauzyMode
Members
Member name | Description
Desaturated | Applies a desaturated effect to the image.
HighContrastForeground | Creates a high contrast effect on the image.
FullColor | Applies a full color gauzy effect.
Max | Applies a maximum filter effect to the image.
Min | Applies a minimum filter effect to the image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand Class

Generates a black and white image dithered to "halftone" dots.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsHalftoneCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HalftoneCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class HalftoneCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The HalftoneCommand type exposes the following members.

Constructors
 | Name | Description
Public method | HalftoneCommand | Creates a new instance of HalftoneCommand.
Public method | HalftoneCommand(Int32, Boolean) | Creates a new instance of HalftoneCommand specifying the dot size and smoothing values.
Protected method | HalftoneCommand(SerializationInfo, StreamingContext) | Creates a new instance of HalftoneCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MaxDotSize | Gets or sets the maximum size of the dots.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SmoothDots | Gets or sets a value indicating if the dots will be smooth or sharp.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a 24-bit image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
MosaicCommand Example


HalftoneCommand Constructor

Overload List
 | Name | Description
Public method | HalftoneCommand | Creates a new instance of HalftoneCommand.
Public method | HalftoneCommand(Int32, Boolean) | Creates a new instance of HalftoneCommand specifying the dot size and smoothing values.
Protected method | HalftoneCommand(SerializationInfo, StreamingContext) | Creates a new instance of HalftoneCommand from serialization information.
Top
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand Constructor

Creates a new instance of HalftoneCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HalftoneCommand()
Public Sub New
See Also

Reference

HalftoneCommand Class
HalftoneCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand Constructor (Int32, Boolean)

Creates a new instance of HalftoneCommand specifying the dot size and smoothing values.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HalftoneCommand(
    int maxDotSize,
    bool smoothDots
)
Public Sub New (
    maxDotSize As Integer,
    smoothDots As Boolean
)

Parameters

maxDotSize
Type: SystemInt32
The maximum size of the dots.
smoothDots
Type: SystemBoolean
A value indicating if the dots will be smooth or sharp.
Exceptions
Exception | Condition
 | Thrown if maxDotSize is less than 1.
See Also

Reference

HalftoneCommand Class
HalftoneCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HalftoneCommand from serialization information.
Creates a new instance of the HalftoneCommand object.
Creates a new instance of HalftoneCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HalftoneCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HalftoneCommand Class
HalftoneCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand Properties

The HalftoneCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MaxDotSize | Gets or sets the maximum size of the dots.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SmoothDots | Gets or sets a value indicating if the dots will be smooth or sharp.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.InPlaceProcessing Property

HalftoneCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.MaxDotSize Property

HalftoneCommandMaxDotSize Property

Gets or sets the maximum size of the dots.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxDotSize { get; set; }
Public Property MaxDotSize As Integer
    Get
    Set

Property Value

Type: Int32
The maximum size of the dots.
Exceptions
Exception | Condition
 | Thrown if value is not greater than 0.
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.SmoothDots Property

HalftoneCommandSmoothDots Property

Gets or sets a value indicating if the dots will be smooth or sharp.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SmoothDots { get; set; }
Public Property SmoothDots As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the dots will be smooth or sharp.
Remarks
If false, dots are solid black, with sharp edges.
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.SupportedPixelFormats Property

HalftoneCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand Methods

The HalftoneCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.GetObjectData Method

HalftoneCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.PerformActualCommand Method

HalftoneCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | MaxDotSize;MaxDotSize cannot be larger than the image or region.
See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HalftoneCommand.VerifyProperties Method

HalftoneCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

HalftoneCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand Class

Performs histogram equalization on an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsHistogramEqualizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HistogramEqualizeCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class HistogramEqualizeCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The HistogramEqualizeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | HistogramEqualizeCommand | Creates a new instance of HistogramEqualizeCommand.
Public method | HistogramEqualizeCommand(Int32, Int32) | Creates a new instance of HistogramEqualizeCommand specifying the threshold levels.
Protected method | HistogramEqualizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of HistogramEqualizeCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | HighThreshold | Gets or sets a high threshold value above which pixels are uneffected.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowThreshold | Gets or sets a low threshold value below which pixels are uneffected.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This function will re-distribute the pixel values across the given range so that there will be (approximately) equal numbers of pixels with each pixel value (0 to 255). Input pixels with values above or below the threshold values are not modified in the output.

Can be used to extend the dynamic range of an image.

When applied to multi-channel (RGB, RGBA) images, each channel is modified independently of the others; because of this, colors may shift. See BrightnessHistogramEqualizeCommand for a similar command that doesn't cause this color shift.

This command processes the image In-Place.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
BrightnessHistogramEqualizeCommand


HistogramEqualizeCommand Constructor

Overload List
 | Name | Description
Public method | HistogramEqualizeCommand | Creates a new instance of HistogramEqualizeCommand.
Public method | HistogramEqualizeCommand(Int32, Int32) | Creates a new instance of HistogramEqualizeCommand specifying the threshold levels.
Protected method | HistogramEqualizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of HistogramEqualizeCommand from serialization information.
Top
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand Constructor

Creates a new instance of HistogramEqualizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HistogramEqualizeCommand()
Public Sub New
See Also

Reference

HistogramEqualizeCommand Class
HistogramEqualizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand Constructor (Int32, Int32)

Creates a new instance of HistogramEqualizeCommand specifying the threshold levels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HistogramEqualizeCommand(
    int lowThreshold,
    int highThreshold
)
Public Sub New (
    lowThreshold As Integer,
    highThreshold As Integer
)

Parameters

lowThreshold
Type: SystemInt32
Pixels are uneffected below this value. (0 - 255)
highThreshold
Type: SystemInt32
Pixels are uneffected above this value. (0 - 255)
Exceptions
Exception | Condition
 | Thrown if either argument is less than 0 or greater than 255.
See Also

Reference

HistogramEqualizeCommand Class
HistogramEqualizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HistogramEqualizeCommand from serialization information.
Creates a new instance of HistogramEqualizeCommand specifying the threshold values.
Creates a new instance of HistogramEqualizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HistogramEqualizeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HistogramEqualizeCommand Class
HistogramEqualizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand Properties

The HistogramEqualizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | HighThreshold | Gets or sets a high threshold value above which pixels are uneffected.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowThreshold | Gets or sets a low threshold value below which pixels are uneffected.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.ChannelsToProcess Property

HistogramEqualizeCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.HighThreshold Property

HistogramEqualizeCommandHighThreshold Property

Gets or sets a high threshold value above which pixels are uneffected.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int HighThreshold { get; set; }
Public Property HighThreshold As Integer
    Get
    Set

Property Value

Type: Int32
A high threshold value where pixels are uneffected.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks
Valid values are from 0 to 255.
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.InPlaceProcessing Property

HistogramEqualizeCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.LowThreshold Property

HistogramEqualizeCommandLowThreshold Property

Gets or sets a low threshold value below which pixels are uneffected.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LowThreshold { get; set; }
Public Property LowThreshold As Integer
    Get
    Set

Property Value

Type: Int32
A low threshold value below which pixels are uneffected.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks
Valid values are from 0 to 255.
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.SupportedPixelFormats Property

HistogramEqualizeCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand Methods

The HistogramEqualizeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.GetObjectData Method

HistogramEqualizeCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.PerformActualCommand Method

HistogramEqualizeCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramEqualizeCommand.VerifyProperties Method

HistogramEqualizeCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

HistogramEqualizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Class

Performs a histogram stretch on an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsHistogramStretchCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HistogramStretchCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class HistogramStretchCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The HistogramStretchCommand type exposes the following members.

Constructors
 | Name | Description
Public method | HistogramStretchCommand | Creates a new instance of HistogramStretchCommand.
Public method | HistogramStretchCommand(Double, Double) | Creates a new instance of HistogramStretchCommand specifying the low and high limits.
Protected method | HistogramStretchCommand(SerializationInfo, StreamingContext) | Creates a new instance of HistogramStretchCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | HighLimit | Gets or sets the percent of pixels to set to 255.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowLimit | Gets or sets the percent of pixels to set to 0.
Public property | MidPoint | Gets or sets the pixel value to set to middle intensity. This value must be from 1 to 254.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | UseMidPoint | Gets or sets a value indicating whether the MidPoint property will be used to divide output range.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Re-distribute the pixel values across the given range by first setting values above and below the thresholds to zero and 255 respectively and then scaling the remaining values to span the entire zero to 255 range.

This can be used to increase the contrast and extend the dynamic range of an image.

When applied to multi-channel (RGB, RGBA) images, each channel is modified independently of the others; because of this, colors may shift. See BrightnessHistogramStretchCommand for a similar command that doesn't cause this color shift.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Constructor

Overload List
 | Name | Description
Public method | HistogramStretchCommand | Creates a new instance of HistogramStretchCommand.
Public method | HistogramStretchCommand(Double, Double) | Creates a new instance of HistogramStretchCommand specifying the low and high limits.
Protected method | HistogramStretchCommand(SerializationInfo, StreamingContext) | Creates a new instance of HistogramStretchCommand from serialization information.
Top
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Constructor

Creates a new instance of HistogramStretchCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HistogramStretchCommand()
Public Sub New
See Also

Reference

HistogramStretchCommand Class
HistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Constructor (Double, Double)

Creates a new instance of HistogramStretchCommand specifying the low and high limits.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HistogramStretchCommand(
    double lowLimit,
    double highLimit
)
Public Sub New (
    lowLimit As Double,
    highLimit As Double
)

Parameters

lowLimit
Type: SystemDouble
Percent of pixels to set to 0. (0 to 100)
highLimit
Type: SystemDouble
Percent of pixels to set to 255. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if either argument is less than 0 or greater than 100.
See Also

Reference

HistogramStretchCommand Class
HistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HistogramStretchCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HistogramStretchCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HistogramStretchCommand Class
HistogramStretchCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Properties

The HistogramStretchCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | HighLimit | Gets or sets the percent of pixels to set to 255.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | LowLimit | Gets or sets the percent of pixels to set to 0.
Public property | MidPoint | Gets or sets the pixel value to set to middle intensity. This value must be from 1 to 254.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | UseMidPoint | Gets or sets a value indicating whether the MidPoint property will be used to divide output range.
Top
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.ChannelsToProcess Property

HistogramStretchCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag of changes to process.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.HighLimit Property

HistogramStretchCommandHighLimit Property

Gets or sets the percent of pixels to set to 255.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HighLimit { get; set; }
Public Property HighLimit As Double
    Get
    Set

Property Value

Type: Double
Percent of pixels to set to 255.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100. The sum of HighLimit and LowLimit must not exceed 100.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.InPlaceProcessing Property

HistogramStretchCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.LowLimit Property

HistogramStretchCommandLowLimit Property

Gets or sets the percent of pixels to set to 0.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LowLimit { get; set; }
Public Property LowLimit As Double
    Get
    Set

Property Value

Type: Double
Percent of pixels to set to 0.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100. The sum of HighLimit and LowLimit must not exceed 100.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.MidPoint Property

HistogramStretchCommandMidPoint Property

Gets or sets the pixel value to set to middle intensity. This value must be from 1 to 254.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MidPoint { get; set; }
Public Property MidPoint As Integer
    Get
    Set

Property Value

Type: Int32
The middle intensity value.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.SupportedPixelFormats Property

HistogramStretchCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.UseMidPoint Property

HistogramStretchCommandUseMidPoint Property

Gets or sets a value indicating whether the MidPoint property will be used to divide output range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseMidPoint { get; set; }
Public Property UseMidPoint As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the MidPoint property is used.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand Methods

The HistogramStretchCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.GetObjectData Method

HistogramStretchCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.PerformActualCommand Method

HistogramStretchCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


HistogramStretchCommand.VerifyProperties Method

HistogramStretchCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ImageProcessException | HighLimit and LowLimit must add up to a value less than 100
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

HistogramStretchCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Class

Corrects the tonal range and color balance by adjusting the shadow, midtone, and highlights of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.ChannelsApplyLutCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsLevelsCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LevelsCommand : ApplyLutCommandBase,
    IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class LevelsCommand
    Inherits ApplyLutCommandBase
    Implements IThreadableCommand, ICloneable

The LevelsCommand type exposes the following members.

Constructors
 | Name | Description
Public method | LevelsCommand | Creates a new instance of LevelsCommand.
Protected method | LevelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of LevelsCommand from serialization information.
Public method | LevelsCommand(Color, Color, Color, Color) | Creates a new instance of LevelsCommand specifying the shadow and highlight colors, and the output range.
Public method | LevelsCommand(Color, Color, Color, Color, GammaColor) | Creates a new instance of LevelsCommand specifying shadow color, highlight color, output range and gamma.
Public method | LevelsCommand(Color, Color, Color, Color, Color) | Creates a new instance of LevelsCommand specifying shadow, midtone and highlight colors, and the output range.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter.
Public property | HighlightColor | Gets or sets the white point in the image used as an input clipping point.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | MidtoneColor | Gets or sets the gray point in the image used as a gamma adjustment.
Public property | OutputRangeHigh | Gets or sets the light color value to stretch the histogram to.
Public property | OutputRangeLow | Gets or sets the dark color value to stretch the histogram to.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | ShadowColor | Gets or sets the black point in the image used as an input clipping point.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Protected method | InternalActualCommand | This method performs the level manipulation on the image.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
Remarks
The shadow, midtone, and highlights are often manually determined from an "eyedropper" tool.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Constructor

Creates a new instance of LevelsCommand.
Overload List
 | Name | Description
Public method | LevelsCommand | Creates a new instance of LevelsCommand.
Protected method | LevelsCommand(SerializationInfo, StreamingContext) | Creates a new instance of LevelsCommand from serialization information.
Public method | LevelsCommand(Color, Color, Color, Color) | Creates a new instance of LevelsCommand specifying the shadow and highlight colors, and the output range.
Public method | LevelsCommand(Color, Color, Color, Color, GammaColor) | Creates a new instance of LevelsCommand specifying shadow color, highlight color, output range and gamma.
Public method | LevelsCommand(Color, Color, Color, Color, Color) | Creates a new instance of LevelsCommand specifying shadow, midtone and highlight colors, and the output range.
Top
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Constructor

Creates a new instance of LevelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LevelsCommand()
Public Sub New
See Also

Reference

LevelsCommand Class
LevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LevelsCommand from serialization information.
Creates a new instance of LevelsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LevelsCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LevelsCommand Class
LevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Constructor (Color, Color, Color, Color)

Creates a new instance of LevelsCommand specifying the shadow and highlight colors, and the output range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LevelsCommand(
    Color shadowColor,
    Color highlightColor,
    Color outputRangeLow,
    Color outputRangeHigh
)
Public Sub New (
    shadowColor As Color,
    highlightColor As Color,
    outputRangeLow As Color,
    outputRangeHigh As Color
)

Parameters

shadowColor
Type: System.DrawingColor
The black point in the image used as an input clipping point.
highlightColor
Type: System.DrawingColor
The white point in the image used as an input clipping point.
outputRangeLow
Type: System.DrawingColor
The dark color value to stretch the histogram to.
outputRangeHigh
Type: System.DrawingColor
The light color value to stretch the histogram to.
See Also

Reference

LevelsCommand Class
LevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Constructor (Color, Color, Color, Color, GammaColor)

Creates a new instance of LevelsCommand specifying shadow color, highlight color, output range and gamma.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LevelsCommand(
    Color shadowColor,
    Color highlightColor,
    Color outputRangeLow,
    Color outputRangeHigh,
    GammaColor gamma
)
Public Sub New (
    shadowColor As Color,
    highlightColor As Color,
    outputRangeLow As Color,
    outputRangeHigh As Color,
    gamma As GammaColor
)

Parameters

shadowColor
Type: System.DrawingColor
The black point in the image used as an input clipping point.
highlightColor
Type: System.DrawingColor
The white point in the image used as an input clipping point.
outputRangeLow
Type: System.DrawingColor
The dark color value to stretch the histogram to.
outputRangeHigh
Type: System.DrawingColor
The light color value to stretch the histogram to.
gamma
Type: Atalasoft.Imaging.ImageProcessing.EffectsGammaColor
The gamma adjustment to apply when running the filter.
See Also

Reference

LevelsCommand Class
LevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Constructor (Color, Color, Color, Color, Color)

Creates a new instance of LevelsCommand specifying shadow, midtone and highlight colors, and the output range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LevelsCommand(
    Color shadowColor,
    Color midtoneColor,
    Color highlightColor,
    Color outputRangeLow,
    Color outputRangeHigh
)
Public Sub New (
    shadowColor As Color,
    midtoneColor As Color,
    highlightColor As Color,
    outputRangeLow As Color,
    outputRangeHigh As Color
)

Parameters

shadowColor
Type: System.DrawingColor
The black point in the image used as an input clipping point.
midtoneColor
Type: System.DrawingColor
The gray point in the image used as a gamma adjustment.
highlightColor
Type: System.DrawingColor
The white point in the image used as an input clipping point.
outputRangeLow
Type: System.DrawingColor
The dark color value to stretch the histogram to.
outputRangeHigh
Type: System.DrawingColor
The light color value to stretch the histogram to.
See Also

Reference

LevelsCommand Class
LevelsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Properties

The LevelsCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Gamma | Gets or sets the gamma adjustment to apply when running the filter.
Public property | HighlightColor | Gets or sets the white point in the image used as an input clipping point.
Public property | InPlaceProcessing | Indicates whether or not the command will operate on the source image alone. (Overrides ApplyLutCommandBaseInPlaceProcessing.)
Public property | MidtoneColor | Gets or sets the gray point in the image used as a gamma adjustment.
Public property | OutputRangeHigh | Gets or sets the light color value to stretch the histogram to.
Public property | OutputRangeLow | Gets or sets the dark color value to stretch the histogram to.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | ShadowColor | Gets or sets the black point in the image used as an input clipping point.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ApplyLutCommandBaseSupportedPixelFormats.)
Top
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.AutoThread Property

LevelsCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.Gamma Property

LevelsCommandGamma Property

Gets or sets the gamma adjustment to apply when running the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GammaColor Gamma { get; set; }
Public Property Gamma As GammaColor
    Get
    Set

Property Value

Type: GammaColor
The gamma adjustment to apply when running the filter.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.HighlightColor Property

LevelsCommandHighlightColor Property

Gets or sets the white point in the image used as an input clipping point.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HighlightColor { get; set; }
Public Property HighlightColor As Color
    Get
    Set

Property Value

Type: Color
The white point in the image used as an input clipping point.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.InPlaceProcessing Property

LevelsCommandInPlaceProcessing Property

Indicates whether or not the command will operate on the source image alone.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
Always returns true.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.MidtoneColor Property

LevelsCommandMidtoneColor Property

Gets or sets the gray point in the image used as a gamma adjustment.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color MidtoneColor { get; set; }
Public Property MidtoneColor As Color
    Get
    Set

Property Value

Type: Color
The gray point in the image used as a gamma adjustment.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.OutputRangeHigh Property

LevelsCommandOutputRangeHigh Property

Gets or sets the light color value to stretch the histogram to.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OutputRangeHigh { get; set; }
Public Property OutputRangeHigh As Color
    Get
    Set

Property Value

Type: Color
The light color value to stretch the histogram to.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.OutputRangeLow Property

LevelsCommandOutputRangeLow Property

Gets or sets the dark color value to stretch the histogram to.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OutputRangeLow { get; set; }
Public Property OutputRangeLow As Color
    Get
    Set

Property Value

Type: Color
The dark color value to stretch the histogram to.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.ShadowColor Property

LevelsCommandShadowColor Property

Gets or sets the black point in the image used as an input clipping point.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ShadowColor { get; set; }
Public Property ShadowColor As Color
    Get
    Set

Property Value

Type: Color
The black point in the image used as an input clipping point.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.SupportedPixelFormats Property

LevelsCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand Methods

The LevelsCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ApplyLutCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Future use. (Overrides ApplyLutCommandBaseImplementMe.)
Protected method | InternalActualCommand | This method performs the level manipulation on the image.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | LLClearChannelLut | Low-level implementation to clear the channel lookup table. (Inherited from ApplyLutCommandBase.)
Protected method | LLGetChannelLut | Returns the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Byte) | Sets the loop-up-table for a single channel. (Inherited from ApplyLutCommandBase.)
Protected method | LLSetChannelLut(ChannelFlags, Int32) | Low-level implementation of set channel look up table. (Inherited from ApplyLutCommandBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ApplyLutCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ApplyLutCommandBaseVerifyProperties(AtalaImage).)
Top
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.AdjustBands Method

LevelsCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.Clone Method

LevelsCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the LevelsCommand.

Implements

ICloneableClone
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.GetObjectData Method

LevelsCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.ImplementMe Method

LevelsCommandImplementMe Method

Future use.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.InternalActualCommand Method

LevelsCommandInternalActualCommand Method

This method performs the level manipulation on the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage InternalActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Function InternalActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
Null (Nothing in VB).
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.PerformActualCommand Method

LevelsCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.PerformSectionCommand Method

LevelsCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


LevelsCommand.VerifyProperties Method

LevelsCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

LevelsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Class

Generate a mosaic (large pixel) image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsMosaicCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MosaicCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MosaicCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MosaicCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MosaicCommand | Creates a new instance of MosaicCommand.
Public method | MosaicCommand(Int32) | Creates a new instance of MosaicCommand specifying the square size.
Protected method | MosaicCommand(SerializationInfo, StreamingContext) | Creates a new instance of MosaicCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SquareSize | Gets or sets the size of the mosaic tiles.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a 24 or 32 bit image. If the source image is not continuous, it will throw the ArgumentException
Examples
Mosaic (C#)
Copy
// Load the image to work with.
AtalaImage image = new AtalaImage(@"D:\Test Images\1save.jpg");

// Apply a mosaic effect to the middle of the image.
Rectangle rc = new Rectangle(20, 20, image.Width - 40, image.Height - 40);
MosaicCommand mos = new MosaicCommand(10);
mos.RegionOfInterest = new RegionOfInterest(rc);
mos.Apply(image);
MosaicVB (Visual Basic)
Copy
' Load the image to work with.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1save.jpg")

' Apply a mosaic effect to the middle of the image.
Dim rc As Rectangle =  New Rectangle(20,20,image.Width - 40,image.Height - 40)
Dim mos As MosaicCommand =  New MosaicCommand(10)
mos.RegionOfInterest = New RegionOfInterest(rc)
mos.Apply(image)
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Constructor

Overload List
 | Name | Description
Public method | MosaicCommand | Creates a new instance of MosaicCommand.
Public method | MosaicCommand(Int32) | Creates a new instance of MosaicCommand specifying the square size.
Protected method | MosaicCommand(SerializationInfo, StreamingContext) | Creates a new instance of MosaicCommand from serialization information.
Top
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Constructor

Creates a new instance of MosaicCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MosaicCommand()
Public Sub New
See Also

Reference

MosaicCommand Class
MosaicCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Constructor (Int32)

Creates a new instance of MosaicCommand specifying the square size.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MosaicCommand(
    int squareSize
)
Public Sub New (
    squareSize As Integer
)

Parameters

squareSize
Type: SystemInt32

The size of the mosaic tiles.

Exceptions
Exception | Condition
 | Thrown if squareSize is less than 2.
See Also

Reference

MosaicCommand Class
MosaicCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MosaicCommand from serialization information.
Creates a new instance of MosaicCommand specifying squareSize.
Creates a new instance of MosaicCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MosaicCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

MosaicCommand Class
MosaicCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Properties

The MosaicCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SquareSize | Gets or sets the size of the mosaic tiles.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand.InPlaceProcessing Property

MosaicCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand.SquareSize Property

MosaicCommandSquareSize Property

Gets or sets the size of the mosaic tiles.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SquareSize { get; set; }
Public Property SquareSize As Integer
    Get
    Set

Property Value

Type: Int32

The size of the mosaic tiles.

Exceptions
Exception | Condition
 | Thrown if value is less than 2.
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand.SupportedPixelFormats Property

MosaicCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand Methods

The MosaicCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand.GetObjectData Method

MosaicCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand.PerformActualCommand Method

MosaicCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | SquareSize;The square size cannot be larger than the image or region.
See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MosaicCommand.VerifyProperties Method

MosaicCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | Image must be 24bit or higher.;image
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MosaicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Class

Create an effect to simulate motion blur on an image
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsMotionBlurCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MotionBlurCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class MotionBlurCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The MotionBlurCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MotionBlurCommand | Creates a new instance of MotionBlurCommand.
Public method | MotionBlurCommand(Double, Int32) | Constructs a new MotionBlurCommand with the provided distance and number of steps.
Protected method | MotionBlurCommand(SerializationInfo, StreamingContext) | Creates a new instance of MotionBlurCommand from serialization information.
Public method | MotionBlurCommand(Double, Int32, MotionBlurMode) | Constructs a new MotionBlurCommand with the provided distance, number of steps and mode.
Public method | MotionBlurCommand(Double, Int32, MotionBlurMode, Double) | Constructs a new MotionBlurCommand with the provided distance, number of steps, mode and angle.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of the blur in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Distance | Gets or sets the distance of the blur in pixels.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the manner of the blur.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Steps | Gets or sets the number of steps in the blur.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Constructor

Constructs a new MotionBlurCommand with the provided information.
Overload List
 | Name | Description
Public method | MotionBlurCommand | Creates a new instance of MotionBlurCommand.
Public method | MotionBlurCommand(Double, Int32) | Constructs a new MotionBlurCommand with the provided distance and number of steps.
Protected method | MotionBlurCommand(SerializationInfo, StreamingContext) | Creates a new instance of MotionBlurCommand from serialization information.
Public method | MotionBlurCommand(Double, Int32, MotionBlurMode) | Constructs a new MotionBlurCommand with the provided distance, number of steps and mode.
Public method | MotionBlurCommand(Double, Int32, MotionBlurMode, Double) | Constructs a new MotionBlurCommand with the provided distance, number of steps, mode and angle.
Top
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Constructor

Creates a new instance of MotionBlurCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MotionBlurCommand()
Public Sub New
See Also

Reference

MotionBlurCommand Class
MotionBlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Constructor (Double, Int32)

Constructs a new MotionBlurCommand with the provided distance and number of steps.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MotionBlurCommand(
    double distance,
    int steps
)
Public Sub New (
    distance As Double,
    steps As Integer
)

Parameters

distance
Type: SystemDouble
The distance of the blur.
steps
Type: SystemInt32
The number of steps used in the blur.
Exceptions
Exception | Condition
 | Thrown if the steps argument is less than 1.
See Also

Reference

MotionBlurCommand Class
MotionBlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MotionBlurCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MotionBlurCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

MotionBlurCommand Class
MotionBlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Constructor (Double, Int32, MotionBlurMode)

Constructs a new MotionBlurCommand with the provided distance, number of steps and mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MotionBlurCommand(
    double distance,
    int steps,
    MotionBlurMode mode
)
Public Sub New (
    distance As Double,
    steps As Integer,
    mode As MotionBlurMode
)

Parameters

distance
Type: SystemDouble
The distance of the blur.
steps
Type: SystemInt32
The number of steps used in the blur.
mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsMotionBlurMode
The manner of the blur.
Exceptions
Exception | Condition
 | Thrown if the steps argument is less than 1.
See Also

Reference

MotionBlurCommand Class
MotionBlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Constructor (Double, Int32, MotionBlurMode, Double)

Constructs a new MotionBlurCommand with the provided distance, number of steps, mode and angle.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MotionBlurCommand(
    double distance,
    int steps,
    MotionBlurMode mode,
    double angle
)
Public Sub New (
    distance As Double,
    steps As Integer,
    mode As MotionBlurMode,
    angle As Double
)

Parameters

distance
Type: SystemDouble
The distance of the blur.
steps
Type: SystemInt32
The number of steps used in the blur.
mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsMotionBlurMode
The manner of the blur.
angle
Type: SystemDouble
The angle of the blur in degrees.
Exceptions
Exception | Condition
 | Thrown if the steps argument is less than 1.
See Also

Reference

MotionBlurCommand Class
MotionBlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Properties

The MotionBlurCommand type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of the blur in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Distance | Gets or sets the distance of the blur in pixels.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the manner of the blur.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Steps | Gets or sets the number of steps in the blur.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.Angle Property

MotionBlurCommandAngle Property

Gets or sets the angle of the blur in degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle of the blur in degrees.
Remarks
Default is 0.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.AutoThread Property

MotionBlurCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.Distance Property

MotionBlurCommandDistance Property

Gets or sets the distance of the blur in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Distance { get; set; }
Public Property Distance As Double
    Get
    Set

Property Value

Type: Double
The distance of the blur in pixels.
Remarks
Default value is 10.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.Mode Property

MotionBlurCommandMode Property

Gets or sets the manner of the blur.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MotionBlurMode Mode { get; set; }
Public Property Mode As MotionBlurMode
    Get
    Set

Property Value

Type: MotionBlurMode
The blur mode to use.
Remarks
Default value is MotionBlurMode.Linear.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.Steps Property

MotionBlurCommandSteps Property

Gets or sets the number of steps in the blur.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Steps { get; set; }
Public Property Steps As Integer
    Get
    Set

Property Value

Type: Int32
The number of steps in the blur.
Exceptions
Exception | Condition
 | Thrown if the value is less than 1.
Remarks
This value must be at least 1. Default value is 2.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.SupportedPixelFormats Property

MotionBlurCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel8bppIndexed
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand Methods

The MotionBlurCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.AdjustBands Method

MotionBlurCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.Clone Method

MotionBlurCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the MotionBlurCommand.

Implements

ICloneableClone
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.GetObjectData Method

MotionBlurCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.PerformActualCommand Method

MotionBlurCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.PerformSectionCommand Method

MotionBlurCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.SelectPreferredPixelFormat Method

MotionBlurCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurCommand.VerifyProperties Method

MotionBlurCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MotionBlurCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


MotionBlurMode Enumeration

Defines the manner of blur for the MotionBlurCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MotionBlurMode
Public Enumeration MotionBlurMode
Members
Member name | Description
Linear | The image is blurred in a line (traditional motion blur).
Radial | The image is blurred in a circle around the center point.
Zoom | The image is blurred as if zooming in.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand Class

Neutral Density (ND) Graduated Filter, Flexible in Location, Hardness and Density.

ND filters are used by photographers to compress the dynamic range of high contrast scenes into a smaller range which can be better viewed or printed. These filters feature a 'dark' half and a clear half, with the transition either soft or hard depending on the effect desired. The dark half is typically either 2 or 3 "f-stops" darker. Multiple filters can be applied to achieve a greater or more complex effect.

A typical use for an ND filter is to darken the bright skies in an image to bring its tonal values more in line with those of the darker foreground. Sunrises, sunsets, horizon shots, canyons and other contrasty landscapes are good candidates for an ND filter.

The PhotoEffects ND Graduated is incredibly flexible, allowing you to adjust where in the image you want the effect applied (using the Location property), how dramatic you want the effect (using the Density parameter), how hard or soft you want the transition (using the Hardness property), how large an area you want the effect portion of the filter to cover (using the Radius property), and the angle at which you want the effect (using the Angle property). Angled effects are important if you have a diagonal sun/shade line or other non-horizontal dark/light division in your image.

The PhotoEffects ND filter can even provide "impossible" effects by allowing you to set the density of the "light" side of the filter. With traditional filters this is always transparent (a value of 1) but with the PhotoEffects filter you can set the starting density to be brighter or darker.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsNDGradFilterCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class NDGradFilterCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class NDGradFilterCommand
    Inherits ImageCommand
    Implements ISerializable

The NDGradFilterCommand type exposes the following members.

Constructors
 | Name | Description
Public method | NDGradFilterCommand | Initializes a new instance of the NDGradFilterCommand class.
Protected method | NDGradFilterCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the NDGradFilterCommand class with serialized data.
Public method | NDGradFilterCommand(Double, Double, Double, Double) | Initializes a new instance of the NDGradFilterCommand class with values for location, density, radius, and hardness.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of effect in degrees. 0 is horizontal (horizon). +/- 90 is vertical, etc.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Density | Gets or sets the density - the strength of the filter, roughly in f-stops.
Public property | FilterType | Gets or sets the filter to use for the ND Graduated Filter.
Public property | Hardness | Gets or sets a value indicating the hardness of the filter, expressed as a Gamma / Power value. 1 is nearly linear, higher values are higher gamma/contrast transitions
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Location | Gets or sets the location of the center of the filter effect from the top of the image (0) to the bottom (1).
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Radius | Gets or sets the radius.
Public property | StartDensity | Gets or sets the starting density.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand Constructor

Overload List
 | Name | Description
Public method | NDGradFilterCommand | Initializes a new instance of the NDGradFilterCommand class.
Protected method | NDGradFilterCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the NDGradFilterCommand class with serialized data.
Public method | NDGradFilterCommand(Double, Double, Double, Double) | Initializes a new instance of the NDGradFilterCommand class with values for location, density, radius, and hardness.
Top
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand Constructor

Initializes a new instance of the NDGradFilterCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NDGradFilterCommand()
Public Sub New
See Also

Reference

NDGradFilterCommand Class
NDGradFilterCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the NDGradFilterCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected NDGradFilterCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

NDGradFilterCommand Class
NDGradFilterCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand Constructor (Double, Double, Double, Double)

Initializes a new instance of the NDGradFilterCommand class with values for location, density, radius, and hardness.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NDGradFilterCommand(
    double location,
    double density,
    double radius,
    double hardness
)
Public Sub New (
    location As Double,
    density As Double,
    radius As Double,
    hardness As Double
)

Parameters

location
Type: SystemDouble
The location of the filter.
density
Type: SystemDouble
The density of the filter.
radius
Type: SystemDouble
The radius of the filter.
hardness
Type: SystemDouble
The hardness of the filter.
See Also

Reference

NDGradFilterCommand Class
NDGradFilterCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand Properties

The NDGradFilterCommand type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of effect in degrees. 0 is horizontal (horizon). +/- 90 is vertical, etc.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Density | Gets or sets the density - the strength of the filter, roughly in f-stops.
Public property | FilterType | Gets or sets the filter to use for the ND Graduated Filter.
Public property | Hardness | Gets or sets a value indicating the hardness of the filter, expressed as a Gamma / Power value. 1 is nearly linear, higher values are higher gamma/contrast transitions
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Location | Gets or sets the location of the center of the filter effect from the top of the image (0) to the bottom (1).
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Radius | Gets or sets the radius.
Public property | StartDensity | Gets or sets the starting density.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.Angle Property

NDGradFilterCommandAngle Property

Gets or sets the angle of effect in degrees. 0 is horizontal (horizon). +/- 90 is vertical, etc.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.Density Property

NDGradFilterCommandDensity Property

Gets or sets the density - the strength of the filter, roughly in f-stops.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Density { get; set; }
Public Property Density As Double
    Get
    Set

Property Value

Type: Double
Remarks
Typical physical ND filters are either 2-stop or 3-stop filters, sometimes used in combination to provide up to 5-stops of filtering. Values can range from 1 to 100. Default value is 2.0.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.FilterType Property

NDGradFilterCommandFilterType Property

Gets or sets the filter to use for the ND Graduated Filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NDGradFilterCommandFilterOfType FilterType { get; set; }
Public Property FilterType As NDGradFilterCommandFilterOfType
    Get
    Set

Property Value

Type: NDGradFilterCommandFilterOfType
Remarks
Corner filters are for burning corners as a radius effect. Linear FilterType is for emulating traditional ND filters with a 'horizon-line' that separates light from dark areas.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.Hardness Property

NDGradFilterCommandHardness Property

Gets or sets a value indicating the hardness of the filter, expressed as a Gamma / Power value. 1 is nearly linear, higher values are higher gamma/contrast transitions

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Hardness { get; set; }
Public Property Hardness As Double
    Get
    Set

Property Value

Type: Double
Exceptions
Exception | Condition
 | Throws when value is less than 0.1 or greater than 100.
Remarks
Default value is 1.0
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.InPlaceProcessing Property

NDGradFilterCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.Location Property

NDGradFilterCommandLocation Property

Gets or sets the location of the center of the filter effect from the top of the image (0) to the bottom (1).

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Location { get; set; }
Public Property Location As Double
    Get
    Set

Property Value

Type: Double
Remarks
Default value is .5, halfway down the image--or halfway across the image when a 90 degree Angle 'vertical' effect is specified.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.Radius Property

NDGradFilterCommandRadius Property

Gets or sets the radius.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
Remarks
The percentage of the image to use as the radius of the filter effect. Default is (.1), 10%, calculated as 10% of the shorter side (.1)
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.StartDensity Property

NDGradFilterCommandStartDensity Property

Gets or sets the starting density.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double StartDensity { get; set; }
Public Property StartDensity As Double
    Get
    Set

Property Value

Type: Double
Remarks
Almost always 1--meaning no effect on one side of the ND horizon, except when we are dodging instead of burning or creating an ND filter. You should normally leave this value alone unless you are looking for a particular special effect or creating your own corner burn effect. Values can range from 0.01 to 100.0
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.SupportedPixelFormats Property

NDGradFilterCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


NDGradFilterCommand Methods

The NDGradFilterCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.GetObjectData Method

NDGradFilterCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.PerformActualCommand Method

NDGradFilterCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.VerifyProperties Method

NDGradFilterCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

NDGradFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


NDGradFilterCommand.FilterOfType Enumeration

NDGradFilterCommandFilterOfType Enumeration

Type of the Neutral Density Graduated filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FilterOfType
Public Enumeration FilterOfType
Members
Member name | Description
FilterLine | Traditional linear filter for a 'horizon' effect.
FilterCorner | Radial filter for burning corners.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Class

This effect makes an image appear as if it's an oil painting.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsOilPaintCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OilPaintCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class OilPaintCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The OilPaintCommand type exposes the following members.

Constructors
 | Name | Description
Public method | OilPaintCommand | Creates a new instance of OilPaintCommand.
Public method | OilPaintCommand(Int32, Int32) | Creates a new instance of OilPaintCommand specifying brush width and max density.
Protected method | OilPaintCommand(SerializationInfo, StreamingContext) | Creates a new instance of OilPaintCommand from serialization information.
Public method | OilPaintCommand(Int32, Int32, Boolean, Boolean) | Creates a new instance of OilPaintCommand specifying the brush width, max density, color edges and contrast enhancement.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlendColorEdges | Gets or sets a value indicating whether the edges use color blending.
Public property | BrushWidth | Gets or set the width of the virtual brush.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | EnhanceContrast | Gets or sets a value indicating whether the image contrast is enhanced.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxDensity | Gets or sets the internal quantization level.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Constructor

Creates a new instance of OilPaintCommand.
Overload List
 | Name | Description
Public method | OilPaintCommand | Creates a new instance of OilPaintCommand.
Public method | OilPaintCommand(Int32, Int32) | Creates a new instance of OilPaintCommand specifying brush width and max density.
Protected method | OilPaintCommand(SerializationInfo, StreamingContext) | Creates a new instance of OilPaintCommand from serialization information.
Public method | OilPaintCommand(Int32, Int32, Boolean, Boolean) | Creates a new instance of OilPaintCommand specifying the brush width, max density, color edges and contrast enhancement.
Top
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Constructor

Creates a new instance of OilPaintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OilPaintCommand()
Public Sub New
See Also

Reference

OilPaintCommand Class
OilPaintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Constructor (Int32, Int32)

Creates a new instance of OilPaintCommand specifying brush width and max density.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OilPaintCommand(
    int brushWidth,
    int maxDensity
)
Public Sub New (
    brushWidth As Integer,
    maxDensity As Integer
)

Parameters

brushWidth
Type: SystemInt32
The width of the virtual brush. Must be greater than zero.
maxDensity
Type: SystemInt32
The internal quantization level. (0 to 255)
Exceptions
Exception | Condition
 | Thrown if the brushWidth is less than or equal to 0, or if maxDensity is less than 0 or greater than 255.
See Also

Reference

OilPaintCommand Class
OilPaintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of OilPaintCommand from serialization information.
Creates a new instance of OilPaintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OilPaintCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

OilPaintCommand Class
OilPaintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Constructor (Int32, Int32, Boolean, Boolean)

Creates a new instance of OilPaintCommand specifying the brush width, max density, color edges and contrast enhancement.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OilPaintCommand(
    int brushWidth,
    int maxDensity,
    bool blendColorEdges,
    bool enhanceContrast
)
Public Sub New (
    brushWidth As Integer,
    maxDensity As Integer,
    blendColorEdges As Boolean,
    enhanceContrast As Boolean
)

Parameters

brushWidth
Type: SystemInt32
The width of the virtual brush. Must be greater than zero.
maxDensity
Type: SystemInt32
The internal quantization level. (0 to 255)
blendColorEdges
Type: SystemBoolean
A value indicating whether the edges use color blending.
enhanceContrast
Type: SystemBoolean
A value indicating whether the image contrast is enhanced.
Exceptions
Exception | Condition
 | Thrown if the brushWidth is less than or equal to 0, or if maxDensity is less than 0 or greater than 255.
See Also

Reference

OilPaintCommand Class
OilPaintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Properties

The OilPaintCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlendColorEdges | Gets or sets a value indicating whether the edges use color blending.
Public property | BrushWidth | Gets or set the width of the virtual brush.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | EnhanceContrast | Gets or sets a value indicating whether the image contrast is enhanced.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxDensity | Gets or sets the internal quantization level.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.BlendColorEdges Property

OilPaintCommandBlendColorEdges Property

Gets or sets a value indicating whether the edges use color blending.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool BlendColorEdges { get; set; }
Public Property BlendColorEdges As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the edges use color blending.
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.BrushWidth Property

OilPaintCommandBrushWidth Property

Gets or set the width of the virtual brush.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BrushWidth { get; set; }
Public Property BrushWidth As Integer
    Get
    Set

Property Value

Type: Int32
The width of the virtual brush.
Exceptions
Exception | Condition
 | Thrown if value is not greater than 0.
Remarks
Low number work best ( 3, 4, 5, ... ).
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.EnhanceContrast Property

OilPaintCommandEnhanceContrast Property

Gets or sets a value indicating whether the image contrast is enhanced.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnhanceContrast { get; set; }
Public Property EnhanceContrast As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the image contrast is enhanced.
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.MaxDensity Property

OilPaintCommandMaxDensity Property

Gets or sets the internal quantization level.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxDensity { get; set; }
Public Property MaxDensity As Integer
    Get
    Set

Property Value

Type: Int32
The internal quantization level. (0 to 255)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.SupportedPixelFormats Property

OilPaintCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand Methods

The OilPaintCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.GetObjectData Method

OilPaintCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.PerformActualCommand Method

OilPaintCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.SelectPreferredPixelFormat Method

OilPaintCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


OilPaintCommand.VerifyProperties Method

OilPaintCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

OilPaintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Class

Makes an image appear cooler by adding blue and reducing red without affecting the overall tone or contrast of the image. This is similar to correcting the White Balance setting on a digital camera. The amount of cooling is controlled using the Effect parameter.

By default the command cools by about 20% (1.2), which is the equivalent at daylight color temperatures of about 800-1000 degrees of color temperature.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCoolerCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PhotoColorCoolerCommand : PhotoColorCorrectCommandBase
<SerializableAttribute>
Public Class PhotoColorCoolerCommand
    Inherits PhotoColorCorrectCommandBase

The PhotoColorCoolerCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoColorCoolerCommand | Initializes a new instance of the PhotoColorCoolerCommand class.
Public method | PhotoColorCoolerCommand(Double) | Initializes a new instance of the PhotoColorCoolerCommand class with specified cool effect value.
Protected method | PhotoColorCoolerCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorCoolerCommand class with serialized data.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Effect | Gets or sets cool effect value for the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from PhotoColorCorrectCommandBase.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhotoColorCorrectCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses. (Overrides PhotoColorCorrectCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides PhotoColorCorrectCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Constructor

Overload List
 | Name | Description
Public method | PhotoColorCoolerCommand | Initializes a new instance of the PhotoColorCoolerCommand class.
Public method | PhotoColorCoolerCommand(Double) | Initializes a new instance of the PhotoColorCoolerCommand class with specified cool effect value.
Protected method | PhotoColorCoolerCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorCoolerCommand class with serialized data.
Top
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Constructor

Initializes a new instance of the PhotoColorCoolerCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorCoolerCommand()
Public Sub New
See Also

Reference

PhotoColorCoolerCommand Class
PhotoColorCoolerCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Constructor (Double)

Initializes a new instance of the PhotoColorCoolerCommand class with specified cool effect value.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorCoolerCommand(
    double effect
)
Public Sub New (
    effect As Double
)

Parameters

effect
Type: SystemDouble
The cool effect to apply.
See Also

Reference

PhotoColorCoolerCommand Class
PhotoColorCoolerCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhotoColorCoolerCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PhotoColorCoolerCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

PhotoColorCoolerCommand Class
PhotoColorCoolerCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Properties

The PhotoColorCoolerCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Effect | Gets or sets cool effect value for the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand.Effect Property

PhotoColorCoolerCommandEffect Property

Gets or sets cool effect value for the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Effect { get; set; }
Public Property Effect As Double
    Get
    Set

Property Value

Type: Double
Remarks
Range of 1 (none) to 10. Default value is 20% (1.2).
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand Methods

The PhotoColorCoolerCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhotoColorCorrectCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses. (Overrides PhotoColorCorrectCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides PhotoColorCorrectCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand.GetObjectData Method

PhotoColorCoolerCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand.ImplementMe Method

PhotoColorCoolerCommandImplementMe Method

Marker method to be implemented in subclasses.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCoolerCommand.PerformActualCommand Method

PhotoColorCoolerCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoColorCoolerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Class

Allows color correction by enhancing or reducing specific colors without affecting image tone.

Specifically, Red, Green, Blue and Yellow can be enhanced or reduced by setting the corresponding effects properties to values >1 for enhancing and <1 for reducing. In all cases the overall tone and contrast of the image is preserved and only the color component of the image is altered.

This command is excellent for removing specific color casts or creating a slightly different effect in an image by changing the relative balance of colors.

It can also be used as a customized color enhancement filter by manually setting the values of the 4 color effect properties to increase the overall color of the image. This is similar to the underlying component of the Automatic Color Correction filters.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PhotoColorCorrectCommand : PhotoColorCorrectCommandBase
<SerializableAttribute>
Public Class PhotoColorCorrectCommand
    Inherits PhotoColorCorrectCommandBase

The PhotoColorCorrectCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoColorCorrectCommand | Initializes a new instance of the PhotoColorCorrectCommand class.
Protected method | PhotoColorCorrectCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorCorrectCommand class with serialized data.
Public method | PhotoColorCorrectCommand(Double, Double, Double, Double) | Initializes a new instance of the PhotoColorCorrectCommand class with values of effect on red, breen, blue, and yellow colors.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlueEffect | Gets or sets effect on the Blue color in the supplied image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | GreenEffect | Gets or sets effect on the Green color in the supplied image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides PhotoColorCorrectCommandBaseInPlaceProcessing.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RedEffect | Gets or sets effect on the Red color in the supplied image.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from PhotoColorCorrectCommandBase.)
Public property | YellowEffect | Gets or sets effect on the Yellow color in the supplied image.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhotoColorCorrectCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses. (Overrides PhotoColorCorrectCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from PhotoColorCorrectCommandBase.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Constructor

Overload List
 | Name | Description
Public method | PhotoColorCorrectCommand | Initializes a new instance of the PhotoColorCorrectCommand class.
Protected method | PhotoColorCorrectCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorCorrectCommand class with serialized data.
Public method | PhotoColorCorrectCommand(Double, Double, Double, Double) | Initializes a new instance of the PhotoColorCorrectCommand class with values of effect on red, breen, blue, and yellow colors.
Top
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Constructor

Initializes a new instance of the PhotoColorCorrectCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorCorrectCommand()
Public Sub New
See Also

Reference

PhotoColorCorrectCommand Class
PhotoColorCorrectCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhotoColorCorrectCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PhotoColorCorrectCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

PhotoColorCorrectCommand Class
PhotoColorCorrectCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Constructor (Double, Double, Double, Double)

Initializes a new instance of the PhotoColorCorrectCommand class with values of effect on red, breen, blue, and yellow colors.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorCorrectCommand(
    double redEffect,
    double greenEffect,
    double blueEffect,
    double yellowEffect
)
Public Sub New (
    redEffect As Double,
    greenEffect As Double,
    blueEffect As Double,
    yellowEffect As Double
)

Parameters

redEffect
Type: SystemDouble
Effect on the Red color.
greenEffect
Type: SystemDouble
Effect on the Green color.
blueEffect
Type: SystemDouble
Effect on the Blue color.
yellowEffect
Type: SystemDouble
Effect on the Yellow color.
See Also

Reference

PhotoColorCorrectCommand Class
PhotoColorCorrectCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Properties

The PhotoColorCorrectCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BlueEffect | Gets or sets effect on the Blue color in the supplied image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | GreenEffect | Gets or sets effect on the Green color in the supplied image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides PhotoColorCorrectCommandBaseInPlaceProcessing.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RedEffect | Gets or sets effect on the Red color in the supplied image.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from PhotoColorCorrectCommandBase.)
Public property | YellowEffect | Gets or sets effect on the Yellow color in the supplied image.
Top
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.BlueEffect Property

PhotoColorCorrectCommandBlueEffect Property

Gets or sets effect on the Blue color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BlueEffect { get; set; }
Public Property BlueEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.GreenEffect Property

PhotoColorCorrectCommandGreenEffect Property

Gets or sets effect on the Green color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GreenEffect { get; set; }
Public Property GreenEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.InPlaceProcessing Property

PhotoColorCorrectCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.RedEffect Property

PhotoColorCorrectCommandRedEffect Property

Gets or sets effect on the Red color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double RedEffect { get; set; }
Public Property RedEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.YellowEffect Property

PhotoColorCorrectCommandYellowEffect Property

Gets or sets effect on the Yellow color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double YellowEffect { get; set; }
Public Property YellowEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand Methods

The PhotoColorCorrectCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhotoColorCorrectCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses. (Overrides PhotoColorCorrectCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from PhotoColorCorrectCommandBase.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.GetObjectData Method

PhotoColorCorrectCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommand.ImplementMe Method

PhotoColorCorrectCommandImplementMe Method

Marker method to be implemented in subclasses.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

PhotoColorCorrectCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase Class

Base class for photo color correction filters.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCoolerCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorWarmerCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class PhotoColorCorrectCommandBase : ImageCommand,
    ISerializable
<SerializableAttribute>
Public MustInherit Class PhotoColorCorrectCommandBase
    Inherits ImageCommand
    Implements ISerializable

The PhotoColorCorrectCommandBase type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoColorCorrectCommandBase | Initializes a new instance of the PhotoColorCorrectCommandBase class.
Protected method | PhotoColorCorrectCommandBase(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorCorrectCommandBase class with serialized data.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image.
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image.
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image.
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase Constructor

Overload List
 | Name | Description
Public method | PhotoColorCorrectCommandBase | Initializes a new instance of the PhotoColorCorrectCommandBase class.
Protected method | PhotoColorCorrectCommandBase(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorCorrectCommandBase class with serialized data.
Top
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase Constructor

Initializes a new instance of the PhotoColorCorrectCommandBase class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorCorrectCommandBase()
Public Sub New
See Also

Reference

PhotoColorCorrectCommandBase Class
PhotoColorCorrectCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhotoColorCorrectCommandBase class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PhotoColorCorrectCommandBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

PhotoColorCorrectCommandBase Class
PhotoColorCorrectCommandBase Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase Properties

The PhotoColorCorrectCommandBase type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image.
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image.
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image.
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.InPlaceProcessing Property

PhotoColorCorrectCommandBaseInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.LLBlueEffect Property

PhotoColorCorrectCommandBaseLLBlueEffect Property

Gets or sets effect on the Blue color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected double LLBlueEffect { get; set; }
Protected Property LLBlueEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.LLGreenEffect Property

PhotoColorCorrectCommandBaseLLGreenEffect Property

Gets or sets effect on the Green color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected double LLGreenEffect { get; set; }
Protected Property LLGreenEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.LLRedEffect Property

PhotoColorCorrectCommandBaseLLRedEffect Property

Gets or sets effect on the Red color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected double LLRedEffect { get; set; }
Protected Property LLRedEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.LLYellowEffect Property

PhotoColorCorrectCommandBaseLLYellowEffect Property

Gets or sets effect on the Yellow color in the supplied image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected double LLYellowEffect { get; set; }
Protected Property LLYellowEffect As Double
    Get
    Set

Property Value

Type: Double
Remarks
> 1 increases. < 1 decreases. Values from 0 to 10.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.SupportedPixelFormats Property

PhotoColorCorrectCommandBaseSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


PhotoColorCorrectCommandBase Methods

The PhotoColorCorrectCommandBase type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.GetObjectData Method

PhotoColorCorrectCommandBaseGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.ImplementMe Method

PhotoColorCorrectCommandBaseImplementMe Method

Marker method to be implemented in subclasses.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void ImplementMe()
Protected MustOverride Sub ImplementMe
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.PerformActualCommand Method

PhotoColorCorrectCommandBasePerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorCorrectCommandBase.VerifyProperties Method

PhotoColorCorrectCommandBaseVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PhotoColorCorrectCommandBase Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand Class

PhotoEffects Color Magic is an Automated or semi-Automated Color Enhancement filter. It features a Proprietary Algorithm for improving the existing colors in most digital images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorMagicCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PhotoColorMagicCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class PhotoColorMagicCommand
    Inherits ImageCommand
    Implements ISerializable

The PhotoColorMagicCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoColorMagicCommand | Initializes a new instance of the PhotoColorMagicCommand class.
Protected method | PhotoColorMagicCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorMagicCommand class with serialized data.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ConstantColor | Gets or sets a value indicating whether to keep color balance constant.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RemoveGray | Gets or sets a value indicating whether to remove gray by setting Black Point in the image.
Public property | Strength | Gets or sets the strength of filter.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Because it preserves the overall color balance and tonal distribution of the original image, Color Magic can normally be used with the default parameters, making it simple to apply in a batch or even un-attended mode.

You can increase or decrease the amount of the effect using the Strength parameter.

Color Magic can also remove the "gray" from an image by automatically adjusting the shadow point in an image. This is similar to the shadow adjustment made by AutoLevels and is provide as an option in this filter primarily as a convenience and optimization. This feature is controlled using the RemoveGray parameter.

For a more complete correction of an image it is assumed that Color Magic would be run with an automated Tone correction command, such as AutoLevels or another Automatic Tone Correction from PhotoEffects.

In some cases users may desire a greater or even slightly un-natural coloring effect. Interesting effects can be achieved by turning off the ConstantColor property of Color Magic. Turning off ConstantColor allows Color Magic to enhance each color separately which provide dramatic effects but does not preserve the overall color balance of the image. In particular when combined with higher strength values this can be quite dramatic.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand Constructor

Overload List
 | Name | Description
Public method | PhotoColorMagicCommand | Initializes a new instance of the PhotoColorMagicCommand class.
Protected method | PhotoColorMagicCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorMagicCommand class with serialized data.
Top
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand Constructor

Initializes a new instance of the PhotoColorMagicCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorMagicCommand()
Public Sub New
See Also

Reference

PhotoColorMagicCommand Class
PhotoColorMagicCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhotoColorMagicCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PhotoColorMagicCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

PhotoColorMagicCommand Class
PhotoColorMagicCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand Properties

The PhotoColorMagicCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ConstantColor | Gets or sets a value indicating whether to keep color balance constant.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RemoveGray | Gets or sets a value indicating whether to remove gray by setting Black Point in the image.
Public property | Strength | Gets or sets the strength of filter.
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.ConstantColor Property

PhotoColorMagicCommandConstantColor Property

Gets or sets a value indicating whether to keep color balance constant.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ConstantColor { get; set; }
Public Property ConstantColor As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
If True then all colors modified similarly. If false then less 'colorful' colors will be amplified more--providing a more dramatic but less realistic effect.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.InPlaceProcessing Property

PhotoColorMagicCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.RemoveGray Property

PhotoColorMagicCommandRemoveGray Property

Gets or sets a value indicating whether to remove gray by setting Black Point in the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RemoveGray { get; set; }
Public Property RemoveGray As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Similar to the shadow adjustment made by AutoLevels.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.Strength Property

PhotoColorMagicCommandStrength Property

Gets or sets the strength of filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Strength { get; set; }
Public Property Strength As Double
    Get
    Set

Property Value

Type: Double
Remarks
Values closer to 0 is less color enhancement but 'safer', closer to 1 is more powerful, but will over-enhance some images. Default is 0.5.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.SupportedPixelFormats Property

PhotoColorMagicCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


PhotoColorMagicCommand Methods

The PhotoColorMagicCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.GetObjectData Method

PhotoColorMagicCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.PerformActualCommand Method

PhotoColorMagicCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMagicCommand.VerifyProperties Method

PhotoColorMagicCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PhotoColorMagicCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand Class

ColorMultiply uses a proprietary algorithm to uniformly enhance the color components of an image without changing the overall color balance of the image or affecting the tones and tonal distribution.

By controlling the Multiple property you can determine the amount of the effect. 1 is no effect, values of 2 to 3 are more useful and values of 5 and above are fairly extreme.

Note that this command is not "intelligent" so using it on an image which already has saturated colors will result in a somewhat garish look. If you want to more safely correct images or use a color correction in batch mode then use the Color Magic command.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorMultiplyCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PhotoColorMultiplyCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class PhotoColorMultiplyCommand
    Inherits ImageCommand
    Implements ISerializable

The PhotoColorMultiplyCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoColorMultiplyCommand | Initializes a new instance of the PhotoColorMultiplyCommand class.
Public method | PhotoColorMultiplyCommand(Double) | Initializes a new instance of the PhotoColorMultiplyCommand class with specified amount of multiple effect.
Protected method | PhotoColorMultiplyCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorMultiplyCommand class with serialized data.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Multiple | Gets or sets a value that indicates how much to multiply the colors in the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand Constructor

Overload List
 | Name | Description
Public method | PhotoColorMultiplyCommand | Initializes a new instance of the PhotoColorMultiplyCommand class.
Public method | PhotoColorMultiplyCommand(Double) | Initializes a new instance of the PhotoColorMultiplyCommand class with specified amount of multiple effect.
Protected method | PhotoColorMultiplyCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorMultiplyCommand class with serialized data.
Top
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand Constructor

Initializes a new instance of the PhotoColorMultiplyCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorMultiplyCommand()
Public Sub New
See Also

Reference

PhotoColorMultiplyCommand Class
PhotoColorMultiplyCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand Constructor (Double)

Initializes a new instance of the PhotoColorMultiplyCommand class with specified amount of multiple effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorMultiplyCommand(
    double multiple
)
Public Sub New (
    multiple As Double
)

Parameters

multiple
Type: SystemDouble
The multiple effect to apply.
See Also

Reference

PhotoColorMultiplyCommand Class
PhotoColorMultiplyCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhotoColorMultiplyCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PhotoColorMultiplyCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

PhotoColorMultiplyCommand Class
PhotoColorMultiplyCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand Properties

The PhotoColorMultiplyCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Multiple | Gets or sets a value that indicates how much to multiply the colors in the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand.Multiple Property

PhotoColorMultiplyCommandMultiple Property

Gets or sets a value that indicates how much to multiply the colors in the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Multiple { get; set; }
Public Property Multiple As Double
    Get
    Set

Property Value

Type: Double
Remarks
1 leaves the Same, < 1 reduces color, 0 is Convert to Gray, 2 doubles color. Range is 0 to 10, Default is 2.0
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand.SupportedPixelFormats Property

PhotoColorMultiplyCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


PhotoColorMultiplyCommand Methods

The PhotoColorMultiplyCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand.ConstructFinalImage Method

PhotoColorMultiplyCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand.GetObjectData Method

PhotoColorMultiplyCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand.PerformActualCommand Method

PhotoColorMultiplyCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage sourceImage,
    AtalaImage returnImage,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    sourceImage As AtalaImage,
    returnImage As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
returnImage
Type: Atalasoft.ImagingAtalaImage
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorMultiplyCommand.VerifyProperties Method

PhotoColorMultiplyCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PhotoColorMultiplyCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Class

Makes an image appear 'warmer' by adding red and reducing blue, without affecting the overall tone or contrast of the image. This is similar to correcting the White Balance setting on a digital camera. The amount of warming is controlled using the Effect parameter.

By default the command warms by about 20% (1.2), which is the equivalent at daylight color temperatures of about 1000-1500 degrees of color temperature.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorCorrectCommandBase
Atalasoft.Imaging.ImageProcessing.EffectsPhotoColorWarmerCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PhotoColorWarmerCommand : PhotoColorCorrectCommandBase
<SerializableAttribute>
Public Class PhotoColorWarmerCommand
    Inherits PhotoColorCorrectCommandBase

The PhotoColorWarmerCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoColorWarmerCommand | Initializes a new instance of the PhotoColorWarmerCommand class.
Public method | PhotoColorWarmerCommand(Double) | Initializes a new instance of the PhotoColorWarmerCommand class with specified warm effect value.
Protected method | PhotoColorWarmerCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorWarmerCommand class with serialized data.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Effect | Gets or sets warm effect value for the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from PhotoColorCorrectCommandBase.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhotoColorCorrectCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses. (Overrides PhotoColorCorrectCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides PhotoColorCorrectCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Constructor

Overload List
 | Name | Description
Public method | PhotoColorWarmerCommand | Initializes a new instance of the PhotoColorWarmerCommand class.
Public method | PhotoColorWarmerCommand(Double) | Initializes a new instance of the PhotoColorWarmerCommand class with specified warm effect value.
Protected method | PhotoColorWarmerCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the PhotoColorWarmerCommand class with serialized data.
Top
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Constructor

Initializes a new instance of the PhotoColorWarmerCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorWarmerCommand()
Public Sub New
See Also

Reference

PhotoColorWarmerCommand Class
PhotoColorWarmerCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Constructor (Double)

Initializes a new instance of the PhotoColorWarmerCommand class with specified warm effect value.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoColorWarmerCommand(
    double effect
)
Public Sub New (
    effect As Double
)

Parameters

effect
Type: SystemDouble
The warm effect to apply.
See Also

Reference

PhotoColorWarmerCommand Class
PhotoColorWarmerCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhotoColorWarmerCommand class with serialized data.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PhotoColorWarmerCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
See Also

Reference

PhotoColorWarmerCommand Class
PhotoColorWarmerCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Properties

The PhotoColorWarmerCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Effect | Gets or sets warm effect value for the image.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLBlueEffect | Gets or sets effect on the Blue color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLGreenEffect | Gets or sets effect on the Green color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLRedEffect | Gets or sets effect on the Red color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Protected property | LLYellowEffect | Gets or sets effect on the Yellow color in the supplied image. (Inherited from PhotoColorCorrectCommandBase.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand.Effect Property

PhotoColorWarmerCommandEffect Property

Gets or sets warm effect value for the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Effect { get; set; }
Public Property Effect As Double
    Get
    Set

Property Value

Type: Double
Remarks
Range of 1 (none) to 10. Default value is 20% (1.2).
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand Methods

The PhotoColorWarmerCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhotoColorCorrectCommandBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | ImplementMe | Marker method to be implemented in subclasses. (Overrides PhotoColorCorrectCommandBaseImplementMe.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides PhotoColorCorrectCommandBasePerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from PhotoColorCorrectCommandBase.)
Top
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand.GetObjectData Method

PhotoColorWarmerCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand.ImplementMe Method

PhotoColorWarmerCommandImplementMe Method

Marker method to be implemented in subclasses.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoColorWarmerCommand.PerformActualCommand Method

PhotoColorWarmerCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoColorWarmerCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand Class

Enhance Portraits Authored by David Cardinal
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoPortraitCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PhotoPortraitCommand : ImageCommand
Public Class PhotoPortraitCommand
    Inherits ImageCommand

The PhotoPortraitCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoPortraitCommand | Initializes a new instance of the PhotoPortraitCommand class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand Constructor

Initializes a new instance of the PhotoPortraitCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoPortraitCommand()
Public Sub New
See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand Properties

The PhotoPortraitCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand.InPlaceProcessing Property

PhotoPortraitCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand.SupportedPixelFormats Property

PhotoPortraitCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


PhotoPortraitCommand Methods

The PhotoPortraitCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand.PerformActualCommand Method

PhotoPortraitCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoPortraitCommand.VerifyProperties Method

PhotoPortraitCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PhotoPortraitCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand Class

Boost Visibility of Shadows. Authored by David Cardinal
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoShadowBoostCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PhotoShadowBoostCommand : ImageCommand
Public Class PhotoShadowBoostCommand
    Inherits ImageCommand

The PhotoShadowBoostCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoShadowBoostCommand | Initializes a new instance of the PhotoShadowBoostCommand class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand Constructor

Initializes a new instance of the PhotoShadowBoostCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoShadowBoostCommand()
Public Sub New
See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand Properties

The PhotoShadowBoostCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand.InPlaceProcessing Property

PhotoShadowBoostCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand.SupportedPixelFormats Property

PhotoShadowBoostCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


PhotoShadowBoostCommand Methods

The PhotoShadowBoostCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand.PerformActualCommand Method

PhotoShadowBoostCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoShadowBoostCommand.VerifyProperties Method

PhotoShadowBoostCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PhotoShadowBoostCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand Class

Enhance Skin Tones Authored by David Cardinal
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsPhotoSkinTonesCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PhotoSkinTonesCommand : ImageCommand
Public Class PhotoSkinTonesCommand
    Inherits ImageCommand

The PhotoSkinTonesCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoSkinTonesCommand | Initializes a new instance of the PhotoSkinTonesCommand class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand Constructor

Initializes a new instance of the PhotoSkinTonesCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoSkinTonesCommand()
Public Sub New
See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand Properties

The PhotoSkinTonesCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Gets an array of supported pixel formats. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand.InPlaceProcessing Property

PhotoSkinTonesCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand.SupportedPixelFormats Property

PhotoSkinTonesCommandSupportedPixelFormats Property

Gets an array of supported pixel formats.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
An array of supported pixel formats.
Remarks
All derived classes must override this property.
See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace
IsPixelFormatSupported Method


PhotoSkinTonesCommand Methods

The PhotoSkinTonesCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand.PerformActualCommand Method

PhotoSkinTonesCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PhotoSkinTonesCommand.VerifyProperties Method

PhotoSkinTonesCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage.AdvancedPhotoEffects (in Atalasoft.dotImage.AdvancedPhotoEffects.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PhotoSkinTonesCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand Class

Generate an image made up of primary and secondary colors of the source image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsPosterizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PosterizeCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class PosterizeCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The PosterizeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PosterizeCommand | Creates a new instance of PosterizeCommand.
Protected method | PosterizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of PosterizeCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a 24-bit image. If the source image is not continuous, it will throw the ArgumentException
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
MosaicCommand Example


PosterizeCommand Constructor

Overload List
 | Name | Description
Public method | PosterizeCommand | Creates a new instance of PosterizeCommand.
Protected method | PosterizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of PosterizeCommand from serialization information.
Top
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand Constructor

Creates a new instance of PosterizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PosterizeCommand()
Public Sub New
See Also

Reference

PosterizeCommand Class
PosterizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PosterizeCommand from serialization information.
Creates a new instance of PosterizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PosterizeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

PosterizeCommand Class
PosterizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand Properties

The PosterizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand.InPlaceProcessing Property

PosterizeCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand.SupportedPixelFormats Property

PosterizeCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand Methods

The PosterizeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand.GetObjectData Method

PosterizeCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand.PerformActualCommand Method

PosterizeCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


PosterizeCommand.VerifyProperties Method

PosterizeCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PosterizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Class

Attempts to eliminate "red-eye" from a region of an RGB image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsRedEyeRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RedEyeRemovalCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class RedEyeRemovalCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The RedEyeRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | RedEyeRemovalCommand | Creates a new instance of RedEyeRemovalCommand.
Public method | RedEyeRemovalCommand(Int32) | Creates a new instance of RedEyeRemovalCommand specifying the saturation threshold.
Public method | RedEyeRemovalCommand(Int32, Int32) | Creates a new instance of RedEyeRemovalCommand specifying the saturation threshold and color range.
Protected method | RedEyeRemovalCommand(SerializationInfo, StreamingContext) | Creates a new instance of RedEyeRemovalCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ColorRange | Gets or sets the red band width.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SaturationThreshold | Gets or sets the percent that red is allowed to dominates the other colors before it is reduced.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
You must select an "eye" region from the image, then choose a saturation level and color range. These should be done interactively, as the color and saturation of the "red-eye" effect varies greatly between images. See the Rubberbanding features in WinControls for selecting the eye region.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Constructor

Creates a new instance of RedEyeRemovalCommand.
Overload List
 | Name | Description
Public method | RedEyeRemovalCommand | Creates a new instance of RedEyeRemovalCommand.
Public method | RedEyeRemovalCommand(Int32) | Creates a new instance of RedEyeRemovalCommand specifying the saturation threshold.
Public method | RedEyeRemovalCommand(Int32, Int32) | Creates a new instance of RedEyeRemovalCommand specifying the saturation threshold and color range.
Protected method | RedEyeRemovalCommand(SerializationInfo, StreamingContext) | Creates a new instance of RedEyeRemovalCommand from serialization information.
Top
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Constructor

Creates a new instance of RedEyeRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RedEyeRemovalCommand()
Public Sub New
See Also

Reference

RedEyeRemovalCommand Class
RedEyeRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Constructor (Int32)

Creates a new instance of RedEyeRemovalCommand specifying the saturation threshold.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RedEyeRemovalCommand(
    int saturationThreshold
)
Public Sub New (
    saturationThreshold As Integer
)

Parameters

saturationThreshold
Type: SystemInt32
The percent that red is allowed to dominates the other colors before it is reduced. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the saturationThreshold is less than 0 or greater than 100.
See Also

Reference

RedEyeRemovalCommand Class
RedEyeRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Constructor (Int32, Int32)

Creates a new instance of RedEyeRemovalCommand specifying the saturation threshold and color range.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RedEyeRemovalCommand(
    int saturationThreshold,
    int colorRange
)
Public Sub New (
    saturationThreshold As Integer,
    colorRange As Integer
)

Parameters

saturationThreshold
Type: SystemInt32
The percent that red is allowed to dominates the other colors before it is reduced. (0 to 100)
colorRange
Type: SystemInt32
The red band width. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the saturationThreshold or colorRange is less than 0 or greater than 100.
See Also

Reference

RedEyeRemovalCommand Class
RedEyeRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RedEyeRemovalCommand from serialization information.
Creates a new instance of RedEyeRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RedEyeRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

RedEyeRemovalCommand Class
RedEyeRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Properties

The RedEyeRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ColorRange | Gets or sets the red band width.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SaturationThreshold | Gets or sets the percent that red is allowed to dominates the other colors before it is reduced.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.AutoThread Property

RedEyeRemovalCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.ColorRange Property

RedEyeRemovalCommandColorRange Property

Gets or sets the red band width.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ColorRange { get; set; }
Public Property ColorRange As Integer
    Get
    Set

Property Value

Type: Int32
The red band width.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Higher values cause pixels with more cyan and yellow to be reduced.
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.InPlaceProcessing Property

RedEyeRemovalCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.SaturationThreshold Property

RedEyeRemovalCommandSaturationThreshold Property

Gets or sets the percent that red is allowed to dominates the other colors before it is reduced.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SaturationThreshold { get; set; }
Public Property SaturationThreshold As Integer
    Get
    Set

Property Value

Type: Int32
The percent that red is allowed to dominates the other colors before it is reduced.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.SupportedPixelFormats Property

RedEyeRemovalCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand Methods

The RedEyeRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.AdjustBands Method

RedEyeRemovalCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.Clone Method

RedEyeRemovalCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the RedEyeRemovalCommand.

Implements

ICloneableClone
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.GetObjectData Method

RedEyeRemovalCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.PerformActualCommand Method

RedEyeRemovalCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ImageProcessException |
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.PerformSectionCommand Method

RedEyeRemovalCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RedEyeRemovalCommand.VerifyProperties Method

RedEyeRemovalCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

RedEyeRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Class

Use this command to convert an image into an 8-bit indexed image with a specified number of colors.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsReduceColorsCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ReduceColorsCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ReduceColorsCommand
    Inherits ImageCommand
    Implements ISerializable

The ReduceColorsCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ReduceColorsCommand | Creates a new instance of ReduceColorsCommand.
Public method | ReduceColorsCommand(Int32) | Creates a new instance of ReduceColorsCommand specifying colors.
Protected method | ReduceColorsCommand(SerializationInfo, StreamingContext) | Creates a new instance of ReduceColorsCommand from serialization information.
Public method | ReduceColorsCommand(Int32, DitheringMode, Int32) | Creates a new instance of ReduceColorsCommand specifying colors, ditherMode, and ditherMaxError.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Colors | Gets or sets the number of colors you want the resulting image to contain.
Public property | DitherMaxError | Gets or sets the maximum error value that can be carried between pixels.
Public property | DitherMode | Gets or sets the type of DitheringMode to perform.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a 24 or 32 bit image. If the source image is of a different format, it will raise the ChangePixelFormat event and convert the image to a compatible format.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Constructor

Overload List
 | Name | Description
Public method | ReduceColorsCommand | Creates a new instance of ReduceColorsCommand.
Public method | ReduceColorsCommand(Int32) | Creates a new instance of ReduceColorsCommand specifying colors.
Protected method | ReduceColorsCommand(SerializationInfo, StreamingContext) | Creates a new instance of ReduceColorsCommand from serialization information.
Public method | ReduceColorsCommand(Int32, DitheringMode, Int32) | Creates a new instance of ReduceColorsCommand specifying colors, ditherMode, and ditherMaxError.
Top
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Constructor

Creates a new instance of ReduceColorsCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReduceColorsCommand()
Public Sub New
See Also

Reference

ReduceColorsCommand Class
ReduceColorsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Constructor (Int32)

Creates a new instance of ReduceColorsCommand specifying colors.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReduceColorsCommand(
    int colors
)
Public Sub New (
    colors As Integer
)

Parameters

colors
Type: SystemInt32
The number of colors you want the resulting image to contain. (2 to 256)
Exceptions
Exception | Condition
 | Thrown if the colors value is less than 2 or greater than 256.
See Also

Reference

ReduceColorsCommand Class
ReduceColorsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ReduceColorsCommand from serialization information.
Creates a new instance of the ReduceColorsCommand object.,

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ReduceColorsCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ReduceColorsCommand Class
ReduceColorsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Constructor (Int32, DitheringMode, Int32)

Creates a new instance of ReduceColorsCommand specifying colors, ditherMode, and ditherMaxError.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReduceColorsCommand(
    int colors,
    DitheringMode ditherMode,
    int ditherMaxError
)
Public Sub New (
    colors As Integer,
    ditherMode As DitheringMode,
    ditherMaxError As Integer
)

Parameters

colors
Type: SystemInt32
The number of colors you want the resulting image to contain. (2 to 256)
ditherMode
Type: Atalasoft.Imaging.ImageProcessingDitheringMode
The type of DitheringMode to perform.
ditherMaxError
Type: SystemInt32
The maximum error value that can be carried between pixels. (0 to 127)
Exceptions
Exception | Condition
 | Thrown if colors is less than 2 or greater than 256, or if ditherMaxError is less than 0 or greater than 127.
See Also

Reference

ReduceColorsCommand Class
ReduceColorsCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Properties

The ReduceColorsCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Colors | Gets or sets the number of colors you want the resulting image to contain.
Public property | DitherMaxError | Gets or sets the maximum error value that can be carried between pixels.
Public property | DitherMode | Gets or sets the type of DitheringMode to perform.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.Colors Property

ReduceColorsCommandColors Property

Gets or sets the number of colors you want the resulting image to contain.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Colors { get; set; }
Public Property Colors As Integer
    Get
    Set

Property Value

Type: Int32
The number of colors you want the resulting image to contain.
Exceptions
Exception | Condition
 | Thrown if value is not between 2 and 256.
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.DitherMaxError Property

ReduceColorsCommandDitherMaxError Property

Gets or sets the maximum error value that can be carried between pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DitherMaxError { get; set; }
Public Property DitherMaxError As Integer
    Get
    Set

Property Value

Type: Int32
The maximum error value that can be carried between pixels.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 127.
Remarks
Valid values are from 0 to 127.
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.DitherMode Property

ReduceColorsCommandDitherMode Property

Gets or sets the type of DitheringMode to perform.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DitheringMode DitherMode { get; set; }
Public Property DitherMode As DitheringMode
    Get
    Set

Property Value

Type: DitheringMode
The type of DitheringMode to perform.
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.SupportedPixelFormats Property

ReduceColorsCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand Methods

The ReduceColorsCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.ConstructFinalImage Method

ReduceColorsCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.GetObjectData Method

ReduceColorsCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.PerformActualCommand Method

ReduceColorsCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.SelectPreferredPixelFormat Method

ReduceColorsCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReduceColorsCommand.VerifyProperties Method

ReduceColorsCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ReduceColorsCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Class

Replaces a color in an image with another using the specified color tolerance.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsReplaceColorCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ReplaceColorCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class ReplaceColorCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The ReplaceColorCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ReplaceColorCommand | Creates a new instance of ReplaceColorCommand.
Protected method | ReplaceColorCommand(SerializationInfo, StreamingContext) | Creates a new instance of ReplaceColorCommand from serialization information.
Public method | ReplaceColorCommand(Color, Color, Double) | Creates a new instance of ReplaceColorCommand specifying color to replace, the new color and tolerance.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | NewColor | Gets or sets the color used to replace the old color.
Public property | OldColor | Gets or sets the color you want to replace.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the maximum color distance to match. A value of 0 will provide strict matching.
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone or an 8-bit indexed image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Constructor

Overload List
 | Name | Description
Public method | ReplaceColorCommand | Creates a new instance of ReplaceColorCommand.
Protected method | ReplaceColorCommand(SerializationInfo, StreamingContext) | Creates a new instance of ReplaceColorCommand from serialization information.
Public method | ReplaceColorCommand(Color, Color, Double) | Creates a new instance of ReplaceColorCommand specifying color to replace, the new color and tolerance.
Top
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Constructor

Creates a new instance of ReplaceColorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplaceColorCommand()
Public Sub New
See Also

Reference

ReplaceColorCommand Class
ReplaceColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ReplaceColorCommand from serialization information.
Creates a new instance of ReplaceColorCommand specifying oldColor, newColor, and tolerance.
Creates a new instance of ReplaceColorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ReplaceColorCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ReplaceColorCommand Class
ReplaceColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Constructor (Color, Color, Double)

Creates a new instance of ReplaceColorCommand specifying color to replace, the new color and tolerance.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplaceColorCommand(
    Color oldColor,
    Color newColor,
    double tolerance
)
Public Sub New (
    oldColor As Color,
    newColor As Color,
    tolerance As Double
)

Parameters

oldColor
Type: System.DrawingColor
The color you want to replace.
newColor
Type: System.DrawingColor
The color used to replace the old color.
tolerance
Type: SystemDouble
The maximum color distance to match. A value of 0 will provide strict matching. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the tolerance is less than 0 or greater than 100.
See Also

Reference

ReplaceColorCommand Class
ReplaceColorCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Properties

The ReplaceColorCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | NewColor | Gets or sets the color used to replace the old color.
Public property | OldColor | Gets or sets the color you want to replace.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tolerance | Gets or sets the maximum color distance to match. A value of 0 will provide strict matching.
Top
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.AutoThread Property

ReplaceColorCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.InPlaceProcessing Property

ReplaceColorCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.NewColor Property

ReplaceColorCommandNewColor Property

Gets or sets the color used to replace the old color.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color NewColor { get; set; }
Public Property NewColor As Color
    Get
    Set

Property Value

Type: Color
The color used to replace the old color.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.OldColor Property

ReplaceColorCommandOldColor Property

Gets or sets the color you want to replace.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OldColor { get; set; }
Public Property OldColor As Color
    Get
    Set

Property Value

Type: Color
The color you want to replace.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.SupportedPixelFormats Property

ReplaceColorCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel32bppBgra
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.Tolerance Property

ReplaceColorCommandTolerance Property

Gets or sets the maximum color distance to match. A value of 0 will provide strict matching.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set

Property Value

Type: Double
The maximum color distance to match. A value of 0 will provide strict matching.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 1.
Remarks
Valid values are from 0 to 1.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand Methods

The ReplaceColorCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.AdjustBands Method

ReplaceColorCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.Clone Method

ReplaceColorCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the ReplaceColorCommand.

Implements

ICloneableClone
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.GetObjectData Method

ReplaceColorCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.PerformActualCommand Method

ReplaceColorCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.PerformSectionCommand Method

ReplaceColorCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ReplaceColorCommand.VerifyProperties Method

ReplaceColorCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ReplaceColorCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Class

Create an artistic embossing of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsRoundedBevelCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RoundedBevelCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class RoundedBevelCommand
    Inherits ImageCommand
    Implements ISerializable

The RoundedBevelCommand type exposes the following members.

Constructors
 | Name | Description
Public method | RoundedBevelCommand | Creates a new instance of RoundedBevelCommand.
Public method | RoundedBevelCommand(Int32) | Construct a new RoundedBevelCommand with the depth provided.
Public method | RoundedBevelCommand(Int32, Int32) | Construct a new RoundedBevelCommand with the depth and angle provided.
Protected method | RoundedBevelCommand(SerializationInfo, StreamingContext) | Creates a new instance of RoundedBevelCommand from serialization information.
Public method | RoundedBevelCommand(Int32, Int32, Single) | Construct a new RoundedBevelCommand with the depth, angle and softness provided.
Public method | RoundedBevelCommand(Int32, Int32, Single, Color, Color) | Construct a new RoundedBevelCommand with the depth, angle and softness provided. Highlights and shadows will be created with the provided colors.
Top
Properties
 | Name | Description
Public property | Angle | The angle of the embossing in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Depth | The depth of the embossing effect.
Public property | Highlight | The color that will used for applying highlights.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Shadow | Sets or gets the color used for shadowing.
Public property | Softness | Sets the softness of the mask constructed to build the embossed shaped.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command works best on images with an isolated shape on a blank background.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor

Construct a new RoundedBevelCommand from the information provided.
Overload List
 | Name | Description
Public method | RoundedBevelCommand | Creates a new instance of RoundedBevelCommand.
Public method | RoundedBevelCommand(Int32) | Construct a new RoundedBevelCommand with the depth provided.
Public method | RoundedBevelCommand(Int32, Int32) | Construct a new RoundedBevelCommand with the depth and angle provided.
Protected method | RoundedBevelCommand(SerializationInfo, StreamingContext) | Creates a new instance of RoundedBevelCommand from serialization information.
Public method | RoundedBevelCommand(Int32, Int32, Single) | Construct a new RoundedBevelCommand with the depth, angle and softness provided.
Public method | RoundedBevelCommand(Int32, Int32, Single, Color, Color) | Construct a new RoundedBevelCommand with the depth, angle and softness provided. Highlights and shadows will be created with the provided colors.
Top
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor

Creates a new instance of RoundedBevelCommand.
Construct a new RoundedBevelCommand with default properties.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RoundedBevelCommand()
Public Sub New
See Also

Reference

RoundedBevelCommand Class
RoundedBevelCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor (Int32)

Construct a new RoundedBevelCommand with the depth provided.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RoundedBevelCommand(
    int depth
)
Public Sub New (
    depth As Integer
)

Parameters

depth
Type: SystemInt32
The depth of the embossing effect.
Exceptions
Exception | Condition
 | Thrown if the depth is not greater than 0.
See Also

Reference

RoundedBevelCommand Class
RoundedBevelCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor (Int32, Int32)

Construct a new RoundedBevelCommand with the depth and angle provided.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RoundedBevelCommand(
    int depth,
    int angle
)
Public Sub New (
    depth As Integer,
    angle As Integer
)

Parameters

depth
Type: SystemInt32
The depth of the embossing effect.
angle
Type: SystemInt32
The angle of the embossing in degrees.
Exceptions
Exception | Condition
 | Thrown if the depth is less than 0, or if angle is less than 0 or greater than 359.
See Also

Reference

RoundedBevelCommand Class
RoundedBevelCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RoundedBevelCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RoundedBevelCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

RoundedBevelCommand Class
RoundedBevelCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor (Int32, Int32, Single)

Construct a new RoundedBevelCommand with the depth, angle and softness provided.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RoundedBevelCommand(
    int depth,
    int angle,
    float softness
)
Public Sub New (
    depth As Integer,
    angle As Integer,
    softness As Single
)

Parameters

depth
Type: SystemInt32
The depth of the embossing effect. Must be greater than 0.
angle
Type: SystemInt32
The angle of the embossing in degrees. (0 to 359)
softness
Type: SystemSingle
Sets the softness of the mask constructed to build the embossed shaped. (0.0 to 1.0)
Exceptions
Exception | Condition
 | Thrown if an argument is out of its specified range.
See Also

Reference

RoundedBevelCommand Class
RoundedBevelCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Constructor (Int32, Int32, Single, Color, Color)

Construct a new RoundedBevelCommand with the depth, angle and softness provided. Highlights and shadows will be created with the provided colors.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RoundedBevelCommand(
    int depth,
    int angle,
    float softness,
    Color highlight,
    Color shadow
)
Public Sub New (
    depth As Integer,
    angle As Integer,
    softness As Single,
    highlight As Color,
    shadow As Color
)

Parameters

depth
Type: SystemInt32
The depth of the embossing effect. Must be greater than 0.
angle
Type: SystemInt32
The angle of the embossing in degrees. (0 to 359)
softness
Type: SystemSingle
Sets the softness of the mask constructed to build the embossed shaped. (0.0 to 1.0)
highlight
Type: System.DrawingColor
The color that will used for applying highlights.
shadow
Type: System.DrawingColor
Sets or gets the color used for shadowing.
Exceptions
Exception | Condition
 | Thrown if an argument is out of its specified range.
See Also

Reference

RoundedBevelCommand Class
RoundedBevelCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Properties

The RoundedBevelCommand type exposes the following members.

Properties
 | Name | Description
Public property | Angle | The angle of the embossing in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Depth | The depth of the embossing effect.
Public property | Highlight | The color that will used for applying highlights.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Shadow | Sets or gets the color used for shadowing.
Public property | Softness | Sets the softness of the mask constructed to build the embossed shaped.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.Angle Property

RoundedBevelCommandAngle Property

The angle of the embossing in degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Angle { get; set; }
Public Property Angle As Integer
    Get
    Set

Property Value

Type: Int32
An integer in the range of 0 to 359.
Exceptions
Exception | Condition
 | Thrown if the value is less than zero or greater than 359.
Remarks
Default value is 45.
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.Depth Property

RoundedBevelCommandDepth Property

The depth of the embossing effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Depth { get; set; }
Public Property Depth As Integer
    Get
    Set

Property Value

Type: Int32
The amount of embossing effect.
Exceptions
Exception | Condition
 | Thrown if the value is not greater than zero.
Remarks
Depth must be greater than zero. The default value is 5.
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.Highlight Property

RoundedBevelCommandHighlight Property

The color that will used for applying highlights.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Highlight { get; set; }
Public Property Highlight As Color
    Get
    Set

Property Value

Type: Color
The highlight color.
Remarks
Default value is Color.White.
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.Shadow Property

RoundedBevelCommandShadow Property

Sets or gets the color used for shadowing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Shadow { get; set; }
Public Property Shadow As Color
    Get
    Set

Property Value

Type: Color
The shadow color.
Remarks
Default value is Color.Black.
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.Softness Property

RoundedBevelCommandSoftness Property

Sets the softness of the mask constructed to build the embossed shaped.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Softness { get; set; }
Public Property Softness As Single
    Get
    Set

Property Value

Type: Single
The amount of softness used for the emboss.
Exceptions
Exception | Condition
 | Thrown if the value is less than zero or greater than 1.
Remarks
Softness must be a value from 0 to 1. Default value is 1.0.
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.SupportedPixelFormats Property

RoundedBevelCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand Methods

The RoundedBevelCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.ConstructFinalImage Method

RoundedBevelCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.GetObjectData Method

RoundedBevelCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.PerformActualCommand Method

RoundedBevelCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.SelectPreferredPixelFormat Method

RoundedBevelCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


RoundedBevelCommand.VerifyProperties Method

RoundedBevelCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Depth;The depth property must be less than half the width or height of the image, whichever is smaller.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

RoundedBevelCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand Class

Modify the saturation levels of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsSaturationCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SaturationCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class SaturationCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The SaturationCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationCommand | Creates a new instance of SaturationCommand.
Public method | SaturationCommand(Double) | Creates a new instance of SaturationCommand specifying the saturation level.
Protected method | SaturationCommand(SerializationInfo, StreamingContext) | Creates a new instance of SaturationCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SaturationLevel | Gets or sets the saturation level to apply.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
Atalasoft.Imaging.ImageProcessing.EffectsMosaicCommand


SaturationCommand Constructor

Overload List
 | Name | Description
Public method | SaturationCommand | Creates a new instance of SaturationCommand.
Public method | SaturationCommand(Double) | Creates a new instance of SaturationCommand specifying the saturation level.
Protected method | SaturationCommand(SerializationInfo, StreamingContext) | Creates a new instance of SaturationCommand from serialization information.
Top
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand Constructor

Creates a new instance of SaturationCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SaturationCommand()
Public Sub New
See Also

Reference

SaturationCommand Class
SaturationCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand Constructor (Double)

Creates a new instance of SaturationCommand specifying the saturation level.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SaturationCommand(
    double saturationLevel
)
Public Sub New (
    saturationLevel As Double
)

Parameters

saturationLevel
Type: SystemDouble
The saturation level to apply.
See Also

Reference

SaturationCommand Class
SaturationCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SaturationCommand from serialization information.
Creates a new instance of SaturationCommand specifying saturationLevel.
Creates a new instance of SaturationCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SaturationCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SaturationCommand Class
SaturationCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand Properties

The SaturationCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SaturationLevel | Gets or sets the saturation level to apply.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand.InPlaceProcessing Property

SaturationCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand.SaturationLevel Property

SaturationCommandSaturationLevel Property

Gets or sets the saturation level to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SaturationLevel { get; set; }
Public Property SaturationLevel As Double
    Get
    Set

Property Value

Type: Double
The saturation level to apply.
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand.SupportedPixelFormats Property

SaturationCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand Methods

The SaturationCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand.GetObjectData Method

SaturationCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand.PerformActualCommand Method

SaturationCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SaturationCommand.VerifyProperties Method

SaturationCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SaturationCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Class

Generate an image that looks like it was drawn with paint and a heavy outline pen.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsScribbleCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ScribbleCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ScribbleCommand
    Inherits ImageCommand
    Implements ISerializable

The ScribbleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ScribbleCommand | Creates a new instance of ScribbleCommand.
Protected method | ScribbleCommand(SerializationInfo, StreamingContext) | Creates a new instance of ScribbleCommand from serialization information.
Public method | ScribbleCommand(ScribbleMode, Boolean, Int32) | Creates a new instance of ScribbleCommand specifying the mode, darkness and whether the filter should be applied before the effect.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Darkness | Gets or sets the darkness of the lines used for scribbling.
Public property | FilterFirst | Gets or sets whether or not a filter should be applied to the image before the strokes.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the ScribbleMode for the command.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Constructor

Constructs a new ScribbleCommand with the information provided.
Overload List
 | Name | Description
Public method | ScribbleCommand | Creates a new instance of ScribbleCommand.
Protected method | ScribbleCommand(SerializationInfo, StreamingContext) | Creates a new instance of ScribbleCommand from serialization information.
Public method | ScribbleCommand(ScribbleMode, Boolean, Int32) | Creates a new instance of ScribbleCommand specifying the mode, darkness and whether the filter should be applied before the effect.
Top
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Constructor

Creates a new instance of ScribbleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScribbleCommand()
Public Sub New
See Also

Reference

ScribbleCommand Class
ScribbleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ScribbleCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ScribbleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ScribbleCommand Class
ScribbleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Constructor (ScribbleMode, Boolean, Int32)

Creates a new instance of ScribbleCommand specifying the mode, darkness and whether the filter should be applied before the effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScribbleCommand(
    ScribbleMode mode,
    bool filterFirst,
    int darkness
)
Public Sub New (
    mode As ScribbleMode,
    filterFirst As Boolean,
    darkness As Integer
)

Parameters

mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsScribbleMode
The mode that will be used for the scribbling.
filterFirst
Type: SystemBoolean
Filter the image before the scribbling effect is applied.
darkness
Type: SystemInt32
The darkness of the lines. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the darkness argument is less than 0 or greater than 100.
See Also

Reference

ScribbleCommand Class
ScribbleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Properties

The ScribbleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Darkness | Gets or sets the darkness of the lines used for scribbling.
Public property | FilterFirst | Gets or sets whether or not a filter should be applied to the image before the strokes.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the ScribbleMode for the command.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.Darkness Property

ScribbleCommandDarkness Property

Gets or sets the darkness of the lines used for scribbling.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Darkness { get; set; }
Public Property Darkness As Integer
    Get
    Set

Property Value

Type: Int32
An integer from 0 to 100.
Exceptions
Exception | Condition
 | Thrown if the value is less than 0 or greater than 100.
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.FilterFirst Property

ScribbleCommandFilterFirst Property

Gets or sets whether or not a filter should be applied to the image before the strokes.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FilterFirst { get; set; }
Public Property FilterFirst As Boolean
    Get
    Set

Property Value

Type: Boolean
Filter before drawing lines.
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.Mode Property

ScribbleCommandMode Property

Gets or sets the ScribbleMode for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScribbleMode Mode { get; set; }
Public Property Mode As ScribbleMode
    Get
    Set

Property Value

Type: ScribbleMode
Type of filter to apply to the image.
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.SupportedPixelFormats Property

ScribbleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel8bppIndexed
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand Methods

The ScribbleCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.ConstructChangedSourceImage Method

ScribbleCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.ConstructFinalImage Method

ScribbleCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.GetObjectData Method

ScribbleCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.PerformActualCommand Method

ScribbleCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleCommand.VerifyProperties Method

ScribbleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ScribbleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


ScribbleMode Enumeration

Indicates the type of blurring to use on the ScribbleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ScribbleMode
Public Enumeration ScribbleMode
Members
Member name | Description
Blurred | Applies a blurring effect to the image.
Filtered | Applies a filtered effect to the image.
Posterized | Applies a posterized effect to the image.
Despeckled | Applies a despeckle effect to the image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand Class

Use this command to adjust the curves to generate a classic "solarize" effect.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsSolarizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SolarizeCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class SolarizeCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The SolarizeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SolarizeCommand | Creates a new instance of SolarizeCommand.
Protected method | SolarizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of SolarizeCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace
MosaicCommand Example


SolarizeCommand Constructor

Overload List
 | Name | Description
Public method | SolarizeCommand | Creates a new instance of SolarizeCommand.
Protected method | SolarizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of SolarizeCommand from serialization information.
Top
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand Constructor

Creates a new instance of SolarizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SolarizeCommand()
Public Sub New
See Also

Reference

SolarizeCommand Class
SolarizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SolarizeCommand from serialization information.
Creates a new instance of SolarizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SolarizeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SolarizeCommand Class
SolarizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand Properties

The SolarizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand.InPlaceProcessing Property

SolarizeCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand.SupportedPixelFormats Property

SolarizeCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand Methods

The SolarizeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand.GetObjectData Method

SolarizeCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo

A SerializationInfo containing information for this command.

context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand.PerformActualCommand Method

SolarizeCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


SolarizeCommand.VerifyProperties Method

SolarizeCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SolarizeCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Class

This command generates a bumped image effect.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsStippleCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class StippleCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class StippleCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The StippleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | StippleCommand | Creates a new instance of StippleCommand.
Protected method | StippleCommand(SerializationInfo, StreamingContext) | Creates a new instance of StippleCommand from serialization information.
Public method | StippleCommand(Int32, StippleFilterType, StippleMode) | Creates a new instance of StippleCommand specifying the size, filter and stipple mode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Filter | Gets or sets the StippleFilterType used to control blurring.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the StippleMode to use for this command.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Size | Gets or sets the size of the spots.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a compatible format.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Constructor

Overload List
 | Name | Description
Public method | StippleCommand | Creates a new instance of StippleCommand.
Protected method | StippleCommand(SerializationInfo, StreamingContext) | Creates a new instance of StippleCommand from serialization information.
Public method | StippleCommand(Int32, StippleFilterType, StippleMode) | Creates a new instance of StippleCommand specifying the size, filter and stipple mode.
Top
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Constructor

Creates a new instance of StippleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StippleCommand()
Public Sub New
See Also

Reference

StippleCommand Class
StippleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of StippleCommand from serialization information.
Creates a new instance of StippleCommand specifying size, filter, and mode.
Creates a new instance of StippleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected StippleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

StippleCommand Class
StippleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Constructor (Int32, StippleFilterType, StippleMode)

Creates a new instance of StippleCommand specifying the size, filter and stipple mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StippleCommand(
    int size,
    StippleFilterType filter,
    StippleMode mode
)
Public Sub New (
    size As Integer,
    filter As StippleFilterType,
    mode As StippleMode
)

Parameters

size
Type: SystemInt32
The size of the spots. (0 to 100)
filter
Type: Atalasoft.Imaging.ImageProcessing.EffectsStippleFilterType

The StippleFilterType used to control blurring.

mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsStippleMode

The StippleMode to use for this command.

Exceptions
Exception | Condition
 | Thrown if the size is less than 0 or greater than 100.
See Also

Reference

StippleCommand Class
StippleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Properties

The StippleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Filter | Gets or sets the StippleFilterType used to control blurring.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the StippleMode to use for this command.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Size | Gets or sets the size of the spots.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.Filter Property

StippleCommandFilter Property

Gets or sets the StippleFilterType used to control blurring.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StippleFilterType Filter { get; set; }
Public Property Filter As StippleFilterType
    Get
    Set

Property Value

Type: StippleFilterType

The StippleFilterType used to control blurring.

See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.Mode Property

StippleCommandMode Property

Gets or sets the StippleMode to use for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StippleMode Mode { get; set; }
Public Property Mode As StippleMode
    Get
    Set

Property Value

Type: StippleMode

The StippleMode to use for this command.

See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.Size Property

StippleCommandSize Property

Gets or sets the size of the spots.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set

Property Value

Type: Int32
The size of the spots.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.SupportedPixelFormats Property

StippleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand Methods

The StippleCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Overrides ImageCommandConstructChangedSourceImage(AtalaImage).)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.ConstructChangedSourceImage Method

StippleCommandConstructChangedSourceImage Method

The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructChangedSourceImage(
    AtalaImage image
)
Protected Overrides Function ConstructChangedSourceImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The original source image passed to Apply.

Return Value

Type: AtalaImage
A new image in a pixel format supported by the command or null to indicate that the original image is acceptable.
Remarks

The default implementation of ConstructChangedSourceImage requests that the command report its preferred pixel format (typically, this is the source image's pixel format, but some commands support many pixel formats, but work best in gray, for example), and if that is supported, returns a new image in the preferred format if it is different from the source image.

If the pixel format is not supported and ApplyToAnyPixelFormat is set to true, the command is queried for its best alternate pixel format and a new image is returned in that pixel format. If ApplyToAnyPixelFormat is set to false, ConstructChangedSourceImage will throw an IncompatiblePixelFormatException.

If an error occurs, ConstructChangedImage should throw an exception. Any new image constructed by ConstructChangedImage must be a pixel format supported by this command.

See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.ConstructFinalImage Method

StippleCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.GetObjectData Method

StippleCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.PerformActualCommand Method

StippleCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleCommand.VerifyProperties Method

StippleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

StippleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleFilterType Enumeration

Indicates the type of blurring to use in the StippleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum StippleFilterType
Public Enumeration StippleFilterType
Members
Member name | Description
ArithmeticMean | Applies an arithmetic mean filter to the image.
Minimum | Applies a minimum filter to the image.
Maximum | Applies a maximum filter to the image.
GeometricMean | Applies a geometric mean filter to the image.
YPMean | Applies a YP mean filter to the image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


StippleMode Enumeration

Indicates how to process the image in the StippleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum StippleMode
Public Enumeration StippleMode
Members
Member name | Description
NoiseFirst | Applies the noise before the filter.
FilterFirst | Applies the filter before adding the noise.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Class

Converts a grayscale image into a RGB or RGBA image and applies a color tint in the same process.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.EffectsTintGrayscaleCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TintGrayscaleCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class TintGrayscaleCommand
    Inherits ImageCommand
    Implements ISerializable

The TintGrayscaleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | TintGrayscaleCommand | Creates a new instance of TintGrayscaleCommand.
Public method | TintGrayscaleCommand(Color) | Creates a new instance of TintGrayscaleCommand specifying the tint color.
Protected method | TintGrayscaleCommand(SerializationInfo, StreamingContext) | Creates a new instance of TintGrayscaleCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ColorToTint | Gets or sets the color to tint the output.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires an 8-bit or 16-bit grayscale w/ alpha image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Constructor

Overload List
 | Name | Description
Public method | TintGrayscaleCommand | Creates a new instance of TintGrayscaleCommand.
Public method | TintGrayscaleCommand(Color) | Creates a new instance of TintGrayscaleCommand specifying the tint color.
Protected method | TintGrayscaleCommand(SerializationInfo, StreamingContext) | Creates a new instance of TintGrayscaleCommand from serialization information.
Top
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Constructor

Creates a new instance of TintGrayscaleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TintGrayscaleCommand()
Public Sub New
See Also

Reference

TintGrayscaleCommand Class
TintGrayscaleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Constructor (Color)

Creates a new instance of TintGrayscaleCommand specifying the tint color.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TintGrayscaleCommand(
    Color colorToTint
)
Public Sub New (
    colorToTint As Color
)

Parameters

colorToTint
Type: System.DrawingColor
The color to tint the output.
Exceptions
Exception | Condition
 | Thrown if colorToTint equals Color.IsEmpty.
See Also

Reference

TintGrayscaleCommand Class
TintGrayscaleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of TintGrayscaleCommand from serialization information.
Creates a new instance of TintGrayscaleCommand specifying colorToTint.
Creates a new instance of TintGrayscaleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected TintGrayscaleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

TintGrayscaleCommand Class
TintGrayscaleCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Properties

The TintGrayscaleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ColorToTint | Gets or sets the color to tint the output.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand.ColorToTint Property

TintGrayscaleCommandColorToTint Property

Gets or sets the color to tint the output.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ColorToTint { get; set; }
Public Property ColorToTint As Color
    Get
    Set

Property Value

Type: Color
The color to tint the output.
Exceptions
Exception | Condition
 | Thrown if value equals Color.IsEmpty.
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand.SupportedPixelFormats Property

TintGrayscaleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel16bppGrayscaleAlpha
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand Methods

The TintGrayscaleCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand.ConstructFinalImage Method

TintGrayscaleCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand.GetObjectData Method

TintGrayscaleCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand.PerformActualCommand Method

TintGrayscaleCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


TintGrayscaleCommand.VerifyProperties Method

TintGrayscaleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

TintGrayscaleCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Class

This command modifies an image to appear as if it was drawn using watercolors.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.EffectsWatercolorTintCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class WatercolorTintCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class WatercolorTintCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The WatercolorTintCommand type exposes the following members.

Constructors
 | Name | Description
Public method | WatercolorTintCommand | Creates a new instance of WatercolorTintCommand.
Public method | WatercolorTintCommand(Double, WatercolorTintMode) | Creates a new instance of WatercolorTintCommand specifying the blur and tint mode.
Protected method | WatercolorTintCommand(SerializationInfo, StreamingContext) | Creates a new instance of WatercolorTintCommand from serialization information.
Public method | WatercolorTintCommand(Double, WatercolorTintMode, Boolean) | Creates a new instance of WatercolorTintCommand specifying blur, tint mode and contrast enhancement.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | Blur | Gets or sets the amount of blurring to add during processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | EnhanceContrast | Gets or sets a value indicating whether the image contrast is enhanced during processing.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tint | Gets or sets a value indicating if the image should be lightened or darkened.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Constructor

Creates a new instance of WatercolorTintCommand.
Overload List
 | Name | Description
Public method | WatercolorTintCommand | Creates a new instance of WatercolorTintCommand.
Public method | WatercolorTintCommand(Double, WatercolorTintMode) | Creates a new instance of WatercolorTintCommand specifying the blur and tint mode.
Protected method | WatercolorTintCommand(SerializationInfo, StreamingContext) | Creates a new instance of WatercolorTintCommand from serialization information.
Public method | WatercolorTintCommand(Double, WatercolorTintMode, Boolean) | Creates a new instance of WatercolorTintCommand specifying blur, tint mode and contrast enhancement.
Top
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Constructor

Creates a new instance of WatercolorTintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WatercolorTintCommand()
Public Sub New
See Also

Reference

WatercolorTintCommand Class
WatercolorTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Constructor (Double, WatercolorTintMode)

Creates a new instance of WatercolorTintCommand specifying the blur and tint mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WatercolorTintCommand(
    double blur,
    WatercolorTintMode mode
)
Public Sub New (
    blur As Double,
    mode As WatercolorTintMode
)

Parameters

blur
Type: SystemDouble
The amount of blurring to add during processing. (0 to 100)
mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsWatercolorTintMode
Indicates if the image should be lightened or darkened.
Exceptions
Exception | Condition
 | Thrown if blur is less than 0 or greater than 100.
See Also

Reference

WatercolorTintCommand Class
WatercolorTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of WatercolorTintCommand from serialization information.
Creates a new instance of WatercolorTintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WatercolorTintCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

WatercolorTintCommand Class
WatercolorTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Constructor (Double, WatercolorTintMode, Boolean)

Creates a new instance of WatercolorTintCommand specifying blur, tint mode and contrast enhancement.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WatercolorTintCommand(
    double blur,
    WatercolorTintMode mode,
    bool enhanceContrast
)
Public Sub New (
    blur As Double,
    mode As WatercolorTintMode,
    enhanceContrast As Boolean
)

Parameters

blur
Type: SystemDouble
The amount of blurring to add during processing. (0 to 100)
mode
Type: Atalasoft.Imaging.ImageProcessing.EffectsWatercolorTintMode
Indicates if the image should be lightened or darkened.
enhanceContrast
Type: SystemBoolean
A value indicating whether the image contrast is enhanced during processing.
Exceptions
Exception | Condition
 | Thrown if blur is less than 0 or greater than 100.
See Also

Reference

WatercolorTintCommand Class
WatercolorTintCommand Overload
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Properties

The WatercolorTintCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | Blur | Gets or sets the amount of blurring to add during processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | EnhanceContrast | Gets or sets a value indicating whether the image contrast is enhanced during processing.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Tint | Gets or sets a value indicating if the image should be lightened or darkened.
Top
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.Blur Property

WatercolorTintCommandBlur Property

Gets or sets the amount of blurring to add during processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Blur { get; set; }
Public Property Blur As Double
    Get
    Set

Property Value

Type: Double
The amount of blurring to add during processing.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.EnhanceContrast Property

WatercolorTintCommandEnhanceContrast Property

Gets or sets a value indicating whether the image contrast is enhanced during processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnhanceContrast { get; set; }
Public Property EnhanceContrast As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the image contrast is enhanced during processing.
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.SupportedPixelFormats Property

WatercolorTintCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.Tint Property

WatercolorTintCommandTint Property

Gets or sets a value indicating if the image should be lightened or darkened.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WatercolorTintMode Tint { get; set; }
Public Property Tint As WatercolorTintMode
    Get
    Set

Property Value

Type: WatercolorTintMode
Indicates if the image should be lightened or darkened.
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand Methods

The WatercolorTintCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills the SerializationInfo object with information for this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.GetObjectData Method

WatercolorTintCommandGetObjectData Method

Fills the SerializationInfo object with information for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
 | Thrown if the info argument is null (Nothing in VB).
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.PerformActualCommand Method

WatercolorTintCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.SelectPreferredPixelFormat Method

WatercolorTintCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintCommand.VerifyProperties Method

WatercolorTintCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

WatercolorTintCommand Class
Atalasoft.Imaging.ImageProcessing.Effects Namespace


WatercolorTintMode Enumeration

Specifies the tint mode for WatercolorTintCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Effects
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WatercolorTintMode
Public Enumeration WatercolorTintMode
Members
Member name | Description
Darken | Darkens the image.
Lighten | Lightens the image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Effects Namespace


Atalasoft.Imaging.ImageProcessing.Fft Namespace

Classes
 | Class | Description
Public class | BandPassFftCommand | Combines low pass and high pass to filters at a low and high cutoff radius.
Public class | ButterworthHighBoostFftCommand | Similar to the high pass butterworth filter with an additive offset and multiplier.
Public class | ButterworthHighPassFftCommand | Similar to the ideal high pass filter, but with smoother transitions and less "ringing".
Public class | ButterworthLowPassFftCommand | Similar to the ideal low pass filter, but with smoother transitions and less "ringing".
Public class | FftCommand | The base class used for all FFT (Fast Fourier Transform) filters for frequency domain image processing.
 | FftGrid | The FftGrid is used as an intermediate step in FFT processing. It transforms a grayscale image into the FFT domain, and is required prior to all FFT filters.
Public class | GaussianHighBoostFftCommand | Similar to the high pass gaussian filter with an additive offset and multiplier.
Public class | GaussianHighPassFftCommand | Similar to the ideal high pass filter, but with smoother transitions and less "ringing".
Public class | GaussianLowPassFftCommand | Similar to the ideal low pass filter, but with smoother transitions and less "ringing".
Public class | IdealHighPassFftCommand | The ideal high pass filter zeros out all frequencies inside a specified cutoff radius.
Public class | IdealLowPassFftCommand | The ideal low pass filter zeros out all frequencies outside a specified cutoff radius.
Public class | InversePowerFftCommand |


BandPassFftCommand Class

Combines low pass and high pass to filters at a low and high cutoff radius.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftBandPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BandPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class BandPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The BandPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BandPassFftCommand | Initializes a new instance of the BandPassFftCommand class.
Public method | BandPassFftCommand(Double, Double) | Initializes a new BandPassFftCommand specifying the cut off values.
Protected method | BandPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of BandPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighCutoff | Gets or sets the high cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | LowCutoff | Gets or sets the low cutoff radius in the frequency domain.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies BandPassFftComand to a grid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
Atalasoft.Imaging.ImageProcessing.FftFftGrid


BandPassFftCommand Constructor

Initializes a new instance of BandPassFftCommand.
Overload List
 | Name | Description
Public method | BandPassFftCommand | Initializes a new instance of the BandPassFftCommand class.
Public method | BandPassFftCommand(Double, Double) | Initializes a new BandPassFftCommand specifying the cut off values.
Protected method | BandPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of BandPassFftCommand.
Top
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand Constructor

Initializes a new instance of the BandPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BandPassFftCommand()
Public Sub New
See Also

Reference

BandPassFftCommand Class
BandPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand Constructor (Double, Double)

Initializes a new BandPassFftCommand specifying the cut off values.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BandPassFftCommand(
    double lowCutoff,
    double highCutoff
)
Public Sub New (
    lowCutoff As Double,
    highCutoff As Double
)

Parameters

lowCutoff
Type: SystemDouble
highCutoff
Type: SystemDouble
See Also

Reference

BandPassFftCommand Class
BandPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of BandPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BandPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BandPassFftCommand Class
BandPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand Properties

The BandPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighCutoff | Gets or sets the high cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | LowCutoff | Gets or sets the low cutoff radius in the frequency domain.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand.HighCutoff Property

BandPassFftCommandHighCutoff Property

Gets or sets the high cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HighCutoff { get; set; }
Public Property HighCutoff As Double
    Get
    Set

Property Value

Type: Double
The high cutoff radius in the frequency domain.
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand.LowCutoff Property

BandPassFftCommandLowCutoff Property

Gets or sets the low cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LowCutoff { get; set; }
Public Property LowCutoff As Double
    Get
    Set

Property Value

Type: Double
The low cutoff radius in the frequency domain.
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand Methods

The BandPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies BandPassFftComand to a grid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand.ApplyToGrid Method

BandPassFftCommandApplyToGrid Method

Applies BandPassFftComand to a grid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


BandPassFftCommand.GetObjectData Method

BandPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | BandPassFftCommand does not support serialization
See Also

Reference

BandPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand Class

Similar to the high pass butterworth filter with an additive offset and multiplier.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftButterworthHighBoostFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ButterworthHighBoostFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class ButterworthHighBoostFftCommand
    Inherits FftCommand
    Implements ISerializable

The ButterworthHighBoostFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ButterworthHighBoostFftCommand | Initializes a new instance of the ButterworthHighBoostFftCommand class.
Protected method | ButterworthHighBoostFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ButterworthHighBoostFftCommand.
Public method | ButterworthHighBoostFftCommand(Double, Double, Double) | Initializes a new instance of ButterworthHighBoostFftCommand specifying the cutoff radius, factor, and offset.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | Factor | Gets or sets the multiplier applied to the high pass filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or sets the offset applied to the high pass filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
FftGrid Example


ButterworthHighBoostFftCommand Constructor

Initializes a new instance of ButterworthHighBoostFftCommand.
Overload List
 | Name | Description
Public method | ButterworthHighBoostFftCommand | Initializes a new instance of the ButterworthHighBoostFftCommand class.
Protected method | ButterworthHighBoostFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ButterworthHighBoostFftCommand.
Public method | ButterworthHighBoostFftCommand(Double, Double, Double) | Initializes a new instance of ButterworthHighBoostFftCommand specifying the cutoff radius, factor, and offset.
Top
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand Constructor

Initializes a new instance of the ButterworthHighBoostFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ButterworthHighBoostFftCommand()
Public Sub New
See Also

Reference

ButterworthHighBoostFftCommand Class
ButterworthHighBoostFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of ButterworthHighBoostFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ButterworthHighBoostFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ButterworthHighBoostFftCommand Class
ButterworthHighBoostFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand Constructor (Double, Double, Double)

Initializes a new instance of ButterworthHighBoostFftCommand specifying the cutoff radius, factor, and offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ButterworthHighBoostFftCommand(
    double cutoff,
    double offset,
    double factor
)
Public Sub New (
    cutoff As Double,
    offset As Double,
    factor As Double
)

Parameters

cutoff
Type: SystemDouble
offset
Type: SystemDouble
factor
Type: SystemDouble
See Also

Reference

ButterworthHighBoostFftCommand Class
ButterworthHighBoostFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand Properties

The ButterworthHighBoostFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | Factor | Gets or sets the multiplier applied to the high pass filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or sets the offset applied to the high pass filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand.Cutoff Property

ButterworthHighBoostFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand.Factor Property

ButterworthHighBoostFftCommandFactor Property

Gets or sets the multiplier applied to the high pass filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Factor { get; set; }
Public Property Factor As Double
    Get
    Set

Property Value

Type: Double
The multiplier applied to the high pass filter.
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand.Offset Property

ButterworthHighBoostFftCommandOffset Property

Gets or sets the offset applied to the high pass filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set

Property Value

Type: Double
The offset applied to the high pass filter.
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand Methods

The ButterworthHighBoostFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand.ApplyToGrid Method

ButterworthHighBoostFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighBoostFftCommand.GetObjectData Method

ButterworthHighBoostFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | ButterworthHighBoostFftCommand does not support serialization
See Also

Reference

ButterworthHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Class

Similar to the ideal high pass filter, but with smoother transitions and less "ringing".
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftButterworthHighPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ButterworthHighPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class ButterworthHighPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The ButterworthHighPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ButterworthHighPassFftCommand | Initializes a new instance of the ButterworthHighPassFftCommand class.
Public method | ButterworthHighPassFftCommand(Double, Double) | Initializes a new instance of ButterworthHighPassFftCommand specifying the cutoff radius and order.
Protected method | ButterworthHighPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ButterworthHighPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Order | Gets or sets the function order.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
Remarks
High pass filters clip low frequencies tending to sharpen images.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Constructor

Initializes a new instance of ButterworthHighPassFftCommand.
Overload List
 | Name | Description
Public method | ButterworthHighPassFftCommand | Initializes a new instance of the ButterworthHighPassFftCommand class.
Public method | ButterworthHighPassFftCommand(Double, Double) | Initializes a new instance of ButterworthHighPassFftCommand specifying the cutoff radius and order.
Protected method | ButterworthHighPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ButterworthHighPassFftCommand.
Top
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Constructor

Initializes a new instance of the ButterworthHighPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ButterworthHighPassFftCommand()
Public Sub New
See Also

Reference

ButterworthHighPassFftCommand Class
ButterworthHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Constructor (Double, Double)

Initializes a new instance of ButterworthHighPassFftCommand specifying the cutoff radius and order.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ButterworthHighPassFftCommand(
    double cutoff,
    double order
)
Public Sub New (
    cutoff As Double,
    order As Double
)

Parameters

cutoff
Type: SystemDouble
order
Type: SystemDouble
See Also

Reference

ButterworthHighPassFftCommand Class
ButterworthHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of ButterworthHighPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ButterworthHighPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ButterworthHighPassFftCommand Class
ButterworthHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Properties

The ButterworthHighPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Order | Gets or sets the function order.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand.Cutoff Property

ButterworthHighPassFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand.Order Property

ButterworthHighPassFftCommandOrder Property

Gets or sets the function order.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Order { get; set; }
Public Property Order As Double
    Get
    Set

Property Value

Type: Double
The function order.
Remarks
A good value to start with is 2.0.
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand Methods

The ButterworthHighPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand.ApplyToGrid Method

ButterworthHighPassFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthHighPassFftCommand.GetObjectData Method

ButterworthHighPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | ButterworthHighPassFftCommand does not support serialization
See Also

Reference

ButterworthHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand Class

Similar to the ideal low pass filter, but with smoother transitions and less "ringing".
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftButterworthLowPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ButterworthLowPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class ButterworthLowPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The ButterworthLowPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ButterworthLowPassFftCommand | Initializes a new instance of the ButterworthLowPassFftCommand class.
Public method | ButterworthLowPassFftCommand(Double, Double) | Initializes a new instance of ButterworthLowPassFftCommand specifying the cutoff radius and order.
Protected method | ButterworthLowPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ButterworthLowPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Order | Gets or sets the function order.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
Remarks
Low pass filters clip high frequencies tending to blur images.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
Atalasoft.Imaging.ImageProcessing.FftFftGrid


ButterworthLowPassFftCommand Constructor

Initializes a new instance of ButterworthLowPassFftCommand.
Overload List
 | Name | Description
Public method | ButterworthLowPassFftCommand | Initializes a new instance of the ButterworthLowPassFftCommand class.
Public method | ButterworthLowPassFftCommand(Double, Double) | Initializes a new instance of ButterworthLowPassFftCommand specifying the cutoff radius and order.
Protected method | ButterworthLowPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of ButterworthLowPassFftCommand.
Top
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand Constructor

Initializes a new instance of the ButterworthLowPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ButterworthLowPassFftCommand()
Public Sub New
See Also

Reference

ButterworthLowPassFftCommand Class
ButterworthLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand Constructor (Double, Double)

Initializes a new instance of ButterworthLowPassFftCommand specifying the cutoff radius and order.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ButterworthLowPassFftCommand(
    double cutoff,
    double order
)
Public Sub New (
    cutoff As Double,
    order As Double
)

Parameters

cutoff
Type: SystemDouble
order
Type: SystemDouble
See Also

Reference

ButterworthLowPassFftCommand Class
ButterworthLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of ButterworthLowPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ButterworthLowPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ButterworthLowPassFftCommand Class
ButterworthLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand Properties

The ButterworthLowPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Order | Gets or sets the function order.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand.Cutoff Property

ButterworthLowPassFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand.Order Property

ButterworthLowPassFftCommandOrder Property

Gets or sets the function order.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Order { get; set; }
Public Property Order As Double
    Get
    Set

Property Value

Type: Double
The function order.
Remarks
A good value to start with is 2.0.
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand Methods

The ButterworthLowPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand.ApplyToGrid Method

ButterworthLowPassFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


ButterworthLowPassFftCommand.GetObjectData Method

ButterworthLowPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | ButterworthLowPassFftCommand does not support serialzation
See Also

Reference

ButterworthLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand Class

The base class used for all FFT (Fast Fourier Transform) filters for frequency domain image processing.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
More...

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class FftCommand : ImageCommand
Public MustInherit Class FftCommand
    Inherits ImageCommand

The FftCommand type exposes the following members.

Constructors
 | Name | Description
Protected method | FftCommand | Initializes a new instance of the FftCommand class.
Protected method | FftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the FftCommand class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid.
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
Includes the method ApplyToGrid which allows multiple FFT filters to be applied without converting back and forth to the frequency domain. Can also be used normally with the ApplyToImage method for processing a single FFT filter.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftBandPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftButterworthHighBoostFftCommand
Atalasoft.Imaging.ImageProcessing.FftButterworthHighPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftButterworthLowPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftGaussianHighBoostFftCommand
Atalasoft.Imaging.ImageProcessing.FftGaussianHighPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftGaussianLowPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftIdealHighPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftIdealLowPassFftCommand
Atalasoft.Imaging.ImageProcessing.FftInversePowerFftCommand


FftCommand Constructor

Overload List
 | Name | Description
Protected method | FftCommand | Initializes a new instance of the FftCommand class.
Protected method | FftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of the FftCommand class.
Top
See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand Constructor

Initializes a new instance of the FftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FftCommand()
Protected Sub New
See Also

Reference

FftCommand Class
FftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

FftCommand Class
FftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand Properties

The FftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand.SupportedPixelFormats Property

FftCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand Methods

The FftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid.
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand.ApplyToGrid Method

FftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void ApplyToGrid(
    FftGrid grid
)
Public MustOverride Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand.ConstructFinalImage Method

FftCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand.PerformActualCommand Method

FftCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftCommand.VerifyProperties Method

FftCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

FftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid Class

The FftGrid is used as an intermediate step in FFT processing. It transforms a grayscale image into the FFT domain, and is required prior to all FFT filters.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.FftFftGrid

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FftGrid : IDisposable
Public Class FftGrid
    Implements IDisposable

The FftGrid type exposes the following members.

Constructors
 | Name | Description
Public method | FftGrid | Initializes a new instance of the FftGrid class.
Public method | FftGrid(AtalaImage) | Initializes a new instance of the FftGrid class
Top
Properties
 | Name | Description
Public property | Height | Gets the height of this FftGrid.
Public property | Image | Gets or sets the AtalaImage associated with this FftGrid.
Public property | Width | Gets the width of this FftGrid.
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the FftGrid class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetNextPowerOfTwo | A helper function that retrieves the next power of two (128, 256, 512, 1024, etc). x^2
Public method | GetProcessedImage | Returns the processed image from the frequency domain.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
When using the Grid as the intermediate step, multiple FFT filters can be applied. Each FFT Command has an ApplyToGrid method that uses an FftGrid to process. Once the image has completed processing, be sure to return the changed image with the GetProcessedImage method.
Examples
FftGrid Example (C#)
Copy
// Load an 8-bit grayscale image.
AtalaImage image = new AtalaImage(@"D:\Test Images\JPG\8-bit alpha mask.jpg");

// Resize the image so its width and height are a power of 2.
Size newSize = new Size(FftGrid.GetNextPowerOfTwo(image.Width), FftGrid.GetNextPowerOfTwo(image.Height));
ResampleCommand resample = new ResampleCommand(newSize);
AtalaImage temp = resample.ApplyToImage(image);
image.Dispose();

// Create an FftGrid from the image and apply a filter to it.
FftGrid grid = new FftGrid(temp);
ButterworthHighPassFftCommand cmd = new ButterworthHighPassFftCommand(1.2, 2.4);
cmd.ApplyToGrid(grid);

// Get the resulting image.
this.viewer.Image = grid.GetProcessedImage();
temp.Dispose();
FftGrid Example (Visual Basic)
Copy
' Load an 8-bit grayscale image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\JPG\8-bit alpha mask.jpg")

' Resize the image so its width and height are a power of 2.
Dim NewSize As Size =  New Size(FftGrid.GetNextPowerOfTwo(image.Width),FftGrid.GetNextPowerOfTwo(image.Height))
Dim resample As ResampleCommand =  New ResampleCommand(NewSize)
Dim temp As AtalaImage =  resample.ApplyToImage(image)
image.Dispose()

' Create an FftGrid from the image and apply a filter to it.
Dim grid As FftGrid =  New FftGrid(temp)
Dim cmd As ButterworthHighPassFftCommand =  New ButterworthHighPassFftCommand(1.2,2.4)
cmd.ApplyToGrid(grid)

' Get the resulting image.
Me.viewer.Image = grid.GetProcessedImage()
temp.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid Constructor

Overload List
 | Name | Description
Public method | FftGrid | Initializes a new instance of the FftGrid class.
Public method | FftGrid(AtalaImage) | Initializes a new instance of the FftGrid class
Top
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid Constructor

Initializes a new instance of the FftGrid class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FftGrid()
Public Sub New
Exceptions
Exception | Condition
AtalasoftLicenseException | This command requires a photo pro license.
See Also

Reference

FftGrid Class
FftGrid Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid Constructor (AtalaImage)

Initializes a new instance of the FftGrid class

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FftGrid(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The grayscale AtalaImage to initialize the FftGrid with.
Remarks
Initializes a new instance of FftGrid.
See Also

Reference

FftGrid Class
FftGrid Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid Properties

The FftGrid type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height of this FftGrid.
Public property | Image | Gets or sets the AtalaImage associated with this FftGrid.
Public property | Width | Gets the width of this FftGrid.
Top
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.Height Property

FftGridHeight Property

Gets the height of this FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
The height of this FftGrid .
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.Image Property

FftGridImage Property

Gets or sets the AtalaImage associated with this FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage associated with this FftGrid
Exceptions
Exception | Condition
 | Thrown if the image is not grayscale.
 | Thrown if the image dimensions are not a power of 2.
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.Width Property

FftGridWidth Property

Gets the width of this FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
The width of this FftGrid .
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid Methods

The FftGrid type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the FftGrid class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetNextPowerOfTwo | A helper function that retrieves the next power of two (128, 256, 512, 1024, etc). x^2
Public method | GetProcessedImage | Returns the processed image from the frequency domain.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.Dispose Method

FftGridDispose Method

Cleans up unmanaged resources.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.Finalize Method

FftGridFinalize Method

Finalizes an instance of the FftGrid class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.GetNextPowerOfTwo Method

FftGridGetNextPowerOfTwo Method

A helper function that retrieves the next power of two (128, 256, 512, 1024, etc). x^2

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetNextPowerOfTwo(
    int value
)
Public Shared Function GetNextPowerOfTwo (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32

The value to use when testing the next power of two.

Return Value

Type: Int32
The next power of two.
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


FftGrid.GetProcessedImage Method

FftGridGetProcessedImage Method

Returns the processed image from the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetProcessedImage()
Public Function GetProcessedImage As AtalaImage

Return Value

Type: AtalaImage
The processed image.
Exceptions
Exception | Condition
 | Thrown if the image paramater is not set.
See Also

Reference

FftGrid Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand Class

Similar to the high pass gaussian filter with an additive offset and multiplier.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftGaussianHighBoostFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GaussianHighBoostFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class GaussianHighBoostFftCommand
    Inherits FftCommand
    Implements ISerializable

The GaussianHighBoostFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | GaussianHighBoostFftCommand | Initializes a new instance of the GaussianHighBoostFftCommand class.
Protected method | GaussianHighBoostFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of GaussianHighBoostFftCommand.
Public method | GaussianHighBoostFftCommand(Double, Double, Double) | Initializes a new instance of GaussianHighBoostFftCommand specifying cutoff radius, factor, and offset.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | Factor | Gets or sets the multiplier applied to the high pass filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or sets the offset applied to the high pass filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
FftGrid Example


GaussianHighBoostFftCommand Constructor

Initializes a new instance of GaussianHighBoostFftCommand.
Overload List
 | Name | Description
Public method | GaussianHighBoostFftCommand | Initializes a new instance of the GaussianHighBoostFftCommand class.
Protected method | GaussianHighBoostFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of GaussianHighBoostFftCommand.
Public method | GaussianHighBoostFftCommand(Double, Double, Double) | Initializes a new instance of GaussianHighBoostFftCommand specifying cutoff radius, factor, and offset.
Top
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand Constructor

Initializes a new instance of the GaussianHighBoostFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GaussianHighBoostFftCommand()
Public Sub New
See Also

Reference

GaussianHighBoostFftCommand Class
GaussianHighBoostFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of GaussianHighBoostFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GaussianHighBoostFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

GaussianHighBoostFftCommand Class
GaussianHighBoostFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand Constructor (Double, Double, Double)

Initializes a new instance of GaussianHighBoostFftCommand specifying cutoff radius, factor, and offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GaussianHighBoostFftCommand(
    double cutoff,
    double offset,
    double factor
)
Public Sub New (
    cutoff As Double,
    offset As Double,
    factor As Double
)

Parameters

cutoff
Type: SystemDouble
offset
Type: SystemDouble
factor
Type: SystemDouble
See Also

Reference

GaussianHighBoostFftCommand Class
GaussianHighBoostFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand Properties

The GaussianHighBoostFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | Factor | Gets or sets the multiplier applied to the high pass filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or sets the offset applied to the high pass filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand.Cutoff Property

GaussianHighBoostFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand.Factor Property

GaussianHighBoostFftCommandFactor Property

Gets or sets the multiplier applied to the high pass filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Factor { get; set; }
Public Property Factor As Double
    Get
    Set

Property Value

Type: Double
the multiplier applied to the high pass filter.
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand.Offset Property

GaussianHighBoostFftCommandOffset Property

Gets or sets the offset applied to the high pass filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set

Property Value

Type: Double
The offset applied to the high pass filter.
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand Methods

The GaussianHighBoostFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand.ApplyToGrid Method

GaussianHighBoostFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighBoostFftCommand.GetObjectData Method

GaussianHighBoostFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | GaussianHighBoostFftCommand does not support serialization
See Also

Reference

GaussianHighBoostFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand Class

Similar to the ideal high pass filter, but with smoother transitions and less "ringing".
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftGaussianHighPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GaussianHighPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class GaussianHighPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The GaussianHighPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | GaussianHighPassFftCommand | Initializes a new instance of the GaussianHighPassFftCommand class.
Public method | GaussianHighPassFftCommand(Double) | itializes a new instance of GaussianHighPassFftCommand specifying the cutoff frequency.
Protected method | GaussianHighPassFftCommand(SerializationInfo, StreamingContext) | itializes a new instance of GaussianHighPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
Remarks
High pass filters clip low frequencies tending to sharpen images.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
FftGrid Example


GaussianHighPassFftCommand Constructor

Initializes a new instance of GaussianHighPassFftCommand.
Overload List
 | Name | Description
Public method | GaussianHighPassFftCommand | Initializes a new instance of the GaussianHighPassFftCommand class.
Public method | GaussianHighPassFftCommand(Double) | itializes a new instance of GaussianHighPassFftCommand specifying the cutoff frequency.
Protected method | GaussianHighPassFftCommand(SerializationInfo, StreamingContext) | itializes a new instance of GaussianHighPassFftCommand.
Top
See Also

Reference

GaussianHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand Constructor

Initializes a new instance of the GaussianHighPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GaussianHighPassFftCommand()
Public Sub New
See Also

Reference

GaussianHighPassFftCommand Class
GaussianHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand Constructor (Double)

itializes a new instance of GaussianHighPassFftCommand specifying the cutoff frequency.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GaussianHighPassFftCommand(
    double cutoff
)
Public Sub New (
    cutoff As Double
)

Parameters

cutoff
Type: SystemDouble
See Also

Reference

GaussianHighPassFftCommand Class
GaussianHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand Constructor (SerializationInfo, StreamingContext)

itializes a new instance of GaussianHighPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GaussianHighPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

GaussianHighPassFftCommand Class
GaussianHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand Properties

The GaussianHighPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

GaussianHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand.Cutoff Property

GaussianHighPassFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

GaussianHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand Methods

The GaussianHighPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

GaussianHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand.ApplyToGrid Method

GaussianHighPassFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

GaussianHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianHighPassFftCommand.GetObjectData Method

GaussianHighPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | GaussianHighPassFftCommand does not support serialization
See Also

Reference

GaussianHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand Class

Similar to the ideal low pass filter, but with smoother transitions and less "ringing".
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftGaussianLowPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GaussianLowPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class GaussianLowPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The GaussianLowPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | GaussianLowPassFftCommand | Initializes a new instance of the GaussianLowPassFftCommand class.
Public method | GaussianLowPassFftCommand(Double) | Initializes a new instance of GaussianLowPassFftCommand specifying the cutoff radius.
Protected method | GaussianLowPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of GaussianLowPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
Remarks
Low pass filters clip high frequencies tending to blur images.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
Atalasoft.Imaging.ImageProcessing.FftFftGrid


GaussianLowPassFftCommand Constructor

Initializes a new instance of GaussianLowPassFftCommand.
Overload List
 | Name | Description
Public method | GaussianLowPassFftCommand | Initializes a new instance of the GaussianLowPassFftCommand class.
Public method | GaussianLowPassFftCommand(Double) | Initializes a new instance of GaussianLowPassFftCommand specifying the cutoff radius.
Protected method | GaussianLowPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of GaussianLowPassFftCommand.
Top
See Also

Reference

GaussianLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand Constructor

Initializes a new instance of the GaussianLowPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GaussianLowPassFftCommand()
Public Sub New
See Also

Reference

GaussianLowPassFftCommand Class
GaussianLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand Constructor (Double)

Initializes a new instance of GaussianLowPassFftCommand specifying the cutoff radius.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GaussianLowPassFftCommand(
    double cutoff
)
Public Sub New (
    cutoff As Double
)

Parameters

cutoff
Type: SystemDouble
See Also

Reference

GaussianLowPassFftCommand Class
GaussianLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of GaussianLowPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GaussianLowPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

GaussianLowPassFftCommand Class
GaussianLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand Properties

The GaussianLowPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

GaussianLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand.Cutoff Property

GaussianLowPassFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

GaussianLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand Methods

The GaussianLowPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

GaussianLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand.ApplyToGrid Method

GaussianLowPassFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

GaussianLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


GaussianLowPassFftCommand.GetObjectData Method

GaussianLowPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | GaussianLowPassFftCommand does not support serialization
See Also

Reference

GaussianLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand Class

The ideal high pass filter zeros out all frequencies inside a specified cutoff radius.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftIdealHighPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IdealHighPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class IdealHighPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The IdealHighPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | IdealHighPassFftCommand | Initializes a new instance of the IdealHighPassFftCommand class.
Public method | IdealHighPassFftCommand(Double) | Initializes a new instance of IdealHighPassFftCommand specifying the cutoff radius.
Protected method | IdealHighPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of IdealHighPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
Remarks
High pass filters clip low frequencies tending to sharpen images. Ideal filters use a strict cutoff, tending to cause a ringing effect when converted back to the spatial domain. This "ringing" is similar to how JPEG's generate artifacts at sharp color changes. In practice, Ideal filters are rarely used due to this side effect.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
Atalasoft.Imaging.ImageProcessing.FftFftGrid


IdealHighPassFftCommand Constructor

Initializes a new instance of IdealHighPassFftCommand.
Overload List
 | Name | Description
Public method | IdealHighPassFftCommand | Initializes a new instance of the IdealHighPassFftCommand class.
Public method | IdealHighPassFftCommand(Double) | Initializes a new instance of IdealHighPassFftCommand specifying the cutoff radius.
Protected method | IdealHighPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of IdealHighPassFftCommand.
Top
See Also

Reference

IdealHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand Constructor

Initializes a new instance of the IdealHighPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IdealHighPassFftCommand()
Public Sub New
See Also

Reference

IdealHighPassFftCommand Class
IdealHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand Constructor (Double)

Initializes a new instance of IdealHighPassFftCommand specifying the cutoff radius.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IdealHighPassFftCommand(
    double cutoff
)
Public Sub New (
    cutoff As Double
)

Parameters

cutoff
Type: SystemDouble
The cutoff radius
See Also

Reference

IdealHighPassFftCommand Class
IdealHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of IdealHighPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IdealHighPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

IdealHighPassFftCommand Class
IdealHighPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand Properties

The IdealHighPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

IdealHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand.Cutoff Property

IdealHighPassFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

IdealHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand Methods

The IdealHighPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

IdealHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand.ApplyToGrid Method

IdealHighPassFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

IdealHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealHighPassFftCommand.GetObjectData Method

IdealHighPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | IdealHighPassFftCommand does not support serialization
See Also

Reference

IdealHighPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand Class

The ideal low pass filter zeros out all frequencies outside a specified cutoff radius.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftIdealLowPassFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IdealLowPassFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class IdealLowPassFftCommand
    Inherits FftCommand
    Implements ISerializable

The IdealLowPassFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | IdealLowPassFftCommand | Initializes a new instance of the IdealLowPassFftCommand class.
Public method | IdealLowPassFftCommand(Double) | Initializes a new instance of IdealLowPassFftCommand specifying the cutoff radius.
Protected method | IdealLowPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of IdealLowPassFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
Remarks
Low pass filters clip high frequencies tending to blur images. Ideal filters use a strict cutoff, tending to cause a ringing effect when converted back to the spatial domain. This "ringing" is similar to how JPEG's generate artifacts at sharp color changes. In practice, Ideal filters are rarely used due to this side effect.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
FftGrid Example


IdealLowPassFftCommand Constructor

Initializes a new instance of IdealLowPassFftCommand.
Overload List
 | Name | Description
Public method | IdealLowPassFftCommand | Initializes a new instance of the IdealLowPassFftCommand class.
Public method | IdealLowPassFftCommand(Double) | Initializes a new instance of IdealLowPassFftCommand specifying the cutoff radius.
Protected method | IdealLowPassFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of IdealLowPassFftCommand.
Top
See Also

Reference

IdealLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand Constructor

Initializes a new instance of the IdealLowPassFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IdealLowPassFftCommand()
Public Sub New
See Also

Reference

IdealLowPassFftCommand Class
IdealLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand Constructor (Double)

Initializes a new instance of IdealLowPassFftCommand specifying the cutoff radius.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IdealLowPassFftCommand(
    double cutoff
)
Public Sub New (
    cutoff As Double
)

Parameters

cutoff
Type: SystemDouble
The cutoff radius
See Also

Reference

IdealLowPassFftCommand Class
IdealLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of IdealLowPassFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IdealLowPassFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

IdealLowPassFftCommand Class
IdealLowPassFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand Properties

The IdealLowPassFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Cutoff | Gets or sets the cutoff radius in the frequency domain.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

IdealLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand.Cutoff Property

IdealLowPassFftCommandCutoff Property

Gets or sets the cutoff radius in the frequency domain.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Cutoff { get; set; }
Public Property Cutoff As Double
    Get
    Set

Property Value

Type: Double
The cutoff radius in the frequency domain.
See Also

Reference

IdealLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand Methods

The IdealLowPassFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

IdealLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand.ApplyToGrid Method

IdealLowPassFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

IdealLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


IdealLowPassFftCommand.GetObjectData Method

IdealLowPassFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | IdealLowPassFftCommand does not support serialization
See Also

Reference

IdealLowPassFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FftFftCommand
Atalasoft.Imaging.ImageProcessing.FftInversePowerFftCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InversePowerFftCommand : FftCommand,
    ISerializable
<SerializableAttribute>
Public Class InversePowerFftCommand
    Inherits FftCommand
    Implements ISerializable

The InversePowerFftCommand type exposes the following members.

Constructors
 | Name | Description
Public method | InversePowerFftCommand | Initializes a new instance of the InversePowerFftCommand class.
Public method | InversePowerFftCommand(Double) | Initializes a new instance of InversePowerFftCommand specifying the power.
Protected method | InversePowerFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of InversePowerFftCommand.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Power | Gets or sets the power applied to the function controlling the cutoff radius.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Fft Namespace
Atalasoft.Imaging.ImageProcessing.FftFftGrid


InversePowerFftCommand Constructor

Initializes a new instance of InversePowerFftCommand.
Overload List
 | Name | Description
Public method | InversePowerFftCommand | Initializes a new instance of the InversePowerFftCommand class.
Public method | InversePowerFftCommand(Double) | Initializes a new instance of InversePowerFftCommand specifying the power.
Protected method | InversePowerFftCommand(SerializationInfo, StreamingContext) | Initializes a new instance of InversePowerFftCommand.
Top
See Also

Reference

InversePowerFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand Constructor

Initializes a new instance of the InversePowerFftCommand class.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InversePowerFftCommand()
Public Sub New
See Also

Reference

InversePowerFftCommand Class
InversePowerFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand Constructor (Double)

Initializes a new instance of InversePowerFftCommand specifying the power.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InversePowerFftCommand(
    double power
)
Public Sub New (
    power As Double
)

Parameters

power
Type: SystemDouble
The power applied to the function controlling the cutoff radius.
See Also

Reference

InversePowerFftCommand Class
InversePowerFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of InversePowerFftCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected InversePowerFftCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

InversePowerFftCommand Class
InversePowerFftCommand Overload
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand Properties

The InversePowerFftCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Power | Gets or sets the power applied to the function controlling the cutoff radius.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from FftCommand.)
Top
See Also

Reference

InversePowerFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand.Power Property

InversePowerFftCommandPower Property

Gets or sets the power applied to the function controlling the cutoff radius.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Power { get; set; }
Public Property Power As Double
    Get
    Set

Property Value

Type: Double
The power applied to the function controlling the cutoff radius.
See Also

Reference

InversePowerFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand Methods

The InversePowerFftCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToGrid | Applies the filter on an FftGrid. (Overrides FftCommandApplyToGrid(FftGrid).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from FftCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from FftCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from FftCommand.)
Top
See Also

Reference

InversePowerFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand.ApplyToGrid Method

InversePowerFftCommandApplyToGrid Method

Applies the filter on an FftGrid.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ApplyToGrid(
    FftGrid grid
)
Public Overrides Sub ApplyToGrid (
    grid As FftGrid
)

Parameters

grid
Type: Atalasoft.Imaging.ImageProcessing.FftFftGrid
The FftGrid to process.

Return Value

Type:
null (Nothing in Visual Basic)
See Also

Reference

InversePowerFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


InversePowerFftCommand.GetObjectData Method

InversePowerFftCommandGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.Imaging.ImageProcessing.Fft
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
NotImplementedException | InversePowerFftCommand does not support serialization
See Also

Reference

InversePowerFftCommand Class
Atalasoft.Imaging.ImageProcessing.Fft Namespace


Atalasoft.Imaging.ImageProcessing.Filters Namespace

Classes
 | Class | Description
Public class | AdaptiveUnsharpMaskCommand | Uses a powerful technique for sharpening images in the presence of low noise levels via an adaptive filtering algorithm.
Public class | AddNoiseCommand | Add different types of noise to an image.
Public class | BlurCommand | Applies a Blur filter onto an image.
Public class | BlurGaussianCommand | Performs a Gaussian blur filter on the image. This has a more dispersed effect then the traditional blur filter, but slower.
 | CannyEdgeDetectorCommand | Find edges in an image using the Canny algorithm.
Public class | ColorizeCommand | This command can be used to replace the hue, saturation and luminance values in an image with those of a specified color.
Public class | ConvolutionFilterCommand | Applies a custom Convolution Filter to an image.
Public class | ConvolutionMatrixCommand | Applies a custom Convolution Matrix to an image.
Public class | DespeckleCommand | This filter cleans the image by removing stray pixel spikes (speckles).
Public class | DoubleMatrix | This object composes of a matrix of doubles that is used in various filters including ConvolutionFilterCommand and ConvolutionMatrixCommand.
Public class | DustAndScratchRemovalCommand | This command is used to remove dust and scratch marks from an image.
Public class | EdgeDetectionCommand | This filter enhances edges in an image.
 | EmbossCommand | Applies an embossing filter to the source image.
Public class | HighPassCommand | Removes Low Frequency signals from an image.
Public class | IntegerMatrix | This object composes of a matrix of integers that is used in various morphological and related filters.
Public class | IntensifyCommand | Increases the color intensity as if a flash of light from a camera hit it.
Public class | MaximumCommand | Sets each color value to the maximum value under the filter.
Public class | MeanCommand | Applies an Arithmetic, Harmonic, Geometric, or Yp mean filter to an image.
Public class | MedianCommand | Reduces noise in an image, similarly to the mean filter, however doing a better job preserving useful detail in the image.
Public class | MidpointCommand | Find the average of minimum and maximum values under the filter.
Public class | MinimumCommand | Find the minimum values under the filter.
Public class | MorphoGrayCommand | Applies a morphological Erosion, Dilation, Open, Close, or TopHat to a grayscale image.
Public class | SharpenCommand | Applies a traditional sharpening filter to the image.
Public class | ThresholdCommand | Set pixel components above a high threshold value to 255 and below a low threshold value to 0.
Public class | UnsharpMaskCommand | The unsharp mask is a sharpening filter which derives its name from the fact that it enhances edges and other high frequency components in an image via a procedure which subtracts an unsharp, or gaussian blurred, version of an image from the original image. The unsharp mask filter is commonly used in the photographic and printing industries for crispening edges.
Enumerations
 | Enumeration | Description
Public enumeration | AdaptiveUnsharpQuality | Indicates the quality level in the %AdaptiveUnsharpMaskCommand%.
Public enumeration | AddNoiseFilterType | The type of noise to add to an image.
Public enumeration | EdgeDetectionDirection | Specifies the direction of the edge detection
Public enumeration | EdgeDetectionType | Specified the type of the edge detection.
Public enumeration | EmbossMethod | Obsolete. The type of Emboss method to use in the EmbossCommand
Public enumeration | MeanFilterType | Various types of MeanFilter.
Public enumeration | MorphoGrayMode | The type of morphological filter to use in the MorphoGrayCommand.


AdaptiveUnsharpMaskCommand Class

Uses a powerful technique for sharpening images in the presence of low noise levels via an adaptive filtering algorithm.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersAdaptiveUnsharpMaskCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AdaptiveUnsharpMaskCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class AdaptiveUnsharpMaskCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The AdaptiveUnsharpMaskCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AdaptiveUnsharpMaskCommand | Creates a new instance of AdaptiveUnsharpMaskCommand.
Protected method | AdaptiveUnsharpMaskCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdaptiveUnsharpMaskCommand from serialization information.
Public method | AdaptiveUnsharpMaskCommand(Int32, Double, AdaptiveUnsharpQuality) | Creates a new instance of AdaptiveUnsharpMaskCommand specifying the threshold, sharpen amount and filter quality.
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the amount of the sharpened signal to add to the output image.,
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FilterQuality | Gets or sets the quality of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Threshold | Gets or sets a value controlling the depth of the effect.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand Constructor

Overload List
 | Name | Description
Public method | AdaptiveUnsharpMaskCommand | Creates a new instance of AdaptiveUnsharpMaskCommand.
Protected method | AdaptiveUnsharpMaskCommand(SerializationInfo, StreamingContext) | Creates a new instance of AdaptiveUnsharpMaskCommand from serialization information.
Public method | AdaptiveUnsharpMaskCommand(Int32, Double, AdaptiveUnsharpQuality) | Creates a new instance of AdaptiveUnsharpMaskCommand specifying the threshold, sharpen amount and filter quality.
Top
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand Constructor

Creates a new instance of AdaptiveUnsharpMaskCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveUnsharpMaskCommand()
Public Sub New
See Also

Reference

AdaptiveUnsharpMaskCommand Class
AdaptiveUnsharpMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AdaptiveUnsharpMaskCommand from serialization information.
Initializes a new instance of AdaptiveUnsharpMaskCommand. Creates a new instance of AdaptiveUnsharpMaskCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AdaptiveUnsharpMaskCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
Region of Interest is available in the Professional edition only.
See Also

Reference

AdaptiveUnsharpMaskCommand Class
AdaptiveUnsharpMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand Constructor (Int32, Double, AdaptiveUnsharpQuality)

Creates a new instance of AdaptiveUnsharpMaskCommand specifying the threshold, sharpen amount and filter quality.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveUnsharpMaskCommand(
    int threshold,
    double amount,
    AdaptiveUnsharpQuality filterQuality
)
Public Sub New (
    threshold As Integer,
    amount As Double,
    filterQuality As AdaptiveUnsharpQuality
)

Parameters

threshold
Type: SystemInt32

A value controlling the depth of the effect with the lower the value, the greater the effect. (0 to 255)

amount
Type: SystemDouble
The amount of the sharpened signal to add to the output image.
filterQuality
Type: Atalasoft.Imaging.ImageProcessing.FiltersAdaptiveUnsharpQuality
Quality of the filter.
Exceptions
Exception | Condition
 | Thrown if threshold is less than 0 or greater than 255.
See Also

Reference

AdaptiveUnsharpMaskCommand Class
AdaptiveUnsharpMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand Properties

The AdaptiveUnsharpMaskCommand type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the amount of the sharpened signal to add to the output image.,
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FilterQuality | Gets or sets the quality of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Threshold | Gets or sets a value controlling the depth of the effect.
Top
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.Amount Property

AdaptiveUnsharpMaskCommandAmount Property

Gets or sets the amount of the sharpened signal to add to the output image.,

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Amount { get; set; }
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double
The amount of the sharpened signal to add to the output image.
Remarks

0 = no change,1 = full change

You can use any number (even negative), but the intended use is between 0 and 1.

See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.FilterQuality Property

AdaptiveUnsharpMaskCommandFilterQuality Property

Gets or sets the quality of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdaptiveUnsharpQuality FilterQuality { get; set; }
Public Property FilterQuality As AdaptiveUnsharpQuality
    Get
    Set

Property Value

Type: AdaptiveUnsharpQuality
The quality of the filter.
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.SupportedPixelFormats Property

AdaptiveUnsharpMaskCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.Threshold Property

AdaptiveUnsharpMaskCommandThreshold Property

Gets or sets a value controlling the depth of the effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Threshold { get; set; }
Public Property Threshold As Integer
    Get
    Set

Property Value

Type: Int32

A value controlling the depth of the effect.

Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks

Any value between 0 and 255 is valid. The lower the value, the greater the effect.

See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand Methods

The AdaptiveUnsharpMaskCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.GetObjectData Method

AdaptiveUnsharpMaskCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.PerformActualCommand Method

AdaptiveUnsharpMaskCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.SelectPreferredPixelFormat Method

AdaptiveUnsharpMaskCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpMaskCommand.VerifyProperties Method

AdaptiveUnsharpMaskCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AdaptiveUnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AdaptiveUnsharpQuality Enumeration

Indicates the quality level in the %AdaptiveUnsharpMaskCommand%.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AdaptiveUnsharpQuality
Public Enumeration AdaptiveUnsharpQuality
Members
Member name | Description
Low | Less accurate results, but very fast.
Middle | Good results, slower to process.
High | Highest quality with the best results. Very slow.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace
AdaptiveUnsharpMaskCommand


AddNoiseCommand Class

Add different types of noise to an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersAddNoiseCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class AddNoiseCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class AddNoiseCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The AddNoiseCommand type exposes the following members.

Constructors
 | Name | Description
Public method | AddNoiseCommand | Creates a new instance of AddNoiseCommand.
Protected method | AddNoiseCommand(SerializationInfo, StreamingContext) | Creates a new instance of AddNoiseCommand from serialization information.
Public method | AddNoiseCommand(AddNoiseFilterType, Double, Boolean) | Initializes a new instance of AddNoiseCommand specifying the filter type, variance, and monochromatic setting.
Public method | AddNoiseCommand(AddNoiseFilterType, Double, Boolean, Double) | Initializes a new instance of AddNoiseCommand specifying the filter type, variance, monochromatic setting, and mean.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mean | Gets or sets a value which adds additional noise to the output for Gaussian and Uniform noise types.
Public property | Monochromatic | Gets or sets a value that when true applies the same noise equally to each channel.
Public property | NoiseType | Gets or sets the type of noise to apply.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Variance | Gets or sets a value controlling the intensity.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
See the Workspace or WorkspaceViewer for applying this command to an image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace
Workspace ApplyCommand
WorkspaceViewer ApplyCommand


AddNoiseCommand Constructor

Overload List
 | Name | Description
Public method | AddNoiseCommand | Creates a new instance of AddNoiseCommand.
Protected method | AddNoiseCommand(SerializationInfo, StreamingContext) | Creates a new instance of AddNoiseCommand from serialization information.
Public method | AddNoiseCommand(AddNoiseFilterType, Double, Boolean) | Initializes a new instance of AddNoiseCommand specifying the filter type, variance, and monochromatic setting.
Public method | AddNoiseCommand(AddNoiseFilterType, Double, Boolean, Double) | Initializes a new instance of AddNoiseCommand specifying the filter type, variance, monochromatic setting, and mean.
Top
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand Constructor

Creates a new instance of AddNoiseCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AddNoiseCommand()
Public Sub New
See Also

Reference

AddNoiseCommand Class
AddNoiseCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of AddNoiseCommand from serialization information.
Initialize a new instance of AddNoiseCommand. Creates a new instance of AddNoiseCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AddNoiseCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

AddNoiseCommand Class
AddNoiseCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand Constructor (AddNoiseFilterType, Double, Boolean)

Initializes a new instance of AddNoiseCommand specifying the filter type, variance, and monochromatic setting.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AddNoiseCommand(
    AddNoiseFilterType noiseType,
    double variance,
    bool monochromatic
)
Public Sub New (
    noiseType As AddNoiseFilterType,
    variance As Double,
    monochromatic As Boolean
)

Parameters

noiseType
Type: Atalasoft.Imaging.ImageProcessing.FiltersAddNoiseFilterType
The type of noise to apply.
variance
Type: SystemDouble
Controls the intensity.
monochromatic
Type: SystemBoolean
If True, the same noise is applied equally to all pixel channels.
Exceptions
Exception | Condition
 | Thrown if the variance argument is less than 0.
See Also

Reference

AddNoiseCommand Class
AddNoiseCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand Constructor (AddNoiseFilterType, Double, Boolean, Double)

Initializes a new instance of AddNoiseCommand specifying the filter type, variance, monochromatic setting, and mean.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AddNoiseCommand(
    AddNoiseFilterType noiseType,
    double variance,
    bool monochromatic,
    double mean
)
Public Sub New (
    noiseType As AddNoiseFilterType,
    variance As Double,
    monochromatic As Boolean,
    mean As Double
)

Parameters

noiseType
Type: Atalasoft.Imaging.ImageProcessing.FiltersAddNoiseFilterType
The type of noise to apply.
variance
Type: SystemDouble
Controls the intensity.
monochromatic
Type: SystemBoolean
When true applies the same noise equally to each channel.
mean
Type: SystemDouble
Adds additional noise to the output for Gaussian and Uniform noise types.
Exceptions
Exception | Condition
 | Thrown if the variance or mean arguments are less than 0.
See Also

Reference

AddNoiseCommand Class
AddNoiseCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand Properties

The AddNoiseCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mean | Gets or sets a value which adds additional noise to the output for Gaussian and Uniform noise types.
Public property | Monochromatic | Gets or sets a value that when true applies the same noise equally to each channel.
Public property | NoiseType | Gets or sets the type of noise to apply.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Variance | Gets or sets a value controlling the intensity.
Top
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.ChannelsToProcess Property

AddNoiseCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks

Only the fourth channel can be set using this flag. By default, with a value of 0, the fourth channel is ignored for RGBA images.

See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.InPlaceProcessing Property

AddNoiseCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.Mean Property

AddNoiseCommandMean Property

Gets or sets a value which adds additional noise to the output for Gaussian and Uniform noise types.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Mean { get; set; }
Public Property Mean As Double
    Get
    Set

Property Value

Type: Double
A value which adds additional noise to the output for Gaussian and Uniform noise types.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.Monochromatic Property

AddNoiseCommandMonochromatic Property

Gets or sets a value that when true applies the same noise equally to each channel.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Monochromatic { get; set; }
Public Property Monochromatic As Boolean
    Get
    Set

Property Value

Type: Boolean
A value that when true applies the same noise equally to each channel.
Exceptions
Exception | Condition
 | Thrown if value is null (Nothing in Visual Basic).
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.NoiseType Property

AddNoiseCommandNoiseType Property

Gets or sets the type of noise to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AddNoiseFilterType NoiseType { get; set; }
Public Property NoiseType As AddNoiseFilterType
    Get
    Set

Property Value

Type: AddNoiseFilterType
The type of noise to apply.
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.SupportedPixelFormats Property

AddNoiseCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.Variance Property

AddNoiseCommandVariance Property

Gets or sets a value controlling the intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Variance { get; set; }
Public Property Variance As Double
    Get
    Set

Property Value

Type: Double
A value controlling the intensity.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
There is no upper limit to this value. A good value to start with is around 500.
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand Methods

The AddNoiseCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.GetObjectData Method

AddNoiseCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.PerformActualCommand Method

AddNoiseCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseCommand.VerifyProperties Method

AddNoiseCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

AddNoiseCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


AddNoiseFilterType Enumeration

The type of noise to add to an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AddNoiseFilterType
Public Enumeration AddNoiseFilterType
Members
Member name | Description
Gaussian | A type of noise whose histogram is bell-shaped: most of the noise will occur in the middle of the pixel value range, and less noise will occur at the extremes.
Negative | Negative Exponential Noise.
Rayleigh | Rayleigh noise.
Uniform | Uniform Noise.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Class

Applies a Blur filter onto an image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersBlurCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BlurCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class BlurCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The BlurCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BlurCommand | Creates a new instance of BlurCommand.
Public method | BlurCommand(Double) | Initializes a new instance of BlurCommand specifying the intensity.
Public method | BlurCommand(Double, Int32) | Initializes a new instance of BlurCommand specifying the intensity and matrix size.
Protected method | BlurCommand(SerializationInfo, StreamingContext) | Creates a new instance of BlurCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value controlling the intensity of the filter.
Public property | MatrixSize | Gets or sets the size of the matrix.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Requires a continuous tone image.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Constructor

Overload List
 | Name | Description
Public method | BlurCommand | Creates a new instance of BlurCommand.
Public method | BlurCommand(Double) | Initializes a new instance of BlurCommand specifying the intensity.
Public method | BlurCommand(Double, Int32) | Initializes a new instance of BlurCommand specifying the intensity and matrix size.
Protected method | BlurCommand(SerializationInfo, StreamingContext) | Creates a new instance of BlurCommand from serialization information.
Top
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Constructor

Creates a new instance of BlurCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlurCommand()
Public Sub New
See Also

Reference

BlurCommand Class
BlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Constructor (Double)

Initializes a new instance of BlurCommand specifying the intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlurCommand(
    double intensity
)
Public Sub New (
    intensity As Double
)

Parameters

intensity
Type: SystemDouble

The intensity of the filter. (0 to 100)

Exceptions
Exception | Condition
 | Thrown if the intensity is less than 0 or greater than 100.
See Also

Reference

BlurCommand Class
BlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Constructor (Double, Int32)

Initializes a new instance of BlurCommand specifying the intensity and matrix size.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlurCommand(
    double intensity,
    int matrixSize
)
Public Sub New (
    intensity As Double,
    matrixSize As Integer
)

Parameters

intensity
Type: SystemDouble

The intensity of the filter. (0 to 100)

matrixSize
Type: SystemInt32
The size of the matrix. Should be an odd value greater than or equal to 3.
Exceptions
Exception | Condition
 | Thrown if the intensity is less than 0 or greater than 100, or if matrixSize is less than 3.
See Also

Reference

BlurCommand Class
BlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BlurCommand from serialization information.
Initializes a new instance of BlurCommand. Creates a new instance of BlurCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BlurCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

BlurCommand Class
BlurCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Properties

The BlurCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value controlling the intensity of the filter.
Public property | MatrixSize | Gets or sets the size of the matrix.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.ChannelsToProcess Property

BlurCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks

A value of 0 or AllChannels will process each channel in the image. Remove the fourth channel from the bit flag to ignore the alpha in an RGBA image.

See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.Intensity Property

BlurCommandIntensity Property

Gets or sets a value controlling the intensity of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
A value controlling the intensity of the filter.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are between 0 and 100.
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.MatrixSize Property

BlurCommandMatrixSize Property

Gets or sets the size of the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MatrixSize { get; set; }
Public Property MatrixSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the matrix.
Exceptions
Exception | Condition
 | Thrown if value is less than 3.
Remarks
The larger the matrix, the greater depth of the effect. Should be an odd value greater than or equal to 3.
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.SupportedPixelFormats Property

BlurCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand Methods

The BlurCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.ConstructFinalImage Method

BlurCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.GetObjectData Method

BlurCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.PerformActualCommand Method

BlurCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.SelectPreferredPixelFormat Method

BlurCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurCommand.VerifyProperties Method

BlurCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BlurCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Class

Performs a Gaussian blur filter on the image. This has a more dispersed effect then the traditional blur filter, but slower.
Performs a Gaussian blur filter on the image. This has a more dispersed effect then the traditional blur filter, but slower.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersBlurGaussianCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BlurGaussianCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class BlurGaussianCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The BlurGaussianCommand type exposes the following members.

Constructors
 | Name | Description
Public method | BlurGaussianCommand | Creates a new instance of BlurGaussianCommand.
Public method | BlurGaussianCommand(Double) | Creates a new instance of BlurGaussianCommand specifying the amount of blur.
Protected method | BlurGaussianCommand(SerializationInfo, StreamingContext) | Creates a new instance of BlurGaussianCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets the standard deviation of the gaussian kernal, controlling the amount of blur.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.

Our ActiveX version, ImgX, uses Intensity for this method where Intensity = (sigma - 0.5) * 100. A good value to start with is around 2.0.

Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.

Our ActiveX version, ImgX, uses Intensity for this method where Intensity = (sigma - 0.5) * 100. A good value to start with is around 2.0.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Constructor

Overload List
 | Name | Description
Public method | BlurGaussianCommand | Creates a new instance of BlurGaussianCommand.
Public method | BlurGaussianCommand(Double) | Creates a new instance of BlurGaussianCommand specifying the amount of blur.
Protected method | BlurGaussianCommand(SerializationInfo, StreamingContext) | Creates a new instance of BlurGaussianCommand from serialization information.
Top
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Constructor

Creates a new instance of BlurGaussianCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlurGaussianCommand()
Public Sub New
See Also

Reference

BlurGaussianCommand Class
BlurGaussianCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Constructor (Double)

Creates a new instance of BlurGaussianCommand specifying the amount of blur.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BlurGaussianCommand(
    double sigma
)
Public Sub New (
    sigma As Double
)

Parameters

sigma
Type: SystemDouble
The standard deviation of the gaussian kernal, controlling the amount of blur.
Exceptions
Exception | Condition
 | Thrown if sigma is less than 0.
See Also

Reference

BlurGaussianCommand Class
BlurGaussianCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BlurGaussianCommand from serialization information.
Initializes a new instance of %BlurGaussianCommand%. Creates a new instance of BlurGaussianCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BlurGaussianCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
Region of Interest is available in the Photo Pro and Document Imaging editions.
See Also

Reference

BlurGaussianCommand Class
BlurGaussianCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Properties

The BlurGaussianCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets the standard deviation of the gaussian kernal, controlling the amount of blur.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.ChannelsToProcess Property

BlurGaussianCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks

A value of 0 or AllChannels will process each channel in the image.

See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.Sigma Property

BlurGaussianCommandSigma Property

Gets or sets the standard deviation of the gaussian kernal, controlling the amount of blur.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Sigma { get; set; }
Public Property Sigma As Double
    Get
    Set

Property Value

Type: Double
The standard deviation of the gaussian kernal, controlling the amount of blur.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Good values to start with are between 0.6 and 2.4. The higher the value the greater the blur depth and longer the processing time.
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.SupportedPixelFormats Property

BlurGaussianCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand Methods

The BlurGaussianCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.ConstructFinalImage Method

BlurGaussianCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.GetObjectData Method

BlurGaussianCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.PerformActualCommand Method

BlurGaussianCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.SelectPreferredPixelFormat Method

BlurGaussianCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


BlurGaussianCommand.VerifyProperties Method

BlurGaussianCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

BlurGaussianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Class

Find edges in an image using the Canny algorithm.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersCannyEdgeDetectorCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CannyEdgeDetectorCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class CannyEdgeDetectorCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The CannyEdgeDetectorCommand type exposes the following members.

Constructors
 | Name | Description
Public method | CannyEdgeDetectorCommand | Creates a new instance of CannyEdgeDetectorCommand.
Protected method | CannyEdgeDetectorCommand(SerializationInfo, StreamingContext) | Creates a new instance of CannyEdgeDetectorCommand from serialization information.
Public method | CannyEdgeDetectorCommand(Double, Double, Double) | Creates a new instance of CannyEdgeDetectorCommand specifying the deviation and hysteresis.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighHysteresis | Gets or sets a value used to specify the high hysteresis value.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | LowHysteresis | Gets or sets a value used to specify the low hysteresis value.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets the standard deviation of the gaussian kernal.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Applies a Canny Edge Detection filter using the current settings to the specified image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Examples
CannyEdge Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Apply the command.
CannyEdgeDetectorCommand cmd = new CannyEdgeDetectorCommand(1.1, 30, 20);
AtalaImage result = cmd.Apply(image).Image;

image.Dispose();
CannyEdge Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Apply the command.
Dim cmd As CannyEdgeDetectorCommand =  New CannyEdgeDetectorCommand(1.1,30,20)
Dim result As AtalaImage =  cmd.Apply(image).Image

image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Constructor

Overload List
 | Name | Description
Public method | CannyEdgeDetectorCommand | Creates a new instance of CannyEdgeDetectorCommand.
Protected method | CannyEdgeDetectorCommand(SerializationInfo, StreamingContext) | Creates a new instance of CannyEdgeDetectorCommand from serialization information.
Public method | CannyEdgeDetectorCommand(Double, Double, Double) | Creates a new instance of CannyEdgeDetectorCommand specifying the deviation and hysteresis.
Top
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Constructor

Creates a new instance of CannyEdgeDetectorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CannyEdgeDetectorCommand()
Public Sub New
See Also

Reference

CannyEdgeDetectorCommand Class
CannyEdgeDetectorCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of CannyEdgeDetectorCommand from serialization information.
Initializes a new instance of CannyEdgeDetectorCommand. Creates a new instance of CannyEdgeDetectorCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CannyEdgeDetectorCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

CannyEdgeDetectorCommand Class
CannyEdgeDetectorCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Constructor (Double, Double, Double)

Creates a new instance of CannyEdgeDetectorCommand specifying the deviation and hysteresis.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CannyEdgeDetectorCommand(
    double sigma,
    double lowHysteresis,
    double highHysteresis
)
Public Sub New (
    sigma As Double,
    lowHysteresis As Double,
    highHysteresis As Double
)

Parameters

sigma
Type: SystemDouble
Standard deviation of the gaussian kernal.
lowHysteresis
Type: SystemDouble
The low hysteresis value. (0 to 100)
highHysteresis
Type: SystemDouble
The high hysteresis value. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if the lowHysteresis or highHysteresis is less than 0 or greater than 100, or if sigma is less than 0.
See Also

Reference

CannyEdgeDetectorCommand Class
CannyEdgeDetectorCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Properties

The CannyEdgeDetectorCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | HighHysteresis | Gets or sets a value used to specify the high hysteresis value.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | LowHysteresis | Gets or sets a value used to specify the low hysteresis value.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets the standard deviation of the gaussian kernal.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.HighHysteresis Property

CannyEdgeDetectorCommandHighHysteresis Property

Gets or sets a value used to specify the high hysteresis value.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HighHysteresis { get; set; }
Public Property HighHysteresis As Double
    Get
    Set

Property Value

Type: Double
A value used to specify the high hysteresis value.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
This fraction (0 to 100) specifies the percentage point in a histogram of the gradient of the magnitude. Magnitude values of zero are not counted in the histogram. Good starting values are between 60 and 90.
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.LowHysteresis Property

CannyEdgeDetectorCommandLowHysteresis Property

Gets or sets a value used to specify the low hysteresis value.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LowHysteresis { get; set; }
Public Property LowHysteresis As Double
    Get
    Set

Property Value

Type: Double
A value used to specify the low hysteresis value.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
This is a percentage of the computed high threshold edge strength value. Good starting values are between 20 and 50.
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.Sigma Property

CannyEdgeDetectorCommandSigma Property

Gets or sets the standard deviation of the gaussian kernal.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Sigma { get; set; }
Public Property Sigma As Double
    Get
    Set

Property Value

Type: Double
The standard deviation of the gaussian kernal.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Good values to start with are between 0.6 and 2.4. Higher values increase processing time.
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.SupportedPixelFormats Property

CannyEdgeDetectorCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand Methods

The CannyEdgeDetectorCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Applies a Canny Edge Detection filter using the current settings to the specified image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.Apply Method

CannyEdgeDetectorCommandApply Method

Applies a Canny Edge Detection filter using the current settings to the specified image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageResults Apply(
    AtalaImage image
)
Public Overrides Function Apply (
    image As AtalaImage
) As ImageResults

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source %AtalaImage% which will be processed.

Return Value

Type: ImageResults
A new AtalaImage containing the processed image or null (Nothing in Visual Basic) if cancelled.
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.GetObjectData Method

CannyEdgeDetectorCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.PerformActualCommand Method

CannyEdgeDetectorCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.SelectPreferredPixelFormat Method

CannyEdgeDetectorCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


CannyEdgeDetectorCommand.VerifyProperties Method

CannyEdgeDetectorCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

CannyEdgeDetectorCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Class

This command can be used to replace the hue, saturation and luminance values in an image with those of a specified color.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.FiltersColorizeCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ColorizeCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ColorizeCommand
    Inherits ImageCommand
    Implements ISerializable

The ColorizeCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ColorizeCommand | Creates a new instance of ColorizeCommand.
Public method | ColorizeCommand(Color) | Creates a new instance of ColorizeCommand specifying the base color.
Protected method | ColorizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of ColorizeCommand from serialization information.
Public method | ColorizeCommand(Color, Boolean, Boolean, Boolean) | Creates a new instance of ColorizeCommand specifying the base color and values indicating whether to process the hue, saturation and luminance.
Top
Properties
 | Name | Description
Public property | ApplyHue | Gets or sets a value indicating whether the hue pixel values is replaced by the BaseColor hue.
Public property | ApplyLuminance | Gets or sets a value indicating whether the luminance pixel values is replaced by the BaseColor luminance.
Public property | ApplySaturation | Gets or sets a value indicating whether the saturation pixel values is replaced by the BaseColor saturation.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BaseColor | Gets or sets the base color used for processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Constructor

Creates a new instance of ColorizeCommand.
Overload List
 | Name | Description
Public method | ColorizeCommand | Creates a new instance of ColorizeCommand.
Public method | ColorizeCommand(Color) | Creates a new instance of ColorizeCommand specifying the base color.
Protected method | ColorizeCommand(SerializationInfo, StreamingContext) | Creates a new instance of ColorizeCommand from serialization information.
Public method | ColorizeCommand(Color, Boolean, Boolean, Boolean) | Creates a new instance of ColorizeCommand specifying the base color and values indicating whether to process the hue, saturation and luminance.
Top
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Constructor

Creates a new instance of ColorizeCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorizeCommand()
Public Sub New
See Also

Reference

ColorizeCommand Class
ColorizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Constructor (Color)

Creates a new instance of ColorizeCommand specifying the base color.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorizeCommand(
    Color baseColor
)
Public Sub New (
    baseColor As Color
)

Parameters

baseColor
Type: System.DrawingColor
The color used for processing.
See Also

Reference

ColorizeCommand Class
ColorizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ColorizeCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ColorizeCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ColorizeCommand Class
ColorizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Constructor (Color, Boolean, Boolean, Boolean)

Creates a new instance of ColorizeCommand specifying the base color and values indicating whether to process the hue, saturation and luminance.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorizeCommand(
    Color baseColor,
    bool applyHue,
    bool applySaturation,
    bool applyLuminance
)
Public Sub New (
    baseColor As Color,
    applyHue As Boolean,
    applySaturation As Boolean,
    applyLuminance As Boolean
)

Parameters

baseColor
Type: System.DrawingColor
The color used for processing.
applyHue
Type: SystemBoolean
Set to true to replace the pixel hue with the hue from baseColor.
applySaturation
Type: SystemBoolean
Set to true to replace the pixel saturation with the saturation from baseColor.
applyLuminance
Type: SystemBoolean
Set to true to replace the pixel luminance with the luminance from baseColor.
See Also

Reference

ColorizeCommand Class
ColorizeCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Properties

The ColorizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyHue | Gets or sets a value indicating whether the hue pixel values is replaced by the BaseColor hue.
Public property | ApplyLuminance | Gets or sets a value indicating whether the luminance pixel values is replaced by the BaseColor luminance.
Public property | ApplySaturation | Gets or sets a value indicating whether the saturation pixel values is replaced by the BaseColor saturation.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BaseColor | Gets or sets the base color used for processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.ApplyHue Property

ColorizeCommandApplyHue Property

Gets or sets a value indicating whether the hue pixel values is replaced by the BaseColor hue.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ApplyHue { get; set; }
Public Property ApplyHue As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the hue pixel values is replaced by the BaseColor hue.
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.ApplyLuminance Property

ColorizeCommandApplyLuminance Property

Gets or sets a value indicating whether the luminance pixel values is replaced by the BaseColor luminance.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ApplyLuminance { get; set; }
Public Property ApplyLuminance As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the luminance pixel values is replaced by the BaseColor luminance.
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.ApplySaturation Property

ColorizeCommandApplySaturation Property

Gets or sets a value indicating whether the saturation pixel values is replaced by the BaseColor saturation.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ApplySaturation { get; set; }
Public Property ApplySaturation As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the saturation pixel values is replaced by the BaseColor saturation.
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.BaseColor Property

ColorizeCommandBaseColor Property

Gets or sets the base color used for processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BaseColor { get; set; }
Public Property BaseColor As Color
    Get
    Set

Property Value

Type: Color
The base color used for processing.
Remarks
The hue, saturation and luminance of this color is used to process the image.
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.SupportedPixelFormats Property

ColorizeCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand Methods

The ColorizeCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.ConstructFinalImage Method

ColorizeCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.GetObjectData Method

ColorizeCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.PerformActualCommand Method

ColorizeCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ColorizeCommand.VerifyProperties Method

ColorizeCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ColorizeCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Class

Applies a custom Convolution Filter to an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersConvolutionFilterCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ConvolutionFilterCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class ConvolutionFilterCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The ConvolutionFilterCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ConvolutionFilterCommand | Creates a new instance of ConvolutionFilterCommand.
Protected method | ConvolutionFilterCommand(SerializationInfo, StreamingContext) | Creates a new instance of ConvolutionFilterCommand from serialization information.
Public method | ConvolutionFilterCommand(DoubleMatrix, Double) | Creates a new instance of ConvolutionFilterCommand specifying the matrix and intensity.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value controlling the intensity of the filter.
Public property | Matrix | Gets or sets the matrix to apply to the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Traditional | Gets or sets a value indicating if the traditional version is used.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This should only be used on continuous-tone images (RGBA, grayscale, RGB, etc.).

If Traditional is true, this can be used to do things like a Gaussian blur, etc., depending on the matrix used.

The number of columns and the number of rows in the matrix must both be odd.

The filter is applied as follows :

M = matrix ( 3 x 3, in this example)

M = 1 1 1 this is a sharpening matrix 1 -8 1 1 1 1

The matrix is centered on the current pixel. In this example, M[4] is the center of the matrix.

k is the inteisity.

P = pixels . Since the matrix is centered on the current pixel, P(x,y), the pixels used in this calculation will be :

P(x-1,y-1) P(x, y-1) P(x+1, y-1) P(x-1,y) P(x, y) P(x+1, y) P(x-1,y+1) P(x, y+1) P(x+1, y+1)

t = sum ( M[i] * P[i] ) [for all elements of the matrix]

if "traditional" processing (see uFlags) , outPixel = k * t ,else , outPixel = curPixel - (k * t)

outPixel is then clipped to 0..255

Matrix M in this example demonstrates the sharpening filter used by this library, if bTraditional is FALSE.

Besides the ability to use matricies of arbitrary size, this object differs from %ConvolutionMatrixCommand% in the way the final calculation is performed.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Constructor

Overload List
 | Name | Description
Public method | ConvolutionFilterCommand | Creates a new instance of ConvolutionFilterCommand.
Protected method | ConvolutionFilterCommand(SerializationInfo, StreamingContext) | Creates a new instance of ConvolutionFilterCommand from serialization information.
Public method | ConvolutionFilterCommand(DoubleMatrix, Double) | Creates a new instance of ConvolutionFilterCommand specifying the matrix and intensity.
Top
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Constructor

Creates a new instance of ConvolutionFilterCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConvolutionFilterCommand()
Public Sub New
See Also

Reference

ConvolutionFilterCommand Class
ConvolutionFilterCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ConvolutionFilterCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ConvolutionFilterCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ConvolutionFilterCommand Class
ConvolutionFilterCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Constructor (DoubleMatrix, Double)

Creates a new instance of ConvolutionFilterCommand specifying the matrix and intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConvolutionFilterCommand(
    DoubleMatrix matrix,
    double intensity
)
Public Sub New (
    matrix As DoubleMatrix,
    intensity As Double
)

Parameters

matrix
Type: Atalasoft.Imaging.ImageProcessing.FiltersDoubleMatrix
The matrix to apply to the image.
intensity
Type: SystemDouble
The intensity of the filter.
Exceptions
Exception | Condition
 | Thrown if the intensity is less than 0.
 | Thrown if the matrix has an even number of rows or columns
See Also

Reference

ConvolutionFilterCommand Class
ConvolutionFilterCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Properties

The ConvolutionFilterCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value controlling the intensity of the filter.
Public property | Matrix | Gets or sets the matrix to apply to the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Traditional | Gets or sets a value indicating if the traditional version is used.
Top
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.ChannelsToProcess Property

ConvolutionFilterCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.Intensity Property

ConvolutionFilterCommandIntensity Property

Gets or sets a value controlling the intensity of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
A value controlling the intensity of the filter.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks

Must be a value greater than 0.

See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.Matrix Property

ConvolutionFilterCommandMatrix Property

Gets or sets the matrix to apply to the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DoubleMatrix Matrix { get; set; }
Public Property Matrix As DoubleMatrix
    Get
    Set

Property Value

Type: DoubleMatrix
A Matrix of 9 or more double
Exceptions
Exception | Condition
 | Thrown if the matrix has an even number of rows or columns
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.SupportedPixelFormats Property

ConvolutionFilterCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel8bppIndexed
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.Traditional Property

ConvolutionFilterCommandTraditional Property

Gets or sets a value indicating if the traditional version is used.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Traditional { get; set; }
Public Property Traditional As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the traditional version is used.
Remarks
The traditional filter can be used to perform gaussian blur and some others.
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand Methods

The ConvolutionFilterCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.ConstructFinalImage Method

ConvolutionFilterCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.GetObjectData Method

ConvolutionFilterCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.PerformActualCommand Method

ConvolutionFilterCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.SelectPreferredPixelFormat Method

ConvolutionFilterCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionFilterCommand.VerifyProperties Method

ConvolutionFilterCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ConvolutionFilterCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Class

Applies a custom Convolution Matrix to an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersConvolutionMatrixCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ConvolutionMatrixCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class ConvolutionMatrixCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The ConvolutionMatrixCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ConvolutionMatrixCommand | Creates a new instance of ConvolutionMatrixCommand.
Protected method | ConvolutionMatrixCommand(SerializationInfo, StreamingContext) | Creates a new instance of ConvolutionMatrixCommand from serialization information.
Public method | ConvolutionMatrixCommand(DoubleMatrix, Boolean, Double) | Creates a new instance of ConvolutionMatrixCommand specifying the matrix, feedback and intensity.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | Feedback | Gets or sets a value indicating if a feedback calculation is performed.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value controlling the intensity of the filter.
Public property | Matrix | Gets or sets the matrix to apply to the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.

The matrix is an array of 9 doubles, arranged as : ,,

0 1 2 3 4 5 6 7 8

,where "4" is the source pixel. ,,It is applied for pixel(x,y) as : ,,Step 1 ,
            double tempSum = ( ,            pMatrix[0] * pixel(x-1, y-1) + ,            pMatrix[1] * pixel(x, y-1) +
            ,            pMatrix[2] * pixel(x+1, y-1) + ,            pMatrix[3] * pixel(x-1, y ) + ,
            pMatrix[4] * pixel(x, y ) + ,            pMatrix[5] * pixel(x+1, y ) + ,            pMatrix[6] *
            pixel(x-1, y+1) + ,            pMatrix[7] * pixel(x, y+1) + ,            pMatrix[8] * pixel(x+1, y+1));
            ,,Step 2 ,    if doFeedback = true,         tempSum = pixel(x,y) * (1.0 - k) + (k *
            tempSum);,    else,         tempSum = tempSum * k; ,,    where k is the
            intensity,,Step 3 ,    tempSum = min(tempSum, 255); ,,Step 4 ,    tempSum =
            max(tempSum, 0); ,,Step 5 ,    outval = tempSum;

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Constructor

Overload List
 | Name | Description
Public method | ConvolutionMatrixCommand | Creates a new instance of ConvolutionMatrixCommand.
Protected method | ConvolutionMatrixCommand(SerializationInfo, StreamingContext) | Creates a new instance of ConvolutionMatrixCommand from serialization information.
Public method | ConvolutionMatrixCommand(DoubleMatrix, Boolean, Double) | Creates a new instance of ConvolutionMatrixCommand specifying the matrix, feedback and intensity.
Top
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Constructor

Creates a new instance of ConvolutionMatrixCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConvolutionMatrixCommand()
Public Sub New
See Also

Reference

ConvolutionMatrixCommand Class
ConvolutionMatrixCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ConvolutionMatrixCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ConvolutionMatrixCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ConvolutionMatrixCommand Class
ConvolutionMatrixCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Constructor (DoubleMatrix, Boolean, Double)

Creates a new instance of ConvolutionMatrixCommand specifying the matrix, feedback and intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ConvolutionMatrixCommand(
    DoubleMatrix matrix,
    bool feedback,
    double intensity
)
Public Sub New (
    matrix As DoubleMatrix,
    feedback As Boolean,
    intensity As Double
)

Parameters

matrix
Type: Atalasoft.Imaging.ImageProcessing.FiltersDoubleMatrix
The matrix to apply to the image.
feedback
Type: SystemBoolean
Indicates if a feedback calculation is performed.
intensity
Type: SystemDouble
The intensity of the filter.
Exceptions
Exception | Condition
 | Thrown if matrix is not a 3x3 matrix or if intensity is less than 0.
See Also

Reference

ConvolutionMatrixCommand Class
ConvolutionMatrixCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Properties

The ConvolutionMatrixCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | Feedback | Gets or sets a value indicating if a feedback calculation is performed.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value controlling the intensity of the filter.
Public property | Matrix | Gets or sets the matrix to apply to the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.ChannelsToProcess Property

ConvolutionMatrixCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.Feedback Property

ConvolutionMatrixCommandFeedback Property

Gets or sets a value indicating if a feedback calculation is performed.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Feedback { get; set; }
Public Property Feedback As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if a feedback calculation is performed.
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.Intensity Property

ConvolutionMatrixCommandIntensity Property

Gets or sets a value controlling the intensity of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
A value controlling the intensity of the filter.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Must be a value greater than 0.
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.Matrix Property

ConvolutionMatrixCommandMatrix Property

Gets or sets the matrix to apply to the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DoubleMatrix Matrix { get; set; }
Public Property Matrix As DoubleMatrix
    Get
    Set

Property Value

Type: DoubleMatrix

The matrix to apply to the image.

Exceptions
Exception | Condition
 | Thrown if value is not a 3x3 matrix.
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.SupportedPixelFormats Property

ConvolutionMatrixCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel8bppIndexed
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand Methods

The ConvolutionMatrixCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.ConstructFinalImage Method

ConvolutionMatrixCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.GetObjectData Method

ConvolutionMatrixCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.PerformActualCommand Method

ConvolutionMatrixCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.SelectPreferredPixelFormat Method

ConvolutionMatrixCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ConvolutionMatrixCommand.VerifyProperties Method

ConvolutionMatrixCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ConvolutionMatrixCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand Class

This filter cleans the image by removing stray pixel spikes (speckles).
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersDespeckleCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DespeckleCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class DespeckleCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The DespeckleCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DespeckleCommand | Creates a new instance of DespeckleCommand.
Protected method | DespeckleCommand(SerializationInfo, StreamingContext) | Creates a new instance of DespeckleCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | InternalActualCommand | InternalActualCommand does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
For despeckling document images, see DocumentDespeckleCommand.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand Constructor

Overload List
 | Name | Description
Public method | DespeckleCommand | Creates a new instance of DespeckleCommand.
Protected method | DespeckleCommand(SerializationInfo, StreamingContext) | Creates a new instance of DespeckleCommand from serialization information.
Top
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand Constructor

Creates a new instance of DespeckleCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DespeckleCommand()
Public Sub New
See Also

Reference

DespeckleCommand Class
DespeckleCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DespeckleCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DespeckleCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

DespeckleCommand Class
DespeckleCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand Properties

The DespeckleCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.AutoThread Property

DespeckleCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.ChannelsToProcess Property

DespeckleCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.InPlaceProcessing Property

DespeckleCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.SupportedPixelFormats Property

DespeckleCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand Methods

The DespeckleCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of the command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Protected method | InternalActualCommand | InternalActualCommand does the actual work of the image processing command.
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.AdjustBands Method

DespeckleCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.Clone Method

DespeckleCommandClone Method

Returns a copy of the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the DespeckleCommand.

Implements

ICloneableClone
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.GetObjectData Method

DespeckleCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.InternalActualCommand Method

DespeckleCommandInternalActualCommand Method

InternalActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage InternalActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Function InternalActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
Null (Nothing in VB)
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.PerformActualCommand Method

DespeckleCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.PerformSectionCommand Method

DespeckleCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DespeckleCommand.VerifyProperties Method

DespeckleCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DespeckleCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix Class

This object composes of a matrix of doubles that is used in various filters including ConvolutionFilterCommand and ConvolutionMatrixCommand.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.FiltersDoubleMatrix

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DoubleMatrix : ISerializable
<SerializableAttribute>
Public Class DoubleMatrix
    Implements ISerializable

The DoubleMatrix type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleMatrix(Int32, Int32) | Creates a new instance of DoubleMatrix.
Protected method | DoubleMatrix(SerializationInfo, StreamingContext) | Creates a new instance of DoubleMatrix from serialization information.
Top
Properties
 | Name | Description
Public property | Columns | Gets or sets the number of columns in the matrix.
Public property | Rows | Gets or sets the number of rows in the matrix.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArray | Return a one-dimentional array that composes of the matrix elements.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItem | Gets a value in the specified location of the matrix.
Public method | GetObjectData | Fills a SerializationInfo object with information about this object.
Public method | GetRow | Returns a one-dimensional array containing an entire row of the matrix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetItem | Set the value of an element in the array.
Public method | SetRow | Set the entire row of the matrix to a parameter list of values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix Constructor

Overload List
 | Name | Description
Public method | DoubleMatrix(Int32, Int32) | Creates a new instance of DoubleMatrix.
Protected method | DoubleMatrix(SerializationInfo, StreamingContext) | Creates a new instance of DoubleMatrix from serialization information.
Top
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix Constructor (Int32, Int32)

Creates a new instance of DoubleMatrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DoubleMatrix(
    int rows,
    int columns
)
Public Sub New (
    rows As Integer,
    columns As Integer
)

Parameters

rows
Type: SystemInt32
The number of rows in the matrix.
columns
Type: SystemInt32
The number of columns in the matrix.
See Also

Reference

DoubleMatrix Class
DoubleMatrix Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DoubleMatrix from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DoubleMatrix(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

DoubleMatrix Class
DoubleMatrix Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix Properties

The DoubleMatrix type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Gets or sets the number of columns in the matrix.
Public property | Rows | Gets or sets the number of rows in the matrix.
Top
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.Columns Property

DoubleMatrixColumns Property

Gets or sets the number of columns in the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get

Property Value

Type: Int32
The number of columns in the matrix.
Remarks
Most methods require an odd and equal number of columns and rows.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.Rows Property

DoubleMatrixRows Property

Gets or sets the number of rows in the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
The number of rows in the matrix.
Remarks
Most methods require an odd and equal number of columns and rows.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix Methods

The DoubleMatrix type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArray | Return a one-dimentional array that composes of the matrix elements.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItem | Gets a value in the specified location of the matrix.
Public method | GetObjectData | Fills a SerializationInfo object with information about this object.
Public method | GetRow | Returns a one-dimensional array containing an entire row of the matrix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetItem | Set the value of an element in the array.
Public method | SetRow | Set the entire row of the matrix to a parameter list of values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.GetArray Method

DoubleMatrixGetArray Method

Return a one-dimentional array that composes of the matrix elements.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] GetArray()
Public Function GetArray As Double()

Return Value

Type: Double
A one-dimentional array that composes of the matrix elements.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.GetItem Method

DoubleMatrixGetItem Method

Gets a value in the specified location of the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetItem(
    int row,
    int column
)
Public Function GetItem (
    row As Integer,
    column As Integer
) As Double

Parameters

row
Type: SystemInt32
The row containing the element to get. (zero based)
column
Type: SystemInt32
The column containing the element to get. (zero based)

Return Value

Type: Double
A value in the specified location of the matrix.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.GetObjectData Method

DoubleMatrixGetObjectData Method

Fills a SerializationInfo object with information about this object.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.GetRow Method

DoubleMatrixGetRow Method

Returns a one-dimensional array containing an entire row of the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] GetRow(
    int rowIndex
)
Public Function GetRow (
    rowIndex As Integer
) As Double()

Parameters

rowIndex
Type: SystemInt32
The zero based row to retreive.

Return Value

Type: Double
A one-dimensional array containing an entire row of the matrix.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.SetItem Method

DoubleMatrixSetItem Method

Set the value of an element in the array.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetItem(
    int row,
    int column,
    double itemValue
)
Public Sub SetItem (
    row As Integer,
    column As Integer,
    itemValue As Double
)

Parameters

row
Type: SystemInt32
The row containing the element to set. (zero based)
column
Type: SystemInt32
The column containing the element to set. (zero based)
itemValue
Type: SystemDouble
The value to set.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DoubleMatrix.SetRow Method

DoubleMatrixSetRow Method

Set the entire row of the matrix to a parameter list of values.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetRow(
    int rowIndex,
    params double[] rowList
)
Public Sub SetRow (
    rowIndex As Integer,
    ParamArray rowList As Double()
)

Parameters

rowIndex
Type: SystemInt32
The zero based row index to set.
rowList
Type: SystemDouble
A parameter array of doubles that are set to the matrix row.
See Also

Reference

DoubleMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Class

This command is used to remove dust and scratch marks from an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersDustAndScratchRemovalCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DustAndScratchRemovalCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class DustAndScratchRemovalCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The DustAndScratchRemovalCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DustAndScratchRemovalCommand | Creates a new instance of DustAndStratchRemovalCommand.
Protected method | DustAndScratchRemovalCommand(SerializationInfo, StreamingContext) | Creates a new instance of DustAndScratchRemovalCommand specifying the filter size, threshold and blending values. Creates a new instance of DustAndScratchRemovalCommand.
Public method | DustAndScratchRemovalCommand(Int32, Int32, Double) | Creates a new instance of DustAndScratchRemovalCommand specifying the filter size, threshold and blending.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | Blending | Gets or sets the blending of original image with the removed image detail.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the channels of the image to process.
Public property | FilterSize | Gets or sets the size of the features that will be removed.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Threshold | Gets or sets the minimum detail intensity required to trigger removal.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Constructor

Overload List
 | Name | Description
Public method | DustAndScratchRemovalCommand | Creates a new instance of DustAndStratchRemovalCommand.
Protected method | DustAndScratchRemovalCommand(SerializationInfo, StreamingContext) | Creates a new instance of DustAndScratchRemovalCommand specifying the filter size, threshold and blending values. Creates a new instance of DustAndScratchRemovalCommand.
Public method | DustAndScratchRemovalCommand(Int32, Int32, Double) | Creates a new instance of DustAndScratchRemovalCommand specifying the filter size, threshold and blending.
Top
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Constructor

Creates a new instance of DustAndStratchRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DustAndScratchRemovalCommand()
Public Sub New
See Also

Reference

DustAndScratchRemovalCommand Class
DustAndScratchRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of DustAndScratchRemovalCommand specifying the filter size, threshold and blending values.
Creates a new instance of DustAndScratchRemovalCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DustAndScratchRemovalCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

DustAndScratchRemovalCommand Class
DustAndScratchRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Constructor (Int32, Int32, Double)

Creates a new instance of DustAndScratchRemovalCommand specifying the filter size, threshold and blending.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DustAndScratchRemovalCommand(
    int filterSize,
    int threshold,
    double blending
)
Public Sub New (
    filterSize As Integer,
    threshold As Integer,
    blending As Double
)

Parameters

filterSize
Type: SystemInt32
The size of the features that will be removed.
threshold
Type: SystemInt32
The minimum detail intensity required to trigger removal. (0 to 255)
blending
Type: SystemDouble
The blending of original image with the removed image detail. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if filterSize is less than 0, threshold is less than 0 or greater than 255, or if blending is less than 0 or greater than 100.
See Also

Reference

DustAndScratchRemovalCommand Class
DustAndScratchRemovalCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Properties

The DustAndScratchRemovalCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | Blending | Gets or sets the blending of original image with the removed image detail.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the channels of the image to process.
Public property | FilterSize | Gets or sets the size of the features that will be removed.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Threshold | Gets or sets the minimum detail intensity required to trigger removal.
Top
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.Blending Property

DustAndScratchRemovalCommandBlending Property

Gets or sets the blending of original image with the removed image detail.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Blending { get; set; }
Public Property Blending As Double
    Get
    Set

Property Value

Type: Double
The blending of original image with the removed image detail.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.ChannelsToProcess Property

DustAndScratchRemovalCommandChannelsToProcess Property

Gets or sets the channels of the image to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The channels of the image to process.
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.FilterSize Property

DustAndScratchRemovalCommandFilterSize Property

Gets or sets the size of the features that will be removed.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the features that will be removed.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.SupportedPixelFormats Property

DustAndScratchRemovalCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.Threshold Property

DustAndScratchRemovalCommandThreshold Property

Gets or sets the minimum detail intensity required to trigger removal.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Threshold { get; set; }
Public Property Threshold As Integer
    Get
    Set

Property Value

Type: Int32
The minimum detail intensity required to trigger removal. (0 to 255)
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand Methods

The DustAndScratchRemovalCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.ConstructFinalImage Method

DustAndScratchRemovalCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.GetObjectData Method

DustAndScratchRemovalCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.PerformActualCommand Method

DustAndScratchRemovalCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.SelectPreferredPixelFormat Method

DustAndScratchRemovalCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


DustAndScratchRemovalCommand.VerifyProperties Method

DustAndScratchRemovalCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

DustAndScratchRemovalCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Class

This filter enhances edges in an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersEdgeDetectionCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EdgeDetectionCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class EdgeDetectionCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The EdgeDetectionCommand type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeDetectionCommand | Creates a new instance of EdgeDetectionCommand.
Public method | EdgeDetectionCommand(EdgeDetectionType) | Initializes a new instance of EdgeDetectionCommand specifying the type.
Protected method | EdgeDetectionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of EdgeDetectionCommand. Creates a new instance of EdgeDetectionCommand.
Public method | EdgeDetectionCommand(EdgeDetectionType, Double) | Initializes a new instance of EdgeDetectionCommand specifying the type and intensity.
Public method | EdgeDetectionCommand(EdgeDetectionType, Double, EdgeDetectionDirection) | Initializes a new instance of EdgeDetectionCommand specifying the type, intensity, and direction.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the image channels to process.
Public property | Direction | Gets or sets the edge direction for Gradient and Prewitt filters.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets the intensity of the edge detection.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Type | Gets or sets the type of edge detection filter to apply.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Constructor

Overload List
 | Name | Description
Public method | EdgeDetectionCommand | Creates a new instance of EdgeDetectionCommand.
Public method | EdgeDetectionCommand(EdgeDetectionType) | Initializes a new instance of EdgeDetectionCommand specifying the type.
Protected method | EdgeDetectionCommand(SerializationInfo, StreamingContext) | Initializes a new instance of EdgeDetectionCommand. Creates a new instance of EdgeDetectionCommand.
Public method | EdgeDetectionCommand(EdgeDetectionType, Double) | Initializes a new instance of EdgeDetectionCommand specifying the type and intensity.
Public method | EdgeDetectionCommand(EdgeDetectionType, Double, EdgeDetectionDirection) | Initializes a new instance of EdgeDetectionCommand specifying the type, intensity, and direction.
Top
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Constructor

Creates a new instance of EdgeDetectionCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EdgeDetectionCommand()
Public Sub New
See Also

Reference

EdgeDetectionCommand Class
EdgeDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Constructor (EdgeDetectionType)

Initializes a new instance of EdgeDetectionCommand specifying the type.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EdgeDetectionCommand(
    EdgeDetectionType type
)
Public Sub New (
    type As EdgeDetectionType
)

Parameters

type
Type: Atalasoft.Imaging.ImageProcessing.FiltersEdgeDetectionType
Type of edge detection filter to apply.
See Also

Reference

EdgeDetectionCommand Class
EdgeDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of EdgeDetectionCommand. Creates a new instance of EdgeDetectionCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected EdgeDetectionCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

EdgeDetectionCommand Class
EdgeDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Constructor (EdgeDetectionType, Double)

Initializes a new instance of EdgeDetectionCommand specifying the type and intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EdgeDetectionCommand(
    EdgeDetectionType type,
    double intensity
)
Public Sub New (
    type As EdgeDetectionType,
    intensity As Double
)

Parameters

type
Type: Atalasoft.Imaging.ImageProcessing.FiltersEdgeDetectionType
Type of edge detection filter to apply.
intensity
Type: SystemDouble
Intensity of the edge detection.
See Also

Reference

EdgeDetectionCommand Class
EdgeDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Constructor (EdgeDetectionType, Double, EdgeDetectionDirection)

Initializes a new instance of EdgeDetectionCommand specifying the type, intensity, and direction.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EdgeDetectionCommand(
    EdgeDetectionType type,
    double intensity,
    EdgeDetectionDirection direction
)
Public Sub New (
    type As EdgeDetectionType,
    intensity As Double,
    direction As EdgeDetectionDirection
)

Parameters

type
Type: Atalasoft.Imaging.ImageProcessing.FiltersEdgeDetectionType
Type of edge detection filter to apply.
intensity
Type: SystemDouble
Intensity of the edge detection.
direction
Type: Atalasoft.Imaging.ImageProcessing.FiltersEdgeDetectionDirection
The edge detection for Gradient and Prewitt filters.
See Also

Reference

EdgeDetectionCommand Class
EdgeDetectionCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Properties

The EdgeDetectionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the image channels to process.
Public property | Direction | Gets or sets the edge direction for Gradient and Prewitt filters.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets the intensity of the edge detection.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Type | Gets or sets the type of edge detection filter to apply.
Top
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.ChannelsToProcess Property

EdgeDetectionCommandChannelsToProcess Property

Gets or sets the image channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The channels to process.
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.Direction Property

EdgeDetectionCommandDirection Property

Gets or sets the edge direction for Gradient and Prewitt filters.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EdgeDetectionDirection Direction { get; set; }
Public Property Direction As EdgeDetectionDirection
    Get
    Set

Property Value

Type: EdgeDetectionDirection

Specifies the edge detection for Gradient and Prewitt filters.

See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.Intensity Property

EdgeDetectionCommandIntensity Property

Gets or sets the intensity of the edge detection.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double

The intensity of the edge detection.

Remarks
Generally values should be from 0 to 1.
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.SupportedPixelFormats Property

EdgeDetectionCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.Type Property

EdgeDetectionCommandType Property

Gets or sets the type of edge detection filter to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EdgeDetectionType Type { get; set; }
Public Property Type As EdgeDetectionType
    Get
    Set

Property Value

Type: EdgeDetectionType

The type of edge detection filter to apply.

See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand Methods

The EdgeDetectionCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.ConstructFinalImage Method

EdgeDetectionCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.GetObjectData Method

EdgeDetectionCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.PerformActualCommand Method

EdgeDetectionCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.SelectPreferredPixelFormat Method

EdgeDetectionCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionCommand.VerifyProperties Method

EdgeDetectionCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

EdgeDetectionCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EdgeDetectionDirection Enumeration

Specifies the direction of the edge detection

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum EdgeDetectionDirection
Public Enumeration EdgeDetectionDirection
Members
Member name | Description
Top | Emphasizes top edges
Right | Emphasizes right edges
Bottom | Emphasizes bottom edges
Left | Emphasizes left edges
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace
EdgeDetectionCommand


EdgeDetectionType Enumeration

Specified the type of the edge detection.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum EdgeDetectionType
Public Enumeration EdgeDetectionType
Members
Member name | Description
Laplacian | Laplacian Edge Detection
Prewitt | Prewitt Edge Detection
Gradient | Gradient Edge Detection
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace
EdgeDetectionCommand


EmbossCommand Class

Applies an embossing filter to the source image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersEmbossCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EmbossCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class EmbossCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The EmbossCommand type exposes the following members.

Constructors
 | Name | Description
Public method | EmbossCommand | Creates a new instance of EmbossCommand.
Protected method | EmbossCommand(SerializationInfo, StreamingContext) | Creates a new instance of EmbossCommand from serialization information.
Public method | EmbossCommand(Int32, Int32, Int32) | Initializes a new instance of the EmbossCommand specifying the angle, elevation, and depth.
Public method | EmbossCommand(Int32, Int32, Int32, AtalaImage) | Initializes a new instance of the EmbossCommand specifying the angle, elevation, depth, and texture.
Public method | EmbossCommand(Int32, Int32, Int32, Boolean) | Initializes a new instance of the EmbossCommand specifying the angle, elevation, depth, and texture.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of the light source in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Depth | Gets or sets a value controlling the depth of the emboss.
Public property | Elevation | Gets or sets the Height of the light source in degrees.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SelfTexture | Gets or sets a value indicating if the source image should be used as the texture.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TextureEnhancement | Gets or sets a value indicating whether the emboss is enhanced when applying a texture.
Public property | TextureMap | Gets or sets an AtalaImage that is used as a texture map.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Examples
Emboss Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Apply the command.
EmbossCommand cmd = new EmbossCommand(135, 60, 4, true);
AtalaImage result = cmd.Apply(image).Image;

image.Dispose();
Emboss Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Apply the command.
Dim cmd As EmbossCommand =  New EmbossCommand(135,60,4,True)
Dim result As AtalaImage =  cmd.Apply(image).Image

image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Constructor

Overload List
 | Name | Description
Public method | EmbossCommand | Creates a new instance of EmbossCommand.
Protected method | EmbossCommand(SerializationInfo, StreamingContext) | Creates a new instance of EmbossCommand from serialization information.
Public method | EmbossCommand(Int32, Int32, Int32) | Initializes a new instance of the EmbossCommand specifying the angle, elevation, and depth.
Public method | EmbossCommand(Int32, Int32, Int32, AtalaImage) | Initializes a new instance of the EmbossCommand specifying the angle, elevation, depth, and texture.
Public method | EmbossCommand(Int32, Int32, Int32, Boolean) | Initializes a new instance of the EmbossCommand specifying the angle, elevation, depth, and texture.
Top
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Constructor

Creates a new instance of EmbossCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbossCommand()
Public Sub New
See Also

Reference

EmbossCommand Class
EmbossCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of EmbossCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected EmbossCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

EmbossCommand Class
EmbossCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Constructor (Int32, Int32, Int32)

Initializes a new instance of the EmbossCommand specifying the angle, elevation, and depth.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbossCommand(
    int angle,
    int elevation,
    int depth
)
Public Sub New (
    angle As Integer,
    elevation As Integer,
    depth As Integer
)

Parameters

angle
Type: SystemInt32

Angle of the light source in degrees.

elevation
Type: SystemInt32

Height of the light source in degrees.

depth
Type: SystemInt32

Controls the depth of the emboss.

Exceptions
Exception | Condition
 | Thrown if the depth is less than 0.
See Also

Reference

EmbossCommand Class
EmbossCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Constructor (Int32, Int32, Int32, AtalaImage)

Initializes a new instance of the EmbossCommand specifying the angle, elevation, depth, and texture.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbossCommand(
    int angle,
    int elevation,
    int depth,
    AtalaImage textureMap
)
Public Sub New (
    angle As Integer,
    elevation As Integer,
    depth As Integer,
    textureMap As AtalaImage
)

Parameters

angle
Type: SystemInt32

Angle of the light source in degrees.

elevation
Type: SystemInt32

Height of the light source in degrees.

depth
Type: SystemInt32

Controls the depth of the emboss.

textureMap
Type: Atalasoft.ImagingAtalaImage
An AtalaImage that is used as a texture map.
Exceptions
Exception | Condition
 | Thrown if the depth is less than 0.
See Also

Reference

EmbossCommand Class
EmbossCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Constructor (Int32, Int32, Int32, Boolean)

Initializes a new instance of the EmbossCommand specifying the angle, elevation, depth, and texture.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EmbossCommand(
    int angle,
    int elevation,
    int depth,
    bool selfTexture
)
Public Sub New (
    angle As Integer,
    elevation As Integer,
    depth As Integer,
    selfTexture As Boolean
)

Parameters

angle
Type: SystemInt32

Angle of the light source in degrees.

elevation
Type: SystemInt32

Height of the light source in degrees.

depth
Type: SystemInt32

Controls the depth of the emboss.

selfTexture
Type: SystemBoolean
Indicates if the source image should be used as the texture.
Exceptions
Exception | Condition
 | Thrown if the depth is less than 0.
See Also

Reference

EmbossCommand Class
EmbossCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Properties

The EmbossCommand type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of the light source in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Depth | Gets or sets a value controlling the depth of the emboss.
Public property | Elevation | Gets or sets the Height of the light source in degrees.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SelfTexture | Gets or sets a value indicating if the source image should be used as the texture.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | TextureEnhancement | Gets or sets a value indicating whether the emboss is enhanced when applying a texture.
Public property | TextureMap | Gets or sets an AtalaImage that is used as a texture map.
Top
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.Angle Property

EmbossCommandAngle Property

Gets or sets the angle of the light source in degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Angle { get; set; }
Public Property Angle As Integer
    Get
    Set

Property Value

Type: Int32

The angle of the light source in degrees.

See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.Depth Property

EmbossCommandDepth Property

Gets or sets a value controlling the depth of the emboss.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Depth { get; set; }
Public Property Depth As Integer
    Get
    Set

Property Value

Type: Int32

A value controlling the depth of the emboss.

Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.Elevation Property

EmbossCommandElevation Property

Gets or sets the Height of the light source in degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Elevation { get; set; }
Public Property Elevation As Integer
    Get
    Set

Property Value

Type: Int32

The height of the light source in degrees.

See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.SelfTexture Property

EmbossCommandSelfTexture Property

Gets or sets a value indicating if the source image should be used as the texture.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfTexture { get; set; }
Public Property SelfTexture As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the source image should be used as the texture.
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.SupportedPixelFormats Property

EmbossCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.TextureEnhancement Property

EmbossCommandTextureEnhancement Property

Gets or sets a value indicating whether the emboss is enhanced when applying a texture.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TextureEnhancement { get; set; }
Public Property TextureEnhancement As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the emboss is enhanced when applying a texture.
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.TextureMap Property

EmbossCommandTextureMap Property

Gets or sets an AtalaImage that is used as a texture map.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage TextureMap { get; set; }
Public Property TextureMap As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
An AtalaImage that is used as a texture map.
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand Methods

The EmbossCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.Apply Method

EmbossCommandApply Method

Apply the command to the given image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageResults Apply(
    AtalaImage image
)
Public Overrides Function Apply (
    image As AtalaImage
) As ImageResults

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: ImageResults
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.GetObjectData Method

EmbossCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.PerformActualCommand Method

EmbossCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.SelectPreferredPixelFormat Method

EmbossCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossCommand.VerifyProperties Method

EmbossCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

EmbossCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


EmbossMethod Enumeration

Note: This API is now obsolete.

The type of Emboss method to use in the EmbossCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("EmbossMethod is obsolete.", true)]
public enum EmbossMethod
<ObsoleteAttribute("EmbossMethod is obsolete.", true)>
Public Enumeration EmbossMethod
Members
Member name | Description
Standard | Standard embossing
AlternateBlending | Alternate blending
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Class

Removes Low Frequency signals from an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersHighPassCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class HighPassCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class HighPassCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The HighPassCommand type exposes the following members.

Constructors
 | Name | Description
Public method | HighPassCommand | Creates a new instance of HighPassCommand.
Public method | HighPassCommand(Double) | Initializes a new instance of the HighPassCommand specifying the sigma value.
Public method | HighPassCommand(Double, Double) | Initializes a new instance of the HighPassCommand specifying the sigma and mix value.
Protected method | HighPassCommand(SerializationInfo, StreamingContext) | Creates a new instance of HighPassCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mix | Gets or sets the percentage of the filter to mix into the original image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets a value indicating the amount of effect to apply.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Constructor

Overload List
 | Name | Description
Public method | HighPassCommand | Creates a new instance of HighPassCommand.
Public method | HighPassCommand(Double) | Initializes a new instance of the HighPassCommand specifying the sigma value.
Public method | HighPassCommand(Double, Double) | Initializes a new instance of the HighPassCommand specifying the sigma and mix value.
Protected method | HighPassCommand(SerializationInfo, StreamingContext) | Creates a new instance of HighPassCommand from serialization information.
Top
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Constructor

Creates a new instance of HighPassCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HighPassCommand()
Public Sub New
See Also

Reference

HighPassCommand Class
HighPassCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Constructor (Double)

Initializes a new instance of the HighPassCommand specifying the sigma value.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HighPassCommand(
    double sigma
)
Public Sub New (
    sigma As Double
)

Parameters

sigma
Type: SystemDouble
A value indicating the amount of effect to apply.
Exceptions
Exception | Condition
 | Thrown if sigma is less than 0.
See Also

Reference

HighPassCommand Class
HighPassCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Constructor (Double, Double)

Initializes a new instance of the HighPassCommand specifying the sigma and mix value.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HighPassCommand(
    double sigma,
    double mix
)
Public Sub New (
    sigma As Double,
    mix As Double
)

Parameters

sigma
Type: SystemDouble
A value indicating the amount of effect to apply.
mix
Type: SystemDouble
The percentage of the filter to mix into the original image. (0 to 100)
Exceptions
Exception | Condition
 | Thrown if sigma is less than 0, or is mix is less than 0 or greater than 100.
See Also

Reference

HighPassCommand Class
HighPassCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of HighPassCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HighPassCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

HighPassCommand Class
HighPassCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Properties

The HighPassCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Mix | Gets or sets the percentage of the filter to mix into the original image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets a value indicating the amount of effect to apply.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.InPlaceProcessing Property

HighPassCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.Mix Property

HighPassCommandMix Property

Gets or sets the percentage of the filter to mix into the original image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Mix { get; set; }
Public Property Mix As Double
    Get
    Set

Property Value

Type: Double
The percentage of the filter to mix into the original image.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.Sigma Property

HighPassCommandSigma Property

Gets or sets a value indicating the amount of effect to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Sigma { get; set; }
Public Property Sigma As Double
    Get
    Set

Property Value

Type: Double
A value indicating the amount of effect to apply.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.SupportedPixelFormats Property

HighPassCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PiPixelFormat.Pixel32bppCmyk
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand Methods

The HighPassCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Overrides ImageCommandApply(AtalaImage).)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.Apply Method

HighPassCommandApply Method

Apply the command to the given image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ImageResults Apply(
    AtalaImage image
)
Public Overrides Function Apply (
    image As AtalaImage
) As ImageResults

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image which will by processed by the command.

Return Value

Type: ImageResults
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.GetObjectData Method

HighPassCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.PerformActualCommand Method

HighPassCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


HighPassCommand.VerifyProperties Method

HighPassCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
IncompatiblePixelFormatException | You cannot use regions with 1-bit images.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

HighPassCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix Class

This object composes of a matrix of integers that is used in various morphological and related filters.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IntegerMatrix : ISerializable
<SerializableAttribute>
Public Class IntegerMatrix
    Implements ISerializable

The IntegerMatrix type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerMatrix(Int32, Int32) | Creates a new instance of IntegerMatrix.
Protected method | IntegerMatrix(SerializationInfo, StreamingContext) | Creates a new instance of IntegerMatrix from serialization information.
Top
Properties
 | Name | Description
Public property | Columns | Gets the number of columns in the matrix.
Public property | Rows | Gets the number of rows in the matrix.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArray | Return a one-dimentional array that composes of the matrix elements.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItem | Gets a value in the specified location of the matrix.
Public method | GetObjectData | Fills a SerializationInfo object with information about this object.
Public method | GetRow | Returns a one-dimensional array containing an entire row of the matrix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetItem | Set the value of an element in the array.
Public method | SetRow | Set the entire row of the matrix to a parameter list of values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix Constructor

Overload List
 | Name | Description
Public method | IntegerMatrix(Int32, Int32) | Creates a new instance of IntegerMatrix.
Protected method | IntegerMatrix(SerializationInfo, StreamingContext) | Creates a new instance of IntegerMatrix from serialization information.
Top
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix Constructor (Int32, Int32)

Creates a new instance of IntegerMatrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix(
    int rows,
    int columns
)
Public Sub New (
    rows As Integer,
    columns As Integer
)

Parameters

rows
Type: SystemInt32
The number of rows for the matrix.
columns
Type: SystemInt32
The number of columns for the matrix.
See Also

Reference

IntegerMatrix Class
IntegerMatrix Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix Constructor (SerializationInfo, StreamingContext)

Creates a new instance of IntegerMatrix from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IntegerMatrix(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

IntegerMatrix Class
IntegerMatrix Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix Properties

The IntegerMatrix type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Gets the number of columns in the matrix.
Public property | Rows | Gets the number of rows in the matrix.
Top
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.Columns Property

IntegerMatrixColumns Property

Gets the number of columns in the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get

Property Value

Type: Int32
The number of columns in the matrix.
Remarks
Most methods require an odd and equal number of columns and rows.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.Rows Property

IntegerMatrixRows Property

Gets the number of rows in the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
The number of rows in the matrix.
Remarks
Most methods require an odd and equal number of columns and rows.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix Methods

The IntegerMatrix type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArray | Return a one-dimentional array that composes of the matrix elements.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItem | Gets a value in the specified location of the matrix.
Public method | GetObjectData | Fills a SerializationInfo object with information about this object.
Public method | GetRow | Returns a one-dimensional array containing an entire row of the matrix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetItem | Set the value of an element in the array.
Public method | SetRow | Set the entire row of the matrix to a parameter list of values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.GetArray Method

IntegerMatrixGetArray Method

Return a one-dimentional array that composes of the matrix elements.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetArray()
Public Function GetArray As Integer()

Return Value

Type: Int32
A one-dimentional array that composes of the matrix elements.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.GetItem Method

IntegerMatrixGetItem Method

Gets a value in the specified location of the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetItem(
    int row,
    int column
)
Public Function GetItem (
    row As Integer,
    column As Integer
) As Integer

Parameters

row
Type: SystemInt32
The row containing the element to get. (zero based)
column
Type: SystemInt32
The column containing the element to get. (zero based)

Return Value

Type: Int32
A value in the specified location of the matrix.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.GetObjectData Method

IntegerMatrixGetObjectData Method

Fills a SerializationInfo object with information about this object.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this object.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.GetRow Method

IntegerMatrixGetRow Method

Returns a one-dimensional array containing an entire row of the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetRow(
    int rowIndex
)
Public Function GetRow (
    rowIndex As Integer
) As Integer()

Parameters

rowIndex
Type: SystemInt32
The zero based row to retreive.

Return Value

Type: Int32
A one-dimensional array containing an entire row of the matrix.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.SetItem Method

IntegerMatrixSetItem Method

Set the value of an element in the array.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetItem(
    int row,
    int column,
    int itemValue
)
Public Sub SetItem (
    row As Integer,
    column As Integer,
    itemValue As Integer
)

Parameters

row
Type: SystemInt32
The row containing the element to set. (zero based)
column
Type: SystemInt32
The column containing the element to set. (zero based)
itemValue
Type: SystemInt32
The value to set.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntegerMatrix.SetRow Method

IntegerMatrixSetRow Method

Set the entire row of the matrix to a parameter list of values.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetRow(
    int rowIndex,
    params int[] rowList
)
Public Sub SetRow (
    rowIndex As Integer,
    ParamArray rowList As Integer()
)

Parameters

rowIndex
Type: SystemInt32
The zero based row index to set.
rowList
Type: SystemInt32
A parameter array of integers that are set to the matrix row.
See Also

Reference

IntegerMatrix Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Class

Increases the color intensity as if a flash of light from a camera hit it.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersIntensifyCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IntensifyCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class IntensifyCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The IntensifyCommand type exposes the following members.

Constructors
 | Name | Description
Public method | IntensifyCommand | Creates a new instance of IntensifyCommand.
Public method | IntensifyCommand(Double) | Creates a new instance of IntensifyCommand specifying the intensity.
Protected method | IntensifyCommand(SerializationInfo, StreamingContext) | Creates a new instance of IntensifyCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value increasing the color intensity.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Constructor

Overload List
 | Name | Description
Public method | IntensifyCommand | Creates a new instance of IntensifyCommand.
Public method | IntensifyCommand(Double) | Creates a new instance of IntensifyCommand specifying the intensity.
Protected method | IntensifyCommand(SerializationInfo, StreamingContext) | Creates a new instance of IntensifyCommand from serialization information.
Top
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Constructor

Creates a new instance of IntensifyCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntensifyCommand()
Public Sub New
See Also

Reference

IntensifyCommand Class
IntensifyCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Constructor (Double)

Creates a new instance of IntensifyCommand specifying the intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntensifyCommand(
    double intensity
)
Public Sub New (
    intensity As Double
)

Parameters

intensity
Type: SystemDouble
The new intensity value.
Exceptions
Exception | Condition
 | Thrown if intensity is less than 0.
See Also

Reference

IntensifyCommand Class
IntensifyCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of IntensifyCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IntensifyCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

IntensifyCommand Class
IntensifyCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Properties

The IntensifyCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets a value increasing the color intensity.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.ChannelsToProcess Property

IntensifyCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.Intensity Property

IntensifyCommandIntensity Property

Gets or sets a value increasing the color intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
A value increasing the color intensity.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.SupportedPixelFormats Property

IntensifyCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand Methods

The IntensifyCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.GetObjectData Method

IntensifyCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.PerformActualCommand Method

IntensifyCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.SelectPreferredPixelFormat Method

IntensifyCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


IntensifyCommand.VerifyProperties Method

IntensifyCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

IntensifyCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Class

Sets each color value to the maximum value under the filter.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersMaximumCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MaximumCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MaximumCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MaximumCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MaximumCommand | Creates a new instance of MaximumCommand.
Public method | MaximumCommand(Int32) | Creates a new instance of MaximumCommand specifying the filter size.
Protected method | MaximumCommand(SerializationInfo, StreamingContext) | Creates a new instance of MaximumCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Constructor

Overload List
 | Name | Description
Public method | MaximumCommand | Creates a new instance of MaximumCommand.
Public method | MaximumCommand(Int32) | Creates a new instance of MaximumCommand specifying the filter size.
Protected method | MaximumCommand(SerializationInfo, StreamingContext) | Creates a new instance of MaximumCommand from serialization information.
Top
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Constructor

Creates a new instance of MaximumCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MaximumCommand()
Public Sub New
See Also

Reference

MaximumCommand Class
MaximumCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Constructor (Int32)

Creates a new instance of MaximumCommand specifying the filter size.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MaximumCommand(
    int filterSize
)
Public Sub New (
    filterSize As Integer
)

Parameters

filterSize
Type: SystemInt32
Size of the filter. Should be an odd value greater than or equal to 3.
Exceptions
Exception | Condition
 | Thrown if filterSize is less than 0.
See Also

Reference

MaximumCommand Class
MaximumCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MaximumCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MaximumCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MaximumCommand Class
MaximumCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Properties

The MaximumCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.ChannelsToProcess Property

MaximumCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.FilterSize Property

MaximumCommandFilterSize Property

Gets or sets the size of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the filter.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Should be an odd value (3, 5, 7, 9, etc.). The larger the value, the greater the effect at the expense of speed. An even value will be incremented by 1.
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.SupportedPixelFormats Property

MaximumCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand Methods

The MaximumCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.ConstructFinalImage Method

MaximumCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.GetObjectData Method

MaximumCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.PerformActualCommand Method

MaximumCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.SelectPreferredPixelFormat Method

MaximumCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MaximumCommand.VerifyProperties Method

MaximumCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MaximumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Class

Applies an Arithmetic, Harmonic, Geometric, or Yp mean filter to an image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersMeanCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MeanCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MeanCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MeanCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MeanCommand | Creates a new instance of MeanCommand.
Public method | MeanCommand(MeanFilterType) | Initializes a new instance of the MeanCommand specifying the type.
Protected method | MeanCommand(SerializationInfo, StreamingContext) | Creates a new instance of MeanCommand from serialization information.
Public method | MeanCommand(MeanFilterType, Int32) | Initializes a new instance of the MeanCommand specifying the type, filter size.
Public method | MeanCommand(MeanFilterType, Int32, Int32) | Initializes a new instance of the MeanCommand specifying the type, size, and power.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MeanType | Gets or sets the type of mean filter to apply.
Public property | Power | Gets or sets the a non-zero integer that controls power for the Yp mean filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
Remarks

This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.

Mean filtering is a simple method of smoothing images (reducing the amount of intensity variation between one pixel and the next) and often used to reduce noise.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Constructor

Overload List
 | Name | Description
Public method | MeanCommand | Creates a new instance of MeanCommand.
Public method | MeanCommand(MeanFilterType) | Initializes a new instance of the MeanCommand specifying the type.
Protected method | MeanCommand(SerializationInfo, StreamingContext) | Creates a new instance of MeanCommand from serialization information.
Public method | MeanCommand(MeanFilterType, Int32) | Initializes a new instance of the MeanCommand specifying the type, filter size.
Public method | MeanCommand(MeanFilterType, Int32, Int32) | Initializes a new instance of the MeanCommand specifying the type, size, and power.
Top
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Constructor

Creates a new instance of MeanCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MeanCommand()
Public Sub New
See Also

Reference

MeanCommand Class
MeanCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Constructor (MeanFilterType)

Initializes a new instance of the MeanCommand specifying the type.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MeanCommand(
    MeanFilterType meanType
)
Public Sub New (
    meanType As MeanFilterType
)

Parameters

meanType
Type: Atalasoft.Imaging.ImageProcessing.FiltersMeanFilterType
The type of mean filter to apply.
See Also

Reference

MeanCommand Class
MeanCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MeanCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MeanCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MeanCommand Class
MeanCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Constructor (MeanFilterType, Int32)

Initializes a new instance of the MeanCommand specifying the type, filter size.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MeanCommand(
    MeanFilterType meanType,
    int filterSize
)
Public Sub New (
    meanType As MeanFilterType,
    filterSize As Integer
)

Parameters

meanType
Type: Atalasoft.Imaging.ImageProcessing.FiltersMeanFilterType
The type of mean filter to apply.
filterSize
Type: SystemInt32
The size of the filter. Should be an odd value greater than or equal to 3.
Exceptions
Exception | Condition
 | Thrown if filterSize is less than 0.
See Also

Reference

MeanCommand Class
MeanCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Constructor (MeanFilterType, Int32, Int32)

Initializes a new instance of the MeanCommand specifying the type, size, and power.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MeanCommand(
    MeanFilterType meanType,
    int filterSize,
    int power
)
Public Sub New (
    meanType As MeanFilterType,
    filterSize As Integer,
    power As Integer
)

Parameters

meanType
Type: Atalasoft.Imaging.ImageProcessing.FiltersMeanFilterType
The type of mean filter to apply.
filterSize
Type: SystemInt32
The size of the filter. Should be an odd value greater than or equal to 3.
power
Type: SystemInt32
A non-zero integer that controls power for the Yp mean filter.
Exceptions
Exception | Condition
 | Thrown if filterSize is less than 0, or if power is equal to 0.
See Also

Reference

MeanCommand Class
MeanCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Properties

The MeanCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MeanType | Gets or sets the type of mean filter to apply.
Public property | Power | Gets or sets the a non-zero integer that controls power for the Yp mean filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.ChannelsToProcess Property

MeanCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.FilterSize Property

MeanCommandFilterSize Property

Gets or sets the size of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the filter.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Should be an odd value (3, 5, 7, 9, etc.). The larger the value, the greater the effect at the expense of speed. An even value will be incremented by 1.
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.MeanType Property

MeanCommandMeanType Property

Gets or sets the type of mean filter to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MeanFilterType MeanType { get; set; }
Public Property MeanType As MeanFilterType
    Get
    Set

Property Value

Type: MeanFilterType
The type of mean filter to apply.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.Power Property

MeanCommandPower Property

Gets or sets the a non-zero integer that controls power for the Yp mean filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Power { get; set; }
Public Property Power As Integer
    Get
    Set

Property Value

Type: Int32
A non-zero integer that controls power for the Yp mean filter.
Exceptions
Exception | Condition
 | Thrown if value is equal to 0.
Remarks
Ignored if meanType is not MeanFilterType.Yp.,power lt; 0, removes positive outliers ,power gt; 0, removes negative outliers
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.SupportedPixelFormats Property

MeanCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand Methods

The MeanCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.ConstructFinalImage Method

MeanCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.GetObjectData Method

MeanCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.PerformActualCommand Method

MeanCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.SelectPreferredPixelFormat Method

MeanCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanCommand.VerifyProperties Method

MeanCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MeanCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MeanFilterType Enumeration

Various types of MeanFilter.
The type of mean filter to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MeanFilterType
Public Enumeration MeanFilterType
Members
Member name | Description
Arithmetic | Finds average values under the filter.
Geometric | Removes Gaussian type noise from an image better than the arithmetic mean filter. Unlike the YP mean filter, this is susceptible to low-valued outliers: a zero pixel under the filter will cause the filter to output zero.
Harmonic | Removes Gaussian type noise from an image better than the arithmetic mean filter. It is good at removing positive outliers, but it is susceptible to low-valued outliers: a zero pixel under the filter will cause the filter to output zero.
YP | A non-linear mean filter which is better at removing Gaussian type noise and preserving edge features than the basic arithmetic mean filter. It is also very good at removing outliers (positive or negative, depending on the order of the filter) from images.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand Class

Reduces noise in an image, similarly to the mean filter, however doing a better job preserving useful detail in the image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersMedianCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MedianCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MedianCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MedianCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MedianCommand | Creates a new instance of MedianCommand.
Public method | MedianCommand(Int32) | Creates a new instance of MedianCommand specifying the filter size.
Protected method | MedianCommand(SerializationInfo, StreamingContext) | Creates a new instance of MedianCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the matrix.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
A value of 0 or AllChannels will process each channel in the image. For document images, please see DocumentMedianCommand instead.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace
DocumentMedianCommand Class


MedianCommand Constructor

Overload List
 | Name | Description
Public method | MedianCommand | Creates a new instance of MedianCommand.
Public method | MedianCommand(Int32) | Creates a new instance of MedianCommand specifying the filter size.
Protected method | MedianCommand(SerializationInfo, StreamingContext) | Creates a new instance of MedianCommand from serialization information.
Top
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand Constructor

Creates a new instance of MedianCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MedianCommand()
Public Sub New
See Also

Reference

MedianCommand Class
MedianCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand Constructor (Int32)

Creates a new instance of MedianCommand specifying the filter size.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MedianCommand(
    int filterSize
)
Public Sub New (
    filterSize As Integer
)

Parameters

filterSize
Type: SystemInt32
The size of the matrix used for processing this command.
Exceptions
Exception | Condition
 | Thrown if the filterSize is less than 0.
See Also

Reference

MedianCommand Class
MedianCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MedianCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MedianCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MedianCommand Class
MedianCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand Properties

The MedianCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the matrix.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.ChannelsToProcess Property

MedianCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.FilterSize Property

MedianCommandFilterSize Property

Gets or sets the size of the matrix.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the matrix.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
The filter size should be an odd value. The larger the value, the greater the effect at the expense of speed. An even value will be incremented by 1.
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.SupportedPixelFormats Property

MedianCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand Methods

The MedianCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.ConstructFinalImage Method

MedianCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.GetObjectData Method

MedianCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.PerformActualCommand Method

MedianCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.SelectPreferredPixelFormat Method

MedianCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MedianCommand.VerifyProperties Method

MedianCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MedianCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Class

Find the average of minimum and maximum values under the filter.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersMidpointCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MidpointCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MidpointCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MidpointCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MidpointCommand | Creates a new instance of MidpointCommand.
Public method | MidpointCommand(Int32) | Initializes a new instance of the MidpointCommand specifying the filter size.
Protected method | MidpointCommand(SerializationInfo, StreamingContext) | Creates a new instance of MidpointCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Constructor

Overload List
 | Name | Description
Public method | MidpointCommand | Creates a new instance of MidpointCommand.
Public method | MidpointCommand(Int32) | Initializes a new instance of the MidpointCommand specifying the filter size.
Protected method | MidpointCommand(SerializationInfo, StreamingContext) | Creates a new instance of MidpointCommand from serialization information.
Top
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Constructor

Creates a new instance of MidpointCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MidpointCommand()
Public Sub New
See Also

Reference

MidpointCommand Class
MidpointCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Constructor (Int32)

Initializes a new instance of the MidpointCommand specifying the filter size.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MidpointCommand(
    int filterSize
)
Public Sub New (
    filterSize As Integer
)

Parameters

filterSize
Type: SystemInt32
The size of the filter. Should be an odd value greater than or equal to 3.
Exceptions
Exception | Condition
 | Thrown if the filterSize is less than 0.
See Also

Reference

MidpointCommand Class
MidpointCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MidpointCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MidpointCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MidpointCommand Class
MidpointCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Properties

The MidpointCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.ChannelsToProcess Property

MidpointCommandChannelsToProcess Property

Gets or sets the ChannelFlags specifying which channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The ChannelFlags specifying which channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.FilterSize Property

MidpointCommandFilterSize Property

Gets or sets the size of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the filter. Should be an odd value (3, 5, 7, 9, etc.). The larger the value, the greater the effect at the expense of speed. An even value will be incremented by 1.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.SupportedPixelFormats Property

MidpointCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand Methods

The MidpointCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.ConstructFinalImage Method

MidpointCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.GetObjectData Method

MidpointCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.PerformActualCommand Method

MidpointCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.SelectPreferredPixelFormat Method

MidpointCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MidpointCommand.VerifyProperties Method

MidpointCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MidpointCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Class

Find the minimum values under the filter.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersMinimumCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MinimumCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MinimumCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MinimumCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MinimumCommand | Creates a new instance of MinimumCommand.
Public method | MinimumCommand(Int32) | Initializes a new instance of the MinimumCommand specifying the filter size.
Protected method | MinimumCommand(SerializationInfo, StreamingContext) | Creates a new instance of MinimumCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Constructor

Overload List
 | Name | Description
Public method | MinimumCommand | Creates a new instance of MinimumCommand.
Public method | MinimumCommand(Int32) | Initializes a new instance of the MinimumCommand specifying the filter size.
Protected method | MinimumCommand(SerializationInfo, StreamingContext) | Creates a new instance of MinimumCommand from serialization information.
Top
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Constructor

Creates a new instance of MinimumCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MinimumCommand()
Public Sub New
See Also

Reference

MinimumCommand Class
MinimumCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Constructor (Int32)

Initializes a new instance of the MinimumCommand specifying the filter size.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MinimumCommand(
    int filterSize
)
Public Sub New (
    filterSize As Integer
)

Parameters

filterSize
Type: SystemInt32
The size of the filter. Should be an odd value greater than or equal to 3.
Exceptions
Exception | Condition
 | Thrown if the filterSize is less than 0.
See Also

Reference

MinimumCommand Class
MinimumCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MinimumCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MinimumCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MinimumCommand Class
MinimumCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Properties

The MinimumCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets a bit flag indicating the channels to process.
Public property | FilterSize | Gets or sets the size of the filter.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.ChannelsToProcess Property

MinimumCommandChannelsToProcess Property

Gets or sets a bit flag indicating the channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
A bit flag indicating the channels to process.
Remarks
A value of 0 or AllChannels will process each channel in the image.
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.FilterSize Property

MinimumCommandFilterSize Property

Gets or sets the size of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterSize { get; set; }
Public Property FilterSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the filter.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Should be an odd value (3, 5, 7, 9, etc.). The larger the value, the greater the effect at the expense of speed. An even value will be incremented by 1.
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.SupportedPixelFormats Property

MinimumCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand Methods

The MinimumCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.ConstructFinalImage Method

MinimumCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.GetObjectData Method

MinimumCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.PerformActualCommand Method

MinimumCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.SelectPreferredPixelFormat Method

MinimumCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MinimumCommand.VerifyProperties Method

MinimumCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MinimumCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Class

Applies a morphological Erosion, Dilation, Open, Close, or TopHat to a grayscale image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersMorphoGrayCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MorphoGrayCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class MorphoGrayCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The MorphoGrayCommand type exposes the following members.

Constructors
 | Name | Description
Public method | MorphoGrayCommand | Creates a new instance of MorphoGrayCommand.
Public method | MorphoGrayCommand(MorphoGrayMode) | Initializes a new instance of the MorphoGrayCommand specifying the filter mode.
Protected method | MorphoGrayCommand(SerializationInfo, StreamingContext) | Creates a new instance of MorphoGrayCommand from serialization information.
Public method | MorphoGrayCommand(MorphoGrayMode, IntegerMatrix) | Initializes a new instance of the MorphoGrayCommand specifying the filter mode and a structuring element.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mask | Gets or sets a structuring element to use with the morphological filter.
Public property | Mode | Gets or sets the type of morphological filter to apply.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

Morphology is the study of form and structure. In image processing, it encompasses a set of techniques that merge traditional image processing with set theory from mathematics.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Constructor

Overload List
 | Name | Description
Public method | MorphoGrayCommand | Creates a new instance of MorphoGrayCommand.
Public method | MorphoGrayCommand(MorphoGrayMode) | Initializes a new instance of the MorphoGrayCommand specifying the filter mode.
Protected method | MorphoGrayCommand(SerializationInfo, StreamingContext) | Creates a new instance of MorphoGrayCommand from serialization information.
Public method | MorphoGrayCommand(MorphoGrayMode, IntegerMatrix) | Initializes a new instance of the MorphoGrayCommand specifying the filter mode and a structuring element.
Top
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Constructor

Creates a new instance of MorphoGrayCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoGrayCommand()
Public Sub New
See Also

Reference

MorphoGrayCommand Class
MorphoGrayCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Constructor (MorphoGrayMode)

Initializes a new instance of the MorphoGrayCommand specifying the filter mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoGrayCommand(
    MorphoGrayMode mode
)
Public Sub New (
    mode As MorphoGrayMode
)

Parameters

mode
Type: Atalasoft.Imaging.ImageProcessing.FiltersMorphoGrayMode
The type of morphological to apply.
See Also

Reference

MorphoGrayCommand Class
MorphoGrayCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MorphoGrayCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MorphoGrayCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MorphoGrayCommand Class
MorphoGrayCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Constructor (MorphoGrayMode, IntegerMatrix)

Initializes a new instance of the MorphoGrayCommand specifying the filter mode and a structuring element.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoGrayCommand(
    MorphoGrayMode mode,
    IntegerMatrix mask
)
Public Sub New (
    mode As MorphoGrayMode,
    mask As IntegerMatrix
)

Parameters

mode
Type: Atalasoft.Imaging.ImageProcessing.FiltersMorphoGrayMode
The type of morphological to apply.
mask
Type: Atalasoft.Imaging.ImageProcessing.FiltersIntegerMatrix
The structuring element to use.
Exceptions
Exception | Condition
 | Thrown if the matrix does not have an equal number of rows and cols.
See Also

Reference

MorphoGrayCommand Class
MorphoGrayCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Properties

The MorphoGrayCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mask | Gets or sets a structuring element to use with the morphological filter.
Public property | Mode | Gets or sets the type of morphological filter to apply.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand.Mask Property

MorphoGrayCommandMask Property

Gets or sets a structuring element to use with the morphological filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntegerMatrix Mask { get; set; }
Public Property Mask As IntegerMatrix
    Get
    Set

Property Value

Type: IntegerMatrix
A structuring element to use with the morphological filter.
Exceptions
Exception | Condition
 | Thrown if the matrix does not have an equal number of rows and cols.
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand.Mode Property

MorphoGrayCommandMode Property

Gets or sets the type of morphological filter to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MorphoGrayMode Mode { get; set; }
Public Property Mode As MorphoGrayMode
    Get
    Set

Property Value

Type: MorphoGrayMode
The type of morphological filter to apply.
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand.SupportedPixelFormats Property

MorphoGrayCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel8bppGrayscale
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand Methods

The MorphoGrayCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand.GetObjectData Method

MorphoGrayCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand.PerformActualCommand Method

MorphoGrayCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayCommand.VerifyProperties Method

MorphoGrayCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

MorphoGrayCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


MorphoGrayMode Enumeration

The type of morphological filter to use in the MorphoGrayCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MorphoGrayMode
Public Enumeration MorphoGrayMode
Members
Member name | Description
Dilation | Used to smooth small dark regions tending to enhance black features in the image.
Erosion | Used to smooth small light regions tending to reduce black features in the image.
Open | The dilation of the erosion of the image used to reduce small black regions within the image.
Close | The erosion of the dilation of the image used to reduce small white regions within the image.
Tophat | Used to enhance low-contrast, high frequency details within an image.
Gradient | Highlights sharp gray-level transitions (edges) in an image.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Class

Applies a traditional sharpening filter to the image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersSharpenCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SharpenCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class SharpenCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The SharpenCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SharpenCommand | Creates a new instance of SharpenCommand.
Public method | SharpenCommand(Double) | Creates a new instance of SharpenCommand specifying intensity.
Public method | SharpenCommand(Double, Int32) | Creates a new instance of SharpenCommand specifying intensity, and matrixSize.
Protected method | SharpenCommand(SerializationInfo, StreamingContext) | Creates a new instance of SharpenCommand from serialization information.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets the value of intensity
Public property | MatrixSize | Gets or sets the size of the filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Constructor

Overload List
 | Name | Description
Public method | SharpenCommand | Creates a new instance of SharpenCommand.
Public method | SharpenCommand(Double) | Creates a new instance of SharpenCommand specifying intensity.
Public method | SharpenCommand(Double, Int32) | Creates a new instance of SharpenCommand specifying intensity, and matrixSize.
Protected method | SharpenCommand(SerializationInfo, StreamingContext) | Creates a new instance of SharpenCommand from serialization information.
Top
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Constructor

Creates a new instance of SharpenCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SharpenCommand()
Public Sub New
See Also

Reference

SharpenCommand Class
SharpenCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Constructor (Double)

Creates a new instance of SharpenCommand specifying intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SharpenCommand(
    double intensity
)
Public Sub New (
    intensity As Double
)

Parameters

intensity
Type: SystemDouble
Filter intensity. (0-100)
Exceptions
Exception | Condition
 | Thrown if the intensity is less than 0 or greater than 100.
See Also

Reference

SharpenCommand Class
SharpenCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Constructor (Double, Int32)

Creates a new instance of SharpenCommand specifying intensity, and matrixSize.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SharpenCommand(
    double intensity,
    int matrixSize
)
Public Sub New (
    intensity As Double,
    matrixSize As Integer
)

Parameters

intensity
Type: SystemDouble
Filter intensity. (0-100)
matrixSize
Type: SystemInt32
The larger the matrixSize, the stronger the effect
Exceptions
Exception | Condition
 | Thrown if the intensity is less than 0 or greater than 100, or if matrixSize is less than 3.
See Also

Reference

SharpenCommand Class
SharpenCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SharpenCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SharpenCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

SharpenCommand Class
SharpenCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Properties

The SharpenCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets the value of intensity
Public property | MatrixSize | Gets or sets the size of the filter.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.ChannelsToProcess Property

SharpenCommandChannelsToProcess Property

Gets or sets the ChannelFlags specifying which channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The ChannelFlags specifying which channels to process.
Remarks
The default value is AllChannels.
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.Intensity Property

SharpenCommandIntensity Property

Gets or sets the value of intensity

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
The value of intensity
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 100.
Remarks
Valid values are from 0 to 100.
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.MatrixSize Property

SharpenCommandMatrixSize Property

Gets or sets the size of the filter.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MatrixSize { get; set; }
Public Property MatrixSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the filter.
Exceptions
Exception | Condition
 | Thrown if value is less than 3.
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.SupportedPixelFormats Property

SharpenCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand Methods

The SharpenCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.ConstructFinalImage Method

SharpenCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.GetObjectData Method

SharpenCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.PerformActualCommand Method

SharpenCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.SelectPreferredPixelFormat Method

SharpenCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


SharpenCommand.VerifyProperties Method

SharpenCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SharpenCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Class

Set pixel components above a high threshold value to 255 and below a low threshold value to 0.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersThresholdCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ThresholdCommand : ImageRegionCommand,
    ISerializable, IThreadableCommand, ICloneable
<SerializableAttribute>
Public Class ThresholdCommand
    Inherits ImageRegionCommand
    Implements ISerializable, IThreadableCommand, ICloneable

The ThresholdCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ThresholdCommand | Creates a new instance of ThresholdCommand.
Public method | ThresholdCommand(Int32, Int32) | Creates a new instance of ThresholdCommand specifying minValue, and maxValue.
Protected method | ThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of ThresholdCommand from serialization information.
Public method | ThresholdCommand(Int32, Int32, ChannelFlags) | Creates a new instance of ThresholdCommand specifying minValue, maxValue and channelsToProcess.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MaxValue | Gets or sets a value indicating that pixels above this value are set to 255.
Public property | MinValue | Gets or sets a value indicating that pixels below this value are set to 0.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of this command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This method requires a continuous tone image. If the source image is not continuous, it will throw the ArgumentException

This is not the same as the thresholding commands in the Document namespace. See GlobalThresholdCommand and AdaptiveThresholdCommand for binarizing color or grayscale images into binary images.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Constructor

Overload List
 | Name | Description
Public method | ThresholdCommand | Creates a new instance of ThresholdCommand.
Public method | ThresholdCommand(Int32, Int32) | Creates a new instance of ThresholdCommand specifying minValue, and maxValue.
Protected method | ThresholdCommand(SerializationInfo, StreamingContext) | Creates a new instance of ThresholdCommand from serialization information.
Public method | ThresholdCommand(Int32, Int32, ChannelFlags) | Creates a new instance of ThresholdCommand specifying minValue, maxValue and channelsToProcess.
Top
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Constructor

Creates a new instance of ThresholdCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThresholdCommand()
Public Sub New
See Also

Reference

ThresholdCommand Class
ThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Constructor (Int32, Int32)

Creates a new instance of ThresholdCommand specifying minValue, and maxValue.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThresholdCommand(
    int minValue,
    int maxValue
)
Public Sub New (
    minValue As Integer,
    maxValue As Integer
)

Parameters

minValue
Type: SystemInt32
Pixels below this level are set to 0. Valid values (0 - 255).
maxValue
Type: SystemInt32
Pixels above this level are set to 255. (0 - 255)
Exceptions
Exception | Condition
 | Thrown if minValue or maxValue is less than 0 or greater than 255.
See Also

Reference

ThresholdCommand Class
ThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ThresholdCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ThresholdCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ThresholdCommand Class
ThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Constructor (Int32, Int32, ChannelFlags)

Creates a new instance of ThresholdCommand specifying minValue, maxValue and channelsToProcess.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThresholdCommand(
    int minValue,
    int maxValue,
    ChannelFlags channelsToProcess
)
Public Sub New (
    minValue As Integer,
    maxValue As Integer,
    channelsToProcess As ChannelFlags
)

Parameters

minValue
Type: SystemInt32
Pixels below this level are set to 0. Valid values (0 - 255).
maxValue
Type: SystemInt32
Pixels above this level are set to 255. (0 - 255)
channelsToProcess
Type: Atalasoft.Imaging.ImageProcessingChannelFlags
The ChannelFlags specifying which channels to process.
Exceptions
Exception | Condition
 | Thrown if minValue or maxValue is less than 0 or greater than 255.
See Also

Reference

ThresholdCommand Class
ThresholdCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Properties

The ThresholdCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | AutoThread | If set to true the IThreadableCommand will automatically parallelize image processing.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | MaxValue | Gets or sets a value indicating that pixels above this value are set to 255.
Public property | MinValue | Gets or sets a value indicating that pixels below this value are set to 0.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.AutoThread Property

ThresholdCommandAutoThread Property

If set to true the IThreadableCommand will automatically parallelize image processing.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoThread { get; set; }
Public Property AutoThread As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IThreadableCommandAutoThread
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.ChannelsToProcess Property

ThresholdCommandChannelsToProcess Property

Gets or sets the ChannelFlags specifying which channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The ChannelFlags specifying which channels to process.
Remarks
The default value is AllChannels.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.InPlaceProcessing Property

ThresholdCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.MaxValue Property

ThresholdCommandMaxValue Property

Gets or sets a value indicating that pixels above this value are set to 255.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxValue { get; set; }
Public Property MaxValue As Integer
    Get
    Set

Property Value

Type: Int32
A value indicating that pixels above this value are set to 255.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks
Valid values are from 0 to 255.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.MinValue Property

ThresholdCommandMinValue Property

Gets or sets a value indicating that pixels below this value are set to 0.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MinValue { get; set; }
Public Property MinValue As Integer
    Get
    Set

Property Value

Type: Int32
A value indicating that pixels below this value are set to 0.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
Remarks
Valid values are from 0 to 255.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.SupportedPixelFormats Property

ThresholdCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand Methods

The ThresholdCommand type exposes the following members.

Methods
 | Name | Description
Public method | AdjustBands | Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clone | Returns a copy of this command.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Public method | PerformSectionCommand | Performs the command on a specified section of the image.
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.AdjustBands Method

ThresholdCommandAdjustBands Method

Sets the image area which will be processed and also defines the bands or chunks of the image of which each will be sent to a separate thread.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle[] AdjustBands(
    Rectangle bounds,
    Rectangle[] bands
)
Public Function AdjustBands (
    bounds As Rectangle,
    bands As Rectangle()
) As Rectangle()

Parameters

bounds
Type: System.DrawingRectangle
The area of the image which will be processed.
bands
Type: System.DrawingRectangle
An array of Rectangles which represent the desired bands.

Return Value

Type: Rectangle
An array of Rectangles which represent the bands that will actually be used.

Implements

IThreadableCommandAdjustBands(Rectangle, Rectangle)
Remarks
Each band defines an area on which the IThreadableCommand will operate in an independent thread.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.Clone Method

ThresholdCommandClone Method

Returns a copy of this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of the ThresholdCommand.

Implements

ICloneableClone
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.GetObjectData Method

ThresholdCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.PerformActualCommand Method

ThresholdCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.PerformSectionCommand Method

ThresholdCommandPerformSectionCommand Method

Performs the command on a specified section of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PerformSectionCommand(
    AtalaImage source,
    Rectangle sourceBounds,
    AtalaImage dest,
    Rectangle destBounds
)
Public Sub PerformSectionCommand (
    source As AtalaImage,
    sourceBounds As Rectangle,
    dest As AtalaImage,
    destBounds As Rectangle
)

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image.
sourceBounds
Type: System.DrawingRectangle
The source rectangular boundary.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image.
destBounds
Type: System.DrawingRectangle
The destination image boundary.

Implements

IThreadableCommandPerformSectionCommand(AtalaImage, Rectangle, AtalaImage, Rectangle)
Exceptions
Exception | Condition
ImageProcessException | dynamic thresholding failed
Remarks
This is used internally by each thread to perform its portion of the work for the particular IThreadableCommand.
See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


ThresholdCommand.VerifyProperties Method

ThresholdCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ThresholdCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand Class

The unsharp mask is a sharpening filter which derives its name from the fact that it enhances edges and other high frequency components in an image via a procedure which subtracts an unsharp, or gaussian blurred, version of an image from the original image. The unsharp mask filter is commonly used in the photographic and printing industries for crispening edges.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessingImageRegionCommand
Atalasoft.Imaging.ImageProcessing.FiltersUnsharpMaskCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class UnsharpMaskCommand : ImageRegionCommand,
    ISerializable
<SerializableAttribute>
Public Class UnsharpMaskCommand
    Inherits ImageRegionCommand
    Implements ISerializable

The UnsharpMaskCommand type exposes the following members.

Constructors
 | Name | Description
Public method | UnsharpMaskCommand | Creates a new instance of UnsharpMaskCommand.
Protected method | UnsharpMaskCommand(SerializationInfo, StreamingContext) | Creates a new instance of UnsharpMaskCommand from serialization information.
Public method | UnsharpMaskCommand(Int32, Double, Double) | Creates a new instance of UnsharpMaskCommand specifying the threshold, amount of effect and deviation.
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the value of amount
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets the value of sigma
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Threshold | Gets or sets the value of threshold
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Filters Namespace
Atalasoft.Imaging.ImageProcessing.FiltersAdaptiveUnsharpMaskCommand


UnsharpMaskCommand Constructor

Overload List
 | Name | Description
Public method | UnsharpMaskCommand | Creates a new instance of UnsharpMaskCommand.
Protected method | UnsharpMaskCommand(SerializationInfo, StreamingContext) | Creates a new instance of UnsharpMaskCommand from serialization information.
Public method | UnsharpMaskCommand(Int32, Double, Double) | Creates a new instance of UnsharpMaskCommand specifying the threshold, amount of effect and deviation.
Top
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand Constructor

Creates a new instance of UnsharpMaskCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsharpMaskCommand()
Public Sub New
See Also

Reference

UnsharpMaskCommand Class
UnsharpMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of UnsharpMaskCommand from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected UnsharpMaskCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

UnsharpMaskCommand Class
UnsharpMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand Constructor (Int32, Double, Double)

Creates a new instance of UnsharpMaskCommand specifying the threshold, amount of effect and deviation.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsharpMaskCommand(
    int threshold,
    double amount,
    double sigma
)
Public Sub New (
    threshold As Integer,
    amount As Double,
    sigma As Double
)

Parameters

threshold
Type: SystemInt32
Controls the depth of the effect; the lower the value, the greater the effect. Any value between 0 and 255 is valid.
amount
Type: SystemDouble
Controls the intensity of the effect. Values should be between 0.0 (no effect) and 1.0 (full effect). Higher values will give unpredictable results.
sigma
Type: SystemDouble
The standard deviation (sigma) of the gaussian kernal, controlling the amount of blur. Good values to start with are between 0.6 and 2.4. The higher the value the greater the blur depth and longer the processing time.
Exceptions
Exception | Condition
 | Thrown if threshold is less than 0 or greater than 255, or if amount is less than 0.
See Also

Reference

UnsharpMaskCommand Class
UnsharpMaskCommand Overload
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand Properties

The UnsharpMaskCommand type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the value of amount
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | ChannelsToProcess | Gets or sets the ChannelFlags specifying which channels to process.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | RegionOfInterest | Gets or sets a RegionOfInterest which will only process the indicated region of the image. (Inherited from ImageRegionCommand.)
Public property | Sigma | Gets or sets the value of sigma
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | Threshold | Gets or sets the value of threshold
Top
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.Amount Property

UnsharpMaskCommandAmount Property

Gets or sets the value of amount

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Amount { get; set; }
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double
Controls the intensity of the effect. Values should be between 0.0 (no effect) and 1.0 (full effect). Higher values will give unpredictable results.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.ChannelsToProcess Property

UnsharpMaskCommandChannelsToProcess Property

Gets or sets the ChannelFlags specifying which channels to process.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChannelFlags ChannelsToProcess { get; set; }
Public Property ChannelsToProcess As ChannelFlags
    Get
    Set

Property Value

Type: ChannelFlags
The ChannelFlags specifying which channels to process.
Remarks
The default value is AllChannels.
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.Sigma Property

UnsharpMaskCommandSigma Property

Gets or sets the value of sigma

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Sigma { get; set; }
Public Property Sigma As Double
    Get
    Set

Property Value

Type: Double
The standard deviation (sigma) of the gaussian kernal, controlling the amount of blur. Good values to start with are between 0.6 and 2.4. The higher the value the greater the blur depth and longer the processing time.
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.SupportedPixelFormats Property

UnsharpMaskCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.Threshold Property

UnsharpMaskCommandThreshold Property

Gets or sets the value of threshold

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Threshold { get; set; }
Public Property Threshold As Integer
    Get
    Set

Property Value

Type: Int32
Controls the depth of the effect; the lower the value, the greater the effect. Any value between 0 and 255 is valid.
Exceptions
Exception | Condition
 | Thrown if value is not between 0 and 255.
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand Methods

The UnsharpMaskCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command. (Overrides ImageRegionCommandGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.ConstructFinalImage Method

UnsharpMaskCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.GetObjectData Method

UnsharpMaskCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.PerformActualCommand Method

UnsharpMaskCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.SelectPreferredPixelFormat Method

UnsharpMaskCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


UnsharpMaskCommand.VerifyProperties Method

UnsharpMaskCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Filters
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

UnsharpMaskCommand Class
Atalasoft.Imaging.ImageProcessing.Filters Namespace


Atalasoft.Imaging.ImageProcessing.Transforms Namespace

Classes
 | Class | Description
 | BumpMapTransform | This transform applies a bump map texture to an image.
Public class | EllipticalTransform | Rounds the image into an ellipse or sphere.
Public class | FlipCommand | Flips an image horizontally or vertically.
 | LensTransform | Used to create a zoomed camera lens effect.
Public class | LineSliceTransform | This transform produces a center-shift transform which runs from one side of the image to the other, in a straight line.
Public class | MarbleTransform | This transform creates a marbled, wavy, glassy, rippled effect.
 | OffsetTransform | Moves the image on the canvas by a specified number of pixels.
Public class | PerlinTransform | This effect is similar to the marble transform, but the image tends to break up less.
Public class | PinchTransform | This transform attracts pixels towards the center of the image.
Public class | PolygonTransform | This transform resizes image rows (or columns) to fit inside the specified polygon. This polygon must be convex. If it is concave, the largest convex polygon that can be formed from the points will be used.
Public class | PushCommand | Perform a point to point warp of an image, creating a smear effect.
 | QuadrilateralWarpCommand | Similar to the PolygonTransform, this transform additionally lets you specify a source polygon to allow further control over the warping of the image.
Public class | RandomTransform | This transform randomly modifies the pixels of an image.
 | ResizeCanvasCommand | Overlays the current image onto a specified position on a new image of the specified background color.
Public class | RippleTransform | Creates a water ripple effect on the image.
Public class | RotateCommand | This will rotate an image clockwise by the specified number of degrees.
Public class | SkewCommand | Using this command you can shift the top, bottom, left or right side of an image independently.
Public class | SpinTransform | This transform will rotate the image about the center with a constant angular distance.
Public class | SpinWaveTransform | A SpinWaveTransform rotates the image about the center with a variable angular distance. The distance varies in a sine wave pattern.
Public class | Transform | A base class that is used for transforms.
 | TransformChainCommand | This command allows you to combine multiple transforms into a single command call.
 | UserTransform | This allows you to write your own transform methods and add them to the transform chain, just like the built-in transforms. To do this, you must supply a UserTransformCallback.
Public class | UserTransformData | This class is used in the UserTransformCallback to indicate the pixel locations of the transform.
Public class | WaveTransform | This transform moves across the image with a sine wave pattern.
Public class | WowTransform | This transform creates an effect which is a bit like looking at the image though a clear sphere. If you set BigWow to true, the result looks as if you're inside the sphere.
Public class | ZigZagTransform | This transform moves across the images in a triangle wave pattern.
Delegates
Delegate | Description
UserTransformCallback | Callback method for the UserTransform object.
Enumerations
 | Enumeration | Description
Public enumeration | CompressTransformMode | Enumeration used by EllipticalTransform and PolygonTransform.
Public enumeration | OffsetTransformMode | Enumeration used by OffsetTransform.
Public enumeration | RippleTransformMode | Enumeration used by RippleTransform.
Public enumeration | SkewDirection | Enumeration used by SkewCommand.
Public enumeration | WaveTransformMode | Enumeration used by WaveTransform.


BumpMapTransform Class

This transform applies a bump map texture to an image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsBumpMapTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BumpMapTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class BumpMapTransform
    Inherits Transform
    Implements ISerializable

The BumpMapTransform type exposes the following members.

Constructors
 | Name | Description
Public method | BumpMapTransform | Creates a new instance of BumpMapTransform.
Public method | BumpMapTransform(Double, AtalaImage) | Creates a new instance of BumpMapTransform specifying smoothness, and bumpMapImage.
Protected method | BumpMapTransform(SerializationInfo, StreamingContext) | Creates a new instance of BumpMapTransform from serialization information.
Public method | BumpMapTransform(Double, AtalaImage, InterpolationMode) | Creates a new instance of the BumpMapTransform effect.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BumpMapImage | Gets or sets the bump map image used in this transform.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Smoothness | Gets or sets the smoothness value which controls the smoothness of the effect (try between .5 and 1.5 to start).
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode used for this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
Examples
BumpMapTransform Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Load the bumpmap image. (must be an 8-bit grayscale image)
AtalaImage bump = new AtalaImage(@"D:\Test Images\bumpmap.jpg");

// Apply the command.
BumpMapTransform cmd = new BumpMapTransform(0.8, bump);
AtalaImage result = cmd.Apply(image).Image;

// Dispose of the images.
bump.Dispose();
image.Dispose();
BumpMapTransform Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Load the bumpmap image. (must be an 8-bit grayscale image)
Dim bump As AtalaImage =  New AtalaImage("D:\Test Images\bumpmap.jpg")

' Apply the command.
Dim cmd As BumpMapTransform =  New BumpMapTransform(0.8,bump)
Dim result As AtalaImage =  cmd.Apply(image).Image

' Dispose of the images.
bump.Dispose()
image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Constructor

Overload List
 | Name | Description
Public method | BumpMapTransform | Creates a new instance of BumpMapTransform.
Public method | BumpMapTransform(Double, AtalaImage) | Creates a new instance of BumpMapTransform specifying smoothness, and bumpMapImage.
Protected method | BumpMapTransform(SerializationInfo, StreamingContext) | Creates a new instance of BumpMapTransform from serialization information.
Public method | BumpMapTransform(Double, AtalaImage, InterpolationMode) | Creates a new instance of the BumpMapTransform effect.
Top
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Constructor

Creates a new instance of BumpMapTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BumpMapTransform()
Public Sub New
See Also

Reference

BumpMapTransform Class
BumpMapTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Constructor (Double, AtalaImage)

Creates a new instance of BumpMapTransform specifying smoothness, and bumpMapImage.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BumpMapTransform(
    double smoothness,
    AtalaImage bumpMapImage
)
Public Sub New (
    smoothness As Double,
    bumpMapImage As AtalaImage
)

Parameters

smoothness
Type: SystemDouble
Controls smoothness of the effect (try between .5 and 1.5 to start).
bumpMapImage
Type: Atalasoft.ImagingAtalaImage
An 8-bit grayscale image to use as the bump map.
Exceptions
Exception | Condition
 | Thrown if the smoothness argument is less than 0, or if the bumpMapImage is not an 8-bit image.
See Also

Reference

BumpMapTransform Class
BumpMapTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of BumpMapTransform from serialization information.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BumpMapTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

BumpMapTransform Class
BumpMapTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Constructor (Double, AtalaImage, InterpolationMode)

Creates a new instance of the BumpMapTransform effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BumpMapTransform(
    double smoothness,
    AtalaImage bumpMapImage,
    InterpolationMode transformMode
)
Public Sub New (
    smoothness As Double,
    bumpMapImage As AtalaImage,
    transformMode As InterpolationMode
)

Parameters

smoothness
Type: SystemDouble
Controls smoothness of the effect (try between .5 and 1.5 to start).
bumpMapImage
Type: Atalasoft.ImagingAtalaImage
An 8-bit grayscale image to use as the bump map.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if the smoothness is less than 0, or if bumpMapImage is not an 8-bit image.
See Also

Reference

BumpMapTransform Class
BumpMapTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Properties

The BumpMapTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BumpMapImage | Gets or sets the bump map image used in this transform.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Smoothness | Gets or sets the smoothness value which controls the smoothness of the effect (try between .5 and 1.5 to start).
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode used for this transform.
Top
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform.BumpMapImage Property

BumpMapTransformBumpMapImage Property

Gets or sets the bump map image used in this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage BumpMapImage { get; set; }
Public Property BumpMapImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
8-bit image to use as the bump map.
Exceptions
Exception | Condition
 | Thrown if image is not a valid 8-bit image.
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform.Smoothness Property

BumpMapTransformSmoothness Property

Gets or sets the smoothness value which controls the smoothness of the effect (try between .5 and 1.5 to start).

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Smoothness { get; set; }
Public Property Smoothness As Double
    Get
    Set

Property Value

Type: Double
The smoothness of the bump map transform.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform.TransformMode Property

BumpMapTransformTransformMode Property

Gets or sets the InterpolationMode used for this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform Methods

The BumpMapTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform.AddToChain Method

BumpMapTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to which this transform will be applied.
height
Type: SystemInt32
The height of the image to which this transform will be applied.
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform.GetObjectData Method

BumpMapTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


BumpMapTransform.PerformActualCommand Method

BumpMapTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
ArgumentNullException | BumpMapImage;BumpMapImage cannot be null
ApplicationException | Internal conversion error.
See Also

Reference

BumpMapTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


CompressTransformMode Enumeration

Enumeration used by EllipticalTransform and PolygonTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CompressTransformMode
Public Enumeration CompressTransformMode
Members
Member name | Description
Horizontal | Only the horizontal sides will be compressed.
Vertical | Only the vertical sides will be compressed.
Both | Both horizontal and vertical sides will be compressed.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Class

Rounds the image into an ellipse or sphere.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsEllipticalTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class EllipticalTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class EllipticalTransform
    Inherits Transform
    Implements ISerializable

The EllipticalTransform type exposes the following members.

Constructors
 | Name | Description
Public method | EllipticalTransform | Creates a new instance of EllipticalTransform.
Protected method | EllipticalTransform(SerializationInfo, StreamingContext) | Creates a new instance of EllipticalTransform from serialization information
Public method | EllipticalTransform(Size, Point, CompressTransformMode) | Creates a new instance of EllipticalTransform specifying radius, offset and mode.
Public method | EllipticalTransform(Size, Point, CompressTransformMode, InterpolationMode) | Creates a new instance of EllipticalTransform specifying radius, offset, mode and transformMode.
Public method | EllipticalTransform(Size, Point, CompressTransformMode, InterpolationMode, Color) | Creates a new instance of EllipticalTransform specifying radius, offset, mode, transformMode and backColor.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the type of CompressTransformMode used in this transform.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Radius | Gets or set the width and height of the ellipse.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode for this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


EllipticalTransform Constructor

Overload List
 | Name | Description
Public method | EllipticalTransform | Creates a new instance of EllipticalTransform.
Protected method | EllipticalTransform(SerializationInfo, StreamingContext) | Creates a new instance of EllipticalTransform from serialization information
Public method | EllipticalTransform(Size, Point, CompressTransformMode) | Creates a new instance of EllipticalTransform specifying radius, offset and mode.
Public method | EllipticalTransform(Size, Point, CompressTransformMode, InterpolationMode) | Creates a new instance of EllipticalTransform specifying radius, offset, mode and transformMode.
Public method | EllipticalTransform(Size, Point, CompressTransformMode, InterpolationMode, Color) | Creates a new instance of EllipticalTransform specifying radius, offset, mode, transformMode and backColor.
Top
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Constructor

Creates a new instance of EllipticalTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipticalTransform()
Public Sub New
See Also

Reference

EllipticalTransform Class
EllipticalTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of EllipticalTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected EllipticalTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

EllipticalTransform Class
EllipticalTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Constructor (Size, Point, CompressTransformMode)

Creates a new instance of EllipticalTransform specifying radius, offset and mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipticalTransform(
    Size radius,
    Point offset,
    CompressTransformMode mode
)
Public Sub New (
    radius As Size,
    offset As Point,
    mode As CompressTransformMode
)

Parameters

radius
Type: System.DrawingSize
The width and height of the ellipse.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsCompressTransformMode
The type of CompressTransformMode used in this transform.
Exceptions
Exception | Condition
 | Thrown if the radius size is smaller than 1x1.
See Also

Reference

EllipticalTransform Class
EllipticalTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Constructor (Size, Point, CompressTransformMode, InterpolationMode)

Creates a new instance of EllipticalTransform specifying radius, offset, mode and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipticalTransform(
    Size radius,
    Point offset,
    CompressTransformMode mode,
    InterpolationMode transformMode
)
Public Sub New (
    radius As Size,
    offset As Point,
    mode As CompressTransformMode,
    transformMode As InterpolationMode
)

Parameters

radius
Type: System.DrawingSize
The width and height of the ellipse.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsCompressTransformMode
The type of CompressTransformMode used in this transform.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode used for this transform.
Exceptions
Exception | Condition
 | Thrown if the radius size is smaller than 1x1.
See Also

Reference

EllipticalTransform Class
EllipticalTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Constructor (Size, Point, CompressTransformMode, InterpolationMode, Color)

Creates a new instance of EllipticalTransform specifying radius, offset, mode, transformMode and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipticalTransform(
    Size radius,
    Point offset,
    CompressTransformMode mode,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    radius As Size,
    offset As Point,
    mode As CompressTransformMode,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

radius
Type: System.DrawingSize
The width and height of the ellipse.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsCompressTransformMode
The type of CompressTransformMode used in this transform.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode used for this transform.
backColor
Type: System.DrawingColor
The background color to use for newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if the radius size is smaller than 1x1.
See Also

Reference

EllipticalTransform Class
EllipticalTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Properties

The EllipticalTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the type of CompressTransformMode used in this transform.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Radius | Gets or set the width and height of the ellipse.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode for this transform.
Top
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.BackColor Property

EllipticalTransformBackColor Property

Gets or sets the background color to use for newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use for newly uncovered areas of the image.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.Mode Property

EllipticalTransformMode Property

Gets or sets the type of CompressTransformMode used in this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CompressTransformMode Mode { get; set; }
Public Property Mode As CompressTransformMode
    Get
    Set

Property Value

Type: CompressTransformMode
The type of CompressTransformMode used in this transform.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.Offset Property

EllipticalTransformOffset Property

Gets or set the offset position from the center of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The offset position from the center of the image.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.Radius Property

EllipticalTransformRadius Property

Gets or set the width and height of the ellipse.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Radius { get; set; }
Public Property Radius As Size
    Get
    Set

Property Value

Type: Size
The width and height of the ellipse.
Exceptions
Exception | Condition
 | Thrown if the size is smaller than 1x1.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.TransformMode Property

EllipticalTransformTransformMode Property

Gets or sets the InterpolationMode for this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode used for this transform.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform Methods

The EllipticalTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.AddToChain Method

EllipticalTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to be used with this transform.
height
Type: SystemInt32
The height of the image to be used with this transform.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.GetObjectData Method

EllipticalTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


EllipticalTransform.PerformActualCommand Method

EllipticalTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

EllipticalTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Class

Flips an image horizontally or vertically.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsFlipCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FlipCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class FlipCommand
    Inherits ImageCommand
    Implements ISerializable

The FlipCommand type exposes the following members.

Constructors
 | Name | Description
Public method | FlipCommand | Creates a new instance of FlipCommand.
Public method | FlipCommand(FlipDirection) | Creates a new instance of FlipCommand specifying the type of flip to perform.
Protected method | FlipCommand(SerializationInfo, StreamingContext) | Creates a new instance of FlipCommand from serialization information
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Direction | Gets or sets the type of flip to perform.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Constructor

Overload List
 | Name | Description
Public method | FlipCommand | Creates a new instance of FlipCommand.
Public method | FlipCommand(FlipDirection) | Creates a new instance of FlipCommand specifying the type of flip to perform.
Protected method | FlipCommand(SerializationInfo, StreamingContext) | Creates a new instance of FlipCommand from serialization information
Top
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Constructor

Creates a new instance of FlipCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlipCommand()
Public Sub New
See Also

Reference

FlipCommand Class
FlipCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Constructor (FlipDirection)

Creates a new instance of FlipCommand specifying the type of flip to perform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlipCommand(
    FlipDirection direction
)
Public Sub New (
    direction As FlipDirection
)

Parameters

direction
Type: Atalasoft.ImagingFlipDirection
Specifies which direction, horizontal or vertical, to flip the image.
See Also

Reference

FlipCommand Class
FlipCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of FlipCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected FlipCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

FlipCommand Class
FlipCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Properties

The FlipCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Direction | Gets or sets the type of flip to perform.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Overrides ImageCommandInPlaceProcessing.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand.Direction Property

FlipCommandDirection Property

Gets or sets the type of flip to perform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlipDirection Direction { get; set; }
Public Property Direction As FlipDirection
    Get
    Set

Property Value

Type: FlipDirection
The type of flip to perform.
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand.InPlaceProcessing Property

FlipCommandInPlaceProcessing Property

Gets a value indicating if the source image data is processed in-place as opposed to returning a new image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool InPlaceProcessing { get; }
Public Overrides ReadOnly Property InPlaceProcessing As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source image data is processed in-pace as opposed to returning a new image.
Remarks
By default, this value is false. When false, this ImageCommand should never overwrite the original image. If an unmodified copy of the original image must be maintained and this property returns true, clone the image before applying this ImageCommand. Implementing classes should override this and set it to true when processing the source image directly. When this value is true, the Image object returned by Apply(AtalaImage) may occupy the same memory space as the source image. The state of IsImageSourceImage conveys whether the source image was actually modified in place.
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand.SupportedPixelFormats Property

FlipCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel64bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand Methods

The FlipCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from ImageCommand.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand.GetObjectData Method

FlipCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand.PerformActualCommand Method

FlipCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


FlipCommand.VerifyProperties Method

FlipCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

FlipCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Class

Used to create a zoomed camera lens effect.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsLensTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LensTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class LensTransform
    Inherits Transform
    Implements ISerializable

The LensTransform type exposes the following members.

Constructors
 | Name | Description
Public method | LensTransform | Creates a new instance of LensTransform.
Public method | LensTransform(Double, Point) | Creates a new instance of LensTransform specifying radius and offset.
Protected method | LensTransform(SerializationInfo, StreamingContext) | Creates a new instance of LensTransform from serialization information
Public method | LensTransform(Double, Point, InterpolationMode) | Creates a new instance of LensTransform specifying radius, offset and transformMode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Radius | Gets or sets the maximum distance from the center for this effect.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | The InterpolationMode used with this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
Examples
Lens Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

LensTransform cmd = new LensTransform(image.Width / 2, Point.Empty);
AtalaImage result = cmd.Apply(image).Image;

image.Dispose();
Lens Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

Dim cmd As LensTransform =  New LensTransform(image.Width / 2,PoInteger.Empty)
Dim result As AtalaImage =  cmd.Apply(image).Image

image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Constructor

Overload List
 | Name | Description
Public method | LensTransform | Creates a new instance of LensTransform.
Public method | LensTransform(Double, Point) | Creates a new instance of LensTransform specifying radius and offset.
Protected method | LensTransform(SerializationInfo, StreamingContext) | Creates a new instance of LensTransform from serialization information
Public method | LensTransform(Double, Point, InterpolationMode) | Creates a new instance of LensTransform specifying radius, offset and transformMode.
Top
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Constructor

Creates a new instance of LensTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LensTransform()
Public Sub New
See Also

Reference

LensTransform Class
LensTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Constructor (Double, Point)

Creates a new instance of LensTransform specifying radius and offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LensTransform(
    double radius,
    Point offset
)
Public Sub New (
    radius As Double,
    offset As Point
)

Parameters

radius
Type: SystemDouble
Maximum distance from the center for this effect.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
Exceptions
Exception | Condition
 | Thrown if radius is less than 0.
See Also

Reference

LensTransform Class
LensTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LensTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LensTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

LensTransform Class
LensTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Constructor (Double, Point, InterpolationMode)

Creates a new instance of LensTransform specifying radius, offset and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LensTransform(
    double radius,
    Point offset,
    InterpolationMode transformMode
)
Public Sub New (
    radius As Double,
    offset As Point,
    transformMode As InterpolationMode
)

Parameters

radius
Type: SystemDouble
Maximum distance from the center for this effect.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode used for this transform.
Exceptions
Exception | Condition
 | Thrown if radius is less than 0.
See Also

Reference

LensTransform Class
LensTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Properties

The LensTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Radius | Gets or sets the maximum distance from the center for this effect.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | The InterpolationMode used with this transform.
Top
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform.Offset Property

LensTransformOffset Property

Gets or set the offset position from the center of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The offset position from the center of the image.
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform.Radius Property

LensTransformRadius Property

Gets or sets the maximum distance from the center for this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
Maximum distance from the center for this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Pixels past this distance will not be affected.
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform.TransformMode Property

LensTransformTransformMode Property

The InterpolationMode used with this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode used for this transform.
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform Methods

The LensTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform.AddToChain Method

LensTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to be process.
height
Type: SystemInt32
The height of the image to be processed.
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform.GetObjectData Method

LensTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LensTransform.PerformActualCommand Method

LensTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

LensTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Class

This transform produces a center-shift transform which runs from one side of the image to the other, in a straight line.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsLineSliceTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class LineSliceTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class LineSliceTransform
    Inherits Transform
    Implements ISerializable

The LineSliceTransform type exposes the following members.

Constructors
 | Name | Description
Public method | LineSliceTransform | Creates a new instance of LineSliceTransform.
Protected method | LineSliceTransform(SerializationInfo, StreamingContext) | Creates a new instance of LineSliceTransform from serialization information
Public method | LineSliceTransform(Int32, Int32, Boolean) | Creates a new instance of LineSliceTransform object.
Public method | LineSliceTransform(Int32, Int32, Boolean, InterpolationMode) | Creates a new instance of LineSliceTransform object.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | EndPoint1 | Gets or sets the left or top edge of the transform.
Public property | EndPoint2 | Gets or sets the right or bottom edge of the transform.
Public property | HorizontalTransform | Gets or sets the value specifying if the transform will be horizontal or vertical.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode used for this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


LineSliceTransform Constructor

Overload List
 | Name | Description
Public method | LineSliceTransform | Creates a new instance of LineSliceTransform.
Protected method | LineSliceTransform(SerializationInfo, StreamingContext) | Creates a new instance of LineSliceTransform from serialization information
Public method | LineSliceTransform(Int32, Int32, Boolean) | Creates a new instance of LineSliceTransform object.
Public method | LineSliceTransform(Int32, Int32, Boolean, InterpolationMode) | Creates a new instance of LineSliceTransform object.
Top
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Constructor

Creates a new instance of LineSliceTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineSliceTransform()
Public Sub New
See Also

Reference

LineSliceTransform Class
LineSliceTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of LineSliceTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LineSliceTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

LineSliceTransform Class
LineSliceTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Constructor (Int32, Int32, Boolean)

Creates a new instance of LineSliceTransform object.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineSliceTransform(
    int endPoint1,
    int endPoint2,
    bool horizontalTransform
)
Public Sub New (
    endPoint1 As Integer,
    endPoint2 As Integer,
    horizontalTransform As Boolean
)

Parameters

endPoint1
Type: SystemInt32
Left or top edge of the transform.
endPoint2
Type: SystemInt32
Right or bottom edge of the transform.
horizontalTransform
Type: SystemBoolean
Specifies if the transform will be horizontal or vertical.
Exceptions
Exception | Condition
 | Thrown if endPoint1 or endPoint2 is less than 0.
See Also

Reference

LineSliceTransform Class
LineSliceTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Constructor (Int32, Int32, Boolean, InterpolationMode)

Creates a new instance of LineSliceTransform object.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineSliceTransform(
    int endPoint1,
    int endPoint2,
    bool horizontalTransform,
    InterpolationMode transformMode
)
Public Sub New (
    endPoint1 As Integer,
    endPoint2 As Integer,
    horizontalTransform As Boolean,
    transformMode As InterpolationMode
)

Parameters

endPoint1
Type: SystemInt32
Left or top edge of the transform.
endPoint2
Type: SystemInt32
Right or bottom edge of the transform.
horizontalTransform
Type: SystemBoolean
Specifies if the transform will be horizontal or vertical.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if endPoint1 or endPoint2 is less than 0.
See Also

Reference

LineSliceTransform Class
LineSliceTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Properties

The LineSliceTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | EndPoint1 | Gets or sets the left or top edge of the transform.
Public property | EndPoint2 | Gets or sets the right or bottom edge of the transform.
Public property | HorizontalTransform | Gets or sets the value specifying if the transform will be horizontal or vertical.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode used for this transform.
Top
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.EndPoint1 Property

LineSliceTransformEndPoint1 Property

Gets or sets the left or top edge of the transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int EndPoint1 { get; set; }
Public Property EndPoint1 As Integer
    Get
    Set

Property Value

Type: Int32
Left or top edge of the transform.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.EndPoint2 Property

LineSliceTransformEndPoint2 Property

Gets or sets the right or bottom edge of the transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int EndPoint2 { get; set; }
Public Property EndPoint2 As Integer
    Get
    Set

Property Value

Type: Int32
Right or bottom edge of the transform.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.HorizontalTransform Property

LineSliceTransformHorizontalTransform Property

Gets or sets the value specifying if the transform will be horizontal or vertical.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HorizontalTransform { get; set; }
Public Property HorizontalTransform As Boolean
    Get
    Set

Property Value

Type: Boolean
Specifies if the transform will be horizontal or vertical.
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.TransformMode Property

LineSliceTransformTransformMode Property

Gets or sets the InterpolationMode used for this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode used for this transform.
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform Methods

The LineSliceTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.AddToChain Method

LineSliceTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.GetObjectData Method

LineSliceTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


LineSliceTransform.PerformActualCommand Method

LineSliceTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

LineSliceTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Class

This transform creates a marbled, wavy, glassy, rippled effect.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsMarbleTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MarbleTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class MarbleTransform
    Inherits Transform
    Implements ISerializable

The MarbleTransform type exposes the following members.

Constructors
 | Name | Description
Public method | MarbleTransform | Creates a new instance of MarbleTransform.
Public method | MarbleTransform(Double, Size) | Creates a new instance of MarbleTransform specifying smoothness and scale.
Protected method | MarbleTransform(SerializationInfo, StreamingContext) | Creates a new instance of MarbleTransform from serialization information
Public method | MarbleTransform(Double, Size, InterpolationMode) | Creates a new instance of MarbleTransform specifying smoothness, scale and transformMode.
Public method | MarbleTransform(Double, Size, InterpolationMode, Color) | Creates a new instance of MarbleTransform specifying smoothness, scale, transformMode and backColor.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Scale | Gets or sets the size of the perlin noise.
Public property | Smoothness | Gets or sets the smoothness of the transform.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode used for this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


MarbleTransform Constructor

Overload List
 | Name | Description
Public method | MarbleTransform | Creates a new instance of MarbleTransform.
Public method | MarbleTransform(Double, Size) | Creates a new instance of MarbleTransform specifying smoothness and scale.
Protected method | MarbleTransform(SerializationInfo, StreamingContext) | Creates a new instance of MarbleTransform from serialization information
Public method | MarbleTransform(Double, Size, InterpolationMode) | Creates a new instance of MarbleTransform specifying smoothness, scale and transformMode.
Public method | MarbleTransform(Double, Size, InterpolationMode, Color) | Creates a new instance of MarbleTransform specifying smoothness, scale, transformMode and backColor.
Top
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Constructor

Creates a new instance of MarbleTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarbleTransform()
Public Sub New
See Also

Reference

MarbleTransform Class
MarbleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Constructor (Double, Size)

Creates a new instance of MarbleTransform specifying smoothness and scale.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarbleTransform(
    double smoothness,
    Size scale
)
Public Sub New (
    smoothness As Double,
    scale As Size
)

Parameters

smoothness
Type: SystemDouble
Controls smoothness of the effect. Try between 0.5 and 1.5 to start.
scale
Type: System.DrawingSize

The size of the perlin noise.

Exceptions
Exception | Condition
 | Thrown if smoothness or scale values are less than 0.
See Also

Reference

MarbleTransform Class
MarbleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of MarbleTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MarbleTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

MarbleTransform Class
MarbleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Constructor (Double, Size, InterpolationMode)

Creates a new instance of MarbleTransform specifying smoothness, scale and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarbleTransform(
    double smoothness,
    Size scale,
    InterpolationMode transformMode
)
Public Sub New (
    smoothness As Double,
    scale As Size,
    transformMode As InterpolationMode
)

Parameters

smoothness
Type: SystemDouble
Controls smoothness of the effect. Try between 0.5 and 1.5 to start.
scale
Type: System.DrawingSize

The size of the perlin noise.

transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode used for this transform.
Exceptions
Exception | Condition
 | Thrown if smoothness or scale values are less than 0.
See Also

Reference

MarbleTransform Class
MarbleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Constructor (Double, Size, InterpolationMode, Color)

Creates a new instance of MarbleTransform specifying smoothness, scale, transformMode and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarbleTransform(
    double smoothness,
    Size scale,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    smoothness As Double,
    scale As Size,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

smoothness
Type: SystemDouble
Controls smoothness of the effect. Try between 0.5 and 1.5 to start.
scale
Type: System.DrawingSize

The size of the perlin noise.

transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode used for this transform.
backColor
Type: System.DrawingColor
The background color to use for newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if smoothness or scale values are less than 0.
See Also

Reference

MarbleTransform Class
MarbleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Properties

The MarbleTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Scale | Gets or sets the size of the perlin noise.
Public property | Smoothness | Gets or sets the smoothness of the transform.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode used for this transform.
Top
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.BackColor Property

MarbleTransformBackColor Property

Gets or sets the background color to use for newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use for newly uncovered areas of the image.
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.Scale Property

MarbleTransformScale Property

Gets or sets the size of the perlin noise.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF Scale { get; set; }
Public Property Scale As SizeF
    Get
    Set

Property Value

Type: SizeF

The size of the perlin noise.

Exceptions
Exception | Condition
 | Thrown if either the height or width is less than 0.
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.Smoothness Property

MarbleTransformSmoothness Property

Gets or sets the smoothness of the transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Smoothness { get; set; }
Public Property Smoothness As Double
    Get
    Set

Property Value

Type: Double
Controls smoothness of the effect. Try between 0.5 and 1.5 to start.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.TransformMode Property

MarbleTransformTransformMode Property

Gets or sets the InterpolationMode used for this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode used for this transform.
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform Methods

The MarbleTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.AddToChain Method

MarbleTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.GetObjectData Method

MarbleTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


MarbleTransform.PerformActualCommand Method

MarbleTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

MarbleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Class

Moves the image on the canvas by a specified number of pixels.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OffsetTransform : Transform,
    ISerializable
Public Class OffsetTransform
    Inherits Transform
    Implements ISerializable

The OffsetTransform type exposes the following members.

Constructors
 | Name | Description
Public method | OffsetTransform | Creates a new instance of OffsetTransform.
Public method | OffsetTransform(Point, OffsetTransformMode) | Creates a new instance of OffsetTransform specifying offset and offsetMode.
Protected method | OffsetTransform(SerializationInfo, StreamingContext) | Creates a new instance of OffsetTransform from serialization information
Public method | OffsetTransform(Point, OffsetTransformMode, InterpolationMode) | Creates a new instance of OffsetTransform specifying offset, offsetMode and transformMode.
Public method | OffsetTransform(Point, OffsetTransformMode, InterpolationMode, Color) | Creates a new instance of OffsetTransform specifying offset, offsetMode, transformMode and backColor.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use on newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or set the new left, top position for the image.
Public property | OffsetMode | Gets or sets the style of OffsetTransformMode to perform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
Examples
Offset Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Use the OffsetTransform to reposition the image.
OffsetTransform cmd = new OffsetTransform(new Point(image.Width / 2, image.Height / 2), OffsetTransformMode.DontWrapEdges);
AtalaImage result = cmd.Apply(image).Image;

image.Dispose();
Offset Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage = New AtalaImage("D:\Test Images\1.jpg")

' Use the OffsetTransform to reposition the image.
Dim cmd As OffsetTransform = New OffsetTransform(New Point(image.Width / 2,image.Height / 2),OffsetTransformMode.DontWrapEdges)
Dim result As AtalaImage = cmd.Apply(image).Image

image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Constructor

Overload List
 | Name | Description
Public method | OffsetTransform | Creates a new instance of OffsetTransform.
Public method | OffsetTransform(Point, OffsetTransformMode) | Creates a new instance of OffsetTransform specifying offset and offsetMode.
Protected method | OffsetTransform(SerializationInfo, StreamingContext) | Creates a new instance of OffsetTransform from serialization information
Public method | OffsetTransform(Point, OffsetTransformMode, InterpolationMode) | Creates a new instance of OffsetTransform specifying offset, offsetMode and transformMode.
Public method | OffsetTransform(Point, OffsetTransformMode, InterpolationMode, Color) | Creates a new instance of OffsetTransform specifying offset, offsetMode, transformMode and backColor.
Top
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Constructor

Creates a new instance of OffsetTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OffsetTransform()
Public Sub New
See Also

Reference

OffsetTransform Class
OffsetTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Constructor (Point, OffsetTransformMode)

Creates a new instance of OffsetTransform specifying offset and offsetMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OffsetTransform(
    Point offset,
    OffsetTransformMode offsetMode
)
Public Sub New (
    offset As Point,
    offsetMode As OffsetTransformMode
)

Parameters

offset
Type: System.DrawingPoint
The new left, top position for the image.
offsetMode
Type: Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransformMode
Style of OffsetTransformMode to perform.
See Also

Reference

OffsetTransform Class
OffsetTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of OffsetTransform from serialization information
Creates a new instance of OffsetTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OffsetTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
Creates a new OffsetTransform object.
See Also

Reference

OffsetTransform Class
OffsetTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Constructor (Point, OffsetTransformMode, InterpolationMode)

Creates a new instance of OffsetTransform specifying offset, offsetMode and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OffsetTransform(
    Point offset,
    OffsetTransformMode offsetMode,
    InterpolationMode transformMode
)
Public Sub New (
    offset As Point,
    offsetMode As OffsetTransformMode,
    transformMode As InterpolationMode
)

Parameters

offset
Type: System.DrawingPoint
The new left, top position for the image.
offsetMode
Type: Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransformMode
Style of OffsetTransformMode to perform.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode

The InterpolationMode used for this transform.

See Also

Reference

OffsetTransform Class
OffsetTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Constructor (Point, OffsetTransformMode, InterpolationMode, Color)

Creates a new instance of OffsetTransform specifying offset, offsetMode, transformMode and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OffsetTransform(
    Point offset,
    OffsetTransformMode offsetMode,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    offset As Point,
    offsetMode As OffsetTransformMode,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

offset
Type: System.DrawingPoint
The new left, top position for the image.
offsetMode
Type: Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransformMode
Style of OffsetTransformMode to perform.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode

The InterpolationMode used for this transform.

backColor
Type: System.DrawingColor
The background color to use on newly uncovered areas of the image.
See Also

Reference

OffsetTransform Class
OffsetTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Properties

The OffsetTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use on newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or set the new left, top position for the image.
Public property | OffsetMode | Gets or sets the style of OffsetTransformMode to perform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.BackColor Property

OffsetTransformBackColor Property

Gets or sets the background color to use on newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use on newly uncovered areas of the image.
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.Offset Property

OffsetTransformOffset Property

Gets or set the new left, top position for the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The new left, top position for the image.
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.OffsetMode Property

OffsetTransformOffsetMode Property

Gets or sets the style of OffsetTransformMode to perform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OffsetTransformMode OffsetMode { get; set; }
Public Property OffsetMode As OffsetTransformMode
    Get
    Set

Property Value

Type: OffsetTransformMode
Style of OffsetTransformMode to perform.
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.TransformMode Property

OffsetTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode

The InterpolationMode used for this transform.

See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform Methods

The OffsetTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.AddToChain Method

OffsetTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.

Return Value

Type:
Null
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.GetObjectData Method

OffsetTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransform.PerformActualCommand Method

OffsetTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

OffsetTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


OffsetTransformMode Enumeration

Enumeration used by OffsetTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OffsetTransformMode
Public Enumeration OffsetTransformMode
Members
Member name | Description
DontWrapEdges | Don't wrap the image at the edges.
WrapBothEdges | Wrap both X and Y edges.
WrapOnlyX | Wrap only the X edges.
WrapOnlyY | Wrap only the Y edges.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Class

This effect is similar to the marble transform, but the image tends to break up less.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsPerlinTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PerlinTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class PerlinTransform
    Inherits Transform
    Implements ISerializable

The PerlinTransform type exposes the following members.

Constructors
 | Name | Description
Public method | PerlinTransform | Creates a new instance of PerlinTransform.
Public method | PerlinTransform(Double, Size) | Creates a new instance of PerlinTransform specifying the smoothness and scale.
Protected method | PerlinTransform(SerializationInfo, StreamingContext) | Creates a new instance of PerlinTransform from serialization information
Public method | PerlinTransform(Double, Size, InterpolationMode) | Creates a new instance of PerlinTransform specifying smoothness, scale and transform mode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Scale | Gets or sets the size of the perlin noise.
Public property | Smoothness | Gets or sets the smoothness of this effect.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


PerlinTransform Constructor

Overload List
 | Name | Description
Public method | PerlinTransform | Creates a new instance of PerlinTransform.
Public method | PerlinTransform(Double, Size) | Creates a new instance of PerlinTransform specifying the smoothness and scale.
Protected method | PerlinTransform(SerializationInfo, StreamingContext) | Creates a new instance of PerlinTransform from serialization information
Public method | PerlinTransform(Double, Size, InterpolationMode) | Creates a new instance of PerlinTransform specifying smoothness, scale and transform mode.
Top
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Constructor

Creates a new instance of PerlinTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PerlinTransform()
Public Sub New
See Also

Reference

PerlinTransform Class
PerlinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Constructor (Double, Size)

Creates a new instance of PerlinTransform specifying the smoothness and scale.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PerlinTransform(
    double smoothness,
    Size scale
)
Public Sub New (
    smoothness As Double,
    scale As Size
)

Parameters

smoothness
Type: SystemDouble
The smoothness of this effect.
scale
Type: System.DrawingSize
The size of the perlin noise.
Exceptions
Exception | Condition
 | Thrown if smoothness or scale values are less than 0.
See Also

Reference

PerlinTransform Class
PerlinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PerlinTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PerlinTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PerlinTransform Class
PerlinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Constructor (Double, Size, InterpolationMode)

Creates a new instance of PerlinTransform specifying smoothness, scale and transform mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PerlinTransform(
    double smoothness,
    Size scale,
    InterpolationMode transformMode
)
Public Sub New (
    smoothness As Double,
    scale As Size,
    transformMode As InterpolationMode
)

Parameters

smoothness
Type: SystemDouble
The smoothness of this effect.
scale
Type: System.DrawingSize
The size of the perlin noise.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
Exceptions
Exception | Condition
 | Thrown if smoothness or scale values are less than 0.
See Also

Reference

PerlinTransform Class
PerlinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Properties

The PerlinTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | Scale | Gets or sets the size of the perlin noise.
Public property | Smoothness | Gets or sets the smoothness of this effect.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform.Scale Property

PerlinTransformScale Property

Gets or sets the size of the perlin noise.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Scale { get; set; }
Public Property Scale As Size
    Get
    Set

Property Value

Type: Size

The size of the perlin noise.

Exceptions
Exception | Condition
 | Thrown if either the height or width is less than 0.
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform.Smoothness Property

PerlinTransformSmoothness Property

Gets or sets the smoothness of this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Smoothness { get; set; }
Public Property Smoothness As Double
    Get
    Set

Property Value

Type: Double
The smoothness of this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Try values between 0.5 and 1.5 to start.
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform.TransformMode Property

PerlinTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode

The InterpolationMode of this transform.

See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform Methods

The PerlinTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform.AddToChain Method

PerlinTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform.GetObjectData Method

PerlinTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PerlinTransform.PerformActualCommand Method

PerlinTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PerlinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Class

This transform attracts pixels towards the center of the image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsPinchTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PinchTransform : Transform,
    ISerializable
Public Class PinchTransform
    Inherits Transform
    Implements ISerializable

The PinchTransform type exposes the following members.

Constructors
 | Name | Description
Public method | PinchTransform | Creates a new instance of PinchTransform.
Protected method | PinchTransform(SerializationInfo, StreamingContext) | Creates a new instance of PinchTransform from serialization information
Public method | PinchTransform(Double, Double, Point) | Creates a new instance of PinchTransform specifying maxRadius, amount and offset.
Public method | PinchTransform(Double, Double, Point, InterpolationMode) | Creates a new instance of PinchTransform specifying maxRadius, amount, offset and transformMode.
Public method | PinchTransform(Double, Double, Point, InterpolationMode, Color) | Creates a new instance of PinchTransform specifying maxRadius, amount, offset, transformMode and backColor.
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the number of pixels to pinch.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color used for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


PinchTransform Constructor

Overload List
 | Name | Description
Public method | PinchTransform | Creates a new instance of PinchTransform.
Protected method | PinchTransform(SerializationInfo, StreamingContext) | Creates a new instance of PinchTransform from serialization information
Public method | PinchTransform(Double, Double, Point) | Creates a new instance of PinchTransform specifying maxRadius, amount and offset.
Public method | PinchTransform(Double, Double, Point, InterpolationMode) | Creates a new instance of PinchTransform specifying maxRadius, amount, offset and transformMode.
Public method | PinchTransform(Double, Double, Point, InterpolationMode, Color) | Creates a new instance of PinchTransform specifying maxRadius, amount, offset, transformMode and backColor.
Top
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Constructor

Creates a new instance of PinchTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PinchTransform()
Public Sub New
See Also

Reference

PinchTransform Class
PinchTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PinchTransform from serialization information
Creates a new instance of the PinchTransform object.
Creates a new instance of PinchTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PinchTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PinchTransform Class
PinchTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Constructor (Double, Double, Point)

Creates a new instance of PinchTransform specifying maxRadius, amount and offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PinchTransform(
    double maxRadius,
    double amount,
    Point offset
)
Public Sub New (
    maxRadius As Double,
    amount As Double,
    offset As Point
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
amount
Type: SystemDouble
The number of pixels to pinch.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
Exceptions
Exception | Condition
 | Thrown if maxRadius is less than 0.
See Also

Reference

PinchTransform Class
PinchTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Constructor (Double, Double, Point, InterpolationMode)

Creates a new instance of PinchTransform specifying maxRadius, amount, offset and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PinchTransform(
    double maxRadius,
    double amount,
    Point offset,
    InterpolationMode transformMode
)
Public Sub New (
    maxRadius As Double,
    amount As Double,
    offset As Point,
    transformMode As InterpolationMode
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
amount
Type: SystemDouble
The number of pixels to pinch.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
Exceptions
Exception | Condition
 | Thrown if maxRadius is less than 0.
See Also

Reference

PinchTransform Class
PinchTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Constructor (Double, Double, Point, InterpolationMode, Color)

Creates a new instance of PinchTransform specifying maxRadius, amount, offset, transformMode and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PinchTransform(
    double maxRadius,
    double amount,
    Point offset,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    maxRadius As Double,
    amount As Double,
    offset As Point,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
amount
Type: SystemDouble
The number of pixels to pinch.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
backColor
Type: System.DrawingColor
The background color used for newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if maxRadius is less than 0.
See Also

Reference

PinchTransform Class
PinchTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Properties

The PinchTransform type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the number of pixels to pinch.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color used for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.Amount Property

PinchTransformAmount Property

Gets or sets the number of pixels to pinch.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Amount { get; set; }
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double
The number of pixels to pinch.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.BackColor Property

PinchTransformBackColor Property

Gets or sets the background color used for newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color used for newly uncovered areas of the image.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.MaxRadius Property

PinchTransformMaxRadius Property

Gets or sets the maximum distance from the center for this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxRadius { get; set; }
Public Property MaxRadius As Double
    Get
    Set

Property Value

Type: Double
Maximum distance from the center for this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.Offset Property

PinchTransformOffset Property

Gets or set the offset position from the center of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The offset position from the center of the image.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.TransformMode Property

PinchTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform Methods

The PinchTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.AddToChain Method

PinchTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.GetObjectData Method

PinchTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PinchTransform.PerformActualCommand Method

PinchTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PinchTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Class

This transform resizes image rows (or columns) to fit inside the specified polygon. This polygon must be convex. If it is concave, the largest convex polygon that can be formed from the points will be used.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsPolygonTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PolygonTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class PolygonTransform
    Inherits Transform
    Implements ISerializable

The PolygonTransform type exposes the following members.

Constructors
 | Name | Description
Public method | PolygonTransform | Creates a new instance of PolygonTransform.
Public method | PolygonTransform(Point, CompressTransformMode) | Creates a new instance of PolygonTransform specifying points, and mode.
Protected method | PolygonTransform(SerializationInfo, StreamingContext) | Creates a new instance of PolygonTransform from serialization information
Public method | PolygonTransform(Point, CompressTransformMode, InterpolationMode) | Creates a new instance of PolygonTransform specifying points, mode and transformMode.
Public method | PolygonTransform(Point, CompressTransformMode, InterpolationMode, Color) | Creates a new instance of PolygonTransform specifying points, mode, transformMode and backColor.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the CompressTransformMode to use on this transform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetPoints | Gets the points used in the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | SetPoints | Sets the points used in the polygon.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Constructor

Overload List
 | Name | Description
Public method | PolygonTransform | Creates a new instance of PolygonTransform.
Public method | PolygonTransform(Point, CompressTransformMode) | Creates a new instance of PolygonTransform specifying points, and mode.
Protected method | PolygonTransform(SerializationInfo, StreamingContext) | Creates a new instance of PolygonTransform from serialization information
Public method | PolygonTransform(Point, CompressTransformMode, InterpolationMode) | Creates a new instance of PolygonTransform specifying points, mode and transformMode.
Public method | PolygonTransform(Point, CompressTransformMode, InterpolationMode, Color) | Creates a new instance of PolygonTransform specifying points, mode, transformMode and backColor.
Top
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Constructor

Creates a new instance of PolygonTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonTransform()
Public Sub New
See Also

Reference

PolygonTransform Class
PolygonTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Constructor (Point[], CompressTransformMode)

PolygonTransform Constructor (Point, CompressTransformMode)

Creates a new instance of PolygonTransform specifying points, and mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonTransform(
    Point[] points,
    CompressTransformMode mode
)
Public Sub New (
    points As Point(),
    mode As CompressTransformMode
)

Parameters

points
Type: System.DrawingPoint
Array of points for the polygon.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsCompressTransformMode
The compress method to use on this transform.
Exceptions
Exception | Condition
 | Thrown if points is null.
See Also

Reference

PolygonTransform Class
PolygonTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PolygonTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PolygonTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PolygonTransform Class
PolygonTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Constructor (Point[], CompressTransformMode, InterpolationMode)

PolygonTransform Constructor (Point, CompressTransformMode, InterpolationMode)

Creates a new instance of PolygonTransform specifying points, mode and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonTransform(
    Point[] points,
    CompressTransformMode mode,
    InterpolationMode transformMode
)
Public Sub New (
    points As Point(),
    mode As CompressTransformMode,
    transformMode As InterpolationMode
)

Parameters

points
Type: System.DrawingPoint
Array of points for the polygon.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsCompressTransformMode
The compress method to use on this transform.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if points is null.
See Also

Reference

PolygonTransform Class
PolygonTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Constructor (Point[], CompressTransformMode, InterpolationMode, Color)

PolygonTransform Constructor (Point, CompressTransformMode, InterpolationMode, Color)

Creates a new instance of PolygonTransform specifying points, mode, transformMode and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonTransform(
    Point[] points,
    CompressTransformMode mode,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    points As Point(),
    mode As CompressTransformMode,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

points
Type: System.DrawingPoint
Array of points for the polygon.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsCompressTransformMode
The compress method to use on this transform.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
backColor
Type: System.DrawingColor
The background color to use for newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if points is null.
See Also

Reference

PolygonTransform Class
PolygonTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Properties

The PolygonTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Mode | Gets or sets the CompressTransformMode to use on this transform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.BackColor Property

PolygonTransformBackColor Property

Gets or sets the background color to use for newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use for newly uncovered areas of the image.
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.Mode Property

PolygonTransformMode Property

Gets or sets the CompressTransformMode to use on this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CompressTransformMode Mode { get; set; }
Public Property Mode As CompressTransformMode
    Get
    Set

Property Value

Type: CompressTransformMode
The compress method to use on this transform.
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.TransformMode Property

PolygonTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode

The InterpolationMode of this transform.

See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform Methods

The PolygonTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetPoints | Gets the points used in the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | SetPoints | Sets the points used in the polygon.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.AddToChain Method

PolygonTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.GetObjectData Method

PolygonTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.GetPoints Method

PolygonTransformGetPoints Method

Gets the points used in the polygon.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point[] GetPoints()
Public Function GetPoints As Point()

Return Value

Type: Point
The points array used for the polygon
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.PerformActualCommand Method

PolygonTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PolygonTransform.SetPoints Method

PolygonTransformSetPoints Method

Sets the points used in the polygon.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetPoints(
    Point[] points
)
Public Sub SetPoints (
    points As Point()
)

Parameters

points
Type: System.DrawingPoint
An array of Point to use for the polygon.
Exceptions
Exception | Condition
 | Thrown if points is null.
See Also

Reference

PolygonTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand Class

Perform a point to point warp of an image, creating a smear effect.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsPushCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PushCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class PushCommand
    Inherits ImageCommand
    Implements ISerializable

The PushCommand type exposes the following members.

Constructors
 | Name | Description
Public method | PushCommand | Creates a new instance of PushCommand.
Public method | PushCommand(Point, Point) | Creates a new instance of PushCommand specifying the from and to positions.
Protected method | PushCommand(SerializationInfo, StreamingContext) | Creates a new instance of PushCommand from serialization information
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FromPixel | Gets or sets the position on the image to push from.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | ToPixel | Gets or sets the position on the image to move the pixels to.
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


PushCommand Constructor

Overload List
 | Name | Description
Public method | PushCommand | Creates a new instance of PushCommand.
Public method | PushCommand(Point, Point) | Creates a new instance of PushCommand specifying the from and to positions.
Protected method | PushCommand(SerializationInfo, StreamingContext) | Creates a new instance of PushCommand from serialization information
Top
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand Constructor

Creates a new instance of PushCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushCommand()
Public Sub New
See Also

Reference

PushCommand Class
PushCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand Constructor (Point, Point)

Creates a new instance of PushCommand specifying the from and to positions.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushCommand(
    Point fromPixel,
    Point toPixel
)
Public Sub New (
    fromPixel As Point,
    toPixel As Point
)

Parameters

fromPixel
Type: System.DrawingPoint
The position on the image to push from.
toPixel
Type: System.DrawingPoint
The position on the image to move the pixels to.
See Also

Reference

PushCommand Class
PushCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of PushCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PushCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

PushCommand Class
PushCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand Properties

The PushCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | FromPixel | Gets or sets the position on the image to push from.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | ToPixel | Gets or sets the position on the image to move the pixels to.
Top
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.FromPixel Property

PushCommandFromPixel Property

Gets or sets the position on the image to push from.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point FromPixel { get; set; }
Public Property FromPixel As Point
    Get
    Set

Property Value

Type: Point
The position on the image to push from.
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.SupportedPixelFormats Property

PushCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.ToPixel Property

PushCommandToPixel Property

Gets or sets the position on the image to move the pixels to.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ToPixel { get; set; }
Public Property ToPixel As Point
    Get
    Set

Property Value

Type: Point
The position on the image to move the pixels to.
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand Methods

The PushCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.GetObjectData Method

PushCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.PerformActualCommand Method

PushCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.SelectPreferredPixelFormat Method

PushCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


PushCommand.VerifyProperties Method

PushCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

PushCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Class

Similar to the PolygonTransform, this transform additionally lets you specify a source polygon to allow further control over the warping of the image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsQuadrilateralWarpCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class QuadrilateralWarpCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class QuadrilateralWarpCommand
    Inherits ImageCommand
    Implements ISerializable

The QuadrilateralWarpCommand type exposes the following members.

Constructors
 | Name | Description
Public method | QuadrilateralWarpCommand | Creates a new instance of QuadrilateralWarpCommand.
Protected method | QuadrilateralWarpCommand(SerializationInfo, StreamingContext) | Creates a new instance of QuadrilateralWarpCommand from serialization information
Public method | QuadrilateralWarpCommand(Point, Point, Point, Point, InterpolationMode, Color) | Creates a new instance of QuadrilateralWarpCommand specifying destination points that will yield a perspective transform.
Public method | QuadrilateralWarpCommand(Point, Point, Point, Point, Point, Point, Point, Point, InterpolationMode, Color) | Creates a new instance of QuadrilateralWarpCommand specifying sourceBottomLeft, sourceTopLeft, sourceTopRight, sourceBottomRight, destBottomLeft, destTopLeft, destTopRight, destBottomRight, and interpolation.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundColor | Gets or sets the value of backgroundColor
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestBottomLeft | Gets or sets the bottom left point of the destination image in pixels.
Public property | DestBottomRight | Gets or sets the bottom right point of the destination image in pixels.
Public property | DestTopLeft | Gets or sets the top left point of the destination image in pixels.
Public property | DestTopRight | Gets or sets the top right point of the destination image in pixels.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Interpolation | Gets or sets the InterpolationMode of this transform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceBottomLeft | Gets or sets the bottom left point of the source image in pixels.
Public property | SourceBottomRight | Gets or sets the bottom right point of the source image in pixels.
Public property | SourceTopLeft | Gets or sets the top left point of the source image in pixels.
Public property | SourceTopRight | Gets or sets the top right point of the source image in pixels.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.
Examples
QuadExample (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Prepare the warp positions.
Point bottomLeft = new Point(100, image.Height - 80);
Point topLeft = new Point(130, 45);
Point topRight = new Point(image.Width - 60, 140);
Point bottomRight = new Point(image.Width - 20, image.Height);

// Warp the image.
QuadrilateralWarpCommand cmd = new QuadrilateralWarpCommand(bottomLeft,
    topLeft, topRight, bottomRight, InterpolationMode.BiLinear, Color.White);

AtalaImage result = cmd.Apply(image).Image;
image.Dispose();
QuadExample (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Prepare the warp positions.
Dim bottomLeft As Point =  New Point(100,image.Height - 80)
Dim topLeft As Point =  New Point(130,45)
Dim topRight As Point =  New Point(image.Width - 60,140)
Dim bottomRight As Point =  New Point(image.Width - 20,image.Height)

' Warp the image.
QuadrilateralWarpCommand cmd = New QuadrilateralWarpCommand(bottomLeft,
    topLeft, topRight, bottomRight, InterpolationMode.BiLinear, Color.White)

Dim result As AtalaImage =  cmd.Apply(image).Image
image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Constructor

Overload List
 | Name | Description
Public method | QuadrilateralWarpCommand | Creates a new instance of QuadrilateralWarpCommand.
Protected method | QuadrilateralWarpCommand(SerializationInfo, StreamingContext) | Creates a new instance of QuadrilateralWarpCommand from serialization information
Public method | QuadrilateralWarpCommand(Point, Point, Point, Point, InterpolationMode, Color) | Creates a new instance of QuadrilateralWarpCommand specifying destination points that will yield a perspective transform.
Public method | QuadrilateralWarpCommand(Point, Point, Point, Point, Point, Point, Point, Point, InterpolationMode, Color) | Creates a new instance of QuadrilateralWarpCommand specifying sourceBottomLeft, sourceTopLeft, sourceTopRight, sourceBottomRight, destBottomLeft, destTopLeft, destTopRight, destBottomRight, and interpolation.
Top
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Constructor

Creates a new instance of QuadrilateralWarpCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralWarpCommand()
Public Sub New
See Also

Reference

QuadrilateralWarpCommand Class
QuadrilateralWarpCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of QuadrilateralWarpCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected QuadrilateralWarpCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

QuadrilateralWarpCommand Class
QuadrilateralWarpCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Constructor (Point, Point, Point, Point, InterpolationMode, Color)

Creates a new instance of QuadrilateralWarpCommand specifying destination points that will yield a perspective transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralWarpCommand(
    Point destBottomLeft,
    Point destTopLeft,
    Point destTopRight,
    Point destBottomRight,
    InterpolationMode interpolation,
    Color backgroundColor
)
Public Sub New (
    destBottomLeft As Point,
    destTopLeft As Point,
    destTopRight As Point,
    destBottomRight As Point,
    interpolation As InterpolationMode,
    backgroundColor As Color
)

Parameters

destBottomLeft
Type: System.DrawingPoint
The bottom left point of the destination image in pixels.
destTopLeft
Type: System.DrawingPoint
The top left point of the destination image in pixels.
destTopRight
Type: System.DrawingPoint
The top right point of the destination image in pixels.
destBottomRight
Type: System.DrawingPoint
The bottom right point of the destination image in pixels.
interpolation
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The interpolation method to use.
backgroundColor
Type: System.DrawingColor
The background color used for newly uncovered areas of the image.
See Also

Reference

QuadrilateralWarpCommand Class
QuadrilateralWarpCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Constructor (Point, Point, Point, Point, Point, Point, Point, Point, InterpolationMode, Color)

Creates a new instance of QuadrilateralWarpCommand specifying sourceBottomLeft, sourceTopLeft, sourceTopRight, sourceBottomRight, destBottomLeft, destTopLeft, destTopRight, destBottomRight, and interpolation.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralWarpCommand(
    Point sourceBottomLeft,
    Point sourceTopLeft,
    Point sourceTopRight,
    Point sourceBottomRight,
    Point destBottomLeft,
    Point destTopLeft,
    Point destTopRight,
    Point destBottomRight,
    InterpolationMode interpolation,
    Color backgroundColor
)
Public Sub New (
    sourceBottomLeft As Point,
    sourceTopLeft As Point,
    sourceTopRight As Point,
    sourceBottomRight As Point,
    destBottomLeft As Point,
    destTopLeft As Point,
    destTopRight As Point,
    destBottomRight As Point,
    interpolation As InterpolationMode,
    backgroundColor As Color
)

Parameters

sourceBottomLeft
Type: System.DrawingPoint
The bottom left point of the source image in pixels.
sourceTopLeft
Type: System.DrawingPoint
The top left point of the source image in pixels.
sourceTopRight
Type: System.DrawingPoint
The top right point of the source image in pixels.
sourceBottomRight
Type: System.DrawingPoint
The bottom right point of the source image in pixels.
destBottomLeft
Type: System.DrawingPoint
The bottom left point of the destination image in pixels.
destTopLeft
Type: System.DrawingPoint
The top left point of the destination image in pixels.
destTopRight
Type: System.DrawingPoint
The top right point of the destination image in pixels.
destBottomRight
Type: System.DrawingPoint
The bottom right point of the destination image in pixels.
interpolation
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The interpolation method to use.
backgroundColor
Type: System.DrawingColor
The background color used for newly uncovered areas of the image.
See Also

Reference

QuadrilateralWarpCommand Class
QuadrilateralWarpCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Properties

The QuadrilateralWarpCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundColor | Gets or sets the value of backgroundColor
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | DestBottomLeft | Gets or sets the bottom left point of the destination image in pixels.
Public property | DestBottomRight | Gets or sets the bottom right point of the destination image in pixels.
Public property | DestTopLeft | Gets or sets the top left point of the destination image in pixels.
Public property | DestTopRight | Gets or sets the top right point of the destination image in pixels.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Interpolation | Gets or sets the InterpolationMode of this transform.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SourceBottomLeft | Gets or sets the bottom left point of the source image in pixels.
Public property | SourceBottomRight | Gets or sets the bottom right point of the source image in pixels.
Public property | SourceTopLeft | Gets or sets the top left point of the source image in pixels.
Public property | SourceTopRight | Gets or sets the top right point of the source image in pixels.
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.BackgroundColor Property

QuadrilateralWarpCommandBackgroundColor Property

Gets or sets the value of backgroundColor

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The color of the background when the destination image doesn't occupy a perfect rectangle
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.DestBottomLeft Property

QuadrilateralWarpCommandDestBottomLeft Property

Gets or sets the bottom left point of the destination image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point DestBottomLeft { get; set; }
Public Property DestBottomLeft As Point
    Get
    Set

Property Value

Type: Point
The bottom left point of the destination image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.DestBottomRight Property

QuadrilateralWarpCommandDestBottomRight Property

Gets or sets the bottom right point of the destination image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point DestBottomRight { get; set; }
Public Property DestBottomRight As Point
    Get
    Set

Property Value

Type: Point
The bottom right point of the destination image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.DestTopLeft Property

QuadrilateralWarpCommandDestTopLeft Property

Gets or sets the top left point of the destination image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point DestTopLeft { get; set; }
Public Property DestTopLeft As Point
    Get
    Set

Property Value

Type: Point
The top left point of the destination image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.DestTopRight Property

QuadrilateralWarpCommandDestTopRight Property

Gets or sets the top right point of the destination image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point DestTopRight { get; set; }
Public Property DestTopRight As Point
    Get
    Set

Property Value

Type: Point
The top right point of the destination image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.Interpolation Property

QuadrilateralWarpCommandInterpolation Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode Interpolation { get; set; }
Public Property Interpolation As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.SourceBottomLeft Property

QuadrilateralWarpCommandSourceBottomLeft Property

Gets or sets the bottom left point of the source image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point SourceBottomLeft { get; set; }
Public Property SourceBottomLeft As Point
    Get
    Set

Property Value

Type: Point
The bottom left point of the source image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.SourceBottomRight Property

QuadrilateralWarpCommandSourceBottomRight Property

Gets or sets the bottom right point of the source image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point SourceBottomRight { get; set; }
Public Property SourceBottomRight As Point
    Get
    Set

Property Value

Type: Point
The bottom right point of the source image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.SourceTopLeft Property

QuadrilateralWarpCommandSourceTopLeft Property

Gets or sets the top left point of the source image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point SourceTopLeft { get; set; }
Public Property SourceTopLeft As Point
    Get
    Set

Property Value

Type: Point
The top left point of the source image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.SourceTopRight Property

QuadrilateralWarpCommandSourceTopRight Property

Gets or sets the top right point of the source image in pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point SourceTopRight { get; set; }
Public Property SourceTopRight As Point
    Get
    Set

Property Value

Type: Point
The top right point of the source image in pixels.
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.SupportedPixelFormats Property

QuadrilateralWarpCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel8bppIndexed
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand Methods

The QuadrilateralWarpCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.ConstructFinalImage Method

QuadrilateralWarpCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Exceptions
Exception | Condition
InternalErrorException | Unable to allocate destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.GetObjectData Method

QuadrilateralWarpCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.PerformActualCommand Method

QuadrilateralWarpCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
InternalErrorException | unexpected image size - doesn't match quadrtilateral dimensions
See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.SelectPreferredPixelFormat Method

QuadrilateralWarpCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


QuadrilateralWarpCommand.VerifyProperties Method

QuadrilateralWarpCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
ArgumentException | The image must be at least 2 x 2 pixels in size.;sourceImage or Bicubic interpolation is not compatible with colormapped images using QuadrilateralWarpCommand or The destination points cannot all be empty. or The source points are not convex. or The destination points are not convex.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

QuadrilateralWarpCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Class

This transform randomly modifies the pixels of an image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsRandomTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RandomTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class RandomTransform
    Inherits Transform
    Implements ISerializable

The RandomTransform type exposes the following members.

Constructors
 | Name | Description
Public method | RandomTransform | Creates a new instance of RandomTransform.
Public method | RandomTransform(Double) | Creates a new instance of RandomTransform specifying amount.
Public method | RandomTransform(Double, InterpolationMode) | Creates a new instance of RandomTransform specifying amount and transformMode.
Protected method | RandomTransform(SerializationInfo, StreamingContext) | Creates a new instance of RandomTransform from serialization information
Top
Properties
 | Name | Description
Public property | Amount | Gets or sets the amount of offset to apply to the pixels.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


RandomTransform Constructor

Overload List
 | Name | Description
Public method | RandomTransform | Creates a new instance of RandomTransform.
Public method | RandomTransform(Double) | Creates a new instance of RandomTransform specifying amount.
Public method | RandomTransform(Double, InterpolationMode) | Creates a new instance of RandomTransform specifying amount and transformMode.
Protected method | RandomTransform(SerializationInfo, StreamingContext) | Creates a new instance of RandomTransform from serialization information
Top
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Constructor

Creates a new instance of RandomTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomTransform()
Public Sub New
See Also

Reference

RandomTransform Class
RandomTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Constructor (Double)

Creates a new instance of RandomTransform specifying amount.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomTransform(
    double amount
)
Public Sub New (
    amount As Double
)

Parameters

amount
Type: SystemDouble
Amount to offset the pixels.
Exceptions
Exception | Condition
 | Thrown if amount is less than 0.
See Also

Reference

RandomTransform Class
RandomTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Constructor (Double, InterpolationMode)

Creates a new instance of RandomTransform specifying amount and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomTransform(
    double amount,
    InterpolationMode transformMode
)
Public Sub New (
    amount As Double,
    transformMode As InterpolationMode
)

Parameters

amount
Type: SystemDouble
Amount to offset the pixels.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if amount is less than 0.
See Also

Reference

RandomTransform Class
RandomTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RandomTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RandomTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

RandomTransform Class
RandomTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Properties

The RandomTransform type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Gets or sets the amount of offset to apply to the pixels.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform.Amount Property

RandomTransformAmount Property

Gets or sets the amount of offset to apply to the pixels.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Amount { get; set; }
Public Property Amount As Double
    Get
    Set

Property Value

Type: Double
Amount to offset the pixels.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform.TransformMode Property

RandomTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform Methods

The RandomTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform.AddToChain Method

RandomTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform.GetObjectData Method

RandomTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RandomTransform.PerformActualCommand Method

RandomTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

RandomTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Class

Overlays the current image onto a specified position on a new image of the specified background color.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsResizeCanvasCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ResizeCanvasCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class ResizeCanvasCommand
    Inherits ImageCommand
    Implements ISerializable

The ResizeCanvasCommand type exposes the following members.

Constructors
 | Name | Description
Public method | ResizeCanvasCommand | Creates a new instance of ResizeCanvasCommand.
Protected method | ResizeCanvasCommand(SerializationInfo, StreamingContext) | Creates a new instance of ResizeCanvasCommand from serialization information
Public method | ResizeCanvasCommand(Size, Point, Color) | Creates a new instance of ResizeCanvasCommand specifying canvasSize, position, canvasColor, and canvasPaletteIndex.
Public method | ResizeCanvasCommand(Size, Point, Int32) | Creates a new instance of ResizeCanvasCommand specifying canvasSize, position, canvasColor, and canvasPaletteIndex.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CanvasColor | Gets or sets the background color of the canvas.
Public property | CanvasPaletteIndex | Gets or sets the palette index of the canvas.
Public property | CanvasSize | Gets or sets the size of the new canvas.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Position | Gets or sets the position of the image on the new canvas.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This command can be used for adding a border to an image.

This method requires a continuous tone image. If the source image is not continuous, it will raise the ChangePixelFormat event and convert the image to a continuous tone format, which can be 8-bit grayscale, RGB, or RGBA.

Examples
ResizeCanvas Example (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Add a 40 pixel border around the image.
Size newSize = new Size(image.Width + 80, image.Height + 80);

// We position the image at 39, 39 because the top, left position is 0, 0.
ResizeCanvasCommand cmd = new ResizeCanvasCommand(newSize, new Point(39, 39), Color.White);
AtalaImage result = cmd.Apply(image).Image;

image.Dispose();
ResizeCanvas Example (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Add a 40 pixel border around the image.
Dim NewSize As Size =  New Size(image.Width + 80,image.Height + 80)

' We position the image at 39, 39 because the top, left position is 0, 0.
Dim cmd As ResizeCanvasCommand =  New ResizeCanvasCommand(NewSize,New Point(39,39),Color.White)
Dim result As AtalaImage =  cmd.Apply(image).Image

image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Constructor

Overload List
 | Name | Description
Public method | ResizeCanvasCommand | Creates a new instance of ResizeCanvasCommand.
Protected method | ResizeCanvasCommand(SerializationInfo, StreamingContext) | Creates a new instance of ResizeCanvasCommand from serialization information
Public method | ResizeCanvasCommand(Size, Point, Color) | Creates a new instance of ResizeCanvasCommand specifying canvasSize, position, canvasColor, and canvasPaletteIndex.
Public method | ResizeCanvasCommand(Size, Point, Int32) | Creates a new instance of ResizeCanvasCommand specifying canvasSize, position, canvasColor, and canvasPaletteIndex.
Top
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Constructor

Creates a new instance of ResizeCanvasCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResizeCanvasCommand()
Public Sub New
See Also

Reference

ResizeCanvasCommand Class
ResizeCanvasCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ResizeCanvasCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ResizeCanvasCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ResizeCanvasCommand Class
ResizeCanvasCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Constructor (Size, Point, Color)

Creates a new instance of ResizeCanvasCommand specifying canvasSize, position, canvasColor, and canvasPaletteIndex.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResizeCanvasCommand(
    Size canvasSize,
    Point position,
    Color canvasColor
)
Public Sub New (
    canvasSize As Size,
    position As Point,
    canvasColor As Color
)

Parameters

canvasSize
Type: System.DrawingSize
The size of the new canvas.
position
Type: System.DrawingPoint
The position of the image on the new canvas.
canvasColor
Type: System.DrawingColor
The background color of the canvas
Exceptions
Exception | Condition
 | Thrown if either the canvasSize height or width is less than or equal to 0.
See Also

Reference

ResizeCanvasCommand Class
ResizeCanvasCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Constructor (Size, Point, Int32)

Creates a new instance of ResizeCanvasCommand specifying canvasSize, position, canvasColor, and canvasPaletteIndex.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResizeCanvasCommand(
    Size canvasSize,
    Point position,
    int canvasPaletteIndex
)
Public Sub New (
    canvasSize As Size,
    position As Point,
    canvasPaletteIndex As Integer
)

Parameters

canvasSize
Type: System.DrawingSize
The size of the new canvas.
position
Type: System.DrawingPoint
The position of the image on the new canvas.
canvasPaletteIndex
Type: SystemInt32
The palette index of the canvas
Exceptions
Exception | Condition
 | Thrown if either the canvasSize height or width is less than or equal to 0.
See Also

Reference

ResizeCanvasCommand Class
ResizeCanvasCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Properties

The ResizeCanvasCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | CanvasColor | Gets or sets the background color of the canvas.
Public property | CanvasPaletteIndex | Gets or sets the palette index of the canvas.
Public property | CanvasSize | Gets or sets the size of the new canvas.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Position | Gets or sets the position of the image on the new canvas.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.CanvasColor Property

ResizeCanvasCommandCanvasColor Property

Gets or sets the background color of the canvas.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color CanvasColor { get; set; }
Public Property CanvasColor As Color
    Get
    Set

Property Value

Type: Color
The background color of the canvas.
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.CanvasPaletteIndex Property

ResizeCanvasCommandCanvasPaletteIndex Property

Gets or sets the palette index of the canvas.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CanvasPaletteIndex { get; set; }
Public Property CanvasPaletteIndex As Integer
    Get
    Set

Property Value

Type: Int32
The palette index of the canvas.
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.CanvasSize Property

ResizeCanvasCommandCanvasSize Property

Gets or sets the size of the new canvas.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size CanvasSize { get; set; }
Public Property CanvasSize As Size
    Get
    Set

Property Value

Type: Size
The size of the new canvas.
Exceptions
Exception | Condition
 | Thrown if either the height or width is less than or equal to 0.
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.Position Property

ResizeCanvasCommandPosition Property

Gets or sets the position of the image on the new canvas.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point
The position of the image on the new canvas.
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.SupportedPixelFormats Property

ResizeCanvasCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand Methods

The ResizeCanvasCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.ConstructFinalImage Method

ResizeCanvasCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Exceptions
Exception | Condition
InternalErrorException | Failure to allocate dest image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.GetObjectData Method

ResizeCanvasCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.PerformActualCommand Method

ResizeCanvasCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.SelectPreferredPixelFormat Method

ResizeCanvasCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ResizeCanvasCommand.VerifyProperties Method

ResizeCanvasCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

ResizeCanvasCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Class

Creates a water ripple effect on the image.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsRippleTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RippleTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class RippleTransform
    Inherits Transform
    Implements ISerializable

The RippleTransform type exposes the following members.

Constructors
 | Name | Description
Public method | RippleTransform | Creates a new instance of RippleTransform.
Protected method | RippleTransform(SerializationInfo, StreamingContext) | Creates a new instance of RippleTransform from serialization information
Public method | RippleTransform(Double, Double, Double, Point, RippleTransformMode) | Creates a new instance of RippleTransform specifying maxRadius, intensity, periods, offset and mode.
Public method | RippleTransform(Double, Double, Double, Point, RippleTransformMode, InterpolationMode) | Creates a new instance of RippleTransform specifying maxRadius, intensity, periods, offset, mode and transformMode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets the amount of intensity.
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Mode | Gets or sets the RippleTransformMode to use.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Periods | Gets or sets the number of periods in the distance wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


RippleTransform Constructor

Overload List
 | Name | Description
Public method | RippleTransform | Creates a new instance of RippleTransform.
Protected method | RippleTransform(SerializationInfo, StreamingContext) | Creates a new instance of RippleTransform from serialization information
Public method | RippleTransform(Double, Double, Double, Point, RippleTransformMode) | Creates a new instance of RippleTransform specifying maxRadius, intensity, periods, offset and mode.
Public method | RippleTransform(Double, Double, Double, Point, RippleTransformMode, InterpolationMode) | Creates a new instance of RippleTransform specifying maxRadius, intensity, periods, offset, mode and transformMode.
Top
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Constructor

Creates a new instance of RippleTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RippleTransform()
Public Sub New
See Also

Reference

RippleTransform Class
RippleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RippleTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RippleTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

RippleTransform Class
RippleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Constructor (Double, Double, Double, Point, RippleTransformMode)

Creates a new instance of RippleTransform specifying maxRadius, intensity, periods, offset and mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RippleTransform(
    double maxRadius,
    double intensity,
    double periods,
    Point offset,
    RippleTransformMode mode
)
Public Sub New (
    maxRadius As Double,
    intensity As Double,
    periods As Double,
    offset As Point,
    mode As RippleTransformMode
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
intensity
Type: SystemDouble
Amount of intensity. (1 = no effect)
periods
Type: SystemDouble
Number of periods in the distance wave.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsRippleTransformMode
The RippleTransformMode to use.
Exceptions
Exception | Condition
 | Thrown if the maxRadius, intensity or periods are less than 0.
See Also

Reference

RippleTransform Class
RippleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Constructor (Double, Double, Double, Point, RippleTransformMode, InterpolationMode)

Creates a new instance of RippleTransform specifying maxRadius, intensity, periods, offset, mode and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RippleTransform(
    double maxRadius,
    double intensity,
    double periods,
    Point offset,
    RippleTransformMode mode,
    InterpolationMode transformMode
)
Public Sub New (
    maxRadius As Double,
    intensity As Double,
    periods As Double,
    offset As Point,
    mode As RippleTransformMode,
    transformMode As InterpolationMode
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
intensity
Type: SystemDouble
Amount of intensity. (1 = no effect)
periods
Type: SystemDouble
Number of periods in the distance wave.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsRippleTransformMode
The RippleTransformMode to use.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
Exceptions
Exception | Condition
 | Thrown if the maxRadius, intensity or periods are less than 0.
See Also

Reference

RippleTransform Class
RippleTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Properties

The RippleTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Intensity | Gets or sets the amount of intensity.
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Mode | Gets or sets the RippleTransformMode to use.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Periods | Gets or sets the number of periods in the distance wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.Intensity Property

RippleTransformIntensity Property

Gets or sets the amount of intensity.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
Amount of intensity. (1 = no effect)
Exceptions
Exception | Condition
 | Thrown if the value is less than 0.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.MaxRadius Property

RippleTransformMaxRadius Property

Gets or sets the maximum distance from the center for this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxRadius { get; set; }
Public Property MaxRadius As Double
    Get
    Set

Property Value

Type: Double
Maximum distance from the center for this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.Mode Property

RippleTransformMode Property

Gets or sets the RippleTransformMode to use.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RippleTransformMode Mode { get; set; }
Public Property Mode As RippleTransformMode
    Get
    Set

Property Value

Type: RippleTransformMode
The RippleTransformMode to use.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.Offset Property

RippleTransformOffset Property

Gets or set the offset position from the center of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The offset position from the center of the image.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.Periods Property

RippleTransformPeriods Property

Gets or sets the number of periods in the distance wave.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Periods { get; set; }
Public Property Periods As Double
    Get
    Set

Property Value

Type: Double
Number of periods in the distance wave.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.TransformMode Property

RippleTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform Methods

The RippleTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.AddToChain Method

RippleTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.GetObjectData Method

RippleTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransform.PerformActualCommand Method

RippleTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

RippleTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RippleTransformMode Enumeration

Enumeration used by RippleTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RippleTransformMode
Public Enumeration RippleTransformMode
Members
Member name | Description
Full | Waves remain at full intensity.
Linear | Waves diminish linearly with their distance from center.
Square | Waves diminish with the square of their distance.
Sine | Waves diminish with the sine of their distance (inverse!).
Cosine | Waves diminish with the cosine of their distance.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Class

This will rotate an image clockwise by the specified number of degrees.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsRotateCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class RotateCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class RotateCommand
    Inherits ImageCommand
    Implements ISerializable

The RotateCommand type exposes the following members.

Constructors
 | Name | Description
Public method | RotateCommand | Creates a new instance of RotateCommand.
Public method | RotateCommand(Double) | Creates a new instance of RotateCommand specifying the angle.
Public method | RotateCommand(Double, InterpolationMode) | Creates a new instance of RotateCommand specifying angle, and interpolation.
Public method | RotateCommand(Double, Color) | Creates a new instance of RotateCommand specifying angle and backgroundColor.
Protected method | RotateCommand(SerializationInfo, StreamingContext) | Creates a new instance of RotateCommand from serialization information
Public method | RotateCommand(Double, InterpolationMode, Color) | Creates a new instance of RotateCommand specifying angle, interpolation, and backgroundColor.
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of rotation in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundColor | Gets or sets the color of the background when angle is not a multiple of 90 degrees.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Interpolation | Gets or sets the InterpolationMode of this command.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks

This command will work with all PixelFormat except Pixel4bppIndexed. If a Pixel4bppIndexed image is passed to this command, it will attempt to convert the image to Pixel8bppIndexed image before rotating it.

Rotating images in 90 degree increments uses a very fast rotate algorithm.

See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


RotateCommand Constructor

Overload List
 | Name | Description
Public method | RotateCommand | Creates a new instance of RotateCommand.
Public method | RotateCommand(Double) | Creates a new instance of RotateCommand specifying the angle.
Public method | RotateCommand(Double, InterpolationMode) | Creates a new instance of RotateCommand specifying angle, and interpolation.
Public method | RotateCommand(Double, Color) | Creates a new instance of RotateCommand specifying angle and backgroundColor.
Protected method | RotateCommand(SerializationInfo, StreamingContext) | Creates a new instance of RotateCommand from serialization information
Public method | RotateCommand(Double, InterpolationMode, Color) | Creates a new instance of RotateCommand specifying angle, interpolation, and backgroundColor.
Top
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Constructor

Creates a new instance of RotateCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateCommand()
Public Sub New
See Also

Reference

RotateCommand Class
RotateCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Constructor (Double)

Creates a new instance of RotateCommand specifying the angle.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateCommand(
    double angle
)
Public Sub New (
    angle As Double
)

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees.
See Also

Reference

RotateCommand Class
RotateCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Constructor (Double, InterpolationMode)

Creates a new instance of RotateCommand specifying angle, and interpolation.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateCommand(
    double angle,
    InterpolationMode interpolation
)
Public Sub New (
    angle As Double,
    interpolation As InterpolationMode
)

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees.
interpolation
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The interpolation used for rotation.
See Also

Reference

RotateCommand Class
RotateCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Constructor (Double, Color)

Creates a new instance of RotateCommand specifying angle and backgroundColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateCommand(
    double angle,
    Color backgroundColor
)
Public Sub New (
    angle As Double,
    backgroundColor As Color
)

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees.
backgroundColor
Type: System.DrawingColor
The color of the background when angle is not a multiple of 90 degrees.
See Also

Reference

RotateCommand Class
RotateCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of RotateCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RotateCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
Creates a new instance of the RotateCommand object.
See Also

Reference

RotateCommand Class
RotateCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Constructor (Double, InterpolationMode, Color)

Creates a new instance of RotateCommand specifying angle, interpolation, and backgroundColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RotateCommand(
    double angle,
    InterpolationMode interpolation,
    Color backgroundColor
)
Public Sub New (
    angle As Double,
    interpolation As InterpolationMode,
    backgroundColor As Color
)

Parameters

angle
Type: SystemDouble
The angle of rotation in degrees.
interpolation
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The interpolation used for rotation.
backgroundColor
Type: System.DrawingColor
The color of the background when angle is not a multiple of 90 degrees.
See Also

Reference

RotateCommand Class
RotateCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Properties

The RotateCommand type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle of rotation in degrees.
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackgroundColor | Gets or sets the color of the background when angle is not a multiple of 90 degrees.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Interpolation | Gets or sets the InterpolationMode of this command.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.Angle Property

RotateCommandAngle Property

Gets or sets the angle of rotation in degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle of rotation in degrees.
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.BackgroundColor Property

RotateCommandBackgroundColor Property

Gets or sets the color of the background when angle is not a multiple of 90 degrees.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The color of the background when angle is not a multiple of 90 degrees.
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.Interpolation Property

RotateCommandInterpolation Property

Gets or sets the InterpolationMode of this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode Interpolation { get; set; }
Public Property Interpolation As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode used for rotation.
Remarks

1-bit images accept a value of None for fast rotation, and BiLinear or BiCubic for good but slower rotation.

See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.SupportedPixelFormats Property

RotateCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscale,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk,,PixelFormat.Pixel48bppBgr,,PixelFormat.Pixel64bppBgra
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand Methods

The RotateCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.ConstructFinalImage Method

RotateCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.GetObjectData Method

RotateCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.PerformActualCommand Method

RotateCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
Exceptions
Exception | Condition
IncompatiblePixelFormatException | Can't rotate two byte per pixel images in arbitrary increments.
See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.SelectPreferredPixelFormat Method

RotateCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


RotateCommand.VerifyProperties Method

RotateCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Exceptions
Exception | Condition
NotImplementedException | Two byte per component images are limited to 90, 180 and 270 degree rotations.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

RotateCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Class

Using this command you can shift the top, bottom, left or right side of an image independently.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsSkewCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SkewCommand : ImageCommand,
    ISerializable
<SerializableAttribute>
Public Class SkewCommand
    Inherits ImageCommand
    Implements ISerializable

The SkewCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SkewCommand | Creates a new instance of SkewCommand.
Protected method | SkewCommand(SerializationInfo, StreamingContext) | Creates a new instance of SkewCommand from serialization information
Public method | SkewCommand(SkewDirection, Int32) | Creates a new instance of SkewCommand specifying direction and offset.
Public method | SkewCommand(SkewDirection, Int32, Color) | Creates a new instance of SkewCommand specifying direction, offset and backColor.
Public method | SkewCommand(SkewDirection, Int32, Color, Boolean) | Creates a new instance of SkewCommand specifying direction, offset, backColor, and fastSkew.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets a color to used in newly exposed areas.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Direction | Gets or sets a value to determine whether the skew is horizontal or vertical.
Public property | FastSkew | Gets or sets a value indicating if speed is more important then quality.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or sets the number of pixels to skew.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This command does not work with Pixel1bppIndexed or Pixel4bppIndexedPixelFormat. If an image with one of these formats is passed into this command, it will attempt to convert it to Pixel8bppGrayscale or Pixel8bppIndexed respectively.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


SkewCommand Constructor

Overload List
 | Name | Description
Public method | SkewCommand | Creates a new instance of SkewCommand.
Protected method | SkewCommand(SerializationInfo, StreamingContext) | Creates a new instance of SkewCommand from serialization information
Public method | SkewCommand(SkewDirection, Int32) | Creates a new instance of SkewCommand specifying direction and offset.
Public method | SkewCommand(SkewDirection, Int32, Color) | Creates a new instance of SkewCommand specifying direction, offset and backColor.
Public method | SkewCommand(SkewDirection, Int32, Color, Boolean) | Creates a new instance of SkewCommand specifying direction, offset, backColor, and fastSkew.
Top
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Constructor

Creates a new instance of SkewCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SkewCommand()
Public Sub New
See Also

Reference

SkewCommand Class
SkewCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SkewCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SkewCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

SkewCommand Class
SkewCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Constructor (SkewDirection, Int32)

Creates a new instance of SkewCommand specifying direction and offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SkewCommand(
    SkewDirection direction,
    int offset
)
Public Sub New (
    direction As SkewDirection,
    offset As Integer
)

Parameters

direction
Type: Atalasoft.Imaging.ImageProcessing.TransformsSkewDirection
Determines whether the skew is horizontal or vertical.
offset
Type: SystemInt32
The number of pixels to skew.
See Also

Reference

SkewCommand Class
SkewCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Constructor (SkewDirection, Int32, Color)

Creates a new instance of SkewCommand specifying direction, offset and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SkewCommand(
    SkewDirection direction,
    int offset,
    Color backColor
)
Public Sub New (
    direction As SkewDirection,
    offset As Integer,
    backColor As Color
)

Parameters

direction
Type: Atalasoft.Imaging.ImageProcessing.TransformsSkewDirection
Determines whether the skew is horizontal or vertical.
offset
Type: SystemInt32
The number of pixels to skew.
backColor
Type: System.DrawingColor
A color to used in newly exposed areas.
See Also

Reference

SkewCommand Class
SkewCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Constructor (SkewDirection, Int32, Color, Boolean)

Creates a new instance of SkewCommand specifying direction, offset, backColor, and fastSkew.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SkewCommand(
    SkewDirection direction,
    int offset,
    Color backColor,
    bool fastSkew
)
Public Sub New (
    direction As SkewDirection,
    offset As Integer,
    backColor As Color,
    fastSkew As Boolean
)

Parameters

direction
Type: Atalasoft.Imaging.ImageProcessing.TransformsSkewDirection
Determines whether the skew is horizontal or vertical.
offset
Type: SystemInt32
The number of pixels to skew.
backColor
Type: System.DrawingColor
A color to used in newly exposed areas.
fastSkew
Type: SystemBoolean
Provides a faster but less accurate skew.
See Also

Reference

SkewCommand Class
SkewCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Properties

The SkewCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets a color to used in newly exposed areas.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Direction | Gets or sets a value to determine whether the skew is horizontal or vertical.
Public property | FastSkew | Gets or sets a value indicating if speed is more important then quality.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Offset | Gets or sets the number of pixels to skew.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.BackColor Property

SkewCommandBackColor Property

Gets or sets a color to used in newly exposed areas.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
A color to used in newly exposed areas.
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.Direction Property

SkewCommandDirection Property

Gets or sets a value to determine whether the skew is horizontal or vertical.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SkewDirection Direction { get; set; }
Public Property Direction As SkewDirection
    Get
    Set

Property Value

Type: SkewDirection
Determines whether the skew is horizontal or vertical.
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.FastSkew Property

SkewCommandFastSkew Property

Gets or sets a value indicating if speed is more important then quality.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FastSkew { get; set; }
Public Property FastSkew As Boolean
    Get
    Set

Property Value

Type: Boolean
Provides a faster but less accurate skew.
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.Offset Property

SkewCommandOffset Property

Gets or sets the number of pixels to skew.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The number of pixels to skew.
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.SupportedPixelFormats Property

SkewCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand Methods

The SkewCommand type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Overrides ImageCommandConstructFinalImage(AtalaImage).)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.ConstructFinalImage Method

SkewCommandConstructFinalImage Method

Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage ConstructFinalImage(
    AtalaImage image
)
Protected Overrides Function ConstructFinalImage (
    image As AtalaImage
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image being processed. This may be different from the source image passed into Apply.

Return Value

Type: AtalaImage
A new image for the result of the command, or null if it is not possible or necessary to make a destination image.
Remarks

The default implementation returns a new image in the same pixel format as the source image.

The returned image must be the same size as the image passed in.

If it is not possible to allocate the image (for example, the pixel format is not know at this point), it is acceptable to return null. Returning null implies that the command will return a non-null image in PerformActualCommand.

If an error occurs, this method should throw an exception.

See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.GetObjectData Method

SkewCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.PerformActualCommand Method

SkewCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.SelectPreferredPixelFormat Method

SkewCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewCommand.VerifyProperties Method

SkewCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

SkewCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SkewDirection Enumeration

Enumeration used by SkewCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SkewDirection
Public Enumeration SkewDirection
Members
Member name | Description
Horizontal | Makes the image skew on the top or bottom.
Vertical | Makes the image skew on the left or right.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Class

This transform will rotate the image about the center with a constant angular distance.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsSpinTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SpinTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class SpinTransform
    Inherits Transform
    Implements ISerializable

The SpinTransform type exposes the following members.

Constructors
 | Name | Description
Public method | SpinTransform | Creates a new instance of SpinTransform.
Protected method | SpinTransform(SerializationInfo, StreamingContext) | Creates a new instance of SpinTransform from serialization information
Public method | SpinTransform(Double, Double, Point, Color) | Creates a new instance of SpinTransform specifying maxRadius, maxAngleOffset, offset and backColor.
Public method | SpinTransform(Double, Double, Point, Color, InterpolationMode) | Creates a new instance of SpinTransform specifying maxRadius, maxAngleOffset, offset, backColor and transformMode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxAngleOffset | Gets or sets the angular distance to spin pixels. (degrees)
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


SpinTransform Constructor

Overload List
 | Name | Description
Public method | SpinTransform | Creates a new instance of SpinTransform.
Protected method | SpinTransform(SerializationInfo, StreamingContext) | Creates a new instance of SpinTransform from serialization information
Public method | SpinTransform(Double, Double, Point, Color) | Creates a new instance of SpinTransform specifying maxRadius, maxAngleOffset, offset and backColor.
Public method | SpinTransform(Double, Double, Point, Color, InterpolationMode) | Creates a new instance of SpinTransform specifying maxRadius, maxAngleOffset, offset, backColor and transformMode.
Top
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Constructor

Creates a new instance of SpinTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinTransform()
Public Sub New
See Also

Reference

SpinTransform Class
SpinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SpinTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SpinTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

SpinTransform Class
SpinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Constructor (Double, Double, Point, Color)

Creates a new instance of SpinTransform specifying maxRadius, maxAngleOffset, offset and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinTransform(
    double maxRadius,
    double maxAngleOffset,
    Point offset,
    Color backColor
)
Public Sub New (
    maxRadius As Double,
    maxAngleOffset As Double,
    offset As Point,
    backColor As Color
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
maxAngleOffset
Type: SystemDouble
Angular distance to spin pixels. (degrees)
offset
Type: System.DrawingPoint
The offset position from the center of the image.
backColor
Type: System.DrawingColor
The background color to use for newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if the maxRadius or maxAngleOffset is less than 0.
See Also

Reference

SpinTransform Class
SpinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Constructor (Double, Double, Point, Color, InterpolationMode)

Creates a new instance of SpinTransform specifying maxRadius, maxAngleOffset, offset, backColor and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinTransform(
    double maxRadius,
    double maxAngleOffset,
    Point offset,
    Color backColor,
    InterpolationMode transformMode
)
Public Sub New (
    maxRadius As Double,
    maxAngleOffset As Double,
    offset As Point,
    backColor As Color,
    transformMode As InterpolationMode
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
maxAngleOffset
Type: SystemDouble
Angular distance to spin pixels. (degrees)
offset
Type: System.DrawingPoint
The offset position from the center of the image.
backColor
Type: System.DrawingColor
The background color to use for newly uncovered areas of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
Exceptions
Exception | Condition
 | Thrown if the maxRadius or maxAngleOffset is less than 0.
See Also

Reference

SpinTransform Class
SpinTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Properties

The SpinTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use for newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxAngleOffset | Gets or sets the angular distance to spin pixels. (degrees)
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.BackColor Property

SpinTransformBackColor Property

Gets or sets the background color to use for newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use for newly uncovered areas of the image.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.MaxAngleOffset Property

SpinTransformMaxAngleOffset Property

Gets or sets the angular distance to spin pixels. (degrees)

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxAngleOffset { get; set; }
Public Property MaxAngleOffset As Double
    Get
    Set

Property Value

Type: Double
Angular distance to spin pixels. (degrees)
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.MaxRadius Property

SpinTransformMaxRadius Property

Gets or sets the maximum distance from the center for this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxRadius { get; set; }
Public Property MaxRadius As Double
    Get
    Set

Property Value

Type: Double
Maximum distance from the center for this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
Remarks
Pixels outside of this radius will not be affected.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.Offset Property

SpinTransformOffset Property

Gets or set the offset position from the center of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The offset position from the center of the image.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.TransformMode Property

SpinTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform Methods

The SpinTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.AddToChain Method

SpinTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.GetObjectData Method

SpinTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinTransform.PerformActualCommand Method

SpinTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SpinTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Class

A SpinWaveTransform rotates the image about the center with a variable angular distance. The distance varies in a sine wave pattern.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsSpinWaveTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SpinWaveTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class SpinWaveTransform
    Inherits Transform
    Implements ISerializable

The SpinWaveTransform type exposes the following members.

Constructors
 | Name | Description
Public method | SpinWaveTransform | Creates a new instance of SpinWaveTransform.
Protected method | SpinWaveTransform(SerializationInfo, StreamingContext) | Creates a new instance of SpinWaveTransform from serialization information
Public method | SpinWaveTransform(Double, Double, Double, Point) | Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods and offset.
Public method | SpinWaveTransform(Double, Double, Double, Point, InterpolationMode) | Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods, offset and transformMode.
Public method | SpinWaveTransform(Double, Double, Double, Point, InterpolationMode, Color) | Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods, offset, transformMode and backColor.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color of newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxAngleOffset | Gets or sets the angular distance to spin pixels (degrees).
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Periods | Gets or sets the number of periods in the distance wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


SpinWaveTransform Constructor

Overload List
 | Name | Description
Public method | SpinWaveTransform | Creates a new instance of SpinWaveTransform.
Protected method | SpinWaveTransform(SerializationInfo, StreamingContext) | Creates a new instance of SpinWaveTransform from serialization information
Public method | SpinWaveTransform(Double, Double, Double, Point) | Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods and offset.
Public method | SpinWaveTransform(Double, Double, Double, Point, InterpolationMode) | Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods, offset and transformMode.
Public method | SpinWaveTransform(Double, Double, Double, Point, InterpolationMode, Color) | Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods, offset, transformMode and backColor.
Top
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Constructor

Creates a new instance of SpinWaveTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinWaveTransform()
Public Sub New
See Also

Reference

SpinWaveTransform Class
SpinWaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of SpinWaveTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected SpinWaveTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
Creates a new instance of the SpinWaveTransform object.
See Also

Reference

SpinWaveTransform Class
SpinWaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Constructor (Double, Double, Double, Point)

Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods and offset.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinWaveTransform(
    double maxRadius,
    double maxAngleOffset,
    double periods,
    Point offset
)
Public Sub New (
    maxRadius As Double,
    maxAngleOffset As Double,
    periods As Double,
    offset As Point
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
maxAngleOffset
Type: SystemDouble
Angular distance to spin pixels (degrees).
periods
Type: SystemDouble
Number of periods in the distance wave.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
Exceptions
Exception | Condition
 | Thrown if the maxRadius, maxAngleOffset or periods is less than 0.
See Also

Reference

SpinWaveTransform Class
SpinWaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Constructor (Double, Double, Double, Point, InterpolationMode)

Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods, offset and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinWaveTransform(
    double maxRadius,
    double maxAngleOffset,
    double periods,
    Point offset,
    InterpolationMode transformMode
)
Public Sub New (
    maxRadius As Double,
    maxAngleOffset As Double,
    periods As Double,
    offset As Point,
    transformMode As InterpolationMode
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
maxAngleOffset
Type: SystemDouble
Angular distance to spin pixels (degrees).
periods
Type: SystemDouble
Number of periods in the distance wave.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
Exceptions
Exception | Condition
 | Thrown if the maxRadius, maxAngleOffset or periods is less than 0.
See Also

Reference

SpinWaveTransform Class
SpinWaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Constructor (Double, Double, Double, Point, InterpolationMode, Color)

Creates a new instance of SpinWaveTransform specifying maxRadius, maxAngleOffset, periods, offset, transformMode and backColor.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SpinWaveTransform(
    double maxRadius,
    double maxAngleOffset,
    double periods,
    Point offset,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    maxRadius As Double,
    maxAngleOffset As Double,
    periods As Double,
    offset As Point,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
maxAngleOffset
Type: SystemDouble
Angular distance to spin pixels (degrees).
periods
Type: SystemDouble
Number of periods in the distance wave.
offset
Type: System.DrawingPoint
The offset position from the center of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The InterpolationMode of this transform.
backColor
Type: System.DrawingColor
The background color of newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if the maxRadius, maxAngleOffset or periods is less than 0.
See Also

Reference

SpinWaveTransform Class
SpinWaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Properties

The SpinWaveTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color of newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxAngleOffset | Gets or sets the angular distance to spin pixels (degrees).
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Offset | Gets or set the offset position from the center of the image.
Public property | Periods | Gets or sets the number of periods in the distance wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.BackColor Property

SpinWaveTransformBackColor Property

Gets or sets the background color of newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color of newly uncovered areas of the image.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.MaxAngleOffset Property

SpinWaveTransformMaxAngleOffset Property

Gets or sets the angular distance to spin pixels (degrees).

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxAngleOffset { get; set; }
Public Property MaxAngleOffset As Double
    Get
    Set

Property Value

Type: Double
Angular distance to spin pixels (degrees).
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.MaxRadius Property

SpinWaveTransformMaxRadius Property

Gets or sets the maximum distance from the center for this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxRadius { get; set; }
Public Property MaxRadius As Double
    Get
    Set

Property Value

Type: Double
Maximum distance from the center for this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.Offset Property

SpinWaveTransformOffset Property

Gets or set the offset position from the center of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Offset { get; set; }
Public Property Offset As Point
    Get
    Set

Property Value

Type: Point
The offset position from the center of the image.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.Periods Property

SpinWaveTransformPeriods Property

Gets or sets the number of periods in the distance wave.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Periods { get; set; }
Public Property Periods As Double
    Get
    Set

Property Value

Type: Double
Number of periods in the distance wave.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.TransformMode Property

SpinWaveTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform Methods

The SpinWaveTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.AddToChain Method

SpinWaveTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to be processed.
height
Type: SystemInt32
The height of the image to be processed.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.GetObjectData Method

SpinWaveTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


SpinWaveTransform.PerformActualCommand Method

SpinWaveTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

SpinWaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform Class

A base class that is used for transforms.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
More...

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class Transform : ImageCommand
Public MustInherit Class Transform
    Inherits ImageCommand

The Transform type exposes the following members.

Constructors
 | Name | Description
Protected method | Transform | Initializes a new instance of the Transform class.
Protected method | Transform(SerializationInfo, StreamingContext) | Initializes a new instance of the Transform class.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from ImageCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image.
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
A transform uses an algorithm to translate pixels from one position to another. Transforms can be chained together such that they can all be applied at once to the same image in one pass.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsBumpMapTransform
Atalasoft.Imaging.ImageProcessing.TransformsEllipticalTransform
Atalasoft.Imaging.ImageProcessing.TransformsLensTransform
Atalasoft.Imaging.ImageProcessing.TransformsLineSliceTransform
Atalasoft.Imaging.ImageProcessing.TransformsMarbleTransform
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform
Atalasoft.Imaging.ImageProcessing.TransformsPerlinTransform
Atalasoft.Imaging.ImageProcessing.TransformsPinchTransform
Atalasoft.Imaging.ImageProcessing.TransformsPolygonTransform
Atalasoft.Imaging.ImageProcessing.TransformsRandomTransform
Atalasoft.Imaging.ImageProcessing.TransformsRippleTransform
Atalasoft.Imaging.ImageProcessing.TransformsSpinTransform
Atalasoft.Imaging.ImageProcessing.TransformsSpinWaveTransform
Atalasoft.Imaging.ImageProcessing.TransformsUserTransform
Atalasoft.Imaging.ImageProcessing.TransformsWaveTransform
Atalasoft.Imaging.ImageProcessing.TransformsWowTransform
Atalasoft.Imaging.ImageProcessing.TransformsZigZagTransform


Transform Constructor

Overload List
 | Name | Description
Protected method | Transform | Initializes a new instance of the Transform class.
Protected method | Transform(SerializationInfo, StreamingContext) | Initializes a new instance of the Transform class.
Top
See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform Constructor

Initializes a new instance of the Transform class.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Transform()
Protected Sub New
See Also

Reference

Transform Class
Transform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Transform class.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Transform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

Transform Class
Transform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform Properties

The Transform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Top
See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform.SupportedPixelFormats Property

TransformSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform Methods

The Transform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Inherited from ImageCommand.)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image.
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform.AddToChain Method

TransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddToChain(
    int width,
    int height
)
Public MustOverride Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform.SelectCompatibleBackgroundColor Method

TransformSelectCompatibleBackgroundColor Method

Returns a color value compatible with the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Color SelectCompatibleBackgroundColor(
    AtalaImage image,
    Color sourceColor
)
Protected Function SelectCompatibleBackgroundColor (
    image As AtalaImage,
    sourceColor As Color
) As Color

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to get a color for.
sourceColor
Type: System.DrawingColor
The requested color.

Return Value

Type: Color
A color compatible with the image provided.
Remarks
This method will return a grayscale color if the image is grayscale or a CMYK color if the image format is CMYK.
See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform.SelectPreferredPixelFormat Method

TransformSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Transform.VerifyProperties Method

TransformVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

Transform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Class

This command allows you to combine multiple transforms into a single command call.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransformChainCommand

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TransformChainCommand : ImageCommand,
    ICollection, IEnumerable, ISerializable
<SerializableAttribute>
Public Class TransformChainCommand
    Inherits ImageCommand
    Implements ICollection, IEnumerable, ISerializable

The TransformChainCommand type exposes the following members.

Constructors
 | Name | Description
Public method | TransformChainCommand | Creates a new instance of TransformChainCommand.
Public method | TransformChainCommand(Color) | Creates a new instance of TransformChainCommand specifying the background color of the resulting image.
Public method | TransformChainCommand(Transform) | Creates a new instance of TransformChainCommand specifying the transforms.
Public method | TransformChainCommand(Color, InterpolationMode) | Creates a new instance of TransformChainCommand specifying the background color and transform mode.
Protected method | TransformChainCommand(SerializationInfo, StreamingContext) | Creates a new instance of TransformChainCommand from serialization information
Public method | TransformChainCommand(Color, InterpolationMode, Transform) | Creates a new instance of TransformChainCommand specifying the background color, transform mode and a collection of transforms to apply.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use on newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Count | Returns the number of transforms in the collection.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | IsSynchronized | Gets a value indicating whether access to the transforms collection is synchronized.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the transforms collection.
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | Add | Adds a transform to the collection.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clear | Removes all of the transforms from the collection.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | CopyTo(Array, Int32) | Copies transforms from the internal collection to an array.
Public method | CopyTo(Transform, Int32) | Copies transforms from the internal collection to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetEnumerator | This allows the use of foreach statements on the transforms collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
Examples
Using TransformChain (C#)
Copy
// Load a 24-bit image.
AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

// Create the TransformChainCommand and add a couple transforms to it.
TransformChainCommand cmd = new TransformChainCommand();
cmd.Add(new MarbleTransform(0.4, new Size(10, 10)));
cmd.Add(new LensTransform(100, Point.Empty));

// Apply the transform.
AtalaImage result = cmd.Apply(image).Image;
image.Dispose();
Using TransformChain (Visual Basic)
Copy
' Load a 24-bit image.
Dim image As AtalaImage =  New AtalaImage("D:\Test Images\1.jpg")

' Create the TransformChainCommand and add a couple transforms to it.
Dim cmd As TransformChainCommand =  New TransformChainCommand()
cmd.Add(New MarbleTransform(0.4, New Size(10, 10)))
cmd.Add(New LensTransform(100,PoInteger.Empty))

' Apply the transform.
Dim result As AtalaImage =  cmd.Apply(image).Image
image.Dispose()
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor

Overload List
 | Name | Description
Public method | TransformChainCommand | Creates a new instance of TransformChainCommand.
Public method | TransformChainCommand(Color) | Creates a new instance of TransformChainCommand specifying the background color of the resulting image.
Public method | TransformChainCommand(Transform) | Creates a new instance of TransformChainCommand specifying the transforms.
Public method | TransformChainCommand(Color, InterpolationMode) | Creates a new instance of TransformChainCommand specifying the background color and transform mode.
Protected method | TransformChainCommand(SerializationInfo, StreamingContext) | Creates a new instance of TransformChainCommand from serialization information
Public method | TransformChainCommand(Color, InterpolationMode, Transform) | Creates a new instance of TransformChainCommand specifying the background color, transform mode and a collection of transforms to apply.
Top
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor

Creates a new instance of TransformChainCommand.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TransformChainCommand()
Public Sub New
See Also

Reference

TransformChainCommand Class
TransformChainCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor (Color)

Creates a new instance of TransformChainCommand specifying the background color of the resulting image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TransformChainCommand(
    Color backColor
)
Public Sub New (
    backColor As Color
)

Parameters

backColor
Type: System.DrawingColor
The background color to used for newly uncovered areas of the image.
Remarks
Creates a new instance of TransformChainCommand specifying the backColor.
See Also

Reference

TransformChainCommand Class
TransformChainCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor (Transform[])

TransformChainCommand Constructor (Transform)

Creates a new instance of TransformChainCommand specifying the transforms.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TransformChainCommand(
    params Transform[] transforms
)
Public Sub New (
    ParamArray transforms As Transform()
)

Parameters

transforms
Type: Atalasoft.Imaging.ImageProcessing.TransformsTransform
The transforms to add to this command.
See Also

Reference

TransformChainCommand Class
TransformChainCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor (Color, InterpolationMode)

Creates a new instance of TransformChainCommand specifying the background color and transform mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TransformChainCommand(
    Color backColor,
    InterpolationMode transformMode
)
Public Sub New (
    backColor As Color,
    transformMode As InterpolationMode
)

Parameters

backColor
Type: System.DrawingColor
The background color to used for newly uncovered areas of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The interpolation mode to use for this transform.
Remarks
Creates a new instance of the TransformChainCommand specifying backColor and transformMode.
See Also

Reference

TransformChainCommand Class
TransformChainCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor (SerializationInfo, StreamingContext)

Creates a new instance of TransformChainCommand from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected TransformChainCommand(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
You must add a least one transform to the collection before using this command.
See Also

Reference

TransformChainCommand Class
TransformChainCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Constructor (Color, InterpolationMode, Transform[])

TransformChainCommand Constructor (Color, InterpolationMode, Transform)

Creates a new instance of TransformChainCommand specifying the background color, transform mode and a collection of transforms to apply.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TransformChainCommand(
    Color backColor,
    InterpolationMode transformMode,
    params Transform[] transforms
)
Public Sub New (
    backColor As Color,
    transformMode As InterpolationMode,
    ParamArray transforms As Transform()
)

Parameters

backColor
Type: System.DrawingColor
The background color to used for newly uncovered areas of the image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
The interpolation mode to use for this transform.
transforms
Type: Atalasoft.Imaging.ImageProcessing.TransformsTransform
The transforms to add to this command.
Remarks
Creates a new instance of the TransformChainCommand specifying backColor, transformMode and transforms.
See Also

Reference

TransformChainCommand Class
TransformChainCommand Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Properties

The TransformChainCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color to use on newly uncovered areas of the image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | Count | Returns the number of transforms in the collection.
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | IsSynchronized | Gets a value indicating whether access to the transforms collection is synchronized.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Overrides ImageCommandSupportedPixelFormats.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the transforms collection.
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.BackColor Property

TransformChainCommandBackColor Property

Gets or sets the background color to use on newly uncovered areas of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color to use on newly uncovered areas of the image.
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.Count Property

TransformChainCommandCount Property

Returns the number of transforms in the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of transforms in the collection.

Implements

ICollectionCount
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.IsSynchronized Property

TransformChainCommandIsSynchronized Property

Gets a value indicating whether access to the transforms collection is synchronized.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether access to the transforms collection is synchronized.

Implements

ICollectionIsSynchronized
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.SupportedPixelFormats Property

TransformChainCommandSupportedPixelFormats Property

Returns an array of PixelFormats supported by this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PixelFormat[] SupportedPixelFormats { get; }
Public Overrides ReadOnly Property SupportedPixelFormats As PixelFormat()
    Get

Property Value

Type: PixelFormat
PixelFormat.Pixel24bppBgr,,PixelFormat.Pixel8bppGrayscale,,PixelFormat.Pixel32bppBgr,,PixelFormat.Pixel1bppIndexed,,PixelFormat.Pixel4bppIndexed,,PixelFormat.Pixel8bppIndexed,,PixelFormat.Pixel16bppGrayscaleAlpha,,PixelFormat.Pixel32bppBgra,,PixelFormat.Pixel32bppCmyk
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.SyncRoot Property

TransformChainCommandSyncRoot Property

Gets an object that can be used to synchronize access to the transforms collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

Implements

ICollectionSyncRoot
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.TransformMode Property

TransformChainCommandTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand Methods

The TransformChainCommand type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a transform to the collection.
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Public method | Clear | Removes all of the transforms from the collection.
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | CopyTo(Array, Int32) | Copies transforms from the internal collection to an array.
Public method | CopyTo(Transform, Int32) | Copies transforms from the internal collection to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetEnumerator | This allows the use of foreach statements on the transforms collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Overrides ImageCommandSelectPreferredPixelFormat(AtalaImage, PixelFormat, PixelFormat).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Overrides ImageCommandVerifyProperties(AtalaImage).)
Top
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.Add Method

TransformChainCommandAdd Method

Adds a transform to the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    Transform transform
)
Public Sub Add (
    transform As Transform
)

Parameters

transform
Type: Atalasoft.Imaging.ImageProcessing.TransformsTransform
The transform to add.
Exceptions
Exception | Condition
 | Thrown if the transform is null (Nothing in VB).
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.Clear Method

TransformChainCommandClear Method

Removes all of the transforms from the collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.CopyTo Method

TransformChainCommandCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) | Copies transforms from the internal collection to an array.
Public method | CopyTo(Transform, Int32) | Copies transforms from the internal collection to an array.
Top
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.CopyTo Method (Array, Int32)

TransformChainCommandCopyTo Method (Array, Int32)

Copies transforms from the internal collection to an array.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Array array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Array,
    arrayIndex As Integer
)

Parameters

array
Type: SystemArray
An array to copy the transforms into.
arrayIndex
Type: SystemInt32
The index to start copying transforms into.

Implements

ICollectionCopyTo(Array, Int32)
Exceptions
Exception | Condition
 | Thrown if array is null (Nothing in VB).
 | Thrown if arrayIndex is invalid.
See Also

Reference

TransformChainCommand Class
CopyTo Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.CopyTo Method (Transform[], Int32)

TransformChainCommandCopyTo Method (Transform, Int32)

Copies transforms from the internal collection to an array.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Transform[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Transform(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.Imaging.ImageProcessing.TransformsTransform
An array to copy the transforms into.
arrayIndex
Type: SystemInt32

The index to start copying transforms into.

Exceptions
Exception | Condition
 | Thrown if array is null (Nothing in VB).
 | Thrown if the arrayIndex is invalid.
See Also

Reference

TransformChainCommand Class
CopyTo Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.GetEnumerator Method

TransformChainCommandGetEnumerator Method

This allows the use of foreach statements on the transforms collection.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator for the transform collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.GetObjectData Method

TransformChainCommandGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.PerformActualCommand Method

TransformChainCommandPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.SelectPreferredPixelFormat Method

TransformChainCommandSelectPreferredPixelFormat Method

Chooses a pixel format that is preferred for this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat SelectPreferredPixelFormat(
    AtalaImage sourceImage,
    PixelFormat sourceFormat,
    PixelFormat[] formats
)
Protected Overrides Function SelectPreferredPixelFormat (
    sourceImage As AtalaImage,
    sourceFormat As PixelFormat,
    formats As PixelFormat()
) As PixelFormat

Parameters

sourceImage
Type: Atalasoft.ImagingAtalaImage
The original source image.
sourceFormat
Type: Atalasoft.ImagingPixelFormat
The original image's pixel format.
formats
Type: Atalasoft.ImagingPixelFormat
An array of pixel formats supported by this command.

Return Value

Type: PixelFormat
A new pixel format to use for this command.
Remarks

The default implementation returns the sourceFormat value.

In theory, a command should only ever return pixel format that it has direct support for. Unfortunately, many older commands advertised that they supported pixel formats that were not native to the command. To maintain compatibility with older versions of dotImage, this method allows a command to select a new pixel format for itself, without being bound to the ApplyToAnyPixelFormat property.

See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


TransformChainCommand.VerifyProperties Method

TransformChainCommandVerifyProperties Method

Verify the integrity of properties in the command before processing an image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void VerifyProperties(
    AtalaImage image
)
Protected Overrides Sub VerifyProperties (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to be processed.
Remarks

This method does not check the integrity of the source image itself. That is already done by the time VerifyProperties is called.

Errors should be indicated by throwing an appropriate exception.

See Also

Reference

TransformChainCommand Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Class

This allows you to write your own transform methods and add them to the transform chain, just like the built-in transforms. To do this, you must supply a UserTransformCallback.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsUserTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UserTransform : Transform
Public Class UserTransform
    Inherits Transform

The UserTransform type exposes the following members.

Constructors
 | Name | Description
Public method | UserTransform | Creates a new instance of UserTransform.
Public method | UserTransform(UserTransformCallback) | Creates a new instance of the UserTransform class specifying the use transform callback.
Public method | UserTransform(UserTransformCallback, InterpolationMode) | Creates a new instance of the UserTransform class specifying the use transform callback and interpolation mode.
Public method | UserTransform(UserTransformCallback, InterpolationMode, Color) | Creates a new instance of the UserTransform class specifying the use transform callback, interpolation mode, and background color.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color used when a transform uncovers part of the image.
Public property | Callback | Gets or sets the UserTransformCallback delegate which will be called for each pixel processed in the output image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks

This method will be called once for each pixel in the output image. You need to set the FromPixel parameter to the pixels (may be fractional) that the input X and Y values will be pulled from. Again, you tell the transform processor where to pull the source pixel from.

Your callback method should be able to handle any kind of input range; inputs may be outside the image rectangle, if you are chaining transforms. Likewise, your function can output values that are outside the image rectangle. If your function is the last in the chain, values outside the image rect will be set to the background color.

This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.

Examples
UserTransform Example (C#)
Copy
private void menuUserTransform_Click(object sender, System.EventArgs e)
{
    // Load a 24-bit image.
    AtalaImage image = new AtalaImage(@"D:\Test Images\1.jpg");

    // Apply the our own transform.
    UserTransform cmd = new UserTransform(new UserTransformCallback(UserCallback));
    AtalaImage result = cmd.Apply(image).Image;

    // Display the result in a WorkspaceViewer.
    image.Dispose();
    this.viewer.Image = result;
}

private bool UserCallback(UserTransformData data)
{
    // This will take small blocks from the image and rearrange them.

    float fpx = 0;
    float fpy = 0;
    float[] stopPoints = new float[] { 400, 360, 320, 280, 240, 200, 160, 120, 80, 40 };
    bool xFound = false;
    bool yFound = false;

    for (int i = 0; i < stopPoints.Length; i++)
    {
        if (!xFound)
        {
            if (data.CurrentPixel.X > stopPoints[i])
            {
                fpx = stopPoints[i] + data.CurrentPixel.X;
                xFound = true;
            }
            else
                fpx = data.CurrentPixel.X;
        }

        if (!yFound)
        {
            if (data.CurrentPixel.Y > stopPoints[i])
            {
                fpy = stopPoints[i] + data.CurrentPixel.Y;
                yFound = true;
            }
            else
                fpy = data.CurrentPixel.Y;
        }

        if (xFound && yFound) break;
    }

    data.FromPixel = new PointF(fpx, fpy);

    return true;
}
UserTransform Example (Visual Basic)
Copy
Private  Sub menuUserTransform_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    ' Load a 24-bit image.
    Dim image As AtalaImage = New AtalaImage("D:\Test Images\1.jpg")

    ' Apply the our own transform.
    Dim cmd As UserTransform = New UserTransform(New UserTransformCallback(UserCallback))
    Dim result As AtalaImage = cmd.Apply(image).Image

    ' Display the result in a WorkspaceViewer.
    image.Dispose()
    Me.viewer.Image = result
End Sub

Private Function UserCallback(ByVal Data As UserTransformData) As Boolean
    ' This will take small blocks from the image and rearrange them.

    Dim fpx As Single =  0
    Dim fpy As Single =  0
    Dim stopPoints() As Single = New Single() {400, 360, 320, 280, 240, 200, 160, 120, 80, 40}

    Dim xFound As Boolean =  False
    Dim yFound As Boolean =  False

    Dim i As Integer
    For  i = 0 To stopPoints.Length- 1 Step i + 1
        If Not xFound Then
            If Data.CurrentPixel.X > stopPoints(i) Then
                fpx = stopPoints(i) + Data.CurrentPixel.X
                xFound = True
            Else
                fpx = Data.CurrentPixel.X
            End If
        End If

        If Not yFound Then
            If Data.CurrentPixel.Y > stopPoints(i) Then
                fpy = stopPoints(i) + Data.CurrentPixel.Y
                yFound = True
            Else
                fpy = Data.CurrentPixel.Y
            End If
        End If

        If xFound And yFound Then
             Exit For
        End If
    Next

    Data.FromPixel = New PointF(fpx, fpy)

    Return True
End Function
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Constructor

Overload List
 | Name | Description
Public method | UserTransform | Creates a new instance of UserTransform.
Public method | UserTransform(UserTransformCallback) | Creates a new instance of the UserTransform class specifying the use transform callback.
Public method | UserTransform(UserTransformCallback, InterpolationMode) | Creates a new instance of the UserTransform class specifying the use transform callback and interpolation mode.
Public method | UserTransform(UserTransformCallback, InterpolationMode, Color) | Creates a new instance of the UserTransform class specifying the use transform callback, interpolation mode, and background color.
Top
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Constructor

Creates a new instance of UserTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransform()
Public Sub New
See Also

Reference

UserTransform Class
UserTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Constructor (UserTransformCallback)

Creates a new instance of the UserTransform class specifying the use transform callback.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransform(
    UserTransformCallback callback
)
Public Sub New (
    callback As UserTransformCallback
)

Parameters

callback
Type: Atalasoft.Imaging.ImageProcessing.TransformsUserTransformCallback
Delegate which will be called for each pixel processed in the output image.
Exceptions
Exception | Condition
 | Thrown if the callback is null (Nothing in VB).
See Also

Reference

UserTransform Class
UserTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Constructor (UserTransformCallback, InterpolationMode)

Creates a new instance of the UserTransform class specifying the use transform callback and interpolation mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransform(
    UserTransformCallback callback,
    InterpolationMode transformMode
)
Public Sub New (
    callback As UserTransformCallback,
    transformMode As InterpolationMode
)

Parameters

callback
Type: Atalasoft.Imaging.ImageProcessing.TransformsUserTransformCallback
Delegate which will be called for each pixel processed in the output image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if the callback is null (Nothing in VB).
See Also

Reference

UserTransform Class
UserTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Constructor (UserTransformCallback, InterpolationMode, Color)

Creates a new instance of the UserTransform class specifying the use transform callback, interpolation mode, and background color.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransform(
    UserTransformCallback callback,
    InterpolationMode transformMode,
    Color backColor
)
Public Sub New (
    callback As UserTransformCallback,
    transformMode As InterpolationMode,
    backColor As Color
)

Parameters

callback
Type: Atalasoft.Imaging.ImageProcessing.TransformsUserTransformCallback
Delegate which will be called for each pixel processed in the output image.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
backColor
Type: System.DrawingColor
The background color to use for newly uncovered areas of the image.
Exceptions
Exception | Condition
 | Thrown if the callback is null (Nothing in VB).
See Also

Reference

UserTransform Class
UserTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Properties

The UserTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BackColor | Gets or sets the background color used when a transform uncovers part of the image.
Public property | Callback | Gets or sets the UserTransformCallback delegate which will be called for each pixel processed in the output image.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform.BackColor Property

UserTransformBackColor Property

Gets or sets the background color used when a transform uncovers part of the image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color used when a transform uncovers part of the image.
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform.Callback Property

UserTransformCallback Property

Gets or sets the UserTransformCallback delegate which will be called for each pixel processed in the output image.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransformCallback Callback { get; set; }
Public Property Callback As UserTransformCallback
    Get
    Set

Property Value

Type: UserTransformCallback
The UserTransformCallback delegate which will be called for each pixel processed in the output image.
Exceptions
Exception | Condition
 | Thrown if value is null.
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform.TransformMode Property

UserTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform Methods

The UserTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform.AddToChain Method

UserTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransform.PerformActualCommand Method

UserTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

UserTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformCallback Delegate

Callback method for the UserTransform object.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate bool UserTransformCallback(
    UserTransformData callbackData
)
Public Delegate Function UserTransformCallback (
    callbackData As UserTransformData
) As Boolean

Parameters

callbackData
Type: Atalasoft.Imaging.ImageProcessing.TransformsUserTransformData

Contains the information used in the transform.

Return Value

Type: Boolean
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData Class

This class is used in the UserTransformCallback to indicate the pixel locations of the transform.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessing.TransformsUserTransformData

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UserTransformData
Public Class UserTransformData

The UserTransformData type exposes the following members.

Constructors
 | Name | Description
Public method | UserTransformData | Creates a new instance of UserTransformData.
Public method | UserTransformData(PointF, PointF) | Initializes a new instance of UserTransformData specifying the to and from points.
Top
Properties
 | Name | Description
Public property | CurrentPixel | Gets the current pixel to transform.
Public property | FromPixel | Gets or sets the value which the pixel which should move to the current pixel.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See UserTransform.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsUserTransform


UserTransformData Constructor

Overload List
 | Name | Description
Public method | UserTransformData | Creates a new instance of UserTransformData.
Public method | UserTransformData(PointF, PointF) | Initializes a new instance of UserTransformData specifying the to and from points.
Top
See Also

Reference

UserTransformData Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData Constructor

Creates a new instance of UserTransformData.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransformData()
Public Sub New
See Also

Reference

UserTransformData Class
UserTransformData Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData Constructor (PointF, PointF)

Initializes a new instance of UserTransformData specifying the to and from points.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UserTransformData(
    PointF currentPixel,
    PointF fromPixel
)
Public Sub New (
    currentPixel As PointF,
    fromPixel As PointF
)

Parameters

currentPixel
Type: System.DrawingPointF
The current pixel to transform.
fromPixel
Type: System.DrawingPointF
The value which the pixel which should move to the current pixel.
See Also

Reference

UserTransformData Class
UserTransformData Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData Properties

The UserTransformData type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPixel | Gets the current pixel to transform.
Public property | FromPixel | Gets or sets the value which the pixel which should move to the current pixel.
Top
See Also

Reference

UserTransformData Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData.CurrentPixel Property

UserTransformDataCurrentPixel Property

Gets the current pixel to transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF CurrentPixel { get; set; }
Public Property CurrentPixel As PointF
    Get
    Set

Property Value

Type: PointF
The current pixel to transform.
See Also

Reference

UserTransformData Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData.FromPixel Property

UserTransformDataFromPixel Property

Gets or sets the value which the pixel which should move to the current pixel.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF FromPixel { get; set; }
Public Property FromPixel As PointF
    Get
    Set

Property Value

Type: PointF
The value which the pixel which should move to the current pixel.
See Also

Reference

UserTransformData Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


UserTransformData Methods

The UserTransformData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserTransformData Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Class

This transform moves across the image with a sine wave pattern.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsWaveTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class WaveTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class WaveTransform
    Inherits Transform
    Implements ISerializable

The WaveTransform type exposes the following members.

Constructors
 | Name | Description
Public method | WaveTransform | Creates a new instance of WaveTransform.
Protected method | WaveTransform(SerializationInfo, StreamingContext) | Creates a new instance of WaveTransform from serialization information
Public method | WaveTransform(Double, Double, WaveTransformMode) | Creates a new instance of WaveTransform specifying maxOffsetPercent, periods and mode.
Public method | WaveTransform(Double, Double, WaveTransformMode, InterpolationMode) | Creates a new instance of WaveTransform specifying maxOffsetPercent, periods, mode and transformMode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxOffsetPercent | Gets or sets the maximum offset percent for the wave.
Public property | Mode | Gets or sets the style of wave transform to create.
Public property | Periods | Gets or sets the number of periods in the wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
OffsetTransform Example


WaveTransform Constructor

Overload List
 | Name | Description
Public method | WaveTransform | Creates a new instance of WaveTransform.
Protected method | WaveTransform(SerializationInfo, StreamingContext) | Creates a new instance of WaveTransform from serialization information
Public method | WaveTransform(Double, Double, WaveTransformMode) | Creates a new instance of WaveTransform specifying maxOffsetPercent, periods and mode.
Public method | WaveTransform(Double, Double, WaveTransformMode, InterpolationMode) | Creates a new instance of WaveTransform specifying maxOffsetPercent, periods, mode and transformMode.
Top
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Constructor

Creates a new instance of WaveTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WaveTransform()
Public Sub New
See Also

Reference

WaveTransform Class
WaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of WaveTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WaveTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
Remarks
Creates a new instance of the WaveTransform object.
See Also

Reference

WaveTransform Class
WaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Constructor (Double, Double, WaveTransformMode)

Creates a new instance of WaveTransform specifying maxOffsetPercent, periods and mode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WaveTransform(
    double maxOffsetPercent,
    double periods,
    WaveTransformMode mode
)
Public Sub New (
    maxOffsetPercent As Double,
    periods As Double,
    mode As WaveTransformMode
)

Parameters

maxOffsetPercent
Type: SystemDouble
Maximum offset percent for the wave.
periods
Type: SystemDouble
Number of periods in the wave.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsWaveTransformMode
The style of wave transform to create.
Exceptions
Exception | Condition
 | Thrown if the maxOffsetPercent or periods value is less than 0.
See Also

Reference

WaveTransform Class
WaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Constructor (Double, Double, WaveTransformMode, InterpolationMode)

Creates a new instance of WaveTransform specifying maxOffsetPercent, periods, mode and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WaveTransform(
    double maxOffsetPercent,
    double periods,
    WaveTransformMode mode,
    InterpolationMode transformMode
)
Public Sub New (
    maxOffsetPercent As Double,
    periods As Double,
    mode As WaveTransformMode,
    transformMode As InterpolationMode
)

Parameters

maxOffsetPercent
Type: SystemDouble
Maximum offset percent for the wave.
periods
Type: SystemDouble
Number of periods in the wave.
mode
Type: Atalasoft.Imaging.ImageProcessing.TransformsWaveTransformMode
The style of wave transform to create.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if the maxOffsetPercent or periods value is less than 0.
See Also

Reference

WaveTransform Class
WaveTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Properties

The WaveTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxOffsetPercent | Gets or sets the maximum offset percent for the wave.
Public property | Mode | Gets or sets the style of wave transform to create.
Public property | Periods | Gets or sets the number of periods in the wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.MaxOffsetPercent Property

WaveTransformMaxOffsetPercent Property

Gets or sets the maximum offset percent for the wave.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxOffsetPercent { get; set; }
Public Property MaxOffsetPercent As Double
    Get
    Set

Property Value

Type: Double
Maximum offset percent for the wave.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.Mode Property

WaveTransformMode Property

Gets or sets the style of wave transform to create.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WaveTransformMode Mode { get; set; }
Public Property Mode As WaveTransformMode
    Get
    Set

Property Value

Type: WaveTransformMode
The style of wave transform to create.
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.Periods Property

WaveTransformPeriods Property

Gets or sets the number of periods in the wave.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Periods { get; set; }
Public Property Periods As Double
    Get
    Set

Property Value

Type: Double
Number of periods in the wave.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.TransformMode Property

WaveTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform Methods

The WaveTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.AddToChain Method

WaveTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.GetObjectData Method

WaveTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransform.PerformActualCommand Method

WaveTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

WaveTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WaveTransformMode Enumeration

Enumeration used by WaveTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WaveTransformMode
Public Enumeration WaveTransformMode
Members
Member name | Description
LeftToRightSine | The wave moves from left to right as a sine wave.
TopToBottomSine | The wave moves from top to bottom as a sine wave.
LeftToRightCosine | The wave moves from left to right as a cosine wave.
TopToBottomCosine | The wave moves from top to bottom as a cosine wave.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Class

This transform creates an effect which is a bit like looking at the image though a clear sphere. If you set BigWow to true, the result looks as if you're inside the sphere.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsWowTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class WowTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class WowTransform
    Inherits Transform
    Implements ISerializable

The WowTransform type exposes the following members.

Constructors
 | Name | Description
Public method | WowTransform | Creates a new instance of WowTransform.
Public method | WowTransform(Double, Boolean) | Creates a new instance of WowTransform specifying maxRadius, and bigWow.
Protected method | WowTransform(SerializationInfo, StreamingContext) | Creates a new instance of WowTransform from serialization information
Public method | WowTransform(Double, Boolean, InterpolationMode) | Creates a new instance of WowTransform specifying maxRadius, bigWow and transformMode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BigWow | Gets or sets a valid indicating if you the effect to appear inside the sphere.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


WowTransform Constructor

Overload List
 | Name | Description
Public method | WowTransform | Creates a new instance of WowTransform.
Public method | WowTransform(Double, Boolean) | Creates a new instance of WowTransform specifying maxRadius, and bigWow.
Protected method | WowTransform(SerializationInfo, StreamingContext) | Creates a new instance of WowTransform from serialization information
Public method | WowTransform(Double, Boolean, InterpolationMode) | Creates a new instance of WowTransform specifying maxRadius, bigWow and transformMode.
Top
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Constructor

Creates a new instance of WowTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WowTransform()
Public Sub New
See Also

Reference

WowTransform Class
WowTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Constructor (Double, Boolean)

Creates a new instance of WowTransform specifying maxRadius, and bigWow.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WowTransform(
    double maxRadius,
    bool bigWow
)
Public Sub New (
    maxRadius As Double,
    bigWow As Boolean
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
bigWow
Type: SystemBoolean
Makes it appear as if you are inside a clear sphere.
Exceptions
Exception | Condition
 | Thrown if maxRadius is less than 0.
See Also

Reference

WowTransform Class
WowTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of WowTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WowTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

WowTransform Class
WowTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Constructor (Double, Boolean, InterpolationMode)

Creates a new instance of WowTransform specifying maxRadius, bigWow and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WowTransform(
    double maxRadius,
    bool bigWow,
    InterpolationMode transformMode
)
Public Sub New (
    maxRadius As Double,
    bigWow As Boolean,
    transformMode As InterpolationMode
)

Parameters

maxRadius
Type: SystemDouble
Maximum distance from the center for this effect.
bigWow
Type: SystemBoolean
Makes it appear as if you are inside a clear sphere.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if maxRadius is less than 0.
See Also

Reference

WowTransform Class
WowTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Properties

The WowTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | BigWow | Gets or sets a valid indicating if you the effect to appear inside the sphere.
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxRadius | Gets or sets the maximum distance from the center for this effect.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform.BigWow Property

WowTransformBigWow Property

Gets or sets a valid indicating if you the effect to appear inside the sphere.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool BigWow { get; set; }
Public Property BigWow As Boolean
    Get
    Set

Property Value

Type: Boolean
A valid indicating if you the effect to appear inside the sphere. You have to see it to know.
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform.MaxRadius Property

WowTransformMaxRadius Property

Gets or sets the maximum distance from the center for this effect.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxRadius { get; set; }
Public Property MaxRadius As Double
    Get
    Set

Property Value

Type: Double
Maximum distance from the center for this effect.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform.TransformMode Property

WowTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform Methods

The WowTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform.AddToChain Method

WowTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform.GetObjectData Method

WowTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


WowTransform.PerformActualCommand Method

WowTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

WowTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Class

This transform moves across the images in a triangle wave pattern.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageProcessingImageCommand
Atalasoft.Imaging.ImageProcessing.TransformsTransform
Atalasoft.Imaging.ImageProcessing.TransformsZigZagTransform

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ZigZagTransform : Transform,
    ISerializable
<SerializableAttribute>
Public Class ZigZagTransform
    Inherits Transform
    Implements ISerializable

The ZigZagTransform type exposes the following members.

Constructors
 | Name | Description
Public method | ZigZagTransform | Creates a new instance of ZigZagTransform.
Protected method | ZigZagTransform(SerializationInfo, StreamingContext) | Creates a new instance of ZigZagTransform from serialization information
Public method | ZigZagTransform(Double, Int32, Boolean) | Creates a new instance of ZigZagTransform specifying maxOffsetPercent, periods, and topToBottom.
Public method | ZigZagTransform(Double, Int32, Boolean, InterpolationMode) | Creates a new instance of ZigZagTransform specifying maxOffsetPercent, periods, topToBottom and transformMode.
Top
Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxOffsetPercent | Gets or sets the maximum offset percent for the wave.
Public property | Periods | Gets or sets the number of periods in the wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TopToBottom | Gets or sets a value indicating if the wave moves from top to bottom instead of left to right.
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
Remarks
This method requires a continuous tone image. If the source image is not continuous, it will attempt to convert the image into one.
See Also

Reference

Atalasoft.Imaging.ImageProcessing.Transforms Namespace
Atalasoft.Imaging.ImageProcessing.TransformsOffsetTransform


ZigZagTransform Constructor

Overload List
 | Name | Description
Public method | ZigZagTransform | Creates a new instance of ZigZagTransform.
Protected method | ZigZagTransform(SerializationInfo, StreamingContext) | Creates a new instance of ZigZagTransform from serialization information
Public method | ZigZagTransform(Double, Int32, Boolean) | Creates a new instance of ZigZagTransform specifying maxOffsetPercent, periods, and topToBottom.
Public method | ZigZagTransform(Double, Int32, Boolean, InterpolationMode) | Creates a new instance of ZigZagTransform specifying maxOffsetPercent, periods, topToBottom and transformMode.
Top
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Constructor

Creates a new instance of ZigZagTransform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZigZagTransform()
Public Sub New
See Also

Reference

ZigZagTransform Class
ZigZagTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Constructor (SerializationInfo, StreamingContext)

Creates a new instance of ZigZagTransform from serialization information

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ZigZagTransform(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing information for this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.
See Also

Reference

ZigZagTransform Class
ZigZagTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Constructor (Double, Int32, Boolean)

Creates a new instance of ZigZagTransform specifying maxOffsetPercent, periods, and topToBottom.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZigZagTransform(
    double maxOffsetPercent,
    int periods,
    bool topToBottom
)
Public Sub New (
    maxOffsetPercent As Double,
    periods As Integer,
    topToBottom As Boolean
)

Parameters

maxOffsetPercent
Type: SystemDouble
Maximum offset percent for the wave.
periods
Type: SystemInt32
Number of periods in the wave.
topToBottom
Type: SystemBoolean
The wave moves from top to bottom instead of left to right.
Exceptions
Exception | Condition
 | Thrown if maxOffsetPercent or periods is less than 0.
See Also

Reference

ZigZagTransform Class
ZigZagTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Constructor (Double, Int32, Boolean, InterpolationMode)

Creates a new instance of ZigZagTransform specifying maxOffsetPercent, periods, topToBottom and transformMode.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZigZagTransform(
    double maxOffsetPercent,
    int periods,
    bool topToBottom,
    InterpolationMode transformMode
)
Public Sub New (
    maxOffsetPercent As Double,
    periods As Integer,
    topToBottom As Boolean,
    transformMode As InterpolationMode
)

Parameters

maxOffsetPercent
Type: SystemDouble
Maximum offset percent for the wave.
periods
Type: SystemInt32
Number of periods in the wave.
topToBottom
Type: SystemBoolean
The wave moves from top to bottom instead of left to right.
transformMode
Type: Atalasoft.Imaging.ImageProcessingInterpolationMode
Specifies the interpolation used with this transform.
Exceptions
Exception | Condition
 | Thrown if maxOffsetPercent or periods is less than 0.
See Also

Reference

ZigZagTransform Class
ZigZagTransform Overload
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Properties

The ZigZagTransform type exposes the following members.

Properties
 | Name | Description
Public property | ApplyToAnyPixelFormat | Reports whether or not this command will be applied to any supplied PixelFormat image (Inherited from ImageCommand.)
Public property | CanApplyToAnyPixelFormat | Returns true if the command can be applied to any PixelFormat. (Inherited from ImageCommand.)
Public property | InPlaceProcessing | Gets a value indicating if the source image data is processed in-place as opposed to returning a new image. (Inherited from ImageCommand.)
Public property | MaxOffsetPercent | Gets or sets the maximum offset percent for the wave.
Public property | Periods | Gets or sets the number of periods in the wave.
Public property | Progress | Gets or sets the ProgressEventHandler delegate which can be used to view or cancel the progress of the current process. (Inherited from ImageCommand.)
Public property | SupportedPixelFormats | Returns an array of PixelFormats supported by this command. (Inherited from Transform.)
Public property | TopToBottom | Gets or sets a value indicating if the wave moves from top to bottom instead of left to right.
Public property | TransformMode | Gets or sets the InterpolationMode of this transform.
Top
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.MaxOffsetPercent Property

ZigZagTransformMaxOffsetPercent Property

Gets or sets the maximum offset percent for the wave.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxOffsetPercent { get; set; }
Public Property MaxOffsetPercent As Double
    Get
    Set

Property Value

Type: Double
Maximum offset percent for the wave.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.Periods Property

ZigZagTransformPeriods Property

Gets or sets the number of periods in the wave.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Periods { get; set; }
Public Property Periods As Integer
    Get
    Set

Property Value

Type: Int32
Number of periods in the wave.
Exceptions
Exception | Condition
 | Thrown if value is less than 0.
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.TopToBottom Property

ZigZagTransformTopToBottom Property

Gets or sets a value indicating if the wave moves from top to bottom instead of left to right.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TopToBottom { get; set; }
Public Property TopToBottom As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the wave moves from top to bottom instead of left to right.
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.TransformMode Property

ZigZagTransformTransformMode Property

Gets or sets the InterpolationMode of this transform.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InterpolationMode TransformMode { get; set; }
Public Property TransformMode As InterpolationMode
    Get
    Set

Property Value

Type: InterpolationMode
The InterpolationMode of this transform.
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform Methods

The ZigZagTransform type exposes the following members.

Methods
 | Name | Description
Public method | AddToChain | Adds this transform to the transforms chain. (Overrides TransformAddToChain(Int32, Int32).)
Public method | Apply | Apply the command to the given image. (Inherited from ImageCommand.)
Public method | ApplyToImage | Obsolete. Applies the command to the source AtalaImage. (Inherited from ImageCommand.)
Protected method | ConstructChangedSourceImage | The method is called by the default implementation of Apply. It determines if it is necessary to create a copy of the source image in a different pixel format and if so, determines the best new pixel format and allocates that image. (Inherited from ImageCommand.)
Protected method | ConstructFinalImage | Called by the default implementation of Apply, ConstructFinalImage constructs the image that will be used as the destination image for the command. (Inherited from ImageCommand.)
Protected method | ConstructImageResults | Constructs the results object for this command. (Inherited from ImageCommand.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChangedPixelFormat | This method is called to change the pixel format of the source image. (Inherited from ImageCommand.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Fills a SerializationInfo object with information about this command.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImageCommandGetObjectData | Aggregates ImageCommand data into the supplied SerializationInfo object. (Inherited from ImageCommand.)
Public method | IsPixelFormatSupported | Returns a value indicating if the specified pixel format is supported. (Inherited from ImageCommand.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformActualCommand | PerformActualCommand does the actual work of the image processing command. (Overrides ImageCommandPerformActualCommand(AtalaImage, AtalaImage, Rectangle, ImageResults).)
Protected method | SelectBestAlternatePixelFormat | Choose the best pixel format to use for this command when the supplied source image's pixel format is unacceptable. (Inherited from ImageCommand.)
Protected method | SelectCompatibleBackgroundColor | Returns a color value compatible with the image. (Inherited from Transform.)
Protected method | SelectPreferredPixelFormat | Chooses a pixel format that is preferred for this command. (Inherited from Transform.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | VerifyImage | Verify the integrity of an AtalaImage. (Inherited from ImageCommand.)
Protected method | VerifyProperties | Verify the integrity of properties in the command before processing an image. (Inherited from Transform.)
Top
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.AddToChain Method

ZigZagTransformAddToChain Method

Adds this transform to the transforms chain.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void AddToChain(
    int width,
    int height
)
Public Overrides Sub AddToChain (
    width As Integer,
    height As Integer
)

Parameters

width
Type: SystemInt32
The width of the image to process.
height
Type: SystemInt32
The height of the image to process.
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.GetObjectData Method

ZigZagTransformGetObjectData Method

Fills a SerializationInfo object with information about this command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object that will be filled with information about this command.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext for this information.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


ZigZagTransform.PerformActualCommand Method

ZigZagTransformPerformActualCommand Method

PerformActualCommand does the actual work of the image processing command.

Namespace: Atalasoft.Imaging.ImageProcessing.Transforms
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override AtalaImage PerformActualCommand(
    AtalaImage source,
    AtalaImage dest,
    Rectangle imageArea,
    ref ImageResults results
)
Protected Overrides Function PerformActualCommand (
    source As AtalaImage,
    dest As AtalaImage,
    imageArea As Rectangle,
    ByRef results As ImageResults
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
The source image for processing. This may be different from the original image.
dest
Type: Atalasoft.ImagingAtalaImage
The destination image. Dest will be null when InPlaceProcessing is true or when ConstructFinalImage returns null.
imageArea
Type: System.DrawingRectangle
An area of the source image to process. When the destination image is non-null, it will always be the same size as imageArea. ImageArea only differs in size from the source image when the command is a subclass of ImageRegionCommand and when there is a region of interest.
results
Type: Atalasoft.Imaging.ImageProcessingImageResults
The results object that will be used for this command.

Return Value

Type: AtalaImage
In most cases, PerformActualCommand should return null. When PerformActualCommand returns a non-null image, it is indicating that it has allocated a new image to use for the final image. This must be true if ConstructFinalImage returned null.
See Also

Reference

ZigZagTransform Class
Atalasoft.Imaging.ImageProcessing.Transforms Namespace


Atalasoft.Imaging.ImageSources Namespace

Classes
 | Class | Description
 | DbImageSource | A DbImageSource is a sub-class of ImageSource that allows you read-only access to images stored in a database.
Public class | ImageSourceStreamInfo | Objects of this type are returned by IImageStreamSource.GetImageStream(int index). They contain a stream that has the requested image and the frame within that stream that maps to the image index that was requested.
Public class | MergedImageSource | MergedImageSource is a variety of RandomAccessImageSource that can combine any number of other RandomAccessImageSource objects.
Public class | PdfImageSource |
Interfaces
 | Interface | Description
Public interface | IDbImageAccessor | An interface containing methods necessary for getting to the underlying data store
Public interface | IImageStreamSource | Implement this interface in any ImageSource implementations if you can provide a stream with the image instead of the image itself. This is useful if the caller needs information about the image (e.g. height and width) or wants to make a thumbnail or a tile from it and doesn't need all of the image data to do it.
Delegates
 | Delegate | Description
Public delegate | DbImageSourceDecryptor | A delegate to decrypt data back into a string (for use with connection string serialization)
Public delegate | DbImageSourceEncryptor | A delegate to encrypt a string (for use with connection string serialization)
Public delegate | DbImageSourceFrameCounter | A delegate to help count frames in a Stream


DbImageSource Class

A DbImageSource is a sub-class of ImageSource that allows you read-only access to images stored in a database.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.Imaging.ImageSourcesDbImageSource

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DbImageSource : RandomAccessImageSource,
    ISerializable, IImageStreamSource
<SerializableAttribute>
Public Class DbImageSource
    Inherits RandomAccessImageSource
    Implements ISerializable, IImageStreamSource

The DbImageSource type exposes the following members.

Constructors
 | Name | Description
Public method | DbImageSource(IDbImageAccessor) | Creates a DbImageSource from a IDbImageAccessor implementor.
Protected method | DbImageSource(SerializationInfo, StreamingContext) | Deserialize this object from the info and context.
Public method | DbImageSource(IDbImageAccessor, Boolean) | Creates a DbImageSource from a IDbImageAccessor implementor.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | DbAccessor | The accessor used to get to the database. This class supports changing the accessor, but if you change anything about the connected accessor, you are responsible for calling Reset() on the image source.
Public property | DoAllFrames | Whether to include all of the frames as individual images in the source.
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Protected method | CalculateNumPagesPerImage | Calculates and caches the number of frames per image and the image count.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetFrameCountInImage | Returns the number of frames in the image that will be served by this image source. If DoAllFrames is false, this function always returns 1.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageNumAndFrame | Caclulates the image number and frame number given an image source index.
Public method | GetImageStream | Gets the stream and the frame within that stream that corresponds to the passed in index. The caller is responsible for closing the returned stream.
Public method | GetObjectData | Get the data to serialize for this object. (Overrides RandomAccessImageSourceGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Acquires the image at the given image source index. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Acquire the next image in the source. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Disposes any non-GC objects used by this class. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Returns true to indicate that a Reset() should flush all images (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Returns true if AcquireNext would return an image (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Not implemented for this image source. Will throw NotImplementedException. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Empties any cached data about the images (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Increments the internal index so that AcquireNext would skip an image (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | The total number of images in the image source (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
Examples
Using DbImageSource (C#)
Copy
using System.Data;
using System.Data.SqlClient;
using System.Collections;
using Atalasoft.Imaging;
using Atalasoft.Imaging.ImageSources;
using Atalasoft.Imaging.ImageSources.Data;

public class DbImageSourceExample
{
    // Gets a SQL Server specific connection to the image database
    public static IDbConnection GetConn()
    {
       return new SqlConnection("Data Source=DBServer;Integrated security=SSPI;Initial Catalog=ImageDatabase;");
    }

    // create an accessor that uses SQL statements
    public DbCommandImageAccessor CreateSqlImageAccessor()
    {
       Hashtable sqlParams = new Hashtable();
       sqlParams["@lower"] = 2;
       sqlParams["@upper"] = 4;
       return new DbSqlImageAccessor(new GetConnectionCallback(GetConn), false, "imageBlob", "id", "images", "id between 2 and 4", null, null, sqlParams );
    }

    // get an image from the database
    public AtalaImage GetImageFromDb(int i)
    {
       DbImageSource imgSrc = new DbImageSource(CreateSqlImageAccessor());
       return imgSrc[i];
    }
}
Using DbImageSource (Visual Basic)
Copy
Imports System.Data
Imports System.Data.SqlClient
Imports System.Collections
Imports Atalasoft.Imaging
Imports Atalasoft.Imaging.ImageSources
Imports Atalasoft.Imaging.ImageSources.Data

Public Class DbImageSourceExample

    ' Gets a SQL Server specific connection to the image database
    Public Shared Function GetConn() As IDbConnection
        Return New SqlConnection("Data Source=DBServer;Integrated security=SSPI;Initial Catalog=ImageDatabase;")
    End Function

    ' create an accessor that uses SQL statements
    Public Function CreateSqlImageAccessor() As DbCommandImageAccessor
        Dim sqlParams As New Hashtable()
        sqlParams("@lower") = 2
        sqlParams("@upper") = 4
        Return New DbSqlImageAccessor(New GetConnectionCallback(AddressOf GetConn), False, "imageBlob", "id", "images", "id between 2 and 4", _
        Nothing, Nothing, sqlParams)
    End Function

    ' get an image from the database
    Public Function GetImageFromDb(ByVal i As Integer) As AtalaImage
        Dim imgSrc As New DbImageSource(CreateSqlImageAccessor())
        Return imgSrc(i)
    End Function

End Class
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


DbImageSource Constructor

Constructors for DbImageSource
Overload List
 | Name | Description
Public method | DbImageSource(IDbImageAccessor) | Creates a DbImageSource from a IDbImageAccessor implementor.
Protected method | DbImageSource(SerializationInfo, StreamingContext) | Deserialize this object from the info and context.
Public method | DbImageSource(IDbImageAccessor, Boolean) | Creates a DbImageSource from a IDbImageAccessor implementor.
Top
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource Constructor (IDbImageAccessor)

Creates a DbImageSource from a IDbImageAccessor implementor.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbImageSource(
    IDbImageAccessor dbAccessor
)
Public Sub New (
    dbAccessor As IDbImageAccessor
)

Parameters

dbAccessor
Type: Atalasoft.Imaging.ImageSourcesIDbImageAccessor
An object that implements IDbImageAccessor and will access the underlying data.
See Also

Reference

DbImageSource Class
DbImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


DbImageSource Constructor (SerializationInfo, StreamingContext)

Deserialize this object from the info and context.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DbImageSource(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info to use for this object.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.
See Also

Reference

DbImageSource Class
DbImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


DbImageSource Constructor (IDbImageAccessor, Boolean)

Creates a DbImageSource from a IDbImageAccessor implementor.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbImageSource(
    IDbImageAccessor dbAccessor,
    bool doAllFrames
)
Public Sub New (
    dbAccessor As IDbImageAccessor,
    doAllFrames As Boolean
)

Parameters

dbAccessor
Type: Atalasoft.Imaging.ImageSourcesIDbImageAccessor
An object that implements IDbImageAccessor and will access the underlying data.
doAllFrames
Type: SystemBoolean
True means that the source should source all frames of the image. If all of the images are known to be single framed, passing false will increase performance of this class.
See Also

Reference

DbImageSource Class
DbImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


DbImageSource Properties

The DbImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | DbAccessor | The accessor used to get to the database. This class supports changing the accessor, but if you change anything about the connected accessor, you are responsible for calling Reset() on the image source.
Public property | DoAllFrames | Whether to include all of the frames as individual images in the source.
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.DbAccessor Property

DbImageSourceDbAccessor Property

The accessor used to get to the database. This class supports changing the accessor, but if you change anything about the connected accessor, you are responsible for calling Reset() on the image source.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDbImageAccessor DbAccessor { get; set; }
Public Property DbAccessor As IDbImageAccessor
    Get
    Set

Property Value

Type: IDbImageAccessor
The accessor used by this class to get images from the database.
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.DoAllFrames Property

DbImageSourceDoAllFrames Property

Whether to include all of the frames as individual images in the source.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DoAllFrames { get; set; }
Public Property DoAllFrames As Boolean
    Get
    Set

Property Value

Type: Boolean
True if each frame is an image in the source. False if only the first frame is used. If DoAllFrames is false, this class doesn't ever decode images to find the frame count. So, if all of the images are known to be single-framed, this class will be much faster if this property is set to false.
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource Methods

The DbImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Protected method | CalculateNumPagesPerImage | Calculates and caches the number of frames per image and the image count.
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetFrameCountInImage | Returns the number of frames in the image that will be served by this image source. If DoAllFrames is false, this function always returns 1.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageNumAndFrame | Caclulates the image number and frame number given an image source index.
Public method | GetImageStream | Gets the stream and the frame within that stream that corresponds to the passed in index. The caller is responsible for closing the returned stream.
Public method | GetObjectData | Get the data to serialize for this object. (Overrides RandomAccessImageSourceGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Acquires the image at the given image source index. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Acquire the next image in the source. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Disposes any non-GC objects used by this class. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Returns true to indicate that a Reset() should flush all images (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Returns true if AcquireNext would return an image (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Not implemented for this image source. Will throw NotImplementedException. (Overrides ImageSourceLowLevelReplaceImage(ImageSourceNode, AtalaImage).)
Protected method | LowLevelReset | Empties any cached data about the images (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Increments the internal index so that AcquireNext would skip an image (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | The total number of images in the image source (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.CalculateNumPagesPerImage Method

DbImageSourceCalculateNumPagesPerImage Method

Calculates and caches the number of frames per image and the image count.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void CalculateNumPagesPerImage()
Protected Sub CalculateNumPagesPerImage
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.GetFrameCountInImage Method

DbImageSourceGetFrameCountInImage Method

Returns the number of frames in the image that will be served by this image source. If DoAllFrames is false, this function always returns 1.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetFrameCountInImage(
    int index
)
Public Function GetFrameCountInImage (
    index As Integer
) As Integer

Parameters

index
Type: SystemInt32
The index of the image

Return Value

Type: Int32
The number of frames in the image
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.GetImageNumAndFrame Method

DbImageSourceGetImageNumAndFrame Method

Caclulates the image number and frame number given an image source index.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetImageNumAndFrame(
    int index,
    out int imageNum,
    out int frame
)
Public Sub GetImageNumAndFrame (
    index As Integer,
    <OutAttribute> ByRef imageNum As Integer,
    <OutAttribute> ByRef frame As Integer
)

Parameters

index
Type: SystemInt32
The index of the image in the image source.
imageNum
Type: SystemInt32
The image index in the source that contains this image.
frame
Type: SystemInt32
The frame number within the image that contains the image data for the given image.
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.GetImageStream Method

DbImageSourceGetImageStream Method

Gets the stream and the frame within that stream that corresponds to the passed in index. The caller is responsible for closing the returned stream.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceStreamInfo GetImageStream(
    int index
)
Public Function GetImageStream (
    index As Integer
) As ImageSourceStreamInfo

Parameters

index
Type: SystemInt32
The index of the requested image

Return Value

Type: ImageSourceStreamInfo

Implements

IImageStreamSourceGetImageStream(Int32)
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.GetObjectData Method

DbImageSourceGetObjectData Method

Get the data to serialize for this object.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information for this object to serialize
context
Type: System.Runtime.SerializationStreamingContext
The serialization context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelAcquire Method

DbImageSourceLowLevelAcquire Method

Acquires the image at the given image source index.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquire(
    int index
)
Protected Overrides Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32
The index within the image source

Return Value

Type: ImageSourceNode
The image at the index wrapped with a reloader, or null if there is no image at that index.
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelAcquireNextImage Method

DbImageSourceLowLevelAcquireNextImage Method

Acquire the next image in the source.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquireNextImage()
Protected Overrides Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
The next image in the source wrapped with a reloader.
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelDispose Method

DbImageSourceLowLevelDispose Method

Disposes any non-GC objects used by this class.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelDispose()
Protected Overrides Sub LowLevelDispose
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelFlushOnReset Method

DbImageSourceLowLevelFlushOnReset Method

Returns true to indicate that a Reset() should flush all images

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelFlushOnReset()
Protected Overrides Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
true always
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelHasMoreImages Method

DbImageSourceLowLevelHasMoreImages Method

Returns true if AcquireNext would return an image

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelHasMoreImages()
Protected Overrides Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
true if AcquireNext would return an image
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelReplaceImage Method

DbImageSourceLowLevelReplaceImage Method

Not implemented for this image source. Will throw NotImplementedException.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReplaceImage(
    ImageSourceNode node,
    AtalaImage newImage
)
Protected Overrides Sub LowLevelReplaceImage (
    node As ImageSourceNode,
    newImage As AtalaImage
)

Parameters

node
Type: Atalasoft.ImagingImageSourceNode
ignored
newImage
Type: Atalasoft.ImagingAtalaImage
ignored
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelReset Method

DbImageSourceLowLevelReset Method

Empties any cached data about the images

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReset()
Protected Overrides Sub LowLevelReset
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelSkipNextImage Method

DbImageSourceLowLevelSkipNextImage Method

Increments the internal index so that AcquireNext would skip an image

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelSkipNextImage()
Protected Overrides Sub LowLevelSkipNextImage
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.LowLevelTotalImages Method

DbImageSourceLowLevelTotalImages Method

The total number of images in the image source

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LowLevelTotalImages()
Protected Overrides Function LowLevelTotalImages As Integer

Return Value

Type: Int32
The total number of images in the image source
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource Events

The DbImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

DbImageSource Class
Atalasoft.Imaging.ImageSources Namespace


DbImageSource.Decryptor Delegate

DbImageSourceDecryptor Delegate

A delegate to decrypt data back into a string (for use with connection string serialization)

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate string Decryptor(
    byte[] b
)
Public Delegate Function Decryptor (
    b As Byte()
) As String

Parameters

b
Type: SystemByte

Return Value

Type: String
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


DbImageSource.Encryptor Delegate

DbImageSourceEncryptor Delegate

A delegate to encrypt a string (for use with connection string serialization)

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate byte[] Encryptor(
    string s
)
Public Delegate Function Encryptor (
    s As String
) As Byte()

Parameters

s
Type: SystemString

Return Value

Type: Byte
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


DbImageSource.FrameCounter Delegate

DbImageSourceFrameCounter Delegate

A delegate to help count frames in a Stream

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate int FrameCounter(
    Stream s
)
Public Delegate Function FrameCounter (
    s As Stream
) As Integer

Parameters

s
Type: System.IOStream

Return Value

Type: Int32
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


IDbImageAccessor Interface

An interface containing methods necessary for getting to the underlying data store

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IDbImageAccessor : ISerializable
Public Interface IDbImageAccessor
    Inherits ISerializable

The IDbImageAccessor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractImageStream | Returns a stream containing the image at the desired index. You are guaranteed that imageStreamIndex is within the range: 0 < imageStreamIndex <= GetImageStreamCount()
Public method | GetFrameCountInImage | Returns the number of frames in the image stream at index
Public method | GetImageStreamCount | Get the number of streams to source in the image source. Each image stream can have multiple frames
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | Reset | Reset all caches of information if you are storing anything that is a cached from the database, release it.
Top
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


IDbImageAccessor Methods

The IDbImageAccessor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractImageStream | Returns a stream containing the image at the desired index. You are guaranteed that imageStreamIndex is within the range: 0 < imageStreamIndex <= GetImageStreamCount()
Public method | GetFrameCountInImage | Returns the number of frames in the image stream at index
Public method | GetImageStreamCount | Get the number of streams to source in the image source. Each image stream can have multiple frames
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | Reset | Reset all caches of information if you are storing anything that is a cached from the database, release it.
Top
See Also

Reference

IDbImageAccessor Interface
Atalasoft.Imaging.ImageSources Namespace


IDbImageAccessor.ExtractImageStream Method

IDbImageAccessorExtractImageStream Method

Returns a stream containing the image at the desired index. You are guaranteed that imageStreamIndex is within the range: 0 < imageStreamIndex <= GetImageStreamCount()

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Stream ExtractImageStream(
    int imageStreamIndex
)
Function ExtractImageStream (
    imageStreamIndex As Integer
) As Stream

Parameters

imageStreamIndex
Type: SystemInt32
The row index of the desired image. The index represents the image stream which could contain multiple frames.

Return Value

Type: Stream
A Stream containing the image, or throw. Do not return null.
See Also

Reference

IDbImageAccessor Interface
Atalasoft.Imaging.ImageSources Namespace


IDbImageAccessor.GetFrameCountInImage Method

IDbImageAccessorGetFrameCountInImage Method

Returns the number of frames in the image stream at index

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int GetFrameCountInImage(
    int imageStreamIndex,
    DbImageSourceFrameCounter frameCounterFn
)
Function GetFrameCountInImage (
    imageStreamIndex As Integer,
    frameCounterFn As DbImageSourceFrameCounter
) As Integer

Parameters

imageStreamIndex
Type: SystemInt32
The index of the stream.
frameCounterFn
Type: Atalasoft.Imaging.ImageSourcesDbImageSourceFrameCounter
A delegate that can count the number of frames in a stream, which you can use if you haven't stored the framecount elsewhere. To speed performance, it might be better to store the frame count in the data store and not use this delegate.

Return Value

Type: Int32
See Also

Reference

IDbImageAccessor Interface
Atalasoft.Imaging.ImageSources Namespace


IDbImageAccessor.GetImageStreamCount Method

IDbImageAccessorGetImageStreamCount Method

Get the number of streams to source in the image source. Each image stream can have multiple frames

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int GetImageStreamCount()
Function GetImageStreamCount As Integer

Return Value

Type: Int32
The number of streams to source.
See Also

Reference

IDbImageAccessor Interface
Atalasoft.Imaging.ImageSources Namespace


IDbImageAccessor.Reset Method

IDbImageAccessorReset Method

Reset all caches of information if you are storing anything that is a cached from the database, release it.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Reset()
Sub Reset
See Also

Reference

IDbImageAccessor Interface
Atalasoft.Imaging.ImageSources Namespace


IImageStreamSource Interface

Implement this interface in any ImageSource implementations if you can provide a stream with the image instead of the image itself. This is useful if the caller needs information about the image (e.g. height and width) or wants to make a thumbnail or a tile from it and doesn't need all of the image data to do it.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IImageStreamSource
Public Interface IImageStreamSource

The IImageStreamSource type exposes the following members.

Methods
Name | Description
GetImageStream | Returns an object that contains information about the stream that contains the requested image. When you call this, the ImageStream member of the returned object will be open and the caller is responsible for closing it.
Top
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


IImageStreamSource Methods

The IImageStreamSource type exposes the following members.

Methods
Name | Description
GetImageStream | Returns an object that contains information about the stream that contains the requested image. When you call this, the ImageStream member of the returned object will be open and the caller is responsible for closing it.
Top
See Also

Reference

IImageStreamSource Interface
Atalasoft.Imaging.ImageSources Namespace


IImageStreamSource.GetImageStream Method

IImageStreamSourceGetImageStream Method

Returns an object that contains information about the stream that contains the requested image. When you call this, the ImageStream member of the returned object will be open and the caller is responsible for closing it.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
ImageSourceStreamInfo GetImageStream(
    int index
)
Function GetImageStream (
    index As Integer
) As ImageSourceStreamInfo

Parameters

index
Type: SystemInt32
The index of the image within the ImageSource.

Return Value

Type: ImageSourceStreamInfo
An object that contains the stream and information for finding the requested image within it.
Examples
Requesting a Stream from an ImageSource (C#)
Copy
public Size GetSize(RandomAccessImageSource src, int index)
{
    if (src is IImageStreamSource)
    {
       ImageSourceStreamInfo info = ((IImageStreamSource)src).GetImageStream(index);
       // caller is responsible for disposing info.ImageStream
       using (Stream s = info.ImageStream)
       {
          // reads size from meta-data, doesn't decode image
          return RegisteredDecoders.GetImageInfo(s, info.Frame).Size;
       }
    } else {
        return src[index].Size; // reads the whole image into memory
    }
}
See Also

Reference

IImageStreamSource Interface
Atalasoft.Imaging.ImageSources Namespace


ImageSourceStreamInfo Class

Objects of this type are returned by IImageStreamSource.GetImageStream(int index). They contain a stream that has the requested image and the frame within that stream that maps to the image index that was requested.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageSourcesImageSourceStreamInfo

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageSourceStreamInfo
Public Class ImageSourceStreamInfo

The ImageSourceStreamInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSourceStreamInfo | Creates the object from a stream and frame. The stream contains the requested image and the frame maps the requested index to the frame within this stream.
Top
Properties
 | Name | Description
Public property | Frame | The frame within the ImageStream that maps to the image index originally requested
Public property | ImageStream | The stream that contains the requested image
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


ImageSourceStreamInfo Constructor

Creates the object from a stream and frame. The stream contains the requested image and the frame maps the requested index to the frame within this stream.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceStreamInfo(
    Stream imageStream,
    int frame
)
Public Sub New (
    imageStream As Stream,
    frame As Integer
)

Parameters

imageStream
Type: System.IOStream
The stream that contains the requested image
frame
Type: SystemInt32
The frame within this stream that maps to the image index that was requested from the ImageSource
See Also

Reference

ImageSourceStreamInfo Class
Atalasoft.Imaging.ImageSources Namespace


ImageSourceStreamInfo Properties

The ImageSourceStreamInfo type exposes the following members.

Properties
 | Name | Description
Public property | Frame | The frame within the ImageStream that maps to the image index originally requested
Public property | ImageStream | The stream that contains the requested image
Top
See Also

Reference

ImageSourceStreamInfo Class
Atalasoft.Imaging.ImageSources Namespace


ImageSourceStreamInfo.Frame Property

ImageSourceStreamInfoFrame Property

The frame within the ImageStream that maps to the image index originally requested

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Frame { get; }
Public ReadOnly Property Frame As Integer
    Get

Property Value

Type: Int32
The frame within the ImageStream that maps to the index that was originally requested from the ImageSource
See Also

Reference

ImageSourceStreamInfo Class
Atalasoft.Imaging.ImageSources Namespace


ImageSourceStreamInfo.ImageStream Property

ImageSourceStreamInfoImageStream Property

The stream that contains the requested image

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream ImageStream { get; }
Public ReadOnly Property ImageStream As Stream
    Get

Property Value

Type: Stream
The stream that contains the requested image
See Also

Reference

ImageSourceStreamInfo Class
Atalasoft.Imaging.ImageSources Namespace


ImageSourceStreamInfo Methods

The ImageSourceStreamInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageSourceStreamInfo Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Class

MergedImageSource is a variety of RandomAccessImageSource that can combine any number of other RandomAccessImageSource objects.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.Imaging.ImageSourcesMergedImageSource

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MergedImageSource : RandomAccessImageSource,
    ISerializable
<SerializableAttribute>
Public Class MergedImageSource
    Inherits RandomAccessImageSource
    Implements ISerializable

The MergedImageSource type exposes the following members.

Constructors
 | Name | Description
 | MergedImageSource(RandomAccessImageSource) | Constructs a new MergedImageSource object from zero or more supplied RandomAccessImageSource objects
Protected method | MergedImageSource(SerializationInfo, StreamingContext) | Deserialize this object from the info and context.
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Gets the object data to be serialized (Overrides RandomAccessImageSourceGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Performs an acquire of an indexed image. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Inherited from ImageSource.)
Protected method | LowLevelReset | Lows level implementation of reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Constructor

Examples
C#
Copy
public RandomAccessImageSource Merge(RandomAccessImageSource a, RandomAccessImageSource b)
{
    return new MergedImageSource(a, b);
}
Overload List
 | Name | Description
 | MergedImageSource(RandomAccessImageSource) | Constructs a new MergedImageSource object from zero or more supplied RandomAccessImageSource objects
Protected method | MergedImageSource(SerializationInfo, StreamingContext) | Deserialize this object from the info and context.
Top
Examples
C#
Copy
public RandomAccessImageSource Merge(RandomAccessImageSource a, RandomAccessImageSource b)
{
    return new MergedImageSource(a, b);
}
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Constructor (RandomAccessImageSource[])

MergedImageSource Constructor (RandomAccessImageSource)

Constructs a new MergedImageSource object from zero or more supplied RandomAccessImageSource objects

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MergedImageSource(
    params RandomAccessImageSource[] imageSources
)
Public Sub New (
    ParamArray imageSources As RandomAccessImageSource()
)

Parameters

imageSources
Type: Atalasoft.ImagingRandomAccessImageSource
A collection of RandomAccessImageSources to be combined.
Remarks
Each RandomAccessImageSource provided must be unique. Passing in the same RandomAccessImageSource twice is an error.
See Also

Reference

MergedImageSource Class
MergedImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Constructor (SerializationInfo, StreamingContext)

Deserialize this object from the info and context.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MergedImageSource(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info to use for this object.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.
See Also

Reference

MergedImageSource Class
MergedImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Properties

The MergedImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Methods

The MergedImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Gets the object data to be serialized (Overrides RandomAccessImageSourceGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | Performs an acquire of an indexed image. (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | Lows level implementation to acquire next image. (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | Lows level implementation to dispose the ImageSource. (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | Lows level implementation to determine if there should be a flush on reset. (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | Lows level implementation to determine if the ImageSource has more images. (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Inherited from ImageSource.)
Protected method | LowLevelReset | Lows level implementation of reset. (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | Lows level implementation to skip next image. (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | Lows level implementation that returns the total number of images. (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.GetObjectData Method

MergedImageSourceGetObjectData Method

Gets the object data to be serialized

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information for this object to serialize
context
Type: System.Runtime.SerializationStreamingContext
The serialization context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelAcquire Method

MergedImageSourceLowLevelAcquire Method

Performs an acquire of an indexed image.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquire(
    int index
)
Protected Overrides Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32
The index of the image to acquire.

Return Value

Type: ImageSourceNode
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelAcquireNextImage Method

MergedImageSourceLowLevelAcquireNextImage Method

Lows level implementation to acquire next image.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquireNextImage()
Protected Overrides Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelDispose Method

MergedImageSourceLowLevelDispose Method

Lows level implementation to dispose the ImageSource.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelDispose()
Protected Overrides Sub LowLevelDispose
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelFlushOnReset Method

MergedImageSourceLowLevelFlushOnReset Method

Lows level implementation to determine if there should be a flush on reset.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelFlushOnReset()
Protected Overrides Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
true if the ImageSource needs a flush on reset, false otherwise.
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelHasMoreImages Method

MergedImageSourceLowLevelHasMoreImages Method

Lows level implementation to determine if the ImageSource has more images.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelHasMoreImages()
Protected Overrides Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
true if there are more image, false otherwise.
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelReset Method

MergedImageSourceLowLevelReset Method

Lows level implementation of reset.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReset()
Protected Overrides Sub LowLevelReset
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelSkipNextImage Method

MergedImageSourceLowLevelSkipNextImage Method

Lows level implementation to skip next image.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelSkipNextImage()
Protected Overrides Sub LowLevelSkipNextImage
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource.LowLevelTotalImages Method

MergedImageSourceLowLevelTotalImages Method

Lows level implementation that returns the total number of images.

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LowLevelTotalImages()
Protected Overrides Function LowLevelTotalImages As Integer

Return Value

Type: Int32
the total number of images
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


MergedImageSource Events

The MergedImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

MergedImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Class

Inheritance Hierarchy
SystemObject
Atalasoft.ImagingImageSource
Atalasoft.ImagingRandomAccessImageSource
Atalasoft.Imaging.ImageSourcesPdfImageSource

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageSource : RandomAccessImageSource
Public Class PdfImageSource
    Inherits RandomAccessImageSource

The PdfImageSource type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageSource(Stream) | Initializes a new instance of the PdfImageSource class
Public method | PdfImageSource(Stream, String) | Initializes a new instance of the PdfImageSource class
Top
Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | RenderSettings |
Public property | Resolution |
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from RandomAccessImageSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Inherited from ImageSource.)
Protected method | LowLevelReset | (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Constructor

Overload List
 | Name | Description
Public method | PdfImageSource(Stream) | Initializes a new instance of the PdfImageSource class
Public method | PdfImageSource(Stream, String) | Initializes a new instance of the PdfImageSource class
Top
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Constructor (Stream)

Initializes a new instance of the PdfImageSource class

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageSource(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
See Also

Reference

PdfImageSource Class
PdfImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Constructor (Stream, String)

Initializes a new instance of the PdfImageSource class

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageSource(
    Stream stm,
    string password
)
Public Sub New (
    stm As Stream,
    password As String
)

Parameters

stm
Type: System.IOStream
password
Type: SystemString
See Also

Reference

PdfImageSource Class
PdfImageSource Overload
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Properties

The PdfImageSource type exposes the following members.

Properties
 | Name | Description
Protected property | ActiveImages | Gets the active images. (Inherited from ImageSource.)
Public property | Count | Returns the total number of images in the image source. (Inherited from RandomAccessImageSource.)
Protected property | CulledImages | Gets the culled images. (Inherited from ImageSource.)
Public property | Current | Returns the index of the current image. (Inherited from ImageSource.)
Public property | ImmediateUnload | Determines if an image should be unloaded from memory immediately. (Inherited from ImageSource.)
Public property | Item | Acquires the image at location i within the image source and returns it. (Inherited from RandomAccessImageSource.)
Public property | MemoryInUse | Returns an estimate of the number of bytes of memory currently in use by images in this ImageSource. (Inherited from ImageSource.)
Public property | MemoryLimit | This sets the limit for memory usage for this ImageSource. If memory usage goes beyond this, images will be dropped from memory until memory usage is below the limit. (Inherited from ImageSource.)
Public property | RenderSettings |
Public property | Resolution |
Public property | TotalImages | Returns the total number of available images in this ImageSource. (Inherited from ImageSource.)
Public property | TotalImagesKnown | Gets a value indicating whether or not the total number of images in this image source can be known. (Inherited from ImageSource.)
Top
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.RenderSettings Property

PdfImageSourceRenderSettings Property

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderSettings RenderSettings { get; set; }
Public Property RenderSettings As RenderSettings
    Get
    Set

Property Value

Type: RenderSettings
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.Resolution Property

PdfImageSourceResolution Property

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Methods

The PdfImageSource type exposes the following members.

Methods
 | Name | Description
Public method | Acquire(Int32) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | Acquire(AtalaImage) | Obsolete. This method has been deprecated. Use ReAcquire(AtalaImage) instead. (Inherited from ImageSource.)
Public method | AcquireNext | Acquire the next available image from the ImageSource. (Inherited from ImageSource.)
Protected method | AllImagesAreReleased | Determines if all the images have been released. (Inherited from ImageSource.)
Public method | ContainsImage | Determines whether this ImageSource contains the specified image. (Inherited from ImageSource.)
Protected method | CullNode | Culls the node from the ImageSource (Inherited from ImageSource.)
Protected method | CullReleasedImages | Culls all released images. (Inherited from ImageSource.)
Public method | Dispose | Free up resources used by this ImageSource (Inherited from ImageSource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ImageSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ImageSource class. (Inherited from ImageSource.)
Protected method | Find | Finds the specified image. (Inherited from ImageSource.)
Public method | Flush | Flush all released images out of memory. (Inherited from ImageSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from RandomAccessImageSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMoreImages | Determines if there are more images to load. (Inherited from ImageSource.)
Protected method | LowLevelAcquire | (Overrides RandomAccessImageSourceLowLevelAcquire(Int32).)
Protected method | LowLevelAcquireNextImage | (Overrides ImageSourceLowLevelAcquireNextImage.)
Protected method | LowLevelDispose | (Overrides ImageSourceLowLevelDispose.)
Protected method | LowLevelFlushOnReset | (Overrides ImageSourceLowLevelFlushOnReset.)
Protected method | LowLevelHasMoreImages | (Overrides ImageSourceLowLevelHasMoreImages.)
Protected method | LowLevelReplaceImage | Lows level implementation to replace an image. (Inherited from ImageSource.)
Protected method | LowLevelReset | (Overrides ImageSourceLowLevelReset.)
Protected method | LowLevelSkipNextImage | (Overrides ImageSourceLowLevelSkipNextImage.)
Protected method | LowLevelTotalImages | (Overrides ImageSourceLowLevelTotalImages.)
Protected method | LowLevelTotalImagesKnown | Returns if the total images is known. (Inherited from RandomAccessImageSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChangedImage(AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Public method | NotifyChangedImage(AtalaImage, AtalaImage) | This method is used to inform an ImageSource that one of its current acquired images has changed. (Inherited from ImageSource.)
Protected method | OnChangedImage | Raises the [E:ChangedImage] event. (Inherited from ImageSource.)
Protected method | OnNodeIndexSet | This method is called from the RandomAccessImageSource indexer after it has set the ImageSourceNode.Index value. (Inherited from RandomAccessImageSource.)
Protected method | OnReleasing | Called when Release(AtalaImage) was performed on an ImageSourceNode. (Inherited from ImageSource.)
Public method | ReAcquire(Int32) | Acquire a previous image by index. (Inherited from ImageSource.)
Public method | ReAcquire(AtalaImage) | Acquire an AtalaImage that has been previously acquired. (Inherited from ImageSource.)
Public method | Release | Release a previously acquired image. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | ReleaseChangedImage(AtalaImage, AtalaImage) | Release an image that has changed, notifying other clients that the image has changed. (Inherited from ImageSource.)
Public method | Reset | Resets the ImageSource to start over again. (Inherited from ImageSource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelAcquire Method

PdfImageSourceLowLevelAcquire Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquire(
    int index
)
Protected Overrides Function LowLevelAcquire (
    index As Integer
) As ImageSourceNode

Parameters

index
Type: SystemInt32

Return Value

Type: ImageSourceNode
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelAcquireNextImage Method

PdfImageSourceLowLevelAcquireNextImage Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ImageSourceNode LowLevelAcquireNextImage()
Protected Overrides Function LowLevelAcquireNextImage As ImageSourceNode

Return Value

Type: ImageSourceNode
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelDispose Method

PdfImageSourceLowLevelDispose Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelDispose()
Protected Overrides Sub LowLevelDispose
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelFlushOnReset Method

PdfImageSourceLowLevelFlushOnReset Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelFlushOnReset()
Protected Overrides Function LowLevelFlushOnReset As Boolean

Return Value

Type: Boolean
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelHasMoreImages Method

PdfImageSourceLowLevelHasMoreImages Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool LowLevelHasMoreImages()
Protected Overrides Function LowLevelHasMoreImages As Boolean

Return Value

Type: Boolean
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelReset Method

PdfImageSourceLowLevelReset Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelReset()
Protected Overrides Sub LowLevelReset
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelSkipNextImage Method

PdfImageSourceLowLevelSkipNextImage Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LowLevelSkipNextImage()
Protected Overrides Sub LowLevelSkipNextImage
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource.LowLevelTotalImages Method

PdfImageSourceLowLevelTotalImages Method

Namespace: Atalasoft.Imaging.ImageSources
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LowLevelTotalImages()
Protected Overrides Function LowLevelTotalImages As Integer

Return Value

Type: Int32
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


PdfImageSource Events

The PdfImageSource type exposes the following members.

Events
 | Name | Description
Public event | ChangedImage | This event is fired whenever an image has been replaced. (Inherited from ImageSource.)
Public event | Releasing | Raised when the Release(AtalaImage) method is called on an ImageSourceNode. (Inherited from ImageSource.)
Top
See Also

Reference

PdfImageSource Class
Atalasoft.Imaging.ImageSources Namespace


Atalasoft.Imaging.ImageSources.Data Namespace

Classes
 | Class | Description
Public class | DbCommandImageAccessor | A class that can get images by using IDbCommands. You can either sub-class this class and implement the abstract methods to provide the various commands, or DbSqlImageAccessor, which builds up commands from SQL, or DbStoredProcImageAccessor, which builds up commands from Stored Procedures.
Public class | DbSqlImageAccessor | This class can access images for DbImageSource from clauses of SQL statements that are provided.
Public class | DbStoredProcImageAccessor | This class can be used with IDbImageSource to get images from a database through Stored Procedures. The Stored Procedures to call can be specified in the constructor and the only requirement is that they meet certain specifications as described in the constructor parameter documentation.
Delegates
 | Delegate | Description
Protected delegate | DbCommandImageAccessorFieldGetter |
Public delegate | DecryptHandler | A delegate to decrypt data back into a string (for use with serialization)
Public delegate | EncryptHandler | A delegate to encrypt a string (for use with serialization)
Public delegate | GetConnectionCallback | A delegate that can return connections to a Database


DbCommandImageAccessor Class

A class that can get images by using IDbCommands. You can either sub-class this class and implement the abstract methods to provide the various commands, or DbSqlImageAccessor, which builds up commands from SQL, or DbStoredProcImageAccessor, which builds up commands from Stored Procedures.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageSources.DataDbCommandImageAccessor
Atalasoft.Imaging.ImageSources.DataDbSqlImageAccessor
Atalasoft.Imaging.ImageSources.DataDbStoredProcImageAccessor

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class DbCommandImageAccessor : IDbImageAccessor,
    ISerializable
<SerializableAttribute>
Public MustInherit Class DbCommandImageAccessor
    Implements IDbImageAccessor, ISerializable

The DbCommandImageAccessor type exposes the following members.

Constructors
 | Name | Description
Protected method | DbCommandImageAccessor(SerializationInfo, StreamingContext) | Deserializes stored information from the serialization info.
Public method | DbCommandImageAccessor(GetConnectionCallback, Boolean, IDictionary) | Create an image accessor that uses IDbCommand objects to get images. The commands are created by sub-classes in the abstract methods.
Top
Properties
Name Description
Public property Decryptor
A delegate that can decrypt a string.
Public property Encryptor
A delegate that can encrypt a string.
Public property EncryptSerializedState
Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted.
Public property ExtraParameters
A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed.
Protected property GetConnection
A delegate that can return a connection to the database.
Protected property ImageFieldName
The name of the image field in the dataset returned by
Copy
CreateGetImageRowCommand
. If this method returns null, it is assumed to be in the first column.
Top
Methods
Name Description
Protected method AddExtraParameters
Adds any extra parameters supplied by the user that are needed to run the command.
Protected method CreateGetFrameCountCommand
A command that returns the frame count for an image. If this method returns null, the frame count will be determined by decoding the image stream. If not null, this command should result in a single row dataset with the frame count in the first column. If the frame count is stored separately from the image stream, implementing this method can greatly increase performance (especially first access). This command should not be associated with any connection.
Protected method CreateGetImageRowCommand
A method that can return a command that gets a single row dataset with the image stream information at the given index. The field can either be a varbinary, binary or image type (in which case the image stream is the value of the field) or it can be a string which will be interpreted as a filename that contains the image. The command should not be associated with a connection.
Protected method CreateGetImageStreamCountCommand
A command that can get the number of image streams in the source (each of which can contain multiple frames). This command should just return the number of streams (not the total frame count). The command should result in a single row dataset with the count in the first column. The command should not be associated with a connection.
Protected method CreateStreamFromDatabaseObject
Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.
Protected method DecryptIfRequested
Decrypt a string if EncryptSerializedState is true.
Protected method EncryptIfRequested
Encrypt a string if EncryptSerializedState is true.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExtractImageStream
Extracts a stream from a row of the database.
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
Protected method GetDecryptedValue
Gets the value from the serialized data and decrypts it if requested.
Protected method GetFieldByInt
Gets a field from the datareader by passing in the index of a field.
Protected method GetFieldByString
Gets a field from the datareader by passing in the name of the field.
Public method GetFrameCountInImage
The number of frames in the stream indicated by the imageStreamIndex
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageStreamCount
Gets the number of image streams in this database. Each stream can contain more than one frame.
Public method GetObjectData
Get the data to serialize for this object
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method Open
Opens a non-open connection
Public method Reset
Reset all caches of information. If you are storing anything that is a cached from the database, release it.
Protected method StoreEncryptedValue
Stores the value into the serialization info and encrypts it if requested.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor Constructor

Overload List
 | Name | Description
Protected method | DbCommandImageAccessor(SerializationInfo, StreamingContext) | Deserializes stored information from the serialization info.
Public method | DbCommandImageAccessor(GetConnectionCallback, Boolean, IDictionary) | Create an image accessor that uses IDbCommand objects to get images. The commands are created by sub-classes in the abstract methods.
Top
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor Constructor (SerializationInfo, StreamingContext)

Deserializes stored information from the serialization info.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DbCommandImageAccessor(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialized data.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.
See Also

Reference

DbCommandImageAccessor Class
DbCommandImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor Constructor (GetConnectionCallback, Boolean, IDictionary)

Create an image accessor that uses IDbCommand objects to get images. The commands are created by sub-classes in the abstract methods.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbCommandImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    IDictionary extraParameters
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    extraParameters As IDictionary
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can be used to get a connection to the database. This delegate may be serialized, so it should be to a static method. In the case of ASP.NET, the deserialization can happen in another page or in another web-server instance.
encryptSerializedState
Type: SystemBoolean
True if the serialized state of the object will be encrypted. Please see documentation of sub-classes to see which members are encrypted.
extraParameters
Type: System.CollectionsIDictionary
The parameters that are passed to all of your stored procedures. For SqlCommands, the keys should be strings which are the names of the parameters and start with an @. For OleDbCommands, you must use a IDictionary with sorted keys (e.g. SortedList) and use index numbers (starting at 0) as keys. The parameters are added in the sort order of the keys. The values can be any object that can be automatically converted by the IDbDataParameter for your connection. The
Copy
extraParameters
are not encrypted when this object is serialized. A copy of the the dictionary will be made upon construction, so that changes to it will not affect this object.
See Also

Reference

DbCommandImageAccessor Class
DbCommandImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor Properties

The DbCommandImageAccessor type exposes the following members.

Properties
Name Description
Public property Decryptor
A delegate that can decrypt a string.
Public property Encryptor
A delegate that can encrypt a string.
Public property EncryptSerializedState
Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted.
Public property ExtraParameters
A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed.
Protected property GetConnection
A delegate that can return a connection to the database.
Protected property ImageFieldName
The name of the image field in the dataset returned by
Copy
CreateGetImageRowCommand
. If this method returns null, it is assumed to be in the first column.
Top
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.Decryptor Property

DbCommandImageAccessorDecryptor Property

A delegate that can decrypt a string.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DecryptHandler Decryptor { get; set; }
Public Property Decryptor As DecryptHandler
    Get
    Set

Property Value

Type: DecryptHandler
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.Encryptor Property

DbCommandImageAccessorEncryptor Property

A delegate that can encrypt a string.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EncryptHandler Encryptor { get; set; }
Public Property Encryptor As EncryptHandler
    Get
    Set

Property Value

Type: EncryptHandler
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.EncryptSerializedState Property

DbCommandImageAccessorEncryptSerializedState Property

Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EncryptSerializedState { get; }
Public ReadOnly Property EncryptSerializedState As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.ExtraParameters Property

DbCommandImageAccessorExtraParameters Property

A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary ExtraParameters { get; }
Public ReadOnly Property ExtraParameters As IDictionary
    Get

Property Value

Type: IDictionary
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetConnection Property

DbCommandImageAccessorGetConnection Property

A delegate that can return a connection to the database.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected GetConnectionCallback GetConnection { get; }
Protected ReadOnly Property GetConnection As GetConnectionCallback
    Get

Property Value

Type: GetConnectionCallback
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.ImageFieldName Property

DbCommandImageAccessorImageFieldName Property

The name of the image field in the dataset returned by
Copy
CreateGetImageRowCommand
. If this method returns null, it is assumed to be in the first column.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string ImageFieldName { get; }
Protected Overridable ReadOnly Property ImageFieldName As String
    Get

Return Value

Type: String
The name of the image field in the dataset, or null if it's ok to assume it's in the first column.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor Methods

The DbCommandImageAccessor type exposes the following members.

Methods
Name Description
Protected method AddExtraParameters
Adds any extra parameters supplied by the user that are needed to run the command.
Protected method CreateGetFrameCountCommand
A command that returns the frame count for an image. If this method returns null, the frame count will be determined by decoding the image stream. If not null, this command should result in a single row dataset with the frame count in the first column. If the frame count is stored separately from the image stream, implementing this method can greatly increase performance (especially first access). This command should not be associated with any connection.
Protected method CreateGetImageRowCommand
A method that can return a command that gets a single row dataset with the image stream information at the given index. The field can either be a varbinary, binary or image type (in which case the image stream is the value of the field) or it can be a string which will be interpreted as a filename that contains the image. The command should not be associated with a connection.
Protected method CreateGetImageStreamCountCommand
A command that can get the number of image streams in the source (each of which can contain multiple frames). This command should just return the number of streams (not the total frame count). The command should result in a single row dataset with the count in the first column. The command should not be associated with a connection.
Protected method CreateStreamFromDatabaseObject
Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.
Protected method DecryptIfRequested
Decrypt a string if EncryptSerializedState is true.
Protected method EncryptIfRequested
Encrypt a string if EncryptSerializedState is true.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExtractImageStream
Extracts a stream from a row of the database.
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
Protected method GetDecryptedValue
Gets the value from the serialized data and decrypts it if requested.
Protected method GetFieldByInt
Gets a field from the datareader by passing in the index of a field.
Protected method GetFieldByString
Gets a field from the datareader by passing in the name of the field.
Public method GetFrameCountInImage
The number of frames in the stream indicated by the imageStreamIndex
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageStreamCount
Gets the number of image streams in this database. Each stream can contain more than one frame.
Public method GetObjectData
Get the data to serialize for this object
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method Open
Opens a non-open connection
Public method Reset
Reset all caches of information. If you are storing anything that is a cached from the database, release it.
Protected method StoreEncryptedValue
Stores the value into the serialization info and encrypts it if requested.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.AddExtraParameters Method

DbCommandImageAccessorAddExtraParameters Method

Adds any extra parameters supplied by the user that are needed to run the command.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IDbCommand AddExtraParameters(
    IDbCommand cmd
)
Protected Overridable Function AddExtraParameters (
    cmd As IDbCommand
) As IDbCommand

Parameters

cmd
Type: System.DataIDbCommand
A command that will be used to call a stored procedure.

Return Value

Type: IDbCommand
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.CreateGetFrameCountCommand Method

DbCommandImageAccessorCreateGetFrameCountCommand Method

A command that returns the frame count for an image. If this method returns null, the frame count will be determined by decoding the image stream. If not null, this command should result in a single row dataset with the frame count in the first column. If the frame count is stored separately from the image stream, implementing this method can greatly increase performance (especially first access). This command should not be associated with any connection.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IDbCommand CreateGetFrameCountCommand(
    IDbConnection conn,
    int imageStreamIndex
)
Protected Overridable Function CreateGetFrameCountCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.
imageStreamIndex
Type: SystemInt32
The index of the image stream in the source.

Return Value

Type: IDbCommand
A command that returns the frame count for an image.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.CreateGetImageRowCommand Method

DbCommandImageAccessorCreateGetImageRowCommand Method

A method that can return a command that gets a single row dataset with the image stream information at the given index. The field can either be a varbinary, binary or image type (in which case the image stream is the value of the field) or it can be a string which will be interpreted as a filename that contains the image. The command should not be associated with a connection.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract IDbCommand CreateGetImageRowCommand(
    IDbConnection conn,
    int imageStreamIndex
)
Protected MustOverride Function CreateGetImageRowCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.
imageStreamIndex
Type: SystemInt32
The index of the image stream.

Return Value

Type: IDbCommand
A command that will a single row with the image stream information.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.CreateGetImageStreamCountCommand Method

DbCommandImageAccessorCreateGetImageStreamCountCommand Method

A command that can get the number of image streams in the source (each of which can contain multiple frames). This command should just return the number of streams (not the total frame count). The command should result in a single row dataset with the count in the first column. The command should not be associated with a connection.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract IDbCommand CreateGetImageStreamCountCommand(
    IDbConnection conn
)
Protected MustOverride Function CreateGetImageStreamCountCommand (
    conn As IDbConnection
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.

Return Value

Type: IDbCommand
A command that can get the number of image streams in the source.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.CreateStreamFromDatabaseObject Method

DbCommandImageAccessorCreateStreamFromDatabaseObject Method

Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Stream CreateStreamFromDatabaseObject(
    Object o
)
Protected Overridable Function CreateStreamFromDatabaseObject (
    o As Object
) As Stream

Parameters

o
Type: SystemObject
An object that represents an image stream.

Return Value

Type: Stream
An open stream that contains an image.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.DecryptIfRequested Method

DbCommandImageAccessorDecryptIfRequested Method

Decrypt a string if EncryptSerializedState is true.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string DecryptIfRequested(
    byte[] data
)
Protected Overridable Function DecryptIfRequested (
    data As Byte()
) As String

Parameters

data
Type: SystemByte
The encrypted string.

Return Value

Type: String
The decryted string.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.EncryptIfRequested Method

DbCommandImageAccessorEncryptIfRequested Method

Encrypt a string if EncryptSerializedState is true.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual byte[] EncryptIfRequested(
    string s
)
Protected Overridable Function EncryptIfRequested (
    s As String
) As Byte()

Parameters

s
Type: SystemString
The string to encrypt

Return Value

Type: Byte
The encrypted string.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.ExtractImageStream Method

DbCommandImageAccessorExtractImageStream Method

Extracts a stream from a row of the database.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Stream ExtractImageStream(
    int imageStreamIndex
)
Public Overridable Function ExtractImageStream (
    imageStreamIndex As Integer
) As Stream

Parameters

imageStreamIndex
Type: SystemInt32
The index of the stream in the source

Return Value

Type: Stream
A stream representing the contents of the image

Implements

IDbImageAccessorExtractImageStream(Int32)
Remarks

This function is implemented for DbImageSource to use.

The field can either be a blob, image or string. If it is a string, it is interpreted as a filename and the filestream is opened. In order to get a connection to the database, the getConnection callback will be called -- the connection returned doesn't have to be opened (it will be opened when necessary), but this function will definitely close it before it returns. This method will use the property ImageFieldName to determine the column name of the image stream information. If that method returns null, it will assume that the information is in the first column.

See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetDatabaseObject Method

DbCommandImageAccessorGetDatabaseObject Method

Overload List
Name Description
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
Top
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetDatabaseObject Method (IDbCommand, Int32)

DbCommandImageAccessorGetDatabaseObject Method (IDbCommand, Int32)

Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object GetDatabaseObject(
    IDbCommand cmd,
    int index
)
Protected Overridable Function GetDatabaseObject (
    cmd As IDbCommand,
    index As Integer
) As Object

Parameters

cmd
Type: System.DataIDbCommand
The command to use to get the data set.
index
Type: SystemInt32
The index of the field to return.

Return Value

Type: Object
The value of the field at
Copy
index
in the first row of the dataset returned by the command.
See Also

Reference

DbCommandImageAccessor Class
GetDatabaseObject Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetDatabaseObject Method (IDbCommand, String)

DbCommandImageAccessorGetDatabaseObject Method (IDbCommand, String)

Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object GetDatabaseObject(
    IDbCommand cmd,
    string field
)
Protected Overridable Function GetDatabaseObject (
    cmd As IDbCommand,
    field As String
) As Object

Parameters

cmd
Type: System.DataIDbCommand
The command to use to get the data set.
field
Type: SystemString
The name of the field to return.

Return Value

Type: Object
The value of the given field in the first row of the dataset returned by the command.
See Also

Reference

DbCommandImageAccessor Class
GetDatabaseObject Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetDatabaseObject Method (IDbCommand, DbCommandImageAccessor.FieldGetter, Object)

DbCommandImageAccessorGetDatabaseObject Method (IDbCommand, DbCommandImageAccessorFieldGetter, Object)

Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object GetDatabaseObject(
    IDbCommand cmd,
    DbCommandImageAccessorFieldGetter fieldGetter,
    Object index
)
Protected Overridable Function GetDatabaseObject (
    cmd As IDbCommand,
    fieldGetter As DbCommandImageAccessorFieldGetter,
    index As Object
) As Object

Parameters

cmd
Type: System.DataIDbCommand
The command to use to get the data set.
fieldGetter
Type: Atalasoft.Imaging.ImageSources.DataDbCommandImageAccessorFieldGetter
A delegate that can get the field using the
Copy
index
.
index
Type: SystemObject
An object that can be used to determine which field to get (by passing it to fieldGetter).

Return Value

Type: Object
The value of the field refered to by index.
See Also

Reference

DbCommandImageAccessor Class
GetDatabaseObject Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetDecryptedValue Method

DbCommandImageAccessorGetDecryptedValue Method

Gets the value from the serialized data and decrypts it if requested.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string GetDecryptedValue(
    string key,
    SerializationInfo info,
    StreamingContext context
)
Protected Overridable Function GetDecryptedValue (
    key As String,
    info As SerializationInfo,
    context As StreamingContext
) As String

Parameters

key
Type: SystemString
The key of the data value.
info
Type: System.Runtime.SerializationSerializationInfo
The serialized data.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.

Return Value

Type: String
The decrypted data.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetFieldByInt Method

DbCommandImageAccessorGetFieldByInt Method

Gets a field from the datareader by passing in the index of a field.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object GetFieldByInt(
    IDataReader dr,
    Object intIndex
)
Protected Overridable Function GetFieldByInt (
    dr As IDataReader,
    intIndex As Object
) As Object

Parameters

dr
Type: System.DataIDataReader
A datareader set to a row.
intIndex
Type: SystemObject
The index of the column in the row to return.

Return Value

Type: Object
The value of the field at index
Copy
intIndex
.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetFieldByString Method

DbCommandImageAccessorGetFieldByString Method

Gets a field from the datareader by passing in the name of the field.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object GetFieldByString(
    IDataReader dr,
    Object fieldName
)
Protected Overridable Function GetFieldByString (
    dr As IDataReader,
    fieldName As Object
) As Object

Parameters

dr
Type: System.DataIDataReader
A datareader set to a row.
fieldName
Type: SystemObject
Name of the field.

Return Value

Type: Object
The value of the field named
Copy
fieldName
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetFrameCountInImage Method

DbCommandImageAccessorGetFrameCountInImage Method

The number of frames in the stream indicated by the imageStreamIndex

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int GetFrameCountInImage(
    int imageStreamIndex,
    DbImageSourceFrameCounter frameCounterFn
)
Public Overridable Function GetFrameCountInImage (
    imageStreamIndex As Integer,
    frameCounterFn As DbImageSourceFrameCounter
) As Integer

Parameters

imageStreamIndex
Type: SystemInt32
The index of the stream in the source. This is guaranteed to be in the range of: 0 < imageStreamIndex <= GetImageStreamCount()
frameCounterFn
Type: Atalasoft.Imaging.ImageSourcesDbImageSourceFrameCounter
A delegate that can count the number of frames in a stream, which you can use if you haven't stored the framecount elsewhere. To speed performance, it might be better to store the frame count in the data store and not use this delegate.

Return Value

Type: Int32
The number of frames in the stream indicated by the imageStreamIndex

Implements

IDbImageAccessorGetFrameCountInImage(Int32, DbImageSourceFrameCounter)
Remarks
This function is implemented for DbImageSource to use.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetImageStreamCount Method

DbCommandImageAccessorGetImageStreamCount Method

Gets the number of image streams in this database. Each stream can contain more than one frame.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int GetImageStreamCount()
Public Overridable Function GetImageStreamCount As Integer

Return Value

Type: Int32
The number of image stream in this database.

Implements

IDbImageAccessorGetImageStreamCount
Remarks
This function is implemented for DbImageSource to use.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.GetObjectData Method

DbCommandImageAccessorGetObjectData Method

Get the data to serialize for this object

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information for this object to serialize
context
Type: System.Runtime.SerializationStreamingContext
The serialization context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.Open Method

DbCommandImageAccessorOpen Method

Opens a non-open connection

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IDbConnection Open(
    IDbConnection conn
)
Protected Overridable Function Open (
    conn As IDbConnection
) As IDbConnection

Parameters

conn
Type: System.DataIDbConnection
A connection

Return Value

Type: IDbConnection
An open connection
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.Reset Method

DbCommandImageAccessorReset Method

Reset all caches of information. If you are storing anything that is a cached from the database, release it.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Reset()
Public Overridable Sub Reset

Implements

IDbImageAccessorReset
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.StoreEncryptedValue Method

DbCommandImageAccessorStoreEncryptedValue Method

Stores the value into the serialization info and encrypts it if requested.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void StoreEncryptedValue(
    string key,
    string theValue,
    SerializationInfo info,
    StreamingContext context
)
Protected Overridable Sub StoreEncryptedValue (
    key As String,
    theValue As String,
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

key
Type: SystemString
The key of the data value.
theValue
Type: SystemString
The value to store.
info
Type: System.Runtime.SerializationSerializationInfo
The object that contains the serialized data.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.
See Also

Reference

DbCommandImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbCommandImageAccessor.FieldGetter Delegate

DbCommandImageAccessorFieldGetter Delegate

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected delegate Object FieldGetter(
    IDataReader dr,
    Object accessor
)
Protected Delegate Function FieldGetter (
    dr As IDataReader,
    accessor As Object
) As Object

Parameters

dr
Type: System.DataIDataReader
The dr.
accessor
Type: SystemObject
The accessor.

Return Value

Type: Object
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Class

This class can access images for DbImageSource from clauses of SQL statements that are provided.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageSources.DataDbCommandImageAccessor
Atalasoft.Imaging.ImageSources.DataDbSqlImageAccessor

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DbSqlImageAccessor : DbCommandImageAccessor
<SerializableAttribute>
Public Class DbSqlImageAccessor
    Inherits DbCommandImageAccessor

The DbSqlImageAccessor type exposes the following members.

Constructors
 | Name | Description
Protected method | DbSqlImageAccessor(SerializationInfo, StreamingContext) | From ISerializable. All properties are encrypted if encryptSerializedState was set to true in the constructor. They are encrypted using the encryptor
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String, String, String, IDictionary) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Top
Properties
 | Name | Description
Public property | Decryptor | A delegate that can decrypt a string. (Inherited from DbCommandImageAccessor.)
Public property | Encryptor | A delegate that can encrypt a string. (Inherited from DbCommandImageAccessor.)
Public property | EncryptSerializedState | Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted. (Inherited from DbCommandImageAccessor.)
Public property | ExtraParameters | A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed. (Inherited from DbCommandImageAccessor.)
Public property | FrameCountField | The name of the frame count field in the data source
Public property | FromClause | The table that contains the images (or any valid from clause)
Protected property | GetConnection | A delegate that can return a connection to the database. (Inherited from DbCommandImageAccessor.)
Public property | ImageField | The name of the image field in the data source
Protected property | ImageFieldName | Returns the name of the field that contains the image stream information. If the field is an expression it must contain an as clause that names the field. (Overrides DbCommandImageAccessorImageFieldName.)
Protected property | NonBlankOrderByClause | Returns either the given order by clause or the primary keys if that is blank
Protected property | NonBlankWhereClause | Returns either the given where clause or a clause that is always true, if that is blank
Public property | OrderByClause | A valid SQL order by clause or null if the dataset should be ordered by the primary keys
Public property | PrimaryKeyFields | The commas separated list of fields that make up the primary key of the data source
Public property | WhereClause | A valid SQL where clause or null if all rows are to be used.
Top
Methods
Name Description
Protected method AddExtraParameters
Adds any extra parameters supplied by the user that are needed to run the command.
(Inherited from DbCommandImageAccessor.)
Protected method CreateGetFieldCommand
Creates a command that can get the given field from the row indexed by imageStreamIndex from the datasource.
Protected method CreateGetFrameCountCommand
A command that returns the frame count for an image. If this method returns null, the frame count will be determined by decoding the image stream. If not null, this command should result in a single row dataset with the frame count in the first column. If the frame count is stored separately from the image stream, implementing this method can greatly increase performance (especially first access). This command should not be associated with any connection.
(Overrides DbCommandImageAccessorCreateGetFrameCountCommand(IDbConnection, Int32).)
Protected method CreateGetImageRowCommand
A method that can return a command that gets a single row dataset with the image stream information at the given index. The field can either be a varbinary, binary or image type (in which case the image stream is the value of the field) or it can be a string which will be interpreted as a filename that contains the image. The command should not be associated with a connection.
(Overrides DbCommandImageAccessorCreateGetImageRowCommand(IDbConnection, Int32).)
Protected method CreateGetImageStreamCountCommand
A command that can get the number of image streams in the source (each of which can contain multiple frames). This command should just return the number of streams (not the total frame count). The command should result in a single row dataset with the count in the first column. The command should not be associated with a connection.
(Overrides DbCommandImageAccessorCreateGetImageStreamCountCommand(IDbConnection).)
Protected method CreateGetImageStreamCountQuery
Creates a SQL statement that can count the number of image streams. The count should be in the first column of the first row of the returned rows.
Protected method CreateSelectFieldByRowQuery
Creates a SQL Query using Common Table Expressions that can get a specific row by index from a data source.
Protected method CreateStreamFromDatabaseObject
Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.
(Inherited from DbCommandImageAccessor.)
Protected method DecryptIfRequested
Decrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Protected method EncryptIfRequested
Encrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExtractImageStream
Extracts a stream from a row of the database.
(Inherited from DbCommandImageAccessor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
(Inherited from DbCommandImageAccessor.)
Protected method GetDecryptedValue
Gets the value from the serialized data and decrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByInt
Gets a field from the datareader by passing in the index of a field.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByString
Gets a field from the datareader by passing in the name of the field.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldNameFromExpression
Takes SQL field clause and returns the name of the column.
Public method GetFrameCountInImage
The number of frames in the stream indicated by the imageStreamIndex
(Inherited from DbCommandImageAccessor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageStreamCount
Gets the number of image streams in this database. Each stream can contain more than one frame.
(Inherited from DbCommandImageAccessor.)
Public method GetObjectData
Get the data to serialize for this object
(Overrides DbCommandImageAccessorGetObjectData(SerializationInfo, StreamingContext).)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method Open
Opens a non-open connection
(Inherited from DbCommandImageAccessor.)
Public method Reset
Reset all caches of information. If you are storing anything that is a cached from the database, release it.
(Inherited from DbCommandImageAccessor.)
Protected method StoreEncryptedValue
Stores the value into the serialization info and encrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor

Constructors for DbSqlImageAccessor
Overload List
 | Name | Description
Protected method | DbSqlImageAccessor(SerializationInfo, StreamingContext) | From ISerializable. All properties are encrypted if encryptSerializedState was set to true in the constructor. They are encrypted using the encryptor
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String, String, String) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Public method | DbSqlImageAccessor(GetConnectionCallback, Boolean, String, String, String, String, String, String, IDictionary) | Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.
Top
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor (SerializationInfo, StreamingContext)

From ISerializable. All properties are encrypted if encryptSerializedState was set to true in the constructor. They are encrypted using the encryptor

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DbSqlImageAccessor(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information to deserialize.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.
See Also

Reference

DbSqlImageAccessor Class
DbSqlImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, String)

Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbSqlImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string imageField,
    string primaryKeyFields,
    string fromClause
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    imageField As String,
    primaryKeyFields As String,
    fromClause As String
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized. This class creates SQL statements that use CTE from SQL Server, so the connection needs to be to a database that supports them.
encryptSerializedState
Type: SystemBoolean
True if the serialized state of the object will be encrypted. Please see documentation of sub-classes to see which members are encrypted.
imageField
Type: SystemString
The name of the image field in the data source (given by the FromClause). Can be an expression, but then an "as" with a field name must appear at the end of it.
primaryKeyFields
Type: SystemString
A comma separated list of the primary keys of the data source (given by the
Copy
fromClause
).
fromClause
Type: SystemString
The source of the data rows. This would normally be a table name, but it can be anything that can appear in the from clause of a SQL Select statement. It should not contain "from" at the beginning.
See Also

Reference

DbSqlImageAccessor Class
DbSqlImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, String, String)

Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbSqlImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string imageField,
    string primaryKeyFields,
    string fromClause,
    string whereClause
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    imageField As String,
    primaryKeyFields As String,
    fromClause As String,
    whereClause As String
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized. This class creates SQL statements that use CTE from SQL Server, so the connection needs to be to a database that supports them.
encryptSerializedState
Type: SystemBoolean
True if the serialized state of the object will be encrypted. Please see documentation of sub-classes to see which members are encrypted.
imageField
Type: SystemString
The name of the image field in the data source (given by the fromClause). Can be an expression, but then an "as" with a field name must appear at the end of it.
primaryKeyFields
Type: SystemString
A comma separated list of the primary keys of the data source (given by the
Copy
fromClause
).
fromClause
Type: SystemString
The source of the data rows. This would normally be a table name, but it can be anything that can appear in the from clause of a SQL Select statement. It should not contain "from" at the beginning.
whereClause
Type: SystemString
A clause that can be used in a where clause of a SQL Select statement. It can be null, which means that you want all rows to be returned. It should not contain "where" at the beginning.
See Also

Reference

DbSqlImageAccessor Class
DbSqlImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, String, String, String)

Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbSqlImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string imageField,
    string primaryKeyFields,
    string fromClause,
    string whereClause,
    string orderByClause
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    imageField As String,
    primaryKeyFields As String,
    fromClause As String,
    whereClause As String,
    orderByClause As String
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized. This class creates SQL statements that use CTE from SQL Server, so the connection needs to be to a database that supports them.
encryptSerializedState
Type: SystemBoolean
True if the serialized state of the object will be encrypted. Please see documentation of sub-classes to see which members are encrypted.
imageField
Type: SystemString
The name of the image field in the data source (given by the
Copy
fromClause
). Can be an expression, but then an "as" with a field name must appear at the end of it.
primaryKeyFields
Type: SystemString
A comma separated list of the primary keys of the data source (given by the
Copy
fromClause
).
fromClause
Type: SystemString
The source of the data rows. This would normally be a table name, but it can be anything that can appear in the from clause of a SQL Select statement. It should not contain "from" at the beginning.
whereClause
Type: SystemString
A clause that can be used in a where clause of a SQL Select statement. It can be null, which means that you want all rows to be returned. It should not contain "where" at the beginning.
orderByClause
Type: SystemString
A clause that can be used in an order by clause. If it is null, the data set is ordered by the primary keys. The dataset must have a defined order. It should not contain "order by" at the beginning.
See Also

Reference

DbSqlImageAccessor Class
DbSqlImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, String, String, String, String)

Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbSqlImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string imageField,
    string primaryKeyFields,
    string fromClause,
    string whereClause,
    string orderByClause,
    string frameCountField
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    imageField As String,
    primaryKeyFields As String,
    fromClause As String,
    whereClause As String,
    orderByClause As String,
    frameCountField As String
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized. This class creates SQL statements that use CTE from SQL Server, so the connection needs to be to a database that supports them.
encryptSerializedState
Type: SystemBoolean
True if the serialized state of the object will be encrypted. Please see documentation of sub-classes to see which members are encrypted.
imageField
Type: SystemString
The name of the image field in the data source (given by the fromClause). Can be an expression, but then an "as" with a field name must appear at the end of it.
primaryKeyFields
Type: SystemString
A comma separated list of the primary keys of the data source (given by the fromClause).
fromClause
Type: SystemString
The source of the data rows. This would normally be a table name, but it can be anything that can appear in the from clause of a SQL Select statement. It should not contain "from" at the beginning.
whereClause
Type: SystemString
A clause that can be used in a where clause of a SQL Select statement. It can be null, which means that you want all rows to be returned. It should not contain "where" at the beginning.
orderByClause
Type: SystemString
A clause that can be used in an order by clause. If it is null, the data set is ordered by the primary keys. The dataset must have a defined order. It should not contain "order by" at the beginning.
frameCountField
Type: SystemString
The name of the frameCount field in the data source (given by the fromClause. If it is null, the frame count will be determined by decoding the image stream.
See Also

Reference

DbSqlImageAccessor Class
DbSqlImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, String, String, String, String, IDictionary)

Creates an object that can be used with DbImageSource to access images stored in a database. The image streams are access by combining clauses of SQL Statements provided.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbSqlImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string imageField,
    string primaryKeyFields,
    string fromClause,
    string whereClause,
    string orderByClause,
    string frameCountField,
    IDictionary extraParameters
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    imageField As String,
    primaryKeyFields As String,
    fromClause As String,
    whereClause As String,
    orderByClause As String,
    frameCountField As String,
    extraParameters As IDictionary
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized. This class creates SQL statements that use CTE from SQL Server, so the connection needs to be to a database that supports them.
encryptSerializedState
Type: SystemBoolean
True if the serialized state of the object will be encrypted. Please see documentation of sub-classes to see which members are encrypted.
imageField
Type: SystemString
The name of the image field in the data source (given by the fromClause). Can be an expression, but then an "as" with a field name must appear at the end of it.
primaryKeyFields
Type: SystemString
A comma separated list of the primary keys of the data source (given by the fromClause).
fromClause
Type: SystemString
The source of the data rows. This would normally be a table name, but it can be anything that can appear in the from clause of a SQL Select statement. It should not contain "from" at the beginning.
whereClause
Type: SystemString
A clause that can be used in a where clause of a SQL Select statement. It can be null, which means that you want all rows to be returned. It should not contain "where" at the beginning.
orderByClause
Type: SystemString
A clause that can be used in an order by clause. If it is null, the data set is ordered by the primary keys. The dataset must have a defined order. It should not contain "order by" at the beginning.
frameCountField
Type: SystemString
The name of the frameCount field in the data source (given by the fromClause>. If it is null, the frame count will be determined by decoding the image stream.
extraParameters
Type: System.CollectionsIDictionary
The parameters that are passed to all of your stored procedures. For SqlCommands, the keys should be strings which are the names of the parameters and start with an @. For OleDbCommands, you must use a IDictionary with sorted keys (e.g. SortedList) and use index numbers (starting at 0) as keys. The parameters are added in the sort order of the keys. The values can be any object that can be automatically converted by the IDbDataParameter for your connection. The
Copy
extraParameters
are not encrypted when this object is serialized. A copy of the the dictionary will be made upon construction, so that changes to it will not affect this object.
See Also

Reference

DbSqlImageAccessor Class
DbSqlImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Properties

The DbSqlImageAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Decryptor | A delegate that can decrypt a string. (Inherited from DbCommandImageAccessor.)
Public property | Encryptor | A delegate that can encrypt a string. (Inherited from DbCommandImageAccessor.)
Public property | EncryptSerializedState | Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted. (Inherited from DbCommandImageAccessor.)
Public property | ExtraParameters | A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed. (Inherited from DbCommandImageAccessor.)
Public property | FrameCountField | The name of the frame count field in the data source
Public property | FromClause | The table that contains the images (or any valid from clause)
Protected property | GetConnection | A delegate that can return a connection to the database. (Inherited from DbCommandImageAccessor.)
Public property | ImageField | The name of the image field in the data source
Protected property | ImageFieldName | Returns the name of the field that contains the image stream information. If the field is an expression it must contain an as clause that names the field. (Overrides DbCommandImageAccessorImageFieldName.)
Protected property | NonBlankOrderByClause | Returns either the given order by clause or the primary keys if that is blank
Protected property | NonBlankWhereClause | Returns either the given where clause or a clause that is always true, if that is blank
Public property | OrderByClause | A valid SQL order by clause or null if the dataset should be ordered by the primary keys
Public property | PrimaryKeyFields | The commas separated list of fields that make up the primary key of the data source
Public property | WhereClause | A valid SQL where clause or null if all rows are to be used.
Top
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.FrameCountField Property

DbSqlImageAccessorFrameCountField Property

The name of the frame count field in the data source

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FrameCountField { get; }
Public ReadOnly Property FrameCountField As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.FromClause Property

DbSqlImageAccessorFromClause Property

The table that contains the images (or any valid from clause)

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FromClause { get; }
Public ReadOnly Property FromClause As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.ImageField Property

DbSqlImageAccessorImageField Property

The name of the image field in the data source

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageField { get; }
Public ReadOnly Property ImageField As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.ImageFieldName Property

DbSqlImageAccessorImageFieldName Property

Returns the name of the field that contains the image stream information. If the field is an expression it must contain an as clause that names the field.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string ImageFieldName { get; }
Protected Overrides ReadOnly Property ImageFieldName As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.NonBlankOrderByClause Property

DbSqlImageAccessorNonBlankOrderByClause Property

Returns either the given order by clause or the primary keys if that is blank

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string NonBlankOrderByClause { get; }
Protected ReadOnly Property NonBlankOrderByClause As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.NonBlankWhereClause Property

DbSqlImageAccessorNonBlankWhereClause Property

Returns either the given where clause or a clause that is always true, if that is blank

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string NonBlankWhereClause { get; }
Protected ReadOnly Property NonBlankWhereClause As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.OrderByClause Property

DbSqlImageAccessorOrderByClause Property

A valid SQL order by clause or null if the dataset should be ordered by the primary keys

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OrderByClause { get; }
Public ReadOnly Property OrderByClause As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.PrimaryKeyFields Property

DbSqlImageAccessorPrimaryKeyFields Property

The commas separated list of fields that make up the primary key of the data source

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PrimaryKeyFields { get; }
Public ReadOnly Property PrimaryKeyFields As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.WhereClause Property

DbSqlImageAccessorWhereClause Property

A valid SQL where clause or null if all rows are to be used.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string WhereClause { get; }
Public ReadOnly Property WhereClause As String
    Get

Property Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor Methods

The DbSqlImageAccessor type exposes the following members.

Methods
Name Description
Protected method AddExtraParameters
Adds any extra parameters supplied by the user that are needed to run the command.
(Inherited from DbCommandImageAccessor.)
Protected method CreateGetFieldCommand
Creates a command that can get the given field from the row indexed by imageStreamIndex from the datasource.
Protected method CreateGetFrameCountCommand
A command that returns the frame count for an image. If this method returns null, the frame count will be determined by decoding the image stream. If not null, this command should result in a single row dataset with the frame count in the first column. If the frame count is stored separately from the image stream, implementing this method can greatly increase performance (especially first access). This command should not be associated with any connection.
(Overrides DbCommandImageAccessorCreateGetFrameCountCommand(IDbConnection, Int32).)
Protected method CreateGetImageRowCommand
A method that can return a command that gets a single row dataset with the image stream information at the given index. The field can either be a varbinary, binary or image type (in which case the image stream is the value of the field) or it can be a string which will be interpreted as a filename that contains the image. The command should not be associated with a connection.
(Overrides DbCommandImageAccessorCreateGetImageRowCommand(IDbConnection, Int32).)
Protected method CreateGetImageStreamCountCommand
A command that can get the number of image streams in the source (each of which can contain multiple frames). This command should just return the number of streams (not the total frame count). The command should result in a single row dataset with the count in the first column. The command should not be associated with a connection.
(Overrides DbCommandImageAccessorCreateGetImageStreamCountCommand(IDbConnection).)
Protected method CreateGetImageStreamCountQuery
Creates a SQL statement that can count the number of image streams. The count should be in the first column of the first row of the returned rows.
Protected method CreateSelectFieldByRowQuery
Creates a SQL Query using Common Table Expressions that can get a specific row by index from a data source.
Protected method CreateStreamFromDatabaseObject
Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.
(Inherited from DbCommandImageAccessor.)
Protected method DecryptIfRequested
Decrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Protected method EncryptIfRequested
Encrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExtractImageStream
Extracts a stream from a row of the database.
(Inherited from DbCommandImageAccessor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
(Inherited from DbCommandImageAccessor.)
Protected method GetDecryptedValue
Gets the value from the serialized data and decrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByInt
Gets a field from the datareader by passing in the index of a field.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByString
Gets a field from the datareader by passing in the name of the field.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldNameFromExpression
Takes SQL field clause and returns the name of the column.
Public method GetFrameCountInImage
The number of frames in the stream indicated by the imageStreamIndex
(Inherited from DbCommandImageAccessor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageStreamCount
Gets the number of image streams in this database. Each stream can contain more than one frame.
(Inherited from DbCommandImageAccessor.)
Public method GetObjectData
Get the data to serialize for this object
(Overrides DbCommandImageAccessorGetObjectData(SerializationInfo, StreamingContext).)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method Open
Opens a non-open connection
(Inherited from DbCommandImageAccessor.)
Public method Reset
Reset all caches of information. If you are storing anything that is a cached from the database, release it.
(Inherited from DbCommandImageAccessor.)
Protected method StoreEncryptedValue
Stores the value into the serialization info and encrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.CreateGetFieldCommand Method

DbSqlImageAccessorCreateGetFieldCommand Method

Creates a command that can get the given field from the row indexed by imageStreamIndex from the datasource.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IDbCommand CreateGetFieldCommand(
    IDbConnection conn,
    int imageStreamIndex,
    string field
)
Protected Overridable Function CreateGetFieldCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer,
    field As String
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database
imageStreamIndex
Type: SystemInt32
The index of the image stream in the datasource.
field
Type: SystemString
The name of the column in the data source that the command should try to get.

Return Value

Type: IDbCommand
A command that gets the given field from a row at index imageStreamIndex from the datasource.
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.CreateGetFrameCountCommand Method

DbSqlImageAccessorCreateGetFrameCountCommand Method

A command that returns the frame count for an image. If this method returns null, the frame count will be determined by decoding the image stream. If not null, this command should result in a single row dataset with the frame count in the first column. If the frame count is stored separately from the image stream, implementing this method can greatly increase performance (especially first access). This command should not be associated with any connection.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IDbCommand CreateGetFrameCountCommand(
    IDbConnection conn,
    int imageStreamIndex
)
Protected Overrides Function CreateGetFrameCountCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.
imageStreamIndex
Type: SystemInt32
The index of the image stream in the source.

Return Value

Type: IDbCommand
A command that returns the frame count for an image.
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.CreateGetImageRowCommand Method

DbSqlImageAccessorCreateGetImageRowCommand Method

A method that can return a command that gets a single row dataset with the image stream information at the given index. The field can either be a varbinary, binary or image type (in which case the image stream is the value of the field) or it can be a string which will be interpreted as a filename that contains the image. The command should not be associated with a connection.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IDbCommand CreateGetImageRowCommand(
    IDbConnection conn,
    int imageStreamIndex
)
Protected Overrides Function CreateGetImageRowCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.
imageStreamIndex
Type: SystemInt32
The index of the image stream.

Return Value

Type: IDbCommand
A command that will a single row with the image stream information.
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.CreateGetImageStreamCountCommand Method

DbSqlImageAccessorCreateGetImageStreamCountCommand Method

A command that can get the number of image streams in the source (each of which can contain multiple frames). This command should just return the number of streams (not the total frame count). The command should result in a single row dataset with the count in the first column. The command should not be associated with a connection.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IDbCommand CreateGetImageStreamCountCommand(
    IDbConnection conn
)
Protected Overrides Function CreateGetImageStreamCountCommand (
    conn As IDbConnection
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.

Return Value

Type: IDbCommand
A command that can get the number of image streams in the source.
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.CreateGetImageStreamCountQuery Method

DbSqlImageAccessorCreateGetImageStreamCountQuery Method

Creates a SQL statement that can count the number of image streams. The count should be in the first column of the first row of the returned rows.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string CreateGetImageStreamCountQuery()
Protected Overridable Function CreateGetImageStreamCountQuery As String

Return Value

Type: String
A SQL statement that counts the number of image streams.
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.CreateSelectFieldByRowQuery Method

DbSqlImageAccessorCreateSelectFieldByRowQuery Method

Creates a SQL Query using Common Table Expressions that can get a specific row by index from a data source.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string CreateSelectFieldByRowQuery(
    string imageStreamIndexParamName,
    string field
)
Protected Overridable Function CreateSelectFieldByRowQuery (
    imageStreamIndexParamName As String,
    field As String
) As String

Parameters

imageStreamIndexParamName
Type: SystemString
The name of the parameter to use to contain the requested index (so that it can be provided later by a Parameter)
field
Type: SystemString
The field that is being requested from the datasouce (must appear in the result of the query)

Return Value

Type: String
A SQL statement that will take a parameter named imageStreamIndexParamName and will contain a field named field.
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.GetFieldNameFromExpression Method

DbSqlImageAccessorGetFieldNameFromExpression Method

Takes SQL field clause and returns the name of the column.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string GetFieldNameFromExpression(
    string expr
)
Protected Overridable Function GetFieldNameFromExpression (
    expr As String
) As String

Parameters

expr
Type: SystemString
The SQL field clause

Return Value

Type: String
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbSqlImageAccessor.GetObjectData Method

DbSqlImageAccessorGetObjectData Method

Get the data to serialize for this object

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information for this object to serialize
context
Type: System.Runtime.SerializationStreamingContext
The serialization context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DbSqlImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Class

This class can be used with IDbImageSource to get images from a database through Stored Procedures. The Stored Procedures to call can be specified in the constructor and the only requirement is that they meet certain specifications as described in the constructor parameter documentation.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.ImageSources.DataDbCommandImageAccessor
Atalasoft.Imaging.ImageSources.DataDbStoredProcImageAccessor

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DbStoredProcImageAccessor : DbCommandImageAccessor
<SerializableAttribute>
Public Class DbStoredProcImageAccessor
    Inherits DbCommandImageAccessor

The DbStoredProcImageAccessor type exposes the following members.

Constructors
 | Name | Description
Protected method | DbStoredProcImageAccessor(SerializationInfo, StreamingContext) | From ISerializable. All properties are encrypted if encryptSerializedState was set to true in the constructor. They are encrypted using the encryptor
Public method | DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) | Construct an accessor that can access images in a database via stored procedures
Public method | DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, String, IDictionary) | Construct an accessor that can access images in a database via stored procedures
Top
Properties
Name Description
Public property Decryptor
A delegate that can decrypt a string.
(Inherited from DbCommandImageAccessor.)
Public property Encryptor
A delegate that can encrypt a string.
(Inherited from DbCommandImageAccessor.)
Public property EncryptSerializedState
Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted.
(Inherited from DbCommandImageAccessor.)
Public property ExtraParameters
A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed.
(Inherited from DbCommandImageAccessor.)
Protected property GetConnection
A delegate that can return a connection to the database.
(Inherited from DbCommandImageAccessor.)
Public property GetFrameCountByIndexProc
The name of the stored procedure that will be used to access the frame count of an image stream. It must take a parameter called index and return a single row dataset with the frame count as the first column. It may also take extra parameters. DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) for an example of a valid stored procedure.
Public property GetImageByIndexProc
The name of the stored procedure that will be used to access image streams. It must take a parameter called index and return a single row dataset with the image stream as the first column. It may also take extra parameters.
Public property GetImageStreamCountProc
The name of the stored procedure that will be used to access the count of image streams. It must take return a single row dataset with the image stream as the first column. It may also take extra parameters. DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) for an example of a valid stored procedure.
Protected property ImageFieldName
The name of the image field in the dataset returned by
Copy
CreateGetImageRowCommand
. If this method returns null, it is assumed to be in the first column.
(Inherited from DbCommandImageAccessor.)
Top
Methods
Name Description
Protected method AddExtraParameters
Adds any extra parameters supplied by the user that are needed to run the command.
(Inherited from DbCommandImageAccessor.)
Protected method CreateGetFrameCountCommand
Creates a command that can get the frame count of an image stream.
(Overrides DbCommandImageAccessorCreateGetFrameCountCommand(IDbConnection, Int32).)
Protected method CreateGetImageRowCommand
Creates a command that can get a single row dataset with the image stream information as the first column. It will pass in a parameter named index with the value of
Copy
imageStreamIndex
.
(Overrides DbCommandImageAccessorCreateGetImageRowCommand(IDbConnection, Int32).)
Protected method CreateGetImageStreamCountCommand
Creates a command that can get the count of image streams.
(Overrides DbCommandImageAccessorCreateGetImageStreamCountCommand(IDbConnection).)
Protected method CreateGetObjectByIndexCommand
Creates a command that can get an image related database object by calling the stored procedure, passing in the given imageStreamIndex.
Protected method CreateStoredProcCommand
Creates a command that can call the given stored procedure.
Protected method CreateStreamFromDatabaseObject
Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.
(Inherited from DbCommandImageAccessor.)
Protected method DecryptIfRequested
Decrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Protected method EncryptIfRequested
Encrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExtractImageStream
Extracts a stream from a row of the database.
(Inherited from DbCommandImageAccessor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
(Inherited from DbCommandImageAccessor.)
Protected method GetDecryptedValue
Gets the value from the serialized data and decrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByInt
Gets a field from the datareader by passing in the index of a field.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByString
Gets a field from the datareader by passing in the name of the field.
(Inherited from DbCommandImageAccessor.)
Public method GetFrameCountInImage
The number of frames in the stream indicated by the imageStreamIndex
(Inherited from DbCommandImageAccessor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageStreamCount
Gets the number of image streams in this database. Each stream can contain more than one frame.
(Inherited from DbCommandImageAccessor.)
Public method GetObjectData
Get the data to serialize for this object
(Overrides DbCommandImageAccessorGetObjectData(SerializationInfo, StreamingContext).)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method Open
Opens a non-open connection
(Inherited from DbCommandImageAccessor.)
Public method Reset
Reset all caches of information. If you are storing anything that is a cached from the database, release it.
(Inherited from DbCommandImageAccessor.)
Protected method StoreEncryptedValue
Stores the value into the serialization info and encrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Constructor

Constructors for DbStoredProcImageAccessor
Overload List
 | Name | Description
Protected method | DbStoredProcImageAccessor(SerializationInfo, StreamingContext) | From ISerializable. All properties are encrypted if encryptSerializedState was set to true in the constructor. They are encrypted using the encryptor
Public method | DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) | Construct an accessor that can access images in a database via stored procedures
Public method | DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, String, IDictionary) | Construct an accessor that can access images in a database via stored procedures
Top
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Constructor (SerializationInfo, StreamingContext)

From ISerializable. All properties are encrypted if encryptSerializedState was set to true in the constructor. They are encrypted using the encryptor

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DbStoredProcImageAccessor(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization info which contains the serialized data.
context
Type: System.Runtime.SerializationStreamingContext
The serialization context.
See Also

Reference

DbStoredProcImageAccessor Class
DbStoredProcImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, IDictionary)

Construct an accessor that can access images in a database via stored procedures

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbStoredProcImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string getImageByIndexProc,
    string getImageStreamCountProc,
    IDictionary extraParameters
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    getImageByIndexProc As String,
    getImageStreamCountProc As String,
    extraParameters As IDictionary
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized.
encryptSerializedState
Type: SystemBoolean
Set to true if you want the serialized state of this accessor to be encrypted. You must set the Encryptor and Decryptor properties to handle the decryption and encryption. The extraParameters are not encrypted when serialized.
getImageByIndexProc
Type: SystemString
The name of a stored procedure that can get an image by index. It should take an int parameter called "@index" and any other parameters you need, and return the image stream at that index. index is not a primary key into your table, but instead is a number in range of 0 to count-1, where count is gotten by calling the stored procedure named in the getImageStreamCountProc argument. If you take any extra parameters (aside from the index), you should specify their values by using the extraParameters argument. The stored procedure should result in a single row dataset where the first column is the image. It can either be an encoded image in a varbinary or image field or a string. If it is a string it is interpreted as a filename, which will be opened to get to the images.
getImageStreamCountProc
Type: SystemString
The name of a stored procedure that can get the number of image streams. There are no required parameters. The stored procedure should result in single row dataset with the count in the first column. If you need any extra parameters, you should specify their values by using the
Copy
extraParameters
argument.
extraParameters
Type: System.CollectionsIDictionary
The parameters that are passed to all of your stored procedures. For SqlCommands, the keys should be strings which are the names of the parameters and start with an @. For OleDbCommands, you must use a IDictionary with sorted keys (e.g. SortedList) and use index numbers (starting at 0) as keys. The parameters are added in the sort order of the keys. The values can be any object that can be automatically converted by the IDbDataParameter for your connection. The extraParameters are not encrypted when this object is serialized. A copy of the the dictionary will be made upon construction, so that changes to it will not affect this object.
Remarks
Here are some sample stored procedures that would work to get images from an table called images, where the data was stored in an field called imageData. Here is a stored procedure that would meet the specification for the getImageByIndexProc. @startId and @endId are extra parameters that would need to be passed in to the constructor.
Copy
create PROCEDURE GetImageByIndex
    @index int, @startId int, @endId int
as
    set nocount on;
    with istr as (
        select id, imagedata, row_number() over (order by id) as rn
        from images where id between @startid and @endid
    ) select imageData from istr where rn=(@index+1)
Here is a stored procedure that would meet the specification for the getImageStreamCountProc. @startId and @endId are extra parameters that would need to be passed in to the constructor.
Copy
create PROCEDURE GetImageStreamCount
    @startid int, @endid int
as
    set nocount on;
    select count(*) from images where id between @startid and @endid
Note: the extra parameters must be the same for all stored procedures.
See Also

Reference

DbStoredProcImageAccessor Class
DbStoredProcImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Constructor (GetConnectionCallback, Boolean, String, String, String, IDictionary)

Construct an accessor that can access images in a database via stored procedures

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DbStoredProcImageAccessor(
    GetConnectionCallback getConnection,
    bool encryptSerializedState,
    string getImageByIndexProc,
    string getImageStreamCountProc,
    string getFrameCountByIndexProc,
    IDictionary extraParameters
)
Public Sub New (
    getConnection As GetConnectionCallback,
    encryptSerializedState As Boolean,
    getImageByIndexProc As String,
    getImageStreamCountProc As String,
    getFrameCountByIndexProc As String,
    extraParameters As IDictionary
)

Parameters

getConnection
Type: Atalasoft.Imaging.ImageSources.DataGetConnectionCallback
A delegate that can return connections to the database. This accessor must be able to be serialized, so make the delegate to a static method. If this accessor is used in an imagesoruce that is used in ASP.NET controls, then it will be serialized.
encryptSerializedState
Type: SystemBoolean
Set to true if you want the serialized state of this accessor to be encrypted. You must set the Encryptor and Decryptor properties to handle the decryption and encryption. The
Copy
extraParameters
are not encrypted when serialized.
getImageByIndexProc
Type: SystemString
The name of a stored procedure that can get an image by index. It should take an int parameter called "@index" and any other parameters you need, and return the image stream at that index. @index is not a primary key into your table, but instead is a number in range of 0 to count-1, where count is gotten by calling the stored procedure named in the
Copy
getImageStreamCountProc
argument. If you take any extra parameters (aside from the index), you should specify their values by using the
Copy
extraParameters
argument. The stored procedure should result in a single row dataset where the first column is the image. It can either be an encoded image in a varbinary or image field or a string. If it is a string it is interpreted as a filename, which will be opened to get to the images.
getImageStreamCountProc
Type: SystemString
The name of a stored procedure that can get the number of image streams. There are no required parameters. The stored procedure should result in single row dataset with the count in the first column. If you need any extra parameters, you should specify their values by using the
Copy
extraParameters
argument.
getFrameCountByIndexProc
Type: SystemString
The name of a stored procedure that can get the frame count of an image stream by index. It should take an int parameter called "@index" and any other parameters you need, and return the frame count at that index. @index is not a primary key into your table, but instead is a number in range of 0 to count-1, where count is gotten by calling the stored procedure named in the
Copy
getImageStreamCountProc
argument. If you take any extra parameters (aside from the index), you should specify their values by using the
Copy
extraParameters
argument. The stored procedure should result in a single row dataset where the first column is the frame count. If you cannot provide this argument, you can pass null, and the frame count will be determined by decoding the image stream gotten with the
Copy
getImageByIndexProc
. Providing this argument can substantially speed up viewing of multi-framed images because viewers can know which images are visible without accessing the stream. A copy of the the dictionary will be made upon construction, so that changes to it will not affect this object.
extraParameters
Type: System.CollectionsIDictionary
The parameters that are passed to all of your stored procedures. For SqlCommands, the keys should be strings which are the names of the parameters and start with an @. For OleDbCommands, you must use a IDictionary with sorted keys (e.g. SortedList) and use index numbers (starting at 0) as keys. The parameters are added in the sort order of the keys. The values can be any object that can be automatically converted by the IDbDataParameter for your connection. The
Copy
extraParameters
are not encrypted when this object is serialized. A copy of the the dictionary will be made upon construction, so that changes to it will not affect this object.
Remarks
Here are some sample stored procedures that would work to get images from an table called images, where the data was stored in an field called
Copy
imageData
and the frame count was stored in field called
Copy
frameCount
. Here is a stored procedure that would meet the specification for the
Copy
getImageByIndexProc
.
Copy
@startId
and
Copy
@endId
are extra parameters that would need to be passed in to the constructor.
Copy
create PROCEDURE GetImageByIndex
    @index int, @startId int, @endId int
as
    set nocount on;
    with istr as (
        select id, imagedata, row_number() over (order by id) as rn
        from images where id between @startid and @endid
    ) select imageData from istr where rn=(@index+1)
Here is a stored procedure that would meet the specification for the
Copy
getImageStreamCountProc
.
Copy
@startId
and
Copy
@endId
are extra parameters that would need to be passed in to the constructor.
Copy
create PROCEDURE GetImageStreamCount
    @startid int, @endid int
as
    set nocount on;
    select count(*) from images where id between @startid and @endid
Here is a stored procedure that would meet the specification for the getImageByIndexProc. @startId and @endId are extra parameters that would need to be passed in to the constructor.
Copy
create PROCEDURE GetFrameCountByIndex
    @index int, @startId int, @endId int
as
    set nocount on;
    with istr as (
        select id, frameCount, row_number() over (order by id) as rn
        from images where id between @startid and @endid
    ) select frameCount from istr where rn=(@index+1)
Note: the extra parameters must be the same for all stored procedures.
See Also

Reference

DbStoredProcImageAccessor Class
DbStoredProcImageAccessor Overload
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Properties

The DbStoredProcImageAccessor type exposes the following members.

Properties
Name Description
Public property Decryptor
A delegate that can decrypt a string.
(Inherited from DbCommandImageAccessor.)
Public property Encryptor
A delegate that can encrypt a string.
(Inherited from DbCommandImageAccessor.)
Public property EncryptSerializedState
Whether or not the serialized state is encrypted. Please see documentation of sub-classes to see which members are encrypted.
(Inherited from DbCommandImageAccessor.)
Public property ExtraParameters
A copy of the extra parameters dictionary. This class does not support changing the parameters after the object has been constructed.
(Inherited from DbCommandImageAccessor.)
Protected property GetConnection
A delegate that can return a connection to the database.
(Inherited from DbCommandImageAccessor.)
Public property GetFrameCountByIndexProc
The name of the stored procedure that will be used to access the frame count of an image stream. It must take a parameter called index and return a single row dataset with the frame count as the first column. It may also take extra parameters. DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) for an example of a valid stored procedure.
Public property GetImageByIndexProc
The name of the stored procedure that will be used to access image streams. It must take a parameter called index and return a single row dataset with the image stream as the first column. It may also take extra parameters.
Public property GetImageStreamCountProc
The name of the stored procedure that will be used to access the count of image streams. It must take return a single row dataset with the image stream as the first column. It may also take extra parameters. DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) for an example of a valid stored procedure.
Protected property ImageFieldName
The name of the image field in the dataset returned by
Copy
CreateGetImageRowCommand
. If this method returns null, it is assumed to be in the first column.
(Inherited from DbCommandImageAccessor.)
Top
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.GetFrameCountByIndexProc Property

DbStoredProcImageAccessorGetFrameCountByIndexProc Property

The name of the stored procedure that will be used to access the frame count of an image stream. It must take a parameter called index and return a single row dataset with the frame count as the first column. It may also take extra parameters. DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) for an example of a valid stored procedure.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetFrameCountByIndexProc { get; }
Public ReadOnly Property GetFrameCountByIndexProc As String
    Get

Property Value

Type: String
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.GetImageByIndexProc Property

DbStoredProcImageAccessorGetImageByIndexProc Property

The name of the stored procedure that will be used to access image streams. It must take a parameter called index and return a single row dataset with the image stream as the first column. It may also take extra parameters.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetImageByIndexProc { get; }
Public ReadOnly Property GetImageByIndexProc As String
    Get

Property Value

Type: String
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.GetImageStreamCountProc Property

DbStoredProcImageAccessorGetImageStreamCountProc Property

The name of the stored procedure that will be used to access the count of image streams. It must take return a single row dataset with the image stream as the first column. It may also take extra parameters. DbStoredProcImageAccessor(GetConnectionCallback, Boolean, String, String, IDictionary) for an example of a valid stored procedure.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetImageStreamCountProc { get; }
Public ReadOnly Property GetImageStreamCountProc As String
    Get

Property Value

Type: String
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor Methods

The DbStoredProcImageAccessor type exposes the following members.

Methods
Name Description
Protected method AddExtraParameters
Adds any extra parameters supplied by the user that are needed to run the command.
(Inherited from DbCommandImageAccessor.)
Protected method CreateGetFrameCountCommand
Creates a command that can get the frame count of an image stream.
(Overrides DbCommandImageAccessorCreateGetFrameCountCommand(IDbConnection, Int32).)
Protected method CreateGetImageRowCommand
Creates a command that can get a single row dataset with the image stream information as the first column. It will pass in a parameter named index with the value of
Copy
imageStreamIndex
.
(Overrides DbCommandImageAccessorCreateGetImageRowCommand(IDbConnection, Int32).)
Protected method CreateGetImageStreamCountCommand
Creates a command that can get the count of image streams.
(Overrides DbCommandImageAccessorCreateGetImageStreamCountCommand(IDbConnection).)
Protected method CreateGetObjectByIndexCommand
Creates a command that can get an image related database object by calling the stored procedure, passing in the given imageStreamIndex.
Protected method CreateStoredProcCommand
Creates a command that can call the given stored procedure.
Protected method CreateStreamFromDatabaseObject
Creates a stream from the object obtained from the database. If the object is a byte array, it is attached to a MemoryStream. If the object is a string, it is interpreted as a filename and an open FileStream to the file is returned. If the object is null or not able to be interpreted as a stream, this method will throw.
(Inherited from DbCommandImageAccessor.)
Protected method DecryptIfRequested
Decrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Protected method EncryptIfRequested
Encrypt a string if EncryptSerializedState is true.
(Inherited from DbCommandImageAccessor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExtractImageStream
Extracts a stream from a row of the database.
(Inherited from DbCommandImageAccessor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Protected method GetDatabaseObject(IDbCommand, Int32)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, String)
Gets the database object from the first row of the data set returned by the command at the field named
Copy
field
.
(Inherited from DbCommandImageAccessor.)
Protected method GetDatabaseObject(IDbCommand, DbCommandImageAccessorFieldGetter, Object)
Gets the database object from the first row of the data set returned by the command from the field at
Copy
index
which can be either a field name or an integer index.
(Inherited from DbCommandImageAccessor.)
Protected method GetDecryptedValue
Gets the value from the serialized data and decrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByInt
Gets a field from the datareader by passing in the index of a field.
(Inherited from DbCommandImageAccessor.)
Protected method GetFieldByString
Gets a field from the datareader by passing in the name of the field.
(Inherited from DbCommandImageAccessor.)
Public method GetFrameCountInImage
The number of frames in the stream indicated by the imageStreamIndex
(Inherited from DbCommandImageAccessor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageStreamCount
Gets the number of image streams in this database. Each stream can contain more than one frame.
(Inherited from DbCommandImageAccessor.)
Public method GetObjectData
Get the data to serialize for this object
(Overrides DbCommandImageAccessorGetObjectData(SerializationInfo, StreamingContext).)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method Open
Opens a non-open connection
(Inherited from DbCommandImageAccessor.)
Public method Reset
Reset all caches of information. If you are storing anything that is a cached from the database, release it.
(Inherited from DbCommandImageAccessor.)
Protected method StoreEncryptedValue
Stores the value into the serialization info and encrypts it if requested.
(Inherited from DbCommandImageAccessor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.CreateGetFrameCountCommand Method

DbStoredProcImageAccessorCreateGetFrameCountCommand Method

Creates a command that can get the frame count of an image stream.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IDbCommand CreateGetFrameCountCommand(
    IDbConnection conn,
    int imageStreamIndex
)
Protected Overrides Function CreateGetFrameCountCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.
imageStreamIndex
Type: SystemInt32
index of the image stream.

Return Value

Type: IDbCommand
A command that will return a single row with the frame count of an image stream in the first column. If it returns null, the frame count will be determined by decoding the image.
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.CreateGetImageRowCommand Method

DbStoredProcImageAccessorCreateGetImageRowCommand Method

Creates a command that can get a single row dataset with the image stream information as the first column. It will pass in a parameter named index with the value of
Copy
imageStreamIndex
.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IDbCommand CreateGetImageRowCommand(
    IDbConnection conn,
    int imageStreamIndex
)
Protected Overrides Function CreateGetImageRowCommand (
    conn As IDbConnection,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.
imageStreamIndex
Type: SystemInt32
The index of the image stream (in the range of 0 to the count of images). It will be passed into the stored procedure as a parameter named index.

Return Value

Type: IDbCommand
A command that will return a single row with the image stream information in the first column.
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.CreateGetImageStreamCountCommand Method

DbStoredProcImageAccessorCreateGetImageStreamCountCommand Method

Creates a command that can get the count of image streams.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IDbCommand CreateGetImageStreamCountCommand(
    IDbConnection conn
)
Protected Overrides Function CreateGetImageStreamCountCommand (
    conn As IDbConnection
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database.

Return Value

Type: IDbCommand
A command that will return a single row with the count of image streams in the first column.
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.CreateGetObjectByIndexCommand Method

DbStoredProcImageAccessorCreateGetObjectByIndexCommand Method

Creates a command that can get an image related database object by calling the stored procedure, passing in the given imageStreamIndex.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IDbCommand CreateGetObjectByIndexCommand(
    IDbConnection conn,
    string procName,
    int imageStreamIndex
)
Protected Overridable Function CreateGetObjectByIndexCommand (
    conn As IDbConnection,
    procName As String,
    imageStreamIndex As Integer
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database
procName
Type: SystemString
The name of the stored procedure that can get a dataset by index.
imageStreamIndex
Type: SystemInt32
The index of the image stream (in the range of 0 to the count of images). It will be passed into the stored procedure as the first parameter and named
Copy
@index
.

Return Value

Type: IDbCommand
A command that can call the stored procedure and pass the index to it.
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.CreateStoredProcCommand Method

DbStoredProcImageAccessorCreateStoredProcCommand Method

Creates a command that can call the given stored procedure.

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IDbCommand CreateStoredProcCommand(
    IDbConnection conn,
    string procName
)
Protected Overridable Function CreateStoredProcCommand (
    conn As IDbConnection,
    procName As String
) As IDbCommand

Parameters

conn
Type: System.DataIDbConnection
A connection to the database
procName
Type: SystemString
The name of the stored procedure

Return Value

Type: IDbCommand
A command that will will the given stored procedure.
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DbStoredProcImageAccessor.GetObjectData Method

DbStoredProcImageAccessorGetObjectData Method

Get the data to serialize for this object

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The information for this object to serialize
context
Type: System.Runtime.SerializationStreamingContext
The serialization context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DbStoredProcImageAccessor Class
Atalasoft.Imaging.ImageSources.Data Namespace


DecryptHandler Delegate

A delegate to decrypt data back into a string (for use with serialization)

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate string DecryptHandler(
    byte[] b
)
Public Delegate Function DecryptHandler (
    b As Byte()
) As String

Parameters

b
Type: SystemByte

Return Value

Type: String
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


EncryptHandler Delegate

A delegate to encrypt a string (for use with serialization)

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate byte[] EncryptHandler(
    string s
)
Public Delegate Function EncryptHandler (
    s As String
) As Byte()

Parameters

s
Type: SystemString

Return Value

Type: Byte
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


GetConnectionCallback Delegate

A delegate that can return connections to a Database

Namespace: Atalasoft.Imaging.ImageSources.Data
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate IDbConnection GetConnectionCallback()
Public Delegate Function GetConnectionCallback As IDbConnection

Return Value

Type: IDbConnection
See Also

Reference

Atalasoft.Imaging.ImageSources.Data Namespace


Atalasoft.Imaging.Memory Namespace

Classes
 | Class | Description
Public class | BitmapPixelMemory | This is a concrete implementation of PixelMemory implemented using a Bitmap object as the owner of the memory.
Public class | GlobalAllocPixelMemory | Represents a PixelMemory object with memory allocated by GlobalAlloc.
Public class | ManagedPixelMemory | Constructs a new PiixelMemory object using memory from the managed heap for the image.
Public class | MemoryUseEventArgs | This class is used by all memory handling events.
Public class | PixelAccessor | This is an abstract object that is used to get direct access to the pixels of an image.
Public class | PixelMemory | PixelMemory is an abstract class that defines how an image's pixels are represented in memory, how they are allocated, deallocated, and accessed.
 | PixelMemoryFactory | PixelMemoryFactory is a singleton object that is used for allocating all image memory in dotImage. The object is accessed through the static Factory property.
 | PixelMemoryFactoryParameters | This class is used to control how PixelMemory is allocated by the PixelMemoryFactory
 | PixelMemoryLocker | PixelMemoryLocker is a utility class to help manage the locking and unlocking of memory. By constructing a PixelMemoryLocker object in a using block, PixelMemory will be automatically locked on entrance and exit of the block.
Public class | PixelMemoryTracker | This is a singleton class that is used for tracking memory used by images.
Public class | ResidentPixelMemory | This is a class used to represent PixelMemory that is resident and for which allocation and deallocation are controlled.
Interfaces
 | Interface | Description
Public interface | IArrayScanline | An interface applied to PixelMemory objects that represent their image in an array.
Public interface | IContiguous | An adornment interface with no members. It is applied to PixelMemory variants that have contiguous allocation.
Public interface | IDirectScanlineAccess | This interface is used for defining flavors of PixelMemory that allow direct access to scanlines.
Delegates
 | Delegate | Description
Public delegate | MemoryUseEventHandler | This delegate defines the type that is used for all PixelMemoryTracker events.
Public delegate | PixelMemoryAllocator | This delegate is used to define a method to allocate pixel memory.


BitmapPixelMemory Class

This is a concrete implementation of PixelMemory implemented using a Bitmap object as the owner of the memory.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemory
Atalasoft.Imaging.MemoryBitmapPixelMemory

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BitmapPixelMemory : PixelMemory,
    IDirectScanlineAccess
Public Class BitmapPixelMemory
    Inherits PixelMemory
    Implements IDirectScanlineAccess

The BitmapPixelMemory type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapPixelMemory | Constructs a new BitmapPixelMemory object from the Bbitmap supplied.
Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Returns true.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Top
Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any memory associated with this PixelMemory object, including the Bitmap. (Overrides PixelMemoryDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes any unmanaged resources associated with this object. (Overrides PixelMemoryDisposeUnmanagedResources.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Gets a pointer to a scanline for this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLClone | Subclasses implement this method to make a deep copy of this PixelAccessor. (Overrides PixelMemoryLLClone.)
Protected method | LLGetHeight | Returns the height of the image. (Overrides PixelMemoryLLGetHeight.)
Protected method | LLGetPixelAccessor | Constructs a PixelAccessor appropriate for BitmapPixelMemory. (Overrides PixelMemoryLLGetPixelAccessor.)
Protected method | LLGetRowStride | Returns the size of a row in bytes, rounded up to the next multiple of 4. (Overrides PixelMemoryLLGetRowStride.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Inherited from PixelMemory.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Inherited from PixelMemory.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory Constructor

Constructs a new BitmapPixelMemory object from the Bbitmap supplied.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapPixelMemory(
    Bitmap bm
)
Public Sub New (
    bm As Bitmap
)

Parameters

bm
Type: System.DrawingBitmap
A non-null Bitmap object.
Remarks
After constructing a BitmapPixelMemory object, the Bitmap is controlled solely by BitmapPixelMemory. If the BitmapPixelMemory object is disposed or garbage-collected, then the Bitmap will also be disposed.
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory Properties

The BitmapPixelMemory type exposes the following members.

Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Returns true.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Top
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.IsContiguous Property

BitmapPixelMemoryIsContiguous Property

Returns true.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsContiguous { get; }
Public Overridable ReadOnly Property IsContiguous As Boolean
    Get

Property Value

Type: Boolean

Implements

IDirectScanlineAccessIsContiguous
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory Methods

The BitmapPixelMemory type exposes the following members.

Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any memory associated with this PixelMemory object, including the Bitmap. (Overrides PixelMemoryDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes any unmanaged resources associated with this object. (Overrides PixelMemoryDisposeUnmanagedResources.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Gets a pointer to a scanline for this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLClone | Subclasses implement this method to make a deep copy of this PixelAccessor. (Overrides PixelMemoryLLClone.)
Protected method | LLGetHeight | Returns the height of the image. (Overrides PixelMemoryLLGetHeight.)
Protected method | LLGetPixelAccessor | Constructs a PixelAccessor appropriate for BitmapPixelMemory. (Overrides PixelMemoryLLGetPixelAccessor.)
Protected method | LLGetRowStride | Returns the size of a row in bytes, rounded up to the next multiple of 4. (Overrides PixelMemoryLLGetRowStride.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Inherited from PixelMemory.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Inherited from PixelMemory.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.DisposeManagedResources Method

BitmapPixelMemoryDisposeManagedResources Method

Disposes any memory associated with this PixelMemory object, including the Bitmap.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.DisposeUnmanagedResources Method

BitmapPixelMemoryDisposeUnmanagedResources Method

Disposes any unmanaged resources associated with this object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeUnmanagedResources()
Protected Overrides Sub DisposeUnmanagedResources
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.GetScanLinePtr Method

BitmapPixelMemoryGetScanLinePtr Method

Gets a pointer to a scanline for this object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IntPtr GetScanLinePtr(
    int i
)
Public Overridable Function GetScanLinePtr (
    i As Integer
) As IntPtr

Parameters

i
Type: SystemInt32
An index to a scanline in the image.

Return Value

Type: IntPtr

Implements

IDirectScanlineAccessGetScanLinePtr(Int32)
Remarks
Will throw if the index is not within the boundary of the image.
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.LLClone Method

BitmapPixelMemoryLLClone Method

Subclasses implement this method to make a deep copy of this PixelAccessor.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelMemory LLClone()
Protected Overrides Function LLClone As PixelMemory

Return Value

Type: PixelMemory
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.LLGetHeight Method

BitmapPixelMemoryLLGetHeight Method

Returns the height of the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetHeight()
Protected Overrides Function LLGetHeight As Integer

Return Value

Type: Int32
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.LLGetPixelAccessor Method

BitmapPixelMemoryLLGetPixelAccessor Method

Constructs a PixelAccessor appropriate for BitmapPixelMemory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelAccessor LLGetPixelAccessor()
Protected Overrides Function LLGetPixelAccessor As PixelAccessor

Return Value

Type: PixelAccessor
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


BitmapPixelMemory.LLGetRowStride Method

BitmapPixelMemoryLLGetRowStride Method

Returns the size of a row in bytes, rounded up to the next multiple of 4.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetRowStride()
Protected Overrides Function LLGetRowStride As Integer

Return Value

Type: Int32
See Also

Reference

BitmapPixelMemory Class
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Class

Represents a PixelMemory object with memory allocated by GlobalAlloc.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemory
Atalasoft.Imaging.MemoryResidentPixelMemory
Atalasoft.Imaging.MemoryGlobalAllocPixelMemory

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GlobalAllocPixelMemory : ResidentPixelMemory
Public Class GlobalAllocPixelMemory
    Inherits ResidentPixelMemory

The GlobalAllocPixelMemory type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalAllocPixelMemory(Int32, Int32) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int32, Int32, Int32) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int32, Int32, Int32, Boolean) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int32, Int32, Int32, Int32, Boolean) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int64, Int32, Int32, Int32, Boolean) | Initializes a new instance of the GlobalAllocPixelMemory class
Public method | GlobalAllocPixelMemory(IntPtr, Int32, Int32, Int32, Int32) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc in the provided pointer.
Public method | GlobalAllocPixelMemory(IntPtr, Int64, Int32, Int32, Int32) | Initializes a new instance of the GlobalAllocPixelMemory class.
Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Returns true. (Inherited from ResidentPixelMemory.)
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Protected property | LLPixelMemoryStart | Returns a pointer to the start of memory. (Inherited from ResidentPixelMemory.)
Protected property | OffsetToFirstScanline | Returns an offset to the first scanline of the image. (Inherited from ResidentPixelMemory.)
Public property | PixelData | Returns a pointer to the first scanline in the image. (Inherited from ResidentPixelMemory.)
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Protected property | SizeInBytes | Returns the number of bytes used by the memory for this image. (Inherited from ResidentPixelMemory.)
Top
Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Protected method | AllocateMemory | Allocates memory for this PixelMemory object and reports it for tracking. (Inherited from ResidentPixelMemory.)
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any unmanaged resources. (Inherited from ResidentPixelMemory.)
Protected method | DisposeUnmanagedResources | Disposes the memory used by this object. (Inherited from ResidentPixelMemory.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Protected method | FreeMemory | Frees memory. (Inherited from ResidentPixelMemory.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Gets a pointer to the a given scanline. (Inherited from ResidentPixelMemory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAllocateMemory(Int32, Boolean) | Obsolete. Allocates memory using GlobalAlloc. (Overrides ResidentPixelMemoryLLAllocateMemory(Int32, Boolean).)
Protected method | LLAllocateMemory(Int64, Boolean) | Subclasses of ResidentPixelMemory implement this method to allocate memory. (Overrides ResidentPixelMemoryLLAllocateMemory(Int64, Boolean).)
Protected method | LLClone | Creates a deep copy of this object. (Overrides PixelMemoryLLClone.)
Protected method | LLFreeMemory | Frees the memory occupied by this object using GlobalFree. (Overrides ResidentPixelMemoryLLFreeMemory(IntPtr).)
Protected method | LLGetHeight | Returns the height of the image. (Inherited from ResidentPixelMemory.)
Protected method | LLGetPixelAccessor | Returns a suitable PixelAccesor object for this PixelMemory. (Inherited from ResidentPixelMemory.)
Protected method | LLGetRowStride | Returns the size of a scanline in bytes, rounded up to the next multiple of 4. (Inherited from ResidentPixelMemory.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Inherited from PixelMemory.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Inherited from PixelMemory.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RerportMemoryAllocated | Rerports that memory was allocated. (Inherited from ResidentPixelMemory.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor

Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Overload List
 | Name | Description
Public method | GlobalAllocPixelMemory(Int32, Int32) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int32, Int32, Int32) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int32, Int32, Int32, Boolean) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int32, Int32, Int32, Int32, Boolean) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc.
Public method | GlobalAllocPixelMemory(Int64, Int32, Int32, Int32, Boolean) | Initializes a new instance of the GlobalAllocPixelMemory class
Public method | GlobalAllocPixelMemory(IntPtr, Int32, Int32, Int32, Int32) | Constructs a new PixelMemory object with memory allocated by GlobalAlloc in the provided pointer.
Public method | GlobalAllocPixelMemory(IntPtr, Int64, Int32, Int32, Int32) | Initializes a new instance of the GlobalAllocPixelMemory class.
Top
See Also

Reference

GlobalAllocPixelMemory Class
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (Int32, Int32)

Constructs a new PixelMemory object with memory allocated by GlobalAlloc.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    int height,
    int rowStride
)
Public Sub New (
    height As Integer,
    rowStride As Integer
)

Parameters

height
Type: SystemInt32
The height of the image.
rowStride
Type: SystemInt32
The number of bytes in a scanline rounded up to the next multiple of 4.
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (Int32, Int32, Int32)

Constructs a new PixelMemory object with memory allocated by GlobalAlloc.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    int numBytes,
    int height,
    int rowStride
)
Public Sub New (
    numBytes As Integer,
    height As Integer,
    rowStride As Integer
)

Parameters

numBytes
Type: SystemInt32
The total number of bytes occupied by this image. Typically this will be height * rowstride, but it could be larger if there is space needed after the last scanline.
height
Type: SystemInt32
The height of the image.
rowStride
Type: SystemInt32
The number of bytes in a scanline rounded up to the next multiple of 4.
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (Int32, Int32, Int32, Boolean)

Constructs a new PixelMemory object with memory allocated by GlobalAlloc.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    int numBytes,
    int height,
    int rowStride,
    bool zeroMemory
)
Public Sub New (
    numBytes As Integer,
    height As Integer,
    rowStride As Integer,
    zeroMemory As Boolean
)

Parameters

numBytes
Type: SystemInt32
The total number of bytes occupied by this image. Typically this will be height * rowstride, but it could be larger if there is space needed after the last scanline.
height
Type: SystemInt32
The height of the image.
rowStride
Type: SystemInt32
The number of bytes in a scanline rounded up to the next multiple of 4.
zeroMemory
Type: SystemBoolean
Indicates whether allocated memory should be cleared or not.
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (Int32, Int32, Int32, Int32, Boolean)

Constructs a new PixelMemory object with memory allocated by GlobalAlloc.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    int numBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline,
    bool zeroMemory
)
Public Sub New (
    numBytes As Integer,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer,
    zeroMemory As Boolean
)

Parameters

numBytes
Type: SystemInt32
The total number of bytes occupied by this image. Typically this will be height * rowstride, but it could be larger if there is space needed before or after the last scanline.
height
Type: SystemInt32
The height of the image.
rowStride
Type: SystemInt32
The number of bytes in a scanline rounded up to the next multiple of 4.
offsetToFirstScanline
Type: SystemInt32
An offset to the first scanline in the image. Typically, this is zero, but in some images, there is header information before the first scanline.
zeroMemory
Type: SystemBoolean
Indicates whether allocated memory should be cleared or not.
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (Int64, Int32, Int32, Int32, Boolean)

Initializes a new instance of the GlobalAllocPixelMemory class

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    long numBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline,
    bool zeroMemory
)
Public Sub New (
    numBytes As Long,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer,
    zeroMemory As Boolean
)

Parameters

numBytes
Type: SystemInt64
height
Type: SystemInt32
rowStride
Type: SystemInt32
offsetToFirstScanline
Type: SystemInt32
zeroMemory
Type: SystemBoolean
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (IntPtr, Int32, Int32, Int32, Int32)

Constructs a new PixelMemory object with memory allocated by GlobalAlloc in the provided pointer.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    IntPtr memoryStart,
    int numBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline
)
Public Sub New (
    memoryStart As IntPtr,
    numBytes As Integer,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer
)

Parameters

memoryStart
Type: SystemIntPtr
A pointer to the start at memory. MemoryStart must be allocated by GlobalAlloc.
numBytes
Type: SystemInt32
The total number of bytes occupied by this image. Typically this will be height * rowstride, but it could be larger if there is space needed before or after the last scanline.
height
Type: SystemInt32
The height of the image.
rowStride
Type: SystemInt32
The number of bytes in a scanline rounded up to the next multiple of 4.
offsetToFirstScanline
Type: SystemInt32
An offset to the first scanline in the image. Typically, this is zero, but in some images, there is header information before the first scanline
Remarks
This method will throw if memoryStart is not the start of a valid block or was not allocated by GlobalAlloc or was not allocated with specified size.
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Constructor (IntPtr, Int64, Int32, Int32, Int32)

Initializes a new instance of the GlobalAllocPixelMemory class.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalAllocPixelMemory(
    IntPtr memoryStart,
    long numBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline
)
Public Sub New (
    memoryStart As IntPtr,
    numBytes As Long,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer
)

Parameters

memoryStart
Type: SystemIntPtr
The memory start.
numBytes
Type: SystemInt64
The number bytes.
height
Type: SystemInt32
The height.
rowStride
Type: SystemInt32
The row stride.
offsetToFirstScanline
Type: SystemInt32
The offset to first scanline.
Exceptions
Exception | Condition
ArgumentNullException | memoryStart;memoryStart needs to be a valid IntPtr.
ArgumentOutOfRangeException | numBytes;nBytes must be greater than 0
ArgumentException | memoryStart is not a valid pointer - maybe it wasn't allocated with GlobalAlloc or isn't the start of a block;memoryStart
See Also

Reference

GlobalAllocPixelMemory Class
GlobalAllocPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Properties

The GlobalAllocPixelMemory type exposes the following members.

Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Returns true. (Inherited from ResidentPixelMemory.)
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Protected property | LLPixelMemoryStart | Returns a pointer to the start of memory. (Inherited from ResidentPixelMemory.)
Protected property | OffsetToFirstScanline | Returns an offset to the first scanline of the image. (Inherited from ResidentPixelMemory.)
Public property | PixelData | Returns a pointer to the first scanline in the image. (Inherited from ResidentPixelMemory.)
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Protected property | SizeInBytes | Returns the number of bytes used by the memory for this image. (Inherited from ResidentPixelMemory.)
Top
See Also

Reference

GlobalAllocPixelMemory Class
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory Methods

The GlobalAllocPixelMemory type exposes the following members.

Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Protected method | AllocateMemory | Allocates memory for this PixelMemory object and reports it for tracking. (Inherited from ResidentPixelMemory.)
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any unmanaged resources. (Inherited from ResidentPixelMemory.)
Protected method | DisposeUnmanagedResources | Disposes the memory used by this object. (Inherited from ResidentPixelMemory.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Protected method | FreeMemory | Frees memory. (Inherited from ResidentPixelMemory.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Gets a pointer to the a given scanline. (Inherited from ResidentPixelMemory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAllocateMemory(Int32, Boolean) | Obsolete. Allocates memory using GlobalAlloc. (Overrides ResidentPixelMemoryLLAllocateMemory(Int32, Boolean).)
Protected method | LLAllocateMemory(Int64, Boolean) | Subclasses of ResidentPixelMemory implement this method to allocate memory. (Overrides ResidentPixelMemoryLLAllocateMemory(Int64, Boolean).)
Protected method | LLClone | Creates a deep copy of this object. (Overrides PixelMemoryLLClone.)
Protected method | LLFreeMemory | Frees the memory occupied by this object using GlobalFree. (Overrides ResidentPixelMemoryLLFreeMemory(IntPtr).)
Protected method | LLGetHeight | Returns the height of the image. (Inherited from ResidentPixelMemory.)
Protected method | LLGetPixelAccessor | Returns a suitable PixelAccesor object for this PixelMemory. (Inherited from ResidentPixelMemory.)
Protected method | LLGetRowStride | Returns the size of a scanline in bytes, rounded up to the next multiple of 4. (Inherited from ResidentPixelMemory.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Inherited from PixelMemory.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Inherited from PixelMemory.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RerportMemoryAllocated | Rerports that memory was allocated. (Inherited from ResidentPixelMemory.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

GlobalAllocPixelMemory Class
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory.LLAllocateMemory Method

GlobalAllocPixelMemoryLLAllocateMemory Method

Overload List
 | Name | Description
Protected method | LLAllocateMemory(Int32, Boolean) | Obsolete. Allocates memory using GlobalAlloc. (Overrides ResidentPixelMemoryLLAllocateMemory(Int32, Boolean).)
Protected method | LLAllocateMemory(Int64, Boolean) | Subclasses of ResidentPixelMemory implement this method to allocate memory. (Overrides ResidentPixelMemoryLLAllocateMemory(Int64, Boolean).)
Top
See Also

Reference

GlobalAllocPixelMemory Class
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory.LLAllocateMemory Method (Int32, Boolean)

GlobalAllocPixelMemoryLLAllocateMemory Method (Int32, Boolean)

Note: This API is now obsolete.

Allocates memory using GlobalAlloc.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("you should override LLAllocateMemory(long size, bool zeroMemory) instead.",
    false)]
protected override IntPtr LLAllocateMemory(
    int size,
    bool zeroMemory
)
<ObsoleteAttribute("you should override LLAllocateMemory(long size, bool zeroMemory) instead.",
    false)>
Protected Overrides Function LLAllocateMemory (
    size As Integer,
    zeroMemory As Boolean
) As IntPtr

Parameters

size
Type: SystemInt32
zeroMemory
Type: SystemBoolean

Return Value

Type: IntPtr
See Also

Reference

GlobalAllocPixelMemory Class
LLAllocateMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory.LLAllocateMemory Method (Int64, Boolean)

GlobalAllocPixelMemoryLLAllocateMemory Method (Int64, Boolean)

Subclasses of ResidentPixelMemory implement this method to allocate memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IntPtr LLAllocateMemory(
    long size,
    bool zeroMemory
)
Protected Overrides Function LLAllocateMemory (
    size As Long,
    zeroMemory As Boolean
) As IntPtr

Parameters

size
Type: SystemInt64
zeroMemory
Type: SystemBoolean

Return Value

Type: IntPtr
See Also

Reference

GlobalAllocPixelMemory Class
LLAllocateMemory Overload
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory.LLClone Method

GlobalAllocPixelMemoryLLClone Method

Creates a deep copy of this object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelMemory LLClone()
Protected Overrides Function LLClone As PixelMemory

Return Value

Type: PixelMemory
See Also

Reference

GlobalAllocPixelMemory Class
Atalasoft.Imaging.Memory Namespace


GlobalAllocPixelMemory.LLFreeMemory Method

GlobalAllocPixelMemoryLLFreeMemory Method

Frees the memory occupied by this object using GlobalFree.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLFreeMemory(
    IntPtr pointer
)
Protected Overrides Sub LLFreeMemory (
    pointer As IntPtr
)

Parameters

pointer
Type: SystemIntPtr
The pointer to free.
See Also

Reference

GlobalAllocPixelMemory Class
Atalasoft.Imaging.Memory Namespace


IArrayScanline Interface

An interface applied to PixelMemory objects that represent their image in an array.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IArrayScanline
Public Interface IArrayScanline

The IArrayScanline type exposes the following members.

Methods
 | Name | Description
Public method | LLReadFromScanline | Reads a subsection from a scanline.
Public method | LLWriteToScanline | Writes an a subsection of an array into a scanline.
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


IArrayScanline Methods

The IArrayScanline type exposes the following members.

Methods
 | Name | Description
Public method | LLReadFromScanline | Reads a subsection from a scanline.
Public method | LLWriteToScanline | Writes an a subsection of an array into a scanline.
Top
See Also

Reference

IArrayScanline Interface
Atalasoft.Imaging.Memory Namespace


IArrayScanline.LLReadFromScanline Method

IArrayScanlineLLReadFromScanline Method

Reads a subsection from a scanline.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool LLReadFromScanline(
    int scanlineIndex,
    int srcIndex,
    byte[] array,
    int index,
    int length
)
Function LLReadFromScanline (
    scanlineIndex As Integer,
    srcIndex As Integer,
    array As Byte(),
    index As Integer,
    length As Integer
) As Boolean

Parameters

scanlineIndex
Type: SystemInt32
Y index of the scanline.
srcIndex
Type: SystemInt32
Byte index into the source scanline.
array
Type: SystemByte
The destination array.
index
Type: SystemInt32
The index into the destination scanline.
length
Type: SystemInt32
The number of bytes to read.

Return Value

Type: Boolean
true on success, false otherwise
See Also

Reference

IArrayScanline Interface
Atalasoft.Imaging.Memory Namespace


IArrayScanline.LLWriteToScanline Method

IArrayScanlineLLWriteToScanline Method

Writes an a subsection of an array into a scanline.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool LLWriteToScanline(
    int scanlineIndex,
    int srcIndex,
    byte[] array,
    int index,
    int length
)
Function LLWriteToScanline (
    scanlineIndex As Integer,
    srcIndex As Integer,
    array As Byte(),
    index As Integer,
    length As Integer
) As Boolean

Parameters

scanlineIndex
Type: SystemInt32
Y index of the scanline.
srcIndex
Type: SystemInt32
Index into the source.
array
Type: SystemByte
The array of data to write into the scanline.
index
Type: SystemInt32
Byte index into the destination scanline.
length
Type: SystemInt32
The number of bytes to write.

Return Value

Type: Boolean
See Also

Reference

IArrayScanline Interface
Atalasoft.Imaging.Memory Namespace


IContiguous Interface

An adornment interface with no members. It is applied to PixelMemory variants that have contiguous allocation.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IContiguous
Public Interface IContiguous
See Also

Reference

Atalasoft.Imaging.Memory Namespace


IDirectScanlineAccess Interface

This interface is used for defining flavors of PixelMemory that allow direct access to scanlines.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IDirectScanlineAccess
Public Interface IDirectScanlineAccess

The IDirectScanlineAccess type exposes the following members.

Properties
 | Name | Description
Public property | IsContiguous | Indicates whether or not the PixelMemory is contiguous in memory.
Top
Methods
 | Name | Description
Public method | GetScanLinePtr | Returns an IntPtr to the ith scanline in an image.
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


IDirectScanlineAccess Properties

The IDirectScanlineAccess type exposes the following members.

Properties
 | Name | Description
Public property | IsContiguous | Indicates whether or not the PixelMemory is contiguous in memory.
Top
See Also

Reference

IDirectScanlineAccess Interface
Atalasoft.Imaging.Memory Namespace


IDirectScanlineAccess.IsContiguous Property

IDirectScanlineAccessIsContiguous Property

Indicates whether or not the PixelMemory is contiguous in memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsContiguous { get; }
ReadOnly Property IsContiguous As Boolean
    Get

Property Value

Type: Boolean
True is the PixelMemory is contiguous, false otherwise.
Remarks
If a PixelMemory object implements IDirectScanlineAccess and IsContiguous is true, then it is safe to assume that any part of an image can be addressed by using a pointer to the 0th scanline and the images RowStride to calculate the address.
See Also

Reference

IDirectScanlineAccess Interface
Atalasoft.Imaging.Memory Namespace


IDirectScanlineAccess Methods

The IDirectScanlineAccess type exposes the following members.

Methods
 | Name | Description
Public method | GetScanLinePtr | Returns an IntPtr to the ith scanline in an image.
Top
See Also

Reference

IDirectScanlineAccess Interface
Atalasoft.Imaging.Memory Namespace


IDirectScanlineAccess.GetScanLinePtr Method

IDirectScanlineAccessGetScanLinePtr Method

Returns an IntPtr to the ith scanline in an image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IntPtr GetScanLinePtr(
    int i
)
Function GetScanLinePtr (
    i As Integer
) As IntPtr

Parameters

i
Type: SystemInt32
The index of the scanline.

Return Value

Type: IntPtr
An IntPtr which points to the first byte in the scanline.
See Also

Reference

IDirectScanlineAccess Interface
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory Class

Constructs a new PiixelMemory object using memory from the managed heap for the image.
Constructs a new PiixelMemory object using memory from the managed heap for the image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemory
Atalasoft.Imaging.MemoryManagedPixelMemory

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ManagedPixelMemory : PixelMemory,
    IContiguous, IDirectScanlineAccess
Public Class ManagedPixelMemory
    Inherits PixelMemory
    Implements IContiguous, IDirectScanlineAccess

The ManagedPixelMemory type exposes the following members.

Constructors
 | Name | Description
Public method | ManagedPixelMemory(Int32, Int32) | Constructs a new ManagedPixelMemory object.
Public method | ManagedPixelMemory(Int64, Int32, Int32, Int32) | Constructs a new ManagedPixelMemory object.
Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Indicates whether or not the memory is contiguous.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Top
Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any unmanaged resources that implement IDisposable (Overrides PixelMemoryDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes and unmanaged resources, such as memory not claimed by the garbage collector. (Overrides PixelMemoryDisposeUnmanagedResources.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Returns a pointer to the specified scan line.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLClone | Subclasses of PixelMemory implement this method to create a deep copy of the object. (Overrides PixelMemoryLLClone.)
Protected method | LLGetHeight | Subclasses of PixelMemory implement this method to return the height of the image. (Overrides PixelMemoryLLGetHeight.)
Protected method | LLGetPixelAccessor | Subclasses of PixelMemory implement this method to return a new PixelAccessor object suitable for their particular version of PixelMemory. (Overrides PixelMemoryLLGetPixelAccessor.)
Protected method | LLGetRowStride | Subclasses of PixelMemory implement this method to return the number of bytes necessary for a row of pixels. This number should be rounded up to the next multiple of 4 bytes. (Overrides PixelMemoryLLGetRowStride.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Overrides PixelMemoryLLLock.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Overrides PixelMemoryLLUnlock.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
Remarks
Managed memory may move. This PixelMemory object needs to be locked before any direct memory access.
Remarks
Managed memory may move. This PixelMemory object needs to be locked before any direct memory access.
See Also

Reference

Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory Constructor

Constructs a new ManagedPixelMemory object.
Overload List
 | Name | Description
Public method | ManagedPixelMemory(Int32, Int32) | Constructs a new ManagedPixelMemory object.
Public method | ManagedPixelMemory(Int64, Int32, Int32, Int32) | Constructs a new ManagedPixelMemory object.
Top
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory Constructor (Int32, Int32)

Constructs a new ManagedPixelMemory object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ManagedPixelMemory(
    int height,
    int rowStride
)
Public Sub New (
    height As Integer,
    rowStride As Integer
)

Parameters

height
Type: SystemInt32

The height of the image in scan lines

rowStride
Type: SystemInt32
The length of a scan line in bytes. This should be a multiple of 4.
See Also

Reference

ManagedPixelMemory Class
ManagedPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory Constructor (Int64, Int32, Int32, Int32)

Constructs a new ManagedPixelMemory object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ManagedPixelMemory(
    long numBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline
)
Public Sub New (
    numBytes As Long,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer
)

Parameters

numBytes
Type: SystemInt64
The total number of bytes needed for the memory. This should be no less than height * rowStride + offsetToFirstScanline, but it can be more.
height
Type: SystemInt32

The height of the image in scan lines

rowStride
Type: SystemInt32
The length of a scan line in bytes. This should be a multiple of 4.
offsetToFirstScanline
Type: SystemInt32
The offset in bytes to the first scan line from the start of memory.
See Also

Reference

ManagedPixelMemory Class
ManagedPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory Properties

The ManagedPixelMemory type exposes the following members.

Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Indicates whether or not the memory is contiguous.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Top
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.IsContiguous Property

ManagedPixelMemoryIsContiguous Property

Indicates whether or not the memory is contiguous.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsContiguous { get; }
Public ReadOnly Property IsContiguous As Boolean
    Get

Property Value

Type: Boolean
Returns true.

Implements

IDirectScanlineAccessIsContiguous
Remarks
Presently, ManagedPixelMemory is contiguous, but this may change in the future.
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory Methods

The ManagedPixelMemory type exposes the following members.

Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any unmanaged resources that implement IDisposable (Overrides PixelMemoryDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes and unmanaged resources, such as memory not claimed by the garbage collector. (Overrides PixelMemoryDisposeUnmanagedResources.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Returns a pointer to the specified scan line.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLClone | Subclasses of PixelMemory implement this method to create a deep copy of the object. (Overrides PixelMemoryLLClone.)
Protected method | LLGetHeight | Subclasses of PixelMemory implement this method to return the height of the image. (Overrides PixelMemoryLLGetHeight.)
Protected method | LLGetPixelAccessor | Subclasses of PixelMemory implement this method to return a new PixelAccessor object suitable for their particular version of PixelMemory. (Overrides PixelMemoryLLGetPixelAccessor.)
Protected method | LLGetRowStride | Subclasses of PixelMemory implement this method to return the number of bytes necessary for a row of pixels. This number should be rounded up to the next multiple of 4 bytes. (Overrides PixelMemoryLLGetRowStride.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Overrides PixelMemoryLLLock.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Overrides PixelMemoryLLUnlock.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.DisposeManagedResources Method

ManagedPixelMemoryDisposeManagedResources Method

Disposes any unmanaged resources that implement IDisposable

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.DisposeUnmanagedResources Method

ManagedPixelMemoryDisposeUnmanagedResources Method

Disposes and unmanaged resources, such as memory not claimed by the garbage collector.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeUnmanagedResources()
Protected Overrides Sub DisposeUnmanagedResources
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.GetScanLinePtr Method

ManagedPixelMemoryGetScanLinePtr Method

Returns a pointer to the specified scan line.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr GetScanLinePtr(
    int i
)
Public Function GetScanLinePtr (
    i As Integer
) As IntPtr

Parameters

i
Type: SystemInt32
The index to the scan line. This value should be greater than or equal to 0 and less than the image height.

Return Value

Type: IntPtr

Implements

IDirectScanlineAccessGetScanLinePtr(Int32)
Remarks
The PixelMemory must be locked before calling this method.
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.LLClone Method

ManagedPixelMemoryLLClone Method

Subclasses of PixelMemory implement this method to create a deep copy of the object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelMemory LLClone()
Protected Overrides Function LLClone As PixelMemory

Return Value

Type: PixelMemory
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.LLGetHeight Method

ManagedPixelMemoryLLGetHeight Method

Subclasses of PixelMemory implement this method to return the height of the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetHeight()
Protected Overrides Function LLGetHeight As Integer

Return Value

Type: Int32
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.LLGetPixelAccessor Method

ManagedPixelMemoryLLGetPixelAccessor Method

Subclasses of PixelMemory implement this method to return a new PixelAccessor object suitable for their particular version of PixelMemory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelAccessor LLGetPixelAccessor()
Protected Overrides Function LLGetPixelAccessor As PixelAccessor

Return Value

Type: PixelAccessor
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.LLGetRowStride Method

ManagedPixelMemoryLLGetRowStride Method

Subclasses of PixelMemory implement this method to return the number of bytes necessary for a row of pixels. This number should be rounded up to the next multiple of 4 bytes.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetRowStride()
Protected Overrides Function LLGetRowStride As Integer

Return Value

Type: Int32
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.LLLock Method

ManagedPixelMemoryLLLock Method

Subclasses of PixelMemory implement this method to lock the memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLLock()
Protected Overrides Sub LLLock
Remarks
LLLock is called by Lock only when it is necessary to actually lock the memory. Lock manages both thread safety as well as accumulation of locks. For any number of calls to Lock without a call to Unlock, there will be precisely one call to LLLock. It is also guaranteed that LLLock can only be called by one thread at a time.
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ManagedPixelMemory.LLUnlock Method

ManagedPixelMemoryLLUnlock Method

Subclasses of PixelMemory implement this method to unlock the memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLUnlock()
Protected Overrides Sub LLUnlock
Remarks
LLUnlock is called by Unlock only when it is necessary to actually unlock the memory. Unlock manages both thread safety as well as accumulation of locks. For any number of calls to Unlock, there will be precisely one call to LLUnlock when there are no further lock requests. It is also guaranteed that LLUnlock can only be called by one thread at a time.
See Also

Reference

ManagedPixelMemory Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs Class

This class is used by all memory handling events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.MemoryMemoryUseEventArgs

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MemoryUseEventArgs : EventArgs
Public Class MemoryUseEventArgs
    Inherits EventArgs

The MemoryUseEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryUseEventArgs | Constructs a new MemoryUseEventArgs object.
Top
Properties
 | Name | Description
Public property | Change | The last change in memory - this is positive for increases and negative for decreases.
Public property | HighWatermark | The current high water mark for reporting high memory usage.
Public property | MemoryInUse | The current amount of memory in use.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs Constructor

Constructs a new MemoryUseEventArgs object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MemoryUseEventArgs(
    long memoryInUse,
    long highWatermark,
    long change
)
Public Sub New (
    memoryInUse As Long,
    highWatermark As Long,
    change As Long
)

Parameters

memoryInUse
Type: SystemInt64
The current amount of memory in use.
highWatermark
Type: SystemInt64
The current high water mark for reporting high memory usage.
change
Type: SystemInt64
The last change in memory - this is positive for increases and negative for decreases.
See Also

Reference

MemoryUseEventArgs Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs Properties

The MemoryUseEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Change | The last change in memory - this is positive for increases and negative for decreases.
Public property | HighWatermark | The current high water mark for reporting high memory usage.
Public property | MemoryInUse | The current amount of memory in use.
Top
See Also

Reference

MemoryUseEventArgs Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs.Change Property

MemoryUseEventArgsChange Property

The last change in memory - this is positive for increases and negative for decreases.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long Change { get; }
Public ReadOnly Property Change As Long
    Get

Property Value

Type: Int64
See Also

Reference

MemoryUseEventArgs Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs.HighWatermark Property

MemoryUseEventArgsHighWatermark Property

The current high water mark for reporting high memory usage.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long HighWatermark { get; }
Public ReadOnly Property HighWatermark As Long
    Get

Property Value

Type: Int64
See Also

Reference

MemoryUseEventArgs Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs.MemoryInUse Property

MemoryUseEventArgsMemoryInUse Property

The current amount of memory in use.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long MemoryInUse { get; }
Public ReadOnly Property MemoryInUse As Long
    Get

Property Value

Type: Int64
Remarks
This is the amount of memory in use when the event was fired. The total memory in use may be different by the time the event is handled.
See Also

Reference

MemoryUseEventArgs Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventArgs Methods

The MemoryUseEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MemoryUseEventArgs Class
Atalasoft.Imaging.Memory Namespace


MemoryUseEventHandler Delegate

This delegate defines the type that is used for all PixelMemoryTracker events.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void MemoryUseEventHandler(
    Object sender,
    MemoryUseEventArgs e
)
Public Delegate Sub MemoryUseEventHandler (
    sender As Object,
    e As MemoryUseEventArgs
)

Parameters

sender
Type: SystemObject
The object raising the event.
e
Type: Atalasoft.Imaging.MemoryMemoryUseEventArgs
A MemoryUseEventArgs object indicating the change in memory.
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelAccessor Class

This is an abstract object that is used to get direct access to the pixels of an image.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelAccessor

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PixelAccessor : IDisposable
Public MustInherit Class PixelAccessor
    Implements IDisposable

The PixelAccessor type exposes the following members.

Constructors
 | Name | Description
Protected method | PixelAccessor | Initializes a new instance of the PixelAccessor class attached to the given owner.
Top
Properties
 | Name | Description
Public property | Height | Returns the height of the image in scanlines.
Protected property | Owner | Returns the PixelMemory object that created this PixelAccessor.
Protected property | OwnerValid | Indicates whether or not the PixelMemory which created this PixelAccessor is still valid.
Public property | RowStride | The number of bytes contained in a scanline, rounded up to the next multiple of 4.
Public property | Valid | Returns true if this PixelAccessor is still valid.
Top
Methods
 | Name | Description
Public method | AcquireNextScanline | Acquires the next scanline in sequence for this image.
Public method | AcquirePreviousScanline | Acquires the previous scanline in the image.
Public method | AcquireScanline | Aquires a scanline of data for accessing.
Public method | Dispose | Disposes this PixelAccessor and all its managed and unmanaged resources.
Protected method | Dispose(Boolean) | Disposes this PixelAccessor and all its managed and unmanaged resources.
Protected method | DisposeManagedResources | Disposed any managed objects that implement IDisposable
Protected method | DisposeUnmanagedResources | Disposes any unmanaged resources such as memory.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelAccessor class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReadOnlyColumn | Gets the read only column.
Public method | GetReadOnlyColumnSection | Gets the read only column section.
Public method | GetReadOnlyScanline(Int32) | Gets the contents of a scanline, allocating memory for the data.
Public method | GetReadOnlyScanline(Int32, Byte) | Copies the contents of a scanline into the supplied array
Public method | GetReadOnlyScanlineSection | Gets the read only scanline section.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAcquireScanline | Subclasses of PixelAccessor implement this method to acquire a pointer to a scanline.
Protected method | LLReleaseScanline | Subclasses of PixelAccessor implement this method to release a previously acquired scanline
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyAccessorReleased | This method is called whenever an accessor has been released.
Protected method | NotifyAccessorReleasing | This method is called when a PixelAccessor is about to be released.
Public method | Release | Releases a PixelAccessor back to the PixelMemory object that owns it.
Public method | ReleaseScanline | Releases the last scanline acquired.
Public method | Reset | Resets the pixel accessor so that AcquireNextScanline will acquire the first scanline in the image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteColumn | Writes the column.
Public method | WriteColumnSection | Writes the column section.
Public method | WriteToScanline | Writes to scanline.
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelAccessor Constructor

Initializes a new instance of the PixelAccessor class attached to the given owner.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PixelAccessor(
    PixelMemory owner
)
Protected Sub New (
    owner As PixelMemory
)

Parameters

owner
Type: Atalasoft.Imaging.MemoryPixelMemory
The owner of the PixelAccessor.
Exceptions
Exception | Condition
ArgumentNullException | owner;PixelAccessor needs a valid owner
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor Properties

The PixelAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Height | Returns the height of the image in scanlines.
Protected property | Owner | Returns the PixelMemory object that created this PixelAccessor.
Protected property | OwnerValid | Indicates whether or not the PixelMemory which created this PixelAccessor is still valid.
Public property | RowStride | The number of bytes contained in a scanline, rounded up to the next multiple of 4.
Public property | Valid | Returns true if this PixelAccessor is still valid.
Top
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Height Property

PixelAccessorHeight Property

Returns the height of the image in scanlines.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Owner Property

PixelAccessorOwner Property

Returns the PixelMemory object that created this PixelAccessor.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PixelMemory Owner { get; }
Protected ReadOnly Property Owner As PixelMemory
    Get

Property Value

Type: PixelMemory
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.OwnerValid Property

PixelAccessorOwnerValid Property

Indicates whether or not the PixelMemory which created this PixelAccessor is still valid.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool OwnerValid { get; }
Protected ReadOnly Property OwnerValid As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.RowStride Property

PixelAccessorRowStride Property

The number of bytes contained in a scanline, rounded up to the next multiple of 4.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RowStride { get; }
Public ReadOnly Property RowStride As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Valid Property

PixelAccessorValid Property

Returns true if this PixelAccessor is still valid.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Valid { get; }
Public ReadOnly Property Valid As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor Methods

The PixelAccessor type exposes the following members.

Methods
 | Name | Description
Public method | AcquireNextScanline | Acquires the next scanline in sequence for this image.
Public method | AcquirePreviousScanline | Acquires the previous scanline in the image.
Public method | AcquireScanline | Aquires a scanline of data for accessing.
Public method | Dispose | Disposes this PixelAccessor and all its managed and unmanaged resources.
Protected method | Dispose(Boolean) | Disposes this PixelAccessor and all its managed and unmanaged resources.
Protected method | DisposeManagedResources | Disposed any managed objects that implement IDisposable
Protected method | DisposeUnmanagedResources | Disposes any unmanaged resources such as memory.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelAccessor class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReadOnlyColumn | Gets the read only column.
Public method | GetReadOnlyColumnSection | Gets the read only column section.
Public method | GetReadOnlyScanline(Int32) | Gets the contents of a scanline, allocating memory for the data.
Public method | GetReadOnlyScanline(Int32, Byte) | Copies the contents of a scanline into the supplied array
Public method | GetReadOnlyScanlineSection | Gets the read only scanline section.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAcquireScanline | Subclasses of PixelAccessor implement this method to acquire a pointer to a scanline.
Protected method | LLReleaseScanline | Subclasses of PixelAccessor implement this method to release a previously acquired scanline
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyAccessorReleased | This method is called whenever an accessor has been released.
Protected method | NotifyAccessorReleasing | This method is called when a PixelAccessor is about to be released.
Public method | Release | Releases a PixelAccessor back to the PixelMemory object that owns it.
Public method | ReleaseScanline | Releases the last scanline acquired.
Public method | Reset | Resets the pixel accessor so that AcquireNextScanline will acquire the first scanline in the image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteColumn | Writes the column.
Public method | WriteColumnSection | Writes the column section.
Public method | WriteToScanline | Writes to scanline.
Top
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.AcquireNextScanline Method

PixelAccessorAcquireNextScanline Method

Acquires the next scanline in sequence for this image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] AcquireNextScanline()
Public Function AcquireNextScanline As Byte()

Return Value

Type: Byte
Returns an array of bytes or null if the next scanline would be outside the image's bounds.
Remarks
For the sake of efficiency many implementations of PixelAccessor may return the same byte array, but with different contents. If you need to keep the data from a previously acquired scanline, you should use multiple PixelAccessor objects or explicitly copy the data in the array.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.AcquirePreviousScanline Method

PixelAccessorAcquirePreviousScanline Method

Acquires the previous scanline in the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] AcquirePreviousScanline()
Public Function AcquirePreviousScanline As Byte()

Return Value

Type: Byte
Returns an array of bytes or null if the previous scanline would be outside the image's bounds.
Remarks
For the sake of efficiency many implementations of PixelAccessor may return the same byte array, but with different contents. If you need to keep the data from a previously acquired scanline, you should use multiple PixelAccessor objects or explicitly copy the data in the array.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.AcquireScanline Method

PixelAccessorAcquireScanline Method

Aquires a scanline of data for accessing.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] AcquireScanline(
    int index
)
Public Function AcquireScanline (
    index As Integer
) As Byte()

Parameters

index
Type: SystemInt32
The index of the scanline.

Return Value

Type: Byte
An array of bytes representing the data in the scanline.
Remarks

This method will throw an exception if i is in within the image boundary.

For the sake of efficiency many implementations of PixelAccessor may return the same byte array, but with different contents. If you need to keep the data from a previously acquired scanline, you should use multiple PixelAccessor objects or explicitly copy the data in the array.

See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Dispose Method

PixelAccessorDispose Method

Disposes any resources needed by this PixelAccessor.
Overload List
 | Name | Description
Public method | Dispose | Disposes this PixelAccessor and all its managed and unmanaged resources.
Protected method | Dispose(Boolean) | Disposes this PixelAccessor and all its managed and unmanaged resources.
Top
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Dispose Method

PixelAccessorDispose Method

Disposes this PixelAccessor and all its managed and unmanaged resources.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PixelAccessor Class
Dispose Overload
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Dispose Method (Boolean)

PixelAccessorDispose Method (Boolean)

Disposes this PixelAccessor and all its managed and unmanaged resources.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
If disposing is true, PixelAccessor will dispose its managed resources and its unmanaged resources. If disposing is false, PixelMemory will dispose only its unmanaged resources.
See Also

Reference

PixelAccessor Class
Dispose Overload
Atalasoft.Imaging.Memory Namespace


PixelAccessor.DisposeManagedResources Method

PixelAccessorDisposeManagedResources Method

Disposed any managed objects that implement IDisposable

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void DisposeManagedResources()
Protected MustOverride Sub DisposeManagedResources
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.DisposeUnmanagedResources Method

PixelAccessorDisposeUnmanagedResources Method

Disposes any unmanaged resources such as memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void DisposeUnmanagedResources()
Protected MustOverride Sub DisposeUnmanagedResources
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Finalize Method

PixelAccessorFinalize Method

Finalizes an instance of the PixelAccessor class.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.GetReadOnlyColumn Method

PixelAccessorGetReadOnlyColumn Method

Gets the read only column.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetReadOnlyColumn(
    int srcIndex,
    byte[] data,
    int dataIndex,
    int bytesToReadPerRow
)
Public Sub GetReadOnlyColumn (
    srcIndex As Integer,
    data As Byte(),
    dataIndex As Integer,
    bytesToReadPerRow As Integer
)

Parameters

srcIndex
Type: SystemInt32
Index of the source.
data
Type: SystemByte
The data.
dataIndex
Type: SystemInt32
Index of the data.
bytesToReadPerRow
Type: SystemInt32
The bytes to read per row.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.GetReadOnlyColumnSection Method

PixelAccessorGetReadOnlyColumnSection Method

Gets the read only column section.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetReadOnlyColumnSection(
    int startY,
    int height,
    int srcIndex,
    byte[] data,
    int dataIndex,
    int bytesToReadPerRow
)
Public Sub GetReadOnlyColumnSection (
    startY As Integer,
    height As Integer,
    srcIndex As Integer,
    data As Byte(),
    dataIndex As Integer,
    bytesToReadPerRow As Integer
)

Parameters

startY
Type: SystemInt32
The start y.
height
Type: SystemInt32
The height.
srcIndex
Type: SystemInt32
Index of the source.
data
Type: SystemByte
The data.
dataIndex
Type: SystemInt32
Index of the data.
bytesToReadPerRow
Type: SystemInt32
The bytes to read per row.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | y;scanline index must be within image bounds or height;scanline index must be within image bounds or bytesToRead or srcIndex or dataIndex or srcIndex;Reading + bytesToReadPerRow + bytes would exceed the row stride. or dataIndex;Reading + (bytesToReadPerRow * height) + bytes would exceed the capacity of data[].
PixelMemoryException | low-level accessor failed to read scanline. or low-level accessor returned null on acquire.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.GetReadOnlyScanline Method

PixelAccessorGetReadOnlyScanline Method

Gets the contents of a scanline in a manner that only requires reading the data.
Overload List
 | Name | Description
Public method | GetReadOnlyScanline(Int32) | Gets the contents of a scanline, allocating memory for the data.
Public method | GetReadOnlyScanline(Int32, Byte) | Copies the contents of a scanline into the supplied array
Top
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.GetReadOnlyScanline Method (Int32)

PixelAccessorGetReadOnlyScanline Method (Int32)

Gets the contents of a scanline, allocating memory for the data.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] GetReadOnlyScanline(
    int index
)
Public Function GetReadOnlyScanline (
    index As Integer
) As Byte()

Parameters

index
Type: SystemInt32
The index of the scanline to get.

Return Value

Type: Byte
See Also

Reference

PixelAccessor Class
GetReadOnlyScanline Overload
Atalasoft.Imaging.Memory Namespace


PixelAccessor.GetReadOnlyScanline Method (Int32, Byte[])

PixelAccessorGetReadOnlyScanline Method (Int32, Byte)

Copies the contents of a scanline into the supplied array

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetReadOnlyScanline(
    int index,
    byte[] data
)
Public Sub GetReadOnlyScanline (
    index As Integer,
    data As Byte()
)

Parameters

index
Type: SystemInt32
The scanline to get.
data
Type: SystemByte
An array of bytes to hold the scanline. This array must be at least as long the image's RowStride.
Remarks
AcquireScanline implies that data read will be written back to the image upon release. GetReadOnlyScanline does not require a release, thus the data will not ever be written back to the scanline.
See Also

Reference

PixelAccessor Class
GetReadOnlyScanline Overload
Atalasoft.Imaging.Memory Namespace


PixelAccessor.GetReadOnlyScanlineSection Method

PixelAccessorGetReadOnlyScanlineSection Method

Gets the read only scanline section.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetReadOnlyScanlineSection(
    int y,
    int srcIndex,
    byte[] data,
    int dataIndex,
    int bytesToRead
)
Public Sub GetReadOnlyScanlineSection (
    y As Integer,
    srcIndex As Integer,
    data As Byte(),
    dataIndex As Integer,
    bytesToRead As Integer
)

Parameters

y
Type: SystemInt32
The y.
srcIndex
Type: SystemInt32
Index of the source.
data
Type: SystemByte
The data.
dataIndex
Type: SystemInt32
Index of the data.
bytesToRead
Type: SystemInt32
The bytes to read.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | y;scanline index must be within image bounds or bytesToRead or srcIndex or dataIndex or srcIndex;Reading + bytesToRead + bytes would exceed the row stride. or dataIndex;Reading + bytesToRead + bytes would exceed the capacity of data[].
PixelMemoryException | low-level accessor failed to read scanline. or low-level accessor returned null on acquire.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.LLAcquireScanline Method

PixelAccessorLLAcquireScanline Method

Subclasses of PixelAccessor implement this method to acquire a pointer to a scanline.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract IntPtr LLAcquireScanline(
    int index
)
Protected MustOverride Function LLAcquireScanline (
    index As Integer
) As IntPtr

Parameters

index
Type: SystemInt32
The index of the scanline to access.

Return Value

Type: IntPtr
Remarks
The index will always be in the correct range for this object.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.LLReleaseScanline Method

PixelAccessorLLReleaseScanline Method

Subclasses of PixelAccessor implement this method to release a previously acquired scanline

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLReleaseScanline(
    int index,
    IntPtr p
)
Protected MustOverride Sub LLReleaseScanline (
    index As Integer,
    p As IntPtr
)

Parameters

index
Type: SystemInt32
The index of the scanline to release.
p
Type: SystemIntPtr
A pointer to the scanline, returned by a previous call to AcquireScaline, AcquireNextScanline, or AcquirePreviousScanline.
Remarks
The index will always be in a correct range for this image.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.NotifyAccessorReleased Method

PixelAccessorNotifyAccessorReleased Method

This method is called whenever an accessor has been released.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void NotifyAccessorReleased()
Protected Overridable Sub NotifyAccessorReleased
Remarks
The default implementation does nothing.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.NotifyAccessorReleasing Method

PixelAccessorNotifyAccessorReleasing Method

This method is called when a PixelAccessor is about to be released.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void NotifyAccessorReleasing()
Protected Overridable Sub NotifyAccessorReleasing
Remarks
The default implementation does nothing.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Release Method

PixelAccessorRelease Method

Releases a PixelAccessor back to the PixelMemory object that owns it.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Release()
Public Sub Release
Remarks
Any attempt to use a PixelAccessor after it has been released should result in a throw.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.ReleaseScanline Method

PixelAccessorReleaseScanline Method

Releases the last scanline acquired.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ReleaseScanline()
Public Sub ReleaseScanline
Remarks
If no scanline was previously acquired, this will do nothing.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.Reset Method

PixelAccessorReset Method

Resets the pixel accessor so that AcquireNextScanline will acquire the first scanline in the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.WriteColumn Method

PixelAccessorWriteColumn Method

Writes the column.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void WriteColumn(
    int destIndex,
    byte[] data,
    int dataIndex,
    int bytesToWritePerRow
)
Public Sub WriteColumn (
    destIndex As Integer,
    data As Byte(),
    dataIndex As Integer,
    bytesToWritePerRow As Integer
)

Parameters

destIndex
Type: SystemInt32
Index of the dest.
data
Type: SystemByte
The data.
dataIndex
Type: SystemInt32
Index of the data.
bytesToWritePerRow
Type: SystemInt32
The bytes to write per row.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.WriteColumnSection Method

PixelAccessorWriteColumnSection Method

Writes the column section.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void WriteColumnSection(
    int startY,
    int height,
    int destIndex,
    byte[] data,
    int dataIndex,
    int bytesToWritePerRow
)
Public Sub WriteColumnSection (
    startY As Integer,
    height As Integer,
    destIndex As Integer,
    data As Byte(),
    dataIndex As Integer,
    bytesToWritePerRow As Integer
)

Parameters

startY
Type: SystemInt32
The start y.
height
Type: SystemInt32
The height.
destIndex
Type: SystemInt32
Index of the dest.
data
Type: SystemByte
The data.
dataIndex
Type: SystemInt32
Index of the data.
bytesToWritePerRow
Type: SystemInt32
The bytes to write per row.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | y;scanline index must be within image bounds or height;scanline index must be within image bounds or bytesToWritePerRow or srcIndex or dataIndex or srcIndex;Writing + bytesToWritePerRow + bytes would exceed the row stride. or dataIndex;Writing + (bytesToWritePerRow * height) + bytes would exceed the capacity of data[].
PixelMemoryException | low-level accessor failed to read scanline. or low-level accessor returned null on acquire.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelAccessor.WriteToScanline Method

PixelAccessorWriteToScanline Method

Writes to scanline.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void WriteToScanline(
    int y,
    int destIndex,
    byte[] data,
    int dataIndex,
    int bytesToWrite
)
Public Sub WriteToScanline (
    y As Integer,
    destIndex As Integer,
    data As Byte(),
    dataIndex As Integer,
    bytesToWrite As Integer
)

Parameters

y
Type: SystemInt32
The y.
destIndex
Type: SystemInt32
Index of the dest.
data
Type: SystemByte
The data.
dataIndex
Type: SystemInt32
Index of the data.
bytesToWrite
Type: SystemInt32
The bytes to write.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | y;scanline index must be within image bounds or bytesToRead or destIndex or dataIndex or destIndex;Writing + bytesToWrite + bytes would exceed the row stride. or dataIndex;Writing + bytesToWrite + bytes would exceed the capacity of data[].
PixelMemoryException | low-level accessor failed to read scanline. or low-level accessor returned null on acquire.
See Also

Reference

PixelAccessor Class
Atalasoft.Imaging.Memory Namespace


PixelMemory Class

PixelMemory is an abstract class that defines how an image's pixels are represented in memory, how they are allocated, deallocated, and accessed.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemory
Atalasoft.Imaging.MemoryBitmapPixelMemory
Atalasoft.Imaging.MemoryManagedPixelMemory
Atalasoft.Imaging.MemoryResidentPixelMemory

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PixelMemory : IDisposable,
    ICloneable
Public MustInherit Class PixelMemory
    Implements IDisposable, ICloneable

The PixelMemory type exposes the following members.

Constructors
 | Name | Description
Protected method | PixelMemory | Initializes a new instance of the PixelMemory class
Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed.
Public property | Height | Returns the height of the image represented.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked.
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4.
Top
Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data.
Public method | Clone | Creates a deep copy of this image and its memory.
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources.
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources.
Protected method | DisposeManagedResources | Disposes any unmanaged resources that implement IDisposable
Protected method | DisposeUnmanagedResources | Disposes and unmanaged resources, such as memory not claimed by the garbage collector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLClone | Subclasses of PixelMemory implement this method to create a deep copy of the object.
Protected method | LLGetHeight | Subclasses of PixelMemory implement this method to return the height of the image.
Protected method | LLGetPixelAccessor | Subclasses of PixelMemory implement this method to return a new PixelAccessor object suitable for their particular version of PixelMemory.
Protected method | LLGetRowStride | Subclasses of PixelMemory implement this method to return the number of bytes necessary for a row of pixels. This number should be rounded up to the next multiple of 4 bytes.
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory.
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory.
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PixelDataFromPixelMemory(AtalaImage) | Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
 | PixelDataFromPixelMemory(PixelMemory) | Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
 | PointerSum | Returns an IntPtr that is offset by the provided amount.
 | ThrowOnNonContiguous(AtalaImage) | This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
 | ThrowOnNonContiguous(PixelMemory) | This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock |
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelMemory Constructor

Initializes a new instance of the PixelMemory class

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PixelMemory()
Protected Sub New
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory Properties

The PixelMemory type exposes the following members.

Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed.
Public property | Height | Returns the height of the image represented.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked.
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4.
Top
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Disposed Property

PixelMemoryDisposed Property

Indicates whether or the PixelMemory has been disposed.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Disposed { get; }
Public ReadOnly Property Disposed As Boolean
    Get

Property Value

Type: Boolean
Returns true if the PixelMemory has been disposed and is no longer valid.
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Height Property

PixelMemoryHeight Property

Returns the height of the image represented.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.IsLocked Property

PixelMemoryIsLocked Property

Indicates whether or not the PixelMemory is currently locked.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get

Property Value

Type: Boolean
Examples
C#
Copy
if (!memory.IsLocked) {
    throw new ArgumentException("memory needs to be locked", "memory");
}
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.RowStride Property

PixelMemoryRowStride Property

Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RowStride { get; }
Public ReadOnly Property RowStride As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory Methods

The PixelMemory type exposes the following members.

Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data.
Public method | Clone | Creates a deep copy of this image and its memory.
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources.
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources.
Protected method | DisposeManagedResources | Disposes any unmanaged resources that implement IDisposable
Protected method | DisposeUnmanagedResources | Disposes and unmanaged resources, such as memory not claimed by the garbage collector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLClone | Subclasses of PixelMemory implement this method to create a deep copy of the object.
Protected method | LLGetHeight | Subclasses of PixelMemory implement this method to return the height of the image.
Protected method | LLGetPixelAccessor | Subclasses of PixelMemory implement this method to return a new PixelAccessor object suitable for their particular version of PixelMemory.
Protected method | LLGetRowStride | Subclasses of PixelMemory implement this method to return the number of bytes necessary for a row of pixels. This number should be rounded up to the next multiple of 4 bytes.
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory.
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory.
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PixelDataFromPixelMemory(AtalaImage) | Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
 | PixelDataFromPixelMemory(PixelMemory) | Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
 | PointerSum | Returns an IntPtr that is offset by the provided amount.
 | ThrowOnNonContiguous(AtalaImage) | This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
 | ThrowOnNonContiguous(PixelMemory) | This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock |
Top
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.AcquirePixelAccessor Method

PixelMemoryAcquirePixelAccessor Method

Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelAccessor AcquirePixelAccessor()
Public Function AcquirePixelAccessor As PixelAccessor

Return Value

Type: PixelAccessor
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Clone Method

PixelMemoryClone Method

Creates a deep copy of this image and its memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Dispose Method

PixelMemoryDispose Method

Disposes this PixelMemory and all its managed and unmanaged resources.
Overload List
 | Name | Description
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources.
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources.
Top
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Dispose Method

PixelMemoryDispose Method

Disposes this PixelMemory and all its managed and unmanaged resources.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
When you dispose a PixelMemory objects, all of its PixelAccessor objects will become invalid.
See Also

Reference

PixelMemory Class
Dispose Overload
Atalasoft.Imaging.Memory Namespace


PixelMemory.Dispose Method (Boolean)

PixelMemoryDispose Method (Boolean)

Disposes this PixelMemory and all its managed and unmanaged resources.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
If disposing is true, PixelMemory will dispose its managed resources and its unmanaged resources. If disposing is false, PixelMemory will dispose only its unmanaged resources.
See Also

Reference

PixelMemory Class
Dispose Overload
Atalasoft.Imaging.Memory Namespace


PixelMemory.DisposeManagedResources Method

PixelMemoryDisposeManagedResources Method

Disposes any unmanaged resources that implement IDisposable

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void DisposeManagedResources()
Protected MustOverride Sub DisposeManagedResources
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.DisposeUnmanagedResources Method

PixelMemoryDisposeUnmanagedResources Method

Disposes and unmanaged resources, such as memory not claimed by the garbage collector.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void DisposeUnmanagedResources()
Protected MustOverride Sub DisposeUnmanagedResources
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Finalize Method

PixelMemoryFinalize Method

Finalizes an instance of the PixelMemory class.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.LLClone Method

PixelMemoryLLClone Method

Subclasses of PixelMemory implement this method to create a deep copy of the object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PixelMemory LLClone()
Protected MustOverride Function LLClone As PixelMemory

Return Value

Type: PixelMemory
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.LLGetHeight Method

PixelMemoryLLGetHeight Method

Subclasses of PixelMemory implement this method to return the height of the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LLGetHeight()
Protected MustOverride Function LLGetHeight As Integer

Return Value

Type: Int32
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.LLGetPixelAccessor Method

PixelMemoryLLGetPixelAccessor Method

Subclasses of PixelMemory implement this method to return a new PixelAccessor object suitable for their particular version of PixelMemory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PixelAccessor LLGetPixelAccessor()
Protected MustOverride Function LLGetPixelAccessor As PixelAccessor

Return Value

Type: PixelAccessor
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.LLGetRowStride Method

PixelMemoryLLGetRowStride Method

Subclasses of PixelMemory implement this method to return the number of bytes necessary for a row of pixels. This number should be rounded up to the next multiple of 4 bytes.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract int LLGetRowStride()
Protected MustOverride Function LLGetRowStride As Integer

Return Value

Type: Int32
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.LLLock Method

PixelMemoryLLLock Method

Subclasses of PixelMemory implement this method to lock the memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLLock()
Protected Overridable Sub LLLock
Remarks
LLLock is called by Lock only when it is necessary to actually lock the memory. Lock manages both thread safety as well as accumulation of locks. For any number of calls to Lock without a call to Unlock, there will be precisely one call to LLLock. It is also guaranteed that LLLock can only be called by one thread at a time.
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.LLUnlock Method

PixelMemoryLLUnlock Method

Subclasses of PixelMemory implement this method to unlock the memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLUnlock()
Protected Overridable Sub LLUnlock
Remarks
LLUnlock is called by Unlock only when it is necessary to actually unlock the memory. Unlock manages both thread safety as well as accumulation of locks. For any number of calls to Unlock, there will be precisely one call to LLUnlock when there are no further lock requests. It is also guaranteed that LLUnlock can only be called by one thread at a time.
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.Lock Method

PixelMemoryLock Method

Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Lock()
Public Sub Lock
Exceptions
Exception | Condition
PixelMemoryException | Attempt to lock PixelMemory during dispose.
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.PixelDataFromPixelMemory Method

PixelMemoryPixelDataFromPixelMemory Method

Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
Overload List
Name | Description
PixelDataFromPixelMemory(AtalaImage) | Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
PixelDataFromPixelMemory(PixelMemory) | Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.
Top
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.PixelDataFromPixelMemory Method (AtalaImage)

PixelMemoryPixelDataFromPixelMemory Method (AtalaImage)

Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr PixelDataFromPixelMemory(
    AtalaImage image
)
Public Shared Function PixelDataFromPixelMemory (
    image As AtalaImage
) As IntPtr

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage object.

Return Value

Type: IntPtr
See Also

Reference

PixelMemory Class
PixelDataFromPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


PixelMemory.PixelDataFromPixelMemory Method (PixelMemory)

PixelMemoryPixelDataFromPixelMemory Method (PixelMemory)

Returns an IntPtr to the first scanline of an image if this version of PixelMemory supports that operation, IntPtr.Zero is returned otherwise.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr PixelDataFromPixelMemory(
    PixelMemory pm
)
Public Shared Function PixelDataFromPixelMemory (
    pm As PixelMemory
) As IntPtr

Parameters

pm
Type: Atalasoft.Imaging.MemoryPixelMemory
A pixel memory object.

Return Value

Type: IntPtr
See Also

Reference

PixelMemory Class
PixelDataFromPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


PixelMemory.PointerSum Method

PixelMemoryPointerSum Method

Returns an IntPtr that is offset by the provided amount.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IntPtr PointerSum(
    IntPtr p,
    int offset
)
Public Shared Function PointerSum (
    p As IntPtr,
    offset As Integer
) As IntPtr

Parameters

p
Type: SystemIntPtr
An IntPtr
offset
Type: SystemInt32
An offset in bytes to add to the pointer

Return Value

Type: IntPtr
An IntPtr that has been offset by the provided amount.
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.ThrowOnNonContiguous Method

PixelMemoryThrowOnNonContiguous Method

This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
Overload List
Name | Description
ThrowOnNonContiguous(AtalaImage) | This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
ThrowOnNonContiguous(PixelMemory) | This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.
Top
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemory.ThrowOnNonContiguous Method (AtalaImage)

PixelMemoryThrowOnNonContiguous Method (AtalaImage)

This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ThrowOnNonContiguous(
    AtalaImage image
)
Public Shared Sub ThrowOnNonContiguous (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage object.
See Also

Reference

PixelMemory Class
ThrowOnNonContiguous Overload
Atalasoft.Imaging.Memory Namespace


PixelMemory.ThrowOnNonContiguous Method (PixelMemory)

PixelMemoryThrowOnNonContiguous Method (PixelMemory)

This is a utility method to throw an exception if a PixelMemory object is not represented by a single contiguous block of memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ThrowOnNonContiguous(
    PixelMemory pm
)
Public Shared Sub ThrowOnNonContiguous (
    pm As PixelMemory
)

Parameters

pm
Type: Atalasoft.Imaging.MemoryPixelMemory
A pixel memory object.
See Also

Reference

PixelMemory Class
ThrowOnNonContiguous Overload
Atalasoft.Imaging.Memory Namespace


PixelMemory.Unlock Method

PixelMemoryUnlock Method

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Unlock()
Public Sub Unlock
Remarks
In a sequence of calls to Unlock, the memory will only actually be unlocked when all locks have been released. Every call to Lock should be balanced with a call to Unlock. When the PixelMemory is disposed, all pending locks will be released. Client code is encouraged to use the PixelMemoryLocker object to make lock management easier.
See Also

Reference

PixelMemory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryAllocator Delegate

This delegate is used to define a method to allocate pixel memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate PixelMemory PixelMemoryAllocator(
    PixelMemoryFactoryParameters factoryParameters,
    Object o
)
Public Delegate Function PixelMemoryAllocator (
    factoryParameters As PixelMemoryFactoryParameters,
    o As Object
) As PixelMemory

Parameters

factoryParameters
Type: Atalasoft.Imaging.MemoryPixelMemoryFactoryParameters
The parameters used to control how the PixelMemory object will be allocated.
o
Type: SystemObject
A user supplied object to control memory allocation.

Return Value

Type: PixelMemory
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory Class

PixelMemoryFactory is a singleton object that is used for allocating all image memory in dotImage. The object is accessed through the static Factory property.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemoryFactory

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PixelMemoryFactory
Public Class PixelMemoryFactory

The PixelMemoryFactory type exposes the following members.

Properties
 | Name | Description
 | Allocator | Sets or gets the PixelMemoryAllocator that will be used to allocate PixelMemory.
Public property | AllocatorObject | Sets or gets and object passed to the Allocator delegate.
 | DefaultAllocator | Gets the default allocator that is used by dotImage.
 | Factory | Gets the singleton object used for memory allocation.
Top
Methods
 | Name | Description
 | Allocate | Allocates a new PixelMemory object using the supplied parameters.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
All PixelMemory should be allocated through this object instead of constructing a concrete subclass of PixelMemory directly.
Examples
C#
Copy
PixelMemory memory = PixelMemoryFactory.Factory.Allocate(parameters);
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory Properties

The PixelMemoryFactory type exposes the following members.

Properties
 | Name | Description
 | Allocator | Sets or gets the PixelMemoryAllocator that will be used to allocate PixelMemory.
Public property | AllocatorObject | Sets or gets and object passed to the Allocator delegate.
 | DefaultAllocator | Gets the default allocator that is used by dotImage.
 | Factory | Gets the singleton object used for memory allocation.
Top
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory.Allocator Property

PixelMemoryFactoryAllocator Property

Sets or gets the PixelMemoryAllocator that will be used to allocate PixelMemory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryAllocator Allocator { get; set; }
Public Property Allocator As PixelMemoryAllocator
    Get
    Set

Property Value

Type: PixelMemoryAllocator
Remarks
It is not necessary to call the Allocator directly. Instead, use the Allocate method.
Examples
C#
Copy
PixelMemoryFactory.Factory.Allocator = PixelMemoryFactory.Factory.DefaultAllocator;
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory.AllocatorObject Property

PixelMemoryFactoryAllocatorObject Property

Sets or gets and object passed to the Allocator delegate.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object AllocatorObject { get; set; }
Public Property AllocatorObject As Object
    Get
    Set

Property Value

Type: Object
Remarks
This is a memento object intended to be used by the Allocator to hold private data that might be needed at allocation time. This object is not currently used in the default allocator, although it may be used in the future. Client allocators should be prepared to handle conditions when this object might have been changed to something unexpected.
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory.DefaultAllocator Property

PixelMemoryFactoryDefaultAllocator Property

Gets the default allocator that is used by dotImage.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PixelMemoryAllocator DefaultAllocator { get; }
Public Shared ReadOnly Property DefaultAllocator As PixelMemoryAllocator
    Get

Property Value

Type: PixelMemoryAllocator
Remarks
The intent of this property is to allow client code to restore the allocator to "factory settings".
Examples

This example illustrates how to restore the Allocator to its default setting.

C#
Copy
PixelMemoryFactory.Factory.Allocator = PixelMemoryFactory.Factory.DefaultAllocator;
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory.Factory Property

PixelMemoryFactoryFactory Property

Gets the singleton object used for memory allocation.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PixelMemoryFactory Factory { get; }
Public Shared ReadOnly Property Factory As PixelMemoryFactory
    Get

Property Value

Type: PixelMemoryFactory
Examples
C#
Copy
PixelMemory memory = PixelMemoryFactory.Factory.Allocate(parameters);
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory Methods

The PixelMemoryFactory type exposes the following members.

Methods
 | Name | Description
 | Allocate | Allocates a new PixelMemory object using the supplied parameters.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactory.Allocate Method

PixelMemoryFactoryAllocate Method

Allocates a new PixelMemory object using the supplied parameters.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemory Allocate(
    PixelMemoryFactoryParameters factoryParameters
)
Public Function Allocate (
    factoryParameters As PixelMemoryFactoryParameters
) As PixelMemory

Parameters

factoryParameters
Type: Atalasoft.Imaging.MemoryPixelMemoryFactoryParameters
The parameters used to control how the PixelMemory object will be allocated.

Return Value

Type: PixelMemory
Remarks
Allocate will use the Allocator property to perform the actual allocation. When the Allocator is invoked, it will be passed the AllocatorObject.
See Also

Reference

PixelMemoryFactory Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Class

This class is used to control how PixelMemory is allocated by the PixelMemoryFactory
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemoryFactoryParameters

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PixelMemoryFactoryParameters
Public Class PixelMemoryFactoryParameters

The PixelMemoryFactoryParameters type exposes the following members.

Constructors
 | Name | Description
Public method | PixelMemoryFactoryParameters(Int32, Int32) | Constructs a new PixelMemoryFactoryParameters object.
Public method | PixelMemoryFactoryParameters(Int64, Int32, Int32) | Constructs a new PixelMemoryFactoryParameters object.
 | PixelMemoryFactoryParameters(Int64, Int32, Int32, Int32, Boolean) | Constructs a new PixelMemoryFactoryParameters object.
Top
Properties
 | Name | Description
Public property | Height | Sets or gets the requested height of the image in scan lines
Public property | NumBytes | Sets or gets the requested total number of bytes needed for the memory. This should be no less than height * rowStride + offsetToFirstScanline, but it can be more.
Public property | OffsetToFirstScanline | Sets or gets the offset in bytes to the first scan line from the start of memory.
Public property | RowStride | Sets or gets the length of a scan line in bytes. This should be a multiple of 4.
Public property | ZeroMemory | Sets or gets whether or not memory will be set to zero upon allocation
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
C#
Copy
public PixelMemory MyAllocator(PixelMemoryFactoryParameters factoryParameters, object allocationObject)
{
    MyFactoryParams myParams = factoryParameters as MyFactoryParams;
    if (myParams != null) {
        return PerformCustomAllocation(myParams);
    }
    else {
        return InvokePreviousAllocator(factoryParameters);
    }
}

}
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Constructor

Constructs a new PixelMemoryFactoryParameters object.
Examples
C#
Copy
PixelMemoryFactoryParameters myParams = new PixelMemoryFactoryParameters(200, 32);
Overload List
 | Name | Description
Public method | PixelMemoryFactoryParameters(Int32, Int32) | Constructs a new PixelMemoryFactoryParameters object.
Public method | PixelMemoryFactoryParameters(Int64, Int32, Int32) | Constructs a new PixelMemoryFactoryParameters object.
 | PixelMemoryFactoryParameters(Int64, Int32, Int32, Int32, Boolean) | Constructs a new PixelMemoryFactoryParameters object.
Top
Examples
C#
Copy
PixelMemoryFactoryParameters myParams = new PixelMemoryFactoryParameters(200, 32);
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Constructor (Int32, Int32)

Constructs a new PixelMemoryFactoryParameters object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryFactoryParameters(
    int height,
    int rowStride
)
Public Sub New (
    height As Integer,
    rowStride As Integer
)

Parameters

height
Type: SystemInt32
The height of the image in scan lines
rowStride
Type: SystemInt32
The length of a scan line in bytes. This should be a multiple of 4.
See Also

Reference

PixelMemoryFactoryParameters Class
PixelMemoryFactoryParameters Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Constructor (Int64, Int32, Int32)

Constructs a new PixelMemoryFactoryParameters object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryFactoryParameters(
    long numBytes,
    int height,
    int rowStride
)
Public Sub New (
    numBytes As Long,
    height As Integer,
    rowStride As Integer
)

Parameters

numBytes
Type: SystemInt64
The total number of bytes needed for the memory. This should be no less than height * rowStride + offsetToFirstScanline, but it can be more.
height
Type: SystemInt32
The height of the image in scan lines
rowStride
Type: SystemInt32
The length of a scan line in bytes. This should be a multiple of 4.
See Also

Reference

PixelMemoryFactoryParameters Class
PixelMemoryFactoryParameters Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Constructor (Int64, Int32, Int32, Int32, Boolean)

Constructs a new PixelMemoryFactoryParameters object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryFactoryParameters(
    long numBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline,
    bool zeroMemory
)
Public Sub New (
    numBytes As Long,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer,
    zeroMemory As Boolean
)

Parameters

numBytes
Type: SystemInt64
The total number of bytes needed for the memory. This should be no less than height * rowStride + offsetToFirstScanline, but it can be more.
height
Type: SystemInt32
The height of the image in scan lines
rowStride
Type: SystemInt32
The length of a scan line in bytes. This should be a multiple of 4.
offsetToFirstScanline
Type: SystemInt32
The offset in bytes to the first scan line from the start of memory.
zeroMemory
Type: SystemBoolean
Indicates whether or not memory should be set to zero.
See Also

Reference

PixelMemoryFactoryParameters Class
PixelMemoryFactoryParameters Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Properties

The PixelMemoryFactoryParameters type exposes the following members.

Properties
 | Name | Description
Public property | Height | Sets or gets the requested height of the image in scan lines
Public property | NumBytes | Sets or gets the requested total number of bytes needed for the memory. This should be no less than height * rowStride + offsetToFirstScanline, but it can be more.
Public property | OffsetToFirstScanline | Sets or gets the offset in bytes to the first scan line from the start of memory.
Public property | RowStride | Sets or gets the length of a scan line in bytes. This should be a multiple of 4.
Public property | ZeroMemory | Sets or gets whether or not memory will be set to zero upon allocation
Top
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters.Height Property

PixelMemoryFactoryParametersHeight Property

Sets or gets the requested height of the image in scan lines

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Height must be 1 or greater.
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters.NumBytes Property

PixelMemoryFactoryParametersNumBytes Property

Sets or gets the requested total number of bytes needed for the memory. This should be no less than height * rowStride + offsetToFirstScanline, but it can be more.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long NumBytes { get; set; }
Public Property NumBytes As Long
    Get
    Set

Property Value

Type: Int64
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters.OffsetToFirstScanline Property

PixelMemoryFactoryParametersOffsetToFirstScanline Property

Sets or gets the offset in bytes to the first scan line from the start of memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int OffsetToFirstScanline { get; set; }
Public Property OffsetToFirstScanline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters.RowStride Property

PixelMemoryFactoryParametersRowStride Property

Sets or gets the length of a scan line in bytes. This should be a multiple of 4.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RowStride { get; set; }
Public Property RowStride As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters.ZeroMemory Property

PixelMemoryFactoryParametersZeroMemory Property

Sets or gets whether or not memory will be set to zero upon allocation

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ZeroMemory { get; set; }
Public Property ZeroMemory As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryFactoryParameters Methods

The PixelMemoryFactoryParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PixelMemoryFactoryParameters Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryLocker Class

PixelMemoryLocker is a utility class to help manage the locking and unlocking of memory. By constructing a PixelMemoryLocker object in a using block, PixelMemory will be automatically locked on entrance and exit of the block.
Inheritance Hierarchy
SystemObject
Atalasoft.ImagingResourceReleaser PixelMemory
Atalasoft.Imaging.MemoryPixelMemoryLocker

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PixelMemoryLocker : ResourceReleaser<PixelMemory>
Public Class PixelMemoryLocker
    Inherits ResourceReleaser(Of PixelMemory)

The PixelMemoryLocker type exposes the following members.

Constructors
 | Name | Description
Public method | PixelMemoryLocker(AtalaImage) | Constructs an object that will automatically lock and unlock the PixelMemory for the supplied AtalaImage.
Public method | PixelMemoryLocker(PixelMemory) | Constructs an object that will automatically lock and unlock the supplied PixelMemory.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser. (Inherited from ResourceReleaserT.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ResourceReleaserT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ResourceReleaserT class. (Inherited from ResourceReleaserT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | mVal | The backing field for the val parameter. (Inherited from ResourceReleaserT.)
Top
Remarks
PixelMemoryLocker should never be used outside of a using block. PixelMemoryLocker depends on Dispose being called in a predictable manner to operate correctly. Using a PixelMemoryLocker outside a using block will cause unpredictable behavior since the memory will be unlocked when the object is either disposed or garbage collected.
Examples
C#
Copy
using (PixelMemoryLocker locker = new PixelMemoryLocker(myImage)) {
    PerformDirectMemoryAccess(myImage);
}
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelMemoryLocker Constructor

Constructs a new PixelMemoryLocker object.
Overload List
 | Name | Description
Public method | PixelMemoryLocker(AtalaImage) | Constructs an object that will automatically lock and unlock the PixelMemory for the supplied AtalaImage.
Public method | PixelMemoryLocker(PixelMemory) | Constructs an object that will automatically lock and unlock the supplied PixelMemory.
Top
See Also

Reference

PixelMemoryLocker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryLocker Constructor (AtalaImage)

Constructs an object that will automatically lock and unlock the PixelMemory for the supplied AtalaImage.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryLocker(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An image to be locked. If image is null, PixelMemoryLocker will do nothing.
Remarks
PixelMemoryLocker should never be used outside of a using block. PixelMemoryLocker depends on Dispose being called in a predictable manner to operate correctly. Using a PixelMemoryLocker outside a using block will cause unpredictable behavior since the memory will be unlocked when the object is either disposed or garbage collected.
See Also

Reference

PixelMemoryLocker Class
PixelMemoryLocker Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryLocker Constructor (PixelMemory)

Constructs an object that will automatically lock and unlock the supplied PixelMemory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PixelMemoryLocker(
    PixelMemory mem
)
Public Sub New (
    mem As PixelMemory
)

Parameters

mem
Type: Atalasoft.Imaging.MemoryPixelMemory
The PixelMemory object to be locked. If mem is null, it will be ignored.
Remarks
PixelMemoryLocker should never be used outside of a using block. PixelMemoryLocker depends on Dispose being called in a predictable manner to operate correctly. Using a PixelMemoryLocker outside a using block will cause unpredictable behavior since the memory will be unlocked when the object is either disposed or garbage collected.
Remarks
Construction of the object will immediately lock the pixel memory.
See Also

Reference

PixelMemoryLocker Class
PixelMemoryLocker Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryLocker Methods

The PixelMemoryLocker type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the ResourceReleaser. (Inherited from ResourceReleaserT.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources. (Inherited from ResourceReleaserT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the ResourceReleaserT class. (Inherited from ResourceReleaserT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PixelMemoryLocker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryLocker Fields

The PixelMemoryLocker type exposes the following members.

Fields
 | Name | Description
Protected field | mVal | The backing field for the val parameter. (Inherited from ResourceReleaserT.)
Top
See Also

Reference

PixelMemoryLocker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker Class

This is a singleton class that is used for tracking memory used by images.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemoryTracker

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PixelMemoryTracker
Public Class PixelMemoryTracker

The PixelMemoryTracker type exposes the following members.

Properties
 | Name | Description
Public property | HighWatermark | Sets or gets a trigger point for memory events.
 | Memory | Returns a singleton object used for tracking memory.
Public property | MemoryInUse | Indicates the total amount of memory in use by AtalaImage objects.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MemoryAllocated(IntPtr, Int64) | This method is used to report an allocation of image memory.
Public method | MemoryAllocated(Object, Int64) | Report than an object has allocated memory.
Public method | MemoryFreed(IntPtr) | Reports a block of memory as free.
Public method | MemoryFreed(Object) | Marks memory as free
Public method | MemoryReallocated | This method is used to report when a block of allocated image memory has been reallocated.
Protected method | OnDroppedBelowHighWatermark | This method handles when memory usage has dropped below the high water mark.
Protected method | OnExceededHighWatermark | This method handles when memory usage has exceeded the high water mark
Protected method | OnMemoryInUseChanged | This method handles when memory usage has changed in some way
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DroppedBelowHighWatermark | This event is fired is MemoryInUse drops below the HighWatermark property of PixelMemoryTracker
Public event | ExceededHighWatermark | This event is fired is MemoryInUse exceeds the HighWatermark property of PixelMemoryTracker
Public event | MemoryInUseChanged | An event for reporting changes in the current memory use.
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker Properties

The PixelMemoryTracker type exposes the following members.

Properties
 | Name | Description
Public property | HighWatermark | Sets or gets a trigger point for memory events.
 | Memory | Returns a singleton object used for tracking memory.
Public property | MemoryInUse | Indicates the total amount of memory in use by AtalaImage objects.
Top
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.HighWatermark Property

PixelMemoryTrackerHighWatermark Property

Sets or gets a trigger point for memory events.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long HighWatermark { get; set; }
Public Property HighWatermark As Long
    Get
    Set

Property Value

Type: Int64
Remarks
When total image memory in use exceeds this value, an event will be fired.
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.Memory Property

PixelMemoryTrackerMemory Property

Returns a singleton object used for tracking memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PixelMemoryTracker Memory { get; }
Public Shared ReadOnly Property Memory As PixelMemoryTracker
    Get

Property Value

Type: PixelMemoryTracker
Remarks
There is only one PixelMemoryTracker object used for tracking memory across a single .NET application. All operations on this object are thread-safe.
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryInUse Property

PixelMemoryTrackerMemoryInUse Property

Indicates the total amount of memory in use by AtalaImage objects.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public long MemoryInUse { get; }
Public ReadOnly Property MemoryInUse As Long
    Get

Property Value

Type: Int64
Remarks
Some images include memory which is not used for visual parts of the image. This memory should also be included in the total bytes.
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker Methods

The PixelMemoryTracker type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MemoryAllocated(IntPtr, Int64) | This method is used to report an allocation of image memory.
Public method | MemoryAllocated(Object, Int64) | Report than an object has allocated memory.
Public method | MemoryFreed(IntPtr) | Reports a block of memory as free.
Public method | MemoryFreed(Object) | Marks memory as free
Public method | MemoryReallocated | This method is used to report when a block of allocated image memory has been reallocated.
Protected method | OnDroppedBelowHighWatermark | This method handles when memory usage has dropped below the high water mark.
Protected method | OnExceededHighWatermark | This method handles when memory usage has exceeded the high water mark
Protected method | OnMemoryInUseChanged | This method handles when memory usage has changed in some way
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryAllocated Method

PixelMemoryTrackerMemoryAllocated Method

Overload List
 | Name | Description
Public method | MemoryAllocated(IntPtr, Int64) | This method is used to report an allocation of image memory.
Public method | MemoryAllocated(Object, Int64) | Report than an object has allocated memory.
Top
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryAllocated Method (IntPtr, Int64)

PixelMemoryTrackerMemoryAllocated Method (IntPtr, Int64)

This method is used to report an allocation of image memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MemoryAllocated(
    IntPtr location,
    long size
)
Public Sub MemoryAllocated (
    location As IntPtr,
    size As Long
)

Parameters

location
Type: SystemIntPtr
A pointer to the first byte of image memory.
size
Type: SystemInt64
The number of bytes used by this block of memory.
Remarks

MemoryAllocated will throw is the location has already been reported as allocated or if the location is null or the size is less than or equal to zero.

All memory reporting routines are thread-safe.

See Also

Reference

PixelMemoryTracker Class
MemoryAllocated Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryAllocated Method (Object, Int64)

PixelMemoryTrackerMemoryAllocated Method (Object, Int64)

Report than an object has allocated memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MemoryAllocated(
    Object o,
    long numBytes
)
Public Sub MemoryAllocated (
    o As Object,
    numBytes As Long
)

Parameters

o
Type: SystemObject
The o.
numBytes
Type: SystemInt64
The number bytes.
See Also

Reference

PixelMemoryTracker Class
MemoryAllocated Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryFreed Method

PixelMemoryTrackerMemoryFreed Method

Overload List
 | Name | Description
Public method | MemoryFreed(IntPtr) | Reports a block of memory as free.
Public method | MemoryFreed(Object) | Marks memory as free
Top
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryFreed Method (IntPtr)

PixelMemoryTrackerMemoryFreed Method (IntPtr)

Reports a block of memory as free.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MemoryFreed(
    IntPtr location
)
Public Sub MemoryFreed (
    location As IntPtr
)

Parameters

location
Type: SystemIntPtr
A pointer to the memory about to be freed.
Remarks
This method is thread-safe.
See Also

Reference

PixelMemoryTracker Class
MemoryFreed Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryFreed Method (Object)

PixelMemoryTrackerMemoryFreed Method (Object)

Marks memory as free

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MemoryFreed(
    Object o
)
Public Sub MemoryFreed (
    o As Object
)

Parameters

o
Type: SystemObject
The o.
Exceptions
Exception | Condition
ArgumentException | Can't mark null pointer as free;location or Unable to location allocation entry;o
See Also

Reference

PixelMemoryTracker Class
MemoryFreed Overload
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryReallocated Method

PixelMemoryTrackerMemoryReallocated Method

This method is used to report when a block of allocated image memory has been reallocated.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MemoryReallocated(
    IntPtr oldLocation,
    IntPtr newLocation,
    long newSize
)
Public Sub MemoryReallocated (
    oldLocation As IntPtr,
    newLocation As IntPtr,
    newSize As Long
)

Parameters

oldLocation
Type: SystemIntPtr
The previous location in memory
newLocation
Type: SystemIntPtr
The new location in memory
newSize
Type: SystemInt64
The size of the new block.
Remarks

If oldLocation has not been previously reported as allocated via MemoryAllocated, this method will throw.

This method is equivalent to:

ReportFreed(oldLocation);

ReportAllocated(newLocation, newSize);

See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.OnDroppedBelowHighWatermark Method

PixelMemoryTrackerOnDroppedBelowHighWatermark Method

This method handles when memory usage has dropped below the high water mark.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDroppedBelowHighWatermark(
    MemoryUseEventArgs e
)
Protected Overridable Sub OnDroppedBelowHighWatermark (
    e As MemoryUseEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.MemoryMemoryUseEventArgs
A MemoryUseEventArgs object indicating the change in memory.
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.OnExceededHighWatermark Method

PixelMemoryTrackerOnExceededHighWatermark Method

This method handles when memory usage has exceeded the high water mark

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnExceededHighWatermark(
    MemoryUseEventArgs e
)
Protected Overridable Sub OnExceededHighWatermark (
    e As MemoryUseEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.MemoryMemoryUseEventArgs
A MemoryUseEventArgs object indicating the change in memory.
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.OnMemoryInUseChanged Method

PixelMemoryTrackerOnMemoryInUseChanged Method

This method handles when memory usage has changed in some way

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMemoryInUseChanged(
    MemoryUseEventArgs e
)
Protected Overridable Sub OnMemoryInUseChanged (
    e As MemoryUseEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.MemoryMemoryUseEventArgs
A MemoryUseEventArgs object indicating the change in memory.
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker Events

The PixelMemoryTracker type exposes the following members.

Events
 | Name | Description
Public event | DroppedBelowHighWatermark | This event is fired is MemoryInUse drops below the HighWatermark property of PixelMemoryTracker
Public event | ExceededHighWatermark | This event is fired is MemoryInUse exceeds the HighWatermark property of PixelMemoryTracker
Public event | MemoryInUseChanged | An event for reporting changes in the current memory use.
Top
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.DroppedBelowHighWatermark Event

PixelMemoryTrackerDroppedBelowHighWatermark Event

This event is fired is MemoryInUse drops below the HighWatermark property of PixelMemoryTracker

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MemoryUseEventHandler DroppedBelowHighWatermark
Public Event DroppedBelowHighWatermark As MemoryUseEventHandler

Value

Type: Atalasoft.Imaging.MemoryMemoryUseEventHandler
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.ExceededHighWatermark Event

PixelMemoryTrackerExceededHighWatermark Event

This event is fired is MemoryInUse exceeds the HighWatermark property of PixelMemoryTracker

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MemoryUseEventHandler ExceededHighWatermark
Public Event ExceededHighWatermark As MemoryUseEventHandler

Value

Type: Atalasoft.Imaging.MemoryMemoryUseEventHandler
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


PixelMemoryTracker.MemoryInUseChanged Event

PixelMemoryTrackerMemoryInUseChanged Event

An event for reporting changes in the current memory use.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MemoryUseEventHandler MemoryInUseChanged
Public Event MemoryInUseChanged As MemoryUseEventHandler

Value

Type: Atalasoft.Imaging.MemoryMemoryUseEventHandler
See Also

Reference

PixelMemoryTracker Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory Class

This is a class used to represent PixelMemory that is resident and for which allocation and deallocation are controlled.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MemoryPixelMemory
Atalasoft.Imaging.MemoryResidentPixelMemory
Atalasoft.Imaging.MemoryGlobalAllocPixelMemory

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ResidentPixelMemory : PixelMemory,
    IDirectScanlineAccess
Public MustInherit Class ResidentPixelMemory
    Inherits PixelMemory
    Implements IDirectScanlineAccess

The ResidentPixelMemory type exposes the following members.

Constructors
 | Name | Description
Public method | ResidentPixelMemory(Int32, Int32, Int32) | Initializes a new instance of the ResidentPixelMemory class, total size in bytes is calculated by multiplying height and rowString and adding offsetToFirstScanline.
Public method | ResidentPixelMemory(Int64, Int32, Int32, Int32) | Initializes a new instance of the ResidentPixelMemory class.
Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Returns true.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Protected property | LLPixelMemoryStart | Returns a pointer to the start of memory.
Protected property | OffsetToFirstScanline | Returns an offset to the first scanline of the image.
Public property | PixelData | Returns a pointer to the first scanline in the image.
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Protected property | SizeInBytes | Returns the number of bytes used by the memory for this image.
Top
Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Protected method | AllocateMemory | Allocates memory for this PixelMemory object and reports it for tracking.
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any unmanaged resources. (Overrides PixelMemoryDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes the memory used by this object. (Overrides PixelMemoryDisposeUnmanagedResources.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Protected method | FreeMemory | Frees memory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Gets a pointer to the a given scanline.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAllocateMemory(Int32, Boolean) | Obsolete. Subclasses of ResidentPixelMemory implement this method to allocate memory.
Protected method | LLAllocateMemory(Int64, Boolean) | Subclasses of ResidentPixelMemory implement this method to allocate memory.
Protected method | LLClone | Subclasses of PixelMemory implement this method to create a deep copy of the object. (Inherited from PixelMemory.)
Protected method | LLFreeMemory | Subclasses of ResidentPixelMemory implement this method to free memory.
Protected method | LLGetHeight | Returns the height of the image. (Overrides PixelMemoryLLGetHeight.)
Protected method | LLGetPixelAccessor | Returns a suitable PixelAccesor object for this PixelMemory. (Overrides PixelMemoryLLGetPixelAccessor.)
Protected method | LLGetRowStride | Returns the size of a scanline in bytes, rounded up to the next multiple of 4. (Overrides PixelMemoryLLGetRowStride.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Inherited from PixelMemory.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Inherited from PixelMemory.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RerportMemoryAllocated | Rerports that memory was allocated.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory Constructor

Overload List
 | Name | Description
Public method | ResidentPixelMemory(Int32, Int32, Int32) | Initializes a new instance of the ResidentPixelMemory class, total size in bytes is calculated by multiplying height and rowString and adding offsetToFirstScanline.
Public method | ResidentPixelMemory(Int64, Int32, Int32, Int32) | Initializes a new instance of the ResidentPixelMemory class.
Top
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory Constructor (Int32, Int32, Int32)

Initializes a new instance of the ResidentPixelMemory class, total size in bytes is calculated by multiplying height and rowString and adding offsetToFirstScanline.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResidentPixelMemory(
    int height,
    int rowStride,
    int offsetToFirstScanline
)
Public Sub New (
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer
)

Parameters

height
Type: SystemInt32
The height.
rowStride
Type: SystemInt32
The row stride.
offsetToFirstScanline
Type: SystemInt32
The offset to first scanline.
See Also

Reference

ResidentPixelMemory Class
ResidentPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory Constructor (Int64, Int32, Int32, Int32)

Initializes a new instance of the ResidentPixelMemory class.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResidentPixelMemory(
    long sizeInBytes,
    int height,
    int rowStride,
    int offsetToFirstScanline
)
Public Sub New (
    sizeInBytes As Long,
    height As Integer,
    rowStride As Integer,
    offsetToFirstScanline As Integer
)

Parameters

sizeInBytes
Type: SystemInt64
The total size in bytes for the image.
height
Type: SystemInt32
The height of the image.
rowStride
Type: SystemInt32
The row stride of the image.
offsetToFirstScanline
Type: SystemInt32
The offset in bytes to first scanline from the start of the image data.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | offsetToFirstScanline;offset must be greater than or equal to zero or height;height must be greater than 0. or height;rowStride must be greater than 0.
ArgumentException | offsetToFirstScanline;Offset to first scanline must be a multiple of 4
See Also

Reference

ResidentPixelMemory Class
ResidentPixelMemory Overload
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory Properties

The ResidentPixelMemory type exposes the following members.

Properties
 | Name | Description
Public property | Disposed | Indicates whether or the PixelMemory has been disposed. (Inherited from PixelMemory.)
Public property | Height | Returns the height of the image represented. (Inherited from PixelMemory.)
Public property | IsContiguous | Returns true.
 | IsLocked | Indicates whether or not the PixelMemory is currently locked. (Inherited from PixelMemory.)
Protected property | LLPixelMemoryStart | Returns a pointer to the start of memory.
Protected property | OffsetToFirstScanline | Returns an offset to the first scanline of the image.
Public property | PixelData | Returns a pointer to the first scanline in the image.
Public property | RowStride | Returns the number of bytes in a row of this image. The number is always rounded up to the next multiple of 4. (Inherited from PixelMemory.)
Protected property | SizeInBytes | Returns the number of bytes used by the memory for this image.
Top
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.IsContiguous Property

ResidentPixelMemoryIsContiguous Property

Returns true.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsContiguous { get; }
Public Overridable ReadOnly Property IsContiguous As Boolean
    Get

Property Value

Type: Boolean

Implements

IDirectScanlineAccessIsContiguous
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLPixelMemoryStart Property

ResidentPixelMemoryLLPixelMemoryStart Property

Returns a pointer to the start of memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IntPtr LLPixelMemoryStart { get; set; }
Protected Overridable Property LLPixelMemoryStart As IntPtr
    Get
    Set

Property Value

Type: IntPtr
Remarks
This pointer may not be a pointer to the first scanline.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.OffsetToFirstScanline Property

ResidentPixelMemoryOffsetToFirstScanline Property

Returns an offset to the first scanline of the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int OffsetToFirstScanline { get; }
Protected ReadOnly Property OffsetToFirstScanline As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.PixelData Property

ResidentPixelMemoryPixelData Property

Returns a pointer to the first scanline in the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr PixelData { get; }
Public ReadOnly Property PixelData As IntPtr
    Get

Property Value

Type: IntPtr
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.SizeInBytes Property

ResidentPixelMemorySizeInBytes Property

Returns the number of bytes used by the memory for this image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected long SizeInBytes { get; }
Protected ReadOnly Property SizeInBytes As Long
    Get

Property Value

Type: Int64
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory Methods

The ResidentPixelMemory type exposes the following members.

Methods
 | Name | Description
Public method | AcquirePixelAccessor | Returns an object that inherits from PixelAccessor that is used to get to an image's pixel data. (Inherited from PixelMemory.)
Protected method | AllocateMemory | Allocates memory for this PixelMemory object and reports it for tracking.
Public method | Clone | Creates a deep copy of this image and its memory. (Inherited from PixelMemory.)
Public method | Dispose | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | Dispose(Boolean) | Disposes this PixelMemory and all its managed and unmanaged resources. (Inherited from PixelMemory.)
Protected method | DisposeManagedResources | Disposes any unmanaged resources. (Overrides PixelMemoryDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes the memory used by this object. (Overrides PixelMemoryDisposeUnmanagedResources.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the PixelMemory class. (Inherited from PixelMemory.)
Protected method | FreeMemory | Frees memory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScanLinePtr | Gets a pointer to the a given scanline.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAllocateMemory(Int32, Boolean) | Obsolete. Subclasses of ResidentPixelMemory implement this method to allocate memory.
Protected method | LLAllocateMemory(Int64, Boolean) | Subclasses of ResidentPixelMemory implement this method to allocate memory.
Protected method | LLClone | Subclasses of PixelMemory implement this method to create a deep copy of the object. (Inherited from PixelMemory.)
Protected method | LLFreeMemory | Subclasses of ResidentPixelMemory implement this method to free memory.
Protected method | LLGetHeight | Returns the height of the image. (Overrides PixelMemoryLLGetHeight.)
Protected method | LLGetPixelAccessor | Returns a suitable PixelAccesor object for this PixelMemory. (Overrides PixelMemoryLLGetPixelAccessor.)
Protected method | LLGetRowStride | Returns the size of a scanline in bytes, rounded up to the next multiple of 4. (Overrides PixelMemoryLLGetRowStride.)
Protected method | LLLock | Subclasses of PixelMemory implement this method to lock the memory. (Inherited from PixelMemory.)
Protected method | LLUnlock | Subclasses of PixelMemory implement this method to unlock the memory. (Inherited from PixelMemory.)
Public method | Lock | Locks this instance of PixelMemory. For memory objects that are movable, this will prevent the PixelMemory from moving. Client code rarely needs to use this method. (Inherited from PixelMemory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RerportMemoryAllocated | Rerports that memory was allocated.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | (Inherited from PixelMemory.)
Top
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.AllocateMemory Method

ResidentPixelMemoryAllocateMemory Method

Allocates memory for this PixelMemory object and reports it for tracking.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IntPtr AllocateMemory(
    long numBytes,
    bool zeroMemory
)
Protected Function AllocateMemory (
    numBytes As Long,
    zeroMemory As Boolean
) As IntPtr

Parameters

numBytes
Type: SystemInt64
The nubmer of bytes to allocate.
zeroMemory
Type: SystemBoolean
Indicates whether or not the memory should be cleared.

Return Value

Type: IntPtr
Remarks
Subclasses of ResidentPixelMemory do not need to be concerned with tracking memory through PixelMemoryTracker if it is allocated in a single block. AllocateMemory automatically tracks it.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.DisposeManagedResources Method

ResidentPixelMemoryDisposeManagedResources Method

Disposes any unmanaged resources.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.DisposeUnmanagedResources Method

ResidentPixelMemoryDisposeUnmanagedResources Method

Disposes the memory used by this object.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeUnmanagedResources()
Protected Overrides Sub DisposeUnmanagedResources
Remarks
Subclasses of ResidentPixelMemory do not need to be concerned with tracking memory through PixelMemoryTracker if it is allocated in a single block. DisposeUnmanagedResources automatically tracks it.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.FreeMemory Method

ResidentPixelMemoryFreeMemory Method

Frees memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void FreeMemory()
Protected Sub FreeMemory
Remarks
Subclasses of ResidentPixelMemory do not need to be concerned with tracking memory through PixelMemoryTracker if it is allocated in a single block.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.GetScanLinePtr Method

ResidentPixelMemoryGetScanLinePtr Method

Gets a pointer to the a given scanline.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IntPtr GetScanLinePtr(
    int index
)
Public Overridable Function GetScanLinePtr (
    index As Integer
) As IntPtr

Parameters

index
Type: SystemInt32
An index to a scanline in an image.

Return Value

Type: IntPtr

Implements

IDirectScanlineAccessGetScanLinePtr(Int32)
Remarks
Throws an ArgumentOutOfRangeException if the index is not within the image boundary.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLAllocateMemory Method

ResidentPixelMemoryLLAllocateMemory Method

Overload List
 | Name | Description
Protected method | LLAllocateMemory(Int32, Boolean) | Obsolete. Subclasses of ResidentPixelMemory implement this method to allocate memory.
Protected method | LLAllocateMemory(Int64, Boolean) | Subclasses of ResidentPixelMemory implement this method to allocate memory.
Top
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLAllocateMemory Method (Int32, Boolean)

ResidentPixelMemoryLLAllocateMemory Method (Int32, Boolean)

Note: This API is now obsolete.

Subclasses of ResidentPixelMemory implement this method to allocate memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use the 64 bit allocator - LLAllocateMemory(long size, bool zeroMemory)",
    false)]
protected abstract IntPtr LLAllocateMemory(
    int size,
    bool zeroMemory
)
<ObsoleteAttribute("Please use the 64 bit allocator - LLAllocateMemory(long size, bool zeroMemory)",
    false)>
Protected MustOverride Function LLAllocateMemory (
    size As Integer,
    zeroMemory As Boolean
) As IntPtr

Parameters

size
Type: SystemInt32
zeroMemory
Type: SystemBoolean

Return Value

Type: IntPtr
See Also

Reference

ResidentPixelMemory Class
LLAllocateMemory Overload
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLAllocateMemory Method (Int64, Boolean)

ResidentPixelMemoryLLAllocateMemory Method (Int64, Boolean)

Subclasses of ResidentPixelMemory implement this method to allocate memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract IntPtr LLAllocateMemory(
    long size,
    bool zeroMemory
)
Protected MustOverride Function LLAllocateMemory (
    size As Long,
    zeroMemory As Boolean
) As IntPtr

Parameters

size
Type: SystemInt64
zeroMemory
Type: SystemBoolean

Return Value

Type: IntPtr
See Also

Reference

ResidentPixelMemory Class
LLAllocateMemory Overload
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLFreeMemory Method

ResidentPixelMemoryLLFreeMemory Method

Subclasses of ResidentPixelMemory implement this method to free memory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLFreeMemory(
    IntPtr p
)
Protected MustOverride Sub LLFreeMemory (
    p As IntPtr
)

Parameters

p
Type: SystemIntPtr
The pointer to free.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLGetHeight Method

ResidentPixelMemoryLLGetHeight Method

Returns the height of the image.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetHeight()
Protected Overrides Function LLGetHeight As Integer

Return Value

Type: Int32
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLGetPixelAccessor Method

ResidentPixelMemoryLLGetPixelAccessor Method

Returns a suitable PixelAccesor object for this PixelMemory.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelAccessor LLGetPixelAccessor()
Protected Overrides Function LLGetPixelAccessor As PixelAccessor

Return Value

Type: PixelAccessor
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.LLGetRowStride Method

ResidentPixelMemoryLLGetRowStride Method

Returns the size of a scanline in bytes, rounded up to the next multiple of 4.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override int LLGetRowStride()
Protected Overrides Function LLGetRowStride As Integer

Return Value

Type: Int32
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


ResidentPixelMemory.RerportMemoryAllocated Method

ResidentPixelMemoryRerportMemoryAllocated Method

Rerports that memory was allocated.

Namespace: Atalasoft.Imaging.Memory
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void RerportMemoryAllocated(
    IntPtr p,
    long numBytes
)
Protected Sub RerportMemoryAllocated (
    p As IntPtr,
    numBytes As Long
)

Parameters

p
Type: SystemIntPtr
The p.
numBytes
Type: SystemInt64
The number bytes.
See Also

Reference

ResidentPixelMemory Class
Atalasoft.Imaging.Memory Namespace


Atalasoft.Imaging.Metadata Namespace

Classes
 | Class | Description
Public class | ComTextCollection | Contains a collection of COM text tags and methods to access COM Text data from an image.
 | ComTextParser | Parses COM Markers from a JPEG or PNG image into a collection of COM Text tags.
Public class | ComTextTag | Contains the data for a specified COM Text tag including the key and text.
Public class | ExifCollection | Contains a collection of EXIF tags.
 | ExifParser | Parses EXIF data from JPEG or TIFF images into a collection of EXIF tags.
Public class | ExifTag | Represents an Exif tag including tag-ID, IFD, value, and description.
Public class | ImageMetadataException | This exception is thrown when an error with image metadata is detected
Public class | IptcCollection | Contains a collection of IPTC tags.
 | IptcParser | Parses IPTC data from JPEG or TIFF images into a collection of IPTC tags.
Public class | IptcTag | Contains the data of this IPTC tag including ID, index, section, and value.
Public class | JpegMarker | The JpegMarker is an object that stores information from JPEG images
Public class | JpegMarkerCollection | Contains a collection of JpegMarkers and methods to access JpegMarker data.
Public class | PhotoshopResource | Contains the data of a Photoshop Resource including ID, Data, and Description.
Public class | PhotoshopResourceCollection | Contains a collection of Photoshop resources.
 | PhotoshopResourceParser | Parses Photoshop resources from JPEG, TIFF, and PSD images into a collection of PhotoshopResources.
Public class | TiffTag | Holds the data of a single TIFF Tag.
Public class | TiffTagCollection | Contains a collection of TIFF tags, used tor writing TIFF Tags to an image when saving.
 | XmpParser | The XmpParser class can extract XMP Binary data from an image, and parse it into XML content.
Structures
 | Structure | Description
Public structure | Rational | A fractional value used to represent certain TIFF and EXIF tags.
Enumerations
 | Enumeration | Description
Public enumeration | ExifTagID | Enumeration of known Exif tag ID's.
Public enumeration | ExifTagIfd | Contains an enumeration of standard Exif Ifd's.
Public enumeration | JpegMarkerCopyFlags | Flag enumeration used with [M:CopyJpegWithNewMarkers].
Public enumeration | JpegMarkerTypes | Defines the types of Jpeg Markers that can be saved as a data chunk inside a Jpeg image.
Public enumeration | TiffTagDataType | Enumeration of TIFF Tag data types
Public enumeration | TiffTagID | Standard Tiff Tags that can be read from a TIFF file.


ComTextCollection Class

Contains a collection of COM text tags and methods to access COM Text data from an image.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.MetadataComTextCollection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ComTextCollection : CollectionBase
Public Class ComTextCollection
    Inherits CollectionBase

The ComTextCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ComTextCollection | Initialize a new instance of this COM Text tag.
Public method | ComTextCollection(Stream) | Obsolete. Obsolete
Public method | ComTextCollection(String) | Obsolete. Obsolete
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the ComTextTag by index in the collection and allows the COM Text tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Add a new COM Text marker to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether [contains] [the specified source].
Public method | CopyTo | Copies items from this collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Indexes the of.
Public method | Insert | Inserts the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified COM Text tag from this collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See the ParseFromImage method of the ComTextParser class to generate data from a JPEG or PNG image.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataComTextCollection
Atalasoft.Imaging.Metadata


ComTextCollection Constructor

Initialize a new instance of ComTextCollection.

Overload List
 | Name | Description
Public method | ComTextCollection | Initialize a new instance of this COM Text tag.
Public method | ComTextCollection(Stream) | Obsolete. Obsolete
Public method | ComTextCollection(String) | Obsolete. Obsolete
Top
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection Constructor

Initialize a new instance of this COM Text tag.

Initialize a new instance of ComTextCollection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextCollection()
Public Sub New
See Also

Reference

ComTextCollection Class
ComTextCollection Overload
Atalasoft.Imaging.Metadata Namespace


ComTextCollection Constructor (Stream)

Note: This API is now obsolete.

Obsolete

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been obsoleted.  Please see ComTextParser for a replacement.",
    true)]
public ComTextCollection(
    Stream stream
)
<ObsoleteAttribute("This constructor has been obsoleted.  Please see ComTextParser for a replacement.",
    true)>
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
See Also

Reference

ComTextCollection Class
ComTextCollection Overload
Atalasoft.Imaging.Metadata Namespace


ComTextCollection Constructor (String)

Note: This API is now obsolete.

Obsolete

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been obsoleted.  Please see ComTextParser for a replacement.",
    true)]
public ComTextCollection(
    string fileName
)
<ObsoleteAttribute("This constructor has been obsoleted.  Please see ComTextParser for a replacement.",
    true)>
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
See Also

Reference

ComTextCollection Class
ComTextCollection Overload
Atalasoft.Imaging.Metadata Namespace


ComTextCollection Properties

The ComTextCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the ComTextTag by index in the collection and allows the COM Text tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.Item Property

ComTextCollectionItem Property

Returns the ComTextTag by index in the collection and allows the COM Text tags to be enumerated.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextTag this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ComTextTag
    Get

Parameters

index
Type: SystemInt32
The index of the item to retrieve.

Property Value

Type: ComTextTag
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection Methods

The ComTextCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a new COM Text marker to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether [contains] [the specified source].
Public method | CopyTo | Copies items from this collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Indexes the of.
Public method | Insert | Inserts the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified COM Text tag from this collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.Add Method

ComTextCollectionAdd Method

Add a new COM Text marker to this collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    ComTextTag tag
)
Public Sub Add (
    tag As ComTextTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataComTextTag
The ComTextTag to add.
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.Contains Method

ComTextCollectionContains Method

Determines whether [contains] [the specified source].

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    ComTextTag source
)
Public Function Contains (
    source As ComTextTag
) As Boolean

Parameters

source
Type: Atalasoft.Imaging.MetadataComTextTag
The source.

Return Value

Type: Boolean
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.CopyTo Method

ComTextCollectionCopyTo Method

Copies items from this collection into an array.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    ComTextTag[] comText,
    int index
)
Public Sub CopyTo (
    comText As ComTextTag(),
    index As Integer
)

Parameters

comText
Type: Atalasoft.Imaging.MetadataComTextTag
An array of ComTextTag objects that will hold the items.
index
Type: SystemInt32
An index in the array where the data will be copied.
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.IndexOf Method

ComTextCollectionIndexOf Method

Indexes the of.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    ComTextTag source
)
Public Function IndexOf (
    source As ComTextTag
) As Integer

Parameters

source
Type: Atalasoft.Imaging.MetadataComTextTag
The source.

Return Value

Type: Int32
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.Insert Method

ComTextCollectionInsert Method

Inserts the specified index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    ComTextTag source
)
Public Sub Insert (
    index As Integer,
    source As ComTextTag
)

Parameters

index
Type: SystemInt32
The index.
source
Type: Atalasoft.Imaging.MetadataComTextTag
The source.
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextCollection.Remove Method

ComTextCollectionRemove Method

Remove a specified COM Text tag from this collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    ComTextTag tag
)
Public Sub Remove (
    tag As ComTextTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataComTextTag
The ComTextTag to remove.
See Also

Reference

ComTextCollection Class
Atalasoft.Imaging.Metadata Namespace


ComTextParser Class

Parses COM Markers from a JPEG or PNG image into a collection of COM Text tags.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataComTextParser

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ComTextParser
Public Class ComTextParser

The ComTextParser type exposes the following members.

Constructors
 | Name | Description
Public method | ComTextParser | Initializes a new instance of ComTextParser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage(Stream) | Parses COM Text data from an image file stream.
Public method | ParseFromImage(String) | Parses COM Text data from an image file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

PNG and JPEG images support a type of metadata called COM Text. This is simple textual information that can be stored into an image. DotImage supports reading and writing this information to an image.

Examples
EX (C#)
Copy
ComTextParser comParser = new ComTextParser();
ComTextCollection comTags = comParser.Parse("myimage.jpg");
EX (Visual Basic)
Copy
Dim comParser As ComTextParser = New ComTextParser();
Dim comTags As ComTextCollection = comParser.Parse("myimage.jpg");
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataComTextCollection
COM Text
Metadata Overview


ComTextParser Constructor

Initializes a new instance of ComTextParser.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextParser()
Public Sub New
See Also

Reference

ComTextParser Class
Atalasoft.Imaging.Metadata Namespace


ComTextParser Methods

The ComTextParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage(Stream) | Parses COM Text data from an image file stream.
Public method | ParseFromImage(String) | Parses COM Text data from an image file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComTextParser Class
Atalasoft.Imaging.Metadata Namespace


ComTextParser.ParseFromImage Method

ComTextParserParseFromImage Method

Parses COM Text data from an image file or stream.
Overload List
 | Name | Description
Public method | ParseFromImage(Stream) | Parses COM Text data from an image file stream.
Public method | ParseFromImage(String) | Parses COM Text data from an image file.
Top
See Also

Reference

ComTextParser Class
Atalasoft.Imaging.Metadata Namespace


ComTextParser.ParseFromImage Method (Stream)

ComTextParserParseFromImage Method (Stream)

Parses COM Text data from an image file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextCollection ParseFromImage(
    Stream imageStream
)
Public Function ParseFromImage (
    imageStream As Stream
) As ComTextCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.

Return Value

Type: ComTextCollection
A ComTextCollection containing all COM Text tags.
See Also

Reference

ComTextParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataComTextParser


ComTextParser.ParseFromImage Method (String)

ComTextParserParseFromImage Method (String)

Parses COM Text data from an image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextCollection ParseFromImage(
    string imageFile
)
Public Function ParseFromImage (
    imageFile As String
) As ComTextCollection

Parameters

imageFile
Type: SystemString
The image file to parse data from.

Return Value

Type: ComTextCollection
Returns a ComTextCollection containing all COM Text data.
See Also

Reference

ComTextParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataComTextParser


ComTextTag Class

Contains the data for a specified COM Text tag including the key and text.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataComTextTag

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ComTextTag
Public Class ComTextTag

The ComTextTag type exposes the following members.

Constructors
 | Name | Description
Public method | ComTextTag | Initialize a new instance of this COM Text tag.
Public method | ComTextTag(String) | Initialize a new instance of this COM Text tag specifying the text.
Public method | ComTextTag(String, String) | Initialize a new instance of this COM Text tag specifying the key and text.
Top
Properties
 | Name | Description
Public property | Key | Gets or sets a unique indentifier of the COM Tag for use in PNG images.
Public property | Text | Gets or sets the text contained in this COM Text Tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a text description of the tag. (Overrides ObjectToString.)
Top
Remarks
The Key value in a COM Text tag is only valid for PNG images. Ignored in JPEG images.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


ComTextTag Constructor

Overload List
 | Name | Description
Public method | ComTextTag | Initialize a new instance of this COM Text tag.
Public method | ComTextTag(String) | Initialize a new instance of this COM Text tag specifying the text.
Public method | ComTextTag(String, String) | Initialize a new instance of this COM Text tag specifying the key and text.
Top
See Also

Reference

ComTextTag Class
Atalasoft.Imaging.Metadata Namespace


ComTextTag Constructor

Initialize a new instance of this COM Text tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextTag()
Public Sub New
See Also

Reference

ComTextTag Class
ComTextTag Overload
Atalasoft.Imaging.Metadata Namespace


ComTextTag Constructor (String)

Initialize a new instance of this COM Text tag specifying the text.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextTag(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text contained in this COM Text Tag.
See Also

Reference

ComTextTag Class
ComTextTag Overload
Atalasoft.Imaging.Metadata Namespace


ComTextTag Constructor (String, String)

Initialize a new instance of this COM Text tag specifying the key and text.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ComTextTag(
    string text,
    string key
)
Public Sub New (
    text As String,
    key As String
)

Parameters

text
Type: SystemString
The text contained in this COM Text Tag.
key
Type: SystemString
A unique indentifier of the COM Tag for use in PNG images.
See Also

Reference

ComTextTag Class
ComTextTag Overload
Atalasoft.Imaging.Metadata Namespace


ComTextTag Properties

The ComTextTag type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets a unique indentifier of the COM Tag for use in PNG images.
Public property | Text | Gets or sets the text contained in this COM Text Tag.
Top
See Also

Reference

ComTextTag Class
Atalasoft.Imaging.Metadata Namespace


ComTextTag.Key Property

ComTextTagKey Property

Gets or sets a unique indentifier of the COM Tag for use in PNG images.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
A unique indentifier of the COM Tag for use in PNG images.
See Also

Reference

ComTextTag Class
Atalasoft.Imaging.Metadata Namespace


ComTextTag.Text Property

ComTextTagText Property

Gets or sets the text contained in this COM Text Tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text contained in this COM Text Tag.
See Also

Reference

ComTextTag Class
Atalasoft.Imaging.Metadata Namespace


ComTextTag Methods

The ComTextTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a text description of the tag. (Overrides ObjectToString.)
Top
See Also

Reference

ComTextTag Class
Atalasoft.Imaging.Metadata Namespace


ComTextTag.ToString Method

ComTextTagToString Method

Returns a text description of the tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A text description of the tag.
See Also

Reference

ComTextTag Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection Class

Contains a collection of EXIF tags.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.MetadataExifCollection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ExifCollection : CollectionBase
Public Class ExifCollection
    Inherits CollectionBase

The ExifCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ExifCollection | Creates a new instance of the ExifCollection class.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the ExifTag by index in the collection and allows the EXIF tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | MakernoteHeader | Gets or sets the makernote header.
Public property | ThumbnailStream | Gets or sets the thumbnail stream contained within this EXIF data.
Top
Methods
 | Name | Description
Public method | Add | Adds a new ExifTag to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value indicating if a particular EXIF Tag exists in the collection.
Public method | CopyTo | Copies items from this collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index value of an ExifTag found in the collection.
Public method | Insert | Insert an EXIF Tag into the collection at the specified index.
Public method | LookupTag(String) | Obsolete. Deprecated
Public method | LookupTag(Int32, ExifTagIfd) | Looks up an ExifTag by id and IFD and returns it, or null.
Public method | LookupTag(ExifTagID, ExifTagIfd) | Looks up an ExifTag by Exif ID and IFD and returns it, or null.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified ExifTag from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToByteArray | Creates a byte array of the EXIF data that can be inserted into an image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See ParseFromImage(Stream, Int32) of ExifParser to populate an ExifCollection with EXIF data from an image.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
EXIF Metadata
Metadata Overview
ExifParser Class


ExifCollection Constructor

Creates a new instance of the ExifCollection class.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifCollection()
Public Sub New
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection Properties

The ExifCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the ExifTag by index in the collection and allows the EXIF tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | MakernoteHeader | Gets or sets the makernote header.
Public property | ThumbnailStream | Gets or sets the thumbnail stream contained within this EXIF data.
Top
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.Item Property

ExifCollectionItem Property

Returns the ExifTag by index in the collection and allows the EXIF tags to be enumerated.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ExifTag
    Get

Parameters

index
Type: SystemInt32
The zero based index in the collection.

Property Value

Type: ExifTag
The EXIF Tag by index in the collection.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.MakernoteHeader Property

ExifCollectionMakernoteHeader Property

Gets or sets the makernote header.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] MakernoteHeader { get; set; }
Public Property MakernoteHeader As Byte()
    Get
    Set

Property Value

Type: Byte
Remarks
This information is required to save EXIF with the original maker note data. It contains the header for vendor specific maker note tags identifying the type of makernote contained within this ExifCollection.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.ThumbnailStream Property

ExifCollectionThumbnailStream Property

Gets or sets the thumbnail stream contained within this EXIF data.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream ThumbnailStream { get; set; }
Public Property ThumbnailStream As Stream
    Get
    Set

Property Value

Type: Stream
Remarks

EXIF information often contains a small thumbnail image. That image can be obtained from this property. The thumbnail can also be set or changed by setting this to a new stream.

Please note that saving a thumbnail inside a TIFF image requires that the thumbnail is a TIFF. When copying EXIF from a JPEG to a TIFF, ensure that the ThumbnailStream is converted from a JPEG to a TIFF.

See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection Methods

The ExifCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new ExifTag to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value indicating if a particular EXIF Tag exists in the collection.
Public method | CopyTo | Copies items from this collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index value of an ExifTag found in the collection.
Public method | Insert | Insert an EXIF Tag into the collection at the specified index.
Public method | LookupTag(String) | Obsolete. Deprecated
Public method | LookupTag(Int32, ExifTagIfd) | Looks up an ExifTag by id and IFD and returns it, or null.
Public method | LookupTag(ExifTagID, ExifTagIfd) | Looks up an ExifTag by Exif ID and IFD and returns it, or null.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified ExifTag from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToByteArray | Creates a byte array of the EXIF data that can be inserted into an image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.Add Method

ExifCollectionAdd Method

Adds a new ExifTag to this collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    ExifTag tag
)
Public Sub Add (
    tag As ExifTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataExifTag
The EXIF tag to add.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.Contains Method

ExifCollectionContains Method

Returns a value indicating if a particular EXIF Tag exists in the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    ExifTag source
)
Public Function Contains (
    source As ExifTag
) As Boolean

Parameters

source
Type: Atalasoft.Imaging.MetadataExifTag
The EXIF tag to test.

Return Value

Type: Boolean
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.CopyTo Method

ExifCollectionCopyTo Method

Copies items from this collection into an array.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    ExifTag[] tags,
    int index
)
Public Sub CopyTo (
    tags As ExifTag(),
    index As Integer
)

Parameters

tags
Type: Atalasoft.Imaging.MetadataExifTag
An array of ExifTags to hold the items.
index
Type: SystemInt32
An index in the array where the data will be copied.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.IndexOf Method

ExifCollectionIndexOf Method

Returns the index value of an ExifTag found in the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    ExifTag tag
)
Public Function IndexOf (
    tag As ExifTag
) As Integer

Parameters

tag
Type: Atalasoft.Imaging.MetadataExifTag
The specific tag to search for.

Return Value

Type: Int32
Returns -1 if the tag was not found.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.Insert Method

ExifCollectionInsert Method

Insert an EXIF Tag into the collection at the specified index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    ExifTag source
)
Public Sub Insert (
    index As Integer,
    source As ExifTag
)

Parameters

index
Type: SystemInt32
The index to insert into.
source
Type: Atalasoft.Imaging.MetadataExifTag
The tag to insert.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.LookupTag Method

ExifCollectionLookupTag Method

Overload List
 | Name | Description
Public method | LookupTag(String) | Obsolete. Deprecated
Public method | LookupTag(Int32, ExifTagIfd) | Looks up an ExifTag by id and IFD and returns it, or null.
Public method | LookupTag(ExifTagID, ExifTagIfd) | Looks up an ExifTag by Exif ID and IFD and returns it, or null.
Top
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.LookupTag Method (String)

ExifCollectionLookupTag Method (String)

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated and might be removed in future versions.  Use the other overloaded methods instead.")]
public ExifTag LookupTag(
    string description
)
<ObsoleteAttribute("This method has been deprecated and might be removed in future versions.  Use the other overloaded methods instead.")>
Public Function LookupTag (
    description As String
) As ExifTag

Parameters

description
Type: SystemString
A textual description of the ExifTag (for example, "DateTime").

Return Value

Type: ExifTag
See Also

Reference

ExifCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifCollection.LookupTag Method (Int32, ExifTagIfd)

ExifCollectionLookupTag Method (Int32, ExifTagIfd)

Looks up an ExifTag by id and IFD and returns it, or null.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag LookupTag(
    int id,
    ExifTagIfd ifd
)
Public Function LookupTag (
    id As Integer,
    ifd As ExifTagIfd
) As ExifTag

Parameters

id
Type: SystemInt32
The int id of the EXIF tag to look for
ifd
Type: Atalasoft.Imaging.MetadataExifTagIfd
The IFD to search through.

Return Value

Type: ExifTag
the matching ExifTag, or null if not found.
See Also

Reference

ExifCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifCollection.LookupTag Method (ExifTagID, ExifTagIfd)

ExifCollectionLookupTag Method (ExifTagID, ExifTagIfd)

Looks up an ExifTag by Exif ID and IFD and returns it, or null.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag LookupTag(
    ExifTagID id,
    ExifTagIfd ifd
)
Public Function LookupTag (
    id As ExifTagID,
    ifd As ExifTagIfd
) As ExifTag

Parameters

id
Type: Atalasoft.Imaging.MetadataExifTagID
The ID of the EXIF tag to lookup.
ifd
Type: Atalasoft.Imaging.MetadataExifTagIfd
The IFD to search through.

Return Value

Type: ExifTag
the matching ExifTag, or null if not found.
See Also

Reference

ExifCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifCollection.Remove Method

ExifCollectionRemove Method

Remove a specified ExifTag from the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    ExifTag tag
)
Public Sub Remove (
    tag As ExifTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataExifTag
The tag to remove
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifCollection.ToByteArray Method

ExifCollectionToByteArray Method

Creates a byte array of the EXIF data that can be inserted into an image.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ToByteArray()
Public Function ToByteArray As Byte()

Return Value

Type: Byte
Remarks
This method is intended on being used to store EXIF in a Jpeg Image. To add or edit EXIF data in a JPEG image, create a JPEG APP1 Marker from this data. See JpegMarker for more information.
See Also

Reference

ExifCollection Class
Atalasoft.Imaging.Metadata Namespace


ExifParser Class

Parses EXIF data from JPEG or TIFF images into a collection of EXIF tags.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataExifParser

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ExifParser
Public Class ExifParser

The ExifParser type exposes the following members.

Constructors
 | Name | Description
Public method | ExifParser | Initializes a new instance of ExifParser.
Top
Properties
 | Name | Description
Public property | FormatTags | Obsolete. Deprecated
Public property | ThumbnailCallback | Obsolete. Deprecated
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Raises the [E:Error] event.
 | ParseFromByteArray | Parses a byte array of EXIF data.
 | ParseFromImage(Stream) | Parses EXIF data from a JPEG or TIFF image file stream.
 | ParseFromImage(String) | Parses EXIF data from a JPEG or TIFF image file.
 | ParseFromImage(Stream, Int32) | Parses EXIF data from an image file stream, specifying the frame index of a multipage TIFF.
 | ParseFromImage(String, Int32) | Parses EXIF data from an image file, specifying the frame index of a multipage TIFF.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CodecError | This event is used by the ExifParser object to report errors that occur when parsing an image.
Top
Remarks

EXIF (Exchangeable Image File Format) is a standard for storing interchange information in image files, in particular JPEG images. This metadata is commonly used in digital camera images to store information specific to digital photography such as shutter speed, date taken, aperture, GPS information, and other information depending on the make of the camera.

Examples

This example demonstrates how to retreive EXIF tags from a JPEG image.

[New Example] (C#)
Copy
ExifTextParser exifParser = new ExifTextParser();
ExifTextCollection exifTags = exifParser.Parse("myimage.jpg");
[New Example] (Visual Basic)
Copy
Dim exifParser As ExifTextParser = New ExifTextParser()
Dim exifTags As ExifTextCollection = exifParser.Parse("myimage.jpg")

This example shows how to retrieve EXIF data from an image, then save it back to a new image.

[New Example] (C#)
Copy
//get EXIF Tags
ExifParser exifParse = new ExifParser();
ExifCollection exifTags = exifParse.ParseFromImage(@"c\in.jpg");
//get JPEG Markers
JpegMarkerCollection appMarkersIn = new JpegMarkerCollection(@"c\in.jpg");
//read image
Workspace myWorkspace = new Workspace();
myWorkspace.Open(@"c\in.jpg");
//get the DataTime Tag from the image and display the value
if (exifTags != null)
{
    ExifTag tag = exifTags.LookupTag("DateTime");
    if (tag != null)
        MessageBox.Show("This photo was taken on " + tag.Data.ToString());
}
JpegEncoder jpeg = new JpegEncoder(75);
//only write EXIF Tags back to the image (APP1)
JpegMarkerCollection appMarkersOut = new JpegMarkerCollection();
foreach (JpegMarker mk in appMarkersIn)
    if (mk.Type == JpegMarkerTypes.MarkerApp1)
        appMarkersOut.Add(mk);
jpeg.AppMarkers = appMarkersOut;
myWorkspace.Save("c:\\out.jpg", jpeg);
[New Example] (Visual Basic)
Copy
'get EXIF Tags
Dim exifParse As ExifParser = New ExifParser()
Dim exifTags As ExifCollection = exifParse.ParseFromImage("c\in.jpg")
'get JPEG Markers
Dim appMarkersIn As JpegMarkerCollection = New JpegMarkerCollection("c:\in.jpg")
'read image
Dim myWorkspace As Workspace =  New Workspace()
myWorkspace.Open("c:\in.jpg")
'get the DataTime Tag from the image and display the value
If Not exifTags Is Nothing Then
    Dim tag As ExifTag =  exifTags.LookupTag("DateTime")
    If Not tag Is Nothing Then
        MessageBox.Show("This photo was taken on " & tag.Data.ToString())
    End If
End If
Dim jpeg As JpegEncoder =  New JpegEncoder(75)
'only write EXIF Tags back to the image (APP1)
Dim appMarkersOut As JpegMarkerCollection = New JpegMarkerCollection()
Dim mk As JpegMarker
For Each mk In appMarkersIn
    If mk.Type = JpegMarkerTypes.MarkerApp1 Then
        appMarkersOut.Add(mk)
    End If
Next
jpeg.AppMarkers = appMarkersOut
myWorkspace.Save("c:\out.jpg", jpeg)
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
EXIF Description
Metadata Overview


ExifParser Constructor

Initializes a new instance of ExifParser.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifParser()
Public Sub New
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser Properties

The ExifParser type exposes the following members.

Properties
 | Name | Description
Public property | FormatTags | Obsolete. Deprecated
Public property | ThumbnailCallback | Obsolete. Deprecated
Top
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.FormatTags Property

ExifParserFormatTags Property

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property has been deprecated.  It is currently ignored.")]
public bool FormatTags { get; set; }
<ObsoleteAttribute("This property has been deprecated.  It is currently ignored.")>
Public Property FormatTags As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the EXIF tags are formatted to english strings.
Remarks
To achieve similar functionality as the pre-deprecated version, use the ToString() method in the ExifTag class. It will return 'TagName: EnglishFormattedValue'. You can parse this string to yield the same result, which is just 'EnglishFormattedValue'.
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.ThumbnailCallback Property

ExifParserThumbnailCallback Property

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property has been deprecated.  See ThumbnailStream in ExifCollection for the replacement.")]
public ImageFileIOEventHandler ThumbnailCallback { get; set; }
<ObsoleteAttribute("This property has been deprecated.  See ThumbnailStream in ExifCollection for the replacement.")>
Public Property ThumbnailCallback As ImageFileIOEventHandler
    Get
    Set

Property Value

Type: ImageFileIOEventHandler
Remarks
See ThumbnailStream in ExifCollection for the replacement.
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser Methods

The ExifParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Raises the [E:Error] event.
 | ParseFromByteArray | Parses a byte array of EXIF data.
 | ParseFromImage(Stream) | Parses EXIF data from a JPEG or TIFF image file stream.
 | ParseFromImage(String) | Parses EXIF data from a JPEG or TIFF image file.
 | ParseFromImage(Stream, Int32) | Parses EXIF data from an image file stream, specifying the frame index of a multipage TIFF.
 | ParseFromImage(String, Int32) | Parses EXIF data from an image file, specifying the frame index of a multipage TIFF.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.OnError Method

ExifParserOnError Method

Raises the [E:Error] event.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnError(
    CodecErrorEventArgs e
)
Protected Overridable Sub OnError (
    e As CodecErrorEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.CodecCodecErrorEventArgs
The CodecErrorEventArgs instance containing the event data.
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.ParseFromByteArray Method

ExifParserParseFromByteArray Method

Parses a byte array of EXIF data.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ExifCollection ParseFromByteArray(
    byte[] exifData
)
Public Overridable Function ParseFromByteArray (
    exifData As Byte()
) As ExifCollection

Parameters

exifData
Type: SystemByte
An array containing the entire EXIF string to parse.

Return Value

Type: ExifCollection
An ExifCollection holding a list of all the EXIF values that were read. This list will be empty if no values were read.
Remarks
Use this method for dealing with raw image data. For reading Exif from an image, use ParseFromImage(String).
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.ParseFromImage Method

ExifParserParseFromImage Method

Parses EXIF data from a JPEG or TIFF image file or stream.
Overload List
Name | Description
ParseFromImage(Stream) | Parses EXIF data from a JPEG or TIFF image file stream.
ParseFromImage(String) | Parses EXIF data from a JPEG or TIFF image file.
ParseFromImage(Stream, Int32) | Parses EXIF data from an image file stream, specifying the frame index of a multipage TIFF.
ParseFromImage(String, Int32) | Parses EXIF data from an image file, specifying the frame index of a multipage TIFF.
Top
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.ParseFromImage Method (Stream)

ExifParserParseFromImage Method (Stream)

Parses EXIF data from a JPEG or TIFF image file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifCollection ParseFromImage(
    Stream imageStream
)
Public Function ParseFromImage (
    imageStream As Stream
) As ExifCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.

Return Value

Type: ExifCollection
Examples
ExifParser Class
See Also

Reference

ExifParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


ExifParser.ParseFromImage Method (String)

ExifParserParseFromImage Method (String)

Parses EXIF data from a JPEG or TIFF image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifCollection ParseFromImage(
    string imageFile
)
Public Function ParseFromImage (
    imageFile As String
) As ExifCollection

Parameters

imageFile
Type: SystemString
The image filename to parse data from.

Return Value

Type: ExifCollection
An ExifCollection containing all EXIF information.
Examples
ExifParser Class
Examples
ExifParser Class
See Also

Reference

ExifParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


ExifParser.ParseFromImage Method (Stream, Int32)

ExifParserParseFromImage Method (Stream, Int32)

Parses EXIF data from an image file stream, specifying the frame index of a multipage TIFF.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ExifCollection ParseFromImage(
    Stream imageStream,
    int frameIndex
)
Public Overridable Function ParseFromImage (
    imageStream As Stream,
    frameIndex As Integer
) As ExifCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.
frameIndex
Type: SystemInt32
The zero based frame index of a multipage TIFF image to load EXIF data from.

Return Value

Type: ExifCollection
Examples
ExifParser Class
See Also

Reference

ExifParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


ExifParser.ParseFromImage Method (String, Int32)

ExifParserParseFromImage Method (String, Int32)

Parses EXIF data from an image file, specifying the frame index of a multipage TIFF.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifCollection ParseFromImage(
    string imageFile,
    int frameIndex
)
Public Function ParseFromImage (
    imageFile As String,
    frameIndex As Integer
) As ExifCollection

Parameters

imageFile
Type: SystemString
The image filename to parse data from.
frameIndex
Type: SystemInt32
The zero based frame index of a multipage TIFF image to load EXIF data from.

Return Value

Type: ExifCollection
Examples
ExifParser Class
See Also

Reference

ExifParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


ExifParser Events

The ExifParser type exposes the following members.

Events
 | Name | Description
Public event | CodecError | This event is used by the ExifParser object to report errors that occur when parsing an image.
Top
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifParser.CodecError Event

ExifParserCodecError Event

This event is used by the ExifParser object to report errors that occur when parsing an image.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CodecErrorEventHandler CodecError
Public Event CodecError As CodecErrorEventHandler

Value

Type: Atalasoft.Imaging.CodecCodecErrorEventHandler
Remarks
The DotImage EXIF Parser is aggressive in suppressing errors encountered while parsing damaged or somewhat malformed files. Normally these errors are not reported. This event provides a mechanism for an application to record, report, or abort in the event of an error.
See Also

Reference

ExifParser Class
Atalasoft.Imaging.Metadata Namespace


ExifTag Class

Represents an Exif tag including tag-ID, IFD, value, and description.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataTiffTag
Atalasoft.Imaging.MetadataExifTag

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ExifTag : TiffTag
Public Class ExifTag
    Inherits TiffTag

The ExifTag type exposes the following members.

Constructors
 | Name | Description
Public method | ExifTag(Int32, ExifTagIfd, Object) | Initializes a new instance of ExifTag.
Public method | ExifTag(ExifTagID, ExifTagIfd, Object) | Initializes a new instance of ExifTag.
Public method | ExifTag(Int32, ExifTagIfd, Object, TiffTagDataType) | Initializes a new instance of ExifTag.
Public method | ExifTag(ExifTagID, ExifTagIfd, Object, TiffTagDataType) | Initializes a new instance of the ExifTag class.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the value of this EXIF tag. (Overrides TiffTagData.)
Public property | Description | Obsolete. This property is deprecated.
Public property | ID | Gets the ID of this TIFF tag. (Inherited from TiffTag.)
Public property | Ifd | Gets the IFD of this ExifTag.
Public property | Type | Gets the TIFF DataType for this TIFF Tag. (Inherited from TiffTag.)
Top
Methods
 | Name | Description
 | ConvertExifDate | convert an Exif Date to a recognizeable system date
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a text description of the tag in the form of 'TagDescription: FormattedTagValue' (Overrides TiffTagToString.)
Top
Remarks
See the ExifParser class to retreive ExifTags from images.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataExifParser


ExifTag Constructor

Overload List
 | Name | Description
Public method | ExifTag(Int32, ExifTagIfd, Object) | Initializes a new instance of ExifTag.
Public method | ExifTag(ExifTagID, ExifTagIfd, Object) | Initializes a new instance of ExifTag.
Public method | ExifTag(Int32, ExifTagIfd, Object, TiffTagDataType) | Initializes a new instance of ExifTag.
Public method | ExifTag(ExifTagID, ExifTagIfd, Object, TiffTagDataType) | Initializes a new instance of the ExifTag class.
Top
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag Constructor (Int32, ExifTagIfd, Object)

Initializes a new instance of ExifTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag(
    int id,
    ExifTagIfd ifd,
    Object data
)
Public Sub New (
    id As Integer,
    ifd As ExifTagIfd,
    data As Object
)

Parameters

id
Type: SystemInt32
The ExifID
ifd
Type: Atalasoft.Imaging.MetadataExifTagIfd
The ExifIdf
data
Type: SystemObject
The object data
See Also

Reference

ExifTag Class
ExifTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifTag Constructor (ExifTagID, ExifTagIfd, Object)

Initializes a new instance of ExifTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag(
    ExifTagID id,
    ExifTagIfd ifd,
    Object data
)
Public Sub New (
    id As ExifTagID,
    ifd As ExifTagIfd,
    data As Object
)

Parameters

id
Type: Atalasoft.Imaging.MetadataExifTagID
The EXIF ID.
ifd
Type: Atalasoft.Imaging.MetadataExifTagIfd
The EXIF IFD.
data
Type: SystemObject
The EXIF Data
See Also

Reference

ExifTag Class
ExifTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifTag Constructor (Int32, ExifTagIfd, Object, TiffTagDataType)

Initializes a new instance of ExifTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag(
    int id,
    ExifTagIfd ifd,
    Object data,
    TiffTagDataType type
)
Public Sub New (
    id As Integer,
    ifd As ExifTagIfd,
    data As Object,
    type As TiffTagDataType
)

Parameters

id
Type: SystemInt32
The ExifID
ifd
Type: Atalasoft.Imaging.MetadataExifTagIfd
The ExifIfd
data
Type: SystemObject
The object data
type
Type: Atalasoft.Imaging.MetadataTiffTagDataType
The tag data type
See Also

Reference

ExifTag Class
ExifTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifTag Constructor (ExifTagID, ExifTagIfd, Object, TiffTagDataType)

Initializes a new instance of the ExifTag class.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTag(
    ExifTagID id,
    ExifTagIfd ifd,
    Object data,
    TiffTagDataType type
)
Public Sub New (
    id As ExifTagID,
    ifd As ExifTagIfd,
    data As Object,
    type As TiffTagDataType
)

Parameters

id
Type: Atalasoft.Imaging.MetadataExifTagID
The tag identifier.
ifd
Type: Atalasoft.Imaging.MetadataExifTagIfd
The ifd.
data
Type: SystemObject
The data to associate with the tag.
type
Type: Atalasoft.Imaging.MetadataTiffTagDataType
The type of the data.
See Also

Reference

ExifTag Class
ExifTag Overload
Atalasoft.Imaging.Metadata Namespace


ExifTag Properties

The ExifTag type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the value of this EXIF tag. (Overrides TiffTagData.)
Public property | Description | Obsolete. This property is deprecated.
Public property | ID | Gets the ID of this TIFF tag. (Inherited from TiffTag.)
Public property | Ifd | Gets the IFD of this ExifTag.
Public property | Type | Gets the TIFF DataType for this TIFF Tag. (Inherited from TiffTag.)
Top
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag.Data Property

ExifTagData Property

Gets or sets the value of this EXIF tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object Data { get; set; }
Public Overrides Property Data As Object
    Get
    Set

Property Value

Type: Object
The value of this EXIF tag.
Remarks

The returned value is a variant object that is stored at its native type. Use ToString to view the string data of this tag.

When editing or adding EXIF data, this tag must be able to be translated to the appropriate Type as defined in the ExifTag.Type property.

Array of types is also supported. To determine if a tag is an array of values ihe invoke the GetType().IsArray() of the Data object.

See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag.Description Property

ExifTagDescription Property

Note: This API is now obsolete.

This property is deprecated.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property has been deprecated.  Use ToString() instead.")]
public string Description { get; set; }
<ObsoleteAttribute("This property has been deprecated.  Use ToString() instead.")>
Public Property Description As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag.Ifd Property

ExifTagIfd Property

Gets the IFD of this ExifTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExifTagIfd Ifd { get; }
Public ReadOnly Property Ifd As ExifTagIfd
    Get

Property Value

Type: ExifTagIfd
The IFD of this ExifTag.
Remarks
EXIF data can be stored in multiple IFD's.
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag Methods

The ExifTag type exposes the following members.

Methods
 | Name | Description
 | ConvertExifDate | convert an Exif Date to a recognizeable system date
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a text description of the tag in the form of 'TagDescription: FormattedTagValue' (Overrides TiffTagToString.)
Top
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag.ConvertExifDate Method

ExifTagConvertExifDate Method

convert an Exif Date to a recognizeable system date

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DateTime ConvertExifDate(
    string exifDate
)
Public Shared Function ConvertExifDate (
    exifDate As String
) As DateTime

Parameters

exifDate
Type: SystemString
A date string returned from an unformatted Exif tag.

Return Value

Type: DateTime
The converted DateTime.
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTag.ToString Method

ExifTagToString Method

Returns a text description of the tag in the form of 'TagDescription: FormattedTagValue'

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A text description of the tag.
See Also

Reference

ExifTag Class
Atalasoft.Imaging.Metadata Namespace


ExifTagID Enumeration

Enumeration of known Exif tag ID's.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ExifTagID
Public Enumeration ExifTagID
Members
Member name | Description
ImageWidth | ImageWidth, used by Main Ifd (0 - 32)
ImageLength | ImageLength, used by Main Ifd (0 - 32)
BitsPerSample | BitsPerSample, used by Main Ifd (0 - 32)
Compression | Compression algorithm
PhotometricInterpretation | PhotometricInterpretation, used by Main Ifd (0 - 32)
DocumentName | (TIFF Extended) The name of the document from which this image was scanned
ImageDescription | ImageDescription, used by Main Ifd (0 - 32)
Make | Make, used by Main Ifd (0 - 32)
Model | Model, used by Main Ifd (0 - 32)
StripOffsets | StripOffsets, used by Main Ifd (0 - 32)
Orientation | Orientation, used by Main Ifd (0 - 32)
SamplesPerPixel | SamplesPerPixel, used by Main Ifd (0 - 32)
RowsPerStrip | RowsPerStrip, used by Main Ifd (0 - 32)
StripByteCounts | StripByteCounts, used by Main Ifd (0 - 32)
XResolution | XResolution, used by Main Ifd (0 - 32)
YResolution | YResolution, used by Main Ifd (0 - 32)
PlanarConfiguration | PlanarConfiguration, used by Main Ifd (0 - 32)
PageName | The name of the page from which this image was scanned
XPosition | (TIFF Extended) X position of the image.
YPosition | (TIFF Extended) Y position of the image.
GrayResponseUnit | The precision of the information contained in the GrayResponseCurve
GrayResponseCurve | For grayscale data, the optical density of each possible pixel value.
ResolutionUnit | ResolutionUnit, used by Main Ifd (0 - 32)
PageNumber | (TIFF Extended) The page number of the page from which this image was scanned.
TransferFunction | TransferFunction, used by Main Ifd (0 - 32)
Software | Software, used by Main Ifd (0 - 32)
DateTime | DateTime, used by Main Ifd (0 - 32)
Artist | Artist, used by Main Ifd (0 - 32)
HostComputer | The computer and/or operating system in use at the time of image creation.
WhitePoint | WhitePoint, used by Main Ifd (0 - 32)
PrimaryChromaticities | PrimaryChromaticities, used by Main Ifd (0 - 32)
JpegInterchangeFormat | JpegInterchangeFormat, used by Main Ifd (0 - 32)
JpegInterchangeFormatLength | JpegInterchangeFormatLength, used by Main Ifd (0 - 32)
YCbCrCoefficients | YCbCrCoefficients, used by Main Ifd (0 - 32)
YCbCrSubSampling | YCbCrSubSampling, used by Main Ifd (0 - 32)
YCbCrPositioning | YCbCrPositioning, used by Main Ifd (0 - 32)
ReferenceBlackWhite | ReferenceBlackWhite, used by Main Ifd (0 - 32)
BatteryLevel | 0x828F TIFF/EP: Encodes camera battery level at time of image capture.
Copyright | Copyright, used by Main Ifd (0 - 32)
ExifIfdPointer | ExifIfdPointer, used by Main Ifd (0 - 32)
GpsInfoIfdPointer | GpsInfoIfdPointer, used by Main Ifd (0 - 32)
ExposureTime | ExposureTime, used by Exif Ifd (31 - 73)
FNumber | FNumber, used by Exif Ifd (31 - 73)
IccProfile | 0x8773 InterColorProfile (Exif)
ExposureProgram | 0x8822 ExposureProgram (Exif)
SpectralSensitivity | 0x8824 SpectralSensitivity (Exif)
IsoSpeedRatings | IsoSpeedRatings, used by Exif Ifd (31 - 73)
Oecf | Oecf, used by Exif Ifd (31 - 73)
Interlace | 0x8829 Interlace - Indicates the field number of multifield images. (TIFF/EP)
TimeZoneOffset | Encodes time zone of camera clock relative to GMT. (TIFF/EP)
SelfTimeMode | 0x882B SelfTimeMode (Exif)
ExifVersion | ExifVersion (Exif)
DateTimeOriginal | DateTimeOriginal (Exif)
DateTimeDigitized | DateTimeDigitized (Exif)
ComponentsConfiguration | ComponentsConfiguration, used by Exif Ifd (31 - 73)
CompressedBitsPerPixel | CompressedBitsPerPixel, used by Exif Ifd (31 - 73)
ShutterSpeedValue | ShutterSpeedValue, used by Exif Ifd (31 - 73)
ApertureValue | ApertureValue, used by Exif Ifd (31 - 73)
BrightnessValue | BrightnessValue, used by Exif Ifd (31 - 73)
ExposureBiasValue | ExposureBiasValue, used by Exif Ifd (31 - 73)
MaxApertureValue | MaxApertureValue, used by Exif Ifd (31 - 73)
SubjectDistance | SubjectDistance, used by Exif Ifd (31 - 73)
MeteringMode | MeteringMode, used by Exif Ifd (31 - 73)
LightSource | LightSource, used by Exif Ifd (31 - 73)
Flash | Flash, used by Exif Ifd (31 - 73)
FocalLength | FocalLength, used by Exif Ifd (31 - 73)
MakerNote | (0x927C) MakerNote
UserComment | (0x9286) UserComment
SubsecTime | SubsecTime, used by Exif Ifd (31 - 73)
SubsecTimeOriginal | SubsecTimeOriginal, used by Exif Ifd (31 - 73)
SubsecTimeDigitized | SubsecTimeDigitized, used by Exif Ifd (31 - 73)
FlashPixVersion | FlashPixVersion, used by Exif Ifd (31 - 73)
ColorSpace | ColorSpace, used by Exif Ifd (31 - 73)
PixelXDimension | PixelXDimension, used by Exif Ifd (31 - 73)
PixelYDimension | PixelYDimension, used by Exif Ifd (31 - 73)
RelatedSoundFile | RelatedSoundFile, used by Exif Ifd (31 - 73)
InteroperabilityIfdPointer | InteroperabilityIfdPointer, used by Exif Ifd (31 - 73)
FlashEnergy | FlashEnergy, used by Exif Ifd (31 - 73)
SpatialFrequencyResponse | (0xA20C) Exif: SpatialFrequencyResponse
FocalPlaneXResolution | (0xA20E) Exif: FocalPlaneXResolution
FocalPlaneYResolution | (0xA20F) Exif: FocalPlaneYResolution
FocalPlaneResolutionUnit | (0xA210) Exif: FocalPlaneResolutionUnit
SubjectLocation | (0xA214) Exif: SubjectLocation
ExposureIndex | ExposureIndex, used by Exif Ifd (31 - 73)
SensingMethod | 0xA217 SensingMethod (Exif)
FileSource | FileSource (Exif)
SceneType | SceneType (Exif)
CFAPattern | Exif: Indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used.
ImageNumber | Exif: ImageNumber
SecurityClassification | SecurityClassification, used by Exif Ifd (31 - 73)
ImageHistory | ImageHistory, used by Exif Ifd (31 - 73)
TiffEpStandardID | TiffEpStandardID (Not well attested - see 0x9216!)
CustomRendered | CustomRendered, used by Exif Ifd (31 - 73)
ExposureMode | ExposureMode, used by Exif Ifd (31 - 73)
WhiteBalance | WhiteBalance, used by Exif Ifd (31 - 73)
DigitalZoomRatio | DigitalZoomRatio, used by Exif Ifd (31 - 73)
FocalLengthIn35mmFormat | FocalLengthIn35mmFormat, used by Exif Ifd (31 - 73)
SceneCaptureType | SceneCaptureType, used by Exif Ifd (31 - 73)
GainControl | GainControl, used by Exif Ifd (31 - 73)
Contrast | Contrast, used by Exif Ifd (31 - 73)
Saturation | Saturation, used by Exif Ifd (31 - 73)
Sharpness | Sharpness, used by Exif Ifd (31 - 73)
DeviceSettingDescription | DeviceSettingDescription, used by Exif Ifd (31 - 73)
SubjectDistanceRange | SubjectDistanceRange, used by Exif Ifd (31 - 73)
ImageUniqueID | ImageUniqueID, used by Exif Ifd (31 - 73)
CameraOwnerName | owner of the camera as an ASCII string
BodySerialNumber | serial number of the body of the camera as an ASCII string
LensSpecification | minimum focal length, maximum focal length, minimum F number in the minimum focal length, and minimum F number in the maximum focal length
LensMake | lens manufacturer as an ASCII string
LensModel | Lens Model ASCII string
LensSerialNumber | Lens Serial Number, serial number of the interchangeable lens that was used in photography, as an ASCII string.
GDALMetaData | GDALMetaData, used by Exif Ifd (31 - 73)
Gamma | Gamma, used by Exif Ifd (31 - 73)
FilmProductCode | FilmProductCode, used by Exif Ifd (31 - 73)
ImageSourceEK | ImageSourceEK, used by Exif Ifd (31 - 73)
CaptureConditionsPAR | CaptureConditionsPAR, used by Exif Ifd (31 - 73)
CameraOwner | CameraOwner, used by Exif Ifd (31 - 73)
SerialNumber | SerialNumber, used by Exif Ifd (31 - 73)
UserSelectGroupTitle | UserSelectGroupTitle, used by Exif Ifd (31 - 73)
DealerIDNumber | DealerIDNumber, used by Exif Ifd (31 - 73)
CaptureDeviceFID | CaptureDeviceFID, used by Exif Ifd (31 - 73)
PrintImageMatching | Exiv2.org says: "description needed". Found in some Olympus JPEGs. Sub-IFD?
DNGVersion | Encodes the DNG four-tier version number.
DNGBackwardVersion | Specifies the oldest version of the Digital Negative specification for which a file is compatible.
UniqueCameraModel | Defines a unique, non-localized name for the camera model that created the image in the raw file.
LocalizedCameraModel | Similar to the UniqueCameraModel tag, except the name can be localized for different markets to match the localization of the camera name
CFAPlaneColor |
CFALayout |
LinearizationTable |
BlackLevelRepeatDim |
BlackLevel |
BlackLevelDeltaH |
BlackLevelDeltaV |
WhiteLevel |
DefaultScale |
DefaultCropOrigin |
DefaultCropSize |
ColorMatrix1 |
ColorMatrix2 |
CameraCalibration1 |
CameraCalibration2 |
ReductionMatrix1 |
ReductionMatrix2 |
AnalogBalance |
AsShotNeutral |
AsShotWhiteXY |
BaselineExposure |
BaselineNoise |
BaselineSharpness |
BayerGreenSplit |
LinearResponseLimit |
CameraSerialNumber |
LensInfo |
ChromaBlurRadius |
AntiAliasStrength |
ShadowScale |
DNGPrivateData |
MakerNoteSafety |
CalibrationIlluminant1 |
CalibrationIlluminant2 |
BestQualityScale |
RawDataUniqueID |
OriginalRawFileName |
OriginalRawFileData |
ActiveArea |
MaskedAreas |
AsShotICCProfile |
AsShotPreProfileMatrix |
CurrentICCProfile |
CurrentPreProfileMatrix |
ColorimetricReference |
CameraCalibrationSignature |
ProfileCalibrationSignature |
AsShotProfileName |
NoiseReductionApplied |
ProfileName |
ProfileHueSatMapDims |
ProfileHueSatMapData1 |
ProfileHueSatMapData2 |
ProfileToneCurve |
ProfileEmbedPolicy |
ProfileCopyright |
ForwardMatrix1 |
ForwardMatrix2 |
PreviewApplicationName |
PreviewApplicationVersion |
PreviewSettingsName |
PreviewSettingsDigest |
PreviewColorSpace |
PreviewDateTime |
RawImageDigest |
OriginalRawFileDigest |
SubTileBlockSize |
RowInterleaveFactor |
ProfileLookTableDims |
ProfileLookTableData |
OpcodeList1 |
OpcodeList2 |
OpcodeList3 |
NoiseProfile |
GpsVersionId | GpsVersionId, used by Gps Ifd (74 - 100)
GpsLatitudeRef | GpsLatitudeRef, used by Gps Ifd (74 - 100)
GpsLatitude | GpsLatitude, used by Gps Ifd (74 - 100)
GpsLongitudeRef | GpsLongitudeRef, used by Gps Ifd (74 - 100)
GpsLongitude | GpsLongitude, used by Gps Ifd (74 - 100)
GpsAltitudeRef | GpsAltitudeRef, used by Gps Ifd (74 - 100)
GpsAltitude | GpsAltitude, used by Gps Ifd (74 - 100)
GpsTimeStamp | GpsTimeStamp, used by Gps Ifd (74 - 100)
GpsSatellites | GpsSatellites, used by Gps Ifd (74 - 100)
GpsStatus | GpsStatus, used by Gps Ifd (74 - 100)
GpsMeasureMode | GpsMeasureMode, used by Gps Ifd (74 - 100)
GpsDop | GpsDop, used by Gps Ifd (74 - 100)
GpsSpeedRef | GpsSpeedRef, used by Gps Ifd (74 - 100)
GpsSpeed | GpsSpeed, used by Gps Ifd (74 - 100)
GpsTrackRef | GpsTrackRef, used by Gps Ifd (74 - 100)
GpsTrack | GpsTrack, used by Gps Ifd (74 - 100)
GpsImgDirectionRef | GpsImgDirectionRef, used by Gps Ifd (74 - 100)
GpsImgDirection | GpsImgDirection, used by Gps Ifd (74 - 100)
GpsMapDatum | GpsMapDatum, used by Gps Ifd (74 - 100)
GpsDestLatitudeRef | GpsDestLatitudeRef, used by Gps Ifd (74 - 100)
GpsDestLatitude | GpsDestLatitude, used by Gps Ifd (74 - 100)
GpsDestLongitudeRef | GpsDestLongitudeRef, used by Gps Ifd (74 - 100)
GpsDestLongitude | GpsDestLongitude, used by Gps Ifd (74 - 100)
GpsDestBearingRef | GpsDestBearingRef, used by Gps Ifd (74 - 100)
GpsDestBearing | GpsDestBearing, used by Gps Ifd (74 - 100)
GpsDestDistanceRef | GpsDestDistanceRef, used by Gps Ifd (74 - 100)
GpsDestDistance | GpsDestDistance, used by Gps Ifd (74 - 100)
InteroperabilityIndex | InteroperabilityIndex, used by Interoperability Ifd (101 - 105)
InteroperabilityVersion | InteroperabilityVersion, used by Interoperability Ifd (101 - 105)
RelatedImageFileFormat | RelatedImageFileFormat, used by Interoperability Ifd (101 - 105)
RelatedImageWidth | RelatedImageWidth, used by Interoperability Ifd (101 - 105)
RelatedImageLength | RelatedImageLength, used by Interoperability Ifd (101 - 105)
FujiVersion | FujiVersion, Fuji specific tag
FujiQuality | FujiQuality, Fuji specific tag
FujiSharpness | FujiSharpness, Fuji specific tag
FujiWhiteBalance | FujiWhiteBalance, Fuji specific tag
FujiColor | FujiColor, Fuji specific tag
FujiTone | FujiTone, Fuji specific tag
FujiFlashMode | FujiFlashMode, Fuji specific tag
FujiFlashStrength | FujiFlashStrength, Fuji specific tag
FujiMacro | FujiMacro, Fuji specific tag
FujiFocusMode | FujiFocusMode, Fuji specific tag
FujiSlowSynch | FujiSlowSynch, Fuji specific tag
FujiPictureMode | FujiPictureMode, Fuji specific tag
FujiContTakeBracket | FujiContTakeBracket, Fuji specific tag
FujiBlurWarning | FujiBlurWarning, Fuji specific tag
FujiFocusWarning | FujiFocusWarning, Fuji specific tag
FujiAEWarning | FujiAEWarning, Fuji specific tag
FujiUnknown | FujiUnknown, Fuji specific tag
OlympusMakernoteVersion | OlympusMakernoteVersion, Olympus makernote tag
OlympusMinoltaCameraSettings | MinoltaCameraSettings, Olympus(Minolta) makernote tag
OlympusMinoltaAltCameraSettings | Minolta Alternate Camera Settings, Olympus(Minolta) makernote tag
OlympusPrintImageMatchingInfo | OlympusPrintImageMatchingInfo, Olympus makernote tag
OlympusCameraCompressedImageSize | OlympusCameraCompressedImageSize, Olympus makernote tag
OlympusMinoltaThumbnailOffset | OlympusMinoltaThumbnailOffset, Olympus makernote tag
OlympusMinoltaThumbnailOffset1 | OlympusMinoltaThumbnailOffset1, Olympus makernote tag
OlympusMinoltaThumbnailLength | OlympusMinoltaThumbnailLength, Olympus makernote tag
OlympusThumbnailImage | Olympus Makernote - thumbnail image
OlympusColorMode | OlympusColorMode, Olympus makernote tag
OlympusImageQuality | OlympusImageQuality (0..4), Olympus makernote tag
OlympusImageQuality1 | OlympusImageQuality1 (0..4), Olympus makernote tag
OlympusBodyFirmwareVersion | Body Firmware Version, Olympus makernote tag
OlympusSpecialMode | SpecialMode, Olympus makernote tag
OlympusJpegQuality | JPEG Quality (1,2,3), Olympus makernote tag
OlympusMacro | Macro mode (0=off, 1=Macro), Olympus makernote tag
OlympusBWMode | Black and white mode, Olympus makernote tag
OlympusDigitalZoom | Digital zoom (0=off, 1=on ?), Olympus makernote tag
OlympusPlaneFocalDiagonal | Digital zoom (0=off, 1=on ?), Olympus makernote tag
OlympusLensDistortionParams | Digital zoom (0=off, 1=on ?), Olympus makernote tag
OlympusCameraType | Camera type, Olympus makernote tag
OlympusPictInfo | OlympusPictInfo, Olympus makernote tag
OlympusCameraId | OlympusCameraId, Olympus makernote tag
OlympusSoftware | Software (?), Olympus(Epson) makernote tag
OlympusFirmware | Firmware (version?), Olympus makernote tag
OlympusDataDump | OlympusDataDump, Olympus makernote tag
OlympusDataDump2 | OlympusDataDump2, Olympus makernote tag
OlympusShutterSpeed | OlympusFlashMode, Olympus makernote tag
OlympusISOSpeed | OlympusFlashMode, Olympus makernote tag
OlympusApertureValue | OlympusFlashMode, Olympus makernote tag
OlympusBrightness | OlympusFlashMode, Olympus makernote tag
OlympusFlashMode | OlympusFlashMode, Olympus makernote tag
OlympusFlashDevice | OlympusFlashDevice, Olympus makernote tag
OlympusBracket | OlympusBracket, Olympus makernote tag
OlympusSensorTemperature | OlympusSensorTemperature, Olympus makernote tag
OlympusLensTemperature | OlympusLensTemperature, Olympus makernote tag
OlympusLightCondition | OlympusLightCondition, Olympus makernote tag
OlympusFocusRange | OlympusFocusRange, Olympus makernote tag
OlympusFocusMode | OlympusFocusMode, Olympus makernote tag
OlympusFocusDistance | OlympusFocusDistance, Olympus makernote tag
OlympusZoom | OlympusZoom, Olympus makernote tag
OlympusMacroFocus | OlympusMacroFocus, Olympus makernote tag
OlympusSharpness | OlympusSharpness, Olympus makernote tag
OlympusFlashChargeLevel | OlympusFlashChargeLevel, Olympus makernote tag
OlympusColorMatrix | OlympusColorMatrix, Olympus makernote tag
OlympusBlackLevel | OlympusBlackLevel, Olympus makernote tag
OlympusBlackLevel1 | OlympusDataDump2, Olympus makernote tag
OlympusWhiteBalance | OlympusWhiteBalance, Olympus makernote tag
OlympusRedBias | OlympusRedBias, Olympus makernote tag
OlympusBlueBias | OlympusBlueBias, Olympus makernote tag
OlympusColorMatrixNumber | OlympusColorMatrixNumber, Olympus makernote tag
OlympusSerialNumber | OlympusSerialNumber, Olympus makernote tag
OlympusFlashBias | OlympusFlashBias, Olympus makernote tag
OlympusContrast | OlympusContrast, Olympus makernote tag
OlympusSharpnessFactor | OlympusSharpnessFactor, Olympus makernote tag
OlympusColorControl | OlympusColorControl, Olympus makernote tag
OlympusValidBits | OlympusValidBits, Olympus makernote tag
OlympusCoringFilter | OlympusCoringFilter, Olympus makernote tag
OlympusImageWidth | OlympusImageWidth, Olympus makernote tag
OlympusImageHeight | OlympusImageHeight, Olympus makernote tag
OlympusCompressionRatio | OlympusCompressionRatio, Olympus makernote tag
OlympusThumbnail | Thumbnail, Olympus makernote tag
OlympusThumbnailOffset | ThumbnailOffset, Olympus makernote tag
OlympusThumbnailLength | ThumbnailLength, Olympus makernote tag
OlympusCCDScanMode | CCDScanMode, Olympus makernote tag
OlympusNoiseReduction | NoiseReduction, Olympus makernote tag
OlympusInfinityLensStep | InfinityLensStep, Olympus makernote tag
OlympusNearLensStep | NearLensStep, Olympus makernote tag
OlympusEquipment | Equipment sub-IFD, Olympus makernote tag
OlympusCameraSettings | Camera settings sub-IFD, Olympus makernote tag
OlympusRawDevelopment | Raw development sub-IFD, Olympus makernote tag
OlympusRawDevelopment2 | Raw development 2 sub-IFD, Olympus makernote tag
OlympusImageProcessing | Image processing sub-IFD, Olympus makernote tag
OlympusFocusInfo | Focus Info sub-IFD, Olympus makernote tag
OlympusRawInfo | Raw info sub-IFD, Olympus makernote tag
NikonQuality | NikonQuality, Nikon specific tag
NikonColorMode | NikonColorMode, Nikon specific tag
NikonImageAdjustment | NikonImageAdjustment, Nikon specific tag
NikonCcdSensitivity | NikonCcdSensitivity, Nikon specific tag
NikonWhiteBalance | NikonWhiteBalance, Nikon specific tag
NikonFocus | NikonFocus, Nikon specific tag
NikonDigitalZoom | NikonDigitalZoom, Nikon specific tag
NikonConverter | NikonConverter, Nikon specific tag
Nikon3MakernoteVersion | Nikon3MakernoteVersion, Nikon specific tag, type 3
Nikon3ISOSpeedUsed | Nikon3ISOSpeedUsed, Nikon specific tag, type 3
Nikon3ColorMode | Nikon3ColorMode, Nikon specific tag, type 3
Nikon3Quality | Nikon3Quality, Nikon specific tag, type 3
Nikon3WhiteBalance | Nikon3WhiteBalance, Nikon specific tag, type 3
Nikon3Sharpening | Nikon3Sharpening, Nikon specific tag, type 3
Nikon3FocusMode | Nikon3FocusMode, Nikon specific tag, type 3
Nikon3FlashSetting | Nikon3FlashSetting, Nikon specific tag, type 3
Nikon3AutoFlashMode | Nikon MakerNote3 AutoFlashMode
Nikon3WhiteBalanceBias | Nikon MakerNote3 WhiteBalanceBias
Nikon3WB_RBLevels | Nikon MakerNote3 WB_RedBlueLevels
Nikon3ProgramShift | Nikon MakerNote3 ProgramShift
Nikon3ExposureDiff | Nikon MakerNote3 ExposureDiff
Nikon3ISOSelection | Nikon MakerNote3 ISOSelection
Nikon3DataDump | Nikon MakerNote3 DataDump
Nikon3Preview | Nikon MakerNote3 Preview
Nikon3FlashComp | Nikon MakerNote3 FlashComp
Nikon3ISOSettings | Nikon MakerNote3 ISOSettings
Nikon3ImageBoundary | Nikon MakerNote3 ImageBoundary
Nikon3PhotoCornerCoordinates | The nikon3 photo corner coordinates
Nikon3FlashExposureComp | Nikon MakerNote3 FlashExposureComp
Nikon3FlashBracketComp | Nikon MakerNote3 FlashBracketComp
Nikon3FlashBracketCompensationApplied | The nikon3 flash bracket compensation applied
Nikon3ExposureBracketComp | Nikon MakerNote3 ExposureBracketComp
Nikon3AEBracketCompensationApplied | The nikon3 ae bracket compensation applied
Nikon3ImageProcessing | Nikon MakerNote3 ImageProcessing
Nikon3CropHiSpeed | Nikon MakerNote3 CropHiSpeed
Nikon3ExposureTuning | Nikon MakerNote3 ExposureTuning
Nikon3SerialNumber | Nikon MakerNote3 SerialNumber
Nikon3ColorSpace | Nikon MakerNote3 ColorSpace
Nikon3VRInfo | Nikon MakerNote3 VRInfo
Nikon3ImageAuthentication | Nikon MakerNote3 ImageAuthentication
Nikon3ActiveDLighting | Nikon MakerNote3 ActiveDLighting
Nikon3PictureControl | Nikon MakerNote3 PictureControl
Nikon3WorldTime | Nikon MakerNote3 WorldTime
Nikon3ISOInfo | Nikon MakerNote3 ISOInfo
Nikon3VignetteControl | Nikon MakerNote3 VignetteControl
Nikon3ImageAdjustment | ImageAdjustment, Nikon specific tag, type 3
Nikon3ToneCompensation | Nikon3ToneCompensation, Nikon specific tag, type 3
Nikon3AuxiliaryLens | Nikon3AuxiliaryLens, Nikon specific tag, type 3
Nikon3LensType | Nikon3LensType, Nikon specific tag, type 3
Nikon3LensMinMaxFocalLength | Nikon3LensMinMaxFocalLength, Nikon specific tag, type 3
Nikon3ManualFocusDistance | Nikon3ManualFocusDistance, Nikon specific tag, type 3
Nikon3DigitalZoomFactor | Nikon3DigitalZoomFactor, Nikon specific tag, type 3
Nikon3FlashUsed | Nikon3FlashUsed, Nikon specific tag, type 3
Nikon3AutoFocusArea | Nikon3AutoFocusArea, Nikon specific tag, type 3
Nikon3BracketingShootingMode | Nikon3BracketingShootingMode, Nikon specific tag, type 3
Nikon3AutoBracketRelease | Nikon MakerNote3 AutoBracketRelease
Nikon3LensFStops | Nikon MakerNote3 LensFStops
Nikon3ContrastCurve | Nikon MakerNote3 ContrastCurve
Nikon3ColorHue | Nikon3ColourMode, Nikon specific tag, type 3
Nikon3ColourMode | The nikon3 colour mode
Nikon3SceneMode | Nikon3SceneMode, Nikon specific tag, type 3
Nikon3LightingType | Nikon3LightingType, Nikon specific tag, type 3
Nikon3ShotInfo | Nikon MakerNote3 ShotInfo
Nikon3HueAdjustment | Nikon MakerNote3 HueAdjustment
Nikon3NEFCompression | Nikon MakerNote3 NEFCompression
Nikon3Saturation | Nikon3Saturation, Nikon specific tag, type 3
Nikon3NoiseReduction | Nikon3NoiseReduction, Nikon specific tag, type 3
Nikon3ColorBalance | Nikon3ColorBalance
Nikon3LensData | Nikon3LensData
Nikon3RawImageCenter | Nikon3RawImageCenter
Nikon3SensorPixelSize | Nikon3SensorPixelSize
Nikon3SceneAssist | Nikon3SceneAssist
Nikon3RetouchHistory | Nikon3RetouchHistory
Nikon3ImageDataSize | Nikon3ImageDataSize
Nikon3TagA3 | Nikon3TagA3
Nikon3ImageCount | Nikon3ImageCount
Nikon3DeletedImageCount | Nikon3DeletedImageCount
Nikon3ShutterCount | TotalNumberOfShutterReleasesForCamera
Nikon3TotalNumberOfShutterReleasesForCamera | The nikon3 total number of shutter releases for camera
Nikon3FlashInfo | FlashInfo
Nikon3ImageOptimisation | ImageOptimisation, Nikon specific tag, type 3
Nikon3Saturation2 | Saturation1, Nikon specific tag, type 3
Nikon3DigitalVariProgram | DigitalVariProgram, Nikon specific tag, type 3
Nikon3MultiExposure | MultiExposure
Nikon3HighISONoiseReduction | HighISONoiseReduction
CasioRecordingMode | CasioRecordingMode, Casio specific tag
CasioQuality | CasioQuality, Casio specific tag
CasioFocusingMode | CasioFocusingMode, Casio specific tag
CasioFlashMode | CasioFlashMode, Casio specific tag
CasioFlashIntensity | CasioFlashIntensity, Casio specific tag
CasioObjectDistance | CasioObjectDistance, Casio specific tag
CasioWhiteBalance | CasioWhiteBalance, Casio specific tag
CasioDigitalZoom | CasioDigitalZoom, Casio specific tag
CasioSharpness | CasioSharpness, Casio specific tag
CasioContrast | CasioContrast, Casio specific tag
CasioSaturation | CasioSaturation, Casio specific tag
CasioCcdSensitivity | CasioCcdSensitivity, Casio specific tag
CanonHeader | CanonHeader, Canon specific tag
CanonTagLength1 | CanonTagLength1, Canon specific tag
CanonMacroMode | CanonMacroMode, Canon specific tag
CanonSelfTimer | CanonSelfTimer, Canon specific tag
CanonQuality | CanonQuality, Canon specific tag
CanonFlashMode | CanonFlashMode, Canon specific tag
CanonContinuousDriveMode | CanonContinuousDriveMode, Canon specific tag
CanonUnknown1_6 | CanonUnknown1_6, Canon specific tag
CanonFocusMode | CanonFocusMode, Canon specific tag
CanonUnknown1_8 | CanonUnknown1_8, Canon specific tag
CanonUnknown1_9 | CanonUnknown1_9, Canon specific tag
CanonImageSize | CanonImageSize, Canon specific tag
CanonEasyShootingMode | CanonEasyShootingMode, Canon specific tag
CanonDigitalZoom | CanonDigitalZoom, Canon specific tag
CanonContrast | CanonContrast, Canon specific tag
CanonSaturation | CanonSaturation, Canon specific tag
CanonSharpness | CanonSharpness, Canon specific tag
CanonIso | CanonIso, Canon specific tag
CanonMeteringMode | CanonMeteringMode, Canon specific tag
CanonFocusType | CanonFocusType, Canon specific tag
CanonAFPointSelected | CanonAFPointSelected, Canon specific tag
CanonExposureMode | CanonExposureMode, Canon specific tag
CanonUnknown1_21 | CanonUnknown1_21, Canon specific tag
CanonLensType | CanonLensType, Canon specific tag
CanonLongFocalLength | CanonLongFocalLength, Canon specific tag
CanonShortFocalLength | CanonShortFocalLength, Canon specific tag
CanonFocalUnits | CanonFocalUnits, Canon specific tag
CanonMaxAperture | CanonMaxAperture, Canon specific tag
CanonUnknown1_27 | CanonUnknown1_27, Canon specific tag
CanonFlashActivity | CanonFlashActivity, Canon specific tag
CanonFlashDetails | CanonFlashDetails, Canon specific tag
CanonUnknown1_30 | CanonUnknown1_30, Canon specific tag
CanonUnknown1_31 | CanonUnknown1_31, Canon specific tag
CanonFocusContinuos | CanonFocusContinuos, Canon specific tag
CanonUnknown1_33 | CanonUnknown1_33, Canon specific tag
CanonUnknown1_34 | CanonUnknown1_34, Canon specific tag
CanonUnknown1_35 | CanonUnknown1_35, Canon specific tag
CanonZoomedResolution | CanonZoomedResolution, Canon specific tag
CanonZoomedResolutionBase | CanonZoomedResolutionBase, Canon specific tag
CanonUnknown1_38 | CanonUnknown1_38, Canon specific tag
CanonUnknown1_39 | CanonUnknown1_39, Canon specific tag
CanonUnknown1_40 | CanonUnknown1_40, Canon specific tag
CanonUnknown1_41 | CanonUnknown1_41, Canon specific tag
CanonColorTone | CanonColorTone, Canon specific tag
CanonUnknown1_43 | CanonUnknown1_43, Canon specific tag
CanonUnknown1_44 | CanonUnknown1_44, Canon specific tag
CanonUnknown1_45 | CanonUnknown1_45, Canon specific tag
CanonUnknown1_46 | CanonUnknown1_46, Canon specific tag
CanonFocalType | Canon specific tag
CanonFocalLength | Canon specific tag
CanonFocalPlaneXSize | Canon specific tag
CanonFocalPlaneYSize | Canon specific tag
CanonUnknownTag3 | Canon specific tag
CanonUnknownTag16 | Canon specific tag
CanonFileLength | Canon specific tag
CanonTagLength4 | Canon specific tag
CanonUnknown4_1 | Canon specific tag
CanonShotISO | Canon specific tag
CanonUnknown4_3 | Canon specific tag
CanonTargetAperture | Canon specific tag
CanonTargetExposureTime | Canon specific tag
CanonExposureCompensation | Canon specific tag
CanonWhiteBalance | Canon specific tag
CanonUnknown4_8 | Canon specific tag
CanonSequenceNumber | Canon specific tag
CanonUnknown4_10 | Canon specific tag
CanonUnknown4_11 | Canon specific tag
CanonUnknown4_12 | Canon specific tag
CanonUnknown4_13 | Canon specific tag
CanonAFPointUsed | Canon specific tag
CanonFlashBias | Canon specific tag
CanonAutoExposureBracketing | Canon specific tag
CanonAEBBracketValue | Canon specific tag
CanonUnknown4_18 | Canon specific tag
CanonSubjectDistance | Canon specific tag
CanonFocusDistanceLower | Canon specific tag
CanonFNumber | Canon specific tag
CanonExposureTime | Canon specific tag
CanonUnknown4_23 | Canon specific tag
CanonBulbDuration | Canon specific tag
CanonAutoRotate | Canon specific tag
CanonUnknown4_26 | Canon specific tag
CanonUnknown4_27 | Canon specific tag
CanonUnknown4_28 | Canon specific tag
CanonUnknown4_29 | Canon specific tag
CanonUnknown4_30 | Canon specific tag
CanonUnknown4_31 | Canon specific tag
CanonUnknown5_00 | Canon specific tag
CanonUnknown5_01 | Canon specific tag
CanonPanoramaFrame | Canon specific tag
CanonUnknown5_03 | Canon specific tag
CanonUnknown5_04 | Canon specific tag
CanonPanoramaDirection | Canon specific tag
CanonImageType | Canon specific tag
CanonFirmwareVersion | Canon specific tag
CanonImageNumber | Canon specific tag
CanonOwnerName | Canon specific tag
CanonFileInfoFileNumber | Canon specific tag
CanonFileInfoShutterCount | Canon specific tag
CanonCameraSerialNumber | Canon specific tag
CanonUnknownA_00 | Canon 0xa specific tag
CanonUnknownA_01 | Canon 0xa specific tag
CanonUnknownA_02 | Canon 0xa specific tag
CanonUnknownA_03 | Canon 0xa specific tag
CanonUnknownA_04 | Canon 0xa specific tag
CanonUnknownA_05 | Canon 0xa specific tag
CanonUnknownA_06 | Canon 0xa specific tag
CanonUnknownA_07 | Canon 0xa specific tag
CanonUnknownA_08 | Canon 0xa specific tag
CanonColorTemperature | Canon 0xa specific tag
CanonColorMatrix | Canon 0xa specific tag
CanonRedBalanceAuto | Canon 0xA9 specific tag
CanonBlueBalanceAuto | Canon 0xA9 specific tag
CanonRedBalanceDayLight | Canon 0xA9 specific tag
CanonBlueBalanceDayLight | Canon 0xA9 specific tag
CanonRedBalanceCloudy | Canon 0xA9 specific tag
CanonBlueBalanceCloudy | Canon 0xA9 specific tag
CanonRedBalanceTungsten | Canon 0xA9 specific tag
CanonBlueBalanceTungsten | Canon 0xA9 specific tag
CanonRedBalanceFluorescent | Canon 0xA9 specific tag
CanonBlueBalanceFluorescent | Canon 0xA9 specific tag
CanonRedBalanceFlash | Canon 0xA9 specific tag
CanonBlueBalanceFlash | Canon 0xA9 specific tag
CanonRedBalanceCustom | Canon 0xA9 specific tag
CanonBlueBalanceCustom | Canon 0xA9 specific tag
CanonRedBalanceBW | Canon 0xA9 specific tag
CanonBlueBalanceBW | Canon 0xA9 specific tag
CanonRedBalanceShade | Canon 0xA9 specific tag
CanonBlueBalanceShade | Canon 0xA9 specific tag
CanonLensInfo1DUnknown0 | Canon 0xd specific tag
CanonLensInfo1DUnknown1 | Canon 0xd specific tag
CanonLensInfo1DUnknown2 | Canon 0xd specific tag
CanonLensInfo1DUnknown3 | Canon 0xd specific tag
CanonLensInfo1DExposureTime | Canon 0xd specific tag
CanonLensInfo1DUnknown5 | Canon 0xd specific tag
CanonLensInfo1DUnknown6 | Canon 0xd specific tag
CanonLensInfo1DUnknown7 | Canon 0xd specific tag
CanonLensInfo1DUnknown8 | Canon 0xd specific tag
CanonLensInfo1DUnknown9 | Canon 0xd specific tag
CanonLensInfo1DFocalLength | Canon 0xd specific tag
CanonLensInfo1DUnknown11 | Canon 0xd specific tag
CanonLensInfo1DLensType | Canon 0xd specific tag
CanonLensInfo1DShortFocal | Canon 0xd specific tag
CanonLensInfo1DLongFocal | Canon 0xd specific tag
CanonLensInfo1DFocalType | Canon 0xd specific tag
CanonColorTemperature1 | Canon 0x00AE specific tag
CanonPictureInfoImageWidth | Canon 0x12 specific tag
CanonPictureInfoImageHeight | Canon 0x12 specific tag
CanonPictureInfoImageWidthAsShot | Canon 0x12 specific tag
CanonPictureInfoImageHeightAsShot | Canon 0x12 specific tag
CanonPictureInfoImageAFPointsUsed | Canon 0x12 specific tag
CanonPictureInfoUnknown | Canon 0x12 specific tag
CanonPreviewImageInfoUnKnown0 | Canon 0x00B6 specific tag
CanonPreviewImageInfoUnKnown1 | Canon 0x00B6 specific tag
CanonPreviewImageInfoLength | Canon 0x00B6 specific tag
CanonPreviewImageInfoWidth | Canon 0x00B6 specific tag
CanonPreviewImageInfoHeight | Canon 0x00B6 specific tag
CanonPreviewImageInfoStart | Canon 0x00B6 specific tag
CanonPreviewImageInfoFocalPlaneXResolution | Canon 0x00B6 specific tag
CanonPreviewImageInfoUnknown7 | Canon 0x00B6 specific tag
CanonPreviewImageInfoFocalPlaneYResolution | Canon 0x00B6 specific tag
CanonTagLength15 | Canon specific tag
CanonLongExposureNoiseReduction | Canon specific tag
CanonShutterAELockButtons | Canon specific tag
CanonMirrorLockup | Canon specific tag
CanonTVAVAndExposureLevel | Canon specific tag
CanonAFAssistLight | Canon specific tag
CanonShutterSpeedInAVMode | Canon specific tag
CanonAebSequenceAutoCancellation | Canon specific tag
CanonShutterCurtainSync | Canon specific tag
CanonLensAFStopButtonFNSwitch | Canon specific tag
CanonAutoReductionOfFillFlash | Canon specific tag
CanonMenuButtonReturnPosition | Canon specific tag
CanonSetButtonFuncWhenShooting | Canon specific tag
CanonSensorCleaning | Canon specific tag
CanonSuperImposedDisplay | Canon specific tag
CanonShutterReleaseNoCFCard | Canon specific tag
TgCanonUnknown0 | Canon specific tag
TgCanonCameraSettings | Canon specific tag
TgCanonFocalLength | Canon specific tag
TgCanonFlashInfo | Canon specific tag
TgCanonShotInfo | Canon specific tag
TgCanonPanorama | Canon specific tag
TgCanonImageType | Canon specific tag
TgCanonFirmwareVersion | Canon specific tag
TgCanonImageNumber | Canon specific tag
TgCanonFileNumber | The tg canon file number
TgCanonOwnerName | Canon specific tag
TgCanonColorInfoD30 | Canon specific tag
TgCanonUnknown11 | Canon specific tag
TgCanonSerialNumber | Canon specific tag
TgCanonLensInfo1D | Canon specific tag
TgCanonFileLength | Canon specific tag
TgCanonCustomFunctions | Canon specific tag
TgCanonModelID | Canon specific tag
TgCanonMovieInfo | Canon specific tag
TgCanonAFInfo | Canon specific tag
TgCanonCameraInfo | Canon specific tag
TgCanonSerialNumberFormat | Canon specific tag
TgCanonSuperMacro | Canon specific tag
TgCanonDateStampMode | Canon specific tag
TgCanonMyColors | Canon specific tag
TgCanonFirmwareRevision | Canon specific tag
TgCanonCategories | Canon specific tag
TgCanonFaceDetect1 | Canon specific tag
TgCanonFaceDetect2 | Canon specific tag
TgCanonAFInfo2 | Canon specific tag
TgCanonContrastInfo | Canon specific tag
TgCanonCustomFunctions1D | Canon specific tag
TgCanonFileInfo | Canon specific tag
TgCanonLensModel | Canon specific tag
TgCanonDustRemovalData | Canon specific tag
TgCanonCropInfo | Canon specific tag
TgCanonAspectInfo | Canon specific tag
TgCanonProcessingInfo | Canon specific tag
TgCanonWhiteBalanceTable | Canon specific tag
TgCanonUnknown168 | Canon specific tag
TgCanonColorBalance | Canon specific tag
TgCanonMeasuredColor | Canon specific tag
TgCanonColorTemperature | Canon specific tag
TgCanonColorSpace | Canon specific tag
TgCanonPreviewImageInfo | Canon specific tag
TgCanonUnknown192 | Canon specific tag
TgCanonUnknown193 | Canon specific tag
CanonRawColorInfo | Canon Raw specific tag
CanonRawFileDescription | Canon Raw specific tag
CanonRawUserComment | Canon Raw specific tag
CanonRawMakeModel | Canon Raw specific tag
CanonRawFirmwareVersion | Canon Raw specific tag
CanonRawROMOperationMode | Canon Raw specific tag
CanonRawOwnerName | Canon Raw specific tag
CanonRawImageType | Canon Raw specific tag
CanonRawOriginalFileName | Canon Raw specific tag
CanonRawThumbnailFileName | Canon Raw specific tag
CanonRawTargetImageType | Canon Raw specific tag
CanonRawShutterReleaseMethod | Canon Raw specific tag
CanonRawShutterReleaseTiming | Canon Raw specific tag
CanonRawBaseISO | Canon Raw specific tag
CanonRawFocalLength | Canon Raw specific tag
CanonRawShotInfo | Canon Raw specific tag
CanonRawCameraSettings | Canon Raw specific tag
CanonRawWhiteSample | Canon Raw specific tag
CanonRawSensorInfo | Canon Raw specific tag
CanonRawCustomFunction | Canon Raw specific tag
CanonRawPictureInfo | Canon Raw specific tag
CanonRawWhiteBalanceTable | Canon Raw specific tag
CanonRawColorTemperature | Canon Raw specific tag
CanonRawColorSpace | Canon Raw specific tag
CanonRawImageFormat | Canon Raw specific tag
CanonRawCompressionRatio | Canon Raw specific tag
CanonRawRecordId | Canon Raw specific tag
CanonRawSelfTimerTime | Canon Raw specific tag
CanonRawTargetDistanceSetting | Canon Raw specific tag
CanonRawSerialNumber | Canon Raw specific tag
CanonRawTimeStamp | Canon Raw specific tag
CanonRawImageInfo | Canon Raw specific tag
CanonRawFlashInfo | Canon Raw specific tag
CanonRawMeasuredEV | Canon Raw specific tag
CanonRawFileNumber | Canon Raw specific tag
CanonRawExposureInfo | Canon Raw specific tag
SanyoSpecialMode | SANYO specific tag
SanyoJpegQuality | SANYO specific tag
SanyoMacro | SANYO specific tag
SanyoDigitalZoom | SANYO specific tag
SanyoSoftwareRelease | SANYO specific tag
SanyoPictInfo | SANYO specific tag
SanyoCameraID | SANYO specific tag
SanyoSequentialShotMethod | SANYO specific tag
SanyoWideRange | SANYO specific tag
SanyoColourAdjustmentMode | SANYO specific tag
SanyoQuickShot | SANYO specific tag
SanyoSelfTimer | SANYO specific tag
SanyoVoiceMemo | SANYO specific tag
SanyoRecordShutterRelease | SANYO specific tag
SanyoFlickerReduce | SANYO specific tag
SanyoOpticalZoom | SANYO specific tag
SanyoDigitalZoom1 | SANYO specific tag
SanyoLightSourceSpecial | SANYO specific tag
SanyoResaved | SANYO specific tag
SanyoSceneSelect | SANYO specific tag
SanyoManualFocalDistance | SANYO specific tag
SanyoFlashMode | SANYO specific tag
SanyoPrintIMFlag | SANYO specific tag
SanyoDataDump | SANYO specific tag
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


ExifTagIfd Enumeration

Contains an enumeration of standard Exif Ifd's.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ExifTagIfd
Public Enumeration ExifTagIfd
Members
Member name | Description
Main | Primary image data information.
Exif | Exif camera information.
Interoperability | Exif interoperabliity information.
Thumbnail | A thumbnail stored with the image.
Gps | GPS Satellite information.
MakerNoteUnknown | Camera specific information for an unknown camera make.
MakerNoteFujiFilm | Camera specific information for a FujiFilm camera make.
MakerNoteOlympus | Camera specific information for an Olympus camera make.
MakerNoteNikonType1 | Camera specific information for a Nikon camera make.
MakerNoteNikonType3 | Camera specific information for a Nikon camera make.
MakerNoteCasio | Camera specific information for a Casio camera make.
MakerNoteCanon | Camera specific information for a Canon camera make.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Class

This exception is thrown when an error with image metadata is detected
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.Imaging.MetadataImageMetadataException

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImageMetadataException : Exception
<SerializableAttribute>
Public Class ImageMetadataException
    Inherits Exception

The ImageMetadataException type exposes the following members.

Constructors
 | Name | Description
Public method | ImageMetadataException | Creates a new instance of ImageMetadataException.
Public method | ImageMetadataException(String) | Creates a new instance of ImageMetadataException specifying the exception message.
Protected method | ImageMetadataException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageMetadataException class.
Public method | ImageMetadataException(String, Exception) | Creates a new instance of ImageMetadataException specifying the exception message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Constructor

Overload List
 | Name | Description
Public method | ImageMetadataException | Creates a new instance of ImageMetadataException.
Public method | ImageMetadataException(String) | Creates a new instance of ImageMetadataException specifying the exception message.
Protected method | ImageMetadataException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageMetadataException class.
Public method | ImageMetadataException(String, Exception) | Creates a new instance of ImageMetadataException specifying the exception message and inner exception.
Top
See Also

Reference

ImageMetadataException Class
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Constructor

Creates a new instance of ImageMetadataException.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageMetadataException()
Public Sub New
See Also

Reference

ImageMetadataException Class
ImageMetadataException Overload
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Constructor (String)

Creates a new instance of ImageMetadataException specifying the exception message.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageMetadataException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

ImageMetadataException Class
ImageMetadataException Overload
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageMetadataException class.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageMetadataException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

ImageMetadataException Class
ImageMetadataException Overload
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Constructor (String, Exception)

Creates a new instance of ImageMetadataException specifying the exception message and inner exception.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageMetadataException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception for this error.
See Also

Reference

ImageMetadataException Class
ImageMetadataException Overload
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Properties

The ImageMetadataException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageMetadataException Class
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Methods

The ImageMetadataException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageMetadataException Class
Atalasoft.Imaging.Metadata Namespace


ImageMetadataException Events

The ImageMetadataException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ImageMetadataException Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection Class

Contains a collection of IPTC tags.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.MetadataIptcCollection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IptcCollection : CollectionBase
Public Class IptcCollection
    Inherits CollectionBase

The IptcCollection type exposes the following members.

Constructors
 | Name | Description
Public method | IptcCollection | Initializes an empty collection of IptcTags
Public method | IptcCollection(Stream) | Obsolete. Creates a new instance of the IptcCollection class specifying the file stream to read the iptc metadata from.
Public method | IptcCollection(String) | Obsolete. Creates a new instance of the IptcCollection class specifying the file to read the iptc metadata from.
Public method | IptcCollection(Stream, Int32) | Obsolete. Creates a new instance of the IptcCollection class specifying the file stream and page index (in a multipage TIFF) to read the iptc metadata from.
Public method | IptcCollection(String, Int32) | Obsolete. Creates a new instance of the IptcCollection class specifying the file and page index (in a multipage TIFF) to read the iptc metadata from.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the IptcTag by index in the collection and allows the Iptc tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Add a new IptcTag to the image.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether [contains] [the specified source].
Public method | CopyTo | Copies items from the collection into an array.
Public method | CreateIptcDataBlock | Generate an IPTC data block.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetTagDescription | Returns a textual description based on an IptcID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index value of an IptcTag.
Public method | Insert | Inserts the specified index.
Public method | LookupTag(Int32, Int32) | Returns an IptcTag based on an IPTC ID and index.
Public method | LookupTag(Int32, Int32, Int32) | Lookups the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified IptcTag from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See the ParseFromImage methods of the IptcParser class to populate an IptcCollection with data from an image.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Metadata Overview


IptcCollection Constructor

Overload List
 | Name | Description
Public method | IptcCollection | Initializes an empty collection of IptcTags
Public method | IptcCollection(Stream) | Obsolete. Creates a new instance of the IptcCollection class specifying the file stream to read the iptc metadata from.
Public method | IptcCollection(String) | Obsolete. Creates a new instance of the IptcCollection class specifying the file to read the iptc metadata from.
Public method | IptcCollection(Stream, Int32) | Obsolete. Creates a new instance of the IptcCollection class specifying the file stream and page index (in a multipage TIFF) to read the iptc metadata from.
Public method | IptcCollection(String, Int32) | Obsolete. Creates a new instance of the IptcCollection class specifying the file and page index (in a multipage TIFF) to read the iptc metadata from.
Top
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection Constructor

Initializes an empty collection of IptcTags

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection()
Public Sub New
See Also

Reference

IptcCollection Class
IptcCollection Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection Constructor (Stream)

Note: This API is now obsolete.

Creates a new instance of the IptcCollection class specifying the file stream to read the iptc metadata from.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)]
public IptcCollection(
    Stream stream
)
<ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)>
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
File to retreive iptc data from.
See Also

Reference

IptcCollection Class
IptcCollection Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection Constructor (String)

Note: This API is now obsolete.

Creates a new instance of the IptcCollection class specifying the file to read the iptc metadata from.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)]
public IptcCollection(
    string fileName
)
<ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)>
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
File to retreive iptc data from.
See Also

Reference

IptcCollection Class
IptcCollection Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection Constructor (Stream, Int32)

Note: This API is now obsolete.

Creates a new instance of the IptcCollection class specifying the file stream and page index (in a multipage TIFF) to read the iptc metadata from.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)]
public IptcCollection(
    Stream stream,
    int frameIndex
)
<ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)>
Public Sub New (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
File to retreive iptc data from.
frameIndex
Type: SystemInt32
The zero based page in a multipage TIFF.
See Also

Reference

IptcCollection Class
IptcCollection Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection Constructor (String, Int32)

Note: This API is now obsolete.

Creates a new instance of the IptcCollection class specifying the file and page index (in a multipage TIFF) to read the iptc metadata from.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)]
public IptcCollection(
    string fileName,
    int frameIndex
)
<ObsoleteAttribute("This constructor is obsolete.  See IptcParser for the replacement.",
    true)>
Public Sub New (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
File to retreive iptc data from.
frameIndex
Type: SystemInt32
The zero based page in a multipage TIFF.
See Also

Reference

IptcCollection Class
IptcCollection Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection Properties

The IptcCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the IptcTag by index in the collection and allows the Iptc tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.Item Property

IptcCollectionItem Property

Returns the IptcTag by index in the collection and allows the Iptc tags to be enumerated.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcTag this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IptcTag
    Get

Parameters

index
Type: SystemInt32
The zero based index in the collection.

Property Value

Type: IptcTag
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection Methods

The IptcCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a new IptcTag to the image.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether [contains] [the specified source].
Public method | CopyTo | Copies items from the collection into an array.
Public method | CreateIptcDataBlock | Generate an IPTC data block.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetTagDescription | Returns a textual description based on an IptcID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index value of an IptcTag.
Public method | Insert | Inserts the specified index.
Public method | LookupTag(Int32, Int32) | Returns an IptcTag based on an IPTC ID and index.
Public method | LookupTag(Int32, Int32, Int32) | Lookups the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified IptcTag from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.Add Method

IptcCollectionAdd Method

Add a new IptcTag to the image.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    IptcTag tag
)
Public Sub Add (
    tag As IptcTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataIptcTag
IptcTag to add.
Remarks
If the tag already exists, the text data will be overwritten.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.Contains Method

IptcCollectionContains Method

Determines whether [contains] [the specified source].

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    IptcTag source
)
Public Function Contains (
    source As IptcTag
) As Boolean

Parameters

source
Type: Atalasoft.Imaging.MetadataIptcTag
The source.

Return Value

Type: Boolean
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.CopyTo Method

IptcCollectionCopyTo Method

Copies items from the collection into an array.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    IptcTag[] tags,
    int index
)
Public Sub CopyTo (
    tags As IptcTag(),
    index As Integer
)

Parameters

tags
Type: Atalasoft.Imaging.MetadataIptcTag
An array of IptcTag object that will hold the collection items.
index
Type: SystemInt32
An index in the array where the data will be copied.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.CreateIptcDataBlock Method

IptcCollectionCreateIptcDataBlock Method

Generate an IPTC data block.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] CreateIptcDataBlock()
Public Function CreateIptcDataBlock As Byte()

Return Value

Type: Byte
The data block generated by this function can be used in IS3AddJPGOutputMarker to add an IPTC data block to a JPG image.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.GetTagDescription Method

IptcCollectionGetTagDescription Method

Returns a textual description based on an IptcID.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string GetTagDescription(
    int id
)
Public Shared Function GetTagDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID of the tag.

Return Value

Type: String
A text description of an IPTC ID.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.IndexOf Method

IptcCollectionIndexOf Method

Returns the index value of an IptcTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    IptcTag tag
)
Public Function IndexOf (
    tag As IptcTag
) As Integer

Parameters

tag
Type: Atalasoft.Imaging.MetadataIptcTag
The IptcTag to search for.

Return Value

Type: Int32
The index of the item or -1 if the item is not in the collection.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.Insert Method

IptcCollectionInsert Method

Inserts the specified index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    IptcTag source
)
Public Sub Insert (
    index As Integer,
    source As IptcTag
)

Parameters

index
Type: SystemInt32
The index.
source
Type: Atalasoft.Imaging.MetadataIptcTag
The source.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.LookupTag Method

IptcCollectionLookupTag Method

Overload List
 | Name | Description
Public method | LookupTag(Int32, Int32) | Returns an IptcTag based on an IPTC ID and index.
Public method | LookupTag(Int32, Int32, Int32) | Lookups the tag.
Top
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcCollection.LookupTag Method (Int32, Int32)

IptcCollectionLookupTag Method (Int32, Int32)

Returns an IptcTag based on an IPTC ID and index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcTag LookupTag(
    int id,
    int index
)
Public Function LookupTag (
    id As Integer,
    index As Integer
) As IptcTag

Parameters

id
Type: SystemInt32
The ID of the tag to look up.
index
Type: SystemInt32
The index of the tag to look up.

Return Value

Type: IptcTag
An IptcTag containing the ID and index specified or null (Nothing in Visual Basic) if a match is not found.
See Also

Reference

IptcCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection.LookupTag Method (Int32, Int32, Int32)

IptcCollectionLookupTag Method (Int32, Int32, Int32)

Lookups the tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcTag LookupTag(
    int section,
    int id,
    int index
)
Public Function LookupTag (
    section As Integer,
    id As Integer,
    index As Integer
) As IptcTag

Parameters

section
Type: SystemInt32
The section.
id
Type: SystemInt32
The identifier.
index
Type: SystemInt32
The index.

Return Value

Type: IptcTag
See Also

Reference

IptcCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


IptcCollection.Remove Method

IptcCollectionRemove Method

Remove a specified IptcTag from the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    IptcTag tag
)
Public Sub Remove (
    tag As IptcTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataIptcTag
The IptcTag to remove.
See Also

Reference

IptcCollection Class
Atalasoft.Imaging.Metadata Namespace


IptcParser Class

Parses IPTC data from JPEG or TIFF images into a collection of IPTC tags.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataIptcParser
Atalasoft.Imaging.Codec.Jpeg2000Jp2IptcParser

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IptcParser
Public Class IptcParser

The IptcParser type exposes the following members.

Constructors
 | Name | Description
Public method | IptcParser | Initializes a new instance of IptcParser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromByteArray | Parses IPTC data from a byte array.
Public method | ParseFromImage(Stream) | Parses IPTC data from a JPEG or TIFF image file stream.
Public method | ParseFromImage(String) | Parses IPTC data from a JPEG or TIFF image file.
Public method | ParseFromImage(Stream, Int32) | Parses IPTC data from a specific frame in a multipage TIFF image file stream.
Public method | ParseFromImage(String, Int32) | Parses IPTC data from a specific frame in a multipage TIFF image file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

The Newspaper Association of America (NAA) and the International Press Telecommunications Council (IPTC) have worked jointly to design a model to store all sorts of data in an image. This metadata is commonly known as IPTC. Adobe Photoshop uses IPTC to store information in images as well as much of the newspaper and press industry. DotImage can read and write IPTC information to a JPEG image and read IPTC information from a TIFF image.

IPTC data can be modified and saved back in a JPEG or TIFF image.

For more information on IPTC and Metadata in general see %iptc.html% and %metadataoverview.html%.

Examples
[New Example] (C#)
Copy
IptcTextParser iptcParser = new IptcTextParser();
IptcTextCollection iptcTags = iptcParser.Parse("myimage.jpg");
[New Example] (Visual Basic)
Copy
Dim iptcParser As IptcTextParser = New IptcTextParser()
Dim iptcTags As IptcTextCollection = iptcParser.Parse("myimage.jpg")
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


IptcParser Constructor

Initializes a new instance of IptcParser.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcParser()
Public Sub New
See Also

Reference

IptcParser Class
Atalasoft.Imaging.Metadata Namespace


IptcParser Methods

The IptcParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromByteArray | Parses IPTC data from a byte array.
Public method | ParseFromImage(Stream) | Parses IPTC data from a JPEG or TIFF image file stream.
Public method | ParseFromImage(String) | Parses IPTC data from a JPEG or TIFF image file.
Public method | ParseFromImage(Stream, Int32) | Parses IPTC data from a specific frame in a multipage TIFF image file stream.
Public method | ParseFromImage(String, Int32) | Parses IPTC data from a specific frame in a multipage TIFF image file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IptcParser Class
Atalasoft.Imaging.Metadata Namespace


IptcParser.ParseFromByteArray Method

IptcParserParseFromByteArray Method

Parses IPTC data from a byte array.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IptcCollection ParseFromByteArray(
    byte[] iptcData
)
Public Overridable Function ParseFromByteArray (
    iptcData As Byte()
) As IptcCollection

Parameters

iptcData
Type: SystemByte
A byte array containing the IPTC data.

Return Value

Type: IptcCollection
An IptcCollection containing the parsed data.
Remarks
This is useful if the image format stores the IPTC in a different location within the file. For instance, IPTC may be stored in the TIFFTAG_RICHTIFFIPTC (ID 33723) instead of the Adobe Photoshop tag.
See Also

Reference

IptcParser Class
Atalasoft.Imaging.Metadata Namespace


IptcParser.ParseFromImage Method

IptcParserParseFromImage Method

Parses IPTC data from a JPEG or TIFF image file or stream.
Overload List
 | Name | Description
Public method | ParseFromImage(Stream) | Parses IPTC data from a JPEG or TIFF image file stream.
Public method | ParseFromImage(String) | Parses IPTC data from a JPEG or TIFF image file.
Public method | ParseFromImage(Stream, Int32) | Parses IPTC data from a specific frame in a multipage TIFF image file stream.
Public method | ParseFromImage(String, Int32) | Parses IPTC data from a specific frame in a multipage TIFF image file.
Top
See Also

Reference

IptcParser Class
Atalasoft.Imaging.Metadata Namespace


IptcParser.ParseFromImage Method (Stream)

IptcParserParseFromImage Method (Stream)

Parses IPTC data from a JPEG or TIFF image file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection ParseFromImage(
    Stream imageStream
)
Public Function ParseFromImage (
    imageStream As Stream
) As IptcCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.

Return Value

Type: IptcCollection
See Also

Reference

IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataIptcParser


IptcParser.ParseFromImage Method (String)

IptcParserParseFromImage Method (String)

Parses IPTC data from a JPEG or TIFF image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection ParseFromImage(
    string imageFile
)
Public Function ParseFromImage (
    imageFile As String
) As IptcCollection

Parameters

imageFile
Type: SystemString
The image file to parse data from.

Return Value

Type: IptcCollection
See Also

Reference

IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataIptcParser


IptcParser.ParseFromImage Method (Stream, Int32)

IptcParserParseFromImage Method (Stream, Int32)

Parses IPTC data from a specific frame in a multipage TIFF image file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IptcCollection ParseFromImage(
    Stream imageStream,
    int frameIndex
)
Public Overridable Function ParseFromImage (
    imageStream As Stream,
    frameIndex As Integer
) As IptcCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.
frameIndex
Type: SystemInt32
The zero based frame index of a multipage TIFF image to load data from.

Return Value

Type: IptcCollection
See Also

Reference

IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataIptcParser


IptcParser.ParseFromImage Method (String, Int32)

IptcParserParseFromImage Method (String, Int32)

Parses IPTC data from a specific frame in a multipage TIFF image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcCollection ParseFromImage(
    string imageFile,
    int frameIndex
)
Public Function ParseFromImage (
    imageFile As String,
    frameIndex As Integer
) As IptcCollection

Parameters

imageFile
Type: SystemString
The image file to parse data from.
frameIndex
Type: SystemInt32
The zero based frame index of a multipage TIFF image to load data from.

Return Value

Type: IptcCollection
See Also

Reference

IptcParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataIptcParser


IptcTag Class

Contains the data of this IPTC tag including ID, index, section, and value.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataIptcTag

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IptcTag
Public Class IptcTag

The IptcTag type exposes the following members.

Constructors
 | Name | Description
Public method | IptcTag | Creates a new instance of ExifTag specifying the id, section, index, and data.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the value of this IptcTag.
Public property | ID | Gets or sets the ID of this IPTC tag.
Public property | Index | Sets or returns the index value for this IPTC tag.
Public property | Section | Gets or sets the section for this IPTC tag. Normally this value is 2.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a text description of the IptcTag. (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality | Compares the specified tags for equality.
Inequality | Compares the specified tags for inequality.
Top
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


IptcTag Constructor

Creates a new instance of ExifTag specifying the id, section, index, and data.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IptcTag(
    int section,
    int id,
    int index,
    string data
)
Public Sub New (
    section As Integer,
    id As Integer,
    index As Integer,
    data As String
)

Parameters

section
Type: SystemInt32
The section for this IPTC tag. Normally 2.
id
Type: SystemInt32
The ID of this IPTC tag.
index
Type: SystemInt32
The index of this IPTC tag.
data
Type: SystemString
The value of this IptcTag.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag Properties

The IptcTag type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the value of this IptcTag.
Public property | ID | Gets or sets the ID of this IPTC tag.
Public property | Index | Sets or returns the index value for this IPTC tag.
Public property | Section | Gets or sets the section for this IPTC tag. Normally this value is 2.
Top
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.Data Property

IptcTagData Property

Gets or sets the value of this IptcTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Data { get; set; }
Public Property Data As String
    Get
    Set

Property Value

Type: String
The value of this IptcTag.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.ID Property

IptcTagID Property

Gets or sets the ID of this IPTC tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set

Property Value

Type: Int32
The ID of this IPTC tag.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.Index Property

IptcTagIndex Property

Sets or returns the index value for this IPTC tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32
The index of this IPTC tag.
Remarks
Each IPTC item can have multiple tags. This specifies the index for this item.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.Section Property

IptcTagSection Property

Gets or sets the section for this IPTC tag. Normally this value is 2.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Section { get; set; }
Public Property Section As Integer
    Get
    Set

Property Value

Type: Int32
The section for this IPTC tag.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag Methods

The IptcTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a text description of the IptcTag. (Overrides ObjectToString.)
Top
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.Equals Method

IptcTagEquals Method

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.GetHashCode Method

IptcTagGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.ToString Method

IptcTagToString Method

Returns a text description of the IptcTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A text description of the IptcTag.
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag Operators

The IptcTag type exposes the following members.

Operators
Name | Description
Equality | Compares the specified tags for equality.
Inequality | Compares the specified tags for inequality.
Top
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.Equality Operator

IptcTagEquality Operator

Compares the specified tags for equality.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    IptcTag tag1,
    IptcTag tag2
)
Public Shared Operator = (
    tag1 As IptcTag,
    tag2 As IptcTag
) As Boolean

Parameters

tag1
Type: Atalasoft.Imaging.MetadataIptcTag
The tag1.
tag2
Type: Atalasoft.Imaging.MetadataIptcTag
The tag2.

Return Value

Type: Boolean
true if the tags are equal, false otherwise
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


IptcTag.Inequality Operator

IptcTagInequality Operator

Compares the specified tags for inequality.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    IptcTag tag1,
    IptcTag tag2
)
Public Shared Operator <> (
    tag1 As IptcTag,
    tag2 As IptcTag
) As Boolean

Parameters

tag1
Type: Atalasoft.Imaging.MetadataIptcTag
The tag1.
tag2
Type: Atalasoft.Imaging.MetadataIptcTag
The tag2.

Return Value

Type: Boolean
true if the tags are not equal, false otherwise
See Also

Reference

IptcTag Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker Class

The JpegMarker is an object that stores information from JPEG images
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataJpegMarker

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegMarker
Public Class JpegMarker

The JpegMarker type exposes the following members.

Constructors
 | Name | Description
Public method | JpegMarker | Creates a new instance of JpegMarker.
Top
Properties
 | Name | Description
Public property | Data | Gets the binary data stored in this marker.
Public property | Length | Obsolete. Gets or sets the length of this marker in bytes.
Public property | Type | Gets or sets the type of JpegMarker.
Top
Methods
 | Name | Description
Public method | Dispose | Obsolete. Call this method to free the JpegMarker data from memory without waiting for the Garbage Collector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
A Jpeg Marker is a data block stored in Jpeg images. Also known as JPEG APPn markers. There are 14 markers that can be stored in JPEG images. See JpegMarkerCollection for retreiving this data from existing JPEG images.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataJpegMarkerCollection


JpegMarker Constructor

Creates a new instance of JpegMarker.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarker(
    JpegMarkerTypes type,
    byte[] data
)
Public Sub New (
    type As JpegMarkerTypes,
    data As Byte()
)

Parameters

type
Type: Atalasoft.Imaging.MetadataJpegMarkerTypes
The type of JpegMarker.
data
Type: SystemByte

The data stored in this marker.

Remarks
Creates a new instance of JpegMarker.
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker Properties

The JpegMarker type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the binary data stored in this marker.
Public property | Length | Obsolete. Gets or sets the length of this marker in bytes.
Public property | Type | Gets or sets the type of JpegMarker.
Top
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker.Data Property

JpegMarkerData Property

Gets the binary data stored in this marker.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Data { get; }
Public ReadOnly Property Data As Byte()
    Get

Property Value

Type: Byte

A pointer to the data stored in this marker.

,The binary data stored in this marker.
Remarks
This data does not contain the first four bytes of marker information, which specifies the data length and marker type. When adding custom data, these four bytes should be removed so the Data property only contains the marker content.
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker.Length Property

JpegMarkerLength Property

Note: This API is now obsolete.

Gets or sets the length of this marker in bytes.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property has been depricated. Use Data.Length instead.")]
public int Length { get; }
<ObsoleteAttribute("This property has been depricated. Use Data.Length instead.")>
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of this marker in bytes.
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker.Type Property

JpegMarkerType Property

Gets or sets the type of JpegMarker.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarkerTypes Type { get; }
Public ReadOnly Property Type As JpegMarkerTypes
    Get

Property Value

Type: JpegMarkerTypes
The type of JpegMarker.
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker Methods

The JpegMarker type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Obsolete. Call this method to free the JpegMarker data from memory without waiting for the Garbage Collector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarker.Dispose Method

JpegMarkerDispose Method

Note: This API is now obsolete.

Call this method to free the JpegMarker data from memory without waiting for the Garbage Collector.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete.")]
public void Dispose()
<ObsoleteAttribute("This method is obsolete.")>
Public Sub Dispose
See Also

Reference

JpegMarker Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Class

Contains a collection of JpegMarkers and methods to access JpegMarker data.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.MetadataJpegMarkerCollection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JpegMarkerCollection : CollectionBase
Public Class JpegMarkerCollection
    Inherits CollectionBase

The JpegMarkerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | JpegMarkerCollection | Creates a new instance of JpegMarkerCollection with an empty collection
Public method | JpegMarkerCollection(Stream) | Creates a new instance of JpegMarkerCollection specifying a stream containing the Jpeg file.
Public method | JpegMarkerCollection(String) | Creates a new instance of JpegMarkerCollection specifying the filename of the image.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows the JpegMarker objects to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | MarkersToSave | Obsolete. Obsolete
Top
Methods
 | Name | Description
Public method | Add | Adds a new JpegMarker to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains(IptcTag) | Obsolete. Determines whether the collection contains the specified marker.
Public method | Contains(JpegMarker) | Determines whether the collection contains the specified marker.
Public method | CopyTo |
Public method | Dispose | Obsolete. Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% and returns the zero-based index of the first occurance within the collection
Public method | Insert | Insert a new %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% into the collection at the specified index.
Public method | LookupMarker | Obsolete. This method is obsolete and will only return the first marker found, please use LookupMarkers instead. Returns a %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% in the collection based on the marker type.
Public method | LookupMarkers | Returns a collection of %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% in the collection based on the marker type.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a specified %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

Metadata such as EXIF, IPTC, and COM Markers are stored in as Jpeg Markers in JPEG files. This class allows Jpeg markers to be accessed and resaved in a new image (both lossy or lossless).

The marker data returned does not contain the first four bytes of actual marker data. These four bytes contain the length of the data and the marker type.

See Also

Reference

Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Constructor

Overload List
 | Name | Description
Public method | JpegMarkerCollection | Creates a new instance of JpegMarkerCollection with an empty collection
Public method | JpegMarkerCollection(Stream) | Creates a new instance of JpegMarkerCollection specifying a stream containing the Jpeg file.
Public method | JpegMarkerCollection(String) | Creates a new instance of JpegMarkerCollection specifying the filename of the image.
Top
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Constructor

Creates a new instance of JpegMarkerCollection with an empty collection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarkerCollection()
Public Sub New
Remarks
Creates a new instance of the JpegMarkerCollection class. ,
See Also

Reference

JpegMarkerCollection Class
JpegMarkerCollection Overload
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Constructor (Stream)

Creates a new instance of JpegMarkerCollection specifying a stream containing the Jpeg file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarkerCollection(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
File to retreive Jpeg markers from.
Remarks
Creates a new instance of the JpegMarkerCollection class specifying the file stream to read the markers from.
See Also

Reference

JpegMarkerCollection Class
JpegMarkerCollection Overload
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Constructor (String)

Creates a new instance of JpegMarkerCollection specifying the filename of the image.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarkerCollection(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
File to retreive Jpeg markers from.
Remarks
Creates a new instance of the JpegMarkerCollection class specifying the file to read the markers from.
See Also

Reference

JpegMarkerCollection Class
JpegMarkerCollection Overload
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Properties

The JpegMarkerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows the JpegMarker objects to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | MarkersToSave | Obsolete. Obsolete
Top
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Item Property

JpegMarkerCollectionItem Property

Allows the JpegMarker objects to be enumerated.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JpegMarker this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As JpegMarker
    Get

Parameters

index
Type: SystemInt32
The zero based index in the collection.

Property Value

Type: JpegMarker
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.MarkersToSave Property

JpegMarkerCollectionMarkersToSave Property

Note: This API is now obsolete.

Obsolete

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("MarkersToSave is obsolete.  Now requires inserting or removing the markers in the collection.",
    true)]
public JpegMarkerTypes MarkersToSave { get; set; }
<ObsoleteAttribute("MarkersToSave is obsolete.  Now requires inserting or removing the markers in the collection.",
    true)>
Public Property MarkersToSave As JpegMarkerTypes
    Get
    Set

Property Value

Type: JpegMarkerTypes
The JpegMarkerTypes bit flags that indicate which markers will be saved.
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection Methods

The JpegMarkerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new JpegMarker to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains(IptcTag) | Obsolete. Determines whether the collection contains the specified marker.
Public method | Contains(JpegMarker) | Determines whether the collection contains the specified marker.
Public method | CopyTo |
Public method | Dispose | Obsolete. Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% and returns the zero-based index of the first occurance within the collection
Public method | Insert | Insert a new %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% into the collection at the specified index.
Public method | LookupMarker | Obsolete. This method is obsolete and will only return the first marker found, please use LookupMarkers instead. Returns a %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% in the collection based on the marker type.
Public method | LookupMarkers | Returns a collection of %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% in the collection based on the marker type.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a specified %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Add Method

JpegMarkerCollectionAdd Method

Adds a new JpegMarker to the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    JpegMarker marker
)
Public Sub Add (
    marker As JpegMarker
)

Parameters

marker
Type: Atalasoft.Imaging.MetadataJpegMarker
The marker to add.
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Contains Method

JpegMarkerCollectionContains Method

Overload List
 | Name | Description
Public method | Contains(IptcTag) | Obsolete. Determines whether the collection contains the specified marker.
Public method | Contains(JpegMarker) | Determines whether the collection contains the specified marker.
Top
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Contains Method (IptcTag)

JpegMarkerCollectionContains Method (IptcTag)

Note: This API is now obsolete.

Determines whether the collection contains the specified marker.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This is an incorrect method and will always return false.")]
public bool Contains(
    IptcTag marker
)
<ObsoleteAttribute("This is an incorrect method and will always return false.")>
Public Function Contains (
    marker As IptcTag
) As Boolean

Parameters

marker
Type: Atalasoft.Imaging.MetadataIptcTag
The marker.

Return Value

Type: Boolean
See Also

Reference

JpegMarkerCollection Class
Contains Overload
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Contains Method (JpegMarker)

JpegMarkerCollectionContains Method (JpegMarker)

Determines whether the collection contains the specified marker.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    JpegMarker marker
)
Public Function Contains (
    marker As JpegMarker
) As Boolean

Parameters

marker
Type: Atalasoft.Imaging.MetadataJpegMarker
The marker.

Return Value

Type: Boolean
See Also

Reference

JpegMarkerCollection Class
Contains Overload
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.CopyTo Method

JpegMarkerCollectionCopyTo Method

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    JpegMarker[] markers,
    int index
)
Public Sub CopyTo (
    markers As JpegMarker(),
    index As Integer
)

Parameters

markers
Type: Atalasoft.Imaging.MetadataJpegMarker
index
Type: SystemInt32
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Dispose Method

JpegMarkerCollectionDispose Method

Note: This API is now obsolete.

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The dispose method is obsolete.", true)]
public void Dispose()
<ObsoleteAttribute("The dispose method is obsolete.", true)>
Public Sub Dispose
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.IndexOf Method

JpegMarkerCollectionIndexOf Method

Searches for the specified %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% and returns the zero-based index of the first occurance within the collection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    JpegMarker marker
)
Public Function IndexOf (
    marker As JpegMarker
) As Integer

Parameters

marker
Type: Atalasoft.Imaging.MetadataJpegMarker

Return Value

Type: Int32
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Insert Method

JpegMarkerCollectionInsert Method

Insert a new %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% into the collection at the specified index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    JpegMarker marker
)
Public Sub Insert (
    index As Integer,
    marker As JpegMarker
)

Parameters

index
Type: SystemInt32
The index in the collection.
marker
Type: Atalasoft.Imaging.MetadataJpegMarker
The marker to insert.
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.LookupMarker Method

JpegMarkerCollectionLookupMarker Method

Note: This API is now obsolete.

This method is obsolete and will only return the first marker found, please use LookupMarkers instead.

Returns a %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% in the collection based on the marker type.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("To ensure you get all markers of this type use LookupMarkers instead.")]
public JpegMarker LookupMarker(
    JpegMarkerTypes type
)
<ObsoleteAttribute("To ensure you get all markers of this type use LookupMarkers instead.")>
Public Function LookupMarker (
    type As JpegMarkerTypes
) As JpegMarker

Parameters

type
Type: Atalasoft.Imaging.MetadataJpegMarkerTypes
The type of marker to lookup.

Return Value

Type: JpegMarker
The JpegMarker or null (Nothing in Visual Basic) if the item is not found.
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.LookupMarkers Method

JpegMarkerCollectionLookupMarkers Method

Returns a collection of %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% in the collection based on the marker type.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Collection<JpegMarker> LookupMarkers(
    JpegMarkerTypes type
)
Public Function LookupMarkers (
    type As JpegMarkerTypes
) As Collection(Of JpegMarker)

Parameters

type
Type: Atalasoft.Imaging.MetadataJpegMarkerTypes
The types of markers to lookup.

Return Value

Type: CollectionJpegMarker
A Collection of markers filtered for the types specified.
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCollection.Remove Method

JpegMarkerCollectionRemove Method

Removes a specified %Atalasoft.dotImage~Atalasoft.Imaging.Metadata.JpegMarker% from the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    JpegMarker marker
)
Public Sub Remove (
    marker As JpegMarker
)

Parameters

marker
Type: Atalasoft.Imaging.MetadataJpegMarker
The marker to remove.
See Also

Reference

JpegMarkerCollection Class
Atalasoft.Imaging.Metadata Namespace


JpegMarkerCopyFlags Enumeration

Flag enumeration used with [M:CopyJpegWithNewMarkers].

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum JpegMarkerCopyFlags
<FlagsAttribute>
Public Enumeration JpegMarkerCopyFlags
Members
Member name | Description
CopyCom | Indicates whether the COM metadata should be copied.
CopyApp | Indicates whether the APP markers should be copied. This will not copy JPEG_APP0.
PlaceAfterSofn | Indicates whether the metadata should be placed after the SOF tag.
CopyApp0 | Indicates whether the JPEG_APP0 marker is copied. Normally this marker should not be copied since it contains image specific information, such as DPI.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


JpegMarkerTypes Enumeration

Defines the types of Jpeg Markers that can be saved as a data chunk inside a Jpeg image.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum JpegMarkerTypes
<FlagsAttribute>
Public Enumeration JpegMarkerTypes
Members
Member name | Description
MarkerApp1 | The APP1 JPEG Marker commonly associated with EXIF data
MarkerApp2 | The APP2 JPEG Marker.
MarkerApp3 | The APP3 JPEG Marker.
MarkerApp4 | The APP4 JPEG Marker.
MarkerApp5 | The APP5 JPEG Marker.
MarkerApp6 | The APP6 JPEG Marker.
MarkerApp7 | The APP7 JPEG Marker.
MarkerApp8 | The APP8 JPEG Marker.
MarkerApp9 | The APP9 JPEG Marker.
MarkerApp10 | The APP10 JPEG Marker.
MarkerApp11 | The APP11 JPEG Marker.
MarkerApp12 | The APP12 JPEG Marker.
MarkerApp13 | The APP13 JPEG Marker commonly associated with IPTC data.
MarkerApp14 | The APP14 JPEG Marker.
AllMarkers | All markers OR'd together.
Remarks
These markers contain binary information such as Exif and Iptc Data.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


PhotoshopResource Class

Contains the data of a Photoshop Resource including ID, Data, and Description.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataPhotoshopResource

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PhotoshopResource
Public Class PhotoshopResource

The PhotoshopResource type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoshopResource | Initializes a new instance of PhotoshopResource.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the data of this resource.
Public property | Description | Gets or sets a textual description of the resource.
Public property | ID | Gets or sets the ID of this resource.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode for this object (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string of: The data if the data is a string OR The description if not null OR The ID as string (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality | Compares two PhotoshopResource objects for equality.
Inequality | Compares two PhotoshopResource objects for inequality.
Top
Remarks
The Data object always contains a byte array.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


PhotoshopResource Constructor

Initializes a new instance of PhotoshopResource.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResource(
    int id,
    Object data,
    string description
)
Public Sub New (
    id As Integer,
    data As Object,
    description As String
)

Parameters

id
Type: SystemInt32
The resource ID.
data
Type: SystemObject
The resource data (typically a string value or byte array).
description
Type: SystemString
A description of the resource (optional).
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource Properties

The PhotoshopResource type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the data of this resource.
Public property | Description | Gets or sets a textual description of the resource.
Public property | ID | Gets or sets the ID of this resource.
Top
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.Data Property

PhotoshopResourceData Property

Gets or sets the data of this resource.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Data { get; set; }
Public Property Data As Object
    Get
    Set

Property Value

Type: Object
The data of this resource.
Remarks
The object is always a byte array.
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataPhotoshopResourceCollection


PhotoshopResource.Description Property

PhotoshopResourceDescription Property

Gets or sets a textual description of the resource.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
A textual description of the resource.
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.ID Property

PhotoshopResourceID Property

Gets or sets the ID of this resource.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set

Property Value

Type: Int32
The ID of this resource.
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource Methods

The PhotoshopResource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode for this object (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string of: The data if the data is a string OR The description if not null OR The ID as string (Overrides ObjectToString.)
Top
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.Equals Method

PhotoshopResourceEquals Method

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.GetHashCode Method

PhotoshopResourceGetHashCode Method

Gets the hashcode for this object

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.ToString Method

PhotoshopResourceToString Method

Returns a string of:

The data if the data is a string

OR

The description if not null

OR

The ID as string

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource Operators

The PhotoshopResource type exposes the following members.

Operators
Name | Description
Equality | Compares two PhotoshopResource objects for equality.
Inequality | Compares two PhotoshopResource objects for inequality.
Top
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.Equality Operator

PhotoshopResourceEquality Operator

Compares two PhotoshopResource objects for equality.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    PhotoshopResource resource1,
    PhotoshopResource resource2
)
Public Shared Operator = (
    resource1 As PhotoshopResource,
    resource2 As PhotoshopResource
) As Boolean

Parameters

resource1
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The resource1.
resource2
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The resource2.

Return Value

Type: Boolean
true if the resources are equal, false otherwise
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResource.Inequality Operator

PhotoshopResourceInequality Operator

Compares two PhotoshopResource objects for inequality.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    PhotoshopResource resource1,
    PhotoshopResource resource2
)
Public Shared Operator <> (
    resource1 As PhotoshopResource,
    resource2 As PhotoshopResource
) As Boolean

Parameters

resource1
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The resource1.
resource2
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The resource2.

Return Value

Type: Boolean
true if the resources are not equal, false otherwise
See Also

Reference

PhotoshopResource Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection Class

Contains a collection of Photoshop resources.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.MetadataPhotoshopResourceCollection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PhotoshopResourceCollection : CollectionBase
Public Class PhotoshopResourceCollection
    Inherits CollectionBase

The PhotoshopResourceCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoshopResourceCollection | Initializes a new instance of PhotoshopResourceCollection.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets an item index of the PhotoshopResourceCollection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified resource.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the given PhotoshopResource is in the collection
Public method | CopyTo | Copies the collection into an Array of PhotoshopResources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero based index of a specified PhotoshopResource if located in the collection.
Public method | Insert | Inserts the resource at the specified index.
Public method | LookupResource | Gets a PhotoshopResource from an ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a specified PhotoshopResource from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
See ParseFromImage of the PhotoshopResourceParser class to populate a PhotoshopResourceCollection with data from an image.
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Photoshop resources


PhotoshopResourceCollection Constructor

Initializes a new instance of PhotoshopResourceCollection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection()
Public Sub New
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection Properties

The PhotoshopResourceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets an item index of the PhotoshopResourceCollection.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.Item Property

PhotoshopResourceCollectionItem Property

Gets an item index of the PhotoshopResourceCollection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResource this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PhotoshopResource
    Get

Parameters

index
Type: SystemInt32
The zero based item index.

Property Value

Type: PhotoshopResource
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection Methods

The PhotoshopResourceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified resource.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the given PhotoshopResource is in the collection
Public method | CopyTo | Copies the collection into an Array of PhotoshopResources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero based index of a specified PhotoshopResource if located in the collection.
Public method | Insert | Inserts the resource at the specified index.
Public method | LookupResource | Gets a PhotoshopResource from an ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes a specified PhotoshopResource from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.Add Method

PhotoshopResourceCollectionAdd Method

Adds the specified resource.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    PhotoshopResource resource
)
Public Sub Add (
    resource As PhotoshopResource
)

Parameters

resource
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The resource.
Exceptions
Exception | Condition
ArgumentNullException | resource;Argument 'resource' cannot be null.
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.Contains Method

PhotoshopResourceCollectionContains Method

Determines whether the given PhotoshopResource is in the collection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PhotoshopResource resource
)
Public Function Contains (
    resource As PhotoshopResource
) As Boolean

Parameters

resource
Type: Atalasoft.Imaging.MetadataPhotoshopResource

Return Value

Type: Boolean
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.CopyTo Method

PhotoshopResourceCollectionCopyTo Method

Copies the collection into an Array of PhotoshopResources.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    PhotoshopResource[] resources,
    int index
)
Public Sub CopyTo (
    resources As PhotoshopResource(),
    index As Integer
)

Parameters

resources
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The array of resources.
index
Type: SystemInt32
the index of the array to start copying into.
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.IndexOf Method

PhotoshopResourceCollectionIndexOf Method

Returns the zero based index of a specified PhotoshopResource if located in the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    PhotoshopResource resource
)
Public Function IndexOf (
    resource As PhotoshopResource
) As Integer

Parameters

resource
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The PhotoshopResource to search for.

Return Value

Type: Int32
Returns -1 if not found, the index in the collection if found.
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.Insert Method

PhotoshopResourceCollectionInsert Method

Inserts the resource at the specified index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    PhotoshopResource resource
)
Public Sub Insert (
    index As Integer,
    resource As PhotoshopResource
)

Parameters

index
Type: SystemInt32
The index.
resource
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The resource.
Exceptions
Exception | Condition
ArgumentNullException | resource;Argument 'resource' cannot be null.
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.LookupResource Method

PhotoshopResourceCollectionLookupResource Method

Gets a PhotoshopResource from an ID.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResource LookupResource(
    int id
)
Public Function LookupResource (
    id As Integer
) As PhotoshopResource

Parameters

id
Type: SystemInt32
The PhotoshopResource ID to look for.

Return Value

Type: PhotoshopResource
A PhotoshopResource that matches the specified ID.
Remarks
Returns null (Nothing in VB) if a resource of the specified ID doesn't exist.
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceCollection.Remove Method

PhotoshopResourceCollectionRemove Method

Removes a specified PhotoshopResource from the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    PhotoshopResource resource
)
Public Sub Remove (
    resource As PhotoshopResource
)

Parameters

resource
Type: Atalasoft.Imaging.MetadataPhotoshopResource
The PhotoshopResource to remove.
See Also

Reference

PhotoshopResourceCollection Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser Class

Parses Photoshop resources from JPEG, TIFF, and PSD images into a collection of PhotoshopResources.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataPhotoshopResourceParser

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PhotoshopResourceParser
Public Class PhotoshopResourceParser

The PhotoshopResourceParser type exposes the following members.

Constructors
 | Name | Description
Public method | PhotoshopResourceParser | Initializes a new instance of PhotoshopResourceParser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage(Stream) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream.
Public method | ParseFromImage(String) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file.
Public method | ParseFromImage(Stream, Int32) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream specifying the frame index.
Public method | ParseFromImage(String, Int32) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file specifying the frame index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The Format Specification for Photoshop Resources is available to purchase from Adobe. This document contains information for each resource ID. The data in each PhotoshopResource is stored as a byte array. The developer must know the format of each ID, available in the specification, to parse to the respective value (string, integer, raw bytes, etc).
Examples
Extract DPI information from a PSD File
See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataPhotoshopResourceCollection


PhotoshopResourceParser Constructor

Initializes a new instance of PhotoshopResourceParser.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceParser()
Public Sub New
See Also

Reference

PhotoshopResourceParser Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser Methods

The PhotoshopResourceParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFromImage(Stream) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream.
Public method | ParseFromImage(String) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file.
Public method | ParseFromImage(Stream, Int32) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream specifying the frame index.
Public method | ParseFromImage(String, Int32) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file specifying the frame index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhotoshopResourceParser Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser.ParseFromImage Method

PhotoshopResourceParserParseFromImage Method

Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file or stream.
Overload List
 | Name | Description
Public method | ParseFromImage(Stream) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream.
Public method | ParseFromImage(String) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file.
Public method | ParseFromImage(Stream, Int32) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream specifying the frame index.
Public method | ParseFromImage(String, Int32) | Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file specifying the frame index.
Top
See Also

Reference

PhotoshopResourceParser Class
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser.ParseFromImage Method (Stream)

PhotoshopResourceParserParseFromImage Method (Stream)

Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection ParseFromImage(
    Stream imageStream
)
Public Function ParseFromImage (
    imageStream As Stream
) As PhotoshopResourceCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.

Return Value

Type: PhotoshopResourceCollection
See Also

Reference

PhotoshopResourceParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser.ParseFromImage Method (String)

PhotoshopResourceParserParseFromImage Method (String)

Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection ParseFromImage(
    string imageFile
)
Public Function ParseFromImage (
    imageFile As String
) As PhotoshopResourceCollection

Parameters

imageFile
Type: SystemString
The image file to parse data from.

Return Value

Type: PhotoshopResourceCollection
See Also

Reference

PhotoshopResourceParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser.ParseFromImage Method (Stream, Int32)

PhotoshopResourceParserParseFromImage Method (Stream, Int32)

Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file stream specifying the frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PhotoshopResourceCollection ParseFromImage(
    Stream imageStream,
    int frameIndex
)
Public Overridable Function ParseFromImage (
    imageStream As Stream,
    frameIndex As Integer
) As PhotoshopResourceCollection

Parameters

imageStream
Type: System.IOStream
The image file stream to parse data from.
frameIndex
Type: SystemInt32
The zero based frame index of a multipage TIFF image to load data from.

Return Value

Type: PhotoshopResourceCollection
See Also

Reference

PhotoshopResourceParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


PhotoshopResourceParser.ParseFromImage Method (String, Int32)

PhotoshopResourceParserParseFromImage Method (String, Int32)

Parses Photoshop Resource data from a JPEG, TIFF, or PSD image file specifying the frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PhotoshopResourceCollection ParseFromImage(
    string imageFile,
    int frameIndex
)
Public Function ParseFromImage (
    imageFile As String,
    frameIndex As Integer
) As PhotoshopResourceCollection

Parameters

imageFile
Type: SystemString
The image file to parse data from.
frameIndex
Type: SystemInt32
The zero based frame index of a multipage TIFF image to load data from.

Return Value

Type: PhotoshopResourceCollection
See Also

Reference

PhotoshopResourceParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


Rational Structure

A fractional value used to represent certain TIFF and EXIF tags.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct Rational
<SerializableAttribute>
Public Structure Rational

The Rational type exposes the following members.

Constructors
 | Name | Description
Public method | Rational | Creates a new instance of Rational.
Top
Properties
 | Name | Description
Public property | Denominator | Gets the denominator of the fraction
 | Empty | Returns an 'Empty' Rational value of 0/1.
Public property | Numerator | Gets the numerator of the fraction.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object, is equal to this instance. (Overrides ValueTypeEquals(Object).)
 | Equals(Rational, Rational) | Equalses the specified rat1.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Parse | Parses a string in the form of numerator/denominator to a Rational value.
Public method | ToString | Returns a string representation of the fraction (numerator/denominator) (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Compares two Rational objects for equality.
Inequality | Compares two Rational objects for inequality.
Top
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


Rational Constructor

Creates a new instance of Rational.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational(
    int numerator,
    int denominator
)
Public Sub New (
    numerator As Integer,
    denominator As Integer
)

Parameters

numerator
Type: SystemInt32
The fraction numerator
denominator
Type: SystemInt32
The fraction denominator
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational Properties

The Rational type exposes the following members.

Properties
 | Name | Description
Public property | Denominator | Gets the denominator of the fraction
 | Empty | Returns an 'Empty' Rational value of 0/1.
Public property | Numerator | Gets the numerator of the fraction.
Top
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Denominator Property

RationalDenominator Property

Gets the denominator of the fraction

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Denominator { get; set; }
Public Property Denominator As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Empty Property

RationalEmpty Property

Returns an 'Empty' Rational value of 0/1.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Rational Empty { get; }
Public Shared ReadOnly Property Empty As Rational
    Get

Property Value

Type: Rational
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Numerator Property

RationalNumerator Property

Gets the numerator of the fraction.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Numerator { get; set; }
Public Property Numerator As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational Methods

The Rational type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object, is equal to this instance. (Overrides ValueTypeEquals(Object).)
 | Equals(Rational, Rational) | Equalses the specified rat1.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Parse | Parses a string in the form of numerator/denominator to a Rational value.
Public method | ToString | Returns a string representation of the fraction (numerator/denominator) (Overrides ValueTypeToString.)
Top
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Equals Method

RationalEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object, is equal to this instance. (Overrides ValueTypeEquals(Object).)
 | Equals(Rational, Rational) | Equalses the specified rat1.
Top
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Equals Method (Object)

RationalEquals Method (Object)

Determines whether the specified Object, is equal to this instance.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

Rational Structure
Equals Overload
Atalasoft.Imaging.Metadata Namespace


Rational.Equals Method (Rational, Rational)

RationalEquals Method (Rational, Rational)

Equalses the specified rat1.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool Equals(
    Rational rat1,
    Rational rat2
)
Public Shared Function Equals (
    rat1 As Rational,
    rat2 As Rational
) As Boolean

Parameters

rat1
Type: Atalasoft.Imaging.MetadataRational
The rat1.
rat2
Type: Atalasoft.Imaging.MetadataRational
The rat2.

Return Value

Type: Boolean
See Also

Reference

Rational Structure
Equals Overload
Atalasoft.Imaging.Metadata Namespace


Rational.GetHashCode Method

RationalGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Parse Method

RationalParse Method

Parses a string in the form of numerator/denominator to a Rational value.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Rational Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Rational

Parameters

s
Type: SystemString
The string to parse

Return Value

Type: Rational
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.ToString Method

RationalToString Method

Returns a string representation of the fraction (numerator/denominator)

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational Operators

The Rational type exposes the following members.

Operators
Name | Description
Equality | Compares two Rational objects for equality.
Inequality | Compares two Rational objects for inequality.
Top
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Equality Operator

RationalEquality Operator

Compares two Rational objects for equality.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    Rational rat1,
    Rational rat2
)
Public Shared Operator = (
    rat1 As Rational,
    rat2 As Rational
) As Boolean

Parameters

rat1
Type: Atalasoft.Imaging.MetadataRational
The rat1.
rat2
Type: Atalasoft.Imaging.MetadataRational
The rat2.

Return Value

Type: Boolean
true if the Rationals are equal, false otherwise
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


Rational.Inequality Operator

RationalInequality Operator

Compares two Rational objects for inequality.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    Rational rat1,
    Rational rat2
)
Public Shared Operator <> (
    rat1 As Rational,
    rat2 As Rational
) As Boolean

Parameters

rat1
Type: Atalasoft.Imaging.MetadataRational
The rat1.
rat2
Type: Atalasoft.Imaging.MetadataRational
The rat2.

Return Value

Type: Boolean
true if the Rationals are not equal, false otherwise
See Also

Reference

Rational Structure
Atalasoft.Imaging.Metadata Namespace


TiffTag Class

Holds the data of a single TIFF Tag.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataTiffTag
Atalasoft.Imaging.MetadataExifTag

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffTag
Public Class TiffTag

The TiffTag type exposes the following members.

Constructors
 | Name | Description
Public method | TiffTag(TiffTagID, Object) | Creates a new instance of TiffTag with the tag ID enumeration and object data automatically determine the data type.
Public method | TiffTag(Int32, Object, TiffTagDataType) | Creates a new instance of TiffTag with the tag ID, object data, and data type.
Public method | TiffTag(TiffTagID, Object, TiffTagDataType) | Creates a new instance of TiffTag with the tag ID, object data, and data type.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the data of a specific TIFF tag.
Public property | ID | Gets the ID of this TIFF tag.
Public property | Type | Gets the TIFF DataType for this TIFF Tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | A text description of the TiffTag. (Overrides ObjectToString.)
Top
Remarks

TIFF Tags are returned when obtaining tags with the TiffDecoder.GetTiffTag method in TiffDecoder, and set with the TiffTag property in the TiffEncoder.

An alternative, and more comprehensive interface for retrieval and editing of TIFF Tags is the TiffFile class.

See Also

Reference

Atalasoft.Imaging.Metadata Namespace
TiffTags Property
GetTiffTag Method
TiffTagCollection Class
TiffFile


TiffTag Constructor

Creates an new instance of TiffTag.
Overload List
 | Name | Description
Public method | TiffTag(TiffTagID, Object) | Creates a new instance of TiffTag with the tag ID enumeration and object data automatically determine the data type.
Public method | TiffTag(Int32, Object, TiffTagDataType) | Creates a new instance of TiffTag with the tag ID, object data, and data type.
Public method | TiffTag(TiffTagID, Object, TiffTagDataType) | Creates a new instance of TiffTag with the tag ID, object data, and data type.
Top
See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTag Constructor (TiffTagID, Object)

Creates a new instance of TiffTag with the tag ID enumeration and object data automatically determine the data type.
Initializes a new instance of the TiffTag class.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTag(
    TiffTagID id,
    Object data
)
Public Sub New (
    id As TiffTagID,
    data As Object
)

Parameters

id
Type: Atalasoft.Imaging.MetadataTiffTagID
The TIFF Tag ID
data
Type: SystemObject
The data of the TIFF Tag
See Also

Reference

TiffTag Class
TiffTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTag Constructor (Int32, Object, TiffTagDataType)

Creates a new instance of TiffTag with the tag ID, object data, and data type.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTag(
    int id,
    Object data,
    TiffTagDataType type
)
Public Sub New (
    id As Integer,
    data As Object,
    type As TiffTagDataType
)

Parameters

id
Type: SystemInt32
The TIFF Tag ID
data
Type: SystemObject
The data of the TIFF Tag
type
Type: Atalasoft.Imaging.MetadataTiffTagDataType
The data type of the TIFF Tag
See Also

Reference

TiffTag Class
TiffTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTag Constructor (TiffTagID, Object, TiffTagDataType)

Creates a new instance of TiffTag with the tag ID, object data, and data type.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTag(
    TiffTagID id,
    Object data,
    TiffTagDataType type
)
Public Sub New (
    id As TiffTagID,
    data As Object,
    type As TiffTagDataType
)

Parameters

id
Type: Atalasoft.Imaging.MetadataTiffTagID
data
Type: SystemObject
type
Type: Atalasoft.Imaging.MetadataTiffTagDataType
See Also

Reference

TiffTag Class
TiffTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTag Properties

The TiffTag type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the data of a specific TIFF tag.
Public property | ID | Gets the ID of this TIFF tag.
Public property | Type | Gets the TIFF DataType for this TIFF Tag.
Top
See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTag.Data Property

TiffTagData Property

Gets or sets the data of a specific TIFF tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Object Data { get; set; }
Public Overridable Property Data As Object
    Get
    Set

Property Value

Type: Object
The data of this TIFF tag.
Exceptions
Exception | Condition
 | Thrown when the conversion from the data passed in to the actual type causes an overflow.
 | Thrown when the an attempt was made to convert the data to the appropriate type, but failed.
 | Thrown when the data passed is not the correct type.
Remarks

TIFF Tag data can is stored in the type which it was read from a file.

The TIFF Tag Data can contain an offset value which is a reference pointer to a location in the TIFF File with the actual image data. In this case the IsReference property is true and the actual data can be obtained by invoking the LoadReferenceTagData(TiffTag) in the TiffDirectory class.

The TIFF Tag Data can be an array of values of the appropriate type. To test if the Data contains an array invoke the GetType().IsArray() method.

See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTag.ID Property

TiffTagID Property

Gets the ID of this TIFF tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32
The ID of this TIFF tag.
See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTag.Type Property

TiffTagType Property

Gets the TIFF DataType for this TIFF Tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTagDataType Type { get; }
Public ReadOnly Property Type As TiffTagDataType
    Get

Property Value

Type: TiffTagDataType
The TIFF DataType for this TIFF Tag.
Remarks
Each TIFF Tag has a specific data type. When the TIFF Tag is created with the TiffTagID enumeration parameter, this value is automatically determined based on the standard TIFF Tag ID.
See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTag Methods

The TiffTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | A text description of the TiffTag. (Overrides ObjectToString.)
Top
See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTag.ToString Method

TiffTagToString Method

A text description of the TiffTag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A text description of the TiffTag object.
See Also

Reference

TiffTag Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Class

Contains a collection of TIFF tags, used tor writing TIFF Tags to an image when saving.

Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.MetadataTiffTagCollection

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TiffTagCollection : CollectionBase
Public Class TiffTagCollection
    Inherits CollectionBase

The TiffTagCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TiffTagCollection | Create a new instance of ExifCollection.
Public method | TiffTagCollection(Stream) | Obsolete. Deprecated
Public method | TiffTagCollection(String) | Obsolete. Deprecated
Public method | TiffTagCollection(Stream, Int32) | Obsolete. Deprecated
Public method | TiffTagCollection(String, Int32) | Obsolete. Deprecated
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the TiffTag by index in the collection and allows the Tiff tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds a new TIFF Tag to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value indicating if a particular TIFF Tag exists in the collection.
Public method | CopyTo | Obsolete. Copies items from the collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSingleTag(TiffTagID, Stream) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file stream.
 | GetSingleTag(TiffTagID, String) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file.
 | GetSingleTag(Int32, Stream, Int32) | Obsolete. Returns a TiffTag from a TIFF image specifying the tag ID, image stream and frame index.
 | GetSingleTag(Int32, String, Int32) | Obsolete. Returns the TIFF tag data from a file.
 | GetSingleTag(TiffTagID, Stream, Int32) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file stream and zero based page index.
 | GetSingleTag(TiffTagID, String, Int32) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file and zero based page index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index value of a TiffTag found in the collection.
Public method | Insert | Insert a TIFF Tag into the collection at the specified index.
Public method | LookupTag(Int32) | Returns a TiffTag based on a TiffID.
Public method | LookupTag(TiffTagID) | Lookups the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified tag from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

All TIFF images contain metadata explaining the size, colordepth, strip size, and other detailed information of the image. A TIFF tag is identified by an ID. DotImage can read this information from a TIFF file as a string.

For more information, see the section on Tiff Tags and the Metadata Overview.

See Also

Reference

Atalasoft.Imaging.Metadata Namespace
Atalasoft.Imaging.MetadataTiffTag
Atalasoft.Imaging.Metadata


TiffTagCollection Constructor

Overload List
 | Name | Description
Public method | TiffTagCollection | Create a new instance of ExifCollection.
Public method | TiffTagCollection(Stream) | Obsolete. Deprecated
Public method | TiffTagCollection(String) | Obsolete. Deprecated
Public method | TiffTagCollection(Stream, Int32) | Obsolete. Deprecated
Public method | TiffTagCollection(String, Int32) | Obsolete. Deprecated
Top
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Constructor

Create a new instance of ExifCollection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTagCollection()
Public Sub New
See Also

Reference

TiffTagCollection Class
TiffTagCollection Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Constructor (Stream)

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)]
public TiffTagCollection(
    Stream fileStream
)
<ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)>
Public Sub New (
    fileStream As Stream
)

Parameters

fileStream
Type: System.IOStream
File to retreive tiff tags from.
See Also

Reference

TiffTagCollection Class
TiffTagCollection Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Constructor (String)

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)]
public TiffTagCollection(
    string fileName
)
<ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)>
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
File to retreive tiff tags from.
See Also

Reference

TiffTagCollection Class
TiffTagCollection Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Constructor (Stream, Int32)

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)]
public TiffTagCollection(
    Stream fileStream,
    int frameIndex
)
<ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)>
Public Sub New (
    fileStream As Stream,
    frameIndex As Integer
)

Parameters

fileStream
Type: System.IOStream
File to retreive tiff tags from.
frameIndex
Type: SystemInt32
The zero based page in a multipage TIFF.
See Also

Reference

TiffTagCollection Class
TiffTagCollection Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Constructor (String, Int32)

Note: This API is now obsolete.

Deprecated

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)]
public TiffTagCollection(
    string fileName,
    int frameIndex
)
<ObsoleteAttribute("This constructor has been deprecated.  Use GetTiffTag in the TiffDecoder class instead.",
    true)>
Public Sub New (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
File to retreive tiff tags from.
frameIndex
Type: SystemInt32
The zero based page in a multipage TIFF.
See Also

Reference

TiffTagCollection Class
TiffTagCollection Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Properties

The TiffTagCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Returns the TiffTag by index in the collection and allows the Tiff tags to be enumerated.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.Item Property

TiffTagCollectionItem Property

Returns the TiffTag by index in the collection and allows the Tiff tags to be enumerated.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTag this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As TiffTag
    Get

Parameters

index
Type: SystemInt32
The zero based index in the collection.

Property Value

Type: TiffTag
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection Methods

The TiffTagCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new TIFF Tag to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns a value indicating if a particular TIFF Tag exists in the collection.
Public method | CopyTo | Obsolete. Copies items from the collection into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSingleTag(TiffTagID, Stream) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file stream.
 | GetSingleTag(TiffTagID, String) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file.
 | GetSingleTag(Int32, Stream, Int32) | Obsolete. Returns a TiffTag from a TIFF image specifying the tag ID, image stream and frame index.
 | GetSingleTag(Int32, String, Int32) | Obsolete. Returns the TIFF tag data from a file.
 | GetSingleTag(TiffTagID, Stream, Int32) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file stream and zero based page index.
 | GetSingleTag(TiffTagID, String, Int32) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file and zero based page index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index value of a TiffTag found in the collection.
Public method | Insert | Insert a TIFF Tag into the collection at the specified index.
Public method | LookupTag(Int32) | Returns a TiffTag based on a TiffID.
Public method | LookupTag(TiffTagID) | Lookups the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Remove a specified tag from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.Add Method

TiffTagCollectionAdd Method

Adds a new TIFF Tag to the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    TiffTag tag
)
Public Sub Add (
    tag As TiffTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTag
The TIFF Tag to add.
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.Contains Method

TiffTagCollectionContains Method

Returns a value indicating if a particular TIFF Tag exists in the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    TiffTag tag
)
Public Function Contains (
    tag As TiffTag
) As Boolean

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTag
The TIFF Tag to check.

Return Value

Type: Boolean
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.CopyTo Method

TiffTagCollectionCopyTo Method

Note: This API is now obsolete.

Copies items from the collection into an array.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")]
public void CopyTo(
    TiffTag[] tags,
    int index
)
<ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")>
Public Sub CopyTo (
    tags As TiffTag(),
    index As Integer
)

Parameters

tags
Type: Atalasoft.Imaging.MetadataTiffTag
An array of TiffTag where the data will be stored.
index
Type: SystemInt32
An index in the array where the data will be stored.
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method

TiffTagCollectionGetSingleTag Method

Overload List
Name | Description
GetSingleTag(TiffTagID, Stream) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file stream.
GetSingleTag(TiffTagID, String) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file.
GetSingleTag(Int32, Stream, Int32) | Obsolete. Returns a TiffTag from a TIFF image specifying the tag ID, image stream and frame index.
GetSingleTag(Int32, String, Int32) | Obsolete. Returns the TIFF tag data from a file.
GetSingleTag(TiffTagID, Stream, Int32) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file stream and zero based page index.
GetSingleTag(TiffTagID, String, Int32) | Obsolete. Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file and zero based page index.
Top
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method (TiffTagID, Stream)

TiffTagCollectionGetSingleTag Method (TiffTagID, Stream)

Note: This API is now obsolete.

Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")]
public static Object GetSingleTag(
    TiffTagID tag,
    Stream source
)
<ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")>
Public Shared Function GetSingleTag (
    tag As TiffTagID,
    source As Stream
) As Object

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTagID
The TIFF Tag ID to retrieve.
source
Type: System.IOStream
The stream containing the encoded TIFF image.

Return Value

Type: Object
See Also

Reference

TiffTagCollection Class
GetSingleTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method (TiffTagID, String)

TiffTagCollectionGetSingleTag Method (TiffTagID, String)

Note: This API is now obsolete.

Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID and file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")]
public static Object GetSingleTag(
    TiffTagID tag,
    string filename
)
<ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")>
Public Shared Function GetSingleTag (
    tag As TiffTagID,
    filename As String
) As Object

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTagID
The TIFF Tag ID to retrieve.
filename
Type: SystemString
The file containing the encoded TIFF image.

Return Value

Type: Object
See Also

Reference

TiffTagCollection Class
GetSingleTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method (Int32, Stream, Int32)

TiffTagCollectionGetSingleTag Method (Int32, Stream, Int32)

Note: This API is now obsolete.

Returns a TiffTag from a TIFF image specifying the tag ID, image stream and frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.",
    true)]
public static Object GetSingleTag(
    int tagID,
    Stream source,
    int frameIndex
)
<ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.",
    true)>
Public Shared Function GetSingleTag (
    tagID As Integer,
    source As Stream,
    frameIndex As Integer
) As Object

Parameters

tagID
Type: SystemInt32
The TIFF tag ID to return.
source
Type: System.IOStream
A stream containing the image data.
frameIndex
Type: SystemInt32
The frame index from a multipage TIFF containing the tag data.

Return Value

Type: Object
A object containing the TIFF tag data.
See Also

Reference

TiffTagCollection Class
GetSingleTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method (Int32, String, Int32)

TiffTagCollectionGetSingleTag Method (Int32, String, Int32)

Note: This API is now obsolete.

Returns the TIFF tag data from a file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been depricated and moved to the GetTiffTag in the TiffDecoder class.")]
public static Object GetSingleTag(
    int tagID,
    string filename,
    int frameIndex
)
<ObsoleteAttribute("GetSingleTag has been depricated and moved to the GetTiffTag in the TiffDecoder class.")>
Public Shared Function GetSingleTag (
    tagID As Integer,
    filename As String,
    frameIndex As Integer
) As Object

Parameters

tagID
Type: SystemInt32
The TIFF Tag ID to retrieve.
filename
Type: SystemString
The filename of the TIFF image.
frameIndex
Type: SystemInt32
The zero based page index of a multipaged TIFF.

Return Value

Type: Object
See Also

Reference

TiffTagCollection Class
GetSingleTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method (TiffTagID, Stream, Int32)

TiffTagCollectionGetSingleTag Method (TiffTagID, Stream, Int32)

Note: This API is now obsolete.

Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file stream and zero based page index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")]
public static Object GetSingleTag(
    TiffTagID tag,
    Stream source,
    int frameIndex
)
<ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")>
Public Shared Function GetSingleTag (
    tag As TiffTagID,
    source As Stream,
    frameIndex As Integer
) As Object

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTagID
The TIFF Tag ID to retrieve.
source
Type: System.IOStream
The stream containing the encoded TIFF image.
frameIndex
Type: SystemInt32
The zero based page index of a multipaged TIFF.

Return Value

Type: Object
See Also

Reference

TiffTagCollection Class
GetSingleTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.GetSingleTag Method (TiffTagID, String, Int32)

TiffTagCollectionGetSingleTag Method (TiffTagID, String, Int32)

Note: This API is now obsolete.

Returns a single TIFF Tag from a TIFF image specifying the TIFF Tag ID, file and zero based page index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")]
public static Object GetSingleTag(
    TiffTagID tag,
    string filename,
    int frameIndex
)
<ObsoleteAttribute("GetSingleTag has been deprecated and moved to the GetTiffTag in the TiffDecoder class.")>
Public Shared Function GetSingleTag (
    tag As TiffTagID,
    filename As String,
    frameIndex As Integer
) As Object

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTagID
The TIFF Tag ID to retrieve.
filename
Type: SystemString
The file containing the encoded TIFF image.
frameIndex
Type: SystemInt32
The zero based page index of a multipaged TIFF.

Return Value

Type: Object
See Also

Reference

TiffTagCollection Class
GetSingleTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.IndexOf Method

TiffTagCollectionIndexOf Method

Returns the index value of a TiffTag found in the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    TiffTag tag
)
Public Function IndexOf (
    tag As TiffTag
) As Integer

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTag
The specific tag to search for.

Return Value

Type: Int32
Returns -1 if the tag was not found.
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.Insert Method

TiffTagCollectionInsert Method

Insert a TIFF Tag into the collection at the specified index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    TiffTag tag
)
Public Sub Insert (
    index As Integer,
    tag As TiffTag
)

Parameters

index
Type: SystemInt32
The index to insert into.
tag
Type: Atalasoft.Imaging.MetadataTiffTag
The tag to insert.
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.LookupTag Method

TiffTagCollectionLookupTag Method

Overload List
 | Name | Description
Public method | LookupTag(Int32) | Returns a TiffTag based on a TiffID.
Public method | LookupTag(TiffTagID) | Lookups the tag.
Top
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.LookupTag Method (Int32)

TiffTagCollectionLookupTag Method (Int32)

Returns a TiffTag based on a TiffID.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTag LookupTag(
    int id
)
Public Function LookupTag (
    id As Integer
) As TiffTag

Parameters

id
Type: SystemInt32

Return Value

Type: TiffTag
See Also

Reference

TiffTagCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.LookupTag Method (TiffTagID)

TiffTagCollectionLookupTag Method (TiffTagID)

Lookups the tag.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TiffTag LookupTag(
    TiffTagID id
)
Public Function LookupTag (
    id As TiffTagID
) As TiffTag

Parameters

id
Type: Atalasoft.Imaging.MetadataTiffTagID
The identifier.

Return Value

Type: TiffTag
See Also

Reference

TiffTagCollection Class
LookupTag Overload
Atalasoft.Imaging.Metadata Namespace


TiffTagCollection.Remove Method

TiffTagCollectionRemove Method

Remove a specified tag from the collection.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    TiffTag tag
)
Public Sub Remove (
    tag As TiffTag
)

Parameters

tag
Type: Atalasoft.Imaging.MetadataTiffTag
The TIFF Tag to remove.
See Also

Reference

TiffTagCollection Class
Atalasoft.Imaging.Metadata Namespace


TiffTagDataType Enumeration

Enumeration of TIFF Tag data types

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TiffTagDataType
Public Enumeration TiffTagDataType
Members
Member name | Description
None | None
Byte | 8-bit unsigned integer
Ascii | 8-bit bytes w/ last byte null
Short | 16-bit unsigned integer
Long | 32-bit unsigned integer
Rational | 64-bit unsigned fraction
SByte | !8-bit signed integer
Undefined | !8-bit untyped data
SShort | !16-bit signed integer
SLong | !32-bit signed integer
SRational | !64-bit signed fraction
Float | !32-bit IEEE floating point
Double | !64-bit IEEE floating point
Ifd | 32-bit unsigned integer (offset)
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


TiffTagID Enumeration

Standard Tiff Tags that can be read from a TIFF file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TiffTagID
Public Enumeration TiffTagID
Members
Member name | Description
NewSubfileType | TIFFTAG_SUBFILETYPE
SubfileType | TIFFTAG_OSUBFILETYPE
ImageWidth | TIFFTAG_IMAGEWIDTH (256) UInt32
ImageLength | TIFFTAG_IMAGELENGTHUInt32 (257) UInt32
BitsPerSample | TIFFTAG_BITSPERSAMPLE (258) UInt16
Compression | TIFFTAG_COMPRESSION (259) UInt16 1 = COMPRESSION_NONE,2 = COMPRESSION_CCITTRLE,3 = COMPRESSION_CCITTFAX3,4 = COMPRESSION_CCITTFAX4,5 = COMPRESSION_LZW,6 = COMPRESSION_OJPEG,7 = COMPRESSION_JPEG,32766 = COMPRESSION_NEXT (NeXT 2-bit RLE),32771 = COMPRESSION_CCITTRLEW (#1 w/ word alignment),32773 = COMPRESSION_PACKBITS (Macintosh RLE),32809 = COMPRESSION_THUNDERSCAN (ThunderScan RLE)
PhotometricInterpretation | TIFFTAG_PHOTOMETRIC (262) UInt16 0 = PHOTOMETRIC_MINISWHITE (min value is white),1 = PHOTOMETRIC_MINISBLACK (min value is black),2 = PHOTOMETRIC_RGB (RGB color model),3 = PHOTOMETRIC_PALETTE (color map indexed),4 = PHOTOMETRIC_MASK ($holdout mask),5 = PHOTOMETRIC_SEPARATED (!color separations),6 = PHOTOMETRIC_YCBCR (!CCIR 601),7 = PHOTOMETRIC_CIELAB (!1976 CIE L*a*b*),8 = PHOTOMETRIC_ICCLAB (ICC L*a*b* [Adobe TIFF Technote 4]),9 = PHOTOMETRIC_ITULAB (ITU L*a*b*),32844 = PHOTOMETRIC_LOGL (CIE Log2(L)),32845 = PHOTOMETRIC_LOGLUV (CIE Log2(L) (u',v'))
Thresholding | TIFFTAG_THRESHHOLDING
CellWidth | TIFFTAG_CELLWIDTH
CellLength | TIFFTAG_CELLLENGTH
FillOrder | TIFFTAG_FILLORDER
DocumentName | TIFFTAG_DOCUMENTNAME (269) String
ImageDescription | TIFFTAG_IMAGEDESCRIPTION (270) String
Make | TIFFTAG_MAKE (271) String
Model | TIFFTAG_MODEL (272) String
StripOffsets | StripOffsets
Orientation | TIFFTAG_ORIENTATION (274) UInt16 1 = ORIENTATION_TOPLEFT,2 = ORIENTATION_TOPRIGHT3 = ORIENTATION_BOTRIGHT,4 = ORIENTATION_BOTLEFT,5 = ORIENTATION_LEFTTOP,6 = ORIENTATION_RIGHTTOP,7 = ORIENTATION_RIGHTBOT,8 = ORIENTATION_LEFTBOT
SamplesPerPixel | TIFFTAG_SAMPLESPERPIXEL
RowsPerStrip | TIFFTAG_ROWSPERSTRIP (The number of rows per strip in the image (not used in tiled images)
StripByteCounts | TIFFTAG_STRIPBYTECOUNTS
MinSampleValue | TIFFTAG_MINSAMPLEVALUE
MaxSampleValue | TIFFTAG_MAXSAMPLEVALUE
XResolution | TIFFTAG_XRESOLUTION (282) Int32
YResolution | TIFFTAG_YRESOLUTION (283) Int32
PlanarConfiguration | How the data of each pixel are stored. TIFFTAG_PLANARCONFIG
PageName | TIFFTAG_PAGENAME (285) String
XPosition | X position of the image. TIFFTAG_XPOSITION
YPosition | Y position of the image. TIFFTAG_YPOSITION
FreeOffsets | TIFFTAG_FREEOFFSETS
FreeByteCounts | TIFFTAG_FREEBYTECOUNTS
GrayResponseUnit | TIFFTAG_GRAYRESPONSEUNIT
GrayResponseCurve | TIFFTAG_GRAYRESPONSECURVE
T4Options | TIFFTAG_GROUP3OPTIONS
T6Options | TIFFTAG_GROUP4OPTIONS
ResolutionUnit | TIFFTAG_RESOLUTIONUNIT (296) UInt16 1 = RESUNIT_NONE,2 = RESUNIT_INCH,3 = RESUNIT_CENTIMETER
PageNumber | Page number of scanned image. TIFFTAG_PAGENUMBER
TransferFunction | TIFFTAG_TRANSFERFUNCTION
Software | TIFFTAG_SOFTWARE (305) String
DateTime | TIFFTAG_DATETIME (306) String
Artist | TIFFTAG_ARTIST (315) String
HostComputer | TIFFTAG_HOSTCOMPUTER (316) String
Predictor | TIFFTAG_PREDICTOR
WhitePoint | TIFFTAG_WHITEPOINT
PrimaryChromaticities | TIFFTAG_PRIMARYCHROMATICITIES
ColorMap | TIFFTAG_COLORMAP
HalftoneHints | TIFFTAG_HALFTONEHINTS
TileWidth | TIFFTAG_TILEWIDTH (322) UInt32
TileLength | TIFFTAG_TILELENGTH (323) UInt32
TileOffsets | TIFFTAG_TILEOFFSETS
TileByteCounts | TIFFTAG_TILEBYTECOUNTS
SubIFD | 330 TIFFTAG_SUBIFD
InkSet | TIFFTAG_INKSET (332) UInt32 1 = INKSET_CMYK (cyan-magenta-yellow-black color),2 = INKSET_MULTIINK (multi-ink or hi-fi color)
InkNames | TIFFTAG_INKNAMES (333) String
NumberOfInks | TIFFTAG_NUMBEROFINKS (334) UInt16
DotRange | TIFFTAG_DOTRANGE (335)
TargetPrinter | TIFFTAG_TARGETPRINTER (337) String
ExtraSamples | TIFFTAG_EXTRASAMPLES (338) 0 = EXTRASAMPLE_UNSPECIFIED (unspecified data),1 = EXTRASAMPLE_ASSOCALPHA (associated alpha data),2 = EXTRASAMPLE_UNASSALPHA (unassociated alpha data)
SampleFormat | TIFFTAG_SAMPLEFORMAT
SMinSampleValue | TIFFTAG_SMINSAMPLEVALUE
SMaxSampleValue | TIFFTAG_SMAXSAMPLEVALUE
TransferRange | TransferRange
JpegTable | TIFFTAG_JPEGTABLES
JpegProc | TIFFTAG_JPEGPROC
JpegInterchangeFormat | JpegInterchangeFormat
JpegInterchangeFormatLength | TIFFTAG_JPEGIFBYTECOUNT
JpegRestartInterval | TIFFTAG_JPEGRESTARTINTERVAL
JpegLosslessPredictors | TIFFTAG_JPEGLOSSLESSPREDICTORS
JpegPointTransforms | TIFFTAG_JPEGPOINTTRANSFORM
JpegQTables | TIFFTAG_JPEGQTABLES
JpegDcTables | TIFFTAG_JPEGDCTABLES
JpegAcTables | TIFFTAG_JPEGACTABLES
YCbCrCoefficients | TIFFTAG_YCBCRCOEFFICIENTS
YCbCrSubSampling | TIFFTAG_YCBCRSUBSAMPLING
YCbCrPositioning | TIFFTAG_YCBCRPOSITIONING
ReferenceBlackWhite | TIFFTAG_REFERENCEBLACKWHITE
StripRowCounts | 559 Defined in the Mixed Raster Content part of RFC 2301, used to replace RowsPerStrip for IFDs with variable-sized strips.
XmpData | TIFFTAG_XMLPACKET (700)
WangAnnotationData | TIFFTAG_ANNOTATIONS (Wang annotations) (32932)
BatteryLevel | 0x828F TIFF/EP: Encodes camera battery level at time of image capture.
CFARepeatPatternDim | 0x828D TIFF/EP and DNG: "For camera raw files from sensors with CFA overlay"
CFAPattern | 0x828E TIFF/EP and DNG: "Indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used"
Copyright | 0x8298 TIFFTAG_COPYRIGHT
ExposureTime | 0x829A ExposureTime (TIFF/EP)
FNumber | 0x829D FNumber (TIFF/EP)
RichTiffIptc | 0x83BB IPTC Data from the RichTIFF specification
Photoshop | 0x8649 (34377) Private tag registered to Adobe for PhotoShop (IPTC data)
ExifIfd | 0x8769 (34665) TIFFTAG_EXIFIFD
IccProfile | 0x8773 (34675) TIFFTAG_ICCPROFILE (TIFF/EP)
ExposureProgram | 0x8822 ExposureProgram (TIFF/EP)
SpectralSensitivity | 0x8824 SpectralSensitivity (TIFF/EP)
GpsIfd | 0x8825 TIFFTAG_GPSIFD (TIFF/EP)
IsoSpeedRatings | IsoSpeedRatings, used by Exif Ifd (31 - 73)
Oecf | OECF: Opto-Electric Conversion Function (OECF) specified in ISO 14524. (TIFF/EP)
Interlace | 0x8829 Interlace - Indicates the field number of multifield images. (TIFF/EP)
TimeZoneOffset | Encodes time zone of camera clock relative to GMT. (TIFF/EP)
SelfTimeMode | 0x882B SelfTimeMode (TIFF/EP)
ExifVersion | ExifVersion (TIFF/EP)
DateTimeOriginal | The date and time when the original image data was generated. (TIFF/EP)
DateTimeDigitized | DateTimeDigitized (TIFF/EP)
CompressedBitsPerPixel | CompressedBitsPerPixel (TIFF/EP)
ShutterSpeedValue | ShutterSpeedValue (TIFF/EP)
ApertureValue | ApertureValue (TIFF/EP)
BrightnessValue | BrightnessValue (TIFF/EP)
ExposureBiasValue | ExposureBiasValue (TIFF/EP)
MaxApertureValue | MaxApertureValue (TIFF/EP)
FlashEnergy | (0x920B) TIFF/EP: energy used by flash during capture, in BCPS
SpatialFrequencyResponse | (0x920C) TIFF/EP: Spatial Frequency Response
FocalPlaneXResolution | (0x920E) TIFF/EP: Focal Plane X-Resolution
FocalPlaneYResolution | (0x920F) TIFF/EP: Focal Plane Y-Resolution
FocalPlaneResolutionUnit | (0x9210) TIFF/EP: Focal Plane Resolution Unit
SubjectLocation | (0x9214) TIFF/EP: Subject Location
ExposureIndex | (0x9215) TIFF/EP: Exposure Index
SensingMethod | (0x9217) TIFF/EP: Sensing Method
EP_StandardID | (0x9216) applicable version of TIFF/EP standard
StoNits | (0x923F) 37439 number of candelas/meter^2 corresponding to a decoded Y value of 1.0
InteroperabilityIfdPointer | 0xA005 InteroperabilityIfdPointer (Exif, Image IFD)
PrintImageMatching | 0xC4A5 maybe PrintImageMatching in Image IFD?
DNGVersion | Encodes the DNG four-tier version number. (DNG, Image IFD)
DNGBackwardVersion | Specifies the oldest version of the Digital Negative specification for which a file is compatible. (DNG IFD-0)
UniqueCameraModel | Defines a unique, non-localized name for the camera model that created the image in the raw file. (DNG IFD-0)
LocalizedCameraModel | Similar to the UniqueCameraModel tag, except the name can be localized for different markets to match the localization of the camera name
CFAPlaneColor | 0xC616
CFALayout | 0xC617
DefaultScale | 0xC61E DefaultScale (DNG)
DefaultCropOrigin | 0xC61F DefaultCropOrigin (DNG)
DefaultCropSize | 0xC620 DefaultCropSize (DNG)
ColorMatrix1 | 0xC621 ColorMatrix1 (DNG)
ColorMatrix2 | 0xC622 ColorMatrix2 (DNG)
CameraCalibration1 | (DNG)
CameraCalibration2 | (DNG)
ReductionMatrix1 | (DNG)
ReductionMatrix2 | (DNG)
AnalogBalance | (DNG)
AsShotNeutral | (DNG)
AsShotWhiteXY | (DNG)
BaselineExposure | (DNG)
BaselineNoise | (DNG)
BaselineSharpness | (DNG)
BayerGreenSplit | (DNG)
LinearResponseLimit | (DNG)
CameraSerialNumber | (DNG)
LensInfo | (DNG)
ChromaBlurRadius | (DNG)
AntiAliasStrength | (DNG)
ShadowScale | (DNG)
DNGPrivateData | (DNG)
MakerNoteSafety | (DNG)
CalibrationIlluminant1 | (DNG)
CalibrationIlluminant2 | (DNG)
BestQualityScale | (DNG)
RawDataUniqueID | (DNG)
AliasLayerMetadata | 0xC660 private tag for Alias Sketchbook Pro
OriginalRawFileName | (DNG)
OriginalRawFileData | (DNG)
ActiveArea | (DNG)
MaskedAreas | (DNG)
AsShotICCProfile | (DNG)
AsShotPreProfileMatrix | (DNG)
CurrentICCProfile | (DNG)
CurrentPreProfileMatrix | (DNG)
ColorimetricReference | (DNG)
CameraCalibrationSignature | (DNG)
ProfileCalibrationSignature | (DNG)
ExtraCameraProfiles | (DNG)
AsShotProfileName | (DNG)
NoiseReductionApplied | (DNG)
ProfileName | (DNG)
ProfileHueSatMapDims | (DNG)
ProfileHueSatMapData1 | (DNG)
ProfileHueSatMapData2 | (DNG)
ProfileToneCurve | (DNG)
ProfileEmbedPolicy | (DNG)
ProfileCopyright | (DNG)
ForwardMatrix1 | (DNG)
ForwardMatrix2 | (DNG)
PreviewApplicationName | (DNG)
PreviewApplicationVersion | (DNG)
PreviewSettingsName | (DNG)
PreviewSettingsDigest | (DNG)
PreviewColorSpace | (DNG)
PreviewDateTime | (DNG)
RawImageDigest | (DNG)
OriginalRawFileDigest | (DNG)
SubTileBlockSize | (DNG)
RowInterleaveFactor | (DNG)
ProfileLookTableDims | (DNG)
ProfileLookTableData | (DNG)
OpcodeList1 | (DNG)
OpcodeList2 | (DNG)
OpcodeList3 | (DNG)
NoiseProfile | (DNG)
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


XmpParser Class

The XmpParser class can extract XMP Binary data from an image, and parse it into XML content.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.MetadataXmpParser

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class XmpParser
Public Class XmpParser

The XmpParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmpParser | Initializes a new instance of XmpParser.
Top
Methods
 | Name | Description
Public method | BytesFromImage(Stream) | Returns a byte array containing XMP data from an image stream.
Public method | BytesFromImage(String) | Returns a byte array containing XMP data from an image file.
Public method | BytesFromImage(Stream, Int32) | Returns a byte array containing XMP data from an image stream specifying the frame index.
Public method | BytesFromImage(String, Int32) | Returns a byte array containing XMP data from an image file specifying the frame index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Raises the [E:Error] event.
Public method | ParseFromImage(Stream) | Returns an XmlDocument containing XMP data from an image file stream.
Public method | ParseFromImage(String) | Returns an XmlDocument containing XMP data from an image file.
Public method | ParseFromImage(Stream, Int32) | Returns an XmlDocument containing XMP data from an image file stream and zero based frame index.
Public method | ParseFromImage(String, Int32) | Returns an XmlDocument containing XMP data from an image file and zero based frame index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CodecError | Occurs when a codec error has been reported.
Top
Remarks

There are two important methods in this class. BytesFromImage(Stream, Int32) returns a byte array of the raw XMP data. It is used in the DotImage Annotations Toolkit, to load XMP annotations data. ParseFromImage(String, Int32) returns an XmlDocument that can be easily parsed using features in the .NET XML namespace.

For more information on XMP including the specification, visit http://www.adobe.com/products/xmp/.

Examples
[New Example] (C#)
Copy
XmpParser xmpParser = new XmpParser();
XmlDocument doc = xmpParser.Parse("document.tif", 1);
[New Example] (Visual Basic)
Copy
Dim xmpParser As XmpParser = New XmpParser()
Dim doc As XmlDocument = xmpParser.Parse("document.tif", 1)
See Also

Reference

Atalasoft.Imaging.Metadata Namespace


XmpParser Constructor

Initializes a new instance of XmpParser.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmpParser()
Public Sub New
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


XmpParser Methods

The XmpParser type exposes the following members.

Methods
 | Name | Description
Public method | BytesFromImage(Stream) | Returns a byte array containing XMP data from an image stream.
Public method | BytesFromImage(String) | Returns a byte array containing XMP data from an image file.
Public method | BytesFromImage(Stream, Int32) | Returns a byte array containing XMP data from an image stream specifying the frame index.
Public method | BytesFromImage(String, Int32) | Returns a byte array containing XMP data from an image file specifying the frame index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | Raises the [E:Error] event.
Public method | ParseFromImage(Stream) | Returns an XmlDocument containing XMP data from an image file stream.
Public method | ParseFromImage(String) | Returns an XmlDocument containing XMP data from an image file.
Public method | ParseFromImage(Stream, Int32) | Returns an XmlDocument containing XMP data from an image file stream and zero based frame index.
Public method | ParseFromImage(String, Int32) | Returns an XmlDocument containing XMP data from an image file and zero based frame index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


XmpParser.BytesFromImage Method

XmpParserBytesFromImage Method

Returns a byte array containing XMP data from an image file or stream.
Overload List
 | Name | Description
Public method | BytesFromImage(Stream) | Returns a byte array containing XMP data from an image stream.
Public method | BytesFromImage(String) | Returns a byte array containing XMP data from an image file.
Public method | BytesFromImage(Stream, Int32) | Returns a byte array containing XMP data from an image stream specifying the frame index.
Public method | BytesFromImage(String, Int32) | Returns a byte array containing XMP data from an image file specifying the frame index.
Top
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


XmpParser.BytesFromImage Method (Stream)

XmpParserBytesFromImage Method (Stream)

Returns a byte array containing XMP data from an image stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] BytesFromImage(
    Stream imageStream
)
Public Function BytesFromImage (
    imageStream As Stream
) As Byte()

Parameters

imageStream
Type: System.IOStream
The image stream to retrieve data from.

Return Value

Type: Byte
See Also

Reference

XmpParser Class
BytesFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.BytesFromImage Method (String)

XmpParserBytesFromImage Method (String)

Returns a byte array containing XMP data from an image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] BytesFromImage(
    string imageFile
)
Public Function BytesFromImage (
    imageFile As String
) As Byte()

Parameters

imageFile
Type: SystemString
The image filename to retreive data from.

Return Value

Type: Byte
See Also

Reference

XmpParser Class
BytesFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.BytesFromImage Method (Stream, Int32)

XmpParserBytesFromImage Method (Stream, Int32)

Returns a byte array containing XMP data from an image stream specifying the frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual byte[] BytesFromImage(
    Stream imageStream,
    int frameIndex
)
Public Overridable Function BytesFromImage (
    imageStream As Stream,
    frameIndex As Integer
) As Byte()

Parameters

imageStream
Type: System.IOStream
The image stream to retrieve data from.
frameIndex
Type: SystemInt32
The zero based frame index of the image to retrieve data from

Return Value

Type: Byte
See Also

Reference

XmpParser Class
BytesFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.BytesFromImage Method (String, Int32)

XmpParserBytesFromImage Method (String, Int32)

Returns a byte array containing XMP data from an image file specifying the frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] BytesFromImage(
    string imageFile,
    int frameIndex
)
Public Function BytesFromImage (
    imageFile As String,
    frameIndex As Integer
) As Byte()

Parameters

imageFile
Type: SystemString
The image filename to retreive data from
frameIndex
Type: SystemInt32
The zero based frame index of the image to retrieve data from

Return Value

Type: Byte
Remarks
Currently supports reading XMP from JPEG, TIFF, and PDF images.
See Also

Reference

XmpParser Class
BytesFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.OnError Method

XmpParserOnError Method

Raises the [E:Error] event.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnError(
    CodecErrorEventArgs e
)
Protected Overridable Sub OnError (
    e As CodecErrorEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.CodecCodecErrorEventArgs
The CodecErrorEventArgs instance containing the event data.
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


XmpParser.ParseFromImage Method

XmpParserParseFromImage Method

Returns an XmlDocument containing XMP data from an image file or stream.
Overload List
 | Name | Description
Public method | ParseFromImage(Stream) | Returns an XmlDocument containing XMP data from an image file stream.
Public method | ParseFromImage(String) | Returns an XmlDocument containing XMP data from an image file.
Public method | ParseFromImage(Stream, Int32) | Returns an XmlDocument containing XMP data from an image file stream and zero based frame index.
Public method | ParseFromImage(String, Int32) | Returns an XmlDocument containing XMP data from an image file and zero based frame index.
Top
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


XmpParser.ParseFromImage Method (Stream)

XmpParserParseFromImage Method (Stream)

Returns an XmlDocument containing XMP data from an image file stream.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IXPathNavigable ParseFromImage(
    Stream imageStream
)
Public Function ParseFromImage (
    imageStream As Stream
) As IXPathNavigable

Parameters

imageStream
Type: System.IOStream
The image file stream containing XMP data.

Return Value

Type: IXPathNavigable
See Also

Reference

XmpParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.ParseFromImage Method (String)

XmpParserParseFromImage Method (String)

Returns an XmlDocument containing XMP data from an image file.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IXPathNavigable ParseFromImage(
    string imageFile
)
Public Function ParseFromImage (
    imageFile As String
) As IXPathNavigable

Parameters

imageFile
Type: SystemString
The image file containing XMP data.

Return Value

Type: IXPathNavigable
See Also

Reference

XmpParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.ParseFromImage Method (Stream, Int32)

XmpParserParseFromImage Method (Stream, Int32)

Returns an XmlDocument containing XMP data from an image file stream and zero based frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IXPathNavigable ParseFromImage(
    Stream imageStream,
    int frameIndex
)
Public Overridable Function ParseFromImage (
    imageStream As Stream,
    frameIndex As Integer
) As IXPathNavigable

Parameters

imageStream
Type: System.IOStream
The image file stream containing XMP data.
frameIndex
Type: SystemInt32
The zero based frame index of a multi-page image.

Return Value

Type: IXPathNavigable
See Also

Reference

XmpParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser.ParseFromImage Method (String, Int32)

XmpParserParseFromImage Method (String, Int32)

Returns an XmlDocument containing XMP data from an image file and zero based frame index.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IXPathNavigable ParseFromImage(
    string imageFile,
    int frameIndex
)
Public Function ParseFromImage (
    imageFile As String,
    frameIndex As Integer
) As IXPathNavigable

Parameters

imageFile
Type: SystemString
The image file containing XMP data.
frameIndex
Type: SystemInt32
The zero based frame index of a multi-page image.

Return Value

Type: IXPathNavigable
A System.Xml.XmlDocument containing XMP information.
See Also

Reference

XmpParser Class
ParseFromImage Overload
Atalasoft.Imaging.Metadata Namespace


XmpParser Events

The XmpParser type exposes the following members.

Events
 | Name | Description
Public event | CodecError | Occurs when a codec error has been reported.
Top
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


XmpParser.CodecError Event

XmpParserCodecError Event

Occurs when a codec error has been reported.

Namespace: Atalasoft.Imaging.Metadata
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CodecErrorEventHandler CodecError
Public Event CodecError As CodecErrorEventHandler

Value

Type: Atalasoft.Imaging.CodecCodecErrorEventHandler
See Also

Reference

XmpParser Class
Atalasoft.Imaging.Metadata Namespace


Atalasoft.Imaging.Text Namespace

Interfaces
 | Interface | Description
Public interface | IGlyphInfo | Represents single glyph information.
Public interface | ITextDocument | Represents document that supports text extraction.
Public interface | ITextFormatDecoder | Represents a codec that is capable of document text extraction.
Public interface | ITextPage | Represents single page text extraction functionality.
Public interface | ITextSegment | Represents single text segment.
Enumerations
 | Enumeration | Description
Public enumeration | PageRotation | Represents possible rotations of a document page for display.
Public enumeration | TextExtractionUnit | Defines the text extraction granularity.


IGlyphInfo Interface

Represents single glyph information.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IGlyphInfo
Public Interface IGlyphInfo

The IGlyphInfo type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the glyph bounds in image coordinates without rotation applied.
Public property | IsGenerated | Gets or sets a value indicating whether this glyph is generated.
Public property | Text | Gets the glyph text.
Top
See Also

Reference

Atalasoft.Imaging.Text Namespace


IGlyphInfo Properties

The IGlyphInfo type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the glyph bounds in image coordinates without rotation applied.
Public property | IsGenerated | Gets or sets a value indicating whether this glyph is generated.
Public property | Text | Gets the glyph text.
Top
See Also

Reference

IGlyphInfo Interface
Atalasoft.Imaging.Text Namespace


IGlyphInfo.Bounds Property

IGlyphInfoBounds Property

Gets the glyph bounds in image coordinates without rotation applied.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
RectangleF Bounds { get; }
ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

IGlyphInfo Interface
Atalasoft.Imaging.Text Namespace


IGlyphInfo.IsGenerated Property

IGlyphInfoIsGenerated Property

Gets or sets a value indicating whether this glyph is generated.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsGenerated { get; }
ReadOnly Property IsGenerated As Boolean
    Get

Property Value

Type: Boolean
Remarks
It's possible the extraction engine adds spaces between individual words or line breaks.
See Also

Reference

IGlyphInfo Interface
Atalasoft.Imaging.Text Namespace


IGlyphInfo.Text Property

IGlyphInfoText Property

Gets the glyph text.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
char Text { get; }
ReadOnly Property Text As Char
    Get

Property Value

Type: Char
See Also

Reference

IGlyphInfo Interface
Atalasoft.Imaging.Text Namespace


ITextDocument Interface

Represents document that supports text extraction.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ITextDocument : IDisposable
Public Interface ITextDocument
    Inherits IDisposable

The ITextDocument type exposes the following members.

Properties
 | Name | Description
Public property | ExtractionGranularity | Gets the extraction granularity provided by this document.
Public property | PageCount | Gets the document page count.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetPage | Gets the ITextPage at the specified index.
Top
See Also

Reference

Atalasoft.Imaging.Text Namespace


ITextDocument Properties

The ITextDocument type exposes the following members.

Properties
 | Name | Description
Public property | ExtractionGranularity | Gets the extraction granularity provided by this document.
Public property | PageCount | Gets the document page count.
Top
See Also

Reference

ITextDocument Interface
Atalasoft.Imaging.Text Namespace


ITextDocument.ExtractionGranularity Property

ITextDocumentExtractionGranularity Property

Gets the extraction granularity provided by this document.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
TextExtractionUnit ExtractionGranularity { get; }
ReadOnly Property ExtractionGranularity As TextExtractionUnit
    Get

Property Value

Type: TextExtractionUnit
See Also

Reference

ITextDocument Interface
Atalasoft.Imaging.Text Namespace


ITextDocument.PageCount Property

ITextDocumentPageCount Property

Gets the document page count.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int PageCount { get; }
ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ITextDocument Interface
Atalasoft.Imaging.Text Namespace


ITextDocument Methods

The ITextDocument type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetPage | Gets the ITextPage at the specified index.
Top
See Also

Reference

ITextDocument Interface
Atalasoft.Imaging.Text Namespace


ITextDocument.GetPage Method

ITextDocumentGetPage Method

Gets the ITextPage at the specified index.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
ITextPage GetPage(
    int index
)
Function GetPage (
    index As Integer
) As ITextPage

Parameters

index
Type: SystemInt32
The page index.

Return Value

Type: ITextPage
ITextPage at the specified index.
See Also

Reference

ITextDocument Interface
Atalasoft.Imaging.Text Namespace


ITextFormatDecoder Interface

Represents a codec that is capable of document text extraction.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ITextFormatDecoder
Public Interface ITextFormatDecoder

The ITextFormatDecoder type exposes the following members.

Methods
 | Name | Description
Public method | GetTextDocument | Creates the text document.
Top
See Also

Reference

Atalasoft.Imaging.Text Namespace


ITextFormatDecoder Methods

The ITextFormatDecoder type exposes the following members.

Methods
 | Name | Description
Public method | GetTextDocument | Creates the text document.
Top
See Also

Reference

ITextFormatDecoder Interface
Atalasoft.Imaging.Text Namespace


ITextFormatDecoder.GetTextDocument Method

ITextFormatDecoderGetTextDocument Method

Creates the text document.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
ITextDocument GetTextDocument(
    Stream stream
)
Function GetTextDocument (
    stream As Stream
) As ITextDocument

Parameters

stream
Type: System.IOStream
The document stream.

Return Value

Type: ITextDocument
ITextDocument that allows text information extraction.
See Also

Reference

ITextFormatDecoder Interface
Atalasoft.Imaging.Text Namespace


ITextPage Interface

Represents single page text extraction functionality.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ITextPage : IDisposable
Public Interface ITextPage
    Inherits IDisposable

The ITextPage type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the page height.
Public property | Resolution | Gets or sets the page resolution.
Public property | Rotate | Gets the page rotation angle.
Public property | SegmentsCount | Gets the text segments count.
Public property | Width | Gets the page width.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetText | Extracts the formatted text for the whole page.
Public method | GetTextSegments | Gets the page text segments with the specified target image resolution.
Top
See Also

Reference

Atalasoft.Imaging.Text Namespace


ITextPage Properties

The ITextPage type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the page height.
Public property | Resolution | Gets or sets the page resolution.
Public property | Rotate | Gets the page rotation angle.
Public property | SegmentsCount | Gets the text segments count.
Public property | Width | Gets the page width.
Top
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.Height Property

ITextPageHeight Property

Gets the page height.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Height { get; }
ReadOnly Property Height As Double
    Get

Property Value

Type: Double
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.Resolution Property

ITextPageResolution Property

Gets or sets the page resolution.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Resolution { get; }
ReadOnly Property Resolution As Double
    Get

Property Value

Type: Double
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.Rotate Property

ITextPageRotate Property

Gets the page rotation angle.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
PageRotation Rotate { get; }
ReadOnly Property Rotate As PageRotation
    Get

Property Value

Type: PageRotation
Remarks
This property is mostly applied to formats that separate rotation representation and physical coordinates. In such case text coordinates on rendered image will differ from returned and Rotate property could be used to transform them.
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.SegmentsCount Property

ITextPageSegmentsCount Property

Gets the text segments count.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int SegmentsCount { get; }
ReadOnly Property SegmentsCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.Width Property

ITextPageWidth Property

Gets the page width.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Width { get; }
ReadOnly Property Width As Double
    Get

Property Value

Type: Double
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage Methods

The ITextPage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetText | Extracts the formatted text for the whole page.
Public method | GetTextSegments | Gets the page text segments with the specified target image resolution.
Top
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.GetText Method

ITextPageGetText Method

Extracts the formatted text for the whole page.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string GetText()
Function GetText As String

Return Value

Type: String
Formatted page text.
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextPage.GetTextSegments Method

ITextPageGetTextSegments Method

Gets the page text segments with the specified target image resolution.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IEnumerable<ITextSegment> GetTextSegments()
Function GetTextSegments As IEnumerable(Of ITextSegment)

Return Value

Type: IEnumerableITextSegment
Extracted text segments.
See Also

Reference

ITextPage Interface
Atalasoft.Imaging.Text Namespace


ITextSegment Interface

Represents single text segment.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ITextSegment
Public Interface ITextSegment

The ITextSegment type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the segment bounding rectangle in image coordinates without rotation applied.
Public property | Glyphs | Gets the individual glyphs information if supported. Returns empty collection otherwise.
Public property | Text | Gets the segment text.
Top
See Also

Reference

Atalasoft.Imaging.Text Namespace


ITextSegment Properties

The ITextSegment type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the segment bounding rectangle in image coordinates without rotation applied.
Public property | Glyphs | Gets the individual glyphs information if supported. Returns empty collection otherwise.
Public property | Text | Gets the segment text.
Top
See Also

Reference

ITextSegment Interface
Atalasoft.Imaging.Text Namespace


ITextSegment.Bounds Property

ITextSegmentBounds Property

Gets the segment bounding rectangle in image coordinates without rotation applied.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
RectangleF Bounds { get; }
ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF
See Also

Reference

ITextSegment Interface
Atalasoft.Imaging.Text Namespace


ITextSegment.Glyphs Property

ITextSegmentGlyphs Property

Gets the individual glyphs information if supported. Returns empty collection otherwise.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IEnumerable<IGlyphInfo> Glyphs { get; }
ReadOnly Property Glyphs As IEnumerable(Of IGlyphInfo)
    Get

Property Value

Type: IEnumerableIGlyphInfo
See Also

Reference

ITextSegment Interface
Atalasoft.Imaging.Text Namespace


ITextSegment.Text Property

ITextSegmentText Property

Gets the segment text.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

ITextSegment Interface
Atalasoft.Imaging.Text Namespace


PageRotation Enumeration

Represents possible rotations of a document page for display.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PageRotation
Public Enumeration PageRotation
Members
Member name | Description
None | The page will not be rotated.
Clockwise90 | The page will be rotated 90 degrees clockwise
Clockwise180 | The page will be rotated 180 degrees clockwise
Clockwise270 | The page will be rotated 270 degrees clockwise
CounterClockwise90 | The page will be rotated 90 degrees counter clockwise (equivalent to Clockwise270)
CounterClockwise180 | The page will be rotated 180 degrees counter clockwise (equivalent to Clockwise180)
CounterClockwise270 | The page will be rotated 270 degrees counter clockwise (equivalent to Clockwise90)
See Also

Reference

Atalasoft.Imaging.Text Namespace


TextExtractionUnit Enumeration

Defines the text extraction granularity.

Namespace: Atalasoft.Imaging.Text
Assembly: Atalasoft.dotImage (in Atalasoft.dotImage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum TextExtractionUnit
<FlagsAttribute>
Public Enumeration TextExtractionUnit
Members
Member name | Description
None | Extraction unit is not specified.
Glyph | Each segment represents individual glyph.
Word | Each segment represents individual world.
Line | Each segment represents one or more words merged together.
See Also

Reference

Atalasoft.Imaging.Text Namespace


Atalasoft.Imaging.WebControls Namespace

Classes
 | Class | Description
Public class | AnnotationDataRequestedEventArgs | Passed to the AnnotationDataRequested event handler so the default file system based annotation data retrieval can be overridden. Setting the Layers property will stop handler from loading the annotation data from the file.
Public class | CallbackBuilder | Summary description for CallbackBuilder.
Public class | CreateSessionIdEventArgs | Passed to the web control's CreateSessionId event handler so that it can override the session id used. Set the SessionId property of the args argument in the event handler.
Public class | CreateUniquePageNameEventArgs | Passed to the web control's CreateUniquePageName event handler so that it can override the page name used. Set the PageName property of the args argument in the event handler.
Public class | DocumentInfoRequestedEventArgs | Passed to the DocumentInfoRequested event handler so the default file system based document retrieval can be overridden. Setting the PageCount property or the PdfDocument property will stop handler from loading all document info from the file.
Public class | DocumentSaveEventArgs | Passed to the DocumentSave event handler so the default file system based save method can be overridden.
Public class | FileUploadedEventArgs | Represents an arguments class for FileUploaded event.
Public class | FileUploadEventArgs | Represents an arguments class for FileUpload event.
Public class | ImageRequestedEventArgs | Passed to the ImageRequested event handler so the default file system based document retrieval can be overridden. Setting the Image property will stop handler from loading the image from the file.
Public class | MouseTool | Encapsulates the mouse tools associated with the left and right buttons of the mouse.
Public class | PageTextRequestedEventArgs | Provides the data for PageTextRequested event.
Public class | PartialPostEventArgs | Partial PostBack event handler
Public class | PdfFormRequestedEventArgs | Passed to the PdfFormRequested event handler so the default file system based PDF form retrieval can be overridden. Setting the PdfDocument property will stop handler from loading all document info from the file.
Public class | RemoteInvokable | This attribute can be applied to a method in a page allowing it to be invoked remotely from client side code.
Public class | RemoteInvokeEventArgs | Specifies arguments used in the RemoteInvoke event in the WebImageViewer control.
Public class | RemoteInvokeHelper | A helper class for remote invocations.
Public class | ResizeImageForZoomEventArgs | Arguments to a ResizeImageForZoomEvent handler
Public class | ResolveDocumentUriEventArgs | Passed to the ResolveDocumentUri event handler so the default file system based save method can be overridden.
Public class | ResolvePageUriEventArgs | Passed to the ResolvePageUri event handler so the default file system based save method can be overridden.
Public class | ResponseSendEventArgs | Represents the arguments for ResponseSending events. Passes as a parameter to ResponseSendEventHandler.
Public class | RubberBand | A control for selecting a rectangular region.
Public class | TextRequestedEventArgs | Provides the data for text data requesting event.
Public class | ThumbnailDropEventArgs | Arguments for the ThumbnailDrop event.
Public class | ThumbnailImageCreatedEventArgs | The arguments for the ThumbnailImageCreated event.
Public class | ThumbnailStyle | Used to set the ThumbStyle property (and Hover, Selected and SelectedHover variants). Encapsulates the visual style of the thumbnail.
Public class | WebDocumentRequestHandler | Web Handler used to handle requests from the WebDocumentViewer
 | WebImageViewer | A scrollable, zoomable viewport for displaying and processing images server-side.
Public class | WebImageViewerStreamTileArgs | StreamTile arguments.
Public class | WebThumbnailViewer | Shows the pages of a multipage image or multiple images from a folder in a scrollable, selectable columnar view.
Public class | WebViewerControl | Defines a base class that can be used for scrolling an image from the browser.
Public class | WebViewerControlDesigner | Summary description for ScrollPortDesigner.
Structures
 | Structure | Description
Protected structure | WebViewerControlClientResource | Stores information on a client resource.
Delegates
 | Delegate | Description
Public delegate | AnnotationDataRequestedEventHandler | A delegate for handling the AnnotationDataRequested event.
Public delegate | CreateSessionIdEventHandler | A delegate for handling the CreateSessionId event.
Public delegate | CreateUniquePageNameEventHandler | A delegate for handling the CreateUniquePageName event.
Public delegate | DocumentInfoRequestedEventHandler | A delegate for handling the DocumentInfoRequested event.
Public delegate | DocumentSaveEventHandler | A delegate for handling the DocumentSaved event.
Public delegate | FileUploadedEventHandler | A delegate for handling FileUploaded event.
Public delegate | FileUploadEventHandler | A delegate for handling FileUpload event.
Public delegate | ImageRequestedEventHandler | A delegate for handling the ImageRequested event.
Public delegate | PartialPostEventHandler | A delegate for the Partial PostBack event.
Public delegate | PdfFormRequestedEventHandler | Event handler delegate for PDF Forms request.
Public delegate | RemoteInvokeEventHandler | A delegate for handling the RemoteInvoke event.
Public delegate | ResizeImageForZoomEventHandler | Signature of handler for a ResizeImageForZoomEvent
Public delegate | ResponseSendEventHandler | A delegate for handling the ResponseSending events.
Public delegate | ThumbnailDropEventHandler | Delegate type for the ThumbnailDrop event.
Public delegate | ThumbnailImageCreatedEventHandler | Delegate type for the AnnotationCreated event.
Public delegate | WebImageViewerStreamTileEventHandler | Fires when a tile is requested and allows the handler to provide it.
Enumerations
 | Enumeration | Description
Public enumeration | AntialiasDisplayMode | Specifies the antialias display mode that can be set to the WebImageViewer controls.
Public enumeration | AutoZoomMode | Specifies the automatic zoom setting of the image displayed in the WebImageViewer control.
Public enumeration | CacheImageFormat | Specifies the type of image to use as browser output for the WebImageViewer controls.
Public enumeration | FlowDirection | Used in FlowDirection to set the ordering of the thumbnails in the viewer.
Public enumeration | ImageDisplayOrder | Used in ImageDisplayOrder to set the order in which to load tiles or ImageDisplayOrder to set the order in which to load the thumbnails.
Public enumeration | Layout | Used in Layout to set the orientation of the thumbnail viewer. It affects the direction that Centered property centers in.
Public enumeration | MouseToolCursor | The mouse tool cursor.
Public enumeration | MouseToolType | Specifies the Mouse Tool Type to use in the ScrollPort control.
Public enumeration | PreCacheMode | Used in PreCacheTiles to set whether or not it should pre-generate static tiles of the image and put them in the image cache. Results in much faster scrolling and better memory usage, but can affect initial load time.
Public enumeration | ReplaceFileExtension | Specifies the a value indicating for which files WDV should set extensions.
Public enumeration | ResolutionScaleMode | The resolution scale mode.
Public enumeration | ResourceType | The resource type.
Public enumeration | ScrollBarVisibility | Specifies how the scroll bars are shown in the ScrollPort and inherited control.
Public enumeration | VisibilityStyle | Controls the Visibility of the RubberBand class when the page loads.
Public enumeration | WebDocumentPageRotation | Web Document page rotation state


AnnotationDataRequestedEventArgs Class

Passed to the AnnotationDataRequested event handler so the default file system based annotation data retrieval can be overridden. Setting the Layers property will stop handler from loading the annotation data from the file.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsAnnotationDataRequestedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationDataRequestedEventArgs : EventArgs
Public Class AnnotationDataRequestedEventArgs
    Inherits EventArgs

The AnnotationDataRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationDataRequestedEventArgs(String, Int32, Int32) | Creates a new AnnotationDataRequestedEventArgs for use with the AnnotationDataRequested event.
Public method | AnnotationDataRequestedEventArgs(String, String, Int32, Int32) | Creates a new AnnotationDataRequestedEventArgs for use with the AnnotationDataRequested event.
Top
Properties
 | Name | Description
Public property | DocumentPath | Gets the document path.
Public property | FilePath | The relative file path that was requested by the client. This can be used in conjunction with the Layers property to use non filesystem based methods of loading annotation data.
Public property | Layers | Gets or sets the root layerdata array of annotation data for this request. Returns null by default. If this property is left null, the handler will attempt to load the layer data from the file path represented in the FilePath property. Setting this property will override the default automatic loading by file path.
Public property | Length | The number of layers that were requested by the client. Returns -1 if all layers were requested.
Public property | Offset | The starting layer index requested.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs Constructor

Overload List
 | Name | Description
Public method | AnnotationDataRequestedEventArgs(String, Int32, Int32) | Creates a new AnnotationDataRequestedEventArgs for use with the AnnotationDataRequested event.
Public method | AnnotationDataRequestedEventArgs(String, String, Int32, Int32) | Creates a new AnnotationDataRequestedEventArgs for use with the AnnotationDataRequested event.
Top
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs Constructor (String, Int32, Int32)

Creates a new AnnotationDataRequestedEventArgs for use with the AnnotationDataRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataRequestedEventArgs(
    string filePath,
    int offset,
    int length
)
Public Sub New (
    filePath As String,
    offset As Integer,
    length As Integer
)

Parameters

filePath
Type: SystemString
Path or name indicating where the annotations are located
offset
Type: SystemInt32
The starting layer index of this request
length
Type: SystemInt32
Number of layers requested
See Also

Reference

AnnotationDataRequestedEventArgs Class
AnnotationDataRequestedEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs Constructor (String, String, Int32, Int32)

Creates a new AnnotationDataRequestedEventArgs for use with the AnnotationDataRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataRequestedEventArgs(
    string filePath,
    string docPath,
    int offset,
    int length
)
Public Sub New (
    filePath As String,
    docPath As String,
    offset As Integer,
    length As Integer
)

Parameters

filePath
Type: SystemString
Path or name indicating where the annotations are located
docPath
Type: SystemString
The document path.
offset
Type: SystemInt32
The starting layer index of this request
length
Type: SystemInt32
Number of layers requested
See Also

Reference

AnnotationDataRequestedEventArgs Class
AnnotationDataRequestedEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs Properties

The AnnotationDataRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DocumentPath | Gets the document path.
Public property | FilePath | The relative file path that was requested by the client. This can be used in conjunction with the Layers property to use non filesystem based methods of loading annotation data.
Public property | Layers | Gets or sets the root layerdata array of annotation data for this request. Returns null by default. If this property is left null, the handler will attempt to load the layer data from the file path represented in the FilePath property. Setting this property will override the default automatic loading by file path.
Public property | Length | The number of layers that were requested by the client. Returns -1 if all layers were requested.
Public property | Offset | The starting layer index requested.
Top
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs.DocumentPath Property

AnnotationDataRequestedEventArgsDocumentPath Property

Gets the document path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentPath { get; }
Public ReadOnly Property DocumentPath As String
    Get

Property Value

Type: String
Remarks
Note that when reloading annotations for pages inserted using JS API FilePath will be empty. Application is responsible for handling such situation when annotations for external page sources are loaded individually.
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs.FilePath Property

AnnotationDataRequestedEventArgsFilePath Property

The relative file path that was requested by the client. This can be used in conjunction with the Layers property to use non filesystem based methods of loading annotation data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs.Layers Property

AnnotationDataRequestedEventArgsLayers Property

Gets or sets the root layerdata array of annotation data for this request. Returns null by default. If this property is left null, the handler will attempt to load the layer data from the file path represented in the FilePath property. Setting this property will override the default automatic loading by file path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerData[] Layers { get; set; }
Public Property Layers As LayerData()
    Get
    Set

Property Value

Type: LayerData
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs.Length Property

AnnotationDataRequestedEventArgsLength Property

The number of layers that were requested by the client. Returns -1 if all layers were requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs.Offset Property

AnnotationDataRequestedEventArgsOffset Property

The starting layer index requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventArgs Methods

The AnnotationDataRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationDataRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


AnnotationDataRequestedEventHandler Delegate

A delegate for handling the AnnotationDataRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationDataRequestedEventHandler(
    Object sender,
    AnnotationDataRequestedEventArgs e
)
Public Delegate Sub AnnotationDataRequestedEventHandler (
    sender As Object,
    e As AnnotationDataRequestedEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired the event
e
Type: Atalasoft.Imaging.WebControlsAnnotationDataRequestedEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


AntialiasDisplayMode Enumeration

Specifies the antialias display mode that can be set to the WebImageViewer controls.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AntialiasDisplayMode
Public Enumeration AntialiasDisplayMode
Members
Member name | Description
None | Do not antialias (fastest performance)
ScaleToGray | Only antialias 1-bit document images for zoom levels less then 1.
ReductionOnly | Antialias all pixel formats when zoom level is less then 1.
Full | Antialias all images for all zoom levels.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


AutoZoomMode Enumeration

Specifies the automatic zoom setting of the image displayed in the WebImageViewer control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AutoZoomMode
Public Enumeration AutoZoomMode
Members
Member name | Description
None | Does not change the zoom of the image based on image size.
BestFit | Fits the image by sizing the width or height to best fit the control.
BestFitShrinkOnly | Fits the image by sizing the width or height to best fit the control.
FitToWidth | Fits the image by sizing the width to fit the control.
FitToHeight | Fits the image by sizing the height to fit the control.
FitToImage | Fits the image by sizing the control to the size of the image. This will change the size of the control, and the control will not revert back to the original size, if another AutoZoomMode is set.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


CacheImageFormat Enumeration

Specifies the type of image to use as browser output for the WebImageViewer controls.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CacheImageFormat
Public Enumeration CacheImageFormat
Members
Member name | Description
Jpeg | JPEG format, good for photos and grayscale images, but with lossy compression effects.
Png | PNG format, great for documents, logos, and photos with no lossy compression artifacts.
Gif | GIF format, good for documents, logos, and graphics with less than 256 colors.
Auto | Uses JPEG for grayscale and color images and PNG for 1-bit document images.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Class

Summary description for CallbackBuilder.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsCallbackBuilder

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CallbackBuilder
Public Class CallbackBuilder

The CallbackBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | CallbackBuilder | Initializes an instance of the CallbackBuilder class.
Public method | CallbackBuilder(String) | Initializes an instance of the CallbackBuilder class using a custom title.
Public method | CallbackBuilder(String, String) | Initializes an instance of the CallbackBuilder class using a custom title and domain.
Top
Properties
 | Name | Description
Public property | IsPartialPost | Gets or sets a value indicating that this is a partial post.
Public property | IsRemoteInvoke | Gets or sets a value indicating that this is a remote invocation.
Top
Methods
 | Name | Description
Public method | AddScriptFile | Appends a script file.
Public method | Append | Appends a block of script.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallbackString | Generates a callback string.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Constructor

Overload List
 | Name | Description
Public method | CallbackBuilder | Initializes an instance of the CallbackBuilder class.
Public method | CallbackBuilder(String) | Initializes an instance of the CallbackBuilder class using a custom title.
Public method | CallbackBuilder(String, String) | Initializes an instance of the CallbackBuilder class using a custom title and domain.
Top
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Constructor

Initializes an instance of the CallbackBuilder class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CallbackBuilder()
Public Sub New
See Also

Reference

CallbackBuilder Class
CallbackBuilder Overload
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Constructor (String)

Initializes an instance of the CallbackBuilder class using a custom title.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CallbackBuilder(
    string title
)
Public Sub New (
    title As String
)

Parameters

title
Type: SystemString
See Also

Reference

CallbackBuilder Class
CallbackBuilder Overload
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Constructor (String, String)

Initializes an instance of the CallbackBuilder class using a custom title and domain.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CallbackBuilder(
    string title,
    string domain
)
Public Sub New (
    title As String,
    domain As String
)

Parameters

title
Type: SystemString
domain
Type: SystemString
See Also

Reference

CallbackBuilder Class
CallbackBuilder Overload
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Properties

The CallbackBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsPartialPost | Gets or sets a value indicating that this is a partial post.
Public property | IsRemoteInvoke | Gets or sets a value indicating that this is a remote invocation.
Top
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder.IsPartialPost Property

CallbackBuilderIsPartialPost Property

Gets or sets a value indicating that this is a partial post.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPartialPost { get; set; }
Public Property IsPartialPost As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder.IsRemoteInvoke Property

CallbackBuilderIsRemoteInvoke Property

Gets or sets a value indicating that this is a remote invocation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRemoteInvoke { get; set; }
Public Property IsRemoteInvoke As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder Methods

The CallbackBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddScriptFile | Appends a script file.
Public method | Append | Appends a block of script.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallbackString | Generates a callback string.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder.AddScriptFile Method

CallbackBuilderAddScriptFile Method

Appends a script file.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddScriptFile(
    string fileName
)
Public Sub AddScriptFile (
    fileName As String
)

Parameters

fileName
Type: SystemString
The name of the script to include.
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder.Append Method

CallbackBuilderAppend Method

Appends a block of script.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Append(
    string scriptBlock
)
Public Sub Append (
    scriptBlock As String
)

Parameters

scriptBlock
Type: SystemString
The script to append.
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CallbackBuilder.GetCallbackString Method

CallbackBuilderGetCallbackString Method

Generates a callback string.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetCallbackString()
Public Function GetCallbackString As String

Return Value

Type: String
The callback.
See Also

Reference

CallbackBuilder Class
Atalasoft.Imaging.WebControls Namespace


CreateSessionIdEventArgs Class

Passed to the web control's CreateSessionId event handler so that it can override the session id used. Set the SessionId property of the args argument in the event handler.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsCreateSessionIdEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CreateSessionIdEventArgs
Public Class CreateSessionIdEventArgs

The CreateSessionIdEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CreateSessionIdEventArgs | Initializes a new instance of the CreateSessionIdEventArgs class
Top
Properties
 | Name | Description
Public property | SessionId | Set this to the Session ID that you want to use to generate names in the cache
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


CreateSessionIdEventArgs Constructor

Initializes a new instance of the CreateSessionIdEventArgs class

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CreateSessionIdEventArgs()
Public Sub New
See Also

Reference

CreateSessionIdEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateSessionIdEventArgs Properties

The CreateSessionIdEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SessionId | Set this to the Session ID that you want to use to generate names in the cache
Top
See Also

Reference

CreateSessionIdEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateSessionIdEventArgs.SessionId Property

CreateSessionIdEventArgsSessionId Property

Set this to the Session ID that you want to use to generate names in the cache

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SessionId { get; set; }
Public Property SessionId As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CreateSessionIdEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateSessionIdEventArgs Methods

The CreateSessionIdEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateSessionIdEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateSessionIdEventHandler Delegate

A delegate for handling the CreateSessionId event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void CreateSessionIdEventHandler(
    Object sender,
    CreateSessionIdEventArgs e
)
Public Delegate Sub CreateSessionIdEventHandler (
    sender As Object,
    e As CreateSessionIdEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired this event.
e
Type: Atalasoft.Imaging.WebControlsCreateSessionIdEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


CreateUniquePageNameEventArgs Class

Passed to the web control's CreateUniquePageName event handler so that it can override the page name used. Set the PageName property of the args argument in the event handler.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsCreateUniquePageNameEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CreateUniquePageNameEventArgs
Public Class CreateUniquePageNameEventArgs

The CreateUniquePageNameEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CreateUniquePageNameEventArgs | Initializes a new instance of the CreateUniquePageNameEventArgs class
Top
Properties
 | Name | Description
Public property | PageName | Set this to the page name that you want to use in the filename generated in the cache.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


CreateUniquePageNameEventArgs Constructor

Initializes a new instance of the CreateUniquePageNameEventArgs class

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CreateUniquePageNameEventArgs()
Public Sub New
See Also

Reference

CreateUniquePageNameEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateUniquePageNameEventArgs Properties

The CreateUniquePageNameEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PageName | Set this to the page name that you want to use in the filename generated in the cache.
Top
See Also

Reference

CreateUniquePageNameEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateUniquePageNameEventArgs.PageName Property

CreateUniquePageNameEventArgsPageName Property

Set this to the page name that you want to use in the filename generated in the cache.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PageName { get; set; }
Public Property PageName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CreateUniquePageNameEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateUniquePageNameEventArgs Methods

The CreateUniquePageNameEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateUniquePageNameEventArgs Class
Atalasoft.Imaging.WebControls Namespace


CreateUniquePageNameEventHandler Delegate

A delegate for handling the CreateUniquePageName event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void CreateUniquePageNameEventHandler(
    Object sender,
    CreateUniquePageNameEventArgs e
)
Public Delegate Sub CreateUniquePageNameEventHandler (
    sender As Object,
    e As CreateUniquePageNameEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired the event
e
Type: Atalasoft.Imaging.WebControlsCreateUniquePageNameEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs Class

Passed to the DocumentInfoRequested event handler so the default file system based document retrieval can be overridden. Setting the PageCount property or the PdfDocument property will stop handler from loading all document info from the file.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsDocumentInfoRequestedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentInfoRequestedEventArgs : EventArgs
Public Class DocumentInfoRequestedEventArgs
    Inherits EventArgs

The DocumentInfoRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentInfoRequestedEventArgs(String) | Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.
Public method | DocumentInfoRequestedEventArgs(String, String, String) | Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.
Top
Properties
 | Name | Description
Public property | AnnotationFilePath | The relative annotation file path that was requested by the client. This can be used in conjunction with the AnnotationLayers property to use non filesystem based methods of loading annotation data.
Public property | AnnotationLayers | Gets or sets the root layerdata array of annotation data for this request. Returns null by default. If this property is left null, the handler will attempt to load the layer data from the file path represented in the FilePath property. Setting this property will override the default automatic loading by file path.
Public property | ColorDepth | Color depth of the requested image. This is used for memory calculations on the client.
Public property | FilePath | The relative file path that was requested by the client. This can be used in conjunction with the PageCount and PageSize properties to use non filesystem based methods of loading document data.
Public property | FormFilePath | The relative forms file path that was requested by the client. This can be used in conjunction with the FormPdfDocument property to use non filesystem based methods of loading form data.
Public property | FormPdfDocument | PDF document to get the forms from. If this is not provided, forms will attempt to load from the PdfDocument property.
Public property | IsVector | Indicates whether this document should allow sending larger images to the client when the zoom is greater than 1. When false, the 1:1 image will be sent, and scaled on the client.
Public property | PageCount | Number of pages in the document. This will be -1 if the info hasn't been loaded yet. Setting this property will stop the handler from loading all document info from the file.
Public property | PageSize | Default page size in pixels. This is set to Size.Empty if the info hasn't been loaded yet. Setting this property is necessary when setting the PageCount property.
Public property | PdfDocument | PDF document to get the document info from. This property is provided to allow a PDF to be loaded only once for loading multiple items. When requested, form data will attempt to load from this property if the FormPdfDocument property is not provided.
Public property | Resolution | Resolution of the image requested.
Public property | ThumbCaptionFormat | Gets or sets the thumbnail captions format.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs Constructor

Overload List
 | Name | Description
Public method | DocumentInfoRequestedEventArgs(String) | Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.
Public method | DocumentInfoRequestedEventArgs(String, String, String) | Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.
Top
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs Constructor (String)

Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentInfoRequestedEventArgs(
    string filePath
)
Public Sub New (
    filePath As String
)

Parameters

filePath
Type: SystemString
File path to use while loading info from the document.
See Also

Reference

DocumentInfoRequestedEventArgs Class
DocumentInfoRequestedEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs Constructor (String, String, String)

Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentInfoRequestedEventArgs(
    string filePath,
    string annoPath,
    string formPath
)
Public Sub New (
    filePath As String,
    annoPath As String,
    formPath As String
)

Parameters

filePath
Type: SystemString
File path to use while loading info from the document.
annoPath
Type: SystemString
File path to use while loading annotation info from the document.
formPath
Type: SystemString
File path to use while loading forms from the document.
See Also

Reference

DocumentInfoRequestedEventArgs Class
DocumentInfoRequestedEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs Properties

The DocumentInfoRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationFilePath | The relative annotation file path that was requested by the client. This can be used in conjunction with the AnnotationLayers property to use non filesystem based methods of loading annotation data.
Public property | AnnotationLayers | Gets or sets the root layerdata array of annotation data for this request. Returns null by default. If this property is left null, the handler will attempt to load the layer data from the file path represented in the FilePath property. Setting this property will override the default automatic loading by file path.
Public property | ColorDepth | Color depth of the requested image. This is used for memory calculations on the client.
Public property | FilePath | The relative file path that was requested by the client. This can be used in conjunction with the PageCount and PageSize properties to use non filesystem based methods of loading document data.
Public property | FormFilePath | The relative forms file path that was requested by the client. This can be used in conjunction with the FormPdfDocument property to use non filesystem based methods of loading form data.
Public property | FormPdfDocument | PDF document to get the forms from. If this is not provided, forms will attempt to load from the PdfDocument property.
Public property | IsVector | Indicates whether this document should allow sending larger images to the client when the zoom is greater than 1. When false, the 1:1 image will be sent, and scaled on the client.
Public property | PageCount | Number of pages in the document. This will be -1 if the info hasn't been loaded yet. Setting this property will stop the handler from loading all document info from the file.
Public property | PageSize | Default page size in pixels. This is set to Size.Empty if the info hasn't been loaded yet. Setting this property is necessary when setting the PageCount property.
Public property | PdfDocument | PDF document to get the document info from. This property is provided to allow a PDF to be loaded only once for loading multiple items. When requested, form data will attempt to load from this property if the FormPdfDocument property is not provided.
Public property | Resolution | Resolution of the image requested.
Public property | ThumbCaptionFormat | Gets or sets the thumbnail captions format.
Top
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.AnnotationFilePath Property

DocumentInfoRequestedEventArgsAnnotationFilePath Property

The relative annotation file path that was requested by the client. This can be used in conjunction with the AnnotationLayers property to use non filesystem based methods of loading annotation data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AnnotationFilePath { get; set; }
Public Property AnnotationFilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.AnnotationLayers Property

DocumentInfoRequestedEventArgsAnnotationLayers Property

Gets or sets the root layerdata array of annotation data for this request. Returns null by default. If this property is left null, the handler will attempt to load the layer data from the file path represented in the FilePath property. Setting this property will override the default automatic loading by file path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerData[] AnnotationLayers { get; set; }
Public Property AnnotationLayers As LayerData()
    Get
    Set

Property Value

Type: LayerData
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.ColorDepth Property

DocumentInfoRequestedEventArgsColorDepth Property

Color depth of the requested image. This is used for memory calculations on the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ColorDepth { get; set; }
Public Property ColorDepth As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.FilePath Property

DocumentInfoRequestedEventArgsFilePath Property

The relative file path that was requested by the client. This can be used in conjunction with the PageCount and PageSize properties to use non filesystem based methods of loading document data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.FormFilePath Property

DocumentInfoRequestedEventArgsFormFilePath Property

The relative forms file path that was requested by the client. This can be used in conjunction with the FormPdfDocument property to use non filesystem based methods of loading form data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FormFilePath { get; set; }
Public Property FormFilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.FormPdfDocument Property

DocumentInfoRequestedEventArgsFormPdfDocument Property

PDF document to get the forms from. If this is not provided, forms will attempt to load from the PdfDocument property.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument FormPdfDocument { get; set; }
Public Property FormPdfDocument As PdfGeneratedDocument
    Get
    Set

Property Value

Type: PdfGeneratedDocument
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.IsVector Property

DocumentInfoRequestedEventArgsIsVector Property

Indicates whether this document should allow sending larger images to the client when the zoom is greater than 1. When false, the 1:1 image will be sent, and scaled on the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVector { get; set; }
Public Property IsVector As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.PageCount Property

DocumentInfoRequestedEventArgsPageCount Property

Number of pages in the document. This will be -1 if the info hasn't been loaded yet. Setting this property will stop the handler from loading all document info from the file.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageCount { get; set; }
Public Property PageCount As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.PageSize Property

DocumentInfoRequestedEventArgsPageSize Property

Default page size in pixels. This is set to Size.Empty if the info hasn't been loaded yet. Setting this property is necessary when setting the PageCount property.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size PageSize { get; set; }
Public Property PageSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.PdfDocument Property

DocumentInfoRequestedEventArgsPdfDocument Property

PDF document to get the document info from. This property is provided to allow a PDF to be loaded only once for loading multiple items. When requested, form data will attempt to load from this property if the FormPdfDocument property is not provided.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument PdfDocument { get; set; }
Public Property PdfDocument As PdfGeneratedDocument
    Get
    Set

Property Value

Type: PdfGeneratedDocument
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.Resolution Property

DocumentInfoRequestedEventArgsResolution Property

Resolution of the image requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; set; }
Public Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs.ThumbCaptionFormat Property

DocumentInfoRequestedEventArgsThumbCaptionFormat Property

Gets or sets the thumbnail captions format.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ThumbCaptionFormat { get; set; }
Public Property ThumbCaptionFormat As String
    Get
    Set

Property Value

Type: String
Remarks
This value is a format string that will be used to generate thumbnail captions. Value could be a format string expecting first argument to be the page index and second is the file name.
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventArgs Methods

The DocumentInfoRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentInfoRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentInfoRequestedEventHandler Delegate

A delegate for handling the DocumentInfoRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void DocumentInfoRequestedEventHandler(
    Object sender,
    DocumentInfoRequestedEventArgs e
)
Public Delegate Sub DocumentInfoRequestedEventHandler (
    sender As Object,
    e As DocumentInfoRequestedEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired the event
e
Type: Atalasoft.Imaging.WebControlsDocumentInfoRequestedEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs Class

Passed to the DocumentSave event handler so the default file system based save method can be overridden.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsDocumentSaveEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentSaveEventArgs : EventArgs
Public Class DocumentSaveEventArgs
    Inherits EventArgs

The DocumentSaveEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSaveEventArgs | Initializes a new instance of the DocumentSaveEventArgs class.
Top
Properties
 | Name | Description
Public property | AnnotationStream | Gets or sets a stream used to override the default file system save while saving the annotations portion of the document. Setting this property will take precedence over using the SaveFolder and FileName properties.
Public property | DocumentStream | Gets or sets a stream used to override the default file system save while saving the image based portion of the document. Setting this property will take precedence over using the SaveFolder and FileName properties.
Public property | DocumentStreamName | Gets or sets a path to stream, where DocumentStream is located. This value will be passed to the client-side and can be used by 'documentsaved' JavaScript event handler.
Public property | FileName | Gets a name of the document being saved.
Public property | ImageSource | Gets an image source where the collection of pages that will be saved is stored. At this point it is possible to use user-defined save.
Public property | Overwrite | Gets or sets a flag indicating whether or not the file should be overwritten if it already exists. Default is .
Public property | Params | Gets an additional document save parameters passed by client side code.
Public property | PreventDefaultSaving | Gets or sets a flag that prevents calling the default save operation into the DocumentStream or by save path SaveFolder FileName.
Public property | SaveFileFormat | Gets or sets a format to save the destination file into.
Public property | SaveFolder | Gets a relative folder path where the file will be saved.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs Constructor

Initializes a new instance of the DocumentSaveEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentSaveEventArgs(
    string saveFolderPath,
    string fileName,
    RandomAccessImageSource imageSource = null,
    IDictionary<string, string> saveParams = null
)
Public Sub New (
    saveFolderPath As String,
    fileName As String,
    Optional imageSource As RandomAccessImageSource = Nothing,
    Optional saveParams As IDictionary(Of String, String) = Nothing
)

Parameters

saveFolderPath
Type: SystemString
Relative folder path where the document will be saved.
fileName
Type: SystemString
File name to use while saving the document.
imageSource (Optional)
Type: Atalasoft.ImagingRandomAccessImageSource
An ImageSource that contains the collection of the pages prepared to be saved.
saveParams (Optional)
Type: System.Collections.GenericIDictionaryString, String
The optional document save parameters.
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs Properties

The DocumentSaveEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationStream | Gets or sets a stream used to override the default file system save while saving the annotations portion of the document. Setting this property will take precedence over using the SaveFolder and FileName properties.
Public property | DocumentStream | Gets or sets a stream used to override the default file system save while saving the image based portion of the document. Setting this property will take precedence over using the SaveFolder and FileName properties.
Public property | DocumentStreamName | Gets or sets a path to stream, where DocumentStream is located. This value will be passed to the client-side and can be used by 'documentsaved' JavaScript event handler.
Public property | FileName | Gets a name of the document being saved.
Public property | ImageSource | Gets an image source where the collection of pages that will be saved is stored. At this point it is possible to use user-defined save.
Public property | Overwrite | Gets or sets a flag indicating whether or not the file should be overwritten if it already exists. Default is .
Public property | Params | Gets an additional document save parameters passed by client side code.
Public property | PreventDefaultSaving | Gets or sets a flag that prevents calling the default save operation into the DocumentStream or by save path SaveFolder FileName.
Public property | SaveFileFormat | Gets or sets a format to save the destination file into.
Public property | SaveFolder | Gets a relative folder path where the file will be saved.
Top
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.AnnotationStream Property

DocumentSaveEventArgsAnnotationStream Property

Gets or sets a stream used to override the default file system save while saving the annotations portion of the document. Setting this property will take precedence over using the SaveFolder and FileName properties.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream AnnotationStream { get; set; }
Public Property AnnotationStream As Stream
    Get
    Set

Property Value

Type: Stream
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.DocumentStream Property

DocumentSaveEventArgsDocumentStream Property

Gets or sets a stream used to override the default file system save while saving the image based portion of the document. Setting this property will take precedence over using the SaveFolder and FileName properties.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream DocumentStream { get; set; }
Public Property DocumentStream As Stream
    Get
    Set

Property Value

Type: Stream
Remarks
When this property is set up, then the DocumentStreamName should be filled so the file name can be handled by the client-side JavaScript code.
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.DocumentStreamName Property

DocumentSaveEventArgsDocumentStreamName Property

Gets or sets a path to stream, where DocumentStream is located. This value will be passed to the client-side and can be used by 'documentsaved' JavaScript event handler.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentStreamName { get; set; }
Public Property DocumentStreamName As String
    Get
    Set

Property Value

Type: String
Remarks
The value of this property ignored, if the DocumentStream is and PreventDefaultSaving is .
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.FileName Property

DocumentSaveEventArgsFileName Property

Gets a name of the document being saved.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.ImageSource Property

DocumentSaveEventArgsImageSource Property

Gets an image source where the collection of pages that will be saved is stored. At this point it is possible to use user-defined save.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomAccessImageSource ImageSource { get; }
Public ReadOnly Property ImageSource As RandomAccessImageSource
    Get

Property Value

Type: RandomAccessImageSource
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.Overwrite Property

DocumentSaveEventArgsOverwrite Property

Gets or sets a flag indicating whether or not the file should be overwritten if it already exists. Default is .

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Overwrite { get; set; }
Public Property Overwrite As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.Params Property

DocumentSaveEventArgsParams Property

Gets an additional document save parameters passed by client side code.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary<string, string> Params { get; }
Public ReadOnly Property Params As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionaryString, String
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.PreventDefaultSaving Property

DocumentSaveEventArgsPreventDefaultSaving Property

Gets or sets a flag that prevents calling the default save operation into the DocumentStream or by save path SaveFolder FileName.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PreventDefaultSaving { get; set; }
Public Property PreventDefaultSaving As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When this property is set up, then the DocumentStreamName should be filled so the file name can be handled by the client-side JavaScript code.
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.SaveFileFormat Property

DocumentSaveEventArgsSaveFileFormat Property

Gets or sets a format to save the destination file into.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SaveFileFormat { get; set; }
Public Property SaveFileFormat As String
    Get
    Set

Property Value

Type: String
Remarks

This value has corresponding config property on a clien-side. If set on a client it can be also overriden here. The possible list of values includes supported file formats: pdf, tiff (or tif), jpeg (or jpg), png, bmp, tga, pcx, psd, tla, wbmp, emf, wmf. These value correspond to the values of ImageType.

This property must have a supported value and cannot be Empty or .

See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs.SaveFolder Property

DocumentSaveEventArgsSaveFolder Property

Gets a relative folder path where the file will be saved.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SaveFolder { get; }
Public ReadOnly Property SaveFolder As String
    Get

Property Value

Type: String
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventArgs Methods

The DocumentSaveEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentSaveEventArgs Class
Atalasoft.Imaging.WebControls Namespace


DocumentSaveEventHandler Delegate

A delegate for handling the DocumentSaved event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void DocumentSaveEventHandler(
    Object sender,
    DocumentSaveEventArgs e
)
Public Delegate Sub DocumentSaveEventHandler (
    sender As Object,
    e As DocumentSaveEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired the event
e
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs Class

Represents an arguments class for FileUploaded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsFileUploadedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FileUploadedEventArgs : EventArgs
Public Class FileUploadedEventArgs
    Inherits EventArgs

The FileUploadedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FileUploadedEventArgs | Initializes a new instance of the FileUploadedEventArgs class.
Top
Properties
 | Name | Description
Public property | DestinationName | Gets or sets a custom name how uploaded file can be identified. This value will be passed to the client-side and can be used by 'fileuploadfinished' JavaScript event handler.
Public property | DestinationStream | Gets a user stream stream where file was saved.
Public property | Error | Gets an upload file exception, if upload was failed.
Public property | FileName | Gets an upload file name.
Public property | MimeType | Gets an upload file MIME-type.
Public property | Params | Gets additional file upload parameters passed by client side code.
Public property | SaveFolder | Gets a relative folder path where file will be uploaded.
Public property | Success | Gets a flag, indicating whether or not upload was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs Constructor

Initializes a new instance of the FileUploadedEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileUploadedEventArgs(
    string uploadFilePath,
    string fileName,
    string mimeType,
    bool success = true,
    Stream userStream = null,
    Exception error = null,
    IDictionary<string, string> uploadParams = null
)
Public Sub New (
    uploadFilePath As String,
    fileName As String,
    mimeType As String,
    Optional success As Boolean = true,
    Optional userStream As Stream = Nothing,
    Optional error As Exception = Nothing,
    Optional uploadParams As IDictionary(Of String, String) = Nothing
)

Parameters

uploadFilePath
Type: SystemString
Relative folder path where the document was saved.
fileName
Type: SystemString
Name of the uploaded file.
mimeType
Type: SystemString
MIME type of the uploaded file.
success (Optional)
Type: SystemBoolean
Flag indicating whether or not operation was successful.
userStream (Optional)
Type: System.IOStream
User stream from the FileUpload event, where file was saved.
error (Optional)
Type: SystemException
Exception that occurred during upload operation.
uploadParams (Optional)
Type: System.Collections.GenericIDictionaryString, String
Optional file upload parameters.
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs Properties

The FileUploadedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DestinationName | Gets or sets a custom name how uploaded file can be identified. This value will be passed to the client-side and can be used by 'fileuploadfinished' JavaScript event handler.
Public property | DestinationStream | Gets a user stream stream where file was saved.
Public property | Error | Gets an upload file exception, if upload was failed.
Public property | FileName | Gets an upload file name.
Public property | MimeType | Gets an upload file MIME-type.
Public property | Params | Gets additional file upload parameters passed by client side code.
Public property | SaveFolder | Gets a relative folder path where file will be uploaded.
Public property | Success | Gets a flag, indicating whether or not upload was successful.
Top
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.DestinationName Property

FileUploadedEventArgsDestinationName Property

Gets or sets a custom name how uploaded file can be identified. This value will be passed to the client-side and can be used by 'fileuploadfinished' JavaScript event handler.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DestinationName { get; set; }
Public Property DestinationName As String
    Get
    Set

Property Value

Type: String
Remarks
If this property is , the path to the uploaded file used instead.
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.DestinationStream Property

FileUploadedEventArgsDestinationStream Property

Gets a user stream stream where file was saved.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream DestinationStream { get; }
Public ReadOnly Property DestinationStream As Stream
    Get

Property Value

Type: Stream
Remarks
If this stream was not set in the FileUpload event, then this property returns .
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.Error Property

FileUploadedEventArgsError Property

Gets an upload file exception, if upload was failed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Exception Error { get; }
Public ReadOnly Property Error As Exception
    Get

Property Value

Type: Exception
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.FileName Property

FileUploadedEventArgsFileName Property

Gets an upload file name.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.MimeType Property

FileUploadedEventArgsMimeType Property

Gets an upload file MIME-type.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MimeType { get; }
Public ReadOnly Property MimeType As String
    Get

Property Value

Type: String
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.Params Property

FileUploadedEventArgsParams Property

Gets additional file upload parameters passed by client side code.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary<string, string> Params { get; }
Public ReadOnly Property Params As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionaryString, String
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.SaveFolder Property

FileUploadedEventArgsSaveFolder Property

Gets a relative folder path where file will be uploaded.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SaveFolder { get; }
Public ReadOnly Property SaveFolder As String
    Get

Property Value

Type: String
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs.Success Property

FileUploadedEventArgsSuccess Property

Gets a flag, indicating whether or not upload was successful.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventArgs Methods

The FileUploadedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileUploadedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadedEventHandler Delegate

A delegate for handling FileUploaded event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void FileUploadedEventHandler(
    Object sender,
    FileUploadedEventArgs e
)
Public Delegate Sub FileUploadedEventHandler (
    sender As Object,
    e As FileUploadedEventArgs
)

Parameters

sender
Type: SystemObject
Object that fired the event.
e
Type: Atalasoft.Imaging.WebControlsFileUploadedEventArgs
Arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs Class

Represents an arguments class for FileUpload event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsFileUploadEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FileUploadEventArgs : EventArgs
Public Class FileUploadEventArgs
    Inherits EventArgs

The FileUploadEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FileUploadEventArgs | Initializes a new instance of the FileUploadEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a flag indicating whether or not file upload should be canceled.
Public property | DestinationStream | Gets or sets a stream where file will be uploaded.
Public property | FileName | Gets an upload file name.
Public property | MimeType | Gets an upload file MIME-type if specified.
Public property | Overwrite | Gets or sets a flag indicating whether or not file should be overwritten if it already exists.
Public property | Params | Gets additional file upload parameters passed by client side code.
Public property | SaveFolder | Gets a relative folder path where file will be uploaded.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs Constructor

Initializes a new instance of the FileUploadEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileUploadEventArgs(
    string uploadFilePath,
    string fileName,
    string mimeType,
    IDictionary<string, string> uploadParams = null
)
Public Sub New (
    uploadFilePath As String,
    fileName As String,
    mimeType As String,
    Optional uploadParams As IDictionary(Of String, String) = Nothing
)

Parameters

uploadFilePath
Type: SystemString
Relative folder path where the document will be upload.
fileName
Type: SystemString
Name of the uploading file.
mimeType
Type: SystemString
MIME type of the uploading file.
uploadParams (Optional)
Type: System.Collections.GenericIDictionaryString, String
Optional file upload parameters.
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs Properties

The FileUploadEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a flag indicating whether or not file upload should be canceled.
Public property | DestinationStream | Gets or sets a stream where file will be uploaded.
Public property | FileName | Gets an upload file name.
Public property | MimeType | Gets an upload file MIME-type if specified.
Public property | Overwrite | Gets or sets a flag indicating whether or not file should be overwritten if it already exists.
Public property | Params | Gets additional file upload parameters passed by client side code.
Public property | SaveFolder | Gets a relative folder path where file will be uploaded.
Top
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.Cancel Property

FileUploadEventArgsCancel Property

Gets or sets a flag indicating whether or not file upload should be canceled.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.DestinationStream Property

FileUploadEventArgsDestinationStream Property

Gets or sets a stream where file will be uploaded.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream DestinationStream { get; set; }
Public Property DestinationStream As Stream
    Get
    Set

Property Value

Type: Stream
Remarks
Setting this property overrides SaveFolder and FileName properties values.
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.FileName Property

FileUploadEventArgsFileName Property

Gets an upload file name.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.MimeType Property

FileUploadEventArgsMimeType Property

Gets an upload file MIME-type if specified.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MimeType { get; }
Public ReadOnly Property MimeType As String
    Get

Property Value

Type: String
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.Overwrite Property

FileUploadEventArgsOverwrite Property

Gets or sets a flag indicating whether or not file should be overwritten if it already exists.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Overwrite { get; set; }
Public Property Overwrite As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
By default this flag has a value.
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.Params Property

FileUploadEventArgsParams Property

Gets additional file upload parameters passed by client side code.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary<string, string> Params { get; }
Public ReadOnly Property Params As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionaryString, String
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs.SaveFolder Property

FileUploadEventArgsSaveFolder Property

Gets a relative folder path where file will be uploaded.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SaveFolder { get; }
Public ReadOnly Property SaveFolder As String
    Get

Property Value

Type: String
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventArgs Methods

The FileUploadEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileUploadEventArgs Class
Atalasoft.Imaging.WebControls Namespace


FileUploadEventHandler Delegate

A delegate for handling FileUpload event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void FileUploadEventHandler(
    Object sender,
    FileUploadEventArgs e
)
Public Delegate Sub FileUploadEventHandler (
    sender As Object,
    e As FileUploadEventArgs
)

Parameters

sender
Type: SystemObject
Object that fired the event.
e
Type: Atalasoft.Imaging.WebControlsFileUploadEventArgs
Arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


FlowDirection Enumeration

Used in FlowDirection to set the ordering of the thumbnails in the viewer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FlowDirection
Public Enumeration FlowDirection
Members
Member name | Description
LeftToRight | Thumbnails start at the upper left, go towards the right, and wrap back to the left.
TopToBottom | Thumbnails start at the upper left, go down and wrap back to the top.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ImageDisplayOrder Enumeration

Used in ImageDisplayOrder to set the order in which to load tiles or ImageDisplayOrder to set the order in which to load the thumbnails.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ImageDisplayOrder
Public Enumeration ImageDisplayOrder
Members
Member name | Description
Sequential | Thumbnails are loaded in the order regardless of whether they are visible. The order is determined by page order in the case of multipage formats or directory order when the thumbnails are separate files loaded from a directory.
VisibleFirst | Visible thumbnails are shown first, but all thumbnails are loaded.
OnDemand | Visible thumbnails are shown first, and the others are loaded on demand.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs Class

Passed to the ImageRequested event handler so the default file system based document retrieval can be overridden. Setting the Image property will stop handler from loading the image from the file.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsImageRequestedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageRequestedEventArgs : EventArgs
Public Class ImageRequestedEventArgs
    Inherits EventArgs

The ImageRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRequestedEventArgs | Creates a new ImageRequestedEventArgs for use with the ImageRequested event.
Top
Properties
 | Name | Description
Public property | AutoScale | Indicates whether the provided image should be scaled by the handler before sending it to the client
Public property | FilePath | The requested file path of the document.
Public property | FrameIndex | The requested frame index of the document.
Public property | Image | The AtalaImage to be sent back to the client. This property will be null before the image is loaded from the document. Setting this property will stop the handler from loading the image from the file.
Public property | Jpeg | Indicates whether this image request should be output in jpeg format
Public property | Params | Stores additional image request parameters passed by client side code.
Public property | Zoom | Indicates what zoom level this image was requested at.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs Constructor

Creates a new ImageRequestedEventArgs for use with the ImageRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageRequestedEventArgs(
    string filePath,
    int frameIndex,
    bool jpeg = false,
    double zoom = 1,
    IDictionary<string, string> imageParams = null
)
Public Sub New (
    filePath As String,
    frameIndex As Integer,
    Optional jpeg As Boolean = false,
    Optional zoom As Double = 1,
    Optional imageParams As IDictionary(Of String, String) = Nothing
)

Parameters

filePath
Type: SystemString
File path to use while loading the image from the document.
frameIndex
Type: SystemInt32
Frame index of the image.
jpeg (Optional)
Type: SystemBoolean
Indicates whether to output this image in jpeg format.
zoom (Optional)
Type: SystemDouble
Indicates what zoom level this image was requested at.
imageParams (Optional)
Type: System.Collections.GenericIDictionaryString, String
The optional image request parameters.
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs Properties

The ImageRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AutoScale | Indicates whether the provided image should be scaled by the handler before sending it to the client
Public property | FilePath | The requested file path of the document.
Public property | FrameIndex | The requested frame index of the document.
Public property | Image | The AtalaImage to be sent back to the client. This property will be null before the image is loaded from the document. Setting this property will stop the handler from loading the image from the file.
Public property | Jpeg | Indicates whether this image request should be output in jpeg format
Public property | Params | Stores additional image request parameters passed by client side code.
Public property | Zoom | Indicates what zoom level this image was requested at.
Top
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.AutoScale Property

ImageRequestedEventArgsAutoScale Property

Indicates whether the provided image should be scaled by the handler before sending it to the client

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoScale { get; set; }
Public Property AutoScale As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.FilePath Property

ImageRequestedEventArgsFilePath Property

The requested file path of the document.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.FrameIndex Property

ImageRequestedEventArgsFrameIndex Property

The requested frame index of the document.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameIndex { get; set; }
Public Property FrameIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.Image Property

ImageRequestedEventArgsImage Property

The AtalaImage to be sent back to the client. This property will be null before the image is loaded from the document. Setting this property will stop the handler from loading the image from the file.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.Jpeg Property

ImageRequestedEventArgsJpeg Property

Indicates whether this image request should be output in jpeg format

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Jpeg { get; set; }
Public Property Jpeg As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.Params Property

ImageRequestedEventArgsParams Property

Stores additional image request parameters passed by client side code.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary<string, string> Params { get; }
Public ReadOnly Property Params As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionaryString, String
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs.Zoom Property

ImageRequestedEventArgsZoom Property

Indicates what zoom level this image was requested at.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; }
Public ReadOnly Property Zoom As Double
    Get

Property Value

Type: Double
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventArgs Methods

The ImageRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ImageRequestedEventHandler Delegate

A delegate for handling the ImageRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ImageRequestedEventHandler(
    Object sender,
    ImageRequestedEventArgs e
)
Public Delegate Sub ImageRequestedEventHandler (
    sender As Object,
    e As ImageRequestedEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired the event
e
Type: Atalasoft.Imaging.WebControlsImageRequestedEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


Layout Enumeration

Used in Layout to set the orientation of the thumbnail viewer. It affects the direction that Centered property centers in.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Layout
Public Enumeration Layout
Members
Member name | Description
Vertical | The WebThumbnailViewer is in a vertical orientation and Centered should center left to right.
Horizontal | The WebThumbnailViewer is in a horizontal orientation and Centered should center top to bottom.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


MouseTool Class

Encapsulates the mouse tools associated with the left and right buttons of the mouse.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
Atalasoft.Imaging.WebControlsMouseTool

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public class MouseTool : Control
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Class MouseTool
    Inherits Control

The MouseTool type exposes the following members.

Constructors
 | Name | Description
Public method | MouseTool | Create a MouseTool with the MouseToolType for the left and right mouse button
Top
Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor used when the mouse is over the viewport.
Public property | CustomCursor | Gets or sets a custom string value to be used for the client side cursor style. Cursor must be set to MouseToolCursor.Custom to use this value.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
Public property | EnableViewState | Gets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Overrides ControlEnableViewState.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | ID | Gets the programmatic identifier assigned to the server control. (Overrides ControlID.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | LeftButton | Gets or sets the behavior of the left mouse button for this MouseTool.
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | RightButton | Gets or sets the behavior of the right mouse button for this MouseTool.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visible | Gets a value that indicates whether a server control is rendered as UI on the page. (Overrides ControlVisible.)
Top
Methods
 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


MouseTool Constructor

Create a MouseTool with the MouseToolType for the left and right mouse button

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseTool(
    MouseToolType left,
    MouseToolType right
)
Public Sub New (
    left As MouseToolType,
    right As MouseToolType
)

Parameters

left
Type: Atalasoft.Imaging.WebControlsMouseToolType
The MouseToolType action to do when the left mouse button is clicked.
right
Type: Atalasoft.Imaging.WebControlsMouseToolType
The MouseToolType action to do when the left mouse button is clicked.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool Properties

The MouseTool type exposes the following members.

Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor used when the mouse is over the viewport.
Public property | CustomCursor | Gets or sets a custom string value to be used for the client side cursor style. Cursor must be set to MouseToolCursor.Custom to use this value.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
Public property | EnableViewState | Gets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Overrides ControlEnableViewState.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | ID | Gets the programmatic identifier assigned to the server control. (Overrides ControlID.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | LeftButton | Gets or sets the behavior of the left mouse button for this MouseTool.
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | RightButton | Gets or sets the behavior of the right mouse button for this MouseTool.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visible | Gets a value that indicates whether a server control is rendered as UI on the page. (Overrides ControlVisible.)
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.Cursor Property

MouseToolCursor Property

Gets or sets the cursor used when the mouse is over the viewport.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseToolCursor Cursor { get; set; }
Public Property Cursor As MouseToolCursor
    Get
    Set

Property Value

Type: MouseToolCursor
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.CustomCursor Property

MouseToolCustomCursor Property

Gets or sets a custom string value to be used for the client side cursor style. Cursor must be set to MouseToolCursor.Custom to use this value.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CustomCursor { get; set; }
Public Property CustomCursor As String
    Get
    Set

Property Value

Type: String
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.EnableViewState Property

MouseToolEnableViewState Property

Gets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get

Return Value

Type: Boolean
true if the server control maintains its view state; otherwise false. The default is true.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.ID Property

MouseToolID Property

Gets the programmatic identifier assigned to the server control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ID { get; }
Public Overrides ReadOnly Property ID As String
    Get

Return Value

Type: String
The programmatic identifier assigned to the control.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.LeftButton Property

MouseToolLeftButton Property

Gets or sets the behavior of the left mouse button for this MouseTool.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseToolType LeftButton { get; set; }
Public Property LeftButton As MouseToolType
    Get
    Set

Property Value

Type: MouseToolType
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.RightButton Property

MouseToolRightButton Property

Gets or sets the behavior of the right mouse button for this MouseTool.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseToolType RightButton { get; set; }
Public Property RightButton As MouseToolType
    Get
    Set

Property Value

Type: MouseToolType
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool.Visible Property

MouseToolVisible Property

Gets a value that indicates whether a server control is rendered as UI on the page.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Visible { get; }
Public Overrides ReadOnly Property Visible As Boolean
    Get

Return Value

Type: Boolean
true if the control is visible on the page; otherwise false.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool Methods

The MouseTool type exposes the following members.

Methods
 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseTool Events

The MouseTool type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.WebControls Namespace


MouseToolCursor Enumeration

The mouse tool cursor.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MouseToolCursor
Public Enumeration MouseToolCursor
Members
Member name | Description
Auto | Auto
Arrow | Arrow cursor
Crosshair | Crosshair cursor.
Grab | Grab cursor.
Hand | Hand cursor.
Move | Move cursor.
ZoomIn | Zoom in cursor.
ZoomOut | Zoom out cursor.
Custom | Custom cursor.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


MouseToolType Enumeration

Specifies the Mouse Tool Type to use in the ScrollPort control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MouseToolType
Public Enumeration MouseToolType
Members
Member name | Description
None | Specify no special mouse behavior.
Center | Clicking the mouse will center the area clicked.
Selection | Mouse will be set to crosshairs and can be used to drag and modify a Selection rectangle onto the image.
ZoomIn | Clicking will center, then zoom in.
ZoomOut | Clicking will center, then zoom out.
ZoomArea | Zoom in on a specified area defined by dragging a rectangle onto the image.
Pan | Click and drag will scroll the image in the direction of the drag.
PassThrough | Posts back a click to the page on the server.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


PageTextRequestedEventArgs Class

Provides the data for PageTextRequested event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsTextRequestedEventArgs
Atalasoft.Imaging.WebControlsPageTextRequestedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageTextRequestedEventArgs : TextRequestedEventArgs
Public Class PageTextRequestedEventArgs
    Inherits TextRequestedEventArgs

The PageTextRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PageTextRequestedEventArgs | Initializes a new instance of the PageTextRequestedEventArgs class.
Top
Properties
 | Name | Description
Public property | FilePath | Gets or sets the text resource identifier that was requested by the client. (Inherited from TextRequestedEventArgs.)
Public property | Index | Gets or sets the index of the requested page.
Public property | JsonData | Gets or sets the pre-generated json data. (Inherited from TextRequestedEventArgs.)
Public property | Page | Gets or sets the page text data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


PageTextRequestedEventArgs Constructor

Initializes a new instance of the PageTextRequestedEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageTextRequestedEventArgs(
    string filePath,
    int index
)
Public Sub New (
    filePath As String,
    index As Integer
)

Parameters

filePath
Type: SystemString
The text data file path that was requested by the client.
index
Type: SystemInt32
The requested page index.
See Also

Reference

PageTextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PageTextRequestedEventArgs Properties

The PageTextRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets or sets the text resource identifier that was requested by the client. (Inherited from TextRequestedEventArgs.)
Public property | Index | Gets or sets the index of the requested page.
Public property | JsonData | Gets or sets the pre-generated json data. (Inherited from TextRequestedEventArgs.)
Public property | Page | Gets or sets the page text data.
Top
See Also

Reference

PageTextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PageTextRequestedEventArgs.Index Property

PageTextRequestedEventArgsIndex Property

Gets or sets the index of the requested page.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PageTextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PageTextRequestedEventArgs.Page Property

PageTextRequestedEventArgsPage Property

Gets or sets the page text data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Page Page { get; set; }
Public Property Page As Page
    Get
    Set

Property Value

Type: Page
See Also

Reference

PageTextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PageTextRequestedEventArgs Methods

The PageTextRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageTextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PartialPostEventArgs Class

Partial PostBack event handler
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsPartialPostEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PartialPostEventArgs : EventArgs
Public Class PartialPostEventArgs
    Inherits EventArgs

The PartialPostEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PartialPostEventArgs | Initializes the PartialPostEventArgs class.
Top
Properties
 | Name | Description
Public property | PostData | Gets teh data.
Public property | Target | Gets the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


PartialPostEventArgs Constructor

Initializes the PartialPostEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PartialPostEventArgs(
    string target,
    string data
)
Public Sub New (
    target As String,
    data As String
)

Parameters

target
Type: SystemString
data
Type: SystemString
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

PartialPostEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PartialPostEventArgs Properties

The PartialPostEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PostData | Gets teh data.
Public property | Target | Gets the target.
Top
See Also

Reference

PartialPostEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PartialPostEventArgs.PostData Property

PartialPostEventArgsPostData Property

Gets teh data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PostData { get; }
Public ReadOnly Property PostData As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

PartialPostEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PartialPostEventArgs.Target Property

PartialPostEventArgsTarget Property

Gets the target.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Target { get; }
Public ReadOnly Property Target As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

PartialPostEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PartialPostEventArgs Methods

The PartialPostEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PartialPostEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PartialPostEventHandler Delegate

A delegate for the Partial PostBack event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PartialPostEventHandler(
    Object sender,
    PartialPostEventArgs e
)
Public Delegate Sub PartialPostEventHandler (
    sender As Object,
    e As PartialPostEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControlsPartialPostEventArgs
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs Class

Passed to the PdfFormRequested event handler so the default file system based PDF form retrieval can be overridden. Setting the PdfDocument property will stop handler from loading all document info from the file.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsPdfFormRequestedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFormRequestedEventArgs : EventArgs
Public Class PdfFormRequestedEventArgs
    Inherits EventArgs

The PdfFormRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PdfFormRequestedEventArgs | Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.
Top
Properties
 | Name | Description
Public property | FilePath | Path to the file that contains the PDF form requested.
Public property | Length | The number of page that were requested by the client. Returns -1 if all layers were requested.
Public property | Offset | The starting page index requested.
Public property | PdfDocument | PDF document to get the forms from. This property will be populated with the current loaded document if one was loaded to get the document info, otherwise it will be null. Setting this property will allow forms from a different document to be loaded, if desired.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs Constructor

Creates a new DocumentInfoRequestedEventArgs for use with the DocumentInfoRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFormRequestedEventArgs(
    string filePath,
    PdfGeneratedDocument formPdf,
    int offset = 0,
    int length = -1
)
Public Sub New (
    filePath As String,
    formPdf As PdfGeneratedDocument,
    Optional offset As Integer = 0,
    Optional length As Integer = -1
)

Parameters

filePath
Type: SystemString
File path to use while loading forms from the PDF.
formPdf
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
PdfGeneratedDocument that form fields will be loaded from.
offset (Optional)
Type: SystemInt32
The index of the first page to retreive fields for.
length (Optional)
Type: SystemInt32
The count of the pages to retreive fields for.
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs Properties

The PdfFormRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Path to the file that contains the PDF form requested.
Public property | Length | The number of page that were requested by the client. Returns -1 if all layers were requested.
Public property | Offset | The starting page index requested.
Public property | PdfDocument | PDF document to get the forms from. This property will be populated with the current loaded document if one was loaded to get the document info, otherwise it will be null. Setting this property will allow forms from a different document to be loaded, if desired.
Top
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs.FilePath Property

PdfFormRequestedEventArgsFilePath Property

Path to the file that contains the PDF form requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs.Length Property

PdfFormRequestedEventArgsLength Property

The number of page that were requested by the client. Returns -1 if all layers were requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs.Offset Property

PdfFormRequestedEventArgsOffset Property

The starting page index requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs.PdfDocument Property

PdfFormRequestedEventArgsPdfDocument Property

PDF document to get the forms from. This property will be populated with the current loaded document if one was loaded to get the document info, otherwise it will be null. Setting this property will allow forms from a different document to be loaded, if desired.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument PdfDocument { get; set; }
Public Property PdfDocument As PdfGeneratedDocument
    Get
    Set

Property Value

Type: PdfGeneratedDocument
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventArgs Methods

The PdfFormRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFormRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


PdfFormRequestedEventHandler Delegate

Event handler delegate for PDF Forms request.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PdfFormRequestedEventHandler(
    Object sender,
    PdfFormRequestedEventArgs e
)
Public Delegate Sub PdfFormRequestedEventHandler (
    sender As Object,
    e As PdfFormRequestedEventArgs
)

Parameters

sender
Type: SystemObject
Object that initiated this event.
e
Type: Atalasoft.Imaging.WebControlsPdfFormRequestedEventArgs
PdfFormRequestedEventArgs
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


PreCacheMode Enumeration

Used in PreCacheTiles to set whether or not it should pre-generate static tiles of the image and put them in the image cache. Results in much faster scrolling and better memory usage, but can affect initial load time.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PreCacheMode
Public Enumeration PreCacheMode
Members
Member name | Description
Never | Never pre-cache tiles for this control
Always | Always pre-cache tiles for this control
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RemoteInvokable Class

This attribute can be applied to a method in a page allowing it to be invoked remotely from client side code.
Inheritance Hierarchy
SystemObject
SystemAttribute
Atalasoft.Imaging.WebControlsRemoteInvokable

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RemoteInvokable : Attribute
Public Class RemoteInvokable
    Inherits Attribute

The RemoteInvokable type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteInvokable | Initializes a new instance of the RemoteInvokable class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RemoteInvokable Constructor

Initializes a new instance of the RemoteInvokable class

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RemoteInvokable()
Public Sub New
See Also

Reference

RemoteInvokable Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokable Properties

The RemoteInvokable type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RemoteInvokable Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokable Methods

The RemoteInvokable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteInvokable Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs Class

Specifies arguments used in the RemoteInvoke event in the WebImageViewer control.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsRemoteInvokeEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RemoteInvokeEventArgs : EventArgs
Public Class RemoteInvokeEventArgs
    Inherits EventArgs

The RemoteInvokeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteInvokeEventArgs(Control, NameValueCollection) | Initializes a new instance of the RemoteInvokeEventArgs class.
Public method | RemoteInvokeEventArgs(Page, NameValueCollection) | Initializes a new instance of the RemoteInvokeEventArgs class.
Top
Properties
 | Name | Description
Public property | NamingContainer | Gets the container used for naming.
Public property | Page | Gets the page.
Public property | Parameters | Gets the parameters.
Public property | ReturnValue | Returns a string of the remote method's return value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs Constructor

Overload List
 | Name | Description
Public method | RemoteInvokeEventArgs(Control, NameValueCollection) | Initializes a new instance of the RemoteInvokeEventArgs class.
Public method | RemoteInvokeEventArgs(Page, NameValueCollection) | Initializes a new instance of the RemoteInvokeEventArgs class.
Top
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs Constructor (Control, NameValueCollection)

Initializes a new instance of the RemoteInvokeEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RemoteInvokeEventArgs(
    Control namingContainer,
    NameValueCollection parameters
)
Public Sub New (
    namingContainer As Control,
    parameters As NameValueCollection
)

Parameters

namingContainer
Type: System.Web.UIControl
parameters
Type: System.Collections.SpecializedNameValueCollection
See Also

Reference

RemoteInvokeEventArgs Class
RemoteInvokeEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs Constructor (Page, NameValueCollection)

Initializes a new instance of the RemoteInvokeEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RemoteInvokeEventArgs(
    Page page,
    NameValueCollection parameters
)
Public Sub New (
    page As Page,
    parameters As NameValueCollection
)

Parameters

page
Type: System.Web.UIPage
parameters
Type: System.Collections.SpecializedNameValueCollection
See Also

Reference

RemoteInvokeEventArgs Class
RemoteInvokeEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs Properties

The RemoteInvokeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NamingContainer | Gets the container used for naming.
Public property | Page | Gets the page.
Public property | Parameters | Gets the parameters.
Public property | ReturnValue | Returns a string of the remote method's return value.
Top
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs.NamingContainer Property

RemoteInvokeEventArgsNamingContainer Property

Gets the container used for naming.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Control NamingContainer { get; }
Public ReadOnly Property NamingContainer As Control
    Get

Property Value

Type: Control
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs.Page Property

RemoteInvokeEventArgsPage Property

Gets the page.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Page Page { get; }
Public ReadOnly Property Page As Page
    Get

Property Value

Type: Page
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs.Parameters Property

RemoteInvokeEventArgsParameters Property

Gets the parameters.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NameValueCollection Parameters { get; }
Public ReadOnly Property Parameters As NameValueCollection
    Get

Property Value

Type: NameValueCollection
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs.ReturnValue Property

RemoteInvokeEventArgsReturnValue Property

Returns a string of the remote method's return value.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ArrayList ReturnValue { get; }
Public ReadOnly Property ReturnValue As ArrayList
    Get

Property Value

Type: ArrayList
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventArgs Methods

The RemoteInvokeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteInvokeEventArgs Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeEventHandler Delegate

A delegate for handling the RemoteInvoke event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void RemoteInvokeEventHandler(
    Object sender,
    RemoteInvokeEventArgs e
)
Public Delegate Sub RemoteInvokeEventHandler (
    sender As Object,
    e As RemoteInvokeEventArgs
)

Parameters

sender
Type: SystemObject
The object which sent the event.
e
Type: Atalasoft.Imaging.WebControlsRemoteInvokeEventArgs
The parameters provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper Class

A helper class for remote invocations.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsRemoteInvokeHelper

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RemoteInvokeHelper
Public Class RemoteInvokeHelper

The RemoteInvokeHelper type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteInvokeHelper | Initializes a new instance of the RemoteInvokeHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindBestMethod(Type, String, Type, Type) | Searches for the closest matching overload.
 | FindBestMethod(Type, String, Type, Type) | Searches for the closest matching overload.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Invoke(Object, NameValueCollection, Type) | Invokes a command.
 | Invoke(Object, String, String, String, Type) | Invokes a command.
 | Invoke(Object, Type, Object, NameValueCollection, Type) | Invokes a command.
 | Invoke(Object, String, Type, Object, String, String, Type) | Invokes a command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TypeStringToTypeArray | Gets a type array from an array of type names.
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper Constructor

Initializes a new instance of the RemoteInvokeHelper class

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RemoteInvokeHelper()
Public Sub New
See Also

Reference

RemoteInvokeHelper Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper Methods

The RemoteInvokeHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindBestMethod(Type, String, Type, Type) | Searches for the closest matching overload.
 | FindBestMethod(Type, String, Type, Type) | Searches for the closest matching overload.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Invoke(Object, NameValueCollection, Type) | Invokes a command.
 | Invoke(Object, String, String, String, Type) | Invokes a command.
 | Invoke(Object, Type, Object, NameValueCollection, Type) | Invokes a command.
 | Invoke(Object, String, Type, Object, String, String, Type) | Invokes a command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TypeStringToTypeArray | Gets a type array from an array of type names.
Top
See Also

Reference

RemoteInvokeHelper Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.FindBestMethod Method

RemoteInvokeHelperFindBestMethod Method

Overload List
Name | Description
FindBestMethod(Type, String, Type, Type) | Searches for the closest matching overload.
FindBestMethod(Type, String, Type, Type) | Searches for the closest matching overload.
Top
See Also

Reference

RemoteInvokeHelper Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.FindBestMethod Method (Type, String, Type[], Type)

RemoteInvokeHelperFindBestMethod Method (Type, String, Type, Type)

Searches for the closest matching overload.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static MethodInfo FindBestMethod(
    Type calleeType,
    string name,
    Type[] signature,
    Type attribute
)
Public Shared Function FindBestMethod (
    calleeType As Type,
    name As String,
    signature As Type(),
    attribute As Type
) As MethodInfo

Parameters

calleeType
Type: SystemType
name
Type: SystemString
signature
Type: SystemType
attribute
Type: SystemType

Return Value

Type: MethodInfo
See Also

Reference

RemoteInvokeHelper Class
FindBestMethod Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.FindBestMethod Method (Type, String, Type[], Type[])

RemoteInvokeHelperFindBestMethod Method (Type, String, Type, Type)

Searches for the closest matching overload.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static MethodInfo FindBestMethod(
    Type calleeType,
    string name,
    Type[] signature,
    Type[] attributes
)
Public Shared Function FindBestMethod (
    calleeType As Type,
    name As String,
    signature As Type(),
    attributes As Type()
) As MethodInfo

Parameters

calleeType
Type: SystemType
name
Type: SystemString
signature
Type: SystemType
attributes
Type: SystemType

Return Value

Type: MethodInfo
See Also

Reference

RemoteInvokeHelper Class
FindBestMethod Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.Invoke Method

RemoteInvokeHelperInvoke Method

Overload List
Name | Description
Invoke(Object, NameValueCollection, Type) | Invokes a command.
Invoke(Object, String, String, String, Type) | Invokes a command.
Invoke(Object, Type, Object, NameValueCollection, Type) | Invokes a command.
Invoke(Object, String, Type, Object, String, String, Type) | Invokes a command.
Top
See Also

Reference

RemoteInvokeHelper Class
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.Invoke Method (Object, NameValueCollection, Type)

RemoteInvokeHelperInvoke Method (Object, NameValueCollection, Type)

Invokes a command.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string Invoke(
    Object theObj,
    NameValueCollection clientParams,
    Type attributeType
)
Public Shared Function Invoke (
    theObj As Object,
    clientParams As NameValueCollection,
    attributeType As Type
) As String

Parameters

theObj
Type: SystemObject
clientParams
Type: System.Collections.SpecializedNameValueCollection
attributeType
Type: SystemType

Return Value

Type: String
See Also

Reference

RemoteInvokeHelper Class
Invoke Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.Invoke Method (Object, String, String, String[], Type)

RemoteInvokeHelperInvoke Method (Object, String, String, String, Type)

Invokes a command.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string Invoke(
    Object theObject,
    string methodName,
    string signature,
    string[] args,
    Type attribute
)
Public Shared Function Invoke (
    theObject As Object,
    methodName As String,
    signature As String,
    args As String(),
    attribute As Type
) As String

Parameters

theObject
Type: SystemObject
methodName
Type: SystemString
signature
Type: SystemString
args
Type: SystemString
attribute
Type: SystemType

Return Value

Type: String
See Also

Reference

RemoteInvokeHelper Class
Invoke Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.Invoke Method (Object, Type[], Object[], NameValueCollection, Type)

RemoteInvokeHelperInvoke Method (Object, Type, Object, NameValueCollection, Type)

Invokes a command.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string Invoke(
    Object theObj,
    Type[] mandatoryParametersTypes,
    Object[] mandatoryParameters,
    NameValueCollection clientParams,
    Type attributeType
)
Public Shared Function Invoke (
    theObj As Object,
    mandatoryParametersTypes As Type(),
    mandatoryParameters As Object(),
    clientParams As NameValueCollection,
    attributeType As Type
) As String

Parameters

theObj
Type: SystemObject
mandatoryParametersTypes
Type: SystemType
mandatoryParameters
Type: SystemObject
clientParams
Type: System.Collections.SpecializedNameValueCollection
attributeType
Type: SystemType

Return Value

Type: String
See Also

Reference

RemoteInvokeHelper Class
Invoke Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.Invoke Method (Object, String, Type[], Object[], String, String[], Type)

RemoteInvokeHelperInvoke Method (Object, String, Type, Object, String, String, Type)

Invokes a command.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string Invoke(
    Object theObject,
    string methodName,
    Type[] mandatoryParameterTypes,
    Object[] mandatoryParameters,
    string signature,
    string[] args,
    Type attribute
)
Public Shared Function Invoke (
    theObject As Object,
    methodName As String,
    mandatoryParameterTypes As Type(),
    mandatoryParameters As Object(),
    signature As String,
    args As String(),
    attribute As Type
) As String

Parameters

theObject
Type: SystemObject
methodName
Type: SystemString
mandatoryParameterTypes
Type: SystemType
mandatoryParameters
Type: SystemObject
signature
Type: SystemString
args
Type: SystemString
attribute
Type: SystemType

Return Value

Type: String
See Also

Reference

RemoteInvokeHelper Class
Invoke Overload
Atalasoft.Imaging.WebControls Namespace


RemoteInvokeHelper.TypeStringToTypeArray Method

RemoteInvokeHelperTypeStringToTypeArray Method

Gets a type array from an array of type names.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Type[] TypeStringToTypeArray(
    string typeStr,
    string[] args
)
Public Shared Function TypeStringToTypeArray (
    typeStr As String,
    args As String()
) As Type()

Parameters

typeStr
Type: SystemString
args
Type: SystemString

Return Value

Type: Type
See Also

Reference

RemoteInvokeHelper Class
Atalasoft.Imaging.WebControls Namespace


ReplaceFileExtension Enumeration

Specifies the a value indicating for which files WDV should set extensions.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ReplaceFileExtension
Public Enumeration ReplaceFileExtension
Members
Member name | Description
None | Do not replace extension.
FilesWithoutExtension | Set image-type based extensions if no extension is specified.
AllFiles | Set image-type based extension for all files.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs Class

Arguments to a ResizeImageForZoomEvent handler
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsResizeImageForZoomEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResizeImageForZoomEventArgs
Public Class ResizeImageForZoomEventArgs

The ResizeImageForZoomEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResizeImageForZoomEventArgs | Creates a ResizeImageForZoomEvent argument object
Top
Properties
 | Name | Description
Public property | DestSize | the 'zoomed' size in pixels of the zoomed region
Public property | ResizedImage | an AtalaImage containing the 'zoomed' pixels of the region of interest
Public property | SourceImage | the source AtalaImage that is being 'zoomed'
Public property | SourceRect | the source rectangle (pixel region) in the source image for the zoomed data
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs Constructor

Creates a ResizeImageForZoomEvent argument object

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResizeImageForZoomEventArgs(
    AtalaImage image,
    Rectangle srcRect,
    Size dstSize
)
Public Sub New (
    image As AtalaImage,
    srcRect As Rectangle,
    dstSize As Size
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
the AtalaImage being 'zoomed'
srcRect
Type: System.DrawingRectangle
the source rectangle of the zoomed region
dstSize
Type: System.DrawingSize
the 'zoomed' size in pixels of the zoomed region
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs Properties

The ResizeImageForZoomEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DestSize | the 'zoomed' size in pixels of the zoomed region
Public property | ResizedImage | an AtalaImage containing the 'zoomed' pixels of the region of interest
Public property | SourceImage | the source AtalaImage that is being 'zoomed'
Public property | SourceRect | the source rectangle (pixel region) in the source image for the zoomed data
Top
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs.DestSize Property

ResizeImageForZoomEventArgsDestSize Property

the 'zoomed' size in pixels of the zoomed region

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size DestSize { get; set; }
Public Property DestSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs.ResizedImage Property

ResizeImageForZoomEventArgsResizedImage Property

an AtalaImage containing the 'zoomed' pixels of the region of interest

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ResizedImage { get; set; }
Public Property ResizedImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs.SourceImage Property

ResizeImageForZoomEventArgsSourceImage Property

the source AtalaImage that is being 'zoomed'

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage SourceImage { get; set; }
Public Property SourceImage As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs.SourceRect Property

ResizeImageForZoomEventArgsSourceRect Property

the source rectangle (pixel region) in the source image for the zoomed data

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SourceRect { get; set; }
Public Property SourceRect As Rectangle
    Get
    Set

Property Value

Type: Rectangle
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventArgs Methods

The ResizeImageForZoomEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResizeImageForZoomEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResizeImageForZoomEventHandler Delegate

Signature of handler for a ResizeImageForZoomEvent

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ResizeImageForZoomEventHandler(
    Object sender,
    ResizeImageForZoomEventArgs e
)
Public Delegate Sub ResizeImageForZoomEventHandler (
    sender As Object,
    e As ResizeImageForZoomEventArgs
)

Parameters

sender
Type: SystemObject
object that fired the event
e
Type: Atalasoft.Imaging.WebControlsResizeImageForZoomEventArgs
arguments, see ResizeImageForZoomEventArgs
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResolutionScaleMode Enumeration

The resolution scale mode.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResolutionScaleMode
Public Enumeration ResolutionScaleMode
Members
Member name | Description
None | None.
Fax | Fax.
All | All.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResolveDocumentUriEventArgs Class

Passed to the ResolveDocumentUri event handler so the default file system based save method can be overridden.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsResolveDocumentUriEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResolveDocumentUriEventArgs : EventArgs
Public Class ResolveDocumentUriEventArgs
    Inherits EventArgs

The ResolveDocumentUriEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveDocumentUriEventArgs | Creates an instance of the resolve uri event args.
Top
Properties
 | Name | Description
Public property | DocumentStream | Stream used to override the default file system save while saving the document. Setting this property will take precedence over using the DocumentUri property.
Public property | DocumentUri | Document uri.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResolveDocumentUriEventArgs Constructor

Creates an instance of the resolve uri event args.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolveDocumentUriEventArgs(
    string uri
)
Public Sub New (
    uri As String
)

Parameters

uri
Type: SystemString
The initial uri to resolve.
See Also

Reference

ResolveDocumentUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolveDocumentUriEventArgs Properties

The ResolveDocumentUriEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DocumentStream | Stream used to override the default file system save while saving the document. Setting this property will take precedence over using the DocumentUri property.
Public property | DocumentUri | Document uri.
Top
See Also

Reference

ResolveDocumentUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolveDocumentUriEventArgs.DocumentStream Property

ResolveDocumentUriEventArgsDocumentStream Property

Stream used to override the default file system save while saving the document. Setting this property will take precedence over using the DocumentUri property.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream DocumentStream { get; set; }
Public Property DocumentStream As Stream
    Get
    Set

Property Value

Type: Stream
See Also

Reference

ResolveDocumentUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolveDocumentUriEventArgs.DocumentUri Property

ResolveDocumentUriEventArgsDocumentUri Property

Document uri.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentUri { get; }
Public ReadOnly Property DocumentUri As String
    Get

Property Value

Type: String
See Also

Reference

ResolveDocumentUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolveDocumentUriEventArgs Methods

The ResolveDocumentUriEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveDocumentUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs Class

Passed to the ResolvePageUri event handler so the default file system based save method can be overridden.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsResolvePageUriEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResolvePageUriEventArgs : EventArgs
Public Class ResolvePageUriEventArgs
    Inherits EventArgs

The ResolvePageUriEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResolvePageUriEventArgs | Creates an instance of the resolve uri event args.
Top
Properties
 | Name | Description
Public property | DocumentPageIndex | [Optional] The index of the page in the DocumentStream if it is a multi-page document. Default value is 0.
Public property | DocumentStream | Stream used to override the default file system save while saving the document. Setting this property will take precedence over using the DocumentUri property.
Public property | DocumentUri | Document uri.
Public property | SourcePageIndex | The requested index of the page in the document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs Constructor

Creates an instance of the resolve uri event args.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolvePageUriEventArgs(
    string uri,
    int index
)
Public Sub New (
    uri As String,
    index As Integer
)

Parameters

uri
Type: SystemString
The initial uri to resolve.
index
Type: SystemInt32
The index of the requested page.
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs Properties

The ResolvePageUriEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DocumentPageIndex | [Optional] The index of the page in the DocumentStream if it is a multi-page document. Default value is 0.
Public property | DocumentStream | Stream used to override the default file system save while saving the document. Setting this property will take precedence over using the DocumentUri property.
Public property | DocumentUri | Document uri.
Public property | SourcePageIndex | The requested index of the page in the document.
Top
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs.DocumentPageIndex Property

ResolvePageUriEventArgsDocumentPageIndex Property

[Optional] The index of the page in the DocumentStream if it is a multi-page document. Default value is 0.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DocumentPageIndex { get; set; }
Public Property DocumentPageIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs.DocumentStream Property

ResolvePageUriEventArgsDocumentStream Property

Stream used to override the default file system save while saving the document. Setting this property will take precedence over using the DocumentUri property.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream DocumentStream { get; set; }
Public Property DocumentStream As Stream
    Get
    Set

Property Value

Type: Stream
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs.DocumentUri Property

ResolvePageUriEventArgsDocumentUri Property

Document uri.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentUri { get; }
Public ReadOnly Property DocumentUri As String
    Get

Property Value

Type: String
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs.SourcePageIndex Property

ResolvePageUriEventArgsSourcePageIndex Property

The requested index of the page in the document.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SourcePageIndex { get; }
Public ReadOnly Property SourcePageIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResolvePageUriEventArgs Methods

The ResolvePageUriEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolvePageUriEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResourceType Enumeration

The resource type.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResourceType
Public Enumeration ResourceType
Members
Member name | Description
Image | Image resource.
Script | Script resource.
Cursor | Cursor resource.
ChildFrame | Child Frame.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResponseSendEventArgs Class

Represents the arguments for ResponseSending events. Passes as a parameter to ResponseSendEventHandler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsResponseSendEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResponseSendEventArgs : EventArgs
Public Class ResponseSendEventArgs
    Inherits EventArgs

The ResponseSendEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CustomResponseData | Gets or sets a user data that should be added to response.
Public property | OriginalResponse | Gets a response JSON before modification.
Public property | Params | Gets a user defined parameters from HTTP request.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ResponseSendEventArgs Properties

The ResponseSendEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CustomResponseData | Gets or sets a user data that should be added to response.
Public property | OriginalResponse | Gets a response JSON before modification.
Public property | Params | Gets a user defined parameters from HTTP request.
Top
See Also

Reference

ResponseSendEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResponseSendEventArgs.CustomResponseData Property

ResponseSendEventArgsCustomResponseData Property

Gets or sets a user data that should be added to response.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary<string, string> CustomResponseData { get; set; }
Public Property CustomResponseData As IDictionary(Of String, String)
    Get
    Set

Property Value

Type: IDictionaryString, String
Remarks
This dictionary will be added to the response JSON object as a separate field 'customData'.
See Also

Reference

ResponseSendEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResponseSendEventArgs.OriginalResponse Property

ResponseSendEventArgsOriginalResponse Property

Gets a response JSON before modification.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Hashtable OriginalResponse { get; }
Public ReadOnly Property OriginalResponse As Hashtable
    Get

Property Value

Type: Hashtable
Remarks
This property represents a copy of the original response and should be used only for informational purposes.
See Also

Reference

ResponseSendEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResponseSendEventArgs.Params Property

ResponseSendEventArgsParams Property

Gets a user defined parameters from HTTP request.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IDictionary<string, string> Params { get; }
Public ReadOnly Property Params As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionaryString, String
See Also

Reference

ResponseSendEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResponseSendEventArgs Methods

The ResponseSendEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResponseSendEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ResponseSendEventHandler Delegate

A delegate for handling the ResponseSending events.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ResponseSendEventHandler(
    Object sender,
    ResponseSendEventArgs e
)
Public Delegate Sub ResponseSendEventHandler (
    sender As Object,
    e As ResponseSendEventArgs
)

Parameters

sender
Type: SystemObject
The object which fired the event
e
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
The arguments provided to the handler.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RubberBand Class

A control for selecting a rectangular region.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
Atalasoft.Imaging.WebControlsRubberBand

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public class RubberBand : Control
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Class RubberBand
    Inherits Control

The RubberBand type exposes the following members.

Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Animated | Gets or sets a value that indicating whether the selection will animate or not.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be contrained to.
Public property | AutoPostBack | Gets or sets a value that indicates whether the selection will automatically post back when it has changed on the client side.
Public property | BackColor | Gets or sets a System.Drawing.Color that represents the color behind the dashed line.
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClickLock | Enables or disables whether the mouse will need dragging to create a selection. When set to true, dragging is disabled, and clicking once will set the first point, clicking a second time will finish the selection.
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | DrawMask | Enables or disables whether a mask is drawn outside the selection.
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Overrides ControlEnableViewState.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | ForeColor | Gets or sets a System.Drawing.Color that represents the color of the dashed line.
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the starting Height of the selection.
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Overrides ControlID.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | Movable | Gets or sets a value that indicates whether the selection can be moved after it is drawn.
Public property | MultiColor | Gets or sets a value indicating if the selection is a solid or dashed line.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Position | Gets or sets the starting position of the selection, if it's visible.
Public property | Rectangle | Gets the RubberBand selection rectangle associated with this control.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | Resizable | Gets or sets a value that indicating whether the selection can resize after it is drawn.
Public property | ShowGrips | Gets or sets a value that indicates whether the RubberBand has grips on the edges.
Public property | ShowTooltip | Gets or sets a value that indicates whether a tooltip that displays the pixel size of the selection is displayed to the lower right of the RubberBand while the area is being selected.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | Size | Gets or sets the starting size of the selection, if it's visible.
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Gets or sets a value indicating if the RubberBand is hidden or visible on initial page load.
Public property | Visible | Indicates whether the RubberBand is visible on page load. (Overrides ControlVisible.)
Public property | Width | Gets or sets the starting Width of the selection.
Top
Methods
 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Adds a hidden tag to HTML.
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Public method | IsEmpty | Checks if this control is equal to an empty RubberBand, returns true if they are equal, false if not
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnRubberBandChanged | Occurs when the rubberband selection area changes.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Render this control to the output parameter specified. (Overrides ControlRender(HtmlTextWriter).)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | Reset | This method resets the RubberBand by setting the Position and Size to 0,0, and sets the Visible property to false.
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | RubberBandChanged | Fires when the RubberBand changes on the client side.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


RubberBand Properties

The RubberBand type exposes the following members.

Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Animated | Gets or sets a value that indicating whether the selection will animate or not.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be contrained to.
Public property | AutoPostBack | Gets or sets a value that indicates whether the selection will automatically post back when it has changed on the client side.
Public property | BackColor | Gets or sets a System.Drawing.Color that represents the color behind the dashed line.
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClickLock | Enables or disables whether the mouse will need dragging to create a selection. When set to true, dragging is disabled, and clicking once will set the first point, clicking a second time will finish the selection.
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | DrawMask | Enables or disables whether a mask is drawn outside the selection.
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Overrides ControlEnableViewState.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | ForeColor | Gets or sets a System.Drawing.Color that represents the color of the dashed line.
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the starting Height of the selection.
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Overrides ControlID.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | Movable | Gets or sets a value that indicates whether the selection can be moved after it is drawn.
Public property | MultiColor | Gets or sets a value indicating if the selection is a solid or dashed line.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Position | Gets or sets the starting position of the selection, if it's visible.
Public property | Rectangle | Gets the RubberBand selection rectangle associated with this control.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | Resizable | Gets or sets a value that indicating whether the selection can resize after it is drawn.
Public property | ShowGrips | Gets or sets a value that indicates whether the RubberBand has grips on the edges.
Public property | ShowTooltip | Gets or sets a value that indicates whether a tooltip that displays the pixel size of the selection is displayed to the lower right of the RubberBand while the area is being selected.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | Size | Gets or sets the starting size of the selection, if it's visible.
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Gets or sets a value indicating if the RubberBand is hidden or visible on initial page load.
Public property | Visible | Indicates whether the RubberBand is visible on page load. (Overrides ControlVisible.)
Public property | Width | Gets or sets the starting Width of the selection.
Top
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Animated Property

RubberBandAnimated Property

Gets or sets a value that indicating whether the selection will animate or not.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Animated { get; set; }
Public Property Animated As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the RubberBand is animated; otherwise, false. The default is true.

Remarks
When this is enabled, the RubberBand will appear to animate by switching the BackColor and ForeColor.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.AspectRatio Property

RubberBandAspectRatio Property

Gets or sets the aspect ratio which the rubberband will be contrained to.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float AspectRatio { get; set; }
Public Property AspectRatio As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.AutoPostBack Property

RubberBandAutoPostBack Property

Gets or sets a value that indicates whether the selection will automatically post back when it has changed on the client side.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoPostBack { get; set; }
Public Property AutoPostBack As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the RubberBand will automatically post back when it has changed on the client side.; otherwise, false. The default is false.

See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.BackColor Property

RubberBandBackColor Property

Gets or sets a System.Drawing.Color that represents the color behind the dashed line.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
A System.Drawing.Color that represents the color behind the dashed line.
Remarks
This property is only used if MultiColor is set to true. The default is Color.White.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.ClickLock Property

RubberBandClickLock Property

Enables or disables whether the mouse will need dragging to create a selection. When set to true, dragging is disabled, and clicking once will set the first point, clicking a second time will finish the selection.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClickLock { get; set; }
Public Property ClickLock As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.DrawMask Property

RubberBandDrawMask Property

Enables or disables whether a mask is drawn outside the selection.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DrawMask { get; set; }
Public Property DrawMask As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.EnableViewState Property

RubberBandEnableViewState Property

Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get

Return Value

Type: Boolean
true if the server control maintains its view state; otherwise false. The default is true.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.ForeColor Property

RubberBandForeColor Property

Gets or sets a System.Drawing.Color that represents the color of the dashed line.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

Property Value

Type: Color
A System.Drawing.Color that represents the color of the dashed line.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Height Property

RubberBandHeight Property

Gets or sets the starting Height of the selection.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set

Property Value

Type: Int32
The starting Height of the selection.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.ID Property

RubberBandID Property

Gets or sets the programmatic identifier assigned to the server control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ID { get; set; }
Public Overrides Property ID As String
    Get
    Set

Return Value

Type: String
The programmatic identifier assigned to the control.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Movable Property

RubberBandMovable Property

Gets or sets a value that indicates whether the selection can be moved after it is drawn.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Movable { get; set; }
Public Property Movable As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the RubberBand is movable; otherwise, false. The default is true.

Remarks
If this property is set to false, the RubberBand will not be movable after it has been created.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.MultiColor Property

RubberBandMultiColor Property

Gets or sets a value indicating if the selection is a solid or dashed line.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MultiColor { get; set; }
Public Property MultiColor As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the RubberBand is multicolor; otherwise, false. The default is true.

Remarks
If false, the selection is a solid line. Default is true.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Position Property

RubberBandPosition Property

Gets or sets the starting position of the selection, if it's visible.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set

Property Value

Type: Point

The starting position of the selection, if it's visible.

Remarks
This property is based on the upper left corner of the control. If the position is set to a location that is not on the control, the client side JavaScript will move the selection to the closest valid point.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Rectangle Property

RubberBandRectangle Property

Gets the RubberBand selection rectangle associated with this control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Rectangle { get; set; }
Public Property Rectangle As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A rectangle selection.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Resizable Property

RubberBandResizable Property

Gets or sets a value that indicating whether the selection can resize after it is drawn.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Resizable { get; set; }
Public Property Resizable As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the RubberBand is resizeable; otherwise, false. The default is true.

See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.ShowGrips Property

RubberBandShowGrips Property

Gets or sets a value that indicates whether the RubberBand has grips on the edges.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowGrips { get; set; }
Public Property ShowGrips As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.ShowTooltip Property

RubberBandShowTooltip Property

Gets or sets a value that indicates whether a tooltip that displays the pixel size of the selection is displayed to the lower right of the RubberBand while the area is being selected.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowTooltip { get; set; }
Public Property ShowTooltip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Size Property

RubberBandSize Property

Gets or sets the starting size of the selection, if it's visible.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The starting size of the selection, if it's visible.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Visibility Property

RubberBandVisibility Property

Gets or sets a value indicating if the RubberBand is hidden or visible on initial page load.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public VisibilityStyle Visibility { get; set; }
Public Property Visibility As VisibilityStyle
    Get
    Set

Property Value

Type: VisibilityStyle
A value indicating if the RubberBand is hidden or visible on initial page load.
Remarks
This property uses the style attribute 'visibility' and only has an affect if Visible is true. Use the Visible or Enabled property to prevent rendering the client side code to draw the RubberBand. Visibility is used to hide the rubberband, but still allow it to be displayed.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Visible Property

RubberBandVisible Property

Indicates whether the RubberBand is visible on page load.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Visible { get; }
Public Overrides ReadOnly Property Visible As Boolean
    Get

Property Value

Type: Boolean

true if the RubberBand is visible; otherwise, false. The default is false.

See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Width Property

RubberBandWidth Property

Gets or sets the starting Width of the selection.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set

Property Value

Type: Int32
The starting Width of the selection.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand Methods

The RubberBand type exposes the following members.

Methods
 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Adds a hidden tag to HTML.
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Public method | IsEmpty | Checks if this control is equal to an empty RubberBand, returns true if they are equal, false if not
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnRubberBandChanged | Occurs when the rubberband selection area changes.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Render this control to the output parameter specified. (Overrides ControlRender(HtmlTextWriter).)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | Reset | This method resets the RubberBand by setting the Position and Size to 0,0, and sets the Visible property to false.
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Top
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.AddHiddenTag Method

RubberBandAddHiddenTag Method

Adds a hidden tag to HTML.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void AddHiddenTag(
    HtmlTextWriter htw,
    string id,
    string val
)
Protected Overridable Sub AddHiddenTag (
    htw As HtmlTextWriter,
    id As String,
    val As String
)

Parameters

htw
Type: System.Web.UIHtmlTextWriter
id
Type: SystemString
val
Type: SystemString
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.IsEmpty Method

RubberBandIsEmpty Method

Checks if this control is equal to an empty RubberBand, returns true if they are equal, false if not

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.OnInit Method

RubberBandOnInit Method

Raises the Init event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.OnRubberBandChanged Method

RubberBandOnRubberBandChanged Method

Occurs when the rubberband selection area changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRubberBandChanged(
    EventArgs e
)
Protected Overridable Sub OnRubberBandChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Render Method

RubberBandRender Method

Render this control to the output parameter specified.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Render(
    HtmlTextWriter writer
)
Protected Overrides Sub Render (
    writer As HtmlTextWriter
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
The HTML writer to write out to
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.Reset Method

RubberBandReset Method

This method resets the RubberBand by setting the Position and Size to 0,0, and sets the Visible property to false.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand Events

The RubberBand type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | RubberBandChanged | Fires when the RubberBand changes on the client side.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


RubberBand.RubberBandChanged Event

RubberBandRubberBandChanged Event

Fires when the RubberBand changes on the client side.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler RubberBandChanged
Public Event RubberBandChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RubberBand Class
Atalasoft.Imaging.WebControls Namespace


ScrollBarVisibility Enumeration

Specifies how the scroll bars are shown in the ScrollPort and inherited control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ScrollBarVisibility
Public Enumeration ScrollBarVisibility
Members
Member name | Description
Dynamic | Automatically show or hide the horizontal and vertical scrollbars as the control or image resizes.
None | Never show scroll bars.
Always | Always show scroll bars.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


TextRequestedEventArgs Class

Provides the data for text data requesting event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsTextRequestedEventArgs
Atalasoft.Imaging.WebControlsPageTextRequestedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class TextRequestedEventArgs : EventArgs
Public MustInherit Class TextRequestedEventArgs
    Inherits EventArgs

The TextRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Protected method | TextRequestedEventArgs | Initializes a new instance of the TextRequestedEventArgs class.
Top
Properties
 | Name | Description
Public property | FilePath | Gets or sets the text resource identifier that was requested by the client.
Public property | JsonData | Gets or sets the pre-generated json data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


TextRequestedEventArgs Constructor

Initializes a new instance of the TextRequestedEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected TextRequestedEventArgs(
    string filePath
)
Protected Sub New (
    filePath As String
)

Parameters

filePath
Type: SystemString
The text data file path that was requested by the client.
See Also

Reference

TextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


TextRequestedEventArgs Properties

The TextRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets or sets the text resource identifier that was requested by the client.
Public property | JsonData | Gets or sets the pre-generated json data.
Top
See Also

Reference

TextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


TextRequestedEventArgs.FilePath Property

TextRequestedEventArgsFilePath Property

Gets or sets the text resource identifier that was requested by the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


TextRequestedEventArgs.JsonData Property

TextRequestedEventArgsJsonData Property

Gets or sets the pre-generated json data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string JsonData { get; set; }
Public Property JsonData As String
    Get
    Set

Property Value

Type: String
Remarks
Setting this field allows to pass pre-generated OCR data without addition serialization round trip.
See Also

Reference

TextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


TextRequestedEventArgs Methods

The TextRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextRequestedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs Class

Arguments for the ThumbnailDrop event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsThumbnailDropEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailDropEventArgs : EventArgs
Public Class ThumbnailDropEventArgs
    Inherits EventArgs

The ThumbnailDropEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailDropEventArgs | Initializes an instance of the ThumbnailDropEventArgs class.
Public method | ThumbnailDropEventArgs(Int32, Int32) | Initializes an instance of the ThumbnailDropEventArgs class.
Top
Properties
 | Name | Description
Public property | DragIndex | The position in the array of thumbnails the thumbnail was dragged from.
Public property | DropIndex | The position in the array of thumbnails the thumbnail was dragged to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs Constructor

Overload List
 | Name | Description
Public method | ThumbnailDropEventArgs | Initializes an instance of the ThumbnailDropEventArgs class.
Public method | ThumbnailDropEventArgs(Int32, Int32) | Initializes an instance of the ThumbnailDropEventArgs class.
Top
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs Constructor

Initializes an instance of the ThumbnailDropEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDropEventArgs()
Public Sub New
See Also

Reference

ThumbnailDropEventArgs Class
ThumbnailDropEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs Constructor (Int32, Int32)

Initializes an instance of the ThumbnailDropEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDropEventArgs(
    int dragIndex,
    int dropIndex
)
Public Sub New (
    dragIndex As Integer,
    dropIndex As Integer
)

Parameters

dragIndex
Type: SystemInt32
dropIndex
Type: SystemInt32
See Also

Reference

ThumbnailDropEventArgs Class
ThumbnailDropEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs Properties

The ThumbnailDropEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DragIndex | The position in the array of thumbnails the thumbnail was dragged from.
Public property | DropIndex | The position in the array of thumbnails the thumbnail was dragged to.
Top
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs.DragIndex Property

ThumbnailDropEventArgsDragIndex Property

The position in the array of thumbnails the thumbnail was dragged from.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DragIndex { get; set; }
Public Property DragIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs.DropIndex Property

ThumbnailDropEventArgsDropIndex Property

The position in the array of thumbnails the thumbnail was dragged to.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DropIndex { get; set; }
Public Property DropIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventArgs Methods

The ThumbnailDropEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailDropEventHandler Delegate

Delegate type for the ThumbnailDrop event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ThumbnailDropEventHandler(
    Object sender,
    ThumbnailDropEventArgs e
)
Public Delegate Sub ThumbnailDropEventHandler (
    sender As Object,
    e As ThumbnailDropEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControlsThumbnailDropEventArgs
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs Class

The arguments for the ThumbnailImageCreated event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControlsThumbnailImageCreatedEventArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailImageCreatedEventArgs : EventArgs
Public Class ThumbnailImageCreatedEventArgs
    Inherits EventArgs

The ThumbnailImageCreatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailImageCreatedEventArgs | Initializes the ThumbnailImageCreatedEventArgs class.
Public method | ThumbnailImageCreatedEventArgs(AtalaImage, Int32, Double) | Initializes the ThumbnailImageCreatedEventArgs class.
Top
Properties
 | Name | Description
Public property | Image | Gets or sets the input image.
Public property | ImageOut | Gets or sets the output image.
Public property | Index | Gets or sets the index.
Public property | Zoom | Gets or sets the zoom level.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs Constructor

Overload List
 | Name | Description
Public method | ThumbnailImageCreatedEventArgs | Initializes the ThumbnailImageCreatedEventArgs class.
Public method | ThumbnailImageCreatedEventArgs(AtalaImage, Int32, Double) | Initializes the ThumbnailImageCreatedEventArgs class.
Top
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs Constructor

Initializes the ThumbnailImageCreatedEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailImageCreatedEventArgs()
Public Sub New
See Also

Reference

ThumbnailImageCreatedEventArgs Class
ThumbnailImageCreatedEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs Constructor (AtalaImage, Int32, Double)

Initializes the ThumbnailImageCreatedEventArgs class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailImageCreatedEventArgs(
    AtalaImage image,
    int index,
    double zoom
)
Public Sub New (
    image As AtalaImage,
    index As Integer,
    zoom As Double
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
index
Type: SystemInt32
zoom
Type: SystemDouble
See Also

Reference

ThumbnailImageCreatedEventArgs Class
ThumbnailImageCreatedEventArgs Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs Properties

The ThumbnailImageCreatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets or sets the input image.
Public property | ImageOut | Gets or sets the output image.
Public property | Index | Gets or sets the index.
Public property | Zoom | Gets or sets the zoom level.
Top
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs.Image Property

ThumbnailImageCreatedEventArgsImage Property

Gets or sets the input image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs.ImageOut Property

ThumbnailImageCreatedEventArgsImageOut Property

Gets or sets the output image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ImageOut { get; set; }
Public Property ImageOut As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs.Index Property

ThumbnailImageCreatedEventArgsIndex Property

Gets or sets the index.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs.Zoom Property

ThumbnailImageCreatedEventArgsZoom Property

Gets or sets the zoom level.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventArgs Methods

The ThumbnailImageCreatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailImageCreatedEventArgs Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailImageCreatedEventHandler Delegate

Delegate type for the AnnotationCreated event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ThumbnailImageCreatedEventHandler(
    Object sender,
    ThumbnailImageCreatedEventArgs e
)
Public Delegate Sub ThumbnailImageCreatedEventHandler (
    sender As Object,
    e As ThumbnailImageCreatedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControlsThumbnailImageCreatedEventArgs
Remarks
This is the delegate signature for the event handler for the AnnotationCreated event.
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Class

Used to set the ThumbStyle property (and Hover, Selected and SelectedHover variants). Encapsulates the visual style of the thumbnail.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
Atalasoft.Imaging.WebControlsThumbnailStyle

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public class ThumbnailStyle : Control
<SerializableAttribute>
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Class ThumbnailStyle
    Inherits Control

The ThumbnailStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailStyle | Creates a ThumbnailStyle where all of the properties are initially set to empty strings.
Public method | ThumbnailStyle(String, String, String, String, String) | Creates a ThumbnailStyle from it's CSS style settings.
Public method | ThumbnailStyle(String, String, String, String, String, String) | Creates a ThumbnailStyle from it's CSS style settings.
Top
Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | BackColor | Gets or sets the color behind the thumbnail.
Public property | BackgroundImage | Gets or sets the image behind the thumbnail.
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Border | Gets or sets the CSS border style around the thumbnail.
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor shown when the mouse is hovered over the thumbnail.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Overrides ControlEnableViewState.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets or sets the css font property.
Public property | ForeColor | Gets or sets the color of the thumbnail caption.
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Overrides ControlID.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Overrides ControlVisible.)
Top
Methods
 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Public method | BuildStyle | Returns a CSS string representing the style of an individual thumbnail based on its properties. It only includes properties that are not set to their default value.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Public method | CopyFromThumbnailStyle | This method copies the values from another ThumbnailStyle to this one
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Returns true if o is a ThumbnailStyle and has the same property values. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | A hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Public method | IsBlank | Returns true if all of the properties are set to empty strings and false otherwise.
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Constructor

Create and initialize ThumbnailStyle objects
Overload List
 | Name | Description
Public method | ThumbnailStyle | Creates a ThumbnailStyle where all of the properties are initially set to empty strings.
Public method | ThumbnailStyle(String, String, String, String, String) | Creates a ThumbnailStyle from it's CSS style settings.
Public method | ThumbnailStyle(String, String, String, String, String, String) | Creates a ThumbnailStyle from it's CSS style settings.
Top
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Constructor

Creates a ThumbnailStyle where all of the properties are initially set to empty strings.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailStyle()
Public Sub New
See Also

Reference

ThumbnailStyle Class
ThumbnailStyle Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Constructor (String, String, String, String, String)

Creates a ThumbnailStyle from it's CSS style settings.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailStyle(
    string backColor,
    string foreColor,
    string backgroundImage,
    string border,
    string cursor
)
Public Sub New (
    backColor As String,
    foreColor As String,
    backgroundImage As String,
    border As String,
    cursor As String
)

Parameters

backColor
Type: SystemString
The CSS background color to use for the thumbnail.
foreColor
Type: SystemString
The CSS foreground color to use for the thumbnail.
backgroundImage
Type: SystemString
The CSS background image to use for the thumbnail.
border
Type: SystemString
The CSS border to use for the thumbnail.
cursor
Type: SystemString
The CSS cursor to show when the mouse is over the thumbnail.
See Also

Reference

ThumbnailStyle Class
ThumbnailStyle Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Constructor (String, String, String, String, String, String)

Creates a ThumbnailStyle from it's CSS style settings.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailStyle(
    string backColor,
    string foreColor,
    string backgroundImage,
    string border,
    string cursor,
    string font
)
Public Sub New (
    backColor As String,
    foreColor As String,
    backgroundImage As String,
    border As String,
    cursor As String,
    font As String
)

Parameters

backColor
Type: SystemString
The CSS background color to use for the thumbnail.
foreColor
Type: SystemString
The CSS foreground color to use for the thumbnail.
backgroundImage
Type: SystemString
The CSS background image to use for the thumbnail.
border
Type: SystemString
The CSS border to use for the thumbnail.
cursor
Type: SystemString
The CSS cursor to show when the mouse is over the thumbnail.
font
Type: SystemString
The font family name.
See Also

Reference

ThumbnailStyle Class
ThumbnailStyle Overload
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Properties

The ThumbnailStyle type exposes the following members.

Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | BackColor | Gets or sets the color behind the thumbnail.
Public property | BackgroundImage | Gets or sets the image behind the thumbnail.
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Border | Gets or sets the CSS border style around the thumbnail.
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor shown when the mouse is hovered over the thumbnail.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Overrides ControlEnableViewState.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets or sets the css font property.
Public property | ForeColor | Gets or sets the color of the thumbnail caption.
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Overrides ControlID.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Overrides ControlVisible.)
Top
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.BackColor Property

ThumbnailStyleBackColor Property

Gets or sets the color behind the thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BackColor { get; set; }
Public Property BackColor As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.BackgroundImage Property

ThumbnailStyleBackgroundImage Property

Gets or sets the image behind the thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BackgroundImage { get; set; }
Public Property BackgroundImage As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.Border Property

ThumbnailStyleBorder Property

Gets or sets the CSS border style around the thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Border { get; set; }
Public Property Border As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.Cursor Property

ThumbnailStyleCursor Property

Gets or sets the cursor shown when the mouse is hovered over the thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Cursor { get; set; }
Public Property Cursor As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.EnableViewState Property

ThumbnailStyleEnableViewState Property

Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get

Return Value

Type: Boolean
true if the server control maintains its view state; otherwise false. The default is true.
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.Font Property

ThumbnailStyleFont Property

Gets or sets the css font property.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Font { get; set; }
Public Property Font As String
    Get
    Set

Property Value

Type: String
The valid CSS font property. This requires a size value and a font value ("15px arial").
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.ForeColor Property

ThumbnailStyleForeColor Property

Gets or sets the color of the thumbnail caption.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ForeColor { get; set; }
Public Property ForeColor As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.ID Property

ThumbnailStyleID Property

Gets or sets the programmatic identifier assigned to the server control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ID { get; }
Public Overrides ReadOnly Property ID As String
    Get

Return Value

Type: String
The programmatic identifier assigned to the control.
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.Visible Property

ThumbnailStyleVisible Property

Gets or sets a value that indicates whether a server control is rendered as UI on the page.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Visible { get; }
Public Overrides ReadOnly Property Visible As Boolean
    Get

Return Value

Type: Boolean
true if the control is visible on the page; otherwise false.
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Methods

The ThumbnailStyle type exposes the following members.

Methods
 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Public method | BuildStyle | Returns a CSS string representing the style of an individual thumbnail based on its properties. It only includes properties that are not set to their default value.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Public method | CopyFromThumbnailStyle | This method copies the values from another ThumbnailStyle to this one
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Returns true if o is a ThumbnailStyle and has the same property values. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | A hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Public method | IsBlank | Returns true if all of the properties are set to empty strings and false otherwise.
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Top
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.BuildStyle Method

ThumbnailStyleBuildStyle Method

Returns a CSS string representing the style of an individual thumbnail based on its properties. It only includes properties that are not set to their default value.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BuildStyle()
Public Function BuildStyle As String

Return Value

Type: String
A CSS string that represents the style of the thumbnail.
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.CopyFromThumbnailStyle Method

ThumbnailStyleCopyFromThumbnailStyle Method

This method copies the values from another ThumbnailStyle to this one

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyFromThumbnailStyle(
    ThumbnailStyle ts
)
Public Sub CopyFromThumbnailStyle (
    ts As ThumbnailStyle
)

Parameters

ts
Type: Atalasoft.Imaging.WebControlsThumbnailStyle
ThumbnailStyle object to copy from
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.Equals Method

ThumbnailStyleEquals Method

Returns true if o is a ThumbnailStyle and has the same property values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
An object to compare this object to.

Return Value

Type: Boolean
True if the object passed in represents the same style as this object and false otherwise.
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.GetHashCode Method

ThumbnailStyleGetHashCode Method

A hash code for this object.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle.IsBlank Method

ThumbnailStyleIsBlank Method

Returns true if all of the properties are set to empty strings and false otherwise.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsBlank()
Public Function IsBlank As Boolean

Return Value

Type: Boolean
True if all of the properties are set to empty strings and false otherwise.
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


ThumbnailStyle Events

The ThumbnailStyle type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

ThumbnailStyle Class
Atalasoft.Imaging.WebControls Namespace


VisibilityStyle Enumeration

Controls the Visibility of the RubberBand class when the page loads.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum VisibilityStyle
Public Enumeration VisibilityStyle
Members
Member name | Description
Hidden | RubberBand is not visible.
Visible | RubberBand is visible.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace
Visibility Property


WebDocumentPageRotation Enumeration

Web Document page rotation state

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WebDocumentPageRotation
Public Enumeration WebDocumentPageRotation
Members
Member name | Description
None | Zero degrees rotation
Clockwise90 | Clockwise 90 degrees
Clockwise180 | Clockwise 180 degrees
Clockwise270 | Clockwise 270 degrees
CounterClockwise90 | Counter clockwise 90 degrees
CounterClockwise180 | Counter clockwise 180 degrees
CounterClockwise270 | Counter clockwise 270 degrees
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler Class

Web Handler used to handle requests from the WebDocumentViewer
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsWebDocumentRequestHandler

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebDocumentRequestHandler : IHttpHandler
Public Class WebDocumentRequestHandler
    Implements IHttpHandler

The WebDocumentRequestHandler type exposes the following members.

Constructors
 | Name | Description
Public method | WebDocumentRequestHandler | Initializes a new instance of the WebDocumentRequestHandler class.
Top
Properties
 | Name | Description
Public property | IsReusable | Gets a value indicating whether another request can use the IHttpHandler instance.
Public property | ReplaceFileExtensionOnSave | Gets or sets a value indicating for which files WDV should set extensions during document save operation.
Public property | ResponseCacheability | Gets or sets the Cache-Control header to one of the values of HttpCacheability
Public property | ResponseMaxAge | Gets or set a time span value for max-age HTTP header.
Public property | ResponseNoServerCaching | Gets or set a flag indicating whether or not stop all origin-server caching for the current response.
Public property | ResponseNoStore | Gets or set a flag indicating whether or not sets the Cache-Control: no-store HTTP header.
Public property | ResponseProxyMaxAge | Gets or set a time span value for s-maxage HTTP header.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationDataRequested | Called by the handler when a request has come from client side javascript, requesting annotation data. This subsequently fires the AnnotationDataRequested event.
Protected method | OnAnnotationStreamWritten | Called by the handler during a save event, right before the AnnotationStream is closed. This subsequently fires the AnnotationStreamWritten event.
Protected method | OnDocumentInfoRequested | Called by the handler when a request has come from client side javascript, requesting document info. This subsequently fires the DocumentInfoRequested event.
Protected method | OnDocumentSave | Called by the handler when a request to save the document has come from client side javascript. This subsequently fires the DocumentSave event.
Protected method | OnDocumentStreamWritten | Called by the handler during a save event, right before the DocumentStream is closed. This subsequently fires the DocumentStreamWritten event.
Protected method | OnImageRequested | Called by the handler when a request has come from client side javascript, requesting an image representing one page of the document. This subsequently fires the ImageRequested event.
Protected method | OnPageTextRequested | Raises the PageTextRequested event.
Protected method | OnPdfFormRequested | Called by the handler when a request has come from client side javascript, requesting PDF form fields. This subsequently fires the PdfFormRequested event.
Public method | ProcessRequest |
Public method | ReadScaledImage | Reads the given stream and attemps to use the codec's more efficient scaled reading (if available)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AnnotationDataRequested | Fires when annotation data has been requested by the client.
Public event | AnnotationsDataResponseSend | Fires when constructing response JSON for requesting annotations data operation.
Public event | AnnotationStreamWritten | Fires after the annotation data has been written to the annotation stream, but before it's closed.
Public event | DocumentInfoRequested | Fires when document info is requested from the client.
Public event | DocumentInfoRequestResponseSend | Fires when constructing response JSON for requesting document info operation.
Public event | DocumentSave | Fires when a document save request has been made from the client.
Public event | DocumentSaveResponseSend | Fires when constructing response JSON for saving document operation.
Public event | DocumentStreamWritten | Fires after the document has been written to the save stream, but before it's closed.
Public event | FileUpload | Fires when file upload request has been made from the client.
Public event | FileUploaded | Fires when file upload request has been processed.
Public event | FileUploadResponseSend | Fires when constructing response JSON for file upload request.
Public event | FormsDataResponseSend | Fires when constructing response JSON for requesting forms data operation.
Public event | ImageRequested | Fires when an image is requested from the client.
Public event | PageTextRequested | Occurs when page text data requested.
Public event | PageTextRequestResponseSend | Fires when constructing response JSON for requesting page text operation.
Public event | PageTextSearchResponseSend | Fires when constructing response JSON for searching text on a page operation.
Public event | PdfFormRequested | Fires when the PDF form fields are requested from the client.
Public event | ReleaseDocumentStream | Fires when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri event.
Public event | ReleasePageStream | Fires when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri event.
Public event | ResolveDocumentUri | Fires when a source document stream is requested while performing save operation.
Public event | ResolvePageUri | Fires when a source page stream is requested while performing save operation.
Top
Fields
Name | Description
Logger | The logger.
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler Constructor

Initializes a new instance of the WebDocumentRequestHandler class.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentRequestHandler()
Public Sub New
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler Properties

The WebDocumentRequestHandler type exposes the following members.

Properties
 | Name | Description
Public property | IsReusable | Gets a value indicating whether another request can use the IHttpHandler instance.
Public property | ReplaceFileExtensionOnSave | Gets or sets a value indicating for which files WDV should set extensions during document save operation.
Public property | ResponseCacheability | Gets or sets the Cache-Control header to one of the values of HttpCacheability
Public property | ResponseMaxAge | Gets or set a time span value for max-age HTTP header.
Public property | ResponseNoServerCaching | Gets or set a flag indicating whether or not stop all origin-server caching for the current response.
Public property | ResponseNoStore | Gets or set a flag indicating whether or not sets the Cache-Control: no-store HTTP header.
Public property | ResponseProxyMaxAge | Gets or set a time span value for s-maxage HTTP header.
Top
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.IsReusable Property

WebDocumentRequestHandlerIsReusable Property

Gets a value indicating whether another request can use the IHttpHandler instance.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReusable { get; }
Public ReadOnly Property IsReusable As Boolean
    Get

Return Value

Type: Boolean
true if the IHttpHandler instance is reusable; otherwise, false.

Implements

IHttpHandlerIsReusable
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ReplaceFileExtensionOnSave Property

WebDocumentRequestHandlerReplaceFileExtensionOnSave Property

Gets or sets a value indicating for which files WDV should set extensions during document save operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplaceFileExtension ReplaceFileExtensionOnSave { get; set; }
Public Property ReplaceFileExtensionOnSave As ReplaceFileExtension
    Get
    Set

Property Value

Type: ReplaceFileExtension
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResponseCacheability Property

WebDocumentRequestHandlerResponseCacheability Property

Gets or sets the Cache-Control header to one of the values of HttpCacheability

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HttpCacheability ResponseCacheability { get; set; }
Public Property ResponseCacheability As HttpCacheability
    Get
    Set

Property Value

Type: HttpCacheability
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResponseMaxAge Property

WebDocumentRequestHandlerResponseMaxAge Property

Gets or set a time span value for max-age HTTP header.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TimeSpan ResponseMaxAge { get; set; }
Public Property ResponseMaxAge As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResponseNoServerCaching Property

WebDocumentRequestHandlerResponseNoServerCaching Property

Gets or set a flag indicating whether or not stop all origin-server caching for the current response.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ResponseNoServerCaching { get; set; }
Public Property ResponseNoServerCaching As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResponseNoStore Property

WebDocumentRequestHandlerResponseNoStore Property

Gets or set a flag indicating whether or not sets the Cache-Control: no-store HTTP header.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ResponseNoStore { get; set; }
Public Property ResponseNoStore As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResponseProxyMaxAge Property

WebDocumentRequestHandlerResponseProxyMaxAge Property

Gets or set a time span value for s-maxage HTTP header.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TimeSpan ResponseProxyMaxAge { get; set; }
Public Property ResponseProxyMaxAge As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler Methods

The WebDocumentRequestHandler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAnnotationDataRequested | Called by the handler when a request has come from client side javascript, requesting annotation data. This subsequently fires the AnnotationDataRequested event.
Protected method | OnAnnotationStreamWritten | Called by the handler during a save event, right before the AnnotationStream is closed. This subsequently fires the AnnotationStreamWritten event.
Protected method | OnDocumentInfoRequested | Called by the handler when a request has come from client side javascript, requesting document info. This subsequently fires the DocumentInfoRequested event.
Protected method | OnDocumentSave | Called by the handler when a request to save the document has come from client side javascript. This subsequently fires the DocumentSave event.
Protected method | OnDocumentStreamWritten | Called by the handler during a save event, right before the DocumentStream is closed. This subsequently fires the DocumentStreamWritten event.
Protected method | OnImageRequested | Called by the handler when a request has come from client side javascript, requesting an image representing one page of the document. This subsequently fires the ImageRequested event.
Protected method | OnPageTextRequested | Raises the PageTextRequested event.
Protected method | OnPdfFormRequested | Called by the handler when a request has come from client side javascript, requesting PDF form fields. This subsequently fires the PdfFormRequested event.
Public method | ProcessRequest |
Public method | ReadScaledImage | Reads the given stream and attemps to use the codec's more efficient scaled reading (if available)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnAnnotationDataRequested Method

WebDocumentRequestHandlerOnAnnotationDataRequested Method

Called by the handler when a request has come from client side javascript, requesting annotation data. This subsequently fires the AnnotationDataRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationDataRequested(
    AnnotationDataRequestedEventArgs e
)
Protected Sub OnAnnotationDataRequested (
    e As AnnotationDataRequestedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsAnnotationDataRequestedEventArgs
AnnotationDataRequestedEventArgs for this request event
Remarks
This is not intended to be called manually, as a client request is needed in order for the handler to respond properly.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnAnnotationStreamWritten Method

WebDocumentRequestHandlerOnAnnotationStreamWritten Method

Called by the handler during a save event, right before the AnnotationStream is closed. This subsequently fires the AnnotationStreamWritten event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAnnotationStreamWritten(
    DocumentSaveEventArgs e
)
Protected Sub OnAnnotationStreamWritten (
    e As DocumentSaveEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
DocumentSaveEventArgs for this request event
Remarks
Only the AnnotationStream will be populated during this event,
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnDocumentInfoRequested Method

WebDocumentRequestHandlerOnDocumentInfoRequested Method

Called by the handler when a request has come from client side javascript, requesting document info. This subsequently fires the DocumentInfoRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnDocumentInfoRequested(
    DocumentInfoRequestedEventArgs e
)
Protected Sub OnDocumentInfoRequested (
    e As DocumentInfoRequestedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsDocumentInfoRequestedEventArgs
DocumentInfoRequestedEventArgs for this request event.
Remarks
This is not intended to be called manually, as a client request is needed in order for the handler to respond properly.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnDocumentSave Method

WebDocumentRequestHandlerOnDocumentSave Method

Called by the handler when a request to save the document has come from client side javascript. This subsequently fires the DocumentSave event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnDocumentSave(
    DocumentSaveEventArgs e
)
Protected Sub OnDocumentSave (
    e As DocumentSaveEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
DocumentSaveEventArgs for this request event.
Remarks
This is not intended to be called manually, as a client request is needed in order for the handler to respond properly.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnDocumentStreamWritten Method

WebDocumentRequestHandlerOnDocumentStreamWritten Method

Called by the handler during a save event, right before the DocumentStream is closed. This subsequently fires the DocumentStreamWritten event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnDocumentStreamWritten(
    DocumentSaveEventArgs e
)
Protected Sub OnDocumentStreamWritten (
    e As DocumentSaveEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
DocumentSaveEventArgs for this request event.
Remarks
Only the DocumentStream will be populated during this event.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnImageRequested Method

WebDocumentRequestHandlerOnImageRequested Method

Called by the handler when a request has come from client side javascript, requesting an image representing one page of the document. This subsequently fires the ImageRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnImageRequested(
    ImageRequestedEventArgs e
)
Protected Sub OnImageRequested (
    e As ImageRequestedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsImageRequestedEventArgs
ImageRequestedEventArgs for this request event
Remarks
This is not intended to be called manually, as a client request is needed in order for the handler to respond properly.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnPageTextRequested Method

WebDocumentRequestHandlerOnPageTextRequested Method

Raises the PageTextRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageTextRequested(
    PageTextRequestedEventArgs e
)
Protected Overridable Sub OnPageTextRequested (
    e As PageTextRequestedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsPageTextRequestedEventArgs
The PageTextRequestedEventArgs instance containing the event data.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.OnPdfFormRequested Method

WebDocumentRequestHandlerOnPdfFormRequested Method

Called by the handler when a request has come from client side javascript, requesting PDF form fields. This subsequently fires the PdfFormRequested event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnPdfFormRequested(
    PdfFormRequestedEventArgs e
)
Protected Sub OnPdfFormRequested (
    e As PdfFormRequestedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsPdfFormRequestedEventArgs
PdfFormRequestedEventArgs for this request event.
Remarks
This is not intended to be called manually, as a client request is needed in order for the handler to respond properly.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ProcessRequest Method

WebDocumentRequestHandlerProcessRequest Method

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ProcessRequest(
    HttpContext context
)
Public Sub ProcessRequest (
    context As HttpContext
)

Parameters

context
Type: System.WebHttpContext

Implements

IHttpHandlerProcessRequest(HttpContext)
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ReadScaledImage Method

WebDocumentRequestHandlerReadScaledImage Method

Reads the given stream and attemps to use the codec's more efficient scaled reading (if available)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ReadScaledImage(
    Stream stream,
    int frameIndex,
    double zoom
)
Public Function ReadScaledImage (
    stream As Stream,
    frameIndex As Integer,
    zoom As Double
) As AtalaImage

Parameters

stream
Type: System.IOStream
A seekable stream that contains one or more images.
frameIndex
Type: SystemInt32
Frame index of the desired image.
zoom
Type: SystemDouble
Zoom level to scale the image to.

Return Value

Type: AtalaImage
An AtalaImage scaled to the given zoom level.
Remarks
When using this method inside the OnImageRequestedEvent, the ImageRequestedEventArgs.AutoScale property will need to be set to false, or the image will be scaled twice.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler Events

The WebDocumentRequestHandler type exposes the following members.

Events
 | Name | Description
Public event | AnnotationDataRequested | Fires when annotation data has been requested by the client.
Public event | AnnotationsDataResponseSend | Fires when constructing response JSON for requesting annotations data operation.
Public event | AnnotationStreamWritten | Fires after the annotation data has been written to the annotation stream, but before it's closed.
Public event | DocumentInfoRequested | Fires when document info is requested from the client.
Public event | DocumentInfoRequestResponseSend | Fires when constructing response JSON for requesting document info operation.
Public event | DocumentSave | Fires when a document save request has been made from the client.
Public event | DocumentSaveResponseSend | Fires when constructing response JSON for saving document operation.
Public event | DocumentStreamWritten | Fires after the document has been written to the save stream, but before it's closed.
Public event | FileUpload | Fires when file upload request has been made from the client.
Public event | FileUploaded | Fires when file upload request has been processed.
Public event | FileUploadResponseSend | Fires when constructing response JSON for file upload request.
Public event | FormsDataResponseSend | Fires when constructing response JSON for requesting forms data operation.
Public event | ImageRequested | Fires when an image is requested from the client.
Public event | PageTextRequested | Occurs when page text data requested.
Public event | PageTextRequestResponseSend | Fires when constructing response JSON for requesting page text operation.
Public event | PageTextSearchResponseSend | Fires when constructing response JSON for searching text on a page operation.
Public event | PdfFormRequested | Fires when the PDF form fields are requested from the client.
Public event | ReleaseDocumentStream | Fires when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri event.
Public event | ReleasePageStream | Fires when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri event.
Public event | ResolveDocumentUri | Fires when a source document stream is requested while performing save operation.
Public event | ResolvePageUri | Fires when a source page stream is requested while performing save operation.
Top
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.AnnotationDataRequested Event

WebDocumentRequestHandlerAnnotationDataRequested Event

Fires when annotation data has been requested by the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationDataRequestedEventHandler AnnotationDataRequested
Public Event AnnotationDataRequested As AnnotationDataRequestedEventHandler

Value

Type: Atalasoft.Imaging.WebControlsAnnotationDataRequestedEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.AnnotationsDataResponseSend Event

WebDocumentRequestHandlerAnnotationsDataResponseSend Event

Fires when constructing response JSON for requesting annotations data operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler AnnotationsDataResponseSend
Public Event AnnotationsDataResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.AnnotationStreamWritten Event

WebDocumentRequestHandlerAnnotationStreamWritten Event

Fires after the annotation data has been written to the annotation stream, but before it's closed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DocumentSaveEventHandler AnnotationStreamWritten
Public Event AnnotationStreamWritten As DocumentSaveEventHandler

Value

Type: Atalasoft.Imaging.WebControlsDocumentSaveEventHandler
Remarks
Only the AnnotationStream will be populated during this event,
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.DocumentInfoRequested Event

WebDocumentRequestHandlerDocumentInfoRequested Event

Fires when document info is requested from the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DocumentInfoRequestedEventHandler DocumentInfoRequested
Public Event DocumentInfoRequested As DocumentInfoRequestedEventHandler

Value

Type: Atalasoft.Imaging.WebControlsDocumentInfoRequestedEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.DocumentInfoRequestResponseSend Event

WebDocumentRequestHandlerDocumentInfoRequestResponseSend Event

Fires when constructing response JSON for requesting document info operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler DocumentInfoRequestResponseSend
Public Event DocumentInfoRequestResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
Remarks
The data from this event can passed to 'annotationloaded' and 'formsloaded' client-side events, since Web Document Viewer can optimize its requests, and send one request to retrieve document information, annotations and forms.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.DocumentSave Event

WebDocumentRequestHandlerDocumentSave Event

Fires when a document save request has been made from the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DocumentSaveEventHandler DocumentSave
Public Event DocumentSave As DocumentSaveEventHandler

Value

Type: Atalasoft.Imaging.WebControlsDocumentSaveEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.DocumentSaveResponseSend Event

WebDocumentRequestHandlerDocumentSaveResponseSend Event

Fires when constructing response JSON for saving document operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler DocumentSaveResponseSend
Public Event DocumentSaveResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.DocumentStreamWritten Event

WebDocumentRequestHandlerDocumentStreamWritten Event

Fires after the document has been written to the save stream, but before it's closed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DocumentSaveEventHandler DocumentStreamWritten
Public Event DocumentStreamWritten As DocumentSaveEventHandler

Value

Type: Atalasoft.Imaging.WebControlsDocumentSaveEventHandler
Remarks
Only the DocumentStream will be populated during this event.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.FileUpload Event

WebDocumentRequestHandlerFileUpload Event

Fires when file upload request has been made from the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event FileUploadEventHandler FileUpload
Public Event FileUpload As FileUploadEventHandler

Value

Type: Atalasoft.Imaging.WebControlsFileUploadEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.FileUploaded Event

WebDocumentRequestHandlerFileUploaded Event

Fires when file upload request has been processed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event FileUploadedEventHandler FileUploaded
Public Event FileUploaded As FileUploadedEventHandler

Value

Type: Atalasoft.Imaging.WebControlsFileUploadedEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.FileUploadResponseSend Event

WebDocumentRequestHandlerFileUploadResponseSend Event

Fires when constructing response JSON for file upload request.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler FileUploadResponseSend
Public Event FileUploadResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.FormsDataResponseSend Event

WebDocumentRequestHandlerFormsDataResponseSend Event

Fires when constructing response JSON for requesting forms data operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler FormsDataResponseSend
Public Event FormsDataResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ImageRequested Event

WebDocumentRequestHandlerImageRequested Event

Fires when an image is requested from the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageRequestedEventHandler ImageRequested
Public Event ImageRequested As ImageRequestedEventHandler

Value

Type: Atalasoft.Imaging.WebControlsImageRequestedEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.PageTextRequested Event

WebDocumentRequestHandlerPageTextRequested Event

Occurs when page text data requested.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<PageTextRequestedEventArgs> PageTextRequested
Public Event PageTextRequested As EventHandler(Of PageTextRequestedEventArgs)

Value

Type: SystemEventHandlerPageTextRequestedEventArgs
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.PageTextRequestResponseSend Event

WebDocumentRequestHandlerPageTextRequestResponseSend Event

Fires when constructing response JSON for requesting page text operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler PageTextRequestResponseSend
Public Event PageTextRequestResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.PageTextSearchResponseSend Event

WebDocumentRequestHandlerPageTextSearchResponseSend Event

Fires when constructing response JSON for searching text on a page operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResponseSendEventHandler PageTextSearchResponseSend
Public Event PageTextSearchResponseSend As ResponseSendEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResponseSendEventHandler
Remarks
Custom data from this event can be handled by 'pagetextloaded' client-side event, when Web Document Viewer performs text search on pages that are not loaded yet. In this case viewer performs a server side search and returns its result alongside with page's text.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.PdfFormRequested Event

WebDocumentRequestHandlerPdfFormRequested Event

Fires when the PDF form fields are requested from the client.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PdfFormRequestedEventHandler PdfFormRequested
Public Event PdfFormRequested As PdfFormRequestedEventHandler

Value

Type: Atalasoft.Imaging.WebControlsPdfFormRequestedEventHandler
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ReleaseDocumentStream Event

WebDocumentRequestHandlerReleaseDocumentStream Event

Fires when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ResolveDocumentUriEventArgs> ReleaseDocumentStream
Public Event ReleaseDocumentStream As EventHandler(Of ResolveDocumentUriEventArgs)

Value

Type: SystemEventHandlerResolveDocumentUriEventArgs
Remarks
After document save operation it is necessary to release the obtained in ResolveDocumentUri event document streams. Fires once for each stream.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ReleasePageStream Event

WebDocumentRequestHandlerReleasePageStream Event

Fires when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ResolvePageUriEventArgs> ReleasePageStream
Public Event ReleasePageStream As EventHandler(Of ResolvePageUriEventArgs)

Value

Type: SystemEventHandlerResolvePageUriEventArgs
Remarks
After document save operation it is necessary to release the obtained in ResolvePageUri event page streams. Fires once for each stream.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResolveDocumentUri Event

WebDocumentRequestHandlerResolveDocumentUri Event

Fires when a source document stream is requested while performing save operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ResolveDocumentUriEventArgs> ResolveDocumentUri
Public Event ResolveDocumentUri As EventHandler(Of ResolveDocumentUriEventArgs)

Value

Type: SystemEventHandlerResolveDocumentUriEventArgs
Remarks
During document save it is necessary to get the source document pages to combine them into the destination stream.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.ResolvePageUri Event

WebDocumentRequestHandlerResolvePageUri Event

Fires when a source page stream is requested while performing save operation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ResolvePageUriEventArgs> ResolvePageUri
Public Event ResolvePageUri As EventHandler(Of ResolvePageUriEventArgs)

Value

Type: SystemEventHandlerResolvePageUriEventArgs
Remarks
During document save it is necessary to get the source document pages to combine them into the destination stream.
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler Fields

The WebDocumentRequestHandler type exposes the following members.

Fields
Name | Description
Logger | The logger.
Top
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebDocumentRequestHandler.Logger Field

WebDocumentRequestHandlerLogger Field

The logger.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected static Logger Logger
Protected Shared Logger As Logger

Field Value

Type: Logger
See Also

Reference

WebDocumentRequestHandler Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer Class

A scrollable, zoomable viewport for displaying and processing images server-side.

Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Atalasoft.Imaging.WebControlsWebViewerControl
Atalasoft.Imaging.WebControlsWebImageViewer
Atalasoft.Imaging.WebControls.AnnotationsWebAnnotationViewer

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebImageViewer : WebViewerControl
Public Class WebImageViewer
    Inherits WebViewerControl

The WebImageViewer type exposes the following members.

Constructors
 | Name | Description
Public method | WebImageViewer | Initializes a new instance of the WebImageViewer control.
Top
Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs. (Inherited from WebViewerControl.)
 | AntialiasDisplay | Gets or sets the quality of the scaled image.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes.
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Inherited from WebViewerControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension. (Inherited from WebViewerControl.)
Public property | BrowserFormat | Gets or sets the format of the images created for browser output. (Inherited from WebViewerControl.)
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled. (Inherited from WebViewerControl.)
Protected property | CacheImageUrl | Gets or sets a URL used to represent the lossless version of the ImageUrl.
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2. (Inherited from WebViewerControl.)
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache. (Inherited from WebViewerControl.)
Public property | Caption | Gets or sets the text to be included below the control. (Inherited from WebViewerControl.)
Public property | Centered | Gets or sets a value indicating if the content is centered in the control. (Inherited from WebViewerControl.)
Protected property | ChildContent | Gets or sets the child content. (Inherited from WebViewerControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from WebViewerControl.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts. (Inherited from WebViewerControl.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from WebViewerControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls. (Inherited from WebViewerControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path. (Inherited from WebViewerControl.)
Public property | CurrentPage | Gets a value indicating the current page of a multi-page image being viewed in this control.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport. (Inherited from WebViewerControl.)
Public property | Domain | Allows cross domain scripting for the specified domain. (Inherited from WebViewerControl.)
Public property | EnableClientEvents | Obsolete. Enables the usage of events coming from the client without postbacks. (Obsolete.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableServerAntialias | Obsolete. Enables server antialiasing for the FullClient ScrollbarType. (Obsolete.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element. (Inherited from WebViewerControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent. (Inherited from WebViewerControl.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Image | Gets or sets the current AtalaImage displayed in this control
Public property | ImageDisplayOrder | Defines the way tiles are loaded in the viewport. Using ImageDisplayOrder.Sequential will reduce performance, OnDemand is the most efficient.
Protected property | ImageInfo | Gets the image info
Public property | ImagePosition | A value indicating the position of the image relative to the top left position of the scrollport.
Protected property | ImageSource | Gets or sets the image source.
Protected property | ImageSourceDataUrl | Gets the image source URL.
Public property | ImageUrl | Gets or sets the location of an image to display in the WebImageViewer control.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time. (Inherited from WebViewerControl.)
Protected property | IsDirty | Gets or sets a value indicating that modifications have been made since the last save.
Protected property | IsDisposed | Gets a value indicating the object has been disposed. (Inherited from WebViewerControl.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post. (Inherited from WebViewerControl.)
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded. (Inherited from WebViewerControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed. (Inherited from WebViewerControl.)
Public property | MouseTool | Gets a value indicating the behavior of the mouse when interacting with the viewport.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table. (Inherited from WebViewerControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.) (Inherited from WebViewerControl.)
Protected property | PixelFormat | Gets the pixel format. (Overrides WebViewerControlPixelFormat.)
Public property | PreCacheTiles | A value from the PreCacheMode to set whether this control creates tiles in the cache or on demand. When set to Always, it creates tiles in the image cache, and when set to Never, it creates the tiles on demand. The value Always greatly increases panning speed and makes better use of memory, but can cause an initial delay.
 | RedosAvailable | Returns the number of Redos available from the cache.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath. (Inherited from WebViewerControl.)
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars. (Inherited from WebViewerControl.)
Protected property | ScrollImageUrl | Url used for holding the location to the image behind the scrollport
Public property | ScrollPosition | Gets or sets the scroll position.
Protected property | ScrollSize | Gets the scroll size.
Public property | Selection | Gets or sets the current RubberBand selection.
Public property | SessionId | Gets the session ID. (Inherited from WebViewerControl.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | TileSize | Gets or sets the size tiles. Smaller tiles on large images can create heavy server load. Minimum tile size is 256x256.
Public property | TitleBar | Gets or sets the text to be included above the control. (Inherited from WebViewerControl.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | UndosAvailable | Returns the number of Undos available from the cache.
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Inherited from WebViewerControl.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered. (Inherited from WebViewerControl.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from WebViewerControl.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Zoom | Gets or sets the zoom level of the image in this WebImageViewer control.
 | ZoomInOutPercentage | Gets or sets the percentage used to increase or decrease the zoom level when the zoom methods are used.
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag. (Inherited from WebViewerControl.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script. (Inherited from WebViewerControl.)
 | ApplyCommand | Applies an ImageCommand to the current image in order to process it.
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildCallbackPage | Builds a callback page.
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Gets the initial querystring for the iframe used for RemoteInvoke and PartialPost. (Overrides WebViewerControlBuildRemoteQuery.)
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts. (Inherited from WebViewerControl.)
Protected method | CacheImage | Saves the image to the file cache, and updates the expiration time
Protected method | CacheImage(ImageEncoder, String) | Saves the image to the file cache so the browser can view it
Protected method | CacheTiles | Saves tiles for the current image to the cache.
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level. (Inherited from WebViewerControl.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | ClearSerializedState | Clears the serialized state.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Overrides WebViewerControlCreateChildControls.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Protected method | DeserializeState | Deserializes the state.
Public method | DesignTime | Enters design-time mode. (Overrides WebViewerControlDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides WebViewerControlDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response. (Inherited from WebViewerControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format. (Inherited from WebViewerControl.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeString | Escapes a string. (Inherited from WebViewerControl.)
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively. (Inherited from WebViewerControl.)
Protected method | FixNumericalID | Fixes the numerical ID. (Inherited from WebViewerControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings (Inherited from WebViewerControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension. (Inherited from WebViewerControl.)
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension. (Inherited from WebViewerControl.)
Protected method | GetFormClientID | Gets the form client ID. (Inherited from WebViewerControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Reads hidden values. (Overrides WebViewerControlGetHiddenValues.)
Protected method | GetIdForSession | Gets the session ID. (Inherited from WebViewerControl.)
Protected method | GetMimeType | Gets the MIME content type of a file name. (Inherited from WebViewerControl.)
Protected method | GetObjectType | Gets the type of object. (Overrides WebViewerControlGetObjectType.)
Protected method | GetResourcePrefix | Get the prefix used for a specific kind of resource. (Overrides WebViewerControlGetResourcePrefix(ResourceType).)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleNonPageRequests | Handles non-page requests.
Protected method | HandleQueryString | Handles the query string. (Overrides WebViewerControlHandleQueryString.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads quesry string variables. (Overrides WebViewerControlLoadQueryStringValues(NameValueCollection).)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file (Inherited from WebViewerControl.)
Protected method | LogMessageToTile | Logs a message.
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path. (Inherited from WebViewerControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Protected method | OnChangedImage | Fires when pixel data in the current image changes without setting a new image.
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnImageChanged | Fires when the Image has changed.
Protected method | OnInit | Raises the Init event. (Overrides WebViewerControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Overrides WebViewerControlOnLoad(EventArgs).)
Protected method | OnNewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.)
Protected method | OnPageInit | Occurs on page initialization.
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides ControlOnPreRender(EventArgs).)
Protected method | OnProgress | Fires while an image is being processed, loaded, or saved.
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Protected method | OnResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize.
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Protected method | OnSelectionChanged | Fires when the selection has been moved or changed. (After PostBack)
Protected method | OnStreamTile | Fires when a tile is requested and allows the handler to provide it.
Protected method | OnStreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true.
Protected method | OnTileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Public method | Open(Stream) | Opens an image into the WebImageViewer control from an image file stream.
Public method | Open(String) | Opens an image into the WebImageViewer control from an image file.
 | Open(RandomAccessImageSource) | Opens a given image and sets it to the display.
Public method | Open(Stream, Int32) | Opens an image into the WebImageViewer control from an image file stream, specifying the frame index of a multi-page image.
Public method | Open(String, Int32) | Opens an image into the WebImageViewer control from an image file, specifying the frame index of a multi-page image.
 | Open(RandomAccessImageSource, Int32) | Opens a given image at a specified frame index and sets it to the display.
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | OpenScrollImageUrl | Opens the scroll image URL.
 | OpenUrl(String) | Opens an image into the WebImageViewer control from a URL or virtual path.
Public method | OpenUrl(String, Int32) | Opens an image into the WebImageViewer control from a URL or virtual path.
Protected method | OutputHiddenValues | Writes hidden values. (Overrides WebViewerControlOutputHiddenValues(HtmlTextWriter).)
Public method | Print |
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | Redo | Reverts the image inside the control back to the previously cached image, if an Undos have been done.
Public method | Redo(Int32) | Redoes the specified number of times.
Protected method | RegisterScriptInclude | Includes a script. (Inherited from WebViewerControl.)
Protected method | RegisterScripts | Registers the scripts. (Overrides WebViewerControlRegisterScripts.)
Protected method | ReleaseImage | Releases the image. (Overrides WebViewerControlReleaseImage(AtalaImage).)
Protected method | Remote | Performs a remote invocation. (Inherited from WebViewerControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebViewerControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name. (Inherited from WebViewerControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Save(Stream, ImageEncoder) | Saves the current image to a stream, with a specified ImageEncoder.
Public method | Save(String, ImageEncoder) | Saves the current image file, with a specified ImageEncoder.
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SerializeState | Serializes teh current state.
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
 | SetZoomMode | Zooms the image based on the given AutoZoomMode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Public method | Undo | Reverts the image inside the control back to the previously cached image.
Public method | Undo(Int32) | Undoes the specified number of times.
Public method | Update | Forces the current image to be cached.
Public method | UpdateClient | Forces the client side JavaScript to update
Protected method | UrlIsWebRequest | Determines if a URL is for a web request. (Inherited from WebViewerControl.)
Protected method | WatermarkImage | Applies a watermark to the image. (Inherited from WebViewerControl.)
Top
Events
 | Name | Description
Public event | CenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Public event | ChangedImage | Fires when pixel data in the current image changes without setting a new image.
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control. (Inherited from WebViewerControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | ImageChanged | Fires when the Image has changed.
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | NewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Progress | Fires while an image is being processed, loaded, or saved.
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Public event | ResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize.
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Public event | SelectionChanged | Fires when the selection has been moved or changed. (After PostBack)
Public event | StreamTile | Fires when a tile is requested and allows the handler to provide it.
Public event | StreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true.
Public event | TileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
Remarks
The WebImageViewer control is intended to be the primary control used for displaying images using DotImage in ASP.NET.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only. Use WebDocumentViewer control instead.
Examples

This example code demonstrates how to use the HtmlInputFile control to enable the client to select an image from the browser and load it into the WebImageViewer

Upload a file into the control C#
Copy
namespace WebControlsExamples
{
    public class UploadExample : System.Web.UI.Page
    {
        protected Atalasoft.Imaging.WebControls.WebImageViewer WebImageViewer1;
        protected System.Web.UI.WebControls.Button Button1;
        protected System.Web.UI.WebControls.Label Label1;
        protected System.Web.UI.HtmlControls.HtmlInputFile File1;

        private void Page_Load(object sender, System.EventArgs e)
        {
            // Put user code to initialize the page here
        }

        #region Web Form Designer generated code
        override protected void OnInit(EventArgs e)
        {
            //
            // CODEGEN: This call is required by the ASP.NET Web Form Designer.
            //
            InitializeComponent();
            base.OnInit(e);
        }

        /// <summary>
        /// Required method for Designer support - do not modify
        /// the contents of this method with the code editor.
        /// </summary>
        private void InitializeComponent()
        {
            this.Button1.Click += new System.EventHandler(this.Button1_Click);
            this.Load += new System.EventHandler(this.Page_Load);
        }
        #endregion

        private void Button1_Click(object sender, System.EventArgs e)
        {
            if (File1.PostedFile.FileName.Length != 0)
            {    // Get the relative server path to the Cache
                string pathToCache = Page.MapPath(System.Configuration.ConfigurationSettings.AppSettings["AtalasoftWebControls_Cache"]);

                // We prefix the file name with the Page.Session.SessionID so
                // that the CacheManager will delete it when the session expires
                string pathToFile = pathToCache + Page.Session.SessionID + "_" + System.IO.Path.GetFileName(File1.PostedFile.FileName);

                try
                {    // Save uploaded file to server cache.
                    File1.PostedFile.SaveAs(pathToFile);
                }
                catch (Exception exc)
                {    // Sends errors to a label
                    Label1.Text = "Error saving file <b>" + pathToFile + "</b><br>" + exc.Message;
                }

                try
                {    // Load the image in the WebImageViewer
                    WebImageViewer1.Open(pathToFile);
                }
                catch (Exception exc)
                {    // Sends errors to a label
                    Label1.Text = "Error opening file <b>" + pathToFile + "</b><br>" + exc.Message;
                }
            }
            else
                Label1.Text = "Error: You must specify a file name.";
        }
    }
}
Upload a file into the control Visual Basic
Copy
Public Class UploadExample
    Inherits System.Web.UI.Page
    Protected WithEvents WebImageViewer1 As Atalasoft.Imaging.WebControls.WebImageViewer
    Protected WithEvents Button1 As System.Web.UI.WebControls.Button
    Protected WithEvents Label1 As System.Web.UI.WebControls.Label
    Protected WithEvents File1 As System.Web.UI.HtmlControls.HtmlInputFile

#Region " Web Form Designer Generated Code "

    'This call is required by the Web Form Designer.
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()

    End Sub

    Private Sub Page_Init(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Init
        'CODEGEN: This method call is required by the Web Form Designer
        'Do not modify it using the code editor.
        InitializeComponent()
    End Sub

#End Region

    Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        'Put user code to initialize the page here
    End Sub

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        If File1.PostedFile.FileName.Length <> 0 Then
            ' Get the relative server path to the Cache
            Dim pathToCache As String = Page.MapPath(System.Configuration.ConfigurationSettings.AppSettings("AtalasoftWebControls_Cache"))

            ' We prefix the file name with the Page.Session.SessionID so
            ' that the CacheManager will delete it when the session expires
            Dim pathToFile As String = pathToCache + Page.Session.SessionID + "_" + System.IO.Path.GetFileName(File1.PostedFile.FileName)

            Try
                ' Save uploaded file to server cache.
                File1.PostedFile.SaveAs(pathToFile)
            Catch exc As Exception
                ' Sends errors to a label
                Label1.Text = "Error saving file <b>" + pathToFile + "</b><br>" + exc.Message
            End Try

            Try
                ' Load the image in the WebImageViewer
                WebImageViewer1.Open(pathToFile)
            Catch exc As Exception
                ' Sends errors to a label
                Label1.Text = "Error opening file <b>" + pathToFile + "</b><br>" + exc.Message
            End Try
        Else
            Label1.Text = "Error: You must specify a file name."
        End If
    End Sub

End Class
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebImageViewer Constructor

Initializes a new instance of the WebImageViewer control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebImageViewer()
Public Sub New
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer Properties

The WebImageViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs. (Inherited from WebViewerControl.)
 | AntialiasDisplay | Gets or sets the quality of the scaled image.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes.
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Inherited from WebViewerControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension. (Inherited from WebViewerControl.)
Public property | BrowserFormat | Gets or sets the format of the images created for browser output. (Inherited from WebViewerControl.)
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled. (Inherited from WebViewerControl.)
Protected property | CacheImageUrl | Gets or sets a URL used to represent the lossless version of the ImageUrl.
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2. (Inherited from WebViewerControl.)
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache. (Inherited from WebViewerControl.)
Public property | Caption | Gets or sets the text to be included below the control. (Inherited from WebViewerControl.)
Public property | Centered | Gets or sets a value indicating if the content is centered in the control. (Inherited from WebViewerControl.)
Protected property | ChildContent | Gets or sets the child content. (Inherited from WebViewerControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from WebViewerControl.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts. (Inherited from WebViewerControl.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from WebViewerControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls. (Inherited from WebViewerControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path. (Inherited from WebViewerControl.)
Public property | CurrentPage | Gets a value indicating the current page of a multi-page image being viewed in this control.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport. (Inherited from WebViewerControl.)
Public property | Domain | Allows cross domain scripting for the specified domain. (Inherited from WebViewerControl.)
Public property | EnableClientEvents | Obsolete. Enables the usage of events coming from the client without postbacks. (Obsolete.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableServerAntialias | Obsolete. Enables server antialiasing for the FullClient ScrollbarType. (Obsolete.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element. (Inherited from WebViewerControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent. (Inherited from WebViewerControl.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Image | Gets or sets the current AtalaImage displayed in this control
Public property | ImageDisplayOrder | Defines the way tiles are loaded in the viewport. Using ImageDisplayOrder.Sequential will reduce performance, OnDemand is the most efficient.
Protected property | ImageInfo | Gets the image info
Public property | ImagePosition | A value indicating the position of the image relative to the top left position of the scrollport.
Protected property | ImageSource | Gets or sets the image source.
Protected property | ImageSourceDataUrl | Gets the image source URL.
Public property | ImageUrl | Gets or sets the location of an image to display in the WebImageViewer control.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time. (Inherited from WebViewerControl.)
Protected property | IsDirty | Gets or sets a value indicating that modifications have been made since the last save.
Protected property | IsDisposed | Gets a value indicating the object has been disposed. (Inherited from WebViewerControl.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post. (Inherited from WebViewerControl.)
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded. (Inherited from WebViewerControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed. (Inherited from WebViewerControl.)
Public property | MouseTool | Gets a value indicating the behavior of the mouse when interacting with the viewport.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table. (Inherited from WebViewerControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.) (Inherited from WebViewerControl.)
Protected property | PixelFormat | Gets the pixel format. (Overrides WebViewerControlPixelFormat.)
Public property | PreCacheTiles | A value from the PreCacheMode to set whether this control creates tiles in the cache or on demand. When set to Always, it creates tiles in the image cache, and when set to Never, it creates the tiles on demand. The value Always greatly increases panning speed and makes better use of memory, but can cause an initial delay.
 | RedosAvailable | Returns the number of Redos available from the cache.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath. (Inherited from WebViewerControl.)
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars. (Inherited from WebViewerControl.)
Protected property | ScrollImageUrl | Url used for holding the location to the image behind the scrollport
Public property | ScrollPosition | Gets or sets the scroll position.
Protected property | ScrollSize | Gets the scroll size.
Public property | Selection | Gets or sets the current RubberBand selection.
Public property | SessionId | Gets the session ID. (Inherited from WebViewerControl.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | TileSize | Gets or sets the size tiles. Smaller tiles on large images can create heavy server load. Minimum tile size is 256x256.
Public property | TitleBar | Gets or sets the text to be included above the control. (Inherited from WebViewerControl.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | UndosAvailable | Returns the number of Undos available from the cache.
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Inherited from WebViewerControl.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered. (Inherited from WebViewerControl.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from WebViewerControl.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Zoom | Gets or sets the zoom level of the image in this WebImageViewer control.
 | ZoomInOutPercentage | Gets or sets the percentage used to increase or decrease the zoom level when the zoom methods are used.
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.AntialiasDisplay Property

WebImageViewerAntialiasDisplay Property

Gets or sets the quality of the scaled image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AntialiasDisplayMode AntialiasDisplay { get; set; }
Public Property AntialiasDisplay As AntialiasDisplayMode
    Get
    Set

Property Value

Type: AntialiasDisplayMode
The AntialiasDisplayMode that indicates the behavior of the display when the image is scaled at different zoom levels.
Remarks

Setting this property to ScaleToGray will cause binary images to be scaled to gray as it is resized. This will increase the readability of zoomed out images, but cause the streaming file size of PNG images to increase slightly.

Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
Examples
C#
Copy
myWebImageViewer.AntialiasDisplay = AntialiasDisplayMode.ReductionOnly;
Visual Basic
Copy
myWebImageViewer.AntialiasDisplay = AntialiasDisplayMode.ReductionOnly
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.AutoZoom Property

WebImageViewerAutoZoom Property

Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoZoomMode AutoZoom { get; set; }
Public Property AutoZoom As AutoZoomMode
    Get
    Set

Property Value

Type: AutoZoomMode
The %Atalasoft.dotImage.WebControls~Atalasoft.Imaging.WebControls.AutoZoomMode% indicating how the image should be zoomed as the control is resized or the image size changes.
Remarks
AutoZoom will override the Zoom property. It can be used to best fit the image, scale to width, or scale to height.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
Examples
C#
Copy
myWebImageViewer.AutoZoom = AutoZoomMode.BestFit;
Visual Basic
Copy
myWebImageViewer.AutoZoom = AutoZoomMode.BestFit
Examples
C#
Copy
myWebImageViewer.AutoZoom = AutoZoomMode.BestFit;
Visual Basic
Copy
myWebImageViewer.AutoZoom = AutoZoomMode.BestFit
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CacheImageUrl Property

WebImageViewerCacheImageUrl Property

Gets or sets a URL used to represent the lossless version of the ImageUrl.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string CacheImageUrl { get; set; }
Protected Property CacheImageUrl As String
    Get
    Set

Property Value

Type: String
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CurrentPage Property

WebImageViewerCurrentPage Property

Gets a value indicating the current page of a multi-page image being viewed in this control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentPage { get; }
Public ReadOnly Property CurrentPage As Integer
    Get

Property Value

Type: Int32
An integer value indicating the current page of the control.
Remarks
This only returns the page number that was opened by the control. If the image is modified in any way, the page gets set to 1, because the control creates a new image every time something is processed. To display a particular page in a multipage image, use the Open(RandomAccessImageSource) or OpenUrl(String) methods.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.EnableClientEvents Property

WebImageViewerEnableClientEvents Property

Note: This API is now obsolete.

Enables the usage of events coming from the client without postbacks. (Obsolete.)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is no longer needed, all server side events get fired without this property")]
public bool EnableClientEvents { get; }
<ObsoleteAttribute("This property is no longer needed, all server side events get fired without this property")>
Public ReadOnly Property EnableClientEvents As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.EnableServerAntialias Property

WebImageViewerEnableServerAntialias Property

Note: This API is now obsolete.

Enables server antialiasing for the FullClient ScrollbarType. (Obsolete.)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is no longer needed, all antialias operations are now done on the server automatically")]
public bool EnableServerAntialias { get; }
<ObsoleteAttribute("This property is no longer needed, all antialias operations are now done on the server automatically")>
Public ReadOnly Property EnableServerAntialias As Boolean
    Get

Property Value

Type: Boolean
Remarks
Antialias operations will be processed by the server while using ScrollbarType FullClient. Default value is false, true will decrease performance.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Image Property

WebImageViewerImage Property

Gets or sets the current AtalaImage displayed in this control

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage Image { get; set; }
Public Overridable Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The current AtalaImage in the control.
Remarks

Using this property directly will cache an extra copy of the incoming image, so that it can be reloaded upon postback. If the location of the image can be expressed in Url form, the recommended method of setting this property is by using OpenUrl(String).

Setting any of this property's members directly will not automatically update the control. Use the Update method to update the image. Using ApplyCommand(ImageCommand) will automatically update the image.

Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
Examples
C#
Copy
myWebImageViewer.Image = new AtalaImage("C:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Image = new AtalaImage("C:\\TestImages\\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Image = new AtalaImage("C:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Image = new AtalaImage("C:\\TestImages\\myTestImage.tif")
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImageDisplayOrder Property

WebImageViewerImageDisplayOrder Property

Defines the way tiles are loaded in the viewport. Using ImageDisplayOrder.Sequential will reduce performance, OnDemand is the most efficient.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageDisplayOrder ImageDisplayOrder { get; set; }
Public Property ImageDisplayOrder As ImageDisplayOrder
    Get
    Set

Property Value

Type: ImageDisplayOrder
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImageInfo Property

WebImageViewerImageInfo Property

Gets the image info

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageInfo ImageInfo { get; }
Protected ReadOnly Property ImageInfo As ImageInfo
    Get

Property Value

Type: ImageInfo
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImagePosition Property

WebImageViewerImagePosition Property

A value indicating the position of the image relative to the top left position of the scrollport.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ImagePosition { get; set; }
Public Property ImagePosition As Point
    Get
    Set

Property Value

Type: Point
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImageSource Property

WebImageViewerImageSource Property

Gets or sets the image source.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RandomAccessImageSource ImageSource { get; set; }
Protected Property ImageSource As RandomAccessImageSource
    Get
    Set

Property Value

Type: RandomAccessImageSource
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImageSourceDataUrl Property

WebImageViewerImageSourceDataUrl Property

Gets the image source URL.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string ImageSourceDataUrl { get; }
Protected ReadOnly Property ImageSourceDataUrl As String
    Get

Property Value

Type: String
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImageUrl Property

WebImageViewerImageUrl Property

Gets or sets the location of an image to display in the WebImageViewer control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageUrl { get; set; }
Public Property ImageUrl As String
    Get
    Set

Property Value

Type: String
The location of an image to display in the WebImageViewer control.
Remarks
This property is used to set the image in design time, and automatically load it into the WebImageViewer control when the application starts. As long as the path is correct, the image will display properly. This will not copy the image, it will only send the location of the image to the OpenUrl(String) method.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.IsDirty Property

WebImageViewerIsDirty Property

Gets or sets a value indicating that modifications have been made since the last save.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsDirty { get; set; }
Protected Property IsDirty As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.MouseTool Property

WebImageViewerMouseTool Property

Gets a value indicating the behavior of the mouse when interacting with the viewport.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual MouseTool MouseTool { get; }
Public Overridable ReadOnly Property MouseTool As MouseTool
    Get

Property Value

Type: MouseTool
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.PixelFormat Property

WebImageViewerPixelFormat Property

Gets the pixel format.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PixelFormat PixelFormat { get; }
Protected Overrides ReadOnly Property PixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.PreCacheTiles Property

WebImageViewerPreCacheTiles Property

A value from the PreCacheMode to set whether this control creates tiles in the cache or on demand. When set to Always, it creates tiles in the image cache, and when set to Never, it creates the tiles on demand. The value Always greatly increases panning speed and makes better use of memory, but can cause an initial delay.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PreCacheMode PreCacheTiles { get; set; }
Public Property PreCacheTiles As PreCacheMode
    Get
    Set

Property Value

Type: PreCacheMode
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.RedosAvailable Property

WebImageViewerRedosAvailable Property

Returns the number of Redos available from the cache.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RedosAvailable { get; }
Public ReadOnly Property RedosAvailable As Integer
    Get

Property Value

Type: Int32
A value indicating how many redos are available in the cache.
Remarks
This value is only accurate after PreRender event, and should only be used for cosmetic purposes in the Render event.
Examples

This example demonstrates how to use the RedosAvailable property in conjunction with a button control.

Redos using a button. C#
Copy
// We override Render because it is the only time this value is valid.
protected override void Render(HtmlTextWriter writer)
{
    if (this.WebImageViewer1.RedosAvailable < 1)
        this.Button1.Enabled = false;
    else
        this.Button1.Enabled = true;

    base.Render (writer);
}

// Button event handler
private void Button1_Click(object sender, System.EventArgs e)
{
    this.WebImageViewer1.Redo();
}
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ScrollImageUrl Property

WebImageViewerScrollImageUrl Property

Url used for holding the location to the image behind the scrollport

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string ScrollImageUrl { get; set; }
Protected Property ScrollImageUrl As String
    Get
    Set

Property Value

Type: String
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ScrollPosition Property

WebImageViewerScrollPosition Property

Gets or sets the scroll position.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; set; }
Public Property ScrollPosition As Point
    Get
    Set

Property Value

Type: Point
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ScrollSize Property

WebImageViewerScrollSize Property

Gets the scroll size.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Size ScrollSize { get; }
Protected ReadOnly Property ScrollSize As Size
    Get

Property Value

Type: Size
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Selection Property

WebImageViewerSelection Property

Gets or sets the current RubberBand selection.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberBand Selection { get; }
Public ReadOnly Property Selection As RubberBand
    Get

Property Value

Type: RubberBand
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.TileSize Property

WebImageViewerTileSize Property

Gets or sets the size tiles. Smaller tiles on large images can create heavy server load. Minimum tile size is 256x256.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size TileSize { get; set; }
Public Property TileSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.UndosAvailable Property

WebImageViewerUndosAvailable Property

Returns the number of Undos available from the cache.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndosAvailable { get; }
Public ReadOnly Property UndosAvailable As Integer
    Get

Property Value

Type: Int32
A value indicating how many undos are available in the cache.
Remarks
This value is only accurate after PreRender event, and should only be used for cosmetic purposes in the Render event.
Examples

This example demonstrates how to use the UndosAvailable property in conjunction with a button control.

Undos with a button C#
Copy
// We override Render because it is the only time this value is valid.
protected override void Render(HtmlTextWriter writer)
{
    if (this.WebImageViewer1.UndosAvailable < 1)
        this.Button1.Enabled = false;
    else
        this.Button1.Enabled = true;

    base.Render (writer);
}

// Button event handler
private void Button1_Click(object sender, System.EventArgs e)
{
    this.WebImageViewer1.Undo();
}
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Zoom Property

WebImageViewerZoom Property

Gets or sets the zoom level of the image in this WebImageViewer control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
A double value indicating the zoom level of the image in the view area. Default is 1.
Remarks
Setting this property to a value while the AutoZoom is set to anything besides AutoZoom will have no effect.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
Examples
C#
Copy
myWebImageViewer.Zoom = 3.5;
Visual Basic
Copy
myWebImageViewer.Zoom = 3.5
Examples
C#
Copy
myWebImageViewer.Zoom = 3.5;
Visual Basic
Copy
myWebImageViewer.Zoom = 3.5
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ZoomInOutPercentage Property

WebImageViewerZoomInOutPercentage Property

Gets or sets the percentage used to increase or decrease the zoom level when the zoom methods are used.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ZoomInOutPercentage { get; set; }
Public Property ZoomInOutPercentage As Integer
    Get
    Set

Property Value

Type: Int32
An integer value indicating the percentage to increase or decrease the Zoom level when the zoom MouseTool are used.
Remarks
Valid values are from 1 to 100. Default is 30.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
Examples
C#
Copy
myWebImageViewer.ZoomInOutPercentage = 50;
Visual Basic
Copy
myWebImageViewer.ZoomInOutPercentage = 50
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer Methods

The WebImageViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag. (Inherited from WebViewerControl.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script. (Inherited from WebViewerControl.)
 | ApplyCommand | Applies an ImageCommand to the current image in order to process it.
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildCallbackPage | Builds a callback page.
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Gets the initial querystring for the iframe used for RemoteInvoke and PartialPost. (Overrides WebViewerControlBuildRemoteQuery.)
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts. (Inherited from WebViewerControl.)
Protected method | CacheImage | Saves the image to the file cache, and updates the expiration time
Protected method | CacheImage(ImageEncoder, String) | Saves the image to the file cache so the browser can view it
Protected method | CacheTiles | Saves tiles for the current image to the cache.
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level. (Inherited from WebViewerControl.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | ClearSerializedState | Clears the serialized state.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Overrides WebViewerControlCreateChildControls.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Protected method | DeserializeState | Deserializes the state.
Public method | DesignTime | Enters design-time mode. (Overrides WebViewerControlDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides WebViewerControlDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response. (Inherited from WebViewerControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format. (Inherited from WebViewerControl.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeString | Escapes a string. (Inherited from WebViewerControl.)
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively. (Inherited from WebViewerControl.)
Protected method | FixNumericalID | Fixes the numerical ID. (Inherited from WebViewerControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings (Inherited from WebViewerControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension. (Inherited from WebViewerControl.)
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension. (Inherited from WebViewerControl.)
Protected method | GetFormClientID | Gets the form client ID. (Inherited from WebViewerControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Reads hidden values. (Overrides WebViewerControlGetHiddenValues.)
Protected method | GetIdForSession | Gets the session ID. (Inherited from WebViewerControl.)
Protected method | GetMimeType | Gets the MIME content type of a file name. (Inherited from WebViewerControl.)
Protected method | GetObjectType | Gets the type of object. (Overrides WebViewerControlGetObjectType.)
Protected method | GetResourcePrefix | Get the prefix used for a specific kind of resource. (Overrides WebViewerControlGetResourcePrefix(ResourceType).)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleNonPageRequests | Handles non-page requests.
Protected method | HandleQueryString | Handles the query string. (Overrides WebViewerControlHandleQueryString.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads quesry string variables. (Overrides WebViewerControlLoadQueryStringValues(NameValueCollection).)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file (Inherited from WebViewerControl.)
Protected method | LogMessageToTile | Logs a message.
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path. (Inherited from WebViewerControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Protected method | OnChangedImage | Fires when pixel data in the current image changes without setting a new image.
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnImageChanged | Fires when the Image has changed.
Protected method | OnInit | Raises the Init event. (Overrides WebViewerControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Overrides WebViewerControlOnLoad(EventArgs).)
Protected method | OnNewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.)
Protected method | OnPageInit | Occurs on page initialization.
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides ControlOnPreRender(EventArgs).)
Protected method | OnProgress | Fires while an image is being processed, loaded, or saved.
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Protected method | OnResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize.
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Protected method | OnSelectionChanged | Fires when the selection has been moved or changed. (After PostBack)
Protected method | OnStreamTile | Fires when a tile is requested and allows the handler to provide it.
Protected method | OnStreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true.
Protected method | OnTileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Public method | Open(Stream) | Opens an image into the WebImageViewer control from an image file stream.
Public method | Open(String) | Opens an image into the WebImageViewer control from an image file.
 | Open(RandomAccessImageSource) | Opens a given image and sets it to the display.
Public method | Open(Stream, Int32) | Opens an image into the WebImageViewer control from an image file stream, specifying the frame index of a multi-page image.
Public method | Open(String, Int32) | Opens an image into the WebImageViewer control from an image file, specifying the frame index of a multi-page image.
 | Open(RandomAccessImageSource, Int32) | Opens a given image at a specified frame index and sets it to the display.
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | OpenScrollImageUrl | Opens the scroll image URL.
 | OpenUrl(String) | Opens an image into the WebImageViewer control from a URL or virtual path.
Public method | OpenUrl(String, Int32) | Opens an image into the WebImageViewer control from a URL or virtual path.
Protected method | OutputHiddenValues | Writes hidden values. (Overrides WebViewerControlOutputHiddenValues(HtmlTextWriter).)
Public method | Print |
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | Redo | Reverts the image inside the control back to the previously cached image, if an Undos have been done.
Public method | Redo(Int32) | Redoes the specified number of times.
Protected method | RegisterScriptInclude | Includes a script. (Inherited from WebViewerControl.)
Protected method | RegisterScripts | Registers the scripts. (Overrides WebViewerControlRegisterScripts.)
Protected method | ReleaseImage | Releases the image. (Overrides WebViewerControlReleaseImage(AtalaImage).)
Protected method | Remote | Performs a remote invocation. (Inherited from WebViewerControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebViewerControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name. (Inherited from WebViewerControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Save(Stream, ImageEncoder) | Saves the current image to a stream, with a specified ImageEncoder.
Public method | Save(String, ImageEncoder) | Saves the current image file, with a specified ImageEncoder.
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SerializeState | Serializes teh current state.
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
 | SetZoomMode | Zooms the image based on the given AutoZoomMode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Public method | Undo | Reverts the image inside the control back to the previously cached image.
Public method | Undo(Int32) | Undoes the specified number of times.
Public method | Update | Forces the current image to be cached.
Public method | UpdateClient | Forces the client side JavaScript to update
Protected method | UrlIsWebRequest | Determines if a URL is for a web request. (Inherited from WebViewerControl.)
Protected method | WatermarkImage | Applies a watermark to the image. (Inherited from WebViewerControl.)
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ApplyCommand Method

WebImageViewerApplyCommand Method

Applies an ImageCommand to the current image in order to process it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command
)
Public Sub ApplyCommand (
    command As ImageCommand
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The ImageCommand to apply to the image.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.BuildCallbackPage Method

WebImageViewerBuildCallbackPage Method

Builds a callback page.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual CallbackBuilder BuildCallbackPage()
Protected Overridable Function BuildCallbackPage As CallbackBuilder

Return Value

Type: CallbackBuilder
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.BuildRemoteQuery Method

WebImageViewerBuildRemoteQuery Method

Gets the initial querystring for the iframe used for RemoteInvoke and PartialPost.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string BuildRemoteQuery()
Protected Overrides Function BuildRemoteQuery As String

Return Value

Type: String
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CacheImage Method

WebImageViewerCacheImage Method

Overload List
 | Name | Description
Protected method | CacheImage | Saves the image to the file cache, and updates the expiration time
Protected method | CacheImage(ImageEncoder, String) | Saves the image to the file cache so the browser can view it
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CacheImage Method

WebImageViewerCacheImage Method

Saves the image to the file cache, and updates the expiration time

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void CacheImage()
Protected Overridable Sub CacheImage
See Also

Reference

WebImageViewer Class
CacheImage Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CacheImage Method (ImageEncoder, String)

WebImageViewerCacheImage Method (ImageEncoder, String)

Saves the image to the file cache so the browser can view it

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void CacheImage(
    ImageEncoder outputImageFormat,
    string outputImageExtension
)
Protected Overridable Sub CacheImage (
    outputImageFormat As ImageEncoder,
    outputImageExtension As String
)

Parameters

outputImageFormat
Type: Atalasoft.Imaging.CodecImageEncoder
outputImageExtension
Type: SystemString
See Also

Reference

WebImageViewer Class
CacheImage Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CacheTiles Method

WebImageViewerCacheTiles Method

Saves tiles for the current image to the cache.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void CacheTiles()
Protected Sub CacheTiles
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ClearSerializedState Method

WebImageViewerClearSerializedState Method

Clears the serialized state.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ClearSerializedState()
Protected Overridable Sub ClearSerializedState
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.CreateChildControls Method

WebImageViewerCreateChildControls Method

Add the child controls to the container, sizing it to the User's specifications.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.DeserializeState Method

WebImageViewerDeserializeState Method

Deserializes the state.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DeserializeState()
Protected Overridable Sub DeserializeState
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.DesignTime Method

WebImageViewerDesignTime Method

Overload List
 | Name | Description
Public method | DesignTime | Enters design-time mode. (Overrides WebViewerControlDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.DesignTime Method

WebImageViewerDesignTime Method

Enters design-time mode.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void DesignTime()
Public Overrides Sub DesignTime
See Also

Reference

WebImageViewer Class
DesignTime Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.DisposeManagedResources Method

WebImageViewerDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.GetHiddenValues Method

WebImageViewerGetHiddenValues Method

Reads hidden values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void GetHiddenValues()
Protected Overrides Sub GetHiddenValues
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.GetObjectType Method

WebImageViewerGetObjectType Method

Gets the type of object.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Type GetObjectType()
Protected Overrides Function GetObjectType As Type

Return Value

Type: Type
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.GetResourcePrefix Method

WebImageViewerGetResourcePrefix Method

Get the prefix used for a specific kind of resource.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string GetResourcePrefix(
    ResourceType rt
)
Protected Overrides Function GetResourcePrefix (
    rt As ResourceType
) As String

Parameters

rt
Type: Atalasoft.Imaging.WebControlsResourceType

Return Value

Type: String
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.HandleNonPageRequests Method

WebImageViewerHandleNonPageRequests Method

Handles non-page requests.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void HandleNonPageRequests()
Protected Overridable Sub HandleNonPageRequests
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.HandleQueryString Method

WebImageViewerHandleQueryString Method

Handles the query string.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void HandleQueryString()
Protected Overrides Sub HandleQueryString
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.LoadQueryStringValues Method

WebImageViewerLoadQueryStringValues Method

Loads quesry string variables.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LoadQueryStringValues(
    NameValueCollection clientParams
)
Protected Overrides Sub LoadQueryStringValues (
    clientParams As NameValueCollection
)

Parameters

clientParams
Type: System.Collections.SpecializedNameValueCollection
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.LogMessageToTile Method

WebImageViewerLogMessageToTile Method

Logs a message.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void LogMessageToTile(
    Point pos,
    Size streamViewSize,
    string errMsg,
    string stackTrace,
    string targetSite
)
Protected Sub LogMessageToTile (
    pos As Point,
    streamViewSize As Size,
    errMsg As String,
    stackTrace As String,
    targetSite As String
)

Parameters

pos
Type: System.DrawingPoint
streamViewSize
Type: System.DrawingSize
errMsg
Type: SystemString
stackTrace
Type: SystemString
targetSite
Type: SystemString
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnChangedImage Method

WebImageViewerOnChangedImage Method

Fires when pixel data in the current image changes without setting a new image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnChangedImage(
    ImageEventArgs e
)
Protected Sub OnChangedImage (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnImageChanged Method

WebImageViewerOnImageChanged Method

Fires when the Image has changed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageChanged(
    EventArgs e
)
Protected Overridable Sub OnImageChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnInit Method

WebImageViewerOnInit Method

Raises the Init event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnLoad Method

WebImageViewerOnLoad Method

Raises the Load event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs object that contains the event data.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnNewImage Method

WebImageViewerOnNewImage Method

Note: This API is now obsolete.

Fires when this Workspace is set to a new current image. (Obsolete.)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This event may be removed from future versions.  Use the ChangedImage event instead.",
    false)]
protected void OnNewImage(
    ImageEventArgs e
)
<ObsoleteAttribute("This event may be removed from future versions.  Use the ChangedImage event instead.",
    false)>
Protected Sub OnNewImage (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnPageInit Method

WebImageViewerOnPageInit Method

Occurs on page initialization.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageInit(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnPageInit (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnPreRender Method

WebImageViewerOnPreRender Method

Raises the PreRender event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnProgress Method

WebImageViewerOnProgress Method

Fires while an image is being processed, loaded, or saved.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnProgress(
    ProgressEventArgs e
)
Protected Sub OnProgress (
    e As ProgressEventArgs
)

Parameters

e
Type: Atalasoft.ImagingProgressEventArgs
Remarks
Handle this event to show a progressbar or to cancel the operation while in progress.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnResizeImageForZoom Method

WebImageViewerOnResizeImageForZoom Method

Fires when the control is going to resize an image to give the user a chance to resize.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnResizeImageForZoom(
    ResizeImageForZoomEventArgs e
)
Protected Sub OnResizeImageForZoom (
    e As ResizeImageForZoomEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsResizeImageForZoomEventArgs
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnSelectionChanged Method

WebImageViewerOnSelectionChanged Method

Fires when the selection has been moved or changed. (After PostBack)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectionChanged(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnStreamTile Method

WebImageViewerOnStreamTile Method

Fires when a tile is requested and allows the handler to provide it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnStreamTile(
    WebImageViewerStreamTileArgs e
)
Protected Overridable Sub OnStreamTile (
    e As WebImageViewerStreamTileArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsWebImageViewerStreamTileArgs
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnStreamViewImage Method

WebImageViewerOnStreamViewImage Method

Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnStreamViewImage(
    EventArgs e
)
Protected Overridable Sub OnStreamViewImage (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
Remarks

Since this event is triggered by a query string GET from the browser, there are a limited number of properties that contain the current state. Properties that are not in this list will contain the initial values that were set in the property grid and in the Page's Onload event. Valid properties include:

  • AntialiasDisplay
  • CurrentPage
  • Image
  • ImageUrl
  • Zoom

Properties that are not in this list will contain the initial values that were set in the property grid and in the Page's Onload event.

Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OnTileStreamed Method

WebImageViewerOnTileStreamed Method

Fires when a tile has been streamed to the response and allows the handler to cache it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnTileStreamed(
    WebImageViewerStreamTileArgs e
)
Protected Overridable Sub OnTileStreamed (
    e As WebImageViewerStreamTileArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsWebImageViewerStreamTileArgs
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method

WebImageViewerOpen Method

Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Overload List
 | Name | Description
Public method | Open(Stream) | Opens an image into the WebImageViewer control from an image file stream.
Public method | Open(String) | Opens an image into the WebImageViewer control from an image file.
 | Open(RandomAccessImageSource) | Opens a given image and sets it to the display.
Public method | Open(Stream, Int32) | Opens an image into the WebImageViewer control from an image file stream, specifying the frame index of a multi-page image.
Public method | Open(String, Int32) | Opens an image into the WebImageViewer control from an image file, specifying the frame index of a multi-page image.
 | Open(RandomAccessImageSource, Int32) | Opens a given image at a specified frame index and sets it to the display.
Top
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
Examples
C#
Copy
myWebImageViewer.Open("c:\\TestImages\\myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.Open("c:\TestImages\myTestImage.tif")
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method (Stream)

WebImageViewerOpen Method (Stream)

Opens an image into the WebImageViewer control from an image file stream.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream
)
Public Sub Open (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The image file stream to open.
See Also

Reference

WebImageViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method (String)

WebImageViewerOpen Method (String)

Opens an image into the WebImageViewer control from an image file.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName
)
Public Sub Open (
    fileName As String
)

Parameters

fileName
Type: SystemString
The image file to open.
See Also

Reference

WebImageViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method (RandomAccessImageSource)

WebImageViewerOpen Method (RandomAccessImageSource)

Opens a given image and sets it to the display.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    RandomAccessImageSource imageSource
)
Public Sub Open (
    imageSource As RandomAccessImageSource
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
Remarks
Use this method when opening a stream, or a file referenced by the hard drive letter. No attempt will be made to map the folder path.
See Also

Reference

WebImageViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method (Stream, Int32)

WebImageViewerOpen Method (Stream, Int32)

Opens an image into the WebImageViewer control from an image file stream, specifying the frame index of a multi-page image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
The image file stream to open.
frameIndex
Type: SystemInt32
The zero based frame index to load.
See Also

Reference

WebImageViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method (String, Int32)

WebImageViewerOpen Method (String, Int32)

Opens an image into the WebImageViewer control from an image file, specifying the frame index of a multi-page image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The image file to open.
frameIndex
Type: SystemInt32
The zero based frame index to load.
See Also

Reference

WebImageViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Open Method (RandomAccessImageSource, Int32)

WebImageViewerOpen Method (RandomAccessImageSource, Int32)

Opens a given image at a specified frame index and sets it to the display.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    RandomAccessImageSource imageSource,
    int frameIndex
)
Public Sub Open (
    imageSource As RandomAccessImageSource,
    frameIndex As Integer
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
frameIndex
Type: SystemInt32
Remarks
Use this method when opening a stream, or a file referenced by the hard drive letter. No attempt will be made to map the folder path.
See Also

Reference

WebImageViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OpenScrollImageUrl Method

WebImageViewerOpenScrollImageUrl Method

Opens the scroll image URL.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OpenScrollImageUrl()
Protected Sub OpenScrollImageUrl
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OpenUrl Method

WebImageViewerOpenUrl Method

Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Overload List
 | Name | Description
 | OpenUrl(String) | Opens an image into the WebImageViewer control from a URL or virtual path.
Public method | OpenUrl(String, Int32) | Opens an image into the WebImageViewer control from a URL or virtual path.
Top
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
Examples

This line of code will attempt to map to the server root.

C#
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("/TestImages/myTestImage.tif")

This line of code will attempt to get the image from the server located at the URL.

C#
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif");
Visual Basic
Copy
myWebImageViewer.OpenUrl("http://www.mydomain.com/TestImages/myTestImage.tif")
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OpenUrl Method (String)

WebImageViewerOpenUrl Method (String)

Opens an image into the WebImageViewer control from a URL or virtual path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OpenUrl(
    string urlPath
)
Public Sub OpenUrl (
    urlPath As String
)

Parameters

urlPath
Type: SystemString
The URL or virtual directory of the image to load.
Remarks
Use this method when opening an image referenced by a URL or a virtual path that can be mapped on the server. If you intend on creating an undo level from this image, use the Update method to cache the image.
See Also

Reference

WebImageViewer Class
OpenUrl Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OpenUrl Method (String, Int32)

WebImageViewerOpenUrl Method (String, Int32)

Opens an image into the WebImageViewer control from a URL or virtual path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OpenUrl(
    string urlPath,
    int frameIndex
)
Public Sub OpenUrl (
    urlPath As String,
    frameIndex As Integer
)

Parameters

urlPath
Type: SystemString
The URL or virtual directory of the image to load.
frameIndex
Type: SystemInt32
The zero based frame index of the image to load.
See Also

Reference

WebImageViewer Class
OpenUrl Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.OutputHiddenValues Method

WebImageViewerOutputHiddenValues Method

Writes hidden values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OutputHiddenValues(
    HtmlTextWriter writer
)
Protected Overrides Sub OutputHiddenValues (
    writer As HtmlTextWriter
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Print Method

WebImageViewerPrint Method

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Print()
Public Sub Print
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Redo Method

WebImageViewerRedo Method

Reverts the image inside the control back to the previously cached image, if an Undos have been done.
Overload List
 | Name | Description
Public method | Redo | Reverts the image inside the control back to the previously cached image, if an Undos have been done.
Public method | Redo(Int32) | Redoes the specified number of times.
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Redo Method

WebImageViewerRedo Method

Reverts the image inside the control back to the previously cached image, if an Undos have been done.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Redo()
Public Sub Redo
Remarks
Checking the RedosAvailable property is not necessary.
See Also

Reference

WebImageViewer Class
Redo Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Redo Method (Int32)

WebImageViewerRedo Method (Int32)

Redoes the specified number of times.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Redo(
    int numberRedos
)
Public Sub Redo (
    numberRedos As Integer
)

Parameters

numberRedos
Type: SystemInt32
The number of redos to perform
Remarks
Checking the RedosAvailable property is not necessary.
See Also

Reference

WebImageViewer Class
Redo Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.RegisterScripts Method

WebImageViewerRegisterScripts Method

Registers the scripts.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RegisterScripts()
Protected Overrides Sub RegisterScripts
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ReleaseImage Method

WebImageViewerReleaseImage Method

Releases the image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ReleaseImage(
    AtalaImage img
)
Protected Overrides Sub ReleaseImage (
    img As AtalaImage
)

Parameters

img
Type: Atalasoft.ImagingAtalaImage
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Save Method

WebImageViewerSave Method

Examples

Saves the image to the writable cache directory.

C#
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath + "myTestImage.jpg", new JpegEncoder(75));
Visual Basic
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath & "myTestImage.jpg", new JpegEncoder(75))
Examples

Saves the image to the writable cache directory.

C#
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath + "myTestImage.jpg", new JpegEncoder(75));
Visual Basic
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath & "myTestImage.jpg", new JpegEncoder(75))
Overload List
 | Name | Description
 | Save(Stream, ImageEncoder) | Saves the current image to a stream, with a specified ImageEncoder.
Public method | Save(String, ImageEncoder) | Saves the current image file, with a specified ImageEncoder.
Top
Examples

Saves the image to the writable cache directory.

C#
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath + "myTestImage.jpg", new JpegEncoder(75));
Visual Basic
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath & "myTestImage.jpg", new JpegEncoder(75))
Examples

Saves the image to the writable cache directory.

C#
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath + "myTestImage.jpg", new JpegEncoder(75));
Visual Basic
Copy
myWebImageViewer.Save(myWebImageViewer.CachePath & "myTestImage.jpg", new JpegEncoder(75))
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Save Method (Stream, ImageEncoder)

WebImageViewerSave Method (Stream, ImageEncoder)

Saves the current image to a stream, with a specified ImageEncoder.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder
)

Parameters

stream
Type: System.IOStream
The stream to save the image to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to encode the image with.
See Also

Reference

WebImageViewer Class
Save Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Save Method (String, ImageEncoder)

WebImageViewerSave Method (String, ImageEncoder)

Saves the current image file, with a specified ImageEncoder.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder
)

Parameters

fileName
Type: SystemString
The filename to save the image to.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to encode the image with.
See Also

Reference

WebImageViewer Class
Save Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.SerializeState Method

WebImageViewerSerializeState Method

Serializes teh current state.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void SerializeState()
Protected Overridable Sub SerializeState
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.SetZoomMode Method

WebImageViewerSetZoomMode Method

Zooms the image based on the given AutoZoomMode.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetZoomMode(
    AutoZoomMode zoomType
)
Public Sub SetZoomMode (
    zoomType As AutoZoomMode
)

Parameters

zoomType
Type: Atalasoft.Imaging.WebControlsAutoZoomMode
The type of AutoZoomMode to set
Remarks
This is a one time zoom. To continuously zoom the image as the control or image resizes, see AutoZoom.
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Undo Method

WebImageViewerUndo Method

Reverts the image inside the control back to the previously cached image.
Overload List
 | Name | Description
Public method | Undo | Reverts the image inside the control back to the previously cached image.
Public method | Undo(Int32) | Undoes the specified number of times.
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Undo Method

WebImageViewerUndo Method

Reverts the image inside the control back to the previously cached image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Undo()
Public Sub Undo
Remarks
Checking the UndosAvailable property is not necessary.
See Also

Reference

WebImageViewer Class
Undo Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Undo Method (Int32)

WebImageViewerUndo Method (Int32)

Undoes the specified number of times.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Undo(
    int numberUndos
)
Public Sub Undo (
    numberUndos As Integer
)

Parameters

numberUndos
Type: SystemInt32
The number of undos to perform
Remarks
Checking the UndosAvailable property is not necessary.
See Also

Reference

WebImageViewer Class
Undo Overload
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Update Method

WebImageViewerUpdate Method

Forces the current image to be cached.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Update()
Public Sub Update
Remarks
This method should be called when the image changes from operations such as GDI+ drawing. Note that applying a command will automatically update the cache.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.UpdateClient Method

WebImageViewerUpdateClient Method

Forces the client side JavaScript to update

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void UpdateClient()
Public Sub UpdateClient
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer Events

The WebImageViewer type exposes the following members.

Events
 | Name | Description
Public event | CenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Public event | ChangedImage | Fires when pixel data in the current image changes without setting a new image.
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control. (Inherited from WebViewerControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | ImageChanged | Fires when the Image has changed.
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | NewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Progress | Fires while an image is being processed, loaded, or saved.
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Public event | ResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize.
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Public event | SelectionChanged | Fires when the selection has been moved or changed. (After PostBack)
Public event | StreamTile | Fires when a tile is requested and allows the handler to provide it.
Public event | StreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true.
Public event | TileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ChangedImage Event

WebImageViewerChangedImage Event

Fires when pixel data in the current image changes without setting a new image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageEventHandler ChangedImage
Public Event ChangedImage As ImageEventHandler

Value

Type: Atalasoft.ImagingImageEventHandler
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ImageChanged Event

WebImageViewerImageChanged Event

Fires when the Image has changed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ImageChanged
Public Event ImageChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.NewImage Event

WebImageViewerNewImage Event

Note: This API is now obsolete.

Fires when this Workspace is set to a new current image. (Obsolete.)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This event may be removed from future versions.  Use the ChangedImage event instead.",
    false)]
public event ImageEventHandler NewImage
<ObsoleteAttribute("This event may be removed from future versions.  Use the ChangedImage event instead.",
    false)>
Public Event NewImage As ImageEventHandler

Value

Type: Atalasoft.ImagingImageEventHandler
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.Progress Event

WebImageViewerProgress Event

Fires while an image is being processed, loaded, or saved.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ProgressEventHandler Progress
Public Event Progress As ProgressEventHandler

Value

Type: Atalasoft.ImagingProgressEventHandler
Remarks
Handle this event to show a progressbar or to cancel the operation while in progress.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.ResizeImageForZoom Event

WebImageViewerResizeImageForZoom Event

Fires when the control is going to resize an image to give the user a chance to resize.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ResizeImageForZoomEventHandler ResizeImageForZoom
Public Event ResizeImageForZoom As ResizeImageForZoomEventHandler

Value

Type: Atalasoft.Imaging.WebControlsResizeImageForZoomEventHandler
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.SelectionChanged Event

WebImageViewerSelectionChanged Event

Fires when the selection has been moved or changed. (After PostBack)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTile Event

WebImageViewerStreamTile Event

Fires when a tile is requested and allows the handler to provide it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event WebImageViewerStreamTileEventHandler StreamTile
Public Event StreamTile As WebImageViewerStreamTileEventHandler

Value

Type: Atalasoft.Imaging.WebControlsWebImageViewerStreamTileEventHandler
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamViewImage Event

WebImageViewerStreamViewImage Event

Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler StreamViewImage
Public Event StreamViewImage As EventHandler

Value

Type: SystemEventHandler
Remarks

Since this event is triggered by a query string GET from the browser, there are a limited number of properties that contain the current state. Properties that are not in this list will contain the initial values that were set in the property grid and in the Page's Onload event. Valid properties include:

  • AntialiasDisplay
  • CurrentPage
  • Image
  • ImageUrl
  • Zoom

Properties that are not in this list will contain the initial values that were set in the property grid and in the Page's Onload event.

Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.TileStreamed Event

WebImageViewerTileStreamed Event

Fires when a tile has been streamed to the response and allows the handler to cache it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event WebImageViewerStreamTileEventHandler TileStreamed
Public Event TileStreamed As WebImageViewerStreamTileEventHandler

Value

Type: Atalasoft.Imaging.WebControlsWebImageViewerStreamTileEventHandler
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebImageViewer Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileArgs Class

WebImageViewerStreamTileArgs Class

StreamTile arguments.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControlsWebImageViewerStreamTileArgs

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StreamTileArgs
Public Class StreamTileArgs

The WebImageViewerStreamTileArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WebImageViewerStreamTileArgs | Initializes a new instance of the WebImageViewerStreamTileArgs class
Top
Properties
 | Name | Description
Public property | Image | Gets or sets the image.
Public property | Request | Gets or sets the request.
Public property | Response | Gets or sets the response.
Public property | Viewer | Gets or sets the viewer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileArgs Constructor

WebImageViewerStreamTileArgs Constructor

Initializes a new instance of the WebImageViewerStreamTileArgs class

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StreamTileArgs()
Public Sub New
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


StreamTileArgs Properties

The WebImageViewerStreamTileArgs type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets or sets the image.
Public property | Request | Gets or sets the request.
Public property | Response | Gets or sets the response.
Public property | Viewer | Gets or sets the viewer.
Top
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileArgs.Image Property

WebImageViewerStreamTileArgsImage Property

Gets or sets the image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileArgs.Request Property

WebImageViewerStreamTileArgsRequest Property

Gets or sets the request.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HttpRequest Request { get; set; }
Public Property Request As HttpRequest
    Get
    Set

Property Value

Type: HttpRequest
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileArgs.Response Property

WebImageViewerStreamTileArgsResponse Property

Gets or sets the response.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HttpResponse Response { get; set; }
Public Property Response As HttpResponse
    Get
    Set

Property Value

Type: HttpResponse
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileArgs.Viewer Property

WebImageViewerStreamTileArgsViewer Property

Gets or sets the viewer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControl Viewer { get; set; }
Public Property Viewer As WebViewerControl
    Get
    Set

Property Value

Type: WebViewerControl
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


StreamTileArgs Methods

The WebImageViewerStreamTileArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebImageViewerStreamTileArgs Class
Atalasoft.Imaging.WebControls Namespace


WebImageViewer.StreamTileEventHandler Delegate

WebImageViewerStreamTileEventHandler Delegate

Fires when a tile is requested and allows the handler to provide it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void StreamTileEventHandler(
    Object sender,
    WebImageViewerStreamTileArgs e
)
Public Delegate Sub StreamTileEventHandler (
    sender As Object,
    e As WebImageViewerStreamTileArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControlsWebImageViewerStreamTileArgs
Remarks
Caution note Caution
WebImageViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer Class

Shows the pages of a multipage image or multiple images from a folder in a scrollable, selectable columnar view.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Atalasoft.Imaging.WebControlsWebViewerControl
Atalasoft.Imaging.WebControlsWebThumbnailViewer

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebThumbnailViewer : WebViewerControl
Public Class WebThumbnailViewer
    Inherits WebViewerControl

The WebThumbnailViewer type exposes the following members.

Constructors
 | Name | Description
Public method | WebThumbnailViewer | Creates a new ThumbnailViewer control
Top
Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowDragDrop | Set to true to allow the user to drag a thumbnail to another position in the thumbnail control. Because the state of the image is not changed at all, the image will have to be reordered on the server side. Use the ThumbnailDrop event on the server side and the ThumbnailDropServer event on the client side.
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs. (Inherited from WebViewerControl.)
Public property | AllowMultiSelect | Set to true to allow the user to select multiple thumbnails with a CTRL-Click. If set to false, only a single thumb can be selected at any time. Use SelectedIndexes to get the individual selections.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | AutoDragDrop | Set to true when AllowDragDrop is also true, the thumbnail control will automatically handle thumbnail rearranging with linked viewers. It is not necessary to automatically save a reordered image server-side everytime a drag drop event is raised; the thumbnail control will request the correct image and annotation layer from the server, regardless of the thumbnail order. The client side method getThumbnailOrder() will return the current order of the thumbnails in the control. When returning from the server after saving the reordered image, the client side method Invalidate() should be called.
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Inherited from WebViewerControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension. (Inherited from WebViewerControl.)
Public property | BrowserFormat | Gets or sets the format of the images created for browser output. (Inherited from WebViewerControl.)
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled. (Inherited from WebViewerControl.)
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2. (Inherited from WebViewerControl.)
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache. (Inherited from WebViewerControl.)
Public property | Caption | Gets or sets the text to be included below the control. (Inherited from WebViewerControl.)
Public property | Centered | Gets or sets a value indicating if the content is centered in the control. (Inherited from WebViewerControl.)
Protected property | ChildContent | Gets or sets the child content. (Inherited from WebViewerControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from WebViewerControl.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts. (Inherited from WebViewerControl.)
Public property | Columns | Defines how many columns of thumbnails there will be. A value of 0 will dynamically calculate the number of columns based on the layout of the control.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from WebViewerControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls. (Inherited from WebViewerControl.)
Public property | Count | The number of thumbnails in the viewer.
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path. (Inherited from WebViewerControl.)
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport. (Inherited from WebViewerControl.)
Public property | Domain | Allows cross domain scripting for the specified domain. (Inherited from WebViewerControl.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | FlowDirection | One of the FlowDirection enumerations to indicate the directional flow of the thumbnails. Concecutive thumbnails will be laid out according to this property
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element. (Inherited from WebViewerControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent. (Inherited from WebViewerControl.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Public property | ImageDisplayOrder | Defines the way thumbs are loaded in the viewport. Using ImageDisplayOrder. Sequential will reduce performance, OnDemand is the most efficient.
Protected property | ImageSource | Gets or sets the image source.
Protected property | ImageSourceDataUrl | Gets the image source URL.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time. (Inherited from WebViewerControl.)
Protected property | IsDisposed | Gets a value indicating the object has been disposed. (Inherited from WebViewerControl.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post. (Inherited from WebViewerControl.)
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded. (Inherited from WebViewerControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Layout | Gets or sets the orientation of the control.
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed. (Inherited from WebViewerControl.)
Public property | MouseTool | Gets or sets the behavior of the mouse when interacting with the viewport.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table. (Inherited from WebViewerControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.) (Inherited from WebViewerControl.)
Protected property | PixelFormat | Gets or sets the pixel format. (Inherited from WebViewerControl.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath. (Inherited from WebViewerControl.)
Public property | Rows | Defines how many rows of thumbnails there will be. A value of 0 will dynamically calculate the number of rows based on the layout of the control.
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars. (Inherited from WebViewerControl.)
Public property | ScrollPosition | The position of the scroll port within the control.
Public property | SelectedIndex | The index of the selected thumbnail.
Public property | SelectedIndexes | The list of indexes of thumbnails selected in the control. The list is in the order they were selected.
Public property | Selection | Gets the RubberBand of the selection.
Public property | SessionId | Gets the session ID. (Inherited from WebViewerControl.)
Public property | ShowAnnotations | Set to true to show annotations on the thumbnail images.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ThumbCaptionFormat | The text to use as the caption for each thumbnail. It is passed to String.Format, and {0} will be replaced by the page number of the thumbnail, and {1} will be replaced by filename.
Public property | ThumbPadding | Gets or sets the number of pixels padded around each thumbnail.
Public property | ThumbSize | Gets or sets the maximum size of the thumbnails. Thumbs will be best-fit to this size.
Public property | ThumbSpacing | Gets or sets the number of pixels between each thumbnail.
Public property | ThumbStyle | Gets a value defining the thumbnail style in it's normal state.
Public property | ThumbStyleHover | Gets a value defining the thumbnail style used when the mouse hovers over it.
Public property | ThumbStyleSelected | Gets a value defining the thumbnail style used when the thumbnail is selected.
Public property | ThumbStyleSelectedHover | Gets a value defining the thumbnail style used when the thumbnail is seleced and the mouse hovers over it.
Public property | TitleBar | Gets or sets the text to be included above the control. (Inherited from WebViewerControl.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Inherited from WebViewerControl.)
Public property | Url | The URL of the image or directory shown in this control.
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | Viewer | Gets the WebImageViewer.
Public property | ViewerID | ID of the WebImageViewer used to display selected thumb.
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered. (Inherited from WebViewerControl.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from WebViewerControl.)
Protected property | WebAnnotationViewerDataUrl | Gets the annotation viewer data URL
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport.
Public property | ZoomInOutPercentage | Gets or sets a value indicating the percentage to increase or decrease the zoom level.
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag. (Inherited from WebViewerControl.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script. (Inherited from WebViewerControl.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Gets the initial querystring for the iframe used for RemoteInvoke and PartialPost. (Overrides WebViewerControlBuildRemoteQuery.)
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts. (Inherited from WebViewerControl.)
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level. (Inherited from WebViewerControl.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | ClearSerializedState | Clears the serialized state.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Overrides WebViewerControlCreateChildControls.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Protected method | DeserializeState | Deserializes the state of the web thumbnail viewer.
Public method | DesignTime | Enters design-time mode. (Overrides WebViewerControlDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides WebViewerControlDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response. (Inherited from WebViewerControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format. (Inherited from WebViewerControl.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeString | Escapes a string. (Inherited from WebViewerControl.)
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively. (Inherited from WebViewerControl.)
Protected method | FixNumericalID | Fixes the numerical ID. (Inherited from WebViewerControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings (Inherited from WebViewerControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension. (Inherited from WebViewerControl.)
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension. (Inherited from WebViewerControl.)
Protected method | GetFormClientID | Gets the form client ID. (Inherited from WebViewerControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Reads hidden values. (Overrides WebViewerControlGetHiddenValues.)
Protected method | GetIdForSession | Gets the session ID. (Inherited from WebViewerControl.)
Protected method | GetMimeType | Gets the MIME content type of a file name. (Inherited from WebViewerControl.)
Protected method | GetObjectType | Gets the object type. (Overrides WebViewerControlGetObjectType.)
Protected method | GetResourcePrefix | Gets the prefix associated with a resource type. (Overrides WebViewerControlGetResourcePrefix(ResourceType).)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleNonPageRequests | Handles non-page requests.
Protected method | HandleQueryString | Handles the query string. (Overrides WebViewerControlHandleQueryString.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads query string variables. (Overrides WebViewerControlLoadQueryStringValues(NameValueCollection).)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file (Inherited from WebViewerControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path. (Inherited from WebViewerControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Overrides WebViewerControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Overrides WebViewerControlOnLoad(EventArgs).)
Protected method | OnPageInit | Handles page initialization.
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides ControlOnPreRender(EventArgs).)
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Protected method | OnSelectedIndexChanged | Fires when the selected thumbnail changes.
Protected method | OnStreamThumbnailImage(ThumbnailImageCreatedEventArgs) | Fires when a thumbnail image is requested by the browser.
Protected method | OnStreamThumbnailImage(AtalaImage, Int32, Double) | Fires when a thumbnail image is requested by the browser.
Protected method | OnThumbnailDrop | This event gets raised on the server side after completing a drag-drop in the thumbnail control on the client side.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OnViewerIDChanged | Fires when the viewer ID changes.
Public method | Open(Stream) | Opens a stream representing a multipage image and shows each individual image as a thumbnail.
Public method | Open(String) | Opens a multipage image and shows each individual image thumbnail in the control.
Public method | Open(RandomAccessImageSource) |
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | OpenFiles(String) | Opens a collection of files.
Public method | OpenFiles(String, String) | Open a list of images in the virtual path provided. Each image is opened in a single thumbnail.
Public method | OpenUrl(String) | Opens up an image given its URL path. If the image has multiple frames, each one will loaded as an individual thumbnail.
Public method | OpenUrl(String, String) | Opens up images matching the search patterns in a directory given its URL path. If the directory has multiple images, each one will loaded as an individual thumbnail.
Protected method | OutputHiddenValues | Writes hidden values. (Overrides WebViewerControlOutputHiddenValues(HtmlTextWriter).)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RegisterScriptInclude | Includes a script. (Inherited from WebViewerControl.)
Protected method | RegisterScripts | Registers the scripts. (Overrides WebViewerControlRegisterScripts.)
Protected method | ReleaseImage | Releases the image. (Inherited from WebViewerControl.)
Protected method | Remote | Performs a remote invocation. (Inherited from WebViewerControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebViewerControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name. (Inherited from WebViewerControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SerializeState | Serializes the state of the web thumbnail viewer.
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Protected method | UrlIsWebRequest | Determines if a URL is for a web request. (Inherited from WebViewerControl.)
Protected method | WatermarkImage | Applies a watermark to the image. (Inherited from WebViewerControl.)
Top
Events
 | Name | Description
Public event | CenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control. (Inherited from WebViewerControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Public event | SelectedIndexChanged | Fires when the selected thumbnail changes.
Public event | StreamThumbnailImage | Fires when a thumbnail image is requested by the browser.
Public event | ThumbnailDrop | This event gets raised on the server side after completing a drag-drop in the thumbnail control on the client side.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Public event | ViewerIDChanged | Fires when the viewer ID changes.
Top
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only. Use WebDocumentThumbnailer control instead.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer Constructor

Creates a new ThumbnailViewer control

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebThumbnailViewer()
Public Sub New
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer Properties

The WebThumbnailViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowDragDrop | Set to true to allow the user to drag a thumbnail to another position in the thumbnail control. Because the state of the image is not changed at all, the image will have to be reordered on the server side. Use the ThumbnailDrop event on the server side and the ThumbnailDropServer event on the client side.
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs. (Inherited from WebViewerControl.)
Public property | AllowMultiSelect | Set to true to allow the user to select multiple thumbnails with a CTRL-Click. If set to false, only a single thumb can be selected at any time. Use SelectedIndexes to get the individual selections.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | AutoDragDrop | Set to true when AllowDragDrop is also true, the thumbnail control will automatically handle thumbnail rearranging with linked viewers. It is not necessary to automatically save a reordered image server-side everytime a drag drop event is raised; the thumbnail control will request the correct image and annotation layer from the server, regardless of the thumbnail order. The client side method getThumbnailOrder() will return the current order of the thumbnails in the control. When returning from the server after saving the reordered image, the client side method Invalidate() should be called.
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Inherited from WebViewerControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension. (Inherited from WebViewerControl.)
Public property | BrowserFormat | Gets or sets the format of the images created for browser output. (Inherited from WebViewerControl.)
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled. (Inherited from WebViewerControl.)
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2. (Inherited from WebViewerControl.)
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache. (Inherited from WebViewerControl.)
Public property | Caption | Gets or sets the text to be included below the control. (Inherited from WebViewerControl.)
Public property | Centered | Gets or sets a value indicating if the content is centered in the control. (Inherited from WebViewerControl.)
Protected property | ChildContent | Gets or sets the child content. (Inherited from WebViewerControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from WebViewerControl.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts. (Inherited from WebViewerControl.)
Public property | Columns | Defines how many columns of thumbnails there will be. A value of 0 will dynamically calculate the number of columns based on the layout of the control.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from WebViewerControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls. (Inherited from WebViewerControl.)
Public property | Count | The number of thumbnails in the viewer.
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path. (Inherited from WebViewerControl.)
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport. (Inherited from WebViewerControl.)
Public property | Domain | Allows cross domain scripting for the specified domain. (Inherited from WebViewerControl.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | FlowDirection | One of the FlowDirection enumerations to indicate the directional flow of the thumbnails. Concecutive thumbnails will be laid out according to this property
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element. (Inherited from WebViewerControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent. (Inherited from WebViewerControl.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Public property | ImageDisplayOrder | Defines the way thumbs are loaded in the viewport. Using ImageDisplayOrder. Sequential will reduce performance, OnDemand is the most efficient.
Protected property | ImageSource | Gets or sets the image source.
Protected property | ImageSourceDataUrl | Gets the image source URL.
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time. (Inherited from WebViewerControl.)
Protected property | IsDisposed | Gets a value indicating the object has been disposed. (Inherited from WebViewerControl.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post. (Inherited from WebViewerControl.)
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded. (Inherited from WebViewerControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Layout | Gets or sets the orientation of the control.
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed. (Inherited from WebViewerControl.)
Public property | MouseTool | Gets or sets the behavior of the mouse when interacting with the viewport.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table. (Inherited from WebViewerControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.) (Inherited from WebViewerControl.)
Protected property | PixelFormat | Gets or sets the pixel format. (Inherited from WebViewerControl.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath. (Inherited from WebViewerControl.)
Public property | Rows | Defines how many rows of thumbnails there will be. A value of 0 will dynamically calculate the number of rows based on the layout of the control.
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars. (Inherited from WebViewerControl.)
Public property | ScrollPosition | The position of the scroll port within the control.
Public property | SelectedIndex | The index of the selected thumbnail.
Public property | SelectedIndexes | The list of indexes of thumbnails selected in the control. The list is in the order they were selected.
Public property | Selection | Gets the RubberBand of the selection.
Public property | SessionId | Gets the session ID. (Inherited from WebViewerControl.)
Public property | ShowAnnotations | Set to true to show annotations on the thumbnail images.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ThumbCaptionFormat | The text to use as the caption for each thumbnail. It is passed to String.Format, and {0} will be replaced by the page number of the thumbnail, and {1} will be replaced by filename.
Public property | ThumbPadding | Gets or sets the number of pixels padded around each thumbnail.
Public property | ThumbSize | Gets or sets the maximum size of the thumbnails. Thumbs will be best-fit to this size.
Public property | ThumbSpacing | Gets or sets the number of pixels between each thumbnail.
Public property | ThumbStyle | Gets a value defining the thumbnail style in it's normal state.
Public property | ThumbStyleHover | Gets a value defining the thumbnail style used when the mouse hovers over it.
Public property | ThumbStyleSelected | Gets a value defining the thumbnail style used when the thumbnail is selected.
Public property | ThumbStyleSelectedHover | Gets a value defining the thumbnail style used when the thumbnail is seleced and the mouse hovers over it.
Public property | TitleBar | Gets or sets the text to be included above the control. (Inherited from WebViewerControl.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Inherited from WebViewerControl.)
Public property | Url | The URL of the image or directory shown in this control.
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | Viewer | Gets the WebImageViewer.
Public property | ViewerID | ID of the WebImageViewer used to display selected thumb.
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered. (Inherited from WebViewerControl.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from WebViewerControl.)
Protected property | WebAnnotationViewerDataUrl | Gets the annotation viewer data URL
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport.
Public property | ZoomInOutPercentage | Gets or sets a value indicating the percentage to increase or decrease the zoom level.
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.AllowDragDrop Property

WebThumbnailViewerAllowDragDrop Property

Set to true to allow the user to drag a thumbnail to another position in the thumbnail control. Because the state of the image is not changed at all, the image will have to be reordered on the server side. Use the ThumbnailDrop event on the server side and the ThumbnailDropServer event on the client side.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowDragDrop { get; set; }
Public Property AllowDragDrop As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.AllowMultiSelect Property

WebThumbnailViewerAllowMultiSelect Property

Set to true to allow the user to select multiple thumbnails with a CTRL-Click. If set to false, only a single thumb can be selected at any time. Use SelectedIndexes to get the individual selections.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowMultiSelect { get; set; }
Public Property AllowMultiSelect As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.AutoDragDrop Property

WebThumbnailViewerAutoDragDrop Property

Set to true when AllowDragDrop is also true, the thumbnail control will automatically handle thumbnail rearranging with linked viewers. It is not necessary to automatically save a reordered image server-side everytime a drag drop event is raised; the thumbnail control will request the correct image and annotation layer from the server, regardless of the thumbnail order.

The client side method getThumbnailOrder() will return the current order of the thumbnails in the control.

When returning from the server after saving the reordered image, the client side method Invalidate() should be called.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoDragDrop { get; set; }
Public Property AutoDragDrop As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

AutoDragDrop cannot be true if:

  • AllowDragDrop is false
  • AllowMultiSelect is true
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Columns Property

WebThumbnailViewerColumns Property

Defines how many columns of thumbnails there will be. A value of 0 will dynamically calculate the number of columns based on the layout of the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Columns { get; set; }
Public Property Columns As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Count Property

WebThumbnailViewerCount Property

The number of thumbnails in the viewer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.FlowDirection Property

WebThumbnailViewerFlowDirection Property

One of the FlowDirection enumerations to indicate the directional flow of the thumbnails. Concecutive thumbnails will be laid out according to this property

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlowDirection FlowDirection { get; set; }
Public Property FlowDirection As FlowDirection
    Get
    Set

Property Value

Type: FlowDirection
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ImageDisplayOrder Property

WebThumbnailViewerImageDisplayOrder Property

Defines the way thumbs are loaded in the viewport. Using ImageDisplayOrder. Sequential will reduce performance, OnDemand is the most efficient.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageDisplayOrder ImageDisplayOrder { get; set; }
Public Property ImageDisplayOrder As ImageDisplayOrder
    Get
    Set

Property Value

Type: ImageDisplayOrder
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ImageSource Property

WebThumbnailViewerImageSource Property

Gets or sets the image source.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RandomAccessImageSource ImageSource { get; set; }
Protected Property ImageSource As RandomAccessImageSource
    Get
    Set

Property Value

Type: RandomAccessImageSource
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ImageSourceDataUrl Property

WebThumbnailViewerImageSourceDataUrl Property

Gets the image source URL.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string ImageSourceDataUrl { get; }
Protected ReadOnly Property ImageSourceDataUrl As String
    Get

Property Value

Type: String
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Layout Property

WebThumbnailViewerLayout Property

Gets or sets the orientation of the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Layout Layout { get; set; }
Public Property Layout As Layout
    Get
    Set

Property Value

Type: Layout
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.MouseTool Property

WebThumbnailViewerMouseTool Property

Gets or sets the behavior of the mouse when interacting with the viewport.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual MouseTool MouseTool { get; }
Public Overridable ReadOnly Property MouseTool As MouseTool
    Get

Property Value

Type: MouseTool
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Rows Property

WebThumbnailViewerRows Property

Defines how many rows of thumbnails there will be. A value of 0 will dynamically calculate the number of rows based on the layout of the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rows { get; set; }
Public Property Rows As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ScrollPosition Property

WebThumbnailViewerScrollPosition Property

The position of the scroll port within the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; }
Public ReadOnly Property ScrollPosition As Point
    Get

Property Value

Type: Point
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.SelectedIndex Property

WebThumbnailViewerSelectedIndex Property

The index of the selected thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SelectedIndex { get; set; }
Public Property SelectedIndex As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.SelectedIndexes Property

WebThumbnailViewerSelectedIndexes Property

The list of indexes of thumbnails selected in the control. The list is in the order they were selected.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] SelectedIndexes { get; set; }
Public Property SelectedIndexes As Integer()
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Selection Property

WebThumbnailViewerSelection Property

Gets the RubberBand of the selection.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberBand Selection { get; }
Public ReadOnly Property Selection As RubberBand
    Get

Property Value

Type: RubberBand
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ShowAnnotations Property

WebThumbnailViewerShowAnnotations Property

Set to true to show annotations on the thumbnail images.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowAnnotations { get; set; }
Public Property ShowAnnotations As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbCaptionFormat Property

WebThumbnailViewerThumbCaptionFormat Property

The text to use as the caption for each thumbnail. It is passed to String.Format, and {0} will be replaced by the page number of the thumbnail, and {1} will be replaced by filename.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ThumbCaptionFormat { get; set; }
Public Property ThumbCaptionFormat As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbPadding Property

WebThumbnailViewerThumbPadding Property

Gets or sets the number of pixels padded around each thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ThumbPadding { get; set; }
Public Property ThumbPadding As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbSize Property

WebThumbnailViewerThumbSize Property

Gets or sets the maximum size of the thumbnails. Thumbs will be best-fit to this size.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ThumbSize { get; set; }
Public Property ThumbSize As Size
    Get
    Set

Property Value

Type: Size
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbSpacing Property

WebThumbnailViewerThumbSpacing Property

Gets or sets the number of pixels between each thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ThumbSpacing { get; set; }
Public Property ThumbSpacing As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbStyle Property

WebThumbnailViewerThumbStyle Property

Gets a value defining the thumbnail style in it's normal state.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ThumbnailStyle ThumbStyle { get; }
Public Overridable ReadOnly Property ThumbStyle As ThumbnailStyle
    Get

Property Value

Type: ThumbnailStyle
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbStyleHover Property

WebThumbnailViewerThumbStyleHover Property

Gets a value defining the thumbnail style used when the mouse hovers over it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ThumbnailStyle ThumbStyleHover { get; }
Public Overridable ReadOnly Property ThumbStyleHover As ThumbnailStyle
    Get

Property Value

Type: ThumbnailStyle
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbStyleSelected Property

WebThumbnailViewerThumbStyleSelected Property

Gets a value defining the thumbnail style used when the thumbnail is selected.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ThumbnailStyle ThumbStyleSelected { get; }
Public Overridable ReadOnly Property ThumbStyleSelected As ThumbnailStyle
    Get

Property Value

Type: ThumbnailStyle
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbStyleSelectedHover Property

WebThumbnailViewerThumbStyleSelectedHover Property

Gets a value defining the thumbnail style used when the thumbnail is seleced and the mouse hovers over it.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ThumbnailStyle ThumbStyleSelectedHover { get; }
Public Overridable ReadOnly Property ThumbStyleSelectedHover As ThumbnailStyle
    Get

Property Value

Type: ThumbnailStyle
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Url Property

WebThumbnailViewerUrl Property

The URL of the image or directory shown in this control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Viewer Property

WebThumbnailViewerViewer Property

Gets the WebImageViewer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WebImageViewer Viewer { get; }
Protected ReadOnly Property Viewer As WebImageViewer
    Get

Property Value

Type: WebImageViewer
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ViewerID Property

WebThumbnailViewerViewerID Property

ID of the WebImageViewer used to display selected thumb.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ViewerID { get; set; }
Public Property ViewerID As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.WebAnnotationViewerDataUrl Property

WebThumbnailViewerWebAnnotationViewerDataUrl Property

Gets the annotation viewer data URL

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string WebAnnotationViewerDataUrl { get; }
Protected ReadOnly Property WebAnnotationViewerDataUrl As String
    Get

Property Value

Type: String
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Zoom Property

WebThumbnailViewerZoom Property

Gets or sets the zoom level of the image in the viewport.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ZoomInOutPercentage Property

WebThumbnailViewerZoomInOutPercentage Property

Gets or sets a value indicating the percentage to increase or decrease the zoom level.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ZoomInOutPercentage { get; set; }
Public Property ZoomInOutPercentage As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer Methods

The WebThumbnailViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag. (Inherited from WebViewerControl.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script. (Inherited from WebViewerControl.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Gets the initial querystring for the iframe used for RemoteInvoke and PartialPost. (Overrides WebViewerControlBuildRemoteQuery.)
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts. (Inherited from WebViewerControl.)
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level. (Inherited from WebViewerControl.)
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | ClearSerializedState | Clears the serialized state.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Overrides WebViewerControlCreateChildControls.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Protected method | DeserializeState | Deserializes the state of the web thumbnail viewer.
Public method | DesignTime | Enters design-time mode. (Overrides WebViewerControlDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides WebViewerControlDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response. (Inherited from WebViewerControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format. (Inherited from WebViewerControl.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeString | Escapes a string. (Inherited from WebViewerControl.)
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively. (Inherited from WebViewerControl.)
Protected method | FixNumericalID | Fixes the numerical ID. (Inherited from WebViewerControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings (Inherited from WebViewerControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension. (Inherited from WebViewerControl.)
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension. (Inherited from WebViewerControl.)
Protected method | GetFormClientID | Gets the form client ID. (Inherited from WebViewerControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Reads hidden values. (Overrides WebViewerControlGetHiddenValues.)
Protected method | GetIdForSession | Gets the session ID. (Inherited from WebViewerControl.)
Protected method | GetMimeType | Gets the MIME content type of a file name. (Inherited from WebViewerControl.)
Protected method | GetObjectType | Gets the object type. (Overrides WebViewerControlGetObjectType.)
Protected method | GetResourcePrefix | Gets the prefix associated with a resource type. (Overrides WebViewerControlGetResourcePrefix(ResourceType).)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleNonPageRequests | Handles non-page requests.
Protected method | HandleQueryString | Handles the query string. (Overrides WebViewerControlHandleQueryString.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads query string variables. (Overrides WebViewerControlLoadQueryStringValues(NameValueCollection).)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file (Inherited from WebViewerControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path. (Inherited from WebViewerControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Overrides WebViewerControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Overrides WebViewerControlOnLoad(EventArgs).)
Protected method | OnPageInit | Handles page initialization.
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides ControlOnPreRender(EventArgs).)
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Protected method | OnSelectedIndexChanged | Fires when the selected thumbnail changes.
Protected method | OnStreamThumbnailImage(ThumbnailImageCreatedEventArgs) | Fires when a thumbnail image is requested by the browser.
Protected method | OnStreamThumbnailImage(AtalaImage, Int32, Double) | Fires when a thumbnail image is requested by the browser.
Protected method | OnThumbnailDrop | This event gets raised on the server side after completing a drag-drop in the thumbnail control on the client side.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OnViewerIDChanged | Fires when the viewer ID changes.
Public method | Open(Stream) | Opens a stream representing a multipage image and shows each individual image as a thumbnail.
Public method | Open(String) | Opens a multipage image and shows each individual image thumbnail in the control.
Public method | Open(RandomAccessImageSource) |
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | OpenFiles(String) | Opens a collection of files.
Public method | OpenFiles(String, String) | Open a list of images in the virtual path provided. Each image is opened in a single thumbnail.
Public method | OpenUrl(String) | Opens up an image given its URL path. If the image has multiple frames, each one will loaded as an individual thumbnail.
Public method | OpenUrl(String, String) | Opens up images matching the search patterns in a directory given its URL path. If the directory has multiple images, each one will loaded as an individual thumbnail.
Protected method | OutputHiddenValues | Writes hidden values. (Overrides WebViewerControlOutputHiddenValues(HtmlTextWriter).)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RegisterScriptInclude | Includes a script. (Inherited from WebViewerControl.)
Protected method | RegisterScripts | Registers the scripts. (Overrides WebViewerControlRegisterScripts.)
Protected method | ReleaseImage | Releases the image. (Inherited from WebViewerControl.)
Protected method | Remote | Performs a remote invocation. (Inherited from WebViewerControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebViewerControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name. (Inherited from WebViewerControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SerializeState | Serializes the state of the web thumbnail viewer.
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Protected method | UrlIsWebRequest | Determines if a URL is for a web request. (Inherited from WebViewerControl.)
Protected method | WatermarkImage | Applies a watermark to the image. (Inherited from WebViewerControl.)
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.BuildRemoteQuery Method

WebThumbnailViewerBuildRemoteQuery Method

Gets the initial querystring for the iframe used for RemoteInvoke and PartialPost.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string BuildRemoteQuery()
Protected Overrides Function BuildRemoteQuery As String

Return Value

Type: String
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ClearSerializedState Method

WebThumbnailViewerClearSerializedState Method

Clears the serialized state.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ClearSerializedState()
Protected Overridable Sub ClearSerializedState
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.CreateChildControls Method

WebThumbnailViewerCreateChildControls Method

Add the child controls to the container, sizing it to the User's specifications.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.DeserializeState Method

WebThumbnailViewerDeserializeState Method

Deserializes the state of the web thumbnail viewer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DeserializeState()
Protected Overridable Sub DeserializeState
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.DesignTime Method

WebThumbnailViewerDesignTime Method

Overload List
 | Name | Description
Public method | DesignTime | Enters design-time mode. (Overrides WebViewerControlDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.DesignTime Method

WebThumbnailViewerDesignTime Method

Enters design-time mode.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void DesignTime()
Public Overrides Sub DesignTime
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
DesignTime Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.DisposeManagedResources Method

WebThumbnailViewerDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.GetHiddenValues Method

WebThumbnailViewerGetHiddenValues Method

Reads hidden values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void GetHiddenValues()
Protected Overrides Sub GetHiddenValues
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.GetObjectType Method

WebThumbnailViewerGetObjectType Method

Gets the object type.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Type GetObjectType()
Protected Overrides Function GetObjectType As Type

Return Value

Type: Type
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.GetResourcePrefix Method

WebThumbnailViewerGetResourcePrefix Method

Gets the prefix associated with a resource type.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string GetResourcePrefix(
    ResourceType rt
)
Protected Overrides Function GetResourcePrefix (
    rt As ResourceType
) As String

Parameters

rt
Type: Atalasoft.Imaging.WebControlsResourceType

Return Value

Type: String
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.HandleNonPageRequests Method

WebThumbnailViewerHandleNonPageRequests Method

Handles non-page requests.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void HandleNonPageRequests()
Protected Sub HandleNonPageRequests
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.HandleQueryString Method

WebThumbnailViewerHandleQueryString Method

Handles the query string.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void HandleQueryString()
Protected Overrides Sub HandleQueryString
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.LoadQueryStringValues Method

WebThumbnailViewerLoadQueryStringValues Method

Loads query string variables.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LoadQueryStringValues(
    NameValueCollection clientParams
)
Protected Overrides Sub LoadQueryStringValues (
    clientParams As NameValueCollection
)

Parameters

clientParams
Type: System.Collections.SpecializedNameValueCollection
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnInit Method

WebThumbnailViewerOnInit Method

Raises the Init event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnLoad Method

WebThumbnailViewerOnLoad Method

Raises the Load event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs object that contains the event data.
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnPageInit Method

WebThumbnailViewerOnPageInit Method

Handles page initialization.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnPageInit(
    Object o,
    EventArgs e
)
Protected Sub OnPageInit (
    o As Object,
    e As EventArgs
)

Parameters

o
Type: SystemObject
e
Type: SystemEventArgs
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnPreRender Method

WebThumbnailViewerOnPreRender Method

Raises the PreRender event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnSelectedIndexChanged Method

WebThumbnailViewerOnSelectedIndexChanged Method

Fires when the selected thumbnail changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectedIndexChanged(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnSelectedIndexChanged (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnStreamThumbnailImage Method

WebThumbnailViewerOnStreamThumbnailImage Method

Overload List
 | Name | Description
Protected method | OnStreamThumbnailImage(ThumbnailImageCreatedEventArgs) | Fires when a thumbnail image is requested by the browser.
Protected method | OnStreamThumbnailImage(AtalaImage, Int32, Double) | Fires when a thumbnail image is requested by the browser.
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnStreamThumbnailImage Method (ThumbnailImageCreatedEventArgs)

WebThumbnailViewerOnStreamThumbnailImage Method (ThumbnailImageCreatedEventArgs)

Fires when a thumbnail image is requested by the browser.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnStreamThumbnailImage(
    ThumbnailImageCreatedEventArgs ticEventArgs
)
Protected Overridable Sub OnStreamThumbnailImage (
    ticEventArgs As ThumbnailImageCreatedEventArgs
)

Parameters

ticEventArgs
Type: Atalasoft.Imaging.WebControlsThumbnailImageCreatedEventArgs
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
OnStreamThumbnailImage Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnStreamThumbnailImage Method (AtalaImage, Int32, Double)

WebThumbnailViewerOnStreamThumbnailImage Method (AtalaImage, Int32, Double)

Fires when a thumbnail image is requested by the browser.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnStreamThumbnailImage(
    AtalaImage image,
    int index,
    double zoom
)
Protected Overridable Sub OnStreamThumbnailImage (
    image As AtalaImage,
    index As Integer,
    zoom As Double
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
index
Type: SystemInt32
zoom
Type: SystemDouble
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
OnStreamThumbnailImage Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnThumbnailDrop Method

WebThumbnailViewerOnThumbnailDrop Method

This event gets raised on the server side after completing a drag-drop in the thumbnail control on the client side.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnThumbnailDrop(
    ThumbnailDropEventArgs tdEventArgs
)
Protected Overridable Sub OnThumbnailDrop (
    tdEventArgs As ThumbnailDropEventArgs
)

Parameters

tdEventArgs
Type: Atalasoft.Imaging.WebControlsThumbnailDropEventArgs
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OnViewerIDChanged Method

WebThumbnailViewerOnViewerIDChanged Method

Fires when the viewer ID changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnViewerIDChanged(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnViewerIDChanged (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Open Method

WebThumbnailViewerOpen Method

Open a multipage image or a folder of images. If you pass a file, it loads the images from it, and if you pass a folder it loads the individual images from it.
Overload List
 | Name | Description
Public method | Open(Stream) | Opens a stream representing a multipage image and shows each individual image as a thumbnail.
Public method | Open(String) | Opens a multipage image and shows each individual image thumbnail in the control.
Public method | Open(RandomAccessImageSource) |
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Open Method (Stream)

WebThumbnailViewerOpen Method (Stream)

Opens a stream representing a multipage image and shows each individual image as a thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream
)
Public Sub Open (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Open Method (String)

WebThumbnailViewerOpen Method (String)

Opens a multipage image and shows each individual image thumbnail in the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName
)
Public Sub Open (
    fileName As String
)

Parameters

fileName
Type: SystemString
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.Open Method (RandomAccessImageSource)

WebThumbnailViewerOpen Method (RandomAccessImageSource)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    RandomAccessImageSource imageSource
)
Public Sub Open (
    imageSource As RandomAccessImageSource
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Open Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OpenFiles Method

WebThumbnailViewerOpenFiles Method

Overload List
 | Name | Description
Public method | OpenFiles(String) | Opens a collection of files.
Public method | OpenFiles(String, String) | Open a list of images in the virtual path provided. Each image is opened in a single thumbnail.
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OpenFiles Method (String[])

WebThumbnailViewerOpenFiles Method (String)

Opens a collection of files.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OpenFiles(
    string[] filesToOpen
)
Public Sub OpenFiles (
    filesToOpen As String()
)

Parameters

filesToOpen
Type: SystemString
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
OpenFiles Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OpenFiles Method (String, String[])

WebThumbnailViewerOpenFiles Method (String, String)

Open a list of images in the virtual path provided. Each image is opened in a single thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OpenFiles(
    string urlDirectoryPath,
    string[] filesToOpen
)
Public Sub OpenFiles (
    urlDirectoryPath As String,
    filesToOpen As String()
)

Parameters

urlDirectoryPath
Type: SystemString
The virtual path to the directory where the files are located.
filesToOpen
Type: SystemString
An array of file names (including extensions) to open.
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
OpenFiles Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OpenUrl Method

WebThumbnailViewerOpenUrl Method

Opens an image into the WebThumbnailViewer control from a URL or virtual path.
Overload List
 | Name | Description
Public method | OpenUrl(String) | Opens up an image given its URL path. If the image has multiple frames, each one will loaded as an individual thumbnail.
Public method | OpenUrl(String, String) | Opens up images matching the search patterns in a directory given its URL path. If the directory has multiple images, each one will loaded as an individual thumbnail.
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OpenUrl Method (String)

WebThumbnailViewerOpenUrl Method (String)

Opens up an image given its URL path. If the image has multiple frames, each one will loaded as an individual thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OpenUrl(
    string urlImagePath
)
Public Sub OpenUrl (
    urlImagePath As String
)

Parameters

urlImagePath
Type: SystemString
The URL path to the image
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
OpenUrl Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OpenUrl Method (String, String[])

WebThumbnailViewerOpenUrl Method (String, String)

Opens up images matching the search patterns in a directory given its URL path. If the directory has multiple images, each one will loaded as an individual thumbnail.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void OpenUrl(
    string urlDirectoryPath,
    params string[] searchPatterns
)
Public Sub OpenUrl (
    urlDirectoryPath As String,
    ParamArray searchPatterns As String()
)

Parameters

urlDirectoryPath
Type: SystemString
The URL path to the directory.
searchPatterns
Type: SystemString
Search patterns using * and ? to match files. The images found is the union of all files matched by the patterns.
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
OpenUrl Overload
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.OutputHiddenValues Method

WebThumbnailViewerOutputHiddenValues Method

Writes hidden values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OutputHiddenValues(
    HtmlTextWriter writer
)
Protected Overrides Sub OutputHiddenValues (
    writer As HtmlTextWriter
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.RegisterScripts Method

WebThumbnailViewerRegisterScripts Method

Registers the scripts.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RegisterScripts()
Protected Overrides Sub RegisterScripts
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.SerializeState Method

WebThumbnailViewerSerializeState Method

Serializes the state of the web thumbnail viewer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void SerializeState()
Protected Overridable Sub SerializeState
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer Events

The WebThumbnailViewer type exposes the following members.

Events
 | Name | Description
Public event | CenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control. (Inherited from WebViewerControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Public event | SelectedIndexChanged | Fires when the selected thumbnail changes.
Public event | StreamThumbnailImage | Fires when a thumbnail image is requested by the browser.
Public event | ThumbnailDrop | This event gets raised on the server side after completing a drag-drop in the thumbnail control on the client side.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Public event | ViewerIDChanged | Fires when the viewer ID changes.
Top
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.SelectedIndexChanged Event

WebThumbnailViewerSelectedIndexChanged Event

Fires when the selected thumbnail changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectedIndexChanged
Public Event SelectedIndexChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.StreamThumbnailImage Event

WebThumbnailViewerStreamThumbnailImage Event

Fires when a thumbnail image is requested by the browser.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailImageCreatedEventHandler StreamThumbnailImage
Public Event StreamThumbnailImage As ThumbnailImageCreatedEventHandler

Value

Type: Atalasoft.Imaging.WebControlsThumbnailImageCreatedEventHandler
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ThumbnailDrop Event

WebThumbnailViewerThumbnailDrop Event

This event gets raised on the server side after completing a drag-drop in the thumbnail control on the client side.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailDropEventHandler ThumbnailDrop
Public Event ThumbnailDrop As ThumbnailDropEventHandler

Value

Type: Atalasoft.Imaging.WebControlsThumbnailDropEventHandler
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebThumbnailViewer.ViewerIDChanged Event

WebThumbnailViewerViewerIDChanged Event

Fires when the viewer ID changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ViewerIDChanged
Public Event ViewerIDChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebThumbnailViewer control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

WebThumbnailViewer Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl Class

Defines a base class that can be used for scrolling an image from the browser.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Atalasoft.Imaging.WebControlsWebViewerControl
Atalasoft.Imaging.WebControlsWebImageViewer
Atalasoft.Imaging.WebControlsWebThumbnailViewer

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class WebViewerControl : WebControl,
    INamingContainer
Public MustInherit Class WebViewerControl
    Inherits WebControl
    Implements INamingContainer

The WebViewerControl type exposes the following members.

Constructors
 | Name | Description
Protected method | WebViewerControl | base WebViewerControl constructor. Set Visible:true, BorderStyle:None.
Top
Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Overrides WebControlBorderStyle.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension.
Public property | BrowserFormat | Gets or sets the format of the images created for browser output.
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled.
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2.
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache.
Public property | Caption | Gets or sets the text to be included below the control.
Public property | Centered | Gets or sets a value indicating if the content is centered in the control.
Protected property | ChildContent | Gets or sets the child content.
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Overrides ControlClientID.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Overrides ControlControls.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls.
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport.
Public property | Domain | Allows cross domain scripting for the specified domain.
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element.
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent.
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time.
Protected property | IsDisposed | Gets a value indicating the object has been disposed.
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post.
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded.
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table.
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.)
Protected property | PixelFormat | Gets or sets the pixel format.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath.
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars.
Public property | SessionId | Gets the session ID.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | TitleBar | Gets or sets the text to be included above the control.
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Overrides ControlUniqueID.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered.
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Overrides ControlVisible.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag.
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script.
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Builds the default querystring for the iframe used for RemoteInvoke, PartialPost, and Async WebThumbnailViewer calls
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts.
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Overrides ControlCreateChildControls.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignTime | Enters design-time mode.
Protected method | DesignTime(String) | Enters design-time mode.
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Overrides ControlDispose.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory.
Protected method | DisposeManagedResources | Enables a server control to perform final clean up before it is released from memory.
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory.
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response.
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeString | Escapes a string.
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Overrides ObjectFinalize.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively.
Protected method | FixNumericalID | Fixes the numerical ID.
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension.
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension.
Protected method | GetFormClientID | Gets the form client ID.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Reads hidden values.
Protected method | GetIdForSession | Gets the session ID.
Protected method | GetMimeType | Gets the MIME content type of a file name.
Protected method | GetObjectType | Gets the type of object.
Protected method | GetResourcePrefix | Gets the prefix associated with a specific resource type.
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleQueryString | Handles the query string.
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads the values from the query string.
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes.
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Overrides ControlOnLoad(EventArgs).)
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data.
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value.
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed.
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | OutputHiddenValues | Writes the hidden values.
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RegisterScriptInclude | Includes a script.
Protected method | RegisterScripts | Registers scripts.
Protected method | ReleaseImage | Releases the image.
Protected method | Remote | Performs a remote invocation.
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Overrides WebControlRender(HtmlTextWriter).)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name.
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Protected method | UrlIsWebRequest | Determines if a URL is for a web request.
Protected method | WatermarkImage | Applies a watermark to the image.
Top
Events
 | Name | Description
Public event | CenteredChanged | Fires when the Centered property changes.
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control.
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data.
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value.
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed.
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
Remarks
Caution note Caution
WebViewerControl control is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebViewerControl Constructor

base WebViewerControl constructor. Set Visible:true, BorderStyle:None.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WebViewerControl()
Protected Sub New
Exceptions
Exception | Condition
AtalasoftLicenseException | Thrown if license is 'Photo' and not design-time.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl Properties

The WebViewerControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs.
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Overrides WebControlBorderStyle.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension.
Public property | BrowserFormat | Gets or sets the format of the images created for browser output.
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled.
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2.
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache.
Public property | Caption | Gets or sets the text to be included below the control.
Public property | Centered | Gets or sets a value indicating if the content is centered in the control.
Protected property | ChildContent | Gets or sets the child content.
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Overrides ControlClientID.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts.
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Overrides ControlControls.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls.
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport.
Public property | Domain | Allows cross domain scripting for the specified domain.
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element.
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent.
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time.
Protected property | IsDisposed | Gets a value indicating the object has been disposed.
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post.
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded.
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed.
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table.
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.)
Protected property | PixelFormat | Gets or sets the pixel format.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath.
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars.
Public property | SessionId | Gets the session ID.
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | TitleBar | Gets or sets the text to be included above the control.
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Overrides ControlUniqueID.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered.
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Overrides ControlVisible.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Top
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.AllowedPaths Property

WebViewerControlAllowedPaths Property

Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ICollection<string> AllowedPaths { get; }
Public ReadOnly Property AllowedPaths As ICollection(Of String)
    Get

Property Value

Type: ICollectionString
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.BorderStyle Property

WebViewerControlBorderStyle Property

Gets the border style used for this control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override BorderStyle BorderStyle { get; }
Public Overrides ReadOnly Property BorderStyle As BorderStyle
    Get

Property Value

Type: BorderStyle
The border style used for this control.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.BrowserExtension Property

WebViewerControlBrowserExtension Property

Gets the file extension.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string BrowserExtension { get; }
Protected ReadOnly Property BrowserExtension As String
    Get

Property Value

Type: String
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.BrowserFormat Property

WebViewerControlBrowserFormat Property

Gets or sets the format of the images created for browser output.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CacheImageFormat BrowserFormat { get; set; }
Public Property BrowserFormat As CacheImageFormat
    Get
    Set

Property Value

Type: CacheImageFormat
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CacheDisabled Property

WebViewerControlCacheDisabled Property

Gets a value indicating if the cache is disabled.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool CacheDisabled { get; }
Protected ReadOnly Property CacheDisabled As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CacheLevels Property

WebViewerControlCacheLevels Property

The number of images to cache on the server, per control, per session. Default value is 2.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CacheLevels { get; set; }
Public Property CacheLevels As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CachePath Property

WebViewerControlCachePath Property

The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CachePath { get; }
Public ReadOnly Property CachePath As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Caption Property

WebViewerControlCaption Property

Gets or sets the text to be included below the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Centered Property

WebViewerControlCentered Property

Gets or sets a value indicating if the content is centered in the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Centered { get; set; }
Public Property Centered As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ChildContent Property

WebViewerControlChildContent Property

Gets or sets the child content.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string ChildContent { get; set; }
Protected Property ChildContent As String
    Get
    Set

Property Value

Type: String
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ClientID Property

WebViewerControlClientID Property

Gets the server control identifier generated by ASP.NET.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ClientID { get; }
Public Overrides ReadOnly Property ClientID As String
    Get

Return Value

Type: String
The server control identifier generated by ASP.NET.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ClientScripts Property

WebViewerControlClientScripts Property

Gets a collection od client scripts.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ArrayList ClientScripts { get; }
Protected ReadOnly Property ClientScripts As ArrayList
    Get

Property Value

Type: ArrayList
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Controls Property

WebViewerControlControls Property

Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override ControlCollection Controls { get; }
Public Overrides ReadOnly Property Controls As ControlCollection
    Get

Return Value

Type: ControlCollection
The collection of child controls for the specified server control.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ControlTable Property

WebViewerControlControlTable Property

Gets the table of controls.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HtmlTable ControlTable { get; }
Protected ReadOnly Property ControlTable As HtmlTable
    Get

Property Value

Type: HtmlTable
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CurrentExecutionPath Property

WebViewerControlCurrentExecutionPath Property

Gets the current execution path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string CurrentExecutionPath { get; }
Protected Overridable ReadOnly Property CurrentExecutionPath As String
    Get

Property Value

Type: String
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.DesignTimeViewPort Property

WebViewerControlDesignTimeViewPort Property

Gets the design-time viewport.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HtmlImage DesignTimeViewPort { get; }
Protected ReadOnly Property DesignTimeViewPort As HtmlImage
    Get

Property Value

Type: HtmlImage
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Domain Property

WebViewerControlDomain Property

Allows cross domain scripting for the specified domain.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.FullClientIFrame Property

WebViewerControlFullClientIFrame Property

Gets the client IFrame element.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HtmlGenericControl FullClientIFrame { get; }
Protected ReadOnly Property FullClientIFrame As HtmlGenericControl
    Get

Property Value

Type: HtmlGenericControl
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.HasResponded Property

WebViewerControlHasResponded Property

Gets a value indicating that a response has been sent.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool HasResponded { get; }
Protected ReadOnly Property HasResponded As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.IsDesignTime Property

WebViewerControlIsDesignTime Property

Gets or sets a value indicating the control is in design time.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDesignTime { get; set; }
Public Property IsDesignTime As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.IsDisposed Property

WebViewerControlIsDisposed Property

Gets a value indicating the object has been disposed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsDisposed { get; }
Protected ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.IsPartialPost Property

WebViewerControlIsPartialPost Property

Gets a value indicating it is a partial post.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsPartialPost { get; }
Protected ReadOnly Property IsPartialPost As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.IsQueryStringLoaded Property

WebViewerControlIsQueryStringLoaded Property

Gets a value indicating the query string was loaded.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsQueryStringLoaded { get; }
Protected ReadOnly Property IsQueryStringLoaded As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Logging Property

WebViewerControlLogging Property

Gets a value indicating that logging is performed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool Logging { get; }
Protected ReadOnly Property Logging As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OuterTable Property

WebViewerControlOuterTable Property

Gets the outer table.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected HtmlTable OuterTable { get; }
Protected ReadOnly Property OuterTable As HtmlTable
    Get

Property Value

Type: HtmlTable
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.PathToResources Property

WebViewerControlPathToResources Property

Note: This API is now obsolete.

Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.)

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("PathToResources has been renamed ResourcePath")]
public string PathToResources { get; }
<ObsoleteAttribute("PathToResources has been renamed ResourcePath")>
Public ReadOnly Property PathToResources As String
    Get

Property Value

Type: String
The virtual path to where the scrollbar images are located.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
Examples
C#
Copy
myWebImageViewer.PathToResources = "Resource_Files/";
Visual Basic
Copy
myWebImageViewer.PathToResources = "Resource_Files/"
Examples
C#
Copy
myWebImageViewer.PathToResources = "Resource_Files/";
Visual Basic
Copy
myWebImageViewer.PathToResources = "Resource_Files/"
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.PixelFormat Property

WebViewerControlPixelFormat Property

Gets or sets the pixel format.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual PixelFormat PixelFormat { get; set; }
Protected Overridable Property PixelFormat As PixelFormat
    Get
    Set

Property Value

Type: PixelFormat
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ResourcePath Property

WebViewerControlResourcePath Property

The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ResourcePath { get; }
Public ReadOnly Property ResourcePath As String
    Get

Property Value

Type: String
Remarks
This is used to speed up the load time of the control. If the resources are not in the specified directory, they will not show up. If this is not set, then the resources are loaded directly from the assembly, which will cause a slight delay each time the control is posted back.
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ScrollBarVisibility Property

WebViewerControlScrollBarVisibility Property

Gets or sets the visibility of the scrollbars.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollBarVisibility ScrollBarVisibility { get; set; }
Public Property ScrollBarVisibility As ScrollBarVisibility
    Get
    Set

Property Value

Type: ScrollBarVisibility
The ScrollBarVisibility indicating the visibility of the scrollbars.

Property Value

Type: ScrollBarVisibility
The visibility of the scrollbars.
Remarks
Defaults to Always.
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.SessionId Property

WebViewerControlSessionId Property

Gets the session ID.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SessionId { get; }
Public ReadOnly Property SessionId As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.TitleBar Property

WebViewerControlTitleBar Property

Gets or sets the text to be included above the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TitleBar { get; set; }
Public Property TitleBar As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.UniqueID Property

WebViewerControlUniqueID Property

Gets the server control identifier generated by ASP.NET MVC.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string UniqueID { get; }
Public Overrides ReadOnly Property UniqueID As String
    Get

Return Value

Type: String
The server control identifier generated by ASP.NET MVC.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Visibility Property

WebViewerControlVisibility Property

Indicates whether the control is visible when rendered.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public VisibilityStyle Visibility { get; set; }
Public Property Visibility As VisibilityStyle
    Get
    Set

Property Value

Type: VisibilityStyle
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Visible Property

WebViewerControlVisible Property

Gets or sets a value that indicates whether a server control is rendered as UI on the page.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Visible { get; set; }
Public Overrides Property Visible As Boolean
    Get
    Set

Return Value

Type: Boolean
true if the control is visible on the page; otherwise false.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl Methods

The WebViewerControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag.
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script.
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Builds the default querystring for the iframe used for RemoteInvoke, PartialPost, and Async WebThumbnailViewer calls
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts.
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Overrides ControlCreateChildControls.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignTime | Enters design-time mode.
Protected method | DesignTime(String) | Enters design-time mode.
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Overrides ControlDispose.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory.
Protected method | DisposeManagedResources | Enables a server control to perform final clean up before it is released from memory.
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory.
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response.
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeString | Escapes a string.
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Overrides ObjectFinalize.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively.
Protected method | FixNumericalID | Fixes the numerical ID.
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension.
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension.
Protected method | GetFormClientID | Gets the form client ID.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Reads hidden values.
Protected method | GetIdForSession | Gets the session ID.
Protected method | GetMimeType | Gets the MIME content type of a file name.
Protected method | GetObjectType | Gets the type of object.
Protected method | GetResourcePrefix | Gets the prefix associated with a specific resource type.
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleQueryString | Handles the query string.
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads the values from the query string.
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes.
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Overrides ControlOnLoad(EventArgs).)
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data.
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value.
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed.
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed.
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | OutputHiddenValues | Writes the hidden values.
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RegisterScriptInclude | Includes a script.
Protected method | RegisterScripts | Registers scripts.
Protected method | ReleaseImage | Releases the image.
Protected method | Remote | Performs a remote invocation.
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Overrides WebControlRender(HtmlTextWriter).)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name.
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Protected method | UrlIsWebRequest | Determines if a URL is for a web request.
Protected method | WatermarkImage | Applies a watermark to the image.
Top
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.AddHiddenTag Method

WebViewerControlAddHiddenTag Method

Writes a hidden tag.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void AddHiddenTag(
    HtmlTextWriter writer,
    string id,
    string val
)
Protected Overridable Sub AddHiddenTag (
    writer As HtmlTextWriter,
    id As String,
    val As String
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
id
Type: SystemString
val
Type: SystemString
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.AddStartupScript Method

WebViewerControlAddStartupScript Method

Adds a startup script.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void AddStartupScript(
    string script
)
Protected Overridable Sub AddStartupScript (
    script As String
)

Parameters

script
Type: SystemString
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.BuildRemoteQuery Method

WebViewerControlBuildRemoteQuery Method

Builds the default querystring for the iframe used for RemoteInvoke, PartialPost, and Async WebThumbnailViewer calls

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string BuildRemoteQuery()
Protected Overridable Function BuildRemoteQuery As String

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.BuildScriptVersionChecker Method

WebViewerControlBuildScriptVersionChecker Method

Builds a version checker function for the scripts.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string BuildScriptVersionChecker()
Protected Overridable Function BuildScriptVersionChecker As String

Return Value

Type: String
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CalculateBestFitZoom Method

WebViewerControlCalculateBestFitZoom Method

Calculates the best fit zoom level.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected double CalculateBestFitZoom(
    SizeF origSize,
    SizeF maxSize
)
Protected Function CalculateBestFitZoom (
    origSize As SizeF,
    maxSize As SizeF
) As Double

Parameters

origSize
Type: System.DrawingSizeF
maxSize
Type: System.DrawingSizeF

Return Value

Type: Double
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CreateChildControls Method

WebViewerControlCreateChildControls Method

Add the child controls to the container, sizing it to the User's specifications.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void CreateChildControls()
Protected Overrides Sub CreateChildControls
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.DesignTime Method

WebViewerControlDesignTime Method

Overload List
 | Name | Description
Public method | DesignTime | Enters design-time mode.
Protected method | DesignTime(String) | Enters design-time mode.
Top
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.DesignTime Method

WebViewerControlDesignTime Method

Enters design-time mode.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void DesignTime()
Public Overridable Sub DesignTime
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
DesignTime Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.DesignTime Method (String)

WebViewerControlDesignTime Method (String)

Enters design-time mode.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DesignTime(
    string splashFileName
)
Protected Overridable Sub DesignTime (
    splashFileName As String
)

Parameters

splashFileName
Type: SystemString
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
DesignTime Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Dispose Method

WebViewerControlDispose Method

Overload List
 | Name | Description
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Overrides ControlDispose.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory.
Top
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Dispose Method

WebViewerControlDispose Method

Enables a server control to perform final clean up before it is released from memory.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override sealed void Dispose()
Public Overrides NotOverridable Sub Dispose

Implements

IDisposableDispose
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Dispose Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Dispose Method (Boolean)

WebViewerControlDispose Method (Boolean)

Enables a server control to perform final clean up before it is released from memory.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Dispose Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.DisposeManagedResources Method

WebViewerControlDisposeManagedResources Method

Enables a server control to perform final clean up before it is released from memory.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.DisposeUnmanagedResources Method

WebViewerControlDisposeUnmanagedResources Method

Enables a server control to perform final clean up before it is released from memory.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.EndResponse Method

WebViewerControlEndResponse Method

Ends the response.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void EndResponse()
Protected Sub EndResponse
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.EnsureValidPixelFormat Method

WebViewerControlEnsureValidPixelFormat Method

Ensures a correct pixel format.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage EnsureValidPixelFormat(
    AtalaImage newImage
)
Protected Function EnsureValidPixelFormat (
    newImage As AtalaImage
) As AtalaImage

Parameters

newImage
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: AtalaImage
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.EscapeString Method

WebViewerControlEscapeString Method

Escapes a string.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string EscapeString(
    string str
)
Protected Function EscapeString (
    str As String
) As String

Parameters

str
Type: SystemString

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Finalize Method

WebViewerControlFinalize Method

Enables a server control to perform final clean up before it is released from memory.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.FindControlRecursive Method

WebViewerControlFindControlRecursive Method

Searches for a control recursively.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Control FindControlRecursive(
    Control root,
    string id
)
Protected Function FindControlRecursive (
    root As Control,
    id As String
) As Control

Parameters

root
Type: System.Web.UIControl
id
Type: SystemString

Return Value

Type: Control
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.FixNumericalID Method

WebViewerControlFixNumericalID Method

Fixes the numerical ID.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string FixNumericalID(
    string id
)
Protected Overridable Function FixNumericalID (
    id As String
) As String

Parameters

id
Type: SystemString

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetConfigAttributes Method

WebViewerControlGetConfigAttributes Method

Load this control's configuration from AppSettings

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void GetConfigAttributes()
Protected Overridable Sub GetConfigAttributes
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetEncoder Method

WebViewerControlGetEncoder Method

Overload List
 | Name | Description
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension.
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension.
Top
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetEncoder Method

WebViewerControlGetEncoder Method

Gets the proper encoder based on the BrowserExtension.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageEncoder GetEncoder()
Protected Function GetEncoder As ImageEncoder

Return Value

Type: ImageEncoder
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
GetEncoder Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetEncoder Method (String)

WebViewerControlGetEncoder Method (String)

Gets the proper encoder based on the file extension.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageEncoder GetEncoder(
    string extension
)
Protected Function GetEncoder (
    extension As String
) As ImageEncoder

Parameters

extension
Type: SystemString

Return Value

Type: ImageEncoder
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
GetEncoder Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetFormClientID Method

WebViewerControlGetFormClientID Method

Gets the form client ID.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string GetFormClientID()
Protected Function GetFormClientID As String

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetHiddenValues Method

WebViewerControlGetHiddenValues Method

Reads hidden values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void GetHiddenValues()
Protected Overridable Sub GetHiddenValues
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetIdForSession Method

WebViewerControlGetIdForSession Method

Gets the session ID.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string GetIdForSession()
Protected Overridable Function GetIdForSession As String

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetMimeType Method

WebViewerControlGetMimeType Method

Gets the MIME content type of a file name.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string GetMimeType(
    string fileName
)
Protected Overridable Function GetMimeType (
    fileName As String
) As String

Parameters

fileName
Type: SystemString

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetObjectType Method

WebViewerControlGetObjectType Method

Gets the type of object.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Type GetObjectType()
Protected Overridable Function GetObjectType As Type

Return Value

Type: Type
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.GetResourcePrefix Method

WebViewerControlGetResourcePrefix Method

Gets the prefix associated with a specific resource type.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string GetResourcePrefix(
    ResourceType rt
)
Protected Overridable Function GetResourcePrefix (
    rt As ResourceType
) As String

Parameters

rt
Type: Atalasoft.Imaging.WebControlsResourceType

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.HandleQueryString Method

WebViewerControlHandleQueryString Method

Handles the query string.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void HandleQueryString()
Protected Overridable Sub HandleQueryString
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.LoadQueryStringValues Method

WebViewerControlLoadQueryStringValues Method

Loads the values from the query string.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LoadQueryStringValues(
    NameValueCollection clientParams
)
Protected Overridable Sub LoadQueryStringValues (
    clientParams As NameValueCollection
)

Parameters

clientParams
Type: System.Collections.SpecializedNameValueCollection
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.LogMessageToCache Method

WebViewerControlLogMessageToCache Method

Write a diagnostic log message into a .txt file

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LogMessageToCache(
    string name,
    string msg,
    string errMsg,
    string stackTrace,
    string targetSite
)
Protected Overridable Sub LogMessageToCache (
    name As String,
    msg As String,
    errMsg As String,
    stackTrace As String,
    targetSite As String
)

Parameters

name
Type: SystemString
full path to log file. If null, uses cache\sessionid_ErrorLog.txt
msg
Type: SystemString
message
errMsg
Type: SystemString
detailed error message
stackTrace
Type: SystemString
stack trace (e.g. Exception.StackTrace)
targetSite
Type: SystemString
e.g. Exception.TargetSite, the method that threw the exception
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.MapUrlPath Method

WebViewerControlMapUrlPath Method

Maps the URL to a path.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string MapUrlPath(
    string urlToImage
)
Protected Function MapUrlPath (
    urlToImage As String
) As String

Parameters

urlToImage
Type: SystemString

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnCenteredChanged Method

WebViewerControlOnCenteredChanged Method

Fires when the Centered property changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCenteredChanged(
    EventArgs e
)
Protected Overridable Sub OnCenteredChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnCreateSessionId Method

WebViewerControlOnCreateSessionId Method

Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnCreateSessionId(
    CreateSessionIdEventArgs e
)
Protected Sub OnCreateSessionId (
    e As CreateSessionIdEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsCreateSessionIdEventArgs
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnInit Method

WebViewerControlOnInit Method

Raises the Init event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnLoad Method

WebViewerControlOnLoad Method

Raises the Load event.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs object that contains the event data.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnPartialPost Method

WebViewerControlOnPartialPost Method

Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnPartialPost(
    PartialPostEventArgs e
)
Protected Sub OnPartialPost (
    e As PartialPostEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControlsPartialPostEventArgs
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnRemoteInvoke Method

WebViewerControlOnRemoteInvoke Method

Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string OnRemoteInvoke(
    RemoteInvokeEventArgs eventArgs
)
Protected Function OnRemoteInvoke (
    eventArgs As RemoteInvokeEventArgs
) As String

Parameters

eventArgs
Type: Atalasoft.Imaging.WebControlsRemoteInvokeEventArgs

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnScrollBarVisibilityChanged Method

WebViewerControlOnScrollBarVisibilityChanged Method

Fires when the ScrollPort.ScrollBarVisibility property has changed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnScrollBarVisibilityChanged(
    EventArgs e
)
Protected Overridable Sub OnScrollBarVisibilityChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OnScrollPositionChanged Method

WebViewerControlOnScrollPositionChanged Method

Fires when the position of the scroll bars have changed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnScrollPositionChanged(
    EventArgs e
)
Protected Sub OnScrollPositionChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.OutputHiddenValues Method

WebViewerControlOutputHiddenValues Method

Writes the hidden values.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OutputHiddenValues(
    HtmlTextWriter writer
)
Protected Overridable Sub OutputHiddenValues (
    writer As HtmlTextWriter
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.RegisterScriptInclude Method

WebViewerControlRegisterScriptInclude Method

Includes a script.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RegisterScriptInclude(
    WebViewerControlClientResource r,
    ArrayList a
)
Protected Overridable Sub RegisterScriptInclude (
    r As WebViewerControlClientResource,
    a As ArrayList
)

Parameters

r
Type: Atalasoft.Imaging.WebControlsWebViewerControlClientResource
a
Type: System.CollectionsArrayList
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.RegisterScripts Method

WebViewerControlRegisterScripts Method

Registers scripts.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RegisterScripts()
Protected Overridable Sub RegisterScripts
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ReleaseImage Method

WebViewerControlReleaseImage Method

Releases the image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ReleaseImage(
    AtalaImage img
)
Protected Overridable Sub ReleaseImage (
    img As AtalaImage
)

Parameters

img
Type: Atalasoft.ImagingAtalaImage
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Remote Method

WebViewerControlRemote Method

Performs a remote invocation.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string Remote(
    RemoteInvokeEventArgs eventArgs
)
Protected Overridable Function Remote (
    eventArgs As RemoteInvokeEventArgs
) As String

Parameters

eventArgs
Type: Atalasoft.Imaging.WebControlsRemoteInvokeEventArgs

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.Render Method

WebViewerControlRender Method

Renders the control to the specified HTML writer.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Render(
    HtmlTextWriter writer
)
Protected Overrides Sub Render (
    writer As HtmlTextWriter
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
The HtmlTextWriter object that receives the control content.
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ReplaceInvalidFileNameChars Method

WebViewerControlReplaceInvalidFileNameChars Method

Fixes an invalid file name.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string ReplaceInvalidFileNameChars(
    string s,
    string r
)
Protected Function ReplaceInvalidFileNameChars (
    s As String,
    r As String
) As String

Parameters

s
Type: SystemString
r
Type: SystemString

Return Value

Type: String
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.UrlIsWebRequest Method

WebViewerControlUrlIsWebRequest Method

Determines if a URL is for a web request.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool UrlIsWebRequest(
    string urlToMap
)
Protected Function UrlIsWebRequest (
    urlToMap As String
) As Boolean

Parameters

urlToMap
Type: SystemString

Return Value

Type: Boolean
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.WatermarkImage Method

WebViewerControlWatermarkImage Method

Applies a watermark to the image.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void WatermarkImage(
    AtalaImage img,
    string msg,
    string shortmsg
)
Protected Overridable Sub WatermarkImage (
    img As AtalaImage,
    msg As String,
    shortmsg As String
)

Parameters

img
Type: Atalasoft.ImagingAtalaImage
msg
Type: SystemString
shortmsg
Type: SystemString
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl Events

The WebViewerControl type exposes the following members.

Events
 | Name | Description
Public event | CenteredChanged | Fires when the Centered property changes.
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control.
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data.
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value.
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed.
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed.
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CenteredChanged Event

WebViewerControlCenteredChanged Event

Fires when the Centered property changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CenteredChanged
Public Event CenteredChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CreateSessionId Event

WebViewerControlCreateSessionId Event

Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CreateSessionIdEventHandler CreateSessionId
Public Event CreateSessionId As CreateSessionIdEventHandler

Value

Type: Atalasoft.Imaging.WebControlsCreateSessionIdEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.CreateUniquePageName Event

WebViewerControlCreateUniquePageName Event

Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CreateUniquePageNameEventHandler CreateUniquePageName
Public Event CreateUniquePageName As CreateUniquePageNameEventHandler

Value

Type: Atalasoft.Imaging.WebControlsCreateUniquePageNameEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
Examples
Setting the Page Name C#
Copy
protected void Page_Load(object sender, EventArgs e)
{
    WebImageViewer1.CreateUniquePageName += new CreateUniquePageNameEventHandler(iv_CreateUniquePageName);
}

void iv_CreateUniquePageName(object sender, CreateUniquePageNameEventArgs e)
{
    e.PageName = "PageName";
}
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.PartialPost Event

WebViewerControlPartialPost Event

Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PartialPostEventHandler PartialPost
Public Event PartialPost As PartialPostEventHandler

Value

Type: Atalasoft.Imaging.WebControlsPartialPostEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.RemoteInvoke Event

WebViewerControlRemoteInvoke Event

Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event RemoteInvokeEventHandler RemoteInvoke
Public Event RemoteInvoke As RemoteInvokeEventHandler

Value

Type: Atalasoft.Imaging.WebControlsRemoteInvokeEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ScrollBarVisibilityChanged Event

WebViewerControlScrollBarVisibilityChanged Event

Fires when the ScrollPort.ScrollBarVisibility property has changed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ScrollBarVisibilityChanged
Public Event ScrollBarVisibilityChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ScrollPositionChanged Event

WebViewerControlScrollPositionChanged Event

Fires when the position of the scroll bars have changed.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ScrollPositionChanged
Public Event ScrollPositionChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebViewerControl control is not available for .NET Core.
See Also

Reference

WebViewerControl Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ClientResource Structure

WebViewerControlClientResource Structure

Stores information on a client resource.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected struct ClientResource
Protected Structure ClientResource

The WebViewerControlClientResource type exposes the following members.

Constructors
 | Name | Description
Public method | WebViewerControlClientResource | Creates a ClientResource object
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | FileName | The file name.
Public field | Version | The version.
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ClientResource Constructor

WebViewerControlClientResource Constructor

Creates a ClientResource object

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ClientResource(
    string fileName,
    string version
)
Public Sub New (
    fileName As String,
    version As String
)

Parameters

fileName
Type: SystemString
version
Type: SystemString
See Also

Reference

WebViewerControlClientResource Structure
Atalasoft.Imaging.WebControls Namespace


ClientResource Methods

The WebViewerControlClientResource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

WebViewerControlClientResource Structure
Atalasoft.Imaging.WebControls Namespace


ClientResource Fields

The WebViewerControlClientResource type exposes the following members.

Fields
 | Name | Description
Public field | FileName | The file name.
Public field | Version | The version.
Top
See Also

Reference

WebViewerControlClientResource Structure
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ClientResource.FileName Field

WebViewerControlClientResourceFileName Field

The file name.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName
Public FileName As String

Field Value

Type: String
See Also

Reference

WebViewerControlClientResource Structure
Atalasoft.Imaging.WebControls Namespace


WebViewerControl.ClientResource.Version Field

WebViewerControlClientResourceVersion Field

The version.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Version
Public Version As String

Field Value

Type: String
See Also

Reference

WebViewerControlClientResource Structure
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner Class

Summary description for ScrollPortDesigner.
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Web.UI.DesignHtmlControlDesigner
System.Web.UI.DesignControlDesigner
Atalasoft.Imaging.WebControlsWebViewerControlDesigner

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebViewerControlDesigner : ControlDesigner
Public Class WebViewerControlDesigner
    Inherits ControlDesigner

The WebViewerControlDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | WebViewerControlDesigner | Initializes a new instance of the WebViewerControlDesigner class
Top
Properties
 | Name | Description
Public property | ActionLists | Gets the action list collection for the control designer. (Inherited from ControlDesigner.)
Public property | AllowResize | Gets a value indicating if this can be resized. (Overrides ControlDesignerAllowResize.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ComponentDesigner.)
Public property | AutoFormats | Gets the collection of predefined automatic formatting schemes to display in the Auto Format dialog box for the associated control at design time. (Inherited from ControlDesigner.)
Public property | Behavior | Obsolete. Gets or sets the DHTML behavior that is associated with the designer. (Inherited from HtmlControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | DataBindings | Gets the data bindings collection for the current control. (Inherited from HtmlControlDesigner.)
Protected property | DataBindingsEnabled | Gets a value indicating whether data binding is supported by the containing region for the associated control. (Inherited from ControlDesigner.)
Protected property | DesignerState | Gets an object that is used to persist data for the associated control at design time. (Inherited from ControlDesigner.)
Protected property | DesignTimeElement | Obsolete. Gets the design-time object representing the control that is associated with the HtmlControlDesigner object on the design surface. (Inherited from HtmlControlDesigner.)
Protected property | DesignTimeElementView | Obsolete. Gets the view-control object for the control designer. (Inherited from ControlDesigner.)
Public property | DesignTimeHtmlRequiresLoadComplete | Obsolete. Gets a value indicating whether the design host must finish loading before the GetDesignTimeHtml method can be called. (Inherited from ControlDesigner.)
Public property | Expressions | Gets the expression bindings for the current control at design time. (Inherited from HtmlControlDesigner.)
Protected property | HidePropertiesInTemplateMode | Gets a value indicating whether the properties of the associated control are hidden when the control is in template mode. (Inherited from ControlDesigner.)
Public property | ID | Gets or sets the ID string for the control. (Inherited from ControlDesigner.)
Protected property | InheritanceAttribute | Gets an attribute that indicates the type of inheritance of the associated component. (Inherited from ComponentDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | InTemplateMode | Gets a value indicating whether the control is in either template viewing or editing mode in the design host. The InTemplateMode property is read-only. (Inherited from ControlDesigner.)
Public property | IsDirty | Obsolete. Gets or sets a value indicating whether the Web server control has been marked as changed. (Inherited from ControlDesigner.)
Protected property | ParentComponent | Gets the parent component for this designer. (Inherited from ComponentDesigner.)
Public property | ReadOnly | Obsolete. Gets or sets a value indicating whether the properties of the control are read-only at design time. (Inherited from ControlDesigner.)
Protected property | RootDesigner | Gets the control designer for the Web Forms page that contains the associated control. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | ShouldCodeSerialize | Obsolete. Gets or sets a value indicating whether to create a field declaration for the control in the code-behind file for the current design document during serialization. (Inherited from HtmlControlDesigner.)
Protected property | Tag | Gets an object representing the HTML markup element for the associated control. (Inherited from ControlDesigner.)
Public property | TemplateGroups | Gets a collection of template groups, each containing one or more template definitions. (Inherited from ControlDesigner.)
Protected property | UsePreviewControl | Gets a value indicating whether the control designer uses a temporary preview control to generate the design-time HTML markup. (Inherited from ControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Public property | ViewControl | Gets or sets a Web server control that can be used for previewing the design-time HTML markup. (Inherited from ControlDesigner.)
Public property | ViewControlCreated | Gets or sets a value indicating whether a View control has been created for display on the design surface. (Inherited from ControlDesigner.)
Protected property | Visible | Gets a value that indicates whether the control is visible at design time. (Inherited from ControlDesigner.)
Top
Methods
 | Name | Description
Protected method | CreateErrorDesignTimeHtml(String) | Creates HTML markup to display a specified error message at design time. (Inherited from ControlDesigner.)
Protected method | CreateErrorDesignTimeHtml(String, Exception) | Creates the HTML markup to display a specified exception error message at design time. (Inherited from ControlDesigner.)
Protected method | CreatePlaceHolderDesignTimeHtml | Provides a simple rectangular placeholder representation that displays the type and ID of the control. (Inherited from ControlDesigner.)
Protected method | CreatePlaceHolderDesignTimeHtml(String) | Provides a simple rectangular placeholder representation that displays the type and ID of the control, and also additional specified instructions or information. (Inherited from ControlDesigner.)
Protected method | CreateViewControl | Returns a copy of the associated control for viewing or rendering on the design surface. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources that are used by the HtmlControlDesigner object and optionally releases the managed resources. (Inherited from HtmlControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Public method | GetBounds | Retrieves the coordinates of the rectangle representing the boundaries for the control as displayed on the design surface. (Inherited from ControlDesigner.)
Public method | GetDesignTimeHtml | Returns a design view of the control as rendered by the control itself. (Overrides ControlDesignerGetDesignTimeHtml.)
Public method | GetDesignTimeHtml(DesignerRegionCollection) | Retrieves the HTML markup to display the control and populates the collection with the current control designer regions. (Inherited from ControlDesigner.)
Public method | GetEditableDesignerRegionContent | Returns the content for an editable region of the design-time view of the associated control. (Inherited from ControlDesigner.)
Protected method | GetEmptyDesignTimeHtml | Retrieves the HTML markup to represent a Web server control at design time that will have no visual representation at run time. (Inherited from ControlDesigner.)
Protected method | GetErrorDesignTimeHtml | Gets a styled error message from an exception. (Overrides ControlDesignerGetErrorDesignTimeHtml(Exception).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPersistenceContent | Retrieves the persistable inner HTML markup of the control at design time. (Inherited from ControlDesigner.)
Public method | GetPersistInnerHtml | Obsolete. Retrieves the persistable inner HTML markup of the control. (Inherited from ControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewRendering | Retrieves an object that contains the design-time markup for the content and regions of the associated control. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes a component. (Overrides ControlDesignerInitialize(IComponent).)
Public method | InitializeExistingComponent | Reinitializes an existing component. (Inherited from ComponentDesigner.)
Public method | InitializeNewComponent | Initializes a newly created component. (Inherited from ComponentDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | Invalidate | Invalidates the whole area of the control that is displayed on the design surface and signals the control designer to redraw the control. (Inherited from ControlDesigner.)
Public method | Invalidate(Rectangle) | Invalidates the specified area of the control that is displayed on the design surface and signals the control designer to redraw the control. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Public method | IsPropertyBound | Obsolete. Retrieves a value indicating whether the specified property on the associated control is data-bound. (Inherited from ControlDesigner.)
Public method | Localize | Uses the provided resource writer to persist the localizable properties of the associated control to a resource in the design host. (Inherited from ControlDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAutoFormatApplied | Called when a predefined, automatic formatting scheme has been applied to the associated control. (Inherited from ControlDesigner.)
Protected method | OnBehaviorAttached | Obsolete. Called when a behavior is associated with the element. (Inherited from HtmlControlDesigner.)
Protected method | OnBehaviorDetaching | Obsolete. Called when a behavior disassociates from the element. (Inherited from HtmlControlDesigner.)
Protected method | OnBindingsCollectionChanged | Obsolete. Called when the data-binding collection changes. (Inherited from ControlDesigner.)
Protected method | OnClick | Called by the design host when the user clicks the associated control at design time. (Inherited from ControlDesigner.)
Public method | OnComponentChanged | Called when the associated control changes. (Overrides ControlDesignerOnComponentChanged(Object, ComponentChangedEventArgs).)
Public method | OnComponentChanging | Represents the method that will handle the ComponentChanging event for the associated control. (Inherited from ControlDesigner.)
Protected method | OnControlResize | Obsolete. Called when the associated Web server control has been resized in the design host at design time. (Overrides ControlDesignerOnControlResize.)
Protected method | OnPaint | Called when the control designer draws the associated control on the design surface, if the CustomPaint value is true. (Inherited from ControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Sets the default properties for the component. (Inherited from ComponentDesigner.)
Public method | OnSetParent | Provides a way to perform additional processing when the associated control is attached to a parent control. (Inherited from HtmlControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Sets the list of events that are exposed at design-time for the TypeDescriptor object for the component. (Inherited from HtmlControlDesigner.)
Protected method | PreFilterProperties | Adds properties to or removes properties from the Properties grid in a design host at design time or provides new design-time properties that might correspond to properties on the associated control. (Inherited from ControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | RaiseResizeEvent | Obsolete. Raises the OnControlResize event. (Inherited from ControlDesigner.)
Public method | RegisterClone | Registers internal data in a cloned control. (Inherited from ControlDesigner.)
Public method | SetEditableDesignerRegionContent | Specifies the content for an editable region of the control at design time. (Inherited from ControlDesigner.)
Protected method | SetRegionContent | Specifies the content for an editable region in the design-time view of the control. (Inherited from ControlDesigner.)
Protected method | SetViewFlags | Assigns the specified bitwise ViewFlags enumeration to the specified flag value. (Inherited from ControlDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDesignTimeHtml | Refreshes the design-time HTML markup for the associated Web server control by calling the GetDesignTimeHtml method. (Inherited from ControlDesigner.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner Constructor

Initializes a new instance of the WebViewerControlDesigner class

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControlDesigner()
Public Sub New
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner Properties

The WebViewerControlDesigner type exposes the following members.

Properties
 | Name | Description
Public property | ActionLists | Gets the action list collection for the control designer. (Inherited from ControlDesigner.)
Public property | AllowResize | Gets a value indicating if this can be resized. (Overrides ControlDesignerAllowResize.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ComponentDesigner.)
Public property | AutoFormats | Gets the collection of predefined automatic formatting schemes to display in the Auto Format dialog box for the associated control at design time. (Inherited from ControlDesigner.)
Public property | Behavior | Obsolete. Gets or sets the DHTML behavior that is associated with the designer. (Inherited from HtmlControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | DataBindings | Gets the data bindings collection for the current control. (Inherited from HtmlControlDesigner.)
Protected property | DataBindingsEnabled | Gets a value indicating whether data binding is supported by the containing region for the associated control. (Inherited from ControlDesigner.)
Protected property | DesignerState | Gets an object that is used to persist data for the associated control at design time. (Inherited from ControlDesigner.)
Protected property | DesignTimeElement | Obsolete. Gets the design-time object representing the control that is associated with the HtmlControlDesigner object on the design surface. (Inherited from HtmlControlDesigner.)
Protected property | DesignTimeElementView | Obsolete. Gets the view-control object for the control designer. (Inherited from ControlDesigner.)
Public property | DesignTimeHtmlRequiresLoadComplete | Obsolete. Gets a value indicating whether the design host must finish loading before the GetDesignTimeHtml method can be called. (Inherited from ControlDesigner.)
Public property | Expressions | Gets the expression bindings for the current control at design time. (Inherited from HtmlControlDesigner.)
Protected property | HidePropertiesInTemplateMode | Gets a value indicating whether the properties of the associated control are hidden when the control is in template mode. (Inherited from ControlDesigner.)
Public property | ID | Gets or sets the ID string for the control. (Inherited from ControlDesigner.)
Protected property | InheritanceAttribute | Gets an attribute that indicates the type of inheritance of the associated component. (Inherited from ComponentDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | InTemplateMode | Gets a value indicating whether the control is in either template viewing or editing mode in the design host. The InTemplateMode property is read-only. (Inherited from ControlDesigner.)
Public property | IsDirty | Obsolete. Gets or sets a value indicating whether the Web server control has been marked as changed. (Inherited from ControlDesigner.)
Protected property | ParentComponent | Gets the parent component for this designer. (Inherited from ComponentDesigner.)
Public property | ReadOnly | Obsolete. Gets or sets a value indicating whether the properties of the control are read-only at design time. (Inherited from ControlDesigner.)
Protected property | RootDesigner | Gets the control designer for the Web Forms page that contains the associated control. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | ShouldCodeSerialize | Obsolete. Gets or sets a value indicating whether to create a field declaration for the control in the code-behind file for the current design document during serialization. (Inherited from HtmlControlDesigner.)
Protected property | Tag | Gets an object representing the HTML markup element for the associated control. (Inherited from ControlDesigner.)
Public property | TemplateGroups | Gets a collection of template groups, each containing one or more template definitions. (Inherited from ControlDesigner.)
Protected property | UsePreviewControl | Gets a value indicating whether the control designer uses a temporary preview control to generate the design-time HTML markup. (Inherited from ControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Public property | ViewControl | Gets or sets a Web server control that can be used for previewing the design-time HTML markup. (Inherited from ControlDesigner.)
Public property | ViewControlCreated | Gets or sets a value indicating whether a View control has been created for display on the design surface. (Inherited from ControlDesigner.)
Protected property | Visible | Gets a value that indicates whether the control is visible at design time. (Inherited from ControlDesigner.)
Top
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.AllowResize Property

WebViewerControlDesignerAllowResize Property

Gets a value indicating if this can be resized.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool AllowResize { get; }
Public Overrides ReadOnly Property AllowResize As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner Methods

The WebViewerControlDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | CreateErrorDesignTimeHtml(String) | Creates HTML markup to display a specified error message at design time. (Inherited from ControlDesigner.)
Protected method | CreateErrorDesignTimeHtml(String, Exception) | Creates the HTML markup to display a specified exception error message at design time. (Inherited from ControlDesigner.)
Protected method | CreatePlaceHolderDesignTimeHtml | Provides a simple rectangular placeholder representation that displays the type and ID of the control. (Inherited from ControlDesigner.)
Protected method | CreatePlaceHolderDesignTimeHtml(String) | Provides a simple rectangular placeholder representation that displays the type and ID of the control, and also additional specified instructions or information. (Inherited from ControlDesigner.)
Protected method | CreateViewControl | Returns a copy of the associated control for viewing or rendering on the design surface. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources that are used by the HtmlControlDesigner object and optionally releases the managed resources. (Inherited from HtmlControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Public method | GetBounds | Retrieves the coordinates of the rectangle representing the boundaries for the control as displayed on the design surface. (Inherited from ControlDesigner.)
Public method | GetDesignTimeHtml | Returns a design view of the control as rendered by the control itself. (Overrides ControlDesignerGetDesignTimeHtml.)
Public method | GetDesignTimeHtml(DesignerRegionCollection) | Retrieves the HTML markup to display the control and populates the collection with the current control designer regions. (Inherited from ControlDesigner.)
Public method | GetEditableDesignerRegionContent | Returns the content for an editable region of the design-time view of the associated control. (Inherited from ControlDesigner.)
Protected method | GetEmptyDesignTimeHtml | Retrieves the HTML markup to represent a Web server control at design time that will have no visual representation at run time. (Inherited from ControlDesigner.)
Protected method | GetErrorDesignTimeHtml | Gets a styled error message from an exception. (Overrides ControlDesignerGetErrorDesignTimeHtml(Exception).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPersistenceContent | Retrieves the persistable inner HTML markup of the control at design time. (Inherited from ControlDesigner.)
Public method | GetPersistInnerHtml | Obsolete. Retrieves the persistable inner HTML markup of the control. (Inherited from ControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewRendering | Retrieves an object that contains the design-time markup for the content and regions of the associated control. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes a component. (Overrides ControlDesignerInitialize(IComponent).)
Public method | InitializeExistingComponent | Reinitializes an existing component. (Inherited from ComponentDesigner.)
Public method | InitializeNewComponent | Initializes a newly created component. (Inherited from ComponentDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | Invalidate | Invalidates the whole area of the control that is displayed on the design surface and signals the control designer to redraw the control. (Inherited from ControlDesigner.)
Public method | Invalidate(Rectangle) | Invalidates the specified area of the control that is displayed on the design surface and signals the control designer to redraw the control. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Public method | IsPropertyBound | Obsolete. Retrieves a value indicating whether the specified property on the associated control is data-bound. (Inherited from ControlDesigner.)
Public method | Localize | Uses the provided resource writer to persist the localizable properties of the associated control to a resource in the design host. (Inherited from ControlDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAutoFormatApplied | Called when a predefined, automatic formatting scheme has been applied to the associated control. (Inherited from ControlDesigner.)
Protected method | OnBehaviorAttached | Obsolete. Called when a behavior is associated with the element. (Inherited from HtmlControlDesigner.)
Protected method | OnBehaviorDetaching | Obsolete. Called when a behavior disassociates from the element. (Inherited from HtmlControlDesigner.)
Protected method | OnBindingsCollectionChanged | Obsolete. Called when the data-binding collection changes. (Inherited from ControlDesigner.)
Protected method | OnClick | Called by the design host when the user clicks the associated control at design time. (Inherited from ControlDesigner.)
Public method | OnComponentChanged | Called when the associated control changes. (Overrides ControlDesignerOnComponentChanged(Object, ComponentChangedEventArgs).)
Public method | OnComponentChanging | Represents the method that will handle the ComponentChanging event for the associated control. (Inherited from ControlDesigner.)
Protected method | OnControlResize | Obsolete. Called when the associated Web server control has been resized in the design host at design time. (Overrides ControlDesignerOnControlResize.)
Protected method | OnPaint | Called when the control designer draws the associated control on the design surface, if the CustomPaint value is true. (Inherited from ControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Sets the default properties for the component. (Inherited from ComponentDesigner.)
Public method | OnSetParent | Provides a way to perform additional processing when the associated control is attached to a parent control. (Inherited from HtmlControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Sets the list of events that are exposed at design-time for the TypeDescriptor object for the component. (Inherited from HtmlControlDesigner.)
Protected method | PreFilterProperties | Adds properties to or removes properties from the Properties grid in a design host at design time or provides new design-time properties that might correspond to properties on the associated control. (Inherited from ControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | RaiseResizeEvent | Obsolete. Raises the OnControlResize event. (Inherited from ControlDesigner.)
Public method | RegisterClone | Registers internal data in a cloned control. (Inherited from ControlDesigner.)
Public method | SetEditableDesignerRegionContent | Specifies the content for an editable region of the control at design time. (Inherited from ControlDesigner.)
Protected method | SetRegionContent | Specifies the content for an editable region in the design-time view of the control. (Inherited from ControlDesigner.)
Protected method | SetViewFlags | Assigns the specified bitwise ViewFlags enumeration to the specified flag value. (Inherited from ControlDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDesignTimeHtml | Refreshes the design-time HTML markup for the associated Web server control by calling the GetDesignTimeHtml method. (Inherited from ControlDesigner.)
Top
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.GetDesignTimeHtml Method

WebViewerControlDesignerGetDesignTimeHtml Method

Overload List
 | Name | Description
Public method | GetDesignTimeHtml | Returns a design view of the control as rendered by the control itself. (Overrides ControlDesignerGetDesignTimeHtml.)
Public method | GetDesignTimeHtml(DesignerRegionCollection) | Retrieves the HTML markup to display the control and populates the collection with the current control designer regions. (Inherited from ControlDesigner.)
Top
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.GetDesignTimeHtml Method

WebViewerControlDesignerGetDesignTimeHtml Method

Returns a design view of the control as rendered by the control itself.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string GetDesignTimeHtml()
Public Overrides Function GetDesignTimeHtml As String

Return Value

Type: String
The HTML of the design time control.
See Also

Reference

WebViewerControlDesigner Class
GetDesignTimeHtml Overload
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.GetErrorDesignTimeHtml Method

WebViewerControlDesignerGetErrorDesignTimeHtml Method

Gets a styled error message from an exception.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string GetErrorDesignTimeHtml(
    Exception e
)
Protected Overrides Function GetErrorDesignTimeHtml (
    e As Exception
) As String

Parameters

e
Type: SystemException
The exception.

Return Value

Type: String
HTML formatted error message.
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.Initialize Method

WebViewerControlDesignerInitialize Method

Initializes a component.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Initialize(
    IComponent component
)
Public Overrides Sub Initialize (
    component As IComponent
)

Parameters

component
Type: System.ComponentModelIComponent
The component.

Implements

IDesignerInitialize(IComponent)
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.OnComponentChanged Method

WebViewerControlDesignerOnComponentChanged Method

Called when the associated control changes.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void OnComponentChanged(
    Object sender,
    ComponentChangedEventArgs ce
)
Public Overrides Sub OnComponentChanged (
    sender As Object,
    ce As ComponentChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
ce
Type: System.ComponentModel.DesignComponentChangedEventArgs
A ComponentChangedEventArgs object that contains the event data.
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


WebViewerControlDesigner.OnControlResize Method

WebViewerControlDesignerOnControlResize Method

Note: This API is now obsolete.

Called when the associated Web server control has been resized in the design host at design time.

Namespace: Atalasoft.Imaging.WebControls
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The recommended alternative is OnComponentChanged()")]
protected override void OnControlResize()
<ObsoleteAttribute("The recommended alternative is OnComponentChanged()")>
Protected Overrides Sub OnControlResize
See Also

Reference

WebViewerControlDesigner Class
Atalasoft.Imaging.WebControls Namespace


Atalasoft.Imaging.WebControls.Annotations Namespace

Classes
 | Class | Description
Public class | AnnotationCreatedEventArgs | This class is used to with the AnnotationCreated event.
Public class | WebAnnotationController | The WebAnnotationController mimics specific behaviors of the AnnotationController for use from with ASP.NET. It contains a LayerCollection for any number of LayerAnnotation objects, each containing any number of annotations.
Public class | WebAnnotationViewer | This control derives from DotImage WebImageViewer and contains a reference to an WebAnnotationController. Drop this control onto a web form to start creating annotations.
Public class | WebCommentUIFactory | The WebComment IAnnotationUIFactory implementation.
Public class | WebPdfLinkUIFactory | The WebPdfLink IAnnotationUIFactory implementation.
Delegates
 | Delegate | Description
Public delegate | AnnotationCreatedEventHandler | This event handler is used with the AnnotationCreated event to process created AnnotationData objects.
Enumerations
 | Enumeration | Description
Public enumeration | AuthorMode | Specifies the how many annotations can be created while using InteractMode.Author
Public enumeration | WebAnnotationInteractMode | Specifies the user interaction mode for the WebAnnotationViewer.


AnnotationCreatedEventArgs Class

This class is used to with the AnnotationCreated event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WebControls.AnnotationsAnnotationCreatedEventArgs

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationCreatedEventArgs : EventArgs
Public Class AnnotationCreatedEventArgs
    Inherits EventArgs

The AnnotationCreatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationCreatedEventArgs | Creates a new instance of AnnotationCreatedEventArgs.
Public method | AnnotationCreatedEventArgs(AnnotationData) | Creates a new instance of AnnotationCreatedEventArgs with the specified AnnotationData object.
Top
Properties
 | Name | Description
Public property | AnnotationData | Gets the AnnotationData object that was created to trigger this event.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventArgs Constructor

Creates a new instance of AnnotationCreatedEventArgs.
Overload List
 | Name | Description
Public method | AnnotationCreatedEventArgs | Creates a new instance of AnnotationCreatedEventArgs.
Public method | AnnotationCreatedEventArgs(AnnotationData) | Creates a new instance of AnnotationCreatedEventArgs with the specified AnnotationData object.
Top
See Also

Reference

AnnotationCreatedEventArgs Class
Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventArgs Constructor

Creates a new instance of AnnotationCreatedEventArgs.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationCreatedEventArgs()
Public Sub New
See Also

Reference

AnnotationCreatedEventArgs Class
AnnotationCreatedEventArgs Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventArgs Constructor (AnnotationData)

Creates a new instance of AnnotationCreatedEventArgs with the specified AnnotationData object.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationCreatedEventArgs(
    AnnotationData data
)
Public Sub New (
    data As AnnotationData
)

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
AnnotationData object that was created.
See Also

Reference

AnnotationCreatedEventArgs Class
AnnotationCreatedEventArgs Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventArgs Properties

The AnnotationCreatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationData | Gets the AnnotationData object that was created to trigger this event.
Top
See Also

Reference

AnnotationCreatedEventArgs Class
Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventArgs.AnnotationData Property

AnnotationCreatedEventArgsAnnotationData Property

Gets the AnnotationData object that was created to trigger this event.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationData AnnotationData { get; set; }
Public Property AnnotationData As AnnotationData
    Get
    Set

Property Value

Type: AnnotationData
See Also

Reference

AnnotationCreatedEventArgs Class
Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventArgs Methods

The AnnotationCreatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationCreatedEventArgs Class
Atalasoft.Imaging.WebControls.Annotations Namespace


AnnotationCreatedEventHandler Delegate

This event handler is used with the AnnotationCreated event to process created AnnotationData objects.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AnnotationCreatedEventHandler(
    Object sender,
    AnnotationCreatedEventArgs e
)
Public Delegate Sub AnnotationCreatedEventHandler (
    sender As Object,
    e As AnnotationCreatedEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Imaging.WebControls.AnnotationsAnnotationCreatedEventArgs
An AnnotationCreatedEventArgs containing information about this event.
Remarks
This is the delegate signature for the event handler for the AnnotationCreated event.
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


AuthorMode Enumeration

Specifies the how many annotations can be created while using InteractMode.Author

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AuthorMode
Public Enumeration AuthorMode
Members
Member name | Description
Unlimited | Enable the creation of an unlimited number of annotations with the mouse, InteractMode will not change.
Single | Enable the creation of one annotation with the mouse, changes the InteractMode to Author when CreateAnnotation is called, and changes the InteractMode back to the previous value once the annotation has been created.
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController Class

The WebAnnotationController mimics specific behaviors of the AnnotationController for use from with ASP.NET. It contains a LayerCollection for any number of LayerAnnotation objects, each containing any number of annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.AnnotationsWebAnnotationController

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebAnnotationController : IComponent,
    IDisposable
Public Class WebAnnotationController
    Implements IComponent, IDisposable

The WebAnnotationController type exposes the following members.

Constructors
 | Name | Description
Public method | WebAnnotationController | Creates a new instance of WebAnnotationController.
Top
Properties
 | Name | Description
Public property | AuthorMode | Gets or sets a value which determines how many annotations are created by the mouse after CreateAnnotation is called. AuthorMode. Single will change InteractMode back to the original value or closest non Author value, after annotation creation.
Public property | CurrentLayer | Gets or sets the current active layer.
Public property | DefaultAnnotations | Gets or sets the default annotations.
Public property | Factories | Gets the AnnotationUIFactoryCollection containing IAnnotationUIFactory objects used to create annotations from AnnotationData classes.
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the AnnotationController.
Public property | LastUniqueIndex | Gets the last unique index of the annotations loaded into this WebAnnotationController.
Public property | Layers | Gets or sets the LayerCollection used by the WebAnnotationController.
Public property | SelectedAnnotations | Gets an array of annotations currently selected.
Public property | Site | Gets or sets the site of the control.
Top
Methods
 | Name | Description
Protected method | CreateAnnotationImage(AnnotationUI) | Creates an image for an annotation.
Protected method | CreateAnnotationImage(AnnotationData, IAnnotationRenderer) | Creates an image for an annotation using a specified renderer.
Public method | Dispose | Releases memory used by the AnnotationController and all of its annotations.
Protected method | Dispose(Boolean) | Releases memory used by the AnnotationController and all of its annotations.
Protected method | DisposeManagedResources | Releases managed memory used by the AnnotationController and all of its annotations.
Protected method | DisposeUnmanagedResources | Releases unmanaged memory used by the AnnotationController and all of its annotations.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetAnnotation(Int32, Int32, Int32) |
Public method | GetAnnotation(Int32, Int32, Int32, String) | Gets the AnnotationUI object at the given layerIndex, groupIndex, and annIndex.
Public method | GetGroup | Gets the n'th group in the annotation tree on the Layer at the given layerIndex.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load(Stream, AnnotationDataFormat) | Loads annotation data from a stream using the supplied formatter into the Layers collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderAnnotation(Int32, Int32, Int32, Double) | Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, and annIndex at the given zoom level.
Public method | RenderAnnotation(Int32, Int32, Int32, String, Double) | Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, ID and annIndex at the given zoom level.
Public method | Save(IFormatter) | Saves the annotations to a byte array using the specified formatter.
Public method | Save(Stream, AnnotationDataFormat) | Saves the annotations to a stream using the specified formatter.
Public method | Save(Stream, IFormatter) | Saves the annotations to a stream using the specified formatter.
Public method | Save(String, AnnotationDataFormat) | Saves the annotations to a file using the specified formatter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Disposed | Raised when the WebAnnotationController has been disposed.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController Constructor

Creates a new instance of WebAnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebAnnotationController()
Public Sub New
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController Properties

The WebAnnotationController type exposes the following members.

Properties
 | Name | Description
Public property | AuthorMode | Gets or sets a value which determines how many annotations are created by the mouse after CreateAnnotation is called. AuthorMode. Single will change InteractMode back to the original value or closest non Author value, after annotation creation.
Public property | CurrentLayer | Gets or sets the current active layer.
Public property | DefaultAnnotations | Gets or sets the default annotations.
Public property | Factories | Gets the AnnotationUIFactoryCollection containing IAnnotationUIFactory objects used to create annotations from AnnotationData classes.
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the AnnotationController.
Public property | LastUniqueIndex | Gets the last unique index of the annotations loaded into this WebAnnotationController.
Public property | Layers | Gets or sets the LayerCollection used by the WebAnnotationController.
Public property | SelectedAnnotations | Gets an array of annotations currently selected.
Public property | Site | Gets or sets the site of the control.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.AuthorMode Property

WebAnnotationControllerAuthorMode Property

Gets or sets a value which determines how many annotations are created by the mouse after CreateAnnotation is called. AuthorMode. Single will change InteractMode back to the original value or closest non Author value, after annotation creation.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AuthorMode AuthorMode { get; set; }
Public Property AuthorMode As AuthorMode
    Get
    Set

Property Value

Type: AuthorMode
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.CurrentLayer Property

WebAnnotationControllerCurrentLayer Property

Gets or sets the current active layer.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerAnnotation CurrentLayer { get; set; }
Public Property CurrentLayer As LayerAnnotation
    Get
    Set

Property Value

Type: LayerAnnotation
The current LayerAnnotation being used.
Remarks

When an annotation is selected, either through code or by the user, the layer it's contained in becomes the current layer. When multiple annotations in different layers are selected, the last selected annotation's layer will become the current layer.

When an annotation is created by the user, it will be added as a child of the current layer.

See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.DefaultAnnotations Property

WebAnnotationControllerDefaultAnnotations Property

Gets or sets the default annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataCollection DefaultAnnotations { get; set; }
Public Property DefaultAnnotations As AnnotationDataCollection
    Get
    Set

Property Value

Type: AnnotationDataCollection
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Factories Property

WebAnnotationControllerFactories Property

Gets the AnnotationUIFactoryCollection containing IAnnotationUIFactory objects used to create annotations from AnnotationData classes.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUIFactoryCollection Factories { get; }
Public ReadOnly Property Factories As AnnotationUIFactoryCollection
    Get

Property Value

Type: AnnotationUIFactoryCollection
The annotation factory collection used to create AnnotationUI objects from AnnotationData classes.
Remarks
The UI factories are used when deserializing AnnotationData classes. When custom annotations are used for serialization an IAnnotationUIFactory for the UI should be added to the factory collection.
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.InteractMode Property

WebAnnotationControllerInteractMode Property

Gets or sets a value specifying the user interactive mode of the AnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebAnnotationInteractMode InteractMode { get; set; }
Public Property InteractMode As WebAnnotationInteractMode
    Get
    Set

Property Value

Type: WebAnnotationInteractMode
The interaction mode of the AnnotationController.
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.LastUniqueIndex Property

WebAnnotationControllerLastUniqueIndex Property

Gets the last unique index of the annotations loaded into this WebAnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int LastUniqueIndex { get; }
Public ReadOnly Property LastUniqueIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Layers Property

WebAnnotationControllerLayers Property

Gets or sets the LayerCollection used by the WebAnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LayerCollection Layers { get; set; }
Public Property Layers As LayerCollection
    Get
    Set

Property Value

Type: LayerCollection
The LayerCollection used for this controller.
Remarks
Each AnnotationController must have its own LayerCollection. Setting the Layers property of more than one AnnotationController to the same LayerCollection will have unforeseen consequences.
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.SelectedAnnotations Property

WebAnnotationControllerSelectedAnnotations Property

Gets an array of annotations currently selected.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUICollection SelectedAnnotations { get; set; }
Public Property SelectedAnnotations As AnnotationUICollection
    Get
    Set

Property Value

Type: AnnotationUICollection
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Site Property

WebAnnotationControllerSite Property

Gets or sets the site of the control.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ISite Site { get; set; }
Public Property Site As ISite
    Get
    Set

Property Value

Type: ISite

Implements

IComponentSite
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController Methods

The WebAnnotationController type exposes the following members.

Methods
 | Name | Description
Protected method | CreateAnnotationImage(AnnotationUI) | Creates an image for an annotation.
Protected method | CreateAnnotationImage(AnnotationData, IAnnotationRenderer) | Creates an image for an annotation using a specified renderer.
Public method | Dispose | Releases memory used by the AnnotationController and all of its annotations.
Protected method | Dispose(Boolean) | Releases memory used by the AnnotationController and all of its annotations.
Protected method | DisposeManagedResources | Releases managed memory used by the AnnotationController and all of its annotations.
Protected method | DisposeUnmanagedResources | Releases unmanaged memory used by the AnnotationController and all of its annotations.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetAnnotation(Int32, Int32, Int32) |
Public method | GetAnnotation(Int32, Int32, Int32, String) | Gets the AnnotationUI object at the given layerIndex, groupIndex, and annIndex.
Public method | GetGroup | Gets the n'th group in the annotation tree on the Layer at the given layerIndex.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load(Stream, AnnotationDataFormat) | Loads annotation data from a stream using the supplied formatter into the Layers collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderAnnotation(Int32, Int32, Int32, Double) | Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, and annIndex at the given zoom level.
Public method | RenderAnnotation(Int32, Int32, Int32, String, Double) | Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, ID and annIndex at the given zoom level.
Public method | Save(IFormatter) | Saves the annotations to a byte array using the specified formatter.
Public method | Save(Stream, AnnotationDataFormat) | Saves the annotations to a stream using the specified formatter.
Public method | Save(Stream, IFormatter) | Saves the annotations to a stream using the specified formatter.
Public method | Save(String, AnnotationDataFormat) | Saves the annotations to a file using the specified formatter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.CreateAnnotationImage Method

WebAnnotationControllerCreateAnnotationImage Method

Overload List
 | Name | Description
Protected method | CreateAnnotationImage(AnnotationUI) | Creates an image for an annotation.
Protected method | CreateAnnotationImage(AnnotationData, IAnnotationRenderer) | Creates an image for an annotation using a specified renderer.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.CreateAnnotationImage Method (AnnotationUI)

WebAnnotationControllerCreateAnnotationImage Method (AnnotationUI)

Creates an image for an annotation.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage CreateAnnotationImage(
    AnnotationUI ann
)
Protected Function CreateAnnotationImage (
    ann As AnnotationUI
) As AtalaImage

Parameters

ann
Type: Atalasoft.Annotate.UIAnnotationUI
The annotation.

Return Value

Type: AtalaImage
An image representation of the annotation.
See Also

Reference

WebAnnotationController Class
CreateAnnotationImage Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.CreateAnnotationImage Method (AnnotationData, IAnnotationRenderer)

WebAnnotationControllerCreateAnnotationImage Method (AnnotationData, IAnnotationRenderer)

Creates an image for an annotation using a specified renderer.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage CreateAnnotationImage(
    AnnotationData data,
    IAnnotationRenderer renderer
)
Protected Function CreateAnnotationImage (
    data As AnnotationData,
    renderer As IAnnotationRenderer
) As AtalaImage

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data.
renderer
Type: Atalasoft.Annotate.RendererIAnnotationRenderer
The renderer to use.

Return Value

Type: AtalaImage
An image representation of the annotation.
See Also

Reference

WebAnnotationController Class
CreateAnnotationImage Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Dispose Method

WebAnnotationControllerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases memory used by the AnnotationController and all of its annotations.
Protected method | Dispose(Boolean) | Releases memory used by the AnnotationController and all of its annotations.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Dispose Method

WebAnnotationControllerDispose Method

Releases memory used by the AnnotationController and all of its annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
All annotations and supporting objects implementing the IDisposeable interface will be disposed in this process. To prevent them from being disposed they must be removed from the controller prior to calling this method.
See Also

Reference

WebAnnotationController Class
Dispose Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Dispose Method (Boolean)

WebAnnotationControllerDispose Method (Boolean)

Releases memory used by the AnnotationController and all of its annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

WebAnnotationController Class
Dispose Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.DisposeManagedResources Method

WebAnnotationControllerDisposeManagedResources Method

Releases managed memory used by the AnnotationController and all of its annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.DisposeUnmanagedResources Method

WebAnnotationControllerDisposeUnmanagedResources Method

Releases unmanaged memory used by the AnnotationController and all of its annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Finalize Method

WebAnnotationControllerFinalize Method

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.GetAnnotation Method

WebAnnotationControllerGetAnnotation Method

Overload List
 | Name | Description
Public method | GetAnnotation(Int32, Int32, Int32) |
Public method | GetAnnotation(Int32, Int32, Int32, String) | Gets the AnnotationUI object at the given layerIndex, groupIndex, and annIndex.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.GetAnnotation Method (Int32, Int32, Int32)

WebAnnotationControllerGetAnnotation Method (Int32, Int32, Int32)

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotation(
    int layerIndex,
    int groupIndex,
    int annIndex
)
Public Function GetAnnotation (
    layerIndex As Integer,
    groupIndex As Integer,
    annIndex As Integer
) As AnnotationUI

Parameters

layerIndex
Type: SystemInt32
Index of the layer that the annotation is on.
groupIndex
Type: SystemInt32
Index of the group that the annotation is on. This should be -1 if the annotation is not in a group.
annIndex
Type: SystemInt32
Index of the annotation relative to the parent object.

Return Value

Type: AnnotationUI
See Also

Reference

WebAnnotationController Class
GetAnnotation Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.GetAnnotation Method (Int32, Int32, Int32, String)

WebAnnotationControllerGetAnnotation Method (Int32, Int32, Int32, String)

Gets the AnnotationUI object at the given layerIndex, groupIndex, and annIndex.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotation(
    int layerIndex,
    int groupIndex,
    int annIndex,
    string uniqueID
)
Public Function GetAnnotation (
    layerIndex As Integer,
    groupIndex As Integer,
    annIndex As Integer,
    uniqueID As String
) As AnnotationUI

Parameters

layerIndex
Type: SystemInt32
groupIndex
Type: SystemInt32
annIndex
Type: SystemInt32
uniqueID
Type: SystemString

Return Value

Type: AnnotationUI
Returns an AnnotationUI object if one is found, null otherwise.
See Also

Reference

WebAnnotationController Class
GetAnnotation Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.GetGroup Method

WebAnnotationControllerGetGroup Method

Gets the n'th group in the annotation tree on the Layer at the given layerIndex.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetGroup(
    int layerIndex,
    int n
)
Public Function GetGroup (
    layerIndex As Integer,
    n As Integer
) As AnnotationUI

Parameters

layerIndex
Type: SystemInt32
Index of the layer that the group is on.
n
Type: SystemInt32

Number that represents the index of the desired group while all groups on the desired layer are counted in sequential order.

Return Value

Type: AnnotationUI
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Load Method

WebAnnotationControllerLoad Method

Use these methods to load annotation data into the controller.
Overload List
 | Name | Description
Public method | Load(Stream, AnnotationDataFormat) | Loads annotation data from a stream using the supplied formatter into the Layers collection.
Public method | Load(String, AnnotationDataFormat) | Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Load Method (Stream, AnnotationDataFormat)

WebAnnotationControllerLoad Method (Stream, AnnotationDataFormat)

Loads annotation data from a stream using the supplied formatter into the Layers collection.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    Stream stream,
    AnnotationDataFormat format
)
Public Sub Load (
    stream As Stream,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
The stream that contains the annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The AnnotationDataFormat to use while loading.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

WebAnnotationController Class
Load Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Load Method (String, AnnotationDataFormat)

WebAnnotationControllerLoad Method (String, AnnotationDataFormat)

Loads annotation data from a file using the supplied formatter and adds the annotations to the Layers collection.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Load(
    string fileName,
    AnnotationDataFormat format
)
Public Sub Load (
    fileName As String,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The absolute file path to the file containing the annotation data.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The AnnotationDataFormat to use while loading.
Exceptions
Exception | Condition
SerializationException | Thrown if there is an error reading the data.
See Also

Reference

WebAnnotationController Class
Load Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.RenderAnnotation Method

WebAnnotationControllerRenderAnnotation Method

Overload List
 | Name | Description
Public method | RenderAnnotation(Int32, Int32, Int32, Double) | Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, and annIndex at the given zoom level.
Public method | RenderAnnotation(Int32, Int32, Int32, String, Double) | Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, ID and annIndex at the given zoom level.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.RenderAnnotation Method (Int32, Int32, Int32, Double)

WebAnnotationControllerRenderAnnotation Method (Int32, Int32, Int32, Double)

Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, and annIndex at the given zoom level.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage RenderAnnotation(
    int layerIndex,
    int groupIndex,
    int annIndex,
    double z
)
Public Function RenderAnnotation (
    layerIndex As Integer,
    groupIndex As Integer,
    annIndex As Integer,
    z As Double
) As AtalaImage

Parameters

layerIndex
Type: SystemInt32
Index of the layer that the annotation is on.
groupIndex
Type: SystemInt32
Index of the group that the annotation is on. This should be -1 if the annotation is not in a group.
annIndex
Type: SystemInt32
Index of the annotation relative to the parent object.
z
Type: SystemDouble
The desired zoom level of the image.

Return Value

Type: AtalaImage
See Also

Reference

WebAnnotationController Class
RenderAnnotation Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.RenderAnnotation Method (Int32, Int32, Int32, String, Double)

WebAnnotationControllerRenderAnnotation Method (Int32, Int32, Int32, String, Double)

Gets an AtalaImage that represents the AnnotationUI object at the given layerIndex, groupIndex, ID and annIndex at the given zoom level.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage RenderAnnotation(
    int layerIndex,
    int groupIndex,
    int annIndex,
    string uniqueID,
    double z
)
Public Function RenderAnnotation (
    layerIndex As Integer,
    groupIndex As Integer,
    annIndex As Integer,
    uniqueID As String,
    z As Double
) As AtalaImage

Parameters

layerIndex
Type: SystemInt32
Index of the layer that the annotation is on.
groupIndex
Type: SystemInt32
Index of the group that the annotation is on. This should be -1 if the annotation is not in a group.
annIndex
Type: SystemInt32
Index of the annotation relative to the parent object.
uniqueID
Type: SystemString
The annotation ID
z
Type: SystemDouble
The desired zoom level of the image.

Return Value

Type: AtalaImage
See Also

Reference

WebAnnotationController Class
RenderAnnotation Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Save Method

WebAnnotationControllerSave Method

Use these methods to save the annotations into the specified format.
Overload List
 | Name | Description
Public method | Save(IFormatter) | Saves the annotations to a byte array using the specified formatter.
Public method | Save(Stream, AnnotationDataFormat) | Saves the annotations to a stream using the specified formatter.
Public method | Save(Stream, IFormatter) | Saves the annotations to a stream using the specified formatter.
Public method | Save(String, AnnotationDataFormat) | Saves the annotations to a file using the specified formatter.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Save Method (IFormatter)

WebAnnotationControllerSave Method (IFormatter)

Saves the annotations to a byte array using the specified formatter.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] Save(
    IFormatter formatter
)
Public Function Save (
    formatter As IFormatter
) As Byte()

Parameters

formatter
Type: System.Runtime.SerializationIFormatter
The formatter used to serialize the annotation data.

Return Value

Type: Byte
A byte array containing the serialized data.
See Also

Reference

WebAnnotationController Class
Save Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Save Method (Stream, AnnotationDataFormat)

WebAnnotationControllerSave Method (Stream, AnnotationDataFormat)

Saves the annotations to a stream using the specified formatter.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    AnnotationDataFormat format
)
Public Sub Save (
    stream As Stream,
    format As AnnotationDataFormat
)

Parameters

stream
Type: System.IOStream
A stream where the data will be stored.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The formatter use to serialize the data.
See Also

Reference

WebAnnotationController Class
Save Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Save Method (Stream, IFormatter)

WebAnnotationControllerSave Method (Stream, IFormatter)

Saves the annotations to a stream using the specified formatter.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    IFormatter formatter
)
Public Sub Save (
    stream As Stream,
    formatter As IFormatter
)

Parameters

stream
Type: System.IOStream
A stream where the data will be stored.
formatter
Type: System.Runtime.SerializationIFormatter
The formatter used for serializing the data.
See Also

Reference

WebAnnotationController Class
Save Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Save Method (String, AnnotationDataFormat)

WebAnnotationControllerSave Method (String, AnnotationDataFormat)

Saves the annotations to a file using the specified formatter.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    AnnotationDataFormat format
)
Public Sub Save (
    fileName As String,
    format As AnnotationDataFormat
)

Parameters

fileName
Type: SystemString
The full path and filename that will be created.
format
Type: Atalasoft.AnnotateAnnotationDataFormat
The formatter use to serialize the data.
See Also

Reference

WebAnnotationController Class
Save Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController Events

The WebAnnotationController type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised when the WebAnnotationController has been disposed.
Top
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationController.Disposed Event

WebAnnotationControllerDisposed Event

Raised when the WebAnnotationController has been disposed.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler

Value

Type: SystemEventHandler

Implements

IComponentDisposed
See Also

Reference

WebAnnotationController Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationInteractMode Enumeration

Specifies the user interaction mode for the WebAnnotationViewer.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WebAnnotationInteractMode
Public Enumeration WebAnnotationInteractMode
Members
Member name | Description
None | Do not allow interaction with annotations -- passes mouse events through to the parent WebImageViewer.
Modify | Annotations can be selected, moved and resized using the mouse.
Author | Annotations can be created, selected, moved, and resized using the mouse.
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer Class

This control derives from DotImage WebImageViewer and contains a reference to an WebAnnotationController. Drop this control onto a web form to start creating annotations.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Atalasoft.Imaging.WebControlsWebViewerControl
Atalasoft.Imaging.WebControlsWebImageViewer
Atalasoft.Imaging.WebControls.AnnotationsWebAnnotationViewer

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebAnnotationViewer : WebImageViewer
Public Class WebAnnotationViewer
    Inherits WebImageViewer

The WebAnnotationViewer type exposes the following members.

Constructors
 | Name | Description
Public method | WebAnnotationViewer | Creates a new instance of WebAnnotationViewer.
Top
Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs. (Inherited from WebViewerControl.)
Public property | AnnotationDataFormat | Gets or sets the AnnotationDataFormat to use while loading.
Public property | AnnotationDataUrl | Gets the url path where the annotation data will be cached.
Public property | Annotations | Gets the WebAnnotationController used by this viewer.
 | AntialiasDisplay | Gets or sets the quality of the scaled image. (Inherited from WebImageViewer.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | AuthorMode | Gets or sets a value that determines how many annotations are created in InteractMode.Author, AuthorMode.Single will change InteractMode back to the previous value after annotation creation.
Public property | AutoLinkThumbnailViewer | Gets or sets a value that determines whether this control will automatically handle annotations and layers on a WebThumbnailViewer that points to this control.
 | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from WebImageViewer.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Inherited from WebViewerControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension. (Inherited from WebViewerControl.)
Public property | BrowserFormat | Gets or sets the format of the images created for browser output. (Inherited from WebViewerControl.)
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled. (Inherited from WebViewerControl.)
Protected property | CacheImageUrl | Gets or sets a URL used to represent the lossless version of the ImageUrl. (Inherited from WebImageViewer.)
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2. (Inherited from WebViewerControl.)
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache. (Inherited from WebViewerControl.)
Public property | Caption | Gets or sets the text to be included below the control. (Inherited from WebViewerControl.)
Public property | Centered | Gets or sets a value indicating if the content is centered in the control. (Inherited from WebViewerControl.)
Protected property | ChildContent | Gets or sets the child content. (Inherited from WebViewerControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from WebViewerControl.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts. (Inherited from WebViewerControl.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from WebViewerControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls. (Inherited from WebViewerControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path. (Inherited from WebViewerControl.)
Public property | CurrentPage | Gets a value indicating the current page of a multi-page image being viewed in this control. (Inherited from WebImageViewer.)
Public property | CurrentUserName | Gets or sets the user name associated with all newly created annotations.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DefaultAnnotationsDataUrl | Gets the default annotation data URL.
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport. (Inherited from WebViewerControl.)
Public property | Domain | Allows cross domain scripting for the specified domain. (Inherited from WebViewerControl.)
Public property | EnableClientEvents | Obsolete. Enables the usage of events coming from the client without postbacks. (Obsolete.) (Inherited from WebImageViewer.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableServerAntialias | Obsolete. Enables server antialiasing for the FullClient ScrollbarType. (Obsolete.) (Inherited from WebImageViewer.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element. (Inherited from WebViewerControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent. (Inherited from WebViewerControl.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Image | Gets or sets the current AtalaImage displayed in this control (Inherited from WebImageViewer.)
Public property | ImageDisplayOrder | Defines the way tiles are loaded in the viewport. Using ImageDisplayOrder.Sequential will reduce performance, OnDemand is the most efficient. (Inherited from WebImageViewer.)
Protected property | ImageInfo | Gets the image info (Inherited from WebImageViewer.)
Public property | ImagePosition | A value indicating the position of the image relative to the top left position of the scrollport. (Inherited from WebImageViewer.)
Protected property | ImageSource | Gets or sets the image source. (Inherited from WebImageViewer.)
Protected property | ImageSourceDataUrl | Gets the image source URL. (Inherited from WebImageViewer.)
Public property | ImageUrl | Gets or sets the location of an image to display in the WebImageViewer control. (Inherited from WebImageViewer.)
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the WebAnnotationViewer
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time. (Inherited from WebViewerControl.)
Protected property | IsDirty | Gets or sets a value indicating that modifications have been made since the last save. (Inherited from WebImageViewer.)
Protected property | IsDisposed | Gets a value indicating the object has been disposed. (Inherited from WebViewerControl.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post. (Inherited from WebViewerControl.)
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded. (Inherited from WebViewerControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed. (Inherited from WebViewerControl.)
Public property | MouseTool | Gets a value indicating the behavior of the mouse when interacting with the viewport. (Inherited from WebImageViewer.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table. (Inherited from WebViewerControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.) (Inherited from WebViewerControl.)
Protected property | PixelFormat | Gets the pixel format. (Inherited from WebImageViewer.)
Public property | PreCacheTiles | A value from the PreCacheMode to set whether this control creates tiles in the cache or on demand. When set to Always, it creates tiles in the image cache, and when set to Never, it creates the tiles on demand. The value Always greatly increases panning speed and makes better use of memory, but can cause an initial delay. (Inherited from WebImageViewer.)
 | RedosAvailable | Returns the number of Redos available from the cache. (Inherited from WebImageViewer.)
Public property | ReferencedImageAnnotationRootPath | Gets or sets a mappable application relative url path used for ReferencedImageAnnotation file paths, allows browser caching for images of the same file name.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath. (Inherited from WebViewerControl.)
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars. (Inherited from WebViewerControl.)
Protected property | ScrollImageUrl | Url used for holding the location to the image behind the scrollport (Inherited from WebImageViewer.)
Public property | ScrollPosition | Gets or sets the scroll position. (Inherited from WebImageViewer.)
Protected property | ScrollSize | Gets the scroll size. (Inherited from WebImageViewer.)
Public property | Selection | Gets or sets the current RubberBand selection. (Inherited from WebImageViewer.)
Public property | SessionId | Gets the session ID. (Inherited from WebViewerControl.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | TileSize | Gets or sets the size tiles. Smaller tiles on large images can create heavy server load. Minimum tile size is 256x256. (Inherited from WebImageViewer.)
Public property | TitleBar | Gets or sets the text to be included above the control. (Inherited from WebViewerControl.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | UndosAvailable | Returns the number of Undos available from the cache. (Inherited from WebImageViewer.)
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Inherited from WebViewerControl.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered. (Inherited from WebViewerControl.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from WebViewerControl.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Zoom | Gets or sets the zoom level of the image in this WebImageViewer control. (Inherited from WebImageViewer.)
 | ZoomInOutPercentage | Gets or sets the percentage used to increase or decrease the zoom level when the zoom methods are used. (Inherited from WebImageViewer.)
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag. (Inherited from WebViewerControl.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script. (Inherited from WebViewerControl.)
 | ApplyCommand | Applies an ImageCommand to the current image in order to process it. (Inherited from WebImageViewer.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildCallbackPage | Builds a callback page. (Overrides WebImageViewerBuildCallbackPage.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Builds the remote query string. (Overrides WebImageViewerBuildRemoteQuery.)
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts. (Inherited from WebViewerControl.)
Protected method | CacheAnnotationData | Caches the annotation data.
Protected method | CacheImage | Saves the image to the file cache, and updates the expiration time (Inherited from WebImageViewer.)
Protected method | CacheImage(ImageEncoder, String) | Saves the image to the file cache so the browser can view it (Inherited from WebImageViewer.)
Protected method | CacheTiles | Saves tiles for the current image to the cache. (Inherited from WebImageViewer.)
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level. (Inherited from WebViewerControl.)
Protected method | ClearAnnotationData | Clears the annoation data in the cache.
Public method | ClearAnnotations | Clears all annotations.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | ClearSerializedState | Clears the serialized state. (Inherited from WebImageViewer.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateAnnotationDataFromType | Creates an annotation data object from a class name.
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Inherited from WebImageViewer.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Protected method | DeserializeDefaultAnnotations | Deserializes the default annotations.
Protected method | DeserializeState | Deserializes the state. (Inherited from WebImageViewer.)
Public method | DesignTime | Enters design-time mode. (Overrides WebImageViewerDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides WebImageViewerDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response. (Inherited from WebViewerControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format. (Inherited from WebViewerControl.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeJsonString | Escapes a JSON string.
Protected method | EscapeString | Escapes a string. (Inherited from WebViewerControl.)
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively. (Inherited from WebViewerControl.)
Protected method | FixNumericalID | Fixes the numerical ID. (Inherited from WebViewerControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetAnnotationDataTypeFromString | Gets an annotation data type from a class name.
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings (Inherited from WebViewerControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension. (Inherited from WebViewerControl.)
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension. (Inherited from WebViewerControl.)
Protected method | GetFormClientID | Gets the form client ID. (Inherited from WebViewerControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Gets the hidden values. (Overrides WebImageViewerGetHiddenValues.)
Protected method | GetIdForSession | Gets the session ID. (Inherited from WebViewerControl.)
Protected method | GetMimeType | Gets the MIME content type of a file name. (Inherited from WebViewerControl.)
Protected method | GetObjectType | Gets the type of object. (Overrides WebImageViewerGetObjectType.)
Protected method | GetResourcePrefix | Gets the prefix used for a particular resource type. (Overrides WebImageViewerGetResourcePrefix(ResourceType).)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleNonPageRequests | Handles non page requests. (Overrides WebImageViewerHandleNonPageRequests.)
Protected method | HandleQueryString | Handles the query string. (Overrides WebImageViewerHandleQueryString.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | LoadAnnotationData(Stream) | Loads annotation data from a stream using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.
Public method | LoadAnnotationData(String) | Loads annotation data from a file using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.
Public method | LoadAnnotationDataUrl | Loads annotation data from a file located at the given relative or absolute url using the AnnotationDataFormat property, and adds the annotations to the underlying WebAnnotationController.
Protected method | LoadCachedAnnotations | Loads cached annotations.
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads WebAnnotationViewer specific QueryString values (Overrides WebImageViewerLoadQueryStringValues(NameValueCollection).)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file (Inherited from WebViewerControl.)
Protected method | LogMessageToTile | Logs a message. (Inherited from WebImageViewer.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path. (Inherited from WebViewerControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnAnnotationCreated | Called when a new annotation has been created by the user.
Protected method | OnAnnotationsModified | Called when annotations have been modified by client side code/interaction.
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Protected method | OnChangedImage | Fires when pixel data in the current image changes without setting a new image. (Inherited from WebImageViewer.)
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnDefaultAnnotationsChanged | Fires when the DefaultAnnotationsCollection has changed, but only after the control has been initially rendered
Protected method | OnImageChanged | Fires when the Image has changed. (Inherited from WebImageViewer.)
Protected method | OnInit | Raises the Init event. (Overrides WebImageViewerOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from WebImageViewer.)
Protected method | OnNewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.) (Inherited from WebImageViewer.)
Protected method | OnPageInit | Occurs on page initialization. (Inherited from WebImageViewer.)
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides WebImageViewerOnPreRender(EventArgs).)
Protected method | OnProgress | Fires while an image is being processed, loaded, or saved. (Inherited from WebImageViewer.)
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Protected method | OnResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize. (Inherited from WebImageViewer.)
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Protected method | OnSelectionChanged | Fires when the selection has been moved or changed. (After PostBack) (Inherited from WebImageViewer.)
Protected method | OnStreamTile | Fires when a tile is requested and allows the handler to provide it. (Inherited from WebImageViewer.)
Protected method | OnStreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true. (Inherited from WebImageViewer.)
Protected method | OnTileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it. (Inherited from WebImageViewer.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Public method | Open(Stream) | Opens an image into the WebImageViewer control from an image file stream. (Inherited from WebImageViewer.)
Public method | Open(String) | Opens an image into the WebImageViewer control from an image file. (Inherited from WebImageViewer.)
 | Open(RandomAccessImageSource) | Opens a given image and sets it to the display. (Inherited from WebImageViewer.)
Public method | Open(Stream, Int32) | Opens an image into the WebImageViewer control from an image file stream, specifying the frame index of a multi-page image. (Inherited from WebImageViewer.)
Public method | Open(String, Int32) | Opens an image into the WebImageViewer control from an image file, specifying the frame index of a multi-page image. (Inherited from WebImageViewer.)
 | Open(RandomAccessImageSource, Int32) | Opens a given image at a specified frame index and sets it to the display. (Inherited from WebImageViewer.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | OpenScrollImageUrl | Opens the scroll image URL. (Inherited from WebImageViewer.)
 | OpenUrl(String) | Opens an image into the WebImageViewer control from a URL or virtual path. (Inherited from WebImageViewer.)
Public method | OpenUrl(String, Int32) | Opens an image into the WebImageViewer control from a URL or virtual path. (Inherited from WebImageViewer.)
Protected method | OutputHiddenValues | Writes hidden values. (Overrides WebImageViewerOutputHiddenValues(HtmlTextWriter).)
Protected method | ParseQueryString | Parses the query string.
Public method | Print | (Inherited from WebImageViewer.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | Redo | Reverts the image inside the control back to the previously cached image, if an Undos have been done. (Inherited from WebImageViewer.)
Public method | Redo(Int32) | Redoes the specified number of times. (Inherited from WebImageViewer.)
Protected method | RegisterScriptInclude | Includes a script. (Inherited from WebViewerControl.)
Protected method | RegisterScripts | Registers the scripts. (Overrides WebImageViewerRegisterScripts.)
Protected method | ReleaseImage | Releases the image. (Inherited from WebImageViewer.)
Protected method | Remote | Performs a remote invocation. (Inherited from WebViewerControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebViewerControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name. (Inherited from WebViewerControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Save(Stream, ImageEncoder) | Saves the current image to a stream, with a specified ImageEncoder. (Inherited from WebImageViewer.)
Public method | Save(String, ImageEncoder) | Saves the current image file, with a specified ImageEncoder. (Inherited from WebImageViewer.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SerializeState | Serializes the current state. (Overrides WebImageViewerSerializeState.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
 | SetZoomMode | Zooms the image based on the given AutoZoomMode. (Inherited from WebImageViewer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Public method | Undo | Reverts the image inside the control back to the previously cached image. (Inherited from WebImageViewer.)
Public method | Undo(Int32) | Undoes the specified number of times. (Inherited from WebImageViewer.)
Public method | Update | Forces the current image to be cached. (Inherited from WebImageViewer.)
Public method | UpdateAnnotations | Forces the control to cache the annotation data for retrieval on the client side.
Public method | UpdateClient | Forces the client side JavaScript to update (Inherited from WebImageViewer.)
Protected method | UrlIsWebRequest | Determines if a URL is for a web request. (Inherited from WebViewerControl.)
Protected method | WatermarkImage | Applies a watermark to the image. (Inherited from WebViewerControl.)
Top
Events
 | Name | Description
Public event | AnnotationCreated | Raised when an annotation is created by the user.
Public event | AnnotationsModified | Fires when annotations are modified from the browser.
Public event | CenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Public event | ChangedImage | Fires when pixel data in the current image changes without setting a new image. (Inherited from WebImageViewer.)
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control. (Inherited from WebViewerControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | DefaultAnnotationsChanged | Fires when the DefaultAnnotationsCollection has changed, but only after the control has been initially rendered.
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | ImageChanged | Fires when the Image has changed. (Inherited from WebImageViewer.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | NewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.) (Inherited from WebImageViewer.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Progress | Fires while an image is being processed, loaded, or saved. (Inherited from WebImageViewer.)
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Public event | ResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize. (Inherited from WebImageViewer.)
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Public event | SelectionChanged | Fires when the selection has been moved or changed. (After PostBack) (Inherited from WebImageViewer.)
Public event | StreamTile | Fires when a tile is requested and allows the handler to provide it. (Inherited from WebImageViewer.)
Public event | StreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true. (Inherited from WebImageViewer.)
Public event | TileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it. (Inherited from WebImageViewer.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
Remarks
Caution note Caution
WebAnnotationViewer control is available with .NET Framework 3.5 and 4.5.2 only. Use WebDocumentViewer control instead.
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer Constructor

Creates a new instance of WebAnnotationViewer.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebAnnotationViewer()
Public Sub New
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer Properties

The WebAnnotationViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AllowedPaths | Gets a paths collection from where the control can retrieve data for annotations, images, etc. It can include absolute or relatives paths, and URLs. (Inherited from WebViewerControl.)
Public property | AnnotationDataFormat | Gets or sets the AnnotationDataFormat to use while loading.
Public property | AnnotationDataUrl | Gets the url path where the annotation data will be cached.
Public property | Annotations | Gets the WebAnnotationController used by this viewer.
 | AntialiasDisplay | Gets or sets the quality of the scaled image. (Inherited from WebImageViewer.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | AuthorMode | Gets or sets a value that determines how many annotations are created in InteractMode.Author, AuthorMode.Single will change InteractMode back to the previous value after annotation creation.
Public property | AutoLinkThumbnailViewer | Gets or sets a value that determines whether this control will automatically handle annotations and layers on a WebThumbnailViewer that points to this control.
 | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from WebImageViewer.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets the border style used for this control. (Inherited from WebViewerControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | BrowserExtension | Gets the file extension. (Inherited from WebViewerControl.)
Public property | BrowserFormat | Gets or sets the format of the images created for browser output. (Inherited from WebViewerControl.)
Protected property | CacheDisabled | Gets a value indicating if the cache is disabled. (Inherited from WebViewerControl.)
Protected property | CacheImageUrl | Gets or sets a URL used to represent the lossless version of the ImageUrl. (Inherited from WebImageViewer.)
Public property | CacheLevels | The number of images to cache on the server, per control, per session. Default value is 2. (Inherited from WebViewerControl.)
Public property | CachePath | The path where images and tiles are cached. This is set in the web.config with the appSetting AtalasoftWebControls_Cache. (Inherited from WebViewerControl.)
Public property | Caption | Gets or sets the text to be included below the control. (Inherited from WebViewerControl.)
Public property | Centered | Gets or sets a value indicating if the content is centered in the control. (Inherited from WebViewerControl.)
Protected property | ChildContent | Gets or sets the child content. (Inherited from WebViewerControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from WebViewerControl.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | ClientScripts | Gets a collection od client scripts. (Inherited from WebViewerControl.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from WebViewerControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Protected property | ControlTable | Gets the table of controls. (Inherited from WebViewerControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | CurrentExecutionPath | Gets the current execution path. (Inherited from WebViewerControl.)
Public property | CurrentPage | Gets a value indicating the current page of a multi-page image being viewed in this control. (Inherited from WebImageViewer.)
Public property | CurrentUserName | Gets or sets the user name associated with all newly created annotations.
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DefaultAnnotationsDataUrl | Gets the default annotation data URL.
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Protected property | DesignTimeViewPort | Gets the design-time viewport. (Inherited from WebViewerControl.)
Public property | Domain | Allows cross domain scripting for the specified domain. (Inherited from WebViewerControl.)
Public property | EnableClientEvents | Obsolete. Enables the usage of events coming from the client without postbacks. (Obsolete.) (Inherited from WebImageViewer.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableServerAntialias | Obsolete. Enables server antialiasing for the FullClient ScrollbarType. (Obsolete.) (Inherited from WebImageViewer.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Protected property | FullClientIFrame | Gets the client IFrame element. (Inherited from WebViewerControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | HasResponded | Gets a value indicating that a response has been sent. (Inherited from WebViewerControl.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Image | Gets or sets the current AtalaImage displayed in this control (Inherited from WebImageViewer.)
Public property | ImageDisplayOrder | Defines the way tiles are loaded in the viewport. Using ImageDisplayOrder.Sequential will reduce performance, OnDemand is the most efficient. (Inherited from WebImageViewer.)
Protected property | ImageInfo | Gets the image info (Inherited from WebImageViewer.)
Public property | ImagePosition | A value indicating the position of the image relative to the top left position of the scrollport. (Inherited from WebImageViewer.)
Protected property | ImageSource | Gets or sets the image source. (Inherited from WebImageViewer.)
Protected property | ImageSourceDataUrl | Gets the image source URL. (Inherited from WebImageViewer.)
Public property | ImageUrl | Gets or sets the location of an image to display in the WebImageViewer control. (Inherited from WebImageViewer.)
Public property | InteractMode | Gets or sets a value specifying the user interactive mode of the WebAnnotationViewer
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsDesignTime | Gets or sets a value indicating the control is in design time. (Inherited from WebViewerControl.)
Protected property | IsDirty | Gets or sets a value indicating that modifications have been made since the last save. (Inherited from WebImageViewer.)
Protected property | IsDisposed | Gets a value indicating the object has been disposed. (Inherited from WebViewerControl.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsPartialPost | Gets a value indicating it is a partial post. (Inherited from WebViewerControl.)
Protected property | IsQueryStringLoaded | Gets a value indicating the query string was loaded. (Inherited from WebViewerControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Protected property | Logging | Gets a value indicating that logging is performed. (Inherited from WebViewerControl.)
Public property | MouseTool | Gets a value indicating the behavior of the mouse when interacting with the viewport. (Inherited from WebImageViewer.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | OuterTable | Gets the outer table. (Inherited from WebViewerControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PathToResources | Obsolete. Gets or sets the virtual path to where the image, script, and cursor files are located. (Obsolete.) (Inherited from WebViewerControl.)
Protected property | PixelFormat | Gets the pixel format. (Inherited from WebImageViewer.)
Public property | PreCacheTiles | A value from the PreCacheMode to set whether this control creates tiles in the cache or on demand. When set to Always, it creates tiles in the image cache, and when set to Never, it creates the tiles on demand. The value Always greatly increases panning speed and makes better use of memory, but can cause an initial delay. (Inherited from WebImageViewer.)
 | RedosAvailable | Returns the number of Redos available from the cache. (Inherited from WebImageViewer.)
Public property | ReferencedImageAnnotationRootPath | Gets or sets a mappable application relative url path used for ReferencedImageAnnotation file paths, allows browser caching for images of the same file name.
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | ResourcePath | The path to the javascript and image resources needed by this control. It is set with the web.config property AtalasoftWebControls_ResourcePath. (Inherited from WebViewerControl.)
 | ScrollBarVisibility | Gets or sets the visibility of the scrollbars. (Inherited from WebViewerControl.)
Protected property | ScrollImageUrl | Url used for holding the location to the image behind the scrollport (Inherited from WebImageViewer.)
Public property | ScrollPosition | Gets or sets the scroll position. (Inherited from WebImageViewer.)
Protected property | ScrollSize | Gets the scroll size. (Inherited from WebImageViewer.)
Public property | Selection | Gets or sets the current RubberBand selection. (Inherited from WebImageViewer.)
Public property | SessionId | Gets the session ID. (Inherited from WebViewerControl.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's IsEnabled property is false. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | TileSize | Gets or sets the size tiles. Smaller tiles on large images can create heavy server load. Minimum tile size is 256x256. (Inherited from WebImageViewer.)
Public property | TitleBar | Gets or sets the text to be included above the control. (Inherited from WebViewerControl.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | UndosAvailable | Returns the number of Undos available from the cache. (Inherited from WebImageViewer.)
Public property | UniqueID | Gets the server control identifier generated by ASP.NET MVC. (Inherited from WebViewerControl.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | Visibility | Indicates whether the control is visible when rendered. (Inherited from WebViewerControl.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from WebViewerControl.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Zoom | Gets or sets the zoom level of the image in this WebImageViewer control. (Inherited from WebImageViewer.)
 | ZoomInOutPercentage | Gets or sets the percentage used to increase or decrease the zoom level when the zoom methods are used. (Inherited from WebImageViewer.)
Top
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.AnnotationDataFormat Property

WebAnnotationViewerAnnotationDataFormat Property

Gets or sets the AnnotationDataFormat to use while loading.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationDataFormat AnnotationDataFormat { get; set; }
Public Property AnnotationDataFormat As AnnotationDataFormat
    Get
    Set

Property Value

Type: AnnotationDataFormat
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.AnnotationDataUrl Property

WebAnnotationViewerAnnotationDataUrl Property

Gets the url path where the annotation data will be cached.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AnnotationDataUrl { get; }
Public ReadOnly Property AnnotationDataUrl As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.Annotations Property

WebAnnotationViewerAnnotations Property

Gets the WebAnnotationController used by this viewer.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebAnnotationController Annotations { get; }
Public ReadOnly Property Annotations As WebAnnotationController
    Get

Property Value

Type: WebAnnotationController
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.AuthorMode Property

WebAnnotationViewerAuthorMode Property

Gets or sets a value that determines how many annotations are created in InteractMode.Author, AuthorMode.Single will change InteractMode back to the previous value after annotation creation.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AuthorMode AuthorMode { get; set; }
Public Property AuthorMode As AuthorMode
    Get
    Set

Property Value

Type: AuthorMode
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.AutoLinkThumbnailViewer Property

WebAnnotationViewerAutoLinkThumbnailViewer Property

Gets or sets a value that determines whether this control will automatically handle annotations and layers on a WebThumbnailViewer that points to this control.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoLinkThumbnailViewer { get; set; }
Public Property AutoLinkThumbnailViewer As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.CurrentUserName Property

WebAnnotationViewerCurrentUserName Property

Gets or sets the user name associated with all newly created annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CurrentUserName { get; set; }
Public Property CurrentUserName As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.DefaultAnnotationsDataUrl Property

WebAnnotationViewerDefaultAnnotationsDataUrl Property

Gets the default annotation data URL.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string DefaultAnnotationsDataUrl { get; }
Protected ReadOnly Property DefaultAnnotationsDataUrl As String
    Get

Property Value

Type: String
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.InteractMode Property

WebAnnotationViewerInteractMode Property

Gets or sets a value specifying the user interactive mode of the WebAnnotationViewer

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebAnnotationInteractMode InteractMode { get; set; }
Public Property InteractMode As WebAnnotationInteractMode
    Get
    Set

Property Value

Type: WebAnnotationInteractMode
The interaction mode of the WebAnnotationViewer.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.ReferencedImageAnnotationRootPath Property

WebAnnotationViewerReferencedImageAnnotationRootPath Property

Gets or sets a mappable application relative url path used for ReferencedImageAnnotation file paths, allows browser caching for images of the same file name.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReferencedImageAnnotationRootPath { get; set; }
Public Property ReferencedImageAnnotationRootPath As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer Methods

The WebAnnotationViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddHiddenTag | Writes a hidden tag. (Inherited from WebViewerControl.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddStartupScript | Adds a startup script. (Inherited from WebViewerControl.)
 | ApplyCommand | Applies an ImageCommand to the current image in order to process it. (Inherited from WebImageViewer.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildCallbackPage | Builds a callback page. (Overrides WebImageViewerBuildCallbackPage.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | BuildRemoteQuery | Builds the remote query string. (Overrides WebImageViewerBuildRemoteQuery.)
Protected method | BuildScriptVersionChecker | Builds a version checker function for the scripts. (Inherited from WebViewerControl.)
Protected method | CacheAnnotationData | Caches the annotation data.
Protected method | CacheImage | Saves the image to the file cache, and updates the expiration time (Inherited from WebImageViewer.)
Protected method | CacheImage(ImageEncoder, String) | Saves the image to the file cache so the browser can view it (Inherited from WebImageViewer.)
Protected method | CacheTiles | Saves tiles for the current image to the cache. (Inherited from WebImageViewer.)
Protected method | CalculateBestFitZoom | Calculates the best fit zoom level. (Inherited from WebViewerControl.)
Protected method | ClearAnnotationData | Clears the annoation data in the cache.
Public method | ClearAnnotations | Clears all annotations.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | ClearSerializedState | Clears the serialized state. (Inherited from WebImageViewer.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateAnnotationDataFromType | Creates an annotation data object from a class name.
Protected method | CreateChildControls | Add the child controls to the container, sizing it to the User's specifications. (Inherited from WebImageViewer.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Protected method | DeserializeDefaultAnnotations | Deserializes the default annotations.
Protected method | DeserializeState | Deserializes the state. (Inherited from WebImageViewer.)
Public method | DesignTime | Enters design-time mode. (Overrides WebImageViewerDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | Dispose(Boolean) | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides WebImageViewerDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EndResponse | Ends the response. (Inherited from WebViewerControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Protected method | EnsureValidPixelFormat | Ensures a correct pixel format. (Inherited from WebViewerControl.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EscapeJsonString | Escapes a JSON string.
Protected method | EscapeString | Escapes a string. (Inherited from WebViewerControl.)
Protected method | Finalize | Enables a server control to perform final clean up before it is released from memory. (Inherited from WebViewerControl.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Protected method | FindControlRecursive | Searches for a control recursively. (Inherited from WebViewerControl.)
Protected method | FixNumericalID | Fixes the numerical ID. (Inherited from WebViewerControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetAnnotationDataTypeFromString | Gets an annotation data type from a class name.
Protected method | GetConfigAttributes | Load this control's configuration from AppSettings (Inherited from WebViewerControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetEncoder | Gets the proper encoder based on the BrowserExtension. (Inherited from WebViewerControl.)
Protected method | GetEncoder(String) | Gets the proper encoder based on the file extension. (Inherited from WebViewerControl.)
Protected method | GetFormClientID | Gets the form client ID. (Inherited from WebViewerControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetHiddenValues | Gets the hidden values. (Overrides WebImageViewerGetHiddenValues.)
Protected method | GetIdForSession | Gets the session ID. (Inherited from WebViewerControl.)
Protected method | GetMimeType | Gets the MIME content type of a file name. (Inherited from WebViewerControl.)
Protected method | GetObjectType | Gets the type of object. (Overrides WebImageViewerGetObjectType.)
Protected method | GetResourcePrefix | Gets the prefix used for a particular resource type. (Overrides WebImageViewerGetResourcePrefix(ResourceType).)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Protected method | HandleNonPageRequests | Handles non page requests. (Overrides WebImageViewerHandleNonPageRequests.)
Protected method | HandleQueryString | Handles the query string. (Overrides WebImageViewerHandleQueryString.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | LoadAnnotationData(Stream) | Loads annotation data from a stream using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.
Public method | LoadAnnotationData(String) | Loads annotation data from a file using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.
Public method | LoadAnnotationDataUrl | Loads annotation data from a file located at the given relative or absolute url using the AnnotationDataFormat property, and adds the annotations to the underlying WebAnnotationController.
Protected method | LoadCachedAnnotations | Loads cached annotations.
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadQueryStringValues | Loads WebAnnotationViewer specific QueryString values (Overrides WebImageViewerLoadQueryStringValues(NameValueCollection).)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState method. (Inherited from WebControl.)
Protected method | LogMessageToCache | Write a diagnostic log message into a .txt file (Inherited from WebViewerControl.)
Protected method | LogMessageToTile | Logs a message. (Inherited from WebImageViewer.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MapUrlPath | Maps the URL to a path. (Inherited from WebViewerControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnAnnotationCreated | Called when a new annotation has been created by the user.
Protected method | OnAnnotationsModified | Called when annotations have been modified by client side code/interaction.
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Protected method | OnChangedImage | Fires when pixel data in the current image changes without setting a new image. (Inherited from WebImageViewer.)
Protected method | OnCreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnDefaultAnnotationsChanged | Fires when the DefaultAnnotationsCollection has changed, but only after the control has been initially rendered
Protected method | OnImageChanged | Fires when the Image has changed. (Inherited from WebImageViewer.)
Protected method | OnInit | Raises the Init event. (Overrides WebImageViewerOnInit(EventArgs).)
Protected method | OnLoad | Raises the Load event. (Inherited from WebImageViewer.)
Protected method | OnNewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.) (Inherited from WebImageViewer.)
Protected method | OnPageInit | Occurs on page initialization. (Inherited from WebImageViewer.)
Protected method | OnPartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides WebImageViewerOnPreRender(EventArgs).)
Protected method | OnProgress | Fires while an image is being processed, loaded, or saved. (Inherited from WebImageViewer.)
Protected method | OnRemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Protected method | OnResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize. (Inherited from WebImageViewer.)
Protected method | OnScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Protected method | OnScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Protected method | OnSelectionChanged | Fires when the selection has been moved or changed. (After PostBack) (Inherited from WebImageViewer.)
Protected method | OnStreamTile | Fires when a tile is requested and allows the handler to provide it. (Inherited from WebImageViewer.)
Protected method | OnStreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true. (Inherited from WebImageViewer.)
Protected method | OnTileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it. (Inherited from WebImageViewer.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Public method | Open(Stream) | Opens an image into the WebImageViewer control from an image file stream. (Inherited from WebImageViewer.)
Public method | Open(String) | Opens an image into the WebImageViewer control from an image file. (Inherited from WebImageViewer.)
 | Open(RandomAccessImageSource) | Opens a given image and sets it to the display. (Inherited from WebImageViewer.)
Public method | Open(Stream, Int32) | Opens an image into the WebImageViewer control from an image file stream, specifying the frame index of a multi-page image. (Inherited from WebImageViewer.)
Public method | Open(String, Int32) | Opens an image into the WebImageViewer control from an image file, specifying the frame index of a multi-page image. (Inherited from WebImageViewer.)
 | Open(RandomAccessImageSource, Int32) | Opens a given image at a specified frame index and sets it to the display. (Inherited from WebImageViewer.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | OpenScrollImageUrl | Opens the scroll image URL. (Inherited from WebImageViewer.)
 | OpenUrl(String) | Opens an image into the WebImageViewer control from a URL or virtual path. (Inherited from WebImageViewer.)
Public method | OpenUrl(String, Int32) | Opens an image into the WebImageViewer control from a URL or virtual path. (Inherited from WebImageViewer.)
Protected method | OutputHiddenValues | Writes hidden values. (Overrides WebImageViewerOutputHiddenValues(HtmlTextWriter).)
Protected method | ParseQueryString | Parses the query string.
Public method | Print | (Inherited from WebImageViewer.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | Redo | Reverts the image inside the control back to the previously cached image, if an Undos have been done. (Inherited from WebImageViewer.)
Public method | Redo(Int32) | Redoes the specified number of times. (Inherited from WebImageViewer.)
Protected method | RegisterScriptInclude | Includes a script. (Inherited from WebViewerControl.)
Protected method | RegisterScripts | Registers the scripts. (Overrides WebImageViewerRegisterScripts.)
Protected method | ReleaseImage | Releases the image. (Inherited from WebImageViewer.)
Protected method | Remote | Performs a remote invocation. (Inherited from WebViewerControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebViewerControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ReplaceInvalidFileNameChars | Fixes an invalid file name. (Inherited from WebViewerControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Save(Stream, ImageEncoder) | Saves the current image to a stream, with a specified ImageEncoder. (Inherited from WebImageViewer.)
Public method | Save(String, ImageEncoder) | Saves the current image file, with a specified ImageEncoder. (Inherited from WebImageViewer.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState method was invoked. (Inherited from WebControl.)
Protected method | SerializeState | Serializes the current state. (Overrides WebImageViewerSerializeState.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
 | SetZoomMode | Zooms the image based on the given AutoZoomMode. (Inherited from WebImageViewer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Public method | Undo | Reverts the image inside the control back to the previously cached image. (Inherited from WebImageViewer.)
Public method | Undo(Int32) | Undoes the specified number of times. (Inherited from WebImageViewer.)
Public method | Update | Forces the current image to be cached. (Inherited from WebImageViewer.)
Public method | UpdateAnnotations | Forces the control to cache the annotation data for retrieval on the client side.
Public method | UpdateClient | Forces the client side JavaScript to update (Inherited from WebImageViewer.)
Protected method | UrlIsWebRequest | Determines if a URL is for a web request. (Inherited from WebViewerControl.)
Protected method | WatermarkImage | Applies a watermark to the image. (Inherited from WebViewerControl.)
Top
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.BuildCallbackPage Method

WebAnnotationViewerBuildCallbackPage Method

Builds a callback page.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override CallbackBuilder BuildCallbackPage()
Protected Overrides Function BuildCallbackPage As CallbackBuilder

Return Value

Type: CallbackBuilder
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.BuildRemoteQuery Method

WebAnnotationViewerBuildRemoteQuery Method

Builds the remote query string.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string BuildRemoteQuery()
Protected Overrides Function BuildRemoteQuery As String

Return Value

Type: String
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.CacheAnnotationData Method

WebAnnotationViewerCacheAnnotationData Method

Caches the annotation data.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void CacheAnnotationData()
Protected Overridable Sub CacheAnnotationData
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.ClearAnnotationData Method

WebAnnotationViewerClearAnnotationData Method

Clears the annoation data in the cache.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ClearAnnotationData()
Protected Overridable Sub ClearAnnotationData
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.ClearAnnotations Method

WebAnnotationViewerClearAnnotations Method

Clears all annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearAnnotations()
Public Sub ClearAnnotations
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.CreateAnnotationDataFromType Method

WebAnnotationViewerCreateAnnotationDataFromType Method

Creates an annotation data object from a class name.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AnnotationData CreateAnnotationDataFromType(
    Type dataType,
    string name
)
Protected Overridable Function CreateAnnotationDataFromType (
    dataType As Type,
    name As String
) As AnnotationData

Parameters

dataType
Type: SystemType
name
Type: SystemString

Return Value

Type: AnnotationData
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.DeserializeDefaultAnnotations Method

WebAnnotationViewerDeserializeDefaultAnnotations Method

Deserializes the default annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DeserializeDefaultAnnotations()
Protected Overridable Sub DeserializeDefaultAnnotations
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.DesignTime Method

WebAnnotationViewerDesignTime Method

Overload List
 | Name | Description
Public method | DesignTime | Enters design-time mode. (Overrides WebImageViewerDesignTime.)
Protected method | DesignTime(String) | Enters design-time mode. (Inherited from WebViewerControl.)
Top
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.DesignTime Method

WebAnnotationViewerDesignTime Method

Enters design-time mode.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void DesignTime()
Public Overrides Sub DesignTime
See Also

Reference

WebAnnotationViewer Class
DesignTime Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.DisposeManagedResources Method

WebAnnotationViewerDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.EscapeJsonString Method

WebAnnotationViewerEscapeJsonString Method

Escapes a JSON string.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string EscapeJsonString(
    string str
)
Protected Function EscapeJsonString (
    str As String
) As String

Parameters

str
Type: SystemString

Return Value

Type: String
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.GetAnnotationDataTypeFromString Method

WebAnnotationViewerGetAnnotationDataTypeFromString Method

Gets an annotation data type from a class name.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Type GetAnnotationDataTypeFromString(
    string dataType
)
Protected Overridable Function GetAnnotationDataTypeFromString (
    dataType As String
) As Type

Parameters

dataType
Type: SystemString

Return Value

Type: Type
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.GetHiddenValues Method

WebAnnotationViewerGetHiddenValues Method

Gets the hidden values.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void GetHiddenValues()
Protected Overrides Sub GetHiddenValues
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.GetObjectType Method

WebAnnotationViewerGetObjectType Method

Gets the type of object.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Type GetObjectType()
Protected Overrides Function GetObjectType As Type

Return Value

Type: Type
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.GetResourcePrefix Method

WebAnnotationViewerGetResourcePrefix Method

Gets the prefix used for a particular resource type.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string GetResourcePrefix(
    ResourceType rt
)
Protected Overrides Function GetResourcePrefix (
    rt As ResourceType
) As String

Parameters

rt
Type: Atalasoft.Imaging.WebControlsResourceType

Return Value

Type: String
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.HandleNonPageRequests Method

WebAnnotationViewerHandleNonPageRequests Method

Handles non page requests.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void HandleNonPageRequests()
Protected Overrides Sub HandleNonPageRequests
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.HandleQueryString Method

WebAnnotationViewerHandleQueryString Method

Handles the query string.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void HandleQueryString()
Protected Overrides Sub HandleQueryString
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.LoadAnnotationData Method

WebAnnotationViewerLoadAnnotationData Method

Loads annotation data from a file using the AnnotationDataFormat property and adds the annotations to the underlying WebAnnotationController.
Overload List
 | Name | Description
Public method | LoadAnnotationData(Stream) | Loads annotation data from a stream using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.
Public method | LoadAnnotationData(String) | Loads annotation data from a file using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.
Top
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.LoadAnnotationData Method (Stream)

WebAnnotationViewerLoadAnnotationData Method (Stream)

Loads annotation data from a stream using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadAnnotationData(
    Stream stream
)
Public Sub LoadAnnotationData (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream that contains the annotation data.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
LoadAnnotationData Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.LoadAnnotationData Method (String)

WebAnnotationViewerLoadAnnotationData Method (String)

Loads annotation data from a file using the AnnotationDataFormat property and adds annotations to the underlying WebAnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadAnnotationData(
    string fileName
)
Public Sub LoadAnnotationData (
    fileName As String
)

Parameters

fileName
Type: SystemString
The absolute file path to the file containing the annotation data.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
LoadAnnotationData Overload
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.LoadAnnotationDataUrl Method

WebAnnotationViewerLoadAnnotationDataUrl Method

Loads annotation data from a file located at the given relative or absolute url using the AnnotationDataFormat property, and adds the annotations to the underlying WebAnnotationController.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadAnnotationDataUrl(
    string urlPath
)
Public Sub LoadAnnotationDataUrl (
    urlPath As String
)

Parameters

urlPath
Type: SystemString
The relative or absolute url path to a file that contains annotation data.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.LoadCachedAnnotations Method

WebAnnotationViewerLoadCachedAnnotations Method

Loads cached annotations.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LoadCachedAnnotations()
Protected Overridable Sub LoadCachedAnnotations
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.LoadQueryStringValues Method

WebAnnotationViewerLoadQueryStringValues Method

Loads WebAnnotationViewer specific QueryString values

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LoadQueryStringValues(
    NameValueCollection clientParams
)
Protected Overrides Sub LoadQueryStringValues (
    clientParams As NameValueCollection
)

Parameters

clientParams
Type: System.Collections.SpecializedNameValueCollection
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.OnAnnotationCreated Method

WebAnnotationViewerOnAnnotationCreated Method

Called when a new annotation has been created by the user.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationCreated(
    AnnotationData annData
)
Protected Overridable Sub OnAnnotationCreated (
    annData As AnnotationData
)

Parameters

annData
Type: Atalasoft.AnnotateAnnotationData
The annotation that was created.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.OnAnnotationsModified Method

WebAnnotationViewerOnAnnotationsModified Method

Called when annotations have been modified by client side code/interaction.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAnnotationsModified(
    EventArgs e
)
Protected Overridable Sub OnAnnotationsModified (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.OnDefaultAnnotationsChanged Method

WebAnnotationViewerOnDefaultAnnotationsChanged Method

Fires when the DefaultAnnotationsCollection has changed, but only after the control has been initially rendered

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDefaultAnnotationsChanged(
    Object sender,
    CollectionChangedEventArgs args
)
Protected Overridable Sub OnDefaultAnnotationsChanged (
    sender As Object,
    args As CollectionChangedEventArgs
)

Parameters

sender
Type: SystemObject
args
Type: Atalasoft.UtilsCollectionChangedEventArgs
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.OnInit Method

WebAnnotationViewerOnInit Method

Raises the Init event.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.OnPreRender Method

WebAnnotationViewerOnPreRender Method

Raises the PreRender event.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs object that contains the event data.
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.OutputHiddenValues Method

WebAnnotationViewerOutputHiddenValues Method

Writes hidden values.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OutputHiddenValues(
    HtmlTextWriter writer
)
Protected Overrides Sub OutputHiddenValues (
    writer As HtmlTextWriter
)

Parameters

writer
Type: System.Web.UIHtmlTextWriter
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.ParseQueryString Method

WebAnnotationViewerParseQueryString Method

Parses the query string.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ParseQueryString()
Protected Overridable Sub ParseQueryString
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.RegisterScripts Method

WebAnnotationViewerRegisterScripts Method

Registers the scripts.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RegisterScripts()
Protected Overrides Sub RegisterScripts
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.SerializeState Method

WebAnnotationViewerSerializeState Method

Serializes the current state.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void SerializeState()
Protected Overrides Sub SerializeState
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.UpdateAnnotations Method

WebAnnotationViewerUpdateAnnotations Method

Forces the control to cache the annotation data for retrieval on the client side.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void UpdateAnnotations()
Public Sub UpdateAnnotations
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer Events

The WebAnnotationViewer type exposes the following members.

Events
 | Name | Description
Public event | AnnotationCreated | Raised when an annotation is created by the user.
Public event | AnnotationsModified | Fires when annotations are modified from the browser.
Public event | CenteredChanged | Fires when the Centered property changes. (Inherited from WebViewerControl.)
Public event | ChangedImage | Fires when pixel data in the current image changes without setting a new image. (Inherited from WebImageViewer.)
Public event | CreateSessionId | Used to override the session id used by the control to generate cache file names. The default is the Session.Id of the page (Inherited from WebViewerControl.)
 | CreateUniquePageName | Used to override the default page name used by the control to generate file names in the cache. The default is the full pathname to the page hosting the control. (Inherited from WebViewerControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | DefaultAnnotationsChanged | Fires when the DefaultAnnotationsCollection has changed, but only after the control has been initially rendered.
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | ImageChanged | Fires when the Image has changed. (Inherited from WebImageViewer.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | NewImage | Obsolete. Fires when this Workspace is set to a new current image. (Obsolete.) (Inherited from WebImageViewer.)
Public event | PartialPost | Fires when the control receives post data from the client, without a full PostBack. Returns a string containing the posted data. (Inherited from WebViewerControl.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Progress | Fires while an image is being processed, loaded, or saved. (Inherited from WebImageViewer.)
Public event | RemoteInvoke | Fires when the control is told to RemoteInvoke. Returns a string containing the remote method's return value. (Inherited from WebViewerControl.)
Public event | ResizeImageForZoom | Fires when the control is going to resize an image to give the user a chance to resize. (Inherited from WebImageViewer.)
Public event | ScrollBarVisibilityChanged | Fires when the ScrollPort.ScrollBarVisibility property has changed. (Inherited from WebViewerControl.)
Public event | ScrollPositionChanged | Fires when the position of the scroll bars have changed. (Inherited from WebViewerControl.)
Public event | SelectionChanged | Fires when the selection has been moved or changed. (After PostBack) (Inherited from WebImageViewer.)
Public event | StreamTile | Fires when a tile is requested and allows the handler to provide it. (Inherited from WebImageViewer.)
Public event | StreamViewImage | Fires only when the viewable portion of the image is streamed to the RichClient. In order for this event to fire properly, the EnableClientEvents property must be set to true. (Inherited from WebImageViewer.)
Public event | TileStreamed | Fires when a tile has been streamed to the response and allows the handler to cache it. (Inherited from WebImageViewer.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.AnnotationCreated Event

WebAnnotationViewerAnnotationCreated Event

Raised when an annotation is created by the user.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AnnotationCreatedEventHandler AnnotationCreated
Public Event AnnotationCreated As AnnotationCreatedEventHandler

Value

Type: Atalasoft.Imaging.WebControls.AnnotationsAnnotationCreatedEventHandler
Remarks
This event is only raised when an annotation is added by the user drawing it with the mouse. Adding annotations to a LayerAnnotation will not raise this event.
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.AnnotationsModified Event

WebAnnotationViewerAnnotationsModified Event

Fires when annotations are modified from the browser.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AnnotationsModified
Public Event AnnotationsModified As EventHandler

Value

Type: SystemEventHandler
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebAnnotationViewer.DefaultAnnotationsChanged Event

WebAnnotationViewerDefaultAnnotationsChanged Event

Fires when the DefaultAnnotationsCollection has changed, but only after the control has been initially rendered.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CollectionChangedEventHandler DefaultAnnotationsChanged
Public Event DefaultAnnotationsChanged As CollectionChangedEventHandler

Value

Type: Atalasoft.UtilsCollectionChangedEventHandler
Remarks
Caution note Caution
WebAnnotationViewer control is not available for .NET Core.
See Also

Reference

WebAnnotationViewer Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebCommentUIFactory Class

The WebComment IAnnotationUIFactory implementation.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.AnnotationsWebCommentUIFactory

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class WebCommentUIFactory : IAnnotationUIFactory
Public NotInheritable Class WebCommentUIFactory
    Implements IAnnotationUIFactory

The WebCommentUIFactory type exposes the following members.

Constructors
 | Name | Description
Public method | WebCommentUIFactory | Initializes a new instance of the WebCommentUIFactory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns the AnnotationUI object for a specific AnnotationData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


WebCommentUIFactory Constructor

Initializes a new instance of the WebCommentUIFactory class

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebCommentUIFactory()
Public Sub New
See Also

Reference

WebCommentUIFactory Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebCommentUIFactory Methods

The WebCommentUIFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns the AnnotationUI object for a specific AnnotationData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebCommentUIFactory Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebCommentUIFactory.GetAnnotationUI Method

WebCommentUIFactoryGetAnnotationUI Method

Returns the AnnotationUI object for a specific AnnotationData class.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data from which a UI is requested.

Return Value

Type: AnnotationUI
The AnnotationUI object or null (Nothing in VB) if the factory is unable to create the object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

WebCommentUIFactory Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebPdfLinkUIFactory Class

The WebPdfLink IAnnotationUIFactory implementation.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.AnnotationsWebPdfLinkUIFactory

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class WebPdfLinkUIFactory : IAnnotationUIFactory
Public NotInheritable Class WebPdfLinkUIFactory
    Implements IAnnotationUIFactory

The WebPdfLinkUIFactory type exposes the following members.

Constructors
 | Name | Description
Public method | WebPdfLinkUIFactory | Initializes a new instance of the WebPdfLinkUIFactory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns the AnnotationUI object for a specific AnnotationData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Annotations Namespace


WebPdfLinkUIFactory Constructor

Initializes a new instance of the WebPdfLinkUIFactory class

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebPdfLinkUIFactory()
Public Sub New
See Also

Reference

WebPdfLinkUIFactory Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebPdfLinkUIFactory Methods

The WebPdfLinkUIFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAnnotationUI | Returns the AnnotationUI object for a specific AnnotationData class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebPdfLinkUIFactory Class
Atalasoft.Imaging.WebControls.Annotations Namespace


WebPdfLinkUIFactory.GetAnnotationUI Method

WebPdfLinkUIFactoryGetAnnotationUI Method

Returns the AnnotationUI object for a specific AnnotationData class.

Namespace: Atalasoft.Imaging.WebControls.Annotations
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationUI GetAnnotationUI(
    AnnotationData data
)
Public Function GetAnnotationUI (
    data As AnnotationData
) As AnnotationUI

Parameters

data
Type: Atalasoft.AnnotateAnnotationData
The annotation data from which a UI is requested.

Return Value

Type: AnnotationUI
The AnnotationUI object or null (Nothing in VB) if the factory is unable to create the object.

Implements

IAnnotationUIFactoryGetAnnotationUI(AnnotationData)
See Also

Reference

WebPdfLinkUIFactory Class
Atalasoft.Imaging.WebControls.Annotations Namespace


Atalasoft.Imaging.WebControls.Capture Namespace

Classes
 | Class | Description
Public class | KicHandler | A web handler that extends the WebCaptureRequestHandler which can be used to connect to a KIC (Kofax Internet Connector) web service endpoint.
Public class | WebCaptureRequestHandler | Base-class to be used for all capture handlers to process server requests from scanning browser components and AJAX capture service requests.


KicHandler Class

A web handler that extends the WebCaptureRequestHandler which can be used to connect to a KIC (Kofax Internet Connector) web service endpoint.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CaptureWebCaptureRequestHandler
Atalasoft.Imaging.WebControls.CaptureKicHandler

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class KicHandler : WebCaptureRequestHandler
Public Class KicHandler
    Inherits WebCaptureRequestHandler

The KicHandler type exposes the following members.

Constructors
 | Name | Description
Public method | KicHandler | Initializes a new instance of the KicHandler class
Top
Properties
 | Name | Description
Public property | IsReusable | Returns whether this handler can be reused. (Inherited from WebCaptureRequestHandler.)
Top
Methods
 | Name | Description
Protected method | BatchFieldsForBatchClass | Returns the batch fields for a specified batch class. (Overrides WebCaptureRequestHandlerBatchFieldsForBatchClass(String).)
Protected method | CurrentImportId | Returns the guid for the most recent import for the current session. (Overrides WebCaptureRequestHandlerCurrentImportId.)
Protected method | DictListToJson | A helper method to turn List<Dictionary<string, string>> into JSON. (Inherited from WebCaptureRequestHandler.)
Protected method | DictToJson | A helper method to turn a Dictionary<string, string> into JSON. (Inherited from WebCaptureRequestHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContentTypeDescription | Returns the document classes, and form type names for the selected content type. (Overrides WebCaptureRequestHandlerGetContentTypeDescription(HttpContext, String).)
Protected method | GetContentTypeList | Returns the content type names published on the Kofax Capture server that is specifed in the service end point. (Overrides WebCaptureRequestHandlerGetContentTypeList(HttpContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNewImportId | Returns a guid in string form. (Inherited from WebCaptureRequestHandler.)
Protected method | GetRawXml | Returns the full unparsed xml returned from KIC for the specified content type. (Overrides WebCaptureRequestHandlerGetRawXml(String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file. (Inherited from WebCaptureRequestHandler.)
Protected method | ImportDocument | Imports a document with the specified batch class, document class, and folder type name. (Overrides WebCaptureRequestHandlerImportDocument(HttpContext, String, String, String, String).)
Protected method | ImportDocumentWithIndexFields | Method to import a document for the specified contentType, documentClass, and indexfields for the documentClass into KC through KIC. (Overrides WebCaptureRequestHandlerImportDocumentWithIndexFields(HttpContext, String, String, String, String, String).)
Protected method | IndexFieldsForDocumentClass | Returns a list of index fields for each document class in the content type specified. (Overrides WebCaptureRequestHandlerIndexFieldsForDocumentClass(String, String).)
Protected method | IndexFieldsForImport | Creates a Indexfield definition
Protected method | ListToJson | A helper method to turn a List<string> into JSON. (Inherited from WebCaptureRequestHandler.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | This is the entry point to the handler. Requests to this take the form of: http://yourServerName/theHandlerName.ashx?cmd=getContentTypeList (Inherited from WebCaptureRequestHandler.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackStatus | Returns the status of the import for the most recent successfully imported document. The importId would be the guid returned from a successful import. (Overrides WebCaptureRequestHandlerTrackStatus(String).)
Top
Remarks
Caution note Caution
The KIC handler class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler Constructor

Initializes a new instance of the KicHandler class

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public KicHandler()
Public Sub New
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler Properties

The KicHandler type exposes the following members.

Properties
 | Name | Description
Public property | IsReusable | Returns whether this handler can be reused. (Inherited from WebCaptureRequestHandler.)
Top
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler Methods

The KicHandler type exposes the following members.

Methods
 | Name | Description
Protected method | BatchFieldsForBatchClass | Returns the batch fields for a specified batch class. (Overrides WebCaptureRequestHandlerBatchFieldsForBatchClass(String).)
Protected method | CurrentImportId | Returns the guid for the most recent import for the current session. (Overrides WebCaptureRequestHandlerCurrentImportId.)
Protected method | DictListToJson | A helper method to turn List<Dictionary<string, string>> into JSON. (Inherited from WebCaptureRequestHandler.)
Protected method | DictToJson | A helper method to turn a Dictionary<string, string> into JSON. (Inherited from WebCaptureRequestHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContentTypeDescription | Returns the document classes, and form type names for the selected content type. (Overrides WebCaptureRequestHandlerGetContentTypeDescription(HttpContext, String).)
Protected method | GetContentTypeList | Returns the content type names published on the Kofax Capture server that is specifed in the service end point. (Overrides WebCaptureRequestHandlerGetContentTypeList(HttpContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNewImportId | Returns a guid in string form. (Inherited from WebCaptureRequestHandler.)
Protected method | GetRawXml | Returns the full unparsed xml returned from KIC for the specified content type. (Overrides WebCaptureRequestHandlerGetRawXml(String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file. (Inherited from WebCaptureRequestHandler.)
Protected method | ImportDocument | Imports a document with the specified batch class, document class, and folder type name. (Overrides WebCaptureRequestHandlerImportDocument(HttpContext, String, String, String, String).)
Protected method | ImportDocumentWithIndexFields | Method to import a document for the specified contentType, documentClass, and indexfields for the documentClass into KC through KIC. (Overrides WebCaptureRequestHandlerImportDocumentWithIndexFields(HttpContext, String, String, String, String, String).)
Protected method | IndexFieldsForDocumentClass | Returns a list of index fields for each document class in the content type specified. (Overrides WebCaptureRequestHandlerIndexFieldsForDocumentClass(String, String).)
Protected method | IndexFieldsForImport | Creates a Indexfield definition
Protected method | ListToJson | A helper method to turn a List<string> into JSON. (Inherited from WebCaptureRequestHandler.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | This is the entry point to the handler. Requests to this take the form of: http://yourServerName/theHandlerName.ashx?cmd=getContentTypeList (Inherited from WebCaptureRequestHandler.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackStatus | Returns the status of the import for the most recent successfully imported document. The importId would be the guid returned from a successful import. (Overrides WebCaptureRequestHandlerTrackStatus(String).)
Top
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.BatchFieldsForBatchClass Method

KicHandlerBatchFieldsForBatchClass Method

Returns the batch fields for a specified batch class.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override List<Dictionary<string, string>> BatchFieldsForBatchClass(
    string contentType
)
Protected Overrides Function BatchFieldsForBatchClass (
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The name of the batch class

Return Value

Type: ListDictionaryString, String
Returns a List<Dictionary<string, string>> that contains the batch field name, type, and required flag.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.CurrentImportId Method

KicHandlerCurrentImportId Method

Returns the guid for the most recent import for the current session.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override string CurrentImportId()
Protected Overrides Function CurrentImportId As String

Return Value

Type: String
The current import ID in string form.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.GetContentTypeDescription Method

KicHandlerGetContentTypeDescription Method

Returns the document classes, and form type names for the selected content type.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override List<Dictionary<string, string>> GetContentTypeDescription(
    HttpContext context,
    string contentType
)
Protected Overrides Function GetContentTypeDescription (
    context As HttpContext,
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

context
Type: System.WebHttpContext
The current HTTP context of the handler.
contentType
Type: SystemString
The selected ContentType.

Return Value

Type: ListDictionaryString, String
Returns a list of dictionaries that contains the DocumentClass, and FormType for each BatchID.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.GetContentTypeList Method

KicHandlerGetContentTypeList Method

Returns the content type names published on the Kofax Capture server that is specifed in the service end point.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override List<string> GetContentTypeList(
    HttpContext context
)
Protected Overrides Function GetContentTypeList (
    context As HttpContext
) As List(Of String)

Parameters

context
Type: System.WebHttpContext
The current HTTP context of the handler.

Return Value

Type: ListString
Returns a list with the BatchIDs published through the KIC server.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.GetRawXml Method

KicHandlerGetRawXml Method

Returns the full unparsed xml returned from KIC for the specified content type.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override List<string> GetRawXml(
    string contentType
)
Protected Overrides Function GetRawXml (
    contentType As String
) As List(Of String)

Parameters

contentType
Type: SystemString
The currently selected ContentType.

Return Value

Type: ListString
Returns a string that contains the unparsed xml for the KIC GetContentTypeDescriptions service call.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.ImportDocument Method

KicHandlerImportDocument Method

Imports a document with the specified batch class, document class, and folder type name.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Dictionary<string, string> ImportDocument(
    HttpContext context,
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription
)
Protected Overrides Function ImportDocument (
    context As HttpContext,
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String
) As Dictionary(Of String, String)

Parameters

context
Type: System.WebHttpContext
The current HTTP context of the handler.
filename
Type: SystemString
The filename and path of the uploaded document.
contentType
Type: SystemString
The selected BatchID.
contentTypeDocumentClass
Type: SystemString
The selected DocumentClass
contentTypeDescription
Type: SystemString
The ContentType description for the selected BatchID, and DocumentClass.

Return Value

Type: DictionaryString, String
A dictionary that contains the success or failure of the import, the id of the import, and the status of the import.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.ImportDocumentWithIndexFields Method

KicHandlerImportDocumentWithIndexFields Method

Method to import a document for the specified contentType, documentClass, and indexfields for the documentClass into KC through KIC.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Dictionary<string, string> ImportDocumentWithIndexFields(
    HttpContext context,
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription,
    string indexFields
)
Protected Overrides Function ImportDocumentWithIndexFields (
    context As HttpContext,
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String,
    indexFields As String
) As Dictionary(Of String, String)

Parameters

context
Type: System.WebHttpContext
The current HTTP context.
filename
Type: SystemString
The file name of the document.
contentType
Type: SystemString
The specified Kofax Capture contentType.
contentTypeDocumentClass
Type: SystemString
The specified Kofax Capture contentTypeDocumentClass.
contentTypeDescription
Type: SystemString
The specified Kofax Capture contentTypeDescription.
indexFields
Type: SystemString
The specified indexFields, and values to be imported along with the document.

Return Value

Type: DictionaryString, String
Returns a Dictionary<string, string> with the import status.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.IndexFieldsForDocumentClass Method

KicHandlerIndexFieldsForDocumentClass Method

Returns a list of index fields for each document class in the content type specified.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override List<Dictionary<string, string>> IndexFieldsForDocumentClass(
    string contentType,
    string documentClass
)
Protected Overrides Function IndexFieldsForDocumentClass (
    contentType As String,
    documentClass As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The currently selected ContentType.
documentClass
Type: SystemString
The currently selected DocumentClass, and FormType for which the IndexFields will be returned for.

Return Value

Type: ListDictionaryString, String
Returns a dictionary that contains the IndexField, and type of the field.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.IndexFieldsForImport Method

KicHandlerIndexFieldsForImport Method

Creates a Indexfield definition

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IndexFieldDefinition[] IndexFieldsForImport(
    string indexFields
)
Protected Overridable Function IndexFieldsForImport (
    indexFields As String
) As IndexFieldDefinition()

Parameters

indexFields
Type: SystemString
The list of index fields from the client. If "" or null is passed an empty array of IndexfieldDefinitions is returned.

Return Value

Type: IndexFieldDefinition
Returns an IndexFieldDefinition array.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


KicHandler.TrackStatus Method

KicHandlerTrackStatus Method

Returns the status of the import for the most recent successfully imported document. The importId would be the guid returned from a successful import.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Dictionary<string, string> TrackStatus(
    string importId
)
Protected Overrides Function TrackStatus (
    importId As String
) As Dictionary(Of String, String)

Parameters

importId
Type: SystemString
A guid in string form for a current import to KIC.

Return Value

Type: DictionaryString, String
Returns a dictionary that contains the current status of the import for the import ID.
Remarks
Caution note Caution
The KIC handler is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler Class

Base-class to be used for all capture handlers to process server requests from scanning browser components and AJAX capture service requests.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CaptureWebCaptureRequestHandler
Atalasoft.Imaging.WebControls.CaptureKicHandler

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebCaptureRequestHandler : IHttpHandler
Public Class WebCaptureRequestHandler
    Implements IHttpHandler

The WebCaptureRequestHandler type exposes the following members.

Constructors
 | Name | Description
Public method | WebCaptureRequestHandler | Initializes a new instance of the WebCaptureRequestHandler class.
Top
Properties
 | Name | Description
Public property | IsReusable | Returns whether this handler can be reused.
 | UploadPath | Returns the upload path. By default this is "~/atala-capture-upload", or what is specified in the web.config appsettings section. For example: <add key="atala_uploadpath" value="c:\documentUploadFolder\tifs"/>
Top
Methods
 | Name | Description
Protected method | BatchFieldsForBatchClass | Method to return the batch fields for a batch class.
Protected method | CurrentImportId | Returns the current import ID.
Protected method | DictListToJson | A helper method to turn List<Dictionary<string, string>> into JSON.
Protected method | DictToJson | A helper method to turn a Dictionary<string, string> into JSON.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContentTypeDescription | Method to get content type descriptions for a specified content type from Kofax products.
Protected method | GetContentTypeList | Method to get content type lists from Kofax products.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNewImportId | Returns a guid in string form.
Protected method | GetRawXml | Would return unparsed xml, when overridden to connect to Kofax products.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file.
Protected method | ImportDocument | Method to import uploaded documents into Kofax products.
Protected method | ImportDocumentWithIndexFields | Method to import an uploaded document into Kofax Capture along with index field information.
Protected method | IndexFieldsForDocumentClass | Method to return IndexFields for a specified document class when overridden.
Protected method | ListToJson | A helper method to turn a List<string> into JSON.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | This is the entry point to the handler. Requests to this take the form of: http://yourServerName/theHandlerName.ashx?cmd=getContentTypeList
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackStatus | Returns the status of a document with the specified import ID.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler Constructor

Initializes a new instance of the WebCaptureRequestHandler class.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebCaptureRequestHandler()
Public Sub New
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler Properties

The WebCaptureRequestHandler type exposes the following members.

Properties
 | Name | Description
Public property | IsReusable | Returns whether this handler can be reused.
 | UploadPath | Returns the upload path. By default this is "~/atala-capture-upload", or what is specified in the web.config appsettings section. For example: <add key="atala_uploadpath" value="c:\documentUploadFolder\tifs"/>
Top
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.IsReusable Property

WebCaptureRequestHandlerIsReusable Property

Returns whether this handler can be reused.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReusable { get; }
Public ReadOnly Property IsReusable As Boolean
    Get

Property Value

Type: Boolean

Implements

IHttpHandlerIsReusable
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.UploadPath Property

WebCaptureRequestHandlerUploadPath Property

Returns the upload path. By default this is "~/atala-capture-upload", or what is specified in the web.config appsettings section. For example: <add key="atala_uploadpath" value="c:\documentUploadFolder\tifs"/>

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string UploadPath { get; }
Public Shared ReadOnly Property UploadPath As String
    Get

Property Value

Type: String
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler Methods

The WebCaptureRequestHandler type exposes the following members.

Methods
 | Name | Description
Protected method | BatchFieldsForBatchClass | Method to return the batch fields for a batch class.
Protected method | CurrentImportId | Returns the current import ID.
Protected method | DictListToJson | A helper method to turn List<Dictionary<string, string>> into JSON.
Protected method | DictToJson | A helper method to turn a Dictionary<string, string> into JSON.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContentTypeDescription | Method to get content type descriptions for a specified content type from Kofax products.
Protected method | GetContentTypeList | Method to get content type lists from Kofax products.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNewImportId | Returns a guid in string form.
Protected method | GetRawXml | Would return unparsed xml, when overridden to connect to Kofax products.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file.
Protected method | ImportDocument | Method to import uploaded documents into Kofax products.
Protected method | ImportDocumentWithIndexFields | Method to import an uploaded document into Kofax Capture along with index field information.
Protected method | IndexFieldsForDocumentClass | Method to return IndexFields for a specified document class when overridden.
Protected method | ListToJson | A helper method to turn a List<string> into JSON.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | This is the entry point to the handler. Requests to this take the form of: http://yourServerName/theHandlerName.ashx?cmd=getContentTypeList
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackStatus | Returns the status of a document with the specified import ID.
Top
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.BatchFieldsForBatchClass Method

WebCaptureRequestHandlerBatchFieldsForBatchClass Method

Method to return the batch fields for a batch class.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual List<Dictionary<string, string>> BatchFieldsForBatchClass(
    string contentType
)
Protected Overridable Function BatchFieldsForBatchClass (
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The currently selected contentType.

Return Value

Type: ListDictionaryString, String
Returns an empty list of dictionaries.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.CurrentImportId Method

WebCaptureRequestHandlerCurrentImportId Method

Returns the current import ID.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string CurrentImportId()
Protected Overridable Function CurrentImportId As String

Return Value

Type: String
Returns an empty string.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.DictListToJson Method

WebCaptureRequestHandlerDictListToJson Method

A helper method to turn List<Dictionary<string, string>> into JSON.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string DictListToJson(
    List<Dictionary<string, string>> list
)
Protected Function DictListToJson (
    list As List(Of Dictionary(Of String, String))
) As String

Parameters

list
Type: System.Collections.GenericListDictionaryString, String
The List<Dictionary<string, string>> which the JSON string is made from.

Return Value

Type: String
Returns a JSON parsable string made from the List<Dictionary<string, string>> passed in..
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.DictToJson Method

WebCaptureRequestHandlerDictToJson Method

A helper method to turn a Dictionary<string, string> into JSON.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string DictToJson(
    Dictionary<string, string> dict
)
Protected Function DictToJson (
    dict As Dictionary(Of String, String)
) As String

Parameters

dict
Type: System.Collections.GenericDictionaryString, String
The Dictionary<string, string> which the JSON string is made from.

Return Value

Type: String
Returns a JSON parsable string made from the Dictionary<string, string> passed in.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.GetContentTypeDescription Method

WebCaptureRequestHandlerGetContentTypeDescription Method

Method to get content type descriptions for a specified content type from Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual List<Dictionary<string, string>> GetContentTypeDescription(
    HttpContext context,
    string contentType
)
Protected Overridable Function GetContentTypeDescription (
    context As HttpContext,
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

context
Type: System.WebHttpContext
The current HTTP context.
contentType
Type: SystemString
The currently selected ContentType.

Return Value

Type: ListDictionaryString, String
Returns an empty List<Dictionary<string, string>>.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.GetContentTypeList Method

WebCaptureRequestHandlerGetContentTypeList Method

Method to get content type lists from Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual List<string> GetContentTypeList(
    HttpContext context
)
Protected Overridable Function GetContentTypeList (
    context As HttpContext
) As List(Of String)

Parameters

context
Type: System.WebHttpContext
The current HTTP context.

Return Value

Type: ListString
Returns an empty list.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.GetNewImportId Method

WebCaptureRequestHandlerGetNewImportId Method

Returns a guid in string form.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string GetNewImportId(
    HttpContext context
)
Protected Overridable Function GetNewImportId (
    context As HttpContext
) As String

Parameters

context
Type: System.WebHttpContext
The current HTTP context.

Return Value

Type: String
Returns a guid in string form.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.GetRawXml Method

WebCaptureRequestHandlerGetRawXml Method

Would return unparsed xml, when overridden to connect to Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual List<string> GetRawXml(
    string contentType
)
Protected Overridable Function GetRawXml (
    contentType As String
) As List(Of String)

Parameters

contentType
Type: SystemString
The selected ContentType.

Return Value

Type: ListString
Returns an empty list.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.HandleUpload Method

WebCaptureRequestHandlerHandleUpload Method

Decodes the base64 encoded stream from the client, and save it as a tif file.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string HandleUpload(
    HttpContext context
)
Protected Overridable Function HandleUpload (
    context As HttpContext
) As String

Parameters

context
Type: System.WebHttpContext
The current HTTP context.

Return Value

Type: String
Returns the path to the file uploaded.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.ImportDocument Method

WebCaptureRequestHandlerImportDocument Method

Method to import uploaded documents into Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Dictionary<string, string> ImportDocument(
    HttpContext context,
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription
)
Protected Overridable Function ImportDocument (
    context As HttpContext,
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String
) As Dictionary(Of String, String)

Parameters

context
Type: System.WebHttpContext
The current HTTP context.
filename
Type: SystemString
The full path name of the file to be imported.
contentType
Type: SystemString
The currently selected ContentType.
contentTypeDocumentClass
Type: SystemString
The currently selected DocumentClass.
contentTypeDescription
Type: SystemString
The ContentTypeDescription for the selected ContentType.

Return Value

Type: DictionaryString, String
Returns an empty Dictionary<string, string>.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.ImportDocumentWithIndexFields Method

WebCaptureRequestHandlerImportDocumentWithIndexFields Method

Method to import an uploaded document into Kofax Capture along with index field information.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Dictionary<string, string> ImportDocumentWithIndexFields(
    HttpContext context,
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription,
    string indexFields
)
Protected Overridable Function ImportDocumentWithIndexFields (
    context As HttpContext,
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String,
    indexFields As String
) As Dictionary(Of String, String)

Parameters

context
Type: System.WebHttpContext
The current HTTP context.
filename
Type: SystemString
The full path name of the file to be imported.
contentType
Type: SystemString
The currently selected ContentType.
contentTypeDocumentClass
Type: SystemString
The currently selected DocumentClass.
contentTypeDescription
Type: SystemString
The ContentTypeDescription for the selected ContentType.
indexFields
Type: SystemString
The index field names, and values.

Return Value

Type: DictionaryString, String
Returns an empty Dictionary<string, string>.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.IndexFieldsForDocumentClass Method

WebCaptureRequestHandlerIndexFieldsForDocumentClass Method

Method to return IndexFields for a specified document class when overridden.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual List<Dictionary<string, string>> IndexFieldsForDocumentClass(
    string contentType,
    string documentClass
)
Protected Overridable Function IndexFieldsForDocumentClass (
    contentType As String,
    documentClass As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
the selected ContentType.
documentClass
Type: SystemString
The selected DocumentClass of the selected ContentType.

Return Value

Type: ListDictionaryString, String
Returns an empty dictionary.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.ListToJson Method

WebCaptureRequestHandlerListToJson Method

A helper method to turn a List<string> into JSON.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string ListToJson(
    List<string> list
)
Protected Function ListToJson (
    list As List(Of String)
) As String

Parameters

list
Type: System.Collections.GenericListString
The List<string> which the JSON string is made from.

Return Value

Type: String
Returns a JSON parsable string made from the List<string> passed in.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.ProcessRequest Method

WebCaptureRequestHandlerProcessRequest Method

This is the entry point to the handler. Requests to this take the form of: http://yourServerName/theHandlerName.ashx?cmd=getContentTypeList

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ProcessRequest(
    HttpContext context
)
Public Overridable Sub ProcessRequest (
    context As HttpContext
)

Parameters

context
Type: System.WebHttpContext
The current HTTP context.

Implements

IHttpHandlerProcessRequest(HttpContext)
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


WebCaptureRequestHandler.TrackStatus Method

WebCaptureRequestHandlerTrackStatus Method

Returns the status of a document with the specified import ID.

Namespace: Atalasoft.Imaging.WebControls.Capture
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Dictionary<string, string> TrackStatus(
    string importId
)
Protected Overridable Function TrackStatus (
    importId As String
) As Dictionary(Of String, String)

Parameters

importId
Type: SystemString
The guid, in string form, of an active import.

Return Value

Type: DictionaryString, String
Returns an empty dictionary.
See Also

Reference

WebCaptureRequestHandler Class
Atalasoft.Imaging.WebControls.Capture Namespace


Atalasoft.Imaging.WebControls.Capture.Authentication Namespace

Classes
 | Class | Description
Public class | AuthenticationSession | A base class for specifying custom authentication logic.
Public class | Authenticator | Automatically manages the lifetime of an AuthenticationSession instance.
Public class | CredentialAuthenticationSession | A AuthenticationSession that temporarily impersonates another ActiveDirectory user.
Public class | NullAuthenticationSession | The AuthenticationSession that is used when no special authentication is needed.


AuthenticationSession Class

A base class for specifying custom authentication logic.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.AuthenticationAuthenticationSession
Atalasoft.Imaging.WebControls.Capture.AuthenticationCredentialAuthenticationSession
Atalasoft.Imaging.WebControls.Capture.AuthenticationNullAuthenticationSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class AuthenticationSession
Public MustInherit Class AuthenticationSession

The AuthenticationSession type exposes the following members.

Constructors
 | Name | Description
Protected method | AuthenticationSession | Initializes a new instance of the AuthenticationSession class
Top
Methods
 | Name | Description
Public method | Enter | Obsolete. Called before privileged operations are about to be performed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Leave | Obsolete. Called after privileged access is no longer needed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


AuthenticationSession Constructor

Initializes a new instance of the AuthenticationSession class

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AuthenticationSession()
Protected Sub New
See Also

Reference

AuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


AuthenticationSession Methods

The AuthenticationSession type exposes the following members.

Methods
 | Name | Description
Public method | Enter | Obsolete. Called before privileged operations are about to be performed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Leave | Obsolete. Called after privileged access is no longer needed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


AuthenticationSession.Enter Method

AuthenticationSessionEnter Method

Note: This API is now obsolete.

Called before privileged operations are about to be performed.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use RunAsImpersonated method instead.")]
public abstract void Enter()
<ObsoleteAttribute("Use RunAsImpersonated method instead.")>
Public MustOverride Sub Enter
See Also

Reference

AuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


AuthenticationSession.Leave Method

AuthenticationSessionLeave Method

Note: This API is now obsolete.

Called after privileged access is no longer needed.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use RunAsImpersonated method instead.")]
public abstract void Leave()
<ObsoleteAttribute("Use RunAsImpersonated method instead.")>
Public MustOverride Sub Leave
See Also

Reference

AuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


Authenticator Class

Automatically manages the lifetime of an AuthenticationSession instance.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.AuthenticationAuthenticator

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Authenticator : IDisposable
Public Class Authenticator
    Implements IDisposable

The Authenticator type exposes the following members.

Constructors
 | Name | Description
Public method | Authenticator | Creates a new Authenticator object that will activate and an AuthenticationSession.
Top
Methods
 | Name | Description
Public method | Dispose | Deactivates the held AuthenticationSession instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Authenticator destructor (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


Authenticator Constructor

Creates a new Authenticator object that will activate and an AuthenticationSession.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Authenticator(
    AuthenticationSession session
)
Public Sub New (
    session As AuthenticationSession
)

Parameters

session
Type: Atalasoft.Imaging.WebControls.Capture.AuthenticationAuthenticationSession
An unactivated AuthenticationSession.
See Also

Reference

Authenticator Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


Authenticator Methods

The Authenticator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Deactivates the held AuthenticationSession instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Authenticator destructor (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Authenticator Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


Authenticator.Dispose Method

AuthenticatorDispose Method

Deactivates the held AuthenticationSession instance.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Authenticator Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


Authenticator.Finalize Method

AuthenticatorFinalize Method

Authenticator destructor

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Authenticator Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession Class

A AuthenticationSession that temporarily impersonates another ActiveDirectory user.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.AuthenticationAuthenticationSession
Atalasoft.Imaging.WebControls.Capture.AuthenticationCredentialAuthenticationSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CredentialAuthenticationSession : AuthenticationSession
Public Class CredentialAuthenticationSession
    Inherits AuthenticationSession

The CredentialAuthenticationSession type exposes the following members.

Constructors
 | Name | Description
Public method | CredentialAuthenticationSession | Creates a new AuthenticationSession to impersonate a user with the given domain, username, and password.
Top
Properties
 | Name | Description
Protected property | IsInContext | Indicates whether the impersonated user context is active or not.
Top
Methods
 | Name | Description
Public method | Enter | Obsolete. Changes the effective user identity in the current execution context to match the user that was used to construct this AuthenticationSession. This method does not work for .NET 5 and greater. (Overrides AuthenticationSessionEnter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Leave | Obsolete. Restores the effective user identity to its previous state. (Overrides AuthenticationSessionLeave.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
User accounts impersonated with this class are considered to be interactive identity tokens. This means the impersonated user can be used to access remote network resources (like a remote Sharepoint server). Standard ASP.NET impersonation, on the other hand, cannot be used to access network resources.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession Constructor

Creates a new AuthenticationSession to impersonate a user with the given domain, username, and password.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CredentialAuthenticationSession(
    string domain,
    string username,
    string password
)
Public Sub New (
    domain As String,
    username As String,
    password As String
)

Parameters

domain
Type: SystemString
The domain of the user.
username
Type: SystemString
The username of the user.
password
Type: SystemString
The plaintext password of the user.
See Also

Reference

CredentialAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession Properties

The CredentialAuthenticationSession type exposes the following members.

Properties
 | Name | Description
Protected property | IsInContext | Indicates whether the impersonated user context is active or not.
Top
See Also

Reference

CredentialAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession.IsInContext Property

CredentialAuthenticationSessionIsInContext Property

Indicates whether the impersonated user context is active or not.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsInContext { get; }
Protected ReadOnly Property IsInContext As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CredentialAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession Methods

The CredentialAuthenticationSession type exposes the following members.

Methods
 | Name | Description
Public method | Enter | Obsolete. Changes the effective user identity in the current execution context to match the user that was used to construct this AuthenticationSession. This method does not work for .NET 5 and greater. (Overrides AuthenticationSessionEnter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Leave | Obsolete. Restores the effective user identity to its previous state. (Overrides AuthenticationSessionLeave.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CredentialAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession.Enter Method

CredentialAuthenticationSessionEnter Method

Note: This API is now obsolete.

Changes the effective user identity in the current execution context to match the user that was used to construct this AuthenticationSession. This method does not work for .NET 5 and greater.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use RunAsImpersonated method instead for .NET5 or greater.")]
public override void Enter()
<ObsoleteAttribute("Use RunAsImpersonated method instead for .NET5 or greater.")>
Public Overrides Sub Enter
See Also

Reference

CredentialAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


CredentialAuthenticationSession.Leave Method

CredentialAuthenticationSessionLeave Method

Note: This API is now obsolete.

Restores the effective user identity to its previous state.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("For .NET 5 and greater use RunAsImpersonated method")]
public override void Leave()
<ObsoleteAttribute("For .NET 5 and greater use RunAsImpersonated method")>
Public Overrides Sub Leave
See Also

Reference

CredentialAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


NullAuthenticationSession Class

The AuthenticationSession that is used when no special authentication is needed.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.AuthenticationAuthenticationSession
Atalasoft.Imaging.WebControls.Capture.AuthenticationNullAuthenticationSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class NullAuthenticationSession : AuthenticationSession
Public Class NullAuthenticationSession
    Inherits AuthenticationSession

The NullAuthenticationSession type exposes the following members.

Constructors
 | Name | Description
Public method | NullAuthenticationSession | Initializes a new instance of the NullAuthenticationSession class
Top
Methods
 | Name | Description
Public method | Enter | Obsolete. Performs no actions. (Overrides AuthenticationSessionEnter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Leave | Obsolete. Performs no actions. (Overrides AuthenticationSessionLeave.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This should not be confused with ASP.NET's anonymous authentication. When this object is used by a handler, the current authentication level and credentials currently in effect in ASP.NET will be used.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


NullAuthenticationSession Constructor

Initializes a new instance of the NullAuthenticationSession class

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NullAuthenticationSession()
Public Sub New
See Also

Reference

NullAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


NullAuthenticationSession Methods

The NullAuthenticationSession type exposes the following members.

Methods
 | Name | Description
Public method | Enter | Obsolete. Performs no actions. (Overrides AuthenticationSessionEnter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Leave | Obsolete. Performs no actions. (Overrides AuthenticationSessionLeave.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NullAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


NullAuthenticationSession.Enter Method

NullAuthenticationSessionEnter Method

Note: This API is now obsolete.

Performs no actions.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public override void Enter()
<ObsoleteAttribute>
Public Overrides Sub Enter
See Also

Reference

NullAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


NullAuthenticationSession.Leave Method

NullAuthenticationSessionLeave Method

Note: This API is now obsolete.

Performs no actions.

Namespace: Atalasoft.Imaging.WebControls.Capture.Authentication
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public override void Leave()
<ObsoleteAttribute>
Public Overrides Sub Leave
See Also

Reference

NullAuthenticationSession Class
Atalasoft.Imaging.WebControls.Capture.Authentication Namespace


Atalasoft.Imaging.WebControls.Capture.Cmis Namespace

Classes
 | Class | Description
Public class | ACLEntryTypeGenerator | The ACLEntryTypeGenerator contains methods to create CMIS ACL control entry types, and properties.
Public class | ACLEntryTypeGeneratorAclPermissions | A static class that has three string constants that represent the ACL permission level.
Public class | CmisConnector | A class to create instances of the CMIS service clients. The class is available with .NET Framework 3.5 and 4.5.2 only.
Public class | CmisPropertyIds | A static class for dealing with CMIS object properties.
Public class | ContentStream | A static class to make working with CMIS a little easier by putting some of the necessary bits for creatign object service content streams in one place.
Public class | ContentStreamMimeType | Just a simple class that returns a string representing a MIME type that CMIS wants for a given document to be turned into a content stream.
Remarks
Caution note Caution
The classes from Atalasoft.Imaging.WebControls.Capture.Cmis namespace are not available for .NET 5 and above.


ACLEntryTypeGenerator Class

The ACLEntryTypeGenerator contains methods to create CMIS ACL control entry types, and properties.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.CmisACLEntryTypeGenerator

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class ACLEntryTypeGenerator
Public NotInheritable Class ACLEntryTypeGenerator

The ACLEntryTypeGenerator type exposes the following members.

Methods
Name | Description
AclEntryType | Method to create a ObjectService.cmisAccessControlEntryType.
Top
Remarks
Caution note Caution
ACLEntryTypeGenerator class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ACLEntryTypeGenerator Methods

The ACLEntryTypeGenerator type exposes the following members.

Methods
Name | Description
AclEntryType | Method to create a ObjectService.cmisAccessControlEntryType.
Top
See Also

Reference

ACLEntryTypeGenerator Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ACLEntryTypeGenerator.AclEntryType Method

ACLEntryTypeGeneratorAclEntryType Method

Method to create a ObjectService.cmisAccessControlEntryType.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisAccessControlEntryType AclEntryType(
    string principalId,
    string permission
)
Public Shared Function AclEntryType (
    principalId As String,
    permission As String
) As cmisAccessControlEntryType

Parameters

principalId
Type: SystemString
The Group, or username that the ACL permission is being applied to.
permission
Type: SystemString
The CMIS ACL permission level. For example, AclPermissions.All, or 'cmis:all'

Return Value

Type: cmisAccessControlEntryType
Returns a ObjectService.cmisAccessControlEntryType.
Remarks
Caution note Caution
ACLEntryTypeGenerator class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ACLEntryTypeGenerator Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ACLEntryTypeGenerator.AclPermissions Class

ACLEntryTypeGeneratorAclPermissions Class

A static class that has three string constants that represent the ACL permission level.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.CmisACLEntryTypeGeneratorAclPermissions

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class AclPermissions
Public NotInheritable Class AclPermissions

The ACLEntryTypeGeneratorAclPermissions type exposes the following members.

Fields
Name | Description
All | Returns the 'cmis:all' ACL permission level.
Read | Returns the 'cmis:read' ACL permission level.
Write | Returns the 'cmis:write' ACL permission level.
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


AclPermissions Fields

The ACLEntryTypeGeneratorAclPermissions type exposes the following members.

Fields
Name | Description
All | Returns the 'cmis:all' ACL permission level.
Read | Returns the 'cmis:read' ACL permission level.
Write | Returns the 'cmis:write' ACL permission level.
Top
See Also

Reference

ACLEntryTypeGeneratorAclPermissions Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ACLEntryTypeGenerator.AclPermissions.All Field

ACLEntryTypeGeneratorAclPermissionsAll Field

Returns the 'cmis:all' ACL permission level.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string All = "cmis:all"
Public Const All As String = "cmis:all"

Field Value

Type: String
See Also

Reference

ACLEntryTypeGeneratorAclPermissions Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ACLEntryTypeGenerator.AclPermissions.Read Field

ACLEntryTypeGeneratorAclPermissionsRead Field

Returns the 'cmis:read' ACL permission level.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Read = "cmis:read"
Public Const Read As String = "cmis:read"

Field Value

Type: String
See Also

Reference

ACLEntryTypeGeneratorAclPermissions Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ACLEntryTypeGenerator.AclPermissions.Write Field

ACLEntryTypeGeneratorAclPermissionsWrite Field

Returns the 'cmis:write' ACL permission level.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Write = "cmis:write"
Public Const Write As String = "cmis:write"

Field Value

Type: String
See Also

Reference

ACLEntryTypeGeneratorAclPermissions Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector Class

A class to create instances of the CMIS service clients. The class is available with .NET Framework 3.5 and 4.5.2 only.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.CmisCmisConnector

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CmisConnector
Public Class CmisConnector

The CmisConnector type exposes the following members.

Constructors
 | Name | Description
Public method | CmisConnector | Constructor to create the instances of the CMIS service clients.
Top
Properties
 | Name | Description
Public property | AclClient | Returns the current instance of the CMIS ACLServicePortClient.
Public property | CmisClient | Returns the current instance of the CMIS DiscoveryServicePortClient.
Public property | DiscoveryClient | Returns the current instance of the CMIS DiscoveryServicePortClient.
Public property | MultiFilingClient | Returns the current instance of the CMIS MultiFilingServicePortClient.
Public property | NavigationClient | Returns the current instance of the CMIS NavigationServicePortClient.
Public property | ObjectClient | Returns the current instance of the CMIS ObjectServicePortClient.
Public property | PolicyClient | Returns the current instance of the CMIS PolicyServicePortClient.
Public property | RelationshipClient | Returns the current instance of the CMIS RelationshipServicePortClient.
Public property | RepositoryClient | Returns the current instance of the CMIS RepositoryServicePortClient.
Public property | RepositoryId | Returns the guid for the current repository.
Public property | VersioningClient | Returns the current instance of the CMIS VersioningServicePortClient.
Top
Methods
 | Name | Description
Public method | Close | Method to close the CMIS clients.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRepositories | Method to return the lists, and list guids for the given endpoint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector Constructor

Constructor to create the instances of the CMIS service clients.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmisConnector()
Public Sub New
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector Properties

The CmisConnector type exposes the following members.

Properties
 | Name | Description
Public property | AclClient | Returns the current instance of the CMIS ACLServicePortClient.
Public property | CmisClient | Returns the current instance of the CMIS DiscoveryServicePortClient.
Public property | DiscoveryClient | Returns the current instance of the CMIS DiscoveryServicePortClient.
Public property | MultiFilingClient | Returns the current instance of the CMIS MultiFilingServicePortClient.
Public property | NavigationClient | Returns the current instance of the CMIS NavigationServicePortClient.
Public property | ObjectClient | Returns the current instance of the CMIS ObjectServicePortClient.
Public property | PolicyClient | Returns the current instance of the CMIS PolicyServicePortClient.
Public property | RelationshipClient | Returns the current instance of the CMIS RelationshipServicePortClient.
Public property | RepositoryClient | Returns the current instance of the CMIS RepositoryServicePortClient.
Public property | RepositoryId | Returns the guid for the current repository.
Public property | VersioningClient | Returns the current instance of the CMIS VersioningServicePortClient.
Top
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.AclClient Property

CmisConnectorAclClient Property

Returns the current instance of the CMIS ACLServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ACLServicePortClient AclClient { get; }
Public ReadOnly Property AclClient As ACLServicePortClient
    Get

Property Value

Type: ACLServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.CmisClient Property

CmisConnectorCmisClient Property

Returns the current instance of the CMIS DiscoveryServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DiscoveryServicePortClient CmisClient { get; }
Public ReadOnly Property CmisClient As DiscoveryServicePortClient
    Get

Property Value

Type: DiscoveryServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.DiscoveryClient Property

CmisConnectorDiscoveryClient Property

Returns the current instance of the CMIS DiscoveryServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DiscoveryServicePortClient DiscoveryClient { get; }
Public ReadOnly Property DiscoveryClient As DiscoveryServicePortClient
    Get

Property Value

Type: DiscoveryServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.MultiFilingClient Property

CmisConnectorMultiFilingClient Property

Returns the current instance of the CMIS MultiFilingServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MultiFilingServicePortClient MultiFilingClient { get; }
Public ReadOnly Property MultiFilingClient As MultiFilingServicePortClient
    Get

Property Value

Type: MultiFilingServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.NavigationClient Property

CmisConnectorNavigationClient Property

Returns the current instance of the CMIS NavigationServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NavigationServicePortClient NavigationClient { get; }
Public ReadOnly Property NavigationClient As NavigationServicePortClient
    Get

Property Value

Type: NavigationServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.ObjectClient Property

CmisConnectorObjectClient Property

Returns the current instance of the CMIS ObjectServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ObjectServicePortClient ObjectClient { get; }
Public ReadOnly Property ObjectClient As ObjectServicePortClient
    Get

Property Value

Type: ObjectServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.PolicyClient Property

CmisConnectorPolicyClient Property

Returns the current instance of the CMIS PolicyServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolicyServicePortClient PolicyClient { get; }
Public ReadOnly Property PolicyClient As PolicyServicePortClient
    Get

Property Value

Type: PolicyServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.RelationshipClient Property

CmisConnectorRelationshipClient Property

Returns the current instance of the CMIS RelationshipServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RelationshipServicePortClient RelationshipClient { get; }
Public ReadOnly Property RelationshipClient As RelationshipServicePortClient
    Get

Property Value

Type: RelationshipServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.RepositoryClient Property

CmisConnectorRepositoryClient Property

Returns the current instance of the CMIS RepositoryServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepositoryServicePortClient RepositoryClient { get; }
Public ReadOnly Property RepositoryClient As RepositoryServicePortClient
    Get

Property Value

Type: RepositoryServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.RepositoryId Property

CmisConnectorRepositoryId Property

Returns the guid for the current repository.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RepositoryId { get; set; }
Public Property RepositoryId As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.VersioningClient Property

CmisConnectorVersioningClient Property

Returns the current instance of the CMIS VersioningServicePortClient.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public VersioningServicePortClient VersioningClient { get; }
Public ReadOnly Property VersioningClient As VersioningServicePortClient
    Get

Property Value

Type: VersioningServicePortClient
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector Methods

The CmisConnector type exposes the following members.

Methods
 | Name | Description
Public method | Close | Method to close the CMIS clients.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRepositories | Method to return the lists, and list guids for the given endpoint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.Close Method

CmisConnectorClose Method

Method to close the CMIS clients.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisConnector.GetRepositories Method

CmisConnectorGetRepositories Method

Method to return the lists, and list guids for the given endpoint.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dictionary<string, string> GetRepositories()
Public Function GetRepositories As Dictionary(Of String, String)

Return Value

Type: DictionaryString, String
Returns a dictionary with the guid for the key, and name for the value.
Remarks
Caution note Caution
CmisConnector class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisConnector Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds Class

A static class for dealing with CMIS object properties.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.CmisCmisPropertyIds

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class CmisPropertyIds
Public NotInheritable Class CmisPropertyIds

The CmisPropertyIds type exposes the following members.

Methods
Name | Description
ChildrenWithProperties | A method that given a CMIS Navigation Service cmisObjectInFolderType array will return the CMIS property type for the objects in the collection.
GetPropertyBoolean | A method to create a CMIS boolean property.
GetPropertyDateTime | A methof to create a CMIS DateTime property.
GetPropertyId | Method to create a CMIS property Id.
GetPropertyInteger | A method to create a CMIS integer property.
GetPropertyString | Returns a CMIS proerty string.
MakeImportDocumentPropertiesList | A method to create the basic set of properties needed to create a document in a repository.
Top
Fields
Name | Description
AllowedChildObjectTypeIds | Returns the CMIS allowedChildObjectTypeIds property type.
BaseTypeId | Returns the CMIS baseTypeId property type.
ChangeToken | Returns the CMIS changeToken property type.
CheckinComment | Returns the CMIS checkinComment property type.
ContentStreamFileName | Returns the CMIS contentStreamFileName property type.
ContentStreamId | Returns the CMIS contentStreamId property type.
ContentStreamLength | Returns the CMIS contentStreamLength property type.
ContentStreamMimeType | Returns the CMIS contentStreamMimeType property type.
CreatedBy | Returns the CMIS createdBy property type.
CreationDate | Returns the CMIS creationDate property type.
Document | Returns the CMIS document property type.
Folder | Returns the CMIS folder property type.
IsImmutable | Returns the CMIS isImmutable property type.
IsLatestMajorVersion | Returns the CMIS isLatestMajorVersion property type.
IsLatestVersion | Returns the CMIS isLatestVersion property type.
IsMajorVersion | Returns the CMIS isMajorVersion property type.
IsVersionSeriesCheckedOut | Returns the CMIS isVersionSeriesCheckedOut property type.
LastModificationDate | Returns the CMIS lastModificationDate property type.
LastModifiedBy | Returns the CMIS lastModifyBy property type.
Name | Returns the CMIS name property type.
ObjectId | Returns the CMIS objectId property type.
ObjectTypeId | Returns the CMIS objectTypeId property type.
ParentId | Returns the CMIS parentId property type.
Path | Returns the CMIS path property type.
PolicyText | Returns the CMIS policyText property type.
SourceId | Returns the CMIS sourceId property type.
TargetId | Returns the CMIS targetId property type.
VersionLabel | Returns the CMIS versionLabel property type.
VersionSeriesCheckedOutBy | Returns the CMIS versionSeriesCheckedOutBy property type.
VersionSeriesCheckedOutId | Returns the CMIS versionSeriesCheckedOutId property type.
VersionSeriesId | Returns the CMIS versionSeriesId property type.
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds Methods

The CmisPropertyIds type exposes the following members.

Methods
Name | Description
ChildrenWithProperties | A method that given a CMIS Navigation Service cmisObjectInFolderType array will return the CMIS property type for the objects in the collection.
GetPropertyBoolean | A method to create a CMIS boolean property.
GetPropertyDateTime | A methof to create a CMIS DateTime property.
GetPropertyId | Method to create a CMIS property Id.
GetPropertyInteger | A method to create a CMIS integer property.
GetPropertyString | Returns a CMIS proerty string.
MakeImportDocumentPropertiesList | A method to create the basic set of properties needed to create a document in a repository.
Top
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ChildrenWithProperties Method

CmisPropertyIdsChildrenWithProperties Method

A method that given a CMIS Navigation Service cmisObjectInFolderType array will return the CMIS property type for the objects in the collection.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static List<Dictionary<string, string>> ChildrenWithProperties(
    cmisObjectInFolderType[] childList
)
Public Shared Function ChildrenWithProperties (
    childList As cmisObjectInFolderType()
) As List(Of Dictionary(Of String, String))

Parameters

childList
Type: cmisObjectInFolderType
A NavigationService.cmisObjectInTypeFolder[].

Return Value

Type: ListDictionaryString, String
Returns a List of Dictionaries that contains the property definition id as the key, and property type as the value.
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.GetPropertyBoolean Method

CmisPropertyIdsGetPropertyBoolean Method

A method to create a CMIS boolean property.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisPropertyBoolean GetPropertyBoolean(
    string displayName,
    string localName,
    string propDef,
    string queryName,
    bool value
)
Public Shared Function GetPropertyBoolean (
    displayName As String,
    localName As String,
    propDef As String,
    queryName As String,
    value As Boolean
) As cmisPropertyBoolean

Parameters

displayName
Type: SystemString
The display name of the property, or what would been seen as the name by a user.
localName
Type: SystemString
A name used internally to the repository.
propDef
Type: SystemString
The CMIS property type.
queryName
Type: SystemString
When submitting a query via the CMIS descovery service.
value
Type: SystemBoolean
The value of the property.

Return Value

Type: cmisPropertyBoolean
Returns a ObjectService.cmisPropertyBoolean.
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.GetPropertyDateTime Method

CmisPropertyIdsGetPropertyDateTime Method

A methof to create a CMIS DateTime property.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisPropertyDateTime GetPropertyDateTime(
    string displayName,
    string localName,
    string propDef,
    string queryName,
    DateTime value
)
Public Shared Function GetPropertyDateTime (
    displayName As String,
    localName As String,
    propDef As String,
    queryName As String,
    value As DateTime
) As cmisPropertyDateTime

Parameters

displayName
Type: SystemString
The display name of the property, or what would been seen as the name by a user.
localName
Type: SystemString
A name used internally to the repository.
propDef
Type: SystemString
The CMIS property type.
queryName
Type: SystemString
When submitting a query via the CMIS descovery service.
value
Type: SystemDateTime
The value of the property.

Return Value

Type: cmisPropertyDateTime
Returns a ObjectService.cmisPropertyDateTime
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.GetPropertyId Method

CmisPropertyIdsGetPropertyId Method

Method to create a CMIS property Id.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisPropertyId GetPropertyId(
    string displayName,
    string localName,
    string propDef,
    string queryName,
    string value
)
Public Shared Function GetPropertyId (
    displayName As String,
    localName As String,
    propDef As String,
    queryName As String,
    value As String
) As cmisPropertyId

Parameters

displayName
Type: SystemString
The display name of the property, or what would been seen as the name by a user.
localName
Type: SystemString
A name used internally to the repository.
propDef
Type: SystemString
The CMIS property type.
queryName
Type: SystemString
When submitting a query via the CMIS descovery service.
value
Type: SystemString
The value of the property.

Return Value

Type: cmisPropertyId
Returns a ObjectService.cmisPropertyId.
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.GetPropertyInteger Method

CmisPropertyIdsGetPropertyInteger Method

A method to create a CMIS integer property.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisPropertyInteger GetPropertyInteger(
    string displayName,
    string localName,
    string propDef,
    string queryName,
    string value
)
Public Shared Function GetPropertyInteger (
    displayName As String,
    localName As String,
    propDef As String,
    queryName As String,
    value As String
) As cmisPropertyInteger

Parameters

displayName
Type: SystemString
The display name of the property, or what would been seen as the name by a user.
localName
Type: SystemString
A name used internally to the repository.
propDef
Type: SystemString
The CMIS property type.
queryName
Type: SystemString
When submitting a query via the CMIS descovery service.
value
Type: SystemString
The value of the property.

Return Value

Type: cmisPropertyInteger
Returns a ObjectService.cmisPropertyInteger.
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.GetPropertyString Method

CmisPropertyIdsGetPropertyString Method

Returns a CMIS proerty string.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisPropertyString GetPropertyString(
    string displayName,
    string localName,
    string propDef,
    string queryName,
    string value
)
Public Shared Function GetPropertyString (
    displayName As String,
    localName As String,
    propDef As String,
    queryName As String,
    value As String
) As cmisPropertyString

Parameters

displayName
Type: SystemString
The display name of the property, or what would been seen as the name by a user.
localName
Type: SystemString
A name used internally to the repository.
propDef
Type: SystemString
The CMIS property type.
queryName
Type: SystemString
When submitting a query via the CMIS descovery service.
value
Type: SystemString
The value of the property.

Return Value

Type: cmisPropertyString
Returns a ObjectService.cmisPropertyString.
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.MakeImportDocumentPropertiesList Method

CmisPropertyIdsMakeImportDocumentPropertiesList Method

A method to create the basic set of properties needed to create a document in a repository.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisPropertiesType MakeImportDocumentPropertiesList(
    string fileName
)
Public Shared Function MakeImportDocumentPropertiesList (
    fileName As String
) As cmisPropertiesType

Parameters

fileName
Type: SystemString
The name of the file which the properties are being created for.

Return Value

Type: cmisPropertiesType
Returns a ObjectService.cmisPropertiesType, which is a collection of CMIS properties.
Remarks
Caution note Caution
CmisPropertyIds class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds Fields

The CmisPropertyIds type exposes the following members.

Fields
Name | Description
AllowedChildObjectTypeIds | Returns the CMIS allowedChildObjectTypeIds property type.
BaseTypeId | Returns the CMIS baseTypeId property type.
ChangeToken | Returns the CMIS changeToken property type.
CheckinComment | Returns the CMIS checkinComment property type.
ContentStreamFileName | Returns the CMIS contentStreamFileName property type.
ContentStreamId | Returns the CMIS contentStreamId property type.
ContentStreamLength | Returns the CMIS contentStreamLength property type.
ContentStreamMimeType | Returns the CMIS contentStreamMimeType property type.
CreatedBy | Returns the CMIS createdBy property type.
CreationDate | Returns the CMIS creationDate property type.
Document | Returns the CMIS document property type.
Folder | Returns the CMIS folder property type.
IsImmutable | Returns the CMIS isImmutable property type.
IsLatestMajorVersion | Returns the CMIS isLatestMajorVersion property type.
IsLatestVersion | Returns the CMIS isLatestVersion property type.
IsMajorVersion | Returns the CMIS isMajorVersion property type.
IsVersionSeriesCheckedOut | Returns the CMIS isVersionSeriesCheckedOut property type.
LastModificationDate | Returns the CMIS lastModificationDate property type.
LastModifiedBy | Returns the CMIS lastModifyBy property type.
Name | Returns the CMIS name property type.
ObjectId | Returns the CMIS objectId property type.
ObjectTypeId | Returns the CMIS objectTypeId property type.
ParentId | Returns the CMIS parentId property type.
Path | Returns the CMIS path property type.
PolicyText | Returns the CMIS policyText property type.
SourceId | Returns the CMIS sourceId property type.
TargetId | Returns the CMIS targetId property type.
VersionLabel | Returns the CMIS versionLabel property type.
VersionSeriesCheckedOutBy | Returns the CMIS versionSeriesCheckedOutBy property type.
VersionSeriesCheckedOutId | Returns the CMIS versionSeriesCheckedOutId property type.
VersionSeriesId | Returns the CMIS versionSeriesId property type.
Top
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.AllowedChildObjectTypeIds Field

CmisPropertyIdsAllowedChildObjectTypeIds Field

Returns the CMIS allowedChildObjectTypeIds property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string AllowedChildObjectTypeIds = "cmis:allowedChildObjectTypeIds"
Public Const AllowedChildObjectTypeIds As String = "cmis:allowedChildObjectTypeIds"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.BaseTypeId Field

CmisPropertyIdsBaseTypeId Field

Returns the CMIS baseTypeId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string BaseTypeId = "cmis:baseTypeId"
Public Const BaseTypeId As String = "cmis:baseTypeId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ChangeToken Field

CmisPropertyIdsChangeToken Field

Returns the CMIS changeToken property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ChangeToken = "cmis:changeToken"
Public Const ChangeToken As String = "cmis:changeToken"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.CheckinComment Field

CmisPropertyIdsCheckinComment Field

Returns the CMIS checkinComment property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string CheckinComment = "cmis:checkinComment"
Public Const CheckinComment As String = "cmis:checkinComment"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ContentStreamFileName Field

CmisPropertyIdsContentStreamFileName Field

Returns the CMIS contentStreamFileName property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ContentStreamFileName = "cmis:contentStreamFileName"
Public Const ContentStreamFileName As String = "cmis:contentStreamFileName"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ContentStreamId Field

CmisPropertyIdsContentStreamId Field

Returns the CMIS contentStreamId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ContentStreamId = "cmis:contentStreamId"
Public Const ContentStreamId As String = "cmis:contentStreamId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ContentStreamLength Field

CmisPropertyIdsContentStreamLength Field

Returns the CMIS contentStreamLength property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ContentStreamLength = "cmis:contentStreamLength"
Public Const ContentStreamLength As String = "cmis:contentStreamLength"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ContentStreamMimeType Field

CmisPropertyIdsContentStreamMimeType Field

Returns the CMIS contentStreamMimeType property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ContentStreamMimeType = "cmis:contentStreamMimeType"
Public Const ContentStreamMimeType As String = "cmis:contentStreamMimeType"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.CreatedBy Field

CmisPropertyIdsCreatedBy Field

Returns the CMIS createdBy property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string CreatedBy = "cmis:createdBy"
Public Const CreatedBy As String = "cmis:createdBy"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.CreationDate Field

CmisPropertyIdsCreationDate Field

Returns the CMIS creationDate property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string CreationDate = "cmis:creationDate"
Public Const CreationDate As String = "cmis:creationDate"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.Document Field

CmisPropertyIdsDocument Field

Returns the CMIS document property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Document = "cmis:document"
Public Const Document As String = "cmis:document"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.Folder Field

CmisPropertyIdsFolder Field

Returns the CMIS folder property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Folder = "cmis:folder"
Public Const Folder As String = "cmis:folder"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.IsImmutable Field

CmisPropertyIdsIsImmutable Field

Returns the CMIS isImmutable property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string IsImmutable = "cmis:isImmutable"
Public Const IsImmutable As String = "cmis:isImmutable"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.IsLatestMajorVersion Field

CmisPropertyIdsIsLatestMajorVersion Field

Returns the CMIS isLatestMajorVersion property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string IsLatestMajorVersion = "cmis:isLatestMajorVersion"
Public Const IsLatestMajorVersion As String = "cmis:isLatestMajorVersion"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.IsLatestVersion Field

CmisPropertyIdsIsLatestVersion Field

Returns the CMIS isLatestVersion property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string IsLatestVersion = "cmis:isLatestVersion"
Public Const IsLatestVersion As String = "cmis:isLatestVersion"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.IsMajorVersion Field

CmisPropertyIdsIsMajorVersion Field

Returns the CMIS isMajorVersion property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string IsMajorVersion = "cmis:isMajorVersion"
Public Const IsMajorVersion As String = "cmis:isMajorVersion"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.IsVersionSeriesCheckedOut Field

CmisPropertyIdsIsVersionSeriesCheckedOut Field

Returns the CMIS isVersionSeriesCheckedOut property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string IsVersionSeriesCheckedOut = "cmis:isVersionSeriesCheckedOut"
Public Const IsVersionSeriesCheckedOut As String = "cmis:isVersionSeriesCheckedOut"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.LastModificationDate Field

CmisPropertyIdsLastModificationDate Field

Returns the CMIS lastModificationDate property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string LastModificationDate = "cmis:lastModificationDate"
Public Const LastModificationDate As String = "cmis:lastModificationDate"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.LastModifiedBy Field

CmisPropertyIdsLastModifiedBy Field

Returns the CMIS lastModifyBy property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string LastModifiedBy = "cmis:lastModifiedBy"
Public Const LastModifiedBy As String = "cmis:lastModifiedBy"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.Name Field

CmisPropertyIdsName Field

Returns the CMIS name property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Name = "cmis:name"
Public Const Name As String = "cmis:name"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ObjectId Field

CmisPropertyIdsObjectId Field

Returns the CMIS objectId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ObjectId = "cmis:objectId"
Public Const ObjectId As String = "cmis:objectId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ObjectTypeId Field

CmisPropertyIdsObjectTypeId Field

Returns the CMIS objectTypeId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ObjectTypeId = "cmis:objectTypeId"
Public Const ObjectTypeId As String = "cmis:objectTypeId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.ParentId Field

CmisPropertyIdsParentId Field

Returns the CMIS parentId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string ParentId = "cmis:parentId"
Public Const ParentId As String = "cmis:parentId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.Path Field

CmisPropertyIdsPath Field

Returns the CMIS path property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Path = "cmis:path"
Public Const Path As String = "cmis:path"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.PolicyText Field

CmisPropertyIdsPolicyText Field

Returns the CMIS policyText property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string PolicyText = "cmis:policyText"
Public Const PolicyText As String = "cmis:policyText"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.SourceId Field

CmisPropertyIdsSourceId Field

Returns the CMIS sourceId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string SourceId = "cmis:sourceId"
Public Const SourceId As String = "cmis:sourceId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.TargetId Field

CmisPropertyIdsTargetId Field

Returns the CMIS targetId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string TargetId = "cmis:targetId"
Public Const TargetId As String = "cmis:targetId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.VersionLabel Field

CmisPropertyIdsVersionLabel Field

Returns the CMIS versionLabel property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string VersionLabel = "cmis:versionLabel"
Public Const VersionLabel As String = "cmis:versionLabel"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.VersionSeriesCheckedOutBy Field

CmisPropertyIdsVersionSeriesCheckedOutBy Field

Returns the CMIS versionSeriesCheckedOutBy property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string VersionSeriesCheckedOutBy = "cmis:versionSeriesCheckedOutBy"
Public Const VersionSeriesCheckedOutBy As String = "cmis:versionSeriesCheckedOutBy"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.VersionSeriesCheckedOutId Field

CmisPropertyIdsVersionSeriesCheckedOutId Field

Returns the CMIS versionSeriesCheckedOutId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string VersionSeriesCheckedOutId = "cmis:versionSeriesCheckedOutId"
Public Const VersionSeriesCheckedOutId As String = "cmis:versionSeriesCheckedOutId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


CmisPropertyIds.VersionSeriesId Field

CmisPropertyIdsVersionSeriesId Field

Returns the CMIS versionSeriesId property type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string VersionSeriesId = "cmis:versionSeriesId"
Public Const VersionSeriesId As String = "cmis:versionSeriesId"

Field Value

Type: String
See Also

Reference

CmisPropertyIds Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream Class

A static class to make working with CMIS a little easier by putting some of the necessary bits for creatign object service content streams in one place.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.CmisContentStream

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class ContentStream
Public NotInheritable Class ContentStream

The ContentStream type exposes the following members.

Methods
Name | Description
CreateFileStream | This method creates an CMIS ObjectService content stream given a file. The default MIME type that gets assigned is 'image/tiff'.
JustTheFileName | A method that returns just the filename from a full path to a file.
Top
Remarks
Caution note Caution
ContentStream class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream Methods

The ContentStream type exposes the following members.

Methods
Name | Description
CreateFileStream | This method creates an CMIS ObjectService content stream given a file. The default MIME type that gets assigned is 'image/tiff'.
JustTheFileName | A method that returns just the filename from a full path to a file.
Top
See Also

Reference

ContentStream Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.CreateFileStream Method

ContentStreamCreateFileStream Method

This method creates an CMIS ObjectService content stream given a file. The default MIME type that gets assigned is 'image/tiff'.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static cmisContentStreamType CreateFileStream(
    string fileNamePath
)
Public Shared Function CreateFileStream (
    fileNamePath As String
) As cmisContentStreamType

Parameters

fileNamePath
Type: SystemString
The full path name to the file which the CMIS ObjectService content stream is to be created from.

Return Value

Type: cmisContentStreamType
Returns a CMIS Object service content stream.
Remarks
Caution note Caution
ContentStream class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ContentStream Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.JustTheFileName Method

ContentStreamJustTheFileName Method

A method that returns just the filename from a full path to a file.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string JustTheFileName(
    string fileNamePath
)
Public Shared Function JustTheFileName (
    fileNamePath As String
) As String

Parameters

fileNamePath
Type: SystemString
The full path to the file.

Return Value

Type: String
Returns just the filename.extension
Remarks
Caution note Caution
ContentStream class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ContentStream Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType Class

ContentStreamMimeType Class

Just a simple class that returns a string representing a MIME type that CMIS wants for a given document to be turned into a content stream.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.CmisContentStreamMimeType

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class MimeType
Public NotInheritable Class MimeType

The ContentStreamMimeType type exposes the following members.

Fields
Name | Description
Bmp | For an image/bmp MIME type use this.
Doc | For an application/vnd.openxmlformats-officedocument.wordprocessingml.document MIME type use this.
Gif | For an image/gif MIME type use this.
Jpeg | For an image/jpeg MIME type use this.
Pdf | For an application/pdf MIME type use this.
Png | For an image/png MIME type use this.
Ppt | For an application/vnd.ms-powerpoint MIME type use this.
Rtf | For an application/rtf MIME type use this.
Text | For an text/plain MIME type use this.
Tiff | For an image/tiff MIME type use this.
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


MimeType Fields

The ContentStreamMimeType type exposes the following members.

Fields
Name | Description
Bmp | For an image/bmp MIME type use this.
Doc | For an application/vnd.openxmlformats-officedocument.wordprocessingml.document MIME type use this.
Gif | For an image/gif MIME type use this.
Jpeg | For an image/jpeg MIME type use this.
Pdf | For an application/pdf MIME type use this.
Png | For an image/png MIME type use this.
Ppt | For an application/vnd.ms-powerpoint MIME type use this.
Rtf | For an application/rtf MIME type use this.
Text | For an text/plain MIME type use this.
Tiff | For an image/tiff MIME type use this.
Top
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Bmp Field

ContentStreamMimeTypeBmp Field

For an image/bmp MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Bmp = "image/bmp"
Public Const Bmp As String = "image/bmp"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Doc Field

ContentStreamMimeTypeDoc Field

For an application/vnd.openxmlformats-officedocument.wordprocessingml.document MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Doc = "application/vnd.openxmlformats-officedocument.wordprocessingml.document"
Public Const Doc As String = "application/vnd.openxmlformats-officedocument.wordprocessingml.document"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Gif Field

ContentStreamMimeTypeGif Field

For an image/gif MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Gif = "image/gif"
Public Const Gif As String = "image/gif"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Jpeg Field

ContentStreamMimeTypeJpeg Field

For an image/jpeg MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Jpeg = "image/jpeg"
Public Const Jpeg As String = "image/jpeg"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Pdf Field

ContentStreamMimeTypePdf Field

For an application/pdf MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Pdf = "application/pdf"
Public Const Pdf As String = "application/pdf"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Png Field

ContentStreamMimeTypePng Field

For an image/png MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Png = "image/png"
Public Const Png As String = "image/png"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Ppt Field

ContentStreamMimeTypePpt Field

For an application/vnd.ms-powerpoint MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Ppt = "application/vnd.ms-powerpoint"
Public Const Ppt As String = "application/vnd.ms-powerpoint"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Rtf Field

ContentStreamMimeTypeRtf Field

For an application/rtf MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Rtf = "application/rtf"
Public Const Rtf As String = "application/rtf"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Text Field

ContentStreamMimeTypeText Field

For an text/plain MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Text = "text/plain"
Public Const Text As String = "text/plain"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


ContentStream.MimeType.Tiff Field

ContentStreamMimeTypeTiff Field

For an image/tiff MIME type use this.

Namespace: Atalasoft.Imaging.WebControls.Capture.Cmis
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string Tiff = "image/tiff"
Public Const Tiff As String = "image/tiff"

Field Value

Type: String
See Also

Reference

ContentStreamMimeType Class
Atalasoft.Imaging.WebControls.Capture.Cmis Namespace


Atalasoft.Imaging.WebControls.Capture.Kic Namespace

Classes
 | Class | Description
Public class | AdvancedOcrOptions |
Public class | AscentCaptureSetup |
Public class | BarCodeOptions |
Public class | base64Binary |
Public class | BatchClass |
Public class | BatchFieldDefinition |
Public class | BatchType |
Public class | BatchTypeBatchField |
Public class | ColorImageCleanupProfile |
Public class | ContentTypeDescription |
Public class | CustomImportSession | This class inherits the auto generated class ImportSession to add some custom initialization.
Public class | CustomLoosePageImportSession | This class inherites the auto generated class ImportSession to add some custom initialization.
Public class | CustomProperty |
Public class | DocumentClass |
Public class | DocumentClassLink |
Public class | DocumentType |
Public class | ExtensionFieldType |
Public class | FieldType |
Public class | FormIDProfile |
Public class | FormType |
Public class | Function |
Public class | FunctionsReplaces |
Public class | GetContentTypeDescription |
Public class | GetContentTypeDescriptionCompletedEventArgs |
Public class | GetContentTypeDescriptionInput |
Public class | GetContentTypeDescriptionOutput |
Public class | GetContentTypeListCompletedEventArgs |
Public class | GetContentTypeListInput |
Public class | GetContentTypeListOutput |
Public class | GetNewImportIDCompletedEventArgs |
Public class | GetNewImportIDInput |
Public class | GetNewImportIDOutput |
Public class | GetNewImportIDResponse |
Public class | ImageCleanupProfile |
Public class | Import |
Public class | ImportCompletedEventArgs |
Public class | ImportInput |
Public class | ImportOutput |
Public class | ImportPartType |
Public class | ImportPartTypeContent |
Public class | importPortTypeClient |
Public class | ImportResponse |
Public class | ImportService |
Public class | ImportSession |
Public class | IndexFieldDefinition |
Public class | IndexFieldType |
Public class | IndexZone |
Public class | KicController | This class handles the direct communication to the KIC web service proxy class.
Public class | KicLogger | A helper class that writes to the Event log.
Public class | LoosePageBatch | A collection of BatchFieldDefinitions.
Public class | LoosePageBatchType |
Public class | LoosePageImportSession |
Public class | Module |
Public class | NewDataSet |
Public class | OcrOptions |
Public class | OmrOptions |
Public class | PageType |
Public class | PDFProperty |
Public class | Process |
Public class | RecognitionProfile |
Public class | RecognitionProfileIcrOptions |
Public class | ReleaseLink |
Public class | ReleaseScript |
Public class | ReleaseSetup |
Public class | Script |
Public class | SeparationFormIDProfile |
Public class | SeparationProfile |
Public class | SeparationZone |
Public class | SingleDocumentBatchType | This class implements the structure of a single document batch type and is a helper class only
Public class | TrackImport |
Public class | TrackImportCompletedEventArgs |
Public class | TrackImportInput |
Public class | TrackImportOutput |
Public class | TrackImportResponse |
Public class | Value |
Interfaces
 | Interface | Description
Public interface | importPortType |
Public interface | importPortTypeChannel |
Delegates
 | Delegate | Description
Public delegate | GetContentTypeDescriptionCompletedEventHandler |
Public delegate | GetContentTypeListCompletedEventHandler |
Public delegate | GetNewImportIDCompletedEventHandler |
Public delegate | ImportCompletedEventHandler |
Public delegate | TrackImportCompletedEventHandler |
Enumerations
 | Enumeration | Description
Public enumeration | BoolType |
Public enumeration | TrackImportResponseStatus |
Remarks
Caution note Caution
The classes from Atalasoft.Imaging.WebControls.Capture.Kic namespace are not available for .NET 5 and above.


AdvancedOcrOptions Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicAdvancedOcrOptions

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AdvancedOcrOptions
Public Class AdvancedOcrOptions

The AdvancedOcrOptions type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedOcrOptions | Initializes a new instance of the AdvancedOcrOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BlankLineEnabled |
Public field | BoldEnabled |
Public field | CharSeparator |
Public field | CharSet |
Public field | ItalicEnabled |
Public field | LineBreakEnabled |
Public field | MarkLevelSpecific |
Public field | OCRMode |
Public field | PageBreakEnabled |
Public field | SpellCheckFlag |
Public field | UncertainWordsEnabled |
Public field | UnderlineEnabled |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions Constructor

Initializes a new instance of the AdvancedOcrOptions class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedOcrOptions()
Public Sub New
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions Methods

The AdvancedOcrOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions Fields

The AdvancedOcrOptions type exposes the following members.

Fields
 | Name | Description
Public field | BlankLineEnabled |
Public field | BoldEnabled |
Public field | CharSeparator |
Public field | CharSet |
Public field | ItalicEnabled |
Public field | LineBreakEnabled |
Public field | MarkLevelSpecific |
Public field | OCRMode |
Public field | PageBreakEnabled |
Public field | SpellCheckFlag |
Public field | UncertainWordsEnabled |
Public field | UnderlineEnabled |
Top
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.BlankLineEnabled Field

AdvancedOcrOptionsBlankLineEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BlankLineEnabled
Public BlankLineEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.BoldEnabled Field

AdvancedOcrOptionsBoldEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BoldEnabled
Public BoldEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.CharSeparator Field

AdvancedOcrOptionsCharSeparator Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CharSeparator
Public CharSeparator As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.CharSet Field

AdvancedOcrOptionsCharSet Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CharSet
Public CharSet As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.ItalicEnabled Field

AdvancedOcrOptionsItalicEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ItalicEnabled
Public ItalicEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.LineBreakEnabled Field

AdvancedOcrOptionsLineBreakEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LineBreakEnabled
Public LineBreakEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.MarkLevelSpecific Field

AdvancedOcrOptionsMarkLevelSpecific Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MarkLevelSpecific
Public MarkLevelSpecific As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.OCRMode Field

AdvancedOcrOptionsOCRMode Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OCRMode
Public OCRMode As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.PageBreakEnabled Field

AdvancedOcrOptionsPageBreakEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PageBreakEnabled
Public PageBreakEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.SpellCheckFlag Field

AdvancedOcrOptionsSpellCheckFlag Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SpellCheckFlag
Public SpellCheckFlag As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.UncertainWordsEnabled Field

AdvancedOcrOptionsUncertainWordsEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UncertainWordsEnabled
Public UncertainWordsEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AdvancedOcrOptions.UnderlineEnabled Field

AdvancedOcrOptionsUnderlineEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UnderlineEnabled
Public UnderlineEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

AdvancedOcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicAscentCaptureSetup

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AscentCaptureSetup
Public Class AscentCaptureSetup

The AscentCaptureSetup type exposes the following members.

Constructors
 | Name | Description
Public method | AscentCaptureSetup | Initializes a new instance of the AscentCaptureSetup class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BatchClasses |
Public field | ColorImageCleanupProfiles |
Public field | DatabaseVersion |
Public field | DataDefinitionVersion |
Public field | DocumentClasses |
Public field | FieldTypes |
Public field | Functions |
Public field | ImageCleanupProfiles |
Public field | Processes |
Public field | RecognitionProfiles |
Public field | ReleaseScripts |
Public field | Scripts |
Public field | SeparationFormIDProfiles |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup Constructor

Initializes a new instance of the AscentCaptureSetup class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AscentCaptureSetup()
Public Sub New
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup Methods

The AscentCaptureSetup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup Fields

The AscentCaptureSetup type exposes the following members.

Fields
 | Name | Description
Public field | BatchClasses |
Public field | ColorImageCleanupProfiles |
Public field | DatabaseVersion |
Public field | DataDefinitionVersion |
Public field | DocumentClasses |
Public field | FieldTypes |
Public field | Functions |
Public field | ImageCleanupProfiles |
Public field | Processes |
Public field | RecognitionProfiles |
Public field | ReleaseScripts |
Public field | Scripts |
Public field | SeparationFormIDProfiles |
Top
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.BatchClasses Field

AscentCaptureSetupBatchClasses Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchClass[] BatchClasses
Public BatchClasses As BatchClass()

Field Value

Type: BatchClass
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.ColorImageCleanupProfiles Field

AscentCaptureSetupColorImageCleanupProfiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorImageCleanupProfile[] ColorImageCleanupProfiles
Public ColorImageCleanupProfiles As ColorImageCleanupProfile()

Field Value

Type: ColorImageCleanupProfile
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.DatabaseVersion Field

AscentCaptureSetupDatabaseVersion Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DatabaseVersion
Public DatabaseVersion As String

Field Value

Type: String
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.DataDefinitionVersion Field

AscentCaptureSetupDataDefinitionVersion Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DataDefinitionVersion
Public DataDefinitionVersion As String

Field Value

Type: String
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.DocumentClasses Field

AscentCaptureSetupDocumentClasses Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentClass[] DocumentClasses
Public DocumentClasses As DocumentClass()

Field Value

Type: DocumentClass
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.FieldTypes Field

AscentCaptureSetupFieldTypes Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FieldType[] FieldTypes
Public FieldTypes As FieldType()

Field Value

Type: FieldType
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.Functions Field

AscentCaptureSetupFunctions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Function[] Functions
Public Functions As Function()

Field Value

Type: Function
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.ImageCleanupProfiles Field

AscentCaptureSetupImageCleanupProfiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCleanupProfile[] ImageCleanupProfiles
Public ImageCleanupProfiles As ImageCleanupProfile()

Field Value

Type: ImageCleanupProfile
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.Processes Field

AscentCaptureSetupProcesses Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Process[] Processes
Public Processes As Process()

Field Value

Type: Process
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.RecognitionProfiles Field

AscentCaptureSetupRecognitionProfiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RecognitionProfile[] RecognitionProfiles
Public RecognitionProfiles As RecognitionProfile()

Field Value

Type: RecognitionProfile
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.ReleaseScripts Field

AscentCaptureSetupReleaseScripts Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleaseScript[] ReleaseScripts
Public ReleaseScripts As ReleaseScript()

Field Value

Type: ReleaseScript
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.Scripts Field

AscentCaptureSetupScripts Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Script[] Scripts
Public Scripts As Script()

Field Value

Type: Script
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


AscentCaptureSetup.SeparationFormIDProfiles Field

AscentCaptureSetupSeparationFormIDProfiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparationFormIDProfile[] SeparationFormIDProfiles
Public SeparationFormIDProfiles As SeparationFormIDProfile()

Field Value

Type: SeparationFormIDProfile
Remarks
See Also

Reference

AscentCaptureSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BarCodeOptions Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicBarCodeOptions

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BarCodeOptions
Public Class BarCodeOptions

The BarCodeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeOptions | Initializes a new instance of the BarCodeOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | UseEnhancedEngine |
Public field | Width |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BarCodeOptions Constructor

Initializes a new instance of the BarCodeOptions class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeOptions()
Public Sub New
See Also

Reference

BarCodeOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BarCodeOptions Methods

The BarCodeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarCodeOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BarCodeOptions Fields

The BarCodeOptions type exposes the following members.

Fields
 | Name | Description
Public field | UseEnhancedEngine |
Public field | Width |
Top
See Also

Reference

BarCodeOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BarCodeOptions.UseEnhancedEngine Field

BarCodeOptionsUseEnhancedEngine Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UseEnhancedEngine
Public UseEnhancedEngine As String

Field Value

Type: String
Remarks
See Also

Reference

BarCodeOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BarCodeOptions.Width Field

BarCodeOptionsWidth Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Width
Public Width As String

Field Value

Type: String
Remarks
See Also

Reference

BarCodeOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


base64Binary Class

Inheritance Hierarchy
SystemObject
System.Web.Services.ProtocolsSoapHeader
Atalasoft.Imaging.WebControls.Capture.Kicbase64Binary

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class base64Binary : SoapHeader
<SerializableAttribute>
Public Class base64Binary
    Inherits SoapHeader

The base64Binary type exposes the following members.

Constructors
 | Name | Description
Public method | base64Binary | Initializes a new instance of the base64Binary class
Top
Properties
 | Name | Description
Public property | Actor | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
Public property | DidUnderstand | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header. (Inherited from SoapHeader.)
Public property | EncodedMustUnderstand | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1. (Inherited from SoapHeader.)
Public property | EncodedMustUnderstand12 | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2. (Inherited from SoapHeader.)
Public property | EncodedRelay | Gets or sets the relay attribute of the SOAP 1.2 header. (Inherited from SoapHeader.)
Public property | MustUnderstand | Gets or sets a value indicating whether the SoapHeader must be understood. (Inherited from SoapHeader.)
Public property | Relay | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header. (Inherited from SoapHeader.)
Public property | Role | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
Public property | Text |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


base64Binary Constructor

Initializes a new instance of the base64Binary class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public base64Binary()
Public Sub New
See Also

Reference

base64Binary Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


base64Binary Properties

The base64Binary type exposes the following members.

Properties
 | Name | Description
Public property | Actor | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
Public property | DidUnderstand | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header. (Inherited from SoapHeader.)
Public property | EncodedMustUnderstand | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1. (Inherited from SoapHeader.)
Public property | EncodedMustUnderstand12 | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2. (Inherited from SoapHeader.)
Public property | EncodedRelay | Gets or sets the relay attribute of the SOAP 1.2 header. (Inherited from SoapHeader.)
Public property | MustUnderstand | Gets or sets a value indicating whether the SoapHeader must be understood. (Inherited from SoapHeader.)
Public property | Relay | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header. (Inherited from SoapHeader.)
Public property | Role | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
Public property | Text |
Top
See Also

Reference

base64Binary Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


base64Binary.Text Property

base64BinaryText Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] Text { get; set; }
Public Property Text As String()
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

base64Binary Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


base64Binary Methods

The base64Binary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

base64Binary Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicBatchClass

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BatchClass
Public Class BatchClass

The BatchClass type exposes the following members.

Constructors
 | Name | Description
Public method | BatchClass | Initializes a new instance of the BatchClass class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BatchClassID |
Public field | BatchFieldDefinitions |
Public field | BatchFieldScriptID |
Public field | ColorImgProcOptID |
Public field | DefaultFormTypeName |
Public field | DocumentClassLinks |
Public field | EADigits |
Public field | EndorseScriptName |
Public field | ExternalBatchClassID |
Public field | ImageDirectory |
Public field | LastPublished |
Public field | ModifiedDateTime |
Public field | Modules |
Public field | Name |
Public field | QCReEndorseOptions |
Public field | RelEndDateTime |
Public field | RelPriority |
Public field | RelStartDateTime |
Public field | ScanImageCleanupProfileName |
Public field | ScnCapMode |
Public field | SeparationFormIDProfileName |
Public field | SeparationZone |
Public field | SupportsNonImageFiles |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass Constructor

Initializes a new instance of the BatchClass class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchClass()
Public Sub New
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass Methods

The BatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass Fields

The BatchClass type exposes the following members.

Fields
 | Name | Description
Public field | BatchClassID |
Public field | BatchFieldDefinitions |
Public field | BatchFieldScriptID |
Public field | ColorImgProcOptID |
Public field | DefaultFormTypeName |
Public field | DocumentClassLinks |
Public field | EADigits |
Public field | EndorseScriptName |
Public field | ExternalBatchClassID |
Public field | ImageDirectory |
Public field | LastPublished |
Public field | ModifiedDateTime |
Public field | Modules |
Public field | Name |
Public field | QCReEndorseOptions |
Public field | RelEndDateTime |
Public field | RelPriority |
Public field | RelStartDateTime |
Public field | ScanImageCleanupProfileName |
Public field | ScnCapMode |
Public field | SeparationFormIDProfileName |
Public field | SeparationZone |
Public field | SupportsNonImageFiles |
Top
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.BatchClassID Field

BatchClassBatchClassID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchClassID
Public BatchClassID As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.BatchFieldDefinitions Field

BatchClassBatchFieldDefinitions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchFieldDefinition[] BatchFieldDefinitions
Public BatchFieldDefinitions As BatchFieldDefinition()

Field Value

Type: BatchFieldDefinition
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.BatchFieldScriptID Field

BatchClassBatchFieldScriptID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchFieldScriptID
Public BatchFieldScriptID As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.ColorImgProcOptID Field

BatchClassColorImgProcOptID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ColorImgProcOptID
Public ColorImgProcOptID As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.DefaultFormTypeName Field

BatchClassDefaultFormTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultFormTypeName
Public DefaultFormTypeName As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.DocumentClassLinks Field

BatchClassDocumentClassLinks Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentClassLink[] DocumentClassLinks
Public DocumentClassLinks As DocumentClassLink()

Field Value

Type: DocumentClassLink
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.EADigits Field

BatchClassEADigits Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EADigits
Public EADigits As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.EndorseScriptName Field

BatchClassEndorseScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EndorseScriptName
Public EndorseScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.ExternalBatchClassID Field

BatchClassExternalBatchClassID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ExternalBatchClassID
Public ExternalBatchClassID As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.ImageDirectory Field

BatchClassImageDirectory Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageDirectory
Public ImageDirectory As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.LastPublished Field

BatchClassLastPublished Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LastPublished
Public LastPublished As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.ModifiedDateTime Field

BatchClassModifiedDateTime Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ModifiedDateTime
Public ModifiedDateTime As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.Modules Field

BatchClassModules Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Module[] Modules
Public Modules As Module()

Field Value

Type: Module
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.Name Field

BatchClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.QCReEndorseOptions Field

BatchClassQCReEndorseOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string QCReEndorseOptions
Public QCReEndorseOptions As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.RelEndDateTime Field

BatchClassRelEndDateTime Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RelEndDateTime
Public RelEndDateTime As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.RelPriority Field

BatchClassRelPriority Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RelPriority
Public RelPriority As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.RelStartDateTime Field

BatchClassRelStartDateTime Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RelStartDateTime
Public RelStartDateTime As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.ScanImageCleanupProfileName Field

BatchClassScanImageCleanupProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScanImageCleanupProfileName
Public ScanImageCleanupProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.ScnCapMode Field

BatchClassScnCapMode Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScnCapMode
Public ScnCapMode As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.SeparationFormIDProfileName Field

BatchClassSeparationFormIDProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SeparationFormIDProfileName
Public SeparationFormIDProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.SeparationZone Field

BatchClassSeparationZone Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparationZone[] SeparationZone
Public SeparationZone As SeparationZone()

Field Value

Type: SeparationZone
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchClass.SupportsNonImageFiles Field

BatchClassSupportsNonImageFiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SupportsNonImageFiles
Public SupportsNonImageFiles As String

Field Value

Type: String
Remarks
See Also

Reference

BatchClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicBatchFieldDefinition

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BatchFieldDefinition
Public Class BatchFieldDefinition

The BatchFieldDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | BatchFieldDefinition | Initializes a new instance of the BatchFieldDefinition class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | DefaultValMacro |
Public field | FieldTypeName |
Public field | Hidden |
Public field | Name |
Public field | Required |
Public field | Value |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition Constructor

Initializes a new instance of the BatchFieldDefinition class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchFieldDefinition()
Public Sub New
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition Methods

The BatchFieldDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition Fields

The BatchFieldDefinition type exposes the following members.

Fields
 | Name | Description
Public field | DefaultValMacro |
Public field | FieldTypeName |
Public field | Hidden |
Public field | Name |
Public field | Required |
Public field | Value |
Top
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition.DefaultValMacro Field

BatchFieldDefinitionDefaultValMacro Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultValMacro
Public DefaultValMacro As String

Field Value

Type: String
Remarks
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition.FieldTypeName Field

BatchFieldDefinitionFieldTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldTypeName
Public FieldTypeName As String

Field Value

Type: String
Remarks
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition.Hidden Field

BatchFieldDefinitionHidden Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Hidden
Public Hidden As String

Field Value

Type: String
Remarks
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition.Name Field

BatchFieldDefinitionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition.Required Field

BatchFieldDefinitionRequired Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Required
Public Required As String

Field Value

Type: String
Remarks
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchFieldDefinition.Value Field

BatchFieldDefinitionValue Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value
Public Value As String

Field Value

Type: String
Remarks
See Also

Reference

BatchFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicBatchType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BatchType
Public Class BatchType

The BatchType type exposes the following members.

Constructors
 | Name | Description
Public method | BatchType | Initializes a new instance of the BatchType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BatchClassName |
Public field | BatchFields |
Public field | Documents |
Public field | EnableAutomaticSeparationAndFormID |
Public field | Imported |
Public field | Name |
Public field | Priority |
Public field | RelativeImageFilePath |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType Constructor

Initializes a new instance of the BatchType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchType()
Public Sub New
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType Methods

The BatchType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType Fields

The BatchType type exposes the following members.

Fields
 | Name | Description
Public field | BatchClassName |
Public field | BatchFields |
Public field | Documents |
Public field | EnableAutomaticSeparationAndFormID |
Public field | Imported |
Public field | Name |
Public field | Priority |
Public field | RelativeImageFilePath |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.BatchClassName Field

BatchTypeBatchClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchClassName
Public BatchClassName As String

Field Value

Type: String
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.BatchFields Field

BatchTypeBatchFields Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchTypeBatchField[] BatchFields
Public BatchFields As BatchTypeBatchField()

Field Value

Type: BatchTypeBatchField
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.Documents Field

BatchTypeDocuments Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentType[] Documents
Public Documents As DocumentType()

Field Value

Type: DocumentType
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.EnableAutomaticSeparationAndFormID Field

BatchTypeEnableAutomaticSeparationAndFormID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BoolType EnableAutomaticSeparationAndFormID
Public EnableAutomaticSeparationAndFormID As BoolType

Field Value

Type: BoolType
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.Imported Field

BatchTypeImported Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BoolType Imported
Public Imported As BoolType

Field Value

Type: BoolType
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.Name Field

BatchTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.Priority Field

BatchTypePriority Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sbyte Priority
Public Priority As SByte

Field Value

Type: SByte
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.RelativeImageFilePath Field

BatchTypeRelativeImageFilePath Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RelativeImageFilePath
Public RelativeImageFilePath As String

Field Value

Type: String
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.XmlAnyAttribute Field

BatchTypeXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchType.XmlAnyElements Field

BatchTypeXmlAnyElements Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] XmlAnyElements
Public XmlAnyElements As Object()

Field Value

Type: Object
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicBatchTypeBatchField

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BatchTypeBatchField
Public Class BatchTypeBatchField

The BatchTypeBatchField type exposes the following members.

Constructors
 | Name | Description
Public method | BatchTypeBatchField | Initializes a new instance of the BatchTypeBatchField class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Public field | XmlAnyAttribute |
Top
Remarks
Caution note Caution
BatchTypeBatchField class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField Constructor

Initializes a new instance of the BatchTypeBatchField class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchTypeBatchField()
Public Sub New
See Also

Reference

BatchTypeBatchField Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField Methods

The BatchTypeBatchField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BatchTypeBatchField Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField Fields

The BatchTypeBatchField type exposes the following members.

Fields
 | Name | Description
Public field | Name |
Public field | Value |
Public field | XmlAnyAttribute |
Top
See Also

Reference

BatchTypeBatchField Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField.Name Field

BatchTypeBatchFieldName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
Caution note Caution
BatchTypeBatchField class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchTypeBatchField Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField.Value Field

BatchTypeBatchFieldValue Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value
Public Value As String

Field Value

Type: String
Remarks
Caution note Caution
BatchTypeBatchField class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

BatchTypeBatchField Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BatchTypeBatchField.XmlAnyAttribute Field

BatchTypeBatchFieldXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
See Also

Reference

BatchTypeBatchField Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


BoolType Enumeration

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BoolType
Public Enumeration BoolType
Members
Member name | Description
Item0 |
Item1 |
Remarks
Caution note Caution
BoolType enum is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicColorImageCleanupProfile

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ColorImageCleanupProfile
Public Class ColorImageCleanupProfile

The ColorImageCleanupProfile type exposes the following members.

Constructors
 | Name | Description
Public method | ColorImageCleanupProfile | Initializes a new instance of the ColorImageCleanupProfile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | DefaultFor |
Public field | KofaxID |
Public field | Name |
Public field | ReadOnly |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile Constructor

Initializes a new instance of the ColorImageCleanupProfile class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorImageCleanupProfile()
Public Sub New
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile Methods

The ColorImageCleanupProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile Fields

The ColorImageCleanupProfile type exposes the following members.

Fields
 | Name | Description
Public field | DefaultFor |
Public field | KofaxID |
Public field | Name |
Public field | ReadOnly |
Top
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile.DefaultFor Field

ColorImageCleanupProfileDefaultFor Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultFor
Public DefaultFor As String

Field Value

Type: String
Remarks
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile.KofaxID Field

ColorImageCleanupProfileKofaxID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KofaxID
Public KofaxID As String

Field Value

Type: String
Remarks
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile.Name Field

ColorImageCleanupProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ColorImageCleanupProfile.ReadOnly Field

ColorImageCleanupProfileReadOnly Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReadOnly
Public ReadOnly As String

Field Value

Type: String
Remarks
See Also

Reference

ColorImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ContentTypeDescription Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicContentTypeDescription

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ContentTypeDescription
<SerializableAttribute>
Public Class ContentTypeDescription

The ContentTypeDescription type exposes the following members.

Constructors
 | Name | Description
Public method | ContentTypeDescription | Initializes a new instance of the ContentTypeDescription class
Top
Properties
 | Name | Description
Public property | Content |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ContentTypeDescription Constructor

Initializes a new instance of the ContentTypeDescription class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContentTypeDescription()
Public Sub New
See Also

Reference

ContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ContentTypeDescription Properties

The ContentTypeDescription type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Top
See Also

Reference

ContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ContentTypeDescription.Content Property

ContentTypeDescriptionContent Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Content { get; set; }
Public Property Content As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ContentTypeDescription Methods

The ContentTypeDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession Class

This class inherits the auto generated class ImportSession to add some custom initialization.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportSession
Atalasoft.Imaging.WebControls.Capture.KicCustomImportSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CustomImportSession : ImportSession
Public Class CustomImportSession
    Inherits ImportSession

The CustomImportSession type exposes the following members.

Constructors
 | Name | Description
Public method | CustomImportSession | Default constructor We need to initialize all required members
Top
Properties
 | Name | Description
Public property | BatchID | The batch id.
Public property | DocumentClassName | The document class name.
Top
Methods
 | Name | Description
Public method | AddPage | add a page to the import session document.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBatchFields | Sets the import sessions BatchFieldDefinition[].
Public method | SetBatchFieldValue | Sets a specified batch field name to the specified batch field value.
Public method | SetDocumentIndexFields | Set index fields of the document
Public method | SetFieldValue | Set an index field value
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Batches | (Inherited from ImportSession.)
Public field | DeleteBatchOnError | (Inherited from ImportSession.)
Public field | IntegratedAuthentication | (Inherited from ImportSession.)
Public field | Password | (Inherited from ImportSession.)
Public field | UserID | (Inherited from ImportSession.)
Public field | XmlAnyAttribute | (Inherited from ImportSession.)
Public field | XmlAnyElements | (Inherited from ImportSession.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession Constructor

Default constructor We need to initialize all required members

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomImportSession()
Public Sub New
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession Properties

The CustomImportSession type exposes the following members.

Properties
 | Name | Description
Public property | BatchID | The batch id.
Public property | DocumentClassName | The document class name.
Top
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.BatchID Property

CustomImportSessionBatchID Property

The batch id.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchID { get; set; }
Public Property BatchID As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.DocumentClassName Property

CustomImportSessionDocumentClassName Property

The document class name.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentClassName { get; set; }
Public Property DocumentClassName As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession Methods

The CustomImportSession type exposes the following members.

Methods
 | Name | Description
Public method | AddPage | add a page to the import session document.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBatchFields | Sets the import sessions BatchFieldDefinition[].
Public method | SetBatchFieldValue | Sets a specified batch field name to the specified batch field value.
Public method | SetDocumentIndexFields | Set index fields of the document
Public method | SetFieldValue | Set an index field value
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.AddPage Method

CustomImportSessionAddPage Method

add a page to the import session document.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddPage(
    string strPath
)
Public Sub AddPage (
    strPath As String
)

Parameters

strPath
Type: SystemString
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.SetBatchFields Method

CustomImportSessionSetBatchFields Method

Sets the import sessions BatchFieldDefinition[].

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetBatchFields(
    BatchFieldDefinition[] batchFields
)
Public Sub SetBatchFields (
    batchFields As BatchFieldDefinition()
)

Parameters

batchFields
Type: Atalasoft.Imaging.WebControls.Capture.KicBatchFieldDefinition
The batch field definitions to apply to the import session.
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.SetBatchFieldValue Method

CustomImportSessionSetBatchFieldValue Method

Sets a specified batch field name to the specified batch field value.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetBatchFieldValue(
    string batchFieldName,
    string batchFieldValue
)
Public Sub SetBatchFieldValue (
    batchFieldName As String,
    batchFieldValue As String
)

Parameters

batchFieldName
Type: SystemString
The name of the batch field to set the value to.
batchFieldValue
Type: SystemString
The value which the specified batch field name should be set to.
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.SetDocumentIndexFields Method

CustomImportSessionSetDocumentIndexFields Method

Set index fields of the document

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetDocumentIndexFields(
    IndexFieldDefinition[] IndexFieldDefinitions
)
Public Sub SetDocumentIndexFields (
    IndexFieldDefinitions As IndexFieldDefinition()
)

Parameters

IndexFieldDefinitions
Type: Atalasoft.Imaging.WebControls.Capture.KicIndexFieldDefinition
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession.SetFieldValue Method

CustomImportSessionSetFieldValue Method

Set an index field value

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetFieldValue(
    string strFieldName,
    string strFieldValue
)
Public Sub SetFieldValue (
    strFieldName As String,
    strFieldValue As String
)

Parameters

strFieldName
Type: SystemString
strFieldValue
Type: SystemString
Remarks
Caution note Caution
CustomImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomImportSession Fields

The CustomImportSession type exposes the following members.

Fields
 | Name | Description
Public field | Batches | (Inherited from ImportSession.)
Public field | DeleteBatchOnError | (Inherited from ImportSession.)
Public field | IntegratedAuthentication | (Inherited from ImportSession.)
Public field | Password | (Inherited from ImportSession.)
Public field | UserID | (Inherited from ImportSession.)
Public field | XmlAnyAttribute | (Inherited from ImportSession.)
Public field | XmlAnyElements | (Inherited from ImportSession.)
Top
See Also

Reference

CustomImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession Class

This class inherites the auto generated class ImportSession to add some custom initialization.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicLoosePageImportSession
Atalasoft.Imaging.WebControls.Capture.KicCustomLoosePageImportSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CustomLoosePageImportSession : LoosePageImportSession
Public Class CustomLoosePageImportSession
    Inherits LoosePageImportSession

The CustomLoosePageImportSession type exposes the following members.

Constructors
 | Name | Description
Public method | CustomLoosePageImportSession | Default constructor We need to initialize all required members
Top
Properties
 | Name | Description
Public property | BatchID | The Batch Id.
Top
Methods
 | Name | Description
Public method | AddLoosePage | add a page to the import session batch.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBatchFields | Sets the import sessions BatchFieldDefinition[].
Public method | SetBatchFieldValue | Sets a specified batch field name to the specified batch field value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Batches | (Inherited from LoosePageImportSession.)
Public field | Password | (Inherited from LoosePageImportSession.)
Public field | UserID | (Inherited from LoosePageImportSession.)
Public field | XmlAnyAttribute | (Inherited from LoosePageImportSession.)
Public field | XmlAnyElements | (Inherited from LoosePageImportSession.)
Top
Remarks
Caution note Caution
CustomLoosePageImportSession class is available with .NET Framework 3.5 and 4.5.2.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession Constructor

Default constructor We need to initialize all required members

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomLoosePageImportSession()
Public Sub New
Remarks
Caution note Caution
CustomLoosePageImportSession class is available with .NET Framework 3.5 and 4.5.2.
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession Properties

The CustomLoosePageImportSession type exposes the following members.

Properties
 | Name | Description
Public property | BatchID | The Batch Id.
Top
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession.BatchID Property

CustomLoosePageImportSessionBatchID Property

The Batch Id.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchID { get; set; }
Public Property BatchID As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
CustomLoosePageImportSession class is available with .NET Framework 3.5 and 4.5.2.
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession Methods

The CustomLoosePageImportSession type exposes the following members.

Methods
 | Name | Description
Public method | AddLoosePage | add a page to the import session batch.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBatchFields | Sets the import sessions BatchFieldDefinition[].
Public method | SetBatchFieldValue | Sets a specified batch field name to the specified batch field value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession.AddLoosePage Method

CustomLoosePageImportSessionAddLoosePage Method

add a page to the import session batch.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddLoosePage(
    string strPath
)
Public Sub AddLoosePage (
    strPath As String
)

Parameters

strPath
Type: SystemString
Remarks
Caution note Caution
CustomLoosePageImportSession class is available with .NET Framework 3.5 and 4.5.2.
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession.SetBatchFields Method

CustomLoosePageImportSessionSetBatchFields Method

Sets the import sessions BatchFieldDefinition[].

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetBatchFields(
    BatchFieldDefinition[] batchFields
)
Public Sub SetBatchFields (
    batchFields As BatchFieldDefinition()
)

Parameters

batchFields
Type: Atalasoft.Imaging.WebControls.Capture.KicBatchFieldDefinition
The batch field definitions to apply to the import session.
Remarks
Caution note Caution
CustomLoosePageImportSession class is available with .NET Framework 3.5 and 4.5.2.
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession.SetBatchFieldValue Method

CustomLoosePageImportSessionSetBatchFieldValue Method

Sets a specified batch field name to the specified batch field value.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetBatchFieldValue(
    string batchFieldName,
    string batchFieldValue
)
Public Sub SetBatchFieldValue (
    batchFieldName As String,
    batchFieldValue As String
)

Parameters

batchFieldName
Type: SystemString
The name of the batch field to set the value to.
batchFieldValue
Type: SystemString
The value which the specified batch field name should be set to.
Remarks
Caution note Caution
CustomLoosePageImportSession class is available with .NET Framework 3.5 and 4.5.2.
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomLoosePageImportSession Fields

The CustomLoosePageImportSession type exposes the following members.

Fields
 | Name | Description
Public field | Batches | (Inherited from LoosePageImportSession.)
Public field | Password | (Inherited from LoosePageImportSession.)
Public field | UserID | (Inherited from LoosePageImportSession.)
Public field | XmlAnyAttribute | (Inherited from LoosePageImportSession.)
Public field | XmlAnyElements | (Inherited from LoosePageImportSession.)
Top
See Also

Reference

CustomLoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomProperty Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicCustomProperty

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CustomProperty
Public Class CustomProperty

The CustomProperty type exposes the following members.

Constructors
 | Name | Description
Public method | CustomProperty | Initializes a new instance of the CustomProperty class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomProperty Constructor

Initializes a new instance of the CustomProperty class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomProperty()
Public Sub New
See Also

Reference

CustomProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomProperty Methods

The CustomProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomProperty Fields

The CustomProperty type exposes the following members.

Fields
 | Name | Description
Public field | Name |
Public field | Value |
Top
See Also

Reference

CustomProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomProperty.Name Field

CustomPropertyName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

CustomProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


CustomProperty.Value Field

CustomPropertyValue Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value
Public Value As String

Field Value

Type: String
Remarks
See Also

Reference

CustomProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicDocumentClass

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentClass
Public Class DocumentClass

The DocumentClass type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentClass | Initializes a new instance of the DocumentClass class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Description |
Public field | FormTypes |
Public field | IndexFieldDefinitions |
Public field | KofaxPDFRecognitionProfileName |
Public field | Name |
Public field | OcrFullTextRecognitionProfileName |
Public field | PDFDictionary |
Public field | PDFPropertyEnabled |
Public field | ScriptName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass Constructor

Initializes a new instance of the DocumentClass class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentClass()
Public Sub New
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass Methods

The DocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass Fields

The DocumentClass type exposes the following members.

Fields
 | Name | Description
Public field | Description |
Public field | FormTypes |
Public field | IndexFieldDefinitions |
Public field | KofaxPDFRecognitionProfileName |
Public field | Name |
Public field | OcrFullTextRecognitionProfileName |
Public field | PDFDictionary |
Public field | PDFPropertyEnabled |
Public field | ScriptName |
Top
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.Description Field

DocumentClassDescription Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description
Public Description As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.FormTypes Field

DocumentClassFormTypes Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormType[] FormTypes
Public FormTypes As FormType()

Field Value

Type: FormType
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.IndexFieldDefinitions Field

DocumentClassIndexFieldDefinitions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexFieldDefinition[] IndexFieldDefinitions
Public IndexFieldDefinitions As IndexFieldDefinition()

Field Value

Type: IndexFieldDefinition
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.KofaxPDFRecognitionProfileName Field

DocumentClassKofaxPDFRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KofaxPDFRecognitionProfileName
Public KofaxPDFRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.Name Field

DocumentClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.OcrFullTextRecognitionProfileName Field

DocumentClassOcrFullTextRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OcrFullTextRecognitionProfileName
Public OcrFullTextRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.PDFDictionary Field

DocumentClassPDFDictionary Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PDFDictionary
Public PDFDictionary As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.PDFPropertyEnabled Field

DocumentClassPDFPropertyEnabled Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PDFPropertyEnabled
Public PDFPropertyEnabled As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClass.ScriptName Field

DocumentClassScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScriptName
Public ScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClass Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicDocumentClassLink

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentClassLink
Public Class DocumentClassLink

The DocumentClassLink type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentClassLink | Initializes a new instance of the DocumentClassLink class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | DocumentClassName |
Public field | PDFProperties |
Public field | ReleaseSetups |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink Constructor

Initializes a new instance of the DocumentClassLink class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentClassLink()
Public Sub New
See Also

Reference

DocumentClassLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink Methods

The DocumentClassLink type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentClassLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink Fields

The DocumentClassLink type exposes the following members.

Fields
 | Name | Description
Public field | DocumentClassName |
Public field | PDFProperties |
Public field | ReleaseSetups |
Top
See Also

Reference

DocumentClassLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink.DocumentClassName Field

DocumentClassLinkDocumentClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentClassName
Public DocumentClassName As String

Field Value

Type: String
Remarks
See Also

Reference

DocumentClassLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink.PDFProperties Field

DocumentClassLinkPDFProperties Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PDFProperty[] PDFProperties
Public PDFProperties As PDFProperty()

Field Value

Type: PDFProperty
Remarks
See Also

Reference

DocumentClassLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentClassLink.ReleaseSetups Field

DocumentClassLinkReleaseSetups Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleaseSetup[] ReleaseSetups
Public ReleaseSetups As ReleaseSetup()

Field Value

Type: ReleaseSetup
Remarks
See Also

Reference

DocumentClassLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicDocumentType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentType
Public Class DocumentType

The DocumentType type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentType | Initializes a new instance of the DocumentType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | FormTypeName |
Public field | IndexFields |
Public field | Items |
Public field | Pages |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
Remarks
Caution note Caution
DocumentType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType Constructor

Initializes a new instance of the DocumentType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentType()
Public Sub New
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType Methods

The DocumentType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType Fields

The DocumentType type exposes the following members.

Fields
 | Name | Description
Public field | FormTypeName |
Public field | IndexFields |
Public field | Items |
Public field | Pages |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType.FormTypeName Field

DocumentTypeFormTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FormTypeName
Public FormTypeName As String

Field Value

Type: String
Remarks
Caution note Caution
DocumentType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType.IndexFields Field

DocumentTypeIndexFields Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexFieldType[] IndexFields
Public IndexFields As IndexFieldType()

Field Value

Type: IndexFieldType
Remarks
Caution note Caution
DocumentType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType.Items Field

DocumentTypeItems Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] Items
Public Items As String()

Field Value

Type: String
Remarks
Caution note Caution
DocumentType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType.Pages Field

DocumentTypePages Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageType[] Pages
Public Pages As PageType()

Field Value

Type: PageType
Remarks
Caution note Caution
DocumentType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType.XmlAnyAttribute Field

DocumentTypeXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


DocumentType.XmlAnyElements Field

DocumentTypeXmlAnyElements Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] XmlAnyElements
Public XmlAnyElements As Object()

Field Value

Type: Object
See Also

Reference

DocumentType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ExtensionFieldType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicExtensionFieldType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ExtensionFieldType
<SerializableAttribute>
Public Class ExtensionFieldType

The ExtensionFieldType type exposes the following members.

Constructors
 | Name | Description
Public method | ExtensionFieldType | Initializes a new instance of the ExtensionFieldType class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ExtensionFieldType Constructor

Initializes a new instance of the ExtensionFieldType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExtensionFieldType()
Public Sub New
See Also

Reference

ExtensionFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ExtensionFieldType Properties

The ExtensionFieldType type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

ExtensionFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ExtensionFieldType.Name Property

ExtensionFieldTypeName Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ExtensionFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ExtensionFieldType.Value Property

ExtensionFieldTypeValue Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ExtensionFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ExtensionFieldType Methods

The ExtensionFieldType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtensionFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicFieldType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FieldType
Public Class FieldType

The FieldType type exposes the following members.

Constructors
 | Name | Description
Public method | FieldType | Initializes a new instance of the FieldType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | EnableValues |
Public field | Name |
Public field | Scale |
Public field | ScriptName |
Public field | SqlType |
Public field | Values |
Public field | Width |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType Constructor

Initializes a new instance of the FieldType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FieldType()
Public Sub New
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType Methods

The FieldType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType Fields

The FieldType type exposes the following members.

Fields
 | Name | Description
Public field | EnableValues |
Public field | Name |
Public field | Scale |
Public field | ScriptName |
Public field | SqlType |
Public field | Values |
Public field | Width |
Top
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.EnableValues Field

FieldTypeEnableValues Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EnableValues
Public EnableValues As String

Field Value

Type: String
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.Name Field

FieldTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.Scale Field

FieldTypeScale Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Scale
Public Scale As String

Field Value

Type: String
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.ScriptName Field

FieldTypeScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScriptName
Public ScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.SqlType Field

FieldTypeSqlType Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SqlType
Public SqlType As String

Field Value

Type: String
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.Values Field

FieldTypeValues Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Value[] Values
Public Values As Value()

Field Value

Type: Value
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FieldType.Width Field

FieldTypeWidth Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Width
Public Width As String

Field Value

Type: String
Remarks
See Also

Reference

FieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicFormIDProfile

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FormIDProfile
Public Class FormIDProfile

The FormIDProfile type exposes the following members.

Constructors
 | Name | Description
Public method | FormIDProfile | Initializes a new instance of the FormIDProfile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Confidence |
Public field | Difference |
Public field | Method |
Public field | PageRecognitionProfileName |
Public field | ZoneRecognitionProfileName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile Constructor

Initializes a new instance of the FormIDProfile class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormIDProfile()
Public Sub New
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile Methods

The FormIDProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile Fields

The FormIDProfile type exposes the following members.

Fields
 | Name | Description
Public field | Confidence |
Public field | Difference |
Public field | Method |
Public field | PageRecognitionProfileName |
Public field | ZoneRecognitionProfileName |
Top
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile.Confidence Field

FormIDProfileConfidence Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Confidence
Public Confidence As String

Field Value

Type: String
Remarks
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile.Difference Field

FormIDProfileDifference Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Difference
Public Difference As String

Field Value

Type: String
Remarks
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile.Method Field

FormIDProfileMethod Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Method
Public Method As String

Field Value

Type: String
Remarks
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile.PageRecognitionProfileName Field

FormIDProfilePageRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PageRecognitionProfileName
Public PageRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormIDProfile.ZoneRecognitionProfileName Field

FormIDProfileZoneRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ZoneRecognitionProfileName
Public ZoneRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

FormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicFormType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FormType
Public Class FormType

The FormType type exposes the following members.

Constructors
 | Name | Description
Public method | FormType | Initializes a new instance of the FormType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BarCodeRecognitionProfileName |
Public field | FormsProcessingImageCleanupProfileName |
Public field | IndexZoneConfidence |
Public field | IndexZones |
Public field | Name |
Public field | RegistrationConfidence |
Public field | SampleImageDirectoryNumber |
Public field | SamplePageCount |
Public field | SamplePageHDPI |
Public field | SamplePagePublishDirectoryNumber |
Public field | SamplePageVDPI |
Public field | ScriptName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType Constructor

Initializes a new instance of the FormType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormType()
Public Sub New
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType Methods

The FormType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType Fields

The FormType type exposes the following members.

Fields
 | Name | Description
Public field | BarCodeRecognitionProfileName |
Public field | FormsProcessingImageCleanupProfileName |
Public field | IndexZoneConfidence |
Public field | IndexZones |
Public field | Name |
Public field | RegistrationConfidence |
Public field | SampleImageDirectoryNumber |
Public field | SamplePageCount |
Public field | SamplePageHDPI |
Public field | SamplePagePublishDirectoryNumber |
Public field | SamplePageVDPI |
Public field | ScriptName |
Top
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.BarCodeRecognitionProfileName Field

FormTypeBarCodeRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BarCodeRecognitionProfileName
Public BarCodeRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.FormsProcessingImageCleanupProfileName Field

FormTypeFormsProcessingImageCleanupProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FormsProcessingImageCleanupProfileName
Public FormsProcessingImageCleanupProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.IndexZoneConfidence Field

FormTypeIndexZoneConfidence Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IndexZoneConfidence
Public IndexZoneConfidence As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.IndexZones Field

FormTypeIndexZones Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexZone[] IndexZones
Public IndexZones As IndexZone()

Field Value

Type: IndexZone
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.Name Field

FormTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.RegistrationConfidence Field

FormTypeRegistrationConfidence Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RegistrationConfidence
Public RegistrationConfidence As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.SampleImageDirectoryNumber Field

FormTypeSampleImageDirectoryNumber Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SampleImageDirectoryNumber
Public SampleImageDirectoryNumber As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.SamplePageCount Field

FormTypeSamplePageCount Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SamplePageCount
Public SamplePageCount As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.SamplePageHDPI Field

FormTypeSamplePageHDPI Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SamplePageHDPI
Public SamplePageHDPI As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.SamplePagePublishDirectoryNumber Field

FormTypeSamplePagePublishDirectoryNumber Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SamplePagePublishDirectoryNumber
Public SamplePagePublishDirectoryNumber As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.SamplePageVDPI Field

FormTypeSamplePageVDPI Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SamplePageVDPI
Public SamplePageVDPI As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FormType.ScriptName Field

FormTypeScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScriptName
Public ScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

FormType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicFunction

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Function
Public Class Function

The Function type exposes the following members.

Constructors
 | Name | Description
Public method | Function | Initializes a new instance of the Function class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | FunctionID |
Public field | Name |
Public field | Order |
Public field | Workflow |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function Constructor

Initializes a new instance of the Function class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Function()
Public Sub New
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function Methods

The Function type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function Fields

The Function type exposes the following members.

Fields
 | Name | Description
Public field | FunctionID |
Public field | Name |
Public field | Order |
Public field | Workflow |
Top
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function.FunctionID Field

FunctionFunctionID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FunctionID
Public FunctionID As String

Field Value

Type: String
Remarks
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function.Name Field

FunctionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function.Order Field

FunctionOrder Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Order
Public Order As String

Field Value

Type: String
Remarks
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Function.Workflow Field

FunctionWorkflow Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Workflow
Public Workflow As String

Field Value

Type: String
Remarks
See Also

Reference

Function Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FunctionsReplaces Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicFunctionsReplaces

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FunctionsReplaces
Public Class FunctionsReplaces

The FunctionsReplaces type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionsReplaces | Initializes a new instance of the FunctionsReplaces class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | FunctionName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FunctionsReplaces Constructor

Initializes a new instance of the FunctionsReplaces class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FunctionsReplaces()
Public Sub New
See Also

Reference

FunctionsReplaces Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FunctionsReplaces Methods

The FunctionsReplaces type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FunctionsReplaces Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FunctionsReplaces Fields

The FunctionsReplaces type exposes the following members.

Fields
 | Name | Description
Public field | FunctionName |
Top
See Also

Reference

FunctionsReplaces Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


FunctionsReplaces.FunctionName Field

FunctionsReplacesFunctionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FunctionName
Public FunctionName As String

Field Value

Type: String
Remarks
See Also

Reference

FunctionsReplaces Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescription Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescription

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GetContentTypeDescription
<SerializableAttribute>
Public Class GetContentTypeDescription

The GetContentTypeDescription type exposes the following members.

Constructors
 | Name | Description
Public method | GetContentTypeDescription | Initializes a new instance of the GetContentTypeDescription class
Top
Properties
 | Name | Description
Public property | ContentTypeName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescription Constructor

Initializes a new instance of the GetContentTypeDescription class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeDescription()
Public Sub New
See Also

Reference

GetContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescription Properties

The GetContentTypeDescription type exposes the following members.

Properties
 | Name | Description
Public property | ContentTypeName |
Top
See Also

Reference

GetContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescription.ContentTypeName Property

GetContentTypeDescriptionContentTypeName Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ContentTypeName { get; set; }
Public Property ContentTypeName As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

GetContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescription Methods

The GetContentTypeDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeDescription Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionCompletedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescriptionCompletedEventArgs

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetContentTypeDescriptionCompletedEventArgs : AsyncCompletedEventArgs
Public Class GetContentTypeDescriptionCompletedEventArgs
    Inherits AsyncCompletedEventArgs

The GetContentTypeDescriptionCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionCompletedEventArgs Properties

The GetContentTypeDescriptionCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
See Also

Reference

GetContentTypeDescriptionCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionCompletedEventArgs.Result Property

GetContentTypeDescriptionCompletedEventArgsResult Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContentTypeDescription Result { get; }
Public ReadOnly Property Result As ContentTypeDescription
    Get

Property Value

Type: ContentTypeDescription
Remarks
See Also

Reference

GetContentTypeDescriptionCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionCompletedEventArgs Methods

The GetContentTypeDescriptionCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeDescriptionCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionCompletedEventHandler Delegate

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void GetContentTypeDescriptionCompletedEventHandler(
    Object sender,
    GetContentTypeDescriptionCompletedEventArgs e
)
Public Delegate Sub GetContentTypeDescriptionCompletedEventHandler (
    sender As Object,
    e As GetContentTypeDescriptionCompletedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescriptionCompletedEventArgs
Remarks
Caution note Caution
This delegate is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescriptionInput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetContentTypeDescriptionInput
Public Class GetContentTypeDescriptionInput

The GetContentTypeDescriptionInput type exposes the following members.

Constructors
 | Name | Description
Public method | GetContentTypeDescriptionInput | Initializes a new instance of the GetContentTypeDescriptionInput class
Public method | GetContentTypeDescriptionInput(Byte, GetContentTypeDescription) | Initializes a new instance of the GetContentTypeDescriptionInput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | credentials |
Public field | GetContentTypeDescription |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput Constructor

Overload List
 | Name | Description
Public method | GetContentTypeDescriptionInput | Initializes a new instance of the GetContentTypeDescriptionInput class
Public method | GetContentTypeDescriptionInput(Byte, GetContentTypeDescription) | Initializes a new instance of the GetContentTypeDescriptionInput class
Top
See Also

Reference

GetContentTypeDescriptionInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput Constructor

Initializes a new instance of the GetContentTypeDescriptionInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeDescriptionInput()
Public Sub New
See Also

Reference

GetContentTypeDescriptionInput Class
GetContentTypeDescriptionInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput Constructor (Byte[], GetContentTypeDescription)

GetContentTypeDescriptionInput Constructor (Byte, GetContentTypeDescription)

Initializes a new instance of the GetContentTypeDescriptionInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeDescriptionInput(
    byte[] credentials,
    GetContentTypeDescription GetContentTypeDescription
)
Public Sub New (
    credentials As Byte(),
    GetContentTypeDescription As GetContentTypeDescription
)

Parameters

credentials
Type: SystemByte
GetContentTypeDescription
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescription
See Also

Reference

GetContentTypeDescriptionInput Class
GetContentTypeDescriptionInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput Methods

The GetContentTypeDescriptionInput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeDescriptionInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput Fields

The GetContentTypeDescriptionInput type exposes the following members.

Fields
 | Name | Description
Public field | credentials |
Public field | GetContentTypeDescription |
Top
See Also

Reference

GetContentTypeDescriptionInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput.credentials Field

GetContentTypeDescriptionInputcredentials Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] credentials
Public credentials As Byte()

Field Value

Type: Byte
See Also

Reference

GetContentTypeDescriptionInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionInput.GetContentTypeDescription Field

GetContentTypeDescriptionInputGetContentTypeDescription Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeDescription GetContentTypeDescription
Public GetContentTypeDescription As GetContentTypeDescription

Field Value

Type: GetContentTypeDescription
See Also

Reference

GetContentTypeDescriptionInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescriptionOutput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetContentTypeDescriptionOutput
Public Class GetContentTypeDescriptionOutput

The GetContentTypeDescriptionOutput type exposes the following members.

Constructors
 | Name | Description
Public method | GetContentTypeDescriptionOutput | Initializes a new instance of the GetContentTypeDescriptionOutput class
Public method | GetContentTypeDescriptionOutput(ContentTypeDescription) | Initializes a new instance of the GetContentTypeDescriptionOutput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ContentTypeDescription |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput Constructor

Overload List
 | Name | Description
Public method | GetContentTypeDescriptionOutput | Initializes a new instance of the GetContentTypeDescriptionOutput class
Public method | GetContentTypeDescriptionOutput(ContentTypeDescription) | Initializes a new instance of the GetContentTypeDescriptionOutput class
Top
See Also

Reference

GetContentTypeDescriptionOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput Constructor

Initializes a new instance of the GetContentTypeDescriptionOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeDescriptionOutput()
Public Sub New
See Also

Reference

GetContentTypeDescriptionOutput Class
GetContentTypeDescriptionOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput Constructor (ContentTypeDescription)

Initializes a new instance of the GetContentTypeDescriptionOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeDescriptionOutput(
    ContentTypeDescription ContentTypeDescription
)
Public Sub New (
    ContentTypeDescription As ContentTypeDescription
)

Parameters

ContentTypeDescription
Type: Atalasoft.Imaging.WebControls.Capture.KicContentTypeDescription
See Also

Reference

GetContentTypeDescriptionOutput Class
GetContentTypeDescriptionOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput Methods

The GetContentTypeDescriptionOutput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeDescriptionOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput Fields

The GetContentTypeDescriptionOutput type exposes the following members.

Fields
 | Name | Description
Public field | ContentTypeDescription |
Top
See Also

Reference

GetContentTypeDescriptionOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeDescriptionOutput.ContentTypeDescription Field

GetContentTypeDescriptionOutputContentTypeDescription Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContentTypeDescription ContentTypeDescription
Public ContentTypeDescription As ContentTypeDescription

Field Value

Type: ContentTypeDescription
See Also

Reference

GetContentTypeDescriptionOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListCompletedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeListCompletedEventArgs

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetContentTypeListCompletedEventArgs : AsyncCompletedEventArgs
Public Class GetContentTypeListCompletedEventArgs
    Inherits AsyncCompletedEventArgs

The GetContentTypeListCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListCompletedEventArgs Properties

The GetContentTypeListCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
See Also

Reference

GetContentTypeListCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListCompletedEventArgs.Result Property

GetContentTypeListCompletedEventArgsResult Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] Result { get; }
Public ReadOnly Property Result As String()
    Get

Property Value

Type: String
Remarks
See Also

Reference

GetContentTypeListCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListCompletedEventArgs Methods

The GetContentTypeListCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeListCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListCompletedEventHandler Delegate

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void GetContentTypeListCompletedEventHandler(
    Object sender,
    GetContentTypeListCompletedEventArgs e
)
Public Delegate Sub GetContentTypeListCompletedEventHandler (
    sender As Object,
    e As GetContentTypeListCompletedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeListCompletedEventArgs
Remarks
Caution note Caution
This delegate is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeListInput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetContentTypeListInput
Public Class GetContentTypeListInput

The GetContentTypeListInput type exposes the following members.

Constructors
 | Name | Description
Public method | GetContentTypeListInput | Initializes a new instance of the GetContentTypeListInput class
Public method | GetContentTypeListInput(Byte, Object) | Initializes a new instance of the GetContentTypeListInput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | credentials |
Public field | GetContentTypeList |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput Constructor

Overload List
 | Name | Description
Public method | GetContentTypeListInput | Initializes a new instance of the GetContentTypeListInput class
Public method | GetContentTypeListInput(Byte, Object) | Initializes a new instance of the GetContentTypeListInput class
Top
See Also

Reference

GetContentTypeListInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput Constructor

Initializes a new instance of the GetContentTypeListInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeListInput()
Public Sub New
See Also

Reference

GetContentTypeListInput Class
GetContentTypeListInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput Constructor (Byte[], Object)

GetContentTypeListInput Constructor (Byte, Object)

Initializes a new instance of the GetContentTypeListInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeListInput(
    byte[] credentials,
    Object GetContentTypeList
)
Public Sub New (
    credentials As Byte(),
    GetContentTypeList As Object
)

Parameters

credentials
Type: SystemByte
GetContentTypeList
Type: SystemObject
See Also

Reference

GetContentTypeListInput Class
GetContentTypeListInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput Methods

The GetContentTypeListInput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeListInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput Fields

The GetContentTypeListInput type exposes the following members.

Fields
 | Name | Description
Public field | credentials |
Public field | GetContentTypeList |
Top
See Also

Reference

GetContentTypeListInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput.credentials Field

GetContentTypeListInputcredentials Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] credentials
Public credentials As Byte()

Field Value

Type: Byte
See Also

Reference

GetContentTypeListInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListInput.GetContentTypeList Field

GetContentTypeListInputGetContentTypeList Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object GetContentTypeList
Public GetContentTypeList As Object

Field Value

Type: Object
See Also

Reference

GetContentTypeListInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeListOutput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetContentTypeListOutput
Public Class GetContentTypeListOutput

The GetContentTypeListOutput type exposes the following members.

Constructors
 | Name | Description
Public method | GetContentTypeListOutput | Initializes a new instance of the GetContentTypeListOutput class
Public method | GetContentTypeListOutput(String) | Initializes a new instance of the GetContentTypeListOutput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ContentTypeList |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput Constructor

Overload List
 | Name | Description
Public method | GetContentTypeListOutput | Initializes a new instance of the GetContentTypeListOutput class
Public method | GetContentTypeListOutput(String) | Initializes a new instance of the GetContentTypeListOutput class
Top
See Also

Reference

GetContentTypeListOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput Constructor

Initializes a new instance of the GetContentTypeListOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeListOutput()
Public Sub New
See Also

Reference

GetContentTypeListOutput Class
GetContentTypeListOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput Constructor (String[])

GetContentTypeListOutput Constructor (String)

Initializes a new instance of the GetContentTypeListOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetContentTypeListOutput(
    string[] ContentTypeList
)
Public Sub New (
    ContentTypeList As String()
)

Parameters

ContentTypeList
Type: SystemString
See Also

Reference

GetContentTypeListOutput Class
GetContentTypeListOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput Methods

The GetContentTypeListOutput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetContentTypeListOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput Fields

The GetContentTypeListOutput type exposes the following members.

Fields
 | Name | Description
Public field | ContentTypeList |
Top
See Also

Reference

GetContentTypeListOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetContentTypeListOutput.ContentTypeList Field

GetContentTypeListOutputContentTypeList Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] ContentTypeList
Public ContentTypeList As String()

Field Value

Type: String
See Also

Reference

GetContentTypeListOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDCompletedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDCompletedEventArgs

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetNewImportIDCompletedEventArgs : AsyncCompletedEventArgs
Public Class GetNewImportIDCompletedEventArgs
    Inherits AsyncCompletedEventArgs

The GetNewImportIDCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDCompletedEventArgs Properties

The GetNewImportIDCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
See Also

Reference

GetNewImportIDCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDCompletedEventArgs.Result Property

GetNewImportIDCompletedEventArgsResult Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse Result { get; }
Public ReadOnly Property Result As GetNewImportIDResponse
    Get

Property Value

Type: GetNewImportIDResponse
Remarks
See Also

Reference

GetNewImportIDCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDCompletedEventArgs Methods

The GetNewImportIDCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetNewImportIDCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDCompletedEventHandler Delegate

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void GetNewImportIDCompletedEventHandler(
    Object sender,
    GetNewImportIDCompletedEventArgs e
)
Public Delegate Sub GetNewImportIDCompletedEventHandler (
    sender As Object,
    e As GetNewImportIDCompletedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDCompletedEventArgs
Remarks
Caution note Caution
This delegate is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDInput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetNewImportIDInput
Public Class GetNewImportIDInput

The GetNewImportIDInput type exposes the following members.

Constructors
 | Name | Description
Public method | GetNewImportIDInput | Initializes a new instance of the GetNewImportIDInput class
Public method | GetNewImportIDInput(Byte, Object) | Initializes a new instance of the GetNewImportIDInput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | credentials |
Public field | GetNewImportID |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput Constructor

Overload List
 | Name | Description
Public method | GetNewImportIDInput | Initializes a new instance of the GetNewImportIDInput class
Public method | GetNewImportIDInput(Byte, Object) | Initializes a new instance of the GetNewImportIDInput class
Top
See Also

Reference

GetNewImportIDInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput Constructor

Initializes a new instance of the GetNewImportIDInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDInput()
Public Sub New
See Also

Reference

GetNewImportIDInput Class
GetNewImportIDInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput Constructor (Byte[], Object)

GetNewImportIDInput Constructor (Byte, Object)

Initializes a new instance of the GetNewImportIDInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDInput(
    byte[] credentials,
    Object GetNewImportID
)
Public Sub New (
    credentials As Byte(),
    GetNewImportID As Object
)

Parameters

credentials
Type: SystemByte
GetNewImportID
Type: SystemObject
See Also

Reference

GetNewImportIDInput Class
GetNewImportIDInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput Methods

The GetNewImportIDInput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetNewImportIDInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput Fields

The GetNewImportIDInput type exposes the following members.

Fields
 | Name | Description
Public field | credentials |
Public field | GetNewImportID |
Top
See Also

Reference

GetNewImportIDInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput.credentials Field

GetNewImportIDInputcredentials Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] credentials
Public credentials As Byte()

Field Value

Type: Byte
See Also

Reference

GetNewImportIDInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDInput.GetNewImportID Field

GetNewImportIDInputGetNewImportID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object GetNewImportID
Public GetNewImportID As Object

Field Value

Type: Object
See Also

Reference

GetNewImportIDInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDOutput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GetNewImportIDOutput
Public Class GetNewImportIDOutput

The GetNewImportIDOutput type exposes the following members.

Constructors
 | Name | Description
Public method | GetNewImportIDOutput | Initializes a new instance of the GetNewImportIDOutput class
Public method | GetNewImportIDOutput(GetNewImportIDResponse) | Initializes a new instance of the GetNewImportIDOutput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | GetNewImportIDResponse |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput Constructor

Overload List
 | Name | Description
Public method | GetNewImportIDOutput | Initializes a new instance of the GetNewImportIDOutput class
Public method | GetNewImportIDOutput(GetNewImportIDResponse) | Initializes a new instance of the GetNewImportIDOutput class
Top
See Also

Reference

GetNewImportIDOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput Constructor

Initializes a new instance of the GetNewImportIDOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDOutput()
Public Sub New
See Also

Reference

GetNewImportIDOutput Class
GetNewImportIDOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput Constructor (GetNewImportIDResponse)

Initializes a new instance of the GetNewImportIDOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDOutput(
    GetNewImportIDResponse GetNewImportIDResponse
)
Public Sub New (
    GetNewImportIDResponse As GetNewImportIDResponse
)

Parameters

GetNewImportIDResponse
Type: Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDResponse
See Also

Reference

GetNewImportIDOutput Class
GetNewImportIDOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput Methods

The GetNewImportIDOutput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetNewImportIDOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput Fields

The GetNewImportIDOutput type exposes the following members.

Fields
 | Name | Description
Public field | GetNewImportIDResponse |
Top
See Also

Reference

GetNewImportIDOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDOutput.GetNewImportIDResponse Field

GetNewImportIDOutputGetNewImportIDResponse Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse GetNewImportIDResponse
Public GetNewImportIDResponse As GetNewImportIDResponse

Field Value

Type: GetNewImportIDResponse
See Also

Reference

GetNewImportIDOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDResponse Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDResponse

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GetNewImportIDResponse
<SerializableAttribute>
Public Class GetNewImportIDResponse

The GetNewImportIDResponse type exposes the following members.

Constructors
 | Name | Description
Public method | GetNewImportIDResponse | Initializes a new instance of the GetNewImportIDResponse class
Top
Properties
 | Name | Description
Public property | ImportID |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDResponse Constructor

Initializes a new instance of the GetNewImportIDResponse class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse()
Public Sub New
See Also

Reference

GetNewImportIDResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDResponse Properties

The GetNewImportIDResponse type exposes the following members.

Properties
 | Name | Description
Public property | ImportID |
Top
See Also

Reference

GetNewImportIDResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDResponse.ImportID Property

GetNewImportIDResponseImportID Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportID { get; set; }
Public Property ImportID As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

GetNewImportIDResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


GetNewImportIDResponse Methods

The GetNewImportIDResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetNewImportIDResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImageCleanupProfile

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageCleanupProfile
Public Class ImageCleanupProfile

The ImageCleanupProfile type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCleanupProfile | Initializes a new instance of the ImageCleanupProfile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BorderEnable |
Public field | DefaultFor |
Public field | DeshadeEnable |
Public field | DeskewEnable |
Public field | DespecEnable |
Public field | DespecHeight |
Public field | DespecWidth |
Public field | FltCharSmoothing |
Public field | FltEnable |
Public field | HorzCharRepair |
Public field | HorzLineEnable |
Public field | HorzMaxHeight |
Public field | HorzMinLength |
Public field | KofaxID |
Public field | MinAngle |
Public field | MinShadeWidth |
Public field | Name |
Public field | ReadOnly |
Public field | ScriptName |
Public field | VertCharRepair |
Public field | VertLineEnable |
Public field | VertMaxWidth |
Public field | VertMinHeight |
Public field | WhiteNoiseGap |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile Constructor

Initializes a new instance of the ImageCleanupProfile class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCleanupProfile()
Public Sub New
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile Methods

The ImageCleanupProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile Fields

The ImageCleanupProfile type exposes the following members.

Fields
 | Name | Description
Public field | BorderEnable |
Public field | DefaultFor |
Public field | DeshadeEnable |
Public field | DeskewEnable |
Public field | DespecEnable |
Public field | DespecHeight |
Public field | DespecWidth |
Public field | FltCharSmoothing |
Public field | FltEnable |
Public field | HorzCharRepair |
Public field | HorzLineEnable |
Public field | HorzMaxHeight |
Public field | HorzMinLength |
Public field | KofaxID |
Public field | MinAngle |
Public field | MinShadeWidth |
Public field | Name |
Public field | ReadOnly |
Public field | ScriptName |
Public field | VertCharRepair |
Public field | VertLineEnable |
Public field | VertMaxWidth |
Public field | VertMinHeight |
Public field | WhiteNoiseGap |
Top
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.BorderEnable Field

ImageCleanupProfileBorderEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BorderEnable
Public BorderEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.DefaultFor Field

ImageCleanupProfileDefaultFor Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultFor
Public DefaultFor As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.DeshadeEnable Field

ImageCleanupProfileDeshadeEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DeshadeEnable
Public DeshadeEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.DeskewEnable Field

ImageCleanupProfileDeskewEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DeskewEnable
Public DeskewEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.DespecEnable Field

ImageCleanupProfileDespecEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DespecEnable
Public DespecEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.DespecHeight Field

ImageCleanupProfileDespecHeight Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DespecHeight
Public DespecHeight As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.DespecWidth Field

ImageCleanupProfileDespecWidth Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DespecWidth
Public DespecWidth As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.FltCharSmoothing Field

ImageCleanupProfileFltCharSmoothing Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FltCharSmoothing
Public FltCharSmoothing As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.FltEnable Field

ImageCleanupProfileFltEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FltEnable
Public FltEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.HorzCharRepair Field

ImageCleanupProfileHorzCharRepair Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HorzCharRepair
Public HorzCharRepair As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.HorzLineEnable Field

ImageCleanupProfileHorzLineEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HorzLineEnable
Public HorzLineEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.HorzMaxHeight Field

ImageCleanupProfileHorzMaxHeight Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HorzMaxHeight
Public HorzMaxHeight As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.HorzMinLength Field

ImageCleanupProfileHorzMinLength Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HorzMinLength
Public HorzMinLength As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.KofaxID Field

ImageCleanupProfileKofaxID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KofaxID
Public KofaxID As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.MinAngle Field

ImageCleanupProfileMinAngle Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MinAngle
Public MinAngle As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.MinShadeWidth Field

ImageCleanupProfileMinShadeWidth Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MinShadeWidth
Public MinShadeWidth As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.Name Field

ImageCleanupProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.ReadOnly Field

ImageCleanupProfileReadOnly Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReadOnly
Public ReadOnly As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.ScriptName Field

ImageCleanupProfileScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScriptName
Public ScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.VertCharRepair Field

ImageCleanupProfileVertCharRepair Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string VertCharRepair
Public VertCharRepair As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.VertLineEnable Field

ImageCleanupProfileVertLineEnable Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string VertLineEnable
Public VertLineEnable As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.VertMaxWidth Field

ImageCleanupProfileVertMaxWidth Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string VertMaxWidth
Public VertMaxWidth As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.VertMinHeight Field

ImageCleanupProfileVertMinHeight Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string VertMinHeight
Public VertMinHeight As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImageCleanupProfile.WhiteNoiseGap Field

ImageCleanupProfileWhiteNoiseGap Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string WhiteNoiseGap
Public WhiteNoiseGap As String

Field Value

Type: String
Remarks
See Also

Reference

ImageCleanupProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImport

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Import
<SerializableAttribute>
Public Class Import

The Import type exposes the following members.

Constructors
 | Name | Description
Public method | Import | Initializes a new instance of the Import class
Top
Properties
 | Name | Description
Public property | Address |
Public property | FirstAttemptWithNewID |
Public property | ImportID |
Public property | OriginatorAddress |
Public property | OriginatorName |
Public property | OwnerReference |
Public property | Part |
Public property | StructuredXmlDocument |
Public property | Subject |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import Constructor

Initializes a new instance of the Import class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Import()
Public Sub New
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import Properties

The Import type exposes the following members.

Properties
 | Name | Description
Public property | Address |
Public property | FirstAttemptWithNewID |
Public property | ImportID |
Public property | OriginatorAddress |
Public property | OriginatorName |
Public property | OwnerReference |
Public property | Part |
Public property | StructuredXmlDocument |
Public property | Subject |
Top
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.Address Property

ImportAddress Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.FirstAttemptWithNewID Property

ImportFirstAttemptWithNewID Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FirstAttemptWithNewID { get; set; }
Public Property FirstAttemptWithNewID As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.ImportID Property

ImportImportID Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportID { get; set; }
Public Property ImportID As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.OriginatorAddress Property

ImportOriginatorAddress Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OriginatorAddress { get; set; }
Public Property OriginatorAddress As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.OriginatorName Property

ImportOriginatorName Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OriginatorName { get; set; }
Public Property OriginatorName As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.OwnerReference Property

ImportOwnerReference Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OwnerReference { get; set; }
Public Property OwnerReference As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.Part Property

ImportPart Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportPartType[] Part { get; set; }
Public Property Part As ImportPartType()
    Get
    Set

Property Value

Type: ImportPartType
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.StructuredXmlDocument Property

ImportStructuredXmlDocument Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportPartType StructuredXmlDocument { get; set; }
Public Property StructuredXmlDocument As ImportPartType
    Get
    Set

Property Value

Type: ImportPartType
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import.Subject Property

ImportSubject Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Import Methods

The Import type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Import Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportCompletedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Atalasoft.Imaging.WebControls.Capture.KicImportCompletedEventArgs

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImportCompletedEventArgs : AsyncCompletedEventArgs
Public Class ImportCompletedEventArgs
    Inherits AsyncCompletedEventArgs

The ImportCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportCompletedEventArgs Properties

The ImportCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
See Also

Reference

ImportCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportCompletedEventArgs.Result Property

ImportCompletedEventArgsResult Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportResponse Result { get; }
Public ReadOnly Property Result As ImportResponse
    Get

Property Value

Type: ImportResponse
Remarks
See Also

Reference

ImportCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportCompletedEventArgs Methods

The ImportCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportCompletedEventHandler Delegate

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ImportCompletedEventHandler(
    Object sender,
    ImportCompletedEventArgs e
)
Public Delegate Sub ImportCompletedEventHandler (
    sender As Object,
    e As ImportCompletedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControls.Capture.KicImportCompletedEventArgs
Remarks
Caution note Caution
This delegate is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportInput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImportInput
Public Class ImportInput

The ImportInput type exposes the following members.

Constructors
 | Name | Description
Public method | ImportInput | Initializes a new instance of the ImportInput class
Public method | ImportInput(Byte, Import) | Initializes a new instance of the ImportInput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | credentials |
Public field | Import |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput Constructor

Overload List
 | Name | Description
Public method | ImportInput | Initializes a new instance of the ImportInput class
Public method | ImportInput(Byte, Import) | Initializes a new instance of the ImportInput class
Top
See Also

Reference

ImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput Constructor

Initializes a new instance of the ImportInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportInput()
Public Sub New
See Also

Reference

ImportInput Class
ImportInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput Constructor (Byte[], Import)

ImportInput Constructor (Byte, Import)

Initializes a new instance of the ImportInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportInput(
    byte[] credentials,
    Import Import
)
Public Sub New (
    credentials As Byte(),
    Import As Import
)

Parameters

credentials
Type: SystemByte
Import
Type: Atalasoft.Imaging.WebControls.Capture.KicImport
See Also

Reference

ImportInput Class
ImportInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput Methods

The ImportInput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput Fields

The ImportInput type exposes the following members.

Fields
 | Name | Description
Public field | credentials |
Public field | Import |
Top
See Also

Reference

ImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput.credentials Field

ImportInputcredentials Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] credentials
Public credentials As Byte()

Field Value

Type: Byte
See Also

Reference

ImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportInput.Import Field

ImportInputImport Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Import Import
Public Import As Import

Field Value

Type: Import
See Also

Reference

ImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportOutput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImportOutput
Public Class ImportOutput

The ImportOutput type exposes the following members.

Constructors
 | Name | Description
Public method | ImportOutput | Initializes a new instance of the ImportOutput class
Public method | ImportOutput(ImportResponse) | Initializes a new instance of the ImportOutput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ImportResponse |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput Constructor

Overload List
 | Name | Description
Public method | ImportOutput | Initializes a new instance of the ImportOutput class
Public method | ImportOutput(ImportResponse) | Initializes a new instance of the ImportOutput class
Top
See Also

Reference

ImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput Constructor

Initializes a new instance of the ImportOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportOutput()
Public Sub New
See Also

Reference

ImportOutput Class
ImportOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput Constructor (ImportResponse)

Initializes a new instance of the ImportOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportOutput(
    ImportResponse ImportResponse
)
Public Sub New (
    ImportResponse As ImportResponse
)

Parameters

ImportResponse
Type: Atalasoft.Imaging.WebControls.Capture.KicImportResponse
See Also

Reference

ImportOutput Class
ImportOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput Methods

The ImportOutput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput Fields

The ImportOutput type exposes the following members.

Fields
 | Name | Description
Public field | ImportResponse |
Top
See Also

Reference

ImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportOutput.ImportResponse Field

ImportOutputImportResponse Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportResponse ImportResponse
Public ImportResponse As ImportResponse

Field Value

Type: ImportResponse
See Also

Reference

ImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportPartType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImportPartType
<SerializableAttribute>
Public Class ImportPartType

The ImportPartType type exposes the following members.

Constructors
 | Name | Description
Public method | ImportPartType | Initializes a new instance of the ImportPartType class
Top
Properties
 | Name | Description
Public property | Content |
Public property | ContentID |
Public property | ContentType |
Public property | Filename |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType Constructor

Initializes a new instance of the ImportPartType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportPartType()
Public Sub New
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType Properties

The ImportPartType type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | ContentID |
Public property | ContentType |
Public property | Filename |
Top
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType.Content Property

ImportPartTypeContent Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportPartTypeContent Content { get; set; }
Public Property Content As ImportPartTypeContent
    Get
    Set

Property Value

Type: ImportPartTypeContent
Remarks
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType.ContentID Property

ImportPartTypeContentID Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ContentID { get; set; }
Public Property ContentID As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType.ContentType Property

ImportPartTypeContentType Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType.Filename Property

ImportPartTypeFilename Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartType Methods

The ImportPartType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportPartType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartTypeContent Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportPartTypeContent

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImportPartTypeContent
<SerializableAttribute>
Public Class ImportPartTypeContent

The ImportPartTypeContent type exposes the following members.

Constructors
 | Name | Description
Public method | ImportPartTypeContent | Initializes a new instance of the ImportPartTypeContent class
Top
Properties
 | Name | Description
Public property | Item |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartTypeContent Constructor

Initializes a new instance of the ImportPartTypeContent class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportPartTypeContent()
Public Sub New
See Also

Reference

ImportPartTypeContent Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartTypeContent Properties

The ImportPartTypeContent type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Top
See Also

Reference

ImportPartTypeContent Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartTypeContent.Item Property

ImportPartTypeContentItem Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Item { get; set; }
Public Property Item As Object
    Get
    Set

Property Value

Type: Object
Remarks
See Also

Reference

ImportPartTypeContent Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportPartTypeContent Methods

The ImportPartTypeContent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportPartTypeContent Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType Interface

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface importPortType
Public Interface importPortType

The importPortType type exposes the following members.

Methods
 | Name | Description
Public method | GetContentTypeDescription |
Public method | GetContentTypeList |
Public method | GetNewImportID |
Public method | Import |
Public method | TrackImport |
Top
Remarks
Caution note Caution
This interface is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType Methods

The importPortType type exposes the following members.

Methods
 | Name | Description
Public method | GetContentTypeDescription |
Public method | GetContentTypeList |
Public method | GetNewImportID |
Public method | Import |
Public method | TrackImport |
Top
See Also

Reference

importPortType Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType.GetContentTypeDescription Method

importPortTypeGetContentTypeDescription Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
GetContentTypeDescriptionOutput GetContentTypeDescription(
    GetContentTypeDescriptionInput request
)
Function GetContentTypeDescription (
    request As GetContentTypeDescriptionInput
) As GetContentTypeDescriptionOutput

Parameters

request
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescriptionInput

Return Value

Type: GetContentTypeDescriptionOutput
See Also

Reference

importPortType Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType.GetContentTypeList Method

importPortTypeGetContentTypeList Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
GetContentTypeListOutput GetContentTypeList(
    GetContentTypeListInput request
)
Function GetContentTypeList (
    request As GetContentTypeListInput
) As GetContentTypeListOutput

Parameters

request
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeListInput

Return Value

Type: GetContentTypeListOutput
See Also

Reference

importPortType Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType.GetNewImportID Method

importPortTypeGetNewImportID Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
GetNewImportIDOutput GetNewImportID(
    GetNewImportIDInput request
)
Function GetNewImportID (
    request As GetNewImportIDInput
) As GetNewImportIDOutput

Parameters

request
Type: Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDInput

Return Value

Type: GetNewImportIDOutput
See Also

Reference

importPortType Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType.Import Method

importPortTypeImport Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
ImportOutput Import(
    ImportInput request
)
Function Import (
    request As ImportInput
) As ImportOutput

Parameters

request
Type: Atalasoft.Imaging.WebControls.Capture.KicImportInput

Return Value

Type: ImportOutput
See Also

Reference

importPortType Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortType.TrackImport Method

importPortTypeTrackImport Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
TrackImportOutput TrackImport(
    TrackImportInput request
)
Function TrackImport (
    request As TrackImportInput
) As TrackImportOutput

Parameters

request
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImportInput

Return Value

Type: TrackImportOutput
See Also

Reference

importPortType Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeChannel Interface

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface importPortTypeChannel : importPortType,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Public Interface importPortTypeChannel
    Inherits importPortType, IClientChannel, IContextChannel, IChannel,
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable

The importPortTypeChannel type exposes the following members.

Properties
 | Name | Description
Public property | AllowInitializationUI | Gets or sets a value indicating whether DisplayInitializationUI attempts to call the IInteractiveChannelInitializer objects in the InteractiveChannelInitializers property or throws if that collection is not empty. (Inherited from IClientChannel.)
Public property | AllowOutputBatching | Gets or sets a value that instructs Windows Communication Foundation (WCF) to store a set of messages before giving the messages to the transport. (Inherited from IContextChannel.)
Public property | DidInteractiveInitialization | Gets a value indicating whether a call was done to a user interface to obtain credential information. (Inherited from IClientChannel.)
Public property | Extensions | Gets a collection of extension objects for this extensible object. (Inherited from IExtensibleObjectIContextChannel.)
Public property | InputSession | Gets the input session for the channel. (Inherited from IContextChannel.)
Public property | LocalAddress | Gets the local endpoint for the channel. (Inherited from IContextChannel.)
Public property | OperationTimeout | Gets or sets the time period within which an operation must complete or an exception is thrown. (Inherited from IContextChannel.)
Public property | OutputSession | Gets the output session associated with the channel, if any. (Inherited from IContextChannel.)
Public property | RemoteAddress | Gets the remote address associated with the channel. (Inherited from IContextChannel.)
Public property | SessionId | Returns an identifier for the current session, if any. (Inherited from IContextChannel.)
Public property | State | Gets the current state of the communication-oriented object. (Inherited from ICommunicationObject.)
Public property | Via | Gets the URI that contains the transport address to which messages are sent on the client channel. (Inherited from IClientChannel.)
Top
Methods
 | Name | Description
Public method | Abort | Causes a communication object to transition immediately from its current state into the closed state. (Inherited from ICommunicationObject.)
Public method | BeginClose(AsyncCallback, Object) | Begins an asynchronous operation to close a communication object. (Inherited from ICommunicationObject.)
Public method | BeginClose(TimeSpan, AsyncCallback, Object) | Begins an asynchronous operation to close a communication object with a specified timeout. (Inherited from ICommunicationObject.)
Public method | BeginDisplayInitializationUI | An asynchronous call to begin using a user interface to obtain credential information. (Inherited from IClientChannel.)
Public method | BeginOpen(AsyncCallback, Object) | Begins an asynchronous operation to open a communication object. (Inherited from ICommunicationObject.)
Public method | BeginOpen(TimeSpan, AsyncCallback, Object) | Begins an asynchronous operation to open a communication object within a specified interval of time. (Inherited from ICommunicationObject.)
Public method | Close | Causes a communication object to transition from its current state into the closed state. (Inherited from ICommunicationObject.)
Public method | Close(TimeSpan) | Causes a communication object to transition from its current state into the closed state. (Inherited from ICommunicationObject.)
Public method | DisplayInitializationUI | A call to a user interface to obtain credential information. (Inherited from IClientChannel.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndClose | Completes an asynchronous operation to close a communication object. (Inherited from ICommunicationObject.)
Public method | EndDisplayInitializationUI | Called when the call to BeginDisplayInitializationUI(AsyncCallback, Object) has finished. (Inherited from IClientChannel.)
Public method | EndOpen | Completes an asynchronous operation to open a communication object. (Inherited from ICommunicationObject.)
Public method | GetContentTypeDescription | (Inherited from importPortType.)
Public method | GetContentTypeList | (Inherited from importPortType.)
Public method | GetNewImportID | (Inherited from importPortType.)
Public method | GetPropertyT | Returns a typed object requested, if present, from the appropriate layer in the channel stack. (Inherited from IChannel.)
Public method | Import | (Inherited from importPortType.)
Public method | Open | Causes a communication object to transition from the created state into the opened state. (Inherited from ICommunicationObject.)
Public method | Open(TimeSpan) | Causes a communication object to transition from the created state into the opened state within a specified interval of time. (Inherited from ICommunicationObject.)
Public method | TrackImport | (Inherited from importPortType.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the communication object completes its transition from the closing state into the closed state. (Inherited from ICommunicationObject.)
Public event | Closing | Occurs when the communication object first enters the closing state. (Inherited from ICommunicationObject.)
Public event | Faulted | Occurs when the communication object first enters the faulted state. (Inherited from ICommunicationObject.)
Public event | Opened | Occurs when the communication object completes its transition from the opening state into the opened state. (Inherited from ICommunicationObject.)
Public event | Opening | Occurs when the communication object first enters the opening state. (Inherited from ICommunicationObject.)
Public event | UnknownMessageReceived | This is a reserved event. (Inherited from IClientChannel.)
Top
Remarks
Caution note Caution
This interface is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeChannel Properties

The importPortTypeChannel type exposes the following members.

Properties
 | Name | Description
Public property | AllowInitializationUI | Gets or sets a value indicating whether DisplayInitializationUI attempts to call the IInteractiveChannelInitializer objects in the InteractiveChannelInitializers property or throws if that collection is not empty. (Inherited from IClientChannel.)
Public property | AllowOutputBatching | Gets or sets a value that instructs Windows Communication Foundation (WCF) to store a set of messages before giving the messages to the transport. (Inherited from IContextChannel.)
Public property | DidInteractiveInitialization | Gets a value indicating whether a call was done to a user interface to obtain credential information. (Inherited from IClientChannel.)
Public property | Extensions | Gets a collection of extension objects for this extensible object. (Inherited from IExtensibleObjectIContextChannel.)
Public property | InputSession | Gets the input session for the channel. (Inherited from IContextChannel.)
Public property | LocalAddress | Gets the local endpoint for the channel. (Inherited from IContextChannel.)
Public property | OperationTimeout | Gets or sets the time period within which an operation must complete or an exception is thrown. (Inherited from IContextChannel.)
Public property | OutputSession | Gets the output session associated with the channel, if any. (Inherited from IContextChannel.)
Public property | RemoteAddress | Gets the remote address associated with the channel. (Inherited from IContextChannel.)
Public property | SessionId | Returns an identifier for the current session, if any. (Inherited from IContextChannel.)
Public property | State | Gets the current state of the communication-oriented object. (Inherited from ICommunicationObject.)
Public property | Via | Gets the URI that contains the transport address to which messages are sent on the client channel. (Inherited from IClientChannel.)
Top
See Also

Reference

importPortTypeChannel Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeChannel Methods

The importPortTypeChannel type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Causes a communication object to transition immediately from its current state into the closed state. (Inherited from ICommunicationObject.)
Public method | BeginClose(AsyncCallback, Object) | Begins an asynchronous operation to close a communication object. (Inherited from ICommunicationObject.)
Public method | BeginClose(TimeSpan, AsyncCallback, Object) | Begins an asynchronous operation to close a communication object with a specified timeout. (Inherited from ICommunicationObject.)
Public method | BeginDisplayInitializationUI | An asynchronous call to begin using a user interface to obtain credential information. (Inherited from IClientChannel.)
Public method | BeginOpen(AsyncCallback, Object) | Begins an asynchronous operation to open a communication object. (Inherited from ICommunicationObject.)
Public method | BeginOpen(TimeSpan, AsyncCallback, Object) | Begins an asynchronous operation to open a communication object within a specified interval of time. (Inherited from ICommunicationObject.)
Public method | Close | Causes a communication object to transition from its current state into the closed state. (Inherited from ICommunicationObject.)
Public method | Close(TimeSpan) | Causes a communication object to transition from its current state into the closed state. (Inherited from ICommunicationObject.)
Public method | DisplayInitializationUI | A call to a user interface to obtain credential information. (Inherited from IClientChannel.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndClose | Completes an asynchronous operation to close a communication object. (Inherited from ICommunicationObject.)
Public method | EndDisplayInitializationUI | Called when the call to BeginDisplayInitializationUI(AsyncCallback, Object) has finished. (Inherited from IClientChannel.)
Public method | EndOpen | Completes an asynchronous operation to open a communication object. (Inherited from ICommunicationObject.)
Public method | GetContentTypeDescription | (Inherited from importPortType.)
Public method | GetContentTypeList | (Inherited from importPortType.)
Public method | GetNewImportID | (Inherited from importPortType.)
Public method | GetPropertyT | Returns a typed object requested, if present, from the appropriate layer in the channel stack. (Inherited from IChannel.)
Public method | Import | (Inherited from importPortType.)
Public method | Open | Causes a communication object to transition from the created state into the opened state. (Inherited from ICommunicationObject.)
Public method | Open(TimeSpan) | Causes a communication object to transition from the created state into the opened state within a specified interval of time. (Inherited from ICommunicationObject.)
Public method | TrackImport | (Inherited from importPortType.)
Top
See Also

Reference

importPortTypeChannel Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeChannel Events

The importPortTypeChannel type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the communication object completes its transition from the closing state into the closed state. (Inherited from ICommunicationObject.)
Public event | Closing | Occurs when the communication object first enters the closing state. (Inherited from ICommunicationObject.)
Public event | Faulted | Occurs when the communication object first enters the faulted state. (Inherited from ICommunicationObject.)
Public event | Opened | Occurs when the communication object completes its transition from the opening state into the opened state. (Inherited from ICommunicationObject.)
Public event | Opening | Occurs when the communication object first enters the opening state. (Inherited from ICommunicationObject.)
Public event | UnknownMessageReceived | This is a reserved event. (Inherited from IClientChannel.)
Top
See Also

Reference

importPortTypeChannel Interface
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Class

Inheritance Hierarchy
SystemObject
System.ServiceModelClientBaseimportPortType
Atalasoft.Imaging.WebControls.Capture.KicimportPortTypeClient

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class importPortTypeClient : ClientBase<importPortType>,
    importPortType
Public Class importPortTypeClient
    Inherits ClientBase(Of importPortType)
    Implements importPortType

The importPortTypeClient type exposes the following members.

Constructors
 | Name | Description
Public method | importPortTypeClient | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(String) | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(Binding, EndpointAddress) | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(String, EndpointAddress) | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(String, String) | Initializes a new instance of the importPortTypeClient class
Top
Properties
 | Name | Description
Protected property | Channel | Gets the inner channel used to send messages to variously configured service endpoints. (Inherited from ClientBaseimportPortType .)
Public property | ChannelFactory | Gets the underlying ChannelFactoryTChannel object. (Inherited from ClientBaseimportPortType .)
Public property | ClientCredentials | Gets the client credentials used to call an operation. (Inherited from ClientBaseimportPortType .)
Public property | Endpoint | Gets the target endpoint for the service to which the WCF client can connect. (Inherited from ClientBaseimportPortType .)
Public property | InnerChannel | Gets the underlying IClientChannel implementation. (Inherited from ClientBaseimportPortType .)
Public property | State | Gets the current state of the ClientBaseTChannel object. (Inherited from ClientBaseimportPortType .)
Top
Methods
 | Name | Description
Public method | Abort | Causes the ClientBaseTChannel object to transition immediately from its current state into the closed state. (Inherited from ClientBaseimportPortType .)
Public method | Close | Causes the ClientBaseTChannel object to transition from its current state into the closed state. (Inherited from ClientBaseimportPortType .)
Protected method | CreateChannel | Returns a new channel to the service. (Inherited from ClientBaseimportPortType .)
Public method | DisplayInitializationUI | Instructs the inner channel to display a user interface if one is required to initialize the channel prior to using it. (Inherited from ClientBaseimportPortType .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContentTypeDescription |
Public method | GetContentTypeList |
Protected method | GetDefaultValueForInitializationT | Replicates the behavior of the default keyword in C#. (Inherited from ClientBaseimportPortType .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNewImportID |
Public method | GetNewImportID(GetNewImportIDInput) |
Public method | GetNewImportID(Byte, Object) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import |
Protected method | InvokeAsync | Provides support for implementing the event-based asynchronous pattern. For more information about this pattern, see Event-based Asynchronous Pattern Overview. (Inherited from ClientBaseimportPortType .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Causes the ClientBaseTChannel object to transition from the created state into the opened state. (Inherited from ClientBaseimportPortType .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackImport |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Constructor

Overload List
 | Name | Description
Public method | importPortTypeClient | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(String) | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(Binding, EndpointAddress) | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(String, EndpointAddress) | Initializes a new instance of the importPortTypeClient class
Public method | importPortTypeClient(String, String) | Initializes a new instance of the importPortTypeClient class
Top
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Constructor

Initializes a new instance of the importPortTypeClient class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public importPortTypeClient()
Public Sub New
See Also

Reference

importPortTypeClient Class
importPortTypeClient Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Constructor (String)

Initializes a new instance of the importPortTypeClient class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public importPortTypeClient(
    string endpointConfigurationName
)
Public Sub New (
    endpointConfigurationName As String
)

Parameters

endpointConfigurationName
Type: SystemString
See Also

Reference

importPortTypeClient Class
importPortTypeClient Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Constructor (Binding, EndpointAddress)

Initializes a new instance of the importPortTypeClient class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public importPortTypeClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Public Sub New (
    binding As Binding,
    remoteAddress As EndpointAddress
)

Parameters

binding
Type: System.ServiceModel.ChannelsBinding
remoteAddress
Type: System.ServiceModelEndpointAddress
See Also

Reference

importPortTypeClient Class
importPortTypeClient Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Constructor (String, EndpointAddress)

Initializes a new instance of the importPortTypeClient class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public importPortTypeClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Public Sub New (
    endpointConfigurationName As String,
    remoteAddress As EndpointAddress
)

Parameters

endpointConfigurationName
Type: SystemString
remoteAddress
Type: System.ServiceModelEndpointAddress
See Also

Reference

importPortTypeClient Class
importPortTypeClient Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Constructor (String, String)

Initializes a new instance of the importPortTypeClient class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public importPortTypeClient(
    string endpointConfigurationName,
    string remoteAddress
)
Public Sub New (
    endpointConfigurationName As String,
    remoteAddress As String
)

Parameters

endpointConfigurationName
Type: SystemString
remoteAddress
Type: SystemString
See Also

Reference

importPortTypeClient Class
importPortTypeClient Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Properties

The importPortTypeClient type exposes the following members.

Properties
 | Name | Description
Protected property | Channel | Gets the inner channel used to send messages to variously configured service endpoints. (Inherited from ClientBaseimportPortType .)
Public property | ChannelFactory | Gets the underlying ChannelFactoryTChannel object. (Inherited from ClientBaseimportPortType .)
Public property | ClientCredentials | Gets the client credentials used to call an operation. (Inherited from ClientBaseimportPortType .)
Public property | Endpoint | Gets the target endpoint for the service to which the WCF client can connect. (Inherited from ClientBaseimportPortType .)
Public property | InnerChannel | Gets the underlying IClientChannel implementation. (Inherited from ClientBaseimportPortType .)
Public property | State | Gets the current state of the ClientBaseTChannel object. (Inherited from ClientBaseimportPortType .)
Top
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient Methods

The importPortTypeClient type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Causes the ClientBaseTChannel object to transition immediately from its current state into the closed state. (Inherited from ClientBaseimportPortType .)
Public method | Close | Causes the ClientBaseTChannel object to transition from its current state into the closed state. (Inherited from ClientBaseimportPortType .)
Protected method | CreateChannel | Returns a new channel to the service. (Inherited from ClientBaseimportPortType .)
Public method | DisplayInitializationUI | Instructs the inner channel to display a user interface if one is required to initialize the channel prior to using it. (Inherited from ClientBaseimportPortType .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContentTypeDescription |
Public method | GetContentTypeList |
Protected method | GetDefaultValueForInitializationT | Replicates the behavior of the default keyword in C#. (Inherited from ClientBaseimportPortType .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNewImportID |
Public method | GetNewImportID(GetNewImportIDInput) |
Public method | GetNewImportID(Byte, Object) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import |
Protected method | InvokeAsync | Provides support for implementing the event-based asynchronous pattern. For more information about this pattern, see Event-based Asynchronous Pattern Overview. (Inherited from ClientBaseimportPortType .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Causes the ClientBaseTChannel object to transition from the created state into the opened state. (Inherited from ClientBaseimportPortType .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackImport |
Top
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.GetContentTypeDescription Method

importPortTypeClientGetContentTypeDescription Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContentTypeDescription GetContentTypeDescription(
    byte[] credentials,
    GetContentTypeDescription GetContentTypeDescription1
)
Public Function GetContentTypeDescription (
    credentials As Byte(),
    GetContentTypeDescription1 As GetContentTypeDescription
) As ContentTypeDescription

Parameters

credentials
Type: SystemByte
GetContentTypeDescription1
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescription

Return Value

Type: ContentTypeDescription
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.GetContentTypeList Method

importPortTypeClientGetContentTypeList Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetContentTypeList(
    byte[] credentials,
    Object GetContentTypeList1
)
Public Function GetContentTypeList (
    credentials As Byte(),
    GetContentTypeList1 As Object
) As String()

Parameters

credentials
Type: SystemByte
GetContentTypeList1
Type: SystemObject

Return Value

Type: String
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.GetNewImportID Method

importPortTypeClientGetNewImportID Method

Overload List
 | Name | Description
Public method | GetNewImportID |
Public method | GetNewImportID(GetNewImportIDInput) |
Public method | GetNewImportID(Byte, Object) |
Top
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.GetNewImportID Method

importPortTypeClientGetNewImportID Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse GetNewImportID()
Public Function GetNewImportID As GetNewImportIDResponse

Return Value

Type: GetNewImportIDResponse
See Also

Reference

importPortTypeClient Class
GetNewImportID Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.GetNewImportID Method (GetNewImportIDInput)

importPortTypeClientGetNewImportID Method (GetNewImportIDInput)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse GetNewImportID(
    GetNewImportIDInput input
)
Public Function GetNewImportID (
    input As GetNewImportIDInput
) As GetNewImportIDResponse

Parameters

input
Type: Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDInput

Return Value

Type: GetNewImportIDResponse
See Also

Reference

importPortTypeClient Class
GetNewImportID Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.GetNewImportID Method (Byte[], Object)

importPortTypeClientGetNewImportID Method (Byte, Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse GetNewImportID(
    byte[] credentials,
    Object GetNewImportID1
)
Public Function GetNewImportID (
    credentials As Byte(),
    GetNewImportID1 As Object
) As GetNewImportIDResponse

Parameters

credentials
Type: SystemByte
GetNewImportID1
Type: SystemObject

Return Value

Type: GetNewImportIDResponse
See Also

Reference

importPortTypeClient Class
GetNewImportID Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.Import Method

importPortTypeClientImport Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportResponse Import(
    byte[] credentials,
    Import Import1
)
Public Function Import (
    credentials As Byte(),
    Import1 As Import
) As ImportResponse

Parameters

credentials
Type: SystemByte
Import1
Type: Atalasoft.Imaging.WebControls.Capture.KicImport

Return Value

Type: ImportResponse
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


importPortTypeClient.TrackImport Method

importPortTypeClientTrackImport Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportResponse TrackImport(
    byte[] credentials,
    TrackImport TrackImport1
)
Public Function TrackImport (
    credentials As Byte(),
    TrackImport1 As TrackImport
) As TrackImportResponse

Parameters

credentials
Type: SystemByte
TrackImport1
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImport

Return Value

Type: TrackImportResponse
See Also

Reference

importPortTypeClient Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportResponse Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportResponse

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ImportResponse
<SerializableAttribute>
Public Class ImportResponse

The ImportResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ImportResponse | Initializes a new instance of the ImportResponse class
Top
Properties
 | Name | Description
Public property | Extension |
Public property | ImportID |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportResponse Constructor

Initializes a new instance of the ImportResponse class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportResponse()
Public Sub New
See Also

Reference

ImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportResponse Properties

The ImportResponse type exposes the following members.

Properties
 | Name | Description
Public property | Extension |
Public property | ImportID |
Top
See Also

Reference

ImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportResponse.Extension Property

ImportResponseExtension Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExtensionFieldType[] Extension { get; set; }
Public Property Extension As ExtensionFieldType()
    Get
    Set

Property Value

Type: ExtensionFieldType
Remarks
See Also

Reference

ImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportResponse.ImportID Property

ImportResponseImportID Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportID { get; set; }
Public Property ImportID As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

ImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportResponse Methods

The ImportResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Web.Services.ProtocolsWebClientProtocol
System.Web.Services.ProtocolsHttpWebClientProtocol
System.Web.Services.ProtocolsSoapHttpClientProtocol
Atalasoft.Imaging.WebControls.Capture.KicImportService

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImportService : SoapHttpClientProtocol
Public Class ImportService
    Inherits SoapHttpClientProtocol

The ImportService type exposes the following members.

Constructors
 | Name | Description
Public method | ImportService | Initializes a new instance of the ImportService class
Top
Properties
 | Name | Description
Public property | AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Public property | credentials |
Public property | Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | EnableDecompression | Gets or sets a value that indicates whether decompression is enabled for this HttpWebClientProtocol. (Inherited from HttpWebClientProtocol.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Public property | Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | Indicates the time an XML Web service client waits for the reply to a synchronous XML Web service request to arrive (in milliseconds). (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Public property | Url |
Public property | UseDefaultCredentials |
Public property | UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)
Top
Methods
 | Name | Description
Public method | Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
Protected method | BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync |
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Protected method | EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetContentTypeDescription |
Public method | GetContentTypeDescriptionAsync(GetContentTypeDescription) |
Public method | GetContentTypeDescriptionAsync(GetContentTypeDescription, Object) |
Public method | GetContentTypeList |
Public method | GetContentTypeListAsync(Object) |
Public method | GetContentTypeListAsync(Object, Object) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNewImportID |
Public method | GetNewImportIDAsync(Object) |
Public method | GetNewImportIDAsync(Object, Object) |
Protected method | GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
Public method | Import |
Public method | ImportAsync(Import) |
Public method | ImportAsync(Import, Object) |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TrackImport |
Public method | TrackImportAsync(TrackImport) |
Public method | TrackImportAsync(TrackImport, Object) |
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | GetContentTypeDescriptionCompleted |
Public event | GetContentTypeListCompleted |
Public event | GetNewImportIDCompleted |
Public event | ImportCompleted |
Public event | TrackImportCompleted |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService Constructor

Initializes a new instance of the ImportService class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportService()
Public Sub New
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService Properties

The ImportService type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Public property | credentials |
Public property | Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | EnableDecompression | Gets or sets a value that indicates whether decompression is enabled for this HttpWebClientProtocol. (Inherited from HttpWebClientProtocol.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Public property | Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | Indicates the time an XML Web service client waits for the reply to a synchronous XML Web service request to arrive (in milliseconds). (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Public property | Url |
Public property | UseDefaultCredentials |
Public property | UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.credentials Property

ImportServicecredentials Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public base64Binary credentials { get; set; }
Public Property credentials As base64Binary
    Get
    Set

Property Value

Type: base64Binary
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.Url Property

ImportServiceUrl Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.UseDefaultCredentials Property

ImportServiceUseDefaultCredentials Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseDefaultCredentials { get; set; }
Public Property UseDefaultCredentials As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService Methods

The ImportService type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
Protected method | BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync |
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Protected method | EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetContentTypeDescription |
Public method | GetContentTypeDescriptionAsync(GetContentTypeDescription) |
Public method | GetContentTypeDescriptionAsync(GetContentTypeDescription, Object) |
Public method | GetContentTypeList |
Public method | GetContentTypeListAsync(Object) |
Public method | GetContentTypeListAsync(Object, Object) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNewImportID |
Public method | GetNewImportIDAsync(Object) |
Public method | GetNewImportIDAsync(Object, Object) |
Protected method | GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
Public method | Import |
Public method | ImportAsync(Import) |
Public method | ImportAsync(Import, Object) |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TrackImport |
Public method | TrackImportAsync(TrackImport) |
Public method | TrackImportAsync(TrackImport, Object) |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.CancelAsync Method

ImportServiceCancelAsync Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CancelAsync(
    Object userState
)
Public Sub CancelAsync (
    userState As Object
)

Parameters

userState
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeDescription Method

ImportServiceGetContentTypeDescription Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContentTypeDescription GetContentTypeDescription(
    GetContentTypeDescription GetContentTypeDescription1
)
Public Function GetContentTypeDescription (
    GetContentTypeDescription1 As GetContentTypeDescription
) As ContentTypeDescription

Parameters

GetContentTypeDescription1
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescription

Return Value

Type: ContentTypeDescription
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeDescriptionAsync Method

ImportServiceGetContentTypeDescriptionAsync Method

Overload List
 | Name | Description
Public method | GetContentTypeDescriptionAsync(GetContentTypeDescription) |
Public method | GetContentTypeDescriptionAsync(GetContentTypeDescription, Object) |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeDescriptionAsync Method (GetContentTypeDescription)

ImportServiceGetContentTypeDescriptionAsync Method (GetContentTypeDescription)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetContentTypeDescriptionAsync(
    GetContentTypeDescription GetContentTypeDescription1
)
Public Sub GetContentTypeDescriptionAsync (
    GetContentTypeDescription1 As GetContentTypeDescription
)

Parameters

GetContentTypeDescription1
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescription
Remarks
See Also

Reference

ImportService Class
GetContentTypeDescriptionAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeDescriptionAsync Method (GetContentTypeDescription, Object)

ImportServiceGetContentTypeDescriptionAsync Method (GetContentTypeDescription, Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetContentTypeDescriptionAsync(
    GetContentTypeDescription GetContentTypeDescription1,
    Object userState
)
Public Sub GetContentTypeDescriptionAsync (
    GetContentTypeDescription1 As GetContentTypeDescription,
    userState As Object
)

Parameters

GetContentTypeDescription1
Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescription
userState
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
GetContentTypeDescriptionAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeList Method

ImportServiceGetContentTypeList Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetContentTypeList(
    Object GetContentTypeList1
)
Public Function GetContentTypeList (
    GetContentTypeList1 As Object
) As String()

Parameters

GetContentTypeList1
Type: SystemObject

Return Value

Type: String
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeListAsync Method

ImportServiceGetContentTypeListAsync Method

Overload List
 | Name | Description
Public method | GetContentTypeListAsync(Object) |
Public method | GetContentTypeListAsync(Object, Object) |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeListAsync Method (Object)

ImportServiceGetContentTypeListAsync Method (Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetContentTypeListAsync(
    Object GetContentTypeList1
)
Public Sub GetContentTypeListAsync (
    GetContentTypeList1 As Object
)

Parameters

GetContentTypeList1
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
GetContentTypeListAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeListAsync Method (Object, Object)

ImportServiceGetContentTypeListAsync Method (Object, Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetContentTypeListAsync(
    Object GetContentTypeList1,
    Object userState
)
Public Sub GetContentTypeListAsync (
    GetContentTypeList1 As Object,
    userState As Object
)

Parameters

GetContentTypeList1
Type: SystemObject
userState
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
GetContentTypeListAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetNewImportID Method

ImportServiceGetNewImportID Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GetNewImportIDResponse GetNewImportID(
    Object GetNewImportID1
)
Public Function GetNewImportID (
    GetNewImportID1 As Object
) As GetNewImportIDResponse

Parameters

GetNewImportID1
Type: SystemObject

Return Value

Type: GetNewImportIDResponse
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetNewImportIDAsync Method

ImportServiceGetNewImportIDAsync Method

Overload List
 | Name | Description
Public method | GetNewImportIDAsync(Object) |
Public method | GetNewImportIDAsync(Object, Object) |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetNewImportIDAsync Method (Object)

ImportServiceGetNewImportIDAsync Method (Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetNewImportIDAsync(
    Object GetNewImportID1
)
Public Sub GetNewImportIDAsync (
    GetNewImportID1 As Object
)

Parameters

GetNewImportID1
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
GetNewImportIDAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetNewImportIDAsync Method (Object, Object)

ImportServiceGetNewImportIDAsync Method (Object, Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetNewImportIDAsync(
    Object GetNewImportID1,
    Object userState
)
Public Sub GetNewImportIDAsync (
    GetNewImportID1 As Object,
    userState As Object
)

Parameters

GetNewImportID1
Type: SystemObject
userState
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
GetNewImportIDAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.Import Method

ImportServiceImport Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportResponse Import(
    Import Import1
)
Public Function Import (
    Import1 As Import
) As ImportResponse

Parameters

Import1
Type: Atalasoft.Imaging.WebControls.Capture.KicImport

Return Value

Type: ImportResponse
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.ImportAsync Method

ImportServiceImportAsync Method

Overload List
 | Name | Description
Public method | ImportAsync(Import) |
Public method | ImportAsync(Import, Object) |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.ImportAsync Method (Import)

ImportServiceImportAsync Method (Import)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ImportAsync(
    Import Import1
)
Public Sub ImportAsync (
    Import1 As Import
)

Parameters

Import1
Type: Atalasoft.Imaging.WebControls.Capture.KicImport
Remarks
See Also

Reference

ImportService Class
ImportAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.ImportAsync Method (Import, Object)

ImportServiceImportAsync Method (Import, Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ImportAsync(
    Import Import1,
    Object userState
)
Public Sub ImportAsync (
    Import1 As Import,
    userState As Object
)

Parameters

Import1
Type: Atalasoft.Imaging.WebControls.Capture.KicImport
userState
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
ImportAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.TrackImport Method

ImportServiceTrackImport Method

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportResponse TrackImport(
    TrackImport TrackImport1
)
Public Function TrackImport (
    TrackImport1 As TrackImport
) As TrackImportResponse

Parameters

TrackImport1
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImport

Return Value

Type: TrackImportResponse
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.TrackImportAsync Method

ImportServiceTrackImportAsync Method

Overload List
 | Name | Description
Public method | TrackImportAsync(TrackImport) |
Public method | TrackImportAsync(TrackImport, Object) |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.TrackImportAsync Method (TrackImport)

ImportServiceTrackImportAsync Method (TrackImport)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void TrackImportAsync(
    TrackImport TrackImport1
)
Public Sub TrackImportAsync (
    TrackImport1 As TrackImport
)

Parameters

TrackImport1
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImport
Remarks
See Also

Reference

ImportService Class
TrackImportAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.TrackImportAsync Method (TrackImport, Object)

ImportServiceTrackImportAsync Method (TrackImport, Object)

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void TrackImportAsync(
    TrackImport TrackImport1,
    Object userState
)
Public Sub TrackImportAsync (
    TrackImport1 As TrackImport,
    userState As Object
)

Parameters

TrackImport1
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImport
userState
Type: SystemObject
Remarks
See Also

Reference

ImportService Class
TrackImportAsync Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService Events

The ImportService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | GetContentTypeDescriptionCompleted |
Public event | GetContentTypeListCompleted |
Public event | GetNewImportIDCompleted |
Public event | ImportCompleted |
Public event | TrackImportCompleted |
Top
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeDescriptionCompleted Event

ImportServiceGetContentTypeDescriptionCompleted Event

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event GetContentTypeDescriptionCompletedEventHandler GetContentTypeDescriptionCompleted
Public Event GetContentTypeDescriptionCompleted As GetContentTypeDescriptionCompletedEventHandler

Value

Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeDescriptionCompletedEventHandler
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetContentTypeListCompleted Event

ImportServiceGetContentTypeListCompleted Event

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event GetContentTypeListCompletedEventHandler GetContentTypeListCompleted
Public Event GetContentTypeListCompleted As GetContentTypeListCompletedEventHandler

Value

Type: Atalasoft.Imaging.WebControls.Capture.KicGetContentTypeListCompletedEventHandler
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.GetNewImportIDCompleted Event

ImportServiceGetNewImportIDCompleted Event

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event GetNewImportIDCompletedEventHandler GetNewImportIDCompleted
Public Event GetNewImportIDCompleted As GetNewImportIDCompletedEventHandler

Value

Type: Atalasoft.Imaging.WebControls.Capture.KicGetNewImportIDCompletedEventHandler
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.ImportCompleted Event

ImportServiceImportCompleted Event

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImportCompletedEventHandler ImportCompleted
Public Event ImportCompleted As ImportCompletedEventHandler

Value

Type: Atalasoft.Imaging.WebControls.Capture.KicImportCompletedEventHandler
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportService.TrackImportCompleted Event

ImportServiceTrackImportCompleted Event

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event TrackImportCompletedEventHandler TrackImportCompleted
Public Event TrackImportCompleted As TrackImportCompletedEventHandler

Value

Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImportCompletedEventHandler
Remarks
See Also

Reference

ImportService Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicImportSession
Atalasoft.Imaging.WebControls.Capture.KicCustomImportSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImportSession
Public Class ImportSession

The ImportSession type exposes the following members.

Constructors
 | Name | Description
Public method | ImportSession | Initializes a new instance of the ImportSession class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Batches |
Public field | DeleteBatchOnError |
Public field | IntegratedAuthentication |
Public field | Password |
Public field | UserID |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession Constructor

Initializes a new instance of the ImportSession class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportSession()
Public Sub New
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession Methods

The ImportSession type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession Fields

The ImportSession type exposes the following members.

Fields
 | Name | Description
Public field | Batches |
Public field | DeleteBatchOnError |
Public field | IntegratedAuthentication |
Public field | Password |
Public field | UserID |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.Batches Field

ImportSessionBatches Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchType[] Batches
Public Batches As BatchType()

Field Value

Type: BatchType
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.DeleteBatchOnError Field

ImportSessionDeleteBatchOnError Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BoolType DeleteBatchOnError
Public DeleteBatchOnError As BoolType

Field Value

Type: BoolType
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.IntegratedAuthentication Field

ImportSessionIntegratedAuthentication Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BoolType IntegratedAuthentication
Public IntegratedAuthentication As BoolType

Field Value

Type: BoolType
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.Password Field

ImportSessionPassword Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Password
Public Password As String

Field Value

Type: String
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.UserID Field

ImportSessionUserID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UserID
Public UserID As String

Field Value

Type: String
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.XmlAnyAttribute Field

ImportSessionXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ImportSession.XmlAnyElements Field

ImportSessionXmlAnyElements Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] XmlAnyElements
Public XmlAnyElements As Object()

Field Value

Type: Object
Remarks
Caution note Caution
ImportSession class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

ImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicIndexFieldDefinition

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IndexFieldDefinition
Public Class IndexFieldDefinition

The IndexFieldDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | IndexFieldDefinition | Initializes a new instance of the IndexFieldDefinition class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | _2XReleaseID |
Public field | DefaultValue |
Public field | DisplayName |
Public field | FieldTypeName |
Public field | FieldValue |
Public field | Hidden |
Public field | Name |
Public field | Required |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition Constructor

Initializes a new instance of the IndexFieldDefinition class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexFieldDefinition()
Public Sub New
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition Methods

The IndexFieldDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition Fields

The IndexFieldDefinition type exposes the following members.

Fields
 | Name | Description
Public field | _2XReleaseID |
Public field | DefaultValue |
Public field | DisplayName |
Public field | FieldTypeName |
Public field | FieldValue |
Public field | Hidden |
Public field | Name |
Public field | Required |
Top
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition._2XReleaseID Field

IndexFieldDefinition_2XReleaseID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string _2XReleaseID
Public _2XReleaseID As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.DefaultValue Field

IndexFieldDefinitionDefaultValue Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultValue
Public DefaultValue As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.DisplayName Field

IndexFieldDefinitionDisplayName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DisplayName
Public DisplayName As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.FieldTypeName Field

IndexFieldDefinitionFieldTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldTypeName
Public FieldTypeName As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.FieldValue Field

IndexFieldDefinitionFieldValue Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldValue
Public FieldValue As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.Hidden Field

IndexFieldDefinitionHidden Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Hidden
Public Hidden As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.Name Field

IndexFieldDefinitionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldDefinition.Required Field

IndexFieldDefinitionRequired Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Required
Public Required As String

Field Value

Type: String
Remarks
See Also

Reference

IndexFieldDefinition Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicIndexFieldType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IndexFieldType
Public Class IndexFieldType

The IndexFieldType type exposes the following members.

Constructors
 | Name | Description
Public method | IndexFieldType | Initializes a new instance of the IndexFieldType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Public field | XmlAnyAttribute |
Top
Remarks
Caution note Caution
IndexFieldType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType Constructor

Initializes a new instance of the IndexFieldType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexFieldType()
Public Sub New
See Also

Reference

IndexFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType Methods

The IndexFieldType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IndexFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType Fields

The IndexFieldType type exposes the following members.

Fields
 | Name | Description
Public field | Name |
Public field | Value |
Public field | XmlAnyAttribute |
Top
See Also

Reference

IndexFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType.Name Field

IndexFieldTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
Caution note Caution
IndexFieldType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

IndexFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType.Value Field

IndexFieldTypeValue Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value
Public Value As String

Field Value

Type: String
Remarks
Caution note Caution
IndexFieldType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

IndexFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexFieldType.XmlAnyAttribute Field

IndexFieldTypeXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
See Also

Reference

IndexFieldType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicIndexZone

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IndexZone
Public Class IndexZone

The IndexZone type exposes the following members.

Constructors
 | Name | Description
Public method | IndexZone | Initializes a new instance of the IndexZone class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | IndexFieldDefinitionName |
Public field | PageNumber |
Public field | RecognitionProfileName |
Public field | ZoneHeight |
Public field | ZoneLeft |
Public field | ZoneTop |
Public field | ZoneWidth |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone Constructor

Initializes a new instance of the IndexZone class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexZone()
Public Sub New
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone Methods

The IndexZone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone Fields

The IndexZone type exposes the following members.

Fields
 | Name | Description
Public field | IndexFieldDefinitionName |
Public field | PageNumber |
Public field | RecognitionProfileName |
Public field | ZoneHeight |
Public field | ZoneLeft |
Public field | ZoneTop |
Public field | ZoneWidth |
Top
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.IndexFieldDefinitionName Field

IndexZoneIndexFieldDefinitionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IndexFieldDefinitionName
Public IndexFieldDefinitionName As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.PageNumber Field

IndexZonePageNumber Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PageNumber
Public PageNumber As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.RecognitionProfileName Field

IndexZoneRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RecognitionProfileName
Public RecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.ZoneHeight Field

IndexZoneZoneHeight Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ZoneHeight
Public ZoneHeight As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.ZoneLeft Field

IndexZoneZoneLeft Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ZoneLeft
Public ZoneLeft As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.ZoneTop Field

IndexZoneZoneTop Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ZoneTop
Public ZoneTop As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


IndexZone.ZoneWidth Field

IndexZoneZoneWidth Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ZoneWidth
Public ZoneWidth As String

Field Value

Type: String
Remarks
See Also

Reference

IndexZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController Class

This class handles the direct communication to the KIC web service proxy class.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicKicController

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class KicController
Public Class KicController

The KicController type exposes the following members.

Constructors
 | Name | Description
Public method | KicController | The constructor for the KicController class.
Top
Properties
 | Name | Description
Public property | FilePath | Gets or sets the path to the file to be imported on the server.
Public property | GetContentTypes | Returns the content types available.
Public property | GetNewImportID | Returns a new guid that can be used for a KIC import ID.
Public property | ImportId | Gets or sets the import ID.
Public property | KicEdServerEndpoint | Gets or sets the WCF service endpoint.
Public property | OwnerReference | Gets or sets the document owner reference on a document to be imported.
Top
Methods
 | Name | Description
Public method | Close | Closes the connection to the service.
Public method | CreateImportSession | Create an import session (a batch to be imported) based on a selected single document batch type
Public method | CreateLoosePageImportSession | Create an import session (a batch to be imported) based on a selected single document batch type
Public method | CreateSingleDocumentBatch | Creates a single document batch type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContentTypeDescriptions | Returns the content type descriptions for the given content type.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Call this to import a document to KIC.
Public method | ImportLoosePage | Call this to import a loose page to KIC.
Public method | ImportStatus | Returns the import status for the given import ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController Constructor

The constructor for the KicController class.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public KicController()
Public Sub New
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController Properties

The KicController type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets or sets the path to the file to be imported on the server.
Public property | GetContentTypes | Returns the content types available.
Public property | GetNewImportID | Returns a new guid that can be used for a KIC import ID.
Public property | ImportId | Gets or sets the import ID.
Public property | KicEdServerEndpoint | Gets or sets the WCF service endpoint.
Public property | OwnerReference | Gets or sets the document owner reference on a document to be imported.
Top
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.FilePath Property

KicControllerFilePath Property

Gets or sets the path to the file to be imported on the server.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.GetContentTypes Property

KicControllerGetContentTypes Property

Returns the content types available.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetContentTypes { get; }
Public ReadOnly Property GetContentTypes As String()
    Get

Property Value

Type: String
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.GetNewImportID Property

KicControllerGetNewImportID Property

Returns a new guid that can be used for a KIC import ID.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetNewImportID { get; }
Public ReadOnly Property GetNewImportID As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.ImportId Property

KicControllerImportId Property

Gets or sets the import ID.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportId { get; set; }
Public Property ImportId As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.KicEdServerEndpoint Property

KicControllerKicEdServerEndpoint Property

Gets or sets the WCF service endpoint.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KicEdServerEndpoint { get; }
Public ReadOnly Property KicEdServerEndpoint As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.OwnerReference Property

KicControllerOwnerReference Property

Gets or sets the document owner reference on a document to be imported.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OwnerReference { get; set; }
Public Property OwnerReference As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController Methods

The KicController type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the connection to the service.
Public method | CreateImportSession | Create an import session (a batch to be imported) based on a selected single document batch type
Public method | CreateLoosePageImportSession | Create an import session (a batch to be imported) based on a selected single document batch type
Public method | CreateSingleDocumentBatch | Creates a single document batch type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContentTypeDescriptions | Returns the content type descriptions for the given content type.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Call this to import a document to KIC.
Public method | ImportLoosePage | Call this to import a loose page to KIC.
Public method | ImportStatus | Returns the import status for the given import ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.Close Method

KicControllerClose Method

Closes the connection to the service.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.CreateImportSession Method

KicControllerCreateImportSession Method

Create an import session (a batch to be imported) based on a selected single document batch type

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomImportSession CreateImportSession(
    SingleDocumentBatchType batchType
)
Public Function CreateImportSession (
    batchType As SingleDocumentBatchType
) As CustomImportSession

Parameters

batchType
Type: Atalasoft.Imaging.WebControls.Capture.KicSingleDocumentBatchType
The BatchType to create a ImportSession with.

Return Value

Type: CustomImportSession
Returns a CustomImportSession.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.CreateLoosePageImportSession Method

KicControllerCreateLoosePageImportSession Method

Create an import session (a batch to be imported) based on a selected single document batch type

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomLoosePageImportSession CreateLoosePageImportSession(
    LoosePageBatch batchType
)
Public Function CreateLoosePageImportSession (
    batchType As LoosePageBatch
) As CustomLoosePageImportSession

Parameters

batchType
Type: Atalasoft.Imaging.WebControls.Capture.KicLoosePageBatch
The BatchType to create a ImportSession with.

Return Value

Type: CustomLoosePageImportSession
Returns a CustomImportSession.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.CreateSingleDocumentBatch Method

KicControllerCreateSingleDocumentBatch Method

Creates a single document batch type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SingleDocumentBatchType CreateSingleDocumentBatch(
    string batchId,
    string documentClass,
    string formType,
    IndexFieldDefinition[] indexFields
)
Public Function CreateSingleDocumentBatch (
    batchId As String,
    documentClass As String,
    formType As String,
    indexFields As IndexFieldDefinition()
) As SingleDocumentBatchType

Parameters

batchId
Type: SystemString
The ContentType selected is used for the batchId.
documentClass
Type: SystemString
The selected DocumentClass for the selected ContentType used to create the BatchType.
formType
Type: SystemString
The FormType to be added to the SingleDocumentBatchType.
indexFields
Type: Atalasoft.Imaging.WebControls.Capture.KicIndexFieldDefinition
The IndexFields for the slected DocumentClass to be added to the SingleDocumentBatchType.

Return Value

Type: SingleDocumentBatchType
Returns a SingleDocumentBatchType that can be used to create a CustomImportSession.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.GetContentTypeDescriptions Method

KicControllerGetContentTypeDescriptions Method

Returns the content type descriptions for the given content type.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetContentTypeDescriptions(
    string contentType
)
Public Function GetContentTypeDescriptions (
    contentType As String
) As String

Parameters

contentType
Type: SystemString
the selected ContentType.

Return Value

Type: String
Returns a string that contains the full ContentTypeDescription for the selected ContentType.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.Import Method

KicControllerImport Method

Call this to import a document to KIC.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Import(
    CustomImportSession importSession
)
Public Function Import (
    importSession As CustomImportSession
) As String

Parameters

importSession
Type: Atalasoft.Imaging.WebControls.Capture.KicCustomImportSession
The ImportSession to be imported into KIC.

Return Value

Type: String
Returns a string with the importID, and status.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.ImportLoosePage Method

KicControllerImportLoosePage Method

Call this to import a loose page to KIC.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportLoosePage(
    LoosePageImportSession importSession
)
Public Function ImportLoosePage (
    importSession As LoosePageImportSession
) As String

Parameters

importSession
Type: Atalasoft.Imaging.WebControls.Capture.KicLoosePageImportSession
The ImportSession to be imported into KIC.

Return Value

Type: String
Returns a string with the importID, and status.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicController.ImportStatus Method

KicControllerImportStatus Method

Returns the import status for the given import ID.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportStatus(
    string importId
)
Public Function ImportStatus (
    importId As String
) As String

Parameters

importId
Type: SystemString
The guid, in string form, of the ImportID.

Return Value

Type: String
Returns a string that contains the status of the Import into KIC for the ImportID passed in.
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicController Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger Class

A helper class that writes to the Event log.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicKicLogger

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class KicLogger : IDisposable
Public Class KicLogger
    Implements IDisposable

The KicLogger type exposes the following members.

Constructors
 | Name | Description
Public method | KicLogger | Initializes a new instance of the KicLogger class
Top
Methods
 | Name | Description
 | Close | Static method to close the logger.
Public method | Dispose | Method to dispose the KicLogger.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteException | Writes an exception to the Kic log file.
 | WriteToAppLog | Method to write informational messages to the Kic log file.
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger Constructor

Initializes a new instance of the KicLogger class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public KicLogger()
Public Sub New
See Also

Reference

KicLogger Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger Methods

The KicLogger type exposes the following members.

Methods
 | Name | Description
 | Close | Static method to close the logger.
Public method | Dispose | Method to dispose the KicLogger.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteException | Writes an exception to the Kic log file.
 | WriteToAppLog | Method to write informational messages to the Kic log file.
Top
See Also

Reference

KicLogger Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger.Close Method

KicLoggerClose Method

Static method to close the logger.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Close()
Public Shared Sub Close
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicLogger Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger.Dispose Method

KicLoggerDispose Method

Method to dispose the KicLogger.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
Caution note Caution
KicController class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicLogger Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger.WriteException Method

KicLoggerWriteException Method

Writes an exception to the Kic log file.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void WriteException(
    Exception ex,
    string message
)
Public Shared Sub WriteException (
    ex As Exception,
    message As String
)

Parameters

ex
Type: SystemException
The exception thrown.
message
Type: SystemString
An additional message which is to be included along with the actual exception in the log file.
Remarks
Caution note Caution
KicLogger class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicLogger Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


KicLogger.WriteToAppLog Method

KicLoggerWriteToAppLog Method

Method to write informational messages to the Kic log file.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void WriteToAppLog(
    string message
)
Public Shared Sub WriteToAppLog (
    message As String
)

Parameters

message
Type: SystemString
The message to be written to the log file.
Remarks
Caution note Caution
KicLogger class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

KicLogger Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch Class

A collection of BatchFieldDefinitions.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicLoosePageBatch

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LoosePageBatch
Public Class LoosePageBatch

The LoosePageBatch type exposes the following members.

Constructors
 | Name | Description
Public method | LoosePageBatch | Default constructor.
Top
Properties
 | Name | Description
Public property | BatchClassName | The batch class name.
Public property | BatchFieldDefinitions | The array of BatchFieldDefinitions.
Public property | SingleDocumentBatchTypeName | Get the document type name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch Constructor

Default constructor.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LoosePageBatch()
Public Sub New
Remarks
Caution note Caution
LoosePageBatch class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatch Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch Properties

The LoosePageBatch type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | The batch class name.
Public property | BatchFieldDefinitions | The array of BatchFieldDefinitions.
Public property | SingleDocumentBatchTypeName | Get the document type name
Top
See Also

Reference

LoosePageBatch Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch.BatchClassName Property

LoosePageBatchBatchClassName Property

The batch class name.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchClassName { get; set; }
Public Property BatchClassName As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
LoosePageBatch class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatch Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch.BatchFieldDefinitions Property

LoosePageBatchBatchFieldDefinitions Property

The array of BatchFieldDefinitions.

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchFieldDefinition[] BatchFieldDefinitions { get; set; }
Public Property BatchFieldDefinitions As BatchFieldDefinition()
    Get
    Set

Property Value

Type: BatchFieldDefinition
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatch Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch.SingleDocumentBatchTypeName Property

LoosePageBatchSingleDocumentBatchTypeName Property

Get the document type name

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SingleDocumentBatchTypeName { get; }
Public ReadOnly Property SingleDocumentBatchTypeName As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatch Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatch Methods

The LoosePageBatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoosePageBatch Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicLoosePageBatchType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LoosePageBatchType
Public Class LoosePageBatchType

The LoosePageBatchType type exposes the following members.

Constructors
 | Name | Description
Public method | LoosePageBatchType | Initializes a new instance of the LoosePageBatchType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BatchClassName |
Public field | BatchFields |
Public field | EnableAutomaticSeparationAndFormID |
Public field | Name |
Public field | Pages |
Public field | RelativeImageFilePath |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType Constructor

Initializes a new instance of the LoosePageBatchType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LoosePageBatchType()
Public Sub New
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType Methods

The LoosePageBatchType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType Fields

The LoosePageBatchType type exposes the following members.

Fields
 | Name | Description
Public field | BatchClassName |
Public field | BatchFields |
Public field | EnableAutomaticSeparationAndFormID |
Public field | Name |
Public field | Pages |
Public field | RelativeImageFilePath |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.BatchClassName Field

LoosePageBatchTypeBatchClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchClassName
Public BatchClassName As String

Field Value

Type: String
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.BatchFields Field

LoosePageBatchTypeBatchFields Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchTypeBatchField[] BatchFields
Public BatchFields As BatchTypeBatchField()

Field Value

Type: BatchTypeBatchField
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.EnableAutomaticSeparationAndFormID Field

LoosePageBatchTypeEnableAutomaticSeparationAndFormID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BoolType EnableAutomaticSeparationAndFormID
Public EnableAutomaticSeparationAndFormID As BoolType

Field Value

Type: BoolType
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.Name Field

LoosePageBatchTypeName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.Pages Field

LoosePageBatchTypePages Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageType[] Pages
Public Pages As PageType()

Field Value

Type: PageType
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.RelativeImageFilePath Field

LoosePageBatchTypeRelativeImageFilePath Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RelativeImageFilePath
Public RelativeImageFilePath As String

Field Value

Type: String
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.XmlAnyAttribute Field

LoosePageBatchTypeXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageBatchType.XmlAnyElements Field

LoosePageBatchTypeXmlAnyElements Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] XmlAnyElements
Public XmlAnyElements As Object()

Field Value

Type: Object
Remarks
Caution note Caution
LoosePageBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicLoosePageImportSession
Atalasoft.Imaging.WebControls.Capture.KicCustomLoosePageImportSession

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LoosePageImportSession
Public Class LoosePageImportSession

The LoosePageImportSession type exposes the following members.

Constructors
 | Name | Description
Public method | LoosePageImportSession | Initializes a new instance of the LoosePageImportSession class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Batches |
Public field | Password |
Public field | UserID |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession Constructor

Initializes a new instance of the LoosePageImportSession class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LoosePageImportSession()
Public Sub New
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession Methods

The LoosePageImportSession type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession Fields

The LoosePageImportSession type exposes the following members.

Fields
 | Name | Description
Public field | Batches |
Public field | Password |
Public field | UserID |
Public field | XmlAnyAttribute |
Public field | XmlAnyElements |
Top
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession.Batches Field

LoosePageImportSessionBatches Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LoosePageBatchType[] Batches
Public Batches As LoosePageBatchType()

Field Value

Type: LoosePageBatchType
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession.Password Field

LoosePageImportSessionPassword Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Password
Public Password As String

Field Value

Type: String
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession.UserID Field

LoosePageImportSessionUserID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UserID
Public UserID As String

Field Value

Type: String
Remarks
Caution note Caution
BatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession.XmlAnyAttribute Field

LoosePageImportSessionXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


LoosePageImportSession.XmlAnyElements Field

LoosePageImportSessionXmlAnyElements Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object[] XmlAnyElements
Public XmlAnyElements As Object()

Field Value

Type: Object
See Also

Reference

LoosePageImportSession Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Module Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicModule

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Module
Public Class Module

The Module type exposes the following members.

Constructors
 | Name | Description
Public method | Module | Initializes a new instance of the Module class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ExceptionModuleID |
Public field | ModuleID |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Module Constructor

Initializes a new instance of the Module class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Module()
Public Sub New
See Also

Reference

Module Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Module Methods

The Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Module Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Module Fields

The Module type exposes the following members.

Fields
 | Name | Description
Public field | ExceptionModuleID |
Public field | ModuleID |
Top
See Also

Reference

Module Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Module.ExceptionModuleID Field

ModuleExceptionModuleID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ExceptionModuleID
Public ExceptionModuleID As String

Field Value

Type: String
Remarks
See Also

Reference

Module Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Module.ModuleID Field

ModuleModuleID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ModuleID
Public ModuleID As String

Field Value

Type: String
Remarks
See Also

Reference

Module Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


NewDataSet Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicNewDataSet

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class NewDataSet
Public Class NewDataSet

The NewDataSet type exposes the following members.

Constructors
 | Name | Description
Public method | NewDataSet | Initializes a new instance of the NewDataSet class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Items |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


NewDataSet Constructor

Initializes a new instance of the NewDataSet class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NewDataSet()
Public Sub New
See Also

Reference

NewDataSet Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


NewDataSet Methods

The NewDataSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewDataSet Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


NewDataSet Fields

The NewDataSet type exposes the following members.

Fields
 | Name | Description
Public field | Items |
Top
See Also

Reference

NewDataSet Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


NewDataSet.Items Field

NewDataSetItems Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AscentCaptureSetup[] Items
Public Items As AscentCaptureSetup()

Field Value

Type: AscentCaptureSetup
Remarks
See Also

Reference

NewDataSet Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicOcrOptions

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrOptions
Public Class OcrOptions

The OcrOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OcrOptions | Initializes a new instance of the OcrOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Content |
Public field | FixedPitch |
Public field | MarkLevel |
Public field | Points |
Public field | TextFill |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions Constructor

Initializes a new instance of the OcrOptions class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrOptions()
Public Sub New
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions Methods

The OcrOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions Fields

The OcrOptions type exposes the following members.

Fields
 | Name | Description
Public field | Content |
Public field | FixedPitch |
Public field | MarkLevel |
Public field | Points |
Public field | TextFill |
Top
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions.Content Field

OcrOptionsContent Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Content
Public Content As String

Field Value

Type: String
Remarks
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions.FixedPitch Field

OcrOptionsFixedPitch Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FixedPitch
Public FixedPitch As String

Field Value

Type: String
Remarks
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions.MarkLevel Field

OcrOptionsMarkLevel Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MarkLevel
Public MarkLevel As String

Field Value

Type: String
Remarks
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions.Points Field

OcrOptionsPoints Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Points
Public Points As String

Field Value

Type: String
Remarks
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OcrOptions.TextFill Field

OcrOptionsTextFill Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TextFill
Public TextFill As String

Field Value

Type: String
Remarks
See Also

Reference

OcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OmrOptions Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicOmrOptions

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmrOptions
Public Class OmrOptions

The OmrOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OmrOptions | Initializes a new instance of the OmrOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Shape |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OmrOptions Constructor

Initializes a new instance of the OmrOptions class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrOptions()
Public Sub New
See Also

Reference

OmrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OmrOptions Methods

The OmrOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OmrOptions Fields

The OmrOptions type exposes the following members.

Fields
 | Name | Description
Public field | Shape |
Top
See Also

Reference

OmrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


OmrOptions.Shape Field

OmrOptionsShape Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Shape
Public Shape As String

Field Value

Type: String
Remarks
See Also

Reference

OmrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PageType Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicPageType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageType
Public Class PageType

The PageType type exposes the following members.

Constructors
 | Name | Description
Public method | PageType | Initializes a new instance of the PageType class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ImportFileName |
Public field | XmlAnyAttribute |
Top
Remarks
Caution note Caution
PageType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PageType Constructor

Initializes a new instance of the PageType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageType()
Public Sub New
See Also

Reference

PageType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PageType Methods

The PageType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PageType Fields

The PageType type exposes the following members.

Fields
 | Name | Description
Public field | ImportFileName |
Public field | XmlAnyAttribute |
Top
See Also

Reference

PageType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PageType.ImportFileName Field

PageTypeImportFileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportFileName
Public ImportFileName As String

Field Value

Type: String
Remarks
Caution note Caution
PageType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

PageType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PageType.XmlAnyAttribute Field

PageTypeXmlAnyAttribute Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlAttribute[] XmlAnyAttribute
Public XmlAnyAttribute As XmlAttribute()

Field Value

Type: XmlAttribute
See Also

Reference

PageType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicPDFProperty

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PDFProperty
Public Class PDFProperty

The PDFProperty type exposes the following members.

Constructors
 | Name | Description
Public method | PDFProperty | Initializes a new instance of the PDFProperty class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BatchFieldDefinitionName |
Public field | DocumentClassName |
Public field | IndexFieldDefinitionName |
Public field | SourceType |
Public field | Type |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty Constructor

Initializes a new instance of the PDFProperty class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PDFProperty()
Public Sub New
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty Methods

The PDFProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty Fields

The PDFProperty type exposes the following members.

Fields
 | Name | Description
Public field | BatchFieldDefinitionName |
Public field | DocumentClassName |
Public field | IndexFieldDefinitionName |
Public field | SourceType |
Public field | Type |
Top
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty.BatchFieldDefinitionName Field

PDFPropertyBatchFieldDefinitionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchFieldDefinitionName
Public BatchFieldDefinitionName As String

Field Value

Type: String
Remarks
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty.DocumentClassName Field

PDFPropertyDocumentClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentClassName
Public DocumentClassName As String

Field Value

Type: String
Remarks
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty.IndexFieldDefinitionName Field

PDFPropertyIndexFieldDefinitionName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IndexFieldDefinitionName
Public IndexFieldDefinitionName As String

Field Value

Type: String
Remarks
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty.SourceType Field

PDFPropertySourceType Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SourceType
Public SourceType As String

Field Value

Type: String
Remarks
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


PDFProperty.Type Field

PDFPropertyType Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Type
Public Type As String

Field Value

Type: String
Remarks
See Also

Reference

PDFProperty Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicProcess

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Process
Public Class Process

The Process type exposes the following members.

Constructors
 | Name | Description
Public method | Process | Initializes a new instance of the Process class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | After |
Public field | Before |
Public field | Custom |
Public field | Description |
Public field | ImageIndex |
Public field | ModuleID |
Public field | Name |
Public field | ProcessID |
Public field | Program |
Public field | ReplacesFunctions |
Public field | SupportsNonImageFiles |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process Constructor

Initializes a new instance of the Process class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Process()
Public Sub New
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process Methods

The Process type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process Fields

The Process type exposes the following members.

Fields
 | Name | Description
Public field | After |
Public field | Before |
Public field | Custom |
Public field | Description |
Public field | ImageIndex |
Public field | ModuleID |
Public field | Name |
Public field | ProcessID |
Public field | Program |
Public field | ReplacesFunctions |
Public field | SupportsNonImageFiles |
Top
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.After Field

ProcessAfter Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string After
Public After As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.Before Field

ProcessBefore Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Before
Public Before As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.Custom Field

ProcessCustom Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Custom
Public Custom As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.Description Field

ProcessDescription Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description
Public Description As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.ImageIndex Field

ProcessImageIndex Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageIndex
Public ImageIndex As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.ModuleID Field

ProcessModuleID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ModuleID
Public ModuleID As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.Name Field

ProcessName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.ProcessID Field

ProcessProcessID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ProcessID
Public ProcessID As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.Program Field

ProcessProgram Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Program
Public Program As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.ReplacesFunctions Field

ProcessReplacesFunctions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FunctionsReplaces[] ReplacesFunctions
Public ReplacesFunctions As FunctionsReplaces()

Field Value

Type: FunctionsReplaces
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Process.SupportsNonImageFiles Field

ProcessSupportsNonImageFiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SupportsNonImageFiles
Public SupportsNonImageFiles As String

Field Value

Type: String
Remarks
See Also

Reference

Process Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicRecognitionProfile

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RecognitionProfile
Public Class RecognitionProfile

The RecognitionProfile type exposes the following members.

Constructors
 | Name | Description
Public method | RecognitionProfile | Initializes a new instance of the RecognitionProfile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | AdvancedOcrOptions |
Public field | BarCodeOptions |
Public field | DefaultFor |
Public field | FormIDOptions |
Public field | IcrOptions |
Public field | ImageCleanupProfileName |
Public field | KofaxID |
Public field | Name |
Public field | OcrOptions |
Public field | OmrOptions |
Public field | ReadOnly |
Public field | ScriptName |
Public field | Type |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile Constructor

Initializes a new instance of the RecognitionProfile class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RecognitionProfile()
Public Sub New
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile Methods

The RecognitionProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile Fields

The RecognitionProfile type exposes the following members.

Fields
 | Name | Description
Public field | AdvancedOcrOptions |
Public field | BarCodeOptions |
Public field | DefaultFor |
Public field | FormIDOptions |
Public field | IcrOptions |
Public field | ImageCleanupProfileName |
Public field | KofaxID |
Public field | Name |
Public field | OcrOptions |
Public field | OmrOptions |
Public field | ReadOnly |
Public field | ScriptName |
Public field | Type |
Top
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.AdvancedOcrOptions Field

RecognitionProfileAdvancedOcrOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AdvancedOcrOptions[] AdvancedOcrOptions
Public AdvancedOcrOptions As AdvancedOcrOptions()

Field Value

Type: AdvancedOcrOptions
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.BarCodeOptions Field

RecognitionProfileBarCodeOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeOptions[] BarCodeOptions
Public BarCodeOptions As BarCodeOptions()

Field Value

Type: BarCodeOptions
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.DefaultFor Field

RecognitionProfileDefaultFor Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultFor
Public DefaultFor As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.FormIDOptions Field

RecognitionProfileFormIDOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FormIDOptions
Public FormIDOptions As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.IcrOptions Field

RecognitionProfileIcrOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RecognitionProfileIcrOptions[] IcrOptions
Public IcrOptions As RecognitionProfileIcrOptions()

Field Value

Type: RecognitionProfileIcrOptions
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.ImageCleanupProfileName Field

RecognitionProfileImageCleanupProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageCleanupProfileName
Public ImageCleanupProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.KofaxID Field

RecognitionProfileKofaxID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KofaxID
Public KofaxID As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.Name Field

RecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.OcrOptions Field

RecognitionProfileOcrOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrOptions[] OcrOptions
Public OcrOptions As OcrOptions()

Field Value

Type: OcrOptions
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.OmrOptions Field

RecognitionProfileOmrOptions Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmrOptions[] OmrOptions
Public OmrOptions As OmrOptions()

Field Value

Type: OmrOptions
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.ReadOnly Field

RecognitionProfileReadOnly Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReadOnly
Public ReadOnly As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.ScriptName Field

RecognitionProfileScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScriptName
Public ScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfile.Type Field

RecognitionProfileType Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Type
Public Type As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicRecognitionProfileIcrOptions

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RecognitionProfileIcrOptions
Public Class RecognitionProfileIcrOptions

The RecognitionProfileIcrOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecognitionProfileIcrOptions | Initializes a new instance of the RecognitionProfileIcrOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | AllowedChars |
Public field | HandprintPitch |
Public field | Language |
Public field | MarkLevel |
Public field | SyntaxMode |
Public field | TextFlag |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions Constructor

Initializes a new instance of the RecognitionProfileIcrOptions class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RecognitionProfileIcrOptions()
Public Sub New
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions Methods

The RecognitionProfileIcrOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions Fields

The RecognitionProfileIcrOptions type exposes the following members.

Fields
 | Name | Description
Public field | AllowedChars |
Public field | HandprintPitch |
Public field | Language |
Public field | MarkLevel |
Public field | SyntaxMode |
Public field | TextFlag |
Top
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions.AllowedChars Field

RecognitionProfileIcrOptionsAllowedChars Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AllowedChars
Public AllowedChars As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions.HandprintPitch Field

RecognitionProfileIcrOptionsHandprintPitch Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HandprintPitch
Public HandprintPitch As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions.Language Field

RecognitionProfileIcrOptionsLanguage Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Language
Public Language As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions.MarkLevel Field

RecognitionProfileIcrOptionsMarkLevel Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MarkLevel
Public MarkLevel As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions.SyntaxMode Field

RecognitionProfileIcrOptionsSyntaxMode Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SyntaxMode
Public SyntaxMode As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


RecognitionProfileIcrOptions.TextFlag Field

RecognitionProfileIcrOptionsTextFlag Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TextFlag
Public TextFlag As String

Field Value

Type: String
Remarks
See Also

Reference

RecognitionProfileIcrOptions Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicReleaseLink

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ReleaseLink
Public Class ReleaseLink

The ReleaseLink type exposes the following members.

Constructors
 | Name | Description
Public method | ReleaseLink | Initializes a new instance of the ReleaseLink class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Destination |
Public field | Source |
Public field | SourceType |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink Constructor

Initializes a new instance of the ReleaseLink class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleaseLink()
Public Sub New
See Also

Reference

ReleaseLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink Methods

The ReleaseLink type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReleaseLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink Fields

The ReleaseLink type exposes the following members.

Fields
 | Name | Description
Public field | Destination |
Public field | Source |
Public field | SourceType |
Top
See Also

Reference

ReleaseLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink.Destination Field

ReleaseLinkDestination Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Destination
Public Destination As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink.Source Field

ReleaseLinkSource Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Source
Public Source As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseLink.SourceType Field

ReleaseLinkSourceType Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SourceType
Public SourceType As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseLink Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicReleaseScript

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ReleaseScript
Public Class ReleaseScript

The ReleaseScript type exposes the following members.

Constructors
 | Name | Description
Public method | ReleaseScript | Initializes a new instance of the ReleaseScript class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Name |
Public field | ReleaseProgID |
Public field | ReleaseVersion |
Public field | RemainLoaded |
Public field | SetupProgID |
Public field | SetupVersion |
Public field | SupportsKofaxPDF |
Public field | SupportsNonImageFiles |
Public field | SupportsOriginalFileName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript Constructor

Initializes a new instance of the ReleaseScript class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleaseScript()
Public Sub New
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript Methods

The ReleaseScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript Fields

The ReleaseScript type exposes the following members.

Fields
 | Name | Description
Public field | Name |
Public field | ReleaseProgID |
Public field | ReleaseVersion |
Public field | RemainLoaded |
Public field | SetupProgID |
Public field | SetupVersion |
Public field | SupportsKofaxPDF |
Public field | SupportsNonImageFiles |
Public field | SupportsOriginalFileName |
Top
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.Name Field

ReleaseScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.ReleaseProgID Field

ReleaseScriptReleaseProgID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReleaseProgID
Public ReleaseProgID As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.ReleaseVersion Field

ReleaseScriptReleaseVersion Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReleaseVersion
Public ReleaseVersion As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.RemainLoaded Field

ReleaseScriptRemainLoaded Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RemainLoaded
Public RemainLoaded As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.SetupProgID Field

ReleaseScriptSetupProgID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SetupProgID
Public SetupProgID As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.SetupVersion Field

ReleaseScriptSetupVersion Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SetupVersion
Public SetupVersion As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.SupportsKofaxPDF Field

ReleaseScriptSupportsKofaxPDF Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SupportsKofaxPDF
Public SupportsKofaxPDF As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.SupportsNonImageFiles Field

ReleaseScriptSupportsNonImageFiles Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SupportsNonImageFiles
Public SupportsNonImageFiles As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseScript.SupportsOriginalFileName Field

ReleaseScriptSupportsOriginalFileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SupportsOriginalFileName
Public SupportsOriginalFileName As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseScript Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicReleaseSetup

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ReleaseSetup
Public Class ReleaseSetup

The ReleaseSetup type exposes the following members.

Constructors
 | Name | Description
Public method | ReleaseSetup | Initializes a new instance of the ReleaseSetup class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | CustomProperties |
Public field | DocumentClassName |
Public field | KofaxPDFDir |
Public field | Name |
Public field | New |
Public field | ReleaseDir |
Public field | ReleaseLinks |
Public field | ReleaseScriptName |
Public field | RelSetupID |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup Constructor

Initializes a new instance of the ReleaseSetup class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleaseSetup()
Public Sub New
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup Methods

The ReleaseSetup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup Fields

The ReleaseSetup type exposes the following members.

Fields
 | Name | Description
Public field | CustomProperties |
Public field | DocumentClassName |
Public field | KofaxPDFDir |
Public field | Name |
Public field | New |
Public field | ReleaseDir |
Public field | ReleaseLinks |
Public field | ReleaseScriptName |
Public field | RelSetupID |
Top
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.CustomProperties Field

ReleaseSetupCustomProperties Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomProperty[] CustomProperties
Public CustomProperties As CustomProperty()

Field Value

Type: CustomProperty
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.DocumentClassName Field

ReleaseSetupDocumentClassName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentClassName
Public DocumentClassName As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.KofaxPDFDir Field

ReleaseSetupKofaxPDFDir Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KofaxPDFDir
Public KofaxPDFDir As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.Name Field

ReleaseSetupName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.New Field

ReleaseSetupNew Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string New
Public New As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.ReleaseDir Field

ReleaseSetupReleaseDir Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReleaseDir
Public ReleaseDir As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.ReleaseLinks Field

ReleaseSetupReleaseLinks Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReleaseLink[] ReleaseLinks
Public ReleaseLinks As ReleaseLink()

Field Value

Type: ReleaseLink
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.ReleaseScriptName Field

ReleaseSetupReleaseScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReleaseScriptName
Public ReleaseScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


ReleaseSetup.RelSetupID Field

ReleaseSetupRelSetupID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RelSetupID
Public RelSetupID As String

Field Value

Type: String
Remarks
See Also

Reference

ReleaseSetup Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicScript

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Script
Public Class Script

The Script type exposes the following members.

Constructors
 | Name | Description
Public method | Script | Initializes a new instance of the Script class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Name |
Public field | SblScriptID |
Public field | Type |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script Constructor

Initializes a new instance of the Script class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Script()
Public Sub New
See Also

Reference

Script Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script Methods

The Script type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Script Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script Fields

The Script type exposes the following members.

Fields
 | Name | Description
Public field | Name |
Public field | SblScriptID |
Public field | Type |
Top
See Also

Reference

Script Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script.Name Field

ScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

Script Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script.SblScriptID Field

ScriptSblScriptID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SblScriptID
Public SblScriptID As String

Field Value

Type: String
Remarks
See Also

Reference

Script Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Script.Type Field

ScriptType Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Type
Public Type As String

Field Value

Type: String
Remarks
See Also

Reference

Script Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicSeparationFormIDProfile

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SeparationFormIDProfile
Public Class SeparationFormIDProfile

The SeparationFormIDProfile type exposes the following members.

Constructors
 | Name | Description
Public method | SeparationFormIDProfile | Initializes a new instance of the SeparationFormIDProfile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | FormIDProfile |
Public field | KofaxID |
Public field | Name |
Public field | ReadOnly |
Public field | ScriptName |
Public field | SeparationProfile |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile Constructor

Initializes a new instance of the SeparationFormIDProfile class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparationFormIDProfile()
Public Sub New
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile Methods

The SeparationFormIDProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile Fields

The SeparationFormIDProfile type exposes the following members.

Fields
 | Name | Description
Public field | FormIDProfile |
Public field | KofaxID |
Public field | Name |
Public field | ReadOnly |
Public field | ScriptName |
Public field | SeparationProfile |
Top
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile.FormIDProfile Field

SeparationFormIDProfileFormIDProfile Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormIDProfile[] FormIDProfile
Public FormIDProfile As FormIDProfile()

Field Value

Type: FormIDProfile
Remarks
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile.KofaxID Field

SeparationFormIDProfileKofaxID Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string KofaxID
Public KofaxID As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile.Name Field

SeparationFormIDProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name
Public Name As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile.ReadOnly Field

SeparationFormIDProfileReadOnly Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ReadOnly
Public ReadOnly As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile.ScriptName Field

SeparationFormIDProfileScriptName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ScriptName
Public ScriptName As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationFormIDProfile.SeparationProfile Field

SeparationFormIDProfileSeparationProfile Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparationProfile[] SeparationProfile
Public SeparationProfile As SeparationProfile()

Field Value

Type: SeparationProfile
Remarks
See Also

Reference

SeparationFormIDProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicSeparationProfile

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SeparationProfile
Public Class SeparationProfile

The SeparationProfile type exposes the following members.

Constructors
 | Name | Description
Public method | SeparationProfile | Initializes a new instance of the SeparationProfile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Confidence |
Public field | Difference |
Public field | FirstPageRecognitionProfileName |
Public field | Method |
Public field | SeparatorSheetRecognitionProfileName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile Constructor

Initializes a new instance of the SeparationProfile class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparationProfile()
Public Sub New
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile Methods

The SeparationProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile Fields

The SeparationProfile type exposes the following members.

Fields
 | Name | Description
Public field | Confidence |
Public field | Difference |
Public field | FirstPageRecognitionProfileName |
Public field | Method |
Public field | SeparatorSheetRecognitionProfileName |
Top
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile.Confidence Field

SeparationProfileConfidence Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Confidence
Public Confidence As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile.Difference Field

SeparationProfileDifference Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Difference
Public Difference As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile.FirstPageRecognitionProfileName Field

SeparationProfileFirstPageRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FirstPageRecognitionProfileName
Public FirstPageRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile.Method Field

SeparationProfileMethod Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Method
Public Method As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationProfile.SeparatorSheetRecognitionProfileName Field

SeparationProfileSeparatorSheetRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SeparatorSheetRecognitionProfileName
Public SeparatorSheetRecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationProfile Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationZone Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicSeparationZone

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SeparationZone
Public Class SeparationZone

The SeparationZone type exposes the following members.

Constructors
 | Name | Description
Public method | SeparationZone | Initializes a new instance of the SeparationZone class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Confidence |
Public field | RecognitionProfileName |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationZone Constructor

Initializes a new instance of the SeparationZone class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparationZone()
Public Sub New
See Also

Reference

SeparationZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationZone Methods

The SeparationZone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SeparationZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationZone Fields

The SeparationZone type exposes the following members.

Fields
 | Name | Description
Public field | Confidence |
Public field | RecognitionProfileName |
Top
See Also

Reference

SeparationZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationZone.Confidence Field

SeparationZoneConfidence Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Confidence
Public Confidence As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SeparationZone.RecognitionProfileName Field

SeparationZoneRecognitionProfileName Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RecognitionProfileName
Public RecognitionProfileName As String

Field Value

Type: String
Remarks
See Also

Reference

SeparationZone Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType Class

This class implements the structure of a single document batch type and is a helper class only
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicSingleDocumentBatchType

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SingleDocumentBatchType
Public Class SingleDocumentBatchType

The SingleDocumentBatchType type exposes the following members.

Constructors
 | Name | Description
Public method | SingleDocumentBatchType | Initializes a new instance of the SingleDocumentBatchType class
Top
Properties
 | Name | Description
Public property | BatchClassName |
Public property | BatchFieldDefinitions |
Public property | DocumentClassName |
Public property | FormTypenameName |
Public property | IndexFieldDefinitions |
Public property | SingleDocumentBatchTypeName | Get the document type name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType Constructor

Initializes a new instance of the SingleDocumentBatchType class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SingleDocumentBatchType()
Public Sub New
Remarks
Caution note Caution
SingleDocumentBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType Properties

The SingleDocumentBatchType type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName |
Public property | BatchFieldDefinitions |
Public property | DocumentClassName |
Public property | FormTypenameName |
Public property | IndexFieldDefinitions |
Public property | SingleDocumentBatchTypeName | Get the document type name
Top
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType.BatchClassName Property

SingleDocumentBatchTypeBatchClassName Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BatchClassName { get; set; }
Public Property BatchClassName As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
SingleDocumentBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType.BatchFieldDefinitions Property

SingleDocumentBatchTypeBatchFieldDefinitions Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchFieldDefinition[] BatchFieldDefinitions { get; set; }
Public Property BatchFieldDefinitions As BatchFieldDefinition()
    Get
    Set

Property Value

Type: BatchFieldDefinition
Remarks
Caution note Caution
SingleDocumentBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType.DocumentClassName Property

SingleDocumentBatchTypeDocumentClassName Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DocumentClassName { get; set; }
Public Property DocumentClassName As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
SingleDocumentBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType.FormTypenameName Property

SingleDocumentBatchTypeFormTypenameName Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FormTypenameName { get; set; }
Public Property FormTypenameName As String
    Get
    Set

Property Value

Type: String
Remarks
Caution note Caution
SingleDocumentBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType.IndexFieldDefinitions Property

SingleDocumentBatchTypeIndexFieldDefinitions Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IndexFieldDefinition[] IndexFieldDefinitions { get; set; }
Public Property IndexFieldDefinitions As IndexFieldDefinition()
    Get
    Set

Property Value

Type: IndexFieldDefinition
Remarks
Caution note Caution
SingleDocumentBatchType class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType.SingleDocumentBatchTypeName Property

SingleDocumentBatchTypeSingleDocumentBatchTypeName Property

Get the document type name

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SingleDocumentBatchTypeName { get; }
Public ReadOnly Property SingleDocumentBatchTypeName As String
    Get

Property Value

Type: String
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


SingleDocumentBatchType Methods

The SingleDocumentBatchType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SingleDocumentBatchType Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImport Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicTrackImport

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TrackImport
<SerializableAttribute>
Public Class TrackImport

The TrackImport type exposes the following members.

Constructors
 | Name | Description
Public method | TrackImport | Initializes a new instance of the TrackImport class
Top
Properties
 | Name | Description
Public property | ImportID |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImport Constructor

Initializes a new instance of the TrackImport class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImport()
Public Sub New
See Also

Reference

TrackImport Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImport Properties

The TrackImport type exposes the following members.

Properties
 | Name | Description
Public property | ImportID |
Top
See Also

Reference

TrackImport Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImport.ImportID Property

TrackImportImportID Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImportID { get; set; }
Public Property ImportID As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

TrackImport Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImport Methods

The TrackImport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TrackImport Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportCompletedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Atalasoft.Imaging.WebControls.Capture.KicTrackImportCompletedEventArgs

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TrackImportCompletedEventArgs : AsyncCompletedEventArgs
Public Class TrackImportCompletedEventArgs
    Inherits AsyncCompletedEventArgs

The TrackImportCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportCompletedEventArgs Properties

The TrackImportCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Top
See Also

Reference

TrackImportCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportCompletedEventArgs.Result Property

TrackImportCompletedEventArgsResult Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportResponse Result { get; }
Public ReadOnly Property Result As TrackImportResponse
    Get

Property Value

Type: TrackImportResponse
Remarks
See Also

Reference

TrackImportCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportCompletedEventArgs Methods

The TrackImportCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TrackImportCompletedEventArgs Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportCompletedEventHandler Delegate

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void TrackImportCompletedEventHandler(
    Object sender,
    TrackImportCompletedEventArgs e
)
Public Delegate Sub TrackImportCompletedEventHandler (
    sender As Object,
    e As TrackImportCompletedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImportCompletedEventArgs
Remarks
Caution note Caution
This delegate is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicTrackImportInput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TrackImportInput
Public Class TrackImportInput

The TrackImportInput type exposes the following members.

Constructors
 | Name | Description
Public method | TrackImportInput | Initializes a new instance of the TrackImportInput class
Public method | TrackImportInput(Byte, TrackImport) | Initializes a new instance of the TrackImportInput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | credentials |
Public field | TrackImport |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput Constructor

Overload List
 | Name | Description
Public method | TrackImportInput | Initializes a new instance of the TrackImportInput class
Public method | TrackImportInput(Byte, TrackImport) | Initializes a new instance of the TrackImportInput class
Top
See Also

Reference

TrackImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput Constructor

Initializes a new instance of the TrackImportInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportInput()
Public Sub New
See Also

Reference

TrackImportInput Class
TrackImportInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput Constructor (Byte[], TrackImport)

TrackImportInput Constructor (Byte, TrackImport)

Initializes a new instance of the TrackImportInput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportInput(
    byte[] credentials,
    TrackImport TrackImport
)
Public Sub New (
    credentials As Byte(),
    TrackImport As TrackImport
)

Parameters

credentials
Type: SystemByte
TrackImport
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImport
See Also

Reference

TrackImportInput Class
TrackImportInput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput Methods

The TrackImportInput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TrackImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput Fields

The TrackImportInput type exposes the following members.

Fields
 | Name | Description
Public field | credentials |
Public field | TrackImport |
Top
See Also

Reference

TrackImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput.credentials Field

TrackImportInputcredentials Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] credentials
Public credentials As Byte()

Field Value

Type: Byte
See Also

Reference

TrackImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportInput.TrackImport Field

TrackImportInputTrackImport Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImport TrackImport
Public TrackImport As TrackImport

Field Value

Type: TrackImport
See Also

Reference

TrackImportInput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicTrackImportOutput

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TrackImportOutput
Public Class TrackImportOutput

The TrackImportOutput type exposes the following members.

Constructors
 | Name | Description
Public method | TrackImportOutput | Initializes a new instance of the TrackImportOutput class
Public method | TrackImportOutput(TrackImportResponse) | Initializes a new instance of the TrackImportOutput class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | TrackImportResponse |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput Constructor

Overload List
 | Name | Description
Public method | TrackImportOutput | Initializes a new instance of the TrackImportOutput class
Public method | TrackImportOutput(TrackImportResponse) | Initializes a new instance of the TrackImportOutput class
Top
See Also

Reference

TrackImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput Constructor

Initializes a new instance of the TrackImportOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportOutput()
Public Sub New
See Also

Reference

TrackImportOutput Class
TrackImportOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput Constructor (TrackImportResponse)

Initializes a new instance of the TrackImportOutput class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportOutput(
    TrackImportResponse TrackImportResponse
)
Public Sub New (
    TrackImportResponse As TrackImportResponse
)

Parameters

TrackImportResponse
Type: Atalasoft.Imaging.WebControls.Capture.KicTrackImportResponse
See Also

Reference

TrackImportOutput Class
TrackImportOutput Overload
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput Methods

The TrackImportOutput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TrackImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput Fields

The TrackImportOutput type exposes the following members.

Fields
 | Name | Description
Public field | TrackImportResponse |
Top
See Also

Reference

TrackImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportOutput.TrackImportResponse Field

TrackImportOutputTrackImportResponse Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportResponse TrackImportResponse
Public TrackImportResponse As TrackImportResponse

Field Value

Type: TrackImportResponse
See Also

Reference

TrackImportOutput Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicTrackImportResponse

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TrackImportResponse
<SerializableAttribute>
Public Class TrackImportResponse

The TrackImportResponse type exposes the following members.

Constructors
 | Name | Description
Public method | TrackImportResponse | Initializes a new instance of the TrackImportResponse class
Top
Properties
 | Name | Description
Public property | DeliveryTime |
Public property | DeliveryTimeSpecified |
Public property | ErrorString |
Public property | Extension |
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse Constructor

Initializes a new instance of the TrackImportResponse class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportResponse()
Public Sub New
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse Properties

The TrackImportResponse type exposes the following members.

Properties
 | Name | Description
Public property | DeliveryTime |
Public property | DeliveryTimeSpecified |
Public property | ErrorString |
Public property | Extension |
Public property | Status |
Top
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse.DeliveryTime Property

TrackImportResponseDeliveryTime Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime DeliveryTime { get; set; }
Public Property DeliveryTime As DateTime
    Get
    Set

Property Value

Type: DateTime
Remarks
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse.DeliveryTimeSpecified Property

TrackImportResponseDeliveryTimeSpecified Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DeliveryTimeSpecified { get; set; }
Public Property DeliveryTimeSpecified As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse.ErrorString Property

TrackImportResponseErrorString Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ErrorString { get; set; }
Public Property ErrorString As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse.Extension Property

TrackImportResponseExtension Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ExtensionFieldType[] Extension { get; set; }
Public Property Extension As ExtensionFieldType()
    Get
    Set

Property Value

Type: ExtensionFieldType
Remarks
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse.Status Property

TrackImportResponseStatus Property

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TrackImportResponseStatus Status { get; set; }
Public Property Status As TrackImportResponseStatus
    Get
    Set

Property Value

Type: TrackImportResponseStatus
Remarks
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponse Methods

The TrackImportResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TrackImportResponse Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


TrackImportResponseStatus Enumeration

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public enum TrackImportResponseStatus
<SerializableAttribute>
Public Enumeration TrackImportResponseStatus
Members
Member name | Description
SUBMITTED |
SUCCESS |
ERROR |
UNKNOWN |
Remarks
Caution note Caution
This enum is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Value Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.Capture.KicValue

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Value
Public Class Value

The Value type exposes the following members.

Constructors
 | Name | Description
Public method | Value | Initializes a new instance of the Value class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Text |
Top
Remarks
Caution note Caution
This class is available with .NET Framework 3.5 and 4.5.2 only.
See Also

Reference

Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Value Constructor

Initializes a new instance of the Value class

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Value()
Public Sub New
See Also

Reference

Value Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Value Methods

The Value type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Value Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Value Fields

The Value type exposes the following members.

Fields
 | Name | Description
Public field | Text |
Top
See Also

Reference

Value Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Value.Text Field

ValueText Field

Namespace: Atalasoft.Imaging.WebControls.Capture.Kic
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text
Public Text As String

Field Value

Type: String
Remarks
See Also

Reference

Value Class
Atalasoft.Imaging.WebControls.Capture.Kic Namespace


Atalasoft.Imaging.WebControls.Core Namespace

Classes
 | Class | Description
Public class | AtalaWebHandlerMiddleware | Defines a base class for Atalasoft middlewares.
Public class | WebCaptureCallbacks | Represents a default implementation of the IWebCaptureCallbacks.
Public class | WebCaptureMiddleware | Defines a Web Capture Service terminal middleware that can be added to the application's request pipeline.
Public class | WebCaptureSettings | Represents a basic implementation of IWebCaptureSettings.
Public class | WebControlsCoreExtensions | Extension class that provides methods to use Atalasoft DotImage middlewares.
Public class | WebDocumentViewerCallbacks | Represents a default implementation of the IWebCaptureCallbacks.
Public class | WebDocumentViewerMiddleware | Defines a Web Document Viewer terminal middleware that can be added to the application's request pipeline.
Public class | WebDocumentViewerOptions | Options for the WebDocumentViewerMiddleware.
Interfaces
 | Interface | Description
Public interface | IWebCaptureCallbacks | IWebCaptureCallbacks is the interface, that contains all necessary callbacks to customize HttpContext handling.
Public interface | IWebCaptureSettings | Represents the interface, that contains shared properties for all WebCaptureMiddleware instances.
Public interface | IWebDocumentViewerCallbacks | IWebDocumentViewerCallbacks is the interface, that contains all necessary callbacks to customize HttpContext handling.


AtalaWebHandlerMiddleware Class

Defines a base class for Atalasoft middlewares.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreAtalaWebHandlerMiddleware
Atalasoft.Imaging.WebControls.CoreWebCaptureMiddleware
Atalasoft.Imaging.WebControls.CoreWebDocumentViewerMiddleware

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class AtalaWebHandlerMiddleware
Public MustInherit Class AtalaWebHandlerMiddleware

The AtalaWebHandlerMiddleware type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


AtalaWebHandlerMiddleware Methods

The AtalaWebHandlerMiddleware type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AtalaWebHandlerMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks Interface

IWebCaptureCallbacks is the interface, that contains all necessary callbacks to customize HttpContext handling.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWebCaptureCallbacks
Public Interface IWebCaptureCallbacks

The IWebCaptureCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | BatchFieldsForBatchClass | Method to return the batch fields for a batch class.
Public method | CurrentImportId | Returns the current import ID.
Public method | GetContentTypeDescription | Method to get content type descriptions for a specified content type from Kofax products.
Public method | GetContentTypeList | Method to get content type lists from Kofax products.
Public method | GetNewImportId | Returns a guid in string form.
Public method | GetRawXml | Would return unparsed xml, when overridden to connect to Kofax products.
Public method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file.
Public method | ImportDocument | Method to import uploaded documents into Kofax products.
Public method | ImportDocumentWithIndexFields | Method to import an uploaded document into Kofax Capture along with index field information.
Public method | IndexFieldsForDocumentClass | Method to return IndexFields for a specified document class when overridden.
Public method | TrackStatus | Returns the status of a document with the specified import ID.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks Methods

The IWebCaptureCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | BatchFieldsForBatchClass | Method to return the batch fields for a batch class.
Public method | CurrentImportId | Returns the current import ID.
Public method | GetContentTypeDescription | Method to get content type descriptions for a specified content type from Kofax products.
Public method | GetContentTypeList | Method to get content type lists from Kofax products.
Public method | GetNewImportId | Returns a guid in string form.
Public method | GetRawXml | Would return unparsed xml, when overridden to connect to Kofax products.
Public method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file.
Public method | ImportDocument | Method to import uploaded documents into Kofax products.
Public method | ImportDocumentWithIndexFields | Method to import an uploaded document into Kofax Capture along with index field information.
Public method | IndexFieldsForDocumentClass | Method to return IndexFields for a specified document class when overridden.
Public method | TrackStatus | Returns the status of a document with the specified import ID.
Top
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.BatchFieldsForBatchClass Method

IWebCaptureCallbacksBatchFieldsForBatchClass Method

Method to return the batch fields for a batch class.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
List<Dictionary<string, string>> BatchFieldsForBatchClass(
    string contentType
)
Function BatchFieldsForBatchClass (
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The currently selected contentType.

Return Value

Type: ListDictionaryString, String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.CurrentImportId Method

IWebCaptureCallbacksCurrentImportId Method

Returns the current import ID.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string CurrentImportId()
Function CurrentImportId As String

Return Value

Type: String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.GetContentTypeDescription Method

IWebCaptureCallbacksGetContentTypeDescription Method

Method to get content type descriptions for a specified content type from Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
List<Dictionary<string, string>> GetContentTypeDescription(
    string contentType
)
Function GetContentTypeDescription (
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The currently selected ContentType.

Return Value

Type: ListDictionaryString, String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.GetContentTypeList Method

IWebCaptureCallbacksGetContentTypeList Method

Method to get content type lists from Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
List<string> GetContentTypeList()
Function GetContentTypeList As List(Of String)

Return Value

Type: ListString
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.GetNewImportId Method

IWebCaptureCallbacksGetNewImportId Method

Returns a guid in string form.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string GetNewImportId()
Function GetNewImportId As String

Return Value

Type: String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.GetRawXml Method

IWebCaptureCallbacksGetRawXml Method

Would return unparsed xml, when overridden to connect to Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
List<string> GetRawXml(
    string contentType
)
Function GetRawXml (
    contentType As String
) As List(Of String)

Parameters

contentType
Type: SystemString
The selected ContentType.

Return Value

Type: ListString
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.HandleUpload Method

IWebCaptureCallbacksHandleUpload Method

Decodes the base64 encoded stream from the client, and save it as a tif file.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string HandleUpload(
    HttpContext context
)
Function HandleUpload (
    context As HttpContext
) As String

Parameters

context
Type: HttpContext
The current HTTP context.

Return Value

Type: String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.ImportDocument Method

IWebCaptureCallbacksImportDocument Method

Method to import uploaded documents into Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Dictionary<string, string> ImportDocument(
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription
)
Function ImportDocument (
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String
) As Dictionary(Of String, String)

Parameters

filename
Type: SystemString
The full path name of the file to be imported.
contentType
Type: SystemString
The currently selected ContentType.
contentTypeDocumentClass
Type: SystemString
The currently selected DocumentClass.
contentTypeDescription
Type: SystemString
The ContentTypeDescription for the selected ContentType.

Return Value

Type: DictionaryString, String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.ImportDocumentWithIndexFields Method

IWebCaptureCallbacksImportDocumentWithIndexFields Method

Method to import an uploaded document into Kofax Capture along with index field information.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Dictionary<string, string> ImportDocumentWithIndexFields(
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription,
    string indexFields
)
Function ImportDocumentWithIndexFields (
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String,
    indexFields As String
) As Dictionary(Of String, String)

Parameters

filename
Type: SystemString
The full path name of the file to be imported.
contentType
Type: SystemString
The currently selected ContentType.
contentTypeDocumentClass
Type: SystemString
The currently selected DocumentClass.
contentTypeDescription
Type: SystemString
The ContentTypeDescription for the selected ContentType.
indexFields
Type: SystemString
The index field names, and values.

Return Value

Type: DictionaryString, String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.IndexFieldsForDocumentClass Method

IWebCaptureCallbacksIndexFieldsForDocumentClass Method

Method to return IndexFields for a specified document class when overridden.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
List<Dictionary<string, string>> IndexFieldsForDocumentClass(
    string contentType,
    string documentClass
)
Function IndexFieldsForDocumentClass (
    contentType As String,
    documentClass As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
the selected ContentType.
documentClass
Type: SystemString
The selected DocumentClass of the selected ContentType.

Return Value

Type: ListDictionaryString, String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureCallbacks.TrackStatus Method

IWebCaptureCallbacksTrackStatus Method

Returns the status of a document with the specified import ID.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Dictionary<string, string> TrackStatus(
    string importId
)
Function TrackStatus (
    importId As String
) As Dictionary(Of String, String)

Parameters

importId
Type: SystemString
The guid, in string form, of an active import.

Return Value

Type: DictionaryString, String
See Also

Reference

IWebCaptureCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureSettings Interface

Represents the interface, that contains shared properties for all WebCaptureMiddleware instances.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWebCaptureSettings
Public Interface IWebCaptureSettings

The IWebCaptureSettings type exposes the following members.

Properties
 | Name | Description
Public property | UploadPath | Gets or sets an upload path for documents from Web Capture Service.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureSettings Properties

The IWebCaptureSettings type exposes the following members.

Properties
 | Name | Description
Public property | UploadPath | Gets or sets an upload path for documents from Web Capture Service.
Top
See Also

Reference

IWebCaptureSettings Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebCaptureSettings.UploadPath Property

IWebCaptureSettingsUploadPath Property

Gets or sets an upload path for documents from Web Capture Service.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string UploadPath { get; set; }
Property UploadPath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IWebCaptureSettings Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks Interface

IWebDocumentViewerCallbacks is the interface, that contains all necessary callbacks to customize HttpContext handling.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWebDocumentViewerCallbacks
Public Interface IWebDocumentViewerCallbacks

The IWebDocumentViewerCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | AnnotationDataRequested | Calls when annotation data has been requested by the client.
Public method | AnnotationsDataResponseSend | Calls when constructing response JSON for requesting annotations data operation.
Public method | AnnotationStreamWritten | Calls after the annotation data has been written to the annotation stream, but before it's closed.
Public method | DocumentInfoRequested | Calls when document info is requested from the client.
Public method | DocumentInfoRequestResponseSend | Calls when constructing response JSON for requesting document info operation.
Public method | DocumentSave | Calls when a document save request has been made from the client.
Public method | DocumentSaveResponseSend | Calls when constructing response JSON for saving document operation.
Public method | DocumentStreamWritten | Calls after the document has been written to the save stream, but before it's closed.
Public method | FileUpload | Calls when file upload request has been made from the client.
Public method | FileUploaded | Calls when file upload request has been processed.
Public method | FileUploadResponseSend | Calls when constructing response JSON for file upload request.
Public method | FormsDataResponseSend | Calls when constructing response JSON for requesting forms data operation.
Public method | ImageRequested | Calls when an image is requested from the client.
Public method | PageTextRequested | Occurs when page text data requested.
Public method | PageTextRequestResponseSend | Calls when constructing response JSON for requesting page text operation.
Public method | PageTextSearchResponseSend | Calls when constructing response JSON for searching text on a page operation.
Public method | PdfFormRequested | Calls when the PDF form fields are requested from the client.
Public method | ReleaseDocumentStream | Calls when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri(ResolveDocumentUriEventArgs) event.
Public method | ReleasePageStream | Calls when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri(ResolvePageUriEventArgs) event.
Public method | ResolveDocumentUri | Calls when a source document stream is requested while performing save operation.
Public method | ResolvePageUri | Calls when a source page stream is requested while performing save operation.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks Methods

The IWebDocumentViewerCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | AnnotationDataRequested | Calls when annotation data has been requested by the client.
Public method | AnnotationsDataResponseSend | Calls when constructing response JSON for requesting annotations data operation.
Public method | AnnotationStreamWritten | Calls after the annotation data has been written to the annotation stream, but before it's closed.
Public method | DocumentInfoRequested | Calls when document info is requested from the client.
Public method | DocumentInfoRequestResponseSend | Calls when constructing response JSON for requesting document info operation.
Public method | DocumentSave | Calls when a document save request has been made from the client.
Public method | DocumentSaveResponseSend | Calls when constructing response JSON for saving document operation.
Public method | DocumentStreamWritten | Calls after the document has been written to the save stream, but before it's closed.
Public method | FileUpload | Calls when file upload request has been made from the client.
Public method | FileUploaded | Calls when file upload request has been processed.
Public method | FileUploadResponseSend | Calls when constructing response JSON for file upload request.
Public method | FormsDataResponseSend | Calls when constructing response JSON for requesting forms data operation.
Public method | ImageRequested | Calls when an image is requested from the client.
Public method | PageTextRequested | Occurs when page text data requested.
Public method | PageTextRequestResponseSend | Calls when constructing response JSON for requesting page text operation.
Public method | PageTextSearchResponseSend | Calls when constructing response JSON for searching text on a page operation.
Public method | PdfFormRequested | Calls when the PDF form fields are requested from the client.
Public method | ReleaseDocumentStream | Calls when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri(ResolveDocumentUriEventArgs) event.
Public method | ReleasePageStream | Calls when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri(ResolvePageUriEventArgs) event.
Public method | ResolveDocumentUri | Calls when a source document stream is requested while performing save operation.
Public method | ResolvePageUri | Calls when a source page stream is requested while performing save operation.
Top
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.AnnotationDataRequested Method

IWebDocumentViewerCallbacksAnnotationDataRequested Method

Calls when annotation data has been requested by the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void AnnotationDataRequested(
    AnnotationDataRequestedEventArgs args
)
Sub AnnotationDataRequested (
    args As AnnotationDataRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsAnnotationDataRequestedEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.AnnotationsDataResponseSend Method

IWebDocumentViewerCallbacksAnnotationsDataResponseSend Method

Calls when constructing response JSON for requesting annotations data operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void AnnotationsDataResponseSend(
    ResponseSendEventArgs args
)
Sub AnnotationsDataResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.AnnotationStreamWritten Method

IWebDocumentViewerCallbacksAnnotationStreamWritten Method

Calls after the annotation data has been written to the annotation stream, but before it's closed.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void AnnotationStreamWritten(
    DocumentSaveEventArgs args
)
Sub AnnotationStreamWritten (
    args As DocumentSaveEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
Remarks
Only the AnnotationStream will be populated during this event,
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.DocumentInfoRequested Method

IWebDocumentViewerCallbacksDocumentInfoRequested Method

Calls when document info is requested from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DocumentInfoRequested(
    DocumentInfoRequestedEventArgs args
)
Sub DocumentInfoRequested (
    args As DocumentInfoRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentInfoRequestedEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.DocumentInfoRequestResponseSend Method

IWebDocumentViewerCallbacksDocumentInfoRequestResponseSend Method

Calls when constructing response JSON for requesting document info operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DocumentInfoRequestResponseSend(
    ResponseSendEventArgs args
)
Sub DocumentInfoRequestResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
Remarks
The data from this event can passed to 'annotationloaded' and 'formsloaded' client-side events, since Web Document Viewer can optimize its requests, and send one request to retrieve document information, annotations and forms.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.DocumentSave Method

IWebDocumentViewerCallbacksDocumentSave Method

Calls when a document save request has been made from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DocumentSave(
    DocumentSaveEventArgs args
)
Sub DocumentSave (
    args As DocumentSaveEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.DocumentSaveResponseSend Method

IWebDocumentViewerCallbacksDocumentSaveResponseSend Method

Calls when constructing response JSON for saving document operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DocumentSaveResponseSend(
    ResponseSendEventArgs args
)
Sub DocumentSaveResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.DocumentStreamWritten Method

IWebDocumentViewerCallbacksDocumentStreamWritten Method

Calls after the document has been written to the save stream, but before it's closed.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void DocumentStreamWritten(
    DocumentSaveEventArgs args
)
Sub DocumentStreamWritten (
    args As DocumentSaveEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs
Remarks
Only the DocumentStream will be populated during this event.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.FileUpload Method

IWebDocumentViewerCallbacksFileUpload Method

Calls when file upload request has been made from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void FileUpload(
    FileUploadEventArgs args
)
Sub FileUpload (
    args As FileUploadEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsFileUploadEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.FileUploaded Method

IWebDocumentViewerCallbacksFileUploaded Method

Calls when file upload request has been processed.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void FileUploaded(
    FileUploadedEventArgs args
)
Sub FileUploaded (
    args As FileUploadedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsFileUploadedEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.FileUploadResponseSend Method

IWebDocumentViewerCallbacksFileUploadResponseSend Method

Calls when constructing response JSON for file upload request.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void FileUploadResponseSend(
    ResponseSendEventArgs args
)
Sub FileUploadResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.FormsDataResponseSend Method

IWebDocumentViewerCallbacksFormsDataResponseSend Method

Calls when constructing response JSON for requesting forms data operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void FormsDataResponseSend(
    ResponseSendEventArgs args
)
Sub FormsDataResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.ImageRequested Method

IWebDocumentViewerCallbacksImageRequested Method

Calls when an image is requested from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void ImageRequested(
    ImageRequestedEventArgs args
)
Sub ImageRequested (
    args As ImageRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsImageRequestedEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.PageTextRequested Method

IWebDocumentViewerCallbacksPageTextRequested Method

Occurs when page text data requested.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PageTextRequested(
    PageTextRequestedEventArgs args
)
Sub PageTextRequested (
    args As PageTextRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsPageTextRequestedEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.PageTextRequestResponseSend Method

IWebDocumentViewerCallbacksPageTextRequestResponseSend Method

Calls when constructing response JSON for requesting page text operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PageTextRequestResponseSend(
    ResponseSendEventArgs args
)
Sub PageTextRequestResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.PageTextSearchResponseSend Method

IWebDocumentViewerCallbacksPageTextSearchResponseSend Method

Calls when constructing response JSON for searching text on a page operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PageTextSearchResponseSend(
    ResponseSendEventArgs args
)
Sub PageTextSearchResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs
Remarks
Custom data from this event can be handled by 'pagetextloaded' client-side event, when Web Document Viewer performs text search on pages that are not loaded yet. In this case viewer performs a server side search and returns its result alongside with page's text.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.PdfFormRequested Method

IWebDocumentViewerCallbacksPdfFormRequested Method

Calls when the PDF form fields are requested from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PdfFormRequested(
    PdfFormRequestedEventArgs args
)
Sub PdfFormRequested (
    args As PdfFormRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsPdfFormRequestedEventArgs
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.ReleaseDocumentStream Method

IWebDocumentViewerCallbacksReleaseDocumentStream Method

Calls when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri(ResolveDocumentUriEventArgs) event.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void ReleaseDocumentStream(
    ResolveDocumentUriEventArgs args
)
Sub ReleaseDocumentStream (
    args As ResolveDocumentUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolveDocumentUriEventArgs
Remarks
After document save operation it is necessary to release the obtained in ResolveDocumentUri(ResolveDocumentUriEventArgs) event document streams. Calls once for each stream.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.ReleasePageStream Method

IWebDocumentViewerCallbacksReleasePageStream Method

Calls when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri(ResolvePageUriEventArgs) event.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void ReleasePageStream(
    ResolvePageUriEventArgs args
)
Sub ReleasePageStream (
    args As ResolvePageUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolvePageUriEventArgs
Remarks
After document save operation it is necessary to release the obtained in ResolvePageUri(ResolvePageUriEventArgs) event page streams. Calls once for each stream.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.ResolveDocumentUri Method

IWebDocumentViewerCallbacksResolveDocumentUri Method

Calls when a source document stream is requested while performing save operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void ResolveDocumentUri(
    ResolveDocumentUriEventArgs args
)
Sub ResolveDocumentUri (
    args As ResolveDocumentUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolveDocumentUriEventArgs
Remarks
During document save it is necessary to get the source document pages to combine them into the destination stream.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


IWebDocumentViewerCallbacks.ResolvePageUri Method

IWebDocumentViewerCallbacksResolvePageUri Method

Calls when a source page stream is requested while performing save operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void ResolvePageUri(
    ResolvePageUriEventArgs args
)
Sub ResolvePageUri (
    args As ResolvePageUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolvePageUriEventArgs
Remarks
During document save it is necessary to get the source document pages to combine them into the destination stream.
See Also

Reference

IWebDocumentViewerCallbacks Interface
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks Class

Represents a default implementation of the IWebCaptureCallbacks.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreWebCaptureCallbacks

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class WebCaptureCallbacks : IWebCaptureCallbacks
Public MustInherit Class WebCaptureCallbacks
    Implements IWebCaptureCallbacks

The WebCaptureCallbacks type exposes the following members.

Constructors
 | Name | Description
Protected method | WebCaptureCallbacks | Obsolete. Initializes a new instance of the WebCaptureCallbacks class
Protected method | WebCaptureCallbacks(IHostingEnvironment) | Initializes a new instance of the WebCaptureCallbacks class
Top
Methods
 | Name | Description
Public method | BatchFieldsForBatchClass | Method to return the batch fields for a batch class.
Public method | CurrentImportId | Returns the current import ID.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContentTypeDescription | Method to get content type descriptions for a specified content type from Kofax products.
Public method | GetContentTypeList | Method to get content type lists from Kofax products.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNewImportId | Returns a guid in string form.
Public method | GetRawXml | Would return unparsed xml, when overridden to connect to Kofax products.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file.
Public method | ImportDocument | Method to import uploaded documents into Kofax products.
Public method | ImportDocumentWithIndexFields | Method to import an uploaded document into Kofax Capture along with index field information.
Public method | IndexFieldsForDocumentClass | Method to return IndexFields for a specified document class when overridden.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackStatus | Returns the status of a document with the specified import ID.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks Constructor

Overload List
 | Name | Description
Protected method | WebCaptureCallbacks | Obsolete. Initializes a new instance of the WebCaptureCallbacks class
Protected method | WebCaptureCallbacks(IHostingEnvironment) | Initializes a new instance of the WebCaptureCallbacks class
Top
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks Constructor

Note: This API is now obsolete.

Initializes a new instance of the WebCaptureCallbacks class

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsoleted. Please, use a constructor WebCaptureCallbacks(IHostingEnvironemnt) instead.",
    true)]
protected WebCaptureCallbacks()
<ObsoleteAttribute("This constructor is obsoleted. Please, use a constructor WebCaptureCallbacks(IHostingEnvironemnt) instead.",
    true)>
Protected Sub New
See Also

Reference

WebCaptureCallbacks Class
WebCaptureCallbacks Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks Constructor (IHostingEnvironment)

Initializes a new instance of the WebCaptureCallbacks class

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WebCaptureCallbacks(
    IHostingEnvironment env
)
Protected Sub New (
    env As IHostingEnvironment
)

Parameters

env
Type: IHostingEnvironment
See Also

Reference

WebCaptureCallbacks Class
WebCaptureCallbacks Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks Methods

The WebCaptureCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | BatchFieldsForBatchClass | Method to return the batch fields for a batch class.
Public method | CurrentImportId | Returns the current import ID.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContentTypeDescription | Method to get content type descriptions for a specified content type from Kofax products.
Public method | GetContentTypeList | Method to get content type lists from Kofax products.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNewImportId | Returns a guid in string form.
Public method | GetRawXml | Would return unparsed xml, when overridden to connect to Kofax products.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleUpload | Decodes the base64 encoded stream from the client, and save it as a tif file.
Public method | ImportDocument | Method to import uploaded documents into Kofax products.
Public method | ImportDocumentWithIndexFields | Method to import an uploaded document into Kofax Capture along with index field information.
Public method | IndexFieldsForDocumentClass | Method to return IndexFields for a specified document class when overridden.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackStatus | Returns the status of a document with the specified import ID.
Top
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.BatchFieldsForBatchClass Method

WebCaptureCallbacksBatchFieldsForBatchClass Method

Method to return the batch fields for a batch class.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual List<Dictionary<string, string>> BatchFieldsForBatchClass(
    string contentType
)
Public Overridable Function BatchFieldsForBatchClass (
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The currently selected contentType.

Return Value

Type: ListDictionaryString, String

Implements

IWebCaptureCallbacksBatchFieldsForBatchClass(String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.CurrentImportId Method

WebCaptureCallbacksCurrentImportId Method

Returns the current import ID.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string CurrentImportId()
Public Overridable Function CurrentImportId As String

Return Value

Type: String

Implements

IWebCaptureCallbacksCurrentImportId
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.GetContentTypeDescription Method

WebCaptureCallbacksGetContentTypeDescription Method

Method to get content type descriptions for a specified content type from Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual List<Dictionary<string, string>> GetContentTypeDescription(
    string contentType
)
Public Overridable Function GetContentTypeDescription (
    contentType As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
The currently selected ContentType.

Return Value

Type: ListDictionaryString, String

Implements

IWebCaptureCallbacksGetContentTypeDescription(String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.GetContentTypeList Method

WebCaptureCallbacksGetContentTypeList Method

Method to get content type lists from Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual List<string> GetContentTypeList()
Public Overridable Function GetContentTypeList As List(Of String)

Return Value

Type: ListString

Implements

IWebCaptureCallbacksGetContentTypeList
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.GetNewImportId Method

WebCaptureCallbacksGetNewImportId Method

Returns a guid in string form.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetNewImportId()
Public Overridable Function GetNewImportId As String

Return Value

Type: String

Implements

IWebCaptureCallbacksGetNewImportId
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.GetRawXml Method

WebCaptureCallbacksGetRawXml Method

Would return unparsed xml, when overridden to connect to Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual List<string> GetRawXml(
    string contentType
)
Public Overridable Function GetRawXml (
    contentType As String
) As List(Of String)

Parameters

contentType
Type: SystemString
The selected ContentType.

Return Value

Type: ListString

Implements

IWebCaptureCallbacksGetRawXml(String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.HandleUpload Method

WebCaptureCallbacksHandleUpload Method

Decodes the base64 encoded stream from the client, and save it as a tif file.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string HandleUpload(
    HttpContext context
)
Public Overridable Function HandleUpload (
    context As HttpContext
) As String

Parameters

context
Type: HttpContext
The current HTTP context.

Return Value

Type: String

Implements

IWebCaptureCallbacksHandleUpload(HttpContext)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.ImportDocument Method

WebCaptureCallbacksImportDocument Method

Method to import uploaded documents into Kofax products.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Dictionary<string, string> ImportDocument(
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription
)
Public Overridable Function ImportDocument (
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String
) As Dictionary(Of String, String)

Parameters

filename
Type: SystemString
The full path name of the file to be imported.
contentType
Type: SystemString
The currently selected ContentType.
contentTypeDocumentClass
Type: SystemString
The currently selected DocumentClass.
contentTypeDescription
Type: SystemString
The ContentTypeDescription for the selected ContentType.

Return Value

Type: DictionaryString, String

Implements

IWebCaptureCallbacksImportDocument(String, String, String, String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.ImportDocumentWithIndexFields Method

WebCaptureCallbacksImportDocumentWithIndexFields Method

Method to import an uploaded document into Kofax Capture along with index field information.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Dictionary<string, string> ImportDocumentWithIndexFields(
    string filename,
    string contentType,
    string contentTypeDocumentClass,
    string contentTypeDescription,
    string indexFields
)
Public Overridable Function ImportDocumentWithIndexFields (
    filename As String,
    contentType As String,
    contentTypeDocumentClass As String,
    contentTypeDescription As String,
    indexFields As String
) As Dictionary(Of String, String)

Parameters

filename
Type: SystemString
The full path name of the file to be imported.
contentType
Type: SystemString
The currently selected ContentType.
contentTypeDocumentClass
Type: SystemString
The currently selected DocumentClass.
contentTypeDescription
Type: SystemString
The ContentTypeDescription for the selected ContentType.
indexFields
Type: SystemString
The index field names, and values.

Return Value

Type: DictionaryString, String

Implements

IWebCaptureCallbacksImportDocumentWithIndexFields(String, String, String, String, String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.IndexFieldsForDocumentClass Method

WebCaptureCallbacksIndexFieldsForDocumentClass Method

Method to return IndexFields for a specified document class when overridden.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual List<Dictionary<string, string>> IndexFieldsForDocumentClass(
    string contentType,
    string documentClass
)
Public Overridable Function IndexFieldsForDocumentClass (
    contentType As String,
    documentClass As String
) As List(Of Dictionary(Of String, String))

Parameters

contentType
Type: SystemString
the selected ContentType.
documentClass
Type: SystemString
The selected DocumentClass of the selected ContentType.

Return Value

Type: ListDictionaryString, String

Implements

IWebCaptureCallbacksIndexFieldsForDocumentClass(String, String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureCallbacks.TrackStatus Method

WebCaptureCallbacksTrackStatus Method

Returns the status of a document with the specified import ID.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Dictionary<string, string> TrackStatus(
    string importId
)
Public Overridable Function TrackStatus (
    importId As String
) As Dictionary(Of String, String)

Parameters

importId
Type: SystemString
The guid, in string form, of an active import.

Return Value

Type: DictionaryString, String

Implements

IWebCaptureCallbacksTrackStatus(String)
See Also

Reference

WebCaptureCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureMiddleware Class

Defines a Web Capture Service terminal middleware that can be added to the application's request pipeline.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreAtalaWebHandlerMiddleware
Atalasoft.Imaging.WebControls.CoreWebCaptureMiddleware

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebCaptureMiddleware : AtalaWebHandlerMiddleware
Public Class WebCaptureMiddleware
    Inherits AtalaWebHandlerMiddleware

The WebCaptureMiddleware type exposes the following members.

Constructors
 | Name | Description
Public method | WebCaptureMiddleware(RequestDelegate, IHostingEnvironment) | Initializes a new instance of the WebCaptureMiddleware class
Public method | WebCaptureMiddleware(RequestDelegate, IHostingEnvironment, IWebCaptureCallbacks) | Initializes a new instance of WebCaptureMiddleware class with specified callbacks.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Request handling method
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureMiddleware Constructor

Overload List
 | Name | Description
Public method | WebCaptureMiddleware(RequestDelegate, IHostingEnvironment) | Initializes a new instance of the WebCaptureMiddleware class
Public method | WebCaptureMiddleware(RequestDelegate, IHostingEnvironment, IWebCaptureCallbacks) | Initializes a new instance of WebCaptureMiddleware class with specified callbacks.
Top
See Also

Reference

WebCaptureMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureMiddleware Constructor (RequestDelegate, IHostingEnvironment)

Initializes a new instance of the WebCaptureMiddleware class

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebCaptureMiddleware(
    RequestDelegate next,
    IHostingEnvironment env
)
Public Sub New (
    next As RequestDelegate,
    env As IHostingEnvironment
)

Parameters

next
Type: RequestDelegate
env
Type: IHostingEnvironment
See Also

Reference

WebCaptureMiddleware Class
WebCaptureMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureMiddleware Constructor (RequestDelegate, IHostingEnvironment, IWebCaptureCallbacks)

Initializes a new instance of WebCaptureMiddleware class with specified callbacks.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebCaptureMiddleware(
    RequestDelegate next,
    IHostingEnvironment env,
    IWebCaptureCallbacks callbacks
)
Public Sub New (
    next As RequestDelegate,
    env As IHostingEnvironment,
    callbacks As IWebCaptureCallbacks
)

Parameters

next
Type: RequestDelegate
The delegate representing the remaining middleware in the request pipeline. Ignores by this middleware.
env
Type: IHostingEnvironment
The information about the web hosting environment.
callbacks
Type: Atalasoft.Imaging.WebControls.CoreIWebCaptureCallbacks
The IWebCaptureCallbacks object.
See Also

Reference

WebCaptureMiddleware Class
WebCaptureMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureMiddleware Methods

The WebCaptureMiddleware type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Request handling method
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebCaptureMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureMiddleware.Invoke Method

WebCaptureMiddlewareInvoke Method

Request handling method

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Task Invoke(
    HttpContext context
)
Public Function Invoke (
    context As HttpContext
) As Task

Parameters

context
Type: HttpContext
The HttpContext for the current request.

Return Value

Type: Task
A Task that represents the execution of this middleware.
See Also

Reference

WebCaptureMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureSettings Class

Represents a basic implementation of IWebCaptureSettings.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreWebCaptureSettings

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebCaptureSettings : IWebCaptureSettings
Public Class WebCaptureSettings
    Implements IWebCaptureSettings

The WebCaptureSettings type exposes the following members.

Constructors
 | Name | Description
Public method | WebCaptureSettings | Initializes a new instance of the WebCaptureSettings class
Top
Properties
 | Name | Description
Public property | UploadPath | Represents the interface, that contains shared properties for all WebCaptureMiddleware instances.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureSettings Constructor

Initializes a new instance of the WebCaptureSettings class

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebCaptureSettings()
Public Sub New
See Also

Reference

WebCaptureSettings Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureSettings Properties

The WebCaptureSettings type exposes the following members.

Properties
 | Name | Description
Public property | UploadPath | Represents the interface, that contains shared properties for all WebCaptureMiddleware instances.
Top
See Also

Reference

WebCaptureSettings Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureSettings.UploadPath Property

WebCaptureSettingsUploadPath Property

Represents the interface, that contains shared properties for all WebCaptureMiddleware instances.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string UploadPath { get; set; }
Public Property UploadPath As String
    Get
    Set

Property Value

Type: String

Implements

IWebCaptureSettingsUploadPath
See Also

Reference

WebCaptureSettings Class
Atalasoft.Imaging.WebControls.Core Namespace


WebCaptureSettings Methods

The WebCaptureSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebCaptureSettings Class
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions Class

Extension class that provides methods to use Atalasoft DotImage middlewares.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreWebControlsCoreExtensions

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class WebControlsCoreExtensions
<ExtensionAttribute>
Public NotInheritable Class WebControlsCoreExtensions

The WebControlsCoreExtensions type exposes the following members.

Methods
Name | Description
ConfigureWebCapture | Configures static properties for WebCaptureMiddlewares
RunWebCaptureMiddleware(IApplicationBuilder) | Adds a terminal WebCaptureMiddleware in the chain of middlewares.
RunWebCaptureMiddleware(IApplicationBuilder, IWebCaptureCallbacks) | Adds a terminal WebCaptureMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder) | Adds a terminal WebDocumentViewerMiddleware in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, IWebDocumentViewerCallbacks) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, WebDocumentViewerOptions) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, WebDocumentViewerOptions, IWebDocumentViewerCallbacks) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions Methods

The WebControlsCoreExtensions type exposes the following members.

Methods
Name | Description
ConfigureWebCapture | Configures static properties for WebCaptureMiddlewares
RunWebCaptureMiddleware(IApplicationBuilder) | Adds a terminal WebCaptureMiddleware in the chain of middlewares.
RunWebCaptureMiddleware(IApplicationBuilder, IWebCaptureCallbacks) | Adds a terminal WebCaptureMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder) | Adds a terminal WebDocumentViewerMiddleware in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, IWebDocumentViewerCallbacks) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, WebDocumentViewerOptions) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, WebDocumentViewerOptions, IWebDocumentViewerCallbacks) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
Top
See Also

Reference

WebControlsCoreExtensions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.ConfigureWebCapture Method

WebControlsCoreExtensionsConfigureWebCapture Method

Configures static properties for WebCaptureMiddlewares

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IServiceCollection ConfigureWebCapture(
    this IServiceCollection services,
    IWebCaptureSettings settings
)
<ExtensionAttribute>
Public Shared Function ConfigureWebCapture (
    services As IServiceCollection,
    settings As IWebCaptureSettings
) As IServiceCollection

Parameters

services
Type: IServiceCollection
Current services collection instance. It should contain an IHostingEnvironment service.
settings
Type: Atalasoft.Imaging.WebControls.CoreIWebCaptureSettings
Web Capture settings object.

Return Value

Type: IServiceCollection
The same service collection instance without any modifications.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IServiceCollection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebCaptureMiddleware Method

WebControlsCoreExtensionsRunWebCaptureMiddleware Method

Overload List
Name | Description
RunWebCaptureMiddleware(IApplicationBuilder) | Adds a terminal WebCaptureMiddleware in the chain of middlewares.
RunWebCaptureMiddleware(IApplicationBuilder, IWebCaptureCallbacks) | Adds a terminal WebCaptureMiddleware with custom callbacks in the chain of middlewares.
Top
See Also

Reference

WebControlsCoreExtensions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebCaptureMiddleware Method (IApplicationBuilder)

WebControlsCoreExtensionsRunWebCaptureMiddleware Method (IApplicationBuilder)

Adds a terminal WebCaptureMiddleware in the chain of middlewares.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IApplicationBuilder RunWebCaptureMiddleware(
    this IApplicationBuilder builder
)
<ExtensionAttribute>
Public Shared Function RunWebCaptureMiddleware (
    builder As IApplicationBuilder
) As IApplicationBuilder

Parameters

builder
Type: IApplicationBuilder
Current application builder instance.

Return Value

Type: IApplicationBuilder
Updated application IApplicationBuilder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
RunWebCaptureMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebCaptureMiddleware Method (IApplicationBuilder, IWebCaptureCallbacks)

WebControlsCoreExtensionsRunWebCaptureMiddleware Method (IApplicationBuilder, IWebCaptureCallbacks)

Adds a terminal WebCaptureMiddleware with custom callbacks in the chain of middlewares.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IApplicationBuilder RunWebCaptureMiddleware(
    this IApplicationBuilder builder,
    IWebCaptureCallbacks callbacks
)
<ExtensionAttribute>
Public Shared Function RunWebCaptureMiddleware (
    builder As IApplicationBuilder,
    callbacks As IWebCaptureCallbacks
) As IApplicationBuilder

Parameters

builder
Type: IApplicationBuilder
Current application builder instance.
callbacks
Type: Atalasoft.Imaging.WebControls.CoreIWebCaptureCallbacks
Web Capture middleware callbacks.

Return Value

Type: IApplicationBuilder
Updated application IApplicationBuilder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
RunWebCaptureMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebDocumentViewerMiddleware Method

WebControlsCoreExtensionsRunWebDocumentViewerMiddleware Method

Overload List
Name | Description
RunWebDocumentViewerMiddleware(IApplicationBuilder) | Adds a terminal WebDocumentViewerMiddleware in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, IWebDocumentViewerCallbacks) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, WebDocumentViewerOptions) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
RunWebDocumentViewerMiddleware(IApplicationBuilder, WebDocumentViewerOptions, IWebDocumentViewerCallbacks) | Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.
Top
See Also

Reference

WebControlsCoreExtensions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebDocumentViewerMiddleware Method (IApplicationBuilder)

WebControlsCoreExtensionsRunWebDocumentViewerMiddleware Method (IApplicationBuilder)

Adds a terminal WebDocumentViewerMiddleware in the chain of middlewares.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IApplicationBuilder RunWebDocumentViewerMiddleware(
    this IApplicationBuilder builder
)
<ExtensionAttribute>
Public Shared Function RunWebDocumentViewerMiddleware (
    builder As IApplicationBuilder
) As IApplicationBuilder

Parameters

builder
Type: IApplicationBuilder
Current application builder instance.

Return Value

Type: IApplicationBuilder
Updated application IApplicationBuilder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
RunWebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebDocumentViewerMiddleware Method (IApplicationBuilder, IWebDocumentViewerCallbacks)

WebControlsCoreExtensionsRunWebDocumentViewerMiddleware Method (IApplicationBuilder, IWebDocumentViewerCallbacks)

Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IApplicationBuilder RunWebDocumentViewerMiddleware(
    this IApplicationBuilder builder,
    IWebDocumentViewerCallbacks callbacks
)
<ExtensionAttribute>
Public Shared Function RunWebDocumentViewerMiddleware (
    builder As IApplicationBuilder,
    callbacks As IWebDocumentViewerCallbacks
) As IApplicationBuilder

Parameters

builder
Type: IApplicationBuilder
Current application builder instance.
callbacks
Type: Atalasoft.Imaging.WebControls.CoreIWebDocumentViewerCallbacks
Web Document Viewer middleware callbacks.

Return Value

Type: IApplicationBuilder
Updated application IApplicationBuilder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
RunWebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebDocumentViewerMiddleware Method (IApplicationBuilder, WebDocumentViewerOptions)

WebControlsCoreExtensionsRunWebDocumentViewerMiddleware Method (IApplicationBuilder, WebDocumentViewerOptions)

Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IApplicationBuilder RunWebDocumentViewerMiddleware(
    this IApplicationBuilder builder,
    WebDocumentViewerOptions options
)
<ExtensionAttribute>
Public Shared Function RunWebDocumentViewerMiddleware (
    builder As IApplicationBuilder,
    options As WebDocumentViewerOptions
) As IApplicationBuilder

Parameters

builder
Type: IApplicationBuilder
Current application builder instance.
options
Type: Atalasoft.Imaging.WebControls.CoreWebDocumentViewerOptions
Web Document Viewer middleware options.

Return Value

Type: IApplicationBuilder
Updated application IApplicationBuilder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
RunWebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebControlsCoreExtensions.RunWebDocumentViewerMiddleware Method (IApplicationBuilder, WebDocumentViewerOptions, IWebDocumentViewerCallbacks)

WebControlsCoreExtensionsRunWebDocumentViewerMiddleware Method (IApplicationBuilder, WebDocumentViewerOptions, IWebDocumentViewerCallbacks)

Adds a terminal WebDocumentViewerMiddleware with custom callbacks in the chain of middlewares.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IApplicationBuilder RunWebDocumentViewerMiddleware(
    this IApplicationBuilder builder,
    WebDocumentViewerOptions options,
    IWebDocumentViewerCallbacks callbacks
)
<ExtensionAttribute>
Public Shared Function RunWebDocumentViewerMiddleware (
    builder As IApplicationBuilder,
    options As WebDocumentViewerOptions,
    callbacks As IWebDocumentViewerCallbacks
) As IApplicationBuilder

Parameters

builder
Type: IApplicationBuilder
Current application builder instance.
options
Type: Atalasoft.Imaging.WebControls.CoreWebDocumentViewerOptions
Web Document Viewer middleware options.
callbacks
Type: Atalasoft.Imaging.WebControls.CoreIWebDocumentViewerCallbacks
Web Document Viewer middleware callbacks.

Return Value

Type: IApplicationBuilder
Updated application IApplicationBuilder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IApplicationBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WebControlsCoreExtensions Class
RunWebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks Class

Represents a default implementation of the IWebCaptureCallbacks.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreWebDocumentViewerCallbacks

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class WebDocumentViewerCallbacks : IWebDocumentViewerCallbacks
Public MustInherit Class WebDocumentViewerCallbacks
    Implements IWebDocumentViewerCallbacks

The WebDocumentViewerCallbacks type exposes the following members.

Constructors
 | Name | Description
Protected method | WebDocumentViewerCallbacks | Initializes a new instance of the WebDocumentViewerCallbacks class
Top
Methods
 | Name | Description
Public method | AnnotationDataRequested | Calls when annotation data has been requested by the client.
Public method | AnnotationsDataResponseSend | Calls when constructing response JSON for requesting annotations data operation.
Public method | AnnotationStreamWritten | Calls after the annotation data has been written to the annotation stream, but before it's closed.
Public method | DocumentInfoRequested | Calls when document info is requested from the client.
Public method | DocumentInfoRequestResponseSend | Calls when constructing response JSON for requesting document info operation.
Public method | DocumentSave | Calls when a document save request has been made from the client.
Public method | DocumentSaveResponseSend | Calls when constructing response JSON for saving document operation.
Public method | DocumentStreamWritten | Calls after the document has been written to the save stream, but before it's closed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FileUpload | Calls when file upload request has been made from the client.
Public method | FileUploaded | Calls when file upload request has been processed.
Public method | FileUploadResponseSend | Calls when constructing response JSON for file upload request.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormsDataResponseSend | Calls when constructing response JSON for requesting forms data operation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImageRequested | Calls when an image is requested from the client.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PageTextRequested | Occurs when page text data requested.
Public method | PageTextRequestResponseSend | Calls when constructing response JSON for requesting page text operation.
Public method | PageTextSearchResponseSend | Calls when constructing response JSON for searching text on a page operation.
Public method | PdfFormRequested | Calls when the PDF form fields are requested from the client.
Public method | ReleaseDocumentStream | Calls when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri(ResolveDocumentUriEventArgs) event.
Public method | ReleasePageStream | Calls when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri(ResolvePageUriEventArgs) event.
Public method | ResolveDocumentUri | Calls when a source document stream is requested while performing save operation.
Public method | ResolvePageUri | Calls when a source page stream is requested while performing save operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks Constructor

Initializes a new instance of the WebDocumentViewerCallbacks class

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WebDocumentViewerCallbacks()
Protected Sub New
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks Methods

The WebDocumentViewerCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | AnnotationDataRequested | Calls when annotation data has been requested by the client.
Public method | AnnotationsDataResponseSend | Calls when constructing response JSON for requesting annotations data operation.
Public method | AnnotationStreamWritten | Calls after the annotation data has been written to the annotation stream, but before it's closed.
Public method | DocumentInfoRequested | Calls when document info is requested from the client.
Public method | DocumentInfoRequestResponseSend | Calls when constructing response JSON for requesting document info operation.
Public method | DocumentSave | Calls when a document save request has been made from the client.
Public method | DocumentSaveResponseSend | Calls when constructing response JSON for saving document operation.
Public method | DocumentStreamWritten | Calls after the document has been written to the save stream, but before it's closed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FileUpload | Calls when file upload request has been made from the client.
Public method | FileUploaded | Calls when file upload request has been processed.
Public method | FileUploadResponseSend | Calls when constructing response JSON for file upload request.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormsDataResponseSend | Calls when constructing response JSON for requesting forms data operation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImageRequested | Calls when an image is requested from the client.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PageTextRequested | Occurs when page text data requested.
Public method | PageTextRequestResponseSend | Calls when constructing response JSON for requesting page text operation.
Public method | PageTextSearchResponseSend | Calls when constructing response JSON for searching text on a page operation.
Public method | PdfFormRequested | Calls when the PDF form fields are requested from the client.
Public method | ReleaseDocumentStream | Calls when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri(ResolveDocumentUriEventArgs) event.
Public method | ReleasePageStream | Calls when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri(ResolvePageUriEventArgs) event.
Public method | ResolveDocumentUri | Calls when a source document stream is requested while performing save operation.
Public method | ResolvePageUri | Calls when a source page stream is requested while performing save operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.AnnotationDataRequested Method

WebDocumentViewerCallbacksAnnotationDataRequested Method

Calls when annotation data has been requested by the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void AnnotationDataRequested(
    AnnotationDataRequestedEventArgs args
)
Public Overridable Sub AnnotationDataRequested (
    args As AnnotationDataRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsAnnotationDataRequestedEventArgs

Implements

IWebDocumentViewerCallbacksAnnotationDataRequested(AnnotationDataRequestedEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.AnnotationsDataResponseSend Method

WebDocumentViewerCallbacksAnnotationsDataResponseSend Method

Calls when constructing response JSON for requesting annotations data operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void AnnotationsDataResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub AnnotationsDataResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksAnnotationsDataResponseSend(ResponseSendEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.AnnotationStreamWritten Method

WebDocumentViewerCallbacksAnnotationStreamWritten Method

Calls after the annotation data has been written to the annotation stream, but before it's closed.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void AnnotationStreamWritten(
    DocumentSaveEventArgs args
)
Public Overridable Sub AnnotationStreamWritten (
    args As DocumentSaveEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs

Implements

IWebDocumentViewerCallbacksAnnotationStreamWritten(DocumentSaveEventArgs)
Remarks
Only the AnnotationStream will be populated during this event,
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.DocumentInfoRequested Method

WebDocumentViewerCallbacksDocumentInfoRequested Method

Calls when document info is requested from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void DocumentInfoRequested(
    DocumentInfoRequestedEventArgs args
)
Public Overridable Sub DocumentInfoRequested (
    args As DocumentInfoRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentInfoRequestedEventArgs

Implements

IWebDocumentViewerCallbacksDocumentInfoRequested(DocumentInfoRequestedEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.DocumentInfoRequestResponseSend Method

WebDocumentViewerCallbacksDocumentInfoRequestResponseSend Method

Calls when constructing response JSON for requesting document info operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void DocumentInfoRequestResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub DocumentInfoRequestResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksDocumentInfoRequestResponseSend(ResponseSendEventArgs)
Remarks
The data from this event can passed to 'annotationloaded' and 'formsloaded' client-side events, since Web Document Viewer can optimize its requests, and send one request to retrieve document information, annotations and forms.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.DocumentSave Method

WebDocumentViewerCallbacksDocumentSave Method

Calls when a document save request has been made from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void DocumentSave(
    DocumentSaveEventArgs args
)
Public Overridable Sub DocumentSave (
    args As DocumentSaveEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs

Implements

IWebDocumentViewerCallbacksDocumentSave(DocumentSaveEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.DocumentSaveResponseSend Method

WebDocumentViewerCallbacksDocumentSaveResponseSend Method

Calls when constructing response JSON for saving document operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void DocumentSaveResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub DocumentSaveResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksDocumentSaveResponseSend(ResponseSendEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.DocumentStreamWritten Method

WebDocumentViewerCallbacksDocumentStreamWritten Method

Calls after the document has been written to the save stream, but before it's closed.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void DocumentStreamWritten(
    DocumentSaveEventArgs args
)
Public Overridable Sub DocumentStreamWritten (
    args As DocumentSaveEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsDocumentSaveEventArgs

Implements

IWebDocumentViewerCallbacksDocumentStreamWritten(DocumentSaveEventArgs)
Remarks
Only the DocumentStream will be populated during this event.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.FileUpload Method

WebDocumentViewerCallbacksFileUpload Method

Calls when file upload request has been made from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void FileUpload(
    FileUploadEventArgs args
)
Public Overridable Sub FileUpload (
    args As FileUploadEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsFileUploadEventArgs

Implements

IWebDocumentViewerCallbacksFileUpload(FileUploadEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.FileUploaded Method

WebDocumentViewerCallbacksFileUploaded Method

Calls when file upload request has been processed.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void FileUploaded(
    FileUploadedEventArgs args
)
Public Overridable Sub FileUploaded (
    args As FileUploadedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsFileUploadedEventArgs

Implements

IWebDocumentViewerCallbacksFileUploaded(FileUploadedEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.FileUploadResponseSend Method

WebDocumentViewerCallbacksFileUploadResponseSend Method

Calls when constructing response JSON for file upload request.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void FileUploadResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub FileUploadResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksFileUploadResponseSend(ResponseSendEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.FormsDataResponseSend Method

WebDocumentViewerCallbacksFormsDataResponseSend Method

Calls when constructing response JSON for requesting forms data operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void FormsDataResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub FormsDataResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksFormsDataResponseSend(ResponseSendEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.ImageRequested Method

WebDocumentViewerCallbacksImageRequested Method

Calls when an image is requested from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ImageRequested(
    ImageRequestedEventArgs args
)
Public Overridable Sub ImageRequested (
    args As ImageRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsImageRequestedEventArgs

Implements

IWebDocumentViewerCallbacksImageRequested(ImageRequestedEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.PageTextRequested Method

WebDocumentViewerCallbacksPageTextRequested Method

Occurs when page text data requested.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void PageTextRequested(
    PageTextRequestedEventArgs args
)
Public Overridable Sub PageTextRequested (
    args As PageTextRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsPageTextRequestedEventArgs

Implements

IWebDocumentViewerCallbacksPageTextRequested(PageTextRequestedEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.PageTextRequestResponseSend Method

WebDocumentViewerCallbacksPageTextRequestResponseSend Method

Calls when constructing response JSON for requesting page text operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void PageTextRequestResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub PageTextRequestResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksPageTextRequestResponseSend(ResponseSendEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.PageTextSearchResponseSend Method

WebDocumentViewerCallbacksPageTextSearchResponseSend Method

Calls when constructing response JSON for searching text on a page operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void PageTextSearchResponseSend(
    ResponseSendEventArgs args
)
Public Overridable Sub PageTextSearchResponseSend (
    args As ResponseSendEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResponseSendEventArgs

Implements

IWebDocumentViewerCallbacksPageTextSearchResponseSend(ResponseSendEventArgs)
Remarks
Custom data from this event can be handled by 'pagetextloaded' client-side event, when Web Document Viewer performs text search on pages that are not loaded yet. In this case viewer performs a server side search and returns its result alongside with page's text.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.PdfFormRequested Method

WebDocumentViewerCallbacksPdfFormRequested Method

Calls when the PDF form fields are requested from the client.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void PdfFormRequested(
    PdfFormRequestedEventArgs args
)
Public Overridable Sub PdfFormRequested (
    args As PdfFormRequestedEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsPdfFormRequestedEventArgs

Implements

IWebDocumentViewerCallbacksPdfFormRequested(PdfFormRequestedEventArgs)
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.ReleaseDocumentStream Method

WebDocumentViewerCallbacksReleaseDocumentStream Method

Calls when a document release stream occurs on document save. This event is raised only for streams that were provided in ResolveDocumentUri(ResolveDocumentUriEventArgs) event.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ReleaseDocumentStream(
    ResolveDocumentUriEventArgs args
)
Public Overridable Sub ReleaseDocumentStream (
    args As ResolveDocumentUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolveDocumentUriEventArgs

Implements

IWebDocumentViewerCallbacksReleaseDocumentStream(ResolveDocumentUriEventArgs)
Remarks
After document save operation it is necessary to release the obtained in ResolveDocumentUri(ResolveDocumentUriEventArgs) event document streams. Calls once for each stream.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.ReleasePageStream Method

WebDocumentViewerCallbacksReleasePageStream Method

Calls when a page release stream occurs on document save. This event is raised only for streams that were provided in ResolvePageUri(ResolvePageUriEventArgs) event.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ReleasePageStream(
    ResolvePageUriEventArgs args
)
Public Overridable Sub ReleasePageStream (
    args As ResolvePageUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolvePageUriEventArgs

Implements

IWebDocumentViewerCallbacksReleasePageStream(ResolvePageUriEventArgs)
Remarks
After document save operation it is necessary to release the obtained in ResolvePageUri(ResolvePageUriEventArgs) event page streams. Calls once for each stream.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.ResolveDocumentUri Method

WebDocumentViewerCallbacksResolveDocumentUri Method

Calls when a source document stream is requested while performing save operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ResolveDocumentUri(
    ResolveDocumentUriEventArgs args
)
Public Overridable Sub ResolveDocumentUri (
    args As ResolveDocumentUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolveDocumentUriEventArgs

Implements

IWebDocumentViewerCallbacksResolveDocumentUri(ResolveDocumentUriEventArgs)
Remarks
During document save it is necessary to get the source document pages to combine them into the destination stream.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerCallbacks.ResolvePageUri Method

WebDocumentViewerCallbacksResolvePageUri Method

Calls when a source page stream is requested while performing save operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void ResolvePageUri(
    ResolvePageUriEventArgs args
)
Public Overridable Sub ResolvePageUri (
    args As ResolvePageUriEventArgs
)

Parameters

args
Type: Atalasoft.Imaging.WebControlsResolvePageUriEventArgs

Implements

IWebDocumentViewerCallbacksResolvePageUri(ResolvePageUriEventArgs)
Remarks
During document save it is necessary to get the source document pages to combine them into the destination stream.
See Also

Reference

WebDocumentViewerCallbacks Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Class

Defines a Web Document Viewer terminal middleware that can be added to the application's request pipeline.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreAtalaWebHandlerMiddleware
Atalasoft.Imaging.WebControls.CoreWebDocumentViewerMiddleware

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebDocumentViewerMiddleware : AtalaWebHandlerMiddleware
Public Class WebDocumentViewerMiddleware
    Inherits AtalaWebHandlerMiddleware

The WebDocumentViewerMiddleware type exposes the following members.

Constructors
 | Name | Description
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment) | Initializes a new instance of WebDocumentViewerMiddleware class.
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment, IWebDocumentViewerCallbacks) | Initializes a new instance of WebDocumentViewerMiddleware class with specified callbacks.
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment, WebDocumentViewerOptions) | Initializes a new instance of WebDocumentViewerMiddleware class with specified options.
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment, WebDocumentViewerOptions, IWebDocumentViewerCallbacks) | Initializes a new instance of WebDocumentViewerMiddleware class with specified options and callbacks.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Request handling method
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Constructor

Overload List
 | Name | Description
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment) | Initializes a new instance of WebDocumentViewerMiddleware class.
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment, IWebDocumentViewerCallbacks) | Initializes a new instance of WebDocumentViewerMiddleware class with specified callbacks.
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment, WebDocumentViewerOptions) | Initializes a new instance of WebDocumentViewerMiddleware class with specified options.
Public method | WebDocumentViewerMiddleware(RequestDelegate, IHostingEnvironment, WebDocumentViewerOptions, IWebDocumentViewerCallbacks) | Initializes a new instance of WebDocumentViewerMiddleware class with specified options and callbacks.
Top
See Also

Reference

WebDocumentViewerMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Constructor (RequestDelegate, IHostingEnvironment)

Initializes a new instance of WebDocumentViewerMiddleware class.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentViewerMiddleware(
    RequestDelegate next,
    IHostingEnvironment env
)
Public Sub New (
    next As RequestDelegate,
    env As IHostingEnvironment
)

Parameters

next
Type: RequestDelegate
The delegate representing the remaining middleware in the request pipeline. Ignores by this middleware.
env
Type: IHostingEnvironment
The information about the web hosting environment.
See Also

Reference

WebDocumentViewerMiddleware Class
WebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Constructor (RequestDelegate, IHostingEnvironment, IWebDocumentViewerCallbacks)

Initializes a new instance of WebDocumentViewerMiddleware class with specified callbacks.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentViewerMiddleware(
    RequestDelegate next,
    IHostingEnvironment env,
    IWebDocumentViewerCallbacks callbacks
)
Public Sub New (
    next As RequestDelegate,
    env As IHostingEnvironment,
    callbacks As IWebDocumentViewerCallbacks
)

Parameters

next
Type: RequestDelegate
The delegate representing the remaining middleware in the request pipeline. Ignores by this middleware.
env
Type: IHostingEnvironment
The information about the web hosting environment.
callbacks
Type: Atalasoft.Imaging.WebControls.CoreIWebDocumentViewerCallbacks
The IWebDocumentViewerCallbacks object.
See Also

Reference

WebDocumentViewerMiddleware Class
WebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Constructor (RequestDelegate, IHostingEnvironment, WebDocumentViewerOptions)

Initializes a new instance of WebDocumentViewerMiddleware class with specified options.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentViewerMiddleware(
    RequestDelegate next,
    IHostingEnvironment env,
    WebDocumentViewerOptions options
)
Public Sub New (
    next As RequestDelegate,
    env As IHostingEnvironment,
    options As WebDocumentViewerOptions
)

Parameters

next
Type: RequestDelegate
The delegate representing the remaining middleware in the request pipeline. Ignores by this middleware.
env
Type: IHostingEnvironment
The information about the web hosting environment.
options
Type: Atalasoft.Imaging.WebControls.CoreWebDocumentViewerOptions
The WebDocumentViewerOptions object.
See Also

Reference

WebDocumentViewerMiddleware Class
WebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Constructor (RequestDelegate, IHostingEnvironment, WebDocumentViewerOptions, IWebDocumentViewerCallbacks)

Initializes a new instance of WebDocumentViewerMiddleware class with specified options and callbacks.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentViewerMiddleware(
    RequestDelegate next,
    IHostingEnvironment env,
    WebDocumentViewerOptions options,
    IWebDocumentViewerCallbacks callbacks
)
Public Sub New (
    next As RequestDelegate,
    env As IHostingEnvironment,
    options As WebDocumentViewerOptions,
    callbacks As IWebDocumentViewerCallbacks
)

Parameters

next
Type: RequestDelegate
The delegate representing the remaining middleware in the request pipeline. Ignores by this middleware.
env
Type: IHostingEnvironment
The information about the web hosting environment.
options
Type: Atalasoft.Imaging.WebControls.CoreWebDocumentViewerOptions
The WebDocumentViewerOptions object.
callbacks
Type: Atalasoft.Imaging.WebControls.CoreIWebDocumentViewerCallbacks
The IWebDocumentViewerCallbacks object.
See Also

Reference

WebDocumentViewerMiddleware Class
WebDocumentViewerMiddleware Overload
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware Methods

The WebDocumentViewerMiddleware type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Request handling method
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebDocumentViewerMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerMiddleware.Invoke Method

WebDocumentViewerMiddlewareInvoke Method

Request handling method

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Task Invoke(
    HttpContext context
)
Public Function Invoke (
    context As HttpContext
) As Task

Parameters

context
Type: HttpContext
The HttpContext for the current request.

Return Value

Type: Task
A Task that represents the execution of this middleware.
See Also

Reference

WebDocumentViewerMiddleware Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerOptions Class

Options for the WebDocumentViewerMiddleware.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.CoreWebDocumentViewerOptions

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebDocumentViewerOptions
Public Class WebDocumentViewerOptions

The WebDocumentViewerOptions type exposes the following members.

Constructors
 | Name | Description
Public method | WebDocumentViewerOptions | Initializes a new instance of the WebDocumentViewerOptions class
Top
Properties
 | Name | Description
Public property | ReplaceFileExtensionOnSave | Gets or sets a value indicating for which files WDV should set extensions during document save operation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerOptions Constructor

Initializes a new instance of the WebDocumentViewerOptions class

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentViewerOptions()
Public Sub New
See Also

Reference

WebDocumentViewerOptions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerOptions Properties

The WebDocumentViewerOptions type exposes the following members.

Properties
 | Name | Description
Public property | ReplaceFileExtensionOnSave | Gets or sets a value indicating for which files WDV should set extensions during document save operation.
Top
See Also

Reference

WebDocumentViewerOptions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerOptions.ReplaceFileExtensionOnSave Property

WebDocumentViewerOptionsReplaceFileExtensionOnSave Property

Gets or sets a value indicating for which files WDV should set extensions during document save operation.

Namespace: Atalasoft.Imaging.WebControls.Core
Assembly: Atalasoft.dotImage.WebControls.Core (in Atalasoft.dotImage.WebControls.Core.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplaceFileExtension ReplaceFileExtensionOnSave { get; set; }
Public Property ReplaceFileExtensionOnSave As ReplaceFileExtension
    Get
    Set

Property Value

Type: ReplaceFileExtension
See Also

Reference

WebDocumentViewerOptions Class
Atalasoft.Imaging.WebControls.Core Namespace


WebDocumentViewerOptions Methods

The WebDocumentViewerOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebDocumentViewerOptions Class
Atalasoft.Imaging.WebControls.Core Namespace


Atalasoft.Imaging.WebControls.Exceptions Namespace

Classes
 | Class | Description
Public class | ImageSourceException | The exception is thrown when the page retrieval from WebDocumentImageSource fails.
Public class | ResolveUriException | The exception is thrown when resolve Uri fails.
Public class | WebDocumentException | The exception is thrown when a document or pages manipulations are unavailable.


ImageSourceException Class

The exception is thrown when the page retrieval from WebDocumentImageSource fails.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ExceptionsAtalaException
Atalasoft.Imaging.WebControls.ExceptionsImageSourceException

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageSourceException : AtalaException
Public Class ImageSourceException
    Inherits AtalaException

The ImageSourceException type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSourceException | Initializes a new instance of the ImageSourceException class.
Public method | ImageSourceException(String) | Initializes a new instance of the ImageSourceException class.
Protected method | ImageSourceException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageSourceException class.
Public method | ImageSourceException(String, Exception) | Initializes a new instance of the ImageSourceException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Constructor

Overload List
 | Name | Description
Public method | ImageSourceException | Initializes a new instance of the ImageSourceException class.
Public method | ImageSourceException(String) | Initializes a new instance of the ImageSourceException class.
Protected method | ImageSourceException(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageSourceException class.
Public method | ImageSourceException(String, Exception) | Initializes a new instance of the ImageSourceException class.
Top
See Also

Reference

ImageSourceException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Constructor

Initializes a new instance of the ImageSourceException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceException()
Public Sub New
See Also

Reference

ImageSourceException Class
ImageSourceException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Constructor (String)

Initializes a new instance of the ImageSourceException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

ImageSourceException Class
ImageSourceException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImageSourceException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageSourceException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ImageSourceException Class
ImageSourceException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Constructor (String, Exception)

Initializes a new instance of the ImageSourceException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageSourceException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

ImageSourceException Class
ImageSourceException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Properties

The ImageSourceException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageSourceException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Methods

The ImageSourceException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ImageSourceException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ImageSourceException Events

The ImageSourceException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ImageSourceException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Class

The exception is thrown when resolve Uri fails.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ExceptionsAtalaException
Atalasoft.Imaging.WebControls.ExceptionsResolveUriException

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ResolveUriException : AtalaException
Public Class ResolveUriException
    Inherits AtalaException

The ResolveUriException type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveUriException | Initializes a new instance of the ResolveUriException class.
Public method | ResolveUriException(String) | Initializes a new instance of the ResolveUriException class.
Protected method | ResolveUriException(SerializationInfo, StreamingContext) | Initializes a new instance of the ResolveUriException class.
Public method | ResolveUriException(String, Exception) | Initializes a new instance of the ResolveUriException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Constructor

Overload List
 | Name | Description
Public method | ResolveUriException | Initializes a new instance of the ResolveUriException class.
Public method | ResolveUriException(String) | Initializes a new instance of the ResolveUriException class.
Protected method | ResolveUriException(SerializationInfo, StreamingContext) | Initializes a new instance of the ResolveUriException class.
Public method | ResolveUriException(String, Exception) | Initializes a new instance of the ResolveUriException class.
Top
See Also

Reference

ResolveUriException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Constructor

Initializes a new instance of the ResolveUriException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolveUriException()
Public Sub New
See Also

Reference

ResolveUriException Class
ResolveUriException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Constructor (String)

Initializes a new instance of the ResolveUriException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolveUriException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

ResolveUriException Class
ResolveUriException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ResolveUriException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ResolveUriException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ResolveUriException Class
ResolveUriException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Constructor (String, Exception)

Initializes a new instance of the ResolveUriException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolveUriException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

ResolveUriException Class
ResolveUriException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Properties

The ResolveUriException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ResolveUriException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Methods

The ResolveUriException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ResolveUriException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


ResolveUriException Events

The ResolveUriException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ResolveUriException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Class

The exception is thrown when a document or pages manipulations are unavailable.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.ExceptionsAtalaException
Atalasoft.Imaging.WebControls.ExceptionsWebDocumentException

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebDocumentException : AtalaException
Public Class WebDocumentException
    Inherits AtalaException

The WebDocumentException type exposes the following members.

Constructors
 | Name | Description
Public method | WebDocumentException | Initializes a new instance of the WebDocumentException class.
Public method | WebDocumentException(String) | Initializes a new instance of the WebDocumentException class.
Protected method | WebDocumentException(SerializationInfo, StreamingContext) | Initializes a new instance of the WebDocumentException class.
Public method | WebDocumentException(String, Exception) | Initializes a new instance of the WebDocumentException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Constructor

Overload List
 | Name | Description
Public method | WebDocumentException | Initializes a new instance of the WebDocumentException class.
Public method | WebDocumentException(String) | Initializes a new instance of the WebDocumentException class.
Protected method | WebDocumentException(SerializationInfo, StreamingContext) | Initializes a new instance of the WebDocumentException class.
Public method | WebDocumentException(String, Exception) | Initializes a new instance of the WebDocumentException class.
Top
See Also

Reference

WebDocumentException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Constructor

Initializes a new instance of the WebDocumentException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentException()
Public Sub New
See Also

Reference

WebDocumentException Class
WebDocumentException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Constructor (String)

Initializes a new instance of the WebDocumentException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

WebDocumentException Class
WebDocumentException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the WebDocumentException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected WebDocumentException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

WebDocumentException Class
WebDocumentException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Constructor (String, Exception)

Initializes a new instance of the WebDocumentException class.

Namespace: Atalasoft.Imaging.WebControls.Exceptions
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

WebDocumentException Class
WebDocumentException Overload
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Properties

The WebDocumentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WebDocumentException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Methods

The WebDocumentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WebDocumentException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


WebDocumentException Events

The WebDocumentException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

WebDocumentException Class
Atalasoft.Imaging.WebControls.Exceptions Namespace


Atalasoft.Imaging.WebControls.Mvc Namespace

Classes
 | Class | Description
Public class | ActionResultHelper |
Public class | WebViewerControlResult |
Public class | WebViewerControlResultViewerInitArgs |
Delegates
 | Delegate | Description
Public delegate | WebViewerControlResultViewerInitEventHandler |


ActionResultHelper Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.MvcActionResultHelper

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ActionResultHelper
Public Class ActionResultHelper

The ActionResultHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ActionResultHelper | Initializes a new instance of the ActionResultHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsWebViewerControlRequest |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Mvc Namespace


ActionResultHelper Constructor

Initializes a new instance of the ActionResultHelper class

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ActionResultHelper()
Public Sub New
See Also

Reference

ActionResultHelper Class
Atalasoft.Imaging.WebControls.Mvc Namespace


ActionResultHelper Methods

The ActionResultHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsWebViewerControlRequest |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionResultHelper Class
Atalasoft.Imaging.WebControls.Mvc Namespace


ActionResultHelper.IsWebViewerControlRequest Method

ActionResultHelperIsWebViewerControlRequest Method

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsWebViewerControlRequest(
    Controller controller
)
Public Shared Function IsWebViewerControlRequest (
    controller As Controller
) As Boolean

Parameters

controller
Type: Controller

Return Value

Type: Boolean
See Also

Reference

ActionResultHelper Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Class

Inheritance Hierarchy
SystemObject
ActionResult
Atalasoft.Imaging.WebControls.MvcWebViewerControlResult

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WebViewerControlResult : ActionResult
Public Class WebViewerControlResult
    Inherits ActionResult

The WebViewerControlResult type exposes the following members.

Constructors
 | Name | Description
Public method | WebViewerControlResult(Controller, String) | Initializes a new instance of the WebViewerControlResult class
Public method | WebViewerControlResult(Controller, NameValueCollection, String) | Initializes a new instance of the WebViewerControlResult class
Public method | WebViewerControlResult(Controller, String, String, String) | Initializes a new instance of the WebViewerControlResult class
Public method | WebViewerControlResult(Controller, NameValueCollection, String, String, String) | Initializes a new instance of the WebViewerControlResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteResult | (Overrides ActionResult.ExecuteResult(ControllerContext).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnViewerInit |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ViewerInit |
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Constructor

Overload List
 | Name | Description
Public method | WebViewerControlResult(Controller, String) | Initializes a new instance of the WebViewerControlResult class
Public method | WebViewerControlResult(Controller, NameValueCollection, String) | Initializes a new instance of the WebViewerControlResult class
Public method | WebViewerControlResult(Controller, String, String, String) | Initializes a new instance of the WebViewerControlResult class
Public method | WebViewerControlResult(Controller, NameValueCollection, String, String, String) | Initializes a new instance of the WebViewerControlResult class
Top
See Also

Reference

WebViewerControlResult Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Constructor (Controller, String)

Initializes a new instance of the WebViewerControlResult class

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControlResult(
    Controller controller,
    string pathToPage
)
Public Sub New (
    controller As Controller,
    pathToPage As String
)

Parameters

controller
Type: Controller
pathToPage
Type: SystemString
See Also

Reference

WebViewerControlResult Class
WebViewerControlResult Overload
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Constructor (Controller, NameValueCollection, String)

Initializes a new instance of the WebViewerControlResult class

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControlResult(
    Controller controller,
    NameValueCollection requestParams,
    string pathToPage
)
Public Sub New (
    controller As Controller,
    requestParams As NameValueCollection,
    pathToPage As String
)

Parameters

controller
Type: Controller
requestParams
Type: System.Collections.SpecializedNameValueCollection
pathToPage
Type: SystemString
See Also

Reference

WebViewerControlResult Class
WebViewerControlResult Overload
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Constructor (Controller, String, String, String)

Initializes a new instance of the WebViewerControlResult class

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControlResult(
    Controller controller,
    string pathToPage,
    string sessionID,
    string pageName
)
Public Sub New (
    controller As Controller,
    pathToPage As String,
    sessionID As String,
    pageName As String
)

Parameters

controller
Type: Controller
pathToPage
Type: SystemString
sessionID
Type: SystemString
pageName
Type: SystemString
See Also

Reference

WebViewerControlResult Class
WebViewerControlResult Overload
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Constructor (Controller, NameValueCollection, String, String, String)

Initializes a new instance of the WebViewerControlResult class

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControlResult(
    Controller controller,
    NameValueCollection requestParams,
    string pathToPage,
    string sessionID,
    string pageName
)
Public Sub New (
    controller As Controller,
    requestParams As NameValueCollection,
    pathToPage As String,
    sessionID As String,
    pageName As String
)

Parameters

controller
Type: Controller
requestParams
Type: System.Collections.SpecializedNameValueCollection
pathToPage
Type: SystemString
sessionID
Type: SystemString
pageName
Type: SystemString
See Also

Reference

WebViewerControlResult Class
WebViewerControlResult Overload
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Methods

The WebViewerControlResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteResult | (Overrides ActionResult.ExecuteResult(ControllerContext).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnViewerInit |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebViewerControlResult Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ExecuteResult Method

WebViewerControlResultExecuteResult Method

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ExecuteResult(
    ControllerContext context
)
Public Overrides Sub ExecuteResult (
    context As ControllerContext
)

Parameters

context
Type: ControllerContext
See Also

Reference

WebViewerControlResult Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.OnViewerInit Method

WebViewerControlResultOnViewerInit Method

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnViewerInit(
    WebViewerControlResultViewerInitArgs e
)
Protected Overridable Sub OnViewerInit (
    e As WebViewerControlResultViewerInitArgs
)

Parameters

e
Type: Atalasoft.Imaging.WebControls.MvcWebViewerControlResultViewerInitArgs
See Also

Reference

WebViewerControlResult Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult Events

The WebViewerControlResult type exposes the following members.

Events
 | Name | Description
Public event | ViewerInit |
Top
See Also

Reference

WebViewerControlResult Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInit Event

WebViewerControlResultViewerInit Event

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event WebViewerControlResultViewerInitEventHandler ViewerInit
Public Event ViewerInit As WebViewerControlResultViewerInitEventHandler

Value

Type: Atalasoft.Imaging.WebControls.MvcWebViewerControlResultViewerInitEventHandler
See Also

Reference

WebViewerControlResult Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInitArgs Class

WebViewerControlResultViewerInitArgs Class

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.MvcWebViewerControlResultViewerInitArgs

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ViewerInitArgs
Public Class ViewerInitArgs

The WebViewerControlResultViewerInitArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WebViewerControlResultViewerInitArgs | Initializes a new instance of the WebViewerControlResultViewerInitArgs class
Top
Properties
 | Name | Description
Public property | Controller |
Public property | RequestParams |
Public property | Viewer |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInitArgs Constructor

WebViewerControlResultViewerInitArgs Constructor

Initializes a new instance of the WebViewerControlResultViewerInitArgs class

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ViewerInitArgs()
Public Sub New
See Also

Reference

WebViewerControlResultViewerInitArgs Class
Atalasoft.Imaging.WebControls.Mvc Namespace


ViewerInitArgs Properties

The WebViewerControlResultViewerInitArgs type exposes the following members.

Properties
 | Name | Description
Public property | Controller |
Public property | RequestParams |
Public property | Viewer |
Top
See Also

Reference

WebViewerControlResultViewerInitArgs Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInitArgs.Controller Property

WebViewerControlResultViewerInitArgsController Property

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Controller Controller { get; set; }
Public Property Controller As Controller
    Get
    Set

Property Value

Type: Controller
See Also

Reference

WebViewerControlResultViewerInitArgs Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInitArgs.RequestParams Property

WebViewerControlResultViewerInitArgsRequestParams Property

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NameValueCollection RequestParams { get; set; }
Public Property RequestParams As NameValueCollection
    Get
    Set

Property Value

Type: NameValueCollection
See Also

Reference

WebViewerControlResultViewerInitArgs Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInitArgs.Viewer Property

WebViewerControlResultViewerInitArgsViewer Property

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebViewerControl Viewer { get; set; }
Public Property Viewer As WebViewerControl
    Get
    Set

Property Value

Type: WebViewerControl
See Also

Reference

WebViewerControlResultViewerInitArgs Class
Atalasoft.Imaging.WebControls.Mvc Namespace


ViewerInitArgs Methods

The WebViewerControlResultViewerInitArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebViewerControlResultViewerInitArgs Class
Atalasoft.Imaging.WebControls.Mvc Namespace


WebViewerControlResult.ViewerInitEventHandler Delegate

WebViewerControlResultViewerInitEventHandler Delegate

Namespace: Atalasoft.Imaging.WebControls.Mvc
Assembly: Atalasoft.dotImage.WebControls.Mvc (in Atalasoft.dotImage.WebControls.Mvc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ViewerInitEventHandler(
    Object sender,
    WebViewerControlResultViewerInitArgs e
)
Public Delegate Sub ViewerInitEventHandler (
    sender As Object,
    e As WebViewerControlResultViewerInitArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WebControls.MvcWebViewerControlResultViewerInitArgs
See Also

Reference

Atalasoft.Imaging.WebControls.Mvc Namespace


Atalasoft.Imaging.WebControls.OCR Namespace

Classes
 | Class | Description
Public class | JsonTranslator | Represents ITranslator that generates output compatible with Atalasoft.Imaging.WebControls.Document format.


JsonTranslator Class

Represents ITranslator that generates output compatible with Atalasoft.Imaging.WebControls.Document format.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.OCRJsonTranslator

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class JsonTranslator : IForeignTranslator,
    ITranslator
Public Class JsonTranslator
    Implements IForeignTranslator, ITranslator

The JsonTranslator type exposes the following members.

Constructors
 | Name | Description
Public method | JsonTranslator | Initializes a new instance of the JsonTranslator class
Top
Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Allow a foreign translator to perform any necessary cleanup.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Prepare | Prepare a foreign translator for translation.
Public method | Supported | Get an array of mime types supported by this translator.
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
Fields
Name | Description
MimeType | The supported MIME type.
Top
See Also

Reference

Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator Constructor

Initializes a new instance of the JsonTranslator class

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public JsonTranslator()
Public Sub New
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator Methods

The JsonTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Allow a foreign translator to perform any necessary cleanup.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Prepare | Prepare a foreign translator for translation.
Public method | Supported | Get an array of mime types supported by this translator.
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.CanStream Method

JsonTranslatorCanStream Method

Checks to see if this translator is capable of streaming.

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanStream()
Public Function CanStream As Boolean

Return Value

Type: Boolean
True if the translator can stream, false otherwise.

Implements

ITranslatorCanStream
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Finish Method

JsonTranslatorFinish Method

Allow a foreign translator to perform any necessary cleanup.

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Finish(
    OcrEngine engine,
    OcrDocument doc,
    bool successful,
    Object translationObject
)
Public Sub Finish (
    engine As OcrEngine,
    doc As OcrDocument,
    successful As Boolean,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that has done the recognition.
doc
Type: Atalasoft.OcrOcrDocument
The recognized document.
successful
Type: SystemBoolean
Indicates that recognition was successful.
translationObject
Type: SystemObject
An object originally provided by the return value of the Prepare(OcrEngine, OcrDocument) method.

Implements

IForeignTranslatorFinish(OcrEngine, OcrDocument, Boolean, Object)
Remarks
While some foreign translator implementations may not need an associated engine, it is best to always provide one as some translators will require it.
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Prepare Method

JsonTranslatorPrepare Method

Prepare a foreign translator for translation.

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Prepare(
    OcrEngine engine,
    OcrDocument doc
)
Public Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that will perform the recognition.
doc
Type: Atalasoft.OcrOcrDocument
The document that will be populated by the engine.

Return Value

Type: Object
An object that will be used specifically by the foreign translator for document translation.

Implements

IForeignTranslatorPrepare(OcrEngine, OcrDocument)
Remarks

This method is provided for two purposes. The first is to establish a translator-specific object to maintain state information about the current translator session. The second is to populate the OcrDocument object with metadata or infrastructure for metadata.

During translation, OcrEngine will construct an empty OcrDocument and pass both itself and the document to the foreign translator through Prepare. Then the engine will attempt to recognize pages, then the foreign translator will translate the OcrDocument into final form. If an error occurs, the foreign translator is always given an opportunity to clean up via the Finish(OcrEngine, OcrDocument, Boolean, Object) method.

See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Supported Method

JsonTranslatorSupported Method

Get an array of mime types supported by this translator.

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] Supported()
Public Function Supported As String()

Return Value

Type: String
An array of strings containing mime types supported by this translator.

Implements

ITranslatorSupported
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Supports Method

JsonTranslatorSupports Method

Checks to see if a specific mime type is supported by this translator.

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Supports(
    string mimeType
)
Public Function Supports (
    mimeType As String
) As Boolean

Parameters

mimeType
Type: SystemString
A string representing a mime type to be checked.

Return Value

Type: Boolean
True if the mime type is supported, false otherwise.

Implements

ITranslatorSupports(String)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Translate Method

JsonTranslatorTranslate Method

Overload List
 | Name | Description
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Translate Method (OcrEngine, OcrDocument, String, Stream, Object)

JsonTranslatorTranslate Method (OcrEngine, OcrDocument, String, Stream, Object)

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    Stream outStream,
    Object translationObject
)
Public Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outStream As Stream,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outStream
Type: System.IOStream
translationObject
Type: SystemObject

Implements

IForeignTranslatorTranslate(OcrEngine, OcrDocument, String, Stream, Object)
Exceptions
Exception | Condition
 | Throws if the MIME type is unknown.
See Also

Reference

JsonTranslator Class
Translate Overload
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.Translate Method (OcrEngine, OcrDocument, String, String, Object)

JsonTranslatorTranslate Method (OcrEngine, OcrDocument, String, String, Object)

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    string outFileName,
    Object translationObject
)
Public Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outFileName As String,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outFileName
Type: SystemString
translationObject
Type: SystemObject

Implements

IForeignTranslatorTranslate(OcrEngine, OcrDocument, String, String, Object)
Exceptions
Exception | Condition
 | Throws if the MIME type is unknown.
See Also

Reference

JsonTranslator Class
Translate Overload
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator Fields

The JsonTranslator type exposes the following members.

Fields
Name | Description
MimeType | The supported MIME type.
Top
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


JsonTranslator.MimeType Field

JsonTranslatorMimeType Field

The supported MIME type.

Namespace: Atalasoft.Imaging.WebControls.OCR
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string MimeType = "application/json"
Public Const MimeType As String = "application/json"

Field Value

Type: String
See Also

Reference

JsonTranslator Class
Atalasoft.Imaging.WebControls.OCR Namespace


Atalasoft.Imaging.WebControls.Text Namespace

Classes
 | Class | Description
Public class | Document | Represents OCR document
Public class | Glyph | Represents OCR glyph.
Public class | Line | Represents OCR line.
Public class | Page | Represents OCR page
Public class | PageObject | Represents page OCR item.
Public class | Region | Represents OCR region.
Public class | SegmentedTextTranslator | Represents segmented text translator.
Public class | Word | Represents OCR word
Enumerations
 | Enumeration | Description
Public enumeration | TextRegionDetectionMode | Specifies supported region detection modes.


Document Class

Represents OCR document
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextDocument

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Document
Public Class Document

The Document type exposes the following members.

Constructors
 | Name | Description
Public method | Document(OcrDocument) | Initializes a new instance of the Document class.
Public method | Document(IEnumerablePage) | Initializes a new instance of the Document class.
Top
Properties
 | Name | Description
Public property | Pages | Gets document the pages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson(Stream) | Reads the document data from the stream containing its json representation.
 | FromJson(String) | Reads the document data from the string json representation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToJson | Serializes current instance to the json string.
Public method | ToJson(Stream) | Serializes current instance to the provided stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Document Constructor

Overload List
 | Name | Description
Public method | Document(OcrDocument) | Initializes a new instance of the Document class.
Public method | Document(IEnumerablePage) | Initializes a new instance of the Document class.
Top
See Also

Reference

Document Class
Atalasoft.Imaging.WebControls.Text Namespace


Document Constructor (OcrDocument)

Initializes a new instance of the Document class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document(
    OcrDocument document
)
Public Sub New (
    document As OcrDocument
)

Parameters

document
Type: Atalasoft.OcrOcrDocument
The ocr engine document.
See Also

Reference

Document Class
Document Overload
Atalasoft.Imaging.WebControls.Text Namespace


Document Constructor (IEnumerable(Page))

Document Constructor (IEnumerablePage)

Initializes a new instance of the Document class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document(
    IEnumerable<Page> pages
)
Public Sub New (
    pages As IEnumerable(Of Page)
)

Parameters

pages
Type: System.Collections.GenericIEnumerablePage
The document pages.
See Also

Reference

Document Class
Document Overload
Atalasoft.Imaging.WebControls.Text Namespace


Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
Public property | Pages | Gets document the pages.
Top
See Also

Reference

Document Class
Atalasoft.Imaging.WebControls.Text Namespace


Document.Pages Property

DocumentPages Property

Gets document the pages.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<Page> Pages { get; }
Public ReadOnly Property Pages As IList(Of Page)
    Get

Property Value

Type: IListPage
See Also

Reference

Document Class
Atalasoft.Imaging.WebControls.Text Namespace


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson(Stream) | Reads the document data from the stream containing its json representation.
 | FromJson(String) | Reads the document data from the string json representation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToJson | Serializes current instance to the json string.
Public method | ToJson(Stream) | Serializes current instance to the provided stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Document Class
Atalasoft.Imaging.WebControls.Text Namespace


Document.FromJson Method

DocumentFromJson Method

Overload List
Name | Description
FromJson(Stream) | Reads the document data from the stream containing its json representation.
FromJson(String) | Reads the document data from the string json representation.
Top
See Also

Reference

Document Class
Atalasoft.Imaging.WebControls.Text Namespace


Document.FromJson Method (Stream)

DocumentFromJson Method (Stream)

Reads the document data from the stream containing its json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Document FromJson(
    Stream stream
)
Public Shared Function FromJson (
    stream As Stream
) As Document

Parameters

stream
Type: System.IOStream
The stream containing document json.

Return Value

Type: Document
Document object instance.
Exceptions
Exception | Condition
ArgumentNullException | stream is null.
See Also

Reference

Document Class
FromJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Document.FromJson Method (String)

DocumentFromJson Method (String)

Reads the document data from the string json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Document FromJson(
    string json
)
Public Shared Function FromJson (
    json As String
) As Document

Parameters

json
Type: SystemString
The document json string.

Return Value

Type: Document
Document object instance.
See Also

Reference

Document Class
FromJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Document.ToJson Method

DocumentToJson Method

Overload List
 | Name | Description
Public method | ToJson | Serializes current instance to the json string.
Public method | ToJson(Stream) | Serializes current instance to the provided stream.
Top
See Also

Reference

Document Class
Atalasoft.Imaging.WebControls.Text Namespace


Document.ToJson Method

DocumentToJson Method

Serializes current instance to the json string.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToJson()
Public Function ToJson As String

Return Value

Type: String
Document json representation.
See Also

Reference

Document Class
ToJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Document.ToJson Method (Stream)

DocumentToJson Method (Stream)

Serializes current instance to the provided stream.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ToJson(
    Stream stream
)
Public Sub ToJson (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream to serialize the document.
Exceptions
Exception | Condition
ArgumentNullException | stream is null.
See Also

Reference

Document Class
ToJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Glyph Class

Represents OCR glyph.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextPageObject
Atalasoft.Imaging.WebControls.TextGlyph

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Glyph : PageObject
Public Class Glyph
    Inherits PageObject

The Glyph type exposes the following members.

Constructors
 | Name | Description
Public method | Glyph(OcrGlyph) | Initializes a new instance of the Glyph class.
Public method | Glyph(RectangleF, String) | Initializes a new instance of the Glyph class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Text | Gets or sets the text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Glyph Constructor

Overload List
 | Name | Description
Public method | Glyph(OcrGlyph) | Initializes a new instance of the Glyph class.
Public method | Glyph(RectangleF, String) | Initializes a new instance of the Glyph class.
Top
See Also

Reference

Glyph Class
Atalasoft.Imaging.WebControls.Text Namespace


Glyph Constructor (OcrGlyph)

Initializes a new instance of the Glyph class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Glyph(
    OcrGlyph glyph
)
Public Sub New (
    glyph As OcrGlyph
)

Parameters

glyph
Type: Atalasoft.OcrOcrGlyph
The ocr engine glyph.
See Also

Reference

Glyph Class
Glyph Overload
Atalasoft.Imaging.WebControls.Text Namespace


Glyph Constructor (RectangleF, String)

Initializes a new instance of the Glyph class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Glyph(
    RectangleF bounds,
    string text
)
Public Sub New (
    bounds As RectangleF,
    text As String
)

Parameters

bounds
Type: System.DrawingRectangleF
The glyph bounds.
text
Type: SystemString
The glyph text.
See Also

Reference

Glyph Class
Glyph Overload
Atalasoft.Imaging.WebControls.Text Namespace


Glyph Properties

The Glyph type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Text | Gets or sets the text.
Top
See Also

Reference

Glyph Class
Atalasoft.Imaging.WebControls.Text Namespace


Glyph.Text Property

GlyphText Property

Gets or sets the text.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Glyph Class
Atalasoft.Imaging.WebControls.Text Namespace


Glyph Methods

The Glyph type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Glyph Class
Atalasoft.Imaging.WebControls.Text Namespace


Glyph.ToHastableJson Method

GlyphToHastableJson Method

Converts the object to the hash table json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Hashtable ToHastableJson()
Protected Overrides Function ToHastableJson As Hashtable

Return Value

Type: Hashtable
Hashtable containing object values.
See Also

Reference

Glyph Class
Atalasoft.Imaging.WebControls.Text Namespace


Line Class

Represents OCR line.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextPageObject
Atalasoft.Imaging.WebControls.TextLine

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Line : PageObject
Public Class Line
    Inherits PageObject

The Line type exposes the following members.

Constructors
 | Name | Description
Public method | Line(OcrLine) | Initializes a new instance of the Line class.
Public method | Line(RectangleF, IEnumerableWord) | Initializes a new instance of the Line class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Words | Gets or sets the words.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Line Constructor

Overload List
 | Name | Description
Public method | Line(OcrLine) | Initializes a new instance of the Line class.
Public method | Line(RectangleF, IEnumerableWord) | Initializes a new instance of the Line class.
Top
See Also

Reference

Line Class
Atalasoft.Imaging.WebControls.Text Namespace


Line Constructor (OcrLine)

Initializes a new instance of the Line class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Line(
    OcrLine line
)
Public Sub New (
    line As OcrLine
)

Parameters

line
Type: Atalasoft.OcrOcrLine
The ocr engine line.
See Also

Reference

Line Class
Line Overload
Atalasoft.Imaging.WebControls.Text Namespace


Line Constructor (RectangleF, IEnumerable(Word))

Line Constructor (RectangleF, IEnumerableWord)

Initializes a new instance of the Line class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Line(
    RectangleF bounds,
    IEnumerable<Word> words
)
Public Sub New (
    bounds As RectangleF,
    words As IEnumerable(Of Word)
)

Parameters

bounds
Type: System.DrawingRectangleF
The line bounds.
words
Type: System.Collections.GenericIEnumerableWord
The line words.
See Also

Reference

Line Class
Line Overload
Atalasoft.Imaging.WebControls.Text Namespace


Line Properties

The Line type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Words | Gets or sets the words.
Top
See Also

Reference

Line Class
Atalasoft.Imaging.WebControls.Text Namespace


Line.Words Property

LineWords Property

Gets or sets the words.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<Word> Words { get; }
Public ReadOnly Property Words As IList(Of Word)
    Get

Property Value

Type: IListWord
See Also

Reference

Line Class
Atalasoft.Imaging.WebControls.Text Namespace


Line Methods

The Line type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Line Class
Atalasoft.Imaging.WebControls.Text Namespace


Line.ToHastableJson Method

LineToHastableJson Method

Converts the object to the hash table json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Hashtable ToHastableJson()
Protected Overrides Function ToHastableJson As Hashtable

Return Value

Type: Hashtable
Hashtable containing object values.
See Also

Reference

Line Class
Atalasoft.Imaging.WebControls.Text Namespace


Page Class

Represents OCR page
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextPageObject
Atalasoft.Imaging.WebControls.TextPage

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Page : PageObject
Public Class Page
    Inherits PageObject

The Page type exposes the following members.

Constructors
 | Name | Description
Public method | Page(OcrPage) | Initializes a new instance of the Page class.
Public method | Page(RectangleF, IEnumerableRegion, Double, Double) | Initializes a new instance of the Word class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Regions | Gets the page text regions.
Public property | ResolutionX | Gets the page horizontal resolution.
Public property | ResolutionY | Gets the page vertical resolution.
Public property | Rotation | Gets or sets the text data rotation relative to page image rotation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson(Stream) | Reads the page data from the stream containing its json representation.
 | FromJson(String) | Reads the page data from the string json representation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToJson | Serializes current instance to the json string.
Public method | ToJson(Stream) | Serializes current instance to the provided stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Page Constructor

Overload List
 | Name | Description
Public method | Page(OcrPage) | Initializes a new instance of the Page class.
Public method | Page(RectangleF, IEnumerableRegion, Double, Double) | Initializes a new instance of the Word class.
Top
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page Constructor (OcrPage)

Initializes a new instance of the Page class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Page(
    OcrPage page
)
Public Sub New (
    page As OcrPage
)

Parameters

page
Type: Atalasoft.OcrOcrPage
The ocr engine page.
See Also

Reference

Page Class
Page Overload
Atalasoft.Imaging.WebControls.Text Namespace


Page Constructor (RectangleF, IEnumerable(Region), Double, Double)

Page Constructor (RectangleF, IEnumerableRegion, Double, Double)

Initializes a new instance of the Word class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Page(
    RectangleF bounds,
    IEnumerable<Region> regions,
    double resX,
    double resY
)
Public Sub New (
    bounds As RectangleF,
    regions As IEnumerable(Of Region),
    resX As Double,
    resY As Double
)

Parameters

bounds
Type: System.DrawingRectangleF
The page bounds.
regions
Type: System.Collections.GenericIEnumerableRegion
The text regions of this pages.
resX
Type: SystemDouble
The horizontal resolution.
resY
Type: SystemDouble
The vertical resolution.
See Also

Reference

Page Class
Page Overload
Atalasoft.Imaging.WebControls.Text Namespace


Page Properties

The Page type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Regions | Gets the page text regions.
Public property | ResolutionX | Gets the page horizontal resolution.
Public property | ResolutionY | Gets the page vertical resolution.
Public property | Rotation | Gets or sets the text data rotation relative to page image rotation.
Top
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.Regions Property

PageRegions Property

Gets the page text regions.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<Region> Regions { get; }
Public ReadOnly Property Regions As IList(Of Region)
    Get

Property Value

Type: IListRegion
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.ResolutionX Property

PageResolutionX Property

Gets the page horizontal resolution.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ResolutionX { get; }
Public ReadOnly Property ResolutionX As Double
    Get

Property Value

Type: Double
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.ResolutionY Property

PageResolutionY Property

Gets the page vertical resolution.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ResolutionY { get; }
Public ReadOnly Property ResolutionY As Double
    Get

Property Value

Type: Double
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.Rotation Property

PageRotation Property

Gets or sets the text data rotation relative to page image rotation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentPageRotation Rotation { get; set; }
Public Property Rotation As WebDocumentPageRotation
    Get
    Set

Property Value

Type: WebDocumentPageRotation
Remarks
Use this property to compensate differences between rendered image and extraction data. For example, PDF text is extracted for zero rotation, while image is rendered for current page rotation.
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page Methods

The Page type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson(Stream) | Reads the page data from the stream containing its json representation.
 | FromJson(String) | Reads the page data from the string json representation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToJson | Serializes current instance to the json string.
Public method | ToJson(Stream) | Serializes current instance to the provided stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.FromJson Method

PageFromJson Method

Overload List
Name | Description
FromJson(Stream) | Reads the page data from the stream containing its json representation.
FromJson(String) | Reads the page data from the string json representation.
Top
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.FromJson Method (Stream)

PageFromJson Method (Stream)

Reads the page data from the stream containing its json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Page FromJson(
    Stream stream
)
Public Shared Function FromJson (
    stream As Stream
) As Page

Parameters

stream
Type: System.IOStream
The stream containing page json.

Return Value

Type: Page
Page object instance.
Exceptions
Exception | Condition
ArgumentNullException | stream is null.
See Also

Reference

Page Class
FromJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Page.FromJson Method (String)

PageFromJson Method (String)

Reads the page data from the string json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Page FromJson(
    string json
)
Public Shared Function FromJson (
    json As String
) As Page

Parameters

json
Type: SystemString
The page json string.

Return Value

Type: Page
Page object instance.
See Also

Reference

Page Class
FromJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Page.ToHastableJson Method

PageToHastableJson Method

Converts the object to the hash table json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Hashtable ToHastableJson()
Protected Overrides Function ToHastableJson As Hashtable

Return Value

Type: Hashtable
Hashtable containing object values.
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.ToJson Method

PageToJson Method

Overload List
 | Name | Description
Public method | ToJson | Serializes current instance to the json string.
Public method | ToJson(Stream) | Serializes current instance to the provided stream.
Top
See Also

Reference

Page Class
Atalasoft.Imaging.WebControls.Text Namespace


Page.ToJson Method

PageToJson Method

Serializes current instance to the json string.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToJson()
Public Function ToJson As String

Return Value

Type: String
Page json representation.
See Also

Reference

Page Class
ToJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


Page.ToJson Method (Stream)

PageToJson Method (Stream)

Serializes current instance to the provided stream.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ToJson(
    Stream stream
)
Public Sub ToJson (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream to serialize the page.
Exceptions
Exception | Condition
ArgumentNullException | stream is null.
See Also

Reference

Page Class
ToJson Overload
Atalasoft.Imaging.WebControls.Text Namespace


PageObject Class

Represents page OCR item.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextPageObject
Atalasoft.Imaging.WebControls.TextGlyph
Atalasoft.Imaging.WebControls.TextLine
Atalasoft.Imaging.WebControls.TextPage
Atalasoft.Imaging.WebControls.TextRegion
Atalasoft.Imaging.WebControls.TextWord

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PageObject
Public MustInherit Class PageObject

The PageObject type exposes the following members.

Constructors
 | Name | Description
Protected method | PageObject | Initializes a new instance of the PageObject class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Returns json representation of the object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


PageObject Constructor

Initializes a new instance of the PageObject class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PageObject(
    RectangleF bounds
)
Protected Sub New (
    bounds As RectangleF
)

Parameters

bounds
Type: System.DrawingRectangleF
The element bounds.
See Also

Reference

PageObject Class
Atalasoft.Imaging.WebControls.Text Namespace


PageObject Properties

The PageObject type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds.
Top
See Also

Reference

PageObject Class
Atalasoft.Imaging.WebControls.Text Namespace


PageObject.Bounds Property

PageObjectBounds Property

Gets or sets the element bounds.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Bounds { get; set; }
Public Property Bounds As RectangleF
    Get
    Set

Property Value

Type: RectangleF
See Also

Reference

PageObject Class
Atalasoft.Imaging.WebControls.Text Namespace


PageObject Methods

The PageObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Returns json representation of the object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageObject Class
Atalasoft.Imaging.WebControls.Text Namespace


PageObject.ToHastableJson Method

PageObjectToHastableJson Method

Returns json representation of the object.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Hashtable ToHastableJson()
Protected Overridable Function ToHastableJson As Hashtable

Return Value

Type: Hashtable
See Also

Reference

PageObject Class
Atalasoft.Imaging.WebControls.Text Namespace


Region Class

Represents OCR region.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextPageObject
Atalasoft.Imaging.WebControls.TextRegion

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Region : PageObject
Public Class Region
    Inherits PageObject

The Region type exposes the following members.

Constructors
 | Name | Description
Public method | Region(Hashtable) | Initializes a new instance of the Region class.
Public method | Region(OcrTextRegion) | Initializes a new instance of the Region class.
Public method | Region(RectangleF, WebDocumentPageRotation, IEnumerableLine) | Initializes a new instance of the Region class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Lines | Gets the lines.
Public property | Rotation | Gets or sets the page rotation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Region Constructor

Overload List
 | Name | Description
Public method | Region(Hashtable) | Initializes a new instance of the Region class.
Public method | Region(OcrTextRegion) | Initializes a new instance of the Region class.
Public method | Region(RectangleF, WebDocumentPageRotation, IEnumerableLine) | Initializes a new instance of the Region class.
Top
See Also

Reference

Region Class
Atalasoft.Imaging.WebControls.Text Namespace


Region Constructor (Hashtable)

Initializes a new instance of the Region class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Region(
    Hashtable json
)
Public Sub New (
    json As Hashtable
)

Parameters

json
Type: System.CollectionsHashtable
The region json representation.
See Also

Reference

Region Class
Region Overload
Atalasoft.Imaging.WebControls.Text Namespace


Region Constructor (OcrTextRegion)

Initializes a new instance of the Region class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Region(
    OcrTextRegion region
)
Public Sub New (
    region As OcrTextRegion
)

Parameters

region
Type: Atalasoft.OcrOcrTextRegion
The region.
See Also

Reference

Region Class
Region Overload
Atalasoft.Imaging.WebControls.Text Namespace


Region Constructor (RectangleF, WebDocumentPageRotation, IEnumerable(Line))

Region Constructor (RectangleF, WebDocumentPageRotation, IEnumerableLine)

Initializes a new instance of the Region class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Region(
    RectangleF bounds,
    WebDocumentPageRotation rotation,
    IEnumerable<Line> lines
)
Public Sub New (
    bounds As RectangleF,
    rotation As WebDocumentPageRotation,
    lines As IEnumerable(Of Line)
)

Parameters

bounds
Type: System.DrawingRectangleF
The region bounds.
rotation
Type: Atalasoft.Imaging.WebControlsWebDocumentPageRotation
The region rotation.
lines
Type: System.Collections.GenericIEnumerableLine
The region lines.
See Also

Reference

Region Class
Region Overload
Atalasoft.Imaging.WebControls.Text Namespace


Region Properties

The Region type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Lines | Gets the lines.
Public property | Rotation | Gets or sets the page rotation.
Top
See Also

Reference

Region Class
Atalasoft.Imaging.WebControls.Text Namespace


Region.Lines Property

RegionLines Property

Gets the lines.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<Line> Lines { get; }
Public ReadOnly Property Lines As IList(Of Line)
    Get

Property Value

Type: IListLine
See Also

Reference

Region Class
Atalasoft.Imaging.WebControls.Text Namespace


Region.Rotation Property

RegionRotation Property

Gets or sets the page rotation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WebDocumentPageRotation Rotation { get; set; }
Public Property Rotation As WebDocumentPageRotation
    Get
    Set

Property Value

Type: WebDocumentPageRotation
See Also

Reference

Region Class
Atalasoft.Imaging.WebControls.Text Namespace


Region Methods

The Region type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Region Class
Atalasoft.Imaging.WebControls.Text Namespace


Region.ToHastableJson Method

RegionToHastableJson Method

Converts the object to the hash table json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Hashtable ToHastableJson()
Protected Overrides Function ToHastableJson As Hashtable

Return Value

Type: Hashtable
Hashtable containing object values.
See Also

Reference

Region Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator Class

Represents segmented text translator.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextSegmentedTextTranslator

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SegmentedTextTranslator : IDisposable
Public Class SegmentedTextTranslator
    Implements IDisposable

The SegmentedTextTranslator type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentedTextTranslator | Initializes a new instance of the SegmentedTextTranslator class.
Top
Properties
 | Name | Description
Public property | BlockDetectionDistance | Gets or sets the block intersection distance counted in average glyph size for that block.
Public property | RegionDetection | Gets or sets the region detection mode.
Public property | TextDocument | Gets the underlying text document.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExtractPageText | Extracts the page text.
Public method | ExtractText | Extracts the PDF document text.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator Constructor

Initializes a new instance of the SegmentedTextTranslator class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SegmentedTextTranslator(
    ITextDocument textDocument
)
Public Sub New (
    textDocument As ITextDocument
)

Parameters

textDocument
Type: Atalasoft.Imaging.TextITextDocument
The text document.
Exceptions
Exception | Condition
ArgumentNullException | textDocument
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator Properties

The SegmentedTextTranslator type exposes the following members.

Properties
 | Name | Description
Public property | BlockDetectionDistance | Gets or sets the block intersection distance counted in average glyph size for that block.
Public property | RegionDetection | Gets or sets the region detection mode.
Public property | TextDocument | Gets the underlying text document.
Top
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.BlockDetectionDistance Property

SegmentedTextTranslatorBlockDetectionDistance Property

Gets or sets the block intersection distance counted in average glyph size for that block.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF BlockDetectionDistance { get; set; }
Public Property BlockDetectionDistance As SizeF
    Get
    Set

Property Value

Type: SizeF
Remarks
Block detection differs for different document layouts - smaller blocks detection distance could create unnecessary segmentation while bigger could join unrelated blocks of text into single region. This property could be used to adjust block detection distance for particular text document if needed. Block detection distance is specified in amount of the average glyph size in vertical and horizontal directions to reflect font differences. Default values are 3 characters for horizontal direction and 1.5 for vertical.
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.RegionDetection Property

SegmentedTextTranslatorRegionDetection Property

Gets or sets the region detection mode.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextRegionDetectionMode RegionDetection { get; set; }
Public Property RegionDetection As TextRegionDetectionMode
    Get
    Set

Property Value

Type: TextRegionDetectionMode
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.TextDocument Property

SegmentedTextTranslatorTextDocument Property

Gets the underlying text document.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ITextDocument TextDocument { get; }
Public ReadOnly Property TextDocument As ITextDocument
    Get

Property Value

Type: ITextDocument
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator Methods

The SegmentedTextTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExtractPageText | Extracts the page text.
Public method | ExtractText | Extracts the PDF document text.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.Dispose Method

SegmentedTextTranslatorDispose Method

Overload List
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources.
Top
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.Dispose Method

SegmentedTextTranslatorDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

SegmentedTextTranslator Class
Dispose Overload
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.Dispose Method (Boolean)

SegmentedTextTranslatorDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SegmentedTextTranslator Class
Dispose Overload
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.ExtractPageText Method

SegmentedTextTranslatorExtractPageText Method

Extracts the page text.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Page ExtractPageText(
    int index
)
Public Function ExtractPageText (
    index As Integer
) As Page

Parameters

index
Type: SystemInt32
The index of the pdf page to extract text.

Return Value

Type: Page
Extracted text data.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


SegmentedTextTranslator.ExtractText Method

SegmentedTextTranslatorExtractText Method

Extracts the PDF document text.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Document ExtractText()
Public Function ExtractText As Document

Return Value

Type: Document
Text data extracted from PDF in OCR-compatible format.
See Also

Reference

SegmentedTextTranslator Class
Atalasoft.Imaging.WebControls.Text Namespace


TextRegionDetectionMode Enumeration

Specifies supported region detection modes.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TextRegionDetectionMode
Public Enumeration TextRegionDetectionMode
Members
Member name | Description
LineDetection | Page text is translated into lines.
BlockDetection | Text regions are detected by merging adjacent words.
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Word Class

Represents OCR word
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WebControls.TextPageObject
Atalasoft.Imaging.WebControls.TextWord

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Word : PageObject
Public Class Word
    Inherits PageObject

The Word type exposes the following members.

Constructors
 | Name | Description
Public method | Word(Hashtable) | Initializes a new instance of the Word class.
Public method | Word(OcrWord) | Initializes a new instance of the Word class.
Public method | Word(RectangleF, String, IEnumerableGlyph) | Initializes a new instance of the Word class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Glyphs | Gets or sets the glyphs.
Public property | OmitSpace | Gets or sets a value indicating whether space space generation should be omitted after this word during page text reconstruction.
Public property | Text | Gets the word text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WebControls.Text Namespace


Word Constructor

Overload List
 | Name | Description
Public method | Word(Hashtable) | Initializes a new instance of the Word class.
Public method | Word(OcrWord) | Initializes a new instance of the Word class.
Public method | Word(RectangleF, String, IEnumerableGlyph) | Initializes a new instance of the Word class.
Top
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Word Constructor (Hashtable)

Initializes a new instance of the Word class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Word(
    Hashtable json
)
Public Sub New (
    json As Hashtable
)

Parameters

json
Type: System.CollectionsHashtable
The word json representation.
See Also

Reference

Word Class
Word Overload
Atalasoft.Imaging.WebControls.Text Namespace


Word Constructor (OcrWord)

Initializes a new instance of the Word class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Word(
    OcrWord word
)
Public Sub New (
    word As OcrWord
)

Parameters

word
Type: Atalasoft.OcrOcrWord
The ocr engine word.
See Also

Reference

Word Class
Word Overload
Atalasoft.Imaging.WebControls.Text Namespace


Word Constructor (RectangleF, String, IEnumerable(Glyph))

Word Constructor (RectangleF, String, IEnumerableGlyph)

Initializes a new instance of the Word class.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Word(
    RectangleF bounds,
    string text,
    IEnumerable<Glyph> glyphs
)
Public Sub New (
    bounds As RectangleF,
    text As String,
    glyphs As IEnumerable(Of Glyph)
)

Parameters

bounds
Type: System.DrawingRectangleF
The bounds.
text
Type: SystemString
The text.
glyphs
Type: System.Collections.GenericIEnumerableGlyph
The word glyphs.
See Also

Reference

Word Class
Word Overload
Atalasoft.Imaging.WebControls.Text Namespace


Word Properties

The Word type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the element bounds. (Inherited from PageObject.)
Public property | Glyphs | Gets or sets the glyphs.
Public property | OmitSpace | Gets or sets a value indicating whether space space generation should be omitted after this word during page text reconstruction.
Public property | Text | Gets the word text.
Top
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Word.Glyphs Property

WordGlyphs Property

Gets or sets the glyphs.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<Glyph> Glyphs { get; }
Public ReadOnly Property Glyphs As IList(Of Glyph)
    Get

Property Value

Type: IListGlyph
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Word.OmitSpace Property

WordOmitSpace Property

Gets or sets a value indicating whether space space generation should be omitted after this word during page text reconstruction.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OmitSpace { get; set; }
Public Property OmitSpace As Boolean
    Get
    Set

Property Value

Type: Boolean
true if omit space after this word; otherwise, false.
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Word.Text Property

WordText Property

Gets the word text.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Word Methods

The Word type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ToHastableJson | Converts the object to the hash table json representation. (Overrides PageObjectToHastableJson.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Word.ToHastableJson Method

WordToHastableJson Method

Converts the object to the hash table json representation.

Namespace: Atalasoft.Imaging.WebControls.Text
Assembly: Atalasoft.dotImage.WebControls (in Atalasoft.dotImage.WebControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Hashtable ToHastableJson()
Protected Overrides Function ToHastableJson As Hashtable

Return Value

Type: Hashtable
Hashtable containing object values.
See Also

Reference

Word Class
Atalasoft.Imaging.WebControls.Text Namespace


Atalasoft.Imaging.WinControls Namespace

Classes
 | Class | Description
Public class | BeforeCreateThumbnailEventArgs | This class holds information for a thumbnail creation process and allows the image used to generate the thumbnail to be modified or replaced.
Public class | BitmapViewer | A scrollable viewport control for displaying a GDI+ Image or Bitmap.
Public class | BorderContainer | This class is used to add a border around any control.
Public class | CachedImageUndoManager | This class is used to provide the undo and redo features in DocumentViewer.
Public class | CollectionChangedEventArgs | This class is used with the CollectionChangedEventHandler delegate to notify when changes have been made to the ThumbnailCollection.
Public class | DataMemberChangedEventArgs | This class is used to provide notification when the ThumbnailDataBinding data has been modified.
Public class | DocumentViewer | The DocumentViewer control simplifies the process of synchronizing a ThumbnailView with a ImageViewer. The control's ThumbnailView can be docked on any side using the ThumbnailDockStyle property. A SeparatorProperties can be enabled, allowing the end user to resize the ThumbnailView and the ImageViewer will fill the rest of the control. Synchronization is performed using the ThumbnailImageViewerSynchronizer class. When a thumbnail is selected, its full size image is loaded into the viewer where it can be modified. When an image is modified its thumbnail will be updated to match the change.
Public class | DocumentViewerThumbnailView |
Public class | EllipseRubberband | A elliptical rubberband that can be positioned with the mouse on a viewport control.
Public class | FolderThumbnailView | A thumbnail list control designed to display thumbnails of images from a directory.
 | ImageCompositePrintDocument | Allows multiple images to be printed per page at typical metric and English photo sizes.
Public class | ImageControlProperties | This class is used to provide properties for the WorkspaceViewer used by the DocumentViewer.
Public class | ImageInsertEventArgs | This class contains information for an image that was inserted into the collection.
 | ImagePrintDocument | Derives from PrintDocument and allows AtalaImage objects to be printed directly to a printer.
Public class | ImageViewer | A scrollable viewport for AtalaImages.
Public class | ItemBounds | This class is used to hold positioning information for a single Thumbnail object.
Public class | LineRubberband | A line rubber-band that can be positioned with the mouse on a viewport control.
Public class | LocDescriptionAttribute | For internal localization use only.
Public class | Magnifier | The Magnifier is part of the ImageViewer control, and when selected in the MouseTool property it will display a magnified region of the image when holding the mouse button down.
Public class | Margin | This class is used to define a margin area.
Public class | MarginTypeConverter | This class is used by the designer, allowing Margin objects to be modified in the property grid.
Public class | OpenDocumentEventArgs | This class holds information for an Open, Add or Insert method.
Public class | OpenImageFileDialog | This class extends the OpenFileDialog by displaying an image preview that automatically updates as the user selects a file in the dialog.
Public class | PaintDropPositionIndicatorEventArgs | Used with the EraseDropPositionIndicator and PaintDropPositionIndicator events to allow for custom drawing.
Public class | PaintThumbnailEventArgs | This class is used with the PaintThumbnail event to allow custom thumbnail drawing.
Public class | PrintCompositeEventArgs | Provides data for the PrintImage event in the ImageCompositePrintDocument class.
Public class | PrintImageEventArgs | Provides data for the AfterPrintPage, GetImage and PrintImage events of ImagePrintDocument.
Public class | RectangleRubberband | A rectangular rubber-band that can be positioned with the mouse on a viewport control.
Public class | RectangleSelection | A rectangular selection that can be positioned and moved with the mouse on a viewport control.
Public class | Rubberband | A base class which all rubber bands inherit from.
Public class | RubberbandEventArgs | Provides data for the Changed and Changing events of the Rubberband class.
Public class | ScreenCapture | This class is used to capture the screen, window or a specified area of the screen or window.
Public class | ScrollEventArgs | Provides data for the Scrolling and ScrollChanged events of the Scrollport control.
Public class | Scrollport | Defines a base class that can be used for scrollable viewport to display and scroll any rectangular area.
Public class | SelectedThumbnailCollection | A collection of Thumbnail objects currently selected in the ThumbnailView. This is provided through the SelectedItems property.
Public class | SeparatorProperties | This class holds properties for the internal Splitter used by the DocumentViewer control.
Public class | Thumbnail | This class contains information about the thumbnail image stored in the ThumbnailView and FolderThumbnailView controls.
Public class | ThumbnailCaptionRequestEventArgs | This class is used with the ThumbnailCaptionRequestEventHandler when thumbnail are being created from an ImageSource.
Public class | ThumbnailCollection | Contains a collection of Thumbnail objects.
Public class | ThumbnailCompareEventArgs | This class is used with the CompareThumbnails event to allow a custom sort.
Public class | ThumbnailControlProperties | This class is used to hold property values for a ThumbnailView control used by the DocumentViewer.
Public class | ThumbnailDataBinding | This class is used to bind the ThumbnailView to a data source.
Public class | ThumbnailDragDropOperation | This class is used for a drag and drop operation on the ThumbnailView control.
Public class | ThumbnailDropEventArgs | This class is send in the ThumbnailDrop event to indicate where the dropped items were placed.
Public class | ThumbnailEventArgs | Provides data for various events in the ThumbnailView control.
Public class | ThumbnailImageViewerSynchronizer | This class is used to synchronize a ThumbnailView and an ImageViewer control together. The ThumbnailImageViewerSynchronizer will handle loading the image of a selected thumbnail into the viewer and updating the thumbnail image when the image has been modified.
Public class | ThumbnailLoadEventArgs | Provides data for the BeforeThumbnailLoad event in the ThumbnailView control.
Public class | ThumbnailView | A thumbnail list control designed to display thumbnails of AtalaImage objects, or image files.
Public class | Viewport | Defines a base scrollable viewport for images contained in classes that inherit this abstract class.
Public class | WorkspaceViewer | A scrollable viewport containing a Workspace object.
Public class | ZoomWindow | The zoom window is a form that displays a zoomed portion of the current image.
Delegates
 | Delegate | Description
Public delegate | CollectionChangedEventHandler | Represents a method that handles changes to the ThumbnailCollection.
Public delegate | CompareEventHandler | Represents a method that handles comparing Thumbnail objects.
Public delegate | DataMemberChangedEventHandler | Represents a method that handles member changes for data binding.
Public delegate | PaintDropPositionIndicatorEventHandler | Represents a method used to paint the DropPositionIndicator.
Public delegate | PaintThumbnailEventHandler | Represents a method that handles painting a single thumbnail.
Public delegate | PrintCompositeEventHandler | Represents the method that handles the AfterPrintImage and PrintImage events of the ImageCompositePrintDocument class.
Public delegate | PrintImageEventHandler | Represents the method that will handle the AfterPrintPage, GetImage and PrintImage events of ImagePrintDocument.
Public delegate | RubberbandEventHandler | Represents the method that will handle the Changed and Changing event of the Rubberband component.
Public delegate | ScrollEventHandler | Represents the method that will handle the Scrolling and ScrollChanged event of the Scrollport control.
Public delegate | ThumbnailCaptionRequestEventHandler | This event handler is used by the ThumbnailView to request caption and tooltip values for images loaded from an ImageSource.
Public delegate | ThumbnailDropEventHandler | Represents the method that will handle the ThumbnailDrop event of the ThumbnailView and FolderThumbnailView controls.
Public delegate | ThumbnailEventHandler |
Public delegate | ThumbnailLoadEventHandler | Represents a method used to handle custom loading or cancelation of a thumbnail.
Enumerations
 | Enumeration | Description
Public enumeration | AntialiasDisplayMode | Specifies the antialis display mode that can be set to the ImageViewer and WorkspaceViewer controls.
Public enumeration | ArrowKeyAction | Defines the action taken when the ThumbnailView receives an arrow key press event.
Public enumeration | AutoZoomMode | Specifies the automatic zoom setting of the image displayed in the Viewport control.
Public enumeration | CollectionChangeType | Specifies changes to the collection.
Public enumeration | CompositePrintLayout | Specifies the layout used in the ImageCompositePrintDocument when printing.
Public enumeration | ControlDockStyle | Defines the dock position of a control.
Public enumeration | ControlSeparator | Defines the type of separator to use.
Public enumeration | DragDropMode | This enumeration dictates the type of drag and drop operation to perform. If the source control is the same one that the thumbnails are being dropped onto, these values are ignored and the thumbnails are simply reordered.
Public enumeration | FileDialogView | This enumeration is used to set the initial view state of the OpenImageFileDialog.
Public enumeration | MouseToolType | Specifies the Mouse Tool Type to use in the Viewport control.
Public enumeration | PrintScaleMode | Specifies the type of scaling used when printing an image with ImagePrintDocument.
Public enumeration | ResolutionScaleMode | Specified the behavior options when displaying images with different X and Y resolutions as defined in the ResolutionScaleMode property of the Viewport control.
Public enumeration | ScrollBarDirection | Specifies the horizontal or vertical scrollbar.
Public enumeration | ScrollBarVisibility | Specifies how the scroll bars are shown in the Scrollport and inherited control.
Public enumeration | SelectedItemRenderStyle | Specifies the rendering style for selected items.
Public enumeration | SelectedItemsOrder | Defines the order of the selected items collection.
Public enumeration | SortOrder | Specifies the sort order used by the ThumbnailView and FolderThumbnailView controls.
Public enumeration | ThumbLoadMethod | Determines the method used to load thumbnails in FolderThumbnailView.
Public enumeration | ThumbnailDropPositionIndicator | Defines the drop position indicator used with the ThumbnailView.
Public enumeration | ThumbnailLayout | This enumeration is used with the ThumbnailLayout property to indicate the layout of the thumbnails.
Public enumeration | ThumbnailSelectionMode | Defines the selection mode of the ThumbnailView.
Public enumeration | ThumbViewAttribute | Specifies values for the DisplayText and SortBy properties.


AntialiasDisplayMode Enumeration

Specifies the antialis display mode that can be set to the ImageViewer and WorkspaceViewer controls.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AntialiasDisplayMode
Public Enumeration AntialiasDisplayMode
Members
Member name | Description
None | Do not antialias (fastest performance)
ScaleToGray | Only antialias 1-bit document images for zoom levels less then 1.
ReductionOnly | Antialias all pixel formats when zoom level is less then 1.
Full | Antialias all images for all zoom levels.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ArrowKeyAction Enumeration

Defines the action taken when the ThumbnailView receives an arrow key press event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ArrowKeyAction
Public Enumeration ArrowKeyAction
Members
Member name | Description
None | No action is taken.
ChangeSelection | The selected item will change.
Scroll | The control will scroll.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


AutoZoomMode Enumeration

Specifies the automatic zoom setting of the image displayed in the Viewport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AutoZoomMode
Public Enumeration AutoZoomMode
Members
Member name | Description
None | Does not change the zoom of the image based on image size.
BestFit | Fits the image by sizing the width or height to best fit the control.
BestFitShrinkOnly | Fits the image by sizing the width or height to best fit the control only if the image needs to be reduced in size.
FitToWidth | Image is zoomed to fit the width.
FitToHeight | Image is zoomed to fit the height.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs Class

This class holds information for a thumbnail creation process and allows the image used to generate the thumbnail to be modified or replaced.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsBeforeCreateThumbnailEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BeforeCreateThumbnailEventArgs : EventArgs
Public Class BeforeCreateThumbnailEventArgs
    Inherits EventArgs

The BeforeCreateThumbnailEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeCreateThumbnailEventArgs | Creates a new instance of BeforeCreateThumbnailEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the thumbnail creation should be canceled.
Public property | Image | Gets or sets the image used to generate the thumbnail.
Public property | Thumbnail | Gets the thumbnail from the ThumbnailCollection that is being created.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs Constructor

Creates a new instance of BeforeCreateThumbnailEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BeforeCreateThumbnailEventArgs(
    Thumbnail thumbnail,
    AtalaImage image
)
Public Sub New (
    thumbnail As Thumbnail,
    image As AtalaImage
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail in the ThumbnailCollection that is being created.
image
Type: Atalasoft.ImagingAtalaImage
The image used to create the thumbnail from.
See Also

Reference

BeforeCreateThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs Properties

The BeforeCreateThumbnailEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the thumbnail creation should be canceled.
Public property | Image | Gets or sets the image used to generate the thumbnail.
Public property | Thumbnail | Gets the thumbnail from the ThumbnailCollection that is being created.
Top
See Also

Reference

BeforeCreateThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs.Cancel Property

BeforeCreateThumbnailEventArgsCancel Property

Gets or sets a value indicating whether the thumbnail creation should be canceled.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the thumbnail creation should be canceled.
See Also

Reference

BeforeCreateThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs.Image Property

BeforeCreateThumbnailEventArgsImage Property

Gets or sets the image used to generate the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image used to generate the thumbnail.
Remarks
This image is automatically disposed after the thumbnail has been created.
See Also

Reference

BeforeCreateThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs.Thumbnail Property

BeforeCreateThumbnailEventArgsThumbnail Property

Gets the thumbnail from the ThumbnailCollection that is being created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Thumbnail { get; }
Public ReadOnly Property Thumbnail As Thumbnail
    Get

Property Value

Type: Thumbnail
The thumbnail that is being created.
See Also

Reference

BeforeCreateThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


BeforeCreateThumbnailEventArgs Methods

The BeforeCreateThumbnailEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeCreateThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer Class

A scrollable viewport control for displaying a GDI+ Image or Bitmap.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsScrollport
Atalasoft.Imaging.WinControlsViewport
Atalasoft.Imaging.WinControlsBitmapViewer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BitmapViewer : Viewport
Public Class BitmapViewer
    Inherits Viewport

The BitmapViewer type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapViewer | Initializes a new instance of BitmapViewer.
Public method | BitmapViewer(Image) | Initializes a new instance of BitmapViewer specifying the Bitmap it contains.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | Gets or sets the GDI+ Bitmap or Image associated with this control.
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Inherited from Viewport.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Viewport.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | (Overrides ViewportGetCurrentImage(Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | Returns the vertical resolution based on the difference in X and Y resolution. (Inherited from Viewport.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageDraw | (Overrides ViewportOnImageDraw(Rectangle, Rectangle, Graphics).)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control need to be painted. (Inherited from Viewport.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event. (Inherited from Viewport.)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
Remarks

The BitmapViewer can be used to view GDI+ Metafiles in a scrollable, zoomable viewport while taking advantage of the full functionality of the viewport such as the mouse tools and magnifier.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace


BitmapViewer Constructor

Overload List
 | Name | Description
Public method | BitmapViewer | Initializes a new instance of BitmapViewer.
Public method | BitmapViewer(Image) | Initializes a new instance of BitmapViewer specifying the Bitmap it contains.
Top
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer Constructor

Initializes a new instance of BitmapViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapViewer()
Public Sub New
See Also

Reference

BitmapViewer Class
BitmapViewer Overload
Atalasoft.Imaging.WinControls Namespace


BitmapViewer Constructor (Image)

Initializes a new instance of BitmapViewer specifying the Bitmap it contains.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapViewer(
    Image image
)
Public Sub New (
    image As Image
)

Parameters

image
Type: System.DrawingImage
The Bitmap that this BitmapViewer displays.
See Also

Reference

BitmapViewer Class
BitmapViewer Overload
Atalasoft.Imaging.WinControls Namespace


BitmapViewer Properties

The BitmapViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | Gets or sets the GDI+ Bitmap or Image associated with this control.
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer.Image Property

BitmapViewerImage Property

Gets or sets the GDI+ Bitmap or Image associated with this control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set

Property Value

Type: Image
The GDI+ Bitmap or Image associated with this control.
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer Methods

The BitmapViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Inherited from Viewport.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Viewport.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | (Overrides ViewportGetCurrentImage(Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | Returns the vertical resolution based on the difference in X and Y resolution. (Inherited from Viewport.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageDraw | (Overrides ViewportOnImageDraw(Rectangle, Rectangle, Graphics).)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control need to be painted. (Inherited from Viewport.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event. (Inherited from Viewport.)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer.GetCurrentImage Method

BitmapViewerGetCurrentImage Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Object GetCurrentImage(
    ref bool isBitmapImage
)
Protected Overrides Function GetCurrentImage (
    ByRef isBitmapImage As Boolean
) As Object

Parameters

isBitmapImage
Type: SystemBoolean

Return Value

Type: Object
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer.OnImageDraw Method

BitmapViewerOnImageDraw Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnImageDraw(
    Rectangle sourceRectangle,
    Rectangle destRectangle,
    Graphics graphics
)
Protected Overrides Sub OnImageDraw (
    sourceRectangle As Rectangle,
    destRectangle As Rectangle,
    graphics As Graphics
)

Parameters

sourceRectangle
Type: System.DrawingRectangle
destRectangle
Type: System.DrawingRectangle
graphics
Type: System.DrawingGraphics
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BitmapViewer Events

The BitmapViewer type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
See Also

Reference

BitmapViewer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer Class

This class is used to add a border around any control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsBorderContainer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BorderContainer : Control
Public Class BorderContainer
    Inherits Control

The BorderContainer type exposes the following members.

Constructors
 | Name | Description
Public method | BorderContainer | Creates a new instance of BorderContainer without specifying the contained control.
Public method | BorderContainer(Control) | Creates a new instance of BorderContainer specifying the contained control.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderSide | Gets or sets the sides of the border to render.
Public property | BorderStyle | Gets or sets the type of border to render.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Called when a control is added to the BorderContainer. (Overrides ControlOnControlAdded(ControlEventArgs).)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when a layout is requested for the control. (Overrides ControlOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Called when the background of the control needs to be painted. (Overrides ControlOnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks
This class only support a single contained control. When adding controls any previous control will be removed.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


BorderContainer Constructor

Creates a new instance of BorderContainer.
Overload List
 | Name | Description
Public method | BorderContainer | Creates a new instance of BorderContainer without specifying the contained control.
Public method | BorderContainer(Control) | Creates a new instance of BorderContainer specifying the contained control.
Top
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer Constructor

Creates a new instance of BorderContainer without specifying the contained control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderContainer()
Public Sub New
See Also

Reference

BorderContainer Class
BorderContainer Overload
Atalasoft.Imaging.WinControls Namespace


BorderContainer Constructor (Control)

Creates a new instance of BorderContainer specifying the contained control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderContainer(
    Control containedControl
)
Public Sub New (
    containedControl As Control
)

Parameters

containedControl
Type: System.Windows.FormsControl
The control that will be contained within this border.
See Also

Reference

BorderContainer Class
BorderContainer Overload
Atalasoft.Imaging.WinControls Namespace


BorderContainer Properties

The BorderContainer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderSide | Gets or sets the sides of the border to render.
Public property | BorderStyle | Gets or sets the type of border to render.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer.BorderSide Property

BorderContainerBorderSide Property

Gets or sets the sides of the border to render.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Border3DSide BorderSide { get; set; }
Public Property BorderSide As Border3DSide
    Get
    Set

Property Value

Type: Border3DSide
The sides of the border to render.
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer.BorderStyle Property

BorderContainerBorderStyle Property

Gets or sets the type of border to render.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Border3DStyle BorderStyle { get; set; }
Public Property BorderStyle As Border3DStyle
    Get
    Set

Property Value

Type: Border3DStyle
The type of border to render.
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer Methods

The BorderContainer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Called when a control is added to the BorderContainer. (Overrides ControlOnControlAdded(ControlEventArgs).)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when a layout is requested for the control. (Overrides ControlOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Called when the background of the control needs to be painted. (Overrides ControlOnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer.OnControlAdded Method

BorderContainerOnControlAdded Method

Called when a control is added to the BorderContainer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnControlAdded(
    ControlEventArgs e
)
Protected Overrides Sub OnControlAdded (
    e As ControlEventArgs
)

Parameters

e
Type: System.Windows.FormsControlEventArgs
A ControlEventArgs containing information about the control that was added.
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer.OnLayout Method

BorderContainerOnLayout Method

Called when a layout is requested for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLayout(
    LayoutEventArgs levent
)
Protected Overrides Sub OnLayout (
    levent As LayoutEventArgs
)

Parameters

levent
Type: System.Windows.FormsLayoutEventArgs
A LayoutEventArgs containing information about this event.
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer.OnPaintBackground Method

BorderContainerOnPaintBackground Method

Called when the background of the control needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaintBackground(
    PaintEventArgs pevent
)
Protected Overrides Sub OnPaintBackground (
    pevent As PaintEventArgs
)

Parameters

pevent
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs containing information for this event.
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


BorderContainer Events

The BorderContainer type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

BorderContainer Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager Class

This class is used to provide the undo and redo features in DocumentViewer.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsCachedImageUndoManager
Atalasoft.Annotate.UICachedImageAnnotationUndoManager

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CachedImageUndoManager : IDisposable
Public Class CachedImageUndoManager
    Implements IDisposable

The CachedImageUndoManager type exposes the following members.

Constructors
 | Name | Description
Public method | CachedImageUndoManager | Creates a new instance of CachedImageUndoManager.
Top
Properties
 | Name | Description
Public property | RedoCount | Gets the number of redo items.
Public property | UndoCount | Gets the number of undo items.
Public property | UndoLevels | Gets or sets the maximum number of undo items to hold at any one time.
Top
Methods
 | Name | Description
Public method | AddUndo | Adds a new undo state to the manager.
Public method | Clear | Clears all undo and redo items.
Public method | Dispose | Releases all resources used by the CachedImageUndoManager.
Protected method | Dispose(Boolean) | Called from the Dispose and finalizer to release all resources for the CachedImageUndoManager.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRedoCount | Called to get the number of redo items.
Public method | GetRedoDescriptions | Called to get an array of redo descriptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUndoCount | Called to get the number of undo items.
Public method | GetUndoDescriptions | Called to get an array of undo descriptions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddUndo | Called to add a new undo item.
Protected method | OnClear | Called to clear the undo and redo items.
Protected method | OnGetRedoDescriptions | Called to get an array of redo descriptions.
Protected method | OnGetUndoDescriptions | Called to get an array of undo descriptions.
Protected method | OnRedo | Called to perform a redo operation.
Protected method | OnRedoPerformed | Called after a redo has been performed and raises the RedoPerformed event.
Protected method | OnUndo | Called to perform an undo operation.
Protected method | OnUndoLevelsChanged | Called when the UndoLevels property has been changed.
Protected method | OnUndoListChanged | Called when the undo/redo lists have changed and raises the UndoListChanged event.
Protected method | OnUndoPerformed | Called after an undo operation has been performed and raises the UndoPerformed event.
Public method | Redo | Performs a redo operation and returns the resulting image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Performs an undo operation and returns the resulting image.
Top
Events
 | Name | Description
Public event | RedoPerformed | Raised when a redo operation has been performed.
Public event | UndoListChanged | Raised when the undo/redo lists have changed.
Public event | UndoPerformed | Raised when an undo operation has been performed.
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager Constructor

Creates a new instance of CachedImageUndoManager.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CachedImageUndoManager()
Public Sub New
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager Properties

The CachedImageUndoManager type exposes the following members.

Properties
 | Name | Description
Public property | RedoCount | Gets the number of redo items.
Public property | UndoCount | Gets the number of undo items.
Public property | UndoLevels | Gets or sets the maximum number of undo items to hold at any one time.
Top
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.RedoCount Property

CachedImageUndoManagerRedoCount Property

Gets the number of redo items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RedoCount { get; }
Public ReadOnly Property RedoCount As Integer
    Get

Property Value

Type: Int32
The number of redo items.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.UndoCount Property

CachedImageUndoManagerUndoCount Property

Gets the number of undo items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndoCount { get; }
Public ReadOnly Property UndoCount As Integer
    Get

Property Value

Type: Int32
The number of undo items.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.UndoLevels Property

CachedImageUndoManagerUndoLevels Property

Gets or sets the maximum number of undo items to hold at any one time.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndoLevels { get; set; }
Public Property UndoLevels As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of undo items to hold. The default value for this property is 100.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager Methods

The CachedImageUndoManager type exposes the following members.

Methods
 | Name | Description
Public method | AddUndo | Adds a new undo state to the manager.
Public method | Clear | Clears all undo and redo items.
Public method | Dispose | Releases all resources used by the CachedImageUndoManager.
Protected method | Dispose(Boolean) | Called from the Dispose and finalizer to release all resources for the CachedImageUndoManager.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRedoCount | Called to get the number of redo items.
Public method | GetRedoDescriptions | Called to get an array of redo descriptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUndoCount | Called to get the number of undo items.
Public method | GetUndoDescriptions | Called to get an array of undo descriptions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddUndo | Called to add a new undo item.
Protected method | OnClear | Called to clear the undo and redo items.
Protected method | OnGetRedoDescriptions | Called to get an array of redo descriptions.
Protected method | OnGetUndoDescriptions | Called to get an array of undo descriptions.
Protected method | OnRedo | Called to perform a redo operation.
Protected method | OnRedoPerformed | Called after a redo has been performed and raises the RedoPerformed event.
Protected method | OnUndo | Called to perform an undo operation.
Protected method | OnUndoLevelsChanged | Called when the UndoLevels property has been changed.
Protected method | OnUndoListChanged | Called when the undo/redo lists have changed and raises the UndoListChanged event.
Protected method | OnUndoPerformed | Called after an undo operation has been performed and raises the UndoPerformed event.
Public method | Redo | Performs a redo operation and returns the resulting image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Performs an undo operation and returns the resulting image.
Top
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.AddUndo Method

CachedImageUndoManagerAddUndo Method

Adds a new undo state to the manager.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddUndo(
    AtalaImage image,
    string description
)
Public Sub AddUndo (
    image As AtalaImage,
    description As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to restore when Undo(AtalaImage) is called.
description
Type: SystemString
The description for this undo or null (Nothing in VB) if there is no description.
Remarks
This method will clear the redo items since they are no longer valid.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Clear Method

CachedImageUndoManagerClear Method

Clears all undo and redo items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Dispose Method

CachedImageUndoManagerDispose Method

These methods release resources used by the CachedImageUndoManager.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the CachedImageUndoManager.
Protected method | Dispose(Boolean) | Called from the Dispose and finalizer to release all resources for the CachedImageUndoManager.
Top
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Dispose Method

CachedImageUndoManagerDispose Method

Releases all resources used by the CachedImageUndoManager.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CachedImageUndoManager Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Dispose Method (Boolean)

CachedImageUndoManagerDispose Method (Boolean)

Called from the Dispose and finalizer to release all resources for the CachedImageUndoManager.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from Dispose.
See Also

Reference

CachedImageUndoManager Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Finalize Method

CachedImageUndoManagerFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.GetRedoCount Method

CachedImageUndoManagerGetRedoCount Method

Called to get the number of redo items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual int GetRedoCount()
Protected Overridable Function GetRedoCount As Integer

Return Value

Type: Int32
The number of redo items.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.GetRedoDescriptions Method

CachedImageUndoManagerGetRedoDescriptions Method

Called to get an array of redo descriptions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetRedoDescriptions()
Public Function GetRedoDescriptions As String()

Return Value

Type: String
An array containing the redo descriptions.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.GetUndoCount Method

CachedImageUndoManagerGetUndoCount Method

Called to get the number of undo items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual int GetUndoCount()
Protected Overridable Function GetUndoCount As Integer

Return Value

Type: Int32
The number of undo items.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.GetUndoDescriptions Method

CachedImageUndoManagerGetUndoDescriptions Method

Called to get an array of undo descriptions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetUndoDescriptions()
Public Function GetUndoDescriptions As String()

Return Value

Type: String
An array of undo descriptions.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnAddUndo Method

CachedImageUndoManagerOnAddUndo Method

Called to add a new undo item.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAddUndo(
    AtalaImage image,
    string description
)
Protected Overridable Sub OnAddUndo (
    image As AtalaImage,
    description As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to restore when Undo(AtalaImage) is called.
description
Type: SystemString
The description for this undo or null (Nothing in VB) if there is no description.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnClear Method

CachedImageUndoManagerOnClear Method

Called to clear the undo and redo items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnClear()
Protected Overridable Sub OnClear
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnGetRedoDescriptions Method

CachedImageUndoManagerOnGetRedoDescriptions Method

Called to get an array of redo descriptions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string[] OnGetRedoDescriptions()
Protected Overridable Function OnGetRedoDescriptions As String()

Return Value

Type: String
An array of redo descriptions.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnGetUndoDescriptions Method

CachedImageUndoManagerOnGetUndoDescriptions Method

Called to get an array of undo descriptions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual string[] OnGetUndoDescriptions()
Protected Overridable Function OnGetUndoDescriptions As String()

Return Value

Type: String
An array of undo descriptions.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnRedo Method

CachedImageUndoManagerOnRedo Method

Called to perform a redo operation.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage OnRedo()
Protected Overridable Function OnRedo As AtalaImage

Return Value

Type: AtalaImage
The resulting AtalaImage from the redo operation or null (Nothing in VB) if the result did not produce an image.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnRedoPerformed Method

CachedImageUndoManagerOnRedoPerformed Method

Called after a redo has been performed and raises the RedoPerformed event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRedoPerformed(
    EventArgs e
)
Protected Overridable Sub OnRedoPerformed (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnUndo Method

CachedImageUndoManagerOnUndo Method

Called to perform an undo operation.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage OnUndo(
    AtalaImage redoImage
)
Protected Overridable Function OnUndo (
    redoImage As AtalaImage
) As AtalaImage

Parameters

redoImage
Type: Atalasoft.ImagingAtalaImage
The image that will be returned from a call to Redo. This can be null (Nothing in VB) if redo does not need to produce an image.

Return Value

Type: AtalaImage
The AtalaImage resulting from this undo operation. This may be null (Nothing in VB).
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnUndoLevelsChanged Method

CachedImageUndoManagerOnUndoLevelsChanged Method

Called when the UndoLevels property has been changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnUndoLevelsChanged(
    EventArgs e
)
Protected Overridable Sub OnUndoLevelsChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this change.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnUndoListChanged Method

CachedImageUndoManagerOnUndoListChanged Method

Called when the undo/redo lists have changed and raises the UndoListChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnUndoListChanged(
    EventArgs e
)
Protected Overridable Sub OnUndoListChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.OnUndoPerformed Method

CachedImageUndoManagerOnUndoPerformed Method

Called after an undo operation has been performed and raises the UndoPerformed event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnUndoPerformed(
    EventArgs e
)
Protected Overridable Sub OnUndoPerformed (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Redo Method

CachedImageUndoManagerRedo Method

Performs a redo operation and returns the resulting image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Redo()
Public Function Redo As AtalaImage

Return Value

Type: AtalaImage
The AtalaImage resulting from this operation. This may be null (Nothing in VB).
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.Undo Method

CachedImageUndoManagerUndo Method

Performs an undo operation and returns the resulting image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Undo(
    AtalaImage redoImage
)
Public Function Undo (
    redoImage As AtalaImage
) As AtalaImage

Parameters

redoImage
Type: Atalasoft.ImagingAtalaImage
The image that will be returned from a call to Redo. This can be null (Nothing in VB) if redo does not need to produce an image.

Return Value

Type: AtalaImage
The AtalaImage resulting from this undo operation. This may be null (Nothing in VB).
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager Events

The CachedImageUndoManager type exposes the following members.

Events
 | Name | Description
Public event | RedoPerformed | Raised when a redo operation has been performed.
Public event | UndoListChanged | Raised when the undo/redo lists have changed.
Public event | UndoPerformed | Raised when an undo operation has been performed.
Top
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.RedoPerformed Event

CachedImageUndoManagerRedoPerformed Event

Raised when a redo operation has been performed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler RedoPerformed
Public Event RedoPerformed As EventHandler

Value

Type: SystemEventHandler
Remarks
Note: This event is raised before the DocumentViewer has updated its image.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.UndoListChanged Event

CachedImageUndoManagerUndoListChanged Event

Raised when the undo/redo lists have changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler UndoListChanged
Public Event UndoListChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CachedImageUndoManager.UndoPerformed Event

CachedImageUndoManagerUndoPerformed Event

Raised when an undo operation has been performed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler UndoPerformed
Public Event UndoPerformed As EventHandler

Value

Type: SystemEventHandler
Remarks
Note: This event is raised before the DocumentViewer has updated its image.
See Also

Reference

CachedImageUndoManager Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs Class

This class is used with the CollectionChangedEventHandler delegate to notify when changes have been made to the ThumbnailCollection.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsCollectionChangedEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CollectionChangedEventArgs : EventArgs
Public Class CollectionChangedEventArgs
    Inherits EventArgs

The CollectionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionChangedEventArgs(CollectionChangeType, Int32, Thumbnail) | Creates a new instance of CollectionChangedEventArgs specifying the type of change, index of the item and an array of Thumbnail objects added to the collection.
Public method | CollectionChangedEventArgs(CollectionChangeType, Int32, Thumbnail, Thumbnail) | Creates a new instance of CollectionChangedEventArgs specifying the type of change, index of the item, old thumbnail and new Thumbnail for this item.
Top
Properties
 | Name | Description
Public property | Change | Gets the type of change applied to the collection.
Public property | Index | Gets the index of the item added, removed or modified.
Public property | NewThumbnail | Gets the new thumbnail.
Public property | OldThumbnail | Gets the old thumbnail.
Public property | Thumbnails | Gets an array of Thumbnail objects that were added to the collection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs Constructor

Creates a CollectionChangedEventArgs object.
Overload List
 | Name | Description
Public method | CollectionChangedEventArgs(CollectionChangeType, Int32, Thumbnail) | Creates a new instance of CollectionChangedEventArgs specifying the type of change, index of the item and an array of Thumbnail objects added to the collection.
Public method | CollectionChangedEventArgs(CollectionChangeType, Int32, Thumbnail, Thumbnail) | Creates a new instance of CollectionChangedEventArgs specifying the type of change, index of the item, old thumbnail and new Thumbnail for this item.
Top
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs Constructor (CollectionChangeType, Int32, Thumbnail[])

CollectionChangedEventArgs Constructor (CollectionChangeType, Int32, Thumbnail)

Creates a new instance of CollectionChangedEventArgs specifying the type of change, index of the item and an array of Thumbnail objects added to the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    CollectionChangeType change,
    int index,
    Thumbnail[] thumbnails
)
Public Sub New (
    change As CollectionChangeType,
    index As Integer,
    thumbnails As Thumbnail()
)

Parameters

change
Type: Atalasoft.Imaging.WinControlsCollectionChangeType
The change on the collection.
index
Type: SystemInt32
The index of the item.
thumbnails
Type: Atalasoft.Imaging.WinControlsThumbnail
An array of Thumbnail objects added to the collection.
See Also

Reference

CollectionChangedEventArgs Class
CollectionChangedEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs Constructor (CollectionChangeType, Int32, Thumbnail, Thumbnail)

Creates a new instance of CollectionChangedEventArgs specifying the type of change, index of the item, old thumbnail and new Thumbnail for this item.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangedEventArgs(
    CollectionChangeType change,
    int index,
    Thumbnail oldThumbnail,
    Thumbnail newThumbnail
)
Public Sub New (
    change As CollectionChangeType,
    index As Integer,
    oldThumbnail As Thumbnail,
    newThumbnail As Thumbnail
)

Parameters

change
Type: Atalasoft.Imaging.WinControlsCollectionChangeType
The change on the collection.
index
Type: SystemInt32
The index of the item.
oldThumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The old thumbnail for this item.
newThumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The new thumbnail for this item.
See Also

Reference

CollectionChangedEventArgs Class
CollectionChangedEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs Properties

The CollectionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Change | Gets the type of change applied to the collection.
Public property | Index | Gets the index of the item added, removed or modified.
Public property | NewThumbnail | Gets the new thumbnail.
Public property | OldThumbnail | Gets the old thumbnail.
Public property | Thumbnails | Gets an array of Thumbnail objects that were added to the collection.
Top
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs.Change Property

CollectionChangedEventArgsChange Property

Gets the type of change applied to the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CollectionChangeType Change { get; }
Public ReadOnly Property Change As CollectionChangeType
    Get

Property Value

Type: CollectionChangeType
The change on the collection.
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs.Index Property

CollectionChangedEventArgsIndex Property

Gets the index of the item added, removed or modified.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the item.
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs.NewThumbnail Property

CollectionChangedEventArgsNewThumbnail Property

Gets the new thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail NewThumbnail { get; }
Public ReadOnly Property NewThumbnail As Thumbnail
    Get

Property Value

Type: Thumbnail
The new thumbnail for this item.
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs.OldThumbnail Property

CollectionChangedEventArgsOldThumbnail Property

Gets the old thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail OldThumbnail { get; }
Public ReadOnly Property OldThumbnail As Thumbnail
    Get

Property Value

Type: Thumbnail
The old thumbnail for this item.
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs.Thumbnails Property

CollectionChangedEventArgsThumbnails Property

Gets an array of Thumbnail objects that were added to the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail[] Thumbnails { get; }
Public ReadOnly Property Thumbnails As Thumbnail()
    Get

Property Value

Type: Thumbnail
An array of Thumbnail objects.
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventArgs Methods

The CollectionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CollectionChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


CollectionChangedEventHandler Delegate

Represents a method that handles changes to the ThumbnailCollection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void CollectionChangedEventHandler(
    Object sender,
    CollectionChangedEventArgs e
)
Public Delegate Sub CollectionChangedEventHandler (
    sender As Object,
    e As CollectionChangedEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Imaging.WinControlsCollectionChangedEventArgs
A CollectionChangedEventArgs containing information for this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


CollectionChangeType Enumeration

Specifies changes to the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CollectionChangeType
Public Enumeration CollectionChangeType
Members
Member name | Description
Clear | The collection was cleared.
Insert | An item was added or inserted into the collection.
Remove | An item was removed from the collection.
Set | An item was changed in the collection.
Move | An item was moved to a different location within the collection.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


CompareEventHandler Delegate

Represents a method that handles comparing Thumbnail objects.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void CompareEventHandler(
    Object sender,
    ThumbnailCompareEventArgs e
)
Public Delegate Sub CompareEventHandler (
    sender As Object,
    e As ThumbnailCompareEventArgs
)

Parameters

sender
Type: SystemObject
The object sending the event.
e
Type: Atalasoft.Imaging.WinControlsThumbnailCompareEventArgs
A ThumbnailCompareEventArgs containing information for this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


CompositePrintLayout Enumeration

Specifies the layout used in the ImageCompositePrintDocument when printing.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CompositePrintLayout
Public Enumeration CompositePrintLayout
Members
Member name | Description
FullPage | Image will fill the entire page to the extent of the minimum margins.
Inch80x100 | A single image printed per page at 8" x 10" portrait, or 10" x 8" landscape.
Cm20x25 | A single image printed per page at 20cm x 25cm portrait, or 25cm x 20cm landscape.
Inch50x70 | Two images printed per page at 7" x 5" portrait, or 5" x 7" landscape.
Cm13x18 | Two images printed per page at 18cm x 13cm portrait, or 13cm x 18cm landscape.
Inch40x60 | Two images printed per page at 6" x 4" portrait, or 4" x 6" landscape.
Cm10x15 | Two images printed per page at 15cm x 10cm portrait, or 10cm x 13cm landscape.
Inch40x60BestFit | Three images printed per page at 4" x 6", with the third image rotated to fit.
Cm10x15BestFit | Three images printed per page at 10cm x 15cm, with the third image rotated to fit.
Inch35x50 | Four images printed per page at 3.5" x 5" portrait, or 5" x 3.5" landscape.
Cm9x13 | Four images printed per page at 9cm x 13cm portrait, or 13cm x 9cm landscape.
Wallet | Nine wallet sized images printed per page (2.5" x 3.125").
ContactSheet | Thirty-five images printed per page (1.4" x 1.12").
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ControlDockStyle Enumeration

Defines the dock position of a control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ControlDockStyle
Public Enumeration ControlDockStyle
Members
Member name | Description
Left | The control is docked on the left side.
Right | The control is docked on the right side.
Top | The control is docked along the top.
Bottom | The control is docked along the bottom.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ControlSeparator Enumeration

Defines the type of separator to use.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ControlSeparator
Public Enumeration ControlSeparator
Members
Member name | Description
None | No separator is displayed.
Splitter | A splitter control is used as a separator.
Spacing | A separator is used for spacing between controls.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventArgs Class

This class is used to provide notification when the ThumbnailDataBinding data has been modified.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsDataMemberChangedEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DataMemberChangedEventArgs : EventArgs
Public Class DataMemberChangedEventArgs
    Inherits EventArgs

The DataMemberChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DataMemberChangedEventArgs | Creates a new instance of DataMemberChangedEventArgs specifying the data member affected and the new value of the member.
Top
Properties
 | Name | Description
Public property | MemberName | Gets the name of the member that was modified.
Public property | Value | Gets the new value of the member.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventArgs Constructor

Creates a new instance of DataMemberChangedEventArgs specifying the data member affected and the new value of the member.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMemberChangedEventArgs(
    string memberName,
    string value
)
Public Sub New (
    memberName As String,
    value As String
)

Parameters

memberName
Type: SystemString
The member that has been modified.
value
Type: SystemString
The new value of this member.
See Also

Reference

DataMemberChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventArgs Properties

The DataMemberChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MemberName | Gets the name of the member that was modified.
Public property | Value | Gets the new value of the member.
Top
See Also

Reference

DataMemberChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventArgs.MemberName Property

DataMemberChangedEventArgsMemberName Property

Gets the name of the member that was modified.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MemberName { get; }
Public ReadOnly Property MemberName As String
    Get

Property Value

Type: String
The name of the modified member.
See Also

Reference

DataMemberChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventArgs.Value Property

DataMemberChangedEventArgsValue Property

Gets the new value of the member.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get

Property Value

Type: String
The value of the member.
See Also

Reference

DataMemberChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventArgs Methods

The DataMemberChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataMemberChangedEventArgs Class
Atalasoft.Imaging.WinControls Namespace


DataMemberChangedEventHandler Delegate

Represents a method that handles member changes for data binding.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void DataMemberChangedEventHandler(
    Object sender,
    DataMemberChangedEventArgs e
)
Public Delegate Sub DataMemberChangedEventHandler (
    sender As Object,
    e As DataMemberChangedEventArgs
)

Parameters

sender
Type: SystemObject
The object that sent the event.
e
Type: Atalasoft.Imaging.WinControlsDataMemberChangedEventArgs
A DataMemberChangedEventArgs containing information for this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


DocumentViewer Class

The DocumentViewer control simplifies the process of synchronizing a ThumbnailView with a ImageViewer.

The control's ThumbnailView can be docked on any side using the ThumbnailDockStyle property. A SeparatorProperties can be enabled, allowing the end user to resize the ThumbnailView and the ImageViewer will fill the rest of the control.

Synchronization is performed using the ThumbnailImageViewerSynchronizer class. When a thumbnail is selected, its full size image is loaded into the viewer where it can be modified. When an image is modified its thumbnail will be updated to match the change.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsDocumentViewer
Atalasoft.Annotate.UIDocumentAnnotationViewer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentViewer : Control
Public Class DocumentViewer
    Inherits Control

The DocumentViewer type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentViewer | Initializes a new instance of the DocumentViewer class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Asynchronous | Indicates whether processing is performed in a background thread. The default value is false
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Count | Gets the number of thumbnails in the ThumbnailView.
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CurrentImageIndex | Gets the index of the image loaded in the viewer.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
 | ImageControl | Gets the image control properties.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoCount | Gets the number of redo operations.
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectFirstPageOnOpen | Gets or sets a value indicating whether the first page of an image is automatically selected after a call to Open(String).
 | Separator | Gets the properties used for the separator.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | SquareResolutionRequired | Gets or sets a value indicating whether the images must have equal X and Y resolution values.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
 | ThumbnailControl | Gets the ThumbnailView properties.
 | ThumbnailControlSize | Gets or sets the width or height of the ThumbnailView.
 | ThumbnailDockStyle | Gets or sets a value indicating which side the thumbnail control should be docked against.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoCount | Gets the number of undo operations.
Public property | UndoLevels | Gets or sets the maximum number of undo operations to hold.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the DocumentViewer.
 | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from an image and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages from a file into the control and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
 | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(AtalaImage, String, String) | Adds an AtalaImage to the thumbnail control.
Public method | Add(Stream, Int32, String, String) | Loads one or more images from a Stream.
Public method | Add(String, Int32, String, String) | Adds one or more images from a file.
Public method | ApplyCommand |
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear |
Public method | ClearSelection |
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the control. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetImageSource |
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTemporaryXmpFileName | Returns the temorary filename used by the DocumentAnnotationViewer to store XMP annotation data.
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert(Int32, RandomAccessImageSource) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all images from a stream into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an AtalaImage into the thumbnail control.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts one or more images into the ThumbnailView from a Stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts one or more images into the ThumbnailView from a file.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsThumbnailVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is currently visible.
Public method | IsThumbnailVisible(Thumbnail, Boolean) | Returns a value indicating whether the specified thumbnail is currently visible.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClear | Called when the Clear method is invoked.
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Overrides ControlOnCreateControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | (Overrides ControlOnDockChanged(EventArgs).)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageInserted | Called when an image is inserted into the collection through the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) methods.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnOpenDocument | Called when the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) method is used to allow derived classes to perform any pre-open actions.
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPrintingPage | Called just before each page is printed to allow derived classes to modify the image.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Called when the current image index has changed.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailControlSizeChanged |
Protected method | OnThumbnailDockStyleChanged |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
 | Open(Stream) | Opens all pages of an image from a stream.
Public method | Open(String) | Opens an image from a filename. If the file is a multipage document, all pages are added to the control.
 | Open(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the viewer.
 | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(Stream, Int32) | Opens the specified page from an image.
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages in an image and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(String, Int32) | Opens the specified frame index from a file.
 | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(Stream, Int32, String, String) | Opens the specified page from an image and provides the thumbnail caption and tooltip.
Public method | Open(String, Int32, String, String) | Opens the specified frame from an image and provides the thumbnail caption and tooltip.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | Print | This method will print the contents of the DocumentViewer.
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Performs a redo operation on the viewer.
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Remove |
Public method | RemoveAt |
Public method | RemoveSelected |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the image(s) to a stream using the supplied encoder.
Public method | Save(String, ImageEncoder) | Saves the image(s) to a file using the supplied encoder.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll |
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectThumbnail |
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetImageViewer | Use this method to replace the standard ImageViewer with another control deriving from ImageViewer.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetUndoManager | Call this method to replace the default CachedImageUndoManager with a custom version.
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetZoomMode |
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Performs an undo operation on the viewer.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AfterLabelEdit |
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit |
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PrintingPage | Raised as each page is about to be printed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RedoPerformed | Raised when a redo operation has been performed.
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged |
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | UndoListChanged | Raised when there has been a change in the undo/redo lists.
Public event | UndoPerformed | Raised when an undo operation has been performed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks

Advantages to using the DocumentViewer control:

There is less code to write: All synchronization between the ThumbnailView and ImageViewer controls is handled for you.Images can be added from an AtalaImage, file, Stream or RandomAccessImageSource and are managed internally so there is no need to keep track of where an image is loaded from.When images are modified they are saved to a temporary file, keeping the original image untouched. These temporary files are automatically deleted when the control is disposed.Only one full size image is kept in memory at a time, resulting in lower memory overhead.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


DocumentViewer Constructor

Initializes a new instance of the DocumentViewer class

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentViewer()
Public Sub New
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer Properties

The DocumentViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Asynchronous | Indicates whether processing is performed in a background thread. The default value is false
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Count | Gets the number of thumbnails in the ThumbnailView.
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CurrentImageIndex | Gets the index of the image loaded in the viewer.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
 | ImageControl | Gets the image control properties.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoCount | Gets the number of redo operations.
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectFirstPageOnOpen | Gets or sets a value indicating whether the first page of an image is automatically selected after a call to Open(String).
 | Separator | Gets the properties used for the separator.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | SquareResolutionRequired | Gets or sets a value indicating whether the images must have equal X and Y resolution values.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
 | ThumbnailControl | Gets the ThumbnailView properties.
 | ThumbnailControlSize | Gets or sets the width or height of the ThumbnailView.
 | ThumbnailDockStyle | Gets or sets a value indicating which side the thumbnail control should be docked against.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoCount | Gets the number of undo operations.
Public property | UndoLevels | Gets or sets the maximum number of undo operations to hold.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Asynchronous Property

DocumentViewerAsynchronous Property

Indicates whether processing is performed in a background thread. The default value is false

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Asynchronous { get; set; }
Public Property Asynchronous As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Count Property

DocumentViewerCount Property

Gets the number of thumbnails in the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of thumbnails.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.CurrentImageIndex Property

DocumentViewerCurrentImageIndex Property

Gets the index of the image loaded in the viewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentImageIndex { get; }
Public ReadOnly Property CurrentImageIndex As Integer
    Get

Property Value

Type: Int32
The index of the image loaded in the viewer.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.ImageControl Property

DocumentViewerImageControl Property

Gets the image control properties.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageControlProperties ImageControl { get; }
Public ReadOnly Property ImageControl As ImageControlProperties
    Get

Property Value

Type: ImageControlProperties
The image control properties.
Examples
C#
VB
Copy
_viewer.ImageControl.MouseTool = MouseToolType.Pan;
_viewer.ImageControl.MouseTool = MouseToolType.Pan
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.RedoCount Property

DocumentViewerRedoCount Property

Gets the number of redo operations.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RedoCount { get; }
Public ReadOnly Property RedoCount As Integer
    Get

Property Value

Type: Int32
The number of redo operation.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SelectFirstPageOnOpen Property

DocumentViewerSelectFirstPageOnOpen Property

Gets or sets a value indicating whether the first page of an image is automatically selected after a call to Open(String).

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelectFirstPageOnOpen { get; set; }
Public Property SelectFirstPageOnOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether to automatically select the first page after calling Open(String).
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Separator Property

DocumentViewerSeparator Property

Gets the properties used for the separator.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SeparatorProperties Separator { get; }
Public ReadOnly Property Separator As SeparatorProperties
    Get

Property Value

Type: SeparatorProperties
The separator properties.
Examples
C#
VB
Copy
_viewer.Separator.Mode = ControlSeparator.Splitter;
_viewer.Separator.MinSize = 100;
_viewer.Separator.MinExtra = 100;
_viewer.Separator.Size = 6;
_viewer.Separator.Mode = ControlSeparator.Splitter
_viewer.Separator.MinSize = 100
_viewer.Separator.MinExtra = 100
_viewer.Separator.Size = 6
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SquareResolutionRequired Property

DocumentViewerSquareResolutionRequired Property

Gets or sets a value indicating whether the images must have equal X and Y resolution values.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool SquareResolutionRequired { get; set; }
Protected Property SquareResolutionRequired As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the images must have equal resolution values.
Remarks
If true, the DocumentViewer will automatically resample the image to make its resolution values equal.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.ThumbnailControl Property

DocumentViewerThumbnailControl Property

Gets the ThumbnailView properties.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailControlProperties ThumbnailControl { get; }
Public ReadOnly Property ThumbnailControl As ThumbnailControlProperties
    Get

Property Value

Type: ThumbnailControlProperties
The ThumbnailView properties.
Examples
C#
VB
Copy
_viewer.ThumbnailControl.CaptionLines = 1;
_viewer.ThumbnailControl.ThumbnailSize = new Size(120, 120);
_viewer.ThumbnailControl.CaptionLines = 1
_viewer.ThumbnailControl.ThumbnailSize = New Size(120, 120)
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.ThumbnailControlSize Property

DocumentViewerThumbnailControlSize Property

Gets or sets the width or height of the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ThumbnailControlSize { get; set; }
Public Property ThumbnailControlSize As Integer
    Get
    Set

Property Value

Type: Int32
The width or height of the ThumbnailView.
Remarks
The control's space is split up into three sections: The ThumbnailControlSize specifies the size of the thumbnail control, the Size specifies the spacing (if any) between the thumbnail and image control, and the rest of the space is filled by the image control.
Examples
C#
VB
Copy
_viewer.ThumbnailControlSize = 180;
_viewer.ThumbnailControlSize = 180
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.ThumbnailDockStyle Property

DocumentViewerThumbnailDockStyle Property

Gets or sets a value indicating which side the thumbnail control should be docked against.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ControlDockStyle ThumbnailDockStyle { get; set; }
Public Property ThumbnailDockStyle As ControlDockStyle
    Get
    Set

Property Value

Type: ControlDockStyle
The dock position of the ThumbnailView.
Examples
C#
VB
Copy
_viewer.ThumbnailDockStyle = ControlDockStyle.Right;
_viewer.ThumbnailDockStyle = ControlDockStyle.Right
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.UndoCount Property

DocumentViewerUndoCount Property

Gets the number of undo operations.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndoCount { get; }
Public ReadOnly Property UndoCount As Integer
    Get

Property Value

Type: Int32
The number of undo operations.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.UndoLevels Property

DocumentViewerUndoLevels Property

Gets or sets the maximum number of undo operations to hold.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndoLevels { get; set; }
Public Property UndoLevels As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of undo operations.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer Methods

The DocumentViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the DocumentViewer.
 | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from an image and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages from a file into the control and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
 | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(AtalaImage, String, String) | Adds an AtalaImage to the thumbnail control.
Public method | Add(Stream, Int32, String, String) | Loads one or more images from a Stream.
Public method | Add(String, Int32, String, String) | Adds one or more images from a file.
Public method | ApplyCommand |
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear |
Public method | ClearSelection |
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the control. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetImageSource |
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTemporaryXmpFileName | Returns the temorary filename used by the DocumentAnnotationViewer to store XMP annotation data.
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert(Int32, RandomAccessImageSource) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all images from a stream into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an AtalaImage into the thumbnail control.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts one or more images into the ThumbnailView from a Stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts one or more images into the ThumbnailView from a file.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsThumbnailVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is currently visible.
Public method | IsThumbnailVisible(Thumbnail, Boolean) | Returns a value indicating whether the specified thumbnail is currently visible.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClear | Called when the Clear method is invoked.
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Overrides ControlOnCreateControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | (Overrides ControlOnDockChanged(EventArgs).)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageInserted | Called when an image is inserted into the collection through the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) methods.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnOpenDocument | Called when the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) method is used to allow derived classes to perform any pre-open actions.
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPrintingPage | Called just before each page is printed to allow derived classes to modify the image.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Called when the current image index has changed.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailControlSizeChanged |
Protected method | OnThumbnailDockStyleChanged |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
 | Open(Stream) | Opens all pages of an image from a stream.
Public method | Open(String) | Opens an image from a filename. If the file is a multipage document, all pages are added to the control.
 | Open(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the viewer.
 | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(Stream, Int32) | Opens the specified page from an image.
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages in an image and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(String, Int32) | Opens the specified frame index from a file.
 | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(Stream, Int32, String, String) | Opens the specified page from an image and provides the thumbnail caption and tooltip.
Public method | Open(String, Int32, String, String) | Opens the specified frame from an image and provides the thumbnail caption and tooltip.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | Print | This method will print the contents of the DocumentViewer.
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Performs a redo operation on the viewer.
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Remove |
Public method | RemoveAt |
Public method | RemoveSelected |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the image(s) to a stream using the supplied encoder.
Public method | Save(String, ImageEncoder) | Saves the image(s) to a file using the supplied encoder.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll |
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectThumbnail |
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetImageViewer | Use this method to replace the standard ImageViewer with another control deriving from ImageViewer.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetUndoManager | Call this method to replace the default CachedImageUndoManager with a custom version.
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetZoomMode |
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Performs an undo operation on the viewer.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method

DocumentViewerAdd Method

Overload List
 | Name | Description
 | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the DocumentViewer.
 | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from an image and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages from a file into the control and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
 | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(AtalaImage, String, String) | Adds an AtalaImage to the thumbnail control.
Public method | Add(Stream, Int32, String, String) | Loads one or more images from a Stream.
Public method | Add(String, Int32, String, String) | Adds one or more images from a file.
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (RandomAccessImageSource)

DocumentViewerAdd Method (RandomAccessImageSource)

Adds images from a RandomAccessImageSource into the DocumentViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    RandomAccessImageSource imageSource
)
Public Sub Add (
    imageSource As RandomAccessImageSource
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source to grab images from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
Examples
C#
VB
Copy
this._viewer.Add(new FileSystemImageSource(new string[] { @"C:\images\multipage.tif" }, true));
Me._viewer.Add(New FileSystemImageSource(New String() { "C:\images\multipage.tif" }, True))
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (Stream, ThumbnailCaptionRequestEventHandler)

DocumentViewerAdd Method (Stream, ThumbnailCaptionRequestEventHandler)

Adds all pages from an image and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Add (
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

stream
Type: System.IOStream
The stream containing the image data.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
The ThumbnailCaptionRequestEventHandler called to get the thumbnail caption and tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
Examples
C#
VB
Copy
private void menuAdd_Click(object sender, System.EventArgs e)
{
  // The caption and tooltip for each page will
  // be set in the OnThumbnailCaptionRequest method.
  using (FileStream fs = new FileStream(@"C:\images\multipage.tif", FileMode.Open, FileAccess.Read, FileShare.Read))
  {
      this._viewer.Add(fs, new ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest));
  }
}

private void OnThumbnailCaptionRequest(object sender, ThumbnailCaptionRequestEventArgs e)
{
  e.Caption = "Image " + e.Index.ToString();
  e.ToolTip = "";
}
Private Sub menuAdd_Click(ByVal sender As Object, ByVal e As System.EventArgs)
  ' The caption and tooltip for each page will
  ' be set in the OnThumbnailCaptionRequest method.
  Dim fs As FileStream = New FileStream("C:\images\multipage.tif", FileMode.Open, FileAccess.Read, FileShare.Read)
  Try
      Me._viewer.Add(fs, New ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest))
  Finally
      fs.Dispose()
  End Try
End Sub

Private Sub OnThumbnailCaptionRequest(ByVal sender As Object, ByVal e As ThumbnailCaptionRequestEventArgs)
  e.Caption = "Image " & e.Index.ToString()
  e.ToolTip = ""
End Sub
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (String, ThumbnailCaptionRequestEventHandler)

DocumentViewerAdd Method (String, ThumbnailCaptionRequestEventHandler)

Adds all pages from a file into the control and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Add (
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

fileName
Type: SystemString
The filename of the image.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
The ThumbnailCaptionRequestEventHandler called to get the thumbnail caption and tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB).
FileNotFoundException | Thrown if the file cannot be found.
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

DocumentViewerAdd Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Adds images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Add (
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source to grab images from.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
The ThumbnailCaptionRequestEventHandler called to get the thumbnail caption and tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
Examples
C#
VB
Copy
private void menuAdd_Click(object sender, System.EventArgs e)
{
   // The caption and tooltip for each page will
   // be set in the OnThumbnailCaptionRequest method.
   this._viewer.Add(new FileSystemImageSource(new string[] { @"C:\images\multipage.tif" }, true), new ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest));
}

private void OnThumbnailCaptionRequest(object sender, ThumbnailCaptionRequestEventArgs e)
{
   e.Caption = "Image " + e.Index.ToString();
   e.ToolTip = "";
}
Private Sub menuAdd_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    ' The caption and tooltip for each page will
    ' be set in the OnThumbnailCaptionRequest method.
    Me._viewer.Add(New FileSystemImageSource(New String() { "C:\images\multipage.tif" }, True), New ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest))
End Sub

Private Sub OnThumbnailCaptionRequest(ByVal sender As Object, ByVal e As ThumbnailCaptionRequestEventArgs)
    e.Caption = "Image " & e.Index.ToString()
    e.ToolTip = ""
End Sub
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (AtalaImage, String, String)

DocumentViewerAdd Method (AtalaImage, String, String)

Adds an AtalaImage to the thumbnail control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    AtalaImage image,
    string caption,
    string toolTip
)
Public Sub Add (
    image As AtalaImage,
    caption As String,
    toolTip As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to add.
caption
Type: SystemString
The caption of the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image is null (Nothing in VB).
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (Stream, Int32, String, String)

DocumentViewerAdd Method (Stream, Int32, String, String)

Loads one or more images from a Stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Add (
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

stream
Type: System.IOStream
The stream containing the image data.
frameIndex
Type: SystemInt32
The frame index to load or -1 to load all pages of a multipage image.
caption
Type: SystemString
The thumbnail caption to use.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream argument is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Add Method (String, Int32, String, String)

DocumentViewerAdd Method (String, Int32, String, String)

Adds one or more images from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Add (
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

fileName
Type: SystemString
The full path and filename of the image.
frameIndex
Type: SystemInt32
The frame index to load or -1 to load all pages in a multipage image.
caption
Type: SystemString
The caption of the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the fileName argument is null (Nothing in VB).
FileNotFoundException | Thrown if the file cannot be found.
See Also

Reference

DocumentViewer Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.ApplyCommand Method

DocumentViewerApplyCommand Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command
)
Public Sub ApplyCommand (
    command As ImageCommand
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Clear Method

DocumentViewerClear Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.ClearSelection Method

DocumentViewerClearSelection Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearSelection()
Public Sub ClearSelection
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Dispose Method

DocumentViewerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the control. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Dispose Method (Boolean)

DocumentViewerDispose Method (Boolean)

Releases resources used by the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
A value indicating whether this method was called from the public Dispose method.
See Also

Reference

DocumentViewer Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.EnsureVisible Method

DocumentViewerEnsureVisible Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void EnsureVisible(
    int index
)
Public Sub EnsureVisible (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Finalize Method

DocumentViewerFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.GetImageSource Method

DocumentViewerGetImageSource Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ImageSource GetImageSource()
Protected Function GetImageSource As ImageSource

Return Value

Type: ImageSource
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.GetTemporaryXmpFileName Method

DocumentViewerGetTemporaryXmpFileName Method

Returns the temorary filename used by the DocumentAnnotationViewer to store XMP annotation data.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected string GetTemporaryXmpFileName(
    int index
)
Protected Function GetTemporaryXmpFileName (
    index As Integer
) As String

Parameters

index
Type: SystemInt32
The index of the image.

Return Value

Type: String
The filename used to store XMP annotation data.
Remarks
A temporary filename is generated for each image, but the file may not exist if the image does not have any annotations.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method

DocumentViewerInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, RandomAccessImageSource) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all images from a stream into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an AtalaImage into the thumbnail control.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts one or more images into the ThumbnailView from a Stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts one or more images into the ThumbnailView from a file.
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, RandomAccessImageSource)

DocumentViewerInsert Method (Int32, RandomAccessImageSource)

Inserts images from a RandomAccessImageSource into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    RandomAccessImageSource imageSource
)
Public Sub Insert (
    index As Integer,
    imageSource As RandomAccessImageSource
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source to grab images from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
Remarks
The ImageSource provided must remain valid for the lifetime of the control or until the images have been removed.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

DocumentViewerInsert Method (Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Inserts images from a RandomAccessImageSource and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Insert (
    index As Integer,
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source to grab images from.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
The ThumbnailCaptionRequestEventHandler called to get the thumbnail caption and tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource is null (Nothing in VB).
ArgumentException | Thorwn if the image source does not know its total image count.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
Remarks
The ImageSource provided must remain valid for the lifetime of the control or until the images have been removed.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, Stream, ThumbnailCaptionRequestEventHandler)

DocumentViewerInsert Method (Int32, Stream, ThumbnailCaptionRequestEventHandler)

Inserts all images from a stream into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Insert (
    index As Integer,
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
stream
Type: System.IOStream
The stream containing the image data.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
The ThumbnailCaptionRequestEventHandler called to get the thumbnail caption and tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
Remarks
The stream can be closed after calling this method because the image data is saved to a temporary file.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, String, ThumbnailCaptionRequestEventHandler)

DocumentViewerInsert Method (Int32, String, ThumbnailCaptionRequestEventHandler)

Inserts all pages from a file into the ThumbnailView and gets the thumbnail caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Insert (
    index As Integer,
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
fileName
Type: SystemString
The filename of the image.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
The ThumbnailCaptionRequestEventHandler called to get the thumbnail caption and tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, AtalaImage, String, String)

DocumentViewerInsert Method (Int32, AtalaImage, String, String)

Inserts an AtalaImage into the thumbnail control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    AtalaImage image,
    string caption,
    string toolTip
)
Public Sub Insert (
    index As Integer,
    image As AtalaImage,
    caption As String,
    toolTip As String
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to add.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image argument is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
Remarks
The AtalaImage can be disposed after this method call.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, Stream, Int32, String, String)

DocumentViewerInsert Method (Int32, Stream, Int32, String, String)

Inserts one or more images into the ThumbnailView from a Stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Insert (
    index As Integer,
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
stream
Type: System.IOStream
The stream containing the image data.
frameIndex
Type: SystemInt32
The frame index of the page to load or -1 to load all pages.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
Remarks
The stream can be closed after calling Insert because the image data is saved to a temporary file.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Insert Method (Int32, String, Int32, String, String)

DocumentViewerInsert Method (Int32, String, Int32, String, String)

Inserts one or more images into the ThumbnailView from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Insert (
    index As Integer,
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted.
fileName
Type: SystemString
The filename of the image.
frameIndex
Type: SystemInt32
The frame index of the page to load or -1 to load all pages.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the fileName argument is null (Nothing in VB).
FileNotFoundException | Thrown if the file cannot be found.
 | Thrown if the index argument is out of range for this collection.
See Also

Reference

DocumentViewer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.IsThumbnailVisible Method

DocumentViewerIsThumbnailVisible Method

Determines whether a specified thumbnail is currently visible.
Overload List
 | Name | Description
Public method | IsThumbnailVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is currently visible.
Public method | IsThumbnailVisible(Thumbnail, Boolean) | Returns a value indicating whether the specified thumbnail is currently visible.
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.IsThumbnailVisible Method (Int32, Boolean)

DocumentViewerIsThumbnailVisible Method (Int32, Boolean)

Returns a value indicating whether the thumbnail at the specified index is currently visible.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsThumbnailVisible(
    int index,
    bool requireFullVisibility
)
Public Function IsThumbnailVisible (
    index As Integer,
    requireFullVisibility As Boolean
) As Boolean

Parameters

index
Type: SystemInt32
The index of the thumbnail.
requireFullVisibility
Type: SystemBoolean
True if the entire thumbnail must be visible.

Return Value

Type: Boolean
True if the thumbnail is visible.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for the collection.
See Also

Reference

DocumentViewer Class
IsThumbnailVisible Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.IsThumbnailVisible Method (Thumbnail, Boolean)

DocumentViewerIsThumbnailVisible Method (Thumbnail, Boolean)

Returns a value indicating whether the specified thumbnail is currently visible.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsThumbnailVisible(
    Thumbnail thumbnail,
    bool requireFullVisibility
)
Public Function IsThumbnailVisible (
    thumbnail As Thumbnail,
    requireFullVisibility As Boolean
) As Boolean

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to validate.
requireFullVisibility
Type: SystemBoolean
True if the entire thumbnail must be visible.

Return Value

Type: Boolean
True if the thumbnail is visible.
Exceptions
Exception | Condition
ArgumentException | Thrown if the thumbnail argument is null (Nothing in VB).
 | Thrown if the thumbnail is not hosted in the viewer.
See Also

Reference

DocumentViewer Class
IsThumbnailVisible Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnClear Method

DocumentViewerOnClear Method

Called when the Clear method is invoked.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnClear()
Protected Overridable Sub OnClear
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnCreateControl Method

DocumentViewerOnCreateControl Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnCreateControl()
Protected Overrides Sub OnCreateControl
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnDockChanged Method

DocumentViewerOnDockChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDockChanged(
    EventArgs e
)
Protected Overrides Sub OnDockChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnImageInserted Method

DocumentViewerOnImageInserted Method

Called when an image is inserted into the collection through the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) methods.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageInserted(
    ImageInsertEventArgs e
)
Protected Overridable Sub OnImageInserted (
    e As ImageInsertEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsImageInsertEventArgs
An ImageInsertEventArgs for the operation.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnOpenDocument Method

DocumentViewerOnOpenDocument Method

Called when the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) method is used to allow derived classes to perform any pre-open actions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnOpenDocument(
    OpenDocumentEventArgs e
)
Protected Overridable Sub OnOpenDocument (
    e As OpenDocumentEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsOpenDocumentEventArgs
An event args containing the arguments passed into the Open(String), Add(AtalaImage, String, String) or Insert(Int32, String, Int32, String, String) method.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnPaint Method

DocumentViewerOnPaint Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnPrintingPage Method

DocumentViewerOnPrintingPage Method

Called just before each page is printed to allow derived classes to modify the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPrintingPage(
    PrintImageEventArgs e
)
Protected Overridable Sub OnPrintingPage (
    e As PrintImageEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
An event args containing information about the image being printed.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnSelectedIndexChanged Method

DocumentViewerOnSelectedIndexChanged Method

Called when the current image index has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectedIndexChanged(
    EventArgs e
)
Protected Overridable Sub OnSelectedIndexChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this operation.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnThumbnailControlSizeChanged Method

DocumentViewerOnThumbnailControlSizeChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnThumbnailControlSizeChanged(
    EventArgs e
)
Protected Overridable Sub OnThumbnailControlSizeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.OnThumbnailDockStyleChanged Method

DocumentViewerOnThumbnailDockStyleChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnThumbnailDockStyleChanged(
    EventArgs e
)
Protected Overridable Sub OnThumbnailDockStyleChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method

DocumentViewerOpen Method

Opens one or more images, replacing the existing images in the DocumentViewer.
Overload List
 | Name | Description
 | Open(Stream) | Opens all pages of an image from a stream.
Public method | Open(String) | Opens an image from a filename. If the file is a multipage document, all pages are added to the control.
 | Open(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the viewer.
 | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(Stream, Int32) | Opens the specified page from an image.
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages in an image and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(String, Int32) | Opens the specified frame index from a file.
 | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.
Public method | Open(Stream, Int32, String, String) | Opens the specified page from an image and provides the thumbnail caption and tooltip.
Public method | Open(String, Int32, String, String) | Opens the specified frame from an image and provides the thumbnail caption and tooltip.
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (Stream)

DocumentViewerOpen Method (Stream)

Opens all pages of an image from a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream
)
Public Sub Open (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
The stream containing the image. The stream must have read access and be seekable.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream argument is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
Examples
C#
VB
Copy
using (FileStream fs = new FileStream(@"C:\images\multipage.tif", FileMode.Open, FileAccess.Read, FileShare.Read))
{
    this._viewer.Open(fs);
}
Dim fs As FileStream = New FileStream("C:\images\multipage.tif", FileMode.Open, FileAccess.Read, FileShare.Read)
Try
    Me._viewer.Open(fs)
Finally
    fs.Dispose()
End Try
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (String)

DocumentViewerOpen Method (String)

Opens an image from a filename. If the file is a multipage document, all pages are added to the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName
)
Public Sub Open (
    fileName As String
)

Parameters

fileName
Type: SystemString
The filename of the image.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename argument is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the filename cannot be found.
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (RandomAccessImageSource)

DocumentViewerOpen Method (RandomAccessImageSource)

Adds images from a RandomAccessImageSource into the viewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    RandomAccessImageSource imageSource
)
Public Sub Open (
    imageSource As RandomAccessImageSource
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source to load images from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
Examples
C#
VB
Copy
this._viewer.Open(new FileSystemImageSource(new string[] { @"C:\images\multipage.tif" }, true));
Me._viewer.Open(New FileSystemImageSource(New String() { "C:\images\multipage.tif" }, True))
Examples
C#
VB
Copy
this._viewer.Open(new FileSystemImageSource(new string[] { @"C:\images\multipage.tif" }, true));
Me._viewer.Open(New FileSystemImageSource(New String() { "C:\images\multipage.tif" }, True))
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (Stream, ThumbnailCaptionRequestEventHandler)

DocumentViewerOpen Method (Stream, ThumbnailCaptionRequestEventHandler)

Opens all pages from a stream and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Open (
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

stream
Type: System.IOStream
The stream containing the image. The stream must have read access and be seekable.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler that will be used to request the caption and tooltip for each thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream argument is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
Examples
C#
VB
Copy
private void menuOpen_Click(object sender, System.EventArgs e)
{
 // The caption and tooltip for each page will
 // be set in the OnThumbnailCaptionRequest method.
 using (FileStream fs = new FileStream(@"C:\images\multipage.tif", FileMode.Open, FileAccess.Read, FileShare.Read))
 {
     this._viewer.Open(fs, new ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest));
 }
}

private void OnThumbnailCaptionRequest(object sender, ThumbnailCaptionRequestEventArgs e)
{
 e.Caption = "Image " + e.Index.ToString();
 e.ToolTip = "";
}
Private Sub menuOpen_Click(ByVal sender As Object, ByVal e As System.EventArgs)
  ' The caption and tooltip for each page will
  ' be set in the OnThumbnailCaptionRequest method.
  Dim fs As FileStream = New FileStream("C:\images\multipage.tif", FileMode.Open, FileAccess.Read, FileShare.Read)
  Try
      Me._viewer.Open(fs, New ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest))
  Finally
      fs.Dispose()
  End Try
End Sub

Private Sub OnThumbnailCaptionRequest(ByVal sender As Object, ByVal e As ThumbnailCaptionRequestEventArgs)
  e.Caption = "Image " & e.Index.ToString()
  e.ToolTip = ""
End Sub
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (Stream, Int32)

DocumentViewerOpen Method (Stream, Int32)

Opens the specified page from an image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
The stream containing the image. The stream must have read access and be seekable.
frameIndex
Type: SystemInt32
The page index to open. A value of -1 will load all pages into the DocumentViewer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream argument is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the frameIndex is out of range for this image.
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (String, ThumbnailCaptionRequestEventHandler)

DocumentViewerOpen Method (String, ThumbnailCaptionRequestEventHandler)

Opens all pages in an image and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Open (
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

fileName
Type: SystemString
The filename of the image.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler that will be used to request the caption and tooltip for each thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (String, Int32)

DocumentViewerOpen Method (String, Int32)

Opens the specified frame index from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The filename of the image.
frameIndex
Type: SystemInt32
The page index to open. A value of -1 will load all pages into the DocumentViewer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename argument is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the filename cannot be found.
ArgumentOutOfRangeException | Thrown if the frameIndex is out of range for this image.
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

DocumentViewerOpen Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Adds images from a RandomAccessImageSource and gets the caption and tooltip from the specified ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Open (
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source to load images from.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler that will be used to request the caption and tooltip for each thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
Examples
C#
VB
Copy
private void menuOpen_Click(object sender, System.EventArgs e)
{
  // The caption and tooltip for each page will
  // be set in the OnThumbnailCaptionRequest method.
  this._viewer.Open(new FileSystemImageSource(new string[] { @"C:\images\multipage.tif" }, true), new ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest));
}

private void OnThumbnailCaptionRequest(object sender, ThumbnailCaptionRequestEventArgs e)
{
  e.Caption = "Image " + e.Index.ToString();
  e.ToolTip = "";
}
Private Sub menuOpen_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    ' The caption and tooltip for each page will
    ' be set in the OnThumbnailCaptionRequest method.
    Me._viewer.Open(New FileSystemImageSource(New String() { "C:\images\multipage.tif" }, True), New ThumbnailCaptionRequestEventHandler(OnThumbnailCaptionRequest))
End Sub

Private Sub OnThumbnailCaptionRequest(ByVal sender As Object, ByVal e As ThumbnailCaptionRequestEventArgs)
    e.Caption = "Image " & e.Index.ToString()
    e.ToolTip = ""
End Sub
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (Stream, Int32, String, String)

DocumentViewerOpen Method (Stream, Int32, String, String)

Opens the specified page from an image and provides the thumbnail caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

stream
Type: System.IOStream
The stream containing the image. The stream must have read access and be seekable.
frameIndex
Type: SystemInt32
The page index to open. A value of -1 will load all pages into the DocumentViewer.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream argument is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the frameIndex is out of range for this image.
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Open Method (String, Int32, String, String)

DocumentViewerOpen Method (String, Int32, String, String)

Opens the specified frame from an image and provides the thumbnail caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

fileName
Type: SystemString
The filename of the image.
frameIndex
Type: SystemInt32
The page index to open. A value of -1 will load all pages into the DocumentViewer.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
ArgumentOutOfRangeException | Thrown if the frameIndex is out of range for this image.
See Also

Reference

DocumentViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Print Method

DocumentViewerPrint Method

This method will print the contents of the DocumentViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Print(
    ImagePrintDocument printDocument
)
Public Sub Print (
    printDocument As ImagePrintDocument
)

Parameters

printDocument
Type: Atalasoft.Imaging.WinControlsImagePrintDocument
An ImagePrintDocument that will be used to print the images.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Redo Method

DocumentViewerRedo Method

Performs a redo operation on the viewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Redo()
Public Sub Redo
Remarks
For the DocumentAnnotationViewer, this method affects both image and annotations operations.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Remove Method

DocumentViewerRemove Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    Thumbnail thumbnail
)
Public Sub Remove (
    thumbnail As Thumbnail
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.RemoveAt Method

DocumentViewerRemoveAt Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.RemoveSelected Method

DocumentViewerRemoveSelected Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveSelected()
Public Sub RemoveSelected
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Save Method

DocumentViewerSave Method

Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder) | Saves the image(s) to a stream using the supplied encoder.
Public method | Save(String, ImageEncoder) | Saves the image(s) to a file using the supplied encoder.
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Save Method (Stream, ImageEncoder)

DocumentViewerSave Method (Stream, ImageEncoder)

Saves the image(s) to a stream using the supplied encoder.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Save(
    Stream stream,
    ImageEncoder encoder
)
Public Overridable Sub Save (
    stream As Stream,
    encoder As ImageEncoder
)

Parameters

stream
Type: System.IOStream
The stream to save the image(s) into.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use when saving. If this encoder derives from MultiFramedImageEncoder, all images will be saved.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
See Also

Reference

DocumentViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Save Method (String, ImageEncoder)

DocumentViewerSave Method (String, ImageEncoder)

Saves the image(s) to a file using the supplied encoder.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder
)

Parameters

fileName
Type: SystemString
The file where the image(s) will be saved.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use when saving. If this encoder derives from MultiFramedImageEncoder, all images will be saved.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if any argument is null (Nothing in VB).
See Also

Reference

DocumentViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SelectAll Method

DocumentViewerSelectAll Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAll()
Public Sub SelectAll
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SelectThumbnail Method

DocumentViewerSelectThumbnail Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectThumbnail(
    int index
)
Public Sub SelectThumbnail (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SetImageViewer Method

DocumentViewerSetImageViewer Method

Use this method to replace the standard ImageViewer with another control deriving from ImageViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetImageViewer(
    ImageViewer viewer
)
Protected Sub SetImageViewer (
    viewer As ImageViewer
)

Parameters

viewer
Type: Atalasoft.Imaging.WinControlsImageViewer
The new viewer for the control.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SetUndoManager Method

DocumentViewerSetUndoManager Method

Call this method to replace the default CachedImageUndoManager with a custom version.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetUndoManager(
    CachedImageUndoManager manager
)
Protected Sub SetUndoManager (
    manager As CachedImageUndoManager
)

Parameters

manager
Type: Atalasoft.Imaging.WinControlsCachedImageUndoManager
The undo manager that will be used for this viewer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the manager argument is null (Nothing in VB).
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SetZoomMode Method

DocumentViewerSetZoomMode Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetZoomMode(
    AutoZoomMode zoomType
)
Public Sub SetZoomMode (
    zoomType As AutoZoomMode
)

Parameters

zoomType
Type: Atalasoft.Imaging.WinControlsAutoZoomMode
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.Undo Method

DocumentViewerUndo Method

Performs an undo operation on the viewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Undo()
Public Sub Undo
Remarks
For the DocumentAnnotationViewer, this method affects both image and annotations operations.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer Events

The DocumentViewer type exposes the following members.

Events
 | Name | Description
Public event | AfterLabelEdit |
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit |
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PrintingPage | Raised as each page is about to be printed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RedoPerformed | Raised when a redo operation has been performed.
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged |
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | UndoListChanged | Raised when there has been a change in the undo/redo lists.
Public event | UndoPerformed | Raised when an undo operation has been performed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.AfterLabelEdit Event

DocumentViewerAfterLabelEdit Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event LabelEditEventHandler AfterLabelEdit
Public Event AfterLabelEdit As LabelEditEventHandler

Value

Type: System.Windows.FormsLabelEditEventHandler
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.BeforeLabelEdit Event

DocumentViewerBeforeLabelEdit Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event LabelEditEventHandler BeforeLabelEdit
Public Event BeforeLabelEdit As LabelEditEventHandler

Value

Type: System.Windows.FormsLabelEditEventHandler
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.PrintingPage Event

DocumentViewerPrintingPage Event

Raised as each page is about to be printed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PrintImageEventHandler PrintingPage
Public Event PrintingPage As PrintImageEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPrintImageEventHandler
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.RedoPerformed Event

DocumentViewerRedoPerformed Event

Raised when a redo operation has been performed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler RedoPerformed
Public Event RedoPerformed As EventHandler

Value

Type: SystemEventHandler
Remarks
Note: This event is raised before the viewer has updated its image.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.SelectedIndexChanged Event

DocumentViewerSelectedIndexChanged Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectedIndexChanged
Public Event SelectedIndexChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.UndoListChanged Event

DocumentViewerUndoListChanged Event

Raised when there has been a change in the undo/redo lists.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler UndoListChanged
Public Event UndoListChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewer.UndoPerformed Event

DocumentViewerUndoPerformed Event

Raised when an undo operation has been performed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler UndoPerformed
Public Event UndoPerformed As EventHandler

Value

Type: SystemEventHandler
Remarks
Note: This event is raised before the viewer has updated its image.
See Also

Reference

DocumentViewer Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
Atalasoft.Imaging.WinControlsThumbnailView
Atalasoft.Imaging.WinControlsDocumentViewerThumbnailView

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentViewerThumbnailView : ThumbnailView
Public Class DocumentViewerThumbnailView
    Inherits ThumbnailView

The DocumentViewerThumbnailView type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentViewerThumbnailView | Initializes a new instance of the DocumentViewerThumbnailView class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the method required by to user to activate a thumbnail. (Inherited from ThumbnailView.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowKeyAction | Gets or sets the action taken when the ThumbnailView receives an arrow key press event. (Inherited from ThumbnailView.)
Public property | Asynchronous | Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously. (Inherited from ThumbnailView.)
Public property | AutoDragDrop | Gets or sets a value indicating whether the internal drag and drop code is used. (Inherited from ThumbnailView.)
Public property | AutoScroll | (Inherited from ThumbnailView.)
Public property | AutoScrollMargin | (Inherited from ThumbnailView.)
Public property | AutoScrollMinSize | (Inherited from ThumbnailView.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFormat | Gets the StringFormat used for rendering the thumbnail captions. (Inherited from ThumbnailView.)
Public property | CaptionLines | Gets or sets the number of text lines to allocate for the caption area. (Inherited from ThumbnailView.)
Public property | CaptionSpacing | Gets or sets the amount of space between the thumbnail area and the caption. (Inherited from ThumbnailView.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ScrollableControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | DisplayText | Tells the thumbview which attribute to display (Inherited from ThumbnailView.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DragDistanceTrigger | Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DragDropMode | Gets or sets the drag and drop mode used when AutoDragDrop is true. (Inherited from ThumbnailView.)
Public property | DragSelectionColor | Gets or sets the color of the outline drawn during a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DropPositionIndicator | Gets or sets the style of drag drop insert indicator used by the ThumbnailView. (Inherited from ThumbnailView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableMouseWheel | Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events. (Inherited from ThumbnailView.)
Public property | ErrorImage | Gets or sets the image displayed when there is an error reading a file. (Inherited from ThumbnailView.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | FocusedItem | Gets the Thumbnail item that currently has focus. (Inherited from ThumbnailView.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GrabFocusOnMouseEnter | Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area. (Inherited from ThumbnailView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundColor | Gets or sets the color used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightBrush | Gets or sets the brush used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightTextColor | Gets or sets the caption text color used when an item is selected. (Inherited from ThumbnailView.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HoverItem | Gets the Thumbnail the mouse is currently hovering over. (Inherited from ThumbnailView.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating if the control has been disposed. (Inherited from ThumbnailView.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a reference to the ThumbnailCollection for this control. (Inherited from ThumbnailView.)
Public property | LabelEdit | Gets or sets a value indicating if the text below the thumbnail can be modified by the user. (Inherited from ThumbnailView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LoadErrorMessage | Gets or sets the error message that will be displayed when there is an error loading images. (Inherited from ThumbnailView.)
Public property | LoadMethod | Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Margins | Gets or sets the margins used for the control. (Inherited from ThumbnailView.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxWorkerThreads | Gets or sets the number of worker threads that will be active at a single time in the thread pool. (Inherited from ThumbnailView.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Obsolete. Gets or sets a value indicating whether multiple thumbnails can be selected at once. (Inherited from ThumbnailView.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PlaceholderImage | Gets or sets an image used as a placeholder before the thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | PlaceholderMessage | Gets or sets the message displayed as a placeholder for thumbnails. (Inherited from ThumbnailView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndices | Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control. (Inherited from ThumbnailView.)
Public property | SelectedItems | Gets a ThumbnailCollection containing the currently selected thumbnails. (Inherited from ThumbnailView.)
Public property | SelectedItemsOrder | Gets or sets the ordering used for the SelectedItems collection. (Inherited from ThumbnailView.)
Public property | SelectedItemStyle | Gets or sets the style used when rendering the highlight for selected items. (Inherited from ThumbnailView.)
Public property | SelectionMode | Gets or sets the selection mode used to select the thumbnails. (Inherited from ThumbnailView.)
Public property | SelectionRectangleBackColor | Gets or sets the background color used for the selection rectangle. (Inherited from ThumbnailView.)
Public property | SelectionRectangleDashStyle | Gets or sets the selection rectangle line style. (Inherited from ThumbnailView.)
Public property | SelectionRectangleLineColor | Gets or sets the line color used for the selection rectangle. (Inherited from ThumbnailView.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SortBy | Gets or sets the ThumbViewAttribute used to sort the thumbnails. (Inherited from ThumbnailView.)
Public property | SortOrder | Gets or sets the sort order of the thumbnails. (Inherited from ThumbnailView.)
Public property | Spacing | Gets or sets the amount of spacing between the thumbnails. (Inherited from ThumbnailView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ThumbnailBackground | Gets or sets the background image used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailLayout | Gets or sets the layout used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailOffset | Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area. (Inherited from ThumbnailView.)
Public property | ThumbnailSize | Gets or sets the size of the thumbnails in pixels. (Inherited from ThumbnailView.)
Public property | ToolTipControl | Gets or sets the ToolTip control used to display tooltips for the thumbnails. (Inherited from ThumbnailView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets the index of the first thumbnail in the visible area of the control. (Inherited from ThumbnailView.)
Public property | TopItem | Gets the Thumbnail displayed at the top of the control. (Inherited from ThumbnailView.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddAfterDragDrop | (Overrides ThumbnailViewAddAfterDragDrop(Thumbnail, Boolean, Boolean).)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelection | This method will unselect any selected thumbnails in the control. (Inherited from ThumbnailView.)
Public method | Compare | Compares two Thumbnail objects. (Inherited from ThumbnailView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the ThumbnailView and releases any resources back to the system. (Inherited from ThumbnailView.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from ThumbnailView.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDropIndex | Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates. (Inherited from ThumbnailView.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexAt | Returns the thumbnail index value from the specified client position. (Inherited from ThumbnailView.)
Public method | GetItemAt | Gets the Thumbnail located at specific x, y coordinates. (Inherited from ThumbnailView.)
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index. (Inherited from ThumbnailView.)
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided. (Inherited from ThumbnailView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaltSorting | Use this method to temporarily keep the ThumbnailCollection from sorting items. (Inherited from ThumbnailView.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | This method is used to allow input from special keys. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | MakeThumbnailDragDropOperation | (Overrides ThumbnailViewMakeThumbnailDragDropOperation(ThumbnailView, Thumbnail, DragDropMode, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterLabelEdit | Called after the thumbnail caption has been modified by the user. (Inherited from ThumbnailView.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeLabelEdit | Called when the user is trying to modifiy the thumbnail caption. (Inherited from ThumbnailView.)
Protected method | OnBeforeThumbnailLoad | Called just before a thumbnail image is created. (Inherited from ThumbnailView.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a click event has occurred. (Inherited from ThumbnailView.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollectionChanged | Called when there has been a change in the ThumbnailCollection. (Inherited from ThumbnailView.)
Protected method | OnCompare | Called when two thumbnails need to be compared. (Inherited from ThumbnailView.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataChanged | Called when a DataRow has changed in the data source. (Inherited from ThumbnailView.)
Protected method | OnDataMemberChanged | Called when a data member has changed. (Inherited from ThumbnailView.)
Protected method | OnDataSourceChanged | Called when the data source has changed. (Inherited from ThumbnailView.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Called when the user double-clicks the control. (Inherited from ThumbnailView.)
Protected method | OnDragDrop | Called when a drag drop operation has completed. (Inherited from ThumbnailView.)
Protected method | OnDragEnter | Called when a DragEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragLeave | Called when a DragLeave event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragOver | Called when a DragOver event has occurred. (Inherited from ThumbnailView.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnEraseDropPositionIndicator | Called when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Protected method | OnFontChanged | Called when the Font property has changed. (Inherited from ThumbnailView.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the handle of the control is created. (Inherited from ThumbnailView.)
Protected method | OnHandleDestroyed | Called when the control handle is destroyed. (Inherited from ThumbnailView.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHoverItemChanged | Called when the HoverItem property has changed. (Inherited from ThumbnailView.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Called when a drag drop operation has started. (Inherited from ThumbnailView.)
Protected method | OnKeyDown | Called when a KeyDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Called when a KeyUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLayout | Called when a layout event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Called when the control has lost focus. (Inherited from ThumbnailView.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a MouseDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseEnter | Called when a MouseEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a MouseMove event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseUp | Called when a MouseUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Called when the control needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnPaintDropPositionIndicator | Called when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintThumbnail | Called when a Thumbnail needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedIndexChanged | Called when the selected index has changed. (Inherited from ThumbnailView.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailActivate | Called when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Protected method | OnThumbnailCreated | Called when a thumbnail image has been created. (Inherited from ThumbnailView.)
Protected method | OnThumbnailSizeChanged | Called when the ThumbnailSize property is changed. (Inherited from ThumbnailView.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveAfterDragDrop | (Overrides ThumbnailViewRemoveAfterDragDrop(ThumbnailDragDropOperation).)
Protected method | RemoveOverride | (Overrides ThumbnailViewRemoveOverride(ThumbnailDragDropOperation).)
Protected method | ReorderAfterDragDrop | (Overrides ThumbnailViewReorderAfterDragDrop(Thumbnail, Int32, Boolean, Boolean).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSorting | Resumes any sorting of the thumbnails. (Inherited from ThumbnailView.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row. (Inherited from ThumbnailView.)
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control. (Inherited from ThumbnailView.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all of the thumbnails in the control. (Inherited from ThumbnailView.)
Public method | SelectFromBounds | This method will select thumbnails that intersect the rectangle provided. (Inherited from ThumbnailView.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataBinding | Sets up data binding for the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Use this method to force the ThumbnailCollection to sort. (Inherited from ThumbnailView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ThumbnailView.)
Top
Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ThumbnailView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ThumbnailView.)
Public event | BeforeThumbnailLoad | Raised just before a thumbnail image is going to be created. (Inherited from ThumbnailView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CompareThumbnails | Occurs when the thumbnail items need to be sorted. (Inherited from ThumbnailView.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | EraseDropPositionIndicator | Raised when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoverItemChanged | Raised when the HoverItem has changed. (Inherited from ThumbnailView.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from ThumbnailView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintDropPositionIndicator | Raised when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Public event | PaintThumbnail | Occurs when a thumbnail needs to be painted. (Inherited from ThumbnailView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | SelectedIndexChanged | Occurs when the selected thumbnail index changes. (Inherited from ThumbnailView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThumbnailActivate | Raised when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Public event | ThumbnailClicked | Raised when a thumbnail is clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailCollectionChanged | Raised when the thumbnail collection has changed from an add, insert, remove or clear action. (Inherited from ThumbnailView.)
Public event | ThumbnailCreated | Raised when a thumbnail has been created. (Inherited from ThumbnailView.)
Public event | ThumbnailDoubleClicked | Raised when a thumbnail is double-clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailDrop | Occurs when the user has dropped an item onto the control. (Inherited from ThumbnailView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Public field | Parent |
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView Constructor

Initializes a new instance of the DocumentViewerThumbnailView class

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentViewerThumbnailView()
Public Sub New
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView Properties

The DocumentViewerThumbnailView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the method required by to user to activate a thumbnail. (Inherited from ThumbnailView.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowKeyAction | Gets or sets the action taken when the ThumbnailView receives an arrow key press event. (Inherited from ThumbnailView.)
Public property | Asynchronous | Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously. (Inherited from ThumbnailView.)
Public property | AutoDragDrop | Gets or sets a value indicating whether the internal drag and drop code is used. (Inherited from ThumbnailView.)
Public property | AutoScroll | (Inherited from ThumbnailView.)
Public property | AutoScrollMargin | (Inherited from ThumbnailView.)
Public property | AutoScrollMinSize | (Inherited from ThumbnailView.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFormat | Gets the StringFormat used for rendering the thumbnail captions. (Inherited from ThumbnailView.)
Public property | CaptionLines | Gets or sets the number of text lines to allocate for the caption area. (Inherited from ThumbnailView.)
Public property | CaptionSpacing | Gets or sets the amount of space between the thumbnail area and the caption. (Inherited from ThumbnailView.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ScrollableControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | DisplayText | Tells the thumbview which attribute to display (Inherited from ThumbnailView.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DragDistanceTrigger | Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DragDropMode | Gets or sets the drag and drop mode used when AutoDragDrop is true. (Inherited from ThumbnailView.)
Public property | DragSelectionColor | Gets or sets the color of the outline drawn during a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DropPositionIndicator | Gets or sets the style of drag drop insert indicator used by the ThumbnailView. (Inherited from ThumbnailView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableMouseWheel | Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events. (Inherited from ThumbnailView.)
Public property | ErrorImage | Gets or sets the image displayed when there is an error reading a file. (Inherited from ThumbnailView.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | FocusedItem | Gets the Thumbnail item that currently has focus. (Inherited from ThumbnailView.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GrabFocusOnMouseEnter | Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area. (Inherited from ThumbnailView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundColor | Gets or sets the color used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightBrush | Gets or sets the brush used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightTextColor | Gets or sets the caption text color used when an item is selected. (Inherited from ThumbnailView.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HoverItem | Gets the Thumbnail the mouse is currently hovering over. (Inherited from ThumbnailView.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating if the control has been disposed. (Inherited from ThumbnailView.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a reference to the ThumbnailCollection for this control. (Inherited from ThumbnailView.)
Public property | LabelEdit | Gets or sets a value indicating if the text below the thumbnail can be modified by the user. (Inherited from ThumbnailView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LoadErrorMessage | Gets or sets the error message that will be displayed when there is an error loading images. (Inherited from ThumbnailView.)
Public property | LoadMethod | Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Margins | Gets or sets the margins used for the control. (Inherited from ThumbnailView.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxWorkerThreads | Gets or sets the number of worker threads that will be active at a single time in the thread pool. (Inherited from ThumbnailView.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Obsolete. Gets or sets a value indicating whether multiple thumbnails can be selected at once. (Inherited from ThumbnailView.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PlaceholderImage | Gets or sets an image used as a placeholder before the thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | PlaceholderMessage | Gets or sets the message displayed as a placeholder for thumbnails. (Inherited from ThumbnailView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndices | Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control. (Inherited from ThumbnailView.)
Public property | SelectedItems | Gets a ThumbnailCollection containing the currently selected thumbnails. (Inherited from ThumbnailView.)
Public property | SelectedItemsOrder | Gets or sets the ordering used for the SelectedItems collection. (Inherited from ThumbnailView.)
Public property | SelectedItemStyle | Gets or sets the style used when rendering the highlight for selected items. (Inherited from ThumbnailView.)
Public property | SelectionMode | Gets or sets the selection mode used to select the thumbnails. (Inherited from ThumbnailView.)
Public property | SelectionRectangleBackColor | Gets or sets the background color used for the selection rectangle. (Inherited from ThumbnailView.)
Public property | SelectionRectangleDashStyle | Gets or sets the selection rectangle line style. (Inherited from ThumbnailView.)
Public property | SelectionRectangleLineColor | Gets or sets the line color used for the selection rectangle. (Inherited from ThumbnailView.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SortBy | Gets or sets the ThumbViewAttribute used to sort the thumbnails. (Inherited from ThumbnailView.)
Public property | SortOrder | Gets or sets the sort order of the thumbnails. (Inherited from ThumbnailView.)
Public property | Spacing | Gets or sets the amount of spacing between the thumbnails. (Inherited from ThumbnailView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ThumbnailBackground | Gets or sets the background image used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailLayout | Gets or sets the layout used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailOffset | Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area. (Inherited from ThumbnailView.)
Public property | ThumbnailSize | Gets or sets the size of the thumbnails in pixels. (Inherited from ThumbnailView.)
Public property | ToolTipControl | Gets or sets the ToolTip control used to display tooltips for the thumbnails. (Inherited from ThumbnailView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets the index of the first thumbnail in the visible area of the control. (Inherited from ThumbnailView.)
Public property | TopItem | Gets the Thumbnail displayed at the top of the control. (Inherited from ThumbnailView.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView Methods

The DocumentViewerThumbnailView type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddAfterDragDrop | (Overrides ThumbnailViewAddAfterDragDrop(Thumbnail, Boolean, Boolean).)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelection | This method will unselect any selected thumbnails in the control. (Inherited from ThumbnailView.)
Public method | Compare | Compares two Thumbnail objects. (Inherited from ThumbnailView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the ThumbnailView and releases any resources back to the system. (Inherited from ThumbnailView.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from ThumbnailView.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDropIndex | Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates. (Inherited from ThumbnailView.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexAt | Returns the thumbnail index value from the specified client position. (Inherited from ThumbnailView.)
Public method | GetItemAt | Gets the Thumbnail located at specific x, y coordinates. (Inherited from ThumbnailView.)
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index. (Inherited from ThumbnailView.)
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided. (Inherited from ThumbnailView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaltSorting | Use this method to temporarily keep the ThumbnailCollection from sorting items. (Inherited from ThumbnailView.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | This method is used to allow input from special keys. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | MakeThumbnailDragDropOperation | (Overrides ThumbnailViewMakeThumbnailDragDropOperation(ThumbnailView, Thumbnail, DragDropMode, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterLabelEdit | Called after the thumbnail caption has been modified by the user. (Inherited from ThumbnailView.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeLabelEdit | Called when the user is trying to modifiy the thumbnail caption. (Inherited from ThumbnailView.)
Protected method | OnBeforeThumbnailLoad | Called just before a thumbnail image is created. (Inherited from ThumbnailView.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a click event has occurred. (Inherited from ThumbnailView.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollectionChanged | Called when there has been a change in the ThumbnailCollection. (Inherited from ThumbnailView.)
Protected method | OnCompare | Called when two thumbnails need to be compared. (Inherited from ThumbnailView.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataChanged | Called when a DataRow has changed in the data source. (Inherited from ThumbnailView.)
Protected method | OnDataMemberChanged | Called when a data member has changed. (Inherited from ThumbnailView.)
Protected method | OnDataSourceChanged | Called when the data source has changed. (Inherited from ThumbnailView.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Called when the user double-clicks the control. (Inherited from ThumbnailView.)
Protected method | OnDragDrop | Called when a drag drop operation has completed. (Inherited from ThumbnailView.)
Protected method | OnDragEnter | Called when a DragEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragLeave | Called when a DragLeave event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragOver | Called when a DragOver event has occurred. (Inherited from ThumbnailView.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnEraseDropPositionIndicator | Called when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Protected method | OnFontChanged | Called when the Font property has changed. (Inherited from ThumbnailView.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the handle of the control is created. (Inherited from ThumbnailView.)
Protected method | OnHandleDestroyed | Called when the control handle is destroyed. (Inherited from ThumbnailView.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHoverItemChanged | Called when the HoverItem property has changed. (Inherited from ThumbnailView.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Called when a drag drop operation has started. (Inherited from ThumbnailView.)
Protected method | OnKeyDown | Called when a KeyDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Called when a KeyUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLayout | Called when a layout event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Called when the control has lost focus. (Inherited from ThumbnailView.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a MouseDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseEnter | Called when a MouseEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a MouseMove event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseUp | Called when a MouseUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Called when the control needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnPaintDropPositionIndicator | Called when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintThumbnail | Called when a Thumbnail needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedIndexChanged | Called when the selected index has changed. (Inherited from ThumbnailView.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailActivate | Called when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Protected method | OnThumbnailCreated | Called when a thumbnail image has been created. (Inherited from ThumbnailView.)
Protected method | OnThumbnailSizeChanged | Called when the ThumbnailSize property is changed. (Inherited from ThumbnailView.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveAfterDragDrop | (Overrides ThumbnailViewRemoveAfterDragDrop(ThumbnailDragDropOperation).)
Protected method | RemoveOverride | (Overrides ThumbnailViewRemoveOverride(ThumbnailDragDropOperation).)
Protected method | ReorderAfterDragDrop | (Overrides ThumbnailViewReorderAfterDragDrop(Thumbnail, Int32, Boolean, Boolean).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSorting | Resumes any sorting of the thumbnails. (Inherited from ThumbnailView.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row. (Inherited from ThumbnailView.)
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control. (Inherited from ThumbnailView.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all of the thumbnails in the control. (Inherited from ThumbnailView.)
Public method | SelectFromBounds | This method will select thumbnails that intersect the rectangle provided. (Inherited from ThumbnailView.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataBinding | Sets up data binding for the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Use this method to force the ThumbnailCollection to sort. (Inherited from ThumbnailView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ThumbnailView.)
Top
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView.AddAfterDragDrop Method

DocumentViewerThumbnailViewAddAfterDragDrop Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void AddAfterDragDrop(
    Thumbnail tn,
    bool clone,
    bool cached
)
Protected Overrides Sub AddAfterDragDrop (
    tn As Thumbnail,
    clone As Boolean,
    cached As Boolean
)

Parameters

tn
Type: Atalasoft.Imaging.WinControlsThumbnail
clone
Type: SystemBoolean
cached
Type: SystemBoolean
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView.MakeThumbnailDragDropOperation Method

DocumentViewerThumbnailViewMakeThumbnailDragDropOperation Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override ThumbnailDragDropOperation MakeThumbnailDragDropOperation(
    ThumbnailView tv,
    Thumbnail[] thumbs,
    DragDropMode mode,
    int[] dragDropIndexes
)
Protected Overrides Function MakeThumbnailDragDropOperation (
    tv As ThumbnailView,
    thumbs As Thumbnail(),
    mode As DragDropMode,
    dragDropIndexes As Integer()
) As ThumbnailDragDropOperation

Parameters

tv
Type: Atalasoft.Imaging.WinControlsThumbnailView
thumbs
Type: Atalasoft.Imaging.WinControlsThumbnail
mode
Type: Atalasoft.Imaging.WinControlsDragDropMode
dragDropIndexes
Type: SystemInt32

Return Value

Type: ThumbnailDragDropOperation
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView.RemoveAfterDragDrop Method

DocumentViewerThumbnailViewRemoveAfterDragDrop Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RemoveAfterDragDrop(
    ThumbnailDragDropOperation data
)
Protected Overrides Sub RemoveAfterDragDrop (
    data As ThumbnailDragDropOperation
)

Parameters

data
Type: Atalasoft.Imaging.WinControlsThumbnailDragDropOperation
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView.RemoveOverride Method

DocumentViewerThumbnailViewRemoveOverride Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RemoveOverride(
    ThumbnailDragDropOperation data
)
Protected Overrides Sub RemoveOverride (
    data As ThumbnailDragDropOperation
)

Parameters

data
Type: Atalasoft.Imaging.WinControlsThumbnailDragDropOperation
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView.ReorderAfterDragDrop Method

DocumentViewerThumbnailViewReorderAfterDragDrop Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ReorderAfterDragDrop(
    Thumbnail tn,
    int index,
    bool clone,
    bool cached
)
Protected Overrides Sub ReorderAfterDragDrop (
    tn As Thumbnail,
    index As Integer,
    clone As Boolean,
    cached As Boolean
)

Parameters

tn
Type: Atalasoft.Imaging.WinControlsThumbnail
index
Type: SystemInt32
clone
Type: SystemBoolean
cached
Type: SystemBoolean
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView Events

The DocumentViewerThumbnailView type exposes the following members.

Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ThumbnailView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ThumbnailView.)
Public event | BeforeThumbnailLoad | Raised just before a thumbnail image is going to be created. (Inherited from ThumbnailView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CompareThumbnails | Occurs when the thumbnail items need to be sorted. (Inherited from ThumbnailView.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | EraseDropPositionIndicator | Raised when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoverItemChanged | Raised when the HoverItem has changed. (Inherited from ThumbnailView.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from ThumbnailView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintDropPositionIndicator | Raised when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Public event | PaintThumbnail | Occurs when a thumbnail needs to be painted. (Inherited from ThumbnailView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | SelectedIndexChanged | Occurs when the selected thumbnail index changes. (Inherited from ThumbnailView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThumbnailActivate | Raised when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Public event | ThumbnailClicked | Raised when a thumbnail is clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailCollectionChanged | Raised when the thumbnail collection has changed from an add, insert, remove or clear action. (Inherited from ThumbnailView.)
Public event | ThumbnailCreated | Raised when a thumbnail has been created. (Inherited from ThumbnailView.)
Public event | ThumbnailDoubleClicked | Raised when a thumbnail is double-clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailDrop | Occurs when the user has dropped an item onto the control. (Inherited from ThumbnailView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView Fields

The DocumentViewerThumbnailView type exposes the following members.

Fields
 | Name | Description
Public field | Parent |
Top
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DocumentViewerThumbnailView.Parent Field

DocumentViewerThumbnailViewParent Field

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentViewer Parent
Public Parent As DocumentViewer

Field Value

Type: DocumentViewer
See Also

Reference

DocumentViewerThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


DragDropMode Enumeration

This enumeration dictates the type of drag and drop operation to perform. If the source control is the same one that the thumbnails are being dropped onto, these values are ignored and the thumbnails are simply reordered.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DragDropMode
Public Enumeration DragDropMode
Members
Member name | Description
Move | The thumbnails will be removed from the previous ThumbnailView and moved to the control they were dropped on.
Copy | A copy of the thumbnails are added to the destination control, leaving the original thumbnails in the source control.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Class

A elliptical rubberband that can be positioned with the mouse on a viewport control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.Imaging.WinControlsRubberband
Atalasoft.Imaging.WinControlsEllipseRubberband

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EllipseRubberband : Rubberband
Public Class EllipseRubberband
    Inherits Rubberband

The EllipseRubberband type exposes the following members.

Constructors
 | Name | Description
Public method | EllipseRubberband | Creates a new instance of EllipseRubberband.
Public method | EllipseRubberband(Viewport) | Creates a new instance of EllipseRubberband specifying the parent Viewport.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Fill | Gets or sets a Fill that is used to fill the inside of the ellipse.
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Inherited from Rubberband.)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns the elliptical region occupied by this rubberband. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Inherited from Rubberband.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event. (Inherited from Rubberband.)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event. (Inherited from Rubberband.)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
Remarks

This object is used to select an elliptical region in an image for cropping, zooming, and applying a command on a rectangular region as well as drawing ellipses onto an image.

Can be used as a component in the toolbox or instantiated directly.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Constructor

Overload List
 | Name | Description
Public method | EllipseRubberband | Creates a new instance of EllipseRubberband.
Public method | EllipseRubberband(Viewport) | Creates a new instance of EllipseRubberband specifying the parent Viewport.
Top
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Constructor

Creates a new instance of EllipseRubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseRubberband()
Public Sub New
Remarks
Initializes a new instance of EllipseRubberband specifying the parent viewport.
See Also

Reference

EllipseRubberband Class
EllipseRubberband Overload
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Constructor (Viewport)

Creates a new instance of EllipseRubberband specifying the parent Viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseRubberband(
    Viewport parent
)
Public Sub New (
    parent As Viewport
)

Parameters

parent
Type: Atalasoft.Imaging.WinControlsViewport
The parent Viewport for this object.
See Also

Reference

EllipseRubberband Class
EllipseRubberband Overload
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Properties

The EllipseRubberband type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Fill | Gets or sets a Fill that is used to fill the inside of the ellipse.
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband.Fill Property

EllipseRubberbandFill Property

Gets or sets a Fill that is used to fill the inside of the ellipse.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Fill Fill { get; set; }
Public Property Fill As Fill
    Get
    Set

Property Value

Type: Fill
A Fill that is used to fill the inside of the ellipse.
Remarks
When this value is null, the ellipse is unfilled.
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Methods

The EllipseRubberband type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Inherited from Rubberband.)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns the elliptical region occupied by this rubberband. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Inherited from Rubberband.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event. (Inherited from Rubberband.)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event. (Inherited from Rubberband.)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband.GetRegion Method

EllipseRubberbandGetRegion Method

Returns the elliptical region occupied by this rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Region GetRegion()
Public Overrides Function GetRegion As Region

Return Value

Type: Region
The region of this rubberband.
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband.OnDrawRubberband Method

EllipseRubberbandOnDrawRubberband Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDrawRubberband(
    Canvas canvas,
    AtalaPen pen
)
Protected Overrides Sub OnDrawRubberband (
    canvas As Canvas,
    pen As AtalaPen
)

Parameters

canvas
Type: Atalasoft.Imaging.DrawingCanvas
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


EllipseRubberband Events

The EllipseRubberband type exposes the following members.

Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
See Also

Reference

EllipseRubberband Class
Atalasoft.Imaging.WinControls Namespace


FileDialogView Enumeration

This enumeration is used to set the initial view state of the OpenImageFileDialog.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FileDialogView
Public Enumeration FileDialogView
Members
Member name | Description
Icons | Icons are displayed.
List | A list of files are displayed.
Details | A list of files are displayed with details.
Thumbnails | Thumbnails are displayed.
Tiles | Tile images are displayed.
Remarks
Use these values when setting the View property.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView Class

A thumbnail list control designed to display thumbnails of images from a directory.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
Atalasoft.Imaging.WinControlsThumbnailView
Atalasoft.Imaging.WinControlsFolderThumbnailView

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FolderThumbnailView : ThumbnailView
Public Class FolderThumbnailView
    Inherits ThumbnailView

The FolderThumbnailView type exposes the following members.

Constructors
 | Name | Description
Public method | FolderThumbnailView | Initializes a new instance of FolderThumbnailView.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the method required by to user to activate a thumbnail. (Inherited from ThumbnailView.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowKeyAction | Gets or sets the action taken when the ThumbnailView receives an arrow key press event. (Inherited from ThumbnailView.)
Public property | Asynchronous | Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously. (Inherited from ThumbnailView.)
Public property | AutoDragDrop | Gets or sets a value indicating whether the internal drag and drop code is used. (Inherited from ThumbnailView.)
Public property | AutoScroll | (Inherited from ThumbnailView.)
Public property | AutoScrollMargin | (Inherited from ThumbnailView.)
Public property | AutoScrollMinSize | (Inherited from ThumbnailView.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFormat | Gets the StringFormat used for rendering the thumbnail captions. (Inherited from ThumbnailView.)
Public property | CaptionLines | Gets or sets the number of text lines to allocate for the caption area. (Inherited from ThumbnailView.)
Public property | CaptionSpacing | Gets or sets the amount of space between the thumbnail area and the caption. (Inherited from ThumbnailView.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ScrollableControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | DisplayText | Tells the thumbview which attribute to display (Inherited from ThumbnailView.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DragDistanceTrigger | Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DragDropMode | Gets or sets the drag and drop mode used when AutoDragDrop is true. (Inherited from ThumbnailView.)
Public property | DragSelectionColor | Gets or sets the color of the outline drawn during a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DropPositionIndicator | Gets or sets the style of drag drop insert indicator used by the ThumbnailView. (Inherited from ThumbnailView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableMouseWheel | Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events. (Inherited from ThumbnailView.)
Public property | ErrorImage | Gets or sets the image displayed when there is an error reading a file. (Inherited from ThumbnailView.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExtensionFilter | Gets or sets the a string representing the file extensions that will be recognized as thumbnails in the FolderThumbnailView control.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | FocusedItem | Gets the Thumbnail item that currently has focus. (Inherited from ThumbnailView.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GrabFocusOnMouseEnter | Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area. (Inherited from ThumbnailView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundColor | Gets or sets the color used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightBrush | Gets or sets the brush used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightTextColor | Gets or sets the caption text color used when an item is selected. (Inherited from ThumbnailView.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HoverItem | Gets the Thumbnail the mouse is currently hovering over. (Inherited from ThumbnailView.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageFolder | Gets or sets the path of the images that are loaded into the FolderThumbnailView control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating if the control has been disposed. (Inherited from ThumbnailView.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a reference to the ThumbnailCollection for this control. (Inherited from ThumbnailView.)
Public property | LabelEdit | Gets or sets a value indicating if the text below the thumbnail can be modified by the user. (Inherited from ThumbnailView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LoadErrorMessage | Gets or sets the error message that will be displayed when there is an error loading images. (Inherited from ThumbnailView.)
Public property | LoadMethod | Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Margins | Gets or sets the margins used for the control. (Inherited from ThumbnailView.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxWorkerThreads | Gets or sets the number of worker threads that will be active at a single time in the thread pool. (Inherited from ThumbnailView.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Obsolete. Gets or sets a value indicating whether multiple thumbnails can be selected at once. (Inherited from ThumbnailView.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NumFolderImages | Returns the number of images in the current folder defined in the ImageFolder property.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PlaceholderImage | Gets or sets an image used as a placeholder before the thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | PlaceholderMessage | Gets or sets the message displayed as a placeholder for thumbnails. (Inherited from ThumbnailView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndices | Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control. (Inherited from ThumbnailView.)
Public property | SelectedItems | Gets a ThumbnailCollection containing the currently selected thumbnails. (Inherited from ThumbnailView.)
Public property | SelectedItemsOrder | Gets or sets the ordering used for the SelectedItems collection. (Inherited from ThumbnailView.)
Public property | SelectedItemStyle | Gets or sets the style used when rendering the highlight for selected items. (Inherited from ThumbnailView.)
Public property | SelectionMode | Gets or sets the selection mode used to select the thumbnails. (Inherited from ThumbnailView.)
Public property | SelectionRectangleBackColor | Gets or sets the background color used for the selection rectangle. (Inherited from ThumbnailView.)
Public property | SelectionRectangleDashStyle | Gets or sets the selection rectangle line style. (Inherited from ThumbnailView.)
Public property | SelectionRectangleLineColor | Gets or sets the line color used for the selection rectangle. (Inherited from ThumbnailView.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SortBy | Gets or sets the ThumbViewAttribute used to sort the thumbnails. (Inherited from ThumbnailView.)
Public property | SortOrder | Gets or sets the sort order of the thumbnails. (Inherited from ThumbnailView.)
Public property | Spacing | Gets or sets the amount of spacing between the thumbnails. (Inherited from ThumbnailView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ThumbnailBackground | Gets or sets the background image used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailLayout | Gets or sets the layout used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailOffset | Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area. (Inherited from ThumbnailView.)
Public property | ThumbnailSize | Gets or sets the size of the thumbnails in pixels. (Inherited from ThumbnailView.)
Public property | ToolTipControl | Gets or sets the ToolTip control used to display tooltips for the thumbnails. (Inherited from ThumbnailView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets the index of the first thumbnail in the visible area of the control. (Inherited from ThumbnailView.)
Public property | TopItem | Gets the Thumbnail displayed at the top of the control. (Inherited from ThumbnailView.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddAfterDragDrop | Override to change the way a thumbnail is added to an empty control, if you are using the ThumbnailView in a composite control (Inherited from ThumbnailView.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelection | This method will unselect any selected thumbnails in the control. (Inherited from ThumbnailView.)
Public method | Compare | Compares two Thumbnail objects. (Inherited from ThumbnailView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the control. (Overrides ThumbnailViewDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ThumbnailViewFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDropIndex | Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates. (Inherited from ThumbnailView.)
Public method | GetFolderImageCount | Returns the number of images in the specified path that pass the file extension filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexAt | Returns the thumbnail index value from the specified client position. (Inherited from ThumbnailView.)
Public method | GetItemAt | Gets the Thumbnail located at specific x, y coordinates. (Inherited from ThumbnailView.)
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index. (Inherited from ThumbnailView.)
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided. (Inherited from ThumbnailView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaltSorting | Use this method to temporarily keep the ThumbnailCollection from sorting items. (Inherited from ThumbnailView.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | This method is used to allow input from special keys. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | MakeThumbnailDragDropOperation | (Inherited from ThumbnailView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterLabelEdit | Called after the thumbnail caption has been modified by the user. (Inherited from ThumbnailView.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeLabelEdit | Called when the user is trying to modifiy the thumbnail caption. (Inherited from ThumbnailView.)
Protected method | OnBeforeThumbnailLoad | Called just before a thumbnail image is created. (Inherited from ThumbnailView.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a click event has occurred. (Inherited from ThumbnailView.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollectionChanged | (Overrides ThumbnailViewOnCollectionChanged(CollectionChangedEventArgs).)
Protected method | OnCompare | Called when two thumbnails need to be compared. (Inherited from ThumbnailView.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataChanged | Called when a DataRow has changed in the data source. (Inherited from ThumbnailView.)
Protected method | OnDataMemberChanged | Called when a data member has changed. (Inherited from ThumbnailView.)
Protected method | OnDataSourceChanged | Called when the data source has changed. (Inherited from ThumbnailView.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Called when the user double-clicks the control. (Inherited from ThumbnailView.)
Protected method | OnDragDrop | Called when a drag drop operation has completed. (Inherited from ThumbnailView.)
Protected method | OnDragEnter | Called when a DragEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragLeave | Called when a DragLeave event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragOver | Called when a DragOver event has occurred. (Inherited from ThumbnailView.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnEraseDropPositionIndicator | Called when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Protected method | OnFontChanged | Called when the Font property has changed. (Inherited from ThumbnailView.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the handle of the control is created. (Inherited from ThumbnailView.)
Protected method | OnHandleDestroyed | Called when the control handle is destroyed. (Inherited from ThumbnailView.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHoverItemChanged | Called when the HoverItem property has changed. (Inherited from ThumbnailView.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Called when a drag drop operation has started. (Inherited from ThumbnailView.)
Protected method | OnKeyDown | Called when a KeyDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Called when a KeyUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLayout | Called when a layout event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Called when the control has lost focus. (Inherited from ThumbnailView.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a MouseDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseEnter | Called when a MouseEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a MouseMove event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseUp | Called when a MouseUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Called when the control needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnPaintDropPositionIndicator | Called when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintThumbnail | Called when a Thumbnail needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedIndexChanged | Called when the selected index has changed. (Inherited from ThumbnailView.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailActivate | Called when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Protected method | OnThumbnailCreated | (Overrides ThumbnailViewOnThumbnailCreated(ThumbnailEventArgs).)
Protected method | OnThumbnailSizeChanged | (Overrides ThumbnailViewOnThumbnailSizeChanged.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshThumbnails | Obsolete. This method will force the items in the FolderThumbnailView to reload. This is the same as calling the Reload method on Items.
Protected method | RemoveAfterDragDrop | Override to change the way a thumbnail is removed after a drag drop, if you are using the ThumbnailView in a composite control (Inherited from ThumbnailView.)
Protected method | RemoveOverride | (Inherited from ThumbnailView.)
Protected method | ReorderAfterDragDrop | Override to change the way a thumbnail is reordered after a drag drop, if you are using the ThumbnailView in a composite control (Inherited from ThumbnailView.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSorting | Resumes any sorting of the thumbnails. (Inherited from ThumbnailView.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row. (Inherited from ThumbnailView.)
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control. (Inherited from ThumbnailView.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all of the thumbnails in the control. (Inherited from ThumbnailView.)
Public method | SelectFromBounds | This method will select thumbnails that intersect the rectangle provided. (Inherited from ThumbnailView.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataBinding | Sets up data binding for the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Use this method to force the ThumbnailCollection to sort. (Inherited from ThumbnailView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ThumbnailView.)
Top
Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ThumbnailView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ThumbnailView.)
Public event | BeforeThumbnailLoad | Raised just before a thumbnail image is going to be created. (Inherited from ThumbnailView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CompareThumbnails | Occurs when the thumbnail items need to be sorted. (Inherited from ThumbnailView.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | EraseDropPositionIndicator | Raised when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Public event | FolderLoadCompleted | Occurs after a folder load completes.
Public event | FolderLoadProgress | Occurs after each thumbnail is loaded during a folder load.
Public event | FolderLoadStarted | Occurs when thumbnails are about to be loaded from a folder.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoverItemChanged | Raised when the HoverItem has changed. (Inherited from ThumbnailView.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from ThumbnailView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintDropPositionIndicator | Raised when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Public event | PaintThumbnail | Occurs when a thumbnail needs to be painted. (Inherited from ThumbnailView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | SelectedIndexChanged | Occurs when the selected thumbnail index changes. (Inherited from ThumbnailView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThumbnailActivate | Raised when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Public event | ThumbnailClicked | Raised when a thumbnail is clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailCollectionChanged | Raised when the thumbnail collection has changed from an add, insert, remove or clear action. (Inherited from ThumbnailView.)
Public event | ThumbnailCreated | Raised when a thumbnail has been created. (Inherited from ThumbnailView.)
Public event | ThumbnailDoubleClicked | Raised when a thumbnail is double-clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailDrop | Occurs when the user has dropped an item onto the control. (Inherited from ThumbnailView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks

The FolderThumbnailView control inherits from the ThumbnailView control and displays a list of thumbnail images obtained from a directory of images by setting the ImageFolder property. The control will load and resample each image that passes the filter criteria defined in the ExtensionFilter property to the maximum width or height specified in ThumbnailSize, while keeping the original aspect ratio.

The FolderThumbnailView is generally used a an image navigation utility, allowing all images located in a file system or network drive to be viewed as thumbnail images. When the thumbnail item is clicked, the associated page can be displayed in the associated ImageViewer, SelectedIndexChanged, ThumbnailActivate, or ThumbnailClicked event can be handled to respond to the thumbnail select or click.

This control automatically watches the file system for any changes such as adding, deleting, or renaming images. It updates the control appropriately. By default, all images are loaded Asynchronously thread pooling if Asynchronous is true. Therefore more than one images can be loading at once.

A custom background image can be displayed for each thumbnail by setting the ThumbnailBackground property. Each thumbnail image will then be overlayed onto this image. Setting the ThumbnailBackground property can enhance the visual style of the thumbnail view control.

For viewing thumbnails from an AtalaImage, such as viewing all pages in a multipage TIFF, the ThumbnailView control may be a better choice.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView Constructor

Initializes a new instance of FolderThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FolderThumbnailView()
Public Sub New
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView Properties

The FolderThumbnailView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the method required by to user to activate a thumbnail. (Inherited from ThumbnailView.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowKeyAction | Gets or sets the action taken when the ThumbnailView receives an arrow key press event. (Inherited from ThumbnailView.)
Public property | Asynchronous | Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously. (Inherited from ThumbnailView.)
Public property | AutoDragDrop | Gets or sets a value indicating whether the internal drag and drop code is used. (Inherited from ThumbnailView.)
Public property | AutoScroll | (Inherited from ThumbnailView.)
Public property | AutoScrollMargin | (Inherited from ThumbnailView.)
Public property | AutoScrollMinSize | (Inherited from ThumbnailView.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFormat | Gets the StringFormat used for rendering the thumbnail captions. (Inherited from ThumbnailView.)
Public property | CaptionLines | Gets or sets the number of text lines to allocate for the caption area. (Inherited from ThumbnailView.)
Public property | CaptionSpacing | Gets or sets the amount of space between the thumbnail area and the caption. (Inherited from ThumbnailView.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ScrollableControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | DisplayText | Tells the thumbview which attribute to display (Inherited from ThumbnailView.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DragDistanceTrigger | Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DragDropMode | Gets or sets the drag and drop mode used when AutoDragDrop is true. (Inherited from ThumbnailView.)
Public property | DragSelectionColor | Gets or sets the color of the outline drawn during a drag and drop operation. (Inherited from ThumbnailView.)
Public property | DropPositionIndicator | Gets or sets the style of drag drop insert indicator used by the ThumbnailView. (Inherited from ThumbnailView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableMouseWheel | Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events. (Inherited from ThumbnailView.)
Public property | ErrorImage | Gets or sets the image displayed when there is an error reading a file. (Inherited from ThumbnailView.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExtensionFilter | Gets or sets the a string representing the file extensions that will be recognized as thumbnails in the FolderThumbnailView control.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | FocusedItem | Gets the Thumbnail item that currently has focus. (Inherited from ThumbnailView.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GrabFocusOnMouseEnter | Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area. (Inherited from ThumbnailView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundColor | Gets or sets the color used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightBrush | Gets or sets the brush used for the highlight (selected) background. (Inherited from ThumbnailView.)
Public property | HighlightTextColor | Gets or sets the caption text color used when an item is selected. (Inherited from ThumbnailView.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HoverItem | Gets the Thumbnail the mouse is currently hovering over. (Inherited from ThumbnailView.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageFolder | Gets or sets the path of the images that are loaded into the FolderThumbnailView control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating if the control has been disposed. (Inherited from ThumbnailView.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a reference to the ThumbnailCollection for this control. (Inherited from ThumbnailView.)
Public property | LabelEdit | Gets or sets a value indicating if the text below the thumbnail can be modified by the user. (Inherited from ThumbnailView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LoadErrorMessage | Gets or sets the error message that will be displayed when there is an error loading images. (Inherited from ThumbnailView.)
Public property | LoadMethod | Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Margins | Gets or sets the margins used for the control. (Inherited from ThumbnailView.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxWorkerThreads | Gets or sets the number of worker threads that will be active at a single time in the thread pool. (Inherited from ThumbnailView.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Obsolete. Gets or sets a value indicating whether multiple thumbnails can be selected at once. (Inherited from ThumbnailView.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NumFolderImages | Returns the number of images in the current folder defined in the ImageFolder property.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PlaceholderImage | Gets or sets an image used as a placeholder before the thumbnails are loaded. (Inherited from ThumbnailView.)
Public property | PlaceholderMessage | Gets or sets the message displayed as a placeholder for thumbnails. (Inherited from ThumbnailView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndices | Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control. (Inherited from ThumbnailView.)
Public property | SelectedItems | Gets a ThumbnailCollection containing the currently selected thumbnails. (Inherited from ThumbnailView.)
Public property | SelectedItemsOrder | Gets or sets the ordering used for the SelectedItems collection. (Inherited from ThumbnailView.)
Public property | SelectedItemStyle | Gets or sets the style used when rendering the highlight for selected items. (Inherited from ThumbnailView.)
Public property | SelectionMode | Gets or sets the selection mode used to select the thumbnails. (Inherited from ThumbnailView.)
Public property | SelectionRectangleBackColor | Gets or sets the background color used for the selection rectangle. (Inherited from ThumbnailView.)
Public property | SelectionRectangleDashStyle | Gets or sets the selection rectangle line style. (Inherited from ThumbnailView.)
Public property | SelectionRectangleLineColor | Gets or sets the line color used for the selection rectangle. (Inherited from ThumbnailView.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SortBy | Gets or sets the ThumbViewAttribute used to sort the thumbnails. (Inherited from ThumbnailView.)
Public property | SortOrder | Gets or sets the sort order of the thumbnails. (Inherited from ThumbnailView.)
Public property | Spacing | Gets or sets the amount of spacing between the thumbnails. (Inherited from ThumbnailView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ThumbnailBackground | Gets or sets the background image used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailLayout | Gets or sets the layout used for the thumbnails. (Inherited from ThumbnailView.)
Public property | ThumbnailOffset | Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area. (Inherited from ThumbnailView.)
Public property | ThumbnailSize | Gets or sets the size of the thumbnails in pixels. (Inherited from ThumbnailView.)
Public property | ToolTipControl | Gets or sets the ToolTip control used to display tooltips for the thumbnails. (Inherited from ThumbnailView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets the index of the first thumbnail in the visible area of the control. (Inherited from ThumbnailView.)
Public property | TopItem | Gets the Thumbnail displayed at the top of the control. (Inherited from ThumbnailView.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.ExtensionFilter Property

FolderThumbnailViewExtensionFilter Property

Gets or sets the a string representing the file extensions that will be recognized as thumbnails in the FolderThumbnailView control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ExtensionFilter { get; set; }
Public Property ExtensionFilter As String
    Get
    Set

Property Value

Type: String
A string representing the file extensions that will be recognized as thumbnails in the FolderThumbnailView control.
Remarks

Each extension should contain a wildcard "*" and be separated by a ";". For example, the default ExtensionFilter is:

"*.png;*. tif ;*.jpg;*.pcx;*.psd;*.tga;*.wbmp;*.wmf;*.emf;*.pcd;*.gif;"

See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.ImageFolder Property

FolderThumbnailViewImageFolder Property

Gets or sets the path of the images that are loaded into the FolderThumbnailView control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageFolder { get; set; }
Public Property ImageFolder As String
    Get
    Set

Property Value

Type: String
The path of the images that are loaded into the FolderThumbnailView control.
Remarks
If thumbnails are still being loaded from a different folder when setting this property, those thumbnails will stop loading and the items cleared from the control.
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.NumFolderImages Property

FolderThumbnailViewNumFolderImages Property

Returns the number of images in the current folder defined in the ImageFolder property.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int NumFolderImages { get; }
Public ReadOnly Property NumFolderImages As Integer
    Get

Property Value

Type: Int32
The number of images in the current folder defined in the ImageFolder property.
Remarks
See GetFolderImageCount(String) to determine the number of images in a folder before setting the ImageFolder property.
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace
FolderThumbnailViewGetFolderImageCount(String)
FolderThumbnailViewImageFolder


FolderThumbnailView Methods

The FolderThumbnailView type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddAfterDragDrop | Override to change the way a thumbnail is added to an empty control, if you are using the ThumbnailView in a composite control (Inherited from ThumbnailView.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelection | This method will unselect any selected thumbnails in the control. (Inherited from ThumbnailView.)
Public method | Compare | Compares two Thumbnail objects. (Inherited from ThumbnailView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the control. (Overrides ThumbnailViewDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible. (Inherited from ThumbnailView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ThumbnailViewFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDropIndex | Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates. (Inherited from ThumbnailView.)
Public method | GetFolderImageCount | Returns the number of images in the specified path that pass the file extension filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexAt | Returns the thumbnail index value from the specified client position. (Inherited from ThumbnailView.)
Public method | GetItemAt | Gets the Thumbnail located at specific x, y coordinates. (Inherited from ThumbnailView.)
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index. (Inherited from ThumbnailView.)
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided. (Inherited from ThumbnailView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaltSorting | Use this method to temporarily keep the ThumbnailCollection from sorting items. (Inherited from ThumbnailView.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | This method is used to allow input from special keys. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | MakeThumbnailDragDropOperation | (Inherited from ThumbnailView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterLabelEdit | Called after the thumbnail caption has been modified by the user. (Inherited from ThumbnailView.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeLabelEdit | Called when the user is trying to modifiy the thumbnail caption. (Inherited from ThumbnailView.)
Protected method | OnBeforeThumbnailLoad | Called just before a thumbnail image is created. (Inherited from ThumbnailView.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a click event has occurred. (Inherited from ThumbnailView.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollectionChanged | (Overrides ThumbnailViewOnCollectionChanged(CollectionChangedEventArgs).)
Protected method | OnCompare | Called when two thumbnails need to be compared. (Inherited from ThumbnailView.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataChanged | Called when a DataRow has changed in the data source. (Inherited from ThumbnailView.)
Protected method | OnDataMemberChanged | Called when a data member has changed. (Inherited from ThumbnailView.)
Protected method | OnDataSourceChanged | Called when the data source has changed. (Inherited from ThumbnailView.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Called when the user double-clicks the control. (Inherited from ThumbnailView.)
Protected method | OnDragDrop | Called when a drag drop operation has completed. (Inherited from ThumbnailView.)
Protected method | OnDragEnter | Called when a DragEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragLeave | Called when a DragLeave event has occurred. (Inherited from ThumbnailView.)
Protected method | OnDragOver | Called when a DragOver event has occurred. (Inherited from ThumbnailView.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnEraseDropPositionIndicator | Called when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Protected method | OnFontChanged | Called when the Font property has changed. (Inherited from ThumbnailView.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the handle of the control is created. (Inherited from ThumbnailView.)
Protected method | OnHandleDestroyed | Called when the control handle is destroyed. (Inherited from ThumbnailView.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHoverItemChanged | Called when the HoverItem property has changed. (Inherited from ThumbnailView.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Called when a drag drop operation has started. (Inherited from ThumbnailView.)
Protected method | OnKeyDown | Called when a KeyDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Called when a KeyUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLayout | Called when a layout event has occurred. (Inherited from ThumbnailView.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Called when the control has lost focus. (Inherited from ThumbnailView.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a MouseDown event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseEnter | Called when a MouseEnter event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a MouseMove event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseUp | Called when a MouseUp event has occurred. (Inherited from ThumbnailView.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Called when the control needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnPaintDropPositionIndicator | Called when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnPaintThumbnail | Called when a Thumbnail needs to be painted. (Inherited from ThumbnailView.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedIndexChanged | Called when the selected index has changed. (Inherited from ThumbnailView.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailActivate | Called when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Protected method | OnThumbnailCreated | (Overrides ThumbnailViewOnThumbnailCreated(ThumbnailEventArgs).)
Protected method | OnThumbnailSizeChanged | (Overrides ThumbnailViewOnThumbnailSizeChanged.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshThumbnails | Obsolete. This method will force the items in the FolderThumbnailView to reload. This is the same as calling the Reload method on Items.
Protected method | RemoveAfterDragDrop | Override to change the way a thumbnail is removed after a drag drop, if you are using the ThumbnailView in a composite control (Inherited from ThumbnailView.)
Protected method | RemoveOverride | (Inherited from ThumbnailView.)
Protected method | ReorderAfterDragDrop | Override to change the way a thumbnail is reordered after a drag drop, if you are using the ThumbnailView in a composite control (Inherited from ThumbnailView.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSorting | Resumes any sorting of the thumbnails. (Inherited from ThumbnailView.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row. (Inherited from ThumbnailView.)
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control. (Inherited from ThumbnailView.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all of the thumbnails in the control. (Inherited from ThumbnailView.)
Public method | SelectFromBounds | This method will select thumbnails that intersect the rectangle provided. (Inherited from ThumbnailView.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataBinding | Sets up data binding for the ThumbnailView. (Inherited from ThumbnailView.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Use this method to force the ThumbnailCollection to sort. (Inherited from ThumbnailView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ThumbnailView.)
Top
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.Dispose Method

FolderThumbnailViewDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources used by the control. (Overrides ThumbnailViewDispose(Boolean).)
Top
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.Dispose Method (Boolean)

FolderThumbnailViewDispose Method (Boolean)

Releases resources used by the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True if being called from the Dispose method.
See Also

Reference

FolderThumbnailView Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.Finalize Method

FolderThumbnailViewFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.GetFolderImageCount Method

FolderThumbnailViewGetFolderImageCount Method

Returns the number of images in the specified path that pass the file extension filter.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetFolderImageCount(
    string path
)
Public Function GetFolderImageCount (
    path As String
) As Integer

Parameters

path
Type: SystemString
The path to query.

Return Value

Type: Int32
The number of images in the specified path that pass the file extension filter.
Remarks
Use this method to determine the number of images in a folder prior to setting the ImageFolder to load it.
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.OnCollectionChanged Method

FolderThumbnailViewOnCollectionChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnCollectionChanged(
    CollectionChangedEventArgs e
)
Protected Overrides Sub OnCollectionChanged (
    e As CollectionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsCollectionChangedEventArgs
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.OnThumbnailCreated Method

FolderThumbnailViewOnThumbnailCreated Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnThumbnailCreated(
    ThumbnailEventArgs e
)
Protected Overrides Sub OnThumbnailCreated (
    e As ThumbnailEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsThumbnailEventArgs
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.OnThumbnailSizeChanged Method

FolderThumbnailViewOnThumbnailSizeChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnThumbnailSizeChanged()
Protected Overrides Sub OnThumbnailSizeChanged
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.RefreshThumbnails Method

FolderThumbnailViewRefreshThumbnails Method

Note: This API is now obsolete.

This method will force the items in the FolderThumbnailView to reload. This is the same as calling the Reload method on Items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method may be removed in future versions.  Use Items.Reload instead.",
    false)]
public void RefreshThumbnails()
<ObsoleteAttribute("This method may be removed in future versions.  Use Items.Reload instead.",
    false)>
Public Sub RefreshThumbnails
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView Events

The FolderThumbnailView type exposes the following members.

Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ThumbnailView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ThumbnailView.)
Public event | BeforeThumbnailLoad | Raised just before a thumbnail image is going to be created. (Inherited from ThumbnailView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CompareThumbnails | Occurs when the thumbnail items need to be sorted. (Inherited from ThumbnailView.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | EraseDropPositionIndicator | Raised when the drag drop indicator needs to be erased. (Inherited from ThumbnailView.)
Public event | FolderLoadCompleted | Occurs after a folder load completes.
Public event | FolderLoadProgress | Occurs after each thumbnail is loaded during a folder load.
Public event | FolderLoadStarted | Occurs when thumbnails are about to be loaded from a folder.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoverItemChanged | Raised when the HoverItem has changed. (Inherited from ThumbnailView.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from ThumbnailView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintDropPositionIndicator | Raised when the drag drop indicator needs to be painted. (Inherited from ThumbnailView.)
Public event | PaintThumbnail | Occurs when a thumbnail needs to be painted. (Inherited from ThumbnailView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | SelectedIndexChanged | Occurs when the selected thumbnail index changes. (Inherited from ThumbnailView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThumbnailActivate | Raised when a thumbnail enters 'edit' mode. (Inherited from ThumbnailView.)
Public event | ThumbnailClicked | Raised when a thumbnail is clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailCollectionChanged | Raised when the thumbnail collection has changed from an add, insert, remove or clear action. (Inherited from ThumbnailView.)
Public event | ThumbnailCreated | Raised when a thumbnail has been created. (Inherited from ThumbnailView.)
Public event | ThumbnailDoubleClicked | Raised when a thumbnail is double-clicked. (Inherited from ThumbnailView.)
Public event | ThumbnailDrop | Occurs when the user has dropped an item onto the control. (Inherited from ThumbnailView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.FolderLoadCompleted Event

FolderThumbnailViewFolderLoadCompleted Event

Occurs after a folder load completes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler FolderLoadCompleted
Public Event FolderLoadCompleted As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.FolderLoadProgress Event

FolderThumbnailViewFolderLoadProgress Event

Occurs after each thumbnail is loaded during a folder load.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler FolderLoadProgress
Public Event FolderLoadProgress As EventHandler

Value

Type: SystemEventHandler
Remarks
This event can be used to increment a progress status indicator.
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


FolderThumbnailView.FolderLoadStarted Event

FolderThumbnailViewFolderLoadStarted Event

Occurs when thumbnails are about to be loaded from a folder.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler FolderLoadStarted
Public Event FolderLoadStarted As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

FolderThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument Class

Allows multiple images to be printed per page at typical metric and English photo sizes.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Drawing.PrintingPrintDocument
Atalasoft.Imaging.WinControlsImageCompositePrintDocument

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageCompositePrintDocument : PrintDocument
Public Class ImageCompositePrintDocument
    Inherits PrintDocument

The ImageCompositePrintDocument type exposes the following members.

Constructors
 | Name | Description
Public method | ImageCompositePrintDocument | Instantiates a new instance of the ImageCompositePrintDocument class.
Public method | ImageCompositePrintDocument(CompositePrintLayout) | Instantiates a new instance of the ImageCompositePrintDocument class specifying the page layout.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CaptionAlignment | Gets or sets the horizontal alignment of the caption text.
Public property | CaptionColor | Gets or sets the color of the caption text.
Public property | CaptionFont | Gets or sets the font properties of the caption text.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CropImageToFit | Gets or sets a value indicating if the image is cropped or resized to fit the aspect ratio of the photo print.
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Layout | Gets or sets the composite photo print layout that will be printed on each page.
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterPrintImage |
Protected method | OnBeginPrint | (Overrides PrintDocumentOnBeginPrint(PrintEventArgs).)
Protected method | OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
Protected method | OnPrintImage |
Protected method | OnPrintPage | (Overrides PrintDocumentOnPrintPage(PrintPageEventArgs).)
Protected method | OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
Events
 | Name | Description
 | AfterPrintImage | Occurs after a specific image is printed during the printing process.
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
 | PrintImage | Occurs before an image is printed during the printing process.
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
Remarks

This component requires the PrintImage event to be handled (or OnPrintImage(PrintCompositeEventArgs) method overridden). In the event handler, pass an AtalaImage into the PrintCompositeEventArgs to be printed. Set the HasMorePages property to true when there are more images to print.

Minimum page margins will be used when calculating the image position. You may override the position and size of the printed image by changing the ImageBounds property of the PrintCompositeEventArgs. The image will always be rotated to fit.

A caption can be printed beneath each image by setting the Caption property of PrintCompositeEventArgs.

By default, images will be cropped to fit the aspect ratio of the printed size. However setting the CropImageToFit property to false will instead scale the image to fit the image bounds, keeping the original aspect ratio of the image.

Examples
Composite Print Events (C#)
Copy
private string[] _folders;

//handle this event to tell the printer component what images to print
private void imageCompositePrintDocument1_PrintImage(object sender, Atalasoft.Imaging.WinControls.PrintCompositeEventArgs e)
{
    if (_folders != null && _folders.Length > e.ImageIndex)
    {
        //specify the image to print
        e.Image = new AtalaImage(_folders[e.ImageIndex]);
        //specify the caption of the image
        e.Caption = System.IO.Path.GetFileName(_folders[e.ImageIndex]);
    }

    //tell Print Document if there are more images/pages to print after this one
    if (e.ImageIndex >= _folders.Length - 1)
        e.HasMorePages = false;
    else
        e.HasMorePages = true;
}

//handle this event to dispose the image that's no longer needed
private void imageCompositePrintDocument1_AfterPrintImage(object sender, Atalasoft.Imaging.WinControls.PrintCompositeEventArgs e)
{
    if (e.Image != null)
        e.Image.Dispose();
}

//print the images
private void btnPrint_Click(object sender, System.EventArgs e)
{
    if (this.printDialog1.ShowDialog(this) == DialogResult.OK)
    {
        //get images from a folder
        _folders = System.IO.Directory.GetFiles("c:\\photos", "*.jpg");
        this.imageCompositePrintDocument1.Print();
    }
}
Composite Print Events (Visual Basic)
Copy
Private _folders() As String

'handle this event to tell the printer component what images to print
Private  Sub imageCompositePrintDocument1_PrintImage(ByVal sender As Object, ByVal e As Atalasoft.Imaging.WinControls.PrintCompositeEventArgs) Handles imageCompositePrintDocument1.PrintImage
    If Not _folders Is Nothing And _folders.Length > e.ImageIndex Then
        'specify the image to print
        e.Image = New AtalaImage(_folders(e.ImageIndex))
        'specify the caption of the image
        e.Caption = System.IO.Path.GetFileName(_folders(e.ImageIndex))
    End If

    'tell Print Document if there are more images/pages to print after this one
    If e.ImageIndex >= _folders.Length - 1 Then
        e.HasMorePages = False
    Else
        e.HasMorePages = True
    End If
End Sub

'handle this event to dispose the image that's no longer needed
Private  Sub imageCompositePrintDocument1_AfterPrintImage(ByVal sender As Object, ByVal e As Atalasoft.Imaging.WinControls.PrintCompositeEventArgs) Handles imageCompositePrintDocument1.AfterPrintImage
    If Not e.Image Is Nothing Then
        e.Image.Dispose()
    End If
End Sub

'print the images
Private  Sub btnPrint_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    If Me.printDialog1.ShowDialog(Me) = DialogResult.OK Then
        'get images from a folder
        _folders = System.IO.Directory.GetFiles("c:\photos", "*.jpg")
        Me.imageCompositePrintDocument1.Print()
    End If
End Sub
See Also

Reference

Atalasoft.Imaging.WinControls Namespace
Atalasoft.Imaging.WinControlsImagePrintDocument


ImageCompositePrintDocument Constructor

Instantiates a new instance of the ImageCompositePrintDocument class.
Overload List
 | Name | Description
Public method | ImageCompositePrintDocument | Instantiates a new instance of the ImageCompositePrintDocument class.
Public method | ImageCompositePrintDocument(CompositePrintLayout) | Instantiates a new instance of the ImageCompositePrintDocument class specifying the page layout.
Top
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument Constructor

Instantiates a new instance of the ImageCompositePrintDocument class.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCompositePrintDocument()
Public Sub New
See Also

Reference

ImageCompositePrintDocument Class
ImageCompositePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument Constructor (CompositePrintLayout)

Instantiates a new instance of the ImageCompositePrintDocument class specifying the page layout.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCompositePrintDocument(
    CompositePrintLayout layout
)
Public Sub New (
    layout As CompositePrintLayout
)

Parameters

layout
Type: Atalasoft.Imaging.WinControlsCompositePrintLayout
The printed image composite layout.
See Also

Reference

ImageCompositePrintDocument Class
ImageCompositePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument Properties

The ImageCompositePrintDocument type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CaptionAlignment | Gets or sets the horizontal alignment of the caption text.
Public property | CaptionColor | Gets or sets the color of the caption text.
Public property | CaptionFont | Gets or sets the font properties of the caption text.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CropImageToFit | Gets or sets a value indicating if the image is cropped or resized to fit the aspect ratio of the photo print.
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Layout | Gets or sets the composite photo print layout that will be printed on each page.
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.CaptionAlignment Property

ImageCompositePrintDocumentCaptionAlignment Property

Gets or sets the horizontal alignment of the caption text.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringAlignment CaptionAlignment { get; set; }
Public Property CaptionAlignment As StringAlignment
    Get
    Set

Property Value

Type: StringAlignment
The horizontal alignment of the caption text.
Remarks
Default is the value Near for left alignment.
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.CaptionColor Property

ImageCompositePrintDocumentCaptionColor Property

Gets or sets the color of the caption text.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color CaptionColor { get; set; }
Public Property CaptionColor As Color
    Get
    Set

Property Value

Type: Color
The color of the caption text.
Remarks
The default value is black.
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.CaptionFont Property

ImageCompositePrintDocumentCaptionFont Property

Gets or sets the font properties of the caption text.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font CaptionFont { get; set; }
Public Property CaptionFont As Font
    Get
    Set

Property Value

Type: Font
The font properties of the caption text.
Remarks
Default value is 8-pt Arial.
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.CropImageToFit Property

ImageCompositePrintDocumentCropImageToFit Property

Gets or sets a value indicating if the image is cropped or resized to fit the aspect ratio of the photo print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CropImageToFit { get; set; }
Public Property CropImageToFit As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the image is cropped or resized to fit the aspect ratio of the photo print.
Remarks
Default value is true.
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.Layout Property

ImageCompositePrintDocumentLayout Property

Gets or sets the composite photo print layout that will be printed on each page.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CompositePrintLayout Layout { get; set; }
Public Property Layout As CompositePrintLayout
    Get
    Set

Property Value

Type: CompositePrintLayout
The composite photo print layout that will be printed on each page.
Remarks
Default is FullPage. Metric and English units can be specified by choosing the appropriate enumeration.
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument Methods

The ImageCompositePrintDocument type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterPrintImage |
Protected method | OnBeginPrint | (Overrides PrintDocumentOnBeginPrint(PrintEventArgs).)
Protected method | OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
Protected method | OnPrintImage |
Protected method | OnPrintPage | (Overrides PrintDocumentOnPrintPage(PrintPageEventArgs).)
Protected method | OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.OnAfterPrintImage Method

ImageCompositePrintDocumentOnAfterPrintImage Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAfterPrintImage(
    PrintCompositeEventArgs e
)
Protected Overridable Sub OnAfterPrintImage (
    e As PrintCompositeEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintCompositeEventArgs
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.OnBeginPrint Method

ImageCompositePrintDocumentOnBeginPrint Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnBeginPrint(
    PrintEventArgs e
)
Protected Overrides Sub OnBeginPrint (
    e As PrintEventArgs
)

Parameters

e
Type: System.Drawing.PrintingPrintEventArgs
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.OnPrintImage Method

ImageCompositePrintDocumentOnPrintImage Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPrintImage(
    PrintCompositeEventArgs e
)
Protected Overridable Sub OnPrintImage (
    e As PrintCompositeEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintCompositeEventArgs
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.OnPrintPage Method

ImageCompositePrintDocumentOnPrintPage Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPrintPage(
    PrintPageEventArgs e
)
Protected Overrides Sub OnPrintPage (
    e As PrintPageEventArgs
)

Parameters

e
Type: System.Drawing.PrintingPrintPageEventArgs
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument Events

The ImageCompositePrintDocument type exposes the following members.

Events
 | Name | Description
 | AfterPrintImage | Occurs after a specific image is printed during the printing process.
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
 | PrintImage | Occurs before an image is printed during the printing process.
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.AfterPrintImage Event

ImageCompositePrintDocumentAfterPrintImage Event

Occurs after a specific image is printed during the printing process.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PrintCompositeEventHandler AfterPrintImage
Public Event AfterPrintImage As PrintCompositeEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPrintCompositeEventHandler
Remarks
Use this event to dispose of images when they are no longer needed, or for any other cleanup required.
Examples
Dispose Image (C#)
Copy
private void imageCompositePrintDocument1_AfterPrintImage(object sender, Atalasoft.Imaging.WinControls.PrintCompositeEventArgs e)
{
    if (e.Image != null)
        e.Image.Dispose();
}
Dispose Image (Visual Basic)
Copy
Private  Sub imageCompositePrintDocument1_AfterPrintImage(ByVal sender As Object, ByVal e As Atalasoft.Imaging.WinControls.PrintCompositeEventArgs) Handles imageCompositePrintDocument1.AfterPrintImage
    If Not e.Image Is Nothing Then
        e.Image.Dispose()
    End If
End Sub
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageCompositePrintDocument.PrintImage Event

ImageCompositePrintDocumentPrintImage Event

Occurs before an image is printed during the printing process.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PrintCompositeEventHandler PrintImage
Public Event PrintImage As PrintCompositeEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPrintCompositeEventHandler
Remarks
This event must be handled or nothing will be printed. Set the PrintCompositeEventArgs members to specify the image to print, the caption of the image, and to indicate if there are any more images to print.
Examples
Print Images (C#)
Copy
private void imageCompositePrintDocument1_PrintImage(object sender, Atalasoft.Imaging.WinControls.PrintCompositeEventArgs e)
{
    if (_folders != null && _folders.Length > e.ImageIndex)
    {
        //specify the image to print
        e.Image = new AtalaImage(_folders[e.ImageIndex]);
        //specify the caption of the image
        e.Caption = System.IO.Path.GetFileName(_folders[e.ImageIndex]);
    }

    //tell Print Document if there are more images/pages to print after this one
    if (e.ImageIndex >= _folders.Length - 1)
        e.HasMorePages = false;
    else
        e.HasMorePages = true;
}
Print Images (Visual Basic)
Copy
Private  Sub imageCompositePrintDocument1_PrintImage(ByVal sender As Object, ByVal e As Atalasoft.Imaging.WinControls.PrintCompositeEventArgs) Handles imageCompositePrintDocument1.PrintImage
    If _folders <> Nothing And _folders.Length > e.ImageIndex Then
        'specify the image to print
        e.Image = New AtalaImage(_folders(e.ImageIndex))
        'specify the caption of the image
        e.Caption = System.IO.Path.GetFileName(_folders(e.ImageIndex))
    End If

    'tell Print Document if there are more images/pages to print after this one
    If e.ImageIndex >= _folders.Length - 1 Then
        e.HasMorePages = False
    Else
        e.HasMorePages = True
    End If
End Sub
See Also

Reference

ImageCompositePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties Class

This class is used to provide properties for the WorkspaceViewer used by the DocumentViewer.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsImageControlProperties

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ImageControlProperties
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ImageControlProperties

The ImageControlProperties type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseButton |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user draggs onto it.
Public property | AntialiasDisplay |
Public property | AutoZoom |
Public property | BackColor | Gets or sets the background color fo the control.
Public property | Centered |
Public property | ColorManage |
Public property | ContextMenu | Gets or sets the ContextMenu for the control.
Public property | ContextMenuStrip | Gets or sets the context menu used for the control.
Public property | Cursor | Gets or sets the Cursor for the control.
Public property | DisplayProfile |
Public property | Image |
Public property | ImageBorderPen |
Public property | ImagePosition |
Public property | ImageRectangle |
Public property | Magnifier |
Public property | MouseTool |
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the control will scroll when mouse wheel events are received.
Public property | OutputProfile |
Public property | PanCursor |
Public property | ProofIntent |
Public property | RenderingIntent |
Public property | ResolutionScaleMode |
Public property | ScrollBarStyle |
Public property | ScrollPosition |
Public property | ScrollRectangle |
Public property | ScrollSize |
Public property | Selection |
Public property | SmoothScroll |
Public property | Zoom |
Public property | ZoomAreaCursor |
Public property | ZoomCursor |
Public property | ZoomInCursor |
Public property | ZoomInOutPercentage |
Public property | ZoomOutCursor |
Public property | ZoomRectangle |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string name for the class. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ImageControlProperties Properties

The ImageControlProperties type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseButton |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user draggs onto it.
Public property | AntialiasDisplay |
Public property | AutoZoom |
Public property | BackColor | Gets or sets the background color fo the control.
Public property | Centered |
Public property | ColorManage |
Public property | ContextMenu | Gets or sets the ContextMenu for the control.
Public property | ContextMenuStrip | Gets or sets the context menu used for the control.
Public property | Cursor | Gets or sets the Cursor for the control.
Public property | DisplayProfile |
Public property | Image |
Public property | ImageBorderPen |
Public property | ImagePosition |
Public property | ImageRectangle |
Public property | Magnifier |
Public property | MouseTool |
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the control will scroll when mouse wheel events are received.
Public property | OutputProfile |
Public property | PanCursor |
Public property | ProofIntent |
Public property | RenderingIntent |
Public property | ResolutionScaleMode |
Public property | ScrollBarStyle |
Public property | ScrollPosition |
Public property | ScrollRectangle |
Public property | ScrollSize |
Public property | Selection |
Public property | SmoothScroll |
Public property | Zoom |
Public property | ZoomAreaCursor |
Public property | ZoomCursor |
Public property | ZoomInCursor |
Public property | ZoomInOutPercentage |
Public property | ZoomOutCursor |
Public property | ZoomRectangle |
Top
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ActiveMouseButton Property

ImageControlPropertiesActiveMouseButton Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButtons ActiveMouseButton { get; set; }
Public Property ActiveMouseButton As MouseButtons
    Get
    Set

Property Value

Type: MouseButtons
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.AllowDrop Property

ImageControlPropertiesAllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user draggs onto it.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowDrop { get; set; }
Public Property AllowDrop As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the control can accept data that is dragged onto it.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.AntialiasDisplay Property

ImageControlPropertiesAntialiasDisplay Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AntialiasDisplayMode AntialiasDisplay { get; set; }
Public Property AntialiasDisplay As AntialiasDisplayMode
    Get
    Set

Property Value

Type: AntialiasDisplayMode
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.AutoZoom Property

ImageControlPropertiesAutoZoom Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoZoomMode AutoZoom { get; set; }
Public Property AutoZoom As AutoZoomMode
    Get
    Set

Property Value

Type: AutoZoomMode
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.BackColor Property

ImageControlPropertiesBackColor Property

Gets or sets the background color fo the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color of the control.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.Centered Property

ImageControlPropertiesCentered Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Centered { get; set; }
Public Property Centered As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ColorManage Property

ImageControlPropertiesColorManage Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ColorManage { get; set; }
Public Property ColorManage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ContextMenu Property

ImageControlPropertiesContextMenu Property

Gets or sets the ContextMenu for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContextMenu ContextMenu { get; set; }
Public Property ContextMenu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu for the control.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ContextMenuStrip Property

ImageControlPropertiesContextMenuStrip Property

Gets or sets the context menu used for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContextMenuStrip ContextMenuStrip { get; set; }
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set

Property Value

Type: ContextMenuStrip
The context menu used for the control.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.Cursor Property

ImageControlPropertiesCursor Property

Gets or sets the Cursor for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor Cursor { get; set; }
Public Property Cursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The Cursor for the control.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.DisplayProfile Property

ImageControlPropertiesDisplayProfile Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile DisplayProfile { get; set; }
Public Property DisplayProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.Image Property

ImageControlPropertiesImage Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ImageBorderPen Property

ImageControlPropertiesImageBorderPen Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen ImageBorderPen { get; set; }
Public Property ImageBorderPen As AtalaPen
    Get
    Set

Property Value

Type: AtalaPen
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ImagePosition Property

ImageControlPropertiesImagePosition Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ImagePosition { get; }
Public ReadOnly Property ImagePosition As Point
    Get

Property Value

Type: Point
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ImageRectangle Property

ImageControlPropertiesImageRectangle Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ImageRectangle { get; }
Public ReadOnly Property ImageRectangle As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.Magnifier Property

ImageControlPropertiesMagnifier Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Magnifier Magnifier { get; set; }
Public Property Magnifier As Magnifier
    Get
    Set

Property Value

Type: Magnifier
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.MouseTool Property

ImageControlPropertiesMouseTool Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseToolType MouseTool { get; set; }
Public Property MouseTool As MouseToolType
    Get
    Set

Property Value

Type: MouseToolType
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.MouseWheelScrolling Property

ImageControlPropertiesMouseWheelScrolling Property

Gets or sets a value indicating whether the control will scroll when mouse wheel events are received.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MouseWheelScrolling { get; set; }
Public Property MouseWheelScrolling As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the control will scroll on mouse wheel events.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.OutputProfile Property

ImageControlPropertiesOutputProfile Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile OutputProfile { get; set; }
Public Property OutputProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.PanCursor Property

ImageControlPropertiesPanCursor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor PanCursor { get; set; }
Public Property PanCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ProofIntent Property

ImageControlPropertiesProofIntent Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent ProofIntent { get; set; }
Public Property ProofIntent As RenderingIntent
    Get
    Set

Property Value

Type: RenderingIntent
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.RenderingIntent Property

ImageControlPropertiesRenderingIntent Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent RenderingIntent { get; set; }
Public Property RenderingIntent As RenderingIntent
    Get
    Set

Property Value

Type: RenderingIntent
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ResolutionScaleMode Property

ImageControlPropertiesResolutionScaleMode Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolutionScaleMode ResolutionScaleMode { get; set; }
Public Property ResolutionScaleMode As ResolutionScaleMode
    Get
    Set

Property Value

Type: ResolutionScaleMode
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ScrollBarStyle Property

ImageControlPropertiesScrollBarStyle Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollBarVisibility ScrollBarStyle { get; set; }
Public Property ScrollBarStyle As ScrollBarVisibility
    Get
    Set

Property Value

Type: ScrollBarVisibility
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ScrollPosition Property

ImageControlPropertiesScrollPosition Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; set; }
Public Property ScrollPosition As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ScrollRectangle Property

ImageControlPropertiesScrollRectangle Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ScrollRectangle { get; }
Public ReadOnly Property ScrollRectangle As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ScrollSize Property

ImageControlPropertiesScrollSize Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ScrollSize { get; }
Public ReadOnly Property ScrollSize As Size
    Get

Property Value

Type: Size
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.Selection Property

ImageControlPropertiesSelection Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rubberband Selection { get; set; }
Public Property Selection As Rubberband
    Get
    Set

Property Value

Type: Rubberband
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.SmoothScroll Property

ImageControlPropertiesSmoothScroll Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SmoothScroll { get; set; }
Public Property SmoothScroll As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.Zoom Property

ImageControlPropertiesZoom Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ZoomAreaCursor Property

ImageControlPropertiesZoomAreaCursor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomAreaCursor { get; set; }
Public Property ZoomAreaCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ZoomCursor Property

ImageControlPropertiesZoomCursor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomCursor { get; set; }
Public Property ZoomCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ZoomInCursor Property

ImageControlPropertiesZoomInCursor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomInCursor { get; set; }
Public Property ZoomInCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ZoomInOutPercentage Property

ImageControlPropertiesZoomInOutPercentage Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ZoomInOutPercentage { get; set; }
Public Property ZoomInOutPercentage As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ZoomOutCursor Property

ImageControlPropertiesZoomOutCursor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomOutCursor { get; set; }
Public Property ZoomOutCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ZoomRectangle Property

ImageControlPropertiesZoomRectangle Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rubberband ZoomRectangle { get; set; }
Public Property ZoomRectangle As Rubberband
    Get
    Set

Property Value

Type: Rubberband
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties Methods

The ImageControlProperties type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string name for the class. (Overrides ObjectToString.)
Top
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageControlProperties.ToString Method

ImageControlPropertiesToString Method

Returns a string name for the class.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string name for the class.
See Also

Reference

ImageControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Class

This class contains information for an image that was inserted into the collection.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsImageInsertEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageInsertEventArgs : EventArgs
Public Class ImageInsertEventArgs
    Inherits EventArgs

The ImageInsertEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageInsertEventArgs(Int32, AtalaImage, String) | Creates a new instance of ImageInsertEventArgs specifying the added image.
Public method | ImageInsertEventArgs(Int32, RandomAccessImageSource, Int32, String) | Creates a new instance of ImageInsertEventArgs specifying the ImageSource and frame index of the image.
Public method | ImageInsertEventArgs(Int32, Stream, Int32, String) | Creates a new instance of ImageInsertEventArgs specifying the stream and frame index of the image.
Public method | ImageInsertEventArgs(Int32, String, Int32, String) | Creates a new instance of ImageInsertEventArgs specifying the filename and frame index of the image.
Top
Properties
 | Name | Description
Public property | FileName | Gets the filename of the image or null (Nothing in VB) if no filename was provided.
Public property | FrameIndex | Gets the frame index of the image.
Public property | Image | Gets the image of null (Nothing in VB) if an image was not provided.
Public property | ImageSource | Gets the image source containing the image or null (Nothing in VB) if an image source was not provided.
Public property | InsertIndex | Gets the index where the image was inserted.
Public property | Stream | Gets the stream containing the image or null (Nothing in VB) if a stream was not provided.
Public property | TemporaryXmpFileName | Gets the temporary filename used for XMP annotation data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Constructor

Constructs a new ImageInsertEventArgs.
Overload List
 | Name | Description
Public method | ImageInsertEventArgs(Int32, AtalaImage, String) | Creates a new instance of ImageInsertEventArgs specifying the added image.
Public method | ImageInsertEventArgs(Int32, RandomAccessImageSource, Int32, String) | Creates a new instance of ImageInsertEventArgs specifying the ImageSource and frame index of the image.
Public method | ImageInsertEventArgs(Int32, Stream, Int32, String) | Creates a new instance of ImageInsertEventArgs specifying the stream and frame index of the image.
Public method | ImageInsertEventArgs(Int32, String, Int32, String) | Creates a new instance of ImageInsertEventArgs specifying the filename and frame index of the image.
Top
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Constructor (Int32, AtalaImage, String)

Creates a new instance of ImageInsertEventArgs specifying the added image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInsertEventArgs(
    int insertIndex,
    AtalaImage image,
    string temporaryXmpFileName
)
Public Sub New (
    insertIndex As Integer,
    image As AtalaImage,
    temporaryXmpFileName As String
)

Parameters

insertIndex
Type: SystemInt32
The index where the image was inserted.
image
Type: Atalasoft.ImagingAtalaImage
The image that was inserted.
temporaryXmpFileName
Type: SystemString
The temporary filename used for XMP annotation data.
See Also

Reference

ImageInsertEventArgs Class
ImageInsertEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Constructor (Int32, RandomAccessImageSource, Int32, String)

Creates a new instance of ImageInsertEventArgs specifying the ImageSource and frame index of the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInsertEventArgs(
    int insertIndex,
    RandomAccessImageSource source,
    int frameIndex,
    string temporaryXmpFileName
)
Public Sub New (
    insertIndex As Integer,
    source As RandomAccessImageSource,
    frameIndex As Integer,
    temporaryXmpFileName As String
)

Parameters

insertIndex
Type: SystemInt32
The index where the image was inserted.
source
Type: Atalasoft.ImagingRandomAccessImageSource
The image source containing the image.
frameIndex
Type: SystemInt32
The frame index in the image source.
temporaryXmpFileName
Type: SystemString
The temporary filename used for XMP annotation data.
See Also

Reference

ImageInsertEventArgs Class
ImageInsertEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Constructor (Int32, Stream, Int32, String)

Creates a new instance of ImageInsertEventArgs specifying the stream and frame index of the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInsertEventArgs(
    int insertIndex,
    Stream stream,
    int frameIndex,
    string temporaryXmpFileName
)
Public Sub New (
    insertIndex As Integer,
    stream As Stream,
    frameIndex As Integer,
    temporaryXmpFileName As String
)

Parameters

insertIndex
Type: SystemInt32
The index where the image was inserted.
stream
Type: System.IOStream
The stream containing the image.
frameIndex
Type: SystemInt32
The frame index of the image.
temporaryXmpFileName
Type: SystemString
The temporary filename used for XMP annotation data.
See Also

Reference

ImageInsertEventArgs Class
ImageInsertEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Constructor (Int32, String, Int32, String)

Creates a new instance of ImageInsertEventArgs specifying the filename and frame index of the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageInsertEventArgs(
    int insertIndex,
    string fileName,
    int frameIndex,
    string temporaryXmpFileName
)
Public Sub New (
    insertIndex As Integer,
    fileName As String,
    frameIndex As Integer,
    temporaryXmpFileName As String
)

Parameters

insertIndex
Type: SystemInt32
The index where the image was inserted.
fileName
Type: SystemString
The filename of the image.
frameIndex
Type: SystemInt32
The frame index of the image.
temporaryXmpFileName
Type: SystemString
The temporary filename used for XMP annotation data.
See Also

Reference

ImageInsertEventArgs Class
ImageInsertEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Properties

The ImageInsertEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets the filename of the image or null (Nothing in VB) if no filename was provided.
Public property | FrameIndex | Gets the frame index of the image.
Public property | Image | Gets the image of null (Nothing in VB) if an image was not provided.
Public property | ImageSource | Gets the image source containing the image or null (Nothing in VB) if an image source was not provided.
Public property | InsertIndex | Gets the index where the image was inserted.
Public property | Stream | Gets the stream containing the image or null (Nothing in VB) if a stream was not provided.
Public property | TemporaryXmpFileName | Gets the temporary filename used for XMP annotation data.
Top
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.FileName Property

ImageInsertEventArgsFileName Property

Gets the filename of the image or null (Nothing in VB) if no filename was provided.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The filename of the image or null (Nothing in VB).
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.FrameIndex Property

ImageInsertEventArgsFrameIndex Property

Gets the frame index of the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameIndex { get; }
Public ReadOnly Property FrameIndex As Integer
    Get

Property Value

Type: Int32
The frame index of the image.
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.Image Property

ImageInsertEventArgsImage Property

Gets the image of null (Nothing in VB) if an image was not provided.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
The image or null (Nothing in VB).
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.ImageSource Property

ImageInsertEventArgsImageSource Property

Gets the image source containing the image or null (Nothing in VB) if an image source was not provided.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomAccessImageSource ImageSource { get; }
Public ReadOnly Property ImageSource As RandomAccessImageSource
    Get

Property Value

Type: RandomAccessImageSource
The image source or null (Nothing in VB).
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.InsertIndex Property

ImageInsertEventArgsInsertIndex Property

Gets the index where the image was inserted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InsertIndex { get; }
Public ReadOnly Property InsertIndex As Integer
    Get

Property Value

Type: Int32
The index where the image was inserted.
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.Stream Property

ImageInsertEventArgsStream Property

Gets the stream containing the image or null (Nothing in VB) if a stream was not provided.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
The stream containing the image or null (Nothing in VB).
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs.TemporaryXmpFileName Property

ImageInsertEventArgsTemporaryXmpFileName Property

Gets the temporary filename used for XMP annotation data.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TemporaryXmpFileName { get; }
Public ReadOnly Property TemporaryXmpFileName As String
    Get

Property Value

Type: String
The filename used for XMP annotation data.
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImageInsertEventArgs Methods

The ImageInsertEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageInsertEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Class

Derives from PrintDocument and allows AtalaImage objects to be printed directly to a printer.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Drawing.PrintingPrintDocument
Atalasoft.Imaging.WinControlsImagePrintDocument
Atalasoft.Annotate.UIAnnotatePrintDocument

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImagePrintDocument : PrintDocument
Public Class ImagePrintDocument
    Inherits PrintDocument

The ImagePrintDocument type exposes the following members.

Constructors
 | Name | Description
Public method | ImagePrintDocument | Initializes a new instance of ImagePrintDocument.
Public method | ImagePrintDocument(AtalaImage) | Initializes a new instance of ImagePrintDocument specifying an image to print.
Public method | ImagePrintDocument(AtalaImage) | Initializes a new instance of ImagePrintDocument specifying an array of images to print on multiple pages.
Public method | ImagePrintDocument(ImageCollection) | Initializes a new instance of ImagePrintDocument specifying the image to print.
Public method | ImagePrintDocument(Boolean, PrintScaleMode, AtalaImage) | Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and scalemode settings.
Public method | ImagePrintDocument(Boolean, PrintScaleMode, AtalaImage) | Initializes a new instance of ImagePrintDocument specifying an array of images to print and the center and scale mode settings.
Public method | ImagePrintDocument(Boolean, PrintScaleMode, ImageCollection) | Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and fit to page settings.
Public method | ImagePrintDocument(Boolean, Boolean, AtalaImage) | Obsolete. Initializes a new instance of ImagePrintDocument specifying the image to print and the center and fit to page settings.
Public method | ImagePrintDocument(Boolean, Boolean, AtalaImage) | Obsolete. Initializes a new instance of ImagePrintDocument specifying an array of images to print and the center and fit to page settings.
Public method | ImagePrintDocument(Boolean, Boolean, ImageCollection) | Obsolete. Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and fit to page settings.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Center | Gets or sets a value indicating if the image is centered onto the page.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitToPage | Obsolete. A value indicating if the image is stretched to fit the page.
Public property | Image | Gets or sets the AtalaImage to print.
Public property | Images | Gets or sets the images to print.
Protected property | ImageToPrint | Gets the image that will be printed for this page.
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | ScaleMode | Gets or sets the scale mode used when printing an image.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterPrintPage | Called after the OnPrintPage(PrintPageEventArgs) method.
Protected method | OnBeginPrint | Call before printing begins. (Overrides PrintDocumentOnBeginPrint(PrintEventArgs).)
Protected method | OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
Protected method | OnGetImage | Raises the GetImage event to obtain the image to print.
Protected method | OnPrintImage | Called to send the image to the printer and raises the PrintImage event.
Protected method | OnPrintPage | Called for each page being printed. (Overrides PrintDocumentOnPrintPage(PrintPageEventArgs).)
Protected method | OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | SetImagesFromImageCollection | Sets the Images in this ImagePrintDocument to an ImageCollection in a Workspace or WorkspaceViewer.
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
Events
 | Name | Description
Public event | AfterPrintPage | Occurs after image is prepared to print.
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
 | GetImage | Occurs when the print job requires the next image to print.
Public event | PrintImage | Occurs just before the image is printed.
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
Remarks

The .NET Framework contains the PrintDialog, PrintPreviewDialog, PrintPreviewControl, and PageSetupDialog giving you fine control over printer settings and showing a preview of the output. Each of these uses a PrintDocument. The ImagePrintDocument extends the PrintDocument so that you can take advantage of this functionality when printing images in DotImage.

Multiple images can be printed by setting the Images array property, or by handling the GetImage event and setting the HasMorePages property of the PrintPageEventArgs to true.

Examples

This example requires you have a placed an ImagePrintDocument onto your form. It demonstrates printing one image to the printer, and scaling it to fit the page.

Printing an Image (C#)
Copy
myImagePrintDocument.Image = myImageViewer.Image;
myImagePrintDocument.ScaleMode = PrintScaleMode.FitToMargins;
myImagePrintDocument.Print();
Printing an Image (Visual Basic)
Copy
myImagePrintDocument.Image = myImageViewer.Image
myImagePrintDocument.ScaleMode = PrintScaleMode.FitToMargins
myImagePrintDocument.Print()

This example demonstrates how to print all images in a WorkspaceViewer to the printer while letting the user specify page and printer settings. By handling the PrintPage and AfterPrintPage events, it also demonstrates how to customize individual pages that are printed. This example uses a WorkspaceViewer, ImagePrintDocument, PageSetupDialog, and PrintDialog in a WinForms application. The Document Property in the PageSetupDialog and PrintDialog must be set to the ImagePrintDocument.

Custom Print Job (C#)
Copy
private void imagePrintDocument1_PrintPage(object sender, System.Drawing.Printing.PrintPageEventArgs e)
{
    //allows the user to customize page fitting for each page that's printed
    if (MessageBox.Show(this, "Do you wish to fit this image to the page?", "Specify Page Fitting", MessageBoxButtons.YesNo) == DialogResult.Yes)
        imagePrintDocument1.ScaleMode = PrintScaleMode.FitToMargins;
    else
        imagePrintDocument1.ScaleMode = PrintScaleMode.None;
}

private void imagePrintDocument1_AfterPrintPage(object sender, System.Drawing.Printing.PrintPageEventArgs e)
{
    //draws a watermark on the page
    e.Graphics.DrawString("This is a test watermark.", new Font("Arial", 18), new SolidBrush(Color.Black), 0, 0);
}

private void btnPrintImage_Click(object sender, System.EventArgs e)
{
    //lets the user set the printer options
    if (printDialog1.ShowDialog(this) == DialogResult.OK)
    {
        //set all images from the image collection
        imagePrintDocument1.SetImagesFromImageCollection(workspaceViewer1.Images);
        imagePrintDocument1.Print();
    }
}

private void btnPageSetup_Click(object sender, System.EventArgs e)
{
    //lets the user modify the page settings such as margins
    pageSetupDialog1.ShowDialog(this);
}
Custom Print Job (Visual Basic)
Copy
Private  Sub imagePrintDocument1_PrintPage(ByVal sender As Object, ByVal e As System.Drawing.Printing.PrintPageEventArgs) Handles imagePrintDocument1.PrintPage
    'allows the user to customize page fitting for each page that's printed
    If MessageBox.Show(this,"Do you wish to fit this image to the page?","Specify Page Fitting",MessageBoxButtons.YesNo) = DialogResult.Yes Then
        imagePrintDocument1.ScaleMode = PrintScaleMode.FitToMargins
    Else
        imagePrintDocument1.ScaleMode = PrintScaleMode.None
    End If
End Sub

Private  Sub imagePrintDocument1_AfterPrintPage(ByVal sender As Object, ByVal e As System.Drawing.Printing.PrintPageEventArgs) Handles imagePrintDocument1.AfterPrintPage
    'draws a watermark on the page
    e.Graphics.DrawString("This is a test watermark.", New Font("Arial", 18), New SolidBrush(Color.Black), 0, 0)
End Sub

Private  Sub btnPrintImage_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnPrintImage.Click
    'lets the user set the printer options
    If printDialog1.ShowDialog(Me) = DialogResult.OK Then
        'set all images from the image collection
        imagePrintDocument1.SetImagesFromImageCollection(workspaceViewer1.Images)
        imagePrintDocument1.Print()
    End If
End Sub

Private  Sub btnPageSetup_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnPageSetup.Click
    'lets the user modify the page settings such as margins
    pageSetupDialog1.ShowDialog(Me)
End Sub
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor

Overload List
 | Name | Description
Public method | ImagePrintDocument | Initializes a new instance of ImagePrintDocument.
Public method | ImagePrintDocument(AtalaImage) | Initializes a new instance of ImagePrintDocument specifying an image to print.
Public method | ImagePrintDocument(AtalaImage) | Initializes a new instance of ImagePrintDocument specifying an array of images to print on multiple pages.
Public method | ImagePrintDocument(ImageCollection) | Initializes a new instance of ImagePrintDocument specifying the image to print.
Public method | ImagePrintDocument(Boolean, PrintScaleMode, AtalaImage) | Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and scalemode settings.
Public method | ImagePrintDocument(Boolean, PrintScaleMode, AtalaImage) | Initializes a new instance of ImagePrintDocument specifying an array of images to print and the center and scale mode settings.
Public method | ImagePrintDocument(Boolean, PrintScaleMode, ImageCollection) | Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and fit to page settings.
Public method | ImagePrintDocument(Boolean, Boolean, AtalaImage) | Obsolete. Initializes a new instance of ImagePrintDocument specifying the image to print and the center and fit to page settings.
Public method | ImagePrintDocument(Boolean, Boolean, AtalaImage) | Obsolete. Initializes a new instance of ImagePrintDocument specifying an array of images to print and the center and fit to page settings.
Public method | ImagePrintDocument(Boolean, Boolean, ImageCollection) | Obsolete. Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and fit to page settings.
Top
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor

Initializes a new instance of ImagePrintDocument.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument()
Public Sub New
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (AtalaImage)

Initializes a new instance of ImagePrintDocument specifying an image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to print on a single sheet.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (AtalaImage[])

ImagePrintDocument Constructor (AtalaImage)

Initializes a new instance of ImagePrintDocument specifying an array of images to print on multiple pages.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument(
    params AtalaImage[] images
)
Public Sub New (
    ParamArray images As AtalaImage()
)

Parameters

images
Type: Atalasoft.ImagingAtalaImage
The array of AtalaImage's to print on multiple sheets.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (ImageCollection)

Initializes a new instance of ImagePrintDocument specifying the image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument(
    ImageCollection images
)
Public Sub New (
    images As ImageCollection
)

Parameters

images
Type: Atalasoft.ImagingImageCollection
An ImageCollection to print on multiple sheets.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (Boolean, PrintScaleMode, AtalaImage)

Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and scalemode settings.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument(
    bool center,
    PrintScaleMode scaleMode,
    AtalaImage image
)
Public Sub New (
    center As Boolean,
    scaleMode As PrintScaleMode,
    image As AtalaImage
)

Parameters

center
Type: SystemBoolean
Indicates if the image is centered on the page.
scaleMode
Type: Atalasoft.Imaging.WinControlsPrintScaleMode
Specifies how the image is scaled to fit the page (if at all).
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to print on a single sheet.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (Boolean, PrintScaleMode, AtalaImage[])

ImagePrintDocument Constructor (Boolean, PrintScaleMode, AtalaImage)

Initializes a new instance of ImagePrintDocument specifying an array of images to print and the center and scale mode settings.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument(
    bool center,
    PrintScaleMode scaleMode,
    params AtalaImage[] images
)
Public Sub New (
    center As Boolean,
    scaleMode As PrintScaleMode,
    ParamArray images As AtalaImage()
)

Parameters

center
Type: SystemBoolean
Indicates if the image is centered on the page.
scaleMode
Type: Atalasoft.Imaging.WinControlsPrintScaleMode
Specifies how the image is scaled to fit the page (if at all).
images
Type: Atalasoft.ImagingAtalaImage
The array of AtalaImage's to print on multiple sheets.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (Boolean, PrintScaleMode, ImageCollection)

Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and fit to page settings.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePrintDocument(
    bool center,
    PrintScaleMode scaleMode,
    ImageCollection images
)
Public Sub New (
    center As Boolean,
    scaleMode As PrintScaleMode,
    images As ImageCollection
)

Parameters

center
Type: SystemBoolean
Indicates if the image is centered on the page.
scaleMode
Type: Atalasoft.Imaging.WinControlsPrintScaleMode
Specifies how the image is scaled to fit the page (if at all).
images
Type: Atalasoft.ImagingImageCollection
An ImageCollection to print on multiple sheets.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (Boolean, Boolean, AtalaImage)

Note: This API is now obsolete.

Initializes a new instance of ImagePrintDocument specifying the image to print and the center and fit to page settings.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The fitToPage parameter is obsolete and will be removed from future versions.",
    false)]
public ImagePrintDocument(
    bool center,
    bool fitToPage,
    AtalaImage image
)
<ObsoleteAttribute("The fitToPage parameter is obsolete and will be removed from future versions.",
    false)>
Public Sub New (
    center As Boolean,
    fitToPage As Boolean,
    image As AtalaImage
)

Parameters

center
Type: SystemBoolean
Indicates if the image is centered on the page.
fitToPage
Type: SystemBoolean
Indicates if the image is resized to fit the page.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to print on a single sheet.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (Boolean, Boolean, AtalaImage[])

ImagePrintDocument Constructor (Boolean, Boolean, AtalaImage)

Note: This API is now obsolete.

Initializes a new instance of ImagePrintDocument specifying an array of images to print and the center and fit to page settings.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The fitToPage parameter is obsolete and will be removed from future versions.",
    false)]
public ImagePrintDocument(
    bool center,
    bool fitToPage,
    params AtalaImage[] images
)
<ObsoleteAttribute("The fitToPage parameter is obsolete and will be removed from future versions.",
    false)>
Public Sub New (
    center As Boolean,
    fitToPage As Boolean,
    ParamArray images As AtalaImage()
)

Parameters

center
Type: SystemBoolean
Indicates if the image is centered on the page.
fitToPage
Type: SystemBoolean
Indicates if the image is resized to fit the page.
images
Type: Atalasoft.ImagingAtalaImage
The array of AtalaImage's to print on multiple sheets.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Constructor (Boolean, Boolean, ImageCollection)

Note: This API is now obsolete.

Initializes a new instance of ImagePrintDocument specifying the ImageCollection to print and the center and fit to page settings.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Th fitToPage parameter is obsolete and will be removed from future versions.",
    false)]
public ImagePrintDocument(
    bool center,
    bool fitToPage,
    ImageCollection images
)
<ObsoleteAttribute("Th fitToPage parameter is obsolete and will be removed from future versions.",
    false)>
Public Sub New (
    center As Boolean,
    fitToPage As Boolean,
    images As ImageCollection
)

Parameters

center
Type: SystemBoolean
Indicates if the image is centered on the page.
fitToPage
Type: SystemBoolean
Indicates if the image is resized to fit the page.
images
Type: Atalasoft.ImagingImageCollection
An ImageCollection to print on multiple sheets.
See Also

Reference

ImagePrintDocument Class
ImagePrintDocument Overload
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Properties

The ImagePrintDocument type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Center | Gets or sets a value indicating if the image is centered onto the page.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitToPage | Obsolete. A value indicating if the image is stretched to fit the page.
Public property | Image | Gets or sets the AtalaImage to print.
Public property | Images | Gets or sets the images to print.
Protected property | ImageToPrint | Gets the image that will be printed for this page.
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | ScaleMode | Gets or sets the scale mode used when printing an image.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.Center Property

ImagePrintDocumentCenter Property

Gets or sets a value indicating if the image is centered onto the page.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Center { get; set; }
Public Property Center As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the image is centered onto the page.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.FitToPage Property

ImagePrintDocumentFitToPage Property

Note: This API is now obsolete.

A value indicating if the image is stretched to fit the page.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ScaleMode property enumeration has replaced the FitToPage boolean property.")]
public bool FitToPage { get; set; }
<ObsoleteAttribute("The ScaleMode property enumeration has replaced the FitToPage boolean property.")>
Public Property FitToPage As Boolean
    Get
    Set

Property Value

Type: Boolean
Gets or sets a value indicating if the image is stretched to fit the page.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.Image Property

ImagePrintDocumentImage Property

Gets or sets the AtalaImage to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage to print.
Remarks
If printing multiple images, this is the first image in the array.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.Images Property

ImagePrintDocumentImages Property

Gets or sets the images to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage[] Images { get; set; }
Public Property Images As AtalaImage()
    Get
    Set

Property Value

Type: AtalaImage
The images to print.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.ImageToPrint Property

ImagePrintDocumentImageToPrint Property

Gets the image that will be printed for this page.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImage ImageToPrint { get; }
Protected ReadOnly Property ImageToPrint As AtalaImage
    Get

Property Value

Type: AtalaImage
The image to print on the current page.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.ScaleMode Property

ImagePrintDocumentScaleMode Property

Gets or sets the scale mode used when printing an image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PrintScaleMode ScaleMode { get; set; }
Public Property ScaleMode As PrintScaleMode
    Get
    Set

Property Value

Type: PrintScaleMode
The scale mode used when printing an image.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Methods

The ImagePrintDocument type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterPrintPage | Called after the OnPrintPage(PrintPageEventArgs) method.
Protected method | OnBeginPrint | Call before printing begins. (Overrides PrintDocumentOnBeginPrint(PrintEventArgs).)
Protected method | OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
Protected method | OnGetImage | Raises the GetImage event to obtain the image to print.
Protected method | OnPrintImage | Called to send the image to the printer and raises the PrintImage event.
Protected method | OnPrintPage | Called for each page being printed. (Overrides PrintDocumentOnPrintPage(PrintPageEventArgs).)
Protected method | OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | SetImagesFromImageCollection | Sets the Images in this ImagePrintDocument to an ImageCollection in a Workspace or WorkspaceViewer.
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.OnAfterPrintPage Method

ImagePrintDocumentOnAfterPrintPage Method

Called after the OnPrintPage(PrintPageEventArgs) method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAfterPrintPage(
    PrintImageEventArgs ev
)
Protected Overridable Sub OnAfterPrintPage (
    ev As PrintImageEventArgs
)

Parameters

ev
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
A PrintImageEventArgs containing information about this print job.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.OnBeginPrint Method

ImagePrintDocumentOnBeginPrint Method

Call before printing begins.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnBeginPrint(
    PrintEventArgs ev
)
Protected Overrides Sub OnBeginPrint (
    ev As PrintEventArgs
)

Parameters

ev
Type: System.Drawing.PrintingPrintEventArgs
A PrintEventArgs containing information about this pring job.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.OnGetImage Method

ImagePrintDocumentOnGetImage Method

Raises the GetImage event to obtain the image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnGetImage(
    PrintImageEventArgs e
)
Protected Overridable Sub OnGetImage (
    e As PrintImageEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
A PrintImageEventArgs that contains information about this event.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.OnPrintImage Method

ImagePrintDocumentOnPrintImage Method

Called to send the image to the printer and raises the PrintImage event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPrintImage(
    PrintImageEventArgs e
)
Protected Overridable Sub OnPrintImage (
    e As PrintImageEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
An PrintImageEventArgs containing information for this event.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.OnPrintPage Method

ImagePrintDocumentOnPrintPage Method

Called for each page being printed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPrintPage(
    PrintPageEventArgs ev
)
Protected Overrides Sub OnPrintPage (
    ev As PrintPageEventArgs
)

Parameters

ev
Type: System.Drawing.PrintingPrintPageEventArgs
A PrintPageEventArgs containing information for this print job.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.SetImagesFromImageCollection Method

ImagePrintDocumentSetImagesFromImageCollection Method

Sets the Images in this ImagePrintDocument to an ImageCollection in a Workspace or WorkspaceViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetImagesFromImageCollection(
    ImageCollection images
)
Public Sub SetImagesFromImageCollection (
    images As ImageCollection
)

Parameters

images
Type: Atalasoft.ImagingImageCollection
The ImageCollection from a Workspace or WorkspaceViewer.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument Events

The ImagePrintDocument type exposes the following members.

Events
 | Name | Description
Public event | AfterPrintPage | Occurs after image is prepared to print.
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
 | GetImage | Occurs when the print job requires the next image to print.
Public event | PrintImage | Occurs just before the image is printed.
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.AfterPrintPage Event

ImagePrintDocumentAfterPrintPage Event

Occurs after image is prepared to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PrintImageEventHandler AfterPrintPage
Public Event AfterPrintPage As PrintImageEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPrintImageEventHandler
Remarks

Handle this event to print custom information onto the page which will be placed on top of the image. For example, this can be used to place a watermark on the page.

See OnPrintPage(PrintPageEventArgs) to customize the page settings for each page.

See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.GetImage Event

ImagePrintDocumentGetImage Event

Occurs when the print job requires the next image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PrintImageEventHandler GetImage
Public Event GetImage As PrintImageEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPrintImageEventHandler
Remarks
Handle this event to pass in one image at a time rather than loading all of the images at once. For this to work correctly, the Image and Images properties must be null.
Examples
GetImageExample (C#)
Copy
private void PrintWithGetImage()
{
    ImagePrintDocument doc = new ImagePrintDocument();
    doc.GetImage += new PrintImageEventHandler(doc_GetImage);
    doc.AfterPrintPage += new PrintImageEventHandler(doc_AfterPrintPage);
    doc.Print();
    doc.Dispose();
}

private void doc_GetImage(object sender, PrintImageEventArgs e)
{
    // Get the next image to print.
    e.Image = GrabNextImage();
}

private void doc_AfterPrintPage(object sender, PrintImageEventArgs e)
{
    if (MoreImagesToPrint())
        e.HasMorePages = true;
    else
        e.HasMorePages = false;
}
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImagePrintDocument.PrintImage Event

ImagePrintDocumentPrintImage Event

Occurs just before the image is printed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PrintImageEventHandler PrintImage
Public Event PrintImage As PrintImageEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPrintImageEventHandler
Remarks
Handle this event when modifying the destination and source rectangle areas used in the printing.
See Also

Reference

ImagePrintDocument Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer Class

A scrollable viewport for AtalaImages.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsScrollport
Atalasoft.Imaging.WinControlsViewport
Atalasoft.Imaging.WinControlsImageViewer
Atalasoft.Imaging.WinControlsWorkspaceViewer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageViewer : Viewport
Public Class ImageViewer
    Inherits Viewport

The ImageViewer type exposes the following members.

Constructors
 | Name | Description
Public method | ImageViewer | Initializes a new instance of ImageViewer.
Public method | ImageViewer(AtalaImage) | Initializes a new instance of ImageViewer specifying the initial AtalaImage.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AntialiasDisplay | Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColorManage | Get or set a value indicating if the control will automatically color correct images.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | Sets or returns the Image which is displayed in the control.
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device.
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Overrides ViewportDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ViewportFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Returns the current image and indicates whether or not this image is a Bitmap. (Overrides ViewportGetCurrentImage(Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control. (Overrides ViewportGetScaledResolutionHeight.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAntialiasDisplayChanged | Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event.
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageChanged | Called when the Image property has changed and raises the ImageChanged event.
Protected method | OnImageDraw | This method is used to draw the image onto the Viewport graphics. (Overrides ViewportOnImageDraw(Rectangle, Rectangle, Graphics).)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to redraw itself. (Overrides ViewportOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event. (Inherited from Viewport.)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Removes any cached images used for fast displays and redraws the image. (Overrides ControlRefresh.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetNewImage | Called when the Image is being replaced.
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
Events
 | Name | Description
Public event | AntialiasDisplayChanged | Occurs when AntialiasDisplay changes.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImageChanged | Occurs when commands are applied to change the image.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
Remarks
When using this control, it is the responsibility of the developer to set a new image when the image changes. See the WorkspaceViewer control to automatically control this behavior.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace
Atalasoft.Imaging.WinControlsWorkspaceViewer


ImageViewer Constructor

Initializes a new instance of ImageViewer.
Overload List
 | Name | Description
Public method | ImageViewer | Initializes a new instance of ImageViewer.
Public method | ImageViewer(AtalaImage) | Initializes a new instance of ImageViewer specifying the initial AtalaImage.
Top
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer Constructor

Initializes a new instance of ImageViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageViewer()
Public Sub New
See Also

Reference

ImageViewer Class
ImageViewer Overload
Atalasoft.Imaging.WinControls Namespace


ImageViewer Constructor (AtalaImage)

Initializes a new instance of ImageViewer specifying the initial AtalaImage.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageViewer(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image that the control will be initially set to.
See Also

Reference

ImageViewer Class
ImageViewer Overload
Atalasoft.Imaging.WinControls Namespace


ImageViewer Properties

The ImageViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AntialiasDisplay | Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColorManage | Get or set a value indicating if the control will automatically color correct images.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | Sets or returns the Image which is displayed in the control.
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device.
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.AntialiasDisplay Property

ImageViewerAntialiasDisplay Property

Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AntialiasDisplayMode AntialiasDisplay { get; set; }
Public Property AntialiasDisplay As AntialiasDisplayMode
    Get
    Set

Property Value

Type: AntialiasDisplayMode
The antialiasing mode, controlling how the image is scaled at different zoom levels.
Remarks
A DotImage Document Imaging license is required for ScaleToGray.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.ColorManage Property

ImageViewerColorManage Property

Get or set a value indicating if the control will automatically color correct images.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ColorManage { get; set; }
Public Property ColorManage As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the control will automatically color correct images.
Remarks

When true, the control uses the DisplayProfile and the ColorProfile of the image to display to transform the colors to the display's colorspace. If the OutputProfile is not null, then the image will be proofed to the OutputProfile.

See Atalasoft.Imaging.ColorManagement for more information.

See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.DisplayProfile Property

ImageViewerDisplayProfile Property

Gets or sets the ColorProfile of the display device.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile DisplayProfile { get; set; }
Public Property DisplayProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
The ColorProfile of the display device.
Remarks
Uses the color profile associated with the current display by default. If no profile is associated with it, the sRGB profile is used.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.Image Property

ImageViewerImage Property

Sets or returns the Image which is displayed in the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual AtalaImage Image { get; set; }
Public Overridable Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The Image which is displayed in the control.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.OutputProfile Property

ImageViewerOutputProfile Property

Gets or sets the color profile used for proofing images to a target device.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile OutputProfile { get; set; }
Public Property OutputProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
The color profile used for proofing images to a target device.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.ProofIntent Property

ImageViewerProofIntent Property

Gets or sets the rendering intent of the color transform used when proofing images.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent ProofIntent { get; set; }
Public Property ProofIntent As RenderingIntent
    Get
    Set

Property Value

Type: RenderingIntent
The rendering intent of the color transform used when proofing images.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.RenderingIntent Property

ImageViewerRenderingIntent Property

Gets or sets the rendering intent when transforming colors to the display device.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent RenderingIntent { get; set; }
Public Property RenderingIntent As RenderingIntent
    Get
    Set

Property Value

Type: RenderingIntent
The rendering intent when transforming colors to the display device.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer Methods

The ImageViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Overrides ViewportDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ViewportFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Returns the current image and indicates whether or not this image is a Bitmap. (Overrides ViewportGetCurrentImage(Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control. (Overrides ViewportGetScaledResolutionHeight.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAntialiasDisplayChanged | Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event.
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageChanged | Called when the Image property has changed and raises the ImageChanged event.
Protected method | OnImageDraw | This method is used to draw the image onto the Viewport graphics. (Overrides ViewportOnImageDraw(Rectangle, Rectangle, Graphics).)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to redraw itself. (Overrides ViewportOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event. (Inherited from Viewport.)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Removes any cached images used for fast displays and redraws the image. (Overrides ControlRefresh.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetNewImage | Called when the Image is being replaced.
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.Dispose Method

ImageViewerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Overrides ViewportDispose(Boolean).)
Top
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.Dispose Method (Boolean)

ImageViewerDispose Method (Boolean)

Disposes the object and releases any resources back to the system.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool isDisposing
)
Protected Overrides Sub Dispose (
    isDisposing As Boolean
)

Parameters

isDisposing
Type: SystemBoolean
A value indicating whether or not this method is called from the public Dispose(Boolean) method.
Remarks
Calling Dispose will automatically dispose the current Display Image.
See Also

Reference

ImageViewer Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


ImageViewer.Finalize Method

ImageViewerFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.GetCurrentImage Method

ImageViewerGetCurrentImage Method

Returns the current image and indicates whether or not this image is a Bitmap.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Object GetCurrentImage(
    ref bool isBitmapImage
)
Protected Overrides Function GetCurrentImage (
    ByRef isBitmapImage As Boolean
) As Object

Parameters

isBitmapImage
Type: SystemBoolean
Indicates whether this image is a Bitmap.

Return Value

Type: Object
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.GetScaledResolutionHeight Method

ImageViewerGetScaledResolutionHeight Method

checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override double GetScaledResolutionHeight()
Public Overrides Function GetScaledResolutionHeight As Double

Return Value

Type: Double
A ratio of the Dpi.X / Dpi.Y that is used for changing the display of images in the control.
Remarks
Having an unequal Dpi.X and Dpi.Y is common for some FAX images.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.OnAntialiasDisplayChanged Method

ImageViewerOnAntialiasDisplayChanged Method

Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAntialiasDisplayChanged(
    EventArgs e
)
Protected Overridable Sub OnAntialiasDisplayChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.OnImageChanged Method

ImageViewerOnImageChanged Method

Called when the Image property has changed and raises the ImageChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageChanged(
    ImageEventArgs e
)
Protected Overridable Sub OnImageChanged (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
An ImageEventArgs containing the new image.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.OnImageDraw Method

ImageViewerOnImageDraw Method

This method is used to draw the image onto the Viewport graphics.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnImageDraw(
    Rectangle sourceRectangle,
    Rectangle destRectangle,
    Graphics graphics
)
Protected Overrides Sub OnImageDraw (
    sourceRectangle As Rectangle,
    destRectangle As Rectangle,
    graphics As Graphics
)

Parameters

sourceRectangle
Type: System.DrawingRectangle
The Rectangle from the source image to draw from.
destRectangle
Type: System.DrawingRectangle
The Rectangle of the graphics to draw on.
graphics
Type: System.DrawingGraphics
The Graphics of the viewport to draw on.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.OnPaint Method

ImageViewerOnPaint Method

Called when the control needs to redraw itself.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs used for rendering the control.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.Refresh Method

ImageViewerRefresh Method

Removes any cached images used for fast displays and redraws the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
Remarks
This method should be called after modifying the AtalaImage directly, usually when using the drawing methods on the Canvas object.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.SetNewImage Method

ImageViewerSetNewImage Method

Called when the Image is being replaced.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetNewImage(
    AtalaImage newImage
)
Protected Sub SetNewImage (
    newImage As AtalaImage
)

Parameters

newImage
Type: Atalasoft.ImagingAtalaImage
The new image that will replace the current one.
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer Events

The ImageViewer type exposes the following members.

Events
 | Name | Description
Public event | AntialiasDisplayChanged | Occurs when AntialiasDisplay changes.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImageChanged | Occurs when commands are applied to change the image.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.AntialiasDisplayChanged Event

ImageViewerAntialiasDisplayChanged Event

Occurs when AntialiasDisplay changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AntialiasDisplayChanged
Public Event AntialiasDisplayChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ImageViewer.ImageChanged Event

ImageViewerImageChanged Event

Occurs when commands are applied to change the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageEventHandler ImageChanged
Public Event ImageChanged As ImageEventHandler

Value

Type: Atalasoft.ImagingImageEventHandler
See Also

Reference

ImageViewer Class
Atalasoft.Imaging.WinControls Namespace


ItemBounds Class

This class is used to hold positioning information for a single Thumbnail object.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsItemBounds

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ItemBounds
Public Class ItemBounds

The ItemBounds type exposes the following members.

Constructors
 | Name | Description
Public method | ItemBounds | Creates a new instance of ItemBounds.
Top
Properties
 | Name | Description
Public property | Caption | Gets or sets the rectangular area for the caption.
Public property | Entire | Gets or sets the bounding rectangle for the entire Thumbnail.
Public property | Image | Gets or sets the rectangular area where the image will be rendered.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The ItemBounds properties represent the position of the item relative to other items.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ItemBounds Constructor

Creates a new instance of ItemBounds.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemBounds()
Public Sub New
See Also

Reference

ItemBounds Class
Atalasoft.Imaging.WinControls Namespace


ItemBounds Properties

The ItemBounds type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Gets or sets the rectangular area for the caption.
Public property | Entire | Gets or sets the bounding rectangle for the entire Thumbnail.
Public property | Image | Gets or sets the rectangular area where the image will be rendered.
Top
See Also

Reference

ItemBounds Class
Atalasoft.Imaging.WinControls Namespace


ItemBounds.Caption Property

ItemBoundsCaption Property

Gets or sets the rectangular area for the caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Caption { get; set; }
Public Property Caption As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular area of the caption.
See Also

Reference

ItemBounds Class
Atalasoft.Imaging.WinControls Namespace


ItemBounds.Entire Property

ItemBoundsEntire Property

Gets or sets the bounding rectangle for the entire Thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Entire { get; set; }
Public Property Entire As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The bounding rectangle of the thumbnail.
See Also

Reference

ItemBounds Class
Atalasoft.Imaging.WinControls Namespace


ItemBounds.Image Property

ItemBoundsImage Property

Gets or sets the rectangular area where the image will be rendered.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Image { get; set; }
Public Property Image As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular area for the image.
See Also

Reference

ItemBounds Class
Atalasoft.Imaging.WinControls Namespace


ItemBounds Methods

The ItemBounds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ItemBounds Class
Atalasoft.Imaging.WinControls Namespace


LineRubberband Class

A line rubber-band that can be positioned with the mouse on a viewport control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.Imaging.WinControlsRubberband
Atalasoft.Imaging.WinControlsLineRubberband

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LineRubberband : Rubberband
Public Class LineRubberband
    Inherits Rubberband

The LineRubberband type exposes the following members.

Constructors
 | Name | Description
Public method | LineRubberband | Initializes a new instance of LineRubberband.
Public method | LineRubberband(Viewport) | Initializes a new instance of LineRubberband specifying the parent Viewport.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Inherited from Rubberband.)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns the region occupied by this rubberband. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Inherited from Rubberband.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event. (Inherited from Rubberband.)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event. (Inherited from Rubberband.)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
Remarks

Generally used for rendering or drawing lines onto an image.

Can be used as a component in the toolbox or instantiated directly.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace


LineRubberband Constructor

Initializes a new instance of LineRubberband.
Overload List
 | Name | Description
Public method | LineRubberband | Initializes a new instance of LineRubberband.
Public method | LineRubberband(Viewport) | Initializes a new instance of LineRubberband specifying the parent Viewport.
Top
See Also

Reference

LineRubberband Class
Atalasoft.Imaging.WinControls Namespace


LineRubberband Constructor

Initializes a new instance of LineRubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineRubberband()
Public Sub New
See Also

Reference

LineRubberband Class
LineRubberband Overload
Atalasoft.Imaging.WinControls Namespace


LineRubberband Constructor (Viewport)

Initializes a new instance of LineRubberband specifying the parent Viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineRubberband(
    Viewport parent
)
Public Sub New (
    parent As Viewport
)

Parameters

parent
Type: Atalasoft.Imaging.WinControlsViewport
The parent Viewport control.
See Also

Reference

LineRubberband Class
LineRubberband Overload
Atalasoft.Imaging.WinControls Namespace


LineRubberband Properties

The LineRubberband type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
See Also

Reference

LineRubberband Class
Atalasoft.Imaging.WinControls Namespace


LineRubberband Methods

The LineRubberband type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Inherited from Rubberband.)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns the region occupied by this rubberband. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Inherited from Rubberband.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event. (Inherited from Rubberband.)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event. (Inherited from Rubberband.)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

LineRubberband Class
Atalasoft.Imaging.WinControls Namespace


LineRubberband.GetRegion Method

LineRubberbandGetRegion Method

Returns the region occupied by this rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Region GetRegion()
Public Overrides Function GetRegion As Region

Return Value

Type: Region
The region of this rubberband.
See Also

Reference

LineRubberband Class
Atalasoft.Imaging.WinControls Namespace


LineRubberband.OnDrawRubberband Method

LineRubberbandOnDrawRubberband Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDrawRubberband(
    Canvas canvas,
    AtalaPen pen
)
Protected Overrides Sub OnDrawRubberband (
    canvas As Canvas,
    pen As AtalaPen
)

Parameters

canvas
Type: Atalasoft.Imaging.DrawingCanvas
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
See Also

Reference

LineRubberband Class
Atalasoft.Imaging.WinControls Namespace


LineRubberband Events

The LineRubberband type exposes the following members.

Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
See Also

Reference

LineRubberband Class
Atalasoft.Imaging.WinControls Namespace


LocDescriptionAttribute Class

For internal localization use only.
Inheritance Hierarchy
SystemObject
SystemAttribute
System.ComponentModelDescriptionAttribute
Atalasoft.Imaging.WinControlsLocDescriptionAttribute

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class LocDescriptionAttribute : DescriptionAttribute
Public NotInheritable Class LocDescriptionAttribute
    Inherits DescriptionAttribute

The LocDescriptionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LocDescriptionAttribute | Initializes a new instance of LocDescriptionAttribute.
Top
Properties
 | Name | Description
Public property | Description | (Overrides DescriptionAttributeDescription.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns whether the value of the given object is equal to the current DescriptionAttribute. (Inherited from DescriptionAttribute.)
Public method | GetHashCode | (Inherited from DescriptionAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Returns a value indicating whether this is the default DescriptionAttribute instance. (Inherited from DescriptionAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


LocDescriptionAttribute Constructor

Initializes a new instance of LocDescriptionAttribute.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LocDescriptionAttribute(
    string descriptionKey
)
Public Sub New (
    descriptionKey As String
)

Parameters

descriptionKey
Type: SystemString
See Also

Reference

LocDescriptionAttribute Class
Atalasoft.Imaging.WinControls Namespace


LocDescriptionAttribute Properties

The LocDescriptionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Description | (Overrides DescriptionAttributeDescription.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

LocDescriptionAttribute Class
Atalasoft.Imaging.WinControls Namespace


LocDescriptionAttribute.Description Property

LocDescriptionAttributeDescription Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

LocDescriptionAttribute Class
Atalasoft.Imaging.WinControls Namespace


LocDescriptionAttribute Methods

The LocDescriptionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns whether the value of the given object is equal to the current DescriptionAttribute. (Inherited from DescriptionAttribute.)
Public method | GetHashCode | (Inherited from DescriptionAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Returns a value indicating whether this is the default DescriptionAttribute instance. (Inherited from DescriptionAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocDescriptionAttribute Class
Atalasoft.Imaging.WinControls Namespace


Magnifier Class

The Magnifier is part of the ImageViewer control, and when selected in the MouseTool property it will display a magnified region of the image when holding the mouse button down.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsMagnifier

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Magnifier : IDisposable
Public Class Magnifier
    Implements IDisposable

The Magnifier type exposes the following members.

Constructors
 | Name | Description
Public method | Magnifier | Initializes a new instance of the Magnifier.
Public method | Magnifier(Viewport) | Initializes a new instance of the Magnifier specifying the parent viewport.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the magnifier is currently active and responding to mouse events.
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate the Magnifier.
Public property | BackColor | Gets or sets the background color of the magnifier.
Public property | BackgroundImage | Gets or sets the background image of the magnifier.
Public property | BorderColor | Gets or sets the color of the border around this Magnifier.
Public property | BorderWidth | Gets or sets the width of the border around this Magnifier.
Public property | Cursor | Gets or sets the cursor associated with the magnifier when active.
Public property | Parent | Gets or sets the parent Viewport control associated with this magnifier.
Public property | Size | Gets or sets the size of this Magnifier.
Public property | Zoom | Gets or sets the zoom level of the image in this Magnifier.
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up the ZoomWindow form resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace
Atalasoft.Imaging.WinControlsMagnifier


Magnifier Constructor

Initializes a new instance of Magnifier.
Overload List
 | Name | Description
Public method | Magnifier | Initializes a new instance of the Magnifier.
Public method | Magnifier(Viewport) | Initializes a new instance of the Magnifier specifying the parent viewport.
Top
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier Constructor

Initializes a new instance of the Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Magnifier()
Public Sub New
See Also

Reference

Magnifier Class
Magnifier Overload
Atalasoft.Imaging.WinControls Namespace


Magnifier Constructor (Viewport)

Initializes a new instance of the Magnifier specifying the parent viewport.
Initializes a new instance of the Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Magnifier(
    Viewport viewer
)
Public Sub New (
    viewer As Viewport
)

Parameters

viewer
Type: Atalasoft.Imaging.WinControlsViewport
The parent Viewport for this component.
See Also

Reference

Magnifier Class
Magnifier Overload
Atalasoft.Imaging.WinControls Namespace


Magnifier Properties

The Magnifier type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the magnifier is currently active and responding to mouse events.
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate the Magnifier.
Public property | BackColor | Gets or sets the background color of the magnifier.
Public property | BackgroundImage | Gets or sets the background image of the magnifier.
Public property | BorderColor | Gets or sets the color of the border around this Magnifier.
Public property | BorderWidth | Gets or sets the width of the border around this Magnifier.
Public property | Cursor | Gets or sets the cursor associated with the magnifier when active.
Public property | Parent | Gets or sets the parent Viewport control associated with this magnifier.
Public property | Size | Gets or sets the size of this Magnifier.
Public property | Zoom | Gets or sets the zoom level of the image in this Magnifier.
Top
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Active Property

MagnifierActive Property

Gets or sets a value indicating whether the magnifier is currently active and responding to mouse events.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the magnifier is currently active and responding to mouse events.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.ActiveMouseButton Property

MagnifierActiveMouseButton Property

Gets or sets the mouse button used to activate the Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButtons ActiveMouseButton { get; set; }
Public Property ActiveMouseButton As MouseButtons
    Get
    Set

Property Value

Type: MouseButtons
The mouse button used to activate the Magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.BackColor Property

MagnifierBackColor Property

Gets or sets the background color of the magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color of the magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.BackgroundImage Property

MagnifierBackgroundImage Property

Gets or sets the background image of the magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image BackgroundImage { get; set; }
Public Property BackgroundImage As Image
    Get
    Set

Property Value

Type: Image
The background image of the magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.BorderColor Property

MagnifierBorderColor Property

Gets or sets the color of the border around this Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set

Property Value

Type: Color
The color of the border around this Magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.BorderWidth Property

MagnifierBorderWidth Property

Gets or sets the width of the border around this Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BorderWidth { get; set; }
Public Property BorderWidth As Integer
    Get
    Set

Property Value

Type: Int32
The width of the border around this Magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Cursor Property

MagnifierCursor Property

Gets or sets the cursor associated with the magnifier when active.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor Cursor { get; set; }
Public Property Cursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor associated with the magnifier when active.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Parent Property

MagnifierParent Property

Gets or sets the parent Viewport control associated with this magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Viewport Parent { get; set; }
Public Property Parent As Viewport
    Get
    Set

Property Value

Type: Viewport
The parent Viewport control associated with this magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Size Property

MagnifierSize Property

Gets or sets the size of this Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The size of this Magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Zoom Property

MagnifierZoom Property

Gets or sets the zoom level of the image in this Magnifier.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
The zoom level of the image in this Magnifier.
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier Methods

The Magnifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up the ZoomWindow form resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Dispose Method

MagnifierDispose Method

Cleans up the ZoomWindow form resources.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Magnifier.Finalize Method

MagnifierFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Magnifier Class
Atalasoft.Imaging.WinControls Namespace


Margin Class

This class is used to define a margin area.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsMargin

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(MarginTypeConverter))]
public class Margin
<TypeConverterAttribute(GetType(MarginTypeConverter))>
Public Class Margin

The Margin type exposes the following members.

Constructors
 | Name | Description
Public method | Margin | Creates a new instance of Margin.
Public method | Margin(Int32) | Creates a new instance of Margin specifying a value for the properties.
Public method | Margin(Int32, Int32) | Creates a new instance of Margin specifying the horizontal and vertical values.
Public method | Margin(Int32, Int32, Int32, Int32) | Creates a new instance of Margin specifying the property values.
Top
Properties
 | Name | Description
Public property | Bottom | Gets the bottom margin value.
Public property | Left | Gets the left margin value.
Public property | Right | Gets the right margin value.
Public property | Top | Gets the top margin value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the Margin object. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Margin Constructor

Constructors for the Margin class.
Overload List
 | Name | Description
Public method | Margin | Creates a new instance of Margin.
Public method | Margin(Int32) | Creates a new instance of Margin specifying a value for the properties.
Public method | Margin(Int32, Int32) | Creates a new instance of Margin specifying the horizontal and vertical values.
Public method | Margin(Int32, Int32, Int32, Int32) | Creates a new instance of Margin specifying the property values.
Top
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin Constructor

Creates a new instance of Margin.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margin()
Public Sub New
See Also

Reference

Margin Class
Margin Overload
Atalasoft.Imaging.WinControls Namespace


Margin Constructor (Int32)

Creates a new instance of Margin specifying a value for the properties.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margin(
    int values
)
Public Sub New (
    values As Integer
)

Parameters

values
Type: SystemInt32
The value for each property.
See Also

Reference

Margin Class
Margin Overload
Atalasoft.Imaging.WinControls Namespace


Margin Constructor (Int32, Int32)

Creates a new instance of Margin specifying the horizontal and vertical values.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margin(
    int horizontal,
    int vertical
)
Public Sub New (
    horizontal As Integer,
    vertical As Integer
)

Parameters

horizontal
Type: SystemInt32
The value for the Left adn Right properties.
vertical
Type: SystemInt32
The value for the Top and Bottom properties.
See Also

Reference

Margin Class
Margin Overload
Atalasoft.Imaging.WinControls Namespace


Margin Constructor (Int32, Int32, Int32, Int32)

Creates a new instance of Margin specifying the property values.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margin(
    int left,
    int top,
    int right,
    int bottom
)
Public Sub New (
    left As Integer,
    top As Integer,
    right As Integer,
    bottom As Integer
)

Parameters

left
Type: SystemInt32
The left margin.
top
Type: SystemInt32
The top margin.
right
Type: SystemInt32
The right margin.
bottom
Type: SystemInt32
The bottom margin.
See Also

Reference

Margin Class
Margin Overload
Atalasoft.Imaging.WinControls Namespace


Margin Properties

The Margin type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | Gets the bottom margin value.
Public property | Left | Gets the left margin value.
Public property | Right | Gets the right margin value.
Public property | Top | Gets the top margin value.
Top
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin.Bottom Property

MarginBottom Property

Gets the bottom margin value.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Bottom { get; }
Public ReadOnly Property Bottom As Integer
    Get

Property Value

Type: Int32
The bottom margin.
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin.Left Property

MarginLeft Property

Gets the left margin value.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Left { get; }
Public ReadOnly Property Left As Integer
    Get

Property Value

Type: Int32
The left margin.
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin.Right Property

MarginRight Property

Gets the right margin value.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Right { get; }
Public ReadOnly Property Right As Integer
    Get

Property Value

Type: Int32
The right margin.
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin.Top Property

MarginTop Property

Gets the top margin value.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Top { get; }
Public ReadOnly Property Top As Integer
    Get

Property Value

Type: Int32
The top margin.
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin Methods

The Margin type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the Margin object. (Overrides ObjectToString.)
Top
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


Margin.ToString Method

MarginToString Method

Returns a string representation of the Margin object.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the Margin formatted as "Left, Top, Right, Bottom".
See Also

Reference

Margin Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter Class

This class is used by the designer, allowing Margin objects to be modified in the property grid.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelExpandableObjectConverter
Atalasoft.Imaging.WinControlsMarginTypeConverter

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MarginTypeConverter : ExpandableObjectConverter
Public Class MarginTypeConverter
    Inherits ExpandableObjectConverter

The MarginTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MarginTypeConverter | Creates a new instance of MarginTypeConverter.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Overrides TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter Constructor

Creates a new instance of MarginTypeConverter.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarginTypeConverter()
Public Sub New
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter Methods

The MarginTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Overrides TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.CanConvertFrom Method

MarginTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

MarginTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

MarginTypeConverter Class
CanConvertFrom Overload
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.CanConvertTo Method

MarginTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

MarginTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

MarginTypeConverter Class
CanConvertTo Overload
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.ConvertFrom Method

MarginTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

MarginTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

MarginTypeConverter Class
ConvertFrom Overload
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.ConvertTo Method

MarginTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

MarginTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

MarginTypeConverter Class
ConvertTo Overload
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.CreateInstance Method

MarginTypeConverterCreateInstance Method

Overload List
 | Name | Description
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverterCreateInstance(ITypeDescriptorContext, IDictionary).)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.CreateInstance Method (ITypeDescriptorContext, IDictionary)

MarginTypeConverterCreateInstance Method (ITypeDescriptorContext, IDictionary)

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Public Overrides Function CreateInstance (
    context As ITypeDescriptorContext,
    propertyValues As IDictionary
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
propertyValues
Type: System.CollectionsIDictionary

Return Value

Type: Object
See Also

Reference

MarginTypeConverter Class
CreateInstance Overload
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.GetCreateInstanceSupported Method

MarginTypeConverterGetCreateInstanceSupported Method

Overload List
 | Name | Description
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Overrides TypeConverterGetCreateInstanceSupported(ITypeDescriptorContext).)
Top
See Also

Reference

MarginTypeConverter Class
Atalasoft.Imaging.WinControls Namespace


MarginTypeConverter.GetCreateInstanceSupported Method (ITypeDescriptorContext)

MarginTypeConverterGetCreateInstanceSupported Method (ITypeDescriptorContext)

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetCreateInstanceSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: Boolean
See Also

Reference

MarginTypeConverter Class
GetCreateInstanceSupported Overload
Atalasoft.Imaging.WinControls Namespace


MouseToolType Enumeration

Specifies the Mouse Tool Type to use in the Viewport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MouseToolType
Public Enumeration MouseToolType
Members
Member name | Description
None | Specify no special mouse behavior.
Selection | Mouse will be set to crosshairs and can be used to drag and modify a Selection rectangle onto the image.
Pan | Dragging the mouse will Pan the image.
Magnifier | Display a magnifying glass when holding the mouse button down.
Zoom | Clicking on the image will zoom in with the left mouse button and zoom out with the right mouse button.
ZoomIn | Clicking will zoom in.
ZoomOut | Clicking will zoom out.
ZoomArea | Zoom in on a specified area defined by dragging a rectangle onto the image.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Class

This class holds information for an Open, Add or Insert method.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsOpenDocumentEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OpenDocumentEventArgs : EventArgs
Public Class OpenDocumentEventArgs
    Inherits EventArgs

The OpenDocumentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OpenDocumentEventArgs(AtalaImage) | Creates a new instance of OpenDocumentEventArgs specifying the image.
Public method | OpenDocumentEventArgs(Stream, Int32) | Creates a new instance of OpenDocumentEventArgs specifying the Stream.
Public method | OpenDocumentEventArgs(String, Int32) | Creates a new instance of OpenDocumentEventArgs specifying the filename.
Public method | OpenDocumentEventArgs(RandomAccessImageSource, Int32) | Creates a new instance of OpenDocumentEventArgs specifying the image source.
Top
Properties
 | Name | Description
Public property | FileName | Gets the filename passed into the Open, Add or Insert method.
Public property | FrameIndex | Gets the frame index passed into the Open, Add or Insert method.
Public property | Image | Gets the image passed into the Add or Insert method.
Public property | ImageSource | Gets the image source passed into the Open, Add or Insert method.
Public property | Stream | Gets the Stream passed into the Open, Add or Insert method.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Constructor

Constructs a new OpenDocumentEventArgs.
Overload List
 | Name | Description
Public method | OpenDocumentEventArgs(AtalaImage) | Creates a new instance of OpenDocumentEventArgs specifying the image.
Public method | OpenDocumentEventArgs(Stream, Int32) | Creates a new instance of OpenDocumentEventArgs specifying the Stream.
Public method | OpenDocumentEventArgs(String, Int32) | Creates a new instance of OpenDocumentEventArgs specifying the filename.
Public method | OpenDocumentEventArgs(RandomAccessImageSource, Int32) | Creates a new instance of OpenDocumentEventArgs specifying the image source.
Top
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Constructor (AtalaImage)

Creates a new instance of OpenDocumentEventArgs specifying the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OpenDocumentEventArgs(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image provided in the Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
OpenDocumentEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Constructor (Stream, Int32)

Creates a new instance of OpenDocumentEventArgs specifying the Stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OpenDocumentEventArgs(
    Stream stream,
    int frameIndex
)
Public Sub New (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
The Stream passed into the Open, Add or Insert method.
frameIndex
Type: SystemInt32
The frame index specified in the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
OpenDocumentEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Constructor (String, Int32)

Creates a new instance of OpenDocumentEventArgs specifying the filename.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OpenDocumentEventArgs(
    string fileName,
    int frameIndex
)
Public Sub New (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The filename passed into the Open, Add or Insert method.
frameIndex
Type: SystemInt32
The frame index specified in the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
OpenDocumentEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Constructor (RandomAccessImageSource, Int32)

Creates a new instance of OpenDocumentEventArgs specifying the image source.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OpenDocumentEventArgs(
    RandomAccessImageSource source,
    int frameIndex
)
Public Sub New (
    source As RandomAccessImageSource,
    frameIndex As Integer
)

Parameters

source
Type: Atalasoft.ImagingRandomAccessImageSource
The image source provided to the Open, Add or Insert method.
frameIndex
Type: SystemInt32
The frame index specified in the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
OpenDocumentEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Properties

The OpenDocumentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets the filename passed into the Open, Add or Insert method.
Public property | FrameIndex | Gets the frame index passed into the Open, Add or Insert method.
Public property | Image | Gets the image passed into the Add or Insert method.
Public property | ImageSource | Gets the image source passed into the Open, Add or Insert method.
Public property | Stream | Gets the Stream passed into the Open, Add or Insert method.
Top
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs.FileName Property

OpenDocumentEventArgsFileName Property

Gets the filename passed into the Open, Add or Insert method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The filename passed into the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs.FrameIndex Property

OpenDocumentEventArgsFrameIndex Property

Gets the frame index passed into the Open, Add or Insert method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameIndex { get; }
Public ReadOnly Property FrameIndex As Integer
    Get

Property Value

Type: Int32
The frame index passed into the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs.Image Property

OpenDocumentEventArgsImage Property

Gets the image passed into the Add or Insert method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
The image passed into the Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs.ImageSource Property

OpenDocumentEventArgsImageSource Property

Gets the image source passed into the Open, Add or Insert method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomAccessImageSource ImageSource { get; }
Public ReadOnly Property ImageSource As RandomAccessImageSource
    Get

Property Value

Type: RandomAccessImageSource
The image source passed into the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs.Stream Property

OpenDocumentEventArgsStream Property

Gets the Stream passed into the Open, Add or Insert method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
The Stream passed into the Open, Add or Insert method.
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenDocumentEventArgs Methods

The OpenDocumentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OpenDocumentEventArgs Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog Class

This class extends the OpenFileDialog by displaying an image preview that automatically updates as the user selects a file in the dialog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsCommonDialog
Atalasoft.Imaging.WinControlsOpenImageFileDialog

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OpenImageFileDialog : CommonDialog
Public Class OpenImageFileDialog
    Inherits CommonDialog

The OpenImageFileDialog type exposes the following members.

Constructors
 | Name | Description
Public method | OpenImageFileDialog | Creates a new instance of OpenImageFileDialog.
Top
Properties
 | Name | Description
Public property | AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
Public property | CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultExt | Gets or sets the default file name extension.
Public property | DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileName | Gets or sets a string containing the file name selected in the file dialog box.
Public property | FileNameBufferSize | Gets or sets the buffer size allocated for the filename field.
Public property | FileNames | Gets the file names of all selected files in the dialog box.
Public property | FileTitle | Gets or sets the filename of the selected file.
Public property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Files of type" box in the dialog box.
Public property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box.
Public property | InfoButtonImage | Gets or sets the image used in the 'Info' toolbar button.
Public property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public property | Multiselect | Gets or sets a value indicating whether the dialog box allows multiple files to be selected.
Public property | PreviewBorderStyle | Gets or sets the style of border used for the preview window.
Public property | PreviewButtonImage | Gets or sets the image used for the 'preview' toolbar button.
Public property | PreviewEnabled | Gets or sets a value indicating whether the preview window is enabled.
Public property | PreviewWidth | Gets or sets the width of the preview area.
Public property | ReadOnlyChecked | Gets or sets a value indicating whether the read-only check box is selected.
Public property | Resizable | Gets or sets a value indicating whether the dialog is resizable.
Public property | RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Public property | ShowHelp | Gets or sets a value indicating whether the Help button is displayed in the file dialog.
Public property | ShowImageInfoButton | Gets or sets a value indicating whether the "information" button is displayed in the dialog toolbar.
Public property | ShowPlacesBar | Gets or sets a value indicating whether to show the places bar in the dialog.
Public property | ShowPreviewButton | Gets or sets a value indicating whether to display the preview button in the dialog toolbar.
Public property | ShowReadOnly | Gets or sets a value indicating whether the dialog box contains a read-only check box.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog.)
Public property | Title | Gets or sets the file dialog box title.
Public property | ValidateNames | Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names.
Public property | View | Gets or sets the initial view style used by the OpenImageFileDialog.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookProc | Defines the common dialog box hook procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnHelpRequest | Raises the HelpRequest event. (Inherited from CommonDialog.)
Protected method | OwnerWndProc | Defines the owner window procedure that is overridden to add specific functionality to a common dialog box. (Overrides CommonDialogOwnerWndProc(IntPtr, Int32, IntPtr, IntPtr).)
Public method | Reset | Resets the property values to their default values. (Overrides CommonDialogReset.)
Protected method | RunDialog | Creates the command dialog. (Overrides CommonDialogRunDialog(IntPtr).)
Public method | ShowDialog | Runs a common dialog box with a default owner. (Inherited from CommonDialog.)
Public method | ShowDialog(IWin32Window) | Runs a common dialog box with the specified owner. (Inherited from CommonDialog.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileOk | Occurs when the user clicks on the Open button on the dialog box.
Public event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog.)
Public event | LoadPreviewException | Raised if there was an exception loading the preview image.
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog Constructor

Creates a new instance of OpenImageFileDialog.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OpenImageFileDialog()
Public Sub New
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog Properties

The OpenImageFileDialog type exposes the following members.

Properties
 | Name | Description
Public property | AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
Public property | CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultExt | Gets or sets the default file name extension.
Public property | DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileName | Gets or sets a string containing the file name selected in the file dialog box.
Public property | FileNameBufferSize | Gets or sets the buffer size allocated for the filename field.
Public property | FileNames | Gets the file names of all selected files in the dialog box.
Public property | FileTitle | Gets or sets the filename of the selected file.
Public property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Files of type" box in the dialog box.
Public property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box.
Public property | InfoButtonImage | Gets or sets the image used in the 'Info' toolbar button.
Public property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public property | Multiselect | Gets or sets a value indicating whether the dialog box allows multiple files to be selected.
Public property | PreviewBorderStyle | Gets or sets the style of border used for the preview window.
Public property | PreviewButtonImage | Gets or sets the image used for the 'preview' toolbar button.
Public property | PreviewEnabled | Gets or sets a value indicating whether the preview window is enabled.
Public property | PreviewWidth | Gets or sets the width of the preview area.
Public property | ReadOnlyChecked | Gets or sets a value indicating whether the read-only check box is selected.
Public property | Resizable | Gets or sets a value indicating whether the dialog is resizable.
Public property | RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Public property | ShowHelp | Gets or sets a value indicating whether the Help button is displayed in the file dialog.
Public property | ShowImageInfoButton | Gets or sets a value indicating whether the "information" button is displayed in the dialog toolbar.
Public property | ShowPlacesBar | Gets or sets a value indicating whether to show the places bar in the dialog.
Public property | ShowPreviewButton | Gets or sets a value indicating whether to display the preview button in the dialog toolbar.
Public property | ShowReadOnly | Gets or sets a value indicating whether the dialog box contains a read-only check box.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog.)
Public property | Title | Gets or sets the file dialog box title.
Public property | ValidateNames | Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names.
Public property | View | Gets or sets the initial view style used by the OpenImageFileDialog.
Top
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.AddExtension Property

OpenImageFileDialogAddExtension Property

Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AddExtension { get; set; }
Public Property AddExtension As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box adds an extension to a file name if the user omits the extension; otherwise, false. The default value is true.
Remarks

The extension added to a file name depends on the currently selected file filter and the value of the CheckFileExists property.

If the CheckFileExists property is true, the dialog box adds the first extension from the current file filter that matches an existing file. If no files match the current file filter, the dialog box adds the extension specified in the DefaultExt property.

If the CheckFileExists property is false, the dialog box adds the first valid file name extension from the current file filter. If the current file filter contains no valid file name extensions, the dialog box adds the extension specified in the DefaultExt property.

See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.CheckFileExists Property

OpenImageFileDialogCheckFileExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CheckFileExists { get; set; }
Public Property CheckFileExists As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the dialog box displays a warning when the user specifies a file name that does not exist; otherwise, false. The default value is true.

See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.CheckPathExists Property

OpenImageFileDialogCheckPathExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CheckPathExists { get; set; }
Public Property CheckPathExists As Boolean
    Get
    Set

Property Value

Type: Boolean

true if the dialog box displays a warning when the user specifies a path that does not exist; otherwise, false. The default value is true.

See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.DefaultExt Property

OpenImageFileDialogDefaultExt Property

Gets or sets the default file name extension.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultExt { get; set; }
Public Property DefaultExt As String
    Get
    Set

Property Value

Type: String
The default file name extension. The returned string does not include the period (.). The default value is an empty string("").
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.DereferenceLinks Property

OpenImageFileDialogDereferenceLinks Property

Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DereferenceLinks { get; set; }
Public Property DereferenceLinks As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box returns the location of the file referenced by the shortcut; otherwise, false. The default value is true.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.FileName Property

OpenImageFileDialogFileName Property

Gets or sets a string containing the file name selected in the file dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The file name selected in the file dialog box. The default value is an empty string ("").
Remarks

The file name includes both the file path and the extension. If no files are selected, this method returns an empty string ("").

This property can only be the name of one selected file. If you want to return an array containing the names of all selected files in a multiple-selection dialog box, use FileNames.

See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.FileNameBufferSize Property

OpenImageFileDialogFileNameBufferSize Property

Gets or sets the buffer size allocated for the filename field.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FileNameBufferSize { get; set; }
Public Property FileNameBufferSize As Integer
    Get
    Set

Property Value

Type: Int32
The buffer size allocated for the filename field. The default and minimum size is 1024.
Remarks
Increase this value if you need to select a large number of files at once.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.FileNames Property

OpenImageFileDialogFileNames Property

Gets the file names of all selected files in the dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] FileNames { get; }
Public ReadOnly Property FileNames As String()
    Get

Property Value

Type: String
An array of type String, containing the file names of all selected files in the dialog box.
Remarks
Each file name includes both the file path and the extension. If no files are selected, this method returns an empty array.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.FileTitle Property

OpenImageFileDialogFileTitle Property

Gets or sets the filename of the selected file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileTitle { get; set; }
Public Property FileTitle As String
    Get
    Set

Property Value

Type: String
The filename of the selected file.
Remarks
This does not include the path, only the filename is returned.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Filter Property

OpenImageFileDialogFilter Property

Gets or sets the current file name filter string, which determines the choices that appear in the "Files of type" box in the dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set

Property Value

Type: String
The file filtering options available in the dialog box.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.FilterIndex Property

OpenImageFileDialogFilterIndex Property

Gets or sets the index of the filter currently selected in the file dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilterIndex { get; set; }
Public Property FilterIndex As Integer
    Get
    Set

Property Value

Type: Int32
A value containing the index of the filter currently selected in the file dialog box. The default value is 1.
Remarks

Use the FilterIndex property to set which filtering option is shown first to the user. You can also use the value of FilterIndex after showing the file dialog to perform special file operations depending upon the filter chosen.

Note The index value of the first filter entry is 1.

See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.InfoButtonImage Property

OpenImageFileDialogInfoButtonImage Property

Gets or sets the image used in the 'Info' toolbar button.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image InfoButtonImage { get; set; }
Public Property InfoButtonImage As Image
    Get
    Set

Property Value

Type: Image
The image used for the 'Info' button.
Remarks
This image must be 16 x 16 pixels; with Magenta used for transparent areas.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.InitialDirectory Property

OpenImageFileDialogInitialDirectory Property

Gets or sets the initial directory displayed by the file dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string InitialDirectory { get; set; }
Public Property InitialDirectory As String
    Get
    Set

Property Value

Type: String
The initial directory displayed by the file dialog box. The default is an empty string ("").
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Multiselect Property

OpenImageFileDialogMultiselect Property

Gets or sets a value indicating whether the dialog box allows multiple files to be selected.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Multiselect { get; set; }
Public Property Multiselect As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box allows multiple files to be selected together or concurrently; otherwise, false. The default value is false.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.PreviewBorderStyle Property

OpenImageFileDialogPreviewBorderStyle Property

Gets or sets the style of border used for the preview window.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Border3DStyle PreviewBorderStyle { get; set; }
Public Property PreviewBorderStyle As Border3DStyle
    Get
    Set

Property Value

Type: Border3DStyle
The style of border used for the preview window.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.PreviewButtonImage Property

OpenImageFileDialogPreviewButtonImage Property

Gets or sets the image used for the 'preview' toolbar button.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image PreviewButtonImage { get; set; }
Public Property PreviewButtonImage As Image
    Get
    Set

Property Value

Type: Image
The image used for the 'preview' button.
Remarks
This image must be 16 x 16 pixels; with Magenta used for transparent areas.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.PreviewEnabled Property

OpenImageFileDialogPreviewEnabled Property

Gets or sets a value indicating whether the preview window is enabled.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PreviewEnabled { get; set; }
Public Property PreviewEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the preview window is enabled.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.PreviewWidth Property

OpenImageFileDialogPreviewWidth Property

Gets or sets the width of the preview area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PreviewWidth { get; set; }
Public Property PreviewWidth As Integer
    Get
    Set

Property Value

Type: Int32
The width of the preview area.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ReadOnlyChecked Property

OpenImageFileDialogReadOnlyChecked Property

Gets or sets a value indicating whether the read-only check box is selected.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ReadOnlyChecked { get; set; }
Public Property ReadOnlyChecked As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the read-only check box is selected; otherwise, false. The default value is false.
Remarks
The ShowReadOnly property must be set before in order for the read-only check box to appear in the dialog box.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Resizable Property

OpenImageFileDialogResizable Property

Gets or sets a value indicating whether the dialog is resizable.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Resizable { get; set; }
Public Property Resizable As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the dialog is resizable.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.RestoreDirectory Property

OpenImageFileDialogRestoreDirectory Property

Gets or sets a value indicating whether the dialog box restores the current directory before closing.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RestoreDirectory { get; set; }
Public Property RestoreDirectory As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box restores the current directory to its original value if the user changed the directory while searching for files; otherwise, false. The default value is false.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ShowHelp Property

OpenImageFileDialogShowHelp Property

Gets or sets a value indicating whether the Help button is displayed in the file dialog.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowHelp { get; set; }
Public Property ShowHelp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box includes a help button; otherwise, false. The default value is false.
Remarks
A System.Windows.Forms.HelpRequested event is raised when the user clicks the Help button.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ShowImageInfoButton Property

OpenImageFileDialogShowImageInfoButton Property

Gets or sets a value indicating whether the "information" button is displayed in the dialog toolbar.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowImageInfoButton { get; set; }
Public Property ShowImageInfoButton As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the "information" button is displayed.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ShowPlacesBar Property

OpenImageFileDialogShowPlacesBar Property

Gets or sets a value indicating whether to show the places bar in the dialog.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowPlacesBar { get; set; }
Public Property ShowPlacesBar As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether to show the places bar.
Remarks
This has no affect on Windows NT or 98 systems.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ShowPreviewButton Property

OpenImageFileDialogShowPreviewButton Property

Gets or sets a value indicating whether to display the preview button in the dialog toolbar.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowPreviewButton { get; set; }
Public Property ShowPreviewButton As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether to display the preview button.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ShowReadOnly Property

OpenImageFileDialogShowReadOnly Property

Gets or sets a value indicating whether the dialog box contains a read-only check box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowReadOnly { get; set; }
Public Property ShowReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box contains a read-only check box; otherwise, false. The default value is false.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Title Property

OpenImageFileDialogTitle Property

Gets or sets the file dialog box title.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The file dialog box title. The default value is an empty string ("").
Remarks
The string is placed in the title bar of the dialog box. If the title is an empty string, the system uses a default title of "Open".
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.ValidateNames Property

OpenImageFileDialogValidateNames Property

Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ValidateNames { get; set; }
Public Property ValidateNames As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dialog box accepts only valid Win32 file names; otherwise, false. The default value is true.
Remarks
If the edit control contains anything but spaces when the user clicks OK, the dialog returns the file name, whether it is valid or not. No default extension is added to the text.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.View Property

OpenImageFileDialogView Property

Gets or sets the initial view style used by the OpenImageFileDialog.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileDialogView View { get; set; }
Public Property View As FileDialogView
    Get
    Set

Property Value

Type: FileDialogView
The initial view style.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog Methods

The OpenImageFileDialog type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookProc | Defines the common dialog box hook procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnHelpRequest | Raises the HelpRequest event. (Inherited from CommonDialog.)
Protected method | OwnerWndProc | Defines the owner window procedure that is overridden to add specific functionality to a common dialog box. (Overrides CommonDialogOwnerWndProc(IntPtr, Int32, IntPtr, IntPtr).)
Public method | Reset | Resets the property values to their default values. (Overrides CommonDialogReset.)
Protected method | RunDialog | Creates the command dialog. (Overrides CommonDialogRunDialog(IntPtr).)
Public method | ShowDialog | Runs a common dialog box with a default owner. (Inherited from CommonDialog.)
Public method | ShowDialog(IWin32Window) | Runs a common dialog box with the specified owner. (Inherited from CommonDialog.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Dispose Method

OpenImageFileDialogDispose Method

Releases resources held by the object back to the system.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Dispose Method (Boolean)

OpenImageFileDialogDispose Method (Boolean)

Releases resources held by the object back to the system.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from the public Dispose method or the Finalizer.
See Also

Reference

OpenImageFileDialog Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Finalize Method

OpenImageFileDialogFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.OwnerWndProc Method

OpenImageFileDialogOwnerWndProc Method

Defines the owner window procedure that is overridden to add specific functionality to a common dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IntPtr OwnerWndProc(
    IntPtr hWnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
Protected Overrides Function OwnerWndProc (
    hWnd As IntPtr,
    msg As Integer,
    wparam As IntPtr,
    lparam As IntPtr
) As IntPtr

Parameters

hWnd
Type: SystemIntPtr
The window handle of the message to send.
msg
Type: SystemInt32
The Win32 message to send.
wparam
Type: SystemIntPtr
The wparam to send with the message.
lparam
Type: SystemIntPtr
The lparam to send with the message.

Return Value

Type: IntPtr
The result of the message processing, which is dependent on the message sent.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.Reset Method

OpenImageFileDialogReset Method

Resets the property values to their default values.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Reset()
Public Overrides Sub Reset
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.RunDialog Method

OpenImageFileDialogRunDialog Method

Creates the command dialog.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool RunDialog(
    IntPtr hwndOwner
)
Protected Overrides Function RunDialog (
    hwndOwner As IntPtr
) As Boolean

Parameters

hwndOwner
Type: SystemIntPtr
A value that represents the window handle of the owner window for the common dialog box.

Return Value

Type: Boolean
True if the dialog box was successfully run; otherwise, false.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog Events

The OpenImageFileDialog type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileOk | Occurs when the user clicks on the Open button on the dialog box.
Public event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog.)
Public event | LoadPreviewException | Raised if there was an exception loading the preview image.
Top
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.FileOk Event

OpenImageFileDialogFileOk Event

Occurs when the user clicks on the Open button on the dialog box.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CancelEventHandler FileOk
Public Event FileOk As CancelEventHandler

Value

Type: System.ComponentModelCancelEventHandler
Remarks
This event can be used to force the dialog to remain displayed if the file selected does not meet your requirements.
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


OpenImageFileDialog.LoadPreviewException Event

OpenImageFileDialogLoadPreviewException Event

Raised if there was an exception loading the preview image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ExceptionEventHandler LoadPreviewException
Public Event LoadPreviewException As ExceptionEventHandler

Value

Type: Atalasoft.ImagingExceptionEventHandler
See Also

Reference

OpenImageFileDialog Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs Class

Used with the EraseDropPositionIndicator and PaintDropPositionIndicator events to allow for custom drawing.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsPaintDropPositionIndicatorEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PaintDropPositionIndicatorEventArgs : EventArgs
Public Class PaintDropPositionIndicatorEventArgs
    Inherits EventArgs

The PaintDropPositionIndicatorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PaintDropPositionIndicatorEventArgs | Creates a new instance of PaintDropPositionIndicatorEventArgs.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the ItemBounds of the insert thumbnail.
Public property | DragArgs | Gets the DragEventArgs from the drag drop event.
Public property | Graphics | Gets the Graphics object used for drawing the indicator.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs Constructor

Creates a new instance of PaintDropPositionIndicatorEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PaintDropPositionIndicatorEventArgs(
    Graphics graphics,
    ItemBounds bounds,
    DragEventArgs dragArgs
)
Public Sub New (
    graphics As Graphics,
    bounds As ItemBounds,
    dragArgs As DragEventArgs
)

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object to draw with.
bounds
Type: Atalasoft.Imaging.WinControlsItemBounds
The ItemBounds of the insert thumbnail.
dragArgs
Type: System.Windows.FormsDragEventArgs
The DragEventArgs from the drag drop event.
See Also

Reference

PaintDropPositionIndicatorEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs Properties

The PaintDropPositionIndicatorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the ItemBounds of the insert thumbnail.
Public property | DragArgs | Gets the DragEventArgs from the drag drop event.
Public property | Graphics | Gets the Graphics object used for drawing the indicator.
Top
See Also

Reference

PaintDropPositionIndicatorEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs.Bounds Property

PaintDropPositionIndicatorEventArgsBounds Property

Gets the ItemBounds of the insert thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemBounds Bounds { get; }
Public ReadOnly Property Bounds As ItemBounds
    Get

Property Value

Type: ItemBounds
The ItemBounds of the insert thumbnail.
See Also

Reference

PaintDropPositionIndicatorEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs.DragArgs Property

PaintDropPositionIndicatorEventArgsDragArgs Property

Gets the DragEventArgs from the drag drop event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DragEventArgs DragArgs { get; }
Public ReadOnly Property DragArgs As DragEventArgs
    Get

Property Value

Type: DragEventArgs
The DragEventArgs from the drag drop event.
See Also

Reference

PaintDropPositionIndicatorEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs.Graphics Property

PaintDropPositionIndicatorEventArgsGraphics Property

Gets the Graphics object used for drawing the indicator.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get

Property Value

Type: Graphics
The Graphics object used for drawing the indicator.
See Also

Reference

PaintDropPositionIndicatorEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventArgs Methods

The PaintDropPositionIndicatorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PaintDropPositionIndicatorEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintDropPositionIndicatorEventHandler Delegate

Represents a method used to paint the DropPositionIndicator.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PaintDropPositionIndicatorEventHandler(
    Object sender,
    PaintDropPositionIndicatorEventArgs e
)
Public Delegate Sub PaintDropPositionIndicatorEventHandler (
    sender As Object,
    e As PaintDropPositionIndicatorEventArgs
)

Parameters

sender
Type: SystemObject
The object that sent the event.
e
Type: Atalasoft.Imaging.WinControlsPaintDropPositionIndicatorEventArgs
A PaintDropPositionIndicatorEventArgs containing information for this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs Class

This class is used with the PaintThumbnail event to allow custom thumbnail drawing.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsPaintThumbnailEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PaintThumbnailEventArgs : EventArgs
Public Class PaintThumbnailEventArgs
    Inherits EventArgs

The PaintThumbnailEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PaintThumbnailEventArgs | Creates a new instance of PaintThumbnailEventArgs.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of the thumbnail.
Public property | Graphics | Gets the Graphics object used for drawing.
Public property | ItemBounds | Gets item positioning information.
Public property | ScrollPosition | Gets the current scrollbar position.
Public property | Thumbnail | Gets the Thumbnail to be drawn.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs Constructor

Creates a new instance of PaintThumbnailEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PaintThumbnailEventArgs(
    Graphics graphics,
    Thumbnail thumbnail,
    ItemBounds itemBounds,
    Point scrollPosition,
    Rectangle bounds
)
Public Sub New (
    graphics As Graphics,
    thumbnail As Thumbnail,
    itemBounds As ItemBounds,
    scrollPosition As Point,
    bounds As Rectangle
)

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object used to draw with.
thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail being drawn.
itemBounds
Type: Atalasoft.Imaging.WinControlsItemBounds
An ItemBounds class containing positioning information for this Thumbnail.
scrollPosition
Type: System.DrawingPoint
The current scrollbar position.
bounds
Type: System.DrawingRectangle
The bounding rectangle of the thumbnail within the control.
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs Properties

The PaintThumbnailEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounding rectangle of the thumbnail.
Public property | Graphics | Gets the Graphics object used for drawing.
Public property | ItemBounds | Gets item positioning information.
Public property | ScrollPosition | Gets the current scrollbar position.
Public property | Thumbnail | Gets the Thumbnail to be drawn.
Top
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs.Bounds Property

PaintThumbnailEventArgsBounds Property

Gets the bounding rectangle of the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
A rectangle specifying the area of the control used for rendering this thumbnail, including the caption area.
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs.Graphics Property

PaintThumbnailEventArgsGraphics Property

Gets the Graphics object used for drawing.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get

Property Value

Type: Graphics
The Graphics object used to draw the thumbnail.
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs.ItemBounds Property

PaintThumbnailEventArgsItemBounds Property

Gets item positioning information.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemBounds ItemBounds { get; }
Public ReadOnly Property ItemBounds As ItemBounds
    Get

Property Value

Type: ItemBounds
An ItemBounds object containing positioning information.
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs.ScrollPosition Property

PaintThumbnailEventArgsScrollPosition Property

Gets the current scrollbar position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; }
Public ReadOnly Property ScrollPosition As Point
    Get

Property Value

Type: Point
The scrollbar position.
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs.Thumbnail Property

PaintThumbnailEventArgsThumbnail Property

Gets the Thumbnail to be drawn.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Thumbnail { get; }
Public ReadOnly Property Thumbnail As Thumbnail
    Get

Property Value

Type: Thumbnail
The Thumbnail object needing to be drawn.
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventArgs Methods

The PaintThumbnailEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PaintThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PaintThumbnailEventHandler Delegate

Represents a method that handles painting a single thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PaintThumbnailEventHandler(
    Object sender,
    PaintThumbnailEventArgs e
)
Public Delegate Sub PaintThumbnailEventHandler (
    sender As Object,
    e As PaintThumbnailEventArgs
)

Parameters

sender
Type: SystemObject
The object sending this event.
e
Type: Atalasoft.Imaging.WinControlsPaintThumbnailEventArgs
A PaintThumbnailEventArgs containing information used for rendering the thumbnail.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs Class

Provides data for the PrintImage event in the ImageCompositePrintDocument class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.Drawing.PrintingPrintPageEventArgs
Atalasoft.Imaging.WinControlsPrintCompositeEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PrintCompositeEventArgs : PrintPageEventArgs
Public Class PrintCompositeEventArgs
    Inherits PrintPageEventArgs

The PrintCompositeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PrintCompositeEventArgs | Instantiates a new instance of PrintCompositeEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the print job should be canceled. (Inherited from PrintPageEventArgs.)
Public property | Caption | Gets or sets the caption to be printed beneath the image.
Public property | CompositeIndex | Gets the index of the image on the specific page.
Public property | Graphics | Gets the Graphics used to paint the page. (Inherited from PrintPageEventArgs.)
Public property | HasMorePages | Gets or sets a value indicating whether an additional page should be printed. (Inherited from PrintPageEventArgs.)
Public property | Image | Gets or sets the image to print.
Public property | ImageBounds | Gets or sets the position and size of the image on the page that will be printed.
Public property | ImageIndex | Gets the index of the image that is about to print.
Public property | MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins. (Inherited from PrintPageEventArgs.)
 | MinMargins | Gets the minimum margins (in pixels) for the printer being used.
Public property | PageBounds | Gets the rectangular area that represents the total area of the page. (Inherited from PrintPageEventArgs.)
Public property | PageSettings | Gets the page settings for the current page. (Inherited from PrintPageEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs Constructor

Instantiates a new instance of PrintCompositeEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PrintCompositeEventArgs(
    Graphics graphics,
    Rectangle marginBounds,
    Rectangle pageBounds,
    PageSettings pageSettings
)
Public Sub New (
    graphics As Graphics,
    marginBounds As Rectangle,
    pageBounds As Rectangle,
    pageSettings As PageSettings
)

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object associated with the printer.
marginBounds
Type: System.DrawingRectangle
The area within the margins.
pageBounds
Type: System.DrawingRectangle
The bounds of the page.
pageSettings
Type: System.Drawing.PrintingPageSettings
The PageSettings object associated with the print job.
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs Properties

The PrintCompositeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the print job should be canceled. (Inherited from PrintPageEventArgs.)
Public property | Caption | Gets or sets the caption to be printed beneath the image.
Public property | CompositeIndex | Gets the index of the image on the specific page.
Public property | Graphics | Gets the Graphics used to paint the page. (Inherited from PrintPageEventArgs.)
Public property | HasMorePages | Gets or sets a value indicating whether an additional page should be printed. (Inherited from PrintPageEventArgs.)
Public property | Image | Gets or sets the image to print.
Public property | ImageBounds | Gets or sets the position and size of the image on the page that will be printed.
Public property | ImageIndex | Gets the index of the image that is about to print.
Public property | MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins. (Inherited from PrintPageEventArgs.)
 | MinMargins | Gets the minimum margins (in pixels) for the printer being used.
Public property | PageBounds | Gets the rectangular area that represents the total area of the page. (Inherited from PrintPageEventArgs.)
Public property | PageSettings | Gets the page settings for the current page. (Inherited from PrintPageEventArgs.)
Top
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs.Caption Property

PrintCompositeEventArgsCaption Property

Gets or sets the caption to be printed beneath the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String
The caption to be printed beneath the image.
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs.CompositeIndex Property

PrintCompositeEventArgsCompositeIndex Property

Gets the index of the image on the specific page.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CompositeIndex { get; }
Public ReadOnly Property CompositeIndex As Integer
    Get

Property Value

Type: Int32
The index of the image on the specific page.
Remarks
This is the zero based index of the image, usually printed from left to right, top to bottom, but in the case of landscape, the order is bottom to top, left to right.
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs.Image Property

PrintCompositeEventArgsImage Property

Gets or sets the image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image to print.
Remarks
This property must be set to an AtalaImage object, or nothing will be printed.
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs.ImageBounds Property

PrintCompositeEventArgsImageBounds Property

Gets or sets the position and size of the image on the page that will be printed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ImageBounds { get; set; }
Public Property ImageBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The position and size of the image on the page that will be printed.
Remarks
This value can be modified to change the location and size of the printed image. However the value works independently of orientation. The ImageBounds will be rotated 90 degrees prior to printing with landscape orientations.
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs.ImageIndex Property

PrintCompositeEventArgsImageIndex Property

Gets the index of the image that is about to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ImageIndex { get; }
Public ReadOnly Property ImageIndex As Integer
    Get

Property Value

Type: Int32
The index of the image that is about to print.
Remarks
This is the image number (minus one).
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventArgs.MinMargins Property

PrintCompositeEventArgsMinMargins Property

Gets the minimum margins (in pixels) for the printer being used.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margins MinMargins { get; }
Public ReadOnly Property MinMargins As Margins
    Get

Property Value

Type: Margins
The minimum margins for the printer being used.
Remarks
This property was added because the MinMargins property in the PageSetupDialog does not work.
Examples
[New Example] (neutral)
Copy
  Examples
 MinMargins Property
  See Also
Reference
PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace
Copyright 2000-2023 Kofax. All rights reserved.
Send comments on this topic to
        Atalasoft Development Team


PrintCompositeEventArgs Methods

The PrintCompositeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PrintCompositeEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintCompositeEventHandler Delegate

Represents the method that handles the AfterPrintImage and PrintImage events of the ImageCompositePrintDocument class.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PrintCompositeEventHandler(
    Object sender,
    PrintCompositeEventArgs e
)
Public Delegate Sub PrintCompositeEventHandler (
    sender As Object,
    e As PrintCompositeEventArgs
)

Parameters

sender
Type: SystemObject
The ImageCompositePrintDocument raising this event.
e
Type: Atalasoft.Imaging.WinControlsPrintCompositeEventArgs
A PrintCompositeEventArgs containing information about this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs Class

Provides data for the AfterPrintPage, GetImage and PrintImage events of ImagePrintDocument.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.Drawing.PrintingPrintPageEventArgs
Atalasoft.Imaging.WinControlsPrintImageEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PrintImageEventArgs : PrintPageEventArgs
Public Class PrintImageEventArgs
    Inherits PrintPageEventArgs

The PrintImageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PrintImageEventArgs | Creates a new instance of PrintImageEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the print job should be canceled. (Inherited from PrintPageEventArgs.)
Public property | DestRectangle | Gets or sets the destination rectangle.
Public property | Graphics | Gets the Graphics used to paint the page. (Inherited from PrintPageEventArgs.)
Public property | HasMorePages | Gets or sets a value indicating whether an additional page should be printed. (Inherited from PrintPageEventArgs.)
Public property | Image | Gets or sets the image to print.
Public property | ImageIndex | Gets or sets the current image being printed.
Public property | MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins. (Inherited from PrintPageEventArgs.)
 | MinMargins | Gets the minimum margins (in pixels) for the printer being used.
Public property | PageBounds | Gets the rectangular area that represents the total area of the page. (Inherited from PrintPageEventArgs.)
Public property | PageSettings | Gets the page settings for the current page. (Inherited from PrintPageEventArgs.)
Public property | SourceRectangle | Gets or sets the source rectangle of the image to print.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class is used by ImagePrintDocument to allow images to be printed in a single print job without having to load all of the images at once.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs Constructor

Creates a new instance of PrintImageEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PrintImageEventArgs(
    Graphics graphics,
    Rectangle marginBounds,
    Rectangle pageBounds,
    PageSettings pageSettings
)
Public Sub New (
    graphics As Graphics,
    marginBounds As Rectangle,
    pageBounds As Rectangle,
    pageSettings As PageSettings
)

Parameters

graphics
Type: System.DrawingGraphics
The graphics object associated with the print job.
marginBounds
Type: System.DrawingRectangle
The area within the margins.
pageBounds
Type: System.DrawingRectangle
The bounds of the page.
pageSettings
Type: System.Drawing.PrintingPageSettings
The PageSettings object associated with the print job.
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs Properties

The PrintImageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the print job should be canceled. (Inherited from PrintPageEventArgs.)
Public property | DestRectangle | Gets or sets the destination rectangle.
Public property | Graphics | Gets the Graphics used to paint the page. (Inherited from PrintPageEventArgs.)
Public property | HasMorePages | Gets or sets a value indicating whether an additional page should be printed. (Inherited from PrintPageEventArgs.)
Public property | Image | Gets or sets the image to print.
Public property | ImageIndex | Gets or sets the current image being printed.
Public property | MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins. (Inherited from PrintPageEventArgs.)
 | MinMargins | Gets the minimum margins (in pixels) for the printer being used.
Public property | PageBounds | Gets the rectangular area that represents the total area of the page. (Inherited from PrintPageEventArgs.)
Public property | PageSettings | Gets the page settings for the current page. (Inherited from PrintPageEventArgs.)
Public property | SourceRectangle | Gets or sets the source rectangle of the image to print.
Top
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs.DestRectangle Property

PrintImageEventArgsDestRectangle Property

Gets or sets the destination rectangle.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle DestRectangle { get; set; }
Public Property DestRectangle As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The destination rectangle.
Remarks
This rectangle can be used to modify the position and size of the image on the printed page. This should only be modified in the PrintImage event.
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace
PrintImageEventArgsSourceRectangle


PrintImageEventArgs.Image Property

PrintImageEventArgsImage Property

Gets or sets the image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image to print.
Remarks
Setting this to null (Nothing in Visual Basic) will inform the ImagePrintDocument that there are no more images to print.
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs.ImageIndex Property

PrintImageEventArgsImageIndex Property

Gets or sets the current image being printed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ImageIndex { get; set; }
Public Property ImageIndex As Integer
    Get
    Set

Property Value

Type: Int32
The current image being printed.
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs.MinMargins Property

PrintImageEventArgsMinMargins Property

Gets the minimum margins (in pixels) for the printer being used.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margins MinMargins { get; }
Public ReadOnly Property MinMargins As Margins
    Get

Property Value

Type: Margins
The minimum margins for the printer being used.
Remarks
This property was added because the MinMargins property in the PageSetupDialog does not work.
Examples
MinMargins (C#)
Copy
private void imagePrintDocument1_PrintImage(object sender, Atalasoft.Imaging.WinControls.PrintImageEventArgs e)
{
     imagePrintDocument1.DefaultPageSettings.Margins = e.MinMargins;
}
MinMargins (Visual Basic)
Copy
Private Sub imagePrintDocument1_PrintImage(ByVal sender As Object, ByVal e As Atalasoft.Imaging.WinControls.PrintImageEventArgs)
     imagePrintDocument1.DefaultPageSettings.Margins = e.MinMargins
End Sub
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintImageEventArgs.SourceRectangle Property

PrintImageEventArgsSourceRectangle Property

Gets or sets the source rectangle of the image to print.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle SourceRectangle { get; set; }
Public Property SourceRectangle As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The source rectangle of the image to print.
Remarks
This can be used to modify the area of the image to print. This property should only be modified in the PrintImage event.
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace
PrintImageEventArgsDestRectangle


PrintImageEventArgs Methods

The PrintImageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PrintImageEventArgs Class
Atalasoft.Imaging.WinControls Namespace


PrintImageEventHandler Delegate

Represents the method that will handle the AfterPrintPage, GetImage and PrintImage events of ImagePrintDocument.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PrintImageEventHandler(
    Object sender,
    PrintImageEventArgs e
)
Public Delegate Sub PrintImageEventHandler (
    sender As Object,
    e As PrintImageEventArgs
)

Parameters

sender
Type: SystemObject
The ImagePrintDocument raising this event.
e
Type: Atalasoft.Imaging.WinControlsPrintImageEventArgs
A PrintImageEventArgs containing information about this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


PrintScaleMode Enumeration

Specifies the type of scaling used when printing an image with ImagePrintDocument.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PrintScaleMode
Public Enumeration PrintScaleMode
Members
Member name | Description
None | No scaling is done, other than to match the image resolution with the printer resolution.
FitToMargins | The image is resized to fit within the page margins.
FitToEdges | The image is resized to fill the page. However, most printers will not print beyond their minimum margins.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


RectangleRubberband Class

A rectangular rubber-band that can be positioned with the mouse on a viewport control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.Imaging.WinControlsRubberband
Atalasoft.Imaging.WinControlsRectangleRubberband

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RectangleRubberband : Rubberband
Public Class RectangleRubberband
    Inherits Rubberband

The RectangleRubberband type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleRubberband | Initializes a new instance of RectangleRubberband.
Public method | RectangleRubberband(Viewport) | Initializes a new instance of RectangleRubberband specifying the parent Viewport.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CornerRadius | Gets or sets the rounding radius of each corner in pixels.
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Fill | Gets or sets a Fill that is used to fill the inside of the rectangle.
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Inherited from Rubberband.)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns the rectangular region occupied by this rubberband. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Inherited from Rubberband.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event. (Inherited from Rubberband.)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event. (Inherited from Rubberband.)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
Remarks

This object is used to select a rectangular region in an image for cropping, zooming, and applying a command on a rectangular region as well as drawing rectangles onto an image.

Can be used as a component in the toolbox or instantiated directly.

See RectangleSelection for an object deriving from RectangleRubberBand that can be resized once created.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace
Atalasoft.Imaging.WinControlsRectangleSelection


RectangleRubberband Constructor

Overload List
 | Name | Description
Public method | RectangleRubberband | Initializes a new instance of RectangleRubberband.
Public method | RectangleRubberband(Viewport) | Initializes a new instance of RectangleRubberband specifying the parent Viewport.
Top
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband Constructor

Initializes a new instance of RectangleRubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleRubberband()
Public Sub New
See Also

Reference

RectangleRubberband Class
RectangleRubberband Overload
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband Constructor (Viewport)

Initializes a new instance of RectangleRubberband specifying the parent Viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleRubberband(
    Viewport parent
)
Public Sub New (
    parent As Viewport
)

Parameters

parent
Type: Atalasoft.Imaging.WinControlsViewport
The parent Viewport control.
See Also

Reference

RectangleRubberband Class
RectangleRubberband Overload
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband Properties

The RectangleRubberband type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CornerRadius | Gets or sets the rounding radius of each corner in pixels.
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Fill | Gets or sets a Fill that is used to fill the inside of the rectangle.
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband.CornerRadius Property

RectangleRubberbandCornerRadius Property

Gets or sets the rounding radius of each corner in pixels.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size CornerRadius { get; set; }
Public Property CornerRadius As Size
    Get
    Set

Property Value

Type: Size
The rounding radius of each corner in pixels.
Remarks
Set to Size.Empty for sharp corners.
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband.Fill Property

RectangleRubberbandFill Property

Gets or sets a Fill that is used to fill the inside of the rectangle.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Fill Fill { get; set; }
Public Property Fill As Fill
    Get
    Set

Property Value

Type: Fill
A Fill that is used to fill the inside of the rectangle.
Remarks
When this value is null, the rectangle is unfilled.
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband Methods

The RectangleRubberband type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Inherited from Rubberband.)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns the rectangular region occupied by this rubberband. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Inherited from Rubberband.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event. (Inherited from Rubberband.)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband. (Inherited from Rubberband.)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event. (Inherited from Rubberband.)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband.GetRegion Method

RectangleRubberbandGetRegion Method

Returns the rectangular region occupied by this rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Region GetRegion()
Public Overrides Function GetRegion As Region

Return Value

Type: Region
The region of this rubberband.
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband.OnDrawRubberband Method

RectangleRubberbandOnDrawRubberband Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDrawRubberband(
    Canvas canvas,
    AtalaPen pen
)
Protected Overrides Sub OnDrawRubberband (
    canvas As Canvas,
    pen As AtalaPen
)

Parameters

canvas
Type: Atalasoft.Imaging.DrawingCanvas
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleRubberband Events

The RectangleRubberband type exposes the following members.

Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
See Also

Reference

RectangleRubberband Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection Class

A rectangular selection that can be positioned and moved with the mouse on a viewport control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.Imaging.WinControlsRubberband
Atalasoft.Imaging.WinControlsRectangleSelection

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RectangleSelection : Rubberband
Public Class RectangleSelection
    Inherits Rubberband

The RectangleSelection type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleSelection | Initializes a new instance of RectangleSelection.
Public method | RectangleSelection(Viewport) | Initializes a new instance of RectangleSelection specifying the parent Viewport.
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | Animated | Gets or sets a valid indicating if the selection is animated.
Public property | AnimationSpeed | Gets or sets the animation speed in milliseconds.
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | SelectionNESWCursor | Gets or sets the cursor displayed when resizing the top-right or bottom-left corners of the selection.
Public property | SelectionNSCursor | Gets or sets the cursor displayed when resizing the top or bottom edges of the selection.
Public property | SelectionNWSECursor | Gets or sets the cursor displayed when resizing the top-left or bottom-right corners of the selection.
Public property | SelectionWECursor | Gets or sets the cursor displayed when resizing the left or right edges of the selection.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides RubberbandDispose(Boolean).)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns a rectangular region occupied by this selection. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Overrides RubberbandHitTest(Point, Boolean).)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | (Overrides RubberbandOnActiveChanged(EventArgs).)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | (Overrides RubberbandOnMouseDown(MouseEventArgs).)
Protected method | OnMouseMove | (Overrides RubberbandOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides RubberbandOnMouseUp(MouseEventArgs).)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | (Overrides RubberbandOnVisibleChanged(EventArgs).)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
Remarks

This object is used to select a rectangular region in an image for cropping, zooming, and applying a command on a rectangular region. By default is will display as an animated, black and white selection.

The RectangleSelection can be used as a component in the toolbox or instantiated directly.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace


RectangleSelection Constructor

Overload List
 | Name | Description
Public method | RectangleSelection | Initializes a new instance of RectangleSelection.
Public method | RectangleSelection(Viewport) | Initializes a new instance of RectangleSelection specifying the parent Viewport.
Top
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection Constructor

Initializes a new instance of RectangleSelection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleSelection()
Public Sub New
See Also

Reference

RectangleSelection Class
RectangleSelection Overload
Atalasoft.Imaging.WinControls Namespace


RectangleSelection Constructor (Viewport)

Initializes a new instance of RectangleSelection specifying the parent Viewport.
Initializes a new instance of RectangleSelection

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleSelection(
    Viewport parent
)
Public Sub New (
    parent As Viewport
)

Parameters

parent
Type: Atalasoft.Imaging.WinControlsViewport
The parent Viewport control.
See Also

Reference

RectangleSelection Class
RectangleSelection Overload
Atalasoft.Imaging.WinControls Namespace


RectangleSelection Properties

The RectangleSelection type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control. (Inherited from Rubberband.)
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband. (Inherited from Rubberband.)
Public property | Animated | Gets or sets a valid indicating if the selection is animated.
Public property | AnimationSpeed | Gets or sets the animation speed in milliseconds.
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to. (Inherited from Rubberband.)
Public property | BackgroundColor | Gets or sets the background color of a dashed line. (Inherited from Rubberband.)
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates. (Inherited from Rubberband.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband. (Inherited from Rubberband.)
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area. (Inherited from Rubberband.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active. (Inherited from Rubberband.)
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection. (Inherited from Rubberband.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner. (Inherited from Rubberband.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted. (Inherited from Rubberband.)
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged. (Inherited from Rubberband.)
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband. (Inherited from Rubberband.)
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse. (Inherited from Rubberband.)
Public property | Parent | Gets or sets the parent ViewPort control. (Inherited from Rubberband.)
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband. (Inherited from Rubberband.)
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released. (Inherited from Rubberband.)
Public property | SelectionNESWCursor | Gets or sets the cursor displayed when resizing the top-right or bottom-left corners of the selection.
Public property | SelectionNSCursor | Gets or sets the cursor displayed when resizing the top or bottom edges of the selection.
Public property | SelectionNWSECursor | Gets or sets the cursor displayed when resizing the top-left or bottom-right corners of the selection.
Public property | SelectionWECursor | Gets or sets the cursor displayed when resizing the left or right edges of the selection.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel. (Inherited from Rubberband.)
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner. (Inherited from Rubberband.)
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible. (Inherited from Rubberband.)
Top
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.Animated Property

RectangleSelectionAnimated Property

Gets or sets a valid indicating if the selection is animated.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Animated { get; set; }
Public Property Animated As Boolean
    Get
    Set

Property Value

Type: Boolean
A valid indicating if the selection is animated.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.AnimationSpeed Property

RectangleSelectionAnimationSpeed Property

Gets or sets the animation speed in milliseconds.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AnimationSpeed { get; set; }
Public Property AnimationSpeed As Integer
    Get
    Set

Property Value

Type: Int32
The animation speed in milliseconds.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.SelectionNESWCursor Property

RectangleSelectionSelectionNESWCursor Property

Gets or sets the cursor displayed when resizing the top-right or bottom-left corners of the selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor SelectionNESWCursor { get; set; }
Public Property SelectionNESWCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor displayed when resizing the top-right or bottom-left corners of the selection.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.SelectionNSCursor Property

RectangleSelectionSelectionNSCursor Property

Gets or sets the cursor displayed when resizing the top or bottom edges of the selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor SelectionNSCursor { get; set; }
Public Property SelectionNSCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor displayed when resizing the top or bottom edges of the selection.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.SelectionNWSECursor Property

RectangleSelectionSelectionNWSECursor Property

Gets or sets the cursor displayed when resizing the top-left or bottom-right corners of the selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor SelectionNWSECursor { get; set; }
Public Property SelectionNWSECursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor displayed when resizing the top-left or bottom-right corners of the selection.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.SelectionWECursor Property

RectangleSelectionSelectionWECursor Property

Gets or sets the cursor displayed when resizing the left or right edges of the selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor SelectionWECursor { get; set; }
Public Property SelectionWECursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor displayed when resizing the left or right edges of the selection.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection Methods

The RectangleSelection type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband. (Inherited from Rubberband.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides RubberbandDispose(Boolean).)
Protected method | DrawRegion | Called when a region needs to be drawn. (Inherited from Rubberband.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region. (Inherited from Rubberband.)
Protected method | Finalize | (Inherited from Rubberband.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid. (Inherited from Rubberband.)
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates. (Inherited from Rubberband.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Returns a rectangular region occupied by this selection. (Overrides RubberbandGetRegion.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary. (Overrides RubberbandHitTest(Point, Boolean).)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event. (Inherited from Rubberband.)
Protected method | OnActiveChanged | (Overrides RubberbandOnActiveChanged(EventArgs).)
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event. (Inherited from Rubberband.)
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event. (Inherited from Rubberband.)
Protected method | OnChanged | Called when the Rubberband has changed. (Inherited from Rubberband.)
Protected method | OnChanging | Called when the Rubberband is in the process of changing. (Inherited from Rubberband.)
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event. (Inherited from Rubberband.)
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event. (Inherited from Rubberband.)
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event. (Inherited from Rubberband.)
Protected method | OnDrawRubberband | (Overrides RubberbandOnDrawRubberband(Canvas, AtalaPen).)
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event. (Inherited from Rubberband.)
Protected method | OnMouseDown | (Overrides RubberbandOnMouseDown(MouseEventArgs).)
Protected method | OnMouseMove | (Overrides RubberbandOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides RubberbandOnMouseUp(MouseEventArgs).)
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event. (Inherited from Rubberband.)
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event. (Inherited from Rubberband.)
Protected method | OnPaint | Called when the Rubberband needs to be painted. (Inherited from Rubberband.)
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event. (Inherited from Rubberband.)
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event. (Inherited from Rubberband.)
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event. (Inherited from Rubberband.)
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event. (Inherited from Rubberband.)
Protected method | OnVisibleChanged | (Overrides RubberbandOnVisibleChanged(EventArgs).)
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position. (Inherited from Rubberband.)
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position. (Inherited from Rubberband.)
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates. (Inherited from Rubberband.)
Public method | Start | Programmatically starts a new rubberband without user interaction. (Inherited from Rubberband.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.Dispose Method

RectangleSelectionDispose Method

Releases resources held by the object back to the system.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides RubberbandDispose(Boolean).)
Top
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.Dispose Method (Boolean)

RectangleSelectionDispose Method (Boolean)

Releases resources held by the object back to the system.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool isDisposing
)
Protected Overrides Sub Dispose (
    isDisposing As Boolean
)

Parameters

isDisposing
Type: SystemBoolean
Indicates whether this method was called from the public Dispose method or the Finalizer.
See Also

Reference

RectangleSelection Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.GetRegion Method

RectangleSelectionGetRegion Method

Returns a rectangular region occupied by this selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override Region GetRegion()
Public Overrides Function GetRegion As Region

Return Value

Type: Region
A region for this selection.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.HitTest Method

RectangleSelectionHitTest Method

Returns a value indicating if the position is within the RubberBand boundary.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool HitTest(
    Point position,
    bool ImageCoordinates
)
Public Overrides Function HitTest (
    position As Point,
    ImageCoordinates As Boolean
) As Boolean

Parameters

position
Type: System.DrawingPoint
The position to test.
ImageCoordinates
Type: SystemBoolean
If true, position is in image coordinates otherwise position is in display coordinates.

Return Value

Type: Boolean
A value indicating if the position is within the RubberBand boundary.
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.OnActiveChanged Method

RectangleSelectionOnActiveChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnActiveChanged(
    EventArgs e
)
Protected Overrides Sub OnActiveChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.OnDrawRubberband Method

RectangleSelectionOnDrawRubberband Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDrawRubberband(
    Canvas canvas,
    AtalaPen pen
)
Protected Overrides Sub OnDrawRubberband (
    canvas As Canvas,
    pen As AtalaPen
)

Parameters

canvas
Type: Atalasoft.Imaging.DrawingCanvas
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.OnMouseDown Method

RectangleSelectionOnMouseDown Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.OnMouseMove Method

RectangleSelectionOnMouseMove Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.OnMouseUp Method

RectangleSelectionOnMouseUp Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection.OnVisibleChanged Method

RectangleSelectionOnVisibleChanged Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


RectangleSelection Events

The RectangleSelection type exposes the following members.

Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes. (Inherited from Rubberband.)
Public event | ActiveChanged | Occurs when Active changes. (Inherited from Rubberband.)
Public event | AspectRatioChanged | Occurs when AspectRatio changes. (Inherited from Rubberband.)
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes. (Inherited from Rubberband.)
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event). (Inherited from Rubberband.)
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event). (Inherited from Rubberband.)
Public event | ClickLockChanged | Occurs when ClickLock changes. (Inherited from Rubberband.)
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes. (Inherited from Rubberband.)
Public event | CursorChanged | Occurs when %Cursor% changes. (Inherited from Rubberband.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes. (Inherited from Rubberband.)
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes. (Inherited from Rubberband.)
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes. (Inherited from Rubberband.)
Public event | ParentChanged | Occurs when %Parent% changes. (Inherited from Rubberband.)
Public event | PenChanged | Occurs when Pen changes. (Inherited from Rubberband.)
Public event | PersistChanged | Occurs when Persist changes. (Inherited from Rubberband.)
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes. (Inherited from Rubberband.)
Public event | VisibleChanged | Occurs when Visible changes. (Inherited from Rubberband.)
Top
See Also

Reference

RectangleSelection Class
Atalasoft.Imaging.WinControls Namespace


ResolutionScaleMode Enumeration

Specified the behavior options when displaying images with different X and Y resolutions as defined in the ResolutionScaleMode property of the Viewport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResolutionScaleMode
Public Enumeration ResolutionScaleMode
Members
Member name | Description
None | Do not adjust the aspect ratio of the image based on the X and Y resolution.
Fax | Adjust the aspect ratio of the display image based on the X and Y resolution only if the image is a 1-bit Black and White FAX image.
All | Always adjust the aspect ratio of the display image based on the X and Y resolution.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Rubberband Class

A base class which all rubber bands inherit from.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.Imaging.WinControlsRubberband
Atalasoft.Imaging.WinControlsEllipseRubberband
Atalasoft.Imaging.WinControlsLineRubberband
Atalasoft.Imaging.WinControlsRectangleRubberband
Atalasoft.Imaging.WinControlsRectangleSelection

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class Rubberband : Component
Public MustInherit Class Rubberband
    Inherits Component

The Rubberband type exposes the following members.

Constructors
 | Name | Description
Protected method | Rubberband | Initializes a new instance of the Rubberband class
Protected method | Rubberband(Viewport) | Initializes a new instance of the Rubberband class
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control.
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband.
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to.
Public property | BackgroundColor | Gets or sets the background color of a dashed line.
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband.
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active.
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted.
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged.
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband.
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse.
Public property | Parent | Gets or sets the parent ViewPort control.
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband.
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel.
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner.
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible.
Top
Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides ComponentDispose(Boolean).)
Protected method | DrawRegion | Called when a region needs to be drawn.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region.
Protected method | Finalize | (Overrides ComponentFinalize.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid.
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Inheriting classes must implement this method and return the region occupied by the rubber band.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event.
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event.
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event.
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event.
Protected method | OnChanged | Called when the Rubberband has changed.
Protected method | OnChanging | Called when the Rubberband is in the process of changing.
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event.
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event.
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event.
Protected method | OnDrawRubberband | Draws the Rubberband using the provided Canvas and pen.
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event.
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband.
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband.
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband.
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event.
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event.
Protected method | OnPaint | Called when the Rubberband needs to be painted.
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event.
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event.
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event.
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event.
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event.
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position.
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position.
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates.
Public method | Start | Programmatically starts a new rubberband without user interaction.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes.
Public event | ActiveChanged | Occurs when Active changes.
Public event | AspectRatioChanged | Occurs when AspectRatio changes.
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes.
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event).
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event).
Public event | ClickLockChanged | Occurs when ClickLock changes.
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes.
Public event | CursorChanged | Occurs when %Cursor% changes.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes.
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes.
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes.
Public event | ParentChanged | Occurs when %Parent% changes.
Public event | PenChanged | Occurs when Pen changes.
Public event | PersistChanged | Occurs when Persist changes.
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes.
Public event | VisibleChanged | Occurs when Visible changes.
Top
Remarks
Allows entities to be drawn onto a Viewport by clicking and dragging with the mouse. Derived classes can draw lines, rectangles, and ellipses and be used to draw primitives and make region selections.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Rubberband Constructor

Overload List
 | Name | Description
Protected method | Rubberband | Initializes a new instance of the Rubberband class
Protected method | Rubberband(Viewport) | Initializes a new instance of the Rubberband class
Top
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband Constructor

Initializes a new instance of the Rubberband class

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Rubberband()
Protected Sub New
See Also

Reference

Rubberband Class
Rubberband Overload
Atalasoft.Imaging.WinControls Namespace


Rubberband Constructor (Viewport)

Initializes a new instance of the Rubberband class

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Rubberband(
    Viewport parent
)
Protected Sub New (
    parent As Viewport
)

Parameters

parent
Type: Atalasoft.Imaging.WinControlsViewport
See Also

Reference

Rubberband Class
Rubberband Overload
Atalasoft.Imaging.WinControls Namespace


Rubberband Properties

The Rubberband type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating if the rubberband is active in the parent Viewport control.
Public property | ActiveButtons | Gets or sets a value indicating which mouse buttons are used to draw the rubberband.
Public property | AspectRatio | Gets or sets the aspect ratio which the rubberband will be constrained to.
Public property | BackgroundColor | Gets or sets the background color of a dashed line.
Public property | Bounds | Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClickLock | Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband.
Public property | ConstrainPosition | Gets or sets a value indicating if the RubberBand can be drawn outside the image area.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Cursor | Gets or sets the cursor which is displayed in the parent Viewport when active.
Protected property | CursorPad | Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | EndPoint | Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Inverted | Gets or sets a value indicating if the rubberband is drawn inverted.
Protected property | IsDragging | Gets or sets a value indicating whether the Rubberband is being dragged.
Public property | MoveCursor | Gets or sets the cursor used when moving the rubberband.
Public property | MoveWhenInside | Gets or sets a value indicating if the rubberband can be moved with the mouse.
Public property | Parent | Gets or sets the parent ViewPort control.
Public property | Pen | Gets or sets a value of the pen which is used to draw the rubberband.
Public property | Persist | Gets or sets a value indicating if the rubberband continues to display after the mouse button is released.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SnapToPixelGrid | Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel.
Protected property | StartPoint | Gets or sets the starting point of the Rubberband. Normally this is the top-left corner.
Public property | Visible | Gets or sets a value indicating if the rubberband is currently visible.
Top
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Active Property

RubberbandActive Property

Gets or sets a value indicating if the rubberband is active in the parent Viewport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the rubberband is active in the parent Viewport control.
Remarks
When true, the mouse can interact with the RubberBand. When false, the current RubberBand will still be displayed, but the mouse cannot interact with it. When this value is set to true, any other RubberBands with the same Parent will be deactivated.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ActiveButtons Property

RubberbandActiveButtons Property

Gets or sets a value indicating which mouse buttons are used to draw the rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButtons ActiveButtons { get; set; }
Public Property ActiveButtons As MouseButtons
    Get
    Set

Property Value

Type: MouseButtons
A value indicating which mouse buttons are used to draw the rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.AspectRatio Property

RubberbandAspectRatio Property

Gets or sets the aspect ratio which the rubberband will be constrained to.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float AspectRatio { get; set; }
Public Property AspectRatio As Single
    Get
    Set

Property Value

Type: Single
The aspect ratio which the rubberband will be constrained to.
Remarks
If the aspect ratio is 0, the rubberband may be freely drawn without any aspect ratio. Default is 0.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.BackgroundColor Property

RubberbandBackgroundColor Property

Gets or sets the background color of a dashed line.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The background color of a dashed line.
Remarks
This value is only applicable when Inverted = false and the the Pen LineStyle is set to a value other then solid. Default = Transparent.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Bounds Property

RubberbandBounds Property

Gets or sets the rectangular area occupied by the rubberband in image pixel coordinates.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; set; }
Public Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular area occupied by the rubberband in image pixel coordinates.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace
RubberbandGetDisplayBounds


Rubberband.ClickLock Property

RubberbandClickLock Property

Gets or sets a value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClickLock { get; set; }
Public Property ClickLock As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if clicking on the Viewport without moving the mouse starts or finishes a rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ConstrainPosition Property

RubberbandConstrainPosition Property

Gets or sets a value indicating if the RubberBand can be drawn outside the image area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ConstrainPosition { get; set; }
Public Property ConstrainPosition As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the RubberBand can be drawn outside the image area.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Cursor Property

RubberbandCursor Property

Gets or sets the cursor which is displayed in the parent Viewport when active.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor Cursor { get; set; }
Public Property Cursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor which is displayed in the parent Viewport when active.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.CursorPad Property

RubberbandCursorPad Property

Gets or sets the amount of padding for the cursor to change and to allow adjusting the existing selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int CursorPad { get; set; }
Protected Property CursorPad As Integer
    Get
    Set

Property Value

Type: Int32
The padding for the cursor to change.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.EndPoint Property

RubberbandEndPoint Property

Gets or sets the end point of the Rubberband. Normally this is the bottom-right corner.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF EndPoint { get; set; }
Protected Property EndPoint As PointF
    Get
    Set

Property Value

Type: PointF
The end point of the Rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Inverted Property

RubberbandInverted Property

Gets or sets a value indicating if the rubberband is drawn inverted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Inverted { get; set; }
Public Property Inverted As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the rubberband is drawn inverted.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.IsDragging Property

RubberbandIsDragging Property

Gets or sets a value indicating whether the Rubberband is being dragged.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool IsDragging { get; set; }
Protected Property IsDragging As Boolean
    Get
    Set

Property Value

Type: Boolean
Indicates whether the Rubberband is being dragged.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.MoveCursor Property

RubberbandMoveCursor Property

Gets or sets the cursor used when moving the rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor MoveCursor { get; set; }
Public Property MoveCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used when moving the rubberband.
Remarks
Only applicable when MoveWhenInside is true.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.MoveWhenInside Property

RubberbandMoveWhenInside Property

Gets or sets a value indicating if the rubberband can be moved with the mouse.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MoveWhenInside { get; set; }
Public Property MoveWhenInside As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the rubberband can be moved with the mouse.
Remarks
When true the mouse changes to a size-all cursor when the inside the selection rectangle. Dragging will then move the entire selection rectangle.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Parent Property

RubberbandParent Property

Gets or sets the parent ViewPort control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Viewport Parent { get; set; }
Public Property Parent As Viewport
    Get
    Set

Property Value

Type: Viewport
The parent ViewPort control.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Pen Property

RubberbandPen Property

Gets or sets a value of the pen which is used to draw the rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen Pen { get; set; }
Public Property Pen As AtalaPen
    Get
    Set

Property Value

Type: AtalaPen
A value of the pen which is used to draw the rubberband.
Remarks
By default the pen is inverted with a dash-dot-dot pattern. If the pen is not inverted, it will cause the rectngular area of the pen to be invalidated at the selection moves. This is somewhat slower but the performance difference should be unnoticeable.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Persist Property

RubberbandPersist Property

Gets or sets a value indicating if the rubberband continues to display after the mouse button is released.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Persist { get; set; }
Public Property Persist As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the rubberband continues to display after the mouse button is released.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.SnapToPixelGrid Property

RubberbandSnapToPixelGrid Property

Gets or sets a value indicating if the rubberband snaps to a grid occupied by one image pixel.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SnapToPixelGrid { get; set; }
Public Property SnapToPixelGrid As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the rubberband snaps to a grid occupied by one image pixel.
Remarks

The grid is only noticeable when the zoom is greater then 1.

See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.StartPoint Property

RubberbandStartPoint Property

Gets or sets the starting point of the Rubberband. Normally this is the top-left corner.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF StartPoint { get; set; }
Protected Property StartPoint As PointF
    Get
    Set

Property Value

Type: PointF
The starting point of the Rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Visible Property

RubberbandVisible Property

Gets or sets a value indicating if the rubberband is currently visible.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the rubberband is currently visible.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband Methods

The Rubberband type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels dragging a new rubberband.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides ComponentDispose(Boolean).)
Protected method | DrawRegion | Called when a region needs to be drawn.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | EraseRegion | Call this method to erase the current region.
Protected method | Finalize | (Overrides ComponentFinalize.)
Protected method | GetConstrainedPoint | Returns a point that is within the image bounds and snap to the pixel grid.
Public method | GetDisplayBounds | Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetRegion | Inheriting classes must implement this method and return the region occupied by the rubber band.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns a value indicating if the position is within the RubberBand boundary.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnActiveButtonsChanged | Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event.
Protected method | OnActiveChanged | Called when the Active property has changed and raises the ActiveChanged event.
Protected method | OnAspectRatioChanged | Called when the AspectRatio property has changed and raises the AspectRatioChanged event.
Protected method | OnBackgroundColorChanged | Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event.
Protected method | OnChanged | Called when the Rubberband has changed.
Protected method | OnChanging | Called when the Rubberband is in the process of changing.
Protected method | OnClickLockChanged | Called when the ClickLock property has changed and raises the ClickLockChanged event.
Protected method | OnConstrainPositionChanged | Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event.
Protected method | OnCursorChanged | Called when the Cursor property has changed and raises the CursorChanged event.
Protected method | OnDrawRubberband | Draws the Rubberband using the provided Canvas and pen.
Protected method | OnInvertedChanged | Called when the Inverted property has changed and raises the InvertedChanged event.
Protected method | OnMouseDown | Called when a mouse button is pressed over the Rubberband.
Protected method | OnMouseMove | Called when the mouse is moved over the Rubberband.
Protected method | OnMouseUp | Called when a mouse button is released over the Rubberband.
Protected method | OnMoveCursorChanged | Called when the MoveCursor property has changed and raises the MoveCursorChanged event.
Protected method | OnMoveWhenInsideChanged | Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event.
Protected method | OnPaint | Called when the Rubberband needs to be painted.
Protected method | OnParentChanged | Called when the Parent property has changed and raises the ParentChanged event.
Protected method | OnPenChanged | Called when the Pen property has changed and raises the PenChanged event.
Protected method | OnPersistChanged | Called when the Persist property has changed and raises the PersistChanged event.
Protected method | OnSnapToPixelGridChanged | Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event.
Protected method | OnVisibleChanged | Called when the Visible property has changed and raises the VisibleChanged event.
Protected method | PixelPointFromDisplayPoint | Returns the pixel position from the specified display position.
Protected method | PixelPointToDisplayPoint | Returns the display position from a pixel position.
Public method | SetDisplayBounds | Sets the rectangular boundary of the rubberband by using Viewport coordinates.
Public method | Start | Programmatically starts a new rubberband without user interaction.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Cancel Method

RubberbandCancel Method

Cancels dragging a new rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Cancel()
Public Sub Cancel
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Dispose Method

RubberbandDispose Method

Releases resources held by the object back to the system.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases resources held by the object back to the system. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Dispose Method (Boolean)

RubberbandDispose Method (Boolean)

Releases resources held by the object back to the system.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool isDisposing
)
Protected Overrides Sub Dispose (
    isDisposing As Boolean
)

Parameters

isDisposing
Type: SystemBoolean
Indicates whether this method was called from the public Dispose method or the Finalizer.
See Also

Reference

Rubberband Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


Rubberband.DrawRegion Method

RubberbandDrawRegion Method

Called when a region needs to be drawn.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void DrawRegion(
    Region invalidRegion
)
Protected Sub DrawRegion (
    invalidRegion As Region
)

Parameters

invalidRegion
Type: System.DrawingRegion
The region to draw.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.EraseRegion Method

RubberbandEraseRegion Method

Call this method to erase the current region.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Region EraseRegion()
Protected Function EraseRegion As Region

Return Value

Type: Region
The invalidated region or null (Nothing in VB).
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Finalize Method

RubberbandFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.GetConstrainedPoint Method

RubberbandGetConstrainedPoint Method

Returns a point that is within the image bounds and snap to the pixel grid.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF GetConstrainedPoint(
    PointF point
)
Protected Function GetConstrainedPoint (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The point to constrain.

Return Value

Type: PointF
The constrained point.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.GetDisplayBounds Method

RubberbandGetDisplayBounds Method

Returns a Rectangle representing the rectangular rubberband boundary in Viewport display coordinates.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF GetDisplayBounds()
Public Function GetDisplayBounds As RectangleF

Return Value

Type: RectangleF
A Rectangle representing the rectangular rubberband boundary in Viewport display coordinates.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace
RubberbandSetDisplayBounds(RectangleF)


Rubberband.GetRegion Method

RubberbandGetRegion Method

Inheriting classes must implement this method and return the region occupied by the rubber band.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract Region GetRegion()
Public MustOverride Function GetRegion As Region

Return Value

Type: Region
A region for this rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.HitTest Method

RubberbandHitTest Method

Returns a value indicating if the position is within the RubberBand boundary.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool HitTest(
    Point position,
    bool imageCoordinates
)
Public Overridable Function HitTest (
    position As Point,
    imageCoordinates As Boolean
) As Boolean

Parameters

position
Type: System.DrawingPoint
The position to test.
imageCoordinates
Type: SystemBoolean
If true, position is in image coordinates otherwise position is in display coordinates.

Return Value

Type: Boolean
A value indicating if the position is within the RubberBand boundary.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnActiveButtonsChanged Method

RubberbandOnActiveButtonsChanged Method

Called when the ActiveButtons property changes and raises the ActiveButtonsChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnActiveButtonsChanged(
    EventArgs e
)
Protected Overridable Sub OnActiveButtonsChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnActiveChanged Method

RubberbandOnActiveChanged Method

Called when the Active property has changed and raises the ActiveChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnActiveChanged(
    EventArgs e
)
Protected Overridable Sub OnActiveChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnAspectRatioChanged Method

RubberbandOnAspectRatioChanged Method

Called when the AspectRatio property has changed and raises the AspectRatioChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAspectRatioChanged(
    EventArgs e
)
Protected Overridable Sub OnAspectRatioChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnBackgroundColorChanged Method

RubberbandOnBackgroundColorChanged Method

Called when the BackgroundColor property has changed and raises the BackgroundColorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnBackgroundColorChanged(
    EventArgs e
)
Protected Overridable Sub OnBackgroundColorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnChanged Method

RubberbandOnChanged Method

Called when the Rubberband has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    RubberbandEventArgs e
)
Protected Overridable Sub OnChanged (
    e As RubberbandEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsRubberbandEventArgs
A RubberbandEventArgs containing the new start and end points.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnChanging Method

RubberbandOnChanging Method

Called when the Rubberband is in the process of changing.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnChanging(
    RubberbandEventArgs e
)
Protected Overridable Sub OnChanging (
    e As RubberbandEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsRubberbandEventArgs
A RubberbandEventArgs containing the new start and end points.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnClickLockChanged Method

RubberbandOnClickLockChanged Method

Called when the ClickLock property has changed and raises the ClickLockChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnClickLockChanged(
    EventArgs e
)
Protected Overridable Sub OnClickLockChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnConstrainPositionChanged Method

RubberbandOnConstrainPositionChanged Method

Called when the ConstrainPosition property has changed and raises the ConstrainPositionChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnConstrainPositionChanged(
    EventArgs e
)
Protected Overridable Sub OnConstrainPositionChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnCursorChanged Method

RubberbandOnCursorChanged Method

Called when the Cursor property has changed and raises the CursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnDrawRubberband Method

RubberbandOnDrawRubberband Method

Draws the Rubberband using the provided Canvas and pen.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void OnDrawRubberband(
    Canvas canvas,
    AtalaPen pen
)
Protected MustOverride Sub OnDrawRubberband (
    canvas As Canvas,
    pen As AtalaPen
)

Parameters

canvas
Type: Atalasoft.Imaging.DrawingCanvas
The Canvas object used to draw the Rubberband.
pen
Type: Atalasoft.Imaging.DrawingAtalaPen
An AtalaPen for drawing the lines of the Rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnInvertedChanged Method

RubberbandOnInvertedChanged Method

Called when the Inverted property has changed and raises the InvertedChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnInvertedChanged(
    EventArgs e
)
Protected Overridable Sub OnInvertedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnMouseDown Method

RubberbandOnMouseDown Method

Called when a mouse button is pressed over the Rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseDown(
    MouseEventArgs e
)
Protected Overridable Sub OnMouseDown (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing the mouse information for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnMouseMove Method

RubberbandOnMouseMove Method

Called when the mouse is moved over the Rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseMove(
    MouseEventArgs e
)
Protected Overridable Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing the mouse information for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnMouseUp Method

RubberbandOnMouseUp Method

Called when a mouse button is released over the Rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseUp(
    MouseEventArgs e
)
Protected Overridable Sub OnMouseUp (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing mouse information for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnMoveCursorChanged Method

RubberbandOnMoveCursorChanged Method

Called when the MoveCursor property has changed and raises the MoveCursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMoveCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnMoveCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnMoveWhenInsideChanged Method

RubberbandOnMoveWhenInsideChanged Method

Called when the MoveWhenInside property has changed and raises the MoveWhenInsideChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMoveWhenInsideChanged(
    EventArgs e
)
Protected Overridable Sub OnMoveWhenInsideChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnPaint Method

RubberbandOnPaint Method

Called when the Rubberband needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPaint(
    PaintEventArgs e
)
Protected Overridable Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs containing the information required to paint the Rubberband.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnParentChanged Method

RubberbandOnParentChanged Method

Called when the Parent property has changed and raises the ParentChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnParentChanged(
    EventArgs e
)
Protected Overridable Sub OnParentChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnPenChanged Method

RubberbandOnPenChanged Method

Called when the Pen property has changed and raises the PenChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPenChanged(
    EventArgs e
)
Protected Overridable Sub OnPenChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnPersistChanged Method

RubberbandOnPersistChanged Method

Called when the Persist property has changed and raises the PersistChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPersistChanged(
    EventArgs e
)
Protected Overridable Sub OnPersistChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnSnapToPixelGridChanged Method

RubberbandOnSnapToPixelGridChanged Method

Called when the SnapToPixelGrid property has changed and raises the SnapToPixelGridChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSnapToPixelGridChanged(
    EventArgs e
)
Protected Overridable Sub OnSnapToPixelGridChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.OnVisibleChanged Method

RubberbandOnVisibleChanged Method

Called when the Visible property has changed and raises the VisibleChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnVisibleChanged(
    EventArgs e
)
Protected Overridable Sub OnVisibleChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.PixelPointFromDisplayPoint Method

RubberbandPixelPointFromDisplayPoint Method

Returns the pixel position from the specified display position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF PixelPointFromDisplayPoint(
    PointF point
)
Protected Function PixelPointFromDisplayPoint (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The position relative to the upper-left corner of the control.

Return Value

Type: PointF
The image pixel position.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.PixelPointToDisplayPoint Method

RubberbandPixelPointToDisplayPoint Method

Returns the display position from a pixel position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PointF PixelPointToDisplayPoint(
    PointF point
)
Protected Function PixelPointToDisplayPoint (
    point As PointF
) As PointF

Parameters

point
Type: System.DrawingPointF
The image pixel position to convert.

Return Value

Type: PointF
The display position, relative to the upper-left corner.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.SetDisplayBounds Method

RubberbandSetDisplayBounds Method

Sets the rectangular boundary of the rubberband by using Viewport coordinates.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetDisplayBounds(
    RectangleF selectionRect
)
Public Sub SetDisplayBounds (
    selectionRect As RectangleF
)

Parameters

selectionRect
Type: System.DrawingRectangleF
The new Rectangle boundary of the rubberband.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace
RubberbandGetDisplayBounds


Rubberband.Start Method

RubberbandStart Method

Programmatically starts a new rubberband without user interaction.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Start(
    PointF startPoint,
    bool imageCoordinates
)
Public Sub Start (
    startPoint As PointF,
    imageCoordinates As Boolean
)

Parameters

startPoint
Type: System.DrawingPointF
The start point of the new rubberband.
imageCoordinates
Type: SystemBoolean
If true, uses image pixel coordinates, otherwise uses Viewport coordinates.
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband Events

The Rubberband type exposes the following members.

Events
 | Name | Description
Public event | ActiveButtonsChanged | Occurs when ActiveButtons changes.
Public event | ActiveChanged | Occurs when Active changes.
Public event | AspectRatioChanged | Occurs when AspectRatio changes.
Public event | BackgroundColorChanged | Occurs when BackgroundColor changes.
Public event | Changed | Occurs when the rubber band changes size (occurs on the MouseUp Event).
Public event | Changing | Occurs when the rubber band is changing size (occurs on the MouseMove Event).
Public event | ClickLockChanged | Occurs when ClickLock changes.
Public event | ConstrainPositionChanged | Occurs when ConstrainPosition changes.
Public event | CursorChanged | Occurs when %Cursor% changes.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | InvertedChanged | Occurs when Inverted changes.
Public event | MoveCursorChanged | Occurs when %MoveCursor% changes.
Public event | MoveWhenInsideChanged | Occurs when MoveWhenInside changes.
Public event | ParentChanged | Occurs when %Parent% changes.
Public event | PenChanged | Occurs when Pen changes.
Public event | PersistChanged | Occurs when Persist changes.
Public event | SnapToPixelGridChanged | Occurs when SnapToPixelGrid changes.
Public event | VisibleChanged | Occurs when Visible changes.
Top
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ActiveButtonsChanged Event

RubberbandActiveButtonsChanged Event

Occurs when ActiveButtons changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ActiveButtonsChanged
Public Event ActiveButtonsChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ActiveChanged Event

RubberbandActiveChanged Event

Occurs when Active changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ActiveChanged
Public Event ActiveChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.AspectRatioChanged Event

RubberbandAspectRatioChanged Event

Occurs when AspectRatio changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AspectRatioChanged
Public Event AspectRatioChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.BackgroundColorChanged Event

RubberbandBackgroundColorChanged Event

Occurs when BackgroundColor changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler BackgroundColorChanged
Public Event BackgroundColorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Changed Event

RubberbandChanged Event

Occurs when the rubber band changes size (occurs on the MouseUp Event).

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event RubberbandEventHandler Changed
Public Event Changed As RubberbandEventHandler

Value

Type: Atalasoft.Imaging.WinControlsRubberbandEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.Changing Event

RubberbandChanging Event

Occurs when the rubber band is changing size (occurs on the MouseMove Event).

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event RubberbandEventHandler Changing
Public Event Changing As RubberbandEventHandler

Value

Type: Atalasoft.Imaging.WinControlsRubberbandEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ClickLockChanged Event

RubberbandClickLockChanged Event

Occurs when ClickLock changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ClickLockChanged
Public Event ClickLockChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ConstrainPositionChanged Event

RubberbandConstrainPositionChanged Event

Occurs when ConstrainPosition changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ConstrainPositionChanged
Public Event ConstrainPositionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.CursorChanged Event

RubberbandCursorChanged Event

Occurs when %Cursor% changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CursorChanged
Public Event CursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.InvertedChanged Event

RubberbandInvertedChanged Event

Occurs when Inverted changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler InvertedChanged
Public Event InvertedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.MoveCursorChanged Event

RubberbandMoveCursorChanged Event

Occurs when %MoveCursor% changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler MoveCursorChanged
Public Event MoveCursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.MoveWhenInsideChanged Event

RubberbandMoveWhenInsideChanged Event

Occurs when MoveWhenInside changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler MoveWhenInsideChanged
Public Event MoveWhenInsideChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.ParentChanged Event

RubberbandParentChanged Event

Occurs when %Parent% changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ParentChanged
Public Event ParentChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.PenChanged Event

RubberbandPenChanged Event

Occurs when Pen changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler PenChanged
Public Event PenChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.PersistChanged Event

RubberbandPersistChanged Event

Occurs when Persist changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler PersistChanged
Public Event PersistChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.SnapToPixelGridChanged Event

RubberbandSnapToPixelGridChanged Event

Occurs when SnapToPixelGrid changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SnapToPixelGridChanged
Public Event SnapToPixelGridChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


Rubberband.VisibleChanged Event

RubberbandVisibleChanged Event

Occurs when Visible changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rubberband Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs Class

Provides data for the Changed and Changing events of the Rubberband class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsRubberbandEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RubberbandEventArgs : EventArgs
Public Class RubberbandEventArgs
    Inherits EventArgs

The RubberbandEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RubberbandEventArgs | Initializes a new instance of RubberbandEventArgs.
Public method | RubberbandEventArgs(PointF, PointF) | Creates a new instance of RubberbandEventArgs specifying the starting and ending points of the rubberband.
Top
Properties
 | Name | Description
Public property | EndPoint | Gets the end position of the Rubberband.
Public property | StartPoint | Gets the start position of the Rubberband.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBounds | Gets the rectangular area of the rectangle in image pixel coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs Constructor

Overload List
 | Name | Description
Public method | RubberbandEventArgs | Initializes a new instance of RubberbandEventArgs.
Public method | RubberbandEventArgs(PointF, PointF) | Creates a new instance of RubberbandEventArgs specifying the starting and ending points of the rubberband.
Top
See Also

Reference

RubberbandEventArgs Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs Constructor

Initializes a new instance of RubberbandEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberbandEventArgs()
Public Sub New
See Also

Reference

RubberbandEventArgs Class
RubberbandEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs Constructor (PointF, PointF)

Creates a new instance of RubberbandEventArgs specifying the starting and ending points of the rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberbandEventArgs(
    PointF startPoint,
    PointF endPoint
)
Public Sub New (
    startPoint As PointF,
    endPoint As PointF
)

Parameters

startPoint
Type: System.DrawingPointF
The top-left corner of the rubberband.
endPoint
Type: System.DrawingPointF
The bottom-right corner of the rubberband.
See Also

Reference

RubberbandEventArgs Class
RubberbandEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs Properties

The RubberbandEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets the end position of the Rubberband.
Public property | StartPoint | Gets the start position of the Rubberband.
Top
See Also

Reference

RubberbandEventArgs Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs.EndPoint Property

RubberbandEventArgsEndPoint Property

Gets the end position of the Rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF EndPoint { get; set; }
Public Property EndPoint As PointF
    Get
    Set

Property Value

Type: PointF
The end position of the Rubberband.
See Also

Reference

RubberbandEventArgs Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs.StartPoint Property

RubberbandEventArgsStartPoint Property

Gets the start position of the Rubberband.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF StartPoint { get; set; }
Public Property StartPoint As PointF
    Get
    Set

Property Value

Type: PointF
The start position of the RubberBand.
See Also

Reference

RubberbandEventArgs Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs Methods

The RubberbandEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBounds | Gets the rectangular area of the rectangle in image pixel coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RubberbandEventArgs Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventArgs.GetBounds Method

RubberbandEventArgsGetBounds Method

Gets the rectangular area of the rectangle in image pixel coordinates.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle GetBounds()
Public Function GetBounds As Rectangle

Return Value

Type: Rectangle
See Also

Reference

RubberbandEventArgs Class
Atalasoft.Imaging.WinControls Namespace


RubberbandEventHandler Delegate

Represents the method that will handle the Changed and Changing event of the Rubberband component.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void RubberbandEventHandler(
    Object sender,
    RubberbandEventArgs e
)
Public Delegate Sub RubberbandEventHandler (
    sender As Object,
    e As RubberbandEventArgs
)

Parameters

sender
Type: SystemObject
The object raising this event.
e
Type: Atalasoft.Imaging.WinControlsRubberbandEventArgs
A RubberbandEventArgs containing information about this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ScreenCapture Class

This class is used to capture the screen, window or a specified area of the screen or window.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsScreenCapture

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ScreenCapture
Public Class ScreenCapture

The ScreenCapture type exposes the following members.

Constructors
 | Name | Description
Public method | ScreenCapture | Creates a new instance of ScreenCapture.
Public method | ScreenCapture(IntPtr) | Creates a new instance of ScreenCapture specifying the window handle to capture.
Public method | ScreenCapture(IntPtr, Boolean) | Creates a new instance of ScreenCapture specifying the window handle to capture and whether the entire window or only the client area is captured.
Public method | ScreenCapture(IntPtr, Rectangle) | Creates a new instance ScreenCapture specifying the window handle and a rectangular area of the window to capture.
Top
Properties
 | Name | Description
Public property | Area | Gets or sets the rectangular area of the screen or window to capture.
Public property | ClientArea | Gets or sets a value indicating whether the entire window is captured or only the client area.
Public property | Handle | Gets or sets the handle of the window to capture.
Top
Methods
 | Name | Description
 | CaptureScreen | Captures the desktop screen.
Public method | CaptureWindow | Captures a window from the handle provided in the Handle property.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ScreenCapture Constructor

Creates a ScreenCapture object that can be used to perform screen and window captures.
Overload List
 | Name | Description
Public method | ScreenCapture | Creates a new instance of ScreenCapture.
Public method | ScreenCapture(IntPtr) | Creates a new instance of ScreenCapture specifying the window handle to capture.
Public method | ScreenCapture(IntPtr, Boolean) | Creates a new instance of ScreenCapture specifying the window handle to capture and whether the entire window or only the client area is captured.
Public method | ScreenCapture(IntPtr, Rectangle) | Creates a new instance ScreenCapture specifying the window handle and a rectangular area of the window to capture.
Top
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture Constructor

Creates a new instance of ScreenCapture.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScreenCapture()
Public Sub New
See Also

Reference

ScreenCapture Class
ScreenCapture Overload
Atalasoft.Imaging.WinControls Namespace


ScreenCapture Constructor (IntPtr)

Creates a new instance of ScreenCapture specifying the window handle to capture.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScreenCapture(
    IntPtr handle
)
Public Sub New (
    handle As IntPtr
)

Parameters

handle
Type: SystemIntPtr
The window handle to capture.
See Also

Reference

ScreenCapture Class
ScreenCapture Overload
Atalasoft.Imaging.WinControls Namespace


ScreenCapture Constructor (IntPtr, Boolean)

Creates a new instance of ScreenCapture specifying the window handle to capture and whether the entire window or only the client area is captured.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScreenCapture(
    IntPtr handle,
    bool clientArea
)
Public Sub New (
    handle As IntPtr,
    clientArea As Boolean
)

Parameters

handle
Type: SystemIntPtr
The window to capture.
clientArea
Type: SystemBoolean
A value specifying whether the entire window is captured or only the client area.
See Also

Reference

ScreenCapture Class
ScreenCapture Overload
Atalasoft.Imaging.WinControls Namespace


ScreenCapture Constructor (IntPtr, Rectangle)

Creates a new instance ScreenCapture specifying the window handle and a rectangular area of the window to capture.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScreenCapture(
    IntPtr handle,
    Rectangle area
)
Public Sub New (
    handle As IntPtr,
    area As Rectangle
)

Parameters

handle
Type: SystemIntPtr
The window to capture.
area
Type: System.DrawingRectangle
A rectangular area of the window to capture.
See Also

Reference

ScreenCapture Class
ScreenCapture Overload
Atalasoft.Imaging.WinControls Namespace


ScreenCapture Properties

The ScreenCapture type exposes the following members.

Properties
 | Name | Description
Public property | Area | Gets or sets the rectangular area of the screen or window to capture.
Public property | ClientArea | Gets or sets a value indicating whether the entire window is captured or only the client area.
Public property | Handle | Gets or sets the handle of the window to capture.
Top
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture.Area Property

ScreenCaptureArea Property

Gets or sets the rectangular area of the screen or window to capture.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Area { get; set; }
Public Property Area As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The rectangular area to capture.
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture.ClientArea Property

ScreenCaptureClientArea Property

Gets or sets a value indicating whether the entire window is captured or only the client area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClientArea { get; set; }
Public Property ClientArea As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the entire window is captured.
Remarks
When capturing the screen with CaptureScreen, this property indicates whether the whole screen or only the working area of the screen will be captured, unless the Area has been set.
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture.Handle Property

ScreenCaptureHandle Property

Gets or sets the handle of the window to capture.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr Handle { get; set; }
Public Property Handle As IntPtr
    Get
    Set

Property Value

Type: IntPtr
The handle of the window to capture.
Remarks
If this property is set to Zero, the screen will be captured.
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture Methods

The ScreenCapture type exposes the following members.

Methods
 | Name | Description
 | CaptureScreen | Captures the desktop screen.
Public method | CaptureWindow | Captures a window from the handle provided in the Handle property.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture.CaptureScreen Method

ScreenCaptureCaptureScreen Method

Captures the desktop screen.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage CaptureScreen()
Public Function CaptureScreen As AtalaImage

Return Value

Type: AtalaImage
The captured image.
Remarks

To capture only the workable area of the screen, set the ClientArea property to true.

If the Area property has been set, ClientArea will be ignored.

See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScreenCapture.CaptureWindow Method

ScreenCaptureCaptureWindow Method

Captures a window from the handle provided in the Handle property.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage CaptureWindow()
Public Function CaptureWindow As AtalaImage

Return Value

Type: AtalaImage
An AtalaImage containing the captured window.
See Also

Reference

ScreenCapture Class
Atalasoft.Imaging.WinControls Namespace


ScrollBarDirection Enumeration

Specifies the horizontal or vertical scrollbar.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ScrollBarDirection
Public Enumeration ScrollBarDirection
Members
Member name | Description
Horizontal | The horizontal scrollbar.
Vertical | The vertical scrollbar.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ScrollBarVisibility Enumeration

Specifies how the scroll bars are shown in the Scrollport and inherited control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ScrollBarVisibility
Public Enumeration ScrollBarVisibility
Members
Member name | Description
Dynamic | Automatically show or hide the horizontal and vertical scrollbars as the control or image resizes.
None | Never show scrollbars.
Always | Always show scrollbars.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Class

Provides data for the Scrolling and ScrollChanged events of the Scrollport control.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsScrollEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ScrollEventArgs : EventArgs
Public Class ScrollEventArgs
    Inherits EventArgs

The ScrollEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollEventArgs | Initializes a new instance of ScrollEventArgs.
Public method | ScrollEventArgs(Point) | Initializes a new instance of ScrollEventArgs specifying the scroll position.
Public method | ScrollEventArgs(Point, ScrollBarDirection) | Initializes a new instance of ScrollEventArgs specifying the scroll position and scroll bar of interest.
Top
Properties
 | Name | Description
Public property | ScrollBar | Gets the scroll bar of interest.
Public property | ScrollPosition | Gets the scroll position.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Constructor

Overload List
 | Name | Description
Public method | ScrollEventArgs | Initializes a new instance of ScrollEventArgs.
Public method | ScrollEventArgs(Point) | Initializes a new instance of ScrollEventArgs specifying the scroll position.
Public method | ScrollEventArgs(Point, ScrollBarDirection) | Initializes a new instance of ScrollEventArgs specifying the scroll position and scroll bar of interest.
Top
See Also

Reference

ScrollEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Constructor

Initializes a new instance of ScrollEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollEventArgs()
Public Sub New
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Constructor (Point)

Initializes a new instance of ScrollEventArgs specifying the scroll position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollEventArgs(
    Point scrollPosition
)
Public Sub New (
    scrollPosition As Point
)

Parameters

scrollPosition
Type: System.DrawingPoint
Gets the position of the scrollbar.
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Constructor (Point, ScrollBarDirection)

Initializes a new instance of ScrollEventArgs specifying the scroll position and scroll bar of interest.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollEventArgs(
    Point scrollPosition,
    ScrollBarDirection scrollBar
)
Public Sub New (
    scrollPosition As Point,
    scrollBar As ScrollBarDirection
)

Parameters

scrollPosition
Type: System.DrawingPoint
Gets the position of the scrollbar.
scrollBar
Type: Atalasoft.Imaging.WinControlsScrollBarDirection
The scrollbar of interest.
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Properties

The ScrollEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ScrollBar | Gets the scroll bar of interest.
Public property | ScrollPosition | Gets the scroll position.
Top
See Also

Reference

ScrollEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs.ScrollBar Property

ScrollEventArgsScrollBar Property

Gets the scroll bar of interest.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollBarDirection ScrollBar { get; }
Public ReadOnly Property ScrollBar As ScrollBarDirection
    Get

Property Value

Type: ScrollBarDirection
See Also

Reference

ScrollEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs.ScrollPosition Property

ScrollEventArgsScrollPosition Property

Gets the scroll position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; }
Public ReadOnly Property ScrollPosition As Point
    Get

Property Value

Type: Point
See Also

Reference

ScrollEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ScrollEventArgs Methods

The ScrollEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScrollEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ScrollEventHandler Delegate

Represents the method that will handle the Scrolling and ScrollChanged event of the Scrollport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ScrollEventHandler(
    Object sender,
    ScrollEventArgs e
)
Public Delegate Sub ScrollEventHandler (
    sender As Object,
    e As ScrollEventArgs
)

Parameters

sender
Type: SystemObject
The object raising this event.
e
Type: Atalasoft.Imaging.WinControlsScrollEventArgs
A ScrollEventArgs containing information about this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Scrollport Class

Defines a base class that can be used for scrollable viewport to display and scroll any rectangular area.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsScrollport
Atalasoft.Imaging.WinControlsViewport

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class Scrollport : Control
Public MustInherit Class Scrollport
    Inherits Control

The Scrollport type exposes the following members.

Constructors
 | Name | Description
Protected method | Scrollport | Initializes a new instance of the Scrollport control.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars.
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area.
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport.
Public property | ScrollSize | Gets or sets the Size of the scrollable area.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event.
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Overrides ControlOnClick(EventArgs).)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when a layout change is requested. (Overrides ControlOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Overrides ControlOnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to be painted. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event.
Protected method | OnScrollChanged | Raises the ScrollChanged event.
Protected method | OnScrolling | Raises the Scrolling event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event.
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetScrollSize | Sets the size of the scrollable area.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Overrides ControlWndProc(Message).)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes.
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes.
Public event | ScrollChanged | Occurs when the scrollbar changes position.
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes.
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks
Similar to the ScrollableControl but with some changes and bug fixes to the .NET Framework version.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Scrollport Constructor

Initializes a new instance of the Scrollport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Scrollport()
Protected Sub New
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport Properties

The Scrollport type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars.
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area.
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport.
Public property | ScrollSize | Gets or sets the Size of the scrollable area.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.Centered Property

ScrollportCentered Property

Gets of sets the value indicating if the image is centered in the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Centered { get; set; }
Public Property Centered As Boolean
    Get
    Set

Property Value

Type: Boolean
The value indicating if the image is centered in the control.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.HScroll Property

ScrollportHScroll Property

Sets of returns a value indicating if the Horizontal scroll bar is visible.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool HScroll { get; set; }
Protected Property HScroll As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
A value indicating if the Horizontal scroll bar is visible.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.MouseWheelScrolling Property

ScrollportMouseWheelScrolling Property

Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MouseWheelScrolling { get; set; }
Public Property MouseWheelScrolling As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the viewer will scroll when the mouse wheel is used.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.ScrollBarStyle Property

ScrollportScrollBarStyle Property

Gets or sets a value indicating the visibility of the scrollbars.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ScrollBarVisibility ScrollBarStyle { get; set; }
Public Property ScrollBarStyle As ScrollBarVisibility
    Get
    Set

Property Value

Type: ScrollBarVisibility
A value indicating the visibility of the scrollbars.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.ScrollPosition Property

ScrollportScrollPosition Property

Gets or sets the top left position of the scrollable area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; set; }
Public Property ScrollPosition As Point
    Get
    Set

Property Value

Type: Point
The top left position of the scrollable area.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.ScrollRectangle Property

ScrollportScrollRectangle Property

Gets the Rectangle of the scrollable area in the scrollport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ScrollRectangle { get; }
Public ReadOnly Property ScrollRectangle As Rectangle
    Get

Property Value

Type: Rectangle
The Rectangle of the scrollable area in the scrollport.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.ScrollSize Property

ScrollportScrollSize Property

Gets or sets the Size of the scrollable area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ScrollSize { get; }
Public ReadOnly Property ScrollSize As Size
    Get

Property Value

Type: Size
The Size of the scrollable area.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.SmoothScroll Property

ScrollportSmoothScroll Property

Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SmoothScroll { get; set; }
Public Property SmoothScroll As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the contents update while the scroll thumb is being dragged.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.VScroll Property

ScrollportVScroll Property

Sets of returns a value indicating if the Vertical scroll bar is visible.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool VScroll { get; set; }
Protected Property VScroll As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
A value indicating if the Vertical scroll bar is visible.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport Methods

The Scrollport type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event.
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Overrides ControlOnClick(EventArgs).)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when a layout change is requested. (Overrides ControlOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Overrides ControlOnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to be painted. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event.
Protected method | OnScrollChanged | Raises the ScrollChanged event.
Protected method | OnScrolling | Raises the Scrolling event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event.
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetScrollSize | Sets the size of the scrollable area.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Overrides ControlWndProc(Message).)
Top
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnCenteredChanged Method

ScrollportOnCenteredChanged Method

Called when the Centered property has changed and raises the CenteredChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCenteredChanged(
    EventArgs e
)
Protected Overridable Sub OnCenteredChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnClick Method

ScrollportOnClick Method

Called when a mouse button is clicked on the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClick(
    EventArgs e
)
Protected Overrides Sub OnClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnLayout Method

ScrollportOnLayout Method

Called when a layout change is requested.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLayout(
    LayoutEventArgs e
)
Protected Overrides Sub OnLayout (
    e As LayoutEventArgs
)

Parameters

e
Type: System.Windows.FormsLayoutEventArgs
A LayoutEventArgs containing information for this event.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnMouseWheel Method

ScrollportOnMouseWheel Method

Called when a MouseWheel event is being raised.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseWheel(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseWheel (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
An event args containing information for the event.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnPaint Method

ScrollportOnPaint Method

Called when the control needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs containing information required to paint this object.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnScrollBarStyleChanged Method

ScrollportOnScrollBarStyleChanged Method

Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnScrollBarStyleChanged(
    EventArgs e
)
Protected Overridable Sub OnScrollBarStyleChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnScrollChanged Method

ScrollportOnScrollChanged Method

Raises the ScrollChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnScrollChanged(
    ScrollEventArgs e
)
Protected Sub OnScrollChanged (
    e As ScrollEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsScrollEventArgs
A ScrollEventArgs that contains the event data.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnScrolling Method

ScrollportOnScrolling Method

Raises the Scrolling event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnScrolling(
    ScrollEventArgs e
)
Protected Sub OnScrolling (
    e As ScrollEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsScrollEventArgs
A ScrollEventArgs that contains the event data.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.OnSmoothScrollChanged Method

ScrollportOnSmoothScrollChanged Method

Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSmoothScrollChanged(
    EventArgs e
)
Protected Overridable Sub OnSmoothScrollChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.SetScrollSize Method

ScrollportSetScrollSize Method

Sets the size of the scrollable area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetScrollSize(
    Size size
)
Protected Sub SetScrollSize (
    size As Size
)

Parameters

size
Type: System.DrawingSize
A System.Drawing.Size containing the size of the scrollable area.
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.WndProc Method

ScrollportWndProc Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)

Parameters

m
Type: System.Windows.FormsMessage
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport Events

The Scrollport type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes.
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes.
Public event | ScrollChanged | Occurs when the scrollbar changes position.
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes.
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.CenteredChanged Event

ScrollportCenteredChanged Event

Occurs when Centered changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CenteredChanged
Public Event CenteredChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.ScrollBarStyleChanged Event

ScrollportScrollBarStyleChanged Event

Occurs when ScrollBarStyle changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ScrollBarStyleChanged
Public Event ScrollBarStyleChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.ScrollChanged Event

ScrollportScrollChanged Event

Occurs when the scrollbar changes position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ScrollEventHandler ScrollChanged
Public Event ScrollChanged As ScrollEventHandler

Value

Type: Atalasoft.Imaging.WinControlsScrollEventHandler
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.Scrolling Event

ScrollportScrolling Event

Occurs while the thumb on the scrollbar is being dragged with the mouse.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ScrollEventHandler Scrolling
Public Event Scrolling As ScrollEventHandler

Value

Type: Atalasoft.Imaging.WinControlsScrollEventHandler
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


Scrollport.SmoothScrollChanged Event

ScrollportSmoothScrollChanged Event

Occurs when SmoothScroll changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SmoothScrollChanged
Public Event SmoothScrollChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Scrollport Class
Atalasoft.Imaging.WinControls Namespace


SelectedItemRenderStyle Enumeration

Specifies the rendering style for selected items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SelectedItemRenderStyle
Public Enumeration SelectedItemRenderStyle
Members
Member name | Description
None | No selection is drawn.
Default | A highlight is placed below the image area and below the caption area with a space between the image and caption areas.
Full | The entire thumbnail is highlighted.
Extended | The highlight is extended two pixels outside of the thumbanil area.
DefaultAboveBackground | Same as Default except that the highlight is rendered on top of the thumbnail background.
FullAboveBackground | Same as Full except that the highlight is rendered on top of the thumbnail background.
ExtendedAboveBackground | Same as Extended except that the highlight is rendered on top of the thumbnail background.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


SelectedItemsOrder Enumeration

Defines the order of the selected items collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SelectedItemsOrder
Public Enumeration SelectedItemsOrder
Members
Member name | Description
ItemIndexOrder | The items will be sorted into their index order.
SelectedOrder | The items will be listed in the order they were selected.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection Class

A collection of Thumbnail objects currently selected in the ThumbnailView. This is provided through the SelectedItems property.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.Imaging.WinControlsSelectedThumbnailCollection

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SelectedThumbnailCollection : ReadOnlyCollectionBase
Public Class SelectedThumbnailCollection
    Inherits ReadOnlyCollectionBase

The SelectedThumbnailCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedThumbnailCollection | Creates a new instance of SelectedThumbnailCollection.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item |
Top
Methods
 | Name | Description
Public method | Clear | Clears the collection.
Public method | CopyTo | Copies the thumbnails into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection Constructor

Creates a new instance of SelectedThumbnailCollection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedThumbnailCollection()
Public Sub New
See Also

Reference

SelectedThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection Properties

The SelectedThumbnailCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item |
Top
See Also

Reference

SelectedThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection.Item Property

SelectedThumbnailCollectionItem Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Thumbnail
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Thumbnail
See Also

Reference

SelectedThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection Methods

The SelectedThumbnailCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the collection.
Public method | CopyTo | Copies the thumbnails into an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectedThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection.Clear Method

SelectedThumbnailCollectionClear Method

Clears the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

SelectedThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


SelectedThumbnailCollection.CopyTo Method

SelectedThumbnailCollectionCopyTo Method

Copies the thumbnails into an array.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Thumbnail[] array
)
Public Sub CopyTo (
    array As Thumbnail()
)

Parameters

array
Type: Atalasoft.Imaging.WinControlsThumbnail
The array thumbnails will be copied into.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the array is null (Nothing in VB).
See Also

Reference

SelectedThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties Class

This class holds properties for the internal Splitter used by the DocumentViewer control.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsSeparatorProperties

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class SeparatorProperties
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class SeparatorProperties

The SeparatorProperties type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets the background color for the Splitter.
Public property | BorderStyle | Gets or sets the border style for the Splitter.
Public property | MinExtra | Gets or sets the minimum distance that must remain between the Splitter control and the opposite side of the container.
Public property | MinSize | Gets or sets the minimum distance that must remain between the Splitter control and the container edge.
Public property | Mode | Gets or sets the type of separator to use.
Public property | Size | Gets or sets the width or height of the Splitter.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string name for this object. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


SeparatorProperties Properties

The SeparatorProperties type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets the background color for the Splitter.
Public property | BorderStyle | Gets or sets the border style for the Splitter.
Public property | MinExtra | Gets or sets the minimum distance that must remain between the Splitter control and the opposite side of the container.
Public property | MinSize | Gets or sets the minimum distance that must remain between the Splitter control and the container edge.
Public property | Mode | Gets or sets the type of separator to use.
Public property | Size | Gets or sets the width or height of the Splitter.
Top
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.BackColor Property

SeparatorPropertiesBackColor Property

Gets or sets the background color for the Splitter.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color for the Splitter.
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.BorderStyle Property

SeparatorPropertiesBorderStyle Property

Gets or sets the border style for the Splitter.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderStyle BorderStyle { get; set; }
Public Property BorderStyle As BorderStyle
    Get
    Set

Property Value

Type: BorderStyle
The border style for the Splitter.
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.MinExtra Property

SeparatorPropertiesMinExtra Property

Gets or sets the minimum distance that must remain between the Splitter control and the opposite side of the container.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MinExtra { get; set; }
Public Property MinExtra As Integer
    Get
    Set

Property Value

Type: Int32
The minimum distance that must remain between the Splitter control and the opposite side of the container.
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.MinSize Property

SeparatorPropertiesMinSize Property

Gets or sets the minimum distance that must remain between the Splitter control and the container edge.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MinSize { get; set; }
Public Property MinSize As Integer
    Get
    Set

Property Value

Type: Int32
The minimum distance that must remain between the Splitter control and the container edge.
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.Mode Property

SeparatorPropertiesMode Property

Gets or sets the type of separator to use.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ControlSeparator Mode { get; set; }
Public Property Mode As ControlSeparator
    Get
    Set

Property Value

Type: ControlSeparator
The type of separator to use.
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.Size Property

SeparatorPropertiesSize Property

Gets or sets the width or height of the Splitter.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set

Property Value

Type: Int32
The width or height of the Splitter.
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties Methods

The SeparatorProperties type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string name for this object. (Overrides ObjectToString.)
Top
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SeparatorProperties.ToString Method

SeparatorPropertiesToString Method

Returns a string name for this object.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

SeparatorProperties Class
Atalasoft.Imaging.WinControls Namespace


SortOrder Enumeration

Specifies the sort order used by the ThumbnailView and FolderThumbnailView controls.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SortOrder
Public Enumeration SortOrder
Members
Member name | Description
Ascending | The thumbnails are displayed in ascending order.
Descending | The thumbnails are displayed in descending order.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbLoadMethod Enumeration

Determines the method used to load thumbnails in FolderThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ThumbLoadMethod
Public Enumeration ThumbLoadMethod
Members
Member name | Description
EntireFolder | Loads all thumbnails in the folder.
WhenVisible | Loads the thumbnails only when they become visible in the viewer. This option is suggested when the folder contains a large number of images.
Remarks
If WhenVisible is used, the viewer will only load thumbnails when scrolling after the scrollbar thumb or button has been released.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Thumbnail Class

This class contains information about the thumbnail image stored in the ThumbnailView and FolderThumbnailView controls.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsThumbnail

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Thumbnail : IComparable
Public Class Thumbnail
    Implements IComparable

The Thumbnail type exposes the following members.

Constructors
 | Name | Description
Public method | Thumbnail(AtalaImage, String, String) | Creates a new instance of Thumbnail specifying the AtalaImage, caption and tooltip.
Public method | Thumbnail(Stream, Int32, String, String) | Creates a new instance of Thumbnail specifying the stream containing the image, a frame index to load, the caption and tooltip.
Public method | Thumbnail(String, Int32, String, String) | Creates a new instance of Thumbnail specifying the filename, frame index, caption and tooltip.
Public method | Thumbnail(RandomAccessImageSource, Int32, String, String) | Creates a new instance of Thumbnail specifying a RandomAccessImageSource, index in the ImageSource for this thumbnail, caption and toolTip.
Top
Properties
 | Name | Description
Public property | FileInfo | Gets the file information associated with the thumbnail image if it was loaded from a file.
Public property | FilePath | Gets the file path associated with the thumbnail image if it was loaded from a file.
Public property | FrameIndex | Gets the zero based frame index of the thumbnail if it was loaded from a file and is a multipage image such as a TIFF.
Public property | Image | Gets the thumbnail AtalaImage.
Public property | LoadErrorMessage | Gets or sets the error message rendered when there is an error creating the thumbnail.
Public property | Row | Gets the DataRow for this Thumbnail when the ThumbnailView is data bound.
Public property | Selected | Gets or sets a value indicating whether this thumbnail is currently selected.
Public property | Source | Gets the RandomAccessImageSource used for this thumbnail.
Public property | Stream | Gets or sets the stream containing the full size image.
Public property | Tag | Gets or sets an object that may be used to keep additional data with the Thumbnail.
Public property | Text | Gets or sets the text caption associated with this Thumbnail object.
Public property | ToolTip | Gets or sets the tooltip for the Thumbnail.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy the Thumbnail.
Public method | CompareTo | Compares two Thumbnail objects to determine if they are the same.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Contains the AtalaImage thumbnail object, the text label, and file information for the Thumbnail objects stored in the ThumbnailView control.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Thumbnail Constructor

Overload List
 | Name | Description
Public method | Thumbnail(AtalaImage, String, String) | Creates a new instance of Thumbnail specifying the AtalaImage, caption and tooltip.
Public method | Thumbnail(Stream, Int32, String, String) | Creates a new instance of Thumbnail specifying the stream containing the image, a frame index to load, the caption and tooltip.
Public method | Thumbnail(String, Int32, String, String) | Creates a new instance of Thumbnail specifying the filename, frame index, caption and tooltip.
Public method | Thumbnail(RandomAccessImageSource, Int32, String, String) | Creates a new instance of Thumbnail specifying a RandomAccessImageSource, index in the ImageSource for this thumbnail, caption and toolTip.
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail Constructor (AtalaImage, String, String)

Creates a new instance of Thumbnail specifying the AtalaImage, caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail(
    AtalaImage image,
    string caption,
    string toolTip
)
Public Sub New (
    image As AtalaImage,
    caption As String,
    toolTip As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage from which the thumbnail will be created.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip used for the thumbnail.
See Also

Reference

Thumbnail Class
Thumbnail Overload
Atalasoft.Imaging.WinControls Namespace


Thumbnail Constructor (Stream, Int32, String, String)

Creates a new instance of Thumbnail specifying the stream containing the image, a frame index to load, the caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail(
    Stream stream,
    int frame,
    string caption,
    string toolTip
)
Public Sub New (
    stream As Stream,
    frame As Integer,
    caption As String,
    toolTip As String
)

Parameters

stream
Type: System.IOStream
A stream containing the image to generate the thumbnail from.
frame
Type: SystemInt32
The frame index of the image to load. Pass in 0 for single page images.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.
See Also

Reference

Thumbnail Class
Thumbnail Overload
Atalasoft.Imaging.WinControls Namespace


Thumbnail Constructor (String, Int32, String, String)

Creates a new instance of Thumbnail specifying the filename, frame index, caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail(
    string path,
    int frame,
    string caption,
    string toolTip
)
Public Sub New (
    path As String,
    frame As Integer,
    caption As String,
    toolTip As String
)

Parameters

path
Type: SystemString
The full path and filename of the image used to create this thumbnail.
frame
Type: SystemInt32
The frame index of the file to use when creating the thumbnail.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip used for the thumbnail.
See Also

Reference

Thumbnail Class
Thumbnail Overload
Atalasoft.Imaging.WinControls Namespace


Thumbnail Constructor (RandomAccessImageSource, Int32, String, String)

Creates a new instance of Thumbnail specifying a RandomAccessImageSource, index in the ImageSource for this thumbnail, caption and toolTip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail(
    RandomAccessImageSource source,
    int frame,
    string caption,
    string toolTip
)
Public Sub New (
    source As RandomAccessImageSource,
    frame As Integer,
    caption As String,
    toolTip As String
)

Parameters

source
Type: Atalasoft.ImagingRandomAccessImageSource
A RandomAccessImageSource where the image will be pulled from.
frame
Type: SystemInt32
The frame index of the image to load.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip text for the thumbnail.
See Also

Reference

Thumbnail Class
Thumbnail Overload
Atalasoft.Imaging.WinControls Namespace


Thumbnail Properties

The Thumbnail type exposes the following members.

Properties
 | Name | Description
Public property | FileInfo | Gets the file information associated with the thumbnail image if it was loaded from a file.
Public property | FilePath | Gets the file path associated with the thumbnail image if it was loaded from a file.
Public property | FrameIndex | Gets the zero based frame index of the thumbnail if it was loaded from a file and is a multipage image such as a TIFF.
Public property | Image | Gets the thumbnail AtalaImage.
Public property | LoadErrorMessage | Gets or sets the error message rendered when there is an error creating the thumbnail.
Public property | Row | Gets the DataRow for this Thumbnail when the ThumbnailView is data bound.
Public property | Selected | Gets or sets a value indicating whether this thumbnail is currently selected.
Public property | Source | Gets the RandomAccessImageSource used for this thumbnail.
Public property | Stream | Gets or sets the stream containing the full size image.
Public property | Tag | Gets or sets an object that may be used to keep additional data with the Thumbnail.
Public property | Text | Gets or sets the text caption associated with this Thumbnail object.
Public property | ToolTip | Gets or sets the tooltip for the Thumbnail.
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.FileInfo Property

ThumbnailFileInfo Property

Gets the file information associated with the thumbnail image if it was loaded from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileInfo FileInfo { get; }
Public ReadOnly Property FileInfo As FileInfo
    Get

Property Value

Type: FileInfo
The file information associated with the thumbnail image if it was loaded from a file.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.FilePath Property

ThumbnailFilePath Property

Gets the file path associated with the thumbnail image if it was loaded from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get

Property Value

Type: String
The file path associated with the thumbnail image if it was loaded from a file.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.FrameIndex Property

ThumbnailFrameIndex Property

Gets the zero based frame index of the thumbnail if it was loaded from a file and is a multipage image such as a TIFF.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FrameIndex { get; }
Public ReadOnly Property FrameIndex As Integer
    Get

Property Value

Type: Int32
The zero based frame index of the thumbnail if it was loaded from a file and is a multipage image such as a TIFF.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Image Property

ThumbnailImage Property

Gets the thumbnail AtalaImage.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The thumbnail AtalaImage.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.LoadErrorMessage Property

ThumbnailLoadErrorMessage Property

Gets or sets the error message rendered when there is an error creating the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LoadErrorMessage { get; set; }
Public Property LoadErrorMessage As String
    Get
    Set

Property Value

Type: String
The error message displayed in the thumbnail area when creating the thumbnail fails.
Remarks
This property is set to the exception message by default.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Row Property

ThumbnailRow Property

Gets the DataRow for this Thumbnail when the ThumbnailView is data bound.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataRow Row { get; }
Public ReadOnly Property Row As DataRow
    Get

Property Value

Type: DataRow
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Selected Property

ThumbnailSelected Property

Gets or sets a value indicating whether this thumbnail is currently selected.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this thumbnail is currently selected.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Source Property

ThumbnailSource Property

Gets the RandomAccessImageSource used for this thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomAccessImageSource Source { get; }
Public ReadOnly Property Source As RandomAccessImageSource
    Get

Property Value

Type: RandomAccessImageSource
The ImageSource for this thumbnail.
Remarks
The FrameIndex represents the ImageSource index when an ImageSource is used.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Stream Property

ThumbnailStream Property

Gets or sets the stream containing the full size image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; set; }
Public Property Stream As Stream
    Get
    Set

Property Value

Type: Stream
The stream containing the full size image.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Tag Property

ThumbnailTag Property

Gets or sets an object that may be used to keep additional data with the Thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
Any object that was stored with the thumbnail.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Text Property

ThumbnailText Property

Gets or sets the text caption associated with this Thumbnail object.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text caption associated with this Thumbnail object.
Remarks
This property is used as the label when DisplayText equals ThumbViewAttribute.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.ToolTip Property

ThumbnailToolTip Property

Gets or sets the tooltip for the Thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set

Property Value

Type: String
The tooltip used for this thumbnail.
Remarks
Tooltips are only used if the ToolTipControl property is set in the ThumbnailView.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail Methods

The Thumbnail type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy the Thumbnail.
Public method | CompareTo | Compares two Thumbnail objects to determine if they are the same.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.Clone Method

ThumbnailClone Method

Creates a copy the Thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Clone()
Public Function Clone As Thumbnail

Return Value

Type: Thumbnail
A copy of the Thumbnail.
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


Thumbnail.CompareTo Method

ThumbnailCompareTo Method

Compares two Thumbnail objects to determine if they are the same.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
The Thumbnail object being compared.

Return Value

Type: Int32
Less than zero if the object is less than the Thumbnail, Greater than zero if the object is greater than the Thumbnail, Zero if the object is equal to the Thumbnail.

Implements

IComparableCompareTo(Object)
See Also

Reference

Thumbnail Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Class

This class is used with the ThumbnailCaptionRequestEventHandler when thumbnail are being created from an ImageSource.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailCaptionRequestEventArgs : EventArgs
Public Class ThumbnailCaptionRequestEventArgs
    Inherits EventArgs

The ThumbnailCaptionRequestEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailCaptionRequestEventArgs(Stream, Int32) | Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the stream and frame index.
Public method | ThumbnailCaptionRequestEventArgs(String, Int32) | Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the filename and frame index.
Public method | ThumbnailCaptionRequestEventArgs(RandomAccessImageSource, Int32) | Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the image source and index.
Top
Properties
 | Name | Description
Public property | Caption | Gets or sets the caption for the thumbnail
Public property | FileName | Gets the filename of the thumbnail.
Public property | ImageSource | Gets the image source used for loading the thumbnail.
Public property | Index | Gets the index used from the image source.
Public property | Stream | Gets the stream used to generate the thumbnail.
Public property | ToolTip | Gets or sets the tooltip used for the thumbnail.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Constructor

Overload List
 | Name | Description
Public method | ThumbnailCaptionRequestEventArgs(Stream, Int32) | Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the stream and frame index.
Public method | ThumbnailCaptionRequestEventArgs(String, Int32) | Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the filename and frame index.
Public method | ThumbnailCaptionRequestEventArgs(RandomAccessImageSource, Int32) | Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the image source and index.
Top
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Constructor (Stream, Int32)

Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the stream and frame index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailCaptionRequestEventArgs(
    Stream stream,
    int index
)
Public Sub New (
    stream As Stream,
    index As Integer
)

Parameters

stream
Type: System.IOStream
A stream containing the image.
index
Type: SystemInt32
The frame index of the image.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
ThumbnailCaptionRequestEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Constructor (String, Int32)

Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the filename and frame index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailCaptionRequestEventArgs(
    string fileName,
    int frameIndex
)
Public Sub New (
    fileName As String,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The filename of the image.
frameIndex
Type: SystemInt32
The frame index of the image.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
ThumbnailCaptionRequestEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Constructor (RandomAccessImageSource, Int32)

Creates a new instance of ThumbnailCaptionRequestEventArgs specifying the image source and index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailCaptionRequestEventArgs(
    RandomAccessImageSource imageSource,
    int index
)
Public Sub New (
    imageSource As RandomAccessImageSource,
    index As Integer
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The RandomAccessImageSource used for loading.
index
Type: SystemInt32
The index of the the image from the ImageSource.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
ThumbnailCaptionRequestEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Properties

The ThumbnailCaptionRequestEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Gets or sets the caption for the thumbnail
Public property | FileName | Gets the filename of the thumbnail.
Public property | ImageSource | Gets the image source used for loading the thumbnail.
Public property | Index | Gets the index used from the image source.
Public property | Stream | Gets the stream used to generate the thumbnail.
Public property | ToolTip | Gets or sets the tooltip used for the thumbnail.
Top
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs.Caption Property

ThumbnailCaptionRequestEventArgsCaption Property

Gets or sets the caption for the thumbnail

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String
The caption for the thumbnail.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs.FileName Property

ThumbnailCaptionRequestEventArgsFileName Property

Gets the filename of the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The filename of the thumbnail.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs.ImageSource Property

ThumbnailCaptionRequestEventArgsImageSource Property

Gets the image source used for loading the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RandomAccessImageSource ImageSource { get; }
Public ReadOnly Property ImageSource As RandomAccessImageSource
    Get

Property Value

Type: RandomAccessImageSource
The image source used for the thumbnail.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs.Index Property

ThumbnailCaptionRequestEventArgsIndex Property

Gets the index used from the image source.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index used from the image source.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs.Stream Property

ThumbnailCaptionRequestEventArgsStream Property

Gets the stream used to generate the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
The stream used to generate the thumbnail.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs.ToolTip Property

ThumbnailCaptionRequestEventArgsToolTip Property

Gets or sets the tooltip used for the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set

Property Value

Type: String
The tooltip used for the thumbnail.
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventArgs Methods

The ThumbnailCaptionRequestEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailCaptionRequestEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCaptionRequestEventHandler Delegate

This event handler is used by the ThumbnailView to request caption and tooltip values for images loaded from an ImageSource.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ThumbnailCaptionRequestEventHandler(
    Object sender,
    ThumbnailCaptionRequestEventArgs e
)
Public Delegate Sub ThumbnailCaptionRequestEventHandler (
    sender As Object,
    e As ThumbnailCaptionRequestEventArgs
)

Parameters

sender
Type: SystemObject
The object sending this event.
e
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventArgs
A ThumbnailCaptionRequestEventArgs containing information about this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection Class

Contains a collection of Thumbnail objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.Imaging.WinControlsThumbnailCollection

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class ThumbnailCollection : CollectionBase,
    IDisposable
Public NotInheritable Class ThumbnailCollection
    Inherits CollectionBase
    Implements IDisposable

The ThumbnailCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of items in this collection.
Public property | IsFixedSize | Gets a value indicating whether this collection is fixed in size.
Public property | IsSynchronized | Gets a value indicating whether access to the ThumbnailCollection is synchronized (thread-safe).
Public property | Item |
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ThumbnailCollection.
Top
Methods
 | Name | Description
Public method | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the collection.
Public method | Add(Thumbnail) | Adds a Thumbnail to the collection.
Public method | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages of an image from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(AtalaImage, String) | Add a Thumbnail to the collection by specifying the AtalaImage and caption.
Public method | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource into the collection.
 | Add(String, Int32, String) | Adds a Thumbnail to the collection by specifying the filename, frame index and caption.
Public method | Add(AtalaImage, String, String) | Add a Thumbnail to the collection by specifying the AtalaImage, caption and tooltip.
Public method | Add(Stream, Int32, String, String) | Adds an image from a stream.
Public method | Add(String, Int32, String, String) | Adds a Thumbnail to the collection by specifying the filename, frame index, caption and tooltip.
 | AddRange | Adds an array of Thumbnail objects to the collection.
Public method | Cancel | Cancels any pending thumbnails from being processed and/or loaded.
Public method | Clear | Remove all images from the ThumbnailView control.
Public method | Contains | This method indicates whether or not a Thumbnail is contained within the collection.
Public method | CopyTo(Thumbnail) | Copies Thumbnail objects from this collection into an array.
Public method | CopyTo(Thumbnail, Int32) | Copies Thumbnail objects from this collection into an array.
Public method | CopyTo(Int32, Thumbnail, Int32, Int32) | Copies Thumbnail objects from this collection into an array.
Public method | Dispose | Clears the collection, disposing the Thumbnail objects in the process.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | This method will search for a specific Thumbnail and if found in the collection will return its index value.
Public method | Insert(Int32, Thumbnail) | Inserts a Thumbnail into the collection at the specified index.
Public method | Insert(Int32, Thumbnail) | Inserts an array of Thumbnails into the collection.
Public method | Insert(Int32, AtalaImage, String) | Obsolete. Inserts a Thumbnail into the collection by specifying the insert index, AtalaImage and caption.
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a stream into the collection.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from an image into the control.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts a thumbnail into the collection from an AtalaImage.
Public method | Insert(Int32, String, Int32, String) | Obsolete. Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index and caption.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts a thumbnail into the collection from a stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index, caption and tooltip.
 | Move | Moves a Thumbnail to a new index.
Public method | Reload | Reloads the thumbnails in the collection.
Public method | Remove(Thumbnail) | Removes a Thumbnail from the collection.
Public method | Remove(Thumbnail) | Removes an array of Thumbnail objects from the collection.
Public method | RemoveAt | Removes the Thumbnail at the specified index from the collection.
Public method | Replace(Int32, Thumbnail, Boolean) | Replaces one Thumbnail in the collection with another.
Public method | Replace(Thumbnail, Thumbnail, Boolean) | Replaces a Thumbnail in the collection with another.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Forces a thumbnail to create a new thumbnail image.
Top
Events
 | Name | Description
Public event | BeforeCreateThumbnail | Raised before each thumbnail is created to allow the image used for the thumbnail to be modified or replaced.
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection Properties

The ThumbnailCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of items in this collection.
Public property | IsFixedSize | Gets a value indicating whether this collection is fixed in size.
Public property | IsSynchronized | Gets a value indicating whether access to the ThumbnailCollection is synchronized (thread-safe).
Public property | Item |
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ThumbnailCollection.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Count Property

ThumbnailCollectionCount Property

Gets the number of items in this collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of items in this collection.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.IsFixedSize Property

ThumbnailCollectionIsFixedSize Property

Gets a value indicating whether this collection is fixed in size.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get

Property Value

Type: Boolean
True if the collection is fixed in size.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.IsSynchronized Property

ThumbnailCollectionIsSynchronized Property

Gets a value indicating whether access to the ThumbnailCollection is synchronized (thread-safe).

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
true if access to the ThumbnailCollection is synchronized (thread-safe); otherwise, false.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Item Property

ThumbnailCollectionItem Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Thumbnail
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Thumbnail
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.SyncRoot Property

ThumbnailCollectionSyncRoot Property

Gets an object that can be used to synchronize access to the ThumbnailCollection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the ThumbnailCollection.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection Methods

The ThumbnailCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the collection.
Public method | Add(Thumbnail) | Adds a Thumbnail to the collection.
Public method | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages of an image from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(AtalaImage, String) | Add a Thumbnail to the collection by specifying the AtalaImage and caption.
Public method | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource into the collection.
 | Add(String, Int32, String) | Adds a Thumbnail to the collection by specifying the filename, frame index and caption.
Public method | Add(AtalaImage, String, String) | Add a Thumbnail to the collection by specifying the AtalaImage, caption and tooltip.
Public method | Add(Stream, Int32, String, String) | Adds an image from a stream.
Public method | Add(String, Int32, String, String) | Adds a Thumbnail to the collection by specifying the filename, frame index, caption and tooltip.
 | AddRange | Adds an array of Thumbnail objects to the collection.
Public method | Cancel | Cancels any pending thumbnails from being processed and/or loaded.
Public method | Clear | Remove all images from the ThumbnailView control.
Public method | Contains | This method indicates whether or not a Thumbnail is contained within the collection.
Public method | CopyTo(Thumbnail) | Copies Thumbnail objects from this collection into an array.
Public method | CopyTo(Thumbnail, Int32) | Copies Thumbnail objects from this collection into an array.
Public method | CopyTo(Int32, Thumbnail, Int32, Int32) | Copies Thumbnail objects from this collection into an array.
Public method | Dispose | Clears the collection, disposing the Thumbnail objects in the process.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | This method will search for a specific Thumbnail and if found in the collection will return its index value.
Public method | Insert(Int32, Thumbnail) | Inserts a Thumbnail into the collection at the specified index.
Public method | Insert(Int32, Thumbnail) | Inserts an array of Thumbnails into the collection.
Public method | Insert(Int32, AtalaImage, String) | Obsolete. Inserts a Thumbnail into the collection by specifying the insert index, AtalaImage and caption.
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a stream into the collection.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from an image into the control.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts a thumbnail into the collection from an AtalaImage.
Public method | Insert(Int32, String, Int32, String) | Obsolete. Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index and caption.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts a thumbnail into the collection from a stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index, caption and tooltip.
 | Move | Moves a Thumbnail to a new index.
Public method | Reload | Reloads the thumbnails in the collection.
Public method | Remove(Thumbnail) | Removes a Thumbnail from the collection.
Public method | Remove(Thumbnail) | Removes an array of Thumbnail objects from the collection.
Public method | RemoveAt | Removes the Thumbnail at the specified index from the collection.
Public method | Replace(Int32, Thumbnail, Boolean) | Replaces one Thumbnail in the collection with another.
Public method | Replace(Thumbnail, Thumbnail, Boolean) | Replaces a Thumbnail in the collection with another.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Forces a thumbnail to create a new thumbnail image.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method

ThumbnailCollectionAdd Method

These methods add one or more thumbnails to the collection.
Overload List
 | Name | Description
Public method | Add(RandomAccessImageSource) | Adds images from a RandomAccessImageSource into the collection.
Public method | Add(Thumbnail) | Adds a Thumbnail to the collection.
Public method | Add(Stream, ThumbnailCaptionRequestEventHandler) | Adds all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(String, ThumbnailCaptionRequestEventHandler) | Adds all pages of an image from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Add(AtalaImage, String) | Add a Thumbnail to the collection by specifying the AtalaImage and caption.
Public method | Add(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Adds images from a RandomAccessImageSource into the collection.
 | Add(String, Int32, String) | Adds a Thumbnail to the collection by specifying the filename, frame index and caption.
Public method | Add(AtalaImage, String, String) | Add a Thumbnail to the collection by specifying the AtalaImage, caption and tooltip.
Public method | Add(Stream, Int32, String, String) | Adds an image from a stream.
Public method | Add(String, Int32, String, String) | Adds a Thumbnail to the collection by specifying the filename, frame index, caption and tooltip.
Top
Examples
ThumbnailCollectionAdd (C#)
Copy
this.thumbnailView1.Items.Add(@"C:\myfile.jpg", 0, "My File");
ThumbnailCollectionAddVB (Visual Basic)
Copy
Me.thumbnailView1.Items.Add("C:\myfile.jpg", 0, "My File")
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (RandomAccessImageSource)

ThumbnailCollectionAdd Method (RandomAccessImageSource)

Adds images from a RandomAccessImageSource into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    RandomAccessImageSource source
)
Public Sub Add (
    source As RandomAccessImageSource
)

Parameters

source
Type: Atalasoft.ImagingRandomAccessImageSource
The source object to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the source argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (Thumbnail)

ThumbnailCollectionAdd Method (Thumbnail)

Adds a Thumbnail to the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    Thumbnail thumbnail
)
Public Sub Add (
    thumbnail As Thumbnail
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to add.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the thumbnail is null (Nothing in VB).
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (Stream, ThumbnailCaptionRequestEventHandler)

ThumbnailCollectionAdd Method (Stream, ThumbnailCaptionRequestEventHandler)

Adds all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Add (
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

stream
Type: System.IOStream
The stream containing the image.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
IOException | Thrown if the stream is not seekable or does not have read access.
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (String, ThumbnailCaptionRequestEventHandler)

ThumbnailCollectionAdd Method (String, ThumbnailCaptionRequestEventHandler)

Adds all pages of an image from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Add (
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

fileName
Type: SystemString
The full path and filename of the image used to create the thumbnail.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB).
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (AtalaImage, String)

ThumbnailCollectionAdd Method (AtalaImage, String)

Add a Thumbnail to the collection by specifying the AtalaImage and caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    AtalaImage image,
    string caption
)
Public Function Add (
    image As AtalaImage,
    caption As String
) As Thumbnail

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage object used to create the thumbnail.
caption
Type: SystemString
The caption for the thumbnail.

Return Value

Type: Thumbnail
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

ThumbnailCollectionAdd Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Adds images from a RandomAccessImageSource into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    RandomAccessImageSource source,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Add (
    source As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

source
Type: Atalasoft.ImagingRandomAccessImageSource
The image source containing images to generate thumbnails for.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the source argument is null (Nothing in VB).
ArgumentException | Thrown if the source does not know its total image count.
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (String, Int32, String)

ThumbnailCollectionAdd Method (String, Int32, String)

Adds a Thumbnail to the collection by specifying the filename, frame index and caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    string fileName,
    int frameIndex,
    string caption
)
Public Function Add (
    fileName As String,
    frameIndex As Integer,
    caption As String
) As Thumbnail

Parameters

fileName
Type: SystemString
The full path and filename of the image used to create the thumbnail.
frameIndex
Type: SystemInt32
The frame index of the image.
caption
Type: SystemString
The caption for the thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
ArgumentOutOfRangeException | Thrown if the frame index is out of range for the image.
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (AtalaImage, String, String)

ThumbnailCollectionAdd Method (AtalaImage, String, String)

Add a Thumbnail to the collection by specifying the AtalaImage, caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    AtalaImage image,
    string caption,
    string tooltip
)
Public Function Add (
    image As AtalaImage,
    caption As String,
    tooltip As String
) As Thumbnail

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage object used to create the thumbnail.
caption
Type: SystemString
The caption for the thumbnail.
tooltip
Type: SystemString
The tooltip for the thumbnail.

Return Value

Type: Thumbnail
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (Stream, Int32, String, String)

ThumbnailCollectionAdd Method (Stream, Int32, String, String)

Adds an image from a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Function Add (
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

stream
Type: System.IOStream
The stream containing the image.
frameIndex
Type: SystemInt32
The frame index of the image.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip used for the thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
IOException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Add Method (String, Int32, String, String)

ThumbnailCollectionAdd Method (String, Int32, String, String)

Adds a Thumbnail to the collection by specifying the filename, frame index, caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Add(
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Function Add (
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

fileName
Type: SystemString
The full path and filename of the image used to create the thumbnail.
frameIndex
Type: SystemInt32
The frame index of the image.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip used for the thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
ArgumentOutOfRangeException | Thrown if the frame index is invalid for this image.
See Also

Reference

ThumbnailCollection Class
Add Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.AddRange Method

ThumbnailCollectionAddRange Method

Adds an array of Thumbnail objects to the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    Thumbnail[] thumbnails
)
Public Sub AddRange (
    thumbnails As Thumbnail()
)

Parameters

thumbnails
Type: Atalasoft.Imaging.WinControlsThumbnail
An array of items to add.
Remarks
Use this method when several thumbnails need to be added at once.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Cancel Method

ThumbnailCollectionCancel Method

Cancels any pending thumbnails from being processed and/or loaded.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Cancel()
Public Sub Cancel
Remarks
This method will abort any working threads.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Clear Method

ThumbnailCollectionClear Method

Remove all images from the ThumbnailView control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Contains Method

ThumbnailCollectionContains Method

This method indicates whether or not a Thumbnail is contained within the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    Thumbnail value
)
Public Function Contains (
    value As Thumbnail
) As Boolean

Parameters

value
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail to search for.

Return Value

Type: Boolean
True if the Thumbnail is contained within the collection.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.CopyTo Method

ThumbnailCollectionCopyTo Method

These methods are used to copy Thumbnail objects into a separate array.
Overload List
 | Name | Description
Public method | CopyTo(Thumbnail) | Copies Thumbnail objects from this collection into an array.
Public method | CopyTo(Thumbnail, Int32) | Copies Thumbnail objects from this collection into an array.
Public method | CopyTo(Int32, Thumbnail, Int32, Int32) | Copies Thumbnail objects from this collection into an array.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.CopyTo Method (Thumbnail[])

ThumbnailCollectionCopyTo Method (Thumbnail)

Copies Thumbnail objects from this collection into an array.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Thumbnail[] array
)
Public Sub CopyTo (
    array As Thumbnail()
)

Parameters

array
Type: Atalasoft.Imaging.WinControlsThumbnail
The array to copy the thumbnails into.
See Also

Reference

ThumbnailCollection Class
CopyTo Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.CopyTo Method (Thumbnail[], Int32)

ThumbnailCollectionCopyTo Method (Thumbnail, Int32)

Copies Thumbnail objects from this collection into an array.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    Thumbnail[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Thumbnail(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.Imaging.WinControlsThumbnail
The array to copy the thumbnails into.
arrayIndex
Type: SystemInt32
The index in array where copying should begin.
See Also

Reference

ThumbnailCollection Class
CopyTo Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.CopyTo Method (Int32, Thumbnail[], Int32, Int32)

ThumbnailCollectionCopyTo Method (Int32, Thumbnail, Int32, Int32)

Copies Thumbnail objects from this collection into an array.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    int index,
    Thumbnail[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    index As Integer,
    array As Thumbnail(),
    arrayIndex As Integer,
    count As Integer
)

Parameters

index
Type: SystemInt32
The collection index where copying should begin.
array
Type: Atalasoft.Imaging.WinControlsThumbnail
The array to copy the thumbnails into.
arrayIndex
Type: SystemInt32
The index in array where copying should begin.
count
Type: SystemInt32
The number of thumbnails to copy.
See Also

Reference

ThumbnailCollection Class
CopyTo Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Dispose Method

ThumbnailCollectionDispose Method

Clears the collection, disposing the Thumbnail objects in the process.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.IndexOf Method

ThumbnailCollectionIndexOf Method

This method will search for a specific Thumbnail and if found in the collection will return its index value.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    Thumbnail value
)
Public Function IndexOf (
    value As Thumbnail
) As Integer

Parameters

value
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail to search for.

Return Value

Type: Int32
The index value of the thumbnail or -1 if the thumbnail does not exist in the collection.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method

ThumbnailCollectionInsert Method

Inserts a thumbnail into the collection.
Overload List
 | Name | Description
Public method | Insert(Int32, Thumbnail) | Inserts a Thumbnail into the collection at the specified index.
Public method | Insert(Int32, Thumbnail) | Inserts an array of Thumbnails into the collection.
Public method | Insert(Int32, AtalaImage, String) | Obsolete. Inserts a Thumbnail into the collection by specifying the insert index, AtalaImage and caption.
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a stream into the collection.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from an image into the control.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts a thumbnail into the collection from an AtalaImage.
Public method | Insert(Int32, String, Int32, String) | Obsolete. Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index and caption.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts a thumbnail into the collection from a stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index, caption and tooltip.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, Thumbnail)

ThumbnailCollectionInsert Method (Int32, Thumbnail)

Inserts a Thumbnail into the collection at the specified index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Thumbnail item
)
Public Sub Insert (
    index As Integer,
    item As Thumbnail
)

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
item
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to insert.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index parameter is invalid for this collection.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, Thumbnail[])

ThumbnailCollectionInsert Method (Int32, Thumbnail)

Inserts an array of Thumbnails into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Thumbnail[] items
)
Public Sub Insert (
    index As Integer,
    items As Thumbnail()
)

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
items
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail objects to insert.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the items argument is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, AtalaImage, String)

ThumbnailCollectionInsert Method (Int32, AtalaImage, String)

Note: This API is now obsolete.

Inserts a Thumbnail into the collection by specifying the insert index, AtalaImage and caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This overload may be removed in future versions.",
    false)]
public Thumbnail Insert(
    int index,
    AtalaImage image,
    string caption
)
<ObsoleteAttribute("This overload may be removed in future versions.",
    false)>
Public Function Insert (
    index As Integer,
    image As AtalaImage,
    caption As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage that will be used to create the thumbnail.
caption
Type: SystemString
The caption for the thumbnail.

Return Value

Type: Thumbnail
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

ThumbnailCollectionInsert Method (Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Inserts images from a RandomAccessImageSource into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Insert (
    index As Integer,
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source containing images to insert.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, Stream, ThumbnailCaptionRequestEventHandler)

ThumbnailCollectionInsert Method (Int32, Stream, ThumbnailCaptionRequestEventHandler)

Inserts all pages from a stream into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Insert (
    index As Integer,
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
stream
Type: System.IOStream
A stream containing the image to generate the thumbnail from.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, String, ThumbnailCaptionRequestEventHandler)

ThumbnailCollectionInsert Method (Int32, String, ThumbnailCaptionRequestEventHandler)

Inserts all pages from an image into the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Insert (
    index As Integer,
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
fileName
Type: SystemString
The full path and filename of the image used to create the thumbnail.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
 | Thrown if the filename is null (Nothing in VB) or an empty string.
 | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, AtalaImage, String, String)

ThumbnailCollectionInsert Method (Int32, AtalaImage, String, String)

Inserts a thumbnail into the collection from an AtalaImage.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    AtalaImage image,
    string caption,
    string toolTip
)
Public Function Insert (
    index As Integer,
    image As AtalaImage,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection to insert the thumbnail.
image
Type: Atalasoft.ImagingAtalaImage
The image used to generate the thumbnail.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.

Return Value

Type: Thumbnail
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, String, Int32, String)

ThumbnailCollectionInsert Method (Int32, String, Int32, String)

Note: This API is now obsolete.

Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index and caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This overload may be removed in future versions.",
    false)]
public Thumbnail Insert(
    int index,
    string fileName,
    int frameIndex,
    string caption
)
<ObsoleteAttribute("This overload may be removed in future versions.",
    false)>
Public Function Insert (
    index As Integer,
    fileName As String,
    frameIndex As Integer,
    caption As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
fileName
Type: SystemString
The full path and filename of the image used to create the thumbnail.
frameIndex
Type: SystemInt32
The frame index of the image.
caption
Type: SystemString
The caption for the thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
 | Thrown if the index parameter is invalid for this collection.
 | Thrown if the filename is null (Nothing in VB) or an empty string.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, Stream, Int32, String, String)

ThumbnailCollectionInsert Method (Int32, Stream, Int32, String, String)

Inserts a thumbnail into the collection from a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Function Insert (
    index As Integer,
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection to insert the thumbnail.
stream
Type: System.IOStream
A stream containing the image to generate the thumbnail from.
frameIndex
Type: SystemInt32
The frame index of a multipage image to generate the thumbnail from.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip for the thumbnail.

Return Value

Type: Thumbnail
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Insert Method (Int32, String, Int32, String, String)

ThumbnailCollectionInsert Method (Int32, String, Int32, String, String)

Inserts a Thumbnail into the collection by specifying the insert index, filename, frame index, caption and tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Function Insert (
    index As Integer,
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index in the collection where the Thumbnail will be inserted.
fileName
Type: SystemString
The full path and filename of the image used to create the thumbnail.
frameIndex
Type: SystemInt32
The frame index of the image.
caption
Type: SystemString
The caption for the thumbnail.
toolTip
Type: SystemString
The tooltip used for the thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
 | Thrown if the index parameter is invalid for this collection.
See Also

Reference

ThumbnailCollection Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Move Method

ThumbnailCollectionMove Method

Moves a Thumbnail to a new index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Move(
    Thumbnail item,
    int newIndex
)
Public Sub Move (
    item As Thumbnail,
    newIndex As Integer
)

Parameters

item
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail to move.
newIndex
Type: SystemInt32
The new index for this Thumbnail.
Exceptions
Exception | Condition
 | Thrown if the item parameter is null.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Reload Method

ThumbnailCollectionReload Method

Reloads the thumbnails in the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Reload()
Public Sub Reload
Remarks
Use this method to force the thumbnails to be recreated.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Remove Method

ThumbnailCollectionRemove Method

Removes a thumbnail from the collection.
Overload List
 | Name | Description
Public method | Remove(Thumbnail) | Removes a Thumbnail from the collection.
Public method | Remove(Thumbnail) | Removes an array of Thumbnail objects from the collection.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Remove Method (Thumbnail)

ThumbnailCollectionRemove Method (Thumbnail)

Removes a Thumbnail from the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    Thumbnail thumbnail
)
Public Sub Remove (
    thumbnail As Thumbnail
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
See Also

Reference

ThumbnailCollection Class
Remove Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Remove Method (Thumbnail[])

ThumbnailCollectionRemove Method (Thumbnail)

Removes an array of Thumbnail objects from the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    Thumbnail[] thumbnails
)
Public Sub Remove (
    thumbnails As Thumbnail()
)

Parameters

thumbnails
Type: Atalasoft.Imaging.WinControlsThumbnail
An array of thumbnails to remove.
See Also

Reference

ThumbnailCollection Class
Remove Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.RemoveAt Method

ThumbnailCollectionRemoveAt Method

Removes the Thumbnail at the specified index from the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the thumbnail to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index parameter is invalid for this collection.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Replace Method

ThumbnailCollectionReplace Method

Replaces one thumbnail with another.
Overload List
 | Name | Description
Public method | Replace(Int32, Thumbnail, Boolean) | Replaces one Thumbnail in the collection with another.
Public method | Replace(Thumbnail, Thumbnail, Boolean) | Replaces a Thumbnail in the collection with another.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Replace Method (Int32, Thumbnail, Boolean)

ThumbnailCollectionReplace Method (Int32, Thumbnail, Boolean)

Replaces one Thumbnail in the collection with another.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    int index,
    Thumbnail newItem,
    bool disposeReplacedItem
)
Public Sub Replace (
    index As Integer,
    newItem As Thumbnail,
    disposeReplacedItem As Boolean
)

Parameters

index
Type: SystemInt32
The index of the thumbnail to replace.
newItem
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to use at this index.
disposeReplacedItem
Type: SystemBoolean
Indicates whether the previous thumbnail should be disposed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for this collection.
ArgumentNullException | Thrown if the newItem parameter is null.
See Also

Reference

ThumbnailCollection Class
Replace Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Replace Method (Thumbnail, Thumbnail, Boolean)

ThumbnailCollectionReplace Method (Thumbnail, Thumbnail, Boolean)

Replaces a Thumbnail in the collection with another.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Replace(
    Thumbnail currentItem,
    Thumbnail newItem,
    bool disposeReplacedItem
)
Public Sub Replace (
    currentItem As Thumbnail,
    newItem As Thumbnail,
    disposeReplacedItem As Boolean
)

Parameters

currentItem
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to replace.
newItem
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail that will take the place of the current one.
disposeReplacedItem
Type: SystemBoolean
Indicates whether the previous thumbnail will be disposed.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the currentItem or newItem parameter is null.
See Also

Reference

ThumbnailCollection Class
Replace Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.Update Method

ThumbnailCollectionUpdate Method

Forces a thumbnail to create a new thumbnail image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Update(
    Thumbnail item,
    AtalaImage image
)
Public Sub Update (
    item As Thumbnail,
    image As AtalaImage
)

Parameters

item
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to update.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage used to generate the new thumbnail.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection Events

The ThumbnailCollection type exposes the following members.

Events
 | Name | Description
Public event | BeforeCreateThumbnail | Raised before each thumbnail is created to allow the image used for the thumbnail to be modified or replaced.
Top
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCollection.BeforeCreateThumbnail Event

ThumbnailCollectionBeforeCreateThumbnail Event

Raised before each thumbnail is created to allow the image used for the thumbnail to be modified or replaced.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<BeforeCreateThumbnailEventArgs> BeforeCreateThumbnail
Public Event BeforeCreateThumbnail As EventHandler(Of BeforeCreateThumbnailEventArgs)

Value

Type: SystemEventHandlerBeforeCreateThumbnailEventArgs
Remarks
The image provided in the event arguments is the full size image the thumbnail will be generated from.
See Also

Reference

ThumbnailCollection Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs Class

This class is used with the CompareThumbnails event to allow a custom sort.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsThumbnailCompareEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailCompareEventArgs : EventArgs
Public Class ThumbnailCompareEventArgs
    Inherits EventArgs

The ThumbnailCompareEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailCompareEventArgs | Creates a new instance of ThumbnailCompareEventArgs.
Top
Properties
 | Name | Description
Public property | Result | Gets or sets the result of the comparison.
Public property | Thumbnail1 | Gets the thumbnail being compared to.
Public property | Thumbnail2 | Gets the thumbnail object to compare with Thumbnail1.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs Constructor

Creates a new instance of ThumbnailCompareEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailCompareEventArgs(
    Thumbnail tn1,
    Thumbnail tn2
)
Public Sub New (
    tn1 As Thumbnail,
    tn2 As Thumbnail
)

Parameters

tn1
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail being compared to.
tn2
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail used for comparing.
See Also

Reference

ThumbnailCompareEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs Properties

The ThumbnailCompareEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Result | Gets or sets the result of the comparison.
Public property | Thumbnail1 | Gets the thumbnail being compared to.
Public property | Thumbnail2 | Gets the thumbnail object to compare with Thumbnail1.
Top
See Also

Reference

ThumbnailCompareEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs.Result Property

ThumbnailCompareEventArgsResult Property

Gets or sets the result of the comparison.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Result { get; set; }
Public Property Result As Integer
    Get
    Set

Property Value

Type: Int32

A value indicating whether the Thumbnail1 and Thumbnail2 items are equal, less than or greater than each other.

If Thumbnail1 is less than Thumbnail2, return a value less than zero. If Thumbnail1 is equal to Thumbnail2 return 0. If Thumbnail1 is greater than Thumbnail2 return a value greater than zero.

See Also

Reference

ThumbnailCompareEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs.Thumbnail1 Property

ThumbnailCompareEventArgsThumbnail1 Property

Gets the thumbnail being compared to.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Thumbnail1 { get; }
Public ReadOnly Property Thumbnail1 As Thumbnail
    Get

Property Value

Type: Thumbnail
The Thumbnail object being compared to.
See Also

Reference

ThumbnailCompareEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs.Thumbnail2 Property

ThumbnailCompareEventArgsThumbnail2 Property

Gets the thumbnail object to compare with Thumbnail1.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Thumbnail2 { get; }
Public ReadOnly Property Thumbnail2 As Thumbnail
    Get

Property Value

Type: Thumbnail
The Thumbnail object to compare.
See Also

Reference

ThumbnailCompareEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailCompareEventArgs Methods

The ThumbnailCompareEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailCompareEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties Class

This class is used to hold property values for a ThumbnailView control used by the DocumentViewer.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsThumbnailControlProperties

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class ThumbnailControlProperties
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class ThumbnailControlProperties

The ThumbnailControlProperties type exposes the following members.

Properties
 | Name | Description
Public property | Activation |
Public property | AllowDrop | Gets or sets a value indicating whether to allow items to be dropped onto it.
Public property | ArrowKeyAction | Gets or sets the action taken when an arrow key is pressed.
Public property | Asynchronous |
Public property | AutoDragDrop |
Public property | BackColor | Gets or sets the background color of the control.
Public property | CaptionFormat |
Public property | CaptionLines |
Public property | CaptionSpacing |
Public property | ContextMenu | Gets or sets the ContextMenu for the control.
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip to use for the control.
Public property | Cursor | Gets or sets the Cursor for the control.
Public property | DisplayText |
Public property | DragDistanceTrigger |
Public property | DragDropMode |
Public property | DragSelectionColor |
Public property | DropPositionIndicator | Gets or sets the type of position indicator used for drag drop operations.
Public property | EnableMouseWheel |
Public property | ErrorImage |
Public property | FocusedItem |
Public property | Font | Gets or sets the Font used for the captions.
Public property | ForeColor | Gets or sets the color used for the captions.
Public property | GrabFocusOnMouseEnter |
Public property | HighlightBackgroundColor |
Public property | HighlightBrush |
Public property | HighlightTextColor |
Public property | HoverItem |
Public property | Items |
Public property | LabelEdit |
Public property | LoadErrorMessage |
Public property | LoadMethod |
Public property | Margins |
Public property | MaxWorkerThreads |
Public property | PlaceholderImage | Gets or sets the image used as a placeholder for the thumbnails that have not been loaded.
Public property | PlaceholderMessage | Gets or sets the message to render as a placeholder for thumbnails that have not been loaded.
Public property | SelectedIndicies |
Public property | SelectedItems |
Public property | SelectedItemsOrder |
Public property | SelectedItemStyle |
Public property | SelectionMode |
Public property | SelectionRectangleBackColor |
Public property | SelectionRectangleDashStyle |
Public property | SelectionRectangleLineColor |
Public property | SortBy |
Public property | SortOrder |
Public property | Spacing |
Public property | ThumbnailBackground |
Public property | ThumbnailLayout |
Public property | ThumbnailOffset |
Public property | ThumbnailSize |
Public property | ToolTipControl |
Public property | TopItem |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string name for the class. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties Properties

The ThumbnailControlProperties type exposes the following members.

Properties
 | Name | Description
Public property | Activation |
Public property | AllowDrop | Gets or sets a value indicating whether to allow items to be dropped onto it.
Public property | ArrowKeyAction | Gets or sets the action taken when an arrow key is pressed.
Public property | Asynchronous |
Public property | AutoDragDrop |
Public property | BackColor | Gets or sets the background color of the control.
Public property | CaptionFormat |
Public property | CaptionLines |
Public property | CaptionSpacing |
Public property | ContextMenu | Gets or sets the ContextMenu for the control.
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip to use for the control.
Public property | Cursor | Gets or sets the Cursor for the control.
Public property | DisplayText |
Public property | DragDistanceTrigger |
Public property | DragDropMode |
Public property | DragSelectionColor |
Public property | DropPositionIndicator | Gets or sets the type of position indicator used for drag drop operations.
Public property | EnableMouseWheel |
Public property | ErrorImage |
Public property | FocusedItem |
Public property | Font | Gets or sets the Font used for the captions.
Public property | ForeColor | Gets or sets the color used for the captions.
Public property | GrabFocusOnMouseEnter |
Public property | HighlightBackgroundColor |
Public property | HighlightBrush |
Public property | HighlightTextColor |
Public property | HoverItem |
Public property | Items |
Public property | LabelEdit |
Public property | LoadErrorMessage |
Public property | LoadMethod |
Public property | Margins |
Public property | MaxWorkerThreads |
Public property | PlaceholderImage | Gets or sets the image used as a placeholder for the thumbnails that have not been loaded.
Public property | PlaceholderMessage | Gets or sets the message to render as a placeholder for thumbnails that have not been loaded.
Public property | SelectedIndicies |
Public property | SelectedItems |
Public property | SelectedItemsOrder |
Public property | SelectedItemStyle |
Public property | SelectionMode |
Public property | SelectionRectangleBackColor |
Public property | SelectionRectangleDashStyle |
Public property | SelectionRectangleLineColor |
Public property | SortBy |
Public property | SortOrder |
Public property | Spacing |
Public property | ThumbnailBackground |
Public property | ThumbnailLayout |
Public property | ThumbnailOffset |
Public property | ThumbnailSize |
Public property | ToolTipControl |
Public property | TopItem |
Top
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Activation Property

ThumbnailControlPropertiesActivation Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemActivation Activation { get; set; }
Public Property Activation As ItemActivation
    Get
    Set

Property Value

Type: ItemActivation
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.AllowDrop Property

ThumbnailControlPropertiesAllowDrop Property

Gets or sets a value indicating whether to allow items to be dropped onto it.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowDrop { get; set; }
Public Property AllowDrop As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether items can be dropped onto the control.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ArrowKeyAction Property

ThumbnailControlPropertiesArrowKeyAction Property

Gets or sets the action taken when an arrow key is pressed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ArrowKeyAction ArrowKeyAction { get; set; }
Public Property ArrowKeyAction As ArrowKeyAction
    Get
    Set

Property Value

Type: ArrowKeyAction
The action taken for an arrow key.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Asynchronous Property

ThumbnailControlPropertiesAsynchronous Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Asynchronous { get; set; }
Public Property Asynchronous As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.AutoDragDrop Property

ThumbnailControlPropertiesAutoDragDrop Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoDragDrop { get; set; }
Public Property AutoDragDrop As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.BackColor Property

ThumbnailControlPropertiesBackColor Property

Gets or sets the background color of the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color of the control.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.CaptionFormat Property

ThumbnailControlPropertiesCaptionFormat Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringFormat CaptionFormat { get; }
Public ReadOnly Property CaptionFormat As StringFormat
    Get

Property Value

Type: StringFormat
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.CaptionLines Property

ThumbnailControlPropertiesCaptionLines Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CaptionLines { get; set; }
Public Property CaptionLines As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.CaptionSpacing Property

ThumbnailControlPropertiesCaptionSpacing Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CaptionSpacing { get; set; }
Public Property CaptionSpacing As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ContextMenu Property

ThumbnailControlPropertiesContextMenu Property

Gets or sets the ContextMenu for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContextMenu ContextMenu { get; set; }
Public Property ContextMenu As ContextMenu
    Get
    Set

Property Value

Type: ContextMenu
The ContextMenu for the control.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ContextMenuStrip Property

ThumbnailControlPropertiesContextMenuStrip Property

Gets or sets the ContextMenuStrip to use for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ContextMenuStrip ContextMenuStrip { get; set; }
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set

Property Value

Type: ContextMenuStrip
The ContextMenuStrip to use for the control.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Cursor Property

ThumbnailControlPropertiesCursor Property

Gets or sets the Cursor for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor Cursor { get; set; }
Public Property Cursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The Cursor for the control.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.DisplayText Property

ThumbnailControlPropertiesDisplayText Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbViewAttribute DisplayText { get; set; }
Public Property DisplayText As ThumbViewAttribute
    Get
    Set

Property Value

Type: ThumbViewAttribute
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.DragDistanceTrigger Property

ThumbnailControlPropertiesDragDistanceTrigger Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DragDistanceTrigger { get; set; }
Public Property DragDistanceTrigger As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.DragDropMode Property

ThumbnailControlPropertiesDragDropMode Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DragDropMode DragDropMode { get; set; }
Public Property DragDropMode As DragDropMode
    Get
    Set

Property Value

Type: DragDropMode
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.DragSelectionColor Property

ThumbnailControlPropertiesDragSelectionColor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color DragSelectionColor { get; set; }
Public Property DragSelectionColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.DropPositionIndicator Property

ThumbnailControlPropertiesDropPositionIndicator Property

Gets or sets the type of position indicator used for drag drop operations.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDropPositionIndicator DropPositionIndicator { get; set; }
Public Property DropPositionIndicator As ThumbnailDropPositionIndicator
    Get
    Set

Property Value

Type: ThumbnailDropPositionIndicator
The type of position indicator used for drag drop operations.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.EnableMouseWheel Property

ThumbnailControlPropertiesEnableMouseWheel Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableMouseWheel { get; set; }
Public Property EnableMouseWheel As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ErrorImage Property

ThumbnailControlPropertiesErrorImage Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image ErrorImage { get; set; }
Public Property ErrorImage As Image
    Get
    Set

Property Value

Type: Image
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.FocusedItem Property

ThumbnailControlPropertiesFocusedItem Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail FocusedItem { get; }
Public ReadOnly Property FocusedItem As Thumbnail
    Get

Property Value

Type: Thumbnail
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Font Property

ThumbnailControlPropertiesFont Property

Gets or sets the Font used for the captions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set

Property Value

Type: Font
The Font used for the captions.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ForeColor Property

ThumbnailControlPropertiesForeColor Property

Gets or sets the color used for the captions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set

Property Value

Type: Color
The color used for the captions.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.GrabFocusOnMouseEnter Property

ThumbnailControlPropertiesGrabFocusOnMouseEnter Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GrabFocusOnMouseEnter { get; set; }
Public Property GrabFocusOnMouseEnter As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.HighlightBackgroundColor Property

ThumbnailControlPropertiesHighlightBackgroundColor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HighlightBackgroundColor { get; set; }
Public Property HighlightBackgroundColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.HighlightBrush Property

ThumbnailControlPropertiesHighlightBrush Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Brush HighlightBrush { get; set; }
Public Property HighlightBrush As Brush
    Get
    Set

Property Value

Type: Brush
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.HighlightTextColor Property

ThumbnailControlPropertiesHighlightTextColor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HighlightTextColor { get; set; }
Public Property HighlightTextColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.HoverItem Property

ThumbnailControlPropertiesHoverItem Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail HoverItem { get; }
Public ReadOnly Property HoverItem As Thumbnail
    Get

Property Value

Type: Thumbnail
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Items Property

ThumbnailControlPropertiesItems Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailCollection Items { get; }
Public ReadOnly Property Items As ThumbnailCollection
    Get

Property Value

Type: ThumbnailCollection
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.LabelEdit Property

ThumbnailControlPropertiesLabelEdit Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool LabelEdit { get; set; }
Public Property LabelEdit As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.LoadErrorMessage Property

ThumbnailControlPropertiesLoadErrorMessage Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LoadErrorMessage { get; set; }
Public Property LoadErrorMessage As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.LoadMethod Property

ThumbnailControlPropertiesLoadMethod Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbLoadMethod LoadMethod { get; set; }
Public Property LoadMethod As ThumbLoadMethod
    Get
    Set

Property Value

Type: ThumbLoadMethod
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Margins Property

ThumbnailControlPropertiesMargins Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margin Margins { get; set; }
Public Property Margins As Margin
    Get
    Set

Property Value

Type: Margin
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.MaxWorkerThreads Property

ThumbnailControlPropertiesMaxWorkerThreads Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxWorkerThreads { get; set; }
Public Property MaxWorkerThreads As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.PlaceholderImage Property

ThumbnailControlPropertiesPlaceholderImage Property

Gets or sets the image used as a placeholder for the thumbnails that have not been loaded.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image PlaceholderImage { get; set; }
Public Property PlaceholderImage As Image
    Get
    Set

Property Value

Type: Image
The image used as a thumbnail placeholder.
Remarks
Setting PlaceholderImage will override the PlaceholderMessage property.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.PlaceholderMessage Property

ThumbnailControlPropertiesPlaceholderMessage Property

Gets or sets the message to render as a placeholder for thumbnails that have not been loaded.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PlaceholderMessage { get; set; }
Public Property PlaceholderMessage As String
    Get
    Set

Property Value

Type: String
The message rendered as a placeholder for thumbnails.
Remarks
If the PlaceholderImage property is set, it will override the PlaceholderMessage.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectedIndicies Property

ThumbnailControlPropertiesSelectedIndicies Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] SelectedIndicies { get; }
Public ReadOnly Property SelectedIndicies As Integer()
    Get

Property Value

Type: Int32
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectedItems Property

ThumbnailControlPropertiesSelectedItems Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedThumbnailCollection SelectedItems { get; }
Public ReadOnly Property SelectedItems As SelectedThumbnailCollection
    Get

Property Value

Type: SelectedThumbnailCollection
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectedItemsOrder Property

ThumbnailControlPropertiesSelectedItemsOrder Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedItemsOrder SelectedItemsOrder { get; set; }
Public Property SelectedItemsOrder As SelectedItemsOrder
    Get
    Set

Property Value

Type: SelectedItemsOrder
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectedItemStyle Property

ThumbnailControlPropertiesSelectedItemStyle Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedItemRenderStyle SelectedItemStyle { get; set; }
Public Property SelectedItemStyle As SelectedItemRenderStyle
    Get
    Set

Property Value

Type: SelectedItemRenderStyle
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectionMode Property

ThumbnailControlPropertiesSelectionMode Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailSelectionMode SelectionMode { get; set; }
Public Property SelectionMode As ThumbnailSelectionMode
    Get
    Set

Property Value

Type: ThumbnailSelectionMode
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectionRectangleBackColor Property

ThumbnailControlPropertiesSelectionRectangleBackColor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color SelectionRectangleBackColor { get; set; }
Public Property SelectionRectangleBackColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectionRectangleDashStyle Property

ThumbnailControlPropertiesSelectionRectangleDashStyle Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DashStyle SelectionRectangleDashStyle { get; set; }
Public Property SelectionRectangleDashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SelectionRectangleLineColor Property

ThumbnailControlPropertiesSelectionRectangleLineColor Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color SelectionRectangleLineColor { get; set; }
Public Property SelectionRectangleLineColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SortBy Property

ThumbnailControlPropertiesSortBy Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbViewAttribute SortBy { get; set; }
Public Property SortBy As ThumbViewAttribute
    Get
    Set

Property Value

Type: ThumbViewAttribute
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.SortOrder Property

ThumbnailControlPropertiesSortOrder Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SortOrder SortOrder { get; set; }
Public Property SortOrder As SortOrder
    Get
    Set

Property Value

Type: SortOrder
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.Spacing Property

ThumbnailControlPropertiesSpacing Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Spacing { get; set; }
Public Property Spacing As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ThumbnailBackground Property

ThumbnailControlPropertiesThumbnailBackground Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image ThumbnailBackground { get; set; }
Public Property ThumbnailBackground As Image
    Get
    Set

Property Value

Type: Image
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ThumbnailLayout Property

ThumbnailControlPropertiesThumbnailLayout Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailLayout ThumbnailLayout { get; set; }
Public Property ThumbnailLayout As ThumbnailLayout
    Get
    Set

Property Value

Type: ThumbnailLayout
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ThumbnailOffset Property

ThumbnailControlPropertiesThumbnailOffset Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ThumbnailOffset { get; set; }
Public Property ThumbnailOffset As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ThumbnailSize Property

ThumbnailControlPropertiesThumbnailSize Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ThumbnailSize { get; set; }
Public Property ThumbnailSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ToolTipControl Property

ThumbnailControlPropertiesToolTipControl Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ToolTip ToolTipControl { get; set; }
Public Property ToolTipControl As ToolTip
    Get
    Set

Property Value

Type: ToolTip
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.TopItem Property

ThumbnailControlPropertiesTopItem Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail TopItem { get; }
Public ReadOnly Property TopItem As Thumbnail
    Get

Property Value

Type: Thumbnail
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties Methods

The ThumbnailControlProperties type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string name for the class. (Overrides ObjectToString.)
Top
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailControlProperties.ToString Method

ThumbnailControlPropertiesToString Method

Returns a string name for the class.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string name for the class.
See Also

Reference

ThumbnailControlProperties Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Class

This class is used to bind the ThumbnailView to a data source.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsThumbnailDataBinding

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailDataBinding : IDisposable
Public Class ThumbnailDataBinding
    Implements IDisposable

The ThumbnailDataBinding type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailDataBinding | Creates a new instance of ThumbnailDataBinding.
Public method | ThumbnailDataBinding(Object, String) | Creates a new instance of ThumbnailDataBinding specifying the data source and image data member.
Public method | ThumbnailDataBinding(Object, String, String) | Creates a new instance of ThumbnailDataBinding specifying the data source, filename and frame index data members.
Public method | ThumbnailDataBinding(Object, String, String, String) | Creates a new instance of ThumbnailDataBinding specifying the data source, image, caption and tooltip data members.
Public method | ThumbnailDataBinding(Object, String, String, String, String) | Creates a new instance of ThumbnailDataBinding specifying the data source, filename, frame index, caption and tooltip data members.
Top
Properties
 | Name | Description
Public property | CaptionDataMember | Gets or sets the data member used for the thumbnail caption.
Public property | DataSource | Gets or sets the data source used for binding.
Public property | FileNameDataMember | Gets or sets the data member used for the filename of the image.
Public property | FrameIndexDataMember | Gets or sets the data member used for the frame index of the image.
Public property | ImageDataMember | Gets or sets the data member for the image data.
Public property | ToolTipDataMember | Gets or sets the data member used for the tooltip.
Top
Methods
 | Name | Description
Public method | Dispose | Releases the resources used by the ThumbnailDataBinding class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataMemberChanged | This method is called when a change to the data source has been detected.
Protected method | OnDataSourceChanged | This method is called when the DataSource has been changed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DataChanged | Raised when data in the source has changed.
Public event | DataMemberChanged | Raised when a data member property has been changed.
Public event | DataReset | This event is raised when the data source has been reset.
Public event | DataSourceChanged | Raised when the DataSource property has been changed.
Top
Remarks
To bind to a data source, pass an instance of this class to the SetDataBinding(ThumbnailDataBinding) method.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Constructor

Overload List
 | Name | Description
Public method | ThumbnailDataBinding | Creates a new instance of ThumbnailDataBinding.
Public method | ThumbnailDataBinding(Object, String) | Creates a new instance of ThumbnailDataBinding specifying the data source and image data member.
Public method | ThumbnailDataBinding(Object, String, String) | Creates a new instance of ThumbnailDataBinding specifying the data source, filename and frame index data members.
Public method | ThumbnailDataBinding(Object, String, String, String) | Creates a new instance of ThumbnailDataBinding specifying the data source, image, caption and tooltip data members.
Public method | ThumbnailDataBinding(Object, String, String, String, String) | Creates a new instance of ThumbnailDataBinding specifying the data source, filename, frame index, caption and tooltip data members.
Top
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Constructor

Creates a new instance of ThumbnailDataBinding.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDataBinding()
Public Sub New
See Also

Reference

ThumbnailDataBinding Class
ThumbnailDataBinding Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Constructor (Object, String)

Creates a new instance of ThumbnailDataBinding specifying the data source and image data member.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDataBinding(
    Object dataSource,
    string imageDataMember
)
Public Sub New (
    dataSource As Object,
    imageDataMember As String
)

Parameters

dataSource
Type: SystemObject
The data source for this binding. This can be a DataView or DataTable.
imageDataMember
Type: SystemString
The data member for the image. If the data source is an IList, this member can be a byte array containing the image or an AtalaImage object. For other data source objects this must be a byte array field.
See Also

Reference

ThumbnailDataBinding Class
ThumbnailDataBinding Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Constructor (Object, String, String)

Creates a new instance of ThumbnailDataBinding specifying the data source, filename and frame index data members.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDataBinding(
    Object dataSource,
    string fileNameDataMember,
    string frameIndexDataMember
)
Public Sub New (
    dataSource As Object,
    fileNameDataMember As String,
    frameIndexDataMember As String
)

Parameters

dataSource
Type: SystemObject
The data source for this binding. This can be a DataView or DataTable.
fileNameDataMember
Type: SystemString
The data member for the image filename.
frameIndexDataMember
Type: SystemString
The data member of the frame index of the image.
See Also

Reference

ThumbnailDataBinding Class
ThumbnailDataBinding Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Constructor (Object, String, String, String)

Creates a new instance of ThumbnailDataBinding specifying the data source, image, caption and tooltip data members.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDataBinding(
    Object dataSource,
    string imageDataMember,
    string captionDataMember,
    string toolTipDataMember
)
Public Sub New (
    dataSource As Object,
    imageDataMember As String,
    captionDataMember As String,
    toolTipDataMember As String
)

Parameters

dataSource
Type: SystemObject
The data source for this binding. This can be a DataView or DataTable.
imageDataMember
Type: SystemString
The data member for the image. If the data source is an IList, this member can be a byte array containing the image or an AtalaImage object. For other data source objects this must be a byte array field.
captionDataMember
Type: SystemString
The data member used for the caption. Pass null (Nothing in VB) to disable this member.
toolTipDataMember
Type: SystemString
The data member used for the tooltip. Pass null (Nothing in VB) to disable this member.
See Also

Reference

ThumbnailDataBinding Class
ThumbnailDataBinding Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Constructor (Object, String, String, String, String)

Creates a new instance of ThumbnailDataBinding specifying the data source, filename, frame index, caption and tooltip data members.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDataBinding(
    Object dataSource,
    string fileNameDataMember,
    string frameIndexDataMember,
    string captionDataMember,
    string toolTipDataMember
)
Public Sub New (
    dataSource As Object,
    fileNameDataMember As String,
    frameIndexDataMember As String,
    captionDataMember As String,
    toolTipDataMember As String
)

Parameters

dataSource
Type: SystemObject
The data source for this binding. This can be a DataView or DataTable.
fileNameDataMember
Type: SystemString
The data member for the image filename.
frameIndexDataMember
Type: SystemString
The data member of the frame index of the image.
captionDataMember
Type: SystemString
The data member used for the caption. Pass null (Nothing in VB) to disable this member.
toolTipDataMember
Type: SystemString
The data member used for the tooltip. Pass null (Nothing in VB) to disable this member.
See Also

Reference

ThumbnailDataBinding Class
ThumbnailDataBinding Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Properties

The ThumbnailDataBinding type exposes the following members.

Properties
 | Name | Description
Public property | CaptionDataMember | Gets or sets the data member used for the thumbnail caption.
Public property | DataSource | Gets or sets the data source used for binding.
Public property | FileNameDataMember | Gets or sets the data member used for the filename of the image.
Public property | FrameIndexDataMember | Gets or sets the data member used for the frame index of the image.
Public property | ImageDataMember | Gets or sets the data member for the image data.
Public property | ToolTipDataMember | Gets or sets the data member used for the tooltip.
Top
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.CaptionDataMember Property

ThumbnailDataBindingCaptionDataMember Property

Gets or sets the data member used for the thumbnail caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CaptionDataMember { get; set; }
Public Property CaptionDataMember As String
    Get
    Set

Property Value

Type: String
The data member for the caption.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.DataSource Property

ThumbnailDataBindingDataSource Property

Gets or sets the data source used for binding.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object DataSource { get; set; }
Public Property DataSource As Object
    Get
    Set

Property Value

Type: Object
The data source used for binding.
Remarks
The data source must be a DataView or DataRow object.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.FileNameDataMember Property

ThumbnailDataBindingFileNameDataMember Property

Gets or sets the data member used for the filename of the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileNameDataMember { get; set; }
Public Property FileNameDataMember As String
    Get
    Set

Property Value

Type: String
The data member for the image filename.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.FrameIndexDataMember Property

ThumbnailDataBindingFrameIndexDataMember Property

Gets or sets the data member used for the frame index of the image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FrameIndexDataMember { get; set; }
Public Property FrameIndexDataMember As String
    Get
    Set

Property Value

Type: String
The data member for frame index.
Remarks
If this property is not set the first frame will be used.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.ImageDataMember Property

ThumbnailDataBindingImageDataMember Property

Gets or sets the data member for the image data.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageDataMember { get; set; }
Public Property ImageDataMember As String
    Get
    Set

Property Value

Type: String
The data member for the image data.
Remarks
If the data source is an IList, this member can be a byte array containing the image or an AtalaImage object. For other data source objects this must be a byte array field.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.ToolTipDataMember Property

ThumbnailDataBindingToolTipDataMember Property

Gets or sets the data member used for the tooltip.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ToolTipDataMember { get; set; }
Public Property ToolTipDataMember As String
    Get
    Set

Property Value

Type: String
The data member for the tooltip.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Methods

The ThumbnailDataBinding type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases the resources used by the ThumbnailDataBinding class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataMemberChanged | This method is called when a change to the data source has been detected.
Protected method | OnDataSourceChanged | This method is called when the DataSource has been changed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.Dispose Method

ThumbnailDataBindingDispose Method

Releases the resources used by the ThumbnailDataBinding class.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.OnDataMemberChanged Method

ThumbnailDataBindingOnDataMemberChanged Method

This method is called when a change to the data source has been detected.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDataMemberChanged(
    DataMemberChangedEventArgs e
)
Protected Overridable Sub OnDataMemberChanged (
    e As DataMemberChangedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsDataMemberChangedEventArgs
A DataMemberChangedEventArgs containing information about this change.
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.OnDataSourceChanged Method

ThumbnailDataBindingOnDataSourceChanged Method

This method is called when the DataSource has been changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDataSourceChanged()
Protected Overridable Sub OnDataSourceChanged
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding Events

The ThumbnailDataBinding type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Raised when data in the source has changed.
Public event | DataMemberChanged | Raised when a data member property has been changed.
Public event | DataReset | This event is raised when the data source has been reset.
Public event | DataSourceChanged | Raised when the DataSource property has been changed.
Top
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.DataChanged Event

ThumbnailDataBindingDataChanged Event

Raised when data in the source has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DataRowChangeEventHandler DataChanged
Public Event DataChanged As DataRowChangeEventHandler

Value

Type: System.DataDataRowChangeEventHandler
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.DataMemberChanged Event

ThumbnailDataBindingDataMemberChanged Event

Raised when a data member property has been changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DataMemberChangedEventHandler DataMemberChanged
Public Event DataMemberChanged As DataMemberChangedEventHandler

Value

Type: Atalasoft.Imaging.WinControlsDataMemberChangedEventHandler
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.DataReset Event

ThumbnailDataBindingDataReset Event

This event is raised when the data source has been reset.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler DataReset
Public Event DataReset As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDataBinding.DataSourceChanged Event

ThumbnailDataBindingDataSourceChanged Event

Raised when the DataSource property has been changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler DataSourceChanged
Public Event DataSourceChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThumbnailDataBinding Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation Class

This class is used for a drag and drop operation on the ThumbnailView control.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsThumbnailDragDropOperation

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailDragDropOperation
Public Class ThumbnailDragDropOperation

The ThumbnailDragDropOperation type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailDragDropOperation(ThumbnailView, Thumbnail, DragDropMode) | Obsolete. Creates a new ThumbnailDragDropOperation.
Public method | ThumbnailDragDropOperation(ThumbnailView, Thumbnail, DragDropMode, Int32) | Creates a new ThumbnailDragDropOperation specifying the source ThumbnailView, the items to drop, the mode and original index values of the thumbnails.
Top
Properties
 | Name | Description
Public property | Indexes | Gets an array of the original index values of the thumbnails.
Public property | Items | Gets the thumbnails being dragged.
Public property | Mode | Gets the drag drop mode for this action.
Public property | NewIndexes | Gets an array of index values for the thumbnails that were used in a drag drop operation.
Public property | Source | Gets the ThumbnailView control from where the thumbnails are being dragged.
Public property | UsingTempFiles |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation Constructor

Overload List
 | Name | Description
Public method | ThumbnailDragDropOperation(ThumbnailView, Thumbnail, DragDropMode) | Obsolete. Creates a new ThumbnailDragDropOperation.
Public method | ThumbnailDragDropOperation(ThumbnailView, Thumbnail, DragDropMode, Int32) | Creates a new ThumbnailDragDropOperation specifying the source ThumbnailView, the items to drop, the mode and original index values of the thumbnails.
Top
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation Constructor (ThumbnailView, Thumbnail[], DragDropMode)

ThumbnailDragDropOperation Constructor (ThumbnailView, Thumbnail, DragDropMode)

Note: This API is now obsolete.

Creates a new ThumbnailDragDropOperation.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This overload may be removed in future versions.",
    false)]
public ThumbnailDragDropOperation(
    ThumbnailView source,
    Thumbnail[] items,
    DragDropMode mode
)
<ObsoleteAttribute("This overload may be removed in future versions.",
    false)>
Public Sub New (
    source As ThumbnailView,
    items As Thumbnail(),
    mode As DragDropMode
)

Parameters

source
Type: Atalasoft.Imaging.WinControlsThumbnailView
The source ThumbnailView where these items are dragged from.
items
Type: Atalasoft.Imaging.WinControlsThumbnail
An array of Thumbnail objects that are being dragged.
mode
Type: Atalasoft.Imaging.WinControlsDragDropMode
The type of drag and drop action being performed.
See Also

Reference

ThumbnailDragDropOperation Class
ThumbnailDragDropOperation Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation Constructor (ThumbnailView, Thumbnail[], DragDropMode, Int32[])

ThumbnailDragDropOperation Constructor (ThumbnailView, Thumbnail, DragDropMode, Int32)

Creates a new ThumbnailDragDropOperation specifying the source ThumbnailView, the items to drop, the mode and original index values of the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDragDropOperation(
    ThumbnailView source,
    Thumbnail[] items,
    DragDropMode mode,
    int[] indexes
)
Public Sub New (
    source As ThumbnailView,
    items As Thumbnail(),
    mode As DragDropMode,
    indexes As Integer()
)

Parameters

source
Type: Atalasoft.Imaging.WinControlsThumbnailView
The source ThumbnailView where these items are dragged from.
items
Type: Atalasoft.Imaging.WinControlsThumbnail
An array of Thumbnail objects that are being dragged.
mode
Type: Atalasoft.Imaging.WinControlsDragDropMode
The type of drag and drop action being performed.
indexes
Type: SystemInt32
An array of index values the thumbnails were dragged from.
See Also

Reference

ThumbnailDragDropOperation Class
ThumbnailDragDropOperation Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation Properties

The ThumbnailDragDropOperation type exposes the following members.

Properties
 | Name | Description
Public property | Indexes | Gets an array of the original index values of the thumbnails.
Public property | Items | Gets the thumbnails being dragged.
Public property | Mode | Gets the drag drop mode for this action.
Public property | NewIndexes | Gets an array of index values for the thumbnails that were used in a drag drop operation.
Public property | Source | Gets the ThumbnailView control from where the thumbnails are being dragged.
Public property | UsingTempFiles |
Top
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation.Indexes Property

ThumbnailDragDropOperationIndexes Property

Gets an array of the original index values of the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] Indexes { get; }
Public ReadOnly Property Indexes As Integer()
    Get

Property Value

Type: Int32
The original index values of the thumbnails.
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation.Items Property

ThumbnailDragDropOperationItems Property

Gets the thumbnails being dragged.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail[] Items { get; }
Public ReadOnly Property Items As Thumbnail()
    Get

Property Value

Type: Thumbnail
An array of Thumbnail objects.
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation.Mode Property

ThumbnailDragDropOperationMode Property

Gets the drag drop mode for this action.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DragDropMode Mode { get; }
Public ReadOnly Property Mode As DragDropMode
    Get

Property Value

Type: DragDropMode
The action used for this drag and drop operation.
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation.NewIndexes Property

ThumbnailDragDropOperationNewIndexes Property

Gets an array of index values for the thumbnails that were used in a drag drop operation.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] NewIndexes { get; }
Public ReadOnly Property NewIndexes As Integer()
    Get

Property Value

Type: Int32
The new index values for thumbnails that were used in a drag drop operation.
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation.Source Property

ThumbnailDragDropOperationSource Property

Gets the ThumbnailView control from where the thumbnails are being dragged.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailView Source { get; }
Public ReadOnly Property Source As ThumbnailView
    Get

Property Value

Type: ThumbnailView
The source ThumbnailView that the thumbnails were dragged from.
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation.UsingTempFiles Property

ThumbnailDragDropOperationUsingTempFiles Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool[] UsingTempFiles { get; }
Public ReadOnly Property UsingTempFiles As Boolean()
    Get

Property Value

Type: Boolean
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDragDropOperation Methods

The ThumbnailDragDropOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailDragDropOperation Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventArgs Class

This class is send in the ThumbnailDrop event to indicate where the dropped items were placed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsThumbnailDropEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailDropEventArgs : EventArgs
Public Class ThumbnailDropEventArgs
    Inherits EventArgs

The ThumbnailDropEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailDropEventArgs | Creates an instance of ThumbnailDropEventArgs.
Top
Properties
 | Name | Description
Public property | DragDropOperation | Gets the ThumbnailDragDropOperation for this drag drop event.
Public property | InsertIndex | Gets the index value where the first item was inserted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventArgs Constructor

Creates an instance of ThumbnailDropEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDropEventArgs(
    int insertIndex,
    ThumbnailDragDropOperation dragDropOperation
)
Public Sub New (
    insertIndex As Integer,
    dragDropOperation As ThumbnailDragDropOperation
)

Parameters

insertIndex
Type: SystemInt32
The index where the first item was dropped.
dragDropOperation
Type: Atalasoft.Imaging.WinControlsThumbnailDragDropOperation
The ThumbnailDragDropOperation that was dropped.
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventArgs Properties

The ThumbnailDropEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DragDropOperation | Gets the ThumbnailDragDropOperation for this drag drop event.
Public property | InsertIndex | Gets the index value where the first item was inserted.
Top
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventArgs.DragDropOperation Property

ThumbnailDropEventArgsDragDropOperation Property

Gets the ThumbnailDragDropOperation for this drag drop event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDragDropOperation DragDropOperation { get; }
Public ReadOnly Property DragDropOperation As ThumbnailDragDropOperation
    Get

Property Value

Type: ThumbnailDragDropOperation
The ThumbnailDragDropOperation for this drag drop event.
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventArgs.InsertIndex Property

ThumbnailDropEventArgsInsertIndex Property

Gets the index value where the first item was inserted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InsertIndex { get; }
Public ReadOnly Property InsertIndex As Integer
    Get

Property Value

Type: Int32
The index value where the first item was inserted.
Remarks
If multiple items were dropped, they are inserted in order starting at this index value.
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventArgs Methods

The ThumbnailDropEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailDropEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailDropEventHandler Delegate

Represents the method that will handle the ThumbnailDrop event of the ThumbnailView and FolderThumbnailView controls.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ThumbnailDropEventHandler(
    Object sender,
    ThumbnailDropEventArgs e
)
Public Delegate Sub ThumbnailDropEventHandler (
    sender As Object,
    e As ThumbnailDropEventArgs
)

Parameters

sender
Type: SystemObject
The control raising this event.
e
Type: Atalasoft.Imaging.WinControlsThumbnailDropEventArgs
A ThumbnailDropEventArgs containing information about this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailDropPositionIndicator Enumeration

Defines the drop position indicator used with the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ThumbnailDropPositionIndicator
Public Enumeration ThumbnailDropPositionIndicator
Members
Member name | Description
Rectangle | The drop position thumbnail will show a rectangle around it.
IBeam | An IBeam indicator is rendered between the thumbnails to show the insert position.
Custom | Causes the EraseDropPositionIndicator and PaintDropPositionIndicator events to fire for custom drawing.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailEventArgs Class

Provides data for various events in the ThumbnailView control.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsThumbnailEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailEventArgs : EventArgs
Public Class ThumbnailEventArgs
    Inherits EventArgs

The ThumbnailEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailEventArgs | Initializes a new instance of the ThumbnailEventArgs class
Top
Properties
 | Name | Description
Public property | Thumbnail | Gets the Thumbnail object containing data about the thumbnail image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace
ThumbnailViewThumbnailActivate
ThumbnailViewThumbnailClicked
ThumbnailViewThumbnailDoubleClicked


ThumbnailEventArgs Constructor

Initializes a new instance of the ThumbnailEventArgs class

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailEventArgs(
    Thumbnail tn
)
Public Sub New (
    tn As Thumbnail
)

Parameters

tn
Type: Atalasoft.Imaging.WinControlsThumbnail
See Also

Reference

ThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailEventArgs Properties

The ThumbnailEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Thumbnail | Gets the Thumbnail object containing data about the thumbnail image.
Top
See Also

Reference

ThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailEventArgs.Thumbnail Property

ThumbnailEventArgsThumbnail Property

Gets the Thumbnail object containing data about the thumbnail image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Thumbnail { get; }
Public ReadOnly Property Thumbnail As Thumbnail
    Get

Property Value

Type: Thumbnail
The Thumbnail object containing data about the thumbnail image.
See Also

Reference

ThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailEventArgs Methods

The ThumbnailEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailEventHandler Delegate

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ThumbnailEventHandler(
    Object sender,
    ThumbnailEventArgs e
)
Public Delegate Sub ThumbnailEventHandler (
    sender As Object,
    e As ThumbnailEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.Imaging.WinControlsThumbnailEventArgs
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer Class

This class is used to synchronize a ThumbnailView and an ImageViewer control together.

The ThumbnailImageViewerSynchronizer will handle loading the image of a selected thumbnail into the viewer and updating the thumbnail image when the image has been modified.

Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WinControlsThumbnailImageViewerSynchronizer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailImageViewerSynchronizer : IDisposable
Public Class ThumbnailImageViewerSynchronizer
    Implements IDisposable

The ThumbnailImageViewerSynchronizer type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailImageViewerSynchronizer | Initializes a new instance of the ThumbnailImageViewerSynchronizer class
Top
Properties
 | Name | Description
Public property | CurrentImageIndex | Gets the index of the current image.
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Dispose | Releases resources used by the class.
Protected method | Dispose(Boolean) | Releases resources used by the class and indicates is this method was called from the public Dispose method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a stream into the collection.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the collection.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an image into the collection.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts or add a thumbnail to the ThumbnailView from a stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts or add a thumbnail.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCurrentImageIndexChanged | Called when the CurrentImageIndex property has changed and raises the CurrentImageIndexChanged event.
Public method | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Opens images from a RandomAccessImageSource.
Public method | Open(Stream, Int32, String, String) | Opens an image from a stream.
Public method | Open(String, Int32, String, String) | Opens an image from a file.
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CurrentImageIndexChanged | Raised when the CurrentImageIndex property changes.
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer Constructor

Initializes a new instance of the ThumbnailImageViewerSynchronizer class

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailImageViewerSynchronizer(
    DocumentViewerThumbnailView thumbnailView,
    ImageViewer imageViewer,
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub New (
    thumbnailView As DocumentViewerThumbnailView,
    imageViewer As ImageViewer,
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

thumbnailView
Type: Atalasoft.Imaging.WinControlsDocumentViewerThumbnailView
imageViewer
Type: Atalasoft.Imaging.WinControlsImageViewer
imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer Properties

The ThumbnailImageViewerSynchronizer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentImageIndex | Gets the index of the current image.
Top
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.CurrentImageIndex Property

ThumbnailImageViewerSynchronizerCurrentImageIndex Property

Gets the index of the current image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentImageIndex { get; }
Public ReadOnly Property CurrentImageIndex As Integer
    Get

Property Value

Type: Int32
The index of the current image.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer Methods

The ThumbnailImageViewerSynchronizer type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Dispose | Releases resources used by the class.
Protected method | Dispose(Boolean) | Releases resources used by the class and indicates is this method was called from the public Dispose method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a stream into the collection.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the collection.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an image into the collection.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts or add a thumbnail to the ThumbnailView from a stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts or add a thumbnail.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCurrentImageIndexChanged | Called when the CurrentImageIndex property has changed and raises the CurrentImageIndexChanged event.
Public method | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Opens images from a RandomAccessImageSource.
Public method | Open(Stream, Int32, String, String) | Opens an image from a stream.
Public method | Open(String, Int32, String, String) | Opens an image from a file.
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Clear Method

ThumbnailImageViewerSynchronizerClear Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Dispose Method

ThumbnailImageViewerSynchronizerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases resources used by the class.
Protected method | Dispose(Boolean) | Releases resources used by the class and indicates is this method was called from the public Dispose method.
Top
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Dispose Method

ThumbnailImageViewerSynchronizerDispose Method

Releases resources used by the class.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Dispose Method (Boolean)

ThumbnailImageViewerSynchronizerDispose Method (Boolean)

Releases resources used by the class and indicates is this method was called from the public Dispose method.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates if this was called from the public Dispose method.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Finalize Method

ThumbnailImageViewerSynchronizerFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method

ThumbnailImageViewerSynchronizerInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Inserts images from a RandomAccessImageSource into the collection.
Public method | Insert(Int32, Stream, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a stream into the collection.
Public method | Insert(Int32, String, ThumbnailCaptionRequestEventHandler) | Inserts all pages from a file into the collection.
Public method | Insert(Int32, AtalaImage, String, String) | Inserts an image into the collection.
Public method | Insert(Int32, Stream, Int32, String, String) | Inserts or add a thumbnail to the ThumbnailView from a stream.
Public method | Insert(Int32, String, Int32, String, String) | Inserts or add a thumbnail.
Top
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method (Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

ThumbnailImageViewerSynchronizerInsert Method (Int32, RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Inserts images from a RandomAccessImageSource into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Insert (
    index As Integer,
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted or -1 to add the thumbnail to the end of the collection.
imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source containing images to insert.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method (Int32, Stream, ThumbnailCaptionRequestEventHandler)

ThumbnailImageViewerSynchronizerInsert Method (Int32, Stream, ThumbnailCaptionRequestEventHandler)

Inserts all pages from a stream into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Insert (
    index As Integer,
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted or -1 to add the thumbnail to the end of the collection.
stream
Type: System.IOStream
A stream containing the image. This stream must be seekable.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method (Int32, String, ThumbnailCaptionRequestEventHandler)

ThumbnailImageViewerSynchronizerInsert Method (Int32, String, ThumbnailCaptionRequestEventHandler)

Inserts all pages from a file into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Function Insert (
    index As Integer,
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
) As Thumbnail

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted or -1 to add the thumbnail to the end of the collection.
fileName
Type: SystemString
The full path and filename of the image to add.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method (Int32, AtalaImage, String, String)

ThumbnailImageViewerSynchronizerInsert Method (Int32, AtalaImage, String, String)

Inserts an image into the collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    AtalaImage image,
    string caption,
    string toolTip
)
Public Function Insert (
    index As Integer,
    image As AtalaImage,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted or -1 to add the thumbnail to the end of the collection.
image
Type: Atalasoft.ImagingAtalaImage
The image to insert.
caption
Type: SystemString
The thumbnail caption.
toolTip
Type: SystemString
The thumbnail tooltip.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the image is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the index is out of range for this collection.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method (Int32, Stream, Int32, String, String)

ThumbnailImageViewerSynchronizerInsert Method (Int32, Stream, Int32, String, String)

Inserts or add a thumbnail to the ThumbnailView from a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Function Insert (
    index As Integer,
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted or -1 to add the thumbnail to the end of the collection.
stream
Type: System.IOStream
A stream containing the image. This stream must be seekable.
frameIndex
Type: SystemInt32
The frame index of the image or -1 to load all frames from a multipage image.
caption
Type: SystemString
The thumbnail caption.
toolTip
Type: SystemString
The thumbnail tooltip.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
ArgumentException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the index is out of rand for this collection.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Insert Method (Int32, String, Int32, String, String)

ThumbnailImageViewerSynchronizerInsert Method (Int32, String, Int32, String, String)

Inserts or add a thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail Insert(
    int index,
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Function Insert (
    index As Integer,
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
) As Thumbnail

Parameters

index
Type: SystemInt32
The index where the thumbnail should be inserted or -1 to add the thumbnail to the end of the collection.
fileName
Type: SystemString
The full path and filename of the image to add.
frameIndex
Type: SystemInt32
The frame index of the image or -1 to load all frames from a multipage image.
caption
Type: SystemString
The thumbnail caption.
toolTip
Type: SystemString
The thumbnail tooltip.

Return Value

Type: Thumbnail
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB).
FileNotFoundException | Thrown if the filename cannot be found.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Insert Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.OnCurrentImageIndexChanged Method

ThumbnailImageViewerSynchronizerOnCurrentImageIndexChanged Method

Called when the CurrentImageIndex property has changed and raises the CurrentImageIndexChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCurrentImageIndexChanged(
    EventArgs e
)
Protected Overridable Sub OnCurrentImageIndexChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Open Method

ThumbnailImageViewerSynchronizerOpen Method

Opens an image.
Overload List
 | Name | Description
Public method | Open(Stream, ThumbnailCaptionRequestEventHandler) | Opens all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Open(String, ThumbnailCaptionRequestEventHandler) | Opens all pages from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.
Public method | Open(RandomAccessImageSource, ThumbnailCaptionRequestEventHandler) | Opens images from a RandomAccessImageSource.
Public method | Open(Stream, Int32, String, String) | Opens an image from a stream.
Public method | Open(String, Int32, String, String) | Opens an image from a file.
Top
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Open Method (Stream, ThumbnailCaptionRequestEventHandler)

ThumbnailImageViewerSynchronizerOpen Method (Stream, ThumbnailCaptionRequestEventHandler)

Opens all pages from a stream and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Open (
    stream As Stream,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

stream
Type: System.IOStream
A stream containing the image. This stream must be seekable.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
IOException | Thrown if the stream is not seekable or does not have read access.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Open Method (String, ThumbnailCaptionRequestEventHandler)

ThumbnailImageViewerSynchronizerOpen Method (String, ThumbnailCaptionRequestEventHandler)

Opens all pages from a file and gets the caption and tooltip from a ThumbnailCaptionRequestEventHandler.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Open (
    fileName As String,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

fileName
Type: SystemString
The full path and filename of the image to add.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the filename is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Open Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

ThumbnailImageViewerSynchronizerOpen Method (RandomAccessImageSource, ThumbnailCaptionRequestEventHandler)

Opens images from a RandomAccessImageSource.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    RandomAccessImageSource imageSource,
    ThumbnailCaptionRequestEventHandler captionRequestHandler
)
Public Sub Open (
    imageSource As RandomAccessImageSource,
    captionRequestHandler As ThumbnailCaptionRequestEventHandler
)

Parameters

imageSource
Type: Atalasoft.ImagingRandomAccessImageSource
The image source containing images to load.
captionRequestHandler
Type: Atalasoft.Imaging.WinControlsThumbnailCaptionRequestEventHandler
A ThumbnailCaptionRequestEventHandler to call when a caption and/or tooltip is needed for a thumbnail.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the imageSource argument is null (Nothing in VB).
ArgumentException | Thrown if the image source does not know its total image count.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Open Method (Stream, Int32, String, String)

ThumbnailImageViewerSynchronizerOpen Method (Stream, Int32, String, String)

Opens an image from a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

stream
Type: System.IOStream
A stream containing the image. This stream must be seekable.
frameIndex
Type: SystemInt32
The frame index of the image or -1 to load all frames from a multipage image.
caption
Type: SystemString
The thumbnail caption.
toolTip
Type: SystemString
The thumbnail tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the stream is null (Nothing in VB).
IOException | Thrown if the stream is not seekable or does not have read access.
ArgumentOutOfRangeException | Thrown if the frame index is invalid for this stream.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Open Method (String, Int32, String, String)

ThumbnailImageViewerSynchronizerOpen Method (String, Int32, String, String)

Opens an image from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex,
    string caption,
    string toolTip
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer,
    caption As String,
    toolTip As String
)

Parameters

fileName
Type: SystemString
The full path and filename of the image to add.
frameIndex
Type: SystemInt32
The frame index of the image or -1 to load all frames from a multipage image.
caption
Type: SystemString
The thumbnail caption.
toolTip
Type: SystemString
The thumbnail tooltip.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the fileName is null (Nothing in VB) or an empty string.
FileNotFoundException | Thrown if the file cannot be found.
ArgumentOutOfRangeException | Thrown if the frame index is invalid for this file.
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.Remove Method

ThumbnailImageViewerSynchronizerRemove Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    Thumbnail thumbnail
)
Public Sub Remove (
    thumbnail As Thumbnail
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.RemoveAt Method

ThumbnailImageViewerSynchronizerRemoveAt Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer Events

The ThumbnailImageViewerSynchronizer type exposes the following members.

Events
 | Name | Description
Public event | CurrentImageIndexChanged | Raised when the CurrentImageIndex property changes.
Top
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailImageViewerSynchronizer.CurrentImageIndexChanged Event

ThumbnailImageViewerSynchronizerCurrentImageIndexChanged Event

Raised when the CurrentImageIndex property changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler CurrentImageIndexChanged
Public Event CurrentImageIndexChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThumbnailImageViewerSynchronizer Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLayout Enumeration

This enumeration is used with the ThumbnailLayout property to indicate the layout of the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ThumbnailLayout
Public Enumeration ThumbnailLayout
Members
Member name | Description
Vertical | The thumbnails are ordered from left to right, top to bottom. A vertical scrollbar will be displayed when needed.
Horizontal | The thumbnails are ordered from top to bottom, left to right. A horizontal scrollbar will be displayed when needed.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Class

Provides data for the BeforeThumbnailLoad event in the ThumbnailView control.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WinControlsThumbnailLoadEventArgs

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailLoadEventArgs : EventArgs
Public Class ThumbnailLoadEventArgs
    Inherits EventArgs

The ThumbnailLoadEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailLoadEventArgs | Creates a new instance of ThumbnailLoadEventArgs.
Public method | ThumbnailLoadEventArgs(AtalaImage, String) | Obsolete. Creates a new instance of ThumbnailLoadEventArgs specifying the image or filename.
Public method | ThumbnailLoadEventArgs(AtalaImage, String, Stream) | Creates a new instance of ThumbnailLoadEventArgs specifying the image, filename or stream used to create the thumbnail.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this operation should be canceled.
Public property | FileName | Gets the filename of the image file that is to be loaded. This value is null (Nothing in VB) if the image was not loaded from a file.
Public property | Image | Gets or sets the AtalaImage that was passed into the Thumbnail control. This value is null (Nothing in VB) if the image is not loaded from an AtalaImage.
Public property | Stream | Gets or sets the stream used to create the thumbnail. This value is null (Nothing in VB) if the image is not loaded from a stream.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Constructor

Overload List
 | Name | Description
Public method | ThumbnailLoadEventArgs | Creates a new instance of ThumbnailLoadEventArgs.
Public method | ThumbnailLoadEventArgs(AtalaImage, String) | Obsolete. Creates a new instance of ThumbnailLoadEventArgs specifying the image or filename.
Public method | ThumbnailLoadEventArgs(AtalaImage, String, Stream) | Creates a new instance of ThumbnailLoadEventArgs specifying the image, filename or stream used to create the thumbnail.
Top
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Constructor

Creates a new instance of ThumbnailLoadEventArgs.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailLoadEventArgs()
Public Sub New
See Also

Reference

ThumbnailLoadEventArgs Class
ThumbnailLoadEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Constructor (AtalaImage, String)

Note: This API is now obsolete.

Creates a new instance of ThumbnailLoadEventArgs specifying the image or filename.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This overload may be removed in a future release.",
    false)]
public ThumbnailLoadEventArgs(
    AtalaImage image,
    string fileName
)
<ObsoleteAttribute("This overload may be removed in a future release.",
    false)>
Public Sub New (
    image As AtalaImage,
    fileName As String
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image from which the thumbnail will be created.
fileName
Type: SystemString
The filename of the image.
See Also

Reference

ThumbnailLoadEventArgs Class
ThumbnailLoadEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Constructor (AtalaImage, String, Stream)

Creates a new instance of ThumbnailLoadEventArgs specifying the image, filename or stream used to create the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailLoadEventArgs(
    AtalaImage image,
    string fileName,
    Stream stream
)
Public Sub New (
    image As AtalaImage,
    fileName As String,
    stream As Stream
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image from which the thumbnail will be created.
fileName
Type: SystemString
The filename of the image.
stream
Type: System.IOStream

The stream used to create the thumbnail.

See Also

Reference

ThumbnailLoadEventArgs Class
ThumbnailLoadEventArgs Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Properties

The ThumbnailLoadEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this operation should be canceled.
Public property | FileName | Gets the filename of the image file that is to be loaded. This value is null (Nothing in VB) if the image was not loaded from a file.
Public property | Image | Gets or sets the AtalaImage that was passed into the Thumbnail control. This value is null (Nothing in VB) if the image is not loaded from an AtalaImage.
Public property | Stream | Gets or sets the stream used to create the thumbnail. This value is null (Nothing in VB) if the image is not loaded from a stream.
Top
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs.Cancel Property

ThumbnailLoadEventArgsCancel Property

Gets or sets a value indicating whether this operation should be canceled.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether this operation should be canceled.
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs.FileName Property

ThumbnailLoadEventArgsFileName Property

Gets the filename of the image file that is to be loaded. This value is null (Nothing in VB) if the image was not loaded from a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The filename of the image file that is to be loaded.
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs.Image Property

ThumbnailLoadEventArgsImage Property

Gets or sets the AtalaImage that was passed into the Thumbnail control. This value is null (Nothing in VB) if the image is not loaded from an AtalaImage.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The image used to create the thumbnail.
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs.Stream Property

ThumbnailLoadEventArgsStream Property

Gets or sets the stream used to create the thumbnail. This value is null (Nothing in VB) if the image is not loaded from a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; set; }
Public Property Stream As Stream
    Get
    Set

Property Value

Type: Stream
The stream used to created the thumbnail.
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventArgs Methods

The ThumbnailLoadEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThumbnailLoadEventArgs Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailLoadEventHandler Delegate

Represents a method used to handle custom loading or cancelation of a thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ThumbnailLoadEventHandler(
    Object sender,
    ThumbnailLoadEventArgs e
)
Public Delegate Sub ThumbnailLoadEventHandler (
    sender As Object,
    e As ThumbnailLoadEventArgs
)

Parameters

sender
Type: SystemObject
The object that raised the event.
e
Type: Atalasoft.Imaging.WinControlsThumbnailLoadEventArgs
A ThumbnailLoadEventArgs containing information for this event.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailSelectionMode Enumeration

Defines the selection mode of the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ThumbnailSelectionMode
Public Enumeration ThumbnailSelectionMode
Members
Member name | Description
SingleSelect | Only one thumbnail can be selected at a time.
MultiSelect | Multiple thumbnails can be selected by holding down the CTRL or SHIFT key when clicking on a thumbnails.
MultiSelectNoKeys | Multiple thumbnails can be selected simply by clicking on the thumbnails; no key press is required. Clicking a selected thumbnail will deselect it.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ThumbnailView Class

A thumbnail list control designed to display thumbnails of AtalaImage objects, or image files.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
Atalasoft.Imaging.WinControlsThumbnailView
Atalasoft.Imaging.WinControlsDocumentViewerThumbnailView
Atalasoft.Imaging.WinControlsFolderThumbnailView

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThumbnailView : ScrollableControl,
    IComparer
Public Class ThumbnailView
    Inherits ScrollableControl
    Implements IComparer

The ThumbnailView type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbnailView | Creates a new instance of the ThumbnailView control.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the method required by to user to activate a thumbnail.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowKeyAction | Gets or sets the action taken when the ThumbnailView receives an arrow key press event.
Public property | Asynchronous | Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously.
Public property | AutoDragDrop | Gets or sets a value indicating whether the internal drag and drop code is used.
Public property | AutoScroll | (Overrides ScrollableControlAutoScroll.)
Public property | AutoScrollMargin |
Public property | AutoScrollMinSize |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFormat | Gets the StringFormat used for rendering the thumbnail captions.
Public property | CaptionLines | Gets or sets the number of text lines to allocate for the caption area.
Public property | CaptionSpacing | Gets or sets the amount of space between the thumbnail area and the caption.
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ScrollableControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | DisplayText | Tells the thumbview which attribute to display
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DragDistanceTrigger | Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation.
Public property | DragDropMode | Gets or sets the drag and drop mode used when AutoDragDrop is true.
Public property | DragSelectionColor | Gets or sets the color of the outline drawn during a drag and drop operation.
Public property | DropPositionIndicator | Gets or sets the style of drag drop insert indicator used by the ThumbnailView.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableMouseWheel | Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events.
Public property | ErrorImage | Gets or sets the image displayed when there is an error reading a file.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | FocusedItem | Gets the Thumbnail item that currently has focus.
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GrabFocusOnMouseEnter | Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundColor | Gets or sets the color used for the highlight (selected) background.
Public property | HighlightBrush | Gets or sets the brush used for the highlight (selected) background.
Public property | HighlightTextColor | Gets or sets the caption text color used when an item is selected.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HoverItem | Gets the Thumbnail the mouse is currently hovering over.
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating if the control has been disposed.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a reference to the ThumbnailCollection for this control.
Public property | LabelEdit | Gets or sets a value indicating if the text below the thumbnail can be modified by the user.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LoadErrorMessage | Gets or sets the error message that will be displayed when there is an error loading images.
Public property | LoadMethod | Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Margins | Gets or sets the margins used for the control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxWorkerThreads | Gets or sets the number of worker threads that will be active at a single time in the thread pool.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Obsolete. Gets or sets a value indicating whether multiple thumbnails can be selected at once.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PlaceholderImage | Gets or sets an image used as a placeholder before the thumbnails are loaded.
Public property | PlaceholderMessage | Gets or sets the message displayed as a placeholder for thumbnails.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndices | Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control.
Public property | SelectedItems | Gets a ThumbnailCollection containing the currently selected thumbnails.
Public property | SelectedItemsOrder | Gets or sets the ordering used for the SelectedItems collection.
Public property | SelectedItemStyle | Gets or sets the style used when rendering the highlight for selected items.
Public property | SelectionMode | Gets or sets the selection mode used to select the thumbnails.
Public property | SelectionRectangleBackColor | Gets or sets the background color used for the selection rectangle.
Public property | SelectionRectangleDashStyle | Gets or sets the selection rectangle line style.
Public property | SelectionRectangleLineColor | Gets or sets the line color used for the selection rectangle.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SortBy | Gets or sets the ThumbViewAttribute used to sort the thumbnails.
Public property | SortOrder | Gets or sets the sort order of the thumbnails.
Public property | Spacing | Gets or sets the amount of spacing between the thumbnails.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ThumbnailBackground | Gets or sets the background image used for the thumbnails.
Public property | ThumbnailLayout | Gets or sets the layout used for the thumbnails.
Public property | ThumbnailOffset | Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area.
Public property | ThumbnailSize | Gets or sets the size of the thumbnails in pixels.
Public property | ToolTipControl | Gets or sets the ToolTip control used to display tooltips for the thumbnails.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets the index of the first thumbnail in the visible area of the control.
Public property | TopItem | Gets the Thumbnail displayed at the top of the control.
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddAfterDragDrop | Override to change the way a thumbnail is added to an empty control, if you are using the ThumbnailView in a composite control
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelection | This method will unselect any selected thumbnails in the control.
Public method | Compare | Compares two Thumbnail objects.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the ThumbnailView and releases any resources back to the system. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible.
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDropIndex | Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexAt | Returns the thumbnail index value from the specified client position.
Public method | GetItemAt | Gets the Thumbnail located at specific x, y coordinates.
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index.
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaltSorting | Use this method to temporarily keep the ThumbnailCollection from sorting items.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | This method is used to allow input from special keys. (Overrides ControlIsInputKey(Keys).)
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView.
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView.
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView.
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView.
Protected method | MakeThumbnailDragDropOperation |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterLabelEdit | Called after the thumbnail caption has been modified by the user.
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeLabelEdit | Called when the user is trying to modifiy the thumbnail caption.
Protected method | OnBeforeThumbnailLoad | Called just before a thumbnail image is created.
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a click event has occurred. (Overrides ControlOnClick(EventArgs).)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollectionChanged | Called when there has been a change in the ThumbnailCollection.
Protected method | OnCompare | Called when two thumbnails need to be compared.
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataChanged | Called when a DataRow has changed in the data source.
Protected method | OnDataMemberChanged | Called when a data member has changed.
Protected method | OnDataSourceChanged | Called when the data source has changed.
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Called when the user double-clicks the control. (Overrides ControlOnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Called when a drag drop operation has completed. (Overrides ControlOnDragDrop(DragEventArgs).)
Protected method | OnDragEnter | Called when a DragEnter event has occurred. (Overrides ControlOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Called when a DragLeave event has occurred. (Overrides ControlOnDragLeave(EventArgs).)
Protected method | OnDragOver | Called when a DragOver event has occurred. (Overrides ControlOnDragOver(DragEventArgs).)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnEraseDropPositionIndicator | Called when the drag drop indicator needs to be erased.
Protected method | OnFontChanged | Called when the Font property has changed. (Overrides ControlOnFontChanged(EventArgs).)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the handle of the control is created. (Overrides ControlOnHandleCreated(EventArgs).)
Protected method | OnHandleDestroyed | Called when the control handle is destroyed. (Overrides ControlOnHandleDestroyed(EventArgs).)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHoverItemChanged | Called when the HoverItem property has changed.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Called when a drag drop operation has started.
Protected method | OnKeyDown | Called when a KeyDown event has occurred. (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Called when a KeyUp event has occurred. (Overrides ControlOnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Called when a layout event has occurred. (Overrides ScrollableControlOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Called when the control has lost focus. (Overrides ControlOnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a MouseDown event has occurred. (Overrides ControlOnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Called when a MouseEnter event has occurred. (Overrides ControlOnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a MouseMove event has occurred. (Overrides ControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has occurred. (Overrides ControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Called when the control needs to be painted. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnPaintDropPositionIndicator | Called when the drag drop indicator needs to be painted.
Protected method | OnPaintThumbnail | Called when a Thumbnail needs to be painted.
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedIndexChanged | Called when the selected index has changed.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailActivate | Called when a thumbnail enters 'edit' mode.
Protected method | OnThumbnailCreated | Called when a thumbnail image has been created.
Protected method | OnThumbnailSizeChanged | Called when the ThumbnailSize property is changed.
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveAfterDragDrop | Override to change the way a thumbnail is removed after a drag drop, if you are using the ThumbnailView in a composite control
Protected method | RemoveOverride |
Protected method | ReorderAfterDragDrop | Override to change the way a thumbnail is reordered after a drag drop, if you are using the ThumbnailView in a composite control
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSorting | Resumes any sorting of the thumbnails.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row.
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control.
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all of the thumbnails in the control.
Public method | SelectFromBounds | This method will select thumbnails that intersect the rectangle provided.
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataBinding | Sets up data binding for the ThumbnailView.
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Use this method to force the ThumbnailCollection to sort.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Overrides ScrollableControlWndProc(Message).)
Top
Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item.
Public event | BeforeThumbnailLoad | Raised just before a thumbnail image is going to be created.
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CompareThumbnails | Occurs when the thumbnail items need to be sorted.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | EraseDropPositionIndicator | Raised when the drag drop indicator needs to be erased.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoverItemChanged | Raised when the HoverItem has changed.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging an item.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintDropPositionIndicator | Raised when the drag drop indicator needs to be painted.
Public event | PaintThumbnail | Occurs when a thumbnail needs to be painted.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | SelectedIndexChanged | Occurs when the selected thumbnail index changes.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThumbnailActivate | Raised when a thumbnail enters 'edit' mode.
Public event | ThumbnailClicked | Raised when a thumbnail is clicked.
Public event | ThumbnailCollectionChanged | Raised when the thumbnail collection has changed from an add, insert, remove or clear action.
Public event | ThumbnailCreated | Raised when a thumbnail has been created.
Public event | ThumbnailDoubleClicked | Raised when a thumbnail is double-clicked.
Public event | ThumbnailDrop | Occurs when the user has dropped an item onto the control.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks

The ThumbnailView control displays a list of thumbnail images obtained from an image file, or directly from an AtalaImage. The control will resample the image passed into the Add method to the maximum width or height specified in ThumbnailSize, while keeping the original aspect ratio.

A common use of the ThumbnailView control is to view the thumbnail of each page in a multipage TIFF image. When the thumbnail item is clicked, the associated page can be displayed in the associated WorkspaceViewer control. The SelectedIndexChanged event can be handled to respond to the thumbnail select or click.

A custom background image can be displayed for each thumbnail by setting the ThumbnailBackground property. Each thumbnail image will then be overlayed onto this image. Setting the ThumbnailBackground property can enhance the visual style of the thumbnail view control.

For viewing thumbnails in a folder, the FolderThumbnailView control is is better choice.

See Also

Reference

Atalasoft.Imaging.WinControls Namespace
Atalasoft.Imaging.WinControlsFolderThumbnailView


ThumbnailView Constructor

Creates a new instance of the ThumbnailView control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailView()
Public Sub New
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView Properties

The ThumbnailView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the method required by to user to activate a thumbnail.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowKeyAction | Gets or sets the action taken when the ThumbnailView receives an arrow key press event.
Public property | Asynchronous | Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously.
Public property | AutoDragDrop | Gets or sets a value indicating whether the internal drag and drop code is used.
Public property | AutoScroll | (Overrides ScrollableControlAutoScroll.)
Public property | AutoScrollMargin |
Public property | AutoScrollMinSize |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionFormat | Gets the StringFormat used for rendering the thumbnail captions.
Public property | CaptionLines | Gets or sets the number of text lines to allocate for the caption area.
Public property | CaptionSpacing | Gets or sets the amount of space between the thumbnail area and the caption.
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ScrollableControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | DisplayText | Tells the thumbview which attribute to display
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DragDistanceTrigger | Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation.
Public property | DragDropMode | Gets or sets the drag and drop mode used when AutoDragDrop is true.
Public property | DragSelectionColor | Gets or sets the color of the outline drawn during a drag and drop operation.
Public property | DropPositionIndicator | Gets or sets the style of drag drop insert indicator used by the ThumbnailView.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableMouseWheel | Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events.
Public property | ErrorImage | Gets or sets the image displayed when there is an error reading a file.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | FocusedItem | Gets the Thumbnail item that currently has focus.
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GrabFocusOnMouseEnter | Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundColor | Gets or sets the color used for the highlight (selected) background.
Public property | HighlightBrush | Gets or sets the brush used for the highlight (selected) background.
Public property | HighlightTextColor | Gets or sets the caption text color used when an item is selected.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HoverItem | Gets the Thumbnail the mouse is currently hovering over.
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating if the control has been disposed.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a reference to the ThumbnailCollection for this control.
Public property | LabelEdit | Gets or sets a value indicating if the text below the thumbnail can be modified by the user.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LoadErrorMessage | Gets or sets the error message that will be displayed when there is an error loading images.
Public property | LoadMethod | Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Margins | Gets or sets the margins used for the control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxWorkerThreads | Gets or sets the number of worker threads that will be active at a single time in the thread pool.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Obsolete. Gets or sets a value indicating whether multiple thumbnails can be selected at once.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PlaceholderImage | Gets or sets an image used as a placeholder before the thumbnails are loaded.
Public property | PlaceholderMessage | Gets or sets the message displayed as a placeholder for thumbnails.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndices | Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control.
Public property | SelectedItems | Gets a ThumbnailCollection containing the currently selected thumbnails.
Public property | SelectedItemsOrder | Gets or sets the ordering used for the SelectedItems collection.
Public property | SelectedItemStyle | Gets or sets the style used when rendering the highlight for selected items.
Public property | SelectionMode | Gets or sets the selection mode used to select the thumbnails.
Public property | SelectionRectangleBackColor | Gets or sets the background color used for the selection rectangle.
Public property | SelectionRectangleDashStyle | Gets or sets the selection rectangle line style.
Public property | SelectionRectangleLineColor | Gets or sets the line color used for the selection rectangle.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SortBy | Gets or sets the ThumbViewAttribute used to sort the thumbnails.
Public property | SortOrder | Gets or sets the sort order of the thumbnails.
Public property | Spacing | Gets or sets the amount of spacing between the thumbnails.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ThumbnailBackground | Gets or sets the background image used for the thumbnails.
Public property | ThumbnailLayout | Gets or sets the layout used for the thumbnails.
Public property | ThumbnailOffset | Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area.
Public property | ThumbnailSize | Gets or sets the size of the thumbnails in pixels.
Public property | ToolTipControl | Gets or sets the ToolTip control used to display tooltips for the thumbnails.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets the index of the first thumbnail in the visible area of the control.
Public property | TopItem | Gets the Thumbnail displayed at the top of the control.
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Activation Property

ThumbnailViewActivation Property

Gets or sets the method required by to user to activate a thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemActivation Activation { get; set; }
Public Property Activation As ItemActivation
    Get
    Set

Property Value

Type: ItemActivation
The method required by the user to activate a thumbnail. Standard, One-Click, or Two-Click as defined in the ItemActivation enumeration.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ArrowKeyAction Property

ThumbnailViewArrowKeyAction Property

Gets or sets the action taken when the ThumbnailView receives an arrow key press event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ArrowKeyAction ArrowKeyAction { get; set; }
Public Property ArrowKeyAction As ArrowKeyAction
    Get
    Set

Property Value

Type: ArrowKeyAction
The action taken for arrow key press events.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Asynchronous Property

ThumbnailViewAsynchronous Property

Gets or sets a value indicating if the thumbnails are loaded asynchronously or synchronously.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Asynchronous { get; set; }
Public Property Asynchronous As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the thumbnails are loaded asynchronously or synchronously.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.AutoDragDrop Property

ThumbnailViewAutoDragDrop Property

Gets or sets a value indicating whether the internal drag and drop code is used.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoDragDrop { get; set; }
Public Property AutoDragDrop As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the internal drag and drop code is used.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.AutoScroll Property

ThumbnailViewAutoScroll Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool AutoScroll { get; set; }
Public Overrides Property AutoScroll As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.AutoScrollMargin Property

ThumbnailViewAutoScrollMargin Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size AutoScrollMargin { get; set; }
Public Property AutoScrollMargin As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.AutoScrollMinSize Property

ThumbnailViewAutoScrollMinSize Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size AutoScrollMinSize { get; set; }
Public Property AutoScrollMinSize As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.CaptionFormat Property

ThumbnailViewCaptionFormat Property

Gets the StringFormat used for rendering the thumbnail captions.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringFormat CaptionFormat { get; }
Public ReadOnly Property CaptionFormat As StringFormat
    Get

Property Value

Type: StringFormat
The StringFormat used when rendering captions.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.CaptionLines Property

ThumbnailViewCaptionLines Property

Gets or sets the number of text lines to allocate for the caption area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CaptionLines { get; set; }
Public Property CaptionLines As Integer
    Get
    Set

Property Value

Type: Int32
The number of text lines for the caption.
Remarks

This property defaults to 2 lines. Setting this property to 0 will remove the caption area from the thumbnail.

When a thumbnail has focus, its entire caption is displayed, even if it takes more lines than the value of this property.

See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.CaptionSpacing Property

ThumbnailViewCaptionSpacing Property

Gets or sets the amount of space between the thumbnail area and the caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CaptionSpacing { get; set; }
Public Property CaptionSpacing As Integer
    Get
    Set

Property Value

Type: Int32
The amount of space between the thumbnail and the caption.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.DisplayText Property

ThumbnailViewDisplayText Property

Tells the thumbview which attribute to display
Gets or sets the attribute used for text displayed below the thumbnail.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbViewAttribute DisplayText { get; set; }
Public Property DisplayText As ThumbViewAttribute
    Get
    Set

Property Value

Type: ThumbViewAttribute
The attribute used for text displayed below the thumbnail.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.DragDistanceTrigger Property

ThumbnailViewDragDistanceTrigger Property

Gets or sets the number of pixel the mouse must be moved before it's considered a drag and drop operation.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DragDistanceTrigger { get; set; }
Public Property DragDistanceTrigger As Integer
    Get
    Set

Property Value

Type: Int32
The number of pixel the mouse must move before starting a drag and drop operation.
Remarks
The default value of this property is 20. This means when the mouse button is pressed, the cursor must move at least 20 pixels before a drag and drop operation starts. Setting this property to larger amounts will help prevent an accidental drag and drop.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.DragDropMode Property

ThumbnailViewDragDropMode Property

Gets or sets the drag and drop mode used when AutoDragDrop is true.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DragDropMode DragDropMode { get; set; }
Public Property DragDropMode As DragDropMode
    Get
    Set

Property Value

Type: DragDropMode
The drag and drop mode for this control.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.DragSelectionColor Property

ThumbnailViewDragSelectionColor Property

Gets or sets the color of the outline drawn during a drag and drop operation.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color DragSelectionColor { get; set; }
Public Property DragSelectionColor As Color
    Get
    Set

Property Value

Type: Color
The color of the drag and drop rectangle.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.DropPositionIndicator Property

ThumbnailViewDropPositionIndicator Property

Gets or sets the style of drag drop insert indicator used by the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailDropPositionIndicator DropPositionIndicator { get; set; }
Public Property DropPositionIndicator As ThumbnailDropPositionIndicator
    Get
    Set

Property Value

Type: ThumbnailDropPositionIndicator
The style of drag drop insert indicator used.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.EnableMouseWheel Property

ThumbnailViewEnableMouseWheel Property

Gets or sets a value indicating whether the scrollbars will respond to mouse wheel events.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableMouseWheel { get; set; }
Public Property EnableMouseWheel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the control handles mouse wheel events.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ErrorImage Property

ThumbnailViewErrorImage Property

Gets or sets the image displayed when there is an error reading a file.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image ErrorImage { get; set; }
Public Property ErrorImage As Image
    Get
    Set

Property Value

Type: Image
The image displayed when there is an error reading a file.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.FocusedItem Property

ThumbnailViewFocusedItem Property

Gets the Thumbnail item that currently has focus.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail FocusedItem { get; }
Public ReadOnly Property FocusedItem As Thumbnail
    Get

Property Value

Type: Thumbnail
The item that has focus.
Examples
C#
VB
Copy
// Move the selected thumbnail to the top.
if (this.thumbnailView1.FocusedItem != null)
    this.thumbnailView1.Items.Move(this.thumbnailView1.FocusedItem, 0);
' Move the selected thumbnail to the top.
If Not Me.thumbnailView1.FocusedItem Is Nothing Then
    Me.thumbnailView1.Items.Move(Me.thumbnailView1.FocusedItem, 0)
End If
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GrabFocusOnMouseEnter Property

ThumbnailViewGrabFocusOnMouseEnter Property

Gets or sets a value indicating whether the ThumbnailView should grab input focus when the cursor enters the control area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GrabFocusOnMouseEnter { get; set; }
Public Property GrabFocusOnMouseEnter As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the ThumbnailView should grab input focus.
Remarks
Setting this property to true may be required in order for the mouse wheel to function properly.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.HighlightBackgroundColor Property

ThumbnailViewHighlightBackgroundColor Property

Gets or sets the color used for the highlight (selected) background.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HighlightBackgroundColor { get; set; }
Public Property HighlightBackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The color used for the highlight background.
Remarks
Setting this property will override the HighlightBrush and create a SolidBrush.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.HighlightBrush Property

ThumbnailViewHighlightBrush Property

Gets or sets the brush used for the highlight (selected) background.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Brush HighlightBrush { get; set; }
Public Property HighlightBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used for the highlight background.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.HighlightTextColor Property

ThumbnailViewHighlightTextColor Property

Gets or sets the caption text color used when an item is selected.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color HighlightTextColor { get; set; }
Public Property HighlightTextColor As Color
    Get
    Set

Property Value

Type: Color
The caption text color for selected items.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.HoverItem Property

ThumbnailViewHoverItem Property

Gets the Thumbnail the mouse is currently hovering over.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail HoverItem { get; }
Public ReadOnly Property HoverItem As Thumbnail
    Get

Property Value

Type: Thumbnail
The item the mouse is hovering over.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsDisposed Property

ThumbnailViewIsDisposed Property

Gets a value indicating if the control has been disposed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the control has been disposed.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Items Property

ThumbnailViewItems Property

Gets a reference to the ThumbnailCollection for this control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailCollection Items { get; }
Public ReadOnly Property Items As ThumbnailCollection
    Get

Property Value

Type: ThumbnailCollection
The ThumbnailCollection for this control.
Remarks
The Items property can be used to enumerate through each Thumbnail within the ThumbnailView control.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.LabelEdit Property

ThumbnailViewLabelEdit Property

Gets or sets a value indicating if the text below the thumbnail can be modified by the user.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool LabelEdit { get; set; }
Public Property LabelEdit As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the text below the thumbnail can be modified by the user.
Remarks
See the BeforeLabelEdit and AfterLabelEdit.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.LoadErrorMessage Property

ThumbnailViewLoadErrorMessage Property

Gets or sets the error message that will be displayed when there is an error loading images.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LoadErrorMessage { get; set; }
Public Property LoadErrorMessage As String
    Get
    Set

Property Value

Type: String
The error message to display on the error thumbnail.
Remarks
If this property is null or Empty the real exception error message is displayed on the thumbnail.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.LoadMethod Property

ThumbnailViewLoadMethod Property

Gets or sets a value indicating whether all of the thumbnails will be loaded when added or if only the visible thumbnails are loaded.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbLoadMethod LoadMethod { get; set; }
Public Property LoadMethod As ThumbLoadMethod
    Get
    Set

Property Value

Type: ThumbLoadMethod
A value indicating whether or not all of the thumbnails are loaded.
Remarks
In order to lessen the amount of memory used, set this property to WhenVisible so only thumbnails that fall into the visible area of the control are loaded.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Margins Property

ThumbnailViewMargins Property

Gets or sets the margins used for the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Margin Margins { get; set; }
Public Property Margins As Margin
    Get
    Set

Property Value

Type: Margin
The margins used for the control.
Remarks
Margins determine the spacing around the thumbnails. To control the spacing between the thumbnails set the Spacing property.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.MaxWorkerThreads Property

ThumbnailViewMaxWorkerThreads Property

Gets or sets the number of worker threads that will be active at a single time in the thread pool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxWorkerThreads { get; set; }
Public Property MaxWorkerThreads As Integer
    Get
    Set

Property Value

Type: Int32
The number of worker threads that will be active at a single time in the thread pool.
Remarks
This value defaults to 3 meaning that up to 3 images will load at once in the background thread pool. Increasing this number will cause more simultaneous threads to be created which could increase performance with multiple CPU systems.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.MultiSelect Property

ThumbnailViewMultiSelect Property

Note: This API is now obsolete.

Gets or sets a value indicating whether multiple thumbnails can be selected at once.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("MultiSelect is obsolete and may be removed in a future release. Use the SelectionMode property instead.",
    false)]
public bool MultiSelect { get; set; }
<ObsoleteAttribute("MultiSelect is obsolete and may be removed in a future release. Use the SelectionMode property instead.",
    false)>
Public Property MultiSelect As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether multiple thumbnails can be selected at once.
Remarks
This property is obsolete. Use the SelectionMode property instead.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.PlaceholderImage Property

ThumbnailViewPlaceholderImage Property

Gets or sets an image used as a placeholder before the thumbnails are loaded.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image PlaceholderImage { get; set; }
Public Property PlaceholderImage As Image
    Get
    Set

Property Value

Type: Image
The image used as a placeholder for thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.PlaceholderMessage Property

ThumbnailViewPlaceholderMessage Property

Gets or sets the message displayed as a placeholder for thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PlaceholderMessage { get; set; }
Public Property PlaceholderMessage As String
    Get
    Set

Property Value

Type: String
The message used as a placeholder for thumbnails.
Remarks
If the PlaceholderImage property is set, the PlaceholderMessage is ignored.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectedIndices Property

ThumbnailViewSelectedIndices Property

Gets a reference to a collection if indexes that are currently selected in the ThumbnailView control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] SelectedIndices { get; }
Public ReadOnly Property SelectedIndices As Integer()
    Get

Property Value

Type: Int32
A reference to a collection if indexes that are currently selected in the ThumbnailView control.
Remarks
Use this collection to determine which thumbnails are selected.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectedItems Property

ThumbnailViewSelectedItems Property

Gets a ThumbnailCollection containing the currently selected thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedThumbnailCollection SelectedItems { get; }
Public ReadOnly Property SelectedItems As SelectedThumbnailCollection
    Get

Property Value

Type: SelectedThumbnailCollection
A ThumbnailCollection containing the currently selected thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectedItemsOrder Property

ThumbnailViewSelectedItemsOrder Property

Gets or sets the ordering used for the SelectedItems collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedItemsOrder SelectedItemsOrder { get; set; }
Public Property SelectedItemsOrder As SelectedItemsOrder
    Get
    Set

Property Value

Type: SelectedItemsOrder
The ordering for the SelectedItems collection. The default value is ItemIndexOrder.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectedItemStyle Property

ThumbnailViewSelectedItemStyle Property

Gets or sets the style used when rendering the highlight for selected items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectedItemRenderStyle SelectedItemStyle { get; set; }
Public Property SelectedItemStyle As SelectedItemRenderStyle
    Get
    Set

Property Value

Type: SelectedItemRenderStyle
The style used when rendering the highlight for selected items.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectionMode Property

ThumbnailViewSelectionMode Property

Gets or sets the selection mode used to select the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailSelectionMode SelectionMode { get; set; }
Public Property SelectionMode As ThumbnailSelectionMode
    Get
    Set

Property Value

Type: ThumbnailSelectionMode
The selection mode used for selecting thumbnails with the mouse.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectionRectangleBackColor Property

ThumbnailViewSelectionRectangleBackColor Property

Gets or sets the background color used for the selection rectangle.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color SelectionRectangleBackColor { get; set; }
Public Property SelectionRectangleBackColor As Color
    Get
    Set

Property Value

Type: Color
The background color for the selection rectangle.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectionRectangleDashStyle Property

ThumbnailViewSelectionRectangleDashStyle Property

Gets or sets the selection rectangle line style.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DashStyle SelectionRectangleDashStyle { get; set; }
Public Property SelectionRectangleDashStyle As DashStyle
    Get
    Set

Property Value

Type: DashStyle
The selection rectangle line style.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectionRectangleLineColor Property

ThumbnailViewSelectionRectangleLineColor Property

Gets or sets the line color used for the selection rectangle.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color SelectionRectangleLineColor { get; set; }
Public Property SelectionRectangleLineColor As Color
    Get
    Set

Property Value

Type: Color
The line color for the selection rectangle.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SortBy Property

ThumbnailViewSortBy Property

Gets or sets the ThumbViewAttribute used to sort the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbViewAttribute SortBy { get; set; }
Public Property SortBy As ThumbViewAttribute
    Get
    Set

Property Value

Type: ThumbViewAttribute
The ThumbViewAttribute used to sort the thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SortOrder Property

ThumbnailViewSortOrder Property

Gets or sets the sort order of the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SortOrder SortOrder { get; set; }
Public Property SortOrder As SortOrder
    Get
    Set

Property Value

Type: SortOrder
The sort order of the thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Spacing Property

ThumbnailViewSpacing Property

Gets or sets the amount of spacing between the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Spacing { get; set; }
Public Property Spacing As Integer
    Get
    Set

Property Value

Type: Int32
The spacing between the thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailBackground Property

ThumbnailViewThumbnailBackground Property

Gets or sets the background image used for the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image ThumbnailBackground { get; set; }
Public Property ThumbnailBackground As Image
    Get
    Set

Property Value

Type: Image
The background image used for the thumbnails.
Remarks
The thumbnail images will be overlayed onto this image, giving each thumbnail an improved visual style.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailLayout Property

ThumbnailViewThumbnailLayout Property

Gets or sets the layout used for the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThumbnailLayout ThumbnailLayout { get; set; }
Public Property ThumbnailLayout As ThumbnailLayout
    Get
    Set

Property Value

Type: ThumbnailLayout
The layout of the thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailOffset Property

ThumbnailViewThumbnailOffset Property

Gets or sets the amount to offset the thumbnail image from the top-left corner of the thumbnail area.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ThumbnailOffset { get; set; }
Public Property ThumbnailOffset As Point
    Get
    Set

Property Value

Type: Point
The amount to offset the thumbnail image.
Remarks
This is useful when using a thumbnail background image to allow exact positioning of the thumbnail on the background.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailSize Property

ThumbnailViewThumbnailSize Property

Gets or sets the size of the thumbnails in pixels.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ThumbnailSize { get; set; }
Public Property ThumbnailSize As Size
    Get
    Set

Property Value

Type: Size
The size of the thumbnails in pixels.
Remarks
Each thumbnail will be resized to fit the width or height of the ThumbnailSize (whichever is greater).
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ToolTipControl Property

ThumbnailViewToolTipControl Property

Gets or sets the ToolTip control used to display tooltips for the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ToolTip ToolTipControl { get; set; }
Public Property ToolTipControl As ToolTip
    Get
    Set

Property Value

Type: ToolTip
The ToolTip control used by the thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.TopIndex Property

ThumbnailViewTopIndex Property

Gets the index of the first thumbnail in the visible area of the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TopIndex { get; }
Public ReadOnly Property TopIndex As Integer
    Get

Property Value

Type: Int32
The index of the top-left visible thumbnail.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.TopItem Property

ThumbnailViewTopItem Property

Gets the Thumbnail displayed at the top of the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail TopItem { get; }
Public ReadOnly Property TopItem As Thumbnail
    Get

Property Value

Type: Thumbnail
The top most visible Thumbnail.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView Methods

The ThumbnailView type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddAfterDragDrop | Override to change the way a thumbnail is added to an empty control, if you are using the ThumbnailView in a composite control
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelection | This method will unselect any selected thumbnails in the control.
Public method | Compare | Compares two Thumbnail objects.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the ThumbnailView and releases any resources back to the system. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible.
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDropIndex | Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexAt | Returns the thumbnail index value from the specified client position.
Public method | GetItemAt | Gets the Thumbnail located at specific x, y coordinates.
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index.
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaltSorting | Use this method to temporarily keep the ThumbnailCollection from sorting items.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | This method is used to allow input from special keys. (Overrides ControlIsInputKey(Keys).)
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView.
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView.
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView.
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView.
Protected method | MakeThumbnailDragDropOperation |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterLabelEdit | Called after the thumbnail caption has been modified by the user.
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeLabelEdit | Called when the user is trying to modifiy the thumbnail caption.
Protected method | OnBeforeThumbnailLoad | Called just before a thumbnail image is created.
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a click event has occurred. (Overrides ControlOnClick(EventArgs).)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollectionChanged | Called when there has been a change in the ThumbnailCollection.
Protected method | OnCompare | Called when two thumbnails need to be compared.
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataChanged | Called when a DataRow has changed in the data source.
Protected method | OnDataMemberChanged | Called when a data member has changed.
Protected method | OnDataSourceChanged | Called when the data source has changed.
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Called when the user double-clicks the control. (Overrides ControlOnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Called when a drag drop operation has completed. (Overrides ControlOnDragDrop(DragEventArgs).)
Protected method | OnDragEnter | Called when a DragEnter event has occurred. (Overrides ControlOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Called when a DragLeave event has occurred. (Overrides ControlOnDragLeave(EventArgs).)
Protected method | OnDragOver | Called when a DragOver event has occurred. (Overrides ControlOnDragOver(DragEventArgs).)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnEraseDropPositionIndicator | Called when the drag drop indicator needs to be erased.
Protected method | OnFontChanged | Called when the Font property has changed. (Overrides ControlOnFontChanged(EventArgs).)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the handle of the control is created. (Overrides ControlOnHandleCreated(EventArgs).)
Protected method | OnHandleDestroyed | Called when the control handle is destroyed. (Overrides ControlOnHandleDestroyed(EventArgs).)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHoverItemChanged | Called when the HoverItem property has changed.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Called when a drag drop operation has started.
Protected method | OnKeyDown | Called when a KeyDown event has occurred. (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Called when a KeyUp event has occurred. (Overrides ControlOnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Called when a layout event has occurred. (Overrides ScrollableControlOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Called when the control has lost focus. (Overrides ControlOnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a MouseDown event has occurred. (Overrides ControlOnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Called when a MouseEnter event has occurred. (Overrides ControlOnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when a MouseMove event has occurred. (Overrides ControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when a MouseUp event has occurred. (Overrides ControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Called when the control needs to be painted. (Overrides ControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnPaintDropPositionIndicator | Called when the drag drop indicator needs to be painted.
Protected method | OnPaintThumbnail | Called when a Thumbnail needs to be painted.
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSelectedIndexChanged | Called when the selected index has changed.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnThumbnailActivate | Called when a thumbnail enters 'edit' mode.
Protected method | OnThumbnailCreated | Called when a thumbnail image has been created.
Protected method | OnThumbnailSizeChanged | Called when the ThumbnailSize property is changed.
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveAfterDragDrop | Override to change the way a thumbnail is removed after a drag drop, if you are using the ThumbnailView in a composite control
Protected method | RemoveOverride |
Protected method | ReorderAfterDragDrop | Override to change the way a thumbnail is reordered after a drag drop, if you are using the ThumbnailView in a composite control
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSorting | Resumes any sorting of the thumbnails.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row.
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control.
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all of the thumbnails in the control.
Public method | SelectFromBounds | This method will select thumbnails that intersect the rectangle provided.
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDataBinding | Sets up data binding for the ThumbnailView.
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Use this method to force the ThumbnailCollection to sort.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Overrides ScrollableControlWndProc(Message).)
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.AddAfterDragDrop Method

ThumbnailViewAddAfterDragDrop Method

Override to change the way a thumbnail is added to an empty control, if you are using the ThumbnailView in a composite control

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void AddAfterDragDrop(
    Thumbnail tn,
    bool clone,
    bool cached
)
Protected Overridable Sub AddAfterDragDrop (
    tn As Thumbnail,
    clone As Boolean,
    cached As Boolean
)

Parameters

tn
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail to add
clone
Type: SystemBoolean
A bool determiing if the Thumbnail should be cloned before insertion
cached
Type: SystemBoolean
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ClearSelection Method

ThumbnailViewClearSelection Method

This method will unselect any selected thumbnails in the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearSelection()
Public Sub ClearSelection
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace
SelectAll Method


ThumbnailView.Compare Method

ThumbnailViewCompare Method

Compares two Thumbnail objects.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Compare(
    Object x,
    Object y
)
Public Function Compare (
    x As Object,
    y As Object
) As Integer

Parameters

x
Type: SystemObject
The Thumbnail to compare against.
y
Type: SystemObject
The Thumbnail being compared.

Return Value

Type: Int32
Less than zero if the y parameter is less than the x parameter, Greater than zero if the y parameter is greater than the x parameter, and Zero if the objects are equal.

Implements

IComparerCompare(Object, Object)
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Dispose Method

ThumbnailViewDispose Method

Disposes the ThumbnailView and all of its Thumbnails.
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the ThumbnailView and releases any resources back to the system. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Dispose Method (Boolean)

ThumbnailViewDispose Method (Boolean)

Disposes the ThumbnailView and releases any resources back to the system.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from the Dispose method.
See Also

Reference

ThumbnailView Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.EnsureVisible Method

ThumbnailViewEnsureVisible Method

These methods bring a thumbnail into view.
Overload List
 | Name | Description
Public method | EnsureVisible(Int32) | Scrolls a thumbnail into view if it is not already visible.
Public method | EnsureVisible(Thumbnail) | Scrolls a thumbnail into view if it is not already visible.
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.EnsureVisible Method (Int32)

ThumbnailViewEnsureVisible Method (Int32)

Scrolls a thumbnail into view if it is not already visible.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void EnsureVisible(
    int index
)
Public Sub EnsureVisible (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the Thumbnail to bring into view.
See Also

Reference

ThumbnailView Class
EnsureVisible Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.EnsureVisible Method (Thumbnail)

ThumbnailViewEnsureVisible Method (Thumbnail)

Scrolls a thumbnail into view if it is not already visible.
Use this method to bring a Thumbnail into view.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void EnsureVisible(
    Thumbnail thumbnail
)
Public Sub EnsureVisible (
    thumbnail As Thumbnail
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to bring into view.
Remarks
If the thumbnail needs to be scrolled down, it will be positioned at the top of the control. If the thumbnail needs to be scrolled up, it will be positioned at the bottom of the control.
See Also

Reference

ThumbnailView Class
EnsureVisible Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Finalize Method

ThumbnailViewFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GetDropIndex Method

ThumbnailViewGetDropIndex Method

Returns the index where items will be inserted from a drag and drop operation if dropped at the provided client coordinates.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetDropIndex(
    int x,
    int y
)
Public Function GetDropIndex (
    x As Integer,
    y As Integer
) As Integer

Parameters

x
Type: SystemInt32
The X coordinate in client space.
y
Type: SystemInt32
The Y coordinate in client space.

Return Value

Type: Int32
The insert index for the item.
Remarks
The result of this method will vary depending on the value of DropPositionIndicator.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GetIndexAt Method

ThumbnailViewGetIndexAt Method

Returns the thumbnail index value from the specified client position.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetIndexAt(
    int x,
    int y
)
Public Function GetIndexAt (
    x As Integer,
    y As Integer
) As Integer

Parameters

x
Type: SystemInt32
The horizontal position.
y
Type: SystemInt32
The vertical position.

Return Value

Type: Int32
The index of the thumbnail in the specified position or -1 if no thumbnail was found.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the x or y parameters are not within the client area.
Remarks
The x and y parameters must be specified in client coordinates.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GetItemAt Method

ThumbnailViewGetItemAt Method

Gets the Thumbnail located at specific x, y coordinates.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Thumbnail GetItemAt(
    int x,
    int y
)
Public Function GetItemAt (
    x As Integer,
    y As Integer
) As Thumbnail

Parameters

x
Type: SystemInt32
The x coordinate.
y
Type: SystemInt32
The y coordinate.

Return Value

Type: Thumbnail
The Thumbnail found at the coordinates given or null (Nothing in Visual Basic) if no Thumbnail was found.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GetItemRect Method

ThumbnailViewGetItemRect Method

These methods return coordinate information for a specific thumbnail.
Overload List
 | Name | Description
Public method | GetItemRect(Int32) | Returns an ItemBounds class containing coordinates for the thumbnail at the specified index.
Public method | GetItemRect(Thumbnail) | Returns an ItemBounds class containing coordinates for the thumbnail provided.
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GetItemRect Method (Int32)

ThumbnailViewGetItemRect Method (Int32)

Returns an ItemBounds class containing coordinates for the thumbnail at the specified index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemBounds GetItemRect(
    int index
)
Public Function GetItemRect (
    index As Integer
) As ItemBounds

Parameters

index
Type: SystemInt32
The index of the thumbnail to retrieve information on.

Return Value

Type: ItemBounds
An ItemBounds containing coordinate information for the thumbnail.
See Also

Reference

ThumbnailView Class
GetItemRect Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.GetItemRect Method (Thumbnail)

ThumbnailViewGetItemRect Method (Thumbnail)

Returns an ItemBounds class containing coordinates for the thumbnail provided.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ItemBounds GetItemRect(
    Thumbnail thumbnail
)
Public Function GetItemRect (
    thumbnail As Thumbnail
) As ItemBounds

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to return information on.

Return Value

Type: ItemBounds
An ItemBounds containing coordinate information for the thumbnail.
See Also

Reference

ThumbnailView Class
GetItemRect Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.HaltSorting Method

ThumbnailViewHaltSorting Method

Use this method to temporarily keep the ThumbnailCollection from sorting items.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void HaltSorting()
Public Sub HaltSorting
Remarks
This is useful when adding or inserting multiple items into the collection. Call ResumeSorting to force the collection to sort the items and return it normal sorting behavior.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsInputKey Method

ThumbnailViewIsInputKey Method

This method is used to allow input from special keys.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool IsInputKey(
    Keys keyData
)
Protected Overrides Function IsInputKey (
    keyData As Keys
) As Boolean

Parameters

keyData
Type: System.Windows.FormsKeys
The key being checked.

Return Value

Type: Boolean

The ThumbnailView allows and handles the following keys:

Keys.ControlKeys.ShiftKeys.DownKeys.LeftKeys.RightKeys.UpKeys.HomeKeys.EndKeys.PageDownKeys.PageUp
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsVisible Method

ThumbnailViewIsVisible Method

These methods are used to determine whether a thumbnail is in the visible area of the ThumbnailView.
Overload List
 | Name | Description
Public method | IsVisible(Int32) | Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView.
Public method | IsVisible(Thumbnail) | Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView.
Public method | IsVisible(Int32, Boolean) | Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView.
Public method | IsVisible(Thumbnail, Boolean) | Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView.
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsVisible Method (Int32)

ThumbnailViewIsVisible Method (Int32)

Returns a value indicating whether the thumbnail at the specified index, or part of it, is in the visible area of the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible(
    int index
)
Public Function IsVisible (
    index As Integer
) As Boolean

Parameters

index
Type: SystemInt32
The index of the thumbnail.

Return Value

Type: Boolean
True if the thumbnail, or part of it, is in the visible area.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for the thumbnail collection.
See Also

Reference

ThumbnailView Class
IsVisible Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsVisible Method (Thumbnail)

ThumbnailViewIsVisible Method (Thumbnail)

Returns a value indicating whether the provided thumbnail, or part of it, is in the visible area of the ThumbnailView.
Use this method to determine if a Thumbnail is currently visible in the viewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible(
    Thumbnail thumbnail
)
Public Function IsVisible (
    thumbnail As Thumbnail
) As Boolean

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to check.

Return Value

Type: Boolean
True if the thumbnail, or part of it, is in the visible area.

Return Value

Type: Boolean
True if the thumbnail is currently visible in the viewer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the thumbnail argument is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the thumbnail provided is not in the thumbnail collection.
See Also

Reference

ThumbnailView Class
IsVisible Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsVisible Method (Int32, Boolean)

ThumbnailViewIsVisible Method (Int32, Boolean)

Returns a value indicating whether the thumbnail at the specified index is in the visible area of the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible(
    int index,
    bool requireFullVisibility
)
Public Function IsVisible (
    index As Integer,
    requireFullVisibility As Boolean
) As Boolean

Parameters

index
Type: SystemInt32
The index of the thumbnail.
requireFullVisibility
Type: SystemBoolean
A value indicating whether the entire thumbnail must be in the visible area or only part of it.

Return Value

Type: Boolean
True if the thumbnail is in the visible area of the control.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the index is invalid for the thumbnail collection.
See Also

Reference

ThumbnailView Class
IsVisible Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.IsVisible Method (Thumbnail, Boolean)

ThumbnailViewIsVisible Method (Thumbnail, Boolean)

Returns a value indicating whether the provided thumbnail is in the visible area of the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible(
    Thumbnail thumbnail,
    bool requireFullVisibility
)
Public Function IsVisible (
    thumbnail As Thumbnail,
    requireFullVisibility As Boolean
) As Boolean

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to check.
requireFullVisibility
Type: SystemBoolean
A value indicating whether the entire thumbnail must be in the visible area or only part of it.

Return Value

Type: Boolean
True if the thumbnail is in the visible area of the control.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the thumbnail argument is null (Nothing in VB).
ArgumentOutOfRangeException | Thrown if the thumbnail provided is not in the thumbnail collection.
See Also

Reference

ThumbnailView Class
IsVisible Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.MakeThumbnailDragDropOperation Method

ThumbnailViewMakeThumbnailDragDropOperation Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual ThumbnailDragDropOperation MakeThumbnailDragDropOperation(
    ThumbnailView tv,
    Thumbnail[] thumbs,
    DragDropMode mode,
    int[] dragDropIndexes
)
Protected Overridable Function MakeThumbnailDragDropOperation (
    tv As ThumbnailView,
    thumbs As Thumbnail(),
    mode As DragDropMode,
    dragDropIndexes As Integer()
) As ThumbnailDragDropOperation

Parameters

tv
Type: Atalasoft.Imaging.WinControlsThumbnailView
thumbs
Type: Atalasoft.Imaging.WinControlsThumbnail
mode
Type: Atalasoft.Imaging.WinControlsDragDropMode
dragDropIndexes
Type: SystemInt32

Return Value

Type: ThumbnailDragDropOperation
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnAfterLabelEdit Method

ThumbnailViewOnAfterLabelEdit Method

Called after the thumbnail caption has been modified by the user.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAfterLabelEdit(
    LabelEditEventArgs e
)
Protected Overridable Sub OnAfterLabelEdit (
    e As LabelEditEventArgs
)

Parameters

e
Type: System.Windows.FormsLabelEditEventArgs
A LabelEditEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnBeforeLabelEdit Method

ThumbnailViewOnBeforeLabelEdit Method

Called when the user is trying to modifiy the thumbnail caption.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnBeforeLabelEdit(
    LabelEditEventArgs e
)
Protected Overridable Sub OnBeforeLabelEdit (
    e As LabelEditEventArgs
)

Parameters

e
Type: System.Windows.FormsLabelEditEventArgs
A LabelEditEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnBeforeThumbnailLoad Method

ThumbnailViewOnBeforeThumbnailLoad Method

Called just before a thumbnail image is created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnBeforeThumbnailLoad(
    ThumbnailLoadEventArgs e
)
Protected Overridable Sub OnBeforeThumbnailLoad (
    e As ThumbnailLoadEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsThumbnailLoadEventArgs
A ThumbnailLoadEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnClick Method

ThumbnailViewOnClick Method

Called when a click event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClick(
    EventArgs e
)
Protected Overrides Sub OnClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnCollectionChanged Method

ThumbnailViewOnCollectionChanged Method

Called when there has been a change in the ThumbnailCollection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnCollectionChanged(
    CollectionChangedEventArgs e
)
Protected Overridable Sub OnCollectionChanged (
    e As CollectionChangedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsCollectionChangedEventArgs
A CollectionChangedEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnCompare Method

ThumbnailViewOnCompare Method

Called when two thumbnails need to be compared.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual int OnCompare(
    Thumbnail tn1,
    Thumbnail tn2
)
Protected Overridable Function OnCompare (
    tn1 As Thumbnail,
    tn2 As Thumbnail
) As Integer

Parameters

tn1
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to compare against.
tn2
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to compare with.

Return Value

Type: Int32
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDataChanged Method

ThumbnailViewOnDataChanged Method

Called when a DataRow has changed in the data source.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDataChanged(
    DataRowChangeEventArgs e
)
Protected Overridable Sub OnDataChanged (
    e As DataRowChangeEventArgs
)

Parameters

e
Type: System.DataDataRowChangeEventArgs
A DataRowChangeEventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDataMemberChanged Method

ThumbnailViewOnDataMemberChanged Method

Called when a data member has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDataMemberChanged(
    DataMemberChangedEventArgs e
)
Protected Overridable Sub OnDataMemberChanged (
    e As DataMemberChangedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsDataMemberChangedEventArgs
A DataMemberChangedEventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDataSourceChanged Method

ThumbnailViewOnDataSourceChanged Method

Called when the data source has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDataSourceChanged(
    EventArgs e
)
Protected Overridable Sub OnDataSourceChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDoubleClick Method

ThumbnailViewOnDoubleClick Method

Called when the user double-clicks the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDoubleClick(
    EventArgs e
)
Protected Overrides Sub OnDoubleClick (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDragDrop Method

ThumbnailViewOnDragDrop Method

Called when a drag drop operation has completed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDragDrop(
    DragEventArgs drgevent
)
Protected Overrides Sub OnDragDrop (
    drgevent As DragEventArgs
)

Parameters

drgevent
Type: System.Windows.FormsDragEventArgs
A DragEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDragEnter Method

ThumbnailViewOnDragEnter Method

Called when a DragEnter event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs drgevent
)
Protected Overrides Sub OnDragEnter (
    drgevent As DragEventArgs
)

Parameters

drgevent
Type: System.Windows.FormsDragEventArgs
A DragEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDragLeave Method

ThumbnailViewOnDragLeave Method

Called when a DragLeave event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDragLeave(
    EventArgs e
)
Protected Overrides Sub OnDragLeave (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnDragOver Method

ThumbnailViewOnDragOver Method

Called when a DragOver event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnDragOver(
    DragEventArgs drgevent
)
Protected Overrides Sub OnDragOver (
    drgevent As DragEventArgs
)

Parameters

drgevent
Type: System.Windows.FormsDragEventArgs
A DragEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnEraseDropPositionIndicator Method

ThumbnailViewOnEraseDropPositionIndicator Method

Called when the drag drop indicator needs to be erased.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnEraseDropPositionIndicator(
    PaintDropPositionIndicatorEventArgs e
)
Protected Overridable Sub OnEraseDropPositionIndicator (
    e As PaintDropPositionIndicatorEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPaintDropPositionIndicatorEventArgs
A PaintDropPositionIndicatorEventArgs containing information used to erase the indicator.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnFontChanged Method

ThumbnailViewOnFontChanged Method

Called when the Font property has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnFontChanged(
    EventArgs e
)
Protected Overrides Sub OnFontChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnHandleCreated Method

ThumbnailViewOnHandleCreated Method

Called when the handle of the control is created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnHandleCreated(
    EventArgs e
)
Protected Overrides Sub OnHandleCreated (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnHandleDestroyed Method

ThumbnailViewOnHandleDestroyed Method

Called when the control handle is destroyed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnHandleDestroyed(
    EventArgs e
)
Protected Overrides Sub OnHandleDestroyed (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnHoverItemChanged Method

ThumbnailViewOnHoverItemChanged Method

Called when the HoverItem property has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnHoverItemChanged(
    ThumbnailEventArgs e
)
Protected Overridable Sub OnHoverItemChanged (
    e As ThumbnailEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsThumbnailEventArgs
A ThumbnailEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnItemDrag Method

ThumbnailViewOnItemDrag Method

Called when a drag drop operation has started.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnItemDrag(
    ItemDragEventArgs e
)
Protected Overridable Sub OnItemDrag (
    e As ItemDragEventArgs
)

Parameters

e
Type: System.Windows.FormsItemDragEventArgs
An ItemDragEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnKeyDown Method

ThumbnailViewOnKeyDown Method

Called when a KeyDown event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.FormsKeyEventArgs
A KeyEventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnKeyUp Method

ThumbnailViewOnKeyUp Method

Called when a KeyUp event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnKeyUp(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyUp (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.FormsKeyEventArgs
A KeyEventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnLayout Method

ThumbnailViewOnLayout Method

Called when a layout event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLayout(
    LayoutEventArgs levent
)
Protected Overrides Sub OnLayout (
    levent As LayoutEventArgs
)

Parameters

levent
Type: System.Windows.FormsLayoutEventArgs
A LayoutEventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnLostFocus Method

ThumbnailViewOnLostFocus Method

Called when the control has lost focus.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    EventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnMouseDown Method

ThumbnailViewOnMouseDown Method

Called when a MouseDown event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnMouseEnter Method

ThumbnailViewOnMouseEnter Method

Called when a MouseEnter event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseEnter(
    EventArgs e
)
Protected Overrides Sub OnMouseEnter (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnMouseMove Method

ThumbnailViewOnMouseMove Method

Called when a MouseMove event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnMouseUp Method

ThumbnailViewOnMouseUp Method

Called when a MouseUp event has occurred.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnPaint Method

ThumbnailViewOnPaint Method

Called when the control needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs containing information about this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnPaintDropPositionIndicator Method

ThumbnailViewOnPaintDropPositionIndicator Method

Called when the drag drop indicator needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPaintDropPositionIndicator(
    PaintDropPositionIndicatorEventArgs e
)
Protected Overridable Sub OnPaintDropPositionIndicator (
    e As PaintDropPositionIndicatorEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPaintDropPositionIndicatorEventArgs
A PaintDropPositionIndicatorEventArgs containing information used to paint the indicator.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnPaintThumbnail Method

ThumbnailViewOnPaintThumbnail Method

Called when a Thumbnail needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPaintThumbnail(
    PaintThumbnailEventArgs e
)
Protected Overridable Sub OnPaintThumbnail (
    e As PaintThumbnailEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsPaintThumbnailEventArgs
A PaintThumbnailEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnSelectedIndexChanged Method

ThumbnailViewOnSelectedIndexChanged Method

Called when the selected index has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectedIndexChanged(
    EventArgs e
)
Protected Overridable Sub OnSelectedIndexChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnThumbnailActivate Method

ThumbnailViewOnThumbnailActivate Method

Called when a thumbnail enters 'edit' mode.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnThumbnailActivate(
    ThumbnailEventArgs e
)
Protected Overridable Sub OnThumbnailActivate (
    e As ThumbnailEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsThumbnailEventArgs
A ThumbnailEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnThumbnailCreated Method

ThumbnailViewOnThumbnailCreated Method

Called when a thumbnail image has been created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnThumbnailCreated(
    ThumbnailEventArgs e
)
Protected Overridable Sub OnThumbnailCreated (
    e As ThumbnailEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WinControlsThumbnailEventArgs
A ThumbnailEventArgs containing information for this event.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.OnThumbnailSizeChanged Method

ThumbnailViewOnThumbnailSizeChanged Method

Called when the ThumbnailSize property is changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnThumbnailSizeChanged()
Protected Overridable Sub OnThumbnailSizeChanged
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.RemoveAfterDragDrop Method

ThumbnailViewRemoveAfterDragDrop Method

Override to change the way a thumbnail is removed after a drag drop, if you are using the ThumbnailView in a composite control

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RemoveAfterDragDrop(
    ThumbnailDragDropOperation data
)
Protected Overridable Sub RemoveAfterDragDrop (
    data As ThumbnailDragDropOperation
)

Parameters

data
Type: Atalasoft.Imaging.WinControlsThumbnailDragDropOperation
The ThumbnailDragDropOperation passed to the OnDragDrop method
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.RemoveOverride Method

ThumbnailViewRemoveOverride Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RemoveOverride(
    ThumbnailDragDropOperation data
)
Protected Overridable Sub RemoveOverride (
    data As ThumbnailDragDropOperation
)

Parameters

data
Type: Atalasoft.Imaging.WinControlsThumbnailDragDropOperation
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ReorderAfterDragDrop Method

ThumbnailViewReorderAfterDragDrop Method

Override to change the way a thumbnail is reordered after a drag drop, if you are using the ThumbnailView in a composite control

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ReorderAfterDragDrop(
    Thumbnail tn,
    int index,
    bool clone,
    bool cached
)
Protected Overridable Sub ReorderAfterDragDrop (
    tn As Thumbnail,
    index As Integer,
    clone As Boolean,
    cached As Boolean
)

Parameters

tn
Type: Atalasoft.Imaging.WinControlsThumbnail
The Thumbnail being dragged
index
Type: SystemInt32
The new thumbnail index
clone
Type: SystemBoolean
A bool determiing if the Thumbnail should be cloned before insertion
cached
Type: SystemBoolean
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ResumeSorting Method

ThumbnailViewResumeSorting Method

Resumes any sorting of the thumbnails.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ResumeSorting()
Public Sub ResumeSorting
Remarks
This method will force a sort if SortBy is anything other than None.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ScrollTo Method

ThumbnailViewScrollTo Method

Scrolls to a specific thumbnail.
Overload List
 | Name | Description
Public method | ScrollTo(Int32) | Scrolls the control to a specific column or row.
Public method | ScrollTo(Thumbnail) | Scrolls a specified Thumbnail to the top of the control.
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ScrollTo Method (Int32)

ThumbnailViewScrollTo Method (Int32)

Scrolls the control to a specific column or row.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ScrollTo(
    int columnOrRow
)
Public Sub ScrollTo (
    columnOrRow As Integer
)

Parameters

columnOrRow
Type: SystemInt32
The column or row to bring to the top. If ThumbnailLayout is Horizontal, this value will be the column, otherwise it specifies the row.
See Also

Reference

ThumbnailView Class
ScrollTo Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ScrollTo Method (Thumbnail)

ThumbnailViewScrollTo Method (Thumbnail)

Scrolls a specified Thumbnail to the top of the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ScrollTo(
    Thumbnail thumbnail
)
Public Sub ScrollTo (
    thumbnail As Thumbnail
)

Parameters

thumbnail
Type: Atalasoft.Imaging.WinControlsThumbnail
The thumbnail to scroll into view.
See Also

Reference

ThumbnailView Class
ScrollTo Overload
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectAll Method

ThumbnailViewSelectAll Method

Selects all of the thumbnails in the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectAll()
Public Sub SelectAll
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace
ClearSelection Method


ThumbnailView.SelectFromBounds Method

ThumbnailViewSelectFromBounds Method

This method will select thumbnails that intersect the rectangle provided.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SelectFromBounds(
    Rectangle selection
)
Public Sub SelectFromBounds (
    selection As Rectangle
)

Parameters

selection
Type: System.DrawingRectangle
The rectangle bounds from which to select items. This selection must be in client coordinates.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SetDataBinding Method

ThumbnailViewSetDataBinding Method

Sets up data binding for the ThumbnailView.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetDataBinding(
    ThumbnailDataBinding binding
)
Public Sub SetDataBinding (
    binding As ThumbnailDataBinding
)

Parameters

binding
Type: Atalasoft.Imaging.WinControlsThumbnailDataBinding
A ThumbnailDataBinding object containing binding information.

Return Value

Type:
To disable data binding pass null (Nothing in VB) to this method.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.Sort Method

ThumbnailViewSort Method

Use this method to force the ThumbnailCollection to sort.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Sort()
Public Sub Sort
Remarks
The thumbnails are sorted based on the thumbnail caption. This can be controlled using the DisplayText property.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.WndProc Method

ThumbnailViewWndProc Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)

Parameters

m
Type: System.Windows.FormsMessage
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView Events

The ThumbnailView type exposes the following members.

Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item.
Public event | BeforeThumbnailLoad | Raised just before a thumbnail image is going to be created.
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CompareThumbnails | Occurs when the thumbnail items need to be sorted.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | EraseDropPositionIndicator | Raised when the drag drop indicator needs to be erased.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoverItemChanged | Raised when the HoverItem has changed.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging an item.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintDropPositionIndicator | Raised when the drag drop indicator needs to be painted.
Public event | PaintThumbnail | Occurs when a thumbnail needs to be painted.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | SelectedIndexChanged | Occurs when the selected thumbnail index changes.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThumbnailActivate | Raised when a thumbnail enters 'edit' mode.
Public event | ThumbnailClicked | Raised when a thumbnail is clicked.
Public event | ThumbnailCollectionChanged | Raised when the thumbnail collection has changed from an add, insert, remove or clear action.
Public event | ThumbnailCreated | Raised when a thumbnail has been created.
Public event | ThumbnailDoubleClicked | Raised when a thumbnail is double-clicked.
Public event | ThumbnailDrop | Occurs when the user has dropped an item onto the control.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.AfterLabelEdit Event

ThumbnailViewAfterLabelEdit Event

Occurs when the label for an item is edited by the user.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event LabelEditEventHandler AfterLabelEdit
Public Event AfterLabelEdit As LabelEditEventHandler

Value

Type: System.Windows.FormsLabelEditEventHandler
Remarks

The AfterLabelEdit event occurs when the user finishes modifying the text for an item. The new string that the user types for the item is passed to the event, and the event handler can reject the change. If the event handler rejects the change, the text reverts to the text as it was before the user began editing the item. In order for the AfterLabelEdit event to be raised, the LabelEdit property of the ThumbnailView control must be set to true. You can create an event handler for the BeforeLabelEdit event to perform tasks before the user edits the text of an item.

See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace
ThumbnailViewBeforeLabelEdit
ThumbnailViewLabelEdit


ThumbnailView.BeforeLabelEdit Event

ThumbnailViewBeforeLabelEdit Event

Occurs when the user starts editing the label of an item.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event LabelEditEventHandler BeforeLabelEdit
Public Event BeforeLabelEdit As LabelEditEventHandler

Value

Type: System.Windows.FormsLabelEditEventHandler
Remarks
The BeforeLabelEdit event occurs when the user begins modifying the text for an item. If the event handler cancels this event, the user cannot edit the text. You can use this event to prevent the user from editing specific items in the ThumbnailView control. If the LabelEdit property of the ThumbnailView control is set to false, the BeforeLabelEdit event is not raised; all user attempts to edit item labels are automatically rejected.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace
ThumbnailViewAfterLabelEdit
ThumbnailViewLabelEdit


ThumbnailView.BeforeThumbnailLoad Event

ThumbnailViewBeforeThumbnailLoad Event

Raised just before a thumbnail image is going to be created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailLoadEventHandler BeforeThumbnailLoad
Public Event BeforeThumbnailLoad As ThumbnailLoadEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailLoadEventHandler
Remarks

Handle this event to override the thumbnail load process. By setting the Image property of the ThumbnailLoadEventArgs, you can load the image with customized decoder settings. If you are using a custom decoder that has a special method for obtaining thumbnails, write the thumbnail load code in this event handler.

The event can also be used to obtain a reference to the ProgressEventHandler for the image being loaded in order to show progress of each thumbnail as it's loaded.

The Cancel property of the ThumbnailLoadEventArgs can be set to true to prevent the thumbnail to be loaded into the control.

See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.CompareThumbnails Event

ThumbnailViewCompareThumbnails Event

Occurs when the thumbnail items need to be sorted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CompareEventHandler CompareThumbnails
Public Event CompareThumbnails As CompareEventHandler

Value

Type: Atalasoft.Imaging.WinControlsCompareEventHandler
Remarks
Handle this event to perform a custom sort on the thumbnails.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.EraseDropPositionIndicator Event

ThumbnailViewEraseDropPositionIndicator Event

Raised when the drag drop indicator needs to be erased.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PaintDropPositionIndicatorEventHandler EraseDropPositionIndicator
Public Event EraseDropPositionIndicator As PaintDropPositionIndicatorEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPaintDropPositionIndicatorEventHandler
Remarks
This event will only be raised if the DropPositionIndicator property is set to Custom.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.HoverItemChanged Event

ThumbnailViewHoverItemChanged Event

Raised when the HoverItem has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailEventHandler HoverItemChanged
Public Event HoverItemChanged As ThumbnailEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ItemDrag Event

ThumbnailViewItemDrag Event

Occurs when the user begins dragging an item.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ItemDragEventHandler ItemDrag
Public Event ItemDrag As ItemDragEventHandler

Value

Type: System.Windows.FormsItemDragEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.PaintDropPositionIndicator Event

ThumbnailViewPaintDropPositionIndicator Event

Raised when the drag drop indicator needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PaintDropPositionIndicatorEventHandler PaintDropPositionIndicator
Public Event PaintDropPositionIndicator As PaintDropPositionIndicatorEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPaintDropPositionIndicatorEventHandler
Remarks
This event will only be raised if the DropPositionIndicator property is set to Custom.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.PaintThumbnail Event

ThumbnailViewPaintThumbnail Event

Occurs when a thumbnail needs to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PaintThumbnailEventHandler PaintThumbnail
Public Event PaintThumbnail As PaintThumbnailEventHandler

Value

Type: Atalasoft.Imaging.WinControlsPaintThumbnailEventHandler
Remarks
Handle this event to perform a custom draw of the thumbnail items.
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.SelectedIndexChanged Event

ThumbnailViewSelectedIndexChanged Event

Occurs when the selected thumbnail index changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectedIndexChanged
Public Event SelectedIndexChanged As EventHandler

Value

Type: SystemEventHandler
Remarks
Handle this event to respond to the user clicking or navigating to a thumbnail with the keyboard in order to view the full size image in an associated ImageViewer control.
Examples
SelectedIndexChanged (C#)
Copy
private void thumbnailView1_SelectedIndexChanged(object sender, System.EventArgs e)
{
     if (thumbnailView1.SelectedIndices.Count > 0)
     {
          workspaceViewer1.Open(_currentFile, thumbnailView1.SelectedIndices[0]);
     }
}
SelectedIndexChanged (Visual Basic)
Copy
Private  Sub thumbnailView1_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles thumbnailView1.SelectedIndexChanged
     If thumbnailView1.SelectedIndices.Count > 0 Then
          workspaceViewer1.Open(_currentFile, thumbnailView1.SelectedIndices(0))
     End If
End Sub
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailActivate Event

ThumbnailViewThumbnailActivate Event

Raised when a thumbnail enters 'edit' mode.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailEventHandler ThumbnailActivate
Public Event ThumbnailActivate As ThumbnailEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailClicked Event

ThumbnailViewThumbnailClicked Event

Raised when a thumbnail is clicked.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailEventHandler ThumbnailClicked
Public Event ThumbnailClicked As ThumbnailEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailCollectionChanged Event

ThumbnailViewThumbnailCollectionChanged Event

Raised when the thumbnail collection has changed from an add, insert, remove or clear action.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event CollectionChangedEventHandler ThumbnailCollectionChanged
Public Event ThumbnailCollectionChanged As CollectionChangedEventHandler

Value

Type: Atalasoft.Imaging.WinControlsCollectionChangedEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailCreated Event

ThumbnailViewThumbnailCreated Event

Raised when a thumbnail has been created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailEventHandler ThumbnailCreated
Public Event ThumbnailCreated As ThumbnailEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailDoubleClicked Event

ThumbnailViewThumbnailDoubleClicked Event

Raised when a thumbnail is double-clicked.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailEventHandler ThumbnailDoubleClicked
Public Event ThumbnailDoubleClicked As ThumbnailEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailEventHandler
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbnailView.ThumbnailDrop Event

ThumbnailViewThumbnailDrop Event

Occurs when the user has dropped an item onto the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ThumbnailDropEventHandler ThumbnailDrop
Public Event ThumbnailDrop As ThumbnailDropEventHandler

Value

Type: Atalasoft.Imaging.WinControlsThumbnailDropEventHandler
Remarks
To find out which item was dragged, handle the ItemDrag event. If multiple items are being dragged, check SelectedIndicies
See Also

Reference

ThumbnailView Class
Atalasoft.Imaging.WinControls Namespace


ThumbViewAttribute Enumeration

Specifies values for the DisplayText and SortBy properties.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ThumbViewAttribute
Public Enumeration ThumbViewAttribute
Members
Member name | Description
None | DisplayText: No text is displayed. SortBy: No sorting is performed.
FileName | DisplayText: The filename is displayed. SortBy: As files are added, they are sorted by their filenames.
DateModified | DisplayText: The last date the file was modified is displayed. SortBy: The files are sorted by their last modified date.
Size | DisplayText: The file size is displayed. SortBy: The files are sorted by their file size.
Type | DisplayText: The type of file is displayed. SortBy: The files are sorted by their type.
DisplayName | DisplayText: The display text is shown. SortBy: The thumbnails are sorted by their display name.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Viewport Class

Defines a base scrollable viewport for images contained in classes that inherit this abstract class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsScrollport
Atalasoft.Imaging.WinControlsViewport
Atalasoft.Imaging.WinControlsBitmapViewer
Atalasoft.Imaging.WinControlsImageViewer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class Viewport : Scrollport
Public MustInherit Class Viewport
    Inherits Scrollport

The Viewport type exposes the following members.

Constructors
 | Name | Description
Protected method | Viewport | Initialize a new instance of the Viewport control.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes.
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border.
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border.
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border.
Protected property | ImageSize | Gets or sets the size of the image in the viewport.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified.
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport.
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport.
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool.
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool.
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool.
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools.
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool.
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool.
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Override this method and pass in a new image. This is used to update the magnifier image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | Returns the vertical resolution based on the difference in X and Y resolution.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event.
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageDraw | Override this method to draw the image onto the viewport.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Overrides ScrollportOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Overrides ControlOnLocationChanged(EventArgs).)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event.
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Overrides ControlOnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Overrides ControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event.
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event.
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Overrides ControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control need to be painted. (Overrides ScrollportOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event.
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event.
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event.
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event.
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event.
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event.
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space.
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed.
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes.
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location.
Public event | MouseToolChanged | Occurs when MouseTool changes.
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed.
Public event | ZoomChanged | Occurs when Zoom changes.
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes.
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes.
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes.
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes.
Top
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


Viewport Constructor

Initialize a new instance of the Viewport control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Viewport()
Protected Sub New
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport Properties

The Viewport type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes.
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border.
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border.
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border.
Protected property | ImageSize | Gets or sets the size of the image in the viewport.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified.
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport.
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport.
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool.
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool.
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool.
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools.
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool.
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool.
Top
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ActiveMouseButton Property

ViewportActiveMouseButton Property

Gets or sets the mouse button used to activate a mouse tool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseButtons ActiveMouseButton { get; set; }
Public Property ActiveMouseButton As MouseButtons
    Get
    Set

Property Value

Type: MouseButtons
The mouse button used to activate mouse tools.
Remarks
The Zoom mouse tool will always use both buttons for zooming in and out.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.AutoZoom Property

ViewportAutoZoom Property

Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoZoomMode AutoZoom { get; set; }
Public Property AutoZoom As AutoZoomMode
    Get
    Set

Property Value

Type: AutoZoomMode
A value indicating how the image should be zoomed as the control is resized or the image size changes.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ImageBorderPen Property

ViewportImageBorderPen Property

Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaPen ImageBorderPen { get; set; }
Public Property ImageBorderPen As AtalaPen
    Get
    Set

Property Value

Type: AtalaPen
The pen used to draw a border around an image.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ImagePosition Property

ViewportImagePosition Property

Gets the visible rectangular region that is occupied by the image excluding the image border.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ImagePosition { get; }
Public ReadOnly Property ImagePosition As Point
    Get

Property Value

Type: Point
The visible rectangular region that is occupied by the image excluding the image border.
Remarks
The property is the same as ScrollPosition but it removes the image border returning the exact position of the image itself.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ImageRectangle Property

ViewportImageRectangle Property

Gets the rectangular area occupied by the image excluding the image border.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ImageRectangle { get; }
Public ReadOnly Property ImageRectangle As Rectangle
    Get

Property Value

Type: Rectangle
The rectangular area occupied by the image excluding the image border.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ImageSize Property

ViewportImageSize Property

Gets or sets the size of the image in the viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Size ImageSize { get; set; }
Protected Property ImageSize As Size
    Get
    Set

Property Value

Type: Size
The size of the image in the viewport.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.Magnifier Property

ViewportMagnifier Property

Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Magnifier Magnifier { get; set; }
Public Property Magnifier As Magnifier
    Get
    Set

Property Value

Type: Magnifier
A reference to the Magnifier attached to this control allowing its properties to be queried and modified.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.MouseTool Property

ViewportMouseTool Property

Gets or sets the value indicating the behavior of the mouse when interacting with the viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual MouseToolType MouseTool { get; set; }
Public Overridable Property MouseTool As MouseToolType
    Get
    Set

Property Value

Type: MouseToolType
The value indicating the behavior of the mouse when interacting with the viewport.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.PanCursor Property

ViewportPanCursor Property

Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor PanCursor { get; set; }
Public Property PanCursor As Cursor
    Get
    Set

Property Value

Type: Cursor

The cursor that is displayed in this Viewport when using the Pan MouseTool.

See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace
ViewportMouseTool


Viewport.ResolutionScaleMode Property

ViewportResolutionScaleMode Property

Gets or sets a value indicating how images with different X and Y resolutions are displayed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolutionScaleMode ResolutionScaleMode { get; set; }
Public Property ResolutionScaleMode As ResolutionScaleMode
    Get
    Set

Property Value

Type: ResolutionScaleMode
A value indicating how images with different X and Y resolutions are displayed.
Remarks
It is common for some FAX images to have a Y resolution that is smaller than the X resolution. It is intended that the height of these images be stretched for display. The ResolutionScaleMode property controls this behavior. The default mode is FAX which only adjusts the aspect ratio of images with binary images.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.Selection Property

ViewportSelection Property

Gets or sets a Rubberband that is used when the MouseTool is set to Selection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rubberband Selection { get; set; }
Public Property Selection As Rubberband
    Get
    Set

Property Value

Type: Rubberband
A Rubberband that is used when the MouseTool is set to Selection.
Remarks
This property may be set to any object inheriting from Rubberband including the RectangleSelection and EllipseRubberband.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.Zoom Property

ViewportZoom Property

Gets or sets the zoom level of the image in the viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
The zoom level of the image in the viewport.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomAreaCursor Property

ViewportZoomAreaCursor Property

Gets or sets the cursor used for the ZoomArea mouse tool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomAreaCursor { get; set; }
Public Property ZoomAreaCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used for the ZoomArea mouse tool.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace
MouseTool Property


Viewport.ZoomCursor Property

ViewportZoomCursor Property

Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomCursor { get; set; }
Public Property ZoomCursor As Cursor
    Get
    Set

Property Value

Type: Cursor

The cursor that is displayed in this Viewport when using the Zoom MouseTool.

See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace
MouseTool Property


Viewport.ZoomInCursor Property

ViewportZoomInCursor Property

Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomInCursor { get; set; }
Public Property ZoomInCursor As Cursor
    Get
    Set

Property Value

Type: Cursor

The cursor that is displayed in this Viewport when using the ZoomIn MouseTool.

See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace
MouseTool Property


Viewport.ZoomInOutPercentage Property

ViewportZoomInOutPercentage Property

Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ZoomInOutPercentage { get; set; }
Public Property ZoomInOutPercentage As Integer
    Get
    Set

Property Value

Type: Int32
The percentage that the zoom will change when using the various Zoom mouse tools.
Remarks
Valid values are from 1 to 100.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomOutCursor Property

ViewportZoomOutCursor Property

Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor ZoomOutCursor { get; set; }
Public Property ZoomOutCursor As Cursor
    Get
    Set

Property Value

Type: Cursor

The cursor that is displayed in this Viewport when using the ZoomOut MouseTool.

See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace
MouseTool Property


Viewport.ZoomRectangle Property

ViewportZoomRectangle Property

Gets or sets the rubberband associated with the ZoomArea MouseTool.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rubberband ZoomRectangle { get; set; }
Public Property ZoomRectangle As Rubberband
    Get
    Set

Property Value

Type: Rubberband
The rubberband associated with the ZoomArea MouseTool.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport Methods

The Viewport type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ComponentFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Override this method and pass in a new image. This is used to update the magnifier image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | Returns the vertical resolution based on the difference in X and Y resolution.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event.
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageDraw | Override this method to draw the image onto the viewport.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Overrides ScrollportOnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Overrides ControlOnLocationChanged(EventArgs).)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event.
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Overrides ControlOnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Overrides ControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event.
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event.
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Overrides ControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control need to be painted. (Overrides ScrollportOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event.
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event.
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event.
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event.
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event.
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event.
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space.
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
 | SetZoomMode | Sets the zoom to the AutoZoomMode.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.Dispose Method

ViewportDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes the object and releases any resources back to the system. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.Dispose Method (Boolean)

ViewportDispose Method (Boolean)

Disposes the object and releases any resources back to the system.
Clean up unmanaged resources.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool isDisposing
)
Protected Overrides Sub Dispose (
    isDisposing As Boolean
)

Parameters

isDisposing
Type: SystemBoolean
A value indicating whether or not this method is called from the public Dispose(Boolean) method.
See Also

Reference

Viewport Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


Viewport.Finalize Method

ViewportFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.GetCurrentImage Method

ViewportGetCurrentImage Method

Override this method and pass in a new image. This is used to update the magnifier image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract Object GetCurrentImage(
    ref bool isBitmapImage
)
Protected MustOverride Function GetCurrentImage (
    ByRef isBitmapImage As Boolean
) As Object

Parameters

isBitmapImage
Type: SystemBoolean
Indicates if the Current image is a GDI+ Image object or if false, a dotImage AtalaImage.

Return Value

Type: Object
An AtalaImage or Image object containing the current image
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.GetScaledResolutionHeight Method

ViewportGetScaledResolutionHeight Method

Returns the vertical resolution based on the difference in X and Y resolution.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GetScaledResolutionHeight()
Public Overridable Function GetScaledResolutionHeight As Double

Return Value

Type: Double
The vertical resolution based on the difference in X and Y resolution.
Remarks
A differing vertical resolution is common for Fax images. Returns a value of 1 unless overridden by an inherited class.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnAutoZoomChanged Method

ViewportOnAutoZoomChanged Method

Called when the AutoZoom property has been changed and raises the AutoZoomChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnAutoZoomChanged(
    EventArgs e
)
Protected Overridable Sub OnAutoZoomChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnImageDraw Method

ViewportOnImageDraw Method

Override this method to draw the image onto the viewport.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void OnImageDraw(
    Rectangle sourceRectangle,
    Rectangle destRectangle,
    Graphics graphics
)
Protected MustOverride Sub OnImageDraw (
    sourceRectangle As Rectangle,
    destRectangle As Rectangle,
    graphics As Graphics
)

Parameters

sourceRectangle
Type: System.DrawingRectangle
The bounding rectangle of the source image.
destRectangle
Type: System.DrawingRectangle
The rectangle indicating the position and size to fit the source rectangle into.
graphics
Type: System.DrawingGraphics
The Graphics object to draw the image onto.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnLayout Method

ViewportOnLayout Method

Called when the layout of the control needs to be updated.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLayout(
    LayoutEventArgs e
)
Protected Overrides Sub OnLayout (
    e As LayoutEventArgs
)

Parameters

e
Type: System.Windows.FormsLayoutEventArgs
A LayoutEventArgs containing information about this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnLocationChanged Method

ViewportOnLocationChanged Method

Called when the Location property has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnLocationChanged(
    EventArgs e
)
Protected Overrides Sub OnLocationChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnMagnifierChanged Method

ViewportOnMagnifierChanged Method

Called when the Magnifier property has been changed and raises the MagnifierChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMagnifierChanged(
    EventArgs e
)
Protected Overridable Sub OnMagnifierChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnMouseDown Method

ViewportOnMouseDown Method

Called when a mouse button has been pressed on top of the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing information about this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnMouseMove Method

ViewportOnMouseMove Method

Called when the mouse is moved over the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs containing information about this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnMouseMovePixel Method

ViewportOnMouseMovePixel Method

Called when the mouse has moved over an image pixel and raises the MouseMovePixel event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseMovePixel(
    MouseEventArgs e
)
Protected Overridable Sub OnMouseMovePixel (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs that contains the pixel location.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnMouseToolChanged Method

ViewportOnMouseToolChanged Method

Called when the MouseTool property has changed and raises the MouseToolChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseToolChanged(
    EventArgs e
)
Protected Overridable Sub OnMouseToolChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnMouseUp Method

ViewportOnMouseUp Method

Called when a mouse button has been released over the control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.FormsMouseEventArgs
A MouseEventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnPaint Method

ViewportOnPaint Method

Called when the control need to be painted.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs containing information used for painting the control.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnPanCursorChanged Method

ViewportOnPanCursorChanged Method

Called when the PanCursor property has changed and raises the PanCursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPanCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnPanCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnSelectionChanged Method

ViewportOnSelectionChanged Method

Called when the Selection has changed and raises the SelectionChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnSelectionChanged(
    EventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnZoomAreaCursorChanged Method

ViewportOnZoomAreaCursorChanged Method

Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnZoomAreaCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnZoomAreaCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnZoomChanged Method

ViewportOnZoomChanged Method

Called when the Zoom property has changed and raises the ZoomChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnZoomChanged(
    EventArgs e
)
Protected Overridable Sub OnZoomChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnZoomCursorChanged Method

ViewportOnZoomCursorChanged Method

Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnZoomCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnZoomCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnZoomInCursorChanged Method

ViewportOnZoomInCursorChanged Method

Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnZoomInCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnZoomInCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnZoomInOutPercentageChanged Method

ViewportOnZoomInOutPercentageChanged Method

Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnZoomInOutPercentageChanged(
    EventArgs e
)
Protected Overridable Sub OnZoomInOutPercentageChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.OnZoomOutCursorChanged Method

ViewportOnZoomOutCursorChanged Method

Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnZoomOutCursorChanged(
    EventArgs e
)
Protected Overridable Sub OnZoomOutCursorChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.PointFromImage Method

ViewportPointFromImage Method

Converts a Point from image space into client space.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point PointFromImage(
    Point imagePoint
)
Public Function PointFromImage (
    imagePoint As Point
) As Point

Parameters

imagePoint
Type: System.DrawingPoint
The image pixel location to convert.

Return Value

Type: Point
The point in client space for the specified pixel.
Remarks
This method performs a simple calculation and does not perform any checks to ensure the Point provided is a valid image pixel location.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.PointToImage Method

ViewportPointToImage Method

Converts a Point in client space to image space.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point PointToImage(
    Point clientPoint
)
Public Function PointToImage (
    clientPoint As Point
) As Point

Parameters

clientPoint
Type: System.DrawingPoint
The point in client space to convert.

Return Value

Type: Point
The image pixel located at the client position.
Remarks
This method performs a simple calculation and does not perform any checks to ensure the Point returned is a valid image pixel location.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.SetZoomMode Method

ViewportSetZoomMode Method

Sets the zoom to the AutoZoomMode.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetZoomMode(
    AutoZoomMode zoomType
)
Public Sub SetZoomMode (
    zoomType As AutoZoomMode
)

Parameters

zoomType
Type: Atalasoft.Imaging.WinControlsAutoZoomMode
The zoom mode to apply.
Remarks
This is a one time setting. See AutoZoom for maintaining this zoom style.
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport Events

The Viewport type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed.
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes.
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location.
Public event | MouseToolChanged | Occurs when MouseTool changes.
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed.
Public event | ZoomChanged | Occurs when Zoom changes.
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes.
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes.
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes.
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes.
Top
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.AutoZoomChanged Event

ViewportAutoZoomChanged Event

Occurs when the AutoZoom property has been changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AutoZoomChanged
Public Event AutoZoomChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.MagnifierChanged Event

ViewportMagnifierChanged Event

Occurs when Magnifier changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler MagnifierChanged
Public Event MagnifierChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.MouseMovePixel Event

ViewportMouseMovePixel Event

Occurs when the cursor moves over a pixel in the image returning the pixel location.
Occurs when the cursor moves over a pixel in the image returning the pixel location.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MouseEventHandler MouseMovePixel
Public Event MouseMovePixel As MouseEventHandler

Value

Type: System.Windows.FormsMouseEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.MouseToolChanged Event

ViewportMouseToolChanged Event

Occurs when MouseTool changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler MouseToolChanged
Public Event MouseToolChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.PanCursorChanged Event

ViewportPanCursorChanged Event

Occurs when PanCursor changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler PanCursorChanged
Public Event PanCursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.SelectionChanged Event

ViewportSelectionChanged Event

Occurs when Selection changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomAreaCursorChanged Event

ViewportZoomAreaCursorChanged Event

Occurs when the cursor of the ZoomArea mouse tool has been changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomAreaCursorChanged
Public Event ZoomAreaCursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace
ZoomAreaCursor Property


Viewport.ZoomChanged Event

ViewportZoomChanged Event

Occurs when Zoom changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomChanged
Public Event ZoomChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomCursorChanged Event

ViewportZoomCursorChanged Event

Occurs when ZoomCursor changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomCursorChanged
Public Event ZoomCursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomInCursorChanged Event

ViewportZoomInCursorChanged Event

Occurs when ZoomInCursor changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomInCursorChanged
Public Event ZoomInCursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomInOutPercentageChanged Event

ViewportZoomInOutPercentageChanged Event

Occurs when ZoomInOutPercentage changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomInOutPercentageChanged
Public Event ZoomInOutPercentageChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


Viewport.ZoomOutCursorChanged Event

ViewportZoomOutCursorChanged Event

Occurs when ZoomOutCursor changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomOutCursorChanged
Public Event ZoomOutCursorChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Viewport Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer Class

A scrollable viewport containing a Workspace object.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Atalasoft.Imaging.WinControlsScrollport
Atalasoft.Imaging.WinControlsViewport
Atalasoft.Imaging.WinControlsImageViewer
Atalasoft.Imaging.WinControlsWorkspaceViewer
Atalasoft.Annotate.UIAnnotateViewer

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WorkspaceViewer : ImageViewer
Public Class WorkspaceViewer
    Inherits ImageViewer

The WorkspaceViewer type exposes the following members.

Constructors
 | Name | Description
Public method | WorkspaceViewer | Initializes a new instance of the WorkspaceViewer control.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AntialiasDisplay | Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels. (Inherited from ImageViewer.)
Public property | Asynchronous |
Public property | AutoDispose | Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoUpdate | Gets or sets a value indicating if the control updates its display whenever the current image changes.
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColorManage | Get or set a value indicating if the control will automatically color correct images. (Inherited from ImageViewer.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Protected property | ControlHandleDestroyed | Gets a value indicating whether the control handle has been destroyed.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device. (Inherited from ImageViewer.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | (Overrides ImageViewerImage.)
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | Images |
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device. (Inherited from ImageViewer.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images. (Inherited from ImageViewer.)
Public property | Queue |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device. (Inherited from ImageViewer.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoLevels | Gets or sets the number of undo levels in the Undo collection.
Public property | Undos |
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image.
Public method | ApplyCommand(ImageCommand, String) | Applies an ImageCommand to the current image with a custom undo description.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the control and releases resources back to the system. (Overrides ImageViewerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ImageViewerFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Returns the current image and indicates whether or not this image is a Bitmap. (Inherited from ImageViewer.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control. (Inherited from ImageViewer.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAntialiasDisplayChanged | Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event. (Inherited from ImageViewer.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDisposeImage | Called when an image is about to be disposed.
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the control handle is created. (Overrides ControlOnHandleCreated(EventArgs).)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageChanged | Called when the Image property has changed. (Overrides ImageViewerOnImageChanged(ImageEventArgs).)
Protected method | OnImageDraw | This method is used to draw the image onto the Viewport graphics. (Inherited from ImageViewer.)
Protected method | OnImageStreamCompleted | Called when the stream being used to read an image is no longer needed and raises the ImageStreamCompleted event.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to redraw itself. (Inherited from ImageViewer.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProcessCompleted | Called when an asynchronous process has completed and raises the ProcessCompleted event.
Protected method | OnProcessError | Called when there is an error during an asynchronous process and raises the ProcessError event.
Protected method | OnProgress | Raises the Progress event.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event. (Inherited from Viewport.)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | Open(Stream) | Loads an image from a stream into the WorkspaceViewer.
Public method | Open(String) | Loads an image file into a WorkspaceViewer.
Public method | Open(Stream, Int32) | Loads an image from a stream into the WorkspaceViewer specifying the frame to load.
Public method | Open(String, Int32) | Loads an image file into a WorkspaceViewer with the specified frame index.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Removes any cached images used for fast displays and redraws the image. (Inherited from ImageViewer.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the current image(s) to a stream.
Public method | Save(String, ImageEncoder) | Saves the current image(s) to a file using the specified encoder.
Public method | Save(String, ImageType) | Obsolete. Saves the current image(s) using the specified image type.
Public method | Save(Stream, ImageEncoder, Int32) | Saves the current image(s) to a stream using the specified encoder and frame index.
Public method | Save(String, ImageEncoder, Int32) | Saves the current image(s) to a file using the specified encoder and frame index.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetNewImage | Called when the Image is being replaced. (Inherited from ImageViewer.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetWorkspace | Sets the Workspace of this control.
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Updates the image in the control with the current image in the workspace.
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
Events
 | Name | Description
Public event | AntialiasDisplayChanged | Occurs when AntialiasDisplay changes. (Inherited from ImageViewer.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DisposeImage | Fired when an image in the ImageCollection or UndoCollection is disposed.
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImageChanged | Occurs when commands are applied to change the image. (Inherited from ImageViewer.)
Public event | ImageStreamCompleted |
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | ProcessCompleted |
Public event | ProcessError |
Public event | Progress |
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
Remarks
The WorkspaceViewer control is intended to be the primary control used for displaying images.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer Constructor

Initializes a new instance of the WorkspaceViewer control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WorkspaceViewer()
Public Sub New
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer Properties

The WorkspaceViewer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveMouseButton | Gets or sets the mouse button used to activate a mouse tool. (Inherited from Viewport.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AntialiasDisplay | Gets or sets the antialiasing mode, controlling how the image is scaled at different zoom levels. (Inherited from ImageViewer.)
Public property | Asynchronous |
Public property | AutoDispose | Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoUpdate | Gets or sets a value indicating if the control updates its display whenever the current image changes.
Public property | AutoZoom | Gets or sets a value indicating how the image should be zoomed as the control is resized or the image size changes. (Inherited from Viewport.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Centered | Gets of sets the value indicating if the image is centered in the control. (Inherited from Scrollport.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColorManage | Get or set a value indicating if the control will automatically color correct images. (Inherited from ImageViewer.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Protected property | ControlHandleDestroyed | Gets a value indicating whether the control handle has been destroyed.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device. (Inherited from ImageViewer.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | HScroll | Sets of returns a value indicating if the Horizontal scroll bar is visible. (Inherited from Scrollport.)
Public property | Image | (Overrides ImageViewerImage.)
Public property | ImageBorderPen | Gets or sets the AtalaPenpen used to draw a border around an image. Set to null for no border. (Inherited from Viewport.)
Public property | ImagePosition | Gets the visible rectangular region that is occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | ImageRectangle | Gets the rectangular area occupied by the image excluding the image border. (Inherited from Viewport.)
Public property | Images |
Protected property | ImageSize | Gets or sets the size of the image in the viewport. (Inherited from Viewport.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Magnifier | Gets a reference to the Magnifier attached to this control allowing its properties to be queried and modified. (Inherited from Viewport.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseTool | Gets or sets the value indicating the behavior of the mouse when interacting with the viewport. (Inherited from Viewport.)
Public property | MouseWheelScrolling | Gets or sets a value indicating whether the viewer will scroll when the mouse wheel is used. (Inherited from Scrollport.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device. (Inherited from ImageViewer.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PanCursor | Gets or sets the cursor that is displayed in this Viewport when using the Pan MouseTool. (Inherited from Viewport.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images. (Inherited from ImageViewer.)
Public property | Queue |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device. (Inherited from ImageViewer.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResolutionScaleMode | Gets or sets a value indicating how images with different X and Y resolutions are displayed. (Inherited from Viewport.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarStyle | Gets or sets a value indicating the visibility of the scrollbars. (Inherited from Scrollport.)
Public property | ScrollPosition | Gets or sets the top left position of the scrollable area. (Inherited from Scrollport.)
Public property | ScrollRectangle | Gets the Rectangle of the scrollable area in the scrollport. (Inherited from Scrollport.)
Public property | ScrollSize | Gets or sets the Size of the scrollable area. (Inherited from Scrollport.)
Public property | Selection | Gets or sets a Rubberband that is used when the MouseTool is set to Selection. (Inherited from Viewport.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmoothScroll | Gets or sets a value indicating whether the contents update while the scroll thumb is being dragged. (Inherited from Scrollport.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoLevels | Gets or sets the number of undo levels in the Undo collection.
Public property | Undos |
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Sets of returns a value indicating if the Vertical scroll bar is visible. (Inherited from Scrollport.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in the viewport. (Inherited from Viewport.)
Public property | ZoomAreaCursor | Gets or sets the cursor used for the ZoomArea mouse tool. (Inherited from Viewport.)
Public property | ZoomCursor | Gets or sets the cursor that is displayed in this Viewport when using the Zoom MouseTool. (Inherited from Viewport.)
Public property | ZoomInCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomIn MouseTool. (Inherited from Viewport.)
Public property | ZoomInOutPercentage | Gets or sets the percentage that the zoom will change when using the various Zoom mouse tools. (Inherited from Viewport.)
Public property | ZoomOutCursor | Gets or sets the cursor that is displayed in this Viewport when using the ZoomOut MouseTool. (Inherited from Viewport.)
Public property | ZoomRectangle | Gets or sets the rubberband associated with the ZoomArea MouseTool. (Inherited from Viewport.)
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Asynchronous Property

WorkspaceViewerAsynchronous Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Asynchronous { get; set; }
Public Property Asynchronous As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.AutoDispose Property

WorkspaceViewerAutoDispose Property

Gets or sets a value indicating if the Workspace should dispose all images it contains when finalized.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoDispose { get; set; }
Public Property AutoDispose As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the Workspace should dispose all images it contains when finalized.
Remarks
This value is true by default. Set it to false if using images in another location.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.AutoUpdate Property

WorkspaceViewerAutoUpdate Property

Gets or sets a value indicating if the control updates its display whenever the current image changes.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoUpdate { get; set; }
Public Property AutoUpdate As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the control updates its display whenever the current image changes.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ControlHandleDestroyed Property

WorkspaceViewerControlHandleDestroyed Property

Gets a value indicating whether the control handle has been destroyed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool ControlHandleDestroyed { get; }
Protected ReadOnly Property ControlHandleDestroyed As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the control handle has been destroyed.
Remarks
Derived classes that override methods should check the value of ControlHandleDestroyed before accessing control properties. This will prevent exceptions if asynchronous processing is ending after the control handle has been destroyed.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Image Property

WorkspaceViewerImage Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override AtalaImage Image { get; set; }
Public Overrides Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Images Property

WorkspaceViewerImages Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCollection Images { get; }
Public ReadOnly Property Images As ImageCollection
    Get

Property Value

Type: ImageCollection
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Queue Property

WorkspaceViewerQueue Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProcessQueue Queue { get; }
Public ReadOnly Property Queue As ProcessQueue
    Get

Property Value

Type: ProcessQueue
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.UndoLevels Property

WorkspaceViewerUndoLevels Property

Gets or sets the number of undo levels in the Undo collection.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int UndoLevels { get; set; }
Public Property UndoLevels As Integer
    Get
    Set

Property Value

Type: Int32
The number of undo levels in the Undo collection.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Undos Property

WorkspaceViewerUndos Property

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UndoCollection Undos { get; }
Public ReadOnly Property Undos As UndoCollection
    Get

Property Value

Type: UndoCollection
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer Methods

The WorkspaceViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image.
Public method | ApplyCommand(ImageCommand, String) | Applies an ImageCommand to the current image with a custom undo description.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the control and releases resources back to the system. (Overrides ImageViewerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ImageViewerFinalize.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetCurrentImage | Returns the current image and indicates whether or not this image is a Bitmap. (Inherited from ImageViewer.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Public method | GetScaledResolutionHeight | checks the image resolution and if the Dpi.X != Dpi.Y returns the value to scaled the height appropriately in the control. (Inherited from ImageViewer.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAntialiasDisplayChanged | Called when the AntialiasDisplay property has changed and raises the AntialiasDisplayChanged event. (Inherited from ImageViewer.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoZoomChanged | Called when the AutoZoom property has been changed and raises the AutoZoomChanged event. (Inherited from Viewport.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCenteredChanged | Called when the Centered property has changed and raises the CenteredChanged event. (Inherited from Scrollport.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Called when a mouse button is clicked on the control. (Inherited from Scrollport.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDisposeImage | Called when an image is about to be disposed.
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Called when the control handle is created. (Overrides ControlOnHandleCreated(EventArgs).)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImageChanged | Called when the Image property has changed. (Overrides ImageViewerOnImageChanged(ImageEventArgs).)
Protected method | OnImageDraw | This method is used to draw the image onto the Viewport graphics. (Inherited from ImageViewer.)
Protected method | OnImageStreamCompleted | Called when the stream being used to read an image is no longer needed and raises the ImageStreamCompleted event.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Called when the layout of the control needs to be updated. (Inherited from Viewport.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the Location property has changed. (Inherited from Viewport.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMagnifierChanged | Called when the Magnifier property has been changed and raises the MagnifierChanged event. (Inherited from Viewport.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button has been pressed on top of the control. (Inherited from Viewport.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Called when the mouse is moved over the control. (Inherited from Viewport.)
Protected method | OnMouseMovePixel | Called when the mouse has moved over an image pixel and raises the MouseMovePixel event. (Inherited from Viewport.)
Protected method | OnMouseToolChanged | Called when the MouseTool property has changed and raises the MouseToolChanged event. (Inherited from Viewport.)
Protected method | OnMouseUp | Called when a mouse button has been released over the control. (Inherited from Viewport.)
Protected method | OnMouseWheel | Called when a MouseWheel event is being raised. (Inherited from Scrollport.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Called when the control needs to redraw itself. (Inherited from ImageViewer.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnPanCursorChanged | Called when the PanCursor property has changed and raises the PanCursorChanged event. (Inherited from Viewport.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProcessCompleted | Called when an asynchronous process has completed and raises the ProcessCompleted event.
Protected method | OnProcessError | Called when there is an error during an asynchronous process and raises the ProcessError event.
Protected method | OnProgress | Raises the Progress event.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScrollBarStyleChanged | Called when the ScrollBarStyle property has changed and raises the ScrollBarStyleChanged event. (Inherited from Scrollport.)
Protected method | OnScrollChanged | Raises the ScrollChanged event. (Inherited from Scrollport.)
Protected method | OnScrolling | Raises the Scrolling event. (Inherited from Scrollport.)
Protected method | OnSelectionChanged | Called when the Selection has changed and raises the SelectionChanged event. (Inherited from Viewport.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSmoothScrollChanged | Called when the SmoothScroll property has changed and raises the SmoothScrollChanged event. (Inherited from Scrollport.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnZoomAreaCursorChanged | Called when the ZoomAreaCursor property has changed and raises the ZoomAreaCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomChanged | Called when the Zoom property has changed and raises the ZoomChanged event. (Inherited from Viewport.)
Protected method | OnZoomCursorChanged | Called when the ZoomCursor property has changed and raises the ZoomCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInCursorChanged | Called when the ZoomInCursor property has changed and raises the ZoomInCursorChanged event. (Inherited from Viewport.)
Protected method | OnZoomInOutPercentageChanged | Called when the ZoomInOutPercentage property has changed and raises the ZoomInOutPercentageChanged event. (Inherited from Viewport.)
Protected method | OnZoomOutCursorChanged | Called when the ZoomOutCursor property has changed and raises the ZoomOutCursorChanged event. (Inherited from Viewport.)
Public method | Open(Stream) | Loads an image from a stream into the WorkspaceViewer.
Public method | Open(String) | Loads an image file into a WorkspaceViewer.
Public method | Open(Stream, Int32) | Loads an image from a stream into the WorkspaceViewer specifying the frame to load.
Public method | Open(String, Int32) | Loads an image file into a WorkspaceViewer with the specified frame index.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointFromImage | Converts a Point from image space into client space. (Inherited from Viewport.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToImage | Converts a Point in client space to image space. (Inherited from Viewport.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Removes any cached images used for fast displays and redraws the image. (Inherited from ImageViewer.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Save(Stream, ImageEncoder) | Saves the current image(s) to a stream.
Public method | Save(String, ImageEncoder) | Saves the current image(s) to a file using the specified encoder.
Public method | Save(String, ImageType) | Obsolete. Saves the current image(s) using the specified image type.
Public method | Save(Stream, ImageEncoder, Int32) | Saves the current image(s) to a stream using the specified encoder and frame index.
Public method | Save(String, ImageEncoder, Int32) | Saves the current image(s) to a file using the specified encoder and frame index.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetNewImage | Called when the Image is being replaced. (Inherited from ImageViewer.)
Protected method | SetScrollSize | Sets the size of the scrollable area. (Inherited from Scrollport.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | SetWorkspace | Sets the Workspace of this control.
 | SetZoomMode | Sets the zoom to the AutoZoomMode. (Inherited from Viewport.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Updates the image in the control with the current image in the workspace.
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from Scrollport.)
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ApplyCommand Method

WorkspaceViewerApplyCommand Method

Overload List
 | Name | Description
Public method | ApplyCommand(ImageCommand) | Applies an ImageCommand to the current image.
Public method | ApplyCommand(ImageCommand, String) | Applies an ImageCommand to the current image with a custom undo description.
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ApplyCommand Method (ImageCommand)

WorkspaceViewerApplyCommand Method (ImageCommand)

Applies an ImageCommand to the current image.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command
)
Public Sub ApplyCommand (
    command As ImageCommand
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The Command to apply. Any object that inherits ImageCommand can be passed into this method.
Remarks
Applies an ImageCommand to the current image in order to process it.
See Also

Reference

WorkspaceViewer Class
ApplyCommand Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ApplyCommand Method (ImageCommand, String)

WorkspaceViewerApplyCommand Method (ImageCommand, String)

Applies an ImageCommand to the current image with a custom undo description.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command,
    string undoDescription
)
Public Sub ApplyCommand (
    command As ImageCommand,
    undoDescription As String
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The Command to apply. Any object that inherits ImageCommand can be passed into this method.
undoDescription
Type: SystemString
A text description of the action being performed.
See Also

Reference

WorkspaceViewer Class
ApplyCommand Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Dispose Method

WorkspaceViewerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the control and releases resources back to the system. (Overrides ImageViewerDispose(Boolean).)
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Dispose Method (Boolean)

WorkspaceViewerDispose Method (Boolean)

Disposes of the control and releases resources back to the system.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method is called from the public Dispose method or from the finalizer.
See Also

Reference

WorkspaceViewer Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Finalize Method

WorkspaceViewerFinalize Method

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnDisposeImage Method

WorkspaceViewerOnDisposeImage Method

Called when an image is about to be disposed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnDisposeImage(
    ImageCancelEventArgs e
)
Protected Sub OnDisposeImage (
    e As ImageCancelEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageCancelEventArgs
An ImageCancelEventArgs containing the image about to be disposed. To stop the image from being disposed, set the Cancel property to true.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnHandleCreated Method

WorkspaceViewerOnHandleCreated Method

Called when the control handle is created.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnHandleCreated(
    EventArgs e
)
Protected Overrides Sub OnHandleCreated (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs for this event.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnImageChanged Method

WorkspaceViewerOnImageChanged Method

Called when the Image property has changed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnImageChanged(
    ImageEventArgs e
)
Protected Overrides Sub OnImageChanged (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
An ImageEventArgs containing the new Image.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnImageStreamCompleted Method

WorkspaceViewerOnImageStreamCompleted Method

Called when the stream being used to read an image is no longer needed and raises the ImageStreamCompleted event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageStreamCompleted(
    ImageStreamEventArgs e
)
Protected Overridable Sub OnImageStreamCompleted (
    e As ImageStreamEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageStreamEventArgs
An ImageStreamEventArgs containing the stream.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnProcessCompleted Method

WorkspaceViewerOnProcessCompleted Method

Called when an asynchronous process has completed and raises the ProcessCompleted event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnProcessCompleted(
    ImageEventArgs e
)
Protected Sub OnProcessCompleted (
    e As ImageEventArgs
)

Parameters

e
Type: Atalasoft.ImagingImageEventArgs
An ImageEventArgs containing the processed image.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnProcessError Method

WorkspaceViewerOnProcessError Method

Called when there is an error during an asynchronous process and raises the ProcessError event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnProcessError(
    ExceptionEventArgs e
)
Protected Sub OnProcessError (
    e As ExceptionEventArgs
)

Parameters

e
Type: Atalasoft.ImagingExceptionEventArgs
An ExceptionEventArgs containing the exception raised during this process.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.OnProgress Method

WorkspaceViewerOnProgress Method

Raises the Progress event.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnProgress(
    ProgressEventArgs e
)
Protected Sub OnProgress (
    e As ProgressEventArgs
)

Parameters

e
Type: Atalasoft.ImagingProgressEventArgs
A ProgressEventArgs containing progress information.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Open Method

WorkspaceViewerOpen Method

Overload List
 | Name | Description
Public method | Open(Stream) | Loads an image from a stream into the WorkspaceViewer.
Public method | Open(String) | Loads an image file into a WorkspaceViewer.
Public method | Open(Stream, Int32) | Loads an image from a stream into the WorkspaceViewer specifying the frame to load.
Public method | Open(String, Int32) | Loads an image file into a WorkspaceViewer with the specified frame index.
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Open Method (Stream)

WorkspaceViewerOpen Method (Stream)

Loads an image from a stream into the WorkspaceViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream
)
Public Sub Open (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing the image data.
See Also

Reference

WorkspaceViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Open Method (String)

WorkspaceViewerOpen Method (String)

Loads an image file into a WorkspaceViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName
)
Public Sub Open (
    fileName As String
)

Parameters

fileName
Type: SystemString
The filename of the image to load.
See Also

Reference

WorkspaceViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Open Method (Stream, Int32)

WorkspaceViewerOpen Method (Stream, Int32)

Loads an image from a stream into the WorkspaceViewer specifying the frame to load.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
A stream containing the image data.
frameIndex
Type: SystemInt32
A zero-based index of the frame to load when the image is a multi-framed format such as TIFF. Set this to -1 to load all of the frames.
See Also

Reference

WorkspaceViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Open Method (String, Int32)

WorkspaceViewerOpen Method (String, Int32)

Loads an image file into a WorkspaceViewer with the specified frame index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string filename,
    int frameIndex
)
Public Sub Open (
    filename As String,
    frameIndex As Integer
)

Parameters

filename
Type: SystemString
The filename of the image to load.
frameIndex
Type: SystemInt32
A zero-based index of the frame to load when the image is a multi-framed format such as TIFF. Set this to -1 to load all of the frames.
See Also

Reference

WorkspaceViewer Class
Open Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Save Method

WorkspaceViewerSave Method

Overload List
 | Name | Description
Public method | Save(Stream, ImageEncoder) | Saves the current image(s) to a stream.
Public method | Save(String, ImageEncoder) | Saves the current image(s) to a file using the specified encoder.
Public method | Save(String, ImageType) | Obsolete. Saves the current image(s) using the specified image type.
Public method | Save(Stream, ImageEncoder, Int32) | Saves the current image(s) to a stream using the specified encoder and frame index.
Public method | Save(String, ImageEncoder, Int32) | Saves the current image(s) to a file using the specified encoder and frame index.
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Save Method (Stream, ImageEncoder)

WorkspaceViewerSave Method (Stream, ImageEncoder)

Saves the current image(s) to a stream.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder
)

Parameters

stream
Type: System.IOStream
The stream to save the image(s) into.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder used to encode the image data.
See Also

Reference

WorkspaceViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Save Method (String, ImageEncoder)

WorkspaceViewerSave Method (String, ImageEncoder)

Saves the current image(s) to a file using the specified encoder.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder
)

Parameters

fileName
Type: SystemString
The filename to which the image data is saved.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder used to encode the image data.
See Also

Reference

WorkspaceViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Save Method (String, ImageType)

WorkspaceViewerSave Method (String, ImageType)

Note: This API is now obsolete.

Saves the current image(s) using the specified image type.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)]
public void Save(
    string fileName,
    ImageType imageType
)
<ObsoleteAttribute("The ImageType enumeration has been deprecated. Use the Save overload that takes an ImageEncoder instead.",
    false)>
Public Sub Save (
    fileName As String,
    imageType As ImageType
)

Parameters

fileName
Type: SystemString
The filename to which the image data is saved.
imageType
Type: Atalasoft.Imaging.CodecImageType
The type of image encoder to use.
See Also

Reference

WorkspaceViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Save Method (Stream, ImageEncoder, Int32)

WorkspaceViewerSave Method (Stream, ImageEncoder, Int32)

Saves the current image(s) to a stream using the specified encoder and frame index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder,
    int frameIndex
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder,
    frameIndex As Integer
)

Parameters

stream
Type: System.IOStream
The stream to save the image(s) into.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder used to encode the image data.
frameIndex
Type: SystemInt32
The image index in the collection to save. Set this to -1 if all images are to be saved.
See Also

Reference

WorkspaceViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Save Method (String, ImageEncoder, Int32)

WorkspaceViewerSave Method (String, ImageEncoder, Int32)

Saves the current image(s) to a file using the specified encoder and frame index.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder,
    int frameIndex
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder,
    frameIndex As Integer
)

Parameters

fileName
Type: SystemString
The filename to which the image data is saved.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder used to encode the image data.
frameIndex
Type: SystemInt32
The image index in the collection to save. Set this to -1 if all images are to be saved.
See Also

Reference

WorkspaceViewer Class
Save Overload
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.SetWorkspace Method

WorkspaceViewerSetWorkspace Method

Sets the Workspace of this control.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetWorkspace(
    Workspace workspace
)
Public Sub SetWorkspace (
    workspace As Workspace
)

Parameters

workspace
Type: Atalasoft.ImagingWorkspace
The Workspace object to set.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Update Method

WorkspaceViewerUpdate Method

Updates the image in the control with the current image in the workspace.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Update()
Public Sub Update
Remarks
Set AutoUpdate to automatically turn on or off this behavior.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace
AutoUpdate


WorkspaceViewer Events

The WorkspaceViewer type exposes the following members.

Events
 | Name | Description
Public event | AntialiasDisplayChanged | Occurs when AntialiasDisplay changes. (Inherited from ImageViewer.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoZoomChanged | Occurs when the AutoZoom property has been changed. (Inherited from Viewport.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CenteredChanged | Occurs when Centered changes. (Inherited from Scrollport.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DisposeImage | Fired when an image in the ImageCollection or UndoCollection is disposed.
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImageChanged | Occurs when commands are applied to change the image. (Inherited from ImageViewer.)
Public event | ImageStreamCompleted |
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MagnifierChanged | Occurs when Magnifier changes. (Inherited from Viewport.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseMovePixel | Occurs when the cursor moves over a pixel in the image returning the pixel location. (Inherited from Viewport.)
Public event | MouseToolChanged | Occurs when MouseTool changes. (Inherited from Viewport.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PanCursorChanged | Occurs when PanCursor changes. (Inherited from Viewport.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | ProcessCompleted |
Public event | ProcessError |
Public event | Progress |
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollBarStyleChanged | Occurs when ScrollBarStyle changes. (Inherited from Scrollport.)
Public event | ScrollChanged | Occurs when the scrollbar changes position. (Inherited from Scrollport.)
Public event | Scrolling | Occurs while the thumb on the scrollbar is being dragged with the mouse. (Inherited from Scrollport.)
Public event | SelectionChanged | Occurs when Selection changes. (Inherited from Viewport.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SmoothScrollChanged | Occurs when SmoothScroll changes. (Inherited from Scrollport.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | ZoomAreaCursorChanged | Occurs when the cursor of the ZoomArea mouse tool has been changed. (Inherited from Viewport.)
Public event | ZoomChanged | Occurs when Zoom changes. (Inherited from Viewport.)
Public event | ZoomCursorChanged | Occurs when ZoomCursor changes. (Inherited from Viewport.)
Public event | ZoomInCursorChanged | Occurs when ZoomInCursor changes. (Inherited from Viewport.)
Public event | ZoomInOutPercentageChanged | Occurs when ZoomInOutPercentage changes. (Inherited from Viewport.)
Public event | ZoomOutCursorChanged | Occurs when ZoomOutCursor changes. (Inherited from Viewport.)
Top
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.DisposeImage Event

WorkspaceViewerDisposeImage Event

Fired when an image in the ImageCollection or UndoCollection is disposed.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageCancelEventHandler DisposeImage
Public Event DisposeImage As ImageCancelEventHandler

Value

Type: Atalasoft.ImagingImageCancelEventHandler
Remarks
This even should be handled if images are being shared. If this event contains an image that shouldn't be disposed, set the Cancel property to true.
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ImageStreamCompleted Event

WorkspaceViewerImageStreamCompleted Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageFileIOEventHandler ImageStreamCompleted
Public Event ImageStreamCompleted As ImageFileIOEventHandler

Value

Type: Atalasoft.ImagingImageFileIOEventHandler
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ProcessCompleted Event

WorkspaceViewerProcessCompleted Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageEventHandler ProcessCompleted
Public Event ProcessCompleted As ImageEventHandler

Value

Type: Atalasoft.ImagingImageEventHandler
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.ProcessError Event

WorkspaceViewerProcessError Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ExceptionEventHandler ProcessError
Public Event ProcessError As ExceptionEventHandler

Value

Type: Atalasoft.ImagingExceptionEventHandler
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


WorkspaceViewer.Progress Event

WorkspaceViewerProgress Event

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ProgressEventHandler Progress
Public Event Progress As ProgressEventHandler

Value

Type: Atalasoft.ImagingProgressEventHandler
See Also

Reference

WorkspaceViewer Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow Class

The zoom window is a form that displays a zoomed portion of the current image.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Atalasoft.Imaging.WinControlsZoomWindow

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ZoomWindow : Form
Public Class ZoomWindow
    Inherits Form

The ZoomWindow type exposes the following members.

Constructors
 | Name | Description
Public method | ZoomWindow | Initializes a new instance of the ZoomWindow.
Public method | ZoomWindow(Boolean) | Creates a new instance of ZoomWindow specifying whether the zoom window uses a BitmapViewer or an ImageViewer.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | Gets or sets the background color of the window.
Public property | BackgroundImage | Gets or sets the background image of the window.
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CenterPoint | Gets or sets the center pixel of the image inside the ZoomWindow.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Image | Gets or sets the AtalaImage that is being displayed in this ZoomWindow.
Protected property | ImageView | Gets a reference to the ImageViewer control which is part of the ZoomWindow.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in this ZoomWindow.
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks
This form is usually used in conjunction with the Magnifier MouseTool but can also be a standalone window.
See Also

Reference

Atalasoft.Imaging.WinControls Namespace


ZoomWindow Constructor

Creates a ZoomWindow.
Overload List
 | Name | Description
Public method | ZoomWindow | Initializes a new instance of the ZoomWindow.
Public method | ZoomWindow(Boolean) | Creates a new instance of ZoomWindow specifying whether the zoom window uses a BitmapViewer or an ImageViewer.
Top
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow Constructor

Initializes a new instance of the ZoomWindow.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomWindow()
Public Sub New
See Also

Reference

ZoomWindow Class
ZoomWindow Overload
Atalasoft.Imaging.WinControls Namespace


ZoomWindow Constructor (Boolean)

Creates a new instance of ZoomWindow specifying whether the zoom window uses a BitmapViewer or an ImageViewer.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomWindow(
    bool bitmapStyle
)
Public Sub New (
    bitmapStyle As Boolean
)

Parameters

bitmapStyle
Type: SystemBoolean
Set to true if a BitmapViewer is used instead of an ImageViewer.
See Also

Reference

ZoomWindow Class
ZoomWindow Overload
Atalasoft.Imaging.WinControls Namespace


ZoomWindow Properties

The ZoomWindow type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | Gets or sets the background color of the window.
Public property | BackgroundImage | Gets or sets the background image of the window.
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CenterPoint | Gets or sets the center pixel of the image inside the ZoomWindow.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Image | Gets or sets the AtalaImage that is being displayed in this ZoomWindow.
Protected property | ImageView | Gets a reference to the ImageViewer control which is part of the ZoomWindow.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | Zoom | Gets or sets the zoom level of the image in this ZoomWindow.
Top
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.BackColor Property

ZoomWindowBackColor Property

Gets or sets the background color of the window.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color
The background color of the window.
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.BackgroundImage Property

ZoomWindowBackgroundImage Property

Gets or sets the background image of the window.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Image BackgroundImage { get; set; }
Public Property BackgroundImage As Image
    Get
    Set

Property Value

Type: Image
The background image of the window.
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.CenterPoint Property

ZoomWindowCenterPoint Property

Gets or sets the center pixel of the image inside the ZoomWindow.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point CenterPoint { get; set; }
Public Property CenterPoint As Point
    Get
    Set

Property Value

Type: Point
The center pixel of the image inside the ZoomWindow.
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.Image Property

ZoomWindowImage Property

Gets or sets the AtalaImage that is being displayed in this ZoomWindow.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Image { get; set; }
Public Property Image As Object
    Get
    Set

Property Value

Type: Object
The AtalaImage that is being displayed in this ZoomWindow.
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.ImageView Property

ZoomWindowImageView Property

Gets a reference to the ImageViewer control which is part of the ZoomWindow.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Viewport ImageView { get; }
Protected ReadOnly Property ImageView As Viewport
    Get

Property Value

Type: Viewport
A reference to the ImageViewer control which is part of the ZoomWindow.
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.Zoom Property

ZoomWindowZoom Property

Gets or sets the zoom level of the image in this ZoomWindow.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
The zoom level of the image in this ZoomWindow.
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow Methods

The ZoomWindow type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.Dispose Method

ZoomWindowDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


ZoomWindow.Dispose Method (Boolean)

ZoomWindowDispose Method (Boolean)

Clean up any resources being used.

Namespace: Atalasoft.Imaging.WinControls
Assembly: Atalasoft.dotImage.WinControls (in Atalasoft.dotImage.WinControls.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from the public Dispose method or from the finalizer.
See Also

Reference

ZoomWindow Class
Dispose Overload
Atalasoft.Imaging.WinControls Namespace


ZoomWindow Events

The ZoomWindow type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ZoomWindow Class
Atalasoft.Imaging.WinControls Namespace


Atalasoft.Imaging.Wpf Namespace

Classes
 | Class | Description
 | AtalaImageViewer | The AtalaImageViewer is an image viewer with automatic zooming and mouse tool capabilities. The viewer takes advantage of DotImage codecs to Open(String, Int32, ProgressEventHandler) and Save(String, ImageEncoder, ProgressEventHandler) images and image commands can be applied to the image using the ApplyCommand(ImageCommand) method. The viewer contains a Source property for a BitmapSource object, making its use in WPF straight forward.
Public class | AtalaObservableDictionaryTKey, TValue | Represents an observable collection of keys and values.
Public class | ImageChangedEventArgs | This class is used with the ImageEventHandler.
Public class | ImagePixelEventArgs | This class is used by the MouseMovePixel event.
 | MagnifierMouseTool | This tool is used to provide a magnified area of the image. Use this class by setting the AtalaViewer.MouseTool property to an instance of the MagnifierMouseTool class.
Public class | MouseTool | This is an abstract class from which all mouse tools must derive.
Public class | MouseWheelZoomEventArgs | Represents an event that files when a mouse wheel action results in a zoom in or zoom out.
 | PanningMouseTool | The PanningMouseTool is used give end-users the ability to drag an image around the viewport with the mouse.
 | SelectionMouseTool | The SelectionMouseTool provides the ability for end-users to select an area of the image for processing. The tool can be animated using the built-in animation feature or by providing custom animation. A masked selection feature is provided which (by default) will darken the image except for the selected area. This effect can be modified by setting the MaskedImageCommand property.
Public class | SelectionMouseToolChangedEventArgs | This class is used by the SelectionChanged and SelectionChanging events.
 | WpfConverter | This is a static class used to convert an AtalaImage to a BitmapSource and back.
 | ZoomMouseTool | This tool is used to zoom in and out of an image by either clicking a mouse button or selecting an area of the image which will be zoomed to fit in the viewer.
Enumerations
 | Enumeration | Description
Public enumeration | AspectRatioMode | Describes the action taken when the AspectRatio property of a SelectionMouseTool is used and the user drags one of the corner grips.
Public enumeration | AutoZoomMode | Describes the type of automatic zooming to perform on the image.
Public enumeration | MouseToolBehavior | Describes the way a selection is created by the user.
Public enumeration | MouseWheelMode | Defines how the mouse wheel will act in the control
Public enumeration | ResolutionScaleMode | Defines the scaling mode applied when an image has different X and Y resolution values.
Public enumeration | SelectionMouseToolType | Describes the type of selection that will be drawn.
Public enumeration | ZoomToolMode | Describes the action taken by a button press.


AspectRatioMode Enumeration

Describes the action taken when the AspectRatio property of a SelectionMouseTool is used and the user drags one of the corner grips.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AspectRatioMode
Public Enumeration AspectRatioMode
Members
Member name | Description
Adjust | The AspectRatio property is adjusted to the new ratio created by the user.
Reset | The AspectRatio property is reset to 0.
Prevent | The user is not allowed to drag the corners of the selection.
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer Class

The AtalaImageViewer is an image viewer with automatic zooming and mouse tool capabilities.

The viewer takes advantage of DotImage codecs to Open(String, Int32, ProgressEventHandler) and Save(String, ImageEncoder, ProgressEventHandler) images and image commands can be applied to the image using the ApplyCommand(ImageCommand) method. The viewer contains a Source property for a BitmapSource object, making its use in WPF straight forward.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsScrollViewer
Atalasoft.Imaging.WpfAtalaImageViewer

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaImageViewer : ScrollViewer
Public Class AtalaImageViewer
    Inherits ScrollViewer

The AtalaImageViewer type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaImageViewer | Creates a new instance of AtalaImageViewer.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoZoom | Gets or sets the automatic zooming performed on an image.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanContentScroll | Gets or sets a value that indicates whether elements that support the IScrollInfo interface are allowed to scroll. (Inherited from ScrollViewer.)
Public property | ClientSize | Returns the client size, excluding the scrollbars, of the viewer.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComputedHorizontalScrollBarVisibility | Gets a value that indicates whether the horizontal ScrollBar is visible. (Inherited from ScrollViewer.)
Public property | ComputedVerticalScrollBarVisibility | Gets a value that indicates whether the vertical ScrollBar is visible. (Inherited from ScrollViewer.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentHorizontalOffset | Gets the horizontal offset of the visible content. (Inherited from ScrollViewer.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContentVerticalOffset | Gets the vertical offset of the visible content. (Inherited from ScrollViewer.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from ScrollViewer.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from ScrollViewer.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates that a control has a ScrollViewer defined in its style that defines custom keyboard scrolling behavior. (Inherited from ScrollViewer.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from ScrollViewer.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed. (Inherited from ScrollViewer.)
Public property | Image | Gets or sets the AtalaImage used by the viewer.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCentered | Gets or sets a value indicating whether the image will be centered within the viewable area.
Public property | IsColorManaged | Get or set a value indicating if the control will automatically color correct images.
Public property | IsDeferredScrollingEnabled | Gets or sets a value that indicates whether the content is stationary when the user drags the Thumb of a ScrollBar. (Inherited from ScrollViewer.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
 | MouseTool | Gets or sets the mouse tool for the viewer.
Public property | MouseToolScrolling | Gets or sets a value indicating whether the viewer will automatically scroll when a mouse tool is being dragged outside of the viewable area.
Public property | MouseToolScrollingZoneLength | Gets or sets the number of pixels around the viewable area that will trigger the viewer to scroll when a mouse tool is being used.
Public property | MouseWheelMode | Gets or sets the mouse wheel mode.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device.
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PanningDeceleration | Gets or sets the rate ScrollViewer slows in device-independent units (1/96th inch per unit) per squared millisecond when in inertia. (Inherited from ScrollViewer.)
Public property | PanningMode | Gets or sets the way ScrollViewer reacts to touch manipulation. (Inherited from ScrollViewer.)
Public property | PanningRatio | Gets or sets the ratio of scrolling offset to translate manipulation offset. (Inherited from ScrollViewer.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images.
Public property | RenderedImageBounds | Gets the bounds of the image in viewer coordinates.
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResolutionScaleMode | Gets or sets the scale mode used when the image has different X and Y resolution values.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ScaledResolutionHeightFactor | Gets the scaling being applied to the image height due to differences in the X and Y resolution values.
Public property | ScrollableHeight | Gets a value that represents the vertical size of the content element that can be scrolled. (Inherited from ScrollViewer.)
Public property | ScrollableWidth | Gets a value that represents the horizontal size of the content element that can be scrolled. (Inherited from ScrollViewer.)
Protected property | ScrollInfo | Gets or sets the element that implements the IScrollInfo interface and provides values for scrolling properties of this ScrollViewer. (Inherited from ScrollViewer.)
Public property | ScrollPosition | Gets or sets the scrollbar positions.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source | Gets or sets the BitmapSource used by the viewer.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from ScrollViewer.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical ScrollBar should be displayed. (Inherited from ScrollViewer.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from ScrollViewer.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from ScrollViewer.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleImageRectangle | Gets the visible area of the image in image coordinates.
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Zoom | Gets or sets the zoom level applied to the image.
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
 | ApplyCommand | Applies a command to the current image.
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of the ScrollViewer. (Inherited from ScrollViewer.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
 | CenterInViewer(Point) | Scrolls the image to center a pixel within the viewer (if possible).
Public method | CenterInViewer(Rect, Boolean) | Centers a rectangle, optionally changing the zoom level to fit the rectangle within the viewer.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Performs a hit test to determine whether the specified points are within the bounds of this ScrollViewer. (Inherited from ScrollViewer.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateScrollInfo | Called by an IScrollInfo interface that is attached to a ScrollViewer when the value of any scrolling property size changes. Scrolling properties include offset, extent, or viewport. (Inherited from ScrollViewer.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the ScrollViewer content downward by one line. (Inherited from ScrollViewer.)
Public method | LineLeft | Scrolls the ScrollViewer content to the left by a predetermined amount. (Inherited from ScrollViewer.)
Public method | LineRight | Scrolls the ScrollViewer content to the right by a predetermined amount. (Inherited from ScrollViewer.)
Public method | LineUp | Scrolls the ScrollViewer content upward by one line. (Inherited from ScrollViewer.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the content of the control. (Overrides ScrollViewerMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Called when a template is applied to the control. (Overrides ScrollViewerOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when child elements of the control are resized. (Overrides UIElementOnChildDesiredSizeChanged(UIElement).)
Protected method | OnClientSizeChanged | Called when the ClientSize property value has changed and raises the ClientSizeChanged event.
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate AutomationPeer implementation for this control, as part of the Windows Presentation Foundation (WPF) automation infrastructure. (Inherited from ScrollViewer.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnImageChanged | Called when the Image property has been changed or a command is applied to the image.
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Responds to specific keyboard input and invokes associated scrolling behavior. (Inherited from ScrollViewer.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from ScrollViewer.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from ScrollViewer.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from ScrollViewer.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Called when the ManipulationStarting event occurs. (Inherited from ScrollViewer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button is pressed on the control. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Responds to a click of the left mouse button. (Inherited from ScrollViewer.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when the mouse is moved over the conrol. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Called when a mouse button is released over the control. (Overrides UIElementOnMouseUp(MouseButtonEventArgs).)
Protected method | OnMouseWheel | Responds to a click of the mouse wheel. (Overrides ScrollViewerOnMouseWheel(MouseWheelEventArgs).)
Protected method | OnMouseWheelZoom | Raises the MouseWheelZoom event.
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the size of the control changes. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Overrides ScrollViewerOnScrollChanged(ScrollChangedEventArgs).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | Open(Stream, Int32, ProgressEventHandler) | Opens an image from a stream.
Public method | Open(String, Int32, ProgressEventHandler) | Opens an image from a filename.
Public method | PageDown | Scrolls the ScrollViewer content downward by one page. (Inherited from ScrollViewer.)
Public method | PageLeft | Scrolls the ScrollViewer content to the left by one page. (Inherited from ScrollViewer.)
Public method | PageRight | Scrolls the ScrollViewer content to the right by one page. (Inherited from ScrollViewer.)
Public method | PageUp | Scrolls the ScrollViewer content upward by one page. (Inherited from ScrollViewer.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
 | PointFromImage | This method converts an image pixel position to viewer coordinate space.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToImage | This method returns the image pixel position at the specified viewer coordinate.
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves the image into a stream using the provided encoder.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves the image to a file using the provided encoder.
 | ScrollImagePixel | Scrolls an image pixel to the specified viewer coordinates.
 | ScrollIntoView | Scrolls an image pixel into view if it is not currently within the viewable area.
Public method | ScrollToBottom | Scrolls vertically to the end of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToEnd | Scrolls vertically to the end of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToHome | Scrolls vertically to the beginning of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToHorizontalOffset | Scrolls the content within the ScrollViewer to the specified horizontal offset position. (Inherited from ScrollViewer.)
Public method | ScrollToLeftEnd | Scrolls horizontally to the beginning of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToRightEnd | Scrolls horizontally to the end of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToTop | Scrolls vertically to the beginning of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToVerticalOffset | Scrolls the content within the ScrollViewer to the specified vertical offset position. (Inherited from ScrollViewer.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ClientSizeChanged | Raised when the ClientSize property is changed.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | ImageChanged | Raised when the Image property or the image data has been changed.
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsCenteredChanged | Occurs when the centered setting changed.
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseMovePixel | Raised when the mouse is moved over an image pixel.
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseWheelZoom | Occurs when the mouse wheel changes the zoom.
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | ScrollChanged | Occurs when changes are detected to the scroll position, extent, or viewport size. (Inherited from ScrollViewer.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ZoomChanged | Occurs when the zoom has changed.
Top
Fields
Name | Description
AutoZoomProperty | Identifies the AutoZoom dependency property.
ClientSizeChangedEvent | Identifies the ClientSizeChanged event.
DisplayProfileProperty | Identifies the DisplayProfile dependency property.
ImageChangedEvent | Identifies the ImageChanged routed event.
IsCenteredChangedEvent | Identifies the IsCenteredChanged event.
IsCenteredProperty | Identifies the IsCentered dependency property.
IsColorManagedProperty | Identifies the IsColorManaged dependency property.
MouseMovePixelEvent | Identifies the MouseMovePixel routed event.
MouseToolProperty | Identifies the MouseTool dependency property.
MouseToolScrollingProperty | Identifies the MouseToolScrolling dependency property.
MouseToolScrollingZoneLengthProperty | Identifies the MouseToolScrollingZoneLength dependency property.
MouseWheelModeProperty | Identifies the MouseWheelMode dependency property.
MouseWheelZoomEvent | Identifies the MouseWheelZoom event.
OutputProfileProperty | Identifies the OutputProfile dependency property.
ProofIntentProperty | Identifies the ProofIntent dependency property.
RenderingIntentProperty | Identifies the RenderingIntent dependency property.
ResolutionScaleModeProperty | Identifies the ResolutionScaleMode dependency property.
SourceProperty | Identifies the Source dependency property.
ZoomChangedEvent | Identifies the ZoomChanged event.
ZoomProperty | Identifies the Zoom dependency property.
Top
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:mc="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <Grid.ColumnDefinitions>
      <ColumnDefinition/>
    </Grid.ColumnDefinitions>
    <Grid.RowDefinitions>
      <RowDefinition Height="22"/>
      <RowDefinition/>
      <RowDefinition Height="22"/>
    </Grid.RowDefinitions>
    <Menu Grid.Column="0" Grid.Row="0">
      <MenuItem Header="_File">
        <MenuItem Header="_Open" Click="OnOpenFile"/>
        <MenuItem Header="_Save" Click="OnSaveFile"/>
        <Separator/>
        <MenuItem Header="E_xit" Click="OnExit"/>
      </MenuItem>
    </Menu>
    <mc:AtalaImageViewer Name="Viewer" Grid.Column="0" Grid.Row="1" ImageChanged="OnImageChanged" MouseMovePixel="OnViewerMouseMove">
      <mc:AtalaImageViewer.MouseTool>
        <mc:SelectionMouseTool SelectionChanged="MySelectionChanged"/>
      </mc:AtalaImageViewer.MouseTool>
    </mc:AtalaImageViewer>
    <StatusBar Name="statusBar1" Grid.Column="0" Grid.Row="2" VerticalAlignment="Bottom">
      <StatusBarItem>
        <TextBlock Name="statusInfo"></TextBlock>
      </StatusBarItem>
    </StatusBar>
  </Grid>
</Window>
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer Constructor

Creates a new instance of AtalaImageViewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImageViewer()
Public Sub New
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer Properties

The AtalaImageViewer type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoZoom | Gets or sets the automatic zooming performed on an image.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanContentScroll | Gets or sets a value that indicates whether elements that support the IScrollInfo interface are allowed to scroll. (Inherited from ScrollViewer.)
Public property | ClientSize | Returns the client size, excluding the scrollbars, of the viewer.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComputedHorizontalScrollBarVisibility | Gets a value that indicates whether the horizontal ScrollBar is visible. (Inherited from ScrollViewer.)
Public property | ComputedVerticalScrollBarVisibility | Gets a value that indicates whether the vertical ScrollBar is visible. (Inherited from ScrollViewer.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentHorizontalOffset | Gets the horizontal offset of the visible content. (Inherited from ScrollViewer.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContentVerticalOffset | Gets the vertical offset of the visible content. (Inherited from ScrollViewer.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayProfile | Gets or sets the ColorProfile of the display device.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from ScrollViewer.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from ScrollViewer.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates that a control has a ScrollViewer defined in its style that defines custom keyboard scrolling behavior. (Inherited from ScrollViewer.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from ScrollViewer.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed. (Inherited from ScrollViewer.)
Public property | Image | Gets or sets the AtalaImage used by the viewer.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCentered | Gets or sets a value indicating whether the image will be centered within the viewable area.
Public property | IsColorManaged | Get or set a value indicating if the control will automatically color correct images.
Public property | IsDeferredScrollingEnabled | Gets or sets a value that indicates whether the content is stationary when the user drags the Thumb of a ScrollBar. (Inherited from ScrollViewer.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
 | MouseTool | Gets or sets the mouse tool for the viewer.
Public property | MouseToolScrolling | Gets or sets a value indicating whether the viewer will automatically scroll when a mouse tool is being dragged outside of the viewable area.
Public property | MouseToolScrollingZoneLength | Gets or sets the number of pixels around the viewable area that will trigger the viewer to scroll when a mouse tool is being used.
Public property | MouseWheelMode | Gets or sets the mouse wheel mode.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OutputProfile | Gets or sets the color profile used for proofing images to a target device.
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PanningDeceleration | Gets or sets the rate ScrollViewer slows in device-independent units (1/96th inch per unit) per squared millisecond when in inertia. (Inherited from ScrollViewer.)
Public property | PanningMode | Gets or sets the way ScrollViewer reacts to touch manipulation. (Inherited from ScrollViewer.)
Public property | PanningRatio | Gets or sets the ratio of scrolling offset to translate manipulation offset. (Inherited from ScrollViewer.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProofIntent | Gets or sets the rendering intent of the color transform used when proofing images.
Public property | RenderedImageBounds | Gets the bounds of the image in viewer coordinates.
Public property | RenderingIntent | Gets or sets the rendering intent when transforming colors to the display device.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResolutionScaleMode | Gets or sets the scale mode used when the image has different X and Y resolution values.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ScaledResolutionHeightFactor | Gets the scaling being applied to the image height due to differences in the X and Y resolution values.
Public property | ScrollableHeight | Gets a value that represents the vertical size of the content element that can be scrolled. (Inherited from ScrollViewer.)
Public property | ScrollableWidth | Gets a value that represents the horizontal size of the content element that can be scrolled. (Inherited from ScrollViewer.)
Protected property | ScrollInfo | Gets or sets the element that implements the IScrollInfo interface and provides values for scrolling properties of this ScrollViewer. (Inherited from ScrollViewer.)
Public property | ScrollPosition | Gets or sets the scrollbar positions.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source | Gets or sets the BitmapSource used by the viewer.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from ScrollViewer.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical ScrollBar should be displayed. (Inherited from ScrollViewer.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from ScrollViewer.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from ScrollViewer.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleImageRectangle | Gets the visible area of the image in image coordinates.
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Zoom | Gets or sets the zoom level applied to the image.
Top
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.AutoZoom Property

AtalaImageViewerAutoZoom Property

Gets or sets the automatic zooming performed on an image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoZoomMode AutoZoom { get; set; }
Public Property AutoZoom As AutoZoomMode
    Get
    Set

Property Value

Type: AutoZoomMode
The automatic zooming performed on the image.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ClientSize Property

AtalaImageViewerClientSize Property

Returns the client size, excluding the scrollbars, of the viewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size ClientSize { get; }
Public ReadOnly Property ClientSize As Size
    Get

Property Value

Type: Size
The client size of the viewer.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.DisplayProfile Property

AtalaImageViewerDisplayProfile Property

Gets or sets the ColorProfile of the display device.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile DisplayProfile { get; set; }
Public Property DisplayProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
The ColorProfile of the display device.
Remarks
Uses the color profile associated with the current display by default. If no profile is associated with it, the sRGB profile is used.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Image Property

AtalaImageViewerImage Property

Gets or sets the AtalaImage used by the viewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage used by the viewer.
Remarks
When this property is changed, the Source property will also be updated to a new BitmapSource.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.IsCentered Property

AtalaImageViewerIsCentered Property

Gets or sets a value indicating whether the image will be centered within the viewable area.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCentered { get; set; }
Public Property IsCentered As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the image will be centered.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.IsColorManaged Property

AtalaImageViewerIsColorManaged Property

Get or set a value indicating if the control will automatically color correct images.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsColorManaged { get; set; }
Public Property IsColorManaged As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the control will automatically color correct images.
Remarks
When true, the control uses the DisplayProfile and the ColorProfile of the image to display to transform the colors to the display's colorspace. If the OutputProfile is not null, then the image will be proofed to the OutputProfile.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseTool Property

AtalaImageViewerMouseTool Property

Gets or sets the mouse tool for the viewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseTool MouseTool { get; set; }
Public Property MouseTool As MouseTool
    Get
    Set

Property Value

Type: MouseTool
The mouse tool for the viewer.
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:atala="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <atala:AtalaImageViewer Name="Viewer">
      <atala:AtalaImageViewer.MouseTool>
        <atala:MagnifierMouseTool Size="120,120" Magnification="2.0">
          <atala:MagnifierMouseTool.Pen>
            <Pen Thickness="1">
              <Pen.Brush>
                <SolidColorBrush Color="Black"/>
              </Pen.Brush>
            </Pen>
          </atala:MagnifierMouseTool.Pen>
        </atala:MagnifierMouseTool>
      </atala:AtalaImageViewer.MouseTool>
    </atala:AtalaImageViewer>
  </Grid>
</Window>
Copy
Me.Viewer.MouseTool = New MagnifierMouseTool(New Size(120, 120), 2, New Pen(New SolidColorBrush(Colors.Black), 1))
Copy
this.Viewer.MouseTool = new MagnifierMouseTool(new Size(120, 120), 2, new Pen(new SolidColorBrush(Colors.Black), 1));
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseToolScrolling Property

AtalaImageViewerMouseToolScrolling Property

Gets or sets a value indicating whether the viewer will automatically scroll when a mouse tool is being dragged outside of the viewable area.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MouseToolScrolling { get; set; }
Public Property MouseToolScrolling As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the viewer will scroll during mouse tool usage.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseToolScrollingZoneLength Property

AtalaImageViewerMouseToolScrollingZoneLength Property

Gets or sets the number of pixels around the viewable area that will trigger the viewer to scroll when a mouse tool is being used.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MouseToolScrollingZoneLength { get; set; }
Public Property MouseToolScrollingZoneLength As Double
    Get
    Set

Property Value

Type: Double
The number of pixels around the viewable area that will trigger scrolling.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseWheelMode Property

AtalaImageViewerMouseWheelMode Property

Gets or sets the mouse wheel mode.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseWheelMode MouseWheelMode { get; set; }
Public Property MouseWheelMode As MouseWheelMode
    Get
    Set

Property Value

Type: MouseWheelMode
The mouse wheel mode.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OutputProfile Property

AtalaImageViewerOutputProfile Property

Gets or sets the color profile used for proofing images to a target device.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorProfile OutputProfile { get; set; }
Public Property OutputProfile As ColorProfile
    Get
    Set

Property Value

Type: ColorProfile
The color profile used for proofing images to a target device.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ProofIntent Property

AtalaImageViewerProofIntent Property

Gets or sets the rendering intent of the color transform used when proofing images.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent ProofIntent { get; set; }
Public Property ProofIntent As RenderingIntent
    Get
    Set

Property Value

Type: RenderingIntent
The rendering intent of the color transform used when proofing images.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.RenderedImageBounds Property

AtalaImageViewerRenderedImageBounds Property

Gets the bounds of the image in viewer coordinates.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect RenderedImageBounds { get; }
Public ReadOnly Property RenderedImageBounds As Rect
    Get

Property Value

Type: Rect
The bounds of the image in viewer coordinates.
Remarks
This property takes the ScrollPosition and Zoom into account when calculating the bounds.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.RenderingIntent Property

AtalaImageViewerRenderingIntent Property

Gets or sets the rendering intent when transforming colors to the display device.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderingIntent RenderingIntent { get; set; }
Public Property RenderingIntent As RenderingIntent
    Get
    Set

Property Value

Type: RenderingIntent
The rendering intent when transforming colors to the display device.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ResolutionScaleMode Property

AtalaImageViewerResolutionScaleMode Property

Gets or sets the scale mode used when the image has different X and Y resolution values.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ResolutionScaleMode ResolutionScaleMode { get; set; }
Public Property ResolutionScaleMode As ResolutionScaleMode
    Get
    Set

Property Value

Type: ResolutionScaleMode
the scale mode used when the image has different X and Y resolution values.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ScaledResolutionHeightFactor Property

AtalaImageViewerScaledResolutionHeightFactor Property

Gets the scaling being applied to the image height due to differences in the X and Y resolution values.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ScaledResolutionHeightFactor { get; }
Public ReadOnly Property ScaledResolutionHeightFactor As Double
    Get

Property Value

Type: Double
The scaling being applied to the image height due to differences in the X and Y resolution values.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ScrollPosition Property

AtalaImageViewerScrollPosition Property

Gets or sets the scrollbar positions.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point ScrollPosition { get; set; }
Public Property ScrollPosition As Point
    Get
    Set

Property Value

Type: Point
The scrollbar positions.
Remarks
These values must be greater than or equal to zero.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Source Property

AtalaImageViewerSource Property

Gets or sets the BitmapSource used by the viewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapSource Source { get; set; }
Public Property Source As BitmapSource
    Get
    Set

Property Value

Type: BitmapSource
The BitmapSource for the viewer.
Remarks
Setting this property changes the AtalaImage used by the viewer.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.VisibleImageRectangle Property

AtalaImageViewerVisibleImageRectangle Property

Gets the visible area of the image in image coordinates.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect VisibleImageRectangle { get; }
Public ReadOnly Property VisibleImageRectangle As Rect
    Get

Property Value

Type: Rect
The visible area of the image.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Zoom Property

AtalaImageViewerZoom Property

Gets or sets the zoom level applied to the image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
The zoom level applied to the image.
Exceptions
Exception | Condition
 | Thrown if the value is less than or equal to zero.
Remarks
A zoom value of 1.0 will display the image at normal size. Values greater than zero but less than 1.0 will reduce the size and values larger than 1.0 will increase the size.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer Methods

The AtalaImageViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
 | ApplyCommand | Applies a command to the current image.
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of the ScrollViewer. (Inherited from ScrollViewer.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
 | CenterInViewer(Point) | Scrolls the image to center a pixel within the viewer (if possible).
Public method | CenterInViewer(Rect, Boolean) | Centers a rectangle, optionally changing the zoom level to fit the rectangle within the viewer.
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Performs a hit test to determine whether the specified points are within the bounds of this ScrollViewer. (Inherited from ScrollViewer.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateScrollInfo | Called by an IScrollInfo interface that is attached to a ScrollViewer when the value of any scrolling property size changes. Scrolling properties include offset, extent, or viewport. (Inherited from ScrollViewer.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the ScrollViewer content downward by one line. (Inherited from ScrollViewer.)
Public method | LineLeft | Scrolls the ScrollViewer content to the left by a predetermined amount. (Inherited from ScrollViewer.)
Public method | LineRight | Scrolls the ScrollViewer content to the right by a predetermined amount. (Inherited from ScrollViewer.)
Public method | LineUp | Scrolls the ScrollViewer content upward by one line. (Inherited from ScrollViewer.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the content of the control. (Overrides ScrollViewerMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Called when a template is applied to the control. (Overrides ScrollViewerOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when child elements of the control are resized. (Overrides UIElementOnChildDesiredSizeChanged(UIElement).)
Protected method | OnClientSizeChanged | Called when the ClientSize property value has changed and raises the ClientSizeChanged event.
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate AutomationPeer implementation for this control, as part of the Windows Presentation Foundation (WPF) automation infrastructure. (Inherited from ScrollViewer.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnImageChanged | Called when the Image property has been changed or a command is applied to the image.
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Responds to specific keyboard input and invokes associated scrolling behavior. (Inherited from ScrollViewer.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from ScrollViewer.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from ScrollViewer.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from ScrollViewer.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Called when the ManipulationStarting event occurs. (Inherited from ScrollViewer.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Called when a mouse button is pressed on the control. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Responds to a click of the left mouse button. (Inherited from ScrollViewer.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when the mouse is moved over the conrol. (Overrides UIElementOnMouseMove(MouseEventArgs).)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Called when a mouse button is released over the control. (Overrides UIElementOnMouseUp(MouseButtonEventArgs).)
Protected method | OnMouseWheel | Responds to a click of the mouse wheel. (Overrides ScrollViewerOnMouseWheel(MouseWheelEventArgs).)
Protected method | OnMouseWheelZoom | Raises the MouseWheelZoom event.
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the size of the control changes. (Overrides FrameworkElementOnRenderSizeChanged(SizeChangedInfo).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Overrides ScrollViewerOnScrollChanged(ScrollChangedEventArgs).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | Open(Stream, Int32, ProgressEventHandler) | Opens an image from a stream.
Public method | Open(String, Int32, ProgressEventHandler) | Opens an image from a filename.
Public method | PageDown | Scrolls the ScrollViewer content downward by one page. (Inherited from ScrollViewer.)
Public method | PageLeft | Scrolls the ScrollViewer content to the left by one page. (Inherited from ScrollViewer.)
Public method | PageRight | Scrolls the ScrollViewer content to the right by one page. (Inherited from ScrollViewer.)
Public method | PageUp | Scrolls the ScrollViewer content upward by one page. (Inherited from ScrollViewer.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
 | PointFromImage | This method converts an image pixel position to viewer coordinate space.
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToImage | This method returns the image pixel position at the specified viewer coordinate.
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
 | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves the image into a stream using the provided encoder.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves the image to a file using the provided encoder.
 | ScrollImagePixel | Scrolls an image pixel to the specified viewer coordinates.
 | ScrollIntoView | Scrolls an image pixel into view if it is not currently within the viewable area.
Public method | ScrollToBottom | Scrolls vertically to the end of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToEnd | Scrolls vertically to the end of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToHome | Scrolls vertically to the beginning of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToHorizontalOffset | Scrolls the content within the ScrollViewer to the specified horizontal offset position. (Inherited from ScrollViewer.)
Public method | ScrollToLeftEnd | Scrolls horizontally to the beginning of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToRightEnd | Scrolls horizontally to the end of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToTop | Scrolls vertically to the beginning of the ScrollViewer content. (Inherited from ScrollViewer.)
Public method | ScrollToVerticalOffset | Scrolls the content within the ScrollViewer to the specified vertical offset position. (Inherited from ScrollViewer.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ApplyCommand Method

AtalaImageViewerApplyCommand Method

Applies a command to the current image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ApplyCommand(
    ImageCommand command
)
Public Sub ApplyCommand (
    command As ImageCommand
)

Parameters

command
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The image command to apply.
Exceptions
Exception | Condition
 | Thrown if the command argument is null (Nothing in VB).
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.CenterInViewer Method

AtalaImageViewerCenterInViewer Method

These methods will attempt to scroll a pixel or rectangular area to the center of the viewer.
Examples
Copy
 ' Add an event handler for the MouseUp event.
Private Me.Viewer.MouseUp += New MouseButtonEventHandler(AddressOf Viewer_MouseUp)

'...

Sub Viewer_MouseUp(ByVal sender As Object, ByVal e As MouseButtonEventArgs)
    If Me.Viewer.Image Is Nothing Then
        Return
    End If

    Dim pt As Point = Me.Viewer.PointToImage(e.GetPosition(Me.Viewer))
    Me.Viewer.CenterInViewer(pt)
End Sub
Copy
 // Add an event handler for the MouseUp event.
this.Viewer.MouseUp += new MouseButtonEventHandler(Viewer_MouseUp);

//...

void Viewer_MouseUp(object sender, MouseButtonEventArgs e)
{
    if (this.Viewer.Image == null) return;

    Point pt = this.Viewer.PointToImage(e.GetPosition(this.Viewer));
    this.Viewer.CenterInViewer(pt);
}
Overload List
 | Name | Description
 | CenterInViewer(Point) | Scrolls the image to center a pixel within the viewer (if possible).
Public method | CenterInViewer(Rect, Boolean) | Centers a rectangle, optionally changing the zoom level to fit the rectangle within the viewer.
Top
Examples
Copy
 ' Add an event handler for the MouseUp event.
Private Me.Viewer.MouseUp += New MouseButtonEventHandler(AddressOf Viewer_MouseUp)

'...

Sub Viewer_MouseUp(ByVal sender As Object, ByVal e As MouseButtonEventArgs)
    If Me.Viewer.Image Is Nothing Then
        Return
    End If

    Dim pt As Point = Me.Viewer.PointToImage(e.GetPosition(Me.Viewer))
    Me.Viewer.CenterInViewer(pt)
End Sub
Copy
 // Add an event handler for the MouseUp event.
this.Viewer.MouseUp += new MouseButtonEventHandler(Viewer_MouseUp);

//...

void Viewer_MouseUp(object sender, MouseButtonEventArgs e)
{
    if (this.Viewer.Image == null) return;

    Point pt = this.Viewer.PointToImage(e.GetPosition(this.Viewer));
    this.Viewer.CenterInViewer(pt);
}
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.CenterInViewer Method (Point)

AtalaImageViewerCenterInViewer Method (Point)

Scrolls the image to center a pixel within the viewer (if possible).

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CenterInViewer(
    Point imagePixel
)
Public Sub CenterInViewer (
    imagePixel As Point
)

Parameters

imagePixel
Type: System.WindowsPoint
The pixel to center.
Remarks
The pixel provided cannot always be centered in the viewer. For example, passing in point {0, 0} will show that pixel at the top left corner of the viewer because the image cannot be scrolled past this point.
See Also

Reference

AtalaImageViewer Class
CenterInViewer Overload
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.CenterInViewer Method (Rect, Boolean)

AtalaImageViewerCenterInViewer Method (Rect, Boolean)

Centers a rectangle, optionally changing the zoom level to fit the rectangle within the viewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CenterInViewer(
    Rect imageRect,
    bool zoomToFit
)
Public Sub CenterInViewer (
    imageRect As Rect,
    zoomToFit As Boolean
)

Parameters

imageRect
Type: System.WindowsRect
The rectangle to center.
zoomToFit
Type: SystemBoolean
If true, the zoom level will be modified to fit the entire rectangle within the viewer. Setting this to false may not show the entire rectangular area within the viewer.
See Also

Reference

AtalaImageViewer Class
CenterInViewer Overload
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MeasureOverride Method

AtalaImageViewerMeasureOverride Method

Measures the content of the control.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size constraint
)
Protected Overrides Function MeasureOverride (
    constraint As Size
) As Size

Parameters

constraint
Type: System.WindowsSize
The size constraint placed on the control.

Return Value

Type: Size
The size of the control content.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnApplyTemplate Method

AtalaImageViewerOnApplyTemplate Method

Called when a template is applied to the control.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void OnApplyTemplate()
Public Overrides Sub OnApplyTemplate
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnChildDesiredSizeChanged Method

AtalaImageViewerOnChildDesiredSizeChanged Method

Supports layout behavior when child elements of the control are resized.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnChildDesiredSizeChanged(
    UIElement child
)
Protected Overrides Sub OnChildDesiredSizeChanged (
    child As UIElement
)

Parameters

child
Type: System.WindowsUIElement
The child element.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnClientSizeChanged Method

AtalaImageViewerOnClientSizeChanged Method

Called when the ClientSize property value has changed and raises the ClientSizeChanged event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnClientSizeChanged()
Protected Overridable Sub OnClientSizeChanged
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnImageChanged Method

AtalaImageViewerOnImageChanged Method

Called when the Image property has been changed or a command is applied to the image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageChanged(
    ImageChangedEventArgs e
)
Protected Overridable Sub OnImageChanged (
    e As ImageChangedEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WpfImageChangedEventArgs
An ImageChangedEventArgs for this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnMouseDown Method

AtalaImageViewerOnMouseDown Method

Called when a mouse button is pressed on the control.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnMouseMove Method

AtalaImageViewerOnMouseMove Method

Called when the mouse is moved over the conrol.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs for this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnMouseUp Method

AtalaImageViewerOnMouseUp Method

Called when a mouse button is released over the control.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs for this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnMouseWheel Method

AtalaImageViewerOnMouseWheel Method

Responds to a click of the mouse wheel.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseWheel(
    MouseWheelEventArgs e
)
Protected Overrides Sub OnMouseWheel (
    e As MouseWheelEventArgs
)

Parameters

e
Type: System.Windows.InputMouseWheelEventArgs
Required arguments that describe this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnMouseWheelZoom Method

AtalaImageViewerOnMouseWheelZoom Method

Raises the MouseWheelZoom event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseWheelZoom(
    MouseWheelZoomEventArgs e
)
Protected Overridable Sub OnMouseWheelZoom (
    e As MouseWheelZoomEventArgs
)

Parameters

e
Type: Atalasoft.Imaging.WpfMouseWheelZoomEventArgs
The MouseWheelZoomEventArgs instance containing the event data.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnRenderSizeChanged Method

AtalaImageViewerOnRenderSizeChanged Method

Called when the size of the control changes.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRenderSizeChanged(
    SizeChangedInfo info
)
Protected Overrides Sub OnRenderSizeChanged (
    info As SizeChangedInfo
)

Parameters

info
Type: System.WindowsSizeChangedInfo
A SizeChangedInfo containing information about this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OnScrollChanged Method

AtalaImageViewerOnScrollChanged Method

Called when the scroll position has changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnScrollChanged(
    ScrollChangedEventArgs e
)
Protected Overrides Sub OnScrollChanged (
    e As ScrollChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsScrollChangedEventArgs
A ScrollChangedEventArgs containing information for this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Open Method

AtalaImageViewerOpen Method

Opens an image into the viewer from a filename or stream.
Overload List
 | Name | Description
Public method | Open(Stream, Int32, ProgressEventHandler) | Opens an image from a stream.
Public method | Open(String, Int32, ProgressEventHandler) | Opens an image from a filename.
Top
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Open Method (Stream, Int32, ProgressEventHandler)

AtalaImageViewerOpen Method (Stream, Int32, ProgressEventHandler)

Opens an image from a stream.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    Stream stream,
    int frameIndex,
    ProgressEventHandler progress
)
Public Sub Open (
    stream As Stream,
    frameIndex As Integer,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
The stream containing the image file.
frameIndex
Type: SystemInt32
The frame index to open. This value must be zero or greater.
progress
Type: Atalasoft.ImagingProgressEventHandler
A ProgressEventHandler used to raise progress during the decoding process. This can be null (Nothing in VB).
Exceptions
Exception | Condition
 | Thrown if the stream is null (Nothing in VB).
 | Thrown if the frameIndex argument is invalid.
See Also

Reference

AtalaImageViewer Class
Open Overload
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Open Method (String, Int32, ProgressEventHandler)

AtalaImageViewerOpen Method (String, Int32, ProgressEventHandler)

Opens an image from a filename.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open(
    string fileName,
    int frameIndex,
    ProgressEventHandler progress
)
Public Sub Open (
    fileName As String,
    frameIndex As Integer,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The filename of the image to open.
frameIndex
Type: SystemInt32
The frame index to open. This value must be zero or greater.
progress
Type: Atalasoft.ImagingProgressEventHandler
A ProgressEventHandler used to raise progress during the decoding process. This can be null (Nothing in VB).
Exceptions
Exception | Condition
 | Thrown if the fileName argument is null (Nothing in VB).
 | Thrown if the fileName cannot be found.
 | Thrown if the frameIndex argument is invalid.
See Also

Reference

AtalaImageViewer Class
Open Overload
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.PointFromImage Method

AtalaImageViewerPointFromImage Method

This method converts an image pixel position to viewer coordinate space.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point PointFromImage(
    Point imagePoint
)
Public Function PointFromImage (
    imagePoint As Point
) As Point

Parameters

imagePoint
Type: System.WindowsPoint
The image pixel to convert.

Return Value

Type: Point
A point containing the viewer position.
Remarks
This method performs a simple conversion of the point and does not validate the position. This could result in return values that are outside of the viewable area.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.PointToImage Method

AtalaImageViewerPointToImage Method

This method returns the image pixel position at the specified viewer coordinate.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point PointToImage(
    Point clientPoint
)
Public Function PointToImage (
    clientPoint As Point
) As Point

Parameters

clientPoint
Type: System.WindowsPoint
The viewer coordinate to convert.

Return Value

Type: Point
The image pixel at the specified coordinate.
Remarks
This method performs a simple conversion of the point and does not validate the position. This could result in return values that are outside of the image area.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Save Method

AtalaImageViewerSave Method

Saves the image to a file or stream using the provided Atalasoft.Imaging.Codec.ImageEncoder.
Overload List
 | Name | Description
 | Save(Stream, ImageEncoder, ProgressEventHandler) | Saves the image into a stream using the provided encoder.
Public method | Save(String, ImageEncoder, ProgressEventHandler) | Saves the image to a file using the provided encoder.
Top
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Save Method (Stream, ImageEncoder, ProgressEventHandler)

AtalaImageViewerSave Method (Stream, ImageEncoder, ProgressEventHandler)

Saves the image into a stream using the provided encoder.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stream,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Sub Save (
    stream As Stream,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
)

Parameters

stream
Type: System.IOStream
A stream where the image will be saved.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use when saving the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
A ProgressEventHandler used to provide progress during the save process. This can be null (Nothing in VB).
Exceptions
Exception | Condition
 | Thrown if the stream or encoder argument is null (Nothing in VB).
Examples
Copy
 Private Sub OnSaveFile(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Dim dlg As Microsoft.Win32.SaveFileDialog = New Microsoft.Win32.SaveFileDialog()
    dlg.Filter = "PNG|*.png|HD Photo|*.wdp"
    If dlg.ShowDialog().Value Then
        Using fs As FileStream = New FileStream(dlg.FileName, FileMode.Create, FileAccess.Write)
            If dlg.FilterIndex = 1 Then
                Me.Viewer.Save(fs, New Atalasoft.Imaging.Codec.PngEncoder(), Nothing)
            Else
                Me.Viewer.Save(fs, New Atalasoft.Imaging.Codec.JpegXrEncoder(), Nothing)
            End If
        End Using
    End If
End Sub
Copy
 private void OnSaveFile(object sender, RoutedEventArgs e)
{
    Microsoft.Win32.SaveFileDialog dlg = new Microsoft.Win32.SaveFileDialog();
    dlg.Filter = "PNG|*.png|HD Photo|*.wdp";
    if (dlg.ShowDialog().Value)
    {
        using (FileStream fs = new FileStream(dlg.FileName, FileMode.Create, FileAccess.Write))
        {
            if (dlg.FilterIndex == 1)
                this.Viewer.Save(fs, new Atalasoft.Imaging.Codec.PngEncoder(), null);
            else
                this.Viewer.Save(fs, new Atalasoft.Imaging.Codec.JpegXrEncoder(), null);
        }
    }
}
See Also

Reference

AtalaImageViewer Class
Save Overload
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.Save Method (String, ImageEncoder, ProgressEventHandler)

AtalaImageViewerSave Method (String, ImageEncoder, ProgressEventHandler)

Saves the image to a file using the provided encoder.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string fileName,
    ImageEncoder encoder,
    ProgressEventHandler progress
)
Public Sub Save (
    fileName As String,
    encoder As ImageEncoder,
    progress As ProgressEventHandler
)

Parameters

fileName
Type: SystemString
The filename for the new image. If the file already exists, it will be overwritten.
encoder
Type: Atalasoft.Imaging.CodecImageEncoder
The ImageEncoder to use when saving the image.
progress
Type: Atalasoft.ImagingProgressEventHandler
A ProgressEventHandler used to provide progress during the save process. This can be null (Nothing in VB).
Exceptions
Exception | Condition
 | Thrown if the encoder is null (Nothing in VB).
See Also

Reference

AtalaImageViewer Class
Save Overload
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ScrollImagePixel Method

AtalaImageViewerScrollImagePixel Method

Scrolls an image pixel to the specified viewer coordinates.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ScrollImagePixel(
    Point imagePixel,
    Point clientPoint
)
Public Sub ScrollImagePixel (
    imagePixel As Point,
    clientPoint As Point
)

Parameters

imagePixel
Type: System.WindowsPoint
The image pixel to move.
clientPoint
Type: System.WindowsPoint
The position on the viewer where the pixel should be placed.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ScrollIntoView Method

AtalaImageViewerScrollIntoView Method

Scrolls an image pixel into view if it is not currently within the viewable area.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ScrollIntoView(
    Point imagePixel,
    double padding
)
Public Sub ScrollIntoView (
    imagePixel As Point,
    padding As Double
)

Parameters

imagePixel
Type: System.WindowsPoint
The image pixel to bring into view.
padding
Type: SystemDouble
The number of pixels around the viewable area that will trigger a scroll. If the image pixel is within the viewable area but falls within this padding, it will be scrolled to force it outside of the padded area.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer Events

The AtalaImageViewer type exposes the following members.

Events
 | Name | Description
Public event | ClientSizeChanged | Raised when the ClientSize property is changed.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | ImageChanged | Raised when the Image property or the image data has been changed.
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsCenteredChanged | Occurs when the centered setting changed.
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseMovePixel | Raised when the mouse is moved over an image pixel.
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseWheelZoom | Occurs when the mouse wheel changes the zoom.
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | ScrollChanged | Occurs when changes are detected to the scroll position, extent, or viewport size. (Inherited from ScrollViewer.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ZoomChanged | Occurs when the zoom has changed.
Top
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ClientSizeChanged Event

AtalaImageViewerClientSizeChanged Event

Raised when the ClientSize property is changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ClientSizeChanged
Public Event ClientSizeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ImageChanged Event

AtalaImageViewerImageChanged Event

Raised when the Image property or the image data has been changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ImageChangedEventArgs> ImageChanged
Public Event ImageChanged As EventHandler(Of ImageChangedEventArgs)

Value

Type: SystemEventHandlerImageChangedEventArgs
Remarks
Setting the Source property will also replace the image and raise this event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.IsCenteredChanged Event

AtalaImageViewerIsCenteredChanged Event

Occurs when the centered setting changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler IsCenteredChanged
Public Event IsCenteredChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseMovePixel Event

AtalaImageViewerMouseMovePixel Event

Raised when the mouse is moved over an image pixel.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ImagePixelEventArgs> MouseMovePixel
Public Event MouseMovePixel As EventHandler(Of ImagePixelEventArgs)

Value

Type: SystemEventHandlerImagePixelEventArgs
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseWheelZoom Event

AtalaImageViewerMouseWheelZoom Event

Occurs when the mouse wheel changes the zoom.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<MouseWheelZoomEventArgs> MouseWheelZoom
Public Event MouseWheelZoom As EventHandler(Of MouseWheelZoomEventArgs)

Value

Type: SystemEventHandlerMouseWheelZoomEventArgs
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ZoomChanged Event

AtalaImageViewerZoomChanged Event

Occurs when the zoom has changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler ZoomChanged
Public Event ZoomChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer Fields

The AtalaImageViewer type exposes the following members.

Fields
Name | Description
AutoZoomProperty | Identifies the AutoZoom dependency property.
ClientSizeChangedEvent | Identifies the ClientSizeChanged event.
DisplayProfileProperty | Identifies the DisplayProfile dependency property.
ImageChangedEvent | Identifies the ImageChanged routed event.
IsCenteredChangedEvent | Identifies the IsCenteredChanged event.
IsCenteredProperty | Identifies the IsCentered dependency property.
IsColorManagedProperty | Identifies the IsColorManaged dependency property.
MouseMovePixelEvent | Identifies the MouseMovePixel routed event.
MouseToolProperty | Identifies the MouseTool dependency property.
MouseToolScrollingProperty | Identifies the MouseToolScrolling dependency property.
MouseToolScrollingZoneLengthProperty | Identifies the MouseToolScrollingZoneLength dependency property.
MouseWheelModeProperty | Identifies the MouseWheelMode dependency property.
MouseWheelZoomEvent | Identifies the MouseWheelZoom event.
OutputProfileProperty | Identifies the OutputProfile dependency property.
ProofIntentProperty | Identifies the ProofIntent dependency property.
RenderingIntentProperty | Identifies the RenderingIntent dependency property.
ResolutionScaleModeProperty | Identifies the ResolutionScaleMode dependency property.
SourceProperty | Identifies the Source dependency property.
ZoomChangedEvent | Identifies the ZoomChanged event.
ZoomProperty | Identifies the Zoom dependency property.
Top
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.AutoZoomProperty Field

AtalaImageViewerAutoZoomProperty Field

Identifies the AutoZoom dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoZoomProperty
Public Shared ReadOnly AutoZoomProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the AutoZoom dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ClientSizeChangedEvent Field

AtalaImageViewerClientSizeChangedEvent Field

Identifies the ClientSizeChanged event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly RoutedEvent ClientSizeChangedEvent
Public Shared ReadOnly ClientSizeChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.DisplayProfileProperty Field

AtalaImageViewerDisplayProfileProperty Field

Identifies the DisplayProfile dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayProfileProperty
Public Shared ReadOnly DisplayProfileProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the DisplayProfile dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ImageChangedEvent Field

AtalaImageViewerImageChangedEvent Field

Identifies the ImageChanged routed event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly RoutedEvent ImageChangedEvent
Public Shared ReadOnly ImageChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
Identifies the ImageChanged routed event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.IsCenteredChangedEvent Field

AtalaImageViewerIsCenteredChangedEvent Field

Identifies the IsCenteredChanged event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly RoutedEvent IsCenteredChangedEvent
Public Shared ReadOnly IsCenteredChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.IsCenteredProperty Field

AtalaImageViewerIsCenteredProperty Field

Identifies the IsCentered dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCenteredProperty
Public Shared ReadOnly IsCenteredProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the IsCentered dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.IsColorManagedProperty Field

AtalaImageViewerIsColorManagedProperty Field

Identifies the IsColorManaged dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsColorManagedProperty
Public Shared ReadOnly IsColorManagedProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the IsColorManaged dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseMovePixelEvent Field

AtalaImageViewerMouseMovePixelEvent Field

Identifies the MouseMovePixel routed event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly RoutedEvent MouseMovePixelEvent
Public Shared ReadOnly MouseMovePixelEvent As RoutedEvent

Field Value

Type: RoutedEvent
Identifies the MouseMovePixel routed event.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseToolProperty Field

AtalaImageViewerMouseToolProperty Field

Identifies the MouseTool dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MouseToolProperty
Public Shared ReadOnly MouseToolProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MouseTool dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseToolScrollingProperty Field

AtalaImageViewerMouseToolScrollingProperty Field

Identifies the MouseToolScrolling dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MouseToolScrollingProperty
Public Shared ReadOnly MouseToolScrollingProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MouseToolScrolling dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseToolScrollingZoneLengthProperty Field

AtalaImageViewerMouseToolScrollingZoneLengthProperty Field

Identifies the MouseToolScrollingZoneLength dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MouseToolScrollingZoneLengthProperty
Public Shared ReadOnly MouseToolScrollingZoneLengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MouseToolScrollingZoneLength dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseWheelModeProperty Field

AtalaImageViewerMouseWheelModeProperty Field

Identifies the MouseWheelMode dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MouseWheelModeProperty
Public Shared ReadOnly MouseWheelModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.MouseWheelZoomEvent Field

AtalaImageViewerMouseWheelZoomEvent Field

Identifies the MouseWheelZoom event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly RoutedEvent MouseWheelZoomEvent
Public Shared ReadOnly MouseWheelZoomEvent As RoutedEvent

Field Value

Type: RoutedEvent
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.OutputProfileProperty Field

AtalaImageViewerOutputProfileProperty Field

Identifies the OutputProfile dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty OutputProfileProperty
Public Shared ReadOnly OutputProfileProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the OutputProfile dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ProofIntentProperty Field

AtalaImageViewerProofIntentProperty Field

Identifies the ProofIntent dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ProofIntentProperty
Public Shared ReadOnly ProofIntentProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the ProofIntent dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.RenderingIntentProperty Field

AtalaImageViewerRenderingIntentProperty Field

Identifies the RenderingIntent dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty RenderingIntentProperty
Public Shared ReadOnly RenderingIntentProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the RenderingIntent dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ResolutionScaleModeProperty Field

AtalaImageViewerResolutionScaleModeProperty Field

Identifies the ResolutionScaleMode dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolutionScaleModeProperty
Public Shared ReadOnly ResolutionScaleModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the ResolutionScaleMode dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.SourceProperty Field

AtalaImageViewerSourceProperty Field

Identifies the Source dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SourceProperty
Public Shared ReadOnly SourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Source dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ZoomChangedEvent Field

AtalaImageViewerZoomChangedEvent Field

Identifies the ZoomChanged event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly RoutedEvent ZoomChangedEvent
Public Shared ReadOnly ZoomChangedEvent As RoutedEvent

Field Value

Type: RoutedEvent
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaImageViewer.ZoomProperty Field

AtalaImageViewerZoomProperty Field

Identifies the Zoom dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomProperty
Public Shared ReadOnly ZoomProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Zoom dependency property.
See Also

Reference

AtalaImageViewer Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Class

AtalaObservableDictionaryTKey, TValue Class

Represents an observable collection of keys and values.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WpfAtalaObservableDictionaryTKey, TValue

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalaObservableDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged

Public Class AtalaObservableDictionary(Of TKey, TValue)
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable,
    INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

The AtalaObservableDictionaryTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | AtalaObservableDictionaryTKey, TValue | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the default initial capacity, and uses the default equality comparer for the key type.
Public method | AtalaObservableDictionaryTKey, TValue(IDictionaryTKey, TValue) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that contains elements copied from the specified IDictionaryTKey, TValue and uses the default equality comparer for the key type.
Public method | AtalaObservableDictionaryTKey, TValue(IEqualityComparerTKey) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the default initial capacity, and uses the specified IEqualityComparerT.
Public method | AtalaObservableDictionaryTKey, TValue(Int32) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the specified initial capacity, and uses the default equality comparer for the key type.
Public method | AtalaObservableDictionaryTKey, TValue(IDictionaryTKey, TValue, IEqualityComparerTKey) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that contains elements copied from the specified IDictionaryTKey, TValue and uses the specified IEqualityComparerT.
Public method | AtalaObservableDictionaryTKey, TValue(Int32, IEqualityComparerTKey) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the specified initial capacity, and uses the specified IEqualityComparerT.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the ICollectionT.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | ContainsKey | Determines whether the IDictionaryTKey, TValue contains an element with the specified key.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Fires a CollectionChanged event with specified args.
Protected method | OnPropertyChanged | Fires a PropertyChanged event.
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the ICollectionT.
Public method | Remove(TKey) | Removes the element with the specified key from the IDictionaryTKey, TValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes.
Public event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor

AtalaObservableDictionaryTKey, TValue Constructor

Overload List
 | Name | Description
Public method | AtalaObservableDictionaryTKey, TValue | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the default initial capacity, and uses the default equality comparer for the key type.
Public method | AtalaObservableDictionaryTKey, TValue(IDictionaryTKey, TValue) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that contains elements copied from the specified IDictionaryTKey, TValue and uses the default equality comparer for the key type.
Public method | AtalaObservableDictionaryTKey, TValue(IEqualityComparerTKey) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the default initial capacity, and uses the specified IEqualityComparerT.
Public method | AtalaObservableDictionaryTKey, TValue(Int32) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the specified initial capacity, and uses the default equality comparer for the key type.
Public method | AtalaObservableDictionaryTKey, TValue(IDictionaryTKey, TValue, IEqualityComparerTKey) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that contains elements copied from the specified IDictionaryTKey, TValue and uses the specified IEqualityComparerT.
Public method | AtalaObservableDictionaryTKey, TValue(Int32, IEqualityComparerTKey) | Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the specified initial capacity, and uses the specified IEqualityComparerT.
Top
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor

AtalaObservableDictionaryTKey, TValue Constructor

Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the default initial capacity, and uses the default equality comparer for the key type.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary()
Public Sub New
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
AtalaObservableDictionaryTKey, TValue Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue))

AtalaObservableDictionaryTKey, TValue Constructor (IDictionaryTKey, TValue)

Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that contains elements copied from the specified IDictionaryTKey, TValue and uses the default equality comparer for the key type.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary(
    IDictionary<TKey, TValue> dictionary
)
Public Sub New (
    dictionary As IDictionary(Of TKey, TValue)
)

Parameters

dictionary
Type: System.Collections.GenericIDictionaryTKey, TValue
The IDictionaryTKey, TValue whose elements are copied to the new AtalaObservableDictionaryTKey, TValue.
Exceptions
Exception | Condition
ArgumentNullException | dictionary is null.
ArgumentException | dictionary contains one or more duplicate keys.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
AtalaObservableDictionaryTKey, TValue Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor (IEqualityComparer(TKey))

AtalaObservableDictionaryTKey, TValue Constructor (IEqualityComparerTKey)

Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the default initial capacity, and uses the specified IEqualityComparerT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary(
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    comparer As IEqualityComparer(Of TKey)
)

Parameters

comparer
Type: System.Collections.GenericIEqualityComparerTKey
The IEqualityComparerT implementation to use when comparing keys, or null to use the default IEqualityComparerT for the type of the key.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
AtalaObservableDictionaryTKey, TValue Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor (Int32)

AtalaObservableDictionaryTKey, TValue Constructor (Int32)

Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the specified initial capacity, and uses the default equality comparer for the key type.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The initial number of elements that the AtalaObservableDictionaryTKey, TValue can contain.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | capacity is less than 0.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
AtalaObservableDictionaryTKey, TValue Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue), IEqualityComparer(TKey))

AtalaObservableDictionaryTKey, TValue Constructor (IDictionaryTKey, TValue, IEqualityComparerTKey)

Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that contains elements copied from the specified IDictionaryTKey, TValue and uses the specified IEqualityComparerT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary(
    IDictionary<TKey, TValue> dictionary,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    dictionary As IDictionary(Of TKey, TValue),
    comparer As IEqualityComparer(Of TKey)
)

Parameters

dictionary
Type: System.Collections.GenericIDictionaryTKey, TValue
The IDictionaryTKey, TValue whose elements are copied to the AtalaObservableDictionaryTKey, TValue.
comparer
Type: System.Collections.GenericIEqualityComparerTKey
The IEqualityComparerT implementation to use when comparing keys, or null to use the default IEqualityComparerT for the type of the key.
Exceptions
Exception | Condition
ArgumentNullException | dictionary is null.
ArgumentException | dictionary contains one or more duplicate keys.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
AtalaObservableDictionaryTKey, TValue Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Constructor (Int32, IEqualityComparer(TKey))

AtalaObservableDictionaryTKey, TValue Constructor (Int32, IEqualityComparerTKey)

Initializes a new instance of the AtalaObservableDictionaryTKey, TValue class that is empty, has the specified initial capacity, and uses the specified IEqualityComparerT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaObservableDictionary(
    int capacity,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    capacity As Integer,
    comparer As IEqualityComparer(Of TKey)
)

Parameters

capacity
Type: SystemInt32
The initial number of elements that the AtalaObservableDictionaryTKey, TValue can contain.
comparer
Type: System.Collections.GenericIEqualityComparerTKey
The IEqualityComparerT implementation to use when comparing keys, or null to use the default IEqualityComparerT for the type of the key.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | capacity is less than 0.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
AtalaObservableDictionaryTKey, TValue Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Properties

AtalaObservableDictionaryTKey, TValue Properties

The AtalaObservableDictionaryTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Count Property

AtalaObservableDictionaryTKey, TValueCount Property

Gets the number of elements contained in the ICollectionT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).IsReadOnly Property

AtalaObservableDictionaryTKey, TValueIsReadOnly Property

Gets a value indicating whether the ICollectionT is read-only.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Return Value

Type: Boolean
true if the ICollectionT is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Item Property

AtalaObservableDictionaryTKey, TValueItem Property

Gets or sets the element with the specified key.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set

Parameters

key
Type: TKey
The key of the element to get or set.

Return Value

Type: TValue
The element with the specified key.

Implements

IDictionaryTKey, TValueItemTKey
Exceptions
Exception | Condition
ArgumentNullException | key is null.
KeyNotFoundException | The property is retrieved and key is not found.
NotSupportedException | The property is set and the IDictionaryTKey, TValue is read-only.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Keys Property

AtalaObservableDictionaryTKey, TValueKeys Property

Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get

Return Value

Type: ICollectionTKey
An ICollectionT containing the keys of the object that implements IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Values Property

AtalaObservableDictionaryTKey, TValueValues Property

Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get

Return Value

Type: ICollectionTValue
An ICollectionT containing the values in the object that implements IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueValues
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Methods

AtalaObservableDictionaryTKey, TValue Methods

The AtalaObservableDictionaryTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the ICollectionT.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | ContainsKey | Determines whether the IDictionaryTKey, TValue contains an element with the specified key.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Fires a CollectionChanged event with specified args.
Protected method | OnPropertyChanged | Fires a PropertyChanged event.
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the ICollectionT.
Public method | Remove(TKey) | Removes the element with the specified key from the IDictionaryTKey, TValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Add Method

AtalaObservableDictionaryTKey, TValueAdd Method

Overload List
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the ICollectionT.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Top
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Add Method (KeyValuePair(TKey, TValue))

AtalaObservableDictionaryTKey, TValueAdd Method (KeyValuePairTKey, TValue)

Adds an item to the ICollectionT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    KeyValuePair<TKey, TValue> item
)
Public Sub Add (
    item As KeyValuePair(Of TKey, TValue)
)

Parameters

item
Type: System.Collections.GenericKeyValuePairTKey, TValue
The object to add to the ICollectionT.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Add Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Add Method (TKey, TValue)

AtalaObservableDictionaryTKey, TValueAdd Method (TKey, TValue)

Adds an element with the provided key and value to the IDictionaryTKey, TValue.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)

Parameters

key
Type: TKey
The object to use as the key of the element to add.
value
Type: TValue
The object to use as the value of the element to add.

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
ArgumentException | An element with the same key already exists in the IDictionaryTKey, TValue.
NotSupportedException | The IDictionaryTKey, TValue is read-only.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Add Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Clear Method

AtalaObservableDictionaryTKey, TValueClear Method

Removes all items from the ICollectionT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Contains Method

AtalaObservableDictionaryTKey, TValueContains Method

Determines whether the ICollectionT contains a specific value.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
Public Function Contains (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean

Parameters

item
Type: System.Collections.GenericKeyValuePairTKey, TValue
The object to locate in the ICollectionT.

Return Value

Type: Boolean
true if item is found in the ICollectionT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).ContainsKey Method

AtalaObservableDictionaryTKey, TValueContainsKey Method

Determines whether the IDictionaryTKey, TValue contains an element with the specified key.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey (
    key As TKey
) As Boolean

Parameters

key
Type: TKey
The key to locate in the IDictionaryTKey, TValue.

Return Value

Type: Boolean
true if the IDictionaryTKey, TValue contains an element with the key; otherwise, false.

Implements

IDictionaryTKey, TValueContainsKey(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).CopyTo Method

AtalaObservableDictionaryTKey, TValueCopyTo Method

Copies the elements of the ICollectionT to an Array, starting at a particular Array index.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of TKey, TValue)(),
    arrayIndex As Integer
)

Parameters

array
Type: System.Collections.GenericKeyValuePairTKey, TValue
The one-dimensional Array that is the destination of the elements copied from ICollectionT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source ICollectionT is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).GetEnumerator Method

AtalaObservableDictionaryTKey, TValueGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))

Return Value

Type: IEnumeratorKeyValuePairTKey, TValue
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).OnCollectionChanged Method

AtalaObservableDictionaryTKey, TValueOnCollectionChanged Method

Fires a CollectionChanged event with specified args.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Sub OnCollectionChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
CollectionChanged arguments.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).OnPropertyChanged Method

AtalaObservableDictionaryTKey, TValueOnPropertyChanged Method

Fires a PropertyChanged event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    string propertyName
)
Protected Overridable Sub OnPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
Property that has changed.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Remove Method

AtalaObservableDictionaryTKey, TValueRemove Method

Overload List
 | Name | Description
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the ICollectionT.
Public method | Remove(TKey) | Removes the element with the specified key from the IDictionaryTKey, TValue.
Top
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Remove Method (KeyValuePair(TKey, TValue))

AtalaObservableDictionaryTKey, TValueRemove Method (KeyValuePairTKey, TValue)

Removes the first occurrence of a specific object from the ICollectionT.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
Public Function Remove (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean

Parameters

item
Type: System.Collections.GenericKeyValuePairTKey, TValue
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Remove Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).Remove Method (TKey)

AtalaObservableDictionaryTKey, TValueRemove Method (TKey)

Removes the element with the specified key from the IDictionaryTKey, TValue.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean

Parameters

key
Type: TKey
The key of the element to remove.

Return Value

Type: Boolean
true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueRemove(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
NotSupportedException | The IDictionaryTKey, TValue is read-only.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Remove Overload
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).TryGetValue Method

AtalaObservableDictionaryTKey, TValueTryGetValue Method

Gets the value associated with the specified key.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean

Parameters

key
Type: TKey
The key whose value to get.
value
Type: TValue
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the object that implements IDictionaryTKey, TValue contains an element with the specified key; otherwise, false.

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue) Events

AtalaObservableDictionaryTKey, TValue Events

The AtalaObservableDictionaryTKey, TValue generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes.
Public event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).CollectionChanged Event

AtalaObservableDictionaryTKey, TValueCollectionChanged Event

Occurs when the collection changes.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AtalaObservableDictionary(TKey, TValue).PropertyChanged Event

AtalaObservableDictionaryTKey, TValuePropertyChanged Event

Occurs when a property value changes.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

AtalaObservableDictionaryTKey, TValue Class
Atalasoft.Imaging.Wpf Namespace


AutoZoomMode Enumeration

Describes the type of automatic zooming to perform on the image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AutoZoomMode
Public Enumeration AutoZoomMode
Members
Member name | Description
None | No action is taken.
BestFit | Zoom is calculated so the entire image can be seen in the viewer without scrollbars.
BestFitReduceOnly | The same as BestFit but will not perform a zoom if the image is smaller than the viewer.
FitToWidth | Zoom is calculated so the image will fit the width of the viewer.
FitToHeight | Zoom is calculated so the image will fit the height of the viewer.
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


ImageChangedEventArgs Class

This class is used with the ImageEventHandler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
Atalasoft.Imaging.WpfImageChangedEventArgs

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImageChangedEventArgs : RoutedEventArgs
Public Class ImageChangedEventArgs
    Inherits RoutedEventArgs

The ImageChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageChangedEventArgs | Creates a new instance of ImageChangedEventArgs.
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | Image | Gets the AtalaImage for the associated event.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


ImageChangedEventArgs Constructor

Creates a new instance of ImageChangedEventArgs.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageChangedEventArgs(
    RoutedEvent routedEvent,
    AtalaImage image
)
Public Sub New (
    routedEvent As RoutedEvent,
    image As AtalaImage
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event for this event args.
image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage for the associated event.
See Also

Reference

ImageChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImageChangedEventArgs Properties

The ImageChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | Image | Gets the AtalaImage for the associated event.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

ImageChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImageChangedEventArgs.Image Property

ImageChangedEventArgsImage Property

Gets the AtalaImage for the associated event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
The AtalaImage for the associated event.
See Also

Reference

ImageChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImageChangedEventArgs Methods

The ImageChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImagePixelEventArgs Class

This class is used by the MouseMovePixel event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
Atalasoft.Imaging.WpfImagePixelEventArgs

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImagePixelEventArgs : RoutedEventArgs
Public Class ImagePixelEventArgs
    Inherits RoutedEventArgs

The ImagePixelEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImagePixelEventArgs | Creates a new instance of ImagePixelEventArgs.
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Pixel | Gets the pixel position for the associated event.
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


ImagePixelEventArgs Constructor

Creates a new instance of ImagePixelEventArgs.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePixelEventArgs(
    RoutedEvent routedEvent,
    Point pixel
)
Public Sub New (
    routedEvent As RoutedEvent,
    pixel As Point
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event for this event args.
pixel
Type: System.WindowsPoint
The pixel position for the associated event.
See Also

Reference

ImagePixelEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImagePixelEventArgs Properties

The ImagePixelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Pixel | Gets the pixel position for the associated event.
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

ImagePixelEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImagePixelEventArgs.Pixel Property

ImagePixelEventArgsPixel Property

Gets the pixel position for the associated event.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Pixel { get; }
Public ReadOnly Property Pixel As Point
    Get

Property Value

Type: Point
The pixel position for the associated event.
See Also

Reference

ImagePixelEventArgs Class
Atalasoft.Imaging.Wpf Namespace


ImagePixelEventArgs Methods

The ImagePixelEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImagePixelEventArgs Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Class

This tool is used to provide a magnified area of the image. Use this class by setting the AtalaViewer.MouseTool property to an instance of the MagnifierMouseTool class.
This mouse tool is used to magnify an area of the image. The end-user initiates magnification by pressing a mouse button on the image. Releasing the mouse button will hide the magnifier.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Atalasoft.Imaging.WpfMouseTool
Atalasoft.Imaging.WpfMagnifierMouseTool

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MagnifierMouseTool : MouseTool
Public Class MagnifierMouseTool
    Inherits MouseTool

The MagnifierMouseTool type exposes the following members.

Constructors
 | Name | Description
Public method | MagnifierMouseTool | Creates a new instance of MagnifierMouseTool with default settings.
Public method | MagnifierMouseTool(Geometry, MouseToolBehavior, Double, Pen) | Creates a new instance of MagnifierMouseTool from a Geometry object.
Public method | MagnifierMouseTool(Size, MouseToolBehavior, Double, Pen) | Creates a new instance of MagnifierMouseTool at the specified size and magnification.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Magnification | Gets or sets the magnification level for the tool.
Public property | Pen | Gets or sets the pen used to outline the magnifier.
Public property | RenderGeometry | Gets or sets the Geometry used to define the shape of the magnifier.
Public property | Size | Gets or sets the size of the magnifier.
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of MagnifierMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Overrides MouseToolHitTestCore(Point).)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Inherited from MouseTool.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Overrides MouseToolOnRender(DrawingContext).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
MagnificationProperty | Identifies the Magnification dependency property.
PenProperty | Identifies the Pen dependency property.
RenderGeometryProperty | Identifies the RenderGeometry dependency property.
SizeProperty | Identifies the Size dependency property.
Top
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:atala="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <atala:AtalaImageViewer Name="Viewer">
      <atala:AtalaImageViewer.MouseTool>
        <atala:MagnifierMouseTool Size="120,120" Magnification="2.0">
          <atala:MagnifierMouseTool.Pen>
            <Pen Thickness="1">
              <Pen.Brush>
                <SolidColorBrush Color="Black"/>
              </Pen.Brush>
            </Pen>
          </atala:MagnifierMouseTool.Pen>
        </atala:MagnifierMouseTool>
      </atala:AtalaImageViewer.MouseTool>
    </atala:AtalaImageViewer>
  </Grid>
</Window>
Copy
Me.Viewer.MouseTool = New MagnifierMouseTool(New Size(120, 120), 2, New Pen(New SolidColorBrush(Colors.Black), 1))
Copy
this.Viewer.MouseTool = new MagnifierMouseTool(new Size(120, 120), 2, new Pen(new SolidColorBrush(Colors.Black), 1));
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Constructor

Creates a MagnifierMouseTool.
Overload List
 | Name | Description
Public method | MagnifierMouseTool | Creates a new instance of MagnifierMouseTool with default settings.
Public method | MagnifierMouseTool(Geometry, MouseToolBehavior, Double, Pen) | Creates a new instance of MagnifierMouseTool from a Geometry object.
Public method | MagnifierMouseTool(Size, MouseToolBehavior, Double, Pen) | Creates a new instance of MagnifierMouseTool at the specified size and magnification.
Top
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Constructor

Creates a new instance of MagnifierMouseTool with default settings.
Creates a new instance of MagnifierMouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MagnifierMouseTool()
Public Sub New
See Also

Reference

MagnifierMouseTool Class
MagnifierMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Constructor (Geometry, MouseToolBehavior, Double, Pen)

Creates a new instance of MagnifierMouseTool from a Geometry object.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MagnifierMouseTool(
    Geometry renderGeometry,
    MouseToolBehavior toolBehavior,
    double magnification,
    Pen pen
)
Public Sub New (
    renderGeometry As Geometry,
    toolBehavior As MouseToolBehavior,
    magnification As Double,
    pen As Pen
)

Parameters

renderGeometry
Type: System.Windows.MediaGeometry
The Geometry object used to define the shape of the magnifier.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates whether the magnifier will use the click-and-drag or two-click method.
magnification
Type: SystemDouble
The magnification to apply.
pen
Type: System.Windows.MediaPen
The pen used to outline the magnifier.
See Also

Reference

MagnifierMouseTool Class
MagnifierMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Constructor (Size, MouseToolBehavior, Double, Pen)

Creates a new instance of MagnifierMouseTool at the specified size and magnification.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MagnifierMouseTool(
    Size size,
    MouseToolBehavior toolBehavior,
    double magnification,
    Pen pen
)
Public Sub New (
    size As Size,
    toolBehavior As MouseToolBehavior,
    magnification As Double,
    pen As Pen
)

Parameters

size
Type: System.WindowsSize
The size of the magnifier.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates whether the magnifier will use the click-and-drag or two-click method.
magnification
Type: SystemDouble
The magnification to apply.
pen
Type: System.Windows.MediaPen
The pen used to outline the magnifier.
See Also

Reference

MagnifierMouseTool Class
MagnifierMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Properties

The MagnifierMouseTool type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Magnification | Gets or sets the magnification level for the tool.
Public property | Pen | Gets or sets the pen used to outline the magnifier.
Public property | RenderGeometry | Gets or sets the Geometry used to define the shape of the magnifier.
Public property | Size | Gets or sets the size of the magnifier.
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Top
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.Magnification Property

MagnifierMouseToolMagnification Property

Gets or sets the magnification level for the tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Magnification { get; set; }
Public Property Magnification As Double
    Get
    Set

Property Value

Type: Double
The magnification level for the tool.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.Pen Property

MagnifierMouseToolPen Property

Gets or sets the pen used to outline the magnifier.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pen Pen { get; set; }
Public Property Pen As Pen
    Get
    Set

Property Value

Type: Pen
The pen used to outline the magnifier.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.RenderGeometry Property

MagnifierMouseToolRenderGeometry Property

Gets or sets the Geometry used to define the shape of the magnifier.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Geometry RenderGeometry { get; set; }
Public Property RenderGeometry As Geometry
    Get
    Set

Property Value

Type: Geometry
The Geometry used to define the shape of the magnifier.
Remarks
Setting this property to a non-null value will automatically change the Size to fit the Geometry.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.Size Property

MagnifierMouseToolSize Property

Gets or sets the size of the magnifier.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The size of the magnifier.
Remarks
Setting this property will remove the RenderGeometry and revert to a rectangular shape.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.SupportedMouseToolBehaviors Property

MagnifierMouseToolSupportedMouseToolBehaviors Property

Gets an array of supported MouseToolBehavior values for this tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override MouseToolBehavior[] SupportedMouseToolBehaviors { get; }
Public Overrides ReadOnly Property SupportedMouseToolBehaviors As MouseToolBehavior()
    Get

Property Value

Type: MouseToolBehavior
An array of supported behaviors, defaulting to ClickAndDrag and MultiClick
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Methods

The MagnifierMouseTool type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of MagnifierMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Overrides MouseToolHitTestCore(Point).)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Inherited from MouseTool.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Overrides MouseToolOnRender(DrawingContext).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.CreateInstanceCore Method

MagnifierMouseToolCreateInstanceCore Method

Returns a new instance of MagnifierMouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Freezable CreateInstanceCore()
Protected Overrides Function CreateInstanceCore As Freezable

Return Value

Type: Freezable
A new instance of MagnifierMouseTool.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.HitTestCore Method

MagnifierMouseToolHitTestCore Method

Called by the AtalaImageViewer to determine if a point is over the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool HitTestCore(
    Point point
)
Protected Overrides Function HitTestCore (
    point As Point
) As Boolean

Parameters

point
Type: System.WindowsPoint
The point in image coordinates.

Return Value

Type: Boolean
True if the point is over the MouseTool.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.OnMouseDown Method

MagnifierMouseToolOnMouseDown Method

Called when a mouse button is pressed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.OnMouseMove Method

MagnifierMouseToolOnMouseMove Method

Called when the mouse is moved over the mouse tool bounds or when dragging the tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.OnMouseUp Method

MagnifierMouseToolOnMouseUp Method

Called when the mouse button is released.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.OnRender Method

MagnifierMouseToolOnRender Method

Called when the tool must render itself.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
A DrawingContext used to render.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Events

The MagnifierMouseTool type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool Fields

The MagnifierMouseTool type exposes the following members.

Fields
Name | Description
MagnificationProperty | Identifies the Magnification dependency property.
PenProperty | Identifies the Pen dependency property.
RenderGeometryProperty | Identifies the RenderGeometry dependency property.
SizeProperty | Identifies the Size dependency property.
Top
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.MagnificationProperty Field

MagnifierMouseToolMagnificationProperty Field

Identifies the Magnification dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MagnificationProperty
Public Shared ReadOnly MagnificationProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Magnification dependency property.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.PenProperty Field

MagnifierMouseToolPenProperty Field

Identifies the Pen dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty PenProperty
Public Shared ReadOnly PenProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Pen dependency property.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.RenderGeometryProperty Field

MagnifierMouseToolRenderGeometryProperty Field

Identifies the RenderGeometry dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty RenderGeometryProperty
Public Shared ReadOnly RenderGeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the RenderGeometry dependency property.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MagnifierMouseTool.SizeProperty Field

MagnifierMouseToolSizeProperty Field

Identifies the Size dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeProperty
Public Shared ReadOnly SizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Size dependency property.
See Also

Reference

MagnifierMouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool Class

This is an abstract class from which all mouse tools must derive.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Atalasoft.Imaging.WpfMouseTool
Atalasoft.Imaging.WpfMagnifierMouseTool
Atalasoft.Imaging.WpfPanningMouseTool
Atalasoft.Imaging.WpfSelectionMouseTool
Atalasoft.Imaging.WpfZoomMouseTool

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class MouseTool : Animatable
Public MustInherit Class MouseTool
    Inherits Animatable

The MouseTool type exposes the following members.

Constructors
 | Name | Description
Protected method | MouseTool | Initializes a new instance of the MouseTool class
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds used by the MouseTool.
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Cursor | Gets or sets the cursor for the MouseTool.
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created.
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool.
Public property | ToolBehavior | Identifies the ToolBehavior dependency property.
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool.
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area.
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image.
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image.
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | When implemented in a derived class, creates a new instance of the Freezable derived class. (Inherited from Freezable.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs.
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs.
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates.
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool.
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method.
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed.
Protected method | OnMouseDown | Called when a mouse button is pressed.
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool.
Protected method | OnMouseUp | Called when the mouse button is released.
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself.
Protected method | OnScrollChanged | Called when the scroll position has changed.
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
BoundsProperty | Identifies the Bounds dependency property.
CursorProperty | Identifies the Cursor dependency property.
ToolBehaviorProperty | Identifies the ToolBehavior property.
Top
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


MouseTool Constructor

Initializes a new instance of the MouseTool class

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected MouseTool()
Protected Sub New
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool Properties

The MouseTool type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds used by the MouseTool.
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Cursor | Gets or sets the cursor for the MouseTool.
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created.
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool.
Public property | ToolBehavior | Identifies the ToolBehavior dependency property.
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool.
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.Bounds Property

MouseToolBounds Property

Gets or sets the bounds used by the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect Bounds { get; set; }
Public Property Bounds As Rect
    Get
    Set

Property Value

Type: Rect
The bounds for the tool.
Remarks
Not all mouse tools have a bounds. For instance, the ZoomMouseTool applies a zoom change on click, but does not contain a bounding rectangle.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.Cursor Property

MouseToolCursor Property

Gets or sets the cursor for the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor Cursor { get; set; }
Public Property Cursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor for the MouseTool.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.IsCreating Property

MouseToolIsCreating Property

Gets a value indicating whether the mouse tool is currently being created.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCreating { get; }
Public ReadOnly Property IsCreating As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the mouse tool is being created.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.SupportedMouseToolBehaviors Property

MouseToolSupportedMouseToolBehaviors Property

Gets an array of supported MouseToolBehavior values for this tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract MouseToolBehavior[] SupportedMouseToolBehaviors { get; }
Public MustOverride ReadOnly Property SupportedMouseToolBehaviors As MouseToolBehavior()
    Get

Property Value

Type: MouseToolBehavior
An array of supported behaviors.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.ToolBehavior Property

MouseToolToolBehavior Property

Identifies the ToolBehavior dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseToolBehavior ToolBehavior { get; set; }
Public Property ToolBehavior As MouseToolBehavior
    Get
    Set

Property Value

Type: MouseToolBehavior
Identifies the ToolBehavior dependency property.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.Viewer Property

MouseToolViewer Property

Gets the AtalaImageViewer which is using the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected AtalaImageViewer Viewer { get; }
Protected ReadOnly Property Viewer As AtalaImageViewer
    Get

Property Value

Type: AtalaImageViewer
The AtalaImageViewer using this tool.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool Methods

The MouseTool type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area.
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image.
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image.
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | When implemented in a derived class, creates a new instance of the Freezable derived class. (Inherited from Freezable.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs.
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs.
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates.
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool.
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method.
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed.
Protected method | OnMouseDown | Called when a mouse button is pressed.
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool.
Protected method | OnMouseUp | Called when the mouse button is released.
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself.
Protected method | OnScrollChanged | Called when the scroll position has changed.
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property.
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.ConfineToImage Method

MouseToolConfineToImage Method

These methods are used to confine a Point or Rect to the image area.
Overload List
 | Name | Description
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area.
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image.
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.ConfineToImage Method (Point)

MouseToolConfineToImage Method (Point)

Returns a modified Point that is confined to the image area.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Point ConfineToImage(
    Point imagePoint
)
Protected Function ConfineToImage (
    imagePoint As Point
) As Point

Parameters

imagePoint
Type: System.WindowsPoint
The point to confine.

Return Value

Type: Point
The confined point.
Remarks
If no image is currently loaded, this method will return a new Point.
See Also

Reference

MouseTool Class
ConfineToImage Overload
Atalasoft.Imaging.Wpf Namespace


MouseTool.ConfineToImage Method (Rect)

MouseToolConfineToImage Method (Rect)

Returns a Rect that is confined to the image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Rect ConfineToImage(
    Rect imageRect
)
Protected Function ConfineToImage (
    imageRect As Rect
) As Rect

Parameters

imageRect
Type: System.WindowsRect
The Rect to confine.

Return Value

Type: Rect
The confined Rect.
Remarks
If no image is currently loaded, this method will return a new Rect.
See Also

Reference

MouseTool Class
ConfineToImage Overload
Atalasoft.Imaging.Wpf Namespace


MouseTool.ConfineToRenderedImage Method

MouseToolConfineToRenderedImage Method

Returns a rectangle confined to the rendered size of the image.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Rect ConfineToRenderedImage(
    Rect imageRect
)
Protected Function ConfineToRenderedImage (
    imageRect As Rect
) As Rect

Parameters

imageRect
Type: System.WindowsRect
The rectangle to constrain.

Return Value

Type: Rect
The constrained rectangle.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.GetImagePosition Method

MouseToolGetImagePosition Method

These methods are used to get the image position from mouse events.
Overload List
 | Name | Description
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs.
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs.
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates.
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.GetImagePosition Method (MouseButtonEventArgs, Boolean)

MouseToolGetImagePosition Method (MouseButtonEventArgs, Boolean)

Returns the image position from a MouseButtonEventArgs.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Point GetImagePosition(
    MouseButtonEventArgs e,
    bool confineToImage
)
Protected Function GetImagePosition (
    e As MouseButtonEventArgs,
    confineToImage As Boolean
) As Point

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs from a mouse event.
confineToImage
Type: SystemBoolean
Indicates whether the point should be confined to the image area. Setting this to false will allow positions outside of the image to be returned.

Return Value

Type: Point
The converted position in image coordinates.
See Also

Reference

MouseTool Class
GetImagePosition Overload
Atalasoft.Imaging.Wpf Namespace


MouseTool.GetImagePosition Method (MouseEventArgs, Boolean)

MouseToolGetImagePosition Method (MouseEventArgs, Boolean)

Returns the image position from a MouseEventArgs.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Point GetImagePosition(
    MouseEventArgs e,
    bool confineToImage
)
Protected Function GetImagePosition (
    e As MouseEventArgs,
    confineToImage As Boolean
) As Point

Parameters

e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs from a mouse event.
confineToImage
Type: SystemBoolean
Indicates whether the point should be confined to the image area. Setting this to false will allow positions outside of the image to be returned.

Return Value

Type: Point
The converted position in image coordinates.
See Also

Reference

MouseTool Class
GetImagePosition Overload
Atalasoft.Imaging.Wpf Namespace


MouseTool.GetImagePosition Method (Point, Boolean)

MouseToolGetImagePosition Method (Point, Boolean)

Returns the image position from a point in viewer coordinates.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Point GetImagePosition(
    Point controlPoint,
    bool confineToImage
)
Protected Function GetImagePosition (
    controlPoint As Point,
    confineToImage As Boolean
) As Point

Parameters

controlPoint
Type: System.WindowsPoint
The viewer point to convert.
confineToImage
Type: SystemBoolean
Indicates whether the point should be confined to the image area. Setting this to false will allow positions outside of the image to be returned.

Return Value

Type: Point
The converted position in image coordinates.
See Also

Reference

MouseTool Class
GetImagePosition Overload
Atalasoft.Imaging.Wpf Namespace


MouseTool.HitTestCore Method

MouseToolHitTestCore Method

Called by the AtalaImageViewer to determine if a point is over the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool HitTestCore(
    Point point
)
Protected Overridable Function HitTestCore (
    point As Point
) As Boolean

Parameters

point
Type: System.WindowsPoint
The point in image coordinates.

Return Value

Type: Boolean
True if the point is over the MouseTool.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.InvaidateVisual Method

MouseToolInvaidateVisual Method

Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void InvaidateVisual()
Protected Sub InvaidateVisual
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.IsMouseToolBehaviorSupported Method

MouseToolIsMouseToolBehaviorSupported Method

Indicates if the specified MouseToolBehavior is supported by the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsMouseToolBehaviorSupported(
    MouseToolBehavior behavior
)
Public Overridable Function IsMouseToolBehaviorSupported (
    behavior As MouseToolBehavior
) As Boolean

Parameters

behavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior to test.

Return Value

Type: Boolean
A value indicating whether the specified behavior is supported.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnImageChanged Method

MouseToolOnImageChanged Method

Called when the image in the AtalaImageViewer has changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageChanged()
Protected Overridable Sub OnImageChanged
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnMouseDown Method

MouseToolOnMouseDown Method

Called when a mouse button is pressed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overridable Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnMouseMove Method

MouseToolOnMouseMove Method

Called when the mouse is moved over the mouse tool bounds or when dragging the tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseMove(
    MouseEventArgs e
)
Protected Overridable Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnMouseUp Method

MouseToolOnMouseUp Method

Called when the mouse button is released.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overridable Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnRender Method

MouseToolOnRender Method

Called when the tool must render itself.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnRender(
    DrawingContext drawingContext
)
Protected Overridable Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
A DrawingContext used to render.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnScrollChanged Method

MouseToolOnScrollChanged Method

Called when the scroll position has changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnScrollChanged(
    ScrollChangedEventArgs e
)
Protected Overridable Sub OnScrollChanged (
    e As ScrollChangedEventArgs
)

Parameters

e
Type: System.Windows.ControlsScrollChangedEventArgs
A ScrollChangedEventArgs containing information about this event.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.OnViewerChanged Method

MouseToolOnViewerChanged Method

Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnViewerChanged()
Protected Overridable Sub OnViewerChanged
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.SetCreatingState Method

MouseToolSetCreatingState Method

Sets the value for the IsCreating property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetCreatingState(
    bool isCreating
)
Protected Sub SetCreatingState (
    isCreating As Boolean
)

Parameters

isCreating
Type: SystemBoolean
The value to use for IsCreating.
Remarks
The value of IsCreating is used by the AtalaImageViewer for scrolling the viewer when MouseToolScrolling is enabled. This method only needs to be used if the tool supports MouseToolBehavior.MultiClick.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool Events

The MouseTool type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool Fields

The MouseTool type exposes the following members.

Fields
Name | Description
BoundsProperty | Identifies the Bounds dependency property.
CursorProperty | Identifies the Cursor dependency property.
ToolBehaviorProperty | Identifies the ToolBehavior property.
Top
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.BoundsProperty Field

MouseToolBoundsProperty Field

Identifies the Bounds dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty BoundsProperty
Public Shared ReadOnly BoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Bounds dependency property.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.CursorProperty Field

MouseToolCursorProperty Field

Identifies the Cursor dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CursorProperty
Public Shared ReadOnly CursorProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Cursor dependency property.
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseTool.ToolBehaviorProperty Field

MouseToolToolBehaviorProperty Field

Identifies the ToolBehavior property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolBehaviorProperty
Public Shared ReadOnly ToolBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

MouseTool Class
Atalasoft.Imaging.Wpf Namespace


MouseToolBehavior Enumeration

Describes the way a selection is created by the user.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MouseToolBehavior
Public Enumeration MouseToolBehavior
Members
Member name | Description
MultiClick | The selection is created by making two mouse clicks; one for the each opposite corner of the selection. This is useful for users that may have a hard time dragging the mouse with a button pressed.
ClickAndDrag | The selection is created by hold down a mouse button and dragging.
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


MouseWheelMode Enumeration

Defines how the mouse wheel will act in the control

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum MouseWheelMode
Public Enumeration MouseWheelMode
Members
Member name | Description
Scroll | The mouse wheel will act as a scroll controller
Zoom | The mouse whell will act as a zoom in/zoom out controller
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


MouseWheelZoomEventArgs Class

Represents an event that files when a mouse wheel action results in a zoom in or zoom out.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
Atalasoft.Imaging.WpfMouseWheelZoomEventArgs

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MouseWheelZoomEventArgs : RoutedEventArgs
Public Class MouseWheelZoomEventArgs
    Inherits RoutedEventArgs

The MouseWheelZoomEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MouseWheelZoomEventArgs | Initializes a new instance of the MouseWheelZoomEventArgs class.
Top
Properties
 | Name | Description
Public property | Delta | Gets the delta for the zoom
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | Zoom | Gets or sets the zoom.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


MouseWheelZoomEventArgs Constructor

Initializes a new instance of the MouseWheelZoomEventArgs class.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MouseWheelZoomEventArgs(
    RoutedEvent routedEvent,
    double zoom,
    int delta
)
Public Sub New (
    routedEvent As RoutedEvent,
    zoom As Double,
    delta As Integer
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event.
zoom
Type: SystemDouble
The zoom.
delta
Type: SystemInt32
The change from last time.
See Also

Reference

MouseWheelZoomEventArgs Class
Atalasoft.Imaging.Wpf Namespace


MouseWheelZoomEventArgs Properties

The MouseWheelZoomEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Delta | Gets the delta for the zoom
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | Zoom | Gets or sets the zoom.
Top
See Also

Reference

MouseWheelZoomEventArgs Class
Atalasoft.Imaging.Wpf Namespace


MouseWheelZoomEventArgs.Delta Property

MouseWheelZoomEventArgsDelta Property

Gets the delta for the zoom

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Delta { get; }
Public ReadOnly Property Delta As Integer
    Get

Property Value

Type: Int32
The change in the zoom.
See Also

Reference

MouseWheelZoomEventArgs Class
Atalasoft.Imaging.Wpf Namespace


MouseWheelZoomEventArgs.Zoom Property

MouseWheelZoomEventArgsZoom Property

Gets or sets the zoom.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Zoom { get; set; }
Public Property Zoom As Double
    Get
    Set

Property Value

Type: Double
The zoom value
Exceptions
Exception | Condition
ArgumentOutOfRangeException | value;Zoom cannot be less than 0.001.
See Also

Reference

MouseWheelZoomEventArgs Class
Atalasoft.Imaging.Wpf Namespace


MouseWheelZoomEventArgs Methods

The MouseWheelZoomEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MouseWheelZoomEventArgs Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Class

The PanningMouseTool is used give end-users the ability to drag an image around the viewport with the mouse.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Atalasoft.Imaging.WpfMouseTool
Atalasoft.Imaging.WpfPanningMouseTool

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PanningMouseTool : MouseTool
Public Class PanningMouseTool
    Inherits MouseTool

The PanningMouseTool type exposes the following members.

Constructors
 | Name | Description
Public method | PanningMouseTool | Creates a new instance of PanningMouseTool with no grab cursor.
Public method | PanningMouseTool(Cursor, Cursor) | Creates a new instance of PanningMouseTool specifying the cursors to use.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | GrabCursor | Gets or sets the cursor to use when the mouse button is pressed.
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of PanningMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Inherited from MouseTool.)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Inherited from MouseTool.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Inherited from MouseTool.)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
GrabCursorProperty | Identifies the GrabCursor dependency property.
Top
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:atala="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <atala:AtalaImageViewer Name="Viewer">
      <atala:AtalaImageViewer.MouseTool>
        <atala:PanningMouseTool/>
      </atala:AtalaImageViewer.MouseTool>
    </atala:AtalaImageViewer>
  </Grid>
</Window>
Copy
Me.Viewer.MouseTool = New PanningMouseTool()
Copy
this.Viewer.MouseTool = new PanningMouseTool();
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Constructor

Creates a new instance of PanningMouseTool.
Overload List
 | Name | Description
Public method | PanningMouseTool | Creates a new instance of PanningMouseTool with no grab cursor.
Public method | PanningMouseTool(Cursor, Cursor) | Creates a new instance of PanningMouseTool specifying the cursors to use.
Top
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Constructor

Creates a new instance of PanningMouseTool with no grab cursor.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PanningMouseTool()
Public Sub New
See Also

Reference

PanningMouseTool Class
PanningMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Constructor (Cursor, Cursor)

Creates a new instance of PanningMouseTool specifying the cursors to use.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PanningMouseTool(
    Cursor standardCursor,
    Cursor grabCursor
)
Public Sub New (
    standardCursor As Cursor,
    grabCursor As Cursor
)

Parameters

standardCursor
Type: System.Windows.InputCursor
The normal cursor that will be used for the tool.
grabCursor
Type: System.Windows.InputCursor
The cursor to use when the mouse button is pressed. This can be null (Nothing in VB).
See Also

Reference

PanningMouseTool Class
PanningMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Properties

The PanningMouseTool type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | GrabCursor | Gets or sets the cursor to use when the mouse button is pressed.
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Top
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.GrabCursor Property

PanningMouseToolGrabCursor Property

Gets or sets the cursor to use when the mouse button is pressed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Cursor GrabCursor { get; set; }
Public Property GrabCursor As Cursor
    Get
    Set

Property Value

Type: Cursor
The cursor used when the mouse button is pressed.
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.SupportedMouseToolBehaviors Property

PanningMouseToolSupportedMouseToolBehaviors Property

Gets an array of supported MouseToolBehavior values for this tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override MouseToolBehavior[] SupportedMouseToolBehaviors { get; }
Public Overrides ReadOnly Property SupportedMouseToolBehaviors As MouseToolBehavior()
    Get

Property Value

Type: MouseToolBehavior
An array of supported behaviors. Current default is ClickAndDrag
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Methods

The PanningMouseTool type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of PanningMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Inherited from MouseTool.)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Inherited from MouseTool.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Inherited from MouseTool.)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.CreateInstanceCore Method

PanningMouseToolCreateInstanceCore Method

Returns a new instance of PanningMouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Freezable CreateInstanceCore()
Protected Overrides Function CreateInstanceCore As Freezable

Return Value

Type: Freezable
A new instance of PanningMouseTool.
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.OnMouseDown Method

PanningMouseToolOnMouseDown Method

Called when a mouse button is pressed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.OnMouseMove Method

PanningMouseToolOnMouseMove Method

Called when the mouse is moved over the mouse tool bounds or when dragging the tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.OnMouseUp Method

PanningMouseToolOnMouseUp Method

Called when the mouse button is released.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Events

The PanningMouseTool type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool Fields

The PanningMouseTool type exposes the following members.

Fields
Name | Description
GrabCursorProperty | Identifies the GrabCursor dependency property.
Top
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


PanningMouseTool.GrabCursorProperty Field

PanningMouseToolGrabCursorProperty Field

Identifies the GrabCursor dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty GrabCursorProperty
Public Shared ReadOnly GrabCursorProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

PanningMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ResolutionScaleMode Enumeration

Defines the scaling mode applied when an image has different X and Y resolution values.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResolutionScaleMode
Public Enumeration ResolutionScaleMode
Members
Member name | Description
None | No scaling is performed.
Fax | Only 1-bit images will perform scaling.
All | All images will perform scaling.
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Class

The SelectionMouseTool provides the ability for end-users to select an area of the image for processing.

The tool can be animated using the built-in animation feature or by providing custom animation. A masked selection feature is provided which (by default) will darken the image except for the selected area. This effect can be modified by setting the MaskedImageCommand property.

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Atalasoft.Imaging.WpfMouseTool
Atalasoft.Imaging.WpfSelectionMouseTool

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SelectionMouseTool : MouseTool
Public Class SelectionMouseTool
    Inherits MouseTool

The SelectionMouseTool type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionMouseTool | Creates a new instance of SelectionMouseTool using default values.
Public method | SelectionMouseTool(Rect) | Creates a new instance of SelectionMouseTool specifying the selection bounds.
Public method | SelectionMouseTool(SelectionMouseToolType) | Creates a new instance of SelectionMouseTool specifying the selection type.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Boolean, ImageCommand) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and masking options.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Boolean, Duration) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and animation options.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Color, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and colors.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Pen, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and pen.
Public method | SelectionMouseTool(Rect, SelectionMouseToolType, MouseToolBehavior, Color, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectMouseTool specifying the bounds, selection type, behavior and colors.
Public method | SelectionMouseTool(Rect, SelectionMouseToolType, MouseToolBehavior, Pen, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectionMouseTool specifying the bounds, selection type, behavior and pen.
Public method | SelectionMouseTool(Rect, SelectionMouseToolType, MouseToolBehavior, Pen, Color, Color, Brush, Boolean, Boolean, Double, AspectRatioMode, Boolean, Duration, Boolean, ImageCommand) | Creates a new instance of SelectionMouseTool specifying its property values.
Top
Properties
 | Name | Description
Public property | AnimationDuration | Gets or sets the duration used with the built-in animation.
 | AspectRatio | Gets or sets the width-to-height ratio for the selection.
Public property | AspectRatioCornerMode | Gets or sets behavior applied when a selection corner is dragged and AspectRatio is greater than zero.
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | ConfineSelectionToImage | Gets or sets a value indicating whether the selection is confined to the image area.
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Gets or sets the brush used to fill the selection.
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsAnimated | Gets or sets a value indicating whether the built-in animation will be used.
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsEmpty | Gets a value indicating if the tool has a valid selection.
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsMasked | Gets or sets a value indicating whether the selection will use masking.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | LineBackgroundColor | Gets or sets the color used as the background line.
Public property | LineColor | Gets or sets the line color used with the built-in pen.
Public property | MaintainPenThickness | Gets or sets a value indicating whether the pen thickness will render at the same size or if it will be scaled along with the image zoom level.
Public property | MaskedImageCommand | Gets or sets the ImageCommand used to for selection masking.
Public property | Pen | Gets or sets the pen used to draw the selection.
Public property | SelectionType | Gets or sets the type of selection to render.
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of SelectionMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetRegion | Returns a RegionOfInterest object containing the region for the selection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Overrides MouseToolHitTestCore(Point).)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Overrides MouseToolOnImageChanged.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Overrides MouseToolOnRender(DrawingContext).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | SelectionChanged | Raised when the selection has finished being modified.
Public event | SelectionChanging | Raised while the selection is being modfied to provide live feedback to the user.
Top
Fields
Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
AspectRatioCornerModeProperty | Identifies the AspectRatioCornerMode dependency property.
AspectRatioProperty | Identifies the AspectRatio dependency property.
ConfineSelectionToImageProperty | Identifies the ConfineSelectionToImage dependency property.
FillProperty | Identifies the Fill dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
IsMaskedProperty | Identifies the IsMasked dependency property.
LineBackgroundColorProperty | Identifies the LineBackgroundColor dependency property.
LineColorProperty | Identifies the LineColor dependency property.
MaintainPenThicknessProperty | Identifies the MaintainPenThickness dependency property.
MaskedImageCommandProperty | Identifies the MaskedImageCommand dependency property.
PenProperty | Identifies the Pen dependency property.
SelectionTypeProperty | Identifies the SelectionType dependency property.
Top
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:atala="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <atala:AtalaImageViewer Name="Viewer">
      <atala:AtalaImageViewer.MouseTool>
        <atala:SelectionMouseTool/>
      </atala:AtalaImageViewer.MouseTool>
    </atala:AtalaImageViewer>
  </Grid>
</Window>
Copy
Me.Viewer.MouseTool = New SelectionMouseTool()
Copy
this.Viewer.MouseTool = new SelectionMouseTool();
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor

Creates a new instance of SelectionMouseTool.
Overload List
 | Name | Description
Public method | SelectionMouseTool | Creates a new instance of SelectionMouseTool using default values.
Public method | SelectionMouseTool(Rect) | Creates a new instance of SelectionMouseTool specifying the selection bounds.
Public method | SelectionMouseTool(SelectionMouseToolType) | Creates a new instance of SelectionMouseTool specifying the selection type.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Boolean, ImageCommand) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and masking options.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Boolean, Duration) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and animation options.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Color, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and colors.
Public method | SelectionMouseTool(SelectionMouseToolType, MouseToolBehavior, Pen, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectionMouseTool specifying the selection type, behavior and pen.
Public method | SelectionMouseTool(Rect, SelectionMouseToolType, MouseToolBehavior, Color, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectMouseTool specifying the bounds, selection type, behavior and colors.
Public method | SelectionMouseTool(Rect, SelectionMouseToolType, MouseToolBehavior, Pen, Color, Brush, Boolean, Boolean) | Creates a new instance of SelectionMouseTool specifying the bounds, selection type, behavior and pen.
Public method | SelectionMouseTool(Rect, SelectionMouseToolType, MouseToolBehavior, Pen, Color, Color, Brush, Boolean, Boolean, Double, AspectRatioMode, Boolean, Duration, Boolean, ImageCommand) | Creates a new instance of SelectionMouseTool specifying its property values.
Top
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor

Creates a new instance of SelectionMouseTool using default values.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool()
Public Sub New
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (Rect)

Creates a new instance of SelectionMouseTool specifying the selection bounds.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    Rect bounds
)
Public Sub New (
    bounds As Rect
)

Parameters

bounds
Type: System.WindowsRect
The selection bounds in image coordinates.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (SelectionMouseToolType)

Creates a new instance of SelectionMouseTool specifying the selection type.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    SelectionMouseToolType selectionType
)
Public Sub New (
    selectionType As SelectionMouseToolType
)

Parameters

selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (SelectionMouseToolType, MouseToolBehavior, Boolean, ImageCommand)

Creates a new instance of SelectionMouseTool specifying the selection type, behavior and masking options.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    bool masked,
    ImageCommand maskedImageCommand
)
Public Sub New (
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    masked As Boolean,
    maskedImageCommand As ImageCommand
)

Parameters

selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
masked
Type: SystemBoolean
Indicates whether the selection using masking on the image.
maskedImageCommand
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The ImageCommand used for the masking effect.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (SelectionMouseToolType, MouseToolBehavior, Boolean, Duration)

Creates a new instance of SelectionMouseTool specifying the selection type, behavior and animation options.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    bool animated,
    Duration animationDuration
)
Public Sub New (
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    animated As Boolean,
    animationDuration As Duration
)

Parameters

selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
animated
Type: SystemBoolean
Indicates whether the built-in animation will be used.
animationDuration
Type: System.WindowsDuration
The duration for the built-in animation.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (SelectionMouseToolType, MouseToolBehavior, Color, Color, Brush, Boolean, Boolean)

Creates a new instance of SelectionMouseTool specifying the selection type, behavior and colors.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    Color lineColor,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    bool confineSelectionToImage
)
Public Sub New (
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    lineColor As Color,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    confineSelectionToImage As Boolean
)

Parameters

selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
lineColor
Type: System.Windows.MediaColor
The pen color for the line.
lineBackgroundColor
Type: System.Windows.MediaColor
The background pen color for the line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates whether the pen thickness will render the same size or scale with the zoom level.
confineSelectionToImage
Type: SystemBoolean
Indicates whether the selection should be confined to the image area.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (SelectionMouseToolType, MouseToolBehavior, Pen, Color, Brush, Boolean, Boolean)

Creates a new instance of SelectionMouseTool specifying the selection type, behavior and pen.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    bool confineSelectionToImage
)
Public Sub New (
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    confineSelectionToImage As Boolean
)

Parameters

selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
pen
Type: System.Windows.MediaPen
The pen used to draw the line.
lineBackgroundColor
Type: System.Windows.MediaColor
The background pen color for the line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates whether the pen thickness will render the same size or scale with the zoom level.
confineSelectionToImage
Type: SystemBoolean
Indicates whether the selection should be confined to the image area.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (Rect, SelectionMouseToolType, MouseToolBehavior, Color, Color, Brush, Boolean, Boolean)

Creates a new instance of SelectMouseTool specifying the bounds, selection type, behavior and colors.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    Rect bounds,
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    Color lineColor,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    bool confineSelectionToImage
)
Public Sub New (
    bounds As Rect,
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    lineColor As Color,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    confineSelectionToImage As Boolean
)

Parameters

bounds
Type: System.WindowsRect
The selection bounds in image coordinates.
selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
lineColor
Type: System.Windows.MediaColor
The pen color for the line.
lineBackgroundColor
Type: System.Windows.MediaColor
The background pen color for the line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates whether the pen thickness will render the same size or scale with the zoom level.
confineSelectionToImage
Type: SystemBoolean
Indicates whether the selection should be confined to the image area.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (Rect, SelectionMouseToolType, MouseToolBehavior, Pen, Color, Brush, Boolean, Boolean)

Creates a new instance of SelectionMouseTool specifying the bounds, selection type, behavior and pen.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    Rect bounds,
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    bool confineSelectionToImage
)
Public Sub New (
    bounds As Rect,
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    confineSelectionToImage As Boolean
)

Parameters

bounds
Type: System.WindowsRect
The selection bounds in image coordinates.
selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
pen
Type: System.Windows.MediaPen
The pen used to draw the line.
lineBackgroundColor
Type: System.Windows.MediaColor
The background pen color for the line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates whether the pen thickness will render the same size or scale with the zoom level.
confineSelectionToImage
Type: SystemBoolean
Indicates whether the selection should be confined to the image area.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Constructor (Rect, SelectionMouseToolType, MouseToolBehavior, Pen, Color, Color, Brush, Boolean, Boolean, Double, AspectRatioMode, Boolean, Duration, Boolean, ImageCommand)

Creates a new instance of SelectionMouseTool specifying its property values.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseTool(
    Rect bounds,
    SelectionMouseToolType selectionType,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineColor,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    bool confineSelectionToImage,
    double aspectRatio,
    AspectRatioMode aspectRatioCornerMode,
    bool animated,
    Duration animationDuration,
    bool masked,
    ImageCommand maskedImageCommand
)
Public Sub New (
    bounds As Rect,
    selectionType As SelectionMouseToolType,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineColor As Color,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    confineSelectionToImage As Boolean,
    aspectRatio As Double,
    aspectRatioCornerMode As AspectRatioMode,
    animated As Boolean,
    animationDuration As Duration,
    masked As Boolean,
    maskedImageCommand As ImageCommand
)

Parameters

bounds
Type: System.WindowsRect
The selection bounds in image coordinates.
selectionType
Type: Atalasoft.Imaging.WpfSelectionMouseToolType
The type of selection for the tool.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
The behavior for the tool.
pen
Type: System.Windows.MediaPen
The pen used to draw the line.
lineColor
Type: System.Windows.MediaColor
The pen color for the line if the Pen is null (Nothing in VB).
lineBackgroundColor
Type: System.Windows.MediaColor
The background pen color for the line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates whether the pen thickness will render the same size or scale with the zoom level.
confineSelectionToImage
Type: SystemBoolean
Indicates whether the selection should be confined to the image area.
aspectRatio
Type: SystemDouble
The width to height aspect ratio of the bounds. A value of zero will disable this feature.
aspectRatioCornerMode
Type: Atalasoft.Imaging.WpfAspectRatioMode
Determines how the selection will act when the user grabs a corner to resize and AspectRatio is not zero.
animated
Type: SystemBoolean
Indicates whether the built-in animation will be used.
animationDuration
Type: System.WindowsDuration
The duration for the built-in animation.
masked
Type: SystemBoolean
Indicates whether the selection using masking on the image.
maskedImageCommand
Type: Atalasoft.Imaging.ImageProcessingImageCommand
The ImageCommand used for the masking effect.
See Also

Reference

SelectionMouseTool Class
SelectionMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Properties

The SelectionMouseTool type exposes the following members.

Properties
 | Name | Description
Public property | AnimationDuration | Gets or sets the duration used with the built-in animation.
 | AspectRatio | Gets or sets the width-to-height ratio for the selection.
Public property | AspectRatioCornerMode | Gets or sets behavior applied when a selection corner is dragged and AspectRatio is greater than zero.
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | ConfineSelectionToImage | Gets or sets a value indicating whether the selection is confined to the image area.
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Gets or sets the brush used to fill the selection.
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsAnimated | Gets or sets a value indicating whether the built-in animation will be used.
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsEmpty | Gets a value indicating if the tool has a valid selection.
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsMasked | Gets or sets a value indicating whether the selection will use masking.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | LineBackgroundColor | Gets or sets the color used as the background line.
Public property | LineColor | Gets or sets the line color used with the built-in pen.
Public property | MaintainPenThickness | Gets or sets a value indicating whether the pen thickness will render at the same size or if it will be scaled along with the image zoom level.
Public property | MaskedImageCommand | Gets or sets the ImageCommand used to for selection masking.
Public property | Pen | Gets or sets the pen used to draw the selection.
Public property | SelectionType | Gets or sets the type of selection to render.
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Top
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.AnimationDuration Property

SelectionMouseToolAnimationDuration Property

Gets or sets the duration used with the built-in animation.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Duration AnimationDuration { get; set; }
Public Property AnimationDuration As Duration
    Get
    Set

Property Value

Type: Duration
The duration for the animation.
Remarks
IsAnimated must be true for this property to take affect.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.AspectRatio Property

SelectionMouseToolAspectRatio Property

Gets or sets the width-to-height ratio for the selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double AspectRatio { get; set; }
Public Property AspectRatio As Double
    Get
    Set

Property Value

Type: Double
The width-to-height ratio for the selection.
Remarks
Setting AspectRatio to zero will disable the feature.
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:atala="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <atala:AtalaImageViewer Name="Viewer">
      <atala:AtalaImageViewer.MouseTool>
        <atala:SelectionMouseTool AspectRatio="1.5"/>
      </atala:AtalaImageViewer.MouseTool>
    </atala:AtalaImageViewer>
  </Grid>
</Window>
Copy
 Me.Viewer.MouseTool = SelectionMouseTool tool = New SelectionMouseTool()
tool.AspectRatio = 1.5
Me.Viewer.MouseTool = tool
Copy
 SelectionMouseTool tool = new SelectionMouseTool();
tool.AspectRatio = 1.5;
this.Viewer.MouseTool = tool;
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.AspectRatioCornerMode Property

SelectionMouseToolAspectRatioCornerMode Property

Gets or sets behavior applied when a selection corner is dragged and AspectRatio is greater than zero.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AspectRatioMode AspectRatioCornerMode { get; set; }
Public Property AspectRatioCornerMode As AspectRatioMode
    Get
    Set

Property Value

Type: AspectRatioMode
The behavior applied when a selection corner is dragged.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.ConfineSelectionToImage Property

SelectionMouseToolConfineSelectionToImage Property

Gets or sets a value indicating whether the selection is confined to the image area.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ConfineSelectionToImage { get; set; }
Public Property ConfineSelectionToImage As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the selection is confined to the image.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.Fill Property

SelectionMouseToolFill Property

Gets or sets the brush used to fill the selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Brush Fill { get; set; }
Public Property Fill As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill the selection.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.IsAnimated Property

SelectionMouseToolIsAnimated Property

Gets or sets a value indicating whether the built-in animation will be used.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsAnimated { get; set; }
Public Property IsAnimated As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the built-in animation will be used.
Remarks
If the Pen property has been set, the animation feature is ignored.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.IsEmpty Property

SelectionMouseToolIsEmpty Property

Gets a value indicating if the tool has a valid selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the tool has a valid selection.
Remarks
If either the width or height of the selection Bounds is zero, this property will return false.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.IsMasked Property

SelectionMouseToolIsMasked Property

Gets or sets a value indicating whether the selection will use masking.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMasked { get; set; }
Public Property IsMasked As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the selection will use masking.
Remarks

Masking is a feature in which the image is processed with the MaskedImageCommand except for the selected area.

Masked selection cannot be used with the freehand selection type.

See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.LineBackgroundColor Property

SelectionMouseToolLineBackgroundColor Property

Gets or sets the color used as the background line.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color LineBackgroundColor { get; set; }
Public Property LineBackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The color used for the background line.
Remarks
Using a background line color helps the selection visibility when selecting over dark colored images.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.LineColor Property

SelectionMouseToolLineColor Property

Gets or sets the line color used with the built-in pen.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set

Property Value

Type: Color
The line color for the built-in pen.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.MaintainPenThickness Property

SelectionMouseToolMaintainPenThickness Property

Gets or sets a value indicating whether the pen thickness will render at the same size or if it will be scaled along with the image zoom level.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MaintainPenThickness { get; set; }
Public Property MaintainPenThickness As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the pen thickness will render at the same size or if it will be scaled along with the image zoom level.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.MaskedImageCommand Property

SelectionMouseToolMaskedImageCommand Property

Gets or sets the ImageCommand used to for selection masking.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageCommand MaskedImageCommand { get; set; }
Public Property MaskedImageCommand As ImageCommand
    Get
    Set

Property Value

Type: ImageCommand
The ImageCommand used for selection masking.
Remarks
The default ImageCommand used is the BrightnessContrastCommand with its brightness level set to -40.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.Pen Property

SelectionMouseToolPen Property

Gets or sets the pen used to draw the selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pen Pen { get; set; }
Public Property Pen As Pen
    Get
    Set

Property Value

Type: Pen
The pen used to draw the selection.
Remarks
When this property is set, the built-in animation feature will be disabled. This allows developer to apply their own custom animations.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.SelectionType Property

SelectionMouseToolSelectionType Property

Gets or sets the type of selection to render.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseToolType SelectionType { get; set; }
Public Property SelectionType As SelectionMouseToolType
    Get
    Set

Property Value

Type: SelectionMouseToolType
The type of selection to render.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.SupportedMouseToolBehaviors Property

SelectionMouseToolSupportedMouseToolBehaviors Property

Gets an array of supported MouseToolBehavior values for this tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override MouseToolBehavior[] SupportedMouseToolBehaviors { get; }
Public Overrides ReadOnly Property SupportedMouseToolBehaviors As MouseToolBehavior()
    Get

Property Value

Type: MouseToolBehavior
An array of supported behaviors, defaulting to ClickAndDrag and MultiClick.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Methods

The SelectionMouseTool type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of SelectionMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetRegion | Returns a RegionOfInterest object containing the region for the selection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Overrides MouseToolHitTestCore(Point).)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Overrides MouseToolOnImageChanged.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Overrides MouseToolOnRender(DrawingContext).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.CreateInstanceCore Method

SelectionMouseToolCreateInstanceCore Method

Returns a new instance of SelectionMouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Freezable CreateInstanceCore()
Protected Overrides Function CreateInstanceCore As Freezable

Return Value

Type: Freezable
A new instance of SelectionMouseTool.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.GetRegion Method

SelectionMouseToolGetRegion Method

Returns a RegionOfInterest object containing the region for the selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RegionOfInterest GetRegion()
Public Function GetRegion As RegionOfInterest

Return Value

Type: RegionOfInterest
A RegionOfInterest object for the selection.
Remarks
The RegionOfInterest object can be used with ImageRegionCommand classes so only the selected region will be processed.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.HitTestCore Method

SelectionMouseToolHitTestCore Method

Called by the AtalaImageViewer to determine if a point is over the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool HitTestCore(
    Point point
)
Protected Overrides Function HitTestCore (
    point As Point
) As Boolean

Parameters

point
Type: System.WindowsPoint
The point in image coordinates.

Return Value

Type: Boolean
True if the point is over the MouseTool.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.OnImageChanged Method

SelectionMouseToolOnImageChanged Method

Called when the image in the AtalaImageViewer has changed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnImageChanged()
Protected Overrides Sub OnImageChanged
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.OnMouseDown Method

SelectionMouseToolOnMouseDown Method

Called when a mouse button is pressed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.OnMouseMove Method

SelectionMouseToolOnMouseMove Method

Called when the mouse is moved over the mouse tool bounds or when dragging the tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.OnMouseUp Method

SelectionMouseToolOnMouseUp Method

Called when the mouse button is released.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.OnRender Method

SelectionMouseToolOnRender Method

Called when the tool must render itself.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
A DrawingContext used to render.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Events

The SelectionMouseTool type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | SelectionChanged | Raised when the selection has finished being modified.
Public event | SelectionChanging | Raised while the selection is being modfied to provide live feedback to the user.
Top
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.SelectionChanged Event

SelectionMouseToolSelectionChanged Event

Raised when the selection has finished being modified.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<SelectionMouseToolChangedEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of SelectionMouseToolChangedEventArgs)

Value

Type: SystemEventHandlerSelectionMouseToolChangedEventArgs
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.SelectionChanging Event

SelectionMouseToolSelectionChanging Event

Raised while the selection is being modfied to provide live feedback to the user.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<SelectionMouseToolChangedEventArgs> SelectionChanging
Public Event SelectionChanging As EventHandler(Of SelectionMouseToolChangedEventArgs)

Value

Type: SystemEventHandlerSelectionMouseToolChangedEventArgs
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool Fields

The SelectionMouseTool type exposes the following members.

Fields
Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
AspectRatioCornerModeProperty | Identifies the AspectRatioCornerMode dependency property.
AspectRatioProperty | Identifies the AspectRatio dependency property.
ConfineSelectionToImageProperty | Identifies the ConfineSelectionToImage dependency property.
FillProperty | Identifies the Fill dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
IsMaskedProperty | Identifies the IsMasked dependency property.
LineBackgroundColorProperty | Identifies the LineBackgroundColor dependency property.
LineColorProperty | Identifies the LineColor dependency property.
MaintainPenThicknessProperty | Identifies the MaintainPenThickness dependency property.
MaskedImageCommandProperty | Identifies the MaskedImageCommand dependency property.
PenProperty | Identifies the Pen dependency property.
SelectionTypeProperty | Identifies the SelectionType dependency property.
Top
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.AnimationDurationProperty Field

SelectionMouseToolAnimationDurationProperty Field

Identifies the AnimationDuration dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AnimationDurationProperty
Public Shared ReadOnly AnimationDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the AnimationDuration dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.AspectRatioCornerModeProperty Field

SelectionMouseToolAspectRatioCornerModeProperty Field

Identifies the AspectRatioCornerMode dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AspectRatioCornerModeProperty
Public Shared ReadOnly AspectRatioCornerModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the AspectRatioCornerMode dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.AspectRatioProperty Field

SelectionMouseToolAspectRatioProperty Field

Identifies the AspectRatio dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AspectRatioProperty
Public Shared ReadOnly AspectRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the AspectRatio dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.ConfineSelectionToImageProperty Field

SelectionMouseToolConfineSelectionToImageProperty Field

Identifies the ConfineSelectionToImage dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ConfineSelectionToImageProperty
Public Shared ReadOnly ConfineSelectionToImageProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the ConfineSelectionToImage dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.FillProperty Field

SelectionMouseToolFillProperty Field

Identifies the Fill dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FillProperty
Public Shared ReadOnly FillProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Fill dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.IsAnimatedProperty Field

SelectionMouseToolIsAnimatedProperty Field

Identifies the IsAnimated dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAnimatedProperty
Public Shared ReadOnly IsAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the IsAnimated dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.IsMaskedProperty Field

SelectionMouseToolIsMaskedProperty Field

Identifies the IsMasked dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaskedProperty
Public Shared ReadOnly IsMaskedProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the IsMasked dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.LineBackgroundColorProperty Field

SelectionMouseToolLineBackgroundColorProperty Field

Identifies the LineBackgroundColor dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineBackgroundColorProperty
Public Shared ReadOnly LineBackgroundColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the LineBackgroundColor dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.LineColorProperty Field

SelectionMouseToolLineColorProperty Field

Identifies the LineColor dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineColorProperty
Public Shared ReadOnly LineColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the LineColor dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.MaintainPenThicknessProperty Field

SelectionMouseToolMaintainPenThicknessProperty Field

Identifies the MaintainPenThickness dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaintainPenThicknessProperty
Public Shared ReadOnly MaintainPenThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MaintainPenThickness dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.MaskedImageCommandProperty Field

SelectionMouseToolMaskedImageCommandProperty Field

Identifies the MaskedImageCommand dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskedImageCommandProperty
Public Shared ReadOnly MaskedImageCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MaskedImageCommand dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.PenProperty Field

SelectionMouseToolPenProperty Field

Identifies the Pen dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty PenProperty
Public Shared ReadOnly PenProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Pen dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseTool.SelectionTypeProperty Field

SelectionMouseToolSelectionTypeProperty Field

Identifies the SelectionType dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionTypeProperty
Public Shared ReadOnly SelectionTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the SelectionType dependency property.
See Also

Reference

SelectionMouseTool Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseToolChangedEventArgs Class

This class is used by the SelectionChanged and SelectionChanging events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Imaging.WpfSelectionMouseToolChangedEventArgs

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SelectionMouseToolChangedEventArgs : EventArgs
Public Class SelectionMouseToolChangedEventArgs
    Inherits EventArgs

The SelectionMouseToolChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionMouseToolChangedEventArgs | Creates a new instance of SelectionMouseToolChangedEventArgs.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the bounds for the selection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


SelectionMouseToolChangedEventArgs Constructor

Creates a new instance of SelectionMouseToolChangedEventArgs.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SelectionMouseToolChangedEventArgs(
    Rect bounds
)
Public Sub New (
    bounds As Rect
)

Parameters

bounds
Type: System.WindowsRect
The bounds for the new selection.
See Also

Reference

SelectionMouseToolChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseToolChangedEventArgs Properties

The SelectionMouseToolChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the bounds for the selection.
Top
See Also

Reference

SelectionMouseToolChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseToolChangedEventArgs.Bounds Property

SelectionMouseToolChangedEventArgsBounds Property

Gets the bounds for the selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rect Bounds { get; }
Public ReadOnly Property Bounds As Rect
    Get

Property Value

Type: Rect
The bounds for the selection.
See Also

Reference

SelectionMouseToolChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseToolChangedEventArgs Methods

The SelectionMouseToolChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectionMouseToolChangedEventArgs Class
Atalasoft.Imaging.Wpf Namespace


SelectionMouseToolType Enumeration

Describes the type of selection that will be drawn.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SelectionMouseToolType
Public Enumeration SelectionMouseToolType
Members
Member name | Description
Rectangle | A rectangular selection.
Ellipse | An elliptical selection.
Freehand | A freehand selection.
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


WpfConverter Class

This is a static class used to convert an AtalaImage to a BitmapSource and back.
Inheritance Hierarchy
SystemObject
Atalasoft.Imaging.WpfWpfConverter

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static class WpfConverter
Public NotInheritable Class WpfConverter

The WpfConverter type exposes the following members.

Methods
Name | Description
AtalaImageToBitmapSource | Converts an AtalaImage to a BitmapSource.
AtalaToWpfPixelFormat | Converts an Atalasoft.Imaging.PixelFormat to a System.Windows.Media.PixelFormat equivalent.
BitmapSourceToAtalaImage | Converts a BitmapSource to an AtalaImage.
WpfToAtalaPixelFormat | Converts an System.Windows.Media.PixelFormat to a Atalasoft.Imaging.PixelFormat equivalent.
Top
Examples
Copy
 Dim dlg As Microsoft.Win32.OpenFileDialog = New Microsoft.Win32.OpenFileDialog()
dlg.Filter = "Images|*.jpg;*.png;*.tif;*.gif;*.bmp;*.wdp;*.xps"
If dlg.ShowDialog(Me).Value Then
    Dim image As Atalasoft.Imaging.AtalaImage = New Atalasoft.Imaging.AtalaImage(dlg.FileName)
    Dim source As BitmapSource = WpfConverter.AtalaImageToBitmapSource(image)
    image.Dispose()

    Me.Viewer.Source = source
End If
Copy
 Microsoft.Win32.OpenFileDialog dlg = new Microsoft.Win32.OpenFileDialog();
dlg.Filter = "Images|*.jpg;*.png;*.tif;*.gif;*.bmp;*.wdp;*.xps";
if (dlg.ShowDialog(this).Value)
{
    Atalasoft.Imaging.AtalaImage image = new Atalasoft.Imaging.AtalaImage(dlg.FileName);
    BitmapSource source = WpfConverter.AtalaImageToBitmapSource(image);
    image.Dispose();

    this.Viewer.Source = source;
}
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


WpfConverter Methods

The WpfConverter type exposes the following members.

Methods
Name | Description
AtalaImageToBitmapSource | Converts an AtalaImage to a BitmapSource.
AtalaToWpfPixelFormat | Converts an Atalasoft.Imaging.PixelFormat to a System.Windows.Media.PixelFormat equivalent.
BitmapSourceToAtalaImage | Converts a BitmapSource to an AtalaImage.
WpfToAtalaPixelFormat | Converts an System.Windows.Media.PixelFormat to a Atalasoft.Imaging.PixelFormat equivalent.
Top
See Also

Reference

WpfConverter Class
Atalasoft.Imaging.Wpf Namespace


WpfConverter.AtalaImageToBitmapSource Method

WpfConverterAtalaImageToBitmapSource Method

Converts an AtalaImage to a BitmapSource.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static BitmapSource AtalaImageToBitmapSource(
    AtalaImage atalaImage
)
Public Shared Function AtalaImageToBitmapSource (
    atalaImage As AtalaImage
) As BitmapSource

Parameters

atalaImage
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to convert.

Return Value

Type: BitmapSource
A BitmapSource for the image.
Remarks
The AtalaImage can be disposed after the conversion to free up memory.
See Also

Reference

WpfConverter Class
Atalasoft.Imaging.Wpf Namespace


WpfConverter.AtalaToWpfPixelFormat Method

WpfConverterAtalaToWpfPixelFormat Method

Converts an Atalasoft.Imaging.PixelFormat to a System.Windows.Media.PixelFormat equivalent.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PixelFormat AtalaToWpfPixelFormat(
    PixelFormat atalaFormat
)
Public Shared Function AtalaToWpfPixelFormat (
    atalaFormat As PixelFormat
) As PixelFormat

Parameters

atalaFormat
Type: Atalasoft.ImagingPixelFormat
The Atalasoft.Imaging.PixelFormat to convert.

Return Value

Type: PixelFormat
The equivalent System.Windows.Media.PixelFormat.
Exceptions
Exception | Condition
 | Thrown if there is no equivalent format.
See Also

Reference

WpfConverter Class
Atalasoft.Imaging.Wpf Namespace


WpfConverter.BitmapSourceToAtalaImage Method

WpfConverterBitmapSourceToAtalaImage Method

Converts a BitmapSource to an AtalaImage.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalaImage BitmapSourceToAtalaImage(
    BitmapSource bitmapSource
)
Public Shared Function BitmapSourceToAtalaImage (
    bitmapSource As BitmapSource
) As AtalaImage

Parameters

bitmapSource
Type: System.Windows.Media.ImagingBitmapSource
The BitmapSource to convert.

Return Value

Type: AtalaImage
A copy of the image as an AtalaImage object.
Remarks
The image data is copied from the BitmapSource. After processing the AtalaImage, a new BitmapSource can be created from the AtalaImageToBitmapSource(AtalaImage) method.
See Also

Reference

WpfConverter Class
Atalasoft.Imaging.Wpf Namespace


WpfConverter.WpfToAtalaPixelFormat Method

WpfConverterWpfToAtalaPixelFormat Method

Converts an System.Windows.Media.PixelFormat to a Atalasoft.Imaging.PixelFormat equivalent.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PixelFormat WpfToAtalaPixelFormat(
    PixelFormat wpfFormat
)
Public Shared Function WpfToAtalaPixelFormat (
    wpfFormat As PixelFormat
) As PixelFormat

Parameters

wpfFormat
Type: System.Windows.MediaPixelFormat
The System.Windows.Media.PixelFormat to convert.

Return Value

Type: PixelFormat
The equivalent Atalasoft.Imaging.PixelFormat.
Exceptions
Exception | Condition
 | Thrown if there is no equivalent format.
See Also

Reference

WpfConverter Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Class

This tool is used to zoom in and out of an image by either clicking a mouse button or selecting an area of the image which will be zoomed to fit in the viewer.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Atalasoft.Imaging.WpfMouseTool
Atalasoft.Imaging.WpfZoomMouseTool

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ZoomMouseTool : MouseTool
Public Class ZoomMouseTool
    Inherits MouseTool

The ZoomMouseTool type exposes the following members.

Constructors
 | Name | Description
Public method | ZoomMouseTool | Creates a new instance of ZoomMouseTool in which the left mouse button is for zooming in and the right button is used for zooming out.
Public method | ZoomMouseTool(ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the tool used for all mouse buttons.
Public method | ZoomMouseTool(ZoomToolMode, ZoomToolMode, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the tool to use for common mouse buttons.
Public method | ZoomMouseTool(Double, Boolean, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean) | Creates a new instance of ZoomMouseTool specifying the pen, fill and common properties.
Public method | ZoomMouseTool(Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean) | Creates a new instance of ZoomMouseTool specifying the pen, tool behavior and zoom level parameters.
Public method | ZoomMouseTool(Double, Boolean, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode, ZoomToolMode, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the pen, behavior and button tools.
Public method | ZoomMouseTool(Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the pen, tool behavior, zoom level parameters and tool used for all buttons.
Public method | ZoomMouseTool(Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode, ZoomToolMode, ZoomToolMode, ZoomToolMode, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying all of its property values.
Top
Properties
 | Name | Description
Public property | AutoZoomSelection | Gets or sets a value indicating whether the tool will automatically perform a zoom selection when an active button is pressed and dragged.
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | CenterZoom | Gets or sets a value indicating whether a zoom in and zoom out will scroll the pixel clicked to the center of the viewer.
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Gets or sets the brush used to fill the zoom selection.
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | LeftButtonTool | Gets or sets the tool to use for a left button click.
Public property | LineBackgroundColor | Gets or sets the color used behind the zoom selection line.
Public property | MaintainPenThickness | Gets or sets a value indicating whether the thickness of the zoom selection pen is rendered at the same size or scaled along with the image zoom value.
Public property | MaximumZoomLevel | Gets or sets the maximum allows zoom level.
Public property | MiddleButtonTool | Gets or sets the tool used for the middle mouse button.
Public property | MinimumZoomLevel | Gets or sets the minimum allowed zoom level.
Public property | Pen | Gets or sets the pen to use for the zoom selection.
Public property | RightButtonTool | Gets or sets the tool to use for the right mouse button.
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Public property | XButton1Tool | Gets or sets the tool used for the XButton1 mouse button.
Public property | XButton2Tool | Gets or sets the tool used for the XButton2 mouse button.
Public property | ZoomChangePercentage | Gets or sets the percentage to change the zoom for each mouse click.
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of ZoomMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Overrides MouseToolHitTestCore(Point).)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Inherited from MouseTool.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Overrides MouseToolOnRender(DrawingContext).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Protected method | PerformZoom | This method applies the actual zoom change to the AtalaImageViewer.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | SelectionChanged | Raised when the selection has finished being modified.
Public event | SelectionChanging | Raised while the selection is being modfied to provide live feedback to the user.
Top
Fields
Name | Description
AutoZoomSelectionProperty | Identifies the AutoZoomSelection dependency property.
CenterZoomProperty | Identifies the CenterZoom dependency property.
FillProperty | Identifies the Fill dependency property.
LeftButtonToolProperty | Identifies the LeftButtonTool dependency property.
LineBackgroundColorProperty | Identifies the LineBackgroundColor dependency property.
MaintainPenThicknessProperty | Identifies the MaintainPenThickness dependency property.
MaximumZoomLevelProperty | Identifies the MaximumZoomLevel dependency property.
MiddleButtonToolProperty | Identifies the MiddleButtonTool dependency property.
MinimumZoomLevelProperty | Identifies the MinimumZoomLevel dependency property.
PenProperty | Identifies the Pen dependency property.
RightButtonToolProperty | Identifies the RightButtonTool dependency property.
XButton1ToolProperty | Identifies the XButton1Tool dependency property.
XButton2ToolProperty | Identifies the XButton2Tool dependency property.
ZoomChangePercentageProperty | Identifies the ZoomChangePercentage dependency property.
Top
Examples
Copy
 <Window x:Class="WpfControlsDemo.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:atala="clr-namespace:Atalasoft.Imaging.Wpf;assembly=Atalasoft.dotImage.Wpf"
    Title="WPF Controls Demo" Height="565" Width="756"
    Background="White"
    >
  <Grid>
    <atala:AtalaImageViewer Name="Viewer">
      <atala:AtalaImageViewer.MouseTool>
        <atala:ZoomMouseTool ZoomChangePercentage="0.2" LeftButtonTool="ZoomSelection"/>
      </atala:AtalaImageViewer.MouseTool>
    </atala:AtalaImageViewer>
  </Grid>
</Window>
Copy
Me.Viewer.MouseTool = New ZoomMouseTool(0.2, False, False, MouseToolBehavior.ClickAndDrag, Nothing, Colors.White, Nothing, True, ZoomToolMode.ZoomSelection, ZoomToolMode.None, ZoomToolMode.None)
Copy
this.Viewer.MouseTool = new ZoomMouseTool(0.2, false, false, MouseToolBehavior.ClickAndDrag, null, Colors.White, null, true, ZoomToolMode.ZoomSelection, ZoomToolMode.None, ZoomToolMode.None);
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor

Creates a new instance of ZoomMouseTool.
Overload List
 | Name | Description
Public method | ZoomMouseTool | Creates a new instance of ZoomMouseTool in which the left mouse button is for zooming in and the right button is used for zooming out.
Public method | ZoomMouseTool(ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the tool used for all mouse buttons.
Public method | ZoomMouseTool(ZoomToolMode, ZoomToolMode, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the tool to use for common mouse buttons.
Public method | ZoomMouseTool(Double, Boolean, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean) | Creates a new instance of ZoomMouseTool specifying the pen, fill and common properties.
Public method | ZoomMouseTool(Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean) | Creates a new instance of ZoomMouseTool specifying the pen, tool behavior and zoom level parameters.
Public method | ZoomMouseTool(Double, Boolean, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode, ZoomToolMode, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the pen, behavior and button tools.
Public method | ZoomMouseTool(Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying the pen, tool behavior, zoom level parameters and tool used for all buttons.
Public method | ZoomMouseTool(Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode, ZoomToolMode, ZoomToolMode, ZoomToolMode, ZoomToolMode) | Creates a new instance of ZoomMouseTool specifying all of its property values.
Top
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor

Creates a new instance of ZoomMouseTool in which the left mouse button is for zooming in and the right button is used for zooming out.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool()
Public Sub New
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (ZoomToolMode)

Creates a new instance of ZoomMouseTool specifying the tool used for all mouse buttons.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    ZoomToolMode toolForAllButtons
)
Public Sub New (
    toolForAllButtons As ZoomToolMode
)

Parameters

toolForAllButtons
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool to use for any mouse button.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (ZoomToolMode, ZoomToolMode, ZoomToolMode)

Creates a new instance of ZoomMouseTool specifying the tool to use for common mouse buttons.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    ZoomToolMode leftButtonTool,
    ZoomToolMode middleButtonTool,
    ZoomToolMode rightButtonTool
)
Public Sub New (
    leftButtonTool As ZoomToolMode,
    middleButtonTool As ZoomToolMode,
    rightButtonTool As ZoomToolMode
)

Parameters

leftButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the left mouse button is clicked.
middleButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the middle mouse button is clicked.
rightButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the right mouse button is clicked.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (Double, Boolean, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean)

Creates a new instance of ZoomMouseTool specifying the pen, fill and common properties.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    double zoomChangePercentage,
    bool centerZoom,
    bool autoZoomSelection,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness
)
Public Sub New (
    zoomChangePercentage As Double,
    centerZoom As Boolean,
    autoZoomSelection As Boolean,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean
)

Parameters

zoomChangePercentage
Type: SystemDouble
The percentage the zoom will change each time to tool is applied. This has no effect when ZoomSelection is used.
centerZoom
Type: SystemBoolean
Indicates whether the pixel clicked will be centered in the viewer.
autoZoomSelection
Type: SystemBoolean
If true, the tool will automatically switch to ZoomSelection mode if the user clicks and drags the mouse. Clicks without moving the mouse will use the tool specified for the mouse button.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates if the ZoomSelection will use the click and drag or two click method.
pen
Type: System.Windows.MediaPen
The pen to use for the selection. If null (Nothing in VB), a default pen will be used.
lineBackgroundColor
Type: System.Windows.MediaColor
The color used behind the selection line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates if the pen thickness will render the same size regardless of the zoom level.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean)

Creates a new instance of ZoomMouseTool specifying the pen, tool behavior and zoom level parameters.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    double zoomChangePercentage,
    bool centerZoom,
    double minimumZoomLevel,
    double maximumZoomLevel,
    bool autoZoomSelection,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness
)
Public Sub New (
    zoomChangePercentage As Double,
    centerZoom As Boolean,
    minimumZoomLevel As Double,
    maximumZoomLevel As Double,
    autoZoomSelection As Boolean,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean
)

Parameters

zoomChangePercentage
Type: SystemDouble
The percentage the zoom will change each time to tool is applied. This has no effect when ZoomSelection is used.
centerZoom
Type: SystemBoolean
Indicates whether the pixel clicked will be centered in the viewer.
minimumZoomLevel
Type: SystemDouble
Specifies the minimum zoom level allowed.
maximumZoomLevel
Type: SystemDouble
Specifies the maximum zoom level allowed.
autoZoomSelection
Type: SystemBoolean
If true, the tool will automatically switch to ZoomSelection mode if the user clicks and drags the mouse. Clicks without moving the mouse will use the tool specified for the mouse button.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates if the ZoomSelection will use the click and drag or two click method.
pen
Type: System.Windows.MediaPen
The pen to use for the selection. If null (Nothing in VB), a default pen will be used.
lineBackgroundColor
Type: System.Windows.MediaColor
The color used behind the selection line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates if the pen thickness will render the same size regardless of the zoom level.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (Double, Boolean, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode, ZoomToolMode, ZoomToolMode)

Creates a new instance of ZoomMouseTool specifying the pen, behavior and button tools.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    double zoomChangePercentage,
    bool centerZoom,
    bool autoZoomSelection,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    ZoomToolMode leftButtonTool,
    ZoomToolMode middleButtonTool,
    ZoomToolMode rightButtonTool
)
Public Sub New (
    zoomChangePercentage As Double,
    centerZoom As Boolean,
    autoZoomSelection As Boolean,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    leftButtonTool As ZoomToolMode,
    middleButtonTool As ZoomToolMode,
    rightButtonTool As ZoomToolMode
)

Parameters

zoomChangePercentage
Type: SystemDouble
The percentage the zoom will change each time to tool is applied. This has no effect when ZoomSelection is used.
centerZoom
Type: SystemBoolean
Indicates whether the pixel clicked will be centered in the viewer.
autoZoomSelection
Type: SystemBoolean
If true, the tool will automatically switch to ZoomSelection mode if the user clicks and drags the mouse. Clicks without moving the mouse will use the tool specified for the mouse button.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates if the ZoomSelection will use the click and drag or two click method.
pen
Type: System.Windows.MediaPen
The pen to use for the selection. If null (Nothing in VB), a default pen will be used.
lineBackgroundColor
Type: System.Windows.MediaColor
The color used behind the selection line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates if the pen thickness will render the same size regardless of the zoom level.
leftButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the left mouse button is clicked.
middleButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the middle mouse button is clicked.
rightButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the right mouse button is clicked.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode)

Creates a new instance of ZoomMouseTool specifying the pen, tool behavior, zoom level parameters and tool used for all buttons.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    double zoomChangePercentage,
    bool centerZoom,
    double minimumZoomLevel,
    double maximumZoomLevel,
    bool autoZoomSelection,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    ZoomToolMode toolForAllButtons
)
Public Sub New (
    zoomChangePercentage As Double,
    centerZoom As Boolean,
    minimumZoomLevel As Double,
    maximumZoomLevel As Double,
    autoZoomSelection As Boolean,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    toolForAllButtons As ZoomToolMode
)

Parameters

zoomChangePercentage
Type: SystemDouble
The percentage the zoom will change each time to tool is applied. This has no effect when ZoomSelection is used.
centerZoom
Type: SystemBoolean
Indicates whether the pixel clicked will be centered in the viewer.
minimumZoomLevel
Type: SystemDouble
Specifies the minimum zoom level allowed.
maximumZoomLevel
Type: SystemDouble
Specifies the maximum zoom level allowed.
autoZoomSelection
Type: SystemBoolean
If true, the tool will automatically switch to ZoomSelection mode if the user clicks and drags the mouse. Clicks without moving the mouse will use the tool specified for the mouse button.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates if the ZoomSelection will use the click and drag or two click method.
pen
Type: System.Windows.MediaPen
The pen to use for the selection. If null (Nothing in VB), a default pen will be used.
lineBackgroundColor
Type: System.Windows.MediaColor
The color used behind the selection line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates if the pen thickness will render the same size regardless of the zoom level.
toolForAllButtons
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool to use for any mouse button.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Constructor (Double, Boolean, Double, Double, Boolean, MouseToolBehavior, Pen, Color, Brush, Boolean, ZoomToolMode, ZoomToolMode, ZoomToolMode, ZoomToolMode, ZoomToolMode)

Creates a new instance of ZoomMouseTool specifying all of its property values.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomMouseTool(
    double zoomChangePercentage,
    bool centerZoom,
    double minimumZoomLevel,
    double maximumZoomLevel,
    bool autoZoomSelection,
    MouseToolBehavior toolBehavior,
    Pen pen,
    Color lineBackgroundColor,
    Brush fill,
    bool maintainPenThickness,
    ZoomToolMode leftButtonTool,
    ZoomToolMode middleButtonTool,
    ZoomToolMode rightButtonTool,
    ZoomToolMode xButton1Tool,
    ZoomToolMode xButton2Tool
)
Public Sub New (
    zoomChangePercentage As Double,
    centerZoom As Boolean,
    minimumZoomLevel As Double,
    maximumZoomLevel As Double,
    autoZoomSelection As Boolean,
    toolBehavior As MouseToolBehavior,
    pen As Pen,
    lineBackgroundColor As Color,
    fill As Brush,
    maintainPenThickness As Boolean,
    leftButtonTool As ZoomToolMode,
    middleButtonTool As ZoomToolMode,
    rightButtonTool As ZoomToolMode,
    xButton1Tool As ZoomToolMode,
    xButton2Tool As ZoomToolMode
)

Parameters

zoomChangePercentage
Type: SystemDouble
The percentage the zoom will change each time to tool is applied. This has no effect when ZoomSelection is used.
centerZoom
Type: SystemBoolean
Indicates whether the pixel clicked will be centered in the viewer.
minimumZoomLevel
Type: SystemDouble
Specifies the minimum zoom level allowed.
maximumZoomLevel
Type: SystemDouble
Specifies the maximum zoom level allowed.
autoZoomSelection
Type: SystemBoolean
If true, the tool will automatically switch to ZoomSelection mode if the user clicks and drags the mouse. Clicks without moving the mouse will use the tool specified for the mouse button.
toolBehavior
Type: Atalasoft.Imaging.WpfMouseToolBehavior
Indicates if the ZoomSelection will use the click and drag or two click method.
pen
Type: System.Windows.MediaPen
The pen to use for the selection. If null (Nothing in VB), a default pen will be used.
lineBackgroundColor
Type: System.Windows.MediaColor
The color used behind the selection line.
fill
Type: System.Windows.MediaBrush
The brush used to fill the selection.
maintainPenThickness
Type: SystemBoolean
Indicates if the pen thickness will render the same size regardless of the zoom level.
leftButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the left mouse button is clicked.
middleButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the middle mouse button is clicked.
rightButtonTool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the right mouse button is clicked.
xButton1Tool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the XButton1 is clicked.
xButton2Tool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool used when the XButton2 is clicked.
See Also

Reference

ZoomMouseTool Class
ZoomMouseTool Overload
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Properties

The ZoomMouseTool type exposes the following members.

Properties
 | Name | Description
Public property | AutoZoomSelection | Gets or sets a value indicating whether the tool will automatically perform a zoom selection when an active button is pressed and dragged.
Public property | Bounds | Gets or sets the bounds used by the MouseTool. (Inherited from MouseTool.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | CenterZoom | Gets or sets a value indicating whether a zoom in and zoom out will scroll the pixel clicked to the center of the viewer.
Public property | Cursor | Gets or sets the cursor for the MouseTool. (Inherited from MouseTool.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Fill | Gets or sets the brush used to fill the zoom selection.
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsCreating | Gets a value indicating whether the mouse tool is currently being created. (Inherited from MouseTool.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | LeftButtonTool | Gets or sets the tool to use for a left button click.
Public property | LineBackgroundColor | Gets or sets the color used behind the zoom selection line.
Public property | MaintainPenThickness | Gets or sets a value indicating whether the thickness of the zoom selection pen is rendered at the same size or scaled along with the image zoom value.
Public property | MaximumZoomLevel | Gets or sets the maximum allows zoom level.
Public property | MiddleButtonTool | Gets or sets the tool used for the middle mouse button.
Public property | MinimumZoomLevel | Gets or sets the minimum allowed zoom level.
Public property | Pen | Gets or sets the pen to use for the zoom selection.
Public property | RightButtonTool | Gets or sets the tool to use for the right mouse button.
Public property | SupportedMouseToolBehaviors | Gets an array of supported MouseToolBehavior values for this tool. (Overrides MouseToolSupportedMouseToolBehaviors.)
Public property | ToolBehavior | Identifies the ToolBehavior dependency property. (Inherited from MouseTool.)
Protected property | Viewer | Gets the AtalaImageViewer which is using the MouseTool. (Inherited from MouseTool.)
Public property | XButton1Tool | Gets or sets the tool used for the XButton1 mouse button.
Public property | XButton2Tool | Gets or sets the tool used for the XButton2 mouse button.
Public property | ZoomChangePercentage | Gets or sets the percentage to change the zoom for each mouse click.
Top
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.AutoZoomSelection Property

ZoomMouseToolAutoZoomSelection Property

Gets or sets a value indicating whether the tool will automatically perform a zoom selection when an active button is pressed and dragged.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoZoomSelection { get; set; }
Public Property AutoZoomSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether a zoom selection is automatically taken when the user clicks and drags.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.CenterZoom Property

ZoomMouseToolCenterZoom Property

Gets or sets a value indicating whether a zoom in and zoom out will scroll the pixel clicked to the center of the viewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CenterZoom { get; set; }
Public Property CenterZoom As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the pixel clicked will be scrolled to the center of the viewer.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.Fill Property

ZoomMouseToolFill Property

Gets or sets the brush used to fill the zoom selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Brush Fill { get; set; }
Public Property Fill As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill the zoom selection.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.LeftButtonTool Property

ZoomMouseToolLeftButtonTool Property

Gets or sets the tool to use for a left button click.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomToolMode LeftButtonTool { get; set; }
Public Property LeftButtonTool As ZoomToolMode
    Get
    Set

Property Value

Type: ZoomToolMode
The tool to use for a left button click. The default value is ZoomIn.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.LineBackgroundColor Property

ZoomMouseToolLineBackgroundColor Property

Gets or sets the color used behind the zoom selection line.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color LineBackgroundColor { get; set; }
Public Property LineBackgroundColor As Color
    Get
    Set

Property Value

Type: Color
The color behind the zoom selection line.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MaintainPenThickness Property

ZoomMouseToolMaintainPenThickness Property

Gets or sets a value indicating whether the thickness of the zoom selection pen is rendered at the same size or scaled along with the image zoom value.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MaintainPenThickness { get; set; }
Public Property MaintainPenThickness As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the zoom selection pen thickness is kept the same size.
Remarks
Setting this property to true will keep the pen at the same size. A setting of false will allow the pen to scale with the zoom level of the image.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MaximumZoomLevel Property

ZoomMouseToolMaximumZoomLevel Property

Gets or sets the maximum allows zoom level.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaximumZoomLevel { get; set; }
Public Property MaximumZoomLevel As Double
    Get
    Set

Property Value

Type: Double
The maximum allows zoom level. This value defaults to 10,000.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MiddleButtonTool Property

ZoomMouseToolMiddleButtonTool Property

Gets or sets the tool used for the middle mouse button.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomToolMode MiddleButtonTool { get; set; }
Public Property MiddleButtonTool As ZoomToolMode
    Get
    Set

Property Value

Type: ZoomToolMode
The tool for the middle mouse button.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MinimumZoomLevel Property

ZoomMouseToolMinimumZoomLevel Property

Gets or sets the minimum allowed zoom level.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MinimumZoomLevel { get; set; }
Public Property MinimumZoomLevel As Double
    Get
    Set

Property Value

Type: Double
The minimum allowed zoom level. This value defaults to 0.0001.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.Pen Property

ZoomMouseToolPen Property

Gets or sets the pen to use for the zoom selection.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pen Pen { get; set; }
Public Property Pen As Pen
    Get
    Set

Property Value

Type: Pen
The pen to use for the zoom selection.
Remarks
Setting this property to null (Nothing in VB) will cause a default (black 1-pixel dashed) pen to be used.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.RightButtonTool Property

ZoomMouseToolRightButtonTool Property

Gets or sets the tool to use for the right mouse button.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomToolMode RightButtonTool { get; set; }
Public Property RightButtonTool As ZoomToolMode
    Get
    Set

Property Value

Type: ZoomToolMode
The tool for the right mouse button.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.SupportedMouseToolBehaviors Property

ZoomMouseToolSupportedMouseToolBehaviors Property

Gets an array of supported MouseToolBehavior values for this tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override MouseToolBehavior[] SupportedMouseToolBehaviors { get; }
Public Overrides ReadOnly Property SupportedMouseToolBehaviors As MouseToolBehavior()
    Get

Property Value

Type: MouseToolBehavior
An array of supported behaviors, defaulting to ClickAndDrag and MultiClick
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.XButton1Tool Property

ZoomMouseToolXButton1Tool Property

Gets or sets the tool used for the XButton1 mouse button.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomToolMode XButton1Tool { get; set; }
Public Property XButton1Tool As ZoomToolMode
    Get
    Set

Property Value

Type: ZoomToolMode
The tool used for the XButton1 mouse button.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.XButton2Tool Property

ZoomMouseToolXButton2Tool Property

Gets or sets the tool used for the XButton2 mouse button.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ZoomToolMode XButton2Tool { get; set; }
Public Property XButton2Tool As ZoomToolMode
    Get
    Set

Property Value

Type: ZoomToolMode
The tool used for the XButton2 mouse button.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.ZoomChangePercentage Property

ZoomMouseToolZoomChangePercentage Property

Gets or sets the percentage to change the zoom for each mouse click.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ZoomChangePercentage { get; set; }
Public Property ZoomChangePercentage As Double
    Get
    Set

Property Value

Type: Double
The percentage to change the zoom for each mouse click. This value defaults to 0.2.
Remarks
When there is a click event, the Zoom property will be changed by adding or subtracting the ZoomChangePercentage multiplied by the current zoom level.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Methods

The ZoomMouseTool type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | ConfineToImage(Point) | Returns a modified Point that is confined to the image area. (Inherited from MouseTool.)
Protected method | ConfineToImage(Rect) | Returns a Rect that is confined to the image. (Inherited from MouseTool.)
Protected method | ConfineToRenderedImage | Returns a rectangle confined to the rendered size of the image. (Inherited from MouseTool.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | Returns a new instance of ZoomMouseTool. (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetImagePosition(MouseButtonEventArgs, Boolean) | Returns the image position from a MouseButtonEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(MouseEventArgs, Boolean) | Returns the image position from a MouseEventArgs. (Inherited from MouseTool.)
Protected method | GetImagePosition(Point, Boolean) | Returns the image position from a point in viewer coordinates. (Inherited from MouseTool.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HitTestCore | Called by the AtalaImageViewer to determine if a point is over the MouseTool. (Overrides MouseToolHitTestCore(Point).)
Protected method | InvaidateVisual | Use this method to force the AtalaImageViewer to redraw itself and call the OnRender(DrawingContext) method. (Inherited from MouseTool.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | IsMouseToolBehaviorSupported | Indicates if the specified MouseToolBehavior is supported by the MouseTool. (Inherited from MouseTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnImageChanged | Called when the image in the AtalaImageViewer has changed. (Inherited from MouseTool.)
Protected method | OnMouseDown | Called when a mouse button is pressed. (Overrides MouseToolOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseMove | Called when the mouse is moved over the mouse tool bounds or when dragging the tool. (Overrides MouseToolOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Called when the mouse button is released. (Overrides MouseToolOnMouseUp(MouseButtonEventArgs).)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnRender | Called when the tool must render itself. (Overrides MouseToolOnRender(DrawingContext).)
Protected method | OnScrollChanged | Called when the scroll position has changed. (Inherited from MouseTool.)
Protected method | OnViewerChanged | Called when the MouseTool becomes or is removed as the active tool for the AtalaImageViewer. (Inherited from MouseTool.)
Protected method | PerformZoom | This method applies the actual zoom change to the AtalaImageViewer.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Protected method | SetCreatingState | Sets the value for the IsCreating property. (Inherited from MouseTool.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.CreateInstanceCore Method

ZoomMouseToolCreateInstanceCore Method

Returns a new instance of ZoomMouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override Freezable CreateInstanceCore()
Protected Overrides Function CreateInstanceCore As Freezable

Return Value

Type: Freezable
A new instance of ZoomMouseTool.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.HitTestCore Method

ZoomMouseToolHitTestCore Method

Called by the AtalaImageViewer to determine if a point is over the MouseTool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool HitTestCore(
    Point point
)
Protected Overrides Function HitTestCore (
    point As Point
) As Boolean

Parameters

point
Type: System.WindowsPoint
The point in image coordinates.

Return Value

Type: Boolean
True if the point is over the MouseTool.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.OnMouseDown Method

ZoomMouseToolOnMouseDown Method

Called when a mouse button is pressed.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.OnMouseMove Method

ZoomMouseToolOnMouseMove Method

Called when the mouse is moved over the mouse tool bounds or when dragging the tool.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.InputMouseEventArgs
A MouseEventArgs containing information for this event.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.OnMouseUp Method

ZoomMouseToolOnMouseUp Method

Called when the mouse button is released.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseButtonEventArgs
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
A MouseButtonEventArgs containing information for this event.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.OnRender Method

ZoomMouseToolOnRender Method

Called when the tool must render itself.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
Protected Overrides Sub OnRender (
    drawingContext As DrawingContext
)

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
A DrawingContext used to render.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.PerformZoom Method

ZoomMouseToolPerformZoom Method

This method applies the actual zoom change to the AtalaImageViewer.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void PerformZoom(
    Point ctrlPoint,
    Point point,
    ZoomToolMode tool
)
Protected Overridable Sub PerformZoom (
    ctrlPoint As Point,
    point As Point,
    tool As ZoomToolMode
)

Parameters

ctrlPoint
Type: System.WindowsPoint
The point in viewer space that was clicked.
point
Type: System.WindowsPoint
The image pixel that was clicked.
tool
Type: Atalasoft.Imaging.WpfZoomToolMode
The tool that was used.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Events

The ZoomMouseTool type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | SelectionChanged | Raised when the selection has finished being modified.
Public event | SelectionChanging | Raised while the selection is being modfied to provide live feedback to the user.
Top
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.SelectionChanged Event

ZoomMouseToolSelectionChanged Event

Raised when the selection has finished being modified.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<SelectionMouseToolChangedEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of SelectionMouseToolChangedEventArgs)

Value

Type: SystemEventHandlerSelectionMouseToolChangedEventArgs
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.SelectionChanging Event

ZoomMouseToolSelectionChanging Event

Raised while the selection is being modfied to provide live feedback to the user.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<SelectionMouseToolChangedEventArgs> SelectionChanging
Public Event SelectionChanging As EventHandler(Of SelectionMouseToolChangedEventArgs)

Value

Type: SystemEventHandlerSelectionMouseToolChangedEventArgs
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool Fields

The ZoomMouseTool type exposes the following members.

Fields
Name | Description
AutoZoomSelectionProperty | Identifies the AutoZoomSelection dependency property.
CenterZoomProperty | Identifies the CenterZoom dependency property.
FillProperty | Identifies the Fill dependency property.
LeftButtonToolProperty | Identifies the LeftButtonTool dependency property.
LineBackgroundColorProperty | Identifies the LineBackgroundColor dependency property.
MaintainPenThicknessProperty | Identifies the MaintainPenThickness dependency property.
MaximumZoomLevelProperty | Identifies the MaximumZoomLevel dependency property.
MiddleButtonToolProperty | Identifies the MiddleButtonTool dependency property.
MinimumZoomLevelProperty | Identifies the MinimumZoomLevel dependency property.
PenProperty | Identifies the Pen dependency property.
RightButtonToolProperty | Identifies the RightButtonTool dependency property.
XButton1ToolProperty | Identifies the XButton1Tool dependency property.
XButton2ToolProperty | Identifies the XButton2Tool dependency property.
ZoomChangePercentageProperty | Identifies the ZoomChangePercentage dependency property.
Top
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.AutoZoomSelectionProperty Field

ZoomMouseToolAutoZoomSelectionProperty Field

Identifies the AutoZoomSelection dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoZoomSelectionProperty
Public Shared ReadOnly AutoZoomSelectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the AutoZoomSelection dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.CenterZoomProperty Field

ZoomMouseToolCenterZoomProperty Field

Identifies the CenterZoom dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty CenterZoomProperty
Public Shared ReadOnly CenterZoomProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the CenterZoom dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.FillProperty Field

ZoomMouseToolFillProperty Field

Identifies the Fill dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty FillProperty
Public Shared ReadOnly FillProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Fill dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.LeftButtonToolProperty Field

ZoomMouseToolLeftButtonToolProperty Field

Identifies the LeftButtonTool dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LeftButtonToolProperty
Public Shared ReadOnly LeftButtonToolProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the LeftButtonTool dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.LineBackgroundColorProperty Field

ZoomMouseToolLineBackgroundColorProperty Field

Identifies the LineBackgroundColor dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineBackgroundColorProperty
Public Shared ReadOnly LineBackgroundColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the LineBackgroundColor dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MaintainPenThicknessProperty Field

ZoomMouseToolMaintainPenThicknessProperty Field

Identifies the MaintainPenThickness dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaintainPenThicknessProperty
Public Shared ReadOnly MaintainPenThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MaintainPenThickness dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MaximumZoomLevelProperty Field

ZoomMouseToolMaximumZoomLevelProperty Field

Identifies the MaximumZoomLevel dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumZoomLevelProperty
Public Shared ReadOnly MaximumZoomLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MaximumZoomLevel dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MiddleButtonToolProperty Field

ZoomMouseToolMiddleButtonToolProperty Field

Identifies the MiddleButtonTool dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MiddleButtonToolProperty
Public Shared ReadOnly MiddleButtonToolProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MiddleButtonTool dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.MinimumZoomLevelProperty Field

ZoomMouseToolMinimumZoomLevelProperty Field

Identifies the MinimumZoomLevel dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumZoomLevelProperty
Public Shared ReadOnly MinimumZoomLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the MinimumZoomLevel dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.PenProperty Field

ZoomMouseToolPenProperty Field

Identifies the Pen dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty PenProperty
Public Shared ReadOnly PenProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the Pen dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.RightButtonToolProperty Field

ZoomMouseToolRightButtonToolProperty Field

Identifies the RightButtonTool dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty RightButtonToolProperty
Public Shared ReadOnly RightButtonToolProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the RightButtonTool dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.XButton1ToolProperty Field

ZoomMouseToolXButton1ToolProperty Field

Identifies the XButton1Tool dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty XButton1ToolProperty
Public Shared ReadOnly XButton1ToolProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the XButton1Tool dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.XButton2ToolProperty Field

ZoomMouseToolXButton2ToolProperty Field

Identifies the XButton2Tool dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty XButton2ToolProperty
Public Shared ReadOnly XButton2ToolProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the XButton2Tool dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomMouseTool.ZoomChangePercentageProperty Field

ZoomMouseToolZoomChangePercentageProperty Field

Identifies the ZoomChangePercentage dependency property.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomChangePercentageProperty
Public Shared ReadOnly ZoomChangePercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
Identifies the ZoomChangePercentage dependency property.
See Also

Reference

ZoomMouseTool Class
Atalasoft.Imaging.Wpf Namespace


ZoomToolMode Enumeration

Describes the action taken by a button press.

Namespace: Atalasoft.Imaging.Wpf
Assembly: Atalasoft.dotImage.Wpf (in Atalasoft.dotImage.Wpf.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ZoomToolMode
Public Enumeration ZoomToolMode
Members
Member name | Description
None | No action is taken.
ZoomIn | The zoom level is increased.
ZoomOut | The zoom level is decreased.
ZoomSelection | A selection rectangle is started and zoom will be calculated so the selection fits within the viewer.
See Also

Reference

Atalasoft.Imaging.Wpf Namespace


Atalasoft.Isis Namespace

Classing that is required to scan using ISIS scanners.
Classes
 | Class | Description
Public class | IsisAcquisition | This is the main class for image acquisitions with ISIS devices. Use this class by itself for standard acquires, or use it to get an IsisDevice object for more control over the acquire operation. For low level access to ISIS drivers, use the IsisController object.
Public class | IsisBarcodeDetectedEventArgs | Contains information about detected barcode.
Public class | IsisBarcodeSettings | Represents Isis barcode settings.
Public class | IsisCodec | The class represents the codec driver required to compress/decompress image data.
Public class | IsisCodecManager | The list of ISIS codecs available on the system.
Public class | IsisController | The IsisController class allows for lower level access to ISIS drivers, providing greater control over the acquisition and access to custom device properties.
Public class | IsisCustomBrightnessContrast | Represents brightness/contrast value.
Public class | IsisDataAcquiredEventArgs | Contains information about acquired image data.
Public class | IsisDevice | Represents ISIS device.
Public class | IsisDeviceCollection | Represents the list of ISIS devices installed on the system.
Public class | IsisDocumentFeeder | Represents feeder related configuration values.
Public class | IsisErrorNotificationEventArgs | Contains information about the acquired error.
Public class | IsisException | Represents ISIS exception.
Public class | IsisFileAcquisitionEventArgs | Contains information about acquired file.
Public class | IsisImageAcquiredEventArgs | Contains information about the image just acquired.
Public class | IsisImageAcquiringEventArgs | Contains information about acquiring image.
Public class | IsisSettingData | Represents settings data.
Public class | IsisSettingDataManager | The data manager that allows to read and write ISIS settings to file or stream in XML format.
Public class | IsisSettings | Represents ISIS device settings.
Public class | UnsupportedImageFormatException | Thrown when an unsupported image format is passed in from the device.
Public class | UnsupportedSettingException | Thrown in case of unsupported settings.
Interfaces
 | Interface | Description
Public interface | ISettingDataManager | Describes an interface for the classes that may read and write IsisSettingData.
Delegates
 | Delegate | Description
Public delegate | IsisBarcodeDetectedEventHandler | This event handler is used to notify the application when a barcode is detected.
Public delegate | IsisDataAcquiredEventHandler | This event handler is used to notify the application when image data is acquired.
Public delegate | IsisErrorNotificationEventHandler | This event handler is used to notify the application when error is appeared.
Public delegate | IsisFileAcquisitionEventHandler | This event handler is used to notify the application about file acquisition.
Public delegate | IsisImageAcquiredEventHandler | This event handler is used to notify the application when an image has been acquired.
Public delegate | IsisImageAcquiringEventHandler | This event handler is used to notify the application when an image is acquiring.
Enumerations
 | Enumeration | Description
Public enumeration | IsisAcquiredImageType | Image types to scan to.
Public enumeration | IsisBarcodeEmphasis | The types of weak barcodes to enhance.
Public enumeration | IsisBarcodeImageQuality | The value that describe quality of image from which barcodes will be read.
Public enumeration | IsisBarcodeSearchDirection | Available barcode direction values.
Public enumeration | IsisBarcodeSearchMode | Available barcode serach modes.
Public enumeration | IsisBarcodeSupport | Available barcode detection settings.
Public enumeration | IsisBarcodeType | Available barcode types.
Public enumeration | IsisBrightness | Available brightness values.
Public enumeration | IsisCompression | Available compression values.
Public enumeration | IsisEmphasis | Available emphasis settings.
Public enumeration | IsisFileType | Available file types for ISIS.
Public enumeration | IsisJobSeparatorDetection | Available job separator values.
Public enumeration | IsisOrientation | Types of orientations valid for ISIS.
Public enumeration | IsisPhotometric | Available photometric values.
Public enumeration | IsisPixelFormat | Available ISIS pixel formats.
Public enumeration | IsisPlanarConfiguration | Available planar configuration values.
Public enumeration | IsisResolutionUnit | Available resolution units for ISIS
Public enumeration | IsisScanType | Available scan types.
Public enumeration | IsisSetting | Available settings for ISIS.
Public enumeration | IsisSettingType | Available setting types for ISIS
Public enumeration | IsisState | Available states for ISIS


ISettingDataManager Interface

Describes an interface for the classes that may read and write IsisSettingData.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ISettingDataManager
Public Interface ISettingDataManager

The ISettingDataManager type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes data manager.
Public method | Open | Opens data manager in order to start reading and/or writing settings data.
Public method | ReadSetting | Read settings data.
Public method | WriteSetting | Write settings data.
Top
See Also

Reference

Atalasoft.Isis Namespace


ISettingDataManager Methods

The ISettingDataManager type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes data manager.
Public method | Open | Opens data manager in order to start reading and/or writing settings data.
Public method | ReadSetting | Read settings data.
Public method | WriteSetting | Write settings data.
Top
See Also

Reference

ISettingDataManager Interface
Atalasoft.Isis Namespace


ISettingDataManager.Close Method

ISettingDataManagerClose Method

Closes data manager.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Close()
Sub Close
See Also

Reference

ISettingDataManager Interface
Atalasoft.Isis Namespace


ISettingDataManager.Open Method

ISettingDataManagerOpen Method

Opens data manager in order to start reading and/or writing settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Open(
    bool writing
)
Function Open (
    writing As Boolean
) As Boolean

Parameters

writing
Type: SystemBoolean
Indicates whether writing data is allowed.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

ISettingDataManager Interface
Atalasoft.Isis Namespace


ISettingDataManager.ReadSetting Method

ISettingDataManagerReadSetting Method

Read settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool ReadSetting(
    IsisSettingData data
)
Function ReadSetting (
    data As IsisSettingData
) As Boolean

Parameters

data
Type: Atalasoft.IsisIsisSettingData
IsisSettingData that should receive settings data.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

ISettingDataManager Interface
Atalasoft.Isis Namespace


ISettingDataManager.WriteSetting Method

ISettingDataManagerWriteSetting Method

Write settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool WriteSetting(
    IsisSettingData data
)
Function WriteSetting (
    data As IsisSettingData
) As Boolean

Parameters

data
Type: Atalasoft.IsisIsisSettingData
Data to write.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

ISettingDataManager Interface
Atalasoft.Isis Namespace


IsisAcquiredImageType Enumeration

Image types to scan to.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisAcquiredImageType
Public Enumeration IsisAcquiredImageType
Members
Member name | Description
AtalaImage | Atalasoft image.
Bitmap | Standard bitmap image.
See Also

Reference

Atalasoft.Isis Namespace


IsisAcquisition Class

This is the main class for image acquisitions with ISIS devices. Use this class by itself for standard acquires, or use it to get an IsisDevice object for more control over the acquire operation. For low level access to ISIS drivers, use the IsisController object.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.IsisIsisAcquisition

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisAcquisition : Component
Public Class IsisAcquisition
    Inherits Component

The IsisAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | IsisAcquisition | Creates a new instance of IsisAcquisition.
Top
Properties
 | Name | Description
Public property | AcquiredImageType | Gets or sets the type of image to be returned from a scanner. The default value is AtalaImage.
Public property | ActiveDevice | Gets or sets the IsisDevice to work with.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CodecManager | Gets the list of available codecs that can be used to compress scanned image data.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Devices | Gets a collection of installed ISIS scanners in the system.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Methods
 | Name | Description
Public method | Acquire | Acquires an image from the active device.
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the active device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the active device to PDF document.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAcquireCanceled | Handles AcquireCanceled event.
Protected method | OnAcquireFinished | Handles AcquireFinished event.
Protected method | OnBarcodeDetected | Handles BarcodeDetected event.
Protected method | OnDataAcquired | Handles DataAcquired event.
Protected method | OnErrorNotification | Handles ErrorNotification event.
Protected method | OnFileAcquisition | Handles FileAcquisition event.
Protected method | OnImageAcquired | Handles ImageAcquired event.
Protected method | OnYield | Handles Yield event.
Public method | ShowDeviceDialog | Displays a scanner configuration dialog, allowing users to change scan settings.
Public method | ShowSelectSource | Shows Select Source dialog which allows the user to select, add, or configure a scanner.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | AcquireCanceled | This event will fire if the user has canceled the acquisition.
Public event | AcquireFinished | This event will fire when all of the images have been acquired. This is useful when a document feeder is used.
Public event | BarcodeDetected | This event is fired to notify the application when a barcode is detected.
Public event | DataAcquired | This event fires after the data has been transferred but before it has been processed by DotIsis.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ErrorNotification | This event is fired error is appeared.
Public event | FileAcquisition | This event is fired just before acquiring an image directly to file. You must fill in the FileName property of the IsisFileAcquisitionEventArgs object.
Public event | ImageAcquired | This event will fire for each image acquired.
Public event | ImageAcquiring | This event is fired before the data is transferred from the device, allows the transfer to be canceled.
Public event | Yield | This event is fired during scanning and allows an application to implement yield function in order to obtain processor attention when the SDK performs such a long operation.
Top
Remarks
IsisAcquisition is also a component which can be added to the Visual Studio .NET toolbox. This enables properties and events to be established at design time.
See Also

Reference

Atalasoft.Isis Namespace


IsisAcquisition Constructor

Creates a new instance of IsisAcquisition.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisAcquisition()
Public Sub New
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition Properties

The IsisAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AcquiredImageType | Gets or sets the type of image to be returned from a scanner. The default value is AtalaImage.
Public property | ActiveDevice | Gets or sets the IsisDevice to work with.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CodecManager | Gets the list of available codecs that can be used to compress scanned image data.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Devices | Gets a collection of installed ISIS scanners in the system.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.AcquiredImageType Property

IsisAcquisitionAcquiredImageType Property

Gets or sets the type of image to be returned from a scanner. The default value is AtalaImage.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisAcquiredImageType AcquiredImageType { get; set; }
Public Property AcquiredImageType As IsisAcquiredImageType
    Get
    Set

Property Value

Type: IsisAcquiredImageType
Remarks
After an image data is acquired from a scanner, DotIsis wraps it with an object that can be used further in an application. By default, AtalaImage is produced. However, if needed user may instruct the SDK to produce Bitmap object.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisAcquiredImageType


IsisAcquisition.ActiveDevice Property

IsisAcquisitionActiveDevice Property

Gets or sets the IsisDevice to work with.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDevice ActiveDevice { get; set; }
Public Property ActiveDevice As IsisDevice
    Get
    Set

Property Value

Type: IsisDevice
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.CodecManager Property

IsisAcquisitionCodecManager Property

Gets the list of available codecs that can be used to compress scanned image data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCodecManager CodecManager { get; }
Public ReadOnly Property CodecManager As IsisCodecManager
    Get

Property Value

Type: IsisCodecManager
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.Devices Property

IsisAcquisitionDevices Property

Gets a collection of installed ISIS scanners in the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDeviceCollection Devices { get; }
Public ReadOnly Property Devices As IsisDeviceCollection
    Get

Property Value

Type: IsisDeviceCollection
A IsisDeviceCollection object containing ISIS scanners found on the system.
Remarks
It's possible a device may be listed even when it's not connected.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisDevice
Atalasoft.IsisIsisDevice


IsisAcquisition Methods

The IsisAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | Acquire | Acquires an image from the active device.
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the active device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the active device to PDF document.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAcquireCanceled | Handles AcquireCanceled event.
Protected method | OnAcquireFinished | Handles AcquireFinished event.
Protected method | OnBarcodeDetected | Handles BarcodeDetected event.
Protected method | OnDataAcquired | Handles DataAcquired event.
Protected method | OnErrorNotification | Handles ErrorNotification event.
Protected method | OnFileAcquisition | Handles FileAcquisition event.
Protected method | OnImageAcquired | Handles ImageAcquired event.
Protected method | OnYield | Handles Yield event.
Public method | ShowDeviceDialog | Displays a scanner configuration dialog, allowing users to change scan settings.
Public method | ShowSelectSource | Shows Select Source dialog which allows the user to select, add, or configure a scanner.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.Acquire Method

IsisAcquisitionAcquire Method

Acquires an image from the active device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Acquire()
Public Function Acquire As Boolean

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks

The ImageAcquired event must be handled as it is raised for each image that is acquired.

See Remarks in IsisController for more information about error handling.

See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace
IsisAcquisitionActiveDevice


IsisAcquisition.AcquireToFile Method

IsisAcquisitionAcquireToFile Method

Overload List
 | Name | Description
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the active device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the active device to PDF document.
Top
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.AcquireToFile Method (IsisFileType, IsisCompression)

IsisAcquisitionAcquireToFile Method (IsisFileType, IsisCompression)

Acquires an image from the active device to a file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AcquireToFile(
    IsisFileType fileType,
    IsisCompression compression
)
Public Function AcquireToFile (
    fileType As IsisFileType,
    compression As IsisCompression
) As Boolean

Parameters

fileType
Type: Atalasoft.IsisIsisFileType
Specifies a file format to be used to save image.
compression
Type: Atalasoft.IsisIsisCompression
Specifies desired image data compression.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks

The event should be handled in order to specify file name.

See Remarks in IsisController for more information about error handling.

See Also

Reference

IsisAcquisition Class
AcquireToFile Overload
Atalasoft.Isis Namespace
IsisAcquisitionFileAcquisition
IsisAcquisitionActiveDevice


IsisAcquisition.AcquireToFile Method (IsisCompression, String, String, String, String, String)

IsisAcquisitionAcquireToFile Method (IsisCompression, String, String, String, String, String)

Acquires an image from the active device to PDF document.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AcquireToFile(
    IsisCompression compression,
    string author,
    string creator,
    string title,
    string subject,
    string keywords
)
Public Function AcquireToFile (
    compression As IsisCompression,
    author As String,
    creator As String,
    title As String,
    subject As String,
    keywords As String
) As Boolean

Parameters

compression
Type: Atalasoft.IsisIsisCompression
Specifies desired image data compression.
author
Type: SystemString
Specifies PDF document author.
creator
Type: SystemString
Specifies PDF document creator tag.
title
Type: SystemString
Specifies PDF document title.
subject
Type: SystemString
Specifies PDF document subject tag.
keywords
Type: SystemString
Specifies PDF document keywords.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks

The event should be handled in order to specify file name.

See Remarks in IsisController for more information about error handling.

See Also

Reference

IsisAcquisition Class
AcquireToFile Overload
Atalasoft.Isis Namespace
IsisAcquisitionFileAcquisition
IsisAcquisitionActiveDevice


IsisAcquisition.OnAcquireCanceled Method

IsisAcquisitionOnAcquireCanceled Method

Handles AcquireCanceled event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAcquireCanceled(
    Object sender,
    EventArgs e
)
Protected Sub OnAcquireCanceled (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: SystemEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnAcquireFinished Method

IsisAcquisitionOnAcquireFinished Method

Handles AcquireFinished event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnAcquireFinished(
    Object sender,
    EventArgs e
)
Protected Sub OnAcquireFinished (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: SystemEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnBarcodeDetected Method

IsisAcquisitionOnBarcodeDetected Method

Handles BarcodeDetected event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnBarcodeDetected(
    Object sender,
    IsisBarcodeDetectedEventArgs e
)
Protected Sub OnBarcodeDetected (
    sender As Object,
    e As IsisBarcodeDetectedEventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: Atalasoft.IsisIsisBarcodeDetectedEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnDataAcquired Method

IsisAcquisitionOnDataAcquired Method

Handles DataAcquired event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnDataAcquired(
    Object sender,
    IsisDataAcquiredEventArgs e
)
Protected Sub OnDataAcquired (
    sender As Object,
    e As IsisDataAcquiredEventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: Atalasoft.IsisIsisDataAcquiredEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnErrorNotification Method

IsisAcquisitionOnErrorNotification Method

Handles ErrorNotification event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnErrorNotification(
    Object sender,
    IsisErrorNotificationEventArgs e
)
Protected Sub OnErrorNotification (
    sender As Object,
    e As IsisErrorNotificationEventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: Atalasoft.IsisIsisErrorNotificationEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnFileAcquisition Method

IsisAcquisitionOnFileAcquisition Method

Handles FileAcquisition event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnFileAcquisition(
    Object sender,
    IsisFileAcquisitionEventArgs e
)
Protected Sub OnFileAcquisition (
    sender As Object,
    e As IsisFileAcquisitionEventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: Atalasoft.IsisIsisFileAcquisitionEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnImageAcquired Method

IsisAcquisitionOnImageAcquired Method

Handles ImageAcquired event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnImageAcquired(
    Object sender,
    IsisImageAcquiredEventArgs e
)
Protected Sub OnImageAcquired (
    sender As Object,
    e As IsisImageAcquiredEventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: Atalasoft.IsisIsisImageAcquiredEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.OnYield Method

IsisAcquisitionOnYield Method

Handles Yield event.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnYield(
    Object sender,
    EventArgs e
)
Protected Sub OnYield (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: SystemObject
Sender of the event.
e
Type: SystemEventArgs
Event argument.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.ShowDeviceDialog Method

IsisAcquisitionShowDeviceDialog Method

Displays a scanner configuration dialog, allowing users to change scan settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowDeviceDialog(
    IWin32Window parent
)
Public Function ShowDeviceDialog (
    parent As IWin32Window
) As Boolean

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent for this dialog.

Return Value

Type: Boolean
True if the user selected the OK button.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the parent argument is not provided.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.ShowSelectSource Method

IsisAcquisitionShowSelectSource Method

Shows Select Source dialog which allows the user to select, add, or configure a scanner.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowSelectSource(
    IWin32Window parent
)
Public Function ShowSelectSource (
    parent As IWin32Window
) As Boolean

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent for this dialog.

Return Value

Type: Boolean
True if the user selected the OK button.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition Events

The IsisAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AcquireCanceled | This event will fire if the user has canceled the acquisition.
Public event | AcquireFinished | This event will fire when all of the images have been acquired. This is useful when a document feeder is used.
Public event | BarcodeDetected | This event is fired to notify the application when a barcode is detected.
Public event | DataAcquired | This event fires after the data has been transferred but before it has been processed by DotIsis.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ErrorNotification | This event is fired error is appeared.
Public event | FileAcquisition | This event is fired just before acquiring an image directly to file. You must fill in the FileName property of the IsisFileAcquisitionEventArgs object.
Public event | ImageAcquired | This event will fire for each image acquired.
Public event | ImageAcquiring | This event is fired before the data is transferred from the device, allows the transfer to be canceled.
Public event | Yield | This event is fired during scanning and allows an application to implement yield function in order to obtain processor attention when the SDK performs such a long operation.
Top
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.AcquireCanceled Event

IsisAcquisitionAcquireCanceled Event

This event will fire if the user has canceled the acquisition.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AcquireCanceled
Public Event AcquireCanceled As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.AcquireFinished Event

IsisAcquisitionAcquireFinished Event

This event will fire when all of the images have been acquired. This is useful when a document feeder is used.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AcquireFinished
Public Event AcquireFinished As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.BarcodeDetected Event

IsisAcquisitionBarcodeDetected Event

This event is fired to notify the application when a barcode is detected.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisBarcodeDetectedEventHandler BarcodeDetected
Public Event BarcodeDetected As IsisBarcodeDetectedEventHandler

Value

Type: Atalasoft.IsisIsisBarcodeDetectedEventHandler
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.DataAcquired Event

IsisAcquisitionDataAcquired Event

This event fires after the data has been transferred but before it has been processed by DotIsis.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisDataAcquiredEventHandler DataAcquired
Public Event DataAcquired As IsisDataAcquiredEventHandler

Value

Type: Atalasoft.IsisIsisDataAcquiredEventHandler
Remarks
This event allows for processing of data DotIsis does not support, such as unique image formats. If this data should not be processed by DotIsis, set the Handled property of the IsisDataAcquiredEventArgs to true.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.ErrorNotification Event

IsisAcquisitionErrorNotification Event

This event is fired error is appeared.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisErrorNotificationEventHandler ErrorNotification
Public Event ErrorNotification As IsisErrorNotificationEventHandler

Value

Type: Atalasoft.IsisIsisErrorNotificationEventHandler
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.FileAcquisition Event

IsisAcquisitionFileAcquisition Event

This event is fired just before acquiring an image directly to file. You must fill in the FileName property of the IsisFileAcquisitionEventArgs object.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisFileAcquisitionEventHandler FileAcquisition
Public Event FileAcquisition As IsisFileAcquisitionEventHandler

Value

Type: Atalasoft.IsisIsisFileAcquisitionEventHandler
Remarks
You can cancel the acquisition by setting the Cancel property of the IsisFileAcquisitionEventArgs to true.
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.ImageAcquired Event

IsisAcquisitionImageAcquired Event

This event will fire for each image acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisImageAcquiredEventHandler ImageAcquired
Public Event ImageAcquired As IsisImageAcquiredEventHandler

Value

Type: Atalasoft.IsisIsisImageAcquiredEventHandler
Remarks

All pending image acquisitions can be canceled by setting the Cancel property of the IsisImageAcquiredEventArgs to true.

To transfer the returned Bitmap to an AtalaImage when integrating with DotImage, use the FromBitmap(Bitmap, Boolean) method.

When scanning multiple pages at once, this method can be used to compose a multipage image by invoking the [!:Imaging.Workspace.Images.Add] method of the Workspace object in DotImage.

See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisImageAcquiredEventArgs


IsisAcquisition.ImageAcquiring Event

IsisAcquisitionImageAcquiring Event

This event is fired before the data is transferred from the device, allows the transfer to be canceled.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisImageAcquiringEventHandler ImageAcquiring
Public Event ImageAcquiring As IsisImageAcquiringEventHandler

Value

Type: Atalasoft.IsisIsisImageAcquiringEventHandler
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisAcquisition.Yield Event

IsisAcquisitionYield Event

This event is fired during scanning and allows an application to implement yield function in order to obtain processor attention when the SDK performs such a long operation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Yield
Public Event Yield As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IsisAcquisition Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs Class

Contains information about detected barcode.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.IsisIsisBarcodeDetectedEventArgs

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisBarcodeDetectedEventArgs : EventArgs
Public Class IsisBarcodeDetectedEventArgs
    Inherits EventArgs

The IsisBarcodeDetectedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IsisBarcodeDetectedEventArgs | Initializes a new instance of the IsisBarcodeDetectedEventArgs class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets the barcode location bounds.
Public property | CodeType | Gets the barcode type.
Public property | Orientation | Gets the barcode orientation.
Public property | Quality | Gets the barcode quality.
Public property | SearchTime | Gets the search time.
Public property | Text | Gets the text.
Public property | ValidChecksum | Gets a value indication whether checksum is valid.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs Constructor

Initializes a new instance of the IsisBarcodeDetectedEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeDetectedEventArgs(
    IsisBarcodeType codeType,
    Rectangle bounds,
    string text,
    IsisOrientation orientation,
    int searchTime,
    int quality,
    bool validChecksum
)
Public Sub New (
    codeType As IsisBarcodeType,
    bounds As Rectangle,
    text As String,
    orientation As IsisOrientation,
    searchTime As Integer,
    quality As Integer,
    validChecksum As Boolean
)

Parameters

codeType
Type: Atalasoft.IsisIsisBarcodeType
The barcode type.
bounds
Type: System.DrawingRectangle
The barcode location bounds.
text
Type: SystemString
The barcode text.
orientation
Type: Atalasoft.IsisIsisOrientation
The orientation of the barcode.
searchTime
Type: SystemInt32
The search time.
quality
Type: SystemInt32
The quality of the barcode.
validChecksum
Type: SystemBoolean
The value indication whether checksum is valid.
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs Properties

The IsisBarcodeDetectedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets the barcode location bounds.
Public property | CodeType | Gets the barcode type.
Public property | Orientation | Gets the barcode orientation.
Public property | Quality | Gets the barcode quality.
Public property | SearchTime | Gets the search time.
Public property | Text | Gets the text.
Public property | ValidChecksum | Gets a value indication whether checksum is valid.
Top
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.Bounds Property

IsisBarcodeDetectedEventArgsBounds Property

Gets the barcode location bounds.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; }
Public ReadOnly Property Bounds As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.CodeType Property

IsisBarcodeDetectedEventArgsCodeType Property

Gets the barcode type.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeType CodeType { get; }
Public ReadOnly Property CodeType As IsisBarcodeType
    Get

Property Value

Type: IsisBarcodeType
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.Orientation Property

IsisBarcodeDetectedEventArgsOrientation Property

Gets the barcode orientation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisOrientation Orientation { get; }
Public ReadOnly Property Orientation As IsisOrientation
    Get

Property Value

Type: IsisOrientation
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.Quality Property

IsisBarcodeDetectedEventArgsQuality Property

Gets the barcode quality.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Quality { get; }
Public ReadOnly Property Quality As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.SearchTime Property

IsisBarcodeDetectedEventArgsSearchTime Property

Gets the search time.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SearchTime { get; }
Public ReadOnly Property SearchTime As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.Text Property

IsisBarcodeDetectedEventArgsText Property

Gets the text.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs.ValidChecksum Property

IsisBarcodeDetectedEventArgsValidChecksum Property

Gets a value indication whether checksum is valid.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ValidChecksum { get; }
Public ReadOnly Property ValidChecksum As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventArgs Methods

The IsisBarcodeDetectedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisBarcodeDetectedEventArgs Class
Atalasoft.Isis Namespace


IsisBarcodeDetectedEventHandler Delegate

This event handler is used to notify the application when a barcode is detected.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void IsisBarcodeDetectedEventHandler(
    Object sender,
    IsisBarcodeDetectedEventArgs e
)
Public Delegate Sub IsisBarcodeDetectedEventHandler (
    sender As Object,
    e As IsisBarcodeDetectedEventArgs
)

Parameters

sender
Type: SystemObject
The event sender.
e
Type: Atalasoft.IsisIsisBarcodeDetectedEventArgs
The information about barcode.
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeEmphasis Enumeration

The types of weak barcodes to enhance.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisBarcodeEmphasis
Public Enumeration IsisBarcodeEmphasis
Members
Member name | Description
None | No barcodes.
Black | Black barcodes.
White | White barcodes.
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeImageQuality Enumeration

The value that describe quality of image from which barcodes will be read.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisBarcodeImageQuality
Public Enumeration IsisBarcodeImageQuality
Members
Member name | Description
Auto | Auto recognize.
Dithered | Image is dithered.
DotMatrix | Printed by a dot matrix.
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeSearchDirection Enumeration

Available barcode direction values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisBarcodeSearchDirection
Public Enumeration IsisBarcodeSearchDirection
Members
Member name | Description
Forward | Forward direction.
Reverse | Reverse direction.
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeSearchMode Enumeration

Available barcode serach modes.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisBarcodeSearchMode
Public Enumeration IsisBarcodeSearchMode
Members
Member name | Description
Horizontal | Horizontal search mode.
HorizontalVertical | Horizontal and vertical search mode.
Veritcal | Vertical search mode.
VerticalHorizontal | Vertical and horizontal search mode.
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeSettings Class

Represents Isis barcode settings.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisBarcodeSettings

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisBarcodeSettings
Public Class IsisBarcodeSettings

The IsisBarcodeSettings type exposes the following members.

Properties
 | Name | Description
Public property | Emphasis | Gets or sets the type of weak barcode to enhance.
Public property | Enabled | Gets or sets a value indicating whether barcode detection should be enabled.
Public property | ImageQuality | Gets or sets the quality of image from which barcodes should be read.
Public property | LinearSearch | Gets or sets a value indicating that barcodes should be searched top to bottom instead of middle to edge.
Public property | MaximumOnLine | Gets or sets the maximum number of barcodes on a line.
Public property | MaximumOnPage | Gets or sets the maximum number of barcodes on the page.
Public property | SearchDirection | Gets or sets barcode search direction.
Public property | SearchMode | Gets or sets barcode search mode.
Public property | SearchOffset | Gets or sets barcode search offset.
Public property | SearchOrientation | Gets or sets barcode search orientation.
Public property | Supported | Gets the value indicating whether barcode detection is supported.
Public property | VerifyChecksum | Gets or sets a value indicating whether detected barcodes should be verified by checksum.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentCodeTypes | Gets the current barcode types.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportedBarcodeTypes | Returns the supported barcode types for this device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentCodeTypes | Sets current barcode types.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeSettings Properties

The IsisBarcodeSettings type exposes the following members.

Properties
 | Name | Description
Public property | Emphasis | Gets or sets the type of weak barcode to enhance.
Public property | Enabled | Gets or sets a value indicating whether barcode detection should be enabled.
Public property | ImageQuality | Gets or sets the quality of image from which barcodes should be read.
Public property | LinearSearch | Gets or sets a value indicating that barcodes should be searched top to bottom instead of middle to edge.
Public property | MaximumOnLine | Gets or sets the maximum number of barcodes on a line.
Public property | MaximumOnPage | Gets or sets the maximum number of barcodes on the page.
Public property | SearchDirection | Gets or sets barcode search direction.
Public property | SearchMode | Gets or sets barcode search mode.
Public property | SearchOffset | Gets or sets barcode search offset.
Public property | SearchOrientation | Gets or sets barcode search orientation.
Public property | Supported | Gets the value indicating whether barcode detection is supported.
Public property | VerifyChecksum | Gets or sets a value indicating whether detected barcodes should be verified by checksum.
Top
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.Emphasis Property

IsisBarcodeSettingsEmphasis Property

Gets or sets the type of weak barcode to enhance.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeEmphasis Emphasis { get; set; }
Public Property Emphasis As IsisBarcodeEmphasis
    Get
    Set

Property Value

Type: IsisBarcodeEmphasis
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.Enabled Property

IsisBarcodeSettingsEnabled Property

Gets or sets a value indicating whether barcode detection should be enabled.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeSupport Enabled { get; set; }
Public Property Enabled As IsisBarcodeSupport
    Get
    Set

Property Value

Type: IsisBarcodeSupport
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.ImageQuality Property

IsisBarcodeSettingsImageQuality Property

Gets or sets the quality of image from which barcodes should be read.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeImageQuality ImageQuality { get; set; }
Public Property ImageQuality As IsisBarcodeImageQuality
    Get
    Set

Property Value

Type: IsisBarcodeImageQuality
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.LinearSearch Property

IsisBarcodeSettingsLinearSearch Property

Gets or sets a value indicating that barcodes should be searched top to bottom instead of middle to edge.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool LinearSearch { get; set; }
Public Property LinearSearch As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.MaximumOnLine Property

IsisBarcodeSettingsMaximumOnLine Property

Gets or sets the maximum number of barcodes on a line.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumOnLine { get; set; }
Public Property MaximumOnLine As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.MaximumOnPage Property

IsisBarcodeSettingsMaximumOnPage Property

Gets or sets the maximum number of barcodes on the page.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumOnPage { get; set; }
Public Property MaximumOnPage As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.SearchDirection Property

IsisBarcodeSettingsSearchDirection Property

Gets or sets barcode search direction.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeSearchDirection SearchDirection { get; set; }
Public Property SearchDirection As IsisBarcodeSearchDirection
    Get
    Set

Property Value

Type: IsisBarcodeSearchDirection
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.SearchMode Property

IsisBarcodeSettingsSearchMode Property

Gets or sets barcode search mode.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeSearchMode SearchMode { get; set; }
Public Property SearchMode As IsisBarcodeSearchMode
    Get
    Set

Property Value

Type: IsisBarcodeSearchMode
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.SearchOffset Property

IsisBarcodeSettingsSearchOffset Property

Gets or sets barcode search offset.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point SearchOffset { get; set; }
Public Property SearchOffset As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.SearchOrientation Property

IsisBarcodeSettingsSearchOrientation Property

Gets or sets barcode search orientation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisOrientation SearchOrientation { get; set; }
Public Property SearchOrientation As IsisOrientation
    Get
    Set

Property Value

Type: IsisOrientation
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.Supported Property

IsisBarcodeSettingsSupported Property

Gets the value indicating whether barcode detection is supported.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Supported { get; }
Public ReadOnly Property Supported As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.VerifyChecksum Property

IsisBarcodeSettingsVerifyChecksum Property

Gets or sets a value indicating whether detected barcodes should be verified by checksum.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool VerifyChecksum { get; set; }
Public Property VerifyChecksum As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings Methods

The IsisBarcodeSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentCodeTypes | Gets the current barcode types.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportedBarcodeTypes | Returns the supported barcode types for this device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentCodeTypes | Sets current barcode types.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.GetCurrentCodeTypes Method

IsisBarcodeSettingsGetCurrentCodeTypes Method

Gets the current barcode types.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeType[] GetCurrentCodeTypes()
Public Function GetCurrentCodeTypes As IsisBarcodeType()

Return Value

Type: IsisBarcodeType
Array of current barcode types.
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.GetSupportedBarcodeTypes Method

IsisBarcodeSettingsGetSupportedBarcodeTypes Method

Returns the supported barcode types for this device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeType[] GetSupportedBarcodeTypes()
Public Function GetSupportedBarcodeTypes As IsisBarcodeType()

Return Value

Type: IsisBarcodeType
An array of BarcodeType supported by the device.
Remarks
Use this method to determine the valid values for use with the CodeType property.
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSettings.SetCurrentCodeTypes Method

IsisBarcodeSettingsSetCurrentCodeTypes Method

Sets current barcode types.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetCurrentCodeTypes(
    IsisBarcodeType[] codeTypes
)
Public Sub SetCurrentCodeTypes (
    codeTypes As IsisBarcodeType()
)

Parameters

codeTypes
Type: Atalasoft.IsisIsisBarcodeType
See Also

Reference

IsisBarcodeSettings Class
Atalasoft.Isis Namespace


IsisBarcodeSupport Enumeration

Available barcode detection settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum IsisBarcodeSupport
<FlagsAttribute>
Public Enumeration IsisBarcodeSupport
Members
Member name | Description
None | Barcode detection is not supported.
BackSide | Barcode detection is supported for the back side of a duplex device.
FrontSide | Barcode detection is supported for a non-duplex device or the front side of a duplex enabled device.
See Also

Reference

Atalasoft.Isis Namespace


IsisBarcodeType Enumeration

Available barcode types.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisBarcodeType
Public Enumeration IsisBarcodeType
Members
Member name | Description
None | No barcode.
Addon2 | ADDON2.
Addon5 | ADDON5.
Auto | Auto detect any barcode types.
Aztec | Aztec barcodes.
BcdMatrix | BCD matrix barcode.
Code25 | Code 2/5 barcode.
Code25Airline | Code 2/5 (airline) barcode.
Code25DataLogic | Code 2/5 (datalogic) barcode.
Code25Iata | Code 2/5 (IATA) barcode.
Code25Industrial | Code 2/5 (industrial) barcode.
Code25Interleaved | Code 2/5 interleaved barcode.
Code25Invert | Code 2/5 (inverted) barcode.
Code25Matrix | Code 2/5 (matrix) barcode.
Code32 | Code 32 barcode.
Code39 | Code 39 barcode.
Code39Ascii | Code 39 ASCII barcode.
Code93 | Code 93 barcode.
Codabar | Codebar barcode.
CodebarStartStop | Codabar including Start/Stop.
Datamatrix | Datamatrix barcode.
Ean13 | EAN-13 barcode.
Ean8 | EAN-8 barcode.
Maxicode | MaxiCode barcode.
MicrCmc7 | MICR CMC7 barcode.
MicrE13B | MICR E13B barcode.
Msi | MSI barcode.
Patchcode | Any patchcodes.
Patchcode1 | Patchcode Type I.
Patchcode2 | Patchcode Type II.
Patchcode3 | Patchcode Type III.
Patchcode4 | Patchcode Type IV.
Patchcode5 | Patchcode Type V.
PatchTransfer | Patchcode Transfer.
Pdf417 | PDF417 barcode.
Postnet | Ppostnet barcode.
QRCode | QR code barcode.
Type128 | Type 128 barcode.
Ucc128 | UCC-128 barcode.
UpcA | UPC code revision A barcode.
UpcE | UPC code revision E barcode.
See Also

Reference

Atalasoft.Isis Namespace


IsisBrightness Enumeration

Available brightness values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisBrightness
Public Enumeration IsisBrightness
Members
Member name | Description
Auto | Automatic.
Darken | Darken.
Lighten | Lighten.
Normal | Normal.
See Also

Reference

Atalasoft.Isis Namespace


IsisCodec Class

The class represents the codec driver required to compress/decompress image data.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisCodec

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisCodec
Public Class IsisCodec

The IsisCodec type exposes the following members.

Properties
 | Name | Description
Public property | FileType | Gets the type of file supported by the codec.
Public property | MultipageSupport | Gets a value indicating whether multipage is supported.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportedColorFormats | Retrieves the list of supported color formats.
Public method | GetSupportedCompressions | Retreives the list of supported compressions.
Public method | GetSupportedCompressions(IsisPixelFormat) | Retrieves the list of supported compressions available for the specified pixel format.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisCodec Properties

The IsisCodec type exposes the following members.

Properties
 | Name | Description
Public property | FileType | Gets the type of file supported by the codec.
Public property | MultipageSupport | Gets a value indicating whether multipage is supported.
Top
See Also

Reference

IsisCodec Class
Atalasoft.Isis Namespace


IsisCodec.FileType Property

IsisCodecFileType Property

Gets the type of file supported by the codec.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisFileType FileType { get; }
Public ReadOnly Property FileType As IsisFileType
    Get

Property Value

Type: IsisFileType
See Also

Reference

IsisCodec Class
Atalasoft.Isis Namespace


IsisCodec.MultipageSupport Property

IsisCodecMultipageSupport Property

Gets a value indicating whether multipage is supported.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MultipageSupport { get; }
Public ReadOnly Property MultipageSupport As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisCodec Class
Atalasoft.Isis Namespace


IsisCodec Methods

The IsisCodec type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportedColorFormats | Retrieves the list of supported color formats.
Public method | GetSupportedCompressions | Retreives the list of supported compressions.
Public method | GetSupportedCompressions(IsisPixelFormat) | Retrieves the list of supported compressions available for the specified pixel format.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisCodec Class
Atalasoft.Isis Namespace


IsisCodec.GetSupportedColorFormats Method

IsisCodecGetSupportedColorFormats Method

Retrieves the list of supported color formats.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisPixelFormat[] GetSupportedColorFormats()
Public Function GetSupportedColorFormats As IsisPixelFormat()

Return Value

Type: IsisPixelFormat
List of supported color formats.
See Also

Reference

IsisCodec Class
Atalasoft.Isis Namespace


IsisCodec.GetSupportedCompressions Method

IsisCodecGetSupportedCompressions Method

Overload List
 | Name | Description
Public method | GetSupportedCompressions | Retreives the list of supported compressions.
Public method | GetSupportedCompressions(IsisPixelFormat) | Retrieves the list of supported compressions available for the specified pixel format.
Top
See Also

Reference

IsisCodec Class
Atalasoft.Isis Namespace


IsisCodec.GetSupportedCompressions Method

IsisCodecGetSupportedCompressions Method

Retreives the list of supported compressions.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCompression[] GetSupportedCompressions()
Public Function GetSupportedCompressions As IsisCompression()

Return Value

Type: IsisCompression
List of compressions.
See Also

Reference

IsisCodec Class
GetSupportedCompressions Overload
Atalasoft.Isis Namespace


IsisCodec.GetSupportedCompressions Method (IsisPixelFormat)

IsisCodecGetSupportedCompressions Method (IsisPixelFormat)

Retrieves the list of supported compressions available for the specified pixel format.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCompression[] GetSupportedCompressions(
    IsisPixelFormat pixelFormat
)
Public Function GetSupportedCompressions (
    pixelFormat As IsisPixelFormat
) As IsisCompression()

Parameters

pixelFormat
Type: Atalasoft.IsisIsisPixelFormat
Pixel format for which the list of supported compressions is requirested.

Return Value

Type: IsisCompression
List of supported compressions.
See Also

Reference

IsisCodec Class
GetSupportedCompressions Overload
Atalasoft.Isis Namespace


IsisCodecManager Class

The list of ISIS codecs available on the system.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisCodecManager

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisCodecManager : IEnumerable
Public Class IsisCodecManager
    Implements IEnumerable

The IsisCodecManager type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets a number of codecs installed on the system.
Public property | ItemInt32 | Gets IsisCodec.
Public property | ItemIsisFileType | Gets IsisCodec required to save to the specified IsisFileType.
Top
Methods
 | Name | Description
Public method | Contains(String) | Checks whether the specified codec driver is installed on the system.
Public method | Contains(IsisFileType) | Checks whether the specified IsisFileType is supported by ISIS codecs installed on the system.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetFileTypes | Gets the list supported of IsisFileType.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisCodecManager Properties

The IsisCodecManager type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets a number of codecs installed on the system.
Public property | ItemInt32 | Gets IsisCodec.
Public property | ItemIsisFileType | Gets IsisCodec required to save to the specified IsisFileType.
Top
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCodecManager.Count Property

IsisCodecManagerCount Property

Gets a number of codecs installed on the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCodecManager.Item Property

IsisCodecManagerItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets IsisCodec.
Public property | ItemIsisFileType | Gets IsisCodec required to save to the specified IsisFileType.
Top
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCodecManager.Item Property (Int32)

IsisCodecManagerItem Property (Int32)

Gets IsisCodec.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCodec this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IsisCodec
    Get

Parameters

index
Type: SystemInt32
Index of the IsisCodec in the list.

Return Value

Type: IsisCodec
Requested codec.
See Also

Reference

IsisCodecManager Class
Item Overload
Atalasoft.Isis Namespace


IsisCodecManager.Item Property (IsisFileType)

IsisCodecManagerItem Property (IsisFileType)

Gets IsisCodec required to save to the specified IsisFileType.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCodec this[
    IsisFileType fileType
] { get; }
Public ReadOnly Default Property Item (
    fileType As IsisFileType
) As IsisCodec
    Get

Parameters

fileType
Type: Atalasoft.IsisIsisFileType
Desired IsisFileType.

Return Value

Type: IsisCodec
Codec required to save image data.
See Also

Reference

IsisCodecManager Class
Item Overload
Atalasoft.Isis Namespace


IsisCodecManager Methods

The IsisCodecManager type exposes the following members.

Methods
 | Name | Description
Public method | Contains(String) | Checks whether the specified codec driver is installed on the system.
Public method | Contains(IsisFileType) | Checks whether the specified IsisFileType is supported by ISIS codecs installed on the system.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetFileTypes | Gets the list supported of IsisFileType.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCodecManager.Contains Method

IsisCodecManagerContains Method

Overload List
 | Name | Description
Public method | Contains(String) | Checks whether the specified codec driver is installed on the system.
Public method | Contains(IsisFileType) | Checks whether the specified IsisFileType is supported by ISIS codecs installed on the system.
Top
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCodecManager.Contains Method (String)

IsisCodecManagerContains Method (String)

Checks whether the specified codec driver is installed on the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    string driver
)
Public Function Contains (
    driver As String
) As Boolean

Parameters

driver
Type: SystemString
Codec driver to check.

Return Value

Type: Boolean
true if installed, otherwise false.
See Also

Reference

IsisCodecManager Class
Contains Overload
Atalasoft.Isis Namespace


IsisCodecManager.Contains Method (IsisFileType)

IsisCodecManagerContains Method (IsisFileType)

Checks whether the specified IsisFileType is supported by ISIS codecs installed on the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    IsisFileType fileType
)
Public Function Contains (
    fileType As IsisFileType
) As Boolean

Parameters

fileType
Type: Atalasoft.IsisIsisFileType
Type of file to check.

Return Value

Type: Boolean
true if supported, otherwise false.
See Also

Reference

IsisCodecManager Class
Contains Overload
Atalasoft.Isis Namespace


IsisCodecManager.GetEnumerator Method

IsisCodecManagerGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCodecManager.GetFileTypes Method

IsisCodecManagerGetFileTypes Method

Gets the list supported of IsisFileType.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisFileType[] GetFileTypes()
Public Function GetFileTypes As IsisFileType()

Return Value

Type: IsisFileType
See Also

Reference

IsisCodecManager Class
Atalasoft.Isis Namespace


IsisCompression Enumeration

Available compression values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisCompression
Public Enumeration IsisCompression
Members
Member name | Description
None | Uncompressed.
Bmp | Compression used in BMP files.
Gif | Compression used in Gif files.
GifInterlaced | Interlaced compression used in Gif files.
Group3 | Standard ITU Group 3 encoding.
Group4 | Standard ITU Group 4 encoding.
Jbig | JBIG compression.
Jpeg | JPEG compression.
Jpeg2000 | JPEG 2000 compression.
JpegInTiff | JPEG compression used in TIFF files.
Lzw | LZW compression.
ModifiedGroup3 | Modified ITU Group 3 encoding.
None2ByteAligned | Uncompressed, each line padded to two bytes.
None4ByteAligned | Uncompressed, each line padded to four bytes.
Packbits | Packbits compression.
Pcl | PCL compression.
Pcx | Compression used in PCX files.
WangJpeg | Wang JPEG compression.
Zip | ZIP compression.
See Also

Reference

Atalasoft.Isis Namespace


IsisController Class

The IsisController class allows for lower level access to ISIS drivers, providing greater control over the acquisition and access to custom device properties.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisController

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisController : IDisposable
Public Class IsisController
    Implements IDisposable

The IsisController type exposes the following members.

Constructors
 | Name | Description
Public method | IsisController | Initializes a new instance of IsisController class.
Top
Properties
 | Name | Description
Public property | AcquiredImageType | Gets or sets the type of image to be returned from a scanner. The default value is AtalaImage.
Public property | ActiveDevice | Gets or sets the IsisDevice to work with.
Public property | CodecManager | Gets the list of available codecs that can be used to compress scanned image data.
Public property | Devices | Gets a collection of installed IsisDevice in the system.
Public property | IsDisposed | Gets a value indicating whether the object is disposed.
Public property | LastErrorDescription | Gets description of the last error returned from ISIS device.
Public property | State | Gets a value indicating state of ISIS device.
Top
Methods
 | Name | Description
Public method | Acquire | Acquires an image from the active device.
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the active device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the active device to PDF document.
Public method | Close | Closes any open driver connections.
Public method | Dispose | Closes any ISIS drivers and releases resources back to the system.
Protected method | Dispose(Boolean) | Closes any ISIS drivers and releases resources back to the system.
 | EnumTypeFromSetting | Detects the type of the desired setting.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | IsisController destructor. (Overrides ObjectFinalize.)
Public method | GetAffectedSettings | Returns a list of properties that are affected by changing the specified property value.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntValue | Retrieves setting value as integer.
Public method | GetRationalValue | Retrieves setting value as Rational.
Public method | GetSettingType | Retrieves ISIS type of the specified setting.
Public method | GetStringValue | Retrieve setting value as string.
Public method | GetSupportedIntValues | Gets the list of supported integer values of the specified setting.
Public method | GetSupportedListValues | Gets the list of supported values and currently selected value index.
Public method | GetSupportedRationalValues | Gets the list of supported Rational values of the specified setting.
Public method | GetSupportedSettings | Gets the list of supported settings.
Public method | GetSupportedStringValues | Gets the list of supported string values of the specified setting.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens active ISIS device.
Public method | QuerySupport | Checks whether the specified setting is supported by ISIS device.
Public method | RestoreIniSettings | Restores configuration of the active device from the specified INI file.
Public method | RestoreSettings(Stream) | Restores configuration information of active device from.
Public method | RestoreSettings(String) | Restores configuration information of active device from.
Public method | RestoreSettings(ISettingDataManager) | Restores configuration information of active device from.
Public method | SaveIniSettings | Saves configuration information of the active device to the specified INI file.
Public method | SaveSettings(Stream) | Saves configuration of the active device to the stream.
Public method | SaveSettings(String) | Saves configuration of the active device to the specified file.
Public method | SaveSettings(ISettingDataManager) | Saves configuration of the active device to a data manager.
Public method | SetIntValue | Sets integer setting value.
Public method | SetRationalValue | Sets Rational setting value.
Public method | SetStringValue | Sets string setting value.
Public method | ShowConfigurationDialog | Displays a dialog box showing configuration information for a scanner and allowing the configuration information to be changed by the user.
Public method | ShowDeviceDialog | Displays a scanner configuration dialog, allowing users to change scan settings.
Public method | ShowSelectSource | Shows Select Source dialog which allows the user to select, add, or configure a scanner.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AcquireCanceled | This event will fire if the user has canceled the acquisition.
Public event | AcquireFinished | This event will fire when all of the images have been acquired. This is useful when a document feeder is used.
Public event | BarcodeDetected | This event is fired to notify the application when a barcode is detected.
Public event | DataAcquired | This event fires after the data has been transferred but before it has been processed by DotIsis.
Public event | ErrorNotification | This event is fired error is appeared.
Public event | FileAcquisition | This event is fired just before acquiring an image directly to file. You must fill in the FileName property of the IsisFileAcquisitionEventArgs object.
Public event | ImageAcquired | This event will fire for each image acquired.
Public event | ImageAcquiring | This event is fired before the data is transferred from the device, allows the transfer to be canceled.
Public event | Yield | This event is fired during scanning and allows an application to implement yield function in order to obtain processor attention when the SDK performs such a long operation.
Top
Remarks

Error handling.

In case of problems in attempt to access ISIS device, IsisController methods can throw IsisException or fire ErrorNotification event depends on whether ErrorNotification event is handled in user's code or not. In case if the event is handled, the ErrorNotification is fired and the method, where the problem occurred, returns default value if applicable.
See Also

Reference

Atalasoft.Isis Namespace


IsisController Constructor

Initializes a new instance of IsisController class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisController()
Public Sub New
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController Properties

The IsisController type exposes the following members.

Properties
 | Name | Description
Public property | AcquiredImageType | Gets or sets the type of image to be returned from a scanner. The default value is AtalaImage.
Public property | ActiveDevice | Gets or sets the IsisDevice to work with.
Public property | CodecManager | Gets the list of available codecs that can be used to compress scanned image data.
Public property | Devices | Gets a collection of installed IsisDevice in the system.
Public property | IsDisposed | Gets a value indicating whether the object is disposed.
Public property | LastErrorDescription | Gets description of the last error returned from ISIS device.
Public property | State | Gets a value indicating state of ISIS device.
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.AcquiredImageType Property

IsisControllerAcquiredImageType Property

Gets or sets the type of image to be returned from a scanner. The default value is AtalaImage.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisAcquiredImageType AcquiredImageType { get; set; }
Public Property AcquiredImageType As IsisAcquiredImageType
    Get
    Set

Property Value

Type: IsisAcquiredImageType
Remarks
After an image data is acquired from a scanner, DotIsis wraps it with an object that can be used further in an application. By default, AtalaImage is produced. However, if needed user may instruct the SDK to produce Bitmap object.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisAcquiredImageType


IsisController.ActiveDevice Property

IsisControllerActiveDevice Property

Gets or sets the IsisDevice to work with.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDevice ActiveDevice { get; set; }
Public Property ActiveDevice As IsisDevice
    Get
    Set

Property Value

Type: IsisDevice
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.CodecManager Property

IsisControllerCodecManager Property

Gets the list of available codecs that can be used to compress scanned image data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCodecManager CodecManager { get; }
Public ReadOnly Property CodecManager As IsisCodecManager
    Get

Property Value

Type: IsisCodecManager
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Devices Property

IsisControllerDevices Property

Gets a collection of installed IsisDevice in the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDeviceCollection Devices { get; }
Public ReadOnly Property Devices As IsisDeviceCollection
    Get

Property Value

Type: IsisDeviceCollection
A IsisDeviceCollection object containing ISIS devices found on the system.
Remarks
It's possible a device may be listed even when it's not connected.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisDevice


IsisController.IsDisposed Property

IsisControllerIsDisposed Property

Gets a value indicating whether the object is disposed.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.LastErrorDescription Property

IsisControllerLastErrorDescription Property

Gets description of the last error returned from ISIS device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LastErrorDescription { get; }
Public ReadOnly Property LastErrorDescription As String
    Get

Property Value

Type: String
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.State Property

IsisControllerState Property

Gets a value indicating state of ISIS device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisState State { get; }
Public ReadOnly Property State As IsisState
    Get

Property Value

Type: IsisState
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisState


IsisController Methods

The IsisController type exposes the following members.

Methods
 | Name | Description
Public method | Acquire | Acquires an image from the active device.
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the active device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the active device to PDF document.
Public method | Close | Closes any open driver connections.
Public method | Dispose | Closes any ISIS drivers and releases resources back to the system.
Protected method | Dispose(Boolean) | Closes any ISIS drivers and releases resources back to the system.
 | EnumTypeFromSetting | Detects the type of the desired setting.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | IsisController destructor. (Overrides ObjectFinalize.)
Public method | GetAffectedSettings | Returns a list of properties that are affected by changing the specified property value.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntValue | Retrieves setting value as integer.
Public method | GetRationalValue | Retrieves setting value as Rational.
Public method | GetSettingType | Retrieves ISIS type of the specified setting.
Public method | GetStringValue | Retrieve setting value as string.
Public method | GetSupportedIntValues | Gets the list of supported integer values of the specified setting.
Public method | GetSupportedListValues | Gets the list of supported values and currently selected value index.
Public method | GetSupportedRationalValues | Gets the list of supported Rational values of the specified setting.
Public method | GetSupportedSettings | Gets the list of supported settings.
Public method | GetSupportedStringValues | Gets the list of supported string values of the specified setting.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens active ISIS device.
Public method | QuerySupport | Checks whether the specified setting is supported by ISIS device.
Public method | RestoreIniSettings | Restores configuration of the active device from the specified INI file.
Public method | RestoreSettings(Stream) | Restores configuration information of active device from.
Public method | RestoreSettings(String) | Restores configuration information of active device from.
Public method | RestoreSettings(ISettingDataManager) | Restores configuration information of active device from.
Public method | SaveIniSettings | Saves configuration information of the active device to the specified INI file.
Public method | SaveSettings(Stream) | Saves configuration of the active device to the stream.
Public method | SaveSettings(String) | Saves configuration of the active device to the specified file.
Public method | SaveSettings(ISettingDataManager) | Saves configuration of the active device to a data manager.
Public method | SetIntValue | Sets integer setting value.
Public method | SetRationalValue | Sets Rational setting value.
Public method | SetStringValue | Sets string setting value.
Public method | ShowConfigurationDialog | Displays a dialog box showing configuration information for a scanner and allowing the configuration information to be changed by the user.
Public method | ShowDeviceDialog | Displays a scanner configuration dialog, allowing users to change scan settings.
Public method | ShowSelectSource | Shows Select Source dialog which allows the user to select, add, or configure a scanner.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Acquire Method

IsisControllerAcquire Method

Acquires an image from the active device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Acquire()
Public Function Acquire As Boolean

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks
The ImageAcquired event must be handled as it is raised for each image that is acquired.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace
IsisControllerActiveDevice


IsisController.AcquireToFile Method

IsisControllerAcquireToFile Method

Overload List
 | Name | Description
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the active device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the active device to PDF document.
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.AcquireToFile Method (IsisFileType, IsisCompression)

IsisControllerAcquireToFile Method (IsisFileType, IsisCompression)

Acquires an image from the active device to a file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AcquireToFile(
    IsisFileType fileType,
    IsisCompression compression
)
Public Function AcquireToFile (
    fileType As IsisFileType,
    compression As IsisCompression
) As Boolean

Parameters

fileType
Type: Atalasoft.IsisIsisFileType
Specifies a file format to be used to save image.
compression
Type: Atalasoft.IsisIsisCompression
Specifies desired image data compression.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks
The event should be handled in order to specify file name.
See Also

Reference

IsisController Class
AcquireToFile Overload
Atalasoft.Isis Namespace
IsisControllerFileAcquisition
IsisControllerActiveDevice


IsisController.AcquireToFile Method (IsisCompression, String, String, String, String, String)

IsisControllerAcquireToFile Method (IsisCompression, String, String, String, String, String)

Acquires an image from the active device to PDF document.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AcquireToFile(
    IsisCompression compression,
    string author,
    string creator,
    string title,
    string subject,
    string keywords
)
Public Function AcquireToFile (
    compression As IsisCompression,
    author As String,
    creator As String,
    title As String,
    subject As String,
    keywords As String
) As Boolean

Parameters

compression
Type: Atalasoft.IsisIsisCompression
Specifies desired image data compression.
author
Type: SystemString
Specifies PDF document author.
creator
Type: SystemString
Specifies PDF document creator tag.
title
Type: SystemString
Specifies PDF document title.
subject
Type: SystemString
Specifies PDF document subject tag.
keywords
Type: SystemString
Specifies PDF document keywords.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks
The event should be handled in order to specify file name.
See Also

Reference

IsisController Class
AcquireToFile Overload
Atalasoft.Isis Namespace
IsisControllerFileAcquisition
IsisControllerActiveDevice


IsisController.Close Method

IsisControllerClose Method

Closes any open driver connections.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Dispose Method

IsisControllerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Closes any ISIS drivers and releases resources back to the system.
Protected method | Dispose(Boolean) | Closes any ISIS drivers and releases resources back to the system.
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Dispose Method

IsisControllerDispose Method

Closes any ISIS drivers and releases resources back to the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

IsisController Class
Dispose Overload
Atalasoft.Isis Namespace


IsisController.Dispose Method (Boolean)

IsisControllerDispose Method (Boolean)

Closes any ISIS drivers and releases resources back to the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from the Dispose method or the Finalizer.
See Also

Reference

IsisController Class
Dispose Overload
Atalasoft.Isis Namespace


IsisController.EnumTypeFromSetting Method

IsisControllerEnumTypeFromSetting Method

Detects the type of the desired setting.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Type EnumTypeFromSetting(
    IsisSetting setting
)
Public Shared Function EnumTypeFromSetting (
    setting As IsisSetting
) As Type

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Settings to check.

Return Value

Type: Type
Type of the specified setting or null.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Finalize Method

IsisControllerFinalize Method

IsisController destructor.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetAffectedSettings Method

IsisControllerGetAffectedSettings Method

Returns a list of properties that are affected by changing the specified property value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSetting[] GetAffectedSettings(
    IsisSetting setting
)
Public Function GetAffectedSettings (
    setting As IsisSetting
) As IsisSetting()

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: IsisSetting
An array of affected property names.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetIntValue Method

IsisControllerGetIntValue Method

Retrieves setting value as integer.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetIntValue(
    IsisSetting setting,
    int index
)
Public Function GetIntValue (
    setting As IsisSetting,
    index As Integer
) As Integer

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to retrieve.
index
Type: SystemInt32
Index of the element to get. Most settings have only one element, in this case the index must be set to 0.

Return Value

Type: Int32
Setting value.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetRationalValue Method

IsisControllerGetRationalValue Method

Retrieves setting value as Rational.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational GetRationalValue(
    IsisSetting setting,
    int index
)
Public Function GetRationalValue (
    setting As IsisSetting,
    index As Integer
) As Rational

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to retrieve.
index
Type: SystemInt32
Index of the element to get. Most settings have only one element, in this case the index must be set to 0.

Return Value

Type: Rational
Setting value.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetSettingType Method

IsisControllerGetSettingType Method

Retrieves ISIS type of the specified setting.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSettingType GetSettingType(
    IsisSetting setting
)
Public Function GetSettingType (
    setting As IsisSetting
) As IsisSettingType

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: IsisSettingType
ISIS type of setting.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetStringValue Method

IsisControllerGetStringValue Method

Retrieve setting value as string.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetStringValue(
    IsisSetting setting
)
Public Function GetStringValue (
    setting As IsisSetting
) As String

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to retrieve.

Return Value

Type: String
Setting value.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetSupportedIntValues Method

IsisControllerGetSupportedIntValues Method

Gets the list of supported integer values of the specified setting.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedIntValues(
    IsisSetting setting
)
Public Function GetSupportedIntValues (
    setting As IsisSetting
) As Integer()

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: Int32
List of supported values.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetSupportedListValues Method

IsisControllerGetSupportedListValues Method

Gets the list of supported values and currently selected value index.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GetSupportedListValues(
    IsisSetting setting,
    ref Object[] list,
    ref int selectedIndex
)
Public Function GetSupportedListValues (
    setting As IsisSetting,
    ByRef list As Object(),
    ByRef selectedIndex As Integer
) As Boolean

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.
list
Type: SystemObject
The list object that receives the list of supported value.
selectedIndex
Type: SystemInt32
The value that receives current value in the name.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetSupportedRationalValues Method

IsisControllerGetSupportedRationalValues Method

Gets the list of supported Rational values of the specified setting.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational[] GetSupportedRationalValues(
    IsisSetting setting
)
Public Function GetSupportedRationalValues (
    setting As IsisSetting
) As Rational()

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: Rational
List of supported values.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetSupportedSettings Method

IsisControllerGetSupportedSettings Method

Gets the list of supported settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSetting[] GetSupportedSettings(
    bool excludeUnknownSettings
)
Public Function GetSupportedSettings (
    excludeUnknownSettings As Boolean
) As IsisSetting()

Parameters

excludeUnknownSettings
Type: SystemBoolean
The value indicating whether the settings other than defined in IsisSetting should be included.

Return Value

Type: IsisSetting
The list of supported settings.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.GetSupportedStringValues Method

IsisControllerGetSupportedStringValues Method

Gets the list of supported string values of the specified setting.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetSupportedStringValues(
    IsisSetting setting
)
Public Function GetSupportedStringValues (
    setting As IsisSetting
) As String()

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: String
List of supported values.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Open Method

IsisControllerOpen Method

Opens active ISIS device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Open()
Public Function Open As Boolean

Return Value

Type: Boolean
Exceptions
Exception | Condition
IsisException | In case of error in attempt to open active device.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace
IsisControllerActiveDevice


IsisController.QuerySupport Method

IsisControllerQuerySupport Method

Checks whether the specified setting is supported by ISIS device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool QuerySupport(
    IsisSetting setting
)
Public Function QuerySupport (
    setting As IsisSetting
) As Boolean

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: Boolean
true if the specified setting is supported, otherwise false.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.RestoreIniSettings Method

IsisControllerRestoreIniSettings Method

Restores configuration of the active device from the specified INI file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RestoreIniSettings(
    string fileName,
    string section
)
Public Function RestoreIniSettings (
    fileName As String,
    section As String
) As Boolean

Parameters

fileName
Type: SystemString
The name of INI file.
section
Type: SystemString
The name of [Section] from which the configuration have to be taken.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.RestoreSettings Method

IsisControllerRestoreSettings Method

Overload List
 | Name | Description
Public method | RestoreSettings(Stream) | Restores configuration information of active device from.
Public method | RestoreSettings(String) | Restores configuration information of active device from.
Public method | RestoreSettings(ISettingDataManager) | Restores configuration information of active device from.
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.RestoreSettings Method (Stream)

IsisControllerRestoreSettings Method (Stream)

Restores configuration information of active device from.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RestoreSettings(
    Stream stream
)
Public Function RestoreSettings (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
Stream that contains configuration information.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
RestoreSettings Overload
Atalasoft.Isis Namespace


IsisController.RestoreSettings Method (String)

IsisControllerRestoreSettings Method (String)

Restores configuration information of active device from.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RestoreSettings(
    string fileName
)
Public Function RestoreSettings (
    fileName As String
) As Boolean

Parameters

fileName
Type: SystemString
Name of the file that contains configuration information.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
RestoreSettings Overload
Atalasoft.Isis Namespace


IsisController.RestoreSettings Method (ISettingDataManager)

IsisControllerRestoreSettings Method (ISettingDataManager)

Restores configuration information of active device from.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RestoreSettings(
    ISettingDataManager dataManager
)
Public Function RestoreSettings (
    dataManager As ISettingDataManager
) As Boolean

Parameters

dataManager
Type: Atalasoft.IsisISettingDataManager
Data manager that contains configuration information.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
RestoreSettings Overload
Atalasoft.Isis Namespace


IsisController.SaveIniSettings Method

IsisControllerSaveIniSettings Method

Saves configuration information of the active device to the specified INI file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SaveIniSettings(
    string fileName,
    string section
)
Public Function SaveIniSettings (
    fileName As String,
    section As String
) As Boolean

Parameters

fileName
Type: SystemString
The name of INI file.
section
Type: SystemString
The name of the [Section] in which the configuration information have to be saved.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.SaveSettings Method

IsisControllerSaveSettings Method

Overload List
 | Name | Description
Public method | SaveSettings(Stream) | Saves configuration of the active device to the stream.
Public method | SaveSettings(String) | Saves configuration of the active device to the specified file.
Public method | SaveSettings(ISettingDataManager) | Saves configuration of the active device to a data manager.
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.SaveSettings Method (Stream)

IsisControllerSaveSettings Method (Stream)

Saves configuration of the active device to the stream.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SaveSettings(
    Stream stream
)
Public Function SaveSettings (
    stream As Stream
) As Boolean

Parameters

stream
Type: System.IOStream
Stream object to store configuration information.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
SaveSettings Overload
Atalasoft.Isis Namespace


IsisController.SaveSettings Method (String)

IsisControllerSaveSettings Method (String)

Saves configuration of the active device to the specified file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SaveSettings(
    string fileName
)
Public Function SaveSettings (
    fileName As String
) As Boolean

Parameters

fileName
Type: SystemString
Name of the file which should contain configuration.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
SaveSettings Overload
Atalasoft.Isis Namespace


IsisController.SaveSettings Method (ISettingDataManager)

IsisControllerSaveSettings Method (ISettingDataManager)

Saves configuration of the active device to a data manager.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SaveSettings(
    ISettingDataManager dataManager
)
Public Function SaveSettings (
    dataManager As ISettingDataManager
) As Boolean

Parameters

dataManager
Type: Atalasoft.IsisISettingDataManager
Data manager object that should receive configuration information.

Return Value

Type: Boolean
true if operation is succeeded, otherwise false.
See Also

Reference

IsisController Class
SaveSettings Overload
Atalasoft.Isis Namespace


IsisController.SetIntValue Method

IsisControllerSetIntValue Method

Sets integer setting value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetIntValue(
    IsisSetting setting,
    int index,
    int value
)
Public Function SetIntValue (
    setting As IsisSetting,
    index As Integer,
    value As Integer
) As Boolean

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to set.
index
Type: SystemInt32
Index of the element to set. Most settings have only one element, in this case the index must be set to 0.
value
Type: SystemInt32
Value to set.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.SetRationalValue Method

IsisControllerSetRationalValue Method

Sets Rational setting value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetRationalValue(
    IsisSetting setting,
    int index,
    Rational value
)
Public Function SetRationalValue (
    setting As IsisSetting,
    index As Integer,
    value As Rational
) As Boolean

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to set.
index
Type: SystemInt32
value
Type: Atalasoft.Imaging.MetadataRational
Value to set.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.SetStringValue Method

IsisControllerSetStringValue Method

Sets string setting value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetStringValue(
    IsisSetting setting,
    string value
)
Public Function SetStringValue (
    setting As IsisSetting,
    value As String
) As Boolean

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to set.
value
Type: SystemString
Value to set.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Exceptions
Exception | Condition
IsisException | In case of error in attempt to execute the command. See "Error handling" in Remarks section of IsisController class description for more information.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.ShowConfigurationDialog Method

IsisControllerShowConfigurationDialog Method

Displays a dialog box showing configuration information for a scanner and allowing the configuration information to be changed by the user.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowConfigurationDialog(
    IWin32Window parent
)
Public Function ShowConfigurationDialog (
    parent As IWin32Window
) As Boolean

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent for this dialog.

Return Value

Type: Boolean
True if the user selected the OK button.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the parent argument is not provided.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.ShowDeviceDialog Method

IsisControllerShowDeviceDialog Method

Displays a scanner configuration dialog, allowing users to change scan settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowDeviceDialog(
    IWin32Window parent
)
Public Function ShowDeviceDialog (
    parent As IWin32Window
) As Boolean

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent for this dialog.

Return Value

Type: Boolean
True if the user selected the OK button.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the parent argument is not provided.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.ShowSelectSource Method

IsisControllerShowSelectSource Method

Shows Select Source dialog which allows the user to select, add, or configure a scanner.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowSelectSource(
    IWin32Window parent
)
Public Function ShowSelectSource (
    parent As IWin32Window
) As Boolean

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent for this dialog.

Return Value

Type: Boolean
True if the user selected the OK button.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController Events

The IsisController type exposes the following members.

Events
 | Name | Description
Public event | AcquireCanceled | This event will fire if the user has canceled the acquisition.
Public event | AcquireFinished | This event will fire when all of the images have been acquired. This is useful when a document feeder is used.
Public event | BarcodeDetected | This event is fired to notify the application when a barcode is detected.
Public event | DataAcquired | This event fires after the data has been transferred but before it has been processed by DotIsis.
Public event | ErrorNotification | This event is fired error is appeared.
Public event | FileAcquisition | This event is fired just before acquiring an image directly to file. You must fill in the FileName property of the IsisFileAcquisitionEventArgs object.
Public event | ImageAcquired | This event will fire for each image acquired.
Public event | ImageAcquiring | This event is fired before the data is transferred from the device, allows the transfer to be canceled.
Public event | Yield | This event is fired during scanning and allows an application to implement yield function in order to obtain processor attention when the SDK performs such a long operation.
Top
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.AcquireCanceled Event

IsisControllerAcquireCanceled Event

This event will fire if the user has canceled the acquisition.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AcquireCanceled
Public Event AcquireCanceled As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.AcquireFinished Event

IsisControllerAcquireFinished Event

This event will fire when all of the images have been acquired. This is useful when a document feeder is used.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AcquireFinished
Public Event AcquireFinished As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.BarcodeDetected Event

IsisControllerBarcodeDetected Event

This event is fired to notify the application when a barcode is detected.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisBarcodeDetectedEventHandler BarcodeDetected
Public Event BarcodeDetected As IsisBarcodeDetectedEventHandler

Value

Type: Atalasoft.IsisIsisBarcodeDetectedEventHandler
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.DataAcquired Event

IsisControllerDataAcquired Event

This event fires after the data has been transferred but before it has been processed by DotIsis.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisDataAcquiredEventHandler DataAcquired
Public Event DataAcquired As IsisDataAcquiredEventHandler

Value

Type: Atalasoft.IsisIsisDataAcquiredEventHandler
Remarks
This event allows for processing of data DotIsis does not support, such as unique image formats. If this data should not be processed by DotIsis, set the Handled property of the IsisDataAcquiredEventArgs to true.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.ErrorNotification Event

IsisControllerErrorNotification Event

This event is fired error is appeared.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisErrorNotificationEventHandler ErrorNotification
Public Event ErrorNotification As IsisErrorNotificationEventHandler

Value

Type: Atalasoft.IsisIsisErrorNotificationEventHandler
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.FileAcquisition Event

IsisControllerFileAcquisition Event

This event is fired just before acquiring an image directly to file. You must fill in the FileName property of the IsisFileAcquisitionEventArgs object.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisFileAcquisitionEventHandler FileAcquisition
Public Event FileAcquisition As IsisFileAcquisitionEventHandler

Value

Type: Atalasoft.IsisIsisFileAcquisitionEventHandler
Remarks
You can cancel the acquisition by setting the Cancel property of the IsisFileAcquisitionEventArgs to true.
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.ImageAcquired Event

IsisControllerImageAcquired Event

This event will fire for each image acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisImageAcquiredEventHandler ImageAcquired
Public Event ImageAcquired As IsisImageAcquiredEventHandler

Value

Type: Atalasoft.IsisIsisImageAcquiredEventHandler
Remarks

All pending image acquisitions can be canceled by setting the Cancel property of the IsisImageAcquiredEventArgs to true.

To transfer the returned Bitmap to an AtalaImage when integrating with DotImage, use the FromBitmap(Bitmap, Boolean) method.

When scanning multiple pages at once, this method can be used to compose a multipage image by invoking the [!:Imaging.Workspace.Images.Add] method of the Workspace object in DotImage.

See Also

Reference

IsisController Class
Atalasoft.Isis Namespace
Atalasoft.IsisIsisImageAcquiredEventArgs


IsisController.ImageAcquiring Event

IsisControllerImageAcquiring Event

This event is fired before the data is transferred from the device, allows the transfer to be canceled.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event IsisImageAcquiringEventHandler ImageAcquiring
Public Event ImageAcquiring As IsisImageAcquiringEventHandler

Value

Type: Atalasoft.IsisIsisImageAcquiringEventHandler
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisController.Yield Event

IsisControllerYield Event

This event is fired during scanning and allows an application to implement yield function in order to obtain processor attention when the SDK performs such a long operation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler Yield
Public Event Yield As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IsisController Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast Class

Represents brightness/contrast value.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisCustomBrightnessContrast

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisCustomBrightnessContrast
Public Class IsisCustomBrightnessContrast

The IsisCustomBrightnessContrast type exposes the following members.

Constructors
 | Name | Description
Public method | IsisCustomBrightnessContrast | Constructs IsisCustomBrightnessContrast object.
Top
Properties
 | Name | Description
Public property | BlueLevel | Gets or sets blue level value.
Public property | GreenLevel | Gets or sets green level value.
Public property | RedLevel | Gets or sets red level value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisCustomBrightnessContrast Constructor

Constructs IsisCustomBrightnessContrast object.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCustomBrightnessContrast(
    int red,
    int green,
    int blue
)
Public Sub New (
    red As Integer,
    green As Integer,
    blue As Integer
)

Parameters

red
Type: SystemInt32
Red level value, should be between 0 and 255.
green
Type: SystemInt32
Green level value, should be between 0 and 255.
blue
Type: SystemInt32
Blue level value, should be between 0 and 255.
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast Properties

The IsisCustomBrightnessContrast type exposes the following members.

Properties
 | Name | Description
Public property | BlueLevel | Gets or sets blue level value.
Public property | GreenLevel | Gets or sets green level value.
Public property | RedLevel | Gets or sets red level value.
Top
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast.BlueLevel Property

IsisCustomBrightnessContrastBlueLevel Property

Gets or sets blue level value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BlueLevel { get; set; }
Public Property BlueLevel As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast.GreenLevel Property

IsisCustomBrightnessContrastGreenLevel Property

Gets or sets green level value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GreenLevel { get; set; }
Public Property GreenLevel As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast.RedLevel Property

IsisCustomBrightnessContrastRedLevel Property

Gets or sets red level value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RedLevel { get; set; }
Public Property RedLevel As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast Methods

The IsisCustomBrightnessContrast type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisCustomBrightnessContrast.ToString Method

IsisCustomBrightnessContrastToString Method

Returns a string that represents the current object.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string that represents the current object.
See Also

Reference

IsisCustomBrightnessContrast Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs Class

Contains information about acquired image data.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.IsisIsisDataAcquiredEventArgs

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisDataAcquiredEventArgs : EventArgs
Public Class IsisDataAcquiredEventArgs
    Inherits EventArgs

The IsisDataAcquiredEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IsisDataAcquiredEventArgs | Initializes a new instance of the IsisDataAcquiredEventArgs class.
Top
Properties
 | Name | Description
Public property | BitsPerSample | Gets the number of bits per sample.
Public property | Compression | Gets a compression scheme used on the image.
Public property | Data | Gets the image data.
Public property | Handled | Gets the value indicating whether the event is handled.
Public property | Orientation | Gets the image orientation.
Public property | PaletteData | Gets the image palette data.
Public property | Photometric | Gets the color space of the image.
Public property | PlanarConfiguration | Gets the way how the components of each pixel are stored.
Public property | Resolution | Gets the image resolution.
Public property | ResolutionUnit | Gets resolution units.
Public property | SamplesPerPixel | Gets the number of samples per pixel.
Public property | Size | Gets the image size.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs Constructor

Initializes a new instance of the IsisDataAcquiredEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDataAcquiredEventArgs(
    IntPtr data,
    Size size,
    int samplesPerPixel,
    int bitsPerSample,
    IsisPhotometric photometric,
    IsisCompression compression,
    IsisPlanarConfiguration planarConfiguration,
    IsisResolutionUnit resolutionUnit,
    Point resolution,
    byte[] palette,
    IsisOrientation orientation
)
Public Sub New (
    data As IntPtr,
    size As Size,
    samplesPerPixel As Integer,
    bitsPerSample As Integer,
    photometric As IsisPhotometric,
    compression As IsisCompression,
    planarConfiguration As IsisPlanarConfiguration,
    resolutionUnit As IsisResolutionUnit,
    resolution As Point,
    palette As Byte(),
    orientation As IsisOrientation
)

Parameters

data
Type: SystemIntPtr
The acquired image data.
size
Type: System.DrawingSize
Size of image.
samplesPerPixel
Type: SystemInt32
Number of samples per pixel.
bitsPerSample
Type: SystemInt32
Number of bits per sample.
photometric
Type: Atalasoft.IsisIsisPhotometric
The color space of the image.
compression
Type: Atalasoft.IsisIsisCompression
Compression scheme used on the image.
planarConfiguration
Type: Atalasoft.IsisIsisPlanarConfiguration
The way how the components of each pixel are stored.
resolutionUnit
Type: Atalasoft.IsisIsisResolutionUnit
The resolution units.
resolution
Type: System.DrawingPoint
The image resolution.
palette
Type: SystemByte
The image palette data.
orientation
Type: Atalasoft.IsisIsisOrientation
The image orientation.
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs Properties

The IsisDataAcquiredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerSample | Gets the number of bits per sample.
Public property | Compression | Gets a compression scheme used on the image.
Public property | Data | Gets the image data.
Public property | Handled | Gets the value indicating whether the event is handled.
Public property | Orientation | Gets the image orientation.
Public property | PaletteData | Gets the image palette data.
Public property | Photometric | Gets the color space of the image.
Public property | PlanarConfiguration | Gets the way how the components of each pixel are stored.
Public property | Resolution | Gets the image resolution.
Public property | ResolutionUnit | Gets resolution units.
Public property | SamplesPerPixel | Gets the number of samples per pixel.
Public property | Size | Gets the image size.
Top
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.BitsPerSample Property

IsisDataAcquiredEventArgsBitsPerSample Property

Gets the number of bits per sample.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BitsPerSample { get; }
Public ReadOnly Property BitsPerSample As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Compression Property

IsisDataAcquiredEventArgsCompression Property

Gets a compression scheme used on the image.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCompression Compression { get; }
Public ReadOnly Property Compression As IsisCompression
    Get

Property Value

Type: IsisCompression
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Data Property

IsisDataAcquiredEventArgsData Property

Gets the image data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr Data { get; }
Public ReadOnly Property Data As IntPtr
    Get

Property Value

Type: IntPtr
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Handled Property

IsisDataAcquiredEventArgsHandled Property

Gets the value indicating whether the event is handled.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Orientation Property

IsisDataAcquiredEventArgsOrientation Property

Gets the image orientation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisOrientation Orientation { get; }
Public ReadOnly Property Orientation As IsisOrientation
    Get

Property Value

Type: IsisOrientation
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.PaletteData Property

IsisDataAcquiredEventArgsPaletteData Property

Gets the image palette data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] PaletteData { get; }
Public ReadOnly Property PaletteData As Byte()
    Get

Property Value

Type: Byte
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Photometric Property

IsisDataAcquiredEventArgsPhotometric Property

Gets the color space of the image.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisPhotometric Photometric { get; }
Public ReadOnly Property Photometric As IsisPhotometric
    Get

Property Value

Type: IsisPhotometric
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.PlanarConfiguration Property

IsisDataAcquiredEventArgsPlanarConfiguration Property

Gets the way how the components of each pixel are stored.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisPlanarConfiguration PlanarConfiguration { get; }
Public ReadOnly Property PlanarConfiguration As IsisPlanarConfiguration
    Get

Property Value

Type: IsisPlanarConfiguration
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Resolution Property

IsisDataAcquiredEventArgsResolution Property

Gets the image resolution.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Resolution { get; }
Public ReadOnly Property Resolution As Point
    Get

Property Value

Type: Point
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.ResolutionUnit Property

IsisDataAcquiredEventArgsResolutionUnit Property

Gets resolution units.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisResolutionUnit ResolutionUnit { get; }
Public ReadOnly Property ResolutionUnit As IsisResolutionUnit
    Get

Property Value

Type: IsisResolutionUnit
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.SamplesPerPixel Property

IsisDataAcquiredEventArgsSamplesPerPixel Property

Gets the number of samples per pixel.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SamplesPerPixel { get; }
Public ReadOnly Property SamplesPerPixel As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs.Size Property

IsisDataAcquiredEventArgsSize Property

Gets the image size.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get

Property Value

Type: Size
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventArgs Methods

The IsisDataAcquiredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisDataAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisDataAcquiredEventHandler Delegate

This event handler is used to notify the application when image data is acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void IsisDataAcquiredEventHandler(
    Object sender,
    IsisDataAcquiredEventArgs e
)
Public Delegate Sub IsisDataAcquiredEventHandler (
    sender As Object,
    e As IsisDataAcquiredEventArgs
)

Parameters

sender
Type: SystemObject
The event sender.
e
Type: Atalasoft.IsisIsisDataAcquiredEventArgs
The information about acquired image data.
See Also

Reference

Atalasoft.Isis Namespace


IsisDevice Class

Represents ISIS device.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisDevice

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisDevice
Public Class IsisDevice

The IsisDevice type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the device controller.
Public property | Location | Gets the device location.
Public property | Name | Gets the device name.
Public property | Settings | Gets the settings.
Public property | State | Gets the controller state.
Top
Methods
 | Name | Description
Public method | Acquire | Acquires an image from the device.
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the device to PDF document.
Public method | Close | Closes the device.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the device.
Public method | ShowDeviceDialog | Displays a scanner configuration dialog, allowing users to change scan settings.
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisDevice Properties

The IsisDevice type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the device controller.
Public property | Location | Gets the device location.
Public property | Name | Gets the device name.
Public property | Settings | Gets the settings.
Public property | State | Gets the controller state.
Top
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.Controller Property

IsisDeviceController Property

Gets the device controller.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisController Controller { get; }
Public ReadOnly Property Controller As IsisController
    Get

Property Value

Type: IsisController
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.Location Property

IsisDeviceLocation Property

Gets the device location.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get

Property Value

Type: String
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.Name Property

IsisDeviceName Property

Gets the device name.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.Settings Property

IsisDeviceSettings Property

Gets the settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSettings Settings { get; }
Public ReadOnly Property Settings As IsisSettings
    Get

Property Value

Type: IsisSettings
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.State Property

IsisDeviceState Property

Gets the controller state.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisState State { get; }
Public ReadOnly Property State As IsisState
    Get

Property Value

Type: IsisState
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice Methods

The IsisDevice type exposes the following members.

Methods
 | Name | Description
Public method | Acquire | Acquires an image from the device.
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the device to PDF document.
Public method | Close | Closes the device.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the device.
Public method | ShowDeviceDialog | Displays a scanner configuration dialog, allowing users to change scan settings.
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.Acquire Method

IsisDeviceAcquire Method

Acquires an image from the device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Acquire()
Public Function Acquire As Boolean

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks
In order to control scanning process various events defined in IsisController class can be used. See Acquire method for details.
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.AcquireToFile Method

IsisDeviceAcquireToFile Method

Overload List
 | Name | Description
Public method | AcquireToFile(IsisFileType, IsisCompression) | Acquires an image from the device to a file.
Public method | AcquireToFile(IsisCompression, String, String, String, String, String) | Acquires an image from the device to PDF document.
Top
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.AcquireToFile Method (IsisFileType, IsisCompression)

IsisDeviceAcquireToFile Method (IsisFileType, IsisCompression)

Acquires an image from the device to a file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AcquireToFile(
    IsisFileType fileType,
    IsisCompression compression
)
Public Function AcquireToFile (
    fileType As IsisFileType,
    compression As IsisCompression
) As Boolean

Parameters

fileType
Type: Atalasoft.IsisIsisFileType
Specifies a file format to be used to save image.
compression
Type: Atalasoft.IsisIsisCompression
Specifies desired image data compression.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks
In order to control scanning process various events defined in IsisController class can be used. See AcquireToFile(IsisFileType, IsisCompression) method for details.
See Also

Reference

IsisDevice Class
AcquireToFile Overload
Atalasoft.Isis Namespace


IsisDevice.AcquireToFile Method (IsisCompression, String, String, String, String, String)

IsisDeviceAcquireToFile Method (IsisCompression, String, String, String, String, String)

Acquires an image from the device to PDF document.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AcquireToFile(
    IsisCompression compression,
    string author,
    string creator,
    string title,
    string subject,
    string keywords
)
Public Function AcquireToFile (
    compression As IsisCompression,
    author As String,
    creator As String,
    title As String,
    subject As String,
    keywords As String
) As Boolean

Parameters

compression
Type: Atalasoft.IsisIsisCompression
Specifies desired image data compression.
author
Type: SystemString
Specifies PDF document author.
creator
Type: SystemString
Specifies PDF document creator tag.
title
Type: SystemString
Specifies PDF document title.
subject
Type: SystemString
Specifies PDF document subject tag.
keywords
Type: SystemString
Specifies PDF document keywords.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
Remarks
In order to control scanning process various events defined in IsisController class can be used. See AcquireToFile(IsisCompression, String, String, String, String, String) method for details.
See Also

Reference

IsisDevice Class
AcquireToFile Overload
Atalasoft.Isis Namespace


IsisDevice.Close Method

IsisDeviceClose Method

Closes the device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.Open Method

IsisDeviceOpen Method

Opens the device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Open()
Public Function Open As Boolean

Return Value

Type: Boolean
true id device is opened successfully, otherwise false.
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.ShowDeviceDialog Method

IsisDeviceShowDeviceDialog Method

Displays a scanner configuration dialog, allowing users to change scan settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowDeviceDialog(
    IWin32Window parent
)
Public Function ShowDeviceDialog (
    parent As IWin32Window
) As Boolean

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent for this dialog.

Return Value

Type: Boolean
True if the user selected the OK button.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the parent argument is not provided.
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDevice.ToString Method

IsisDeviceToString Method

Returns a string that represents the current object.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string that represents the current object.
See Also

Reference

IsisDevice Class
Atalasoft.Isis Namespace


IsisDeviceCollection Class

Represents the list of ISIS devices installed on the system.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.IsisIsisDeviceCollection

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisDeviceCollection : ReadOnlyCollectionBase
Public Class IsisDeviceCollection
    Inherits ReadOnlyCollectionBase

The IsisDeviceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Default | Gets default ISIS device.
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | ItemInt32 | Gets IsisDevice by index.
Public property | ItemString | Gets IsisDevice by name.
Top
Methods
 | Name | Description
Public method | CopyTo | Copies all the elements of ISIS devices array to the specified one-dimensional array starting at the specified destination array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshList | Clears and reloads the collection with a list of devices.
Public method | ToArray | Gets the list of installed ISIS devices.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisDeviceCollection Properties

The IsisDeviceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Default | Gets default ISIS device.
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | ItemInt32 | Gets IsisDevice by index.
Public property | ItemString | Gets IsisDevice by name.
Top
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDeviceCollection.Default Property

IsisDeviceCollectionDefault Property

Gets default ISIS device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDevice Default { get; }
Public ReadOnly Property Default As IsisDevice
    Get

Property Value

Type: IsisDevice
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDeviceCollection.Item Property

IsisDeviceCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets IsisDevice by index.
Public property | ItemString | Gets IsisDevice by name.
Top
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDeviceCollection.Item Property (Int32)

IsisDeviceCollectionItem Property (Int32)

Gets IsisDevice by index.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDevice this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IsisDevice
    Get

Parameters

index
Type: SystemInt32
Index of the IsisDevice in the list.

Return Value

Type: IsisDevice
ISIS device.
See Also

Reference

IsisDeviceCollection Class
Item Overload
Atalasoft.Isis Namespace


IsisDeviceCollection.Item Property (String)

IsisDeviceCollectionItem Property (String)

Gets IsisDevice by name.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDevice this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IsisDevice
    Get

Parameters

name
Type: SystemString
Name of the IsisDevice in the list.

Return Value

Type: IsisDevice
ISIS device.
See Also

Reference

IsisDeviceCollection Class
Item Overload
Atalasoft.Isis Namespace


IsisDeviceCollection Methods

The IsisDeviceCollection type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies all the elements of ISIS devices array to the specified one-dimensional array starting at the specified destination array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshList | Clears and reloads the collection with a list of devices.
Public method | ToArray | Gets the list of installed ISIS devices.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDeviceCollection.CopyTo Method

IsisDeviceCollectionCopyTo Method

Copies all the elements of ISIS devices array to the specified one-dimensional array starting at the specified destination array index.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    IsisDevice[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As IsisDevice(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.IsisIsisDevice
The array to which the list of ISIS devices should be copied.>
arrayIndex
Type: SystemInt32
Index in array at which copying begins.
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDeviceCollection.RefreshList Method

IsisDeviceCollectionRefreshList Method

Clears and reloads the collection with a list of devices.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RefreshList()
Public Function RefreshList As Integer

Return Value

Type: Int32
The number of devices found.
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDeviceCollection.ToArray Method

IsisDeviceCollectionToArray Method

Gets the list of installed ISIS devices.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDevice[] ToArray()
Public Function ToArray As IsisDevice()

Return Value

Type: IsisDevice
List of ISIS devices.
See Also

Reference

IsisDeviceCollection Class
Atalasoft.Isis Namespace


IsisDocumentFeeder Class

Represents feeder related configuration values.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisDocumentFeeder

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisDocumentFeeder
Public Class IsisDocumentFeeder

The IsisDocumentFeeder type exposes the following members.

Properties
 | Name | Description
Public property | CanPause | Gets a value indicating whether the scanner can stop scan ahead and process all pages from the buffer that have been already scanned.
Public property | Exists | Gets a value indicating whether feeder exists on the device.
Public property | ImmediateStop | Gets or sets a value indicating whether the scanner will stop immediately or will finish the page being scanned when the user presses the Stop button.
Public property | MaximumPageCount | Gets maximum number of pages which may be loaded in the scanner's feeder.
Public property | PageDetection | Gets a value indicating whether the scanner is able to detect if there are pages in scanner's feeder.
Public property | StopScanAheadOnPause | Gets or sets a value indicating whether the scanner should stop its scan ahead support when paused or only slow down.
Public property | Timeout | Gets or sets the number of seconds the scanner will attempt to read the next page before reporting that no page was found.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisDocumentFeeder Properties

The IsisDocumentFeeder type exposes the following members.

Properties
 | Name | Description
Public property | CanPause | Gets a value indicating whether the scanner can stop scan ahead and process all pages from the buffer that have been already scanned.
Public property | Exists | Gets a value indicating whether feeder exists on the device.
Public property | ImmediateStop | Gets or sets a value indicating whether the scanner will stop immediately or will finish the page being scanned when the user presses the Stop button.
Public property | MaximumPageCount | Gets maximum number of pages which may be loaded in the scanner's feeder.
Public property | PageDetection | Gets a value indicating whether the scanner is able to detect if there are pages in scanner's feeder.
Public property | StopScanAheadOnPause | Gets or sets a value indicating whether the scanner should stop its scan ahead support when paused or only slow down.
Public property | Timeout | Gets or sets the number of seconds the scanner will attempt to read the next page before reporting that no page was found.
Top
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.CanPause Property

IsisDocumentFeederCanPause Property

Gets a value indicating whether the scanner can stop scan ahead and process all pages from the buffer that have been already scanned.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanPause { get; }
Public ReadOnly Property CanPause As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.Exists Property

IsisDocumentFeederExists Property

Gets a value indicating whether feeder exists on the device.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.ImmediateStop Property

IsisDocumentFeederImmediateStop Property

Gets or sets a value indicating whether the scanner will stop immediately or will finish the page being scanned when the user presses the Stop button.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ImmediateStop { get; set; }
Public Property ImmediateStop As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.MaximumPageCount Property

IsisDocumentFeederMaximumPageCount Property

Gets maximum number of pages which may be loaded in the scanner's feeder.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumPageCount { get; }
Public ReadOnly Property MaximumPageCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.PageDetection Property

IsisDocumentFeederPageDetection Property

Gets a value indicating whether the scanner is able to detect if there are pages in scanner's feeder.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PageDetection { get; }
Public ReadOnly Property PageDetection As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.StopScanAheadOnPause Property

IsisDocumentFeederStopScanAheadOnPause Property

Gets or sets a value indicating whether the scanner should stop its scan ahead support when paused or only slow down.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool StopScanAheadOnPause { get; set; }
Public Property StopScanAheadOnPause As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder.Timeout Property

IsisDocumentFeederTimeout Property

Gets or sets the number of seconds the scanner will attempt to read the next page before reporting that no page was found.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set

Property Value

Type: Int32
The number of seconds before the scanner will timeout.
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisDocumentFeeder Methods

The IsisDocumentFeeder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisDocumentFeeder Class
Atalasoft.Isis Namespace


IsisEmphasis Enumeration

Available emphasis settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisEmphasis
Public Enumeration IsisEmphasis
Members
Member name | Description
Off | No emphasis.
High | High emphasis settings.
Low | Low emphasis settings.
Medium | Medium emphasis settings.
Smooth | Smooth emphasis setting.
See Also

Reference

Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Class

Contains information about the acquired error.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.IsisIsisErrorNotificationEventArgs

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisErrorNotificationEventArgs : EventArgs
Public Class IsisErrorNotificationEventArgs
    Inherits EventArgs

The IsisErrorNotificationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IsisErrorNotificationEventArgs | Initializes a new instance of the IsisErrorNotificationEventArgs class.
Public method | IsisErrorNotificationEventArgs(String) | Initializes a new instance of the IsisErrorNotificationEventArgs class.
Public method | IsisErrorNotificationEventArgs(String, Exception) | Initializes a new instance of the IsisErrorNotificationEventArgs class.
Top
Properties
 | Name | Description
Public property | Exception | Gets the thrown exception.
Public property | Message | Gets the error message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Constructor

Overload List
 | Name | Description
Public method | IsisErrorNotificationEventArgs | Initializes a new instance of the IsisErrorNotificationEventArgs class.
Public method | IsisErrorNotificationEventArgs(String) | Initializes a new instance of the IsisErrorNotificationEventArgs class.
Public method | IsisErrorNotificationEventArgs(String, Exception) | Initializes a new instance of the IsisErrorNotificationEventArgs class.
Top
See Also

Reference

IsisErrorNotificationEventArgs Class
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Constructor

Initializes a new instance of the IsisErrorNotificationEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisErrorNotificationEventArgs()
Public Sub New
See Also

Reference

IsisErrorNotificationEventArgs Class
IsisErrorNotificationEventArgs Overload
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Constructor (String)

Initializes a new instance of the IsisErrorNotificationEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisErrorNotificationEventArgs(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The error message.
See Also

Reference

IsisErrorNotificationEventArgs Class
IsisErrorNotificationEventArgs Overload
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Constructor (String, Exception)

Initializes a new instance of the IsisErrorNotificationEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisErrorNotificationEventArgs(
    string message,
    Exception exception
)
Public Sub New (
    message As String,
    exception As Exception
)

Parameters

message
Type: SystemString
The error message.
exception
Type: SystemException
The thrown exception.
See Also

Reference

IsisErrorNotificationEventArgs Class
IsisErrorNotificationEventArgs Overload
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Properties

The IsisErrorNotificationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets the thrown exception.
Public property | Message | Gets the error message.
Top
See Also

Reference

IsisErrorNotificationEventArgs Class
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs.Exception Property

IsisErrorNotificationEventArgsException Property

Gets the thrown exception.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get

Property Value

Type: Exception
See Also

Reference

IsisErrorNotificationEventArgs Class
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs.Message Property

IsisErrorNotificationEventArgsMessage Property

Gets the error message.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get

Property Value

Type: String
See Also

Reference

IsisErrorNotificationEventArgs Class
Atalasoft.Isis Namespace


IsisErrorNotificationEventArgs Methods

The IsisErrorNotificationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisErrorNotificationEventArgs Class
Atalasoft.Isis Namespace


IsisErrorNotificationEventHandler Delegate

This event handler is used to notify the application when error is appeared.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void IsisErrorNotificationEventHandler(
    Object sender,
    IsisErrorNotificationEventArgs e
)
Public Delegate Sub IsisErrorNotificationEventHandler (
    sender As Object,
    e As IsisErrorNotificationEventArgs
)

Parameters

sender
Type: SystemObject
The event sender.
e
Type: Atalasoft.IsisIsisErrorNotificationEventArgs
The information about error.
See Also

Reference

Atalasoft.Isis Namespace


IsisException Class

Represents ISIS exception.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.IsisIsisException

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IsisException : Exception
<SerializableAttribute>
Public Class IsisException
    Inherits Exception

The IsisException type exposes the following members.

Constructors
 | Name | Description
Public method | IsisException | Initializes a new instance of the IsisException class.
Public method | IsisException(String) | Initializes a new instance of the IsisException class.
Protected method | IsisException(SerializationInfo, StreamingContext) | Initializes a new instance of the IsisException class.
Public method | IsisException(String, Exception) | Initializes a new instance of the IsisException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisException Constructor

Overload List
 | Name | Description
Public method | IsisException | Initializes a new instance of the IsisException class.
Public method | IsisException(String) | Initializes a new instance of the IsisException class.
Protected method | IsisException(SerializationInfo, StreamingContext) | Initializes a new instance of the IsisException class.
Public method | IsisException(String, Exception) | Initializes a new instance of the IsisException class.
Top
See Also

Reference

IsisException Class
Atalasoft.Isis Namespace


IsisException Constructor

Initializes a new instance of the IsisException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisException()
Public Sub New
See Also

Reference

IsisException Class
IsisException Overload
Atalasoft.Isis Namespace


IsisException Constructor (String)

Initializes a new instance of the IsisException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

IsisException Class
IsisException Overload
Atalasoft.Isis Namespace


IsisException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the IsisException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected IsisException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
Contextual information about the source or destination.
See Also

Reference

IsisException Class
IsisException Overload
Atalasoft.Isis Namespace


IsisException Constructor (String, Exception)

Initializes a new instance of the IsisException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
The inner exception.
See Also

Reference

IsisException Class
IsisException Overload
Atalasoft.Isis Namespace


IsisException Properties

The IsisException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

IsisException Class
Atalasoft.Isis Namespace


IsisException Methods

The IsisException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

IsisException Class
Atalasoft.Isis Namespace


IsisException Events

The IsisException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

IsisException Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs Class

Contains information about acquired file.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.IsisIsisFileAcquisitionEventArgs

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisFileAcquisitionEventArgs : EventArgs
Public Class IsisFileAcquisitionEventArgs
    Inherits EventArgs

The IsisFileAcquisitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IsisFileAcquisitionEventArgs | Initializes a new instance of the IsisFileAcquisitionEventArgs class.
Top
Properties
 | Name | Description
Public property | Append | Gets or sets a value indicating whether file should be appended to existing file.
Public property | Cancel | Gets or sets a value which determines if the file will be acquired.
Public property | FileName | Gets or sets file name.
Public property | FileType | Gets the file type.
Public property | ScanCount | Gets the scan count.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs Constructor

Initializes a new instance of the IsisFileAcquisitionEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisFileAcquisitionEventArgs(
    IsisFileType fileType,
    int scanCount
)
Public Sub New (
    fileType As IsisFileType,
    scanCount As Integer
)

Parameters

fileType
Type: Atalasoft.IsisIsisFileType
The file type.
scanCount
Type: SystemInt32
The scan count.
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs Properties

The IsisFileAcquisitionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Append | Gets or sets a value indicating whether file should be appended to existing file.
Public property | Cancel | Gets or sets a value which determines if the file will be acquired.
Public property | FileName | Gets or sets file name.
Public property | FileType | Gets the file type.
Public property | ScanCount | Gets the scan count.
Top
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs.Append Property

IsisFileAcquisitionEventArgsAppend Property

Gets or sets a value indicating whether file should be appended to existing file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Append { get; set; }
Public Property Append As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs.Cancel Property

IsisFileAcquisitionEventArgsCancel Property

Gets or sets a value which determines if the file will be acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value which determines if the file will be acquired.
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs.FileName Property

IsisFileAcquisitionEventArgsFileName Property

Gets or sets file name.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs.FileType Property

IsisFileAcquisitionEventArgsFileType Property

Gets the file type.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisFileType FileType { get; }
Public ReadOnly Property FileType As IsisFileType
    Get

Property Value

Type: IsisFileType
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs.ScanCount Property

IsisFileAcquisitionEventArgsScanCount Property

Gets the scan count.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ScanCount { get; }
Public ReadOnly Property ScanCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventArgs Methods

The IsisFileAcquisitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisFileAcquisitionEventArgs Class
Atalasoft.Isis Namespace


IsisFileAcquisitionEventHandler Delegate

This event handler is used to notify the application about file acquisition.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void IsisFileAcquisitionEventHandler(
    Object sender,
    IsisFileAcquisitionEventArgs e
)
Public Delegate Sub IsisFileAcquisitionEventHandler (
    sender As Object,
    e As IsisFileAcquisitionEventArgs
)

Parameters

sender
Type: SystemObject
The event sender.
e
Type: Atalasoft.IsisIsisFileAcquisitionEventArgs
The information about file.
See Also

Reference

Atalasoft.Isis Namespace


IsisFileType Enumeration

Available file types for ISIS.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisFileType
Public Enumeration IsisFileType
Members
Member name | Description
None | Default value if cannot access file type property.
Bmp | Bitmap digital images.
Cals | 1-bit (black and white) image.
Dcx | DCX file is a Fax image. DCX is a basically a multipage PCX graphic file.
Gif | Graphics Interchange Format,bitmap image format.
Jbig | Jbig image file.
Jpeg | Jpeg image file.
Jpeg2000 | JPEG 2000 is an image compression standard and coding system.
MoDca | Image compression methods of G3, G4, JPEG and uncompressed. Single and multi-page image files.
Pcx | Graphic format
Pda | Print extension
Pdf | Document format
PlexusTiff | Single and multipage image files.
Png | bitonal and color content
Tiff | Single and multipage image files.
See Also

Reference

Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs Class

Contains information about the image just acquired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.IsisIsisImageAcquiredEventArgs

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisImageAcquiredEventArgs : EventArgs
Public Class IsisImageAcquiredEventArgs
    Inherits EventArgs

The IsisImageAcquiredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bitmap | Gets the image as bitmap.
Public property | Cancel | Gets or sets a value which determines if the pending images will be acquired.
Public property | Image | Gets the image acquired.
Public property | JobSeparator | Gets the value indicating whether this image is marked as job separator.
Public property | Orientation | Gets the image orientation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs Properties

The IsisImageAcquiredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Bitmap | Gets the image as bitmap.
Public property | Cancel | Gets or sets a value which determines if the pending images will be acquired.
Public property | Image | Gets the image acquired.
Public property | JobSeparator | Gets the value indicating whether this image is marked as job separator.
Public property | Orientation | Gets the image orientation.
Top
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs.Bitmap Property

IsisImageAcquiredEventArgsBitmap Property

Gets the image as bitmap.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Bitmap Bitmap { get; }
Public ReadOnly Property Bitmap As Bitmap
    Get

Property Value

Type: Bitmap
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs.Cancel Property

IsisImageAcquiredEventArgsCancel Property

Gets or sets a value which determines if the pending images will be acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value which determines if the pending images will be acquired.
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs.Image Property

IsisImageAcquiredEventArgsImage Property

Gets the image acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
The image acquired.
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs.JobSeparator Property

IsisImageAcquiredEventArgsJobSeparator Property

Gets the value indicating whether this image is marked as job separator.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool JobSeparator { get; }
Public ReadOnly Property JobSeparator As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs.Orientation Property

IsisImageAcquiredEventArgsOrientation Property

Gets the image orientation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisOrientation Orientation { get; }
Public ReadOnly Property Orientation As IsisOrientation
    Get

Property Value

Type: IsisOrientation
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventArgs Methods

The IsisImageAcquiredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisImageAcquiredEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiredEventHandler Delegate

This event handler is used to notify the application when an image has been acquired.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void IsisImageAcquiredEventHandler(
    Object sender,
    IsisImageAcquiredEventArgs e
)
Public Delegate Sub IsisImageAcquiredEventHandler (
    sender As Object,
    e As IsisImageAcquiredEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.IsisIsisImageAcquiredEventArgs
See Also

Reference

Atalasoft.Isis Namespace


IsisImageAcquiringEventArgs Class

Contains information about acquiring image.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.IsisIsisImageAcquiringEventArgs

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisImageAcquiringEventArgs : EventArgs
Public Class IsisImageAcquiringEventArgs
    Inherits EventArgs

The IsisImageAcquiringEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IsisImageAcquiringEventArgs | Initializes a new instance of the IsisImageAcquiringEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value which determines if images acquiring was canceled.
Public property | PageCount | Gets the page count.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisImageAcquiringEventArgs Constructor

Initializes a new instance of the IsisImageAcquiringEventArgs class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisImageAcquiringEventArgs(
    int pageCount
)
Public Sub New (
    pageCount As Integer
)

Parameters

pageCount
Type: SystemInt32
The page count.
See Also

Reference

IsisImageAcquiringEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiringEventArgs Properties

The IsisImageAcquiringEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value which determines if images acquiring was canceled.
Public property | PageCount | Gets the page count.
Top
See Also

Reference

IsisImageAcquiringEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiringEventArgs.Cancel Property

IsisImageAcquiringEventArgsCancel Property

Gets or sets a value which determines if images acquiring was canceled.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
A value which determines if images acquiring was canceled.
See Also

Reference

IsisImageAcquiringEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiringEventArgs.PageCount Property

IsisImageAcquiringEventArgsPageCount Property

Gets the page count.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisImageAcquiringEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiringEventArgs Methods

The IsisImageAcquiringEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisImageAcquiringEventArgs Class
Atalasoft.Isis Namespace


IsisImageAcquiringEventHandler Delegate

This event handler is used to notify the application when an image is acquiring.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void IsisImageAcquiringEventHandler(
    Object sender,
    IsisImageAcquiringEventArgs e
)
Public Delegate Sub IsisImageAcquiringEventHandler (
    sender As Object,
    e As IsisImageAcquiringEventArgs
)

Parameters

sender
Type: SystemObject
The event sender.
e
Type: Atalasoft.IsisIsisImageAcquiringEventArgs
The information about acquiring image.
See Also

Reference

Atalasoft.Isis Namespace


IsisJobSeparatorDetection Enumeration

Available job separator values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisJobSeparatorDetection
Public Enumeration IsisJobSeparatorDetection
Members
Member name | Description
Off | Batch detection is turned off.
DetectScanAndContinue | Detect and scan separator, continue scan ahead.
DetectScanAndStop | Detect and scan separator, stop scan ahead.
DetectSkipAndContinue | Detect and skip separator, continue scan ahead.
DetectSkipAndStop | Detect and skip separator, stop scan ahead.
See Also

Reference

Atalasoft.Isis Namespace


IsisOrientation Enumeration

Types of orientations valid for ISIS.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisOrientation
Public Enumeration IsisOrientation
Members
Member name | Description
None | No orientation.
Landscape | The image data is in landscape orientation.
LandscapeMirrored | The image data is in landscape mirrored orientation.
Portrait | The image data is in portrait orientation.
PortraitMirrored | The image data is in portrait mirrored orientation.
Rotate180 | The image data is in upside-down portrait orientation.
Rotate180Mirrored | The image data is in upside down portrait, mirrored orientation.
Rotate270 | The image data is in upside-down landscape orientation.
Rotate270Mirrored | The image data is in upside down landscape, mirrored orientation.
See Also

Reference

Atalasoft.Isis Namespace


IsisPhotometric Enumeration

Available photometric values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisPhotometric
Public Enumeration IsisPhotometric
Members
Member name | Description
Bgr | BGR.
Palette | Palette.
Rgb | RGB.
White0 | White0.
White1 | White1.
See Also

Reference

Atalasoft.Isis Namespace


IsisPixelFormat Enumeration

Available ISIS pixel formats.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisPixelFormat
Public Enumeration IsisPixelFormat
Members
Member name | Description
Binary | Binary image.
Grayscale4Bit | Grayscale 4-bit image.
Grayscale8Bit | Grayscale 8-bit image.
Paletted4Bit | Palette 4-bit image.
Paletted8Bit | Palette 8-bit image.
Rgb24Bit | RGB image.
See Also

Reference

Atalasoft.Isis Namespace


IsisPlanarConfiguration Enumeration

Available planar configuration values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisPlanarConfiguration
Public Enumeration IsisPlanarConfiguration
Members
Member name | Description
Unknown | Unknown.
LinePacked | Line packed.
LineUnpacked | Line unpacked.
Page | Page.
See Also

Reference

Atalasoft.Isis Namespace


IsisResolutionUnit Enumeration

Available resolution units for ISIS

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisResolutionUnit
Public Enumeration IsisResolutionUnit
Members
Member name | Description
None | Default resolution unit
Inch | Inch resolution unit
Centimeter | Centimeter(metric) resolution unit
See Also

Reference

Atalasoft.Isis Namespace


IsisScanType Enumeration

Available scan types.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisScanType
Public Enumeration IsisScanType
Members
Member name | Description
Automatic | Scan from the ADF if pages are detected; otherwise, scan from the flatbed.
FeederBackFront | Scan in duplex mode, but return the back side of the page first (duplex scanner), from the feeder.
FeederBackOnly | Scan only the back side of the page (duplex scanner), from the feeder.
FeederFrontBack | Scan in duplex mode (duplex scanner), from the feeder.
FeederFrontOnly | Scan only the front side of the page (duplex scanner).
Flatbed | Scan from the flatbed.
Transparency | Scan from the transparency unit.
See Also

Reference

Atalasoft.Isis Namespace


IsisSetting Enumeration

Available settings for ISIS.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisSetting
Public Enumeration IsisSetting
Members
Member name | Description
Barcode | Availability and status of barcode detection.
BarcodeAutoReadFront | Turns barcode detection on front side in a duplex scan.
BarcodeAutoReadBack | Turns barcode detection on back side in a duplex scan.
BarcodeChecksum | Enables barcode checksum verification.
BarcodeConfirmationTone |
BarcodeContrast |
BarcodeDataChecksum | Tells whether barcode checksum is correct..
BarcodeDataHeight | Barcode height.
BarcodeDataOrientation | Barcode orientation.
BarcodeDataQuality | Contains barcode recognition quality.
BarcodeDataSearchTime | Barcode search time.
BarcodeDataText | Decoded barcode string.
BarcodeDataType | Barcode type. See IsisBarcodeType for possible values.
BarcodeDataWidth | Barcode width.
BarcodeDataXPosition | Barcode X position.
BarcodeDataYPosition | Barcode Y position.
BarcodeEmphasis | Barcode enhancement options. See IsisBarcodeEmphasis for possible values.
BarcodeExactLength | Barcode length.
BarcodeExamine | Automatically examine page for barcodes.
BarcodeExpectedHeight | Expected barcode height in mm.
BarcodeExpectedWidth | Expected barcode width in mm.
BarcodeFindMax | Maximum number of barcodes to find on a page.
BarcodeImageQuality | Quality of image from wich barcode shoul dbe read. See IsisBarcodeImageQuality for possible values.
BarcodeMaxCount | Maximum bars for a code to be considered valid..
BarcodeMaxOnLine | Maximum number of barcodes on a line.
BarcodeMaxOnPage | Maximum number of barcodes on a page.
BarcodeMaxRatio | Maximum ration between wide bars and narrow bars.
BarcodeMinChars | Maximum characters in a barcode.
BarcodeMinCount | Minimum bars needed for a code to be considered valid.
BarcodeMinHeight | Minimum height of barcode in mm.
BarcodeMinOnPage | Minimum number of barcodes on a page.
BarcodeMinWidth | Minimum width of barcode in mm.
BarcodeOrientationCount |
BarcodeSearchCount | Tells how many times to search for one tag.
BarcodeSearchDirection | Barcode search direction. See IsisBarcodeSearchDirection for possible values.
BarcodeSearchLinear | Tells whether to search barcodes from top to bottom instead of middle to edge.
BarcodeSearchMode | Barcode search order. See IsisBarcodeSearchMode for possible values.
BarcodeSearchOrder | String representation of barcode search order.
BarcodeSearchOrientation | Expected orientation for barcode.
BarcodeSearchTime | Barcode search time.
BarcodeSearchX | X position to start search for barcodes.
BarcodeSearchY | Y position to start search for barcodes.
BarcodeSkew | Number of degrees of barcode skew (0-45).
BarcodeTransferPatchLevel |
BarcodeType | MICR type.
BarcodeTypeCount | Number of MICR types.
BarcodeWidth | Number of pixels of the smallest barcode.
Bell | Scanner's bell status.
BitsPerSample | Number of bits per sample.
BlueBrightness | Blue brightness settings.
BlueContrast | Blue contrast settings.
Brightness | Brightness settings.
ColorMap | Color map for palette color images.
Compression | Data compression settings.
Configuration | Driver defined user configuration names.
Contrast | Contrast settings.
ControlSheet | Defines scanner behavior when control sheet is detected.
DataOrientation | Orientation of image data.
Dither | Dither settings.
Emphasis | Emphasis settings. See IsisEmphasis for possible values.
EndorserText | String to be printed by scanner's endorser.
Feeder | Provides information about scanner's feeder. See IsisDocumentFeeder for possible values.
FeederFeed | Indicates that scanner has a feeder.
FeederPauseMode | Configures scanner behavior in case when scanahead is turned off in the middle of a scanahead batch.
FeederStopMode | Tells a scanner whether it should stop immediately when user hits stop button, or wait for the current page to go through the feeder.
FeederTimeout | Number of seconds that scanner tries to read next page before reporting that feeder is empty.
FileType | Type of image file. See IsisFileType for possible values.
FillOrder | Logical order of bits in a byte.
Gamma | Gamma curve adjustment for scanning.
GreenBrightness | Green brightness settings.
GreenContrast | Green contrast settings.
ImageLength | Number of rows in the image.
ImageWidth | Number of columns in the image.
InsertMode | Allows to specify whether to create, overwrite, append, or insert when writing a file.
JobSeparatorDetected | Job separation sheet detection status.
JobSeparatorDetection | Job separation detection mode. See IsisJobSeparatorDetection for possible values.
MaximumPageCount | Maximum number of pages that can be loaded in scanner's ADF.
MixedScanning | Is supported by the scanner, allows to specify whether to capture dithered binary data from non-textual areas of the page, and non-dithered binary data from textual areas.
MoreSettings | Indicates whether the scanner driver implements More Settings dialog.
Orientation | Image orientation.
Outline | Outline settings.
OutputAuthor | Document author.
OutputCreator | Document creator.
OutputKeywords | Document keywords.
OutputName | Output file name.
OutputSubject | Document subject.
OutputTitle | Document title.
Overscan | Overscan area color in black or white.
OverscanColor | Overscan area color as an RGB.
PageScanTimeout | Maximum time in 1/10 seconds required to scan a page.
PageSize | Scanner page size setting.
PhotometricInterpretation | Color space of image data. See IsisPhotometric for possible values.
PlanarConfiguration | Specifies arrangement of the components of an RGB image. See IsisPlanarConfiguration for possible values.
PositionX | Distance from the left edge of the page to the start of the image.
PositionY | Distance from the dop edge of the page to the start of the image.
RedBrightness | Red brightness settings.
RedContrast | Red contrast settings.
RemoveBlackPages | Specifies whether to remove black pages.
RemoveBlackPageThreshold | Contains threshold for deciding whether the page is black.
RemoveWhitePages | Specifies whether to remove white pages.
RemoveWhitePageThreshold | Contains threshold for deciding whether the is white.
ResolutionUnit | Unit of resolution measurement. See IsisResolutionUnit for possible values.
ResolutionX | Horizontal resolution.
ResolutionY | Vertical resolution.
SamplesPerPixel | Samples per pixel.
ScanAhead | Scan ahead status.
ScanAheadBuffered | Number of pages that have been scanned ahead.
ScanAheadCount | Maximum number of pages that can be scanned ahead.
ScannerId | Scanner identification string.
ScanOrientation | Orientation of pages in the scanner's feeder.
ScanType | Specifies scan source. See IsisScanType for possible values.
Sharpness |
See Also

Reference

Atalasoft.Isis Namespace


IsisSettingData Class

Represents settings data.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisSettingData

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisSettingData
Public Class IsisSettingData

The IsisSettingData type exposes the following members.

Constructors
 | Name | Description
Public method | IsisSettingData | Initializes a new instance of IsisSettingData class.
Top
Properties
 | Name | Description
Public property | Entry | Gets settings data entry.
Public property | Section | Gets section name for the data.
Public property | Value | Gets settings data value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisSettingData Constructor

Initializes a new instance of IsisSettingData class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSettingData(
    string section,
    string entry,
    string value
)
Public Sub New (
    section As String,
    entry As String,
    value As String
)

Parameters

section
Type: SystemString
Section for the data.
entry
Type: SystemString
Settings data entry.
value
Type: SystemString
Settings data value.
See Also

Reference

IsisSettingData Class
Atalasoft.Isis Namespace


IsisSettingData Properties

The IsisSettingData type exposes the following members.

Properties
 | Name | Description
Public property | Entry | Gets settings data entry.
Public property | Section | Gets section name for the data.
Public property | Value | Gets settings data value.
Top
See Also

Reference

IsisSettingData Class
Atalasoft.Isis Namespace


IsisSettingData.Entry Property

IsisSettingDataEntry Property

Gets settings data entry.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Entry { get; }
Public ReadOnly Property Entry As String
    Get

Property Value

Type: String
See Also

Reference

IsisSettingData Class
Atalasoft.Isis Namespace


IsisSettingData.Section Property

IsisSettingDataSection Property

Gets section name for the data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Section { get; }
Public ReadOnly Property Section As String
    Get

Property Value

Type: String
See Also

Reference

IsisSettingData Class
Atalasoft.Isis Namespace


IsisSettingData.Value Property

IsisSettingDataValue Property

Gets settings data value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IsisSettingData Class
Atalasoft.Isis Namespace


IsisSettingData Methods

The IsisSettingData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisSettingData Class
Atalasoft.Isis Namespace


IsisSettingDataManager Class

The data manager that allows to read and write ISIS settings to file or stream in XML format.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisSettingDataManager

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisSettingDataManager : ISettingDataManager,
    IDisposable
Public Class IsisSettingDataManager
    Implements ISettingDataManager, IDisposable

The IsisSettingDataManager type exposes the following members.

Constructors
 | Name | Description
Public method | IsisSettingDataManager(Stream) | Creates a new instance of IsisSettingDataManager class.
Public method | IsisSettingDataManager(String) | Creates a new instance of IsisSettingDataManager class.
Top
Properties
 | Name | Description
Protected property | InnerStream | Gets stream.
Top
Methods
 | Name | Description
Public method | Close | Closes data manager.
Public method | Dispose | Closes file stream and releases resources back to the system.
Protected method | Dispose(Boolean) | Closes file stream and releases resources back to the system.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | IsisSettingDataManager destructor. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginRead | The method is called before IsisSettingData is being read.
Protected method | OnBeginWrite | The method is called before IsisSettingData is being written.
Protected method | OnEndRead | The method is called after the IsisSettingData is read.
Protected method | OnEndWrite | The method is called after IsisSettingData is written.
Protected method | OnReadSetting | The method is called in order to read settings data.
Protected method | OnWriteSetting | The method is called in order to write IsisSettingData.
Public method | Open | Opens data manager in order to start reading and/or writing settings data.
Public method | ReadSetting | Read settings data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteSetting | Write settings data.
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisSettingDataManager Constructor

Overload List
 | Name | Description
Public method | IsisSettingDataManager(Stream) | Creates a new instance of IsisSettingDataManager class.
Public method | IsisSettingDataManager(String) | Creates a new instance of IsisSettingDataManager class.
Top
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager Constructor (Stream)

Creates a new instance of IsisSettingDataManager class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSettingDataManager(
    Stream stream
)
Public Sub New (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
Stream which should be used to read and write settings data.
See Also

Reference

IsisSettingDataManager Class
IsisSettingDataManager Overload
Atalasoft.Isis Namespace


IsisSettingDataManager Constructor (String)

Creates a new instance of IsisSettingDataManager class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSettingDataManager(
    string fileName
)
Public Sub New (
    fileName As String
)

Parameters

fileName
Type: SystemString
The name of the file which should be used to read and write settings data.
See Also

Reference

IsisSettingDataManager Class
IsisSettingDataManager Overload
Atalasoft.Isis Namespace


IsisSettingDataManager Properties

The IsisSettingDataManager type exposes the following members.

Properties
 | Name | Description
Protected property | InnerStream | Gets stream.
Top
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.InnerStream Property

IsisSettingDataManagerInnerStream Property

Gets stream.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Stream InnerStream { get; }
Protected ReadOnly Property InnerStream As Stream
    Get

Property Value

Type: Stream
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager Methods

The IsisSettingDataManager type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes data manager.
Public method | Dispose | Closes file stream and releases resources back to the system.
Protected method | Dispose(Boolean) | Closes file stream and releases resources back to the system.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | IsisSettingDataManager destructor. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginRead | The method is called before IsisSettingData is being read.
Protected method | OnBeginWrite | The method is called before IsisSettingData is being written.
Protected method | OnEndRead | The method is called after the IsisSettingData is read.
Protected method | OnEndWrite | The method is called after IsisSettingData is written.
Protected method | OnReadSetting | The method is called in order to read settings data.
Protected method | OnWriteSetting | The method is called in order to write IsisSettingData.
Public method | Open | Opens data manager in order to start reading and/or writing settings data.
Public method | ReadSetting | Read settings data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteSetting | Write settings data.
Top
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.Close Method

IsisSettingDataManagerClose Method

Closes data manager.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

ISettingDataManagerClose
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.Dispose Method

IsisSettingDataManagerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Closes file stream and releases resources back to the system.
Protected method | Dispose(Boolean) | Closes file stream and releases resources back to the system.
Top
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.Dispose Method

IsisSettingDataManagerDispose Method

Closes file stream and releases resources back to the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

IsisSettingDataManager Class
Dispose Overload
Atalasoft.Isis Namespace


IsisSettingDataManager.Dispose Method (Boolean)

IsisSettingDataManagerDispose Method (Boolean)

Closes file stream and releases resources back to the system.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Indicates whether this method was called from the Dispose method or the Finalizer.
See Also

Reference

IsisSettingDataManager Class
Dispose Overload
Atalasoft.Isis Namespace


IsisSettingDataManager.Finalize Method

IsisSettingDataManagerFinalize Method

IsisSettingDataManager destructor.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.OnBeginRead Method

IsisSettingDataManagerOnBeginRead Method

The method is called before IsisSettingData is being read.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool OnBeginRead()
Protected Overridable Function OnBeginRead As Boolean

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.OnBeginWrite Method

IsisSettingDataManagerOnBeginWrite Method

The method is called before IsisSettingData is being written.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool OnBeginWrite()
Protected Overridable Function OnBeginWrite As Boolean

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.OnEndRead Method

IsisSettingDataManagerOnEndRead Method

The method is called after the IsisSettingData is read.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnEndRead()
Protected Overridable Sub OnEndRead
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.OnEndWrite Method

IsisSettingDataManagerOnEndWrite Method

The method is called after IsisSettingData is written.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnEndWrite()
Protected Overridable Sub OnEndWrite
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.OnReadSetting Method

IsisSettingDataManagerOnReadSetting Method

The method is called in order to read settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnReadSetting(
    IsisSettingData data
)
Protected Overridable Sub OnReadSetting (
    data As IsisSettingData
)

Parameters

data
Type: Atalasoft.IsisIsisSettingData
Data to read.
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.OnWriteSetting Method

IsisSettingDataManagerOnWriteSetting Method

The method is called in order to write IsisSettingData.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnWriteSetting(
    IsisSettingData data
)
Protected Overridable Sub OnWriteSetting (
    data As IsisSettingData
)

Parameters

data
Type: Atalasoft.IsisIsisSettingData
Data to write.
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.Open Method

IsisSettingDataManagerOpen Method

Opens data manager in order to start reading and/or writing settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Open(
    bool writing
)
Public Function Open (
    writing As Boolean
) As Boolean

Parameters

writing
Type: SystemBoolean
Indicates whether writing data is allowed.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.

Implements

ISettingDataManagerOpen(Boolean)
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.ReadSetting Method

IsisSettingDataManagerReadSetting Method

Read settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ReadSetting(
    IsisSettingData data
)
Public Function ReadSetting (
    data As IsisSettingData
) As Boolean

Parameters

data
Type: Atalasoft.IsisIsisSettingData
IsisSettingData that should receive settings data.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.

Implements

ISettingDataManagerReadSetting(IsisSettingData)
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettingDataManager.WriteSetting Method

IsisSettingDataManagerWriteSetting Method

Write settings data.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WriteSetting(
    IsisSettingData data
)
Public Function WriteSetting (
    data As IsisSettingData
) As Boolean

Parameters

data
Type: Atalasoft.IsisIsisSettingData
Data to write.

Return Value

Type: Boolean
true if the operation is succeeded, otherwise false.

Implements

ISettingDataManagerWriteSetting(IsisSettingData)
See Also

Reference

IsisSettingDataManager Class
Atalasoft.Isis Namespace


IsisSettings Class

Represents ISIS device settings.
Inheritance Hierarchy
SystemObject
Atalasoft.IsisIsisSettings

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IsisSettings
Public Class IsisSettings

The IsisSettings type exposes the following members.

Properties
 | Name | Description
Public property | Barcode | Gets barcode related settings.
Public property | Brightness | Gets or sets the brightness value used when scanning.
Public property | Compression | Gets or sets scanning compression settings.
Public property | Contrast | Gets or sets contrast value used for scanning.
Public property | CustomBrightness | Gets or sets custom brightness value.
Public property | CustomContrast | Gets or sets custom contrast value.
Public property | DataOrientation | Gets or sets image data orientation.
Public property | Dither | Gets or sets dither settings.
Public property | DocumentFeeder | Gets document feeder settings.
Public property | Emphasis | Gets or sets emphasis settings.
Public property | EndorserText | Gets or sets a string to be printed by the scanner's endorser.
Public property | FileType | Gets or sets type of file.
Public property | Gamma | Gets or sets gamma value.
Public property | JobSeparatorDetection | Gets or sets job separation mode.
Public property | MixedScanning | Gets or sets mixed scanning settings value.
Public property | Outline | Gets or sets a value indicating whether outline scanning should be performed or not.
Public property | OverscanColor | Gets or sets the color of the overscan area.
Public property | PageScanTimeout | Gets a value indicating the maximum number of tenths of a second for a scanner to scan a page.
Public property | PageSize | Gets or sets the size of page to scan.
Public property | PixelFormat | Gets or sets pixel format use for scanning.
Public property | RemoveBlackPages | Gets or sets a value indicating whether black pages should be removed.
Public property | RemoveBlackPageThreshold | Gets or sets black page threshold used if RemoveBlackPages is turned on.
Public property | RemoveWhitePages | Gets or sets a value indicating whether white page should be removed.
Public property | RemoveWhitePageThreshold | Gets or sets white page threshold used if RemoveWhitePages is turned on.
Public property | Resolution | Gets or sets scan resolution.
Public property | ResolutionUnit | Gets or sets resolution unit.
Public property | ScanAhead | Gets or sets a value indicating whether scan ahead should be turned on.
Public property | ScanAheadBuffered | Gets the number of pages in the scanner's buffer.
Public property | ScanAheadCount | Gets or sets the maximum number of pages to be scanned ahead.
Public property | ScanArea | Gets or sets rectangle to be scannned.
Public property | ScanType | Gets or sets scanning source value.
Public property | Sharpness | Gets or sets sharpness value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportedBlackPageThresholdValues | Gets the list of supported threshold values for black page detection.
Public method | GetSupportedBlankPageThresholdValues | Obsolete. Gets the list of supported threshold values for black page detection.
Public method | GetSupportedBrightnessValues | Gets the list of supported brightness values.
Public method | GetSupportedColorFormats | Gets the list of supported color formats.
Public method | GetSupportedCompressions | Gets the list of supported compressions.
Public method | GetSupportedContrastValues | Gets the list of supported contrast values.
Public method | GetSupportedDataOrientationValues | Gets the list of supported data orientation values.
Public method | GetSupportedDitherMethods | Gets the list of supported dither methods.
Public method | GetSupportedFileTypes | Gets the list of supported file types.
Public method | GetSupportedGammaValues | Gets the list of supported gamma values.
Public method | GetSupportedPageSizes | Gets the list of supported page sizes.
Public method | GetSupportedResolutions | Gets the list of supported resolutions.
Public method | GetSupportedScanAreaWidthValues | Gets the list of supported image width values.
Public method | GetSupportedScanTypes | Gets the list of supported scan types.
Public method | GetSupportedSettings | Gets the list of supported settings.
Public method | GetSupportedSharpnessValues | Gets the list of supported sharpness values.
Public method | GetSupportedWhitePageThresholdValues | Gets the list of supported threshold values for white page detection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCustomBrightnessSupported | Checks if custom brightness value can be set.
Public method | IsCustomContrastSupported | Checks if custom contrast value can be set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QuerySupport | Checks if the specified setting is supported.
Public method | ShowConfigurationDialog | Displays a default configuration dialog, allowing the user to create or modify configurations for the driver.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Isis Namespace


IsisSettings Properties

The IsisSettings type exposes the following members.

Properties
 | Name | Description
Public property | Barcode | Gets barcode related settings.
Public property | Brightness | Gets or sets the brightness value used when scanning.
Public property | Compression | Gets or sets scanning compression settings.
Public property | Contrast | Gets or sets contrast value used for scanning.
Public property | CustomBrightness | Gets or sets custom brightness value.
Public property | CustomContrast | Gets or sets custom contrast value.
Public property | DataOrientation | Gets or sets image data orientation.
Public property | Dither | Gets or sets dither settings.
Public property | DocumentFeeder | Gets document feeder settings.
Public property | Emphasis | Gets or sets emphasis settings.
Public property | EndorserText | Gets or sets a string to be printed by the scanner's endorser.
Public property | FileType | Gets or sets type of file.
Public property | Gamma | Gets or sets gamma value.
Public property | JobSeparatorDetection | Gets or sets job separation mode.
Public property | MixedScanning | Gets or sets mixed scanning settings value.
Public property | Outline | Gets or sets a value indicating whether outline scanning should be performed or not.
Public property | OverscanColor | Gets or sets the color of the overscan area.
Public property | PageScanTimeout | Gets a value indicating the maximum number of tenths of a second for a scanner to scan a page.
Public property | PageSize | Gets or sets the size of page to scan.
Public property | PixelFormat | Gets or sets pixel format use for scanning.
Public property | RemoveBlackPages | Gets or sets a value indicating whether black pages should be removed.
Public property | RemoveBlackPageThreshold | Gets or sets black page threshold used if RemoveBlackPages is turned on.
Public property | RemoveWhitePages | Gets or sets a value indicating whether white page should be removed.
Public property | RemoveWhitePageThreshold | Gets or sets white page threshold used if RemoveWhitePages is turned on.
Public property | Resolution | Gets or sets scan resolution.
Public property | ResolutionUnit | Gets or sets resolution unit.
Public property | ScanAhead | Gets or sets a value indicating whether scan ahead should be turned on.
Public property | ScanAheadBuffered | Gets the number of pages in the scanner's buffer.
Public property | ScanAheadCount | Gets or sets the maximum number of pages to be scanned ahead.
Public property | ScanArea | Gets or sets rectangle to be scannned.
Public property | ScanType | Gets or sets scanning source value.
Public property | Sharpness | Gets or sets sharpness value.
Top
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Barcode Property

IsisSettingsBarcode Property

Gets barcode related settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBarcodeSettings Barcode { get; }
Public ReadOnly Property Barcode As IsisBarcodeSettings
    Get

Property Value

Type: IsisBarcodeSettings
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Brightness Property

IsisSettingsBrightness Property

Gets or sets the brightness value used when scanning.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisBrightness Brightness { get; set; }
Public Property Brightness As IsisBrightness
    Get
    Set

Property Value

Type: IsisBrightness
The brightness value used on the scan.
Remarks
In addition to the enumeration options, a value of 1 to 127 can be cast to an IsisBrightness type in order to set a specific brightness.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Compression Property

IsisSettingsCompression Property

Gets or sets scanning compression settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCompression Compression { get; set; }
Public Property Compression As IsisCompression
    Get
    Set

Property Value

Type: IsisCompression
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Contrast Property

IsisSettingsContrast Property

Gets or sets contrast value used for scanning.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Contrast { get; set; }
Public Property Contrast As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.CustomBrightness Property

IsisSettingsCustomBrightness Property

Gets or sets custom brightness value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCustomBrightnessContrast CustomBrightness { get; set; }
Public Property CustomBrightness As IsisCustomBrightnessContrast
    Get
    Set

Property Value

Type: IsisCustomBrightnessContrast
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.CustomContrast Property

IsisSettingsCustomContrast Property

Gets or sets custom contrast value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCustomBrightnessContrast CustomContrast { get; set; }
Public Property CustomContrast As IsisCustomBrightnessContrast
    Get
    Set

Property Value

Type: IsisCustomBrightnessContrast
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.DataOrientation Property

IsisSettingsDataOrientation Property

Gets or sets image data orientation.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisOrientation DataOrientation { get; set; }
Public Property DataOrientation As IsisOrientation
    Get
    Set

Property Value

Type: IsisOrientation
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Dither Property

IsisSettingsDither Property

Gets or sets dither settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Dither { get; set; }
Public Property Dither As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.DocumentFeeder Property

IsisSettingsDocumentFeeder Property

Gets document feeder settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisDocumentFeeder DocumentFeeder { get; }
Public ReadOnly Property DocumentFeeder As IsisDocumentFeeder
    Get

Property Value

Type: IsisDocumentFeeder
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Emphasis Property

IsisSettingsEmphasis Property

Gets or sets emphasis settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisEmphasis Emphasis { get; set; }
Public Property Emphasis As IsisEmphasis
    Get
    Set

Property Value

Type: IsisEmphasis
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.EndorserText Property

IsisSettingsEndorserText Property

Gets or sets a string to be printed by the scanner's endorser.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string EndorserText { get; set; }
Public Property EndorserText As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.FileType Property

IsisSettingsFileType Property

Gets or sets type of file.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisFileType FileType { get; set; }
Public Property FileType As IsisFileType
    Get
    Set

Property Value

Type: IsisFileType
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Gamma Property

IsisSettingsGamma Property

Gets or sets gamma value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Gamma { get; set; }
Public Property Gamma As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.JobSeparatorDetection Property

IsisSettingsJobSeparatorDetection Property

Gets or sets job separation mode.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisJobSeparatorDetection JobSeparatorDetection { get; set; }
Public Property JobSeparatorDetection As IsisJobSeparatorDetection
    Get
    Set

Property Value

Type: IsisJobSeparatorDetection
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.MixedScanning Property

IsisSettingsMixedScanning Property

Gets or sets mixed scanning settings value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MixedScanning { get; set; }
Public Property MixedScanning As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Mixed scanning provides a means to capture dithered binary data from non-textual areas of the page, and non-dithered binary from the textual portions, providing the best readability for both text and graphics with a single scan.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Outline Property

IsisSettingsOutline Property

Gets or sets a value indicating whether outline scanning should be performed or not.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Outline { get; set; }
Public Property Outline As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Consult your scanner's documentation for more information.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.OverscanColor Property

IsisSettingsOverscanColor Property

Gets or sets the color of the overscan area.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color OverscanColor { get; set; }
Public Property OverscanColor As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.PageScanTimeout Property

IsisSettingsPageScanTimeout Property

Gets a value indicating the maximum number of tenths of a second for a scanner to scan a page.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageScanTimeout { get; }
Public ReadOnly Property PageScanTimeout As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.PageSize Property

IsisSettingsPageSize Property

Gets or sets the size of page to scan.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PageSize { get; set; }
Public Property PageSize As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.PixelFormat Property

IsisSettingsPixelFormat Property

Gets or sets pixel format use for scanning.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisPixelFormat PixelFormat { get; set; }
Public Property PixelFormat As IsisPixelFormat
    Get
    Set

Property Value

Type: IsisPixelFormat
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.RemoveBlackPages Property

IsisSettingsRemoveBlackPages Property

Gets or sets a value indicating whether black pages should be removed.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RemoveBlackPages { get; set; }
Public Property RemoveBlackPages As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.RemoveBlackPageThreshold Property

IsisSettingsRemoveBlackPageThreshold Property

Gets or sets black page threshold used if RemoveBlackPages is turned on.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational RemoveBlackPageThreshold { get; set; }
Public Property RemoveBlackPageThreshold As Rational
    Get
    Set

Property Value

Type: Rational
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.RemoveWhitePages Property

IsisSettingsRemoveWhitePages Property

Gets or sets a value indicating whether white page should be removed.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RemoveWhitePages { get; set; }
Public Property RemoveWhitePages As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.RemoveWhitePageThreshold Property

IsisSettingsRemoveWhitePageThreshold Property

Gets or sets white page threshold used if RemoveWhitePages is turned on.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational RemoveWhitePageThreshold { get; set; }
Public Property RemoveWhitePageThreshold As Rational
    Get
    Set

Property Value

Type: Rational
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Resolution Property

IsisSettingsResolution Property

Gets or sets scan resolution.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational Resolution { get; set; }
Public Property Resolution As Rational
    Get
    Set

Property Value

Type: Rational
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ResolutionUnit Property

IsisSettingsResolutionUnit Property

Gets or sets resolution unit.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisResolutionUnit ResolutionUnit { get; set; }
Public Property ResolutionUnit As IsisResolutionUnit
    Get
    Set

Property Value

Type: IsisResolutionUnit
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ScanAhead Property

IsisSettingsScanAhead Property

Gets or sets a value indicating whether scan ahead should be turned on.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ScanAhead { get; set; }
Public Property ScanAhead As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ScanAheadBuffered Property

IsisSettingsScanAheadBuffered Property

Gets the number of pages in the scanner's buffer.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ScanAheadBuffered { get; }
Public ReadOnly Property ScanAheadBuffered As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ScanAheadCount Property

IsisSettingsScanAheadCount Property

Gets or sets the maximum number of pages to be scanned ahead.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ScanAheadCount { get; set; }
Public Property ScanAheadCount As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Zero value indicating that all pages in the feader should be scanned.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ScanArea Property

IsisSettingsScanArea Property

Gets or sets rectangle to be scannned.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle ScanArea { get; set; }
Public Property ScanArea As Rectangle
    Get
    Set

Property Value

Type: Rectangle
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ScanType Property

IsisSettingsScanType Property

Gets or sets scanning source value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisScanType ScanType { get; set; }
Public Property ScanType As IsisScanType
    Get
    Set

Property Value

Type: IsisScanType
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.Sharpness Property

IsisSettingsSharpness Property

Gets or sets sharpness value.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Sharpness { get; set; }
Public Property Sharpness As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings Methods

The IsisSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSupportedBlackPageThresholdValues | Gets the list of supported threshold values for black page detection.
Public method | GetSupportedBlankPageThresholdValues | Obsolete. Gets the list of supported threshold values for black page detection.
Public method | GetSupportedBrightnessValues | Gets the list of supported brightness values.
Public method | GetSupportedColorFormats | Gets the list of supported color formats.
Public method | GetSupportedCompressions | Gets the list of supported compressions.
Public method | GetSupportedContrastValues | Gets the list of supported contrast values.
Public method | GetSupportedDataOrientationValues | Gets the list of supported data orientation values.
Public method | GetSupportedDitherMethods | Gets the list of supported dither methods.
Public method | GetSupportedFileTypes | Gets the list of supported file types.
Public method | GetSupportedGammaValues | Gets the list of supported gamma values.
Public method | GetSupportedPageSizes | Gets the list of supported page sizes.
Public method | GetSupportedResolutions | Gets the list of supported resolutions.
Public method | GetSupportedScanAreaWidthValues | Gets the list of supported image width values.
Public method | GetSupportedScanTypes | Gets the list of supported scan types.
Public method | GetSupportedSettings | Gets the list of supported settings.
Public method | GetSupportedSharpnessValues | Gets the list of supported sharpness values.
Public method | GetSupportedWhitePageThresholdValues | Gets the list of supported threshold values for white page detection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCustomBrightnessSupported | Checks if custom brightness value can be set.
Public method | IsCustomContrastSupported | Checks if custom contrast value can be set.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QuerySupport | Checks if the specified setting is supported.
Public method | ShowConfigurationDialog | Displays a default configuration dialog, allowing the user to create or modify configurations for the driver.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedBlackPageThresholdValues Method

IsisSettingsGetSupportedBlackPageThresholdValues Method

Gets the list of supported threshold values for black page detection.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational[] GetSupportedBlackPageThresholdValues()
Public Function GetSupportedBlackPageThresholdValues As Rational()

Return Value

Type: Rational
List of supported threshold values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedBlankPageThresholdValues Method

IsisSettingsGetSupportedBlankPageThresholdValues Method

Note: This API is now obsolete.

Gets the list of supported threshold values for black page detection.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("Due to misspelling in the method name, please use GetSupportedBlackPageThresholdValues() method instead.",
    false)]
public Rational[] GetSupportedBlankPageThresholdValues()
<ObsoleteAttribute("Due to misspelling in the method name, please use GetSupportedBlackPageThresholdValues() method instead.",
    false)>
Public Function GetSupportedBlankPageThresholdValues As Rational()

Return Value

Type: Rational
List of supported threshold values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedBrightnessValues Method

IsisSettingsGetSupportedBrightnessValues Method

Gets the list of supported brightness values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedBrightnessValues()
Public Function GetSupportedBrightnessValues As Integer()

Return Value

Type: Int32
List of supported brightness values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedColorFormats Method

IsisSettingsGetSupportedColorFormats Method

Gets the list of supported color formats.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisPixelFormat[] GetSupportedColorFormats()
Public Function GetSupportedColorFormats As IsisPixelFormat()

Return Value

Type: IsisPixelFormat
The list of supported color formats.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedCompressions Method

IsisSettingsGetSupportedCompressions Method

Gets the list of supported compressions.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisCompression[] GetSupportedCompressions()
Public Function GetSupportedCompressions As IsisCompression()

Return Value

Type: IsisCompression
List of supported compressions.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedContrastValues Method

IsisSettingsGetSupportedContrastValues Method

Gets the list of supported contrast values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedContrastValues()
Public Function GetSupportedContrastValues As Integer()

Return Value

Type: Int32
List of supported contrast values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedDataOrientationValues Method

IsisSettingsGetSupportedDataOrientationValues Method

Gets the list of supported data orientation values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisOrientation[] GetSupportedDataOrientationValues()
Public Function GetSupportedDataOrientationValues As IsisOrientation()

Return Value

Type: IsisOrientation
List of supported data orientation values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedDitherMethods Method

IsisSettingsGetSupportedDitherMethods Method

Gets the list of supported dither methods.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetSupportedDitherMethods()
Public Function GetSupportedDitherMethods As String()

Return Value

Type: String
List of supported dither methods.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedFileTypes Method

IsisSettingsGetSupportedFileTypes Method

Gets the list of supported file types.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisFileType[] GetSupportedFileTypes()
Public Function GetSupportedFileTypes As IsisFileType()

Return Value

Type: IsisFileType
The list of supported file types.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedGammaValues Method

IsisSettingsGetSupportedGammaValues Method

Gets the list of supported gamma values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedGammaValues()
Public Function GetSupportedGammaValues As Integer()

Return Value

Type: Int32
List of supported gamma values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedPageSizes Method

IsisSettingsGetSupportedPageSizes Method

Gets the list of supported page sizes.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetSupportedPageSizes()
Public Function GetSupportedPageSizes As String()

Return Value

Type: String
List of supported page sizes.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedResolutions Method

IsisSettingsGetSupportedResolutions Method

Gets the list of supported resolutions.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational[] GetSupportedResolutions()
Public Function GetSupportedResolutions As Rational()

Return Value

Type: Rational
List of supported resolutions.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedScanAreaWidthValues Method

IsisSettingsGetSupportedScanAreaWidthValues Method

Gets the list of supported image width values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedScanAreaWidthValues()
Public Function GetSupportedScanAreaWidthValues As Integer()

Return Value

Type: Int32
List of supported image width values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedScanTypes Method

IsisSettingsGetSupportedScanTypes Method

Gets the list of supported scan types.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisScanType[] GetSupportedScanTypes()
Public Function GetSupportedScanTypes As IsisScanType()

Return Value

Type: IsisScanType
List of supported file types.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedSettings Method

IsisSettingsGetSupportedSettings Method

Gets the list of supported settings.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IsisSetting[] GetSupportedSettings(
    bool excludeUnknownSettings
)
Public Function GetSupportedSettings (
    excludeUnknownSettings As Boolean
) As IsisSetting()

Parameters

excludeUnknownSettings
Type: SystemBoolean
The value indicating whether the settings other than defined in IsisSetting should be included.

Return Value

Type: IsisSetting
The list of supported settings.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedSharpnessValues Method

IsisSettingsGetSupportedSharpnessValues Method

Gets the list of supported sharpness values.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedSharpnessValues()
Public Function GetSupportedSharpnessValues As Integer()

Return Value

Type: Int32
List of supported sharpness values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.GetSupportedWhitePageThresholdValues Method

IsisSettingsGetSupportedWhitePageThresholdValues Method

Gets the list of supported threshold values for white page detection.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rational[] GetSupportedWhitePageThresholdValues()
Public Function GetSupportedWhitePageThresholdValues As Rational()

Return Value

Type: Rational
List of supported threshold values.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.IsCustomBrightnessSupported Method

IsisSettingsIsCustomBrightnessSupported Method

Checks if custom brightness value can be set.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCustomBrightnessSupported()
Public Function IsCustomBrightnessSupported As Boolean

Return Value

Type: Boolean
true if custom brightness value can be set, otherwise false.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.IsCustomContrastSupported Method

IsisSettingsIsCustomContrastSupported Method

Checks if custom contrast value can be set.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCustomContrastSupported()
Public Function IsCustomContrastSupported As Boolean

Return Value

Type: Boolean
true if custom contrast value can be set, otherwise false.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.QuerySupport Method

IsisSettingsQuerySupport Method

Checks if the specified setting is supported.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool QuerySupport(
    IsisSetting setting
)
Public Function QuerySupport (
    setting As IsisSetting
) As Boolean

Parameters

setting
Type: Atalasoft.IsisIsisSetting
Setting to check.

Return Value

Type: Boolean
true if supported, otherwise false.
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettings.ShowConfigurationDialog Method

IsisSettingsShowConfigurationDialog Method

Displays a default configuration dialog, allowing the user to create or modify configurations for the driver.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ShowConfigurationDialog(
    IWin32Window parent
)
Public Sub ShowConfigurationDialog (
    parent As IWin32Window
)

Parameters

parent
Type: System.Windows.FormsIWin32Window
See Also

Reference

IsisSettings Class
Atalasoft.Isis Namespace


IsisSettingType Enumeration

Available setting types for ISIS

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisSettingType
Public Enumeration IsisSettingType
Members
Member name | Description
Int32 | integer
Rational | float
String | string
See Also

Reference

Atalasoft.Isis Namespace


IsisState Enumeration

Available states for ISIS

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum IsisState
Public Enumeration IsisState
Members
Member name | Description
Closed | Not open or acquiring.
Open | Currently open.
Acquiring | Acquiring.
See Also

Reference

Atalasoft.Isis Namespace


UnsupportedImageFormatException Class

Thrown when an unsupported image format is passed in from the device.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.IsisUnsupportedImageFormatException

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class UnsupportedImageFormatException : Exception
<SerializableAttribute>
Public Class UnsupportedImageFormatException
    Inherits Exception

The UnsupportedImageFormatException type exposes the following members.

Constructors
 | Name | Description
Public method | UnsupportedImageFormatException | Initializes a new instance of the UnsupportedImageFormatException class.
Public method | UnsupportedImageFormatException(String) | Initializes a new instance of the UnsupportedImageFormatException class.
Protected method | UnsupportedImageFormatException(SerializationInfo, StreamingContext) | Initializes a new instance of the UnsupportedImageFormatException class.
Public method | UnsupportedImageFormatException(String, Exception) | Initializes a new instance of the UnsupportedImageFormatException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Isis Namespace


UnsupportedImageFormatException Constructor

Overload List
 | Name | Description
Public method | UnsupportedImageFormatException | Initializes a new instance of the UnsupportedImageFormatException class.
Public method | UnsupportedImageFormatException(String) | Initializes a new instance of the UnsupportedImageFormatException class.
Protected method | UnsupportedImageFormatException(SerializationInfo, StreamingContext) | Initializes a new instance of the UnsupportedImageFormatException class.
Public method | UnsupportedImageFormatException(String, Exception) | Initializes a new instance of the UnsupportedImageFormatException class.
Top
See Also

Reference

UnsupportedImageFormatException Class
Atalasoft.Isis Namespace


UnsupportedImageFormatException Constructor

Initializes a new instance of the UnsupportedImageFormatException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedImageFormatException()
Public Sub New
See Also

Reference

UnsupportedImageFormatException Class
UnsupportedImageFormatException Overload
Atalasoft.Isis Namespace


UnsupportedImageFormatException Constructor (String)

Initializes a new instance of the UnsupportedImageFormatException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedImageFormatException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

UnsupportedImageFormatException Class
UnsupportedImageFormatException Overload
Atalasoft.Isis Namespace


UnsupportedImageFormatException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the UnsupportedImageFormatException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected UnsupportedImageFormatException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
Contextual information about the source or destination.
See Also

Reference

UnsupportedImageFormatException Class
UnsupportedImageFormatException Overload
Atalasoft.Isis Namespace


UnsupportedImageFormatException Constructor (String, Exception)

Initializes a new instance of the UnsupportedImageFormatException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedImageFormatException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
The inner exception.
See Also

Reference

UnsupportedImageFormatException Class
UnsupportedImageFormatException Overload
Atalasoft.Isis Namespace


UnsupportedImageFormatException Properties

The UnsupportedImageFormatException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnsupportedImageFormatException Class
Atalasoft.Isis Namespace


UnsupportedImageFormatException Methods

The UnsupportedImageFormatException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnsupportedImageFormatException Class
Atalasoft.Isis Namespace


UnsupportedImageFormatException Events

The UnsupportedImageFormatException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

UnsupportedImageFormatException Class
Atalasoft.Isis Namespace


UnsupportedSettingException Class

Thrown in case of unsupported settings.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.IsisUnsupportedSettingException

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class UnsupportedSettingException : Exception
<SerializableAttribute>
Public Class UnsupportedSettingException
    Inherits Exception

The UnsupportedSettingException type exposes the following members.

Constructors
 | Name | Description
Public method | UnsupportedSettingException | Initializes a new instance of the UnsupportedSettingException class.
Public method | UnsupportedSettingException(String) | Initializes a new instance of the UnsupportedSettingException class.
Protected method | UnsupportedSettingException(SerializationInfo, StreamingContext) | Initializes a new instance of the UnsupportedSettingException class.
Public method | UnsupportedSettingException(String, Exception) | Initializes a new instance of the UnsupportedSettingException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Isis Namespace


UnsupportedSettingException Constructor

Overload List
 | Name | Description
Public method | UnsupportedSettingException | Initializes a new instance of the UnsupportedSettingException class.
Public method | UnsupportedSettingException(String) | Initializes a new instance of the UnsupportedSettingException class.
Protected method | UnsupportedSettingException(SerializationInfo, StreamingContext) | Initializes a new instance of the UnsupportedSettingException class.
Public method | UnsupportedSettingException(String, Exception) | Initializes a new instance of the UnsupportedSettingException class.
Top
See Also

Reference

UnsupportedSettingException Class
Atalasoft.Isis Namespace


UnsupportedSettingException Constructor

Initializes a new instance of the UnsupportedSettingException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedSettingException()
Public Sub New
See Also

Reference

UnsupportedSettingException Class
UnsupportedSettingException Overload
Atalasoft.Isis Namespace


UnsupportedSettingException Constructor (String)

Initializes a new instance of the UnsupportedSettingException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedSettingException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

UnsupportedSettingException Class
UnsupportedSettingException Overload
Atalasoft.Isis Namespace


UnsupportedSettingException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the UnsupportedSettingException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected UnsupportedSettingException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
Contextual information about the source or destination.
See Also

Reference

UnsupportedSettingException Class
UnsupportedSettingException Overload
Atalasoft.Isis Namespace


UnsupportedSettingException Constructor (String, Exception)

Initializes a new instance of the UnsupportedSettingException class.

Namespace: Atalasoft.Isis
Assembly: Atalasoft.dotImage.Isis (in Atalasoft.dotImage.Isis.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedSettingException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
The inner exception.
See Also

Reference

UnsupportedSettingException Class
UnsupportedSettingException Overload
Atalasoft.Isis Namespace


UnsupportedSettingException Properties

The UnsupportedSettingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnsupportedSettingException Class
Atalasoft.Isis Namespace


UnsupportedSettingException Methods

The UnsupportedSettingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnsupportedSettingException Class
Atalasoft.Isis Namespace


UnsupportedSettingException Events

The UnsupportedSettingException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

UnsupportedSettingException Class
Atalasoft.Isis Namespace


Atalasoft.Ocr Namespace

High level classes for managing OCR engines and their output.
Classes
 | Class | Description
Public class | BasicFontBuilder | BasicFontBuilder is a simple implementation of the IFontBuilder interface.
Public class | BasicFontMapper | BasicFontMapper is a simple implementation of the IFontMapper interface.
Public class | BasicOcrFactory | BasicOcrFactory is a simple implementation of the IOcrFactory interface. Each method returns a new instantiation of the base class of the associated document or page element.
Public class | BasicOcrGlyphAccessor | BasicOcrGlyphAccessor is a simple implementation of the IOcrGlyphAccessor interface which provides basic functionality for a glyph.
Public class | BasicOcrLineAccessor | BasicOcrLineAccessor is a simple implementation of the IOcrLineAccessor interface which provides basic functionality for a line of text.
Public class | BasicOcrWordAccessor | BasicOcrLineAccessor is a simple implementation of the IOcrWordAccessor interface which provides basic functionality for a word of text.
Public class | CustomCultureInfo |
Public class | GenericOcrResourceLoader | Helper class for loading OCR Engine resources.
 | GlyphReaderLoader | This class is used to load all resources for the GlyphReader OCR Engine
Public class | IrisLoader | This class is used to load all resources for the Iris OCR Engine.
Public class | OcrBarcodeRegion | OcrBarcodeRegion is page element which describes a region that contains a barcode.
Public class | OcrContainerRegion | Abstract skeletal implementation that encompasses base functionality for those OcrRegion types that can contain other OcrRegions within themselves
Public class | OcrDocument | Summary description for OcrDocument.
Public class | OcrDocumentProgressEventArgs | OcrDocumentProgressEventArgs provides the information necessary to track the progress of OCR in a document.
Public class | OcrEngine | OcrEngine represents the functionality of an OCR engine. It is an abstract class and cannot be constructed directly, but it provides much of the functionality needed in subclasses.
Public class | OcrEngineCollection | OcrEngineCollection represents a standard collection of OcrEngine objects.
Public class | OcrException | Summary description for OcrException.
Public class | OcrFormElementGroupRegion | OcrFormElementGroupRegion represents a group of related OcrFormElementRegion elements
Public class | OcrFormElementRegion | OcrFormElementRegion defines a page element identified as a form element.
Public class | OcrGlyph | Summary description for OcrGlyph.
Public class | OcrGlyphCollection | Summary description for OcrLineCollection.
Public class | OcrGlyphMetrics | OcrGlyphMetrics is a utility class for statistically determining the baseline or other general metrics of a text from its bounding box or height.
Public class | OcrImagePreprocessingEventArgs | Event argument used for pre-processing OCR events.
Public class | OcrImageRegion | This class represents an Image contained within a page.
Public class | OcrLine | Summary description for OcrLine.
Public class | OcrLineCollection | Summary description for OcrLineCollection.
Public class | OcrNativePreprocessingOptions | This is a class built to hold constants to use as bit fields for native preprocessing options.
Public class | OcrPage | The OcrPage object represents a page within a document recognized by OCR.
Public class | OcrPageCollection | Summary description for OcrPageCollection.
Public class | OcrPageConstructionEventArgs | OcrPageConstructionEventArgs is used for events that are fired before a page has started to be constructed and after it has finished being constructed.
Public class | OcrPageElementEventArgs | This object is used to pass information about changes in page elements
Public class | OcrPageLocationEventArgs | OcrPageLocationEventArgs represents information needed for handling a PageLocation event from an OcrEngine.
Public class | OcrPageProgressEventArgs | This class represents information about progress within OCR processing on a page.
Public class | OcrPreprocessingOptions | Summary description for OcrPreProcessingOptions.
Public class | OcrRegion | OcrRegion is a base class that represents the core functionality of a region within a page. It is abstract and therefore can't be instantiated on its own.
Public class | OcrRegionCollection | Summary description for OcrRegionCollection.
Public class | OcrRegionCollectionT | Summary description for OcrRegionCollection. Version with Generics support.
Public class | OcrResourceLoader | Obsolete. Used to load OCR Resources
Public class | OcrTableRegion | OcrTableRegion represents a table page element.
Public class | OcrTableRegionOcrTableSeparator | OcrTableSeparator represents a single table separator.
Public class | OcrTextRegion | OcrTextRegion represents an area of text on a page.
Public class | OcrWord | Summary description for OcrWord.
Public class | OcrWordCollection | Summary description for OcrLineCollection.
Public class | OmniPageEngineBase |
Public class | PdfImageTicket | The PdfImageTicket class is used to store information about an image for PDF translation
Public class | PdfPageConstructionEventArgs | This class is used to encapsulate information surrounding PDF page construction in the PDF Translator.
Public class | PdfPageInfo | PdfPageInfo represents metadata for each page within an OcrPage in the process of being translated to PDF.
Public class | PdfTranslationSession | PdfTranslationSession is a helper class used by the PdfTranslator to maintain state information about the current document being translated.
Public class | PdfTranslator | The PdfTranslator object is a general-purpose object for translating OcrDocuments and their pages into PDF files or streams.
Public class | TextTranslator | Outputs OCR into formatted text.
Public class | TranslatorCollection | TranslatorCollection represents a standard collection of ITranslator objects.
Interfaces
 | Interface | Description
Public interface | IFontBuilder | IFontBuilder provides a mechanism to control how fonts are constructed.
Public interface | IFontMapper | IFontMapper provides a mechanism for translating fonts identified in the process of OCR from one set of characteristics to another.
Public interface | IForeignTranslator | IForeignTranslator is a interface used to define how an OcrDocument will be translated to another format.
Public interface | INativeTranslator | INativeTranslator is an interface used to define how an OcrDocument will be translated to another format by low-level OCR engine support.
Public interface | IOcrFactory | Summary description for OcrFactory.
Public interface | IOcrGlyphAccessor | IOcrGlyphAccessor defines an interface for accessing data elements for a glyph.
Public interface | IOcrLineAccessor | IOcrLineAccessor defines an interface for accessing data elements for a line of text.
Public interface | IOcrWordAccessor | IOcrWordAccessor defines an interface for accessing data elements for a word.
Public interface | IPerPageTranslator | IPerPageTranslator is an interface that allows IForeignTranslator objects to translate a document while it is being recognized on a page-by-page basis. In many cases this can result in a smaller memory load by allowing the translator to release per page resources immediately. In general, client code need not worry about this interface as it is called by the OcrEngine object.
Public interface | ITranslator | ITranslator defines an interface which allows the translation of documents from images to text-based formats.
Delegates
 | Delegate | Description
Public delegate | OcrDocumentProgressEventHandler | The OcrDocumentProgressEventHandler delegate defines the event fired during progress on recognition of a document.
Public delegate | OcrImagePreprocessingEventHandler | The OcrImagePreprocessingEventHandler delegate defines the event fired during OCR pre-processing.
Public delegate | OcrPageConstructionEventHandler | The OcrPageConstructionEventHandler delegate defines the event that is fired before a page is fully constructed or has finished being constructed.
Public delegate | OcrPageElementChangedEventHandler | The OcrPageElementChangedEventHandler delegate defines the event that is fired after a page element has changed.
Public delegate | OcrPageLocationEventHandler | The OcrPageLocationEventHandler delegate defines the event fired during region location of a page.
Public delegate | OcrPageProgressEventHandler | The OcrPageProgressEventHandler delegate defines the event fired during progress on recognition of a document.
Public delegate | PdfCompressionSelector | This delegate is used to determine what compression to use on a given page in the process of being translated.
Public delegate | PdfPageConstructionEventHandler | Event responsible for notifying about Pdf Page Contruction items.
Enumerations
 | Enumeration | Description
Public enumeration | OcrBarcodeSymbologies | Lists standard barcode symbologies that can be used in various OCR engines that support barcode recognition.
Public enumeration | OcrDocumentInfoKey | This enumeration defines a set of keys that are used to access metadata within an OcrDocument.
Public enumeration | OcrDocumentMetadataKey | This enumeration is used to define keys for accessing document metadata.
Public enumeration | OcrDocumentStage | OcrDocumentStage represents the current stage of document translation.
Public enumeration | OcrPageElementAction | This enumeration defines actions that are being taken on an Ocr page element.
Public enumeration | OcrPageMetadataKey | This enumeration is used to define keys for accessing page metadata.
Public enumeration | OcrPageStage | OcrPageStage represents the current stage of page translation.
Public enumeration | OcrSymbolSet | The list of Symbols for Ocr
Public enumeration | OcrTextKind | Represents type of text detected by OCR engine.
Public enumeration | OcrTextRotation | This enumeration is used to define coarse rotation of text in a page element.
Public enumeration | PdfColorSpace | This enumeration defines color spaces supported for Pdf output.
Public enumeration | PdfImageCompressionType | This enumeration describes possible Pdf image compression
Public enumeration | PdfTranslatorOutputType | This enumeration defines how the PdfTranslator will create its pages
Public enumeration | TextWhitespaceMode | Controls how to handle whitespace in the Whitespace property.


BasicFontBuilder Class

BasicFontBuilder is a simple implementation of the IFontBuilder interface.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrBasicFontBuilder

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicFontBuilder : IFontBuilder
Public Class BasicFontBuilder
    Implements IFontBuilder

The BasicFontBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | BasicFontBuilder | Constructs a new BasicFontBuilder object.
Top
Properties
 | Name | Description
Public property | Fonts | Returns a new array of Fonts that represents all constructed fonts in the FontBuilder's cache.
Top
Methods
 | Name | Description
Public method | BuildFont | Build the specified font.
Public method | Clear | Clears all constructed fonts out of the FontBuilder cache.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This basic font builder uses each font as specified, caching based on the characteristics. Caching is done via an array list.
See Also

Reference

Atalasoft.Ocr Namespace


BasicFontBuilder Constructor

Constructs a new BasicFontBuilder object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicFontBuilder()
Public Sub New
See Also

Reference

BasicFontBuilder Class
Atalasoft.Ocr Namespace


BasicFontBuilder Properties

The BasicFontBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Fonts | Returns a new array of Fonts that represents all constructed fonts in the FontBuilder's cache.
Top
See Also

Reference

BasicFontBuilder Class
Atalasoft.Ocr Namespace


BasicFontBuilder.Fonts Property

BasicFontBuilderFonts Property

Returns a new array of Fonts that represents all constructed fonts in the FontBuilder's cache.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Font[] Fonts { get; }
Public Overridable ReadOnly Property Fonts As Font()
    Get

Property Value

Type: Font
A new array of Fonts that represents all constructed fonts in the FontBuilder's cache.

Implements

IFontBuilderFonts
Remarks
A new array is constructed each time this method is called.
See Also

Reference

BasicFontBuilder Class
Atalasoft.Ocr Namespace


BasicFontBuilder Methods

The BasicFontBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildFont | Build the specified font.
Public method | Clear | Clears all constructed fonts out of the FontBuilder cache.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicFontBuilder Class
Atalasoft.Ocr Namespace


BasicFontBuilder.BuildFont Method

BasicFontBuilderBuildFont Method

Build the specified font.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Font BuildFont(
    FontFamily family,
    float size,
    FontStyle style
)
Public Overridable Function BuildFont (
    family As FontFamily,
    size As Single,
    style As FontStyle
) As Font

Parameters

family
Type: System.DrawingFontFamily
The FontFamily of the font to build.
size
Type: SystemSingle
The size in points of the font to build.
style
Type: System.DrawingFontStyle
The FontStyle of the font to build.

Return Value

Type: Font
A Font object if BuildFont could build the font, null otherwise.

Implements

IFontBuilderBuildFont(FontFamily, Single, FontStyle)
Remarks
BuildFont will return a cached version of a font if it has been asked to build an identical font before.
See Also

Reference

BasicFontBuilder Class
Atalasoft.Ocr Namespace


BasicFontBuilder.Clear Method

BasicFontBuilderClear Method

Clears all constructed fonts out of the FontBuilder cache.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Clear()
Public Overridable Sub Clear

Implements

IFontBuilderClear
See Also

Reference

BasicFontBuilder Class
Atalasoft.Ocr Namespace


BasicFontMapper Class

BasicFontMapper is a simple implementation of the IFontMapper interface.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrBasicFontMapper

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicFontMapper : IFontMapper,
    IDisposable
Public Class BasicFontMapper
    Implements IFontMapper, IDisposable

The BasicFontMapper type exposes the following members.

Constructors
 | Name | Description
Public method | BasicFontMapper | Constructs a new BasicFontMapper object.
Top
Methods
 | Name | Description
Public method | Dispose | Dispose memory used by the font mapper.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BasicFontMapper and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | BasicFontMapper finalizer. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapToFontFamily(GenericFontFamilies) | Provide a FontFamily for a generic font family.
Public method | MapToFontFamily(String) | Map a given font family represented by the string to a FontFamily object.
Public method | MapToFontName | Maps a string representing a font name to a new font name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemapStyle | Map a given font style to a new one.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
BasicFontMapper will attempt to find the font exactly as specified. If it cannot find the font it will substitute Arial. BasicFontMapper will map generic font families onto the system generic font families.
See Also

Reference

Atalasoft.Ocr Namespace


BasicFontMapper Constructor

Constructs a new BasicFontMapper object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicFontMapper()
Public Sub New
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicFontMapper Methods

The BasicFontMapper type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose memory used by the font mapper.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | BasicFontMapper finalizer. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapToFontFamily(GenericFontFamilies) | Provide a FontFamily for a generic font family.
Public method | MapToFontFamily(String) | Map a given font family represented by the string to a FontFamily object.
Public method | MapToFontName | Maps a string representing a font name to a new font name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemapStyle | Map a given font style to a new one.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicFontMapper.Dispose Method

BasicFontMapperDispose Method

Disposes memory used by the font mapper object.
Overload List
 | Name | Description
Public method | Dispose | Dispose memory used by the font mapper.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BasicFontMapper and optionally releases the managed resources
Top
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicFontMapper.Dispose Method

BasicFontMapperDispose Method

Dispose memory used by the font mapper.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

BasicFontMapper Class
Dispose Overload
Atalasoft.Ocr Namespace


BasicFontMapper.Dispose Method (Boolean)

BasicFontMapperDispose Method (Boolean)

Releases the unmanaged resources used by the BasicFontMapper and optionally releases the managed resources

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

BasicFontMapper Class
Dispose Overload
Atalasoft.Ocr Namespace


BasicFontMapper.Finalize Method

BasicFontMapperFinalize Method

BasicFontMapper finalizer.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicFontMapper.MapToFontFamily Method

BasicFontMapperMapToFontFamily Method

Overload List
 | Name | Description
Public method | MapToFontFamily(GenericFontFamilies) | Provide a FontFamily for a generic font family.
Public method | MapToFontFamily(String) | Map a given font family represented by the string to a FontFamily object.
Top
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicFontMapper.MapToFontFamily Method (GenericFontFamilies)

BasicFontMapperMapToFontFamily Method (GenericFontFamilies)

Provide a FontFamily for a generic font family.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontFamily MapToFontFamily(
    GenericFontFamilies generic
)
Public Overridable Function MapToFontFamily (
    generic As GenericFontFamilies
) As FontFamily

Parameters

generic
Type: System.Drawing.TextGenericFontFamilies
A GenericFontFamily recognized by an OCR engine.

Return Value

Type: FontFamily

Implements

IFontMapperMapToFontFamily(GenericFontFamilies)
See Also

Reference

BasicFontMapper Class
MapToFontFamily Overload
Atalasoft.Ocr Namespace


BasicFontMapper.MapToFontFamily Method (String)

BasicFontMapperMapToFontFamily Method (String)

Map a given font family represented by the string to a FontFamily object.
Maps a string representing a font family name to a FontFamily object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontFamily MapToFontFamily(
    string name
)
Public Overridable Function MapToFontFamily (
    name As String
) As FontFamily

Parameters

name
Type: SystemString
The name of the font.

Return Value

Type: FontFamily
A FontFamily object representing the request font. If the font isn't available, switch to Arial.

Implements

IFontMapperMapToFontFamily(String)
Remarks
BasicFontMapper will cache FontFamily objects.
See Also

Reference

BasicFontMapper Class
MapToFontFamily Overload
Atalasoft.Ocr Namespace


BasicFontMapper.MapToFontName Method

BasicFontMapperMapToFontName Method

Maps a string representing a font name to a new font name.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string MapToFontName(
    string name
)
Public Overridable Function MapToFontName (
    name As String
) As String

Parameters

name
Type: SystemString
The name of the desired font.

Return Value

Type: String
A string representing the name of the actual font that will be used.

Implements

IFontMapperMapToFontName(String)
Remarks
BasicFontMapper returns the name as is, if it is defined on the system, "Arial" otherwise.
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicFontMapper.RemapStyle Method

BasicFontMapperRemapStyle Method

Map a given font style to a new one.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontStyle RemapStyle(
    FontFamily family,
    FontStyle style
)
Public Overridable Function RemapStyle (
    family As FontFamily,
    style As FontStyle
) As FontStyle

Parameters

family
Type: System.DrawingFontFamily
The FontFamily of the requested font.
style
Type: System.DrawingFontStyle
The requested style.

Return Value

Type: FontStyle
A new style to use for this font.

Implements

IFontMapperRemapStyle(FontFamily, FontStyle)
Remarks
BasicFontMapper returns all styles unchanged.
See Also

Reference

BasicFontMapper Class
Atalasoft.Ocr Namespace


BasicOcrFactory Class

BasicOcrFactory is a simple implementation of the IOcrFactory interface. Each method returns a new instantiation of the base class of the associated document or page element.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrBasicOcrFactory

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicOcrFactory : IOcrFactory
Public Class BasicOcrFactory
    Implements IOcrFactory

The BasicOcrFactory type exposes the following members.

Constructors
 | Name | Description
Public method | BasicOcrFactory | Initializes a new instance of the BasicOcrFactory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Construct a new OcrBarcodeRegion object.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Construct a new OcrBarcodeRegion object.
Public method | OcrDocument | Constructs a new OcrDocument object.
Public method | OcrFormElementRegion(Rectangle) | Constructs a new OcrFormElementRegion.
Public method | OcrFormElementRegion(PolygonF) | Constructs a new OcrFormElementRegion.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) | Constructs a new glyph with the given accessor, bounding box and baseline.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) | Constructs a new glyph with the given accessor, bounding box, baseline and color.
Public method | OcrImageRegion(Rectangle, AtalaImage) | Constructs a new OcrImageRegion using the supplied image and bounds.
Public method | OcrImageRegion(AtalaImage, Boolean) | Constructs a new OcrImageRegion using the supplied Image.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Constructs a new OcrImageRegion using the supplied image and bounds.
Public method | OcrLine | Constructs a new OcrLine(IOcrLineAccessor, Rectangle, Int32) object.
Public method | OcrPage(AtalaImage) | Constructs a new OcrPage object using the width, height, and resolution from the supplied AtalaImage.
Public method | OcrPage(Int32, Int32, Dpi) | Constructs a new OcrPage object using the supplied width, height, and resolution.
Public method | OcrTableRegion(Rectangle) | Constructs a new OcrTableRegion object.
Public method | OcrTableRegion(PolygonF) | Construct a page element to represent a table.
Public method | OcrTextRegion(Rectangle) | Construct a new OcrTextRegion object.
Public method | OcrTextRegion(PolygonF) | Construct a new OcrTextRegion object.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Construct a new OcrTextRegion object.
Public method | OcrWord | Constructs a new OcrWord(IOcrWordAccessor, Rectangle, Int32) object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


BasicOcrFactory Constructor

Initializes a new instance of the BasicOcrFactory class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrFactory()
Public Sub New
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory Methods

The BasicOcrFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Construct a new OcrBarcodeRegion object.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Construct a new OcrBarcodeRegion object.
Public method | OcrDocument | Constructs a new OcrDocument object.
Public method | OcrFormElementRegion(Rectangle) | Constructs a new OcrFormElementRegion.
Public method | OcrFormElementRegion(PolygonF) | Constructs a new OcrFormElementRegion.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) | Constructs a new glyph with the given accessor, bounding box and baseline.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) | Constructs a new glyph with the given accessor, bounding box, baseline and color.
Public method | OcrImageRegion(Rectangle, AtalaImage) | Constructs a new OcrImageRegion using the supplied image and bounds.
Public method | OcrImageRegion(AtalaImage, Boolean) | Constructs a new OcrImageRegion using the supplied Image.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Constructs a new OcrImageRegion using the supplied image and bounds.
Public method | OcrLine | Constructs a new OcrLine(IOcrLineAccessor, Rectangle, Int32) object.
Public method | OcrPage(AtalaImage) | Constructs a new OcrPage object using the width, height, and resolution from the supplied AtalaImage.
Public method | OcrPage(Int32, Int32, Dpi) | Constructs a new OcrPage object using the supplied width, height, and resolution.
Public method | OcrTableRegion(Rectangle) | Constructs a new OcrTableRegion object.
Public method | OcrTableRegion(PolygonF) | Construct a page element to represent a table.
Public method | OcrTextRegion(Rectangle) | Construct a new OcrTextRegion object.
Public method | OcrTextRegion(PolygonF) | Construct a new OcrTextRegion object.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Construct a new OcrTextRegion object.
Public method | OcrWord | Constructs a new OcrWord(IOcrWordAccessor, Rectangle, Int32) object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrBarcodeRegion Method

BasicOcrFactoryOcrBarcodeRegion Method

Overload List
 | Name | Description
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Construct a new OcrBarcodeRegion object.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Construct a new OcrBarcodeRegion object.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrBarcodeRegion Method (Rectangle, String, OcrBarcodeSymbologies)

BasicOcrFactoryOcrBarcodeRegion Method (Rectangle, String, OcrBarcodeSymbologies)

Construct a new OcrBarcodeRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrBarcodeRegion OcrBarcodeRegion(
    Rectangle bounds,
    string text,
    OcrBarcodeSymbologies barcodeType
)
Public Overridable Function OcrBarcodeRegion (
    bounds As Rectangle,
    text As String,
    barcodeType As OcrBarcodeSymbologies
) As OcrBarcodeRegion

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.
text
Type: SystemString
Text of the barcode within region.
barcodeType
Type: Atalasoft.OcrOcrBarcodeSymbologies
Type of the barcode within region.

Return Value

Type: OcrBarcodeRegion
A new OcrBarcodeRegion.

Implements

IOcrFactoryOcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies)
See Also

Reference

BasicOcrFactory Class
OcrBarcodeRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrBarcodeRegion Method (PolygonF, String, OcrBarcodeSymbologies)

BasicOcrFactoryOcrBarcodeRegion Method (PolygonF, String, OcrBarcodeSymbologies)

Construct a new OcrBarcodeRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrBarcodeRegion OcrBarcodeRegion(
    PolygonF bounds,
    string text,
    OcrBarcodeSymbologies barcodeType
)
Public Overridable Function OcrBarcodeRegion (
    bounds As PolygonF,
    text As String,
    barcodeType As OcrBarcodeSymbologies
) As OcrBarcodeRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.
text
Type: SystemString
Text of the barcode within region.
barcodeType
Type: Atalasoft.OcrOcrBarcodeSymbologies
Type of the barcode within region.

Return Value

Type: OcrBarcodeRegion
A new OcrBarcodeRegion.

Implements

IOcrFactoryOcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies)
See Also

Reference

BasicOcrFactory Class
OcrBarcodeRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrDocument Method

BasicOcrFactoryOcrDocument Method

Constructs a new OcrDocument object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrDocument OcrDocument()
Public Overridable Function OcrDocument As OcrDocument

Return Value

Type: OcrDocument
A new OcrDocument object.

Implements

IOcrFactoryOcrDocument
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrFormElementRegion Method

BasicOcrFactoryOcrFormElementRegion Method

Overload List
 | Name | Description
Public method | OcrFormElementRegion(Rectangle) | Constructs a new OcrFormElementRegion.
Public method | OcrFormElementRegion(PolygonF) | Constructs a new OcrFormElementRegion.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrFormElementRegion Method (Rectangle)

BasicOcrFactoryOcrFormElementRegion Method (Rectangle)

Constructs a new OcrFormElementRegion.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrFormElementRegion OcrFormElementRegion(
    Rectangle bounds
)
Public Overridable Function OcrFormElementRegion (
    bounds As Rectangle
) As OcrFormElementRegion

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.

Return Value

Type: OcrFormElementRegion
A new OcrFormElementRegion.

Implements

IOcrFactoryOcrFormElementRegion(Rectangle)
Remarks
This class is in the prototype stage and likely to change.
See Also

Reference

BasicOcrFactory Class
OcrFormElementRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrFormElementRegion Method (PolygonF)

BasicOcrFactoryOcrFormElementRegion Method (PolygonF)

Constructs a new OcrFormElementRegion.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrFormElementRegion OcrFormElementRegion(
    PolygonF bounds
)
Public Overridable Function OcrFormElementRegion (
    bounds As PolygonF
) As OcrFormElementRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.

Return Value

Type: OcrFormElementRegion
A new OcrFormElementRegion.

Implements

IOcrFactoryOcrFormElementRegion(PolygonF)
Remarks
This class is in the prototype stage and likely to change.
See Also

Reference

BasicOcrFactory Class
OcrFormElementRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrGlyph Method

BasicOcrFactoryOcrGlyph Method

Overload List
 | Name | Description
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) | Constructs a new glyph with the given accessor, bounding box and baseline.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) | Constructs a new glyph with the given accessor, bounding box, baseline and color.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32)

BasicOcrFactoryOcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32)

Constructs a new glyph with the given accessor, bounding box and baseline.
Constructs a new OcrGlyph object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrGlyph OcrGlyph(
    IOcrGlyphAccessor accessor,
    Rectangle bounds,
    int baseline
)
Public Overridable Function OcrGlyph (
    accessor As IOcrGlyphAccessor,
    bounds As Rectangle,
    baseline As Integer
) As OcrGlyph

Parameters

accessor
Type: Atalasoft.OcrIOcrGlyphAccessor
The accessor that will be used for this object. This is usually supplied by the engine during recognition. If you need to call OcrGlyph to change a glyph in an existing document, you can use a BasicOcrGlyphAccessor object.
bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.
baseline
Type: SystemInt32
The baseline of the text on the page in pixels.

Return Value

Type: OcrGlyph
A new OcrGlyph object.

Implements

IOcrFactoryOcrGlyph(IOcrGlyphAccessor, Rectangle, Int32)
Remarks
Glyphs created through this method will be black.
See Also

Reference

BasicOcrFactory Class
OcrGlyph Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32, Color)

BasicOcrFactoryOcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32, Color)

Constructs a new glyph with the given accessor, bounding box, baseline and color.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrGlyph OcrGlyph(
    IOcrGlyphAccessor accessor,
    Rectangle bounds,
    int baseline,
    Color color
)
Public Overridable Function OcrGlyph (
    accessor As IOcrGlyphAccessor,
    bounds As Rectangle,
    baseline As Integer,
    color As Color
) As OcrGlyph

Parameters

accessor
Type: Atalasoft.OcrIOcrGlyphAccessor
The accessor that will be used for this object. This is usually supplied by the engine during recognition. If you need to call OcrGlyph to change a glyph in an existing document, you can use a BasicOcrGlyphAccessor object.
bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.
baseline
Type: SystemInt32
The baseline of the text on the page in pixels.
color
Type: System.DrawingColor
The color of this glyph.

Return Value

Type: OcrGlyph

Implements

IOcrFactoryOcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color)
See Also

Reference

BasicOcrFactory Class
OcrGlyph Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrImageRegion Method

BasicOcrFactoryOcrImageRegion Method

Overload List
 | Name | Description
Public method | OcrImageRegion(Rectangle, AtalaImage) | Constructs a new OcrImageRegion using the supplied image and bounds.
Public method | OcrImageRegion(AtalaImage, Boolean) | Constructs a new OcrImageRegion using the supplied Image.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Constructs a new OcrImageRegion using the supplied image and bounds.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrImageRegion Method (Rectangle, AtalaImage)

BasicOcrFactoryOcrImageRegion Method (Rectangle, AtalaImage)

Constructs a new OcrImageRegion using the supplied image and bounds.
Constructs a new OcrImageRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrImageRegion OcrImageRegion(
    Rectangle bounds,
    AtalaImage image
)
Public Overridable Function OcrImageRegion (
    bounds As Rectangle,
    image As AtalaImage
) As OcrImageRegion

Parameters

bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.
image
Type: Atalasoft.ImagingAtalaImage
The image that defines the entire page.

Return Value

Type: OcrImageRegion
The image that is stored is made creating a new cropped version the supplied image.

Return Value

Type: OcrImageRegion
A new OcrImageRegion object.

Implements

IOcrFactoryOcrImageRegion(Rectangle, AtalaImage)
Remarks
This method will create a new image by cropping the given image to the supplied bounding rectangle.
See Also

Reference

BasicOcrFactory Class
OcrImageRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrImageRegion Method (AtalaImage, Boolean)

BasicOcrFactoryOcrImageRegion Method (AtalaImage, Boolean)

Constructs a new OcrImageRegion using the supplied Image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrImageRegion OcrImageRegion(
    AtalaImage image,
    bool makeCopy
)
Public Overridable Function OcrImageRegion (
    image As AtalaImage,
    makeCopy As Boolean
) As OcrImageRegion

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to use for this region.
makeCopy
Type: SystemBoolean
If makeCopy is true, this region will store a copy of the image, otherwise it will store the image itself.

Return Value

Type: OcrImageRegion

Implements

IOcrFactoryOcrImageRegion(AtalaImage, Boolean)
See Also

Reference

BasicOcrFactory Class
OcrImageRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrImageRegion Method (PolygonF, AtalaImage)

BasicOcrFactoryOcrImageRegion Method (PolygonF, AtalaImage)

Constructs a new OcrImageRegion using the supplied image and bounds.
Constructs a new OcrImageRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrImageRegion OcrImageRegion(
    PolygonF bounds,
    AtalaImage image
)
Public Overridable Function OcrImageRegion (
    bounds As PolygonF,
    image As AtalaImage
) As OcrImageRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding rectangle of the object on the page in pixels.
image
Type: Atalasoft.ImagingAtalaImage
The image that defines the entire page.

Return Value

Type: OcrImageRegion
The image that is stored is made creating a new cropped version the supplied image.

Return Value

Type: OcrImageRegion
A new OcrImageRegion object.

Implements

IOcrFactoryOcrImageRegion(PolygonF, AtalaImage)
Remarks
This method will create a new image by cropping the given image to the supplied bounding rectangle.
See Also

Reference

BasicOcrFactory Class
OcrImageRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrLine Method

BasicOcrFactoryOcrLine Method

Constructs a new OcrLine(IOcrLineAccessor, Rectangle, Int32) object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrLine OcrLine(
    IOcrLineAccessor accessor,
    Rectangle bounds,
    int baseline
)
Public Overridable Function OcrLine (
    accessor As IOcrLineAccessor,
    bounds As Rectangle,
    baseline As Integer
) As OcrLine

Parameters

accessor
Type: Atalasoft.OcrIOcrLineAccessor
The accessor that will be used for this object. This is usually supplied by the engine during recognition. If you need to call OcrLine to change a line in an existing document, you can use a BasicOcrLineAccessor object.
bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.
baseline
Type: SystemInt32
The baseline of the text on the page in pixels.

Return Value

Type: OcrLine
A new OcrLine(IOcrLineAccessor, Rectangle, Int32) object.

Implements

IOcrFactoryOcrLine(IOcrLineAccessor, Rectangle, Int32)
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrPage Method

BasicOcrFactoryOcrPage Method

Overload List
 | Name | Description
Public method | OcrPage(AtalaImage) | Constructs a new OcrPage object using the width, height, and resolution from the supplied AtalaImage.
Public method | OcrPage(Int32, Int32, Dpi) | Constructs a new OcrPage object using the supplied width, height, and resolution.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrPage Method (AtalaImage)

BasicOcrFactoryOcrPage Method (AtalaImage)

Constructs a new OcrPage object using the width, height, and resolution from the supplied AtalaImage.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrPage OcrPage(
    AtalaImage image
)
Public Overridable Function OcrPage (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
An AtalaImage that represents this page.

Return Value

Type: OcrPage
A new OcrPage object.

Return Value

Type: OcrPage
A new OcrPage object.

Implements

IOcrFactoryOcrPage(AtalaImage)
See Also

Reference

BasicOcrFactory Class
OcrPage Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrPage Method (Int32, Int32, Dpi)

BasicOcrFactoryOcrPage Method (Int32, Int32, Dpi)

Constructs a new OcrPage object using the supplied width, height, and resolution.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrPage OcrPage(
    int width,
    int height,
    Dpi resolution
)
Public Overridable Function OcrPage (
    width As Integer,
    height As Integer,
    resolution As Dpi
) As OcrPage

Parameters

width
Type: SystemInt32
The width of the page in pixels.
height
Type: SystemInt32
The height of the page in pixels.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.

Return Value

Type: OcrPage
A new OcrPage object.

Implements

IOcrFactoryOcrPage(Int32, Int32, Dpi)
See Also

Reference

BasicOcrFactory Class
OcrPage Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTableRegion Method

BasicOcrFactoryOcrTableRegion Method

Overload List
 | Name | Description
Public method | OcrTableRegion(Rectangle) | Constructs a new OcrTableRegion object.
Public method | OcrTableRegion(PolygonF) | Construct a page element to represent a table.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTableRegion Method (Rectangle)

BasicOcrFactoryOcrTableRegion Method (Rectangle)

Constructs a new OcrTableRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrTableRegion OcrTableRegion(
    Rectangle bounds
)
Public Overridable Function OcrTableRegion (
    bounds As Rectangle
) As OcrTableRegion

Parameters

bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.

Return Value

Type: OcrTableRegion
A new OcrTableRegion object.

Implements

IOcrFactoryOcrTableRegion(Rectangle)
See Also

Reference

BasicOcrFactory Class
OcrTableRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTableRegion Method (PolygonF)

BasicOcrFactoryOcrTableRegion Method (PolygonF)

Construct a page element to represent a table.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrTableRegion OcrTableRegion(
    PolygonF bounds
)
Public Overridable Function OcrTableRegion (
    bounds As PolygonF
) As OcrTableRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding rectangle of the object on the page.

Return Value

Type: OcrTableRegion
A new object of type OcrTableRegion.

Implements

IOcrFactoryOcrTableRegion(PolygonF)
See Also

Reference

BasicOcrFactory Class
OcrTableRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTextRegion Method

BasicOcrFactoryOcrTextRegion Method

Overload List
 | Name | Description
Public method | OcrTextRegion(Rectangle) | Construct a new OcrTextRegion object.
Public method | OcrTextRegion(PolygonF) | Construct a new OcrTextRegion object.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Construct a new OcrTextRegion object.
Top
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTextRegion Method (Rectangle)

BasicOcrFactoryOcrTextRegion Method (Rectangle)

Construct a new OcrTextRegion object.
Constructs a new OcrTextRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrTextRegion OcrTextRegion(
    Rectangle bounds
)
Public Overridable Function OcrTextRegion (
    bounds As Rectangle
) As OcrTextRegion

Parameters

bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.

Return Value

Type: OcrTextRegion
A new OcrTextRegion object.

Implements

IOcrFactoryOcrTextRegion(Rectangle)
See Also

Reference

BasicOcrFactory Class
OcrTextRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTextRegion Method (PolygonF)

BasicOcrFactoryOcrTextRegion Method (PolygonF)

Construct a new OcrTextRegion object.
Constructs a new OcrTextRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrTextRegion OcrTextRegion(
    PolygonF bounds
)
Public Overridable Function OcrTextRegion (
    bounds As PolygonF
) As OcrTextRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding rectangle of the object on the page.

Return Value

Type: OcrTextRegion
A new OcrTextRegion object.

Implements

IOcrFactoryOcrTextRegion(PolygonF)
See Also

Reference

BasicOcrFactory Class
OcrTextRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrTextRegion Method (Rectangle, OcrTextRotation)

BasicOcrFactoryOcrTextRegion Method (Rectangle, OcrTextRotation)

Construct a new OcrTextRegion object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrTextRegion OcrTextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Public Overridable Function OcrTextRegion (
    bounds As Rectangle,
    rotation As OcrTextRotation
) As OcrTextRegion

Parameters

bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.
rotation
Type: Atalasoft.OcrOcrTextRotation
The rotation of this text region.

Return Value

Type: OcrTextRegion

Implements

IOcrFactoryOcrTextRegion(Rectangle, OcrTextRotation)
See Also

Reference

BasicOcrFactory Class
OcrTextRegion Overload
Atalasoft.Ocr Namespace


BasicOcrFactory.OcrWord Method

BasicOcrFactoryOcrWord Method

Constructs a new OcrWord(IOcrWordAccessor, Rectangle, Int32) object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrWord OcrWord(
    IOcrWordAccessor accessor,
    Rectangle bounds,
    int baseline
)
Public Overridable Function OcrWord (
    accessor As IOcrWordAccessor,
    bounds As Rectangle,
    baseline As Integer
) As OcrWord

Parameters

accessor
Type: Atalasoft.OcrIOcrWordAccessor
The accessor that will be used for this object. This is usually supplied by the engine during recognition. If you need to call OcrWord to change a word in an existing document, you can use a BasicOcrWordAccessor object.
bounds
Type: System.DrawingRectangle
The bounding rectangle of the object on the page in pixels.
baseline
Type: SystemInt32
The baseline of the text on the page in pixels.

Return Value

Type: OcrWord
A new OcrWord(IOcrWordAccessor, Rectangle, Int32) object.

Implements

IOcrFactoryOcrWord(IOcrWordAccessor, Rectangle, Int32)
See Also

Reference

BasicOcrFactory Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Class

BasicOcrGlyphAccessor is a simple implementation of the IOcrGlyphAccessor interface which provides basic functionality for a glyph.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrBasicOcrGlyphAccessor

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicOcrGlyphAccessor : MarshalByRefObject,
    IOcrGlyphAccessor
Public Class BasicOcrGlyphAccessor
    Inherits MarshalByRefObject
    Implements IOcrGlyphAccessor

The BasicOcrGlyphAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | BasicOcrGlyphAccessor(Char, String, FontStyle, Single) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(String, String, FontStyle, Single) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(Char, String, FontStyle, Single, Color) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(String, String, FontStyle, Single, Color) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(Char, String, FontStyle, Single, Color, Double) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(String, String, FontStyle, Single, Color, Double) | Construct a new BasicOcrGlyphAccessor.
Top
Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the glyph in pixels relative to the source image.
Public property | Char | The unicode representation of this glyph.
Public property | Color | This property represents the color of this glyph.
Public property | Confidence | This property represents the confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Public property | Glyph | This property allows the constructor of OcrGlyph to hook the OcrGlyph into the IOcrGlyphAccessor.
Public property | IsSingleton | Checks to see if the glyph is represented by more than one letter.
Public property | Text | This property is a string represents the text of this glyph.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFont | Gets the Font for this glyph.
Public method | GetFontFamily | Get the FontFamily that represents this glyph.
Public method | GetFontName | Get the name of the font used for this glyph.
Public method | GetFontSize | Gets the font size of this glyph.
Public method | GetFontStyle | Get the FontStyle of this glyph.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor

Overload List
 | Name | Description
Public method | BasicOcrGlyphAccessor(Char, String, FontStyle, Single) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(String, String, FontStyle, Single) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(Char, String, FontStyle, Single, Color) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(String, String, FontStyle, Single, Color) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(Char, String, FontStyle, Single, Color, Double) | Construct a new BasicOcrGlyphAccessor.
Public method | BasicOcrGlyphAccessor(String, String, FontStyle, Single, Color, Double) | Construct a new BasicOcrGlyphAccessor.
Top
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor (Char, String, FontStyle, Single)

Construct a new BasicOcrGlyphAccessor.
Constucts a new BasicOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrGlyphAccessor(
    char theCharacter,
    string family,
    FontStyle style,
    float size
)
Public Sub New (
    theCharacter As Char,
    family As String,
    style As FontStyle,
    size As Single
)

Parameters

theCharacter
Type: SystemChar
The character that this glyph represents.
family
Type: SystemString
The name of the font family that for this glyph.
style
Type: System.DrawingFontStyle
The FontStyle for this glyph.
size
Type: SystemSingle
The size of this glyph in points.

Return Value

Type:
A new BasicOcrGlyphAccessor.
See Also

Reference

BasicOcrGlyphAccessor Class
BasicOcrGlyphAccessor Overload
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor (String, String, FontStyle, Single)

Construct a new BasicOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrGlyphAccessor(
    string text,
    string family,
    FontStyle style,
    float size
)
Public Sub New (
    text As String,
    family As String,
    style As FontStyle,
    size As Single
)

Parameters

text
Type: SystemString
The text that this glyph represents.
family
Type: SystemString
The name of the font family that for this glyph.
style
Type: System.DrawingFontStyle
The FontStyle for this glyph.
size
Type: SystemSingle
The size of this glyph in points.
See Also

Reference

BasicOcrGlyphAccessor Class
BasicOcrGlyphAccessor Overload
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor (Char, String, FontStyle, Single, Color)

Construct a new BasicOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrGlyphAccessor(
    char theCharacter,
    string family,
    FontStyle style,
    float size,
    Color color
)
Public Sub New (
    theCharacter As Char,
    family As String,
    style As FontStyle,
    size As Single,
    color As Color
)

Parameters

theCharacter
Type: SystemChar
The character that this glyph represents.
family
Type: SystemString
The name of the font family that for this glyph.
style
Type: System.DrawingFontStyle
The FontStyle for this glyph.
size
Type: SystemSingle
The size of this glyph in points.
color
Type: System.DrawingColor
The color for this glyph.
See Also

Reference

BasicOcrGlyphAccessor Class
BasicOcrGlyphAccessor Overload
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor (String, String, FontStyle, Single, Color)

Construct a new BasicOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrGlyphAccessor(
    string text,
    string family,
    FontStyle style,
    float size,
    Color color
)
Public Sub New (
    text As String,
    family As String,
    style As FontStyle,
    size As Single,
    color As Color
)

Parameters

text
Type: SystemString
The text that this glyph represents.
family
Type: SystemString
The name of the font family that for this glyph.
style
Type: System.DrawingFontStyle
The FontStyle for this glyph.
size
Type: SystemSingle
The size of this glyph in points.
color
Type: System.DrawingColor
The color for this glyph.
See Also

Reference

BasicOcrGlyphAccessor Class
BasicOcrGlyphAccessor Overload
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor (Char, String, FontStyle, Single, Color, Double)

Construct a new BasicOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrGlyphAccessor(
    char theCharacter,
    string family,
    FontStyle style,
    float size,
    Color color,
    double confidence
)
Public Sub New (
    theCharacter As Char,
    family As String,
    style As FontStyle,
    size As Single,
    color As Color,
    confidence As Double
)

Parameters

theCharacter
Type: SystemChar
The character that this glyph represents.
family
Type: SystemString
The name of the font family that for this glyph.
style
Type: System.DrawingFontStyle
The FontStyle for this glyph.
size
Type: SystemSingle
The size of this glyph in points.
color
Type: System.DrawingColor
The color for this glyph.
confidence
Type: SystemDouble
The confidence value of this glyph.
See Also

Reference

BasicOcrGlyphAccessor Class
BasicOcrGlyphAccessor Overload
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Constructor (String, String, FontStyle, Single, Color, Double)

Construct a new BasicOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrGlyphAccessor(
    string text,
    string family,
    FontStyle style,
    float size,
    Color color,
    double confidence
)
Public Sub New (
    text As String,
    family As String,
    style As FontStyle,
    size As Single,
    color As Color,
    confidence As Double
)

Parameters

text
Type: SystemString
The text that this glyph represents.
family
Type: SystemString
The name of the font family that for this glyph.
style
Type: System.DrawingFontStyle
The FontStyle for this glyph.
size
Type: SystemSingle
The size of this glyph in points.
color
Type: System.DrawingColor
The color for this glyph.
confidence
Type: SystemDouble
The confidence value of this glyph.
See Also

Reference

BasicOcrGlyphAccessor Class
BasicOcrGlyphAccessor Overload
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Properties

The BasicOcrGlyphAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the glyph in pixels relative to the source image.
Public property | Char | The unicode representation of this glyph.
Public property | Color | This property represents the color of this glyph.
Public property | Confidence | This property represents the confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Public property | Glyph | This property allows the constructor of OcrGlyph to hook the OcrGlyph into the IOcrGlyphAccessor.
Public property | IsSingleton | Checks to see if the glyph is represented by more than one letter.
Public property | Text | This property is a string represents the text of this glyph.
Top
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Baseline Property

BasicOcrGlyphAccessorBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Baseline { get; set; }
Public Overridable Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IOcrGlyphAccessorBaseline
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Bounds Property

BasicOcrGlyphAccessorBounds Property

This property represents the bounding box of the glyph in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; set; }
Public Overridable Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this glyph.

Implements

IOcrGlyphAccessorBounds
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Char Property

BasicOcrGlyphAccessorChar Property

The unicode representation of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual char Char { get; }
Public Overridable ReadOnly Property Char As Char
    Get

Property Value

Type: Char

Implements

IOcrGlyphAccessorChar
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Color Property

BasicOcrGlyphAccessorColor Property

This property represents the color of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Color Color { get; set; }
Public Overridable Property Color As Color
    Get
    Set

Property Value

Type: Color

Implements

IOcrGlyphAccessorColor
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Confidence Property

BasicOcrGlyphAccessorConfidence Property

This property represents the confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double Confidence { get; }
Public Overridable ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Implements

IOcrGlyphAccessorConfidence
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Glyph Property

BasicOcrGlyphAccessorGlyph Property

This property allows the constructor of OcrGlyph to hook the OcrGlyph into the IOcrGlyphAccessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrGlyph Glyph { get; set; }
Public Overridable Property Glyph As OcrGlyph
    Get
    Set

Property Value

Type: OcrGlyph

Implements

IOcrGlyphAccessorGlyph
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.IsSingleton Property

BasicOcrGlyphAccessorIsSingleton Property

Checks to see if the glyph is represented by more than one letter.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool IsSingleton { get; }
Public Overridable ReadOnly Property IsSingleton As Boolean
    Get

Property Value

Type: Boolean
True if the character is only one letter, false otherwise.

Implements

IOcrGlyphAccessorIsSingleton
Remarks
Glyphs in typography may represent more than one individual character. Typically, this done via a ligature wherein two or more characters are joined together. This property makes it possible to determine if that is the case in order to better reconstruct an image or to facilitate searching through the text.
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.Text Property

BasicOcrGlyphAccessorText Property

This property is a string represents the text of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string Text { get; }
Public Overridable ReadOnly Property Text As String
    Get

Property Value

Type: String

Implements

IOcrGlyphAccessorText
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor Methods

The BasicOcrGlyphAccessor type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFont | Gets the Font for this glyph.
Public method | GetFontFamily | Get the FontFamily that represents this glyph.
Public method | GetFontName | Get the name of the font used for this glyph.
Public method | GetFontSize | Gets the font size of this glyph.
Public method | GetFontStyle | Get the FontStyle of this glyph.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.GetFont Method

BasicOcrGlyphAccessorGetFont Method

Gets the Font for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Font GetFont(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder
)
Public Overridable Function GetFont (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image.
mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.
builder
Type: Atalasoft.OcrIFontBuilder
An IFontBuilder to build the resulting font.

Return Value

Type: Font
The Font for this glyph.

Implements

IOcrGlyphAccessorGetFont(Dpi, IFontMapper, IFontBuilder)
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.GetFontFamily Method

BasicOcrGlyphAccessorGetFontFamily Method

Get the FontFamily that represents this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontFamily GetFontFamily(
    IFontMapper mapper
)
Public Overridable Function GetFontFamily (
    mapper As IFontMapper
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.

Return Value

Type: FontFamily
The FontFamily that represents this glyph.

Implements

IOcrGlyphAccessorGetFontFamily(IFontMapper)
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.GetFontName Method

BasicOcrGlyphAccessorGetFontName Method

Get the name of the font used for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetFontName(
    IFontMapper mapper
)
Public Overridable Function GetFontName (
    mapper As IFontMapper
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.

Return Value

Type: String

Implements

IOcrGlyphAccessorGetFontName(IFontMapper)
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.GetFontSize Method

BasicOcrGlyphAccessorGetFontSize Method

Gets the font size of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual float GetFontSize(
    Dpi imageResolution
)
Public Overridable Function GetFontSize (
    imageResolution As Dpi
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image.

Return Value

Type: Single
The font size of the glyph in points.

Implements

IOcrGlyphAccessorGetFontSize(Dpi)
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrGlyphAccessor.GetFontStyle Method

BasicOcrGlyphAccessorGetFontStyle Method

Get the FontStyle of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontStyle GetFontStyle(
    IFontMapper mapper
)
Public Overridable Function GetFontStyle (
    mapper As IFontMapper
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.

Return Value

Type: FontStyle
The FontStyle of this glyph.

Implements

IOcrGlyphAccessorGetFontStyle(IFontMapper)
See Also

Reference

BasicOcrGlyphAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor Class

BasicOcrLineAccessor is a simple implementation of the IOcrLineAccessor interface which provides basic functionality for a line of text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrBasicOcrLineAccessor

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicOcrLineAccessor : MarshalByRefObject,
    IOcrLineAccessor
Public Class BasicOcrLineAccessor
    Inherits MarshalByRefObject
    Implements IOcrLineAccessor

The BasicOcrLineAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | BasicOcrLineAccessor | Initializes a new instance of the BasicOcrLineAccessor class
Top
Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the line in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire line.
Public property | Line | This property is used for setting the OcrLine that this accessor is attached to.
Public property | Text | Returns the text of the line as a string.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindWordFromIndex | Returns the Word located at the input index.
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a line of text.
Public method | GetFontColorAt | Returns the color of the glyph at the position in a line of text.
Public method | GetFontFamilyAt | Get the FontFamily for this glyph.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the line.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a line of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | StyleIsUniform | Check to see if the font and style are uniform across this line of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


BasicOcrLineAccessor Constructor

Initializes a new instance of the BasicOcrLineAccessor class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrLineAccessor()
Public Sub New
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor Properties

The BasicOcrLineAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the line in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire line.
Public property | Line | This property is used for setting the OcrLine that this accessor is attached to.
Public property | Text | Returns the text of the line as a string.
Top
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.Baseline Property

BasicOcrLineAccessorBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Baseline { get; set; }
Public Overridable Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IOcrLineAccessorBaseline
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.Bounds Property

BasicOcrLineAccessorBounds Property

This property represents the bounding box of the line in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; set; }
Public Overridable Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this glyph.

Implements

IOcrLineAccessorBounds
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.Confidence Property

BasicOcrLineAccessorConfidence Property

This property represents the confidence of recognition of the entire line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double Confidence { get; }
Public Overridable ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Implements

IOcrLineAccessorConfidence
Remarks
This value is calculated as the average confidence of all the glyphs in the line.
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.Line Property

BasicOcrLineAccessorLine Property

This property is used for setting the OcrLine that this accessor is attached to.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrLine Line { get; set; }
Public Overridable Property Line As OcrLine
    Get
    Set

Property Value

Type: OcrLine

Implements

IOcrLineAccessorLine
Remarks
This property is used when an OcrLine is constructed. Typically, an OcrEngine will construct an object that meets IOcrLineAccessor first, then construct the OcrLine via an IOcrFactory. Finally, it will set the Line property to the constructed OcrLine.
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.Text Property

BasicOcrLineAccessorText Property

Returns the text of the line as a string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string Text { get; }
Public Overridable ReadOnly Property Text As String
    Get

Property Value

Type: String
A string representing the text of the line.

Implements

IOcrLineAccessorText
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor Methods

The BasicOcrLineAccessor type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindWordFromIndex | Returns the Word located at the input index.
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a line of text.
Public method | GetFontColorAt | Returns the color of the glyph at the position in a line of text.
Public method | GetFontFamilyAt | Get the FontFamily for this glyph.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the line.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a line of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | StyleIsUniform | Check to see if the font and style are uniform across this line of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.FindWordFromIndex Method

BasicOcrLineAccessorFindWordFromIndex Method

Returns the Word located at the input index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual OcrWord FindWordFromIndex(
    int characterIndex,
    out int wordIndex
)
Protected Overridable Function FindWordFromIndex (
    characterIndex As Integer,
    <OutAttribute> ByRef wordIndex As Integer
) As OcrWord

Parameters

characterIndex
Type: SystemInt32
The character index to start search.
wordIndex
Type: SystemInt32
The word index to start search.

Return Value

Type: OcrWord
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetConfidenceAt Method

BasicOcrLineAccessorGetConfidenceAt Method

Get the confidence of recognition at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GetConfidenceAt(
    int i
)
Public Overridable Function GetConfidenceAt (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Double
A double representing the confidence of recognition of the specified glyph ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Implements

IOcrLineAccessorGetConfidenceAt(Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetFontAt Method

BasicOcrLineAccessorGetFontAt Method

Get the Font of a glyph at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Font GetFontAt(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder,
    int i
)
Public Overridable Function GetFontAt (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder,
    i As Integer
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image.
mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.
builder
Type: Atalasoft.OcrIFontBuilder
An IFontBuilder to build the resulting font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Font
An object of type Font that represents the font of the glyph.

Implements

IOcrLineAccessorGetFontAt(Dpi, IFontMapper, IFontBuilder, Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetFontColorAt Method

BasicOcrLineAccessorGetFontColorAt Method

Returns the color of the glyph at the position in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Color GetFontColorAt(
    int i
)
Public Overridable Function GetFontColorAt (
    i As Integer
) As Color

Parameters

i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Color
The color of the glyph at the position in a line of text.

Implements

IOcrLineAccessorGetFontColorAt(Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetFontFamilyAt Method

BasicOcrLineAccessorGetFontFamilyAt Method

Get the FontFamily for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontFamily GetFontFamilyAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontFamilyAt (
    mapper As IFontMapper,
    i As Integer
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: FontFamily
An object of type FontFamily that represents the font family of the glyph.

Implements

IOcrLineAccessorGetFontFamilyAt(IFontMapper, Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetFontNameAt Method

BasicOcrLineAccessorGetFontNameAt Method

Returns the name of the font used for the glyph at the specified position in the line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetFontNameAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontNameAt (
    mapper As IFontMapper,
    i As Integer
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An object to map font names.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: String
A string representing the name of the font used for the glyph at the specified position in the line.

Implements

IOcrLineAccessorGetFontNameAt(IFontMapper, Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetFontSizeAt Method

BasicOcrLineAccessorGetFontSizeAt Method

Get the font size of a glyph at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual float GetFontSizeAt(
    Dpi imageResolution,
    int i
)
Public Overridable Function GetFontSizeAt (
    imageResolution As Dpi,
    i As Integer
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Single
A floating point number that represents the size of the glyph in points.

Implements

IOcrLineAccessorGetFontSizeAt(Dpi, Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.GetFontStyleAt Method

BasicOcrLineAccessorGetFontStyleAt Method

This property represents the FontStyle of a glyph at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontStyle GetFontStyleAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontStyleAt (
    mapper As IFontMapper,
    i As Integer
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of the glyph.

Implements

IOcrLineAccessorGetFontStyleAt(IFontMapper, Int32)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrLineAccessor.StyleIsUniform Method

BasicOcrLineAccessorStyleIsUniform Method

Check to see if the font and style are uniform across this line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool StyleIsUniform(
    IFontMapper mapper,
    IFontBuilder builder
)
Public Overridable Function StyleIsUniform (
    mapper As IFontMapper,
    builder As IFontBuilder
) As Boolean

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.
builder
Type: Atalasoft.OcrIFontBuilder
An IFontBuilder to build the resulting font.

Return Value

Type: Boolean
True if the font family, style and size are the same throughout the line of text.

Implements

IOcrLineAccessorStyleIsUniform(IFontMapper, IFontBuilder)
See Also

Reference

BasicOcrLineAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor Class

BasicOcrLineAccessor is a simple implementation of the IOcrWordAccessor interface which provides basic functionality for a word of text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrBasicOcrWordAccessor

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicOcrWordAccessor : MarshalByRefObject,
    IOcrWordAccessor
Public Class BasicOcrWordAccessor
    Inherits MarshalByRefObject
    Implements IOcrWordAccessor

The BasicOcrWordAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | BasicOcrWordAccessor | Initializes a new instance of the BasicOcrWordAccessor class
Top
Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the word in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire word.
Public property | Text | Returns the text of the word as a string.
Public property | Word | This property is used for setting the OcrWord that this accessor is attached to.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a word of text.
Public method | GetFontColorAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontFamilyAt | Get the FontFamily for this glyph.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a word of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | StyleIsUniform | Check to see if the font and style are uniform across this word of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


BasicOcrWordAccessor Constructor

Initializes a new instance of the BasicOcrWordAccessor class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicOcrWordAccessor()
Public Sub New
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor Properties

The BasicOcrWordAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the word in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire word.
Public property | Text | Returns the text of the word as a string.
Public property | Word | This property is used for setting the OcrWord that this accessor is attached to.
Top
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.Baseline Property

BasicOcrWordAccessorBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Baseline { get; set; }
Public Overridable Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IOcrWordAccessorBaseline
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.Bounds Property

BasicOcrWordAccessorBounds Property

This property represents the bounding box of the word in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; set; }
Public Overridable Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this glyph.

Implements

IOcrWordAccessorBounds
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.Confidence Property

BasicOcrWordAccessorConfidence Property

This property represents the confidence of recognition of the entire word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double Confidence { get; }
Public Overridable ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Implements

IOcrWordAccessorConfidence
Remarks
This value is calculated as the average confidence of all the glyphs in the word.
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.Text Property

BasicOcrWordAccessorText Property

Returns the text of the word as a string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string Text { get; }
Public Overridable ReadOnly Property Text As String
    Get

Property Value

Type: String
A string representing the text of the word.

Implements

IOcrWordAccessorText
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.Word Property

BasicOcrWordAccessorWord Property

This property is used for setting the OcrWord that this accessor is attached to.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrWord Word { get; set; }
Public Overridable Property Word As OcrWord
    Get
    Set

Property Value

Type: OcrWord

Implements

IOcrWordAccessorWord
Remarks
This property is used when an OcrWord is constructed. Typically, an OcrEngine will construct an object that meets IOcrWordAccessor first, then construct the OcrWord via an IOcrFactory. Finally, it will set the Word property to the constructed OcrWord.
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor Methods

The BasicOcrWordAccessor type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a word of text.
Public method | GetFontColorAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontFamilyAt | Get the FontFamily for this glyph.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a word of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | StyleIsUniform | Check to see if the font and style are uniform across this word of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetConfidenceAt Method

BasicOcrWordAccessorGetConfidenceAt Method

Get the confidence of recognition at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GetConfidenceAt(
    int i
)
Public Overridable Function GetConfidenceAt (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Double
A double representing the confidence of recognition of the specified glyph ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Implements

IOcrWordAccessorGetConfidenceAt(Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetFontAt Method

BasicOcrWordAccessorGetFontAt Method

Get the Font of a glyph at a particular point in a word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Font GetFontAt(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder,
    int i
)
Public Overridable Function GetFontAt (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder,
    i As Integer
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
builder
Type: Atalasoft.OcrIFontBuilder
An IFontBuilder to build the resulting font.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Font
An object of type Font that represents the font of the glyph.

Implements

IOcrWordAccessorGetFontAt(Dpi, IFontMapper, IFontBuilder, Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetFontColorAt Method

BasicOcrWordAccessorGetFontColorAt Method

Returns the name of the font used for the glyph at the specified position in the word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Color GetFontColorAt(
    int i
)
Public Overridable Function GetFontColorAt (
    i As Integer
) As Color

Parameters

i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Color
The color of the glyph at the position in a word of text.

Implements

IOcrWordAccessorGetFontColorAt(Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetFontFamilyAt Method

BasicOcrWordAccessorGetFontFamilyAt Method

Get the FontFamily for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontFamily GetFontFamilyAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontFamilyAt (
    mapper As IFontMapper,
    i As Integer
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An IFontMapper to map the font characteristics.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: FontFamily
An object of type FontFamily that represents the font family of the glyph.

Implements

IOcrWordAccessorGetFontFamilyAt(IFontMapper, Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetFontNameAt Method

BasicOcrWordAccessorGetFontNameAt Method

Returns the name of the font used for the glyph at the specified position in the word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetFontNameAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontNameAt (
    mapper As IFontMapper,
    i As Integer
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within the word.

Return Value

Type: String
A string representing the name of the font used for the glyph at the specified position in the word.

Implements

IOcrWordAccessorGetFontNameAt(IFontMapper, Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetFontSizeAt Method

BasicOcrWordAccessorGetFontSizeAt Method

Get the font size of a glyph at a particular point in a word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual float GetFontSizeAt(
    Dpi imageResolution,
    int i
)
Public Overridable Function GetFontSizeAt (
    imageResolution As Dpi,
    i As Integer
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image from which this word was taken.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Single
A floating point number that represents the size of the glyph in points.

Implements

IOcrWordAccessorGetFontSizeAt(Dpi, Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.GetFontStyleAt Method

BasicOcrWordAccessorGetFontStyleAt Method

This property represents the FontStyle of a glyph at a particular point in a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontStyle GetFontStyleAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontStyleAt (
    mapper As IFontMapper,
    i As Integer
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of the glyph.

Implements

IOcrWordAccessorGetFontStyleAt(IFontMapper, Int32)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


BasicOcrWordAccessor.StyleIsUniform Method

BasicOcrWordAccessorStyleIsUniform Method

Check to see if the font and style are uniform across this word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool StyleIsUniform(
    IFontMapper mapper,
    IFontBuilder builder
)
Public Overridable Function StyleIsUniform (
    mapper As IFontMapper,
    builder As IFontBuilder
) As Boolean

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
builder
Type: Atalasoft.OcrIFontBuilder
An IFontBuilder to build the resulting font.

Return Value

Type: Boolean
True if the font family, style and size are the same throughout the line of text.

Implements

IOcrWordAccessorStyleIsUniform(IFontMapper, IFontBuilder)
See Also

Reference

BasicOcrWordAccessor Class
Atalasoft.Ocr Namespace


CustomCultureInfo Class

Inheritance Hierarchy
SystemObject
System.GlobalizationCultureInfo
Atalasoft.OcrCustomCultureInfo
Atalasoft.Ocr.OmniPageOmniPageCultureInfo

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CustomCultureInfo : CultureInfo
Public Class CustomCultureInfo
    Inherits CultureInfo

The CustomCultureInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CustomCultureInfo | Initializes a new instance of the CustomCultureInfo class
Top
Properties
 | Name | Description
Public property | Calendar | Gets the default calendar used by the culture. (Inherited from CultureInfo.)
Public property | CompareInfo | Gets the CompareInfo that defines how to compare strings for the culture. (Inherited from CultureInfo.)
Public property | CultureTypes | Gets the culture types that pertain to the current CultureInfo object. (Inherited from CultureInfo.)
Public property | DateTimeFormat | Gets or sets a DateTimeFormatInfo that defines the culturally appropriate format of displaying dates and times. (Inherited from CultureInfo.)
Public property | DisplayName | (Overrides CultureInfoDisplayName.)
Public property | EnglishName | (Overrides CultureInfoEnglishName.)
Public property | IetfLanguageTag | Deprecated. Gets the RFC 4646 standard identification for a language. (Inherited from CultureInfo.)
Public property | IsNeutralCulture | Gets a value indicating whether the current CultureInfo represents a neutral culture. (Inherited from CultureInfo.)
Public property | IsReadOnly | Gets a value indicating whether the current CultureInfo is read-only. (Inherited from CultureInfo.)
Public property | KeyboardLayoutId | Gets the active input locale identifier. (Inherited from CultureInfo.)
Public property | LCID | Gets the culture identifier for the current CultureInfo. (Inherited from CultureInfo.)
Public property | Name | (Overrides CultureInfoName.)
Public property | NativeName | (Overrides CultureInfoNativeName.)
Public property | NumberFormat | Gets or sets a NumberFormatInfo that defines the culturally appropriate format of displaying numbers, currency, and percentage. (Inherited from CultureInfo.)
Public property | OptionalCalendars | Gets the list of calendars that can be used by the culture. (Inherited from CultureInfo.)
Public property | Parent | Gets the CultureInfo that represents the parent culture of the current CultureInfo. (Inherited from CultureInfo.)
Public property | TextInfo | Gets the TextInfo that defines the writing system associated with the culture. (Inherited from CultureInfo.)
Public property | ThreeLetterISOLanguageName | Gets the ISO 639-2 three-letter code for the language of the current CultureInfo. (Inherited from CultureInfo.)
Public property | ThreeLetterWindowsLanguageName | Gets the three-letter code for the language as defined in the Windows API. (Inherited from CultureInfo.)
Public property | TwoLetterISOLanguageName | Gets the ISO 639-1 two-letter code for the language of the current CultureInfo. (Inherited from CultureInfo.)
Public property | UseUserOverride | Gets a value indicating whether the current CultureInfo uses the user-selected culture settings. (Inherited from CultureInfo.)
Top
Methods
 | Name | Description
Public method | ClearCachedData | Refreshes cached culture-related information. (Inherited from CultureInfo.)
Public method | Clone | Creates a copy of the current CultureInfo. (Inherited from CultureInfo.)
Public method | Equals | Determines whether the specified object is the same culture as the current CultureInfo. (Inherited from CultureInfo.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConsoleFallbackUICulture | Gets an alternate user interface culture suitable for console applications when the default graphic user interface culture is unsuitable. (Inherited from CultureInfo.)
Public method | GetFormat | Gets an object that defines how to format the specified type. (Inherited from CultureInfo.)
Public method | GetHashCode | Serves as a hash function for the current CultureInfo, suitable for hashing algorithms and data structures, such as a hash table. (Inherited from CultureInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string containing the name of the current CultureInfo in the format languagecode2-country/regioncode2. (Inherited from CultureInfo.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


CustomCultureInfo Constructor

Initializes a new instance of the CustomCultureInfo class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CustomCultureInfo(
    string customNamePrefix,
    string name,
    string displayName
)
Public Sub New (
    customNamePrefix As String,
    name As String,
    displayName As String
)

Parameters

customNamePrefix
Type: SystemString
name
Type: SystemString
displayName
Type: SystemString
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


CustomCultureInfo Properties

The CustomCultureInfo type exposes the following members.

Properties
 | Name | Description
Public property | Calendar | Gets the default calendar used by the culture. (Inherited from CultureInfo.)
Public property | CompareInfo | Gets the CompareInfo that defines how to compare strings for the culture. (Inherited from CultureInfo.)
Public property | CultureTypes | Gets the culture types that pertain to the current CultureInfo object. (Inherited from CultureInfo.)
Public property | DateTimeFormat | Gets or sets a DateTimeFormatInfo that defines the culturally appropriate format of displaying dates and times. (Inherited from CultureInfo.)
Public property | DisplayName | (Overrides CultureInfoDisplayName.)
Public property | EnglishName | (Overrides CultureInfoEnglishName.)
Public property | IetfLanguageTag | Deprecated. Gets the RFC 4646 standard identification for a language. (Inherited from CultureInfo.)
Public property | IsNeutralCulture | Gets a value indicating whether the current CultureInfo represents a neutral culture. (Inherited from CultureInfo.)
Public property | IsReadOnly | Gets a value indicating whether the current CultureInfo is read-only. (Inherited from CultureInfo.)
Public property | KeyboardLayoutId | Gets the active input locale identifier. (Inherited from CultureInfo.)
Public property | LCID | Gets the culture identifier for the current CultureInfo. (Inherited from CultureInfo.)
Public property | Name | (Overrides CultureInfoName.)
Public property | NativeName | (Overrides CultureInfoNativeName.)
Public property | NumberFormat | Gets or sets a NumberFormatInfo that defines the culturally appropriate format of displaying numbers, currency, and percentage. (Inherited from CultureInfo.)
Public property | OptionalCalendars | Gets the list of calendars that can be used by the culture. (Inherited from CultureInfo.)
Public property | Parent | Gets the CultureInfo that represents the parent culture of the current CultureInfo. (Inherited from CultureInfo.)
Public property | TextInfo | Gets the TextInfo that defines the writing system associated with the culture. (Inherited from CultureInfo.)
Public property | ThreeLetterISOLanguageName | Gets the ISO 639-2 three-letter code for the language of the current CultureInfo. (Inherited from CultureInfo.)
Public property | ThreeLetterWindowsLanguageName | Gets the three-letter code for the language as defined in the Windows API. (Inherited from CultureInfo.)
Public property | TwoLetterISOLanguageName | Gets the ISO 639-1 two-letter code for the language of the current CultureInfo. (Inherited from CultureInfo.)
Public property | UseUserOverride | Gets a value indicating whether the current CultureInfo uses the user-selected culture settings. (Inherited from CultureInfo.)
Top
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


CustomCultureInfo.DisplayName Property

CustomCultureInfoDisplayName Property

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


CustomCultureInfo.EnglishName Property

CustomCultureInfoEnglishName Property

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string EnglishName { get; }
Public Overrides ReadOnly Property EnglishName As String
    Get

Property Value

Type: String
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


CustomCultureInfo.Name Property

CustomCultureInfoName Property

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


CustomCultureInfo.NativeName Property

CustomCultureInfoNativeName Property

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string NativeName { get; }
Public Overrides ReadOnly Property NativeName As String
    Get

Property Value

Type: String
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


CustomCultureInfo Methods

The CustomCultureInfo type exposes the following members.

Methods
 | Name | Description
Public method | ClearCachedData | Refreshes cached culture-related information. (Inherited from CultureInfo.)
Public method | Clone | Creates a copy of the current CultureInfo. (Inherited from CultureInfo.)
Public method | Equals | Determines whether the specified object is the same culture as the current CultureInfo. (Inherited from CultureInfo.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConsoleFallbackUICulture | Gets an alternate user interface culture suitable for console applications when the default graphic user interface culture is unsuitable. (Inherited from CultureInfo.)
Public method | GetFormat | Gets an object that defines how to format the specified type. (Inherited from CultureInfo.)
Public method | GetHashCode | Serves as a hash function for the current CultureInfo, suitable for hashing algorithms and data structures, such as a hash table. (Inherited from CultureInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string containing the name of the current CultureInfo in the format languagecode2-country/regioncode2. (Inherited from CultureInfo.)
Top
See Also

Reference

CustomCultureInfo Class
Atalasoft.Ocr Namespace


GenericOcrResourceLoader Class

Helper class for loading OCR Engine resources.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrGenericOcrResourceLoader

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GenericOcrResourceLoader
Public Class GenericOcrResourceLoader

The GenericOcrResourceLoader type exposes the following members.

Constructors
 | Name | Description
Public method | GenericOcrResourceLoader | Initializes a new instance of the GenericOcrResourceLoader class
Top
Properties
Name | Description
OcrResources | Gets the name of default OCR resources folder.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseResourcePaths | Gets collection of base path where OCR Engine resources are stored.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


GenericOcrResourceLoader Constructor

Initializes a new instance of the GenericOcrResourceLoader class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GenericOcrResourceLoader()
Public Sub New
See Also

Reference

GenericOcrResourceLoader Class
Atalasoft.Ocr Namespace


GenericOcrResourceLoader Properties

The GenericOcrResourceLoader type exposes the following members.

Properties
Name | Description
OcrResources | Gets the name of default OCR resources folder.
Top
See Also

Reference

GenericOcrResourceLoader Class
Atalasoft.Ocr Namespace


GenericOcrResourceLoader.OcrResources Property

GenericOcrResourceLoaderOcrResources Property

Gets the name of default OCR resources folder.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string OcrResources { get; }
Public Shared ReadOnly Property OcrResources As String
    Get

Return Value

Type: String
Default OCR resources folder name.
See Also

Reference

GenericOcrResourceLoader Class
Atalasoft.Ocr Namespace


GenericOcrResourceLoader Methods

The GenericOcrResourceLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseResourcePaths | Gets collection of base path where OCR Engine resources are stored.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenericOcrResourceLoader Class
Atalasoft.Ocr Namespace


GenericOcrResourceLoader.GetBaseResourcePaths Method

GenericOcrResourceLoaderGetBaseResourcePaths Method

Gets collection of base path where OCR Engine resources are stored.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static StringCollection GetBaseResourcePaths()
Public Shared Function GetBaseResourcePaths As StringCollection

Return Value

Type: StringCollection
Collection of resources base paths.
See Also

Reference

GenericOcrResourceLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader Class

This class is used to load all resources for the GlyphReader OCR Engine
Inheritance Hierarchy
SystemObject
Atalasoft.OcrGlyphReaderLoader

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GlyphReaderLoader
Public Class GlyphReaderLoader

The GlyphReaderLoader type exposes the following members.

Constructors
 | Name | Description
Public method | GlyphReaderLoader | Initializes a new instance of the GlyphReaderDllLoader class and loads resources from default locations.
Public method | GlyphReaderLoader(String) | Initializes a new instance of the GlyphReaderDllLoader class and loads resources from a specified location.
Top
Properties
 | Name | Description
Public property | DllHandle | Gets the handle of the DLL from LoadLibrary().
Public property | FailureMessage | The failure message when the resouces cannot be loaded.
Public property | FullPath | Gets the full path of the resources.
Public property | Loaded | Determines if the resources sucessfully loaded.
Public property | Location | Gets the folder location of the resources.
Public property | PathsSearched | Gets collection of folders searched for the resources.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class should be constructed in a static constructor before the engine is used in any way.
Examples
Copy
 Public Sub Shared Form1
    Dim loader As GlyphReaderLoader = New GlyphReaderLoader()
    If Not loader.Loaded Then
        MessageBox.Show("Failed to load OCR Resources")
    End If
End Sub
Copy
 public static Form1()
{
    GlyphReaderLoader loader = new GlyphReaderLoader();
    if (!loader.Loaded)
    {
        MessageBox.Show("Failed to load OCR Resources");
    }
}
Examples
Copy
 Public Sub Shared Form1
    Dim loader As GlyphReaderLoader = New GlyphReaderLoader()
    If Not loader.Loaded Then
        MessageBox.Show("Failed to load OCR Resources")
    End If
End Sub
Copy
 public static Form1()
{
    GlyphReaderLoader loader = new GlyphReaderLoader();
    if (!loader.Loaded)
    {
        MessageBox.Show("Failed to load OCR Resources");
    }
}
See Also

Reference

Atalasoft.Ocr Namespace


GlyphReaderLoader Constructor

Overload List
 | Name | Description
Public method | GlyphReaderLoader | Initializes a new instance of the GlyphReaderDllLoader class and loads resources from default locations.
Public method | GlyphReaderLoader(String) | Initializes a new instance of the GlyphReaderDllLoader class and loads resources from a specified location.
Top
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader Constructor

Initializes a new instance of the GlyphReaderDllLoader class and loads resources from default locations.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlyphReaderLoader()
Public Sub New
See Also

Reference

GlyphReaderLoader Class
GlyphReaderLoader Overload
Atalasoft.Ocr Namespace


GlyphReaderLoader Constructor (String)

Initializes a new instance of the GlyphReaderDllLoader class and loads resources from a specified location.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlyphReaderLoader(
    string resourceDir
)
Public Sub New (
    resourceDir As String
)

Parameters

resourceDir
Type: SystemString
The folder where the resources are loaded from.
See Also

Reference

GlyphReaderLoader Class
GlyphReaderLoader Overload
Atalasoft.Ocr Namespace


GlyphReaderLoader Properties

The GlyphReaderLoader type exposes the following members.

Properties
 | Name | Description
Public property | DllHandle | Gets the handle of the DLL from LoadLibrary().
Public property | FailureMessage | The failure message when the resouces cannot be loaded.
Public property | FullPath | Gets the full path of the resources.
Public property | Loaded | Determines if the resources sucessfully loaded.
Public property | Location | Gets the folder location of the resources.
Public property | PathsSearched | Gets collection of folders searched for the resources.
Top
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader.DllHandle Property

GlyphReaderLoaderDllHandle Property

Gets the handle of the DLL from LoadLibrary().

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr DllHandle { get; }
Public ReadOnly Property DllHandle As IntPtr
    Get

Property Value

Type: IntPtr
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader.FailureMessage Property

GlyphReaderLoaderFailureMessage Property

The failure message when the resouces cannot be loaded.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FailureMessage { get; }
Public ReadOnly Property FailureMessage As String
    Get

Property Value

Type: String
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader.FullPath Property

GlyphReaderLoaderFullPath Property

Gets the full path of the resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get

Property Value

Type: String
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader.Loaded Property

GlyphReaderLoaderLoaded Property

Determines if the resources sucessfully loaded.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Loaded { get; }
Public ReadOnly Property Loaded As Boolean
    Get

Property Value

Type: Boolean
True if successful.
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader.Location Property

GlyphReaderLoaderLocation Property

Gets the folder location of the resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get

Property Value

Type: String
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader.PathsSearched Property

GlyphReaderLoaderPathsSearched Property

Gets collection of folders searched for the resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] PathsSearched { get; }
Public ReadOnly Property PathsSearched As String()
    Get

Property Value

Type: String
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


GlyphReaderLoader Methods

The GlyphReaderLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlyphReaderLoader Class
Atalasoft.Ocr Namespace


IFontBuilder Interface

IFontBuilder provides a mechanism to control how fonts are constructed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IFontBuilder
Public Interface IFontBuilder

The IFontBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Fonts | Provide a list of all font objects that have requested in this font builder.
Top
Methods
 | Name | Description
Public method | BuildFont | Build a font in the specified font family, size, and style.
Public method | Clear | Clears any old information in the font builder.
Top
Remarks
The IFontBuilder interface is used to define a class that will manage the construction of Fonts in a recognized document. A simple implementation of IFontBuilder is provided by the BasicFontBuilder class.
See Also

Reference

Atalasoft.Ocr Namespace
Atalasoft.OcrBasicFontBuilder


IFontBuilder Properties

The IFontBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Fonts | Provide a list of all font objects that have requested in this font builder.
Top
See Also

Reference

IFontBuilder Interface
Atalasoft.Ocr Namespace


IFontBuilder.Fonts Property

IFontBuilderFonts Property

Provide a list of all font objects that have requested in this font builder.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Font[] Fonts { get; }
ReadOnly Property Fonts As Font()
    Get

Property Value

Type: Font
See Also

Reference

IFontBuilder Interface
Atalasoft.Ocr Namespace


IFontBuilder Methods

The IFontBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildFont | Build a font in the specified font family, size, and style.
Public method | Clear | Clears any old information in the font builder.
Top
See Also

Reference

IFontBuilder Interface
Atalasoft.Ocr Namespace


IFontBuilder.BuildFont Method

IFontBuilderBuildFont Method

Build a font in the specified font family, size, and style.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Font BuildFont(
    FontFamily family,
    float size,
    FontStyle style
)
Function BuildFont (
    family As FontFamily,
    size As Single,
    style As FontStyle
) As Font

Parameters

family
Type: System.DrawingFontFamily
The FontFamily to construct.
size
Type: SystemSingle
The size of the font to construct, in points.
style
Type: System.DrawingFontStyle
The FontStyle of the font to construct.

Return Value

Type: Font
The constructed font.
Remarks

It is expected that an implementation of IFontBuilder will only create any unique font once, no matter how many times it is called with the same parameters. Any mechanism for caching is left up to the implementor.

Although it is possible to return a font which is a different FontFamily or FontStyle as that requested, that process is mapping and should be handled by an object that impements the IFontMapper interface.

See Also

Reference

IFontBuilder Interface
Atalasoft.Ocr Namespace


IFontBuilder.Clear Method

IFontBuilderClear Method

Clears any old information in the font builder.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

IFontBuilder Interface
Atalasoft.Ocr Namespace


IFontMapper Interface

IFontMapper provides a mechanism for translating fonts identified in the process of OCR from one set of characteristics to another.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IFontMapper
Public Interface IFontMapper

The IFontMapper type exposes the following members.

Methods
 | Name | Description
Public method | MapToFontFamily(GenericFontFamilies) |
Public method | MapToFontFamily(String) |
Public method | MapToFontName | This method maps a font name to another name.
Public method | RemapStyle | RemapStyle maps an input FontFamily and style to a new FontStyle.
Top
Remarks
The IFontMapper interface is used to define a class which will transform a font with one set of characteristics to another. A simple implementation of the IFontMapper interface is provided by the BasicFontMapper class.
See Also

Reference

Atalasoft.Ocr Namespace
BasicFontMapper Class


IFontMapper Methods

The IFontMapper type exposes the following members.

Methods
 | Name | Description
Public method | MapToFontFamily(GenericFontFamilies) |
Public method | MapToFontFamily(String) |
Public method | MapToFontName | This method maps a font name to another name.
Public method | RemapStyle | RemapStyle maps an input FontFamily and style to a new FontStyle.
Top
See Also

Reference

IFontMapper Interface
Atalasoft.Ocr Namespace


IFontMapper.MapToFontFamily Method

IFontMapperMapToFontFamily Method

Overload List
 | Name | Description
Public method | MapToFontFamily(GenericFontFamilies) |
Public method | MapToFontFamily(String) |
Top
See Also

Reference

IFontMapper Interface
Atalasoft.Ocr Namespace


IFontMapper.MapToFontFamily Method (GenericFontFamilies)

IFontMapperMapToFontFamily Method (GenericFontFamilies)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontFamily MapToFontFamily(
    GenericFontFamilies generic
)
Function MapToFontFamily (
    generic As GenericFontFamilies
) As FontFamily

Parameters

generic
Type: System.Drawing.TextGenericFontFamilies

Return Value

Type: FontFamily
The new FontFamily that will be used.
Remarks
A recognized document may have fonts that are not part of the current system. IFontMapper can be used to supply replacement fonts under those circumstances or provide a set of richer fonts for engines that can only recognize generic font families.
See Also

Reference

IFontMapper Interface
MapToFontFamily Overload
Atalasoft.Ocr Namespace


IFontMapper.MapToFontFamily Method (String)

IFontMapperMapToFontFamily Method (String)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontFamily MapToFontFamily(
    string name
)
Function MapToFontFamily (
    name As String
) As FontFamily

Parameters

name
Type: SystemString

Return Value

Type: FontFamily
The new FontFamily that will be used.
Remarks
A recognized document may have fonts that are not part of the current system. IFontMapper can be used to supply replacement fonts under those circumstances or provide a set of richer fonts for engines that can only recognize generic font families.
See Also

Reference

IFontMapper Interface
MapToFontFamily Overload
Atalasoft.Ocr Namespace


IFontMapper.MapToFontName Method

IFontMapperMapToFontName Method

This method maps a font name to another name.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string MapToFontName(
    string name
)
Function MapToFontName (
    name As String
) As String

Parameters

name
Type: SystemString
The name of the desired font.

Return Value

Type: String
A string representing the name of the actual font that will be used.
Remarks
This method makes it possible to provide altername fonts for recognized fonts in an OCR engine.
See Also

Reference

IFontMapper Interface
Atalasoft.Ocr Namespace


IFontMapper.RemapStyle Method

IFontMapperRemapStyle Method

RemapStyle maps an input FontFamily and style to a new FontStyle.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontStyle RemapStyle(
    FontFamily family,
    FontStyle style
)
Function RemapStyle (
    family As FontFamily,
    style As FontStyle
) As FontStyle

Parameters

family
Type: System.DrawingFontFamily
The FontFamily of the font being remapped.
style
Type: System.DrawingFontStyle
The FontStyle of the font being remapped.

Return Value

Type: FontStyle
A new FontStyle to be used instead of the one supplied.
Remarks
It is acceptable to simply return the FontStyle provided. This method is provided by those who want very fine grain control over font usage in a recognized image.
See Also

Reference

IFontMapper Interface
Atalasoft.Ocr Namespace


IForeignTranslator Interface

IForeignTranslator is a interface used to define how an OcrDocument will be translated to another format.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IForeignTranslator : ITranslator
Public Interface IForeignTranslator
    Inherits ITranslator

The IForeignTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Inherited from ITranslator.)
Public method | Finish | Allow a foreign translator to perform any necessary cleanup.
Public method | Prepare | Prepare a foreign translator for translation.
Public method | Supported | Get an array of mime types supported by this translator. (Inherited from ITranslator.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator. (Inherited from ITranslator.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
Remarks

Classes implementing IForeignTranslator are used to to augment or replace native translation capability provided by an OcrEngine. These translators can be used across all OCR Engines, thus are not specific to a single engine. TextTranslator and PdfTranslator are both Foreign Translators.

See Also

Reference

Atalasoft.Ocr Namespace


IForeignTranslator Methods

The IForeignTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Inherited from ITranslator.)
Public method | Finish | Allow a foreign translator to perform any necessary cleanup.
Public method | Prepare | Prepare a foreign translator for translation.
Public method | Supported | Get an array of mime types supported by this translator. (Inherited from ITranslator.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator. (Inherited from ITranslator.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
See Also

Reference

IForeignTranslator Interface
Atalasoft.Ocr Namespace


IForeignTranslator.Finish Method

IForeignTranslatorFinish Method

Allow a foreign translator to perform any necessary cleanup.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Finish(
    OcrEngine engine,
    OcrDocument doc,
    bool successful,
    Object translationObject
)
Sub Finish (
    engine As OcrEngine,
    doc As OcrDocument,
    successful As Boolean,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that has done the recognition.
doc
Type: Atalasoft.OcrOcrDocument
The recognized document.
successful
Type: SystemBoolean
Indicates that recognition was successful.
translationObject
Type: SystemObject
An object originally provided by the return value of the Prepare(OcrEngine, OcrDocument) method.
Remarks
While some foreign translator implementations may not need an associated engine, it is best to always provide one as some translators will require it.
See Also

Reference

IForeignTranslator Interface
Atalasoft.Ocr Namespace


IForeignTranslator.Prepare Method

IForeignTranslatorPrepare Method

Prepare a foreign translator for translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Object Prepare(
    OcrEngine engine,
    OcrDocument doc
)
Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that will perform the recognition.
doc
Type: Atalasoft.OcrOcrDocument
The document that will be populated by the engine.

Return Value

Type: Object
An object that will be used specifically by the foreign translator for document translation.
Remarks

This method is provided for two purposes. The first is to establish a translator-specific object to maintain state information about the current translator session. The second is to populate the OcrDocument object with metadata or infrastructure for metadata.

During translation, OcrEngine will construct an empty OcrDocument and pass both itself and the document to the foreign translator through Prepare. Then the engine will attempt to recognize pages, then the foreign translator will translate the OcrDocument into final form. If an error occurs, the foreign translator is always given an opportunity to clean up via the Finish(OcrEngine, OcrDocument, Boolean, Object) method.

See Also

Reference

IForeignTranslator Interface
Atalasoft.Ocr Namespace


IForeignTranslator.Translate Method

IForeignTranslatorTranslate Method

Translate an OcrDocument object into a document of the given type, writing to either a stream or a file.
Translate an OcrDocument object into a document of the given type, writing to either a stream or a file.
Overload List
 | Name | Description
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
See Also

Reference

IForeignTranslator Interface
Atalasoft.Ocr Namespace


IForeignTranslator.Translate Method (OcrEngine, OcrDocument, String, Stream, Object)

IForeignTranslatorTranslate Method (OcrEngine, OcrDocument, String, Stream, Object)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    Stream outStream,
    Object translationObject
)
Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outStream As Stream,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outStream
Type: System.IOStream
translationObject
Type: SystemObject
Exceptions
Exception | Condition
 | Throws if the MIME type is unknown.
See Also

Reference

IForeignTranslator Interface
Translate Overload
Atalasoft.Ocr Namespace


IForeignTranslator.Translate Method (OcrEngine, OcrDocument, String, String, Object)

IForeignTranslatorTranslate Method (OcrEngine, OcrDocument, String, String, Object)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    string outFileName,
    Object translationObject
)
Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outFileName As String,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outFileName
Type: SystemString
translationObject
Type: SystemObject
Exceptions
Exception | Condition
 | Throws if the MIME type is unknown.
See Also

Reference

IForeignTranslator Interface
Translate Overload
Atalasoft.Ocr Namespace


INativeTranslator Interface

INativeTranslator is an interface used to define how an OcrDocument will be translated to another format by low-level OCR engine support.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface INativeTranslator : ITranslator
Public Interface INativeTranslator
    Inherits ITranslator

The INativeTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Inherited from ITranslator.)
Public method | Supported | Get an array of mime types supported by this translator. (Inherited from ITranslator.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator. (Inherited from ITranslator.)
Public method | Translate(ImageSource, String, Stream) |
Public method | Translate(ImageSource, String, String) |
Top
Remarks

Native Translators are engine specific and must be implemented in a class deriving from OcrEngine.

See Also

Reference

Atalasoft.Ocr Namespace


INativeTranslator Methods

The INativeTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Inherited from ITranslator.)
Public method | Supported | Get an array of mime types supported by this translator. (Inherited from ITranslator.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator. (Inherited from ITranslator.)
Public method | Translate(ImageSource, String, Stream) |
Public method | Translate(ImageSource, String, String) |
Top
See Also

Reference

INativeTranslator Interface
Atalasoft.Ocr Namespace


INativeTranslator.Translate Method

INativeTranslatorTranslate Method

Translate a set of images to a document of the given mime type, writing to a Stream or to a file.
Translate a set of images to a document of the given mime type, writing to a Stream or to a file.
Overload List
 | Name | Description
Public method | Translate(ImageSource, String, Stream) |
Public method | Translate(ImageSource, String, String) |
Top
See Also

Reference

INativeTranslator Interface
Atalasoft.Ocr Namespace


INativeTranslator.Translate Method (ImageSource, String, Stream)

INativeTranslatorTranslate Method (ImageSource, String, Stream)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Translate(
    ImageSource images,
    string mimeType,
    Stream outStream
)
Sub Translate (
    images As ImageSource,
    mimeType As String,
    outStream As Stream
)

Parameters

images
Type: Atalasoft.ImagingImageSource
mimeType
Type: SystemString
outStream
Type: System.IOStream
Remarks
Engine may be null. Throws an Exception of type OcrException if the mime type is unknown.
See Also

Reference

INativeTranslator Interface
Translate Overload
Atalasoft.Ocr Namespace


INativeTranslator.Translate Method (ImageSource, String, String)

INativeTranslatorTranslate Method (ImageSource, String, String)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Translate(
    ImageSource images,
    string mimeType,
    string outFileName
)
Sub Translate (
    images As ImageSource,
    mimeType As String,
    outFileName As String
)

Parameters

images
Type: Atalasoft.ImagingImageSource
mimeType
Type: SystemString
outFileName
Type: SystemString
Remarks
Engine may be null. Throws an Exception of type OcrException if the mime type is unknown.
See Also

Reference

INativeTranslator Interface
Translate Overload
Atalasoft.Ocr Namespace


IOcrFactory Interface

Summary description for OcrFactory.
IOcrFactory provides a uniform interface for the construction of page element objects for the process of OCR.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IOcrFactory
Public Interface IOcrFactory

The IOcrFactory type exposes the following members.

Methods
 | Name | Description
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Construct a page element to represent a barcode.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Construct a page element to represent a barcode.
Public method | OcrDocument | Construct a new OcrDocument object.
Public method | OcrFormElementRegion(Rectangle) | Constructs a new OcrFormElement for this page.
Public method | OcrFormElementRegion(PolygonF) | Constructs a new OcrFormElement for this page.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) |
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) |
Public method | OcrImageRegion(Rectangle, AtalaImage) | Construct a new page element to represent an image in a document.
Public method | OcrImageRegion(AtalaImage, Boolean) | Construct a new page element to represent an image in a document.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Construct a new page element to represent an image in a document.
Public method | OcrLine | Construct a new page element to represent a line of text in a document.
Public method | OcrPage(AtalaImage) |
Public method | OcrPage(Int32, Int32, Dpi) |
Public method | OcrTableRegion(Rectangle) | Construct a page element to represent a table.
Public method | OcrTableRegion(PolygonF) | Construct a page element to represent a table.
Public method | OcrTextRegion(Rectangle) | Construct a page element to represent text.
Public method | OcrTextRegion(PolygonF) | Construct a page element to represent text.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Construct a page element to represent text.
Public method | OcrWord | Construct a new page element to represent a word of text in a document.
Top
Remarks
See BasicOcrFactory for a simple class that implements IOcrFactory.
See Also

Reference

Atalasoft.Ocr Namespace
BasicOcrFactory Class


IOcrFactory Methods

The IOcrFactory type exposes the following members.

Methods
 | Name | Description
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Construct a page element to represent a barcode.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Construct a page element to represent a barcode.
Public method | OcrDocument | Construct a new OcrDocument object.
Public method | OcrFormElementRegion(Rectangle) | Constructs a new OcrFormElement for this page.
Public method | OcrFormElementRegion(PolygonF) | Constructs a new OcrFormElement for this page.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) |
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) |
Public method | OcrImageRegion(Rectangle, AtalaImage) | Construct a new page element to represent an image in a document.
Public method | OcrImageRegion(AtalaImage, Boolean) | Construct a new page element to represent an image in a document.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Construct a new page element to represent an image in a document.
Public method | OcrLine | Construct a new page element to represent a line of text in a document.
Public method | OcrPage(AtalaImage) |
Public method | OcrPage(Int32, Int32, Dpi) |
Public method | OcrTableRegion(Rectangle) | Construct a page element to represent a table.
Public method | OcrTableRegion(PolygonF) | Construct a page element to represent a table.
Public method | OcrTextRegion(Rectangle) | Construct a page element to represent text.
Public method | OcrTextRegion(PolygonF) | Construct a page element to represent text.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Construct a page element to represent text.
Public method | OcrWord | Construct a new page element to represent a word of text in a document.
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrBarcodeRegion Method

IOcrFactoryOcrBarcodeRegion Method

Overload List
 | Name | Description
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Construct a page element to represent a barcode.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Construct a page element to represent a barcode.
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrBarcodeRegion Method (Rectangle, String, OcrBarcodeSymbologies)

IOcrFactoryOcrBarcodeRegion Method (Rectangle, String, OcrBarcodeSymbologies)

Construct a page element to represent a barcode.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrBarcodeRegion OcrBarcodeRegion(
    Rectangle bounds,
    string text,
    OcrBarcodeSymbologies barcodeType
)
Function OcrBarcodeRegion (
    bounds As Rectangle,
    text As String,
    barcodeType As OcrBarcodeSymbologies
) As OcrBarcodeRegion

Parameters

bounds
Type: System.DrawingRectangle
text
Type: SystemString
barcodeType
Type: Atalasoft.OcrOcrBarcodeSymbologies

Return Value

Type: OcrBarcodeRegion
A new object of type OcrBarcodeRegion.
See Also

Reference

IOcrFactory Interface
OcrBarcodeRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrBarcodeRegion Method (PolygonF, String, OcrBarcodeSymbologies)

IOcrFactoryOcrBarcodeRegion Method (PolygonF, String, OcrBarcodeSymbologies)

Construct a page element to represent a barcode.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrBarcodeRegion OcrBarcodeRegion(
    PolygonF bounds,
    string text,
    OcrBarcodeSymbologies barcodeType
)
Function OcrBarcodeRegion (
    bounds As PolygonF,
    text As String,
    barcodeType As OcrBarcodeSymbologies
) As OcrBarcodeRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
text
Type: SystemString
barcodeType
Type: Atalasoft.OcrOcrBarcodeSymbologies

Return Value

Type: OcrBarcodeRegion
A new object of type OcrBarcodeRegion.
See Also

Reference

IOcrFactory Interface
OcrBarcodeRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrDocument Method

IOcrFactoryOcrDocument Method

Construct a new OcrDocument object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrDocument OcrDocument()
Function OcrDocument As OcrDocument

Return Value

Type: OcrDocument
A new object of type OcrDocument.
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrFormElementRegion Method

IOcrFactoryOcrFormElementRegion Method

Overload List
 | Name | Description
Public method | OcrFormElementRegion(Rectangle) | Constructs a new OcrFormElement for this page.
Public method | OcrFormElementRegion(PolygonF) | Constructs a new OcrFormElement for this page.
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrFormElementRegion Method (Rectangle)

IOcrFactoryOcrFormElementRegion Method (Rectangle)

Constructs a new OcrFormElement for this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrFormElementRegion OcrFormElementRegion(
    Rectangle bounds
)
Function OcrFormElementRegion (
    bounds As Rectangle
) As OcrFormElementRegion

Parameters

bounds
Type: System.DrawingRectangle

Return Value

Type: OcrFormElementRegion
A new oject of type OcrFormElementRegion.
See Also

Reference

IOcrFactory Interface
OcrFormElementRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrFormElementRegion Method (PolygonF)

IOcrFactoryOcrFormElementRegion Method (PolygonF)

Constructs a new OcrFormElement for this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrFormElementRegion OcrFormElementRegion(
    PolygonF bounds
)
Function OcrFormElementRegion (
    bounds As PolygonF
) As OcrFormElementRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF

Return Value

Type: OcrFormElementRegion
A new oject of type OcrFormElementRegion.
See Also

Reference

IOcrFactory Interface
OcrFormElementRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrGlyph Method

IOcrFactoryOcrGlyph Method

Construct a new page element to represent a glyph.
Construct a new page element to represent a glyph.
Overload List
 | Name | Description
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) |
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) |
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32)

IOcrFactoryOcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrGlyph OcrGlyph(
    IOcrGlyphAccessor accessor,
    Rectangle bounds,
    int baseline
)
Function OcrGlyph (
    accessor As IOcrGlyphAccessor,
    bounds As Rectangle,
    baseline As Integer
) As OcrGlyph

Parameters

accessor
Type: Atalasoft.OcrIOcrGlyphAccessor
bounds
Type: System.DrawingRectangle
baseline
Type: SystemInt32

Return Value

Type: OcrGlyph
See Also

Reference

IOcrFactory Interface
OcrGlyph Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32, Color)

IOcrFactoryOcrGlyph Method (IOcrGlyphAccessor, Rectangle, Int32, Color)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrGlyph OcrGlyph(
    IOcrGlyphAccessor accessor,
    Rectangle bounds,
    int baseline,
    Color color
)
Function OcrGlyph (
    accessor As IOcrGlyphAccessor,
    bounds As Rectangle,
    baseline As Integer,
    color As Color
) As OcrGlyph

Parameters

accessor
Type: Atalasoft.OcrIOcrGlyphAccessor
bounds
Type: System.DrawingRectangle
baseline
Type: SystemInt32
color
Type: System.DrawingColor

Return Value

Type: OcrGlyph
See Also

Reference

IOcrFactory Interface
OcrGlyph Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrImageRegion Method

IOcrFactoryOcrImageRegion Method

Constructs an OcrImageRegion object.
Constructs an OcrImageRegion object.
Constructs an OcrImageRegion object.
Overload List
 | Name | Description
Public method | OcrImageRegion(Rectangle, AtalaImage) | Construct a new page element to represent an image in a document.
Public method | OcrImageRegion(AtalaImage, Boolean) | Construct a new page element to represent an image in a document.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Construct a new page element to represent an image in a document.
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrImageRegion Method (Rectangle, AtalaImage)

IOcrFactoryOcrImageRegion Method (Rectangle, AtalaImage)

Construct a new page element to represent an image in a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrImageRegion OcrImageRegion(
    Rectangle bounds,
    AtalaImage image
)
Function OcrImageRegion (
    bounds As Rectangle,
    image As AtalaImage
) As OcrImageRegion

Parameters

bounds
Type: System.DrawingRectangle
image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: OcrImageRegion
A new object of type OcrImageRegion.
See Also

Reference

IOcrFactory Interface
OcrImageRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrImageRegion Method (AtalaImage, Boolean)

IOcrFactoryOcrImageRegion Method (AtalaImage, Boolean)

Construct a new page element to represent an image in a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrImageRegion OcrImageRegion(
    AtalaImage image,
    bool makeCopy
)
Function OcrImageRegion (
    image As AtalaImage,
    makeCopy As Boolean
) As OcrImageRegion

Parameters

image
Type: Atalasoft.ImagingAtalaImage
makeCopy
Type: SystemBoolean

Return Value

Type: OcrImageRegion
A new object of type OcrImageRegion.
See Also

Reference

IOcrFactory Interface
OcrImageRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrImageRegion Method (PolygonF, AtalaImage)

IOcrFactoryOcrImageRegion Method (PolygonF, AtalaImage)

Construct a new page element to represent an image in a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrImageRegion OcrImageRegion(
    PolygonF bounds,
    AtalaImage image
)
Function OcrImageRegion (
    bounds As PolygonF,
    image As AtalaImage
) As OcrImageRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: OcrImageRegion
A new object of type OcrImageRegion.
See Also

Reference

IOcrFactory Interface
OcrImageRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrLine Method

IOcrFactoryOcrLine Method

Construct a new page element to represent a line of text in a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrLine OcrLine(
    IOcrLineAccessor accessor,
    Rectangle bounds,
    int baseline
)
Function OcrLine (
    accessor As IOcrLineAccessor,
    bounds As Rectangle,
    baseline As Integer
) As OcrLine

Parameters

accessor
Type: Atalasoft.OcrIOcrLineAccessor
The accessor that will be used to provide key elements of this object.
bounds
Type: System.DrawingRectangle
The bounding rectangle of this page element in pixels relative to the image.
baseline
Type: SystemInt32
The baseline for the text in this page element, in pixels relative to the image.

Return Value

Type: OcrLine
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrPage Method

IOcrFactoryOcrPage Method

Overload List
 | Name | Description
Public method | OcrPage(AtalaImage) |
Public method | OcrPage(Int32, Int32, Dpi) |
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrPage Method (AtalaImage)

IOcrFactoryOcrPage Method (AtalaImage)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrPage OcrPage(
    AtalaImage image
)
Function OcrPage (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage

Return Value

Type: OcrPage
A new object of type OcrPage.
See Also

Reference

IOcrFactory Interface
OcrPage Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrPage Method (Int32, Int32, Dpi)

IOcrFactoryOcrPage Method (Int32, Int32, Dpi)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrPage OcrPage(
    int width,
    int height,
    Dpi resolution
)
Function OcrPage (
    width As Integer,
    height As Integer,
    resolution As Dpi
) As OcrPage

Parameters

width
Type: SystemInt32
height
Type: SystemInt32
resolution
Type: Atalasoft.ImagingDpi

Return Value

Type: OcrPage
A new object of type OcrPage.
See Also

Reference

IOcrFactory Interface
OcrPage Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrTableRegion Method

IOcrFactoryOcrTableRegion Method

Overload List
 | Name | Description
Public method | OcrTableRegion(Rectangle) | Construct a page element to represent a table.
Public method | OcrTableRegion(PolygonF) | Construct a page element to represent a table.
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrTableRegion Method (Rectangle)

IOcrFactoryOcrTableRegion Method (Rectangle)

Construct a page element to represent a table.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrTableRegion OcrTableRegion(
    Rectangle bounds
)
Function OcrTableRegion (
    bounds As Rectangle
) As OcrTableRegion

Parameters

bounds
Type: System.DrawingRectangle

Return Value

Type: OcrTableRegion
A new object of type OcrTableRegion.
See Also

Reference

IOcrFactory Interface
OcrTableRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrTableRegion Method (PolygonF)

IOcrFactoryOcrTableRegion Method (PolygonF)

Construct a page element to represent a table.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrTableRegion OcrTableRegion(
    PolygonF bounds
)
Function OcrTableRegion (
    bounds As PolygonF
) As OcrTableRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF

Return Value

Type: OcrTableRegion
A new object of type OcrTableRegion.
See Also

Reference

IOcrFactory Interface
OcrTableRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrTextRegion Method

IOcrFactoryOcrTextRegion Method

Constructs a new OcrTextRegion object.
Constructs a new OcrTextRegion object.
Constructs a new OcrTextRegion object.
Overload List
 | Name | Description
Public method | OcrTextRegion(Rectangle) | Construct a page element to represent text.
Public method | OcrTextRegion(PolygonF) | Construct a page element to represent text.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Construct a page element to represent text.
Top
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrFactory.OcrTextRegion Method (Rectangle)

IOcrFactoryOcrTextRegion Method (Rectangle)

Construct a page element to represent text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrTextRegion OcrTextRegion(
    Rectangle bounds
)
Function OcrTextRegion (
    bounds As Rectangle
) As OcrTextRegion

Parameters

bounds
Type: System.DrawingRectangle

Return Value

Type: OcrTextRegion
A new object of type OcrTextRegion.
See Also

Reference

IOcrFactory Interface
OcrTextRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrTextRegion Method (PolygonF)

IOcrFactoryOcrTextRegion Method (PolygonF)

Construct a page element to represent text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrTextRegion OcrTextRegion(
    PolygonF bounds
)
Function OcrTextRegion (
    bounds As PolygonF
) As OcrTextRegion

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF

Return Value

Type: OcrTextRegion
A new object of type OcrTextRegion.
See Also

Reference

IOcrFactory Interface
OcrTextRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrTextRegion Method (Rectangle, OcrTextRotation)

IOcrFactoryOcrTextRegion Method (Rectangle, OcrTextRotation)

Construct a page element to represent text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrTextRegion OcrTextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Function OcrTextRegion (
    bounds As Rectangle,
    rotation As OcrTextRotation
) As OcrTextRegion

Parameters

bounds
Type: System.DrawingRectangle
rotation
Type: Atalasoft.OcrOcrTextRotation

Return Value

Type: OcrTextRegion
A new object of type OcrTextRegion.
See Also

Reference

IOcrFactory Interface
OcrTextRegion Overload
Atalasoft.Ocr Namespace


IOcrFactory.OcrWord Method

IOcrFactoryOcrWord Method

Construct a new page element to represent a word of text in a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrWord OcrWord(
    IOcrWordAccessor accessor,
    Rectangle bounds,
    int baseline
)
Function OcrWord (
    accessor As IOcrWordAccessor,
    bounds As Rectangle,
    baseline As Integer
) As OcrWord

Parameters

accessor
Type: Atalasoft.OcrIOcrWordAccessor
The accessor that will be used to provide key elements of this object.
bounds
Type: System.DrawingRectangle
The bounding rectangle of this page element in pixels relative to the image.
baseline
Type: SystemInt32
The baseline for the text in this page element, in pixels relative to the image.

Return Value

Type: OcrWord
A new object of type OcrWord(IOcrWordAccessor, Rectangle, Int32).
See Also

Reference

IOcrFactory Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor Interface

IOcrGlyphAccessor defines an interface for accessing data elements for a glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IOcrGlyphAccessor
Public Interface IOcrGlyphAccessor

The IOcrGlyphAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the glyph in pixels relative to the source image.
Public property | Char | The unicode representation of this glyph.
Public property | Color | Returns the color of this glyph.
Public property | Confidence | This property represents the confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Public property | Glyph | This property is used for setting the OcrGlyph that this accessor is attached to.
Public property | IsSingleton | This property represents a boolean that determines if this glyph is a single character or not.
Public property | Text | This property is a string that represents the text of this glyph.
Top
Methods
 | Name | Description
Public method | GetFont | Return the font used for this glyph using the given resolution, font mapper and font builder.
Public method | GetFontFamily | Get the FontFamily for this glyph.
Public method | GetFontName | Returns the name of the font used for this glyph.
Public method | GetFontSize | Get the font size for this glyph.
Public method | GetFontStyle | Get the FontStyle for this glyph.
Top
Remarks
This interface is usually provided by a low-level engine implementation and is typically not defined in client code. If a client needs to construct an OcrGlyph through the IOcrFactory interface, it may use the BasicOcrGlyphAccessor class for a version that is not tied to any given engine.
See Also

Reference

Atalasoft.Ocr Namespace


IOcrGlyphAccessor Properties

The IOcrGlyphAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the glyph in pixels relative to the source image.
Public property | Char | The unicode representation of this glyph.
Public property | Color | Returns the color of this glyph.
Public property | Confidence | This property represents the confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Public property | Glyph | This property is used for setting the OcrGlyph that this accessor is attached to.
Public property | IsSingleton | This property represents a boolean that determines if this glyph is a single character or not.
Public property | Text | This property is a string that represents the text of this glyph.
Top
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Baseline Property

IOcrGlyphAccessorBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Baseline { get; set; }
Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Bounds Property

IOcrGlyphAccessorBounds Property

This property represents the bounding box of the glyph in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Rectangle Bounds { get; set; }
Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this glyph.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Char Property

IOcrGlyphAccessorChar Property

The unicode representation of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
char Char { get; }
ReadOnly Property Char As Char
    Get

Property Value

Type: Char
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Color Property

IOcrGlyphAccessorColor Property

Returns the color of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Color Color { get; set; }
Property Color As Color
    Get
    Set

Property Value

Type: Color
An object of type Color representing the color of this glyph.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Confidence Property

IOcrGlyphAccessorConfidence Property

This property represents the confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Confidence { get; }
ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Glyph Property

IOcrGlyphAccessorGlyph Property

This property is used for setting the OcrGlyph that this accessor is attached to.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrGlyph Glyph { get; set; }
Property Glyph As OcrGlyph
    Get
    Set

Property Value

Type: OcrGlyph
Remarks
This property is used when an OcrGlyph is constructed. Typically, an OcrEngine will construct an object that meets IOcrGlyphAccessor first, then construct the OcrGlyph via an IOcrFactory. Finally, it will set the Glyph property to the constructed OcrGlyph.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.IsSingleton Property

IOcrGlyphAccessorIsSingleton Property

This property represents a boolean that determines if this glyph is a single character or not.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsSingleton { get; }
ReadOnly Property IsSingleton As Boolean
    Get

Property Value

Type: Boolean
A boolean that determines if this glyph is a single character or not.
Remarks
Glyphs in typography may represent more than one individual character. Typically, this done via a ligature wherein two or more characters are joined together. This property makes it possible to determine if that is the case in order to better reconstruct an image or to facilitate searching through the text.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.Text Property

IOcrGlyphAccessorText Property

This property is a string that represents the text of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor Methods

The IOcrGlyphAccessor type exposes the following members.

Methods
 | Name | Description
Public method | GetFont | Return the font used for this glyph using the given resolution, font mapper and font builder.
Public method | GetFontFamily | Get the FontFamily for this glyph.
Public method | GetFontName | Returns the name of the font used for this glyph.
Public method | GetFontSize | Get the font size for this glyph.
Public method | GetFontStyle | Get the FontStyle for this glyph.
Top
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.GetFont Method

IOcrGlyphAccessorGetFont Method

Return the font used for this glyph using the given resolution, font mapper and font builder.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Font GetFont(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder
)
Function GetFont (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this glyph was taken.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.

Return Value

Type: Font
An object of type Font that represents the font of this glyph.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.GetFontFamily Method

IOcrGlyphAccessorGetFontFamily Method

Get the FontFamily for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontFamily GetFontFamily(
    IFontMapper mapper
)
Function GetFontFamily (
    mapper As IFontMapper
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.

Return Value

Type: FontFamily
An object of type FontFamily.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.GetFontName Method

IOcrGlyphAccessorGetFontName Method

Returns the name of the font used for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string GetFontName(
    IFontMapper mapper
)
Function GetFontName (
    mapper As IFontMapper
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
An object of type IFontMapper that will be used to map the font.

Return Value

Type: String
A string representing the name of the font used for this glyph.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.GetFontSize Method

IOcrGlyphAccessorGetFontSize Method

Get the font size for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float GetFontSize(
    Dpi imageResolution
)
Function GetFontSize (
    imageResolution As Dpi
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this glyph was taken.

Return Value

Type: Single
A floating point number that represents the size of this font in points.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrGlyphAccessor.GetFontStyle Method

IOcrGlyphAccessorGetFontStyle Method

Get the FontStyle for this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontStyle GetFontStyle(
    IFontMapper mapper
)
Function GetFontStyle (
    mapper As IFontMapper
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of this glyph.
See Also

Reference

IOcrGlyphAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor Interface

IOcrLineAccessor defines an interface for accessing data elements for a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IOcrLineAccessor
Public Interface IOcrLineAccessor

The IOcrLineAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the line in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire line.
Public property | Line | This property is used for setting the OcrLine that this accessor is attached to.
Public property | Text | Returns the text of the line as a string.
Top
Methods
 | Name | Description
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line of text.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a line of text.
Public method | GetFontColorAt | Returns the color of the glyph at the position in a line of text.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a line of text.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the line.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a line of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this line of text.
Top
See Also

Reference

Atalasoft.Ocr Namespace


IOcrLineAccessor Properties

The IOcrLineAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the line in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire line.
Public property | Line | This property is used for setting the OcrLine that this accessor is attached to.
Public property | Text | Returns the text of the line as a string.
Top
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.Baseline Property

IOcrLineAccessorBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Baseline { get; set; }
Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.Bounds Property

IOcrLineAccessorBounds Property

This property represents the bounding box of the line in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Rectangle Bounds { get; set; }
Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this line.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.Confidence Property

IOcrLineAccessorConfidence Property

This property represents the confidence of recognition of the entire line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Confidence { get; }
ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
This value is calculated as the average confidence of all the glyphs in the line.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.Line Property

IOcrLineAccessorLine Property

This property is used for setting the OcrLine that this accessor is attached to.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrLine Line { get; set; }
Property Line As OcrLine
    Get
    Set

Property Value

Type: OcrLine
Remarks
This property is used when an OcrLine, is constructed. Typically, an OcrEngine will construct an object that meets IOcrLineAccessor first, then construct the OcrLine via an IOcrFactory. Finally, it will set the Line property to the constructed OcrLine.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.Text Property

IOcrLineAccessorText Property

Returns the text of the line as a string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
A string representing the text of the line.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor Methods

The IOcrLineAccessor type exposes the following members.

Methods
 | Name | Description
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line of text.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a line of text.
Public method | GetFontColorAt | Returns the color of the glyph at the position in a line of text.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a line of text.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the line.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a line of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this line of text.
Top
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetConfidenceAt Method

IOcrLineAccessorGetConfidenceAt Method

Get the confidence of recognition at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double GetConfidenceAt(
    int i
)
Function GetConfidenceAt (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Double
A double representing the confidence of recognition of the specified glyph ranging from 0.0 (no confidence) to 1.0 (complete confidence).
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetFontAt Method

IOcrLineAccessorGetFontAt Method

Get the Font of a glyph at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Font GetFontAt(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder,
    int i
)
Function GetFontAt (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder,
    i As Integer
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this line was taken.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Font
An object of type Font that represents the font of the glyph.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetFontColorAt Method

IOcrLineAccessorGetFontColorAt Method

Returns the color of the glyph at the position in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Color GetFontColorAt(
    int i
)
Function GetFontColorAt (
    i As Integer
) As Color

Parameters

i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Color
The color of the glyph at the position in a line of text.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetFontFamilyAt Method

IOcrLineAccessorGetFontFamilyAt Method

Get the FontFamily at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontFamily GetFontFamilyAt(
    IFontMapper mapper,
    int i
)
Function GetFontFamilyAt (
    mapper As IFontMapper,
    i As Integer
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: FontFamily
An object of type FontFamily that represents the font family of the glyph.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetFontNameAt Method

IOcrLineAccessorGetFontNameAt Method

Returns the name of the font used for the glyph at the specified position in the line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string GetFontNameAt(
    IFontMapper mapper,
    int i
)
Function GetFontNameAt (
    mapper As IFontMapper,
    i As Integer
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: String
A string representing the name of the font used for the glyph at the specified position in the line.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetFontSizeAt Method

IOcrLineAccessorGetFontSizeAt Method

Get the font size of a glyph at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float GetFontSizeAt(
    Dpi imageResolution,
    int i
)
Function GetFontSizeAt (
    imageResolution As Dpi,
    i As Integer
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this line was taken.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Single
A floating point number that represents the size of the glyph in points.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.GetFontStyleAt Method

IOcrLineAccessorGetFontStyleAt Method

This property represents the FontStyle of a glyph at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontStyle GetFontStyleAt(
    IFontMapper mapper,
    int i
)
Function GetFontStyleAt (
    mapper As IFontMapper,
    i As Integer
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of the glyph.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrLineAccessor.StyleIsUniform Method

IOcrLineAccessorStyleIsUniform Method

Check to see if the font and style are uniform across this line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool StyleIsUniform(
    IFontMapper mapper,
    IFontBuilder builder
)
Function StyleIsUniform (
    mapper As IFontMapper,
    builder As IFontBuilder
) As Boolean

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.

Return Value

Type: Boolean
True if the font family, style and size are the same throughout the line of text.
See Also

Reference

IOcrLineAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor Interface

IOcrWordAccessor defines an interface for accessing data elements for a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IOcrWordAccessor
Public Interface IOcrWordAccessor

The IOcrWordAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the word in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire word.
Public property | Text | Returns the text of the word as a string.
Public property | Word | This property is used for setting the OcrWord that this accessor is attached to.
Top
Methods
 | Name | Description
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a line of text.
Public method | GetFontColorAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a line of text.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a word of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this word of text.
Top
See Also

Reference

Atalasoft.Ocr Namespace


IOcrWordAccessor Properties

The IOcrWordAccessor type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the word in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire word.
Public property | Text | Returns the text of the word as a string.
Public property | Word | This property is used for setting the OcrWord that this accessor is attached to.
Top
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.Baseline Property

IOcrWordAccessorBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Baseline { get; set; }
Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.Bounds Property

IOcrWordAccessorBounds Property

This property represents the bounding box of the word in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Rectangle Bounds { get; set; }
Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this word.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.Confidence Property

IOcrWordAccessorConfidence Property

This property represents the confidence of recognition of the entire word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Confidence { get; }
ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
This value is calculated as the average confidence of all the glyphs in the word.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.Text Property

IOcrWordAccessorText Property

Returns the text of the word as a string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
A string representing the text of the word.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.Word Property

IOcrWordAccessorWord Property

This property is used for setting the OcrWord that this accessor is attached to.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrWord Word { get; set; }
Property Word As OcrWord
    Get
    Set

Property Value

Type: OcrWord
Remarks
This property is used when an OcrWord is constructed. Typically, an OcrEngine will construct an object that meets IOcrWordAccessor first, then construct the OcrWord via an IOcrFactory. Finally, it will set the Line property to the constructed OcrWord.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor Methods

The IOcrWordAccessor type exposes the following members.

Methods
 | Name | Description
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line.
Public method | GetFontAt | Get the Font of a glyph at a particular point in a line of text.
Public method | GetFontColorAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a line of text.
Public method | GetFontNameAt | Returns the name of the font used for the glyph at the specified position in the word.
Public method | GetFontSizeAt | Get the font size of a glyph at a particular point in a word of text.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this word of text.
Top
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetConfidenceAt Method

IOcrWordAccessorGetConfidenceAt Method

Get the confidence of recognition at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double GetConfidenceAt(
    int i
)
Function GetConfidenceAt (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Double
A double representing the confidence of recognition of the specified glyph ranging from 0.0 (no confidence) to 1.0 (complete confidence).
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetFontAt Method

IOcrWordAccessorGetFontAt Method

Get the Font of a glyph at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Font GetFontAt(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder,
    int i
)
Function GetFontAt (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder,
    i As Integer
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this word was taken.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.
i
Type: SystemInt32
The index of the glyph within the word.

Return Value

Type: Font
An object of type Font that represents the font of the glyph.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetFontColorAt Method

IOcrWordAccessorGetFontColorAt Method

Returns the name of the font used for the glyph at the specified position in the word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Color GetFontColorAt(
    int i
)
Function GetFontColorAt (
    i As Integer
) As Color

Parameters

i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Color
The color of the glyph at the position in a word of text.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetFontFamilyAt Method

IOcrWordAccessorGetFontFamilyAt Method

Get the FontFamily at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontFamily GetFontFamilyAt(
    IFontMapper mapper,
    int i
)
Function GetFontFamilyAt (
    mapper As IFontMapper,
    i As Integer
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within the word.

Return Value

Type: FontFamily
An object of type FontFamily that represents the font family of the glyph.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetFontNameAt Method

IOcrWordAccessorGetFontNameAt Method

Returns the name of the font used for the glyph at the specified position in the word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string GetFontNameAt(
    IFontMapper mapper,
    int i
)
Function GetFontNameAt (
    mapper As IFontMapper,
    i As Integer
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within the word.

Return Value

Type: String
A string representing the name of the font used for the glyph at the specified position in the word.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetFontSizeAt Method

IOcrWordAccessorGetFontSizeAt Method

Get the font size of a glyph at a particular point in a word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
float GetFontSizeAt(
    Dpi imageResolution,
    int i
)
Function GetFontSizeAt (
    imageResolution As Dpi,
    i As Integer
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this word was taken.
i
Type: SystemInt32
The index of the glyph within the word.

Return Value

Type: Single
A floating point number that represents the size of the glyph in points.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.GetFontStyleAt Method

IOcrWordAccessorGetFontStyleAt Method

This property represents the FontStyle of a glyph at a particular point in a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
FontStyle GetFontStyleAt(
    IFontMapper mapper,
    int i
)
Function GetFontStyleAt (
    mapper As IFontMapper,
    i As Integer
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within the word.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of the glyph.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IOcrWordAccessor.StyleIsUniform Method

IOcrWordAccessorStyleIsUniform Method

Check to see if the font and style are uniform across this word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool StyleIsUniform(
    IFontMapper mapper,
    IFontBuilder builder
)
Function StyleIsUniform (
    mapper As IFontMapper,
    builder As IFontBuilder
) As Boolean

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.

Return Value

Type: Boolean
True if the font family, style and size are the same throughout the line of text.
See Also

Reference

IOcrWordAccessor Interface
Atalasoft.Ocr Namespace


IPerPageTranslator Interface

IPerPageTranslator is an interface that allows IForeignTranslator objects to translate a document while it is being recognized on a page-by-page basis. In many cases this can result in a smaller memory load by allowing the translator to release per page resources immediately.

In general, client code need not worry about this interface as it is called by the OcrEngine object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPerPageTranslator
Public Interface IPerPageTranslator

The IPerPageTranslator type exposes the following members.

Properties
 | Name | Description
Public property | UseIForeignTranslatorInterface | Indicates whether or not the called OcrEngine object should use the IForeignTranslator interface of the IPerPageTranslator interface for document translation
Top
Methods
 | Name | Description
Public method | Prepare(OcrEngine, OcrDocument, String, Stream) |
Public method | Prepare(OcrEngine, OcrDocument, String, String) |
Public method | TranslatePage | Translates a single page into the translator's output format
Top
See Also

Reference

Atalasoft.Ocr Namespace


IPerPageTranslator Properties

The IPerPageTranslator type exposes the following members.

Properties
 | Name | Description
Public property | UseIForeignTranslatorInterface | Indicates whether or not the called OcrEngine object should use the IForeignTranslator interface of the IPerPageTranslator interface for document translation
Top
See Also

Reference

IPerPageTranslator Interface
Atalasoft.Ocr Namespace


IPerPageTranslator.UseIForeignTranslatorInterface Property

IPerPageTranslatorUseIForeignTranslatorInterface Property

Indicates whether or not the called OcrEngine object should use the IForeignTranslator interface of the IPerPageTranslator interface for document translation

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool UseIForeignTranslatorInterface { get; set; }
Property UseIForeignTranslatorInterface As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IPerPageTranslator Interface
Atalasoft.Ocr Namespace


IPerPageTranslator Methods

The IPerPageTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Prepare(OcrEngine, OcrDocument, String, Stream) |
Public method | Prepare(OcrEngine, OcrDocument, String, String) |
Public method | TranslatePage | Translates a single page into the translator's output format
Top
See Also

Reference

IPerPageTranslator Interface
Atalasoft.Ocr Namespace


IPerPageTranslator.Prepare Method

IPerPageTranslatorPrepare Method

Allows a translator to prepare itself for subsequent translation
Allows a translator to prepare itself for subsequent translation
Overload List
 | Name | Description
Public method | Prepare(OcrEngine, OcrDocument, String, Stream) |
Public method | Prepare(OcrEngine, OcrDocument, String, String) |
Top
See Also

Reference

IPerPageTranslator Interface
Atalasoft.Ocr Namespace


IPerPageTranslator.Prepare Method (OcrEngine, OcrDocument, String, Stream)

IPerPageTranslatorPrepare Method (OcrEngine, OcrDocument, String, Stream)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Object Prepare(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    Stream outStream
)
Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outStream As Stream
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outStream
Type: System.IOStream

Return Value

Type: Object
See Also

Reference

IPerPageTranslator Interface
Prepare Overload
Atalasoft.Ocr Namespace


IPerPageTranslator.Prepare Method (OcrEngine, OcrDocument, String, String)

IPerPageTranslatorPrepare Method (OcrEngine, OcrDocument, String, String)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Object Prepare(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    string outFileName
)
Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outFileName As String
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outFileName
Type: SystemString

Return Value

Type: Object
See Also

Reference

IPerPageTranslator Interface
Prepare Overload
Atalasoft.Ocr Namespace


IPerPageTranslator.TranslatePage Method

IPerPageTranslatorTranslatePage Method

Translates a single page into the translator's output format

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void TranslatePage(
    OcrEngine engine,
    OcrDocument doc,
    OcrPage page,
    Object translationObject,
    bool totalPagesKnown,
    int pageIndex,
    int totalPages
)
Sub TranslatePage (
    engine As OcrEngine,
    doc As OcrDocument,
    page As OcrPage,
    translationObject As Object,
    totalPagesKnown As Boolean,
    pageIndex As Integer,
    totalPages As Integer
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The OcrEngine requesting translation
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument which receives OcrPages during translation
page
Type: Atalasoft.OcrOcrPage
The last OcrPage that has been translated
translationObject
Type: SystemObject
The object returned by IPerPageTranslator.Prepare
totalPagesKnown
Type: SystemBoolean
A boolean indicating whether or not the total page count is known
pageIndex
Type: SystemInt32
The zero-based index of the current page
totalPages
Type: SystemInt32
The total pages (this is only valid if totalPagesKnown is true)
See Also

Reference

IPerPageTranslator Interface
Atalasoft.Ocr Namespace


IrisLoader Class

This class is used to load all resources for the Iris OCR Engine.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrIrisLoader

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IrisLoader
Public Class IrisLoader

The IrisLoader type exposes the following members.

Constructors
 | Name | Description
Public method | IrisLoader | Initializes a new instance of the IrisLoader class.
Top
Properties
 | Name | Description
Public property | DllHandle | Gets the handle of the Iris DLL from LoadLibrary()
Public property | FailureMessage | Gets the failure message when the resouces cannot be loaded.
Public property | FullPath | Gets the full path of the resources.
Public property | Loaded | Gets a value indicating whether resources are successfully loaded.
Public property | Location | Gets the folder location of the resources.
Public property | ResourceLocation | Gets the folder location of the Iris OCR Engine resources.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetProbableResourcePaths | Gets collection of paths where Iris OCR Engine resources could be found.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


IrisLoader Constructor

Initializes a new instance of the IrisLoader class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IrisLoader()
Public Sub New
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader Properties

The IrisLoader type exposes the following members.

Properties
 | Name | Description
Public property | DllHandle | Gets the handle of the Iris DLL from LoadLibrary()
Public property | FailureMessage | Gets the failure message when the resouces cannot be loaded.
Public property | FullPath | Gets the full path of the resources.
Public property | Loaded | Gets a value indicating whether resources are successfully loaded.
Public property | Location | Gets the folder location of the resources.
Public property | ResourceLocation | Gets the folder location of the Iris OCR Engine resources.
Top
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.DllHandle Property

IrisLoaderDllHandle Property

Gets the handle of the Iris DLL from LoadLibrary()

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr DllHandle { get; }
Public ReadOnly Property DllHandle As IntPtr
    Get

Property Value

Type: IntPtr
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.FailureMessage Property

IrisLoaderFailureMessage Property

Gets the failure message when the resouces cannot be loaded.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FailureMessage { get; }
Public ReadOnly Property FailureMessage As String
    Get

Property Value

Type: String
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.FullPath Property

IrisLoaderFullPath Property

Gets the full path of the resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get

Property Value

Type: String
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.Loaded Property

IrisLoaderLoaded Property

Gets a value indicating whether resources are successfully loaded.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Loaded { get; }
Public ReadOnly Property Loaded As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.Location Property

IrisLoaderLocation Property

Gets the folder location of the resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get

Property Value

Type: String
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.ResourceLocation Property

IrisLoaderResourceLocation Property

Gets the folder location of the Iris OCR Engine resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ResourceLocation { get; }
Public ReadOnly Property ResourceLocation As String
    Get

Property Value

Type: String
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader Methods

The IrisLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetProbableResourcePaths | Gets collection of paths where Iris OCR Engine resources could be found.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


IrisLoader.GetProbableResourcePaths Method

IrisLoaderGetProbableResourcePaths Method

Gets collection of paths where Iris OCR Engine resources could be found.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static StringCollection GetProbableResourcePaths()
Public Shared Function GetProbableResourcePaths As StringCollection

Return Value

Type: StringCollection
See Also

Reference

IrisLoader Class
Atalasoft.Ocr Namespace


ITranslator Interface

ITranslator defines an interface which allows the translation of documents from images to text-based formats.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface ITranslator
Public Interface ITranslator

The ITranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | Supported | Get an array of mime types supported by this translator.
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Top
Remarks
Client code will almost always want to implement INativeTranslator or IForeignTranslator rather than ITranslator.
See Also

Reference

Atalasoft.Ocr Namespace
IForeignTranslator Interface
INativeTranslator Interface


ITranslator Methods

The ITranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | Supported | Get an array of mime types supported by this translator.
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Top
See Also

Reference

ITranslator Interface
Atalasoft.Ocr Namespace


ITranslator.CanStream Method

ITranslatorCanStream Method

Checks to see if this translator is capable of streaming.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool CanStream()
Function CanStream As Boolean

Return Value

Type: Boolean
True if the translator can stream, false otherwise.
See Also

Reference

ITranslator Interface
Atalasoft.Ocr Namespace


ITranslator.Supported Method

ITranslatorSupported Method

Get an array of mime types supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string[] Supported()
Function Supported As String()

Return Value

Type: String
An array of strings containing mime types supported by this translator.
See Also

Reference

ITranslator Interface
Atalasoft.Ocr Namespace


ITranslator.Supports Method

ITranslatorSupports Method

Checks to see if a specific mime type is supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool Supports(
    string mimeType
)
Function Supports (
    mimeType As String
) As Boolean

Parameters

mimeType
Type: SystemString
A string representing a mime type to be checked.

Return Value

Type: Boolean
True if the mime type is supported, false otherwise.
See Also

Reference

ITranslator Interface
Atalasoft.Ocr Namespace


OcrBarcodeRegion Class

OcrBarcodeRegion is page element which describes a region that contains a barcode.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrBarcodeRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrBarcodeRegion : OcrRegion
Public Class OcrBarcodeRegion
    Inherits OcrRegion

The OcrBarcodeRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Initializes a new instance of the OcrBarcodeRegion class.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Initializes a new instance of the OcrBarcodeRegion class.
Top
Properties
 | Name | Description
Public property | BarcodeType | Gets the type of barcode that is contained in this region.
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Text | Gets the text of the recognized barcode.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This object is in prototype stage and is likely to change.
See Also

Reference

Atalasoft.Ocr Namespace


OcrBarcodeRegion Constructor

Overload List
 | Name | Description
Public method | OcrBarcodeRegion(Rectangle, String, OcrBarcodeSymbologies) | Initializes a new instance of the OcrBarcodeRegion class.
Public method | OcrBarcodeRegion(PolygonF, String, OcrBarcodeSymbologies) | Initializes a new instance of the OcrBarcodeRegion class.
Top
See Also

Reference

OcrBarcodeRegion Class
Atalasoft.Ocr Namespace


OcrBarcodeRegion Constructor (Rectangle, String, OcrBarcodeSymbologies)

Initializes a new instance of the OcrBarcodeRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrBarcodeRegion(
    Rectangle bounds,
    string text,
    OcrBarcodeSymbologies barcodeType
)
Public Sub New (
    bounds As Rectangle,
    text As String,
    barcodeType As OcrBarcodeSymbologies
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.
text
Type: SystemString
Text of the barcode within region.
barcodeType
Type: Atalasoft.OcrOcrBarcodeSymbologies
Type of the barcode within region.

Return Value

Type:
A new OcrBarcodeRegion object
See Also

Reference

OcrBarcodeRegion Class
OcrBarcodeRegion Overload
Atalasoft.Ocr Namespace


OcrBarcodeRegion Constructor (PolygonF, String, OcrBarcodeSymbologies)

Initializes a new instance of the OcrBarcodeRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrBarcodeRegion(
    PolygonF bounds,
    string text,
    OcrBarcodeSymbologies barcodeType
)
Public Sub New (
    bounds As PolygonF,
    text As String,
    barcodeType As OcrBarcodeSymbologies
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.
text
Type: SystemString
Text of the barcode within region.
barcodeType
Type: Atalasoft.OcrOcrBarcodeSymbologies
Type of the barcode within region.

Return Value

Type:
A new OcrBarcodeRegion object
See Also

Reference

OcrBarcodeRegion Class
OcrBarcodeRegion Overload
Atalasoft.Ocr Namespace


OcrBarcodeRegion Properties

The OcrBarcodeRegion type exposes the following members.

Properties
 | Name | Description
Public property | BarcodeType | Gets the type of barcode that is contained in this region.
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Text | Gets the text of the recognized barcode.
Top
See Also

Reference

OcrBarcodeRegion Class
Atalasoft.Ocr Namespace


OcrBarcodeRegion.BarcodeType Property

OcrBarcodeRegionBarcodeType Property

Gets the type of barcode that is contained in this region.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrBarcodeSymbologies BarcodeType { get; set; }
Public Property BarcodeType As OcrBarcodeSymbologies
    Get
    Set

Property Value

Type: OcrBarcodeSymbologies
See Also

Reference

OcrBarcodeRegion Class
Atalasoft.Ocr Namespace


OcrBarcodeRegion.Text Property

OcrBarcodeRegionText Property

Gets the text of the recognized barcode.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
A string representing the barcode.
See Also

Reference

OcrBarcodeRegion Class
Atalasoft.Ocr Namespace


OcrBarcodeRegion Methods

The OcrBarcodeRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrBarcodeRegion Class
Atalasoft.Ocr Namespace


OcrBarcodeSymbologies Enumeration

Lists standard barcode symbologies that can be used in various OCR engines that support barcode recognition.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum OcrBarcodeSymbologies
<FlagsAttribute>
Public Enumeration OcrBarcodeSymbologies
Members
Member name | Description
None | No barcode
Codabar | Codabar
Code11 | Code 11
Code128 | Code 128. For more information see http://en.wikipedia.org/wiki/Code_128
Code32

also known as: Base 32, Pharma 32/39, and Italian Pharmacode. Note, not the same as Pharmacode-Laetus.

Code 32 barcodes are similar to Code 39 barcodes with a different encodation.

If both Code39 and Code32 are enabled, some symbols (barcodes) can be returned twice, once for each symbology.

Code39 | Code 39
Code93 | Code 93
Datamatrix | Data Matrix
Ean13 | EAN13
Ean8 | EAN8
I2of5 | Interleaved 2 of 5
Patch | Patch
Pdf417 | PDF417
Plus2 | 2-digit supplementals associated with EAN and UPC symbology barcodes.
Plus5 | 5-digit supplementals associated with EAN and UPC symbology barcodes.
Qr | QR Code
Rss14 RSS-14

RSS-14 alternate formats are read as well as the regular format. The alternate formats are truncated, stacked, and stacked omnidirectional. It is recommended that the alignment of truncated and stacked symbols be close to horizontal or vertical.

RssLimited RSS Limited

It is recommended that symbols whose height is near to the specified minimum be aligned close to horizontal or vertical.

Telepen | Telepen
Upca UPC A

UPC A barcodes are identical to EAN13 barcodes with the same encodation except for an additional leading zero on the latter.

Upce UPC E

UPC E encodations are a compressed form of UPC A.

Interleaved2of5 | Interleaved 2 of 5
Iata2of5 | IATA 2 of 5
Matrix25 | Matric 25
Ucc128 | UCC 128
Postnet | Postnet
Industrial2of5 | Iris specific: Industrial 2 of 5
Ean5 | Iris specific: EAN5
Ean2 | Iris specific: EAN2
Msi | Iris specific: MSI
MsiPh | Iris specific: MSI Ph
D2of5 | Iris specific: Discrete 2 of 5
Code39Extended | Iris specific: Code 39 Extended
Code39Hibc | Iris specific: Code 39 HIBC
Postnet32 | Iris specific: Postnet32
Postnet52 | Iris specific: Postnet52
Postnet62 | Iris specific: Postnet62
UpceExtended | Iris specific: UPC E Extended
DataLogic2of5 | Iris specific: DataLogic 2 of 5
Code39OutOfSpec | Iris specific: Code 39 Out of Spec
Code128OutOfSpec | Iris specific: Code 128 Out of Spec
CodabarOutOfSpec | Iris specific: Codabar Out of Spec
Reverse2of5 | Iris specific: Reverse 2 of 5.
AutoDetect | Iris specific: auto detect barcode symbology.
Aztec | Aztec Code
IntelligentMail | Intelligent Mail
MaxiCode | MaxiCode
See Also

Reference

Atalasoft.Ocr Namespace


OcrContainerRegion Class

Abstract skeletal implementation that encompasses base functionality for those OcrRegion types that can contain other OcrRegions within themselves
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrContainerRegion
Atalasoft.OcrOcrFormElementGroupRegion
Atalasoft.OcrOcrTableRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class OcrContainerRegion : OcrRegion
Public MustInherit Class OcrContainerRegion
    Inherits OcrRegion

The OcrContainerRegion type exposes the following members.

Constructors
 | Name | Description
Protected method | OcrContainerRegion(Rectangle) | A constructor for the abstract OcrContainerRegion class.
Protected method | OcrContainerRegion(PolygonF) | A constructor for the abstract OcrContainerRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Protected property | Elements | Gets the contained elements
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | ElementsElementChanged | Reroutes listener events to specific methods in this class, based on the OcrPageElementAction of the OcrPageElementEventArgs of the event
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates bound encompassing all contained regions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrContainerRegion Constructor

Overload List
 | Name | Description
Protected method | OcrContainerRegion(Rectangle) | A constructor for the abstract OcrContainerRegion class.
Protected method | OcrContainerRegion(PolygonF) | A constructor for the abstract OcrContainerRegion class.
Top
See Also

Reference

OcrContainerRegion Class
Atalasoft.Ocr Namespace


OcrContainerRegion Constructor (Rectangle)

A constructor for the abstract OcrContainerRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrContainerRegion(
    Rectangle bounds
)
Protected Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
Region bounding rectangle.
See Also

Reference

OcrContainerRegion Class
OcrContainerRegion Overload
Atalasoft.Ocr Namespace


OcrContainerRegion Constructor (PolygonF)

A constructor for the abstract OcrContainerRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrContainerRegion(
    PolygonF bounds
)
Protected Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
Region bounding rectangle.
See Also

Reference

OcrContainerRegion Class
OcrContainerRegion Overload
Atalasoft.Ocr Namespace


OcrContainerRegion Properties

The OcrContainerRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Protected property | Elements | Gets the contained elements
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
See Also

Reference

OcrContainerRegion Class
Atalasoft.Ocr Namespace


OcrContainerRegion.Elements Property

OcrContainerRegionElements Property

Gets the contained elements

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrRegionCollection Elements { get; set; }
Protected Property Elements As OcrRegionCollection
    Get
    Set

Property Value

Type: OcrRegionCollection
See Also

Reference

OcrContainerRegion Class
Atalasoft.Ocr Namespace


OcrContainerRegion Methods

The OcrContainerRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | ElementsElementChanged | Reroutes listener events to specific methods in this class, based on the OcrPageElementAction of the OcrPageElementEventArgs of the event
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates bound encompassing all contained regions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrContainerRegion Class
Atalasoft.Ocr Namespace


OcrContainerRegion.ElementsElementChanged Method

OcrContainerRegionElementsElementChanged Method

Reroutes listener events to specific methods in this class, based on the OcrPageElementAction of the OcrPageElementEventArgs of the event

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ElementsElementChanged(
    Object sender,
    OcrPageElementEventArgs e
)
Protected Sub ElementsElementChanged (
    sender As Object,
    e As OcrPageElementEventArgs
)

Parameters

sender
Type: SystemObject
The sender of the event, typically OcrEngine.
e
Type: Atalasoft.OcrOcrPageElementEventArgs
Parameters that describe the operation.
See Also

Reference

OcrContainerRegion Class
Atalasoft.Ocr Namespace


OcrContainerRegion.RecalculateBounds Method

OcrContainerRegionRecalculateBounds Method

Recalculates bound encompassing all contained regions.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RecalculateBounds()
Public Sub RecalculateBounds
See Also

Reference

OcrContainerRegion Class
Atalasoft.Ocr Namespace


OcrDocument Class

Summary description for OcrDocument.
OcrDocument represents each page of a OCR'ed document and associated metadata.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrDocument

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrDocument
Public Class OcrDocument

The OcrDocument type exposes the following members.

Constructors
 | Name | Description
Public method | OcrDocument | Constructs a new OcrDocument object.
Top
Properties
 | Name | Description
Public property | Author | This property describes the author of a document
Public property | CreationDate | A date object representing the creation date of the document
Public property | Creator | Gets or sets the Creator metadata for this OcrDocument.
Public property | Keywords | An array of strings that represent keywords in this document.
Public property | Metadata | A Hashtable that represents document metadata.
Public property | Pages | An object of type OcrPageCollection that represents the pages within this document.
Public property | Producer | Gets or sets the Producer metadata for this document.
Public property | Subject | A string representing the subject of this document.
Public property | Title | A string representing the title of this document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDocumentInfo | Returns a hashtable that represents document metadata.
Protected method | GetDocumentInfoValue | Returns information about document using provided key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextString | Returns textual information from all pages of the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetDocumentInfoValue | Sets metadata information about the document using provided key and value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrDocument Constructor

Constructs a new OcrDocument object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrDocument()
Public Sub New

Return Value

Type:
A new OcrDocument object.
Remarks
Avoid calling this constructor directly. Instead use the OcrDocument method in BasicOcrFactory, or a class implementing IOcrFactory.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument Properties

The OcrDocument type exposes the following members.

Properties
 | Name | Description
Public property | Author | This property describes the author of a document
Public property | CreationDate | A date object representing the creation date of the document
Public property | Creator | Gets or sets the Creator metadata for this OcrDocument.
Public property | Keywords | An array of strings that represent keywords in this document.
Public property | Metadata | A Hashtable that represents document metadata.
Public property | Pages | An object of type OcrPageCollection that represents the pages within this document.
Public property | Producer | Gets or sets the Producer metadata for this document.
Public property | Subject | A string representing the subject of this document.
Public property | Title | A string representing the title of this document.
Top
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Author Property

OcrDocumentAuthor Property

This property describes the author of a document

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set

Property Value

Type: String
A string representing the author of the document.
Remarks
Default value is ""
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.CreationDate Property

OcrDocumentCreationDate Property

A date object representing the creation date of the document

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
Remarks
This is set to current time on object construction.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Creator Property

OcrDocumentCreator Property

Gets or sets the Creator metadata for this OcrDocument.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Keywords Property

OcrDocumentKeywords Property

An array of strings that represent keywords in this document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set

Property Value

Type: String
An array of strings that represent keywords in this document.
Remarks
There is no standard that defines what the keywords should be. Common sense suggests that each array element should be a single word.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Metadata Property

OcrDocumentMetadata Property

A Hashtable that represents document metadata.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Hashtable Metadata { get; }
Public ReadOnly Property Metadata As Hashtable
    Get

Property Value

Type: Hashtable
Remarks
While it is possible to access Author, CreationDate, Keywords, etc through this object, it is best to use the properties to insulate client code from possible future structural changes.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Pages Property

OcrDocumentPages Property

An object of type OcrPageCollection that represents the pages within this document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageCollection Pages { get; }
Public ReadOnly Property Pages As OcrPageCollection
    Get

Property Value

Type: OcrPageCollection
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Producer Property

OcrDocumentProducer Property

Gets or sets the Producer metadata for this document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Producer { get; set; }
Public Property Producer As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Subject Property

OcrDocumentSubject Property

A string representing the subject of this document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.Title Property

OcrDocumentTitle Property

A string representing the title of this document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument Methods

The OcrDocument type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDocumentInfo | Returns a hashtable that represents document metadata.
Protected method | GetDocumentInfoValue | Returns information about document using provided key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextString | Returns textual information from all pages of the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetDocumentInfoValue | Sets metadata information about the document using provided key and value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.GetDocumentInfo Method

OcrDocumentGetDocumentInfo Method

Returns a hashtable that represents document metadata.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Hashtable GetDocumentInfo()
Protected Function GetDocumentInfo As Hashtable

Return Value

Type: Hashtable
Document metadata.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.GetDocumentInfoValue Method

OcrDocumentGetDocumentInfoValue Method

Returns information about document using provided key.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Object GetDocumentInfoValue(
    OcrDocumentInfoKey key
)
Protected Function GetDocumentInfoValue (
    key As OcrDocumentInfoKey
) As Object

Parameters

key
Type: Atalasoft.OcrOcrDocumentInfoKey
Document metadata key.

Return Value

Type: Object
Requested metadata value.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.GetTextString Method

OcrDocumentGetTextString Method

Returns textual information from all pages of the document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetTextString(
    bool removeLineBreaks
)
Public Function GetTextString (
    removeLineBreaks As Boolean
) As String

Parameters

removeLineBreaks
Type: SystemBoolean
Specifies whether to remove line breaks (replace them with space character) or preserve them.

Return Value

Type: String
Textual representation of the document.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocument.SetDocumentInfoValue Method

OcrDocumentSetDocumentInfoValue Method

Sets metadata information about the document using provided key and value.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetDocumentInfoValue(
    OcrDocumentInfoKey key,
    Object val
)
Protected Sub SetDocumentInfoValue (
    key As OcrDocumentInfoKey,
    val As Object
)

Parameters

key
Type: Atalasoft.OcrOcrDocumentInfoKey
Document metadata key.
val
Type: SystemObject
Document metadata value to set.
See Also

Reference

OcrDocument Class
Atalasoft.Ocr Namespace


OcrDocumentInfoKey Enumeration

This enumeration defines a set of keys that are used to access metadata within an OcrDocument.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrDocumentInfoKey
Public Enumeration OcrDocumentInfoKey
Members
Member name | Description
Title | This key is used to access the Title of the document
Subject | This key is used to access the Subject of the document
Author | This key is used to access the Author of the document
Creator | This key is used to access the Creator of the document
Producer | This key is used to access the Producer of the document
Keywords | This key is used to access keywords defined in the document
CreationDate | This key is used to access the creation date of the document
See Also

Reference

Atalasoft.Ocr Namespace


OcrDocumentMetadataKey Enumeration

This enumeration is used to define keys for accessing document metadata.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrDocumentMetadataKey
Public Enumeration OcrDocumentMetadataKey
Members
Member name | Description
DocumentInfo | This is a key used to access general document information metadata.
PdfDocumentInfo | This is a key used to access Pdf specific document information metadata
See Also

Reference

Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs Class

OcrDocumentProgressEventArgs provides the information necessary to track the progress of OCR in a document.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
Atalasoft.OcrOcrDocumentProgressEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrDocumentProgressEventArgs : CancelEventArgs
Public Class OcrDocumentProgressEventArgs
    Inherits CancelEventArgs

The OcrDocumentProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OcrDocumentProgressEventArgs(OcrDocumentStage, Boolean, Int32) | Constructs a new OcrDocumentProgressEventArgs.
Public method | OcrDocumentProgressEventArgs(OcrDocumentStage, Boolean, Int32, OcrDocument) | Constructs a new OcrDocumentProgressEventArgs.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Document | Gets the OcrDocument associated with this progress event.
Public property | Progress | The property represents the total document progress as a percent value.
Public property | ProgressIsValid | This property indicates if the Progress property is valid or not.
Public property | Stage | This property represents the current stage of document processing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs Constructor

Overload List
 | Name | Description
Public method | OcrDocumentProgressEventArgs(OcrDocumentStage, Boolean, Int32) | Constructs a new OcrDocumentProgressEventArgs.
Public method | OcrDocumentProgressEventArgs(OcrDocumentStage, Boolean, Int32, OcrDocument) | Constructs a new OcrDocumentProgressEventArgs.
Top
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs Constructor (OcrDocumentStage, Boolean, Int32)

Constructs a new OcrDocumentProgressEventArgs.
Constructs a new OcrDocumentProgressEventArgs object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrDocumentProgressEventArgs(
    OcrDocumentStage stage,
    bool progressIsValid,
    int progress
)
Public Sub New (
    stage As OcrDocumentStage,
    progressIsValid As Boolean,
    progress As Integer
)

Parameters

stage
Type: Atalasoft.OcrOcrDocumentStage
The OCR Document Stage
progressIsValid
Type: SystemBoolean
The OCR Document Stage
progress
Type: SystemInt32
The percent progress

Return Value

Type:
A new OcrDocumentProgressEventArgs object.
See Also

Reference

OcrDocumentProgressEventArgs Class
OcrDocumentProgressEventArgs Overload
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs Constructor (OcrDocumentStage, Boolean, Int32, OcrDocument)

Constructs a new OcrDocumentProgressEventArgs.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrDocumentProgressEventArgs(
    OcrDocumentStage stage,
    bool progressIsValid,
    int progress,
    OcrDocument document
)
Public Sub New (
    stage As OcrDocumentStage,
    progressIsValid As Boolean,
    progress As Integer,
    document As OcrDocument
)

Parameters

stage
Type: Atalasoft.OcrOcrDocumentStage
The OCR Document Stage
progressIsValid
Type: SystemBoolean
The OCR Document Stage
progress
Type: SystemInt32
The percent progress
document
Type: Atalasoft.OcrOcrDocument
The parent OcrDocument.
See Also

Reference

OcrDocumentProgressEventArgs Class
OcrDocumentProgressEventArgs Overload
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs Properties

The OcrDocumentProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Document | Gets the OcrDocument associated with this progress event.
Public property | Progress | The property represents the total document progress as a percent value.
Public property | ProgressIsValid | This property indicates if the Progress property is valid or not.
Public property | Stage | This property represents the current stage of document processing.
Top
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs.Document Property

OcrDocumentProgressEventArgsDocument Property

Gets the OcrDocument associated with this progress event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrDocument Document { get; }
Public ReadOnly Property Document As OcrDocument
    Get

Property Value

Type: OcrDocument
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs.Progress Property

OcrDocumentProgressEventArgsProgress Property

The property represents the total document progress as a percent value.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Progress { get; }
Public ReadOnly Property Progress As Integer
    Get

Property Value

Type: Int32
An integer from 0 to 100.
Remarks
Progress may not be valid in all cases. If it is impossible how many pages there are to process a priori, then this value will be invalid. Before using this property, check the ProgressIsValid property.
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs.ProgressIsValid Property

OcrDocumentProgressEventArgsProgressIsValid Property

This property indicates if the Progress property is valid or not.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ProgressIsValid { get; }
Public ReadOnly Property ProgressIsValid As Boolean
    Get

Property Value

Type: Boolean
True if the Progress property is valid for this document, false otherwise.
Remarks
In some cases, it is not possible to know how many pages there will be in a document before processing.
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs.Stage Property

OcrDocumentProgressEventArgsStage Property

This property represents the current stage of document processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrDocumentStage Stage { get; }
Public ReadOnly Property Stage As OcrDocumentStage
    Get

Property Value

Type: OcrDocumentStage
An enumerated value of type OcrDocumentStage representing the current state of progress.
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventArgs Methods

The OcrDocumentProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrDocumentProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrDocumentProgressEventHandler Delegate

The OcrDocumentProgressEventHandler delegate defines the event fired during progress on recognition of a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OcrDocumentProgressEventHandler(
    Object sender,
    OcrDocumentProgressEventArgs e
)
Public Delegate Sub OcrDocumentProgressEventHandler (
    sender As Object,
    e As OcrDocumentProgressEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Atalasoft.OcrOcrDocumentProgressEventArgs
The arguments for the event.
See Also

Reference

Atalasoft.Ocr Namespace


OcrDocumentStage Enumeration

OcrDocumentStage represents the current stage of document translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrDocumentStage
Public Enumeration OcrDocumentStage
Members
Member name | Description
BeginDocument | A new document is being translated.
BeginPage | A new page is being translated.
EndPage | A page has finished translation.
EndDocument | A document has finished translation.
Remarks
This enumeration is used by the DocumentProgress event in OcrEngine.
See Also

Reference

Atalasoft.Ocr Namespace


OcrEngine Class

OcrEngine represents the functionality of an OCR engine. It is an abstract class and cannot be constructed directly, but it provides much of the functionality needed in subclasses.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.Ocr.GlyphReaderGlyphReaderEngine
Atalasoft.OcrOmniPageEngineBase
Atalasoft.Ocr.TesseractTesseract3Engine
Atalasoft.Ocr.TesseractTesseract5Engine
Atalasoft.Ocr.VotingVotingEngine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class OcrEngine : IDisposable
Public MustInherit Class OcrEngine
    Implements IDisposable

The OcrEngine type exposes the following members.

Constructors
 | Name | Description
Protected method | OcrEngine | Initializes a new instance of the OcrEngine class.
Protected method | OcrEngine(IOcrFactory) | Initializes a new instance of the OcrEngine class using provided IOcrFactory.
Top
Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine.
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition.
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not.
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine.
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine.
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements.
Public property | FontBuilder | This property provides a font builder that will be used for page construction.
Public property | FontMapper | This property provides a font mapper that will be used for page construction.
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine.
Public property | RecognitionCulture | Sets or gets the recognition language for this engine.
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition.
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition.
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any).
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures.
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents.
Top
Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream.
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format.
Protected method | CulturesMatch | Detects whether specified cultures match.
Public method | Dispose | Dispose memory used by the OcrEngine.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OcrEngine and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Overrides ObjectFinalize.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not.
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name.
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine.
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image.
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location.
Public method | Initialize | Initialize the engine.
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures.
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported.
Protected method | OnDocumentProgress | Fire the DocumentProgress event.
Protected method | OnImageIntroduction | Raises the ImageIntroduction event.
Protected method | OnImageSendOff | Raises the ImageSendOff event.
Protected method | OnImageTransformation | Raises the ImageTransformation event.
Protected method | OnPageConstructed | Fire the PageConstructed event.
Protected method | OnPageConstructing | Fire the PageConstructing event.
Protected method | OnPageLocation | Fire the PageLocation event.
Protected method | OnPageProgress | Fire the page progress event.
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes.
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object.
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document.
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document.
Public method | ShutDown | Terminates the engine.
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine.
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine.
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set.
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job.
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job.
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator.
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator.
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images.
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew.
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing.
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised.
Public event | PageConstructed | This event is used to publish the page that has just been constructed.
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated.
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image.
Public event | PageProgress | This event is used to publish progress made in the recognition of a page.
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrEngine Constructor

Overload List
 | Name | Description
Protected method | OcrEngine | Initializes a new instance of the OcrEngine class.
Protected method | OcrEngine(IOcrFactory) | Initializes a new instance of the OcrEngine class using provided IOcrFactory.
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine Constructor

Initializes a new instance of the OcrEngine class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrEngine()
Protected Sub New
See Also

Reference

OcrEngine Class
OcrEngine Overload
Atalasoft.Ocr Namespace


OcrEngine Constructor (IOcrFactory)

Initializes a new instance of the OcrEngine class using provided IOcrFactory.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrEngine(
    IOcrFactory factory
)
Protected Sub New (
    factory As IOcrFactory
)

Parameters

factory
Type: Atalasoft.OcrIOcrFactory
IOcrFactory instance to use.
See Also

Reference

OcrEngine Class
OcrEngine Overload
Atalasoft.Ocr Namespace


OcrEngine Properties

The OcrEngine type exposes the following members.

Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine.
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition.
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not.
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine.
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine.
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements.
Public property | FontBuilder | This property provides a font builder that will be used for page construction.
Public property | FontMapper | This property provides a font mapper that will be used for page construction.
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine.
Public property | RecognitionCulture | Sets or gets the recognition language for this engine.
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition.
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition.
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any).
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures.
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents.
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.AvailablePreprocessingOptions Property

OcrEngineAvailablePreprocessingOptions Property

This property returns the available set of image preprocessing options for this OcrEngine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPreprocessingOptions AvailablePreprocessingOptions { get; }
Public ReadOnly Property AvailablePreprocessingOptions As OcrPreprocessingOptions
    Get

Property Value

Type: OcrPreprocessingOptions
An integer bit field with the available supported preprocessing options for this engine.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.CanRecognizeBarcodes Property

OcrEngineCanRecognizeBarcodes Property

Returns true if this engine supports barcode recognition.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanRecognizeBarcodes { get; }
Public ReadOnly Property CanRecognizeBarcodes As Boolean
    Get

Property Value

Type: Boolean
Remarks
Returns GetCanRecognizeBarcodes method result. Each ocr engine can define the barcode detection support via this method.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.CanUseSymbolSet Property

OcrEngineCanUseSymbolSet Property

Gets a value indicating whether engine can use symbol set or not.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool CanUseSymbolSet { get; }
Public Overridable ReadOnly Property CanUseSymbolSet As Boolean
    Get

Return Value

Type: Boolean
Value indicating whether engine can use symbol set or not.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.DefaultPreprocessingOptions Property

OcrEngineDefaultPreprocessingOptions Property

Returns the default preprocessing options for this OcrEngine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPreprocessingOptions DefaultPreprocessingOptions { get; }
Public ReadOnly Property DefaultPreprocessingOptions As OcrPreprocessingOptions
    Get

Property Value

Type: OcrPreprocessingOptions
An integer bit field with the default preprocessing options for this engine.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.DefaultRecognitionCulture Property

OcrEngineDefaultRecognitionCulture Property

Returns the default recognition language for this engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract CultureInfo DefaultRecognitionCulture { get; }
Public MustOverride ReadOnly Property DefaultRecognitionCulture As CultureInfo
    Get

Property Value

Type: CultureInfo
The default recognition language for this engine.
Remarks
Most engines will return English or neutral culture as their default.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Factory Property

OcrEngineFactory Property

This property provides an object of type IOcrFactory for the construction of page and document elements.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IOcrFactory Factory { get; set; }
Public Property Factory As IOcrFactory
    Get
    Set

Property Value

Type: IOcrFactory
An object of type IOcrFactory.
Remarks
This object should be used in favor of calling a page element constructor directly.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.FontBuilder Property

OcrEngineFontBuilder Property

This property provides a font builder that will be used for page construction.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFontBuilder FontBuilder { get; set; }
Public Property FontBuilder As IFontBuilder
    Get
    Set

Property Value

Type: IFontBuilder
An object that meets the IFontBuilder interface.
Remarks
When an engine is constructed, the FontBuilder property will be set to a new instance of the BasicFontBuilder object.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.FontMapper Property

OcrEngineFontMapper Property

This property provides a font mapper that will be used for page construction.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFontMapper FontMapper { get; set; }
Public Property FontMapper As IFontMapper
    Get
    Set

Property Value

Type: IFontMapper
An object that meets the IFontMapper interface.
Remarks
When an engine is constructed, the FontMapper property will be set to a new instance of the BasicFontMapper object.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.PreprocessingOptions Property

OcrEnginePreprocessingOptions Property

The property provides the preprocessing options to be used for this engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPreprocessingOptions PreprocessingOptions { get; }
Public ReadOnly Property PreprocessingOptions As OcrPreprocessingOptions
    Get

Property Value

Type: OcrPreprocessingOptions
An integer bit field reflecting the current preprocessing options for this engine.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.RecognitionCulture Property

OcrEngineRecognitionCulture Property

Sets or gets the recognition language for this engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CultureInfo RecognitionCulture { get; set; }
Public Property RecognitionCulture As CultureInfo
    Get
    Set

Property Value

Type: CultureInfo
The recognition language for this engine.
Exceptions
Exception | Condition
OcrException | Thrown when the requested culture is not supported.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.RecognitionCulturesList Property

OcrEngineRecognitionCulturesList Property

Gets or sets the list of cultures to be used during recognition.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<CultureInfo> RecognitionCulturesList { get; set; }
Public Property RecognitionCulturesList As IEnumerable(Of CultureInfo)
    Get
    Set

Property Value

Type: IEnumerableCultureInfo
The list of cultures to be used during recognition.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.RecognizeBarcodes Property

OcrEngineRecognizeBarcodes Property

When true, will recognize barcodes as well as text if the engine supports barcode recognition.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RecognizeBarcodes { get; set; }
Public Property RecognizeBarcodes As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
This property could be set to true only if barcode detection is supported (if CanRecognizeBarcodes is true).
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.SupportedBarcodeSymbologies Property

OcrEngineSupportedBarcodeSymbologies Property

Gets a list of barcode symbologies that are supported by this OcrDocument (if any).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrBarcodeSymbologies SupportedBarcodeSymbologies { get; }
Public ReadOnly Property SupportedBarcodeSymbologies As OcrBarcodeSymbologies
    Get

Property Value

Type: OcrBarcodeSymbologies
The list of barcode symbologies that are supported by this OcrDocument (if any).
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.SupportMultiCultureRecognition Property

OcrEngineSupportMultiCultureRecognition Property

Gets the value indicating whether the OCR engine supports multiple recognition cultures.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SupportMultiCultureRecognition { get; }
Public ReadOnly Property SupportMultiCultureRecognition As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Translators Property

OcrEngineTranslators Property

This property provides access to a TranslatorCollection object used by the engine to translate images to documents.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TranslatorCollection Translators { get; }
Public ReadOnly Property Translators As TranslatorCollection
    Get

Property Value

Type: TranslatorCollection
An object of type TranslatorCollection containing currently installed translators.
Remarks
Subclasses of OcrEngine will typically populate this collection with INativeTranslator objects during construction. Clients are free to add or remove translator objects as they see fit. For example, to add PDF Translation support add an instance of PdfTranslator to the Translators collection.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine Methods

The OcrEngine type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream.
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format.
Protected method | CulturesMatch | Detects whether specified cultures match.
Public method | Dispose | Dispose memory used by the OcrEngine.
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Overrides ObjectFinalize.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not.
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name.
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine.
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image.
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location.
Public method | Initialize | Initialize the engine.
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures.
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported.
Protected method | OnDocumentProgress | Fire the DocumentProgress event.
Protected method | OnImageIntroduction | Raises the ImageIntroduction event.
Protected method | OnImageSendOff | Raises the ImageSendOff event.
Protected method | OnImageTransformation | Raises the ImageTransformation event.
Protected method | OnPageConstructed | Fire the PageConstructed event.
Protected method | OnPageConstructing | Fire the PageConstructing event.
Protected method | OnPageLocation | Fire the PageLocation event.
Protected method | OnPageProgress | Fire the page progress event.
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes.
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object.
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document.
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document.
Public method | ShutDown | Terminates the engine.
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine.
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine.
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set.
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job.
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job.
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator.
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator.
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.CanStream Method

OcrEngineCanStream Method

Determines if it is possible to write a particular output format to a Stream.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanStream(
    string mime
)
Public Function CanStream (
    mime As String
) As Boolean

Parameters

mime
Type: SystemString
The standard mime type of the request output stream.

Return Value

Type: Boolean
True if there is a translator available which can generate the requested mime type to a stream.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.CanTranslate Method

OcrEngineCanTranslate Method

Determines if it is possible to translate a document to a particular output format.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanTranslate(
    string mime
)
Public Function CanTranslate (
    mime As String
) As Boolean

Parameters

mime
Type: SystemString
The standard mime type of the request output stream.

Return Value

Type: Boolean
True if there is a translator that supports translation to the requested output type.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.CulturesMatch Method

OcrEngineCulturesMatch Method

Detects whether specified cultures match.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool CulturesMatch(
    CultureInfo first,
    CultureInfo second
)
Protected Overridable Function CulturesMatch (
    first As CultureInfo,
    second As CultureInfo
) As Boolean

Parameters

first
Type: System.GlobalizationCultureInfo
First culture to match.
second
Type: System.GlobalizationCultureInfo
Second culture to match.

Return Value

Type: Boolean
True if cultures math; false otherwise.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Dispose Method

OcrEngineDispose Method

Dipose memory used by the OcrEngine
Overload List
 | Name | Description
Public method | Dispose | Dispose memory used by the OcrEngine.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OcrEngine and optionally releases the managed resources
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Dispose Method

OcrEngineDispose Method

Dispose memory used by the OcrEngine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

OcrEngine Class
Dispose Overload
Atalasoft.Ocr Namespace


OcrEngine.Dispose Method (Boolean)

OcrEngineDispose Method (Boolean)

Releases the unmanaged resources used by the OcrEngine and optionally releases the managed resources

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

OcrEngine Class
Dispose Overload
Atalasoft.Ocr Namespace


OcrEngine.Finalize Method

OcrEngineFinalize Method

OcrEngine finalizer.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetAvailablePreprocessingOptions Method

OcrEngineGetAvailablePreprocessingOptions Method

Gets available preprocessing options for this OcrEngine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract OcrPreprocessingOptions GetAvailablePreprocessingOptions()
Protected MustOverride Function GetAvailablePreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Available preprocessing options.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetCanRecognizeBarcodes Method

OcrEngineGetCanRecognizeBarcodes Method

Gets the value indicating whether the engine can recognize barcodes or not.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool GetCanRecognizeBarcodes()
Protected Overridable Function GetCanRecognizeBarcodes As Boolean

Return Value

Type: Boolean
The value indicating whether the engine can recognize barcodes or not.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetDefaultPreprocessingOptions Method

OcrEngineGetDefaultPreprocessingOptions Method

Gets default preprocessing options for this OcrEngine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract OcrPreprocessingOptions GetDefaultPreprocessingOptions()
Protected MustOverride Function GetDefaultPreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Default preprocessing options
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetLicenseFlag Method

OcrEngineGetLicenseFlag Method

Retrieves value of the flag with specified name.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Object GetLicenseFlag(
    string name
)
Protected Function GetLicenseFlag (
    name As String
) As Object

Parameters

name
Type: SystemString
Name of the flag to retrieve.

Return Value

Type: Object
Value of the requested flag.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetSupportedBarcodeSymbologies Method

OcrEngineGetSupportedBarcodeSymbologies Method

Returns the barcode symbologies supported by this engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual OcrBarcodeSymbologies GetSupportedBarcodeSymbologies()
Protected Overridable Function GetSupportedBarcodeSymbologies As OcrBarcodeSymbologies

Return Value

Type: OcrBarcodeSymbologies
Barcode symbologies supported by this engine.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetSupportedRecognitionCultures Method

OcrEngineGetSupportedRecognitionCultures Method

Returns an array of supported recognition languages for this engine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract CultureInfo[] GetSupportedRecognitionCultures()
Public MustOverride Function GetSupportedRecognitionCultures As CultureInfo()

Return Value

Type: CultureInfo
An array of supported recognition languages for this engine
Remarks
Some engines support few or one recognition language. Some engines support hundreds, although most of the supported languages are equivalent to "latin alphabet" or "cyrillic alphabet". Some engines provide languages for which there is no equivalent CultureInfo (Esperanto, for example) and therefore can't be reflected in this interface.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.GetSymbolSet Method

OcrEngineGetSymbolSet Method

Returns an engine-specific symbol set matching string from a standard symbol set.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetSymbolSet(
    OcrSymbolSet set
)
Public Overridable Function GetSymbolSet (
    set As OcrSymbolSet
) As String

Parameters

set
Type: Atalasoft.OcrOcrSymbolSet
A standard symbol set.

Return Value

Type: String
Engine-specific symbol set matching string from a standard symbol set.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.HandleDeskew Method

OcrEngineHandleDeskew Method

Handles the process of deskewing an image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage HandleDeskew(
    AtalaImage image,
    out double angle
)
Protected Overridable Function HandleDeskew (
    image As AtalaImage,
    <OutAttribute> ByRef angle As Double
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image.
angle
Type: SystemDouble
The angle by which the image was rotated.

Return Value

Type: AtalaImage
A new deskewed image or null if no deskewing was needed.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.HasPageLocationHandler Method

OcrEngineHasPageLocationHandler Method

Determines whether or not events have been installed for page location.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool HasPageLocationHandler()
Public Overridable Function HasPageLocationHandler As Boolean

Return Value

Type: Boolean
True if an OcrPageLocationEventHandler has been installed.
Remarks
This is should be used by a subclass of OcrEngine to determine whether or not it will be necessary to translate a native set of page location structures into OcrRegion objects. An engine can avoid the extra work by checking to see if any handlers are present.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Initialize Method

OcrEngineInitialize Method

Initialize the engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Initialize()
Public MustOverride Sub Initialize
Remarks
This is an abstract method and must be implemented by a subclass of OcrEngine. Not every engine will perform an action in this method.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.IsMultiCultureRecognitionSupported Method

OcrEngineIsMultiCultureRecognitionSupported Method

Tells whether the OCR engine supports multiple recognition cultures.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool IsMultiCultureRecognitionSupported()
Protected Overridable Function IsMultiCultureRecognitionSupported As Boolean

Return Value

Type: Boolean
Returns true if the OCR engine supports multiple recognition cultures, otherwise false.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.MakeBinarizeCommand Method

OcrEngineMakeBinarizeCommand Method

Returns a new ImageCommand that will binarize an image in the HandleDeskew method

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual ImageCommand MakeBinarizeCommand()
Protected Overridable Function MakeBinarizeCommand As ImageCommand

Return Value

Type: ImageCommand
ImageCommand that will binarize an image in the HandleDeskew method.
Remarks

By default this method returns a new instance of the DynamicThresholdCommand with default settings. If you override this method, you need to return a command that when applied to an image will return an image of PixelFormat1bppIndexed. If the result of the command's Apply method is not a 1-bit image, it will be discarded and a SimpleThresholdCommand will be used instead.

If MakeBinarizeCommand returns null, HandleDeskew will revert to DotImage 6.09 behavior, which is to attempt to apply an AutoDeskewCommand to a color image if it the appropriate licensing is in place. Otherwise, SimpleThreshold and 1-Bit deskew will be used.

See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.MakeDeskewCommand Method

OcrEngineMakeDeskewCommand Method

Returns a new ImageCommand that will deskew an image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AutoDeskewCommand MakeDeskewCommand()
Protected Overridable Function MakeDeskewCommand As AutoDeskewCommand

Return Value

Type: AutoDeskewCommand
A new object of type ImageCommand
Remarks
The default implementation returns an AutoDeskewCommand.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OcrBarcodeSymbologyIsSupported Method

OcrEngineOcrBarcodeSymbologyIsSupported Method

Returns true if a given barcode symbology is supported.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OcrBarcodeSymbologyIsSupported(
    OcrBarcodeSymbologies symbologies
)
Public Function OcrBarcodeSymbologyIsSupported (
    symbologies As OcrBarcodeSymbologies
) As Boolean

Parameters

symbologies
Type: Atalasoft.OcrOcrBarcodeSymbologies
The barcode symbologies to check

Return Value

Type: Boolean
True if a given barcode symbology is supported.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnDocumentProgress Method

OcrEngineOnDocumentProgress Method

Fire the DocumentProgress event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDocumentProgress(
    OcrDocumentProgressEventArgs e
)
Protected Overridable Sub OnDocumentProgress (
    e As OcrDocumentProgressEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrDocumentProgressEventArgs
OcrDocumentProgressEventArgs. The information necessary to track the progress of OCR in a document.

Return Value

Type:
n/a
Remarks
If it is impossible to determine how many pages are present ahead of time, set progressIsValid to false and progress to 0.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnImageIntroduction Method

OcrEngineOnImageIntroduction Method

Raises the ImageIntroduction event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageIntroduction(
    OcrImagePreprocessingEventArgs e
)
Protected Overridable Sub OnImageIntroduction (
    e As OcrImagePreprocessingEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrImagePreprocessingEventArgs
The OcrImagePreprocessingEventArgs instance containing the event data.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnImageSendOff Method

OcrEngineOnImageSendOff Method

Raises the ImageSendOff event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageSendOff(
    OcrImagePreprocessingEventArgs e
)
Protected Overridable Sub OnImageSendOff (
    e As OcrImagePreprocessingEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrImagePreprocessingEventArgs
The OcrImagePreprocessingEventArgs instance containing the event data.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnImageTransformation Method

OcrEngineOnImageTransformation Method

Raises the ImageTransformation event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnImageTransformation(
    OcrImagePreprocessingEventArgs e
)
Protected Overridable Sub OnImageTransformation (
    e As OcrImagePreprocessingEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrImagePreprocessingEventArgs
The OcrImagePreprocessingEventArgs instance containing the event data.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnPageConstructed Method

OcrEngineOnPageConstructed Method

Fire the PageConstructed event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageConstructed(
    OcrPageConstructionEventArgs e
)
Protected Overridable Sub OnPageConstructed (
    e As OcrPageConstructionEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrPageConstructionEventArgs
OcrPageConstructionEventArgs. The information is used for events that are fired before a page has started to be constructed and after it has finished being constructed.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnPageConstructing Method

OcrEngineOnPageConstructing Method

Fire the PageConstructing event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageConstructing(
    OcrPageConstructionEventArgs e
)
Protected Overridable Sub OnPageConstructing (
    e As OcrPageConstructionEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrPageConstructionEventArgs
OcrPageConstructionEventArgs. The information is used for events that are fired before a page has started to be constructed and after it has finished being constructed.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnPageLocation Method

OcrEngineOnPageLocation Method

Fire the PageLocation event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageLocation(
    OcrPageLocationEventArgs e
)
Protected Overridable Sub OnPageLocation (
    e As OcrPageLocationEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrPageLocationEventArgs
OcrPageLocationEventArgs represents information needed for handling a PageLocation event from an OcrEngine.

Return Value

Type:
n/a
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.OnPageProgress Method

OcrEngineOnPageProgress Method

Fire the page progress event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageProgress(
    OcrPageProgressEventArgs e
)
Protected Overridable Sub OnPageProgress (
    e As OcrPageProgressEventArgs
)

Parameters

e
Type: Atalasoft.OcrOcrPageProgressEventArgs
OcrPageProgressEventArgs represents information about progress within OCR processing on a page..
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.RecognitionCultureChanged Method

OcrEngineRecognitionCultureChanged Method

Occurs when a recognition culture list changes.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void RecognitionCultureChanged()
Protected MustOverride Sub RecognitionCultureChanged
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.RecognitionCultureSupported Method

OcrEngineRecognitionCultureSupported Method

Indicates whether or not this engine will support a given recognition culture

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RecognitionCultureSupported(
    CultureInfo target
)
Public Function RecognitionCultureSupported (
    target As CultureInfo
) As Boolean

Parameters

target
Type: System.GlobalizationCultureInfo
The CultureInfo to be checked

Return Value

Type: Boolean
True if this engine supports the given culture, false otherwise.
Remarks
Note that some engines distinguish between similar languages used in different locales (U.S. English versus U.K. English). The engine will consider the same language in different locales to be equivalent by default. It is possible to change this behavior by overriding the CulturesMatch method.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Recognize Method

OcrEngineRecognize Method

Recognize text in an AtalaImage, transforming it into an OcrPage object.
Overload List
 | Name | Description
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object.
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document.
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document.
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Recognize Method (AtalaImage)

OcrEngineRecognize Method (AtalaImage)

Recognize text in an AtalaImage, transforming it into an OcrPage object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract OcrPage Recognize(
    AtalaImage image
)
Public MustOverride Function Recognize (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to recognize.

Return Value

Type: OcrPage
The recognized page.
Remarks
The version of Recognize that takes an ImageCollection is likely to change.
See Also

Reference

OcrEngine Class
Recognize Overload
Atalasoft.Ocr Namespace


OcrEngine.Recognize Method (ImageSource)

OcrEngineRecognize Method (ImageSource)

Recognize a set of AtalaImage objects as an entire document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrDocument Recognize(
    ImageSource images
)
Public Overridable Function Recognize (
    images As ImageSource
) As OcrDocument

Parameters

images
Type: Atalasoft.ImagingImageSource
A set of images to recognize.

Return Value

Type: OcrDocument
A new OcrDocument containing one page for every image in the collection.
Remarks
This method is likely to go away in the future.
See Also

Reference

OcrEngine Class
Recognize Overload
Atalasoft.Ocr Namespace


OcrEngine.Recognize Method (AtalaImage, Rectangle)

OcrEngineRecognize Method (AtalaImage, Rectangle)

Recognize only within a specific rectangle in an AtalaImage.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage Recognize(
    AtalaImage image,
    Rectangle bounds
)
Public Function Recognize (
    image As AtalaImage,
    bounds As Rectangle
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to recognize.
bounds
Type: System.DrawingRectangle
An area to within the image to focus on.

Return Value

Type: OcrPage

Returns OcrPage object which is transformed from AtalaImage. Recognize only within a specific rectangle in an AtalaImage.

In most cases this method is equivalent to:

return engine.Recognize( (new CropCommand(bounds)).Apply(image).Image);

See Also

Reference

OcrEngine Class
Recognize Overload
Atalasoft.Ocr Namespace


OcrEngine.Recognize Method (AtalaImage, Int32)

OcrEngineRecognize Method (AtalaImage, Int32)

Recognize text in an AtalaImage

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual OcrPage Recognize(
    AtalaImage image,
    int num
)
Protected Overridable Function Recognize (
    image As AtalaImage,
    num As Integer
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
Image to recognize.
num
Type: SystemInt32
Page number in the document.

Return Value

Type: OcrPage
The recognized page.
See Also

Reference

OcrEngine Class
Recognize Overload
Atalasoft.Ocr Namespace


OcrEngine.Recognize Method (ImageSource, OcrDocument, IForeignTranslator, Object)

OcrEngineRecognize Method (ImageSource, OcrDocument, IForeignTranslator, Object)

Recognize a set of AtalaImage objects as an entire document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual OcrDocument Recognize(
    ImageSource images,
    OcrDocument document,
    IForeignTranslator xlator,
    ref Object translationObject
)
Protected Overridable Function Recognize (
    images As ImageSource,
    document As OcrDocument,
    xlator As IForeignTranslator,
    ByRef translationObject As Object
) As OcrDocument

Parameters

images
Type: Atalasoft.ImagingImageSource
A set of images to recognize.
document
Type: Atalasoft.OcrOcrDocument
The recognized document.
xlator
Type: Atalasoft.OcrIForeignTranslator
Translator used to define how a document will be translated
translationObject
Type: SystemObject
An object is provided by the return value of the Prepare(OcrEngine, OcrDocument) method.

Return Value

Type: OcrDocument
A new OcrDocument containing one page for every image in the collection.
See Also

Reference

OcrEngine Class
Recognize Overload
Atalasoft.Ocr Namespace


OcrEngine.ShutDown Method

OcrEngineShutDown Method

Terminates the engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void ShutDown()
Public MustOverride Sub ShutDown
Remarks
This method is abstract and must be implemented by an engine. Not every engine will perform an action for this method.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Supported Method

OcrEngineSupported Method

Note: This API is now obsolete.

Provides a list of all mime types supported by Translators in this engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been renamed to SupportedMimeTypes()",
    false)]
public string[] Supported()
<ObsoleteAttribute("This method has been renamed to SupportedMimeTypes()",
    false)>
Public Function Supported As String()

Return Value

Type: String
List of supported mime types.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.SupportedMimeTypes Method

OcrEngineSupportedMimeTypes Method

Provides a list of all mime types supported by Translators in this engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] SupportedMimeTypes()
Public Function SupportedMimeTypes As String()

Return Value

Type: String
List of supported mime types.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.SupportingTranslator Method

OcrEngineSupportingTranslator Method

Finds a translator that supports translation to the requested output type.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ITranslator SupportingTranslator(
    string mime,
    bool needsStreaming
)
Protected Function SupportingTranslator (
    mime As String,
    needsStreaming As Boolean
) As ITranslator

Parameters

mime
Type: SystemString
The standard mime type of the request output stream.
needsStreaming
Type: SystemBoolean
Specifies whether streaming is needed or not.

Return Value

Type: ITranslator
Found translator instance; null if not found.s
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.ToSymbolSet Method

OcrEngineToSymbolSet Method

Converts a set of unique characters to a engine-specific symbol matching set.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string ToSymbolSet(
    string s
)
Public Overridable Function ToSymbolSet (
    s As String
) As String

Parameters

s
Type: SystemString
A non-null string of unique characters.

Return Value

Type: String
Engine-specific symbol matching set.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Translate Method

OcrEngineTranslate Method

Translate a set of images to a new document format.
Overload List
 | Name | Description
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job.
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job.
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator.
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator.
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.Translate Method (ImageSource, String, Stream)

OcrEngineTranslate Method (ImageSource, String, Stream)

Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    ImageSource images,
    string mime,
    Stream outStream
)
Public Sub Translate (
    images As ImageSource,
    mime As String,
    outStream As Stream
)

Parameters

images
Type: Atalasoft.ImagingImageSource
An ImageSource of the images to translate.
mime
Type: SystemString
The standard mime type of the request output stream.
outStream
Type: System.IOStream
The stream to write to.
See Also

Reference

OcrEngine Class
Translate Overload
Atalasoft.Ocr Namespace


OcrEngine.Translate Method (ImageSource, String, String)

OcrEngineTranslate Method (ImageSource, String, String)

Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    ImageSource images,
    string mime,
    string fileName
)
Public Sub Translate (
    images As ImageSource,
    mime As String,
    fileName As String
)

Parameters

images
Type: Atalasoft.ImagingImageSource
An ImageSource of the images to translate.
mime
Type: SystemString
The standard mime type of the request output stream.
fileName
Type: SystemString
A string represent the path of a file to write to.

Return Value

Type:
n/a
Remarks
These methods are likely to change in the future to use a more flexible class than ImageCollection.
See Also

Reference

OcrEngine Class
Translate Overload
Atalasoft.Ocr Namespace


OcrEngine.Translate Method (ImageSource, String, Stream, ITranslator)

OcrEngineTranslate Method (ImageSource, String, Stream, ITranslator)

Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    ImageSource images,
    string mime,
    Stream outStream,
    ITranslator translator
)
Public Sub Translate (
    images As ImageSource,
    mime As String,
    outStream As Stream,
    translator As ITranslator
)

Parameters

images
Type: Atalasoft.ImagingImageSource
An ImageSource of the images to translate.
mime
Type: SystemString
The standard mime type of the request output stream.
outStream
Type: System.IOStream
The stream to write to.
translator
Type: Atalasoft.OcrITranslator
An object of type ITranslator to use on this set of images.

Return Value

Type:
n/a
See Also

Reference

OcrEngine Class
Translate Overload
Atalasoft.Ocr Namespace


OcrEngine.Translate Method (ImageSource, String, String, ITranslator)

OcrEngineTranslate Method (ImageSource, String, String, ITranslator)

Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    ImageSource images,
    string mime,
    string fileName,
    ITranslator translator
)
Public Sub Translate (
    images As ImageSource,
    mime As String,
    fileName As String,
    translator As ITranslator
)

Parameters

images
Type: Atalasoft.ImagingImageSource
An ImageSource of the images to translate.
mime
Type: SystemString
The standard mime type of the request output stream.
fileName
Type: SystemString
A string represent the path of a file to write to.
translator
Type: Atalasoft.OcrITranslator
An object of type ITranslator to use on this set of images.
See Also

Reference

OcrEngine Class
Translate Overload
Atalasoft.Ocr Namespace


OcrEngine Events

The OcrEngine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images.
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew.
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing.
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised.
Public event | PageConstructed | This event is used to publish the page that has just been constructed.
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated.
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image.
Public event | PageProgress | This event is used to publish progress made in the recognition of a page.
Top
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.DocumentProgress Event

OcrEngineDocumentProgress Event

This event is used to publish progress made in recognition of a set of images.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrDocumentProgressEventHandler DocumentProgress
Public Event DocumentProgress As OcrDocumentProgressEventHandler

Field Value

Type:
The delegate defines the event fired during progress on recognition of a document.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.ImageIntroduction Event

OcrEngineImageIntroduction Event

This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrImagePreprocessingEventHandler ImageIntroduction
Public Event ImageIntroduction As OcrImagePreprocessingEventHandler

Field Value

Type:
The delegate defines the event fired before ImageTransformation in order to allow the document to be pre-processed prior to deskew.
Remarks

Custom OCR Pre-processing that cleans up the image, and improves visual characteristics should be applied in this event. If the source image is color, the image should remain color to be included in searchable PDF output or other "Image behind Text" formats.

See ImageSendOff for pre-processing a bi-tonal image prior to OCR.

See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace
ImageTransformation Event
ImageSendOff Event


OcrEngine.ImageSendOff Event

OcrEngineImageSendOff Event

This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrImagePreprocessingEventHandler ImageSendOff
Public Event ImageSendOff As OcrImagePreprocessingEventHandler

Field Value

Type:
The delegate defines the event fired before the OCR process starts, and after ImageTransformation for OCRImageIntroduction pre-processing.
Remarks
Any processing of the image in this event handler has no effect on the image that's included in a searchable PDF or other "Hidden Text Behind Image" formats. It is reasonable to threshold a color image to bi-tonal, and to strip away non-text content in this handler.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.ImageTransformation Event

OcrEngineImageTransformation Event

This event is raised just after the image is deskewed and before ImageSendOff is raised.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrImagePreprocessingEventHandler ImageTransformation
Public Event ImageTransformation As OcrImagePreprocessingEventHandler

Field Value

Type:
The delegate defines the event fired just after the image is deskewed and before ImageSendOff is raised.
Remarks
Any coordinate transformations such as deskew, crop, or rotate should be applied in this event handler. The resulting image is used in searchable PDF's and other "Hidden Text Behind Image" formats.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.PageConstructed Event

OcrEnginePageConstructed Event

This event is used to publish the page that has just been constructed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageConstructionEventHandler PageConstructed
Public Event PageConstructed As OcrPageConstructionEventHandler

Field Value

Type:
The delegate defines the event that is fired when the page has just been constructed
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.PageConstructing Event

OcrEnginePageConstructing Event

This event is used to publish the page that is in the process of being populated.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageConstructionEventHandler PageConstructing
Public Event PageConstructing As OcrPageConstructionEventHandler

Field Value

Type:
The delegate defines the event that is fired when the page is in the process of being populated.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.PageLocation Event

OcrEnginePageLocation Event

This event is used to publish OcrRegions that have been identified within an image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageLocationEventHandler PageLocation
Public Event PageLocation As OcrPageLocationEventHandler

Field Value

Type:
The delegate defines the event fired when region have been identified within an image.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngine.PageProgress Event

OcrEnginePageProgress Event

This event is used to publish progress made in the recognition of a page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageProgressEventHandler PageProgress
Public Event PageProgress As OcrPageProgressEventHandler

Field Value

Type:
The delegate defines the event fired during progress on recognition of a page.
See Also

Reference

OcrEngine Class
Atalasoft.Ocr Namespace


OcrEngineCollection Class

OcrEngineCollection represents a standard collection of OcrEngine objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrEngineCollection

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrEngineCollection : CollectionBase
<SerializableAttribute>
Public Class OcrEngineCollection
    Inherits CollectionBase

The OcrEngineCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrEngineCollection | Initializes a new instance of the OcrEngineCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for accessing item by index
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an OcrEngine to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrEngine.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrEngine in the collection.
Public method | Insert | Inserts an OcrEngine into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrEngine from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrEngineCollection Constructor

Initializes a new instance of the OcrEngineCollection class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEngineCollection()
Public Sub New
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection Properties

The OcrEngineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for accessing item by index
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.Item Property

OcrEngineCollectionItem Property

Allows for accessing item by index

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEngine this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As OcrEngine
    Get
    Set

Parameters

index
Type: SystemInt32
integer used to retrieve item

Return Value

Type: OcrEngine
An OcrEngine at index
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection Methods

The OcrEngineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an OcrEngine to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrEngine.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrEngine in the collection.
Public method | Insert | Inserts an OcrEngine into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrEngine from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.Add Method

OcrEngineCollectionAdd Method

Adds an OcrEngine to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    OcrEngine value
)
Public Function Add (
    value As OcrEngine
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrEngine
The OcrEngine to add.

Return Value

Type: Int32
The position into which the new element was inserted, or -1 to indicate that the item was not inserted into the collection.
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.Contains Method

OcrEngineCollectionContains Method

Determines whether the collection contains a specified OcrEngine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    OcrEngine value
)
Public Function Contains (
    value As OcrEngine
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrEngine
The OcrEngine to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.CopyTo Method

OcrEngineCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    OcrEngine[] array,
    int index
)
Public Sub CopyTo (
    array As OcrEngine(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrOcrEngine
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.IndexOf Method

OcrEngineCollectionIndexOf Method

Returns the index of a specified OcrEngine in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    OcrEngine value
)
Public Function IndexOf (
    value As OcrEngine
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrEngine
The OcrEngine to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.Insert Method

OcrEngineCollectionInsert Method

Inserts an OcrEngine into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    OcrEngine value
)
Public Sub Insert (
    index As Integer,
    value As OcrEngine
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrEngine should be inserted.
value
Type: Atalasoft.OcrOcrEngine
The OcrEngine to insert.

Return Value

Type:
n/a
Remarks
If index is equal to the size of the collection, value is appended to the collection.
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrEngineCollection.Remove Method

OcrEngineCollectionRemove Method

Removes the first occurrence of the specified OcrEngine from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    OcrEngine value
)
Public Sub Remove (
    value As OcrEngine
)

Parameters

value
Type: Atalasoft.OcrOcrEngine
The OcrEngine to remove.

Return Value

Type:
n/a
See Also

Reference

OcrEngineCollection Class
Atalasoft.Ocr Namespace


OcrException Class

Summary description for OcrException.
OcrException is used typically by OcrEngine objects to report errors or illegal conditions that occur during processing.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.OcrOcrException

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrException : Exception
<SerializableAttribute>
Public Class OcrException
    Inherits Exception

The OcrException type exposes the following members.

Constructors
 | Name | Description
Public method | OcrException | Initializes a new instance of the OcrException
Public method | OcrException(String) | Initializes a new instance of the OcrException
Protected method | OcrException(SerializationInfo, StreamingContext) | Initializes a new instance of the OcrException class using provided serialization info.
Public method | OcrException(String, Exception) | Initializes a new instance of the OcrException
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrException Constructor

Constructs a new OcrException object.
Overload List
 | Name | Description
Public method | OcrException | Initializes a new instance of the OcrException
Public method | OcrException(String) | Initializes a new instance of the OcrException
Protected method | OcrException(SerializationInfo, StreamingContext) | Initializes a new instance of the OcrException class using provided serialization info.
Public method | OcrException(String, Exception) | Initializes a new instance of the OcrException
Top
See Also

Reference

OcrException Class
Atalasoft.Ocr Namespace


OcrException Constructor

Initializes a new instance of the OcrException

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrException()
Public Sub New

Return Value

Type:
A new OcrException object.
See Also

Reference

OcrException Class
OcrException Overload
Atalasoft.Ocr Namespace


OcrException Constructor (String)

Initializes a new instance of the OcrException

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The reason for the exception.
See Also

Reference

OcrException Class
OcrException Overload
Atalasoft.Ocr Namespace


OcrException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the OcrException class using provided serialization info.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

OcrException Class
OcrException Overload
Atalasoft.Ocr Namespace


OcrException Constructor (String, Exception)

Initializes a new instance of the OcrException

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

OcrException Class
OcrException Overload
Atalasoft.Ocr Namespace


OcrException Properties

The OcrException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OcrException Class
Atalasoft.Ocr Namespace


OcrException Methods

The OcrException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OcrException Class
Atalasoft.Ocr Namespace


OcrException Events

The OcrException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OcrException Class
Atalasoft.Ocr Namespace


OcrFormElementGroupRegion Class

OcrFormElementGroupRegion represents a group of related OcrFormElementRegion elements
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrContainerRegion
Atalasoft.OcrOcrFormElementGroupRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class OcrFormElementGroupRegion : OcrContainerRegion
Public NotInheritable Class OcrFormElementGroupRegion
    Inherits OcrContainerRegion

The OcrFormElementGroupRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OcrFormElementGroupRegion(Rectangle) | Initializes a new instance of the OcrFormElementRegion class.
Public method | OcrFormElementGroupRegion(PolygonF) | Initializes a new instance of the OcrFormElementRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | FormElements | A List of OcrFormElementRegion elements pertaining to this OcrFormElementGroupRegion group
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Public method | RecalculateBounds | Recalculates bound encompassing all contained regions. (Inherited from OcrContainerRegion.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This is a protoype class and will likely change in the future.
See Also

Reference

Atalasoft.Ocr Namespace


OcrFormElementGroupRegion Constructor

Overload List
 | Name | Description
Public method | OcrFormElementGroupRegion(Rectangle) | Initializes a new instance of the OcrFormElementRegion class.
Public method | OcrFormElementGroupRegion(PolygonF) | Initializes a new instance of the OcrFormElementRegion class.
Top
See Also

Reference

OcrFormElementGroupRegion Class
Atalasoft.Ocr Namespace


OcrFormElementGroupRegion Constructor (Rectangle)

Initializes a new instance of the OcrFormElementRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrFormElementGroupRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.
See Also

Reference

OcrFormElementGroupRegion Class
OcrFormElementGroupRegion Overload
Atalasoft.Ocr Namespace


OcrFormElementGroupRegion Constructor (PolygonF)

Initializes a new instance of the OcrFormElementRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrFormElementGroupRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.
See Also

Reference

OcrFormElementGroupRegion Class
OcrFormElementGroupRegion Overload
Atalasoft.Ocr Namespace


OcrFormElementGroupRegion Properties

The OcrFormElementGroupRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | FormElements | A List of OcrFormElementRegion elements pertaining to this OcrFormElementGroupRegion group
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
See Also

Reference

OcrFormElementGroupRegion Class
Atalasoft.Ocr Namespace


OcrFormElementGroupRegion.FormElements Property

OcrFormElementGroupRegionFormElements Property

A List of OcrFormElementRegion elements pertaining to this OcrFormElementGroupRegion group

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionCollection<OcrFormElementRegion> FormElements { get; set; }
Public Property FormElements As OcrRegionCollection(Of OcrFormElementRegion)
    Get
    Set

Property Value

Type: OcrRegionCollection OcrFormElementRegion
See Also

Reference

OcrFormElementGroupRegion Class
Atalasoft.Ocr Namespace


OcrFormElementGroupRegion Methods

The OcrFormElementGroupRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Public method | RecalculateBounds | Recalculates bound encompassing all contained regions. (Inherited from OcrContainerRegion.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrFormElementGroupRegion Class
Atalasoft.Ocr Namespace


OcrFormElementRegion Class

OcrFormElementRegion defines a page element identified as a form element.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrFormElementRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrFormElementRegion : OcrRegion
Public Class OcrFormElementRegion
    Inherits OcrRegion

The OcrFormElementRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OcrFormElementRegion(Rectangle) | Initializes a new instance of the OcrFormElementRegion class.
Public method | OcrFormElementRegion(PolygonF) | Initializes a new instance of the OcrFormElementRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This is a protoype class and will likely change in the future.
See Also

Reference

Atalasoft.Ocr Namespace


OcrFormElementRegion Constructor

Overload List
 | Name | Description
Public method | OcrFormElementRegion(Rectangle) | Initializes a new instance of the OcrFormElementRegion class.
Public method | OcrFormElementRegion(PolygonF) | Initializes a new instance of the OcrFormElementRegion class.
Top
See Also

Reference

OcrFormElementRegion Class
Atalasoft.Ocr Namespace


OcrFormElementRegion Constructor (Rectangle)

Initializes a new instance of the OcrFormElementRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrFormElementRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.
See Also

Reference

OcrFormElementRegion Class
OcrFormElementRegion Overload
Atalasoft.Ocr Namespace


OcrFormElementRegion Constructor (PolygonF)

Initializes a new instance of the OcrFormElementRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrFormElementRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.
See Also

Reference

OcrFormElementRegion Class
OcrFormElementRegion Overload
Atalasoft.Ocr Namespace


OcrFormElementRegion Properties

The OcrFormElementRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
See Also

Reference

OcrFormElementRegion Class
Atalasoft.Ocr Namespace


OcrFormElementRegion Methods

The OcrFormElementRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrFormElementRegion Class
Atalasoft.Ocr Namespace


OcrGlyph Class

Summary description for OcrGlyph.

OcrGlyph defines a textual glyph on the page. Conceptually, a glyph is the representation of a unit of written or printed text. A glyph may consist of a single character such as a single letter or may consist of several characters that are typographically joined in a unit, as in the case of ligatures.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrGlyph

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrGlyph : MarshalByRefObject
Public Class OcrGlyph
    Inherits MarshalByRefObject

The OcrGlyph type exposes the following members.

Constructors
 | Name | Description
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) | Constructs a new OcrGlyph object.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) | Constructs a new OcrGlyph object.
Top
Properties
 | Name | Description
Public property | Accessor | The IOcrGlyphAccessor associated with this object.
Public property | Alternates | The best alternatives to this glyph that were considered by the engine
Public property | Baseline | The baseline of the text, in pixels from the top of the source image.
Public property | Bounds | The bounding box of the glyph, in pixels coordinates in the source image.
Public property | Char | This glyph, as a Unicode character
Public property | Codepoint | The Unicode codepoint of this glyph.
Public property | Color | The color of this glyph.
Public property | Confidence | The confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).
 | DefaultImprintFontName | The default font to use. Default is Arial.
Public property | IsSingleton | True if this glyph represents a single character.
Public property | Text | This glyph, as a string
Public property | TextKind | The Kind of text for the OcrLine. MachinePrint, HandPrint, Any. OcrTextKind
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFont | The Font used for this page element.
Public method | GetFontFamily | The FontFamily of this glyph.
Public method | GetFontName | The name of the font of this glyph.
Public method | GetFontSize | The font size of this glyph.
Public method | GetFontStyle | The FontStyle of this glyph.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ResetConfidence | Resets the confidence to that provided by the engine.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrGlyph Constructor

Overload List
 | Name | Description
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32) | Constructs a new OcrGlyph object.
Public method | OcrGlyph(IOcrGlyphAccessor, Rectangle, Int32, Color) | Constructs a new OcrGlyph object.
Top
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph Constructor (IOcrGlyphAccessor, Rectangle, Int32)

Constructs a new OcrGlyph object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyph(
    IOcrGlyphAccessor accessor,
    Rectangle bounds,
    int baseline
)
Public Sub New (
    accessor As IOcrGlyphAccessor,
    bounds As Rectangle,
    baseline As Integer
)

Parameters

accessor
Type: Atalasoft.OcrIOcrGlyphAccessor
The IOcrGlyphAccessor that will be used to access the components of this glyph.
bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
baseline
Type: SystemInt32
The baseline of the text in pixels relative to the image.
Remarks
Avoid calling the constructor directly. Use the OcrGlyph method in the Factory property.
See Also

Reference

OcrGlyph Class
OcrGlyph Overload
Atalasoft.Ocr Namespace


OcrGlyph Constructor (IOcrGlyphAccessor, Rectangle, Int32, Color)

Constructs a new OcrGlyph object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyph(
    IOcrGlyphAccessor accessor,
    Rectangle bounds,
    int baseline,
    Color color
)
Public Sub New (
    accessor As IOcrGlyphAccessor,
    bounds As Rectangle,
    baseline As Integer,
    color As Color
)

Parameters

accessor
Type: Atalasoft.OcrIOcrGlyphAccessor
The IOcrGlyphAccessor that will be used to access the components of this glyph.
bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
baseline
Type: SystemInt32
The baseline of the text in pixels relative to the image.
color
Type: System.DrawingColor
The color of the glyph.
Remarks
Avoid calling the constructor directly. Use the OcrGlyph method in the Factory property.
See Also

Reference

OcrGlyph Class
OcrGlyph Overload
Atalasoft.Ocr Namespace


OcrGlyph Properties

The OcrGlyph type exposes the following members.

Properties
 | Name | Description
Public property | Accessor | The IOcrGlyphAccessor associated with this object.
Public property | Alternates | The best alternatives to this glyph that were considered by the engine
Public property | Baseline | The baseline of the text, in pixels from the top of the source image.
Public property | Bounds | The bounding box of the glyph, in pixels coordinates in the source image.
Public property | Char | This glyph, as a Unicode character
Public property | Codepoint | The Unicode codepoint of this glyph.
Public property | Color | The color of this glyph.
Public property | Confidence | The confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).
 | DefaultImprintFontName | The default font to use. Default is Arial.
Public property | IsSingleton | True if this glyph represents a single character.
Public property | Text | This glyph, as a string
Public property | TextKind | The Kind of text for the OcrLine. MachinePrint, HandPrint, Any. OcrTextKind
Top
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Accessor Property

OcrGlyphAccessor Property

The IOcrGlyphAccessor associated with this object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IOcrGlyphAccessor Accessor { get; }
Public ReadOnly Property Accessor As IOcrGlyphAccessor
    Get

Property Value

Type: IOcrGlyphAccessor
An object of type IOcrGlyphAccessor that is used to access this object.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Alternates Property

OcrGlyphAlternates Property

The best alternatives to this glyph that were considered by the engine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyphCollection Alternates { get; }
Public ReadOnly Property Alternates As OcrGlyphCollection
    Get

Property Value

Type: OcrGlyphCollection
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Baseline Property

OcrGlyphBaseline Property

The baseline of the text, in pixels from the top of the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Baseline { get; set; }
Public Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Bounds Property

OcrGlyphBounds Property

The bounding box of the glyph, in pixels coordinates in the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; set; }
Public Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this glyph.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Char Property

OcrGlyphChar Property

This glyph, as a Unicode character

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public char Char { get; }
Public ReadOnly Property Char As Char
    Get

Property Value

Type: Char
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Codepoint Property

OcrGlyphCodepoint Property

The Unicode codepoint of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Codepoint { get; }
Public ReadOnly Property Codepoint As Integer
    Get

Property Value

Type: Int32
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Color Property

OcrGlyphColor Property

The color of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Confidence Property

OcrGlyphConfidence Property

The confidence with which this glyph was recognized by the engine, ranging from 0.0 (no confidence) to 1.0 (complete confidence).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Confidence { get; set; }
Public Property Confidence As Double
    Get
    Set

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
The initial value is provided by the engine.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.DefaultImprintFontName Property

OcrGlyphDefaultImprintFontName Property

The default font to use. Default is Arial.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string DefaultImprintFontName { get; set; }
Public Shared Property DefaultImprintFontName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.IsSingleton Property

OcrGlyphIsSingleton Property

True if this glyph represents a single character.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSingleton { get; }
Public ReadOnly Property IsSingleton As Boolean
    Get

Property Value

Type: Boolean
A boolean that indicates if this glyph represents a single character.
Remarks
Glyphs in typography may represent more than one individual character. A common example is a ligature - two or more characters joined into a single glyph. This property makes it possible to determine if that is the case in order to better reconstruct an image or to facilitate searching through the text.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.Text Property

OcrGlyphText Property

This glyph, as a string

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.TextKind Property

OcrGlyphTextKind Property

The Kind of text for the OcrLine. MachinePrint, HandPrint, Any. OcrTextKind

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextKind TextKind { get; set; }
Public Property TextKind As OcrTextKind
    Get
    Set

Property Value

Type: OcrTextKind
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph Methods

The OcrGlyph type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFont | The Font used for this page element.
Public method | GetFontFamily | The FontFamily of this glyph.
Public method | GetFontName | The name of the font of this glyph.
Public method | GetFontSize | The font size of this glyph.
Public method | GetFontStyle | The FontStyle of this glyph.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ResetConfidence | Resets the confidence to that provided by the engine.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.GetFont Method

OcrGlyphGetFont Method

The Font used for this page element.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font GetFont(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder
)
Public Function GetFont (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the source image.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.

Return Value

Type: Font
An object of type Font that represents the font of this glyph.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.GetFontFamily Method

OcrGlyphGetFontFamily Method

The FontFamily of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontFamily GetFontFamily(
    IFontMapper mapper
)
Public Function GetFontFamily (
    mapper As IFontMapper
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.

Return Value

Type: FontFamily
An object of type FontFamily.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.GetFontName Method

OcrGlyphGetFontName Method

The name of the font of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetFontName(
    IFontMapper mapper
)
Public Function GetFontName (
    mapper As IFontMapper
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.

Return Value

Type: String
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.GetFontSize Method

OcrGlyphGetFontSize Method

The font size of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float GetFontSize(
    Dpi imageResolution
)
Public Function GetFontSize (
    imageResolution As Dpi
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this glyph was taken.

Return Value

Type: Single
A floating point number that represents the size of this font in points.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.GetFontStyle Method

OcrGlyphGetFontStyle Method

The FontStyle of this glyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontStyle GetFontStyle(
    IFontMapper mapper
)
Public Function GetFontStyle (
    mapper As IFontMapper
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this glyph's font.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of this glyph.
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyph.ResetConfidence Method

OcrGlyphResetConfidence Method

Resets the confidence to that provided by the engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ResetConfidence()
Public Sub ResetConfidence
See Also

Reference

OcrGlyph Class
Atalasoft.Ocr Namespace


OcrGlyphCollection Class

Summary description for OcrLineCollection.
OcrGlyphCollection represents a standard collection of OcrGlyph objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrGlyphCollection

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrGlyphCollection : CollectionBase
<SerializableAttribute>
Public Class OcrGlyphCollection
    Inherits CollectionBase

The OcrGlyphCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrGlyphCollection | Initializes a new instance of the OcrGlyphCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the OcrGlyph at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an OcrGlyph to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrGlyph.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrGlyph in the collection.
Public method | Insert | Inserts an OcrGlyph into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Raises the [E:ElementChanged] event.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrGlyph from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

Atalasoft.Ocr Namespace
OcrGlyph Class


OcrGlyphCollection Constructor

Initializes a new instance of the OcrGlyphCollection class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyphCollection()
Public Sub New
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection Properties

The OcrGlyphCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the OcrGlyph at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.Item Property

OcrGlyphCollectionItem Property

Gets the OcrGlyph at the specified index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyph this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As OcrGlyph
    Get
    Set

Parameters

index
Type: SystemInt32
Index of the glyph.

Property Value

Type: OcrGlyph
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection Methods

The OcrGlyphCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an OcrGlyph to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrGlyph.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrGlyph in the collection.
Public method | Insert | Inserts an OcrGlyph into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Raises the [E:ElementChanged] event.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrGlyph from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.Add Method

OcrGlyphCollectionAdd Method

Adds an OcrGlyph to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    OcrGlyph value
)
Public Function Add (
    value As OcrGlyph
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrGlyph
The glyph to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.Contains Method

OcrGlyphCollectionContains Method

Determines whether the collection contains a specified OcrGlyph.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    OcrGlyph value
)
Public Function Contains (
    value As OcrGlyph
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrGlyph
The OcrGlyph to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.CopyTo Method

OcrGlyphCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    OcrGlyph[] array,
    int index
)
Public Sub CopyTo (
    array As OcrGlyph(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrOcrGlyph
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.IndexOf Method

OcrGlyphCollectionIndexOf Method

Returns the index of a specified OcrGlyph in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    OcrGlyph value
)
Public Function IndexOf (
    value As OcrGlyph
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrGlyph
The OcrGlyph to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.Insert Method

OcrGlyphCollectionInsert Method

Inserts an OcrGlyph into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    OcrGlyph value
)
Public Sub Insert (
    index As Integer,
    value As OcrGlyph
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrGlyph should be inserted.
value
Type: Atalasoft.OcrOcrGlyph
The OcrGlyph to insert.

Return Value

Type:
n/a
Remarks
If index is equal to the size of the collection, value is appended to the collection.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.OnClearComplete Method

OcrGlyphCollectionOnClearComplete Method

Performs additional custom processes after clearing the contents of the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.OnElementChanged Method

OcrGlyphCollectionOnElementChanged Method

Raises the [E:ElementChanged] event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnElementChanged(
    OcrPageElementEventArgs args
)
Protected Sub OnElementChanged (
    args As OcrPageElementEventArgs
)

Parameters

args
Type: Atalasoft.OcrOcrPageElementEventArgs
The OcrPageElementEventArgs instance containing the event data.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.OnInsertComplete Method

OcrGlyphCollectionOnInsertComplete Method

Performs additional custom processes after inserting a new element into the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which to insert value.
value
Type: SystemObject
The new value of the element at index.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.OnRemoveComplete Method

OcrGlyphCollectionOnRemoveComplete Method

Performs additional custom processes after removing an element from the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which value can be found.
value
Type: SystemObject
The value of the element to remove from index.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.OnSetComplete Method

OcrGlyphCollectionOnSetComplete Method

Performs additional custom processes after setting a value in the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which oldValue can be found.
oldValue
Type: SystemObject
The value to replace with newValue.
newValue
Type: SystemObject
The new value of the element at index.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.Remove Method

OcrGlyphCollectionRemove Method

Removes the first occurrence of the specified OcrGlyph from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    OcrGlyph value
)
Public Sub Remove (
    value As OcrGlyph
)

Parameters

value
Type: Atalasoft.OcrOcrGlyph
The OcrGlyph to remove.

Return Value

Type:
n/a
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection Events

The OcrGlyphCollection type exposes the following members.

Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphCollection.ElementChanged Event

OcrGlyphCollectionElementChanged Event

This event is triggered when a change has been made to this collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageElementChangedEventHandler ElementChanged
Public Event ElementChanged As OcrPageElementChangedEventHandler

Value

Type: Atalasoft.OcrOcrPageElementChangedEventHandler
Remarks
This event is used for internal maintenance of bounding boxes and confidence levels. It is typically not necessary for client code to hook into it.
See Also

Reference

OcrGlyphCollection Class
Atalasoft.Ocr Namespace


OcrGlyphMetrics Class

OcrGlyphMetrics is a utility class for statistically determining the baseline or other general metrics of a text from its bounding box or height.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrGlyphMetrics

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrGlyphMetrics
Public Class OcrGlyphMetrics

The OcrGlyphMetrics type exposes the following members.

Constructors
 | Name | Description
Public method | OcrGlyphMetrics | Initializes a new instance of the OcrGlyphMetrics class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAscentHeightRatio | Returns the ratio of character ascent to character height.
 | GetBaseLine | Get the approximate baseline of a character.
 | GetFontAscent | Gets the statistical ascent of an entire font from given character.
 | GetFontAscentHeightRatio | Get the ratio of an entire font's statistical ascent to its height.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class is typically needed by creators of new OcrEngine objects.
See Also

Reference

Atalasoft.Ocr Namespace


OcrGlyphMetrics Constructor

Initializes a new instance of the OcrGlyphMetrics class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyphMetrics()
Public Sub New
See Also

Reference

OcrGlyphMetrics Class
Atalasoft.Ocr Namespace


OcrGlyphMetrics Methods

The OcrGlyphMetrics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAscentHeightRatio | Returns the ratio of character ascent to character height.
 | GetBaseLine | Get the approximate baseline of a character.
 | GetFontAscent | Gets the statistical ascent of an entire font from given character.
 | GetFontAscentHeightRatio | Get the ratio of an entire font's statistical ascent to its height.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrGlyphMetrics Class
Atalasoft.Ocr Namespace


OcrGlyphMetrics.GetAscentHeightRatio Method

OcrGlyphMetricsGetAscentHeightRatio Method

Returns the ratio of character ascent to character height.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static double GetAscentHeightRatio(
    char c
)
Public Shared Function GetAscentHeightRatio (
    c As Char
) As Double

Parameters

c
Type: SystemChar
The character to be measured.

Return Value

Type: Double
A unitless value that represents the statistical ratio of a characters ascent to its overall height. This can be used to determine the fontsize of a character.
Remarks
This value is determined from a statistical range of values. It will not be completely accurate.
See Also

Reference

OcrGlyphMetrics Class
Atalasoft.Ocr Namespace


OcrGlyphMetrics.GetBaseLine Method

OcrGlyphMetricsGetBaseLine Method

Get the approximate baseline of a character.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetBaseLine(
    char c,
    int top,
    int bottom
)
Public Shared Function GetBaseLine (
    c As Char,
    top As Integer,
    bottom As Integer
) As Integer

Parameters

c
Type: SystemChar
The character to be measured.
top
Type: SystemInt32
The topmost coordinate of the character.
bottom
Type: SystemInt32
The bottommost coordinate of the character.

Return Value

Type: Int32
A value representing the baseline of the character in the same coordinate system as top and bottom.
Remarks
This value is determined from a statistical range of values. It will not be completely accurate.
See Also

Reference

OcrGlyphMetrics Class
Atalasoft.Ocr Namespace


OcrGlyphMetrics.GetFontAscent Method

OcrGlyphMetricsGetFontAscent Method

Gets the statistical ascent of an entire font from given character.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int GetFontAscent(
    char c,
    int top,
    int bottom
)
Public Shared Function GetFontAscent (
    c As Char,
    top As Integer,
    bottom As Integer
) As Integer

Parameters

c
Type: SystemChar
The character to be measured.
top
Type: SystemInt32
The topmost coordinate of the character.
bottom
Type: SystemInt32
The bottommost coordinate of the character.

Return Value

Type: Int32
A value representing the ascent of the character in the same coordinate system as top and bottom.
Remarks
This value is determined from a statistical range of values. It will not be completely accurate.
See Also

Reference

OcrGlyphMetrics Class
Atalasoft.Ocr Namespace


OcrGlyphMetrics.GetFontAscentHeightRatio Method

OcrGlyphMetricsGetFontAscentHeightRatio Method

Get the ratio of an entire font's statistical ascent to its height.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static double GetFontAscentHeightRatio(
    char c
)
Public Shared Function GetFontAscentHeightRatio (
    c As Char
) As Double

Parameters

c
Type: SystemChar
The character to be measured.

Return Value

Type: Double
A double representing the ratio of an entire font's statistical ascent to its height.
Remarks
This value is determined from a statistical range of values. It will not be completely accurate.
See Also

Reference

OcrGlyphMetrics Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs Class

Event argument used for pre-processing OCR events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.OcrOcrImagePreprocessingEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrImagePreprocessingEventArgs : EventArgs
Public Class OcrImagePreprocessingEventArgs
    Inherits EventArgs

The OcrImagePreprocessingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OcrImagePreprocessingEventArgs | Creates a new instance of OcrImagePreprocessingEventArgs.
Top
Properties
 | Name | Description
Public property | ImageIn | The image passed into the event
Public property | ImageOut | Set this to a new image to change the current image for OCR
Public property | Options | Pre-processing options that the engine should apply.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs Constructor

Creates a new instance of OcrImagePreprocessingEventArgs.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrImagePreprocessingEventArgs(
    AtalaImage image,
    OcrPreprocessingOptions options
)
Public Sub New (
    image As AtalaImage,
    options As OcrPreprocessingOptions
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to pass into the event.
options
Type: Atalasoft.OcrOcrPreprocessingOptions
pre-processing options
See Also

Reference

OcrImagePreprocessingEventArgs Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs Properties

The OcrImagePreprocessingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ImageIn | The image passed into the event
Public property | ImageOut | Set this to a new image to change the current image for OCR
Public property | Options | Pre-processing options that the engine should apply.
Top
See Also

Reference

OcrImagePreprocessingEventArgs Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs.ImageIn Property

OcrImagePreprocessingEventArgsImageIn Property

The image passed into the event

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ImageIn { get; }
Public ReadOnly Property ImageIn As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

OcrImagePreprocessingEventArgs Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs.ImageOut Property

OcrImagePreprocessingEventArgsImageOut Property

Set this to a new image to change the current image for OCR

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage ImageOut { get; set; }
Public Property ImageOut As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
See Also

Reference

OcrImagePreprocessingEventArgs Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs.Options Property

OcrImagePreprocessingEventArgsOptions Property

Pre-processing options that the engine should apply.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPreprocessingOptions Options { get; }
Public ReadOnly Property Options As OcrPreprocessingOptions
    Get

Property Value

Type: OcrPreprocessingOptions
See Also

Reference

OcrImagePreprocessingEventArgs Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventArgs Methods

The OcrImagePreprocessingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrImagePreprocessingEventArgs Class
Atalasoft.Ocr Namespace


OcrImagePreprocessingEventHandler Delegate

The OcrImagePreprocessingEventHandler delegate defines the event fired during OCR pre-processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OcrImagePreprocessingEventHandler(
    Object sender,
    OcrImagePreprocessingEventArgs e
)
Public Delegate Sub OcrImagePreprocessingEventHandler (
    sender As Object,
    e As OcrImagePreprocessingEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.OcrOcrImagePreprocessingEventArgs
See Also

Reference

Atalasoft.Ocr Namespace


OcrImageRegion Class

This class represents an Image contained within a page.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrImageRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrImageRegion : OcrRegion
Public Class OcrImageRegion
    Inherits OcrRegion

The OcrImageRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OcrImageRegion(Rectangle, AtalaImage) | Initializes a new instance of the OcrImageRegion class.
Public method | OcrImageRegion(AtalaImage, Boolean) | Initializes a new instance of the OcrImageRegion class.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Initializes a new instance of the OcrImageRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Image | Gets the image associated with this OcrImageRegion.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrImageRegion Constructor

Overload List
 | Name | Description
Public method | OcrImageRegion(Rectangle, AtalaImage) | Initializes a new instance of the OcrImageRegion class.
Public method | OcrImageRegion(AtalaImage, Boolean) | Initializes a new instance of the OcrImageRegion class.
Public method | OcrImageRegion(PolygonF, AtalaImage) | Initializes a new instance of the OcrImageRegion class.
Top
See Also

Reference

OcrImageRegion Class
Atalasoft.Ocr Namespace


OcrImageRegion Constructor (Rectangle, AtalaImage)

Initializes a new instance of the OcrImageRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrImageRegion(
    Rectangle bounds,
    AtalaImage parentImage
)
Public Sub New (
    bounds As Rectangle,
    parentImage As AtalaImage
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.
parentImage
Type: Atalasoft.ImagingAtalaImage
The image from which this image will be taken.

Return Value

Type:
A new OcrImageRegion object.
Remarks

This constructor will make a new image by cropping the parent image to the given bounds.

In typical usage, this constructor should not be called directly. Instead, use the OcrImageRegion method contained in the Factory property of OcrEngine.

See Also

Reference

OcrImageRegion Class
OcrImageRegion Overload
Atalasoft.Ocr Namespace


OcrImageRegion Constructor (AtalaImage, Boolean)

Initializes a new instance of the OcrImageRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrImageRegion(
    AtalaImage parentImage,
    bool shouldCopy
)
Public Sub New (
    parentImage As AtalaImage,
    shouldCopy As Boolean
)

Parameters

parentImage
Type: Atalasoft.ImagingAtalaImage
The image from which this image will be taken.
shouldCopy
Type: SystemBoolean
If shouldCopy is true, this constructor will make a copy of the image provided instead of using it directly.
Remarks

This constructor will make a new image by cropping the parent image to the given bounds.

In typical usage, this constructor should not be called directly. Instead, use the OcrImageRegion method contained in the Factory property of OcrEngine.

See Also

Reference

OcrImageRegion Class
OcrImageRegion Overload
Atalasoft.Ocr Namespace


OcrImageRegion Constructor (PolygonF, AtalaImage)

Initializes a new instance of the OcrImageRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrImageRegion(
    PolygonF bounds,
    AtalaImage parentImage
)
Public Sub New (
    bounds As PolygonF,
    parentImage As AtalaImage
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.
parentImage
Type: Atalasoft.ImagingAtalaImage
The image from which this image will be taken.

Return Value

Type:
A new OcrImageRegion object.
Remarks

This constructor will make a new image by cropping the parent image to the given bounds.

In typical usage, this constructor should not be called directly. Instead, use the OcrImageRegion method contained in the Factory property of OcrEngine.

See Also

Reference

OcrImageRegion Class
OcrImageRegion Overload
Atalasoft.Ocr Namespace


OcrImageRegion Properties

The OcrImageRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Image | Gets the image associated with this OcrImageRegion.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Top
See Also

Reference

OcrImageRegion Class
Atalasoft.Ocr Namespace


OcrImageRegion.Image Property

OcrImageRegionImage Property

Gets the image associated with this OcrImageRegion.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; set; }
Public Property Image As AtalaImage
    Get
    Set

Property Value

Type: AtalaImage
An AtalaImage that represents the image.
See Also

Reference

OcrImageRegion Class
Atalasoft.Ocr Namespace


OcrImageRegion Methods

The OcrImageRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrImageRegion Class
Atalasoft.Ocr Namespace


OcrLine Class

Summary description for OcrLine.
OcrLine represents lines of text contained within a text region on a page.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrLine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrLine : MarshalByRefObject
Public Class OcrLine
    Inherits MarshalByRefObject

The OcrLine type exposes the following members.

Constructors
 | Name | Description
Public method | OcrLine | Construct a new OcrLine object.
Top
Properties
 | Name | Description
Public property | Accessor | This property provides the IOcrLineAccessor associated with this object.
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the line in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire line.
Public property | Text | Returns the text of the line as a string.
Public property | TextKind | The Kind of text for the OcrLine. MachinePrint, HandPrint, Any. OcrTextKind
Public property | Words | Gets an OcrWordCollection representing the words that make up this line of text.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line of text.
Public method | GetFontAt | Returns the Font used for this page element.
Public method | GetFontColorAt | Get the color of a glyph within a line.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a line of text.
Public method | GetFontNameAt | Get the name of the font for a glyph in a line.
Public method | GetFontSizeAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box for this line.
Public method | ResetConfidence | Resets the confidence of the line to that provided by the engine.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this line of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrLine Constructor

Construct a new OcrLine object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrLine(
    IOcrLineAccessor accessor,
    Rectangle bounds,
    int baseline
)
Public Sub New (
    accessor As IOcrLineAccessor,
    bounds As Rectangle,
    baseline As Integer
)

Parameters

accessor
Type: Atalasoft.OcrIOcrLineAccessor
The IOcrLineAccessor that will be used to access data for this object.
bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
baseline
Type: SystemInt32
The baseline of the text in pixels relative to the image.

Return Value

Type:
A new OcrLine object.
Remarks
Avoid calling the constructor directly. Instead use the OcrLine method in the Factory property.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine Properties

The OcrLine type exposes the following members.

Properties
 | Name | Description
Public property | Accessor | This property provides the IOcrLineAccessor associated with this object.
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the line in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire line.
Public property | Text | Returns the text of the line as a string.
Public property | TextKind | The Kind of text for the OcrLine. MachinePrint, HandPrint, Any. OcrTextKind
Public property | Words | Gets an OcrWordCollection representing the words that make up this line of text.
Top
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.Accessor Property

OcrLineAccessor Property

This property provides the IOcrLineAccessor associated with this object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IOcrLineAccessor Accessor { get; }
Public ReadOnly Property Accessor As IOcrLineAccessor
    Get

Property Value

Type: IOcrLineAccessor
An object of type IOcrLineAccessor to access the data for this object.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.Baseline Property

OcrLineBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int Baseline { get; set; }
Public Overridable Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.Bounds Property

OcrLineBounds Property

This property represents the bounding box of the line in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; set; }
Public Overridable Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this line.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.Confidence Property

OcrLineConfidence Property

This property represents the confidence of recognition of the entire line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Confidence { get; set; }
Public Property Confidence As Double
    Get
    Set

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
This value is calculated as the average confidence of all the glyphs in the line.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.Text Property

OcrLineText Property

Returns the text of the line as a string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string Text { get; }
Public Overridable ReadOnly Property Text As String
    Get

Property Value

Type: String
A string representing the text of the line.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.TextKind Property

OcrLineTextKind Property

The Kind of text for the OcrLine. MachinePrint, HandPrint, Any. OcrTextKind

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextKind TextKind { get; set; }
Public Property TextKind As OcrTextKind
    Get
    Set

Property Value

Type: OcrTextKind
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.Words Property

OcrLineWords Property

Gets an OcrWordCollection representing the words that make up this line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrWordCollection Words { get; }
Public Overridable ReadOnly Property Words As OcrWordCollection
    Get

Property Value

Type: OcrWordCollection
An object of type OcrWordCollection.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine Methods

The OcrLine type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a line of text.
Public method | GetFontAt | Returns the Font used for this page element.
Public method | GetFontColorAt | Get the color of a glyph within a line.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a line of text.
Public method | GetFontNameAt | Get the name of the font for a glyph in a line.
Public method | GetFontSizeAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a line.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box for this line.
Public method | ResetConfidence | Resets the confidence of the line to that provided by the engine.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this line of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetConfidenceAt Method

OcrLineGetConfidenceAt Method

Get the confidence of recognition at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double GetConfidenceAt(
    int i
)
Public Overridable Function GetConfidenceAt (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Double
A double representing the confidence of recognition of the specified glyph ranging from 0.0 (no confidence) to 1.0 (complete confidence).
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetFontAt Method

OcrLineGetFontAt Method

Returns the Font used for this page element.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Font GetFontAt(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder,
    int i
)
Public Overridable Function GetFontAt (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder,
    i As Integer
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this line was taken.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Font
The Font that represents this glyph.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetFontColorAt Method

OcrLineGetFontColorAt Method

Get the color of a glyph within a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Color GetFontColorAt(
    int i
)
Public Overridable Function GetFontColorAt (
    i As Integer
) As Color

Parameters

i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Color
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetFontFamilyAt Method

OcrLineGetFontFamilyAt Method

Get the FontFamily at a particular point in a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontFamily GetFontFamilyAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontFamilyAt (
    mapper As IFontMapper,
    i As Integer
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: FontFamily
An object of type FontFamily that represents the font family of the glyph.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetFontNameAt Method

OcrLineGetFontNameAt Method

Get the name of the font for a glyph in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string GetFontNameAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontNameAt (
    mapper As IFontMapper,
    i As Integer
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: String
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetFontSizeAt Method

OcrLineGetFontSizeAt Method

This property represents the FontStyle of a glyph at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual float GetFontSizeAt(
    Dpi imageResolution,
    int i
)
Public Overridable Function GetFontSizeAt (
    imageResolution As Dpi,
    i As Integer
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this line was taken.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: Single
A floating point number that represents the size of the glyph in points.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.GetFontStyleAt Method

OcrLineGetFontStyleAt Method

This property represents the FontStyle of a glyph at a particular point in a line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual FontStyle GetFontStyleAt(
    IFontMapper mapper,
    int i
)
Public Overridable Function GetFontStyleAt (
    mapper As IFontMapper,
    i As Integer
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
i
Type: SystemInt32
The index of the glyph within a line of text.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of the glyph.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.RecalculateBounds Method

OcrLineRecalculateBounds Method

Recalculates the bounding box for this line.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RecalculateBounds()
Public Sub RecalculateBounds
Remarks
This is a utility method that is used internally. Under most circumstances, there is no need to call this directly.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.ResetConfidence Method

OcrLineResetConfidence Method

Resets the confidence of the line to that provided by the engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ResetConfidence()
Public Sub ResetConfidence
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLine.StyleIsUniform Method

OcrLineStyleIsUniform Method

Check to see if the font and style are uniform across this line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual bool StyleIsUniform(
    IFontMapper mapper,
    IFontBuilder builder
)
Public Overridable Function StyleIsUniform (
    mapper As IFontMapper,
    builder As IFontBuilder
) As Boolean

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this line's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.

Return Value

Type: Boolean
True if the font family, style and size are the same throughout the line of text.
See Also

Reference

OcrLine Class
Atalasoft.Ocr Namespace


OcrLineCollection Class

Summary description for OcrLineCollection.
OcrLineCollection represents a standard collection of OcrLine objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrLineCollection

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrLineCollection : CollectionBase
<SerializableAttribute>
Public Class OcrLineCollection
    Inherits CollectionBase

The OcrLineCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrLineCollection | Initializes a new instance of the OcrLineCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for accessing item by index
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an OcrLine to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrLine.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrLine in the collection.
Public method | Insert | Inserts an OcrLine into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | This gets called after a clear is performed on the collection. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Called when an element changed event occurs
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | This gets called after an insert is performed on the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | This gets called after a remove is performed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | This gets called after a value is set in the collection. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrLine from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

Atalasoft.Ocr Namespace
OcrLine Class


OcrLineCollection Constructor

Initializes a new instance of the OcrLineCollection class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrLineCollection()
Public Sub New
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection Properties

The OcrLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for accessing item by index
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.Item Property

OcrLineCollectionItem Property

Allows for accessing item by index

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrLine this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As OcrLine
    Get
    Set

Parameters

index
Type: SystemInt32
integer used to retrieve item

Return Value

Type: OcrLine
An OcrLine at index
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection Methods

The OcrLineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an OcrLine to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrLine.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrLine in the collection.
Public method | Insert | Inserts an OcrLine into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | This gets called after a clear is performed on the collection. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Called when an element changed event occurs
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | This gets called after an insert is performed on the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | This gets called after a remove is performed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | This gets called after a value is set in the collection. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrLine from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.Add Method

OcrLineCollectionAdd Method

Adds an OcrLine to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    OcrLine value
)
Public Function Add (
    value As OcrLine
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrLine
The OcrLine to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.Contains Method

OcrLineCollectionContains Method

Determines whether the collection contains a specified OcrLine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    OcrLine value
)
Public Function Contains (
    value As OcrLine
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrLine
The OcrLine to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.CopyTo Method

OcrLineCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    OcrLine[] array,
    int index
)
Public Sub CopyTo (
    array As OcrLine(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrOcrLine
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.IndexOf Method

OcrLineCollectionIndexOf Method

Returns the index of a specified OcrLine in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    OcrLine value
)
Public Function IndexOf (
    value As OcrLine
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrLine
The OcrLine to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.Insert Method

OcrLineCollectionInsert Method

Inserts an OcrLine into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    OcrLine value
)
Public Sub Insert (
    index As Integer,
    value As OcrLine
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrLine should be inserted.
value
Type: Atalasoft.OcrOcrLine
The OcrLine to insert in the collection.

Return Value

Type:
n/a
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.OnClearComplete Method

OcrLineCollectionOnClearComplete Method

This gets called after a clear is performed on the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.OnElementChanged Method

OcrLineCollectionOnElementChanged Method

Called when an element changed event occurs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnElementChanged(
    OcrPageElementEventArgs args
)
Protected Sub OnElementChanged (
    args As OcrPageElementEventArgs
)

Parameters

args
Type: Atalasoft.OcrOcrPageElementEventArgs
The details of the changing element.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.OnInsertComplete Method

OcrLineCollectionOnInsertComplete Method

This gets called after an insert is performed on the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the newly added item.
value
Type: SystemObject
The value that was inserted in the collection.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.OnRemoveComplete Method

OcrLineCollectionOnRemoveComplete Method

This gets called after a remove is performed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The location of the item in the collection.
value
Type: SystemObject
The item that was removed.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.OnSetComplete Method

OcrLineCollectionOnSetComplete Method

This gets called after a value is set in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The location of the item in the collection.
oldValue
Type: SystemObject
The value at the index before the set was done.
newValue
Type: SystemObject
The value at the index after the set was done.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.Remove Method

OcrLineCollectionRemove Method

Removes the first occurrence of the specified OcrLine from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    OcrLine value
)
Public Sub Remove (
    value As OcrLine
)

Parameters

value
Type: Atalasoft.OcrOcrLine
The OcrLine to remove from the collection.

Return Value

Type:
n/a
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection Events

The OcrLineCollection type exposes the following members.

Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrLineCollection.ElementChanged Event

OcrLineCollectionElementChanged Event

This event is triggered when a change has been made to this collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageElementChangedEventHandler ElementChanged
Public Event ElementChanged As OcrPageElementChangedEventHandler

Value

Type: Atalasoft.OcrOcrPageElementChangedEventHandler
Remarks
This event is used for internal maintenance of bounding boxes and confidence levels. It is typically not necessary for client code to hook into it.
See Also

Reference

OcrLineCollection Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions Class

This is a class built to hold constants to use as bit fields for native preprocessing options.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrNativePreprocessingOptions

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrNativePreprocessingOptions
Public Class OcrNativePreprocessingOptions

The OcrNativePreprocessingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OcrNativePreprocessingOptions | Initializes a new instance of the OcrNativePreprocessingOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AutoRotate | Auto-rotate image before processing.
Deskew | Deskew image before processing.
Despeckle | Despeckle image before processing.
FlipLeftRight | File image left to right before processing.
Invert | Invert image before processing.
None | No preprocessing.
ToBilevel | Convert image to black and white before processing.
Top
Remarks
Bits 0-15 are reserved for engine-specific features. Developers who need to define project-specific constants can use bits 16-31. Since %%company%% may need more of the bits in the future, it is recommended that developers start from bit 31 and work down instead of from bit 16 and work up.
See Also

Reference

Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions Constructor

Initializes a new instance of the OcrNativePreprocessingOptions class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrNativePreprocessingOptions()
Public Sub New
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions Methods

The OcrNativePreprocessingOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions Fields

The OcrNativePreprocessingOptions type exposes the following members.

Fields
Name | Description
AutoRotate | Auto-rotate image before processing.
Deskew | Deskew image before processing.
Despeckle | Despeckle image before processing.
FlipLeftRight | File image left to right before processing.
Invert | Invert image before processing.
None | No preprocessing.
ToBilevel | Convert image to black and white before processing.
Top
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.AutoRotate Field

OcrNativePreprocessingOptionsAutoRotate Field

Auto-rotate image before processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int AutoRotate = 2
Public Const AutoRotate As Integer = 2

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.Deskew Field

OcrNativePreprocessingOptionsDeskew Field

Deskew image before processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int Deskew = 1
Public Const Deskew As Integer = 1

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.Despeckle Field

OcrNativePreprocessingOptionsDespeckle Field

Despeckle image before processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int Despeckle = 4
Public Const Despeckle As Integer = 4

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.FlipLeftRight Field

OcrNativePreprocessingOptionsFlipLeftRight Field

File image left to right before processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int FlipLeftRight = 32
Public Const FlipLeftRight As Integer = 32

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.Invert Field

OcrNativePreprocessingOptionsInvert Field

Invert image before processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int Invert = 16
Public Const Invert As Integer = 16

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.None Field

OcrNativePreprocessingOptionsNone Field

No preprocessing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int None = 0
Public Const None As Integer = 0

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrNativePreprocessingOptions.ToBilevel Field

OcrNativePreprocessingOptionsToBilevel Field

Convert image to black and white before processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const int ToBilevel = 8
Public Const ToBilevel As Integer = 8

Field Value

Type: Int32
See Also

Reference

OcrNativePreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPage Class

The OcrPage object represents a page within a document recognized by OCR.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrPage

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrPage
<SerializableAttribute>
Public Class OcrPage

The OcrPage type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPage | Initializes a new instance of the OcrPage class
Public method | OcrPage(AtalaImage) | Constructs an OcrPage with dimensions and resolution that match the supplied AtalaImage.
Public method | OcrPage(Rectangle, Dpi) | Constructs a page representing an arbitrary rectangle
Public method | OcrPage(Int32, Int32, AtalaImage) | Construct an OcrPage with a non-zero top corner.
Public method | OcrPage(Int32, Int32, Dpi) | Constructs an OcrPage with the given width and height and resolution.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds of this page
Public property | Height | This property gets or sets the height of the OcrPage.
Public property | Metadata | Gets the metadata associated with this page
Public property | Regions | This property represents a collection of all the page elements in this page.
Public property | Resolution | This property represents the overall resolution of the page.
Public property | Width | This property sets or gets the width of the page.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextString | Returns textual information from the page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrPage Constructor

Constructs a new OcrPage object.
Overload List
 | Name | Description
Public method | OcrPage | Initializes a new instance of the OcrPage class
Public method | OcrPage(AtalaImage) | Constructs an OcrPage with dimensions and resolution that match the supplied AtalaImage.
Public method | OcrPage(Rectangle, Dpi) | Constructs a page representing an arbitrary rectangle
Public method | OcrPage(Int32, Int32, AtalaImage) | Construct an OcrPage with a non-zero top corner.
Public method | OcrPage(Int32, Int32, Dpi) | Constructs an OcrPage with the given width and height and resolution.
Top
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage Constructor

Initializes a new instance of the OcrPage class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage()
Public Sub New

Return Value

Type:
A new OcrPage object.
Remarks
Avoid calling the constructor directly. Instead use the OcrPage method in the Factory property of an OcrEngine.
See Also

Reference

OcrPage Class
OcrPage Overload
Atalasoft.Ocr Namespace


OcrPage Constructor (AtalaImage)

Constructs an OcrPage with dimensions and resolution that match the supplied AtalaImage.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage(
    AtalaImage image
)
Public Sub New (
    image As AtalaImage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image that is used to define this page.

Return Value

Type:
A new OcrPage object.
See Also

Reference

OcrPage Class
OcrPage Overload
Atalasoft.Ocr Namespace


OcrPage Constructor (Rectangle, Dpi)

Constructs a page representing an arbitrary rectangle

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage(
    Rectangle bounds,
    Dpi resolution
)
Public Sub New (
    bounds As Rectangle,
    resolution As Dpi
)

Parameters

bounds
Type: System.DrawingRectangle
The bounds for the page
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page
See Also

Reference

OcrPage Class
OcrPage Overload
Atalasoft.Ocr Namespace


OcrPage Constructor (Int32, Int32, AtalaImage)

Construct an OcrPage with a non-zero top corner.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage(
    int left,
    int top,
    AtalaImage image
)
Public Sub New (
    left As Integer,
    top As Integer,
    image As AtalaImage
)

Parameters

left
Type: SystemInt32
The position of the left edge of the page
top
Type: SystemInt32
The position of the top edge of the page
image
Type: Atalasoft.ImagingAtalaImage
The image from which this page is being constructed
See Also

Reference

OcrPage Class
OcrPage Overload
Atalasoft.Ocr Namespace


OcrPage Constructor (Int32, Int32, Dpi)

Constructs an OcrPage with the given width and height and resolution.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage(
    int width,
    int height,
    Dpi resolution
)
Public Sub New (
    width As Integer,
    height As Integer,
    resolution As Dpi
)

Parameters

width
Type: SystemInt32
The width of the page in pixels.
height
Type: SystemInt32
The height of the page in pixels.
resolution
Type: Atalasoft.ImagingDpi
The resolution of the page.

Return Value

Type:
A new OcrPage object.
See Also

Reference

OcrPage Class
OcrPage Overload
Atalasoft.Ocr Namespace


OcrPage Properties

The OcrPage type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds of this page
Public property | Height | This property gets or sets the height of the OcrPage.
Public property | Metadata | Gets the metadata associated with this page
Public property | Regions | This property represents a collection of all the page elements in this page.
Public property | Resolution | This property represents the overall resolution of the page.
Public property | Width | This property sets or gets the width of the page.
Top
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.Bounds Property

OcrPageBounds Property

Gets or sets the bounds of this page

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; set; }
Public Overridable Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.Height Property

OcrPageHeight Property

This property gets or sets the height of the OcrPage.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set

Property Value

Type: Int32
An integer representing the height of the page in pixels.
Remarks
Changing the dimensions of a page with existing page elements doesn't change the page elements.
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.Metadata Property

OcrPageMetadata Property

Gets the metadata associated with this page

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Hashtable Metadata { get; }
Public ReadOnly Property Metadata As Hashtable
    Get

Property Value

Type: Hashtable
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.Regions Property

OcrPageRegions Property

This property represents a collection of all the page elements in this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrRegionCollection Regions { get; }
Public Overridable ReadOnly Property Regions As OcrRegionCollection
    Get

Property Value

Type: OcrRegionCollection
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.Resolution Property

OcrPageResolution Property

This property represents the overall resolution of the page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Dpi Resolution { get; set; }
Public Overridable Property Resolution As Dpi
    Get
    Set

Property Value

Type: Dpi
Remarks
Changing the resolution of a page with existing page elements doesn't change the page elements.
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.Width Property

OcrPageWidth Property

This property sets or gets the width of the page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set

Property Value

Type: Int32
An integer representing the width of the page in pixels.
Remarks
Changing the dimensions of a page with existing page elements doesn't change the page elements.
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage Methods

The OcrPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextString | Returns textual information from the page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPage.GetTextString Method

OcrPageGetTextString Method

Returns textual information from the page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetTextString(
    bool removeLineBreaks
)
Public Function GetTextString (
    removeLineBreaks As Boolean
) As String

Parameters

removeLineBreaks
Type: SystemBoolean
Specifies whether to remove line breaks (replace them with space character) or preserve them.

Return Value

Type: String
Textual representation of the page.
See Also

Reference

OcrPage Class
Atalasoft.Ocr Namespace


OcrPageCollection Class

Summary description for OcrPageCollection.
OcrPageCollection represents a standard collection of OcrPage objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrPageCollection

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrPageCollection : CollectionBase
<SerializableAttribute>
Public Class OcrPageCollection
    Inherits CollectionBase

The OcrPageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPageCollection | Constructs a new OcrPageCollection object.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the OcrPage at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an OcrPage to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrPage.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrPage in the collection.
Public method | Insert | Inserts an OcrPage into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Raises the [E:ElementChanged] event.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrPage from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

Atalasoft.Ocr Namespace
OcrPage Class


OcrPageCollection Constructor

Constructs a new OcrPageCollection object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageCollection()
Public Sub New

Return Value

Type:
A new OcrPageCollection object.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection Properties

The OcrPageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Gets the OcrPage at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.Item Property

OcrPageCollectionItem Property

Gets the OcrPage at the specified index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As OcrPage
    Get
    Set

Parameters

index
Type: SystemInt32
Index of the page.

Property Value

Type: OcrPage
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection Methods

The OcrPageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an OcrPage to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrPage.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrPage in the collection.
Public method | Insert | Inserts an OcrPage into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Raises the [E:ElementChanged] event.
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrPage from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.Add Method

OcrPageCollectionAdd Method

Adds an OcrPage to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    OcrPage value
)
Public Function Add (
    value As OcrPage
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrPage
The OcrPage to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.Contains Method

OcrPageCollectionContains Method

Determines whether the collection contains a specified OcrPage.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    OcrPage value
)
Public Function Contains (
    value As OcrPage
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrPage
The OcrPage to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.CopyTo Method

OcrPageCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    OcrPage[] array,
    int index
)
Public Sub CopyTo (
    array As OcrPage(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrOcrPage
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.IndexOf Method

OcrPageCollectionIndexOf Method

Returns the index of a specified OcrPage in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    OcrPage value
)
Public Function IndexOf (
    value As OcrPage
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrPage
The OcrPage to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.Insert Method

OcrPageCollectionInsert Method

Inserts an OcrPage into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    OcrPage value
)
Public Sub Insert (
    index As Integer,
    value As OcrPage
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrPage should be inserted.
value
Type: Atalasoft.OcrOcrPage
The OcrPage to insert in the collection.

Return Value

Type:
n/a
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.OnClearComplete Method

OcrPageCollectionOnClearComplete Method

Performs additional custom processes after clearing the contents of the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.OnElementChanged Method

OcrPageCollectionOnElementChanged Method

Raises the [E:ElementChanged] event.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnElementChanged(
    OcrPageElementEventArgs args
)
Protected Sub OnElementChanged (
    args As OcrPageElementEventArgs
)

Parameters

args
Type: Atalasoft.OcrOcrPageElementEventArgs
The OcrPageElementEventArgs instance containing the event data.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.OnInsertComplete Method

OcrPageCollectionOnInsertComplete Method

Performs additional custom processes after inserting a new element into the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which to insert value.
value
Type: SystemObject
The new value of the element at index.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.OnRemoveComplete Method

OcrPageCollectionOnRemoveComplete Method

Performs additional custom processes after removing an element from the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which value can be found.
value
Type: SystemObject
The value of the element to remove from index.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.OnSetComplete Method

OcrPageCollectionOnSetComplete Method

Performs additional custom processes after setting a value in the CollectionBase instance.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which oldValue can be found.
oldValue
Type: SystemObject
The value to replace with newValue.
newValue
Type: SystemObject
The new value of the element at index.
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.Remove Method

OcrPageCollectionRemove Method

Removes the first occurrence of the specified OcrPage from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    OcrPage value
)
Public Sub Remove (
    value As OcrPage
)

Parameters

value
Type: Atalasoft.OcrOcrPage
The OcrPage to remove from the collection.

Return Value

Type:
n/a
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection Events

The OcrPageCollection type exposes the following members.

Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageCollection.ElementChanged Event

OcrPageCollectionElementChanged Event

This event is triggered when a change has been made to this collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageElementChangedEventHandler ElementChanged
Public Event ElementChanged As OcrPageElementChangedEventHandler

Value

Type: Atalasoft.OcrOcrPageElementChangedEventHandler
See Also

Reference

OcrPageCollection Class
Atalasoft.Ocr Namespace


OcrPageConstructionEventArgs Class

OcrPageConstructionEventArgs is used for events that are fired before a page has started to be constructed and after it has finished being constructed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.OcrOcrPageConstructionEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrPageConstructionEventArgs : EventArgs
Public Class OcrPageConstructionEventArgs
    Inherits EventArgs

The OcrPageConstructionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPageConstructionEventArgs | Construct a new OcrPageConstructionEventArgs object.
Top
Properties
 | Name | Description
Public property | Image | This property gives access to the image that was or is being used to generate this page.
Public property | Page | This property gives access to the object that is being used to contain all the elements for this page.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageConstructionEventArgs Constructor

Construct a new OcrPageConstructionEventArgs object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageConstructionEventArgs(
    AtalaImage image,
    OcrPage page
)
Public Sub New (
    image As AtalaImage,
    page As OcrPage
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image that was or is being used to generate this page.
page
Type: Atalasoft.OcrOcrPage
The page object in the process of being constructed.

Return Value

Type:
A new OcrPageConstructionEventArgs object.
See Also

Reference

OcrPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


OcrPageConstructionEventArgs Properties

The OcrPageConstructionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Image | This property gives access to the image that was or is being used to generate this page.
Public property | Page | This property gives access to the object that is being used to contain all the elements for this page.
Top
See Also

Reference

OcrPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


OcrPageConstructionEventArgs.Image Property

OcrPageConstructionEventArgsImage Property

This property gives access to the image that was or is being used to generate this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

OcrPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


OcrPageConstructionEventArgs.Page Property

OcrPageConstructionEventArgsPage Property

This property gives access to the object that is being used to contain all the elements for this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage Page { get; }
Public ReadOnly Property Page As OcrPage
    Get

Property Value

Type: OcrPage
See Also

Reference

OcrPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


OcrPageConstructionEventArgs Methods

The OcrPageConstructionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


OcrPageConstructionEventHandler Delegate

The OcrPageConstructionEventHandler delegate defines the event that is fired before a page is fully constructed or has finished being constructed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OcrPageConstructionEventHandler(
    Object sender,
    OcrPageConstructionEventArgs e
)
Public Delegate Sub OcrPageConstructionEventHandler (
    sender As Object,
    e As OcrPageConstructionEventArgs
)

Parameters

sender
Type: SystemObject
The source of this event.
e
Type: Atalasoft.OcrOcrPageConstructionEventArgs
The arguments for this event.
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageElementAction Enumeration

This enumeration defines actions that are being taken on an Ocr page element.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrPageElementAction
Public Enumeration OcrPageElementAction
Members
Member name | Description
None | No action is being taken
Set | An element is being set
Insert | An element is being inserted
Remove | An element is being removed
Clear | An element is being cleared
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageElementChangedEventHandler Delegate

The OcrPageElementChangedEventHandler delegate defines the event that is fired after a page element has changed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OcrPageElementChangedEventHandler(
    Object sender,
    OcrPageElementEventArgs e
)
Public Delegate Sub OcrPageElementChangedEventHandler (
    sender As Object,
    e As OcrPageElementEventArgs
)

Parameters

sender
Type: SystemObject
The sender of the event, typically OcrEngine.
e
Type: Atalasoft.OcrOcrPageElementEventArgs
Parameters that describe the operation.
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageElementEventArgs Class

This object is used to pass information about changes in page elements
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.OcrOcrPageElementEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrPageElementEventArgs : EventArgs
Public Class OcrPageElementEventArgs
    Inherits EventArgs

The OcrPageElementEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPageElementEventArgs(Object, Int32, OcrPageElementAction) | Constructs a new OcrPageElementEventArgs object
Public method | OcrPageElementEventArgs(Object, Object, Int32, OcrPageElementAction) | Constructs a new OcrPageElementEventArgs object
Top
Properties
 | Name | Description
Public property | Action | The type of change made
Public property | Index | The index of the change (if applicable)
Public property | NewElement | The new element added (if applicable)
Public property | OldElement | The old element being removed or replaced (if applicable)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageElementEventArgs Constructor

Constructs a new OcrPageElementEventArgs object
Overload List
 | Name | Description
Public method | OcrPageElementEventArgs(Object, Int32, OcrPageElementAction) | Constructs a new OcrPageElementEventArgs object
Public method | OcrPageElementEventArgs(Object, Object, Int32, OcrPageElementAction) | Constructs a new OcrPageElementEventArgs object
Top
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageElementEventArgs Constructor (Object, Int32, OcrPageElementAction)

Constructs a new OcrPageElementEventArgs object

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageElementEventArgs(
    Object newElement,
    int index,
    OcrPageElementAction action
)
Public Sub New (
    newElement As Object,
    index As Integer,
    action As OcrPageElementAction
)

Parameters

newElement
Type: SystemObject
The new element being added/inserted/removed
index
Type: SystemInt32
The index of the element
action
Type: Atalasoft.OcrOcrPageElementAction
The action taken
See Also

Reference

OcrPageElementEventArgs Class
OcrPageElementEventArgs Overload
Atalasoft.Ocr Namespace


OcrPageElementEventArgs Constructor (Object, Object, Int32, OcrPageElementAction)

Constructs a new OcrPageElementEventArgs object

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageElementEventArgs(
    Object oldElement,
    Object newElement,
    int index,
    OcrPageElementAction action
)
Public Sub New (
    oldElement As Object,
    newElement As Object,
    index As Integer,
    action As OcrPageElementAction
)

Parameters

oldElement
Type: SystemObject
The old element that is being replaced
newElement
Type: SystemObject
The new element being added/inserted/removed
index
Type: SystemInt32
The index of the element
action
Type: Atalasoft.OcrOcrPageElementAction
The action taken
See Also

Reference

OcrPageElementEventArgs Class
OcrPageElementEventArgs Overload
Atalasoft.Ocr Namespace


OcrPageElementEventArgs Properties

The OcrPageElementEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Action | The type of change made
Public property | Index | The index of the change (if applicable)
Public property | NewElement | The new element added (if applicable)
Public property | OldElement | The old element being removed or replaced (if applicable)
Top
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageElementEventArgs.Action Property

OcrPageElementEventArgsAction Property

The type of change made

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageElementAction Action { get; }
Public ReadOnly Property Action As OcrPageElementAction
    Get

Property Value

Type: OcrPageElementAction
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageElementEventArgs.Index Property

OcrPageElementEventArgsIndex Property

The index of the change (if applicable)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageElementEventArgs.NewElement Property

OcrPageElementEventArgsNewElement Property

The new element added (if applicable)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object NewElement { get; }
Public ReadOnly Property NewElement As Object
    Get

Property Value

Type: Object
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageElementEventArgs.OldElement Property

OcrPageElementEventArgsOldElement Property

The old element being removed or replaced (if applicable)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object OldElement { get; }
Public ReadOnly Property OldElement As Object
    Get

Property Value

Type: Object
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageElementEventArgs Methods

The OcrPageElementEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPageElementEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventArgs Class

OcrPageLocationEventArgs represents information needed for handling a PageLocation event from an OcrEngine.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.OcrOcrPageLocationEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrPageLocationEventArgs : EventArgs
Public Class OcrPageLocationEventArgs
    Inherits EventArgs

The OcrPageLocationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPageLocationEventArgs | Constructs a new OcrPageLocationEventArgs object.
Top
Properties
 | Name | Description
Public property | Image | The image that is currently being scanned for locations.
Public property | RegionsIn | This property provides a collection of OcrRegion objects that have been identified by the OcrEngine as areas of interest within a page.
Public property | RegionsOut | This property represents a collection of OcrRegion objects that will be used for text or element recognition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageLocationEventArgs Constructor

Constructs a new OcrPageLocationEventArgs object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageLocationEventArgs(
    OcrRegionCollection regionsIn,
    AtalaImage image
)
Public Sub New (
    regionsIn As OcrRegionCollection,
    image As AtalaImage
)

Parameters

regionsIn
Type: Atalasoft.OcrOcrRegionCollection
A collection of regions that have been recognized on a page.
image
Type: Atalasoft.ImagingAtalaImage
The image that is currently being scanned for locations.

Return Value

Type:
A new OcrPageLocationEventArgs object.
See Also

Reference

OcrPageLocationEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventArgs Properties

The OcrPageLocationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Image | The image that is currently being scanned for locations.
Public property | RegionsIn | This property provides a collection of OcrRegion objects that have been identified by the OcrEngine as areas of interest within a page.
Public property | RegionsOut | This property represents a collection of OcrRegion objects that will be used for text or element recognition.
Top
See Also

Reference

OcrPageLocationEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventArgs.Image Property

OcrPageLocationEventArgsImage Property

The image that is currently being scanned for locations.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage Image { get; }
Public ReadOnly Property Image As AtalaImage
    Get

Property Value

Type: AtalaImage
See Also

Reference

OcrPageLocationEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventArgs.RegionsIn Property

OcrPageLocationEventArgsRegionsIn Property

This property provides a collection of OcrRegion objects that have been identified by the OcrEngine as areas of interest within a page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionCollection RegionsIn { get; }
Public ReadOnly Property RegionsIn As OcrRegionCollection
    Get

Property Value

Type: OcrRegionCollection
Remarks

Do not modify this collection or elements within it. In the best case, changes will be ignored.

Do not expect any of the regions to contain valid data except for the bounding rectangle.

See Also

Reference

OcrPageLocationEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventArgs.RegionsOut Property

OcrPageLocationEventArgsRegionsOut Property

This property represents a collection of OcrRegion objects that will be used for text or element recognition.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionCollection RegionsOut { get; set; }
Public Property RegionsOut As OcrRegionCollection
    Get
    Set

Property Value

Type: OcrRegionCollection
Remarks
This property will initially be null. If set to null, this instructs the engine to use region objects that it discovered with no changes. If this property is set to a non-null value, the contents of this collection will be used instead of those in RegionsIn. This allows a client to change, filter, or augment what has been discovered by an OcrEngine. Putting an OcrRegion into RegionsOut that the engine doesn't recognize will do nothing. In other words, you shouldn't ask an engine to recognize form elements if it doesn't have that capability.
See Also

Reference

OcrPageLocationEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventArgs Methods

The OcrPageLocationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPageLocationEventArgs Class
Atalasoft.Ocr Namespace


OcrPageLocationEventHandler Delegate

The OcrPageLocationEventHandler delegate defines the event fired during region location of a page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OcrPageLocationEventHandler(
    Object sender,
    OcrPageLocationEventArgs e
)
Public Delegate Sub OcrPageLocationEventHandler (
    sender As Object,
    e As OcrPageLocationEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Atalasoft.OcrOcrPageLocationEventArgs
The arguments for the event.
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageMetadataKey Enumeration

This enumeration is used to define keys for accessing page metadata.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrPageMetadataKey
Public Enumeration OcrPageMetadataKey
Members
Member name | Description
PageInfo | This key defines page info metadata
PdfPageInfo | This key defines page info metadata specific to PDF
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageProgressEventArgs Class

This class represents information about progress within OCR processing on a page.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
Atalasoft.OcrOcrPageProgressEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrPageProgressEventArgs : CancelEventArgs
Public Class OcrPageProgressEventArgs
    Inherits CancelEventArgs

The OcrPageProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPageProgressEventArgs | Constructs a new OcrPageProgressEventArgs object.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Progress | This property represents the total progress made on the current page.
Public property | Stage | This property represents the current stage of processing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageProgressEventArgs Constructor

Constructs a new OcrPageProgressEventArgs object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageProgressEventArgs(
    OcrPageStage stage,
    int progress
)
Public Sub New (
    stage As OcrPageStage,
    progress As Integer
)

Parameters

stage
Type: Atalasoft.OcrOcrPageStage
The current stage of processing.
progress
Type: SystemInt32
The total progress represented as an integer from 0 to 100.

Return Value

Type:
A new OcrPageProgressEventArgs object.
See Also

Reference

OcrPageProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrPageProgressEventArgs Properties

The OcrPageProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Progress | This property represents the total progress made on the current page.
Public property | Stage | This property represents the current stage of processing.
Top
See Also

Reference

OcrPageProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrPageProgressEventArgs.Progress Property

OcrPageProgressEventArgsProgress Property

This property represents the total progress made on the current page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Progress { get; }
Public ReadOnly Property Progress As Integer
    Get

Property Value

Type: Int32
An integer from 0 to 100 representing the total progress on this page as an percentage.
See Also

Reference

OcrPageProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrPageProgressEventArgs.Stage Property

OcrPageProgressEventArgsStage Property

This property represents the current stage of processing.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPageStage Stage { get; }
Public ReadOnly Property Stage As OcrPageStage
    Get

Property Value

Type: OcrPageStage
Remarks
The OcrPageStage enumeration represents the possible things that an OcrEnginemight do, not the things that an OcrEnginewill do. You should never assume that any given engine will send all or any particular OcrPageStage value or that they will be sent in any particular order. Instead, this should only by interpreted as an indication of what the engine just did or is in the process of doing.
See Also

Reference

OcrPageProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrPageProgressEventArgs Methods

The OcrPageProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPageProgressEventArgs Class
Atalasoft.Ocr Namespace


OcrPageProgressEventHandler Delegate

The OcrPageProgressEventHandler delegate defines the event fired during progress on recognition of a document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void OcrPageProgressEventHandler(
    Object sender,
    OcrPageProgressEventArgs e
)
Public Delegate Sub OcrPageProgressEventHandler (
    sender As Object,
    e As OcrPageProgressEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Atalasoft.OcrOcrPageProgressEventArgs
The arguments for the event.
See Also

Reference

Atalasoft.Ocr Namespace


OcrPageStage Enumeration

OcrPageStage represents the current stage of page translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrPageStage
Public Enumeration OcrPageStage
Members
Member name | Description
Preprocessing | Preprocessing has begun or is in progress.
Location | Location has begun or is in progress.
Analysis | Analysis has begun or is in progress.
Recognition | Recognition has begun or is in progress.
Export | Exporting has begun or is in progress.
Canceling | The engine is canceling the last operation.
Postprocessing | Post processing has begun or is in progress.
Spellchecking | Spellchecking has begun or is in progress.
Remarks
This enumeration is used by the PageProgress event in OcrEngine.
See Also

Reference

Atalasoft.Ocr Namespace


OcrPreprocessingOptions Class

Summary description for OcrPreProcessingOptions.
This class represents pre-processing options that will be applied to the core OcrEngine when recognizing.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrPreprocessingOptions

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrPreprocessingOptions : ICloneable
Public Class OcrPreprocessingOptions
    Implements ICloneable

The OcrPreprocessingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OcrPreprocessingOptions | Creates a new instance of OcrPreprocessingOptions.
Public method | OcrPreprocessingOptions(Int32) | Creates a new instance of OcrPreprocessingOptions passing in the 32-bit native mask of processing options.
Top
Properties
 | Name | Description
Public property | AutoRotate | Determines of the OCR engine should rotate the document based on text orientation.
Public property | Deskew | Determines if the OCR engine should deskew the image.
Public property | Despeckle | Determines if the engine should despeckle the image.
Public property | FlipLeftRight | Determines if the engine should flip the image left to right
Public property | Invert | Determines if the engine should invert the image
Public property | ToBilevel | Determines if the image should convert to black and white prior to OCR.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this object
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetOption | Retrieves the option using the integer mask.
Public method | GetOptionsMask | Gets the native pre-processing options from the value of properties in this class.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalClone | Returns a deep copy of the OcrPreProcessing options
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetOption | Sets an option using an integer mask
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class can be extended to add more options, in which case, the instance of the extended class should be passed into the various pre-processing events that are fired in OcrEngine.
See Also

Reference

Atalasoft.Ocr Namespace


OcrPreprocessingOptions Constructor

Overload List
 | Name | Description
Public method | OcrPreprocessingOptions | Creates a new instance of OcrPreprocessingOptions.
Public method | OcrPreprocessingOptions(Int32) | Creates a new instance of OcrPreprocessingOptions passing in the 32-bit native mask of processing options.
Top
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions Constructor

Creates a new instance of OcrPreprocessingOptions.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPreprocessingOptions()
Public Sub New
See Also

Reference

OcrPreprocessingOptions Class
OcrPreprocessingOptions Overload
Atalasoft.Ocr Namespace


OcrPreprocessingOptions Constructor (Int32)

Creates a new instance of OcrPreprocessingOptions passing in the 32-bit native mask of processing options.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPreprocessingOptions(
    int options
)
Public Sub New (
    options As Integer
)

Parameters

options
Type: SystemInt32
native pre-processing mask
See Also

Reference

OcrPreprocessingOptions Class
OcrPreprocessingOptions Overload
Atalasoft.Ocr Namespace


OcrPreprocessingOptions Properties

The OcrPreprocessingOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoRotate | Determines of the OCR engine should rotate the document based on text orientation.
Public property | Deskew | Determines if the OCR engine should deskew the image.
Public property | Despeckle | Determines if the engine should despeckle the image.
Public property | FlipLeftRight | Determines if the engine should flip the image left to right
Public property | Invert | Determines if the engine should invert the image
Public property | ToBilevel | Determines if the image should convert to black and white prior to OCR.
Top
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.AutoRotate Property

OcrPreprocessingOptionsAutoRotate Property

Determines of the OCR engine should rotate the document based on text orientation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoRotate { get; set; }
Public Property AutoRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.Deskew Property

OcrPreprocessingOptionsDeskew Property

Determines if the OCR engine should deskew the image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Deskew { get; set; }
Public Property Deskew As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
This option is on by default. When OnImageTransformation(OcrImagePreprocessingEventArgs) is invoked it's turned off so that if the engine itself has the capability to deskew, it will not be used.
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.Despeckle Property

OcrPreprocessingOptionsDespeckle Property

Determines if the engine should despeckle the image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Despeckle { get; set; }
Public Property Despeckle As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.FlipLeftRight Property

OcrPreprocessingOptionsFlipLeftRight Property

Determines if the engine should flip the image left to right

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FlipLeftRight { get; set; }
Public Property FlipLeftRight As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.Invert Property

OcrPreprocessingOptionsInvert Property

Determines if the engine should invert the image

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Invert { get; set; }
Public Property Invert As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.ToBilevel Property

OcrPreprocessingOptionsToBilevel Property

Determines if the image should convert to black and white prior to OCR.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ToBilevel { get; set; }
Public Property ToBilevel As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions Methods

The OcrPreprocessingOptions type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this object
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetOption | Retrieves the option using the integer mask.
Public method | GetOptionsMask | Gets the native pre-processing options from the value of properties in this class.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalClone | Returns a deep copy of the OcrPreProcessing options
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetOption | Sets an option using an integer mask
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.Clone Method

OcrPreprocessingOptionsClone Method

Creates a copy of this object

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of OcrPreprocessingOptions. The object must be cast.

Implements

ICloneableClone
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.GetOption Method

OcrPreprocessingOptionsGetOption Method

Retrieves the option using the integer mask.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool GetOption(
    int option
)
Protected Function GetOption (
    option As Integer
) As Boolean

Parameters

option
Type: SystemInt32
interger mask

Return Value

Type: Boolean
The option for the integer mask.
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.GetOptionsMask Method

OcrPreprocessingOptionsGetOptionsMask Method

Gets the native pre-processing options from the value of properties in this class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetOptionsMask()
Public Function GetOptionsMask As Integer

Return Value

Type: Int32
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.InternalClone Method

OcrPreprocessingOptionsInternalClone Method

Returns a deep copy of the OcrPreProcessing options

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual Object InternalClone()
Protected Overridable Function InternalClone As Object

Return Value

Type: Object
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrPreprocessingOptions.SetOption Method

OcrPreprocessingOptionsSetOption Method

Sets an option using an integer mask

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void SetOption(
    int option,
    bool val
)
Protected Sub SetOption (
    option As Integer,
    val As Boolean
)

Parameters

option
Type: SystemInt32
The integer mask to use
val
Type: SystemBoolean
The value to set the option
See Also

Reference

OcrPreprocessingOptions Class
Atalasoft.Ocr Namespace


OcrRegion Class

OcrRegion is a base class that represents the core functionality of a region within a page. It is abstract and therefore can't be instantiated on its own.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrBarcodeRegion
Atalasoft.OcrOcrContainerRegion
Atalasoft.OcrOcrFormElementRegion
Atalasoft.OcrOcrImageRegion
Atalasoft.OcrOcrTextRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class OcrRegion : MarshalByRefObject
Public MustInherit Class OcrRegion
    Inherits MarshalByRefObject

The OcrRegion type exposes the following members.

Constructors
 | Name | Description
Protected method | OcrRegion(Rectangle) | Initializes a new instance of the OcrRegion class.
Protected method | OcrRegion(PolygonF) | Initializes a new instance of the OcrRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not.
Public property | PolygonBounds | This property represents the bounds of the Region.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrRegion Constructor

Overload List
 | Name | Description
Protected method | OcrRegion(Rectangle) | Initializes a new instance of the OcrRegion class.
Protected method | OcrRegion(PolygonF) | Initializes a new instance of the OcrRegion class.
Top
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegion Constructor (Rectangle)

Initializes a new instance of the OcrRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrRegion(
    Rectangle bounds
)
Protected Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
Region bounding rectangle.
See Also

Reference

OcrRegion Class
OcrRegion Overload
Atalasoft.Ocr Namespace


OcrRegion Constructor (PolygonF)

Initializes a new instance of the OcrRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OcrRegion(
    PolygonF bounds
)
Protected Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
Region bounding rectangle.
See Also

Reference

OcrRegion Class
OcrRegion Overload
Atalasoft.Ocr Namespace


OcrRegion Properties

The OcrRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not.
Public property | PolygonBounds | This property represents the bounds of the Region.
Top
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegion.Bounds Property

OcrRegionBounds Property

This property represents the bounds of the Region in pixels.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual Rectangle Bounds { get; set; }
Public Overridable Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
The bounding Rectangle of the page element in pixels relative to the source image.
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegion.IsRectangular Property

OcrRegionIsRectangular Property

Gets a value indicating whether region is rectangular or not.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRectangular { get; }
Public ReadOnly Property IsRectangular As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegion.PolygonBounds Property

OcrRegionPolygonBounds Property

This property represents the bounds of the Region.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonF PolygonBounds { get; set; }
Public Property PolygonBounds As PolygonF
    Get
    Set

Property Value

Type: PolygonF
The bounding PolygonF of the page element relative to the source image.
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegion Methods

The OcrRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegion.MaskToBounds Method

OcrRegionMaskToBounds Method

Masks provided image to the region's bounds, optionally cropping masked area.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage MaskToBounds(
    AtalaImage image,
    bool crop
)
Public Function MaskToBounds (
    image As AtalaImage,
    crop As Boolean
) As AtalaImage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
Image to mask.
crop
Type: SystemBoolean
Indicates whether crop the image or not.

Return Value

Type: AtalaImage
Masked image.
See Also

Reference

OcrRegion Class
Atalasoft.Ocr Namespace


OcrRegionCollection Class

Summary description for OcrRegionCollection.
OcrRegionCollection represents a standard collection of OcrRegion objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrRegionCollection
Atalasoft.OcrOcrRegionCollectionT

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrRegionCollection : CollectionBase
<SerializableAttribute>
Public Class OcrRegionCollection
    Inherits CollectionBase

The OcrRegionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrRegionCollection | Constructs a new OcrRegionCollection object.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of an OcrRegion from the collection by an index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an OcrRegion to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrRegion.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrRegion in the collection.
Public method | Insert | Inserts an OcrRegion into the collection at specified position.
Protected method | IsValidForCollection | Returns whether the specified OcrRegion object is valid for addition to this collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | This gets called after a clear is performed on the collection. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Called when an element changed event occurs
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | This gets called after an insert is performed on the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | This gets called after a remove is performed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | This gets called after a value is set in the collection. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrRegion from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

Atalasoft.Ocr Namespace
OcrRegion Class


OcrRegionCollection Constructor

Constructs a new OcrRegionCollection object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionCollection()
Public Sub New

Return Value

Type:
A new OcrRegionCollection object.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection Properties

The OcrRegionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of an OcrRegion from the collection by an index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.Item Property

OcrRegionCollectionItem Property

Allows for retrieval of an OcrRegion from the collection by an index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegion this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As OcrRegion
    Get
    Set

Parameters

index
Type: SystemInt32
The location within the collection

Return Value

Type: OcrRegion
OcrRegion
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection Methods

The OcrRegionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an OcrRegion to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrRegion.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrRegion in the collection.
Public method | Insert | Inserts an OcrRegion into the collection at specified position.
Protected method | IsValidForCollection | Returns whether the specified OcrRegion object is valid for addition to this collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | This gets called after a clear is performed on the collection. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Called when an element changed event occurs
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | This gets called after an insert is performed on the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | This gets called after a remove is performed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | This gets called after a value is set in the collection. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrRegion from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.Add Method

OcrRegionCollectionAdd Method

Adds an OcrRegion to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    OcrRegion value
)
Public Function Add (
    value As OcrRegion
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrRegion
The OcrRegion to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.Contains Method

OcrRegionCollectionContains Method

Determines whether the collection contains a specified OcrRegion.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    OcrRegion value
)
Public Function Contains (
    value As OcrRegion
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrRegion
The OcrRegion to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.CopyTo Method

OcrRegionCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    OcrRegion[] array,
    int index
)
Public Sub CopyTo (
    array As OcrRegion(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrOcrRegion
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.IndexOf Method

OcrRegionCollectionIndexOf Method

Returns the index of a specified OcrRegion in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    OcrRegion value
)
Public Function IndexOf (
    value As OcrRegion
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrRegion
The OcrRegion to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.Insert Method

OcrRegionCollectionInsert Method

Inserts an OcrRegion into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    OcrRegion value
)
Public Sub Insert (
    index As Integer,
    value As OcrRegion
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrRegion should be inserted.
value
Type: Atalasoft.OcrOcrRegion
The OcrRegion to insert in the collection.

Return Value

Type:
n/a
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.IsValidForCollection Method

OcrRegionCollectionIsValidForCollection Method

Returns whether the specified OcrRegion object is valid for addition to this collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool IsValidForCollection(
    OcrRegion value
)
Protected Overridable Function IsValidForCollection (
    value As OcrRegion
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrRegion
The OcrRegion to be tested for validity

Return Value

Type: Boolean
True if the object is valid
Remarks
For the base OcrRegionCollection class, this method always returns true. Typically, this method will be used for type-safety testing of objects in subclasses of OcrRegionCollection, although other use cases are possible too.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.OnClearComplete Method

OcrRegionCollectionOnClearComplete Method

This gets called after a clear is performed on the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.OnElementChanged Method

OcrRegionCollectionOnElementChanged Method

Called when an element changed event occurs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnElementChanged(
    OcrPageElementEventArgs args
)
Protected Sub OnElementChanged (
    args As OcrPageElementEventArgs
)

Parameters

args
Type: Atalasoft.OcrOcrPageElementEventArgs
The details of the changing element.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.OnInsertComplete Method

OcrRegionCollectionOnInsertComplete Method

This gets called after an insert is performed on the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the newly added item.
value
Type: SystemObject
The value that was inserted in the collection.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.OnRemoveComplete Method

OcrRegionCollectionOnRemoveComplete Method

This gets called after a remove is performed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The location of the item in the collection.
value
Type: SystemObject
The item that was removed.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.OnSetComplete Method

OcrRegionCollectionOnSetComplete Method

This gets called after a value is set in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The location of the item in the collection.
oldValue
Type: SystemObject
The value at the index before the set was done.
newValue
Type: SystemObject
The value at the index after the set was done.
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.Remove Method

OcrRegionCollectionRemove Method

Removes the first occurrence of the specified OcrRegion from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    OcrRegion value
)
Public Sub Remove (
    value As OcrRegion
)

Parameters

value
Type: Atalasoft.OcrOcrRegion
The OcrRegion to remove from the collection.

Return Value

Type:
n/a
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection Events

The OcrRegionCollection type exposes the following members.

Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection.ElementChanged Event

OcrRegionCollectionElementChanged Event

This event is triggered when a change has been made to this collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageElementChangedEventHandler ElementChanged
Public Event ElementChanged As OcrPageElementChangedEventHandler

Value

Type: Atalasoft.OcrOcrPageElementChangedEventHandler
See Also

Reference

OcrRegionCollection Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T) Class

OcrRegionCollectionT Class

Summary description for OcrRegionCollection. Version with Generics support.
OcrRegionCollection represents a standard collection of OcrRegion objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrRegionCollection
Atalasoft.OcrOcrRegionCollectionT

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public sealed class OcrRegionCollection<T> : OcrRegionCollection
where T : OcrRegion

<SerializableAttribute>
Public NotInheritable Class OcrRegionCollection(Of T As OcrRegion)
    Inherits OcrRegionCollection

Type Parameters

T

The OcrRegionCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | OcrRegionCollectionT | Initializes a new instance of the OcrRegionCollectionT class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of an OcrRegion from the collection by an index.
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an OcrRegion to the collection.
Public method | Add(OcrRegion) | Adds an OcrRegion to the collection. (Inherited from OcrRegionCollection.)
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains(T) | Determines whether the collection contains a specified OcrRegion.
Public method | Contains(OcrRegion) | Determines whether the collection contains a specified OcrRegion. (Inherited from OcrRegionCollection.)
Public method | CopyTo(T, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(OcrRegion, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from OcrRegionCollection.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Returns the index of a specified OcrRegion in the collection.
Public method | IndexOf(OcrRegion) | Returns the index of a specified OcrRegion in the collection. (Inherited from OcrRegionCollection.)
Public method | Insert(Int32, OcrRegion) | Inserts an OcrRegion into the collection at specified position. (Inherited from OcrRegionCollection.)
Public method | Insert(Int32, T) | Inserts an OcrRegion into the collection at specified position.
Public method | Remove(T) | Removes the first occurrence of the specified OcrRegion from the collection.
Public method | Remove(OcrRegion) | Removes the first occurrence of the specified OcrRegion from the collection. (Inherited from OcrRegionCollection.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

Atalasoft.Ocr Namespace
OcrRegion Class


OcrRegionCollection(T) Constructor

OcrRegionCollectionT Constructor

Initializes a new instance of the OcrRegionCollectionT class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionCollection()
Public Sub New
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T) Properties

OcrRegionCollectionT Properties

The OcrRegionCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of an OcrRegion from the collection by an index.
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Item Property

OcrRegionCollectionTItem Property

Allows for retrieval of an OcrRegion from the collection by an index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32
The location within the collection

Return Value

Type: T
OcrRegion
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T) Methods

OcrRegionCollectionT Methods

The OcrRegionCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an OcrRegion to the collection.
Public method | Add(OcrRegion) | Adds an OcrRegion to the collection. (Inherited from OcrRegionCollection.)
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains(T) | Determines whether the collection contains a specified OcrRegion.
Public method | Contains(OcrRegion) | Determines whether the collection contains a specified OcrRegion. (Inherited from OcrRegionCollection.)
Public method | CopyTo(T, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(OcrRegion, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from OcrRegionCollection.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Returns the index of a specified OcrRegion in the collection.
Public method | IndexOf(OcrRegion) | Returns the index of a specified OcrRegion in the collection. (Inherited from OcrRegionCollection.)
Public method | Insert(Int32, OcrRegion) | Inserts an OcrRegion into the collection at specified position. (Inherited from OcrRegionCollection.)
Public method | Insert(Int32, T) | Inserts an OcrRegion into the collection at specified position.
Public method | Remove(T) | Removes the first occurrence of the specified OcrRegion from the collection.
Public method | Remove(OcrRegion) | Removes the first occurrence of the specified OcrRegion from the collection. (Inherited from OcrRegionCollection.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Add Method

OcrRegionCollectionTAdd Method

Overload List
 | Name | Description
Public method | Add(T) | Adds an OcrRegion to the collection.
Public method | Add(OcrRegion) | Adds an OcrRegion to the collection. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Add Method (T)

OcrRegionCollectionTAdd Method (T)

Adds an OcrRegion to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    T value
)
Public Function Add (
    value As T
) As Integer

Parameters

value
Type: T
The OcrRegion to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

OcrRegionCollectionT Class
Add Overload
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Contains Method

OcrRegionCollectionTContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether the collection contains a specified OcrRegion.
Public method | Contains(OcrRegion) | Determines whether the collection contains a specified OcrRegion. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Contains Method (T)

OcrRegionCollectionTContains Method (T)

Determines whether the collection contains a specified OcrRegion.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    T value
)
Public Function Contains (
    value As T
) As Boolean

Parameters

value
Type: T
The OcrRegion to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrRegionCollectionT Class
Contains Overload
Atalasoft.Ocr Namespace


OcrRegionCollection(T).CopyTo Method

OcrRegionCollectionTCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(T, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(OcrRegion, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).CopyTo Method (T[], Int32)

OcrRegionCollectionTCopyTo Method (T, Int32)

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    T[] array,
    int index
)
Public Sub CopyTo (
    array As T(),
    index As Integer
)

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrRegionCollectionT Class
CopyTo Overload
Atalasoft.Ocr Namespace


OcrRegionCollection(T).IndexOf Method

OcrRegionCollectionTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Returns the index of a specified OcrRegion in the collection.
Public method | IndexOf(OcrRegion) | Returns the index of a specified OcrRegion in the collection. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).IndexOf Method (T)

OcrRegionCollectionTIndexOf Method (T)

Returns the index of a specified OcrRegion in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    T value
)
Public Function IndexOf (
    value As T
) As Integer

Parameters

value
Type: T
The OcrRegion to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrRegionCollectionT Class
IndexOf Overload
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Insert Method

OcrRegionCollectionTInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, OcrRegion) | Inserts an OcrRegion into the collection at specified position. (Inherited from OcrRegionCollection.)
Public method | Insert(Int32, T) | Inserts an OcrRegion into the collection at specified position.
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Insert Method (Int32, T)

OcrRegionCollectionTInsert Method (Int32, T)

Inserts an OcrRegion into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    T value
)
Public Sub Insert (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrRegion should be inserted.
value
Type: T
The OcrRegion to insert in the collection.

Return Value

Type:
n/a
See Also

Reference

OcrRegionCollectionT Class
Insert Overload
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Remove Method

OcrRegionCollectionTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes the first occurrence of the specified OcrRegion from the collection.
Public method | Remove(OcrRegion) | Removes the first occurrence of the specified OcrRegion from the collection. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrRegionCollection(T).Remove Method (T)

OcrRegionCollectionTRemove Method (T)

Removes the first occurrence of the specified OcrRegion from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    T value
)
Public Sub Remove (
    value As T
)

Parameters

value
Type: T
The OcrRegion to remove from the collection.

Return Value

Type:
n/a
See Also

Reference

OcrRegionCollectionT Class
Remove Overload
Atalasoft.Ocr Namespace


OcrRegionCollection(T) Events

OcrRegionCollectionT Events

The OcrRegionCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection. (Inherited from OcrRegionCollection.)
Top
See Also

Reference

OcrRegionCollectionT Class
Atalasoft.Ocr Namespace


OcrResourceLoader Class

Note: This API is now obsolete.

Used to load OCR Resources
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrResourceLoader

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("The class is obsolete. Please use GlyphReaderLoader instead.",
    false)]
public class OcrResourceLoader
<ObsoleteAttribute("The class is obsolete. Please use GlyphReaderLoader instead.",
    false)>
Public Class OcrResourceLoader

The OcrResourceLoader type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResourceLoader | Creates a new instance of OcrResourceLoader and loads all OCR resources from all known engines from default locations.
Public method | OcrResourceLoader(String) | Creates a new instance of OcrResourceLoader and loads all OCR resources from all known engines from a specified location.
Top
Properties
 | Name | Description
 | OcrResourcesDirectoryName | Gets name of the folder where OCR Engine resources are stored.
Public property | PathsSearched | Gets collection of folders searched for the resources.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseResourcePaths | Gets collection of base paths where GlyphReader OCR Engine resources are stored.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Should be constructed in a static contructor before any OCR code. See GlyphReaderLoader for more information.
See Also

Reference

Atalasoft.Ocr Namespace
GlyphReaderLoader Class


OcrResourceLoader Constructor

Overload List
 | Name | Description
Public method | OcrResourceLoader | Creates a new instance of OcrResourceLoader and loads all OCR resources from all known engines from default locations.
Public method | OcrResourceLoader(String) | Creates a new instance of OcrResourceLoader and loads all OCR resources from all known engines from a specified location.
Top
See Also

Reference

OcrResourceLoader Class
Atalasoft.Ocr Namespace


OcrResourceLoader Constructor

Creates a new instance of OcrResourceLoader and loads all OCR resources from all known engines from default locations.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrResourceLoader()
Public Sub New
See Also

Reference

OcrResourceLoader Class
OcrResourceLoader Overload
Atalasoft.Ocr Namespace


OcrResourceLoader Constructor (String)

Creates a new instance of OcrResourceLoader and loads all OCR resources from all known engines from a specified location.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrResourceLoader(
    string resourceDir
)
Public Sub New (
    resourceDir As String
)

Parameters

resourceDir
Type: SystemString
See Also

Reference

OcrResourceLoader Class
OcrResourceLoader Overload
Atalasoft.Ocr Namespace


OcrResourceLoader Properties

The OcrResourceLoader type exposes the following members.

Properties
 | Name | Description
 | OcrResourcesDirectoryName | Gets name of the folder where OCR Engine resources are stored.
Public property | PathsSearched | Gets collection of folders searched for the resources.
Top
See Also

Reference

OcrResourceLoader Class
Atalasoft.Ocr Namespace


OcrResourceLoader.OcrResourcesDirectoryName Property

OcrResourceLoaderOcrResourcesDirectoryName Property

Gets name of the folder where OCR Engine resources are stored.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string OcrResourcesDirectoryName { get; }
Public Shared ReadOnly Property OcrResourcesDirectoryName As String
    Get

Property Value

Type: String
See Also

Reference

OcrResourceLoader Class
Atalasoft.Ocr Namespace


OcrResourceLoader.PathsSearched Property

OcrResourceLoaderPathsSearched Property

Gets collection of folders searched for the resources.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] PathsSearched { get; }
Public ReadOnly Property PathsSearched As String()
    Get

Property Value

Type: String
See Also

Reference

OcrResourceLoader Class
Atalasoft.Ocr Namespace


OcrResourceLoader Methods

The OcrResourceLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseResourcePaths | Gets collection of base paths where GlyphReader OCR Engine resources are stored.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrResourceLoader Class
Atalasoft.Ocr Namespace


OcrResourceLoader.GetBaseResourcePaths Method

OcrResourceLoaderGetBaseResourcePaths Method

Gets collection of base paths where GlyphReader OCR Engine resources are stored.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static StringCollection GetBaseResourcePaths()
Public Shared Function GetBaseResourcePaths As StringCollection

Return Value

Type: StringCollection
Collection of resources base paths.
See Also

Reference

OcrResourceLoader Class
Atalasoft.Ocr Namespace


OcrSymbolSet Enumeration

The list of Symbols for Ocr

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrSymbolSet
Public Enumeration OcrSymbolSet
Members
Member name | Description
None | No symbol
Alphabetic | Alphabetic, uppercase and lowercase
AlphabeticUppercase | AlphabeticUppercase, uppercase only
AlphabeticLowercase | AlphabeticLowercase, lowercase only
Numeric | Numeric, numeric digits
AlphaNumeric | AlphaNumeric, alphabetic and numeric
AlphaNumericUppercase | AlphaNumericUppercase, alphabetic and numeric, uppercase only
AlphaNumericLowercase | AlphaNumericLowercase, alphabetic and numeric, lowercase only
See Also

Reference

Atalasoft.Ocr Namespace


OcrTableRegion Class

OcrTableRegion represents a table page element.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrContainerRegion
Atalasoft.OcrOcrTableRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrTableRegion : OcrContainerRegion
Public Class OcrTableRegion
    Inherits OcrContainerRegion

The OcrTableRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OcrTableRegion(Rectangle) | Initializes a new instance of the OcrTableRegion class.
Public method | OcrTableRegion(PolygonF) | Initializes a new instance of the OcrTableRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Cells | Gets cells within the table.
Protected property | Elements | Gets the contained elements (Inherited from OcrContainerRegion.)
Public property | HSeparators | Horizonal table separators.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | VSeparators | Vertical table separators.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | ElementsElementChanged | Reroutes listener events to specific methods in this class, based on the OcrPageElementAction of the OcrPageElementEventArgs of the event (Inherited from OcrContainerRegion.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates bound encompassing all contained regions. (Inherited from OcrContainerRegion.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class is a prototype and will change in the future.
See Also

Reference

Atalasoft.Ocr Namespace


OcrTableRegion Constructor

Overload List
 | Name | Description
Public method | OcrTableRegion(Rectangle) | Initializes a new instance of the OcrTableRegion class.
Public method | OcrTableRegion(PolygonF) | Initializes a new instance of the OcrTableRegion class.
Top
See Also

Reference

OcrTableRegion Class
Atalasoft.Ocr Namespace


OcrTableRegion Constructor (Rectangle)

Initializes a new instance of the OcrTableRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTableRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the parent image.
Remarks
Avoid calling the constructor directly. Instead use the OcrTableRegion method in the Factory property of an OcrEngine.
See Also

Reference

OcrTableRegion Class
OcrTableRegion Overload
Atalasoft.Ocr Namespace


OcrTableRegion Constructor (PolygonF)

Initializes a new instance of the OcrTableRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTableRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element relative to the parent image.
Remarks
Avoid calling the constructor directly. Instead use the OcrTableRegion method in the Factory property of an OcrEngine.
See Also

Reference

OcrTableRegion Class
OcrTableRegion Overload
Atalasoft.Ocr Namespace


OcrTableRegion Properties

The OcrTableRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Cells | Gets cells within the table.
Protected property | Elements | Gets the contained elements (Inherited from OcrContainerRegion.)
Public property | HSeparators | Horizonal table separators.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | VSeparators | Vertical table separators.
Top
See Also

Reference

OcrTableRegion Class
Atalasoft.Ocr Namespace


OcrTableRegion.Cells Property

OcrTableRegionCells Property

Gets cells within the table.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrRegionCollection Cells { get; set; }
Public Property Cells As OcrRegionCollection
    Get
    Set

Property Value

Type: OcrRegionCollection
See Also

Reference

OcrTableRegion Class
Atalasoft.Ocr Namespace


OcrTableRegion.HSeparators Property

OcrTableRegionHSeparators Property

Horizonal table separators.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<OcrTableRegionOcrTableSeparator> HSeparators { get; set; }
Public Property HSeparators As List(Of OcrTableRegionOcrTableSeparator)
    Get
    Set

Property Value

Type: ListOcrTableRegionOcrTableSeparator
See Also

Reference

OcrTableRegion Class
Atalasoft.Ocr Namespace


OcrTableRegion.VSeparators Property

OcrTableRegionVSeparators Property

Vertical table separators.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<OcrTableRegionOcrTableSeparator> VSeparators { get; set; }
Public Property VSeparators As List(Of OcrTableRegionOcrTableSeparator)
    Get
    Set

Property Value

Type: ListOcrTableRegionOcrTableSeparator
See Also

Reference

OcrTableRegion Class
Atalasoft.Ocr Namespace


OcrTableRegion Methods

The OcrTableRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | ElementsElementChanged | Reroutes listener events to specific methods in this class, based on the OcrPageElementAction of the OcrPageElementEventArgs of the event (Inherited from OcrContainerRegion.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates bound encompassing all contained regions. (Inherited from OcrContainerRegion.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrTableRegion Class
Atalasoft.Ocr Namespace


OcrTableRegion.OcrTableSeparator Class

OcrTableRegionOcrTableSeparator Class

OcrTableSeparator represents a single table separator.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrTableRegionOcrTableSeparator

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrTableSeparator : IComparable<OcrTableRegionOcrTableSeparator>
Public Class OcrTableSeparator
    Implements IComparable(Of OcrTableRegionOcrTableSeparator)

The OcrTableRegionOcrTableSeparator type exposes the following members.

Constructors
 | Name | Description
Public method | OcrTableRegionOcrTableSeparator | Initializes a new instance of the OcrTableRegionOcrTableSeparator class.
Public method | OcrTableRegionOcrTableSeparator(Int32) | Initializes a new instance of the OcrTableRegionOcrTableSeparator class
Top
Properties
 | Name | Description
Public property | Position | Coordinate of the separator (horizontal or vertical coordinate on the image).
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrTableSeparator Constructor

Overload List
 | Name | Description
Public method | OcrTableRegionOcrTableSeparator | Initializes a new instance of the OcrTableRegionOcrTableSeparator class.
Public method | OcrTableRegionOcrTableSeparator(Int32) | Initializes a new instance of the OcrTableRegionOcrTableSeparator class
Top
See Also

Reference

OcrTableRegionOcrTableSeparator Class
Atalasoft.Ocr Namespace


OcrTableRegion.OcrTableSeparator Constructor

OcrTableRegionOcrTableSeparator Constructor

Initializes a new instance of the OcrTableRegionOcrTableSeparator class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTableSeparator()
Public Sub New
See Also

Reference

OcrTableRegionOcrTableSeparator Class
OcrTableRegionOcrTableSeparator Overload
Atalasoft.Ocr Namespace


OcrTableRegion.OcrTableSeparator Constructor (Int32)

OcrTableRegionOcrTableSeparator Constructor (Int32)

Initializes a new instance of the OcrTableRegionOcrTableSeparator class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTableSeparator(
    int _position
)
Public Sub New (
    _position As Integer
)

Parameters

_position
Type: SystemInt32
See Also

Reference

OcrTableRegionOcrTableSeparator Class
OcrTableRegionOcrTableSeparator Overload
Atalasoft.Ocr Namespace


OcrTableSeparator Properties

The OcrTableRegionOcrTableSeparator type exposes the following members.

Properties
 | Name | Description
Public property | Position | Coordinate of the separator (horizontal or vertical coordinate on the image).
Top
See Also

Reference

OcrTableRegionOcrTableSeparator Class
Atalasoft.Ocr Namespace


OcrTableRegion.OcrTableSeparator.Position Property

OcrTableRegionOcrTableSeparatorPosition Property

Coordinate of the separator (horizontal or vertical coordinate on the image).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

OcrTableRegionOcrTableSeparator Class
Atalasoft.Ocr Namespace


OcrTableSeparator Methods

The OcrTableRegionOcrTableSeparator type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrTableRegionOcrTableSeparator Class
Atalasoft.Ocr Namespace


OcrTableRegion.OcrTableSeparator.CompareTo Method

OcrTableRegionOcrTableSeparatorCompareTo Method

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CompareTo(
    OcrTableRegionOcrTableSeparator val
)
Public Function CompareTo (
    val As OcrTableRegionOcrTableSeparator
) As Integer

Parameters

val
Type: Atalasoft.OcrOcrTableRegionOcrTableSeparator

Return Value

Type: Int32

Implements

IComparableTCompareTo(T)
See Also

Reference

OcrTableRegionOcrTableSeparator Class
Atalasoft.Ocr Namespace


OcrTextKind Enumeration

Represents type of text detected by OCR engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrTextKind
Public Enumeration OcrTextKind
Members
Member name | Description
MachinePrint | Machine printed text.
HandPrint | Human (hand) printed text.
Any | Any text kind.
See Also

Reference

Atalasoft.Ocr Namespace


OcrTextRegion Class

OcrTextRegion represents an area of text on a page.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrTextRegion

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrTextRegion : OcrRegion
Public Class OcrTextRegion
    Inherits OcrRegion

The OcrTextRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OcrTextRegion(Rectangle) | Initializes a new instance of the OcrTextRegion class.
Public method | OcrTextRegion(PolygonF) | Initializes a new instance of the OcrTextRegion class.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OcrTextRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized.
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region.
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation.
Public property | TextKind | Gets or sets kind of the text within the text sregion.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region.
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrTextRegion Constructor

Overload List
 | Name | Description
Public method | OcrTextRegion(Rectangle) | Initializes a new instance of the OcrTextRegion class.
Public method | OcrTextRegion(PolygonF) | Initializes a new instance of the OcrTextRegion class.
Public method | OcrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OcrTextRegion class.
Top
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion Constructor (Rectangle)

Initializes a new instance of the OcrTextRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.

Return Value

Type:
A new OcrTextRegion object.
Remarks
Avoid calling the constructor directly. Instead use the OcrTextRegion method in the Factory property of an OcrEngine.
See Also

Reference

OcrTextRegion Class
OcrTextRegion Overload
Atalasoft.Ocr Namespace


OcrTextRegion Constructor (PolygonF)

Initializes a new instance of the OcrTextRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding Rectangle of the page element relative to the source image.

Return Value

Type:
A new OcrTextRegion object.
Remarks
Avoid calling the constructor directly. Instead use the OcrTextRegion method in the Factory property of an OcrEngine.
See Also

Reference

OcrTextRegion Class
OcrTextRegion Overload
Atalasoft.Ocr Namespace


OcrTextRegion Constructor (Rectangle, OcrTextRotation)

Initializes a new instance of the OcrTextRegion class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Public Sub New (
    bounds As Rectangle,
    rotation As OcrTextRotation
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
rotation
Type: Atalasoft.OcrOcrTextRotation
The rotation of the text region with respect to the entire page.
See Also

Reference

OcrTextRegion Class
OcrTextRegion Overload
Atalasoft.Ocr Namespace


OcrTextRegion Properties

The OcrTextRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized.
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region.
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region.
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation.
Public property | TextKind | Gets or sets kind of the text within the text sregion.
Top
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.Confidence Property

OcrTextRegionConfidence Property

This property represents the overall confidence with which the text was recognized.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual double Confidence { get; }
Public Overridable ReadOnly Property Confidence As Double
    Get

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
This value is calculated as the average confidence of all the glyphs in the region.
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.ExpectedSymbolSet Property

OcrTextRegionExpectedSymbolSet Property

Gets or sets expected symbol set for the text region.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ExpectedSymbolSet { get; set; }
Public Property ExpectedSymbolSet As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.Lines Property

OcrTextRegionLines Property

This property provides access to individual lines of text within the region.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrLineCollection Lines { get; }
Public Overridable ReadOnly Property Lines As OcrLineCollection
    Get

Property Value

Type: OcrLineCollection
An object of type OcrLineCollection.
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.Rotation Property

OcrTextRegionRotation Property

This property represents the orientation of the text region, expressed as a rotation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrTextRotation Rotation { get; set; }
Public Overridable Property Rotation As OcrTextRotation
    Get
    Set

Property Value

Type: OcrTextRotation
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.TextKind Property

OcrTextRegionTextKind Property

Gets or sets kind of the text within the text sregion.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextKind TextKind { get; set; }
Public Property TextKind As OcrTextKind
    Get
    Set

Property Value

Type: OcrTextKind
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion Methods

The OcrTextRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region.
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Overrides ObjectToString.)
Top
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.RecalculateBounds Method

OcrTextRegionRecalculateBounds Method

Recalculates the bounding box of a text region.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RecalculateBounds()
Public Sub RecalculateBounds
Remarks
This is a utility method that is used internally. Under most circumstances, there is no need to call this directly.
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRegion.ToString Method

OcrTextRegionToString Method

Converts the entire contents of an OcrTextRegion to a single string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Remarks
The string is formed by concatenating every line in the region with a new line character between each line.
See Also

Reference

OcrTextRegion Class
Atalasoft.Ocr Namespace


OcrTextRotation Enumeration

This enumeration is used to define coarse rotation of text in a page element.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OcrTextRotation
Public Enumeration OcrTextRotation
Members
Member name | Description
None | No rotation.
Clockwise90 | The text is rotated 90 degrees clockwise.
Clockwise180 | The text is rotated 180 degrees clockwise.
Clockwise270 | The text is rotated 270 degrees clockwise.
CounterClockwise90 | The text is rotated 90 degrees counterclockwise.
CounterClockwise180 | The text is rotated 180 degrees counterclockwise.
CounterClockwise270 | The text is rotated 270 degrees counterclockwise.
Remarks
Each of these enumerations is defined to have a value that is equal to the rotation in degrees. In the future, the AtalaOcr name space may support arbitrary rotation of text by degrees. These definitions will then provide a convenient way to transitions to this model.
See Also

Reference

Atalasoft.Ocr Namespace


OcrWord Class

Summary description for OcrWord.
The OcrWord object represents a word of recognized text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrWord

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrWord : MarshalByRefObject
<SerializableAttribute>
Public Class OcrWord
    Inherits MarshalByRefObject

The OcrWord type exposes the following members.

Constructors
 | Name | Description
Public method | OcrWord | Constructs a new OcrWord object.
Top
Properties
 | Name | Description
Public property | Accessor | This property provides the IOcrWordAccessor associated with this object.
Public property | Alternates | Gets a collection of alternate words for this word.
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the word in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire word.
Public property | Glyphs | Gets an OcrGlyphCollection which contains the glyphs that make up this word.
Public property | Text | Returns the text of the word as a string.
Public property | TextKind | Gets or sets text kind of the word.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a wordof text.
Public method | GetFontAt | Returns the Font used for this page element.
Public method | GetFontColorAt | Get the color of a glyph within a word.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a word of text.
Public method | GetFontNameAt | Get the name of the font used for a glyph in the word.
Public method | GetFontSizeAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a word.
Public method | ResetConfidence | Resets the confidence of a word to the value supplied by its accessor.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this word of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrWord Constructor

Constructs a new OcrWord object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrWord(
    IOcrWordAccessor accessor,
    Rectangle bounds,
    int baseline
)
Public Sub New (
    accessor As IOcrWordAccessor,
    bounds As Rectangle,
    baseline As Integer
)

Parameters

accessor
Type: Atalasoft.OcrIOcrWordAccessor
The IOcrWordAccessor that will be used to access data for this object.
bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
baseline
Type: SystemInt32
The baseline of the text in pixels relative to the image.

Return Value

Type:
A new OcrWord object.
Remarks
Avoid calling the constructor directly. Instead use the OcrWord method in the Factory property.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord Properties

The OcrWord type exposes the following members.

Properties
 | Name | Description
Public property | Accessor | This property provides the IOcrWordAccessor associated with this object.
Public property | Alternates | Gets a collection of alternate words for this word.
Public property | Baseline | This property represents the baseline of the text in pixels relative to the source image.
Public property | Bounds | This property represents the bounding box of the word in pixels relative to the source image.
Public property | Confidence | This property represents the confidence of recognition of the entire word.
Public property | Glyphs | Gets an OcrGlyphCollection which contains the glyphs that make up this word.
Public property | Text | Returns the text of the word as a string.
Public property | TextKind | Gets or sets text kind of the word.
Top
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Accessor Property

OcrWordAccessor Property

This property provides the IOcrWordAccessor associated with this object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IOcrWordAccessor Accessor { get; }
Public ReadOnly Property Accessor As IOcrWordAccessor
    Get

Property Value

Type: IOcrWordAccessor
An object of type IOcrWordAccessor to access the data for this object.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Alternates Property

OcrWordAlternates Property

Gets a collection of alternate words for this word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrWordCollection Alternates { get; }
Public ReadOnly Property Alternates As OcrWordCollection
    Get

Property Value

Type: OcrWordCollection
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Baseline Property

OcrWordBaseline Property

This property represents the baseline of the text in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Baseline { get; set; }
Public Property Baseline As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Bounds Property

OcrWordBounds Property

This property represents the bounding box of the word in pixels relative to the source image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Bounds { get; set; }
Public Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle
A Rectangle that represents the bounding box of this word.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Confidence Property

OcrWordConfidence Property

This property represents the confidence of recognition of the entire word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Confidence { get; set; }
Public Property Confidence As Double
    Get
    Set

Property Value

Type: Double
A double ranging from 0.0 (no confidence) to 1.0 (complete confidence).
Remarks
This value is calculated as the average confidence of all the glyphs in the word.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Glyphs Property

OcrWordGlyphs Property

Gets an OcrGlyphCollection which contains the glyphs that make up this word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrGlyphCollection Glyphs { get; }
Public ReadOnly Property Glyphs As OcrGlyphCollection
    Get

Property Value

Type: OcrGlyphCollection
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.Text Property

OcrWordText Property

Returns the text of the word as a string.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
A string representing the text of the word.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.TextKind Property

OcrWordTextKind Property

Gets or sets text kind of the word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrTextKind TextKind { get; set; }
Public Property TextKind As OcrTextKind
    Get
    Set

Property Value

Type: OcrTextKind
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord Methods

The OcrWord type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfidenceAt | Get the confidence of recognition at a particular point in a wordof text.
Public method | GetFontAt | Returns the Font used for this page element.
Public method | GetFontColorAt | Get the color of a glyph within a word.
Public method | GetFontFamilyAt | Get the FontFamily at a particular point in a word of text.
Public method | GetFontNameAt | Get the name of the font used for a glyph in the word.
Public method | GetFontSizeAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | GetFontStyleAt | This property represents the FontStyle of a glyph at a particular point in a word.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a word.
Public method | ResetConfidence | Resets the confidence of a word to the value supplied by its accessor.
Public method | StyleIsUniform | Check to see if the font and style are uniform across this word of text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetConfidenceAt Method

OcrWordGetConfidenceAt Method

Get the confidence of recognition at a particular point in a wordof text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetConfidenceAt(
    int i
)
Public Function GetConfidenceAt (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Double
A double representing the confidence of recognition of the specified glyph ranging from 0.0 (no confidence) to 1.0 (complete confidence).
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetFontAt Method

OcrWordGetFontAt Method

Returns the Font used for this page element.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Font GetFontAt(
    Dpi imageResolution,
    IFontMapper mapper,
    IFontBuilder builder,
    int i
)
Public Function GetFontAt (
    imageResolution As Dpi,
    mapper As IFontMapper,
    builder As IFontBuilder,
    i As Integer
) As Font

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this word was taken.
mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Font
The Font that represents this glyph.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetFontColorAt Method

OcrWordGetFontColorAt Method

Get the color of a glyph within a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color GetFontColorAt(
    int i
)
Public Function GetFontColorAt (
    i As Integer
) As Color

Parameters

i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Color
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetFontFamilyAt Method

OcrWordGetFontFamilyAt Method

Get the FontFamily at a particular point in a word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontFamily GetFontFamilyAt(
    IFontMapper mapper,
    int i
)
Public Function GetFontFamilyAt (
    mapper As IFontMapper,
    i As Integer
) As FontFamily

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: FontFamily
An object of type FontFamily that represents the font family of the glyph.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetFontNameAt Method

OcrWordGetFontNameAt Method

Get the name of the font used for a glyph in the word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetFontNameAt(
    IFontMapper mapper,
    int i
)
Public Function GetFontNameAt (
    mapper As IFontMapper,
    i As Integer
) As String

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: String
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetFontSizeAt Method

OcrWordGetFontSizeAt Method

This property represents the FontStyle of a glyph at a particular point in a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float GetFontSizeAt(
    Dpi imageResolution,
    int i
)
Public Function GetFontSizeAt (
    imageResolution As Dpi,
    i As Integer
) As Single

Parameters

imageResolution
Type: Atalasoft.ImagingDpi
The resolution of the image from which this word was taken.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: Single
A floating point number that represents the size of the glyph in points.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.GetFontStyleAt Method

OcrWordGetFontStyleAt Method

This property represents the FontStyle of a glyph at a particular point in a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontStyle GetFontStyleAt(
    IFontMapper mapper,
    int i
)
Public Function GetFontStyleAt (
    mapper As IFontMapper,
    i As Integer
) As FontStyle

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
i
Type: SystemInt32
The index of the glyph within a word of text.

Return Value

Type: FontStyle
An object of type FontStyle that represents the font style of the glyph.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.RecalculateBounds Method

OcrWordRecalculateBounds Method

Recalculates the bounding box of a word.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RecalculateBounds()
Public Sub RecalculateBounds
Remarks
This is a utility method that is used internally. Under most circumstances, there is no need to call this directly.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.ResetConfidence Method

OcrWordResetConfidence Method

Resets the confidence of a word to the value supplied by its accessor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ResetConfidence()
Public Sub ResetConfidence
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWord.StyleIsUniform Method

OcrWordStyleIsUniform Method

Check to see if the font and style are uniform across this word of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool StyleIsUniform(
    IFontMapper mapper,
    IFontBuilder builder
)
Public Function StyleIsUniform (
    mapper As IFontMapper,
    builder As IFontBuilder
) As Boolean

Parameters

mapper
Type: Atalasoft.OcrIFontMapper
The IFontMapper to use to remap this word's font.
builder
Type: Atalasoft.OcrIFontBuilder
The IFontBuilder to use to construct the font.

Return Value

Type: Boolean
True if the font family, style and size are the same throughout the word of text.
See Also

Reference

OcrWord Class
Atalasoft.Ocr Namespace


OcrWordCollection Class

Summary description for OcrLineCollection.
OcrWordCollection represents a standard collection of OcrWord objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrOcrWordCollection

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OcrWordCollection : CollectionBase
<SerializableAttribute>
Public Class OcrWordCollection
    Inherits CollectionBase

The OcrWordCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrWordCollection | Initializes a new instance of the OcrWordCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of an item in the collection by index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an OcrWord to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrWord.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrWord in the collection.
Public method | Insert | Inserts an OcrWord into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | This gets called after a clear is performed on the collection. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Called when an element changed event occurs
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | This gets called after an insert is performed on the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | This gets called after a remove is performed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | This gets called after a value is set in the collection. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrWord from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

Atalasoft.Ocr Namespace


OcrWordCollection Constructor

Initializes a new instance of the OcrWordCollection class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrWordCollection()
Public Sub New
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection Properties

The OcrWordCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of an item in the collection by index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.Item Property

OcrWordCollectionItem Property

Allows for retrieval of an item in the collection by index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrWord this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As OcrWord
    Get
    Set

Parameters

index
Type: SystemInt32
The location within the collection to use

Return Value

Type: OcrWord
An OcrWord object at the index.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection Methods

The OcrWordCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an OcrWord to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified OcrWord.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified OcrWord in the collection.
Public method | Insert | Inserts an OcrWord into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | This gets called after a clear is performed on the collection. (Overrides CollectionBaseOnClearComplete.)
Protected method | OnElementChanged | Called when an element changed event occurs
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | This gets called after an insert is performed on the collection. (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | This gets called after a remove is performed. (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | This gets called after a value is set in the collection. (Overrides CollectionBaseOnSetComplete(Int32, Object, Object).)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified OcrWord from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.Add Method

OcrWordCollectionAdd Method

Adds an OcrWord to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    OcrWord value
)
Public Function Add (
    value As OcrWord
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrWord
The OcrWord to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.Contains Method

OcrWordCollectionContains Method

Determines whether the collection contains a specified OcrWord.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    OcrWord value
)
Public Function Contains (
    value As OcrWord
) As Boolean

Parameters

value
Type: Atalasoft.OcrOcrWord
The OcrWord to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.CopyTo Method

OcrWordCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    OcrWord[] array,
    int index
)
Public Sub CopyTo (
    array As OcrWord(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrOcrWord
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.IndexOf Method

OcrWordCollectionIndexOf Method

Returns the index of a specified OcrWord in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    OcrWord value
)
Public Function IndexOf (
    value As OcrWord
) As Integer

Parameters

value
Type: Atalasoft.OcrOcrWord
The OcrWord to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.Insert Method

OcrWordCollectionInsert Method

Inserts an OcrWord into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    OcrWord value
)
Public Sub Insert (
    index As Integer,
    value As OcrWord
)

Parameters

index
Type: SystemInt32
The zero-based position at which the OcrWord should be inserted.
value
Type: Atalasoft.OcrOcrWord
The OcrWord to insert in the collection.

Return Value

Type:
n/a
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.OnClearComplete Method

OcrWordCollectionOnClearComplete Method

This gets called after a clear is performed on the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnClearComplete()
Protected Overrides Sub OnClearComplete
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.OnElementChanged Method

OcrWordCollectionOnElementChanged Method

Called when an element changed event occurs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void OnElementChanged(
    OcrPageElementEventArgs args
)
Protected Sub OnElementChanged (
    args As OcrPageElementEventArgs
)

Parameters

args
Type: Atalasoft.OcrOcrPageElementEventArgs
The details of the changing element.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.OnInsertComplete Method

OcrWordCollectionOnInsertComplete Method

This gets called after an insert is performed on the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The index of the newly added item.
value
Type: SystemObject
The value that was inserted in the collection.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.OnRemoveComplete Method

OcrWordCollectionOnRemoveComplete Method

This gets called after a remove is performed.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)

Parameters

index
Type: SystemInt32
The location of the item in the collection.
value
Type: SystemObject
The item that was removed.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.OnSetComplete Method

OcrWordCollectionOnSetComplete Method

This gets called after a value is set in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnSetComplete (
    index As Integer,
    oldValue As Object,
    newValue As Object
)

Parameters

index
Type: SystemInt32
The location of the item in the collection.
oldValue
Type: SystemObject
The value at the index before the set was done.
newValue
Type: SystemObject
The value at the index after the set was done.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.Remove Method

OcrWordCollectionRemove Method

Removes the first occurrence of the specified OcrWord from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    OcrWord value
)
Public Sub Remove (
    value As OcrWord
)

Parameters

value
Type: Atalasoft.OcrOcrWord
Removes the first occurrence of the specified OcrWord from the collection.

Return Value

Type:
n/a
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection Events

The OcrWordCollection type exposes the following members.

Events
 | Name | Description
Public event | ElementChanged | This event is triggered when a change has been made to this collection.
Top
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OcrWordCollection.ElementChanged Event

OcrWordCollectionElementChanged Event

This event is triggered when a change has been made to this collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event OcrPageElementChangedEventHandler ElementChanged
Public Event ElementChanged As OcrPageElementChangedEventHandler

Value

Type: Atalasoft.OcrOcrPageElementChangedEventHandler
Remarks
This event is used for internal maintenance of bounding boxes and confidence levels. It is typically not necessary for client code to hook into it.
See Also

Reference

OcrWordCollection Class
Atalasoft.Ocr Namespace


OmniPageEngineBase Class

Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.OcrOmniPageEngineBase
Atalasoft.Ocr.OmniPageOmniPageEngine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class OmniPageEngineBase : OcrEngine,
    INativeTranslator, ITranslator
Public MustInherit Class OmniPageEngineBase
    Inherits OcrEngine
    Implements INativeTranslator, ITranslator

The OmniPageEngineBase type exposes the following members.

Constructors
 | Name | Description
Protected method | OmniPageEngineBase | Initializes a new instance of the OmniPageEngineBase class
Top
Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine. (Inherited from OcrEngine.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | CanStream(String) | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Inherited from OcrEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine (Inherited from OcrEngine.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine (Inherited from OcrEngine.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Inherited from OcrEngine.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Protected method | INativeTranslator_Translate(ImageSource, String, Stream) |
Protected method | INativeTranslator_Translate(ImageSource, String, String) |
Public method | Initialize | Initialize the engine. (Inherited from OcrEngine.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Inherited from OcrEngine.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Inherited from OcrEngine.)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | Terminates the engine. (Inherited from OcrEngine.)
Public method | Supported | Get an array of mime types supported by this translator.
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


OmniPageEngineBase Constructor

Initializes a new instance of the OmniPageEngineBase class

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected OmniPageEngineBase()
Protected Sub New
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase Properties

The OmniPageEngineBase type exposes the following members.

Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine. (Inherited from OcrEngine.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase Methods

The OmniPageEngineBase type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | CanStream(String) | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Inherited from OcrEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine (Inherited from OcrEngine.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine (Inherited from OcrEngine.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Inherited from OcrEngine.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Protected method | INativeTranslator_Translate(ImageSource, String, Stream) |
Protected method | INativeTranslator_Translate(ImageSource, String, String) |
Public method | Initialize | Initialize the engine. (Inherited from OcrEngine.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Inherited from OcrEngine.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Inherited from OcrEngine.)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | Terminates the engine. (Inherited from OcrEngine.)
Public method | Supported | Get an array of mime types supported by this translator.
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase.CanStream Method

OmniPageEngineBaseCanStream Method

Overload List
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | CanStream(String) | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase.CanStream Method

OmniPageEngineBaseCanStream Method

Checks to see if this translator is capable of streaming.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool CanStream()
Public MustOverride Function CanStream As Boolean

Return Value

Type: Boolean
True if the translator can stream, false otherwise.

Implements

ITranslatorCanStream
See Also

Reference

OmniPageEngineBase Class
CanStream Overload
Atalasoft.Ocr Namespace


OmniPageEngineBase.INativeTranslator_Translate Method

OmniPageEngineBaseINativeTranslator_Translate Method

Overload List
 | Name | Description
Protected method | INativeTranslator_Translate(ImageSource, String, Stream) |
Protected method | INativeTranslator_Translate(ImageSource, String, String) |
Top
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase.INativeTranslator_Translate Method (ImageSource, String, Stream)

OmniPageEngineBaseINativeTranslator_Translate Method (ImageSource, String, Stream)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void INativeTranslator_Translate(
    ImageSource images,
    string mime,
    Stream outStream
)
Protected MustOverride Sub INativeTranslator_Translate (
    images As ImageSource,
    mime As String,
    outStream As Stream
)

Parameters

images
Type: Atalasoft.ImagingImageSource
mime
Type: SystemString
outStream
Type: System.IOStream
See Also

Reference

OmniPageEngineBase Class
INativeTranslator_Translate Overload
Atalasoft.Ocr Namespace


OmniPageEngineBase.INativeTranslator_Translate Method (ImageSource, String, String)

OmniPageEngineBaseINativeTranslator_Translate Method (ImageSource, String, String)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void INativeTranslator_Translate(
    ImageSource images,
    string mime,
    string fileName
)
Protected MustOverride Sub INativeTranslator_Translate (
    images As ImageSource,
    mime As String,
    fileName As String
)

Parameters

images
Type: Atalasoft.ImagingImageSource
mime
Type: SystemString
fileName
Type: SystemString
See Also

Reference

OmniPageEngineBase Class
INativeTranslator_Translate Overload
Atalasoft.Ocr Namespace


OmniPageEngineBase.Supported Method

OmniPageEngineBaseSupported Method

Get an array of mime types supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract string[] Supported()
Public MustOverride Function Supported As String()

Return Value

Type: String
An array of strings containing mime types supported by this translator.

Implements

ITranslatorSupported
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase.Supports Method

OmniPageEngineBaseSupports Method

Checks to see if a specific mime type is supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool Supports(
    string mimeType
)
Public MustOverride Function Supports (
    mimeType As String
) As Boolean

Parameters

mimeType
Type: SystemString
A string representing a mime type to be checked.

Return Value

Type: Boolean
True if the mime type is supported, false otherwise.

Implements

ITranslatorSupports(String)
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


OmniPageEngineBase Events

The OmniPageEngineBase type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngineBase Class
Atalasoft.Ocr Namespace


PdfColorSpace Enumeration

This enumeration defines color spaces supported for Pdf output.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfColorSpace
Public Enumeration PdfColorSpace
Members
Member name | Description
None | None - not used.
DeviceGray | Gray
DeviceRGB | Red, Green, Blue
DeviceCMYK | Cyan, Magenta, Yellow, Black
CalGray | Single component CIE color space
Lab | CIE-based ABC color space
ICCBased | ICC specific color space
Indexed | Color mapped color space
Pattern | Pattern color space
Separation | Process color color space
DeviceN | Arbitrary color component space
See Also

Reference

Atalasoft.Ocr Namespace


PdfCompressionSelector Delegate

This delegate is used to determine what compression to use on a given page in the process of being translated.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate PdfImageCompressionType PdfCompressionSelector(
    PixelFormat pf
)
Public Delegate Function PdfCompressionSelector (
    pf As PixelFormat
) As PdfImageCompressionType

Parameters

pf
Type: Atalasoft.ImagingPixelFormat
The pixel format of the image to be compressed.

Return Value

Type: PdfImageCompressionType
Remarks
An inappropriate pixel format will result in an exception being thrown later on.
See Also

Reference

Atalasoft.Ocr Namespace


PdfImageCompressionType Enumeration

This enumeration describes possible Pdf image compression

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfImageCompressionType
Public Enumeration PdfImageCompressionType
Members
Member name | Description
None | No compression
Flate | Zlib/deflate compression
CcittGroup4 | CCITT Group 4 compression
JBig2 | Joint Bi-Level Image Experts Group compression
Jpeg | JPEG compression
Jpeg2000 | JPX/JPEG2000 compression
See Also

Reference

Atalasoft.Ocr Namespace


PdfImageTicket Class

The PdfImageTicket class is used to store information about an image for PDF translation
Inheritance Hierarchy
SystemObject
Atalasoft.OcrPdfImageTicket

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageTicket
Public Class PdfImageTicket

The PdfImageTicket type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageTicket(AtalaImage, PdfImageCompressionType) | Construct a new PdfImageTicketObject
Public method | PdfImageTicket(String, PdfImageCompressionType, Dpi) | Obsolete. Construct a new PdfImageTicketObject
Public method | PdfImageTicket(String, PdfImageCompressionType, Int32, Int32, Dpi) | Initializes a new instance of the PdfImageTicket class.
Public method | PdfImageTicket(DisposableTempFile, PdfImageCompressionType, Int32, Int32, Dpi) | Initializes a new instance of the PdfImageTicket class.
Public method | PdfImageTicket(Stream, Int64, Int64, Int32, Int32, Int32, PdfColorSpace, PdfImageCompressionType, Dpi) | Initializes a new instance of the PdfImageTicket class.
Top
Properties
 | Name | Description
Public property | Height | Gets the height of this image
Public property | Jpeg2000CompressionFactor | Gets or sets Jpeg2000 compression factor.
Public property | JpegQuality | Gets or sets Jpeg quality.
Public property | Resolution | Gets the resolution of this image
Public property | Width | Gets the width of this image
Top
Methods
 | Name | Description
Public method | ClearImage | ClearImage removes all references to the image in this PdfImageTicket
Public method | ClearPath | ClearPath removes any reference to the path to an image in the PdfImageTicket
Public method | ClearTempFile | ClearTempFile calls Dispose on the DisposableTempFile if it is non-null.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Get the representation of the PdfImageTicket as an AtalaImage
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


PdfImageTicket Constructor

Construct a new PdfImageTicketObject
Overload List
 | Name | Description
Public method | PdfImageTicket(AtalaImage, PdfImageCompressionType) | Construct a new PdfImageTicketObject
Public method | PdfImageTicket(String, PdfImageCompressionType, Dpi) | Obsolete. Construct a new PdfImageTicketObject
Public method | PdfImageTicket(String, PdfImageCompressionType, Int32, Int32, Dpi) | Initializes a new instance of the PdfImageTicket class.
Public method | PdfImageTicket(DisposableTempFile, PdfImageCompressionType, Int32, Int32, Dpi) | Initializes a new instance of the PdfImageTicket class.
Public method | PdfImageTicket(Stream, Int64, Int64, Int32, Int32, Int32, PdfColorSpace, PdfImageCompressionType, Dpi) | Initializes a new instance of the PdfImageTicket class.
Top
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket Constructor (AtalaImage, PdfImageCompressionType)

Construct a new PdfImageTicketObject

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageTicket(
    AtalaImage image,
    PdfImageCompressionType compression
)
Public Sub New (
    image As AtalaImage,
    compression As PdfImageCompressionType
)

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The source image for the page
compression
Type: Atalasoft.OcrPdfImageCompressionType
The desired compression for the image in the PDF file
See Also

Reference

PdfImageTicket Class
PdfImageTicket Overload
Atalasoft.Ocr Namespace


PdfImageTicket Constructor (String, PdfImageCompressionType, Dpi)

Note: This API is now obsolete.

Construct a new PdfImageTicketObject

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete.  Please use the method that includes image dimensions")]
public PdfImageTicket(
    string path,
    PdfImageCompressionType compression,
    Dpi resolution
)
<ObsoleteAttribute("This method is obsolete.  Please use the method that includes image dimensions")>
Public Sub New (
    path As String,
    compression As PdfImageCompressionType,
    resolution As Dpi
)

Parameters

path
Type: SystemString
A path to a file representing an image
compression
Type: Atalasoft.OcrPdfImageCompressionType
The compression that will be used for that image in the resulting PDF
resolution
Type: Atalasoft.ImagingDpi
The resolution of the image
See Also

Reference

PdfImageTicket Class
PdfImageTicket Overload
Atalasoft.Ocr Namespace


PdfImageTicket Constructor (String, PdfImageCompressionType, Int32, Int32, Dpi)

Initializes a new instance of the PdfImageTicket class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageTicket(
    string path,
    PdfImageCompressionType compression,
    int width,
    int height,
    Dpi resolution
)
Public Sub New (
    path As String,
    compression As PdfImageCompressionType,
    width As Integer,
    height As Integer,
    resolution As Dpi
)

Parameters

path
Type: SystemString
The path.
compression
Type: Atalasoft.OcrPdfImageCompressionType
The compression.
width
Type: SystemInt32
The width.
height
Type: SystemInt32
The height.
resolution
Type: Atalasoft.ImagingDpi
The resolution.
Exceptions
Exception | Condition
ArgumentNullException | path;path can't be null
See Also

Reference

PdfImageTicket Class
PdfImageTicket Overload
Atalasoft.Ocr Namespace


PdfImageTicket Constructor (DisposableTempFile, PdfImageCompressionType, Int32, Int32, Dpi)

Initializes a new instance of the PdfImageTicket class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageTicket(
    DisposableTempFile tempFile,
    PdfImageCompressionType compression,
    int width,
    int height,
    Dpi resolution
)
Public Sub New (
    tempFile As DisposableTempFile,
    compression As PdfImageCompressionType,
    width As Integer,
    height As Integer,
    resolution As Dpi
)

Parameters

tempFile
Type: Atalasoft.Shared.IODisposableTempFile
Temporary file to use.
compression
Type: Atalasoft.OcrPdfImageCompressionType
The compression.
width
Type: SystemInt32
The width.
height
Type: SystemInt32
The height.
resolution
Type: Atalasoft.ImagingDpi
The resolution.
Exceptions
Exception | Condition
ArgumentNullException | source;source stream can't be null
See Also

Reference

PdfImageTicket Class
PdfImageTicket Overload
Atalasoft.Ocr Namespace


PdfImageTicket Constructor (Stream, Int64, Int64, Int32, Int32, Int32, PdfColorSpace, PdfImageCompressionType, Dpi)

Initializes a new instance of the PdfImageTicket class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageTicket(
    Stream source,
    long start,
    long length,
    int width,
    int height,
    int bitsPerComponent,
    PdfColorSpace colorSpace,
    PdfImageCompressionType compression,
    Dpi resolution
)
Public Sub New (
    source As Stream,
    start As Long,
    length As Long,
    width As Integer,
    height As Integer,
    bitsPerComponent As Integer,
    colorSpace As PdfColorSpace,
    compression As PdfImageCompressionType,
    resolution As Dpi
)

Parameters

source
Type: System.IOStream
The source.
start
Type: SystemInt64
The start.
length
Type: SystemInt64
The length.
width
Type: SystemInt32
The width.
height
Type: SystemInt32
The height.
bitsPerComponent
Type: SystemInt32
The bits per component.
colorSpace
Type: Atalasoft.OcrPdfColorSpace
The color space.
compression
Type: Atalasoft.OcrPdfImageCompressionType
The compression.
resolution
Type: Atalasoft.ImagingDpi
The resolution.
Exceptions
Exception | Condition
ArgumentNullException | source;source stream can't be null
See Also

Reference

PdfImageTicket Class
PdfImageTicket Overload
Atalasoft.Ocr Namespace


PdfImageTicket Properties

The PdfImageTicket type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height of this image
Public property | Jpeg2000CompressionFactor | Gets or sets Jpeg2000 compression factor.
Public property | JpegQuality | Gets or sets Jpeg quality.
Public property | Resolution | Gets the resolution of this image
Public property | Width | Gets the width of this image
Top
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.Height Property

PdfImageTicketHeight Property

Gets the height of this image

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.Jpeg2000CompressionFactor Property

PdfImageTicketJpeg2000CompressionFactor Property

Gets or sets Jpeg2000 compression factor.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Jpeg2000CompressionFactor { get; set; }
Public Property Jpeg2000CompressionFactor As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.JpegQuality Property

PdfImageTicketJpegQuality Property

Gets or sets Jpeg quality.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.Resolution Property

PdfImageTicketResolution Property

Gets the resolution of this image

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Dpi Resolution { get; }
Public ReadOnly Property Resolution As Dpi
    Get

Property Value

Type: Dpi
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.Width Property

PdfImageTicketWidth Property

Gets the width of this image

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket Methods

The PdfImageTicket type exposes the following members.

Methods
 | Name | Description
Public method | ClearImage | ClearImage removes all references to the image in this PdfImageTicket
Public method | ClearPath | ClearPath removes any reference to the path to an image in the PdfImageTicket
Public method | ClearTempFile | ClearTempFile calls Dispose on the DisposableTempFile if it is non-null.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Get the representation of the PdfImageTicket as an AtalaImage
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.ClearImage Method

PdfImageTicketClearImage Method

ClearImage removes all references to the image in this PdfImageTicket

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearImage()
Public Sub ClearImage
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.ClearPath Method

PdfImageTicketClearPath Method

ClearPath removes any reference to the path to an image in the PdfImageTicket

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearPath()
Public Sub ClearPath
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.ClearTempFile Method

PdfImageTicketClearTempFile Method

ClearTempFile calls Dispose on the DisposableTempFile if it is non-null.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearTempFile()
Public Sub ClearTempFile
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfImageTicket.GetImage Method

PdfImageTicketGetImage Method

Get the representation of the PdfImageTicket as an AtalaImage

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalaImage GetImage()
Public Function GetImage As AtalaImage

Return Value

Type: AtalaImage
See Also

Reference

PdfImageTicket Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs Class

This class is used to encapsulate information surrounding PDF page construction in the PDF Translator.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrPdfPageConstructionEventArgs

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfPageConstructionEventArgs
Public Class PdfPageConstructionEventArgs

The PdfPageConstructionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPageConstructionEventArgs | Construct a new PdfPageConstructionEventArgs object.
Top
Properties
 | Name | Description
Public property | OcrPage | The OcrPage object from which a PDF Page will be made.
Public property | PageIndex | The zero-based index of this page within the document.
Public property | PageInfo | The page information associated with this page.
Public property | SkipPage | An indication as to whether or not this page should be skipped.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs Constructor

Construct a new PdfPageConstructionEventArgs object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageConstructionEventArgs(
    OcrPage ocrPage,
    PdfPageInfo pageInfo,
    int pageIndex
)
Public Sub New (
    ocrPage As OcrPage,
    pageInfo As PdfPageInfo,
    pageIndex As Integer
)

Parameters

ocrPage
Type: Atalasoft.OcrOcrPage
The OcrPage object from which a PDF Page will be made.
pageInfo
Type: Atalasoft.OcrPdfPageInfo
The page information associated with this page.
pageIndex
Type: SystemInt32
The zero-based index of this page within the document.
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs Properties

The PdfPageConstructionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OcrPage | The OcrPage object from which a PDF Page will be made.
Public property | PageIndex | The zero-based index of this page within the document.
Public property | PageInfo | The page information associated with this page.
Public property | SkipPage | An indication as to whether or not this page should be skipped.
Top
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs.OcrPage Property

PdfPageConstructionEventArgsOcrPage Property

The OcrPage object from which a PDF Page will be made.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage OcrPage { get; }
Public ReadOnly Property OcrPage As OcrPage
    Get

Property Value

Type: OcrPage
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs.PageIndex Property

PdfPageConstructionEventArgsPageIndex Property

The zero-based index of this page within the document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs.PageInfo Property

PdfPageConstructionEventArgsPageInfo Property

The page information associated with this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageInfo PageInfo { get; }
Public ReadOnly Property PageInfo As PdfPageInfo
    Get

Property Value

Type: PdfPageInfo
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs.SkipPage Property

PdfPageConstructionEventArgsSkipPage Property

An indication as to whether or not this page should be skipped.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SkipPage { get; set; }
Public Property SkipPage As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Set this property to true to skip this page. The default value is false.
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventArgs Methods

The PdfPageConstructionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfPageConstructionEventArgs Class
Atalasoft.Ocr Namespace


PdfPageConstructionEventHandler Delegate

Event responsible for notifying about Pdf Page Contruction items.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PdfPageConstructionEventHandler(
    Object sender,
    PdfPageConstructionEventArgs e
)
Public Delegate Sub PdfPageConstructionEventHandler (
    sender As Object,
    e As PdfPageConstructionEventArgs
)

Parameters

sender
Type: SystemObject
The object that is sending the information.
e
Type: Atalasoft.OcrPdfPageConstructionEventArgs
The event details.
See Also

Reference

Atalasoft.Ocr Namespace


PdfPageInfo Class

PdfPageInfo represents metadata for each page within an OcrPage in the process of being translated to PDF.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrPdfPageInfo

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfPageInfo
Public Class PdfPageInfo

The PdfPageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPageInfo | Constructs a new PdfPageInfo object using reasonable default values
Public method | PdfPageInfo(PdfTranslator) | Constructs a new PdfPageInfo object inheriting default values from an owning PdfTranslator
Top
Properties
 | Name | Description
Public property | CompressionSelector | The CompressionSelector is a delegate that is used to choose the compression for an image.
Public property | GenerateThumbnails | Determines whether or not a thumbnail will be generated for this page.
Public property | OutputType | Determines the output style for this page.
Public property | PageImage | A PdfImageTicket that represents the full image for this page.
Public property | PdfPageSize | The dimensions of the output page in PDF page units (1/72 of an inch)
Public property | TextColor | Determines the default color for text on the page.
Public property | ThumbnailImage | Determines the image that will be used for a thumbnail for a page.
Public property | UseDocumentTextColor | Indicates that the color determined by the document is what will be used for final output.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


PdfPageInfo Constructor

Constructs a new PdfPageInfo object
Overload List
 | Name | Description
Public method | PdfPageInfo | Constructs a new PdfPageInfo object using reasonable default values
Public method | PdfPageInfo(PdfTranslator) | Constructs a new PdfPageInfo object inheriting default values from an owning PdfTranslator
Top
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo Constructor

Constructs a new PdfPageInfo object using reasonable default values

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageInfo()
Public Sub New
See Also

Reference

PdfPageInfo Class
PdfPageInfo Overload
Atalasoft.Ocr Namespace


PdfPageInfo Constructor (PdfTranslator)

Constructs a new PdfPageInfo object inheriting default values from an owning PdfTranslator

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageInfo(
    PdfTranslator owner
)
Public Sub New (
    owner As PdfTranslator
)

Parameters

owner
Type: Atalasoft.OcrPdfTranslator
The PdfTranslator that created this PdfPageInfo object
See Also

Reference

PdfPageInfo Class
PdfPageInfo Overload
Atalasoft.Ocr Namespace


PdfPageInfo Properties

The PdfPageInfo type exposes the following members.

Properties
 | Name | Description
Public property | CompressionSelector | The CompressionSelector is a delegate that is used to choose the compression for an image.
Public property | GenerateThumbnails | Determines whether or not a thumbnail will be generated for this page.
Public property | OutputType | Determines the output style for this page.
Public property | PageImage | A PdfImageTicket that represents the full image for this page.
Public property | PdfPageSize | The dimensions of the output page in PDF page units (1/72 of an inch)
Public property | TextColor | Determines the default color for text on the page.
Public property | ThumbnailImage | Determines the image that will be used for a thumbnail for a page.
Public property | UseDocumentTextColor | Indicates that the color determined by the document is what will be used for final output.
Top
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.CompressionSelector Property

PdfPageInfoCompressionSelector Property

The CompressionSelector is a delegate that is used to choose the compression for an image.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressionSelector CompressionSelector { get; set; }
Public Property CompressionSelector As PdfCompressionSelector
    Get
    Set

Property Value

Type: PdfCompressionSelector
Remarks
The compression selector is used to choose a compression mode for an image into a PDF file. With a null CompressionSelector, the PdfTranslator will choose the what it thinks is the most appropriate compression scheme for any given image. Default value is null.
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.GenerateThumbnails Property

PdfPageInfoGenerateThumbnails Property

Determines whether or not a thumbnail will be generated for this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GenerateThumbnails { get; set; }
Public Property GenerateThumbnails As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Even with this value set to true, it may not always be possible to generate a thumbnail for a page. Default value is true.
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.OutputType Property

PdfPageInfoOutputType Property

Determines the output style for this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTranslatorOutputType OutputType { get; set; }
Public Property OutputType As PdfTranslatorOutputType
    Get
    Set

Property Value

Type: PdfTranslatorOutputType
Remarks
Default value is TextAndImages.
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.PageImage Property

PdfPageInfoPageImage Property

A PdfImageTicket that represents the full image for this page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageTicket PageImage { get; set; }
Public Property PageImage As PdfImageTicket
    Get
    Set

Property Value

Type: PdfImageTicket
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.PdfPageSize Property

PdfPageInfoPdfPageSize Property

The dimensions of the output page in PDF page units (1/72 of an inch)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF PdfPageSize { get; set; }
Public Property PdfPageSize As SizeF
    Get
    Set

Property Value

Type: SizeF
Remarks
In typical operation this value is generated by the translator.
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.TextColor Property

PdfPageInfoTextColor Property

Determines the default color for text on the page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set

Property Value

Type: Color
Remarks
By default, this will be black.
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.ThumbnailImage Property

PdfPageInfoThumbnailImage Property

Determines the image that will be used for a thumbnail for a page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageTicket ThumbnailImage { get; set; }
Public Property ThumbnailImage As PdfImageTicket
    Get
    Set

Property Value

Type: PdfImageTicket
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo.UseDocumentTextColor Property

PdfPageInfoUseDocumentTextColor Property

Indicates that the color determined by the document is what will be used for final output.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseDocumentTextColor { get; set; }
Public Property UseDocumentTextColor As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
If set to true, the text colors reported by the document will be used. If set to false, the PdfPageInfo's TextColor will be used instead. Default is true.
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfPageInfo Methods

The PdfPageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfPageInfo Class
Atalasoft.Ocr Namespace


PdfTranslationSession Class

PdfTranslationSession is a helper class used by the PdfTranslator to maintain state information about the current document being translated.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrPdfTranslationSession

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTranslationSession
Public Class PdfTranslationSession

The PdfTranslationSession type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTranslationSession | Constructs a new PdfTranslationSession object.
Top
Properties
 | Name | Description
Public property | Engine | Returns the engine to which this session is attached.
Public property | SessionID | Returns a session ID for this session.
Public property | TempPath | Returns a base path used for temporary files for this session.
Public property | UseTempFiles | Determines whether or not this session will use temporary files for translation.
Top
Methods
 | Name | Description
Public method | ConnectToEngine | Connect this session to the engine being used to generate a PDF document.
Public method | DisconnectFromEngine | Removes prior connections to the engine
Public method | Dispose | Releases all resources used by the PdfTranslationSession
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextImageID | This is a utility method used by a session to uniquely identify images within a document
Public method | GetNextImageResourceName | This is a utility method used for generating resource names for images inside the Pdf document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


PdfTranslationSession Constructor

Constructs a new PdfTranslationSession object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTranslationSession(
    PdfTranslator owner
)
Public Sub New (
    owner As PdfTranslator
)

Parameters

owner
Type: Atalasoft.OcrPdfTranslator
The translator that is using this session.
Remarks
This object is used internally. In typical usage, a client need not use this object directly.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession Properties

The PdfTranslationSession type exposes the following members.

Properties
 | Name | Description
Public property | Engine | Returns the engine to which this session is attached.
Public property | SessionID | Returns a session ID for this session.
Public property | TempPath | Returns a base path used for temporary files for this session.
Public property | UseTempFiles | Determines whether or not this session will use temporary files for translation.
Top
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.Engine Property

PdfTranslationSessionEngine Property

Returns the engine to which this session is attached.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEngine Engine { get; }
Public ReadOnly Property Engine As OcrEngine
    Get

Property Value

Type: OcrEngine
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.SessionID Property

PdfTranslationSessionSessionID Property

Returns a session ID for this session.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SessionID { get; }
Public ReadOnly Property SessionID As Integer
    Get

Property Value

Type: Int32
Remarks
The session ID is used for tracking temporary files by the translator. There is typically no need to call this method in client code.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.TempPath Property

PdfTranslationSessionTempPath Property

Returns a base path used for temporary files for this session.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TempPath { get; }
Public ReadOnly Property TempPath As String
    Get

Property Value

Type: String
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.UseTempFiles Property

PdfTranslationSessionUseTempFiles Property

Determines whether or not this session will use temporary files for translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseTempFiles { get; }
Public ReadOnly Property UseTempFiles As Boolean
    Get

Property Value

Type: Boolean
Remarks
Default is true. When set to false, the PdfTranslator will attempt to keep a copy of every page image and every thumbnail in memory. For small documents of a few pages or less, this is acceptable and will boost overall performance, but is impractical for larger documents.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession Methods

The PdfTranslationSession type exposes the following members.

Methods
 | Name | Description
Public method | ConnectToEngine | Connect this session to the engine being used to generate a PDF document.
Public method | DisconnectFromEngine | Removes prior connections to the engine
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextImageID | This is a utility method used by a session to uniquely identify images within a document
Public method | GetNextImageResourceName | This is a utility method used for generating resource names for images inside the Pdf document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.ConnectToEngine Method

PdfTranslationSessionConnectToEngine Method

Connect this session to the engine being used to generate a PDF document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ConnectToEngine(
    OcrEngine engine,
    OcrDocument doc
)
Public Sub ConnectToEngine (
    engine As OcrEngine,
    doc As OcrDocument
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that will be used to recognize a set of images.
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument into which the resulting pages will be added.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.DisconnectFromEngine Method

PdfTranslationSessionDisconnectFromEngine Method

Removes prior connections to the engine

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DisconnectFromEngine(
    OcrEngine engine,
    OcrDocument doc
)
Public Sub DisconnectFromEngine (
    engine As OcrEngine,
    doc As OcrDocument
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine to which this session was previously connected.
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument generated by the engine.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.Dispose Method

PdfTranslationSessionDispose Method

Releases all resources used by the PdfTranslationSession

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.GetNextImageID Method

PdfTranslationSessionGetNextImageID Method

This is a utility method used by a session to uniquely identify images within a document

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetNextImageID()
Public Function GetNextImageID As Integer

Return Value

Type: Int32
Remarks
There is typically no need to call this method in client code.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslationSession.GetNextImageResourceName Method

PdfTranslationSessionGetNextImageResourceName Method

This is a utility method used for generating resource names for images inside the Pdf document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetNextImageResourceName()
Public Function GetNextImageResourceName As String

Return Value

Type: String
Remarks
There is typically no need to call this method in client code.
See Also

Reference

PdfTranslationSession Class
Atalasoft.Ocr Namespace


PdfTranslator Class

The PdfTranslator object is a general-purpose object for translating OcrDocuments and their pages into PDF files or streams.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrPdfTranslator

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTranslator : IForeignTranslator,
    ITranslator, IPerPageTranslator
Public Class PdfTranslator
    Implements IForeignTranslator, ITranslator, IPerPageTranslator

The PdfTranslator type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTranslator | Constructs a new PdfTranslator object.
Public method | PdfTranslator(PdfDocumentType) | Constructs a new PdfTranslator object.
Top
Properties
 | Name | Description
Public property | AdjustPdfVersionAsNeeded | Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.
Public property | Author | Gets or sets the Author metadata to write in the resulting PDF.
Public property | AutoPageRotation | Determines if the PDFTranslator will correct page rotation
 | BookmarkTree | Gets or sets the PDF bookmark tree that will be used with this document. Default value is null (no tree).
Public property | ClearOcrPageContents | Controls the behavior of the translator with respect to keeping OcrPages in memory.
Public property | CompressionSelector | This delegate can be used to select a compression type for images in an output PDF file.
Public property | Creator | Gets or sets the Creator metadata to write in the resulting PDF.
Public property | DocumentType | Specifies the type of PDF document that will be produced, including PDF-A.
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata should be encrypted. Default is true.
Public property | EnforceWordWidths | Indicates that the PdfTranslator should apply a horizontal scale to the text in a word to match the word bounding box as accurately as possible using the font size reported by the OCR engine.
Public property | GenerateDefaultColorProfile | Specifies if the PdfTranslator should try to generate it's default ColorProfiles for images added.
Public property | GenerateThumbnails | Indicates whether or not the translator will generate thumnail images.
Public property | Jpeg2000CompressionFactor | Sets or gets the compression factor for Jpeg2000 images
Public property | JpegQuality | Sets or gets the JpegQuality that will be used for images compressed with Jpeg.
Public property | Keywords | Gets or sets the Keywords metadata to write in the resulting PDF.
Public property | Metadata | Document metadata for the output file
Public property | OutputType | The output style for pages.
Public property | OwnerPassword | Obsolete. Sets or gets an owner password to use for the document. Default value is null (no password).
Public property | PdfVersion | Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.
Public property | Permissions | Sets or gets the set of allowable actions for this PDF.
Public property | Producer | Gets or sets the Producer metadata to write in the resulting PDF.
Public property | SetDocumentMetadata | Gets or sets a value indicating if metadata should be included in the document.
Public property | Subject | Gets or sets the Subject metadata to write in the resulting PDF.
Public property | TempPath | Sets or gets a path to use for temporary files.
Public property | TextColor | Sets or gets a Color that can be used to override the recognized text color.
Public property | Title | Gets or sets the Title metadata to write in the resulting PDF.
Public property | UseCompressedObjectStreams | Gets or sets a value indicating whether the PDF document contains compressed object streams.
Public property | UseDocumentTextColor | Indicates whether or not the document's text color will be used.
Public property | UseIForeignTranslatorInterface | Indicates whether or not the PdfTranslator should use the older IForeignTranslator interface or the newer IPerPageTranslator interface
Public property | UseNormalizedBaseline | Indicates whether or not the translator will attempt to normalize the baseline for a line of text.
Public property | UserPassword | Obsolete. Sets or gets a user password to use for the document. Default value is null (no password).
Public property | UseTempFiles | Indicates whether or not temporary files will be used for page images in translation.
Top
Methods
 | Name | Description
Public method | CanStream | Indicates whether or not this translator can write to a Stream object
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finish a translation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPageConstructing | This method fires the PageConstructing event
Public method | Prepare(OcrEngine, OcrDocument) | Prepares the PdfTranslator for output
Public method | Prepare(OcrEngine, OcrDocument, String, Stream) | Prepares the PdfTranslator for output
Public method | Prepare(OcrEngine, OcrDocument, String, String) | Prepares the PdfTranslator for output
Public method | SetOneTimePasswords | Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after calling Translate method.
Public method | Supported | Returns an array of strings representing the MIME types supported by this translator.
Public method | Supports | Indicates whether or not this translator supports a given MIME type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) | Translates an OcrDocument to a new output format writing to the given Stream.
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) | Translates an OcrDocument to a new output format writing to the given path.
Public method | TranslatePage | Translates an individual page to a PDF page.
Top
Events
 | Name | Description
Public event | PageConstructing | This event is used to track when each OcrPage object is about to be translated into a PDF page.
Top
Remarks
Use this translator to create searchable PDF's from any supported OCR engine. Supports the MIME Type "application/pdf".
See Also

Reference

Atalasoft.Ocr Namespace


PdfTranslator Constructor

Constructs a new PdfTranslator object.
Overload List
 | Name | Description
Public method | PdfTranslator | Constructs a new PdfTranslator object.
Public method | PdfTranslator(PdfDocumentType) | Constructs a new PdfTranslator object.
Top
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator Constructor

Constructs a new PdfTranslator object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTranslator()
Public Sub New
See Also

Reference

PdfTranslator Class
PdfTranslator Overload
Atalasoft.Ocr Namespace


PdfTranslator Constructor (PdfDocumentType)

Constructs a new PdfTranslator object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTranslator(
    PdfDocumentType documentType
)
Public Sub New (
    documentType As PdfDocumentType
)

Parameters

documentType
Type: Atalasoft.PdfDocPdfDocumentType
The type of PDF document to create. This can be used to select a PDF/A-1B document.
Remarks
Note that PDF/A-1B documents will be larger as they require all fonts to be embedded and images may not use JBIG2 or JPEG2000 encoders.
See Also

Reference

PdfTranslator Class
PdfTranslator Overload
Atalasoft.Ocr Namespace


PdfTranslator Properties

The PdfTranslator type exposes the following members.

Properties
 | Name | Description
Public property | AdjustPdfVersionAsNeeded | Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.
Public property | Author | Gets or sets the Author metadata to write in the resulting PDF.
Public property | AutoPageRotation | Determines if the PDFTranslator will correct page rotation
 | BookmarkTree | Gets or sets the PDF bookmark tree that will be used with this document. Default value is null (no tree).
Public property | ClearOcrPageContents | Controls the behavior of the translator with respect to keeping OcrPages in memory.
Public property | CompressionSelector | This delegate can be used to select a compression type for images in an output PDF file.
Public property | Creator | Gets or sets the Creator metadata to write in the resulting PDF.
Public property | DocumentType | Specifies the type of PDF document that will be produced, including PDF-A.
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata should be encrypted. Default is true.
Public property | EnforceWordWidths | Indicates that the PdfTranslator should apply a horizontal scale to the text in a word to match the word bounding box as accurately as possible using the font size reported by the OCR engine.
Public property | GenerateDefaultColorProfile | Specifies if the PdfTranslator should try to generate it's default ColorProfiles for images added.
Public property | GenerateThumbnails | Indicates whether or not the translator will generate thumnail images.
Public property | Jpeg2000CompressionFactor | Sets or gets the compression factor for Jpeg2000 images
Public property | JpegQuality | Sets or gets the JpegQuality that will be used for images compressed with Jpeg.
Public property | Keywords | Gets or sets the Keywords metadata to write in the resulting PDF.
Public property | Metadata | Document metadata for the output file
Public property | OutputType | The output style for pages.
Public property | OwnerPassword | Obsolete. Sets or gets an owner password to use for the document. Default value is null (no password).
Public property | PdfVersion | Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.
Public property | Permissions | Sets or gets the set of allowable actions for this PDF.
Public property | Producer | Gets or sets the Producer metadata to write in the resulting PDF.
Public property | SetDocumentMetadata | Gets or sets a value indicating if metadata should be included in the document.
Public property | Subject | Gets or sets the Subject metadata to write in the resulting PDF.
Public property | TempPath | Sets or gets a path to use for temporary files.
Public property | TextColor | Sets or gets a Color that can be used to override the recognized text color.
Public property | Title | Gets or sets the Title metadata to write in the resulting PDF.
Public property | UseCompressedObjectStreams | Gets or sets a value indicating whether the PDF document contains compressed object streams.
Public property | UseDocumentTextColor | Indicates whether or not the document's text color will be used.
Public property | UseIForeignTranslatorInterface | Indicates whether or not the PdfTranslator should use the older IForeignTranslator interface or the newer IPerPageTranslator interface
Public property | UseNormalizedBaseline | Indicates whether or not the translator will attempt to normalize the baseline for a line of text.
Public property | UserPassword | Obsolete. Sets or gets a user password to use for the document. Default value is null (no password).
Public property | UseTempFiles | Indicates whether or not temporary files will be used for page images in translation.
Top
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.AdjustPdfVersionAsNeeded Property

PdfTranslatorAdjustPdfVersionAsNeeded Property

Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AdjustPdfVersionAsNeeded { get; set; }
Public Property AdjustPdfVersionAsNeeded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [adjust PDF version as needed]; otherwise, false.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Author Property

PdfTranslatorAuthor Property

Gets or sets the Author metadata to write in the resulting PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.AutoPageRotation Property

PdfTranslatorAutoPageRotation Property

Determines if the PDFTranslator will correct page rotation

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoPageRotation { get; set; }
Public Property AutoPageRotation As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
If set to true, the PDFTranslator will rotate an entire page to reflect correct reading order if every text region within a given page is rotated the same direction.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.BookmarkTree Property

PdfTranslatorBookmarkTree Property

Gets or sets the PDF bookmark tree that will be used with this document. Default value is null (no tree).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkTree BookmarkTree { get; set; }
Public Property BookmarkTree As PdfBookmarkTree
    Get
    Set

Property Value

Type: PdfBookmarkTree
Examples
Copy
 encoder.BookmarkTree = new PdfBookmarkTree();
PdfGotoViewAction action = PdfGotoViewAction.FitPage();
action.Page = new PdfIndexedPageReference(0);
PdfBookmark bookmark = new PdfBookmark("Introduction", action);
encoder.BookmarkTree.Bookmarks.Add(bookmark);
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.ClearOcrPageContents Property

PdfTranslatorClearOcrPageContents Property

Controls the behavior of the translator with respect to keeping OcrPages in memory.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ClearOcrPageContents { get; set; }
Public Property ClearOcrPageContents As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When set to true, the PdfTranslator will clear the Regions property of every OcrPage after it has been transformed to PDF. This will reduce the amount of memory consumed by the PdfTranslator for large documents.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.CompressionSelector Property

PdfTranslatorCompressionSelector Property

This delegate can be used to select a compression type for images in an output PDF file.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressionSelector CompressionSelector { get; set; }
Public Property CompressionSelector As PdfCompressionSelector
    Get
    Set

Property Value

Type: PdfCompressionSelector
Remarks
Default value is null. In this case, the Translator will decide the most appropriate compression.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Creator Property

PdfTranslatorCreator Property

Gets or sets the Creator metadata to write in the resulting PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.DocumentType Property

PdfTranslatorDocumentType Property

Specifies the type of PDF document that will be produced, including PDF-A.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentType DocumentType { get; set; }
Public Property DocumentType As PdfDocumentType
    Get
    Set

Property Value

Type: PdfDocumentType
A value indicating the type of PDF document that will be produced.
Remarks

The default value is PdfDocumentType.Default which allows the encoder the greatest latitude in creating PDF files.

,When using PDFA1b, the user must either provide appropriate ColorSpaces for all images or set GenerateDefaultColorProfile to true. ,

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.EncryptMetadata Property

PdfTranslatorEncryptMetadata Property

Sets or gets a boolean indicating that metadata should be encrypted. Default is true.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EncryptMetadata { get; set; }
Public Property EncryptMetadata As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

When a PDF document is encrypted, nearly all embedded strings and stream data are encrypted. Metadata stream do not have to be encrypted. This allows indexing software to retrieve metadata without needing to know document passwords.

This value is ignored for the PDF versions below 2.0.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.EnforceWordWidths Property

PdfTranslatorEnforceWordWidths Property

Indicates that the PdfTranslator should apply a horizontal scale to the text in a word to match the word bounding box as accurately as possible using the font size reported by the OCR engine.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnforceWordWidths { get; set; }
Public Property EnforceWordWidths As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is true.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.GenerateDefaultColorProfile Property

PdfTranslatorGenerateDefaultColorProfile Property

Specifies if the PdfTranslator should try to generate it's default ColorProfiles for images added.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GenerateDefaultColorProfile { get; set; }
Public Property GenerateDefaultColorProfile As Boolean
    Get
    Set

Property Value

Type: Boolean
A boolean which specifies if the PdfTranslator will try to automatically generate ColorProfiles for embedded images.
Remarks

This is designed to primarily be used for automatic PDFA compliance.

Currently, CMYK Color Profiles cannot be automatically generated.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.GenerateThumbnails Property

PdfTranslatorGenerateThumbnails Property

Indicates whether or not the translator will generate thumnail images.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool GenerateThumbnails { get; set; }
Public Property GenerateThumbnails As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false. When true the translator will attempt to honor it, but this is only possible if the translator has a stashed copy of the original page image.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Jpeg2000CompressionFactor Property

PdfTranslatorJpeg2000CompressionFactor Property

Sets or gets the compression factor for Jpeg2000 images

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Jpeg2000CompressionFactor { get; set; }
Public Property Jpeg2000CompressionFactor As Double
    Get
    Set

Property Value

Type: Double
Remarks

This property is only used when an image within a document has been marked as being compressed with Jpeg2000 compression. If the image is compressed with some other compression or the Jpeg2000 encoder is not present, this property will be ignored.

See the dotImage documentation for a full description of the Jpeg2000 encoder and its properties.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.JpegQuality Property

PdfTranslatorJpegQuality Property

Sets or gets the JpegQuality that will be used for images compressed with Jpeg.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
A value between 1 and 100, inclusive
Remarks
Higher values are better quality. Lower values create smaller files. The default is 80.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Keywords Property

PdfTranslatorKeywords Property

Gets or sets the Keywords metadata to write in the resulting PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Metadata Property

PdfTranslatorMetadata Property

Document metadata for the output file

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentMetadata Metadata { get; }
Public ReadOnly Property Metadata As PdfDocumentMetadata
    Get

Property Value

Type: PdfDocumentMetadata
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.OutputType Property

PdfTranslatorOutputType Property

The output style for pages.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTranslatorOutputType OutputType { get; set; }
Public Property OutputType As PdfTranslatorOutputType
    Get
    Set

Property Value

Type: PdfTranslatorOutputType
Remarks
Default value is TextUnderImage.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.OwnerPassword Property

PdfTranslatorOwnerPassword Property

Note: This API is now obsolete.

Sets or gets an owner password to use for the document. Default value is null (no password).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.PdfVersion Property

PdfTranslatorPdfVersion Property

Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PdfVersion { get; set; }
Public Property PdfVersion As Double
    Get
    Set

Property Value

Type: Double
The PDF version of the output document.
Remarks
Setting this value indicates the maximum version desired. It is possible that the output document could be read under earlier versions of the PDF standard, but it will be marked as the number specified. AdjustPdfVersionAsNeeded can be used to make an automatic setting.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Permissions Property

PdfTranslatorPermissions Property

Sets or gets the set of allowable actions for this PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAccessPermissions Permissions { get; set; }
Public Property Permissions As PdfAccessPermissions
    Get
    Set

Property Value

Type: PdfAccessPermissions
Remarks
PdfAccessPermissions refer to permissions that are allowed within a PDF document. Permissions are granted by allowing actions rather than preventing them.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Producer Property

PdfTranslatorProducer Property

Gets or sets the Producer metadata to write in the resulting PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Producer { get; set; }
Public Property Producer As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.SetDocumentMetadata Property

PdfTranslatorSetDocumentMetadata Property

Gets or sets a value indicating if metadata should be included in the document.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetDocumentMetadata { get; set; }
Public Property SetDocumentMetadata As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Subject Property

PdfTranslatorSubject Property

Gets or sets the Subject metadata to write in the resulting PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.TempPath Property

PdfTranslatorTempPath Property

Sets or gets a path to use for temporary files.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TempPath { get; set; }
Public Property TempPath As String
    Get
    Set

Property Value

Type: String
Remarks
Default is the appropriate operating system temporary folder.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.TextColor Property

PdfTranslatorTextColor Property

Sets or gets a Color that can be used to override the recognized text color.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set

Property Value

Type: Color
Remarks
This value will be used when UseDocumentTextColor is set to false. Default value is black.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Title Property

PdfTranslatorTitle Property

Gets or sets the Title metadata to write in the resulting PDF.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.UseCompressedObjectStreams Property

PdfTranslatorUseCompressedObjectStreams Property

Gets or sets a value indicating whether the PDF document contains compressed object streams.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseCompressedObjectStreams { get; set; }
Public Property UseCompressedObjectStreams As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

PDF/A-1 does not support compressed object streams.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.UseDocumentTextColor Property

PdfTranslatorUseDocumentTextColor Property

Indicates whether or not the document's text color will be used.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseDocumentTextColor { get; set; }
Public Property UseDocumentTextColor As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When set to false, the TextColor property will be used. Default value is true.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.UseIForeignTranslatorInterface Property

PdfTranslatorUseIForeignTranslatorInterface Property

Indicates whether or not the PdfTranslator should use the older IForeignTranslator interface or the newer IPerPageTranslator interface

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseIForeignTranslatorInterface { get; set; }
Public Property UseIForeignTranslatorInterface As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IPerPageTranslatorUseIForeignTranslatorInterface
Remarks
Default is false
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.UseNormalizedBaseline Property

PdfTranslatorUseNormalizedBaseline Property

Indicates whether or not the translator will attempt to normalize the baseline for a line of text.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseNormalizedBaseline { get; set; }
Public Property UseNormalizedBaseline As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default is true. There is usually a fair amount of variability in the baseline of words in a line. Setting this to true attempts to compensate for that variability by averaging the baselines of a line's components.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.UserPassword Property

PdfTranslatorUserPassword Property

Note: This API is now obsolete.

Sets or gets a user password to use for the document. Default value is null (no password).

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.UseTempFiles Property

PdfTranslatorUseTempFiles Property

Indicates whether or not temporary files will be used for page images in translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseTempFiles { get; set; }
Public Property UseTempFiles As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default is true. When set to false, the PdfTranslator will attempt to keep a copy of every page image and every thumbnail in memory. For small documents of a few pages or less, this is acceptable and will boost overall performance, but is impractical for larger documents.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator Methods

The PdfTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Indicates whether or not this translator can write to a Stream object
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finish a translation.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPageConstructing | This method fires the PageConstructing event
Public method | Prepare(OcrEngine, OcrDocument) | Prepares the PdfTranslator for output
Public method | Prepare(OcrEngine, OcrDocument, String, Stream) | Prepares the PdfTranslator for output
Public method | Prepare(OcrEngine, OcrDocument, String, String) | Prepares the PdfTranslator for output
Public method | SetOneTimePasswords | Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after calling Translate method.
Public method | Supported | Returns an array of strings representing the MIME types supported by this translator.
Public method | Supports | Indicates whether or not this translator supports a given MIME type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) | Translates an OcrDocument to a new output format writing to the given Stream.
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) | Translates an OcrDocument to a new output format writing to the given path.
Public method | TranslatePage | Translates an individual page to a PDF page.
Top
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.CanStream Method

PdfTranslatorCanStream Method

Indicates whether or not this translator can write to a Stream object

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanStream()
Public Function CanStream As Boolean

Return Value

Type: Boolean

Implements

ITranslatorCanStream
Remarks
Always returns true, but the stream must be seekable.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Finish Method

PdfTranslatorFinish Method

Finish a translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Finish(
    OcrEngine engine,
    OcrDocument doc,
    bool successful,
    Object translationObject
)
Public Sub Finish (
    engine As OcrEngine,
    doc As OcrDocument,
    successful As Boolean,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that invoked the translation.
doc
Type: Atalasoft.OcrOcrDocument
The generated document.
successful
Type: SystemBoolean
Indicates whether or not the translation was successful.
translationObject
Type: SystemObject
The translation-specific object generated by PdfTranslator.Prepare.

Implements

IForeignTranslatorFinish(OcrEngine, OcrDocument, Boolean, Object)
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.OnPageConstructing Method

PdfTranslatorOnPageConstructing Method

This method fires the PageConstructing event

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnPageConstructing(
    PdfPageConstructionEventArgs e
)
Protected Overridable Sub OnPageConstructing (
    e As PdfPageConstructionEventArgs
)

Parameters

e
Type: Atalasoft.OcrPdfPageConstructionEventArgs
The page construction argument.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Prepare Method

PdfTranslatorPrepare Method

Prepares the PdfTranslator for output
Overload List
 | Name | Description
Public method | Prepare(OcrEngine, OcrDocument) | Prepares the PdfTranslator for output
Public method | Prepare(OcrEngine, OcrDocument, String, Stream) | Prepares the PdfTranslator for output
Public method | Prepare(OcrEngine, OcrDocument, String, String) | Prepares the PdfTranslator for output
Top
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Prepare Method (OcrEngine, OcrDocument)

PdfTranslatorPrepare Method (OcrEngine, OcrDocument)

Prepares the PdfTranslator for output
Prepares a translator for document translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Prepare(
    OcrEngine engine,
    OcrDocument doc
)
Public Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The OcrEngine requesting translation
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument which receives OcrPages during translation

Return Value

Type: Object

Implements

IForeignTranslatorPrepare(OcrEngine, OcrDocument)
See Also

Reference

PdfTranslator Class
Prepare Overload
Atalasoft.Ocr Namespace


PdfTranslator.Prepare Method (OcrEngine, OcrDocument, String, Stream)

PdfTranslatorPrepare Method (OcrEngine, OcrDocument, String, Stream)

Prepares the PdfTranslator for output

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Prepare(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    Stream outStream
)
Public Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outStream As Stream
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The OcrEngine requesting translation
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument which receives OcrPages during translation
mimeType
Type: SystemString
The requested output mime type. This should always be "application/pdf"
outStream
Type: System.IOStream
A stream for the output PDF file. This stream should allow seeking

Return Value

Type: Object

Implements

IPerPageTranslatorPrepare(OcrEngine, OcrDocument, String, Stream)
See Also

Reference

PdfTranslator Class
Prepare Overload
Atalasoft.Ocr Namespace


PdfTranslator.Prepare Method (OcrEngine, OcrDocument, String, String)

PdfTranslatorPrepare Method (OcrEngine, OcrDocument, String, String)

Prepares the PdfTranslator for output

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Prepare(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    string outFileName
)
Public Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outFileName As String
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The OcrEngine requesting translation
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument which receives OcrPages during translation
mimeType
Type: SystemString
The requested output mime type. This should always be "application/pdf"
outFileName
Type: SystemString
The path to the output PDF file

Return Value

Type: Object

Implements

IPerPageTranslatorPrepare(OcrEngine, OcrDocument, String, String)
See Also

Reference

PdfTranslator Class
Prepare Overload
Atalasoft.Ocr Namespace


PdfTranslator.SetOneTimePasswords Method

PdfTranslatorSetOneTimePasswords Method

Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after calling Translate method.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetOneTimePasswords(
    SecureString userPassword,
    SecureString ownerPassword = null
)
Public Sub SetOneTimePasswords (
    userPassword As SecureString,
    Optional ownerPassword As SecureString = Nothing
)

Parameters

userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password.
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Supported Method

PdfTranslatorSupported Method

Returns an array of strings representing the MIME types supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] Supported()
Public Function Supported As String()

Return Value

Type: String

Implements

ITranslatorSupported
Remarks
Will always return "application/pdf"
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Supports Method

PdfTranslatorSupports Method

Indicates whether or not this translator supports a given MIME type.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Supports(
    string mimeType
)
Public Function Supports (
    mimeType As String
) As Boolean

Parameters

mimeType
Type: SystemString
The MIME type to be checked.

Return Value

Type: Boolean
True if the MIME type is supported, false otherwise.

Implements

ITranslatorSupports(String)
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Translate Method

PdfTranslatorTranslate Method

Translate an OcrDocument to a new output format.
Overload List
 | Name | Description
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) | Translates an OcrDocument to a new output format writing to the given Stream.
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) | Translates an OcrDocument to a new output format writing to the given path.
Top
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.Translate Method (OcrEngine, OcrDocument, String, Stream, Object)

PdfTranslatorTranslate Method (OcrEngine, OcrDocument, String, Stream, Object)

Translates an OcrDocument to a new output format writing to the given Stream.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    Stream outStream,
    Object translationObject
)
Public Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outStream As Stream,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that has recognized the document.
doc
Type: Atalasoft.OcrOcrDocument
The recognized document
mimeType
Type: SystemString
The requested MIME type
outStream
Type: System.IOStream
The Stream to write to
translationObject
Type: SystemObject
The object returned by a previous call to Prepare

Implements

IForeignTranslatorTranslate(OcrEngine, OcrDocument, String, Stream, Object)
See Also

Reference

PdfTranslator Class
Translate Overload
Atalasoft.Ocr Namespace


PdfTranslator.Translate Method (OcrEngine, OcrDocument, String, String, Object)

PdfTranslatorTranslate Method (OcrEngine, OcrDocument, String, String, Object)

Translates an OcrDocument to a new output format writing to the given path.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    string outFileName,
    Object translationObject
)
Public Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outFileName As String,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that has recognized the document.
doc
Type: Atalasoft.OcrOcrDocument
The recognized document
mimeType
Type: SystemString
The requested MIME type
outFileName
Type: SystemString
The path to the output file
translationObject
Type: SystemObject
The object returned by a previous call to Prepare

Implements

IForeignTranslatorTranslate(OcrEngine, OcrDocument, String, String, Object)
See Also

Reference

PdfTranslator Class
Translate Overload
Atalasoft.Ocr Namespace


PdfTranslator.TranslatePage Method

PdfTranslatorTranslatePage Method

Translates an individual page to a PDF page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void TranslatePage(
    OcrEngine engine,
    OcrDocument doc,
    OcrPage page,
    Object translationObject,
    bool totalPagesKnown,
    int pageIndex,
    int totalPages
)
Public Sub TranslatePage (
    engine As OcrEngine,
    doc As OcrDocument,
    page As OcrPage,
    translationObject As Object,
    totalPagesKnown As Boolean,
    pageIndex As Integer,
    totalPages As Integer
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The OcrEngine requesting translation
doc
Type: Atalasoft.OcrOcrDocument
The OcrDocument which receives OcrPages during translation
page
Type: Atalasoft.OcrOcrPage
The last OcrPage that has been translated
translationObject
Type: SystemObject
The object returned by IPerPageTranslator.Prepare
totalPagesKnown
Type: SystemBoolean
A boolean indicating whether or not the total page count is known
pageIndex
Type: SystemInt32
The zero-based index of the current page
totalPages
Type: SystemInt32
The total pages (this is only valid if totalPagesKnown is true)

Implements

IPerPageTranslatorTranslatePage(OcrEngine, OcrDocument, OcrPage, Object, Boolean, Int32, Int32)
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator Events

The PdfTranslator type exposes the following members.

Events
 | Name | Description
Public event | PageConstructing | This event is used to track when each OcrPage object is about to be translated into a PDF page.
Top
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslator.PageConstructing Event

PdfTranslatorPageConstructing Event

This event is used to track when each OcrPage object is about to be translated into a PDF page.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event PdfPageConstructionEventHandler PageConstructing
Public Event PageConstructing As PdfPageConstructionEventHandler

Value

Type: Atalasoft.OcrPdfPageConstructionEventHandler
Remarks
In addition to being able to make late changes to the OcrPage contents, it is possible to induce the PdfTranslator to skip pages within the document via the SkipPage property in the PdfPageConstructionEventArgs.
See Also

Reference

PdfTranslator Class
Atalasoft.Ocr Namespace


PdfTranslatorOutputType Enumeration

This enumeration defines how the PdfTranslator will create its pages

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTranslatorOutputType
Public Enumeration PdfTranslatorOutputType
Members
Member name | Description
TextAndImages | Text and images will be placed on the pages separately.
TextOnly | Only text will be placed on the pages.
TextUnderImage | The entire image will be placed on the page with "invisible" text under it
ImagesOnly | Only images will be placed on the pages
TextAndClippedImage | Text and the entire image will be placed on the page, but the image will be clipped to areas defined as separate images by the OcrEngine
See Also

Reference

Atalasoft.Ocr Namespace


TextTranslator Class

Outputs OCR into formatted text.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrTextTranslator

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextTranslator : IForeignTranslator,
    ITranslator
Public Class TextTranslator
    Implements IForeignTranslator, ITranslator

The TextTranslator type exposes the following members.

Constructors
 | Name | Description
Public method | TextTranslator | Default Constructor for TextTranslator.
Public method | TextTranslator(TextWhitespaceMode, String, Single, Single, Encoding, Single) | Initializes a new instance of the TextTranslator class with given parameter values.
Top
Properties
 | Name | Description
Public property | CharacterSpaceMaximum | Property that allows for the getting and setting of the character width scale
Public property | EncodingMethod | Property that allows for the getting and setting of the text encoding method.
Public property | LineMergeFactor | Property that allows for the getting and setting of the character height scale.
Public property | LineSpacingCutOff | Property that allows for the getting and setting of the line space cut off.
Public property | LineTerminator | Property that allows for the getting and setting of the line terminator.
Public property | Whitespace | Property that allows for the getting and setting of the Whitespace parameter.
Top
Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Allow a foreign translator to perform any necessary cleanup.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Prepare | Prepare a foreign translator for translation.
Public method | Supported | Get an array of mime types supported by this translator.
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
Remarks
Supports the MIME Type "text/plain".
See Also

Reference

Atalasoft.Ocr Namespace


TextTranslator Constructor

Overload List
 | Name | Description
Public method | TextTranslator | Default Constructor for TextTranslator.
Public method | TextTranslator(TextWhitespaceMode, String, Single, Single, Encoding, Single) | Initializes a new instance of the TextTranslator class with given parameter values.
Top
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator Constructor

Default Constructor for TextTranslator.
Initializes a new instance of the TextTranslator class.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextTranslator()
Public Sub New
Remarks
The constructor sets the whitespace settings to AllWhitespace. The line terminator is \r\n. The character width scaling factor is set to 1. The character height scaling factor is set to .4. The cutoff for determining the number of blank lines is set to .5. The encoding method is set to Unicode.
See Also

Reference

TextTranslator Class
TextTranslator Overload
Atalasoft.Ocr Namespace


TextTranslator Constructor (TextWhitespaceMode, String, Single, Single, Encoding, Single)

Initializes a new instance of the TextTranslator class with given parameter values.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextTranslator(
    TextWhitespaceMode whitespace,
    string lineTerminator,
    float characterSpaceMaximum,
    float lineMergeFactor,
    Encoding encodingMethod,
    float lineSpacingCutOff
)
Public Sub New (
    whitespace As TextWhitespaceMode,
    lineTerminator As String,
    characterSpaceMaximum As Single,
    lineMergeFactor As Single,
    encodingMethod As Encoding,
    lineSpacingCutOff As Single
)

Parameters

whitespace
Type: Atalasoft.OcrTextWhitespaceMode
indicates how to handle white space
lineTerminator
Type: SystemString
a string value used for line termination
characterSpaceMaximum
Type: SystemSingle
the maximum number of spaces to include in the translated output
lineMergeFactor
Type: SystemSingle
the factor use to determine when to combine lines from multiple zones.
encodingMethod
Type: System.TextEncoding
the text encoding method
lineSpacingCutOff
Type: SystemSingle
the line spacing cutoff
See Also

Reference

TextTranslator Class
TextTranslator Overload
Atalasoft.Ocr Namespace


TextTranslator Properties

The TextTranslator type exposes the following members.

Properties
 | Name | Description
Public property | CharacterSpaceMaximum | Property that allows for the getting and setting of the character width scale
Public property | EncodingMethod | Property that allows for the getting and setting of the text encoding method.
Public property | LineMergeFactor | Property that allows for the getting and setting of the character height scale.
Public property | LineSpacingCutOff | Property that allows for the getting and setting of the line space cut off.
Public property | LineTerminator | Property that allows for the getting and setting of the line terminator.
Public property | Whitespace | Property that allows for the getting and setting of the Whitespace parameter.
Top
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.CharacterSpaceMaximum Property

TextTranslatorCharacterSpaceMaximum Property

Property that allows for the getting and setting of the character width scale
Gets or sets the maximum number of spaces to include in the translated output.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float CharacterSpaceMaximum { get; set; }
Public Property CharacterSpaceMaximum As Single
    Get
    Set

Property Value

Type: Single
Remarks
The character width scale is a multiple which determines how many character widths to ignore. For normal spacing, this should generally be set to 1. For documents with multiple spaces between characters, this number can be increased to make the large space into a single space. Setting this value to 0, creates a justified version of the document.
Remarks
This property a multiple which determines how many character widths to ignore. For normal spacing, this should generally be set to 1. For documents with multiple spaces between characters, this number can be increased to make the large space into a single space. Setting this value to 0, creates a document with no spaces.
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.EncodingMethod Property

TextTranslatorEncodingMethod Property

Property that allows for the getting and setting of the text encoding method.
Gets or sets the text encoding method.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Encoding EncodingMethod { get; set; }
Public Property EncodingMethod As Encoding
    Get
    Set

Property Value

Type: Encoding
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.LineMergeFactor Property

TextTranslatorLineMergeFactor Property

Property that allows for the getting and setting of the character height scale.
Gets or sets the factor use to determine when to combine lines from multiple zones.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float LineMergeFactor { get; set; }
Public Property LineMergeFactor As Single
    Get
    Set

Property Value

Type: Single
Remarks
The character height scale is used when examining lines from multiple regions and determining if two lines of text should be merged to a single line in the text document. The smaller this value, the stricter the line merging. Larger values will merge lines that may not be on the same line in the original document. Generally, this value is set to .4.
Remarks
This property is used when examining lines from multiple regions and determining if two lines of text should be merged to a single line in the text document. The smaller this value, the stricter the line merging. Larger values will merge lines that may not be on the same line in the original document. Defaults to 0.4.
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.LineSpacingCutOff Property

TextTranslatorLineSpacingCutOff Property

Property that allows for the getting and setting of the line space cut off.
Gets or sets the line spacing cutoff.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float LineSpacingCutOff { get; set; }
Public Property LineSpacingCutOff As Single
    Get
    Set

Property Value

Type: Single
Remarks
When calculating the number of blank lines that should be inserted between two consecutive lines, this is the margin for what decimal remainder should still be considered a line. The smaller this number, the more spaces will be added. This number should range between 0 and 1 for regular documents. Making the number greater than 1 will change the original documents spacing.
Remarks
When calculating the number of blank lines that should be inserted between two consecutive lines, this is the margin for what decimal remainder should still be considered a line. The smaller this number, the more spaces will be added. This number should range between 0 and 1 for regular documents. Making the number greater than 1 will change the original documents spacing.
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.LineTerminator Property

TextTranslatorLineTerminator Property

Property that allows for the getting and setting of the line terminator.
Gets or sets a string value used for line termination.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LineTerminator { get; set; }
Public Property LineTerminator As String
    Get
    Set

Property Value

Type: String
Remarks
The line terminator is used when printing a new line in the text document. Example values are \n \r and \r\n
Remarks
Default value is /r/n
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Whitespace Property

TextTranslatorWhitespace Property

Property that allows for the getting and setting of the Whitespace parameter.
Gets or sets a value indicating how to handle white space.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextWhitespaceMode Whitespace { get; set; }
Public Property Whitespace As TextWhitespaceMode
    Get
    Set

Property Value

Type: TextWhitespaceMode
Remarks
The Whitespace parameter controls how much the text document looks like the original.
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator Methods

The TextTranslator type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Allow a foreign translator to perform any necessary cleanup.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Prepare | Prepare a foreign translator for translation.
Public method | Supported | Get an array of mime types supported by this translator.
Public method | Supports | Checks to see if a specific mime type is supported by this translator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.CanStream Method

TextTranslatorCanStream Method

Checks to see if this translator is capable of streaming.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CanStream()
Public Function CanStream As Boolean

Return Value

Type: Boolean
True if the translator can stream, false otherwise.

Implements

ITranslatorCanStream
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Finish Method

TextTranslatorFinish Method

Allow a foreign translator to perform any necessary cleanup.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Finish(
    OcrEngine engine,
    OcrDocument doc,
    bool successful,
    Object translationObject
)
Public Sub Finish (
    engine As OcrEngine,
    doc As OcrDocument,
    successful As Boolean,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that has done the recognition.
doc
Type: Atalasoft.OcrOcrDocument
The recognized document.
successful
Type: SystemBoolean
Indicates that recognition was successful.
translationObject
Type: SystemObject
An object originally provided by the return value of the Prepare(OcrEngine, OcrDocument) method.

Implements

IForeignTranslatorFinish(OcrEngine, OcrDocument, Boolean, Object)
Remarks
While some foreign translator implementations may not need an associated engine, it is best to always provide one as some translators will require it.
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Prepare Method

TextTranslatorPrepare Method

Prepare a foreign translator for translation.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Prepare(
    OcrEngine engine,
    OcrDocument doc
)
Public Function Prepare (
    engine As OcrEngine,
    doc As OcrDocument
) As Object

Parameters

engine
Type: Atalasoft.OcrOcrEngine
The engine that will perform the recognition.
doc
Type: Atalasoft.OcrOcrDocument
The document that will be populated by the engine.

Return Value

Type: Object
An object that will be used specifically by the foreign translator for document translation.

Implements

IForeignTranslatorPrepare(OcrEngine, OcrDocument)
Remarks

This method is provided for two purposes. The first is to establish a translator-specific object to maintain state information about the current translator session. The second is to populate the OcrDocument object with metadata or infrastructure for metadata.

During translation, OcrEngine will construct an empty OcrDocument and pass both itself and the document to the foreign translator through Prepare. Then the engine will attempt to recognize pages, then the foreign translator will translate the OcrDocument into final form. If an error occurs, the foreign translator is always given an opportunity to clean up via the Finish(OcrEngine, OcrDocument, Boolean, Object) method.

See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Supported Method

TextTranslatorSupported Method

Get an array of mime types supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] Supported()
Public Function Supported As String()

Return Value

Type: String
An array of strings containing mime types supported by this translator.

Implements

ITranslatorSupported
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Supports Method

TextTranslatorSupports Method

Checks to see if a specific mime type is supported by this translator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Supports(
    string mimeType
)
Public Function Supports (
    mimeType As String
) As Boolean

Parameters

mimeType
Type: SystemString
A string representing a mime type to be checked.

Return Value

Type: Boolean
True if the mime type is supported, false otherwise.

Implements

ITranslatorSupports(String)
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Translate Method

TextTranslatorTranslate Method

Overload List
 | Name | Description
Public method | Translate(OcrEngine, OcrDocument, String, Stream, Object) |
Public method | Translate(OcrEngine, OcrDocument, String, String, Object) |
Top
See Also

Reference

TextTranslator Class
Atalasoft.Ocr Namespace


TextTranslator.Translate Method (OcrEngine, OcrDocument, String, Stream, Object)

TextTranslatorTranslate Method (OcrEngine, OcrDocument, String, Stream, Object)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    Stream outStream,
    Object translationObject
)
Public Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outStream As Stream,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outStream
Type: System.IOStream
translationObject
Type: SystemObject

Implements

IForeignTranslatorTranslate(OcrEngine, OcrDocument, String, Stream, Object)
Exceptions
Exception | Condition
 | Throws if the MIME type is unknown.
See Also

Reference

TextTranslator Class
Translate Overload
Atalasoft.Ocr Namespace


TextTranslator.Translate Method (OcrEngine, OcrDocument, String, String, Object)

TextTranslatorTranslate Method (OcrEngine, OcrDocument, String, String, Object)

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Translate(
    OcrEngine engine,
    OcrDocument doc,
    string mimeType,
    string outFileName,
    Object translationObject
)
Public Sub Translate (
    engine As OcrEngine,
    doc As OcrDocument,
    mimeType As String,
    outFileName As String,
    translationObject As Object
)

Parameters

engine
Type: Atalasoft.OcrOcrEngine
doc
Type: Atalasoft.OcrOcrDocument
mimeType
Type: SystemString
outFileName
Type: SystemString
translationObject
Type: SystemObject

Implements

IForeignTranslatorTranslate(OcrEngine, OcrDocument, String, String, Object)
Exceptions
Exception | Condition
 | Throws if the MIME type is unknown.
See Also

Reference

TextTranslator Class
Translate Overload
Atalasoft.Ocr Namespace


TextWhitespaceMode Enumeration

Controls how to handle whitespace in the Whitespace property.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TextWhitespaceMode
Public Enumeration TextWhitespaceMode
Members
Member name | Description
NoWhitespace | Ignores all whitespace
NoMargins | Truncates margins but factors all other whitespace
AllWhitespace | Text document includes margins and all other whitespace
See Also

Reference

Atalasoft.Ocr Namespace


TranslatorCollection Class

TranslatorCollection represents a standard collection of ITranslator objects.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Atalasoft.OcrTranslatorCollection

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TranslatorCollection : CollectionBase
Public Class TranslatorCollection
    Inherits CollectionBase

The TranslatorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TranslatorCollection | Constructs a new TranslatorCollection object.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of item by index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
Methods
 | Name | Description
Public method | Add | Adds an ITranslator to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified ITranslator.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified ITranslator in the collection.
Public method | Insert | Inserts an ITranslator into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified ITranslator from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr Namespace


TranslatorCollection Constructor

Constructs a new TranslatorCollection object.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TranslatorCollection()
Public Sub New

Return Value

Type:
A new TranslatorCollection object.
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection Properties

The TranslatorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Allows for retrieval of item by index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Top
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.Item Property

TranslatorCollectionItem Property

Allows for retrieval of item by index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ITranslator this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ITranslator
    Get
    Set

Parameters

index
Type: SystemInt32

Return Value

Type: ITranslator
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection Methods

The TranslatorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an ITranslator to the collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains a specified ITranslator.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a specified ITranslator in the collection.
Public method | Insert | Inserts an ITranslator into the collection at specified position.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the first occurrence of the specified ITranslator from the collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.Add Method

TranslatorCollectionAdd Method

Adds an ITranslator to the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Add(
    ITranslator value
)
Public Function Add (
    value As ITranslator
) As Integer

Parameters

value
Type: Atalasoft.OcrITranslator
The ITranslator to add to the collection.

Return Value

Type: Int32
The position into which the new element was inserted.
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.Contains Method

TranslatorCollectionContains Method

Determines whether the collection contains a specified ITranslator.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    ITranslator value
)
Public Function Contains (
    value As ITranslator
) As Boolean

Parameters

value
Type: Atalasoft.OcrITranslator
The ITranslator to locate in the collection.

Return Value

Type: Boolean
True if the object was found, false otherwise.
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.CopyTo Method

TranslatorCollectionCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    ITranslator[] array,
    int index
)
Public Sub CopyTo (
    array As ITranslator(),
    index As Integer
)

Parameters

array
Type: Atalasoft.OcrITranslator
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.IndexOf Method

TranslatorCollectionIndexOf Method

Returns the index of a specified ITranslator in the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    ITranslator value
)
Public Function IndexOf (
    value As ITranslator
) As Integer

Parameters

value
Type: Atalasoft.OcrITranslator
The ITranslator to locate in the collection.

Return Value

Type: Int32
The index of value if found; otherwise -1.
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.Insert Method

TranslatorCollectionInsert Method

Inserts an ITranslator into the collection at specified position.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    ITranslator value
)
Public Sub Insert (
    index As Integer,
    value As ITranslator
)

Parameters

index
Type: SystemInt32
The zero-based position at which the ITranslator should be inserted.
value
Type: Atalasoft.OcrITranslator
The ITranslator to insert in the collection.

Return Value

Type:
n/a
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


TranslatorCollection.Remove Method

TranslatorCollectionRemove Method

Removes the first occurrence of the specified ITranslator from the collection.

Namespace: Atalasoft.Ocr
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Remove(
    ITranslator value
)
Public Sub Remove (
    value As ITranslator
)

Parameters

value
Type: Atalasoft.OcrITranslator
Removes the first occurrence of the specified ITranslator from the collection.

Return Value

Type:
n/a
See Also

Reference

TranslatorCollection Class
Atalasoft.Ocr Namespace


Atalasoft.Ocr.GlyphReader Namespace

Classes
 | Class | Description
Public class | GlyphReaderEngine | The highly accurate GlyphReader OCR engine.


GlyphReaderEngine Class

The highly accurate GlyphReader OCR engine.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.Ocr.GlyphReaderGlyphReaderEngine

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GlyphReaderEngine : OcrEngine
Public Class GlyphReaderEngine
    Inherits OcrEngine

The GlyphReaderEngine type exposes the following members.

Constructors
 | Name | Description
Public method | GlyphReaderEngine | Initializes a new instance of GlyphReader Engine.
Top
Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | BreakOrMergeCharacters | Gets or sets a value indicating if the engine should attempt to break merged characters or merge broken characters.
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultFontName | Gets or sets the font name that all text will be returned as.
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | DisabledCharacters | Gets or sets a string containing characters to disable. These characters will not be recognized.
Public property | EnableSegmentation |
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | LateralTextReading | Gets or sets a value that when true, will attempt to read text laterally, even across columns.
Public property | MaximumJobs |
Public property | MaximumLicensedJobs |
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | RejectPoorCharacters | Gets or sets a value that will reject low confidence characters.
Public property | RejectPoorLines | Gets or sets a value that will reject low confidence lines.
Public property | ResampleLargeImages |
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Public property | UseLexicalProcessing | Gets or sets a value that indicates if the engine should use Lexical processing.
Top
Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GlyphReaderEngine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Not used in the GlyphReader Engine, but returns Invariant Culture. (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the GlyphReader engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Perform OCR on a specified AtalaImage. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) |
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Protected method | ResampleImage |
Public method | ShutDown | Shutdown OCR Processing, and frees license for another use. (Overrides OcrEngineShutDown.)
 | ShutdownAllJobs | Shutdown all jobs currently using GlyphReader.
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
Remarks
Create an instance of the GlyphReaderLoader or OcrResourceLoader in a static constructor to load the GlyphReader Resources prior to instantiating the GlyphReaderEngine.
See Also

Reference

Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine Constructor

Initializes a new instance of GlyphReader Engine.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlyphReaderEngine()
Public Sub New
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine Properties

The GlyphReaderEngine type exposes the following members.

Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | BreakOrMergeCharacters | Gets or sets a value indicating if the engine should attempt to break merged characters or merge broken characters.
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultFontName | Gets or sets the font name that all text will be returned as.
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | DisabledCharacters | Gets or sets a string containing characters to disable. These characters will not be recognized.
Public property | EnableSegmentation |
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | LateralTextReading | Gets or sets a value that when true, will attempt to read text laterally, even across columns.
Public property | MaximumJobs |
Public property | MaximumLicensedJobs |
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | RejectPoorCharacters | Gets or sets a value that will reject low confidence characters.
Public property | RejectPoorLines | Gets or sets a value that will reject low confidence lines.
Public property | ResampleLargeImages |
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Public property | UseLexicalProcessing | Gets or sets a value that indicates if the engine should use Lexical processing.
Top
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.BreakOrMergeCharacters Property

GlyphReaderEngineBreakOrMergeCharacters Property

Gets or sets a value indicating if the engine should attempt to break merged characters or merge broken characters.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool BreakOrMergeCharacters { get; set; }
Public Property BreakOrMergeCharacters As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

When set to true, if two letters appear to be joined, the engine will attempt to break them apart and treat them as two separate letters. If a single letter appears to have a break in it (such as a broken stem), the engine will attempt to join them together. The Default value is True.

Setting the value to false will improve performance and is recommended for high quality scans.

See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.DefaultFontName Property

GlyphReaderEngineDefaultFontName Property

Gets or sets the font name that all text will be returned as.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultFontName { get; set; }
Public Property DefaultFontName As String
    Get
    Set

Property Value

Type: String
Remarks
GlyphReader does not support recognizing Font Names or Family, therefore set this property to the font that will be returned in the OcrDocument. Default value is Arial.
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.DefaultRecognitionCulture Property

GlyphReaderEngineDefaultRecognitionCulture Property

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo DefaultRecognitionCulture { get; }
Public Overrides ReadOnly Property DefaultRecognitionCulture As CultureInfo
    Get

Property Value

Type: CultureInfo
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.DisabledCharacters Property

GlyphReaderEngineDisabledCharacters Property

Gets or sets a string containing characters to disable. These characters will not be recognized.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DisabledCharacters { get; set; }
Public Property DisabledCharacters As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.EnableSegmentation Property

GlyphReaderEngineEnableSegmentation Property

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableSegmentation { get; set; }
Public Property EnableSegmentation As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Segmentation is not currently supported. This property has no effect on the engine.
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.LateralTextReading Property

GlyphReaderEngineLateralTextReading Property

Gets or sets a value that when true, will attempt to read text laterally, even across columns.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool LateralTextReading { get; set; }
Public Property LateralTextReading As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Default value is false.
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.MaximumJobs Property

GlyphReaderEngineMaximumJobs Property

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumJobs { get; set; }
Public Property MaximumJobs As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.MaximumLicensedJobs Property

GlyphReaderEngineMaximumLicensedJobs Property

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumLicensedJobs { get; }
Public ReadOnly Property MaximumLicensedJobs As Integer
    Get

Property Value

Type: Int32
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.RejectPoorCharacters Property

GlyphReaderEngineRejectPoorCharacters Property

Gets or sets a value that will reject low confidence characters.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RejectPoorCharacters { get; set; }
Public Property RejectPoorCharacters As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.RejectPoorLines Property

GlyphReaderEngineRejectPoorLines Property

Gets or sets a value that will reject low confidence lines.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RejectPoorLines { get; set; }
Public Property RejectPoorLines As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.ResampleLargeImages Property

GlyphReaderEngineResampleLargeImages Property

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ResampleLargeImages { get; set; }
Public Property ResampleLargeImages As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Resampling large images within the engine is not currently supported.
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.UseLexicalProcessing Property

GlyphReaderEngineUseLexicalProcessing Property

Gets or sets a value that indicates if the engine should use Lexical processing.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseLexicalProcessing { get; set; }
Public Property UseLexicalProcessing As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

When set to true, GlyphReader will assume that the text in the document is in a single column in left to right, top to bottom reading order. When set to false, GlyphReader will attempt to assign text to columns within the page.

Default value is true.

See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine Methods

The GlyphReaderEngine type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Not used in the GlyphReader Engine, but returns Invariant Culture. (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the GlyphReader engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Perform OCR on a specified AtalaImage. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) |
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Protected method | ResampleImage |
Public method | ShutDown | Shutdown OCR Processing, and frees license for another use. (Overrides OcrEngineShutDown.)
 | ShutdownAllJobs | Shutdown all jobs currently using GlyphReader.
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Dispose Method

GlyphReaderEngineDispose Method

Dipose memory used by the OcrEngine
Frees unmanaged resources.
Overload List
 | Name | Description
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GlyphReaderEngine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Top
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Dispose Method (Boolean)

GlyphReaderEngineDispose Method (Boolean)

Releases the unmanaged resources used by the GlyphReaderEngine and optionally releases the managed resources

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool A_0
)
Protected Overrides Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

GlyphReaderEngine Class
Dispose Overload
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.GetAvailablePreprocessingOptions Method

GlyphReaderEngineGetAvailablePreprocessingOptions Method

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetAvailablePreprocessingOptions()
Protected Overrides Function GetAvailablePreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.GetDefaultPreprocessingOptions Method

GlyphReaderEngineGetDefaultPreprocessingOptions Method

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetDefaultPreprocessingOptions()
Protected Overrides Function GetDefaultPreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.GetSupportedRecognitionCultures Method

GlyphReaderEngineGetSupportedRecognitionCultures Method

Not used in the GlyphReader Engine, but returns Invariant Culture.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo[] GetSupportedRecognitionCultures()
Public Overrides Function GetSupportedRecognitionCultures As CultureInfo()

Return Value

Type: CultureInfo
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Initialize Method

GlyphReaderEngineInitialize Method

Initialize the GlyphReader engine.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
Remarks
Must be invoked prior to recognition.
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.RecognitionCultureChanged Method

GlyphReaderEngineRecognitionCultureChanged Method

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RecognitionCultureChanged()
Protected Overrides Sub RecognitionCultureChanged
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Recognize Method

GlyphReaderEngineRecognize Method

Overload List
 | Name | Description
Public method | Recognize(AtalaImage) | Perform OCR on a specified AtalaImage. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) |
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Top
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Recognize Method (AtalaImage)

GlyphReaderEngineRecognize Method (AtalaImage)

Perform OCR on a specified AtalaImage.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrPage Recognize(
    AtalaImage image
)
Public Overrides Function Recognize (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The AtalaImage to OCR.

Return Value

Type: OcrPage
An OcrPage with the results from OCR.
See Also

Reference

GlyphReaderEngine Class
Recognize Overload
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Recognize Method (ImageSource)

GlyphReaderEngineRecognize Method (ImageSource)

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrDocument Recognize(
    ImageSource images
)
Public Overrides Function Recognize (
    images As ImageSource
) As OcrDocument

Parameters

images
Type: Atalasoft.ImagingImageSource

Return Value

Type: OcrDocument
See Also

Reference

GlyphReaderEngine Class
Recognize Overload
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.Recognize Method (AtalaImage, Rectangle)

GlyphReaderEngineRecognize Method (AtalaImage, Rectangle)

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage Recognize(
    AtalaImage image,
    Rectangle bounds
)
Public Function Recognize (
    image As AtalaImage,
    bounds As Rectangle
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
bounds
Type: System.DrawingRectangle

Return Value

Type: OcrPage
See Also

Reference

GlyphReaderEngine Class
Recognize Overload
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.ResampleImage Method

GlyphReaderEngineResampleImage Method

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual AtalaImage ResampleImage(
    AtalaImage source,
    int maxW,
    int maxH
)
Protected Overridable Function ResampleImage (
    source As AtalaImage,
    maxW As Integer,
    maxH As Integer
) As AtalaImage

Parameters

source
Type: Atalasoft.ImagingAtalaImage
maxW
Type: SystemInt32
maxH
Type: SystemInt32

Return Value

Type: AtalaImage
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.ShutDown Method

GlyphReaderEngineShutDown Method

Shutdown OCR Processing, and frees license for another use.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ShutDown()
Public Overrides Sub ShutDown
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine.ShutdownAllJobs Method

GlyphReaderEngineShutdownAllJobs Method

Shutdown all jobs currently using GlyphReader.

Namespace: Atalasoft.Ocr.GlyphReader
Assembly: Atalasoft.dotImage.Ocr.GlyphReader (in Atalasoft.dotImage.Ocr.GlyphReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ShutdownAllJobs()
Public Shared Sub ShutdownAllJobs
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


GlyphReaderEngine Events

The GlyphReaderEngine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

GlyphReaderEngine Class
Atalasoft.Ocr.GlyphReader Namespace


Atalasoft.Ocr.OmniPage Namespace

Classes
 | Class | Description
Public class | OmniPageCultureInfo |
Public class | OmniPageEngine | The OmniPage OCR engine object is used for recognizing either machine printed or hand printed text within a scanned image using OmniPage OCR Engine.
Public class | OmniPageIcrTextRegion | OmniPageIcrTextRegion represents an area of hand-printed text on a page with optional parameters specific to the OmniPage OCR engine.
Public class | OmniPageLicenseLimitsInfoElement | Describes license limits info.
Public class | OmniPageLoader | This class is used to load all resources for the OmniPage OCR Engine
Public class | OmniPageOcrCMC7TextRegion | OmniPageOcrCMC7TextRegion represents an area of Magnetic ink character recognition code, known in short as MICR code, CMC-7 font on a page with optional parameters specific to the OmniPage OCR engine.
Public class | OmniPageOcrMicrTextRegion | OmniPageOcrMicrTextRegion represents an area of Magnetic ink character recognition code, known in short as MICR code, E-13B font on a page with optional parameters specific to the OmniPage OCR engine.
Public class | OmniPageOcrTextRegion | OmniPageOcrTextRegion represents an area of printed text on a page, specific to the OmniPage OCR engine.
Enumerations
 | Enumeration | Description
Public enumeration | OmniPageLicenseLimitType | Describes license limit type used by OmniPageLicenseLimitsInfoElement.


OmniPageCultureInfo Class

Inheritance Hierarchy
SystemObject
System.GlobalizationCultureInfo
Atalasoft.OcrCustomCultureInfo
Atalasoft.Ocr.OmniPageOmniPageCultureInfo

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageCultureInfo : CustomCultureInfo
Public Class OmniPageCultureInfo
    Inherits CustomCultureInfo

The OmniPageCultureInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageCultureInfo | Initializes a new instance of the OmniPageCultureInfo class
Top
Properties
 | Name | Description
Public property | Calendar | Gets the default calendar used by the culture. (Inherited from CultureInfo.)
Public property | CompareInfo | Gets the CompareInfo that defines how to compare strings for the culture. (Inherited from CultureInfo.)
Public property | CultureTypes | Gets the culture types that pertain to the current CultureInfo object. (Inherited from CultureInfo.)
Public property | DateTimeFormat | Gets or sets a DateTimeFormatInfo that defines the culturally appropriate format of displaying dates and times. (Inherited from CultureInfo.)
Public property | DisplayName | (Inherited from CustomCultureInfo.)
Public property | EnglishName | (Inherited from CustomCultureInfo.)
Public property | IetfLanguageTag | Deprecated. Gets the RFC 4646 standard identification for a language. (Inherited from CultureInfo.)
Public property | IsNeutralCulture | Gets a value indicating whether the current CultureInfo represents a neutral culture. (Inherited from CultureInfo.)
Public property | IsReadOnly | Gets a value indicating whether the current CultureInfo is read-only. (Inherited from CultureInfo.)
Public property | KeyboardLayoutId | Gets the active input locale identifier. (Inherited from CultureInfo.)
Public property | LCID | Gets the culture identifier for the current CultureInfo. (Inherited from CultureInfo.)
Public property | Name | (Inherited from CustomCultureInfo.)
Public property | NativeName | (Inherited from CustomCultureInfo.)
Public property | NumberFormat | Gets or sets a NumberFormatInfo that defines the culturally appropriate format of displaying numbers, currency, and percentage. (Inherited from CultureInfo.)
Public property | OptionalCalendars | Gets the list of calendars that can be used by the culture. (Inherited from CultureInfo.)
Public property | Parent | Gets the CultureInfo that represents the parent culture of the current CultureInfo. (Inherited from CultureInfo.)
Public property | TextInfo | Gets the TextInfo that defines the writing system associated with the culture. (Inherited from CultureInfo.)
Public property | ThreeLetterISOLanguageName | Gets the ISO 639-2 three-letter code for the language of the current CultureInfo. (Overrides CultureInfoThreeLetterISOLanguageName.)
Public property | ThreeLetterWindowsLanguageName | Gets the three-letter code for the language as defined in the Windows API. (Overrides CultureInfoThreeLetterWindowsLanguageName.)
Public property | TwoLetterISOLanguageName | Gets the ISO 639-1 two-letter code for the language of the current CultureInfo. (Overrides CultureInfoTwoLetterISOLanguageName.)
Public property | UseUserOverride | Gets a value indicating whether the current CultureInfo uses the user-selected culture settings. (Inherited from CultureInfo.)
Top
Methods
 | Name | Description
Public method | ClearCachedData | Refreshes cached culture-related information. (Inherited from CultureInfo.)
Public method | Clone | Creates a copy of the current CultureInfo. (Inherited from CultureInfo.)
Public method | Equals | Determines whether the specified object is the same culture as the current CultureInfo. (Inherited from CultureInfo.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConsoleFallbackUICulture | Gets an alternate user interface culture suitable for console applications when the default graphic user interface culture is unsuitable. (Inherited from CultureInfo.)
Public method | GetFormat | Gets an object that defines how to format the specified type. (Inherited from CultureInfo.)
Public method | GetHashCode | Serves as a hash function for the current CultureInfo, suitable for hashing algorithms and data structures, such as a hash table. (Inherited from CultureInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string containing the name of the current CultureInfo in the format languagecode2-country/regioncode2. (Inherited from CultureInfo.)
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageCultureInfo Constructor

Initializes a new instance of the OmniPageCultureInfo class

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageCultureInfo(
    string name,
    string threeLetterWindowsName,
    string threeLetterISOName,
    string twoLetterName
)
Public Sub New (
    name As String,
    threeLetterWindowsName As String,
    threeLetterISOName As String,
    twoLetterName As String
)

Parameters

name
Type: SystemString
CultureInfo name.
threeLetterWindowsName
Type: SystemString
The three-letter code for the language as defined in the Windows API.
threeLetterISOName
Type: SystemString
The ISO 639-2 three-letter code for the language of the current System.Globalization.CultureInfo.
twoLetterName
Type: SystemString
The ISO 639-1 two-letter code for the language of the current System.Globalization.CultureInfo.
See Also

Reference

OmniPageCultureInfo Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageCultureInfo Properties

The OmniPageCultureInfo type exposes the following members.

Properties
 | Name | Description
Public property | Calendar | Gets the default calendar used by the culture. (Inherited from CultureInfo.)
Public property | CompareInfo | Gets the CompareInfo that defines how to compare strings for the culture. (Inherited from CultureInfo.)
Public property | CultureTypes | Gets the culture types that pertain to the current CultureInfo object. (Inherited from CultureInfo.)
Public property | DateTimeFormat | Gets or sets a DateTimeFormatInfo that defines the culturally appropriate format of displaying dates and times. (Inherited from CultureInfo.)
Public property | DisplayName | (Inherited from CustomCultureInfo.)
Public property | EnglishName | (Inherited from CustomCultureInfo.)
Public property | IetfLanguageTag | Deprecated. Gets the RFC 4646 standard identification for a language. (Inherited from CultureInfo.)
Public property | IsNeutralCulture | Gets a value indicating whether the current CultureInfo represents a neutral culture. (Inherited from CultureInfo.)
Public property | IsReadOnly | Gets a value indicating whether the current CultureInfo is read-only. (Inherited from CultureInfo.)
Public property | KeyboardLayoutId | Gets the active input locale identifier. (Inherited from CultureInfo.)
Public property | LCID | Gets the culture identifier for the current CultureInfo. (Inherited from CultureInfo.)
Public property | Name | (Inherited from CustomCultureInfo.)
Public property | NativeName | (Inherited from CustomCultureInfo.)
Public property | NumberFormat | Gets or sets a NumberFormatInfo that defines the culturally appropriate format of displaying numbers, currency, and percentage. (Inherited from CultureInfo.)
Public property | OptionalCalendars | Gets the list of calendars that can be used by the culture. (Inherited from CultureInfo.)
Public property | Parent | Gets the CultureInfo that represents the parent culture of the current CultureInfo. (Inherited from CultureInfo.)
Public property | TextInfo | Gets the TextInfo that defines the writing system associated with the culture. (Inherited from CultureInfo.)
Public property | ThreeLetterISOLanguageName | Gets the ISO 639-2 three-letter code for the language of the current CultureInfo. (Overrides CultureInfoThreeLetterISOLanguageName.)
Public property | ThreeLetterWindowsLanguageName | Gets the three-letter code for the language as defined in the Windows API. (Overrides CultureInfoThreeLetterWindowsLanguageName.)
Public property | TwoLetterISOLanguageName | Gets the ISO 639-1 two-letter code for the language of the current CultureInfo. (Overrides CultureInfoTwoLetterISOLanguageName.)
Public property | UseUserOverride | Gets a value indicating whether the current CultureInfo uses the user-selected culture settings. (Inherited from CultureInfo.)
Top
See Also

Reference

OmniPageCultureInfo Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageCultureInfo.ThreeLetterISOLanguageName Property

OmniPageCultureInfoThreeLetterISOLanguageName Property

Gets the ISO 639-2 three-letter code for the language of the current CultureInfo.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ThreeLetterISOLanguageName { get; set; }
Public Overrides Property ThreeLetterISOLanguageName As String
    Get
    Set

Return Value

Type: String
The ISO 639-2 three-letter code for the language of the current CultureInfo.
See Also

Reference

OmniPageCultureInfo Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageCultureInfo.ThreeLetterWindowsLanguageName Property

OmniPageCultureInfoThreeLetterWindowsLanguageName Property

Gets the three-letter code for the language as defined in the Windows API.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ThreeLetterWindowsLanguageName { get; set; }
Public Overrides Property ThreeLetterWindowsLanguageName As String
    Get
    Set

Return Value

Type: String
The three-letter code for the language as defined in the Windows API.
See Also

Reference

OmniPageCultureInfo Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageCultureInfo.TwoLetterISOLanguageName Property

OmniPageCultureInfoTwoLetterISOLanguageName Property

Gets the ISO 639-1 two-letter code for the language of the current CultureInfo.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string TwoLetterISOLanguageName { get; set; }
Public Overrides Property TwoLetterISOLanguageName As String
    Get
    Set

Return Value

Type: String
The ISO 639-1 two-letter code for the language of the current CultureInfo.
See Also

Reference

OmniPageCultureInfo Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageCultureInfo Methods

The OmniPageCultureInfo type exposes the following members.

Methods
 | Name | Description
Public method | ClearCachedData | Refreshes cached culture-related information. (Inherited from CultureInfo.)
Public method | Clone | Creates a copy of the current CultureInfo. (Inherited from CultureInfo.)
Public method | Equals | Determines whether the specified object is the same culture as the current CultureInfo. (Inherited from CultureInfo.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConsoleFallbackUICulture | Gets an alternate user interface culture suitable for console applications when the default graphic user interface culture is unsuitable. (Inherited from CultureInfo.)
Public method | GetFormat | Gets an object that defines how to format the specified type. (Inherited from CultureInfo.)
Public method | GetHashCode | Serves as a hash function for the current CultureInfo, suitable for hashing algorithms and data structures, such as a hash table. (Inherited from CultureInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string containing the name of the current CultureInfo in the format languagecode2-country/regioncode2. (Inherited from CultureInfo.)
Top
See Also

Reference

OmniPageCultureInfo Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine Class

The OmniPage OCR engine object is used for recognizing either machine printed or hand printed text within a scanned image using OmniPage OCR Engine.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.OcrOmniPageEngineBase
Atalasoft.Ocr.OmniPageOmniPageEngine

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageEngine : OmniPageEngineBase
Public Class OmniPageEngine
    Inherits OmniPageEngineBase

The OmniPageEngine type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageEngine | Initializes a new instance of the OmniPageEngine class
Top
Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | ParallelProcessing | Gets or sets a value indicating whether parallel processing is enabled.
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | RetainLayout | Specifies if original lines in recognized text should be retained in the result. This property is false by default.
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Overrides OmniPageEngineBaseCanStream.)
Public method | CanStream(String) | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OmniPageEngine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Public method | GetLicenseLimitsInfo | Gets license limits information.
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Protected method | INativeTranslator_Translate(ImageSource, String, Stream) | (Overrides OmniPageEngineBaseINativeTranslator_Translate(ImageSource, String, Stream).)
Protected method | INativeTranslator_Translate(ImageSource, String, String) | (Overrides OmniPageEngineBaseINativeTranslator_Translate(ImageSource, String, String).)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Overrides OcrEngineIsMultiCultureRecognitionSupported.)
Public method | LoadSettings | Load OCR engine settings.
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, ListOmniPageOcrTextRegion) |
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Overrides OcrEngineRecognize(AtalaImage, Int32).)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource, OcrDocument, IForeignTranslator, Object).)
Public method | SaveSettings | Save OCR engine settings.
Public method | ShutDown | Terminates the engine. (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Get an array of mime types supported by this translator. (Overrides OmniPageEngineBaseSupported.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator. (Overrides OmniPageEngineBaseSupports(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine Constructor

Initializes a new instance of the OmniPageEngine class

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageEngine()
Public Sub New
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine Properties

The OmniPageEngine type exposes the following members.

Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | ParallelProcessing | Gets or sets a value indicating whether parallel processing is enabled.
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | RetainLayout | Specifies if original lines in recognized text should be retained in the result. This property is false by default.
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.DefaultRecognitionCulture Property

OmniPageEngineDefaultRecognitionCulture Property

Returns the default recognition language for this engine.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo DefaultRecognitionCulture { get; }
Public Overrides ReadOnly Property DefaultRecognitionCulture As CultureInfo
    Get

Property Value

Type: CultureInfo
The default recognition language for this engine.
Remarks
Most engines will return English or neutral culture as their default.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.ParallelProcessing Property

OmniPageEngineParallelProcessing Property

Gets or sets a value indicating whether parallel processing is enabled.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ParallelProcessing { get; set; }
Public Property ParallelProcessing As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Parallel processing affects Recognize and Translate overloads that accept collection of images (through parameter). Parallel processing is disabled by default.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.RetainLayout Property

OmniPageEngineRetainLayout Property

Specifies if original lines in recognized text should be retained in the result. This property is false by default.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RetainLayout { get; set; }
Public Property RetainLayout As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Layout retaining is applied to the following output file types: rtf, xls, epub, ppt, xlsx, docx, html, pptx.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine Methods

The OmniPageEngine type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Overrides OmniPageEngineBaseCanStream.)
Public method | CanStream(String) | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Public method | GetLicenseLimitsInfo | Gets license limits information.
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Protected method | INativeTranslator_Translate(ImageSource, String, Stream) | (Overrides OmniPageEngineBaseINativeTranslator_Translate(ImageSource, String, Stream).)
Protected method | INativeTranslator_Translate(ImageSource, String, String) | (Overrides OmniPageEngineBaseINativeTranslator_Translate(ImageSource, String, String).)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Overrides OcrEngineIsMultiCultureRecognitionSupported.)
Public method | LoadSettings | Load OCR engine settings.
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, ListOmniPageOcrTextRegion) |
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Overrides OcrEngineRecognize(AtalaImage, Int32).)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource, OcrDocument, IForeignTranslator, Object).)
Public method | SaveSettings | Save OCR engine settings.
Public method | ShutDown | Terminates the engine. (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Get an array of mime types supported by this translator. (Overrides OmniPageEngineBaseSupported.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | Supports | Checks to see if a specific mime type is supported by this translator. (Overrides OmniPageEngineBaseSupports(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.CanStream Method

OmniPageEngineCanStream Method

Overload List
 | Name | Description
Public method | CanStream | Checks to see if this translator is capable of streaming. (Overrides OmniPageEngineBaseCanStream.)
Public method | CanStream(String) | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.CanStream Method

OmniPageEngineCanStream Method

Checks to see if this translator is capable of streaming.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool CanStream()
Public Overrides Function CanStream As Boolean

Return Value

Type: Boolean
True if the translator can stream, false otherwise.

Implements

ITranslatorCanStream
See Also

Reference

OmniPageEngine Class
CanStream Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Dispose Method

OmniPageEngineDispose Method

Dipose memory used by the OcrEngine
Overload List
 | Name | Description
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OmniPageEngine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Dispose Method (Boolean)

OmniPageEngineDispose Method (Boolean)

Releases the unmanaged resources used by the OmniPageEngine and optionally releases the managed resources

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool A_0
)
Protected Overrides Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

OmniPageEngine Class
Dispose Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.GetAvailablePreprocessingOptions Method

OmniPageEngineGetAvailablePreprocessingOptions Method

Gets available preprocessing options for this OcrEngine

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetAvailablePreprocessingOptions()
Protected Overrides Function GetAvailablePreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Available preprocessing options.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.GetDefaultPreprocessingOptions Method

OmniPageEngineGetDefaultPreprocessingOptions Method

Gets default preprocessing options for this OcrEngine

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetDefaultPreprocessingOptions()
Protected Overrides Function GetDefaultPreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Default preprocessing options
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.GetLicenseLimitsInfo Method

OmniPageEngineGetLicenseLimitsInfo Method

Gets license limits information.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageLicenseLimitsInfoElement[] GetLicenseLimitsInfo()
Public Function GetLicenseLimitsInfo As OmniPageLicenseLimitsInfoElement()

Return Value

Type: OmniPageLicenseLimitsInfoElement
An array of OmniPageLicenseLimitsInfoElement with current license limits information.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.GetSupportedRecognitionCultures Method

OmniPageEngineGetSupportedRecognitionCultures Method

Returns an array of supported recognition languages for this engine

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo[] GetSupportedRecognitionCultures()
Public Overrides Function GetSupportedRecognitionCultures As CultureInfo()

Return Value

Type: CultureInfo
An array of supported recognition languages for this engine
Remarks
Some engines support few or one recognition language. Some engines support hundreds, although most of the supported languages are equivalent to "latin alphabet" or "cyrillic alphabet". Some engines provide languages for which there is no equivalent CultureInfo (Esperanto, for example) and therefore can't be reflected in this interface.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.INativeTranslator_Translate Method

OmniPageEngineINativeTranslator_Translate Method

Overload List
 | Name | Description
Protected method | INativeTranslator_Translate(ImageSource, String, Stream) | (Overrides OmniPageEngineBaseINativeTranslator_Translate(ImageSource, String, Stream).)
Protected method | INativeTranslator_Translate(ImageSource, String, String) | (Overrides OmniPageEngineBaseINativeTranslator_Translate(ImageSource, String, String).)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.INativeTranslator_Translate Method (ImageSource, String, Stream)

OmniPageEngineINativeTranslator_Translate Method (ImageSource, String, Stream)

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void INativeTranslator_Translate(
    ImageSource images,
    string mime,
    Stream outStream
)
Protected Overrides Sub INativeTranslator_Translate (
    images As ImageSource,
    mime As String,
    outStream As Stream
)

Parameters

images
Type: Atalasoft.ImagingImageSource
mime
Type: SystemString
outStream
Type: System.IOStream
See Also

Reference

OmniPageEngine Class
INativeTranslator_Translate Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.INativeTranslator_Translate Method (ImageSource, String, String)

OmniPageEngineINativeTranslator_Translate Method (ImageSource, String, String)

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void INativeTranslator_Translate(
    ImageSource images,
    string mime,
    string fileName
)
Protected Overrides Sub INativeTranslator_Translate (
    images As ImageSource,
    mime As String,
    fileName As String
)

Parameters

images
Type: Atalasoft.ImagingImageSource
mime
Type: SystemString
fileName
Type: SystemString
See Also

Reference

OmniPageEngine Class
INativeTranslator_Translate Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Initialize Method

OmniPageEngineInitialize Method

Initialize the engine.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
Remarks
This is an abstract method and must be implemented by a subclass of OcrEngine. Not every engine will perform an action in this method.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.IsMultiCultureRecognitionSupported Method

OmniPageEngineIsMultiCultureRecognitionSupported Method

Tells whether the OCR engine supports multiple recognition cultures.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool IsMultiCultureRecognitionSupported()
Protected Overrides Function IsMultiCultureRecognitionSupported As Boolean

Return Value

Type: Boolean
Returns true if the OCR engine supports multiple recognition cultures, otherwise false.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.LoadSettings Method

OmniPageEngineLoadSettings Method

Load OCR engine settings.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadSettings(
    string settingsFileName
)
Public Sub LoadSettings (
    settingsFileName As String
)

Parameters

settingsFileName
Type: SystemString
Path to settings file.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.RecognitionCultureChanged Method

OmniPageEngineRecognitionCultureChanged Method

Occurs when a recognition culture list changes.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RecognitionCultureChanged()
Protected Overrides Sub RecognitionCultureChanged
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Recognize Method

OmniPageEngineRecognize Method

Overload List
 | Name | Description
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, ListOmniPageOcrTextRegion) |
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Overrides OcrEngineRecognize(AtalaImage, Int32).)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource, OcrDocument, IForeignTranslator, Object).)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Recognize Method (AtalaImage)

OmniPageEngineRecognize Method (AtalaImage)

Recognize text in an AtalaImage, transforming it into an OcrPage object.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrPage Recognize(
    AtalaImage image
)
Public Overrides Function Recognize (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to recognize.

Return Value

Type: OcrPage
The recognized page.
Remarks
The version of Recognize that takes an ImageCollection is likely to change.
See Also

Reference

OmniPageEngine Class
Recognize Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Recognize Method (AtalaImage, List(OmniPageOcrTextRegion))

OmniPageEngineRecognize Method (AtalaImage, ListOmniPageOcrTextRegion)

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrPage Recognize(
    AtalaImage image,
    List<OmniPageOcrTextRegion> textRegionList
)
Public Function Recognize (
    image As AtalaImage,
    textRegionList As List(Of OmniPageOcrTextRegion)
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
textRegionList
Type: System.Collections.GenericListOmniPageOcrTextRegion

Return Value

Type: OcrPage
See Also

Reference

OmniPageEngine Class
Recognize Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Recognize Method (AtalaImage, Int32)

OmniPageEngineRecognize Method (AtalaImage, Int32)

Recognize text in an AtalaImage

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPage Recognize(
    AtalaImage image,
    int pageNum
)
Protected Overrides Function Recognize (
    image As AtalaImage,
    pageNum As Integer
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
Image to recognize.
pageNum
Type: SystemInt32

Return Value

Type: OcrPage
The recognized page.
See Also

Reference

OmniPageEngine Class
Recognize Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Recognize Method (ImageSource, OcrDocument, IForeignTranslator, Object)

OmniPageEngineRecognize Method (ImageSource, OcrDocument, IForeignTranslator, Object)

Recognize a set of AtalaImage objects as an entire document.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrDocument Recognize(
    ImageSource images,
    OcrDocument document,
    IForeignTranslator xlator,
    ref Object translationObject
)
Protected Overrides Function Recognize (
    images As ImageSource,
    document As OcrDocument,
    xlator As IForeignTranslator,
    ByRef translationObject As Object
) As OcrDocument

Parameters

images
Type: Atalasoft.ImagingImageSource
A set of images to recognize.
document
Type: Atalasoft.OcrOcrDocument
The recognized document.
xlator
Type: Atalasoft.OcrIForeignTranslator
Translator used to define how a document will be translated
translationObject
Type: SystemObject
An object is provided by the return value of the Prepare(OcrEngine, OcrDocument) method.

Return Value

Type: OcrDocument
A new OcrDocument containing one page for every image in the collection.
See Also

Reference

OmniPageEngine Class
Recognize Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.SaveSettings Method

OmniPageEngineSaveSettings Method

Save OCR engine settings.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SaveSettings(
    string settingsFileName
)
Public Sub SaveSettings (
    settingsFileName As String
)

Parameters

settingsFileName
Type: SystemString
Path to settings file.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.ShutDown Method

OmniPageEngineShutDown Method

Terminates the engine.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ShutDown()
Public Overrides Sub ShutDown
Remarks
This method is abstract and must be implemented by an engine. Not every engine will perform an action for this method.
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Supported Method

OmniPageEngineSupported Method

Note: This API is now obsolete.

Get an array of mime types supported by this translator.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been renamed to SupportedMimeTypes()")]
public override string[] Supported()
<ObsoleteAttribute("This method has been renamed to SupportedMimeTypes()")>
Public Overrides Function Supported As String()

Return Value

Type: String
An array of strings containing mime types supported by this translator.

Implements

ITranslatorSupported
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine.Supports Method

OmniPageEngineSupports Method

Checks to see if a specific mime type is supported by this translator.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Supports(
    string mimeType
)
Public Overrides Function Supports (
    mimeType As String
) As Boolean

Parameters

mimeType
Type: SystemString
A string representing a mime type to be checked.

Return Value

Type: Boolean
True if the mime type is supported, false otherwise.

Implements

ITranslatorSupports(String)
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageEngine Events

The OmniPageEngine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

OmniPageEngine Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Class

OmniPageIcrTextRegion represents an area of hand-printed text on a page with optional parameters specific to the OmniPage OCR engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageIcrTextRegion

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageIcrTextRegion : OmniPageOcrTextRegion
Public Class OmniPageIcrTextRegion
    Inherits OmniPageOcrTextRegion

The OmniPageIcrTextRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageIcrTextRegion(Rectangle) | Initializes a new instance of the OmniPageIcrTextRegion class.
Public method | OmniPageIcrTextRegion(PolygonF) | Initializes a new instance of the OmniPageIcrTextRegion class.
Public method | OmniPageIcrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageIcrTextRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Constructor

Overload List
 | Name | Description
Public method | OmniPageIcrTextRegion(Rectangle) | Initializes a new instance of the OmniPageIcrTextRegion class.
Public method | OmniPageIcrTextRegion(PolygonF) | Initializes a new instance of the OmniPageIcrTextRegion class.
Public method | OmniPageIcrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageIcrTextRegion class.
Top
See Also

Reference

OmniPageIcrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Constructor (Rectangle)

Initializes a new instance of the OmniPageIcrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageIcrTextRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
See Also

Reference

OmniPageIcrTextRegion Class
OmniPageIcrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Constructor (PolygonF)

Initializes a new instance of the OmniPageIcrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageIcrTextRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element in pixels relative to the source image.
See Also

Reference

OmniPageIcrTextRegion Class
OmniPageIcrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Constructor (Rectangle, OcrTextRotation)

Initializes a new instance of the OmniPageIcrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageIcrTextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Public Sub New (
    bounds As Rectangle,
    rotation As OcrTextRotation
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
rotation
Type: Atalasoft.OcrOcrTextRotation
The rotation of the text region with respect to the entire page.
Remarks
For OmniPage OCR engine Clockwise180 text rotation option is equal to None. Both these values are the same horizontal values. Note that if the source page is 180 degrees rotated then it is processed and detected correctly.
See Also

Reference

OmniPageIcrTextRegion Class
OmniPageIcrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Properties

The OmniPageIcrTextRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageIcrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageIcrTextRegion Methods

The OmniPageIcrTextRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageIcrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement Class

Describes license limits info.
Inheritance Hierarchy
SystemObject
Atalasoft.Ocr.OmniPageOmniPageLicenseLimitsInfoElement

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageLicenseLimitsInfoElement
Public Class OmniPageLicenseLimitsInfoElement

The OmniPageLicenseLimitsInfoElement type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageLicenseLimitsInfoElement | Initializes a new instance of the OmniPageLicenseLimitsInfoElement class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ExpirationTime | Specifies limit expiration time.
Public field | Limit | Specifies limit value.
Public field | Type | Specifies limit type.
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement Constructor

Initializes a new instance of the OmniPageLicenseLimitsInfoElement class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageLicenseLimitsInfoElement(
    OmniPageLicenseLimitType _type,
    int _limit,
    ValueType _expTime
)
Public Sub New (
    _type As OmniPageLicenseLimitType,
    _limit As Integer,
    _expTime As ValueType
)

Parameters

_type
Type: Atalasoft.Ocr.OmniPageOmniPageLicenseLimitType
Limit type.
_limit
Type: SystemInt32
Limit value.
_expTime
Type: SystemValueType
Limit expiration time.
See Also

Reference

OmniPageLicenseLimitsInfoElement Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement Methods

The OmniPageLicenseLimitsInfoElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmniPageLicenseLimitsInfoElement Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement Fields

The OmniPageLicenseLimitsInfoElement type exposes the following members.

Fields
 | Name | Description
Public field | ExpirationTime | Specifies limit expiration time.
Public field | Limit | Specifies limit value.
Public field | Type | Specifies limit type.
Top
See Also

Reference

OmniPageLicenseLimitsInfoElement Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement.ExpirationTime Field

OmniPageLicenseLimitsInfoElementExpirationTime Field

Specifies limit expiration time.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ValueType ExpirationTime
Public ExpirationTime As ValueType

Field Value

Type: ValueType
See Also

Reference

OmniPageLicenseLimitsInfoElement Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement.Limit Field

OmniPageLicenseLimitsInfoElementLimit Field

Specifies limit value.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Limit
Public Limit As Integer

Field Value

Type: Int32
See Also

Reference

OmniPageLicenseLimitsInfoElement Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitsInfoElement.Type Field

OmniPageLicenseLimitsInfoElementType Field

Specifies limit type.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageLicenseLimitType Type
Public Type As OmniPageLicenseLimitType

Field Value

Type: OmniPageLicenseLimitType
See Also

Reference

OmniPageLicenseLimitsInfoElement Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLicenseLimitType Enumeration

Describes license limit type used by OmniPageLicenseLimitsInfoElement.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum OmniPageLicenseLimitType
Public Enumeration OmniPageLicenseLimitType
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader Class

This class is used to load all resources for the OmniPage OCR Engine
Inheritance Hierarchy
SystemObject
Atalasoft.Ocr.OmniPageOmniPageLoader

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageLoader
Public Class OmniPageLoader

The OmniPageLoader type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageLoader | Initializes a new instance of the OmniPageLoader class and loads resources from default locations.
Public method | OmniPageLoader(String) | Initializes a new instance of the OmniPageLoader class and loads resources from a specified location.
Top
Properties
 | Name | Description
Public property | DllHandle | Gets the handle of the DLL from LoadLibrary().
Public property | FailureMessage | The failure message when the resouces cannot be loaded.
Public property | FullPaths | Gets the full path of the resources.
Public property | Loaded | Determines if the resources sucessfully loaded.
Public property | Location | Gets the folder location of the resources.
Public property | PathsSearched | Gets collection of folders searched for the resources.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader Constructor

Overload List
 | Name | Description
Public method | OmniPageLoader | Initializes a new instance of the OmniPageLoader class and loads resources from default locations.
Public method | OmniPageLoader(String) | Initializes a new instance of the OmniPageLoader class and loads resources from a specified location.
Top
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader Constructor

Initializes a new instance of the OmniPageLoader class and loads resources from default locations.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageLoader()
Public Sub New
See Also

Reference

OmniPageLoader Class
OmniPageLoader Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader Constructor (String)

Initializes a new instance of the OmniPageLoader class and loads resources from a specified location.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageLoader(
    string resourceDir
)
Public Sub New (
    resourceDir As String
)

Parameters

resourceDir
Type: SystemString
The folder where the resources are loaded from.
See Also

Reference

OmniPageLoader Class
OmniPageLoader Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader Properties

The OmniPageLoader type exposes the following members.

Properties
 | Name | Description
Public property | DllHandle | Gets the handle of the DLL from LoadLibrary().
Public property | FailureMessage | The failure message when the resouces cannot be loaded.
Public property | FullPaths | Gets the full path of the resources.
Public property | Loaded | Determines if the resources sucessfully loaded.
Public property | Location | Gets the folder location of the resources.
Public property | PathsSearched | Gets collection of folders searched for the resources.
Top
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader.DllHandle Property

OmniPageLoaderDllHandle Property

Gets the handle of the DLL from LoadLibrary().

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IntPtr DllHandle { get; }
Public ReadOnly Property DllHandle As IntPtr
    Get

Property Value

Type: IntPtr
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader.FailureMessage Property

OmniPageLoaderFailureMessage Property

The failure message when the resouces cannot be loaded.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FailureMessage { get; }
Public ReadOnly Property FailureMessage As String
    Get

Property Value

Type: String
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader.FullPaths Property

OmniPageLoaderFullPaths Property

Gets the full path of the resources.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] FullPaths { get; }
Public ReadOnly Property FullPaths As String()
    Get

Property Value

Type: String
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader.Loaded Property

OmniPageLoaderLoaded Property

Determines if the resources sucessfully loaded.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Loaded { get; }
Public ReadOnly Property Loaded As Boolean
    Get

Property Value

Type: Boolean
True if successful.
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader.Location Property

OmniPageLoaderLocation Property

Gets the folder location of the resources.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get

Property Value

Type: String
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader.PathsSearched Property

OmniPageLoaderPathsSearched Property

Gets collection of folders searched for the resources.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] PathsSearched { get; }
Public ReadOnly Property PathsSearched As String()
    Get

Property Value

Type: String
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageLoader Methods

The OmniPageLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OmniPageLoader Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Class

OmniPageOcrCMC7TextRegion represents an area of Magnetic ink character recognition code, known in short as MICR code, CMC-7 font on a page with optional parameters specific to the OmniPage OCR engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrCMC7TextRegion

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageOcrCMC7TextRegion : OmniPageOcrTextRegion
Public Class OmniPageOcrCMC7TextRegion
    Inherits OmniPageOcrTextRegion

The OmniPageOcrCMC7TextRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageOcrCMC7TextRegion(Rectangle) | Initializes a new instance of the OmniPageOcrCMC7TextRegion class.
Public method | OmniPageOcrCMC7TextRegion(PolygonF) | Initializes a new instance of the OmniPageOcrCMC7TextRegion class.
Public method | OmniPageOcrCMC7TextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageOcrCMC7TextRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Constructor

Overload List
 | Name | Description
Public method | OmniPageOcrCMC7TextRegion(Rectangle) | Initializes a new instance of the OmniPageOcrCMC7TextRegion class.
Public method | OmniPageOcrCMC7TextRegion(PolygonF) | Initializes a new instance of the OmniPageOcrCMC7TextRegion class.
Public method | OmniPageOcrCMC7TextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageOcrCMC7TextRegion class.
Top
See Also

Reference

OmniPageOcrCMC7TextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Constructor (Rectangle)

Initializes a new instance of the OmniPageOcrCMC7TextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrCMC7TextRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
See Also

Reference

OmniPageOcrCMC7TextRegion Class
OmniPageOcrCMC7TextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Constructor (PolygonF)

Initializes a new instance of the OmniPageOcrCMC7TextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrCMC7TextRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element in pixels relative to the source image.
See Also

Reference

OmniPageOcrCMC7TextRegion Class
OmniPageOcrCMC7TextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Constructor (Rectangle, OcrTextRotation)

Initializes a new instance of the OmniPageOcrCMC7TextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrCMC7TextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Public Sub New (
    bounds As Rectangle,
    rotation As OcrTextRotation
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
rotation
Type: Atalasoft.OcrOcrTextRotation
The rotation of the text region with respect to the entire page.
Remarks
For OmniPage OCR engine Clockwise180 text rotation option is equal to None. Both these values are the same horizontal values. Note that if the source page is 180 degrees rotated then it is processed and detected correctly.
See Also

Reference

OmniPageOcrCMC7TextRegion Class
OmniPageOcrCMC7TextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Properties

The OmniPageOcrCMC7TextRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageOcrCMC7TextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrCMC7TextRegion Methods

The OmniPageOcrCMC7TextRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageOcrCMC7TextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Class

OmniPageOcrMicrTextRegion represents an area of Magnetic ink character recognition code, known in short as MICR code, E-13B font on a page with optional parameters specific to the OmniPage OCR engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrMicrTextRegion

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageOcrMicrTextRegion : OmniPageOcrTextRegion
Public Class OmniPageOcrMicrTextRegion
    Inherits OmniPageOcrTextRegion

The OmniPageOcrMicrTextRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageOcrMicrTextRegion(Rectangle) | Initializes a new instance of the OmniPageOcrMicrTextRegion class.
Public method | OmniPageOcrMicrTextRegion(PolygonF) | Initializes a new instance of the OmniPageOcrMicrTextRegion class.
Public method | OmniPageOcrMicrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageOcrMicrTextRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Constructor

Overload List
 | Name | Description
Public method | OmniPageOcrMicrTextRegion(Rectangle) | Initializes a new instance of the OmniPageOcrMicrTextRegion class.
Public method | OmniPageOcrMicrTextRegion(PolygonF) | Initializes a new instance of the OmniPageOcrMicrTextRegion class.
Public method | OmniPageOcrMicrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageOcrMicrTextRegion class.
Top
See Also

Reference

OmniPageOcrMicrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Constructor (Rectangle)

Initializes a new instance of the OmniPageOcrMicrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrMicrTextRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
See Also

Reference

OmniPageOcrMicrTextRegion Class
OmniPageOcrMicrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Constructor (PolygonF)

Initializes a new instance of the OmniPageOcrMicrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrMicrTextRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding Rectangle of the page element in pixels relative to the source image.
See Also

Reference

OmniPageOcrMicrTextRegion Class
OmniPageOcrMicrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Constructor (Rectangle, OcrTextRotation)

Initializes a new instance of the OmniPageOcrMicrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrMicrTextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Public Sub New (
    bounds As Rectangle,
    rotation As OcrTextRotation
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
rotation
Type: Atalasoft.OcrOcrTextRotation
The rotation of the text region with respect to the entire page.
Remarks
For OmniPage OCR engine Clockwise180 text rotation option is equal to None. Both these values are the same horizontal values. Note that if the source page is 180 degrees rotated then it is processed and detected correctly.
See Also

Reference

OmniPageOcrMicrTextRegion Class
OmniPageOcrMicrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Properties

The OmniPageOcrMicrTextRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageOcrMicrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrMicrTextRegion Methods

The OmniPageOcrMicrTextRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageOcrMicrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Class

OmniPageOcrTextRegion represents an area of printed text on a page, specific to the OmniPage OCR engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Atalasoft.OcrOcrRegion
Atalasoft.OcrOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageIcrTextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrCMC7TextRegion
Atalasoft.Ocr.OmniPageOmniPageOcrMicrTextRegion

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageOcrTextRegion : OcrTextRegion
Public Class OmniPageOcrTextRegion
    Inherits OcrTextRegion

The OmniPageOcrTextRegion type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageOcrTextRegion(Rectangle) | Initializes a new instance of the OmniPageOcrTextRegion class.
Public method | OmniPageOcrTextRegion(PolygonF) | Initializes a new instance of the OmniPageOcrTextRegion class.
Public method | OmniPageOcrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageOcrTextRegion class.
Top
Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
Remarks
OmniPage OCR engine auto rotation mechanism works with multiple image attributes, mostly text lines and the amount of the text has large weight in the rotation decision. As the result the “right” direction is the direction in which the majority text is detected. This lead to the fact that OmniPage in some cases is not able to process correctly pages which contain text blocks with different directions. Also rotated blocks could be in the detection results with incorrect data string (as for example vertical text is tried to be recognized as horizontal).
See Also

Reference

Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Constructor

Overload List
 | Name | Description
Public method | OmniPageOcrTextRegion(Rectangle) | Initializes a new instance of the OmniPageOcrTextRegion class.
Public method | OmniPageOcrTextRegion(PolygonF) | Initializes a new instance of the OmniPageOcrTextRegion class.
Public method | OmniPageOcrTextRegion(Rectangle, OcrTextRotation) | Initializes a new instance of the OmniPageOcrTextRegion class.
Top
See Also

Reference

OmniPageOcrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Constructor (Rectangle)

Initializes a new instance of the OmniPageOcrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrTextRegion(
    Rectangle bounds
)
Public Sub New (
    bounds As Rectangle
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
See Also

Reference

OmniPageOcrTextRegion Class
OmniPageOcrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Constructor (PolygonF)

Initializes a new instance of the OmniPageOcrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrTextRegion(
    PolygonF bounds
)
Public Sub New (
    bounds As PolygonF
)

Parameters

bounds
Type: Atalasoft.Utils.GeometryPolygonF
The bounding PolygonF of the page element in pixels relative to the source image.
See Also

Reference

OmniPageOcrTextRegion Class
OmniPageOcrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Constructor (Rectangle, OcrTextRotation)

Initializes a new instance of the OmniPageOcrTextRegion class.

Namespace: Atalasoft.Ocr.OmniPage
Assembly: Atalasoft.dotImage.Ocr.OmniPage (in Atalasoft.dotImage.Ocr.OmniPage.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageOcrTextRegion(
    Rectangle bounds,
    OcrTextRotation rotation
)
Public Sub New (
    bounds As Rectangle,
    rotation As OcrTextRotation
)

Parameters

bounds
Type: System.DrawingRectangle
The bounding Rectangle of the page element in pixels relative to the source image.
rotation
Type: Atalasoft.OcrOcrTextRotation
The rotation of the text region with respect to the entire page.
Remarks
For OmniPage OCR engine Clockwise180 text rotation option is equal to None. Both these values are the same horizontal values. Note that if the source page is 180 degrees rotated then it is processed and detected correctly.
See Also

Reference

OmniPageOcrTextRegion Class
OmniPageOcrTextRegion Overload
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Properties

The OmniPageOcrTextRegion type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | This property represents the bounds of the Region in pixels. (Inherited from OcrRegion.)
Public property | Confidence | This property represents the overall confidence with which the text was recognized. (Inherited from OcrTextRegion.)
Public property | ExpectedSymbolSet | Gets or sets expected symbol set for the text region. (Inherited from OcrTextRegion.)
Public property | IsRectangular | Gets a value indicating whether region is rectangular or not. (Inherited from OcrRegion.)
Public property | Lines | This property provides access to individual lines of text within the region. (Inherited from OcrTextRegion.)
Public property | PolygonBounds | This property represents the bounds of the Region. (Inherited from OcrRegion.)
Public property | Rotation | This property represents the orientation of the text region, expressed as a rotation. (Inherited from OcrTextRegion.)
Public property | TextKind | Gets or sets kind of the text within the text sregion. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageOcrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


OmniPageOcrTextRegion Methods

The OmniPageOcrTextRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | MaskToBounds | Masks provided image to the region's bounds, optionally cropping masked area. (Inherited from OcrRegion.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | RecalculateBounds | Recalculates the bounding box of a text region. (Inherited from OcrTextRegion.)
 | ToString | Converts the entire contents of an OcrTextRegion to a single string. (Inherited from OcrTextRegion.)
Top
See Also

Reference

OmniPageOcrTextRegion Class
Atalasoft.Ocr.OmniPage Namespace


Atalasoft.Ocr.Tesseract Namespace

Classes
Class | Description
Tesseract3Engine |
Tesseract5Engine |


Tesseract3Engine Class

Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.Ocr.TesseractTesseract3Engine

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Tesseract3Engine : OcrEngine
Public Class Tesseract3Engine
    Inherits OcrEngine

The Tesseract3Engine type exposes the following members.

Constructors
 | Name | Description
Public method | Tesseract3Engine | Initializes a new instance of the Tesseract3Engine class with the default OcrResources directory
Public method | Tesseract3Engine(String) | Initializes a new instance of the Tesseract3Engine class with the customer specified OcrResources directory
Top
Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for Tesseract3Engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CultureInfoToTesseractLang | Return a Tesseract language representing the CultureInfo object.
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Tesseract3Engine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this engine. (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. Returns false as Tesseract doesn’t support barcode detection. (Overrides OcrEngineGetCanRecognizeBarcodes.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this engine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Gets the value indicating whether the engine supports multiple recognition cultures. (Overrides OcrEngineIsMultiCultureRecognitionSupported.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Performs optical character recognition of the image or images. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Protected method | TesseractLangToCultureInfo | Return a CultureInfo object representing the named Tesseract language - or NULL
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
Remarks
See the Tesseract3Engine Constructor for information about loading Tesseract's resources.
Examples
To configure Tesseract3 library location, you should add the next line to app.config file:
Copy
<Atalasoft>
    <OcrEngines>
        <Tesseract3Engine Tesseract3Location="C:\Folder\Subfolder\SubSubFolder"/>
    </OcrEngines>
    <!-- Components sections -->
    ...
</Atalasoft>
You can also use a relaive path
Copy
<Atalasoft>
    <OcrEngines>
        <Tesseract3Engine Tesseract3Location="..\Another\Sub\Folder"/>
    </OcrEngines>
    <!-- Components sections -->
    ...
</Atalasoft>
See Also

Reference

Atalasoft.Ocr.Tesseract Namespace
Atalasoft.SharedAtalasoftConfigSection


Tesseract3Engine Constructor

Constructs a new Tesseract Ocr Engine
Overload List
 | Name | Description
Public method | Tesseract3Engine | Initializes a new instance of the Tesseract3Engine class with the default OcrResources directory
Public method | Tesseract3Engine(String) | Initializes a new instance of the Tesseract3Engine class with the customer specified OcrResources directory
Top
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine Constructor

Initializes a new instance of the Tesseract3Engine class with the default OcrResources directory

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract3Engine()
Public Sub New
Remarks

Tesseract's resources are loaded at construction time. Firstly, a directory list is built. Secondly, each directory in that list is checked to see if it contains the \Tesseract\v3.04\tessdata directory structure. When a directory is found that directory is checked to ensure that it contains all of the correct resource files. The following locations are searched for in order:

1) If the constructor's resources argument is supplied, it is checked (for example C:\ResourcesFolder\Tesseract\v3.04\tessdata);

2) If the constructor's resources argument is supplied, the OcrResources subdirectory of the argument is checked (for example C:\Folder\OcrResources\Tesseract\v3.04\tessdata);

3) The SDK OcrResources directory which is determined by a registry key with OcrResources subdirectory (for example C:\RegistryKeyFolder\OcrResources\Tesseract\v3.04\tessdata)

4) The location of the Tesseract Assembly (for example C:\TesseractAssemblyFolder\Tesseract\v3.04\tessdata);

5) The location of the Tesseract Assembly's OcrResources subdirectory (for example C:\TesseractAssemblyFolder\OcrResources\Tesseract\v3.04\tessdata);

6) The value of the TESSDATA_PREFIX environment variable (for example C:\TESSDATA_PREFIXFolder\Tesseract\v3.04\tessdata).

See Also

Reference

Tesseract3Engine Class
Tesseract3Engine Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine Constructor (String)

Initializes a new instance of the Tesseract3Engine class with the customer specified OcrResources directory

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract3Engine(
    string resources
)
Public Sub New (
    resources As String
)

Parameters

resources
Type: SystemString
The path to your OcrResources directory.
See Also

Reference

Tesseract3Engine Class
Tesseract3Engine Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine Properties

The Tesseract3Engine type exposes the following members.

Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for Tesseract3Engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.DefaultRecognitionCulture Property

Tesseract3EngineDefaultRecognitionCulture Property

Returns the default recognition language for Tesseract3Engine.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo DefaultRecognitionCulture { get; }
Public Overrides ReadOnly Property DefaultRecognitionCulture As CultureInfo
    Get

Property Value

Type: CultureInfo
The default recognition language for Tesseract3Engine.
Remarks
Tesseract3Engine will return English as default.
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine Methods

The Tesseract3Engine type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CultureInfoToTesseractLang | Return a Tesseract language representing the CultureInfo object.
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this engine. (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. Returns false as Tesseract doesn’t support barcode detection. (Overrides OcrEngineGetCanRecognizeBarcodes.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this engine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Gets the value indicating whether the engine supports multiple recognition cultures. (Overrides OcrEngineIsMultiCultureRecognitionSupported.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Performs optical character recognition of the image or images. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Protected method | TesseractLangToCultureInfo | Return a CultureInfo object representing the named Tesseract language - or NULL
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.CultureInfoToTesseractLang Method

Tesseract3EngineCultureInfoToTesseractLang Method

Return a Tesseract language representing the CultureInfo object.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual sbyte* CultureInfoToTesseractLang(
    CultureInfo ci
)
Visual Basic does not support APIs that consume or return unsafe types.

Parameters

ci
Type: System.GlobalizationCultureInfo
CultureInfo object for transforming

Return Value

Type: SByte*
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Dispose Method

Tesseract3EngineDispose Method

Dipose memory used by the OcrEngine
Overload List
 | Name | Description
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Tesseract3Engine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Top
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Dispose Method (Boolean)

Tesseract3EngineDispose Method (Boolean)

Releases the unmanaged resources used by the Tesseract3Engine and optionally releases the managed resources

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool A_0
)
Protected Overrides Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Tesseract3Engine Class
Dispose Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.GetAvailablePreprocessingOptions Method

Tesseract3EngineGetAvailablePreprocessingOptions Method

Gets available preprocessing options for this engine.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetAvailablePreprocessingOptions()
Protected Overrides Function GetAvailablePreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Available preprocessing options.
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.GetCanRecognizeBarcodes Method

Tesseract3EngineGetCanRecognizeBarcodes Method

Gets the value indicating whether the engine can recognize barcodes or not. Returns false as Tesseract doesn’t support barcode detection.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool GetCanRecognizeBarcodes()
Protected Overrides Function GetCanRecognizeBarcodes As Boolean

Return Value

Type: Boolean
The value indicating whether the engine can recognize barcodes or not.
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.GetDefaultPreprocessingOptions Method

Tesseract3EngineGetDefaultPreprocessingOptions Method

Gets default preprocessing options for this engine

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetDefaultPreprocessingOptions()
Protected Overrides Function GetDefaultPreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Default preprocessing options.
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.GetSupportedRecognitionCultures Method

Tesseract3EngineGetSupportedRecognitionCultures Method

Returns an array of supported recognition languages for this engine

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo[] GetSupportedRecognitionCultures()
Public Overrides Function GetSupportedRecognitionCultures As CultureInfo()

Return Value

Type: CultureInfo
An array of supported recognition languages for this engine
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Initialize Method

Tesseract3EngineInitialize Method

Initialize the engine.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.IsMultiCultureRecognitionSupported Method

Tesseract3EngineIsMultiCultureRecognitionSupported Method

Gets the value indicating whether the engine supports multiple recognition cultures.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool IsMultiCultureRecognitionSupported()
Protected Overrides Function IsMultiCultureRecognitionSupported As Boolean

Return Value

Type: Boolean
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.RecognitionCultureChanged Method

Tesseract3EngineRecognitionCultureChanged Method

Occurs when a recognition culture list changes.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RecognitionCultureChanged()
Protected Overrides Sub RecognitionCultureChanged
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Recognize Method

Tesseract3EngineRecognize Method

Performs optical character recognition of the image or images.
Overload List
 | Name | Description
Public method | Recognize(AtalaImage) | Performs optical character recognition of the image or images. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Recognize Method (AtalaImage)

Tesseract3EngineRecognize Method (AtalaImage)

Performs optical character recognition of the image or images.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrPage Recognize(
    AtalaImage image
)
Public Overrides Function Recognize (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image on which to perform OCR.

Return Value

Type: OcrPage
Remarks
Once the Recognize method is called the RecognitionCulture is fixed and cannot be changed.
See Also

Reference

Tesseract3Engine Class
Recognize Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Recognize Method (ImageSource)

Tesseract3EngineRecognize Method (ImageSource)

Recognize a set of AtalaImage objects as an entire document.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrDocument Recognize(
    ImageSource imgSrc
)
Public Overrides Function Recognize (
    imgSrc As ImageSource
) As OcrDocument

Parameters

imgSrc
Type: Atalasoft.ImagingImageSource
The source of images for the OCR process.

Return Value

Type: OcrDocument
A new OcrDocument containing one page for every image in the collection.
Remarks
This method is likely to go away in the future.
See Also

Reference

Tesseract3Engine Class
Recognize Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.Recognize Method (AtalaImage, Rectangle)

Tesseract3EngineRecognize Method (AtalaImage, Rectangle)

Recognize only within a specific rectangle in an AtalaImage.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrPage Recognize(
    AtalaImage image,
    Rectangle bounds
)
Public Overridable Function Recognize (
    image As AtalaImage,
    bounds As Rectangle
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image on which to perform OCR.
bounds
Type: System.DrawingRectangle
The area of the image on which to perform OCR.

Return Value

Type: OcrPage
Returns OcrPage object which is transformed from AtalaImage. Recognize only within a specific rectangle in an AtalaImage.
See Also

Reference

Tesseract3Engine Class
Recognize Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.ShutDown Method

Tesseract3EngineShutDown Method

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ShutDown()
Public Overrides Sub ShutDown
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine.TesseractLangToCultureInfo Method

Tesseract3EngineTesseractLangToCultureInfo Method

Return a CultureInfo object representing the named Tesseract language - or NULL

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract3 (in Atalasoft.dotImage.Ocr.Tesseract3.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual CultureInfo TesseractLangToCultureInfo(
    string tessLang
)
Protected Overridable Function TesseractLangToCultureInfo (
    tessLang As String
) As CultureInfo

Parameters

tessLang
Type: SystemString
Tesseract language for transforming

Return Value

Type: CultureInfo
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract3Engine Events

The Tesseract3Engine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract3Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine Class

Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.Ocr.TesseractTesseract5Engine

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Tesseract5Engine : OcrEngine
Public Class Tesseract5Engine
    Inherits OcrEngine

The Tesseract5Engine type exposes the following members.

Constructors
 | Name | Description
Public method | Tesseract5Engine | Initializes a new instance of the Tesseract5Engine class with the default OcrResources directory
Public method | Tesseract5Engine(String) | Initializes a new instance of the Tesseract5Engine class with the customer specified OcrResources directory
Top
Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for Tesseract5Engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CultureInfoToTesseractLang | Return a Tesseract language representing the CultureInfo object.
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Tesseract5Engine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this engine. (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. Returns false as Tesseract doesn’t support barcode detection. (Overrides OcrEngineGetCanRecognizeBarcodes.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this engine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Gets the value indicating whether the engine supports multiple recognition cultures. (Overrides OcrEngineIsMultiCultureRecognitionSupported.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Performs optical character recognition of the image or images. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Protected method | TesseractLangToCultureInfo | Return a CultureInfo object representing the named Tesseract language - or NULL
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
Remarks
See the Tesseract5Engine Constructor for information about loading Tesseract's resources.
Examples
To configure Tesseract5 library location, you should add the next line to app.config file:
Copy
<Atalasoft>
    <OcrEngines>
        <Tesseract5Engine Tesseract5Location="C:\Folder\Subfolder\SubSubFolder"/>
    </OcrEngines>
    <!-- Components sections -->
    ...
</Atalasoft>
You can also use a relaive path
Copy
<Atalasoft>
    <OcrEngines>
        <Tesseract5Engine Tesseract5Location="..\Another\Sub\Folder"/>
    </OcrEngines>
    <!-- Components sections -->
    ...
</Atalasoft>
See Also

Reference

Atalasoft.Ocr.Tesseract Namespace
Atalasoft.SharedAtalasoftConfigSection


Tesseract5Engine Constructor

Constructs a new Tesseract Ocr Engine
Overload List
 | Name | Description
Public method | Tesseract5Engine | Initializes a new instance of the Tesseract5Engine class with the default OcrResources directory
Public method | Tesseract5Engine(String) | Initializes a new instance of the Tesseract5Engine class with the customer specified OcrResources directory
Top
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine Constructor

Initializes a new instance of the Tesseract5Engine class with the default OcrResources directory

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract5Engine()
Public Sub New
Remarks

Tesseract's resources are loaded at construction time. Firstly, a directory list is built. Secondly, each directory in that list is checked to see if it contains the \Tesseract\v5.3.0 directory structure. When a directory is found that directory is checked to ensure that it contains all of the correct resource files. The following locations are searched for in order:

1) If the constructor's resources argument is supplied, it is checked (for example C:\ResourcesFolder\Tesseract\v5.3.0);

2) If the constructor's resources argument is supplied, the OcrResources subdirectory of the argument is checked (for example C:\Folder\OcrResources\Tesseract\v5.3.0);

3) The SDK OcrResources directory which is determined by a registry key with OcrResources subdirectory (for example C:\RegistryKeyFolder\OcrResources\Tesseract\v5.3.0)

4) The location of the Tesseract Assembly (for example C:\TesseractAssemblyFolder\Tesseract\v5.3.0);

5) The location of the Tesseract Assembly's OcrResources subdirectory (for example C:\TesseractAssemblyFolder\OcrResources\Tesseract\v5.3.0);

6) The value of the TESS5DATA_PREFIX environment variable (for example C:\TESS5DATA_PREFIXFolder\Tesseract\v5.3.0).

See Also

Reference

Tesseract5Engine Class
Tesseract5Engine Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine Constructor (String)

Initializes a new instance of the Tesseract5Engine class with the customer specified OcrResources directory

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract5Engine(
    string resources
)
Public Sub New (
    resources As String
)

Parameters

resources
Type: SystemString
The path to your OcrResources directory.
See Also

Reference

Tesseract5Engine Class
Tesseract5Engine Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine Properties

The Tesseract5Engine type exposes the following members.

Properties
 | Name | Description
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for Tesseract5Engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.DefaultRecognitionCulture Property

Tesseract5EngineDefaultRecognitionCulture Property

Returns the default recognition language for Tesseract5Engine.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo DefaultRecognitionCulture { get; }
Public Overrides ReadOnly Property DefaultRecognitionCulture As CultureInfo
    Get

Property Value

Type: CultureInfo
The default recognition language for Tesseract5Engine.
Remarks
Tesseract5Engine will return English as default.
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine Methods

The Tesseract5Engine type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CultureInfoToTesseractLang | Return a Tesseract language representing the CultureInfo object.
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Overrides OcrEngineDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this engine. (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. Returns false as Tesseract doesn’t support barcode detection. (Overrides OcrEngineGetCanRecognizeBarcodes.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this engine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Gets the value indicating whether the engine supports multiple recognition cultures. (Overrides OcrEngineIsMultiCultureRecognitionSupported.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Performs optical character recognition of the image or images. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Protected method | TesseractLangToCultureInfo | Return a CultureInfo object representing the named Tesseract language - or NULL
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.CultureInfoToTesseractLang Method

Tesseract5EngineCultureInfoToTesseractLang Method

Return a Tesseract language representing the CultureInfo object.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual sbyte* CultureInfoToTesseractLang(
    CultureInfo ci
)
Visual Basic does not support APIs that consume or return unsafe types.

Parameters

ci
Type: System.GlobalizationCultureInfo
CultureInfo object for transforming

Return Value

Type: SByte*
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Dispose Method

Tesseract5EngineDispose Method

Dipose memory used by the OcrEngine
Overload List
 | Name | Description
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Tesseract5Engine and optionally releases the managed resources (Overrides OcrEngineDispose(Boolean).)
Top
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Dispose Method (Boolean)

Tesseract5EngineDispose Method (Boolean)

Releases the unmanaged resources used by the Tesseract5Engine and optionally releases the managed resources

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool A_0
)
Protected Overrides Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Tesseract5Engine Class
Dispose Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.GetAvailablePreprocessingOptions Method

Tesseract5EngineGetAvailablePreprocessingOptions Method

Gets available preprocessing options for this engine.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetAvailablePreprocessingOptions()
Protected Overrides Function GetAvailablePreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Available preprocessing options.
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.GetCanRecognizeBarcodes Method

Tesseract5EngineGetCanRecognizeBarcodes Method

Gets the value indicating whether the engine can recognize barcodes or not. Returns false as Tesseract doesn’t support barcode detection.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool GetCanRecognizeBarcodes()
Protected Overrides Function GetCanRecognizeBarcodes As Boolean

Return Value

Type: Boolean
The value indicating whether the engine can recognize barcodes or not.
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.GetDefaultPreprocessingOptions Method

Tesseract5EngineGetDefaultPreprocessingOptions Method

Gets default preprocessing options for this engine

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetDefaultPreprocessingOptions()
Protected Overrides Function GetDefaultPreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Default preprocessing options.
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.GetSupportedRecognitionCultures Method

Tesseract5EngineGetSupportedRecognitionCultures Method

Returns an array of supported recognition languages for this engine

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo[] GetSupportedRecognitionCultures()
Public Overrides Function GetSupportedRecognitionCultures As CultureInfo()

Return Value

Type: CultureInfo
An array of supported recognition languages for this engine
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Initialize Method

Tesseract5EngineInitialize Method

Initialize the engine.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.IsMultiCultureRecognitionSupported Method

Tesseract5EngineIsMultiCultureRecognitionSupported Method

Gets the value indicating whether the engine supports multiple recognition cultures.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool IsMultiCultureRecognitionSupported()
Protected Overrides Function IsMultiCultureRecognitionSupported As Boolean

Return Value

Type: Boolean
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.RecognitionCultureChanged Method

Tesseract5EngineRecognitionCultureChanged Method

Occurs when a recognition culture list changes.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RecognitionCultureChanged()
Protected Overrides Sub RecognitionCultureChanged
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Recognize Method

Tesseract5EngineRecognize Method

Performs optical character recognition of the image or images.
Overload List
 | Name | Description
Public method | Recognize(AtalaImage) | Performs optical character recognition of the image or images. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Overrides OcrEngineRecognize(ImageSource).)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage.
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Recognize Method (AtalaImage)

Tesseract5EngineRecognize Method (AtalaImage)

Performs optical character recognition of the image or images.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrPage Recognize(
    AtalaImage image
)
Public Overrides Function Recognize (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image on which to perform OCR.

Return Value

Type: OcrPage
Remarks
Once the Recognize method is called the RecognitionCulture is fixed and cannot be changed.
See Also

Reference

Tesseract5Engine Class
Recognize Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Recognize Method (ImageSource)

Tesseract5EngineRecognize Method (ImageSource)

Recognize a set of AtalaImage objects as an entire document.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrDocument Recognize(
    ImageSource imgSrc
)
Public Overrides Function Recognize (
    imgSrc As ImageSource
) As OcrDocument

Parameters

imgSrc
Type: Atalasoft.ImagingImageSource
The source of images for the OCR process.

Return Value

Type: OcrDocument
A new OcrDocument containing one page for every image in the collection.
Remarks
This method is likely to go away in the future.
See Also

Reference

Tesseract5Engine Class
Recognize Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.Recognize Method (AtalaImage, Rectangle)

Tesseract5EngineRecognize Method (AtalaImage, Rectangle)

Recognize only within a specific rectangle in an AtalaImage.

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual OcrPage Recognize(
    AtalaImage image,
    Rectangle bounds
)
Public Overridable Function Recognize (
    image As AtalaImage,
    bounds As Rectangle
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image on which to perform OCR.
bounds
Type: System.DrawingRectangle
The area of the image on which to perform OCR.

Return Value

Type: OcrPage
Returns OcrPage object which is transformed from AtalaImage. Recognize only within a specific rectangle in an AtalaImage.
See Also

Reference

Tesseract5Engine Class
Recognize Overload
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.ShutDown Method

Tesseract5EngineShutDown Method

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ShutDown()
Public Overrides Sub ShutDown
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine.TesseractLangToCultureInfo Method

Tesseract5EngineTesseractLangToCultureInfo Method

Return a CultureInfo object representing the named Tesseract language - or NULL

Namespace: Atalasoft.Ocr.Tesseract
Assembly: Atalasoft.dotImage.Ocr.Tesseract5 (in Atalasoft.dotImage.Ocr.Tesseract5.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual CultureInfo TesseractLangToCultureInfo(
    string tessLang
)
Protected Overridable Function TesseractLangToCultureInfo (
    tessLang As String
) As CultureInfo

Parameters

tessLang
Type: SystemString
Tesseract language for transforming

Return Value

Type: CultureInfo
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Tesseract5Engine Events

The Tesseract5Engine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

Tesseract5Engine Class
Atalasoft.Ocr.Tesseract Namespace


Atalasoft.Ocr.Voting Namespace

Classes
 | Class | Description
Public class | BasicWordNominator | Provides basic functionality for nominating words for voting.
Public class | BasicWordSelector | Provides basic functionality for choosing the best word from a set of words.
Public class | VotingEngine | An implementation of OcrEngine which includes voting.
Interfaces
 | Interface | Description
Public interface | INominator | Defines that interface for nominating a word.
Public interface | IWordSelector | Defines the interface for selecting a word.


BasicWordNominator Class

Provides basic functionality for nominating words for voting.
Inheritance Hierarchy
SystemObject
Atalasoft.Ocr.VotingBasicWordNominator

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicWordNominator : INominator
Public Class BasicWordNominator
    Implements INominator

The BasicWordNominator type exposes the following members.

Constructors
 | Name | Description
Public method | BasicWordNominator | Construct a BasicWordNominator object
Public method | BasicWordNominator(Double, Double) | Construct a BasicWordNominator object
Top
Properties
 | Name | Description
Public property | GlyphConfidenceLimit | Gets or sets the limit for deciding if a word should be a candidate. Glyphs in the word with confidence under this limit will cause the word to be a candidate.
Public property | WordConfidenceLimit | Gets or sets the limit for deciding if a word should be a candidate. Words with confidence under this limit will be a candidate
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCandidate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr.Voting Namespace


BasicWordNominator Constructor

Construct a BasicWordNominator object
Overload List
 | Name | Description
Public method | BasicWordNominator | Construct a BasicWordNominator object
Public method | BasicWordNominator(Double, Double) | Construct a BasicWordNominator object
Top
See Also

Reference

BasicWordNominator Class
Atalasoft.Ocr.Voting Namespace


BasicWordNominator Constructor

Construct a BasicWordNominator object

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicWordNominator()
Public Sub New
See Also

Reference

BasicWordNominator Class
BasicWordNominator Overload
Atalasoft.Ocr.Voting Namespace


BasicWordNominator Constructor (Double, Double)

Construct a BasicWordNominator object

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicWordNominator(
    double wordConfidenceLimit,
    double glyphConfidenceLimit
)
Public Sub New (
    wordConfidenceLimit As Double,
    glyphConfidenceLimit As Double
)

Parameters

wordConfidenceLimit
Type: SystemDouble
The limit for deciding if a word should be a candidate. Words with confidence under this limit will be candidates.
glyphConfidenceLimit
Type: SystemDouble
The limit for deciding if a word should be a candidate. Glyphs with confidence under this limit will cause the word to be a candidate
See Also

Reference

BasicWordNominator Class
BasicWordNominator Overload
Atalasoft.Ocr.Voting Namespace


BasicWordNominator Properties

The BasicWordNominator type exposes the following members.

Properties
 | Name | Description
Public property | GlyphConfidenceLimit | Gets or sets the limit for deciding if a word should be a candidate. Glyphs in the word with confidence under this limit will cause the word to be a candidate.
Public property | WordConfidenceLimit | Gets or sets the limit for deciding if a word should be a candidate. Words with confidence under this limit will be a candidate
Top
See Also

Reference

BasicWordNominator Class
Atalasoft.Ocr.Voting Namespace


BasicWordNominator.GlyphConfidenceLimit Property

BasicWordNominatorGlyphConfidenceLimit Property

Gets or sets the limit for deciding if a word should be a candidate. Glyphs in the word with confidence under this limit will cause the word to be a candidate.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GlyphConfidenceLimit { get; set; }
Public Property GlyphConfidenceLimit As Double
    Get
    Set

Property Value

Type: Double
Remarks
This value should be between 0 and 1. Useful values will be in the range of 0.50 to 0.70
See Also

Reference

BasicWordNominator Class
Atalasoft.Ocr.Voting Namespace


BasicWordNominator.WordConfidenceLimit Property

BasicWordNominatorWordConfidenceLimit Property

Gets or sets the limit for deciding if a word should be a candidate. Words with confidence under this limit will be a candidate

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double WordConfidenceLimit { get; set; }
Public Property WordConfidenceLimit As Double
    Get
    Set

Property Value

Type: Double
Remarks
This value should be between 0 and 1. Useful values will be in the range of 0.50 to 0.70
See Also

Reference

BasicWordNominator Class
Atalasoft.Ocr.Voting Namespace


BasicWordNominator Methods

The BasicWordNominator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCandidate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicWordNominator Class
Atalasoft.Ocr.Voting Namespace


BasicWordNominator.IsCandidate Method

BasicWordNominatorIsCandidate Method

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCandidate(
    OcrWord word
)
Public Function IsCandidate (
    word As OcrWord
) As Boolean

Parameters

word
Type: Atalasoft.OcrOcrWord

Return Value

Type: Boolean

Implements

INominatorIsCandidate(OcrWord)
See Also

Reference

BasicWordNominator Class
Atalasoft.Ocr.Voting Namespace


BasicWordSelector Class

Provides basic functionality for choosing the best word from a set of words.
Inheritance Hierarchy
SystemObject
Atalasoft.Ocr.VotingBasicWordSelector

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicWordSelector : IWordSelector
Public Class BasicWordSelector
    Implements IWordSelector

The BasicWordSelector type exposes the following members.

Constructors
 | Name | Description
Public method | BasicWordSelector | Constructs a new BasicWordSelector object
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectWord | Select a word from a set of candidate words.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Ocr.Voting Namespace


BasicWordSelector Constructor

Constructs a new BasicWordSelector object

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BasicWordSelector()
Public Sub New
See Also

Reference

BasicWordSelector Class
Atalasoft.Ocr.Voting Namespace


BasicWordSelector Methods

The BasicWordSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectWord | Select a word from a set of candidate words.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicWordSelector Class
Atalasoft.Ocr.Voting Namespace


BasicWordSelector.SelectWord Method

BasicWordSelectorSelectWord Method

Select a word from a set of candidate words.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrWord SelectWord(
    OcrWord originalWord,
    OcrWordCollection words
)
Public Function SelectWord (
    originalWord As OcrWord,
    words As OcrWordCollection
) As OcrWord

Parameters

originalWord
Type: Atalasoft.OcrOcrWord
The original word recognized by the primary engine and nominated for voting
words
Type: Atalasoft.OcrOcrWordCollection
Alternate words provided by other engines.

Return Value

Type: OcrWord
Returns the best word among all the choices. SelectWord must return non-null.

Implements

IWordSelectorSelectWord(OcrWord, OcrWordCollection)
See Also

Reference

BasicWordSelector Class
Atalasoft.Ocr.Voting Namespace


INominator Interface

Defines that interface for nominating a word.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface INominator
Public Interface INominator

The INominator type exposes the following members.

Methods
 | Name | Description
Public method | IsCandidate | Determine if a word is possible candidate for voting.
Top
See Also

Reference

Atalasoft.Ocr.Voting Namespace


INominator Methods

The INominator type exposes the following members.

Methods
 | Name | Description
Public method | IsCandidate | Determine if a word is possible candidate for voting.
Top
See Also

Reference

INominator Interface
Atalasoft.Ocr.Voting Namespace


INominator.IsCandidate Method

INominatorIsCandidate Method

Determine if a word is possible candidate for voting.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsCandidate(
    OcrWord word
)
Function IsCandidate (
    word As OcrWord
) As Boolean

Parameters

word
Type: Atalasoft.OcrOcrWord
The word that might be nominated.

Return Value

Type: Boolean
Returns true if the word should be a candidate for voting, false otherwise.
See Also

Reference

INominator Interface
Atalasoft.Ocr.Voting Namespace


IWordSelector Interface

Defines the interface for selecting a word.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWordSelector
Public Interface IWordSelector

The IWordSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectWord | Select a word from a set of candidate words.
Top
See Also

Reference

Atalasoft.Ocr.Voting Namespace


IWordSelector Methods

The IWordSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectWord | Select a word from a set of candidate words.
Top
See Also

Reference

IWordSelector Interface
Atalasoft.Ocr.Voting Namespace


IWordSelector.SelectWord Method

IWordSelectorSelectWord Method

Select a word from a set of candidate words.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
OcrWord SelectWord(
    OcrWord originalWord,
    OcrWordCollection words
)
Function SelectWord (
    originalWord As OcrWord,
    words As OcrWordCollection
) As OcrWord

Parameters

originalWord
Type: Atalasoft.OcrOcrWord
The original word recognized by the primary engine and nominated for voting
words
Type: Atalasoft.OcrOcrWordCollection
Alternate words provided by other engines.

Return Value

Type: OcrWord
Returns the best word among all the choices. SelectWord must return non-null.
See Also

Reference

IWordSelector Interface
Atalasoft.Ocr.Voting Namespace


VotingEngine Class

An implementation of OcrEngine which includes voting.
Inheritance Hierarchy
SystemObject
Atalasoft.OcrOcrEngine
Atalasoft.Ocr.VotingVotingEngine

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class VotingEngine : OcrEngine
Public Class VotingEngine
    Inherits OcrEngine

The VotingEngine type exposes the following members.

Constructors
 | Name | Description
Public method | VotingEngine | Constructs a new VotingEngine object.
Top
Properties
 | Name | Description
Public property | AlternateEngines | Gets the collection of alternate engines for the voting engine.
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | InitializeAndShutDownAlternateEngines | Gets or sets a property to control whether or not alternate engines should be initialized and shut down automatically
Public property | Nominator | Gets or sets the nominator that is used for the voting engine.
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | PrimaryEngine | Sets or gets the primary engine used for Ocr.
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Public property | WordSelector | Gets or sets the WordSelector used for the VotingEngine.
Top
Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Inherited from OcrEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | Terminates the engine. (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

Atalasoft.Ocr.Voting Namespace


VotingEngine Constructor

Constructs a new VotingEngine object.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public VotingEngine(
    OcrEngine primaryEngine
)
Public Sub New (
    primaryEngine As OcrEngine
)

Parameters

primaryEngine
Type: Atalasoft.OcrOcrEngine
An engine to use as a primary Ocr engine. Must not be null.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine Properties

The VotingEngine type exposes the following members.

Properties
 | Name | Description
Public property | AlternateEngines | Gets the collection of alternate engines for the voting engine.
Public property | AvailablePreprocessingOptions | This property returns the available set of image preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | CanRecognizeBarcodes | Returns true if this engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | CanUseSymbolSet | Gets a value indicating whether engine can use symbol set or not. (Inherited from OcrEngine.)
Public property | DefaultPreprocessingOptions | Returns the default preprocessing options for this OcrEngine. (Inherited from OcrEngine.)
Public property | DefaultRecognitionCulture | Returns the default recognition language for this engine. (Overrides OcrEngineDefaultRecognitionCulture.)
Public property | Factory | This property provides an object of type IOcrFactory for the construction of page and document elements. (Inherited from OcrEngine.)
Public property | FontBuilder | This property provides a font builder that will be used for page construction. (Inherited from OcrEngine.)
Public property | FontMapper | This property provides a font mapper that will be used for page construction. (Inherited from OcrEngine.)
Public property | InitializeAndShutDownAlternateEngines | Gets or sets a property to control whether or not alternate engines should be initialized and shut down automatically
Public property | Nominator | Gets or sets the nominator that is used for the voting engine.
Public property | PreprocessingOptions | The property provides the preprocessing options to be used for this engine. (Inherited from OcrEngine.)
Public property | PrimaryEngine | Sets or gets the primary engine used for Ocr.
Public property | RecognitionCulture | Sets or gets the recognition language for this engine. (Inherited from OcrEngine.)
Public property | RecognitionCulturesList | Gets or sets the list of cultures to be used during recognition. (Inherited from OcrEngine.)
Public property | RecognizeBarcodes | When true, will recognize barcodes as well as text if the engine supports barcode recognition. (Inherited from OcrEngine.)
Public property | SupportedBarcodeSymbologies | Gets a list of barcode symbologies that are supported by this OcrDocument (if any). (Inherited from OcrEngine.)
Public property | SupportMultiCultureRecognition | Gets the value indicating whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Public property | Translators | This property provides access to a TranslatorCollection object used by the engine to translate images to documents. (Inherited from OcrEngine.)
Public property | WordSelector | Gets or sets the WordSelector used for the VotingEngine.
Top
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.AlternateEngines Property

VotingEngineAlternateEngines Property

Gets the collection of alternate engines for the voting engine.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEngineCollection AlternateEngines { get; }
Public ReadOnly Property AlternateEngines As OcrEngineCollection
    Get

Property Value

Type: OcrEngineCollection
Remarks
In order to vote on suspect words, this collection must contain at least one engine.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.DefaultRecognitionCulture Property

VotingEngineDefaultRecognitionCulture Property

Returns the default recognition language for this engine.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo DefaultRecognitionCulture { get; }
Public Overrides ReadOnly Property DefaultRecognitionCulture As CultureInfo
    Get

Property Value

Type: CultureInfo
The default recognition language for this engine.
Remarks
Most engines will return English or neutral culture as their default.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.InitializeAndShutDownAlternateEngines Property

VotingEngineInitializeAndShutDownAlternateEngines Property

Gets or sets a property to control whether or not alternate engines should be initialized and shut down automatically

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool InitializeAndShutDownAlternateEngines { get; set; }
Public Property InitializeAndShutDownAlternateEngines As Boolean
    Get
    Set

Property Value

Type: Boolean
True if the VotingEngine will automatically initialize and shut down alternate engines, false otherwise.
Remarks
There may be some speed gains by not having to initialize and shut down every engine contained within the voting engine. Default value is true.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.Nominator Property

VotingEngineNominator Property

Gets or sets the nominator that is used for the voting engine.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public INominator Nominator { get; set; }
Public Property Nominator As INominator
    Get
    Set

Property Value

Type: INominator
Remarks
Must not be set to null. By default is set to an instance of BasicWordNominator.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.PrimaryEngine Property

VotingEnginePrimaryEngine Property

Sets or gets the primary engine used for Ocr.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEngine PrimaryEngine { get; set; }
Public Property PrimaryEngine As OcrEngine
    Get
    Set

Property Value

Type: OcrEngine
Remarks
Must not be null. Default value is set by the VotingEngine constructor.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.WordSelector Property

VotingEngineWordSelector Property

Gets or sets the WordSelector used for the VotingEngine.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IWordSelector WordSelector { get; set; }
Public Property WordSelector As IWordSelector
    Get
    Set

Property Value

Type: IWordSelector
Remarks
Must not be null. Default value is an instance of BasicWordSelector.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine Methods

The VotingEngine type exposes the following members.

Methods
 | Name | Description
Public method | CanStream | Determines if it is possible to write a particular output format to a Stream. (Inherited from OcrEngine.)
Public method | CanTranslate | Determines if it is possible to translate a document to a particular output format. (Inherited from OcrEngine.)
Protected method | CulturesMatch | Detects whether specified cultures match. (Inherited from OcrEngine.)
Public method | Dispose | Dispose memory used by the OcrEngine. (Inherited from OcrEngine.)
Protected method | Dispose(Boolean) | (Inherited from OcrEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | OcrEngine finalizer. (Inherited from OcrEngine.)
Protected method | GetAvailablePreprocessingOptions | Gets available preprocessing options for this OcrEngine (Overrides OcrEngineGetAvailablePreprocessingOptions.)
Protected method | GetCanRecognizeBarcodes | Gets the value indicating whether the engine can recognize barcodes or not. (Inherited from OcrEngine.)
Protected method | GetDefaultPreprocessingOptions | Gets default preprocessing options for this OcrEngine (Overrides OcrEngineGetDefaultPreprocessingOptions.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetLicenseFlag | Retrieves value of the flag with specified name. (Inherited from OcrEngine.)
Protected method | GetSupportedBarcodeSymbologies | Returns the barcode symbologies supported by this engine. (Inherited from OcrEngine.)
Public method | GetSupportedRecognitionCultures | Returns an array of supported recognition languages for this engine (Overrides OcrEngineGetSupportedRecognitionCultures.)
Public method | GetSymbolSet | Returns an engine-specific symbol set matching string from a standard symbol set. (Inherited from OcrEngine.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDeskew | Handles the process of deskewing an image. (Inherited from OcrEngine.)
Public method | HasPageLocationHandler | Determines whether or not events have been installed for page location. (Inherited from OcrEngine.)
Public method | Initialize | Initialize the engine. (Overrides OcrEngineInitialize.)
Protected method | IsMultiCultureRecognitionSupported | Tells whether the OCR engine supports multiple recognition cultures. (Inherited from OcrEngine.)
Protected method | MakeBinarizeCommand | Returns a new ImageCommand that will binarize an image in the HandleDeskew method (Inherited from OcrEngine.)
Protected method | MakeDeskewCommand | Returns a new ImageCommand that will deskew an image. (Inherited from OcrEngine.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OcrBarcodeSymbologyIsSupported | Returns true if a given barcode symbology is supported. (Inherited from OcrEngine.)
Protected method | OnDocumentProgress | Fire the DocumentProgress event. (Inherited from OcrEngine.)
Protected method | OnImageIntroduction | Raises the ImageIntroduction event. (Inherited from OcrEngine.)
Protected method | OnImageSendOff | Raises the ImageSendOff event. (Inherited from OcrEngine.)
Protected method | OnImageTransformation | Raises the ImageTransformation event. (Inherited from OcrEngine.)
Protected method | OnPageConstructed | Fire the PageConstructed event. (Inherited from OcrEngine.)
Protected method | OnPageConstructing | Fire the PageConstructing event. (Inherited from OcrEngine.)
Protected method | OnPageLocation | Fire the PageLocation event. (Inherited from OcrEngine.)
Protected method | OnPageProgress | Fire the page progress event. (Inherited from OcrEngine.)
Protected method | RecognitionCultureChanged | Occurs when a recognition culture list changes. (Overrides OcrEngineRecognitionCultureChanged.)
Public method | RecognitionCultureSupported | Indicates whether or not this engine will support a given recognition culture (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | ShutDown | Terminates the engine. (Overrides OcrEngineShutDown.)
Public method | Supported | Obsolete. Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Public method | SupportedMimeTypes | Provides a list of all mime types supported by Translators in this engine. (Inherited from OcrEngine.)
Protected method | SupportingTranslator | Finds a translator that supports translation to the requested output type. (Inherited from OcrEngine.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToSymbolSet | Converts a set of unique characters to a engine-specific symbol matching set. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream) | Translates a collection of images to the specified mime type, writing the output to the given stream. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String) | Translates a collection of images to the specified mime type, writing the output to the given path. This method attempts to select the best translator for the job. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, Stream, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given stream using the supplied translator. (Inherited from OcrEngine.)
Public method | Translate(ImageSource, String, String, ITranslator) | Translates a collection of images to the specified mime type, writing the output to the given path using the supplied translator. (Inherited from OcrEngine.)
Top
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.GetAvailablePreprocessingOptions Method

VotingEngineGetAvailablePreprocessingOptions Method

Gets available preprocessing options for this OcrEngine

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetAvailablePreprocessingOptions()
Protected Overrides Function GetAvailablePreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Available preprocessing options.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.GetDefaultPreprocessingOptions Method

VotingEngineGetDefaultPreprocessingOptions Method

Gets default preprocessing options for this OcrEngine

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override OcrPreprocessingOptions GetDefaultPreprocessingOptions()
Protected Overrides Function GetDefaultPreprocessingOptions As OcrPreprocessingOptions

Return Value

Type: OcrPreprocessingOptions
Default preprocessing options
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.GetSupportedRecognitionCultures Method

VotingEngineGetSupportedRecognitionCultures Method

Returns an array of supported recognition languages for this engine

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override CultureInfo[] GetSupportedRecognitionCultures()
Public Overrides Function GetSupportedRecognitionCultures As CultureInfo()

Return Value

Type: CultureInfo
An array of supported recognition languages for this engine
Remarks
Some engines support few or one recognition language. Some engines support hundreds, although most of the supported languages are equivalent to "latin alphabet" or "cyrillic alphabet". Some engines provide languages for which there is no equivalent CultureInfo (Esperanto, for example) and therefore can't be reflected in this interface.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.Initialize Method

VotingEngineInitialize Method

Initialize the engine.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
Remarks
This is an abstract method and must be implemented by a subclass of OcrEngine. Not every engine will perform an action in this method.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.RecognitionCultureChanged Method

VotingEngineRecognitionCultureChanged Method

Occurs when a recognition culture list changes.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RecognitionCultureChanged()
Protected Overrides Sub RecognitionCultureChanged
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.Recognize Method

VotingEngineRecognize Method

Overload List
 | Name | Description
Public method | Recognize(AtalaImage) | Recognize text in an AtalaImage, transforming it into an OcrPage object. (Overrides OcrEngineRecognize(AtalaImage).)
Public method | Recognize(ImageSource) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Public method | Recognize(AtalaImage, Rectangle) | Recognize only within a specific rectangle in an AtalaImage. (Inherited from OcrEngine.)
Protected method | Recognize(AtalaImage, Int32) | Recognize text in an AtalaImage (Inherited from OcrEngine.)
Protected method | Recognize(ImageSource, OcrDocument, IForeignTranslator, Object) | Recognize a set of AtalaImage objects as an entire document. (Inherited from OcrEngine.)
Top
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine.Recognize Method (AtalaImage)

VotingEngineRecognize Method (AtalaImage)

Recognize text in an AtalaImage, transforming it into an OcrPage object.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override OcrPage Recognize(
    AtalaImage image
)
Public Overrides Function Recognize (
    image As AtalaImage
) As OcrPage

Parameters

image
Type: Atalasoft.ImagingAtalaImage
The image to recognize.

Return Value

Type: OcrPage
The recognized page.
Remarks
The version of Recognize that takes an ImageCollection is likely to change.
See Also

Reference

VotingEngine Class
Recognize Overload
Atalasoft.Ocr.Voting Namespace


VotingEngine.ShutDown Method

VotingEngineShutDown Method

Terminates the engine.

Namespace: Atalasoft.Ocr.Voting
Assembly: Atalasoft.dotImage.Ocr (in Atalasoft.dotImage.Ocr.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void ShutDown()
Public Overrides Sub ShutDown
Remarks
This method is abstract and must be implemented by an engine. Not every engine will perform an action for this method.
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


VotingEngine Events

The VotingEngine type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | This event is used to publish progress made in recognition of a set of images. (Inherited from OcrEngine.)
Public event | ImageIntroduction | This event is raised before ImageTransformation in order to allow the document to be pre-processed prior to deskew. (Inherited from OcrEngine.)
Public event | ImageSendOff | This event is raised before the OCR process starts, and after ImageTransformation for OCR pre-processing. (Inherited from OcrEngine.)
Public event | ImageTransformation | This event is raised just after the image is deskewed and before ImageSendOff is raised. (Inherited from OcrEngine.)
Public event | PageConstructed | This event is used to publish the page that has just been constructed. (Inherited from OcrEngine.)
Public event | PageConstructing | This event is used to publish the page that is in the process of being populated. (Inherited from OcrEngine.)
Public event | PageLocation | This event is used to publish OcrRegions that have been identified within an image. (Inherited from OcrEngine.)
Public event | PageProgress | This event is used to publish progress made in the recognition of a page. (Inherited from OcrEngine.)
Top
See Also

Reference

VotingEngine Class
Atalasoft.Ocr.Voting Namespace


Atalasoft.Pdf.TextExtract Namespace

Classes
 | Class | Description
Public class | PdfSearchResults | Defines result of a search operation.
 | PdfTextDocument | Represents a PDF document for text processing operations.
Public class | PdfTextFont | Represents a PDF Font object.
Public class | PdfTextPage | The object representation of a page in a PDF document. Used for PDF text search and complex text extraction.
 | PdfTextReader | Represents a TextReader implementation for PDF documents.
Public class | PdfTextSegment | Represents a text segment of PDF page.


PdfSearchResults Class

Defines result of a search operation.
Inheritance Hierarchy
SystemObject
Atalasoft.Pdf.TextExtractPdfSearchResults

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfSearchResults : IDisposable
Public Class PdfSearchResults
    Implements IDisposable

The PdfSearchResults type exposes the following members.

Properties
 | Name | Description
Public property | CharCount | Gets start number of characters that comprise current search result.
Public property | HasResults | Gets a value indicating whether results of the search operation exist or not.
Public property | StartIndex | Gets start index of the current search result.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfSearchResults
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfSearchResults and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNext | Moves to the next search result.
Public method | FindPrevious | Moves to the previous search result.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class is similar to IEnumerable in a sense that you need to call FindNext to get the first search result. In other words, right after the search operation, PdfSearchResuls instance is positioned before first search result.
See Also

Reference

Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults Properties

The PdfSearchResults type exposes the following members.

Properties
 | Name | Description
Public property | CharCount | Gets start number of characters that comprise current search result.
Public property | HasResults | Gets a value indicating whether results of the search operation exist or not.
Public property | StartIndex | Gets start index of the current search result.
Top
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.CharCount Property

PdfSearchResultsCharCount Property

Gets start number of characters that comprise current search result.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CharCount { get; }
Public ReadOnly Property CharCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.HasResults Property

PdfSearchResultsHasResults Property

Gets a value indicating whether results of the search operation exist or not.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasResults { get; }
Public ReadOnly Property HasResults As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.StartIndex Property

PdfSearchResultsStartIndex Property

Gets start index of the current search result.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int StartIndex { get; }
Public ReadOnly Property StartIndex As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults Methods

The PdfSearchResults type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNext | Moves to the next search result.
Public method | FindPrevious | Moves to the previous search result.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.Dispose Method

PdfSearchResultsDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfSearchResults
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfSearchResults and optionally releases the managed resources
Top
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.Dispose Method

PdfSearchResultsDispose Method

Releases all resources used by the PdfSearchResults

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfSearchResults Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.Dispose Method (Boolean)

PdfSearchResultsDispose Method (Boolean)

Releases the unmanaged resources used by the PdfSearchResults and optionally releases the managed resources

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfSearchResults Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.FindNext Method

PdfSearchResultsFindNext Method

Moves to the next search result.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FindNext()
Public Function FindNext As Boolean

Return Value

Type: Boolean
true if next search result exists; otherwise false.
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfSearchResults.FindPrevious Method

PdfSearchResultsFindPrevious Method

Moves to the previous search result.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FindPrevious()
Public Function FindPrevious As Boolean

Return Value

Type: Boolean
true if there is previous search result exists; otherwise false.
See Also

Reference

PdfSearchResults Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Class

Represents a PDF document for text processing operations.
Inheritance Hierarchy
SystemObject
Atalasoft.Pdf.TextExtractPdfTextDocument

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTextDocument : IDisposable,
    ITextDocument
Public Class PdfTextDocument
    Implements IDisposable, ITextDocument

The PdfTextDocument type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTextDocument(Stream) | Initalizes a new instance of the PdfTextDocument class.
Public method | PdfTextDocument(String) | Initalizes a new instance of the PdfTextDocument class.
Public method | PdfTextDocument(Stream, String) | Initalizes a new instance of the PdfTextDocument class.
Public method | PdfTextDocument(String, String) | Initalizes a new instance of the PdfTextDocument class.
Top
Properties
 | Name | Description
Public property | ExtractionGranularity | Gets the extraction granularity provided by this document.
Public property | OutputLineEnd | Gets or sets a flag indicating whether line end symbols should returned by PdfTextReader.
Public property | OutputPageEnd | Gets or sets a flag indicating whether a page end symbol should returned by PdfTextReader.
Public property | PageCount | Gets the document page count.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfTextDocument
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfTextDocument and optionally releases the managed resources
Protected method | DisposePages | Disposes all pages in a cache.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPage | Retrieves a PdfTextPage from document.
Public method | GetPdfTextReader | Creates a new PdfTextReader for all pages in document.
Public method | GetPdfTextReader(Int32) | Creates a new PdfTextReader for specified page.
Public method | GetPdfTextReader(Int32, Int32) | Creates a new PdfTextReader for specified pages range.
Public method | GetTextPage | Gets the ITextPage at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Obsolete.
Protected method | MakePages | Initializes a pages cache.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Extracting Text from a PDF (C#)
Copy
using Atalasoft.Pdf.TextExtract;
using System.Drawing;
using System.IO;

// some examples of using the classes in the
// Atalasoft.Pdf.TextExtract namespace

// get the number of pages in a PDF
public int GetPageCount(Stream s)
{
    using (PdfTextDocument doc = new PdfTextDocument(s))
    {
        return doc.PageCount;
    }
}

// get the number of characters on a page in a PDF
public int GetCharCount(Stream s, int pageNum)
{
    using (PdfTextDocument doc = new PdfTextDocument(s))
    {
        PdfTextPage textPage = doc.GetPage(pageNum);
        return textPage.CharCount;
    }
}

// Extract Text from a PDF
public String GetText(Stream s, int pageNum, int index, int count)
{
    using (PdfTextDocument doc = new PdfTextDocument(s))
    {
        PdfTextPage textPage = doc.GetPage(pageNum);
        return textPage.GetText(index, count);
    }
}

// Find out where a character is in a PDF
public PointF GetCharPos(Stream s, int pageNum, int index)
{
    using (PdfTextDocument doc = new PdfTextDocument(s))
    {
        PdfTextPage textPage = doc.GetPage(pageNum);
        return textPage.CharOrigin(index);
    }
}
Extracting Text from a PDF (Visual Basic)
Copy
Imports System.Drawing
Imports System.IO
Imports Atalasoft.Pdf.TextExtract

' some examples of using the classes In the
' Atalasoft.Pdf.TextExtract Namespace

' get the number of pages in a PDF
Public Function GetPageCount(ByVal s As Stream) As Integer
    Using doc As New PdfTextDocument(s)
        Return doc.PageCount
    End Using
End Function

' get the number of characters on a page in a PDF
Public Function GetCharCount(ByVal s As Stream, ByVal pageNum As Integer) As Integer
    Using doc As New PdfTextDocument(s)
        Dim textPage As PdfTextPage = doc.GetPage(pageNum)
        Return textPage.CharCount
    End Using
End Function

' Extract Text from a PDF
Public Function GetText(ByVal s As Stream, ByVal pageNum As Integer, ByVal index As Integer, ByVal count As Integer) As String
    Using doc As New PdfTextDocument(s)
        Dim textPage As PdfTextPage = doc.GetPage(pageNum)
        Return textPage.GetText(index, count)
    End Using
End Function

' Find out where a character is in a PDF
Public Function GetCharPos(ByVal s As Stream, ByVal pageNum As Integer, ByVal index As Integer) As PointF
    Using doc As New PdfTextDocument(s)
        Dim textPage As PdfTextPage = doc.GetPage(pageNum)
        Return textPage.CharOrigin(index)
    End Using
End Function
See Also

Reference

Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Constructor

Overload List
 | Name | Description
Public method | PdfTextDocument(Stream) | Initalizes a new instance of the PdfTextDocument class.
Public method | PdfTextDocument(String) | Initalizes a new instance of the PdfTextDocument class.
Public method | PdfTextDocument(Stream, String) | Initalizes a new instance of the PdfTextDocument class.
Public method | PdfTextDocument(String, String) | Initalizes a new instance of the PdfTextDocument class.
Top
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Constructor (Stream)

Initalizes a new instance of the PdfTextDocument class.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextDocument(
    Stream s
)
Public Sub New (
    s As Stream
)

Parameters

s
Type: System.IOStream
Stream where PDF document store.
See Also

Reference

PdfTextDocument Class
PdfTextDocument Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Constructor (String)

Initalizes a new instance of the PdfTextDocument class.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextDocument(
    string filename
)
Public Sub New (
    filename As String
)

Parameters

filename
Type: SystemString
a filepath to the PDF document.
See Also

Reference

PdfTextDocument Class
PdfTextDocument Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Constructor (Stream, String)

Initalizes a new instance of the PdfTextDocument class.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextDocument(
    Stream s,
    string password
)
Public Sub New (
    s As Stream,
    password As String
)

Parameters

s
Type: System.IOStream
Stream where PDF document store.
password
Type: SystemString
Password to open PDF document.
See Also

Reference

PdfTextDocument Class
PdfTextDocument Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Constructor (String, String)

Initalizes a new instance of the PdfTextDocument class.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextDocument(
    string filename,
    string password
)
Public Sub New (
    filename As String,
    password As String
)

Parameters

filename
Type: SystemString
a filepath to the PDF document.
password
Type: SystemString
Password to open PDFdocument.
See Also

Reference

PdfTextDocument Class
PdfTextDocument Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Properties

The PdfTextDocument type exposes the following members.

Properties
 | Name | Description
Public property | ExtractionGranularity | Gets the extraction granularity provided by this document.
Public property | OutputLineEnd | Gets or sets a flag indicating whether line end symbols should returned by PdfTextReader.
Public property | OutputPageEnd | Gets or sets a flag indicating whether a page end symbol should returned by PdfTextReader.
Public property | PageCount | Gets the document page count.
Top
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.ExtractionGranularity Property

PdfTextDocumentExtractionGranularity Property

Gets the extraction granularity provided by this document.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual TextExtractionUnit ExtractionGranularity { get; }
Public Overridable ReadOnly Property ExtractionGranularity As TextExtractionUnit
    Get

Property Value

Type: TextExtractionUnit

Implements

ITextDocumentExtractionGranularity
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.OutputLineEnd Property

PdfTextDocumentOutputLineEnd Property

Gets or sets a flag indicating whether line end symbols should returned by PdfTextReader.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OutputLineEnd { get; set; }
Public Property OutputLineEnd As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.OutputPageEnd Property

PdfTextDocumentOutputPageEnd Property

Gets or sets a flag indicating whether a page end symbol should returned by PdfTextReader.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OutputPageEnd { get; set; }
Public Property OutputPageEnd As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.PageCount Property

PdfTextDocumentPageCount Property

Gets the document page count.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual int PageCount { get; }
Public Overridable ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32

Implements

ITextDocumentPageCount
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument Methods

The PdfTextDocument type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | DisposePages | Disposes all pages in a cache.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPage | Retrieves a PdfTextPage from document.
Public method | GetPdfTextReader | Creates a new PdfTextReader for all pages in document.
Public method | GetPdfTextReader(Int32) | Creates a new PdfTextReader for specified page.
Public method | GetPdfTextReader(Int32, Int32) | Creates a new PdfTextReader for specified pages range.
Public method | GetTextPage | Gets the ITextPage at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Obsolete.
Protected method | MakePages | Initializes a pages cache.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.Dispose Method

PdfTextDocumentDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfTextDocument
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfTextDocument and optionally releases the managed resources
Top
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.Dispose Method

PdfTextDocumentDispose Method

Releases all resources used by the PdfTextDocument

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfTextDocument Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.Dispose Method (Boolean)

PdfTextDocumentDispose Method (Boolean)

Releases the unmanaged resources used by the PdfTextDocument and optionally releases the managed resources

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfTextDocument Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.DisposePages Method

PdfTextDocumentDisposePages Method

Disposes all pages in a cache.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void DisposePages(
    bool disposing
)
Protected Sub DisposePages (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.GetPage Method

PdfTextDocumentGetPage Method

Retrieves a PdfTextPage from document.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PdfTextPage GetPage(
    int index
)
Public Overridable Function GetPage (
    index As Integer
) As PdfTextPage

Parameters

index
Type: SystemInt32

Return Value

Type: PdfTextPage
A created or cached PdfTextPage.
Remarks
PdfTextDocument stores all retrieved pages in its own cache which clears only when all document disposing.
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.GetPdfTextReader Method

PdfTextDocumentGetPdfTextReader Method

Overload List
 | Name | Description
Public method | GetPdfTextReader | Creates a new PdfTextReader for all pages in document.
Public method | GetPdfTextReader(Int32) | Creates a new PdfTextReader for specified page.
Public method | GetPdfTextReader(Int32, Int32) | Creates a new PdfTextReader for specified pages range.
Top
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.GetPdfTextReader Method

PdfTextDocumentGetPdfTextReader Method

Creates a new PdfTextReader for all pages in document.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextReader GetPdfTextReader()
Public Function GetPdfTextReader As PdfTextReader

Return Value

Type: PdfTextReader
A created PdfTextReader.
See Also

Reference

PdfTextDocument Class
GetPdfTextReader Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.GetPdfTextReader Method (Int32)

PdfTextDocumentGetPdfTextReader Method (Int32)

Creates a new PdfTextReader for specified page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextReader GetPdfTextReader(
    int page
)
Public Function GetPdfTextReader (
    page As Integer
) As PdfTextReader

Parameters

page
Type: SystemInt32
page index.

Return Value

Type: PdfTextReader
A created PdfTextReader.
See Also

Reference

PdfTextDocument Class
GetPdfTextReader Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.GetPdfTextReader Method (Int32, Int32)

PdfTextDocumentGetPdfTextReader Method (Int32, Int32)

Creates a new PdfTextReader for specified pages range.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextReader GetPdfTextReader(
    int startPage,
    int endPage
)
Public Function GetPdfTextReader (
    startPage As Integer,
    endPage As Integer
) As PdfTextReader

Parameters

startPage
Type: SystemInt32
page index from what range should begin.
endPage
Type: SystemInt32
page index where range should end.

Return Value

Type: PdfTextReader
A created PdfTextReader.
See Also

Reference

PdfTextDocument Class
GetPdfTextReader Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.GetTextPage Method

PdfTextDocumentGetTextPage Method

Gets the ITextPage at the specified index.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ITextPage GetTextPage(
    int index
)
Public Overridable Function GetTextPage (
    index As Integer
) As ITextPage

Parameters

index
Type: SystemInt32
The page index.

Return Value

Type: ITextPage
ITextPage at the specified index.

Implements

ITextDocumentGetPage(Int32)
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.Initialize Method

PdfTextDocumentInitialize Method

Note: This API is now obsolete.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("You don't need to use this method. All initialization proceeds in the constructor")]
protected static void Initialize()
<ObsoleteAttribute("You don't need to use this method. All initialization proceeds in the constructor")>
Protected Shared Sub Initialize
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextDocument.MakePages Method

PdfTextDocumentMakePages Method

Initializes a pages cache.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void MakePages()
Protected Sub MakePages
See Also

Reference

PdfTextDocument Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextFont Class

Represents a PDF Font object.
Inheritance Hierarchy
SystemObject
Atalasoft.Pdf.TextExtractPdfTextFont

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTextFont
Public Class PdfTextFont

The PdfTextFont type exposes the following members.

Properties
 | Name | Description
Public property | Ascent | The maximum height above the baseline reached by glyphs in this font.
Public property | Descent | The maximum depth below the baseline reached by glyphs in this font.
Public property | Name | Gets a PostScript name of the font.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Pdf.TextExtract Namespace


PdfTextFont Properties

The PdfTextFont type exposes the following members.

Properties
 | Name | Description
Public property | Ascent | The maximum height above the baseline reached by glyphs in this font.
Public property | Descent | The maximum depth below the baseline reached by glyphs in this font.
Public property | Name | Gets a PostScript name of the font.
Top
See Also

Reference

PdfTextFont Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextFont.Ascent Property

PdfTextFontAscent Property

The maximum height above the baseline reached by glyphs in this font.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Ascent { get; }
Public ReadOnly Property Ascent As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfTextFont Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextFont.Descent Property

PdfTextFontDescent Property

The maximum depth below the baseline reached by glyphs in this font.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Descent { get; }
Public ReadOnly Property Descent As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfTextFont Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextFont.Name Property

PdfTextFontName Property

Gets a PostScript name of the font.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

PdfTextFont Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextFont Methods

The PdfTextFont type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextFont Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage Class

The object representation of a page in a PDF document. Used for PDF text search and complex text extraction.
Inheritance Hierarchy
SystemObject
Atalasoft.Pdf.TextExtractPdfTextPage

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTextPage : IDisposable
Public Class PdfTextPage
    Implements IDisposable

The PdfTextPage type exposes the following members.

Properties
 | Name | Description
Public property | CharCount | The number of characters in the page.
Protected property | CropBox | Get a PDF page CropBox.
Public property | Height | The height of the page in PDF "user space".
Protected property | MediaBox | Get a PDF page MediaBox.
Protected property | PdfPage | Gets a native pointer to PDF page
Public property | Rotate | Gets the clockwise rotation in degrees that the viewer should apply to the page.
Protected property | TextPage | Gets a native pointer to PDF text page
Public property | Width | The width of the page in PDF "user space".
Top
Methods
 | Name | Description
Public method | CharAt | Gets a character from this page by index.
Public method | CharBox | Gets the bounding box of a character at an index.
Public method | CharIsGenerated | Indicates whether a character at an index is a generated character or actually exists in the PDF.
Public method | CharOrigin | Get origin position of a particular character by index.
Public method | ConvertPdfUnitsToPixels(PointF, Dpi) | Converts a point given in PDF User space units to the corresponding pixel location at the given resolution.
Public method | ConvertPdfUnitsToPixels(QuadrilateralF, Dpi) | Converts a quadrilateral given in PDF User space units to the corresponding pixel location at the given resolution.
Public method | ConvertPixelsToPdfUnits(PointF, Dpi) | Converts a point given in pixels to the corresponding location in PDF User space units at the given resolution.
Public method | ConvertPixelsToPdfUnits(QuadrilateralF, Dpi) | Converts a quadrilateral given in pixels to the corresponding location in PDF User space units at the given resolution.
Public method | Dispose | Releases all resources used by the PdfTextPage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfTextPage and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoundedTextSegments | Gets all of the text segments within a rectangular boundary on the page.
Public method | GetBoxes | Given an character index and a number of characters returns a bounding box for the specified text.
Public method | GetFont | Gets a PdfTextFont object containing the font information for the specified character.
Public method | GetFontSize | Gets the font size of the specified character.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexFromPoint(PointF, Double) | Gets the index of a character at or nearby a given position on the page.
Public method | GetIndexFromPoint(PointF, Double, Double) | Gets the index of a character at or nearby a given position on the page.
Public method | GetText | Extracts a text string from the page.
Public method | GetTextInBox | Extract text within a rectangular boundary on the page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Search | Begins the text search process.
Protected method | ThrowWhenBadIndex | A helper method to check that index is in available range.
Protected method | ThrowWhenBadSearchIndex | A helper method to check that index is in available range.
Protected method | ThrowWhenDisposed | A helper method to check for object disposed state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Pdf.TextExtract Namespace


PdfTextPage Properties

The PdfTextPage type exposes the following members.

Properties
 | Name | Description
Public property | CharCount | The number of characters in the page.
Protected property | CropBox | Get a PDF page CropBox.
Public property | Height | The height of the page in PDF "user space".
Protected property | MediaBox | Get a PDF page MediaBox.
Protected property | PdfPage | Gets a native pointer to PDF page
Public property | Rotate | Gets the clockwise rotation in degrees that the viewer should apply to the page.
Protected property | TextPage | Gets a native pointer to PDF text page
Public property | Width | The width of the page in PDF "user space".
Top
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.CharCount Property

PdfTextPageCharCount Property

The number of characters in the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CharCount { get; }
Public ReadOnly Property CharCount As Integer
    Get

Property Value

Type: Int32
Remarks
Generated characters, like additional space characters, new line characters, are also counted.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.CropBox Property

PdfTextPageCropBox Property

Get a PDF page CropBox.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF CropBox { get; }
Protected ReadOnly Property CropBox As RectangleF
    Get

Property Value

Type: RectangleF
Remarks
A rectangle, expressed in default user space units, that shall define the visible region of default user space. When the page is displayed or printed, its contents shall be clipped(cropped) to this rectangle and then shall be imposed on the output medium in some implementation - defined manner. Default value : the value of MediaBox.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Height Property

PdfTextPageHeight Property

The height of the page in PDF "user space".

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get

Property Value

Type: Double
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.MediaBox Property

PdfTextPageMediaBox Property

Get a PDF page MediaBox.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected RectangleF MediaBox { get; }
Protected ReadOnly Property MediaBox As RectangleF
    Get

Property Value

Type: RectangleF
Remarks
A rectangle, expressed in default user space units, that shall define the boundaries of the physical medium on which the page shall be displayed or printed.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.PdfPage Property

PdfTextPagePdfPage Property

Gets a native pointer to PDF page

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected atala_pdf_page_t__* PdfPage { get; }
Visual Basic does not support APIs that consume or return unsafe types.

Property Value

Type: atala_pdf_page_t__*
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Rotate Property

PdfTextPageRotate Property

Gets the clockwise rotation in degrees that the viewer should apply to the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Rotate { get; }
Public ReadOnly Property Rotate As Integer
    Get

Property Value

Type: Int32
Remarks
If the page does not have an explicit viewer rotation set, 0 is returned.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.TextPage Property

PdfTextPageTextPage Property

Gets a native pointer to PDF text page

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected atala_pdf_textpage_t__* TextPage { get; }
Visual Basic does not support APIs that consume or return unsafe types.

Property Value

Type: atala_pdf_textpage_t__*
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Width Property

PdfTextPageWidth Property

The width of the page in PDF "user space".

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get

Property Value

Type: Double
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage Methods

The PdfTextPage type exposes the following members.

Methods
 | Name | Description
Public method | CharAt | Gets a character from this page by index.
Public method | CharBox | Gets the bounding box of a character at an index.
Public method | CharIsGenerated | Indicates whether a character at an index is a generated character or actually exists in the PDF.
Public method | CharOrigin | Get origin position of a particular character by index.
Public method | ConvertPdfUnitsToPixels(PointF, Dpi) | Converts a point given in PDF User space units to the corresponding pixel location at the given resolution.
Public method | ConvertPdfUnitsToPixels(QuadrilateralF, Dpi) | Converts a quadrilateral given in PDF User space units to the corresponding pixel location at the given resolution.
Public method | ConvertPixelsToPdfUnits(PointF, Dpi) | Converts a point given in pixels to the corresponding location in PDF User space units at the given resolution.
Public method | ConvertPixelsToPdfUnits(QuadrilateralF, Dpi) | Converts a quadrilateral given in pixels to the corresponding location in PDF User space units at the given resolution.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoundedTextSegments | Gets all of the text segments within a rectangular boundary on the page.
Public method | GetBoxes | Given an character index and a number of characters returns a bounding box for the specified text.
Public method | GetFont | Gets a PdfTextFont object containing the font information for the specified character.
Public method | GetFontSize | Gets the font size of the specified character.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexFromPoint(PointF, Double) | Gets the index of a character at or nearby a given position on the page.
Public method | GetIndexFromPoint(PointF, Double, Double) | Gets the index of a character at or nearby a given position on the page.
Public method | GetText | Extracts a text string from the page.
Public method | GetTextInBox | Extract text within a rectangular boundary on the page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Search | Begins the text search process.
Protected method | ThrowWhenBadIndex | A helper method to check that index is in available range.
Protected method | ThrowWhenBadSearchIndex | A helper method to check that index is in available range.
Protected method | ThrowWhenDisposed | A helper method to check for object disposed state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.CharAt Method

PdfTextPageCharAt Method

Gets a character from this page by index.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public char CharAt(
    int index
)
Public Function CharAt (
    index As Integer
) As Char

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.

Return Value

Type: Char

The character at index.

If a character is not encoded in Unicode and it can't be converted to Unicode, the return value will be zero.

See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.CharBox Method

PdfTextPageCharBox Method

Gets the bounding box of a character at an index.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralF CharBox(
    int index
)
Public Function CharBox (
    index As Integer
) As QuadrilateralF

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.

Return Value

Type: QuadrilateralF
a QuadrilateralF which describes the bounding box of the character.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.CharIsGenerated Method

PdfTextPageCharIsGenerated Method

Indicates whether a character at an index is a generated character or actually exists in the PDF.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CharIsGenerated(
    int index
)
Public Function CharIsGenerated (
    index As Integer
) As Boolean

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.

Return Value

Type: Boolean
True if the character was generated, False if it exists inside the PDF.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.CharOrigin Method

PdfTextPageCharOrigin Method

Get origin position of a particular character by index.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF CharOrigin(
    int index
)
Public Function CharOrigin (
    index As Integer
) As PointF

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.

Return Value

Type: PointF

PointF describing the origin position of the indexed character.

X and Y positions are measured in terms of PDF "user space".

See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ConvertPdfUnitsToPixels Method

PdfTextPageConvertPdfUnitsToPixels Method

Converts objects given in PDF User space units to the corresponding pixel location at the given resolution.
Overload List
 | Name | Description
Public method | ConvertPdfUnitsToPixels(PointF, Dpi) | Converts a point given in PDF User space units to the corresponding pixel location at the given resolution.
Public method | ConvertPdfUnitsToPixels(QuadrilateralF, Dpi) | Converts a quadrilateral given in PDF User space units to the corresponding pixel location at the given resolution.
Top
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ConvertPdfUnitsToPixels Method (PointF, Dpi)

PdfTextPageConvertPdfUnitsToPixels Method (PointF, Dpi)

Converts a point given in PDF User space units to the corresponding pixel location at the given resolution.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ConvertPdfUnitsToPixels(
    PointF pt,
    Dpi resolution
)
Public Function ConvertPdfUnitsToPixels (
    pt As PointF,
    resolution As Dpi
) As PointF

Parameters

pt
Type: System.DrawingPointF
resolution
Type: Atalasoft.ImagingDpi

Return Value

Type: PointF
Remarks

In a PDF, the origin is at the bottom-left of a page, and a Y length is positive when starting at the bottom and going towards the top of the page. In pixels, the origin is at the top-left of the image and a Y length is positive when starting at the top of the image and going towards the bottom of the image.

See Also

Reference

PdfTextPage Class
ConvertPdfUnitsToPixels Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ConvertPdfUnitsToPixels Method (QuadrilateralF, Dpi)

PdfTextPageConvertPdfUnitsToPixels Method (QuadrilateralF, Dpi)

Converts a quadrilateral given in PDF User space units to the corresponding pixel location at the given resolution.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralF ConvertPdfUnitsToPixels(
    QuadrilateralF boxInPdfUnits,
    Dpi resolution
)
Public Function ConvertPdfUnitsToPixels (
    boxInPdfUnits As QuadrilateralF,
    resolution As Dpi
) As QuadrilateralF

Parameters

boxInPdfUnits
Type: Atalasoft.Utils.GeometryQuadrilateralF
resolution
Type: Atalasoft.ImagingDpi

Return Value

Type: QuadrilateralF
See Also

Reference

PdfTextPage Class
ConvertPdfUnitsToPixels Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ConvertPixelsToPdfUnits Method

PdfTextPageConvertPixelsToPdfUnits Method

Converts objects given in pixels to the corresponding location in PDF User space units at the given resolution.
Overload List
 | Name | Description
Public method | ConvertPixelsToPdfUnits(PointF, Dpi) | Converts a point given in pixels to the corresponding location in PDF User space units at the given resolution.
Public method | ConvertPixelsToPdfUnits(QuadrilateralF, Dpi) | Converts a quadrilateral given in pixels to the corresponding location in PDF User space units at the given resolution.
Top
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ConvertPixelsToPdfUnits Method (PointF, Dpi)

PdfTextPageConvertPixelsToPdfUnits Method (PointF, Dpi)

Converts a point given in pixels to the corresponding location in PDF User space units at the given resolution.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF ConvertPixelsToPdfUnits(
    PointF pt,
    Dpi resolution
)
Public Function ConvertPixelsToPdfUnits (
    pt As PointF,
    resolution As Dpi
) As PointF

Parameters

pt
Type: System.DrawingPointF
resolution
Type: Atalasoft.ImagingDpi

Return Value

Type: PointF
Remarks

In a PDF, the origin is at the bottom-left of a page, and a Y length is positive when starting at the bottom and going towards the top of the page. In pixels, the origin is at the top-left of the image and a Y length is positive when starting at the top of the image and going towards the bottom of the image.

See Also

Reference

PdfTextPage Class
ConvertPixelsToPdfUnits Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ConvertPixelsToPdfUnits Method (QuadrilateralF, Dpi)

PdfTextPageConvertPixelsToPdfUnits Method (QuadrilateralF, Dpi)

Converts a quadrilateral given in pixels to the corresponding location in PDF User space units at the given resolution.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralF ConvertPixelsToPdfUnits(
    QuadrilateralF boxInPdfUnits,
    Dpi resolution
)
Public Function ConvertPixelsToPdfUnits (
    boxInPdfUnits As QuadrilateralF,
    resolution As Dpi
) As QuadrilateralF

Parameters

boxInPdfUnits
Type: Atalasoft.Utils.GeometryQuadrilateralF
resolution
Type: Atalasoft.ImagingDpi

Return Value

Type: QuadrilateralF
See Also

Reference

PdfTextPage Class
ConvertPixelsToPdfUnits Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Dispose Method

PdfTextPageDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfTextPage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfTextPage and optionally releases the managed resources
Top
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Dispose Method

PdfTextPageDispose Method

Releases all resources used by the PdfTextPage

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfTextPage Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Dispose Method (Boolean)

PdfTextPageDispose Method (Boolean)

Releases the unmanaged resources used by the PdfTextPage and optionally releases the managed resources

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool A_0
)
Protected Overridable Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfTextPage Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetBoundedTextSegments Method

PdfTextPageGetBoundedTextSegments Method

Gets all of the text segments within a rectangular boundary on the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextSegment[] GetBoundedTextSegments(
    RectangleF box
)
Public Function GetBoundedTextSegments (
    box As RectangleF
) As PdfTextSegment()

Parameters

box
Type: System.DrawingRectangleF
A RectangleF which describes the area from which to get the text segments.

Return Value

Type: PdfTextSegment
An array of PdfTextSegment objects.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetBoxes Method

PdfTextPageGetBoxes Method

Given an character index and a number of characters returns a bounding box for the specified text.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QuadrilateralF[] GetBoxes(
    int index,
    int count
)
Public Function GetBoxes (
    index As Integer,
    count As Integer
) As QuadrilateralF()

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.
count
Type: SystemInt32
The number of characters after the index to build the bounding box around.

Return Value

Type: QuadrilateralF
A QuadrilateralF array which describes a bounding box around the specified text.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetFont Method

PdfTextPageGetFont Method

Gets a PdfTextFont object containing the font information for the specified character.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextFont GetFont(
    int index
)
Public Function GetFont (
    index As Integer
) As PdfTextFont

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.

Return Value

Type: PdfTextFont
A PdfTextFont object which describes the PDF font of the specified character.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetFontSize Method

PdfTextPageGetFontSize Method

Gets the font size of the specified character.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetFontSize(
    int index
)
Public Function GetFontSize (
    index As Integer
) As Double

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.

Return Value

Type: Double
The size of the PDF font at the given index.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetIndexFromPoint Method

PdfTextPageGetIndexFromPoint Method

Gets the index of a character at or nearby a given position on the page.

Overload List
 | Name | Description
Public method | GetIndexFromPoint(PointF, Double) | Gets the index of a character at or nearby a given position on the page.
Public method | GetIndexFromPoint(PointF, Double, Double) | Gets the index of a character at or nearby a given position on the page.
Top
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetIndexFromPoint Method (PointF, Double)

PdfTextPageGetIndexFromPoint Method (PointF, Double)

Gets the index of a character at or nearby a given position on the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetIndexFromPoint(
    PointF point,
    double tolerance
)
Public Function GetIndexFromPoint (
    point As PointF,
    tolerance As Double
) As Integer

Parameters

point
Type: System.DrawingPointF
A PointF representing a location in PDF "user space".
tolerance
Type: SystemDouble
A point unit tolerance value for character hit detection for both the X and Y axis.

Return Value

Type: Int32

Returns the zero-based index of the character at, or nearby the given point.

If there is no character at or nearby the point, return value will be -1.

If an error occurs, -3 will be returned.

See Also

Reference

PdfTextPage Class
GetIndexFromPoint Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetIndexFromPoint Method (PointF, Double, Double)

PdfTextPageGetIndexFromPoint Method (PointF, Double, Double)

Gets the index of a character at or nearby a given position on the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int GetIndexFromPoint(
    PointF point,
    double xTolerance,
    double yTolerance
)
Public Function GetIndexFromPoint (
    point As PointF,
    xTolerance As Double,
    yTolerance As Double
) As Integer

Parameters

point
Type: System.DrawingPointF
A PointF representing a location in PDF "user space".
xTolerance
Type: SystemDouble
A point unit tolerance value for character hit detection for the X axis.
yTolerance
Type: SystemDouble
A point unit tolerance value for character hit detection for the Y axis.

Return Value

Type: Int32

Returns the zero-based index of the character at, or nearby the given point.

If there is no character at or nearby the point, return value will be -1.

If an error occurs, -3 will be returned.

See Also

Reference

PdfTextPage Class
GetIndexFromPoint Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetText Method

PdfTextPageGetText Method

Extracts a text string from the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetText(
    int index,
    int count
)
Public Function GetText (
    index As Integer,
    count As Integer
) As String

Parameters

index
Type: SystemInt32
Zero-based index of the character in terms of this page.
count
Type: SystemInt32
The number of characters to get.

Return Value

Type: String
A string containing the specified range of characters.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.GetTextInBox Method

PdfTextPageGetTextInBox Method

Extract text within a rectangular boundary on the page.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetTextInBox(
    RectangleF box
)
Public Function GetTextInBox (
    box As RectangleF
) As String

Parameters

box
Type: System.DrawingRectangleF
A RectangleF specifying the region from which text will be extracted.

Return Value

Type: String
A string containing the specified characters.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.Search Method

PdfTextPageSearch Method

Begins the text search process.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSearchResults Search(
    int index,
    string text,
    bool matchCase,
    bool wholeWord
)
Public Function Search (
    index As Integer,
    text As String,
    matchCase As Boolean,
    wholeWord As Boolean
) As PdfSearchResults

Parameters

index
Type: SystemInt32

Zero-based index of the character in terms of this page.

-1 starts the search at the end of the page.

text
Type: SystemString
The text to search for.
matchCase
Type: SystemBoolean
A flag to specify if search should match case.
wholeWord
Type: SystemBoolean
A flag to specify if search should match whole words only.

Return Value

Type: PdfSearchResults
A PdfSearchResults object which represents the results of the search.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ThrowWhenBadIndex Method

PdfTextPageThrowWhenBadIndex Method

A helper method to check that index is in available range.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ThrowWhenBadIndex(
    int index
)
Protected Sub ThrowWhenBadIndex (
    index As Integer
)

Parameters

index
Type: SystemInt32
Page char index.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ThrowWhenBadSearchIndex Method

PdfTextPageThrowWhenBadSearchIndex Method

A helper method to check that index is in available range.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ThrowWhenBadSearchIndex(
    int index
)
Protected Sub ThrowWhenBadSearchIndex (
    index As Integer
)

Parameters

index
Type: SystemInt32
Page char index.
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextPage.ThrowWhenDisposed Method

PdfTextPageThrowWhenDisposed Method

A helper method to check for object disposed state.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ThrowWhenDisposed()
Protected Sub ThrowWhenDisposed
See Also

Reference

PdfTextPage Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader Class

Represents a TextReader implementation for PDF documents.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOTextReader
Atalasoft.Pdf.TextExtractPdfTextReader

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTextReader : TextReader
Public Class PdfTextReader
    Inherits TextReader

The PdfTextReader type exposes the following members.

Properties
 | Name | Description
Public property | OutputLineEnd | Gets or sets a flag indicating whether Read(Char, Int32, Int32) and Peek methods should return line end symbols.
Public property | OutputPageEnd | Gets or sets a flag indicating whether Read(Char, Int32, Int32) and Peek methods should return page end symbol.
Top
Methods
 | Name | Description
Public method | Close | Closes the TextReader and releases any system resources associated with the TextReader. (Inherited from TextReader.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfTextReader and optionally releases the managed resources (Overrides TextReaderDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Reads the next character without changing the state of the reader or the character source. Returns the next available character without actually reading it from the reader. (Overrides TextReaderPeek.)
Public method | Read | Reads the next character from the text reader and advances the character position by one character. (Overrides TextReaderRead.)
Public method | Read(Char, Int32, Int32) | Reads a specified maximum number of characters from the current reader and writes the data to a buffer, beginning at the specified index. (Overrides TextReaderRead(Char, Int32, Int32).)
Public method | ReadAsync | Reads a specified maximum number of characters from the current text reader asynchronously and writes the data to a buffer, beginning at the specified index. (Inherited from TextReader.)
Public method | ReadBlock | Reads a specified maximum number of characters from the current text reader and writes the data to a buffer, beginning at the specified index. (Inherited from TextReader.)
Public method | ReadBlockAsync | Reads a specified maximum number of characters from the current text reader asynchronously and writes the data to a buffer, beginning at the specified index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the text reader and returns the data as a string. (Overrides TextReaderReadLine.)
Public method | ReadLineAsync | Reads a line of characters asynchronously and returns the data as a string. (Inherited from TextReader.)
Public method | ReadToEnd | Reads all characters from the current position to the end of the text reader and returns them as one string. (Inherited from TextReader.)
Public method | ReadToEndAsync | Reads all characters from the current position to the end of the text reader asynchronously and returns them as one string. (Inherited from TextReader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Using a PdfTextReader (C#)
Copy
public String ReadTextFromPages(Stream s, int pageStart, int pageEnd)
{
    using (PdfTextDocument doc = new PdfTextDocument(s))
    {
        PdfTextReader rdr = doc.GetPdfTextReader(pageStart, pageEnd);
        return rdr.ReadToEnd();
    }
}
Using a PdfTextReader (Visual Basic)
Copy
Public Function ReadTextFromPages(ByVal s As Stream, ByVal pageStart As Integer, ByVal pageEnd As Integer) As String
    Using doc As New PdfTextDocument(s)
        Dim rdr As PdfTextReader = doc.GetPdfTextReader(pageStart, pageEnd)
        Return rdr.ReadToEnd()
    End Using
End Function
See Also

Reference

Atalasoft.Pdf.TextExtract Namespace


PdfTextReader Properties

The PdfTextReader type exposes the following members.

Properties
 | Name | Description
Public property | OutputLineEnd | Gets or sets a flag indicating whether Read(Char, Int32, Int32) and Peek methods should return line end symbols.
Public property | OutputPageEnd | Gets or sets a flag indicating whether Read(Char, Int32, Int32) and Peek methods should return page end symbol.
Top
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.OutputLineEnd Property

PdfTextReaderOutputLineEnd Property

Gets or sets a flag indicating whether Read(Char, Int32, Int32) and Peek methods should return line end symbols.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OutputLineEnd { get; set; }
Public Property OutputLineEnd As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.OutputPageEnd Property

PdfTextReaderOutputPageEnd Property

Gets or sets a flag indicating whether Read(Char, Int32, Int32) and Peek methods should return page end symbol.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool OutputPageEnd { get; set; }
Public Property OutputPageEnd As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader Methods

The PdfTextReader type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the TextReader and releases any system resources associated with the TextReader. (Inherited from TextReader.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | (Overrides TextReaderDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Reads the next character without changing the state of the reader or the character source. Returns the next available character without actually reading it from the reader. (Overrides TextReaderPeek.)
Public method | Read | Reads the next character from the text reader and advances the character position by one character. (Overrides TextReaderRead.)
Public method | Read(Char, Int32, Int32) | Reads a specified maximum number of characters from the current reader and writes the data to a buffer, beginning at the specified index. (Overrides TextReaderRead(Char, Int32, Int32).)
Public method | ReadAsync | Reads a specified maximum number of characters from the current text reader asynchronously and writes the data to a buffer, beginning at the specified index. (Inherited from TextReader.)
Public method | ReadBlock | Reads a specified maximum number of characters from the current text reader and writes the data to a buffer, beginning at the specified index. (Inherited from TextReader.)
Public method | ReadBlockAsync | Reads a specified maximum number of characters from the current text reader asynchronously and writes the data to a buffer, beginning at the specified index. (Inherited from TextReader.)
Public method | ReadLine | Reads a line of characters from the text reader and returns the data as a string. (Overrides TextReaderReadLine.)
Public method | ReadLineAsync | Reads a line of characters asynchronously and returns the data as a string. (Inherited from TextReader.)
Public method | ReadToEnd | Reads all characters from the current position to the end of the text reader and returns them as one string. (Inherited from TextReader.)
Public method | ReadToEndAsync | Reads all characters from the current position to the end of the text reader asynchronously and returns them as one string. (Inherited from TextReader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.Dispose Method

PdfTextReaderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfTextReader and optionally releases the managed resources (Overrides TextReaderDispose(Boolean).)
Top
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.Dispose Method (Boolean)

PdfTextReaderDispose Method (Boolean)

Releases the unmanaged resources used by the PdfTextReader and optionally releases the managed resources

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool A_0
)
Protected Overrides Sub Dispose (
    A_0 As Boolean
)

Parameters

A_0
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfTextReader Class
Dispose Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.Peek Method

PdfTextReaderPeek Method

Reads the next character without changing the state of the reader or the character source. Returns the next available character without actually reading it from the reader.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int Peek()
Public Overrides Function Peek As Integer

Return Value

Type: Int32
An integer representing the next character to be read, or -1 if no more characters are available or the reader does not support seeking.
Exceptions
Exception | Condition
ObjectDisposedException | The TextReader is closed.
IOException | An I/O error occurs.
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.Read Method

PdfTextReaderRead Method

Overload List
 | Name | Description
Public method | Read | Reads the next character from the text reader and advances the character position by one character. (Overrides TextReaderRead.)
Public method | Read(Char, Int32, Int32) | Reads a specified maximum number of characters from the current reader and writes the data to a buffer, beginning at the specified index. (Overrides TextReaderRead(Char, Int32, Int32).)
Top
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.Read Method

PdfTextReaderRead Method

Reads the next character from the text reader and advances the character position by one character.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int Read()
Public Overrides Function Read As Integer

Return Value

Type: Int32
The next character from the text reader, or -1 if no more characters are available. The default implementation returns -1.
Exceptions
Exception | Condition
ObjectDisposedException | The TextReader is closed.
IOException | An I/O error occurs.
See Also

Reference

PdfTextReader Class
Read Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.Read Method (Char[], Int32, Int32)

PdfTextReaderRead Method (Char, Int32, Int32)

Reads a specified maximum number of characters from the current reader and writes the data to a buffer, beginning at the specified index.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int Read(
    char[] buffer,
    int index,
    int count
)
Public Overrides Function Read (
    buffer As Char(),
    index As Integer,
    count As Integer
) As Integer

Parameters

buffer
Type: SystemChar
When this method returns, contains the specified character array with the values between index and (index + count - 1) replaced by the characters read from the current source.
index
Type: SystemInt32
The position in buffer at which to begin writing.
count
Type: SystemInt32
The maximum number of characters to read. If the end of the reader is reached before the specified number of characters is read into the buffer, the method returns.

Return Value

Type: Int32
The number of characters that have been read. The number will be less than or equal to count, depending on whether the data is available within the reader. This method returns 0 (zero) if it is called when no more characters are left to read.
Exceptions
Exception | Condition
ArgumentNullException | Throws when buffer is a .
ArgumentException | Throws when the buffer length minus index is less than count.
ArgumentOutOfRangeException | Throws when index or count is negative.
ObjectDisposedException | Throws when the PdfTextReader is closed.
IOException | Throws when an I/O error occurs.
See Also

Reference

PdfTextReader Class
Read Overload
Atalasoft.Pdf.TextExtract Namespace


PdfTextReader.ReadLine Method

PdfTextReaderReadLine Method

Reads a line of characters from the text reader and returns the data as a string.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ReadLine()
Public Overrides Function ReadLine As String

Return Value

Type: String
The next line from the reader, or null if all characters have been read.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
OutOfMemoryException | There is insufficient memory to allocate a buffer for the returned string.
ObjectDisposedException | The TextReader is closed.
ArgumentOutOfRangeException | The number of characters in the next line is larger than MaxValue
See Also

Reference

PdfTextReader Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextSegment Class

Represents a text segment of PDF page.
Inheritance Hierarchy
SystemObject
Atalasoft.Pdf.TextExtractPdfTextSegment

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTextSegment
Public Class PdfTextSegment

The PdfTextSegment type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets a length of a segment.
Public property | Index | Gets a index in page char array where segment is started.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Pdf.TextExtract Namespace


PdfTextSegment Properties

The PdfTextSegment type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets a length of a segment.
Public property | Index | Gets a index in page char array where segment is started.
Top
See Also

Reference

PdfTextSegment Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextSegment.Count Property

PdfTextSegmentCount Property

Gets a length of a segment.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfTextSegment Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextSegment.Index Property

PdfTextSegmentIndex Property

Gets a index in page char array where segment is started.

Namespace: Atalasoft.Pdf.TextExtract
Assembly: Atalasoft.dotImage.PdfReader (in Atalasoft.dotImage.PdfReader.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfTextSegment Class
Atalasoft.Pdf.TextExtract Namespace


PdfTextSegment Methods

The PdfTextSegment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextSegment Class
Atalasoft.Pdf.TextExtract Namespace


Atalasoft.PdfDoc Namespace

Classes
Class | Description
Public class BasePage
An empty class which represents any page in a document. Use concrete page implementations like PdfGeneratedPage or PdfPage.
Public class DpcmToPdfCoordinateConverter
This class converts coordinates from conventional image space (values measured in Dots Per cm (Pixels Per cm) with the origin in the upper left corner and X and Y extending to the right and down respectively) to PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively).
Public class DpiToPdfCoordinateConverter
This class converts coordinates from conventional image space (values measured in Dots Per Inch (Pixels Per Inch) with the origin in the upper left corner and X and Y extending to the right and down respectively) to PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively).
Public class IncorrectPasswordException
This exception is thrown when a PdfDocument is opened with an incorrect password.
Public class | ObjectCannotBeSavedEventArg
Public class PdfAction
PdfAction is an abstract class that represents an action that will be taken when certain items in PDF documents have been activated.
Public class PdfActionList
PdfActionList is a list of PdfAction objects that will be associated as a sequence.
Public class PdfAException Obsolete.
An exception from DotPdf
Public class PdfBookmark
PdfBookmark is a representation of a single bookmark in the document outline of a PDF document.
Public class PdfBookmarkList
PdfBookmarkList is a list of bookmarks contained within the document outline of a PDF document.
Public class PdfBookmarkResult
PdfBookmarkResult is an immutable class that it used for holding the results of visiting a PdfBookmarkTree using the PdfBookmarkVisitor
Public class PdfBookmarkTree
PdfBookmarkTree is a tree structure representing the entire document outline of a PDF document.
PdfBookmarkVisitor
PdfBookmarkVisitor is a utility class that can be used to visit each PdfBookmark contained in a PdfBookmarkTree. The tree can be visited either depth first or breadth first. The order of node visit in either breadth or depth first is undefined and subject to change.
Examples
Print each element in the tree in breadth first order.
Copy
foreach (PdfBookmarkResult result in new PdfBookmarkVisitor(tree, false)) {
    Console.WriteLine(result.Bookmark.Text);
}
Public class PdfCoordinateConverter
PdfCoordinateConverter is a base class for performing unit conversions to and from PDF coordinate space using an affine matrix transformation.
Public class PdfDestination
PdfDestination is an abstract class that represents a possible target location for a "go to" action.
Public class PdfDocument
PdfDocument is a representation of a PDF document and the pages and other structures contained therein.
Public class PdfDocumentMetadata
PdfDocumentMetadata represents standard PDF metadata including title, subject, author and so on.
Public class PdfException
An exception from DotPdf
Public class PdfGoToViewAction
PdfGoToViewAction is a concrete class that represents an action that causes a PDF viewer to go to a specific view within a document.
Public class PdfIndexedPageReference
PdfIndexedPageReference is low-overhead class that represents a PDF page by its 0-based page number.
Public class PdfJavaScriptAction
PdfJavaScriptAction represents an action taken that will cause JavaScript code to be executed.
Public class PdfPage
PdfPage is a class that represents a single page within a PDF Document.
Public class PdfPageReference
PdfPageReference is an abstract class that is used to refer to pages within a PDF document.
Public class PdfParseException
An exception from DotPdf
Public class PdfSaveOptions
The options for saving a pdf document.
Public class PdfToDpcmCoordinateConverter
This class converts coordinates from PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively) to conventional image space (values measured in Dots Per cm (Pixels Per cm) with the origin in the upper left corner and X and Y extending to the right and down respectively).
Public class PdfToDpiCoordinateConverter
This class converts coordinates from PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively) to conventional image space (values measured in Dots Per inch (Pixels Per inch) with the origin in the upper left corner and X and Y extending to the right and down respectively).
Public class PdfUnknownAction
PdfUnknownAction is a concrete representation of PdfActions that do not map to any other concrete PdfAction class.
Public class PdfURIAction
An action that pdf documents can be made to take upon load
Public class PdfViewerPreferences
PdfViewerPreferences represents document-specific preferences that are applied to the document viewer. It should be noted that not all PDF viewers will honor all settings and the behaviors may not be consistent across viewers.
Delegates
 | Delegate | Description
 | PdfBookmarkVisitorPredicate | A predicate that is used determine if a PdfBookmark should be included in the results of visiting a PdfBookmarkTree.
Public delegate | PdfDocumentLoadedProgress | A delegate that will be called when a page has been loaded in the document.
Public delegate | PdfFileCreator | The event delegate for file creation.
Public delegate | PdfPageSavedHandler | The delegate which is called when a single-page document is saved and the corresponding stream is about to be closed.
Public delegate | PdfStreamCreator | The delegate for PdfStream creation events.
Enumerations
 | Enumeration | Description
Public enumeration | ObjectCannotBeSavedEventArgSaveObjectAction |
Public enumeration | PdfAccessPermissions | PdfAccessPermissions refer to permissions that are allowed within a PDF document. Permissions are granted by allowing actions rather than preventing them.
Public enumeration | PdfActionType | Possible actions that can be represented in a PDF document
Public enumeration | PdfDocumentType | Controls the type of PDF Document generated.
Public enumeration | PdfImageCodec | An enum to represnet which codec is used to compress an image resource
Public enumeration | PdfImageColorSpace | An enum representing the color space types as their channel designations
Public enumeration | PdfPageBox | The set of names of bounding boxes that define view/scale areas.
Public enumeration | PdfPageDisplayMode | Defines an additional view to be displayed with a PDF page in a viewer.
Public enumeration | PdfPageFitMode | Describes view modes for a document
Public enumeration | PdfPageReferenceType | Defines the possible types of page references
Public enumeration | PdfPageRotation | An enum representing possible rotations of a PDF page for display. Several of the values overlap for convenience. For example, Clockwise180 and CounterClockwise180 are identical.
Public enumeration | PdfPostFullScreenPageDisplayMode | Defines the additional views that should be present when a user switches a document from full-screen view to a windowed view.
Public enumeration | PdfPrintingMode | Defines how single/multi-sided printing is done.
Public enumeration | PdfReadingOrder | Defines the dominant reading order for a document. This will affect how pages are displayed in a multi-page view as well as the tab order for annotations on a page.
Public enumeration | PdfTabOrder | Defines the order in with annotations should be navigated on a page.
Public enumeration | PdfTrapSetting | An enumeration used to indicate the trapping information in the document.


BasePage Class

An empty class which represents any page in a document. Use concrete page implementations like PdfGeneratedPage or PdfPage.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocBasePage
Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
Atalasoft.PdfDocPdfPage

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasePage
Public Class BasePage

The BasePage type exposes the following members.

Constructors
 | Name | Description
Protected method | BasePage | Initializes a new instance of the BasePage class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


BasePage Constructor

Initializes a new instance of the BasePage class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BasePage()
Protected Sub New
See Also

Reference

BasePage Class
Atalasoft.PdfDoc Namespace


BasePage Methods

The BasePage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasePage Class
Atalasoft.PdfDoc Namespace


DpcmToPdfCoordinateConverter Class

This class converts coordinates from conventional image space (values measured in Dots Per cm (Pixels Per cm) with the origin in the upper left corner and X and Y extending to the right and down respectively) to PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively).
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfCoordinateConverter
Atalasoft.PdfDocDpiToPdfCoordinateConverter
Atalasoft.PdfDocDpcmToPdfCoordinateConverter

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DpcmToPdfCoordinateConverter : DpiToPdfCoordinateConverter
Public Class DpcmToPdfCoordinateConverter
    Inherits DpiToPdfCoordinateConverter

The DpcmToPdfCoordinateConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DpcmToPdfCoordinateConverter(Double, Size) | Constructs a new converter object with the specified resolution in dots per cm and the specified page size in pixels.
Public method | DpcmToPdfCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified resolution in dots per cm and the specified page size in pixels.
Top
Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


DpcmToPdfCoordinateConverter Constructor

Constructs a new converter from dots per cm to PDF page units.
Constructs a new converter from dots per cm to PDF page units.
Overload List
 | Name | Description
Public method | DpcmToPdfCoordinateConverter(Double, Size) | Constructs a new converter object with the specified resolution in dots per cm and the specified page size in pixels.
Public method | DpcmToPdfCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified resolution in dots per cm and the specified page size in pixels.
Top
See Also

Reference

DpcmToPdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


DpcmToPdfCoordinateConverter Constructor (Double, Size)

Constructs a new converter object with the specified resolution in dots per cm and the specified page size in pixels.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DpcmToPdfCoordinateConverter(
    double dpcm,
    Size pageSize
)
Public Sub New (
    dpcm As Double,
    pageSize As Size
)

Parameters

dpcm
Type: SystemDouble
The resolution of the source space in pixels or dots per cm.
pageSize
Type: System.DrawingSize
The size of the source space in pixels
See Also

Reference

DpcmToPdfCoordinateConverter Class
DpcmToPdfCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


DpcmToPdfCoordinateConverter Constructor (Double, SizeF)

Constructs a new converter object with the specified resolution in dots per cm and the specified page size in pixels.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DpcmToPdfCoordinateConverter(
    double dpcm,
    SizeF pageSize
)
Public Sub New (
    dpcm As Double,
    pageSize As SizeF
)

Parameters

dpcm
Type: SystemDouble
The resolution of the source space in pixels or dots per cm.
pageSize
Type: System.DrawingSizeF
The size of the source space in pixels
See Also

Reference

DpcmToPdfCoordinateConverter Class
DpcmToPdfCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


DpcmToPdfCoordinateConverter Methods

The DpcmToPdfCoordinateConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DpcmToPdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


DpiToPdfCoordinateConverter Class

This class converts coordinates from conventional image space (values measured in Dots Per Inch (Pixels Per Inch) with the origin in the upper left corner and X and Y extending to the right and down respectively) to PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively).
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfCoordinateConverter
Atalasoft.PdfDocDpiToPdfCoordinateConverter
Atalasoft.PdfDocDpcmToPdfCoordinateConverter

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DpiToPdfCoordinateConverter : PdfCoordinateConverter
Public Class DpiToPdfCoordinateConverter
    Inherits PdfCoordinateConverter

The DpiToPdfCoordinateConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DpiToPdfCoordinateConverter(Double, Size) | Constructs a new converter object with the specified resolution in dots per inch and the specified page size in pixels.
Public method | DpiToPdfCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified resolution in dots per inch and the specified page size in pixels.
Top
Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


DpiToPdfCoordinateConverter Constructor

Constructs a new converter from dots per inch to PDF page units.
Constructs a new converter from dots per inch to PDF page units.
Overload List
 | Name | Description
Public method | DpiToPdfCoordinateConverter(Double, Size) | Constructs a new converter object with the specified resolution in dots per inch and the specified page size in pixels.
Public method | DpiToPdfCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified resolution in dots per inch and the specified page size in pixels.
Top
See Also

Reference

DpiToPdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


DpiToPdfCoordinateConverter Constructor (Double, Size)

Constructs a new converter object with the specified resolution in dots per inch and the specified page size in pixels.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DpiToPdfCoordinateConverter(
    double dpi,
    Size pageSize
)
Public Sub New (
    dpi As Double,
    pageSize As Size
)

Parameters

dpi
Type: SystemDouble
The resolution of the source space in pixels or dots per inch.
pageSize
Type: System.DrawingSize
The size of the source space in pixels
See Also

Reference

DpiToPdfCoordinateConverter Class
DpiToPdfCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


DpiToPdfCoordinateConverter Constructor (Double, SizeF)

Constructs a new converter object with the specified resolution in dots per inch and the specified page size in pixels.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DpiToPdfCoordinateConverter(
    double dpi,
    SizeF pageSize
)
Public Sub New (
    dpi As Double,
    pageSize As SizeF
)

Parameters

dpi
Type: SystemDouble
The resolution of the source space in pixels or dots per inch.
pageSize
Type: System.DrawingSizeF
The size of the source space in pixels
See Also

Reference

DpiToPdfCoordinateConverter Class
DpiToPdfCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


DpiToPdfCoordinateConverter Methods

The DpiToPdfCoordinateConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DpiToPdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Class

This exception is thrown when a PdfDocument is opened with an incorrect password.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocIncorrectPasswordException

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class IncorrectPasswordException : Exception
Public Class IncorrectPasswordException
    Inherits Exception

The IncorrectPasswordException type exposes the following members.

Constructors
 | Name | Description
Public method | IncorrectPasswordException | Construct a new IncorrectPasswordException object with no message.
Public method | IncorrectPasswordException(String) | Construct a new IncorrectPasswordException object with the specified message.
Public method | IncorrectPasswordException(String, Exception) | Construct a new IncorrectPasswordException object with the specified message and inner exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


IncorrectPasswordException Constructor

Construct a new IncorrectPasswordException object from the specified paramaters.
Construct a new IncorrectPasswordException object from the specified paramaters.
Construct a new IncorrectPasswordException object from the specified paramaters.
Overload List
 | Name | Description
Public method | IncorrectPasswordException | Construct a new IncorrectPasswordException object with no message.
Public method | IncorrectPasswordException(String) | Construct a new IncorrectPasswordException object with the specified message.
Public method | IncorrectPasswordException(String, Exception) | Construct a new IncorrectPasswordException object with the specified message and inner exception.
Top
See Also

Reference

IncorrectPasswordException Class
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Constructor

Construct a new IncorrectPasswordException object with no message.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IncorrectPasswordException()
Public Sub New
See Also

Reference

IncorrectPasswordException Class
IncorrectPasswordException Overload
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Constructor (String)

Construct a new IncorrectPasswordException object with the specified message.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IncorrectPasswordException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

IncorrectPasswordException Class
IncorrectPasswordException Overload
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Constructor (String, Exception)

Construct a new IncorrectPasswordException object with the specified message and inner exception.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IncorrectPasswordException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

IncorrectPasswordException Class
IncorrectPasswordException Overload
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Properties

The IncorrectPasswordException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

IncorrectPasswordException Class
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Methods

The IncorrectPasswordException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

IncorrectPasswordException Class
Atalasoft.PdfDoc Namespace


IncorrectPasswordException Events

The IncorrectPasswordException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

IncorrectPasswordException Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.PdfDocObjectCannotBeSavedEventArg

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ObjectCannotBeSavedEventArg : EventArgs
Public Class ObjectCannotBeSavedEventArg
    Inherits EventArgs

The ObjectCannotBeSavedEventArg type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectCannotBeSavedEventArg | Initializes a new instance of the ObjectCannotBeSavedEventArg class
Top
Properties
 | Name | Description
Public property | Action | Gets or sets flag, that determines skip the object that cannot be saved or throw PdfException Default value: ThrowException
Public property | ObjectType |
Public property | Reason |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg Constructor

Initializes a new instance of the ObjectCannotBeSavedEventArg class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ObjectCannotBeSavedEventArg(
    string objectType,
    string reason
)
Public Sub New (
    objectType As String,
    reason As String
)

Parameters

objectType
Type: SystemString
reason
Type: SystemString
See Also

Reference

ObjectCannotBeSavedEventArg Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg Properties

The ObjectCannotBeSavedEventArg type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets or sets flag, that determines skip the object that cannot be saved or throw PdfException Default value: ThrowException
Public property | ObjectType |
Public property | Reason |
Top
See Also

Reference

ObjectCannotBeSavedEventArg Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg.Action Property

ObjectCannotBeSavedEventArgAction Property

Gets or sets flag, that determines skip the object that cannot be saved or throw PdfException Default value: ThrowException

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ObjectCannotBeSavedEventArgSaveObjectAction Action { get; set; }
Public Property Action As ObjectCannotBeSavedEventArgSaveObjectAction
    Get
    Set

Property Value

Type: ObjectCannotBeSavedEventArgSaveObjectAction
See Also

Reference

ObjectCannotBeSavedEventArg Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg.ObjectType Property

ObjectCannotBeSavedEventArgObjectType Property

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ObjectType { get; }
Public ReadOnly Property ObjectType As String
    Get

Property Value

Type: String
See Also

Reference

ObjectCannotBeSavedEventArg Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg.Reason Property

ObjectCannotBeSavedEventArgReason Property

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Reason { get; }
Public ReadOnly Property Reason As String
    Get

Property Value

Type: String
See Also

Reference

ObjectCannotBeSavedEventArg Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg Methods

The ObjectCannotBeSavedEventArg type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObjectCannotBeSavedEventArg Class
Atalasoft.PdfDoc Namespace


ObjectCannotBeSavedEventArg.SaveObjectAction Enumeration

ObjectCannotBeSavedEventArgSaveObjectAction Enumeration

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SaveObjectAction
Public Enumeration SaveObjectAction
Members
Member name | Description
ThrowException |
Skip |
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfAccessPermissions Enumeration

PdfAccessPermissions refer to permissions that are allowed within a PDF document. Permissions are granted by allowing actions rather than preventing them.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum PdfAccessPermissions
<FlagsAttribute>
Public Enumeration PdfAccessPermissions
Members
Member name | Description
None | None
Print | Allows printing of the document
Modify | Allows modifications to the document
CopyTextAndGraphics | Allows text and graphics to be copied from the document
ModifyAnnotationsOrFields | Allows annotations and fields to be modified
FillFields | Allows form fields to be filled in
AccessibilityExtractTextAndGraphics | Allows text and graphics extraction for users with disabilities
AssembleDocument | Allow the insertion, rotation, or deletion of pages and creation of bookmarks and thumbnail images.
PrintHighQuality | Allows the highest possible quality printing of the document possible on the output device.
Default | A set of typical default permissions for a document. This includes the previous permissions.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfAction Class

PdfAction is an abstract class that represents an action that will be taken when certain items in PDF documents have been activated.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
More...

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class PdfAction : IValidatable
<SerializableAttribute>
Public MustInherit Class PdfAction
    Implements IValidatable

The PdfAction type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfAction | Initializes a new instance of the PdfAction class
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
Remarks
PdfAction is an abstract class with internal abstract members. Client code is not meant to make subclasses of PdfAction.
See Also

Reference

Atalasoft.PdfDoc Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDoc.ActionsPdfNamedAction
Atalasoft.PdfDoc.ActionsPdfResetFormAction
Atalasoft.PdfDoc.ActionsPdfShowHideAction
Atalasoft.PdfDoc.ActionsPdfSoundAction
Atalasoft.PdfDoc.ActionsPdfSubmitFormAction
Atalasoft.PdfDocPdfGoToViewAction
Atalasoft.PdfDocPdfJavaScriptAction
Atalasoft.PdfDocPdfUnknownAction
Atalasoft.PdfDocPdfURIAction


PdfAction Constructor

Initializes a new instance of the PdfAction class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAction()
Protected Sub New
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfAction Properties

The PdfAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object
Top
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfAction.ActionType Property

PdfActionActionType Property

Gets the type of the action represented by this object

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract PdfActionType ActionType { get; }
Public MustOverride ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfAction Methods

The PdfAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfAction.LLValidate Method

PdfActionLLValidate Method

Low-level validation. Not for use by client code

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLValidate(
    ProblemList problems,
    RepairContext repairContext
)
Protected Overridable Sub LLValidate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems so far.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfAction.MakeRepairContext Method

PdfActionMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
Exceptions
Exception | Condition
ArgumentNullException | o
ArgumentException | expected an ActionRepairContext, but got a + o.GetType().Name
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfAction.Validate Method

PdfActionValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

PdfAction Class
Atalasoft.PdfDoc Namespace


PdfActionList Class

PdfActionList is a list of PdfAction objects that will be associated as a sequence.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListPdfAction
Atalasoft.PdfDocPdfActionList

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfActionList : List<PdfAction>,
    IValidatable
<SerializableAttribute>
Public Class PdfActionList
    Inherits List(Of PdfAction)
    Implements IValidatable

The PdfActionList type exposes the following members.

Constructors
 | Name | Description
Public method | PdfActionList | Initializes a new instance of the PdfActionList class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfAction .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfAction .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfAction .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfAction .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfAction .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfAction .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfAction .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfAction .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfAction .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfAction .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfAction .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfAction .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfAction .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfAction .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfAction .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfAction .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfAction .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfAction .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfAction .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfAction .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfAction .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfAction .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfAction .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfAction .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfAction .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfAction .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfAction .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfAction .)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfAction .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfAction .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfAction .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfAction .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfAction .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfAction .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfAction .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfAction .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfAction .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfAction .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfAction .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfActionList Constructor

Initializes a new instance of the PdfActionList class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList()
Public Sub New
See Also

Reference

PdfActionList Class
Atalasoft.PdfDoc Namespace


PdfActionList Properties

The PdfActionList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfAction .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfAction .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfAction .)
Top
See Also

Reference

PdfActionList Class
Atalasoft.PdfDoc Namespace


PdfActionList Methods

The PdfActionList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfAction .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfAction .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfAction .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfAction .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfAction .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfAction .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfAction .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfAction .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfAction .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfAction .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfAction .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfAction .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfAction .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfAction .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfAction .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfAction .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfAction .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfAction .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfAction .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfAction .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfAction .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfAction .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfAction .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfAction .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfAction .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfAction .)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfAction .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfAction .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfAction .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfAction .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfAction .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfAction .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfAction .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfAction .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfAction .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfAction .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfAction .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfAction .)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PdfActionList Class
Atalasoft.PdfDoc Namespace


PdfActionList.MakeRepairContext Method

PdfActionListMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
Exceptions
Exception | Condition
ArgumentNullException | o
ArgumentException | Expected a DocRepairContext or a document but got + o.GetType().Name
See Also

Reference

PdfActionList Class
Atalasoft.PdfDoc Namespace


PdfActionList.Validate Method

PdfActionListValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

PdfActionList Class
Atalasoft.PdfDoc Namespace


PdfActionType Enumeration

Possible actions that can be represented in a PDF document

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfActionType
Public Enumeration PdfActionType
Members
Member name | Description
GoToView | Change the current view of a document to the specified view.
GoToRemote | Go to a view in another document.
GoToEmbedded | Go to a view in an embedded document
LaunchApplication | Launch an application
ReadThread | Go to a particular article thread
FollowURI | Go to the destination specified by a URI
PlaySound | Play a sound
PlayMovie | Play a movie
Hide | Hide an annotation
PerformNamedAction | Perform an action or a sequence of actions specified by name
SubmitForm | Submit form data for processing
ResetForm | Reset form state to its default
ImportData | Import data into a form
JavaScript | Execute embedded javascript
SetOCGState | Sets the state of an optional content group (OCG)
Rendition | Controls the playing of multimedia content
PerformTransition | Sets the mechanism of changing the view of one page to another
GoTo3DView | Go to a specific view in a 3D model
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfAException Class

Note: This API is now obsolete.

An exception from DotPdf
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDocPdfAException

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute("Please use PdfAException from Atalasoft.PdfDoc.PdfA namespace.",
    false)]
public class PdfAException : PdfException
<SerializableAttribute>
<ObsoleteAttribute("Please use PdfAException from Atalasoft.PdfDoc.PdfA namespace.",
    false)>
Public Class PdfAException
    Inherits PdfException

The PdfAException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAException | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String) | Initializes a new instance of the PdfAException class.
Protected method | PdfAException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String, Exception) | Initializes a new instance of the PdfAException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfAException Constructor

Overload List
 | Name | Description
Public method | PdfAException | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String) | Initializes a new instance of the PdfAException class.
Protected method | PdfAException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String, Exception) | Initializes a new instance of the PdfAException class.
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc Namespace


PdfAException Constructor

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAException()
Public Sub New
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc Namespace


PdfAException Constructor (String)

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc Namespace


PdfAException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc Namespace


PdfAException Constructor (String, Exception)

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc Namespace


PdfAException Properties

The PdfAException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc Namespace


PdfAException Methods

The PdfAException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc Namespace


PdfAException Events

The PdfAException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc Namespace


PdfBookmark Class

PdfBookmark is a representation of a single bookmark in the document outline of a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfBookmark

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfBookmark : IValidatable
Public Class PdfBookmark
    Implements IValidatable

The PdfBookmark type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBookmark | Constructs a new default PdfBookmark object
Public method | PdfBookmark(String, PdfAction) | Constructs a new PdfBookmark object with the specified text and action
Public method | PdfBookmark(String, Color, FontStyle, PdfAction, Boolean) | Constructs a new PdfBookmark object with the specified text, color, style, action, and open/closed state
Top
Properties
 | Name | Description
Public property | Children | Gets a list of bookmarks that are children to this bookmark.
Public property | ClickAction | Gets a list of actions that will be performed when a user clicks the bookmark
Public property | Color | Sets or gets the color of the bookmark
Public property | IsOpen | Sets or gets the open/closed state of the bookmark
Public property | Style | Sets or gets the FontStyle of the bookmark
Public property | Text | Sets or gets the text for the bookmark
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfBookmark Constructor

Constucts a new PdfBookmark object
Constucts a new PdfBookmark object
Constucts a new PdfBookmark object
Overload List
 | Name | Description
Public method | PdfBookmark | Constructs a new default PdfBookmark object
Public method | PdfBookmark(String, PdfAction) | Constructs a new PdfBookmark object with the specified text and action
Public method | PdfBookmark(String, Color, FontStyle, PdfAction, Boolean) | Constructs a new PdfBookmark object with the specified text, color, style, action, and open/closed state
Top
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark Constructor

Constructs a new default PdfBookmark object

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmark()
Public Sub New
See Also

Reference

PdfBookmark Class
PdfBookmark Overload
Atalasoft.PdfDoc Namespace


PdfBookmark Constructor (String, PdfAction)

Constructs a new PdfBookmark object with the specified text and action

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmark(
    string text,
    PdfAction action
)
Public Sub New (
    text As String,
    action As PdfAction
)

Parameters

text
Type: SystemString
The text for the bookmark
action
Type: Atalasoft.PdfDocPdfAction
An action to perform when the bookmark is clicked
See Also

Reference

PdfBookmark Class
PdfBookmark Overload
Atalasoft.PdfDoc Namespace


PdfBookmark Constructor (String, Color, FontStyle, PdfAction, Boolean)

Constructs a new PdfBookmark object with the specified text, color, style, action, and open/closed state

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmark(
    string text,
    Color color,
    FontStyle style,
    PdfAction action,
    bool isOpen
)
Public Sub New (
    text As String,
    color As Color,
    style As FontStyle,
    action As PdfAction,
    isOpen As Boolean
)

Parameters

text
Type: SystemString
The text for the bookmark
color
Type: System.DrawingColor
The color of the bookmark
style
Type: System.DrawingFontStyle
The FontStyle for the bookmark
action
Type: Atalasoft.PdfDocPdfAction
An action to perform when the bookmark is clicked
isOpen
Type: SystemBoolean
Indicates whether or not children of this bookmark will be initially visible to the user
See Also

Reference

PdfBookmark Class
PdfBookmark Overload
Atalasoft.PdfDoc Namespace


PdfBookmark Properties

The PdfBookmark type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets a list of bookmarks that are children to this bookmark.
Public property | ClickAction | Gets a list of actions that will be performed when a user clicks the bookmark
Public property | Color | Sets or gets the color of the bookmark
Public property | IsOpen | Sets or gets the open/closed state of the bookmark
Public property | Style | Sets or gets the FontStyle of the bookmark
Public property | Text | Sets or gets the text for the bookmark
Top
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.Children Property

PdfBookmarkChildren Property

Gets a list of bookmarks that are children to this bookmark.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkList Children { get; }
Public ReadOnly Property Children As PdfBookmarkList
    Get

Property Value

Type: PdfBookmarkList
A list bookmarks that are the children of this bookmark
Remarks
While it is possible to build bookmarks with cycles (elements of the Children collection are contained elsewhere in the bookmark tree), this is an error and may generate a damaged PDF.
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.ClickAction Property

PdfBookmarkClickAction Property

Gets a list of actions that will be performed when a user clicks the bookmark

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList ClickAction { get; }
Public ReadOnly Property ClickAction As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.Color Property

PdfBookmarkColor Property

Sets or gets the color of the bookmark

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.IsOpen Property

PdfBookmarkIsOpen Property

Sets or gets the open/closed state of the bookmark

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
This property only has an effect in the final PDF if the Children collection has one or more entry.
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.Style Property

PdfBookmarkStyle Property

Sets or gets the FontStyle of the bookmark

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontStyle Style { get; set; }
Public Property Style As FontStyle
    Get
    Set

Property Value

Type: FontStyle
Remarks
PDF only supports bookmarks with the styles Bold, Italic or Bold and Italic.
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.Text Property

PdfBookmarkText Property

Sets or gets the text for the bookmark

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark Methods

The PdfBookmark type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.MakeRepairContext Method

PdfBookmarkMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmark.Validate Method

PdfBookmarkValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

PdfBookmark Class
Atalasoft.PdfDoc Namespace


PdfBookmarkList Class

PdfBookmarkList is a list of bookmarks contained within the document outline of a PDF document.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListPdfBookmark
Atalasoft.PdfDocPdfBookmarkList

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfBookmarkList : List<PdfBookmark>
Public Class PdfBookmarkList
    Inherits List(Of PdfBookmark)

The PdfBookmarkList type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBookmarkList | Initializes a new instance of the PdfBookmarkList class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfBookmark .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfBookmark .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfBookmark .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfBookmark .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfBookmark .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfBookmark .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfBookmark .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfBookmark .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfBookmark .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfBookmark .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfBookmark .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfBookmark .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfBookmark .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfBookmark .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfBookmark .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfBookmark .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfBookmark .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfBookmark .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfBookmark .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfBookmark .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfBookmark .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfBookmark .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfBookmark .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfBookmark .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfBookmark .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfBookmark .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfBookmark .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfBookmark .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfBookmark .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfBookmark .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfBookmark .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfBookmark .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfBookmark .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfBookmark .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfBookmark .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfBookmark .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfBookmark .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfBookmark .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfBookmark .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfBookmarkList Constructor

Initializes a new instance of the PdfBookmarkList class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkList()
Public Sub New
See Also

Reference

PdfBookmarkList Class
Atalasoft.PdfDoc Namespace


PdfBookmarkList Properties

The PdfBookmarkList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfBookmark .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfBookmark .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfBookmark .)
Top
See Also

Reference

PdfBookmarkList Class
Atalasoft.PdfDoc Namespace


PdfBookmarkList Methods

The PdfBookmarkList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfBookmark .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfBookmark .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfBookmark .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfBookmark .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfBookmark .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfBookmark .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfBookmark .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfBookmark .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfBookmark .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfBookmark .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfBookmark .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfBookmark .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfBookmark .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfBookmark .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfBookmark .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfBookmark .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfBookmark .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfBookmark .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfBookmark .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfBookmark .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfBookmark .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfBookmark .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfBookmark .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfBookmark .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfBookmark .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfBookmark .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfBookmark .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfBookmark .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfBookmark .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfBookmark .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfBookmark .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfBookmark .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfBookmark .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfBookmark .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfBookmark .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfBookmark .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfBookmark .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfBookmark .)
Top
See Also

Reference

PdfBookmarkList Class
Atalasoft.PdfDoc Namespace


PdfBookmarkResult Class

PdfBookmarkResult is an immutable class that it used for holding the results of visiting a PdfBookmarkTree using the PdfBookmarkVisitor
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfBookmarkResult

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfBookmarkResult
Public Class PdfBookmarkResult

The PdfBookmarkResult type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBookmarkResult | Initializes a new instance of the PdfBookmarkResult class.
Top
Properties
 | Name | Description
Public property | Bookmark | Gets the PdfBookmark associated with a node visited.
Public property | Parent | Gets the parent of the visited bookmark (if any)
Public property | ParentList | Gets the parent list which contains the visited bookmark.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfBookmarkResult Constructor

Initializes a new instance of the PdfBookmarkResult class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkResult(
    PdfBookmark bookmark,
    PdfBookmarkList parentList,
    PdfBookmark parent
)
Public Sub New (
    bookmark As PdfBookmark,
    parentList As PdfBookmarkList,
    parent As PdfBookmark
)

Parameters

bookmark
Type: Atalasoft.PdfDocPdfBookmark
The PdfBookmark that was visited.
parentList
Type: Atalasoft.PdfDocPdfBookmarkList
The parent list that contains the bookmark.
parent
Type: Atalasoft.PdfDocPdfBookmark
The parent bookmark that contains the bookmark as a child.
See Also

Reference

PdfBookmarkResult Class
Atalasoft.PdfDoc Namespace


PdfBookmarkResult Properties

The PdfBookmarkResult type exposes the following members.

Properties
 | Name | Description
Public property | Bookmark | Gets the PdfBookmark associated with a node visited.
Public property | Parent | Gets the parent of the visited bookmark (if any)
Public property | ParentList | Gets the parent list which contains the visited bookmark.
Top
See Also

Reference

PdfBookmarkResult Class
Atalasoft.PdfDoc Namespace


PdfBookmarkResult.Bookmark Property

PdfBookmarkResultBookmark Property

Gets the PdfBookmark associated with a node visited.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmark Bookmark { get; }
Public ReadOnly Property Bookmark As PdfBookmark
    Get

Property Value

Type: PdfBookmark
The PdfBookmark associated with a node visited.
See Also

Reference

PdfBookmarkResult Class
Atalasoft.PdfDoc Namespace


PdfBookmarkResult.Parent Property

PdfBookmarkResultParent Property

Gets the parent of the visited bookmark (if any)

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmark Parent { get; }
Public ReadOnly Property Parent As PdfBookmark
    Get

Property Value

Type: PdfBookmark
The parent of the visited bookmark.
See Also

Reference

PdfBookmarkResult Class
Atalasoft.PdfDoc Namespace


PdfBookmarkResult.ParentList Property

PdfBookmarkResultParentList Property

Gets the parent list which contains the visited bookmark.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkList ParentList { get; }
Public ReadOnly Property ParentList As PdfBookmarkList
    Get

Property Value

Type: PdfBookmarkList
The parent list which contains the visited bookmark.
See Also

Reference

PdfBookmarkResult Class
Atalasoft.PdfDoc Namespace


PdfBookmarkResult Methods

The PdfBookmarkResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfBookmarkResult Class
Atalasoft.PdfDoc Namespace


PdfBookmarkTree Class

PdfBookmarkTree is a tree structure representing the entire document outline of a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfBookmarkTree

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfBookmarkTree : IValidatable
Public Class PdfBookmarkTree
    Implements IValidatable

The PdfBookmarkTree type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBookmarkTree | Constructs a new, empty tree of PDF bookmarks
Top
Properties
 | Name | Description
Public property | Bookmarks | Gets the top-level list of bookmarks within a PDF document
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfBookmarkTree Constructor

Constructs a new, empty tree of PDF bookmarks

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkTree()
Public Sub New
See Also

Reference

PdfBookmarkTree Class
Atalasoft.PdfDoc Namespace


PdfBookmarkTree Properties

The PdfBookmarkTree type exposes the following members.

Properties
 | Name | Description
Public property | Bookmarks | Gets the top-level list of bookmarks within a PDF document
Top
See Also

Reference

PdfBookmarkTree Class
Atalasoft.PdfDoc Namespace


PdfBookmarkTree.Bookmarks Property

PdfBookmarkTreeBookmarks Property

Gets the top-level list of bookmarks within a PDF document

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkList Bookmarks { get; }
Public ReadOnly Property Bookmarks As PdfBookmarkList
    Get

Property Value

Type: PdfBookmarkList
See Also

Reference

PdfBookmarkTree Class
Atalasoft.PdfDoc Namespace


PdfBookmarkTree Methods

The PdfBookmarkTree type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PdfBookmarkTree Class
Atalasoft.PdfDoc Namespace


PdfBookmarkTree.MakeRepairContext Method

PdfBookmarkTreeMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

PdfBookmarkTree Class
Atalasoft.PdfDoc Namespace


PdfBookmarkTree.Validate Method

PdfBookmarkTreeValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

PdfBookmarkTree Class
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor Class

PdfBookmarkVisitor is a utility class that can be used to visit each PdfBookmark contained in a PdfBookmarkTree. The tree can be visited either depth first or breadth first. The order of node visit in either breadth or depth first is undefined and subject to change.
Examples
Print each element in the tree in breadth first order.
Copy
foreach (PdfBookmarkResult result in new PdfBookmarkVisitor(tree, false)) {
    Console.WriteLine(result.Bookmark.Text);
}
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfBookmarkVisitor

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfBookmarkVisitor : IEnumerable<PdfBookmarkResult>,
    IEnumerable
Public Class PdfBookmarkVisitor
    Implements IEnumerable(Of PdfBookmarkResult), IEnumerable

The PdfBookmarkVisitor type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBookmarkVisitor(PdfBookmarkTree, Boolean) | Initializes a new instance of the PdfBookmarkVisitor class.
Public method | PdfBookmarkVisitor(PdfBookmarkTree, Boolean, PdfBookmarkVisitorPredicate) | Initializes a new instance of the PdfBookmarkVisitor class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetParent | Gets the parent PdfBookmark of a given child PdfBookmark if any. Returns if the child has no parent or is not contained within the given tree.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor Constructor

Overload List
 | Name | Description
Public method | PdfBookmarkVisitor(PdfBookmarkTree, Boolean) | Initializes a new instance of the PdfBookmarkVisitor class.
Public method | PdfBookmarkVisitor(PdfBookmarkTree, Boolean, PdfBookmarkVisitorPredicate) | Initializes a new instance of the PdfBookmarkVisitor class.
Top
See Also

Reference

PdfBookmarkVisitor Class
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor Constructor (PdfBookmarkTree, Boolean)

Initializes a new instance of the PdfBookmarkVisitor class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkVisitor(
    PdfBookmarkTree tree,
    bool depthFirst
)
Public Sub New (
    tree As PdfBookmarkTree,
    depthFirst As Boolean
)

Parameters

tree
Type: Atalasoft.PdfDocPdfBookmarkTree
The PdfBookmarkTree to visit.
depthFirst
Type: SystemBoolean
if set to true visit the tree in depth-first order, otherwise search breatdth first.
See Also

Reference

PdfBookmarkVisitor Class
PdfBookmarkVisitor Overload
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor Constructor (PdfBookmarkTree, Boolean, PdfBookmarkVisitor.Predicate)

PdfBookmarkVisitor Constructor (PdfBookmarkTree, Boolean, PdfBookmarkVisitorPredicate)

Initializes a new instance of the PdfBookmarkVisitor class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkVisitor(
    PdfBookmarkTree tree,
    bool depthFirst,
    PdfBookmarkVisitorPredicate predicate
)
Public Sub New (
    tree As PdfBookmarkTree,
    depthFirst As Boolean,
    predicate As PdfBookmarkVisitorPredicate
)

Parameters

tree
Type: Atalasoft.PdfDocPdfBookmarkTree
The PdfBookmarkTree to visit.
depthFirst
Type: SystemBoolean
if set to true visit the tree in depth-first order, otherwise search breatdth first.
predicate
Type: Atalasoft.PdfDocPdfBookmarkVisitorPredicate
The predicate to determine if a PdfBookmark should be included in the results.
Exceptions
Exception | Condition
ArgumentNullException | tree
See Also

Reference

PdfBookmarkVisitor Class
PdfBookmarkVisitor Overload
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor Methods

The PdfBookmarkVisitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetParent | Gets the parent PdfBookmark of a given child PdfBookmark if any. Returns if the child has no parent or is not contained within the given tree.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfBookmarkVisitor Class
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor.GetEnumerator Method

PdfBookmarkVisitorGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<PdfBookmarkResult> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of PdfBookmarkResult)

Return Value

Type: IEnumeratorPdfBookmarkResult
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

PdfBookmarkVisitor Class
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor.GetParent Method

PdfBookmarkVisitorGetParent Method

Gets the parent PdfBookmark of a given child PdfBookmark if any. Returns if the child has no parent or is not contained within the given tree.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfBookmark GetParent(
    PdfBookmarkTree tree,
    PdfBookmark child
)
Public Shared Function GetParent (
    tree As PdfBookmarkTree,
    child As PdfBookmark
) As PdfBookmark

Parameters

tree
Type: Atalasoft.PdfDocPdfBookmarkTree
The bookmark tree.
child
Type: Atalasoft.PdfDocPdfBookmark
The child bookmark to search for.

Return Value

Type: PdfBookmark
Returns the parent PdfBookmark or .
See Also

Reference

PdfBookmarkVisitor Class
Atalasoft.PdfDoc Namespace


PdfBookmarkVisitor.Predicate Delegate

PdfBookmarkVisitorPredicate Delegate

A predicate that is used determine if a PdfBookmark should be included in the results of visiting a PdfBookmarkTree.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate bool Predicate(
    PdfBookmark mark
)
Public Delegate Function Predicate (
    mark As PdfBookmark
) As Boolean

Parameters

mark
Type: Atalasoft.PdfDocPdfBookmark
The bookmark.

Return Value

Type: Boolean
Copy
true
if the PdfBookmark should be included in the results,
Copy
false
otherwise
Examples
A predicate to return all PdfBookmark objects that have no action associated with them.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfCoordinateConverter Class

PdfCoordinateConverter is a base class for performing unit conversions to and from PDF coordinate space using an affine matrix transformation.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfCoordinateConverter
Atalasoft.PdfDocDpiToPdfCoordinateConverter
Atalasoft.PdfDocPdfToDpiCoordinateConverter

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCoordinateConverter
Public Class PdfCoordinateConverter

The PdfCoordinateConverter type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfCoordinateConverter | Initializes a new instance of the PdfCoordinateConverter class.
Top
Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class has an internal constructor and is not meant to be used directly by client code.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfCoordinateConverter Constructor

Initializes a new instance of the PdfCoordinateConverter class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfCoordinateConverter(
    double an,
    double ad,
    double bn,
    double bd,
    double cn,
    double cd,
    double dn,
    double dd,
    double e,
    double f
)
Protected Sub New (
    an As Double,
    ad As Double,
    bn As Double,
    bd As Double,
    cn As Double,
    cd As Double,
    dn As Double,
    dd As Double,
    e As Double,
    f As Double
)

Parameters

an
Type: SystemDouble
An.
ad
Type: SystemDouble
The ad.
bn
Type: SystemDouble
The bn.
bd
Type: SystemDouble
The bd.
cn
Type: SystemDouble
The cn.
cd
Type: SystemDouble
The cd.
dn
Type: SystemDouble
The dn.
dd
Type: SystemDouble
The dd.
e
Type: SystemDouble
The e.
f
Type: SystemDouble
The f.
See Also

Reference

PdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfCoordinateConverter Methods

The PdfCoordinateConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfCoordinateConverter.Convert Method

PdfCoordinateConverterConvert Method

Converts a given point or rectangle from one coordinate space to another.
Converts a given point or rectangle from one coordinate space to another.
Converts a given point or rectangle from one coordinate space to another.
Converts a given point or rectangle from one coordinate space to another.
Overload List
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another
Top
See Also

Reference

PdfCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfCoordinateConverter.Convert Method (Point)

PdfCoordinateConverterConvert Method (Point)

Converts a Point from one coordinate space to another

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Point Convert(
    Point p
)
Public Function Convert (
    p As Point
) As Point

Parameters

p
Type: System.DrawingPoint
The Point to convert

Return Value

Type: Point
A new Point in the target coordinate space
See Also

Reference

PdfCoordinateConverter Class
Convert Overload
Atalasoft.PdfDoc Namespace


PdfCoordinateConverter.Convert Method (PointF)

PdfCoordinateConverterConvert Method (PointF)

Converts a PointF from one coordinate space to another

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Convert(
    PointF p
)
Public Function Convert (
    p As PointF
) As PointF

Parameters

p
Type: System.DrawingPointF
The Point to convert

Return Value

Type: PointF
A new PointF in the target coordinate space
See Also

Reference

PdfCoordinateConverter Class
Convert Overload
Atalasoft.PdfDoc Namespace


PdfCoordinateConverter.Convert Method (Rectangle)

PdfCoordinateConverterConvert Method (Rectangle)

Converts a Rectangle from one coordinate space to another

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Rectangle Convert(
    Rectangle r
)
Public Function Convert (
    r As Rectangle
) As Rectangle

Parameters

r
Type: System.DrawingRectangle
The Rectangle to convert

Return Value

Type: Rectangle
A new Rectangle in the target coordinate space
See Also

Reference

PdfCoordinateConverter Class
Convert Overload
Atalasoft.PdfDoc Namespace


PdfCoordinateConverter.Convert Method (RectangleF)

PdfCoordinateConverterConvert Method (RectangleF)

Converts a RectangleF from one coordinate space to another

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Convert(
    RectangleF r
)
Public Function Convert (
    r As RectangleF
) As RectangleF

Parameters

r
Type: System.DrawingRectangleF
The RectangleF to convert

Return Value

Type: RectangleF
A new Rectangle in the target coordinate space
See Also

Reference

PdfCoordinateConverter Class
Convert Overload
Atalasoft.PdfDoc Namespace


PdfDestination Class

PdfDestination is an abstract class that represents a possible target location for a "go to" action.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfDestination

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfDestination : ISerializable
<SerializableAttribute>
Public Class PdfDestination
    Implements ISerializable

The PdfDestination type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDestination | Constructs a new, empty PdfDestination object. PdfDestination has a number of convenience factory methods for making the most common types of PdfDestination objects. After calling one of these methods, it will still be necessary to set the Page property to have a valid destination.
Protected method | PdfDestination(SerializationInfo, StreamingContext) | Constructs a new, empty PdfDestination object. PdfDestination has a number of convenience factory methods for making the most common types of PdfDestination objects. After calling one of these methods, it will still be necessary to set the Page property to have a valid destination.
Top
Properties
 | Name | Description
Public property | Bottom | Sets or gets the bottom extent of the view in PDF page coordinates
Public property | Left | Sets or gets the left extent of the view in PDF page coordinates
Public property | Page | Sets or gets a reference to the PdfPage to use as a target destination.
Public property | PageFitMode | Sets or gets the PdfPageFitMode for the destination.
Public property | Right | Sets or gets the right extent of the view in PDF page coordinates
Public property | Top | Sets or gets the top extent of the view in PDF page coordinates
Public property | Zoom | Sets or gets the zoom to be used for the view
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FitBounds | A factory method for making a PdfDestination with FitBounds as its PageFitMode.
 | FitBoundsAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitBounds as its PageFitMode
 | FitBoundsWidth | A factory method for making a PdfDestination with FitBoundsWidth as its PageFitMode.
 | FitBoundsWidthAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitBoundsWidth as its PageFitMode.
 | FitHeight | A factory method for making a PdfDestination with FitHeight as its PageFitMode.
 | FitHeightAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitHeight as its PageFitMode
 | FitPage | A factory method for making a PdfDestination with FitPage as its PageFitMode.
 | FitPageAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitPage as its PageFitMode
 | FitRectangle | A factory method for making a PdfDestination with FitRectangle as its PageFitMode.
 | FitRectangleAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitRectangle as its PageFitMode
 | FitWidth | A factory method for making a PdfDestination with FitWidth as its PageFitMode.
 | FitWidthAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitWidth as its PageFitMode
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointZoom | A factory method for making a PdfDestination with PointZoom as its PageFitMode
 | PointZoomAction | A factory method for making a PdfGoToViewAction with a PdfDestination with PointZoom as its PageFitMode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfDestination Constructor

Overload List
 | Name | Description
Public method | PdfDestination | Constructs a new, empty PdfDestination object. PdfDestination has a number of convenience factory methods for making the most common types of PdfDestination objects. After calling one of these methods, it will still be necessary to set the Page property to have a valid destination.
Protected method | PdfDestination(SerializationInfo, StreamingContext) | Constructs a new, empty PdfDestination object. PdfDestination has a number of convenience factory methods for making the most common types of PdfDestination objects. After calling one of these methods, it will still be necessary to set the Page property to have a valid destination.
Top
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination Constructor

Constructs a new, empty PdfDestination object. PdfDestination has a number of convenience factory methods for making the most common types of PdfDestination objects. After calling one of these methods, it will still be necessary to set the Page property to have a valid destination.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDestination()
Public Sub New
See Also

Reference

PdfDestination Class
PdfDestination Overload
Atalasoft.PdfDoc Namespace


PdfDestination Constructor (SerializationInfo, StreamingContext)

Constructs a new, empty PdfDestination object. PdfDestination has a number of convenience factory methods for making the most common types of PdfDestination objects. After calling one of these methods, it will still be necessary to set the Page property to have a valid destination.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfDestination(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

PdfDestination Class
PdfDestination Overload
Atalasoft.PdfDoc Namespace


PdfDestination Properties

The PdfDestination type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | Sets or gets the bottom extent of the view in PDF page coordinates
Public property | Left | Sets or gets the left extent of the view in PDF page coordinates
Public property | Page | Sets or gets a reference to the PdfPage to use as a target destination.
Public property | PageFitMode | Sets or gets the PdfPageFitMode for the destination.
Public property | Right | Sets or gets the right extent of the view in PDF page coordinates
Public property | Top | Sets or gets the top extent of the view in PDF page coordinates
Public property | Zoom | Sets or gets the zoom to be used for the view
Top
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.Bottom Property

PdfDestinationBottom Property

Sets or gets the bottom extent of the view in PDF page coordinates

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> Bottom { get; set; }
Public Property Bottom As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
Remarks
Bottom is only used with PageFitMode set to FitRectangle. Otherwise it is ignored.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.Left Property

PdfDestinationLeft Property

Sets or gets the left extent of the view in PDF page coordinates

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> Left { get; set; }
Public Property Left As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
Remarks
Left is only used with the following settings of PageFitMode: PointZoom, FitHeight, and FitRectangle. Otherwise it is ignored. If Left is null, it means that the current Left extent in the viewer shall be used.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.Page Property

PdfDestinationPage Property

Sets or gets a reference to the PdfPage to use as a target destination.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageReference Page { get; set; }
Public Property Page As PdfPageReference
    Get
    Set

Property Value

Type: PdfPageReference
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.PageFitMode Property

PdfDestinationPageFitMode Property

Sets or gets the PdfPageFitMode for the destination.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageFitMode PageFitMode { get; set; }
Public Property PageFitMode As PdfPageFitMode
    Get
    Set

Property Value

Type: PdfPageFitMode
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.Right Property

PdfDestinationRight Property

Sets or gets the right extent of the view in PDF page coordinates

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> Right { get; set; }
Public Property Right As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
Remarks
Right is only used with PageFitMode set to FitRectangle. It is ignored otherwise.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.Top Property

PdfDestinationTop Property

Sets or gets the top extent of the view in PDF page coordinates

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> Top { get; set; }
Public Property Top As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
Remarks
Top is only used when PageFitMode is set to PointZoom, FitWidth, FitRectangle and FitBoundsWidth. It is ignored otherwise. If Left is null, it means that the current Left extent in the viewer shall be used.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.Zoom Property

PdfDestinationZoom Property

Sets or gets the zoom to be used for the view

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> Zoom { get; set; }
Public Property Zoom As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
Remarks
Zoom is only used when PageFitMode is set to PointZoom. It is ignored otherwise. Zoom is a multiplicative value. 1.0 is actual size. 0.5 is half size, etc. 0 or null means "use the current zoom".
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination Methods

The PdfDestination type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FitBounds | A factory method for making a PdfDestination with FitBounds as its PageFitMode.
 | FitBoundsAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitBounds as its PageFitMode
 | FitBoundsWidth | A factory method for making a PdfDestination with FitBoundsWidth as its PageFitMode.
 | FitBoundsWidthAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitBoundsWidth as its PageFitMode.
 | FitHeight | A factory method for making a PdfDestination with FitHeight as its PageFitMode.
 | FitHeightAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitHeight as its PageFitMode
 | FitPage | A factory method for making a PdfDestination with FitPage as its PageFitMode.
 | FitPageAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitPage as its PageFitMode
 | FitRectangle | A factory method for making a PdfDestination with FitRectangle as its PageFitMode.
 | FitRectangleAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitRectangle as its PageFitMode
 | FitWidth | A factory method for making a PdfDestination with FitWidth as its PageFitMode.
 | FitWidthAction | A factory method for making a PdfGoToViewAction with a PdfDestination with FitWidth as its PageFitMode
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointZoom | A factory method for making a PdfDestination with PointZoom as its PageFitMode
 | PointZoomAction | A factory method for making a PdfGoToViewAction with a PdfDestination with PointZoom as its PageFitMode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitBounds Method

PdfDestinationFitBounds Method

A factory method for making a PdfDestination with FitBounds as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination FitBounds()
Public Shared Function FitBounds As PdfDestination

Return Value

Type: PdfDestination
Returns the PdfDestination.
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitBoundsAction Method

PdfDestinationFitBoundsAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with FitBounds as its PageFitMode

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction FitBoundsAction(
    int pageIndex
)
Public Shared Function FitBoundsAction (
    pageIndex As Integer
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.

Return Value

Type: PdfGoToViewAction
A new PdfGoToViewAction
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitBoundsWidth Method

PdfDestinationFitBoundsWidth Method

A factory method for making a PdfDestination with FitBoundsWidth as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination FitBoundsWidth(
    Nullable<double> top
)
Public Shared Function FitBoundsWidth (
    top As Nullable(Of Double)
) As PdfDestination

Parameters

top
Type: SystemNullableDouble
Specifies the top most edge of the view in PDF page coordinates. Setting this to null with instruct the viewer to use its default.

Return Value

Type: PdfDestination
Returns the PdfDestination.
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitBoundsWidthAction Method

PdfDestinationFitBoundsWidthAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with FitBoundsWidth as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction FitBoundsWidthAction(
    int pageIndex,
    Nullable<double> top
)
Public Shared Function FitBoundsWidthAction (
    pageIndex As Integer,
    top As Nullable(Of Double)
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.
top
Type: SystemNullableDouble
Specifies the top most edge of the view in PDF page coordinates. Setting this to null with instruct the viewer to use its default.

Return Value

Type: PdfGoToViewAction
A new PdfGoToViewAction
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitHeight Method

PdfDestinationFitHeight Method

A factory method for making a PdfDestination with FitHeight as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination FitHeight(
    Nullable<double> left
)
Public Shared Function FitHeight (
    left As Nullable(Of Double)
) As PdfDestination

Parameters

left
Type: SystemNullableDouble
Specifies the left most edge of the view in PDF page coordinates. Setting this to null with instruct the viewer to use its default.

Return Value

Type: PdfDestination
Returns the PdfDestination.
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitHeightAction Method

PdfDestinationFitHeightAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with FitHeight as its PageFitMode

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction FitHeightAction(
    int pageIndex,
    Nullable<double> left
)
Public Shared Function FitHeightAction (
    pageIndex As Integer,
    left As Nullable(Of Double)
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.
left
Type: SystemNullableDouble
Specifies the left most edge of the view in PDF page coordinates. Setting this to null with instruct the viewer to use its default.

Return Value

Type: PdfGoToViewAction
A new PdfGoToViewAction
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitPage Method

PdfDestinationFitPage Method

A factory method for making a PdfDestination with FitPage as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination FitPage()
Public Shared Function FitPage As PdfDestination

Return Value

Type: PdfDestination
Returns the PdfDestination.
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitPageAction Method

PdfDestinationFitPageAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with FitPage as its PageFitMode

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction FitPageAction(
    int pageIndex
)
Public Shared Function FitPageAction (
    pageIndex As Integer
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.

Return Value

Type: PdfGoToViewAction
A new PdfGoToViewAction
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitRectangle Method

PdfDestinationFitRectangle Method

A factory method for making a PdfDestination with FitRectangle as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination FitRectangle(
    RectangleF rect
)
Public Shared Function FitRectangle (
    rect As RectangleF
) As PdfDestination

Parameters

rect
Type: System.DrawingRectangleF
A rectangle representing the view in PDF page coordinates.

Return Value

Type: PdfDestination
Returns the PdfDestination.
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitRectangleAction Method

PdfDestinationFitRectangleAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with FitRectangle as its PageFitMode

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction FitRectangleAction(
    int pageIndex,
    RectangleF rect
)
Public Shared Function FitRectangleAction (
    pageIndex As Integer,
    rect As RectangleF
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.
rect
Type: System.DrawingRectangleF
A rectangle representing the view in PDF page coordinates.

Return Value

Type: PdfGoToViewAction
A new PdfGoToViewAction
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitWidth Method

PdfDestinationFitWidth Method

A factory method for making a PdfDestination with FitWidth as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination FitWidth(
    Nullable<double> top
)
Public Shared Function FitWidth (
    top As Nullable(Of Double)
) As PdfDestination

Parameters

top
Type: SystemNullableDouble
The top edge of the page to be shown in PDF page coordinates

Return Value

Type: PdfDestination
Returns the PdfDestination.
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.FitWidthAction Method

PdfDestinationFitWidthAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with FitWidth as its PageFitMode

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction FitWidthAction(
    int pageIndex,
    Nullable<double> top
)
Public Shared Function FitWidthAction (
    pageIndex As Integer,
    top As Nullable(Of Double)
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.
top
Type: SystemNullableDouble
The top edge of the page to be shown in PDF page coordinates

Return Value

Type: PdfGoToViewAction
A new PdfGoToViewAction
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.GetObjectData Method

PdfDestinationGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.PointZoom Method

PdfDestinationPointZoom Method

A factory method for making a PdfDestination with PointZoom as its PageFitMode

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDestination PointZoom(
    PointF position,
    double zoom
)
Public Shared Function PointZoom (
    position As PointF,
    zoom As Double
) As PdfDestination

Parameters

position
Type: System.DrawingPointF
The position to be zoomed in on in PDF page coordinates
zoom
Type: SystemDouble
The zoom level of the view. Zoom is a multiplier: 1.0 will be normal size. 0.5 will be half size, etc. 0 or null means "use current zoom"

Return Value

Type: PdfDestination
A PdfDestination with PointZoom
Remarks
After calling this method, it is still necessary to set the Page property to make a valid PdfDestination.
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDestination.PointZoomAction Method

PdfDestinationPointZoomAction Method

A factory method for making a PdfGoToViewAction with a PdfDestination with PointZoom as its PageFitMode.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGoToViewAction PointZoomAction(
    int pageIndex,
    PointF position,
    double zoom
)
Public Shared Function PointZoomAction (
    pageIndex As Integer,
    position As PointF,
    zoom As Double
) As PdfGoToViewAction

Parameters

pageIndex
Type: SystemInt32
Index of the page.
position
Type: System.DrawingPointF
The position to be zoomed in on in PDF page coordinates
zoom
Type: SystemDouble
The zoom level of the view. Zoom is a multiplier: 1.0 will be normal size. 0.5 will be half size, etc. 0 or null means "use current zoom"

Return Value

Type: PdfGoToViewAction
A PdfGoToViewAction with a PointZoom destination
See Also

Reference

PdfDestination Class
Atalasoft.PdfDoc Namespace


PdfDocument Class

PdfDocument is a representation of a PDF document and the pages and other structures contained therein.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfDocument

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDocument
Public Class PdfDocument

The PdfDocument type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocument | Initializes a new, empty instance of the PdfDocument class.
Public method | PdfDocument(Stream) | Initializes a new instance of the PdfDocument class, populated from the supplied stream.
Public method | PdfDocument(String) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path.
Public method | PdfDocument(Stream, RepairOptions) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(Stream, SecureString) | Initializes a new instance of the PdfDocument class, using the supplied stream and decodes it with the supplied password.
Public method | PdfDocument(String, RepairOptions) | Initializes a new instance of the PdfDocument class
Public method | PdfDocument(String, Stream) | Obsolete. Initializes a new instance of the PdfDocument class, using the supplied stream and decodes it with the supplied password.
Public method | PdfDocument(String, SecureString) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied password.
Public method | PdfDocument(String, String) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied password.
Public method | PdfDocument(Stream, SecureString, SecureString) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, SecureString, SecureString) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, Stream) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, String) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(Stream, SecureString, SecureString, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, SecureString, SecureString, RepairOptions) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, Stream, PdfDocumentLoadedProgress) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, String, RepairOptions) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(Stream, SecureString, SecureString, PdfDocumentLoadedProgress, RepairOptions) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(String, String, Stream, PdfDocumentLoadedProgress, RepairOptions) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(Stream, SecureString, SecureString, PdfDocumentLoadedProgress, RepairOptions, Boolean) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(String, String, Stream, PdfDocumentLoadedProgress, RepairOptions, Boolean) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Top
Properties
 | Name | Description
Public property | AllowSavingOfPreviouslySignedDocuments | Gets or sets a value indicating whether to allow previously signed documents to be saved. Default value is false. If set to false, if DocumentWasSigned is true, calling Save will throw a PdfException. If set to true and DocumentWasSigned is true, calling Save will not throw an exception, but will create an invalid PDF which may still render correctly.
Public property | BookmarkTree | Sets or gets the PdfBookmarkTree for this document.
Public property | DisplayMode | Gets or sets the display mode that will be used for this document.
Public property | DocumentCertification | Gets or sets the document certification.
Public property | DocumentWasSigned | Gets a value indicating whether the document contained a digital signature when opened.
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata should be encrypted. Default is false.
Public property | IsPdfPortfolio | Gets a value indicating whether the document contains a PDF Portfolio. A PDF Portfolio is a feature wherein a PDF document doesn't necessarily contain any PDF data at all, but instead contains a series of embedded files which represent the content of the document. Some PDF documents that have a Portfolion include an ersatz page which is shown for compatibility. The presentation of embedded files is application dependent.
Public property | Metadata | Sets or gets the document metadata for the PDF.
Public property | OwnerPassword | Obsolete. Sets or gets a password to use for the owner password for the document.
Public property | Pages | Gets a collection of objects that represent the pages in a PDF document.
Public property | Permissions | Sets or gets the set of allowable actions for this PDF.
Public property | RepairOptions | Gets the repair options that will be used for the document.
Public property | SelfPrintingPdf | Gets or sets a value indicating whether the document generated will automatically print upon opening.
Public property | UserPassword | Obsolete. Sets or gets a password to use for the user password for the document.
Public property | ViewerPreferences | Gets or sets the viewer preferences for this PDF document. PdfViewerPreferences control coarse levels of document and page level user interaction such as the reading order of the document and print characteristics.
Top
Methods
 | Name | Description
Public method | Close | Closes the PdfDocument's underlying stream, invalidates all pages, and clears the Pages collection.
 | Combine(Stream, Stream) | Combines one or more streams containing PDF documents into a single stream.
 | Combine(Stream, String) | Combines one or more paths containing PDF documents into a single stream.
 | Combine(String, String) | Combines one or more files containing PDF documents into a single file.
 | Combine(Stream, PdfSaveOptions, Stream) | Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.
 | Combine(Stream, PdfSaveOptions, String) | Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.
 | Combine(String, Stream, Stream) | Obsolete. Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.
 | Combine(String, Stream, String) | Obsolete. Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPdfACompatible | Checks the Output Intent color profiles and the PDF/A compatibility level (from metadata) of all source documents. Note! IsPdfACompatible() method does not check for compliance with the PDF/A standard.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Repair(Stream, Stream, RepairOptions) | Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
 | Repair(String, String, RepairOptions) | Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
 | Repair(Stream, Stream, RepairOptions, SecureString, SecureString) | Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
 | Repair(String, String, RepairOptions, SecureString, SecureString) | Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
 | Repair(String, String, Stream, Stream, RepairOptions) | Obsolete. Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
 | Repair(String, String, String, String, RepairOptions) | Obsolete. Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
Public method | Save(Stream) | Saves a PdfDocument into the supplied stream.
Public method | Save(String) | Saves a PdfDocument to a new file.
Public method | Save(Stream, PdfSaveOptions) | Saves a PdfDocument into the supplied stream.
Public method | Save(String, PdfSaveOptions) | Saves a PdfDocument to a new file.
Public method | Save(String, Stream) | Obsolete. Saves a PdfDocument into the supplied stream, encrypting with the supplied password.
Public method | Save(String, String) | Obsolete. Saves a PdfDocument into a new file encrypting with the supplied password.
Public method | Save(String, String, Stream) | Obsolete. Saves a PdfDocument into a stream encrypting with the supplied passwords.
Public method | Save(String, String, String) | Obsolete. Saves a PdfDocument into a new file encrypting with the supplied passwords.
 | Separate(String, String, Stream, PdfStreamCreator) | Obsolete. Separates a single PDF into multiple files: one file per page.
 | Separate(Stream, PdfStreamCreator, SecureString, SecureString, RepairOptions, PdfPageSavedHandler) | Separates a single PDF into multiple files: one file per page.
 | Separate(String, String, String, String, String, Boolean) | Obsolete. Separates a single PDF into multiple files: one file per page.
 | Separate(String, String, String, Boolean, SecureString, SecureString, RepairOptions, PdfPageSavedHandler) | Separates a single PDF into multiple files: one file per page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfDocument Constructor

Constructs a new PdfDocument object.
Overload List
 | Name | Description
Public method | PdfDocument | Initializes a new, empty instance of the PdfDocument class.
Public method | PdfDocument(Stream) | Initializes a new instance of the PdfDocument class, populated from the supplied stream.
Public method | PdfDocument(String) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path.
Public method | PdfDocument(Stream, RepairOptions) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(Stream, SecureString) | Initializes a new instance of the PdfDocument class, using the supplied stream and decodes it with the supplied password.
Public method | PdfDocument(String, RepairOptions) | Initializes a new instance of the PdfDocument class
Public method | PdfDocument(String, Stream) | Obsolete. Initializes a new instance of the PdfDocument class, using the supplied stream and decodes it with the supplied password.
Public method | PdfDocument(String, SecureString) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied password.
Public method | PdfDocument(String, String) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied password.
Public method | PdfDocument(Stream, SecureString, SecureString) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, SecureString, SecureString) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, Stream) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, String) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(Stream, SecureString, SecureString, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, SecureString, SecureString, RepairOptions) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, Stream, PdfDocumentLoadedProgress) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(String, String, String, RepairOptions) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.
Public method | PdfDocument(Stream, SecureString, SecureString, PdfDocumentLoadedProgress, RepairOptions) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(String, String, Stream, PdfDocumentLoadedProgress, RepairOptions) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(Stream, SecureString, SecureString, PdfDocumentLoadedProgress, RepairOptions, Boolean) | Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Public method | PdfDocument(String, String, Stream, PdfDocumentLoadedProgress, RepairOptions, Boolean) | Obsolete. Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument Constructor

Initializes a new, empty instance of the PdfDocument class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument()
Public Sub New
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream)

Initializes a new instance of the PdfDocument class, populated from the supplied stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    string path
)
Public Sub New (
    path As String
)

Parameters

path
Type: SystemString
A non-null path to the PDF document to be opened.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream, RepairOptions)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm,
    RepairOptions repairOptions
)
Public Sub New (
    stm As Stream,
    repairOptions As RepairOptions
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream, SecureString)

Initializes a new instance of the PdfDocument class, using the supplied stream and decodes it with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm,
    SecureString userPassword
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, RepairOptions)

Initializes a new instance of the PdfDocument class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    string path,
    RepairOptions repairOptions
)
Public Sub New (
    path As String,
    repairOptions As RepairOptions
)

Parameters

path
Type: SystemString
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, Stream)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the supplied stream and decodes it with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword) instead.",
    false)]
public PdfDocument(
    string userPassword,
    Stream stm
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword) instead.",
    false)>
Public Sub New (
    userPassword As String,
    stm As Stream
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
stm
Type: System.IOStream
A non-null stream containing a PDF document.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, SecureString)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    string path,
    SecureString userPassword
)
Public Sub New (
    path As String,
    userPassword As SecureString
)

Parameters

path
Type: SystemString
A non-null path to the PDF document to be opened.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(string path, SecureString userPassword) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string path
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(string path, SecureString userPassword) instead.",
    false)>
Public Sub New (
    userPassword As String,
    path As String
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
path
Type: SystemString
A non-null path to the PDF document to be opened.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream, SecureString, SecureString)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, SecureString, SecureString)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    string path,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Sub New (
    path As String,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

path
Type: SystemString
A non-null path to the PDF document to be opened.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String, Stream)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string ownerPassword,
    Stream stm
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
stm
Type: System.IOStream
A non-null stream containing a PDF document.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String, String)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(string path, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string ownerPassword,
    string path
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(string path, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    path As String
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
path
Type: SystemString
A non-null path to the PDF document to be opened.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream, SecureString, SecureString, PdfDocumentLoadedProgress)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    PdfDocumentLoadedProgress pageLoaded
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, SecureString, SecureString, RepairOptions)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    string path,
    SecureString userPassword,
    SecureString ownerPassword,
    RepairOptions repairOptions
)
Public Sub New (
    path As String,
    userPassword As SecureString,
    ownerPassword As SecureString,
    repairOptions As RepairOptions
)

Parameters

path
Type: SystemString
A non-null path to the PDF document to be opened.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String, Stream, PdfDocumentLoadedProgress)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    PdfDocumentLoadedProgress pageLoaded
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
stm
Type: System.IOStream
A non-null stream containing a PDF document.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String, String, RepairOptions)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(string path, SecureString userPassword, SecureString ownerPassword, RepairOptions repairOptions) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string ownerPassword,
    string path,
    RepairOptions repairOptions
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(string path, SecureString userPassword, SecureString ownerPassword, RepairOptions repairOptions) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    path As String,
    repairOptions As RepairOptions
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
path
Type: SystemString
A non-null path to the PDF document to be opened.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream, SecureString, SecureString, PdfDocumentLoadedProgress, RepairOptions)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    PdfDocumentLoadedProgress pageLoaded,
    RepairOptions repairOptions
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    pageLoaded As PdfDocumentLoadedProgress,
    repairOptions As RepairOptions
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String, Stream, PdfDocumentLoadedProgress, RepairOptions)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded, RepairOptions repairOptions) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    PdfDocumentLoadedProgress pageLoaded,
    RepairOptions repairOptions
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded, RepairOptions repairOptions) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    pageLoaded As PdfDocumentLoadedProgress,
    repairOptions As RepairOptions
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
stm
Type: System.IOStream
A non-null stream containing a PDF document.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (Stream, SecureString, SecureString, PdfDocumentLoadedProgress, RepairOptions, Boolean)

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    PdfDocumentLoadedProgress pageLoaded,
    RepairOptions repairOptions,
    bool leaveOpen
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    pageLoaded As PdfDocumentLoadedProgress,
    repairOptions As RepairOptions,
    leaveOpen As Boolean
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
leaveOpen
Type: SystemBoolean
The value indicating whether the provided stream should be closed on document close.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Constructor (String, String, Stream, PdfDocumentLoadedProgress, RepairOptions, Boolean)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocument class, using the file specified by the supplied path and decodes it with the supplied passwords and repair options.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded, RepairOptions repairOptions, bool leaveOpen) instead.",
    false)]
public PdfDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    PdfDocumentLoadedProgress pageLoaded,
    RepairOptions repairOptions,
    bool leaveOpen
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded, RepairOptions repairOptions, bool leaveOpen) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    pageLoaded As PdfDocumentLoadedProgress,
    repairOptions As RepairOptions,
    leaveOpen As Boolean
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
stm
Type: System.IOStream
A non-null stream containing a PDF document.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
leaveOpen
Type: SystemBoolean
The value indicating whether the provided stream should be closed on document close.
Exceptions
Exception | Condition
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocument Class
PdfDocument Overload
Atalasoft.PdfDoc Namespace


PdfDocument Properties

The PdfDocument type exposes the following members.

Properties
 | Name | Description
Public property | AllowSavingOfPreviouslySignedDocuments | Gets or sets a value indicating whether to allow previously signed documents to be saved. Default value is false. If set to false, if DocumentWasSigned is true, calling Save will throw a PdfException. If set to true and DocumentWasSigned is true, calling Save will not throw an exception, but will create an invalid PDF which may still render correctly.
Public property | BookmarkTree | Sets or gets the PdfBookmarkTree for this document.
Public property | DisplayMode | Gets or sets the display mode that will be used for this document.
Public property | DocumentCertification | Gets or sets the document certification.
Public property | DocumentWasSigned | Gets a value indicating whether the document contained a digital signature when opened.
Public property | EncryptMetadata | Sets or gets a boolean indicating that metadata should be encrypted. Default is false.
Public property | IsPdfPortfolio | Gets a value indicating whether the document contains a PDF Portfolio. A PDF Portfolio is a feature wherein a PDF document doesn't necessarily contain any PDF data at all, but instead contains a series of embedded files which represent the content of the document. Some PDF documents that have a Portfolion include an ersatz page which is shown for compatibility. The presentation of embedded files is application dependent.
Public property | Metadata | Sets or gets the document metadata for the PDF.
Public property | OwnerPassword | Obsolete. Sets or gets a password to use for the owner password for the document.
Public property | Pages | Gets a collection of objects that represent the pages in a PDF document.
Public property | Permissions | Sets or gets the set of allowable actions for this PDF.
Public property | RepairOptions | Gets the repair options that will be used for the document.
Public property | SelfPrintingPdf | Gets or sets a value indicating whether the document generated will automatically print upon opening.
Public property | UserPassword | Obsolete. Sets or gets a password to use for the user password for the document.
Public property | ViewerPreferences | Gets or sets the viewer preferences for this PDF document. PdfViewerPreferences control coarse levels of document and page level user interaction such as the reading order of the document and print characteristics.
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.AllowSavingOfPreviouslySignedDocuments Property

PdfDocumentAllowSavingOfPreviouslySignedDocuments Property

Gets or sets a value indicating whether to allow previously signed documents to be saved. Default value is false. If set to false, if DocumentWasSigned is true, calling Save will throw a PdfException. If set to true and DocumentWasSigned is true, calling Save will not throw an exception, but will create an invalid PDF which may still render correctly.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowSavingOfPreviouslySignedDocuments { get; set; }
Public Property AllowSavingOfPreviouslySignedDocuments As Boolean
    Get
    Set

Property Value

Type: Boolean
true if saving of previously signed documents is allowed; otherwise, false.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.BookmarkTree Property

PdfDocumentBookmarkTree Property

Sets or gets the PdfBookmarkTree for this document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkTree BookmarkTree { get; set; }
Public Property BookmarkTree As PdfBookmarkTree
    Get
    Set

Property Value

Type: PdfBookmarkTree
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.DisplayMode Property

PdfDocumentDisplayMode Property

Gets or sets the display mode that will be used for this document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageDisplayMode DisplayMode { get; set; }
Public Property DisplayMode As PdfPageDisplayMode
    Get
    Set

Property Value

Type: PdfPageDisplayMode
The display mode for the document.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.DocumentCertification Property

PdfDocumentDocumentCertification Property

Gets or sets the document certification.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentCertification DocumentCertification { get; set; }
Public Property DocumentCertification As PdfDocumentCertification
    Get
    Set

Property Value

Type: PdfDocumentCertification
The document certification.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.DocumentWasSigned Property

PdfDocumentDocumentWasSigned Property

Gets a value indicating whether the document contained a digital signature when opened.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DocumentWasSigned { get; }
Public ReadOnly Property DocumentWasSigned As Boolean
    Get

Property Value

Type: Boolean
true if the document contained a digital signature; otherwise, false.
Remarks
This property does not indicate that the validity of the signature - only that there was a signature at the time the file was opened. Saving a file with a previous digital signature will create an invalid PDF.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.EncryptMetadata Property

PdfDocumentEncryptMetadata Property

Sets or gets a boolean indicating that metadata should be encrypted. Default is false.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EncryptMetadata { get; set; }
Public Property EncryptMetadata As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When a PDF document is encrypted, nearly all embedded strings and stream data are encrypted. Metadata strings do not have to be encrypted. This allows indexing software to retrieve metadata without needing to know document passwords.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.IsPdfPortfolio Property

PdfDocumentIsPdfPortfolio Property

Gets a value indicating whether the document contains a PDF Portfolio. A PDF Portfolio is a feature wherein a PDF document doesn't necessarily contain any PDF data at all, but instead contains a series of embedded files which represent the content of the document. Some PDF documents that have a Portfolion include an ersatz page which is shown for compatibility. The presentation of embedded files is application dependent.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPdfPortfolio { get; }
Public ReadOnly Property IsPdfPortfolio As Boolean
    Get

Property Value

Type: Boolean
true if the document contains a PDF portfolio; otherwise, false.
Remarks
PdfDocument does not support saving PDF portfolio.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Metadata Property

PdfDocumentMetadata Property

Sets or gets the document metadata for the PDF.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentMetadata Metadata { get; set; }
Public Property Metadata As PdfDocumentMetadata
    Get
    Set

Property Value

Type: PdfDocumentMetadata
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.OwnerPassword Property

PdfDocumentOwnerPassword Property

Note: This API is now obsolete.

Sets or gets a password to use for the owner password for the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
Remarks
If a variant of Save is used that takes a ownerPassword parameter, that parameter will override this property. If the ownerPassword parameter is null, then this property will be used or the user password if the OwnerPassword property is null. PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Pages Property

PdfDocumentPages Property

Gets a collection of objects that represent the pages in a PDF document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public List<PdfPage> Pages { get; }
Public ReadOnly Property Pages As List(Of PdfPage)
    Get

Property Value

Type: ListPdfPage
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Permissions Property

PdfDocumentPermissions Property

Sets or gets the set of allowable actions for this PDF.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAccessPermissions Permissions { get; set; }
Public Property Permissions As PdfAccessPermissions
    Get
    Set

Property Value

Type: PdfAccessPermissions
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.RepairOptions Property

PdfDocumentRepairOptions Property

Gets the repair options that will be used for the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairOptions RepairOptions { get; }
Public ReadOnly Property RepairOptions As RepairOptions
    Get

Property Value

Type: RepairOptions
Remarks
This object must be set through the constructor for PdfDocument. This is necessary since the constructors open the PDF which may in turn require repair actions. Changing the options after construction may affect some of the repairs or result in them being done inconsistently.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.SelfPrintingPdf Property

PdfDocumentSelfPrintingPdf Property

Gets or sets a value indicating whether the document generated will automatically print upon opening.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfPrintingPdf { get; set; }
Public Property SelfPrintingPdf As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [self printing PDF]; otherwise, false.
Remarks
PDF/A standard does not support JavaScript actions. Therefore, self-printing PDF/A document cannot be created.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.UserPassword Property

PdfDocumentUserPassword Property

Note: This API is now obsolete.

Sets or gets a password to use for the user password for the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
Remarks
If a variant of Save is used that takes a userPassword parameter, that parameter will override this property. If the userPassword parameter is null, then this property will be used. PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.ViewerPreferences Property

PdfDocumentViewerPreferences Property

Gets or sets the viewer preferences for this PDF document. PdfViewerPreferences control coarse levels of document and page level user interaction such as the reading order of the document and print characteristics.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfViewerPreferences ViewerPreferences { get; set; }
Public Property ViewerPreferences As PdfViewerPreferences
    Get
    Set

Property Value

Type: PdfViewerPreferences
The viewer preferences.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument Methods

The PdfDocument type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the PdfDocument's underlying stream, invalidates all pages, and clears the Pages collection.
 | Combine(Stream, Stream) | Combines one or more streams containing PDF documents into a single stream.
 | Combine(Stream, String) | Combines one or more paths containing PDF documents into a single stream.
 | Combine(String, String) | Combines one or more files containing PDF documents into a single file.
 | Combine(Stream, PdfSaveOptions, Stream) | Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.
 | Combine(Stream, PdfSaveOptions, String) | Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.
 | Combine(String, Stream, Stream) | Obsolete. Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.
 | Combine(String, Stream, String) | Obsolete. Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPdfACompatible | Checks the Output Intent color profiles and the PDF/A compatibility level (from metadata) of all source documents. Note! IsPdfACompatible() method does not check for compliance with the PDF/A standard.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Repair(Stream, Stream, RepairOptions) | Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
 | Repair(String, String, RepairOptions) | Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
 | Repair(Stream, Stream, RepairOptions, SecureString, SecureString) | Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
 | Repair(String, String, RepairOptions, SecureString, SecureString) | Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
 | Repair(String, String, Stream, Stream, RepairOptions) | Obsolete. Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
 | Repair(String, String, String, String, RepairOptions) | Obsolete. Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
Public method | Save(Stream) | Saves a PdfDocument into the supplied stream.
Public method | Save(String) | Saves a PdfDocument to a new file.
Public method | Save(Stream, PdfSaveOptions) | Saves a PdfDocument into the supplied stream.
Public method | Save(String, PdfSaveOptions) | Saves a PdfDocument to a new file.
Public method | Save(String, Stream) | Obsolete. Saves a PdfDocument into the supplied stream, encrypting with the supplied password.
Public method | Save(String, String) | Obsolete. Saves a PdfDocument into a new file encrypting with the supplied password.
Public method | Save(String, String, Stream) | Obsolete. Saves a PdfDocument into a stream encrypting with the supplied passwords.
Public method | Save(String, String, String) | Obsolete. Saves a PdfDocument into a new file encrypting with the supplied passwords.
 | Separate(String, String, Stream, PdfStreamCreator) | Obsolete. Separates a single PDF into multiple files: one file per page.
 | Separate(Stream, PdfStreamCreator, SecureString, SecureString, RepairOptions, PdfPageSavedHandler) | Separates a single PDF into multiple files: one file per page.
 | Separate(String, String, String, String, String, Boolean) | Obsolete. Separates a single PDF into multiple files: one file per page.
 | Separate(String, String, String, Boolean, SecureString, SecureString, RepairOptions, PdfPageSavedHandler) | Separates a single PDF into multiple files: one file per page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Close Method

PdfDocumentClose Method

Closes the PdfDocument's underlying stream, invalidates all pages, and clears the Pages collection.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
Remarks
When a PdfDocument has been constructed from a string representing a path, it is necessary to call Close to ensure that the underlying stream created by the constructor will be closed. Calling Close() will invalidate all existing PdfPage objects that were associated with the original PdfDocument, even if they are contained within a new PdfDocument. When a PdfDocument has been constructed from a Stream object, the Stream will be closed.
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method

PdfDocumentCombine Method

Combines one or more PDF documents into a single document.
Combines one or more PDF documents into a single document.
Combines one or more PDF documents into a single document.
Combines one or more PDF documents into a single document.
Combines one or more PDF documents into a single document.
Combines one or more PDF documents into a single document.
Combines one or more PDF documents into a single document.
Overload List
Name | Description
Combine(Stream, Stream) | Combines one or more streams containing PDF documents into a single stream.
Combine(Stream, String) | Combines one or more paths containing PDF documents into a single stream.
Combine(String, String) | Combines one or more files containing PDF documents into a single file.
Combine(Stream, PdfSaveOptions, Stream) | Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.
Combine(Stream, PdfSaveOptions, String) | Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.
Combine(String, Stream, Stream) | Obsolete. Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.
Combine(String, Stream, String) | Obsolete. Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (Stream, Stream[])

PdfDocumentCombine Method (Stream, Stream)

Combines one or more streams containing PDF documents into a single stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    Stream output,
    params Stream[] sources
)
Public Shared Sub Combine (
    output As Stream,
    ParamArray sources As Stream()
)

Parameters

output
Type: System.IOStream
A non-null stream to which to save the resulting document.
sources
Type: System.IOStream
Two or more non-null streams containing PDF documents.
Remarks
If the output stream is contained within sources, Combine will throw an exception.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (Stream, String[])

PdfDocumentCombine Method (Stream, String)

Combines one or more paths containing PDF documents into a single stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    Stream output,
    params string[] sourceFiles
)
Public Shared Sub Combine (
    output As Stream,
    ParamArray sourceFiles As String()
)

Parameters

output
Type: System.IOStream
A non-null stream to which to save the resulting document.
sourceFiles
Type: SystemString
Two or more non-null strings containing paths PDF documents.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (String, String[])

PdfDocumentCombine Method (String, String)

Combines one or more files containing PDF documents into a single file.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    string outputFile,
    params string[] sourceFiles
)
Public Shared Sub Combine (
    outputFile As String,
    ParamArray sourceFiles As String()
)

Parameters

outputFile
Type: SystemString
A non-null path to the resulting output file.
sourceFiles
Type: SystemString
Two or more non-null strings containing paths PDF documents.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (Stream, PdfSaveOptions, Stream[])

PdfDocumentCombine Method (Stream, PdfSaveOptions, Stream)

Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    Stream output,
    PdfSaveOptions options,
    params Stream[] sources
)
Public Shared Sub Combine (
    output As Stream,
    options As PdfSaveOptions,
    ParamArray sources As Stream()
)

Parameters

output
Type: System.IOStream
A non-null stream to which to save the resulting document.
options
Type: Atalasoft.PdfDocPdfSaveOptions
Options for saving the Pdf document.
sources
Type: System.IOStream
Two or more non-null streams containing PDF documents.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (Stream, PdfSaveOptions, String[])

PdfDocumentCombine Method (Stream, PdfSaveOptions, String)

Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Combine(
    Stream output,
    PdfSaveOptions options,
    params string[] sourceFiles
)
Public Shared Sub Combine (
    output As Stream,
    options As PdfSaveOptions,
    ParamArray sourceFiles As String()
)

Parameters

output
Type: System.IOStream
A non-null stream to which to save the resulting document.
options
Type: Atalasoft.PdfDocPdfSaveOptions
Options for saving the Pdf document.
sourceFiles
Type: SystemString
Two or more non-null strings containing paths PDF documents.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (String, Stream, Stream[])

PdfDocumentCombine Method (String, Stream, Stream)

Note: This API is now obsolete.

Combines one or more streams containing PDF documents into a single stream and encrypts the document with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Combine(Stream, PdfSaveOptions, params Stream[]) instead.",
    true)]
public static void Combine(
    string password,
    Stream output,
    params Stream[] sources
)
<ObsoleteAttribute("This method is obsolete. Use Combine(Stream, PdfSaveOptions, params Stream[]) instead.",
    true)>
Public Shared Sub Combine (
    password As String,
    output As Stream,
    ParamArray sources As Stream()
)

Parameters

password
Type: SystemString
A password to encrypt the document. Null or empty string means "no password".
output
Type: System.IOStream
A non-null stream to which to save the resulting document.
sources
Type: System.IOStream
Two or more non-null streams containing PDF documents.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Combine Method (String, Stream, String[])

PdfDocumentCombine Method (String, Stream, String)

Note: This API is now obsolete.

Combines one or more paths containing PDF documents into a single stream and encrypts the document with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Combine(Stream, PdfSaveOptions, params string[]) instead.",
    true)]
public static void Combine(
    string password,
    Stream output,
    params string[] sourceFiles
)
<ObsoleteAttribute("This method is obsolete. Use Combine(Stream, PdfSaveOptions, params string[]) instead.",
    true)>
Public Shared Sub Combine (
    password As String,
    output As Stream,
    ParamArray sourceFiles As String()
)

Parameters

password
Type: SystemString
A password to encrypt the document. Null or empty string means "no password".
output
Type: System.IOStream
A non-null stream to which to save the resulting document.
sourceFiles
Type: SystemString
Two or more non-null strings containing paths PDF documents.
See Also

Reference

PdfDocument Class
Combine Overload
Atalasoft.PdfDoc Namespace


PdfDocument.IsPdfACompatible Method

PdfDocumentIsPdfACompatible Method

Checks the Output Intent color profiles and the PDF/A compatibility level (from metadata) of all source documents. Note! IsPdfACompatible() method does not check for compliance with the PDF/A standard.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPdfACompatible()
Public Function IsPdfACompatible As Boolean

Return Value

Type: Boolean
if Output Intent color profiles and the PDF/A version of all source documents are compatible; otherwise, .
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method

PdfDocumentRepair Method

Overload List
Name | Description
Repair(Stream, Stream, RepairOptions) | Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
Repair(String, String, RepairOptions) | Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
Repair(Stream, Stream, RepairOptions, SecureString, SecureString) | Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
Repair(String, String, RepairOptions, SecureString, SecureString) | Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
Repair(String, String, Stream, Stream, RepairOptions) | Obsolete. Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.
Repair(String, String, String, String, RepairOptions) | Obsolete. Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method (Stream, Stream, RepairOptions)

PdfDocumentRepair Method (Stream, Stream, RepairOptions)

Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Repair(
    Stream input,
    Stream output,
    RepairOptions options
)
Public Shared Sub Repair (
    input As Stream,
    output As Stream,
    options As RepairOptions
)

Parameters

input
Type: System.IOStream
The stream containing the input PDF.
output
Type: System.IOStream
The stream to contain the output PDF.
options
Type: Atalasoft.PdfDoc.RepairRepairOptions
The repair options.
See Also

Reference

PdfDocument Class
Repair Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method (String, String, RepairOptions)

PdfDocumentRepair Method (String, String, RepairOptions)

Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Repair(
    string inputPath,
    string outputPath,
    RepairOptions options
)
Public Shared Sub Repair (
    inputPath As String,
    outputPath As String,
    options As RepairOptions
)

Parameters

inputPath
Type: SystemString
The path to the file containing the input PDF.
outputPath
Type: SystemString
The path to the file which will contain the output PDF.
options
Type: Atalasoft.PdfDoc.RepairRepairOptions
The repair options.
See Also

Reference

PdfDocument Class
Repair Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method (Stream, Stream, RepairOptions, SecureString, SecureString)

PdfDocumentRepair Method (Stream, Stream, RepairOptions, SecureString, SecureString)

Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Repair(
    Stream input,
    Stream output,
    RepairOptions options,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Shared Sub Repair (
    input As Stream,
    output As Stream,
    options As RepairOptions,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

input
Type: System.IOStream
The stream containing the input PDF.
output
Type: System.IOStream
The stream to contain the output PDF.
options
Type: Atalasoft.PdfDoc.RepairRepairOptions
The repair options.
userPassword
Type: System.SecuritySecureString
The user password for the document. Can be null.
ownerPassword
Type: System.SecuritySecureString
The owner password for the document. Can be null.
See Also

Reference

PdfDocument Class
Repair Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method (String, String, RepairOptions, SecureString, SecureString)

PdfDocumentRepair Method (String, String, RepairOptions, SecureString, SecureString)

Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Repair(
    string inputPath,
    string outputPath,
    RepairOptions options,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Shared Sub Repair (
    inputPath As String,
    outputPath As String,
    options As RepairOptions,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

inputPath
Type: SystemString
The path to the file containing the input PDF.
outputPath
Type: SystemString
The path to the file which will contain the output PDF.
options
Type: Atalasoft.PdfDoc.RepairRepairOptions
The repair options.
userPassword
Type: System.SecuritySecureString
The user password for the document. Can be null.
ownerPassword
Type: System.SecuritySecureString
The owner password for the document. Can be null.
See Also

Reference

PdfDocument Class
Repair Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method (String, String, Stream, Stream, RepairOptions)

PdfDocumentRepair Method (String, String, Stream, Stream, RepairOptions)

Note: This API is now obsolete.

Repairs the PDF document in the Stream input, saving the repaired PDF to the Stream output.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Repair(Stream input, Stream output, RepairOptions options, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public static void Repair(
    string userPassword,
    string ownerPassword,
    Stream input,
    Stream output,
    RepairOptions options
)
<ObsoleteAttribute("This method is obsolete. Use Repair(Stream input, Stream output, RepairOptions options, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Shared Sub Repair (
    userPassword As String,
    ownerPassword As String,
    input As Stream,
    output As Stream,
    options As RepairOptions
)

Parameters

userPassword
Type: SystemString
The user password for the document. Can be null.
ownerPassword
Type: SystemString
The owner password for the document. Can be null.
input
Type: System.IOStream
The stream containing the input PDF.
output
Type: System.IOStream
The stream to contain the output PDF.
options
Type: Atalasoft.PdfDoc.RepairRepairOptions
The repair options.
See Also

Reference

PdfDocument Class
Repair Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Repair Method (String, String, String, String, RepairOptions)

PdfDocumentRepair Method (String, String, String, String, RepairOptions)

Note: This API is now obsolete.

Repairs the PDF document in file intputPath, saving the repaired PDF to the file outputPath.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Repair(string inputPath, string outputPath, RepairOptions options, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public static void Repair(
    string userPassword,
    string ownerPassword,
    string inputPath,
    string outputPath,
    RepairOptions options
)
<ObsoleteAttribute("This method is obsolete. Use Repair(string inputPath, string outputPath, RepairOptions options, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Shared Sub Repair (
    userPassword As String,
    ownerPassword As String,
    inputPath As String,
    outputPath As String,
    options As RepairOptions
)

Parameters

userPassword
Type: SystemString
The user password for the document. Can be null.
ownerPassword
Type: SystemString
The owner password for the document. Can be null.
inputPath
Type: SystemString
The path to the file containing the input PDF.
outputPath
Type: SystemString
The path to the file which will contain the output PDF.
options
Type: Atalasoft.PdfDoc.RepairRepairOptions
The repair options.
See Also

Reference

PdfDocument Class
Repair Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method

PdfDocumentSave Method

Saves a PdfDocument to a new stream or file.
Saves a PdfDocument to a new stream or file.
Saves a PdfDocument to a new stream or file.
Saves a PdfDocument to a new stream or file.
Saves a PdfDocument to a new stream or file.
Saves a PdfDocument to a new stream or file.
Saves a PdfDocument into a new stream or file
Overload List
 | Name | Description
Public method | Save(Stream) | Saves a PdfDocument into the supplied stream.
Public method | Save(String) | Saves a PdfDocument to a new file.
Public method | Save(Stream, PdfSaveOptions) | Saves a PdfDocument into the supplied stream.
Public method | Save(String, PdfSaveOptions) | Saves a PdfDocument to a new file.
Public method | Save(String, Stream) | Obsolete. Saves a PdfDocument into the supplied stream, encrypting with the supplied password.
Public method | Save(String, String) | Obsolete. Saves a PdfDocument into a new file encrypting with the supplied password.
Public method | Save(String, String, Stream) | Obsolete. Saves a PdfDocument into a stream encrypting with the supplied passwords.
Public method | Save(String, String, String) | Obsolete. Saves a PdfDocument into a new file encrypting with the supplied passwords.
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (Stream)

PdfDocumentSave Method (Stream)

Saves a PdfDocument into the supplied stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stm
)
Public Sub Save (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
A non-null stream to which to save the resulting document.
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (String)

PdfDocumentSave Method (String)

Saves a PdfDocument to a new file.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string path
)
Public Sub Save (
    path As String
)

Parameters

path
Type: SystemString
A non-null path to the resulting output file.
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (Stream, PdfSaveOptions)

PdfDocumentSave Method (Stream, PdfSaveOptions)

Saves a PdfDocument into the supplied stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream stm,
    PdfSaveOptions saveOptions
)
Public Sub Save (
    stm As Stream,
    saveOptions As PdfSaveOptions
)

Parameters

stm
Type: System.IOStream
A non-null stream to which to save the resulting document.
saveOptions
Type: Atalasoft.PdfDocPdfSaveOptions
Options for saving the Pdf document. This parameter may be .
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (String, PdfSaveOptions)

PdfDocumentSave Method (String, PdfSaveOptions)

Saves a PdfDocument to a new file.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string path,
    PdfSaveOptions saveOptions
)
Public Sub Save (
    path As String,
    saveOptions As PdfSaveOptions
)

Parameters

path
Type: SystemString
A non-null path to the resulting output file.
saveOptions
Type: Atalasoft.PdfDocPdfSaveOptions
Options for saving the Pdf document. This parameter may be .
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (String, Stream)

PdfDocumentSave Method (String, Stream)

Note: This API is now obsolete.

Saves a PdfDocument into the supplied stream, encrypting with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Save(Stream, PdfSaveOptions) instead.",
    true)]
public void Save(
    string userPassword,
    Stream stm
)
<ObsoleteAttribute("This method is obsolete. Use Save(Stream, PdfSaveOptions) instead.",
    true)>
Public Sub Save (
    userPassword As String,
    stm As Stream
)

Parameters

userPassword
Type: SystemString
A value to use for the user password. This parameter may be null.
stm
Type: System.IOStream
A non-null stream to which to save the resulting document.
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (String, String)

PdfDocumentSave Method (String, String)

Note: This API is now obsolete.

Saves a PdfDocument into a new file encrypting with the supplied password.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Save(string, PdfSaveOptions) instead.",
    true)]
public void Save(
    string userPassword,
    string path
)
<ObsoleteAttribute("This method is obsolete. Use Save(string, PdfSaveOptions) instead.",
    true)>
Public Sub Save (
    userPassword As String,
    path As String
)

Parameters

userPassword
Type: SystemString
A value to use for the user password. This parameter may be null.
path
Type: SystemString
A non-null path to the resulting output file.
Remarks
If the userPassword parameter is null, then the UserPassword property will be used instead. If there is no userPassword, but the OwnerPassword property is non-null, it will be used as both the user password and the owner password. PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (String, String, Stream)

PdfDocumentSave Method (String, String, Stream)

Note: This API is now obsolete.

Saves a PdfDocument into a stream encrypting with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Save(Stream, PdfSaveOptions) instead.",
    true)]
public void Save(
    string userPassword,
    string ownerPassword,
    Stream stm
)
<ObsoleteAttribute("This method is obsolete. Use Save(Stream, PdfSaveOptions) instead.",
    true)>
Public Sub Save (
    userPassword As String,
    ownerPassword As String,
    stm As Stream
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
stm
Type: System.IOStream
A non-null stream to which to save the resulting document.
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Save Method (String, String, String)

PdfDocumentSave Method (String, String, String)

Note: This API is now obsolete.

Saves a PdfDocument into a new file encrypting with the supplied passwords.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Save(string, PdfSaveOptions) instead.",
    true)]
public void Save(
    string userPassword,
    string ownerPassword,
    string path
)
<ObsoleteAttribute("This method is obsolete. Use Save(string, PdfSaveOptions) instead.",
    true)>
Public Sub Save (
    userPassword As String,
    ownerPassword As String,
    path As String
)

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
path
Type: SystemString
A non-null path to the resulting output file.
Remarks
PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.
See Also

Reference

PdfDocument Class
Save Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Separate Method

PdfDocumentSeparate Method

Overload List
Name | Description
Separate(String, String, Stream, PdfStreamCreator) | Obsolete. Separates a single PDF into multiple files: one file per page.
Separate(Stream, PdfStreamCreator, SecureString, SecureString, RepairOptions, PdfPageSavedHandler) | Separates a single PDF into multiple files: one file per page.
Separate(String, String, String, String, String, Boolean) | Obsolete. Separates a single PDF into multiple files: one file per page.
Separate(String, String, String, Boolean, SecureString, SecureString, RepairOptions, PdfPageSavedHandler) | Separates a single PDF into multiple files: one file per page.
Top
See Also

Reference

PdfDocument Class
Atalasoft.PdfDoc Namespace


PdfDocument.Separate Method (String, String, Stream, PdfStreamCreator)

PdfDocumentSeparate Method (String, String, Stream, PdfStreamCreator)

Note: This API is now obsolete.

Separates a single PDF into multiple files: one file per page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Separate(Stream source, PdfStreamCreator creator, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public static void Separate(
    string userPassword,
    string ownerPassword,
    Stream source,
    PdfStreamCreator creator
)
<ObsoleteAttribute("This method is obsolete. Use Separate(Stream source, PdfStreamCreator creator, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Shared Sub Separate (
    userPassword As String,
    ownerPassword As String,
    source As Stream,
    creator As PdfStreamCreator
)

Parameters

userPassword
Type: SystemString
The user password. Set a value to secure the pdf with a password.
ownerPassword
Type: SystemString
The owner password. Set a value to secure the pdf with a password.
source
Type: System.IOStream
The source stream.
creator
Type: Atalasoft.PdfDocPdfStreamCreator
The creator.
Remarks
Separated documents will not contain a portfolio, even if the source document contains a portfolio.
Examples
Copy
string userPass = "";
string ownerPass = "";
Stream originalPdfStream = ... a stream containing your original PDF ...

public Stream creator(Stream st, int page)
{
    FileStream fs = File.Create(@"C:\Sample Images\devPage" + page.ToString() + ".pdf");
    return fs;
}

PdfDocument.Separate(userPass ,ownerPass, originalPdfStream , creator);
See Also

Reference

PdfDocument Class
Separate Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Separate Method (Stream, PdfStreamCreator, SecureString, SecureString, RepairOptions, PdfPageSavedHandler)

PdfDocumentSeparate Method (Stream, PdfStreamCreator, SecureString, SecureString, RepairOptions, PdfPageSavedHandler)

Separates a single PDF into multiple files: one file per page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Separate(
    Stream source,
    PdfStreamCreator creator,
    SecureString userPassword,
    SecureString ownerPassword,
    RepairOptions repairOptions = null,
    PdfPageSavedHandler pageSavedHandler = null
)
Public Shared Sub Separate (
    source As Stream,
    creator As PdfStreamCreator,
    userPassword As SecureString,
    ownerPassword As SecureString,
    Optional repairOptions As RepairOptions = Nothing,
    Optional pageSavedHandler As PdfPageSavedHandler = Nothing
)

Parameters

source
Type: System.IOStream
The source stream.
creator
Type: Atalasoft.PdfDocPdfStreamCreator
The creator.
userPassword
Type: System.SecuritySecureString
The user password. Set a value to secure the pdf with a password.
ownerPassword
Type: System.SecuritySecureString
The owner password. Set a value to secure the pdf with a password.
repairOptions (Optional)
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
pageSavedHandler (Optional)
Type: Atalasoft.PdfDocPdfPageSavedHandler
A handler that is called when the single-page document is saved. This value may be null.
Remarks
Separated documents will not contain a portfolio, even if the source document contains a portfolio.
Examples
Copy
string userPass = "";
string ownerPass = "";
Stream originalPdfStream = ... a stream containing your original PDF ...

public Stream creator(Stream st, int page)
{
    FileStream fs = File.Create(@"C:\Sample Images\devPage" + page.ToString() + ".pdf");
    return fs;
}

PdfDocument.Separate(userPass ,ownerPass, originalPdfStream , creator);
See Also

Reference

PdfDocument Class
Separate Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Separate Method (String, String, String, String, String, Boolean)

PdfDocumentSeparate Method (String, String, String, String, String, Boolean)

Note: This API is now obsolete.

Separates a single PDF into multiple files: one file per page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Separate(string source, string destFolder, string fileNameFormat, bool overwrite, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public static void Separate(
    string userPassword,
    string ownerPassword,
    string source,
    string destFolder,
    string fileNameFormat,
    bool overwrite
)
<ObsoleteAttribute("This method is obsolete. Use Separate(string source, string destFolder, string fileNameFormat, bool overwrite, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Shared Sub Separate (
    userPassword As String,
    ownerPassword As String,
    source As String,
    destFolder As String,
    fileNameFormat As String,
    overwrite As Boolean
)

Parameters

userPassword
Type: SystemString
The user password. Set a value to secure the pdf with a password.
ownerPassword
Type: SystemString
The owner password. Set a value to secure the pdf with a password.
source
Type: SystemString
The source file name.
destFolder
Type: SystemString
The destination folder.
fileNameFormat
Type: SystemString
The file name format.
overwrite
Type: SystemBoolean
if set to true [overwrite].
Remarks
Separated documents will not contain a portfolio, even if the source document contains a portfolio.
Examples
Copy
string userPass = "";
string ownerPass = "";
string sourceFile = "Example_02403.pdf";
string destFolder = @"C:\myOutputFolder";
string nameFormat = "{0}.pdf";
bool overwriteExisting = true;

PdfDocument.Separate(userPass , ownerPass , sourceFile , destFolder , nameFormat , overwriteExisting );
See Also

Reference

PdfDocument Class
Separate Overload
Atalasoft.PdfDoc Namespace


PdfDocument.Separate Method (String, String, String, Boolean, SecureString, SecureString, RepairOptions, PdfPageSavedHandler)

PdfDocumentSeparate Method (String, String, String, Boolean, SecureString, SecureString, RepairOptions, PdfPageSavedHandler)

Separates a single PDF into multiple files: one file per page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void Separate(
    string source,
    string destFolder,
    string fileNameFormat,
    bool overwrite,
    SecureString userPassword,
    SecureString ownerPassword,
    RepairOptions repairOptions = null,
    PdfPageSavedHandler pageSavedHandler = null
)
Public Shared Sub Separate (
    source As String,
    destFolder As String,
    fileNameFormat As String,
    overwrite As Boolean,
    userPassword As SecureString,
    ownerPassword As SecureString,
    Optional repairOptions As RepairOptions = Nothing,
    Optional pageSavedHandler As PdfPageSavedHandler = Nothing
)

Parameters

source
Type: SystemString
The source file name.
destFolder
Type: SystemString
The destination folder.
fileNameFormat
Type: SystemString
The file name format.
overwrite
Type: SystemBoolean
if set to true [overwrite].
userPassword
Type: System.SecuritySecureString
The user password. Set a value to secure the pdf with a password.
ownerPassword
Type: System.SecuritySecureString
The owner password. Set a value to secure the pdf with a password.
repairOptions (Optional)
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that specifies features for handling PDF document repair. This value may be null.
pageSavedHandler (Optional)
Type: Atalasoft.PdfDocPdfPageSavedHandler
A handler that is called when the single-page document is saved. This value may be null.
Remarks
Separated documents will not contain a portfolio, even if the source document contains a portfolio.
Examples
Copy
string sourceFile = "Example_02403.pdf";
string destFolder = @"C:\myOutputFolder";
string nameFormat = "{0}.pdf";
bool overwriteExisting = true;

PdfDocument.Separate(sourceFile , destFolder , nameFormat , overwriteExisting );
See Also

Reference

PdfDocument Class
Separate Overload
Atalasoft.PdfDoc Namespace


PdfDocumentLoadedProgress Delegate

A delegate that will be called when a page has been loaded in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PdfDocumentLoadedProgress(
    int currentPageNumber,
    int currentPageIndex,
    int totalPages
)
Public Delegate Sub PdfDocumentLoadedProgress (
    currentPageNumber As Integer,
    currentPageIndex As Integer,
    totalPages As Integer
)

Parameters

currentPageNumber
Type: SystemInt32
The current page number of the page loaded relative to the document.
currentPageIndex
Type: SystemInt32
Indicates the total number of pages loaded so far.
totalPages
Type: SystemInt32
The total number of pages that will be loaded.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfDocumentMetadata Class

PdfDocumentMetadata represents standard PDF metadata including title, subject, author and so on.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfDocumentMetadata

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDocumentMetadata
Public Class PdfDocumentMetadata

The PdfDocumentMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocumentMetadata | Constructs a new PdfDocumentMetadata object with default values for all the fields.
Top
Properties
 | Name | Description
Public property | Author | Gets or sets the Author field of the document.
Public property | CreationDate | Sets or gets the date when the document was created.
Public property | Creator | Gets or sets the Creator field of the document.
Public property | CustomFields | Gets a table of custom metadata fields.
Public property | DocumentTrapping | Gets or sets the trapping to be used for this document. The default value is PdfTrapSetting.None.
Public property | Keywords | Gets or sets the keywords associated with the document.
Public property | ModificationDate | Gets or sets the modification date for this document.
Public property | PdfAVersion | Gets conformance level and part of PDF/A.
Public property | Producer | Gets or sets the producer of this PDF document.
Public property | Subject | Gets or sets the Subject of this PDF document
Public property | Title | Gets or sets the title of the PDF document.
Top
Methods
 | Name | Description
Public method | AddCustomField | Adds a custom field to the metadata object.
Public method | Append | Adds the metadata to an existing PDF stream
Public method | Clear | Clears out all metadata within a PdfDocumentMetadata object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream(Stream) | Constructs a new PdfDocumentMetadata object from the stream
 | FromStream(Stream, SecureString) | Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
 | FromStream(Stream, String) | Obsolete. Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
Public method | GetCustomField | Attempts to retrieve the value of a custom field from the PdfDocumentMetadata object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomField | Removes a field from the metadata object.
 | ToSecondsPrecision | Round a DateTime down to the nearest second i.e. strip off Milliseconds
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateCustomField | Updates a custom field in the metadata object.
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfDocumentMetadata Constructor

Constructs a new PdfDocumentMetadata object with default values for all the fields.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentMetadata()
Public Sub New

Return Value

Type:
A new PdfDocumentMetadata object with default values.
Remarks
All string fields are set to null except for the Producer field, which is set to "%%company%% DotImage Version x.y.z". The creation and modification date are set to the current date and time.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata Properties

The PdfDocumentMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets or sets the Author field of the document.
Public property | CreationDate | Sets or gets the date when the document was created.
Public property | Creator | Gets or sets the Creator field of the document.
Public property | CustomFields | Gets a table of custom metadata fields.
Public property | DocumentTrapping | Gets or sets the trapping to be used for this document. The default value is PdfTrapSetting.None.
Public property | Keywords | Gets or sets the keywords associated with the document.
Public property | ModificationDate | Gets or sets the modification date for this document.
Public property | PdfAVersion | Gets conformance level and part of PDF/A.
Public property | Producer | Gets or sets the producer of this PDF document.
Public property | Subject | Gets or sets the Subject of this PDF document
Public property | Title | Gets or sets the title of the PDF document.
Top
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Author Property

PdfDocumentMetadataAuthor Property

Gets or sets the Author field of the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set

Property Value

Type: String
Remarks
Setting the field to null indicates that the field has no value and will not be added to a file.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.CreationDate Property

PdfDocumentMetadataCreationDate Property

Sets or gets the date when the document was created.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
Remarks
If the date is set to DateTime.MinValue, it will not be written to a PDF.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Creator Property

PdfDocumentMetadataCreator Property

Gets or sets the Creator field of the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set

Property Value

Type: String
Remarks
Setting the field to null indicates that the field has no value and will not be added to a file. This field is meant to represent the name of the application that created the original document.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.CustomFields Property

PdfDocumentMetadataCustomFields Property

Gets a table of custom metadata fields.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Hashtable CustomFields { get; }
Public ReadOnly Property CustomFields As Hashtable
    Get

Property Value

Type: Hashtable
Remarks
The PDF specification requires that metadata field names and values are strings. It is possible to add any object type to the table, but this will create an illegal PDF. Standard fields (Title, Subject, Author, Keywords, Creator, and Producer) must not be stored in this table; use the properties for standard fields instead.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.DocumentTrapping Property

PdfDocumentMetadataDocumentTrapping Property

Gets or sets the trapping to be used for this document. The default value is PdfTrapSetting.None.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTrapSetting DocumentTrapping { get; set; }
Public Property DocumentTrapping As PdfTrapSetting
    Get
    Set

Property Value

Type: PdfTrapSetting
Remarks
Setting the DocumentTrapping property to PdfTrapSetting.None indicates that no trapping information should be written to the file.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Keywords Property

PdfDocumentMetadataKeywords Property

Gets or sets the keywords associated with the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set

Property Value

Type: String
Remarks
Keywords are meant to be space-delimited words that describe the document.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.ModificationDate Property

PdfDocumentMetadataModificationDate Property

Gets or sets the modification date for this document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime ModificationDate { get; set; }
Public Property ModificationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.PdfAVersion Property

PdfDocumentMetadataPdfAVersion Property

Gets conformance level and part of PDF/A.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAVersion PdfAVersion { get; }
Public ReadOnly Property PdfAVersion As PdfAVersion
    Get

Property Value

Type: PdfAVersion
Remarks
PdfAVersion property value is set based on metadata retrieved from PDF document. This metadata may be incorrect, because PDF document itself may not conform to the PDF/A standard at all or to the specified version of the PDF/A standard. PdfDocument class does not check for compliance with the PDF/A standard, therefore, PdfAVersion property value may also be incorrect.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Producer Property

PdfDocumentMetadataProducer Property

Gets or sets the producer of this PDF document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Producer { get; set; }
Public Property Producer As String
    Get
    Set

Property Value

Type: String
Remarks
By default the Producer is set to "%%company%% DotImage Version x.y.z"
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Subject Property

PdfDocumentMetadataSubject Property

Gets or sets the Subject of this PDF document

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Title Property

PdfDocumentMetadataTitle Property

Gets or sets the title of the PDF document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata Methods

The PdfDocumentMetadata type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomField | Adds a custom field to the metadata object.
Public method | Append | Adds the metadata to an existing PDF stream
Public method | Clear | Clears out all metadata within a PdfDocumentMetadata object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream(Stream) | Constructs a new PdfDocumentMetadata object from the stream
 | FromStream(Stream, SecureString) | Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
 | FromStream(Stream, String) | Obsolete. Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
Public method | GetCustomField | Attempts to retrieve the value of a custom field from the PdfDocumentMetadata object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCustomField | Removes a field from the metadata object.
 | ToSecondsPrecision | Round a DateTime down to the nearest second i.e. strip off Milliseconds
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateCustomField | Updates a custom field in the metadata object.
Top
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.AddCustomField Method

PdfDocumentMetadataAddCustomField Method

Adds a custom field to the metadata object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddCustomField(
    string name,
    string val
)
Public Sub AddCustomField (
    name As String,
    val As String
)

Parameters

name
Type: SystemString
The name to be associated with this metadata
val
Type: SystemString
The string value to associate with this metadata
Remarks
While the name parameter can be any string, you should avoid using whitespace characters or PDF delimiters. Whitespace characters include NUL (ASCII 0), Tab (ASCII 9), Line Feed (ASCII 10), Form Feed (ASCII 12), Carriage Return (ASCII 13) or space (ASCII 32). Delimiter characters include (, ), lt;, gt;, [, ], {, }, /, and %. Upper and lower case characters are considered unique. It is recommended that the string for name be chosen in such a way that it appropriately describes the content of the metadata. Avoid using the names of standard metadata fields (Title, Subject, Author, Keywords, Creator, Producer). Extra fields can also be added via the CustomFields hashtable.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Append Method

PdfDocumentMetadataAppend Method

Adds the metadata to an existing PDF stream

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Append(
    Stream stm,
    bool mergeMetadata
)
Public Sub Append (
    stm As Stream,
    mergeMetadata As Boolean
)

Parameters

stm
Type: System.IOStream
A non-null stream containing a PDF document.
mergeMetadata
Type: SystemBoolean
Determines if the metadata will be merged into the existing document metadata, if any.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.Clear Method

PdfDocumentMetadataClear Method

Clears out all metadata within a PdfDocumentMetadata object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
Remarks
Clear will set all fields to null, exception for producer. Producer will be set to "%%company%% DotImage Version x.y.z". The creation and modification dates will be set to the current date and time.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.FromStream Method

PdfDocumentMetadataFromStream Method

Constructs a new PdfDocumentMetadata object from the stream
Constructs a new PdfDocumentMetadata object from the stream
Constructs a new PdfDocumentMetadata object from the stream
Overload List
Name | Description
FromStream(Stream) | Constructs a new PdfDocumentMetadata object from the stream
FromStream(Stream, SecureString) | Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
FromStream(Stream, String) | Obsolete. Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
Top
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.FromStream Method (Stream)

PdfDocumentMetadataFromStream Method (Stream)

Constructs a new PdfDocumentMetadata object from the stream

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDocumentMetadata FromStream(
    Stream stm
)
Public Shared Function FromStream (
    stm As Stream
) As PdfDocumentMetadata

Parameters

stm
Type: System.IOStream
A stream containing a PDF document

Return Value

Type: PdfDocumentMetadata
A new PdfDocumentMetadata object containing the fields from the PDF.
Remarks
Reads PDF document metadata from an existing PDF and returns a new PdfDocumentMetadata object populated with all the fields contained in the stream. If metadata fields are not present within the PDF, they will be null in the resulting PdfDocumentMetadata object.
See Also

Reference

PdfDocumentMetadata Class
FromStream Overload
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.FromStream Method (Stream, SecureString)

PdfDocumentMetadataFromStream Method (Stream, SecureString)

Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
Reads PDF document metadata from an existing PDF and returns a new PdfDocumentMetadata object populated with all the fields contained in the stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDocumentMetadata FromStream(
    Stream stm,
    SecureString password
)
Public Shared Function FromStream (
    stm As Stream,
    password As SecureString
) As PdfDocumentMetadata

Parameters

stm
Type: System.IOStream
A stream containing a PDF document
password
Type: System.SecuritySecureString
A password to use to decrypt the document

Return Value

Type: PdfDocumentMetadata
A new PdfDocumentMetadata object containing the fields from the PDF.
Remarks
If metadata fields are not present within the PDF, they will be null in the resulting PdfDocumentMetadata object.
See Also

Reference

PdfDocumentMetadata Class
FromStream Overload
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.FromStream Method (Stream, String)

PdfDocumentMetadataFromStream Method (Stream, String)

Note: This API is now obsolete.

Constructs a new PdfDocumentMetadata object from the stream, using the supplied password
Reads PDF document metadata from an existing PDF and returns a new PdfDocumentMetadata object populated with all the fields contained in the stream.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use FromStream(Stream stm, SecureString password) instead.",
    false)]
public static PdfDocumentMetadata FromStream(
    Stream stm,
    string password
)
<ObsoleteAttribute("This method is obsolete. Use FromStream(Stream stm, SecureString password) instead.",
    false)>
Public Shared Function FromStream (
    stm As Stream,
    password As String
) As PdfDocumentMetadata

Parameters

stm
Type: System.IOStream
A stream containing a PDF document
password
Type: SystemString
A password to use to decrypt the document

Return Value

Type: PdfDocumentMetadata
A new PdfDocumentMetadata object containing the fields from the PDF.
Remarks
If metadata fields are not present within the PDF, they will be null in the resulting PdfDocumentMetadata object.
See Also

Reference

PdfDocumentMetadata Class
FromStream Overload
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.GetCustomField Method

PdfDocumentMetadataGetCustomField Method

Attempts to retrieve the value of a custom field from the PdfDocumentMetadata object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GetCustomField(
    string name
)
Public Function GetCustomField (
    name As String
) As String

Parameters

name
Type: SystemString
The name of a custom field in the metadata. See AddCustomField(String, String) for restrictions.

Return Value

Type: String
A string containing the metadata.
Remarks
The PDF specification requires that all custom field values be strings. It is possible, however, that some PDF files will contain illegal, non-string metadata. GetCustomField attempts to represent the data as a string. If it fails, it will throw an IllegalCastException. If client code is attempting to read specific, non-string data, it is best to get the data directly from the CustomFields property.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.RemoveCustomField Method

PdfDocumentMetadataRemoveCustomField Method

Removes a field from the metadata object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveCustomField(
    string name
)
Public Sub RemoveCustomField (
    name As String
)

Parameters

name
Type: SystemString
The name associated with the metadata to be removed.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.ToSecondsPrecision Method

PdfDocumentMetadataToSecondsPrecision Method

Round a DateTime down to the nearest second i.e. strip off Milliseconds

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DateTime ToSecondsPrecision(
    DateTime t
)
Public Shared Function ToSecondsPrecision (
    t As DateTime
) As DateTime

Parameters

t
Type: SystemDateTime
arbitrary DateTime

Return Value

Type: DateTime
input value but with Millisecond set to 0
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentMetadata.UpdateCustomField Method

PdfDocumentMetadataUpdateCustomField Method

Updates a custom field in the metadata object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void UpdateCustomField(
    string name,
    string val
)
Public Sub UpdateCustomField (
    name As String,
    val As String
)

Parameters

name
Type: SystemString
The name associated with the metadata field to be updated.
val
Type: SystemString
The string value to associate with this metadata.
See Also

Reference

PdfDocumentMetadata Class
Atalasoft.PdfDoc Namespace


PdfDocumentType Enumeration

Controls the type of PDF Document generated.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfDocumentType
Public Enumeration PdfDocumentType
Members
Member name | Description
Default | Generate a default PDF document, without any specific constraints.
PdfA1b | Generate a PDFA-1b compliant PDF document.
PdfA2b | Generate a PDFA-2b compliant PDF document.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfException Class

An exception from DotPdf
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDoc.PdfAPdfAException
Atalasoft.PdfDocPdfAException
Atalasoft.PdfDocPdfParseException

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfException : Exception
<SerializableAttribute>
Public Class PdfException
    Inherits Exception

The PdfException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfException | Initializes a new instance of the PdfException class.
Public method | PdfException(String) | Initializes a new instance of the PdfException class.
Protected method | PdfException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfException class.
Public method | PdfException(String, Exception) | Initializes a new instance of the PdfException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfException Constructor

Overload List
 | Name | Description
Public method | PdfException | Initializes a new instance of the PdfException class.
Public method | PdfException(String) | Initializes a new instance of the PdfException class.
Protected method | PdfException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfException class.
Public method | PdfException(String, Exception) | Initializes a new instance of the PdfException class.
Top
See Also

Reference

PdfException Class
Atalasoft.PdfDoc Namespace


PdfException Constructor

Initializes a new instance of the PdfException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfException()
Public Sub New
See Also

Reference

PdfException Class
PdfException Overload
Atalasoft.PdfDoc Namespace


PdfException Constructor (String)

Initializes a new instance of the PdfException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfException Class
PdfException Overload
Atalasoft.PdfDoc Namespace


PdfException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfException Class
PdfException Overload
Atalasoft.PdfDoc Namespace


PdfException Constructor (String, Exception)

Initializes a new instance of the PdfException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfException Class
PdfException Overload
Atalasoft.PdfDoc Namespace


PdfException Properties

The PdfException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfException Class
Atalasoft.PdfDoc Namespace


PdfException Methods

The PdfException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfException Class
Atalasoft.PdfDoc Namespace


PdfException Events

The PdfException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfException Class
Atalasoft.PdfDoc Namespace


PdfFileCreator Delegate

The event delegate for file creation.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate string PdfFileCreator(
    string pathToOriginalPdf,
    int pageIndex
)
Public Delegate Function PdfFileCreator (
    pathToOriginalPdf As String,
    pageIndex As Integer
) As String

Parameters

pathToOriginalPdf
Type: SystemString
The path to original PDF.
pageIndex
Type: SystemInt32
Index of the page.

Return Value

Type: String
A new file name.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfGoToViewAction Class

PdfGoToViewAction is a concrete class that represents an action that causes a PDF viewer to go to a specific view within a document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDocPdfGoToViewAction

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfGoToViewAction : PdfAction,
    ISerializable
<SerializableAttribute>
Public Class PdfGoToViewAction
    Inherits PdfAction
    Implements ISerializable

The PdfGoToViewAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfGoToViewAction | Constructs a new empty PdfGoToViewAction
Public method | PdfGoToViewAction(PdfDestination) | Constructs a new PdfGoToViewAction that goes to the destination.
Protected method | PdfGoToViewAction(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfGoToViewAction class
Top
Properties
 | Name | Description
Public property | ActionType | Gets the action type for this action (Overrides PdfActionActionType.)
Public property | Destination | Sets or gets the destination of the PdfGoToViewAction
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Overrides PdfActionLLValidate(ProblemList, RepairContext).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfGoToViewAction Constructor

Constructs a new PdfGoToViewAction object
Constructs a new PdfGoToViewAction object
Constructs a new PdfGoToViewAction object
Overload List
 | Name | Description
Public method | PdfGoToViewAction | Constructs a new empty PdfGoToViewAction
Public method | PdfGoToViewAction(PdfDestination) | Constructs a new PdfGoToViewAction that goes to the destination.
Protected method | PdfGoToViewAction(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfGoToViewAction class
Top
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfGoToViewAction Constructor

Constructs a new empty PdfGoToViewAction

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGoToViewAction()
Public Sub New
See Also

Reference

PdfGoToViewAction Class
PdfGoToViewAction Overload
Atalasoft.PdfDoc Namespace


PdfGoToViewAction Constructor (PdfDestination)

Constructs a new PdfGoToViewAction that goes to the destination.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGoToViewAction(
    PdfDestination dest
)
Public Sub New (
    dest As PdfDestination
)

Parameters

dest
Type: Atalasoft.PdfDocPdfDestination
The destination of the view
See Also

Reference

PdfGoToViewAction Class
PdfGoToViewAction Overload
Atalasoft.PdfDoc Namespace


PdfGoToViewAction Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfGoToViewAction class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfGoToViewAction(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

PdfGoToViewAction Class
PdfGoToViewAction Overload
Atalasoft.PdfDoc Namespace


PdfGoToViewAction Properties

The PdfGoToViewAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the action type for this action (Overrides PdfActionActionType.)
Public property | Destination | Sets or gets the destination of the PdfGoToViewAction
Top
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfGoToViewAction.ActionType Property

PdfGoToViewActionActionType Property

Gets the action type for this action

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
Always returns PdfActionType.GoToView
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfGoToViewAction.Destination Property

PdfGoToViewActionDestination Property

Sets or gets the destination of the PdfGoToViewAction

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDestination Destination { get; set; }
Public Property Destination As PdfDestination
    Get
    Set

Property Value

Type: PdfDestination
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfGoToViewAction Methods

The PdfGoToViewAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Overrides PdfActionLLValidate(ProblemList, RepairContext).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfGoToViewAction.GetObjectData Method

PdfGoToViewActionGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfGoToViewAction.LLValidate Method

PdfGoToViewActionLLValidate Method

Low-level validation. Not for use by client code

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLValidate(
    ProblemList problems,
    RepairContext repairContext
)
Protected Overrides Sub LLValidate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems so far.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.
Exceptions
Exception | Condition
ArgumentException | repairContext
PdfException | PdfGoToView action has illegal destination: + (Destination == null ? Destination is null : Destination page reference is bad)
See Also

Reference

PdfGoToViewAction Class
Atalasoft.PdfDoc Namespace


PdfImageCodec Enumeration

An enum to represnet which codec is used to compress an image resource

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfImageCodec
Public Enumeration PdfImageCodec
Members
Member name | Description
None | No Compression
LZW | LZW compression
Flate | Flate compression
RunLength | Run Length compression
CCITTGroup4 | CCITT Group 4 Compression
JBIG2 | JBIG2 Compression (requires JBig2 Encoder License)
DCT | DCT Compression
JPX | JPEG 2000 Compression (requires Jpeg2k Encoder License)
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfImageColorSpace Enumeration

An enum representing the color space types as their channel designations

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfImageColorSpace
Public Enumeration PdfImageColorSpace
Members
Member name | Description
Gray | Grayscale color space. One channel representing Gamma.
Rgb | Red Green Blue color space. Channels representing Red, Green, then Blue.
Cmyk | Cyan Magenta Yellow Black color space. Channels representing Cyan, Magenta, Yellow, then Black.
Paletted | Palleted color space. Specific colors mapped to single channel values.
Unknown | Unknown color space.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfIndexedPageReference Class

PdfIndexedPageReference is low-overhead class that represents a PDF page by its 0-based page number.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfPageReference
Atalasoft.PdfDocPdfIndexedPageReference

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfIndexedPageReference : PdfPageReference,
    ISerializable
<SerializableAttribute>
Public Class PdfIndexedPageReference
    Inherits PdfPageReference
    Implements ISerializable

The PdfIndexedPageReference type exposes the following members.

Constructors
 | Name | Description
Public method | PdfIndexedPageReference(Int32) | Constructs a new PdfIndexedPageReference using the supplied index
Protected method | PdfIndexedPageReference(SerializationInfo, StreamingContext) | Constructs a new PdfIndexedPageReference using the supplied index
Top
Properties
 | Name | Description
Public property | PageIndex | Sets or gets the page index
Public property | ReferenceType | Gets the PdfPageReferenceType for this PdfPageReference object (Overrides PdfPageReferenceReferenceType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfIndexedPageReference Constructor

Overload List
 | Name | Description
Public method | PdfIndexedPageReference(Int32) | Constructs a new PdfIndexedPageReference using the supplied index
Protected method | PdfIndexedPageReference(SerializationInfo, StreamingContext) | Constructs a new PdfIndexedPageReference using the supplied index
Top
See Also

Reference

PdfIndexedPageReference Class
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference Constructor (Int32)

Constructs a new PdfIndexedPageReference using the supplied index

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfIndexedPageReference(
    int index
)
Public Sub New (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

PdfIndexedPageReference Class
PdfIndexedPageReference Overload
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference Constructor (SerializationInfo, StreamingContext)

Constructs a new PdfIndexedPageReference using the supplied index

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfIndexedPageReference(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

PdfIndexedPageReference Class
PdfIndexedPageReference Overload
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference Properties

The PdfIndexedPageReference type exposes the following members.

Properties
 | Name | Description
Public property | PageIndex | Sets or gets the page index
Public property | ReferenceType | Gets the PdfPageReferenceType for this PdfPageReference object (Overrides PdfPageReferenceReferenceType.)
Top
See Also

Reference

PdfIndexedPageReference Class
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference.PageIndex Property

PdfIndexedPageReferencePageIndex Property

Sets or gets the page index

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageIndex { get; set; }
Public Property PageIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PdfIndexedPageReference Class
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference.ReferenceType Property

PdfIndexedPageReferenceReferenceType Property

Gets the PdfPageReferenceType for this PdfPageReference object

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfPageReferenceType ReferenceType { get; }
Public Overrides ReadOnly Property ReferenceType As PdfPageReferenceType
    Get

Property Value

Type: PdfPageReferenceType
Always returns PdfPageReferenceType.Indexed
See Also

Reference

PdfIndexedPageReference Class
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference Methods

The PdfIndexedPageReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfIndexedPageReference Class
Atalasoft.PdfDoc Namespace


PdfIndexedPageReference.GetObjectData Method

PdfIndexedPageReferenceGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PdfIndexedPageReference Class
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Class

PdfJavaScriptAction represents an action taken that will cause JavaScript code to be executed.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDocPdfJavaScriptAction

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfJavaScriptAction : PdfAction,
    ISerializable
<SerializableAttribute>
Public Class PdfJavaScriptAction
    Inherits PdfAction
    Implements ISerializable

The PdfJavaScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfJavaScriptAction | Initializes a new instance of the PdfJavaScriptAction class.
Public method | PdfJavaScriptAction(String) | Initializes a new instance of the PdfJavaScriptAction class.
Protected method | PdfJavaScriptAction(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfJavaScriptAction class.
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object (Overrides PdfActionActionType.)
Public property | Code | Gets or sets the JavaScript code for the action.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
Remarks
The number of things that can be done via a JavaScript action are fairly extensive. Please refer to the Acrobat JavaScript Scripting Reference for more information.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Constructor

Overload List
 | Name | Description
Public method | PdfJavaScriptAction | Initializes a new instance of the PdfJavaScriptAction class.
Public method | PdfJavaScriptAction(String) | Initializes a new instance of the PdfJavaScriptAction class.
Protected method | PdfJavaScriptAction(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfJavaScriptAction class.
Top
See Also

Reference

PdfJavaScriptAction Class
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Constructor

Initializes a new instance of the PdfJavaScriptAction class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptAction()
Public Sub New
See Also

Reference

PdfJavaScriptAction Class
PdfJavaScriptAction Overload
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Constructor (String)

Initializes a new instance of the PdfJavaScriptAction class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptAction(
    string code
)
Public Sub New (
    code As String
)

Parameters

code
Type: SystemString
The code.
See Also

Reference

PdfJavaScriptAction Class
PdfJavaScriptAction Overload
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfJavaScriptAction class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfJavaScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

PdfJavaScriptAction Class
PdfJavaScriptAction Overload
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Properties

The PdfJavaScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object (Overrides PdfActionActionType.)
Public property | Code | Gets or sets the JavaScript code for the action.
Top
See Also

Reference

PdfJavaScriptAction Class
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction.ActionType Property

PdfJavaScriptActionActionType Property

Gets the type of the action represented by this object

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfJavaScriptAction Class
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction.Code Property

PdfJavaScriptActionCode Property

Gets or sets the JavaScript code for the action.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set

Property Value

Type: String
The code.
See Also

Reference

PdfJavaScriptAction Class
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction Methods

The PdfJavaScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfJavaScriptAction Class
Atalasoft.PdfDoc Namespace


PdfJavaScriptAction.GetObjectData Method

PdfJavaScriptActionGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PdfJavaScriptAction Class
Atalasoft.PdfDoc Namespace


PdfPage Class

PdfPage is a class that represents a single page within a PDF Document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocBasePage
Atalasoft.PdfDocPdfPage

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfPage : BasePage
Public Class PdfPage
    Inherits BasePage

The PdfPage type exposes the following members.

Properties
 | Name | Description
Public property | Frame | Gets the page index for this page
Public property | Rotation | Gets or sets the rotation for the page.
Public property | Stream | Gets the stream from which this page was constructed
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
PdfPage objects aren't constructed by client code. They are created when a PdfDocument has been constructed.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPage Properties

The PdfPage type exposes the following members.

Properties
 | Name | Description
Public property | Frame | Gets the page index for this page
Public property | Rotation | Gets or sets the rotation for the page.
Public property | Stream | Gets the stream from which this page was constructed
Top
See Also

Reference

PdfPage Class
Atalasoft.PdfDoc Namespace


PdfPage.Frame Property

PdfPageFrame Property

Gets the page index for this page

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Frame { get; }
Public ReadOnly Property Frame As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfPage Class
Atalasoft.PdfDoc Namespace


PdfPage.Rotation Property

PdfPageRotation Property

Gets or sets the rotation for the page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageRotation Rotation { get; set; }
Public Property Rotation As PdfPageRotation
    Get
    Set

Property Value

Type: PdfPageRotation
The rotation for the page in 90 degree increments.
See Also

Reference

PdfPage Class
Atalasoft.PdfDoc Namespace


PdfPage.Stream Property

PdfPageStream Property

Gets the stream from which this page was constructed

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get

Property Value

Type: Stream
See Also

Reference

PdfPage Class
Atalasoft.PdfDoc Namespace


PdfPage Methods

The PdfPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfPage Class
Atalasoft.PdfDoc Namespace


PdfPageBox Enumeration

The set of names of bounding boxes that define view/scale areas.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPageBox
Public Enumeration PdfPageBox
Members
Member name | Description
CropBox | The crop box.
MediaBox | The media box - the size of the physical media for the page.
BleedBox | The bleed box - the paper area that will used for clipping in a production environment.
TrimBox | The trim box - the intended dimensions of the page after trimming.
ArtBox | The art box - the area in which the meaningful content is contained.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPageDisplayMode Enumeration

Defines an additional view to be displayed with a PDF page in a viewer.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPageDisplayMode
Public Enumeration PdfPageDisplayMode
Members
Member name | Description
None | No additional views specified (viewer default).
Bookmarks | Show the Bookmark tree.
Thumbnails | Show the page thumbnail images
FullScreen | Show full screen
OptionalContent | Show optional content
Attachments | Show attachments
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPageFitMode Enumeration

Describes view modes for a document

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPageFitMode
Public Enumeration PdfPageFitMode
Members
Member name | Description
PointZoom | The view of the document will center on a specified point and a specified zoom
FitPage | The view will contain the entire page
FitWidth | The view will contain the document scaled so that the width fills the view
FitHeight | The view will contain the document scaled so that the height fills the view
FitRectangle | The view will contain a specific rectangle
FitBounds | The view will contain the page bounding box
FitBoundsWidth | The view will contain the page bounding box scaled to fit its width
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPageReference Class

PdfPageReference is an abstract class that is used to refer to pages within a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfPageReference
Atalasoft.PdfDocPdfIndexedPageReference

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class PdfPageReference
<SerializableAttribute>
Public MustInherit Class PdfPageReference

The PdfPageReference type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfPageReference | Initializes a new instance of the PdfPageReference class
Top
Properties
 | Name | Description
Public property | ReferenceType | Gets the PdfPageReferenceType for this object
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPageReference Constructor

Initializes a new instance of the PdfPageReference class

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfPageReference()
Protected Sub New
See Also

Reference

PdfPageReference Class
Atalasoft.PdfDoc Namespace


PdfPageReference Properties

The PdfPageReference type exposes the following members.

Properties
 | Name | Description
Public property | ReferenceType | Gets the PdfPageReferenceType for this object
Top
See Also

Reference

PdfPageReference Class
Atalasoft.PdfDoc Namespace


PdfPageReference.ReferenceType Property

PdfPageReferenceReferenceType Property

Gets the PdfPageReferenceType for this object

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract PdfPageReferenceType ReferenceType { get; }
Public MustOverride ReadOnly Property ReferenceType As PdfPageReferenceType
    Get

Property Value

Type: PdfPageReferenceType
See Also

Reference

PdfPageReference Class
Atalasoft.PdfDoc Namespace


PdfPageReference Methods

The PdfPageReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfPageReference Class
Atalasoft.PdfDoc Namespace


PdfPageReferenceType Enumeration

Defines the possible types of page references

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPageReferenceType
Public Enumeration PdfPageReferenceType
Members
Member name | Description
Indexed | Pages will be referenced by a 0-based index
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPageRotation Enumeration

An enum representing possible rotations of a PDF page for display. Several of the values overlap for convenience. For example, Clockwise180 and CounterClockwise180 are identical.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPageRotation
Public Enumeration PdfPageRotation
Members
Member name | Description
None | The page will not be rotated.
Clockwise90 | The page will be rotated 90 degrees clockwise
Clockwise180 | The page will be rotated 180 degrees clockwise
Clockwise270 | The page will be rotated 270 degrees clockwise
CounterClockwise90 | The page will be rotated 90 degrees counter clockwise (equivalent to Clockwise270)
CounterClockwise180 | The page will be rotated 180 degrees counter clockwise (equivalent to Clockwise180)
CounterClockwise270 | The page will be rotated 270 degrees counter clockwise (equivalent to Clockwise90)
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPageSavedHandler Delegate

The delegate which is called when a single-page document is saved and the corresponding stream is about to be closed.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void PdfPageSavedHandler(
    Stream pageStream,
    int pageIndex
)
Public Delegate Sub PdfPageSavedHandler (
    pageStream As Stream,
    pageIndex As Integer
)

Parameters

pageStream
Type: System.IOStream
The stream containing a single-page document.
pageIndex
Type: SystemInt32
Index of the page.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfParseException Class

An exception from DotPdf
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDocPdfParseException

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfParseException : PdfException
<SerializableAttribute>
Public Class PdfParseException
    Inherits PdfException

The PdfParseException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfParseException | Initializes a new instance of the PdfParseException class.
Public method | PdfParseException(String) | Initializes a new instance of the PdfParseException class.
Protected method | PdfParseException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfParseException class.
Public method | PdfParseException(String, Exception) | Initializes a new instance of the PdfParseException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfParseException Constructor

Overload List
 | Name | Description
Public method | PdfParseException | Initializes a new instance of the PdfParseException class.
Public method | PdfParseException(String) | Initializes a new instance of the PdfParseException class.
Protected method | PdfParseException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfParseException class.
Public method | PdfParseException(String, Exception) | Initializes a new instance of the PdfParseException class.
Top
See Also

Reference

PdfParseException Class
Atalasoft.PdfDoc Namespace


PdfParseException Constructor

Initializes a new instance of the PdfParseException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfParseException()
Public Sub New
See Also

Reference

PdfParseException Class
PdfParseException Overload
Atalasoft.PdfDoc Namespace


PdfParseException Constructor (String)

Initializes a new instance of the PdfParseException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfParseException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfParseException Class
PdfParseException Overload
Atalasoft.PdfDoc Namespace


PdfParseException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfParseException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfParseException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfParseException Class
PdfParseException Overload
Atalasoft.PdfDoc Namespace


PdfParseException Constructor (String, Exception)

Initializes a new instance of the PdfParseException class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfParseException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfParseException Class
PdfParseException Overload
Atalasoft.PdfDoc Namespace


PdfParseException Properties

The PdfParseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfParseException Class
Atalasoft.PdfDoc Namespace


PdfParseException Methods

The PdfParseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfParseException Class
Atalasoft.PdfDoc Namespace


PdfParseException Events

The PdfParseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfParseException Class
Atalasoft.PdfDoc Namespace


PdfPostFullScreenPageDisplayMode Enumeration

Defines the additional views that should be present when a user switches a document from full-screen view to a windowed view.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPostFullScreenPageDisplayMode
Public Enumeration PdfPostFullScreenPageDisplayMode
Members
Member name | Description
None | No additional views specified (viewer default).
Bookmarks | Show the Bookmark tree.
Thumbnails | Show the page thumbnail images
OptionalContent | Show optional content
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfPrintingMode Enumeration

Defines how single/multi-sided printing is done.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfPrintingMode
Public Enumeration PdfPrintingMode
Members
Member name | Description
OneSided | Print with one PDF page per sheet of paper
TwoSidedFlipShortEdge | Print two sided and flip the pages along the short edge. This is also known as tumble duplex.
TwoSidedFlipLongEdge | print two sided and flip the pages along the long edge. This is also known as no tumble duplex.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfReadingOrder Enumeration

Defines the dominant reading order for a document. This will affect how pages are displayed in a multi-page view as well as the tab order for annotations on a page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfReadingOrder
Public Enumeration PdfReadingOrder
Members
Member name | Description
LeftToRight | Left to right reading order
RightToLeft | Right to left reading order
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfSaveOptions Class

The options for saving a pdf document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfSaveOptions

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfSaveOptions
Public Class PdfSaveOptions

The PdfSaveOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PdfSaveOptions | Initializes a new instance of the PdfSaveOptions class.
Top
Properties
 | Name | Description
Public property | Linearized | Gets or sets a value indicating whether the PDF document will be saved as linearized.
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to use for saving the document. This parameter may be .
Public property | PdfASavingBehavior | Gets or sets a value that determines the behavior of PdfDocument when it saves a PDF/A document.
Public property | UseCompressedObjectStreams | Gets or sets a value indicating whether the PDF document contains compressed object streams.
Public property | UserPassword | Obsolete. Gets or sets the user password to use for saving the document. This parameter may be .
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetOneTimePasswords | Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ObjectCannotBeSaved | Occurs when PDF object cannot be written to the document
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfSaveOptions Constructor

Initializes a new instance of the PdfSaveOptions class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSaveOptions()
Public Sub New
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions Properties

The PdfSaveOptions type exposes the following members.

Properties
 | Name | Description
Public property | Linearized | Gets or sets a value indicating whether the PDF document will be saved as linearized.
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to use for saving the document. This parameter may be .
Public property | PdfASavingBehavior | Gets or sets a value that determines the behavior of PdfDocument when it saves a PDF/A document.
Public property | UseCompressedObjectStreams | Gets or sets a value indicating whether the PDF document contains compressed object streams.
Public property | UserPassword | Obsolete. Gets or sets the user password to use for saving the document. This parameter may be .
Top
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.Linearized Property

PdfSaveOptionsLinearized Property

Gets or sets a value indicating whether the PDF document will be saved as linearized.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Linearized { get; set; }
Public Property Linearized As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.OwnerPassword Property

PdfSaveOptionsOwnerPassword Property

Note: This API is now obsolete.

Gets or sets the owner password to use for saving the document. This parameter may be .

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.PdfASavingBehavior Property

PdfSaveOptionsPdfASavingBehavior Property

Gets or sets a value that determines the behavior of PdfDocument when it saves a PDF/A document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfASavingBehavior PdfASavingBehavior { get; set; }
Public Property PdfASavingBehavior As PdfASavingBehavior
    Get
    Set

Property Value

Type: PdfASavingBehavior
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.UseCompressedObjectStreams Property

PdfSaveOptionsUseCompressedObjectStreams Property

Gets or sets a value indicating whether the PDF document contains compressed object streams.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseCompressedObjectStreams { get; set; }
Public Property UseCompressedObjectStreams As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks

PDF/A-1 does not support compressed object streams.

PdfDocument does not support compressed object streams in linearized PDF.

See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.UserPassword Property

PdfSaveOptionsUserPassword Property

Note: This API is now obsolete.

Gets or sets the user password to use for saving the document. This parameter may be .

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions Methods

The PdfSaveOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetOneTimePasswords | Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after usage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.SetOneTimePasswords Method

PdfSaveOptionsSetOneTimePasswords Method

Sets user and owner passwords and generates one-time keys for saving encrypted PDF document. Keys will be reset after usage.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetOneTimePasswords(
    SecureString userPassword,
    SecureString ownerPassword = null,
    PdfAccessPermissions permissions = PdfAccessPermissions.Default,
    bool encryptMetadata = true
)
Public Sub SetOneTimePasswords (
    userPassword As SecureString,
    Optional ownerPassword As SecureString = Nothing,
    Optional permissions As PdfAccessPermissions = PdfAccessPermissions.Default,
    Optional encryptMetadata As Boolean = true
)

Parameters

userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password.
permissions (Optional)
Type: Atalasoft.PdfDocPdfAccessPermissions
The set of allowable actions for PDF document.
encryptMetadata (Optional)
Type: SystemBoolean
a boolean indicating that metadata stream should be encrypted. Ignored for PDF version below 2.0.
Remarks

PDF documents have two passwords associated with them, a user password and an owner password. If an encrypted document is opened by a conforming reader using the owner password, then the security Permissions are ignored. If an encrypted document is opened by a conforming reader using the user password, then the security Permissions are enforced. When a document is created with only one password or one unique password, it is considered the same as having only an owner password.

PDF/A standard does not support encryption and password-protected access permissions.

See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions Events

The PdfSaveOptions type exposes the following members.

Events
 | Name | Description
Public event | ObjectCannotBeSaved | Occurs when PDF object cannot be written to the document
Top
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfSaveOptions.ObjectCannotBeSaved Event

PdfSaveOptionsObjectCannotBeSaved Event

Occurs when PDF object cannot be written to the document

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ObjectCannotBeSavedEventArg> ObjectCannotBeSaved
Public Event ObjectCannotBeSaved As EventHandler(Of ObjectCannotBeSavedEventArg)

Value

Type: SystemEventHandlerObjectCannotBeSavedEventArg
See Also

Reference

PdfSaveOptions Class
Atalasoft.PdfDoc Namespace


PdfStreamCreator Delegate

The delegate for PdfStream creation events.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate Stream PdfStreamCreator(
    Stream originalStream,
    int pageIndex
)
Public Delegate Function PdfStreamCreator (
    originalStream As Stream,
    pageIndex As Integer
) As Stream

Parameters

originalStream
Type: System.IOStream
The original stream.
pageIndex
Type: SystemInt32
Index of the page.

Return Value

Type: Stream
A new stream.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfTabOrder Enumeration

Defines the order in with annotations should be navigated on a page.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTabOrder
Public Enumeration PdfTabOrder
Members
Member name | Description
None | Navigation is up to viewer discretion
Row | Navigation is done in rows across the page. The order of navigation within a row is determined by the the ReadingOrder property in the PdfViewerPreferences object.
Column | Navigation is done in Columns up and down the page. The order of navigation within a row is determined by the the ReadingOrder property in the PdfViewerPreferences object.
Structure | Navigation is done according to the structure tree. Not currently supported.
Unknown | Unspecified order. Results are not documented. Not currently supported.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfToDpcmCoordinateConverter Class

This class converts coordinates from PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively) to conventional image space (values measured in Dots Per cm (Pixels Per cm) with the origin in the upper left corner and X and Y extending to the right and down respectively).
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfCoordinateConverter
Atalasoft.PdfDocPdfToDpiCoordinateConverter
Atalasoft.PdfDocPdfToDpcmCoordinateConverter

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfToDpcmCoordinateConverter : PdfToDpiCoordinateConverter
Public Class PdfToDpcmCoordinateConverter
    Inherits PdfToDpiCoordinateConverter

The PdfToDpcmCoordinateConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PdfToDpcmCoordinateConverter(Double, Size) | Constructs a new converter object with the specified target resolution in dots per cm and the specified source page size in PDF units.
Public method | PdfToDpcmCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified target resolution in dots per cm and the specified source page size in PDF units.
Top
Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfToDpcmCoordinateConverter Constructor

Constructs a new converter from PDF page units to dots per cm.
Constructs a new converter from PDF page units to dots per cm.
Overload List
 | Name | Description
Public method | PdfToDpcmCoordinateConverter(Double, Size) | Constructs a new converter object with the specified target resolution in dots per cm and the specified source page size in PDF units.
Public method | PdfToDpcmCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified target resolution in dots per cm and the specified source page size in PDF units.
Top
See Also

Reference

PdfToDpcmCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfToDpcmCoordinateConverter Constructor (Double, Size)

Constructs a new converter object with the specified target resolution in dots per cm and the specified source page size in PDF units.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfToDpcmCoordinateConverter(
    double dpcm,
    Size pageSize
)
Public Sub New (
    dpcm As Double,
    pageSize As Size
)

Parameters

dpcm
Type: SystemDouble
The resolution of the source space in pixels or dots per cm.
pageSize
Type: System.DrawingSize
The size of the source space in PDF page units (1/72 of an inch)
See Also

Reference

PdfToDpcmCoordinateConverter Class
PdfToDpcmCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


PdfToDpcmCoordinateConverter Constructor (Double, SizeF)

Constructs a new converter object with the specified target resolution in dots per cm and the specified source page size in PDF units.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfToDpcmCoordinateConverter(
    double dpcm,
    SizeF pageSize
)
Public Sub New (
    dpcm As Double,
    pageSize As SizeF
)

Parameters

dpcm
Type: SystemDouble
The resolution of the source space in pixels or dots per cm.
pageSize
Type: System.DrawingSizeF
The size of the source space in PDF page units (1/72 of an inch)
See Also

Reference

PdfToDpcmCoordinateConverter Class
PdfToDpcmCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


PdfToDpcmCoordinateConverter Methods

The PdfToDpcmCoordinateConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfToDpcmCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfToDpiCoordinateConverter Class

This class converts coordinates from PDF coordinate space (values measured in 1/72 inch with the origin in the lower left of the page and X and Y extending to the right and up respectively) to conventional image space (values measured in Dots Per inch (Pixels Per inch) with the origin in the upper left corner and X and Y extending to the right and down respectively).
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfCoordinateConverter
Atalasoft.PdfDocPdfToDpiCoordinateConverter
Atalasoft.PdfDocPdfToDpcmCoordinateConverter

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfToDpiCoordinateConverter : PdfCoordinateConverter
Public Class PdfToDpiCoordinateConverter
    Inherits PdfCoordinateConverter

The PdfToDpiCoordinateConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PdfToDpiCoordinateConverter(Double, Size) | Constructs a new converter object with the specified target resolution in dots per inch and the specified source page size in PDF units.
Public method | PdfToDpiCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified target resolution in dots per inch and the specified source page size in PDF units.
Top
Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfToDpiCoordinateConverter Constructor

Constructs a new converter from PDF page units to dots per inch.
Constructs a new converter from PDF page units to dots per inch.
Overload List
 | Name | Description
Public method | PdfToDpiCoordinateConverter(Double, Size) | Constructs a new converter object with the specified target resolution in dots per inch and the specified source page size in PDF units.
Public method | PdfToDpiCoordinateConverter(Double, SizeF) | Constructs a new converter object with the specified target resolution in dots per inch and the specified source page size in PDF units.
Top
See Also

Reference

PdfToDpiCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfToDpiCoordinateConverter Constructor (Double, Size)

Constructs a new converter object with the specified target resolution in dots per inch and the specified source page size in PDF units.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfToDpiCoordinateConverter(
    double dpi,
    Size pageSize
)
Public Sub New (
    dpi As Double,
    pageSize As Size
)

Parameters

dpi
Type: SystemDouble
The resolution of the source space in pixels or dots per inch.
pageSize
Type: System.DrawingSize
The size of the source space in PDF page units (1/72 of an inch)
See Also

Reference

PdfToDpiCoordinateConverter Class
PdfToDpiCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


PdfToDpiCoordinateConverter Constructor (Double, SizeF)

Constructs a new converter object with the specified target resolution in dots per inch and the specified source page size in PDF units.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfToDpiCoordinateConverter(
    double dpi,
    SizeF pageSize
)
Public Sub New (
    dpi As Double,
    pageSize As SizeF
)

Parameters

dpi
Type: SystemDouble
The resolution of the source space in pixels or dots per inch.
pageSize
Type: System.DrawingSizeF
The size of the source space in PDF page units (1/72 of an inch)
See Also

Reference

PdfToDpiCoordinateConverter Class
PdfToDpiCoordinateConverter Overload
Atalasoft.PdfDoc Namespace


PdfToDpiCoordinateConverter Methods

The PdfToDpiCoordinateConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert(Point) | Converts a Point from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(PointF) | Converts a PointF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(Rectangle) | Converts a Rectangle from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Convert(RectangleF) | Converts a RectangleF from one coordinate space to another (Inherited from PdfCoordinateConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfToDpiCoordinateConverter Class
Atalasoft.PdfDoc Namespace


PdfTrapSetting Enumeration

An enumeration used to indicate the trapping information in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTrapSetting
Public Enumeration PdfTrapSetting
Members
Member name | Description
None | No setting - no entry will be placed in the PDF document.
False | The document has not yet been trapped.
True | The document has been fully trapped
Unknown | Either the document has not yet been trapped or has not yet been fully trapped.
Remarks
For more details, see the PDF Reference, section 10.10.5, "Trapping Support"
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfUnknownAction Class

PdfUnknownAction is a concrete representation of PdfActions that do not map to any other concrete PdfAction class.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDocPdfUnknownAction

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfUnknownAction : PdfAction
Public Class PdfUnknownAction
    Inherits PdfAction

The PdfUnknownAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the PDF action type associated with this action (Overrides PdfActionActionType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
Remarks
PDF has a number of valid actions that are not yet available in dotImage. They are represented publicly as PdfUnknownAction and encapsulate all the original information of the PDF action in this opaque object. Client code cannot construct PdfUnknownAction objects directly.
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfUnknownAction Properties

The PdfUnknownAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the PDF action type associated with this action (Overrides PdfActionActionType.)
Top
See Also

Reference

PdfUnknownAction Class
Atalasoft.PdfDoc Namespace


PdfUnknownAction.ActionType Property

PdfUnknownActionActionType Property

Gets the PDF action type associated with this action

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfUnknownAction Class
Atalasoft.PdfDoc Namespace


PdfUnknownAction Methods

The PdfUnknownAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfUnknownAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction Class

An action that pdf documents can be made to take upon load
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDocPdfURIAction

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfURIAction : PdfAction,
    ISerializable
<SerializableAttribute>
Public Class PdfURIAction
    Inherits PdfAction
    Implements ISerializable

The PdfURIAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfURIAction(Uri) | Initializes a new instance of the PdfURIAction class.
Protected method | PdfURIAction(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfURIAction class.
Public method | PdfURIAction(Uri, Uri, Boolean) | Initializes a new instance of the PdfURIAction class.
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object (Overrides PdfActionActionType.)
Public property | Base | Gets or sets the base.
Public property | IsMap | Gets or sets a value indicating whether this instance is map.
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfURIAction Constructor

Overload List
 | Name | Description
Public method | PdfURIAction(Uri) | Initializes a new instance of the PdfURIAction class.
Protected method | PdfURIAction(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfURIAction class.
Public method | PdfURIAction(Uri, Uri, Boolean) | Initializes a new instance of the PdfURIAction class.
Top
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction Constructor (Uri)

Initializes a new instance of the PdfURIAction class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfURIAction(
    Uri uri
)
Public Sub New (
    uri As Uri
)

Parameters

uri
Type: SystemUri
The URI.
See Also

Reference

PdfURIAction Class
PdfURIAction Overload
Atalasoft.PdfDoc Namespace


PdfURIAction Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfURIAction class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfURIAction(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

PdfURIAction Class
PdfURIAction Overload
Atalasoft.PdfDoc Namespace


PdfURIAction Constructor (Uri, Uri, Boolean)

Initializes a new instance of the PdfURIAction class.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfURIAction(
    Uri uri,
    Uri baseUri,
    bool isMap
)
Public Sub New (
    uri As Uri,
    baseUri As Uri,
    isMap As Boolean
)

Parameters

uri
Type: SystemUri
The URI.
baseUri
Type: SystemUri
The base URI.
isMap
Type: SystemBoolean
if set to true [is map].
See Also

Reference

PdfURIAction Class
PdfURIAction Overload
Atalasoft.PdfDoc Namespace


PdfURIAction Properties

The PdfURIAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object (Overrides PdfActionActionType.)
Public property | Base | Gets or sets the base.
Public property | IsMap | Gets or sets a value indicating whether this instance is map.
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction.ActionType Property

PdfURIActionActionType Property

Gets the type of the action represented by this object

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction.Base Property

PdfURIActionBase Property

Gets or sets the base.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Uri Base { get; set; }
Public Property Base As Uri
    Get
    Set

Property Value

Type: Uri
The base.
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction.IsMap Property

PdfURIActionIsMap Property

Gets or sets a value indicating whether this instance is map.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMap { get; set; }
Public Property IsMap As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is map; otherwise, false.
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction.URI Property

PdfURIActionURI Property

Gets or sets the URI.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Uri URI { get; set; }
Public Property URI As Uri
    Get
    Set

Property Value

Type: Uri
The URI.
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction Methods

The PdfURIAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfURIAction.GetObjectData Method

PdfURIActionGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

PdfURIAction Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences Class

PdfViewerPreferences represents document-specific preferences that are applied to the document viewer. It should be noted that not all PDF viewers will honor all settings and the behaviors may not be consistent across viewers.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfViewerPreferences

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfViewerPreferences : IValidatable
Public Class PdfViewerPreferences
    Implements IValidatable

The PdfViewerPreferences type exposes the following members.

Constructors
 | Name | Description
Public method | PdfViewerPreferences | Initializes a new instance of the PdfViewerPreferences class with default settings.
Top
Properties
 | Name | Description
Public property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered.
Public property | CopiesToPrint | Gets or sets the number of copies of the document to print. The value must be greater than 0.
Public property | DisplayDocumentTitle | Gets or sets a value indicating whether the window's title should display the document title from the document's PdfDocumentMetadata object.
Public property | FitWindowToInitialPage | Gets or sets a value indicating whether the document's window should be sized to fit the initial page size.
Public property | HideMenubar | Gets or sets a value indicating whether the viewer should hide its menu bar (if any) when displaying the document.
Public property | HideToolbar | Gets or sets a value indicating whether the viewer should hide its toolbar (if any) when displaying the document.
Public property | HideWindowDressing | Gets or sets a value indicating whether the viewer should hide window UI controls such as scroll bars snd navigation tools when displaying the document.
Public property | PostFullScreenPageDisplayMode | Gets or sets the page view mode that will be used when the viewer is siwtched out of full screen viewing.
Public property | PrintingArea | Gets or sets the box to use as a printing area for pages in the document.
Public property | PrintingMode | Gets or sets the printing mode for the document in terms of whether printing should be one-sided or two-sided and if two-sided, what the relationship between front and back pages should be.
Public property | PrintingVisibleArea | Gets or sets the box to use as a printing visible area for pages in the document.
Public property | PrintPageRanges | Gets the page ranges for printing. Each pair represents a sub-range of pages within the document to be printed. The ranges are 0-based and refer to page indexes in the document.
Public property | PrintScaling | Gets or sets the print scaling for the viewer. There are currently two useful values for this property: "None" and "AppDefault". The PDF specification does not offer any suggestion for what the value should mean other than "None" will provide no scaling.
Public property | ReadingOrder | Gets or sets the dominant reading order for the document.
Public property | SelectPaperByPageSize | Gets or sets a value indicating whether the viewing application should set the print settings to pick paper from a source that matches the page size. This will depend on the capabilities of the printer and print driver.
Public property | ViewingArea | Gets or sets the box to use as a viewing area for pages in the document.
Public property | ViewingVisibleArea | Gets or sets the box to use as the visible area for pages in the document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc Namespace


PdfViewerPreferences Constructor

Initializes a new instance of the PdfViewerPreferences class with default settings.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfViewerPreferences()
Public Sub New
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences Properties

The PdfViewerPreferences type exposes the following members.

Properties
 | Name | Description
Public property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered.
Public property | CopiesToPrint | Gets or sets the number of copies of the document to print. The value must be greater than 0.
Public property | DisplayDocumentTitle | Gets or sets a value indicating whether the window's title should display the document title from the document's PdfDocumentMetadata object.
Public property | FitWindowToInitialPage | Gets or sets a value indicating whether the document's window should be sized to fit the initial page size.
Public property | HideMenubar | Gets or sets a value indicating whether the viewer should hide its menu bar (if any) when displaying the document.
Public property | HideToolbar | Gets or sets a value indicating whether the viewer should hide its toolbar (if any) when displaying the document.
Public property | HideWindowDressing | Gets or sets a value indicating whether the viewer should hide window UI controls such as scroll bars snd navigation tools when displaying the document.
Public property | PostFullScreenPageDisplayMode | Gets or sets the page view mode that will be used when the viewer is siwtched out of full screen viewing.
Public property | PrintingArea | Gets or sets the box to use as a printing area for pages in the document.
Public property | PrintingMode | Gets or sets the printing mode for the document in terms of whether printing should be one-sided or two-sided and if two-sided, what the relationship between front and back pages should be.
Public property | PrintingVisibleArea | Gets or sets the box to use as a printing visible area for pages in the document.
Public property | PrintPageRanges | Gets the page ranges for printing. Each pair represents a sub-range of pages within the document to be printed. The ranges are 0-based and refer to page indexes in the document.
Public property | PrintScaling | Gets or sets the print scaling for the viewer. There are currently two useful values for this property: "None" and "AppDefault". The PDF specification does not offer any suggestion for what the value should mean other than "None" will provide no scaling.
Public property | ReadingOrder | Gets or sets the dominant reading order for the document.
Public property | SelectPaperByPageSize | Gets or sets a value indicating whether the viewing application should set the print settings to pick paper from a source that matches the page size. This will depend on the capabilities of the printer and print driver.
Public property | ViewingArea | Gets or sets the box to use as a viewing area for pages in the document.
Public property | ViewingVisibleArea | Gets or sets the box to use as the visible area for pages in the document.
Top
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.CenterWindow Property

PdfViewerPreferencesCenterWindow Property

Gets or sets a value indicating whether the document's window should be centered.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CenterWindow { get; set; }
Public Property CenterWindow As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document's window should be centered; otherwise, false. Default is false.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.CopiesToPrint Property

PdfViewerPreferencesCopiesToPrint Property

Gets or sets the number of copies of the document to print. The value must be greater than 0.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CopiesToPrint { get; set; }
Public Property CopiesToPrint As Integer
    Get
    Set

Property Value

Type: Int32
The number of copies to print. Default is 1.
Remarks
This requires PDF version 1.7 or greater.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.DisplayDocumentTitle Property

PdfViewerPreferencesDisplayDocumentTitle Property

Gets or sets a value indicating whether the window's title should display the document title from the document's PdfDocumentMetadata object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayDocumentTitle { get; set; }
Public Property DisplayDocumentTitle As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window's title should display the document metadata title; otherwise, false. Default is false.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.FitWindowToInitialPage Property

PdfViewerPreferencesFitWindowToInitialPage Property

Gets or sets a value indicating whether the document's window should be sized to fit the initial page size.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FitWindowToInitialPage { get; set; }
Public Property FitWindowToInitialPage As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document's window should be sized to fit the initial page size; otherwise, false. Default is false.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.HideMenubar Property

PdfViewerPreferencesHideMenubar Property

Gets or sets a value indicating whether the viewer should hide its menu bar (if any) when displaying the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HideMenubar { get; set; }
Public Property HideMenubar As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the viewer should hide its menu bar; otherwise, false. Default is false.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.HideToolbar Property

PdfViewerPreferencesHideToolbar Property

Gets or sets a value indicating whether the viewer should hide its toolbar (if any) when displaying the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HideToolbar { get; set; }
Public Property HideToolbar As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the viewer should hide the toolbar; otherwise, false. Default is false.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.HideWindowDressing Property

PdfViewerPreferencesHideWindowDressing Property

Gets or sets a value indicating whether the viewer should hide window UI controls such as scroll bars snd navigation tools when displaying the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HideWindowDressing { get; set; }
Public Property HideWindowDressing As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the viewer should hide window UI controls; otherwise, false. Default is false.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.PostFullScreenPageDisplayMode Property

PdfViewerPreferencesPostFullScreenPageDisplayMode Property

Gets or sets the page view mode that will be used when the viewer is siwtched out of full screen viewing.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPostFullScreenPageDisplayMode PostFullScreenPageDisplayMode { get; set; }
Public Property PostFullScreenPageDisplayMode As PdfPostFullScreenPageDisplayMode
    Get
    Set

Property Value

Type: PdfPostFullScreenPageDisplayMode
The post full screen view mode.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.PrintingArea Property

PdfViewerPreferencesPrintingArea Property

Gets or sets the box to use as a printing area for pages in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageBox PrintingArea { get; set; }
Public Property PrintingArea As PdfPageBox
    Get
    Set

Property Value

Type: PdfPageBox
The printing area box. Default is Crop
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.PrintingMode Property

PdfViewerPreferencesPrintingMode Property

Gets or sets the printing mode for the document in terms of whether printing should be one-sided or two-sided and if two-sided, what the relationship between front and back pages should be.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPrintingMode PrintingMode { get; set; }
Public Property PrintingMode As PdfPrintingMode
    Get
    Set

Property Value

Type: PdfPrintingMode
The printing mode for the document. Default is OneSided.
Remarks
This requires PDF version 1.6 or greater.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.PrintingVisibleArea Property

PdfViewerPreferencesPrintingVisibleArea Property

Gets or sets the box to use as a printing visible area for pages in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageBox PrintingVisibleArea { get; set; }
Public Property PrintingVisibleArea As PdfPageBox
    Get
    Set

Property Value

Type: PdfPageBox
The printing visible area box. Default is Crop
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.PrintPageRanges Property

PdfViewerPreferencesPrintPageRanges Property

Gets the page ranges for printing. Each pair represents a sub-range of pages within the document to be printed. The ranges are 0-based and refer to page indexes in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<Range<int>> PrintPageRanges { get; }
Public ReadOnly Property PrintPageRanges As IList(Of Range(Of Integer))
    Get

Property Value

Type: IListRange Int32
The print page ranges.
Remarks
This requires PDF version 1.7 or greater.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.PrintScaling Property

PdfViewerPreferencesPrintScaling Property

Gets or sets the print scaling for the viewer. There are currently two useful values for this property: "None" and "AppDefault". The PDF specification does not offer any suggestion for what the value should mean other than "None" will provide no scaling.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PrintScaling { get; set; }
Public Property PrintScaling As String
    Get
    Set

Property Value

Type: String
The print scaling. Default is "AppDefault".
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.ReadingOrder Property

PdfViewerPreferencesReadingOrder Property

Gets or sets the dominant reading order for the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfReadingOrder ReadingOrder { get; set; }
Public Property ReadingOrder As PdfReadingOrder
    Get
    Set

Property Value

Type: PdfReadingOrder
The dominant reading order. Default is LeftToRight
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.SelectPaperByPageSize Property

PdfViewerPreferencesSelectPaperByPageSize Property

Gets or sets a value indicating whether the viewing application should set the print settings to pick paper from a source that matches the page size. This will depend on the capabilities of the printer and print driver.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelectPaperByPageSize { get; set; }
Public Property SelectPaperByPageSize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the viewiing application should select paper by page size; otherwise, false. Default is false
Remarks
This requires PDF version 1.7 or greater.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.ViewingArea Property

PdfViewerPreferencesViewingArea Property

Gets or sets the box to use as a viewing area for pages in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageBox ViewingArea { get; set; }
Public Property ViewingArea As PdfPageBox
    Get
    Set

Property Value

Type: PdfPageBox
The viewing area box. Default is Crop
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.ViewingVisibleArea Property

PdfViewerPreferencesViewingVisibleArea Property

Gets or sets the box to use as the visible area for pages in the document.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageBox ViewingVisibleArea { get; set; }
Public Property ViewingVisibleArea As PdfPageBox
    Get
    Set

Property Value

Type: PdfPageBox
The viewing visible area box. Default is Crop
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences Methods

The PdfViewerPreferences type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.MakeRepairContext Method

PdfViewerPreferencesMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
Exceptions
Exception | Condition
ArgumentException | Repair context should be either a PdfDocument or a PdfGeneratedDocument.
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


PdfViewerPreferences.Validate Method

PdfViewerPreferencesValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
Exceptions
Exception | Condition
ArgumentException | repairContext
PdfException | PrintPageRanges contains a null Range at index + i
See Also

Reference

PdfViewerPreferences Class
Atalasoft.PdfDoc Namespace


Atalasoft.PdfDoc.Actions Namespace

Classes
Class Description
Public class AnnotationAdditionalActions
Represents a set of actions that are available to annotations on particular events. These actions allow the creation of interactive PDF documents.
Public class DocumentAdditionalActions
Represents a collection of sets of actions to taken at the document event level. Note that these events are to be carried out by a PDF viewing application, not by the PdfGeneratedDocument class.
PageAdditionalActions
PageAdditionalActions represent a set of actions that are performed when a page has been either opened or closed. Opening or closing a page within a PDF viewer navigates to or away from a viewable page. The PDF specification is not clear as to what will happen when a viewer supports showing multiple pages at once. When going from page to page, the OnPageClosed actions on the current page will happen before the OnPageOpened actions on the subsequent page.
Examples
Adding a sound to play when a page has been opened.
Copy
public void AddSoundToPageOpened(PdfGeneratedPage page, PdfSoundAction openSound)
{
    page.AdditionalActions.OnPageOpened.Add(openSound);
}
Public class PdfAnnotationIdentifier
This class is used to represent a reference to an annotation or form field that exists somewhere in a PDF document.
Public class PdfJavaScriptActionList
A specialized collection for JavaScript only actions
Public class PdfJavaScriptActionListCollection
This is a collection of JavaScriptActionLists that are used within a PDF when a document is opened. Upon opening, all scripts within this collection will be executed in string order of the keys. The keys themselves are unimportant and are not used for anything beyond the order of execution. The intent of this collection is to define JavaScript elements that may be used elsewhere in the document.
Public class PdfNamedAction
PdfNamedAction is a PdfAction class that is used for causing specific behaviors to occur in the PDF viewer. The PDF specification defines a number of standard navigation named actions that are to be implemented in all PDF viewers, but any named action could be defined. The standard names are: NextPageGo to the next page in the document (if there is one)PrevPageGo to the previous page in the document (if there is one)FirstPageGo to the first page in the documentLastPageGo to the last page in the document The advantage to using PdfNamedAction instead of PdfGoToViewAction is that the named actions aren't tied to a particular page so if, for example, a PushButtonWidgetAnnotation labeled "Next" has a "NextPage" action, the widget will always work correctly no matter how the pages have been ordered. This allows an author to easily put navigation buttons on pages for reading or for skipping to, say, a contents page at the beginning or an index page at the end.
Public class PdfResetFormAction
This class represents an action which will cause a PdfForm object (if any) within a PDF document to have either all or a subset of fields within it to be reset to their default values.
Public class PdfShowHideAction
PdfShowHideAction is an action that is used to show or hide one or more annotations or fields on a page.
Public class PdfSoundAction
Represents an action that will cause a sound to be played.
Public class PdfSubmitFormAction
PdfSubmitFormActions represents an action to cause the form elements in a document to be sent to a server for processing.


AnnotationAdditionalActions Class

Represents a set of actions that are available to annotations on particular events. These actions allow the creation of interactive PDF documents.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.ActionsAnnotationAdditionalActions

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationAdditionalActions : IValidatable
Public Class AnnotationAdditionalActions
    Implements IValidatable

The AnnotationAdditionalActions type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationAdditionalActions | Initializes a new instance of the AnnotationAdditionalActions class. Each action event is initialized to an empty PdfActionList
Top
Properties
 | Name | Description
Public property | OnClickDown | Gets the PdfActionList for when the mouse is clicked when the cursor is in the area of an annotation.
Public property | OnClickUp | Gets the PdfActionList for when the mouse is released after a click within the area of an annotation.
Public property | OnCursorIn | Gets the PdfActionList for when the cursor enters the area of an annotation.
Public property | OnCursorOut | Gets the PdfActionList for when the cursor leaves the area of an annotation.
Public property | OnFieldFormatting | Gets the PdfJavaScriptActionList for when a field is about to be displayed. This action may change the field's value.
Public property | OnFieldRecalculating | Gets the PdfJavaScriptActionList for when changes in other fields would require this field to be recalculated.
Public property | OnFieldValueChanging | Gets the PdfJavaScriptActionList for when a field's value is changing. This action may check for validity.
Public property | OnFocusIn | Gets the PdfActionList for when the annotation gets focus from the application.
Public property | OnFocusOut | Gets the PdfActionList for when the annotation loses focus from the application.
Public property | OnKeyDown | Gets the PdfJavaScriptActionList for when a key is entered in a text for field, a pop-up box, or a list box.
Public property | OnPageClosed | Gets the PdfActionList for when the page on which the annotation appears is closed.
Public property | OnPageInView | Gets the PdfActionList for when the page on which the annotation appears comes into view.
Public property | OnPageOpened | Gets the PdfActionList for when the page on which the annotation appears is opened.
Public property | OnPageOutOfView | Gets the PdfActionList for when the page on which the annotation appears moves out of view.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines whether all PdfActionList objects are empty.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the class and adds to the problem list.
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions Constructor

Initializes a new instance of the AnnotationAdditionalActions class. Each action event is initialized to an empty PdfActionList

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationAdditionalActions()
Public Sub New
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions Properties

The AnnotationAdditionalActions type exposes the following members.

Properties
 | Name | Description
Public property | OnClickDown | Gets the PdfActionList for when the mouse is clicked when the cursor is in the area of an annotation.
Public property | OnClickUp | Gets the PdfActionList for when the mouse is released after a click within the area of an annotation.
Public property | OnCursorIn | Gets the PdfActionList for when the cursor enters the area of an annotation.
Public property | OnCursorOut | Gets the PdfActionList for when the cursor leaves the area of an annotation.
Public property | OnFieldFormatting | Gets the PdfJavaScriptActionList for when a field is about to be displayed. This action may change the field's value.
Public property | OnFieldRecalculating | Gets the PdfJavaScriptActionList for when changes in other fields would require this field to be recalculated.
Public property | OnFieldValueChanging | Gets the PdfJavaScriptActionList for when a field's value is changing. This action may check for validity.
Public property | OnFocusIn | Gets the PdfActionList for when the annotation gets focus from the application.
Public property | OnFocusOut | Gets the PdfActionList for when the annotation loses focus from the application.
Public property | OnKeyDown | Gets the PdfJavaScriptActionList for when a key is entered in a text for field, a pop-up box, or a list box.
Public property | OnPageClosed | Gets the PdfActionList for when the page on which the annotation appears is closed.
Public property | OnPageInView | Gets the PdfActionList for when the page on which the annotation appears comes into view.
Public property | OnPageOpened | Gets the PdfActionList for when the page on which the annotation appears is opened.
Public property | OnPageOutOfView | Gets the PdfActionList for when the page on which the annotation appears moves out of view.
Top
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnClickDown Property

AnnotationAdditionalActionsOnClickDown Property

Gets the PdfActionList for when the mouse is clicked when the cursor is in the area of an annotation.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnClickDown { get; }
Public ReadOnly Property OnClickDown As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnClickUp Property

AnnotationAdditionalActionsOnClickUp Property

Gets the PdfActionList for when the mouse is released after a click within the area of an annotation.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnClickUp { get; }
Public ReadOnly Property OnClickUp As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnCursorIn Property

AnnotationAdditionalActionsOnCursorIn Property

Gets the PdfActionList for when the cursor enters the area of an annotation.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnCursorIn { get; }
Public ReadOnly Property OnCursorIn As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnCursorOut Property

AnnotationAdditionalActionsOnCursorOut Property

Gets the PdfActionList for when the cursor leaves the area of an annotation.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnCursorOut { get; }
Public ReadOnly Property OnCursorOut As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnFieldFormatting Property

AnnotationAdditionalActionsOnFieldFormatting Property

Gets the PdfJavaScriptActionList for when a field is about to be displayed. This action may change the field's value.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionList OnFieldFormatting { get; }
Public ReadOnly Property OnFieldFormatting As PdfJavaScriptActionList
    Get

Property Value

Type: PdfJavaScriptActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnFieldRecalculating Property

AnnotationAdditionalActionsOnFieldRecalculating Property

Gets the PdfJavaScriptActionList for when changes in other fields would require this field to be recalculated.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionList OnFieldRecalculating { get; }
Public ReadOnly Property OnFieldRecalculating As PdfJavaScriptActionList
    Get

Property Value

Type: PdfJavaScriptActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnFieldValueChanging Property

AnnotationAdditionalActionsOnFieldValueChanging Property

Gets the PdfJavaScriptActionList for when a field's value is changing. This action may check for validity.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionList OnFieldValueChanging { get; }
Public ReadOnly Property OnFieldValueChanging As PdfJavaScriptActionList
    Get

Property Value

Type: PdfJavaScriptActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnFocusIn Property

AnnotationAdditionalActionsOnFocusIn Property

Gets the PdfActionList for when the annotation gets focus from the application.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnFocusIn { get; }
Public ReadOnly Property OnFocusIn As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnFocusOut Property

AnnotationAdditionalActionsOnFocusOut Property

Gets the PdfActionList for when the annotation loses focus from the application.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnFocusOut { get; }
Public ReadOnly Property OnFocusOut As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnKeyDown Property

AnnotationAdditionalActionsOnKeyDown Property

Gets the PdfJavaScriptActionList for when a key is entered in a text for field, a pop-up box, or a list box.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionList OnKeyDown { get; }
Public ReadOnly Property OnKeyDown As PdfJavaScriptActionList
    Get

Property Value

Type: PdfJavaScriptActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnPageClosed Property

AnnotationAdditionalActionsOnPageClosed Property

Gets the PdfActionList for when the page on which the annotation appears is closed.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnPageClosed { get; }
Public ReadOnly Property OnPageClosed As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnPageInView Property

AnnotationAdditionalActionsOnPageInView Property

Gets the PdfActionList for when the page on which the annotation appears comes into view.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnPageInView { get; }
Public ReadOnly Property OnPageInView As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnPageOpened Property

AnnotationAdditionalActionsOnPageOpened Property

Gets the PdfActionList for when the page on which the annotation appears is opened.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnPageOpened { get; }
Public ReadOnly Property OnPageOpened As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.OnPageOutOfView Property

AnnotationAdditionalActionsOnPageOutOfView Property

Gets the PdfActionList for when the page on which the annotation appears moves out of view.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnPageOutOfView { get; }
Public ReadOnly Property OnPageOutOfView As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions Methods

The AnnotationAdditionalActions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines whether all PdfActionList objects are empty.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the class and adds to the problem list.
Top
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.IsEmpty Method

AnnotationAdditionalActionsIsEmpty Method

Determines whether all PdfActionList objects are empty.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
true if all actions lists are empty; otherwise, false.
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.MakeRepairContext Method

AnnotationAdditionalActionsMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


AnnotationAdditionalActions.Validate Method

AnnotationAdditionalActionsValidate Method

Validates the class and adds to the problem list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context for this class.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

AnnotationAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions Class

Represents a collection of sets of actions to taken at the document event level. Note that these events are to be carried out by a PDF viewing application, not by the PdfGeneratedDocument class.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.ActionsDocumentAdditionalActions

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentAdditionalActions : IValidatable
Public Class DocumentAdditionalActions
    Implements IValidatable

The DocumentAdditionalActions type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentAdditionalActions | Initializes a new instance of the DocumentAdditionalActions class. All actions will be set to new empty lists.
Top
Properties
 | Name | Description
Public property | OnDocumentClosing | Gets the actions to be performed when a document will be closed. This is initialized to an empty list.
Public property | OnDocumentOpened | Gets the actions to be performed when a document has been opened. This is initialized to an empty list.
Public property | OnDocumentPrinted | Gets the actions to be performed when a document has been printed. This is initialized to an empty list.
Public property | OnDocumentPrinting | Gets the actions to be performed when a document will be printed. This is initialized to an empty list.
Public property | OnDocumentSaved | Gets the actions to be performed when a document has been saved. This is initialized to an empty list.
Public property | OnDocumentSaving | Gets the actions to be performed when a document will be saved. This is initialized to an empty list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines whether all action lists are empty.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions Constructor

Initializes a new instance of the DocumentAdditionalActions class. All actions will be set to new empty lists.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentAdditionalActions()
Public Sub New
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions Properties

The DocumentAdditionalActions type exposes the following members.

Properties
 | Name | Description
Public property | OnDocumentClosing | Gets the actions to be performed when a document will be closed. This is initialized to an empty list.
Public property | OnDocumentOpened | Gets the actions to be performed when a document has been opened. This is initialized to an empty list.
Public property | OnDocumentPrinted | Gets the actions to be performed when a document has been printed. This is initialized to an empty list.
Public property | OnDocumentPrinting | Gets the actions to be performed when a document will be printed. This is initialized to an empty list.
Public property | OnDocumentSaved | Gets the actions to be performed when a document has been saved. This is initialized to an empty list.
Public property | OnDocumentSaving | Gets the actions to be performed when a document will be saved. This is initialized to an empty list.
Top
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.OnDocumentClosing Property

DocumentAdditionalActionsOnDocumentClosing Property

Gets the actions to be performed when a document will be closed. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnDocumentClosing { get; }
Public ReadOnly Property OnDocumentClosing As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.OnDocumentOpened Property

DocumentAdditionalActionsOnDocumentOpened Property

Gets the actions to be performed when a document has been opened. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnDocumentOpened { get; }
Public ReadOnly Property OnDocumentOpened As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.OnDocumentPrinted Property

DocumentAdditionalActionsOnDocumentPrinted Property

Gets the actions to be performed when a document has been printed. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnDocumentPrinted { get; }
Public ReadOnly Property OnDocumentPrinted As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.OnDocumentPrinting Property

DocumentAdditionalActionsOnDocumentPrinting Property

Gets the actions to be performed when a document will be printed. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnDocumentPrinting { get; }
Public ReadOnly Property OnDocumentPrinting As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.OnDocumentSaved Property

DocumentAdditionalActionsOnDocumentSaved Property

Gets the actions to be performed when a document has been saved. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnDocumentSaved { get; }
Public ReadOnly Property OnDocumentSaved As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.OnDocumentSaving Property

DocumentAdditionalActionsOnDocumentSaving Property

Gets the actions to be performed when a document will be saved. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnDocumentSaving { get; }
Public ReadOnly Property OnDocumentSaving As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions Methods

The DocumentAdditionalActions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines whether all action lists are empty.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.IsEmpty Method

DocumentAdditionalActionsIsEmpty Method

Determines whether all action lists are empty.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
true if there are no actions; otherwise, false.
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.MakeRepairContext Method

DocumentAdditionalActionsMakeRepairContext Method

Makes the repair context for repairing problems in this object.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


DocumentAdditionalActions.Validate Method

DocumentAdditionalActionsValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

DocumentAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions Class

PageAdditionalActions represent a set of actions that are performed when a page has been either opened or closed. Opening or closing a page within a PDF viewer navigates to or away from a viewable page. The PDF specification is not clear as to what will happen when a viewer supports showing multiple pages at once. When going from page to page, the OnPageClosed actions on the current page will happen before the OnPageOpened actions on the subsequent page.
Examples
Adding a sound to play when a page has been opened.
Copy
public void AddSoundToPageOpened(PdfGeneratedPage page, PdfSoundAction openSound)
{
    page.AdditionalActions.OnPageOpened.Add(openSound);
}
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.ActionsPageAdditionalActions

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageAdditionalActions : IValidatable
Public Class PageAdditionalActions
    Implements IValidatable

The PageAdditionalActions type exposes the following members.

Constructors
 | Name | Description
Public method | PageAdditionalActions | Initializes a new instance of the PageAdditionalActions class. All actions will be empty lists.
Top
Properties
 | Name | Description
Public property | OnPageClosed | Gets the actions to be performed when a page has been closed. This is initialized to an empty list.
Public property | OnPageOpened | Gets the actions to be performed when a page has been opened. This is initialized to an empty list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines whether all action lists are empty.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions Constructor

Initializes a new instance of the PageAdditionalActions class. All actions will be empty lists.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageAdditionalActions()
Public Sub New
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions Properties

The PageAdditionalActions type exposes the following members.

Properties
 | Name | Description
Public property | OnPageClosed | Gets the actions to be performed when a page has been closed. This is initialized to an empty list.
Public property | OnPageOpened | Gets the actions to be performed when a page has been opened. This is initialized to an empty list.
Top
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions.OnPageClosed Property

PageAdditionalActionsOnPageClosed Property

Gets the actions to be performed when a page has been closed. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnPageClosed { get; }
Public ReadOnly Property OnPageClosed As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions.OnPageOpened Property

PageAdditionalActionsOnPageOpened Property

Gets the actions to be performed when a page has been opened. This is initialized to an empty list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList OnPageOpened { get; }
Public ReadOnly Property OnPageOpened As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions Methods

The PageAdditionalActions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Determines whether all action lists are empty.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions.IsEmpty Method

PageAdditionalActionsIsEmpty Method

Determines whether all action lists are empty.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
true if there are no actions; otherwise, false.
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions.MakeRepairContext Method

PageAdditionalActionsMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PageAdditionalActions.Validate Method

PageAdditionalActionsValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

PageAdditionalActions Class
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier Class

This class is used to represent a reference to an annotation or form field that exists somewhere in a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.ActionsPdfAnnotationIdentifier

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAnnotationIdentifier
<SerializableAttribute>
Public Class PdfAnnotationIdentifier

The PdfAnnotationIdentifier type exposes the following members.

Constructors
Name | Description
PdfAnnotationIdentifier(String) | Initializes a new instance of the PdfAnnotationIdentifier class as a reference to a form field.
PdfAnnotationIdentifier(Int32, Int32) | Initializes a new instance of the PdfAnnotationIdentifier class as a reference to an annotation.
Top
Properties
 | Name | Description
Public property | AnnotationIndex | Gets the index of the annotation. Returns -1 if this PdfAnnotationIdentifier refers to a field by name.
Public property | FieldIdentifier | Gets the field identifier. Returns null if this PdfAnnotationIdentifier refers to an annotation.
Public property | PageIndex | Gets the index of the page. Returns -1 if this PdfAnnotationIdentifier refers to a field by name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier Constructor

Overload List
Name | Description
PdfAnnotationIdentifier(String) | Initializes a new instance of the PdfAnnotationIdentifier class as a reference to a form field.
PdfAnnotationIdentifier(Int32, Int32) | Initializes a new instance of the PdfAnnotationIdentifier class as a reference to an annotation.
Top
See Also

Reference

PdfAnnotationIdentifier Class
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier Constructor (String)

Initializes a new instance of the PdfAnnotationIdentifier class as a reference to a form field.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationIdentifier(
    string fieldIdentifier
)
Public Sub New (
    fieldIdentifier As String
)

Parameters

fieldIdentifier
Type: SystemString
The field identifier which refers to the FieldName of a field defined in the Form object.
Examples
Given a PdfAnnotationIdentifier that refers to a field, the field could be found with the following code:
Copy
foreach (IFormElement elem in FormVisitor.BreadthFirst(doc.Form))
{
    if (elem.FieldName == annotIdentifier.FieldIdentifier)
        return elem; // found
}
See Also

Reference

PdfAnnotationIdentifier Class
PdfAnnotationIdentifier Overload
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier Constructor (Int32, Int32)

Initializes a new instance of the PdfAnnotationIdentifier class as a reference to an annotation.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationIdentifier(
    int pageIndex,
    int annotationIndex
)
Public Sub New (
    pageIndex As Integer,
    annotationIndex As Integer
)

Parameters

pageIndex
Type: SystemInt32
Zero-based index of the PdfGeneratedPage that holds the annotation.
annotationIndex
Type: SystemInt32
Index of the annotation within the Annotations collection.
Remarks
The page index should be a zero-based index of a page, although the page does not need to exist in the document collection until the document is saved. The annotation index should be a zero-based index of an annotation in a pages annotation collection, althogh the annotation does not need to exist until the document is saved.
Examples
Given a PdfAnnotationIdentifier that refers to an annotation, the annotation could be found with the following code:
Copy
// note - the PageIndex and AnnotationIndex values need to be in range
BaseAnnotation annot = ((PdfGeneratedPage)doc.Pages[annotIdentifier.PageIndex]).Annotations[annotIdentidifier.AnnotationIndex];
See Also

Reference

PdfAnnotationIdentifier Class
PdfAnnotationIdentifier Overload
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier Properties

The PdfAnnotationIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationIndex | Gets the index of the annotation. Returns -1 if this PdfAnnotationIdentifier refers to a field by name.
Public property | FieldIdentifier | Gets the field identifier. Returns null if this PdfAnnotationIdentifier refers to an annotation.
Public property | PageIndex | Gets the index of the page. Returns -1 if this PdfAnnotationIdentifier refers to a field by name.
Top
See Also

Reference

PdfAnnotationIdentifier Class
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier.AnnotationIndex Property

PdfAnnotationIdentifierAnnotationIndex Property

Gets the index of the annotation. Returns -1 if this PdfAnnotationIdentifier refers to a field by name.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AnnotationIndex { get; }
Public ReadOnly Property AnnotationIndex As Integer
    Get

Property Value

Type: Int32
The zero-based index of the annotation within its page's Annotation collection.
See Also

Reference

PdfAnnotationIdentifier Class
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier.FieldIdentifier Property

PdfAnnotationIdentifierFieldIdentifier Property

Gets the field identifier. Returns null if this PdfAnnotationIdentifier refers to an annotation.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldIdentifier { get; }
Public ReadOnly Property FieldIdentifier As String
    Get

Property Value

Type: String
See Also

Reference

PdfAnnotationIdentifier Class
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier.PageIndex Property

PdfAnnotationIdentifierPageIndex Property

Gets the index of the page. Returns -1 if this PdfAnnotationIdentifier refers to a field by name.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get

Property Value

Type: Int32
The zero-based index of the page referred on which an annotation appears.
See Also

Reference

PdfAnnotationIdentifier Class
Atalasoft.PdfDoc.Actions Namespace


PdfAnnotationIdentifier Methods

The PdfAnnotationIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfAnnotationIdentifier Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionList Class

A specialized collection for JavaScript only actions
Inheritance Hierarchy
SystemObject
System.Collections.GenericListPdfJavaScriptAction
Atalasoft.PdfDoc.ActionsPdfJavaScriptActionList

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfJavaScriptActionList : List<PdfJavaScriptAction>
Public Class PdfJavaScriptActionList
    Inherits List(Of PdfJavaScriptAction)

The PdfJavaScriptActionList type exposes the following members.

Constructors
 | Name | Description
Public method | PdfJavaScriptActionList | Initializes a new instance of the PdfJavaScriptActionList class.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfJavaScriptAction .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfJavaScriptAction .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfJavaScriptAction .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfJavaScriptAction .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfJavaScriptAction .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfJavaScriptAction .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfJavaScriptAction .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfJavaScriptAction .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfJavaScriptAction .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfJavaScriptAction .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfJavaScriptAction .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfJavaScriptAction .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfJavaScriptAction .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfJavaScriptAction .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfJavaScriptAction .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfJavaScriptAction .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfJavaScriptAction .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfJavaScriptAction .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionList Constructor

Initializes a new instance of the PdfJavaScriptActionList class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionList()
Public Sub New
See Also

Reference

PdfJavaScriptActionList Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionList Properties

The PdfJavaScriptActionList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfJavaScriptAction .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfJavaScriptAction .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfJavaScriptAction .)
Top
See Also

Reference

PdfJavaScriptActionList Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionList Methods

The PdfJavaScriptActionList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfJavaScriptAction .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfJavaScriptAction .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfJavaScriptAction .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfJavaScriptAction .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfJavaScriptAction .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfJavaScriptAction .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfJavaScriptAction .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfJavaScriptAction .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfJavaScriptAction .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfJavaScriptAction .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfJavaScriptAction .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfJavaScriptAction .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfJavaScriptAction .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfJavaScriptAction .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfJavaScriptAction .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfJavaScriptAction .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfJavaScriptAction .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfJavaScriptAction .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfJavaScriptAction .)
Top
See Also

Reference

PdfJavaScriptActionList Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection Class

This is a collection of JavaScriptActionLists that are used within a PDF when a document is opened. Upon opening, all scripts within this collection will be executed in string order of the keys. The keys themselves are unimportant and are not used for anything beyond the order of execution. The intent of this collection is to define JavaScript elements that may be used elsewhere in the document.
Inheritance Hierarchy
SystemObject
System.Collections.GenericSortedListString, PdfJavaScriptActionList
Atalasoft.PdfDoc.ActionsPdfJavaScriptActionListCollection

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfJavaScriptActionListCollection : SortedList<string, PdfJavaScriptActionList>
Public Class PdfJavaScriptActionListCollection
    Inherits SortedList(Of String, PdfJavaScriptActionList)

The PdfJavaScriptActionListCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PdfJavaScriptActionListCollection | Initializes a new instance of the PdfJavaScriptActionListCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the SortedListTKey, TValue can contain. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Comparer | Gets the IComparerT for the sorted list. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Count | Gets the number of key/value pairs contained in the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Keys | Gets a collection containing the keys in the SortedListTKey, TValue, in sorted order. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Values | Gets a collection containing the values in the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Top
Methods
 | Name | Description
Public method | Add(TKey, TValue) | Adds an element with the specified key and value into the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | Add(String, PdfJavaScriptAction) | Adds the specified action to the collection, creating a new PdfJavaScriptActionList if needed.
Public method | Clear | Removes all elements from the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | ContainsKey | Determines whether the SortedListTKey, TValue contains a specific key. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | ContainsValue | Determines whether the SortedListTKey, TValue contains a specific value. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOfKey | Searches for the specified key and returns the zero-based index within the entire SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | IndexOfValue | Searches for the specified value and returns the zero-based index of the first occurrence within the entire SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | IsEmpty | Determines whether this collection contains any scripts, checking each list (if any) for elements.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the element with the specified key from the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | RemoveAt | Removes the element at the specified index of the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the SortedListTKey, TValue, if that number is less than 90 percent of current capacity. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from SortedListString, PdfJavaScriptActionList .)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection Constructor

Initializes a new instance of the PdfJavaScriptActionListCollection class

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionListCollection()
Public Sub New
See Also

Reference

PdfJavaScriptActionListCollection Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection Properties

The PdfJavaScriptActionListCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the SortedListTKey, TValue can contain. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Comparer | Gets the IComparerT for the sorted list. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Count | Gets the number of key/value pairs contained in the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Keys | Gets a collection containing the keys in the SortedListTKey, TValue, in sorted order. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public property | Values | Gets a collection containing the values in the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Top
See Also

Reference

PdfJavaScriptActionListCollection Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection Methods

The PdfJavaScriptActionListCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(TKey, TValue) | Adds an element with the specified key and value into the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | Add(String, PdfJavaScriptAction) | Adds the specified action to the collection, creating a new PdfJavaScriptActionList if needed.
Public method | Clear | Removes all elements from the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | ContainsKey | Determines whether the SortedListTKey, TValue contains a specific key. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | ContainsValue | Determines whether the SortedListTKey, TValue contains a specific value. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOfKey | Searches for the specified key and returns the zero-based index within the entire SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | IndexOfValue | Searches for the specified value and returns the zero-based index of the first occurrence within the entire SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | IsEmpty | Determines whether this collection contains any scripts, checking each list (if any) for elements.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the element with the specified key from the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | RemoveAt | Removes the element at the specified index of the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the SortedListTKey, TValue, if that number is less than 90 percent of current capacity. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from SortedListString, PdfJavaScriptActionList .)
Top
See Also

Reference

PdfJavaScriptActionListCollection Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection.Add Method

PdfJavaScriptActionListCollectionAdd Method

Overload List
 | Name | Description
Public method | Add(TKey, TValue) | Adds an element with the specified key and value into the SortedListTKey, TValue. (Inherited from SortedListString, PdfJavaScriptActionList .)
Public method | Add(String, PdfJavaScriptAction) | Adds the specified action to the collection, creating a new PdfJavaScriptActionList if needed.
Top
See Also

Reference

PdfJavaScriptActionListCollection Class
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection.Add Method (String, PdfJavaScriptAction)

PdfJavaScriptActionListCollectionAdd Method (String, PdfJavaScriptAction)

Adds the specified action to the collection, creating a new PdfJavaScriptActionList if needed.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string name,
    PdfJavaScriptAction action
)
Public Sub Add (
    name As String,
    action As PdfJavaScriptAction
)

Parameters

name
Type: SystemString
The name of the action.
action
Type: Atalasoft.PdfDocPdfJavaScriptAction
The action to add.
Remarks
This is a convenience method for adding a single action instead of a list of actions. If name already exists in the collection, action will be added to it. If not, a new PdfJavaScriptActionList will be created, the action added to that list, then the list will be added to the collection under name.
See Also

Reference

PdfJavaScriptActionListCollection Class
Add Overload
Atalasoft.PdfDoc.Actions Namespace


PdfJavaScriptActionListCollection.IsEmpty Method

PdfJavaScriptActionListCollectionIsEmpty Method

Determines whether this collection contains any scripts, checking each list (if any) for elements.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
true if there are any scripts in this collection; otherwise, false.
See Also

Reference

PdfJavaScriptActionListCollection Class
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction Class

PdfNamedAction is a PdfAction class that is used for causing specific behaviors to occur in the PDF viewer. The PDF specification defines a number of standard navigation named actions that are to be implemented in all PDF viewers, but any named action could be defined. The standard names are: NextPageGo to the next page in the document (if there is one)PrevPageGo to the previous page in the document (if there is one)FirstPageGo to the first page in the documentLastPageGo to the last page in the document The advantage to using PdfNamedAction instead of PdfGoToViewAction is that the named actions aren't tied to a particular page so if, for example, a PushButtonWidgetAnnotation labeled "Next" has a "NextPage" action, the widget will always work correctly no matter how the pages have been ordered. This allows an author to easily put navigation buttons on pages for reading or for skipping to, say, a contents page at the beginning or an index page at the end.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDoc.ActionsPdfNamedAction

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfNamedAction : PdfAction
<SerializableAttribute>
Public Class PdfNamedAction
    Inherits PdfAction

The PdfNamedAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfNamedAction | Initializes a new instance of the PdfNamedAction class. The Name property will be initialized to "NextPage".
Public method | PdfNamedAction(String) | Initializes a new instance of the PdfNamedAction class.
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object. Returns PdfActionType.PerformNamedAction. (Overrides PdfActionActionType.)
Public property | Name | Gets or sets the name for this action.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsStandardName | Determines whether name is a member of the set of standard names: "NextPage", "PrevPage", "FirstPage" or "LastPage".
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction Constructor

Overload List
 | Name | Description
Public method | PdfNamedAction | Initializes a new instance of the PdfNamedAction class. The Name property will be initialized to "NextPage".
Public method | PdfNamedAction(String) | Initializes a new instance of the PdfNamedAction class.
Top
See Also

Reference

PdfNamedAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction Constructor

Initializes a new instance of the PdfNamedAction class. The Name property will be initialized to "NextPage".

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfNamedAction()
Public Sub New
See Also

Reference

PdfNamedAction Class
PdfNamedAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction Constructor (String)

Initializes a new instance of the PdfNamedAction class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfNamedAction(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The name for the action.
See Also

Reference

PdfNamedAction Class
PdfNamedAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction Properties

The PdfNamedAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object. Returns PdfActionType.PerformNamedAction. (Overrides PdfActionActionType.)
Public property | Name | Gets or sets the name for this action.
Top
See Also

Reference

PdfNamedAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction.ActionType Property

PdfNamedActionActionType Property

Gets the type of the action represented by this object. Returns PdfActionType.PerformNamedAction.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfNamedAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction.Name Property

PdfNamedActionName Property

Gets or sets the name for this action.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name to set - must not be null.
See Also

Reference

PdfNamedAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction Methods

The PdfNamedAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsStandardName | Determines whether name is a member of the set of standard names: "NextPage", "PrevPage", "FirstPage" or "LastPage".
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfNamedAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfNamedAction.IsStandardName Method

PdfNamedActionIsStandardName Method

Determines whether name is a member of the set of standard names: "NextPage", "PrevPage", "FirstPage" or "LastPage".

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsStandardName(
    string name
)
Public Shared Function IsStandardName (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name to check.

Return Value

Type: Boolean
true if the specified name is a standard name; otherwise, false.
See Also

Reference

PdfNamedAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction Class

This class represents an action which will cause a PdfForm object (if any) within a PDF document to have either all or a subset of fields within it to be reset to their default values.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDoc.ActionsPdfResetFormAction

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfResetFormAction : PdfAction
<SerializableAttribute>
Public Class PdfResetFormAction
    Inherits PdfAction

The PdfResetFormAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfResetFormAction | Initializes a new instance of the PdfResetFormAction class
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object - returns PdfActionType.SubmitForm (Overrides PdfActionActionType.)
Public property | ExcludeFields | Gets or sets a value indicating whether to exclude fields from the form reset.
Public property | Fields | Gets the fields that will be included or excluded from the form reset. If the Fields property is an empty list, all fields will be reset and the ExcludeFields property will be ignored.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction Constructor

Initializes a new instance of the PdfResetFormAction class

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfResetFormAction()
Public Sub New
See Also

Reference

PdfResetFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction Properties

The PdfResetFormAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object - returns PdfActionType.SubmitForm (Overrides PdfActionActionType.)
Public property | ExcludeFields | Gets or sets a value indicating whether to exclude fields from the form reset.
Public property | Fields | Gets the fields that will be included or excluded from the form reset. If the Fields property is an empty list, all fields will be reset and the ExcludeFields property will be ignored.
Top
See Also

Reference

PdfResetFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction.ActionType Property

PdfResetFormActionActionType Property

Gets the type of the action represented by this object - returns PdfActionType.SubmitForm

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfResetFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction.ExcludeFields Property

PdfResetFormActionExcludeFields Property

Gets or sets a value indicating whether to exclude fields from the form reset.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ExcludeFields { get; set; }
Public Property ExcludeFields As Boolean
    Get
    Set

Property Value

Type: Boolean
if true, the Fields will be excluded, otherwise they will be included.
See Also

Reference

PdfResetFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction.Fields Property

PdfResetFormActionFields Property

Gets the fields that will be included or excluded from the form reset. If the Fields property is an empty list, all fields will be reset and the ExcludeFields property will be ignored.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfAnnotationIdentifier> Fields { get; }
Public ReadOnly Property Fields As IList(Of PdfAnnotationIdentifier)
    Get

Property Value

Type: IListPdfAnnotationIdentifier
See Also

Reference

PdfResetFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfResetFormAction Methods

The PdfResetFormAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfResetFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction Class

PdfShowHideAction is an action that is used to show or hide one or more annotations or fields on a page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDoc.ActionsPdfShowHideAction

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfShowHideAction : PdfAction
<SerializableAttribute>
Public Class PdfShowHideAction
    Inherits PdfAction

The PdfShowHideAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfShowHideAction(Boolean) | Initializes a new instance of the PdfShowHideAction class.
 | PdfShowHideAction(Boolean, PdfAnnotationIdentifier) | Initializes a new instance of the PdfShowHideAction class.
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object. Returns Hide (Overrides PdfActionActionType.)
Public property | Identifiers | Gets the identifiers of fields or annotations that will be shown or hidden.
Public property | WillHide | Gets or sets a value indicating whether the action will hide the annotation(s). ///
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction Constructor

Overload List
 | Name | Description
Public method | PdfShowHideAction(Boolean) | Initializes a new instance of the PdfShowHideAction class.
 | PdfShowHideAction(Boolean, PdfAnnotationIdentifier) | Initializes a new instance of the PdfShowHideAction class.
Top
See Also

Reference

PdfShowHideAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction Constructor (Boolean)

Initializes a new instance of the PdfShowHideAction class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfShowHideAction(
    bool willHide
)
Public Sub New (
    willHide As Boolean
)

Parameters

willHide
Type: SystemBoolean
if set to true the target will be hidden, shown otherwise.
See Also

Reference

PdfShowHideAction Class
PdfShowHideAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction Constructor (Boolean, PdfAnnotationIdentifier[])

PdfShowHideAction Constructor (Boolean, PdfAnnotationIdentifier)

Initializes a new instance of the PdfShowHideAction class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfShowHideAction(
    bool willHide,
    params PdfAnnotationIdentifier[] idents
)
Public Sub New (
    willHide As Boolean,
    ParamArray idents As PdfAnnotationIdentifier()
)

Parameters

willHide
Type: SystemBoolean
if set to true the target will be hidden, shown otherwise.
idents
Type: Atalasoft.PdfDoc.ActionsPdfAnnotationIdentifier
The PdfAnnotationIdentifier objects to show or hide.
Examples
This is an example of how to show a field on a page.
Copy
TextWidgetAnnotation annot = GetMyTextWidget(); // from somewhere else
PdfShowHideAction action = new PdfShowHideAction(false, new PdfAnnotationIdentifier(annot.FieldName));
See Also

Reference

PdfShowHideAction Class
PdfShowHideAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction Properties

The PdfShowHideAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object. Returns Hide (Overrides PdfActionActionType.)
Public property | Identifiers | Gets the identifiers of fields or annotations that will be shown or hidden.
Public property | WillHide | Gets or sets a value indicating whether the action will hide the annotation(s). ///
Top
See Also

Reference

PdfShowHideAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction.ActionType Property

PdfShowHideActionActionType Property

Gets the type of the action represented by this object. Returns Hide

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfShowHideAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction.Identifiers Property

PdfShowHideActionIdentifiers Property

Gets the identifiers of fields or annotations that will be shown or hidden.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfAnnotationIdentifier> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of PdfAnnotationIdentifier)
    Get

Property Value

Type: IListPdfAnnotationIdentifier
See Also

Reference

PdfShowHideAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction.WillHide Property

PdfShowHideActionWillHide Property

Gets or sets a value indicating whether the action will hide the annotation(s). ///

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool WillHide { get; set; }
Public Property WillHide As Boolean
    Get
    Set

Property Value

Type: Boolean
true if annotation(s) will be hidden; otherwise, false.
See Also

Reference

PdfShowHideAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfShowHideAction Methods

The PdfShowHideAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfShowHideAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction Class

Represents an action that will cause a sound to be played.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDoc.ActionsPdfSoundAction

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfSoundAction : PdfAction
<SerializableAttribute>
Public Class PdfSoundAction
    Inherits PdfAction

The PdfSoundAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfSoundAction | Initializes a new instance of the PdfSoundAction class with no sound specified. the Sound property needs to be specified before saving a PDF with this action.
Public method | PdfSoundAction(Sound) | Initializes a new instance of the PdfSoundAction class with the specified Sound.
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object. Returns PlaySound (Overrides PdfActionActionType.)
Public property | IsSynchronous | Gets or sets a value indicating whether this sound is to be played synchronously.
Public property | MixWithPlayingSounds | Gets or sets a value indicating whether the sound will be mixed with already playing sounds.
Public property | Repeat | Gets or sets a value indicating whether this PdfSoundAction is repeated when played.
Public property | Sound | Gets or sets the Sound that will be played.
Public property | Volume | Gets or sets the volume with which the sound with be played.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction Constructor

Overload List
 | Name | Description
Public method | PdfSoundAction | Initializes a new instance of the PdfSoundAction class with no sound specified. the Sound property needs to be specified before saving a PDF with this action.
Public method | PdfSoundAction(Sound) | Initializes a new instance of the PdfSoundAction class with the specified Sound.
Top
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction Constructor

Initializes a new instance of the PdfSoundAction class with no sound specified. the Sound property needs to be specified before saving a PDF with this action.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSoundAction()
Public Sub New
See Also

Reference

PdfSoundAction Class
PdfSoundAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction Constructor (Sound)

Initializes a new instance of the PdfSoundAction class with the specified Sound.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSoundAction(
    Sound sound
)
Public Sub New (
    sound As Sound
)

Parameters

sound
Type: Atalasoft.PdfDoc.Generating.MultimediaSound
The sound that will be played.
See Also

Reference

PdfSoundAction Class
PdfSoundAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction Properties

The PdfSoundAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object. Returns PlaySound (Overrides PdfActionActionType.)
Public property | IsSynchronous | Gets or sets a value indicating whether this sound is to be played synchronously.
Public property | MixWithPlayingSounds | Gets or sets a value indicating whether the sound will be mixed with already playing sounds.
Public property | Repeat | Gets or sets a value indicating whether this PdfSoundAction is repeated when played.
Public property | Sound | Gets or sets the Sound that will be played.
Public property | Volume | Gets or sets the volume with which the sound with be played.
Top
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction.ActionType Property

PdfSoundActionActionType Property

Gets the type of the action represented by this object. Returns PlaySound

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction.IsSynchronous Property

PdfSoundActionIsSynchronous Property

Gets or sets a value indicating whether this sound is to be played synchronously.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSynchronous { get; set; }
Public Property IsSynchronous As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is to played synchronously; otherwise, false.
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction.MixWithPlayingSounds Property

PdfSoundActionMixWithPlayingSounds Property

Gets or sets a value indicating whether the sound will be mixed with already playing sounds.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MixWithPlayingSounds { get; set; }
Public Property MixWithPlayingSounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the sound will be mixed with already playing sounds; otherwise, false.
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction.Repeat Property

PdfSoundActionRepeat Property

Gets or sets a value indicating whether this PdfSoundAction is repeated when played.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Repeat { get; set; }
Public Property Repeat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if repeated; otherwise, false.
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction.Sound Property

PdfSoundActionSound Property

Gets or sets the Sound that will be played.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Sound Sound { get; set; }
Public Property Sound As Sound
    Get
    Set

Property Value

Type: Sound
The sound to play.
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction.Volume Property

PdfSoundActionVolume Property

Gets or sets the volume with which the sound with be played.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Volume { get; set; }
Public Property Volume As Double
    Get
    Set

Property Value

Type: Double
The volume of the sound to be played.
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSoundAction Methods

The PdfSoundAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfSoundAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Class

PdfSubmitFormActions represents an action to cause the form elements in a document to be sent to a server for processing.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocPdfAction
Atalasoft.PdfDoc.ActionsPdfSubmitFormAction

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfSubmitFormAction : PdfAction
<SerializableAttribute>
Public Class PdfSubmitFormAction
    Inherits PdfAction

The PdfSubmitFormAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfSubmitFormAction | Initializes a new instance of the PdfSubmitFormAction class.
Public method | PdfSubmitFormAction(String) | Initializes a new instance of the PdfSubmitFormAction class.
Public method | PdfSubmitFormAction(Uri) | Initializes a new instance of the PdfSubmitFormAction class.
Top
Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object (Overrides PdfActionActionType.)
Public property | EmbedForm | Gets or sets a value indicating whether to include the embedded form data.
Public property | ExcludeAnnotationsWithoutUser | Gets or sets a value indicating whether markup annotations that do not have a user name will be ignored.
Public property | ExcludeFdfFile | Gets or sets a value indicating whether to exclude the FDF file specification.
Public property | ExcludeFields | Gets or sets a value indicating whether to exlude fields from the form submission.
Public property | Fields | Gets the fields that will be included or excluded from the form submission. If the Fields property is empty, all fields will be sumbitted, ignoring the ExcludeFields property, except for those fields that individually have IsFieldNoExport set to true.
Public property | FormDestination | Gets or sets the form destination.
Public property | IncludeAnnotations | Gets or sets a value indicating whether to include all markup annotation data.
Public property | IncludeAppendSaves | Gets or sets a value indicating whether to include appended save data.
Public property | IncludeEmptyFields | Gets or sets a value indicating whether empty fields should be sumbitted.
Public property | MalformedImportedUri | If a PDF file has been read that contains an improper URI, this property will be set to the improper value and the FormDestination will be set to null.
Public property | SubmitAsHtml | If SubmitAsPdf and SubmitAsXFDF are false, then if SubmitAsHtml is true, the form will be submitted as HTML form formal, otherwise it will be submitted as FDF.
Public property | SubmitAsPdf | Gets or sets a value indicating whether the entire document will be sumbitted.
Public property | SubmitAsXFDF | Gets or sets a value indicating whether to submit the form as XFDF.
Public property | SubmitCoordinates | Gets or sets a value indicating whether to submit coordinates with the data.
Public property | SubmitDatesAsPdfFormat | Gets or sets a value indicating whether to submit dates in the PDF date format
Public property | UseHttpGet | Gets or sets a value indicating whether to use HTTP GET, otherwise use HTTP POST.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Constructor

Overload List
 | Name | Description
Public method | PdfSubmitFormAction | Initializes a new instance of the PdfSubmitFormAction class.
Public method | PdfSubmitFormAction(String) | Initializes a new instance of the PdfSubmitFormAction class.
Public method | PdfSubmitFormAction(Uri) | Initializes a new instance of the PdfSubmitFormAction class.
Top
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Constructor

Initializes a new instance of the PdfSubmitFormAction class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSubmitFormAction()
Public Sub New
See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Constructor (String)

Initializes a new instance of the PdfSubmitFormAction class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSubmitFormAction(
    string uri
)
Public Sub New (
    uri As String
)

Parameters

uri
Type: SystemString
The URL of the server.
Remarks
Will throw an exception if uri is not a proper URI.
See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Constructor (Uri)

Initializes a new instance of the PdfSubmitFormAction class.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSubmitFormAction(
    Uri uri
)
Public Sub New (
    uri As Uri
)

Parameters

uri
Type: SystemUri
The URI of the server.
See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Overload
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Properties

The PdfSubmitFormAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of the action represented by this object (Overrides PdfActionActionType.)
Public property | EmbedForm | Gets or sets a value indicating whether to include the embedded form data.
Public property | ExcludeAnnotationsWithoutUser | Gets or sets a value indicating whether markup annotations that do not have a user name will be ignored.
Public property | ExcludeFdfFile | Gets or sets a value indicating whether to exclude the FDF file specification.
Public property | ExcludeFields | Gets or sets a value indicating whether to exlude fields from the form submission.
Public property | Fields | Gets the fields that will be included or excluded from the form submission. If the Fields property is empty, all fields will be sumbitted, ignoring the ExcludeFields property, except for those fields that individually have IsFieldNoExport set to true.
Public property | FormDestination | Gets or sets the form destination.
Public property | IncludeAnnotations | Gets or sets a value indicating whether to include all markup annotation data.
Public property | IncludeAppendSaves | Gets or sets a value indicating whether to include appended save data.
Public property | IncludeEmptyFields | Gets or sets a value indicating whether empty fields should be sumbitted.
Public property | MalformedImportedUri | If a PDF file has been read that contains an improper URI, this property will be set to the improper value and the FormDestination will be set to null.
Public property | SubmitAsHtml | If SubmitAsPdf and SubmitAsXFDF are false, then if SubmitAsHtml is true, the form will be submitted as HTML form formal, otherwise it will be submitted as FDF.
Public property | SubmitAsPdf | Gets or sets a value indicating whether the entire document will be sumbitted.
Public property | SubmitAsXFDF | Gets or sets a value indicating whether to submit the form as XFDF.
Public property | SubmitCoordinates | Gets or sets a value indicating whether to submit coordinates with the data.
Public property | SubmitDatesAsPdfFormat | Gets or sets a value indicating whether to submit dates in the PDF date format
Public property | UseHttpGet | Gets or sets a value indicating whether to use HTTP GET, otherwise use HTTP POST.
Top
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.ActionType Property

PdfSubmitFormActionActionType Property

Gets the type of the action represented by this object

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfActionType ActionType { get; }
Public Overrides ReadOnly Property ActionType As PdfActionType
    Get

Property Value

Type: PdfActionType
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.EmbedForm Property

PdfSubmitFormActionEmbedForm Property

Gets or sets a value indicating whether to include the embedded form data.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EmbedForm { get; set; }
Public Property EmbedForm As Boolean
    Get
    Set

Property Value

Type: Boolean
true if to include the embeded form data; otherwise, false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.ExcludeAnnotationsWithoutUser Property

PdfSubmitFormActionExcludeAnnotationsWithoutUser Property

Gets or sets a value indicating whether markup annotations that do not have a user name will be ignored.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ExcludeAnnotationsWithoutUser { get; set; }
Public Property ExcludeAnnotationsWithoutUser As Boolean
    Get
    Set

Property Value

Type: Boolean
true if markup annotations without a user name; otherwise, false.
Remarks
This will only be used if SubmitAsXFDF and SubmitAsHtml are false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.ExcludeFdfFile Property

PdfSubmitFormActionExcludeFdfFile Property

Gets or sets a value indicating whether to exclude the FDF file specification.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ExcludeFdfFile { get; set; }
Public Property ExcludeFdfFile As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the FDF file will be excluded; otherwise, false.
Remarks
This will only be used if SubmitAsXFDF and SubmitAsHtml are false. Not currently supported.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.ExcludeFields Property

PdfSubmitFormActionExcludeFields Property

Gets or sets a value indicating whether to exlude fields from the form submission.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ExcludeFields { get; set; }
Public Property ExcludeFields As Boolean
    Get
    Set

Property Value

Type: Boolean
if true, the Fields will be excluded, otherwise they will be included.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.Fields Property

PdfSubmitFormActionFields Property

Gets the fields that will be included or excluded from the form submission. If the Fields property is empty, all fields will be sumbitted, ignoring the ExcludeFields property, except for those fields that individually have IsFieldNoExport set to true.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfAnnotationIdentifier> Fields { get; }
Public ReadOnly Property Fields As IList(Of PdfAnnotationIdentifier)
    Get

Property Value

Type: IListPdfAnnotationIdentifier
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.FormDestination Property

PdfSubmitFormActionFormDestination Property

Gets or sets the form destination.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Uri FormDestination { get; set; }
Public Property FormDestination As Uri
    Get
    Set

Property Value

Type: Uri
The form destination.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.IncludeAnnotations Property

PdfSubmitFormActionIncludeAnnotations Property

Gets or sets a value indicating whether to include all markup annotation data.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncludeAnnotations { get; set; }
Public Property IncludeAnnotations As Boolean
    Get
    Set

Property Value

Type: Boolean
true if all markup annotation data will be included; otherwise, false.
Remarks
This will only be used if SubmitAsXFDF and SubmitAsHtml are false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.IncludeAppendSaves Property

PdfSubmitFormActionIncludeAppendSaves Property

Gets or sets a value indicating whether to include appended save data.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncludeAppendSaves { get; set; }
Public Property IncludeAppendSaves As Boolean
    Get
    Set

Property Value

Type: Boolean
true if append save data will be included; otherwise, false.
Remarks
This will only be used if SubmitAsXFDF and SubmitAsHtml are false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.IncludeEmptyFields Property

PdfSubmitFormActionIncludeEmptyFields Property

Gets or sets a value indicating whether empty fields should be sumbitted.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncludeEmptyFields { get; set; }
Public Property IncludeEmptyFields As Boolean
    Get
    Set

Property Value

Type: Boolean
true if to include empty fields; otherwise, false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.MalformedImportedUri Property

PdfSubmitFormActionMalformedImportedUri Property

If a PDF file has been read that contains an improper URI, this property will be set to the improper value and the FormDestination will be set to null.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string MalformedImportedUri { get; }
Public ReadOnly Property MalformedImportedUri As String
    Get

Property Value

Type: String
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.SubmitAsHtml Property

PdfSubmitFormActionSubmitAsHtml Property

If SubmitAsPdf and SubmitAsXFDF are false, then if SubmitAsHtml is true, the form will be submitted as HTML form formal, otherwise it will be submitted as FDF.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SubmitAsHtml { get; set; }
Public Property SubmitAsHtml As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data will be submitted as HTML, false if it will be submitted as FDF.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.SubmitAsPdf Property

PdfSubmitFormActionSubmitAsPdf Property

Gets or sets a value indicating whether the entire document will be sumbitted.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SubmitAsPdf { get; set; }
Public Property SubmitAsPdf As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the entire document will be submitted; otherwise, false.
Remarks
If true, all other flags will be ignored except UseHttpGet. Documents will be submitted using the MIME content type application/pdf.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.SubmitAsXFDF Property

PdfSubmitFormActionSubmitAsXFDF Property

Gets or sets a value indicating whether to submit the form as XFDF.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SubmitAsXFDF { get; set; }
Public Property SubmitAsXFDF As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the form data will be submitted as XFDF; otherwise, false.
Remarks
This will only be used if SubmitAsPdf is false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.SubmitCoordinates Property

PdfSubmitFormActionSubmitCoordinates Property

Gets or sets a value indicating whether to submit coordinates with the data.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SubmitCoordinates { get; set; }
Public Property SubmitCoordinates As Boolean
    Get
    Set

Property Value

Type: Boolean
true if coordinates will be submitted, false otherwise.
Remarks
If true, the coordinates of the mouse click within the clicked widget will get submitted in the format name.x=xvalue&name.y=yvalue, where name is the widget's field name for export or the field name, whichever is non-null.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.SubmitDatesAsPdfFormat Property

PdfSubmitFormActionSubmitDatesAsPdfFormat Property

Gets or sets a value indicating whether to submit dates in the PDF date format

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SubmitDatesAsPdfFormat { get; set; }
Public Property SubmitDatesAsPdfFormat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if to submit dates in the PDF data format; otherwise, false.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction.UseHttpGet Property

PdfSubmitFormActionUseHttpGet Property

Gets or sets a value indicating whether to use HTTP GET, otherwise use HTTP POST.

Namespace: Atalasoft.PdfDoc.Actions
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseHttpGet { get; set; }
Public Property UseHttpGet As Boolean
    Get
    Set

Property Value

Type: Boolean
true to use HTTP GET; otherwise, HTTP POST.
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


PdfSubmitFormAction Methods

The PdfSubmitFormAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLValidate | Low-level validation. Not for use by client code (Inherited from PdfAction.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from PdfAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from PdfAction.)
Top
See Also

Reference

PdfSubmitFormAction Class
Atalasoft.PdfDoc.Actions Namespace


Atalasoft.PdfDoc.BarcodeWriting Namespace

Classes
 | Class | Description
Public class | BarcodeWritingShape | The shape to write one dimensional barcodes in the Pdf Generation Toolkit
Public class | DataMatrixBarcodeWritingShape | The shape for rendering DataMatrix barcodes in the Pdf Generation Toolkit
Public class | Pdf417BarcodeWritingShape | The shape to write Pdf417 barcodes in the Pdf Generation Toolkit
Public class | PdfBarGraphics | Implements pdf bar graphics.


BarcodeWritingShape Class

The shape to write one dimensional barcodes in the Pdf Generation Toolkit
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.BarcodeWritingBarcodeWritingShape

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class BarcodeWritingShape : PdfBaseShape
<SerializableAttribute>
Public Class BarcodeWritingShape
    Inherits PdfBaseShape

The BarcodeWritingShape type exposes the following members.

Constructors
 | Name | Description
Public method | BarcodeWritingShape | Initializes a new instance of the BarcodeWritingShape class.
Top
Properties
 | Name | Description
Public property | BarcodeStyle | Gets the barcode style.
Public property | BarcodeText | Gets the barcode text.
Public property | Bounds | Gets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape Constructor

Initializes a new instance of the BarcodeWritingShape class.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeWritingShape(
    string barcodeText,
    BarcodeStyle barcodeStyle,
    PdfBounds bounds
)
Public Sub New (
    barcodeText As String,
    barcodeStyle As BarcodeStyle,
    bounds As PdfBounds
)

Parameters

barcodeText
Type: SystemString
The barcode text.
barcodeStyle
Type: Atalasoft.Barcoding.WritingBarcodeStyle
The style of barcode.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds to render the barcode in.
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape Properties

The BarcodeWritingShape type exposes the following members.

Properties
 | Name | Description
Public property | BarcodeStyle | Gets the barcode style.
Public property | BarcodeText | Gets the barcode text.
Public property | Bounds | Gets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape.BarcodeStyle Property

BarcodeWritingShapeBarcodeStyle Property

Gets the barcode style.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarcodeStyle BarcodeStyle { get; }
Public ReadOnly Property BarcodeStyle As BarcodeStyle
    Get

Property Value

Type: BarcodeStyle
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape.BarcodeText Property

BarcodeWritingShapeBarcodeText Property

Gets the barcode text.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BarcodeText { get; }
Public ReadOnly Property BarcodeText As String
    Get

Property Value

Type: String
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape.Bounds Property

BarcodeWritingShapeBounds Property

Gets the bounds.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; }
Public ReadOnly Property Bounds As PdfBounds
    Get

Property Value

Type: PdfBounds
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape Methods

The BarcodeWritingShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape.CloneInstance Method

BarcodeWritingShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


BarcodeWritingShape.DrawShape Method

BarcodeWritingShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer w
)
Protected Overrides Sub DrawShape (
    w As PdfPageRenderer
)

Parameters

w
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape Class

The shape for rendering DataMatrix barcodes in the Pdf Generation Toolkit
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.BarcodeWritingDataMatrixBarcodeWritingShape

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DataMatrixBarcodeWritingShape : PdfBaseShape
<SerializableAttribute>
Public Class DataMatrixBarcodeWritingShape
    Inherits PdfBaseShape

The DataMatrixBarcodeWritingShape type exposes the following members.

Constructors
 | Name | Description
Public method | DataMatrixBarcodeWritingShape | Initializes a new instance of the DataMatrixBarcodeWritingShape class.
Top
Properties
 | Name | Description
Public property | BarcodeText | Gets the barcode text.
Public property | Bounds | Gets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape Constructor

Initializes a new instance of the DataMatrixBarcodeWritingShape class.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DataMatrixBarcodeWritingShape(
    string barcodeText,
    PdfBounds bounds
)
Public Sub New (
    barcodeText As String,
    bounds As PdfBounds
)

Parameters

barcodeText
Type: SystemString
The barcode text.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape Properties

The DataMatrixBarcodeWritingShape type exposes the following members.

Properties
 | Name | Description
Public property | BarcodeText | Gets the barcode text.
Public property | Bounds | Gets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape.BarcodeText Property

DataMatrixBarcodeWritingShapeBarcodeText Property

Gets the barcode text.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BarcodeText { get; }
Public ReadOnly Property BarcodeText As String
    Get

Property Value

Type: String
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape.Bounds Property

DataMatrixBarcodeWritingShapeBounds Property

Gets the bounds.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; }
Public ReadOnly Property Bounds As PdfBounds
    Get

Property Value

Type: PdfBounds
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape Methods

The DataMatrixBarcodeWritingShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape.CloneInstance Method

DataMatrixBarcodeWritingShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


DataMatrixBarcodeWritingShape.DrawShape Method

DataMatrixBarcodeWritingShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer w
)
Protected Overrides Sub DrawShape (
    w As PdfPageRenderer
)

Parameters

w
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

DataMatrixBarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape Class

The shape to write Pdf417 barcodes in the Pdf Generation Toolkit
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.BarcodeWritingPdf417BarcodeWritingShape

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Pdf417BarcodeWritingShape : PdfBaseShape
<SerializableAttribute>
Public Class Pdf417BarcodeWritingShape
    Inherits PdfBaseShape

The Pdf417BarcodeWritingShape type exposes the following members.

Constructors
 | Name | Description
Public method | Pdf417BarcodeWritingShape | Initializes a new instance of the Pdf417BarcodeWritingShape class.
Top
Properties
 | Name | Description
Public property | BarcodeText | Gets the barcode text.
Public property | Bounds | Gets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape Constructor

Initializes a new instance of the Pdf417BarcodeWritingShape class.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Pdf417BarcodeWritingShape(
    string barcodeText,
    PdfBounds bounds
)
Public Sub New (
    barcodeText As String,
    bounds As PdfBounds
)

Parameters

barcodeText
Type: SystemString
The barcode text.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape Properties

The Pdf417BarcodeWritingShape type exposes the following members.

Properties
 | Name | Description
Public property | BarcodeText | Gets the barcode text.
Public property | Bounds | Gets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape.BarcodeText Property

Pdf417BarcodeWritingShapeBarcodeText Property

Gets the barcode text.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string BarcodeText { get; }
Public ReadOnly Property BarcodeText As String
    Get

Property Value

Type: String
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape.Bounds Property

Pdf417BarcodeWritingShapeBounds Property

Gets the bounds.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; }
Public ReadOnly Property Bounds As PdfBounds
    Get

Property Value

Type: PdfBounds
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape Methods

The Pdf417BarcodeWritingShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape.CloneInstance Method

Pdf417BarcodeWritingShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Pdf417BarcodeWritingShape.DrawShape Method

Pdf417BarcodeWritingShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer w
)
Protected Overrides Sub DrawShape (
    w As PdfPageRenderer
)

Parameters

w
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

Pdf417BarcodeWritingShape Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics Class

Implements pdf bar graphics.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.BarcodeWritingPdfBarGraphics

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfBarGraphics : IBarGraphics
Public Class PdfBarGraphics
    Implements IBarGraphics

The PdfBarGraphics type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBarGraphics | Initializes a new instance of the PdfBarGraphics class.
Top
Properties
 | Name | Description
Public property | DpiX | Gets the dpi in the X direction.
Public property | DpiY | Gets the dpi in the Y direction.
Top
Methods
 | Name | Description
Public method | DrawString(String, Font, Brush, Rectangle, StringFormat) | Draws the string.
Public method | DrawString(String, Font, Brush, RectangleF, StringFormat) | Draws a string.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillRectangle | Fills the rectangle.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureString | Measures the string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Restore | Restores the specified GraphicsState.
Public method | RotateTransform | Use a rotate transform to rotate the render canvas.
Public method | Save | Saves the instance of GraphicsState.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateTransform | Use a translate transform to move the render point
Top
See Also

Reference

Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics Constructor

Initializes a new instance of the PdfBarGraphics class.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBarGraphics(
    PdfPageRenderer w
)
Public Sub New (
    w As PdfPageRenderer
)

Parameters

w
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics Properties

The PdfBarGraphics type exposes the following members.

Properties
 | Name | Description
Public property | DpiX | Gets the dpi in the X direction.
Public property | DpiY | Gets the dpi in the Y direction.
Top
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.DpiX Property

PdfBarGraphicsDpiX Property

Gets the dpi in the X direction.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float DpiX { get; }
Public ReadOnly Property DpiX As Single
    Get

Property Value

Type: Single

Implements

IBarGraphicsDpiX
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.DpiY Property

PdfBarGraphicsDpiY Property

Gets the dpi in the Y direction.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float DpiY { get; }
Public ReadOnly Property DpiY As Single
    Get

Property Value

Type: Single

Implements

IBarGraphicsDpiY
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics Methods

The PdfBarGraphics type exposes the following members.

Methods
 | Name | Description
Public method | DrawString(String, Font, Brush, Rectangle, StringFormat) | Draws the string.
Public method | DrawString(String, Font, Brush, RectangleF, StringFormat) | Draws a string.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillRectangle | Fills the rectangle.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureString | Measures the string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Restore | Restores the specified GraphicsState.
Public method | RotateTransform | Use a rotate transform to rotate the render canvas.
Public method | Save | Saves the instance of GraphicsState.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateTransform | Use a translate transform to move the render point
Top
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.DrawString Method

PdfBarGraphicsDrawString Method

Overload List
 | Name | Description
Public method | DrawString(String, Font, Brush, Rectangle, StringFormat) | Draws the string.
Public method | DrawString(String, Font, Brush, RectangleF, StringFormat) | Draws a string.
Top
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.DrawString Method (String, Font, Brush, Rectangle, StringFormat)

PdfBarGraphicsDrawString Method (String, Font, Brush, Rectangle, StringFormat)

Draws the string.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawString(
    string text,
    Font font,
    Brush foreground,
    Rectangle r,
    StringFormat format
)
Public Sub DrawString (
    text As String,
    font As Font,
    foreground As Brush,
    r As Rectangle,
    format As StringFormat
)

Parameters

text
Type: SystemString
The text to draw.
font
Type: System.DrawingFont
The font to use to draw the text.
foreground
Type: System.DrawingBrush
The brush to draw the text with.
r
Type: System.DrawingRectangle
The rectangle to write the text in.
format
Type: System.DrawingStringFormat
The format to use to draw the text.

Implements

IBarGraphicsDrawString(String, Font, Brush, Rectangle, StringFormat)
See Also

Reference

PdfBarGraphics Class
DrawString Overload
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

PdfBarGraphicsDrawString Method (String, Font, Brush, RectangleF, StringFormat)

Draws a string.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void DrawString(
    string text,
    Font font,
    Brush b,
    RectangleF rf,
    StringFormat fmt
)
Public Sub DrawString (
    text As String,
    font As Font,
    b As Brush,
    rf As RectangleF,
    fmt As StringFormat
)

Parameters

text
Type: SystemString
The text to draw.
font
Type: System.DrawingFont
b
Type: System.DrawingBrush
The brush to use to draw the text.
rf
Type: System.DrawingRectangleF
The rectangle to contain the text.
fmt
Type: System.DrawingStringFormat
The StringFormat.

Implements

IBarGraphicsDrawString(String, Font, Brush, RectangleF, StringFormat)
See Also

Reference

PdfBarGraphics Class
DrawString Overload
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.FillRectangle Method

PdfBarGraphicsFillRectangle Method

Fills the rectangle.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void FillRectangle(
    Brush backBrush,
    Rectangle r
)
Public Sub FillRectangle (
    backBrush As Brush,
    r As Rectangle
)

Parameters

backBrush
Type: System.DrawingBrush
The fill brush.
r
Type: System.DrawingRectangle
The rectangle to fill.

Implements

IBarGraphicsFillRectangle(Brush, Rectangle)
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.MeasureString Method

PdfBarGraphicsMeasureString Method

Measures the string.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF MeasureString(
    string text,
    Font font
)
Public Function MeasureString (
    text As String,
    font As Font
) As SizeF

Parameters

text
Type: SystemString
The text to measure.
font
Type: System.DrawingFont
The font used.

Return Value

Type: SizeF
Returns the space needed to render the text with the font

Implements

IBarGraphicsMeasureString(String, Font)
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.Restore Method

PdfBarGraphicsRestore Method

Restores the specified GraphicsState.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Restore(
    GraphicsState gState
)
Public Sub Restore (
    gState As GraphicsState
)

Parameters

gState
Type: System.Drawing.Drawing2DGraphicsState
the GraphicsState to restore to.

Implements

IBarGraphicsRestore(GraphicsState)
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.RotateTransform Method

PdfBarGraphicsRotateTransform Method

Use a rotate transform to rotate the render canvas.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RotateTransform(
    float degrees
)
Public Sub RotateTransform (
    degrees As Single
)

Parameters

degrees
Type: SystemSingle
The amount to rotate, in degrees.

Implements

IBarGraphicsRotateTransform(Single)
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.Save Method

PdfBarGraphicsSave Method

Saves the instance of GraphicsState.

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GraphicsState Save()
Public Function Save As GraphicsState

Return Value

Type: GraphicsState
Returns the GraphicsState

Implements

IBarGraphicsSave
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


PdfBarGraphics.TranslateTransform Method

PdfBarGraphicsTranslateTransform Method

Use a translate transform to move the render point

Namespace: Atalasoft.PdfDoc.BarcodeWriting
Assembly: Atalasoft.dotImage.PdfDoc.BarcodeWriting (in Atalasoft.dotImage.PdfDoc.BarcodeWriting.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void TranslateTransform(
    float x,
    float y
)
Public Sub TranslateTransform (
    x As Single,
    y As Single
)

Parameters

x
Type: SystemSingle
The x direction translation.
y
Type: SystemSingle
The y direction translation.

Implements

IBarGraphicsTranslateTransform(Single, Single)
See Also

Reference

PdfBarGraphics Class
Atalasoft.PdfDoc.BarcodeWriting Namespace


Atalasoft.PdfDoc.DigitalSignatures Namespace

Classes
 | Class | Description
Public class | BaseDocumentCertification | The BaseDocumentCertification class represents the common information necessary for placing a certification signature on a PDF document. A certification signature is an indication that the document is as it was intended to be at the time it was signed. A signer may control the changes that may be made to the document after certification. The certification may be visible or not. If visible, the parameters that control the appearance are in the specific subclasses used in PdfDocument and PdfGeneratedDocument
Public class | BaseSignature | A base class that represents common elements of all digital signatures and certifications
Public class | CmsInformation | This class represents the CMS information used to sign a PDF document.
Public class | PdfCertification | This class represents the certification information for a signed PDF. The certification is represented by a CmsInformation object, although in the future it may be represented by other types.
Public class | PdfDocumentCertification | The PdfDocumentCertification class is a subclass of BaseDocumentCertification used specifically for certifying documents created by the PdfDocument object.
 | PdfDocumentSignature | The PdfDocumentSignature class represents the data needed for applying a digital signature to an existing SignatureWidgetAnnotation object in a PdfDocument. This means that the SignatureWidgetAnnotation must already exist in the PagesOfAnnotations property in the PdfDocumentSigner either because it was pre-existing in the original document or that the document allowed it to be added.
Public class | PdfDocumentSignatureInformation | PdfDocumentSignatureInformation is a class that contains information that was retrieved from an existing signed or certified PDF document.
Public class | PdfDocumentSigner | PdfDocumentSigner is a class that is responsible for getting information about DigitalSignatures within a PDF document and applying signatures to a PDF document.
Public class | PdfGeneratedDocumentCertification | The PdfGeneratedDocumentCertification class is a subclass of the BaseDocumentCertification class which is used specifically to control the appearance of signatures in a PdfGeneratedDocument object.
Public class | PdfSignatureInformation | This is an information class that represents the data associated with a digital signature applied to a PDF document.
Public class | SignatureValidationError | Represents an error while validating digital signatures
Enumerations
 | Enumeration | Description
Public enumeration | DocumentMDPAllowedChanges | Describes changes allowed to a certified document.
Public enumeration | FieldDisallowChangeAction | When a document is signed, this enum determines whether or not all fields or a subset of of fields will be locked for changes.
Public enumeration | PdfContentDigestMethod | When a document is signed, this enum determines the hashing algorithm that is used to create the detached message digest that will embedded in the file.
Public enumeration | SignatureValidationErrorSeverity | Describes the severity of an error that occurred while validating a PDF digital signature
Public enumeration | UnsupportedContentDigestAlgorithmAction | Defines the action to be taken when the contentdigest algorithm is not supported.


BaseDocumentCertification Class

The BaseDocumentCertification class represents the common information necessary for placing a certification signature on a PDF document. A certification signature is an indication that the document is as it was intended to be at the time it was signed. A signer may control the changes that may be made to the document after certification.

The certification may be visible or not. If visible, the parameters that control the appearance are in the specific subclasses used in PdfDocument and PdfGeneratedDocument

Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesBaseSignature
Atalasoft.PdfDoc.DigitalSignaturesBaseDocumentCertification
Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentCertification
Atalasoft.PdfDoc.DigitalSignaturesPdfGeneratedDocumentCertification

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BaseDocumentCertification : BaseSignature
Public Class BaseDocumentCertification
    Inherits BaseSignature

The BaseDocumentCertification type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseDocumentCertification | Initializes a new instance of the BaseDocumentCertification class.
Top
Properties
 | Name | Description
Public property | AllowedChanges | Gets or sets the allowed changes, may not be NotSpecified.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseDocumentCertification Constructor

Initializes a new instance of the BaseDocumentCertification class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseDocumentCertification(
    CmsInformation cmsInfo,
    DocumentMDPAllowedChanges allowedChanges,
    bool isVisible
)
Protected Sub New (
    cmsInfo As CmsInformation,
    allowedChanges As DocumentMDPAllowedChanges,
    isVisible As Boolean
)

Parameters

cmsInfo
Type: Atalasoft.PdfDoc.DigitalSignaturesCmsInformation
The CMS information used to sign the document.
allowedChanges
Type: Atalasoft.PdfDoc.DigitalSignaturesDocumentMDPAllowedChanges
The allowed changes after signing.
isVisible
Type: SystemBoolean
if set to true if the signature is visible.
Exceptions
Exception | Condition
ArgumentNullException | cmsInfo
ArgumentException | allowedChanges
See Also

Reference

BaseDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseDocumentCertification Properties

The BaseDocumentCertification type exposes the following members.

Properties
 | Name | Description
Public property | AllowedChanges | Gets or sets the allowed changes, may not be NotSpecified.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Top
See Also

Reference

BaseDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseDocumentCertification.AllowedChanges Property

BaseDocumentCertificationAllowedChanges Property

Gets or sets the allowed changes, may not be NotSpecified.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentMDPAllowedChanges AllowedChanges { get; set; }
Public Property AllowedChanges As DocumentMDPAllowedChanges
    Get
    Set

Property Value

Type: DocumentMDPAllowedChanges
The allowed changes.
Exceptions
Exception | Condition
ArgumentException | value
See Also

Reference

BaseDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseDocumentCertification Methods

The BaseDocumentCertification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

BaseDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature Class

A base class that represents common elements of all digital signatures and certifications
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesBaseSignature
Atalasoft.PdfDoc.DigitalSignaturesBaseDocumentCertification
Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentSignature

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BaseSignature : IValidatable
Public Class BaseSignature
    Implements IValidatable

The BaseSignature type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseSignature | Initializes a new instance of the BaseSignature class.
Top
Properties
 | Name | Description
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures.
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature Constructor

Initializes a new instance of the BaseSignature class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseSignature(
    CmsInformation cmsInfo,
    bool isVisible
)
Protected Sub New (
    cmsInfo As CmsInformation,
    isVisible As Boolean
)

Parameters

cmsInfo
Type: Atalasoft.PdfDoc.DigitalSignaturesCmsInformation
The CMS information.
isVisible
Type: SystemBoolean
if set to true the signature will be visible.
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature Properties

The BaseSignature type exposes the following members.

Properties
 | Name | Description
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures.
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible.
Top
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature.CmsInformation Property

BaseSignatureCmsInformation Property

Gets or sets the CMS information used to sign the document including the signatures.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmsInformation CmsInformation { get; set; }
Public Property CmsInformation As CmsInformation
    Get
    Set

Property Value

Type: CmsInformation
The CMS information used to sign the document.
Exceptions
Exception | Condition
ArgumentNullException | value
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature.IsVisible Property

BaseSignatureIsVisible Property

Gets or sets a value indicating whether the signature is visible.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the signature is visible; otherwise, false.
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature Methods

The BaseSignature type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature.MakeRepairContext Method

BaseSignatureMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


BaseSignature.Validate Method

BaseSignatureValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
Exceptions
Exception | Condition
ArgumentException | expected a DocRepairContext but got + repairContext == null ? null : repairContext.GetType().Name
See Also

Reference

BaseSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Class

This class represents the CMS information used to sign a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesCmsInformation

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CmsInformation
Public Class CmsInformation

The CmsInformation type exposes the following members.

Constructors
 | Name | Description
Public method | CmsInformation(X509Certificate2Collection) | Initializes a new instance of the CmsInformation class.
Public method | CmsInformation(X509Certificate2Collection, PdfContentDigestMethod, UnsupportedContentDigestAlgorithmAction) | Initializes a new instance of the CmsInformation class.
Public method | CmsInformation(Stream, SecureString, PdfContentDigestMethod, UnsupportedContentDigestAlgorithmAction) | Initializes a new instance of the CmsInformation class.
Top
Properties
 | Name | Description
Public property | Certificates | Gets the certificates collection. This represents the certificate or chain of certificates used to sign the document. The actual signer will always be the first.
Public property | ContentDigestMethod | Gets the content digest method that will be used to create a message digest of the PDF file. Note that this is currently only used for signature creation and not for reflecting the method used in a signed file.
Public property | ContentDigestMethodIsSupported | Gets a value indicating whether the ContentDigestMethod is supported by the provided certificate if it is supported, it will be used as is. If it is unsupported, at the time of saving the document (in PdfDocument or PdfGeneratedDocument) or signing (in PdfDocumentSigner), the UnsupportedContentDigestAlgorithmAction will be invoked.
Public property | UnsupportedContentDigestAlgorithmAction | Gets the action that will be taken when the ContentDigestMethod is not supported.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
When a PDF document is signed, the X509Certificate2Collection is used to create a cryptographic signature that will be embedded in the PDF file. If the certificate uses RSA encryption and the RSACryptoServiceProvider object in the certificate does not support the specified digest algorithm, DotPdf will attempt to use BouncyCastle to perform the signing. This will only work as a fall back method if the certificate came from a file and the file was opened as having the private key exportable.

Otherwise, the property ContentDigestMethodIsSupported will be false and at the time of signing, DotPdf will invoke the action in the property UnsupportedContentDigestAlgorithmAction. Almost certainly, certificates that come from the Windows certificate store will NOT have an exportable private key.

Examples
This sample shows how to open a certificate file to allow exporting a private key.
Copy
X509Certificate2 cert = new X509Certificate2(pathToACertFile, yourCertPassword, X509KeyStorageFlags.Exportable);
Examples
How to determine the set of supported digest methods.
Copy
public IList<PdfContentDigestMethod> GetSupportedDigestMethods(X509Certificate2Collection certificates)
{
    List<PdfContentDigestMethod> meths = new List<PdfContentDigestMethod>();
    foreach (PdfContentDigestMethod method in Enum.GetValues(typeof(PdfContentDigestMethod)))
    {
        CmsInformation cms = new CmsInformation(certificate, method, UnsupportedContentDigestAlgorithmAction.FallBackToSHA1);
        if (cms.ContentDigestMethodIsSupported)
            meths.Add(method);
    }
    return meths;
}
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Constructor

Overload List
 | Name | Description
Public method | CmsInformation(X509Certificate2Collection) | Initializes a new instance of the CmsInformation class.
Public method | CmsInformation(X509Certificate2Collection, PdfContentDigestMethod, UnsupportedContentDigestAlgorithmAction) | Initializes a new instance of the CmsInformation class.
Public method | CmsInformation(Stream, SecureString, PdfContentDigestMethod, UnsupportedContentDigestAlgorithmAction) | Initializes a new instance of the CmsInformation class.
Top
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Constructor (X509Certificate2Collection)

Initializes a new instance of the CmsInformation class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmsInformation(
    X509Certificate2Collection certificates
)
Public Sub New (
    certificates As X509Certificate2Collection
)

Parameters

certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
A non-null, non-empty collection of certificates.
Exceptions
Exception | Condition
ArgumentNullException | certificates or signers
ArgumentOutOfRangeException | certificates or signers
Remarks
This constructor will set the UnsupportedContentDigestAlgorithmAction to FallBackToSHA1
See Also

Reference

CmsInformation Class
CmsInformation Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Constructor (X509Certificate2Collection, PdfContentDigestMethod, UnsupportedContentDigestAlgorithmAction)

Initializes a new instance of the CmsInformation class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmsInformation(
    X509Certificate2Collection certificates,
    PdfContentDigestMethod method,
    UnsupportedContentDigestAlgorithmAction action
)
Public Sub New (
    certificates As X509Certificate2Collection,
    method As PdfContentDigestMethod,
    action As UnsupportedContentDigestAlgorithmAction
)

Parameters

certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
A non-null, non-empty collection of certificates.
method
Type: Atalasoft.PdfDoc.DigitalSignaturesPdfContentDigestMethod
The method that will be used to create a message digest of the PDF file for the signature.
action
Type: Atalasoft.PdfDoc.DigitalSignaturesUnsupportedContentDigestAlgorithmAction
The that will be taken when attempting to sign a document with an unsupported algorithm.
Exceptions
Exception | Condition
ArgumentNullException | certificates
ArgumentOutOfRangeException | certificates
See Also

Reference

CmsInformation Class
CmsInformation Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Constructor (Stream, SecureString, PdfContentDigestMethod, UnsupportedContentDigestAlgorithmAction)

Initializes a new instance of the CmsInformation class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmsInformation(
    Stream certificate,
    SecureString password,
    PdfContentDigestMethod method,
    UnsupportedContentDigestAlgorithmAction action
)
Public Sub New (
    certificate As Stream,
    password As SecureString,
    method As PdfContentDigestMethod,
    action As UnsupportedContentDigestAlgorithmAction
)

Parameters

certificate
Type: System.IOStream
password
Type: System.SecuritySecureString
The password required to access the X.509 certificate data.
method
Type: Atalasoft.PdfDoc.DigitalSignaturesPdfContentDigestMethod
The method that will be used to create a message digest of the PDF file for the signature.
action
Type: Atalasoft.PdfDoc.DigitalSignaturesUnsupportedContentDigestAlgorithmAction
The method that will be taken when attempting to sign a document with an unsupported algorithm.
Exceptions
Exception | Condition
ArgumentNullException | certificates
ArgumentOutOfRangeException | certificates
See Also

Reference

CmsInformation Class
CmsInformation Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Properties

The CmsInformation type exposes the following members.

Properties
 | Name | Description
Public property | Certificates | Gets the certificates collection. This represents the certificate or chain of certificates used to sign the document. The actual signer will always be the first.
Public property | ContentDigestMethod | Gets the content digest method that will be used to create a message digest of the PDF file. Note that this is currently only used for signature creation and not for reflecting the method used in a signed file.
Public property | ContentDigestMethodIsSupported | Gets a value indicating whether the ContentDigestMethod is supported by the provided certificate if it is supported, it will be used as is. If it is unsupported, at the time of saving the document (in PdfDocument or PdfGeneratedDocument) or signing (in PdfDocumentSigner), the UnsupportedContentDigestAlgorithmAction will be invoked.
Public property | UnsupportedContentDigestAlgorithmAction | Gets the action that will be taken when the ContentDigestMethod is not supported.
Top
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation.Certificates Property

CmsInformationCertificates Property

Gets the certificates collection. This represents the certificate or chain of certificates used to sign the document. The actual signer will always be the first.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public X509Certificate2Collection Certificates { get; }
Public ReadOnly Property Certificates As X509Certificate2Collection
    Get

Property Value

Type: X509Certificate2Collection
The certificates.
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation.ContentDigestMethod Property

CmsInformationContentDigestMethod Property

Gets the content digest method that will be used to create a message digest of the PDF file.

Note that this is currently only used for signature creation and not for reflecting the method used in a signed file.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfContentDigestMethod ContentDigestMethod { get; }
Public ReadOnly Property ContentDigestMethod As PdfContentDigestMethod
    Get

Property Value

Type: PdfContentDigestMethod
The content digest method to use to create a message digest of the PDF file.
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation.ContentDigestMethodIsSupported Property

CmsInformationContentDigestMethodIsSupported Property

Gets a value indicating whether the ContentDigestMethod is supported by the provided certificate if it is supported, it will be used as is. If it is unsupported, at the time of saving the document (in PdfDocument or PdfGeneratedDocument) or signing (in PdfDocumentSigner), the UnsupportedContentDigestAlgorithmAction will be invoked.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ContentDigestMethodIsSupported { get; }
Public ReadOnly Property ContentDigestMethodIsSupported As Boolean
    Get

Property Value

Type: Boolean
true if the content digest method is supported; otherwise, false.
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation.UnsupportedContentDigestAlgorithmAction Property

CmsInformationUnsupportedContentDigestAlgorithmAction Property

Gets the action that will be taken when the ContentDigestMethod is not supported.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnsupportedContentDigestAlgorithmAction UnsupportedContentDigestAlgorithmAction { get; }
Public ReadOnly Property UnsupportedContentDigestAlgorithmAction As UnsupportedContentDigestAlgorithmAction
    Get

Property Value

Type: UnsupportedContentDigestAlgorithmAction
The action taken when the ContentDigestMethod is not supported.
Remarks
If set to FallBackToSHA256, the document will be digested and signed using the SHA256 algorithm. If not, DotPdf will throw a PdfException indicating the failure.
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


CmsInformation Methods

The CmsInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CmsInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


DocumentMDPAllowedChanges Enumeration

Describes changes allowed to a certified document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DocumentMDPAllowedChanges
Public Enumeration DocumentMDPAllowedChanges
Members
Member name | Description
NotSpecified | The document did not specify a set of allowed changes. If the document is certified, this is allowable but suspect.
None | No changes of any kind may be made to the document.
FillFormsAndSigning | The document allows users to fill forms and signing the document.
FillFormsSigningAndAnnotations | The document allows users to fill forms, sign the document, and edit annotations (add, remove, modify).
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


FieldDisallowChangeAction Enumeration

When a document is signed, this enum determines whether or not all fields or a subset of of fields will be locked for changes.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FieldDisallowChangeAction
Public Enumeration FieldDisallowChangeAction
Members
Member name | Description
IncludeAll | All non-read-only fields will be marked as read only upon signing.
IncludeSome | The signature will contain a list of fields that will be locked upon signing.
ExcludeSome | The signature will contain a list of fields that will not be locked upon signing, all others will be locked.
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfCertification Class

This class represents the certification information for a signed PDF. The certification is represented by a CmsInformation object, although in the future it may be represented by other types.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesPdfCertification

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCertification
Public Class PdfCertification

The PdfCertification type exposes the following members.

Properties
 | Name | Description
Public property | CmsInformation | Gets the CMS information for signer of the PDF document, if signed using CMS.
Public property | IsValid | Gets a value indicating whether the certification was valid as read from the PDF.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ValidateECDsa |
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfCertification Properties

The PdfCertification type exposes the following members.

Properties
 | Name | Description
Public property | CmsInformation | Gets the CMS information for signer of the PDF document, if signed using CMS.
Public property | IsValid | Gets a value indicating whether the certification was valid as read from the PDF.
Top
See Also

Reference

PdfCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfCertification.CmsInformation Property

PdfCertificationCmsInformation Property

Gets the CMS information for signer of the PDF document, if signed using CMS.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CmsInformation CmsInformation { get; }
Public ReadOnly Property CmsInformation As CmsInformation
    Get

Property Value

Type: CmsInformation
The CMS information.
See Also

Reference

PdfCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfCertification.IsValid Property

PdfCertificationIsValid Property

Gets a value indicating whether the certification was valid as read from the PDF.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get

Property Value

Type: Boolean
true if the certification is valid; otherwise, false.
Remarks
This does not indicate that the document is necessarily valid nor does it necessarily indicate that the associated CmsInformtation is valid. This indicates that when the secure hash was extracted from the CmsInformation in the document that it matches the current hash of the PDF. A mismatch indicates that the file has been modified.
See Also

Reference

PdfCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfCertification Methods

The PdfCertification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ValidateECDsa |
Top
See Also

Reference

PdfCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfCertification.ValidateECDsa Method

PdfCertificationValidateECDsa Method

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ValidateECDsa(
    X509Certificate2 cert,
    byte[] hash,
    byte[] whatToValidate
)
Public Shared Sub ValidateECDsa (
    cert As X509Certificate2,
    hash As Byte(),
    whatToValidate As Byte()
)

Parameters

cert
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
hash
Type: SystemByte
whatToValidate
Type: SystemByte
See Also

Reference

PdfCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfContentDigestMethod Enumeration

When a document is signed, this enum determines the hashing algorithm that is used to create the detached message digest that will embedded in the file.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfContentDigestMethod
Public Enumeration PdfContentDigestMethod
Members
Member name | Description
SHA1 | The sha-1 message digest is a 160 bit hash.
SHA256 | The sha-256 message digest is a 256 bit hash using the general SHA-2 algorithm
SHA384 | The sha-384 message digest is a 384 bit hash using the general SHA-2 algorithm
SHA512 | The sha-256 message digest is a 512 bit hash using the general SHA-2 algorithm
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentCertification Class

The PdfDocumentCertification class is a subclass of BaseDocumentCertification used specifically for certifying documents created by the PdfDocument object.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesBaseSignature
Atalasoft.PdfDoc.DigitalSignaturesBaseDocumentCertification
Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentCertification

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDocumentCertification : BaseDocumentCertification
Public Class PdfDocumentCertification
    Inherits BaseDocumentCertification

The PdfDocumentCertification type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocumentCertification | Initializes a new instance of the PdfDocumentCertification class. This class is used to represent the document certification and placement information for certifying a PDF document. The class is only intended to be used with the PdfDocument object.
Top
Properties
 | Name | Description
Public property | AllowedChanges | Gets or sets the allowed changes, may not be NotSpecified. (Inherited from BaseDocumentCertification.)
Public property | Bounds | Gets or sets the location of the signature on the page in PDF coordinates.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Public property | PageIndex | Gets or sets the index of the page upon which the signature will be placed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentCertification Constructor

Initializes a new instance of the PdfDocumentCertification class. This class is used to represent the document certification and placement information for certifying a PDF document. The class is only intended to be used with the PdfDocument object.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentCertification(
    CmsInformation cmsInfo,
    DocumentMDPAllowedChanges allowedChanges,
    bool isVisible,
    int pageIndex,
    PdfBounds bounds
)
Public Sub New (
    cmsInfo As CmsInformation,
    allowedChanges As DocumentMDPAllowedChanges,
    isVisible As Boolean,
    pageIndex As Integer,
    bounds As PdfBounds
)

Parameters

cmsInfo
Type: Atalasoft.PdfDoc.DigitalSignaturesCmsInformation
The CMS information.
allowedChanges
Type: Atalasoft.PdfDoc.DigitalSignaturesDocumentMDPAllowedChanges
The allowed changes.
isVisible
Type: SystemBoolean
if set to true the signature is visible.
pageIndex
Type: SystemInt32
Index of the page which will contain the signature.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the signature.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | pageIndex should be non-negative or bounds should not be empty if isVisible is true.
See Also

Reference

PdfDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentCertification Properties

The PdfDocumentCertification type exposes the following members.

Properties
 | Name | Description
Public property | AllowedChanges | Gets or sets the allowed changes, may not be NotSpecified. (Inherited from BaseDocumentCertification.)
Public property | Bounds | Gets or sets the location of the signature on the page in PDF coordinates.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Public property | PageIndex | Gets or sets the index of the page upon which the signature will be placed.
Top
See Also

Reference

PdfDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentCertification.Bounds Property

PdfDocumentCertificationBounds Property

Gets or sets the location of the signature on the page in PDF coordinates.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The location of the signature.
See Also

Reference

PdfDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentCertification.PageIndex Property

PdfDocumentCertificationPageIndex Property

Gets or sets the index of the page upon which the signature will be placed.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageIndex { get; set; }
Public Property PageIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index of the page.
See Also

Reference

PdfDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentCertification Methods

The PdfDocumentCertification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

PdfDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignature Class

The PdfDocumentSignature class represents the data needed for applying a digital signature to an existing SignatureWidgetAnnotation object in a PdfDocument. This means that the SignatureWidgetAnnotation must already exist in the PagesOfAnnotations property in the PdfDocumentSigner either because it was pre-existing in the original document or that the document allowed it to be added.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesBaseSignature
Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentSignature

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDocumentSignature : BaseSignature
Public Class PdfDocumentSignature
    Inherits BaseSignature

The PdfDocumentSignature type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocumentSignature | Initializes a new instance of the PdfDocumentSignature class.
Top
Properties
 | Name | Description
Public property | AutoGenerateSignatureAppearance | Gets or sets a value indicating whether DotPdf should automatically generate the signature's AppearanceSet.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Public property | SignatureWidget | Gets the signature widget that will be used for signing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
Examples
This example shows how you can sign a document using PdfDocumentSignature.
Copy
public void SignDoc(PdfDocumentSigner signer, SignatureWidgetAnnotation annot, CmsInformation cmsInfo)
{
    PdfDocumentSignature signature = new PdfDocumentSignature(cmsInfo, signature, true, true);
    signer.SignAndSave(new PdfDocumentSignature[] { signature } );
}
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignature Constructor

Initializes a new instance of the PdfDocumentSignature class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentSignature(
    CmsInformation cmsInfo,
    SignatureWidgetAnnotation signature,
    bool isVisible,
    bool autoGenerateAppearance
)
Public Sub New (
    cmsInfo As CmsInformation,
    signature As SignatureWidgetAnnotation,
    isVisible As Boolean,
    autoGenerateAppearance As Boolean
)

Parameters

cmsInfo
Type: Atalasoft.PdfDoc.DigitalSignaturesCmsInformation
The CMS information for the signature.
signature
Type: Atalasoft.PdfDoc.Generating.AnnotationsSignatureWidgetAnnotation
The signature widget annotation that holds the visual cuing.
isVisible
Type: SystemBoolean
if set to true the signature will be visible.
autoGenerateAppearance
Type: SystemBoolean
if set to true DotPdf will auto-generate an appearance for this signature.
See Also

Reference

PdfDocumentSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignature Properties

The PdfDocumentSignature type exposes the following members.

Properties
 | Name | Description
Public property | AutoGenerateSignatureAppearance | Gets or sets a value indicating whether DotPdf should automatically generate the signature's AppearanceSet.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Public property | SignatureWidget | Gets the signature widget that will be used for signing.
Top
See Also

Reference

PdfDocumentSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignature.AutoGenerateSignatureAppearance Property

PdfDocumentSignatureAutoGenerateSignatureAppearance Property

Gets or sets a value indicating whether DotPdf should automatically generate the signature's AppearanceSet.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateSignatureAppearance { get; set; }
Public Property AutoGenerateSignatureAppearance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf should automatically generate the signature's AppearanceSet; otherwise, false.
See Also

Reference

PdfDocumentSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignature.SignatureWidget Property

PdfDocumentSignatureSignatureWidget Property

Gets the signature widget that will be used for signing.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureWidgetAnnotation SignatureWidget { get; }
Public ReadOnly Property SignatureWidget As SignatureWidgetAnnotation
    Get

Property Value

Type: SignatureWidgetAnnotation
The signature widget.
See Also

Reference

PdfDocumentSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignature Methods

The PdfDocumentSignature type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

PdfDocumentSignature Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation Class

PdfDocumentSignatureInformation is a class that contains information that was retrieved from an existing signed or certified PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentSignatureInformation

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDocumentSignatureInformation
Public Class PdfDocumentSignatureInformation

The PdfDocumentSignatureInformation type exposes the following members.

Properties
 | Name | Description
Public property | AllowedChanges | Gets the allowed changes to the document.
Public property | Certificate | Gets the certificate associated with the document or null if there is no certificate.
Public property | ErrorsEncountered | Gets a description of the errors encountered, if any, while attempting to get signature information from a PDF file. If there were no errors, this will be an empty string.
Public property | HasSignatures | Gets a value indicating whether a PDF document has signatures.
Public property | IsCertified | Gets a value indicating whether a PDF document is certified.
Public property | SignatureCount | Gets the total number of signature fields in the document.
Public property | Signatures | Gets the list of signatures in the document. A signature, represented by a PdfSignatureInformation object may be signed or unsigned.
Public property | SignedSignatureCount | Gets the total number of signed signatures in the document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this PDF-oriented aspects of the signatures within the document.
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation Properties

The PdfDocumentSignatureInformation type exposes the following members.

Properties
 | Name | Description
Public property | AllowedChanges | Gets the allowed changes to the document.
Public property | Certificate | Gets the certificate associated with the document or null if there is no certificate.
Public property | ErrorsEncountered | Gets a description of the errors encountered, if any, while attempting to get signature information from a PDF file. If there were no errors, this will be an empty string.
Public property | HasSignatures | Gets a value indicating whether a PDF document has signatures.
Public property | IsCertified | Gets a value indicating whether a PDF document is certified.
Public property | SignatureCount | Gets the total number of signature fields in the document.
Public property | Signatures | Gets the list of signatures in the document. A signature, represented by a PdfSignatureInformation object may be signed or unsigned.
Public property | SignedSignatureCount | Gets the total number of signed signatures in the document.
Top
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.AllowedChanges Property

PdfDocumentSignatureInformationAllowedChanges Property

Gets the allowed changes to the document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentMDPAllowedChanges AllowedChanges { get; }
Public ReadOnly Property AllowedChanges As DocumentMDPAllowedChanges
    Get

Property Value

Type: DocumentMDPAllowedChanges
The allowed changes to the document. If set to NotSpecified, the document did not provide a set of changes. If IsCertified is false, this will be set to NotSpecified. If IsCertified is true, this is technically allowable but is suspect.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.Certificate Property

PdfDocumentSignatureInformationCertificate Property

Gets the certificate associated with the document or null if there is no certificate.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfSignatureInformation Certificate { get; }
Public ReadOnly Property Certificate As PdfSignatureInformation
    Get

Property Value

Type: PdfSignatureInformation
The certificate for the document.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.ErrorsEncountered Property

PdfDocumentSignatureInformationErrorsEncountered Property

Gets a description of the errors encountered, if any, while attempting to get signature information from a PDF file. If there were no errors, this will be an empty string.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<SignatureValidationError> ErrorsEncountered { get; }
Public ReadOnly Property ErrorsEncountered As IList(Of SignatureValidationError)
    Get

Property Value

Type: IListSignatureValidationError
The errors encountered while opening a PDF file.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.HasSignatures Property

PdfDocumentSignatureInformationHasSignatures Property

Gets a value indicating whether a PDF document has signatures.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasSignatures { get; }
Public ReadOnly Property HasSignatures As Boolean
    Get

Property Value

Type: Boolean
true if a PDF document has signatures; otherwise, false.
Remarks
This only indicates the presence of signatures not whether they are signed or valid.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.IsCertified Property

PdfDocumentSignatureInformationIsCertified Property

Gets a value indicating whether a PDF document is certified.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCertified { get; }
Public ReadOnly Property IsCertified As Boolean
    Get

Property Value

Type: Boolean
true if a PDF document is certified; otherwise, false.
Remarks
This property does not indicate that the certificate is valid, only that it is present.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.SignatureCount Property

PdfDocumentSignatureInformationSignatureCount Property

Gets the total number of signature fields in the document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SignatureCount { get; }
Public ReadOnly Property SignatureCount As Integer
    Get

Property Value

Type: Int32
The signature count of the document.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.Signatures Property

PdfDocumentSignatureInformationSignatures Property

Gets the list of signatures in the document. A signature, represented by a PdfSignatureInformation object may be signed or unsigned.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfSignatureInformation> Signatures { get; }
Public ReadOnly Property Signatures As IList(Of PdfSignatureInformation)
    Get

Property Value

Type: IListPdfSignatureInformation
The list of signatures in the document.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.SignedSignatureCount Property

PdfDocumentSignatureInformationSignedSignatureCount Property

Gets the total number of signed signatures in the document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SignedSignatureCount { get; }
Public ReadOnly Property SignedSignatureCount As Integer
    Get

Property Value

Type: Int32
The signed signature count of the document.
Remarks
This does not reflect whether or not the signatures are valid.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation Methods

The PdfDocumentSignatureInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this PDF-oriented aspects of the signatures within the document.
Top
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSignatureInformation.Validate Method

PdfDocumentSignatureInformationValidate Method

Validates this PDF-oriented aspects of the signatures within the document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<SignatureValidationError> Validate()
Public Function Validate As IList(Of SignatureValidationError)

Return Value

Type: IListSignatureValidationError
A list of possible errors. If there are not errors, returns an empty list.
Remarks
DotPdf does not validate the content of the X509 certificates that were used to sign the document. How that should be done is strictly up to client code. This method instead will look at the aspects of the document that are not controlled by the signining certificates. For example, did a program modify the PDF document in a way that was forbidden by either the document's Certification or by one or more SignatureWidgetAnnotation\ objects within the document.
See Also

Reference

PdfDocumentSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Class

PdfDocumentSigner is a class that is responsible for getting information about DigitalSignatures within a PDF document and applying signatures to a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesPdfDocumentSigner

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDocumentSigner : IDisposable
Public Class PdfDocumentSigner
    Implements IDisposable

The PdfDocumentSigner type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocumentSigner(Stream, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfDocumentSigner class.
Public method | PdfDocumentSigner(Stream, SecureString, SecureString, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfDocumentSigner class.
Public method | PdfDocumentSigner(String, String, Stream, PdfDocumentLoadedProgress) | Obsolete. Initializes a new instance of the PdfDocumentSigner class.
Top
Properties
 | Name | Description
Public property | Form | Gets or sets the form object for the document. By default, this is null.
Public property | Info | Gets the signature information about the document signatures as the result of opening the document.
Public property | PagesOfAnnotations | Gets the pages of annotations within the PDF document. This is a read-only collection and can't be modified. Each element represents a page in the document in order. If a page has no annotations, it will contain an empty collection. If a document disallows adding or removing annotations, each collection will be a read- only collection.
Public property | Resources | Gets or sets the global resources.
Top
Methods
 | Name | Description
Public method | AppendChangesFinal | Appends any changes made to annotations and form fields to the Stream provided in the constructor. After calling this method, this object is considered dead and can no longer be used for appending more changes or appending signatures. Further changes require constructing a new PdfDocumentSignerObject.
Public method | AppendSignaturesFinal | This method will sign, in turn, the provided collection of PdfDocumentSignature then append all changes to the PDF document. After calling this method, this object is considered dead and can no longer be used for appending more changes or appending signatures. Further changes require constructing a new PdfDocumentSignerObject.
Public method | Dispose | Releases all resources used by the PdfDocumentSigner
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfDocumentSigner and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetInfo(Stream) | Gets the signature information for a PDF document.
 | GetInfo(Stream, SecureString, SecureString) | Gets the signature information for a PDF document.
 | GetInfo(String, String, Stream) | Obsolete. Gets the signature information for a PDF document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Constructor

Overload List
 | Name | Description
Public method | PdfDocumentSigner(Stream, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfDocumentSigner class.
Public method | PdfDocumentSigner(Stream, SecureString, SecureString, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfDocumentSigner class.
Public method | PdfDocumentSigner(String, String, Stream, PdfDocumentLoadedProgress) | Obsolete. Initializes a new instance of the PdfDocumentSigner class.
Top
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Constructor (Stream, PdfDocumentLoadedProgress)

Initializes a new instance of the PdfDocumentSigner class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentSigner(
    Stream stream,
    PdfDocumentLoadedProgress pageLoaded
)
Public Sub New (
    stream As Stream,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

stream
Type: System.IOStream
The stream containing a PDF document.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
The page loaded handler.
See Also

Reference

PdfDocumentSigner Class
PdfDocumentSigner Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Constructor (Stream, SecureString, SecureString, PdfDocumentLoadedProgress)

Initializes a new instance of the PdfDocumentSigner class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentSigner(
    Stream stream,
    SecureString userPassword,
    SecureString ownerPassword,
    PdfDocumentLoadedProgress pageLoaded
)
Public Sub New (
    stream As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

stream
Type: System.IOStream
The stream containing a PDF document.
userPassword
Type: System.SecuritySecureString
The optional user password for the document.
ownerPassword
Type: System.SecuritySecureString
The optional owner password for the document.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
The page loaded handler.
Exceptions
Exception | Condition
PdfException | Throws a PdfException if one or more fatal errors occurred getting signature information. The exception message will contain the specifics of the errors. These messages are taken from a PdfDocumentSignatureInformation object.
See Also

Reference

PdfDocumentSigner Class
PdfDocumentSigner Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Constructor (String, String, Stream, PdfDocumentLoadedProgress)

Note: This API is now obsolete.

Initializes a new instance of the PdfDocumentSigner class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfDocumentSigner(Stream stream, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded) instead.",
    false)]
public PdfDocumentSigner(
    string userPassword,
    string ownerPassword,
    Stream stream,
    PdfDocumentLoadedProgress pageLoaded
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfDocumentSigner(Stream stream, SecureString userPassword, SecureString ownerPassword, PdfDocumentLoadedProgress pageLoaded) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stream As Stream,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

userPassword
Type: SystemString
The optional user password for the document.
ownerPassword
Type: SystemString
The optional owner password for the document.
stream
Type: System.IOStream
The stream containing a PDF document.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
The page loaded handler.
Exceptions
Exception | Condition
PdfException | Throws a PdfException if one or more fatal errors occurred getting signature information. The exception message will contain the specifics of the errors. These messages are taken from a PdfDocumentSignatureInformation object.
See Also

Reference

PdfDocumentSigner Class
PdfDocumentSigner Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Properties

The PdfDocumentSigner type exposes the following members.

Properties
 | Name | Description
Public property | Form | Gets or sets the form object for the document. By default, this is null.
Public property | Info | Gets the signature information about the document signatures as the result of opening the document.
Public property | PagesOfAnnotations | Gets the pages of annotations within the PDF document. This is a read-only collection and can't be modified. Each element represents a page in the document in order. If a page has no annotations, it will contain an empty collection. If a document disallows adding or removing annotations, each collection will be a read- only collection.
Public property | Resources | Gets or sets the global resources.
Top
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.Form Property

PdfDocumentSignerForm Property

Gets or sets the form object for the document. By default, this is null.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfForm Form { get; }
Public ReadOnly Property Form As PdfForm
    Get

Property Value

Type: PdfForm
The form.
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.Info Property

PdfDocumentSignerInfo Property

Gets the signature information about the document signatures as the result of opening the document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentSignatureInformation Info { get; }
Public ReadOnly Property Info As PdfDocumentSignatureInformation
    Get

Property Value

Type: PdfDocumentSignatureInformation
The signature information for the document.
Remarks
This is object is equivalent to
Copy
PdfDocumentSigner.GetInfo(stm)
.
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.PagesOfAnnotations Property

PdfDocumentSignerPagesOfAnnotations Property

Gets the pages of annotations within the PDF document. This is a read-only collection and can't be modified. Each element represents a page in the document in order. If a page has no annotations, it will contain an empty collection. If a document disallows adding or removing annotations, each collection will be a read- only collection.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOnlyCollection<IList<BaseAnnotation>> PagesOfAnnotations { get; }
Public ReadOnly Property PagesOfAnnotations As ReadOnlyCollection(Of IList(Of BaseAnnotation))
    Get

Property Value

Type: ReadOnlyCollectionIListBaseAnnotation
The pages of annotations.
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.Resources Property

PdfDocumentSignerResources Property

Gets or sets the global resources.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalResources Resources { get; }
Public ReadOnly Property Resources As GlobalResources
    Get

Property Value

Type: GlobalResources
The global resources.
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner Methods

The PdfDocumentSigner type exposes the following members.

Methods
 | Name | Description
Public method | AppendChangesFinal | Appends any changes made to annotations and form fields to the Stream provided in the constructor. After calling this method, this object is considered dead and can no longer be used for appending more changes or appending signatures. Further changes require constructing a new PdfDocumentSignerObject.
Public method | AppendSignaturesFinal | This method will sign, in turn, the provided collection of PdfDocumentSignature then append all changes to the PDF document. After calling this method, this object is considered dead and can no longer be used for appending more changes or appending signatures. Further changes require constructing a new PdfDocumentSignerObject.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetInfo(Stream) | Gets the signature information for a PDF document.
 | GetInfo(Stream, SecureString, SecureString) | Gets the signature information for a PDF document.
 | GetInfo(String, String, Stream) | Obsolete. Gets the signature information for a PDF document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.AppendChangesFinal Method

PdfDocumentSignerAppendChangesFinal Method

Appends any changes made to annotations and form fields to the Stream provided in the constructor. After calling this method, this object is considered dead and can no longer be used for appending more changes or appending signatures. Further changes require constructing a new PdfDocumentSignerObject.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AppendChangesFinal(
    bool closeStream
)
Public Sub AppendChangesFinal (
    closeStream As Boolean
)

Parameters

closeStream
Type: SystemBoolean
if set to true close the initial stream.
Remarks
If closeStream is true, the stream will not be closed in the event of an error.

This is an append action, not a rewrite action and will modify the original stream. If you need to preserve the original stream, copy it to a temporary stream first, then use that stream for making changes.

See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.AppendSignaturesFinal Method

PdfDocumentSignerAppendSignaturesFinal Method

This method will sign, in turn, the provided collection of PdfDocumentSignature then append all changes to the PDF document. After calling this method, this object is considered dead and can no longer be used for appending more changes or appending signatures. Further changes require constructing a new PdfDocumentSignerObject.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AppendSignaturesFinal(
    bool closeStream,
    ICollection<PdfDocumentSignature> signatures
)
Public Sub AppendSignaturesFinal (
    closeStream As Boolean,
    signatures As ICollection(Of PdfDocumentSignature)
)

Parameters

closeStream
Type: SystemBoolean
if set to true close the stream containing the PDF upon completion.
signatures
Type: System.Collections.GenericICollectionPdfDocumentSignature
The signatures.
Exceptions
Exception | Condition
ArgumentNullException | signatures
ArgumentException | signatures
Remarks
Each PdfDocumentSignature object must contain an unsigned SignatureWidgetAnnotation which is also contained in both the PagesOfAnnotations collection as well as the Form.

Each signature will be checked for validity, will have an appearance applied to it (if requested), and, the signature applied and finally any fields that are required to be locked will be locked.

See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.Dispose Method

PdfDocumentSignerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfDocumentSigner
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfDocumentSigner and optionally releases the managed resources
Top
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.Dispose Method

PdfDocumentSignerDispose Method

Releases all resources used by the PdfDocumentSigner

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfDocumentSigner Class
Dispose Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.Dispose Method (Boolean)

PdfDocumentSignerDispose Method (Boolean)

Releases the unmanaged resources used by the PdfDocumentSigner and optionally releases the managed resources

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfDocumentSigner Class
Dispose Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.GetInfo Method

PdfDocumentSignerGetInfo Method

Overload List
Name | Description
GetInfo(Stream) | Gets the signature information for a PDF document.
GetInfo(Stream, SecureString, SecureString) | Gets the signature information for a PDF document.
GetInfo(String, String, Stream) | Obsolete. Gets the signature information for a PDF document.
Top
See Also

Reference

PdfDocumentSigner Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.GetInfo Method (Stream)

PdfDocumentSignerGetInfo Method (Stream)

Gets the signature information for a PDF document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDocumentSignatureInformation GetInfo(
    Stream stream
)
Public Shared Function GetInfo (
    stream As Stream
) As PdfDocumentSignatureInformation

Parameters

stream
Type: System.IOStream
The stream that contains a PDF file.

Return Value

Type: PdfDocumentSignatureInformation
A new PdfDocumentSignatureInformation object.
See Also

Reference

PdfDocumentSigner Class
GetInfo Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.GetInfo Method (Stream, SecureString, SecureString)

PdfDocumentSignerGetInfo Method (Stream, SecureString, SecureString)

Gets the signature information for a PDF document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfDocumentSignatureInformation GetInfo(
    Stream stream,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Shared Function GetInfo (
    stream As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString
) As PdfDocumentSignatureInformation

Parameters

stream
Type: System.IOStream
The stream that contains a PDF file.
userPassword
Type: System.SecuritySecureString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: System.SecuritySecureString
The owner password to use for this document. This parameter may be null.

Return Value

Type: PdfDocumentSignatureInformation
Exceptions
Exception | Condition
ArgumentNullException | stream
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocumentSigner Class
GetInfo Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfDocumentSigner.GetInfo Method (String, String, Stream)

PdfDocumentSignerGetInfo Method (String, String, Stream)

Note: This API is now obsolete.

Gets the signature information for a PDF document.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use GetInfo(Stream stream, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public static PdfDocumentSignatureInformation GetInfo(
    string userPassword,
    string ownerPassword,
    Stream stream
)
<ObsoleteAttribute("This method is obsolete. Use GetInfo(Stream stream, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Shared Function GetInfo (
    userPassword As String,
    ownerPassword As String,
    stream As Stream
) As PdfDocumentSignatureInformation

Parameters

userPassword
Type: SystemString
The user password to use for this document. This parameter may be null.
ownerPassword
Type: SystemString
The owner password to use for this document. This parameter may be null.
stream
Type: System.IOStream
The stream that contains a PDF file.

Return Value

Type: PdfDocumentSignatureInformation
Exceptions
Exception | Condition
ArgumentNullException | stream
IncorrectPasswordException | If the password is incorrect or cannot be verified, the constructor will throw a IncorrectPasswordException.
See Also

Reference

PdfDocumentSigner Class
GetInfo Overload
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfGeneratedDocumentCertification Class

The PdfGeneratedDocumentCertification class is a subclass of the BaseDocumentCertification class which is used specifically to control the appearance of signatures in a PdfGeneratedDocument object.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesBaseSignature
Atalasoft.PdfDoc.DigitalSignaturesBaseDocumentCertification
Atalasoft.PdfDoc.DigitalSignaturesPdfGeneratedDocumentCertification

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfGeneratedDocumentCertification : BaseDocumentCertification
Public Class PdfGeneratedDocumentCertification
    Inherits BaseDocumentCertification

The PdfGeneratedDocumentCertification type exposes the following members.

Constructors
 | Name | Description
Public method | PdfGeneratedDocumentCertification | Initializes a new instance of the PdfGeneratedDocumentCertification class. This class is used to represent the document certification and placement information for certifying a PDF document. The class is only intended to be used with the PdfGeneratedDocument object.
Top
Properties
 | Name | Description
Public property | AllowedChanges | Gets or sets the allowed changes, may not be NotSpecified. (Inherited from BaseDocumentCertification.)
Public property | AutoGenerateSignatureAppearance | Gets or sets a value indicating whether DotPdf should automatically generate the signature's AppearanceSet.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Public property | Signature | Gets or sets the SignatureWidgetAnnotation that represents the signature. This is required whether or not IsVisible is true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfGeneratedDocumentCertification Constructor

Initializes a new instance of the PdfGeneratedDocumentCertification class. This class is used to represent the document certification and placement information for certifying a PDF document. The class is only intended to be used with the PdfGeneratedDocument object.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocumentCertification(
    CmsInformation cmsInfo,
    DocumentMDPAllowedChanges allowedChanges,
    bool isVisible,
    SignatureWidgetAnnotation signature,
    bool autoGenerateSignatureAppearance
)
Public Sub New (
    cmsInfo As CmsInformation,
    allowedChanges As DocumentMDPAllowedChanges,
    isVisible As Boolean,
    signature As SignatureWidgetAnnotation,
    autoGenerateSignatureAppearance As Boolean
)

Parameters

cmsInfo
Type: Atalasoft.PdfDoc.DigitalSignaturesCmsInformation
The CMS information.
allowedChanges
Type: Atalasoft.PdfDoc.DigitalSignaturesDocumentMDPAllowedChanges
The allowed changes.
isVisible
Type: SystemBoolean
if set to true the signature is visible.
signature
Type: Atalasoft.PdfDoc.Generating.AnnotationsSignatureWidgetAnnotation
The annotation representing the signature.
autoGenerateSignatureAppearance
Type: SystemBoolean
if set to true DotPdf should automatically generate the signature's AppearanceSet.
Exceptions
Exception | Condition
ArgumentNullException | signature
See Also

Reference

PdfGeneratedDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfGeneratedDocumentCertification Properties

The PdfGeneratedDocumentCertification type exposes the following members.

Properties
 | Name | Description
Public property | AllowedChanges | Gets or sets the allowed changes, may not be NotSpecified. (Inherited from BaseDocumentCertification.)
Public property | AutoGenerateSignatureAppearance | Gets or sets a value indicating whether DotPdf should automatically generate the signature's AppearanceSet.
Public property | CmsInformation | Gets or sets the CMS information used to sign the document including the signatures. (Inherited from BaseSignature.)
Public property | IsVisible | Gets or sets a value indicating whether the signature is visible. (Inherited from BaseSignature.)
Public property | Signature | Gets or sets the SignatureWidgetAnnotation that represents the signature. This is required whether or not IsVisible is true.
Top
See Also

Reference

PdfGeneratedDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfGeneratedDocumentCertification.AutoGenerateSignatureAppearance Property

PdfGeneratedDocumentCertificationAutoGenerateSignatureAppearance Property

Gets or sets a value indicating whether DotPdf should automatically generate the signature's AppearanceSet.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateSignatureAppearance { get; set; }
Public Property AutoGenerateSignatureAppearance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf should automatically generate the signature's AppearanceSet; otherwise, false.
See Also

Reference

PdfGeneratedDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfGeneratedDocumentCertification.Signature Property

PdfGeneratedDocumentCertificationSignature Property

Gets or sets the SignatureWidgetAnnotation that represents the signature. This is required whether or not IsVisible is true.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureWidgetAnnotation Signature { get; }
Public ReadOnly Property Signature As SignatureWidgetAnnotation
    Get

Property Value

Type: SignatureWidgetAnnotation
The SignatureWidgetAnnotation for the certification.
See Also

Reference

PdfGeneratedDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfGeneratedDocumentCertification Methods

The PdfGeneratedDocumentCertification type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseSignature.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list. (Inherited from BaseSignature.)
Top
See Also

Reference

PdfGeneratedDocumentCertification Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation Class

This is an information class that represents the data associated with a digital signature applied to a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesPdfSignatureInformation

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfSignatureInformation
Public Class PdfSignatureInformation

The PdfSignatureInformation type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationIndex | Gets the 0-based index of the associated SignatureWidgetAnnotation in the page's annotation collection.
Public property | Certification | Gets the certification for the signature.
Public property | ContactInfo | Gets the information provided by the signer to enable a recipient to contact the signer to verify the signature. For example, a phone number.
Public property | Filter | Gets the name of the preferred signature handler to use when validating this signature.
Public property | IsSigned | Gets a value indicating whether the given signature is signed.
Public property | IsVisible | Gets a value indicating whether the signature is visible.
Public property | Location | Gets the CPU host name or physical location of the signing.
Public property | PageNumber | Gets the 0-based page number on which the associated SignatureWidgetAnnotation exists.
Public property | Reason | Gets the reason for the signing, such as (I agree...).
Public property | SignatureAuthor | Gets the name of the person or authority signing the document. This value should be used only when it is not possible to extract the name from the signature.
Public property | SignatureFieldName | Gets the name of the associated SignatureWidgetAnnotation. This will be a string in full "dotted name" form used by the PDF specification.
Public property | SigningIteration | Gets the signing iteration for this document. This is an indication of when this signature was applied relative to other signature annotations.
Public property | SigningTime | Gets the time of signing. Depending on the signature handler, this may be a normal unverified computer time or a time generated in a verifiable way from a secure time server. This value should be used only when the time of signing is not available in the signature.
Public property | SubFilter | Gets a name that describes the encoding of the signature value. May be used by any handler that supports this format to validate the signature.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation Properties

The PdfSignatureInformation type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationIndex | Gets the 0-based index of the associated SignatureWidgetAnnotation in the page's annotation collection.
Public property | Certification | Gets the certification for the signature.
Public property | ContactInfo | Gets the information provided by the signer to enable a recipient to contact the signer to verify the signature. For example, a phone number.
Public property | Filter | Gets the name of the preferred signature handler to use when validating this signature.
Public property | IsSigned | Gets a value indicating whether the given signature is signed.
Public property | IsVisible | Gets a value indicating whether the signature is visible.
Public property | Location | Gets the CPU host name or physical location of the signing.
Public property | PageNumber | Gets the 0-based page number on which the associated SignatureWidgetAnnotation exists.
Public property | Reason | Gets the reason for the signing, such as (I agree...).
Public property | SignatureAuthor | Gets the name of the person or authority signing the document. This value should be used only when it is not possible to extract the name from the signature.
Public property | SignatureFieldName | Gets the name of the associated SignatureWidgetAnnotation. This will be a string in full "dotted name" form used by the PDF specification.
Public property | SigningIteration | Gets the signing iteration for this document. This is an indication of when this signature was applied relative to other signature annotations.
Public property | SigningTime | Gets the time of signing. Depending on the signature handler, this may be a normal unverified computer time or a time generated in a verifiable way from a secure time server. This value should be used only when the time of signing is not available in the signature.
Public property | SubFilter | Gets a name that describes the encoding of the signature value. May be used by any handler that supports this format to validate the signature.
Top
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.AnnotationIndex Property

PdfSignatureInformationAnnotationIndex Property

Gets the 0-based index of the associated SignatureWidgetAnnotation in the page's annotation collection.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AnnotationIndex { get; }
Public ReadOnly Property AnnotationIndex As Integer
    Get

Property Value

Type: Int32
The index of the associated SignatureWidgetAnnotation.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.Certification Property

PdfSignatureInformationCertification Property

Gets the certification for the signature.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCertification Certification { get; }
Public ReadOnly Property Certification As PdfCertification
    Get

Property Value

Type: PdfCertification
The PdfCertification for the signature or null if not signed.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.ContactInfo Property

PdfSignatureInformationContactInfo Property

Gets the information provided by the signer to enable a recipient to contact the signer to verify the signature. For example, a phone number.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ContactInfo { get; }
Public ReadOnly Property ContactInfo As String
    Get

Property Value

Type: String
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.Filter Property

PdfSignatureInformationFilter Property

Gets the name of the preferred signature handler to use when validating this signature.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Filter { get; }
Public ReadOnly Property Filter As String
    Get

Property Value

Type: String
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.IsSigned Property

PdfSignatureInformationIsSigned Property

Gets a value indicating whether the given signature is signed.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSigned { get; }
Public ReadOnly Property IsSigned As Boolean
    Get

Property Value

Type: Boolean
true if the signature is signed; otherwise, false.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.IsVisible Property

PdfSignatureInformationIsVisible Property

Gets a value indicating whether the signature is visible.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsVisible { get; }
Public ReadOnly Property IsVisible As Boolean
    Get

Property Value

Type: Boolean
true if the signature is visible; otherwise, false.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.Location Property

PdfSignatureInformationLocation Property

Gets the CPU host name or physical location of the signing.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get

Property Value

Type: String
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.PageNumber Property

PdfSignatureInformationPageNumber Property

Gets the 0-based page number on which the associated SignatureWidgetAnnotation exists.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get

Property Value

Type: Int32
The page number of the associated SignatureWidgetAnnotation.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.Reason Property

PdfSignatureInformationReason Property

Gets the reason for the signing, such as (I agree...).

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Reason { get; }
Public ReadOnly Property Reason As String
    Get

Property Value

Type: String
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.SignatureAuthor Property

PdfSignatureInformationSignatureAuthor Property

Gets the name of the person or authority signing the document. This value should be used only when it is not possible to extract the name from the signature.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SignatureAuthor { get; }
Public ReadOnly Property SignatureAuthor As String
    Get

Property Value

Type: String
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.SignatureFieldName Property

PdfSignatureInformationSignatureFieldName Property

Gets the name of the associated SignatureWidgetAnnotation. This will be a string in full "dotted name" form used by the PDF specification.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SignatureFieldName { get; }
Public ReadOnly Property SignatureFieldName As String
    Get

Property Value

Type: String
The name of the signature field.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.SigningIteration Property

PdfSignatureInformationSigningIteration Property

Gets the signing iteration for this document. This is an indication of when this signature was applied relative to other signature annotations.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SigningIteration { get; }
Public ReadOnly Property SigningIteration As Integer
    Get

Property Value

Type: Int32
The signing iteration, 0 indicated an unsigned signature.
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.SigningTime Property

PdfSignatureInformationSigningTime Property

Gets the time of signing. Depending on the signature handler, this may be a normal unverified computer time or a time generated in a verifiable way from a secure time server. This value should be used only when the time of signing is not available in the signature.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime SigningTime { get; }
Public ReadOnly Property SigningTime As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation.SubFilter Property

PdfSignatureInformationSubFilter Property

Gets a name that describes the encoding of the signature value. May be used by any handler that supports this format to validate the signature.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SubFilter { get; }
Public ReadOnly Property SubFilter As String
    Get

Property Value

Type: String
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


PdfSignatureInformation Methods

The PdfSignatureInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfSignatureInformation Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationError Class

Represents an error while validating digital signatures
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.DigitalSignaturesSignatureValidationError

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SignatureValidationError
Public Class SignatureValidationError

The SignatureValidationError type exposes the following members.

Constructors
 | Name | Description
Public method | SignatureValidationError | Initializes a new instance of the SignatureValidationError class.
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message.
Public property | Severity | Gets the severity.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationError Constructor

Initializes a new instance of the SignatureValidationError class.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureValidationError(
    string message,
    SignatureValidationErrorSeverity severity
)
Public Sub New (
    message As String,
    severity As SignatureValidationErrorSeverity
)

Parameters

message
Type: SystemString
The message associated with the error.
severity
Type: Atalasoft.PdfDoc.DigitalSignaturesSignatureValidationErrorSeverity
The severity of the error.
Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

SignatureValidationError Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationError Properties

The SignatureValidationError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message.
Public property | Severity | Gets the severity.
Top
See Also

Reference

SignatureValidationError Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationError.ErrorMessage Property

SignatureValidationErrorErrorMessage Property

Gets the error message.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get

Property Value

Type: String
The error message.
See Also

Reference

SignatureValidationError Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationError.Severity Property

SignatureValidationErrorSeverity Property

Gets the severity.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureValidationErrorSeverity Severity { get; }
Public ReadOnly Property Severity As SignatureValidationErrorSeverity
    Get

Property Value

Type: SignatureValidationErrorSeverity
The severity.
See Also

Reference

SignatureValidationError Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationError Methods

The SignatureValidationError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SignatureValidationError Class
Atalasoft.PdfDoc.DigitalSignatures Namespace


SignatureValidationErrorSeverity Enumeration

Describes the severity of an error that occurred while validating a PDF digital signature

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SignatureValidationErrorSeverity
Public Enumeration SignatureValidationErrorSeverity
Members
Member name | Description
Information | Occurs when there is no issue, but there is associated information.
Warning | Occurs when the issue may be acceptable under certain circumstances.
Fatal | Occurs when the issue is not acceptable.
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


UnsupportedContentDigestAlgorithmAction Enumeration

Defines the action to be taken when the contentdigest algorithm is not supported.

Namespace: Atalasoft.PdfDoc.DigitalSignatures
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum UnsupportedContentDigestAlgorithmAction
Public Enumeration UnsupportedContentDigestAlgorithmAction
Members
Member name | Description
FallBackToSHA1 | Fall back to the SHA1 digest algorithm. Can be used for PDF 1.7 and lower.
FallBackToSHA256 | Fall back to the SHA256 digest algorithm.
ThrowException | The throw an exception. Note that throwing an exception will result in an incompletely written file.
See Also

Reference

Atalasoft.PdfDoc.DigitalSignatures Namespace


Atalasoft.PdfDoc.Examiner Namespace

Classes
 | Class | Description
Public class | ExaminerResults | ExaminerResults represents the results of information about a PDF that can be determined without extensive scanning of the document. Not all information within the results is exhaustive and therefore may have either false positives or false negatives depending on the actual document content. To the greatest extent possible, these false indicators are benign except where noted.


ExaminerResults Class

ExaminerResults represents the results of information about a PDF that can be determined without extensive scanning of the document. Not all information within the results is exhaustive and therefore may have either false positives or false negatives depending on the actual document content. To the greatest extent possible, these false indicators are benign except where noted.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.ExaminerExaminerResults

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ExaminerResults
Public Class ExaminerResults

The ExaminerResults type exposes the following members.

Properties
 | Name | Description
Public property | DocumentVersion | Gets the document version advertised by the document. The resulting value is the maximum of the value in the document header and the value in the document catalog. The value will always be for the form major.minor. Currently major is always 1. Note many incorrect documents contain PDF features that are beyond their advertised version.
Public property | ErrorsEncountered | Gets a list of errors encountered while opening the document. Since only a narrow subset of the document is examined, this list is not guaranteed to be exhaustive.
Public property | FormUsesXFA | Gets a value indicating whether the AcroForm in the document uses Adobe's Extensible Form Architecture, XFA.
Public property | HasForm | Gets a value indicating whether the document contains an AcroForm.
Public property | HasSignatures | Gets a value indicating whether the AcroForm advertises that it contains digital signatures. This does not indicate that the signatures are valid.
Public property | HasXmp | Gets a value indicating whether the document has XMP metatdata.
Public property | IsBadlyDamaged | Gets a value indicating whether the document is badly damaged. If, during the process of opening the file, errors were encountered that were of Major severity or worse then IsBadlyDamaged will be set to true. If true, only the properties IsPdf, [P:IsValidHeader], and IsEncrypted will be valid. All other values are suspect.
Public property | IsEncrypted | Gets a value indicating whether the document contains encryption. Not all documents that are encrypted require a non-empty password. This property merely indicates that a password might be required to correctly open the document. If FromStream(Stream, SecureString, SecureString) throws an IncorrectPasswordException, then the document requires a non-empty password or the supplied password(s) are incorrect.
Public property | IsIncorrectVersionForXrefStream | Gets a value indicating whether the PDF document's advertised document version is incorrect. Specifically, some PDF document generators use a PDF featured called cross-reference streams that require that the document be version 1.5 or greater. If there is evidence of a cross-reference stream and the version is less than 1.5, this property will true.
Public property | IsPdf | Gets a value indicating whether the document is a PDF. This test is more lenient than the specification allows and will return true if the document contains the PDF header including in some pathological cases. If the PDF header meets specification, [P:IsValidHeader] will return true. If it returns false, the document is well out-of-spec and no other information in ExaminerResults will be valid.
Public property | IsPdfA | Gets a value indicating whether the document advertises itself as conforming to the PDF/A-1b archival specification. This does not mean that the document in any way complies with the specification, merely that it says it does. For example, if IsPdfA returns true and HasXmp returns false, then the document is NOT a PDF/A compliant document.
Public property | IsPdfPortfolio | Gets a value indicating whether the document contains a PDF Portfolio. This test looks specifically for a Collection object in the document's catalog. A PDF Portfolio is a feature wherein a PDF document doesn't necessarily contain any PDF data at all, but instead contains a series of embedded files which represent the content of the document. Some PDF documents that have a Portfolion include an ersatz page which is shown for compatibility. The presentation of embedded files is application dependent.
Public property | IsValidPdfHeader | Gets a value indicating whether the document contains a valid PDF header. If the document does not meet the PDF specification for a header but still contains the text "%PDF-" this will return false. For example, if the document start with the following: %!PS-Adobe - this is PostScript not %PDF-1.0 this will be considered to be a PDF, even though it is not within specification (and because it's labeled as PostScript, it will likely generate other errors).
Public property | Metadata | Gets the metadata associated with the PDF document from the DocumentInfo object within the file. This value may be null.
Public property | PageCount | Gets the page count of the document.
Public property | RequiresDynamicFormRendering | Gets a value indicating whether requires dynamic form rendering. Typically, this is set when a document contains an XFA form and has embedded form data that has not yet been converted into PDF content.
Top
Methods
Name Description
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
FromStream(Stream)
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
If the document is encrypted, FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
FromStream(Stream, SecureString, SecureString)
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
FromStream(Stream, String, String) Obsolete.
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults Properties

The ExaminerResults type exposes the following members.

Properties
 | Name | Description
Public property | DocumentVersion | Gets the document version advertised by the document. The resulting value is the maximum of the value in the document header and the value in the document catalog. The value will always be for the form major.minor. Currently major is always 1. Note many incorrect documents contain PDF features that are beyond their advertised version.
Public property | ErrorsEncountered | Gets a list of errors encountered while opening the document. Since only a narrow subset of the document is examined, this list is not guaranteed to be exhaustive.
Public property | FormUsesXFA | Gets a value indicating whether the AcroForm in the document uses Adobe's Extensible Form Architecture, XFA.
Public property | HasForm | Gets a value indicating whether the document contains an AcroForm.
Public property | HasSignatures | Gets a value indicating whether the AcroForm advertises that it contains digital signatures. This does not indicate that the signatures are valid.
Public property | HasXmp | Gets a value indicating whether the document has XMP metatdata.
Public property | IsBadlyDamaged | Gets a value indicating whether the document is badly damaged. If, during the process of opening the file, errors were encountered that were of Major severity or worse then IsBadlyDamaged will be set to true. If true, only the properties IsPdf, [P:IsValidHeader], and IsEncrypted will be valid. All other values are suspect.
Public property | IsEncrypted | Gets a value indicating whether the document contains encryption. Not all documents that are encrypted require a non-empty password. This property merely indicates that a password might be required to correctly open the document. If FromStream(Stream, SecureString, SecureString) throws an IncorrectPasswordException, then the document requires a non-empty password or the supplied password(s) are incorrect.
Public property | IsIncorrectVersionForXrefStream | Gets a value indicating whether the PDF document's advertised document version is incorrect. Specifically, some PDF document generators use a PDF featured called cross-reference streams that require that the document be version 1.5 or greater. If there is evidence of a cross-reference stream and the version is less than 1.5, this property will true.
Public property | IsPdf | Gets a value indicating whether the document is a PDF. This test is more lenient than the specification allows and will return true if the document contains the PDF header including in some pathological cases. If the PDF header meets specification, [P:IsValidHeader] will return true. If it returns false, the document is well out-of-spec and no other information in ExaminerResults will be valid.
Public property | IsPdfA | Gets a value indicating whether the document advertises itself as conforming to the PDF/A-1b archival specification. This does not mean that the document in any way complies with the specification, merely that it says it does. For example, if IsPdfA returns true and HasXmp returns false, then the document is NOT a PDF/A compliant document.
Public property | IsPdfPortfolio | Gets a value indicating whether the document contains a PDF Portfolio. This test looks specifically for a Collection object in the document's catalog. A PDF Portfolio is a feature wherein a PDF document doesn't necessarily contain any PDF data at all, but instead contains a series of embedded files which represent the content of the document. Some PDF documents that have a Portfolion include an ersatz page which is shown for compatibility. The presentation of embedded files is application dependent.
Public property | IsValidPdfHeader | Gets a value indicating whether the document contains a valid PDF header. If the document does not meet the PDF specification for a header but still contains the text "%PDF-" this will return false. For example, if the document start with the following: %!PS-Adobe - this is PostScript not %PDF-1.0 this will be considered to be a PDF, even though it is not within specification (and because it's labeled as PostScript, it will likely generate other errors).
Public property | Metadata | Gets the metadata associated with the PDF document from the DocumentInfo object within the file. This value may be null.
Public property | PageCount | Gets the page count of the document.
Public property | RequiresDynamicFormRendering | Gets a value indicating whether requires dynamic form rendering. Typically, this is set when a document contains an XFA form and has embedded form data that has not yet been converted into PDF content.
Top
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.DocumentVersion Property

ExaminerResultsDocumentVersion Property

Gets the document version advertised by the document. The resulting value is the maximum of the value in the document header and the value in the document catalog. The value will always be for the form major.minor. Currently major is always 1. Note many incorrect documents contain PDF features that are beyond their advertised version.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double DocumentVersion { get; }
Public ReadOnly Property DocumentVersion As Double
    Get

Property Value

Type: Double
The document version.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.ErrorsEncountered Property

ExaminerResultsErrorsEncountered Property

Gets a list of errors encountered while opening the document. Since only a narrow subset of the document is examined, this list is not guaranteed to be exhaustive.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<string> ErrorsEncountered { get; }
Public ReadOnly Property ErrorsEncountered As IList(Of String)
    Get

Property Value

Type: IListString
The errors encountered while opening the document.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.FormUsesXFA Property

ExaminerResultsFormUsesXFA Property

Gets a value indicating whether the AcroForm in the document uses Adobe's Extensible Form Architecture, XFA.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FormUsesXFA { get; }
Public ReadOnly Property FormUsesXFA As Boolean
    Get

Property Value

Type: Boolean
true if the AcroForm uses xfa; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.HasForm Property

ExaminerResultsHasForm Property

Gets a value indicating whether the document contains an AcroForm.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasForm { get; }
Public ReadOnly Property HasForm As Boolean
    Get

Property Value

Type: Boolean
true if the document contains an AcroForm; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.HasSignatures Property

ExaminerResultsHasSignatures Property

Gets a value indicating whether the AcroForm advertises that it contains digital signatures. This does not indicate that the signatures are valid.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasSignatures { get; }
Public ReadOnly Property HasSignatures As Boolean
    Get

Property Value

Type: Boolean
true if the document advertises that it has signatures; otherwise, false.
Remarks
Some documents may advertise that they contains signatures, but have had them (incorrectly) removed
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.HasXmp Property

ExaminerResultsHasXmp Property

Gets a value indicating whether the document has XMP metatdata.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasXmp { get; }
Public ReadOnly Property HasXmp As Boolean
    Get

Property Value

Type: Boolean
true if the document has XMP metadata; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsBadlyDamaged Property

ExaminerResultsIsBadlyDamaged Property

Gets a value indicating whether the document is badly damaged. If, during the process of opening the file, errors were encountered that were of Major severity or worse then IsBadlyDamaged will be set to true. If true, only the properties IsPdf, [P:IsValidHeader], and IsEncrypted will be valid. All other values are suspect.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsBadlyDamaged { get; }
Public ReadOnly Property IsBadlyDamaged As Boolean
    Get

Property Value

Type: Boolean
true if the document is badly damaged; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsEncrypted Property

ExaminerResultsIsEncrypted Property

Gets a value indicating whether the document contains encryption. Not all documents that are encrypted require a non-empty password. This property merely indicates that a password might be required to correctly open the document. If FromStream(Stream, SecureString, SecureString) throws an IncorrectPasswordException, then the document requires a non-empty password or the supplied password(s) are incorrect.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEncrypted { get; }
Public ReadOnly Property IsEncrypted As Boolean
    Get

Property Value

Type: Boolean
true if the document is encrypted; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsIncorrectVersionForXrefStream Property

ExaminerResultsIsIncorrectVersionForXrefStream Property

Gets a value indicating whether the PDF document's advertised document version is incorrect. Specifically, some PDF document generators use a PDF featured called cross-reference streams that require that the document be version 1.5 or greater. If there is evidence of a cross-reference stream and the version is less than 1.5, this property will true.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsIncorrectVersionForXrefStream { get; }
Public ReadOnly Property IsIncorrectVersionForXrefStream As Boolean
    Get

Property Value

Type: Boolean
true if the PDF is marked version 1.4 or earlier and contains a cross reference stream; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsPdf Property

ExaminerResultsIsPdf Property

Gets a value indicating whether the document is a PDF. This test is more lenient than the specification allows and will return true if the document contains the PDF header including in some pathological cases. If the PDF header meets specification, [P:IsValidHeader] will return true. If it returns false, the document is well out-of-spec and no other information in ExaminerResults will be valid.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPdf { get; }
Public ReadOnly Property IsPdf As Boolean
    Get

Property Value

Type: Boolean
true if the document is a PDF; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsPdfA Property

ExaminerResultsIsPdfA Property

Gets a value indicating whether the document advertises itself as conforming to the PDF/A-1b archival specification. This does not mean that the document in any way complies with the specification, merely that it says it does. For example, if IsPdfA returns true and HasXmp returns false, then the document is NOT a PDF/A compliant document.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPdfA { get; }
Public ReadOnly Property IsPdfA As Boolean
    Get

Property Value

Type: Boolean
true if the document advertises itself as conforming to the PDF/A-1b specification; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsPdfPortfolio Property

ExaminerResultsIsPdfPortfolio Property

Gets a value indicating whether the document contains a PDF Portfolio. This test looks specifically for a Collection object in the document's catalog. A PDF Portfolio is a feature wherein a PDF document doesn't necessarily contain any PDF data at all, but instead contains a series of embedded files which represent the content of the document. Some PDF documents that have a Portfolion include an ersatz page which is shown for compatibility. The presentation of embedded files is application dependent.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPdfPortfolio { get; }
Public ReadOnly Property IsPdfPortfolio As Boolean
    Get

Property Value

Type: Boolean
true if the document contains a PDF portfolio; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.IsValidPdfHeader Property

ExaminerResultsIsValidPdfHeader Property

Gets a value indicating whether the document contains a valid PDF header. If the document does not meet the PDF specification for a header but still contains the text "%PDF-" this will return false. For example, if the document start with the following:

%!PS-Adobe - this is PostScript not %PDF-1.0

this will be considered to be a PDF, even though it is not within specification (and because it's labeled as PostScript, it will likely generate other errors).

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsValidPdfHeader { get; }
Public ReadOnly Property IsValidPdfHeader As Boolean
    Get

Property Value

Type: Boolean
true if the document contains a valid PDF header; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.Metadata Property

ExaminerResultsMetadata Property

Gets the metadata associated with the PDF document from the DocumentInfo object within the file. This value may be null.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentMetadata Metadata { get; }
Public ReadOnly Property Metadata As PdfDocumentMetadata
    Get

Property Value

Type: PdfDocumentMetadata
The metadata for the file
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.PageCount Property

ExaminerResultsPageCount Property

Gets the page count of the document.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32
The page count.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.RequiresDynamicFormRendering Property

ExaminerResultsRequiresDynamicFormRendering Property

Gets a value indicating whether requires dynamic form rendering. Typically, this is set when a document contains an XFA form and has embedded form data that has not yet been converted into PDF content.

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RequiresDynamicFormRendering { get; }
Public ReadOnly Property RequiresDynamicFormRendering As Boolean
    Get

Property Value

Type: Boolean
true if the document requires dynamic form rendering; otherwise, false.
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults Methods

The ExaminerResults type exposes the following members.

Methods
Name Description
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
FromStream(Stream)
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
If the document is encrypted, FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
FromStream(Stream, SecureString, SecureString)
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
FromStream(Stream, String, String) Obsolete.
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.FromStream Method

ExaminerResultsFromStream Method

Overload List
Name Description
FromStream(Stream)
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
If the document is encrypted, FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
FromStream(Stream, SecureString, SecureString)
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
FromStream(Stream, String, String) Obsolete.
Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}
Top
See Also

Reference

ExaminerResults Class
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.FromStream Method (Stream)

ExaminerResultsFromStream Method (Stream)

Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
If the document is encrypted, FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ExaminerResults FromStream(
    Stream stm
)
Public Shared Function FromStream (
    stm As Stream
) As ExaminerResults

Parameters

stm
Type: System.IOStream
The instream.

Return Value

Type: ExaminerResults
An instance of ExaminerResults if successfull.
Exceptions
Exception | Condition
ArgumentNullException |
IncorrectPasswordException |
See Also

Reference

ExaminerResults Class
FromStream Overload
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.FromStream Method (Stream, SecureString, SecureString)

ExaminerResultsFromStream Method (Stream, SecureString, SecureString)

Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ExaminerResults FromStream(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Shared Function FromStream (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString
) As ExaminerResults

Parameters

stm
Type: System.IOStream
The instream.
userPassword
Type: System.SecuritySecureString
The user password. Set to null for no password.
ownerPassword
Type: System.SecuritySecureString
The owner password. Set to null for no password.

Return Value

Type: ExaminerResults
An instance of ExaminerResults if successfull.
Exceptions
Exception | Condition
ArgumentNullException |
IncorrectPasswordException |
See Also

Reference

ExaminerResults Class
FromStream Overload
Atalasoft.PdfDoc.Examiner Namespace


ExaminerResults.FromStream Method (Stream, String, String)

ExaminerResultsFromStream Method (Stream, String, String)

Note: This API is now obsolete.

Attempts to build an ExaminerResults object from the stream provided. To the greatest extent possible, FromStream attempts to get some information from the file. If the file is a PDF and it is encrypted, FromStream will throw an IncorrectPasswordException.
Note that many of the properties in the file cascade. For example, if IsPdf returns false, no other property will be valid. If IsEncrypted is true, no other properties except IsPdf, IsPdfA, and IsIncorrectVersionForXrefStream will be valid.
The properties within ExaminerResults are meant to reflect a very lightweight examination of the file and are in no way are exhaustive. PDF is a very complicated file format and there are a number of exceptions in the specification that are counter to the goal of having a light-weight interface to the information within the file. For example, because a PDF file presents information that indicates that it meets the archival variant, PDF/A, this doesn't guarantee that the document meets all requirements. ExaminerResults reflects what is advertised by the file and not necessarily the entire depth of content.
The stream position can not be counted on to be at a consistent location upon return.
The supplied passwords may either or both be null indicating no password. If passwords are supplied and the document is not encrypted, the passwords will be ignored. If the document is encrypted and the password(s) are incorrect or null FromStream will throw an IncorrectPasswordException.
Examples
The following example examines PDF document. If PDF document is encrypted, a password will be requested from the user.
ExaminePdfExample
Copy
ExaminerResults res = null;

using (FileStream stm = File.OpenRead(path))
{
    try
    {
        res = ExaminerResults.FromStream(stm);
    }
    catch (IncorrectPasswordException)
    {
        while (true)
        {
            using (var userSecure = GetPasswordFromUser())
                try
                {
                    res = ExaminerResults.FromStream(stm, userSecure, null);
                    break;
                }
                catch (IncorrectPasswordException)
                {
                    OnIncorrectUserPassword();
                }
        }
    }

}

Namespace: Atalasoft.PdfDoc.Examiner
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use FromStream(Stream stm, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public static ExaminerResults FromStream(
    Stream stm,
    string userPassword,
    string ownerPassword
)
<ObsoleteAttribute("This method is obsolete. Use FromStream(Stream stm, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Shared Function FromStream (
    stm As Stream,
    userPassword As String,
    ownerPassword As String
) As ExaminerResults

Parameters

stm
Type: System.IOStream
The instream.
userPassword
Type: SystemString
The user password. Set to null for no password.
ownerPassword
Type: SystemString
The owner password. Set to null for no password.

Return Value

Type: ExaminerResults
An instance of ExaminerResults if successfull.
Exceptions
Exception | Condition
ArgumentNullException |
IncorrectPasswordException |
See Also

Reference

ExaminerResults Class
FromStream Overload
Atalasoft.PdfDoc.Examiner Namespace


Atalasoft.PdfDoc.Generating Namespace

Classes
 | Class | Description
Public class | OpaquePageInformer | When a page from a PDF document can't be imported for some reason, this class can report the reason for the failure if it is available.
Public class | PdfColorFactory | A factory class to create PdfColors from their channel components.
Public class | PdfDefaultPages | A collection of default pages for use in the PdfGeneratedDocument object
 | PdfGeneratedDocument | The PdfGeneratedDocument object is designed to create documents using the Pdf Generating Tools.
Public class | PdfGeneratedPage | A BasePage object which contains functionality to create Pdf. Use this class when trying to programmatically generate pdf pages.
Interfaces
 | Interface | Description
Public interface | IPdfCmykColor | The interface for CMYK colors in Pdf.
Public interface | IPdfColor | A container interface used to carry color objects in collections. Do not use this interface unless you are simply moving a more specific color object to another object.
Public interface | IPdfGrayColor | The interface for Gray based colors in Pdf
Public interface | IPdfRgbColor | The interface for RGB color in Pdf
Enumerations
 | Enumeration | Description
Public enumeration | PdfColorSpaceType | The available color spaces in pdf


IPdfCmykColor Interface

The interface for CMYK colors in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfCmykColor : IPdfColor
Public Interface IPdfCmykColor
    Inherits IPdfColor

The IPdfCmykColor type exposes the following members.

Properties
 | Name | Description
Public property | C | Gets or sets the Cyan channel
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource. (Inherited from IPdfColor.)
Public property | K | Gets or sets the Black channel.
Public property | M | Gets or sets the Magenta channel.
Public property | Y | Gets or sets the Yellow channel.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


IPdfCmykColor Properties

The IPdfCmykColor type exposes the following members.

Properties
 | Name | Description
Public property | C | Gets or sets the Cyan channel
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource. (Inherited from IPdfColor.)
Public property | K | Gets or sets the Black channel.
Public property | M | Gets or sets the Magenta channel.
Public property | Y | Gets or sets the Yellow channel.
Top
See Also

Reference

IPdfCmykColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfCmykColor.C Property

IPdfCmykColorC Property

Gets or sets the Cyan channel

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double C { get; set; }
Property C As Double
    Get
    Set

Property Value

Type: Double
The Cyan channel. Value between 0.0 and 1.0
See Also

Reference

IPdfCmykColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfCmykColor.K Property

IPdfCmykColorK Property

Gets or sets the Black channel.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double K { get; set; }
Property K As Double
    Get
    Set

Property Value

Type: Double
The Black channel. Value between 0.0 and 1.0
See Also

Reference

IPdfCmykColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfCmykColor.M Property

IPdfCmykColorM Property

Gets or sets the Magenta channel.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double M { get; set; }
Property M As Double
    Get
    Set

Property Value

Type: Double
The Magenta channel. Value between 0.0 and 1.0
See Also

Reference

IPdfCmykColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfCmykColor.Y Property

IPdfCmykColorY Property

Gets or sets the Yellow channel.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Y { get; set; }
Property Y As Double
    Get
    Set

Property Value

Type: Double
The Yellow channel. Value between 0.0 and 1.0
See Also

Reference

IPdfCmykColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfColor Interface

A container interface used to carry color objects in collections. Do not use this interface unless you are simply moving a more specific color object to another object.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfColor
Public Interface IPdfColor

The IPdfColor type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


IPdfColor Properties

The IPdfColor type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource.
Top
See Also

Reference

IPdfColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfColor.ColorSpaceResourceName Property

IPdfColorColorSpaceResourceName Property

Gets or sets the name of the color space resource.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string ColorSpaceResourceName { get; set; }
Property ColorSpaceResourceName As String
    Get
    Set

Property Value

Type: String
The name of the color space resource.
See Also

Reference

IPdfColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfGrayColor Interface

The interface for Gray based colors in Pdf

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfGrayColor : IPdfColor
Public Interface IPdfGrayColor
    Inherits IPdfColor

The IPdfGrayColor type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource. (Inherited from IPdfColor.)
Public property | Gray | Gets or sets the gray.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


IPdfGrayColor Properties

The IPdfGrayColor type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource. (Inherited from IPdfColor.)
Public property | Gray | Gets or sets the gray.
Top
See Also

Reference

IPdfGrayColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfGrayColor.Gray Property

IPdfGrayColorGray Property

Gets or sets the gray.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double Gray { get; set; }
Property Gray As Double
    Get
    Set

Property Value

Type: Double
The gray. Value between 0.0 and 1.0
See Also

Reference

IPdfGrayColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfRgbColor Interface

The interface for RGB color in Pdf

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfRgbColor : IPdfColor
Public Interface IPdfRgbColor
    Inherits IPdfColor

The IPdfRgbColor type exposes the following members.

Properties
 | Name | Description
Public property | B | Gets or sets the Blue channel.
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource. (Inherited from IPdfColor.)
Public property | G | Gets or sets the Green channel.
Public property | R | Gets or sets the Red channel.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


IPdfRgbColor Properties

The IPdfRgbColor type exposes the following members.

Properties
 | Name | Description
Public property | B | Gets or sets the Blue channel.
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource. (Inherited from IPdfColor.)
Public property | G | Gets or sets the Green channel.
Public property | R | Gets or sets the Red channel.
Top
See Also

Reference

IPdfRgbColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfRgbColor.B Property

IPdfRgbColorB Property

Gets or sets the Blue channel.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double B { get; set; }
Property B As Double
    Get
    Set

Property Value

Type: Double
The Blue channel. Value between 0.0 and 1.0
See Also

Reference

IPdfRgbColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfRgbColor.G Property

IPdfRgbColorG Property

Gets or sets the Green channel.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double G { get; set; }
Property G As Double
    Get
    Set

Property Value

Type: Double
The Green channel. Value between 0.0 and 1.0.
See Also

Reference

IPdfRgbColor Interface
Atalasoft.PdfDoc.Generating Namespace


IPdfRgbColor.R Property

IPdfRgbColorR Property

Gets or sets the Red channel.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
double R { get; set; }
Property R As Double
    Get
    Set

Property Value

Type: Double
The Red channel. Value between 0.0 and 1.0
See Also

Reference

IPdfRgbColor Interface
Atalasoft.PdfDoc.Generating Namespace


OpaquePageInformer Class

When a page from a PDF document can't be imported for some reason, this class can report the reason for the failure if it is available.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeneratingOpaquePageInformer

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OpaquePageInformer
Public Class OpaquePageInformer

The OpaquePageInformer type exposes the following members.

Constructors
 | Name | Description
Public method | OpaquePageInformer | Initializes a new instance of the OpaquePageInformer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFailureReason | Imports the failure reason from the page.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


OpaquePageInformer Constructor

Initializes a new instance of the OpaquePageInformer class

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OpaquePageInformer()
Public Sub New
See Also

Reference

OpaquePageInformer Class
Atalasoft.PdfDoc.Generating Namespace


OpaquePageInformer Methods

The OpaquePageInformer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFailureReason | Imports the failure reason from the page.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OpaquePageInformer Class
Atalasoft.PdfDoc.Generating Namespace


OpaquePageInformer.ImportFailureReason Method

OpaquePageInformerImportFailureReason Method

Imports the failure reason from the page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string ImportFailureReason(
    BasePage page
)
Public Shared Function ImportFailureReason (
    page As BasePage
) As String

Parameters

page
Type: Atalasoft.PdfDocBasePage
The page must be the type OpaquePage which is used internally in DotPdf.

Return Value

Type: String
The reason for failure to import, null if the page is not an OpaquePage
See Also

Reference

OpaquePageInformer Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory Class

A factory class to create PdfColors from their channel components.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeneratingPdfColorFactory

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfColorFactory
Public Class PdfColorFactory

The PdfColorFactory type exposes the following members.

Constructors
 | Name | Description
Public method | PdfColorFactory | Initializes a new instance of the PdfColorFactory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromCmyk(Double, Double, Double, Double) | Create a Cymk color for use in Pdf.
 | FromCmyk(Double, Double, Double, Double, String) | Create a Cymk color for use in Pdf.
 | FromColor(Color) | Create an Rgb color for use in Pdf.
 | FromColor(Color, String) | Create an Rgb color for use in Pdf.
 | FromGray(Double) | Create a Grayscale color for use in Pdf
 | FromGray(Double, String) | Froms the gray.
 | FromRgb(Double, Double, Double) | Create an Rgb color for use in Pdf.
 | FromRgb(Double, Double, Double, String) | Create an Rgb color for use in Pdf.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory Constructor

Initializes a new instance of the PdfColorFactory class

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorFactory()
Public Sub New
See Also

Reference

PdfColorFactory Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory Methods

The PdfColorFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromCmyk(Double, Double, Double, Double) | Create a Cymk color for use in Pdf.
 | FromCmyk(Double, Double, Double, Double, String) | Create a Cymk color for use in Pdf.
 | FromColor(Color) | Create an Rgb color for use in Pdf.
 | FromColor(Color, String) | Create an Rgb color for use in Pdf.
 | FromGray(Double) | Create a Grayscale color for use in Pdf
 | FromGray(Double, String) | Froms the gray.
 | FromRgb(Double, Double, Double) | Create an Rgb color for use in Pdf.
 | FromRgb(Double, Double, Double, String) | Create an Rgb color for use in Pdf.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfColorFactory Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromCmyk Method

PdfColorFactoryFromCmyk Method

Overload List
Name | Description
FromCmyk(Double, Double, Double, Double) | Create a Cymk color for use in Pdf.
FromCmyk(Double, Double, Double, Double, String) | Create a Cymk color for use in Pdf.
Top
See Also

Reference

PdfColorFactory Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromCmyk Method (Double, Double, Double, Double)

PdfColorFactoryFromCmyk Method (Double, Double, Double, Double)

Create a Cymk color for use in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfCmykColor FromCmyk(
    double c,
    double y,
    double m,
    double k
)
Public Shared Function FromCmyk (
    c As Double,
    y As Double,
    m As Double,
    k As Double
) As IPdfCmykColor

Parameters

c
Type: SystemDouble
The cyan color. Value between 0.0 and 1.0
y
Type: SystemDouble
The yellow color. Value between 0.0 and 1.0
m
Type: SystemDouble
The magenta color. Value between 0.0 and 1.0
k
Type: SystemDouble
The black color. Value between 0.0 and 1.0

Return Value

Type: IPdfCmykColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromCmyk Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromCmyk Method (Double, Double, Double, Double, String)

PdfColorFactoryFromCmyk Method (Double, Double, Double, Double, String)

Create a Cymk color for use in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfCmykColor FromCmyk(
    double c,
    double y,
    double m,
    double k,
    string resourceName
)
Public Shared Function FromCmyk (
    c As Double,
    y As Double,
    m As Double,
    k As Double,
    resourceName As String
) As IPdfCmykColor

Parameters

c
Type: SystemDouble
The cyan color. Value between 0.0 and 1.0
y
Type: SystemDouble
The yellow color. Value between 0.0 and 1.0
m
Type: SystemDouble
The magenta color. Value between 0.0 and 1.0
k
Type: SystemDouble
The black color. Value between 0.0 and 1.0
resourceName
Type: SystemString
Name of the color space resource to use to describe this color.

Return Value

Type: IPdfCmykColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromCmyk Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromColor Method

PdfColorFactoryFromColor Method

Overload List
Name | Description
FromColor(Color) | Create an Rgb color for use in Pdf.
FromColor(Color, String) | Create an Rgb color for use in Pdf.
Top
See Also

Reference

PdfColorFactory Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromColor Method (Color)

PdfColorFactoryFromColor Method (Color)

Create an Rgb color for use in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfRgbColor FromColor(
    Color color
)
Public Shared Function FromColor (
    color As Color
) As IPdfRgbColor

Parameters

color
Type: System.DrawingColor
The color.

Return Value

Type: IPdfRgbColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromColor Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromColor Method (Color, String)

PdfColorFactoryFromColor Method (Color, String)

Create an Rgb color for use in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfRgbColor FromColor(
    Color color,
    string resourceName
)
Public Shared Function FromColor (
    color As Color,
    resourceName As String
) As IPdfRgbColor

Parameters

color
Type: System.DrawingColor
The color.
resourceName
Type: SystemString
Name of the color space resource to use to describe this color.

Return Value

Type: IPdfRgbColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromColor Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromGray Method

PdfColorFactoryFromGray Method

Overload List
Name | Description
FromGray(Double) | Create a Grayscale color for use in Pdf
FromGray(Double, String) | Froms the gray.
Top
See Also

Reference

PdfColorFactory Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromGray Method (Double)

PdfColorFactoryFromGray Method (Double)

Create a Grayscale color for use in Pdf

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfGrayColor FromGray(
    double gray
)
Public Shared Function FromGray (
    gray As Double
) As IPdfGrayColor

Parameters

gray
Type: SystemDouble
The gray color. Value between 0.0 (black) and 1.0 (white)

Return Value

Type: IPdfGrayColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromGray Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromGray Method (Double, String)

PdfColorFactoryFromGray Method (Double, String)

Froms the gray.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfGrayColor FromGray(
    double gray,
    string resourceName
)
Public Shared Function FromGray (
    gray As Double,
    resourceName As String
) As IPdfGrayColor

Parameters

gray
Type: SystemDouble
The gray.
resourceName
Type: SystemString
Name of the color space resource to use to describe this color.

Return Value

Type: IPdfGrayColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromGray Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromRgb Method

PdfColorFactoryFromRgb Method

Overload List
Name | Description
FromRgb(Double, Double, Double) | Create an Rgb color for use in Pdf.
FromRgb(Double, Double, Double, String) | Create an Rgb color for use in Pdf.
Top
See Also

Reference

PdfColorFactory Class
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromRgb Method (Double, Double, Double)

PdfColorFactoryFromRgb Method (Double, Double, Double)

Create an Rgb color for use in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfRgbColor FromRgb(
    double r,
    double g,
    double b
)
Public Shared Function FromRgb (
    r As Double,
    g As Double,
    b As Double
) As IPdfRgbColor

Parameters

r
Type: SystemDouble
The red channel. Value between 0.0 and 1.0
g
Type: SystemDouble
The green channel. Value between 0.0 and 1.0
b
Type: SystemDouble
The blue channel. Value between 0.0 and 1.0

Return Value

Type: IPdfRgbColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromRgb Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorFactory.FromRgb Method (Double, Double, Double, String)

PdfColorFactoryFromRgb Method (Double, Double, Double, String)

Create an Rgb color for use in Pdf.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfRgbColor FromRgb(
    double r,
    double g,
    double b,
    string resourceName
)
Public Shared Function FromRgb (
    r As Double,
    g As Double,
    b As Double,
    resourceName As String
) As IPdfRgbColor

Parameters

r
Type: SystemDouble
The red channel. Value between 0.0 and 1.0
g
Type: SystemDouble
The green channel. Value between 0.0 and 1.0
b
Type: SystemDouble
The blue channel. Value between 0.0 and 1.0
resourceName
Type: SystemString
Name of the color space resource to use to describe this color.

Return Value

Type: IPdfRgbColor
a new IPdfColor representing the desired color
See Also

Reference

PdfColorFactory Class
FromRgb Overload
Atalasoft.PdfDoc.Generating Namespace


PdfColorSpaceType Enumeration

The available color spaces in pdf

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfColorSpaceType
Public Enumeration PdfColorSpaceType
Members
Member name | Description
Rgb | Red Green Blue
Gray | Grayscale
Cmyk | Cyan Magenta Yellow Black
Lab | Custom color spaces
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages Class

A collection of default pages for use in the PdfGeneratedDocument object
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeneratingPdfDefaultPages

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDefaultPages
Public Class PdfDefaultPages

The PdfDefaultPages type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDefaultPages | Initializes a new instance of the PdfDefaultPages class
Top
Properties
Name | Description
A4 | Gets the a4 sized page.
A4Landscape | Gets the a4 landscape sized page.
A5 | Gets the a5 sized page.
A5Landscape | Gets the a5 landscape sized page.
A6 | Gets the a6 sized page.
A6Landscape | Gets the a6 landscape sized page.
B4 | Gets the b4 sized page.
B4Landscape | Gets the b4 landscape sized page.
B5 | Gets the b5 sized page.
B5Landscaped | Gets the b5 landscaped sized page.
B6 | Gets the b6 sized page.
B6Landscape | Gets the b6 landscape sized page.
C4 | Gets the c4 sized page.
C4Landscape | Gets the c4 landscape sized page.
C5 | Gets the c5 sized page.
C5Landscape | Gets the c5 landscape sized page.
C6 | Gets the c6 sized page.
C6Landscape | Gets the c6 landscape sized page.
Ledger | Gets the ledger sized page.
LedgerLandscape | Gets the ledger landscape sized page.
Legal | Gets the legalsized page.
LegalLandscape | Gets the legal landscape sized page.
Letter | Gets the letter sized page.
LetterLandscape | Gets the letter landscape sized page.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages Constructor

Initializes a new instance of the PdfDefaultPages class

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDefaultPages()
Public Sub New
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages Properties

The PdfDefaultPages type exposes the following members.

Properties
Name | Description
A4 | Gets the a4 sized page.
A4Landscape | Gets the a4 landscape sized page.
A5 | Gets the a5 sized page.
A5Landscape | Gets the a5 landscape sized page.
A6 | Gets the a6 sized page.
A6Landscape | Gets the a6 landscape sized page.
B4 | Gets the b4 sized page.
B4Landscape | Gets the b4 landscape sized page.
B5 | Gets the b5 sized page.
B5Landscaped | Gets the b5 landscaped sized page.
B6 | Gets the b6 sized page.
B6Landscape | Gets the b6 landscape sized page.
C4 | Gets the c4 sized page.
C4Landscape | Gets the c4 landscape sized page.
C5 | Gets the c5 sized page.
C5Landscape | Gets the c5 landscape sized page.
C6 | Gets the c6 sized page.
C6Landscape | Gets the c6 landscape sized page.
Ledger | Gets the ledger sized page.
LedgerLandscape | Gets the ledger landscape sized page.
Legal | Gets the legalsized page.
LegalLandscape | Gets the legal landscape sized page.
Letter | Gets the letter sized page.
LetterLandscape | Gets the letter landscape sized page.
Top
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.A4 Property

PdfDefaultPagesA4 Property

Gets the a4 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage A4 { get; }
Public Shared ReadOnly Property A4 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.A4Landscape Property

PdfDefaultPagesA4Landscape Property

Gets the a4 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage A4Landscape { get; }
Public Shared ReadOnly Property A4Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.A5 Property

PdfDefaultPagesA5 Property

Gets the a5 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage A5 { get; }
Public Shared ReadOnly Property A5 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.A5Landscape Property

PdfDefaultPagesA5Landscape Property

Gets the a5 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage A5Landscape { get; }
Public Shared ReadOnly Property A5Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.A6 Property

PdfDefaultPagesA6 Property

Gets the a6 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage A6 { get; }
Public Shared ReadOnly Property A6 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.A6Landscape Property

PdfDefaultPagesA6Landscape Property

Gets the a6 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage A6Landscape { get; }
Public Shared ReadOnly Property A6Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.B4 Property

PdfDefaultPagesB4 Property

Gets the b4 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage B4 { get; }
Public Shared ReadOnly Property B4 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.B4Landscape Property

PdfDefaultPagesB4Landscape Property

Gets the b4 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage B4Landscape { get; }
Public Shared ReadOnly Property B4Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.B5 Property

PdfDefaultPagesB5 Property

Gets the b5 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage B5 { get; }
Public Shared ReadOnly Property B5 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.B5Landscaped Property

PdfDefaultPagesB5Landscaped Property

Gets the b5 landscaped sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage B5Landscaped { get; }
Public Shared ReadOnly Property B5Landscaped As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.B6 Property

PdfDefaultPagesB6 Property

Gets the b6 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage B6 { get; }
Public Shared ReadOnly Property B6 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.B6Landscape Property

PdfDefaultPagesB6Landscape Property

Gets the b6 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage B6Landscape { get; }
Public Shared ReadOnly Property B6Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.C4 Property

PdfDefaultPagesC4 Property

Gets the c4 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage C4 { get; }
Public Shared ReadOnly Property C4 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.C4Landscape Property

PdfDefaultPagesC4Landscape Property

Gets the c4 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage C4Landscape { get; }
Public Shared ReadOnly Property C4Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.C5 Property

PdfDefaultPagesC5 Property

Gets the c5 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage C5 { get; }
Public Shared ReadOnly Property C5 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.C5Landscape Property

PdfDefaultPagesC5Landscape Property

Gets the c5 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage C5Landscape { get; }
Public Shared ReadOnly Property C5Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.C6 Property

PdfDefaultPagesC6 Property

Gets the c6 sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage C6 { get; }
Public Shared ReadOnly Property C6 As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.C6Landscape Property

PdfDefaultPagesC6Landscape Property

Gets the c6 landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage C6Landscape { get; }
Public Shared ReadOnly Property C6Landscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.Ledger Property

PdfDefaultPagesLedger Property

Gets the ledger sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage Ledger { get; }
Public Shared ReadOnly Property Ledger As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.LedgerLandscape Property

PdfDefaultPagesLedgerLandscape Property

Gets the ledger landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage LedgerLandscape { get; }
Public Shared ReadOnly Property LedgerLandscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.Legal Property

PdfDefaultPagesLegal Property

Gets the legalsized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage Legal { get; }
Public Shared ReadOnly Property Legal As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.LegalLandscape Property

PdfDefaultPagesLegalLandscape Property

Gets the legal landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage LegalLandscape { get; }
Public Shared ReadOnly Property LegalLandscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.Letter Property

PdfDefaultPagesLetter Property

Gets the letter sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage Letter { get; }
Public Shared ReadOnly Property Letter As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages.LetterLandscape Property

PdfDefaultPagesLetterLandscape Property

Gets the letter landscape sized page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfGeneratedPage LetterLandscape { get; }
Public Shared ReadOnly Property LetterLandscape As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfDefaultPages Methods

The PdfDefaultPages type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDefaultPages Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Class

The PdfGeneratedDocument object is designed to create documents using the Pdf Generating Tools.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfGeneratedDocument : IDisposable
Public Class PdfGeneratedDocument
    Implements IDisposable

The PdfGeneratedDocument type exposes the following members.

Constructors
 | Name | Description
Public method | PdfGeneratedDocument | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, Boolean) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString) | Initializes a new instance of the PdfGeneratedDocument class. This overload is designed to open an existing DotPdf generated pdf document for editing/modification.
Public method | PdfGeneratedDocument(String, String, Stream) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class. This overload is designed to open an existing DotPdf generated pdf document for editing/modification.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, RepairOptions) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, Int32) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, RepairOptions) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, Int32) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32, GlobalResources) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32, GlobalResources) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Top
Properties
Name Description
Public property AdditionalActions
Gets the list of additional actions that may be performed by a document.
Public property AdjustPdfVersionAsNeeded
Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.
Public property AllowSavingOfPreviouslySignedDocuments
Gets or sets a value indicating whether to allow previously signed documents to be saved. Default value is false. If set to false, if DocumentWasSigned is true, calling Save will throw a PdfException. If set to true and DocumentWasSigned is true, calling Save will not throw an exception, but will create an invalid PDF which may still render correctly.
Public property AutomaticValidateAndRepairBeforeSave
Gets or sets a value indicating whether the document should attempt to automatically repair issues that may generate incorrect PDF.
Public property BookmarkTree
Gets or sets the bookmark tree.
Public property DisplayMode
Gets or sets the display mode that will be used for this document.
Public property DocumentCertification
Gets or sets the information used to certify the document.
Public property DocumentWasSigned
Gets a value indicating whether the document contained a digital signature when opened.
Public property EmbedGeneratedContent
Gets or sets a value indicating whether to embed Generated content allowing a PdfGeneratedDocument to be reconstructed from a PDF.
Public property EncryptMetadata
Gets or sets a value indicating whether to encrypt metadata.
Public property Form
Gets or sets the form object for the document. By default, this is null.
GlobalJavaScriptActions
Gets the global java script actions that will be executed when the PDF document is opened. This is initialized to an empty collection.
Public property Metadata
Gets the document's metadata.
Public property OwnerPassword Obsolete.
Gets or sets the owner password.
Public property Pages
Gets the pages of the document.
Public property PdfVersion
Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.
Public property Permissions
Gets or sets the permissions.
Public property RepairOptions
Gets the repair options that will be used for the document.
Public property Resources
Gets or sets the global resources.
Public property SelfPrinting
Gets or sets a value indicating whether will self print upon opening.
Public property UserPassword Obsolete.
Gets or sets the user password.
ValidationChooser
Gets or sets the validation chooser. This is a delegate that is used if AutomaticValidateAndRepairBeforeSave is true to choose to repair detected problems or not. The delegate will be called for each problem in turn. If the delegate returns true, the problem will be repaired.
Remarks
If ValidationChooser is set to null, only problems of Serious or less will be repaired. If there are any remaining problems, this will cause a PdfException to be thrown containing all the problems detected.
Examples
Copy
doc.ValidationChooser = PdfGeneratedDocument.MakeValidationSeverityChooser(Severity.Minor);
Public property ViewerPreferences
Gets or sets the viewer preferences for this PDF document. PdfViewerPreferences control coarse levels of document and page level user interaction such as the reading order of the document and print characteristics.
Top
Methods
 | Name | Description
 | AddPage | Adds the page to the document, returning the added page. This is a convenience method to streamline the process of adding pages to a document.
Public method | Dispose | Releases all resources used by the PdfGeneratedDocument
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfGeneratedDocument and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImportPages | Imports pages and associated resources from PDF stream.
 | MakeValidationSeverityChooser | This is a convenience factory that will return a new delegate that will repair all problems that are as severe or less severity than the specified maximum.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream) | Saves the document to the specified outStream.
Public method | Save(String) | Saves the document to the specified output file.
Public method | Save(Stream, EventHandlerRenderProgressEventArgs) | Saves the document to the specified outStream.
Public method | Save(String, EventHandlerRenderProgressEventArgs) | Saves the document to the specified output file.
Public method | Save(Stream, PdfSaveOptions, EventHandlerRenderProgressEventArgs) | Saves the Pdf document to the output stream using the provided options.
Public method | Save(String, PdfSaveOptions, EventHandlerRenderProgressEventArgs) | Saves the document to the specified output file.
Public method | Save(String, String, Stream, EventHandlerRenderProgressEventArgs) | Obsolete. Saves the Pdf document to the output stream using the provided passwords.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the document and returns a set of possible problems.
Top
Examples
//Saves a Pdf document with a blank page
PdfGeneratedDocument doc = new PdfGeneratedDocument();
doc.Pages.Add(PdfDefaultPages.Letter);
doc.Save(outputStream);
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor

Overload List
 | Name | Description
Public method | PdfGeneratedDocument | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, Boolean) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString) | Initializes a new instance of the PdfGeneratedDocument class. This overload is designed to open an existing DotPdf generated pdf document for editing/modification.
Public method | PdfGeneratedDocument(String, String, Stream) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class. This overload is designed to open an existing DotPdf generated pdf document for editing/modification.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, RepairOptions) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, Int32) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, RepairOptions) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, Int32) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32, GlobalResources) | Initializes a new instance of the PdfGeneratedDocument class.
Public method | PdfGeneratedDocument(String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32, GlobalResources) | Obsolete. Initializes a new instance of the PdfGeneratedDocument class.
Top
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument()
Public Sub New
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, Boolean)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    bool attemptToImportForeignContent
)
Public Sub New (
    stm As Stream,
    attemptToImportForeignContent As Boolean
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, SecureString, SecureString)

Initializes a new instance of the PdfGeneratedDocument class. This overload is designed to open an existing DotPdf generated pdf document for editing/modification.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword
Type: System.SecuritySecureString
The owner password.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (String, String, Stream)

Note: This API is now obsolete.

Initializes a new instance of the PdfGeneratedDocument class. This overload is designed to open an existing DotPdf generated pdf document for editing/modification.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword) instead.",
    false)]
public PdfGeneratedDocument(
    string userPassword,
    string ownerPassword,
    Stream stm
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
stm
Type: System.IOStream
The stream containing the previously generated pdf.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword
Type: System.SecuritySecureString
The owner password.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress)

Note: This API is now obsolete.

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded) instead.",
    false)]
public PdfGeneratedDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
stm
Type: System.IOStream
The stream containing the previously generated pdf.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, RepairOptions)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    RepairOptions repairOptions
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    repairOptions As RepairOptions
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword
Type: System.SecuritySecureString
The owner password.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that will determine how foreign content will be repaired on being read. May be null.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerable(Int32))

PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    IEnumerable<int> pagesToLoad
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    pagesToLoad As IEnumerable(Of Integer)
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword
Type: System.SecuritySecureString
The owner password.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
pagesToLoad
Type: System.Collections.GenericIEnumerableInt32
A a set of page numbers to load.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, Int32[])

PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, Int32)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    params int[] pagesToLoad
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    ParamArray pagesToLoad As Integer()
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword
Type: System.SecuritySecureString
The owner password.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
pagesToLoad
Type: SystemInt32
A a set of page numbers to load.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, RepairOptions)

Note: This API is now obsolete.

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, RepairOptions repairOptions) instead.",
    false)]
public PdfGeneratedDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    RepairOptions repairOptions
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, RepairOptions repairOptions) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    repairOptions As RepairOptions
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
stm
Type: System.IOStream
The stream containing the previously generated pdf.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
repairOptions
Type: Atalasoft.PdfDoc.RepairRepairOptions
An object that will determine how foreign content will be repaired on being read. May be null.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerable(Int32))

PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32)

Note: This API is now obsolete.

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, IEnumerable<int> pagesToLoad) instead.",
    false)]
public PdfGeneratedDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    IEnumerable<int> pagesToLoad
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, IEnumerable<int> pagesToLoad) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    pagesToLoad As IEnumerable(Of Integer)
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
stm
Type: System.IOStream
The stream containing the previously generated pdf.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
pagesToLoad
Type: System.Collections.GenericIEnumerableInt32
A a set of page numbers to load.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, Int32[])

PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, Int32)

Note: This API is now obsolete.

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, params int[] pagesToLoad) instead.",
    false)]
public PdfGeneratedDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    params int[] pagesToLoad
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, params int[] pagesToLoad) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    ParamArray pagesToLoad As Integer()
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
stm
Type: System.IOStream
The stream containing the previously generated pdf.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
pagesToLoad
Type: SystemInt32
A a set of page numbers to load.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerable(Int32), GlobalResources)

PdfGeneratedDocument Constructor (Stream, SecureString, SecureString, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32, GlobalResources)

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument(
    Stream stm,
    SecureString userPassword,
    SecureString ownerPassword,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    IEnumerable<int> pagesToLoad,
    GlobalResources globalResources
)
Public Sub New (
    stm As Stream,
    userPassword As SecureString,
    ownerPassword As SecureString,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    pagesToLoad As IEnumerable(Of Integer),
    globalResources As GlobalResources
)

Parameters

stm
Type: System.IOStream
The stream containing the previously generated pdf.
userPassword
Type: System.SecuritySecureString
The user password.
ownerPassword
Type: System.SecuritySecureString
The owner password.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
pagesToLoad
Type: System.Collections.GenericIEnumerableInt32
A a set of page numbers to load.
globalResources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
Global resources to use for the created document.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerable(Int32), GlobalResources)

PdfGeneratedDocument Constructor (String, String, Stream, Boolean, PdfDocumentLoadedProgress, IEnumerableInt32, GlobalResources)

Note: This API is now obsolete.

Initializes a new instance of the PdfGeneratedDocument class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, IEnumerable<int> pagesToLoad, GlobalResources globalResources) instead.",
    false)]
public PdfGeneratedDocument(
    string userPassword,
    string ownerPassword,
    Stream stm,
    bool attemptToImportForeignContent,
    PdfDocumentLoadedProgress pageLoaded,
    IEnumerable<int> pagesToLoad,
    GlobalResources globalResources
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfGeneratedDocument(Stream stm, SecureString userPassword, SecureString ownerPassword, bool attemptToImportForeignContent, PdfDocumentLoadedProgress pageLoaded, IEnumerable<int> pagesToLoad, GlobalResources globalResources) instead.",
    false)>
Public Sub New (
    userPassword As String,
    ownerPassword As String,
    stm As Stream,
    attemptToImportForeignContent As Boolean,
    pageLoaded As PdfDocumentLoadedProgress,
    pagesToLoad As IEnumerable(Of Integer),
    globalResources As GlobalResources
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
stm
Type: System.IOStream
The stream containing the previously generated pdf.
attemptToImportForeignContent
Type: SystemBoolean
if set to true attempt to import PDF content not previously serialized by DotPdf.
pageLoaded
Type: Atalasoft.PdfDocPdfDocumentLoadedProgress
A delegate that will be called when a page is loaded. This value may be null.
pagesToLoad
Type: System.Collections.GenericIEnumerableInt32
A a set of page numbers to load.
globalResources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
Global resources to use for the created document.
See Also

Reference

PdfGeneratedDocument Class
PdfGeneratedDocument Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Properties

The PdfGeneratedDocument type exposes the following members.

Properties
Name Description
Public property AdditionalActions
Gets the list of additional actions that may be performed by a document.
Public property AdjustPdfVersionAsNeeded
Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.
Public property AllowSavingOfPreviouslySignedDocuments
Gets or sets a value indicating whether to allow previously signed documents to be saved. Default value is false. If set to false, if DocumentWasSigned is true, calling Save will throw a PdfException. If set to true and DocumentWasSigned is true, calling Save will not throw an exception, but will create an invalid PDF which may still render correctly.
Public property AutomaticValidateAndRepairBeforeSave
Gets or sets a value indicating whether the document should attempt to automatically repair issues that may generate incorrect PDF.
Public property BookmarkTree
Gets or sets the bookmark tree.
Public property DisplayMode
Gets or sets the display mode that will be used for this document.
Public property DocumentCertification
Gets or sets the information used to certify the document.
Public property DocumentWasSigned
Gets a value indicating whether the document contained a digital signature when opened.
Public property EmbedGeneratedContent
Gets or sets a value indicating whether to embed Generated content allowing a PdfGeneratedDocument to be reconstructed from a PDF.
Public property EncryptMetadata
Gets or sets a value indicating whether to encrypt metadata.
Public property Form
Gets or sets the form object for the document. By default, this is null.
GlobalJavaScriptActions
Gets the global java script actions that will be executed when the PDF document is opened. This is initialized to an empty collection.
Public property Metadata
Gets the document's metadata.
Public property OwnerPassword Obsolete.
Gets or sets the owner password.
Public property Pages
Gets the pages of the document.
Public property PdfVersion
Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.
Public property Permissions
Gets or sets the permissions.
Public property RepairOptions
Gets the repair options that will be used for the document.
Public property Resources
Gets or sets the global resources.
Public property SelfPrinting
Gets or sets a value indicating whether will self print upon opening.
Public property UserPassword Obsolete.
Gets or sets the user password.
ValidationChooser
Gets or sets the validation chooser. This is a delegate that is used if AutomaticValidateAndRepairBeforeSave is true to choose to repair detected problems or not. The delegate will be called for each problem in turn. If the delegate returns true, the problem will be repaired.
Remarks
If ValidationChooser is set to null, only problems of Serious or less will be repaired. If there are any remaining problems, this will cause a PdfException to be thrown containing all the problems detected.
Examples
Copy
doc.ValidationChooser = PdfGeneratedDocument.MakeValidationSeverityChooser(Severity.Minor);
Public property ViewerPreferences
Gets or sets the viewer preferences for this PDF document. PdfViewerPreferences control coarse levels of document and page level user interaction such as the reading order of the document and print characteristics.
Top
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.AdditionalActions Property

PdfGeneratedDocumentAdditionalActions Property

Gets the list of additional actions that may be performed by a document.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentAdditionalActions AdditionalActions { get; }
Public ReadOnly Property AdditionalActions As DocumentAdditionalActions
    Get

Property Value

Type: DocumentAdditionalActions
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.AdjustPdfVersionAsNeeded Property

PdfGeneratedDocumentAdjustPdfVersionAsNeeded Property

Gets or sets a value indicating whether to adjust PDF version as needed. If the document is saved using features that surpass the version of the PDF spec to adhere to specified in PdfVersion, this will automatically adjust the version to match.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AdjustPdfVersionAsNeeded { get; set; }
Public Property AdjustPdfVersionAsNeeded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [adjust PDF version as needed]; otherwise, false.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.AllowSavingOfPreviouslySignedDocuments Property

PdfGeneratedDocumentAllowSavingOfPreviouslySignedDocuments Property

Gets or sets a value indicating whether to allow previously signed documents to be saved. Default value is false. If set to false, if DocumentWasSigned is true, calling Save will throw a PdfException. If set to true and DocumentWasSigned is true, calling Save will not throw an exception, but will create an invalid PDF which may still render correctly.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowSavingOfPreviouslySignedDocuments { get; set; }
Public Property AllowSavingOfPreviouslySignedDocuments As Boolean
    Get
    Set

Property Value

Type: Boolean
true if saving of previously signed documents is allowed; otherwise, false.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.AutomaticValidateAndRepairBeforeSave Property

PdfGeneratedDocumentAutomaticValidateAndRepairBeforeSave Property

Gets or sets a value indicating whether the document should attempt to automatically repair issues that may generate incorrect PDF.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutomaticValidateAndRepairBeforeSave { get; set; }
Public Property AutomaticValidateAndRepairBeforeSave As Boolean
    Get
    Set

Property Value

Type: Boolean
true attempt automatic repair before saving; otherwise, false.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.BookmarkTree Property

PdfGeneratedDocumentBookmarkTree Property

Gets or sets the bookmark tree.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBookmarkTree BookmarkTree { get; set; }
Public Property BookmarkTree As PdfBookmarkTree
    Get
    Set

Property Value

Type: PdfBookmarkTree
The bookmark tree.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.DisplayMode Property

PdfGeneratedDocumentDisplayMode Property

Gets or sets the display mode that will be used for this document.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageDisplayMode DisplayMode { get; set; }
Public Property DisplayMode As PdfPageDisplayMode
    Get
    Set

Property Value

Type: PdfPageDisplayMode
The display mode for the document.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.DocumentCertification Property

PdfGeneratedDocumentDocumentCertification Property

Gets or sets the information used to certify the document.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocumentCertification DocumentCertification { get; set; }
Public Property DocumentCertification As PdfGeneratedDocumentCertification
    Get
    Set

Property Value

Type: PdfGeneratedDocumentCertification
The document certification.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.DocumentWasSigned Property

PdfGeneratedDocumentDocumentWasSigned Property

Gets a value indicating whether the document contained a digital signature when opened.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DocumentWasSigned { get; }
Public ReadOnly Property DocumentWasSigned As Boolean
    Get

Property Value

Type: Boolean
true if the document contained a digital signature; otherwise, false.
Remarks
This property does not indicate that the validitity of the signature - only that there was a signature at the time the file was opened. Saving a file with a previous digital signature will create an invalid PDF.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.EmbedGeneratedContent Property

PdfGeneratedDocumentEmbedGeneratedContent Property

Gets or sets a value indicating whether to embed Generated content allowing a PdfGeneratedDocument to be reconstructed from a PDF.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EmbedGeneratedContent { get; set; }
Public Property EmbedGeneratedContent As Boolean
    Get
    Set

Property Value

Type: Boolean
true to embed Generated content; otherwise, false.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.EncryptMetadata Property

PdfGeneratedDocumentEncryptMetadata Property

Gets or sets a value indicating whether to encrypt metadata.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EncryptMetadata { get; set; }
Public Property EncryptMetadata As Boolean
    Get
    Set

Property Value

Type: Boolean
true if metadata will be encrypted; otherwise, false.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Form Property

PdfGeneratedDocumentForm Property

Gets or sets the form object for the document. By default, this is null.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfForm Form { get; set; }
Public Property Form As PdfForm
    Get
    Set

Property Value

Type: PdfForm
The form.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.GlobalJavaScriptActions Property

PdfGeneratedDocumentGlobalJavaScriptActions Property

Gets the global java script actions that will be executed when the PDF document is opened. This is initialized to an empty collection.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJavaScriptActionListCollection GlobalJavaScriptActions { get; }
Public ReadOnly Property GlobalJavaScriptActions As PdfJavaScriptActionListCollection
    Get

Property Value

Type: PdfJavaScriptActionListCollection
Examples
This example illustrates the technique used internally by Atalasoft to make a document self-printing (via the SelfPrinting property.
Copy
PdfJavaScriptAction selfPrint = new PdfJavaScriptAction("this.print({bUI:true,bSilent:false,bShrinkToFit:true});");
document.GlobalJavaScriptActions.Add("AtalaSelfPrint", selfPrint);
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Metadata Property

PdfGeneratedDocumentMetadata Property

Gets the document's metadata.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDocumentMetadata Metadata { get; }
Public ReadOnly Property Metadata As PdfDocumentMetadata
    Get

Property Value

Type: PdfDocumentMetadata
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.OwnerPassword Property

PdfGeneratedDocumentOwnerPassword Property

Note: This API is now obsolete.

Gets or sets the owner password.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
The owner password.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Pages Property

PdfGeneratedDocumentPages Property

Gets the pages of the document.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<BasePage> Pages { get; }
Public ReadOnly Property Pages As IList(Of BasePage)
    Get

Property Value

Type: IListBasePage
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.PdfVersion Property

PdfGeneratedDocumentPdfVersion Property

Gets or sets the desired PDF version for the output document. Currently, this will accept 2.0 value and values from 1.0 to 1.7 in increments of 0.1. Other values will be rejected. Defaults to 1.4.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PdfVersion { get; set; }
Public Property PdfVersion As Double
    Get
    Set

Property Value

Type: Double
The PDF version of the output document.
Remarks
Setting this value indicates the maximum version desired. It is possible that the output document could be read under earlier versions of the PDF standard, but it will be marked as the number specified. AdjustPdfVersionAsNeeded can be used to make an automatic setting.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Permissions Property

PdfGeneratedDocumentPermissions Property

Gets or sets the permissions.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAccessPermissions Permissions { get; set; }
Public Property Permissions As PdfAccessPermissions
    Get
    Set

Property Value

Type: PdfAccessPermissions
The permissions.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.RepairOptions Property

PdfGeneratedDocumentRepairOptions Property

Gets the repair options that will be used for the document.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairOptions RepairOptions { get; }
Public ReadOnly Property RepairOptions As RepairOptions
    Get

Property Value

Type: RepairOptions
Remarks
This object must be set through the constructor for PdfDocument. This is necessary since the constructors open the PDF which may in turn require repair actions. Changing the options after construction may affect some of the repairs or result in them being done inconsistently.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Resources Property

PdfGeneratedDocumentResources Property

Gets or sets the global resources.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalResources Resources { get; set; }
Public Property Resources As GlobalResources
    Get
    Set

Property Value

Type: GlobalResources
The global resources.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.SelfPrinting Property

PdfGeneratedDocumentSelfPrinting Property

Gets or sets a value indicating whether will self print upon opening.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SelfPrinting { get; set; }
Public Property SelfPrinting As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [self printing]; otherwise, false.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.UserPassword Property

PdfGeneratedDocumentUserPassword Property

Note: This API is now obsolete.

Gets or sets the user password.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use PdfSaveOptions.SetOneTimePasswords() instead to provide the passwords for saving.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
The user password.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.ValidationChooser Property

PdfGeneratedDocumentValidationChooser Property

Gets or sets the validation chooser. This is a delegate that is used if AutomaticValidateAndRepairBeforeSave is true to choose to repair detected problems or not. The delegate will be called for each problem in turn. If the delegate returns true, the problem will be repaired.
Remarks
If ValidationChooser is set to null, only problems of Serious or less will be repaired. If there are any remaining problems, this will cause a PdfException to be thrown containing all the problems detected.
Examples
Copy
doc.ValidationChooser = PdfGeneratedDocument.MakeValidationSeverityChooser(Severity.Minor);

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairChooser ValidationChooser { get; set; }
Public Property ValidationChooser As RepairChooser
    Get
    Set

Property Value

Type: RepairChooser
The current validation chooser.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.ViewerPreferences Property

PdfGeneratedDocumentViewerPreferences Property

Gets or sets the viewer preferences for this PDF document. PdfViewerPreferences control coarse levels of document and page level user interaction such as the reading order of the document and print characteristics.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfViewerPreferences ViewerPreferences { get; set; }
Public Property ViewerPreferences As PdfViewerPreferences
    Get
    Set

Property Value

Type: PdfViewerPreferences
The viewer preferences.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument Methods

The PdfGeneratedDocument type exposes the following members.

Methods
 | Name | Description
 | AddPage | Adds the page to the document, returning the added page. This is a convenience method to streamline the process of adding pages to a document.
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImportPages | Imports pages and associated resources from PDF stream.
 | MakeValidationSeverityChooser | This is a convenience factory that will return a new delegate that will repair all problems that are as severe or less severity than the specified maximum.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save(Stream) | Saves the document to the specified outStream.
Public method | Save(String) | Saves the document to the specified output file.
Public method | Save(Stream, EventHandlerRenderProgressEventArgs) | Saves the document to the specified outStream.
Public method | Save(String, EventHandlerRenderProgressEventArgs) | Saves the document to the specified output file.
Public method | Save(Stream, PdfSaveOptions, EventHandlerRenderProgressEventArgs) | Saves the Pdf document to the output stream using the provided options.
Public method | Save(String, PdfSaveOptions, EventHandlerRenderProgressEventArgs) | Saves the document to the specified output file.
Public method | Save(String, String, Stream, EventHandlerRenderProgressEventArgs) | Obsolete. Saves the Pdf document to the output stream using the provided passwords.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the document and returns a set of possible problems.
Top
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.AddPage Method

PdfGeneratedDocumentAddPage Method

Adds the page to the document, returning the added page. This is a convenience method to streamline the process of adding pages to a document.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedPage AddPage(
    PdfGeneratedPage page
)
Public Function AddPage (
    page As PdfGeneratedPage
) As PdfGeneratedPage

Parameters

page
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
The page.

Return Value

Type: PdfGeneratedPage
The new page that has been added.
Examples
Instead of writing this code:
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = new PdfGeneratedPage(PdfDefaultPages.Letter);
doc.Pages.Add(page);
You can write this instead:
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = doc.AddPage(PdfDefaultPages.Letter);
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Dispose Method

PdfGeneratedDocumentDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfGeneratedDocument
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfGeneratedDocument and optionally releases the managed resources
Top
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Dispose Method

PdfGeneratedDocumentDispose Method

Releases all resources used by the PdfGeneratedDocument

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfGeneratedDocument Class
Dispose Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Dispose Method (Boolean)

PdfGeneratedDocumentDispose Method (Boolean)

Releases the unmanaged resources used by the PdfGeneratedDocument and optionally releases the managed resources

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfGeneratedDocument Class
Dispose Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.ImportPages Method

PdfGeneratedDocumentImportPages Method

Imports pages and associated resources from PDF stream.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ImportPages(
    Stream stm,
    ImportOptions importOptions = null,
    SecureString userPassword = null,
    SecureString ownerPassword = null
)
Public Sub ImportPages (
    stm As Stream,
    Optional importOptions As ImportOptions = Nothing,
    Optional userPassword As SecureString = Nothing,
    Optional ownerPassword As SecureString = Nothing
)

Parameters

stm
Type: System.IOStream
importOptions (Optional)
Type: Atalasoft.PdfDoc.MergeFormsImportOptions
Options for importing the PDF document. This parameter may be .
userPassword (Optional)
Type: System.SecuritySecureString
The user password to open the document.
ownerPassword (Optional)
Type: System.SecuritySecureString
The owner password to open the document.
Remarks

Imported pages will be added to Pages.

If Form in current document is null and imported document contains form, imported document form will be set in current document form.

If Form in current document is not null and imported document does not contain form, current document form will not change.

If Form in current document is not null and imported document contains form, current document form will not change, but fields will be merged.

On merging fields, fields collections will be compared. If both collections contain fields with equal fully qualified names, FormFieldsConflictHandler will be called to resolve the conflict.

If FormFieldsConflictHandler is not set, by default, all fields with equal fully qualified names and same field types are merged:

  • current field of current form is not changed;
  • all child fields of external field added to children collection of current field.

Examples
Sample for merging fields with same type and renaming fields with different types
Copy
public void CombinePdfForms()
{
    using (var stm = File.OpenRead(@"TwoPagesForm.pdf"))

    using (var genDoc = new PdfGeneratedDocument(stm))
    using (var streamForImport = File.OpenRead(@"docWithForms.pdf"))
    {
        genDoc.ImportPages(streamForImport, new ImportOptions
        {
            FormFieldsConflictHandler = ResolveFormFieldsConflict
        });

        using (var outStm = File.Create("CombinedForm.pdf"))
            genDoc.Save(outStm);
    }
}

private void ResolveFormFieldsConflict(object s, FormFieldsConflictEventArgs a)
{
    if (a.AreFieldTypesEqual)
    {
        a.ConflictResolution =
            FormFieldsConflictResult.KeepCurrentFieldAndMergeChildren;
        return;
    }
    // generate new name for field
    a.ExternalField.FieldName = "new" + a.ExternalField.FieldName;
    a.ConflictResolution = FormFieldsConflictResult.KeepBoth;
}
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.MakeValidationSeverityChooser Method

PdfGeneratedDocumentMakeValidationSeverityChooser Method

This is a convenience factory that will return a new delegate that will repair all problems that are as severe or less severity than the specified maximum.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RepairChooser MakeValidationSeverityChooser(
    Severity maximumSeverity
)
Public Shared Function MakeValidationSeverityChooser (
    maximumSeverity As Severity
) As RepairChooser

Parameters

maximumSeverity
Type: Atalasoft.PdfDoc.Generating.ValidationSeverity
The maximum allowable severity.

Return Value

Type: RepairChooser
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method

PdfGeneratedDocumentSave Method

Overload List
 | Name | Description
Public method | Save(Stream) | Saves the document to the specified outStream.
Public method | Save(String) | Saves the document to the specified output file.
Public method | Save(Stream, EventHandlerRenderProgressEventArgs) | Saves the document to the specified outStream.
Public method | Save(String, EventHandlerRenderProgressEventArgs) | Saves the document to the specified output file.
Public method | Save(Stream, PdfSaveOptions, EventHandlerRenderProgressEventArgs) | Saves the Pdf document to the output stream using the provided options.
Public method | Save(String, PdfSaveOptions, EventHandlerRenderProgressEventArgs) | Saves the document to the specified output file.
Public method | Save(String, String, Stream, EventHandlerRenderProgressEventArgs) | Obsolete. Saves the Pdf document to the output stream using the provided passwords.
Top
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (Stream)

PdfGeneratedDocumentSave Method (Stream)

Saves the document to the specified outStream.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outStream
)
Public Sub Save (
    outStream As Stream
)

Parameters

outStream
Type: System.IOStream
The out stream to which to save the resulting document.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (String)

PdfGeneratedDocumentSave Method (String)

Saves the document to the specified output file.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string outputFile
)
Public Sub Save (
    outputFile As String
)

Parameters

outputFile
Type: SystemString
The path to the output file.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (Stream, EventHandler(RenderProgressEventArgs))

PdfGeneratedDocumentSave Method (Stream, EventHandlerRenderProgressEventArgs)

Saves the document to the specified outStream.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outStream,
    EventHandler<RenderProgressEventArgs> progressHandler
)
Public Sub Save (
    outStream As Stream,
    progressHandler As EventHandler(Of RenderProgressEventArgs)
)

Parameters

outStream
Type: System.IOStream
The out stream to which to save the resulting document.
progressHandler
Type: SystemEventHandlerRenderProgressEventArgs
The progress handler.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (String, EventHandler(RenderProgressEventArgs))

PdfGeneratedDocumentSave Method (String, EventHandlerRenderProgressEventArgs)

Saves the document to the specified output file.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string outputFile,
    EventHandler<RenderProgressEventArgs> progressHandler
)
Public Sub Save (
    outputFile As String,
    progressHandler As EventHandler(Of RenderProgressEventArgs)
)

Parameters

outputFile
Type: SystemString
The path to the output file.
progressHandler
Type: SystemEventHandlerRenderProgressEventArgs
The progress handler.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (Stream, PdfSaveOptions, EventHandler(RenderProgressEventArgs))

PdfGeneratedDocumentSave Method (Stream, PdfSaveOptions, EventHandlerRenderProgressEventArgs)

Saves the Pdf document to the output stream using the provided options.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    Stream outStream,
    PdfSaveOptions saveOptions,
    EventHandler<RenderProgressEventArgs> progressHandler
)
Public Sub Save (
    outStream As Stream,
    saveOptions As PdfSaveOptions,
    progressHandler As EventHandler(Of RenderProgressEventArgs)
)

Parameters

outStream
Type: System.IOStream
The out stream to which to save the resulting document.
saveOptions
Type: Atalasoft.PdfDocPdfSaveOptions
Options for saving the Pdf document. This parameter may be .
progressHandler
Type: SystemEventHandlerRenderProgressEventArgs
The progress handler.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (String, PdfSaveOptions, EventHandler(RenderProgressEventArgs))

PdfGeneratedDocumentSave Method (String, PdfSaveOptions, EventHandlerRenderProgressEventArgs)

Saves the document to the specified output file.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Save(
    string outputFile,
    PdfSaveOptions saveOptions,
    EventHandler<RenderProgressEventArgs> progressHandler
)
Public Sub Save (
    outputFile As String,
    saveOptions As PdfSaveOptions,
    progressHandler As EventHandler(Of RenderProgressEventArgs)
)

Parameters

outputFile
Type: SystemString
The path to the output file.
saveOptions
Type: Atalasoft.PdfDocPdfSaveOptions
Options for saving the Pdf document. This parameter may be .
progressHandler
Type: SystemEventHandlerRenderProgressEventArgs
The progress handler.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Save Method (String, String, Stream, EventHandler(RenderProgressEventArgs))

PdfGeneratedDocumentSave Method (String, String, Stream, EventHandlerRenderProgressEventArgs)

Note: This API is now obsolete.

Saves the Pdf document to the output stream using the provided passwords.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is obsolete. Use Save(Stream, PdfSaveOptions, EventHandler<RenderProgressEventArgs>) instead.",
    true)]
public void Save(
    string userPassword,
    string ownerPassword,
    Stream outStream,
    EventHandler<RenderProgressEventArgs> progressHandler
)
<ObsoleteAttribute("This method is obsolete. Use Save(Stream, PdfSaveOptions, EventHandler<RenderProgressEventArgs>) instead.",
    true)>
Public Sub Save (
    userPassword As String,
    ownerPassword As String,
    outStream As Stream,
    progressHandler As EventHandler(Of RenderProgressEventArgs)
)

Parameters

userPassword
Type: SystemString
The user password.
ownerPassword
Type: SystemString
The owner password.
outStream
Type: System.IOStream
The out stream to which to save the resulting document.
progressHandler
Type: SystemEventHandlerRenderProgressEventArgs
The progress handler.
See Also

Reference

PdfGeneratedDocument Class
Save Overload
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedDocument.Validate Method

PdfGeneratedDocumentValidate Method

Validates the document and returns a set of possible problems.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProblemList Validate()
Public Function Validate As ProblemList

Return Value

Type: ProblemList
The (possibly empty) list of problems encountered.
See Also

Reference

PdfGeneratedDocument Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage Class

A BasePage object which contains functionality to create Pdf. Use this class when trying to programmatically generate pdf pages.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDocBasePage
Atalasoft.PdfDoc.GeneratingPdfGeneratedPage

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfGeneratedPage : BasePage,
    IValidatable
Public Class PdfGeneratedPage
    Inherits BasePage
    Implements IValidatable

The PdfGeneratedPage type exposes the following members.

Constructors
 | Name | Description
Public method | PdfGeneratedPage | Initializes a new instance of the PdfGeneratedPage class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the list of additional actions that may be performed by a page.
 | Annotations | Gets the list of annotations on this page. This is an empty list by default.
Public property | ArtBox | Gets or sets the art box.
Public property | BleedBox | Gets or sets the bleed box.
Public property | CropBox | Gets or sets the crop box.
Public property | DrawingList | Gets the drawing list. The drawing list contains all the objects on the page to be saved to the pdf file.
Public property | ImportedColorSpaces | Gets a list of global resource names of the color spaces that were successfully imported into GlobalResources from the source document (if any).
Public property | ImportedFonts | Gets a list of global resource names of the fonts that were successfully imported into GlobalResources from the source document (if any).
Public property | ImportedImages | Gets a list of global resource names of the images that were successfully imported into GlobalResources from the source document (if any).
Public property | MediaBox | Gets or sets the media box.
Public property | Rotation | Gets or sets the rotation for the page.
Public property | TabOrder | Gets or sets the tab order for annotations on the page. Default is None
Public property | TrimBox | Gets or sets the trim box.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the DocumentRepairContext for repairing problems in this object. This method expects a PdfGeneratedDocument to be passed in.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage Constructor

Initializes a new instance of the PdfGeneratedPage class.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedPage(
    double width,
    double height
)
Public Sub New (
    width As Double,
    height As Double
)

Parameters

width
Type: SystemDouble
The width of the page.
height
Type: SystemDouble
The height of the page.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage Properties

The PdfGeneratedPage type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the list of additional actions that may be performed by a page.
 | Annotations | Gets the list of annotations on this page. This is an empty list by default.
Public property | ArtBox | Gets or sets the art box.
Public property | BleedBox | Gets or sets the bleed box.
Public property | CropBox | Gets or sets the crop box.
Public property | DrawingList | Gets the drawing list. The drawing list contains all the objects on the page to be saved to the pdf file.
Public property | ImportedColorSpaces | Gets a list of global resource names of the color spaces that were successfully imported into GlobalResources from the source document (if any).
Public property | ImportedFonts | Gets a list of global resource names of the fonts that were successfully imported into GlobalResources from the source document (if any).
Public property | ImportedImages | Gets a list of global resource names of the images that were successfully imported into GlobalResources from the source document (if any).
Public property | MediaBox | Gets or sets the media box.
Public property | Rotation | Gets or sets the rotation for the page.
Public property | TabOrder | Gets or sets the tab order for annotations on the page. Default is None
Public property | TrimBox | Gets or sets the trim box.
Top
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.AdditionalActions Property

PdfGeneratedPageAdditionalActions Property

Gets the list of additional actions that may be performed by a page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageAdditionalActions AdditionalActions { get; }
Public ReadOnly Property AdditionalActions As PageAdditionalActions
    Get

Property Value

Type: PageAdditionalActions
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.Annotations Property

PdfGeneratedPageAnnotations Property

Gets the list of annotations on this page. This is an empty list by default.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationList Annotations { get; }
Public ReadOnly Property Annotations As PdfAnnotationList
    Get

Property Value

Type: PdfAnnotationList
Remarks
Annotations are not typically precluded from appearing on multiple pages, but it not encouraged. BaseWidgetAnnotation objects are forbidden from appearing more than once per document.
Examples
To add an annotation to a page:
Copy
BaseAnnotation annot = MakeAnnot();
page.Annotations.Add(annot);
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.ArtBox Property

PdfGeneratedPageArtBox Property

Gets or sets the art box.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds ArtBox { get; set; }
Public Property ArtBox As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The art box.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.BleedBox Property

PdfGeneratedPageBleedBox Property

Gets or sets the bleed box.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds BleedBox { get; set; }
Public Property BleedBox As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bleed box.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.CropBox Property

PdfGeneratedPageCropBox Property

Gets or sets the crop box.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds CropBox { get; set; }
Public Property CropBox As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The crop box.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.DrawingList Property

PdfGeneratedPageDrawingList Property

Gets the drawing list. The drawing list contains all the objects on the page to be saved to the pdf file.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDrawingList DrawingList { get; }
Public ReadOnly Property DrawingList As PdfDrawingList
    Get

Property Value

Type: PdfDrawingList
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.ImportedColorSpaces Property

PdfGeneratedPageImportedColorSpaces Property

Gets a list of global resource names of the color spaces that were successfully imported into GlobalResources from the source document (if any).

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ImportedColorSpaces { get; }
Public ReadOnly Property ImportedColorSpaces As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerableString
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.ImportedFonts Property

PdfGeneratedPageImportedFonts Property

Gets a list of global resource names of the fonts that were successfully imported into GlobalResources from the source document (if any).

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ImportedFonts { get; }
Public ReadOnly Property ImportedFonts As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerableString
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.ImportedImages Property

PdfGeneratedPageImportedImages Property

Gets a list of global resource names of the images that were successfully imported into GlobalResources from the source document (if any).

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ImportedImages { get; }
Public ReadOnly Property ImportedImages As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerableString
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.MediaBox Property

PdfGeneratedPageMediaBox Property

Gets or sets the media box.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds MediaBox { get; set; }
Public Property MediaBox As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The media box.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.Rotation Property

PdfGeneratedPageRotation Property

Gets or sets the rotation for the page.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageRotation Rotation { get; set; }
Public Property Rotation As PdfPageRotation
    Get
    Set

Property Value

Type: PdfPageRotation
The rotation for the page in 90 degree increments.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.TabOrder Property

PdfGeneratedPageTabOrder Property

Gets or sets the tab order for annotations on the page. Default is None

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTabOrder TabOrder { get; set; }
Public Property TabOrder As PdfTabOrder
    Get
    Set

Property Value

Type: PdfTabOrder
The tab order for annotations on the page.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.TrimBox Property

PdfGeneratedPageTrimBox Property

Gets or sets the trim box.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds TrimBox { get; set; }
Public Property TrimBox As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The trim box.
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage Methods

The PdfGeneratedPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the DocumentRepairContext for repairing problems in this object. This method expects a PdfGeneratedDocument to be passed in.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.MakeRepairContext Method

PdfGeneratedPageMakeRepairContext Method

Makes the DocumentRepairContext for repairing problems in this object. This method expects a PdfGeneratedDocument to be passed in.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An PdfGeneratedDocument used to make the repair context.

Return Value

Type: RepairContext
A new DocumentRepairContext for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


PdfGeneratedPage.Validate Method

PdfGeneratedPageValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.PdfDoc.Generating
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

PdfGeneratedPage Class
Atalasoft.PdfDoc.Generating Namespace


Atalasoft.PdfDoc.Generating.Annotations Namespace

Classes
Class Description
AnnotationBorder
This class represents the appearance of the border drawn for PDF annotations.
Examples
This is an example of how to create a RectangleAnnotation with round corners and a wide outline:
Copy
RectangleAnnotation annot = new RectangleAnnotation(bounds);
annot.Border = new AnnotationBorder(4, 4, 10, AnnotationBorder.EmpyDashPattern);
Public class AnnotationPropertyProblemT
Defines a problem that could occur with the a BaseAnnotation property value.
AppearanceSet
Pdf annotations support appearances that can be associated with three interaction modes NormalHow the annotation will appear under typical circumstances (ie, no interaction)RolloverHow the annotation will appear when the cursor is in the annotationActivatedHow the annotation will appear when click on Each of this modes is associated with a collection of appearances, each of which corresponds to an annotation's current state. For example, a CheckboxWidgetAnnotation defines states for when it has been checked and when it is clear. The Normal property would contain appearances for each of these states. When an annotation only has one state, the name of that state is inconsequetial and will be ignored when written to the PDF file. For naming purposes, if an annotation has only a single state with no meaningful name, you can use DefaultAppearanceName for the name.
Public class AppearanceStates
AppearanceStates represents a collection of names of PdfTemplateResource objects that are keyed by a state name. For most annotations there is only one state that has no particular state name. For this situation, you can use DefaultAppearanceName for the single state name.
Public class BaseAnnotation
Represents a base class for all PDF annotation types.
Public class BaseButtonWidgetAnnotation
This class is a base class for all button widgets, including PushButtonWidgetAnnotation, CheckboxWidgetAnnotation, and RadioButtonWidgetAnnotation. It cannot be constructed directly.
Public class BaseMarkupAnnotation
BaseMarkupAnnotation is an abstract class that represents the common features of PDF annotations that are used for document mark-up.
Public class BaseWidgetAnnotation
BaseWidgetAnnotation is the abstract base class of all widget annotations. All widgets serve both as annotations and as form elements, therefore BaseWidgetAnnotation also implements the IFormElement interface allowing it to act as a child field of any non-widget annotation.
Public class BorderEffect
The BorderEffect object represents a way to modify the basic appearance of some PDF annotations, including RectangleAnnotation, EllipseAnnotation, PolygonAnnotation and TextBoxAnnotation. Support for all but TextBoxAnnotation began with PDF 1.5. Support for TextBoxAnnotation began in PDF 1.6. BorderEffect consists of a BorderEffectKind and an intensity setting. Intensity only currently applies to Cloudy.
Public class BorderStyle
The BorderStyle object represents a border than may surround an annotation including border width, style and dash pattern.
Public class CalloutAnnotation
The CalloutAnnotation is a type of TextBoxAnnotation which represents a text annotation with a line pointing from the annotation to a particular point on the page.
Public class CalloutLine
A callout line is a line that runs from a CalloutAnnotation to another point on the page. CalloutLine is abstract with concrete implementations that represent a two-point line and a three-point line.
Public class CaretAnnotation
A CaretAnnotation is a BaseMarkupAnnotation that represents an intended insertion point in a document.
CheckboxWidgetAnnotation
The CheckboxWidgetAnnotation is a button type widget that allows the user to select between one of two possible values. By convention, these values are "Yes" and "Off". Unlike most annotations, CheckBoxWidgetAnnotations needs to have a suite of DrawingTemplate resources associated with it. At a minimum, there needs to be a "Yes" and "Off" entries in the Normal appearance set.
Examples
This is how to set up a set of default appearances for a checkbox:
Copy
checkbox.Appearance.Normal.Add(CheckboxWidgetAnnotation.CheckedValue, "normalChecked");
checkbox.Appearance.Normal.Add(CheckboxWidgetAnnotation.ClearedValue, "normalCleared");
"normalChecked" and "normalCleared" are strings that should be the name of PdfTemplateResource objects in your document's resource collection.
Public class ChoicePair
In a ChoiceWidgetAnnotation, it is possible to have either a list of choices which will be used both for display and for exporting data, or a list of pairs where one element is used for display and the other element is used for exporting data. For example, you might create a survey where a ChoiceWidgetAnnotation displays "Best - Would Purchase Again", "Good - Satisfactory", "Poor - Would Not Purchase Again". These are wordy and might not be suitable for a data consumer, so you could instead associate export names with each choice: "Best", "Good", "Poor". You could also create surveys for other languages by putting the target language in the display name and a language neutral name in the export name.
Public class ChoiceWidgetAnnotation
A ChoiceWidgetAnnotation is a BaseWidgetAnnotation used for defining a selection from a list of options. The selection can be none, 1 item or many items. The annotation can be either a list box or a pop-up menu of options.
Public class DefaultWidgetTemplates
This is a class that is used for defining and installing PdfTemplateResource objects in a resource dictionary that represent the appearances for widget annotations. At present this class is responsible for making appearances for checkbox and radio button widgets, as these appearances can be shared across an entire document. Before working with a new document, you can set the basic color schemes used for the appearances. In addition, you can force installation of your own default appearances and they will be treated as standard.
Public class EllipseAnnotation
Represents an ellipse (or circle) annotation. This annotation is identical in every way to the RectangleAnnotation except for the appearance.
Public class GeneralReview
GeneralReview represents a review process with states None, Accepted, Rejected, Cancelled, and Completed.
Public class InkAnnotation
An InkAnnotation represents a series of free-hand marks. They are modeled by a set of polylines grouped as one. These could be used for a signature or document mark up.
Public class LineAnnotation
The LineAnnotation represents a single line on the page
Public class LinkAnnotation
A LinkAnnotation represents a hyperlink in a PDF document. A PDF hyperlink is a generalized to mean "an area that when clicked causes a chain of actions to take place." For example, a LinkAnnotation could cause a sound to be played and then the document to be zoomed to a particular view on a page.
Public class MarkingReview
A MarkingReview represents a review process with two states: Marked and Unmarked.
Public class OpaqueAnnotation
OpaqueAnnotation is an annotation that does not currently have a DotPdf high-level representation. You cannot create an OpaqueAnnotation directly. It will be created when reading a PDF file with an unsupported annotation.
Public class PdfAnnotationList
PdfAnnotationList is a collection of annotations for a PDF page,
Public class PolygonAnnotation
The PolygonAnnotation represents a filled polygon on the page.
Public class PolylineAnnotation
The PolylineAnnotation represents an unfilled polygon.
Public class PopupAnnotation
The PopupAnnotation represents an annotation that can be shown or hidden and offers more information about another annotation. Popup annotations never appear singly. They are always associated with an existing annotation via its Popup property and also by setting the ParentAnnotation property to the BaseMarkupAnnotation. When the ParentAnnotation is a BaseMarkupAnnotation, the PopupAnnotation will project properties of the BaseMarkupAnnotation.
Public class PushButtonWidgetAnnotation
A PushButtonWidgetAnnotation represents a clickable button on a page. A pushbutton annotation doesn't have any actions associated by default and need to be set in the ClickActions property.
Public class RadioButtonWidgetAnnotation
The RadioButtonWidgetAnnotation represents a possible selection in a set of choices. Typically, the act of selecting a radio button annotation will have the side effect of de-selecting one or more others. As a result, a single RadioButtonWidgetAnnotation is not particularly useful on its own. Grouping is managed by making each button in the group be a child of a RadioButtonFormField. This is done by creating a RadioButtonWidgetAnnotation for each button, giving each a unique "on value", setting each in the ChildFields collection of the parent field and putting the annotations into a page. It is far easier to use MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) which will construct the parent field and all the radio buttons and wire them up correctly. If you use the standard appearances, the radio button's appearance will not have any text associated with it. It will instead just be the button itself. It is the responsibility of the client code to provide labels.
Public class RectangleAnnotation
A RectangleAnnotation represents a rectangle drawn on the page.
RedactionProposalAnnotation
The RedactionProposalAnnotation is a BaseMarkupAnnotation that is used to mark areas within a document that are proposed for redaction. The creation of this annotation on a page does not remove any content below it. That is left strictly to the PDF viewer and may or may not be supported. This particular annotation was only supported beginning with PDF version 1.7 and should be used with care. When a compliant viewer performs redaction based on one or more RedactionProposalAnnotation objects, it is instructed to remove all content under the area or areas specified and will remove the annotation but insert new content in its place. This content depends on the specification of the annotation. If the annotation does not specify any quadrilaterals in the Regions property, the area will be a rectangle specified by Bounds that is filled with the RedactionInteriorColor or black if none has been specified. If there are Regions specified, they will be used instead of Bounds. If OverlayText is specified, this text will be overlayed on top of the redacted area. If IsOverlayTextRepeated is true, then the text will be laid down in a repeating pattern. If RedactionTemplate is set, this template will be used for the redaction instead of all of the previous elements.
Public class ReviewProcess
StickyNoteAnnotation objects can be use to mark documents for being in a particular review state. The process of review is represented by the ReviewProcess class. ReviewProcess is an abstract class and is not used directly.
Public class RubberStampAnnotation
A RubberStampAnnotation represents a canned set of markings for a document that appear as if the document had been stamped.
Public class SignatureWidgetAnnotation
A SignatureWidgetAnnotation represents an area on a page that can be signed by the recipient of a document.
Public class SoundAnnotation
The SoundAnnotation is used to provide a voice or other sound mark-up in a document. The annotation appears on the page as either a speaker or a microphone using the standard appearance. SoundAnnotation objects contain a Sound object which represents the sound that will be played. In most PDF viewers, sound annotations can only be triggered to play by direct user interaction. If you need a Sound to be played by some other trigger, consider using a PdfSoundAction
StickyNoteAnnotation
A StickyNoteAnnotation is meant to represent a sticky note on the page. In interaction, the note is either closed or open. When closed, it appears as a small piece of paper attached to the page. When open, it provides a simple user interface to view and edit text associated with it. In the initial versions of PDF, this annotation was represented on its own and because of the nature of the UI, was very complicated. In later revisions, it was changed to be two annotations: a StickyNoteAnnotation which holds the text and a PopupAnnotation which represents the UI for editing the text. This is now the preferred form and there is a convenience constructor that will make an associated PopupAnnotation and attach it to the StickyNoteAnnotation.
Examples
This shows how to use the convenience constructor for making a PopupAnnotation.
Copy
StickyNoteAnnotation annot = new StickyNoteAnnotation(new PdfBounds(72, 400, 36, 72), "empty.",
                                        new PdfBounds(72, 400, 144, 288));
// this is equivalent to:

StickyNoteAnnotation annot = new StickyNoteAnnotation(new PdfBounds(72, 400, 36, 72) "empty.");
annot.Popup = new PopupAnnotation(new PdfBounds(72, 400, 144, 288), annot);
Public class StringDrawingTemplatePair
StringDrawingTemplatePair is a utility class to associate a name with a DrawingTemplate. This class is immutable. Once constructed, neither component can be changed.
Public class TextBoxAnnotation
A TextBoxAnnotation represents and annotation with text constrained by a bounding rectangle. Unlike the StickyNoteAnnotation, the TextBoxAnnotation does not have an open/closed state. It is simply text in a box on the page.
Public class TextMarkupAnnotation
A TextMarkupAnnotation is an annotation type that is used to represent various similar ways of marking editing changes to text on a page. Typically, this type of annotation is built by using the set of quadrilaterals that bound individual words or word parts on a page and then providing marks on top of the text including underlines, highlights, an insertion caret, strike out, or squiggly underline.
TextWidgetAnnotation
A TextWidgetAnnotation is used to provide a user-fillable text field on a form in a document. Note that the act of putting a widget annotation of a page is not enough to mark it as a form field. The annotation must also be put into the Fields collection of the document's Form property as well.
Examples
Creating a typical widget annotation.
Copy
TextWidgetAnnotation anno = new TextWidgetAnnotation(bounds, "user", "anonymous");
page.Annotations.Add(anno);
doc.Form.Fields.Add(anno);
Public class ThreePointCalloutLine
A ThreePointCalloutLine is a line that contains a "knee" in the middle of the line. This can be used to make a more pleasing call out line such that at least one line segment is rectilinear.
Public class TwoPointCalloutLine
This represents a simple two-point line with a starting point and an ending point.
Public class TypeWriterAnnotation
The TypeWriterAnnotation is nearly identical to the TextBoxAnnotation except that it implies that the Bounds property are fluid to the text that is being entered and that there is usually no background or outline drawn for the bounding region. As such, it is supposed to appear as if the user is typing notes directly onto the page. If the text contains either neline or carriage returns characters ('\n' or '\r', the lines will be split at those points.
Public class UnknownReview
Represents a review process that is not modeled in DotPdf. Since review process in Acrobat does not contain all possible states, it is impossible to infer the full set of possible states from PDF file, so this class of review is likely to be incomplete.
Enumerations
 | Enumeration | Description
Public enumeration | AnnotationIntent | In PDF, annotations can optionally specify their intended meaning and use. For some annotations, such as TextBoxAnnotation, CalloutAnnotation, and TypeWriterAnnotation, there is not always a reliable way to disambiguate one annotation from another in the PDF file without having an AnnotationIntent set in the Intent property of an annotation. When an AnnotationIntent is mandatory, DotPdf classes will enforce them and ensure they are correct. When it is optional, it is typically left out.
Public enumeration | AnnotationTextAlignment | Determines alignment of text drawn in certain types of annotations.
Public enumeration | BorderEffectKind | Some annotations can be shown with a "cloudy" effect on the border. This enumeration is used for specifying it.
Public enumeration | BorderStyleKind | BorderStyleKind is used to specify how the borders of simple annotations should appear on the page. None is default.
Public enumeration | CaptionPositionKind | Determines where to locate a caption on a line
Public enumeration | CaretSymbol | The symbol to use for a insertion annotation
Public enumeration | ChoiceWidgetKind | Determines how a ChoiceWidgetAnnotation will appear in the user interface.
Public enumeration | LineEndingKind | Annotations with lines may have decorative ends. This enumeration specifies those ends.
Public enumeration | LineUsageKind | Specifies how a line is to be used
Public enumeration | LinkHighlightAppearance | Determines how a link annotation should respond when clicked
Public enumeration | ReplyRelation | Represents the type of reply a BaseMarkupAnnotation represents.
Public enumeration | RubberStampKind | Determines how a rubber stamp will appear from the set of standard PDF types.
Public enumeration | TextMarkupKind | Determines the type of text markup in a TextMarkupAnnotation
Public enumeration | WidgetHighlightAppearance | Determines how a clickable widget will appear when it is clicked.


AnnotationBorder Class

This class represents the appearance of the border drawn for PDF annotations.
Examples
This is an example of how to create a RectangleAnnotation with round corners and a wide outline:
Copy
RectangleAnnotation annot = new RectangleAnnotation(bounds);
annot.Border = new AnnotationBorder(4, 4, 10, AnnotationBorder.EmpyDashPattern);
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsAnnotationBorder

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationBorder
Public Class AnnotationBorder

The AnnotationBorder type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationBorder | Initializes a new instance of the AnnotationBorder class with HorizontalCornerRadius = 0, VerticalCornerRadius = 0, Width = 0, and DashPattern = EmptyDashPattern.
Public method | AnnotationBorder(Double, Double, Double, IEnumerableDouble) | Initializes a new instance of the AnnotationBorder class with the specified values.
Top
Properties
 | Name | Description
 | DashPattern | Gets or sets the dash pattern.
 | EmptyDashPattern | Gets the empty dash pattern. Using this as the dash pattern with generate a solid line.
Public property | HorizontalCornerRadius | Gets or sets the horizontal corner radius in PDF units.
Public property | VerticalCornerRadius | Gets or sets the vertical corner radius in PDF units.
Public property | Width | Gets or sets the width of the line in PDF units.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder Constructor

Overload List
 | Name | Description
Public method | AnnotationBorder | Initializes a new instance of the AnnotationBorder class with HorizontalCornerRadius = 0, VerticalCornerRadius = 0, Width = 0, and DashPattern = EmptyDashPattern.
Public method | AnnotationBorder(Double, Double, Double, IEnumerableDouble) | Initializes a new instance of the AnnotationBorder class with the specified values.
Top
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder Constructor

Initializes a new instance of the AnnotationBorder class with HorizontalCornerRadius = 0, VerticalCornerRadius = 0, Width = 0, and DashPattern = EmptyDashPattern.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBorder()
Public Sub New
See Also

Reference

AnnotationBorder Class
AnnotationBorder Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder Constructor (Double, Double, Double, IEnumerable(Double))

AnnotationBorder Constructor (Double, Double, Double, IEnumerableDouble)

Initializes a new instance of the AnnotationBorder class with the specified values.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBorder(
    double hoizontalCornerRadius,
    double verticalCornerRadius,
    double width,
    IEnumerable<double> dashPattern
)
Public Sub New (
    hoizontalCornerRadius As Double,
    verticalCornerRadius As Double,
    width As Double,
    dashPattern As IEnumerable(Of Double)
)

Parameters

hoizontalCornerRadius
Type: SystemDouble
The hoizontal corner radius.
verticalCornerRadius
Type: SystemDouble
The vertical corner radius.
width
Type: SystemDouble
The line width.
dashPattern
Type: System.Collections.GenericIEnumerableDouble
The dash pattern.
See Also

Reference

AnnotationBorder Class
AnnotationBorder Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder Properties

The AnnotationBorder type exposes the following members.

Properties
 | Name | Description
 | DashPattern | Gets or sets the dash pattern.
 | EmptyDashPattern | Gets the empty dash pattern. Using this as the dash pattern with generate a solid line.
Public property | HorizontalCornerRadius | Gets or sets the horizontal corner radius in PDF units.
Public property | VerticalCornerRadius | Gets or sets the vertical corner radius in PDF units.
Public property | Width | Gets or sets the width of the line in PDF units.
Top
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder.DashPattern Property

AnnotationBorderDashPattern Property

Gets or sets the dash pattern.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<double> DashPattern { get; set; }
Public Property DashPattern As IEnumerable(Of Double)
    Get
    Set

Property Value

Type: IEnumerableDouble
The dash pattern.
Examples
This is a set of numbers that indicate how many PDF units the line will be drawn and skipped. For example, to have lines drawn with a 3 unit dash seprated by 1 unit spaces, you would use new double[] { 3, 1 }
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder.EmptyDashPattern Property

AnnotationBorderEmptyDashPattern Property

Gets the empty dash pattern. Using this as the dash pattern with generate a solid line.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<double> EmptyDashPattern { get; }
Public Shared ReadOnly Property EmptyDashPattern As IEnumerable(Of Double)
    Get

Property Value

Type: IEnumerableDouble
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder.HorizontalCornerRadius Property

AnnotationBorderHorizontalCornerRadius Property

Gets or sets the horizontal corner radius in PDF units.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HorizontalCornerRadius { get; set; }
Public Property HorizontalCornerRadius As Double
    Get
    Set

Property Value

Type: Double
The horizontal corner radius.
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder.VerticalCornerRadius Property

AnnotationBorderVerticalCornerRadius Property

Gets or sets the vertical corner radius in PDF units.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double VerticalCornerRadius { get; set; }
Public Property VerticalCornerRadius As Double
    Get
    Set

Property Value

Type: Double
The vertical corner radius.
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder.Width Property

AnnotationBorderWidth Property

Gets or sets the width of the line in PDF units.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set

Property Value

Type: Double
The width of the line.
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationBorder Methods

The AnnotationBorder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationBorder Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationIntent Enumeration

In PDF, annotations can optionally specify their intended meaning and use. For some annotations, such as TextBoxAnnotation, CalloutAnnotation, and TypeWriterAnnotation, there is not always a reliable way to disambiguate one annotation from another in the PDF file without having an AnnotationIntent set in the Intent property of an annotation. When an AnnotationIntent is mandatory, DotPdf classes will enforce them and ensure they are correct. When it is optional, it is typically left out.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationIntent
Public Enumeration AnnotationIntent
Members
Member name | Description
None | No Intent
FreeTextCallout | A Free Text annotation acting as a call-out
FreeTextTypeWriter | A Free Text annotation that lets a user type directly on the page.
LineArrow | A pointing line
LineDimension | A line for measurement
PolygonCloud | A cloud-appearance polygon
Text | Text
Link | A hyperlink
FreeText | Plain text on the page
Line | A simple line
Square | A square
Circle | A circle
Polygon | A polygon
PolyLine | An unfilled, typically open polygon
Highlight | A text highlight
Underline | Text underline
Squiggly | Text squiggly line
StrikeOut | Text strike-out
Stamp | A rubber stamp
Caret | A text insertion point
Ink | Free hand marks
Popup | Pop-up extra information
FileAttachment | An attached file
Sound | A sound
Movie | A movie
Widget | A form field
Screen | A display area for movies
PrinterMark | Marks for print production
TrapNet | Indications for print trapping
Watermark | A page watermark
PolyLineDimension | A connected set of segments for measurement
PolygonDimension | A filled polygon for measurement
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationPropertyProblem(T) Class

AnnotationPropertyProblemT Class

Defines a problem that could occur with the a BaseAnnotation property value.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationBaseProblem
Atalasoft.Shared.ValidationProblem T, PageRepairContext
Atalasoft.PdfDoc.Generating.AnnotationsAnnotationPropertyProblemT

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationPropertyProblem<T> : Problem<T, PageRepairContext>
where T : BaseAnnotation

Public Class AnnotationPropertyProblem(Of T As BaseAnnotation)
    Inherits Problem(Of T, PageRepairContext)

Type Parameters

T

The AnnotationPropertyProblemT type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationPropertyProblemT | Initializes a new instance of the AnnotationPropertyProblemT class.
Top
Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs. (Inherited from BaseProblem.)
Public property | Description | Gets or sets the description of the problem. (Inherited from BaseProblem.)
Public property | Name | Gets the name of the problem. (Inherited from BaseProblem.)
Public property | Source | Gets the source of the problem. (Inherited from ProblemT, U.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs this problem. (Inherited from ProblemT, U.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationPropertyProblem(T) Constructor

AnnotationPropertyProblemT Constructor

Initializes a new instance of the AnnotationPropertyProblemT class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationPropertyProblem(
    T source,
    string propertyName,
    string description,
    PdfRepairConsequences consequences,
    PageRepairContext repairContext,
    ProblemT, UReparationMechanism reparation
)
Public Sub New (
    source As T,
    propertyName As String,
    description As String,
    consequences As PdfRepairConsequences,
    repairContext As PageRepairContext,
    reparation As ProblemT, UReparationMechanism
)

Parameters

source
Type: T
The source annotation.
propertyName
Type: SystemString
Name of the property.
description
Type: SystemString
The description of the problem.
consequences
Type: Atalasoft.PdfDoc.Generating.ValidationPdfRepairConsequences
The description of the consequences of fixing the problem.
repairContext
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
reparation
Type: Atalasoft.Shared.ValidationProblemT, UReparationMechanism
The reparation action to take.
See Also

Reference

AnnotationPropertyProblemT Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationPropertyProblem(T) Properties

AnnotationPropertyProblemT Properties

The AnnotationPropertyProblemT generic type exposes the following members.

Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs. (Inherited from BaseProblem.)
Public property | Description | Gets or sets the description of the problem. (Inherited from BaseProblem.)
Public property | Name | Gets the name of the problem. (Inherited from BaseProblem.)
Public property | Source | Gets the source of the problem. (Inherited from ProblemT, U.)
Top
See Also

Reference

AnnotationPropertyProblemT Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationPropertyProblem(T) Methods

AnnotationPropertyProblemT Methods

The AnnotationPropertyProblemT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs this problem. (Inherited from ProblemT, U.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationPropertyProblemT Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AnnotationTextAlignment Enumeration

Determines alignment of text drawn in certain types of annotations.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AnnotationTextAlignment
Public Enumeration AnnotationTextAlignment
Members
Member name | Description
Left | Text will be aligned along the left edge.
Center | Text will be center-aligned.
Right | Text will be aligned along the right edge.
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet Class

Pdf annotations support appearances that can be associated with three interaction modes NormalHow the annotation will appear under typical circumstances (ie, no interaction)RolloverHow the annotation will appear when the cursor is in the annotationActivatedHow the annotation will appear when click on Each of this modes is associated with a collection of appearances, each of which corresponds to an annotation's current state. For example, a CheckboxWidgetAnnotation defines states for when it has been checked and when it is clear. The Normal property would contain appearances for each of these states. When an annotation only has one state, the name of that state is inconsequetial and will be ignored when written to the PDF file. For naming purposes, if an annotation has only a single state with no meaningful name, you can use DefaultAppearanceName for the name.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsAppearanceSet

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AppearanceSet : IPdfResourceConsumer
Public Class AppearanceSet
    Implements IPdfResourceConsumer

The AppearanceSet type exposes the following members.

Constructors
 | Name | Description
Public method | AppearanceSet | Initializes a new instance of the AppearanceSet class. Normal, Rollover, and Activated are initialed to empty AppearanceStates
Top
Properties
 | Name | Description
Public property | Activated | Gets the Activated AppearanceStates.
Public property | Normal | Gets the normal AppearanceStates.
Public property | Rollover | Gets the rollover AppearanceStates.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies the object that the resource was renamed.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultAppearanceName | A string to use for AppearanceStates objects with a single state.
Top
Examples
The following example makes an annotation with a star appearance.
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = doc.AddPage(PdfDefaultPages.Letter);
RectangleAnnotation anno = new RectangleAnnotation(new PdfBounds(72, 400, 200, 200));
DrawingTemplate template = new DrawingTemplate(new PdfBounds(0, 0, anno.Bounds.Width, anno.Bounds.Height));
PdfPath path = new PdfPath(PdfColorFactory.FromRgb(.8, .25, .25));
path.FillMethod = PdfFillMethod.NonZeroWinding;
path.MoveTo(100, 200);
path.LineTo(175, 0);
path.LineTo(0, 150);
path.LineTo(200, 150);
path.LineTo(25, 0);
path.Close();
template.DrawingList.Add(path);
string resourceName = doc.Resources.Templates.Add(template);
anno.Appearance = new AppearanceSet();
anno.Appearance.Normal.Add(AppearanceSet.DefaultAppearanceName, resourceName);
page.Annotations.Add(anno);
doc.Save("staranno.pdf");
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet Constructor

Initializes a new instance of the AppearanceSet class. Normal, Rollover, and Activated are initialed to empty AppearanceStates

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AppearanceSet()
Public Sub New
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet Properties

The AppearanceSet type exposes the following members.

Properties
 | Name | Description
Public property | Activated | Gets the Activated AppearanceStates.
Public property | Normal | Gets the normal AppearanceStates.
Public property | Rollover | Gets the rollover AppearanceStates.
Top
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet.Activated Property

AppearanceSetActivated Property

Gets the Activated AppearanceStates.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AppearanceStates Activated { get; }
Public ReadOnly Property Activated As AppearanceStates
    Get

Property Value

Type: AppearanceStates
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet.Normal Property

AppearanceSetNormal Property

Gets the normal AppearanceStates.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AppearanceStates Normal { get; }
Public ReadOnly Property Normal As AppearanceStates
    Get

Property Value

Type: AppearanceStates
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet.Rollover Property

AppearanceSetRollover Property

Gets the rollover AppearanceStates.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AppearanceStates Rollover { get; }
Public ReadOnly Property Rollover As AppearanceStates
    Get

Property Value

Type: AppearanceStates
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet Methods

The AppearanceSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies the object that the resource was renamed.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet.NotifyResourceRenamed Method

AppearanceSetNotifyResourceRenamed Method

Notifies the object that the resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources that contain the resource.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name to be used.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet.ResourcesUsed Method

AppearanceSetResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet Fields

The AppearanceSet type exposes the following members.

Fields
Name | Description
DefaultAppearanceName | A string to use for AppearanceStates objects with a single state.
Top
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceSet.DefaultAppearanceName Field

AppearanceSetDefaultAppearanceName Field

A string to use for AppearanceStates objects with a single state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const string DefaultAppearanceName = "AtalasoftDefaultAppearanceName"
Public Const DefaultAppearanceName As String = "AtalasoftDefaultAppearanceName"

Field Value

Type: String
See Also

Reference

AppearanceSet Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceStates Class

AppearanceStates represents a collection of names of PdfTemplateResource objects that are keyed by a state name. For most annotations there is only one state that has no particular state name. For this situation, you can use DefaultAppearanceName for the single state name.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionaryString, String
Atalasoft.PdfDoc.Generating.AnnotationsAppearanceStates

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AppearanceStates : Dictionary<string, string>,
    IPdfResourceConsumer
Public Class AppearanceStates
    Inherits Dictionary(Of String, String)
    Implements IPdfResourceConsumer

The AppearanceStates type exposes the following members.

Constructors
 | Name | Description
Public method | AppearanceStates | Initializes a new instance of the AppearanceStates class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from DictionaryString, String.)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from DictionaryString, String.)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from DictionaryString, String.)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from DictionaryString, String.)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from DictionaryString, String.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from DictionaryString, String.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies the object that the resource was renamed.
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from DictionaryString, String.)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from DictionaryString, String.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceStates Constructor

Initializes a new instance of the AppearanceStates class

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AppearanceStates()
Public Sub New
See Also

Reference

AppearanceStates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceStates Properties

The AppearanceStates type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from DictionaryString, String.)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from DictionaryString, String.)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Top
See Also

Reference

AppearanceStates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceStates Methods

The AppearanceStates type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from DictionaryString, String.)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from DictionaryString, String.)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from DictionaryString, String.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from DictionaryString, String.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies the object that the resource was renamed.
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from DictionaryString, String.)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from DictionaryString, String.)
Top
See Also

Reference

AppearanceStates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceStates.NotifyResourceRenamed Method

AppearanceStatesNotifyResourceRenamed Method

Notifies the object that the resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources that contain the resource.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name to be used.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

AppearanceStates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


AppearanceStates.ResourcesUsed Method

AppearanceStatesResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

AppearanceStates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation Class

Represents a base class for all PDF annotation types.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
More...

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseAnnotation : IValidatable,
    IPdfResourceConsumer
Public MustInherit Class BaseAnnotation
    Implements IValidatable, IPdfResourceConsumer

The BaseAnnotation type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseAnnotation | Initializes a new instance of the BaseAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations.
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set).
Public property | Border | Gets or sets the AnnotationBorder for this annotation.
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation.
Public property | Bounds | Gets or sets the bounding rectangle for this annotation.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked.
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation.
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered.
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState].
Public property | DocumentRevision | Gets the revision of the document in which this widget was found.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false.
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property.
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true.
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable.
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it.
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation.
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false.
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false.
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false.
Public property | ParentPage | Gets or sets the parent page that contains this annotation.
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false.
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems.
Protected method | ValidateActionList | Validates the action list.
Protected method | ValidateActions | Validates the actions.
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsLinkAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsOpaqueAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPopupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsSoundAnnotation


BaseAnnotation Constructor

Initializes a new instance of the BaseAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseAnnotation()
Protected Sub New
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation Properties

The BaseAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations.
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set).
Public property | Border | Gets or sets the AnnotationBorder for this annotation.
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation.
Public property | Bounds | Gets or sets the bounding rectangle for this annotation.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked.
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation.
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered.
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState].
Public property | DocumentRevision | Gets the revision of the document in which this widget was found.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false.
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property.
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true.
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable.
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it.
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation.
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false.
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false.
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false.
Public property | ParentPage | Gets or sets the parent page that contains this annotation.
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false.
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it.
Top
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.AdditionalActions Property

BaseAnnotationAdditionalActions Property

Gets the additional actions associated with the annotation. These are generally only used by widget annotations.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationAdditionalActions AdditionalActions { get; }
Public ReadOnly Property AdditionalActions As AnnotationAdditionalActions
    Get

Property Value

Type: AnnotationAdditionalActions
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.AnnotationType Property

BaseAnnotationAnnotationType Property

Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AnnotationType { get; }
Public ReadOnly Property AnnotationType As String
    Get

Property Value

Type: String
The type of the annotation, empty string if none.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Appearance Property

BaseAnnotationAppearance Property

Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set).

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AppearanceSet Appearance { get; set; }
Public Property Appearance As AppearanceSet
    Get
    Set

Property Value

Type: AppearanceSet
The appearance set to use for the annotation.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Border Property

BaseAnnotationBorder Property

Gets or sets the AnnotationBorder for this annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationBorder Border { get; set; }
Public Property Border As AnnotationBorder
    Get
    Set

Property Value

Type: AnnotationBorder
The border to use.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.BorderStyle Property

BaseAnnotationBorderStyle Property

Gets or sets the BorderStyle for the annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderStyle BorderStyle { get; set; }
Public Property BorderStyle As BorderStyle
    Get
    Set

Property Value

Type: BorderStyle
The border style.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Bounds Property

BaseAnnotationBounds Property

Gets or sets the bounding rectangle for this annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds of the annotation.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ClickActions Property

BaseAnnotationClickActions Property

Gets the set of actions performed when the annotation has been clicked.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfActionList ClickActions { get; }
Public ReadOnly Property ClickActions As PdfActionList
    Get

Property Value

Type: PdfActionList
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Color Property

BaseAnnotationColor Property

Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual IPdfColor Color { get; set; }
Public Overridable Property Color As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Contents Property

BaseAnnotationContents Property

Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string Contents { get; set; }
Public Overridable Property Contents As String
    Get
    Set

Property Value

Type: String
The text contents.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.DefaultAppearanceState Property

BaseAnnotationDefaultAppearanceState Property

Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState].

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultAppearanceState { get; set; }
Public Property DefaultAppearanceState As String
    Get
    Set

Property Value

Type: String
The default state of the appearance.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.DocumentRevision Property

BaseAnnotationDocumentRevision Property

Gets the revision of the document in which this widget was found.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DocumentRevision { get; }
Public ReadOnly Property DocumentRevision As Integer
    Get

Property Value

Type: Int32
The revision of the document in which this widget was found.
Remarks
A widget may be placed in any revision that is allowed by the document and it may be replaced in any subsequent revision. Typically this is used to identify which annotations should have been marked read only when a document is signed.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.EnforceReadyOnlyWithException Property

BaseAnnotationEnforceReadyOnlyWithException Property

Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnforceReadyOnlyWithException { get; set; }
Public Property EnforceReadyOnlyWithException As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ReadOnly will be enforced with an exception; otherwise, false.
Remarks
When set to true, if ReadOnly or IsFieldReadOnlyis set to true, this will cause any property that is modified to throw an InvalidOperationException. This has true as a default value. It is not recommended to change this property.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Hidden Property

BaseAnnotationHidden Property

Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set

Property Value

Type: Boolean
true if hidden; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Invisible Property

BaseAnnotationInvisible Property

Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Invisible { get; set; }
Public Property Invisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if invisible; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.IsDirty Property

BaseAnnotationIsDirty Property

Gets or sets a value indicating whether the annotation is dirty and in need of being written.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDirty { get; set; }
Public Property IsDirty As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the annotation is dirty; otherwise, false.
Remarks
This property is, at present, used only by the PdfDocumentSigner object in order to track annotations and fields that have been changed in order to update them in the output. This property is automatically set in the act of setting any property in the annotation, however, it is not set when changing the contents of a property.
Copy
someAnnotation.AppearanceSet = GenerateNewAppearanceSet(); // someAnnotation.IsDirty is now true
someAnnotation.IsDirty = false;
someAnnotation.AppearanceSet.Normal.Add("SomeName", "SomeTemplate"); // someAnnotation.IsDirty is still false
Therefore, an application that intends to modify annotations should, as a matter of course, mark them dirty so that they will be updated in the output.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.IsParentRequired Property

BaseAnnotationIsParentRequired Property

Gets a value indicating whether this instance requires the parent property.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool IsParentRequired { get; }
Protected Overridable ReadOnly Property IsParentRequired As Boolean
    Get

Property Value

Type: Boolean
true if this instance requires the parent property; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.IsReadOnlyOrFieldReadOnly Property

BaseAnnotationIsReadOnlyOrFieldReadOnly Property

Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnlyOrFieldReadOnly { get; }
Public ReadOnly Property IsReadOnlyOrFieldReadOnly As Boolean
    Get

Return Value

Type: Boolean
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.IsTransparent Property

BaseAnnotationIsTransparent Property

Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsTransparent { get; set; }
Public Property IsTransparent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is transparent; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Locked Property

BaseAnnotationLocked Property

Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Locked { get; set; }
Public Property Locked As Boolean
    Get
    Set

Property Value

Type: Boolean
true if locked; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ModificationDate Property

BaseAnnotationModificationDate Property

Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual DateTime ModificationDate { get; set; }
Public Overridable Property ModificationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
The modification date.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Name Property

BaseAnnotationName Property

Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the annotation.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.NoRotate Property

BaseAnnotationNoRotate Property

Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool NoRotate { get; set; }
Public Property NoRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
true if will not rotate; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.NoView Property

BaseAnnotationNoView Property

Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool NoView { get; set; }
Public Property NoView As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the annotation is not viewable; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.NoZoom Property

BaseAnnotationNoZoom Property

Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool NoZoom { get; set; }
Public Property NoZoom As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the annotation will not zoom; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ParentPage Property

BaseAnnotationParentPage Property

Gets or sets the parent page that contains this annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedPage ParentPage { get; set; }
Public Property ParentPage As PdfGeneratedPage
    Get
    Set

Property Value

Type: PdfGeneratedPage
The parent page.
Remarks
This property is only required for ScreenAnnotations, but can be set by any annotation.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Print Property

BaseAnnotationPrint Property

Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Print { get; set; }
Public Property Print As Boolean
    Get
    Set

Property Value

Type: Boolean
true if print; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ReadOnly Property

BaseAnnotationReadOnly Property

Gets or sets a value indicating whether the annotation can interact with the user. Default is false.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the annotation is unusable; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ToggleNoView Property

BaseAnnotationToggleNoView Property

Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ToggleNoView { get; set; }
Public Property ToggleNoView As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NoView will be toggled; otherwise, false.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation Methods

The BaseAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems.
Protected method | ValidateActionList | Validates the action list.
Protected method | ValidateActions | Validates the actions.
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list.
Top
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.HasAppearance Method

BaseAnnotationHasAppearance Method

Determines whether this instance has at least 1 element in the Normal appearance set.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasAppearance()
Public Function HasAppearance As Boolean

Return Value

Type: Boolean
true if there is at least 1 appearance; false otherwise.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.MakeRepairContext Method

BaseAnnotationMakeRepairContext Method

Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
Remarks
Expected o to be a PdfGeneratedPage.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.NotifyResourceRenamed Method

BaseAnnotationNotifyResourceRenamed Method

This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ResourcesUsed Method

BaseAnnotationResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ThrowIfReadOnly(T) Method

BaseAnnotationThrowIfReadOnlyT Method

If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected T ThrowIfReadOnly<T>(
    T value
)

Protected Function ThrowIfReadOnly(Of T) (
    value As T
) As T

Parameters

value
Type: T
The value

Type Parameters

T
The value type

Return Value

Type: T
Exceptions
Exception | Condition
InvalidOperationException | Attempt to modify a read-only annotation.
Remarks
This is a helper method used in public properties to prevent modification to annotation contents.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.Validate Method

BaseAnnotationValidate Method

Validates the annotation and accumulates any problems.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ValidateActionList Method

BaseAnnotationValidateActionList Method

Validates the action list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ValidateActionList(
    ProblemList problems,
    PageRepairContext context,
    PdfActionList actions
)
Protected Sub ValidateActionList (
    problems As ProblemList,
    context As PageRepairContext,
    actions As PdfActionList
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context.
actions
Type: Atalasoft.PdfDocPdfActionList
The actions.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ValidateActions Method

BaseAnnotationValidateActions Method

Validates the actions.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ValidateActions(
    ProblemList problems,
    PageRepairContext context
)
Protected Overridable Sub ValidateActions (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseAnnotation.ValidateProperties Method

BaseAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overridable Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

BaseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseButtonWidgetAnnotation Class

This class is a base class for all button widgets, including PushButtonWidgetAnnotation, CheckboxWidgetAnnotation, and RadioButtonWidgetAnnotation. It cannot be constructed directly.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseButtonWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsCheckboxWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPushButtonWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRadioButtonWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseButtonWidgetAnnotation : BaseWidgetAnnotation
Public MustInherit Class BaseButtonWidgetAnnotation
    Inherits BaseWidgetAnnotation

The BaseButtonWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseButtonWidgetAnnotation | Initializes a new instance of the BaseButtonWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button.
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. (Inherited from BaseWidgetAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string. (Inherited from BaseWidgetAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. (Inherited from BaseWidgetAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseWidgetAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseButtonWidgetAnnotation Constructor

Initializes a new instance of the BaseButtonWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseButtonWidgetAnnotation()
Protected Sub New
See Also

Reference

BaseButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseButtonWidgetAnnotation Properties

The BaseButtonWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button.
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. (Inherited from BaseWidgetAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string. (Inherited from BaseWidgetAnnotation.)
Top
See Also

Reference

BaseButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseButtonWidgetAnnotation.Caption Property

BaseButtonWidgetAnnotationCaption Property

Gets or sets the text displayed on the button.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String
See Also

Reference

BaseButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseButtonWidgetAnnotation Methods

The BaseButtonWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. (Inherited from BaseWidgetAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseWidgetAnnotation.)
Top
See Also

Reference

BaseButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation Class

BaseMarkupAnnotation is an abstract class that represents the common features of PDF annotations that are used for document mark-up.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
More...

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseMarkupAnnotation : BaseAnnotation
Public MustInherit Class BaseMarkupAnnotation
    Inherits BaseAnnotation

The BaseMarkupAnnotation type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseMarkupAnnotation | Initializes a new instance of the BaseMarkupAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file.
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to.
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation.
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsCaretAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsInkAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsLineAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPolygonAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRectangleAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRedactionProposalAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRubberStampAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsStickyNoteAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextBoxAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextMarkupAnnotation


BaseMarkupAnnotation Constructor

Initializes a new instance of the BaseMarkupAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseMarkupAnnotation()
Protected Sub New
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation Properties

The BaseMarkupAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file.
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to.
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation.
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0.
Top
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.AuthorName Property

BaseMarkupAnnotationAuthorName Property

Gets or sets the name of the author of the annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string AuthorName { get; set; }
Public Overridable Property AuthorName As String
    Get
    Set

Property Value

Type: String
The name of the author.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.CreationDate Property

BaseMarkupAnnotationCreationDate Property

Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DateTime CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.InReplyTo Property

BaseMarkupAnnotationInReplyTo Property

Gets or sets the BaseAnnotation that this annotation is in reply to.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BaseAnnotation InReplyTo { get; set; }
Public Property InReplyTo As BaseAnnotation
    Get
    Set

Property Value

Type: BaseAnnotation
The annotation to which this annotation is in reply to.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.InReplyToRelation Property

BaseMarkupAnnotationInReplyToRelation Property

Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReplyRelation InReplyToRelation { get; set; }
Public Property InReplyToRelation As ReplyRelation
    Get
    Set

Property Value

Type: ReplyRelation
The relationship of this annotation to its InReplyTo.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.Intent Property

BaseMarkupAnnotationIntent Property

Gets or sets the intent of the annotation. Set automatically where required.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationIntent Intent { get; protected set; }
Public Property Intent As AnnotationIntent
    Get
    Protected Set

Property Value

Type: AnnotationIntent
The intent of the annotation.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.Popup Property

BaseMarkupAnnotationPopup Property

Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PopupAnnotation Popup { get; set; }
Public Property Popup As PopupAnnotation
    Get
    Set

Property Value

Type: PopupAnnotation
The popup annotation.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.RichTextContent Property

BaseMarkupAnnotationRichTextContent Property

The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlDocument RichTextContent { get; set; }
Public Property RichTextContent As XmlDocument
    Get
    Set

Property Value

Type: XmlDocument
The content of the rich text.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.Transparency Property

BaseMarkupAnnotationTransparency Property

Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Transparency { get; set; }
Public Property Transparency As Double
    Get
    Set

Property Value

Type: Double
The transparency.
Remarks
If an annotation has a custom appearance stream, this value will have no affect in a compliant viewer.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation Methods

The BaseMarkupAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.GetRichTextContent Method

BaseMarkupAnnotationGetRichTextContent Method

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual XmlDocument GetRichTextContent(
    GlobalResources resources
)
Protected Overridable Function GetRichTextContent (
    resources As GlobalResources
) As XmlDocument

Parameters

resources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources

Return Value

Type: XmlDocument
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseMarkupAnnotation.ValidateProperties Method

BaseMarkupAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

BaseMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation Class

BaseWidgetAnnotation is the abstract base class of all widget annotations. All widgets serve both as annotations and as form elements, therefore BaseWidgetAnnotation also implements the IFormElement interface allowing it to act as a child field of any non-widget annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseButtonWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsSignatureWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseWidgetAnnotation : BaseAnnotation,
    IFormElement
Public MustInherit Class BaseWidgetAnnotation
    Inherits BaseAnnotation
    Implements IFormElement

The BaseWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseWidgetAnnotation | Initializes a new instance of the BaseWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border.
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance.
Public property | DefaultValueAsString | Gets the default value as string.
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export.
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only.
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation Constructor

Initializes a new instance of the BaseWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseWidgetAnnotation()
Protected Sub New
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation Properties

The BaseWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border.
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance.
Public property | DefaultValueAsString | Gets the default value as string.
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export.
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only.
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string.
Top
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.BackgroundColor Property

BaseWidgetAnnotationBackgroundColor Property

Gets or sets the color of the background.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor BackgroundColor { get; set; }
Public Property BackgroundColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the background.
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.BorderColor Property

BaseWidgetAnnotationBorderColor Property

Gets or sets the color of the border.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor BorderColor { get; set; }
Public Property BorderColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the border.
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.ChildFields Property

BaseWidgetAnnotationChildFields Property

Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<IFormElement> ChildFields { get; }
Public ReadOnly Property ChildFields As IList(Of IFormElement)
    Get

Property Value

Type: IListIFormElement

Implements

IFormElementChildFields
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.DefaultTextAppearance Property

BaseWidgetAnnotationDefaultTextAppearance Property

Gets or sets the default text appearance.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance DefaultTextAppearance { get; set; }
Public Property DefaultTextAppearance As PdfTextAppearance
    Get
    Set

Property Value

Type: PdfTextAppearance
The default text appearance.
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.DefaultValueAsString Property

BaseWidgetAnnotationDefaultValueAsString Property

Gets the default value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract string DefaultValueAsString { get; }
Public MustOverride ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.FieldAlternateDescription Property

BaseWidgetAnnotationFieldAlternateDescription Property

Gets or sets the field alternate description for display in the UI.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldAlternateDescription { get; set; }
Public Property FieldAlternateDescription As String
    Get
    Set

Property Value

Type: String
The field alternate description.

Implements

IFormElementFieldAlternateDescription
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.FieldFullName Property

BaseWidgetAnnotationFieldFullName Property

Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldFullName { get; }
Public ReadOnly Property FieldFullName As String
    Get

Property Value

Type: String
The full name of the field.

Implements

IFormElementFieldFullName
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.FieldName Property

BaseWidgetAnnotationFieldName Property

Gets or sets the name of the field.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set

Property Value

Type: String
The name of the field.

Implements

IFormElementFieldName
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.FieldNameForExport Property

BaseWidgetAnnotationFieldNameForExport Property

Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldNameForExport { get; set; }
Public Property FieldNameForExport As String
    Get
    Set

Property Value

Type: String
The field name for export.

Implements

IFormElementFieldNameForExport
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.HighlightAppearance Property

BaseWidgetAnnotationHighlightAppearance Property

Gets or sets the highlight appearance.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WidgetHighlightAppearance HighlightAppearance { get; set; }
Public Property HighlightAppearance As WidgetHighlightAppearance
    Get
    Set

Property Value

Type: WidgetHighlightAppearance
The highlight appearance.
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.IsFieldNoExport Property

BaseWidgetAnnotationIsFieldNoExport Property

Gets or sets a value indicating whether this field should not be export.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFieldNoExport { get; set; }
Public Property IsFieldNoExport As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this field should not exported; otherwise, false.

Implements

IFormElementIsFieldNoExport
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.IsFieldReadOnly Property

BaseWidgetAnnotationIsFieldReadOnly Property

Gets or sets a value indicating whether this field is read only.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFieldReadOnly { get; set; }
Public Property IsFieldReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance field is read only; otherwise, false.

Implements

IFormElementIsFieldReadOnly
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.IsFieldRequired Property

BaseWidgetAnnotationIsFieldRequired Property

Gets or sets a value indicating whether this field is required.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFieldRequired { get; set; }
Public Property IsFieldRequired As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance field is required; otherwise, false.

Implements

IFormElementIsFieldRequired
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.ParentField Property

BaseWidgetAnnotationParentField Property

Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFormElement ParentField { get; set; }
Public Property ParentField As IFormElement
    Get
    Set

Property Value

Type: IFormElement
The parent field.

Implements

IFormElementParentField
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.ValueAsString Property

BaseWidgetAnnotationValueAsString Property

Gets the value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract string ValueAsString { get; }
Public MustOverride ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation Methods

The BaseWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.IsValidChildOf Method

BaseWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool IsValidChildOf(
    IFormElement elem
)
Public MustOverride Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BaseWidgetAnnotation.ValidateProperties Method

BaseWidgetAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

BaseWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffect Class

The BorderEffect object represents a way to modify the basic appearance of some PDF annotations, including RectangleAnnotation, EllipseAnnotation, PolygonAnnotation and TextBoxAnnotation. Support for all but TextBoxAnnotation began with PDF 1.5. Support for TextBoxAnnotation began in PDF 1.6. BorderEffect consists of a BorderEffectKind and an intensity setting. Intensity only currently applies to Cloudy.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBorderEffect

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BorderEffect
Public Class BorderEffect

The BorderEffect type exposes the following members.

Constructors
 | Name | Description
Public method | BorderEffect | Initializes a new instance of the BorderEffect class. EffectKind will be set to None and Intensity will be set to 0.
Top
Properties
 | Name | Description
Public property | EffectKind | Gets or sets the kind of the effect.
Public property | Intensity | Gets or sets the intensity of the effect. This only currently affects Cloudy.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffect Constructor

Initializes a new instance of the BorderEffect class. EffectKind will be set to None and Intensity will be set to 0.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderEffect()
Public Sub New
See Also

Reference

BorderEffect Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffect Properties

The BorderEffect type exposes the following members.

Properties
 | Name | Description
Public property | EffectKind | Gets or sets the kind of the effect.
Public property | Intensity | Gets or sets the intensity of the effect. This only currently affects Cloudy.
Top
See Also

Reference

BorderEffect Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffect.EffectKind Property

BorderEffectEffectKind Property

Gets or sets the kind of the effect.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderEffectKind EffectKind { get; set; }
Public Property EffectKind As BorderEffectKind
    Get
    Set

Property Value

Type: BorderEffectKind
The kind of the effect.
See Also

Reference

BorderEffect Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffect.Intensity Property

BorderEffectIntensity Property

Gets or sets the intensity of the effect. This only currently affects Cloudy.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Intensity { get; set; }
Public Property Intensity As Double
    Get
    Set

Property Value

Type: Double
The intensity of the effect.
See Also

Reference

BorderEffect Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffect Methods

The BorderEffect type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BorderEffect Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderEffectKind Enumeration

Some annotations can be shown with a "cloudy" effect on the border. This enumeration is used for specifying it.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BorderEffectKind
Public Enumeration BorderEffectKind
Members
Member name | Description
None | No effect
Cloudy | Cloudy effect
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle Class

The BorderStyle object represents a border than may surround an annotation including border width, style and dash pattern.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBorderStyle

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BorderStyle : IValidatable
Public Class BorderStyle
    Implements IValidatable

The BorderStyle type exposes the following members.

Constructors
 | Name | Description
Public method | BorderStyle | Initializes a new instance of the BorderStyle class with StyleKind set to Solid and DashPattern set to DefaultDashPattern.
Top
Properties
 | Name | Description
Public property | DashPattern | Gets or sets the dash pattern for the border.
 | DefaultDashPattern | Gets the default dash pattern for PDF border styles.
 | EmptyDashPattern | Gets an empty dash pattern which represents a solid line.
Public property | StyleKind | Gets or sets the style of the border.
Public property | Width | Gets or sets the width of the border - default is 0, value is specified to be non-negative.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the BorderStyle accumulating any problems.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle Constructor

Initializes a new instance of the BorderStyle class with StyleKind set to Solid and DashPattern set to DefaultDashPattern.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderStyle()
Public Sub New
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle Properties

The BorderStyle type exposes the following members.

Properties
 | Name | Description
Public property | DashPattern | Gets or sets the dash pattern for the border.
 | DefaultDashPattern | Gets the default dash pattern for PDF border styles.
 | EmptyDashPattern | Gets an empty dash pattern which represents a solid line.
Public property | StyleKind | Gets or sets the style of the border.
Public property | Width | Gets or sets the width of the border - default is 0, value is specified to be non-negative.
Top
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.DashPattern Property

BorderStyleDashPattern Property

Gets or sets the dash pattern for the border.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<double> DashPattern { get; set; }
Public Property DashPattern As IEnumerable(Of Double)
    Get
    Set

Property Value

Type: IEnumerableDouble
The dash pattern.
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.DefaultDashPattern Property

BorderStyleDefaultDashPattern Property

Gets the default dash pattern for PDF border styles.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<double> DefaultDashPattern { get; }
Public Shared ReadOnly Property DefaultDashPattern As IEnumerable(Of Double)
    Get

Property Value

Type: IEnumerableDouble
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.EmptyDashPattern Property

BorderStyleEmptyDashPattern Property

Gets an empty dash pattern which represents a solid line.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<double> EmptyDashPattern { get; }
Public Shared ReadOnly Property EmptyDashPattern As IEnumerable(Of Double)
    Get

Property Value

Type: IEnumerableDouble
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.StyleKind Property

BorderStyleStyleKind Property

Gets or sets the style of the border.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderStyleKind StyleKind { get; set; }
Public Property StyleKind As BorderStyleKind
    Get
    Set

Property Value

Type: BorderStyleKind
The style of the border.
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.Width Property

BorderStyleWidth Property

Gets or sets the width of the border - default is 0, value is specified to be non-negative.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set

Property Value

Type: Double
The width of the border.
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle Methods

The BorderStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the BorderStyle accumulating any problems.
Top
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.MakeRepairContext Method

BorderStyleMakeRepairContext Method

Makes the repair context for repairing problems in this object.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyle.Validate Method

BorderStyleValidate Method

Validates the BorderStyle accumulating any problems.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

BorderStyle Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


BorderStyleKind Enumeration

BorderStyleKind is used to specify how the borders of simple annotations should appear on the page. None is default.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BorderStyleKind
Public Enumeration BorderStyleKind
Members
Member name | Description
None | No additional effect
Solid | A solid line - default
Dashed | A dashed line determined by an associated dash array
Beveled | A simulated embossed border
Inset | A simulated engraved border
Underline | A single underline
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Class

The CalloutAnnotation is a type of TextBoxAnnotation which represents a text annotation with a line pointing from the annotation to a particular point on the page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextBoxAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsCalloutAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CalloutAnnotation : TextBoxAnnotation
Public Class CalloutAnnotation
    Inherits TextBoxAnnotation

The CalloutAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | CalloutAnnotation | Initializes a new instance of the CalloutAnnotation class.
Public method | CalloutAnnotation(PdfBounds) | Initializes a new instance of the CalloutAnnotation class using the bounds provided. In order for the annotation to be complete it needs to be set to point at a particular location. This can be done by setting the Line property. To make it easier to build the callout Line property, you can use the utility method PointAt(PdfPoint).
Public method | CalloutAnnotation(PdfBounds, String) | Initializes a new instance of the CalloutAnnotation class using the bounds and text provided. In order for the annotation to be complete it needs to be set to point at a particular location. This can be done by setting the Line property. To make it easier to build the callout Line property, you can use the utility method PointAt(PdfPoint).
Public method | CalloutAnnotation(PdfBounds, String, PdfPoint) | Initializes a new instance of the CalloutAnnotation class with the text provided, pointing at the supplied point with an open arrow head.
Public method | CalloutAnnotation(PdfBounds, String, PdfPoint, LineEndingKind) | Initializes a new instance of the CalloutAnnotation class with the text provided, pointing at the supplied point with the specified line ending kind.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property. (Inherited from TextBoxAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point. (Inherited from TextBoxAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the effect for the border of the annotation. (Inherited from TextBoxAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FontColor | Gets or sets the color of the font. (Inherited from TextBoxAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsetArea | Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property. (Inherited from TextBoxAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Line | Gets or sets the line for the CalloutAnnotation. There is no guidance in the PDF specification as how the line in the callout should be defined, including making lines that don't originate from the annotation. Be aware that while unusual representations may be rendered correctly, if they are moved a viewer is likely to change the location of at least the starting point.
Public property | LineEnding | Gets or sets the line ending for the callout.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from TextBoxAnnotation.)
Public property | TextStrikeout | Gets or sets a value indicating whether the text has a line drawn through it. (Inherited from TextBoxAnnotation.)
Public property | TextUnderline | Gets or sets a value indicating whether the text is underlined. (Inherited from TextBoxAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from TextBoxAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | PointAt | Builds a CalloutLine for this annotation which points at the given target. The CalloutLine object will be a TwoPointCalloutLine if the target is either inside the annoutation's Bounds or if it lines up with the midpoint of the nearest edge of the Bounds, otherwise it will be a ThreePointCalloutLine.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of the class. (Overrides TextBoxAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Constructor

Overload List
 | Name | Description
Public method | CalloutAnnotation | Initializes a new instance of the CalloutAnnotation class.
Public method | CalloutAnnotation(PdfBounds) | Initializes a new instance of the CalloutAnnotation class using the bounds provided. In order for the annotation to be complete it needs to be set to point at a particular location. This can be done by setting the Line property. To make it easier to build the callout Line property, you can use the utility method PointAt(PdfPoint).
Public method | CalloutAnnotation(PdfBounds, String) | Initializes a new instance of the CalloutAnnotation class using the bounds and text provided. In order for the annotation to be complete it needs to be set to point at a particular location. This can be done by setting the Line property. To make it easier to build the callout Line property, you can use the utility method PointAt(PdfPoint).
Public method | CalloutAnnotation(PdfBounds, String, PdfPoint) | Initializes a new instance of the CalloutAnnotation class with the text provided, pointing at the supplied point with an open arrow head.
Public method | CalloutAnnotation(PdfBounds, String, PdfPoint, LineEndingKind) | Initializes a new instance of the CalloutAnnotation class with the text provided, pointing at the supplied point with the specified line ending kind.
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Constructor

Initializes a new instance of the CalloutAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation()
Public Sub New
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Constructor (PdfBounds)

Initializes a new instance of the CalloutAnnotation class using the bounds provided. In order for the annotation to be complete it needs to be set to point at a particular location. This can be done by setting the Line property. To make it easier to build the callout Line property, you can use the utility method PointAt(PdfPoint).

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Constructor (PdfBounds, String)

Initializes a new instance of the CalloutAnnotation class using the bounds and text provided. In order for the annotation to be complete it needs to be set to point at a particular location. This can be done by setting the Line property. To make it easier to build the callout Line property, you can use the utility method PointAt(PdfPoint).

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    PdfBounds bounds,
    string text
)
Public Sub New (
    bounds As PdfBounds,
    text As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
text
Type: SystemString
The text.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Constructor (PdfBounds, String, PdfPoint)

Initializes a new instance of the CalloutAnnotation class with the text provided, pointing at the supplied point with an open arrow head.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    PdfBounds bounds,
    string text,
    PdfPoint pointAt
)
Public Sub New (
    bounds As PdfBounds,
    text As String,
    pointAt As PdfPoint
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
text
Type: SystemString
The text.
pointAt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point at.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Constructor (PdfBounds, String, PdfPoint, LineEndingKind)

Initializes a new instance of the CalloutAnnotation class with the text provided, pointing at the supplied point with the specified line ending kind.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutAnnotation(
    PdfBounds bounds,
    string text,
    PdfPoint pointAt,
    LineEndingKind ending
)
Public Sub New (
    bounds As PdfBounds,
    text As String,
    pointAt As PdfPoint,
    ending As LineEndingKind
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
text
Type: SystemString
The text.
pointAt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to point at.
ending
Type: Atalasoft.PdfDoc.Generating.AnnotationsLineEndingKind
The ending style of the line.
See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Properties

The CalloutAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property. (Inherited from TextBoxAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point. (Inherited from TextBoxAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the effect for the border of the annotation. (Inherited from TextBoxAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FontColor | Gets or sets the color of the font. (Inherited from TextBoxAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsetArea | Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property. (Inherited from TextBoxAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Line | Gets or sets the line for the CalloutAnnotation. There is no guidance in the PDF specification as how the line in the callout should be defined, including making lines that don't originate from the annotation. Be aware that while unusual representations may be rendered correctly, if they are moved a viewer is likely to change the location of at least the starting point.
Public property | LineEnding | Gets or sets the line ending for the callout.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from TextBoxAnnotation.)
Public property | TextStrikeout | Gets or sets a value indicating whether the text has a line drawn through it. (Inherited from TextBoxAnnotation.)
Public property | TextUnderline | Gets or sets a value indicating whether the text is underlined. (Inherited from TextBoxAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation.Line Property

CalloutAnnotationLine Property

Gets or sets the line for the CalloutAnnotation. There is no guidance in the PDF specification as how the line in the callout should be defined, including making lines that don't originate from the annotation. Be aware that while unusual representations may be rendered correctly, if they are moved a viewer is likely to change the location of at least the starting point.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutLine Line { get; set; }
Public Property Line As CalloutLine
    Get
    Set

Property Value

Type: CalloutLine
The line that represents where the callout line starts from and points to.
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation.LineEnding Property

CalloutAnnotationLineEnding Property

Gets or sets the line ending for the callout.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineEndingKind LineEnding { get; set; }
Public Property LineEnding As LineEndingKind
    Get
    Set

Property Value

Type: LineEndingKind
The line ending.
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation Methods

The CalloutAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from TextBoxAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | PointAt | Builds a CalloutLine for this annotation which points at the given target. The CalloutLine object will be a TwoPointCalloutLine if the target is either inside the annoutation's Bounds or if it lines up with the midpoint of the nearest edge of the Bounds, otherwise it will be a ThreePointCalloutLine.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of the class. (Overrides TextBoxAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation.PointAt Method

CalloutAnnotationPointAt Method

Builds a CalloutLine for this annotation which points at the given target. The CalloutLine object will be a TwoPointCalloutLine if the target is either inside the annoutation's Bounds or if it lines up with the midpoint of the nearest edge of the Bounds, otherwise it will be a ThreePointCalloutLine.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CalloutLine PointAt(
    PdfPoint target
)
Public Function PointAt (
    target As PdfPoint
) As CalloutLine

Parameters

target
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The target to point to.

Return Value

Type: CalloutLine
A new CalloutLine
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutAnnotation.ValidateProperties Method

CalloutAnnotationValidateProperties Method

Validates the properties of the class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context.
See Also

Reference

CalloutAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutLine Class

A callout line is a line that runs from a CalloutAnnotation to another point on the page. CalloutLine is abstract with concrete implementations that represent a two-point line and a three-point line.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsCalloutLine
Atalasoft.PdfDoc.Generating.AnnotationsTwoPointCalloutLine

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class CalloutLine
Public MustInherit Class CalloutLine

The CalloutLine type exposes the following members.

Constructors
 | Name | Description
Protected method | CalloutLine | Initializes a new instance of the CalloutLine class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDoubleArray | Converts the points to a double array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutLine Constructor

Initializes a new instance of the CalloutLine class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected CalloutLine()
Protected Sub New
See Also

Reference

CalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutLine Methods

The CalloutLine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDoubleArray | Converts the points to a double array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CalloutLine.ToDoubleArray Method

CalloutLineToDoubleArray Method

Converts the points to a double array.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract double[] ToDoubleArray()
Public MustOverride Function ToDoubleArray As Double()

Return Value

Type: Double
An array representing the callout points
See Also

Reference

CalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaptionPositionKind Enumeration

Determines where to locate a caption on a line

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CaptionPositionKind
Public Enumeration CaptionPositionKind
Members
Member name | Description
Inline | In the middle of the line itself
Top | On top of the line
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation Class

A CaretAnnotation is a BaseMarkupAnnotation that represents an intended insertion point in a document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsCaretAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CaretAnnotation : BaseMarkupAnnotation
Public Class CaretAnnotation
    Inherits BaseMarkupAnnotation

The CaretAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | CaretAnnotation | Initializes a new instance of the CaretAnnotation class.
Public method | CaretAnnotation(PdfBounds) | Initializes a new instance of the CaretAnnotation class at the specified bounds.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | InsetArea | Gets or sets the inset area for the annotation. This PdfBounds should be either empty or completely contained within the Bounds of this annotation.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | Symbol | Gets or sets the symbol to use for the caret.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation Constructor

Overload List
 | Name | Description
Public method | CaretAnnotation | Initializes a new instance of the CaretAnnotation class.
Public method | CaretAnnotation(PdfBounds) | Initializes a new instance of the CaretAnnotation class at the specified bounds.
Top
See Also

Reference

CaretAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation Constructor

Initializes a new instance of the CaretAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CaretAnnotation()
Public Sub New
See Also

Reference

CaretAnnotation Class
CaretAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation Constructor (PdfBounds)

Initializes a new instance of the CaretAnnotation class at the specified bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CaretAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

CaretAnnotation Class
CaretAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation Properties

The CaretAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | InsetArea | Gets or sets the inset area for the annotation. This PdfBounds should be either empty or completely contained within the Bounds of this annotation.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | Symbol | Gets or sets the symbol to use for the caret.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

CaretAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation.InsetArea Property

CaretAnnotationInsetArea Property

Gets or sets the inset area for the annotation. This PdfBounds should be either empty or completely contained within the Bounds of this annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds InsetArea { get; set; }
Public Property InsetArea As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The inset area.
See Also

Reference

CaretAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation.Symbol Property

CaretAnnotationSymbol Property

Gets or sets the symbol to use for the caret.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CaretSymbol Symbol { get; set; }
Public Property Symbol As CaretSymbol
    Get
    Set

Property Value

Type: CaretSymbol
The symbol to use.
See Also

Reference

CaretAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation Methods

The CaretAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

CaretAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretAnnotation.ValidateProperties Method

CaretAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

CaretAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CaretSymbol Enumeration

The symbol to use for a insertion annotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CaretSymbol
Public Enumeration CaretSymbol
Members
Member name | Description
None | The default symbol
Paragraph | A new paragraph symbol (ie, ¶)
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Class

The CheckboxWidgetAnnotation is a button type widget that allows the user to select between one of two possible values. By convention, these values are "Yes" and "Off". Unlike most annotations, CheckBoxWidgetAnnotations needs to have a suite of DrawingTemplate resources associated with it. At a minimum, there needs to be a "Yes" and "Off" entries in the Normal appearance set.
Examples
This is how to set up a set of default appearances for a checkbox:
Copy
checkbox.Appearance.Normal.Add(CheckboxWidgetAnnotation.CheckedValue, "normalChecked");
checkbox.Appearance.Normal.Add(CheckboxWidgetAnnotation.ClearedValue, "normalCleared");
"normalChecked" and "normalCleared" are strings that should be the name of PdfTemplateResource objects in your document's resource collection.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseButtonWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsCheckboxWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CheckboxWidgetAnnotation : BaseButtonWidgetAnnotation
Public Class CheckboxWidgetAnnotation
    Inherits BaseButtonWidgetAnnotation

The CheckboxWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | CheckboxWidgetAnnotation | Initializes a new instance of the CheckboxWidgetAnnotation class.
Public method | CheckboxWidgetAnnotation(GlobalResources, PdfBounds, String, String, String) | Initializes a new instance of the CheckboxWidgetAnnotation class and will initialize the default appearances for Normal and Activated for the annotation using "standard" appearances. If the standard appearances have not been installed in the provided resource collection, they will be installed for you.
Public method | CheckboxWidgetAnnotation(GlobalResources, PdfBounds, String, String, String, Boolean) | Initializes a new instance of the CheckboxWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button. (Inherited from BaseButtonWidgetAnnotation.)
 | CheckedValue | Gets the standard checked value string.
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
 | ClearedValue | Gets the standard cleared value string.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValue | Gets or sets the default value of the checkbox. Use CheckedValue or ClearedValue to be compatible with convention.
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Value | Gets or sets the current value of the checkbox. Use CheckedValue or ClearedValue to be compatible with convention.
Public property | ValueAsString | Gets the value as string. (Overrides BaseWidgetAnnotationValueAsString.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a CheckboxFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Constructor

Overload List
 | Name | Description
Public method | CheckboxWidgetAnnotation | Initializes a new instance of the CheckboxWidgetAnnotation class.
Public method | CheckboxWidgetAnnotation(GlobalResources, PdfBounds, String, String, String) | Initializes a new instance of the CheckboxWidgetAnnotation class and will initialize the default appearances for Normal and Activated for the annotation using "standard" appearances. If the standard appearances have not been installed in the provided resource collection, they will be installed for you.
Public method | CheckboxWidgetAnnotation(GlobalResources, PdfBounds, String, String, String, Boolean) | Initializes a new instance of the CheckboxWidgetAnnotation class.
Top
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Constructor

Initializes a new instance of the CheckboxWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CheckboxWidgetAnnotation()
Public Sub New
See Also

Reference

CheckboxWidgetAnnotation Class
CheckboxWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Constructor (GlobalResources, PdfBounds, String, String, String)

Initializes a new instance of the CheckboxWidgetAnnotation class and will initialize the default appearances for Normal and Activated for the annotation using "standard" appearances. If the standard appearances have not been installed in the provided resource collection, they will be installed for you.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CheckboxWidgetAnnotation(
    GlobalResources gr,
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport
)
Public Sub New (
    gr As GlobalResources,
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection which will hold the standard appearances.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the check.
name
Type: SystemString
The name of the field.
nameForUI
Type: SystemString
The name of the field shown in a view user interface.
nameForExport
Type: SystemString
The name of the field used for data export.
See Also

Reference

CheckboxWidgetAnnotation Class
CheckboxWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Constructor (GlobalResources, PdfBounds, String, String, String, Boolean)

Initializes a new instance of the CheckboxWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CheckboxWidgetAnnotation(
    GlobalResources gr,
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport,
    bool useStandardAppearances
)
Public Sub New (
    gr As GlobalResources,
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String,
    useStandardAppearances As Boolean
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection which will hold the standard appearances.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the check.
name
Type: SystemString
The name of the field.
nameForUI
Type: SystemString
The name of the field shown in a view user interface.
nameForExport
Type: SystemString
The name of the field used for data export.
useStandardAppearances
Type: SystemBoolean
if set to true this check box with use standard appearances, installing them if needed.
See Also

Reference

CheckboxWidgetAnnotation Class
CheckboxWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Properties

The CheckboxWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button. (Inherited from BaseButtonWidgetAnnotation.)
 | CheckedValue | Gets the standard checked value string.
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
 | ClearedValue | Gets the standard cleared value string.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValue | Gets or sets the default value of the checkbox. Use CheckedValue or ClearedValue to be compatible with convention.
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Value | Gets or sets the current value of the checkbox. Use CheckedValue or ClearedValue to be compatible with convention.
Public property | ValueAsString | Gets the value as string. (Overrides BaseWidgetAnnotationValueAsString.)
Top
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.CheckedValue Property

CheckboxWidgetAnnotationCheckedValue Property

Gets the standard checked value string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckedValue { get; }
Public Shared ReadOnly Property CheckedValue As String
    Get

Property Value

Type: String
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.ClearedValue Property

CheckboxWidgetAnnotationClearedValue Property

Gets the standard cleared value string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string ClearedValue { get; }
Public Shared ReadOnly Property ClearedValue As String
    Get

Property Value

Type: String
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.DefaultValue Property

CheckboxWidgetAnnotationDefaultValue Property

Gets or sets the default value of the checkbox. Use CheckedValue or ClearedValue to be compatible with convention.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set

Property Value

Type: String
The default value of the checkbox.
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.DefaultValueAsString Property

CheckboxWidgetAnnotationDefaultValueAsString Property

Gets the default value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DefaultValueAsString { get; }
Public Overrides ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.Value Property

CheckboxWidgetAnnotationValue Property

Gets or sets the current value of the checkbox. Use CheckedValue or ClearedValue to be compatible with convention.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value of the checkbox.
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.ValueAsString Property

CheckboxWidgetAnnotationValueAsString Property

Gets the value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation Methods

The CheckboxWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a CheckboxFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.IsValidChildOf Method

CheckboxWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a CheckboxFormField

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidChildOf(
    IFormElement elem
)
Public Overrides Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


CheckboxWidgetAnnotation.ValidateProperties Method

CheckboxWidgetAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

CheckboxWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair Class

In a ChoiceWidgetAnnotation, it is possible to have either a list of choices which will be used both for display and for exporting data, or a list of pairs where one element is used for display and the other element is used for exporting data. For example, you might create a survey where a ChoiceWidgetAnnotation displays "Best - Would Purchase Again", "Good - Satisfactory", "Poor - Would Not Purchase Again". These are wordy and might not be suitable for a data consumer, so you could instead associate export names with each choice: "Best", "Good", "Poor". You could also create surveys for other languages by putting the target language in the display name and a language neutral name in the export name.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsChoicePair

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ChoicePair
Public Class ChoicePair

The ChoicePair type exposes the following members.

Constructors
 | Name | Description
Public method | ChoicePair(String) | Initializes a new instance of the ChoicePair class. ExportName will be null.
Public method | ChoicePair(String, String) | Initializes a new instance of the ChoicePair class.
Top
Properties
 | Name | Description
Public property | DisplayName | Gets or sets the display name - must be non-null.
Public property | ExportName | Gets or sets the name for export. Setting to null means that DisplayName will be used for export.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair Constructor

Overload List
 | Name | Description
Public method | ChoicePair(String) | Initializes a new instance of the ChoicePair class. ExportName will be null.
Public method | ChoicePair(String, String) | Initializes a new instance of the ChoicePair class.
Top
See Also

Reference

ChoicePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair Constructor (String)

Initializes a new instance of the ChoicePair class. ExportName will be null.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoicePair(
    string displayName
)
Public Sub New (
    displayName As String
)

Parameters

displayName
Type: SystemString
The display name.
See Also

Reference

ChoicePair Class
ChoicePair Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair Constructor (String, String)

Initializes a new instance of the ChoicePair class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoicePair(
    string displayName,
    string exportName
)
Public Sub New (
    displayName As String,
    exportName As String
)

Parameters

displayName
Type: SystemString
The display name.
exportName
Type: SystemString
Name used for export.
See Also

Reference

ChoicePair Class
ChoicePair Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair Properties

The ChoicePair type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | Gets or sets the display name - must be non-null.
Public property | ExportName | Gets or sets the name for export. Setting to null means that DisplayName will be used for export.
Top
See Also

Reference

ChoicePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair.DisplayName Property

ChoicePairDisplayName Property

Gets or sets the display name - must be non-null.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The display name.
See Also

Reference

ChoicePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair.ExportName Property

ChoicePairExportName Property

Gets or sets the name for export. Setting to null means that DisplayName will be used for export.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ExportName { get; set; }
Public Property ExportName As String
    Get
    Set

Property Value

Type: String
The name used for export.
See Also

Reference

ChoicePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoicePair Methods

The ChoicePair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChoicePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Class

A ChoiceWidgetAnnotation is a BaseWidgetAnnotation used for defining a selection from a list of options. The selection can be none, 1 item or many items. The annotation can be either a list box or a pop-up menu of options.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ChoiceWidgetAnnotation : BaseWidgetAnnotation
Public Class ChoiceWidgetAnnotation
    Inherits BaseWidgetAnnotation

The ChoiceWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | ChoiceWidgetAnnotation | Initializes a new instance of the ChoiceWidgetAnnotation class with the kind set to ListBox.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind) | Initializes a new instance of the ChoiceWidgetAnnotation class with the kind of annotation specified.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String) | Initializes a new instance of the ChoiceWidgetAnnotation class.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String, PdfBounds, IEnumerableChoicePair) | Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will be used as display and export names.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String, PdfBounds, IEnumerableString) | Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will all be used as display names in the choice pairs.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String, PdfBounds, String) | Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will all be used as display names in the choice pairs.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AllowMultiSelect | Gets or sets a value indicating whether the widget will allow multiple selections.
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether to auto generate a basic appearance for this widget. Default is true.
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | Choices | Gets the choices that will be displayed.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CurrentSelection | Gets the indexes of the current selection. This collection is independent of AllowMultiSelect in that it is the client's responsibility to ensure that if AllowMultiSelect is false, then CurrentSelection has at most 1 entry. It is undefined what a PDF viewer should do if AllowMultiSelect is false and CurrentSelection has multiple elements.
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | FirstVisibleChoice | Gets or sets the index of first visible choice.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value of the widget as a string. This value will be a comma-separated list built from the export names from each of the currently selected choices. If the export name for any choice is null, the display name will be used instead. If the name contains a comma, it will be replaced with two commas. (Overrides BaseWidgetAnnotationValueAsString.)
Public property | WidgetKind | Gets or sets the kind of the widget.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a ChoiceFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor

Overload List
 | Name | Description
Public method | ChoiceWidgetAnnotation | Initializes a new instance of the ChoiceWidgetAnnotation class with the kind set to ListBox.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind) | Initializes a new instance of the ChoiceWidgetAnnotation class with the kind of annotation specified.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String) | Initializes a new instance of the ChoiceWidgetAnnotation class.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String, PdfBounds, IEnumerableChoicePair) | Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will be used as display and export names.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String, PdfBounds, IEnumerableString) | Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will all be used as display names in the choice pairs.
Public method | ChoiceWidgetAnnotation(ChoiceWidgetKind, String, PdfBounds, String) | Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will all be used as display names in the choice pairs.
Top
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor

Initializes a new instance of the ChoiceWidgetAnnotation class with the kind set to ListBox.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetAnnotation()
Public Sub New
See Also

Reference

ChoiceWidgetAnnotation Class
ChoiceWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind)

Initializes a new instance of the ChoiceWidgetAnnotation class with the kind of annotation specified.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetAnnotation(
    ChoiceWidgetKind kind
)
Public Sub New (
    kind As ChoiceWidgetKind
)

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetKind
The kind of annotation.
See Also

Reference

ChoiceWidgetAnnotation Class
ChoiceWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String)

Initializes a new instance of the ChoiceWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetAnnotation(
    ChoiceWidgetKind kind,
    string fieldName
)
Public Sub New (
    kind As ChoiceWidgetKind,
    fieldName As String
)

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetKind
The kind of annotation.
fieldName
Type: SystemString
Name of the field.
See Also

Reference

ChoiceWidgetAnnotation Class
ChoiceWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String, PdfBounds, IEnumerable(ChoicePair))

ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String, PdfBounds, IEnumerableChoicePair)

Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will be used as display and export names.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetAnnotation(
    ChoiceWidgetKind kind,
    string fieldName,
    PdfBounds bounds,
    IEnumerable<ChoicePair> choices
)
Public Sub New (
    kind As ChoiceWidgetKind,
    fieldName As String,
    bounds As PdfBounds,
    choices As IEnumerable(Of ChoicePair)
)

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetKind
The kind of annotation.
fieldName
Type: SystemString
Name of the field.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
choices
Type: System.Collections.GenericIEnumerableChoicePair
The choices in the list.
See Also

Reference

ChoiceWidgetAnnotation Class
ChoiceWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String, PdfBounds, IEnumerable(String))

ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String, PdfBounds, IEnumerableString)

Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will all be used as display names in the choice pairs.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetAnnotation(
    ChoiceWidgetKind kind,
    string fieldName,
    PdfBounds bounds,
    IEnumerable<string> choices
)
Public Sub New (
    kind As ChoiceWidgetKind,
    fieldName As String,
    bounds As PdfBounds,
    choices As IEnumerable(Of String)
)

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetKind
The kind of annotation.
fieldName
Type: SystemString
Name of the field.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
choices
Type: System.Collections.GenericIEnumerableString
The choices in the list.
See Also

Reference

ChoiceWidgetAnnotation Class
ChoiceWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String, PdfBounds, String[])

ChoiceWidgetAnnotation Constructor (ChoiceWidgetKind, String, PdfBounds, String)

Initializes a new instance of the ChoiceWidgetAnnotation class. The choices provided will all be used as display names in the choice pairs.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetAnnotation(
    ChoiceWidgetKind kind,
    string fieldName,
    PdfBounds bounds,
    params string[] choices
)
Public Sub New (
    kind As ChoiceWidgetKind,
    fieldName As String,
    bounds As PdfBounds,
    ParamArray choices As String()
)

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsChoiceWidgetKind
The kind of annotation.
fieldName
Type: SystemString
Name of the field.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
choices
Type: SystemString
The choices in the list.
See Also

Reference

ChoiceWidgetAnnotation Class
ChoiceWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Properties

The ChoiceWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AllowMultiSelect | Gets or sets a value indicating whether the widget will allow multiple selections.
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether to auto generate a basic appearance for this widget. Default is true.
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | Choices | Gets the choices that will be displayed.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CurrentSelection | Gets the indexes of the current selection. This collection is independent of AllowMultiSelect in that it is the client's responsibility to ensure that if AllowMultiSelect is false, then CurrentSelection has at most 1 entry. It is undefined what a PDF viewer should do if AllowMultiSelect is false and CurrentSelection has multiple elements.
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | FirstVisibleChoice | Gets or sets the index of first visible choice.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value of the widget as a string. This value will be a comma-separated list built from the export names from each of the currently selected choices. If the export name for any choice is null, the display name will be used instead. If the name contains a comma, it will be replaced with two commas. (Overrides BaseWidgetAnnotationValueAsString.)
Public property | WidgetKind | Gets or sets the kind of the widget.
Top
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.AllowMultiSelect Property

ChoiceWidgetAnnotationAllowMultiSelect Property

Gets or sets a value indicating whether the widget will allow multiple selections.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowMultiSelect { get; set; }
Public Property AllowMultiSelect As Boolean
    Get
    Set

Property Value

Type: Boolean
true if multiple selections are allowed; otherwise, false.
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.AutoGenerateBasicAppearance Property

ChoiceWidgetAnnotationAutoGenerateBasicAppearance Property

Gets or sets a value indicating whether to auto generate a basic appearance for this widget. Default is true.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateBasicAppearance { get; set; }
Public Property AutoGenerateBasicAppearance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if [auto generate basic appearance]; otherwise, false.
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.Choices Property

ChoiceWidgetAnnotationChoices Property

Gets the choices that will be displayed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<ChoicePair> Choices { get; }
Public ReadOnly Property Choices As IList(Of ChoicePair)
    Get

Property Value

Type: IListChoicePair
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.CurrentSelection Property

ChoiceWidgetAnnotationCurrentSelection Property

Gets the indexes of the current selection. This collection is independent of AllowMultiSelect in that it is the client's responsibility to ensure that if AllowMultiSelect is false, then CurrentSelection has at most 1 entry. It is undefined what a PDF viewer should do if AllowMultiSelect is false and CurrentSelection has multiple elements.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<int> CurrentSelection { get; }
Public ReadOnly Property CurrentSelection As IList(Of Integer)
    Get

Property Value

Type: IListInt32
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.DefaultValueAsString Property

ChoiceWidgetAnnotationDefaultValueAsString Property

Gets the default value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DefaultValueAsString { get; }
Public Overrides ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.FirstVisibleChoice Property

ChoiceWidgetAnnotationFirstVisibleChoice Property

Gets or sets the index of first visible choice.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FirstVisibleChoice { get; set; }
Public Property FirstVisibleChoice As Integer
    Get
    Set

Property Value

Type: Int32
The first visible choice in the list.
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.ValueAsString Property

ChoiceWidgetAnnotationValueAsString Property

Gets the value of the widget as a string. This value will be a comma-separated list built from the export names from each of the currently selected choices. If the export name for any choice is null, the display name will be used instead. If the name contains a comma, it will be replaced with two commas.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.WidgetKind Property

ChoiceWidgetAnnotationWidgetKind Property

Gets or sets the kind of the widget.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceWidgetKind WidgetKind { get; set; }
Public Property WidgetKind As ChoiceWidgetKind
    Get
    Set

Property Value

Type: ChoiceWidgetKind
The kind of the widget.
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation Methods

The ChoiceWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a ChoiceFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.IsValidChildOf Method

ChoiceWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a ChoiceFormField

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidChildOf(
    IFormElement elem
)
Public Overrides Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetAnnotation.ValidateProperties Method

ChoiceWidgetAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

ChoiceWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ChoiceWidgetKind Enumeration

Determines how a ChoiceWidgetAnnotation will appear in the user interface.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ChoiceWidgetKind
Public Enumeration ChoiceWidgetKind
Members
Member name | Description
ListBox | The choices will be represented as a list of lines.
PopupSelection | The choices will be displayed as a pop-up menu.
PopupSelectionWithText | The choices will be displayed as a pop-up menu with a text field for typing a name of an element.
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates Class

This is a class that is used for defining and installing PdfTemplateResource objects in a resource dictionary that represent the appearances for widget annotations. At present this class is responsible for making appearances for checkbox and radio button widgets, as these appearances can be shared across an entire document. Before working with a new document, you can set the basic color schemes used for the appearances. In addition, you can force installation of your own default appearances and they will be treated as standard.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsDefaultWidgetTemplates

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DefaultWidgetTemplates
Public Class DefaultWidgetTemplates

The DefaultWidgetTemplates type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultWidgetTemplates | Initializes a new instance of the DefaultWidgetTemplates class
Top
Properties
Name | Description
ActivatedColor | Gets or sets the main color of the activated appearance.
ActivatedHilightColor | Gets or sets the highlight color of the activated appearance.
CheckboxCheckedActivatedName | Gets the name of the checkbox checked activated resource.
CheckboxCheckedNormalName | Gets the name of the checkbox checked normal resource.
CheckboxCheckedRolloverName | Gets the name of the checkbox checked rollover resource.
CheckboxClearedActivatedName | Gets the name of the checkbox cleared activated resource.
CheckboxClearedNormalName | Gets the name of the checkbox cleared normal resource.
CheckboxClearedRolloverName | Gets the name of the checkbox cleared rollover resource.
NormalColor | Gets or sets the main color of the normal appearance.
RadioButtonCheckedActivatedName | Gets the name of the radio button checked activated resource.
RadioButtonCheckedNormalName | Gets the name of the radio button checked normal resource.
RadioButtonCheckedRolloverName | Gets the name of the radio button checked rollover resource.
RadioButtonClearedActivatedName | Gets the name of the radio button cleared activated resource.
RadioButtonClearedNormalName | Gets the name of the radio button cleared normal resource.
RadioButtonClearedRolloverName | Gets the name of the radio button cleared rollover resource.
RolloverColor | Gets or sets the main color of the rollover appearance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCheckAppearances | Gets the standard checkbox appearances.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetRadioAppearances | Gets the standard radio appearances.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InstallAppearances | Installs the appearances in the resource collection.
 | InstallDefaultAppearances | Installs the default appearances in the resource collection, optionally overriding any that exist.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates Constructor

Initializes a new instance of the DefaultWidgetTemplates class

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DefaultWidgetTemplates()
Public Sub New
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates Properties

The DefaultWidgetTemplates type exposes the following members.

Properties
Name | Description
ActivatedColor | Gets or sets the main color of the activated appearance.
ActivatedHilightColor | Gets or sets the highlight color of the activated appearance.
CheckboxCheckedActivatedName | Gets the name of the checkbox checked activated resource.
CheckboxCheckedNormalName | Gets the name of the checkbox checked normal resource.
CheckboxCheckedRolloverName | Gets the name of the checkbox checked rollover resource.
CheckboxClearedActivatedName | Gets the name of the checkbox cleared activated resource.
CheckboxClearedNormalName | Gets the name of the checkbox cleared normal resource.
CheckboxClearedRolloverName | Gets the name of the checkbox cleared rollover resource.
NormalColor | Gets or sets the main color of the normal appearance.
RadioButtonCheckedActivatedName | Gets the name of the radio button checked activated resource.
RadioButtonCheckedNormalName | Gets the name of the radio button checked normal resource.
RadioButtonCheckedRolloverName | Gets the name of the radio button checked rollover resource.
RadioButtonClearedActivatedName | Gets the name of the radio button cleared activated resource.
RadioButtonClearedNormalName | Gets the name of the radio button cleared normal resource.
RadioButtonClearedRolloverName | Gets the name of the radio button cleared rollover resource.
RolloverColor | Gets or sets the main color of the rollover appearance.
Top
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.ActivatedColor Property

DefaultWidgetTemplatesActivatedColor Property

Gets or sets the main color of the activated appearance.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfColor ActivatedColor { get; set; }
Public Shared Property ActivatedColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the activated appearance.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.ActivatedHilightColor Property

DefaultWidgetTemplatesActivatedHilightColor Property

Gets or sets the highlight color of the activated appearance.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfColor ActivatedHilightColor { get; set; }
Public Shared Property ActivatedHilightColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the activated appearance.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.CheckboxCheckedActivatedName Property

DefaultWidgetTemplatesCheckboxCheckedActivatedName Property

Gets the name of the checkbox checked activated resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckboxCheckedActivatedName { get; }
Public Shared ReadOnly Property CheckboxCheckedActivatedName As String
    Get

Property Value

Type: String
The name of the checkbox checked activated resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.CheckboxCheckedNormalName Property

DefaultWidgetTemplatesCheckboxCheckedNormalName Property

Gets the name of the checkbox checked normal resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckboxCheckedNormalName { get; }
Public Shared ReadOnly Property CheckboxCheckedNormalName As String
    Get

Property Value

Type: String
The name of the checkbox checked normal resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.CheckboxCheckedRolloverName Property

DefaultWidgetTemplatesCheckboxCheckedRolloverName Property

Gets the name of the checkbox checked rollover resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckboxCheckedRolloverName { get; }
Public Shared ReadOnly Property CheckboxCheckedRolloverName As String
    Get

Property Value

Type: String
The name of the checkbox checked rollover resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.CheckboxClearedActivatedName Property

DefaultWidgetTemplatesCheckboxClearedActivatedName Property

Gets the name of the checkbox cleared activated resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckboxClearedActivatedName { get; }
Public Shared ReadOnly Property CheckboxClearedActivatedName As String
    Get

Property Value

Type: String
The name of the checkbox cleared activated resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.CheckboxClearedNormalName Property

DefaultWidgetTemplatesCheckboxClearedNormalName Property

Gets the name of the checkbox cleared normal resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckboxClearedNormalName { get; }
Public Shared ReadOnly Property CheckboxClearedNormalName As String
    Get

Property Value

Type: String
The name of the checkbox cleared normal resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.CheckboxClearedRolloverName Property

DefaultWidgetTemplatesCheckboxClearedRolloverName Property

Gets the name of the checkbox cleared rollover resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckboxClearedRolloverName { get; }
Public Shared ReadOnly Property CheckboxClearedRolloverName As String
    Get

Property Value

Type: String
The name of the checkbox cleared rollover resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.NormalColor Property

DefaultWidgetTemplatesNormalColor Property

Gets or sets the main color of the normal appearance.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfColor NormalColor { get; set; }
Public Shared Property NormalColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the normal appearance.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RadioButtonCheckedActivatedName Property

DefaultWidgetTemplatesRadioButtonCheckedActivatedName Property

Gets the name of the radio button checked activated resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string RadioButtonCheckedActivatedName { get; }
Public Shared ReadOnly Property RadioButtonCheckedActivatedName As String
    Get

Property Value

Type: String
The name of the radio button checked activated resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RadioButtonCheckedNormalName Property

DefaultWidgetTemplatesRadioButtonCheckedNormalName Property

Gets the name of the radio button checked normal resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string RadioButtonCheckedNormalName { get; }
Public Shared ReadOnly Property RadioButtonCheckedNormalName As String
    Get

Property Value

Type: String
The name of the radio button checked normal resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RadioButtonCheckedRolloverName Property

DefaultWidgetTemplatesRadioButtonCheckedRolloverName Property

Gets the name of the radio button checked rollover resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string RadioButtonCheckedRolloverName { get; }
Public Shared ReadOnly Property RadioButtonCheckedRolloverName As String
    Get

Property Value

Type: String
The name of the radio button checked rollover resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RadioButtonClearedActivatedName Property

DefaultWidgetTemplatesRadioButtonClearedActivatedName Property

Gets the name of the radio button cleared activated resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string RadioButtonClearedActivatedName { get; }
Public Shared ReadOnly Property RadioButtonClearedActivatedName As String
    Get

Property Value

Type: String
The name of the radio button cleared activated resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RadioButtonClearedNormalName Property

DefaultWidgetTemplatesRadioButtonClearedNormalName Property

Gets the name of the radio button cleared normal resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string RadioButtonClearedNormalName { get; }
Public Shared ReadOnly Property RadioButtonClearedNormalName As String
    Get

Property Value

Type: String
The name of the radio button cleared normal resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RadioButtonClearedRolloverName Property

DefaultWidgetTemplatesRadioButtonClearedRolloverName Property

Gets the name of the radio button cleared rollover resource.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string RadioButtonClearedRolloverName { get; }
Public Shared ReadOnly Property RadioButtonClearedRolloverName As String
    Get

Property Value

Type: String
The name of the radio button cleared rollover resource.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.RolloverColor Property

DefaultWidgetTemplatesRolloverColor Property

Gets or sets the main color of the rollover appearance.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IPdfColor RolloverColor { get; set; }
Public Shared Property RolloverColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the rollover appearance.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates Methods

The DefaultWidgetTemplates type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCheckAppearances | Gets the standard checkbox appearances.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetRadioAppearances | Gets the standard radio appearances.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InstallAppearances | Installs the appearances in the resource collection.
 | InstallDefaultAppearances | Installs the default appearances in the resource collection, optionally overriding any that exist.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.GetCheckAppearances Method

DefaultWidgetTemplatesGetCheckAppearances Method

Gets the standard checkbox appearances.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<StringDrawingTemplatePair> GetCheckAppearances(
    IPdfColor normalColor,
    IPdfColor activatedColor,
    IPdfColor activateHiliteColor,
    IPdfColor rolloverColor
)
Public Shared Function GetCheckAppearances (
    normalColor As IPdfColor,
    activatedColor As IPdfColor,
    activateHiliteColor As IPdfColor,
    rolloverColor As IPdfColor
) As IEnumerable(Of StringDrawingTemplatePair)

Parameters

normalColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the normal appearance.
activatedColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the activated appearance.
activateHiliteColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the activate hilite appearance.
rolloverColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the rollover appearance.

Return Value

Type: IEnumerableStringDrawingTemplatePair
A set of appearances for standard checkbox widgets
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.GetRadioAppearances Method

DefaultWidgetTemplatesGetRadioAppearances Method

Gets the standard radio appearances.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<StringDrawingTemplatePair> GetRadioAppearances(
    IPdfColor normalColor,
    IPdfColor activatedColor,
    IPdfColor activateHiliteColor,
    IPdfColor rolloverColor
)
Public Shared Function GetRadioAppearances (
    normalColor As IPdfColor,
    activatedColor As IPdfColor,
    activateHiliteColor As IPdfColor,
    rolloverColor As IPdfColor
) As IEnumerable(Of StringDrawingTemplatePair)

Parameters

normalColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the normal appearance.
activatedColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the activated appearance.
activateHiliteColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the activate hilite appearance.
rolloverColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the rollover appearance.

Return Value

Type: IEnumerableStringDrawingTemplatePair
A set of standard radio button widget appearances.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.InstallAppearances Method

DefaultWidgetTemplatesInstallAppearances Method

Installs the appearances in the resource collection.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void InstallAppearances(
    GlobalResources gr,
    bool overrideExisting,
    IEnumerable<StringDrawingTemplatePair> pairs
)
Public Shared Sub InstallAppearances (
    gr As GlobalResources,
    overrideExisting As Boolean,
    pairs As IEnumerable(Of StringDrawingTemplatePair)
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection.
overrideExisting
Type: SystemBoolean
if set to true override existing appearances.
pairs
Type: System.Collections.GenericIEnumerableStringDrawingTemplatePair
The sets of names and appearances to use.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


DefaultWidgetTemplates.InstallDefaultAppearances Method

DefaultWidgetTemplatesInstallDefaultAppearances Method

Installs the default appearances in the resource collection, optionally overriding any that exist.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void InstallDefaultAppearances(
    GlobalResources gr,
    bool overrideExisting
)
Public Shared Sub InstallDefaultAppearances (
    gr As GlobalResources,
    overrideExisting As Boolean
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection.
overrideExisting
Type: SystemBoolean
if set to true override existing appearances.
See Also

Reference

DefaultWidgetTemplates Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


EllipseAnnotation Class

Represents an ellipse (or circle) annotation. This annotation is identical in every way to the RectangleAnnotation except for the appearance.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRectangleAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsEllipseAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class EllipseAnnotation : RectangleAnnotation
Public Class EllipseAnnotation
    Inherits RectangleAnnotation

The EllipseAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | EllipseAnnotation | Initializes a new instance of the EllipseAnnotation class.
Public method | EllipseAnnotation(PdfBounds) | Initializes a new instance of the EllipseAnnotation class with the specified bounds.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect. (Inherited from RectangleAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color. (Inherited from RectangleAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from RectangleAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


EllipseAnnotation Constructor

Overload List
 | Name | Description
Public method | EllipseAnnotation | Initializes a new instance of the EllipseAnnotation class.
Public method | EllipseAnnotation(PdfBounds) | Initializes a new instance of the EllipseAnnotation class with the specified bounds.
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


EllipseAnnotation Constructor

Initializes a new instance of the EllipseAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation()
Public Sub New
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


EllipseAnnotation Constructor (PdfBounds)

Initializes a new instance of the EllipseAnnotation class with the specified bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EllipseAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


EllipseAnnotation Properties

The EllipseAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect. (Inherited from RectangleAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color. (Inherited from RectangleAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


EllipseAnnotation Methods

The EllipseAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from RectangleAnnotation.)
Top
See Also

Reference

EllipseAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview Class

GeneralReview represents a review process with states None, Accepted, Rejected, Cancelled, and Completed.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsReviewProcess
Atalasoft.PdfDoc.Generating.AnnotationsGeneralReview

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GeneralReview : ReviewProcess
Public Class GeneralReview
    Inherits ReviewProcess

The GeneralReview type exposes the following members.

Constructors
 | Name | Description
Public method | GeneralReview | Initializes a new instance of the GeneralReview class.
Top
Properties
 | Name | Description
 | AcceptedStateIndex | Gets the index of the accepted state.
 | CancelledStateIndex | Gets the index of the cancelled state.
 | CompletedStateIndex | Gets the index of the completed state.
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates (Inherited from ReviewProcess.)
 | NoneStateIndex | Gets the index of the none state.
Public property | ProcessName | Gets the name of the review process. Returns "Review". (Overrides ReviewProcessProcessName.)
 | RejectedStateIndex | Gets the index of the rejected state.
Public property | StateName | Gets the name of the current review state. (Inherited from ReviewProcess.)
Public property | ValidStates | Gets the valid states for this ReviewProcess (Inherited from ReviewProcess.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state. (Inherited from ReviewProcess.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview Constructor

Initializes a new instance of the GeneralReview class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GeneralReview()
Public Sub New
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview Properties

The GeneralReview type exposes the following members.

Properties
 | Name | Description
 | AcceptedStateIndex | Gets the index of the accepted state.
 | CancelledStateIndex | Gets the index of the cancelled state.
 | CompletedStateIndex | Gets the index of the completed state.
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates (Inherited from ReviewProcess.)
 | NoneStateIndex | Gets the index of the none state.
Public property | ProcessName | Gets the name of the review process. Returns "Review". (Overrides ReviewProcessProcessName.)
 | RejectedStateIndex | Gets the index of the rejected state.
Public property | StateName | Gets the name of the current review state. (Inherited from ReviewProcess.)
Public property | ValidStates | Gets the valid states for this ReviewProcess (Inherited from ReviewProcess.)
Top
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview.AcceptedStateIndex Property

GeneralReviewAcceptedStateIndex Property

Gets the index of the accepted state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int AcceptedStateIndex { get; }
Public Shared ReadOnly Property AcceptedStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the accepted state.
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview.CancelledStateIndex Property

GeneralReviewCancelledStateIndex Property

Gets the index of the cancelled state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int CancelledStateIndex { get; }
Public Shared ReadOnly Property CancelledStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the cancelled state.
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview.CompletedStateIndex Property

GeneralReviewCompletedStateIndex Property

Gets the index of the completed state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int CompletedStateIndex { get; }
Public Shared ReadOnly Property CompletedStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the completed state.
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview.NoneStateIndex Property

GeneralReviewNoneStateIndex Property

Gets the index of the none state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int NoneStateIndex { get; }
Public Shared ReadOnly Property NoneStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the none state.
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview.ProcessName Property

GeneralReviewProcessName Property

Gets the name of the review process. Returns "Review".

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ProcessName { get; }
Public Overrides ReadOnly Property ProcessName As String
    Get

Property Value

Type: String
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview.RejectedStateIndex Property

GeneralReviewRejectedStateIndex Property

Gets the index of the rejected state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int RejectedStateIndex { get; }
Public Shared ReadOnly Property RejectedStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the rejected state.
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


GeneralReview Methods

The GeneralReview type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state. (Inherited from ReviewProcess.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GeneralReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation Class

An InkAnnotation represents a series of free-hand marks. They are modeled by a set of polylines grouped as one. These could be used for a signature or document mark up.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsInkAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class InkAnnotation : BaseMarkupAnnotation
Public Class InkAnnotation
    Inherits BaseMarkupAnnotation

The InkAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | InkAnnotation | Initializes a new instance of the InkAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoCalculateBounds | Gets or sets a value indicating whether to automatically calculate the annotation's Bounds.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InkList | Gets the ink list. This is a collection of PdfPointCollection. Each element represents a polyline that will be drawn.
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation Constructor

Initializes a new instance of the InkAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public InkAnnotation()
Public Sub New
See Also

Reference

InkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation Properties

The InkAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoCalculateBounds | Gets or sets a value indicating whether to automatically calculate the annotation's Bounds.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InkList | Gets the ink list. This is a collection of PdfPointCollection. Each element represents a polyline that will be drawn.
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

InkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation.AutoCalculateBounds Property

InkAnnotationAutoCalculateBounds Property

Gets or sets a value indicating whether to automatically calculate the annotation's Bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoCalculateBounds { get; set; }
Public Property AutoCalculateBounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Bounds will be automatically calculated; otherwise, false.
See Also

Reference

InkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation.InkList Property

InkAnnotationInkList Property

Gets the ink list. This is a collection of PdfPointCollection. Each element represents a polyline that will be drawn.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfPointCollection> InkList { get; }
Public ReadOnly Property InkList As IList(Of PdfPointCollection)
    Get

Property Value

Type: IListPdfPointCollection
See Also

Reference

InkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation Methods

The InkAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

InkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


InkAnnotation.ValidateProperties Method

InkAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

InkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation Class

The LineAnnotation represents a single line on the page
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsLineAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LineAnnotation : BaseMarkupAnnotation
Public Class LineAnnotation
    Inherits BaseMarkupAnnotation

The LineAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | LineAnnotation | Initializes a new instance of the LineAnnotation class.
Public method | LineAnnotation(PdfPoint, PdfPoint) | Initializes a new instance of the LineAnnotation class with the two end points.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | CaptionOffset | Gets or sets the caption offset from its normal position.
Public property | CaptionPositioning | Gets or sets the caption positioning. Captions can be positioned inline or above the line.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EndPt | Gets or sets the end point. Bounds are updated automatically after setting.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color. This color is used to fill in closed endings.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsCaptioned | Gets or sets a value indicating whether this instance is captioned. If a line is captioned, the Contents will be used as a caption.
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LeaderLineExtensionLength | Gets or sets the length of the leader line extension.
Public property | LeaderLineLength | Gets or sets the length of the leader line.
Public property | LeaderLineOffset | Gets or sets the leader line offset.
Public property | LineEnding | Gets the line endings for this line. The 0th entry is the ending for the StartPt and the 1st entry is for the EndPt.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | StartPt | Gets or sets the start point. Bounds are updated automatically after setting.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Public property | Usage | Gets or sets the intended LineUsageKind of the line
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation Constructor

Overload List
 | Name | Description
Public method | LineAnnotation | Initializes a new instance of the LineAnnotation class.
Public method | LineAnnotation(PdfPoint, PdfPoint) | Initializes a new instance of the LineAnnotation class with the two end points.
Top
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation Constructor

Initializes a new instance of the LineAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation()
Public Sub New
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation Constructor (PdfPoint, PdfPoint)

Initializes a new instance of the LineAnnotation class with the two end points.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineAnnotation(
    PdfPoint start,
    PdfPoint end
)
Public Sub New (
    start As PdfPoint,
    end As PdfPoint
)

Parameters

start
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The start point.
end
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The end point.
See Also

Reference

LineAnnotation Class
LineAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation Properties

The LineAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | CaptionOffset | Gets or sets the caption offset from its normal position.
Public property | CaptionPositioning | Gets or sets the caption positioning. Captions can be positioned inline or above the line.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EndPt | Gets or sets the end point. Bounds are updated automatically after setting.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color. This color is used to fill in closed endings.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsCaptioned | Gets or sets a value indicating whether this instance is captioned. If a line is captioned, the Contents will be used as a caption.
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LeaderLineExtensionLength | Gets or sets the length of the leader line extension.
Public property | LeaderLineLength | Gets or sets the length of the leader line.
Public property | LeaderLineOffset | Gets or sets the leader line offset.
Public property | LineEnding | Gets the line endings for this line. The 0th entry is the ending for the StartPt and the 1st entry is for the EndPt.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | StartPt | Gets or sets the start point. Bounds are updated automatically after setting.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Public property | Usage | Gets or sets the intended LineUsageKind of the line
Top
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.CaptionOffset Property

LineAnnotationCaptionOffset Property

Gets or sets the caption offset from its normal position.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint CaptionOffset { get; set; }
Public Property CaptionOffset As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The caption offset.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.CaptionPositioning Property

LineAnnotationCaptionPositioning Property

Gets or sets the caption positioning. Captions can be positioned inline or above the line.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CaptionPositionKind CaptionPositioning { get; set; }
Public Property CaptionPositioning As CaptionPositionKind
    Get
    Set

Property Value

Type: CaptionPositionKind
The caption positioning.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.EndPt Property

LineAnnotationEndPt Property

Gets or sets the end point. Bounds are updated automatically after setting.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint EndPt { get; set; }
Public Property EndPt As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The end point.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.InternalColor Property

LineAnnotationInternalColor Property

Gets or sets the fill color. This color is used to fill in closed endings.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor InternalColor { get; set; }
Public Property InternalColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The fill color.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.IsCaptioned Property

LineAnnotationIsCaptioned Property

Gets or sets a value indicating whether this instance is captioned. If a line is captioned, the Contents will be used as a caption.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCaptioned { get; set; }
Public Property IsCaptioned As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is captioned; otherwise, false.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.LeaderLineExtensionLength Property

LineAnnotationLeaderLineExtensionLength Property

Gets or sets the length of the leader line extension.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LeaderLineExtensionLength { get; set; }
Public Property LeaderLineExtensionLength As Double
    Get
    Set

Property Value

Type: Double
The length of the leader line extension.
Remarks
If you want to customize the appearance of a line annotation beyond simple line ends, you can set three parameters: the LeaderLineLength, the LeaderLineExtensionLength, and the LeaderLineOffset. Lines are offset from the StartPt and EndPt by a distance that is the sum of the LeaderLineLength and the LeaderLineOffset. LeaderLineLength represent the length of the line butt ends that are closest to the starting and ending points (offset by LeaderLineOffset). LeaderLineExtensionLength is the length of the butt ends that project past the actual drawn line. If you specify a LeaderLineExtensionLength, you must also have a non-zero LeaderLineLength.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.LeaderLineLength Property

LineAnnotationLeaderLineLength Property

Gets or sets the length of the leader line.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LeaderLineLength { get; set; }
Public Property LeaderLineLength As Double
    Get
    Set

Property Value

Type: Double
The length of the leader line.
Remarks
If you want to customize the appearance of a line annotation beyond simple line ends, you can set three parameters: the LeaderLineLength, the LeaderLineExtensionLength, and the LeaderLineOffset. Lines are offset from the StartPt and EndPt by a distance that is the sum of the LeaderLineLength and the LeaderLineOffset. LeaderLineLength represent the length of the line butt ends that are closest to the starting and ending points (offset by LeaderLineOffset). LeaderLineExtensionLength is the length of the butt ends that project past the actual drawn line. If you specify a LeaderLineExtensionLength, you must also have a non-zero LeaderLineLength.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.LeaderLineOffset Property

LineAnnotationLeaderLineOffset Property

Gets or sets the leader line offset.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LeaderLineOffset { get; set; }
Public Property LeaderLineOffset As Double
    Get
    Set

Property Value

Type: Double
The leader line offset.
Remarks
If you want to customize the appearance of a line annotation beyond simple line ends, you can set three parameters: the LeaderLineLength, the LeaderLineExtensionLength, and the LeaderLineOffset. Lines are offset from the StartPt and EndPt by a distance that is the sum of the LeaderLineLength and the LeaderLineOffset. LeaderLineLength represent the length of the line butt ends that are closest to the starting and ending points (offset by LeaderLineOffset). LeaderLineExtensionLength is the length of the butt ends that project past the actual drawn line. If you specify a LeaderLineExtensionLength, you must also have a non-zero LeaderLineLength.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.LineEnding Property

LineAnnotationLineEnding Property

Gets the line endings for this line. The 0th entry is the ending for the StartPt and the 1st entry is for the EndPt.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineEndingKind[] LineEnding { get; }
Public ReadOnly Property LineEnding As LineEndingKind()
    Get

Property Value

Type: LineEndingKind
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.StartPt Property

LineAnnotationStartPt Property

Gets or sets the start point. Bounds are updated automatically after setting.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint StartPt { get; set; }
Public Property StartPt As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The start point.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.Usage Property

LineAnnotationUsage Property

Gets or sets the intended LineUsageKind of the line

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineUsageKind Usage { get; set; }
Public Property Usage As LineUsageKind
    Get
    Set

Property Value

Type: LineUsageKind
The line usage.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation Methods

The LineAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineAnnotation.ValidateProperties Method

LineAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

LineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LineEndingKind Enumeration

Annotations with lines may have decorative ends. This enumeration specifies those ends.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum LineEndingKind
Public Enumeration LineEndingKind
Members
Member name | Description
None | No end
Square | Square blocks on the ends
Circle | Circular dots on the ends
Diamond | Diamond blocks on the ends
OpenArrow | An arrow with open flanges on the end
ClosedArrow | An arrow with closed flanges on the end
Butt | Short perpendicular lines
ReverseOpenArrow | A backwards open arrow head
ReverseClosedArrow | A backwards closed arrow head
Slash | Angled end lines
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


LineUsageKind Enumeration

Specifies how a line is to be used

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum LineUsageKind
Public Enumeration LineUsageKind
Members
Member name | Description
Line | Simple line
Arrow | Pointing arrow
Dimension | Measurment line
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Class

A LinkAnnotation represents a hyperlink in a PDF document. A PDF hyperlink is a generalized to mean "an area that when clicked causes a chain of actions to take place." For example, a LinkAnnotation could cause a sound to be played and then the document to be zoomed to a particular view on a page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsLinkAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class LinkAnnotation : BaseAnnotation
Public Class LinkAnnotation
    Inherits BaseAnnotation

The LinkAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | LinkAnnotation | Initializes a new instance of the LinkAnnotation class with empty bounds and no action.
Public method | LinkAnnotation(PdfBounds) | Initializes a new instance of the LinkAnnotation class with the given bounds. No action is specified.
Public method | LinkAnnotation(PdfBounds, PdfAction) | Initializes a new instance of the LinkAnnotation class with the given bounds and to take the particular action.
Public method | LinkAnnotation(PdfBounds, Int32) | Initializes a new instance of the LinkAnnotation class with the given bounds and creates it as a "goto page" link using the index to reference a particular page.
Public method | LinkAnnotation(PdfBounds, Uri) | Initializes a new instance of the LinkAnnotation class with the given bounds and creates it as a "web link" to the given Uri used in a PdfURIAction for the link.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the LinkHighlightAppearance of the annotation when it is clicked.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | Regions | In addition to a simple rectangle, a link annotation may also be represented by a set of quadrilateral areas. If this collection is non-empty, the Bounds will be set to contain all the quadrilaterals.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Constructor

Overload List
 | Name | Description
Public method | LinkAnnotation | Initializes a new instance of the LinkAnnotation class with empty bounds and no action.
Public method | LinkAnnotation(PdfBounds) | Initializes a new instance of the LinkAnnotation class with the given bounds. No action is specified.
Public method | LinkAnnotation(PdfBounds, PdfAction) | Initializes a new instance of the LinkAnnotation class with the given bounds and to take the particular action.
Public method | LinkAnnotation(PdfBounds, Int32) | Initializes a new instance of the LinkAnnotation class with the given bounds and creates it as a "goto page" link using the index to reference a particular page.
Public method | LinkAnnotation(PdfBounds, Uri) | Initializes a new instance of the LinkAnnotation class with the given bounds and creates it as a "web link" to the given Uri used in a PdfURIAction for the link.
Top
See Also

Reference

LinkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Constructor

Initializes a new instance of the LinkAnnotation class with empty bounds and no action.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinkAnnotation()
Public Sub New
See Also

Reference

LinkAnnotation Class
LinkAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Constructor (PdfBounds)

Initializes a new instance of the LinkAnnotation class with the given bounds. No action is specified.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinkAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

LinkAnnotation Class
LinkAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Constructor (PdfBounds, PdfAction)

Initializes a new instance of the LinkAnnotation class with the given bounds and to take the particular action.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinkAnnotation(
    PdfBounds bounds,
    PdfAction action
)
Public Sub New (
    bounds As PdfBounds,
    action As PdfAction
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
action
Type: Atalasoft.PdfDocPdfAction
The action.
See Also

Reference

LinkAnnotation Class
LinkAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Constructor (PdfBounds, Int32)

Initializes a new instance of the LinkAnnotation class with the given bounds and creates it as a "goto page" link using the index to reference a particular page.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinkAnnotation(
    PdfBounds bounds,
    int pageIndex
)
Public Sub New (
    bounds As PdfBounds,
    pageIndex As Integer
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
pageIndex
Type: SystemInt32
Index of the page.
See Also

Reference

LinkAnnotation Class
LinkAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Constructor (PdfBounds, Uri)

Initializes a new instance of the LinkAnnotation class with the given bounds and creates it as a "web link" to the given Uri used in a PdfURIAction for the link.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinkAnnotation(
    PdfBounds bounds,
    Uri uriDestination
)
Public Sub New (
    bounds As PdfBounds,
    uriDestination As Uri
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
uriDestination
Type: SystemUri
The URI destination.
See Also

Reference

LinkAnnotation Class
LinkAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Properties

The LinkAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the LinkHighlightAppearance of the annotation when it is clicked.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | Regions | In addition to a simple rectangle, a link annotation may also be represented by a set of quadrilateral areas. If this collection is non-empty, the Bounds will be set to contain all the quadrilaterals.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
See Also

Reference

LinkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation.HighlightAppearance Property

LinkAnnotationHighlightAppearance Property

Gets or sets the LinkHighlightAppearance of the annotation when it is clicked.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LinkHighlightAppearance HighlightAppearance { get; set; }
Public Property HighlightAppearance As LinkHighlightAppearance
    Get
    Set

Property Value

Type: LinkHighlightAppearance
The highlight appearance.
See Also

Reference

LinkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation.Regions Property

LinkAnnotationRegions Property

In addition to a simple rectangle, a link annotation may also be represented by a set of quadrilateral areas. If this collection is non-empty, the Bounds will be set to contain all the quadrilaterals.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateralCollection Regions { get; }
Public ReadOnly Property Regions As PdfQuadrilateralCollection
    Get

Property Value

Type: PdfQuadrilateralCollection
See Also

Reference

LinkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkAnnotation Methods

The LinkAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseAnnotation.)
Top
See Also

Reference

LinkAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


LinkHighlightAppearance Enumeration

Determines how a link annotation should respond when clicked

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum LinkHighlightAppearance
Public Enumeration LinkHighlightAppearance
Members
Member name | Description
None | No change
Invert | Invert the area of the annotation
Outline | Draw an outline around the area of the annotation
PushDown | Shade the annotation to look like it is recessed in the page
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview Class

A MarkingReview represents a review process with two states: Marked and Unmarked.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsReviewProcess
Atalasoft.PdfDoc.Generating.AnnotationsMarkingReview

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MarkingReview : ReviewProcess
Public Class MarkingReview
    Inherits ReviewProcess

The MarkingReview type exposes the following members.

Constructors
 | Name | Description
Public method | MarkingReview | Initializes a new instance of the MarkingReview class.
Top
Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates (Inherited from ReviewProcess.)
 | MarkedStateIndex | Gets the index of the marked state.
Public property | ProcessName | Gets the name of the review process. Returns "Marked". (Overrides ReviewProcessProcessName.)
Public property | StateName | Gets the name of the current review state. (Inherited from ReviewProcess.)
 | UnmarkedStateIndex | Gets the index of the unmarked state.
Public property | ValidStates | Gets the valid states for this ReviewProcess (Inherited from ReviewProcess.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state. (Inherited from ReviewProcess.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview Constructor

Initializes a new instance of the MarkingReview class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MarkingReview()
Public Sub New
See Also

Reference

MarkingReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview Properties

The MarkingReview type exposes the following members.

Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates (Inherited from ReviewProcess.)
 | MarkedStateIndex | Gets the index of the marked state.
Public property | ProcessName | Gets the name of the review process. Returns "Marked". (Overrides ReviewProcessProcessName.)
Public property | StateName | Gets the name of the current review state. (Inherited from ReviewProcess.)
 | UnmarkedStateIndex | Gets the index of the unmarked state.
Public property | ValidStates | Gets the valid states for this ReviewProcess (Inherited from ReviewProcess.)
Top
See Also

Reference

MarkingReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview.MarkedStateIndex Property

MarkingReviewMarkedStateIndex Property

Gets the index of the marked state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int MarkedStateIndex { get; }
Public Shared ReadOnly Property MarkedStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the marked state.
See Also

Reference

MarkingReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview.ProcessName Property

MarkingReviewProcessName Property

Gets the name of the review process. Returns "Marked".

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ProcessName { get; }
Public Overrides ReadOnly Property ProcessName As String
    Get

Property Value

Type: String
See Also

Reference

MarkingReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview.UnmarkedStateIndex Property

MarkingReviewUnmarkedStateIndex Property

Gets the index of the unmarked state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int UnmarkedStateIndex { get; }
Public Shared ReadOnly Property UnmarkedStateIndex As Integer
    Get

Property Value

Type: Int32
The index of the unmarked state.
See Also

Reference

MarkingReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


MarkingReview Methods

The MarkingReview type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state. (Inherited from ReviewProcess.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarkingReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


OpaqueAnnotation Class

OpaqueAnnotation is an annotation that does not currently have a DotPdf high-level representation. You cannot create an OpaqueAnnotation directly. It will be created when reading a PDF file with an unsupported annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsOpaqueAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OpaqueAnnotation : BaseAnnotation
Public Class OpaqueAnnotation
    Inherits BaseAnnotation

The OpaqueAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


OpaqueAnnotation Properties

The OpaqueAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
See Also

Reference

OpaqueAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


OpaqueAnnotation Methods

The OpaqueAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseAnnotation.)
Top
See Also

Reference

OpaqueAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PdfAnnotationList Class

PdfAnnotationList is a collection of annotations for a PDF page,
Inheritance Hierarchy
SystemObject
System.Collections.GenericListBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPdfAnnotationList

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfAnnotationList : List<BaseAnnotation>,
    IPdfResourceConsumer
Public Class PdfAnnotationList
    Inherits List(Of BaseAnnotation)
    Implements IPdfResourceConsumer

The PdfAnnotationList type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAnnotationList | Initializes a new instance of the PdfAnnotationList class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListBaseAnnotation .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListBaseAnnotation .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListBaseAnnotation .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListBaseAnnotation .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListBaseAnnotation .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListBaseAnnotation .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListBaseAnnotation .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseAnnotation .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseAnnotation .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListBaseAnnotation .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListBaseAnnotation .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListBaseAnnotation .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListBaseAnnotation .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseAnnotation .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseAnnotation .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseAnnotation .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseAnnotation .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseAnnotation .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseAnnotation .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListBaseAnnotation .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListBaseAnnotation .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListBaseAnnotation .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseAnnotation .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseAnnotation .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListBaseAnnotation .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListBaseAnnotation .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseAnnotation .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseAnnotation .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies the list that the resource was renamed.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListBaseAnnotation .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListBaseAnnotation .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListBaseAnnotation .)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListBaseAnnotation .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListBaseAnnotation .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListBaseAnnotation .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListBaseAnnotation .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListBaseAnnotation .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListBaseAnnotation .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListBaseAnnotation .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


PdfAnnotationList Constructor

Initializes a new instance of the PdfAnnotationList class

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAnnotationList()
Public Sub New
See Also

Reference

PdfAnnotationList Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PdfAnnotationList Properties

The PdfAnnotationList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListBaseAnnotation .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListBaseAnnotation .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListBaseAnnotation .)
Top
See Also

Reference

PdfAnnotationList Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PdfAnnotationList Methods

The PdfAnnotationList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListBaseAnnotation .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListBaseAnnotation .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListBaseAnnotation .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListBaseAnnotation .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseAnnotation .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseAnnotation .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListBaseAnnotation .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListBaseAnnotation .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListBaseAnnotation .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListBaseAnnotation .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseAnnotation .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseAnnotation .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseAnnotation .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseAnnotation .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseAnnotation .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseAnnotation .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListBaseAnnotation .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListBaseAnnotation .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListBaseAnnotation .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseAnnotation .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseAnnotation .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListBaseAnnotation .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListBaseAnnotation .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseAnnotation .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseAnnotation .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies the list that the resource was renamed.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListBaseAnnotation .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListBaseAnnotation .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListBaseAnnotation .)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListBaseAnnotation .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListBaseAnnotation .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListBaseAnnotation .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListBaseAnnotation .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListBaseAnnotation .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListBaseAnnotation .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListBaseAnnotation .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListBaseAnnotation .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListBaseAnnotation .)
Top
See Also

Reference

PdfAnnotationList Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PdfAnnotationList.NotifyResourceRenamed Method

PdfAnnotationListNotifyResourceRenamed Method

Notifies the list that the resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection conatining the resource.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

PdfAnnotationList Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PdfAnnotationList.ResourcesUsed Method

PdfAnnotationListResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

PdfAnnotationList Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Class

The PolygonAnnotation represents a filled polygon on the page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPolygonAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPolylineAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PolygonAnnotation : BaseMarkupAnnotation
Public Class PolygonAnnotation
    Inherits BaseMarkupAnnotation

The PolygonAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PolygonAnnotation | Initializes a new instance of the PolygonAnnotation class.
Public method | PolygonAnnotation(IPdfColor, Double, IPdfColor, PdfPoint) | Initializes a new instance of the PolygonAnnotation class with the specified colors and points.
Public method | PolygonAnnotation(IPdfColor, Double, IPdfColor, IEnumerablePdfPoint) | Initializes a new instance of the PolygonAnnotation class with the specified colors and points.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoCalculateBounds | Gets or sets a value indicating whether to automatically calculate the annotation's Bounds.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect for the polygon.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color of the polygon. If the fill color is null, there will be no fill.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsInternalColorTransparent | Gets or sets a value indicating whether the InternalColor is transparent.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LineEnding | Gets the line ending for the polygon. These are only displayed if the polygon is open.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Public property | Vertices | Gets the vertices of the polygon.
Top
Methods
 | Name | Description
Protected method | CalculateBounds |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Protected method | IsVerticesCorrect | Determines whether the vertices are correct for a polygon - returns true if the polygon has at least three vertices.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Constructor

Overload List
 | Name | Description
Public method | PolygonAnnotation | Initializes a new instance of the PolygonAnnotation class.
Public method | PolygonAnnotation(IPdfColor, Double, IPdfColor, PdfPoint) | Initializes a new instance of the PolygonAnnotation class with the specified colors and points.
Public method | PolygonAnnotation(IPdfColor, Double, IPdfColor, IEnumerablePdfPoint) | Initializes a new instance of the PolygonAnnotation class with the specified colors and points.
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Constructor

Initializes a new instance of the PolygonAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation()
Public Sub New
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Constructor (IPdfColor, Double, IPdfColor, PdfPoint[])

PolygonAnnotation Constructor (IPdfColor, Double, IPdfColor, PdfPoint)

Initializes a new instance of the PolygonAnnotation class with the specified colors and points.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor,
    params PdfPoint[] points
)
Public Sub New (
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor,
    ParamArray points As PdfPoint()
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The line width.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
points
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The points.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Constructor (IPdfColor, Double, IPdfColor, IEnumerable(PdfPoint))

PolygonAnnotation Constructor (IPdfColor, Double, IPdfColor, IEnumerablePdfPoint)

Initializes a new instance of the PolygonAnnotation class with the specified colors and points.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolygonAnnotation(
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor,
    IEnumerable<PdfPoint> points
)
Public Sub New (
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor,
    points As IEnumerable(Of PdfPoint)
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The line width.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
points
Type: System.Collections.GenericIEnumerablePdfPoint
The points.
See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Properties

The PolygonAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoCalculateBounds | Gets or sets a value indicating whether to automatically calculate the annotation's Bounds.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect for the polygon.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color of the polygon. If the fill color is null, there will be no fill.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsInternalColorTransparent | Gets or sets a value indicating whether the InternalColor is transparent.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LineEnding | Gets the line ending for the polygon. These are only displayed if the polygon is open.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Public property | Vertices | Gets the vertices of the polygon.
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.AutoCalculateBounds Property

PolygonAnnotationAutoCalculateBounds Property

Gets or sets a value indicating whether to automatically calculate the annotation's Bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoCalculateBounds { get; set; }
Public Property AutoCalculateBounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Bounds will be automatically calculated; otherwise, false.
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.Effect Property

PolygonAnnotationEffect Property

Gets or sets the BorderEffect for the polygon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderEffect Effect { get; set; }
Public Property Effect As BorderEffect
    Get
    Set

Property Value

Type: BorderEffect
The effect.
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.InternalColor Property

PolygonAnnotationInternalColor Property

Gets or sets the fill color of the polygon. If the fill color is null, there will be no fill.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor InternalColor { get; set; }
Public Property InternalColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the internal.
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.IsInternalColorTransparent Property

PolygonAnnotationIsInternalColorTransparent Property

Gets or sets a value indicating whether the InternalColor is transparent.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsInternalColorTransparent { get; set; }
Public Property IsInternalColorTransparent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this the internal color is transparent; otherwise, false.
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.LineEnding Property

PolygonAnnotationLineEnding Property

Gets the line ending for the polygon. These are only displayed if the polygon is open.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LineEndingKind[] LineEnding { get; }
Public ReadOnly Property LineEnding As LineEndingKind()
    Get

Property Value

Type: LineEndingKind
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.Vertices Property

PolygonAnnotationVertices Property

Gets the vertices of the polygon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfPoint> Vertices { get; }
Public ReadOnly Property Vertices As IList(Of PdfPoint)
    Get

Property Value

Type: IListPdfPoint
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation Methods

The PolygonAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateBounds |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Protected method | IsVerticesCorrect | Determines whether the vertices are correct for a polygon - returns true if the polygon has at least three vertices.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.CalculateBounds Method

PolygonAnnotationCalculateBounds Method

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual PdfBounds CalculateBounds()
Protected Overridable Function CalculateBounds As PdfBounds

Return Value

Type: PdfBounds
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.IsVerticesCorrect Method

PolygonAnnotationIsVerticesCorrect Method

Determines whether the vertices are correct for a polygon - returns true if the polygon has at least three vertices.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool IsVerticesCorrect()
Protected Overridable Function IsVerticesCorrect As Boolean

Return Value

Type: Boolean
true if the vertices are correct; otherwise, false.
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolygonAnnotation.ValidateProperties Method

PolygonAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

PolygonAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Class

The PolylineAnnotation represents an unfilled polygon.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPolygonAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPolylineAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PolylineAnnotation : PolygonAnnotation
Public Class PolylineAnnotation
    Inherits PolygonAnnotation

The PolylineAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PolylineAnnotation | Initializes a new instance of the PolylineAnnotation class.
Public method | PolylineAnnotation(IPdfColor, Double, PdfPoint) | Initializes a new instance of the PolylineAnnotation class with the specified colors and points.
Public method | PolylineAnnotation(IPdfColor, Double, IEnumerablePdfPoint) | Initializes a new instance of the PolylineAnnotation class with the specified colors and points.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoCalculateBounds | Gets or sets a value indicating whether to automatically calculate the annotation's Bounds. (Inherited from PolygonAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect for the polygon. (Inherited from PolygonAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color of the polygon. If the fill color is null, there will be no fill. (Inherited from PolygonAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsInternalColorTransparent | Gets or sets a value indicating whether the InternalColor is transparent. (Inherited from PolygonAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LineEnding | Gets the line ending for the polygon. These are only displayed if the polygon is open. (Inherited from PolygonAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Public property | Vertices | Gets the vertices of the polygon. (Inherited from PolygonAnnotation.)
Top
Methods
 | Name | Description
Protected method | CalculateBounds | (Inherited from PolygonAnnotation.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Protected method | IsVerticesCorrect | Determines whether the vertices are correct for a polygon - returns true if the polyline has at least two vertices. (Overrides PolygonAnnotationIsVerticesCorrect.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from PolygonAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Constructor

Overload List
 | Name | Description
Public method | PolylineAnnotation | Initializes a new instance of the PolylineAnnotation class.
Public method | PolylineAnnotation(IPdfColor, Double, PdfPoint) | Initializes a new instance of the PolylineAnnotation class with the specified colors and points.
Public method | PolylineAnnotation(IPdfColor, Double, IEnumerablePdfPoint) | Initializes a new instance of the PolylineAnnotation class with the specified colors and points.
Top
See Also

Reference

PolylineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Constructor

Initializes a new instance of the PolylineAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolylineAnnotation()
Public Sub New
See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Constructor (IPdfColor, Double, PdfPoint[])

PolylineAnnotation Constructor (IPdfColor, Double, PdfPoint)

Initializes a new instance of the PolylineAnnotation class with the specified colors and points.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolylineAnnotation(
    IPdfColor outlineColor,
    double linewidth,
    params PdfPoint[] points
)
Public Sub New (
    outlineColor As IPdfColor,
    linewidth As Double,
    ParamArray points As PdfPoint()
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The line width.
points
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The points.
See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Constructor (IPdfColor, Double, IEnumerable(PdfPoint))

PolylineAnnotation Constructor (IPdfColor, Double, IEnumerablePdfPoint)

Initializes a new instance of the PolylineAnnotation class with the specified colors and points.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PolylineAnnotation(
    IPdfColor outlineColor,
    double linewidth,
    IEnumerable<PdfPoint> points
)
Public Sub New (
    outlineColor As IPdfColor,
    linewidth As Double,
    points As IEnumerable(Of PdfPoint)
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The line width.
points
Type: System.Collections.GenericIEnumerablePdfPoint
The points.
See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Properties

The PolylineAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoCalculateBounds | Gets or sets a value indicating whether to automatically calculate the annotation's Bounds. (Inherited from PolygonAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect for the polygon. (Inherited from PolygonAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color of the polygon. If the fill color is null, there will be no fill. (Inherited from PolygonAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsInternalColorTransparent | Gets or sets a value indicating whether the InternalColor is transparent. (Inherited from PolygonAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LineEnding | Gets the line ending for the polygon. These are only displayed if the polygon is open. (Inherited from PolygonAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Public property | Vertices | Gets the vertices of the polygon. (Inherited from PolygonAnnotation.)
Top
See Also

Reference

PolylineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation Methods

The PolylineAnnotation type exposes the following members.

Methods
 | Name | Description
Protected method | CalculateBounds | (Inherited from PolygonAnnotation.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Protected method | IsVerticesCorrect | Determines whether the vertices are correct for a polygon - returns true if the polyline has at least two vertices. (Overrides PolygonAnnotationIsVerticesCorrect.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from PolygonAnnotation.)
Top
See Also

Reference

PolylineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PolylineAnnotation.IsVerticesCorrect Method

PolylineAnnotationIsVerticesCorrect Method

Determines whether the vertices are correct for a polygon - returns true if the polyline has at least two vertices.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool IsVerticesCorrect()
Protected Overrides Function IsVerticesCorrect As Boolean

Return Value

Type: Boolean
true if the vertices are correct; otherwise, false.
See Also

Reference

PolylineAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation Class

The PopupAnnotation represents an annotation that can be shown or hidden and offers more information about another annotation. Popup annotations never appear singly. They are always associated with an existing annotation via its Popup property and also by setting the ParentAnnotation property to the BaseMarkupAnnotation. When the ParentAnnotation is a BaseMarkupAnnotation, the PopupAnnotation will project properties of the BaseMarkupAnnotation.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPopupAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PopupAnnotation : BaseAnnotation
Public Class PopupAnnotation
    Inherits BaseAnnotation

The PopupAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PopupAnnotation | Initializes a new instance of the PopupAnnotation class.
Public method | PopupAnnotation(PdfBounds, BaseMarkupAnnotation) | Initializes a new instance of the PopupAnnotation class and automatically associates it with the supplied BaseMarkupAnnotation.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author. If the ParentAnnotation is a BaseMarkupAnnotation, the AuthorName property will reflect the parent annotation's AuthorName.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bad of the annotation's pop-up window, the border color of the annotation. If the ParentAnnotation is a BaseMarkupAnnotation, Color will project the parent annotation's color. (Overrides BaseAnnotationColor.)
Public property | Contents | Gets or sets the text contents of the annotation. If the ParentAnnotation is a BaseMarkupAnnotation, Contents will reflect that annotation's Contents. (Overrides BaseAnnotationContents.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsOpen | Gets or sets a value indicating whether popup is open.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. If the ParentAnnotation is a BaseMarkupAnnotation, the ModificationDate will project the parent annotation's ModificationDate. (Overrides BaseAnnotationModificationDate.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentAnnotation | Gets or sets the parent annotation to this popup. This property must be set.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation Constructor

Overload List
 | Name | Description
Public method | PopupAnnotation | Initializes a new instance of the PopupAnnotation class.
Public method | PopupAnnotation(PdfBounds, BaseMarkupAnnotation) | Initializes a new instance of the PopupAnnotation class and automatically associates it with the supplied BaseMarkupAnnotation.
Top
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation Constructor

Initializes a new instance of the PopupAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PopupAnnotation()
Public Sub New
See Also

Reference

PopupAnnotation Class
PopupAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation Constructor (PdfBounds, BaseMarkupAnnotation)

Initializes a new instance of the PopupAnnotation class and automatically associates it with the supplied BaseMarkupAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PopupAnnotation(
    PdfBounds bounds,
    BaseMarkupAnnotation parentAnnotation
)
Public Sub New (
    bounds As PdfBounds,
    parentAnnotation As BaseMarkupAnnotation
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
parentAnnotation
Type: Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
The parent annotation.
See Also

Reference

PopupAnnotation Class
PopupAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation Properties

The PopupAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author. If the ParentAnnotation is a BaseMarkupAnnotation, the AuthorName property will reflect the parent annotation's AuthorName.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bad of the annotation's pop-up window, the border color of the annotation. If the ParentAnnotation is a BaseMarkupAnnotation, Color will project the parent annotation's color. (Overrides BaseAnnotationColor.)
Public property | Contents | Gets or sets the text contents of the annotation. If the ParentAnnotation is a BaseMarkupAnnotation, Contents will reflect that annotation's Contents. (Overrides BaseAnnotationContents.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsOpen | Gets or sets a value indicating whether popup is open.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. If the ParentAnnotation is a BaseMarkupAnnotation, the ModificationDate will project the parent annotation's ModificationDate. (Overrides BaseAnnotationModificationDate.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentAnnotation | Gets or sets the parent annotation to this popup. This property must be set.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation.AuthorName Property

PopupAnnotationAuthorName Property

Gets or sets the name of the author. If the ParentAnnotation is a BaseMarkupAnnotation, the AuthorName property will reflect the parent annotation's AuthorName.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AuthorName { get; set; }
Public Property AuthorName As String
    Get
    Set

Property Value

Type: String
The name of the author.
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation.Color Property

PopupAnnotationColor Property

Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bad of the annotation's pop-up window, the border color of the annotation. If the ParentAnnotation is a BaseMarkupAnnotation, Color will project the parent annotation's color.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override IPdfColor Color { get; set; }
Public Overrides Property Color As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color.
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation.Contents Property

PopupAnnotationContents Property

Gets or sets the text contents of the annotation. If the ParentAnnotation is a BaseMarkupAnnotation, Contents will reflect that annotation's Contents.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string Contents { get; set; }
Public Overrides Property Contents As String
    Get
    Set

Property Value

Type: String
The contents text.
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation.IsOpen Property

PopupAnnotationIsOpen Property

Gets or sets a value indicating whether popup is open.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup is open; otherwise, false.
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation.ModificationDate Property

PopupAnnotationModificationDate Property

Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. If the ParentAnnotation is a BaseMarkupAnnotation, the ModificationDate will project the parent annotation's ModificationDate.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override DateTime ModificationDate { get; set; }
Public Overrides Property ModificationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
The modification date.
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation.ParentAnnotation Property

PopupAnnotationParentAnnotation Property

Gets or sets the parent annotation to this popup. This property must be set.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BaseAnnotation ParentAnnotation { get; set; }
Public Property ParentAnnotation As BaseAnnotation
    Get
    Set

Property Value

Type: BaseAnnotation
The parent annotation.
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PopupAnnotation Methods

The PopupAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseAnnotation.)
Top
See Also

Reference

PopupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Class

A PushButtonWidgetAnnotation represents a clickable button on a page. A pushbutton annotation doesn't have any actions associated by default and need to be set in the ClickActions property.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseButtonWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsPushButtonWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PushButtonWidgetAnnotation : BaseButtonWidgetAnnotation
Public Class PushButtonWidgetAnnotation
    Inherits BaseButtonWidgetAnnotation

The PushButtonWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PushButtonWidgetAnnotation | Initializes a new instance of the PushButtonWidgetAnnotation class.
Public method | PushButtonWidgetAnnotation(PdfBounds, String) | Initializes a new instance of the PushButtonWidgetAnnotation class with the given bounds and name.
Public method | PushButtonWidgetAnnotation(PdfBounds, String, String) | Initializes a new instance of the PushButtonWidgetAnnotation class with the given bounds, name, and export name.
Public method | PushButtonWidgetAnnotation(PdfBounds, String, String, String) | Initializes a new instance of the PushButtonWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether auto generate a basic appearance. Default is true.
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button. (Inherited from BaseButtonWidgetAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string. Always returns null - pushbuttons don't have a value. (Overrides BaseWidgetAnnotationValueAsString.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a PushButtonFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
 | MakeBasicAppearance | Makes the a basic button appearance, installs it in the resources and returns its name. This makes a simple round-cornered rectangle with the text centered in it.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Constructor

Overload List
 | Name | Description
Public method | PushButtonWidgetAnnotation | Initializes a new instance of the PushButtonWidgetAnnotation class.
Public method | PushButtonWidgetAnnotation(PdfBounds, String) | Initializes a new instance of the PushButtonWidgetAnnotation class with the given bounds and name.
Public method | PushButtonWidgetAnnotation(PdfBounds, String, String) | Initializes a new instance of the PushButtonWidgetAnnotation class with the given bounds, name, and export name.
Public method | PushButtonWidgetAnnotation(PdfBounds, String, String, String) | Initializes a new instance of the PushButtonWidgetAnnotation class.
Top
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Constructor

Initializes a new instance of the PushButtonWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushButtonWidgetAnnotation()
Public Sub New
See Also

Reference

PushButtonWidgetAnnotation Class
PushButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Constructor (PdfBounds, String)

Initializes a new instance of the PushButtonWidgetAnnotation class with the given bounds and name.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushButtonWidgetAnnotation(
    PdfBounds bounds,
    string name
)
Public Sub New (
    bounds As PdfBounds,
    name As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
name
Type: SystemString
The name of the field.
See Also

Reference

PushButtonWidgetAnnotation Class
PushButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Constructor (PdfBounds, String, String)

Initializes a new instance of the PushButtonWidgetAnnotation class with the given bounds, name, and export name.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushButtonWidgetAnnotation(
    PdfBounds bounds,
    string name,
    string nameForUI
)
Public Sub New (
    bounds As PdfBounds,
    name As String,
    nameForUI As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
name
Type: SystemString
The name.
nameForUI
Type: SystemString
The name for UI.
See Also

Reference

PushButtonWidgetAnnotation Class
PushButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Constructor (PdfBounds, String, String, String)

Initializes a new instance of the PushButtonWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushButtonWidgetAnnotation(
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport
)
Public Sub New (
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
name
Type: SystemString
The name of the field.
nameForUI
Type: SystemString
The name for UI.
nameForExport
Type: SystemString
The name for export.
See Also

Reference

PushButtonWidgetAnnotation Class
PushButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Properties

The PushButtonWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether auto generate a basic appearance. Default is true.
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button. (Inherited from BaseButtonWidgetAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string. Always returns null - pushbuttons don't have a value. (Overrides BaseWidgetAnnotationValueAsString.)
Top
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation.AutoGenerateBasicAppearance Property

PushButtonWidgetAnnotationAutoGenerateBasicAppearance Property

Gets or sets a value indicating whether auto generate a basic appearance. Default is true.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateBasicAppearance { get; set; }
Public Property AutoGenerateBasicAppearance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the annotation will auto generate a basic appearance; otherwise, false.
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation.DefaultValueAsString Property

PushButtonWidgetAnnotationDefaultValueAsString Property

Gets the default value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DefaultValueAsString { get; }
Public Overrides ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation.ValueAsString Property

PushButtonWidgetAnnotationValueAsString Property

Gets the value as string. Always returns null - pushbuttons don't have a value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation Methods

The PushButtonWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a PushButtonFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
 | MakeBasicAppearance | Makes the a basic button appearance, installs it in the resources and returns its name. This makes a simple round-cornered rectangle with the text centered in it.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation.IsValidChildOf Method

PushButtonWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a PushButtonFormField

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidChildOf(
    IFormElement elem
)
Public Overrides Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation.MakeBasicAppearance Method

PushButtonWidgetAnnotationMakeBasicAppearance Method

Makes the a basic button appearance, installs it in the resources and returns its name. This makes a simple round-cornered rectangle with the text centered in it.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string MakeBasicAppearance(
    GlobalResources gr,
    PdfBounds bounds,
    PdfTextAppearance app,
    double borderWidth,
    IPdfColor outlineColor,
    IPdfColor fillColor,
    string value
)
Public Shared Function MakeBasicAppearance (
    gr As GlobalResources,
    bounds As PdfBounds,
    app As PdfTextAppearance,
    borderWidth As Double,
    outlineColor As IPdfColor,
    fillColor As IPdfColor,
    value As String
) As String

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the button..
app
Type: Atalasoft.PdfDoc.Generating.RenderingPdfTextAppearance
The appearance of the text in the button.
borderWidth
Type: SystemDouble
Width of the border.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
value
Type: SystemString
The text label for the button.

Return Value

Type: String
The name of a basic button appearance that has been installed in the resources.
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


PushButtonWidgetAnnotation.ValidateProperties Method

PushButtonWidgetAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

PushButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Class

The RadioButtonWidgetAnnotation represents a possible selection in a set of choices. Typically, the act of selecting a radio button annotation will have the side effect of de-selecting one or more others. As a result, a single RadioButtonWidgetAnnotation is not particularly useful on its own. Grouping is managed by making each button in the group be a child of a RadioButtonFormField. This is done by creating a RadioButtonWidgetAnnotation for each button, giving each a unique "on value", setting each in the ChildFields collection of the parent field and putting the annotations into a page. It is far easier to use MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) which will construct the parent field and all the radio buttons and wire them up correctly. If you use the standard appearances, the radio button's appearance will not have any text associated with it. It will instead just be the button itself. It is the responsibility of the client code to provide labels.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseButtonWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRadioButtonWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RadioButtonWidgetAnnotation : BaseButtonWidgetAnnotation
Public Class RadioButtonWidgetAnnotation
    Inherits BaseButtonWidgetAnnotation

The RadioButtonWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | RadioButtonWidgetAnnotation | Initializes a new instance of the RadioButtonWidgetAnnotation class.
Public method | RadioButtonWidgetAnnotation(GlobalResources, PdfBounds, String, String, String, String) | Initializes a new instance of the RadioButtonWidgetAnnotation class.
Public method | RadioButtonWidgetAnnotation(GlobalResources, PdfBounds, String, String, String, String, Boolean) | Initializes a new instance of the RadioButtonWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button. (Inherited from BaseButtonWidgetAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
 | ClearedValue | Gets the standard cleared value.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValue | Gets or sets the default value.
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Value | Gets or sets the current value.
Public property | ValueAsString | Gets the value as string. (Overrides BaseWidgetAnnotationValueAsString.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a RadioButtonFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Constructor

Overload List
 | Name | Description
Public method | RadioButtonWidgetAnnotation | Initializes a new instance of the RadioButtonWidgetAnnotation class.
Public method | RadioButtonWidgetAnnotation(GlobalResources, PdfBounds, String, String, String, String) | Initializes a new instance of the RadioButtonWidgetAnnotation class.
Public method | RadioButtonWidgetAnnotation(GlobalResources, PdfBounds, String, String, String, String, Boolean) | Initializes a new instance of the RadioButtonWidgetAnnotation class.
Top
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Constructor

Initializes a new instance of the RadioButtonWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RadioButtonWidgetAnnotation()
Public Sub New
See Also

Reference

RadioButtonWidgetAnnotation Class
RadioButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Constructor (GlobalResources, PdfBounds, String, String, String, String)

Initializes a new instance of the RadioButtonWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RadioButtonWidgetAnnotation(
    GlobalResources gr,
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport,
    string onValue
)
Public Sub New (
    gr As GlobalResources,
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String,
    onValue As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection to hold the appearance.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the button.
name
Type: SystemString
The field name.
nameForUI
Type: SystemString
The name for UI.
nameForExport
Type: SystemString
The name for export.
onValue
Type: SystemString
The on value which is used to identify the appearance of a selected item.
See Also

Reference

RadioButtonWidgetAnnotation Class
RadioButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Constructor (GlobalResources, PdfBounds, String, String, String, String, Boolean)

Initializes a new instance of the RadioButtonWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RadioButtonWidgetAnnotation(
    GlobalResources gr,
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport,
    string onValue,
    bool useStandardAppearances
)
Public Sub New (
    gr As GlobalResources,
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String,
    onValue As String,
    useStandardAppearances As Boolean
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resource collection to hold the appearance.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the button.
name
Type: SystemString
The field name.
nameForUI
Type: SystemString
The name for UI.
nameForExport
Type: SystemString
The name for export.
onValue
Type: SystemString
The on value which is used to identify the appearance of a selected item.
useStandardAppearances
Type: SystemBoolean
if set to true use standard radio button appearances.
See Also

Reference

RadioButtonWidgetAnnotation Class
RadioButtonWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Properties

The RadioButtonWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | Caption | Gets or sets the text displayed on the button. (Inherited from BaseButtonWidgetAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
 | ClearedValue | Gets the standard cleared value.
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValue | Gets or sets the default value.
Public property | DefaultValueAsString | Gets the default value as string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Value | Gets or sets the current value.
Public property | ValueAsString | Gets the value as string. (Overrides BaseWidgetAnnotationValueAsString.)
Top
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.ClearedValue Property

RadioButtonWidgetAnnotationClearedValue Property

Gets the standard cleared value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string ClearedValue { get; }
Public Shared ReadOnly Property ClearedValue As String
    Get

Property Value

Type: String
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.DefaultValue Property

RadioButtonWidgetAnnotationDefaultValue Property

Gets or sets the default value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set

Property Value

Type: String
The default value.
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.DefaultValueAsString Property

RadioButtonWidgetAnnotationDefaultValueAsString Property

Gets the default value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DefaultValueAsString { get; }
Public Overrides ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.Value Property

RadioButtonWidgetAnnotationValue Property

Gets or sets the current value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value.
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.ValueAsString Property

RadioButtonWidgetAnnotationValueAsString Property

Gets the value as string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation Methods

The RadioButtonWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a RadioButtonFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.IsValidChildOf Method

RadioButtonWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a RadioButtonFormField

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidChildOf(
    IFormElement elem
)
Public Overrides Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RadioButtonWidgetAnnotation.ValidateProperties Method

RadioButtonWidgetAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

RadioButtonWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation Class

A RectangleAnnotation represents a rectangle drawn on the page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRectangleAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsEllipseAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RectangleAnnotation : BaseMarkupAnnotation
Public Class RectangleAnnotation
    Inherits BaseMarkupAnnotation

The RectangleAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleAnnotation | Initializes a new instance of the RectangleAnnotation class.
Public method | RectangleAnnotation(PdfBounds) | Initializes a new instance of the RectangleAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation Constructor

Overload List
 | Name | Description
Public method | RectangleAnnotation | Initializes a new instance of the RectangleAnnotation class.
Public method | RectangleAnnotation(PdfBounds) | Initializes a new instance of the RectangleAnnotation class.
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation Constructor

Initializes a new instance of the RectangleAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation()
Public Sub New
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation Constructor (PdfBounds)

Initializes a new instance of the RectangleAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rectangle.
See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation Properties

The RectangleAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the BorderEffect.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | InternalColor | Gets or sets the fill color.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation.Effect Property

RectangleAnnotationEffect Property

Gets or sets the BorderEffect.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderEffect Effect { get; set; }
Public Property Effect As BorderEffect
    Get
    Set

Property Value

Type: BorderEffect
The effect.
See Also

Reference

RectangleAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation.InternalColor Property

RectangleAnnotationInternalColor Property

Gets or sets the fill color.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor InternalColor { get; set; }
Public Property InternalColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The fill color.
See Also

Reference

RectangleAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation Methods

The RectangleAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

RectangleAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RectangleAnnotation.ValidateProperties Method

RectangleAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

RectangleAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation Class

The RedactionProposalAnnotation is a BaseMarkupAnnotation that is used to mark areas within a document that are proposed for redaction. The creation of this annotation on a page does not remove any content below it. That is left strictly to the PDF viewer and may or may not be supported. This particular annotation was only supported beginning with PDF version 1.7 and should be used with care. When a compliant viewer performs redaction based on one or more RedactionProposalAnnotation objects, it is instructed to remove all content under the area or areas specified and will remove the annotation but insert new content in its place. This content depends on the specification of the annotation. If the annotation does not specify any quadrilaterals in the Regions property, the area will be a rectangle specified by Bounds that is filled with the RedactionInteriorColor or black if none has been specified. If there are Regions specified, they will be used instead of Bounds. If OverlayText is specified, this text will be overlayed on top of the redacted area. If IsOverlayTextRepeated is true, then the text will be laid down in a repeating pattern. If RedactionTemplate is set, this template will be used for the redaction instead of all of the previous elements.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRedactionProposalAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RedactionProposalAnnotation : BaseMarkupAnnotation
Public Class RedactionProposalAnnotation
    Inherits BaseMarkupAnnotation

The RedactionProposalAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | RedactionProposalAnnotation | Initializes a new instance of the RedactionProposalAnnotation class with empty bounds.
Public method | RedactionProposalAnnotation(PdfBounds) | Initializes a new instance of the RedactionProposalAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether to auto generate a basic appearance for the proposed redaction. Generation of the appearance happens when the document is saved.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point.
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsOverlayTextRepeated | Gets or sets a value indicating whether the OverlayText, if present, will be repeated.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | OverlayText | Gets or sets the overlay text that will be used on the redaction when placed.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RedactionInteriorColor | Gets or sets the color of the interior of the redacted area. If not set, the redacted area will be transparent.
Public property | RedactionTemplate | Gets or sets the name of a template resource to be used when the redaction is applied. If specified, this template will take precedence over all other appearance related properties.
Public property | Regions | Gets the regions for this annotation. Regions represents a set of quadrilaterals each of which represent the area covered by the annotation. Typically, parts of the annotation are drawn through sections of the quatrilateral. For example, underlines are drawn across the bottom of the annotation, strike outs through the middle.
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
 | MakeBasicAppearance | Makes the basic appearance for the annotation. Unlike CheckboxWidgetAnnotation, TextWidgetAnnotation can't easily share the same appearance since appearances are geometrically scaled to fit the bounds of the annotation. This means that border outlines will grow or shrink when drawn. When the Bounds of the annotation change, the appearance needs to be rebuilt in order to render correctly in the document. This method is provided so that, for example, client code might add in custom coloring or easily build consistent appearances for when the annotation has been cliecked on or when it is rolled over.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from BaseMarkupAnnotation.)
Top
Examples
This example shows how to detect if a document contains any RedactionProposalAnnotation objects. This might be useful in flagging a document to prevent it from being sent out if the redactions have not been applied.
Copy
public static bool PageHasRedactions(PdfGeneratedPage page)
{
    if (page == null) throw new Exception("page was null or not a PdfGeneratedPage.");
    foreach (BaseAnnotation annot in page.Annotations) {
        if (annot is RedactionProposalAnnotation) return true;
    }
    return false;
}

public static bool DocumentHasRedactions(PdfGeneratedDocument doc)
{
    foreach (BasePage page in doc.Pages)
    {
        // page argument will be null if BasePage is not a PdfGeneratedPage
        // this would happen if the document was opened without the "attempt to import foreign content" flag set.
        if (PageHasRedactions(page as PdfGeneratedPage)) return true;
    }
    return false;
}
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation Constructor

Overload List
 | Name | Description
Public method | RedactionProposalAnnotation | Initializes a new instance of the RedactionProposalAnnotation class with empty bounds.
Public method | RedactionProposalAnnotation(PdfBounds) | Initializes a new instance of the RedactionProposalAnnotation class.
Top
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation Constructor

Initializes a new instance of the RedactionProposalAnnotation class with empty bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RedactionProposalAnnotation()
Public Sub New
See Also

Reference

RedactionProposalAnnotation Class
RedactionProposalAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation Constructor (PdfBounds)

Initializes a new instance of the RedactionProposalAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RedactionProposalAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

RedactionProposalAnnotation Class
RedactionProposalAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation Properties

The RedactionProposalAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether to auto generate a basic appearance for the proposed redaction. Generation of the appearance happens when the document is saved.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point.
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsOverlayTextRepeated | Gets or sets a value indicating whether the OverlayText, if present, will be repeated.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | OverlayText | Gets or sets the overlay text that will be used on the redaction when placed.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RedactionInteriorColor | Gets or sets the color of the interior of the redacted area. If not set, the redacted area will be transparent.
Public property | RedactionTemplate | Gets or sets the name of a template resource to be used when the redaction is applied. If specified, this template will take precedence over all other appearance related properties.
Public property | Regions | Gets the regions for this annotation. Regions represents a set of quadrilaterals each of which represent the area covered by the annotation. Typically, parts of the annotation are drawn through sections of the quatrilateral. For example, underlines are drawn across the bottom of the annotation, strike outs through the middle.
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.AutoGenerateBasicAppearance Property

RedactionProposalAnnotationAutoGenerateBasicAppearance Property

Gets or sets a value indicating whether to auto generate a basic appearance for the proposed redaction. Generation of the appearance happens when the document is saved.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateBasicAppearance { get; set; }
Public Property AutoGenerateBasicAppearance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the annotation will make a basic appearance; otherwise, false.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.DefaultTextAppearance Property

RedactionProposalAnnotationDefaultTextAppearance Property

Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance DefaultTextAppearance { get; set; }
Public Property DefaultTextAppearance As PdfTextAppearance
    Get
    Set

Property Value

Type: PdfTextAppearance
The default text appearance.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.IsOverlayTextRepeated Property

RedactionProposalAnnotationIsOverlayTextRepeated Property

Gets or sets a value indicating whether the OverlayText, if present, will be repeated.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsOverlayTextRepeated { get; set; }
Public Property IsOverlayTextRepeated As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the OverlayText, if present, will be repeated; otherwise, false.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.OverlayText Property

RedactionProposalAnnotationOverlayText Property

Gets or sets the overlay text that will be used on the redaction when placed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OverlayText { get; set; }
Public Property OverlayText As String
    Get
    Set

Property Value

Type: String
The overlay text.
Remarks
This value will be ignored if the RedactionTemplate is set.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.RedactionInteriorColor Property

RedactionProposalAnnotationRedactionInteriorColor Property

Gets or sets the color of the interior of the redacted area. If not set, the redacted area will be transparent.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfRgbColor RedactionInteriorColor { get; set; }
Public Property RedactionInteriorColor As IPdfRgbColor
    Get
    Set

Property Value

Type: IPdfRgbColor
The color of the interior of the redacted area.
Remarks
This color is applied after the redaction has been applied by a PDF viewer. If RedactionTemplate is set, this will be ignored.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.RedactionTemplate Property

RedactionProposalAnnotationRedactionTemplate Property

Gets or sets the name of a template resource to be used when the redaction is applied. If specified, this template will take precedence over all other appearance related properties.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string RedactionTemplate { get; set; }
Public Property RedactionTemplate As String
    Get
    Set

Property Value

Type: String
The redaction template.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.Regions Property

RedactionProposalAnnotationRegions Property

Gets the regions for this annotation. Regions represents a set of quadrilaterals each of which represent the area covered by the annotation. Typically, parts of the annotation are drawn through sections of the quatrilateral. For example, underlines are drawn across the bottom of the annotation, strike outs through the middle.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateralCollection Regions { get; }
Public ReadOnly Property Regions As PdfQuadrilateralCollection
    Get

Property Value

Type: PdfQuadrilateralCollection
Remarks
If not used, the Bounds property will be used instead. If used, the Bounds property will be adjusted to contain the entire set of quadrilaterals within Regions.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.TextAlignment Property

RedactionProposalAnnotationTextAlignment Property

Gets or sets the text alignment.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As AnnotationTextAlignment
    Get
    Set

Property Value

Type: AnnotationTextAlignment
The text alignment.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation Methods

The RedactionProposalAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
 | MakeBasicAppearance | Makes the basic appearance for the annotation. Unlike CheckboxWidgetAnnotation, TextWidgetAnnotation can't easily share the same appearance since appearances are geometrically scaled to fit the bounds of the annotation. This means that border outlines will grow or shrink when drawn. When the Bounds of the annotation change, the appearance needs to be rebuilt in order to render correctly in the document. This method is provided so that, for example, client code might add in custom coloring or easily build consistent appearances for when the annotation has been cliecked on or when it is rolled over.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RedactionProposalAnnotation.MakeBasicAppearance Method

RedactionProposalAnnotationMakeBasicAppearance Method

Makes the basic appearance for the annotation. Unlike CheckboxWidgetAnnotation, TextWidgetAnnotation can't easily share the same appearance since appearances are geometrically scaled to fit the bounds of the annotation. This means that border outlines will grow or shrink when drawn. When the Bounds of the annotation change, the appearance needs to be rebuilt in order to render correctly in the document. This method is provided so that, for example, client code might add in custom coloring or easily build consistent appearances for when the annotation has been cliecked on or when it is rolled over.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string MakeBasicAppearance(
    GlobalResources gr,
    PdfBounds bounds,
    PdfQuadrilateralCollection quads,
    double borderWidth,
    IPdfColor outlineColor
)
Public Shared Function MakeBasicAppearance (
    gr As GlobalResources,
    bounds As PdfBounds,
    quads As PdfQuadrilateralCollection,
    borderWidth As Double,
    outlineColor As IPdfColor
) As String

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resources that will hold the appearance.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
quads
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateralCollection
An optionally empty or null collection of quadrilaterals to be marked.
borderWidth
Type: SystemDouble
Width of the border.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.

Return Value

Type: String
A string which is the name of an template resource that will represent the annotation's appearance.
See Also

Reference

RedactionProposalAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReplyRelation Enumeration

Represents the type of reply a BaseMarkupAnnotation represents.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ReplyRelation
Public Enumeration ReplyRelation
Members
Member name | Description
Reply | A direct reply
Group | A group element
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess Class

StickyNoteAnnotation objects can be use to mark documents for being in a particular review state. The process of review is represented by the ReviewProcess class. ReviewProcess is an abstract class and is not used directly.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsReviewProcess
Atalasoft.PdfDoc.Generating.AnnotationsGeneralReview
Atalasoft.PdfDoc.Generating.AnnotationsMarkingReview
Atalasoft.PdfDoc.Generating.AnnotationsUnknownReview

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class ReviewProcess
Public MustInherit Class ReviewProcess

The ReviewProcess type exposes the following members.

Constructors
 | Name | Description
Protected method | ReviewProcess | Initializes a new instance of the ReviewProcess class defining the valid states for the review.
Top
Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates
Public property | ProcessName | Gets the name of the review process.
Public property | StateName | Gets the name of the current review state.
Public property | ValidStates | Gets the valid states for this ReviewProcess
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess Constructor

Initializes a new instance of the ReviewProcess class defining the valid states for the review.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ReviewProcess(
    string[] validStates
)
Protected Sub New (
    validStates As String()
)

Parameters

validStates
Type: SystemString
The valid states.
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess Properties

The ReviewProcess type exposes the following members.

Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates
Public property | ProcessName | Gets the name of the review process.
Public property | StateName | Gets the name of the current review state.
Public property | ValidStates | Gets the valid states for this ReviewProcess
Top
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess.CurrentState Property

ReviewProcessCurrentState Property

Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CurrentState { get; set; }
Public Property CurrentState As Integer
    Get
    Set

Property Value

Type: Int32
The state of the current review.
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess.ProcessName Property

ReviewProcessProcessName Property

Gets the name of the review process.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract string ProcessName { get; }
Public MustOverride ReadOnly Property ProcessName As String
    Get

Property Value

Type: String
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess.StateName Property

ReviewProcessStateName Property

Gets the name of the current review state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string StateName { get; }
Public ReadOnly Property StateName As String
    Get

Property Value

Type: String
The name of the state.
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess.ValidStates Property

ReviewProcessValidStates Property

Gets the valid states for this ReviewProcess

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOnlyCollection<string> ValidStates { get; }
Public ReadOnly Property ValidStates As ReadOnlyCollection(Of String)
    Get

Property Value

Type: ReadOnlyCollectionString
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess Methods

The ReviewProcess type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ReviewProcess.SetCurrentState Method

ReviewProcessSetCurrentState Method

Sets the review state by name. If the name is not a valid state, this will revert to the 0th state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetCurrentState(
    string name
)
Public Sub SetCurrentState (
    name As String
)

Parameters

name
Type: SystemString
The name of the state.
See Also

Reference

ReviewProcess Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Class

A RubberStampAnnotation represents a canned set of markings for a document that appear as if the document had been stamped.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsRubberStampAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RubberStampAnnotation : BaseMarkupAnnotation
Public Class RubberStampAnnotation
    Inherits BaseMarkupAnnotation

The RubberStampAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | RubberStampAnnotation | Initializes a new instance of the RubberStampAnnotation class.
Public method | RubberStampAnnotation(PdfBounds) | Initializes a new instance of the RubberStampAnnotation class with the provided bounds and the RubberStampKind of 'Draft'.
Public method | RubberStampAnnotation(String, PdfBounds) | Initializes a new instance of the RubberStampAnnotation class. Not all PDF readers are required to handle arbitrary stamp strings.
Public method | RubberStampAnnotation(RubberStampKind, PdfBounds) | Initializes a new instance of the RubberStampAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | StampLabel | Gets or sets the stamp label.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
 | StringFromRubberStampKind | Returns the string equivalent of the given RubberStampKind.
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Constructor

Overload List
 | Name | Description
Public method | RubberStampAnnotation | Initializes a new instance of the RubberStampAnnotation class.
Public method | RubberStampAnnotation(PdfBounds) | Initializes a new instance of the RubberStampAnnotation class with the provided bounds and the RubberStampKind of 'Draft'.
Public method | RubberStampAnnotation(String, PdfBounds) | Initializes a new instance of the RubberStampAnnotation class. Not all PDF readers are required to handle arbitrary stamp strings.
Public method | RubberStampAnnotation(RubberStampKind, PdfBounds) | Initializes a new instance of the RubberStampAnnotation class.
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Constructor

Initializes a new instance of the RubberStampAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation()
Public Sub New
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Constructor (PdfBounds)

Initializes a new instance of the RubberStampAnnotation class with the provided bounds and the RubberStampKind of 'Draft'.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Constructor (String, PdfBounds)

Initializes a new instance of the RubberStampAnnotation class. Not all PDF readers are required to handle arbitrary stamp strings.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    string stampLabel,
    PdfBounds bounds
)
Public Sub New (
    stampLabel As String,
    bounds As PdfBounds
)

Parameters

stampLabel
Type: SystemString
The stamp label as text.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Constructor (RubberStampKind, PdfBounds)

Initializes a new instance of the RubberStampAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RubberStampAnnotation(
    RubberStampKind label,
    PdfBounds bounds
)
Public Sub New (
    label As RubberStampKind,
    bounds As PdfBounds
)

Parameters

label
Type: Atalasoft.PdfDoc.Generating.AnnotationsRubberStampKind
The kind of rubber stamp.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

RubberStampAnnotation Class
RubberStampAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Properties

The RubberStampAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | StampLabel | Gets or sets the stamp label.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation.StampLabel Property

RubberStampAnnotationStampLabel Property

Gets or sets the stamp label.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string StampLabel { get; set; }
Public Property StampLabel As String
    Get
    Set

Property Value

Type: String
The stamp label.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation Methods

The RubberStampAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
 | StringFromRubberStampKind | Returns the string equivalent of the given RubberStampKind.
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

RubberStampAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation.StringFromRubberStampKind Method

RubberStampAnnotationStringFromRubberStampKind Method

Returns the string equivalent of the given RubberStampKind.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string StringFromRubberStampKind(
    RubberStampKind kind
)
Public Shared Function StringFromRubberStampKind (
    kind As RubberStampKind
) As String

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsRubberStampKind
The kind of the rubber stamp.

Return Value

Type: String
A string equivalent of the RubberStampKind
See Also

Reference

RubberStampAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampAnnotation.ValidateProperties Method

RubberStampAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

RubberStampAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


RubberStampKind Enumeration

Determines how a rubber stamp will appear from the set of standard PDF types.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RubberStampKind
Public Enumeration RubberStampKind
Members
Member name | Description
Draft | The text "Draft".
Approved | The text "Approved.
Experimental | The text "Experimental"
NotApproved | The text "Not Approved"
AsIs | The text "As Is"
Expired | The text "Expired"
NotForPublicRelease | The text "Not For Public Release"
Confidential | The text "Confidential"
Final | The text "Final"
Sold | The text "Sold"
Departmental | The text "Departmental"
ForComment | The text "For Comment"
TopSecret | The text "Top Secret"
ForPublicRelease | The text "For Public Release"
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation Class

A SignatureWidgetAnnotation represents an area on a page that can be signed by the recipient of a document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsSignatureWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SignatureWidgetAnnotation : BaseWidgetAnnotation
Public Class SignatureWidgetAnnotation
    Inherits BaseWidgetAnnotation

The SignatureWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | SignatureWidgetAnnotation | Initializes a new instance of the SignatureWidgetAnnotation class.
Public method | SignatureWidgetAnnotation(PdfBounds, String, String, String) | Initializes a new instance of the SignatureWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. Returns null. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldDisallowChangeAction | Gets the action to take for allowing or disallowing changes to fields after signing this widget.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | FieldsChangeSet | Gets the list of fields that will be allowed or disallowed by FieldDisallowChangeAction.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsSigned | Gets a value indicating whether the signature widget annotation has already been signed.
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string. Returns null. (Overrides BaseWidgetAnnotationValueAsString.)
Top
Methods
 | Name | Description
Public method | AreFieldChangesDisallowedBySigning | Determines whether changes to the supplied IFormElement would be disallowed by signing this widget.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a SignatureFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
 | MakeBasicAppearance | Makes a basic appearance for using supplied signature information.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Public method | SetFieldsToLock | Sets the fields to set to read only or leave alone when this widget is signed.
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseWidgetAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation Constructor

Overload List
 | Name | Description
Public method | SignatureWidgetAnnotation | Initializes a new instance of the SignatureWidgetAnnotation class.
Public method | SignatureWidgetAnnotation(PdfBounds, String, String, String) | Initializes a new instance of the SignatureWidgetAnnotation class.
Top
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation Constructor

Initializes a new instance of the SignatureWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureWidgetAnnotation()
Public Sub New
See Also

Reference

SignatureWidgetAnnotation Class
SignatureWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation Constructor (PdfBounds, String, String, String)

Initializes a new instance of the SignatureWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureWidgetAnnotation(
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport
)
Public Sub New (
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
name
Type: SystemString
The name of the field.
nameForUI
Type: SystemString
The name displayed in the UI.
nameForExport
Type: SystemString
The name for data export.
See Also

Reference

SignatureWidgetAnnotation Class
SignatureWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation Properties

The SignatureWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultValueAsString | Gets the default value as string. Returns null. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldDisallowChangeAction | Gets the action to take for allowing or disallowing changes to fields after signing this widget.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | FieldsChangeSet | Gets the list of fields that will be allowed or disallowed by FieldDisallowChangeAction.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsSigned | Gets a value indicating whether the signature widget annotation has already been signed.
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as string. Returns null. (Overrides BaseWidgetAnnotationValueAsString.)
Top
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.DefaultValueAsString Property

SignatureWidgetAnnotationDefaultValueAsString Property

Gets the default value as string. Returns null.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DefaultValueAsString { get; }
Public Overrides ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.FieldDisallowChangeAction Property

SignatureWidgetAnnotationFieldDisallowChangeAction Property

Gets the action to take for allowing or disallowing changes to fields after signing this widget.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FieldDisallowChangeAction FieldDisallowChangeAction { get; }
Public ReadOnly Property FieldDisallowChangeAction As FieldDisallowChangeAction
    Get

Property Value

Type: FieldDisallowChangeAction
The field disallow change action.
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.FieldsChangeSet Property

SignatureWidgetAnnotationFieldsChangeSet Property

Gets the list of fields that will be allowed or disallowed by FieldDisallowChangeAction.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReadOnlyCollection<IFormElement> FieldsChangeSet { get; }
Public ReadOnly Property FieldsChangeSet As ReadOnlyCollection(Of IFormElement)
    Get

Property Value

Type: ReadOnlyCollectionIFormElement
The fields change set.
Remarks
If FieldDisallowChangeAction is set to IncludeAll, this list will be empty.
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.IsSigned Property

SignatureWidgetAnnotationIsSigned Property

Gets a value indicating whether the signature widget annotation has already been signed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSigned { get; }
Public ReadOnly Property IsSigned As Boolean
    Get

Property Value

Type: Boolean
true if the annotation is signed; otherwise, false.
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.ValueAsString Property

SignatureWidgetAnnotationValueAsString Property

Gets the value as string. Returns null.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation Methods

The SignatureWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | AreFieldChangesDisallowedBySigning | Determines whether changes to the supplied IFormElement would be disallowed by signing this widget.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a SignatureFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
 | MakeBasicAppearance | Makes a basic appearance for using supplied signature information.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Public method | SetFieldsToLock | Sets the fields to set to read only or leave alone when this widget is signed.
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Inherited from BaseWidgetAnnotation.)
Top
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.AreFieldChangesDisallowedBySigning Method

SignatureWidgetAnnotationAreFieldChangesDisallowedBySigning Method

Determines whether changes to the supplied IFormElement would be disallowed by signing this widget.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AreFieldChangesDisallowedBySigning(
    IFormElement elem
)
Public Function AreFieldChangesDisallowedBySigning (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The element to check, typically a subclass of BaseWidgetAnnotation.

Return Value

Type: Boolean
true if the element would be marked as read-only by signing.
Exceptions
Exception | Condition
PdfException | Unknown FieldDisallowChangeAction: + FieldDisallowChangeAction
Remarks
The value returned by this method is only meaningful if this SignatureWidgetAnnotation has not yet been signed, in other words, this is indication of the result of a future action based on current state. A spec-compliant PDF signing tool will mark the appropriate fields FieldsChangeSet as read-only at the time of signing.

To sign signature widgets in PDF documents with DotPdf, use the PdfDocumentSigner object.

See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.IsValidChildOf Method

SignatureWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a SignatureFormField

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidChildOf(
    IFormElement elem
)
Public Overrides Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.MakeBasicAppearance Method

SignatureWidgetAnnotationMakeBasicAppearance Method

Makes a basic appearance for using supplied signature information.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string MakeBasicAppearance(
    GlobalResources gr,
    PdfBounds bounds,
    PdfTextAppearance app,
    double borderWidth,
    IPdfColor outlineColor,
    IPdfColor fillColor,
    bool includeLogo,
    BaseSignature docCert
)
Public Shared Function MakeBasicAppearance (
    gr As GlobalResources,
    bounds As PdfBounds,
    app As PdfTextAppearance,
    borderWidth As Double,
    outlineColor As IPdfColor,
    fillColor As IPdfColor,
    includeLogo As Boolean,
    docCert As BaseSignature
) As String

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The GlobalResources in which the appearance will be stored.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the appearance.
app
Type: Atalasoft.PdfDoc.Generating.RenderingPdfTextAppearance
The text appearance.
borderWidth
Type: SystemDouble
Width of the border around the signature, ignored if null.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the border.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color used to fill the signature, ignored if null.
includeLogo
Type: SystemBoolean
If set to true, will add a logo under the signature.
docCert
Type: Atalasoft.PdfDoc.DigitalSignaturesBaseSignature
The document cert.

Return Value

Type: String
Exceptions
Exception | Condition
ArgumentException | app
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SignatureWidgetAnnotation.SetFieldsToLock Method

SignatureWidgetAnnotationSetFieldsToLock Method

Sets the fields to set to read only or leave alone when this widget is signed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetFieldsToLock(
    FieldDisallowChangeAction changeAction,
    IEnumerable<IFormElement> formElements
)
Public Sub SetFieldsToLock (
    changeAction As FieldDisallowChangeAction,
    formElements As IEnumerable(Of IFormElement)
)

Parameters

changeAction
Type: Atalasoft.PdfDoc.DigitalSignaturesFieldDisallowChangeAction
The change action to take.
formElements
Type: System.Collections.GenericIEnumerableIFormElement
The form elements to set to read only or to leave alone.
Exceptions
Exception | Condition
ArgumentNullException | If the changeAction is IncludeSome or ExcludeSome, formElements must be non-null.
Remarks
When the change action is set to IncludeAll, formElements will be ignored. When it is set to either IncludeSome or ExcludeSome, then the formElements argument should be an enumerable collection of IFormElement objects to include or exclude.
See Also

Reference

SignatureWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation Class

The SoundAnnotation is used to provide a voice or other sound mark-up in a document. The annotation appears on the page as either a speaker or a microphone using the standard appearance. SoundAnnotation objects contain a Sound object which represents the sound that will be played. In most PDF viewers, sound annotations can only be triggered to play by direct user interaction. If you need a Sound to be played by some other trigger, consider using a PdfSoundAction
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsSoundAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SoundAnnotation : BaseAnnotation
Public Class SoundAnnotation
    Inherits BaseAnnotation

The SoundAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | SoundAnnotation | Initializes a new instance of the SoundAnnotation class with a speaker icon and no associated sound.
Public method | SoundAnnotation(PdfBounds) | Initializes a new instance of the SoundAnnotation class in the specified bounds.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | IconName | Gets or sets the name of the icon that will be displayed. Remarks The PDF specification states that only the icond "Speaker" and "Mic" need to be supported by PDF viewers. These are available via the RecommendedIconNames property.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
 | RecommendedIconNames | Gets the recommended icon names for a SoundAnnotation
Public property | Sound | Gets or sets the sound for playback.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation Constructor

Overload List
 | Name | Description
Public method | SoundAnnotation | Initializes a new instance of the SoundAnnotation class with a speaker icon and no associated sound.
Public method | SoundAnnotation(PdfBounds) | Initializes a new instance of the SoundAnnotation class in the specified bounds.
Top
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation Constructor

Initializes a new instance of the SoundAnnotation class with a speaker icon and no associated sound.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SoundAnnotation()
Public Sub New
See Also

Reference

SoundAnnotation Class
SoundAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation Constructor (PdfBounds)

Initializes a new instance of the SoundAnnotation class in the specified bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SoundAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

SoundAnnotation Class
SoundAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation Properties

The SoundAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | IconName | Gets or sets the name of the icon that will be displayed. Remarks The PDF specification states that only the icond "Speaker" and "Mic" need to be supported by PDF viewers. These are available via the RecommendedIconNames property.
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
 | RecommendedIconNames | Gets the recommended icon names for a SoundAnnotation
Public property | Sound | Gets or sets the sound for playback.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Top
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation.IconName Property

SoundAnnotationIconName Property

Gets or sets the name of the icon that will be displayed.
Remarks
The PDF specification states that only the icond "Speaker" and "Mic" need to be supported by PDF viewers. These are available via the RecommendedIconNames property.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IconName { get; set; }
Public Property IconName As String
    Get
    Set

Property Value

Type: String
The name of the icon.
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation.RecommendedIconNames Property

SoundAnnotationRecommendedIconNames Property

Gets the recommended icon names for a SoundAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string[] RecommendedIconNames { get; }
Public Shared ReadOnly Property RecommendedIconNames As String()
    Get

Property Value

Type: String
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation.Sound Property

SoundAnnotationSound Property

Gets or sets the sound for playback.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Sound Sound { get; set; }
Public Property Sound As Sound
    Get
    Set

Property Value

Type: Sound
The sound.
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation Methods

The SoundAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


SoundAnnotation.ValidateProperties Method

SoundAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

SoundAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Class

A StickyNoteAnnotation is meant to represent a sticky note on the page. In interaction, the note is either closed or open. When closed, it appears as a small piece of paper attached to the page. When open, it provides a simple user interface to view and edit text associated with it. In the initial versions of PDF, this annotation was represented on its own and because of the nature of the UI, was very complicated. In later revisions, it was changed to be two annotations: a StickyNoteAnnotation which holds the text and a PopupAnnotation which represents the UI for editing the text. This is now the preferred form and there is a convenience constructor that will make an associated PopupAnnotation and attach it to the StickyNoteAnnotation.
Examples
This shows how to use the convenience constructor for making a PopupAnnotation.
Copy
StickyNoteAnnotation annot = new StickyNoteAnnotation(new PdfBounds(72, 400, 36, 72), "empty.",
                                        new PdfBounds(72, 400, 144, 288));
// this is equivalent to:

StickyNoteAnnotation annot = new StickyNoteAnnotation(new PdfBounds(72, 400, 36, 72) "empty.");
annot.Popup = new PopupAnnotation(new PdfBounds(72, 400, 144, 288), annot);
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsStickyNoteAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StickyNoteAnnotation : BaseMarkupAnnotation
Public Class StickyNoteAnnotation
    Inherits BaseMarkupAnnotation

The StickyNoteAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | StickyNoteAnnotation | Initializes a new instance of the StickyNoteAnnotation class.
Public method | StickyNoteAnnotation(PdfBounds, String) | Initializes a new instance of the StickyNoteAnnotation class with the specified bounds and text.
Public method | StickyNoteAnnotation(PdfBounds, String, PdfBounds) | Initializes a new instance of the StickyNoteAnnotation class with the specified bounds and text, constructing an associated PopupAnnotation to attach to the StickyNoteAnnotation.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
 | CommentIconName | Gets the name of the comment icon.
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
 | HelpIconName | Gets the name of the help icon.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | IconName | Gets or sets the name of the icon that will be used when the sticky note is closed.
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsertIconName | Gets the name of the insert icon.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsOpen | Gets or sets a value indicating whether the sticky note should appear in open or closed state.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
 | KeyIconName | Gets the name of the key icon.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
 | NewParagraphIconName | Gets the name of the new paragraph icon.
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
 | NoteIconName | Gets the name of the note icon.
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
 | ParagraphIconName | Gets the name of the paragraph icon.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ReviewProcess | Gets or sets the review process for this sticky note.
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
 | StandardIconNames | Gets the standard icon names usable for sticky note appearances.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Constructor

Overload List
 | Name | Description
Public method | StickyNoteAnnotation | Initializes a new instance of the StickyNoteAnnotation class.
Public method | StickyNoteAnnotation(PdfBounds, String) | Initializes a new instance of the StickyNoteAnnotation class with the specified bounds and text.
Public method | StickyNoteAnnotation(PdfBounds, String, PdfBounds) | Initializes a new instance of the StickyNoteAnnotation class with the specified bounds and text, constructing an associated PopupAnnotation to attach to the StickyNoteAnnotation.
Top
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Constructor

Initializes a new instance of the StickyNoteAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StickyNoteAnnotation()
Public Sub New
See Also

Reference

StickyNoteAnnotation Class
StickyNoteAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Constructor (PdfBounds, String)

Initializes a new instance of the StickyNoteAnnotation class with the specified bounds and text.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StickyNoteAnnotation(
    PdfBounds bounds,
    string text
)
Public Sub New (
    bounds As PdfBounds,
    text As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
text
Type: SystemString
The text.
See Also

Reference

StickyNoteAnnotation Class
StickyNoteAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Constructor (PdfBounds, String, PdfBounds)

Initializes a new instance of the StickyNoteAnnotation class with the specified bounds and text, constructing an associated PopupAnnotation to attach to the StickyNoteAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StickyNoteAnnotation(
    PdfBounds bounds,
    string text,
    PdfBounds popupBounds
)
Public Sub New (
    bounds As PdfBounds,
    text As String,
    popupBounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
text
Type: SystemString
The text.
popupBounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the associated PopupAnnotation.
See Also

Reference

StickyNoteAnnotation Class
StickyNoteAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Properties

The StickyNoteAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
 | CommentIconName | Gets the name of the comment icon.
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
 | HelpIconName | Gets the name of the help icon.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | IconName | Gets or sets the name of the icon that will be used when the sticky note is closed.
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsertIconName | Gets the name of the insert icon.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsOpen | Gets or sets a value indicating whether the sticky note should appear in open or closed state.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
 | KeyIconName | Gets the name of the key icon.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
 | NewParagraphIconName | Gets the name of the new paragraph icon.
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
 | NoteIconName | Gets the name of the note icon.
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
 | ParagraphIconName | Gets the name of the paragraph icon.
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | ReviewProcess | Gets or sets the review process for this sticky note.
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
 | StandardIconNames | Gets the standard icon names usable for sticky note appearances.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.CommentIconName Property

StickyNoteAnnotationCommentIconName Property

Gets the name of the comment icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CommentIconName { get; }
Public Shared ReadOnly Property CommentIconName As String
    Get

Property Value

Type: String
The name of the comment icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.HelpIconName Property

StickyNoteAnnotationHelpIconName Property

Gets the name of the help icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string HelpIconName { get; }
Public Shared ReadOnly Property HelpIconName As String
    Get

Property Value

Type: String
The name of the help icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.IconName Property

StickyNoteAnnotationIconName Property

Gets or sets the name of the icon that will be used when the sticky note is closed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string IconName { get; set; }
Public Property IconName As String
    Get
    Set

Property Value

Type: String
The name of the icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.InsertIconName Property

StickyNoteAnnotationInsertIconName Property

Gets the name of the insert icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string InsertIconName { get; }
Public Shared ReadOnly Property InsertIconName As String
    Get

Property Value

Type: String
The name of the insert icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.IsOpen Property

StickyNoteAnnotationIsOpen Property

Gets or sets a value indicating whether the sticky note should appear in open or closed state.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the sticky note is open; otherwise, false.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.KeyIconName Property

StickyNoteAnnotationKeyIconName Property

Gets the name of the key icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string KeyIconName { get; }
Public Shared ReadOnly Property KeyIconName As String
    Get

Property Value

Type: String
The name of the key icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.NewParagraphIconName Property

StickyNoteAnnotationNewParagraphIconName Property

Gets the name of the new paragraph icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string NewParagraphIconName { get; }
Public Shared ReadOnly Property NewParagraphIconName As String
    Get

Property Value

Type: String
The new name of the paragraph icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.NoteIconName Property

StickyNoteAnnotationNoteIconName Property

Gets the name of the note icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string NoteIconName { get; }
Public Shared ReadOnly Property NoteIconName As String
    Get

Property Value

Type: String
The name of the note icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.ParagraphIconName Property

StickyNoteAnnotationParagraphIconName Property

Gets the name of the paragraph icon.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string ParagraphIconName { get; }
Public Shared ReadOnly Property ParagraphIconName As String
    Get

Property Value

Type: String
The name of the paragraph icon.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.ReviewProcess Property

StickyNoteAnnotationReviewProcess Property

Gets or sets the review process for this sticky note.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ReviewProcess ReviewProcess { get; set; }
Public Property ReviewProcess As ReviewProcess
    Get
    Set

Property Value

Type: ReviewProcess
The review process.
Remarks
Sticky note annotations can be used as a tool for reviewing documents. To this end a sticky note can have a ReviewProcess attached to it. A ReviewProcess is a process classification that allows the sticky note to represent a current state from a set of allowable states. For example, a document might be marked, via the sticky note as being "Completed" or "Accepted".
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation.StandardIconNames Property

StickyNoteAnnotationStandardIconNames Property

Gets the standard icon names usable for sticky note appearances.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string[] StandardIconNames { get; }
Public Shared ReadOnly Property StandardIconNames As String()
    Get

Property Value

Type: String
Remarks
The PDF specification states that a set of standard names should be supported by all viewers for icons. The list includes "Note", "Comment", "Key", "Help", "NewParagraph", "Paragraph", and "Insert". If these is no icon name (null), the viewer will use a note.
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StickyNoteAnnotation Methods

The StickyNoteAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

StickyNoteAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StringDrawingTemplatePair Class

StringDrawingTemplatePair is a utility class to associate a name with a DrawingTemplate. This class is immutable. Once constructed, neither component can be changed.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsStringDrawingTemplatePair

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StringDrawingTemplatePair
Public Class StringDrawingTemplatePair

The StringDrawingTemplatePair type exposes the following members.

Constructors
 | Name | Description
Public method | StringDrawingTemplatePair | Initializes a new instance of the StringDrawingTemplatePair class.
Top
Properties
 | Name | Description
Public property | Name | Gets the name in the pair.
Public property | Template | Gets the template in the pair.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


StringDrawingTemplatePair Constructor

Initializes a new instance of the StringDrawingTemplatePair class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StringDrawingTemplatePair(
    string name,
    DrawingTemplate template
)
Public Sub New (
    name As String,
    template As DrawingTemplate
)

Parameters

name
Type: SystemString
The name.
template
Type: Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate
The template.
See Also

Reference

StringDrawingTemplatePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StringDrawingTemplatePair Properties

The StringDrawingTemplatePair type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name in the pair.
Public property | Template | Gets the template in the pair.
Top
See Also

Reference

StringDrawingTemplatePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StringDrawingTemplatePair.Name Property

StringDrawingTemplatePairName Property

Gets the name in the pair.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

StringDrawingTemplatePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StringDrawingTemplatePair.Template Property

StringDrawingTemplatePairTemplate Property

Gets the template in the pair.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DrawingTemplate Template { get; }
Public ReadOnly Property Template As DrawingTemplate
    Get

Property Value

Type: DrawingTemplate
See Also

Reference

StringDrawingTemplatePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


StringDrawingTemplatePair Methods

The StringDrawingTemplatePair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringDrawingTemplatePair Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Class

A TextBoxAnnotation represents and annotation with text constrained by a bounding rectangle. Unlike the StickyNoteAnnotation, the TextBoxAnnotation does not have an open/closed state. It is simply text in a box on the page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextBoxAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsCalloutAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTypeWriterAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextBoxAnnotation : BaseMarkupAnnotation
Public Class TextBoxAnnotation
    Inherits BaseMarkupAnnotation

The TextBoxAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | TextBoxAnnotation | Initializes a new instance of the TextBoxAnnotation class.
Public method | TextBoxAnnotation(PdfBounds) | Initializes a new instance of the TextBoxAnnotation class with the specified bounds.
Public method | TextBoxAnnotation(PdfBounds, String) | Initializes a new instance of the TextBoxAnnotation class with the specified bounds and text. Text is stored in the Contents property.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property.
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point.
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the effect for the border of the annotation.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FontColor | Gets or sets the color of the font.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsetArea | Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextStrikeout | Gets or sets a value indicating whether the text has a line drawn through it.
Public property | TextUnderline | Gets or sets a value indicating whether the text is underlined.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Overrides BaseMarkupAnnotationGetRichTextContent(GlobalResources).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Constructor

Overload List
 | Name | Description
Public method | TextBoxAnnotation | Initializes a new instance of the TextBoxAnnotation class.
Public method | TextBoxAnnotation(PdfBounds) | Initializes a new instance of the TextBoxAnnotation class with the specified bounds.
Public method | TextBoxAnnotation(PdfBounds, String) | Initializes a new instance of the TextBoxAnnotation class with the specified bounds and text. Text is stored in the Contents property.
Top
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Constructor

Initializes a new instance of the TextBoxAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextBoxAnnotation()
Public Sub New
See Also

Reference

TextBoxAnnotation Class
TextBoxAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Constructor (PdfBounds)

Initializes a new instance of the TextBoxAnnotation class with the specified bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextBoxAnnotation(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

TextBoxAnnotation Class
TextBoxAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Constructor (PdfBounds, String)

Initializes a new instance of the TextBoxAnnotation class with the specified bounds and text. Text is stored in the Contents property.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextBoxAnnotation(
    PdfBounds bounds,
    string text
)
Public Sub New (
    bounds As PdfBounds,
    text As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
text
Type: SystemString
The text.
See Also

Reference

TextBoxAnnotation Class
TextBoxAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Properties

The TextBoxAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property.
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point.
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the effect for the border of the annotation.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FontColor | Gets or sets the color of the font.
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsetArea | Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property.
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextStrikeout | Gets or sets a value indicating whether the text has a line drawn through it.
Public property | TextUnderline | Gets or sets a value indicating whether the text is underlined.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.DefaultRichTextStyleString Property

TextBoxAnnotationDefaultRichTextStyleString Property

Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultRichTextStyleString { get; set; }
Public Property DefaultRichTextStyleString As String
    Get
    Set

Property Value

Type: String
The default style string.
Remarks
You should avoid using only the DefaultRichTextStyleString and RichTextContent properties. When using these properties, be sure to set the Contents property to a plain text equivalent. This will allow maximum compatability with older PDF viewers.
Examples
Copy
textBoxAnnot.DefaultRichTextStyleString = "font: 12pt Helvetica";
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.DefaultTextAppearance Property

TextBoxAnnotationDefaultTextAppearance Property

Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance DefaultTextAppearance { get; set; }
Public Property DefaultTextAppearance As PdfTextAppearance
    Get
    Set

Property Value

Type: PdfTextAppearance
The default text appearance.
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.Effect Property

TextBoxAnnotationEffect Property

Gets or sets the effect for the border of the annotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BorderEffect Effect { get; set; }
Public Property Effect As BorderEffect
    Get
    Set

Property Value

Type: BorderEffect
The effect to apply.
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.FontColor Property

TextBoxAnnotationFontColor Property

Gets or sets the color of the font.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Color FontColor { get; set; }
Public Property FontColor As Color
    Get
    Set

Property Value

Type: Color
Remarks
FillColor property of DefaultTextAppearance specifies the color of the text and border for TextBoxAnnotation. FontColor allows to override the font color separately from the border color.
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.InsetArea Property

TextBoxAnnotationInsetArea Property

Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds InsetArea { get; set; }
Public Property InsetArea As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The inset area.
Examples
Setting a 4 unit margin on each side of the annotation.
Copy
textBoxAnnotation.InsetArea = textBoxAnnotation.Bounds.Expand(-4);
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.TextAlignment Property

TextBoxAnnotationTextAlignment Property

Gets or sets the text alignment.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As AnnotationTextAlignment
    Get
    Set

Property Value

Type: AnnotationTextAlignment
The text alignment.
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.TextStrikeout Property

TextBoxAnnotationTextStrikeout Property

Gets or sets a value indicating whether the text has a line drawn through it.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TextStrikeout { get; set; }
Public Property TextStrikeout As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.TextUnderline Property

TextBoxAnnotationTextUnderline Property

Gets or sets a value indicating whether the text is underlined.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TextUnderline { get; set; }
Public Property TextUnderline As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation Methods

The TextBoxAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Overrides BaseMarkupAnnotationGetRichTextContent(GlobalResources).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides BaseMarkupAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.GetRichTextContent Method

TextBoxAnnotationGetRichTextContent Method

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override XmlDocument GetRichTextContent(
    GlobalResources resources
)
Protected Overrides Function GetRichTextContent (
    resources As GlobalResources
) As XmlDocument

Parameters

resources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources

Return Value

Type: XmlDocument
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextBoxAnnotation.ValidateProperties Method

TextBoxAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

TextBoxAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation Class

A TextMarkupAnnotation is an annotation type that is used to represent various similar ways of marking editing changes to text on a page. Typically, this type of annotation is built by using the set of quadrilaterals that bound individual words or word parts on a page and then providing marks on top of the text including underlines, highlights, an insertion caret, strike out, or squiggly underline.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextMarkupAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextMarkupAnnotation : BaseMarkupAnnotation
Public Class TextMarkupAnnotation
    Inherits BaseMarkupAnnotation

The TextMarkupAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | TextMarkupAnnotation | Initializes a new instance of the TextMarkupAnnotation class with Highlight as the default kind. The Regions will be a new empty collection.
Public method | TextMarkupAnnotation(TextMarkupKind) | Initializes a new instance of the TextMarkupAnnotation class with the specified markup kind. The Regions will be a new empty collection.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | MarkupKind | Gets or sets the kind of the markup.
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | Regions | Gets the regions for this annotation. Regions represents a set of quadrilaterals each of which represent the area covered by the annotation. Typically, parts of the annotation are drawn through sections of the quatrilateral. For example, underlines are drawn across the bottom of the annotation, strike outs through the middle.
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation Constructor

Overload List
 | Name | Description
Public method | TextMarkupAnnotation | Initializes a new instance of the TextMarkupAnnotation class with Highlight as the default kind. The Regions will be a new empty collection.
Public method | TextMarkupAnnotation(TextMarkupKind) | Initializes a new instance of the TextMarkupAnnotation class with the specified markup kind. The Regions will be a new empty collection.
Top
See Also

Reference

TextMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation Constructor

Initializes a new instance of the TextMarkupAnnotation class with Highlight as the default kind. The Regions will be a new empty collection.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextMarkupAnnotation()
Public Sub New
See Also

Reference

TextMarkupAnnotation Class
TextMarkupAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation Constructor (TextMarkupKind)

Initializes a new instance of the TextMarkupAnnotation class with the specified markup kind. The Regions will be a new empty collection.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextMarkupAnnotation(
    TextMarkupKind kind
)
Public Sub New (
    kind As TextMarkupKind
)

Parameters

kind
Type: Atalasoft.PdfDoc.Generating.AnnotationsTextMarkupKind
The kind.
See Also

Reference

TextMarkupAnnotation Class
TextMarkupAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation Properties

The TextMarkupAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | MarkupKind | Gets or sets the kind of the markup.
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | Regions | Gets the regions for this annotation. Regions represents a set of quadrilaterals each of which represent the area covered by the annotation. Typically, parts of the annotation are drawn through sections of the quatrilateral. For example, underlines are drawn across the bottom of the annotation, strike outs through the middle.
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

TextMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation.MarkupKind Property

TextMarkupAnnotationMarkupKind Property

Gets or sets the kind of the markup.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextMarkupKind MarkupKind { get; set; }
Public Property MarkupKind As TextMarkupKind
    Get
    Set

Property Value

Type: TextMarkupKind
The kind of the markup.
See Also

Reference

TextMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation.Regions Property

TextMarkupAnnotationRegions Property

Gets the regions for this annotation. Regions represents a set of quadrilaterals each of which represent the area covered by the annotation. Typically, parts of the annotation are drawn through sections of the quatrilateral. For example, underlines are drawn across the bottom of the annotation, strike outs through the middle.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateralCollection Regions { get; }
Public ReadOnly Property Regions As PdfQuadrilateralCollection
    Get

Property Value

Type: PdfQuadrilateralCollection
See Also

Reference

TextMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupAnnotation Methods

The TextMarkupAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from BaseMarkupAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

TextMarkupAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextMarkupKind Enumeration

Determines the type of text markup in a TextMarkupAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TextMarkupKind
Public Enumeration TextMarkupKind
Members
Member name | Description
Highlight | A page highlight annotation
Underline | An underline annotation
Squiggly | A squiggle line
StrikeOut | Text strike out
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Class

A TextWidgetAnnotation is used to provide a user-fillable text field on a form in a document. Note that the act of putting a widget annotation of a page is not enough to mark it as a form field. The annotation must also be put into the Fields collection of the document's Form property as well.
Examples
Creating a typical widget annotation.
Copy
TextWidgetAnnotation anno = new TextWidgetAnnotation(bounds, "user", "anonymous");
page.Annotations.Add(anno);
doc.Form.Fields.Add(anno);
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseWidgetAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextWidgetAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextWidgetAnnotation : BaseWidgetAnnotation
Public Class TextWidgetAnnotation
    Inherits BaseWidgetAnnotation

The TextWidgetAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | TextWidgetAnnotation | Initializes a new instance of the TextWidgetAnnotation class.
Public method | TextWidgetAnnotation(PdfBounds, String, String) | Initializes a new instance of the TextWidgetAnnotation class.
Public method | TextWidgetAnnotation(PdfBounds, String, String, String, String) | Initializes a new instance of the TextWidgetAnnotation class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether to auto generate a basic appearance for the text box. Generation of the appearance happens when the document is saved. Default value is true.
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property.
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultTextValue | Gets or sets the default text value.
Public property | DefaultValueAsString | Gets the default value as a string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsColumns | Gets or sets a value indicating whether this instance is columns of text.
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Public property | IsFileSelection | Gets or sets a value indicating whether the text is a file selection.
Public property | IsMultiLine | Gets or sets a value indicating whether this instance is multi line text.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsPassword | Gets or sets a value indicating whether this instance is password. If true, a PDF viewer should display neutral marks for each of the characters entered. Note that fields values are stored in the PDF file without any encryption. Labeling a field as a password does not imply any security on how that value is stored in the file. At the very least client code should consider encrypting the the output PDF to prevent the password from being stored in clear text.
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsRichText | Gets or sets a value indicating whether text is represented by rich text
Public property | IsScrollable | Gets or sets a value indicating whether the text box will have scroll bars if needed.
Public property | IsSpellChecked | Gets or sets a value indicating whether the text is spell checked. If true, text entered should be checked by a client service for correct spelling.
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | MaximumLength | Gets or sets the maximum length of text in the field.
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextValue | Gets or sets the rich text value.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextValue | Gets or sets the text value of the field.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as a string. (Overrides BaseWidgetAnnotationValueAsString.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateAutoFontSize | Calculates the font size used for auto-sized fonts.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a TextFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
 | MakeBasicAppearance | Makes the basic appearance for the annotation. Unlike CheckboxWidgetAnnotation, TextWidgetAnnotation can't easily share the same appearance since appearances are geometrically scaled to fit the bounds of the annotation. This means that border outlines will grow or shrink when drawn. When the Bounds of the annotation change, the appearance needs to be rebuilt in order to render correctly in the document. This method is provided so that, for example, client code might add in custom coloring or easily build consistent appearances for when the annotation has been cliecked on or when it is rolled over.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Constructor

Overload List
 | Name | Description
Public method | TextWidgetAnnotation | Initializes a new instance of the TextWidgetAnnotation class.
Public method | TextWidgetAnnotation(PdfBounds, String, String) | Initializes a new instance of the TextWidgetAnnotation class.
Public method | TextWidgetAnnotation(PdfBounds, String, String, String, String) | Initializes a new instance of the TextWidgetAnnotation class.
Top
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Constructor

Initializes a new instance of the TextWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextWidgetAnnotation()
Public Sub New
See Also

Reference

TextWidgetAnnotation Class
TextWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Constructor (PdfBounds, String, String)

Initializes a new instance of the TextWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextWidgetAnnotation(
    PdfBounds bounds,
    string name,
    string defaultValue
)
Public Sub New (
    bounds As PdfBounds,
    name As String,
    defaultValue As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the text box.
name
Type: SystemString
The name for identifying the field.
defaultValue
Type: SystemString
The default value of the text box.
See Also

Reference

TextWidgetAnnotation Class
TextWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Constructor (PdfBounds, String, String, String, String)

Initializes a new instance of the TextWidgetAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextWidgetAnnotation(
    PdfBounds bounds,
    string name,
    string nameForUI,
    string nameForExport,
    string defaultValue
)
Public Sub New (
    bounds As PdfBounds,
    name As String,
    nameForUI As String,
    nameForExport As String,
    defaultValue As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the text box.
name
Type: SystemString
The name for identifying the field.
nameForUI
Type: SystemString
The name of the field that should be displayed in the user interface.
nameForExport
Type: SystemString
The name of the field used for exporting data.
defaultValue
Type: SystemString
The default value of the text box.
See Also

Reference

TextWidgetAnnotation Class
TextWidgetAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Properties

The TextWidgetAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AutoGenerateBasicAppearance | Gets or sets a value indicating whether to auto generate a basic appearance for the text box. Generation of the appearance happens when the document is saved. Default value is true.
Public property | BackgroundColor | Gets or sets the color of the background. (Inherited from BaseWidgetAnnotation.)
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderColor | Gets or sets the color of the border. (Inherited from BaseWidgetAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ChildFields | Gets the child fields for this annotation. This will always be null in a BaseWidgetAnnotation (Inherited from BaseWidgetAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property.
Public property | DefaultTextAppearance | Gets or sets the default text appearance. (Inherited from BaseWidgetAnnotation.)
Public property | DefaultTextValue | Gets or sets the default text value.
Public property | DefaultValueAsString | Gets the default value as a string. (Overrides BaseWidgetAnnotationDefaultValueAsString.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the UI. (Inherited from BaseWidgetAnnotation.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseWidgetAnnotation.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseWidgetAnnotation.)
Public property | FieldNameForExport | Gets or sets the field name for export. When data from a form is aggregated, if FieldNameForExport is non-null, it will be used in place of FieldName. This allows you to have field values mapped to a different name which may be more suitable for a data collection application. (Inherited from BaseWidgetAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | HighlightAppearance | Gets or sets the highlight appearance. (Inherited from BaseWidgetAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsColumns | Gets or sets a value indicating whether this instance is columns of text.
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseWidgetAnnotation.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseWidgetAnnotation.)
Public property | IsFileSelection | Gets or sets a value indicating whether the text is a file selection.
Public property | IsMultiLine | Gets or sets a value indicating whether this instance is multi line text.
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsPassword | Gets or sets a value indicating whether this instance is password. If true, a PDF viewer should display neutral marks for each of the characters entered. Note that fields values are stored in the PDF file without any encryption. Labeling a field as a password does not imply any security on how that value is stored in the file. At the very least client code should consider encrypting the the output PDF to prevent the password from being stored in clear text.
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsRichText | Gets or sets a value indicating whether text is represented by rich text
Public property | IsScrollable | Gets or sets a value indicating whether the text box will have scroll bars if needed.
Public property | IsSpellChecked | Gets or sets a value indicating whether the text is spell checked. If true, text entered should be checked by a client service for correct spelling.
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | MaximumLength | Gets or sets the maximum length of text in the field.
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentField | Gets or sets the parent field. When the document is saved, this will be set for you if you haven't set it yourself. (Inherited from BaseWidgetAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextValue | Gets or sets the rich text value.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextValue | Gets or sets the text value of the field.
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | ValueAsString | Gets the value as a string. (Overrides BaseWidgetAnnotationValueAsString.)
Top
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.AutoGenerateBasicAppearance Property

TextWidgetAnnotationAutoGenerateBasicAppearance Property

Gets or sets a value indicating whether to auto generate a basic appearance for the text box. Generation of the appearance happens when the document is saved. Default value is true.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateBasicAppearance { get; set; }
Public Property AutoGenerateBasicAppearance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the widget will make a basic appearance for the text box; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.DefaultRichTextStyleString Property

TextWidgetAnnotationDefaultRichTextStyleString Property

Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultRichTextStyleString { get; set; }
Public Property DefaultRichTextStyleString As String
    Get
    Set

Property Value

Type: String
The default style string.
Remarks
You should avoid using only the DefaultRichTextStyleString and RichTextContent properties. When using these properties, be sure to set the Contents property to a plain text equivalent. This will allow maximum compatability with older PDF viewers.
Examples
Copy
textWidgetAnnot.DefaultRichTextStyleString = "font: 12pt Helvetica";
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.DefaultTextValue Property

TextWidgetAnnotationDefaultTextValue Property

Gets or sets the default text value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultTextValue { get; set; }
Public Property DefaultTextValue As String
    Get
    Set

Property Value

Type: String
The default text value.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.DefaultValueAsString Property

TextWidgetAnnotationDefaultValueAsString Property

Gets the default value as a string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string DefaultValueAsString { get; }
Public Overrides ReadOnly Property DefaultValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsColumns Property

TextWidgetAnnotationIsColumns Property

Gets or sets a value indicating whether this instance is columns of text.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsColumns { get; set; }
Public Property IsColumns As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is columns; otherwise, false.
Remarks
This will only be used if the MaximumLength property is non-zero and the IsScrollable, IsPassword, and IsFileSelection properties are set to false. With those conditions, text will be broken into MaximumLength columns.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsFileSelection Property

TextWidgetAnnotationIsFileSelection Property

Gets or sets a value indicating whether the text is a file selection.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFileSelection { get; set; }
Public Property IsFileSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is file selection; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsMultiLine Property

TextWidgetAnnotationIsMultiLine Property

Gets or sets a value indicating whether this instance is multi line text.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMultiLine { get; set; }
Public Property IsMultiLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is multi line; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsPassword Property

TextWidgetAnnotationIsPassword Property

Gets or sets a value indicating whether this instance is password. If true, a PDF viewer should display neutral marks for each of the characters entered. Note that fields values are stored in the PDF file without any encryption. Labeling a field as a password does not imply any security on how that value is stored in the file. At the very least client code should consider encrypting the the output PDF to prevent the password from being stored in clear text.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPassword { get; set; }
Public Property IsPassword As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is password; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsRichText Property

TextWidgetAnnotationIsRichText Property

Gets or sets a value indicating whether text is represented by rich text

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRichText { get; set; }
Public Property IsRichText As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text is rich text; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsScrollable Property

TextWidgetAnnotationIsScrollable Property

Gets or sets a value indicating whether the text box will have scroll bars if needed.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsScrollable { get; set; }
Public Property IsScrollable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text box will have scroll bars if needed; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsSpellChecked Property

TextWidgetAnnotationIsSpellChecked Property

Gets or sets a value indicating whether the text is spell checked. If true, text entered should be checked by a client service for correct spelling.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSpellChecked { get; set; }
Public Property IsSpellChecked As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text is spell checked; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.MaximumLength Property

TextWidgetAnnotationMaximumLength Property

Gets or sets the maximum length of text in the field.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumLength { get; set; }
Public Property MaximumLength As Integer
    Get
    Set

Property Value

Type: Int32
The maximum length.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.RichTextValue Property

TextWidgetAnnotationRichTextValue Property

Gets or sets the rich text value.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XmlDocument RichTextValue { get; set; }
Public Property RichTextValue As XmlDocument
    Get
    Set

Property Value

Type: XmlDocument
The rich text value.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.TextAlignment Property

TextWidgetAnnotationTextAlignment Property

Gets or sets the text alignment.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As AnnotationTextAlignment
    Get
    Set

Property Value

Type: AnnotationTextAlignment
The text alignment.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.TextValue Property

TextWidgetAnnotationTextValue Property

Gets or sets the text value of the field.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TextValue { get; set; }
Public Property TextValue As String
    Get
    Set

Property Value

Type: String
The text value.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.ValueAsString Property

TextWidgetAnnotationValueAsString Property

Gets the value as a string.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get

Property Value

Type: String
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation Methods

The TextWidgetAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateAutoFontSize | Calculates the font size used for auto-sized fonts.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | IsValidChildOf | Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a TextFormField (Overrides BaseWidgetAnnotationIsValidChildOf(IFormElement).)
 | MakeBasicAppearance | Makes the basic appearance for the annotation. Unlike CheckboxWidgetAnnotation, TextWidgetAnnotation can't easily share the same appearance since appearances are geometrically scaled to fit the bounds of the annotation. This means that border outlines will grow or shrink when drawn. When the Bounds of the annotation change, the appearance needs to be rebuilt in order to render correctly in the document. This method is provided so that, for example, client code might add in custom coloring or easily build consistent appearances for when the annotation has been cliecked on or when it is rolled over.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties of this object and adds any issues to the problems list. (Overrides BaseWidgetAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.GenerateAutoFontSize Method

TextWidgetAnnotationGenerateAutoFontSize Method

Calculates the font size used for auto-sized fonts.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static double GenerateAutoFontSize(
    PdfTextAppearance pdfTextAppearance,
    PdfFontResource pdfFontResource,
    string text,
    PdfBounds pdfBounds
)
Public Shared Function GenerateAutoFontSize (
    pdfTextAppearance As PdfTextAppearance,
    pdfFontResource As PdfFontResource,
    text As String,
    pdfBounds As PdfBounds
) As Double

Parameters

pdfTextAppearance
Type: Atalasoft.PdfDoc.Generating.RenderingPdfTextAppearance
pdfFontResource
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
text
Type: SystemString
pdfBounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds

Return Value

Type: Double
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.IsValidChildOf Method

TextWidgetAnnotationIsValidChildOf Method

Determines whether this annotation is valid child of the specified form field. Returns true is elem is a GenericFormField or a TextFormField

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool IsValidChildOf(
    IFormElement elem
)
Public Overrides Function IsValidChildOf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The parent field.

Return Value

Type: Boolean
true if this is valid child of the specified form field; otherwise, false.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.MakeBasicAppearance Method

TextWidgetAnnotationMakeBasicAppearance Method

Makes the basic appearance for the annotation. Unlike CheckboxWidgetAnnotation, TextWidgetAnnotation can't easily share the same appearance since appearances are geometrically scaled to fit the bounds of the annotation. This means that border outlines will grow or shrink when drawn. When the Bounds of the annotation change, the appearance needs to be rebuilt in order to render correctly in the document. This method is provided so that, for example, client code might add in custom coloring or easily build consistent appearances for when the annotation has been cliecked on or when it is rolled over.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string MakeBasicAppearance(
    GlobalResources gr,
    PdfBounds bounds,
    PdfTextAppearance app,
    double borderWidth,
    IPdfColor outlineColor,
    IPdfColor fillColor,
    string value,
    bool isMultiline,
    AnnotationTextAlignment annotationTextAlignment
)
Public Shared Function MakeBasicAppearance (
    gr As GlobalResources,
    bounds As PdfBounds,
    app As PdfTextAppearance,
    borderWidth As Double,
    outlineColor As IPdfColor,
    fillColor As IPdfColor,
    value As String,
    isMultiline As Boolean,
    annotationTextAlignment As AnnotationTextAlignment
) As String

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resources that will hold the appearance.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the annotation.
app
Type: Atalasoft.PdfDoc.Generating.RenderingPdfTextAppearance
The text appearance for text in the widget.
borderWidth
Type: SystemDouble
Width of the border.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
value
Type: SystemString
The text value.
isMultiline
Type: SystemBoolean
A value indicating if this text can contain multiple lines.
annotationTextAlignment
Type: Atalasoft.PdfDoc.Generating.AnnotationsAnnotationTextAlignment
The horizontal alignment of the text.

Return Value

Type: String
A string which is the name of an template resource that will represent the annotation's appearance.
Examples
If you have AutoGenerateBasicAppearance set to true this method will be called as follows:
Copy
appearanceName = MakeBasicAppearance(resources, Bounds, DefaultAppearance, borderWidth,
    BorderColor ?? PdfColorFactory.FromGray(0), BackgroundColor ?? PdfColorFactory.FromGray(1), TextValue ?? "");
if (this.Appearance == null)
    this.Appearance = new AppearanceSet();
this.Appearance.Normal.Add(AppearanceSet.DefaultAppearanceName, appearanceName);
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TextWidgetAnnotation.ValidateProperties Method

TextWidgetAnnotationValidateProperties Method

Validates the properties of this object and adds any issues to the problems list.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems accumulated so far.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The context for repairing issues.
See Also

Reference

TextWidgetAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ThreePointCalloutLine Class

A ThreePointCalloutLine is a line that contains a "knee" in the middle of the line. This can be used to make a more pleasing call out line such that at least one line segment is rectilinear.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsCalloutLine
Atalasoft.PdfDoc.Generating.AnnotationsTwoPointCalloutLine
Atalasoft.PdfDoc.Generating.AnnotationsThreePointCalloutLine

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ThreePointCalloutLine : TwoPointCalloutLine
Public Class ThreePointCalloutLine
    Inherits TwoPointCalloutLine

The ThreePointCalloutLine type exposes the following members.

Constructors
 | Name | Description
Public method | ThreePointCalloutLine | Initializes a new instance of the ThreePointCalloutLine class.
Top
Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point. (Inherited from TwoPointCalloutLine.)
Public property | KneePoint | Gets or sets the knee point.
Public property | StartPoint | Gets or sets the start point. (Inherited from TwoPointCalloutLine.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDoubleArray | Converts the points to a double array with in the order StartPoint.X, StartPoint.Y, KneePoint.X, KneePoint.Y, EndPoint.X, EndPoint.Y. (Overrides TwoPointCalloutLineToDoubleArray.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


ThreePointCalloutLine Constructor

Initializes a new instance of the ThreePointCalloutLine class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ThreePointCalloutLine(
    PdfPoint startPoint,
    PdfPoint endPoint,
    PdfPoint kneePoint
)
Public Sub New (
    startPoint As PdfPoint,
    endPoint As PdfPoint,
    kneePoint As PdfPoint
)

Parameters

startPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The start point.
endPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The end point.
kneePoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The middle or knee point.
See Also

Reference

ThreePointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ThreePointCalloutLine Properties

The ThreePointCalloutLine type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point. (Inherited from TwoPointCalloutLine.)
Public property | KneePoint | Gets or sets the knee point.
Public property | StartPoint | Gets or sets the start point. (Inherited from TwoPointCalloutLine.)
Top
See Also

Reference

ThreePointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ThreePointCalloutLine.KneePoint Property

ThreePointCalloutLineKneePoint Property

Gets or sets the knee point.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint KneePoint { get; set; }
Public Property KneePoint As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The knee point.
See Also

Reference

ThreePointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ThreePointCalloutLine Methods

The ThreePointCalloutLine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDoubleArray | Converts the points to a double array with in the order StartPoint.X, StartPoint.Y, KneePoint.X, KneePoint.Y, EndPoint.X, EndPoint.Y. (Overrides TwoPointCalloutLineToDoubleArray.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThreePointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


ThreePointCalloutLine.ToDoubleArray Method

ThreePointCalloutLineToDoubleArray Method

Converts the points to a double array with in the order StartPoint.X, StartPoint.Y, KneePoint.X, KneePoint.Y, EndPoint.X, EndPoint.Y.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override double[] ToDoubleArray()
Public Overrides Function ToDoubleArray As Double()

Return Value

Type: Double
An array representing the callout points
See Also

Reference

ThreePointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine Class

This represents a simple two-point line with a starting point and an ending point.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsCalloutLine
Atalasoft.PdfDoc.Generating.AnnotationsTwoPointCalloutLine
Atalasoft.PdfDoc.Generating.AnnotationsThreePointCalloutLine

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TwoPointCalloutLine : CalloutLine
Public Class TwoPointCalloutLine
    Inherits CalloutLine

The TwoPointCalloutLine type exposes the following members.

Constructors
 | Name | Description
Public method | TwoPointCalloutLine | Initializes a new instance of the TwoPointCalloutLine class.
Top
Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point.
Public property | StartPoint | Gets or sets the start point.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDoubleArray | Converts the points to a double array with in the order StartPoint.X, StartPoint.Y, EndPoint.X, EndPoint.Y. (Overrides CalloutLineToDoubleArray.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine Constructor

Initializes a new instance of the TwoPointCalloutLine class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwoPointCalloutLine(
    PdfPoint startPoint,
    PdfPoint endPoint
)
Public Sub New (
    startPoint As PdfPoint,
    endPoint As PdfPoint
)

Parameters

startPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The start point.
endPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The end point.
See Also

Reference

TwoPointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine Properties

The TwoPointCalloutLine type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets the end point.
Public property | StartPoint | Gets or sets the start point.
Top
See Also

Reference

TwoPointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine.EndPoint Property

TwoPointCalloutLineEndPoint Property

Gets or sets the end point.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint EndPoint { get; set; }
Public Property EndPoint As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The end point.
See Also

Reference

TwoPointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine.StartPoint Property

TwoPointCalloutLineStartPoint Property

Gets or sets the start point.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint StartPoint { get; set; }
Public Property StartPoint As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The start point.
See Also

Reference

TwoPointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine Methods

The TwoPointCalloutLine type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDoubleArray | Converts the points to a double array with in the order StartPoint.X, StartPoint.Y, EndPoint.X, EndPoint.Y. (Overrides CalloutLineToDoubleArray.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwoPointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TwoPointCalloutLine.ToDoubleArray Method

TwoPointCalloutLineToDoubleArray Method

Converts the points to a double array with in the order StartPoint.X, StartPoint.Y, EndPoint.X, EndPoint.Y.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override double[] ToDoubleArray()
Public Overrides Function ToDoubleArray As Double()

Return Value

Type: Double
An array representing the callout points
See Also

Reference

TwoPointCalloutLine Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation Class

The TypeWriterAnnotation is nearly identical to the TextBoxAnnotation except that it implies that the Bounds property are fluid to the text that is being entered and that there is usually no background or outline drawn for the bounding region. As such, it is supposed to appear as if the user is typing notes directly onto the page. If the text contains either neline or carriage returns characters ('\n' or '\r', the lines will be split at those points.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsBaseMarkupAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTextBoxAnnotation
Atalasoft.PdfDoc.Generating.AnnotationsTypeWriterAnnotation

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TypeWriterAnnotation : TextBoxAnnotation
Public Class TypeWriterAnnotation
    Inherits TextBoxAnnotation

The TypeWriterAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | TypeWriterAnnotation | Initializes a new instance of the TypeWriterAnnotation class.
Public method | TypeWriterAnnotation(PdfPoint, String) | Initializes a new instance of the TypeWriterAnnotation class, placing the text from the start point supplied.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoGenerateBounds | Gets or sets a value indicating whether to auto generate the bounds. This is done by using the starting point plus the font ascent as the upper left corner of the bounds and the line height times the total number of lines as the overall height. The width is the width of the longest line. This rectangle will be used for the Bounds unless AutoGenerateInsetArea is true, then this rectangle will become the InsetArea and then will be expanded by the LeftRightMargin and TopBottomMargin to get the actual Bounds.
Public property | AutoGenerateInsetArea | Gets or sets a value indicating whether auto generate the InsetArea.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property. (Inherited from TextBoxAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point. (Inherited from TextBoxAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the effect for the border of the annotation. (Inherited from TextBoxAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FontColor | Gets or sets the color of the font. (Inherited from TextBoxAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsetArea | Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property. (Inherited from TextBoxAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LeftRightMargin | Gets or sets the left and right margins.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | StartPoint | Gets or sets the start point for rendering the text in the annotation on the page.
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from TextBoxAnnotation.)
Public property | TextStrikeout | Gets or sets a value indicating whether the text has a line drawn through it. (Inherited from TextBoxAnnotation.)
Public property | TextUnderline | Gets or sets a value indicating whether the text is underlined. (Inherited from TextBoxAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | TopBottomMargin | Gets or sets the top and bottom margins.
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
Methods
 | Name | Description
Public method | CalculateBounds | Calculates the bounds required by the supplied text.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from TextBoxAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides TextBoxAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation Constructor

Overload List
 | Name | Description
Public method | TypeWriterAnnotation | Initializes a new instance of the TypeWriterAnnotation class.
Public method | TypeWriterAnnotation(PdfPoint, String) | Initializes a new instance of the TypeWriterAnnotation class, placing the text from the start point supplied.
Top
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation Constructor

Initializes a new instance of the TypeWriterAnnotation class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TypeWriterAnnotation()
Public Sub New
See Also

Reference

TypeWriterAnnotation Class
TypeWriterAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation Constructor (PdfPoint, String)

Initializes a new instance of the TypeWriterAnnotation class, placing the text from the start point supplied.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TypeWriterAnnotation(
    PdfPoint startPoint,
    string text
)
Public Sub New (
    startPoint As PdfPoint,
    text As String
)

Parameters

startPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The start point.
text
Type: SystemString
The text.
Remarks
The startPoint acts as the baseline and start position for text to be drawn, NOT the upper left of a bounding box.
See Also

Reference

TypeWriterAnnotation Class
TypeWriterAnnotation Overload
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation Properties

The TypeWriterAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions associated with the annotation. These are generally only used by widget annotations. (Inherited from BaseAnnotation.)
Public property | AnnotationType | Gets the type of the original PDF annotation if this annotation was imported from a file. This is generally only useful if the annotation was a type not recognized or not currently modeled by DotPdf (Inherited from BaseAnnotation.)
Public property | Appearance | Gets or sets the AppearanceSet for the annotation. This property defaults to null (no appearance set). (Inherited from BaseAnnotation.)
Public property | AuthorName | Gets or sets the name of the author of the annotation. (Inherited from BaseMarkupAnnotation.)
Public property | AutoGenerateBounds | Gets or sets a value indicating whether to auto generate the bounds. This is done by using the starting point plus the font ascent as the upper left corner of the bounds and the line height times the total number of lines as the overall height. The width is the width of the longest line. This rectangle will be used for the Bounds unless AutoGenerateInsetArea is true, then this rectangle will become the InsetArea and then will be expanded by the LeftRightMargin and TopBottomMargin to get the actual Bounds.
Public property | AutoGenerateInsetArea | Gets or sets a value indicating whether auto generate the InsetArea.
Public property | Border | Gets or sets the AnnotationBorder for this annotation. (Inherited from BaseAnnotation.)
Public property | BorderStyle | Gets or sets the BorderStyle for the annotation. (Inherited from BaseAnnotation.)
Public property | Bounds | Gets or sets the bounding rectangle for this annotation. (Inherited from BaseAnnotation.)
Public property | ClickActions | Gets the set of actions performed when the annotation has been clicked. (Inherited from BaseAnnotation.)
Public property | Color | Gets or sets the color of the annotation. The meaning of this color varies based on the annotation type. It may represent the background color of the annotation's icon (if any) when closed, the title bar of the annotation's pop-up window, the border color of the annotation. (Inherited from BaseAnnotation.)
Public property | Contents | Gets or sets the text contents of the annotation. How contents is used depends on the annotation type. For example a StickyNoteAnnotation will use Contents to represent text the user has entered. (Inherited from BaseAnnotation.)
Public property | CreationDate | Gets the creation date of the annotation. When a new BaseMarkupAnnotation is constructed the CreationDate is automatically set to the current date and time. When a BaseMarkupAnnotation is read from a file, the CreationDate will reflect the date in the file. (Inherited from BaseMarkupAnnotation.)
Public property | DefaultAppearanceState | Gets or sets the name of the default appearance state for the annotation. In annotations that may have multiple possible states (say, "On" of "Off") this the name of the default state. In an annotation's "normal" state, this corresponds to Appearance.Normal[DefaultAppearanceState]. (Inherited from BaseAnnotation.)
 | DefaultRichTextStyleString | Gets or sets the default style string. The style string is a string that specifies the rich text style to use by default for the annotation, if using the RichTextContent property. (Inherited from TextBoxAnnotation.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance for the annotation. If set to null, this will internally default to Helvetica 10 point. (Inherited from TextBoxAnnotation.)
Public property | DocumentRevision | Gets the revision of the document in which this widget was found. (Inherited from BaseAnnotation.)
Public property | Effect | Gets or sets the effect for the border of the annotation. (Inherited from TextBoxAnnotation.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the ReadOnly propery with an exception. (Inherited from BaseAnnotation.)
Public property | FontColor | Gets or sets the color of the font. (Inherited from TextBoxAnnotation.)
Public property | Hidden | Gets or sets a value indicating whether this BaseAnnotation is hidden. A hidden annotation is neither displayed nor printed by a viewer under any circumstances. Default is false. (Inherited from BaseAnnotation.)
Public property | InReplyTo | Gets or sets the BaseAnnotation that this annotation is in reply to. (Inherited from BaseMarkupAnnotation.)
Public property | InReplyToRelation | Gets or sets the relationship of this annotation to its InReplyTo. Default is Reply. (Inherited from BaseMarkupAnnotation.)
 | InsetArea | Gets or sets the inset area of the annotation. This is a way of setting margins for the annotation. The InsetArea must be fully contained within the Bounds property. (Inherited from TextBoxAnnotation.)
Public property | Intent | Gets or sets the intent of the annotation. Set automatically where required. (Inherited from BaseMarkupAnnotation.)
Public property | Invisible | Gets or sets a value indicating whether this BaseAnnotation is invisible. Invisibility specifically means that if the annotation is not recognized by the viewer, then it should not be displayed, otherwise the viewer may make a substitute appearance for the annotation. Default is false. (Inherited from BaseAnnotation.)
Public property | IsDirty | Gets or sets a value indicating whether the annotation is dirty and in need of being written. (Inherited from BaseAnnotation.)
Protected property | IsParentRequired | Gets a value indicating whether this instance requires the parent property. (Inherited from BaseAnnotation.)
Public property | IsReadOnlyOrFieldReadOnly | Determines whether the annotation is read only if either ReadOnly is true or if this object implements IFormElement, if IsFieldReadOnly is true. (Inherited from BaseAnnotation.)
Public property | IsTransparent | Gets or sets a value indicating whether this instance is transparent. This is an indication that there was no Color specified for the annotation. (Inherited from BaseAnnotation.)
Public property | LeftRightMargin | Gets or sets the left and right margins.
Public property | Locked | Gets or sets a value indicating whether this BaseAnnotation is locked. A locked annotation may not be deleted or have its properties changed, but its contents (such as a form field) may still be editable. (Inherited from BaseAnnotation.)
Public property | ModificationDate | Gets or sets the modification date for this annotation. DotPdf does not update this property. It is the client's responsibility to change it. (Inherited from BaseAnnotation.)
Public property | Name | Gets or sets the name of the annotation. This name is meant to be a unique identifier for the annotation and may be use in scripts in PdfJavaScriptAction objects that want to find an annotation. (Inherited from BaseAnnotation.)
Public property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when a page is rotated. Default is false. (Inherited from BaseAnnotation.)
Public property | NoView | Gets or sets a value indicating whether the annotation is viewable and will interact with the user. This is different from hidden in that an annotation NoView set to true can be printed. This is a way, for example, to put watermarks on a page that only show when printed. Default is false. (Inherited from BaseAnnotation.)
Public property | NoZoom | Gets or sets a value indicating whether the annotation's appearance is scaled when the page is zoomed in. Default is false. (Inherited from BaseAnnotation.)
Public property | ParentPage | Gets or sets the parent page that contains this annotation. (Inherited from BaseAnnotation.)
Public property | Popup | Gets or sets the a popup annotation for this annotation. A popup annotation can either be hidden or shown and allows extra information about an annotation to be shown. When adding a popup annotation to another annotation, the popup will need to be added to the same Annotations collection. When attached to a BaseMarkupAnnotation, the PopupAnnotation will project the text content and author of the BaseMarkupAnnotation. (Inherited from BaseMarkupAnnotation.)
Public property | Print | Gets or sets a value indicating whether this BaseAnnotation is printed. Default is false. (Inherited from BaseAnnotation.)
Public property | ReadOnly | Gets or sets a value indicating whether the annotation can interact with the user. Default is false. (Inherited from BaseAnnotation.)
Public property | RichTextContent | The Contents property can also be represented as rich text. Rich text is content that may include a subset of XHTML markup include body, p, i, b, and span tags. When setting the RichTextContent property, you should also set the Contents property to the plain text equivalent with no markup. (Inherited from BaseMarkupAnnotation.)
Public property | StartPoint | Gets or sets the start point for rendering the text in the annotation on the page.
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from TextBoxAnnotation.)
Public property | TextStrikeout | Gets or sets a value indicating whether the text has a line drawn through it. (Inherited from TextBoxAnnotation.)
Public property | TextUnderline | Gets or sets a value indicating whether the text is underlined. (Inherited from TextBoxAnnotation.)
Public property | ToggleNoView | Gets or sets a value indicating whether to toggle the sense of the NoView property. This might be used to make an annotation visible when the mouse enters it. (Inherited from BaseAnnotation.)
Public property | TopBottomMargin | Gets or sets the top and bottom margins.
Public property | Transparency | Gets or sets the transparency of the annotation. 1.0 means fully transparent and 0.0 means fully opaque. Default is 0. (Inherited from BaseMarkupAnnotation.)
Top
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.AutoGenerateBounds Property

TypeWriterAnnotationAutoGenerateBounds Property

Gets or sets a value indicating whether to auto generate the bounds. This is done by using the starting point plus the font ascent as the upper left corner of the bounds and the line height times the total number of lines as the overall height. The width is the width of the longest line. This rectangle will be used for the Bounds unless AutoGenerateInsetArea is true, then this rectangle will become the InsetArea and then will be expanded by the LeftRightMargin and TopBottomMargin to get the actual Bounds.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateBounds { get; set; }
Public Property AutoGenerateBounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the bounds will be calculated before rendering; otherwise, false.
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.AutoGenerateInsetArea Property

TypeWriterAnnotationAutoGenerateInsetArea Property

Gets or sets a value indicating whether auto generate the InsetArea.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoGenerateInsetArea { get; set; }
Public Property AutoGenerateInsetArea As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control will auto generate the InsetArea; otherwise, false.
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.LeftRightMargin Property

TypeWriterAnnotationLeftRightMargin Property

Gets or sets the left and right margins.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LeftRightMargin { get; set; }
Public Property LeftRightMargin As Double
    Get
    Set

Property Value

Type: Double
The left right margin.
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.StartPoint Property

TypeWriterAnnotationStartPoint Property

Gets or sets the start point for rendering the text in the annotation on the page.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint StartPoint { get; set; }
Public Property StartPoint As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The start point.
Remarks
The startPoint acts as the baseline and start position for text to be drawn, NOT the upper left of a bounding box.
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.TopBottomMargin Property

TypeWriterAnnotationTopBottomMargin Property

Gets or sets the top and bottom margins.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double TopBottomMargin { get; set; }
Public Property TopBottomMargin As Double
    Get
    Set

Property Value

Type: Double
The top bottom margin.
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation Methods

The TypeWriterAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | CalculateBounds | Calculates the bounds required by the supplied text.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetRichTextContent | (Inherited from TextBoxAnnotation.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAppearance | Determines whether this instance has at least 1 element in the Normal appearance set. (Inherited from BaseAnnotation.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this annotation object. An object implementing IValidatable should at least return an empty RepairContext object. (Inherited from BaseAnnotation.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | This method is called when a global resourec has been renamed, allowing the resource consumer to update to the new name. Annotations defer this to their appearance, if any. (Inherited from BaseAnnotation.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from BaseAnnotation.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and ReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseAnnotation.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the annotation and accumulates any problems. (Inherited from BaseAnnotation.)
Protected method | ValidateActionList | Validates the action list. (Inherited from BaseAnnotation.)
Protected method | ValidateActions | Validates the actions. (Inherited from BaseAnnotation.)
Protected method | ValidateProperties | Validates the properties for the CaretAnnotation. (Overrides TextBoxAnnotationValidateProperties(ProblemList, PageRepairContext).)
Top
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.CalculateBounds Method

TypeWriterAnnotationCalculateBounds Method

Calculates the bounds required by the supplied text.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds CalculateBounds(
    GlobalResources gr,
    PdfPoint startingPoint,
    string text
)
Public Function CalculateBounds (
    gr As GlobalResources,
    startingPoint As PdfPoint,
    text As String
) As PdfBounds

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The gr.
startingPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The starting point.
text
Type: SystemString
The text.

Return Value

Type: PdfBounds
The bounds required by the supplied text
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


TypeWriterAnnotation.ValidateProperties Method

TypeWriterAnnotationValidateProperties Method

Validates the properties for the CaretAnnotation.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ValidateProperties(
    ProblemList problems,
    PageRepairContext context
)
Protected Overrides Sub ValidateProperties (
    problems As ProblemList,
    context As PageRepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
A list of problems to add to.
context
Type: Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
The repair context.
See Also

Reference

TypeWriterAnnotation Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


UnknownReview Class

Represents a review process that is not modeled in DotPdf. Since review process in Acrobat does not contain all possible states, it is impossible to infer the full set of possible states from PDF file, so this class of review is likely to be incomplete.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.AnnotationsReviewProcess
Atalasoft.PdfDoc.Generating.AnnotationsUnknownReview

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class UnknownReview : ReviewProcess
Public Class UnknownReview
    Inherits ReviewProcess

The UnknownReview type exposes the following members.

Constructors
 | Name | Description
Public method | UnknownReview | Initializes a new instance of the UnknownReview class.
Top
Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates (Inherited from ReviewProcess.)
Public property | ProcessName | Gets the name of the review process. (Overrides ReviewProcessProcessName.)
Public property | StateName | Gets the name of the current review state. (Inherited from ReviewProcess.)
Public property | ValidStates | Gets the valid states for this ReviewProcess (Inherited from ReviewProcess.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state. (Inherited from ReviewProcess.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


UnknownReview Constructor

Initializes a new instance of the UnknownReview class.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnknownReview(
    string name,
    string setting
)
Public Sub New (
    name As String,
    setting As String
)

Parameters

name
Type: SystemString
The name of the review process.
setting
Type: SystemString
The current (and only) setting.
See Also

Reference

UnknownReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


UnknownReview Properties

The UnknownReview type exposes the following members.

Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current review state. This index is used to select a valid state from the set of available review states in ValidStates (Inherited from ReviewProcess.)
Public property | ProcessName | Gets the name of the review process. (Overrides ReviewProcessProcessName.)
Public property | StateName | Gets the name of the current review state. (Inherited from ReviewProcess.)
Public property | ValidStates | Gets the valid states for this ReviewProcess (Inherited from ReviewProcess.)
Top
See Also

Reference

UnknownReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


UnknownReview.ProcessName Property

UnknownReviewProcessName Property

Gets the name of the review process.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ProcessName { get; }
Public Overrides ReadOnly Property ProcessName As String
    Get

Property Value

Type: String
See Also

Reference

UnknownReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


UnknownReview Methods

The UnknownReview type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentState | Sets the review state by name. If the name is not a valid state, this will revert to the 0th state. (Inherited from ReviewProcess.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnknownReview Class
Atalasoft.PdfDoc.Generating.Annotations Namespace


WidgetHighlightAppearance Enumeration

Determines how a clickable widget will appear when it is clicked.

Namespace: Atalasoft.PdfDoc.Generating.Annotations
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WidgetHighlightAppearance
Public Enumeration WidgetHighlightAppearance
Members
Member name | Description
None | No specified appearance.
Invert | The bounds will be inverted.
Outline | An outline will be drawn around the bounds.
PushDown | The annotation will be drawn as if it is sunk into the page.
Toggle | Same as PushDown. PushDown is preferred.
See Also

Reference

Atalasoft.PdfDoc.Generating.Annotations Namespace


Atalasoft.PdfDoc.Generating.Forms Namespace

Classes
 | Class | Description
Public class | BaseButtonFormField | BaseButtonFormField is an abstract class that represents a parent field to any button form field or button widget.
Public class | BaseFormField | BaseFormField is an abstract class used to represent all form fields that will be parents of other fields or widget annotations.
Public class | CheckboxFormField | A CheckboxFormField represents a parent field of other IFormElement objects that are either CheckboxFormField objects or CheckboxWidgetAnnotations.
Public class | ChoiceFormField | A ChoiceFormField represents a parent field of other IFormElement objects that are either ChoiceFormField objects or ChoiceWidgetAnnotations.
Public class | FormVisitor | FormVisitor is an set of utility methods for visiting the elements in a PDF form. There are variations for visiting the elements in either depth first or breadth first order as well as convenience methods that only visit the actual widget annotations.
Public class | GenericFormField | While most implementations of BaseFormField imply that their child fields are a particular type, PDF allows for form fields that have no type associated with them. GenericFormField represents a parent field that may have child fields of any type.
 | PdfForm | A PdfForm represents a collection of fields that may be entered by a user for later collection or submission. A form is a hierarchy of form elements ending in nodes which are always BaseWidgetAnnotation object. For the widgets to be visible to the user, they must also be put into the Annotations collection in a PdfGeneratedPage.
Public class | PdfFormPropertyProblem | Defines a problem that could occur with the a PdfForm property value.
Public class | PushButtonFormField | A PushButtonFormField represents a parent field of other IFormElement objects that are either PushButtonFormField objects or PushButtonWidgetAnnotations.
Public class | RadioButtonFormField | A RadioButtonFormField represents a parent field of other IFormElement objects that are either RadioButtonFormField objects or RadioButtonWidgetAnnotations. Making a set of radio buttons that are wired up correctly can be a tricky process. RadioButtonWidgetAnnotations typically are not used without a parent RadioButtonFormField. It is typically easier to use the MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) method to make a set of radio buttons.
Public class | SignatureFormField | A SignatureFormField represents a parent field of other IFormElement objects that are either SignatureFormField objects or SignatureWidgetAnnotations.
Public class | TextFormField | A TextFormField represents a parent field of other IFormElement objects that are either TextFormField objects or TextWidgetAnnotations.
Interfaces
 | Interface | Description
Public interface | IFormElement | An object that implements the IFormElement interface can be used as a field within in a PDF form. It is not recommended to use any but the standard form elements. Client code should not implement this interface.


BaseButtonFormField Class

BaseButtonFormField is an abstract class that represents a parent field to any button form field or button widget.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsBaseButtonFormField
Atalasoft.PdfDoc.Generating.FormsCheckboxFormField
Atalasoft.PdfDoc.Generating.FormsPushButtonFormField
Atalasoft.PdfDoc.Generating.FormsRadioButtonFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseButtonFormField : BaseFormField
Public MustInherit Class BaseButtonFormField
    Inherits BaseFormField

The BaseButtonFormField type exposes the following members.

Constructors
 | Name | Description
Public method | BaseButtonFormField | Initializes a new instance of the BaseButtonFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


BaseButtonFormField Constructor

Initializes a new instance of the BaseButtonFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BaseButtonFormField()
Public Sub New
See Also

Reference

BaseButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseButtonFormField Properties

The BaseButtonFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
See Also

Reference

BaseButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseButtonFormField Methods

The BaseButtonFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseButtonFormField.ImplementMe Method

BaseButtonFormFieldImplementMe Method

Built for inheritance.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void ImplementMe()
Protected MustOverride Sub ImplementMe
See Also

Reference

BaseButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField Class

BaseFormField is an abstract class used to represent all form fields that will be parents of other fields or widget annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsBaseButtonFormField
Atalasoft.PdfDoc.Generating.FormsChoiceFormField
Atalasoft.PdfDoc.Generating.FormsGenericFormField
Atalasoft.PdfDoc.Generating.FormsSignatureFormField
Atalasoft.PdfDoc.Generating.FormsTextFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseFormField : IFormElement
Public MustInherit Class BaseFormField
    Implements IFormElement

The BaseFormField type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseFormField | Initializes a new instance of the BaseFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field.
Public property | ChildFields | Gets the child fields for this field.
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception.
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldNameForExport | Gets or sets the field name for export.
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export.
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only.
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required.
Public property | ParentField | Gets or sets the parent field.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField Constructor

Initializes a new instance of the BaseFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseFormField()
Protected Sub New
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField Properties

The BaseFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field.
Public property | ChildFields | Gets the child fields for this field.
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception.
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldNameForExport | Gets or sets the field name for export.
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export.
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only.
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required.
Public property | ParentField | Gets or sets the parent field.
Top
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.AdditionalActions Property

BaseFormFieldAdditionalActions Property

Gets the additional actions that may be used by annotations that are children of this field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationAdditionalActions AdditionalActions { get; }
Public ReadOnly Property AdditionalActions As AnnotationAdditionalActions
    Get

Property Value

Type: AnnotationAdditionalActions
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.ChildFields Property

BaseFormFieldChildFields Property

Gets the child fields for this field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<IFormElement> ChildFields { get; }
Public ReadOnly Property ChildFields As IList(Of IFormElement)
    Get

Property Value

Type: IListIFormElement

Implements

IFormElementChildFields
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.DefaultTextAppearance Property

BaseFormFieldDefaultTextAppearance Property

Gets or sets the default text appearance that is shared by children of this field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance DefaultTextAppearance { get; set; }
Public Property DefaultTextAppearance As PdfTextAppearance
    Get
    Set

Property Value

Type: PdfTextAppearance
The default text appearance.
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.EnforceReadyOnlyWithException Property

BaseFormFieldEnforceReadyOnlyWithException Property

Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnforceReadyOnlyWithException { get; set; }
Public Property EnforceReadyOnlyWithException As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ReadOnly will be enforced with an exception; otherwise, false.
Remarks
When set to true, if IsFieldReadOnly or IsFieldReadOnlyis set to true, this will cause any property
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.FieldAlternateDescription Property

BaseFormFieldFieldAlternateDescription Property

Gets or sets the field alternate description for display in the user interface.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldAlternateDescription { get; set; }
Public Property FieldAlternateDescription As String
    Get
    Set

Property Value

Type: String
The field alternate description.

Implements

IFormElementFieldAlternateDescription
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.FieldFullName Property

BaseFormFieldFieldFullName Property

Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldFullName { get; }
Public ReadOnly Property FieldFullName As String
    Get

Property Value

Type: String
The full name of the field.

Implements

IFormElementFieldFullName
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.FieldName Property

BaseFormFieldFieldName Property

Gets or sets the name of the field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set

Property Value

Type: String
The name of the field.

Implements

IFormElementFieldName
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.FieldNameForExport Property

BaseFormFieldFieldNameForExport Property

Gets or sets the field name for export.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FieldNameForExport { get; set; }
Public Property FieldNameForExport As String
    Get
    Set

Property Value

Type: String
The field name for export.

Implements

IFormElementFieldNameForExport
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.IsFieldNoExport Property

BaseFormFieldIsFieldNoExport Property

Gets or sets a value indicating whether this field should not be export.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFieldNoExport { get; set; }
Public Property IsFieldNoExport As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this field should not exported; otherwise, false.

Implements

IFormElementIsFieldNoExport
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.IsFieldReadOnly Property

BaseFormFieldIsFieldReadOnly Property

Gets or sets a value indicating whether this field is read only.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFieldReadOnly { get; set; }
Public Property IsFieldReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance field is read only; otherwise, false.

Implements

IFormElementIsFieldReadOnly
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.IsFieldRequired Property

BaseFormFieldIsFieldRequired Property

Gets or sets a value indicating whether this field is required.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFieldRequired { get; set; }
Public Property IsFieldRequired As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance field is required; otherwise, false.

Implements

IFormElementIsFieldRequired
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.ParentField Property

BaseFormFieldParentField Property

Gets or sets the parent field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFormElement ParentField { get; set; }
Public Property ParentField As IFormElement
    Get
    Set

Property Value

Type: IFormElement
The parent field.

Implements

IFormElementParentField
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField Methods

The BaseFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


BaseFormField.ThrowIfReadOnly(T) Method

BaseFormFieldThrowIfReadOnlyT Method

If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected T ThrowIfReadOnly<T>(
    T value
)

Protected Function ThrowIfReadOnly(Of T) (
    value As T
) As T

Parameters

value
Type: T
The value

Type Parameters

T
The value type

Return Value

Type: T
Exceptions
Exception | Condition
InvalidOperationException | Attempt to modify a read-only annotation.
Remarks
This is a helper method used in public properties to prevent modification to annotation contents.
See Also

Reference

BaseFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField Class

A CheckboxFormField represents a parent field of other IFormElement objects that are either CheckboxFormField objects or CheckboxWidgetAnnotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsBaseButtonFormField
Atalasoft.PdfDoc.Generating.FormsCheckboxFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class CheckboxFormField : BaseButtonFormField
Public Class CheckboxFormField
    Inherits BaseButtonFormField

The CheckboxFormField type exposes the following members.

Constructors
 | Name | Description
Public method | CheckboxFormField | Initializes a new instance of the CheckboxFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
 | CheckedValue | Gets the standard string used for a checked value.
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
 | ClearedValue | Gets the standard string used for a cleared value.
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | DefaultValue | Gets or sets the default string value.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Public property | Value | Gets or sets the string value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance. (Overrides BaseButtonFormFieldImplementMe.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField Constructor

Initializes a new instance of the CheckboxFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CheckboxFormField()
Public Sub New
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField Properties

The CheckboxFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
 | CheckedValue | Gets the standard string used for a checked value.
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
 | ClearedValue | Gets the standard string used for a cleared value.
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | DefaultValue | Gets or sets the default string value.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Public property | Value | Gets or sets the string value.
Top
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField.CheckedValue Property

CheckboxFormFieldCheckedValue Property

Gets the standard string used for a checked value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string CheckedValue { get; }
Public Shared ReadOnly Property CheckedValue As String
    Get

Property Value

Type: String
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField.ClearedValue Property

CheckboxFormFieldClearedValue Property

Gets the standard string used for a cleared value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string ClearedValue { get; }
Public Shared ReadOnly Property ClearedValue As String
    Get

Property Value

Type: String
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField.DefaultValue Property

CheckboxFormFieldDefaultValue Property

Gets or sets the default string value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set

Property Value

Type: String
The default value.
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField.Value Property

CheckboxFormFieldValue Property

Gets or sets the string value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value.
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField Methods

The CheckboxFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance. (Overrides BaseButtonFormFieldImplementMe.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


CheckboxFormField.ImplementMe Method

CheckboxFormFieldImplementMe Method

Built for inheritance.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

CheckboxFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


ChoiceFormField Class

A ChoiceFormField represents a parent field of other IFormElement objects that are either ChoiceFormField objects or ChoiceWidgetAnnotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsChoiceFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ChoiceFormField : BaseFormField
Public Class ChoiceFormField
    Inherits BaseFormField

The ChoiceFormField type exposes the following members.

Constructors
 | Name | Description
Public method | ChoiceFormField | Initializes a new instance of the ChoiceFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


ChoiceFormField Constructor

Initializes a new instance of the ChoiceFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ChoiceFormField()
Public Sub New
See Also

Reference

ChoiceFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


ChoiceFormField Properties

The ChoiceFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
See Also

Reference

ChoiceFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


ChoiceFormField Methods

The ChoiceFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChoiceFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor Class

FormVisitor is an set of utility methods for visiting the elements in a PDF form. There are variations for visiting the elements in either depth first or breadth first order as well as convenience methods that only visit the actual widget annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsFormVisitor

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FormVisitor
Public Class FormVisitor

The FormVisitor type exposes the following members.

Constructors
 | Name | Description
Public method | FormVisitor | Initializes a new instance of the FormVisitor class
Top
Methods
 | Name | Description
 | BreadthFirst | Returns an enumeration of all the IFormElement objects in a form in breadth first order.
 | DepthFirst | Returns an enumeration of all the IFormElement objects in a form in depth first order.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WidgetsBreadthFirst | Returns an enumeration of all the BaseWidgetAnnotation objects in a form in breadth first order.
 | WidgetsDepthFirst | Returns an enumeration of all the BaseWidgetAnnotation objects in a form in depth first order.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor Constructor

Initializes a new instance of the FormVisitor class

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormVisitor()
Public Sub New
See Also

Reference

FormVisitor Class
Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor Methods

The FormVisitor type exposes the following members.

Methods
 | Name | Description
 | BreadthFirst | Returns an enumeration of all the IFormElement objects in a form in breadth first order.
 | DepthFirst | Returns an enumeration of all the IFormElement objects in a form in depth first order.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WidgetsBreadthFirst | Returns an enumeration of all the BaseWidgetAnnotation objects in a form in breadth first order.
 | WidgetsDepthFirst | Returns an enumeration of all the BaseWidgetAnnotation objects in a form in depth first order.
Top
See Also

Reference

FormVisitor Class
Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor.BreadthFirst Method

FormVisitorBreadthFirst Method

Returns an enumeration of all the IFormElement objects in a form in breadth first order.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<IFormElement> BreadthFirst(
    PdfForm form
)
Public Shared Function BreadthFirst (
    form As PdfForm
) As IEnumerable(Of IFormElement)

Parameters

form
Type: Atalasoft.PdfDoc.Generating.FormsPdfForm
The form containing fields.

Return Value

Type: IEnumerableIFormElement
The elements in the form.
See Also

Reference

FormVisitor Class
Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor.DepthFirst Method

FormVisitorDepthFirst Method

Returns an enumeration of all the IFormElement objects in a form in depth first order.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<IFormElement> DepthFirst(
    PdfForm form
)
Public Shared Function DepthFirst (
    form As PdfForm
) As IEnumerable(Of IFormElement)

Parameters

form
Type: Atalasoft.PdfDoc.Generating.FormsPdfForm
The form containing fields.

Return Value

Type: IEnumerableIFormElement
The elements in the form.
See Also

Reference

FormVisitor Class
Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor.WidgetsBreadthFirst Method

FormVisitorWidgetsBreadthFirst Method

Returns an enumeration of all the BaseWidgetAnnotation objects in a form in breadth first order.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<BaseWidgetAnnotation> WidgetsBreadthFirst(
    PdfForm form
)
Public Shared Function WidgetsBreadthFirst (
    form As PdfForm
) As IEnumerable(Of BaseWidgetAnnotation)

Parameters

form
Type: Atalasoft.PdfDoc.Generating.FormsPdfForm
The form containing fields.

Return Value

Type: IEnumerableBaseWidgetAnnotation
The widgets in the form.
See Also

Reference

FormVisitor Class
Atalasoft.PdfDoc.Generating.Forms Namespace


FormVisitor.WidgetsDepthFirst Method

FormVisitorWidgetsDepthFirst Method

Returns an enumeration of all the BaseWidgetAnnotation objects in a form in depth first order.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static IEnumerable<BaseWidgetAnnotation> WidgetsDepthFirst(
    PdfForm form
)
Public Shared Function WidgetsDepthFirst (
    form As PdfForm
) As IEnumerable(Of BaseWidgetAnnotation)

Parameters

form
Type: Atalasoft.PdfDoc.Generating.FormsPdfForm
The form containing fields.

Return Value

Type: IEnumerableBaseWidgetAnnotation
The widgets in the form.
See Also

Reference

FormVisitor Class
Atalasoft.PdfDoc.Generating.Forms Namespace


GenericFormField Class

While most implementations of BaseFormField imply that their child fields are a particular type, PDF allows for form fields that have no type associated with them. GenericFormField represents a parent field that may have child fields of any type.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsGenericFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GenericFormField : BaseFormField
Public Class GenericFormField
    Inherits BaseFormField

The GenericFormField type exposes the following members.

Constructors
 | Name | Description
Public method | GenericFormField | Initializes a new instance of the GenericFormField class
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
While it is possible to put non-matching child fields as the children of any field, this is not considered good practice.
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


GenericFormField Constructor

Initializes a new instance of the GenericFormField class

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GenericFormField()
Public Sub New
See Also

Reference

GenericFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


GenericFormField Properties

The GenericFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
See Also

Reference

GenericFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


GenericFormField Methods

The GenericFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenericFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement Interface

An object that implements the IFormElement interface can be used as a field within in a PDF form. It is not recommended to use any but the standard form elements. Client code should not implement this interface.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IFormElement
Public Interface IFormElement

The IFormElement type exposes the following members.

Properties
 | Name | Description
Public property | ChildFields | Gets the child fields for this field.
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldNameForExport | Gets or sets the field name for export.
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export.
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only.
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required.
Public property | ParentField | Gets or sets the parent field of this form field.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement Properties

The IFormElement type exposes the following members.

Properties
 | Name | Description
Public property | ChildFields | Gets the child fields for this field.
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface.
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldNameForExport | Gets or sets the field name for export.
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export.
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only.
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required.
Public property | ParentField | Gets or sets the parent field of this form field.
Top
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.ChildFields Property

IFormElementChildFields Property

Gets the child fields for this field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IList<IFormElement> ChildFields { get; }
ReadOnly Property ChildFields As IList(Of IFormElement)
    Get

Property Value

Type: IListIFormElement
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.FieldAlternateDescription Property

IFormElementFieldAlternateDescription Property

Gets or sets the field alternate description for display in the user interface.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string FieldAlternateDescription { get; set; }
Property FieldAlternateDescription As String
    Get
    Set

Property Value

Type: String
The field alternate description.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.FieldFullName Property

IFormElementFieldFullName Property

Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string FieldFullName { get; }
ReadOnly Property FieldFullName As String
    Get

Property Value

Type: String
The full name of the field.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.FieldName Property

IFormElementFieldName Property

Gets or sets the name of the field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string FieldName { get; set; }
Property FieldName As String
    Get
    Set

Property Value

Type: String
The name of the field.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.FieldNameForExport Property

IFormElementFieldNameForExport Property

Gets or sets the field name for export.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string FieldNameForExport { get; set; }
Property FieldNameForExport As String
    Get
    Set

Property Value

Type: String
The field name for export.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.IsFieldNoExport Property

IFormElementIsFieldNoExport Property

Gets or sets a value indicating whether this field should not be export.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsFieldNoExport { get; set; }
Property IsFieldNoExport As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this field should not exported; otherwise, false.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.IsFieldReadOnly Property

IFormElementIsFieldReadOnly Property

Gets or sets a value indicating whether this field is read only.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsFieldReadOnly { get; set; }
Property IsFieldReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance field is read only; otherwise, false.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.IsFieldRequired Property

IFormElementIsFieldRequired Property

Gets or sets a value indicating whether this field is required.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
bool IsFieldRequired { get; set; }
Property IsFieldRequired As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance field is required; otherwise, false.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


IFormElement.ParentField Property

IFormElementParentField Property

Gets or sets the parent field of this form field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IFormElement ParentField { get; set; }
Property ParentField As IFormElement
    Get
    Set

Property Value

Type: IFormElement
The parent field.
See Also

Reference

IFormElement Interface
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm Class

A PdfForm represents a collection of fields that may be entered by a user for later collection or submission. A form is a hierarchy of form elements ending in nodes which are always BaseWidgetAnnotation object. For the widgets to be visible to the user, they must also be put into the Annotations collection in a PdfGeneratedPage.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsPdfForm

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfForm : IValidatable, IDisposable
Public Class PdfForm
    Implements IValidatable, IDisposable

The PdfForm type exposes the following members.

Constructors
 | Name | Description
Public method | PdfForm | Initializes a new instance of the PdfForm class
Top
Properties
 | Name | Description
Public property | DefaultAppearance | Gets or sets the default text appearance for all child fields in the form (if not otherwise specified)..
Public property | FieldCalculationSequence | Gets the field calculation sequence. If form fields contain a field calculation, the order of calculation can be specified by this list. A PDF viewer will perform the recalculation based on the order of this list.
Public property | Fields | Gets the fields present in this form. Any BaseWidgetAnnotation objects in the Fields tree must also be contained in an Annotations collection on a page in the document.
Public property | FormHasSignatures | Gets a value indicating whether form has signature fields.
Public property | IsEmpty | Gets a value indicating whether there are any fields in this form.
Public property | SavingWillInvalidateSignatures | Gets a value indicating whether saving the document will invalidate signatures.
Public property | TextAlignment | Gets or sets the text alignment for all child fields in the form (if not otherwise specified).
 | XFA | Gets a collection of StoredStream objects that represent packets of XFA data contained within a PDF Document. Each StoredStream will contain XML data that represents the XFA data. XFA may be contained within a single stream or within a collection of packets, each of which represents a subsection of the XFA model.
Top
Methods
 | Name | Description
Public method | ContainsFormElement | Determines whether this form contains the given IFormElement
Public method | Dispose | Releases all resources used by the PdfForm
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfForm and optionally releases the managed resources
Public method | EnforceParentage | Enforces the parent/child relationships in form elements within a form field hierarchy. This is done by doing a breadth-first traversal of all form elements and forcing the child elements to point back to the parent. Calling this method will ensure that FieldFullName will return the correct value. Before saving a document or validation this method will get called automatically. Calling this method will ensure that the FieldFullName property returns the correct value.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFieldLeaf | Determines whether a give IFormElement is a leaf or a node.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. PdfForm does not require an object passed in.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object looking for problems.
Top
Examples
Here is an example that makes a simple form.
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
doc.Form = new PdfForm();
PdfGeneratedPage page = doc.AddPage(PdfDefaultPages.Letter);
TextWidgetAnnotation text = new TextWidgetAnnotation(new PdfBounds(72, 400, 200, 20), "name", null);
page.Annotations.Add(text);
doc.Form.Fields.Add(text);
doc.Save("output.pdf");
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm Constructor

Initializes a new instance of the PdfForm class

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfForm()
Public Sub New
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm Properties

The PdfForm type exposes the following members.

Properties
 | Name | Description
Public property | DefaultAppearance | Gets or sets the default text appearance for all child fields in the form (if not otherwise specified)..
Public property | FieldCalculationSequence | Gets the field calculation sequence. If form fields contain a field calculation, the order of calculation can be specified by this list. A PDF viewer will perform the recalculation based on the order of this list.
Public property | Fields | Gets the fields present in this form. Any BaseWidgetAnnotation objects in the Fields tree must also be contained in an Annotations collection on a page in the document.
Public property | FormHasSignatures | Gets a value indicating whether form has signature fields.
Public property | IsEmpty | Gets a value indicating whether there are any fields in this form.
Public property | SavingWillInvalidateSignatures | Gets a value indicating whether saving the document will invalidate signatures.
Public property | TextAlignment | Gets or sets the text alignment for all child fields in the form (if not otherwise specified).
 | XFA | Gets a collection of StoredStream objects that represent packets of XFA data contained within a PDF Document. Each StoredStream will contain XML data that represents the XFA data. XFA may be contained within a single stream or within a collection of packets, each of which represents a subsection of the XFA model.
Top
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.DefaultAppearance Property

PdfFormDefaultAppearance Property

Gets or sets the default text appearance for all child fields in the form (if not otherwise specified)..

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance DefaultAppearance { get; set; }
Public Property DefaultAppearance As PdfTextAppearance
    Get
    Set

Property Value

Type: PdfTextAppearance
The default appearance.
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.FieldCalculationSequence Property

PdfFormFieldCalculationSequence Property

Gets the field calculation sequence. If form fields contain a field calculation, the order of calculation can be specified by this list. A PDF viewer will perform the recalculation based on the order of this list.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<IFormElement> FieldCalculationSequence { get; }
Public ReadOnly Property FieldCalculationSequence As IList(Of IFormElement)
    Get

Property Value

Type: IListIFormElement
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.Fields Property

PdfFormFields Property

Gets the fields present in this form. Any BaseWidgetAnnotation objects in the Fields tree must also be contained in an Annotations collection on a page in the document.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<IFormElement> Fields { get; }
Public ReadOnly Property Fields As IList(Of IFormElement)
    Get

Property Value

Type: IListIFormElement
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.FormHasSignatures Property

PdfFormFormHasSignatures Property

Gets a value indicating whether form has signature fields.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FormHasSignatures { get; }
Public ReadOnly Property FormHasSignatures As Boolean
    Get

Property Value

Type: Boolean
true if the form has signatures; otherwise, false.
Remarks
This is meant to be a hint to viewers and may not have been set properly by the generating software. When a PdfGeneratedDocument has been constructed from and existing PDF, this property will reflect the content of the file (correct or not). Upon writing out a document, DotPdf will automatically set this property for you, defaulting it to false and setting it to true if DotPdf encounters either a SignatureFormField or a SignatureWidgetAnnotation.
Examples
If you want to determine if a form has fields, you can use this code:
Copy
public static bool HasField(PdfForm form)
{
    if (form == null) return false;
    foreach (IFormElement elem in FormVisitor.BreadthFirst())
    {
        if (elem is SignatureFormField || elem is SignatureWidgetAnnotation)
            return true;
    }
    return false;
}
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.IsEmpty Property

PdfFormIsEmpty Property

Gets a value indicating whether there are any fields in this form.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the form does not contain fields; otherwise, false.
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.SavingWillInvalidateSignatures Property

PdfFormSavingWillInvalidateSignatures Property

Gets a value indicating whether saving the document will invalidate signatures.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SavingWillInvalidateSignatures { get; }
Public ReadOnly Property SavingWillInvalidateSignatures As Boolean
    Get

Property Value

Type: Boolean
true if saving will invalidate signatures; otherwise, false.
Remarks
The PDF specification for signatures uses data present in a partially written PDF file to create a data hash to verify that a document is consistent with its state when it was signed. Under certain conditions, it may be impossible to retain this ability. Generally speaking, DotPdf will completely rewrite a file when saving and this will invalidate any and all signatures in the file
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.TextAlignment Property

PdfFormTextAlignment Property

Gets or sets the text alignment for all child fields in the form (if not otherwise specified).

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As AnnotationTextAlignment
    Get
    Set

Property Value

Type: AnnotationTextAlignment
The text alignment.
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.XFA Property

PdfFormXFA Property

Gets a collection of StoredStream objects that represent packets of XFA data contained within a PDF Document. Each StoredStream will contain XML data that represents the XFA data. XFA may be contained within a single stream or within a collection of packets, each of which represents a subsection of the XFA model.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<StoredStream> XFA { get; }
Public ReadOnly Property XFA As IList(Of StoredStream)
    Get

Property Value

Type: IListStoredStream
Remarks
DotPdf makes no guarantees about the correctness of the data contained within the XFA packets nor will DotPdf make any attempt to validate data that is provided by client code or other sources before writing the streams to the file. Note that if the source document is signed, saving the new document will generate an exception. See DocumentWasSigned for more information.
Examples
PdfGeneratedDocument doc = new PdfGeneratedDocument("myform.pdf");
if (doc.Form == null) return;
foreach (StoredStream sstm in doc.Form.XFA) {
    ProcessXFAPacket(sstm.Aquire());
    sstm.Release();
}

PdfGenerateDocument changedoc = new PdfGeneratedDocument("myform.pdf");
if (doc.Form == null return;
if (doc.DocumentWasSigned) return; // can't reliably edit a signed document
TempFileStreamProvider provider = new TempFileStreamProvider();
StoredStream sstm = provider.MakeStream();
Stream stm = sstm.Aquire();
CopyNewXFAPacketToStream(stm);
sstm.Release();
doc.Form.XFA.Add(sstm);
doc.Save("newdataadded.pdf");
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm Methods

The PdfForm type exposes the following members.

Methods
 | Name | Description
Public method | ContainsFormElement | Determines whether this form contains the given IFormElement
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | EnforceParentage | Enforces the parent/child relationships in form elements within a form field hierarchy. This is done by doing a breadth-first traversal of all form elements and forcing the child elements to point back to the parent. Calling this method will ensure that FieldFullName will return the correct value. Before saving a document or validation this method will get called automatically. Calling this method will ensure that the FieldFullName property returns the correct value.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFieldLeaf | Determines whether a give IFormElement is a leaf or a node.
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. PdfForm does not require an object passed in.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the object looking for problems.
Top
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.ContainsFormElement Method

PdfFormContainsFormElement Method

Determines whether this form contains the given IFormElement

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ContainsFormElement(
    IFormElement given
)
Public Function ContainsFormElement (
    given As IFormElement
) As Boolean

Parameters

given
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The form element to search for.

Return Value

Type: Boolean
true if the form contains the given element; otherwise, false.
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.Dispose Method

PdfFormDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfForm
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PdfForm and optionally releases the managed resources
Top
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.Dispose Method

PdfFormDispose Method

Releases all resources used by the PdfForm

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfForm Class
Dispose Overload
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.Dispose Method (Boolean)

PdfFormDispose Method (Boolean)

Releases the unmanaged resources used by the PdfForm and optionally releases the managed resources

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PdfForm Class
Dispose Overload
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.EnforceParentage Method

PdfFormEnforceParentage Method

Enforces the parent/child relationships in form elements within a form field hierarchy. This is done by doing a breadth-first traversal of all form elements and forcing the child elements to point back to the parent. Calling this method will ensure that FieldFullName will return the correct value. Before saving a document or validation this method will get called automatically. Calling this method will ensure that the FieldFullName property returns the correct value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void EnforceParentage()
Public Sub EnforceParentage
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.IsFieldLeaf Method

PdfFormIsFieldLeaf Method

Determines whether a give IFormElement is a leaf or a node.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsFieldLeaf(
    IFormElement elem
)
Public Shared Function IsFieldLeaf (
    elem As IFormElement
) As Boolean

Parameters

elem
Type: Atalasoft.PdfDoc.Generating.FormsIFormElement
The form element.

Return Value

Type: Boolean
true if [is field leaf] [the specified elem]; otherwise, false.
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.MakeRepairContext Method

PdfFormMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object. PdfForm does not require an object passed in.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context. In PdfForm, this is ignored.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfForm.Validate Method

PdfFormValidate Method

Validates the object looking for problems.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext context
)
Public Sub Validate (
    problems As ProblemList,
    context As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
context
Type: Atalasoft.Shared.ValidationRepairContext
The context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

PdfForm Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfFormPropertyProblem Class

Defines a problem that could occur with the a PdfForm property value.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationBaseProblem
Atalasoft.Shared.ValidationProblem PdfForm, PdfFormRepairContext
Atalasoft.PdfDoc.Generating.FormsPdfFormPropertyProblem

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFormPropertyProblem : Problem<PdfForm, PdfFormRepairContext>
Public Class PdfFormPropertyProblem
    Inherits Problem(Of PdfForm, PdfFormRepairContext)

The PdfFormPropertyProblem type exposes the following members.

Constructors
 | Name | Description
Public method | PdfFormPropertyProblem | Initializes a new instance of the PdfFormPropertyProblem class.
Top
Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs. (Inherited from BaseProblem.)
Public property | Description | Gets or sets the description of the problem. (Inherited from BaseProblem.)
Public property | Name | Gets the name of the problem. (Inherited from BaseProblem.)
Public property | Source | Gets the source of the problem. (Inherited from ProblemT, U.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs this problem. (Inherited from ProblemT, U.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


PdfFormPropertyProblem Constructor

Initializes a new instance of the PdfFormPropertyProblem class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFormPropertyProblem(
    PdfForm source,
    string propertyName,
    string description,
    PdfRepairConsequences consequences,
    PdfFormRepairContext repairContext,
    ProblemT, UReparationMechanism reparation
)
Public Sub New (
    source As PdfForm,
    propertyName As String,
    description As String,
    consequences As PdfRepairConsequences,
    repairContext As PdfFormRepairContext,
    reparation As ProblemT, UReparationMechanism
)

Parameters

source
Type: Atalasoft.PdfDoc.Generating.FormsPdfForm
The source problem.
propertyName
Type: SystemString
Name of the property.
description
Type: SystemString
The description of the problem.
consequences
Type: Atalasoft.PdfDoc.Generating.ValidationPdfRepairConsequences
The description of the consequences of fixing the problem.
repairContext
Type: Atalasoft.PdfDoc.Generating.ValidationPdfFormRepairContext
The repair context.
reparation
Type: Atalasoft.Shared.ValidationProblemT, UReparationMechanism
The reparation action to take.
See Also

Reference

PdfFormPropertyProblem Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfFormPropertyProblem Properties

The PdfFormPropertyProblem type exposes the following members.

Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs. (Inherited from BaseProblem.)
Public property | Description | Gets or sets the description of the problem. (Inherited from BaseProblem.)
Public property | Name | Gets the name of the problem. (Inherited from BaseProblem.)
Public property | Source | Gets the source of the problem. (Inherited from ProblemT, U.)
Top
See Also

Reference

PdfFormPropertyProblem Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PdfFormPropertyProblem Methods

The PdfFormPropertyProblem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs this problem. (Inherited from ProblemT, U.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFormPropertyProblem Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PushButtonFormField Class

A PushButtonFormField represents a parent field of other IFormElement objects that are either PushButtonFormField objects or PushButtonWidgetAnnotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsBaseButtonFormField
Atalasoft.PdfDoc.Generating.FormsPushButtonFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PushButtonFormField : BaseButtonFormField
Public Class PushButtonFormField
    Inherits BaseButtonFormField

The PushButtonFormField type exposes the following members.

Constructors
 | Name | Description
Public method | PushButtonFormField | Initializes a new instance of the PushButtonFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance. (Overrides BaseButtonFormFieldImplementMe.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


PushButtonFormField Constructor

Initializes a new instance of the PushButtonFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PushButtonFormField()
Public Sub New
See Also

Reference

PushButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PushButtonFormField Properties

The PushButtonFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
See Also

Reference

PushButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PushButtonFormField Methods

The PushButtonFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance. (Overrides BaseButtonFormFieldImplementMe.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PushButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


PushButtonFormField.ImplementMe Method

PushButtonFormFieldImplementMe Method

Built for inheritance.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

PushButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField Class

A RadioButtonFormField represents a parent field of other IFormElement objects that are either RadioButtonFormField objects or RadioButtonWidgetAnnotations. Making a set of radio buttons that are wired up correctly can be a tricky process. RadioButtonWidgetAnnotations typically are not used without a parent RadioButtonFormField. It is typically easier to use the MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) method to make a set of radio buttons.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsBaseButtonFormField
Atalasoft.PdfDoc.Generating.FormsRadioButtonFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RadioButtonFormField : BaseButtonFormField
Public Class RadioButtonFormField
    Inherits BaseButtonFormField

The RadioButtonFormField type exposes the following members.

Constructors
 | Name | Description
Public method | RadioButtonFormField | Initializes a new instance of the RadioButtonFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | DefaultValue | Gets or sets the default string value.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Public property | Value | Gets or sets the string value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance. (Overrides BaseButtonFormFieldImplementMe.)
 | MakeRadioSet(String, String, String, RadioButtonWidgetAnnotation) | Makes a radio set from the collection of RadioButtonWidgetAnnotation objects. Note that it is the client's responsibility to ensure that the radio buttons are put into the Annotations collection of a page in the document.
 | MakeRadioSet(PdfGeneratedPage, String, String, String, RadioButtonWidgetAnnotation) | Makes the radio set from the set of radio buttons installing them in the supplied page (if any).
 | MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) | Makes a set of radio button fields with a single parent field. If currentValue or defaultValue are null, the code will substitute the standard radio button cleared value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField Constructor

Initializes a new instance of the RadioButtonFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RadioButtonFormField()
Public Sub New
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField Properties

The RadioButtonFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | DefaultValue | Gets or sets the default string value.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Public property | Value | Gets or sets the string value.
Top
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.DefaultValue Property

RadioButtonFormFieldDefaultValue Property

Gets or sets the default string value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set

Property Value

Type: String
The default value.
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.Value Property

RadioButtonFormFieldValue Property

Gets or sets the string value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value.
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField Methods

The RadioButtonFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ImplementMe | Built for inheritance. (Overrides BaseButtonFormFieldImplementMe.)
 | MakeRadioSet(String, String, String, RadioButtonWidgetAnnotation) | Makes a radio set from the collection of RadioButtonWidgetAnnotation objects. Note that it is the client's responsibility to ensure that the radio buttons are put into the Annotations collection of a page in the document.
 | MakeRadioSet(PdfGeneratedPage, String, String, String, RadioButtonWidgetAnnotation) | Makes the radio set from the set of radio buttons installing them in the supplied page (if any).
 | MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) | Makes a set of radio button fields with a single parent field. If currentValue or defaultValue are null, the code will substitute the standard radio button cleared value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.ImplementMe Method

RadioButtonFormFieldImplementMe Method

Built for inheritance.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void ImplementMe()
Protected Overrides Sub ImplementMe
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.MakeRadioSet Method

RadioButtonFormFieldMakeRadioSet Method

Overload List
Name | Description
MakeRadioSet(String, String, String, RadioButtonWidgetAnnotation) | Makes a radio set from the collection of RadioButtonWidgetAnnotation objects. Note that it is the client's responsibility to ensure that the radio buttons are put into the Annotations collection of a page in the document.
MakeRadioSet(PdfGeneratedPage, String, String, String, RadioButtonWidgetAnnotation) | Makes the radio set from the set of radio buttons installing them in the supplied page (if any).
MakeRadioSet(GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds) | Makes a set of radio button fields with a single parent field. If currentValue or defaultValue are null, the code will substitute the standard radio button cleared value.
Top
See Also

Reference

RadioButtonFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.MakeRadioSet Method (String, String, String, RadioButtonWidgetAnnotation[])

RadioButtonFormFieldMakeRadioSet Method (String, String, String, RadioButtonWidgetAnnotation)

Makes a radio set from the collection of RadioButtonWidgetAnnotation objects. Note that it is the client's responsibility to ensure that the radio buttons are put into the Annotations collection of a page in the document.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RadioButtonFormField MakeRadioSet(
    string fieldName,
    string currentValue,
    string defaultValue,
    params RadioButtonWidgetAnnotation[] radioButtons
)
Public Shared Function MakeRadioSet (
    fieldName As String,
    currentValue As String,
    defaultValue As String,
    ParamArray radioButtons As RadioButtonWidgetAnnotation()
) As RadioButtonFormField

Parameters

fieldName
Type: SystemString
The name of the output form field
currentValue
Type: SystemString
The current value of the set.
defaultValue
Type: SystemString
The default value of the set.
radioButtons
Type: Atalasoft.PdfDoc.Generating.AnnotationsRadioButtonWidgetAnnotation
The radio buttons.

Return Value

Type: RadioButtonFormField
A set of radio buttons arrached to a RadioButtonFormField
See Also

Reference

RadioButtonFormField Class
MakeRadioSet Overload
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.MakeRadioSet Method (PdfGeneratedPage, String, String, String, RadioButtonWidgetAnnotation[])

RadioButtonFormFieldMakeRadioSet Method (PdfGeneratedPage, String, String, String, RadioButtonWidgetAnnotation)

Makes the radio set from the set of radio buttons installing them in the supplied page (if any).

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RadioButtonFormField MakeRadioSet(
    PdfGeneratedPage owningPage,
    string fieldName,
    string currentValue,
    string defaultValue,
    params RadioButtonWidgetAnnotation[] radioButtons
)
Public Shared Function MakeRadioSet (
    owningPage As PdfGeneratedPage,
    fieldName As String,
    currentValue As String,
    defaultValue As String,
    ParamArray radioButtons As RadioButtonWidgetAnnotation()
) As RadioButtonFormField

Parameters

owningPage
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
The owning page.
fieldName
Type: SystemString
The name of the output form field
currentValue
Type: SystemString
The current value.
defaultValue
Type: SystemString
The default value.
radioButtons
Type: Atalasoft.PdfDoc.Generating.AnnotationsRadioButtonWidgetAnnotation
The radio buttons.

Return Value

Type: RadioButtonFormField
A set of radio buttons arrached to a RadioButtonFormField
See Also

Reference

RadioButtonFormField Class
MakeRadioSet Overload
Atalasoft.PdfDoc.Generating.Forms Namespace


RadioButtonFormField.MakeRadioSet Method (GlobalResources, PdfGeneratedPage, String, String, String, String[], PdfBounds[])

RadioButtonFormFieldMakeRadioSet Method (GlobalResources, PdfGeneratedPage, String, String, String, String, PdfBounds)

Makes a set of radio button fields with a single parent field. If currentValue or defaultValue are null, the code will substitute the standard radio button cleared value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static RadioButtonFormField MakeRadioSet(
    GlobalResources gr,
    PdfGeneratedPage owningPage,
    string fieldName,
    string currentValue,
    string defaultValue,
    string[] values,
    PdfBounds[] locations
)
Public Shared Function MakeRadioSet (
    gr As GlobalResources,
    owningPage As PdfGeneratedPage,
    fieldName As String,
    currentValue As String,
    defaultValue As String,
    values As String(),
    locations As PdfBounds()
) As RadioButtonFormField

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resources for holding button appearances.
owningPage
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
The page that will own the radio buttons.
fieldName
Type: SystemString
The name of the output form field
currentValue
Type: SystemString
The current setting from the set.
defaultValue
Type: SystemString
The default value for the set.
values
Type: SystemString
The possible values for the radio buttons.
locations
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The locations of each radio button.

Return Value

Type: RadioButtonFormField
A single parent RadioButtonFormField that represents a group of radio buttons and their current value (if any).
Examples
How to make a simple set of radio buttons with nothing selected and no default value. Note that this does not create any text on the page, just the buttons. The standard radio button appearance is just the functional part of the button and doesn't include any labeling so that it can be shared across many buttons.
Copy
RadioButtonFormField field = RadioButtonFormField.MakeRadioSet(doc.Resources, page,
          "CallMeHow",
          null, null,
          new string[] {"Yes", "No", "Maybe"},
          new PdfBounds[] { new PdfBounds(72, 100, 8, 8), new PdfBounds(72, 90, 8, 8), new PdfBounds(72, 80, 8, 8) });
doc.Form.Fields.Add(field);
See Also

Reference

RadioButtonFormField Class
MakeRadioSet Overload
Atalasoft.PdfDoc.Generating.Forms Namespace


SignatureFormField Class

A SignatureFormField represents a parent field of other IFormElement objects that are either SignatureFormField objects or SignatureWidgetAnnotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsSignatureFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SignatureFormField : BaseFormField
Public Class SignatureFormField
    Inherits BaseFormField

The SignatureFormField type exposes the following members.

Constructors
 | Name | Description
Public method | SignatureFormField | Initializes a new instance of the SignatureFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


SignatureFormField Constructor

Initializes a new instance of the SignatureFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SignatureFormField()
Public Sub New
See Also

Reference

SignatureFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


SignatureFormField Properties

The SignatureFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Top
See Also

Reference

SignatureFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


SignatureFormField Methods

The SignatureFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SignatureFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField Class

A TextFormField represents a parent field of other IFormElement objects that are either TextFormField objects or TextWidgetAnnotations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.FormsBaseFormField
Atalasoft.PdfDoc.Generating.FormsTextFormField

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TextFormField : BaseFormField
Public Class TextFormField
    Inherits BaseFormField

The TextFormField type exposes the following members.

Constructors
 | Name | Description
Public method | TextFormField | Initializes a new instance of the TextFormField class.
Top
Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | DefaultTextValue | Gets or sets the default text value.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsColumns | Gets or sets a value indicating whether child fields should be columns.
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | IsFileSelection | Gets or sets a value indicating whether child fields are file selection.
Public property | IsMultiLine | Gets or sets a value indicating whether child fields should be multi line.
Public property | IsPassword | Gets or sets a value indicating whether child fields should represent a password field.
Public property | IsRichText | Gets or sets a value indicating whether child fields are rich text.
Public property | IsScrollable | Gets or sets a value indicating whether child fields should be scrollable.
Public property | IsSpellChecked | Gets or sets a value indicating whether child fields should be spell checked.
Public property | MaximumLength | Gets or sets the maximum length for child fields.
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Public property | TextAlignment | Gets or sets the text alignment for child fields.
Public property | TextValue | Gets or sets the text value of this field
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField Constructor

Initializes a new instance of the TextFormField class.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TextFormField()
Public Sub New
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField Properties

The TextFormField type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalActions | Gets the additional actions that may be used by annotations that are children of this field. (Inherited from BaseFormField.)
Public property | ChildFields | Gets the child fields for this field. (Inherited from BaseFormField.)
Public property | DefaultTextAppearance | Gets or sets the default text appearance that is shared by children of this field. (Inherited from BaseFormField.)
Public property | DefaultTextValue | Gets or sets the default text value.
Public property | EnforceReadyOnlyWithException | Gets or sets a value indicating whether to enforce ready only with the IsFieldReadOnly propery with an exception. (Inherited from BaseFormField.)
Public property | FieldAlternateDescription | Gets or sets the field alternate description for display in the user interface. (Inherited from BaseFormField.)
Public property | FieldFullName | Gets the fully qualified name of the field. This value is only correct if ParentField has been set. When the parent chain is properly set up, this will return ParentField.FieldFullName + '.' + FieldName (Inherited from BaseFormField.)
Public property | FieldName | Gets or sets the name of the field. (Inherited from BaseFormField.)
Public property | FieldNameForExport | Gets or sets the field name for export. (Inherited from BaseFormField.)
Public property | IsColumns | Gets or sets a value indicating whether child fields should be columns.
Public property | IsFieldNoExport | Gets or sets a value indicating whether this field should not be export. (Inherited from BaseFormField.)
Public property | IsFieldReadOnly | Gets or sets a value indicating whether this field is read only. (Inherited from BaseFormField.)
Public property | IsFieldRequired | Gets or sets a value indicating whether this field is required. (Inherited from BaseFormField.)
Public property | IsFileSelection | Gets or sets a value indicating whether child fields are file selection.
Public property | IsMultiLine | Gets or sets a value indicating whether child fields should be multi line.
Public property | IsPassword | Gets or sets a value indicating whether child fields should represent a password field.
Public property | IsRichText | Gets or sets a value indicating whether child fields are rich text.
Public property | IsScrollable | Gets or sets a value indicating whether child fields should be scrollable.
Public property | IsSpellChecked | Gets or sets a value indicating whether child fields should be spell checked.
Public property | MaximumLength | Gets or sets the maximum length for child fields.
Public property | ParentField | Gets or sets the parent field. (Inherited from BaseFormField.)
Public property | TextAlignment | Gets or sets the text alignment for child fields.
Public property | TextValue | Gets or sets the text value of this field
Top
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.DefaultTextValue Property

TextFormFieldDefaultTextValue Property

Gets or sets the default text value.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultTextValue { get; set; }
Public Property DefaultTextValue As String
    Get
    Set

Property Value

Type: String
The default text value.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsColumns Property

TextFormFieldIsColumns Property

Gets or sets a value indicating whether child fields should be columns.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsColumns { get; set; }
Public Property IsColumns As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child fields are columns; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsFileSelection Property

TextFormFieldIsFileSelection Property

Gets or sets a value indicating whether child fields are file selection.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsFileSelection { get; set; }
Public Property IsFileSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child fields are file selection; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsMultiLine Property

TextFormFieldIsMultiLine Property

Gets or sets a value indicating whether child fields should be multi line.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsMultiLine { get; set; }
Public Property IsMultiLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child fields should be multi line; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsPassword Property

TextFormFieldIsPassword Property

Gets or sets a value indicating whether child fields should represent a password field.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsPassword { get; set; }
Public Property IsPassword As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child fields should be password fields; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsRichText Property

TextFormFieldIsRichText Property

Gets or sets a value indicating whether child fields are rich text.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRichText { get; set; }
Public Property IsRichText As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child fields are rich text; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsScrollable Property

TextFormFieldIsScrollable Property

Gets or sets a value indicating whether child fields should be scrollable.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsScrollable { get; set; }
Public Property IsScrollable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this child fields should be scrollable; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.IsSpellChecked Property

TextFormFieldIsSpellChecked Property

Gets or sets a value indicating whether child fields should be spell checked.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSpellChecked { get; set; }
Public Property IsSpellChecked As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child fields should be spell checked; otherwise, false.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.MaximumLength Property

TextFormFieldMaximumLength Property

Gets or sets the maximum length for child fields.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaximumLength { get; set; }
Public Property MaximumLength As Integer
    Get
    Set

Property Value

Type: Int32
The maximum length.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.TextAlignment Property

TextFormFieldTextAlignment Property

Gets or sets the text alignment for child fields.

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As AnnotationTextAlignment
    Get
    Set

Property Value

Type: AnnotationTextAlignment
The text alignment.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField.TextValue Property

TextFormFieldTextValue Property

Gets or sets the text value of this field

Namespace: Atalasoft.PdfDoc.Generating.Forms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TextValue { get; set; }
Public Property TextValue As String
    Get
    Set

Property Value

Type: String
The text value.
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


TextFormField Methods

The TextFormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowIfReadOnlyT | If EnforceReadyOnlyWithException is true and IsFieldReadOnly is true, throw an InvalidOperationException, otherwise return value. (Inherited from BaseFormField.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextFormField Class
Atalasoft.PdfDoc.Generating.Forms Namespace


Atalasoft.PdfDoc.Generating.Multimedia Namespace

Classes
 | Class | Description
 | Sound | Represents a sound for playback from a PDF file.
Public class | WavReader | WavReader is a simple implementation of a WAV file reader, implementing IWavReader.
Interfaces
 | Interface | Description
Public interface | IWavReader | IWavReader defines a class that represents the data within a WAV file. This is useful in creating a Sound object.
Enumerations
 | Enumeration | Description
Public enumeration | SoundEncodingFormat | Represents allowable PDF sound data formats.
Public enumeration | WavCompression | Compression formats available in the WAV file standard


IWavReader Interface

IWavReader defines a class that represents the data within a WAV file. This is useful in creating a Sound object.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IWavReader
Public Interface IWavReader

The IWavReader type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerSample | Gets the number bits per sample.
Public property | BlockAlignment | Gets the block alignment of data in the file.
Public property | BytesPerSecond | Gets the playback rate in bytes per second.
Public property | Channels | Gets the total number of channels of sound.
Public property | Compression | Gets the compression used in the data.
Public property | ExtraFormatBytes | Gets extra bytes that may represent further compression or data interpretation information.
Public property | SamplingRate | Gets the sampling rate of the sound data.
Top
Methods
 | Name | Description
Public method | GetDataStream | Gets a stream of possibly compressed sound data from the file.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader Properties

The IWavReader type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerSample | Gets the number bits per sample.
Public property | BlockAlignment | Gets the block alignment of data in the file.
Public property | BytesPerSecond | Gets the playback rate in bytes per second.
Public property | Channels | Gets the total number of channels of sound.
Public property | Compression | Gets the compression used in the data.
Public property | ExtraFormatBytes | Gets extra bytes that may represent further compression or data interpretation information.
Public property | SamplingRate | Gets the sampling rate of the sound data.
Top
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.BitsPerSample Property

IWavReaderBitsPerSample Property

Gets the number bits per sample.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
short BitsPerSample { get; }
ReadOnly Property BitsPerSample As Short
    Get

Property Value

Type: Int16
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.BlockAlignment Property

IWavReaderBlockAlignment Property

Gets the block alignment of data in the file.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int BlockAlignment { get; }
ReadOnly Property BlockAlignment As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.BytesPerSecond Property

IWavReaderBytesPerSecond Property

Gets the playback rate in bytes per second.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int BytesPerSecond { get; }
ReadOnly Property BytesPerSecond As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.Channels Property

IWavReaderChannels Property

Gets the total number of channels of sound.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int Channels { get; }
ReadOnly Property Channels As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.Compression Property

IWavReaderCompression Property

Gets the compression used in the data.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
WavCompression Compression { get; }
ReadOnly Property Compression As WavCompression
    Get

Property Value

Type: WavCompression
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.ExtraFormatBytes Property

IWavReaderExtraFormatBytes Property

Gets extra bytes that may represent further compression or data interpretation information.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
byte[] ExtraFormatBytes { get; }
ReadOnly Property ExtraFormatBytes As Byte()
    Get

Property Value

Type: Byte
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.SamplingRate Property

IWavReaderSamplingRate Property

Gets the sampling rate of the sound data.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
int SamplingRate { get; }
ReadOnly Property SamplingRate As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader Methods

The IWavReader type exposes the following members.

Methods
 | Name | Description
Public method | GetDataStream | Gets a stream of possibly compressed sound data from the file.
Top
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


IWavReader.GetDataStream Method

IWavReaderGetDataStream Method

Gets a stream of possibly compressed sound data from the file.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Stream GetDataStream()
Function GetDataStream As Stream

Return Value

Type: Stream
The sound data stream.
See Also

Reference

IWavReader Interface
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound Class

Represents a sound for playback from a PDF file.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.MultimediaSound

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Sound : IValidatable, ISerializable
<SerializableAttribute>
Public Class Sound
    Implements IValidatable, ISerializable

The Sound type exposes the following members.

Constructors
 | Name | Description
Public method | Sound | Initializes a new instance of the Sound class. SamplingRate will default to 22050, Channels to 1, BitsPerSample to 8, EncodingFormat to Raw and a null DataStream.
Protected method | Sound(SerializationInfo, StreamingContext) | Initializes a new instance of the Sound class.
Top
Properties
 | Name | Description
Public property | BitsPerSample | Gets or sets the bits per sample. Only 8 is supported.
Public property | Channels | Gets or sets the number of channels. This should be either 1 or 2.
Public property | DataStream | Gets or sets the data stream.
Public property | EncodingFormat | Gets or sets the encoding format.
Public property | SamplingRate | Gets or sets the sampling rate. For maximum compatibility this value is in Hz and should be one of: 8000, 11025, or 22050.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromWavReader | Constructs a new Sound from the given IWavReader class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified problems.
Top
Remarks
PDF accepts a wide range of values for sound parameters, but for maximum compatibility, you should limit yourself to with 8kHz, 11.025kHz, or 22.050kHz sampling rates, a multiple of 8 bits of data per sample per channel and either 1 or two channels. Because of these restrictions, it is easier to use pre-existing data that matches that format. WAV is typically the closest and can be handled with the WavReader class.
Examples
Making a sound annotation from an existing file.
Copy
FileStream stm = new FileStream("somefile.wav", FileMode.Open);
WavReader reader = new WavReader(stm);
Sound sound = Sound.FromWavReader(reader);
if (sound == null) // returns null if not a widely compatible format.
{
    // incompatible format
    stm.Close();
    throw new Exception("incompatible sound format");
}
See Also

Reference

Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound Constructor

Overload List
 | Name | Description
Public method | Sound | Initializes a new instance of the Sound class. SamplingRate will default to 22050, Channels to 1, BitsPerSample to 8, EncodingFormat to Raw and a null DataStream.
Protected method | Sound(SerializationInfo, StreamingContext) | Initializes a new instance of the Sound class.
Top
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound Constructor

Initializes a new instance of the Sound class. SamplingRate will default to 22050, Channels to 1, BitsPerSample to 8, EncodingFormat to Raw and a null DataStream.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Sound()
Public Sub New
See Also

Reference

Sound Class
Sound Overload
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Sound class.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected Sound(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info.
context
Type: System.Runtime.SerializationStreamingContext
The context.
See Also

Reference

Sound Class
Sound Overload
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound Properties

The Sound type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerSample | Gets or sets the bits per sample. Only 8 is supported.
Public property | Channels | Gets or sets the number of channels. This should be either 1 or 2.
Public property | DataStream | Gets or sets the data stream.
Public property | EncodingFormat | Gets or sets the encoding format.
Public property | SamplingRate | Gets or sets the sampling rate. For maximum compatibility this value is in Hz and should be one of: 8000, 11025, or 22050.
Top
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.BitsPerSample Property

SoundBitsPerSample Property

Gets or sets the bits per sample. Only 8 is supported.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BitsPerSample { get; set; }
Public Property BitsPerSample As Integer
    Get
    Set

Property Value

Type: Int32
The bits per sample.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.Channels Property

SoundChannels Property

Gets or sets the number of channels. This should be either 1 or 2.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channels { get; set; }
Public Property Channels As Integer
    Get
    Set

Property Value

Type: Int32
The number of channels.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.DataStream Property

SoundDataStream Property

Gets or sets the data stream.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream DataStream { get; set; }
Public Property DataStream As Stream
    Get
    Set

Property Value

Type: Stream
The data stream.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.EncodingFormat Property

SoundEncodingFormat Property

Gets or sets the encoding format.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SoundEncodingFormat EncodingFormat { get; set; }
Public Property EncodingFormat As SoundEncodingFormat
    Get
    Set

Property Value

Type: SoundEncodingFormat
The encoding format.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.SamplingRate Property

SoundSamplingRate Property

Gets or sets the sampling rate. For maximum compatibility this value is in Hz and should be one of: 8000, 11025, or 22050.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double SamplingRate { get; set; }
Public Property SamplingRate As Double
    Get
    Set

Property Value

Type: Double
The sampling rate.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound Methods

The Sound type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromWavReader | Constructs a new Sound from the given IWavReader class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates the specified problems.
Top
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.FromWavReader Method

SoundFromWavReader Method

Constructs a new Sound from the given IWavReader class.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Sound FromWavReader(
    IWavReader reader
)
Public Shared Function FromWavReader (
    reader As IWavReader
) As Sound

Parameters

reader
Type: Atalasoft.PdfDoc.Generating.MultimediaIWavReader
The reader.

Return Value

Type: Sound
A new Sound object if the WAV file contains generally compatible data, null otherwise.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.GetObjectData Method

SoundGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.MakeRepairContext Method

SoundMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext MakeRepairContext(
    Object o
)
Public Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.

Implements

IValidatableMakeRepairContext(Object)
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Sound.Validate Method

SoundValidate Method

Validates the specified problems.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Public Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The list of problems accumulated.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.

Implements

IValidatableValidate(ProblemList, RepairContext)
See Also

Reference

Sound Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


SoundEncodingFormat Enumeration

Represents allowable PDF sound data formats.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum SoundEncodingFormat
Public Enumeration SoundEncodingFormat
Members
Member name | Description
Raw | Raw, or pulse code modulation (PCM)
Signed | Data that should be interpreted as signed.
MuLaw | MuLaw compression
ALaw | ALaw compression
See Also

Reference

Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavCompression Enumeration

Compression formats available in the WAV file standard

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum WavCompression
Public Enumeration WavCompression
Members
Member name | Description
Unknown | Unknown
PCM | Pulse code modulation
ADPCM | Adapative differential pulse code modulation
ALaw | A-law compression
MuLaw | Mu-Law compression
IMAADPCM | Interactive Multimedia Association adaptive differential pulse code modulation
ITUG723 | G.723 speech codec
GSM610 | GSM 6.10 lossy compression
ITUG721 | G.721 speech codec
Mpeg | Mpeg compression
Experimental | Experimential - not recommended.
See Also

Reference

Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader Class

WavReader is a simple implementation of a WAV file reader, implementing IWavReader.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.MultimediaWavReader

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class WavReader : IWavReader
Public Class WavReader
    Implements IWavReader

The WavReader type exposes the following members.

Constructors
 | Name | Description
Public method | WavReader | Initializes a new instance of the WavReader class.
Top
Properties
 | Name | Description
Public property | BitsPerSample | Gets the number bits per sample.
Public property | BlockAlignment | Gets the block alignment of data in the file.
Public property | BytesPerSecond | Gets the playback rate in bytes per second.
Public property | Channels | Gets the total number of channels of sound.
Public property | Compression | Gets the compression used in the data.
Public property | ExtraFormatBytes | Gets extra bytes that may represent further compression or data interpretation information.
Public property | SamplingRate | Gets the sampling rate of the sound data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataStream | Gets a stream of possibly compressed sound data from the file. This is a sub stream of the data within the stream used to construct the class. Closing this stream will close the parent stream as well.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader Constructor

Initializes a new instance of the WavReader class.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WavReader(
    Stream stm
)
Public Sub New (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
The stream to read from. The stream should be at the start of the file.
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader Properties

The WavReader type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerSample | Gets the number bits per sample.
Public property | BlockAlignment | Gets the block alignment of data in the file.
Public property | BytesPerSecond | Gets the playback rate in bytes per second.
Public property | Channels | Gets the total number of channels of sound.
Public property | Compression | Gets the compression used in the data.
Public property | ExtraFormatBytes | Gets extra bytes that may represent further compression or data interpretation information.
Public property | SamplingRate | Gets the sampling rate of the sound data.
Top
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.BitsPerSample Property

WavReaderBitsPerSample Property

Gets the number bits per sample.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public short BitsPerSample { get; }
Public ReadOnly Property BitsPerSample As Short
    Get

Property Value

Type: Int16

Implements

IWavReaderBitsPerSample
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.BlockAlignment Property

WavReaderBlockAlignment Property

Gets the block alignment of data in the file.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BlockAlignment { get; }
Public ReadOnly Property BlockAlignment As Integer
    Get

Property Value

Type: Int32

Implements

IWavReaderBlockAlignment
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.BytesPerSecond Property

WavReaderBytesPerSecond Property

Gets the playback rate in bytes per second.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BytesPerSecond { get; }
Public ReadOnly Property BytesPerSecond As Integer
    Get

Property Value

Type: Int32

Implements

IWavReaderBytesPerSecond
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.Channels Property

WavReaderChannels Property

Gets the total number of channels of sound.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channels { get; }
Public ReadOnly Property Channels As Integer
    Get

Property Value

Type: Int32

Implements

IWavReaderChannels
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.Compression Property

WavReaderCompression Property

Gets the compression used in the data.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public WavCompression Compression { get; }
Public ReadOnly Property Compression As WavCompression
    Get

Property Value

Type: WavCompression

Implements

IWavReaderCompression
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.ExtraFormatBytes Property

WavReaderExtraFormatBytes Property

Gets extra bytes that may represent further compression or data interpretation information.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public byte[] ExtraFormatBytes { get; }
Public ReadOnly Property ExtraFormatBytes As Byte()
    Get

Property Value

Type: Byte

Implements

IWavReaderExtraFormatBytes
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.SamplingRate Property

WavReaderSamplingRate Property

Gets the sampling rate of the sound data.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SamplingRate { get; }
Public ReadOnly Property SamplingRate As Integer
    Get

Property Value

Type: Int32

Implements

IWavReaderSamplingRate
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader Methods

The WavReader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataStream | Gets a stream of possibly compressed sound data from the file. This is a sub stream of the data within the stream used to construct the class. Closing this stream will close the parent stream as well.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


WavReader.GetDataStream Method

WavReaderGetDataStream Method

Gets a stream of possibly compressed sound data from the file. This is a sub stream of the data within the stream used to construct the class. Closing this stream will close the parent stream as well.

Namespace: Atalasoft.PdfDoc.Generating.Multimedia
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream GetDataStream()
Public Function GetDataStream As Stream

Return Value

Type: Stream
A Stream of sound data

Implements

IWavReaderGetDataStream
See Also

Reference

WavReader Class
Atalasoft.PdfDoc.Generating.Multimedia Namespace


Atalasoft.PdfDoc.Generating.Rendering Namespace

Classes
Class Description
Public class DocumentRenderer
The DocumentRenderer class is an abstract class that defines how a PdfGeneratedDocument is rendered into some other form. DocumentRenderer defines the process of rendering, but doesn't define the actual steps. In this way one concrete instance of DocumentRenderer could create a PDF file from a PdfGeneratedDocument and another could create a WPF approximation of a single page within a PdfGeneratedDocument, but both renderers could be treated the same in client code.
Public class FontEventArgs
The class containing the font event data.
PdfARenderer
PdfARenderer is a concrete implementation of the DocumentRenderer class. It is responsible for creating PDF/A files/streams from PdfGeneratedDocument objects. During render operations different PDF/A specific exceptions can occur. See the Exceptions section for details.
Public class PdfDrawingList
PdfDrawing list is a container class used to hold a collection of IPdfRenderable. PdfDrawingList is itself IPdfRenderable allowing nesting or structural grouping of Pdf content generating objects.
Public class PdfDrawingSurface
PdfDrawingSurface is an abstract class that defines the drawing operations that can be performed on PDF page or other PDF content item. In this model, there is a notion of current path. A path a set of possibly disjoint lines or curves. A path or any of its sub paths may be closed open. An existing path may have more paths added to it. When any of the painting operations are performed, the current path will be cleared - unless the user performs a GSave operation in the containing PdfPageRenderer object before painting. Paths may be stroked, painted, painted and stroked, or clipped. Clipping is cumulative. Clipping to a path can only reduce the current clipping region or keep it the same size. Use GSave/GRestore to make temporary changes to the clipping region. In addition, a tranformation matrix may be applied to the drawing surface that will be incorporated into the current transformation. Transformations are cumulative and will affect all subsequent drawing unless managed with a GSave/Grestore operation. Before any operations can be performed on a PdfDrawingSurface, client code is required to call Begin. Client code should also call End when done. Begin and End are very efficient operations.
Public class PdfLineStyle
Represents all the elements that defines the style of stoked lines in PDF content.
Public class PdfPageRenderer
PdfPageRenderer is an abstract class that represents mechanisms for generating or rendering PDF content from a PdfGenerated page.
Public class PdfPathOperation
PdfPathOperation is a class that represents actions taken to create a path and the encapsulated data. PdfPathOperation objects are not constructed directly, but are instead made through static factory methods or through convenience methods in higher level shape objects such as PdfPath.
PdfRenderer
PdfRenderer is a concrete implementation of the DocumentRenderer class. It is responsible for creating PDF files/streams from PdfGeneratedDocument objects. Most client applications concerned with creating PDF files will either use this class or the Save method in PdfGeneratedDocument (which in turns uses PdfRenderer).
Public class PdfTextAppearance
PdfTextAppearance represents the general characteristics of text on page, including font name, size, character spacing, leading, and so on.
Public class PdfTextSurface
PdfTextSurface is used to add Text objects to the pdf display list.
Public class RenderProgressEventArgs
This class represents information about progress made during PDF Rendering.
Interfaces
 | Interface | Description
Public interface | IOpaqueDrawingList | This interface is meant to denote drawing lists that were imported from existing PDF content that could not be translated into IPdfRenderable objects. Opaque drawing lists may be removed from their page or reordered within the list, but they cannot be put into any other list.
Public interface | IPdfImageExtractor | The interface for a class that extract images from a PDF document.
Public interface | IPdfImageExtractorT |
Public interface | IPdfRenderable | Represents objects that can generate PDF document content,
Public interface | IPdfRenderableContainer | This interface is used for certain classes of rendering objects that may need to do meta-rendering. In such cases, an object should implement IPdfRenderableContainer. When it is rendered, it first have PreRender called, then Render, then PostRender. An object may not implement IPdfRenderableContainer alone. It must also implement IPdfRenderable. For example, PdfMarkedContent is a container of other renderer content and does no rendering of its own. Instead, on PreRender it informs the renderer that marked content will follow. The renderer will automatically pick up its DrawingList (since PdfMarkedContent also implements IEumerable<IPdfRenderable>) and render its contents, then on PostRender, it will inform the renderer that marked content is complete.
Enumerations
 | Enumeration | Description
Public enumeration | PathAction | PathAction describes elements that are used in describing a path or subpath
Public enumeration | PdfFillMethod | Defines how a path in PDF page content will be filled.
Public enumeration | PdfLineCapStyle | Represents the way that ends of stroked paths will look.
Public enumeration | PdfLineJoinStyle | Represents how transitions in segments in path will look.


DocumentRenderer Class

The DocumentRenderer class is an abstract class that defines how a PdfGeneratedDocument is rendered into some other form. DocumentRenderer defines the process of rendering, but doesn't define the actual steps. In this way one concrete instance of DocumentRenderer could create a PDF file from a PdfGeneratedDocument and another could create a WPF approximation of a single page within a PdfGeneratedDocument, but both renderers could be treated the same in client code.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingDocumentRenderer
Atalasoft.PdfDoc.Generating.RenderingPdfRenderer

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class DocumentRenderer
Public MustInherit Class DocumentRenderer

The DocumentRenderer type exposes the following members.

Constructors
 | Name | Description
Protected method | DocumentRenderer | Initializes a new instance of the DocumentRenderer class
Top
Properties
 | Name | Description
Protected property | ErrorOccurred | Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLBeginDoc | This method represents the Low-Level implementation of BeginDoc. It is called once at the start of rendering the document after the first DocumentProgress event has been fired, but before the first page is rendered. If a document has an empty Pages collection, LLBeginDoc will not be called. The default implementation does nothing.
Protected method | LLBeginPage | This method represents the Low-Level implementation of BeginPage. A subclass of DocumentRenderer would implement this method to do any processing to set up for rendering a given page. For exmaple, a particular rendered might need to create GDI Graphics objects or clear a frame buffer before rendering a page.
Protected method | LLEndDoc | This method represents the Low-Level implementation of EndDoc. It is called once at the end of rendering a document after the final DocumentProgress event has been fired. If a document has an empty Pages collection, LLEndDoc will not be called. A concrete implementation of DocumentRenderer could use this method for cleaning up temporary files created during the rendering process.
Protected method | LLEndPage | This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing.
Protected method | LLGenerate | This method represents the Low-Level implementation of code used to generate PDF content for a particular page. A complete implementation of this method should call the GeneratePdf method of the page's DrawlingList property, passing in the given PdfPageRenderer object. The default implementation does nothing.
Protected method | MakePageRenderer | Makes the PdfPageRenderer that will be used for each page being rendered. When rendering a document, MakeWriter will be called once for every page that is rendered. A concrete implementation of DocumentRenderer must implement this method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDocumentProgress | Raises the [E:DocumentProgress] event.
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument.
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DocumentProgress | Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer Constructor

Initializes a new instance of the DocumentRenderer class

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected DocumentRenderer()
Protected Sub New
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer Properties

The DocumentRenderer type exposes the following members.

Properties
 | Name | Description
Protected property | ErrorOccurred | Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins.
Top
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.ErrorOccurred Property

DocumentRendererErrorOccurred Property

Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected bool ErrorOccurred { get; set; }
Protected Property ErrorOccurred As Boolean
    Get
    Set

Property Value

Type: Boolean
true if an error occurred; otherwise, false.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer Methods

The DocumentRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLBeginDoc | This method represents the Low-Level implementation of BeginDoc. It is called once at the start of rendering the document after the first DocumentProgress event has been fired, but before the first page is rendered. If a document has an empty Pages collection, LLBeginDoc will not be called. The default implementation does nothing.
Protected method | LLBeginPage | This method represents the Low-Level implementation of BeginPage. A subclass of DocumentRenderer would implement this method to do any processing to set up for rendering a given page. For exmaple, a particular rendered might need to create GDI Graphics objects or clear a frame buffer before rendering a page.
Protected method | LLEndDoc | This method represents the Low-Level implementation of EndDoc. It is called once at the end of rendering a document after the final DocumentProgress event has been fired. If a document has an empty Pages collection, LLEndDoc will not be called. A concrete implementation of DocumentRenderer could use this method for cleaning up temporary files created during the rendering process.
Protected method | LLEndPage | This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing.
Protected method | LLGenerate | This method represents the Low-Level implementation of code used to generate PDF content for a particular page. A complete implementation of this method should call the GeneratePdf method of the page's DrawlingList property, passing in the given PdfPageRenderer object. The default implementation does nothing.
Protected method | MakePageRenderer | Makes the PdfPageRenderer that will be used for each page being rendered. When rendering a document, MakeWriter will be called once for every page that is rendered. A concrete implementation of DocumentRenderer must implement this method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDocumentProgress | Raises the [E:DocumentProgress] event.
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument.
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.LLBeginDoc Method

DocumentRendererLLBeginDoc Method

This method represents the Low-Level implementation of BeginDoc. It is called once at the start of rendering the document after the first DocumentProgress event has been fired, but before the first page is rendered. If a document has an empty Pages collection, LLBeginDoc will not be called. The default implementation does nothing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLBeginDoc(
    PdfGeneratedDocument document
)
Protected Overridable Sub LLBeginDoc (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.LLBeginPage Method

DocumentRendererLLBeginPage Method

This method represents the Low-Level implementation of BeginPage. A subclass of DocumentRenderer would implement this method to do any processing to set up for rendering a given page. For exmaple, a particular rendered might need to create GDI Graphics objects or clear a frame buffer before rendering a page.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLBeginPage(
    PdfGeneratedDocument document,
    BasePage page
)
Protected Overridable Sub LLBeginPage (
    document As PdfGeneratedDocument,
    page As BasePage
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document being rendered.
page
Type: Atalasoft.PdfDocBasePage
The page that is about to be rendered.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.LLEndDoc Method

DocumentRendererLLEndDoc Method

This method represents the Low-Level implementation of EndDoc. It is called once at the end of rendering a document after the final DocumentProgress event has been fired. If a document has an empty Pages collection, LLEndDoc will not be called. A concrete implementation of DocumentRenderer could use this method for cleaning up temporary files created during the rendering process.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLEndDoc(
    PdfGeneratedDocument document
)
Protected Overridable Sub LLEndDoc (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.LLEndPage Method

DocumentRendererLLEndPage Method

This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLEndPage(
    PdfGeneratedDocument document,
    BasePage page
)
Protected Overridable Sub LLEndPage (
    document As PdfGeneratedDocument,
    page As BasePage
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document being rendered.
page
Type: Atalasoft.PdfDocBasePage
The current page that was just rendered.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.LLGenerate Method

DocumentRendererLLGenerate Method

This method represents the Low-Level implementation of code used to generate PDF content for a particular page. A complete implementation of this method should call the GeneratePdf method of the page's DrawlingList property, passing in the given PdfPageRenderer object. The default implementation does nothing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LLGenerate(
    PdfGeneratedDocument document,
    BasePage page,
    PdfPageRenderer renderer
)
Protected Overridable Sub LLGenerate (
    document As PdfGeneratedDocument,
    page As BasePage,
    renderer As PdfPageRenderer
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document being rendered.
page
Type: Atalasoft.PdfDocBasePage
The page being rendered.
renderer
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The PdfPageRenderer object returned by MakeWriter.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.MakePageRenderer Method

DocumentRendererMakePageRenderer Method

Makes the PdfPageRenderer that will be used for each page being rendered. When rendering a document, MakeWriter will be called once for every page that is rendered. A concrete implementation of DocumentRenderer must implement this method.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PdfPageRenderer MakePageRenderer(
    PdfGeneratedDocument document,
    BasePage page
)
Protected MustOverride Function MakePageRenderer (
    document As PdfGeneratedDocument,
    page As BasePage
) As PdfPageRenderer

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document being rendered.
page
Type: Atalasoft.PdfDocBasePage
The page that is about to be rendered.

Return Value

Type: PdfPageRenderer
A new PdfPageRenderer
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.OnDocumentProgress Method

DocumentRendererOnDocumentProgress Method

Raises the [E:DocumentProgress] event.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnDocumentProgress(
    RenderProgressEventArgs e
)
Protected Overridable Sub OnDocumentProgress (
    e As RenderProgressEventArgs
)

Parameters

e
Type: Atalasoft.PdfDoc.Generating.RenderingRenderProgressEventArgs
The RenderProgressEventArgs instance containing the event data.
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.Render Method

DocumentRendererRender Method

Overload List
 | Name | Description
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument.
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined.
Top
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.Render Method (PdfGeneratedDocument)

DocumentRendererRender Method (PdfGeneratedDocument)

Renders the entire PdfGeneratedDocument.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfGeneratedDocument document
)
Public Sub Render (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
See Also

Reference

DocumentRenderer Class
Render Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.Render Method (PdfGeneratedDocument, ICollection(BasePage))

DocumentRendererRender Method (PdfGeneratedDocument, ICollectionBasePage)

Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfGeneratedDocument document,
    ICollection<BasePage> pages
)
Public Sub Render (
    document As PdfGeneratedDocument,
    pages As ICollection(Of BasePage)
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document to render.
pages
Type: System.Collections.GenericICollectionBasePage
An enumerable collection of pages to render.
Examples
Copy
public void RenderFirstPage(PdfGeneratedDocument doc, DocumentRenderer renderer)
{
    renderer.Render(doc, new PdfBasePage[] { doc.Pages[0] });
}
See Also

Reference

DocumentRenderer Class
Render Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer Events

The DocumentRenderer type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired.
Top
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


DocumentRenderer.DocumentProgress Event

DocumentRendererDocumentProgress Event

Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<RenderProgressEventArgs> DocumentProgress
Public Event DocumentProgress As EventHandler(Of RenderProgressEventArgs)

Value

Type: SystemEventHandlerRenderProgressEventArgs
See Also

Reference

DocumentRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs Class

The class containing the font event data.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.PdfDoc.Generating.RenderingFontEventArgs

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FontEventArgs : EventArgs
Public Class FontEventArgs
    Inherits EventArgs

The FontEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FontEventArgs | Initializes a new instance of the FontEventArgs class
Top
Properties
 | Name | Description
Public property | AlternativeFontPath | Gets or sets path to the TrueType font file.
Public property | FontResource | Gets PDF font resource that have not stream.
Public property | GlobalFontName | Gets global name of PDF font resource that have not stream. If for some reasons the font has not been imported to global resources, this value will be null.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs Constructor

Initializes a new instance of the FontEventArgs class

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FontEventArgs(
    PdfFontResource resource,
    string globalName
)
Public Sub New (
    resource As PdfFontResource,
    globalName As String
)

Parameters

resource
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
globalName
Type: SystemString
See Also

Reference

FontEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs Properties

The FontEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlternativeFontPath | Gets or sets path to the TrueType font file.
Public property | FontResource | Gets PDF font resource that have not stream.
Public property | GlobalFontName | Gets global name of PDF font resource that have not stream. If for some reasons the font has not been imported to global resources, this value will be null.
Top
See Also

Reference

FontEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs.AlternativeFontPath Property

FontEventArgsAlternativeFontPath Property

Gets or sets path to the TrueType font file.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AlternativeFontPath { get; set; }
Public Property AlternativeFontPath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

FontEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs.FontResource Property

FontEventArgsFontResource Property

Gets PDF font resource that have not stream.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontResource FontResource { get; }
Public ReadOnly Property FontResource As PdfFontResource
    Get

Property Value

Type: PdfFontResource
See Also

Reference

FontEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs.GlobalFontName Property

FontEventArgsGlobalFontName Property

Gets global name of PDF font resource that have not stream. If for some reasons the font has not been imported to global resources, this value will be null.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GlobalFontName { get; }
Public ReadOnly Property GlobalFontName As String
    Get

Property Value

Type: String
See Also

Reference

FontEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


FontEventArgs Methods

The FontEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FontEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


IOpaqueDrawingList Interface

This interface is meant to denote drawing lists that were imported from existing PDF content that could not be translated into IPdfRenderable objects. Opaque drawing lists may be removed from their page or reordered within the list, but they cannot be put into any other list.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IOpaqueDrawingList
Public Interface IOpaqueDrawingList
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfImageExtractor Interface

The interface for a class that extract images from a PDF document.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfImageExtractor
Public Interface IPdfImageExtractor

The IPdfImageExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractPages | Extracts the pages from the PdfGeneratedDocument object as images.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfImageExtractor Methods

The IPdfImageExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractPages | Extracts the pages from the PdfGeneratedDocument object as images.
Top
See Also

Reference

IPdfImageExtractor Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfImageExtractor.ExtractPages Method

IPdfImageExtractorExtractPages Method

Extracts the pages from the PdfGeneratedDocument object as images.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IEnumerable ExtractPages(
    PdfGeneratedDocument doc,
    IEnumerable<int> pageIndexes = null
)
Function ExtractPages (
    doc As PdfGeneratedDocument,
    Optional pageIndexes As IEnumerable(Of Integer) = Nothing
) As IEnumerable

Parameters

doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
PdfGeneratedDocument object.
pageIndexes (Optional)
Type: System.Collections.GenericIEnumerableInt32
Indexes of pages to be extracted. If is , then all pages will be extracted.

Return Value

Type: IEnumerable
Extracted page images.
See Also

Reference

IPdfImageExtractor Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfImageExtractor(T) Interface

IPdfImageExtractorT Interface

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfImageExtractor<T> : IPdfImageExtractor

Public Interface IPdfImageExtractor(Of T)
    Inherits IPdfImageExtractor

Type Parameters

T
Type of image that will be extracted.

The IPdfImageExtractorT type exposes the following members.

Methods
 | Name | Description
Public method | ExtractPages | Extracts the pages from the PdfGeneratedDocument object as images.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfImageExtractor(T) Methods

IPdfImageExtractorT Methods

The IPdfImageExtractorT generic type exposes the following members.

Methods
 | Name | Description
Public method | ExtractPages | Extracts the pages from the PdfGeneratedDocument object as images.
Top
See Also

Reference

IPdfImageExtractorT Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfImageExtractor(T).ExtractPages Method

IPdfImageExtractorTExtractPages Method

Extracts the pages from the PdfGeneratedDocument object as images.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IEnumerable<T> ExtractPages(
    PdfGeneratedDocument doc,
    IEnumerable<int> pageIndexes = null
)
Function ExtractPages (
    doc As PdfGeneratedDocument,
    Optional pageIndexes As IEnumerable(Of Integer) = Nothing
) As IEnumerable(Of T)

Parameters

doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
PdfGeneratedDocument object.
pageIndexes (Optional)
Type: System.Collections.GenericIEnumerableInt32
Indexes of pages to be extracted. If is , then all pages will be extracted.

Return Value

Type: IEnumerableT
Extracted page images.
See Also

Reference

IPdfImageExtractorT Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderable Interface

Represents objects that can generate PDF document content,

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfRenderable
Public Interface IPdfRenderable

The IPdfRenderable type exposes the following members.

Properties
Name | Description
Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
Methods
Name | Description
Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderable Properties

The IPdfRenderable type exposes the following members.

Properties
Name | Description
Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
See Also

Reference

IPdfRenderable Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderable.Name Property

IPdfRenderableName Property

Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String
The name of the object.
Examples
Copy
foreach (IPdfRenderable namedGroup in list.FindAll(item => item.Name == "Group") {
   ProcessGroup(namedGroup);
}
See Also

Reference

IPdfRenderable Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderable Methods

The IPdfRenderable type exposes the following members.

Methods
Name | Description
Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Top
See Also

Reference

IPdfRenderable Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderable.Render Method

IPdfRenderableRender Method

Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Render(
    PdfPageRenderer r
)
Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The PdfPageRenderer for generating PDF.
Examples
Copy
public void GeneratePdf(PdfPageRenderer r)
{
   w.DrawingSurface.Begin();
   w.DrawingSurface.AddRect(MyBounds); // place a rectangle
   w.DrawingSurface.Stroke(PdfLineStyle.Default, MyColor); // draw its outline in black
   w.DrawingSurface.End();
}
See Also

Reference

IPdfRenderable Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderableContainer Interface

This interface is used for certain classes of rendering objects that may need to do meta-rendering. In such cases, an object should implement IPdfRenderableContainer. When it is rendered, it first have PreRender called, then Render, then PostRender. An object may not implement IPdfRenderableContainer alone. It must also implement IPdfRenderable. For example, PdfMarkedContent is a container of other renderer content and does no rendering of its own. Instead, on PreRender it informs the renderer that marked content will follow. The renderer will automatically pick up its DrawingList (since PdfMarkedContent also implements IEumerable<IPdfRenderable>) and render its contents, then on PostRender, it will inform the renderer that marked content is complete.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfRenderableContainer
Public Interface IPdfRenderableContainer

The IPdfRenderableContainer type exposes the following members.

Methods
 | Name | Description
Public method | PostRender | This method is called after rendering is complete. This is an opportunity for the object to clean up previous work or restore prior state. The value returned by PreRender(PdfPageRenderer) is passed in the parameter memento.
Public method | PreRender | This method is called before rendering happens. This is an opportunity for the object to create or save information for later use or restoration. The value returned is a memento that will be passed back to the object when PostRender(PdfPageRenderer, Object) is called.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderableContainer Methods

The IPdfRenderableContainer type exposes the following members.

Methods
 | Name | Description
Public method | PostRender | This method is called after rendering is complete. This is an opportunity for the object to clean up previous work or restore prior state. The value returned by PreRender(PdfPageRenderer) is passed in the parameter memento.
Public method | PreRender | This method is called before rendering happens. This is an opportunity for the object to create or save information for later use or restoration. The value returned is a memento that will be passed back to the object when PostRender(PdfPageRenderer, Object) is called.
Top
See Also

Reference

IPdfRenderableContainer Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderableContainer.PostRender Method

IPdfRenderableContainerPostRender Method

This method is called after rendering is complete. This is an opportunity for the object to clean up previous work or restore prior state. The value returned by PreRender(PdfPageRenderer) is passed in the parameter memento.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void PostRender(
    PdfPageRenderer r,
    Object memento
)
Sub PostRender (
    r As PdfPageRenderer,
    memento As Object
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The r.
memento
Type: SystemObject
The memento.
See Also

Reference

IPdfRenderableContainer Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


IPdfRenderableContainer.PreRender Method

IPdfRenderableContainerPreRender Method

This method is called before rendering happens. This is an opportunity for the object to create or save information for later use or restoration. The value returned is a memento that will be passed back to the object when PostRender(PdfPageRenderer, Object) is called.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
Object PreRender(
    PdfPageRenderer r
)
Function PreRender (
    r As PdfPageRenderer
) As Object

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The renderer.

Return Value

Type: Object
A memento that will be sent back in PostRender(PdfPageRenderer, Object)
See Also

Reference

IPdfRenderableContainer Interface
Atalasoft.PdfDoc.Generating.Rendering Namespace


PathAction Enumeration

PathAction describes elements that are used in describing a path or subpath

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PathAction
Public Enumeration PathAction
Members
Member name | Description
Move | Move to a new location in the path. This is used to either start a new path or a new subpath.
Line | Extends the current path or subpath by connection a line from the last location in the current path to a new point
Curve | Extends the current path or subpath by adding a Bezier curve from the last location in the current path through two control points and ending with the final path.
Close | Closes the current path or subpath by connection a straight line segment from the the last point in the current path to the first point in the current path. Note that closing a path is different from simply doing a Line operation to the last point in that if the path is stroked, the corners will be correctly mitered with a Close but will not be mitered with a Line.
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer Class

PdfARenderer is a concrete implementation of the DocumentRenderer class. It is responsible for creating PDF/A files/streams from PdfGeneratedDocument objects. During render operations different PDF/A specific exceptions can occur. See the Exceptions section for details.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingDocumentRenderer
Atalasoft.PdfDoc.Generating.RenderingPdfRenderer
Atalasoft.PdfDoc.Generating.RenderingPdfARenderer

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfARenderer : PdfRenderer
Public Class PdfARenderer
    Inherits PdfRenderer

The PdfARenderer type exposes the following members.

Constructors
 | Name | Description
Public method | PdfARenderer | Initializes a new instance of the PdfARenderer class.
Top
Properties
 | Name | Description
Public property | CmykColorSpace | Gets or sets the CMYK color space that will be provided to each CMYK image.
Public property | ConvertIncompatiblePagesToImages | Gets or sets a value indicating whether the page that cannot be converted to PDF/A, will be converted to the image, instead of throwing PdfAException. ImageExtractor is required to use this flag.
Protected property | CurrentPage | (Inherited from PdfRenderer.)
Public property | DefaultRgbColorSpace | Gets default RGB color space resource.
Protected property | ErrorOccurred | Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins. (Inherited from DocumentRenderer.)
Public property | IgnoreUnsupportedAnnotsAndActions | Gets or sets a value indicating whether annotations and actions that not supported by the PDF/A-1b standard will be ignored, instead of throwing PdfAException.
Public property | ImageExtractor | Gets or sets the image extractor.
Public property | RgbColorSpace | Gets or sets the RGB color space that will be used in OutputIntents of PDF/A document. If value is not specified, DefaultRgbColorSpace will be used.
Protected property | SaveOptions | (Inherited from PdfRenderer.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLBeginDoc | (Overrides PdfRendererLLBeginDoc(PdfGeneratedDocument).)
Protected method | LLBeginPage | Low Level the begin page. (Inherited from PdfRenderer.)
Protected method | LLEndDoc | (Overrides PdfRendererLLEndDoc(PdfGeneratedDocument).)
Protected method | LLEndPage | This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing. (Inherited from PdfRenderer.)
Protected method | LLGenerate | (Overrides PdfRendererLLGenerate(PdfGeneratedDocument, BasePage, PdfPageRenderer).)
Protected method | MakePageRenderer | Makes the page renderer. (Inherited from PdfRenderer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDocumentProgress | Raises the [E:DocumentProgress] event. (Inherited from DocumentRenderer.)
Protected method | OnStreamlessFontFound |
Protected method | PreprocessPageResources | (Overrides PdfRendererPreprocessPageResources(PdfPageRenderer, PdfGeneratedPage).)
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument. (Inherited from DocumentRenderer.)
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined. (Inherited from DocumentRenderer.)
Protected method | RenderBookmarkTree | (Inherited from PdfRenderer.)
Protected method | RenderForm | (Overrides PdfRendererRenderForm(PdfGeneratedDocument, Boolean).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DocumentProgress | Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired. (Inherited from DocumentRenderer.)
Public event | StreamlessFontFound | Occurs when not embedded font will be found.
Top
Exceptions
Exception | Condition
PdfAActionException | Occurs, when input document contains actions unsupported by PDF/A.
PdfAAnnotationException | Occurs, when input document contains annotations unsupported by PDF/A, or when annotation appearance doesn't complaint PDF/A.
PdfAException | General error. See the exception message for details.
PdfAImageAndColorSpaceException | Occurs, when input PDF document contains content with CMYK colorspace and property CmykColorSpace is not set.
PdfAFontException | Occurs, when PdfARenderer can't create PDF/A complaint document because of issues with fonts. See the details in exception message.
Examples
Copy
public MemoryStream SaveToMemoryStream(PdfGeneratedDocument doc)
{
    MemoryStream stm = new MemoryStream();
    PdfARenderer renderer = new PdfARenderer(stm);
    renderer.Render(doc);
    return stm;
}
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer Constructor

Initializes a new instance of the PdfARenderer class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfARenderer(
    Stream outStream,
    bool embedGeneratedContent = true
)
Public Sub New (
    outStream As Stream,
    Optional embedGeneratedContent As Boolean = true
)

Parameters

outStream
Type: System.IOStream
The out stream.
embedGeneratedContent (Optional)
Type: SystemBoolean
if set to true [embed generated content].
Remarks

PDF/A does not support JavaScript actions, so SelfPrinting will be ignored during the saving.

See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer Properties

The PdfARenderer type exposes the following members.

Properties
 | Name | Description
Public property | CmykColorSpace | Gets or sets the CMYK color space that will be provided to each CMYK image.
Public property | ConvertIncompatiblePagesToImages | Gets or sets a value indicating whether the page that cannot be converted to PDF/A, will be converted to the image, instead of throwing PdfAException. ImageExtractor is required to use this flag.
Protected property | CurrentPage | (Inherited from PdfRenderer.)
Public property | DefaultRgbColorSpace | Gets default RGB color space resource.
Protected property | ErrorOccurred | Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins. (Inherited from DocumentRenderer.)
Public property | IgnoreUnsupportedAnnotsAndActions | Gets or sets a value indicating whether annotations and actions that not supported by the PDF/A-1b standard will be ignored, instead of throwing PdfAException.
Public property | ImageExtractor | Gets or sets the image extractor.
Public property | RgbColorSpace | Gets or sets the RGB color space that will be used in OutputIntents of PDF/A document. If value is not specified, DefaultRgbColorSpace will be used.
Protected property | SaveOptions | (Inherited from PdfRenderer.)
Top
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.CmykColorSpace Property

PdfARendererCmykColorSpace Property

Gets or sets the CMYK color space that will be provided to each CMYK image.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfIccColorSpaceResource CmykColorSpace { get; set; }
Public Property CmykColorSpace As PdfIccColorSpaceResource
    Get
    Set

Property Value

Type: PdfIccColorSpaceResource
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.ConvertIncompatiblePagesToImages Property

PdfARendererConvertIncompatiblePagesToImages Property

Gets or sets a value indicating whether the page that cannot be converted to PDF/A, will be converted to the image, instead of throwing PdfAException. ImageExtractor is required to use this flag.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ConvertIncompatiblePagesToImages { get; set; }
Public Property ConvertIncompatiblePagesToImages As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.DefaultRgbColorSpace Property

PdfARendererDefaultRgbColorSpace Property

Gets default RGB color space resource.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfIccColorSpaceResource DefaultRgbColorSpace { get; }
Public ReadOnly Property DefaultRgbColorSpace As PdfIccColorSpaceResource
    Get

Property Value

Type: PdfIccColorSpaceResource
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.IgnoreUnsupportedAnnotsAndActions Property

PdfARendererIgnoreUnsupportedAnnotsAndActions Property

Gets or sets a value indicating whether annotations and actions that not supported by the PDF/A-1b standard will be ignored, instead of throwing PdfAException.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IgnoreUnsupportedAnnotsAndActions { get; set; }
Public Property IgnoreUnsupportedAnnotsAndActions As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.ImageExtractor Property

PdfARendererImageExtractor Property

Gets or sets the image extractor.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfImageExtractor ImageExtractor { get; set; }
Public Property ImageExtractor As IPdfImageExtractor
    Get
    Set

Property Value

Type: IPdfImageExtractor
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.RgbColorSpace Property

PdfARendererRgbColorSpace Property

Gets or sets the RGB color space that will be used in OutputIntents of PDF/A document. If value is not specified, DefaultRgbColorSpace will be used.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfIccColorSpaceResource RgbColorSpace { get; set; }
Public Property RgbColorSpace As PdfIccColorSpaceResource
    Get
    Set

Property Value

Type: PdfIccColorSpaceResource
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer Methods

The PdfARenderer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLBeginDoc | (Overrides PdfRendererLLBeginDoc(PdfGeneratedDocument).)
Protected method | LLBeginPage | Low Level the begin page. (Inherited from PdfRenderer.)
Protected method | LLEndDoc | (Overrides PdfRendererLLEndDoc(PdfGeneratedDocument).)
Protected method | LLEndPage | This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing. (Inherited from PdfRenderer.)
Protected method | LLGenerate | (Overrides PdfRendererLLGenerate(PdfGeneratedDocument, BasePage, PdfPageRenderer).)
Protected method | MakePageRenderer | Makes the page renderer. (Inherited from PdfRenderer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDocumentProgress | Raises the [E:DocumentProgress] event. (Inherited from DocumentRenderer.)
Protected method | OnStreamlessFontFound |
Protected method | PreprocessPageResources | (Overrides PdfRendererPreprocessPageResources(PdfPageRenderer, PdfGeneratedPage).)
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument. (Inherited from DocumentRenderer.)
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined. (Inherited from DocumentRenderer.)
Protected method | RenderBookmarkTree | (Inherited from PdfRenderer.)
Protected method | RenderForm | (Overrides PdfRendererRenderForm(PdfGeneratedDocument, Boolean).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.LLBeginDoc Method

PdfARendererLLBeginDoc Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLBeginDoc(
    PdfGeneratedDocument document
)
Protected Overrides Sub LLBeginDoc (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.LLEndDoc Method

PdfARendererLLEndDoc Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLEndDoc(
    PdfGeneratedDocument document
)
Protected Overrides Sub LLEndDoc (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.LLGenerate Method

PdfARendererLLGenerate Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLGenerate(
    PdfGeneratedDocument document,
    BasePage basePage,
    PdfPageRenderer renderer
)
Protected Overrides Sub LLGenerate (
    document As PdfGeneratedDocument,
    basePage As BasePage,
    renderer As PdfPageRenderer
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
basePage
Type: Atalasoft.PdfDocBasePage
renderer
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.OnStreamlessFontFound Method

PdfARendererOnStreamlessFontFound Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnStreamlessFontFound(
    Object sender,
    FontEventArgs e
)
Protected Overridable Sub OnStreamlessFontFound (
    sender As Object,
    e As FontEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.PdfDoc.Generating.RenderingFontEventArgs
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.PreprocessPageResources Method

PdfARendererPreprocessPageResources Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void PreprocessPageResources(
    PdfPageRenderer pdfPageRenderer,
    PdfGeneratedPage page
)
Protected Overrides Sub PreprocessPageResources (
    pdfPageRenderer As PdfPageRenderer,
    page As PdfGeneratedPage
)

Parameters

pdfPageRenderer
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
page
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.RenderForm Method

PdfARendererRenderForm Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void RenderForm(
    PdfGeneratedDocument document,
    bool preserveAllResources
)
Protected Overrides Sub RenderForm (
    document As PdfGeneratedDocument,
    preserveAllResources As Boolean
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
preserveAllResources
Type: SystemBoolean
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer Events

The PdfARenderer type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired. (Inherited from DocumentRenderer.)
Public event | StreamlessFontFound | Occurs when not embedded font will be found.
Top
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfARenderer.StreamlessFontFound Event

PdfARendererStreamlessFontFound Event

Occurs when not embedded font will be found.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<FontEventArgs> StreamlessFontFound
Public Event StreamlessFontFound As EventHandler(Of FontEventArgs)

Value

Type: SystemEventHandlerFontEventArgs
See Also

Reference

PdfARenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList Class

PdfDrawing list is a container class used to hold a collection of IPdfRenderable. PdfDrawingList is itself IPdfRenderable allowing nesting or structural grouping of Pdf content generating objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIPdfRenderable
Atalasoft.PdfDoc.Generating.RenderingPdfDrawingList

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfDrawingList : List<IPdfRenderable>,
    IPdfRenderable, IPdfResourceConsumer
<SerializableAttribute>
Public Class PdfDrawingList
    Inherits List(Of IPdfRenderable)
    Implements IPdfRenderable, IPdfResourceConsumer

The PdfDrawingList type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDrawingList | Initializes a new instance of the PdfDrawingList class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIPdfRenderable .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIPdfRenderable .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIPdfRenderable .)
 | Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Generating API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an object to the end of the ListT. (Inherited from ListIPdfRenderable .)
Public method | AddT(T) | Adds the specified renderable object to the list returning it as a value.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIPdfRenderable .)
Public method | AddShape | Adds the shape to the list returning it as well.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIPdfRenderable .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIPdfRenderable .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIPdfRenderable .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIPdfRenderable .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIPdfRenderable .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIPdfRenderable .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIPdfRenderable .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIPdfRenderable .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIPdfRenderable .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIPdfRenderable .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIPdfRenderable .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIPdfRenderable .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIPdfRenderable .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIPdfRenderable .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIPdfRenderable .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIPdfRenderable .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIPdfRenderable .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIPdfRenderable .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIPdfRenderable .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIPdfRenderable .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIPdfRenderable .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIPdfRenderable .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIPdfRenderable .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies that the resource was renamed.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIPdfRenderable .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIPdfRenderable .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIPdfRenderable .)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page. PdfDrawingList iterates over each IPdfRenderable element of its collection calling their GeneratePdf methods in turn.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIPdfRenderable .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIPdfRenderable .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIPdfRenderable .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIPdfRenderable .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIPdfRenderable .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIPdfRenderable .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIPdfRenderable .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList Constructor

Initializes a new instance of the PdfDrawingList class

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDrawingList()
Public Sub New
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList Properties

The PdfDrawingList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIPdfRenderable .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIPdfRenderable .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIPdfRenderable .)
 | Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Generating API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.Name Property

PdfDrawingListName Property

Gets or sets the name of the object. The use of this property is not dictated by the PDF Generating API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the object.

Implements

IPdfRenderableName
Examples
Copy
foreach (IPdfRenderable namedGroup in list.FindAll(item => item.Name == "Group") {
    ProcessGroup(namedGroup);
}
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList Methods

The PdfDrawingList type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an object to the end of the ListT. (Inherited from ListIPdfRenderable .)
Public method | AddT(T) | Adds the specified renderable object to the list returning it as a value.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIPdfRenderable .)
Public method | AddShape | Adds the shape to the list returning it as well.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIPdfRenderable .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIPdfRenderable .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIPdfRenderable .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIPdfRenderable .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIPdfRenderable .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIPdfRenderable .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIPdfRenderable .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIPdfRenderable .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIPdfRenderable .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIPdfRenderable .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIPdfRenderable .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIPdfRenderable .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIPdfRenderable .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIPdfRenderable .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIPdfRenderable .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIPdfRenderable .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIPdfRenderable .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIPdfRenderable .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIPdfRenderable .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIPdfRenderable .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIPdfRenderable .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIPdfRenderable .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIPdfRenderable .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies that the resource was renamed.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIPdfRenderable .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIPdfRenderable .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIPdfRenderable .)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page. PdfDrawingList iterates over each IPdfRenderable element of its collection calling their GeneratePdf methods in turn.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIPdfRenderable .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIPdfRenderable .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIPdfRenderable .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIPdfRenderable .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIPdfRenderable .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIPdfRenderable .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIPdfRenderable .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIPdfRenderable .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIPdfRenderable .)
Top
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.Add Method

PdfDrawingListAdd Method

Overload List
 | Name | Description
Public method | AddT(T) | Adds the specified renderable object to the list returning it as a value.
Public method | Add(T) | Adds an object to the end of the ListT. (Inherited from ListIPdfRenderable .)
Top
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.Add(T) Method (T)

PdfDrawingListAddT Method (T)

Adds the specified renderable object to the list returning it as a value.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Add<T>(
    T renderable
)
where T : IPdfRenderable

Public Function Add(Of T As IPdfRenderable) (
    renderable As T
) As T

Parameters

renderable
Type: T
The renderable object.

Type Parameters

T

Return Value

Type: T
The renderable added.
See Also

Reference

PdfDrawingList Class
Add Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.AddShape Method

PdfDrawingListAddShape Method

Adds the shape to the list returning it as well.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBaseShape AddShape(
    PdfBaseShape shape
)
Public Function AddShape (
    shape As PdfBaseShape
) As PdfBaseShape

Parameters

shape
Type: Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
The shape to add.

Return Value

Type: PdfBaseShape
The shape added.
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.NotifyResourceRenamed Method

PdfDrawingListNotifyResourceRenamed Method

Notifies that the resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The gr.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original.
newName
Type: SystemString
The new name.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.Render Method

PdfDrawingListRender Method

Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page. PdfDrawingList iterates over each IPdfRenderable element of its collection calling their GeneratePdf methods in turn.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfPageRenderer r
)
Public Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The PdfPageRenderer for generating PDF.

Implements

IPdfRenderableRender(PdfPageRenderer)
Examples
Copy
public void Render(PdfPageRenderer r)
{
    w.DrawingSurface.Begin();
    w.DrawingSurface.AddRect(MyBounds); // place a rectangle
    w.DrawingSurface.Stroke(PdfLineStyle.Default, MyColor); // draw its outline in black
    w.DrawingSurface.End();
}
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingList.ResourcesUsed Method

PdfDrawingListResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

PdfDrawingList Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface Class

PdfDrawingSurface is an abstract class that defines the drawing operations that can be performed on PDF page or other PDF content item. In this model, there is a notion of current path. A path a set of possibly disjoint lines or curves. A path or any of its sub paths may be closed open. An existing path may have more paths added to it. When any of the painting operations are performed, the current path will be cleared - unless the user performs a GSave operation in the containing PdfPageRenderer object before painting. Paths may be stroked, painted, painted and stroked, or clipped. Clipping is cumulative. Clipping to a path can only reduce the current clipping region or keep it the same size. Use GSave/GRestore to make temporary changes to the clipping region. In addition, a tranformation matrix may be applied to the drawing surface that will be incorporated into the current transformation. Transformations are cumulative and will affect all subsequent drawing unless managed with a GSave/Grestore operation. Before any operations can be performed on a PdfDrawingSurface, client code is required to call Begin. Client code should also call End when done. Begin and End are very efficient operations.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingPdfDrawingSurface

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PdfDrawingSurface
Public MustInherit Class PdfDrawingSurface

The PdfDrawingSurface type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfDrawingSurface | Initializes a new instance of the PdfDrawingSurface class
Top
Methods
 | Name | Description
 | AddPath(IEnumerablePdfPathOperation) | Adds a set of path operations to the current path. Path should start with a Move operation.
 | AddPath(IEnumerablePdfPathOperation, PdfPoint) | First applies a translation transform then adds a set of path operations to the current path. Path should start with a Move operation. The translation remains in place after the addition.
 | AddPath(IEnumerablePdfPathOperation, PdfTransform) | First applies a transform then adds a set of path operations to the current path. Path should start with a Move operation. The transform remains in place after the addition.
 | AddRect(PdfBounds) | Adds the a closed rectangle to the current path.
 | AddRect(PdfBounds, PdfPoint) | First applies a translation transform then adds the a closed rectangle to the current path. The translation remains in place after the addition.
 | AddRect(PdfBounds, PdfTransform) | First applies a transform then adds the a closed rectangle to the current path. The transform remains in place after the addition.
 | ApplyTransformation | Applies the transform to the drawing surface. The transform will be accumulated onto any existing transformation. Previous transforms can be saved and restored via the GSave and GRestore methods in PdfPageRenderer.
 | Begin | Signal that drawing operations have begun.
Public method | BeginMarkedContent | Marks a stream of PDF content with the given tag. All calls to BeginMarkedContent(String) must have a matching call to EndMarkedContent. The PDF spec does not allow nesting of marked content.
 | Clip(PdfFillMethod) | Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.
 | Clip(PdfFillMethod, Boolean) | Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.
 | End | Signal that drawing on the drawing surface is complete.
Public method | EndMarkedContent | Deontes the end of a stream of PDF content marked via BeginMarkedContent(String).
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Fill | Paints the current path using the specified fill method and color then clears the current path.
 | FillAndStroke | Paints then strokes the current path using the specified parameters, then clears the current path.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlaceImage(String, String, PdfBounds) | Places the image on the drawing surface within the bounds provided.
Public method | PlaceImage(String, String, PdfPoint) | Places the image on the drawing surface at the given location. The image will be placed such that each pixel is 1 PDF page unit square.
Public method | PlaceImage(String, String, PdfTransform) | Places the image on the drawing surface within the bounds and transformed by the matrix provided.
Public method | PlaceTemplate(String, PdfBounds) | Places the template on the drawing surface within the bounds provided.
Public method | PlaceTemplate(String, PdfPoint) | Places the template on the drawing surface at the given location. The template will be placed such that each pixel is 1 PDF page unit square.
Public method | PlaceTemplate(String, PdfTransform) | Places the template on the drawing surface within the bounds and transformed by the matrix provided.
 | Stroke | Strokes the current path in the specified style and color then clears the current path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface Constructor

Initializes a new instance of the PdfDrawingSurface class

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfDrawingSurface()
Protected Sub New
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface Methods

The PdfDrawingSurface type exposes the following members.

Methods
 | Name | Description
 | AddPath(IEnumerablePdfPathOperation) | Adds a set of path operations to the current path. Path should start with a Move operation.
 | AddPath(IEnumerablePdfPathOperation, PdfPoint) | First applies a translation transform then adds a set of path operations to the current path. Path should start with a Move operation. The translation remains in place after the addition.
 | AddPath(IEnumerablePdfPathOperation, PdfTransform) | First applies a transform then adds a set of path operations to the current path. Path should start with a Move operation. The transform remains in place after the addition.
 | AddRect(PdfBounds) | Adds the a closed rectangle to the current path.
 | AddRect(PdfBounds, PdfPoint) | First applies a translation transform then adds the a closed rectangle to the current path. The translation remains in place after the addition.
 | AddRect(PdfBounds, PdfTransform) | First applies a transform then adds the a closed rectangle to the current path. The transform remains in place after the addition.
 | ApplyTransformation | Applies the transform to the drawing surface. The transform will be accumulated onto any existing transformation. Previous transforms can be saved and restored via the GSave and GRestore methods in PdfPageRenderer.
 | Begin | Signal that drawing operations have begun.
Public method | BeginMarkedContent | Marks a stream of PDF content with the given tag. All calls to BeginMarkedContent(String) must have a matching call to EndMarkedContent. The PDF spec does not allow nesting of marked content.
 | Clip(PdfFillMethod) | Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.
 | Clip(PdfFillMethod, Boolean) | Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.
 | End | Signal that drawing on the drawing surface is complete.
Public method | EndMarkedContent | Deontes the end of a stream of PDF content marked via BeginMarkedContent(String).
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Fill | Paints the current path using the specified fill method and color then clears the current path.
 | FillAndStroke | Paints then strokes the current path using the specified parameters, then clears the current path.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlaceImage(String, String, PdfBounds) | Places the image on the drawing surface within the bounds provided.
Public method | PlaceImage(String, String, PdfPoint) | Places the image on the drawing surface at the given location. The image will be placed such that each pixel is 1 PDF page unit square.
Public method | PlaceImage(String, String, PdfTransform) | Places the image on the drawing surface within the bounds and transformed by the matrix provided.
Public method | PlaceTemplate(String, PdfBounds) | Places the template on the drawing surface within the bounds provided.
Public method | PlaceTemplate(String, PdfPoint) | Places the template on the drawing surface at the given location. The template will be placed such that each pixel is 1 PDF page unit square.
Public method | PlaceTemplate(String, PdfTransform) | Places the template on the drawing surface within the bounds and transformed by the matrix provided.
 | Stroke | Strokes the current path in the specified style and color then clears the current path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddPath Method

PdfDrawingSurfaceAddPath Method

Overload List
Name | Description
AddPath(IEnumerablePdfPathOperation) | Adds a set of path operations to the current path. Path should start with a Move operation.
AddPath(IEnumerablePdfPathOperation, PdfPoint) | First applies a translation transform then adds a set of path operations to the current path. Path should start with a Move operation. The translation remains in place after the addition.
AddPath(IEnumerablePdfPathOperation, PdfTransform) | First applies a transform then adds a set of path operations to the current path. Path should start with a Move operation. The transform remains in place after the addition.
Top
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddPath Method (IEnumerable(PdfPathOperation))

PdfDrawingSurfaceAddPath Method (IEnumerablePdfPathOperation)

Adds a set of path operations to the current path. Path should start with a Move operation.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddPath(
    IEnumerable<PdfPathOperation> path
)
Public MustOverride Sub AddPath (
    path As IEnumerable(Of PdfPathOperation)
)

Parameters

path
Type: System.Collections.GenericIEnumerablePdfPathOperation
The path to add.
Examples
Copy
drawingSurface.AddPath(new PdfPathOperation[] { PdfPathOperation.MoveTo(0, 0), PdfPathOperation.LineTo(100, 150); });
See Also

Reference

PdfDrawingSurface Class
AddPath Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddPath Method (IEnumerable(PdfPathOperation), PdfPoint)

PdfDrawingSurfaceAddPath Method (IEnumerablePdfPathOperation, PdfPoint)

First applies a translation transform then adds a set of path operations to the current path. Path should start with a Move operation. The translation remains in place after the addition.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddPath(
    IEnumerable<PdfPathOperation> path,
    PdfPoint location
)
Public MustOverride Sub AddPath (
    path As IEnumerable(Of PdfPathOperation),
    location As PdfPoint
)

Parameters

path
Type: System.Collections.GenericIEnumerablePdfPathOperation
The path to add.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The location to which the path will be translated.
Examples
Copy
drawingSurface.AddPath(myPath, drawingOrigin);
See Also

Reference

PdfDrawingSurface Class
AddPath Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddPath Method (IEnumerable(PdfPathOperation), PdfTransform)

PdfDrawingSurfaceAddPath Method (IEnumerablePdfPathOperation, PdfTransform)

First applies a transform then adds a set of path operations to the current path. Path should start with a Move operation. The transform remains in place after the addition.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddPath(
    IEnumerable<PdfPathOperation> path,
    PdfTransform transform
)
Public MustOverride Sub AddPath (
    path As IEnumerable(Of PdfPathOperation),
    transform As PdfTransform
)

Parameters

path
Type: System.Collections.GenericIEnumerablePdfPathOperation
The path to add.
transform
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform to apply.
Examples
Copy
drawingSurface.AddPath(myPath, PdfTransform.Scale(10)); // scale up by 10 uniformly in both axes
See Also

Reference

PdfDrawingSurface Class
AddPath Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddRect Method

PdfDrawingSurfaceAddRect Method

Overload List
Name | Description
AddRect(PdfBounds) | Adds the a closed rectangle to the current path.
AddRect(PdfBounds, PdfPoint) | First applies a translation transform then adds the a closed rectangle to the current path. The translation remains in place after the addition.
AddRect(PdfBounds, PdfTransform) | First applies a transform then adds the a closed rectangle to the current path. The transform remains in place after the addition.
Top
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddRect Method (PdfBounds)

PdfDrawingSurfaceAddRect Method (PdfBounds)

Adds the a closed rectangle to the current path.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddRect(
    PdfBounds r
)
Public MustOverride Sub AddRect (
    r As PdfBounds
)

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The rectangle to add.
Examples
Copy
drawingSurface.Add(new PdfBounds(20, 20, 100, 150));
See Also

Reference

PdfDrawingSurface Class
AddRect Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddRect Method (PdfBounds, PdfPoint)

PdfDrawingSurfaceAddRect Method (PdfBounds, PdfPoint)

First applies a translation transform then adds the a closed rectangle to the current path. The translation remains in place after the addition.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddRect(
    PdfBounds r,
    PdfPoint location
)
Public MustOverride Sub AddRect (
    r As PdfBounds,
    location As PdfPoint
)

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The rectangle to add.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The location to which the rectangle will be translated.
Examples
Copy
drawingSurface.AddRect(new PdfBounds(0, 0, 60, 60), new PdfPoint(100, 120));
See Also

Reference

PdfDrawingSurface Class
AddRect Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.AddRect Method (PdfBounds, PdfTransform)

PdfDrawingSurfaceAddRect Method (PdfBounds, PdfTransform)

First applies a transform then adds the a closed rectangle to the current path. The transform remains in place after the addition.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void AddRect(
    PdfBounds r,
    PdfTransform transform
)
Public MustOverride Sub AddRect (
    r As PdfBounds,
    transform As PdfTransform
)

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The rectangle to add.
transform
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform to apply.
Examples
Copy
drawingSurface.AddRect(new PdfBounds(0, 0, 60, 60), PdfTransform.Rotate(Math.PI/4.0));
See Also

Reference

PdfDrawingSurface Class
AddRect Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.ApplyTransformation Method

PdfDrawingSurfaceApplyTransformation Method

Applies the transform to the drawing surface. The transform will be accumulated onto any existing transformation. Previous transforms can be saved and restored via the GSave and GRestore methods in PdfPageRenderer.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void ApplyTransformation(
    PdfTransform transform
)
Public MustOverride Sub ApplyTransformation (
    transform As PdfTransform
)

Parameters

transform
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform to apply.
Examples
Copy
writer.GSave();
drawingSurface.ApplyTransformation(PdfTransform.Scale(2, 5)); // non-uniform scale
PlaceScaledShapes();
writer.GRestore();
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.Begin Method

PdfDrawingSurfaceBegin Method

Signal that drawing operations have begun.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Begin()
Public MustOverride Sub Begin
Examples
Copy
try {
    drawingSurface.Begin();
    // more drawing operations
}
finally {
    drawingSurface.End();
}
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.BeginMarkedContent Method

PdfDrawingSurfaceBeginMarkedContent Method

Marks a stream of PDF content with the given tag. All calls to BeginMarkedContent(String) must have a matching call to EndMarkedContent. The PDF spec does not allow nesting of marked content.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void BeginMarkedContent(
    string markedContentTag
)
Public MustOverride Sub BeginMarkedContent (
    markedContentTag As String
)

Parameters

markedContentTag
Type: SystemString
The marked content tag.
Remarks
Tags have meaning that is specific to entities within PDF. For example, text that is rendered within some classes of annotations are set off with a Txtag and a BMC operator within PDF. Most code will never need to use this method directly. For access at a higher level, use the PdfMarkedContent object which can be used in any PdfDrawingList and emits both the begin marked content operator as well as the matching end marked content operator in a PDF stream.
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.Clip Method

PdfDrawingSurfaceClip Method

Overload List
Name | Description
Clip(PdfFillMethod) | Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.
Clip(PdfFillMethod, Boolean) | Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.
Top
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.Clip Method (PdfFillMethod)

PdfDrawingSurfaceClip Method (PdfFillMethod)

Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Clip(
    PdfFillMethod fillMethod
)
Public MustOverride Sub Clip (
    fillMethod As PdfFillMethod
)

Parameters

fillMethod
Type: Atalasoft.PdfDoc.Generating.RenderingPdfFillMethod
The fill method to use for the path.
Examples
Copy
writer.GSave();
drawingSurface.AddPath(clippingRegion);
drawingSurface.Clip(PdfFillMethod.EvenOdd);
PlaceClippedShapes();
writer.GRestore();
See Also

Reference

PdfDrawingSurface Class
Clip Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.Clip Method (PdfFillMethod, Boolean)

PdfDrawingSurfaceClip Method (PdfFillMethod, Boolean)

Reduces the clipping area of the current drawing surface by intersecting the current path with the current clipping area. Clipping is a strictly reductive process. To preserve previous clipping areas, use the GSave and GRestore methods in PdfPageRenderer.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Clip(
    PdfFillMethod fillMethod,
    bool keepPath
)
Public MustOverride Sub Clip (
    fillMethod As PdfFillMethod,
    keepPath As Boolean
)

Parameters

fillMethod
Type: Atalasoft.PdfDoc.Generating.RenderingPdfFillMethod
The fill method to use for the path.
keepPath
Type: SystemBoolean
True if the clipping path should be kept as the current path, false otherwise
Examples
Copy
writer.GSave();
drawingSurface.AddPath(clippingRegion);
drawingSurface.Clip(PdfFillMethod.EvenOdd);
PlaceClippedShapes();
writer.GRestore();
See Also

Reference

PdfDrawingSurface Class
Clip Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.End Method

PdfDrawingSurfaceEnd Method

Signal that drawing on the drawing surface is complete.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void End()
Public MustOverride Sub End
Examples
Copy
try {
    drawingSurface.Begin();
    // more drawing operations
}
finally {
    drawingSurface.End();
}
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.EndMarkedContent Method

PdfDrawingSurfaceEndMarkedContent Method

Deontes the end of a stream of PDF content marked via BeginMarkedContent(String).

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void EndMarkedContent()
Public MustOverride Sub EndMarkedContent
Remarks
Most code will never need to use this method directly. For access at a higher level, use the PdfMarkedContent object which can be used in any PdfDrawingList and emits both the begin marked content operator as well as the matching end marked content operator in a PDF stream.
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.Fill Method

PdfDrawingSurfaceFill Method

Paints the current path using the specified fill method and color then clears the current path.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Fill(
    PdfFillMethod fillMethod,
    IPdfColor color
)
Public MustOverride Sub Fill (
    fillMethod As PdfFillMethod,
    color As IPdfColor
)

Parameters

fillMethod
Type: Atalasoft.PdfDoc.Generating.RenderingPdfFillMethod
The fill method for the path.
color
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
The color used to fill the path.
Examples
Copy
drawingSurface.AddPath(shape);
drawingSurface.Fill(PdfFillMethod.EvenOdd, fillColor);
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.FillAndStroke Method

PdfDrawingSurfaceFillAndStroke Method

Paints then strokes the current path using the specified parameters, then clears the current path.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void FillAndStroke(
    PdfFillMethod fillMethod,
    IPdfColor fillColor,
    PdfLineStyle style,
    IPdfColor lineColor
)
Public MustOverride Sub FillAndStroke (
    fillMethod As PdfFillMethod,
    fillColor As IPdfColor,
    style As PdfLineStyle,
    lineColor As IPdfColor
)

Parameters

fillMethod
Type: Atalasoft.PdfDoc.Generating.RenderingPdfFillMethod
The fill method that will be used to fill the path.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
The Color used for filling the path.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of the line used to stroke the path.
lineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
The Color of the line used to stroke the path.
Examples
Copy
drawingSurface.AddPath(shape);
drawingSurface.FillAndStroke(PdfFillMethod.EvenOff, fillColor, lineStyle, lineColor);
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceImage Method

PdfDrawingSurfacePlaceImage Method

Overload List
 | Name | Description
Public method | PlaceImage(String, String, PdfBounds) | Places the image on the drawing surface within the bounds provided.
Public method | PlaceImage(String, String, PdfPoint) | Places the image on the drawing surface at the given location. The image will be placed such that each pixel is 1 PDF page unit square.
Public method | PlaceImage(String, String, PdfTransform) | Places the image on the drawing surface within the bounds and transformed by the matrix provided.
Top
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceImage Method (String, String, PdfBounds)

PdfDrawingSurfacePlaceImage Method (String, String, PdfBounds)

Places the image on the drawing surface within the bounds provided.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void PlaceImage(
    string imageName,
    string colorSpaceResourceName,
    PdfBounds locationAndSize
)
Public MustOverride Sub PlaceImage (
    imageName As String,
    colorSpaceResourceName As String,
    locationAndSize As PdfBounds
)

Parameters

imageName
Type: SystemString
Name of the image from global resources to place on the drawing surface.
colorSpaceResourceName
Type: SystemString
Optional name of a color space resource to use for the image.
locationAndSize
Type: Atalasoft.PdfDoc.GeometryPdfBounds
location and size of the image in PDF page units.
See Also

Reference

PdfDrawingSurface Class
PlaceImage Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceImage Method (String, String, PdfPoint)

PdfDrawingSurfacePlaceImage Method (String, String, PdfPoint)

Places the image on the drawing surface at the given location. The image will be placed such that each pixel is 1 PDF page unit square.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void PlaceImage(
    string imageName,
    string colorSpaceResourceName,
    PdfPoint location
)
Public MustOverride Sub PlaceImage (
    imageName As String,
    colorSpaceResourceName As String,
    location As PdfPoint
)

Parameters

imageName
Type: SystemString
Name of the image from global resources to place on the drawing surface.
colorSpaceResourceName
Type: SystemString
Optional name of a color space resource to use for the image.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The location of the image on the page.
See Also

Reference

PdfDrawingSurface Class
PlaceImage Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceImage Method (String, String, PdfTransform)

PdfDrawingSurfacePlaceImage Method (String, String, PdfTransform)

Places the image on the drawing surface within the bounds and transformed by the matrix provided.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void PlaceImage(
    string imageName,
    string colorSpaceResourceName,
    PdfTransform transform
)
Public MustOverride Sub PlaceImage (
    imageName As String,
    colorSpaceResourceName As String,
    transform As PdfTransform
)

Parameters

imageName
Type: SystemString
Name of the image from global resources to place on the drawing surface.
colorSpaceResourceName
Type: SystemString
Optional name of a color space resource to use for the image.
transform
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform.
See Also

Reference

PdfDrawingSurface Class
PlaceImage Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceTemplate Method

PdfDrawingSurfacePlaceTemplate Method

Overload List
 | Name | Description
Public method | PlaceTemplate(String, PdfBounds) | Places the template on the drawing surface within the bounds provided.
Public method | PlaceTemplate(String, PdfPoint) | Places the template on the drawing surface at the given location. The template will be placed such that each pixel is 1 PDF page unit square.
Public method | PlaceTemplate(String, PdfTransform) | Places the template on the drawing surface within the bounds and transformed by the matrix provided.
Top
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceTemplate Method (String, PdfBounds)

PdfDrawingSurfacePlaceTemplate Method (String, PdfBounds)

Places the template on the drawing surface within the bounds provided.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void PlaceTemplate(
    string templateName,
    PdfBounds locationAndSize
)
Public MustOverride Sub PlaceTemplate (
    templateName As String,
    locationAndSize As PdfBounds
)

Parameters

templateName
Type: SystemString
Name of the template from global resources to place on the drawing surface.
locationAndSize
Type: Atalasoft.PdfDoc.GeometryPdfBounds
location and size of the template in PDF page units.
See Also

Reference

PdfDrawingSurface Class
PlaceTemplate Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceTemplate Method (String, PdfPoint)

PdfDrawingSurfacePlaceTemplate Method (String, PdfPoint)

Places the template on the drawing surface at the given location. The template will be placed such that each pixel is 1 PDF page unit square.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void PlaceTemplate(
    string templateName,
    PdfPoint location
)
Public MustOverride Sub PlaceTemplate (
    templateName As String,
    location As PdfPoint
)

Parameters

templateName
Type: SystemString
Name of the template from global resources to place on the drawing surface.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The location of the template on the page.
See Also

Reference

PdfDrawingSurface Class
PlaceTemplate Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.PlaceTemplate Method (String, PdfTransform)

PdfDrawingSurfacePlaceTemplate Method (String, PdfTransform)

Places the template on the drawing surface within the bounds and transformed by the matrix provided.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void PlaceTemplate(
    string templateName,
    PdfTransform transform
)
Public MustOverride Sub PlaceTemplate (
    templateName As String,
    transform As PdfTransform
)

Parameters

templateName
Type: SystemString
Name of the template from global resources to place on the drawing surface.
transform
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform.
See Also

Reference

PdfDrawingSurface Class
PlaceTemplate Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfDrawingSurface.Stroke Method

PdfDrawingSurfaceStroke Method

Strokes the current path in the specified style and color then clears the current path.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Stroke(
    PdfLineStyle style,
    IPdfColor color
)
Public MustOverride Sub Stroke (
    style As PdfLineStyle,
    color As IPdfColor
)

Parameters

style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The line style that will be used to draw the path.
color
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
The color of the line that will be drawn.
Examples
Copy
drawingSurface.AddRect(boundingRect);
drawingSurface.Stroke(currentStyle, outlineColor);
See Also

Reference

PdfDrawingSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfFillMethod Enumeration

Defines how a path in PDF page content will be filled.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfFillMethod
Public Enumeration PdfFillMethod
Members
Member name | Description
NonZeroWinding | This fill method represents the non-zero winding rule. In this method, horizontal rays are fired through the path and if segments cross the ray from bottom to top, 1 is added to a winding count. If segments cross the ray from top to bottom, 1 is subtracted from the winding count. If the winding count is non-zero, the path will be filled along the ray. If the winding number is 0, the path will be empty along the ray.
EvenOdd | This fill method represents the even/odd rule. In this method, horizontal rays are fired through the path and a running total of segments crossing the ray is kept. If the running total is odd, the path will be filled along the ray. If the running total is even, the path will not be filled along the ray.
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineCapStyle Enumeration

Represents the way that ends of stroked paths will look.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfLineCapStyle
Public Enumeration PdfLineCapStyle
Members
Member name | Description
Butt | Represents flat ends to lines
Round | Represetns half-circle round ends to lines
ProjectingSquare | Similar to butt ends, but lines ends will project out by half the line width forming a square end.
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineJoinStyle Enumeration

Represents how transitions in segments in path will look.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfLineJoinStyle
Public Enumeration PdfLineJoinStyle
Members
Member name | Description
Mitered | At the vertex of connected line segments, the segments will be joined by projecting the outer edges of the segments until they intersect. If this would produce too sharp an angle a bevel is used instead.
Rounded | At the vertex of connected line segments, the segments will be joined by a circular arc.
Beveled | At the vertex of connected line segments, the segments will be joined by connecting the outer tips of the segments, creating a bevel.
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Class

Represents all the elements that defines the style of stoked lines in PDF content.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfLineStyle : ICloneable
<SerializableAttribute>
Public Class PdfLineStyle
    Implements ICloneable

The PdfLineStyle type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLineStyle(Double) | Initializes a new instance of the PdfLineStyle class with defaults, except for the width.
Public method | PdfLineStyle(PdfLineStyle) | Initializes a new instance of the PdfLineStyle class using the contents of the PdfLineStyle passed in.
Public method | PdfLineStyle(PdfLineStyle, Double) | Initializes a new instance of the PdfLineStyle class.
Public method | PdfLineStyle(Double, PdfLineCapStyle, PdfLineJoinStyle, Double, Double, Int32) | Constructs a new instance of the PdfLineStyle class.
Top
Properties
 | Name | Description
Public property | CapStyle | Gets or sets the line cap style.
Public property | DashPattern | Gets or sets the dash pattern used for lines. This is an array of doubles that represents alternating on and off patterns of dashes in PDF units. An empty array is a solid line. A single number is alternated on and off (ie, [4] will be 4 units on, 4 units off). More than a single number will be alternated. Default is an empty array.
Public property | DashPhase | Gets or sets the dash phase. This number represents at what point dashes will start in the DashPattern. For example, if the DashPattern is [2, 3] and the phase is 1, the dashed line will be 1 unit on, 3 off, 2 on, 3 off, etc.
 | Default | Gets the default line style: 1 PDF unit wide, butt line ends, mitered joints, a miter limit of 10, no dash pattern, 0 phase.
Public property | JoinStyle | Gets or sets the line join style.
Public property | MiterLimit | Gets or sets the miter limit when JoinStyle is set to Mitered. When segments join with a mitered joint at sharp angles, MiterLimit keeps the joints from projecting too far. The miter length of a joint is this distance from the internal intersection of the line to the projected external intersection. If the ration of the miter length to the line width is greater than the miter limit, the joint will be beveled.
Public property | Width | Gets or sets the width of the line in PDF units.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Constructor

Overload List
 | Name | Description
Public method | PdfLineStyle(Double) | Initializes a new instance of the PdfLineStyle class with defaults, except for the width.
Public method | PdfLineStyle(PdfLineStyle) | Initializes a new instance of the PdfLineStyle class using the contents of the PdfLineStyle passed in.
Public method | PdfLineStyle(PdfLineStyle, Double) | Initializes a new instance of the PdfLineStyle class.
Public method | PdfLineStyle(Double, PdfLineCapStyle, PdfLineJoinStyle, Double, Double, Int32) | Constructs a new instance of the PdfLineStyle class.
Top
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Constructor (Double)

Initializes a new instance of the PdfLineStyle class with defaults, except for the width.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineStyle(
    double width
)
Public Sub New (
    width As Double
)

Parameters

width
Type: SystemDouble
The width of the line in PDF units.
See Also

Reference

PdfLineStyle Class
PdfLineStyle Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Constructor (PdfLineStyle)

Initializes a new instance of the PdfLineStyle class using the contents of the PdfLineStyle passed in.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineStyle(
    PdfLineStyle source
)
Public Sub New (
    source As PdfLineStyle
)

Parameters

source
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The source to copy from.
See Also

Reference

PdfLineStyle Class
PdfLineStyle Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Constructor (PdfLineStyle, Double)

Initializes a new instance of the PdfLineStyle class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineStyle(
    PdfLineStyle source,
    double width
)
Public Sub New (
    source As PdfLineStyle,
    width As Double
)

Parameters

source
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The source to copy from.
width
Type: SystemDouble
The width of the line in PDF units that will override the width in source.
See Also

Reference

PdfLineStyle Class
PdfLineStyle Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Constructor (Double, PdfLineCapStyle, PdfLineJoinStyle, Double, Double[], Int32)

PdfLineStyle Constructor (Double, PdfLineCapStyle, PdfLineJoinStyle, Double, Double, Int32)

Constructs a new instance of the PdfLineStyle class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineStyle(
    double width,
    PdfLineCapStyle capStyle,
    PdfLineJoinStyle joinStyle,
    double miterLimit,
    double[] dashPattern,
    int dashPhase
)
Public Sub New (
    width As Double,
    capStyle As PdfLineCapStyle,
    joinStyle As PdfLineJoinStyle,
    miterLimit As Double,
    dashPattern As Double(),
    dashPhase As Integer
)

Parameters

width
Type: SystemDouble
The width of the line in PDF units.
capStyle
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineCapStyle
The line cap style.
joinStyle
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineJoinStyle
The line join style.
miterLimit
Type: SystemDouble
The miter limit of mitered line joints.
dashPattern
Type: SystemDouble
The dash pattern.
dashPhase
Type: SystemInt32
The dash phase.
See Also

Reference

PdfLineStyle Class
PdfLineStyle Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Properties

The PdfLineStyle type exposes the following members.

Properties
 | Name | Description
Public property | CapStyle | Gets or sets the line cap style.
Public property | DashPattern | Gets or sets the dash pattern used for lines. This is an array of doubles that represents alternating on and off patterns of dashes in PDF units. An empty array is a solid line. A single number is alternated on and off (ie, [4] will be 4 units on, 4 units off). More than a single number will be alternated. Default is an empty array.
Public property | DashPhase | Gets or sets the dash phase. This number represents at what point dashes will start in the DashPattern. For example, if the DashPattern is [2, 3] and the phase is 1, the dashed line will be 1 unit on, 3 off, 2 on, 3 off, etc.
 | Default | Gets the default line style: 1 PDF unit wide, butt line ends, mitered joints, a miter limit of 10, no dash pattern, 0 phase.
Public property | JoinStyle | Gets or sets the line join style.
Public property | MiterLimit | Gets or sets the miter limit when JoinStyle is set to Mitered. When segments join with a mitered joint at sharp angles, MiterLimit keeps the joints from projecting too far. The miter length of a joint is this distance from the internal intersection of the line to the projected external intersection. If the ration of the miter length to the line width is greater than the miter limit, the joint will be beveled.
Public property | Width | Gets or sets the width of the line in PDF units.
Top
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.CapStyle Property

PdfLineStyleCapStyle Property

Gets or sets the line cap style.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineCapStyle CapStyle { get; set; }
Public Property CapStyle As PdfLineCapStyle
    Get
    Set

Property Value

Type: PdfLineCapStyle
The cap style.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.DashPattern Property

PdfLineStyleDashPattern Property

Gets or sets the dash pattern used for lines. This is an array of doubles that represents alternating on and off patterns of dashes in PDF units. An empty array is a solid line. A single number is alternated on and off (ie, [4] will be 4 units on, 4 units off). More than a single number will be alternated. Default is an empty array.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] DashPattern { get; set; }
Public Property DashPattern As Double()
    Get
    Set

Property Value

Type: Double
The dash pattern.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.DashPhase Property

PdfLineStyleDashPhase Property

Gets or sets the dash phase. This number represents at what point dashes will start in the DashPattern. For example, if the DashPattern is [2, 3] and the phase is 1, the dashed line will be 1 unit on, 3 off, 2 on, 3 off, etc.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DashPhase { get; set; }
Public Property DashPhase As Integer
    Get
    Set

Property Value

Type: Int32
The dash phase.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.Default Property

PdfLineStyleDefault Property

Gets the default line style: 1 PDF unit wide, butt line ends, mitered joints, a miter limit of 10, no dash pattern, 0 phase.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfLineStyle Default { get; }
Public Shared ReadOnly Property Default As PdfLineStyle
    Get

Property Value

Type: PdfLineStyle
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.JoinStyle Property

PdfLineStyleJoinStyle Property

Gets or sets the line join style.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineJoinStyle JoinStyle { get; set; }
Public Property JoinStyle As PdfLineJoinStyle
    Get
    Set

Property Value

Type: PdfLineJoinStyle
The join style.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.MiterLimit Property

PdfLineStyleMiterLimit Property

Gets or sets the miter limit when JoinStyle is set to Mitered. When segments join with a mitered joint at sharp angles, MiterLimit keeps the joints from projecting too far. The miter length of a joint is this distance from the internal intersection of the line to the projected external intersection. If the ration of the miter length to the line width is greater than the miter limit, the joint will be beveled.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MiterLimit { get; set; }
Public Property MiterLimit As Double
    Get
    Set

Property Value

Type: Double
The miter limit. This value should be set to 1 or greater. Default is 10.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.Width Property

PdfLineStyleWidth Property

Gets or sets the width of the line in PDF units.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set

Property Value

Type: Double
The width in PDF units. Width should be 0 or greater. 0 represents the smallest width that can be represented on the target device. On very high resolution devices, this may be nearly invisible and should be avoided.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle Methods

The PdfLineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.Clone Method

PdfLineStyleClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.Equals Method

PdfLineStyleEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfLineStyle.GetHashCode Method

PdfLineStyleGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PdfLineStyle Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer Class

PdfPageRenderer is an abstract class that represents mechanisms for generating or rendering PDF content from a PdfGenerated page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PdfPageRenderer
Public MustInherit Class PdfPageRenderer

The PdfPageRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPageRenderer | Constructs a new instance of the PdfPageRenderer class.
Top
Properties
 | Name | Description
 | DrawingSurface | Gets or sets the drawing surface for rendering graphics or images on a PDF page.
Public property | GlobalResources | Gets the global resources that are available to a document and page that is being rendered.
Public property | ParentPageRenderer | Gets or sets the parent page renderer (if any).
 | TextSurface | Gets or sets the text surface for rendering text content on a PDF page.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GRestore | Restores the current graphics state to the last saved state by GSave. It is an error to call GRestore without first calling GSave.
 | GSave | Performs a graphics save operation. All current graphics state should be encapsulated and pushed on a stack for later retrieval.
Protected method | LLMakeDrawingTemplateRenderer | Constructs a child template renderer.
Public method | MakeDrawingTemplateRenderer | Makes a child renderer for rendering DrawingTemplate objects.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer Constructor

Constructs a new instance of the PdfPageRenderer class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageRenderer(
    GlobalResources globalResources
)
Public Sub New (
    globalResources As GlobalResources
)

Parameters

globalResources
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources that are available for this document.
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer Properties

The PdfPageRenderer type exposes the following members.

Properties
 | Name | Description
 | DrawingSurface | Gets or sets the drawing surface for rendering graphics or images on a PDF page.
Public property | GlobalResources | Gets the global resources that are available to a document and page that is being rendered.
Public property | ParentPageRenderer | Gets or sets the parent page renderer (if any).
 | TextSurface | Gets or sets the text surface for rendering text content on a PDF page.
Top
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.DrawingSurface Property

PdfPageRendererDrawingSurface Property

Gets or sets the drawing surface for rendering graphics or images on a PDF page.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDrawingSurface DrawingSurface { get; protected set; }
Public Property DrawingSurface As PdfDrawingSurface
    Get
    Protected Set

Property Value

Type: PdfDrawingSurface
The drawing surface.
Examples
Copy
public void Triangle(PdfPageRenderer renderer)
{
    writer.DrawingSurface.Begin();
    writer.AddPath(new PdfPathOperation[] {
        PdfPathOperation.MoveTo(0, 0), PdfPathOperation.LineTo(20, 100),
        PdfPathOperation.LineTo(40, 0), PdfPathOperation.Close()
        });
    writer.DrawingSurface.End();
}
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.GlobalResources Property

PdfPageRendererGlobalResources Property

Gets the global resources that are available to a document and page that is being rendered.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalResources GlobalResources { get; }
Public ReadOnly Property GlobalResources As GlobalResources
    Get

Property Value

Type: GlobalResources
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.ParentPageRenderer Property

PdfPageRendererParentPageRenderer Property

Gets or sets the parent page renderer (if any).

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageRenderer ParentPageRenderer { get; protected set; }
Public Property ParentPageRenderer As PdfPageRenderer
    Get
    Protected Set

Property Value

Type: PdfPageRenderer
The parent page renderer.
Remarks
In some cases, a page renderer may need to create a child renderer for rendering content on page, including DrawingTemplate objects or annotations. This method allows a child renderer to access its parent, if needed.
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.TextSurface Property

PdfPageRendererTextSurface Property

Gets or sets the text surface for rendering text content on a PDF page.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextSurface TextSurface { get; protected set; }
Public Property TextSurface As PdfTextSurface
    Get
    Protected Set

Property Value

Type: PdfTextSurface
The text surface.
Examples
Copy
public void HelloWorld(PdfPageRenderer renderer)
{
    writer.TextSurface.Begin();
    writer.TextSurface.SetFont("courier", 12.0);
    writer.TextSurface.WriteTextLine("hello, world!", new PdfPoint(36, 288));
    writer.TextSurface.End();
}
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer Methods

The PdfPageRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GRestore | Restores the current graphics state to the last saved state by GSave. It is an error to call GRestore without first calling GSave.
 | GSave | Performs a graphics save operation. All current graphics state should be encapsulated and pushed on a stack for later retrieval.
Protected method | LLMakeDrawingTemplateRenderer | Constructs a child template renderer.
Public method | MakeDrawingTemplateRenderer | Makes a child renderer for rendering DrawingTemplate objects.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.GRestore Method

PdfPageRendererGRestore Method

Restores the current graphics state to the last saved state by GSave. It is an error to call GRestore without first calling GSave.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void GRestore()
Public MustOverride Sub GRestore
Examples
Copy
public void ClipToShape(PdfPageRenderer renderer, SomeShape shape, IPdfRenderable moreContent)
{
    writer.GSave(); // saves the current clip region
    ClipToMyShape(w, shape);
    moreContent.GeneratePdf(w); // generates clipped content
    writer.GRestore(); // restores the old clipping region
}
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.GSave Method

PdfPageRendererGSave Method

Performs a graphics save operation. All current graphics state should be encapsulated and pushed on a stack for later retrieval.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void GSave()
Public MustOverride Sub GSave
Examples
Copy
public void ClipToShape(PdfPageRenderer renderer, SomeShape shape, IPdfRenderable moreContent)
{
    writer.GSave(); // saves the current clip region
    ClipToMyShape(w, shape);
    moreContent.GeneratePdf(w); // generates clipped content
    writer.GRestore(); // restores the old clipping region
}
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.LLMakeDrawingTemplateRenderer Method

PdfPageRendererLLMakeDrawingTemplateRenderer Method

Constructs a child template renderer.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PdfPageRenderer LLMakeDrawingTemplateRenderer(
    DrawingTemplate template
)
Protected MustOverride Function LLMakeDrawingTemplateRenderer (
    template As DrawingTemplate
) As PdfPageRenderer

Parameters

template
Type: Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate
The template.

Return Value

Type: PdfPageRenderer
A new PdfPageRenderer
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPageRenderer.MakeDrawingTemplateRenderer Method

PdfPageRendererMakeDrawingTemplateRenderer Method

Makes a child renderer for rendering DrawingTemplate objects.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPageRenderer MakeDrawingTemplateRenderer(
    DrawingTemplate template
)
Public Function MakeDrawingTemplateRenderer (
    template As DrawingTemplate
) As PdfPageRenderer

Parameters

template
Type: Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate
The template.

Return Value

Type: PdfPageRenderer
A new renderer.
See Also

Reference

PdfPageRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation Class

PdfPathOperation is a class that represents actions taken to create a path and the encapsulated data. PdfPathOperation objects are not constructed directly, but are instead made through static factory methods or through convenience methods in higher level shape objects such as PdfPath.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingPdfPathOperation

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfPathOperation
<SerializableAttribute>
Public Class PdfPathOperation

The PdfPathOperation type exposes the following members.

Properties
 | Name | Description
 | Action | Gets the action for this path operation.
Public property | DestinationPoint | Gets the destination point for a Move, Line or Curve operation. In the case of a Curve, this returns the final point in the set of three as the curve will always end at that point.
 | Points | Gets the points associated with this path operation. For Move and Line operations, this list will contain one PdfPoint. For Curve operations, the list will contain exactly three points. For Close operations, this list will be empty. Changing the number of points in an existing PdfPathOperation object will cause unpredictable results.
Top
Methods
 | Name | Description
 | Close | Constructs a new Close PdfPathOperation, representing a closed sub path.
 | CurveTo | Constructs a new Curve PdfPathOpertaion, representing a Bezier curve
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LineTo(PdfPoint) | Constructs a new Line PdfPathOperation to the specified point.
 | LineTo(Double, Double) | Constructs a new Line PdfPathOperation to the specified x and y coordinates.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTo(PdfPoint) | Constructs a new Move PdfPathOperation to the specified point.
 | MoveTo(Double, Double) | Constructs a new Move PdfPathOperation to the specified x and y coordinates.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation Properties

The PdfPathOperation type exposes the following members.

Properties
 | Name | Description
 | Action | Gets the action for this path operation.
Public property | DestinationPoint | Gets the destination point for a Move, Line or Curve operation. In the case of a Curve, this returns the final point in the set of three as the curve will always end at that point.
 | Points | Gets the points associated with this path operation. For Move and Line operations, this list will contain one PdfPoint. For Curve operations, the list will contain exactly three points. For Close operations, this list will be empty. Changing the number of points in an existing PdfPathOperation object will cause unpredictable results.
Top
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.Action Property

PdfPathOperationAction Property

Gets the action for this path operation.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PathAction Action { get; }
Public ReadOnly Property Action As PathAction
    Get

Property Value

Type: PathAction
Examples
Copy
// print out every operation in a list of PdfPathOperations
foreach (PdfPathOperation op in ops) {
    string output = "";
    switch (op.Action) {
    case PathAction.Move: output = String.Format("Move({0})", op.Points[0]); break;
    case PathAction.Line: output = String.Format("Line({0})", op.Points[0]); break;
    case PathAction.Curve: output = String.Format("Curve({0}, {1}, {2})", op.Points[0], op.Points[1], op.Points[2]); break;
    case PathAction.Close: output = "Close"; break;
    }
    Console.WriteLine(output);
}
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.DestinationPoint Property

PdfPathOperationDestinationPoint Property

Gets the destination point for a Move, Line or Curve operation. In the case of a Curve, this returns the final point in the set of three as the curve will always end at that point.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint DestinationPoint { get; }
Public ReadOnly Property DestinationPoint As PdfPoint
    Get

Property Value

Type: PdfPoint
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.Points Property

PdfPathOperationPoints Property

Gets the points associated with this path operation. For Move and Line operations, this list will contain one PdfPoint. For Curve operations, the list will contain exactly three points. For Close operations, this list will be empty. Changing the number of points in an existing PdfPathOperation object will cause unpredictable results.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfPoint> Points { get; }
Public ReadOnly Property Points As IList(Of PdfPoint)
    Get

Property Value

Type: IListPdfPoint
Examples
Copy
// find the minimum X in a list of path operations
double minx = Double.MaxValue;
foreach (PdfPathOperation op in Ops) {
    foreach (PdfPoint point in op.Points) {
        if (point.X < minx)
           minx = point.X;
    }
}
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation Methods

The PdfPathOperation type exposes the following members.

Methods
 | Name | Description
 | Close | Constructs a new Close PdfPathOperation, representing a closed sub path.
 | CurveTo | Constructs a new Curve PdfPathOpertaion, representing a Bezier curve
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LineTo(PdfPoint) | Constructs a new Line PdfPathOperation to the specified point.
 | LineTo(Double, Double) | Constructs a new Line PdfPathOperation to the specified x and y coordinates.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTo(PdfPoint) | Constructs a new Move PdfPathOperation to the specified point.
 | MoveTo(Double, Double) | Constructs a new Move PdfPathOperation to the specified x and y coordinates.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.Close Method

PdfPathOperationClose Method

Constructs a new Close PdfPathOperation, representing a closed sub path.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPathOperation Close()
Public Shared Function Close As PdfPathOperation

Return Value

Type: PdfPathOperation
A new PdfPathOperation with Action set to Close. The Points property will be empty.
Examples
Copy
List<PdfPathOperation> triangle = new List<PdfPathOperation>();
triangle.Add(PdfPathOperation.MoveTo(0, 0));
triangle.Add(PdfPathOperation.LineTo(20, 50));
triangle.Add(PdfPathOperation.LineTo(40, 0));
triangle.Add(PdfPathOpertaion.Close());
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.CurveTo Method

PdfPathOperationCurveTo Method

Constructs a new Curve PdfPathOpertaion, representing a Bezier curve

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPathOperation CurveTo(
    PdfPoint sourceControlPoint,
    PdfPoint destinationControlPoint,
    PdfPoint destinationPoint
)
Public Shared Function CurveTo (
    sourceControlPoint As PdfPoint,
    destinationControlPoint As PdfPoint,
    destinationPoint As PdfPoint
) As PdfPathOperation

Parameters

sourceControlPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The source control point.
destinationControlPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination control point.
destinationPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination point.

Return Value

Type: PdfPathOperation
a new PdfPathoperation with Action set to Curve. The Points property will contain three points representing the source and destination control points and the destination point, respectively.
Examples
Copy
PdfPathOpertaion curve = PdfPathOperation.CurveTo(cp1, cp2, destPoint);
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.Equals Method

PdfPathOperationEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.GetHashCode Method

PdfPathOperationGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.LineTo Method

PdfPathOperationLineTo Method

Overload List
Name | Description
LineTo(PdfPoint) | Constructs a new Line PdfPathOperation to the specified point.
LineTo(Double, Double) | Constructs a new Line PdfPathOperation to the specified x and y coordinates.
Top
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.LineTo Method (PdfPoint)

PdfPathOperationLineTo Method (PdfPoint)

Constructs a new Line PdfPathOperation to the specified point.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPathOperation LineTo(
    PdfPoint pt
)
Public Shared Function LineTo (
    pt As PdfPoint
) As PdfPathOperation

Parameters

pt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to connect a line to.

Return Value

Type: PdfPathOperation
A new PdfPathOperation with Action set ot Line and one PdfPoint in the Points property.
Examples
Copy
PdfPathOperation line = PdfPathOpertaion.LineTo(destPt);
See Also

Reference

PdfPathOperation Class
LineTo Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.LineTo Method (Double, Double)

PdfPathOperationLineTo Method (Double, Double)

Constructs a new Line PdfPathOperation to the specified x and y coordinates.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPathOperation LineTo(
    double x,
    double y
)
Public Shared Function LineTo (
    x As Double,
    y As Double
) As PdfPathOperation

Parameters

x
Type: SystemDouble
The x coordinate of the point.
y
Type: SystemDouble
The y coordinate of the point.

Return Value

Type: PdfPathOperation
A new PdfPathOperation with Action set to Line and one PdfPoint in the Points property.
Examples
Copy
PdfPathOperation line = PdfPathOperation.MoveTo(endX, endY);
See Also

Reference

PdfPathOperation Class
LineTo Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.MoveTo Method

PdfPathOperationMoveTo Method

Overload List
Name | Description
MoveTo(PdfPoint) | Constructs a new Move PdfPathOperation to the specified point.
MoveTo(Double, Double) | Constructs a new Move PdfPathOperation to the specified x and y coordinates.
Top
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.MoveTo Method (PdfPoint)

PdfPathOperationMoveTo Method (PdfPoint)

Constructs a new Move PdfPathOperation to the specified point.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPathOperation MoveTo(
    PdfPoint pt
)
Public Shared Function MoveTo (
    pt As PdfPoint
) As PdfPathOperation

Parameters

pt
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to Move to.

Return Value

Type: PdfPathOperation
A new PdfPathOperation with Action set to Move and one PdfPoint in the Points property.
Examples
Copy
PdfPathOperation move = PdfPathOperation.MoveTo(destinationPoint);
See Also

Reference

PdfPathOperation Class
MoveTo Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.MoveTo Method (Double, Double)

PdfPathOperationMoveTo Method (Double, Double)

Constructs a new Move PdfPathOperation to the specified x and y coordinates.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPathOperation MoveTo(
    double x,
    double y
)
Public Shared Function MoveTo (
    x As Double,
    y As Double
) As PdfPathOperation

Parameters

x
Type: SystemDouble
The x coordinate of the point.
y
Type: SystemDouble
The y coordinate of the point.

Return Value

Type: PdfPathOperation
A new PdfPathOperation with Action set to Move and one PdfPoint in the Points property.
Examples
Copy
PdfPathOperation move = PdfPathOperation.MoveTo(destinationX, destinationY);
See Also

Reference

PdfPathOperation Class
MoveTo Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfPathOperation.ToString Method

PdfPathOperationToString Method

Returns a String that represents this instance.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PdfPathOperation Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Class

PdfRenderer is a concrete implementation of the DocumentRenderer class. It is responsible for creating PDF files/streams from PdfGeneratedDocument objects. Most client applications concerned with creating PDF files will either use this class or the Save method in PdfGeneratedDocument (which in turns uses PdfRenderer).
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingDocumentRenderer
Atalasoft.PdfDoc.Generating.RenderingPdfRenderer
Atalasoft.PdfDoc.Generating.RenderingPdfARenderer

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfRenderer : DocumentRenderer
Public Class PdfRenderer
    Inherits DocumentRenderer

The PdfRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | PdfRenderer(Stream) | Creates a new instance of the PdfRenderer class.
Public method | PdfRenderer(String, String, Stream) | Obsolete. Creates a new instance of the PdfRenderer class.
Public method | PdfRenderer(Stream, PdfSaveOptions, Boolean, Boolean) | Initializes a new instance of the PdfRenderer class.
Public method | PdfRenderer(String, String, Stream, Boolean, Boolean) | Obsolete. Initializes a new instance of the PdfRenderer class.
Top
Properties
 | Name | Description
Protected property | CurrentPage |
Protected property | ErrorOccurred | Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins. (Inherited from DocumentRenderer.)
Protected property | SaveOptions |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLBeginDoc | This method represents the Low-Level implementation of BeginDoc. It is called once at the start of rendering the document after the first DocumentProgress event has been fired, but before the first page is rendered. If a document has an empty Pages collection, LLBeginDoc will not be called. The default implementation does nothing. (Overrides DocumentRendererLLBeginDoc(PdfGeneratedDocument).)
Protected method | LLBeginPage | Low Level the begin page. (Overrides DocumentRendererLLBeginPage(PdfGeneratedDocument, BasePage).)
Protected method | LLEndDoc | This method represents the Low-Level implementation of EndDoc. It is called once at the end of rendering a document after the final DocumentProgress event has been fired. If a document has an empty Pages collection, LLEndDoc will not be called. A concrete implementation of DocumentRenderer could use this method for cleaning up temporary files created during the rendering process. (Overrides DocumentRendererLLEndDoc(PdfGeneratedDocument).)
Protected method | LLEndPage | This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing. (Overrides DocumentRendererLLEndPage(PdfGeneratedDocument, BasePage).)
Protected method | LLGenerate | Low Level generate. (Overrides DocumentRendererLLGenerate(PdfGeneratedDocument, BasePage, PdfPageRenderer).)
Protected method | MakePageRenderer | Makes the page renderer. (Overrides DocumentRendererMakePageRenderer(PdfGeneratedDocument, BasePage).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDocumentProgress | Raises the [E:DocumentProgress] event. (Inherited from DocumentRenderer.)
Protected method | PreprocessPageResources |
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument. (Inherited from DocumentRenderer.)
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined. (Inherited from DocumentRenderer.)
Protected method | RenderBookmarkTree |
Protected method | RenderForm |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DocumentProgress | Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired. (Inherited from DocumentRenderer.)
Top
Examples
Copy
public MemoryStream SaveToMemoryStream(PdfGeneratedDocument doc)
{
    MemoryStream stm = new MemoryStream();
    PdfRenderer renderer = new PdfRenderer(stm);
    renderer.Render(doc);
    return stm;
}
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Constructor

Overload List
 | Name | Description
Public method | PdfRenderer(Stream) | Creates a new instance of the PdfRenderer class.
Public method | PdfRenderer(String, String, Stream) | Obsolete. Creates a new instance of the PdfRenderer class.
Public method | PdfRenderer(Stream, PdfSaveOptions, Boolean, Boolean) | Initializes a new instance of the PdfRenderer class.
Public method | PdfRenderer(String, String, Stream, Boolean, Boolean) | Obsolete. Initializes a new instance of the PdfRenderer class.
Top
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Constructor (Stream)

Creates a new instance of the PdfRenderer class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRenderer(
    Stream outStream
)
Public Sub New (
    outStream As Stream
)

Parameters

outStream
Type: System.IOStream
The stream to which a PdfGeneratedDocument will be rendered.
See Also

Reference

PdfRenderer Class
PdfRenderer Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Constructor (String, String, Stream)

Note: This API is now obsolete.

Creates a new instance of the PdfRenderer class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfRenderer(outStream, pdfSaveOptions, embedGeneratedContent, selfPrinting) constructor overload.")]
public PdfRenderer(
    string UserPassword,
    string OwnerPassword,
    Stream outStream
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfRenderer(outStream, pdfSaveOptions, embedGeneratedContent, selfPrinting) constructor overload.")>
Public Sub New (
    UserPassword As String,
    OwnerPassword As String,
    outStream As Stream
)

Parameters

UserPassword
Type: SystemString
The user password for the document. Null indicates no password.
OwnerPassword
Type: SystemString
The owner password for the document. Null indicates no password.
outStream
Type: System.IOStream
The output stream.
See Also

Reference

PdfRenderer Class
PdfRenderer Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Constructor (Stream, PdfSaveOptions, Boolean, Boolean)

Initializes a new instance of the PdfRenderer class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRenderer(
    Stream outStream,
    PdfSaveOptions pdfSaveOptions = null,
    bool embedGeneratedContent = true,
    bool selfPrinting = false
)
Public Sub New (
    outStream As Stream,
    Optional pdfSaveOptions As PdfSaveOptions = Nothing,
    Optional embedGeneratedContent As Boolean = true,
    Optional selfPrinting As Boolean = false
)

Parameters

outStream
Type: System.IOStream
The out stream.
pdfSaveOptions (Optional)
Type: Atalasoft.PdfDocPdfSaveOptions
The options for saving the PDF document.
embedGeneratedContent (Optional)
Type: SystemBoolean
if set to true [embed generated content].
selfPrinting (Optional)
Type: SystemBoolean
if set to true [self printing].
See Also

Reference

PdfRenderer Class
PdfRenderer Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Constructor (String, String, Stream, Boolean, Boolean)

Note: This API is now obsolete.

Initializes a new instance of the PdfRenderer class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This constructor is obsolete. Use PdfRenderer(outStream, pdfSaveOptions, embedGeneratedContent, selfPrinting) constructor overload.")]
public PdfRenderer(
    string UserPassword,
    string OwnerPassword,
    Stream outStream,
    bool embedGeneratedContent,
    bool selfPrinting
)
<ObsoleteAttribute("This constructor is obsolete. Use PdfRenderer(outStream, pdfSaveOptions, embedGeneratedContent, selfPrinting) constructor overload.")>
Public Sub New (
    UserPassword As String,
    OwnerPassword As String,
    outStream As Stream,
    embedGeneratedContent As Boolean,
    selfPrinting As Boolean
)

Parameters

UserPassword
Type: SystemString
The user password.
OwnerPassword
Type: SystemString
The owner password.
outStream
Type: System.IOStream
The out stream.
embedGeneratedContent
Type: SystemBoolean
if set to true [embed generated content].
selfPrinting
Type: SystemBoolean
if set to true [self printing].
See Also

Reference

PdfRenderer Class
PdfRenderer Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Properties

The PdfRenderer type exposes the following members.

Properties
 | Name | Description
Protected property | CurrentPage |
Protected property | ErrorOccurred | Gets or sets a value indicating whether an error occurred in the process of rendering a page. ErrorOccurred will be cleared before rendering begins. (Inherited from DocumentRenderer.)
Protected property | SaveOptions |
Top
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.CurrentPage Property

PdfRendererCurrentPage Property

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected int CurrentPage { get; set; }
Protected Property CurrentPage As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.SaveOptions Property

PdfRendererSaveOptions Property

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfSaveOptions SaveOptions { get; }
Protected ReadOnly Property SaveOptions As PdfSaveOptions
    Get

Property Value

Type: PdfSaveOptions
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Methods

The PdfRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLBeginDoc | This method represents the Low-Level implementation of BeginDoc. It is called once at the start of rendering the document after the first DocumentProgress event has been fired, but before the first page is rendered. If a document has an empty Pages collection, LLBeginDoc will not be called. The default implementation does nothing. (Overrides DocumentRendererLLBeginDoc(PdfGeneratedDocument).)
Protected method | LLBeginPage | Low Level the begin page. (Overrides DocumentRendererLLBeginPage(PdfGeneratedDocument, BasePage).)
Protected method | LLEndDoc | This method represents the Low-Level implementation of EndDoc. It is called once at the end of rendering a document after the final DocumentProgress event has been fired. If a document has an empty Pages collection, LLEndDoc will not be called. A concrete implementation of DocumentRenderer could use this method for cleaning up temporary files created during the rendering process. (Overrides DocumentRendererLLEndDoc(PdfGeneratedDocument).)
Protected method | LLEndPage | This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing. (Overrides DocumentRendererLLEndPage(PdfGeneratedDocument, BasePage).)
Protected method | LLGenerate | Low Level generate. (Overrides DocumentRendererLLGenerate(PdfGeneratedDocument, BasePage, PdfPageRenderer).)
Protected method | MakePageRenderer | Makes the page renderer. (Overrides DocumentRendererMakePageRenderer(PdfGeneratedDocument, BasePage).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDocumentProgress | Raises the [E:DocumentProgress] event. (Inherited from DocumentRenderer.)
Protected method | PreprocessPageResources |
Public method | Render(PdfGeneratedDocument) | Renders the entire PdfGeneratedDocument. (Inherited from DocumentRenderer.)
 | Render(PdfGeneratedDocument, ICollectionBasePage) | Renders a subset of pages from the specified document. This method is intended to allow the rendering of a subset of pages from a document. If pages is an empty enumeration, the output is undefined. (Inherited from DocumentRenderer.)
Protected method | RenderBookmarkTree |
Protected method | RenderForm |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.LLBeginDoc Method

PdfRendererLLBeginDoc Method

This method represents the Low-Level implementation of BeginDoc. It is called once at the start of rendering the document after the first DocumentProgress event has been fired, but before the first page is rendered. If a document has an empty Pages collection, LLBeginDoc will not be called. The default implementation does nothing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLBeginDoc(
    PdfGeneratedDocument document
)
Protected Overrides Sub LLBeginDoc (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.LLBeginPage Method

PdfRendererLLBeginPage Method

Low Level the begin page.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLBeginPage(
    PdfGeneratedDocument document,
    BasePage basePage
)
Protected Overrides Sub LLBeginPage (
    document As PdfGeneratedDocument,
    basePage As BasePage
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
basePage
Type: Atalasoft.PdfDocBasePage
The base page.
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.LLEndDoc Method

PdfRendererLLEndDoc Method

This method represents the Low-Level implementation of EndDoc. It is called once at the end of rendering a document after the final DocumentProgress event has been fired. If a document has an empty Pages collection, LLEndDoc will not be called. A concrete implementation of DocumentRenderer could use this method for cleaning up temporary files created during the rendering process.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLEndDoc(
    PdfGeneratedDocument document
)
Protected Overrides Sub LLEndDoc (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.LLEndPage Method

PdfRendererLLEndPage Method

This method represents the Low-Level implementation of EndPage. A subclass of DocumentRenderer would implement this method to do any processing to finish up after a page has been rendered. For example, a particular instance might need to remove temporary files created earlier. The default implementation does nothing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLEndPage(
    PdfGeneratedDocument document,
    BasePage page
)
Protected Overrides Sub LLEndPage (
    document As PdfGeneratedDocument,
    page As BasePage
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document being rendered.
page
Type: Atalasoft.PdfDocBasePage
The current page that was just rendered.
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.LLGenerate Method

PdfRendererLLGenerate Method

Low Level generate.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void LLGenerate(
    PdfGeneratedDocument document,
    BasePage basePage,
    PdfPageRenderer renderer
)
Protected Overrides Sub LLGenerate (
    document As PdfGeneratedDocument,
    basePage As BasePage,
    renderer As PdfPageRenderer
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
basePage
Type: Atalasoft.PdfDocBasePage
The base page.
renderer
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The renderer.
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.MakePageRenderer Method

PdfRendererMakePageRenderer Method

Makes the page renderer.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfPageRenderer MakePageRenderer(
    PdfGeneratedDocument document,
    BasePage basePage
)
Protected Overrides Function MakePageRenderer (
    document As PdfGeneratedDocument,
    basePage As BasePage
) As PdfPageRenderer

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
basePage
Type: Atalasoft.PdfDocBasePage
The base page.

Return Value

Type: PdfPageRenderer
A new PdfPageRenderer
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.PreprocessPageResources Method

PdfRendererPreprocessPageResources Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void PreprocessPageResources(
    PdfPageRenderer pdfPageRenderer,
    PdfGeneratedPage page
)
Protected Overridable Sub PreprocessPageResources (
    pdfPageRenderer As PdfPageRenderer,
    page As PdfGeneratedPage
)

Parameters

pdfPageRenderer
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
page
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.RenderBookmarkTree Method

PdfRendererRenderBookmarkTree Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderBookmarkTree(
    PdfGeneratedDocument document
)
Protected Overridable Sub RenderBookmarkTree (
    document As PdfGeneratedDocument
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer.RenderForm Method

PdfRendererRenderForm Method

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void RenderForm(
    PdfGeneratedDocument document,
    bool preserveAllResources
)
Protected Overridable Sub RenderForm (
    document As PdfGeneratedDocument,
    preserveAllResources As Boolean
)

Parameters

document
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
preserveAllResources
Type: SystemBoolean
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfRenderer Events

The PdfRenderer type exposes the following members.

Events
 | Name | Description
Public event | DocumentProgress | Occurs when progress is made in the overall process of rendering the document. This event is fired when rendering starts, when rendering completes, when each page starts and when each page completes. If the document contains no pages, then precisely one DocumentProgress event will be fired. (Inherited from DocumentRenderer.)
Top
See Also

Reference

PdfRenderer Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance Class

PdfTextAppearance represents the general characteristics of text on page, including font name, size, character spacing, leading, and so on.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingPdfTextAppearance

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTextAppearance
Public Class PdfTextAppearance

The PdfTextAppearance type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTextAppearance | Initializes a new instance of the PdfTextAppearance class.
Public method | PdfTextAppearance(String, Double) | Initializes a new instance of the PdfTextAppearance class with the given font and size in points.
Top
Properties
 | Name | Description
Public property | CharacterSpacing | Gets or sets the character spacing.
Public property | FillColor | Gets or sets the fill color of the text. This is only used in one of the text render modes that uses filling.
Public property | FontName | Gets or sets the name of the font. This is a resource name, not the font's name.
Public property | FontSize | Gets or sets the size of the font in points.
Public property | HorizontalScaling | Gets or sets the horizontal scaling of characters as they are placed on the page as a percentage. 100 is normal. Less than 100 is narrower, greater is wider.
Public property | Leading | Gets or sets the leading or spacing between lines.
Public property | Matrix | Gets or sets the font matrix.
Public property | RenderMode | Gets or sets the render mode for the text.
Public property | Rise | Gets or sets the rise, or how much characters sit above (or below) the baseline. This is used for creating superscript or subscript writing.
Public property | StrokeColor | Gets or sets the stroke color of the text. This is only used in one of the text render modes that uses stroking.
Public property | WordSpacing | Gets or sets the word spacing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The following are the default values for the class: MatrixThe identity matrix.CharacterSpacing0WordSpacing0HorizontalScaling100Leading0RenderModeFillTextRise0FillColorGray 0 (ie, black)StrokeColornull - no stroke, fill onlyFontSize0FontNamenull
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance Constructor

Overload List
 | Name | Description
Public method | PdfTextAppearance | Initializes a new instance of the PdfTextAppearance class.
Public method | PdfTextAppearance(String, Double) | Initializes a new instance of the PdfTextAppearance class with the given font and size in points.
Top
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance Constructor

Initializes a new instance of the PdfTextAppearance class.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance()
Public Sub New
See Also

Reference

PdfTextAppearance Class
PdfTextAppearance Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance Constructor (String, Double)

Initializes a new instance of the PdfTextAppearance class with the given font and size in points.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAppearance(
    string fontName,
    double fontSize
)
Public Sub New (
    fontName As String,
    fontSize As Double
)

Parameters

fontName
Type: SystemString
Name of the font from the document resources.
fontSize
Type: SystemDouble
Size of the font.
See Also

Reference

PdfTextAppearance Class
PdfTextAppearance Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance Properties

The PdfTextAppearance type exposes the following members.

Properties
 | Name | Description
Public property | CharacterSpacing | Gets or sets the character spacing.
Public property | FillColor | Gets or sets the fill color of the text. This is only used in one of the text render modes that uses filling.
Public property | FontName | Gets or sets the name of the font. This is a resource name, not the font's name.
Public property | FontSize | Gets or sets the size of the font in points.
Public property | HorizontalScaling | Gets or sets the horizontal scaling of characters as they are placed on the page as a percentage. 100 is normal. Less than 100 is narrower, greater is wider.
Public property | Leading | Gets or sets the leading or spacing between lines.
Public property | Matrix | Gets or sets the font matrix.
Public property | RenderMode | Gets or sets the render mode for the text.
Public property | Rise | Gets or sets the rise, or how much characters sit above (or below) the baseline. This is used for creating superscript or subscript writing.
Public property | StrokeColor | Gets or sets the stroke color of the text. This is only used in one of the text render modes that uses stroking.
Public property | WordSpacing | Gets or sets the word spacing.
Top
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.CharacterSpacing Property

PdfTextAppearanceCharacterSpacing Property

Gets or sets the character spacing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double CharacterSpacing { get; set; }
Public Property CharacterSpacing As Double
    Get
    Set

Property Value

Type: Double
The character spacing.
Remarks
Spacing is the amount of space to add (or take away) between characters as they are placed on the page. Negative numbers bring the characters closer.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.FillColor Property

PdfTextAppearanceFillColor Property

Gets or sets the fill color of the text. This is only used in one of the text render modes that uses filling.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor FillColor { get; set; }
Public Property FillColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The fill color of the text.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.FontName Property

PdfTextAppearanceFontName Property

Gets or sets the name of the font. This is a resource name, not the font's name.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set

Property Value

Type: String
The name of the font.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.FontSize Property

PdfTextAppearanceFontSize Property

Gets or sets the size of the font in points.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double FontSize { get; set; }
Public Property FontSize As Double
    Get
    Set

Property Value

Type: Double
The size of the font.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.HorizontalScaling Property

PdfTextAppearanceHorizontalScaling Property

Gets or sets the horizontal scaling of characters as they are placed on the page as a percentage. 100 is normal. Less than 100 is narrower, greater is wider.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HorizontalScaling { get; set; }
Public Property HorizontalScaling As Double
    Get
    Set

Property Value

Type: Double
The horizontal scaling.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.Leading Property

PdfTextAppearanceLeading Property

Gets or sets the leading or spacing between lines.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Leading { get; set; }
Public Property Leading As Double
    Get
    Set

Property Value

Type: Double
The leading.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.Matrix Property

PdfTextAppearanceMatrix Property

Gets or sets the font matrix.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform Matrix { get; set; }
Public Property Matrix As PdfTransform
    Get
    Set

Property Value

Type: PdfTransform
The matrix.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.RenderMode Property

PdfTextAppearanceRenderMode Property

Gets or sets the render mode for the text.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextRenderMode RenderMode { get; set; }
Public Property RenderMode As PdfTextRenderMode
    Get
    Set

Property Value

Type: PdfTextRenderMode
The render mode.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.Rise Property

PdfTextAppearanceRise Property

Gets or sets the rise, or how much characters sit above (or below) the baseline. This is used for creating superscript or subscript writing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Rise { get; set; }
Public Property Rise As Double
    Get
    Set

Property Value

Type: Double
The rise.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.StrokeColor Property

PdfTextAppearanceStrokeColor Property

Gets or sets the stroke color of the text. This is only used in one of the text render modes that uses stroking.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor StrokeColor { get; set; }
Public Property StrokeColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The stroke color of the text.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance.WordSpacing Property

PdfTextAppearanceWordSpacing Property

Gets or sets the word spacing.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double WordSpacing { get; set; }
Public Property WordSpacing As Double
    Get
    Set

Property Value

Type: Double
The word spacing.
Remarks
Spacing is the amount of space to add (or take away) between words as they are placed on the page. Negative numbers bring the words closer.
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextAppearance Methods

The PdfTextAppearance type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextAppearance Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface Class

PdfTextSurface is used to add Text objects to the pdf display list.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.RenderingPdfTextSurface

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PdfTextSurface
Public MustInherit Class PdfTextSurface

The PdfTextSurface type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfTextSurface | Initializes a new instance of the PdfTextSurface class
Top
Methods
 | Name | Description
Public method | ApplyTextMatrix | Applies the text matrix.
Public method | Begin | Begin starts the TextSurface and prepares it for writing. It must be called before using any other TextSurface operations.
Public method | EncodeToPdf(String, Char) | Encodes a single character to PDF using an appropriate encoding for the supplied font in GlobalResources.
Public method | EncodeToPdf(String, String) | Encodes a string to PDF using an appropriate encoding for the supplied font in GlobalResources.
Public method | End | End completes the TextSurface. It must be called when the TextSurface is no longer needed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFont | Sets the font.
Public method | SetHorizontalScale | Sets the horizontal scale.
Public method | SetTextLeading | Sets the text leading.
Public method | SetTextPoint | Sets the text start point.
Public method | SetTextRenderMode(PdfTextRenderMode) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor, Double) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor, IPdfColor, NullableDouble) | Sets the text render mode.
Public method | SetWordSpace | Sets the word space.
Public method | TextIsUnicode | Identifies if the text is unicode or not
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteAdvanceLineWithNewXStartPoint | Writes the text line with a new X start point and inserts a newline.
Public method | WriteKerningPairs | Writes the kerning pairs.
Public method | WriteText | Writes the text at the current point.
Public method | WriteTextAdvanceLine | Writes the text and inserts a newline.
Public method | WriteTextAt(String, PdfPoint) | Writes the text at the specified point.
Public method | WriteTextAt(String, Double, Double) | Writes the text at.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface Constructor

Initializes a new instance of the PdfTextSurface class

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfTextSurface()
Protected Sub New
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface Methods

The PdfTextSurface type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTextMatrix | Applies the text matrix.
Public method | Begin | Begin starts the TextSurface and prepares it for writing. It must be called before using any other TextSurface operations.
Public method | EncodeToPdf(String, Char) | Encodes a single character to PDF using an appropriate encoding for the supplied font in GlobalResources.
Public method | EncodeToPdf(String, String) | Encodes a string to PDF using an appropriate encoding for the supplied font in GlobalResources.
Public method | End | End completes the TextSurface. It must be called when the TextSurface is no longer needed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFont | Sets the font.
Public method | SetHorizontalScale | Sets the horizontal scale.
Public method | SetTextLeading | Sets the text leading.
Public method | SetTextPoint | Sets the text start point.
Public method | SetTextRenderMode(PdfTextRenderMode) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor, Double) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor, IPdfColor, NullableDouble) | Sets the text render mode.
Public method | SetWordSpace | Sets the word space.
Public method | TextIsUnicode | Identifies if the text is unicode or not
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteAdvanceLineWithNewXStartPoint | Writes the text line with a new X start point and inserts a newline.
Public method | WriteKerningPairs | Writes the kerning pairs.
Public method | WriteText | Writes the text at the current point.
Public method | WriteTextAdvanceLine | Writes the text and inserts a newline.
Public method | WriteTextAt(String, PdfPoint) | Writes the text at the specified point.
Public method | WriteTextAt(String, Double, Double) | Writes the text at.
Top
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.ApplyTextMatrix Method

PdfTextSurfaceApplyTextMatrix Method

Applies the text matrix.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void ApplyTextMatrix(
    PdfTransform transform
)
Public MustOverride Sub ApplyTextMatrix (
    transform As PdfTransform
)

Parameters

transform
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform matrix.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.Begin Method

PdfTextSurfaceBegin Method

Begin starts the TextSurface and prepares it for writing. It must be called before using any other TextSurface operations.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Begin()
Public MustOverride Sub Begin
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.EncodeToPdf Method

PdfTextSurfaceEncodeToPdf Method

Overload List
 | Name | Description
Public method | EncodeToPdf(String, Char) | Encodes a single character to PDF using an appropriate encoding for the supplied font in GlobalResources.
Public method | EncodeToPdf(String, String) | Encodes a string to PDF using an appropriate encoding for the supplied font in GlobalResources.
Top
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.EncodeToPdf Method (String, Char)

PdfTextSurfaceEncodeToPdf Method (String, Char)

Encodes a single character to PDF using an appropriate encoding for the supplied font in GlobalResources.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual char EncodeToPdf(
    string globalFontName,
    char charToEncode
)
Public Overridable Function EncodeToPdf (
    globalFontName As String,
    charToEncode As Char
) As Char

Parameters

globalFontName
Type: SystemString
Name of the font in GlobalResources.
charToEncode
Type: SystemChar
The text to encode.

Return Value

Type: Char
An encoded character
Remarks
This is meant to be used for text that will appear in a content stream of a PDF document.
See Also

Reference

PdfTextSurface Class
EncodeToPdf Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.EncodeToPdf Method (String, String)

PdfTextSurfaceEncodeToPdf Method (String, String)

Encodes a string to PDF using an appropriate encoding for the supplied font in GlobalResources.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual string EncodeToPdf(
    string globalFontName,
    string textToEncode
)
Public Overridable Function EncodeToPdf (
    globalFontName As String,
    textToEncode As String
) As String

Parameters

globalFontName
Type: SystemString
Name of the font in GlobalResources.
textToEncode
Type: SystemString
The text to encode.

Return Value

Type: String
An encoded string
Remarks
This is meant to be used for text that will appear in a content stream of a PDF document.
See Also

Reference

PdfTextSurface Class
EncodeToPdf Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.End Method

PdfTextSurfaceEnd Method

End completes the TextSurface. It must be called when the TextSurface is no longer needed.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void End()
Public MustOverride Sub End
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetFont Method

PdfTextSurfaceSetFont Method

Sets the font.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void SetFont(
    string fontName,
    double fontSize,
    bool requiresUnicodeFont
)
Public MustOverride Sub SetFont (
    fontName As String,
    fontSize As Double,
    requiresUnicodeFont As Boolean
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
requiresUnicodeFont
Type: SystemBoolean
if set to true then the font will need unicode characters.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetHorizontalScale Method

PdfTextSurfaceSetHorizontalScale Method

Sets the horizontal scale.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void SetHorizontalScale(
    double scale
)
Public MustOverride Sub SetHorizontalScale (
    scale As Double
)

Parameters

scale
Type: SystemDouble
The scale in percentage from default (100 is the default).
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextLeading Method

PdfTextSurfaceSetTextLeading Method

Sets the text leading.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void SetTextLeading(
    double leading
)
Public MustOverride Sub SetTextLeading (
    leading As Double
)

Parameters

leading
Type: SystemDouble
The text leading expressed in Pdf text points.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextPoint Method

PdfTextSurfaceSetTextPoint Method

Sets the text start point.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void SetTextPoint(
    PdfPoint point
)
Public MustOverride Sub SetTextPoint (
    point As PdfPoint
)

Parameters

point
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The text start point.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextRenderMode Method

PdfTextSurfaceSetTextRenderMode Method

Overload List
 | Name | Description
Public method | SetTextRenderMode(PdfTextRenderMode) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor, Double) | Sets the text render mode.
Public method | SetTextRenderMode(PdfTextRenderMode, IPdfColor, IPdfColor, NullableDouble) | Sets the text render mode.
Top
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextRenderMode Method (PdfTextRenderMode)

PdfTextSurfaceSetTextRenderMode Method (PdfTextRenderMode)

Sets the text render mode.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void SetTextRenderMode(
    PdfTextRenderMode mode
)
Public Overridable Sub SetTextRenderMode (
    mode As PdfTextRenderMode
)

Parameters

mode
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfTextRenderMode
The render mode.
See Also

Reference

PdfTextSurface Class
SetTextRenderMode Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextRenderMode Method (PdfTextRenderMode, IPdfColor)

PdfTextSurfaceSetTextRenderMode Method (PdfTextRenderMode, IPdfColor)

Sets the text render mode.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void SetTextRenderMode(
    PdfTextRenderMode mode,
    IPdfColor fillColor
)
Public Overridable Sub SetTextRenderMode (
    mode As PdfTextRenderMode,
    fillColor As IPdfColor
)

Parameters

mode
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfTextRenderMode
The render mode.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color the text will be filled with.
See Also

Reference

PdfTextSurface Class
SetTextRenderMode Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextRenderMode Method (PdfTextRenderMode, IPdfColor, Double)

PdfTextSurfaceSetTextRenderMode Method (PdfTextRenderMode, IPdfColor, Double)

Sets the text render mode.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void SetTextRenderMode(
    PdfTextRenderMode mode,
    IPdfColor outlineColor,
    double outlineWidth
)
Public Overridable Sub SetTextRenderMode (
    mode As PdfTextRenderMode,
    outlineColor As IPdfColor,
    outlineWidth As Double
)

Parameters

mode
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfTextRenderMode
The render mode.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline of the text.
outlineWidth
Type: SystemDouble
Width of the outline of the text.
See Also

Reference

PdfTextSurface Class
SetTextRenderMode Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetTextRenderMode Method (PdfTextRenderMode, IPdfColor, IPdfColor, Nullable(Double))

PdfTextSurfaceSetTextRenderMode Method (PdfTextRenderMode, IPdfColor, IPdfColor, NullableDouble)

Sets the text render mode.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void SetTextRenderMode(
    PdfTextRenderMode mode,
    IPdfColor fillColor,
    IPdfColor outlineColor,
    Nullable<double> outlineWidth
)
Public MustOverride Sub SetTextRenderMode (
    mode As PdfTextRenderMode,
    fillColor As IPdfColor,
    outlineColor As IPdfColor,
    outlineWidth As Nullable(Of Double)
)

Parameters

mode
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfTextRenderMode
The render mode.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color the text will be filled with.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline of the text.
outlineWidth
Type: SystemNullableDouble
Width of the outline of the text.
See Also

Reference

PdfTextSurface Class
SetTextRenderMode Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.SetWordSpace Method

PdfTextSurfaceSetWordSpace Method

Sets the word space.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void SetWordSpace(
    double space
)
Public MustOverride Sub SetWordSpace (
    space As Double
)

Parameters

space
Type: SystemDouble
The spaceing between words.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.TextIsUnicode Method

PdfTextSurfaceTextIsUnicode Method

Identifies if the text is unicode or not

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TextIsUnicode(
    string text
)
Public Function TextIsUnicode (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text.

Return Value

Type: Boolean
True if the text requires unicode encoding
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteAdvanceLineWithNewXStartPoint Method

PdfTextSurfaceWriteAdvanceLineWithNewXStartPoint Method

Writes the text line with a new X start point and inserts a newline.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void WriteAdvanceLineWithNewXStartPoint(
    double newXStartPos,
    string text
)
Public MustOverride Sub WriteAdvanceLineWithNewXStartPoint (
    newXStartPos As Double,
    text As String
)

Parameters

newXStartPos
Type: SystemDouble
The new X coordinate to write the line at.
text
Type: SystemString
The text.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteKerningPairs Method

PdfTextSurfaceWriteKerningPairs Method

Writes the kerning pairs.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void WriteKerningPairs(
    IList<KerningPair> kerningPairs
)
Public MustOverride Sub WriteKerningPairs (
    kerningPairs As IList(Of KerningPair)
)

Parameters

kerningPairs
Type: System.Collections.GenericIListKerningPair
The kerning pairs.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteText Method

PdfTextSurfaceWriteText Method

Writes the text at the current point.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void WriteText(
    string text
)
Public MustOverride Sub WriteText (
    text As String
)

Parameters

text
Type: SystemString
The text.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteTextAdvanceLine Method

PdfTextSurfaceWriteTextAdvanceLine Method

Writes the text and inserts a newline.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void WriteTextAdvanceLine(
    string text
)
Public MustOverride Sub WriteTextAdvanceLine (
    text As String
)

Parameters

text
Type: SystemString
The text.
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteTextAt Method

PdfTextSurfaceWriteTextAt Method

Overload List
 | Name | Description
Public method | WriteTextAt(String, PdfPoint) | Writes the text at the specified point.
Public method | WriteTextAt(String, Double, Double) | Writes the text at.
Top
See Also

Reference

PdfTextSurface Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteTextAt Method (String, PdfPoint)

PdfTextSurfaceWriteTextAt Method (String, PdfPoint)

Writes the text at the specified point.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void WriteTextAt(
    string text,
    PdfPoint point
)
Public Sub WriteTextAt (
    text As String,
    point As PdfPoint
)

Parameters

text
Type: SystemString
The text.
point
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to start writing the text at.
See Also

Reference

PdfTextSurface Class
WriteTextAt Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


PdfTextSurface.WriteTextAt Method (String, Double, Double)

PdfTextSurfaceWriteTextAt Method (String, Double, Double)

Writes the text at.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void WriteTextAt(
    string text,
    double xLineOffset,
    double yLineOffset
)
Public MustOverride Sub WriteTextAt (
    text As String,
    xLineOffset As Double,
    yLineOffset As Double
)

Parameters

text
Type: SystemString
The text.
xLineOffset
Type: SystemDouble
The x coordinate of the point to write the text.
yLineOffset
Type: SystemDouble
The y coordinate of the point to write the text.
See Also

Reference

PdfTextSurface Class
WriteTextAt Overload
Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs Class

This class represents information about progress made during PDF Rendering.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.PdfDoc.Generating.RenderingRenderProgressEventArgs

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RenderProgressEventArgs : EventArgs
Public Class RenderProgressEventArgs
    Inherits EventArgs

The RenderProgressEventArgs type exposes the following members.

Constructors
Name | Description
RenderProgressEventArgs | Constructs a new instance of the RenderProgressEventArgs class. Note that this class is constructed during normal operation of document rendering. There are few cases where client code would have to construct this.
Top
Properties
 | Name | Description
Public property | Message | Gets or sets a message describing current work being done.
Public property | Progress | Gets or sets the current progress.
Public property | Total | Gets or sets the total amount of work to do.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs Constructor

Constructs a new instance of the RenderProgressEventArgs class. Note that this class is constructed during normal operation of document rendering. There are few cases where client code would have to construct this.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RenderProgressEventArgs(
    int currentProgress,
    int total,
    string message
)
Public Sub New (
    currentProgress As Integer,
    total As Integer,
    message As String
)

Parameters

currentProgress
Type: SystemInt32
The current progress of the document.
total
Type: SystemInt32
The total progress to be made.
message
Type: SystemString
Description of the current work being done.
Examples
Copy
RenderProgressEventArgs e = new RenderProgressEventArgs(currentPage, totalPages, "Rendering a page.");
See Also

Reference

RenderProgressEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs Properties

The RenderProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets or sets a message describing current work being done.
Public property | Progress | Gets or sets the current progress.
Public property | Total | Gets or sets the total amount of work to do.
Top
See Also

Reference

RenderProgressEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs.Message Property

RenderProgressEventArgsMessage Property

Gets or sets a message describing current work being done.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set

Property Value

Type: String
A string describing work that is being done.
See Also

Reference

RenderProgressEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs.Progress Property

RenderProgressEventArgsProgress Property

Gets or sets the current progress.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Progress { get; set; }
Public Property Progress As Integer
    Get
    Set

Property Value

Type: Int32
Progress should be an integer between 0 and Total, inclusive.
See Also

Reference

RenderProgressEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs.Total Property

RenderProgressEventArgsTotal Property

Gets or sets the total amount of work to do.

Namespace: Atalasoft.PdfDoc.Generating.Rendering
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Total { get; set; }
Public Property Total As Integer
    Get
    Set

Property Value

Type: Int32
Total should be be an integer greater than 0. While it is possible to set it to other values, client code may wish to monitor work as a percentage and dividing by a negative or zero will produce bad results.
See Also

Reference

RenderProgressEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


RenderProgressEventArgs Methods

The RenderProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RenderProgressEventArgs Class
Atalasoft.PdfDoc.Generating.Rendering Namespace


Atalasoft.PdfDoc.Generating.ResourceHandling Namespace

Classes
 | Class | Description
Public class | GlobalResources | This class represents resources that will be used globally through one or more PDF documents being Generated.
Public class | PdfResource | PdfResource is a base class for all document resources used in Generating PDF documents. These resource include fonts, images, page content templates, and color space definitions. Resources can represent large amounts of data that may be used by multiple pages within a document. By referring to them indirectly through resource managers allows the resources to be shared within the document. The PDF Generating toolkit defines the resource types and managers for each. Client code will never need to define its own resource types. PdfResource on its own is never used except to define base capabilities and to create collection classes.
Public class | PdfResourceManagerT | PdfResourceManager is a generic type that is used for defining the base capabilities and implementations of all classes of resource manager. Specific implementations of PdfResourceManager are defined in the PDF Generating toolkit and need not be created by client code. Resources are referred to by a string name. The actual name itself is not important and will not appear directly in any produced PDF. The name is used to distinguish one resource from another. Clients may choose any name they wish as long as different resources of the same type have different names.
Interfaces
 | Interface | Description
Public interface | IPdfResourceConsumer | An interface to prevent renaming conflict disconnects when a resource changes names.
Delegates
 | Delegate | Description
Public delegate | GlobalResourcesMergeRenameNotifier | An event delegate used for alerting about successful merge renames.
Enumerations
 | Enumeration | Description
Public enumeration | PdfResourceClass | A PdfResource designation class
Public enumeration | ResourceSelection | The handler for duplicate entries coming into the ResourceManager


GlobalResources Class

This class represents resources that will be used globally through one or more PDF documents being Generated.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GlobalResources : IDisposable
Public Class GlobalResources
    Implements IDisposable

The GlobalResources type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalResources | Initializes a new instance of the GlobalResources class with new managers for each class of resource.
Top
Properties
 | Name | Description
Public property | ColorSpaces | Gets the color spaces.
Public property | Fonts | Gets the font resource manager for these global resources
Public property | Images | Gets the images.
Public property | Templates | Gets the templates.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes all the resources in all the resource maangers contained within this object.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the GlobalResources is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merges the specified other.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources Constructor

Initializes a new instance of the GlobalResources class with new managers for each class of resource.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GlobalResources()
Public Sub New
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources Properties

The GlobalResources type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaces | Gets the color spaces.
Public property | Fonts | Gets the font resource manager for these global resources
Public property | Images | Gets the images.
Public property | Templates | Gets the templates.
Top
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.ColorSpaces Property

GlobalResourcesColorSpaces Property

Gets the color spaces.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorSpaceManager ColorSpaces { get; }
Public ReadOnly Property ColorSpaces As PdfColorSpaceManager
    Get

Property Value

Type: PdfColorSpaceManager
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Fonts Property

GlobalResourcesFonts Property

Gets the font resource manager for these global resources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontManager Fonts { get; }
Public ReadOnly Property Fonts As PdfFontManager
    Get

Property Value

Type: PdfFontManager
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Images Property

GlobalResourcesImages Property

Gets the images.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageManager Images { get; }
Public ReadOnly Property Images As PdfImageManager
    Get

Property Value

Type: PdfImageManager
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Templates Property

GlobalResourcesTemplates Property

Gets the templates.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTemplateManager Templates { get; }
Public ReadOnly Property Templates As PdfTemplateManager
    Get

Property Value

Type: PdfTemplateManager
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources Methods

The GlobalResources type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes all the resources in all the resource maangers contained within this object.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the GlobalResources is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merges the specified other.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Dispose Method

GlobalResourcesDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes all the resources in all the resource maangers contained within this object.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Top
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Dispose Method

GlobalResourcesDispose Method

Disposes all the resources in all the resource maangers contained within this object.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

GlobalResources Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Dispose Method (Boolean)

GlobalResourcesDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

GlobalResources Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.DisposeManagedResources Method

GlobalResourcesDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.DisposeUnmanagedResources Method

GlobalResourcesDisposeUnmanagedResources Method

Disposes the unmanaged resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Finalize Method

GlobalResourcesFinalize Method

Releases unmanaged resources and performs other cleanup operations before the GlobalResources is reclaimed by garbage collection.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.Merge Method

GlobalResourcesMerge Method

Merges the specified other.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Merge(
    GlobalResources other,
    GlobalResourcesMergeRenameNotifier notifier
)
Public Sub Merge (
    other As GlobalResources,
    notifier As GlobalResourcesMergeRenameNotifier
)

Parameters

other
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The other.
notifier
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResourcesMergeRenameNotifier
The notifier.
See Also

Reference

GlobalResources Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


GlobalResources.MergeRenameNotifier Delegate

GlobalResourcesMergeRenameNotifier Delegate

An event delegate used for alerting about successful merge renames.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void MergeRenameNotifier(
    PdfResourceClass resourceClass,
    string oldName,
    string newName
)
Public Delegate Sub MergeRenameNotifier (
    resourceClass As PdfResourceClass,
    oldName As String,
    newName As String
)

Parameters

resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
oldName
Type: SystemString
The old name.
newName
Type: SystemString
The new name.
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


IPdfResourceConsumer Interface

An interface to prevent renaming conflict disconnects when a resource changes names.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfResourceConsumer
Public Interface IPdfResourceConsumer

The IPdfResourceConsumer type exposes the following members.

Methods
 | Name | Description
Public method | NotifyResourceRenamed | Notifies that the resource was renamed.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


IPdfResourceConsumer Methods

The IPdfResourceConsumer type exposes the following members.

Methods
 | Name | Description
Public method | NotifyResourceRenamed | Notifies that the resource was renamed.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Top
See Also

Reference

IPdfResourceConsumer Interface
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


IPdfResourceConsumer.NotifyResourceRenamed Method

IPdfResourceConsumerNotifyResourceRenamed Method

Notifies that the resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The gr.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original.
newName
Type: SystemString
The new name.
See Also

Reference

IPdfResourceConsumer Interface
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


IPdfResourceConsumer.ResourcesUsed Method

IPdfResourceConsumerResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.
Remarks
The gr parameter is used by objects that refer to resources which themselves may be resource consumers. Typical client code is unlikely to need to implement this class unless is uses a resource by name.
See Also

Reference

IPdfResourceConsumer Interface
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource Class

PdfResource is a base class for all document resources used in Generating PDF documents. These resource include fonts, images, page content templates, and color space definitions. Resources can represent large amounts of data that may be used by multiple pages within a document. By referring to them indirectly through resource managers allows the resources to be shared within the document. The PDF Generating toolkit defines the resource types and managers for each. Client code will never need to define its own resource types. PdfResource on its own is never used except to define base capabilities and to create collection classes.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageResource
Atalasoft.PdfDoc.Generating.ResourceHandling.TemplatesPdfTemplateResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfResource : IDisposable
Public Class PdfResource
    Implements IDisposable

The PdfResource type exposes the following members.

Constructors
 | Name | Description
Public method | PdfResource | Initializes a new instance of the PdfResource class
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource Constructor

Initializes a new instance of the PdfResource class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfResource()
Public Sub New
See Also

Reference

PdfResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource Methods

The PdfResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource.Dispose Method

PdfResourceDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Top
See Also

Reference

PdfResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource.Dispose Method

PdfResourceDispose Method

Disposes the resource.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfResource Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource.Dispose Method (Boolean)

PdfResourceDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PdfResource Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource.DisposeManagedResources Method

PdfResourceDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
See Also

Reference

PdfResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource.DisposeUnmanagedResources Method

PdfResourceDisposeUnmanagedResources Method

Disposes the unmanaged resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
See Also

Reference

PdfResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResource.Finalize Method

PdfResourceFinalize Method

Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

PdfResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceClass Enumeration

A PdfResource designation class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfResourceClass
Public Enumeration PdfResourceClass
Members
Member name | Description
Fonts | A font used for typography
Images | An image to display on the pdf
ColorSpaces | A colorspace to use
Templates | A drawing template
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T) Class

PdfResourceManagerT Class

PdfResourceManager is a generic type that is used for defining the base capabilities and implementations of all classes of resource manager. Specific implementations of PdfResourceManager are defined in the PDF Generating toolkit and need not be created by client code. Resources are referred to by a string name. The actual name itself is not important and will not appear directly in any produced PDF. The name is used to distinguish one resource from another. Clients may choose any name they wish as long as different resources of the same type have different names.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceManagerT
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceManager
Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageManager
Atalasoft.PdfDoc.Generating.ResourceHandling.TemplatesPdfTemplateManager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PdfResourceManager<T> : IDisposable
where T : PdfResource

Public MustInherit Class PdfResourceManager(Of T As PdfResource)
    Implements IDisposable

Type Parameters

T
The type of resource that is to be managed, must be a subclass of PdfResource

The PdfResourceManagerT type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfResourceManagerT | Initializes a new instance of the PdfResourceManagerT class.
Top
Properties
Name Description
Public property Item
Gets the resource with the specified s.
Protected property ResourceClass
Gets the resource class.
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
Top
Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
Public method Contains
Determines whether or not the resource is present.
Public method Dispose
Disposes all resources contained in this resource manager
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
Protected method DisposeManagedResources
Disposes the managed resources.
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Overrides ObjectFinalize.)
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
Protected method ResourcesMatch
Compares two resources for equality. Default implementation returns false. Subclasses should override this method
Protected method | ThrowIfDisposed
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T) Constructor

PdfResourceManagerT Constructor

Initializes a new instance of the PdfResourceManagerT class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfResourceManager(
    string autoPrefix
)
Protected Sub New (
    autoPrefix As String
)

Parameters

autoPrefix
Type: SystemString
The auto prefix.
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T) Properties

PdfResourceManagerT Properties

The PdfResourceManagerT generic type exposes the following members.

Properties
Name Description
Public property Item
Gets the resource with the specified s.
Protected property ResourceClass
Gets the resource class.
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
Top
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Item Property

PdfResourceManagerTItem Property

Gets the resource with the specified s.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T this[
    string s
] { get; }
Public ReadOnly Default Property Item (
    s As String
) As T
    Get

Parameters

s
Type: SystemString

Property Value

Type: T
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).ResourceClass Property

PdfResourceManagerTResourceClass Property

Gets the resource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PdfResourceClass ResourceClass { get; }
Protected MustOverride ReadOnly Property ResourceClass As PdfResourceClass
    Get

Property Value

Type: PdfResourceClass
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).ResourceNames Property

PdfResourceManagerTResourceNames Property

Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ICollection<string> ResourceNames { get; }
Public ReadOnly Property ResourceNames As ICollection(Of String)
    Get

Property Value

Type: ICollectionString
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T) Methods

PdfResourceManagerT Methods

The PdfResourceManagerT generic type exposes the following members.

Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
Public method Contains
Determines whether or not the resource is present.
Public method Dispose
Disposes all resources contained in this resource manager
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
Protected method DisposeManagedResources
Disposes the managed resources.
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Overrides ObjectFinalize.)
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
Protected method ResourcesMatch
Compares two resources for equality. Default implementation returns false. Subclasses should override this method
Protected method | ThrowIfDisposed
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
Top
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Add Method

PdfResourceManagerTAdd Method

Overload List
Name | Description
Add(T) | Adds the specified resource with an auto-generated name.
Add(String, T) | Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
Top
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Add Method (T)

PdfResourceManagerTAdd Method (T)

Adds the specified resource with an auto-generated name.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Add(
    T resource
)
Public Function Add (
    resource As T
) As String

Parameters

resource
Type: T
The resource to add.

Return Value

Type: String
A unique name that is associated with the given resource
Examples
Copy
string image = globalResources.Images.Add(myImageResource);
See Also

Reference

PdfResourceManagerT Class
Add Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Add Method (String, T)

PdfResourceManagerTAdd Method (String, T)

Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string name,
    T resource
)
Public Sub Add (
    name As String,
    resource As T
)

Parameters

name
Type: SystemString
The name of the resource to add.
resource
Type: T
The resource that will be added.
Examples
Copy
globalResources.Fonts.Add("times", PdfFontResource.FromFontName(globalResources.Fonts, "Times New Roman"));
See Also

Reference

PdfResourceManagerT Class
Add Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Contains Method

PdfResourceManagerTContains Method

Determines whether or not the resource is present.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the resource to look up.

Return Value

Type: Boolean
true if the manager contains the specified name; otherwise, false.
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Dispose Method

PdfResourceManagerTDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes all resources contained in this resource manager
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Top
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Dispose Method

PdfResourceManagerTDispose Method

Disposes all resources contained in this resource manager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfResourceManagerT Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Dispose Method (Boolean)

PdfResourceManagerTDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PdfResourceManagerT Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).DisposeManagedResources Method

PdfResourceManagerTDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).DisposeUnmanagedResources Method

PdfResourceManagerTDisposeUnmanagedResources Method

Disposes the unmanaged resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Finalize Method

PdfResourceManagerTFinalize Method

Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Get Method

PdfResourceManagerTGet Method

Gets a resource with the given name. Throws an exception if there is no resource present with that name.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Get(
    string name
)
Public Function Get (
    name As String
) As T

Parameters

name
Type: SystemString
The name of the resource to get.

Return Value

Type: T
The found resource
Examples
Copy
PdfFontResource font = globalResources.Get("plainfont0");
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Merge Method

PdfResourceManagerTMerge Method

Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Merge(
    PdfResourceManager<T> other,
    GlobalResourcesMergeRenameNotifier notifier
)
Public Sub Merge (
    other As PdfResourceManager(Of T),
    notifier As GlobalResourcesMergeRenameNotifier
)

Parameters

other
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceManager T
The set of other resources to be merged.
notifier
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResourcesMergeRenameNotifier
The selector to resolve conflicts. If selector is null, the original resource will be kept.
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).NextName Method

PdfResourceManagerTNextName Method

Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string NextName()
Public Function NextName As String

Return Value

Type: String
The next available name
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).Remove Method

PdfResourceManagerTRemove Method

Removes the resource of the specified name. Throws an ArgumentException if name is not present.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Remove(
    string name
)
Public Function Remove (
    name As String
) As T

Parameters

name
Type: SystemString
The name of the resource to remove.

Return Value

Type: T
The resource associated with name.
Examples
Copy
PdfFontResource resource = globalResources.Fonts.Remove("titlefont");
resource.Dispose(); // dispose this if it's no longer needed.
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).ResourcesMatch Method

PdfResourceManagerTResourcesMatch Method

Compares two resources for equality. Default implementation returns false. Subclasses should override this method

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual bool ResourcesMatch(
    T one,
    T two
)
Protected Overridable Function ResourcesMatch (
    one As T,
    two As T
) As Boolean

Parameters

one
Type: T
The first resource.
two
Type: T
The second resource.

Return Value

Type: Boolean
true if the resources match, false otherwise.
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).ThrowIfDisposed Method

PdfResourceManagerTThrowIfDisposed Method

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected void ThrowIfDisposed()
Protected Sub ThrowIfDisposed
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


PdfResourceManager(T).TryGet Method

PdfResourceManagerTTryGet Method

Tries to get the specified resource.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TryGet(
    string name,
    out T value
)
Public Function TryGet (
    name As String,
    <OutAttribute> ByRef value As T
) As Boolean

Parameters

name
Type: SystemString
The name of the resource to get.
value
Type: T
The resource retrieved.

Return Value

Type: Boolean
true if name is present; falseotherwise.
Examples
Copy
PdfFontResource font = null;
if (!globalResources.Fonts.TryGet("headingfont", out font))
    throw new Exception("unable to get heading font");
See Also

Reference

PdfResourceManagerT Class
Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


ResourceSelection Enumeration

The handler for duplicate entries coming into the ResourceManager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ResourceSelection
Public Enumeration ResourceSelection
Members
Member name | Description
KeepOriginal | Keep the original discard the new
OverwriteWithNew | Discard the original keep the new
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling Namespace


Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace

Classes
 | Class | Description
Public class | PdfCalGrayColorSpaceResource | A concrete calibrated grayscale color resource
Public class | PdfCalibratedColorSpaceResource | A generic calibrated color space
Public class | PdfCalRgbColorSpaceResource | A Calibrated color space as a resource.
Public class | PdfColorSpaceManager | Manages the pdf color space resources
Public class | PdfColorSpaceResource | A resource representing a color space for use in a pdf image.
Public class | PdfIccColorSpaceResource | A class representing an ICC complient color space for use in pdf
Public class | PdfNamedColorSpaceResource | PdfNamedColorSpaceResource is an internally used class representing stock PDF "device" colorspaces


PdfCalGrayColorSpaceResource Class

A concrete calibrated grayscale color resource
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalibratedColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalGrayColorSpaceResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCalGrayColorSpaceResource : PdfCalibratedColorSpaceResource
Public Class PdfCalGrayColorSpaceResource
    Inherits PdfCalibratedColorSpaceResource

The PdfCalGrayColorSpaceResource type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCalGrayColorSpaceResource | Initializes a new instance of the PdfCalGrayColorSpaceResource class.
Top
Properties
 | Name | Description
Public property | BlackPoint | Gets the black point. (Inherited from PdfCalibratedColorSpaceResource.)
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | Gamma | Gets or sets the gamma.
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Public property | WhitePoint | Gets the white point. (Inherited from PdfCalibratedColorSpaceResource.)
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowOnGammaOutOfRange | Throws the on gamma out of range. (Inherited from PdfCalibratedColorSpaceResource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalGrayColorSpaceResource Constructor

Initializes a new instance of the PdfCalGrayColorSpaceResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCalGrayColorSpaceResource()
Public Sub New
See Also

Reference

PdfCalGrayColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalGrayColorSpaceResource Properties

The PdfCalGrayColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | BlackPoint | Gets the black point. (Inherited from PdfCalibratedColorSpaceResource.)
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | Gamma | Gets or sets the gamma.
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Public property | WhitePoint | Gets the white point. (Inherited from PdfCalibratedColorSpaceResource.)
Top
See Also

Reference

PdfCalGrayColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalGrayColorSpaceResource.Gamma Property

PdfCalGrayColorSpaceResourceGamma Property

Gets or sets the gamma.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Gamma { get; set; }
Public Property Gamma As Double
    Get
    Set

Property Value

Type: Double
The gamma.
See Also

Reference

PdfCalGrayColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalGrayColorSpaceResource Methods

The PdfCalGrayColorSpaceResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowOnGammaOutOfRange | Throws the on gamma out of range. (Inherited from PdfCalibratedColorSpaceResource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCalGrayColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource Class

A generic calibrated color space
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalibratedColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalGrayColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalRgbColorSpaceResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCalibratedColorSpaceResource : PdfColorSpaceResource
Public Class PdfCalibratedColorSpaceResource
    Inherits PdfColorSpaceResource

The PdfCalibratedColorSpaceResource type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfCalibratedColorSpaceResource | Initializes a new instance of the PdfCalibratedColorSpaceResource class.
Top
Properties
 | Name | Description
Public property | BlackPoint | Gets the black point.
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Public property | WhitePoint | Gets the white point.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowOnGammaOutOfRange | Throws the on gamma out of range.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource Constructor

Initializes a new instance of the PdfCalibratedColorSpaceResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfCalibratedColorSpaceResource(
    PdfColorSpaceType type,
    int components
)
Protected Sub New (
    type As PdfColorSpaceType,
    components As Integer
)

Parameters

type
Type: Atalasoft.PdfDoc.GeneratingPdfColorSpaceType
The type.
components
Type: SystemInt32
The components.
See Also

Reference

PdfCalibratedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource Properties

The PdfCalibratedColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | BlackPoint | Gets the black point.
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Public property | WhitePoint | Gets the white point.
Top
See Also

Reference

PdfCalibratedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource.BlackPoint Property

PdfCalibratedColorSpaceResourceBlackPoint Property

Gets the black point.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] BlackPoint { get; }
Public ReadOnly Property BlackPoint As Double()
    Get

Property Value

Type: Double
See Also

Reference

PdfCalibratedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource.WhitePoint Property

PdfCalibratedColorSpaceResourceWhitePoint Property

Gets the white point.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] WhitePoint { get; }
Public ReadOnly Property WhitePoint As Double()
    Get

Property Value

Type: Double
See Also

Reference

PdfCalibratedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource Methods

The PdfCalibratedColorSpaceResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowOnGammaOutOfRange | Throws the on gamma out of range.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCalibratedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalibratedColorSpaceResource.ThrowOnGammaOutOfRange Method

PdfCalibratedColorSpaceResourceThrowOnGammaOutOfRange Method

Throws the on gamma out of range.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected double ThrowOnGammaOutOfRange(
    double gamma,
    string propname
)
Protected Function ThrowOnGammaOutOfRange (
    gamma As Double,
    propname As String
) As Double

Parameters

gamma
Type: SystemDouble
The gamma.
propname
Type: SystemString
The propname.

Return Value

Type: Double
The gamma value passed in.
See Also

Reference

PdfCalibratedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource Class

A Calibrated color space as a resource.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalibratedColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalRgbColorSpaceResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCalRgbColorSpaceResource : PdfCalibratedColorSpaceResource
Public Class PdfCalRgbColorSpaceResource
    Inherits PdfCalibratedColorSpaceResource

The PdfCalRgbColorSpaceResource type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCalRgbColorSpaceResource | Initializes a new instance of the PdfCalRgbColorSpaceResource class.
Top
Properties
 | Name | Description
Public property | BlackPoint | Gets the black point. (Inherited from PdfCalibratedColorSpaceResource.)
Public property | BlueGamma | Gets or sets the blue gamma.
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | ComponentMatrix | Gets the component matrix.
Public property | Gammas | Gets the gammas.
Public property | GreenGamma | Gets or sets the green gamma.
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Public property | RedGamma | Gets or sets the red gamma.
Public property | WhitePoint | Gets the white point. (Inherited from PdfCalibratedColorSpaceResource.)
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowOnGammaOutOfRange | Throws the on gamma out of range. (Inherited from PdfCalibratedColorSpaceResource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource Constructor

Initializes a new instance of the PdfCalRgbColorSpaceResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCalRgbColorSpaceResource()
Public Sub New
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource Properties

The PdfCalRgbColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | BlackPoint | Gets the black point. (Inherited from PdfCalibratedColorSpaceResource.)
Public property | BlueGamma | Gets or sets the blue gamma.
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | ComponentMatrix | Gets the component matrix.
Public property | Gammas | Gets the gammas.
Public property | GreenGamma | Gets or sets the green gamma.
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Public property | RedGamma | Gets or sets the red gamma.
Public property | WhitePoint | Gets the white point. (Inherited from PdfCalibratedColorSpaceResource.)
Top
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource.BlueGamma Property

PdfCalRgbColorSpaceResourceBlueGamma Property

Gets or sets the blue gamma.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BlueGamma { get; set; }
Public Property BlueGamma As Double
    Get
    Set

Property Value

Type: Double
The blue gamma.(between 0 and 1)
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource.ComponentMatrix Property

PdfCalRgbColorSpaceResourceComponentMatrix Property

Gets the component matrix.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] ComponentMatrix { get; }
Public ReadOnly Property ComponentMatrix As Double()
    Get

Property Value

Type: Double
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource.Gammas Property

PdfCalRgbColorSpaceResourceGammas Property

Gets the gammas.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] Gammas { get; }
Public ReadOnly Property Gammas As Double()
    Get

Property Value

Type: Double
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource.GreenGamma Property

PdfCalRgbColorSpaceResourceGreenGamma Property

Gets or sets the green gamma.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GreenGamma { get; set; }
Public Property GreenGamma As Double
    Get
    Set

Property Value

Type: Double
The green gamma. (between 0 and 1)
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource.RedGamma Property

PdfCalRgbColorSpaceResourceRedGamma Property

Gets or sets the red gamma.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double RedGamma { get; set; }
Public Property RedGamma As Double
    Get
    Set

Property Value

Type: Double
The red gamma value. (between 0 and 1)
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfCalRgbColorSpaceResource Methods

The PdfCalRgbColorSpaceResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ThrowOnGammaOutOfRange | Throws the on gamma out of range. (Inherited from PdfCalibratedColorSpaceResource.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCalRgbColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager Class

Manages the pdf color space resources
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceManager PdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceManager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfColorSpaceManager : PdfResourceManager<PdfColorSpaceResource>
Public Class PdfColorSpaceManager
    Inherits PdfResourceManager(Of PdfColorSpaceResource)

The PdfColorSpaceManager type exposes the following members.

Constructors
 | Name | Description
Public method | PdfColorSpaceManager | Initializes a new instance of the PdfColorSpaceManager class.
Top
Properties
Name Description
Public property DefaultCmykColorSpace
Gets or sets the default cmyk color space.
Public property DefaultGrayColorSpace
Gets or sets the default gray color space.
Public property DefaultRgbColorSpace
Gets or sets the default RGB color space.
DeviceCmykColorSpace
Gets the name of the pre-installed device cmyk color space.
DeviceGrayColorSpace
Gets the name of the pre-installed device gray color space.
DeviceRgbColorSpace
Gets the name of the pre-installed device rgb color space.
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Protected property ResourceClass
Gets the resource class.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
Top
Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
Public method AddFromBytes
Adds from bytes.
Public method AddFromFile
Adds from file.
Public method AddFromStream
Adds from stream.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
Public method FromBytes
Froms the bytes.
Public method FromFile
Froms the file.
Public method FromStream
Froms the stream.
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Resources the match.
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager Constructor

Initializes a new instance of the PdfColorSpaceManager class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorSpaceManager()
Public Sub New
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager Properties

The PdfColorSpaceManager type exposes the following members.

Properties
Name Description
Public property DefaultCmykColorSpace
Gets or sets the default cmyk color space.
Public property DefaultGrayColorSpace
Gets or sets the default gray color space.
Public property DefaultRgbColorSpace
Gets or sets the default RGB color space.
DeviceCmykColorSpace
Gets the name of the pre-installed device cmyk color space.
DeviceGrayColorSpace
Gets the name of the pre-installed device gray color space.
DeviceRgbColorSpace
Gets the name of the pre-installed device rgb color space.
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Protected property ResourceClass
Gets the resource class.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.DefaultCmykColorSpace Property

PdfColorSpaceManagerDefaultCmykColorSpace Property

Gets or sets the default cmyk color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultCmykColorSpace { get; set; }
Public Property DefaultCmykColorSpace As String
    Get
    Set

Property Value

Type: String
The default cmyk color space.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.DefaultGrayColorSpace Property

PdfColorSpaceManagerDefaultGrayColorSpace Property

Gets or sets the default gray color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultGrayColorSpace { get; set; }
Public Property DefaultGrayColorSpace As String
    Get
    Set

Property Value

Type: String
The default gray color space.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.DefaultRgbColorSpace Property

PdfColorSpaceManagerDefaultRgbColorSpace Property

Gets or sets the default RGB color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DefaultRgbColorSpace { get; set; }
Public Property DefaultRgbColorSpace As String
    Get
    Set

Property Value

Type: String
The default RGB color space.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.DeviceCmykColorSpace Property

PdfColorSpaceManagerDeviceCmykColorSpace Property

Gets the name of the pre-installed device cmyk color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string DeviceCmykColorSpace { get; }
Public Shared ReadOnly Property DeviceCmykColorSpace As String
    Get

Property Value

Type: String
The stock device cmyk color space
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.DeviceGrayColorSpace Property

PdfColorSpaceManagerDeviceGrayColorSpace Property

Gets the name of the pre-installed device gray color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string DeviceGrayColorSpace { get; }
Public Shared ReadOnly Property DeviceGrayColorSpace As String
    Get

Property Value

Type: String
The stock device gray color space
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.DeviceRgbColorSpace Property

PdfColorSpaceManagerDeviceRgbColorSpace Property

Gets the name of the pre-installed device rgb color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string DeviceRgbColorSpace { get; }
Public Shared ReadOnly Property DeviceRgbColorSpace As String
    Get

Property Value

Type: String
The stock device rgb color space
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.ResourceClass Property

PdfColorSpaceManagerResourceClass Property

Gets the resource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfResourceClass ResourceClass { get; }
Protected Overrides ReadOnly Property ResourceClass As PdfResourceClass
    Get

Property Value

Type: PdfResourceClass
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager Methods

The PdfColorSpaceManager type exposes the following members.

Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
Public method AddFromBytes
Adds from bytes.
Public method AddFromFile
Adds from file.
Public method AddFromStream
Adds from stream.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
Public method FromBytes
Froms the bytes.
Public method FromFile
Froms the file.
Public method FromStream
Froms the stream.
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Resources the match.
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.AddFromBytes Method

PdfColorSpaceManagerAddFromBytes Method

Adds from bytes.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddFromBytes(
    byte[] data
)
Public Function AddFromBytes (
    data As Byte()
) As String

Parameters

data
Type: SystemByte
The data.

Return Value

Type: String
The new resource name.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.AddFromFile Method

PdfColorSpaceManagerAddFromFile Method

Adds from file.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddFromFile(
    string path
)
Public Function AddFromFile (
    path As String
) As String

Parameters

path
Type: SystemString
The path.

Return Value

Type: String
The new resource name.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.AddFromStream Method

PdfColorSpaceManagerAddFromStream Method

Adds from stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddFromStream(
    Stream stm,
    bool closeOnDispose
)
Public Function AddFromStream (
    stm As Stream,
    closeOnDispose As Boolean
) As String

Parameters

stm
Type: System.IOStream
The STM.
closeOnDispose
Type: SystemBoolean
if set to true [close on dispose].

Return Value

Type: String
The new resource name.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.FromBytes Method

PdfColorSpaceManagerFromBytes Method

Froms the bytes.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorSpaceResource FromBytes(
    byte[] data
)
Public Function FromBytes (
    data As Byte()
) As PdfColorSpaceResource

Parameters

data
Type: SystemByte
The data.

Return Value

Type: PdfColorSpaceResource
The new resource.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.FromFile Method

PdfColorSpaceManagerFromFile Method

Froms the file.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorSpaceResource FromFile(
    string path
)
Public Function FromFile (
    path As String
) As PdfColorSpaceResource

Parameters

path
Type: SystemString
The path.

Return Value

Type: PdfColorSpaceResource
The new resource.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.FromStream Method

PdfColorSpaceManagerFromStream Method

Froms the stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorSpaceResource FromStream(
    Stream stm,
    bool closeOnDispose
)
Public Function FromStream (
    stm As Stream,
    closeOnDispose As Boolean
) As PdfColorSpaceResource

Parameters

stm
Type: System.IOStream
The STM.
closeOnDispose
Type: SystemBoolean
if set to true [close on dispose].

Return Value

Type: PdfColorSpaceResource
The new resource.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceManager.ResourcesMatch Method

PdfColorSpaceManagerResourcesMatch Method

Resources the match.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool ResourcesMatch(
    PdfColorSpaceResource one,
    PdfColorSpaceResource two
)
Protected Overrides Function ResourcesMatch (
    one As PdfColorSpaceResource,
    two As PdfColorSpaceResource
) As Boolean

Parameters

one
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
The first resource.
two
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
The second resources.

Return Value

Type: Boolean
true if the resources match; false otherwise.
See Also

Reference

PdfColorSpaceManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceResource Class

A resource representing a color space for use in a pdf image.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfCalibratedColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfIccColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfNamedColorSpaceResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfColorSpaceResource : PdfResource
Public Class PdfColorSpaceResource
    Inherits PdfResource

The PdfColorSpaceResource type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfColorSpaceResource | Initializes a new instance of the PdfColorSpaceResource class.
Top
Properties
 | Name | Description
Public property | ColorSpaceType | Gets or sets the type of the color space.
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceResource Constructor

Initializes a new instance of the PdfColorSpaceResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfColorSpaceResource(
    PdfColorSpaceType type
)
Protected Sub New (
    type As PdfColorSpaceType
)

Parameters

type
Type: Atalasoft.PdfDoc.GeneratingPdfColorSpaceType
The type.
See Also

Reference

PdfColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceResource Properties

The PdfColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceType | Gets or sets the type of the color space.
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated.
Top
See Also

Reference

PdfColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceResource.ColorSpaceType Property

PdfColorSpaceResourceColorSpaceType Property

Gets or sets the type of the color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfColorSpaceType ColorSpaceType { get; set; }
Public Property ColorSpaceType As PdfColorSpaceType
    Get
    Set

Property Value

Type: PdfColorSpaceType
The type of the color space.
See Also

Reference

PdfColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceResource.IsCalibrated Property

PdfColorSpaceResourceIsCalibrated Property

Gets or sets a value indicating whether this instance is calibrated.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCalibrated { get; protected set; }
Public Property IsCalibrated As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if this instance is calibrated; otherwise, false.
See Also

Reference

PdfColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfColorSpaceResource Methods

The PdfColorSpaceResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource Class

A class representing an ICC complient color space for use in pdf
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfIccColorSpaceResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfIccColorSpaceResource : PdfColorSpaceResource
Public Class PdfIccColorSpaceResource
    Inherits PdfColorSpaceResource

The PdfIccColorSpaceResource type exposes the following members.

Constructors
 | Name | Description
Public method | PdfIccColorSpaceResource(Byte) | Initializes a new instance of the PdfIccColorSpaceResource class.
Public method | PdfIccColorSpaceResource(Stream, Boolean) | Initializes a new instance of the PdfIccColorSpaceResource class.
Top
Properties
 | Name | Description
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides PdfResourceDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource Constructor

Overload List
 | Name | Description
Public method | PdfIccColorSpaceResource(Byte) | Initializes a new instance of the PdfIccColorSpaceResource class.
Public method | PdfIccColorSpaceResource(Stream, Boolean) | Initializes a new instance of the PdfIccColorSpaceResource class.
Top
See Also

Reference

PdfIccColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource Constructor (Byte[])

PdfIccColorSpaceResource Constructor (Byte)

Initializes a new instance of the PdfIccColorSpaceResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfIccColorSpaceResource(
    byte[] profile
)
Public Sub New (
    profile As Byte()
)

Parameters

profile
Type: SystemByte
The profile.
See Also

Reference

PdfIccColorSpaceResource Class
PdfIccColorSpaceResource Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource Constructor (Stream, Boolean)

Initializes a new instance of the PdfIccColorSpaceResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfIccColorSpaceResource(
    Stream stm,
    bool closeOnDispose
)
Public Sub New (
    stm As Stream,
    closeOnDispose As Boolean
)

Parameters

stm
Type: System.IOStream
The STM.
closeOnDispose
Type: SystemBoolean
if set to true [close on dispose].
See Also

Reference

PdfIccColorSpaceResource Class
PdfIccColorSpaceResource Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource Properties

The PdfIccColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Top
See Also

Reference

PdfIccColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource Methods

The PdfIccColorSpaceResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides PdfResourceDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfIccColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfIccColorSpaceResource.DisposeManagedResources Method

PdfIccColorSpaceResourceDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
See Also

Reference

PdfIccColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfNamedColorSpaceResource Class

PdfNamedColorSpaceResource is an internally used class representing stock PDF "device" colorspaces
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfColorSpaceResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ColorsPdfNamedColorSpaceResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Colors
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfNamedColorSpaceResource : PdfColorSpaceResource
Public Class PdfNamedColorSpaceResource
    Inherits PdfColorSpaceResource

The PdfNamedColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfNamedColorSpaceResource Properties

The PdfNamedColorSpaceResource type exposes the following members.

Properties
 | Name | Description
Public property | ColorSpaceType | Gets or sets the type of the color space. (Inherited from PdfColorSpaceResource.)
Public property | IsCalibrated | Gets or sets a value indicating whether this instance is calibrated. (Inherited from PdfColorSpaceResource.)
Top
See Also

Reference

PdfNamedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


PdfNamedColorSpaceResource Methods

The PdfNamedColorSpaceResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfNamedColorSpaceResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Colors Namespace


Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace

Classes
 | Class | Description
Public class | PdfFontEmbeddingPolicy | When a font needs to be embedded in a PDF document, client code will be called in order to determine what action to take. Client code will return an object of PdfFontEmbeddingPolicy which will be used to enact that action.
Public class | PdfFontManager | PdfFontManager is a class that is used by the GlobalResources class to maintain and manage fonts within PDF documents. In addition to tracking which fonts are requested, PdfFontManager also handles policy decisions for embedding fonts in PDF files. The choice to embed a font or not depends upon the circumstances. For example, some fonts may publish that they are not to be embedded without permission from the creator. Since the PDF Generating toolkit can't know if client code has permission for a given font, the action to be taken for embedding should be provided by client code where possible. The PdfFontManager contains a default policy which embeds the font when the permissions are PreviewAndPrint, Unrestricted, NoSubsetting, and Editable. In all other cases it will throw an exception.
Public class | PdfFontMetrics | This class contains tools for measuring text that is to be placed in a page in a PDF document. Concrete versions of this class are constructed behind the scenes for client code. It is unlikely that client code would ever need to create or construct a concrete version of this class. FontBounds, Ascent, Descent, and Leading are measured in PDF font design units, in which glyph coordinates are laid out in a design grid that is 1000 units by 1000 units. In practice, glyphs will go outside this grid for descender and for glyphs that project to the left (swashes, for example). To convert these numbers to a particular point size, use this formula: final size = (size in PDF design units x font size in points) / 1000
Public class | PdfFontResource | PdfFontResource represents a typographic font that will be used for placing text on a page in a PDF document. This object represents the font as a whole and not a rendering of the font in a specific size. Font resources represent a single style of the font and not a family of fonts. For example, Basketball Overextended and Basketball Overextended Bold are considered to be two different fonts, even if conceptually they are in the same family.
Delegates
Delegate | Description
PdfFontEmbeddingPolicyProvider | This delegate represents a method of function that will be called when a request has come to embed a particular font within a PDF. Client code will be passed a font resource and the embedding permissions that are contained within the font's data. The permissions describe the circumstances under which the font may be embedded. It is up to client code to respect these permissions.
Enumerations
 | Enumeration | Description
Public enumeration | PdfFontEmbeddingAction | Describes an anction to take in response to a request to embed a font.
Public enumeration | PdfFontEmbeddingPermission | This enumeration describes possible permissions for embedding a TrueType font.
Public enumeration | PdfTextRenderMode | The mode with which to render text


PdfFontEmbeddingAction Enumeration

Describes an anction to take in response to a request to embed a font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfFontEmbeddingAction
Public Enumeration PdfFontEmbeddingAction
Members
Member name | Description
Embed | Embed the font within the PDF
DontEmbed | Do not embed the font within the PDF
ThrowException | Throw an exception instead of embedding the font
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPermission Enumeration

This enumeration describes possible permissions for embedding a TrueType font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfFontEmbeddingPermission
Public Enumeration PdfFontEmbeddingPermission
Members
Member name | Description
Unrestricted | The font may be embedded in a PDF with no restrictions
ForbiddenWithoutPermission | The font may not be embedded in a PDF unless client code has been granted permission from the font's creator
PreviewAndPrint | The font may be embedded in a PDF, but only for previewing and printing actions.
NoSubsetting | The font may be embedded in a PDF, but only in its entirety
Editable | The font may be embedded in a PDF and the document may be editable.
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy Class

When a font needs to be embedded in a PDF document, client code will be called in order to determine what action to take. Client code will return an object of PdfFontEmbeddingPolicy which will be used to enact that action.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontEmbeddingPolicy

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFontEmbeddingPolicy
Public Class PdfFontEmbeddingPolicy

The PdfFontEmbeddingPolicy type exposes the following members.

Constructors
Name | Description
PdfFontEmbeddingPolicy(PdfFontEmbeddingAction) | Constructs a new instance of the PdfFontEmbeddingPolicy class.
PdfFontEmbeddingPolicy(PdfFontEmbeddingAction, Exception) | Constructs a new instance of the PdfFontEmbeddingPolicy class.
Top
Properties
 | Name | Description
Public property | Action | Gets or sets the action to take on a font embedding request.
Public property | ExceptionToThrow | Gets or sets the exception to throw when action is set to PdfFontEmbeddingAction.ThrowException.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy Constructor

Overload List
Name | Description
PdfFontEmbeddingPolicy(PdfFontEmbeddingAction) | Constructs a new instance of the PdfFontEmbeddingPolicy class.
PdfFontEmbeddingPolicy(PdfFontEmbeddingAction, Exception) | Constructs a new instance of the PdfFontEmbeddingPolicy class.
Top
See Also

Reference

PdfFontEmbeddingPolicy Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy Constructor (PdfFontEmbeddingAction)

Constructs a new instance of the PdfFontEmbeddingPolicy class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontEmbeddingPolicy(
    PdfFontEmbeddingAction action
)
Public Sub New (
    action As PdfFontEmbeddingAction
)

Parameters

action
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontEmbeddingAction
The action to take on a font embedding request.
Examples
Copy
PdfFontEmbeddingPolicy policy = new PdfFontEmbeddingPolicy(PdfFontEmbeddingAction.Embed); // embed always
See Also

Reference

PdfFontEmbeddingPolicy Class
PdfFontEmbeddingPolicy Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy Constructor (PdfFontEmbeddingAction, Exception)

Constructs a new instance of the PdfFontEmbeddingPolicy class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontEmbeddingPolicy(
    PdfFontEmbeddingAction action,
    Exception exception
)
Public Sub New (
    action As PdfFontEmbeddingAction,
    exception As Exception
)

Parameters

action
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontEmbeddingAction
The action to take on a font embedding request.
exception
Type: SystemException
An exception to throw if the action is set to PdfFontEmbeddingAction.ThrowException. If exception is null, a PdfException will be thrown.
Examples
Copy
PdfFontEmbeddingPolicy policy = new PdfFontEmbeddingPolicy(PdfFontEmbeddingAction.ThrowException, new MyException("can't embed this font"));
See Also

Reference

PdfFontEmbeddingPolicy Class
PdfFontEmbeddingPolicy Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy Properties

The PdfFontEmbeddingPolicy type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets or sets the action to take on a font embedding request.
Public property | ExceptionToThrow | Gets or sets the exception to throw when action is set to PdfFontEmbeddingAction.ThrowException.
Top
See Also

Reference

PdfFontEmbeddingPolicy Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy.Action Property

PdfFontEmbeddingPolicyAction Property

Gets or sets the action to take on a font embedding request.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontEmbeddingAction Action { get; set; }
Public Property Action As PdfFontEmbeddingAction
    Get
    Set

Property Value

Type: PdfFontEmbeddingAction
The action to take.
See Also

Reference

PdfFontEmbeddingPolicy Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy.ExceptionToThrow Property

PdfFontEmbeddingPolicyExceptionToThrow Property

Gets or sets the exception to throw when action is set to PdfFontEmbeddingAction.ThrowException.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Exception ExceptionToThrow { get; set; }
Public Property ExceptionToThrow As Exception
    Get
    Set

Property Value

Type: Exception
The exception to throw. This property is intended for client code that wants to control what kind of exception should be thrown when a font can't be embedded.
See Also

Reference

PdfFontEmbeddingPolicy Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicy Methods

The PdfFontEmbeddingPolicy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFontEmbeddingPolicy Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontEmbeddingPolicyProvider Delegate

This delegate represents a method of function that will be called when a request has come to embed a particular font within a PDF. Client code will be passed a font resource and the embedding permissions that are contained within the font's data. The permissions describe the circumstances under which the font may be embedded. It is up to client code to respect these permissions.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate PdfFontEmbeddingPolicy PdfFontEmbeddingPolicyProvider(
    PdfFontResource resource,
    PdfFontEmbeddingPermission permissions
)
Public Delegate Function PdfFontEmbeddingPolicyProvider (
    resource As PdfFontResource,
    permissions As PdfFontEmbeddingPermission
) As PdfFontEmbeddingPolicy

Parameters

resource
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
The font resource that is needs an embedding policy.
permissions
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontEmbeddingPermission
The permissions for the font resource.

Return Value

Type: PdfFontEmbeddingPolicy
A new PdfFontEmbeddingPolicy describing the embedding action to take for this font.
Examples
There a number of different actions that client code could take for a request to embed a font. In general, if there is doubt as to what action to take, not embedding is the safest.
Copy
private PdfFontEmbeddingPolicy MyEmbeddingPolicyProvider(PdfFontResource resource, PdfFontEmbeddingPermission permissions)
{
    PdfFontEmbeddingAction action = PdfFontEmbeddingAction.DontEmbed;
    switch (permissions) {
    case PdfFontEmbeddingPermission.Unrestricted:
    case PdfFontEmbeddingPermission.PreviewAndPrint:
    case PdfFontEmbeddingPermission.NoSubsetting:
        action = PdfFontEmbeddingAction.Embed;
        break;
    }
    return new PdfFontEmbeddingPolicy(action);
}
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager Class

PdfFontManager is a class that is used by the GlobalResources class to maintain and manage fonts within PDF documents. In addition to tracking which fonts are requested, PdfFontManager also handles policy decisions for embedding fonts in PDF files. The choice to embed a font or not depends upon the circumstances. For example, some fonts may publish that they are not to be embedded without permission from the creator. Since the PDF Generating toolkit can't know if client code has permission for a given font, the action to be taken for embedding should be provided by client code where possible. The PdfFontManager contains a default policy which embeds the font when the permissions are PreviewAndPrint, Unrestricted, NoSubsetting, and Editable. In all other cases it will throw an exception.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceManager PdfFontResource
Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFontManager : PdfResourceManager<PdfFontResource>
Public Class PdfFontManager
    Inherits PdfResourceManager(Of PdfFontResource)

The PdfFontManager type exposes the following members.

Constructors
 | Name | Description
Public method | PdfFontManager | Constructs a new instance of the PdfFontManager class and sets its default embedding policy. A PdfFontManager is constructed for client code in the GlobalResources class. Client code will rarely if ever need to construct this class.
Top
Properties
Name Description
Public property DefaultEmbeddingPolicyProvider
Gets the default embedding policy provider for the font manager.
Public property EmbeddingPolicyProvider
Gets or sets the embedding policy provider for the font resource manager.
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Protected property ResourceClass
Gets the resource class.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
StandardType1Fonts
Gets a list of the standard Type 1 fonts.
Top
Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
AddFromFile
Adds a new font resource using a new unique name from from a path to a true type font file.
Public method AddFromFont
Adds a new font resource using a new unique name from Font object.
AddFromFontName
Adds a new font resource using a new unique named from the name of an installed font.
AddStream
Adds a new font resource using a new unique name from a stream that contains a true type font.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
FromFile
Constructs a new PdfFontResource from the path to a true type file.
Public method FromFont
Constructs a new PdfFontResource from Font object.
FromFontName
Constructs a new PdfFontResource from the name of a font.
Public method FromStream
Constructs a new PdfFontResource from a stream that contains a true type font.
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetEmbeddingPolicy
Gets the embedding policy for a particular font. This method will be called by DocumentRenderer objects or PDF writer objects. There is typically no need to call it from client code. Calling this method from client code will not affect how any given font is embedded.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsStandardFont
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Public method RebuildAvailableFontList
When new font resources are constructed by font name (instead of using the font stream directly), the font manager uses a cached list of installed fonts on the client computer to avoid having to repeatedly search the available resources. An application should call this method if it wishes to invalidate the list. This would allow an application to be aware of new fonts installed while the application is running at the cost of some performance.
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Compares two resources for equality. Default implementation returns false. Subclasses should override this method
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager Constructor

Constructs a new instance of the PdfFontManager class and sets its default embedding policy. A PdfFontManager is constructed for client code in the GlobalResources class. Client code will rarely if ever need to construct this class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontManager()
Public Sub New
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager Properties

The PdfFontManager type exposes the following members.

Properties
Name Description
Public property DefaultEmbeddingPolicyProvider
Gets the default embedding policy provider for the font manager.
Public property EmbeddingPolicyProvider
Gets or sets the embedding policy provider for the font resource manager.
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Protected property ResourceClass
Gets the resource class.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
StandardType1Fonts
Gets a list of the standard Type 1 fonts.
Top
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.DefaultEmbeddingPolicyProvider Property

PdfFontManagerDefaultEmbeddingPolicyProvider Property

Gets the default embedding policy provider for the font manager.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontEmbeddingPolicyProvider DefaultEmbeddingPolicyProvider { get; }
Public ReadOnly Property DefaultEmbeddingPolicyProvider As PdfFontEmbeddingPolicyProvider
    Get

Property Value

Type: PdfFontEmbeddingPolicyProvider
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.EmbeddingPolicyProvider Property

PdfFontManagerEmbeddingPolicyProvider Property

Gets or sets the embedding policy provider for the font resource manager.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontEmbeddingPolicyProvider EmbeddingPolicyProvider { get; set; }
Public Property EmbeddingPolicyProvider As PdfFontEmbeddingPolicyProvider
    Get
    Set

Property Value

Type: PdfFontEmbeddingPolicyProvider
The embedding policy provider that will be called to get the action to take in a request to embed a font.
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.ResourceClass Property

PdfFontManagerResourceClass Property

Gets the resource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfResourceClass ResourceClass { get; }
Protected Overrides ReadOnly Property ResourceClass As PdfResourceClass
    Get

Property Value

Type: PdfResourceClass
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.StandardType1Fonts Property

PdfFontManagerStandardType1Fonts Property

Gets a list of the standard Type 1 fonts.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static string[] StandardType1Fonts { get; }
Public Shared ReadOnly Property StandardType1Fonts As String()
    Get

Property Value

Type: String
Remarks
PDF allows access to a set of PostScript Type 1 fonts that may be used in a PDF without the need for the fonts to be embedded in the document. This allows a document to be smaller since the overhead of the font is part of the reader, not part of the document. DotPdf allows you to use these fonts and keeps a database of their metrics so they can be properly measured.
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager Methods

The PdfFontManager type exposes the following members.

Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
AddFromFile
Adds a new font resource using a new unique name from from a path to a true type font file.
Public method AddFromFont
Adds a new font resource using a new unique name from Font object.
AddFromFontName
Adds a new font resource using a new unique named from the name of an installed font.
AddStream
Adds a new font resource using a new unique name from a stream that contains a true type font.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
FromFile
Constructs a new PdfFontResource from the path to a true type file.
Public method FromFont
Constructs a new PdfFontResource from Font object.
FromFontName
Constructs a new PdfFontResource from the name of a font.
Public method FromStream
Constructs a new PdfFontResource from a stream that contains a true type font.
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetEmbeddingPolicy
Gets the embedding policy for a particular font. This method will be called by DocumentRenderer objects or PDF writer objects. There is typically no need to call it from client code. Calling this method from client code will not affect how any given font is embedded.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsStandardFont
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Public method RebuildAvailableFontList
When new font resources are constructed by font name (instead of using the font stream directly), the font manager uses a cached list of installed fonts on the client computer to avoid having to repeatedly search the available resources. An application should call this method if it wishes to invalidate the list. This would allow an application to be aware of new fonts installed while the application is running at the cost of some performance.
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Compares two resources for equality. Default implementation returns false. Subclasses should override this method
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.AddFromFile Method

PdfFontManagerAddFromFile Method

Adds a new font resource using a new unique name from from a path to a true type font file.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddFromFile(
    string path
)
Public Function AddFromFile (
    path As String
) As String

Parameters

path
Type: SystemString
The path to a true type font file.

Return Value

Type: String
A unique name that is associated with the new font resource
Examples
Copy
string fontName = gResources.Fonts.AddFromFile(pathToFontFile);
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.AddFromFont Method

PdfFontManagerAddFromFont Method

Adds a new font resource using a new unique name from Font object.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddFromFont(
    Font font
)
Public Function AddFromFont (
    font As Font
) As String

Parameters

font
Type: System.DrawingFont
Font object.

Return Value

Type: String
A unique name that is associated with the new font resource
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.AddFromFontName Method

PdfFontManagerAddFromFontName Method

Adds a new font resource using a new unique named from the name of an installed font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddFromFontName(
    string name
)
Public Function AddFromFontName (
    name As String
) As String

Parameters

name
Type: SystemString
The name of the font to add.

Return Value

Type: String
A unique name that is associated with the new font resource
Examples
Copy
string fontName = gResources.Fonts.AddFromFontName("Times New Roman Italic");
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.AddStream Method

PdfFontManagerAddStream Method

Adds a new font resource using a new unique name from a stream that contains a true type font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddStream(
    Stream stm,
    bool closeOnDispose
)
Public Function AddStream (
    stm As Stream,
    closeOnDispose As Boolean
) As String

Parameters

stm
Type: System.IOStream
The stream that contains the true type font.
closeOnDispose
Type: SystemBoolean
if set to true the stream when the resource is disposed.

Return Value

Type: String
A unique name that is associated with the new font resource
Examples
Copy
Stream myFontStream = GetFontStream();
string fontName = gResources.Fonts.AddFromStream(myFontStream, true);
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.FromFile Method

PdfFontManagerFromFile Method

Constructs a new PdfFontResource from the path to a true type file.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontResource FromFile(
    string path
)
Public Function FromFile (
    path As String
) As PdfFontResource

Parameters

path
Type: SystemString
The path to the file that contains the font.

Return Value

Type: PdfFontResource
A new PdfFontResource representing the font.
Examples
Copy
gResources.Fonts.Add("times", gResources.Fonts.FromFile(pathToTimesNewRoman));
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.FromFont Method

PdfFontManagerFromFont Method

Constructs a new PdfFontResource from Font object.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontResource FromFont(
    Font font
)
Public Function FromFont (
    font As Font
) As PdfFontResource

Parameters

font
Type: System.DrawingFont
Font object.

Return Value

Type: PdfFontResource
A new PdfFontResource representing the font.
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.FromFontName Method

PdfFontManagerFromFontName Method

Constructs a new PdfFontResource from the name of a font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontResource FromFontName(
    string name
)
Public Function FromFontName (
    name As String
) As PdfFontResource

Parameters

name
Type: SystemString
The name of an installed font.

Return Value

Type: PdfFontResource
A new PdfFontResource representing the font.
Examples
Copy
gResources.Fonts.Add("times", gResources.Fonts.FromFontName("Calibri"));
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.FromStream Method

PdfFontManagerFromStream Method

Constructs a new PdfFontResource from a stream that contains a true type font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontResource FromStream(
    Stream stm,
    bool closeOnDispose
)
Public Function FromStream (
    stm As Stream,
    closeOnDispose As Boolean
) As PdfFontResource

Parameters

stm
Type: System.IOStream
The stream that contains the font.
closeOnDispose
Type: SystemBoolean
if set to true clost the stream when the resource is disposed.

Return Value

Type: PdfFontResource
The new resource
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.GetEmbeddingPolicy Method

PdfFontManagerGetEmbeddingPolicy Method

Gets the embedding policy for a particular font. This method will be called by DocumentRenderer objects or PDF writer objects. There is typically no need to call it from client code. Calling this method from client code will not affect how any given font is embedded.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontEmbeddingPolicy GetEmbeddingPolicy(
    PdfFontResource resource,
    PdfFontEmbeddingPermission permission
)
Public Function GetEmbeddingPolicy (
    resource As PdfFontResource,
    permission As PdfFontEmbeddingPermission
) As PdfFontEmbeddingPolicy

Parameters

resource
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
The font resource that is being considered for embedding.
permission
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontEmbeddingPermission
The permission published by that font for embedding.

Return Value

Type: PdfFontEmbeddingPolicy
A new PdfFontEmbeddingPolicy represention an action to take for embedding the font.
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.IsStandardFont Method

PdfFontManagerIsStandardFont Method

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool IsStandardFont(
    string name
)
Public Shared Function IsStandardFont (
    name As String
) As Boolean

Parameters

name
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.RebuildAvailableFontList Method

PdfFontManagerRebuildAvailableFontList Method

When new font resources are constructed by font name (instead of using the font stream directly), the font manager uses a cached list of installed fonts on the client computer to avoid having to repeatedly search the available resources. An application should call this method if it wishes to invalidate the list. This would allow an application to be aware of new fonts installed while the application is running at the cost of some performance.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RebuildAvailableFontList()
Public Sub RebuildAvailableFontList
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontManager.ResourcesMatch Method

PdfFontManagerResourcesMatch Method

Compares two resources for equality. Default implementation returns false. Subclasses should override this method

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool ResourcesMatch(
    PdfFontResource one,
    PdfFontResource two
)
Protected Overrides Function ResourcesMatch (
    one As PdfFontResource,
    two As PdfFontResource
) As Boolean

Parameters

one
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
The first resource.
two
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
The second resource.

Return Value

Type: Boolean
true if the resources match, false otherwise.
See Also

Reference

PdfFontManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics Class

This class contains tools for measuring text that is to be placed in a page in a PDF document. Concrete versions of this class are constructed behind the scenes for client code. It is unlikely that client code would ever need to create or construct a concrete version of this class. FontBounds, Ascent, Descent, and Leading are measured in PDF font design units, in which glyph coordinates are laid out in a design grid that is 1000 units by 1000 units. In practice, glyphs will go outside this grid for descender and for glyphs that project to the left (swashes, for example). To convert these numbers to a particular point size, use this formula: final size = (size in PDF design units x font size in points) / 1000
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontMetrics

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class PdfFontMetrics
Public MustInherit Class PdfFontMetrics

The PdfFontMetrics type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfFontMetrics | Initializes a new instance of the PdfFontMetrics class
Top
Properties
Name | Description
Ascent | Gets the ascent of the font in PDF font design units.
Descent | Gets the descent of the font in PDF font design units. The Descent is the distance that the font extends below the baseline of the font. Descent is usually negative.
FontBounds | Gets the smallest bounding box that can surround all glyphs within the font. Units are in PDF font design units.
Leading | Gets the recommended leading for this font in PDF font design units. This should be the height of the gap between lines, not the distance between baselines of successive lines. The distance between successive lines will be Ascent - Descent + Leading.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCharMetrics | Gets the metrics for a given character using the specified transform. This method is implemented by concrete instances of PdfFontMetrics. Client code will not typically create subclasses of PdfFontMetrics.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetTextBounds(Double, String) | Gets bounding box that surrounds the text.
 | GetTextBounds(Double, String, Int32, Int32) | Gets bounding box that surrounds the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LineSpacing | Measures the line spacing for a font in a given point size.
 | MeasureText(Double, String) | Measures the given text in the provided font size in points.
 | MeasureText(Double, String, Int32, Int32) | Measures the given text in the provided font size in points.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics Constructor

Initializes a new instance of the PdfFontMetrics class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfFontMetrics()
Protected Sub New
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics Properties

The PdfFontMetrics type exposes the following members.

Properties
Name | Description
Ascent | Gets the ascent of the font in PDF font design units.
Descent | Gets the descent of the font in PDF font design units. The Descent is the distance that the font extends below the baseline of the font. Descent is usually negative.
FontBounds | Gets the smallest bounding box that can surround all glyphs within the font. Units are in PDF font design units.
Leading | Gets the recommended leading for this font in PDF font design units. This should be the height of the gap between lines, not the distance between baselines of successive lines. The distance between successive lines will be Ascent - Descent + Leading.
Top
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.Ascent Property

PdfFontMetricsAscent Property

Gets the ascent of the font in PDF font design units.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Ascent { get; protected set; }
Public Property Ascent As Double
    Get
    Protected Set

Property Value

Type: Double
The ascent of the font in PDF font design units.
Examples
Copy
double ascent = metrics.Ascent;
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.Descent Property

PdfFontMetricsDescent Property

Gets the descent of the font in PDF font design units. The Descent is the distance that the font extends below the baseline of the font. Descent is usually negative.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Descent { get; protected set; }
Public Property Descent As Double
    Get
    Protected Set

Property Value

Type: Double
The descent of the font in PDF font design units.
Examples
Copy
double descent = metrics.Descent;
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.FontBounds Property

PdfFontMetricsFontBounds Property

Gets the smallest bounding box that can surround all glyphs within the font. Units are in PDF font design units.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds FontBounds { get; protected set; }
Public Property FontBounds As PdfBounds
    Get
    Protected Set

Property Value

Type: PdfBounds
The font bounds in PDF font design units.
Examples
Copy
PdfBounds bounds = metrics.FontBounds;
double totalHeight = bounds.Height;
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.Leading Property

PdfFontMetricsLeading Property

Gets the recommended leading for this font in PDF font design units. This should be the height of the gap between lines, not the distance between baselines of successive lines. The distance between successive lines will be Ascent - Descent + Leading.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Leading { get; protected set; }
Public Property Leading As Double
    Get
    Protected Set

Property Value

Type: Double
The leading of the font in PDF font design units.
Examples
Copy
double lineSpacing = metrics.Ascent - metrics.Descent + metrics.Leading;
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics Methods

The PdfFontMetrics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCharMetrics | Gets the metrics for a given character using the specified transform. This method is implemented by concrete instances of PdfFontMetrics. Client code will not typically create subclasses of PdfFontMetrics.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetTextBounds(Double, String) | Gets bounding box that surrounds the text.
 | GetTextBounds(Double, String, Int32, Int32) | Gets bounding box that surrounds the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LineSpacing | Measures the line spacing for a font in a given point size.
 | MeasureText(Double, String) | Measures the given text in the provided font size in points.
 | MeasureText(Double, String, Int32, Int32) | Measures the given text in the provided font size in points.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.GetCharMetrics Method

PdfFontMetricsGetCharMetrics Method

Gets the metrics for a given character using the specified transform. This method is implemented by concrete instances of PdfFontMetrics. Client code will not typically create subclasses of PdfFontMetrics.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PdfPoint GetCharMetrics(
    char c,
    PdfTransform fontTransfrom
)
Protected MustOverride Function GetCharMetrics (
    c As Char,
    fontTransfrom As PdfTransform
) As PdfPoint

Parameters

c
Type: SystemChar
The character to measure.
fontTransfrom
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The font transfrom.

Return Value

Type: PdfPoint
The advance width for the given character.
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.GetTextBounds Method

PdfFontMetricsGetTextBounds Method

Overload List
Name | Description
GetTextBounds(Double, String) | Gets bounding box that surrounds the text.
GetTextBounds(Double, String, Int32, Int32) | Gets bounding box that surrounds the text.
Top
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.GetTextBounds Method (Double, String)

PdfFontMetricsGetTextBounds Method (Double, String)

Gets bounding box that surrounds the text.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds GetTextBounds(
    double pointSize,
    string text
)
Public Function GetTextBounds (
    pointSize As Double,
    text As String
) As PdfBounds

Parameters

pointSize
Type: SystemDouble
Size of the font in points.
text
Type: SystemString
The text to be measured.

Return Value

Type: PdfBounds
descent plus its ascent. Vertical writing systems are not currently supported.
Examples
Copy
PdfBounds bounds = metrics.GetTextBounds(12.0, "Striling engine");
See Also

Reference

PdfFontMetrics Class
GetTextBounds Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.GetTextBounds Method (Double, String, Int32, Int32)

PdfFontMetricsGetTextBounds Method (Double, String, Int32, Int32)

Gets bounding box that surrounds the text.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds GetTextBounds(
    double pointSize,
    string text,
    int start,
    int length
)
Public Function GetTextBounds (
    pointSize As Double,
    text As String,
    start As Integer,
    length As Integer
) As PdfBounds

Parameters

pointSize
Type: SystemDouble
Size of the font in points.
text
Type: SystemString
The text to be measured.
start
Type: SystemInt32
The start index of text to measure.
length
Type: SystemInt32
The number of characters to measure.

Return Value

Type: PdfBounds
A new PdfBounds object that represents the bounds of the text in points. X will be 0. Width will be the absolute value of the width of the string. Y will be the negative of the font's Descent. Height will be the font's descent plus its ascent. Vertical writing systems are not currently supported.
Examples
Copy
PdfBounds bounds = metrics.GetTextBounds(12.0, "laminated writing desk", 0, 9); // measure 'laminated'
See Also

Reference

PdfFontMetrics Class
GetTextBounds Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.LineSpacing Method

PdfFontMetricsLineSpacing Method

Measures the line spacing for a font in a given point size.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LineSpacing(
    double pointSize
)
Public Function LineSpacing (
    pointSize As Double
) As Double

Parameters

pointSize
Type: SystemDouble
Size of the point.

Return Value

Type: Double
The line spacing in PDF units
Remarks
This is equivalent to:
Copy
(Ascent - Descent + Leading) * pointSize / 1000.0
If Leading is less than or equal to 0, it will be replaced with 1.25 * Descent.
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.MeasureText Method

PdfFontMetricsMeasureText Method

Overload List
Name | Description
MeasureText(Double, String) | Measures the given text in the provided font size in points.
MeasureText(Double, String, Int32, Int32) | Measures the given text in the provided font size in points.
Top
See Also

Reference

PdfFontMetrics Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.MeasureText Method (Double, String)

PdfFontMetricsMeasureText Method (Double, String)

Measures the given text in the provided font size in points.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint MeasureText(
    double pointSize,
    string text
)
Public Function MeasureText (
    pointSize As Double,
    text As String
) As PdfPoint

Parameters

pointSize
Type: SystemDouble
Size of the font in points.
text
Type: SystemString
The text to be measured.

Return Value

Type: PdfPoint
The size of the text provided. In practice, this measurement represents what is known as the Advance Width of a given string. The is the amount and the direction that the text origin would be moved by placing the text. If the font represents a left to right writing system, the X value of the returned point will be set to "width" of the text and the Y value will be 0. Vertical writing systems are not currently supported.
Examples
Copy
PdfPoint size = metrics.MeasureText(12.0, "Bivalve farming");
See Also

Reference

PdfFontMetrics Class
MeasureText Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontMetrics.MeasureText Method (Double, String, Int32, Int32)

PdfFontMetricsMeasureText Method (Double, String, Int32, Int32)

Measures the given text in the provided font size in points.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PdfPoint MeasureText(
    double pointSize,
    string text,
    int start,
    int length
)
Public Overridable Function MeasureText (
    pointSize As Double,
    text As String,
    start As Integer,
    length As Integer
) As PdfPoint

Parameters

pointSize
Type: SystemDouble
Size of the font in points.
text
Type: SystemString
The text to be measured.
start
Type: SystemInt32
The start index of text to measure.
length
Type: SystemInt32
The number of characters to measure.

Return Value

Type: PdfPoint
The size of the text provided. In practice, this measurement represents what is known as the Advance Width of a given string. The is the amount and the direction that the text origin would be moved by placing the text. If the font represents a left to right writing system, the X value of the returned point will be set to "width" of the text and the Y value will be 0. Vertical writing systems are not currently supported.
Examples
Copy
PdfPoint size = metrics.MeasureText(12.0, "Alyssa P. Hacker", 10, 6); // measure 'Hacker'
bool isLeftToRight = size.Width > 0;
See Also

Reference

PdfFontMetrics Class
MeasureText Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource Class

PdfFontResource represents a typographic font that will be used for placing text on a page in a PDF document. This object represents the font as a whole and not a rendering of the font in a specific size. Font resources represent a single style of the font and not a family of fonts. For example, Basketball Overextended and Basketball Overextended Bold are considered to be two different fonts, even if conceptually they are in the same family.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFontResource : PdfResource
Public Class PdfFontResource
    Inherits PdfResource

The PdfFontResource type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfFontResource | Initializes a new instance of the PdfFontResource class.
Top
Properties
Name | Description
FontFamily | Gets the name of the font's family. For example, the font Armageddon Light would have the FontFamily "Armageddon"
FontSubFamily | Gets the font sub family name such as "Bold" or "Condensed".
Metrics | Gets the an object that can be used for measuring text in the font.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource Constructor

Initializes a new instance of the PdfFontResource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfFontResource()
Protected Sub New
See Also

Reference

PdfFontResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource Properties

The PdfFontResource type exposes the following members.

Properties
Name | Description
FontFamily | Gets the name of the font's family. For example, the font Armageddon Light would have the FontFamily "Armageddon"
FontSubFamily | Gets the font sub family name such as "Bold" or "Condensed".
Metrics | Gets the an object that can be used for measuring text in the font.
Top
See Also

Reference

PdfFontResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource.FontFamily Property

PdfFontResourceFontFamily Property

Gets the name of the font's family. For example, the font Armageddon Light would have the FontFamily "Armageddon"

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontFamily { get; protected set; }
Public Property FontFamily As String
    Get
    Protected Set

Property Value

Type: String
Examples
Copy
Console.WriteLine("Font family is " + fontResource.FontFamily);
See Also

Reference

PdfFontResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource.FontSubFamily Property

PdfFontResourceFontSubFamily Property

Gets the font sub family name such as "Bold" or "Condensed".

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontSubFamily { get; protected set; }
Public Property FontSubFamily As String
    Get
    Protected Set

Property Value

Type: String
Examples
Copy
Console.WriteLine("Font family is " + fontResource.FontSubFamily);
See Also

Reference

PdfFontResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource.Metrics Property

PdfFontResourceMetrics Property

Gets the an object that can be used for measuring text in the font.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontMetrics Metrics { get; protected set; }
Public Property Metrics As PdfFontMetrics
    Get
    Protected Set

Property Value

Type: PdfFontMetrics
Examples
Copy
PdfFontMetrics mets = fontResource.Metrics;
PdfPoint size = mets.MeasureText(12.0, "Dixon, Illinois");
See Also

Reference

PdfFontResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfFontResource Methods

The PdfFontResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFontResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


PdfTextRenderMode Enumeration

The mode with which to render text

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTextRenderMode
Public Enumeration PdfTextRenderMode
Members
Member name | Description
FillText | Fill the text with the current fill color (Default).
StrokeText | Draw the outline of the text based on the linewidth.
FillThenStrokeText | Fill the text then draw the outline based on the linewidth.
Invisible | Draw nothing
FillTextAndClip | Fill the text and set the clip region to the text
StrokeTextAndClip | Strokes the text and sets the clip region to the text
FillStrokeTextAndClip | Both fills and clips the text and sets the clip region
Clip | Sets the clip region to the text.
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Fonts Namespace


Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace

Classes
 | Class | Description
Public class | GdiImageCompressor | A compressor for Gdi Images
Public class | GdiImageCompressorBitmapImageDataProvider | The provider for bitmap image data
Public class | MemoryStreamProvider | A stream for handling images from a MemoryStream
Public class | PdfCCITTGroup4ImageCompression | The settings class for CCITT (group 4) compression
Public class | PdfCompressedImageStreamProvider | Used to decompress image streams from existing pdf into PdfImageResource
Public class | PdfDctImageCodecDetails | The settings for Dct encoded images in generated pdfs
Public class | PdfDctImageCompression | The compression settings for Dct compression
Public class | PdfFlateImageCompression | Settings for Flate Compression
Public class | PdfImageCodecDetails | A class to hold codec details
Public class | PdfImageColorSpaceInfo | PdfImageColorSpaceInfo is a class that is used to describe the color representation of an image in a PDF document. This includes the color space of the image (red, green, blue for example) as well as the number of channels in the image and an optional associated color space resource for associating calibrated colors with the image. This class is constructed for client code during the process of converting an image into an image resource and there is no reason to construct it directly.
Public class | PdfImageCompression | An object used to set the image compression used in an image resource.
Public class | PdfImageInformation | Information about a pdf image
Public class | PdfImageManager | The resource manager for images
Public class | PdfImageResource | A resource for pdf creation that is an image.
Public class | PdfJbig2ImageCompression | The Jbig2 settings for pdf images
Public class | PdfJpxImageCodecDetails | The settings for the pdf jpeg2000 codec
Public class | PdfJpxImageCompression | The settings for Jpeg2000 image compression for a PdfImageResource
Public class | PdfLzwImageCompression | The settings for Lzw compression
Public class | PdfNoneImageCompression | The settings for no compression
Public class | PdfRunLengthImageCompression | The settings for run length image compression
Public class | StoredStream | A temporary stream to store inner resources.
Public class | TempFileStreamProvider | A stream provider for temporary files
Interfaces
 | Interface | Description
Public interface | IPdfImageCompressor | An interface for compressing pdf images
Public interface | IStoredStreamProvider | An interface used for generating streams from stored locations
Delegates
 | Delegate | Description
Public delegate | PdfImageCompressionSelector | The event delegate that is called when it is time to select image compression
Enumerations
 | Enumeration | Description
Public enumeration | ImageHandlingSkill | The style of image handling to use


GdiImageCompressor Class

A compressor for Gdi Images
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesGdiImageCompressor

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class GdiImageCompressor : IPdfImageCompressor
Public Class GdiImageCompressor
    Implements IPdfImageCompressor

The GdiImageCompressor type exposes the following members.

Constructors
 | Name | Description
Public method | GdiImageCompressor | Initializes a new instance of the GdiImageCompressor class
Top
Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified o.
Public method | Compress | Compresses the specified o.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | Gets the image information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor Constructor

Initializes a new instance of the GdiImageCompressor class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GdiImageCompressor()
Public Sub New
See Also

Reference

GdiImageCompressor Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor Methods

The GdiImageCompressor type exposes the following members.

Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified o.
Public method | Compress | Compresses the specified o.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageInformation | Gets the image information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GdiImageCompressor Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.CanCompress Method

GdiImageCompressorCanCompress Method

Determines whether this instance can compress the specified o.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfImageCodec> CanCompress(
    Object o,
    ImageHandlingSkill skill
)
Public Function CanCompress (
    o As Object,
    skill As ImageHandlingSkill
) As IList(Of PdfImageCodec)

Parameters

o
Type: SystemObject
The o.
skill
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesImageHandlingSkill
The skill.

Return Value

Type: IListPdfImageCodec
A list of PdfImageCodec objects that can compress the given object.

Implements

IPdfImageCompressorCanCompress(Object, ImageHandlingSkill)
See Also

Reference

GdiImageCompressor Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.Compress Method

GdiImageCompressorCompress Method

Compresses the specified o.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressedImageStreamProvider Compress(
    Object o,
    IStoredStreamProvider streamProvider,
    PdfImageCompression compression
)
Public Function Compress (
    o As Object,
    streamProvider As IStoredStreamProvider,
    compression As PdfImageCompression
) As PdfCompressedImageStreamProvider

Parameters

o
Type: SystemObject
The o.
streamProvider
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesIStoredStreamProvider
The stream provider.
compression
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
The compression.

Return Value

Type: PdfCompressedImageStreamProvider
A stream provider representing the compressed image data.

Implements

IPdfImageCompressorCompress(Object, IStoredStreamProvider, PdfImageCompression)
See Also

Reference

GdiImageCompressor Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.GetImageInformation Method

GdiImageCompressorGetImageInformation Method

Gets the image information.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageInformation GetImageInformation(
    Object o,
    string colorSpaceResourceName
)
Public Function GetImageInformation (
    o As Object,
    colorSpaceResourceName As String
) As PdfImageInformation

Parameters

o
Type: SystemObject
The o.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.

Return Value

Type: PdfImageInformation
The image information

Implements

IPdfImageCompressorGetImageInformation(Object, String)
See Also

Reference

GdiImageCompressor Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider Class

GdiImageCompressorBitmapImageDataProvider Class

The provider for bitmap image data
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesGdiImageCompressorBitmapImageDataProvider

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BitmapImageDataProvider
Public Class BitmapImageDataProvider

The GdiImageCompressorBitmapImageDataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | GdiImageCompressorBitmapImageDataProvider(Bitmap, Boolean) | Initializes a new instance of the GdiImageCompressorBitmapImageDataProvider class.
Public method | GdiImageCompressorBitmapImageDataProvider(BitmapData, Int32) | Initializes a new instance of the GdiImageCompressorBitmapImageDataProvider class.
Top
Properties
 | Name | Description
Public property | Height | Gets or sets the height.
Public property | Width | Gets or sets the width.
Top
Methods
 | Name | Description
Public method | Begin | Begins this instance.
Public method | End | Ends this instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow | Gets the row.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


BitmapImageDataProvider Constructor

Overload List
 | Name | Description
Public method | GdiImageCompressorBitmapImageDataProvider(Bitmap, Boolean) | Initializes a new instance of the GdiImageCompressorBitmapImageDataProvider class.
Public method | GdiImageCompressorBitmapImageDataProvider(BitmapData, Int32) | Initializes a new instance of the GdiImageCompressorBitmapImageDataProvider class.
Top
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider Constructor (Bitmap, Boolean)

GdiImageCompressorBitmapImageDataProvider Constructor (Bitmap, Boolean)

Initializes a new instance of the GdiImageCompressorBitmapImageDataProvider class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapImageDataProvider(
    Bitmap bm,
    bool invert
)
Public Sub New (
    bm As Bitmap,
    invert As Boolean
)

Parameters

bm
Type: System.DrawingBitmap
The bm.
invert
Type: SystemBoolean
if set to true [invert].
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
GdiImageCompressorBitmapImageDataProvider Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider Constructor (BitmapData, Int32)

GdiImageCompressorBitmapImageDataProvider Constructor (BitmapData, Int32)

Initializes a new instance of the GdiImageCompressorBitmapImageDataProvider class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitmapImageDataProvider(
    BitmapData data,
    int width
)
Public Sub New (
    data As BitmapData,
    width As Integer
)

Parameters

data
Type: System.Drawing.ImagingBitmapData
The data.
width
Type: SystemInt32
The width.
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
GdiImageCompressorBitmapImageDataProvider Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


BitmapImageDataProvider Properties

The GdiImageCompressorBitmapImageDataProvider type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets or sets the height.
Public property | Width | Gets or sets the width.
Top
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider.Height Property

GdiImageCompressorBitmapImageDataProviderHeight Property

Gets or sets the height.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set

Property Value

Type: Int32
The height.
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider.Width Property

GdiImageCompressorBitmapImageDataProviderWidth Property

Gets or sets the width.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set

Property Value

Type: Int32
The width.
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


BitmapImageDataProvider Methods

The GdiImageCompressorBitmapImageDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | Begin | Begins this instance.
Public method | End | Ends this instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow | Gets the row.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider.Begin Method

GdiImageCompressorBitmapImageDataProviderBegin Method

Begins this instance.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Begin()
Public Sub Begin
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider.End Method

GdiImageCompressorBitmapImageDataProviderEnd Method

Ends this instance.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


GdiImageCompressor.BitmapImageDataProvider.GetRow Method

GdiImageCompressorBitmapImageDataProviderGetRow Method

Gets the row.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void GetRow(
    int y,
    byte[] destBuffer,
    int destOffset,
    int totalBytes
)
Public Sub GetRow (
    y As Integer,
    destBuffer As Byte(),
    destOffset As Integer,
    totalBytes As Integer
)

Parameters

y
Type: SystemInt32
The y.
destBuffer
Type: SystemByte
The dest buffer.
destOffset
Type: SystemInt32
The dest offset.
totalBytes
Type: SystemInt32
The total bytes.
See Also

Reference

GdiImageCompressorBitmapImageDataProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


ImageHandlingSkill Enumeration

The style of image handling to use

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ImageHandlingSkill
Public Enumeration ImageHandlingSkill
Members
Member name | Description
Perfect | Do not change information at all
IncreaseInformation | Only increase information
ReduceInformation | Only reduce information
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IPdfImageCompressor Interface

An interface for compressing pdf images

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfImageCompressor
Public Interface IPdfImageCompressor

The IPdfImageCompressor type exposes the following members.

Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified o.
Public method | Compress | Compresses the specified o.
Public method | GetImageInformation | Gets the image information.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IPdfImageCompressor Methods

The IPdfImageCompressor type exposes the following members.

Methods
 | Name | Description
Public method | CanCompress | Determines whether this instance can compress the specified o.
Public method | Compress | Compresses the specified o.
Public method | GetImageInformation | Gets the image information.
Top
See Also

Reference

IPdfImageCompressor Interface
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IPdfImageCompressor.CanCompress Method

IPdfImageCompressorCanCompress Method

Determines whether this instance can compress the specified o.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
IList<PdfImageCodec> CanCompress(
    Object o,
    ImageHandlingSkill skill
)
Function CanCompress (
    o As Object,
    skill As ImageHandlingSkill
) As IList(Of PdfImageCodec)

Parameters

o
Type: SystemObject
The o.
skill
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesImageHandlingSkill
The skill.

Return Value

Type: IListPdfImageCodec
A list of PdfImageCodec objects that can compress the given image object
See Also

Reference

IPdfImageCompressor Interface
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IPdfImageCompressor.Compress Method

IPdfImageCompressorCompress Method

Compresses the specified o.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
PdfCompressedImageStreamProvider Compress(
    Object o,
    IStoredStreamProvider streamProvider,
    PdfImageCompression compression
)
Function Compress (
    o As Object,
    streamProvider As IStoredStreamProvider,
    compression As PdfImageCompression
) As PdfCompressedImageStreamProvider

Parameters

o
Type: SystemObject
The o.
streamProvider
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesIStoredStreamProvider
The stream provider.
compression
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
The compression.

Return Value

Type: PdfCompressedImageStreamProvider
A stream provider representing the compressed image data.
See Also

Reference

IPdfImageCompressor Interface
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IPdfImageCompressor.GetImageInformation Method

IPdfImageCompressorGetImageInformation Method

Gets the image information.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
PdfImageInformation GetImageInformation(
    Object o,
    string colorSpaceResourceName
)
Function GetImageInformation (
    o As Object,
    colorSpaceResourceName As String
) As PdfImageInformation

Parameters

o
Type: SystemObject
The o.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.

Return Value

Type: PdfImageInformation
The image information
See Also

Reference

IPdfImageCompressor Interface
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IStoredStreamProvider Interface

An interface used for generating streams from stored locations

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IStoredStreamProvider
Public Interface IStoredStreamProvider

The IStoredStreamProvider type exposes the following members.

Methods
 | Name | Description
Public method | MakeStream | Makes the required stream.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IStoredStreamProvider Methods

The IStoredStreamProvider type exposes the following members.

Methods
 | Name | Description
Public method | MakeStream | Makes the required stream.
Top
See Also

Reference

IStoredStreamProvider Interface
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


IStoredStreamProvider.MakeStream Method

IStoredStreamProviderMakeStream Method

Makes the required stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
StoredStream MakeStream()
Function MakeStream As StoredStream

Return Value

Type: StoredStream
A StoredStream object that can be used for getting a data stream.
See Also

Reference

IStoredStreamProvider Interface
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


MemoryStreamProvider Class

A stream for handling images from a MemoryStream
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesMemoryStreamProvider

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class MemoryStreamProvider : IStoredStreamProvider
Public Class MemoryStreamProvider
    Implements IStoredStreamProvider

The MemoryStreamProvider type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryStreamProvider | Initializes a new instance of the MemoryStreamProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeStream | Makes the required stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


MemoryStreamProvider Constructor

Initializes a new instance of the MemoryStreamProvider class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public MemoryStreamProvider()
Public Sub New
See Also

Reference

MemoryStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


MemoryStreamProvider Methods

The MemoryStreamProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeStream | Makes the required stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MemoryStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


MemoryStreamProvider.MakeStream Method

MemoryStreamProviderMakeStream Method

Makes the required stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StoredStream MakeStream()
Public Function MakeStream As StoredStream

Return Value

Type: StoredStream
A StoredStream object that can be used for getting a data stream.

Implements

IStoredStreamProviderMakeStream
See Also

Reference

MemoryStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCCITTGroup4ImageCompression Class

The settings class for CCITT (group 4) compression
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfCCITTGroup4ImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCCITTGroup4ImageCompression : PdfImageCompression
Public Class PdfCCITTGroup4ImageCompression
    Inherits PdfImageCompression

The PdfCCITTGroup4ImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCCITTGroup4ImageCompression | Initializes a new instance of the PdfCCITTGroup4ImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCCITTGroup4ImageCompression Constructor

Initializes a new instance of the PdfCCITTGroup4ImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCCITTGroup4ImageCompression()
Public Sub New
See Also

Reference

PdfCCITTGroup4ImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCCITTGroup4ImageCompression Properties

The PdfCCITTGroup4ImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfCCITTGroup4ImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCCITTGroup4ImageCompression Methods

The PdfCCITTGroup4ImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCCITTGroup4ImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider Class

Used to decompress image streams from existing pdf into PdfImageResource
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfCompressedImageStreamProvider

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfCompressedImageStreamProvider : IDisposable
Public Class PdfCompressedImageStreamProvider
    Implements IDisposable

The PdfCompressedImageStreamProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCompressedImageStreamProvider(StoredStream, StoredStream) | Initializes a new instance of the PdfCompressedImageStreamProvider class.
Public method | PdfCompressedImageStreamProvider(StoredStream, StoredStream, Boolean) | Initializes a new instance of the PdfCompressedImageStreamProvider class.
Top
Properties
 | Name | Description
Public property | HasImage | Gets a value indicating whether this instance has image.
Public property | HasMask | Gets a value indicating whether this instance has mask.
Public property | IsSoftMask | Gets a value indicating whether this instance is soft mask.
Top
Methods
 | Name | Description
Public method | CloseImageStream | Closes the image stream.
Public method | CloseMaskStream | Closes the mask stream.
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfCompressedImageStreamProvider is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenImageStream | Opens the image stream.
Public method | OpenMaskStream | Opens the mask stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider Constructor

Overload List
 | Name | Description
Public method | PdfCompressedImageStreamProvider(StoredStream, StoredStream) | Initializes a new instance of the PdfCompressedImageStreamProvider class.
Public method | PdfCompressedImageStreamProvider(StoredStream, StoredStream, Boolean) | Initializes a new instance of the PdfCompressedImageStreamProvider class.
Top
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider Constructor (StoredStream, StoredStream)

Initializes a new instance of the PdfCompressedImageStreamProvider class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressedImageStreamProvider(
    StoredStream imageStream,
    StoredStream maskStream
)
Public Sub New (
    imageStream As StoredStream,
    maskStream As StoredStream
)

Parameters

imageStream
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesStoredStream
The image stream.
maskStream
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesStoredStream
The mask stream.
See Also

Reference

PdfCompressedImageStreamProvider Class
PdfCompressedImageStreamProvider Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider Constructor (StoredStream, StoredStream, Boolean)

Initializes a new instance of the PdfCompressedImageStreamProvider class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressedImageStreamProvider(
    StoredStream imageStream,
    StoredStream maskStream,
    bool isSoftMask
)
Public Sub New (
    imageStream As StoredStream,
    maskStream As StoredStream,
    isSoftMask As Boolean
)

Parameters

imageStream
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesStoredStream
The image stream.
maskStream
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesStoredStream
The mask stream.
isSoftMask
Type: SystemBoolean
if set to true [is soft mask].
See Also

Reference

PdfCompressedImageStreamProvider Class
PdfCompressedImageStreamProvider Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider Properties

The PdfCompressedImageStreamProvider type exposes the following members.

Properties
 | Name | Description
Public property | HasImage | Gets a value indicating whether this instance has image.
Public property | HasMask | Gets a value indicating whether this instance has mask.
Public property | IsSoftMask | Gets a value indicating whether this instance is soft mask.
Top
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.HasImage Property

PdfCompressedImageStreamProviderHasImage Property

Gets a value indicating whether this instance has image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasImage { get; }
Public ReadOnly Property HasImage As Boolean
    Get

Property Value

Type: Boolean
true if this instance has image; otherwise, false.
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.HasMask Property

PdfCompressedImageStreamProviderHasMask Property

Gets a value indicating whether this instance has mask.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasMask { get; }
Public ReadOnly Property HasMask As Boolean
    Get

Property Value

Type: Boolean
true if this instance has mask; otherwise, false.
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.IsSoftMask Property

PdfCompressedImageStreamProviderIsSoftMask Property

Gets a value indicating whether this instance is soft mask.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSoftMask { get; }
Public ReadOnly Property IsSoftMask As Boolean
    Get

Property Value

Type: Boolean
true if this instance is soft mask; otherwise, false.
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider Methods

The PdfCompressedImageStreamProvider type exposes the following members.

Methods
 | Name | Description
Public method | CloseImageStream | Closes the image stream.
Public method | CloseMaskStream | Closes the mask stream.
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfCompressedImageStreamProvider is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenImageStream | Opens the image stream.
Public method | OpenMaskStream | Opens the mask stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.CloseImageStream Method

PdfCompressedImageStreamProviderCloseImageStream Method

Closes the image stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CloseImageStream(
    Stream stm
)
Public Sub CloseImageStream (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
The STM.
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.CloseMaskStream Method

PdfCompressedImageStreamProviderCloseMaskStream Method

Closes the mask stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CloseMaskStream(
    Stream stm
)
Public Sub CloseMaskStream (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
The STM.
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.Dispose Method

PdfCompressedImageStreamProviderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Top
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.Dispose Method

PdfCompressedImageStreamProviderDispose Method

Disposes the resource.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PdfCompressedImageStreamProvider Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.Dispose Method (Boolean)

PdfCompressedImageStreamProviderDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PdfCompressedImageStreamProvider Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.DisposeManagedResources Method

PdfCompressedImageStreamProviderDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.DisposeUnmanagedResources Method

PdfCompressedImageStreamProviderDisposeUnmanagedResources Method

Disposes the unmanaged resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.Finalize Method

PdfCompressedImageStreamProviderFinalize Method

Releases unmanaged resources and performs other cleanup operations before the PdfCompressedImageStreamProvider is reclaimed by garbage collection.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.OpenImageStream Method

PdfCompressedImageStreamProviderOpenImageStream Method

Opens the image stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream OpenImageStream()
Public Function OpenImageStream As Stream

Return Value

Type: Stream
A stream of image data
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfCompressedImageStreamProvider.OpenMaskStream Method

PdfCompressedImageStreamProviderOpenMaskStream Method

Opens the mask stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream OpenMaskStream()
Public Function OpenMaskStream As Stream

Return Value

Type: Stream
A stream of mask image data
See Also

Reference

PdfCompressedImageStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCodecDetails Class

The settings for Dct encoded images in generated pdfs
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCodecDetails
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfDctImageCodecDetails

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDctImageCodecDetails : PdfImageCodecDetails
Public Class PdfDctImageCodecDetails
    Inherits PdfImageCodecDetails

The PdfDctImageCodecDetails type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDctImageCodecDetails | Initializes a new instance of the PdfDctImageCodecDetails class.
Top
Properties
 | Name | Description
Public property | Quality | Gets the quality.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCodecDetails Constructor

Initializes a new instance of the PdfDctImageCodecDetails class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDctImageCodecDetails(
    int quality
)
Public Sub New (
    quality As Integer
)

Parameters

quality
Type: SystemInt32
The quality.
See Also

Reference

PdfDctImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCodecDetails Properties

The PdfDctImageCodecDetails type exposes the following members.

Properties
 | Name | Description
Public property | Quality | Gets the quality.
Top
See Also

Reference

PdfDctImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCodecDetails.Quality Property

PdfDctImageCodecDetailsQuality Property

Gets the quality.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Quality { get; }
Public ReadOnly Property Quality As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfDctImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCodecDetails Methods

The PdfDctImageCodecDetails type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDctImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression Class

The compression settings for Dct compression
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfDctImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDctImageCompression : PdfImageCompression
Public Class PdfDctImageCompression
    Inherits PdfImageCompression

The PdfDctImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDctImageCompression | Initializes a new instance of the PdfDctImageCompression class.
Public method | PdfDctImageCompression(Int32) | Initializes a new instance of the PdfDctImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
 | DefaultQuality | Gets the default quality.
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression Constructor

Overload List
 | Name | Description
Public method | PdfDctImageCompression | Initializes a new instance of the PdfDctImageCompression class.
Public method | PdfDctImageCompression(Int32) | Initializes a new instance of the PdfDctImageCompression class.
Top
See Also

Reference

PdfDctImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression Constructor

Initializes a new instance of the PdfDctImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDctImageCompression()
Public Sub New
See Also

Reference

PdfDctImageCompression Class
PdfDctImageCompression Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression Constructor (Int32)

Initializes a new instance of the PdfDctImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDctImageCompression(
    int quality
)
Public Sub New (
    quality As Integer
)

Parameters

quality
Type: SystemInt32
The quality.
See Also

Reference

PdfDctImageCompression Class
PdfDctImageCompression Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression Properties

The PdfDctImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
 | DefaultQuality | Gets the default quality.
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfDctImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression.DefaultQuality Property

PdfDctImageCompressionDefaultQuality Property

Gets the default quality.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static int DefaultQuality { get; }
Public Shared ReadOnly Property DefaultQuality As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfDctImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfDctImageCompression Methods

The PdfDctImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfDctImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfFlateImageCompression Class

Settings for Flate Compression
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfFlateImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFlateImageCompression : PdfImageCompression
Public Class PdfFlateImageCompression
    Inherits PdfImageCompression

The PdfFlateImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfFlateImageCompression | Initializes a new instance of the PdfFlateImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfFlateImageCompression Constructor

Initializes a new instance of the PdfFlateImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFlateImageCompression()
Public Sub New
See Also

Reference

PdfFlateImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfFlateImageCompression Properties

The PdfFlateImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfFlateImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfFlateImageCompression Methods

The PdfFlateImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFlateImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCodecDetails Class

A class to hold codec details
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCodecDetails
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfDctImageCodecDetails
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfJpxImageCodecDetails

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageCodecDetails
Public Class PdfImageCodecDetails

The PdfImageCodecDetails type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageCodecDetails | Initializes a new instance of the PdfImageCodecDetails class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCodecDetails Constructor

Initializes a new instance of the PdfImageCodecDetails class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageCodecDetails()
Public Sub New
See Also

Reference

PdfImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCodecDetails Methods

The PdfImageCodecDetails type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Class

PdfImageColorSpaceInfo is a class that is used to describe the color representation of an image in a PDF document. This includes the color space of the image (red, green, blue for example) as well as the number of channels in the image and an optional associated color space resource for associating calibrated colors with the image. This class is constructed for client code during the process of converting an image into an image resource and there is no reason to construct it directly.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageColorSpaceInfo

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageColorSpaceInfo
Public Class PdfImageColorSpaceInfo

The PdfImageColorSpaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageColorSpaceInfo(PdfImageColorSpace) | Initializes a new instance of the PdfImageColorSpaceInfo class.
Public method | PdfImageColorSpaceInfo(PdfImageColorSpace, String) | Initializes a new instance of the PdfImageColorSpaceInfo class.
Public method | PdfImageColorSpaceInfo(PdfImageColorSpace, String, IListIPdfColor) | Initializes a new instance of the PdfImageColorSpaceInfo class.
Top
Properties
 | Name | Description
Public property | Channels | Gets the channels.
Public property | ColorSpace | Gets the color space.
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource.
Public property | Palette | Gets the palette.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Constructor

Overload List
 | Name | Description
Public method | PdfImageColorSpaceInfo(PdfImageColorSpace) | Initializes a new instance of the PdfImageColorSpaceInfo class.
Public method | PdfImageColorSpaceInfo(PdfImageColorSpace, String) | Initializes a new instance of the PdfImageColorSpaceInfo class.
Public method | PdfImageColorSpaceInfo(PdfImageColorSpace, String, IListIPdfColor) | Initializes a new instance of the PdfImageColorSpaceInfo class.
Top
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Constructor (PdfImageColorSpace)

Initializes a new instance of the PdfImageColorSpaceInfo class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageColorSpaceInfo(
    PdfImageColorSpace space
)
Public Sub New (
    space As PdfImageColorSpace
)

Parameters

space
Type: Atalasoft.PdfDocPdfImageColorSpace
The space.
See Also

Reference

PdfImageColorSpaceInfo Class
PdfImageColorSpaceInfo Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Constructor (PdfImageColorSpace, String)

Initializes a new instance of the PdfImageColorSpaceInfo class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageColorSpaceInfo(
    PdfImageColorSpace space,
    string colorSpaceResource
)
Public Sub New (
    space As PdfImageColorSpace,
    colorSpaceResource As String
)

Parameters

space
Type: Atalasoft.PdfDocPdfImageColorSpace
The space.
colorSpaceResource
Type: SystemString
The color space resource.
See Also

Reference

PdfImageColorSpaceInfo Class
PdfImageColorSpaceInfo Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Constructor (PdfImageColorSpace, String, IList(IPdfColor))

PdfImageColorSpaceInfo Constructor (PdfImageColorSpace, String, IListIPdfColor)

Initializes a new instance of the PdfImageColorSpaceInfo class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageColorSpaceInfo(
    PdfImageColorSpace space,
    string colorSpaceResource,
    IList<IPdfColor> palette
)
Public Sub New (
    space As PdfImageColorSpace,
    colorSpaceResource As String,
    palette As IList(Of IPdfColor)
)

Parameters

space
Type: Atalasoft.PdfDocPdfImageColorSpace
The space.
colorSpaceResource
Type: SystemString
The color space resource.
palette
Type: System.Collections.GenericIListIPdfColor
The palette.
See Also

Reference

PdfImageColorSpaceInfo Class
PdfImageColorSpaceInfo Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Properties

The PdfImageColorSpaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Gets the channels.
Public property | ColorSpace | Gets the color space.
Public property | ColorSpaceResourceName | Gets or sets the name of the color space resource.
Public property | Palette | Gets the palette.
Top
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo.Channels Property

PdfImageColorSpaceInfoChannels Property

Gets the channels.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channels { get; }
Public ReadOnly Property Channels As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo.ColorSpace Property

PdfImageColorSpaceInfoColorSpace Property

Gets the color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageColorSpace ColorSpace { get; }
Public ReadOnly Property ColorSpace As PdfImageColorSpace
    Get

Property Value

Type: PdfImageColorSpace
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo.ColorSpaceResourceName Property

PdfImageColorSpaceInfoColorSpaceResourceName Property

Gets or sets the name of the color space resource.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ColorSpaceResourceName { get; set; }
Public Property ColorSpaceResourceName As String
    Get
    Set

Property Value

Type: String
The name of the color space resource.
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo.Palette Property

PdfImageColorSpaceInfoPalette Property

Gets the palette.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<IPdfColor> Palette { get; }
Public ReadOnly Property Palette As IList(Of IPdfColor)
    Get

Property Value

Type: IListIPdfColor
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageColorSpaceInfo Methods

The PdfImageColorSpaceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageColorSpaceInfo Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCompression Class

An object used to set the image compression used in an image resource.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
More...

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageCompression
Public Class PdfImageCompression

The PdfImageCompression type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfImageCompression | Initializes a new instance of the PdfImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec.
Public property | Details | Gets the details.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfCCITTGroup4ImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfDctImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfFlateImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfJbig2ImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfJpxImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfLzwImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfNoneImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfRunLengthImageCompression


PdfImageCompression Constructor

Initializes a new instance of the PdfImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfImageCompression(
    PdfImageCodec codec,
    PdfImageCodecDetails details
)
Protected Sub New (
    codec As PdfImageCodec,
    details As PdfImageCodecDetails
)

Parameters

codec
Type: Atalasoft.PdfDocPdfImageCodec
The codec.
details
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCodecDetails
The details.
See Also

Reference

PdfImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCompression Properties

The PdfImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec.
Public property | Details | Gets the details.
Top
See Also

Reference

PdfImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCompression.Codec Property

PdfImageCompressionCodec Property

Gets the codec.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageCodec Codec { get; }
Public ReadOnly Property Codec As PdfImageCodec
    Get

Property Value

Type: PdfImageCodec
See Also

Reference

PdfImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCompression.Details Property

PdfImageCompressionDetails Property

Gets the details.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageCodecDetails Details { get; }
Public ReadOnly Property Details As PdfImageCodecDetails
    Get

Property Value

Type: PdfImageCodecDetails
See Also

Reference

PdfImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCompression Methods

The PdfImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageCompressionSelector Delegate

The event delegate that is called when it is time to select image compression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate PdfImageCompression PdfImageCompressionSelector(
    IList<PdfImageCodec> codecs,
    PdfImageInformation info
)
Public Delegate Function PdfImageCompressionSelector (
    codecs As IList(Of PdfImageCodec),
    info As PdfImageInformation
) As PdfImageCompression

Parameters

codecs
Type: System.Collections.GenericIListPdfImageCodec
The codecs.
info
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageInformation
The info.

Return Value

Type: PdfImageCompression
A delegate that can select an appropriate image compression.
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation Class

Information about a pdf image
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageInformation

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageInformation
Public Class PdfImageInformation

The PdfImageInformation type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageInformation | Initializes a new instance of the PdfImageInformation class.
Top
Properties
 | Name | Description
Public property | BitsPerChannel | Gets the bits per channel.
Public property | Channels | Gets the channels.
Public property | ColorSpace | Gets the color space.
Public property | Compression | Gets the compression.
Public property | Height | Gets the height.
Public property | Width | Gets the width.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation Constructor

Initializes a new instance of the PdfImageInformation class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageInformation(
    int width,
    int height,
    int channels,
    int bitsPerChannel,
    PdfImageCompression compression,
    PdfImageColorSpaceInfo colorSpace
)
Public Sub New (
    width As Integer,
    height As Integer,
    channels As Integer,
    bitsPerChannel As Integer,
    compression As PdfImageCompression,
    colorSpace As PdfImageColorSpaceInfo
)

Parameters

width
Type: SystemInt32
The width.
height
Type: SystemInt32
The height.
channels
Type: SystemInt32
The channels.
bitsPerChannel
Type: SystemInt32
The bits per channel.
compression
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
The compression.
colorSpace
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageColorSpaceInfo
The color space.
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation Properties

The PdfImageInformation type exposes the following members.

Properties
 | Name | Description
Public property | BitsPerChannel | Gets the bits per channel.
Public property | Channels | Gets the channels.
Public property | ColorSpace | Gets the color space.
Public property | Compression | Gets the compression.
Public property | Height | Gets the height.
Public property | Width | Gets the width.
Top
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation.BitsPerChannel Property

PdfImageInformationBitsPerChannel Property

Gets the bits per channel.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BitsPerChannel { get; }
Public ReadOnly Property BitsPerChannel As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation.Channels Property

PdfImageInformationChannels Property

Gets the channels.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Channels { get; }
Public ReadOnly Property Channels As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation.ColorSpace Property

PdfImageInformationColorSpace Property

Gets the color space.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageColorSpaceInfo ColorSpace { get; }
Public ReadOnly Property ColorSpace As PdfImageColorSpaceInfo
    Get

Property Value

Type: PdfImageColorSpaceInfo
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation.Compression Property

PdfImageInformationCompression Property

Gets the compression.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageCompression Compression { get; }
Public ReadOnly Property Compression As PdfImageCompression
    Get

Property Value

Type: PdfImageCompression
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation.Height Property

PdfImageInformationHeight Property

Gets the height.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation.Width Property

PdfImageInformationWidth Property

Gets the width.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageInformation Methods

The PdfImageInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageInformation Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager Class

The resource manager for images
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceManager PdfImageResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageManager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageManager : PdfResourceManager<PdfImageResource>
Public Class PdfImageManager
    Inherits PdfResourceManager(Of PdfImageResource)

The PdfImageManager type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageManager | Initializes a new instance of the PdfImageManager class.
Top
Properties
Name Description
Public property CompressionSelector
Gets or sets the compression selector.
Public property Compressors
Gets the compressors.
Public property DctQuality
Gets or sets the DCT quality.
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Public property JpxQuality
Gets or sets the JPX quality.
Protected property ResourceClass
Gets the resource class.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
Public property StreamProvider
Gets or sets the stream provider.
Top
Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
Public method AddImage(Object)
Adds the image.
Public method AddImage(Object, String)
Adds the image.
Public method AddImage(String, Object)
Adds the image.
Public method AddImage(String, Object, String)
Adds the image.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
Public method FromImage(Object)
Froms the image.
Public method FromImage(Object, String)
Froms the image.
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Compares two PDF Image resources for equality.
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager Constructor

Initializes a new instance of the PdfImageManager class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageManager()
Public Sub New
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager Properties

The PdfImageManager type exposes the following members.

Properties
Name Description
Public property CompressionSelector
Gets or sets the compression selector.
Public property Compressors
Gets the compressors.
Public property DctQuality
Gets or sets the DCT quality.
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Public property JpxQuality
Gets or sets the JPX quality.
Protected property ResourceClass
Gets the resource class.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
Public property StreamProvider
Gets or sets the stream provider.
Top
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.CompressionSelector Property

PdfImageManagerCompressionSelector Property

Gets or sets the compression selector.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageCompressionSelector CompressionSelector { get; set; }
Public Property CompressionSelector As PdfImageCompressionSelector
    Get
    Set

Property Value

Type: PdfImageCompressionSelector
The compression selector.
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.Compressors Property

PdfImageManagerCompressors Property

Gets the compressors.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<IPdfImageCompressor> Compressors { get; }
Public ReadOnly Property Compressors As IList(Of IPdfImageCompressor)
    Get

Property Value

Type: IListIPdfImageCompressor
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.DctQuality Property

PdfImageManagerDctQuality Property

Gets or sets the DCT quality.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int DctQuality { get; set; }
Public Property DctQuality As Integer
    Get
    Set

Property Value

Type: Int32
The DCT quality.
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.JpxQuality Property

PdfImageManagerJpxQuality Property

Gets or sets the JPX quality.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double JpxQuality { get; set; }
Public Property JpxQuality As Double
    Get
    Set

Property Value

Type: Double
The JPX quality.
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.ResourceClass Property

PdfImageManagerResourceClass Property

Gets the resource class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfResourceClass ResourceClass { get; }
Protected Overrides ReadOnly Property ResourceClass As PdfResourceClass
    Get

Property Value

Type: PdfResourceClass
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.StreamProvider Property

PdfImageManagerStreamProvider Property

Gets or sets the stream provider.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IStoredStreamProvider StreamProvider { get; set; }
Public Property StreamProvider As IStoredStreamProvider
    Get
    Set

Property Value

Type: IStoredStreamProvider
The stream provider.
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager Methods

The PdfImageManager type exposes the following members.

Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
Public method AddImage(Object)
Adds the image.
Public method AddImage(Object, String)
Adds the image.
Public method AddImage(String, Object)
Adds the image.
Public method AddImage(String, Object, String)
Adds the image.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
Public method FromImage(Object)
Froms the image.
Public method FromImage(Object, String)
Froms the image.
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Compares two PDF Image resources for equality.
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.AddImage Method

PdfImageManagerAddImage Method

Overload List
 | Name | Description
Public method | AddImage(Object) | Adds the image.
Public method | AddImage(Object, String) | Adds the image.
Public method | AddImage(String, Object) | Adds the image.
Public method | AddImage(String, Object, String) | Adds the image.
Top
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.AddImage Method (Object)

PdfImageManagerAddImage Method (Object)

Adds the image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddImage(
    Object o
)
Public Function AddImage (
    o As Object
) As String

Parameters

o
Type: SystemObject
The o.

Return Value

Type: String
The name of the new resource
See Also

Reference

PdfImageManager Class
AddImage Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.AddImage Method (Object, String)

PdfImageManagerAddImage Method (Object, String)

Adds the image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string AddImage(
    Object o,
    string colorSpaceResourceName
)
Public Function AddImage (
    o As Object,
    colorSpaceResourceName As String
) As String

Parameters

o
Type: SystemObject
The o.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.

Return Value

Type: String
The name of the new resource.
See Also

Reference

PdfImageManager Class
AddImage Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.AddImage Method (String, Object)

PdfImageManagerAddImage Method (String, Object)

Adds the image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddImage(
    string name,
    Object o
)
Public Sub AddImage (
    name As String,
    o As Object
)

Parameters

name
Type: SystemString
The name.
o
Type: SystemObject
The o.
See Also

Reference

PdfImageManager Class
AddImage Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.AddImage Method (String, Object, String)

PdfImageManagerAddImage Method (String, Object, String)

Adds the image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddImage(
    string name,
    Object o,
    string colorSpaceResourceName
)
Public Sub AddImage (
    name As String,
    o As Object,
    colorSpaceResourceName As String
)

Parameters

name
Type: SystemString
The name.
o
Type: SystemObject
The o.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.
See Also

Reference

PdfImageManager Class
AddImage Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.FromImage Method

PdfImageManagerFromImage Method

Overload List
 | Name | Description
Public method | FromImage(Object) | Froms the image.
Public method | FromImage(Object, String) | Froms the image.
Top
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.FromImage Method (Object)

PdfImageManagerFromImage Method (Object)

Froms the image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageResource FromImage(
    Object o
)
Public Function FromImage (
    o As Object
) As PdfImageResource

Parameters

o
Type: SystemObject
The o.

Return Value

Type: PdfImageResource
The new image resource
See Also

Reference

PdfImageManager Class
FromImage Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.FromImage Method (Object, String)

PdfImageManagerFromImage Method (Object, String)

Froms the image.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageResource FromImage(
    Object o,
    string colorSpaceResourceName
)
Public Function FromImage (
    o As Object,
    colorSpaceResourceName As String
) As PdfImageResource

Parameters

o
Type: SystemObject
The o.
colorSpaceResourceName
Type: SystemString
Name of the color space resource.

Return Value

Type: PdfImageResource
The new image resource
See Also

Reference

PdfImageManager Class
FromImage Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageManager.ResourcesMatch Method

PdfImageManagerResourcesMatch Method

Compares two PDF Image resources for equality.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool ResourcesMatch(
    PdfImageResource one,
    PdfImageResource two
)
Protected Overrides Function ResourcesMatch (
    one As PdfImageResource,
    two As PdfImageResource
) As Boolean

Parameters

one
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageResource
The first image resource.
two
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageResource
The second image resource.

Return Value

Type: Boolean
true if the resources match, false otherwise.
See Also

Reference

PdfImageManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageResource Class

A resource for pdf creation that is an image.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfImageResource : PdfResource
Public Class PdfImageResource
    Inherits PdfResource

The PdfImageResource type exposes the following members.

Properties
 | Name | Description
Public property | ImageInfo | Gets the image info.
Public property | ImageProvider | Gets the image provider.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides PdfResourceDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageResource Properties

The PdfImageResource type exposes the following members.

Properties
 | Name | Description
Public property | ImageInfo | Gets the image info.
Public property | ImageProvider | Gets the image provider.
Top
See Also

Reference

PdfImageResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageResource.ImageInfo Property

PdfImageResourceImageInfo Property

Gets the image info.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageInformation ImageInfo { get; }
Public ReadOnly Property ImageInfo As PdfImageInformation
    Get

Property Value

Type: PdfImageInformation
See Also

Reference

PdfImageResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageResource.ImageProvider Property

PdfImageResourceImageProvider Property

Gets the image provider.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCompressedImageStreamProvider ImageProvider { get; }
Public ReadOnly Property ImageProvider As PdfCompressedImageStreamProvider
    Get

Property Value

Type: PdfCompressedImageStreamProvider
See Also

Reference

PdfImageResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageResource Methods

The PdfImageResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Overrides PdfResourceDisposeManagedResources.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfImageResource.DisposeManagedResources Method

PdfImageResourceDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DisposeManagedResources()
Protected Overrides Sub DisposeManagedResources
See Also

Reference

PdfImageResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJbig2ImageCompression Class

The Jbig2 settings for pdf images
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfJbig2ImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfJbig2ImageCompression : PdfImageCompression
Public Class PdfJbig2ImageCompression
    Inherits PdfImageCompression

The PdfJbig2ImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfJbig2ImageCompression | Initializes a new instance of the PdfJbig2ImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJbig2ImageCompression Constructor

Initializes a new instance of the PdfJbig2ImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJbig2ImageCompression()
Public Sub New
See Also

Reference

PdfJbig2ImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJbig2ImageCompression Properties

The PdfJbig2ImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfJbig2ImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJbig2ImageCompression Methods

The PdfJbig2ImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfJbig2ImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCodecDetails Class

The settings for the pdf jpeg2000 codec
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCodecDetails
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfJpxImageCodecDetails

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfJpxImageCodecDetails : PdfImageCodecDetails
Public Class PdfJpxImageCodecDetails
    Inherits PdfImageCodecDetails

The PdfJpxImageCodecDetails type exposes the following members.

Constructors
 | Name | Description
Public method | PdfJpxImageCodecDetails | Initializes a new instance of the PdfJpxImageCodecDetails class.
Top
Properties
 | Name | Description
Public property | Quality | Gets the quality.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCodecDetails Constructor

Initializes a new instance of the PdfJpxImageCodecDetails class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJpxImageCodecDetails(
    double quality
)
Public Sub New (
    quality As Double
)

Parameters

quality
Type: SystemDouble
The quality.
See Also

Reference

PdfJpxImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCodecDetails Properties

The PdfJpxImageCodecDetails type exposes the following members.

Properties
 | Name | Description
Public property | Quality | Gets the quality.
Top
See Also

Reference

PdfJpxImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCodecDetails.Quality Property

PdfJpxImageCodecDetailsQuality Property

Gets the quality.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Quality { get; }
Public ReadOnly Property Quality As Double
    Get

Property Value

Type: Double
See Also

Reference

PdfJpxImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCodecDetails Methods

The PdfJpxImageCodecDetails type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfJpxImageCodecDetails Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCompression Class

The settings for Jpeg2000 image compression for a PdfImageResource
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfJpxImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfJpxImageCompression : PdfImageCompression
Public Class PdfJpxImageCompression
    Inherits PdfImageCompression

The PdfJpxImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfJpxImageCompression | Initializes a new instance of the PdfJpxImageCompression class.
Public method | PdfJpxImageCompression(Double) | Initializes a new instance of the PdfJpxImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCompression Constructor

Overload List
 | Name | Description
Public method | PdfJpxImageCompression | Initializes a new instance of the PdfJpxImageCompression class.
Public method | PdfJpxImageCompression(Double) | Initializes a new instance of the PdfJpxImageCompression class.
Top
See Also

Reference

PdfJpxImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCompression Constructor

Initializes a new instance of the PdfJpxImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJpxImageCompression()
Public Sub New
See Also

Reference

PdfJpxImageCompression Class
PdfJpxImageCompression Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCompression Constructor (Double)

Initializes a new instance of the PdfJpxImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfJpxImageCompression(
    double quality
)
Public Sub New (
    quality As Double
)

Parameters

quality
Type: SystemDouble
The quality.
See Also

Reference

PdfJpxImageCompression Class
PdfJpxImageCompression Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCompression Properties

The PdfJpxImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfJpxImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfJpxImageCompression Methods

The PdfJpxImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfJpxImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfLzwImageCompression Class

The settings for Lzw compression
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfLzwImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfLzwImageCompression : PdfImageCompression
Public Class PdfLzwImageCompression
    Inherits PdfImageCompression

The PdfLzwImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfLzwImageCompression | Initializes a new instance of the PdfLzwImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfLzwImageCompression Constructor

Initializes a new instance of the PdfLzwImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLzwImageCompression()
Public Sub New
See Also

Reference

PdfLzwImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfLzwImageCompression Properties

The PdfLzwImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfLzwImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfLzwImageCompression Methods

The PdfLzwImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfLzwImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfNoneImageCompression Class

The settings for no compression
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfNoneImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfNoneImageCompression : PdfImageCompression
Public Class PdfNoneImageCompression
    Inherits PdfImageCompression

The PdfNoneImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfNoneImageCompression | Initializes a new instance of the PdfNoneImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfNoneImageCompression Constructor

Initializes a new instance of the PdfNoneImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfNoneImageCompression()
Public Sub New
See Also

Reference

PdfNoneImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfNoneImageCompression Properties

The PdfNoneImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfNoneImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfNoneImageCompression Methods

The PdfNoneImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfNoneImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfRunLengthImageCompression Class

The settings for run length image compression
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfImageCompression
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesPdfRunLengthImageCompression

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfRunLengthImageCompression : PdfImageCompression
Public Class PdfRunLengthImageCompression
    Inherits PdfImageCompression

The PdfRunLengthImageCompression type exposes the following members.

Constructors
 | Name | Description
Public method | PdfRunLengthImageCompression | Initializes a new instance of the PdfRunLengthImageCompression class.
Top
Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfRunLengthImageCompression Constructor

Initializes a new instance of the PdfRunLengthImageCompression class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRunLengthImageCompression()
Public Sub New
See Also

Reference

PdfRunLengthImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfRunLengthImageCompression Properties

The PdfRunLengthImageCompression type exposes the following members.

Properties
 | Name | Description
Public property | Codec | Gets the codec. (Inherited from PdfImageCompression.)
Public property | Details | Gets the details. (Inherited from PdfImageCompression.)
Top
See Also

Reference

PdfRunLengthImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


PdfRunLengthImageCompression Methods

The PdfRunLengthImageCompression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfRunLengthImageCompression Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream Class

A temporary stream to store inner resources.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesStoredStream

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class StoredStream : IDisposable
Public MustInherit Class StoredStream
    Implements IDisposable

The StoredStream type exposes the following members.

Constructors
 | Name | Description
Protected method | StoredStream | Initializes a new instance of the StoredStream class
Top
Methods
 | Name | Description
Public method | Acquire | Acquires a stream.
Public method | CanCloseStream | Determines whether this instance [can close stream].
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the StoredStream is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAquire | Low level aquire.
Protected method | LLRelease | Low Level release.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | Releases the stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream Constructor

Initializes a new instance of the StoredStream class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected StoredStream()
Protected Sub New
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream Methods

The StoredStream type exposes the following members.

Methods
 | Name | Description
Public method | Acquire | Acquires a stream.
Public method | CanCloseStream | Determines whether this instance [can close stream].
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Protected method | DisposeManagedResources | Disposes the managed resources.
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the StoredStream is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LLAquire | Low level aquire.
Protected method | LLRelease | Low Level release.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | Releases the stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.Acquire Method

StoredStreamAcquire Method

Acquires a stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Acquire()
Public Function Acquire As Stream

Return Value

Type: Stream
The acquired stream.
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.CanCloseStream Method

StoredStreamCanCloseStream Method

Determines whether this instance [can close stream].

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract bool CanCloseStream()
Public MustOverride Function CanCloseStream As Boolean

Return Value

Type: Boolean
true if this instance [can close stream]; otherwise, false.
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.Dispose Method

StoredStreamDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the resource.
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources
Top
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.Dispose Method

StoredStreamDispose Method

Disposes the resource.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

StoredStream Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.Dispose Method (Boolean)

StoredStreamDispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

StoredStream Class
Dispose Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.DisposeManagedResources Method

StoredStreamDisposeManagedResources Method

Disposes the managed resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeManagedResources()
Protected Overridable Sub DisposeManagedResources
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.DisposeUnmanagedResources Method

StoredStreamDisposeUnmanagedResources Method

Disposes the unmanaged resources.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void DisposeUnmanagedResources()
Protected Overridable Sub DisposeUnmanagedResources
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.Finalize Method

StoredStreamFinalize Method

Releases unmanaged resources and performs other cleanup operations before the StoredStream is reclaimed by garbage collection.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.LLAquire Method

StoredStreamLLAquire Method

Low level aquire.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract Stream LLAquire()
Protected MustOverride Function LLAquire As Stream

Return Value

Type: Stream
The acquired stream.
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.LLRelease Method

StoredStreamLLRelease Method

Low Level release.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void LLRelease(
    Stream stm
)
Protected MustOverride Sub LLRelease (
    stm As Stream
)

Parameters

stm
Type: System.IOStream
The STM.
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


StoredStream.Release Method

StoredStreamRelease Method

Releases the stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Release()
Public Sub Release
See Also

Reference

StoredStream Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


TempFileStreamProvider Class

A stream provider for temporary files
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandling.ImagesTempFileStreamProvider

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class TempFileStreamProvider : IStoredStreamProvider
Public Class TempFileStreamProvider
    Implements IStoredStreamProvider

The TempFileStreamProvider type exposes the following members.

Constructors
 | Name | Description
Public method | TempFileStreamProvider | Initializes a new instance of the TempFileStreamProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeStream | Makes the required stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


TempFileStreamProvider Constructor

Initializes a new instance of the TempFileStreamProvider class

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TempFileStreamProvider()
Public Sub New
See Also

Reference

TempFileStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


TempFileStreamProvider Methods

The TempFileStreamProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeStream | Makes the required stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TempFileStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


TempFileStreamProvider.MakeStream Method

TempFileStreamProviderMakeStream Method

Makes the required stream.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Images
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StoredStream MakeStream()
Public Function MakeStream As StoredStream

Return Value

Type: StoredStream
A StoredTempFileStream object that can be used for getting a data stream.

Implements

IStoredStreamProviderMakeStream
See Also

Reference

TempFileStreamProvider Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Images Namespace


Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace

Classes
 | Class | Description
Public class | PdfTemplateManager | PdfTemplateManager is a PdfResourceManager instance used for managing PdfTemplateResource objects which are used to hold DrawingTemplate objects. You will never need to make one of these objects yourself. There is an instance of the PdfTemplateManager class in Templates property of the GlobalResources class.
Public class | PdfTemplateResource | A PdfTemplateResource is a document-level resource that represents a reusable DrawingTemplate on a page or used as an appearance for an annotation.


PdfTemplateManager Class

PdfTemplateManager is a PdfResourceManager instance used for managing PdfTemplateResource objects which are used to hold DrawingTemplate objects. You will never need to make one of these objects yourself. There is an instance of the PdfTemplateManager class in Templates property of the GlobalResources class.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceManager PdfTemplateResource
Atalasoft.PdfDoc.Generating.ResourceHandling.TemplatesPdfTemplateManager

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTemplateManager : PdfResourceManager<PdfTemplateResource>
Public Class PdfTemplateManager
    Inherits PdfResourceManager(Of PdfTemplateResource)

The PdfTemplateManager type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTemplateManager | Initializes a new empty instance of the PdfTemplateManager class.
Top
Properties
Name Description
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Protected property ResourceClass
Gets the resource class. Returns Templates.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
Top
Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Public method Add(DrawingTemplate)
Adds the specified template.
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
Public method Add(String, DrawingTemplate)
Adds the specified template, using the provided name.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Compares two resources for equality. Default implementation returns false. Subclasses should override this method
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager Constructor

Initializes a new empty instance of the PdfTemplateManager class.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTemplateManager()
Public Sub New
See Also

Reference

PdfTemplateManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager Properties

The PdfTemplateManager type exposes the following members.

Properties
Name Description
Public property Item
Gets the resource with the specified s.
(Inherited from PdfResourceManagerT.)
Protected property ResourceClass
Gets the resource class. Returns Templates.
(Overrides PdfResourceManagerTResourceClass.)
ResourceNames
Gets the resource names for this resource manager.
Examples
Copy
foreach (string name in globalResources.Images.ResourceNames) {
    Console.WriteLine("resource name: " + name);
}
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

PdfTemplateManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager.ResourceClass Property

PdfTemplateManagerResourceClass Property

Gets the resource class. Returns Templates.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfResourceClass ResourceClass { get; }
Protected Overrides ReadOnly Property ResourceClass As PdfResourceClass
    Get

Property Value

Type: PdfResourceClass
See Also

Reference

PdfTemplateManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager Methods

The PdfTemplateManager type exposes the following members.

Methods
Name | Description
Add(T)
Adds the specified resource with an auto-generated name.
(Inherited from PdfResourceManagerT.)
Public method Add(DrawingTemplate)
Adds the specified template.
Add(String, T)
Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present.
(Inherited from PdfResourceManagerT.)
Public method Add(String, DrawingTemplate)
Adds the specified template, using the provided name.
Public method Contains
Determines whether or not the resource is present.
(Inherited from PdfResourceManagerT.)
Public method Dispose
Disposes all resources contained in this resource manager
(Inherited from PdfResourceManagerT.)
Protected method Dispose(Boolean)
Releases unmanaged and - optionally - managed resources
(Inherited from PdfResourceManagerT.)
Protected method DisposeManagedResources
Disposes the managed resources.
(Inherited from PdfResourceManagerT.)
Protected method DisposeUnmanagedResources
Disposes the unmanaged resources.
(Inherited from PdfResourceManagerT.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Releases unmanaged resources and performs other cleanup operations before the PdfResourceManagerT is reclaimed by garbage collection.
(Inherited from PdfResourceManagerT.)
Get
Gets a resource with the given name. Throws an exception if there is no resource present with that name.
(Inherited from PdfResourceManagerT.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Merge
Merges the set of resources, other, into this ResourceManager using the selector to resolve name conflicts.
(Inherited from PdfResourceManagerT.)
Public method NextName
Returns the next available auto-generated name for this resource.
Copy
string name = someResourceManager.NextName();
someResourceManager.Add(name, someResource);
(Inherited from PdfResourceManagerT.)
Remove
Removes the resource of the specified name. Throws an ArgumentException if name is not present.
(Inherited from PdfResourceManagerT.)
Protected method ResourcesMatch
Compares two resources for equality. Default implementation returns false. Subclasses should override this method
(Overrides PdfResourceManagerTResourcesMatch(T, T).)
Protected method | ThrowIfDisposed | (Inherited from PdfResourceManagerT.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
TryGet
Tries to get the specified resource.
(Inherited from PdfResourceManagerT.)
Top
See Also

Reference

PdfTemplateManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager.Add Method

PdfTemplateManagerAdd Method

Overload List
 | Name | Description
 | Add(T) | Adds the specified resource with an auto-generated name. (Inherited from PdfResourceManagerT.)
Public method | Add(DrawingTemplate) | Adds the specified template.
 | Add(String, T) | Adds a resource to the resource manager. Throws ArgumentException if a resource with the same name is already present. (Inherited from PdfResourceManagerT.)
Public method | Add(String, DrawingTemplate) | Adds the specified template, using the provided name.
Top
See Also

Reference

PdfTemplateManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager.Add Method (DrawingTemplate)

PdfTemplateManagerAdd Method (DrawingTemplate)

Adds the specified template.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Add(
    DrawingTemplate template
)
Public Function Add (
    template As DrawingTemplate
) As String

Parameters

template
Type: Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate
The template.

Return Value

Type: String
The added resource
See Also

Reference

PdfTemplateManager Class
Add Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager.Add Method (String, DrawingTemplate)

PdfTemplateManagerAdd Method (String, DrawingTemplate)

Adds the specified template, using the provided name.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    string name,
    DrawingTemplate template
)
Public Sub Add (
    name As String,
    template As DrawingTemplate
)

Parameters

name
Type: SystemString
The name.
template
Type: Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate
The template.
Remarks
Throws a PDF Exception if a resource exists with that name.
See Also

Reference

PdfTemplateManager Class
Add Overload
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateManager.ResourcesMatch Method

PdfTemplateManagerResourcesMatch Method

Compares two resources for equality. Default implementation returns false. Subclasses should override this method

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override bool ResourcesMatch(
    PdfTemplateResource one,
    PdfTemplateResource two
)
Protected Overrides Function ResourcesMatch (
    one As PdfTemplateResource,
    two As PdfTemplateResource
) As Boolean

Parameters

one
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.TemplatesPdfTemplateResource
The first resource.
two
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.TemplatesPdfTemplateResource
The second resource.

Return Value

Type: Boolean
true if the resources match, false otherwise.
See Also

Reference

PdfTemplateManager Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateResource Class

A PdfTemplateResource is a document-level resource that represents a reusable DrawingTemplate on a page or used as an appearance for an annotation.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResource
Atalasoft.PdfDoc.Generating.ResourceHandling.TemplatesPdfTemplateResource

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfTemplateResource : PdfResource
Public Class PdfTemplateResource
    Inherits PdfResource

The PdfTemplateResource type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTemplateResource | Initializes a new instance of the PdfTemplateResource class from the given DrawingTemplate.
Top
Properties
 | Name | Description
Public property | Template | Gets the template.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateResource Constructor

Initializes a new instance of the PdfTemplateResource class from the given DrawingTemplate.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTemplateResource(
    DrawingTemplate template
)
Public Sub New (
    template As DrawingTemplate
)

Parameters

template
Type: Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate
The template.
Remarks
The template must be non-null.
See Also

Reference

PdfTemplateResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateResource Properties

The PdfTemplateResource type exposes the following members.

Properties
 | Name | Description
Public property | Template | Gets the template.
Top
See Also

Reference

PdfTemplateResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateResource.Template Property

PdfTemplateResourceTemplate Property

Gets the template.

Namespace: Atalasoft.PdfDoc.Generating.ResourceHandling.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DrawingTemplate Template { get; }
Public ReadOnly Property Template As DrawingTemplate
    Get

Property Value

Type: DrawingTemplate
See Also

Reference

PdfTemplateResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


PdfTemplateResource Methods

The PdfTemplateResource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resource. (Inherited from PdfResource.)
Protected method | Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from PdfResource.)
Protected method | DisposeManagedResources | Disposes the managed resources. (Inherited from PdfResource.)
Protected method | DisposeUnmanagedResources | Disposes the unmanaged resources. (Inherited from PdfResource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the PdfResource is reclaimed by garbage collection. (Inherited from PdfResource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTemplateResource Class
Atalasoft.PdfDoc.Generating.ResourceHandling.Templates Namespace


Atalasoft.PdfDoc.Generating.Shapes Namespace

Classes
 | Class | Description
Public class | AddRemoveEventArgsT | This object represents the information provided on an Add or Remove event to an ObservableList.
 | DynamicPdfTextBox | DynamicPdfTextBox is a text shape that is used to take a variable amount of space. By providing a maximum height and maximum width and the text instructions, the DynamicPdfTextBox will provide the minimum amount of space required to display the information through its MinimumBounds property.
Public class | GRestore | A displaylist level GRestore operation for generating pdf
Public class | GSave | A drawinglist level call to GSave
Public class | ObservableListT | Represents a list that generates events when objects are being added or removed. Hooking into the ItemChanged event will allow an application to observe when an item has been added or removed. On a set operation through the array accessor both a remove and add event are fired.
 | PdfArc | A Shape class for PdfGeneratedDocuments which draws Arcs, Chords and Pie segments.
 | PdfBaseShape | A base class for any repeatable composite drawing action. To use this class inherit from PdfBaseShape then override the CloneInstance and DrawShape methods to get the PdfPageRenderer object.
Public class | PdfBaseTextShape | The base class for making pdf text shapes. It provides the basic settings to control fonts and transformations automatically.
 | PdfCircle | A PdfBaseShape overload which draws a circle based on a center point and a radius.
 | PdfClippedTextLine | A pdf text object which writes text and clips to a rectangle. This object is best used to make spreadsheet like trimming of long strings to fit into a cell of a table.
Public class | PdfImageShape | The shape used to place an image on a page
 | PdfMarkedContent | PdfMarkedContent represents an area within drawing on a PDF page or in a DrawingTemplate that is marked as having special meaning. For example, certain classes of annotations that have customized appearances use "marked content" to set aside an area that reserved for customizable or user-entered text.
 | PdfPath | A PdfBaseShape that contains a series of operations to define a custom drawing.
 | PdfRectangle | A PdfBaseShape to draw a Rectangle.
 | PdfRoundedRectangle | A PdfBaseShape for making RoundedRectangles
 | PdfStyledTextBox | An object to output styled text to a PdfGeneratedDocument.
 | PdfTable | An object to output object data in a table format to a PdfGeneratedDocument.
Public class | PdfTableColumn | Used to define the columns for the PdfTable
Public class | PdfTableColumnCollection | Collection of table columns, added methods to calculate widths and clone the column collection
Public class | PdfTemplateShape | The shape used to place an image on a page
 | PdfTextBox | A simple pdf text box.
 | PdfTextLine | The PdfTextLine is a Shape object that can be added to a PdfGeneratedDocument.DisplayList. It provides an interface to write a single line of text at a specified location.
 | PdfTextPath | A PdfBaseShape to perform complex custom direction text writing
Public class | PdfTextStyle | An object used to provide a text style to a pdf text object.
Public class | PostnetBarcodeShape | The shape for drawing Postnet style barcodes.
Public class | ShapeUtilities | A utility class for objects that Override PdfBaseShape
Public class | StyleTextInput | An object used to provide styled text to pdf text objects that can handle style changes.
Public class | Transform | Transform represents an Affine transform in PDF page. It wraps a PdfTransform object and will apply it upon render. Client code should avoid injecting transformations that have no inverse (Scale with 0 in either or both X and Y), as it creates a degenrate transform that can only be undone with a GRestore to a prior GSave. Since this has other side effects (changing clipping, line thickness and so on), it is not good practice.
Interfaces
 | Interface | Description
Public interface | IPdfTextContainer | An interface for shapes that contain text.
Enumerations
 | Enumeration | Description
Public enumeration | PathTextStyle | The style of how the text is broken to apply to the path.
Public enumeration | PdfTableBorderStyle | Border style options available for the PdfTable. To be used to set the PdfTable.BorderStyle property.
Public enumeration | PdfTextAlignment | An enum to represent text alignment styles


AddRemoveEventArgs(T) Class

AddRemoveEventArgsT Class

This object represents the information provided on an Add or Remove event to an ObservableList.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.PdfDoc.Generating.ShapesAddRemoveEventArgsT

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AddRemoveEventArgs<T> : EventArgs

Public Class AddRemoveEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The type of the object in the list under observation.

The AddRemoveEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | AddRemoveEventArgsT | Initializes a new instance of the AddRemoveEventArgsT class.
Top
Properties
 | Name | Description
Public property | IsAdd | Gets a value indicating whether this instance is an add event or a remove event.
Public property | Item | Gets the item that is being added or removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


AddRemoveEventArgs(T) Constructor

AddRemoveEventArgsT Constructor

Initializes a new instance of the AddRemoveEventArgsT class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AddRemoveEventArgs(
    T item,
    bool isAdd
)
Public Sub New (
    item As T,
    isAdd As Boolean
)

Parameters

item
Type: T
The item.
isAdd
Type: SystemBoolean
if set to true [is add].
See Also

Reference

AddRemoveEventArgsT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


AddRemoveEventArgs(T) Properties

AddRemoveEventArgsT Properties

The AddRemoveEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | IsAdd | Gets a value indicating whether this instance is an add event or a remove event.
Public property | Item | Gets the item that is being added or removed.
Top
See Also

Reference

AddRemoveEventArgsT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


AddRemoveEventArgs(T).IsAdd Property

AddRemoveEventArgsTIsAdd Property

Gets a value indicating whether this instance is an add event or a remove event.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsAdd { get; }
Public ReadOnly Property IsAdd As Boolean
    Get

Property Value

Type: Boolean
true if this instance is an add event; otherwise, false.
See Also

Reference

AddRemoveEventArgsT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


AddRemoveEventArgs(T).Item Property

AddRemoveEventArgsTItem Property

Gets the item that is being added or removed.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Item { get; }
Public ReadOnly Property Item As T
    Get

Property Value

Type: T
See Also

Reference

AddRemoveEventArgsT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


AddRemoveEventArgs(T) Methods

AddRemoveEventArgsT Methods

The AddRemoveEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddRemoveEventArgsT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox Class

DynamicPdfTextBox is a text shape that is used to take a variable amount of space. By providing a maximum height and maximum width and the text instructions, the DynamicPdfTextBox will provide the minimum amount of space required to display the information through its MinimumBounds property.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesDynamicPdfTextBox

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DynamicPdfTextBox : PdfBaseTextShape
<SerializableAttribute>
Public Class DynamicPdfTextBox
    Inherits PdfBaseTextShape

The DynamicPdfTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicPdfTextBox(PdfPoint, Double, Double, StyleTextInput, PdfFontManager, PdfTextAlignment) | Initializes a new instance of the DynamicPdfTextBox class.
Public method | DynamicPdfTextBox(PdfPoint, String, Double, Double, Double, String, PdfFontManager, PdfTextAlignment) | Initializes a new instance of the DynamicPdfTextBox class.
Top
Properties
 | Name | Description
Public property | Alignment | (Overrides PdfBaseTextShapeAlignment.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | LockedWidth | Gets the width of the box.
Public property | MaximumHeight | Gets the maximum height of the box.
Public property | MinimumBounds | Gets the minimum bounds of the box calculated from the given text.
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
DynamicPdfTextBox box = new DynamicPdfTestBox(startPoint, "Font0", 12.0, 400, 500, textString, document.GlobalResources.Fonts);
if(box.MinimumBounds.Height < 200)
page.DrawingList.Add(smallBorderShape)
else
page.DrawingList.Add(largeBorderShape)
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox Constructor

Overload List
 | Name | Description
Public method | DynamicPdfTextBox(PdfPoint, Double, Double, StyleTextInput, PdfFontManager, PdfTextAlignment) | Initializes a new instance of the DynamicPdfTextBox class.
Public method | DynamicPdfTextBox(PdfPoint, String, Double, Double, Double, String, PdfFontManager, PdfTextAlignment) | Initializes a new instance of the DynamicPdfTextBox class.
Top
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox Constructor (PdfPoint, Double, Double, StyleTextInput, PdfFontManager, PdfTextAlignment)

Initializes a new instance of the DynamicPdfTextBox class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DynamicPdfTextBox(
    PdfPoint startPoint,
    double width,
    double maximumHeight,
    StyleTextInput text,
    PdfFontManager manager,
    PdfTextAlignment alignment = PdfTextAlignment.Left
)
Public Sub New (
    startPoint As PdfPoint,
    width As Double,
    maximumHeight As Double,
    text As StyleTextInput,
    manager As PdfFontManager,
    Optional alignment As PdfTextAlignment = PdfTextAlignment.Left
)

Parameters

startPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The start point.
width
Type: SystemDouble
The width.
maximumHeight
Type: SystemDouble
The maximum height.
text
Type: Atalasoft.PdfDoc.Generating.ShapesStyleTextInput
The styled text input.
manager
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager
The manager.
alignment (Optional)
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextAlignment
See Also

Reference

DynamicPdfTextBox Class
DynamicPdfTextBox Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox Constructor (PdfPoint, String, Double, Double, Double, String, PdfFontManager, PdfTextAlignment)

Initializes a new instance of the DynamicPdfTextBox class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DynamicPdfTextBox(
    PdfPoint startPoint,
    string fontName,
    double fontSize,
    double width,
    double maximumHeight,
    string text,
    PdfFontManager manager,
    PdfTextAlignment alignment = PdfTextAlignment.Left
)
Public Sub New (
    startPoint As PdfPoint,
    fontName As String,
    fontSize As Double,
    width As Double,
    maximumHeight As Double,
    text As String,
    manager As PdfFontManager,
    Optional alignment As PdfTextAlignment = PdfTextAlignment.Left
)

Parameters

startPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The start point.
fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
width
Type: SystemDouble
The width.
maximumHeight
Type: SystemDouble
The maximum height.
text
Type: SystemString
The text.
manager
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager
The manager.
alignment (Optional)
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextAlignment
See Also

Reference

DynamicPdfTextBox Class
DynamicPdfTextBox Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox Properties

The DynamicPdfTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | (Overrides PdfBaseTextShapeAlignment.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | LockedWidth | Gets the width of the box.
Public property | MaximumHeight | Gets the maximum height of the box.
Public property | MinimumBounds | Gets the minimum bounds of the box calculated from the given text.
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox.Alignment Property

DynamicPdfTextBoxAlignment Property

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override PdfTextAlignment Alignment { get; set; }
Public Overrides Property Alignment As PdfTextAlignment
    Get
    Set

Property Value

Type: PdfTextAlignment
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox.LockedWidth Property

DynamicPdfTextBoxLockedWidth Property

Gets the width of the box.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LockedWidth { get; }
Public ReadOnly Property LockedWidth As Double
    Get

Property Value

Type: Double
The width of the box.
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox.MaximumHeight Property

DynamicPdfTextBoxMaximumHeight Property

Gets the maximum height of the box.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaximumHeight { get; }
Public ReadOnly Property MaximumHeight As Double
    Get

Property Value

Type: Double
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox.MinimumBounds Property

DynamicPdfTextBoxMinimumBounds Property

Gets the minimum bounds of the box calculated from the given text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds MinimumBounds { get; }
Public ReadOnly Property MinimumBounds As PdfBounds
    Get

Property Value

Type: PdfBounds
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox Methods

The DynamicPdfTextBox type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox.CloneInstance Method

DynamicPdfTextBoxCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A clone of this shape
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


DynamicPdfTextBox.DrawShape Method

DynamicPdfTextBoxDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer.
See Also

Reference

DynamicPdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GRestore Class

A displaylist level GRestore operation for generating pdf
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesGRestore

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GRestore : IPdfRenderable
<SerializableAttribute>
Public Class GRestore
    Implements IPdfRenderable

The GRestore type exposes the following members.

Constructors
 | Name | Description
Public method | GRestore | Initializes a new instance of the GRestore class
Top
Properties
Name | Description
Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


GRestore Constructor

Initializes a new instance of the GRestore class

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GRestore()
Public Sub New
See Also

Reference

GRestore Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GRestore Properties

The GRestore type exposes the following members.

Properties
Name | Description
Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
See Also

Reference

GRestore Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GRestore.Name Property

GRestoreName Property

Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the object.

Implements

IPdfRenderableName
Examples
Copy
foreach (IPdfRenderable namedGroup in list.FindAll(item => item.Name == "Group") {
ProcessGroup(namedGroup);
}
See Also

Reference

GRestore Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GRestore Methods

The GRestore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GRestore Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GRestore.Render Method

GRestoreRender Method

Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfPageRenderer r
)
Public Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer

Implements

IPdfRenderableRender(PdfPageRenderer)
Examples
Copy
public void GeneratePdf(PdfPageRenderer r)
{
w.DrawingSurface.Begin();
w.DrawingSurface.AddRect(MyBounds); // place a rectangle
w.DrawingSurface.Stroke(PdfLineStyle.Default, MyColor); // draw its outline in black
w.DrawingSurface.End();
}
See Also

Reference

GRestore Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GSave Class

A drawinglist level call to GSave
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesGSave

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GSave : IPdfRenderable
<SerializableAttribute>
Public Class GSave
    Implements IPdfRenderable

The GSave type exposes the following members.

Constructors
 | Name | Description
Public method | GSave | Initializes a new instance of the GSave class
Top
Properties
Name | Description
Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


GSave Constructor

Initializes a new instance of the GSave class

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public GSave()
Public Sub New
See Also

Reference

GSave Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GSave Properties

The GSave type exposes the following members.

Properties
Name | Description
Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Top
See Also

Reference

GSave Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GSave.Name Property

GSaveName Property

Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the object.

Implements

IPdfRenderableName
Examples
Copy
foreach (IPdfRenderable namedGroup in list.FindAll(item => item.Name == "Group") {
ProcessGroup(namedGroup);
}
See Also

Reference

GSave Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GSave Methods

The GSave type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GSave Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


GSave.Render Method

GSaveRender Method

Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfPageRenderer r
)
Public Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer

Implements

IPdfRenderableRender(PdfPageRenderer)
Examples
Copy
public void GeneratePdf(PdfPageRenderer r)
{
w.DrawingSurface.Begin();
w.DrawingSurface.AddRect(MyBounds); // place a rectangle
w.DrawingSurface.Stroke(PdfLineStyle.Default, MyColor); // draw its outline in black
w.DrawingSurface.End();
}
See Also

Reference

GSave Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


IPdfTextContainer Interface

An interface for shapes that contain text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IPdfTextContainer
Public Interface IPdfTextContainer

The IPdfTextContainer type exposes the following members.

Properties
 | Name | Description
Public property | Text | Gets or sets the text.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


IPdfTextContainer Properties

The IPdfTextContainer type exposes the following members.

Properties
 | Name | Description
Public property | Text | Gets or sets the text.
Top
See Also

Reference

IPdfTextContainer Interface
Atalasoft.PdfDoc.Generating.Shapes Namespace


IPdfTextContainer.Text Property

IPdfTextContainerText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
string Text { get; set; }
Property Text As String
    Get
    Set

Property Value

Type: String
The text.
See Also

Reference

IPdfTextContainer Interface
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T) Class

ObservableListT Class

Represents a list that generates events when objects are being added or removed. Hooking into the ItemChanged event will allow an application to observe when an item has been added or removed. On a set operation through the array accessor both a remove and add event are fired.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesObservableListT

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ObservableList<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

<SerializableAttribute>
Public Class ObservableList(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable

Type Parameters

T

The ObservableListT type exposes the following members.

Constructors
 | Name | Description
Public method | ObservableListT | Initializes a new instance of the ObservableListT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element at the specified index. Fires an ItemChanged event with a "remove" and then an "add".
Top
Methods
Name Description
Public method Add
Adds an item to the ICollectionT. Fires an ItemChanged "add" event.
Public method Clear
Removes all items from the ICollectionT. Fires ItemChanged "remove" events for every item in the list.
Public method Contains
Determines whether the ICollectionT contains a specific value.
Public method CopyTo
Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator that iterates through the collection.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Determines the index of a specific item in the IListT.
Public method Insert
Inserts an item to the IListT at the specified index. Fires the ItemChanged event with an "add".
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method OnItemChanged
Raises the [E:ItemChanged] event.
Public method Remove
Removes the first occurrence of a specific object from the ICollectionT. Fires the ItemChanged event with a "remove".
Public method RemoveAll
Removes all the elements in the list for which pred returns true. Note that each element will be visited twice.
Copy
list.RemoveAll(shape => shape is PdfPath); // remove all paths from the list
Public method RemoveAt
Removes the IListT item at the specified index. Fires the ItemChanged event with a "remove".
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
Fields
Name Description
Public field ItemChanged
Event for hooking to the list to observe add/remove operations
Copy
list.ItemChanged += new EventHandler<AddRemoveEventArgs<MyItemType>>(MyEventHandler);
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T) Constructor

ObservableListT Constructor

Initializes a new instance of the ObservableListT class

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ObservableList()
Public Sub New
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T) Properties

ObservableListT Properties

The ObservableListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element at the specified index. Fires an ItemChanged event with a "remove" and then an "add".
Top
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Count Property

ObservableListTCount Property

Gets the number of elements contained in the ICollectionT.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).IsReadOnly Property

ObservableListTIsReadOnly Property

Gets a value indicating whether the ICollectionT is read-only.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Return Value

Type: Boolean
true if the ICollectionT is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Item Property

ObservableListTItem Property

Gets or sets the element at the specified index. Fires an ItemChanged event with a "remove" and then an "add".

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32

Return Value

Type: T
The element at the specified index.

Implements

IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The property is set and the IListT is read-only.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T) Methods

ObservableListT Methods

The ObservableListT generic type exposes the following members.

Methods
Name Description
Public method Add
Adds an item to the ICollectionT. Fires an ItemChanged "add" event.
Public method Clear
Removes all items from the ICollectionT. Fires ItemChanged "remove" events for every item in the list.
Public method Contains
Determines whether the ICollectionT contains a specific value.
Public method CopyTo
Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator that iterates through the collection.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Determines the index of a specific item in the IListT.
Public method Insert
Inserts an item to the IListT at the specified index. Fires the ItemChanged event with an "add".
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Protected method OnItemChanged
Raises the [E:ItemChanged] event.
Public method Remove
Removes the first occurrence of a specific object from the ICollectionT. Fires the ItemChanged event with a "remove".
Public method RemoveAll
Removes all the elements in the list for which pred returns true. Note that each element will be visited twice.
Copy
list.RemoveAll(shape => shape is PdfPath); // remove all paths from the list
Public method RemoveAt
Removes the IListT item at the specified index. Fires the ItemChanged event with a "remove".
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Add Method

ObservableListTAdd Method

Adds an item to the ICollectionT. Fires an ItemChanged "add" event.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)

Parameters

item
Type: T
The object to add to the ICollectionT.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Clear Method

ObservableListTClear Method

Removes all items from the ICollectionT. Fires ItemChanged "remove" events for every item in the list.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Contains Method

ObservableListTContains Method

Determines whether the ICollectionT contains a specific value.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

Parameters

item
Type: T
The object to locate in the ICollectionT.

Return Value

Type: Boolean
true if item is found in the ICollectionT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).CopyTo Method

ObservableListTCopyTo Method

Copies the elements of the ICollectionT to an Array, starting at a particular Array index.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from ICollectionT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollectionT is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).GetEnumerator Method

ObservableListTGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumeratorT
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).IndexOf Method

ObservableListTIndexOf Method

Determines the index of a specific item in the IListT.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The object to locate in the IListT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Insert Method

ObservableListTInsert Method

Inserts an item to the IListT at the specified index. Fires the ItemChanged event with an "add".

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    T item
)
Public Sub Insert (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert into the IListT.

Implements

IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).OnItemChanged Method

ObservableListTOnItemChanged Method

Raises the [E:ItemChanged] event.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnItemChanged(
    AddRemoveEventArgs<T> e
)
Protected Overridable Sub OnItemChanged (
    e As AddRemoveEventArgs(Of T)
)

Parameters

e
Type: Atalasoft.PdfDoc.Generating.ShapesAddRemoveEventArgs T
The AddRemoveEventArgsT instance containing the event data.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).Remove Method

ObservableListTRemove Method

Removes the first occurrence of a specific object from the ICollectionT. Fires the ItemChanged event with a "remove".

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean

Parameters

item
Type: T
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).RemoveAll Method

ObservableListTRemoveAll Method

Removes all the elements in the list for which pred returns true. Note that each element will be visited twice.
Copy
list.RemoveAll(shape => shape is PdfPath); // remove all paths from the list

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int RemoveAll(
    Predicate<T> pred
)
Public Function RemoveAll (
    pred As Predicate(Of T)
) As Integer

Parameters

pred
Type: SystemPredicateT
The pred.

Return Value

Type: Int32
The number of items removed.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).RemoveAt Method

ObservableListTRemoveAt Method

Removes the IListT item at the specified index. Fires the ItemChanged event with a "remove".

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T) Fields

ObservableListT Fields

The ObservableListT generic type exposes the following members.

Fields
Name Description
Public field ItemChanged
Event for hooking to the list to observe add/remove operations
Copy
list.ItemChanged += new EventHandler<AddRemoveEventArgs<MyItemType>>(MyEventHandler);
Top
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ObservableList(T).ItemChanged Field

ObservableListTItemChanged Field

Event for hooking to the list to observe add/remove operations
Copy
list.ItemChanged += new EventHandler<AddRemoveEventArgs<MyItemType>>(MyEventHandler);

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EventHandler<AddRemoveEventArgs<T>> ItemChanged
Public ItemChanged As EventHandler(Of AddRemoveEventArgs(Of T))

Field Value

Type: EventHandlerAddRemoveEventArgs T
See Also

Reference

ObservableListT Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PathTextStyle Enumeration

The style of how the text is broken to apply to the path.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public enum PathTextStyle
<SerializableAttribute>
Public Enumeration PathTextStyle
Members
Member name | Description
Letter | break per letter
Word | break per word
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Class

A Shape class for PdfGeneratedDocuments which draws Arcs, Chords and Pie segments.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfArc

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfArc : PdfBaseShape
<SerializableAttribute>
Public Class PdfArc
    Inherits PdfBaseShape

The PdfArc type exposes the following members.

Constructors
 | Name | Description
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor) | Initializes a new instance of the PdfArc class.
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor, Double) | Initializes a new instance of the PdfArc class.
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfArc class.
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfArc class.
Top
Properties
 | Name | Description
Public property | Center | Gets or sets the center.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | Clockwise | Gets or sets a value indicating whether this PdfArc is clockwise.
Public property | EndAngle | Gets or sets the end angle.
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | IncludeWedge | Gets or sets a value indicating whether to include the wedge of the arc.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Radius | Gets or sets the radius.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = PdfDefaultPages.Letter;
doc.Pages.Add(page);
PdfCircle circle = new PdfCircle(new PdfPoint(100, 100), 100, PdfColorFactory.FromRgb(1, 0, 0), 1);
page.DrawingList.Add(circle);
PdfArc arc = new PdfArc(new PdfPoint(100, 100), 100, 315, 45, PdfColorFactory.FromGray(0), 1);
arc.Style.DashPattern = new double[] { 4, 2 };
arc.IncludeWedge = true;
arc.Clockwise = false;
page.DrawingList.Add(arc);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Constructor

Overload List
 | Name | Description
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor) | Initializes a new instance of the PdfArc class.
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor, Double) | Initializes a new instance of the PdfArc class.
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfArc class.
Public method | PdfArc(PdfPoint, Double, Double, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfArc class.
Top
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Constructor (PdfPoint, Double, Double, Double, IPdfColor)

Initializes a new instance of the PdfArc class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfArc(
    PdfPoint center,
    double radius,
    double startAngle,
    double endAngle,
    IPdfColor fillColor
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    startAngle As Double,
    endAngle As Double,
    fillColor As IPdfColor
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle that is used to generate the arc
radius
Type: SystemDouble
The radius.
startAngle
Type: SystemDouble
The start angle.
endAngle
Type: SystemDouble
The end angle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfArc Class
PdfArc Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Constructor (PdfPoint, Double, Double, Double, IPdfColor, Double)

Initializes a new instance of the PdfArc class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfArc(
    PdfPoint center,
    double radius,
    double startAngle,
    double endAngle,
    IPdfColor outlineColor,
    double linewidth
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    startAngle As Double,
    endAngle As Double,
    outlineColor As IPdfColor,
    linewidth As Double
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle that is used to generate the arc
radius
Type: SystemDouble
The radius of the circle that is used to generate the arc
startAngle
Type: SystemDouble
The start angle of the arc
endAngle
Type: SystemDouble
The end angle
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline
linewidth
Type: SystemDouble
The width of the drawn lines
See Also

Reference

PdfArc Class
PdfArc Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Constructor (PdfPoint, Double, Double, Double, IPdfColor, PdfLineStyle, IPdfColor)

Initializes a new instance of the PdfArc class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfArc(
    PdfPoint center,
    double radius,
    double startAngle,
    double endAngle,
    IPdfColor outlineColor,
    PdfLineStyle style,
    IPdfColor fillColor
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    startAngle As Double,
    endAngle As Double,
    outlineColor As IPdfColor,
    style As PdfLineStyle,
    fillColor As IPdfColor
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle that is used to generate the arc
radius
Type: SystemDouble
The radius of the circle that is used to generate the arc
startAngle
Type: SystemDouble
The start angle of the arc
endAngle
Type: SystemDouble
The end angle of the arc
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfArc Class
PdfArc Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Constructor (PdfPoint, Double, Double, Double, IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfArc class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfArc(
    PdfPoint center,
    double radius,
    double startAngle,
    double endAngle,
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    startAngle As Double,
    endAngle As Double,
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle that is used to generate the arc
radius
Type: SystemDouble
The radius of the circle that is used to generate the arc
startAngle
Type: SystemDouble
The start angle of the arc
endAngle
Type: SystemDouble
The end angle of the arc
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The width of drawn lines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfArc Class
PdfArc Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Properties

The PdfArc type exposes the following members.

Properties
 | Name | Description
Public property | Center | Gets or sets the center.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | Clockwise | Gets or sets a value indicating whether this PdfArc is clockwise.
Public property | EndAngle | Gets or sets the end angle.
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | IncludeWedge | Gets or sets a value indicating whether to include the wedge of the arc.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Radius | Gets or sets the radius.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.Center Property

PdfArcCenter Property

Gets or sets the center.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint Center { get; set; }
Public Property Center As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The center of the circle that is used to generate the arc
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.Clockwise Property

PdfArcClockwise Property

Gets or sets a value indicating whether this PdfArc is clockwise.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Clockwise { get; set; }
Public Property Clockwise As Boolean
    Get
    Set

Property Value

Type: Boolean
true if clockwise; otherwise, false.
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.EndAngle Property

PdfArcEndAngle Property

Gets or sets the end angle.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set

Property Value

Type: Double
The end angle of the arc
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.IncludeWedge Property

PdfArcIncludeWedge Property

Gets or sets a value indicating whether to include the wedge of the arc.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IncludeWedge { get; set; }
Public Property IncludeWedge As Boolean
    Get
    Set

Property Value

Type: Boolean
true if wedge included; otherwise, false.
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.Radius Property

PdfArcRadius Property

Gets or sets the radius.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The radius of the circle that is used to generate the arc
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.StartAngle Property

PdfArcStartAngle Property

Gets or sets the start angle.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set

Property Value

Type: Double
The start angle of the arc
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc Methods

The PdfArc type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.CloneInstance Method

PdfArcCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfArc.DrawShape Method

PdfArcDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfArc Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Class

A base class for any repeatable composite drawing action. To use this class inherit from PdfBaseShape then override the CloneInstance and DrawShape methods to get the PdfPageRenderer object.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
More...

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class PdfBaseShape : ICloneable,
    IPdfRenderable, IPdfResourceConsumer
<SerializableAttribute>
Public MustInherit Class PdfBaseShape
    Implements ICloneable, IPdfRenderable, IPdfResourceConsumer

The PdfBaseShape type exposes the following members.

Constructors
 | Name | Description
Protected method | PdfBaseShape | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor) | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor, Double) | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfBaseShape class.
Top
Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip.
Public property | FillColor | Gets or sets the color of the fill.
Public property | Location | Gets or sets the location.
Public property | Name | Gets or sets the name of the IPdfRenderable object.
Public property | OutlineColor | Gets or sets the color of the outline.
Public property | Rotation | Gets or sets the rotation in degrees.
Public property | Scale | Gets or sets the scale.
Public property | Style | Gets or sets the style.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | CloneInstance | Clones the instance.
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape.
Protected method | DrawShape | Draws the shape.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed.
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed.
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested
Public method | Render | Generates the PDF.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
public class RegularPolygon : PdfBaseShape
{
public RegularPolygon(PdfPoint center, double radius, int sides):base(PdfColorFactory.FromGray(0.0),5.0)
{
if (sides < 3) throw new ArgumentException("Polygons must have 3 sides");
GeneratePoints(center, radius, sides);
Center = center;
Radius = radius;
Sides = sides;
}
public PdfPoint Center { get; private set; }
public double Radius { get; private set; }
public int Sides { get; private set; }
private void GeneratePoints(PdfPoint center, double radius, int sides)
{
Points = new List<PdfPoint>();
PdfPoint currPoint = new PdfPoint(0, radius);
Points.Add(currPoint + center);
PdfTransform transform = PdfTransform.Rotate(2 * Math.PI/(double)sides);
for (int i = 1; i < sides; i++)
{
currPoint = transform.Transform(currPoint);
Points.Add(currPoint + center);
}
}
public List<PdfPoint> Points { get; set; }
protected override PdfBaseShape CloneInstance()
{
return new RegularPolygon(Center, Radius, Sides);
}
protected override void DrawShape(PdfPageRenderer r)
{
bool first = true;
PdfPath path = new PdfPath(this);
foreach (PdfPoint p in Points)
{
if (first) { first = false; path.MoveTo(p); }
else { path.LineTo(p); }
}
path.Close();
path.GeneratePdf(w);
}
}
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.BarcodeWritingBarcodeWritingShape
Atalasoft.PdfDoc.BarcodeWritingDataMatrixBarcodeWritingShape
Atalasoft.PdfDoc.BarcodeWritingPdf417BarcodeWritingShape
Atalasoft.PdfDoc.Generating.ShapesPdfArc
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesPdfCircle
Atalasoft.PdfDoc.Generating.ShapesPdfImageShape
Atalasoft.PdfDoc.Generating.ShapesPdfPath
Atalasoft.PdfDoc.Generating.ShapesPdfRectangle
Atalasoft.PdfDoc.Generating.ShapesPdfRoundedRectangle
Atalasoft.PdfDoc.Generating.ShapesPdfTemplateShape
Atalasoft.PdfDoc.Generating.ShapesPostnetBarcodeShape
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOMSvgDocument


PdfBaseShape Constructor

Overload List
 | Name | Description
Protected method | PdfBaseShape | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor) | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor, Double) | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfBaseShape class.
Protected method | PdfBaseShape(IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfBaseShape class.
Top
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Constructor

Initializes a new instance of the PdfBaseShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseShape()
Protected Sub New
See Also

Reference

PdfBaseShape Class
PdfBaseShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Constructor (IPdfColor)

Initializes a new instance of the PdfBaseShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseShape(
    IPdfColor fillColor
)
Protected Sub New (
    fillColor As IPdfColor
)

Parameters

fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfBaseShape Class
PdfBaseShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Constructor (IPdfColor, Double)

Initializes a new instance of the PdfBaseShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseShape(
    IPdfColor outlineColor,
    double linewidth
)
Protected Sub New (
    outlineColor As IPdfColor,
    linewidth As Double
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The width of outlines.
See Also

Reference

PdfBaseShape Class
PdfBaseShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Constructor (IPdfColor, PdfLineStyle, IPdfColor)

Initializes a new instance of the PdfBaseShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseShape(
    IPdfColor outlineColor,
    PdfLineStyle style,
    IPdfColor fillColor
)
Protected Sub New (
    outlineColor As IPdfColor,
    style As PdfLineStyle,
    fillColor As IPdfColor
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfBaseShape Class
PdfBaseShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Constructor (IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfBaseShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseShape(
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor
)
Protected Sub New (
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The width of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfBaseShape Class
PdfBaseShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Properties

The PdfBaseShape type exposes the following members.

Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip.
Public property | FillColor | Gets or sets the color of the fill.
Public property | Location | Gets or sets the location.
Public property | Name | Gets or sets the name of the IPdfRenderable object.
Public property | OutlineColor | Gets or sets the color of the outline.
Public property | Rotation | Gets or sets the rotation in degrees.
Public property | Scale | Gets or sets the scale.
Public property | Style | Gets or sets the style.
Top
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Clip Property

PdfBaseShapeClip Property

Gets or sets a value indicating whether this PdfBaseShape shape will clip.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Clip { get; set; }
Public Property Clip As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the shape will clip; otherwise, false.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.FillColor Property

PdfBaseShapeFillColor Property

Gets or sets the color of the fill.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor FillColor { get; set; }
Public Property FillColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the fill.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Location Property

PdfBaseShapeLocation Property

Gets or sets the location.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint Location { get; set; }
Public Property Location As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The location of the shape.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Name Property

PdfBaseShapeName Property

Gets or sets the name of the IPdfRenderable object.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the IPdfRenderable object.

Implements

IPdfRenderableName
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.OutlineColor Property

PdfBaseShapeOutlineColor Property

Gets or sets the color of the outline.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor OutlineColor { get; set; }
Public Property OutlineColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the outline.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Rotation Property

PdfBaseShapeRotation Property

Gets or sets the rotation in degrees.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set

Property Value

Type: Double
The rotation of the shape in degrees.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Scale Property

PdfBaseShapeScale Property

Gets or sets the scale.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint Scale { get; set; }
Public Property Scale As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The scale of the shape.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Style Property

PdfBaseShapeStyle Property

Gets or sets the style.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfLineStyle Style { get; set; }
Public Property Style As PdfLineStyle
    Get
    Set

Property Value

Type: PdfLineStyle
The style.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape Methods

The PdfBaseShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Protected method | CloneInstance | Clones the instance.
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape.
Protected method | DrawShape | Draws the shape.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed.
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed.
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested
Public method | Render | Generates the PDF.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Clone Method

PdfBaseShapeClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.CloneInstance Method

PdfBaseShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PdfBaseShape CloneInstance()
Protected MustOverride Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.CopyBaseShapePropertiesTo Method

PdfBaseShapeCopyBaseShapePropertiesTo Method

Copies the base shape properties to the parameter shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyBaseShapePropertiesTo(
    PdfBaseShape other,
    bool copyTransform
)
Public Sub CopyBaseShapePropertiesTo (
    other As PdfBaseShape,
    copyTransform As Boolean
)

Parameters

other
Type: Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
The parameter shape.
copyTransform
Type: SystemBoolean
if set to true [copy transform].
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.DrawShape Method

PdfBaseShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void DrawShape(
    PdfPageRenderer r
)
Protected MustOverride Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.GenerateTransform Method

PdfBaseShapeGenerateTransform Method

Generates the default transform based on Scale, Rotate, and Translate.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual PdfTransform GenerateTransform()
Protected Overridable Function GenerateTransform As PdfTransform

Return Value

Type: PdfTransform
the PdfTransform based on the Scale, Rotate, and Translate properties.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.NotifyResourceRenamed Method

PdfBaseShapeNotifyResourceRenamed Method

Notifies a resource consumer that a resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.OnResourceRenamed Method

PdfBaseShapeOnResourceRenamed Method

Called when a resource in the base shape has been renamed.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Protected Overridable Sub OnResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.OnResourcesRequested Method

PdfBaseShapeOnResourcesRequested Method

Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual IEnumerable<string> OnResourcesRequested(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Protected Overridable Function OnResourcesRequested (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.Render Method

PdfBaseShapeRender Method

Generates the PDF.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual void Render(
    PdfPageRenderer r
)
Public Overridable Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.

Implements

IPdfRenderableRender(PdfPageRenderer)
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseShape.ResourcesUsed Method

PdfBaseShapeResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

PdfBaseShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Class

The base class for making pdf text shapes. It provides the basic settings to control fonts and transformations automatically.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
More...

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class PdfBaseTextShape : PdfBaseShape
<SerializableAttribute>
Public MustInherit Class PdfBaseTextShape
    Inherits PdfBaseShape

The PdfBaseTextShape type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBaseTextShape(PdfBaseTextShape) | Initializes a new instance of the PdfBaseTextShape class.
Public method | PdfBaseTextShape(String, Double) | Initializes a new instance of the PdfBaseTextShape class.
Protected method | PdfBaseTextShape(String, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfBaseTextShape class.
Public method | PdfBaseTextShape(String, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfBaseTextShape class.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font.
Public property | FontSize | Gets or sets the size of the font.
Public property | HorizontalScaling | Gets or sets the horizontal scaling.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | WordSpacing | Gets or sets the word spacing.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment.
 | GetTextStartOffset(Double, Double, PdfTextAlignment) | Gets the text start offset for a line of text. This is used to align text based on the alignment.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Overrides PdfBaseShapeOnResourceRenamed(GlobalResources, PdfResourceClass, String, String).)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Overrides PdfBaseShapeOnResourcesRequested(GlobalResources, PdfResourceClass).)
Public method | Render | Generates the PDF display list objects. (Overrides PdfBaseShapeRender(PdfPageRenderer).)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesDynamicPdfTextBox
Atalasoft.PdfDoc.Generating.ShapesPdfClippedTextLine
Atalasoft.PdfDoc.Generating.ShapesPdfStyledTextBox
Atalasoft.PdfDoc.Generating.ShapesPdfTextBox
Atalasoft.PdfDoc.Generating.ShapesPdfTextLine
Atalasoft.PdfDoc.Generating.ShapesPdfTextPath


PdfBaseTextShape Constructor

Overload List
 | Name | Description
Public method | PdfBaseTextShape(PdfBaseTextShape) | Initializes a new instance of the PdfBaseTextShape class.
Public method | PdfBaseTextShape(String, Double) | Initializes a new instance of the PdfBaseTextShape class.
Protected method | PdfBaseTextShape(String, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfBaseTextShape class.
Public method | PdfBaseTextShape(String, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfBaseTextShape class.
Top
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Constructor (PdfBaseTextShape)

Initializes a new instance of the PdfBaseTextShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBaseTextShape(
    PdfBaseTextShape copy
)
Public Sub New (
    copy As PdfBaseTextShape
)

Parameters

copy
Type: Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
The PdfBaseTextShape to copy from.
See Also

Reference

PdfBaseTextShape Class
PdfBaseTextShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Constructor (String, Double)

Initializes a new instance of the PdfBaseTextShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBaseTextShape(
    string fontName,
    double fontSize
)
Public Sub New (
    fontName As String,
    fontSize As Double
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
See Also

Reference

PdfBaseTextShape Class
PdfBaseTextShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Constructor (String, Double, IPdfColor, PdfLineStyle, IPdfColor)

Initializes a new instance of the PdfBaseTextShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseTextShape(
    string fontName,
    double fontSize,
    IPdfColor outlineColor,
    PdfLineStyle style,
    IPdfColor fillColor
)
Protected Sub New (
    fontName As String,
    fontSize As Double,
    outlineColor As IPdfColor,
    style As PdfLineStyle,
    fillColor As IPdfColor
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfBaseTextShape Class
PdfBaseTextShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Constructor (String, Double, IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfBaseTextShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBaseTextShape(
    string fontName,
    double fontSize,
    IPdfColor outlineColor,
    double lineWidth,
    IPdfColor fillColor
)
Public Sub New (
    fontName As String,
    fontSize As Double,
    outlineColor As IPdfColor,
    lineWidth As Double,
    fillColor As IPdfColor
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
lineWidth
Type: SystemDouble
Width of the line.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfBaseTextShape Class
PdfBaseTextShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Properties

The PdfBaseTextShape type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font.
Public property | FontSize | Gets or sets the size of the font.
Public property | HorizontalScaling | Gets or sets the horizontal scaling.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | WordSpacing | Gets or sets the word spacing.
Top
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.Alignment Property

PdfBaseTextShapeAlignment Property

Gets or sets the alignment.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual PdfTextAlignment Alignment { get; set; }
Public Overridable Property Alignment As PdfTextAlignment
    Get
    Set

Property Value

Type: PdfTextAlignment
The alignment.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.FontName Property

PdfBaseTextShapeFontName Property

Gets or sets the name of the font.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set

Property Value

Type: String
The name of the font.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.FontSize Property

PdfBaseTextShapeFontSize Property

Gets or sets the size of the font.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double FontSize { get; set; }
Public Property FontSize As Double
    Get
    Set

Property Value

Type: Double
The size of the font.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.HorizontalScaling Property

PdfBaseTextShapeHorizontalScaling Property

Gets or sets the horizontal scaling.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double HorizontalScaling { get; set; }
Public Property HorizontalScaling As Double
    Get
    Set

Property Value

Type: Double
The horizontal scaling value in percent (100 is default).
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.RenderMode Property

PdfBaseTextShapeRenderMode Property

Gets or sets the render mode.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextRenderMode RenderMode { get; set; }
Public Property RenderMode As PdfTextRenderMode
    Get
    Set

Property Value

Type: PdfTextRenderMode
The render mode.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.WordSpacing Property

PdfBaseTextShapeWordSpacing Property

Gets or sets the word spacing.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double WordSpacing { get; set; }
Public Property WordSpacing As Double
    Get
    Set

Property Value

Type: Double
The word spacing in pdf text points (0 is default).
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape Methods

The PdfBaseTextShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment.
 | GetTextStartOffset(Double, Double, PdfTextAlignment) | Gets the text start offset for a line of text. This is used to align text based on the alignment.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Overrides PdfBaseShapeOnResourceRenamed(GlobalResources, PdfResourceClass, String, String).)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Overrides PdfBaseShapeOnResourcesRequested(GlobalResources, PdfResourceClass).)
Public method | Render | Generates the PDF display list objects. (Overrides PdfBaseShapeRender(PdfPageRenderer).)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.CloneInstance Method

PdfBaseTextShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract PdfBaseShape CloneInstance()
Protected MustOverride Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.DrawShape Method

PdfBaseTextShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected abstract void DrawShape(
    PdfPageRenderer r
)
Protected MustOverride Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.GetTextStartOffset Method

PdfBaseTextShapeGetTextStartOffset Method

Overload List
 | Name | Description
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment.
 | GetTextStartOffset(Double, Double, PdfTextAlignment) | Gets the text start offset for a line of text. This is used to align text based on the alignment.
Top
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.GetTextStartOffset Method (Double, Double)

PdfBaseTextShapeGetTextStartOffset Method (Double, Double)

Gets the text start offset for a line of text. This is used to align text based on the alignment.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double GetTextStartOffset(
    double textLength,
    double spaceLength
)
Public Function GetTextStartOffset (
    textLength As Double,
    spaceLength As Double
) As Double

Parameters

textLength
Type: SystemDouble
Length of the text.
spaceLength
Type: SystemDouble
Length of the space.

Return Value

Type: Double
A copy of this shape.
See Also

Reference

PdfBaseTextShape Class
GetTextStartOffset Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.GetTextStartOffset Method (Double, Double, PdfTextAlignment)

PdfBaseTextShapeGetTextStartOffset Method (Double, Double, PdfTextAlignment)

Gets the text start offset for a line of text. This is used to align text based on the alignment.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static double GetTextStartOffset(
    double textLength,
    double spaceLength,
    PdfTextAlignment alignment
)
Public Shared Function GetTextStartOffset (
    textLength As Double,
    spaceLength As Double,
    alignment As PdfTextAlignment
) As Double

Parameters

textLength
Type: SystemDouble
Length of the text.
spaceLength
Type: SystemDouble
Length of the space.
alignment
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextAlignment
The alignment.

Return Value

Type: Double
The offset for the line start
See Also

Reference

PdfBaseTextShape Class
GetTextStartOffset Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.OnResourceRenamed Method

PdfBaseTextShapeOnResourceRenamed Method

Called when a resource in the shape has been renamed.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Protected Overrides Sub OnResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.OnResourcesRequested Method

PdfBaseTextShapeOnResourcesRequested Method

Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IEnumerable<string> OnResourcesRequested(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Protected Overrides Function OnResourcesRequested (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfBaseTextShape.Render Method

PdfBaseTextShapeRender Method

Generates the PDF display list objects.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Render(
    PdfPageRenderer r
)
Public Overrides Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.

Implements

IPdfRenderableRender(PdfPageRenderer)
See Also

Reference

PdfBaseTextShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Class

A PdfBaseShape overload which draws a circle based on a center point and a radius.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfCircle

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfCircle : PdfBaseShape
<SerializableAttribute>
Public Class PdfCircle
    Inherits PdfBaseShape

The PdfCircle type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCircle(PdfPoint, Double, IPdfColor) | Initializes a new instance of the PdfCircle class.
Public method | PdfCircle(PdfPoint, Double, IPdfColor, Double) | Initializes a new instance of the PdfCircle class.
Public method | PdfCircle(PdfPoint, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfCircle class.
Public method | PdfCircle(PdfPoint, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfCircle class.
Top
Properties
 | Name | Description
Public property | Center | Gets or sets the center.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Radius | Gets or sets the radius.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
       doc.Pages.Add(PdfDefaultPages.Letter);
       for (int i = 0; i < 100; i++)
            doc.Pages[0].DrawingList.Add(new PdfCircle(new PdfPoint(p.MediaBox.Width / 2, p.MediaBox.Height / 2), i * 5, PdfColorFactory.FromGray((100-i)/100.0), 1.0));
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Constructor

Overload List
 | Name | Description
Public method | PdfCircle(PdfPoint, Double, IPdfColor) | Initializes a new instance of the PdfCircle class.
Public method | PdfCircle(PdfPoint, Double, IPdfColor, Double) | Initializes a new instance of the PdfCircle class.
Public method | PdfCircle(PdfPoint, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfCircle class.
Public method | PdfCircle(PdfPoint, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfCircle class.
Top
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Constructor (PdfPoint, Double, IPdfColor)

Initializes a new instance of the PdfCircle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCircle(
    PdfPoint center,
    double radius,
    IPdfColor fillColor
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    fillColor As IPdfColor
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle.
radius
Type: SystemDouble
The radius of the circle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill of the circle.
See Also

Reference

PdfCircle Class
PdfCircle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Constructor (PdfPoint, Double, IPdfColor, Double)

Initializes a new instance of the PdfCircle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCircle(
    PdfPoint center,
    double radius,
    IPdfColor outlineColor,
    double linewidth
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    outlineColor As IPdfColor,
    linewidth As Double
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle.
radius
Type: SystemDouble
The radius of the circle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline of the circle.
linewidth
Type: SystemDouble
The linewidth of the outline of the circle.
See Also

Reference

PdfCircle Class
PdfCircle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Constructor (PdfPoint, Double, IPdfColor, PdfLineStyle, IPdfColor)

Initializes a new instance of the PdfCircle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCircle(
    PdfPoint center,
    double radius,
    IPdfColor outlineColor,
    PdfLineStyle style,
    IPdfColor fillColor
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    outlineColor As IPdfColor,
    style As PdfLineStyle,
    fillColor As IPdfColor
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle.
radius
Type: SystemDouble
The radius of the circle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline of the circle.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill of the circle.
See Also

Reference

PdfCircle Class
PdfCircle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Constructor (PdfPoint, Double, IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfCircle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfCircle(
    PdfPoint center,
    double radius,
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor
)
Public Sub New (
    center As PdfPoint,
    radius As Double,
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor
)

Parameters

center
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The center of the circle.
radius
Type: SystemDouble
The radius of the circle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline of the circle.
linewidth
Type: SystemDouble
The linewidth of the outline of the circle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill of the circle.
See Also

Reference

PdfCircle Class
PdfCircle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Properties

The PdfCircle type exposes the following members.

Properties
 | Name | Description
Public property | Center | Gets or sets the center.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Radius | Gets or sets the radius.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle.Center Property

PdfCircleCenter Property

Gets or sets the center.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint Center { get; set; }
Public Property Center As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The center of the circle.
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle.Radius Property

PdfCircleRadius Property

Gets or sets the radius.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The radius of the circle.
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle Methods

The PdfCircle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle.CloneInstance Method

PdfCircleCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfCircle.DrawShape Method

PdfCircleDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfCircle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine Class

A pdf text object which writes text and clips to a rectangle. This object is best used to make spreadsheet like trimming of long strings to fit into a cell of a table.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesPdfClippedTextLine

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfClippedTextLine : PdfBaseTextShape
<SerializableAttribute>
Public Class PdfClippedTextLine
    Inherits PdfBaseTextShape

The PdfClippedTextLine type exposes the following members.

Constructors
 | Name | Description
Public method | PdfClippedTextLine(String, String, PdfBounds, PdfFontManager) | Initializes a new instance of the PdfClippedTextLine class while intelligently figuring out fontsize and positioning.
Public method | PdfClippedTextLine(String, String, Double, PdfPoint, PdfBounds) | Initializes a new instance of the PdfClippedTextLine class.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | ClipBounds | Gets or sets the clip bounds.
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Overrides PdfBaseTextShapeRender(PdfPageRenderer).)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
for(int i=0; i < 5;i++)
{
    PdfClippedTextLine line = new PdfClippedTextLine(TextValues[i], new PdfBounds(100*i,200,100,50), doc.GlobalResources.Fonts);
    doc.DisplayList.Add(line);
}
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine Constructor

Overload List
 | Name | Description
Public method | PdfClippedTextLine(String, String, PdfBounds, PdfFontManager) | Initializes a new instance of the PdfClippedTextLine class while intelligently figuring out fontsize and positioning.
Public method | PdfClippedTextLine(String, String, Double, PdfPoint, PdfBounds) | Initializes a new instance of the PdfClippedTextLine class.
Top
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine Constructor (String, String, PdfBounds, PdfFontManager)

Initializes a new instance of the PdfClippedTextLine class while intelligently figuring out fontsize and positioning.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfClippedTextLine(
    string text,
    string fontName,
    PdfBounds bounds,
    PdfFontManager manager
)
Public Sub New (
    text As String,
    fontName As String,
    bounds As PdfBounds,
    manager As PdfFontManager
)

Parameters

text
Type: SystemString
The text.
fontName
Type: SystemString
Name of the font.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
manager
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager
The manager.
See Also

Reference

PdfClippedTextLine Class
PdfClippedTextLine Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine Constructor (String, String, Double, PdfPoint, PdfBounds)

Initializes a new instance of the PdfClippedTextLine class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfClippedTextLine(
    string text,
    string fontName,
    double fontSize,
    PdfPoint location,
    PdfBounds clipBounds
)
Public Sub New (
    text As String,
    fontName As String,
    fontSize As Double,
    location As PdfPoint,
    clipBounds As PdfBounds
)

Parameters

text
Type: SystemString
The text.
fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The text start point.
clipBounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The clip bounds.
See Also

Reference

PdfClippedTextLine Class
PdfClippedTextLine Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine Properties

The PdfClippedTextLine type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | ClipBounds | Gets or sets the clip bounds.
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine.ClipBounds Property

PdfClippedTextLineClipBounds Property

Gets or sets the clip bounds.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds ClipBounds { get; set; }
Public Property ClipBounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The clip bounds.
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine.Text Property

PdfClippedTextLineText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine Methods

The PdfClippedTextLine type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Overrides PdfBaseTextShapeRender(PdfPageRenderer).)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine.CloneInstance Method

PdfClippedTextLineCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine.DrawShape Method

PdfClippedTextLineDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfClippedTextLine.Render Method

PdfClippedTextLineRender Method

Generates the PDF display list objects.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Render(
    PdfPageRenderer r
)
Public Overrides Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.

Implements

IPdfRenderableRender(PdfPageRenderer)
See Also

Reference

PdfClippedTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape Class

The shape used to place an image on a page
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfImageShape

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfImageShape : PdfBaseShape,
    IPdfResourceConsumer
<SerializableAttribute>
Public Class PdfImageShape
    Inherits PdfBaseShape
    Implements IPdfResourceConsumer

The PdfImageShape type exposes the following members.

Constructors
 | Name | Description
Public method | PdfImageShape | Initializes a new instance of the PdfImageShape class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | ImageName | Gets or sets the name of the image.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when [resource renamed]. (Overrides PdfBaseShapeOnResourceRenamed(GlobalResources, PdfResourceClass, String, String).)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Overrides PdfBaseShapeOnResourcesRequested(GlobalResources, PdfResourceClass).)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape Constructor

Initializes a new instance of the PdfImageShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfImageShape(
    string imageName,
    PdfBounds bounds
)
Public Sub New (
    imageName As String,
    bounds As PdfBounds
)

Parameters

imageName
Type: SystemString
Name of the image.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape Properties

The PdfImageShape type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | ImageName | Gets or sets the name of the image.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape.Bounds Property

PdfImageShapeBounds Property

Gets or sets the bounds.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds.
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape.ImageName Property

PdfImageShapeImageName Property

Gets or sets the name of the image.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set

Property Value

Type: String
The name of the image.
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape Methods

The PdfImageShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when [resource renamed]. (Overrides PdfBaseShapeOnResourceRenamed(GlobalResources, PdfResourceClass, String, String).)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Overrides PdfBaseShapeOnResourcesRequested(GlobalResources, PdfResourceClass).)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape.CloneInstance Method

PdfImageShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape.DrawShape Method

PdfImageShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape.OnResourceRenamed Method

PdfImageShapeOnResourceRenamed Method

Called when [resource renamed].

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Protected Overrides Sub OnResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The gr.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original.
newName
Type: SystemString
The new name.
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfImageShape.OnResourcesRequested Method

PdfImageShapeOnResourcesRequested Method

Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IEnumerable<string> OnResourcesRequested(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Protected Overrides Function OnResourcesRequested (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.
See Also

Reference

PdfImageShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent Class

PdfMarkedContent represents an area within drawing on a PDF page or in a DrawingTemplate that is marked as having special meaning. For example, certain classes of annotations that have customized appearances use "marked content" to set aside an area that reserved for customizable or user-entered text.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfMarkedContent

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfMarkedContent : IPdfRenderable,
    IPdfResourceConsumer, IEnumerable<IPdfRenderable>, IEnumerable, IPdfRenderableContainer
<SerializableAttribute>
Public Class PdfMarkedContent
    Implements IPdfRenderable, IPdfResourceConsumer, IEnumerable(Of IPdfRenderable),
    IEnumerable, IPdfRenderableContainer

The PdfMarkedContent type exposes the following members.

Constructors
 | Name | Description
Public method | PdfMarkedContent | Initializes a new instance of the PdfMarkedContent class. Tag will be "unknown".
Public method | PdfMarkedContent(String) | Initializes a new instance of the PdfMarkedContent class with the given tag.
Top
Properties
 | Name | Description
Public property | DrawingList | Gets the drawing list for the marked content.
 | Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Public property | Tag | Gets or sets the tag to the value specified.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies that the resource was renamed.
Public method | PostRender | This method is called after rendering is complete. This is an opportunity for the object to clean up previous work or restore prior state. The value returned by PreRender(PdfPageRenderer) is passed in the parameter memento.
Public method | PreRender | This method is called before rendering happens. This is an opportunity for the object to create or save information for later use or restoration. The value returned is a memento that will be passed back to the object when PostRender(PdfPageRenderer, Object) is called.
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
In order to create text marked for an annotation, you might do this:
PdfMarkedContent content = new PdfMarkedContent("Tx");
PdfTextLine line = new PdfTextLine(myFontName, 10.0, "This is marked content", new PdfPoint(36, 700));
content.DrawingList.Add(line);
page.DrawingList.Add(content);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent Constructor

Overload List
 | Name | Description
Public method | PdfMarkedContent | Initializes a new instance of the PdfMarkedContent class. Tag will be "unknown".
Public method | PdfMarkedContent(String) | Initializes a new instance of the PdfMarkedContent class with the given tag.
Top
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent Constructor

Initializes a new instance of the PdfMarkedContent class. Tag will be "unknown".

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkedContent()
Public Sub New
See Also

Reference

PdfMarkedContent Class
PdfMarkedContent Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent Constructor (String)

Initializes a new instance of the PdfMarkedContent class with the given tag.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfMarkedContent(
    string tag
)
Public Sub New (
    tag As String
)

Parameters

tag
Type: SystemString
The tag.
Remarks
The tag must be non-null and non-empty.
See Also

Reference

PdfMarkedContent Class
PdfMarkedContent Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent Properties

The PdfMarkedContent type exposes the following members.

Properties
 | Name | Description
Public property | DrawingList | Gets the drawing list for the marked content.
 | Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Public property | Tag | Gets or sets the tag to the value specified.
Top
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.DrawingList Property

PdfMarkedContentDrawingList Property

Gets the drawing list for the marked content.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDrawingList DrawingList { get; }
Public ReadOnly Property DrawingList As PdfDrawingList
    Get

Property Value

Type: PdfDrawingList
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.Name Property

PdfMarkedContentName Property

Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the object.

Implements

IPdfRenderableName
Examples
Copy
foreach (IPdfRenderable namedGroup in list.FindAll(item => item.Name == "Group") {
ProcessGroup(namedGroup);
}
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.Tag Property

PdfMarkedContentTag Property

Gets or sets the tag to the value specified.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set

Property Value

Type: String
The tag.
Remarks
The tag must be non-null and non-empty.
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent Methods

The PdfMarkedContent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies that the resource was renamed.
Public method | PostRender | This method is called after rendering is complete. This is an opportunity for the object to clean up previous work or restore prior state. The value returned by PreRender(PdfPageRenderer) is passed in the parameter memento.
Public method | PreRender | This method is called before rendering happens. This is an opportunity for the object to create or save information for later use or restoration. The value returned is a memento that will be passed back to the object when PostRender(PdfPageRenderer, Object) is called.
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.GetEnumerator Method

PdfMarkedContentGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<IPdfRenderable> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IPdfRenderable)

Return Value

Type: IEnumeratorIPdfRenderable
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.NotifyResourceRenamed Method

PdfMarkedContentNotifyResourceRenamed Method

Notifies that the resource was renamed.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void NotifyResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Public Sub NotifyResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original.
newName
Type: SystemString
The new name.

Implements

IPdfResourceConsumerNotifyResourceRenamed(GlobalResources, PdfResourceClass, String, String)
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.PostRender Method

PdfMarkedContentPostRender Method

This method is called after rendering is complete. This is an opportunity for the object to clean up previous work or restore prior state. The value returned by PreRender(PdfPageRenderer) is passed in the parameter memento.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void PostRender(
    PdfPageRenderer r,
    Object memento
)
Public Sub PostRender (
    r As PdfPageRenderer,
    memento As Object
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The r.
memento
Type: SystemObject
The memento.

Implements

IPdfRenderableContainerPostRender(PdfPageRenderer, Object)
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.PreRender Method

PdfMarkedContentPreRender Method

This method is called before rendering happens. This is an opportunity for the object to create or save information for later use or restoration. The value returned is a memento that will be passed back to the object when PostRender(PdfPageRenderer, Object) is called.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object PreRender(
    PdfPageRenderer r
)
Public Function PreRender (
    r As PdfPageRenderer
) As Object

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The renderer.

Return Value

Type: Object
A memento for rendering, passed back in PostRender(PdfPageRenderer, Object)

Implements

IPdfRenderableContainerPreRender(PdfPageRenderer)
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.Render Method

PdfMarkedContentRender Method

Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfPageRenderer r
)
Public Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The PdfPageRenderer for generating PDF.

Implements

IPdfRenderableRender(PdfPageRenderer)
Examples
Copy
public void GeneratePdf(PdfPageRenderer r)
{
w.DrawingSurface.Begin();
w.DrawingSurface.AddRect(MyBounds); // place a rectangle
w.DrawingSurface.Stroke(PdfLineStyle.Default, MyColor); // draw its outline in black
w.DrawingSurface.End();
}
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfMarkedContent.ResourcesUsed Method

PdfMarkedContentResourcesUsed Method

Reports a list of all resources consumed by the object of the given class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ResourcesUsed(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Public Function ResourcesUsed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.

Implements

IPdfResourceConsumerResourcesUsed(GlobalResources, PdfResourceClass)
See Also

Reference

PdfMarkedContent Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Class

A PdfBaseShape that contains a series of operations to define a custom drawing.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfPath

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfPath : PdfBaseShape
<SerializableAttribute>
Public Class PdfPath
    Inherits PdfBaseShape

The PdfPath type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPath(IPdfColor) | Initializes a new instance of the PdfPath class.
Public method | PdfPath(PdfBaseShape) | Initializes a new instance of the PdfPath class.
Public method | PdfPath(IPdfColor, Double) | Initializes a new instance of the PdfPath class.
Public method | PdfPath(IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfPath class.
Top
Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FillMethod | Gets or sets the fill method.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | PathOperations | Gets the path operations that comprise the shape. This will be a list of operations that will be performed in order.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | Close | Closes the path to the previous MoveTo command.
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Public method | CurveTo(PdfPoint, PdfPoint, PdfPoint) | Curves to the destination point from the previous point using the sourceControlPoint and destinationControl point to render the curve
Public method | CurveTo(Double, Double, Double, Double, Double, Double) | Curves to the destination point from the previous point using the (x1, y1) as the source control point, (x2, y2) as the destination control point and (x3, y3) as the destination point to render the curve
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetBounds | Gets the bounding box of the PdfPath.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LineTo(PdfPoint) | Draws a line from the current drawing point to the parameter
Public method | LineTo(Double, Double) | Draws a line from the current drawing point to (x, y)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo(PdfPoint) | Sets the current drawing point to the parameter
Public method | MoveTo(Double, Double) | Sets the current drawing point to (x, y)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
page.DrawingList.Add(path);
PdfPath path = new PdfPath(PdfColorFactory.FromGray(0.0), 2.0);
path.MoveTo(new PdfPoint(0, 0));
path.LineTo(new PdfPoint(100, 150));
path.CurveTo(new PdfPoint(100, 250), new PdfPoint(200, 250), new PdfPoint(200, 150));
path.LineTo(new PdfPoint(300, 40));
path.CurveTo(new PdfPoint(340, 0), new PdfPoint(340, 0), new PdfPoint(380, 40));
path.CurveTo(new PdfPoint(380,100), new PdfPoint(380,100),new PdfPoint(600, 40));
page.DrawingList.Add(path);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Constructor

Overload List
 | Name | Description
Public method | PdfPath(IPdfColor) | Initializes a new instance of the PdfPath class.
Public method | PdfPath(PdfBaseShape) | Initializes a new instance of the PdfPath class.
Public method | PdfPath(IPdfColor, Double) | Initializes a new instance of the PdfPath class.
Public method | PdfPath(IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfPath class.
Top
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Constructor (IPdfColor)

Initializes a new instance of the PdfPath class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath(
    IPdfColor fillColor
)
Public Sub New (
    fillColor As IPdfColor
)

Parameters

fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfPath Class
PdfPath Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Constructor (PdfBaseShape)

Initializes a new instance of the PdfPath class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath(
    PdfBaseShape s
)
Public Sub New (
    s As PdfBaseShape
)

Parameters

s
Type: Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
the object to copy from
See Also

Reference

PdfPath Class
PdfPath Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Constructor (IPdfColor, Double)

Initializes a new instance of the PdfPath class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath(
    IPdfColor outlineColor,
    double linewidth
)
Public Sub New (
    outlineColor As IPdfColor,
    linewidth As Double
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The width of the outlines of the shape.
See Also

Reference

PdfPath Class
PdfPath Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Constructor (IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfPath class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath(
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor
)
Public Sub New (
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor
)

Parameters

outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline of the shape.
linewidth
Type: SystemDouble
The width of outlines of the shape.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill if the shape.
See Also

Reference

PdfPath Class
PdfPath Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Properties

The PdfPath type exposes the following members.

Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FillMethod | Gets or sets the fill method.
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | PathOperations | Gets the path operations that comprise the shape. This will be a list of operations that will be performed in order.
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.FillMethod Property

PdfPathFillMethod Property

Gets or sets the fill method.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFillMethod FillMethod { get; set; }
Public Property FillMethod As PdfFillMethod
    Get
    Set

Property Value

Type: PdfFillMethod
The fill method.
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.PathOperations Property

PdfPathPathOperations Property

Gets the path operations that comprise the shape. This will be a list of operations that will be performed in order.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IList<PdfPathOperation> PathOperations { get; }
Public ReadOnly Property PathOperations As IList(Of PdfPathOperation)
    Get

Property Value

Type: IListPdfPathOperation
The path operations that comprise the shape.
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath Methods

The PdfPath type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | Close | Closes the path to the previous MoveTo command.
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Public method | CurveTo(PdfPoint, PdfPoint, PdfPoint) | Curves to the destination point from the previous point using the sourceControlPoint and destinationControl point to render the curve
Public method | CurveTo(Double, Double, Double, Double, Double, Double) | Curves to the destination point from the previous point using the (x1, y1) as the source control point, (x2, y2) as the destination control point and (x3, y3) as the destination point to render the curve
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetBounds | Gets the bounding box of the PdfPath.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LineTo(PdfPoint) | Draws a line from the current drawing point to the parameter
Public method | LineTo(Double, Double) | Draws a line from the current drawing point to (x, y)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo(PdfPoint) | Sets the current drawing point to the parameter
Public method | MoveTo(Double, Double) | Sets the current drawing point to (x, y)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.CloneInstance Method

PdfPathCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.Close Method

PdfPathClose Method

Closes the path to the previous MoveTo command.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath Close()
Public Function Close As PdfPath

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.CurveTo Method

PdfPathCurveTo Method

Overload List
 | Name | Description
Public method | CurveTo(PdfPoint, PdfPoint, PdfPoint) | Curves to the destination point from the previous point using the sourceControlPoint and destinationControl point to render the curve
Public method | CurveTo(Double, Double, Double, Double, Double, Double) | Curves to the destination point from the previous point using the (x1, y1) as the source control point, (x2, y2) as the destination control point and (x3, y3) as the destination point to render the curve
Top
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.CurveTo Method (PdfPoint, PdfPoint, PdfPoint)

PdfPathCurveTo Method (PdfPoint, PdfPoint, PdfPoint)

Curves to the destination point from the previous point using the sourceControlPoint and destinationControl point to render the curve

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath CurveTo(
    PdfPoint sourceControlPoint,
    PdfPoint destinationControlPoint,
    PdfPoint destinationPoint
)
Public Function CurveTo (
    sourceControlPoint As PdfPoint,
    destinationControlPoint As PdfPoint,
    destinationPoint As PdfPoint
) As PdfPath

Parameters

sourceControlPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The source control point.
destinationControlPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination control point.
destinationPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination point.

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
CurveTo Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.CurveTo Method (Double, Double, Double, Double, Double, Double)

PdfPathCurveTo Method (Double, Double, Double, Double, Double, Double)

Curves to the destination point from the previous point using the (x1, y1) as the source control point, (x2, y2) as the destination control point and (x3, y3) as the destination point to render the curve

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath CurveTo(
    double x1,
    double y1,
    double x2,
    double y2,
    double x3,
    double y3
)
Public Function CurveTo (
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double,
    x3 As Double,
    y3 As Double
) As PdfPath

Parameters

x1
Type: SystemDouble
The x coordinate of the source control point
y1
Type: SystemDouble
The y coordinate of the source control point.
x2
Type: SystemDouble
The x coordinate of the destination control point.
y2
Type: SystemDouble
The y coordinate of the destination control point.
x3
Type: SystemDouble
The x coordinate of the destination point.
y3
Type: SystemDouble
The y coordinate of the destination point.

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
CurveTo Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.DrawShape Method

PdfPathDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.GetBounds Method

PdfPathGetBounds Method

Gets the bounding box of the PdfPath.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds GetBounds()
Public Function GetBounds As PdfBounds

Return Value

Type: PdfBounds
The smallest PdfBounds that contains all the path elements.
Remarks
Since Bezier curves never extend past their control points, this will return the PdfBounds that contains all the points of all the path operations. Note that this does not take into account line width or line end caps.
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.LineTo Method

PdfPathLineTo Method

Overload List
 | Name | Description
Public method | LineTo(PdfPoint) | Draws a line from the current drawing point to the parameter
Public method | LineTo(Double, Double) | Draws a line from the current drawing point to (x, y)
Top
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.LineTo Method (PdfPoint)

PdfPathLineTo Method (PdfPoint)

Draws a line from the current drawing point to the parameter

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath LineTo(
    PdfPoint p
)
Public Function LineTo (
    p As PdfPoint
) As PdfPath

Parameters

p
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to draw a line to.

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
LineTo Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.LineTo Method (Double, Double)

PdfPathLineTo Method (Double, Double)

Draws a line from the current drawing point to (x, y)

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath LineTo(
    double x,
    double y
)
Public Function LineTo (
    x As Double,
    y As Double
) As PdfPath

Parameters

x
Type: SystemDouble
The x coordinate.
y
Type: SystemDouble
The y coordinate.

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
LineTo Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.MoveTo Method

PdfPathMoveTo Method

Overload List
 | Name | Description
Public method | MoveTo(PdfPoint) | Sets the current drawing point to the parameter
Public method | MoveTo(Double, Double) | Sets the current drawing point to (x, y)
Top
See Also

Reference

PdfPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.MoveTo Method (PdfPoint)

PdfPathMoveTo Method (PdfPoint)

Sets the current drawing point to the parameter

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath MoveTo(
    PdfPoint p
)
Public Function MoveTo (
    p As PdfPoint
) As PdfPath

Parameters

p
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to move to.

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
MoveTo Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfPath.MoveTo Method (Double, Double)

PdfPathMoveTo Method (Double, Double)

Sets the current drawing point to (x, y)

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPath MoveTo(
    double x,
    double y
)
Public Function MoveTo (
    x As Double,
    y As Double
) As PdfPath

Parameters

x
Type: SystemDouble
The x coordinate.
y
Type: SystemDouble
The y coordinate.

Return Value

Type: PdfPath
The current path object.
See Also

Reference

PdfPath Class
MoveTo Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Class

A PdfBaseShape to draw a Rectangle.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfRectangle

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfRectangle : PdfBaseShape
<SerializableAttribute>
Public Class PdfRectangle
    Inherits PdfBaseShape

The PdfRectangle type exposes the following members.

Constructors
 | Name | Description
Public method | PdfRectangle(PdfBounds, IPdfColor) | Initializes a new instance of the PdfRectangle class.
Public method | PdfRectangle(PdfBounds, IPdfColor, Double) | Initializes a new instance of the PdfRectangle class.
Public method | PdfRectangle(PdfBounds, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfRectangle class.
Public method | PdfRectangle(PdfBounds, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfRectangle class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds of the rectangle.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = PdfDefaultPages.Letter;
doc.Pages.Add(page);
PdfRectangle rect = new PdfRectangle(new PdfBounds(0, 0, 100, 100), PdfColorFactory.FromRgb(.25, .75, .15));
rect.OutlineColor = PdfColorFactory.FromRgb(0, 0, .25);
page.DrawingList.Add(rect);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Constructor

Overload List
 | Name | Description
Public method | PdfRectangle(PdfBounds, IPdfColor) | Initializes a new instance of the PdfRectangle class.
Public method | PdfRectangle(PdfBounds, IPdfColor, Double) | Initializes a new instance of the PdfRectangle class.
Public method | PdfRectangle(PdfBounds, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfRectangle class.
Public method | PdfRectangle(PdfBounds, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfRectangle class.
Top
See Also

Reference

PdfRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Constructor (PdfBounds, IPdfColor)

Initializes a new instance of the PdfRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRectangle(
    PdfBounds bounds,
    IPdfColor fillColor
)
Public Sub New (
    bounds As PdfBounds,
    fillColor As IPdfColor
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rectangle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfRectangle Class
PdfRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Constructor (PdfBounds, IPdfColor, Double)

Initializes a new instance of the PdfRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRectangle(
    PdfBounds bounds,
    IPdfColor outlineColor,
    double linewidth
)
Public Sub New (
    bounds As PdfBounds,
    outlineColor As IPdfColor,
    linewidth As Double
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rectangle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The linewidth of the outline.
See Also

Reference

PdfRectangle Class
PdfRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Constructor (PdfBounds, IPdfColor, PdfLineStyle, IPdfColor)

Initializes a new instance of the PdfRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRectangle(
    PdfBounds bounds,
    IPdfColor outlineColor,
    PdfLineStyle style,
    IPdfColor fillColor
)
Public Sub New (
    bounds As PdfBounds,
    outlineColor As IPdfColor,
    style As PdfLineStyle,
    fillColor As IPdfColor
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rectangle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfRectangle Class
PdfRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Constructor (PdfBounds, IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRectangle(
    PdfBounds bounds,
    IPdfColor outlineColor,
    double linewidth,
    IPdfColor fillColor
)
Public Sub New (
    bounds As PdfBounds,
    outlineColor As IPdfColor,
    linewidth As Double,
    fillColor As IPdfColor
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rectangle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
linewidth
Type: SystemDouble
The linewidth of the outline.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfRectangle Class
PdfRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Properties

The PdfRectangle type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds of the rectangle.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

PdfRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle.Bounds Property

PdfRectangleBounds Property

Gets or sets the bounds of the rectangle.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds of the rectangle.
See Also

Reference

PdfRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle Methods

The PdfRectangle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle.CloneInstance Method

PdfRectangleCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRectangle.DrawShape Method

PdfRectangleDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Class

A PdfBaseShape for making RoundedRectangles
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfRoundedRectangle

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfRoundedRectangle : PdfBaseShape
<SerializableAttribute>
Public Class PdfRoundedRectangle
    Inherits PdfBaseShape

The PdfRoundedRectangle type exposes the following members.

Constructors
 | Name | Description
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor) | Initializes a new instance of the PdfRoundedRectangle class.
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor, Double) | Initializes a new instance of the PdfRoundedRectangle class.
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor, IPdfColor, PdfLineStyle) | Initializes a new instance of the PdfRoundedRectangle class.
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor, IPdfColor, Double) | Initializes a new instance of the PdfRoundedRectangle class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | CurveRadius | Gets or sets the curve radius.
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = PdfDefaultPages.Letter;
doc.Pages.Add(page);
PdfRoundedRectangle rect = new PdfRoundedRectangle(new PdfBounds(0, 0, 72, 72), 12.0, PdfColorFactory.FromGray(0.0), 2.0);
PdfRoundedRectangle rect2 = new PdfRoundedRectangle(new PdfBounds(72 * 2, 72 * 2, 72 * 3, 72 * 1), 26, PdfColorFactory.FromGray(0.0));
page.DrawingList.Add(rect);
page.DrawingList.Add(rect2);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Constructor

Overload List
 | Name | Description
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor) | Initializes a new instance of the PdfRoundedRectangle class.
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor, Double) | Initializes a new instance of the PdfRoundedRectangle class.
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor, IPdfColor, PdfLineStyle) | Initializes a new instance of the PdfRoundedRectangle class.
Public method | PdfRoundedRectangle(PdfBounds, Double, IPdfColor, IPdfColor, Double) | Initializes a new instance of the PdfRoundedRectangle class.
Top
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Constructor (PdfBounds, Double, IPdfColor)

Initializes a new instance of the PdfRoundedRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRoundedRectangle(
    PdfBounds bounds,
    double curveRadius,
    IPdfColor fillColor
)
Public Sub New (
    bounds As PdfBounds,
    curveRadius As Double,
    fillColor As IPdfColor
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rounded rectangle.
curveRadius
Type: SystemDouble
The curve radius of the corners of the rectangle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfRoundedRectangle Class
PdfRoundedRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Constructor (PdfBounds, Double, IPdfColor, Double)

Initializes a new instance of the PdfRoundedRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRoundedRectangle(
    PdfBounds bounds,
    double curveRadius,
    IPdfColor outlineColor,
    double lineWidth
)
Public Sub New (
    bounds As PdfBounds,
    curveRadius As Double,
    outlineColor As IPdfColor,
    lineWidth As Double
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rounded rectangle.
curveRadius
Type: SystemDouble
The curve radius of the corners of the rectangle.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
lineWidth
Type: SystemDouble
Width of the line.
See Also

Reference

PdfRoundedRectangle Class
PdfRoundedRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Constructor (PdfBounds, Double, IPdfColor, IPdfColor, PdfLineStyle)

Initializes a new instance of the PdfRoundedRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRoundedRectangle(
    PdfBounds bounds,
    double curveRadius,
    IPdfColor fillColor,
    IPdfColor outlineColor,
    PdfLineStyle style
)
Public Sub New (
    bounds As PdfBounds,
    curveRadius As Double,
    fillColor As IPdfColor,
    outlineColor As IPdfColor,
    style As PdfLineStyle
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rounded rectangle.
curveRadius
Type: SystemDouble
The curve radius of the corners of the rectangle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
See Also

Reference

PdfRoundedRectangle Class
PdfRoundedRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Constructor (PdfBounds, Double, IPdfColor, IPdfColor, Double)

Initializes a new instance of the PdfRoundedRectangle class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfRoundedRectangle(
    PdfBounds bounds,
    double curveRadius,
    IPdfColor fillColor,
    IPdfColor outlineColor,
    double lineWidth
)
Public Sub New (
    bounds As PdfBounds,
    curveRadius As Double,
    fillColor As IPdfColor,
    outlineColor As IPdfColor,
    lineWidth As Double
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the rounded rectangle.
curveRadius
Type: SystemDouble
The curve radius of the corners of the rectangle.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
lineWidth
Type: SystemDouble
Width of the line.
See Also

Reference

PdfRoundedRectangle Class
PdfRoundedRectangle Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Properties

The PdfRoundedRectangle type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | CurveRadius | Gets or sets the curve radius.
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Top
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle.Bounds Property

PdfRoundedRectangleBounds Property

Gets or sets the bounds.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds of the rounded rectangle.
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle.CurveRadius Property

PdfRoundedRectangleCurveRadius Property

Gets or sets the curve radius.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double CurveRadius { get; set; }
Public Property CurveRadius As Double
    Get
    Set

Property Value

Type: Double
The curve radius of the corners of the rectangle
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle Methods

The PdfRoundedRectangle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle.CloneInstance Method

PdfRoundedRectangleCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfRoundedRectangle.DrawShape Method

PdfRoundedRectangleDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfRoundedRectangle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox Class

An object to output styled text to a PdfGeneratedDocument.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesPdfStyledTextBox

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfStyledTextBox : PdfBaseTextShape,
    IPdfTextContainer
<SerializableAttribute>
Public Class PdfStyledTextBox
    Inherits PdfBaseTextShape
    Implements IPdfTextContainer

The PdfStyledTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | PdfStyledTextBox | Initializes a new instance of the PdfStyledTextBox class. Add text to the box using the Fill method.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill | Fills the specified input. This method must be called before the shape attempts to draw. This is what fills the styled text shape with content.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
StyledTextInput input = new StyledTextInput("Font0");
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox Constructor

Initializes a new instance of the PdfStyledTextBox class. Add text to the box using the Fill method.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfStyledTextBox(
    string fontName,
    PdfBounds bounds
)
Public Sub New (
    fontName As String,
    bounds As PdfBounds
)

Parameters

fontName
Type: SystemString
Name of the default font.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the text object.
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox Properties

The PdfStyledTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox.Bounds Property

PdfStyledTextBoxBounds Property

Gets or sets the bounds.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds.
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox.Text Property

PdfStyledTextBoxText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.

Implements

IPdfTextContainerText
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox Methods

The PdfStyledTextBox type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill | Fills the specified input. This method must be called before the shape attempts to draw. This is what fills the styled text shape with content.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox.CloneInstance Method

PdfStyledTextBoxCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of this shape.
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox.DrawShape Method

PdfStyledTextBoxDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfStyledTextBox.Fill Method

PdfStyledTextBoxFill Method

Fills the specified input. This method must be called before the shape attempts to draw. This is what fills the styled text shape with content.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Fill(
    StyleTextInput input,
    PdfFontManager manager
)
Public Sub Fill (
    input As StyleTextInput,
    manager As PdfFontManager
)

Parameters

input
Type: Atalasoft.PdfDoc.Generating.ShapesStyleTextInput
The input.
manager
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager
The manager.
See Also

Reference

PdfStyledTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable Class

An object to output object data in a table format to a PdfGeneratedDocument.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfTable

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTable : IPdfRenderable, ICloneable
<SerializableAttribute>
Public Class PdfTable
    Implements IPdfRenderable, ICloneable

The PdfTable type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTable | Initializes a new instance of the PdfTable class.
Top
Properties
 | Name | Description
Public property | ActualHeight | returns the height of the filled table.
 | BorderColor | Gets/sets the color to draw the border grid lines. The default border color is black.
 | BorderStyle | The border style for the table. See PdfTableBorderStyle The default border style is None. Border options are: Grid,Vertical,Horizontal,Outline, None.
Public property | BorderWidth | Gets/sets the width the border should be drawn. This applies to all the lines that are drawn for the table The default border width is 1.
Public property | Bounds | Gets/sets the bounds for the table
Public property | Columns | Returns the columns already set for the PdfTable. See PdfTableColumn
Public property | FilledRowsCount | Gets a count of rows placed to the table after the Fill() method using. This value takes into account header row if it exists.
Public property | FontName | Gets/sets the name of the font to be used
Public property | FontSize | Gets/sets the size of the font.
Public property | HasMoreRows | Returns true if there are more rows to draw for the table. Check this after the Fill() method to see if all the rows were written to the table.
Public property | HeaderFontName | Gets or sets the name of the header font. If set to null, when Fill(PdfFontManager) is called, PdfTable will attempt to find a font named FontName + " Bold" in the system (creating a font resource if needed), otherwise it will use a font named by HeaderFontName.
Public property | LineHeight | Gets/sets the height of each row in the table. If text has multiple lines the row height will be multiplied by the number of lines. The default row height is calculated based on the font type and font size specified.
Public property | Name | Gets/sets the name of the IPdfRenderable object.
Public property | ShowColumnHeadingRow | Get/sets whether to draw the a heading row for the table. Default is true.
Public property | TextPaddingLeft | The padding from the left margin to the start of the text. This will apply to the entire table. If there is a column TextPaddingLeft defined it will override this value.
Public property | TextPaddingRight | The padding from the end of the text to the right margin. This will apply to the entire table If there is a column TextPaddingRight defined it will override this value.
Top
Methods
 | Name | Description
 | AddRows | Add row data to the table. Pass an enumerator for a collection of items. Can also be an enumerator of a List<Dictionary<string,string>> object.
Public method | Clone | Copy the PdfTable object to a new instance. Reuses the Font Resource manager. Reuses the Ta Does not copy table rows.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill | Fills the specified table with rows using the PdfTableInput enumerator This method must be called before the table attempts to render. This fills the table with the rows provided, it will stop at the point the table bounds height has been reached.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Generates the PDFTable. Draws each row in the table
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
// constructor takes the PdfBounds for the table, the default font type, and font size
PdfTable productTable = new PdfTable(new PdfBounds(10, 100, 500, 600), "Arial", 6);

// create the table columns
// the columns are shown in the order they are added to the table
// add a column, pass the key, display Text, and column Width
productTable.Columns.Add(new PdfTableColumn("SKU", "Product Code", 50));

// if the width is not specified, the width will be calculated by using the average of what width is left
productTable.Columns.Add(new PdfTableColumn("Name", "Product Name"));

productTable.Columns.Add(new PdfTableColumn("Quantity", "Quantity", 25));
productTable.Columns.Add(new PdfTableColumn("UnitPrice", "Price", 50));

// specify the BorderStyle,BorderWidth, and BorderColor
// BorderStyle options: Grid, Vertical, Horizontal, Outline, None
productTable.BorderStyle = PdfTableBorderStyle.Vertical;
productTable.BorderWidth = .5;
productTable.BorderColor = PdfColorFactory.FromColor(System.Drawing.Color.Black);

List<Product> productList = CreateProductList();
productTable.AddRows(productList.GetEnumerator());

// create the Pdf doc and page to draw to
PdfGeneratedDocument pdfDoc = new PdfGeneratedDocument();
PdfGeneratedPage page = PdfDefaultPages.Letter;

// populate the table with the data collection
productTable.Fill(pdfDoc.Resources.Fonts);

// add the table to the page
page.DrawingList.Add(productTable);
pdfDoc.Pages.Add(page);
Examples
The following example demonstrates how to create a document with a multi-page table.
Multi-page table
Copy
PdfGeneratedDocument pdfDoc = new PdfGeneratedDocument();
PdfGeneratedPage page = PdfDefaultPages.Letter;
List<Product> productList = CreateProductList(30);

PdfTable productTable = new PdfTable(new PdfBounds(10, 100, 500, 200), "Arial", 6);

productTable.Columns.Add(new PdfTableColumn("SKU", "Product Code", 30));
productTable.Columns.Add(new PdfTableColumn("Name", "Product Name"));
productTable.Columns.Add(new PdfTableColumn("Quantity", "Quantity", 50));
productTable.Columns.Add(new PdfTableColumn("UnitPrice", "Price", 50));

productTable.BorderStyle = PdfTableBorderStyle.Grid;
productTable.BorderWidth = .5;
productTable.BorderColor = PdfColorFactory.FromColor(System.Drawing.Color.Black);

productTable.AddRows(productList.GetEnumerator());

// populate the table with the collection data
productTable.Fill(pdfDoc.Resources.Fonts);

// add the table to the page
page.DrawingList.Add(productTable);
pdfDoc.Pages.Add(page);

while (productTable.HasMoreRows)
{
    page = PdfDefaultPages.Letter;
    productTable = (PdfTable)productTable.Clone();

    // populate the table with the collection data
    productTable.Fill(pdfDoc.Resources.Fonts);

    // add the table to the page
    page.DrawingList.Add(productTable);
    pdfDoc.Pages.Add(page);
}

using (FileStream fs = new FileStream("MultipleIterationExampleTest.pdf", FileMode.Create,
    FileAccess.ReadWrite, FileShare.Read))
    pdfDoc.Save(fs);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable Constructor

Initializes a new instance of the PdfTable class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTable(
    PdfBounds bounds,
    string fontName,
    double fontSize
)
Public Sub New (
    bounds As PdfBounds,
    fontName As String,
    fontSize As Double
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the table
fontName
Type: SystemString
Name of the default font
fontSize
Type: SystemDouble
Default font size
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable Properties

The PdfTable type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | returns the height of the filled table.
 | BorderColor | Gets/sets the color to draw the border grid lines. The default border color is black.
 | BorderStyle | The border style for the table. See PdfTableBorderStyle The default border style is None. Border options are: Grid,Vertical,Horizontal,Outline, None.
Public property | BorderWidth | Gets/sets the width the border should be drawn. This applies to all the lines that are drawn for the table The default border width is 1.
Public property | Bounds | Gets/sets the bounds for the table
Public property | Columns | Returns the columns already set for the PdfTable. See PdfTableColumn
Public property | FilledRowsCount | Gets a count of rows placed to the table after the Fill() method using. This value takes into account header row if it exists.
Public property | FontName | Gets/sets the name of the font to be used
Public property | FontSize | Gets/sets the size of the font.
Public property | HasMoreRows | Returns true if there are more rows to draw for the table. Check this after the Fill() method to see if all the rows were written to the table.
Public property | HeaderFontName | Gets or sets the name of the header font. If set to null, when Fill(PdfFontManager) is called, PdfTable will attempt to find a font named FontName + " Bold" in the system (creating a font resource if needed), otherwise it will use a font named by HeaderFontName.
Public property | LineHeight | Gets/sets the height of each row in the table. If text has multiple lines the row height will be multiplied by the number of lines. The default row height is calculated based on the font type and font size specified.
Public property | Name | Gets/sets the name of the IPdfRenderable object.
Public property | ShowColumnHeadingRow | Get/sets whether to draw the a heading row for the table. Default is true.
Public property | TextPaddingLeft | The padding from the left margin to the start of the text. This will apply to the entire table. If there is a column TextPaddingLeft defined it will override this value.
Public property | TextPaddingRight | The padding from the end of the text to the right margin. This will apply to the entire table If there is a column TextPaddingRight defined it will override this value.
Top
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.ActualHeight Property

PdfTableActualHeight Property

returns the height of the filled table.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double ActualHeight { get; set; }
Public Property ActualHeight As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.BorderColor Property

PdfTableBorderColor Property

Gets/sets the color to draw the border grid lines. The default border color is black.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor BorderColor { get; set; }
Public Property BorderColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
A IPdfColor color the border gridlines should draw
Examples
Copy
pdfTable.BorderColor = PdfColorFactory.FromColor(System.Drawing.Color.Black);
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.BorderStyle Property

PdfTableBorderStyle Property

The border style for the table. See PdfTableBorderStyle The default border style is None. Border options are: Grid,Vertical,Horizontal,Outline, None.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableBorderStyle BorderStyle { get; set; }
Public Property BorderStyle As PdfTableBorderStyle
    Get
    Set

Property Value

Type: PdfTableBorderStyle
A PdfTableBorderStyle to render the gridlines
Examples
Copy
pdfTable.BorderStyle = PdfTableBorderStyle.Vertical;
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.BorderWidth Property

PdfTableBorderWidth Property

Gets/sets the width the border should be drawn. This applies to all the lines that are drawn for the table The default border width is 1.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double BorderWidth { get; set; }
Public Property BorderWidth As Double
    Get
    Set

Property Value

Type: Double
The borderwidth of the gridlines.
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.Bounds Property

PdfTableBounds Property

Gets/sets the bounds for the table

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds to use for the table
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.Columns Property

PdfTableColumns Property

Returns the columns already set for the PdfTable. See PdfTableColumn

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumnCollection Columns { get; }
Public ReadOnly Property Columns As PdfTableColumnCollection
    Get

Return Value

Type: PdfTableColumnCollection
List of columns set for the table. See PdfTableColumn
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.FilledRowsCount Property

PdfTableFilledRowsCount Property

Gets a count of rows placed to the table after the Fill() method using. This value takes into account header row if it exists.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FilledRowsCount { get; }
Public ReadOnly Property FilledRowsCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.FontName Property

PdfTableFontName Property

Gets/sets the name of the font to be used

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set

Property Value

Type: String
The name of the font to use for all text in the table.
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.FontSize Property

PdfTableFontSize Property

Gets/sets the size of the font.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double FontSize { get; set; }
Public Property FontSize As Double
    Get
    Set

Property Value

Type: Double
The size of the font.
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.HasMoreRows Property

PdfTableHasMoreRows Property

Returns true if there are more rows to draw for the table. Check this after the Fill() method to see if all the rows were written to the table.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HasMoreRows { get; }
Public ReadOnly Property HasMoreRows As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.HeaderFontName Property

PdfTableHeaderFontName Property

Gets or sets the name of the header font. If set to null, when Fill(PdfFontManager) is called, PdfTable will attempt to find a font named FontName + " Bold" in the system (creating a font resource if needed), otherwise it will use a font named by HeaderFontName.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HeaderFontName { get; set; }
Public Property HeaderFontName As String
    Get
    Set

Property Value

Type: String
The name of the header font.
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.LineHeight Property

PdfTableLineHeight Property

Gets/sets the height of each row in the table. If text has multiple lines the row height will be multiplied by the number of lines. The default row height is calculated based on the font type and font size specified.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double LineHeight { get; set; }
Public Property LineHeight As Double
    Get
    Set

Property Value

Type: Double
The row height for each rendered row.
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.Name Property

PdfTableName Property

Gets/sets the name of the IPdfRenderable object.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the IPdfRenderable object.

Implements

IPdfRenderableName
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.ShowColumnHeadingRow Property

PdfTableShowColumnHeadingRow Property

Get/sets whether to draw the a heading row for the table. Default is true.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowColumnHeadingRow { get; set; }
Public Property ShowColumnHeadingRow As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.TextPaddingLeft Property

PdfTableTextPaddingLeft Property

The padding from the left margin to the start of the text. This will apply to the entire table. If there is a column TextPaddingLeft defined it will override this value.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double TextPaddingLeft { get; set; }
Public Property TextPaddingLeft As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.TextPaddingRight Property

PdfTableTextPaddingRight Property

The padding from the end of the text to the right margin. This will apply to the entire table If there is a column TextPaddingRight defined it will override this value.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double TextPaddingRight { get; set; }
Public Property TextPaddingRight As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable Methods

The PdfTable type exposes the following members.

Methods
 | Name | Description
 | AddRows | Add row data to the table. Pass an enumerator for a collection of items. Can also be an enumerator of a List<Dictionary<string,string>> object.
Public method | Clone | Copy the PdfTable object to a new instance. Reuses the Font Resource manager. Reuses the Ta Does not copy table rows.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Fill | Fills the specified table with rows using the PdfTableInput enumerator This method must be called before the table attempts to render. This fills the table with the rows provided, it will stop at the point the table bounds height has been reached.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Generates the PDFTable. Draws each row in the table
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.AddRows Method

PdfTableAddRows Method

Add row data to the table. Pass an enumerator for a collection of items. Can also be an enumerator of a List<Dictionary<string,string>> object.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRows(
    IEnumerator en
)
Public Sub AddRows (
    en As IEnumerator
)

Parameters

en
Type: System.CollectionsIEnumerator
An enumerator for the data collection
Examples
Copy
List<Product> productList = CreateProductList();
productTable.AddRows(productList.GetEnumerator());

//Or

Dictionary<string, string> productData = new Dictionary<string, string>();
productData.Add("Name", productName);
productData.Add("SKU", productSku);
productData.Add("Quantity", quantity.ToString());
productData.Add("UnitPrice", unitPrice.ToString("C", CultureInfo.CurrentCulture));
productData.Add("CreatedDate", createdDate.ToString("d"));
productData.Add("TotalPrice", (quantity * unitPrice).ToString("C", CultureInfo.CurrentCulture));
List<Dictionary<string, string>> productList = new List<Dictionary<string, string>>();
productList.add(productData);
productTable.AddRows(productList.GetEnumerator());
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.Clone Method

PdfTableClone Method

Copy the PdfTable object to a new instance. Reuses the Font Resource manager. Reuses the Ta Does not copy table rows.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
PdfTable

Implements

ICloneableClone
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.Fill Method

PdfTableFill Method

Fills the specified table with rows using the PdfTableInput enumerator This method must be called before the table attempts to render. This fills the table with the rows provided, it will stop at the point the table bounds height has been reached.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Fill(
    PdfFontManager fontManager
)
Public Sub Fill (
    fontManager As PdfFontManager
)

Parameters

fontManager
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontManager
The font manager to use for resources.
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTable.Render Method

PdfTableRender Method

Generates the PDFTable. Draws each row in the table

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfPageRenderer r
)
Public Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.

Implements

IPdfRenderableRender(PdfPageRenderer)
See Also

Reference

PdfTable Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableBorderStyle Enumeration

Border style options available for the PdfTable. To be used to set the PdfTable.BorderStyle property.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTableBorderStyle
Public Enumeration PdfTableBorderStyle
Members
Member name | Description
None | Draw no border. No vertical column lines, no horizontal row lines
Vertical | Draw only vertical column lines
Horizontal | Draw only horizontal row lines
Outline | Draw only outside border. No vertical column lines and NO horizontal row lines
Grid | Draws vertical column lines and horizontal row lines and outside border lines
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Class

Used to define the columns for the PdfTable
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTableColumn : ICloneable
<SerializableAttribute>
Public Class PdfTableColumn
    Implements ICloneable

The PdfTableColumn type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTableColumn(String, String) | Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.
Public method | PdfTableColumn(String, String, Double) | Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.
Public method | PdfTableColumn(String, String, Double, PdfTextAlignment) | Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.
Public method | PdfTableColumn(String, String, Double, PdfTextAlignment, Double, Double) | Initializes a new instance of the PdfTableColumn class. The key is used to do a lookup in a collection or Dictionary for property values.
Top
Properties
 | Name | Description
Public property | DisplayText | Text that will display in the column heading
Public property | Key | The key is used to do a lookup in a collection or Dictionary for property values.
Public property | TextAlignment | Horizontal alignment for the text in the column
Public property | TextPaddingLeft | Get/sets the padding to the left of text for the column
Public property | TextPaddingRight | Get/sets the padding to the right of text for the column
Public property | TextStyle | The text style to apply to the column
Public property | Width | Width of the column
Top
Methods
 | Name | Description
Public method | Clone | Creates and returns a new instance of the PdfTableColumn
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Constructor

Overload List
 | Name | Description
Public method | PdfTableColumn(String, String) | Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.
Public method | PdfTableColumn(String, String, Double) | Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.
Public method | PdfTableColumn(String, String, Double, PdfTextAlignment) | Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.
Public method | PdfTableColumn(String, String, Double, PdfTextAlignment, Double, Double) | Initializes a new instance of the PdfTableColumn class. The key is used to do a lookup in a collection or Dictionary for property values.
Top
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Constructor (String, String)

Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumn(
    string key,
    string displayText
)
Public Sub New (
    key As String,
    displayText As String
)

Parameters

key
Type: SystemString
Key for column. This should be the same as the property name of the object
displayText
Type: SystemString
Text to show in table
See Also

Reference

PdfTableColumn Class
PdfTableColumn Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Constructor (String, String, Double)

Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumn(
    string key,
    string displayText,
    double columnWidth
)
Public Sub New (
    key As String,
    displayText As String,
    columnWidth As Double
)

Parameters

key
Type: SystemString
Key for column. This should be the same as the property name of the object
displayText
Type: SystemString
Text to show in table column header
columnWidth
Type: SystemDouble
The width the column should span
See Also

Reference

PdfTableColumn Class
PdfTableColumn Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Constructor (String, String, Double, PdfTextAlignment)

Initializes a new instance of the PdfTableColumn class. The key should match the property name or Dictionary key for the objects.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumn(
    string key,
    string displayText,
    double columnWidth,
    PdfTextAlignment textAlignment
)
Public Sub New (
    key As String,
    displayText As String,
    columnWidth As Double,
    textAlignment As PdfTextAlignment
)

Parameters

key
Type: SystemString
Key for column. This should be the same as the property name of the object or Dictionary<string,string> key.
displayText
Type: SystemString
Text to show in table column header
columnWidth
Type: SystemDouble
The width the column should span
textAlignment
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextAlignment
The horizontal alignment for the column text
See Also

Reference

PdfTableColumn Class
PdfTableColumn Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Constructor (String, String, Double, PdfTextAlignment, Double, Double)

Initializes a new instance of the PdfTableColumn class. The key is used to do a lookup in a collection or Dictionary for property values.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumn(
    string key,
    string displayText,
    double columnWidth,
    PdfTextAlignment textAlignment,
    double textPaddingLeft,
    double textPaddingRight
)
Public Sub New (
    key As String,
    displayText As String,
    columnWidth As Double,
    textAlignment As PdfTextAlignment,
    textPaddingLeft As Double,
    textPaddingRight As Double
)

Parameters

key
Type: SystemString
Key for column. This should be the same as the property name of the object or Dictionary<string,string> key.
displayText
Type: SystemString
Text to show in table column header
columnWidth
Type: SystemDouble
The width the column should span
textAlignment
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextAlignment
The horizontal alignment for the column text
textPaddingLeft
Type: SystemDouble
The amount of padding to the left of the text for the column
textPaddingRight
Type: SystemDouble
The amount of padding to the right of the text for the column
See Also

Reference

PdfTableColumn Class
PdfTableColumn Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Properties

The PdfTableColumn type exposes the following members.

Properties
 | Name | Description
Public property | DisplayText | Text that will display in the column heading
Public property | Key | The key is used to do a lookup in a collection or Dictionary for property values.
Public property | TextAlignment | Horizontal alignment for the text in the column
Public property | TextPaddingLeft | Get/sets the padding to the left of text for the column
Public property | TextPaddingRight | Get/sets the padding to the right of text for the column
Public property | TextStyle | The text style to apply to the column
Public property | Width | Width of the column
Top
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.DisplayText Property

PdfTableColumnDisplayText Property

Text that will display in the column heading

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DisplayText { get; set; }
Public Property DisplayText As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.Key Property

PdfTableColumnKey Property

The key is used to do a lookup in a collection or Dictionary for property values.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.TextAlignment Property

PdfTableColumnTextAlignment Property

Horizontal alignment for the text in the column

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextAlignment TextAlignment { get; set; }
Public Property TextAlignment As PdfTextAlignment
    Get
    Set

Property Value

Type: PdfTextAlignment
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.TextPaddingLeft Property

PdfTableColumnTextPaddingLeft Property

Get/sets the padding to the left of text for the column

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double TextPaddingLeft { get; set; }
Public Property TextPaddingLeft As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.TextPaddingRight Property

PdfTableColumnTextPaddingRight Property

Get/sets the padding to the right of text for the column

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double TextPaddingRight { get; set; }
Public Property TextPaddingRight As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.TextStyle Property

PdfTableColumnTextStyle Property

The text style to apply to the column

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextStyle TextStyle { get; set; }
Public Property TextStyle As PdfTextStyle
    Get
    Set

Property Value

Type: PdfTextStyle
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.Width Property

PdfTableColumnWidth Property

Width of the column

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn Methods

The PdfTableColumn type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates and returns a new instance of the PdfTableColumn
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumn.Clone Method

PdfTableColumnClone Method

Creates and returns a new instance of the PdfTableColumn

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A copy of this column.

Implements

ICloneableClone
See Also

Reference

PdfTableColumn Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection Class

Collection of table columns, added methods to calculate widths and clone the column collection
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfTableColumnCollection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTableColumnCollection : IList<PdfTableColumn>,
    ICollection<PdfTableColumn>, IEnumerable<PdfTableColumn>, IEnumerable
<SerializableAttribute>
Public Class PdfTableColumnCollection
    Implements IList(Of PdfTableColumn), ICollection(Of PdfTableColumn),
    IEnumerable(Of PdfTableColumn), IEnumerable

The PdfTableColumnCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTableColumnCollection | Initializes a new instance of the PdfTableColumnCollection class
Top
Properties
 | Name | Description
Public property | Count | the number of columns
Public property | IsReadOnly | whther the collection is read only
Public property | Item | indexor access
Top
Methods
 | Name | Description
Public method | Add | adds an item to the collection
Public method | AddRange(ListPdfTableColumn) | adds multiple items tothe collection
Public method | AddRange(PdfTableColumnCollection) | add a collection of PdfTableColumn
Public method | Clear | clears all items from the collection
Public method | Contains | returns true if the item is found in the collection
Public method | CopyTo | copies the collection
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | returns an enumerator for the column collection
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | returns the index of the item
Public method | Insert | inserts an items at the index
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | removes an item from collection
Public method | RemoveAt | removes the item at the index
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection Constructor

Initializes a new instance of the PdfTableColumnCollection class

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumnCollection()
Public Sub New
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection Properties

The PdfTableColumnCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | the number of columns
Public property | IsReadOnly | whther the collection is read only
Public property | Item | indexor access
Top
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Count Property

PdfTableColumnCollectionCount Property

the number of columns

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.IsReadOnly Property

PdfTableColumnCollectionIsReadOnly Property

whther the collection is read only

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Item Property

PdfTableColumnCollectionItem Property

indexor access

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTableColumn this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As PdfTableColumn
    Get
    Set

Parameters

index
Type: SystemInt32

Return Value

Type: PdfTableColumn
The nth PdfTableColumn

Implements

IListTItemInt32
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection Methods

The PdfTableColumnCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | adds an item to the collection
Public method | AddRange(ListPdfTableColumn) | adds multiple items tothe collection
Public method | AddRange(PdfTableColumnCollection) | add a collection of PdfTableColumn
Public method | Clear | clears all items from the collection
Public method | Contains | returns true if the item is found in the collection
Public method | CopyTo | copies the collection
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | returns an enumerator for the column collection
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | returns the index of the item
Public method | Insert | inserts an items at the index
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | removes an item from collection
Public method | RemoveAt | removes the item at the index
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Add Method

PdfTableColumnCollectionAdd Method

adds an item to the collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    PdfTableColumn item
)
Public Sub Add (
    item As PdfTableColumn
)

Parameters

item
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.AddRange Method

PdfTableColumnCollectionAddRange Method

Overload List
 | Name | Description
Public method | AddRange(ListPdfTableColumn) | adds multiple items tothe collection
Public method | AddRange(PdfTableColumnCollection) | add a collection of PdfTableColumn
Top
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.AddRange Method (List(PdfTableColumn))

PdfTableColumnCollectionAddRange Method (ListPdfTableColumn)

adds multiple items tothe collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    List<PdfTableColumn> items
)
Public Sub AddRange (
    items As List(Of PdfTableColumn)
)

Parameters

items
Type: System.Collections.GenericListPdfTableColumn
See Also

Reference

PdfTableColumnCollection Class
AddRange Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.AddRange Method (PdfTableColumnCollection)

PdfTableColumnCollectionAddRange Method (PdfTableColumnCollection)

add a collection of PdfTableColumn

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddRange(
    PdfTableColumnCollection columns
)
Public Sub AddRange (
    columns As PdfTableColumnCollection
)

Parameters

columns
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumnCollection
See Also

Reference

PdfTableColumnCollection Class
AddRange Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Clear Method

PdfTableColumnCollectionClear Method

clears all items from the collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Contains Method

PdfTableColumnCollectionContains Method

returns true if the item is found in the collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PdfTableColumn item
)
Public Function Contains (
    item As PdfTableColumn
) As Boolean

Parameters

item
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn

Return Value

Type: Boolean
true if found; false otherwise.
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.CopyTo Method

PdfTableColumnCollectionCopyTo Method

copies the collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    PdfTableColumn[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As PdfTableColumn(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn
arrayIndex
Type: SystemInt32
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.GetEnumerator Method

PdfTableColumnCollectionGetEnumerator Method

returns an enumerator for the column collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<PdfTableColumn> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of PdfTableColumn)

Return Value

Type: IEnumeratorPdfTableColumn
An enumerable list of columns
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.IndexOf Method

PdfTableColumnCollectionIndexOf Method

returns the index of the item

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    PdfTableColumn item
)
Public Function IndexOf (
    item As PdfTableColumn
) As Integer

Parameters

item
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn

Return Value

Type: Int32
The index of the item; returns < 0 when not found.

Implements

IListTIndexOf(T)
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Insert Method

PdfTableColumnCollectionInsert Method

inserts an items at the index

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    PdfTableColumn item
)
Public Sub Insert (
    index As Integer,
    item As PdfTableColumn
)

Parameters

index
Type: SystemInt32
item
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn

Implements

IListTInsert(Int32, T)
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.Remove Method

PdfTableColumnCollectionRemove Method

removes an item from collection

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    PdfTableColumn item
)
Public Function Remove (
    item As PdfTableColumn
) As Boolean

Parameters

item
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTableColumn

Return Value

Type: Boolean
true if removed; false otherwise
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTableColumnCollection.RemoveAt Method

PdfTableColumnCollectionRemoveAt Method

removes the item at the index

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32

Implements

IListTRemoveAt(Int32)
See Also

Reference

PdfTableColumnCollection Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape Class

The shape used to place an image on a page
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfTemplateShape

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTemplateShape : PdfBaseShape,
    IPdfResourceConsumer
<SerializableAttribute>
Public Class PdfTemplateShape
    Inherits PdfBaseShape
    Implements IPdfResourceConsumer

The PdfTemplateShape type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTemplateShape(PdfTemplateShape) | Initializes a new instance of the PdfTemplateShape class copying from the supplied PdfTemplateShape
Public method | PdfTemplateShape(String, PdfBounds) | Initializes a new instance of the PdfTemplateShape class.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | TemplateName | Gets or sets the name of the template.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when resource has been renamed. (Overrides PdfBaseShapeOnResourceRenamed(GlobalResources, PdfResourceClass, String, String).)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Overrides PdfBaseShapeOnResourcesRequested(GlobalResources, PdfResourceClass).)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape Constructor

Overload List
 | Name | Description
Public method | PdfTemplateShape(PdfTemplateShape) | Initializes a new instance of the PdfTemplateShape class copying from the supplied PdfTemplateShape
Public method | PdfTemplateShape(String, PdfBounds) | Initializes a new instance of the PdfTemplateShape class.
Top
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape Constructor (PdfTemplateShape)

Initializes a new instance of the PdfTemplateShape class copying from the supplied PdfTemplateShape

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTemplateShape(
    PdfTemplateShape other
)
Public Sub New (
    other As PdfTemplateShape
)

Parameters

other
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTemplateShape
The shape to copy from.
See Also

Reference

PdfTemplateShape Class
PdfTemplateShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape Constructor (String, PdfBounds)

Initializes a new instance of the PdfTemplateShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTemplateShape(
    string templateName,
    PdfBounds bounds
)
Public Sub New (
    templateName As String,
    bounds As PdfBounds
)

Parameters

templateName
Type: SystemString
Name of the template in your document's Resources.
bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds of the template.
See Also

Reference

PdfTemplateShape Class
PdfTemplateShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape Properties

The PdfTemplateShape type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | TemplateName | Gets or sets the name of the template.
Top
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape.Bounds Property

PdfTemplateShapeBounds Property

Gets or sets the bounds.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds.
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape.TemplateName Property

PdfTemplateShapeTemplateName Property

Gets or sets the name of the template.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string TemplateName { get; set; }
Public Property TemplateName As String
    Get
    Set

Property Value

Type: String
The name of the template.
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape Methods

The PdfTemplateShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when resource has been renamed. (Overrides PdfBaseShapeOnResourceRenamed(GlobalResources, PdfResourceClass, String, String).)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Overrides PdfBaseShapeOnResourcesRequested(GlobalResources, PdfResourceClass).)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape.CloneInstance Method

PdfTemplateShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of the shape
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape.DrawShape Method

PdfTemplateShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape.OnResourceRenamed Method

PdfTemplateShapeOnResourceRenamed Method

Called when resource has been renamed.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void OnResourceRenamed(
    GlobalResources gr,
    PdfResourceClass resourceClass,
    string originalName,
    string newName
)
Protected Overrides Sub OnResourceRenamed (
    gr As GlobalResources,
    resourceClass As PdfResourceClass,
    originalName As String,
    newName As String
)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.
originalName
Type: SystemString
Name of the original resource.
newName
Type: SystemString
The new name.
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTemplateShape.OnResourcesRequested Method

PdfTemplateShapeOnResourcesRequested Method

Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override IEnumerable<string> OnResourcesRequested(
    GlobalResources gr,
    PdfResourceClass resourceClass
)
Protected Overrides Function OnResourcesRequested (
    gr As GlobalResources,
    resourceClass As PdfResourceClass
) As IEnumerable(Of String)

Parameters

gr
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingGlobalResources
The global resources.
resourceClass
Type: Atalasoft.PdfDoc.Generating.ResourceHandlingPdfResourceClass
The resource class.

Return Value

Type: IEnumerableString
A list of all resources of the class specified that may be used by this object.
See Also

Reference

PdfTemplateShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextAlignment Enumeration

An enum to represent text alignment styles

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTextAlignment
Public Enumeration PdfTextAlignment
Members
Member name | Description
Left | Left justify. (Default)
Right | Right justify.
Center | Center justify.
Fill | Fill the available space. This is not supported by all text objects.
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Class

A simple pdf text box.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesPdfTextBox

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTextBox : PdfBaseTextShape, IPdfTextContainer
<SerializableAttribute>
Public Class PdfTextBox
    Inherits PdfBaseTextShape
    Implements IPdfTextContainer

The PdfTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTextBox(PdfBounds, String, Double) | Initializes a new instance of the PdfTextBox class.
Public method | PdfTextBox(PdfBounds, String, Double, String) | Initializes a new instance of the PdfTextBox class.
Public method | PdfTextBox(PdfBounds, String, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfTextBox class.
Public method | PdfTextBox(PdfBounds, String, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfTextBox class.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Bounds | Gets or sets the bounds of the text box.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text that will be in the box.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Overrides PdfBaseShapeGenerateTransform.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
PdfTextBox box = new PdfTextBox(100,100,100,100,fontName,10.0,"This is a text box. Word wrap is automatic");
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Constructor

Overload List
 | Name | Description
Public method | PdfTextBox(PdfBounds, String, Double) | Initializes a new instance of the PdfTextBox class.
Public method | PdfTextBox(PdfBounds, String, Double, String) | Initializes a new instance of the PdfTextBox class.
Public method | PdfTextBox(PdfBounds, String, Double, IPdfColor, PdfLineStyle, IPdfColor) | Initializes a new instance of the PdfTextBox class.
Public method | PdfTextBox(PdfBounds, String, Double, IPdfColor, Double, IPdfColor) | Initializes a new instance of the PdfTextBox class.
Top
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Constructor (PdfBounds, String, Double)

Initializes a new instance of the PdfTextBox class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextBox(
    PdfBounds bounds,
    string fontName,
    double fontSize
)
Public Sub New (
    bounds As PdfBounds,
    fontName As String,
    fontSize As Double
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
See Also

Reference

PdfTextBox Class
PdfTextBox Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Constructor (PdfBounds, String, Double, String)

Initializes a new instance of the PdfTextBox class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextBox(
    PdfBounds bounds,
    string fontName,
    double fontSize,
    string text
)
Public Sub New (
    bounds As PdfBounds,
    fontName As String,
    fontSize As Double,
    text As String
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
text
Type: SystemString
The text.
See Also

Reference

PdfTextBox Class
PdfTextBox Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Constructor (PdfBounds, String, Double, IPdfColor, PdfLineStyle, IPdfColor)

Initializes a new instance of the PdfTextBox class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextBox(
    PdfBounds bounds,
    string fontName,
    double fontSize,
    IPdfColor outlineColor,
    PdfLineStyle style,
    IPdfColor fillColor
)
Public Sub New (
    bounds As PdfBounds,
    fontName As String,
    fontSize As Double,
    outlineColor As IPdfColor,
    style As PdfLineStyle,
    fillColor As IPdfColor
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The box.
fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfTextBox Class
PdfTextBox Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Constructor (PdfBounds, String, Double, IPdfColor, Double, IPdfColor)

Initializes a new instance of the PdfTextBox class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextBox(
    PdfBounds box,
    string fontName,
    double fontSize,
    IPdfColor outlineColor,
    double lineWidth,
    IPdfColor fillColor
)
Public Sub New (
    box As PdfBounds,
    fontName As String,
    fontSize As Double,
    outlineColor As IPdfColor,
    lineWidth As Double,
    fillColor As IPdfColor
)

Parameters

box
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The box.
fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
lineWidth
Type: SystemDouble
Width of the outline.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
See Also

Reference

PdfTextBox Class
PdfTextBox Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Properties

The PdfTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Bounds | Gets or sets the bounds of the text box.
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text that will be in the box.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox.Bounds Property

PdfTextBoxBounds Property

Gets or sets the bounds of the text box.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds.
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox.Text Property

PdfTextBoxText Property

Gets or sets the text that will be in the box.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.

Implements

IPdfTextContainerText
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox Methods

The PdfTextBox type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Overrides PdfBaseShapeGenerateTransform.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox.CloneInstance Method

PdfTextBoxCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of the shape
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox.DrawShape Method

PdfTextBoxDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextBox.GenerateTransform Method

PdfTextBoxGenerateTransform Method

Generates the default transform based on Scale, Rotate, and Translate.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfTransform GenerateTransform()
Protected Overrides Function GenerateTransform As PdfTransform

Return Value

Type: PdfTransform
the PdfTransform based on the Scale, Rotate, and Translate properties.
See Also

Reference

PdfTextBox Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Class

The PdfTextLine is a Shape object that can be added to a PdfGeneratedDocument.DisplayList. It provides an interface to write a single line of text at a specified location.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesPdfTextLine

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTextLine : PdfBaseTextShape,
    IPdfTextContainer
<SerializableAttribute>
Public Class PdfTextLine
    Inherits PdfBaseTextShape
    Implements IPdfTextContainer

The PdfTextLine type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTextLine(String, Double, String, PdfPoint) | Initializes a new instance of the PdfTextLine class.
Public method | PdfTextLine(String, Double, String, PdfPoint, IPdfColor, IPdfColor, PdfLineStyle) | Initializes a new instance of the PdfTextLine class.
Public method | PdfTextLine(String, Double, String, PdfPoint, IPdfColor, IPdfColor, Double) | Initializes a new instance of the PdfTextLine class.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Overrides PdfBaseTextShapeRender(PdfPageRenderer).)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
PdfGeneratedPage page = PdfDefaultPages.Letter;
GlobalResources globalRes = new GlobalResources();
doc.Resources = globalRes;
globalRes.Fonts.Add("Arial", PdfFontResource.FromFontName(globalRes.Fonts,"Arial"));
doc.Pages.Add(page);
PdfTextLine tLine = new PdfTextLine("HELLO WORLD", new PdfPoint(100.0, 100.0));
tLine.FontName = "Arial";
tLine.FontSize = 24.0;
page.DrawingList.Add(tLine);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Constructor

Overload List
 | Name | Description
Public method | PdfTextLine(String, Double, String, PdfPoint) | Initializes a new instance of the PdfTextLine class.
Public method | PdfTextLine(String, Double, String, PdfPoint, IPdfColor, IPdfColor, PdfLineStyle) | Initializes a new instance of the PdfTextLine class.
Public method | PdfTextLine(String, Double, String, PdfPoint, IPdfColor, IPdfColor, Double) | Initializes a new instance of the PdfTextLine class.
Top
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Constructor (String, Double, String, PdfPoint)

Initializes a new instance of the PdfTextLine class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextLine(
    string fontName,
    double fontSize,
    string text,
    PdfPoint point
)
Public Sub New (
    fontName As String,
    fontSize As Double,
    text As String,
    point As PdfPoint
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
text
Type: SystemString
The text that will be outputted
point
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point where the text will begin
See Also

Reference

PdfTextLine Class
PdfTextLine Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Constructor (String, Double, String, PdfPoint, IPdfColor, IPdfColor, PdfLineStyle)

Initializes a new instance of the PdfTextLine class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextLine(
    string fontName,
    double fontSize,
    string text,
    PdfPoint location,
    IPdfColor fillColor,
    IPdfColor outlineColor,
    PdfLineStyle style
)
Public Sub New (
    fontName As String,
    fontSize As Double,
    text As String,
    location As PdfPoint,
    fillColor As IPdfColor,
    outlineColor As IPdfColor,
    style As PdfLineStyle
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
text
Type: SystemString
The text.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The location.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style of outlines.
See Also

Reference

PdfTextLine Class
PdfTextLine Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Constructor (String, Double, String, PdfPoint, IPdfColor, IPdfColor, Double)

Initializes a new instance of the PdfTextLine class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextLine(
    string fontName,
    double fontSize,
    string text,
    PdfPoint point,
    IPdfColor fillColor,
    IPdfColor outlineColor,
    double width
)
Public Sub New (
    fontName As String,
    fontSize As Double,
    text As String,
    point As PdfPoint,
    fillColor As IPdfColor,
    outlineColor As IPdfColor,
    width As Double
)

Parameters

fontName
Type: SystemString
Name of the font.
fontSize
Type: SystemDouble
Size of the font.
text
Type: SystemString
The text.
point
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
outlineColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the outline.
width
Type: SystemDouble
The width.
See Also

Reference

PdfTextLine Class
PdfTextLine Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Properties

The PdfTextLine type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine.Text Property

PdfTextLineText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text that will be outputted

Implements

IPdfTextContainerText
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine Methods

The PdfTextLine type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Overrides PdfBaseTextShapeRender(PdfPageRenderer).)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine.CloneInstance Method

PdfTextLineCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of the shape
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine.DrawShape Method

PdfTextLineDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer used for drawing the shape.
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextLine.Render Method

PdfTextLineRender Method

Generates the PDF display list objects.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Render(
    PdfPageRenderer r
)
Public Overrides Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer

Implements

IPdfRenderableRender(PdfPageRenderer)
See Also

Reference

PdfTextLine Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath Class

A PdfBaseShape to perform complex custom direction text writing
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPdfBaseTextShape
Atalasoft.PdfDoc.Generating.ShapesPdfTextPath

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTextPath : PdfBaseTextShape,
    IPdfTextContainer
<SerializableAttribute>
Public Class PdfTextPath
    Inherits PdfBaseTextShape
    Implements IPdfTextContainer

The PdfTextPath type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTextPath | Initializes a new instance of the PdfTextPath class.
Top
Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | PathStyle | Gets or sets the path style.
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Public method | CurveTo | Draws a curve from the previous point to the destination point using two bezier control points
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LineTo | Draws a line from the previous point to the destination point
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to a point in pdf space
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
     PdfGeneratedDocument doc = new PdfGeneratedDocument();
PdfGeneratedPage page = PdfDefaultPages.Letter;
GlobalResources globalRes = new GlobalResources();
doc.Resources = globalRes;
globalRes.Fonts.Add("Arial", PdfFontResource.FromFontName(globalRes.Fonts, "Arial"));
doc.Pages.Add(page);
PdfTextPath path = new PdfTextPath();
path.PathStyle = PathTextStyle.Letter;
path.FontName = "Arial";
path.FontSize = 18.0;
path.Text = "This Text is following a path and will soon find itself at the end of the path";
path.LineTo(new PdfPoint(100, 150));
path.CurveTo(new PdfPoint(100, 250), new PdfPoint(200, 250), new PdfPoint(200, 150));
path.LineTo(new PdfPoint(300, 40));
path.CurveTo(new PdfPoint(340, 0), new PdfPoint(340, 0), new PdfPoint(380, 40));
path.CurveTo(new PdfPoint(380, 100), new PdfPoint(380, 100), new PdfPoint(600, 40));
page.DrawingList.Add(path);
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath Constructor

Initializes a new instance of the PdfTextPath class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextPath(
    string fontName,
    double fontSize
)
Public Sub New (
    fontName As String,
    fontSize As Double
)

Parameters

fontName
Type: SystemString
fontSize
Type: SystemDouble
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath Properties

The PdfTextPath type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Gets or sets the alignment. (Inherited from PdfBaseTextShape.)
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | FontName | Gets or sets the name of the font. (Inherited from PdfBaseTextShape.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from PdfBaseTextShape.)
Public property | HorizontalScaling | Gets or sets the horizontal scaling. (Inherited from PdfBaseTextShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | PathStyle | Gets or sets the path style.
Public property | RenderMode | Gets or sets the render mode. (Inherited from PdfBaseTextShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Public property | WordSpacing | Gets or sets the word spacing. (Inherited from PdfBaseTextShape.)
Top
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.PathStyle Property

PdfTextPathPathStyle Property

Gets or sets the path style.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PathTextStyle PathStyle { get; set; }
Public Property PathStyle As PathTextStyle
    Get
    Set

Property Value

Type: PathTextStyle
The path style.
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.Text Property

PdfTextPathText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.

Implements

IPdfTextContainerText
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath Methods

The PdfTextPath type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseTextShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Public method | CurveTo | Draws a curve from the previous point to the destination point using two bezier control points
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseTextShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextStartOffset(Double, Double) | Gets the text start offset for a line of text. This is used to align text based on the alignment. (Inherited from PdfBaseTextShape.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LineTo | Draws a line from the previous point to the destination point
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to a point in pdf space
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the shape has been renamed. (Inherited from PdfBaseTextShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseTextShape.)
Public method | Render | Generates the PDF display list objects. (Inherited from PdfBaseTextShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.CloneInstance Method

PdfTextPathCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of the shape
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.CurveTo Method

PdfTextPathCurveTo Method

Draws a curve from the previous point to the destination point using two bezier control points

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CurveTo(
    PdfPoint sourceControlPoint,
    PdfPoint destinationControlPoint,
    PdfPoint destinationPoint
)
Public Sub CurveTo (
    sourceControlPoint As PdfPoint,
    destinationControlPoint As PdfPoint,
    destinationPoint As PdfPoint
)

Parameters

sourceControlPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The source control point.
destinationControlPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination control point.
destinationPoint
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination point.
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.DrawShape Method

PdfTextPathDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The writer object.
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.LineTo Method

PdfTextPathLineTo Method

Draws a line from the previous point to the destination point

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LineTo(
    PdfPoint p
)
Public Sub LineTo (
    p As PdfPoint
)

Parameters

p
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination point
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextPath.MoveTo Method

PdfTextPathMoveTo Method

Moves to a point in pdf space

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void MoveTo(
    PdfPoint p
)
Public Sub MoveTo (
    p As PdfPoint
)

Parameters

p
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The destination point
See Also

Reference

PdfTextPath Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle Class

An object used to provide a text style to a pdf text object.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfTextStyle

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTextStyle
<SerializableAttribute>
Public Class PdfTextStyle

The PdfTextStyle type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTextStyle | Initializes a new instance of the PdfTextStyle class (This constructor defaults FontSize to 12 and FontColor to Black and RenderMode to Fill).
Top
Properties
 | Name | Description
Public property | FontColor | Gets or sets the color of the font.
Public property | FontName | Gets or sets the name of the font.
Public property | FontSize | Gets or sets the size of the font.
Public property | HorizontalScale | Gets or sets the horizontal scale.
Public property | OutlineColor | Gets or sets the color of the outline.
Public property | TextRenderMode | Gets or sets the text render mode.
Public property | WordSpace | Gets or sets the word space.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Addition | Masks one style object onto the other. Any value left null will not effect the original.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle Constructor

Initializes a new instance of the PdfTextStyle class (This constructor defaults FontSize to 12 and FontColor to Black and RenderMode to Fill).

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTextStyle(
    string fontName
)
Public Sub New (
    fontName As String
)

Parameters

fontName
Type: SystemString
Name of the font.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle Properties

The PdfTextStyle type exposes the following members.

Properties
 | Name | Description
Public property | FontColor | Gets or sets the color of the font.
Public property | FontName | Gets or sets the name of the font.
Public property | FontSize | Gets or sets the size of the font.
Public property | HorizontalScale | Gets or sets the horizontal scale.
Public property | OutlineColor | Gets or sets the color of the outline.
Public property | TextRenderMode | Gets or sets the text render mode.
Public property | WordSpace | Gets or sets the word space.
Top
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.FontColor Property

PdfTextStyleFontColor Property

Gets or sets the color of the font.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor FontColor { get; set; }
Public Property FontColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the font.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.FontName Property

PdfTextStyleFontName Property

Gets or sets the name of the font.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set

Property Value

Type: String
The name of the font.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.FontSize Property

PdfTextStyleFontSize Property

Gets or sets the size of the font.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> FontSize { get; set; }
Public Property FontSize As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
The size of the font.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.HorizontalScale Property

PdfTextStyleHorizontalScale Property

Gets or sets the horizontal scale.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> HorizontalScale { get; set; }
Public Property HorizontalScale As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
The horizontal scale percent (default is 100).
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.OutlineColor Property

PdfTextStyleOutlineColor Property

Gets or sets the color of the outline.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IPdfColor OutlineColor { get; set; }
Public Property OutlineColor As IPdfColor
    Get
    Set

Property Value

Type: IPdfColor
The color of the outline.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.TextRenderMode Property

PdfTextStyleTextRenderMode Property

Gets or sets the text render mode.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<PdfTextRenderMode> TextRenderMode { get; set; }
Public Property TextRenderMode As Nullable(Of PdfTextRenderMode)
    Get
    Set

Property Value

Type: NullablePdfTextRenderMode
The text render mode.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.WordSpace Property

PdfTextStyleWordSpace Property

Gets or sets the word space.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Nullable<double> WordSpace { get; set; }
Public Property WordSpace As Nullable(Of Double)
    Get
    Set

Property Value

Type: NullableDouble
The word spacing in pdf font units.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle Methods

The PdfTextStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle Operators

The PdfTextStyle type exposes the following members.

Operators
Name | Description
Addition | Masks one style object onto the other. Any value left null will not effect the original.
Top
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PdfTextStyle.Addition Operator

PdfTextStyleAddition Operator

Masks one style object onto the other. Any value left null will not effect the original.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTextStyle operator +(
    PdfTextStyle lhs,
    PdfTextStyle rhs
)
Public Shared Operator + (
    lhs As PdfTextStyle,
    rhs As PdfTextStyle
) As PdfTextStyle

Parameters

lhs
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextStyle
The LHS.
rhs
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextStyle
The RHS.

Return Value

Type: PdfTextStyle
The result of the operator.
See Also

Reference

PdfTextStyle Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape Class

The shape for drawing Postnet style barcodes.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.ShapesPostnetBarcodeShape

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PostnetBarcodeShape : PdfBaseShape,
    IPdfTextContainer
<SerializableAttribute>
Public Class PostnetBarcodeShape
    Inherits PdfBaseShape
    Implements IPdfTextContainer

The PostnetBarcodeShape type exposes the following members.

Constructors
 | Name | Description
Public method | PostnetBarcodeShape(String) | Initializes a new instance of the PostnetBarcodeShape class.
Public method | PostnetBarcodeShape(String, PdfPoint) | Initializes a new instance of the PostnetBarcodeShape class.
Top
Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Size | Gets the size.
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape Constructor

Overload List
 | Name | Description
Public method | PostnetBarcodeShape(String) | Initializes a new instance of the PostnetBarcodeShape class.
Public method | PostnetBarcodeShape(String, PdfPoint) | Initializes a new instance of the PostnetBarcodeShape class.
Top
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape Constructor (String)

Initializes a new instance of the PostnetBarcodeShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PostnetBarcodeShape(
    string code
)
Public Sub New (
    code As String
)

Parameters

code
Type: SystemString
The code.
See Also

Reference

PostnetBarcodeShape Class
PostnetBarcodeShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape Constructor (String, PdfPoint)

Initializes a new instance of the PostnetBarcodeShape class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PostnetBarcodeShape(
    string text,
    PdfPoint location
)
Public Sub New (
    text As String,
    location As PdfPoint
)

Parameters

text
Type: SystemString
The code.
location
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The location.
See Also

Reference

PostnetBarcodeShape Class
PostnetBarcodeShape Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape Properties

The PostnetBarcodeShape type exposes the following members.

Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Size | Gets the size.
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Text | Gets or sets the text.
Top
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape.Size Property

PostnetBarcodeShapeSize Property

Gets the size.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Size { get; }
Public ReadOnly Property Size As PdfBounds
    Get

Property Value

Type: PdfBounds
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape.Text Property

PostnetBarcodeShapeText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.

Implements

IPdfTextContainerText
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape Methods

The PostnetBarcodeShape type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Clones the instance. (Overrides PdfBaseShapeCloneInstance.)
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Draws the shape. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape.CloneInstance Method

PostnetBarcodeShapeCloneInstance Method

Clones the instance.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
A copy of the shape
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


PostnetBarcodeShape.DrawShape Method

PostnetBarcodeShapeDrawShape Method

Draws the shape.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

PostnetBarcodeShape Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ShapeUtilities Class

A utility class for objects that Override PdfBaseShape
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesShapeUtilities

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ShapeUtilities
Public Class ShapeUtilities

The ShapeUtilities type exposes the following members.

Constructors
 | Name | Description
Public method | ShapeUtilities | Initializes a new instance of the ShapeUtilities class
Top
Methods
 | Name | Description
 | ConditionallyClipStrokeOrFill(PdfPageRenderer, IPdfColor, IPdfColor, Boolean, PdfLineStyle, PdfFillMethod) | Conditionallies the clip stroke or fill.
 | ConditionallyClipStrokeOrFill(PdfPageRenderer, IPdfColor, IPdfColor, Boolean, Boolean, PdfLineStyle, PdfFillMethod) | Conditionallies the clip stroke or fill.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


ShapeUtilities Constructor

Initializes a new instance of the ShapeUtilities class

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ShapeUtilities()
Public Sub New
See Also

Reference

ShapeUtilities Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ShapeUtilities Methods

The ShapeUtilities type exposes the following members.

Methods
 | Name | Description
 | ConditionallyClipStrokeOrFill(PdfPageRenderer, IPdfColor, IPdfColor, Boolean, PdfLineStyle, PdfFillMethod) | Conditionallies the clip stroke or fill.
 | ConditionallyClipStrokeOrFill(PdfPageRenderer, IPdfColor, IPdfColor, Boolean, Boolean, PdfLineStyle, PdfFillMethod) | Conditionallies the clip stroke or fill.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShapeUtilities Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ShapeUtilities.ConditionallyClipStrokeOrFill Method

ShapeUtilitiesConditionallyClipStrokeOrFill Method

Overload List
Name | Description
ConditionallyClipStrokeOrFill(PdfPageRenderer, IPdfColor, IPdfColor, Boolean, PdfLineStyle, PdfFillMethod) | Conditionallies the clip stroke or fill.
ConditionallyClipStrokeOrFill(PdfPageRenderer, IPdfColor, IPdfColor, Boolean, Boolean, PdfLineStyle, PdfFillMethod) | Conditionallies the clip stroke or fill.
Top
See Also

Reference

ShapeUtilities Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


ShapeUtilities.ConditionallyClipStrokeOrFill Method (PdfPageRenderer, IPdfColor, IPdfColor, Boolean, PdfLineStyle, PdfFillMethod)

ShapeUtilitiesConditionallyClipStrokeOrFill Method (PdfPageRenderer, IPdfColor, IPdfColor, Boolean, PdfLineStyle, PdfFillMethod)

Conditionallies the clip stroke or fill.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ConditionallyClipStrokeOrFill(
    PdfPageRenderer r,
    IPdfColor strokeColor,
    IPdfColor fillColor,
    bool clip,
    PdfLineStyle style,
    PdfFillMethod fillMethod
)
Public Shared Sub ConditionallyClipStrokeOrFill (
    r As PdfPageRenderer,
    strokeColor As IPdfColor,
    fillColor As IPdfColor,
    clip As Boolean,
    style As PdfLineStyle,
    fillMethod As PdfFillMethod
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The r.
strokeColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the stroke.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
clip
Type: SystemBoolean
if set to true [clip].
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style.
fillMethod
Type: Atalasoft.PdfDoc.Generating.RenderingPdfFillMethod
The fill method.
See Also

Reference

ShapeUtilities Class
ConditionallyClipStrokeOrFill Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


ShapeUtilities.ConditionallyClipStrokeOrFill Method (PdfPageRenderer, IPdfColor, IPdfColor, Boolean, Boolean, PdfLineStyle, PdfFillMethod)

ShapeUtilitiesConditionallyClipStrokeOrFill Method (PdfPageRenderer, IPdfColor, IPdfColor, Boolean, Boolean, PdfLineStyle, PdfFillMethod)

Conditionallies the clip stroke or fill.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static void ConditionallyClipStrokeOrFill(
    PdfPageRenderer r,
    IPdfColor strokeColor,
    IPdfColor fillColor,
    bool clip,
    bool maintainPathAfterClip,
    PdfLineStyle style,
    PdfFillMethod fillMethod
)
Public Shared Sub ConditionallyClipStrokeOrFill (
    r As PdfPageRenderer,
    strokeColor As IPdfColor,
    fillColor As IPdfColor,
    clip As Boolean,
    maintainPathAfterClip As Boolean,
    style As PdfLineStyle,
    fillMethod As PdfFillMethod
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
The r.
strokeColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the stroke.
fillColor
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
Color of the fill.
clip
Type: SystemBoolean
if set to true [clip].
maintainPathAfterClip
Type: SystemBoolean
true if the shape will maintain the current path after clip; otherwise, false.
style
Type: Atalasoft.PdfDoc.Generating.RenderingPdfLineStyle
The style.
fillMethod
Type: Atalasoft.PdfDoc.Generating.RenderingPdfFillMethod
The fill method.
See Also

Reference

ShapeUtilities Class
ConditionallyClipStrokeOrFill Overload
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput Class

An object used to provide styled text to pdf text objects that can handle style changes.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesStyleTextInput

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StyleTextInput
Public Class StyleTextInput

The StyleTextInput type exposes the following members.

Constructors
 | Name | Description
Public method | StyleTextInput | Initializes a new instance of the StyleTextInput class.
Top
Properties
 | Name | Description
Public property | ContainsText | Gets a value indicating whether the input contains text.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Top
Methods
 | Name | Description
Public method | AddLineBreak | Adds a line break to the input.
Public method | AddText | Adds text of the current style to the input.
Public method | ChangeFont | Changes the font of future text input.
Public method | ChangeFontColor | Changes the color of the font of future text input.
Public method | ChangeFontSize | Changes the size of the font of future text input.
Public method | ChangeHoizontalScale | Changes the hoizontal scale of future text input.
Public method | ChangeOutlineColor | Changes the color of the outline of future text input.
Public method | ChangeStyle | Changes the style of the future text input.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput Constructor

Initializes a new instance of the StyleTextInput class.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StyleTextInput(
    string defaultFontName
)
Public Sub New (
    defaultFontName As String
)

Parameters

defaultFontName
Type: SystemString
Default name of the font.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput Properties

The StyleTextInput type exposes the following members.

Properties
 | Name | Description
Public property | ContainsText | Gets a value indicating whether the input contains text.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Top
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ContainsText Property

StyleTextInputContainsText Property

Gets a value indicating whether the input contains text.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ContainsText { get; }
Public ReadOnly Property ContainsText As Boolean
    Get

Property Value

Type: Boolean
true if the input contains text; otherwise, false.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.IsEmpty Property

StyleTextInputIsEmpty Property

Gets a value indicating whether this instance is empty.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if this instance is empty; otherwise, false.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput Methods

The StyleTextInput type exposes the following members.

Methods
 | Name | Description
Public method | AddLineBreak | Adds a line break to the input.
Public method | AddText | Adds text of the current style to the input.
Public method | ChangeFont | Changes the font of future text input.
Public method | ChangeFontColor | Changes the color of the font of future text input.
Public method | ChangeFontSize | Changes the size of the font of future text input.
Public method | ChangeHoizontalScale | Changes the hoizontal scale of future text input.
Public method | ChangeOutlineColor | Changes the color of the outline of future text input.
Public method | ChangeStyle | Changes the style of the future text input.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.AddLineBreak Method

StyleTextInputAddLineBreak Method

Adds a line break to the input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddLineBreak()
Public Sub AddLineBreak
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.AddText Method

StyleTextInputAddText Method

Adds text of the current style to the input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void AddText(
    string text
)
Public Sub AddText (
    text As String
)

Parameters

text
Type: SystemString
The text.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ChangeFont Method

StyleTextInputChangeFont Method

Changes the font of future text input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeFont(
    string fontName
)
Public Sub ChangeFont (
    fontName As String
)

Parameters

fontName
Type: SystemString
Name of the font of future text input.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ChangeFontColor Method

StyleTextInputChangeFontColor Method

Changes the color of the font of future text input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeFontColor(
    IPdfColor color
)
Public Sub ChangeFontColor (
    color As IPdfColor
)

Parameters

color
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
The color of future text input.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ChangeFontSize Method

StyleTextInputChangeFontSize Method

Changes the size of the font of future text input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeFontSize(
    double p
)
Public Sub ChangeFontSize (
    p As Double
)

Parameters

p
Type: SystemDouble
The point size of the future text input.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ChangeHoizontalScale Method

StyleTextInputChangeHoizontalScale Method

Changes the hoizontal scale of future text input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeHoizontalScale(
    double scaleFactor
)
Public Sub ChangeHoizontalScale (
    scaleFactor As Double
)

Parameters

scaleFactor
Type: SystemDouble
The scale factor of future text input (100 is default).
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ChangeOutlineColor Method

StyleTextInputChangeOutlineColor Method

Changes the color of the outline of future text input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeOutlineColor(
    IPdfColor color
)
Public Sub ChangeOutlineColor (
    color As IPdfColor
)

Parameters

color
Type: Atalasoft.PdfDoc.GeneratingIPdfColor
The color of the outline of future text input.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


StyleTextInput.ChangeStyle Method

StyleTextInputChangeStyle Method

Changes the style of the future text input.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ChangeStyle(
    PdfTextStyle style
)
Public Sub ChangeStyle (
    style As PdfTextStyle
)

Parameters

style
Type: Atalasoft.PdfDoc.Generating.ShapesPdfTextStyle
The style of future text input.
See Also

Reference

StyleTextInput Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform Class

Transform represents an Affine transform in PDF page. It wraps a PdfTransform object and will apply it upon render. Client code should avoid injecting transformations that have no inverse (Scale with 0 in either or both X and Y), as it creates a degenrate transform that can only be undone with a GRestore to a prior GSave. Since this has other side effects (changing clipping, line thickness and so on), it is not good practice.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesTransform

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Transform : IPdfRenderable
<SerializableAttribute>
Public Class Transform
    Implements IPdfRenderable

The Transform type exposes the following members.

Constructors
 | Name | Description
Public method | Transform | Construct a new Transform object with the given PdfTransform.
Top
Properties
 | Name | Description
 | Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Public property | TransformationMatrix | Gets or sets the transformation matrix that will be applied when this object is rendered.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInverse | Returns a new Transform object which represents the inverse transform.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInvertable | Returns true if the TransformationMatrix has an inverse false otherwise.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform Constructor

Construct a new Transform object with the given PdfTransform.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Transform(
    PdfTransform transformationMatrix
)
Public Sub New (
    transformationMatrix As PdfTransform
)

Parameters

transformationMatrix
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The PdfTransform that will be applied. The transform is used directly, not copied.
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform Properties

The Transform type exposes the following members.

Properties
 | Name | Description
 | Name | Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.
Public property | TransformationMatrix | Gets or sets the transformation matrix that will be applied when this object is rendered.
Top
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform.Name Property

TransformName Property

Gets or sets the name of the object. The use of this property is not dictated by the PDF Authoring API. It is in place as a convenience for client code where it could be used for creating named objects in PDF content for later retrieval/editing.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the object.

Implements

IPdfRenderableName
Examples
Copy
foreach (IPdfRenderable namedGroup in list.FindAll(item => item.Name == "Group") {
ProcessGroup(namedGroup);
}
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform.TransformationMatrix Property

TransformTransformationMatrix Property

Gets or sets the transformation matrix that will be applied when this object is rendered.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform TransformationMatrix { get; set; }
Public Property TransformationMatrix As PdfTransform
    Get
    Set

Property Value

Type: PdfTransform
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform Methods

The Transform type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInverse | Returns a new Transform object which represents the inverse transform.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInvertable | Returns true if the TransformationMatrix has an inverse false otherwise.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render | Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform.GetInverse Method

TransformGetInverse Method

Returns a new Transform object which represents the inverse transform.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Transform GetInverse()
Public Function GetInverse As Transform

Return Value

Type: Transform
A new inverse Transform object.
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform.IsInvertable Method

TransformIsInvertable Method

Returns true if the TransformationMatrix has an inverse false otherwise.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsInvertable()
Public Function IsInvertable As Boolean

Return Value

Type: Boolean
true if the matrix has an inverse; false otherwise.
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Transform.Render Method

TransformRender Method

Generates PDF content for this object using the provider PdfPageRenderer object. The PdfPageRenderer represents an object that is aggregating PDF content for a particular page. It is the responsibility of each object that implements IPdfRenderable to add content appropriate for that object to the page.

Namespace: Atalasoft.PdfDoc.Generating.Shapes
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Render(
    PdfPageRenderer r
)
Public Sub Render (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer

Implements

IPdfRenderableRender(PdfPageRenderer)
Examples
Copy
public void GeneratePdf(PdfPageRenderer r)
{
w.DrawingSurface.Begin();
w.DrawingSurface.AddRect(MyBounds); // place a rectangle
w.DrawingSurface.Stroke(PdfLineStyle.Default, MyColor); // draw its outline in black
w.DrawingSurface.End();
}
See Also

Reference

Transform Class
Atalasoft.PdfDoc.Generating.Shapes Namespace


Atalasoft.PdfDoc.Generating.Templates Namespace

Classes
Class Description
DrawingTemplate
A DrawingTemplate is a representation of a reusable drawing to be placed on a page or to be used to set or replace the appearance of an annotation on a page. DrawingTemplate objects are never used directly. Instead, after they are created they are stored in a document's Resources property and referenced throughout the document by the resource name instead of using the DrawingTemplate directly. DrawingTemplate objects themselves may refer to other resources including image, font, colorspace, and template resources. DrawingTemplate objects have a Bounds property that specifies the area in which the DrawingTemplate will be constrained when drawn. Any marks outside of this box will be clipped out of view. To use a DrawingTemplate within a page or another template, make a PdfTemplateShape that references the template's resource name. The PdfTemplateShape can be put into the page's DrawingList. To build the visual components of a template, make shape objects and put them in the template's DrawingList.
Enumerations
 | Enumeration | Description
Public enumeration | TemplateColorSpaceKind | This represents possible color spaces for a transparent DrawingTemplate.
Public enumeration | TemplateKind | TemplateKind describes the general usage of a DrawingTemplate.


DrawingTemplate Class

A DrawingTemplate is a representation of a reusable drawing to be placed on a page or to be used to set or replace the appearance of an annotation on a page. DrawingTemplate objects are never used directly. Instead, after they are created they are stored in a document's Resources property and referenced throughout the document by the resource name instead of using the DrawingTemplate directly. DrawingTemplate objects themselves may refer to other resources including image, font, colorspace, and template resources. DrawingTemplate objects have a Bounds property that specifies the area in which the DrawingTemplate will be constrained when drawn. Any marks outside of this box will be clipped out of view. To use a DrawingTemplate within a page or another template, make a PdfTemplateShape that references the template's resource name. The PdfTemplateShape can be put into the page's DrawingList. To build the visual components of a template, make shape objects and put them in the template's DrawingList.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.TemplatesDrawingTemplate

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DrawingTemplate
Public Class DrawingTemplate

The DrawingTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | DrawingTemplate(PdfBounds) | Initializes a new instance of the DrawingTemplate class with the supplied bounds.
Public method | DrawingTemplate(Double, Double) | Initializes a new instance of the DrawingTemplate class with the supplied width and height.
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds for the template. All drawing will be limited to the interior of the bounds.
Public property | ColorSpace | Gets or sets the color space preferred by the template. In general, this is used by the PDF viewer when the template is rendered transparently. In such a case, the template will be rendered to this color space before compositing with other elements.
Public property | DrawingList | Gets the drawing list that represents shapes in the template.
Public property | ICCResourceName | Gets or sets the name of the ICC resource to be used as a ColorSpace if the template should be rendered with a calibrated color space.
Public property | ImportedFonts | If the template was imported from an existing PDF, this will contain a list of fonts that were successfully imported into the resource dictionary.
Public property | Kind | Gets or sets the kind of drawing template. Currently only Normal or Transparency are supported.
Public property | TransformationMatrix | Gets or sets the transformation matrix that maps the coordinates of elements in the template to the surface on which it's drawn. The default is the identity matrix.
Public property | TransparencyIsIsolated | Gets or sets a value indicating whether transparency for this template will be isolated from the rest of the backdrop.
Public property | TransparencyIsKnockout | Gets or sets a value indicating whether transparency is a knockout, meaning that it will be composited with the template's backdrop rather than preceding elements in the template.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Making a triangle shape.
Copy
DrawingTemplate template = new DrawingTemplate(new PdfBounds(0, 0, 100, 100));
PdfPath path = new PdfPath(PdfColorFactory.FromRgb(0, 0, 0), 2, PdfColorFactory.FromRgb(1, 1, 0));
path.MoveTo(2, 2);
path.LineTo(98, 2);
path.LineTo(50, 98);
path.Close();
template.DrawingList.Add(path);
string resourceName = doc.Resources.Templates.Add(template);
PdfTemplateShape shape = new PdfTemplateShape(resourceName, template.Bounds);
page.DrawingList.Add(shape); // this puts the template on the page
See Also

Reference

Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate Constructor

Overload List
 | Name | Description
Public method | DrawingTemplate(PdfBounds) | Initializes a new instance of the DrawingTemplate class with the supplied bounds.
Public method | DrawingTemplate(Double, Double) | Initializes a new instance of the DrawingTemplate class with the supplied width and height.
Top
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate Constructor (PdfBounds)

Initializes a new instance of the DrawingTemplate class with the supplied bounds.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DrawingTemplate(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

DrawingTemplate Class
DrawingTemplate Overload
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate Constructor (Double, Double)

Initializes a new instance of the DrawingTemplate class with the supplied width and height.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DrawingTemplate(
    double width,
    double height
)
Public Sub New (
    width As Double,
    height As Double
)

Parameters

width
Type: SystemDouble
The width of the bounding box.
height
Type: SystemDouble
The height of the bounding box.
Remarks
This is equivalent to DrawingTemplate(new PdfBounds(0, 0, width, height))
See Also

Reference

DrawingTemplate Class
DrawingTemplate Overload
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate Properties

The DrawingTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets the bounds for the template. All drawing will be limited to the interior of the bounds.
Public property | ColorSpace | Gets or sets the color space preferred by the template. In general, this is used by the PDF viewer when the template is rendered transparently. In such a case, the template will be rendered to this color space before compositing with other elements.
Public property | DrawingList | Gets the drawing list that represents shapes in the template.
Public property | ICCResourceName | Gets or sets the name of the ICC resource to be used as a ColorSpace if the template should be rendered with a calibrated color space.
Public property | ImportedFonts | If the template was imported from an existing PDF, this will contain a list of fonts that were successfully imported into the resource dictionary.
Public property | Kind | Gets or sets the kind of drawing template. Currently only Normal or Transparency are supported.
Public property | TransformationMatrix | Gets or sets the transformation matrix that maps the coordinates of elements in the template to the surface on which it's drawn. The default is the identity matrix.
Public property | TransparencyIsIsolated | Gets or sets a value indicating whether transparency for this template will be isolated from the rest of the backdrop.
Public property | TransparencyIsKnockout | Gets or sets a value indicating whether transparency is a knockout, meaning that it will be composited with the template's backdrop rather than preceding elements in the template.
Top
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.Bounds Property

DrawingTemplateBounds Property

Gets or sets the bounds for the template. All drawing will be limited to the interior of the bounds.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Bounds { get; set; }
Public Property Bounds As PdfBounds
    Get
    Set

Property Value

Type: PdfBounds
The bounds.
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.ColorSpace Property

DrawingTemplateColorSpace Property

Gets or sets the color space preferred by the template. In general, this is used by the PDF viewer when the template is rendered transparently. In such a case, the template will be rendered to this color space before compositing with other elements.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TemplateColorSpaceKind ColorSpace { get; set; }
Public Property ColorSpace As TemplateColorSpaceKind
    Get
    Set

Property Value

Type: TemplateColorSpaceKind
The color space.
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.DrawingList Property

DrawingTemplateDrawingList Property

Gets the drawing list that represents shapes in the template.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDrawingList DrawingList { get; }
Public ReadOnly Property DrawingList As PdfDrawingList
    Get

Property Value

Type: PdfDrawingList
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.ICCResourceName Property

DrawingTemplateICCResourceName Property

Gets or sets the name of the ICC resource to be used as a ColorSpace if the template should be rendered with a calibrated color space.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ICCResourceName { get; set; }
Public Property ICCResourceName As String
    Get
    Set

Property Value

Type: String
The name of the ICC resource.
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.ImportedFonts Property

DrawingTemplateImportedFonts Property

If the template was imported from an existing PDF, this will contain a list of fonts that were successfully imported into the resource dictionary.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerable<string> ImportedFonts { get; }
Public ReadOnly Property ImportedFonts As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerableString
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.Kind Property

DrawingTemplateKind Property

Gets or sets the kind of drawing template. Currently only Normal or Transparency are supported.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TemplateKind Kind { get; set; }
Public Property Kind As TemplateKind
    Get
    Set

Property Value

Type: TemplateKind
The kind of template
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.TransformationMatrix Property

DrawingTemplateTransformationMatrix Property

Gets or sets the transformation matrix that maps the coordinates of elements in the template to the surface on which it's drawn. The default is the identity matrix.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform TransformationMatrix { get; set; }
Public Property TransformationMatrix As PdfTransform
    Get
    Set

Property Value

Type: PdfTransform
The transformation matrix.
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.TransparencyIsIsolated Property

DrawingTemplateTransparencyIsIsolated Property

Gets or sets a value indicating whether transparency for this template will be isolated from the rest of the backdrop.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TransparencyIsIsolated { get; set; }
Public Property TransparencyIsIsolated As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the transparency is isolated; otherwise, false.
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate.TransparencyIsKnockout Property

DrawingTemplateTransparencyIsKnockout Property

Gets or sets a value indicating whether transparency is a knockout, meaning that it will be composited with the template's backdrop rather than preceding elements in the template.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TransparencyIsKnockout { get; set; }
Public Property TransparencyIsKnockout As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the transparency is knockout; otherwise, false.
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


DrawingTemplate Methods

The DrawingTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DrawingTemplate Class
Atalasoft.PdfDoc.Generating.Templates Namespace


TemplateColorSpaceKind Enumeration

This represents possible color spaces for a transparent DrawingTemplate.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum TemplateColorSpaceKind
Public Enumeration TemplateColorSpaceKind
Members
Member name | Description
None | None specified.
RGB | Red, green, and blue.
CMYK | Cyan, magenta, yellow, and black.
Gray | Grayscale.
CalibratedGray | Calibrated grayscale.
CalibratedRGB | Calibrated red, green and blue.
ICC | An ICC color space. This should always be accompanied with a colorspace resource.
See Also

Reference

Atalasoft.PdfDoc.Generating.Templates Namespace


TemplateKind Enumeration

TemplateKind describes the general usage of a DrawingTemplate.

Namespace: Atalasoft.PdfDoc.Generating.Templates
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum TemplateKind
<FlagsAttribute>
Public Enumeration TemplateKind
Members
Member name | Description
Normal | This represents a normal drawing.
Transparency | This represents a template that should be drawn with transparency.
Reference | This represents a template that is contained within a separate PDF file and is not currently supported.
See Also

Reference

Atalasoft.PdfDoc.Generating.Templates Namespace


Atalasoft.PdfDoc.Generating.Utilities Namespace

Structures
 | Structure | Description
Public structure | KerningPair | An object to represent a "kerning pair". A "kerning pair" is comprised of a string and a kern value. The kern value represents how much spacing exists inbetween each letter.


KerningPair Structure

An object to represent a "kerning pair". A "kerning pair" is comprised of a string and a kern value. The kern value represents how much spacing exists inbetween each letter.

Namespace: Atalasoft.PdfDoc.Generating.Utilities
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct KerningPair
<SerializableAttribute>
Public Structure KerningPair

The KerningPair type exposes the following members.

Constructors
 | Name | Description
Public method | KerningPair | Initializes a new instance of the KerningPair struct.
Top
Properties
 | Name | Description
Public property | KernValue | Gets or sets the kern value.
Public property | Text | Gets or sets the text.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Utilities Namespace


KerningPair Constructor

Initializes a new instance of the KerningPair struct.

Namespace: Atalasoft.PdfDoc.Generating.Utilities
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public KerningPair(
    string text,
    int kernValue
)
Public Sub New (
    text As String,
    kernValue As Integer
)

Parameters

text
Type: SystemString
The text.
kernValue
Type: SystemInt32
The kern value.
See Also

Reference

KerningPair Structure
Atalasoft.PdfDoc.Generating.Utilities Namespace


KerningPair Properties

The KerningPair type exposes the following members.

Properties
 | Name | Description
Public property | KernValue | Gets or sets the kern value.
Public property | Text | Gets or sets the text.
Top
See Also

Reference

KerningPair Structure
Atalasoft.PdfDoc.Generating.Utilities Namespace


KerningPair.KernValue Property

KerningPairKernValue Property

Gets or sets the kern value.

Namespace: Atalasoft.PdfDoc.Generating.Utilities
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int KernValue { get; }
Public ReadOnly Property KernValue As Integer
    Get

Property Value

Type: Int32
The kern value.
See Also

Reference

KerningPair Structure
Atalasoft.PdfDoc.Generating.Utilities Namespace


KerningPair.Text Property

KerningPairText Property

Gets or sets the text.

Namespace: Atalasoft.PdfDoc.Generating.Utilities
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The text.
See Also

Reference

KerningPair Structure
Atalasoft.PdfDoc.Generating.Utilities Namespace


KerningPair Methods

The KerningPair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

KerningPair Structure
Atalasoft.PdfDoc.Generating.Utilities Namespace


Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace

Classes
 | Class | Description
Public class | SvgParsingErrorEventArgs | This class is used for encapsulating errors encountered while parsing SVG files.
Delegates
 | Delegate | Description
Public delegate | SvgParsingErrorEventHandler | Event handler when errors occur when reading images.
Enumerations
 | Enumeration | Description
Public enumeration | ErrorLevel |


ErrorLevel Enumeration

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ErrorLevel
Public Enumeration ErrorLevel
Members
Member name | Description
None | This value denotes that there is no error present. While it is not presently used, it is included for the sake of completeness.
Warning | This value denotes that a problem of very mild severity has been detected in a codec.
Error | This value denotes that a problem of moderate to high severity has been detected in a codec.
Fatal | This value denotes that there a severe error has occurred that could be fatal to the CLR or the current application. This severity should never be used in released software.
Remarks
This enumeration is used in the SvgParsingErrorEventArgs class in order to denote the severity of an error.
See Also

Reference

Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventArgs Class

This class is used for encapsulating errors encountered while parsing SVG files.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.Utilities.VectorImportSvgParsingErrorEventArgs

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class SvgParsingErrorEventArgs
Public Class SvgParsingErrorEventArgs

The SvgParsingErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SvgParsingErrorEventArgs | Construct a new set CodecErrorEventArgs object.
Top
Properties
 | Name | Description
Public property | Description | Get the description of the error that has occurred.
Public property | ErrorLevel | Get the severity of the error that has occurred.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventArgs Constructor

Construct a new set CodecErrorEventArgs object.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgParsingErrorEventArgs(
    string description,
    ErrorLevel level
)
Public Sub New (
    description As String,
    level As ErrorLevel
)

Parameters

description
Type: SystemString
A string description of the error that has occurred.
level
Type: Atalasoft.PdfDoc.Generating.Utilities.VectorImportErrorLevel
The severity of the error that has occurred.
See Also

Reference

SvgParsingErrorEventArgs Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventArgs Properties

The SvgParsingErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Description | Get the description of the error that has occurred.
Public property | ErrorLevel | Get the severity of the error that has occurred.
Top
See Also

Reference

SvgParsingErrorEventArgs Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventArgs.Description Property

SvgParsingErrorEventArgsDescription Property

Get the description of the error that has occurred.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

SvgParsingErrorEventArgs Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventArgs.ErrorLevel Property

SvgParsingErrorEventArgsErrorLevel Property

Get the severity of the error that has occurred.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ErrorLevel ErrorLevel { get; }
Public ReadOnly Property ErrorLevel As ErrorLevel
    Get

Property Value

Type: ErrorLevel
See Also

Reference

SvgParsingErrorEventArgs Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventArgs Methods

The SvgParsingErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SvgParsingErrorEventArgs Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


SvgParsingErrorEventHandler Delegate

Event handler when errors occur when reading images.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void SvgParsingErrorEventHandler(
    Object sender,
    SvgParsingErrorEventArgs e
)
Public Delegate Sub SvgParsingErrorEventHandler (
    sender As Object,
    e As SvgParsingErrorEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: Atalasoft.PdfDoc.Generating.Utilities.VectorImportSvgParsingErrorEventArgs
See Also

Reference

Atalasoft.PdfDoc.Generating.Utilities.VectorImport Namespace


Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace

Classes
 | Class | Description
Public class | SvgDocument | This object is created by parsing an SVG file. It extends from IPdfRenderable so it can be placed in a drawing list of a page.


SvgDocument Class

This object is created by parsing an SVG file. It extends from IPdfRenderable so it can be placed in a drawing list of a page.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.Generating.ShapesPdfBaseShape
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOMSvgDocument

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SvgDocument : PdfBaseShape
<SerializableAttribute>
Public Class SvgDocument
    Inherits PdfBaseShape

The SvgDocument type exposes the following members.

Constructors
 | Name | Description
Public method | SvgDocument(String, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(XmlDocument, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(String, Double, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(XmlDocument, Double, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(String, Double, PdfGeneratedDocument, SvgParsingErrorEventHandler) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(XmlDocument, Double, PdfGeneratedDocument, SvgParsingErrorEventHandler) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Top
Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | PageHeight | The page height defined in SVG xml
Public property | PageWidth | The page width defined in SVG xml
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Version | The version defined in SVG xml
Public property | ViewBox | The viewbox defined in the root svg node
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Creates a clone of current SvgDocument (Overrides PdfBaseShapeCloneInstance.)
Protected method | CloneInstance(PdfGeneratedDocument) | Creates a clone of current SvgDocument
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Override of PdfBaseShape DrawShape. Draws all SVG shapes that need rendering for document. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromSvg(String, PdfGeneratedDocument) | Creates a new DrawingTemplate with a drawing list containing the supplied SVG.
 | FromSvg(XmlDocument, PdfGeneratedDocument) | Creates a new DrawingTemplate with a drawing list containing the supplied SVG.
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | SvgParsingError | This event is used by the SvgDocument object to report errors that occur when parsing a SVG file.
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor

Overload List
 | Name | Description
Public method | SvgDocument(String, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(XmlDocument, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(String, Double, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(XmlDocument, Double, PdfGeneratedDocument) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(String, Double, PdfGeneratedDocument, SvgParsingErrorEventHandler) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Public method | SvgDocument(XmlDocument, Double, PdfGeneratedDocument, SvgParsingErrorEventHandler) | A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.
Top
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor (String, PdfGeneratedDocument)

A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgDocument(
    string filePath,
    PdfGeneratedDocument doc
)
Public Sub New (
    filePath As String,
    doc As PdfGeneratedDocument
)

Parameters

filePath
Type: SystemString
The path to the .svg file
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The PdfGeneratedDocument object the SVG will be inserted.
See Also

Reference

SvgDocument Class
SvgDocument Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor (XmlDocument, PdfGeneratedDocument)

A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgDocument(
    XmlDocument xml,
    PdfGeneratedDocument doc
)
Public Sub New (
    xml As XmlDocument,
    doc As PdfGeneratedDocument
)

Parameters

xml
Type: System.XmlXmlDocument
An XmlDocument object loaded with SVG. Can use the LoadXml() method to load a string of SVG
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The PdfGeneratedDocument object to the SVG will be inserted.
See Also

Reference

SvgDocument Class
SvgDocument Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor (String, Double, PdfGeneratedDocument)

A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgDocument(
    string filePath,
    double pageHeight,
    PdfGeneratedDocument doc
)
Public Sub New (
    filePath As String,
    pageHeight As Double,
    doc As PdfGeneratedDocument
)

Parameters

filePath
Type: SystemString
The path to the .svg file
pageHeight
Type: SystemDouble
The page height of the Pdf Document the SVG objects will appear
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The PdfGeneratedDocument object the SVG will be inserted.
See Also

Reference

SvgDocument Class
SvgDocument Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor (XmlDocument, Double, PdfGeneratedDocument)

A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgDocument(
    XmlDocument xml,
    double pageHeight,
    PdfGeneratedDocument doc
)
Public Sub New (
    xml As XmlDocument,
    pageHeight As Double,
    doc As PdfGeneratedDocument
)

Parameters

xml
Type: System.XmlXmlDocument
An XmlDocument object loaded with SVG. Can use the LoadXml() method to load a string of SVG
pageHeight
Type: SystemDouble
The page height of the Pdf Document the SVG objects will appear
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The PdfGeneratedDocument object to the SVG will be inserted.
See Also

Reference

SvgDocument Class
SvgDocument Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor (String, Double, PdfGeneratedDocument, SvgParsingErrorEventHandler)

A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgDocument(
    string filePath,
    double pageHeight,
    PdfGeneratedDocument doc,
    SvgParsingErrorEventHandler parsingErrorHandler
)
Public Sub New (
    filePath As String,
    pageHeight As Double,
    doc As PdfGeneratedDocument,
    parsingErrorHandler As SvgParsingErrorEventHandler
)

Parameters

filePath
Type: SystemString
The path to the .svg file
pageHeight
Type: SystemDouble
The page height of the Pdf Document the SVG objects will appear
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The PdfGeneratedDocument object the SVG will be inserted.
parsingErrorHandler
Type: Atalasoft.PdfDoc.Generating.Utilities.VectorImportSvgParsingErrorEventHandler
The parsing error delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

SvgDocument Class
SvgDocument Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Constructor (XmlDocument, Double, PdfGeneratedDocument, SvgParsingErrorEventHandler)

A PdfRenderable object that should be added to a PdfGeneratedPage drawing list to allow objects from a Svg file to be inserted on page.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SvgDocument(
    XmlDocument xml,
    double pageHeight,
    PdfGeneratedDocument doc,
    SvgParsingErrorEventHandler parsingErrorHandler
)
Public Sub New (
    xml As XmlDocument,
    pageHeight As Double,
    doc As PdfGeneratedDocument,
    parsingErrorHandler As SvgParsingErrorEventHandler
)

Parameters

xml
Type: System.XmlXmlDocument
An XmlDocument object loaded with SVG. Can use the LoadXml() method to load a string of SVG
pageHeight
Type: SystemDouble
The page height of the Pdf Document the SVG objects will appear
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The PdfGeneratedDocument object to the SVG will be inserted.
parsingErrorHandler
Type: Atalasoft.PdfDoc.Generating.Utilities.VectorImportSvgParsingErrorEventHandler
The parsing error delegate. Can be set to null (Nothing in Visual Basic).
See Also

Reference

SvgDocument Class
SvgDocument Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Properties

The SvgDocument type exposes the following members.

Properties
 | Name | Description
Public property | Clip | Gets or sets a value indicating whether this PdfBaseShape shape will clip. (Inherited from PdfBaseShape.)
Public property | FillColor | Gets or sets the color of the fill. (Inherited from PdfBaseShape.)
Public property | Location | Gets or sets the location. (Inherited from PdfBaseShape.)
Public property | Name | Gets or sets the name of the IPdfRenderable object. (Inherited from PdfBaseShape.)
Public property | OutlineColor | Gets or sets the color of the outline. (Inherited from PdfBaseShape.)
Public property | PageHeight | The page height defined in SVG xml
Public property | PageWidth | The page width defined in SVG xml
Public property | Rotation | Gets or sets the rotation in degrees. (Inherited from PdfBaseShape.)
Public property | Scale | Gets or sets the scale. (Inherited from PdfBaseShape.)
Public property | Style | Gets or sets the style. (Inherited from PdfBaseShape.)
Public property | Version | The version defined in SVG xml
Public property | ViewBox | The viewbox defined in the root svg node
Top
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.PageHeight Property

SvgDocumentPageHeight Property

The page height defined in SVG xml

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PageHeight { get; }
Public ReadOnly Property PageHeight As Double
    Get

Property Value

Type: Double
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.PageWidth Property

SvgDocumentPageWidth Property

The page width defined in SVG xml

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double PageWidth { get; }
Public ReadOnly Property PageWidth As Double
    Get

Property Value

Type: Double
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.Version Property

SvgDocumentVersion Property

The version defined in SVG xml

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.ViewBox Property

SvgDocumentViewBox Property

The viewbox defined in the root svg node

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ViewBox { get; set; }
Public Property ViewBox As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Methods

The SvgDocument type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from PdfBaseShape.)
Protected method | CloneInstance | Creates a clone of current SvgDocument (Overrides PdfBaseShapeCloneInstance.)
Protected method | CloneInstance(PdfGeneratedDocument) | Creates a clone of current SvgDocument
Public method | CopyBaseShapePropertiesTo | Copies the base shape properties to the parameter shape. (Inherited from PdfBaseShape.)
Protected method | DrawShape | Override of PdfBaseShape DrawShape. Draws all SVG shapes that need rendering for document. (Overrides PdfBaseShapeDrawShape(PdfPageRenderer).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromSvg(String, PdfGeneratedDocument) | Creates a new DrawingTemplate with a drawing list containing the supplied SVG.
 | FromSvg(XmlDocument, PdfGeneratedDocument) | Creates a new DrawingTemplate with a drawing list containing the supplied SVG.
Protected method | GenerateTransform | Generates the default transform based on Scale, Rotate, and Translate. (Inherited from PdfBaseShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyResourceRenamed | Notifies a resource consumer that a resource was renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourceRenamed | Called when a resource in the base shape has been renamed. (Inherited from PdfBaseShape.)
Protected method | OnResourcesRequested | Called when the PdfBaseShape is requested to report resources used. If client code consumes resources, it should override this method combining its results with those of base.OnResourceRequested (Inherited from PdfBaseShape.)
Public method | Render | Generates the PDF. (Inherited from PdfBaseShape.)
Public method | ResourcesUsed | Reports a list of all resources consumed by the object of the given class. (Inherited from PdfBaseShape.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.CloneInstance Method

SvgDocumentCloneInstance Method

Overload List
 | Name | Description
Protected method | CloneInstance | Creates a clone of current SvgDocument (Overrides PdfBaseShapeCloneInstance.)
Protected method | CloneInstance(PdfGeneratedDocument) | Creates a clone of current SvgDocument
Top
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.CloneInstance Method

SvgDocumentCloneInstance Method

Creates a clone of current SvgDocument

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override PdfBaseShape CloneInstance()
Protected Overrides Function CloneInstance As PdfBaseShape

Return Value

Type: PdfBaseShape
See Also

Reference

SvgDocument Class
CloneInstance Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.CloneInstance Method (PdfGeneratedDocument)

SvgDocumentCloneInstance Method (PdfGeneratedDocument)

Creates a clone of current SvgDocument

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfBaseShape CloneInstance(
    PdfGeneratedDocument doc
)
Protected Function CloneInstance (
    doc As PdfGeneratedDocument
) As PdfBaseShape

Parameters

doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument

Return Value

Type: PdfBaseShape
See Also

Reference

SvgDocument Class
CloneInstance Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.DrawShape Method

SvgDocumentDrawShape Method

Override of PdfBaseShape DrawShape. Draws all SVG shapes that need rendering for document.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void DrawShape(
    PdfPageRenderer r
)
Protected Overrides Sub DrawShape (
    r As PdfPageRenderer
)

Parameters

r
Type: Atalasoft.PdfDoc.Generating.RenderingPdfPageRenderer
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.FromSvg Method

SvgDocumentFromSvg Method

Overload List
Name | Description
FromSvg(String, PdfGeneratedDocument) | Creates a new DrawingTemplate with a drawing list containing the supplied SVG.
FromSvg(XmlDocument, PdfGeneratedDocument) | Creates a new DrawingTemplate with a drawing list containing the supplied SVG.
Top
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.FromSvg Method (String, PdfGeneratedDocument)

SvgDocumentFromSvg Method (String, PdfGeneratedDocument)

Creates a new DrawingTemplate with a drawing list containing the supplied SVG.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DrawingTemplate FromSvg(
    string filePath,
    PdfGeneratedDocument doc
)
Public Shared Function FromSvg (
    filePath As String,
    doc As PdfGeneratedDocument
) As DrawingTemplate

Parameters

filePath
Type: SystemString
The path to an SVG file.
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The receiving PdfGeneratedDocument.

Return Value

Type: DrawingTemplate
See Also

Reference

SvgDocument Class
FromSvg Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.FromSvg Method (XmlDocument, PdfGeneratedDocument)

SvgDocumentFromSvg Method (XmlDocument, PdfGeneratedDocument)

Creates a new DrawingTemplate with a drawing list containing the supplied SVG.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DrawingTemplate FromSvg(
    XmlDocument xml,
    PdfGeneratedDocument doc
)
Public Shared Function FromSvg (
    xml As XmlDocument,
    doc As PdfGeneratedDocument
) As DrawingTemplate

Parameters

xml
Type: System.XmlXmlDocument
Xml represeting SVG.
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The receiving PdfGeneratedDocument.

Return Value

Type: DrawingTemplate
See Also

Reference

SvgDocument Class
FromSvg Overload
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument Events

The SvgDocument type exposes the following members.

Events
 | Name | Description
Public event | SvgParsingError | This event is used by the SvgDocument object to report errors that occur when parsing a SVG file.
Top
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


SvgDocument.SvgParsingError Event

SvgDocumentSvgParsingError Event

This event is used by the SvgDocument object to report errors that occur when parsing a SVG file.

Namespace: Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event SvgParsingErrorEventHandler SvgParsingError
Public Event SvgParsingError As SvgParsingErrorEventHandler

Value

Type: Atalasoft.PdfDoc.Generating.Utilities.VectorImportSvgParsingErrorEventHandler
See Also

Reference

SvgDocument Class
Atalasoft.PdfDoc.Generating.Utilities.VectorImport.DOM Namespace


Atalasoft.PdfDoc.Generating.Validation Namespace

Classes
 | Class | Description
Public class | AnnotationRepairContext | A repair context for fixing problems in annotations.
Public class | DocumentRepairContext | Represents a RepairContext used for repairs that require document-level information.
Public class | PageRepairContext | Defines a context for repairs that require access to a page that contain the objects.
Public class | PdfFormRepairContext | Represents a repair context holding a form.
Public class | PdfRepairConsequences | This class represents the consequences of making a given repair on a PDF document.
Enumerations
 | Enumeration | Description
Public enumeration | Severity | Describes the severity of the consequences of making a repair to part of a PDF document.


AnnotationRepairContext Class

A repair context for fixing problems in annotations.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationRepairContext
Atalasoft.Shared.ValidationBasicRepairContext BaseAnnotation
Atalasoft.PdfDoc.Generating.ValidationAnnotationRepairContext

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AnnotationRepairContext : BasicRepairContext<BaseAnnotation>
Public Class AnnotationRepairContext
    Inherits BasicRepairContext(Of BaseAnnotation)

The AnnotationRepairContext type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationRepairContext | Initializes a new instance of the AnnotationRepairContext class.
Top
Properties
 | Name | Description
Public property | Annotation | Gets the annotation.
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Validation Namespace


AnnotationRepairContext Constructor

Initializes a new instance of the AnnotationRepairContext class.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AnnotationRepairContext(
    BaseAnnotation annot
)
Public Sub New (
    annot As BaseAnnotation
)

Parameters

annot
Type: Atalasoft.PdfDoc.Generating.AnnotationsBaseAnnotation
The annot.
See Also

Reference

AnnotationRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


AnnotationRepairContext Properties

The AnnotationRepairContext type exposes the following members.

Properties
 | Name | Description
Public property | Annotation | Gets the annotation.
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Top
See Also

Reference

AnnotationRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


AnnotationRepairContext.Annotation Property

AnnotationRepairContextAnnotation Property

Gets the annotation.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BaseAnnotation Annotation { get; }
Public ReadOnly Property Annotation As BaseAnnotation
    Get

Property Value

Type: BaseAnnotation
See Also

Reference

AnnotationRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


AnnotationRepairContext Methods

The AnnotationRepairContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnnotationRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


DocumentRepairContext Class

Represents a RepairContext used for repairs that require document-level information.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationRepairContext
Atalasoft.Shared.ValidationBasicRepairContext PdfGeneratedDocument
Atalasoft.PdfDoc.Generating.ValidationDocumentRepairContext

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DocumentRepairContext : BasicRepairContext<PdfGeneratedDocument>
Public Class DocumentRepairContext
    Inherits BasicRepairContext(Of PdfGeneratedDocument)

The DocumentRepairContext type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentRepairContext | Initializes a new instance of the DocumentRepairContext class.
Top
Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Public property | Document | Gets the document associated with the repair context.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Validation Namespace


DocumentRepairContext Constructor

Initializes a new instance of the DocumentRepairContext class.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentRepairContext(
    PdfGeneratedDocument doc
)
Public Sub New (
    doc As PdfGeneratedDocument
)

Parameters

doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document for the repair.
See Also

Reference

DocumentRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


DocumentRepairContext Properties

The DocumentRepairContext type exposes the following members.

Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Public property | Document | Gets the document associated with the repair context.
Top
See Also

Reference

DocumentRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


DocumentRepairContext.Document Property

DocumentRepairContextDocument Property

Gets the document associated with the repair context.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument Document { get; }
Public ReadOnly Property Document As PdfGeneratedDocument
    Get

Property Value

Type: PdfGeneratedDocument
See Also

Reference

DocumentRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


DocumentRepairContext Methods

The DocumentRepairContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PageRepairContext Class

Defines a context for repairs that require access to a page that contain the objects.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationRepairContext
Atalasoft.Shared.ValidationBasicRepairContext PdfGeneratedPage
Atalasoft.PdfDoc.Generating.ValidationPageRepairContext

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PageRepairContext : BasicRepairContext<PdfGeneratedPage>
Public Class PageRepairContext
    Inherits BasicRepairContext(Of PdfGeneratedPage)

The PageRepairContext type exposes the following members.

Constructors
 | Name | Description
Public method | PageRepairContext | Initializes a new instance of the PageRepairContext class.
Top
Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Public property | Document | Gets the document associated with this repair.
Public property | Page | Gets the page associated with this repair.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Validation Namespace


PageRepairContext Constructor

Initializes a new instance of the PageRepairContext class.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PageRepairContext(
    PdfGeneratedPage page,
    PdfGeneratedDocument doc
)
Public Sub New (
    page As PdfGeneratedPage,
    doc As PdfGeneratedDocument
)

Parameters

page
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedPage
The page.
doc
Type: Atalasoft.PdfDoc.GeneratingPdfGeneratedDocument
The document.
See Also

Reference

PageRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PageRepairContext Properties

The PageRepairContext type exposes the following members.

Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Public property | Document | Gets the document associated with this repair.
Public property | Page | Gets the page associated with this repair.
Top
See Also

Reference

PageRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PageRepairContext.Document Property

PageRepairContextDocument Property

Gets the document associated with this repair.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedDocument Document { get; }
Public ReadOnly Property Document As PdfGeneratedDocument
    Get

Property Value

Type: PdfGeneratedDocument
See Also

Reference

PageRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PageRepairContext.Page Property

PageRepairContextPage Property

Gets the page associated with this repair.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfGeneratedPage Page { get; }
Public ReadOnly Property Page As PdfGeneratedPage
    Get

Property Value

Type: PdfGeneratedPage
See Also

Reference

PageRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PageRepairContext Methods

The PageRepairContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfFormRepairContext Class

Represents a repair context holding a form.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationRepairContext
Atalasoft.Shared.ValidationBasicRepairContext PdfForm
Atalasoft.PdfDoc.Generating.ValidationPdfFormRepairContext

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfFormRepairContext : BasicRepairContext<PdfForm>
Public Class PdfFormRepairContext
    Inherits BasicRepairContext(Of PdfForm)

The PdfFormRepairContext type exposes the following members.

Constructors
 | Name | Description
Public method | PdfFormRepairContext | Initializes a new instance of the PdfFormRepairContext class.
Top
Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Public property | Form | Gets the form object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Generating.Validation Namespace


PdfFormRepairContext Constructor

Initializes a new instance of the PdfFormRepairContext class.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFormRepairContext(
    PdfForm form
)
Public Sub New (
    form As PdfForm
)

Parameters

form
Type: Atalasoft.PdfDoc.Generating.FormsPdfForm
The form.
See Also

Reference

PdfFormRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfFormRepairContext Properties

The PdfFormRepairContext type exposes the following members.

Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context. (Inherited from BasicRepairContextT.)
Public property | Form | Gets the form object.
Top
See Also

Reference

PdfFormRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfFormRepairContext.Form Property

PdfFormRepairContextForm Property

Gets the form object.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfForm Form { get; }
Public ReadOnly Property Form As PdfForm
    Get

Property Value

Type: PdfForm
See Also

Reference

PdfFormRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfFormRepairContext Methods

The PdfFormRepairContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfFormRepairContext Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences Class

This class represents the consequences of making a given repair on a PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationBaseRepairConsequences
Atalasoft.PdfDoc.Generating.ValidationPdfRepairConsequences

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfRepairConsequences : BaseRepairConsequences
Public Class PdfRepairConsequences
    Inherits BaseRepairConsequences

The PdfRepairConsequences type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the possible consequences of making the repair. (Inherited from BaseRepairConsequences.)
Public property | Severity | Gets the Severity of the consequences.
Top
Methods
 | Name | Description
 | Benign | Constructs a new PdfRepairConsequences object with a Benign Severity. The problem is readily fixable and will affect neither the outward appearance nor the content of the document.
 | Catastrophic | Constructs a new PdfRepairConsequences object with a Catastrophic Severity. The problem is not fixable. Any attempts to fix the problem would result in a PDF that is damaged.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Major | Constructs a new PdfRepairConsequences object with a Major Severity. The problem is fixable, but the fix necessitates permanently removing content from the document. It is not recommended to indiscriminantly allow automatic repair of Major problems.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minor | Constructs a new PdfRepairConsequences object with a Minor Severity. The problem is readily fixable, but the fix may affect the outward appearance in an acceptable manner, but not the content of the document.
 | Serious | Constructs a new PdfRepairConsequences object with a Serious Severity. The problem is readily fixable, but the fix may affect the outward appearance and/or the content of the document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This class can only be constructed through the given factory methods.
See Also

Reference

Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences Properties

The PdfRepairConsequences type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the possible consequences of making the repair. (Inherited from BaseRepairConsequences.)
Public property | Severity | Gets the Severity of the consequences.
Top
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences.Severity Property

PdfRepairConsequencesSeverity Property

Gets the Severity of the consequences.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Severity Severity { get; }
Public ReadOnly Property Severity As Severity
    Get

Property Value

Type: Severity
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences Methods

The PdfRepairConsequences type exposes the following members.

Methods
 | Name | Description
 | Benign | Constructs a new PdfRepairConsequences object with a Benign Severity. The problem is readily fixable and will affect neither the outward appearance nor the content of the document.
 | Catastrophic | Constructs a new PdfRepairConsequences object with a Catastrophic Severity. The problem is not fixable. Any attempts to fix the problem would result in a PDF that is damaged.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Major | Constructs a new PdfRepairConsequences object with a Major Severity. The problem is fixable, but the fix necessitates permanently removing content from the document. It is not recommended to indiscriminantly allow automatic repair of Major problems.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minor | Constructs a new PdfRepairConsequences object with a Minor Severity. The problem is readily fixable, but the fix may affect the outward appearance in an acceptable manner, but not the content of the document.
 | Serious | Constructs a new PdfRepairConsequences object with a Serious Severity. The problem is readily fixable, but the fix may affect the outward appearance and/or the content of the document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences.Benign Method

PdfRepairConsequencesBenign Method

Constructs a new PdfRepairConsequences object with a Benign Severity. The problem is readily fixable and will affect neither the outward appearance nor the content of the document.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfRepairConsequences Benign(
    string description
)
Public Shared Function Benign (
    description As String
) As PdfRepairConsequences

Parameters

description
Type: SystemString
The non-null description of the consequences of the repair.

Return Value

Type: PdfRepairConsequences
A new PdfRepairConsequences object
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences.Catastrophic Method

PdfRepairConsequencesCatastrophic Method

Constructs a new PdfRepairConsequences object with a Catastrophic Severity. The problem is not fixable. Any attempts to fix the problem would result in a PDF that is damaged.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfRepairConsequences Catastrophic(
    string description
)
Public Shared Function Catastrophic (
    description As String
) As PdfRepairConsequences

Parameters

description
Type: SystemString
The non-null description of the consequences of the repair.

Return Value

Type: PdfRepairConsequences
A new PdfRepairConsequences object
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences.Major Method

PdfRepairConsequencesMajor Method

Constructs a new PdfRepairConsequences object with a Major Severity. The problem is fixable, but the fix necessitates permanently removing content from the document. It is not recommended to indiscriminantly allow automatic repair of Major problems.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfRepairConsequences Major(
    string description
)
Public Shared Function Major (
    description As String
) As PdfRepairConsequences

Parameters

description
Type: SystemString
The non-null description of the consequences of the repair.

Return Value

Type: PdfRepairConsequences
A new PdfRepairConsequences object
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences.Minor Method

PdfRepairConsequencesMinor Method

Constructs a new PdfRepairConsequences object with a Minor Severity. The problem is readily fixable, but the fix may affect the outward appearance in an acceptable manner, but not the content of the document.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfRepairConsequences Minor(
    string description
)
Public Shared Function Minor (
    description As String
) As PdfRepairConsequences

Parameters

description
Type: SystemString
The non-null description of the consequences of the repair.

Return Value

Type: PdfRepairConsequences
A new PdfRepairConsequences object
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


PdfRepairConsequences.Serious Method

PdfRepairConsequencesSerious Method

Constructs a new PdfRepairConsequences object with a Serious Severity. The problem is readily fixable, but the fix may affect the outward appearance and/or the content of the document.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfRepairConsequences Serious(
    string description
)
Public Shared Function Serious (
    description As String
) As PdfRepairConsequences

Parameters

description
Type: SystemString
The non-null description of the consequences of the repair.

Return Value

Type: PdfRepairConsequences
A new PdfRepairConsequences object
See Also

Reference

PdfRepairConsequences Class
Atalasoft.PdfDoc.Generating.Validation Namespace


Severity Enumeration

Describes the severity of the consequences of making a repair to part of a PDF document.

Namespace: Atalasoft.PdfDoc.Generating.Validation
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum Severity
Public Enumeration Severity
Members
Member name | Description
None | No severity - not used - this is equivalent to no problem.
Benign | The problem is readily fixable and will affect neither the outward appearance nor the content of the document.
Minor | The problem is readily fixable, but the fix may affect the outward appearance in an acceptable manner, but not the content of the document.
Serious | The problem is readily fixable, but the fix may affect the outward appearance and/or the content of the document.
Major | The problem is fixable, but the fix necessitates permanently removing content from the document. It is not recommended to indiscriminately allow automatic repair of Major problems.
Catastrophic | The problem is not fixable.
Remarks
Although enumerated, this is an ordinal type and new levels of severity may be added in the future. Rather than check for equality of one of these values, you should instead compare to a value. For example you might care about anything >= Severity.Serious. The severity is ordered based on a scale of the effect of changes made in terms of how the appearance and content may change.
See Also

Reference

Atalasoft.PdfDoc.Generating.Validation Namespace


Atalasoft.PdfDoc.Geometry Namespace

Classes
 | Class | Description
Public class | PdfPointCollection | Represents a list of PdfPoint objects.
Public class | PdfQuadrilateral | This class represents a four-sided polygon. It is typically used in marking text on the page. For drawing order purposes, if the quadrilateral is a rectangle on the page, P0 is the lower-left corner, P1 is the lower-right corner, P2 is the upper right corner, and P3 is the upper-left corner. Misordering the points may result in the shape being rendered upside down or as a bow-tie.
Public class | PdfQuadrilateralCollection | This class represents a collection of PdfQuadrilateral objects.
 | PdfTransform | A class representing a matrix transform usable with the Pdf Generating Tools.
Public class | RangeT | Range represents an orderable range of values.
Structures
 | Structure | Description
Public structure | PdfBounds | A struct representing the bounds of an object in Pdf space.
Public structure | PdfPoint | A representation of a point in PDF space.
Enumerations
 | Enumeration | Description
Public enumeration | PdfTransformType | The type of transform that a PdfTransform is


PdfBounds Structure

A struct representing the bounds of an object in Pdf space.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct PdfBounds
<SerializableAttribute>
Public Structure PdfBounds

The PdfBounds type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBounds(RectangleF) | Initializes a new instance of the PdfBounds struct.
Public method | PdfBounds(Double, Double, Double, Double) | Initializes a new instance of the PdfBounds struct.
Top
Properties
 | Name | Description
Public property | Bottom | Gets the offset of the bottom side of this boundary.
 | Empty | Returns the Empty PdfBounds
Public property | Height | Gets the height.
Public property | Left | Gets the offset of the left side of this boundary.
Public property | Right | Gets the offset of the right side of this boundary.
Public property | Top | Gets the offset of the top side of this boundary.
Public property | Width | Gets the width.
Top
Methods
 | Name | Description
Public method | Contains(PdfBounds) | Determines whether the bounds contains the specified inner PdfBounds.
Public method | Contains(PdfPoint) | Determines whether the supplied point is contained within this rectangle.
Public method | Contains(PdfQuadrilateral) | Determines whether the rectangle contains the specified quadrilateral.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Expand(Double) | Expands the PdfBounds by the specified amount on all sides.
Public method | Expand(Double, Double) | Expands the PdfBounds by specified amount on sides and on the top and bottom.
Public method | Expand(Double, Double, Double, Double) | Expands the PdfBounds by specified amount on each side.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Checks to see if a given rectangle intersects this one.
Public method | IsEmpty | Determines whether this instance is empty.
Public method | LowerBound | Returns the minimum X and Y as a PdfPoint.
Public method | MaxX | Returns the maximum X.
Public method | MaxY | Returns the maximum Y.
Public method | MinX | Returns the minimum X.
Public method | MinY | Returns the minimum Y.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Public method | UpperBound | Returns the maximum X and Y as a PdfPoint.
Top
Operators
Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.
Top
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


PdfBounds Constructor

Overload List
 | Name | Description
Public method | PdfBounds(RectangleF) | Initializes a new instance of the PdfBounds struct.
Public method | PdfBounds(Double, Double, Double, Double) | Initializes a new instance of the PdfBounds struct.
Top
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds Constructor (RectangleF)

Initializes a new instance of the PdfBounds struct.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds(
    RectangleF r
)
Public Sub New (
    r As RectangleF
)

Parameters

r
Type: System.DrawingRectangleF
The rectangle.
See Also

Reference

PdfBounds Structure
PdfBounds Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds Constructor (Double, Double, Double, Double)

Initializes a new instance of the PdfBounds struct.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds(
    double left,
    double bottom,
    double width,
    double height
)
Public Sub New (
    left As Double,
    bottom As Double,
    width As Double,
    height As Double
)

Parameters

left
Type: SystemDouble
The left coordinate.
bottom
Type: SystemDouble
The bottom coordinate.
width
Type: SystemDouble
The width.
height
Type: SystemDouble
The height.
See Also

Reference

PdfBounds Structure
PdfBounds Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds Properties

The PdfBounds type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | Gets the offset of the bottom side of this boundary.
 | Empty | Returns the Empty PdfBounds
Public property | Height | Gets the height.
Public property | Left | Gets the offset of the left side of this boundary.
Public property | Right | Gets the offset of the right side of this boundary.
Public property | Top | Gets the offset of the top side of this boundary.
Public property | Width | Gets the width.
Top
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Bottom Property

PdfBoundsBottom Property

Gets the offset of the bottom side of this boundary.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Bottom { get; }
Public ReadOnly Property Bottom As Double
    Get

Property Value

Type: Double
The Y coordinate of the bottom edge.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Empty Property

PdfBoundsEmpty Property

Returns the Empty PdfBounds

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfBounds Empty { get; }
Public Shared ReadOnly Property Empty As PdfBounds
    Get

Property Value

Type: PdfBounds
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Height Property

PdfBoundsHeight Property

Gets the height.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get

Property Value

Type: Double
The height of this boundary.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Left Property

PdfBoundsLeft Property

Gets the offset of the left side of this boundary.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Left { get; }
Public ReadOnly Property Left As Double
    Get

Property Value

Type: Double
The X coordinate of the left edge.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Right Property

PdfBoundsRight Property

Gets the offset of the right side of this boundary.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Right { get; }
Public ReadOnly Property Right As Double
    Get

Property Value

Type: Double
The X coordinate of the right edge.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Top Property

PdfBoundsTop Property

Gets the offset of the top side of this boundary.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Top { get; }
Public ReadOnly Property Top As Double
    Get

Property Value

Type: Double
The Y coordinate of the top edge.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Width Property

PdfBoundsWidth Property

Gets the width.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get

Property Value

Type: Double
The width of this boundary.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds Methods

The PdfBounds type exposes the following members.

Methods
 | Name | Description
Public method | Contains(PdfBounds) | Determines whether the bounds contains the specified inner PdfBounds.
Public method | Contains(PdfPoint) | Determines whether the supplied point is contained within this rectangle.
Public method | Contains(PdfQuadrilateral) | Determines whether the rectangle contains the specified quadrilateral.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | Expand(Double) | Expands the PdfBounds by the specified amount on all sides.
Public method | Expand(Double, Double) | Expands the PdfBounds by specified amount on sides and on the top and bottom.
Public method | Expand(Double, Double, Double, Double) | Expands the PdfBounds by specified amount on each side.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Checks to see if a given rectangle intersects this one.
Public method | IsEmpty | Determines whether this instance is empty.
Public method | LowerBound | Returns the minimum X and Y as a PdfPoint.
Public method | MaxX | Returns the maximum X.
Public method | MaxY | Returns the maximum Y.
Public method | MinX | Returns the minimum X.
Public method | MinY | Returns the minimum Y.
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Public method | UpperBound | Returns the maximum X and Y as a PdfPoint.
Top
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Contains Method

PdfBoundsContains Method

Overload List
 | Name | Description
Public method | Contains(PdfBounds) | Determines whether the bounds contains the specified inner PdfBounds.
Public method | Contains(PdfPoint) | Determines whether the supplied point is contained within this rectangle.
Public method | Contains(PdfQuadrilateral) | Determines whether the rectangle contains the specified quadrilateral.
Top
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Contains Method (PdfBounds)

PdfBoundsContains Method (PdfBounds)

Determines whether the bounds contains the specified inner PdfBounds.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PdfBounds that
)
Public Function Contains (
    that As PdfBounds
) As Boolean

Parameters

that
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The PdfBounds to check

Return Value

Type: Boolean
true if the specified PdfBounds is contained in the bounds; otherwise, false.
See Also

Reference

PdfBounds Structure
Contains Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Contains Method (PdfPoint)

PdfBoundsContains Method (PdfPoint)

Determines whether the supplied point is contained within this rectangle.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PdfPoint p
)
Public Function Contains (
    p As PdfPoint
) As Boolean

Parameters

p
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point.

Return Value

Type: Boolean
true if the rectangle contains p; otherwise, false.
See Also

Reference

PdfBounds Structure
Contains Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Contains Method (PdfQuadrilateral)

PdfBoundsContains Method (PdfQuadrilateral)

Determines whether the rectangle contains the specified quadrilateral.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PdfQuadrilateral q
)
Public Function Contains (
    q As PdfQuadrilateral
) As Boolean

Parameters

q
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The quadrilateral.

Return Value

Type: Boolean
true if the rectangle contains the specified quadrilateral; otherwise, false.
See Also

Reference

PdfBounds Structure
Contains Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Equals Method

PdfBoundsEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Expand Method

PdfBoundsExpand Method

Overload List
 | Name | Description
Public method | Expand(Double) | Expands the PdfBounds by the specified amount on all sides.
Public method | Expand(Double, Double) | Expands the PdfBounds by specified amount on sides and on the top and bottom.
Public method | Expand(Double, Double, Double, Double) | Expands the PdfBounds by specified amount on each side.
Top
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Expand Method (Double)

PdfBoundsExpand Method (Double)

Expands the PdfBounds by the specified amount on all sides.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Expand(
    double amountOnAllSides
)
Public Function Expand (
    amountOnAllSides As Double
) As PdfBounds

Parameters

amountOnAllSides
Type: SystemDouble
The amount on all sides.

Return Value

Type: PdfBounds
A new PdfBounds with the expansion applied.
Remarks
If amountOnAllSides is negative, the PdfBounds will be smaller.
See Also

Reference

PdfBounds Structure
Expand Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Expand Method (Double, Double)

PdfBoundsExpand Method (Double, Double)

Expands the PdfBounds by specified amount on sides and on the top and bottom.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Expand(
    double amountOnSides,
    double amountOnTopAndBottom
)
Public Function Expand (
    amountOnSides As Double,
    amountOnTopAndBottom As Double
) As PdfBounds

Parameters

amountOnSides
Type: SystemDouble
The amount on sides.
amountOnTopAndBottom
Type: SystemDouble
The amount on top and bottom.

Return Value

Type: PdfBounds
A new PdfBounds with the expansion applied.
Remarks
If amountOnSides or amountOnTopAndBottom are negative, the PdfBounds will be smaller in those dimensions.
See Also

Reference

PdfBounds Structure
Expand Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Expand Method (Double, Double, Double, Double)

PdfBoundsExpand Method (Double, Double, Double, Double)

Expands the PdfBounds by specified amount on each side.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfBounds Expand(
    double leftAmount,
    double rightAmount,
    double topAmount,
    double bottomAmount
)
Public Function Expand (
    leftAmount As Double,
    rightAmount As Double,
    topAmount As Double,
    bottomAmount As Double
) As PdfBounds

Parameters

leftAmount
Type: SystemDouble
The left amount.
rightAmount
Type: SystemDouble
The right amount.
topAmount
Type: SystemDouble
The top amount.
bottomAmount
Type: SystemDouble
The bottom amount.

Return Value

Type: PdfBounds
A new PdfBounds with the expansion applied.
Remarks
If leftAmount, rightAmount, topAmount or bottomAmount are negative, the PdfBounds will be smaller in those dimensions.
See Also

Reference

PdfBounds Structure
Expand Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.GetHashCode Method

PdfBoundsGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Intersects Method

PdfBoundsIntersects Method

Checks to see if a given rectangle intersects this one.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Intersects(
    PdfBounds r
)
Public Function Intersects (
    r As PdfBounds
) As Boolean

Parameters

r
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The candidate rectangle.

Return Value

Type: Boolean
true if there is an intersection, false otherwise.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.IsEmpty Method

PdfBoundsIsEmpty Method

Determines whether this instance is empty.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
true if this instance is empty; otherwise, false.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.LowerBound Method

PdfBoundsLowerBound Method

Returns the minimum X and Y as a PdfPoint.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint LowerBound()
Public Function LowerBound As PdfPoint

Return Value

Type: PdfPoint
The minimum X and Y.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.MaxX Method

PdfBoundsMaxX Method

Returns the maximum X.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxX()
Public Function MaxX As Double

Return Value

Type: Double
The maximum X
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.MaxY Method

PdfBoundsMaxY Method

Returns the maximum Y.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxY()
Public Function MaxY As Double

Return Value

Type: Double
The maximum Y
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.MinX Method

PdfBoundsMinX Method

Returns the minimum X.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MinX()
Public Function MinX As Double

Return Value

Type: Double
The minimum X
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.MinY Method

PdfBoundsMinY Method

Returns the minimum Y.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MinY()
Public Function MinY As Double

Return Value

Type: Double
The minimum Y
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.ToString Method

PdfBoundsToString Method

Returns a String that represents this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.UpperBound Method

PdfBoundsUpperBound Method

Returns the maximum X and Y as a PdfPoint.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint UpperBound()
Public Function UpperBound As PdfPoint

Return Value

Type: PdfPoint
The maximum X and Y.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds Operators

The PdfBounds type exposes the following members.

Operators
Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.
Top
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Equality Operator

PdfBoundsEquality Operator

Implements the operator ==.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    PdfBounds a,
    PdfBounds b
)
Public Shared Operator = (
    a As PdfBounds,
    b As PdfBounds
) As Boolean

Parameters

a
Type: Atalasoft.PdfDoc.GeometryPdfBounds
A.
b
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The b.

Return Value

Type: Boolean
The result of the equality.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfBounds.Inequality Operator

PdfBoundsInequality Operator

Implements the operator !=.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    PdfBounds a,
    PdfBounds b
)
Public Shared Operator <> (
    a As PdfBounds,
    b As PdfBounds
) As Boolean

Parameters

a
Type: Atalasoft.PdfDoc.GeometryPdfBounds
A.
b
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The b.

Return Value

Type: Boolean
The result of the inequality.
See Also

Reference

PdfBounds Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Structure

A representation of a point in PDF space.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct PdfPoint
<SerializableAttribute>
Public Structure PdfPoint

The PdfPoint type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPoint(PdfPoint) | Initializes a new instance of the PdfPoint struct.
Public method | PdfPoint(Double, Double) | Initializes a new instance of the PdfPoint struct.
Top
Properties
 | Name | Description
 | Empty | Returns the empty PdfPoint (0,0).
Public property | X | Gets the X component.
Public property | Y | Gets the Y component.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition | Implements the operator +.
Equality | Implements the operator ==.
Inequality | Implements the operator !=.
Subtraction | Implements the operator -.
Top
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Constructor

Overload List
 | Name | Description
Public method | PdfPoint(PdfPoint) | Initializes a new instance of the PdfPoint struct.
Public method | PdfPoint(Double, Double) | Initializes a new instance of the PdfPoint struct.
Top
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Constructor (PdfPoint)

Initializes a new instance of the PdfPoint struct.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint(
    PdfPoint p
)
Public Sub New (
    p As PdfPoint
)

Parameters

p
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The point to copy.
See Also

Reference

PdfPoint Structure
PdfPoint Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Constructor (Double, Double)

Initializes a new instance of the PdfPoint struct.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint(
    double x,
    double y
)
Public Sub New (
    x As Double,
    y As Double
)

Parameters

x
Type: SystemDouble
The x value.
y
Type: SystemDouble
The y value.
See Also

Reference

PdfPoint Structure
PdfPoint Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Properties

The PdfPoint type exposes the following members.

Properties
 | Name | Description
 | Empty | Returns the empty PdfPoint (0,0).
Public property | X | Gets the X component.
Public property | Y | Gets the Y component.
Top
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Empty Property

PdfPointEmpty Property

Returns the empty PdfPoint (0,0).

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPoint Empty { get; }
Public Shared ReadOnly Property Empty As PdfPoint
    Get

Property Value

Type: PdfPoint
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.X Property

PdfPointX Property

Gets the X component.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double X { get; }
Public ReadOnly Property X As Double
    Get

Property Value

Type: Double
The X component.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Y Property

PdfPointY Property

Gets the Y component.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Y { get; }
Public ReadOnly Property Y As Double
    Get

Property Value

Type: Double
The Y component.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Methods

The PdfPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Equals Method

PdfPointEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.GetHashCode Method

PdfPointGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.ToString Method

PdfPointToString Method

Returns a String that represents this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint Operators

The PdfPoint type exposes the following members.

Operators
Name | Description
Addition | Implements the operator +.
Equality | Implements the operator ==.
Inequality | Implements the operator !=.
Subtraction | Implements the operator -.
Top
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Addition Operator

PdfPointAddition Operator

Implements the operator +.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPoint operator +(
    PdfPoint lhs,
    PdfPoint rhs
)
Public Shared Operator + (
    lhs As PdfPoint,
    rhs As PdfPoint
) As PdfPoint

Parameters

lhs
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The LHS.
rhs
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The RHS.

Return Value

Type: PdfPoint
The result of the addition.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Equality Operator

PdfPointEquality Operator

Implements the operator ==.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator ==(
    PdfPoint a,
    PdfPoint b
)
Public Shared Operator = (
    a As PdfPoint,
    b As PdfPoint
) As Boolean

Parameters

a
Type: Atalasoft.PdfDoc.GeometryPdfPoint
A.
b
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The b.

Return Value

Type: Boolean
The result of the equality.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Inequality Operator

PdfPointInequality Operator

Implements the operator !=.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static bool operator !=(
    PdfPoint a,
    PdfPoint b
)
Public Shared Operator <> (
    a As PdfPoint,
    b As PdfPoint
) As Boolean

Parameters

a
Type: Atalasoft.PdfDoc.GeometryPdfPoint
A.
b
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The b.

Return Value

Type: Boolean
The result of the lack of equality.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPoint.Subtraction Operator

PdfPointSubtraction Operator

Implements the operator -.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfPoint operator -(
    PdfPoint lhs,
    PdfPoint rhs
)
Public Shared Operator - (
    lhs As PdfPoint,
    rhs As PdfPoint
) As PdfPoint

Parameters

lhs
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The LHS.
rhs
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The RHS.

Return Value

Type: PdfPoint
The result of the subtraction.
See Also

Reference

PdfPoint Structure
Atalasoft.PdfDoc.Geometry Namespace


PdfPointCollection Class

Represents a list of PdfPoint objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListPdfPoint
Atalasoft.PdfDoc.GeometryPdfPointCollection

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfPointCollection : List<PdfPoint>
Public Class PdfPointCollection
    Inherits List(Of PdfPoint)

The PdfPointCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPointCollection | Initializes a new instance of the PdfPointCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfPoint .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfPoint .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfPoint .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfPoint .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfPoint .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfPoint .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfPoint .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfPoint .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfPoint .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfPoint .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfPoint .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfPoint .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfPoint .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfPoint .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfPoint .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfPoint .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfPoint .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfPoint .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfPoint .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfPoint .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfPoint .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfPoint .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfPoint .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfPoint .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfPoint .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfPoint .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfPoint .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfPoint .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfPoint .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfPoint .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfPoint .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfPoint .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfPoint .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfPoint .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfPoint .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfPoint .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfPoint .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfPoint .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfPoint .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Top
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


PdfPointCollection Constructor

Initializes a new instance of the PdfPointCollection class

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPointCollection()
Public Sub New
See Also

Reference

PdfPointCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfPointCollection Properties

The PdfPointCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListPdfPoint .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListPdfPoint .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListPdfPoint .)
Top
See Also

Reference

PdfPointCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfPointCollection Methods

The PdfPointCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListPdfPoint .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListPdfPoint .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListPdfPoint .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListPdfPoint .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfPoint .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListPdfPoint .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListPdfPoint .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListPdfPoint .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListPdfPoint .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListPdfPoint .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfPoint .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListPdfPoint .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfPoint .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfPoint .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfPoint .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfPoint .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListPdfPoint .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListPdfPoint .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListPdfPoint .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListPdfPoint .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListPdfPoint .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListPdfPoint .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListPdfPoint .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListPdfPoint .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListPdfPoint .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListPdfPoint .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListPdfPoint .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListPdfPoint .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListPdfPoint .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListPdfPoint .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListPdfPoint .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListPdfPoint .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListPdfPoint .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListPdfPoint .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListPdfPoint .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListPdfPoint .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListPdfPoint .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListPdfPoint .)
Top
See Also

Reference

PdfPointCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Class

This class represents a four-sided polygon. It is typically used in marking text on the page. For drawing order purposes, if the quadrilateral is a rectangle on the page, P0 is the lower-left corner, P1 is the lower-right corner, P2 is the upper right corner, and P3 is the upper-left corner. Misordering the points may result in the shape being rendered upside down or as a bow-tie.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeometryPdfQuadrilateral

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfQuadrilateral
Public Class PdfQuadrilateral

The PdfQuadrilateral type exposes the following members.

Constructors
 | Name | Description
Public method | PdfQuadrilateral | Initializes a new empty instance of the PdfQuadrilateral class.
Public method | PdfQuadrilateral(PdfBounds) | Initializes a new instance of the PdfQuadrilateral class using the supplied bounds.
Public method | PdfQuadrilateral(PdfQuadrilateral) | Initializes a new instance of the PdfQuadrilateral class copying from the supplied quadrilateral.
Public method | PdfQuadrilateral(PdfPoint, PdfPoint, PdfPoint, PdfPoint) | Initializes a new instance of the PdfQuadrilateral class.
Public method | PdfQuadrilateral(Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the PdfQuadrilateral class using the eight values.
Top
Properties
 | Name | Description
 | Empty | Gets an empty quadrilateral.
Public property | Item | Gets or sets the PdfPoint at the specified index. Index may be 0-3 inclusive.
Public property | P0 | Gets or sets the Point 0.
Public property | P1 | Gets or sets the Point 1.
Public property | P2 | Gets or sets the Point 2.
Public property | P3 | Gets or sets the Point 3.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConcave | Determines whether this quadrilateral is concave. A quadrilateral is concave if it is simple and if it is not convex.
Public method | IsConvex | Determines whether this quadrilateral is convex. A quadrilateral is convex if it is not empty and if its diagonals cross.
Public method | IsEmpty | Determines whether this quadrilateral is empty.
Public method | IsRectangular | Determines whether this quadrilateral is rectangular. Note that this test checks to see if the diagonals are equal and the shape is convex, therefore it is correct regardless of rotation.
Public method | IsSimple | Determines whether this quadrilateral is convex. A quadrilateral is simple if it is not empty and if its edges do not cross.
Public method | LowerBound | Gets the lower bound of the quadrilateral.
Public method | LowerBound(PdfPoint) | Gets the smaller of the LowerBound and the supplied point.
Public method | MaxX | Gets the maximum of all X coordinates.
Public method | MaxY | Gets the maximum of all Y coordinates.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinX | Gets the minimum of all X coordinates.
Public method | MinY | Gets the minimum of all Y coordinates.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpperBound | Gets the upper bound of the quadrilateral.
Public method | UpperBound(PdfPoint) | Gets the larger of the UpperBound and the supplied point.
Top
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Constructor

Overload List
 | Name | Description
Public method | PdfQuadrilateral | Initializes a new empty instance of the PdfQuadrilateral class.
Public method | PdfQuadrilateral(PdfBounds) | Initializes a new instance of the PdfQuadrilateral class using the supplied bounds.
Public method | PdfQuadrilateral(PdfQuadrilateral) | Initializes a new instance of the PdfQuadrilateral class copying from the supplied quadrilateral.
Public method | PdfQuadrilateral(PdfPoint, PdfPoint, PdfPoint, PdfPoint) | Initializes a new instance of the PdfQuadrilateral class.
Public method | PdfQuadrilateral(Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the PdfQuadrilateral class using the eight values.
Top
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Constructor

Initializes a new empty instance of the PdfQuadrilateral class.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateral()
Public Sub New
See Also

Reference

PdfQuadrilateral Class
PdfQuadrilateral Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Constructor (PdfBounds)

Initializes a new instance of the PdfQuadrilateral class using the supplied bounds.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateral(
    PdfBounds bounds
)
Public Sub New (
    bounds As PdfBounds
)

Parameters

bounds
Type: Atalasoft.PdfDoc.GeometryPdfBounds
The bounds.
See Also

Reference

PdfQuadrilateral Class
PdfQuadrilateral Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Constructor (PdfQuadrilateral)

Initializes a new instance of the PdfQuadrilateral class copying from the supplied quadrilateral.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateral(
    PdfQuadrilateral other
)
Public Sub New (
    other As PdfQuadrilateral
)

Parameters

other
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The other quadrilateral.
See Also

Reference

PdfQuadrilateral Class
PdfQuadrilateral Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Constructor (PdfPoint, PdfPoint, PdfPoint, PdfPoint)

Initializes a new instance of the PdfQuadrilateral class.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateral(
    PdfPoint p0,
    PdfPoint p1,
    PdfPoint p2,
    PdfPoint p3
)
Public Sub New (
    p0 As PdfPoint,
    p1 As PdfPoint,
    p2 As PdfPoint,
    p3 As PdfPoint
)

Parameters

p0
Type: Atalasoft.PdfDoc.GeometryPdfPoint
Point 0.
p1
Type: Atalasoft.PdfDoc.GeometryPdfPoint
Point 1.
p2
Type: Atalasoft.PdfDoc.GeometryPdfPoint
Point 2.
p3
Type: Atalasoft.PdfDoc.GeometryPdfPoint
Point 3.
See Also

Reference

PdfQuadrilateral Class
PdfQuadrilateral Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Constructor (Double, Double, Double, Double, Double, Double, Double, Double)

Initializes a new instance of the PdfQuadrilateral class using the eight values.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateral(
    double x0,
    double y0,
    double x1,
    double y1,
    double x2,
    double y2,
    double x3,
    double y3
)
Public Sub New (
    x0 As Double,
    y0 As Double,
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double,
    x3 As Double,
    y3 As Double
)

Parameters

x0
Type: SystemDouble
Point 0 X.
y0
Type: SystemDouble
Point 0 Y.
x1
Type: SystemDouble
Point 1 X.
y1
Type: SystemDouble
Point 1 Y.
x2
Type: SystemDouble
Point 2 X.
y2
Type: SystemDouble
Point 2 Y.
x3
Type: SystemDouble
Point 3 X.
y3
Type: SystemDouble
Point 3 Y.
See Also

Reference

PdfQuadrilateral Class
PdfQuadrilateral Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Properties

The PdfQuadrilateral type exposes the following members.

Properties
 | Name | Description
 | Empty | Gets an empty quadrilateral.
Public property | Item | Gets or sets the PdfPoint at the specified index. Index may be 0-3 inclusive.
Public property | P0 | Gets or sets the Point 0.
Public property | P1 | Gets or sets the Point 1.
Public property | P2 | Gets or sets the Point 2.
Public property | P3 | Gets or sets the Point 3.
Top
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.Empty Property

PdfQuadrilateralEmpty Property

Gets an empty quadrilateral.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfQuadrilateral Empty { get; }
Public Shared ReadOnly Property Empty As PdfQuadrilateral
    Get

Property Value

Type: PdfQuadrilateral
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.Item Property

PdfQuadrilateralItem Property

Gets or sets the PdfPoint at the specified index. Index may be 0-3 inclusive.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As PdfPoint
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: PdfPoint
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.P0 Property

PdfQuadrilateralP0 Property

Gets or sets the Point 0.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint P0 { get; set; }
Public Property P0 As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The p0.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.P1 Property

PdfQuadrilateralP1 Property

Gets or sets the Point 1.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint P1 { get; set; }
Public Property P1 As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The p1.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.P2 Property

PdfQuadrilateralP2 Property

Gets or sets the Point 2.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint P2 { get; set; }
Public Property P2 As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The p2.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.P3 Property

PdfQuadrilateralP3 Property

Gets or sets the Point 3.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint P3 { get; set; }
Public Property P3 As PdfPoint
    Get
    Set

Property Value

Type: PdfPoint
The p3.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral Methods

The PdfQuadrilateral type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConcave | Determines whether this quadrilateral is concave. A quadrilateral is concave if it is simple and if it is not convex.
Public method | IsConvex | Determines whether this quadrilateral is convex. A quadrilateral is convex if it is not empty and if its diagonals cross.
Public method | IsEmpty | Determines whether this quadrilateral is empty.
Public method | IsRectangular | Determines whether this quadrilateral is rectangular. Note that this test checks to see if the diagonals are equal and the shape is convex, therefore it is correct regardless of rotation.
Public method | IsSimple | Determines whether this quadrilateral is convex. A quadrilateral is simple if it is not empty and if its edges do not cross.
Public method | LowerBound | Gets the lower bound of the quadrilateral.
Public method | LowerBound(PdfPoint) | Gets the smaller of the LowerBound and the supplied point.
Public method | MaxX | Gets the maximum of all X coordinates.
Public method | MaxY | Gets the maximum of all Y coordinates.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MinX | Gets the minimum of all X coordinates.
Public method | MinY | Gets the minimum of all Y coordinates.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpperBound | Gets the upper bound of the quadrilateral.
Public method | UpperBound(PdfPoint) | Gets the larger of the UpperBound and the supplied point.
Top
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.IsConcave Method

PdfQuadrilateralIsConcave Method

Determines whether this quadrilateral is concave. A quadrilateral is concave if it is simple and if it is not convex.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsConcave()
Public Function IsConcave As Boolean

Return Value

Type: Boolean
true if this quadrilateral is concave; otherwise, false.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.IsConvex Method

PdfQuadrilateralIsConvex Method

Determines whether this quadrilateral is convex. A quadrilateral is convex if it is not empty and if its diagonals cross.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsConvex()
Public Function IsConvex As Boolean

Return Value

Type: Boolean
true if this quadrilateral is convex; otherwise, false.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.IsEmpty Method

PdfQuadrilateralIsEmpty Method

Determines whether this quadrilateral is empty.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean

Return Value

Type: Boolean
true if this quadrilateral is empty; otherwise, false.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.IsRectangular Method

PdfQuadrilateralIsRectangular Method

Determines whether this quadrilateral is rectangular. Note that this test checks to see if the diagonals are equal and the shape is convex, therefore it is correct regardless of rotation.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsRectangular()
Public Function IsRectangular As Boolean

Return Value

Type: Boolean
true if this quadrilateral is rectangular; otherwise, false.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.IsSimple Method

PdfQuadrilateralIsSimple Method

Determines whether this quadrilateral is convex. A quadrilateral is simple if it is not empty and if its edges do not cross.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsSimple()
Public Function IsSimple As Boolean

Return Value

Type: Boolean
true if this quadrilateral is simple; otherwise, false.
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.LowerBound Method

PdfQuadrilateralLowerBound Method

Overload List
 | Name | Description
Public method | LowerBound | Gets the lower bound of the quadrilateral.
Public method | LowerBound(PdfPoint) | Gets the smaller of the LowerBound and the supplied point.
Top
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.LowerBound Method

PdfQuadrilateralLowerBound Method

Gets the lower bound of the quadrilateral.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint LowerBound()
Public Function LowerBound As PdfPoint

Return Value

Type: PdfPoint
The minumum (X, Y) of the shape.
See Also

Reference

PdfQuadrilateral Class
LowerBound Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.LowerBound Method (PdfPoint)

PdfQuadrilateralLowerBound Method (PdfPoint)

Gets the smaller of the LowerBound and the supplied point.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint LowerBound(
    PdfPoint other
)
Public Function LowerBound (
    other As PdfPoint
) As PdfPoint

Parameters

other
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The other point.

Return Value

Type: PdfPoint
The smaller of the LowerBound and the supplied point.
See Also

Reference

PdfQuadrilateral Class
LowerBound Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.MaxX Method

PdfQuadrilateralMaxX Method

Gets the maximum of all X coordinates.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxX()
Public Function MaxX As Double

Return Value

Type: Double
The maximum X
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.MaxY Method

PdfQuadrilateralMaxY Method

Gets the maximum of all Y coordinates.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MaxY()
Public Function MaxY As Double

Return Value

Type: Double
The maximum Y
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.MinX Method

PdfQuadrilateralMinX Method

Gets the minimum of all X coordinates.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MinX()
Public Function MinX As Double

Return Value

Type: Double
The minimum X
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.MinY Method

PdfQuadrilateralMinY Method

Gets the minimum of all Y coordinates.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double MinY()
Public Function MinY As Double

Return Value

Type: Double
The minimum Y
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.UpperBound Method

PdfQuadrilateralUpperBound Method

Overload List
 | Name | Description
Public method | UpperBound | Gets the upper bound of the quadrilateral.
Public method | UpperBound(PdfPoint) | Gets the larger of the UpperBound and the supplied point.
Top
See Also

Reference

PdfQuadrilateral Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.UpperBound Method

PdfQuadrilateralUpperBound Method

Gets the upper bound of the quadrilateral.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint UpperBound()
Public Function UpperBound As PdfPoint

Return Value

Type: PdfPoint
The maximum (X, Y) of the shape.
See Also

Reference

PdfQuadrilateral Class
UpperBound Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateral.UpperBound Method (PdfPoint)

PdfQuadrilateralUpperBound Method (PdfPoint)

Gets the larger of the UpperBound and the supplied point.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint UpperBound(
    PdfPoint other
)
Public Function UpperBound (
    other As PdfPoint
) As PdfPoint

Parameters

other
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The other point.

Return Value

Type: PdfPoint
The larger of the UpperBound and the supplied point.
See Also

Reference

PdfQuadrilateral Class
UpperBound Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection Class

This class represents a collection of PdfQuadrilateral objects.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeometryPdfQuadrilateralCollection

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfQuadrilateralCollection : IList<PdfQuadrilateral>,
    ICollection<PdfQuadrilateral>, IEnumerable<PdfQuadrilateral>, IEnumerable
Public Class PdfQuadrilateralCollection
    Implements IList(Of PdfQuadrilateral), ICollection(Of PdfQuadrilateral),
    IEnumerable(Of PdfQuadrilateral), IEnumerable

The PdfQuadrilateralCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PdfQuadrilateralCollection | Initializes a new instance of the PdfQuadrilateralCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the IListT item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection Constructor

Initializes a new instance of the PdfQuadrilateralCollection class

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateralCollection()
Public Sub New
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection Properties

The PdfQuadrilateralCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Count Property

PdfQuadrilateralCollectionCount Property

Gets the number of elements contained in the ICollectionT.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.IsReadOnly Property

PdfQuadrilateralCollectionIsReadOnly Property

Gets a value indicating whether the ICollectionT is read-only.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Return Value

Type: Boolean
true if the ICollectionT is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Item Property

PdfQuadrilateralCollectionItem Property

Gets or sets the element at the specified index.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfQuadrilateral this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As PdfQuadrilateral
    Get
    Set

Parameters

index
Type: SystemInt32

Return Value

Type: PdfQuadrilateral
The element at the specified index.

Implements

IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The property is set and the IListT is read-only.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection Methods

The PdfQuadrilateralCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Public method | Clear | Removes all items from the ICollectionT.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the IListT item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Add Method

PdfQuadrilateralCollectionAdd Method

Adds an item to the ICollectionT.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Add(
    PdfQuadrilateral item
)
Public Sub Add (
    item As PdfQuadrilateral
)

Parameters

item
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The object to add to the ICollectionT.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Clear Method

PdfQuadrilateralCollectionClear Method

Removes all items from the ICollectionT.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Contains Method

PdfQuadrilateralCollectionContains Method

Determines whether the ICollectionT contains a specific value.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Contains(
    PdfQuadrilateral item
)
Public Function Contains (
    item As PdfQuadrilateral
) As Boolean

Parameters

item
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The object to locate in the ICollectionT.

Return Value

Type: Boolean
true if item is found in the ICollectionT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.CopyTo Method

PdfQuadrilateralCollectionCopyTo Method

Copies the elements of the ICollectionT to an Array, starting at a particular Array index.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void CopyTo(
    PdfQuadrilateral[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As PdfQuadrilateral(),
    arrayIndex As Integer
)

Parameters

array
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The one-dimensional Array that is the destination of the elements copied from ICollectionT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollectionT is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.GetEnumerator Method

PdfQuadrilateralCollectionGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IEnumerator<PdfQuadrilateral> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of PdfQuadrilateral)

Return Value

Type: IEnumeratorPdfQuadrilateral
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.IndexOf Method

PdfQuadrilateralCollectionIndexOf Method

Determines the index of a specific item in the IListT.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int IndexOf(
    PdfQuadrilateral item
)
Public Function IndexOf (
    item As PdfQuadrilateral
) As Integer

Parameters

item
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The object to locate in the IListT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Insert Method

PdfQuadrilateralCollectionInsert Method

Inserts an item to the IListT at the specified index.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Insert(
    int index,
    PdfQuadrilateral item
)
Public Sub Insert (
    index As Integer,
    item As PdfQuadrilateral
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The object to insert into the IListT.

Implements

IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.Remove Method

PdfQuadrilateralCollectionRemove Method

Removes the first occurrence of a specific object from the ICollectionT.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Remove(
    PdfQuadrilateral item
)
Public Function Remove (
    item As PdfQuadrilateral
) As Boolean

Parameters

item
Type: Atalasoft.PdfDoc.GeometryPdfQuadrilateral
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfQuadrilateralCollection.RemoveAt Method

PdfQuadrilateralCollectionRemoveAt Method

Removes the IListT item at the specified index.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

PdfQuadrilateralCollection Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Class

A class representing a matrix transform usable with the Pdf Generating Tools.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeometryPdfTransform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfTransform : ICloneable
<SerializableAttribute>
Public Class PdfTransform
    Implements ICloneable

The PdfTransform type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTransform | Initializes a new instance of the PdfTransform class.
Public method | PdfTransform(Double) | Initializes a new instance of the PdfTransform class copying the array coming in.
Public method | PdfTransform(PdfTransform) | Initializes a new instance of the PdfTransform class copying the transform coming in.
Public method | PdfTransform(Double, Double, Double, Double, Double, Double) | Initializes a new instance of the PdfTransform class.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the Double with the specified index.
Public property | Matrix | Gets the matrix as an array.
Public property | TransformType | Gets the type of the transform.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Concat | Concats the specified transform on to the current transform.
Public method | Determinant | Returns the determinant of this transform
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetInverse | Gets the inverse.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Identity | Returns an Identity Transform.
Public method | IsIdentity | Determines whether this instance is the identity matrix.
Public method | IsInvertable | Determines whether this instance is invertible.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rotate | Returns a Rotation Transform
 | Scale(Double) | Returns a Scale Transform
 | Scale(Double, Double) | Returns a Scale Transform
 | Skew | Returns a Skew Transform
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform(PointF) | Transforms the specified point.
Public method | Transform(PdfPoint) | Transforms the specified point.
Public method | Transform(Double, Double, Double, Double) | Transforms the specified x and y coordinates.
 | Translate | Returns a Translate Transform
Top
Examples
Create a Transform which rotates a point 90 degrees then shifts it 100 in the X direction and 100 in the Y direction
Copy
PdfTransform transform = PdfTransform.Rotate(Math.PI/2);
transform.Concat(PdfTransform.Translate(100,100);
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Constructor

Overload List
 | Name | Description
Public method | PdfTransform | Initializes a new instance of the PdfTransform class.
Public method | PdfTransform(Double) | Initializes a new instance of the PdfTransform class copying the array coming in.
Public method | PdfTransform(PdfTransform) | Initializes a new instance of the PdfTransform class copying the transform coming in.
Public method | PdfTransform(Double, Double, Double, Double, Double, Double) | Initializes a new instance of the PdfTransform class.
Top
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Constructor

Initializes a new instance of the PdfTransform class.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform()
Public Sub New
See Also

Reference

PdfTransform Class
PdfTransform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Constructor (Double[])

PdfTransform Constructor (Double)

Initializes a new instance of the PdfTransform class copying the array coming in.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform(
    double[] arr
)
Public Sub New (
    arr As Double()
)

Parameters

arr
Type: SystemDouble
The 2x3 matrix as an array
See Also

Reference

PdfTransform Class
PdfTransform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Constructor (PdfTransform)

Initializes a new instance of the PdfTransform class copying the transform coming in.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform(
    PdfTransform other
)
Public Sub New (
    other As PdfTransform
)

Parameters

other
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The transform to copy from.
See Also

Reference

PdfTransform Class
PdfTransform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Constructor (Double, Double, Double, Double, Double, Double)

Initializes a new instance of the PdfTransform class.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f
)
Public Sub New (
    a As Double,
    b As Double,
    c As Double,
    d As Double,
    e As Double,
    f As Double
)

Parameters

a
Type: SystemDouble
The first value in the matrix
b
Type: SystemDouble
The second value in the matrix
c
Type: SystemDouble
The third value in the matrix
d
Type: SystemDouble
The fourth value in the matrix
e
Type: SystemDouble
The fifth value in the matrix
f
Type: SystemDouble
The sixth value in the matrix
See Also

Reference

PdfTransform Class
PdfTransform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Properties

The PdfTransform type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the Double with the specified index.
Public property | Matrix | Gets the matrix as an array.
Public property | TransformType | Gets the type of the transform.
Top
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Item Property

PdfTransformItem Property

Gets or sets the Double with the specified index.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double this[
    int i
] { get; set; }
Public Default Property Item (
    i As Integer
) As Double
    Get
    Set

Parameters

i
Type: SystemInt32

Property Value

Type: Double
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Matrix Property

PdfTransformMatrix Property

Gets the matrix as an array.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double[] Matrix { get; }
Public ReadOnly Property Matrix As Double()
    Get

Property Value

Type: Double
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.TransformType Property

PdfTransformTransformType Property

Gets the type of the transform.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransformType TransformType { get; }
Public ReadOnly Property TransformType As PdfTransformType
    Get

Property Value

Type: PdfTransformType
The type of the transform.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform Methods

The PdfTransform type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Concat | Concats the specified transform on to the current transform.
Public method | Determinant | Returns the determinant of this transform
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetInverse | Gets the inverse.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Identity | Returns an Identity Transform.
Public method | IsIdentity | Determines whether this instance is the identity matrix.
Public method | IsInvertable | Determines whether this instance is invertible.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rotate | Returns a Rotation Transform
 | Scale(Double) | Returns a Scale Transform
 | Scale(Double, Double) | Returns a Scale Transform
 | Skew | Returns a Skew Transform
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform(PointF) | Transforms the specified point.
Public method | Transform(PdfPoint) | Transforms the specified point.
Public method | Transform(Double, Double, Double, Double) | Transforms the specified x and y coordinates.
 | Translate | Returns a Translate Transform
Top
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Clone Method

PdfTransformClone Method

Creates a new object that is a copy of the current instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
A new object that is a copy of this instance.

Implements

ICloneableClone
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Concat Method

PdfTransformConcat Method

Concats the specified transform on to the current transform.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Concat(
    PdfTransform t
)
Public Sub Concat (
    t As PdfTransform
)

Parameters

t
Type: Atalasoft.PdfDoc.GeometryPdfTransform
The specified transform.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Determinant Method

PdfTransformDeterminant Method

Returns the determinant of this transform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public double Determinant()
Public Function Determinant As Double

Return Value

Type: Double
The determinant of the transformation matrix
Remarks
A PdfTransform can be treated as a 3x3 matrix:
Copy
| a b c |
| d e f |
| g h i |
where c, f, and i are 0, 0, and 1, respectively. Using this definition, the determinant of a 3x3 matrix is defined as (a * e * i) + (b * f * g) + (c * d * h) - (a * f * h) - (b * d * i) - (c * e * g). Using the constants for c, f, and i, this can be reduced to (a * e) - (b * d). While client code may not have direct use for the determinant of the matrix, it is used internally to determine if a matrix is invertible and to calculate the inverse.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Equals Method

PdfTransformEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.GetHashCode Method

PdfTransformGetHashCode Method

Returns a hash code for this instance.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.GetInverse Method

PdfTransformGetInverse Method

Gets the inverse.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfTransform GetInverse()
Public Function GetInverse As PdfTransform

Return Value

Type: PdfTransform
The inverse matrix
Remarks
This will throw an OverflowException if the matrix has no inverse.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Identity Method

PdfTransformIdentity Method

Returns an Identity Transform.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTransform Identity()
Public Shared Function Identity As PdfTransform

Return Value

Type: PdfTransform
A new Identity transform.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.IsIdentity Method

PdfTransformIsIdentity Method

Determines whether this instance is the identity matrix.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsIdentity()
Public Function IsIdentity As Boolean

Return Value

Type: Boolean
true if this instance is the identity matrix; otherwise, false.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.IsInvertable Method

PdfTransformIsInvertable Method

Determines whether this instance is invertible.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsInvertable()
Public Function IsInvertable As Boolean

Return Value

Type: Boolean
true if this instance is invertible; otherwise, false.
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Rotate Method

PdfTransformRotate Method

Returns a Rotation Transform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTransform Rotate(
    double theta
)
Public Shared Function Rotate (
    theta As Double
) As PdfTransform

Parameters

theta
Type: SystemDouble
The theta in radians.

Return Value

Type: PdfTransform
A new rotation transform
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Scale Method

PdfTransformScale Method

Overload List
Name | Description
Scale(Double) | Returns a Scale Transform
Scale(Double, Double) | Returns a Scale Transform
Top
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Scale Method (Double)

PdfTransformScale Method (Double)

Returns a Scale Transform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTransform Scale(
    double s
)
Public Shared Function Scale (
    s As Double
) As PdfTransform

Parameters

s
Type: SystemDouble
The scale factor.

Return Value

Type: PdfTransform
A new scale transform
See Also

Reference

PdfTransform Class
Scale Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Scale Method (Double, Double)

PdfTransformScale Method (Double, Double)

Returns a Scale Transform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTransform Scale(
    double x,
    double y
)
Public Shared Function Scale (
    x As Double,
    y As Double
) As PdfTransform

Parameters

x
Type: SystemDouble
The x scale factor.
y
Type: SystemDouble
The y scale factor.

Return Value

Type: PdfTransform
A new scale transform
See Also

Reference

PdfTransform Class
Scale Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Skew Method

PdfTransformSkew Method

Returns a Skew Transform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTransform Skew(
    double x,
    double y
)
Public Shared Function Skew (
    x As Double,
    y As Double
) As PdfTransform

Parameters

x
Type: SystemDouble
The x skew.
y
Type: SystemDouble
The y skew.

Return Value

Type: PdfTransform
A new skew transform
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Transform Method

PdfTransformTransform Method

Overload List
 | Name | Description
Public method | Transform(PointF) | Transforms the specified point.
Public method | Transform(PdfPoint) | Transforms the specified point.
Public method | Transform(Double, Double, Double, Double) | Transforms the specified x and y coordinates.
Top
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Transform Method (PointF)

PdfTransformTransform Method (PointF)

Transforms the specified point.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PointF Transform(
    PointF src
)
Public Function Transform (
    src As PointF
) As PointF

Parameters

src
Type: System.DrawingPointF
The source point.

Return Value

Type: PointF
The transformed point
See Also

Reference

PdfTransform Class
Transform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Transform Method (PdfPoint)

PdfTransformTransform Method (PdfPoint)

Transforms the specified point.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfPoint Transform(
    PdfPoint src
)
Public Function Transform (
    src As PdfPoint
) As PdfPoint

Parameters

src
Type: Atalasoft.PdfDoc.GeometryPdfPoint
The source point.

Return Value

Type: PdfPoint
The transformed point
See Also

Reference

PdfTransform Class
Transform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Transform Method (Double, Double, Double, Double)

PdfTransformTransform Method (Double, Double, Double, Double)

Transforms the specified x and y coordinates.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Transform(
    double x,
    double y,
    out double xprime,
    out double yprime
)
Public Sub Transform (
    x As Double,
    y As Double,
    <OutAttribute> ByRef xprime As Double,
    <OutAttribute> ByRef yprime As Double
)

Parameters

x
Type: SystemDouble
The x.
y
Type: SystemDouble
The y.
xprime
Type: SystemDouble
The x output.
yprime
Type: SystemDouble
The y output.
See Also

Reference

PdfTransform Class
Transform Overload
Atalasoft.PdfDoc.Geometry Namespace


PdfTransform.Translate Method

PdfTransformTranslate Method

Returns a Translate Transform

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static PdfTransform Translate(
    double x,
    double y
)
Public Shared Function Translate (
    x As Double,
    y As Double
) As PdfTransform

Parameters

x
Type: SystemDouble
The x translation.
y
Type: SystemDouble
The y translation.

Return Value

Type: PdfTransform
A new translation transform
See Also

Reference

PdfTransform Class
Atalasoft.PdfDoc.Geometry Namespace


PdfTransformType Enumeration

The type of transform that a PdfTransform is

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfTransformType
Public Enumeration PdfTransformType
Members
Member name | Description
Identity | Identity is a matrix which will provide the same output as the input.
Translate | Translate is a matrix which will offset the position of the input points.
Scale | Scale is a matrix which will stretch or shrink the position of input points
NonUniformScale | NonUniformScale is a matrix which will stretch or shrink the position of input points, but will do so for different factors on the x and y coordinates.
Rotate | Rotate is a matrix which will rotate input points around the origin
Skew | Skew is a matrix which will offset points in a direction (usually in just the X or Y direction).
Other | Other is a matrix which is a combination of other PdfTransformType matrices.
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


Range(T) Class

RangeT Class

Range represents an orderable range of values.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.GeometryRangeT

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Range<T>
where T : IComparable

Public Class Range(Of T As IComparable)

Type Parameters

T

The RangeT type exposes the following members.

Constructors
 | Name | Description
Public method | RangeT | Initializes a new instance of the RangeT class.
Top
Properties
 | Name | Description
Public property | First | Gets the first element in the range.
Public property | IsDecreasing | Returns true if Second is less than or equal to First.
Public property | IsIncreasing | Returns true if Second is greater than or equal to First.
Public property | IsStrictlyDecreasing | Returns true if Second is less than First.
Public property | IsStrictlyIncreasing | Returns true if Second is greater than First.
Public property | Second | Gets the second element in the range.
Top
Methods
 | Name | Description
Public method | Clamp(T) | Clamps the specified value within the given range. The order of First and Second is unimportant.
Public method | Clamp(RangeT) | Clamps the given other range to be within this range. This is done by clamping each of other.First and other.Second to be within this range. Order is unimportant.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Geometry Namespace


Range(T) Constructor

RangeT Constructor

Initializes a new instance of the RangeT class.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Range(
    T first,
    T second
)
Public Sub New (
    first As T,
    second As T
)

Parameters

first
Type: T
The first value in the range.
second
Type: T
The second value in the range.
Remarks
Neither first nor last may be null.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T) Properties

RangeT Properties

The RangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | First | Gets the first element in the range.
Public property | IsDecreasing | Returns true if Second is less than or equal to First.
Public property | IsIncreasing | Returns true if Second is greater than or equal to First.
Public property | IsStrictlyDecreasing | Returns true if Second is less than First.
Public property | IsStrictlyIncreasing | Returns true if Second is greater than First.
Public property | Second | Gets the second element in the range.
Top
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).First Property

RangeTFirst Property

Gets the first element in the range.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T First { get; }
Public ReadOnly Property First As T
    Get

Property Value

Type: T
The first element.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).IsDecreasing Property

RangeTIsDecreasing Property

Returns true if Second is less than or equal to First.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDecreasing { get; }
Public ReadOnly Property IsDecreasing As Boolean
    Get

Property Value

Type: Boolean
true if this range is decreasing; otherwise, false.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).IsIncreasing Property

RangeTIsIncreasing Property

Returns true if Second is greater than or equal to First.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsIncreasing { get; }
Public ReadOnly Property IsIncreasing As Boolean
    Get

Property Value

Type: Boolean
true if this range is increasing; otherwise, false.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).IsStrictlyDecreasing Property

RangeTIsStrictlyDecreasing Property

Returns true if Second is less than First.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsStrictlyDecreasing { get; }
Public ReadOnly Property IsStrictlyDecreasing As Boolean
    Get

Property Value

Type: Boolean
true if this range is strictly decreasing; otherwise, false.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).IsStrictlyIncreasing Property

RangeTIsStrictlyIncreasing Property

Returns true if Second is greater than First.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsStrictlyIncreasing { get; }
Public ReadOnly Property IsStrictlyIncreasing As Boolean
    Get

Property Value

Type: Boolean
true if this range is strictly increasing; otherwise, false.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).Second Property

RangeTSecond Property

Gets the second element in the range.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Second { get; }
Public ReadOnly Property Second As T
    Get

Property Value

Type: T
The second element.
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T) Methods

RangeT Methods

The RangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clamp(T) | Clamps the specified value within the given range. The order of First and Second is unimportant.
Public method | Clamp(RangeT) | Clamps the given other range to be within this range. This is done by clamping each of other.First and other.Second to be within this range. Order is unimportant.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).Clamp Method

RangeTClamp Method

Overload List
 | Name | Description
Public method | Clamp(T) | Clamps the specified value within the given range. The order of First and Second is unimportant.
Public method | Clamp(RangeT) | Clamps the given other range to be within this range. This is done by clamping each of other.First and other.Second to be within this range. Order is unimportant.
Top
See Also

Reference

RangeT Class
Atalasoft.PdfDoc.Geometry Namespace


Range(T).Clamp Method (T)

RangeTClamp Method (T)

Clamps the specified value within the given range. The order of First and Second is unimportant.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Clamp(
    T val
)
Public Function Clamp (
    val As T
) As T

Parameters

val
Type: T
The value to clamp.

Return Value

Type: T
The val if in Range, otherwise either First or Second.
See Also

Reference

RangeT Class
Clamp Overload
Atalasoft.PdfDoc.Geometry Namespace


Range(T).Clamp Method (Range(T))

RangeTClamp Method (RangeT)

Clamps the given other range to be within this range. This is done by clamping each of other.First and other.Second to be within this range. Order is unimportant.

Namespace: Atalasoft.PdfDoc.Geometry
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Range<T> Clamp(
    Range<T> other
)
Public Function Clamp (
    other As Range(Of T)
) As Range(Of T)

Parameters

other
Type: Atalasoft.PdfDoc.GeometryRange T
The other to clamp.

Return Value

Type: Range T
A new Range that is clamped.
See Also

Reference

RangeT Class
Clamp Overload
Atalasoft.PdfDoc.Geometry Namespace


Atalasoft.PdfDoc.MergeForms Namespace

Classes
 | Class | Description
Public class | FormFieldsConflictEventArgs | Class for resolving conflicted fields with equal fully qualified names.
Public class | ImportOptions | The options for importing pages from PDF document.
Enumerations
 | Enumeration | Description
Public enumeration | FormFieldsConflictResult |


FormFieldsConflictEventArgs Class

Class for resolving conflicted fields with equal fully qualified names.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.PdfDoc.MergeFormsFormFieldsConflictEventArgs

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FormFieldsConflictEventArgs : EventArgs
Public Class FormFieldsConflictEventArgs
    Inherits EventArgs

The FormFieldsConflictEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FormFieldsConflictEventArgs | Initializes a new instance of the FormFieldsConflictEventArgs class
Top
Properties
 | Name | Description
Public property | AreFieldTypesEqual | Gets a boolean indicating that both IFormElement have the same field type. If it's , form elements can be merged safely. Note: Signature fields cannot be merged. If one ore both conflicted fields are signature, the property returns .
Public property | ConflictResolution | Gets or sets result of merging fields. Default value is KeepCurrentFieldAndMergeChildren
Public property | CurrentField |
Public property | CurrentForm |
Public property | ExternalField |
Public property | ExternalForm |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs Constructor

Initializes a new instance of the FormFieldsConflictEventArgs class

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormFieldsConflictEventArgs()
Public Sub New
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs Properties

The FormFieldsConflictEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AreFieldTypesEqual | Gets a boolean indicating that both IFormElement have the same field type. If it's , form elements can be merged safely. Note: Signature fields cannot be merged. If one ore both conflicted fields are signature, the property returns .
Public property | ConflictResolution | Gets or sets result of merging fields. Default value is KeepCurrentFieldAndMergeChildren
Public property | CurrentField |
Public property | CurrentForm |
Public property | ExternalField |
Public property | ExternalForm |
Top
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs.AreFieldTypesEqual Property

FormFieldsConflictEventArgsAreFieldTypesEqual Property

Gets a boolean indicating that both IFormElement have the same field type. If it's , form elements can be merged safely.

Note: Signature fields cannot be merged. If one ore both conflicted fields are signature, the property returns .

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AreFieldTypesEqual { get; set; }
Public Property AreFieldTypesEqual As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs.ConflictResolution Property

FormFieldsConflictEventArgsConflictResolution Property

Gets or sets result of merging fields. Default value is KeepCurrentFieldAndMergeChildren

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FormFieldsConflictResult ConflictResolution { get; set; }
Public Property ConflictResolution As FormFieldsConflictResult
    Get
    Set

Property Value

Type: FormFieldsConflictResult
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs.CurrentField Property

FormFieldsConflictEventArgsCurrentField Property

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFormElement CurrentField { get; set; }
Public Property CurrentField As IFormElement
    Get
    Set

Property Value

Type: IFormElement
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs.CurrentForm Property

FormFieldsConflictEventArgsCurrentForm Property

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfForm CurrentForm { get; set; }
Public Property CurrentForm As PdfForm
    Get
    Set

Property Value

Type: PdfForm
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs.ExternalField Property

FormFieldsConflictEventArgsExternalField Property

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IFormElement ExternalField { get; set; }
Public Property ExternalField As IFormElement
    Get
    Set

Property Value

Type: IFormElement
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs.ExternalForm Property

FormFieldsConflictEventArgsExternalForm Property

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfForm ExternalForm { get; set; }
Public Property ExternalForm As PdfForm
    Get
    Set

Property Value

Type: PdfForm
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictEventArgs Methods

The FormFieldsConflictEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormFieldsConflictEventArgs Class
Atalasoft.PdfDoc.MergeForms Namespace


FormFieldsConflictResult Enumeration

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FormFieldsConflictResult
Public Enumeration FormFieldsConflictResult
Members
Member name | Description
KeepCurrentFieldAndMergeChildren | Keep field from current form only and merge children with children of external field.
KeepExternalFieldAndMergeChildren | Keep field from external form only and merge children with children of current field.
KeepBoth | Keep both fields. At list one of field should be renamed.
See Also

Reference

Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions Class

The options for importing pages from PDF document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.MergeFormsImportOptions

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ImportOptions
Public Class ImportOptions

The ImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImportOptions | Initializes a new instance of the ImportOptions class
Top
Properties
 | Name | Description
Public property | FormFieldsConflictHandler | Gets or sets the handler for resolving conflicts between form fields. Conflicts happen if form fields have equal fully qualified names. Handler can decide to merge fields with or without children, add both fields, or only one field in current form. This parameter may be .
Public property | InsertIndex | Gets or sets insert position. Default value is -1 (insert pages at the end of document).
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to open the document. This parameter may be .
Public property | PagesToImport | Gets or sets indexes of pages that should be imported. If the parameter is not specified, all pages are imported.
Public property | RepairOptions | Gets or sets an object that determines how foreign content will be repaired on being read. This parameter may be .
Public property | UserPassword | Obsolete. Gets or sets the user password to open the document. This parameter may be .
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions Constructor

Initializes a new instance of the ImportOptions class

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImportOptions()
Public Sub New
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions Properties

The ImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | FormFieldsConflictHandler | Gets or sets the handler for resolving conflicts between form fields. Conflicts happen if form fields have equal fully qualified names. Handler can decide to merge fields with or without children, add both fields, or only one field in current form. This parameter may be .
Public property | InsertIndex | Gets or sets insert position. Default value is -1 (insert pages at the end of document).
Public property | OwnerPassword | Obsolete. Gets or sets the owner password to open the document. This parameter may be .
Public property | PagesToImport | Gets or sets indexes of pages that should be imported. If the parameter is not specified, all pages are imported.
Public property | RepairOptions | Gets or sets an object that determines how foreign content will be repaired on being read. This parameter may be .
Public property | UserPassword | Obsolete. Gets or sets the user password to open the document. This parameter may be .
Top
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions.FormFieldsConflictHandler Property

ImportOptionsFormFieldsConflictHandler Property

Gets or sets the handler for resolving conflicts between form fields. Conflicts happen if form fields have equal fully qualified names. Handler can decide to merge fields with or without children, add both fields, or only one field in current form. This parameter may be .

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public EventHandler<FormFieldsConflictEventArgs> FormFieldsConflictHandler { get; set; }
Public Property FormFieldsConflictHandler As EventHandler(Of FormFieldsConflictEventArgs)
    Get
    Set

Property Value

Type: EventHandlerFormFieldsConflictEventArgs
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions.InsertIndex Property

ImportOptionsInsertIndex Property

Gets or sets insert position. Default value is -1 (insert pages at the end of document).

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int InsertIndex { get; set; }
Public Property InsertIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions.OwnerPassword Property

ImportOptionsOwnerPassword Property

Note: This API is now obsolete.

Gets or sets the owner password to open the document. This parameter may be .

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use ImportPages method with user and owner passwords parameters.",
    true)]
public string OwnerPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use ImportPages method with user and owner passwords parameters.",
    true)>
Public Property OwnerPassword As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions.PagesToImport Property

ImportOptionsPagesToImport Property

Gets or sets indexes of pages that should be imported. If the parameter is not specified, all pages are imported.

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] PagesToImport { get; set; }
Public Property PagesToImport As Integer()
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions.RepairOptions Property

ImportOptionsRepairOptions Property

Gets or sets an object that determines how foreign content will be repaired on being read. This parameter may be .

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairOptions RepairOptions { get; set; }
Public Property RepairOptions As RepairOptions
    Get
    Set

Property Value

Type: RepairOptions
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions.UserPassword Property

ImportOptionsUserPassword Property

Note: This API is now obsolete.

Gets or sets the user password to open the document. This parameter may be .

Namespace: Atalasoft.PdfDoc.MergeForms
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This property is obsolete. Use ImportPages method with user and owner passwords parameters.",
    true)]
public string UserPassword { get; set; }
<ObsoleteAttribute("This property is obsolete. Use ImportPages method with user and owner passwords parameters.",
    true)>
Public Property UserPassword As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


ImportOptions Methods

The ImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImportOptions Class
Atalasoft.PdfDoc.MergeForms Namespace


Atalasoft.PdfDoc.PdfA Namespace

This namespace contains PDF/A specific classes and enumerations.
Classes
 | Class | Description
Public class | PdfAActionException | An exception from PdfDoc
Public class | PdfAAnnotationException | An exception from PdfDoc
Public class | PdfAException | Represents a general exception related to work with PDF/A documents.
Public class | PdfAFontException | Represents a font exception related to work with PDF/A documents.
Public class | PdfAImageAndColorSpaceException | An exception from PdfDoc
Enumerations
 | Enumeration | Description
Public enumeration | PdfASavingBehavior | Specifies the behavior of PdfDocument on saving PDF/A documents.
Public enumeration | PdfAVersion | Version and conformance level of PDF/A standard.


PdfAActionException Class

An exception from PdfDoc
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDoc.PdfAPdfAException
Atalasoft.PdfDoc.PdfAPdfAActionException

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAActionException : PdfAException
<SerializableAttribute>
Public Class PdfAActionException
    Inherits PdfAException

The PdfAActionException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAActionException | Initializes a new instance of the PdfAActionException class.
Public method | PdfAActionException(String) | Initializes a new instance of the PdfAActionException class.
Protected method | PdfAActionException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAActionException class.
Public method | PdfAActionException(String, Exception) | Initializes a new instance of the PdfAActionException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Constructor

Overload List
 | Name | Description
Public method | PdfAActionException | Initializes a new instance of the PdfAActionException class.
Public method | PdfAActionException(String) | Initializes a new instance of the PdfAActionException class.
Protected method | PdfAActionException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAActionException class.
Public method | PdfAActionException(String, Exception) | Initializes a new instance of the PdfAActionException class.
Top
See Also

Reference

PdfAActionException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Constructor

Initializes a new instance of the PdfAActionException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAActionException()
Public Sub New
See Also

Reference

PdfAActionException Class
PdfAActionException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Constructor (String)

Initializes a new instance of the PdfAActionException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAActionException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfAActionException Class
PdfAActionException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfAActionException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAActionException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfAActionException Class
PdfAActionException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Constructor (String, Exception)

Initializes a new instance of the PdfAActionException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAActionException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfAActionException Class
PdfAActionException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Properties

The PdfAActionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAActionException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Methods

The PdfAActionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAActionException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAActionException Events

The PdfAActionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAActionException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Class

An exception from PdfDoc
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDoc.PdfAPdfAException
Atalasoft.PdfDoc.PdfAPdfAAnnotationException

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAAnnotationException : PdfAException
<SerializableAttribute>
Public Class PdfAAnnotationException
    Inherits PdfAException

The PdfAAnnotationException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAAnnotationException | Initializes a new instance of the PdfAAnnotationException class.
Public method | PdfAAnnotationException(String) | Initializes a new instance of the PdfAAnnotationException class.
Protected method | PdfAAnnotationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAAnnotationException class.
Public method | PdfAAnnotationException(String, Exception) | Initializes a new instance of the PdfAAnnotationException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Constructor

Overload List
 | Name | Description
Public method | PdfAAnnotationException | Initializes a new instance of the PdfAAnnotationException class.
Public method | PdfAAnnotationException(String) | Initializes a new instance of the PdfAAnnotationException class.
Protected method | PdfAAnnotationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAAnnotationException class.
Public method | PdfAAnnotationException(String, Exception) | Initializes a new instance of the PdfAAnnotationException class.
Top
See Also

Reference

PdfAAnnotationException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Constructor

Initializes a new instance of the PdfAAnnotationException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAAnnotationException()
Public Sub New
See Also

Reference

PdfAAnnotationException Class
PdfAAnnotationException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Constructor (String)

Initializes a new instance of the PdfAAnnotationException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAAnnotationException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfAAnnotationException Class
PdfAAnnotationException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfAAnnotationException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAAnnotationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfAAnnotationException Class
PdfAAnnotationException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Constructor (String, Exception)

Initializes a new instance of the PdfAAnnotationException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAAnnotationException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfAAnnotationException Class
PdfAAnnotationException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Properties

The PdfAAnnotationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAAnnotationException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Methods

The PdfAAnnotationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAAnnotationException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAAnnotationException Events

The PdfAAnnotationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAAnnotationException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Class

Represents a general exception related to work with PDF/A documents.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDoc.PdfAPdfAException
Atalasoft.PdfDoc.PdfAPdfAActionException
Atalasoft.PdfDoc.PdfAPdfAAnnotationException
Atalasoft.PdfDoc.PdfAPdfAFontException
Atalasoft.PdfDoc.PdfAPdfAImageAndColorSpaceException

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAException : PdfException
<SerializableAttribute>
Public Class PdfAException
    Inherits PdfException

The PdfAException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAException | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String) | Initializes a new instance of the PdfAException class.
Protected method | PdfAException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String, Exception) | Initializes a new instance of the PdfAException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


PdfAException Constructor

Overload List
 | Name | Description
Public method | PdfAException | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String) | Initializes a new instance of the PdfAException class.
Protected method | PdfAException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAException class.
Public method | PdfAException(String, Exception) | Initializes a new instance of the PdfAException class.
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Constructor

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAException()
Public Sub New
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Constructor (String)

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Constructor (String, Exception)

Initializes a new instance of the PdfAException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfAException Class
PdfAException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Properties

The PdfAException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Methods

The PdfAException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAException Events

The PdfAException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Class

Represents a font exception related to work with PDF/A documents.
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDoc.PdfAPdfAException
Atalasoft.PdfDoc.PdfAPdfAFontException

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAFontException : PdfAException
<SerializableAttribute>
Public Class PdfAFontException
    Inherits PdfAException

The PdfAFontException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAFontException | Initializes a new instance of the PdfAFontException class.
Public method | PdfAFontException(String) | Initializes a new instance of the PdfAFontException class.
Protected method | PdfAFontException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAFontException class.
Public method | PdfAFontException(String, Exception) | Initializes a new instance of the PdfAFontException class.
Public method | PdfAFontException(String, PdfFontResource, String) | Initializes a new instance of the PdfAFontException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FontResource | Gets PDF font resource.
Public property | GlobalName | Gets global name of PDF font resource. If for some reasons the font has not been imported to global resources, this value will be null.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Constructor

Overload List
 | Name | Description
Public method | PdfAFontException | Initializes a new instance of the PdfAFontException class.
Public method | PdfAFontException(String) | Initializes a new instance of the PdfAFontException class.
Protected method | PdfAFontException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAFontException class.
Public method | PdfAFontException(String, Exception) | Initializes a new instance of the PdfAFontException class.
Public method | PdfAFontException(String, PdfFontResource, String) | Initializes a new instance of the PdfAFontException class.
Top
See Also

Reference

PdfAFontException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Constructor

Initializes a new instance of the PdfAFontException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAFontException()
Public Sub New
See Also

Reference

PdfAFontException Class
PdfAFontException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Constructor (String)

Initializes a new instance of the PdfAFontException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAFontException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfAFontException Class
PdfAFontException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfAFontException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAFontException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfAFontException Class
PdfAFontException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Constructor (String, Exception)

Initializes a new instance of the PdfAFontException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAFontException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfAFontException Class
PdfAFontException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Constructor (String, PdfFontResource, String)

Initializes a new instance of the PdfAFontException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAFontException(
    string message,
    PdfFontResource font,
    string globalName
)
Public Sub New (
    message As String,
    font As PdfFontResource,
    globalName As String
)

Parameters

message
Type: SystemString
The message.
font
Type: Atalasoft.PdfDoc.Generating.ResourceHandling.FontsPdfFontResource
The PDF font resource.
globalName
Type: SystemString
The global name of PDF font resource.
See Also

Reference

PdfAFontException Class
PdfAFontException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Properties

The PdfAFontException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FontResource | Gets PDF font resource.
Public property | GlobalName | Gets global name of PDF font resource. If for some reasons the font has not been imported to global resources, this value will be null.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAFontException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException.FontResource Property

PdfAFontExceptionFontResource Property

Gets PDF font resource.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfFontResource FontResource { get; }
Public ReadOnly Property FontResource As PdfFontResource
    Get

Property Value

Type: PdfFontResource
See Also

Reference

PdfAFontException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException.GlobalName Property

PdfAFontExceptionGlobalName Property

Gets global name of PDF font resource. If for some reasons the font has not been imported to global resources, this value will be null.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string GlobalName { get; }
Public ReadOnly Property GlobalName As String
    Get

Property Value

Type: String
See Also

Reference

PdfAFontException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Methods

The PdfAFontException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAFontException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAFontException Events

The PdfAFontException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAFontException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Class

An exception from PdfDoc
Inheritance Hierarchy
SystemObject
SystemException
Atalasoft.PdfDocPdfException
Atalasoft.PdfDoc.PdfAPdfAException
Atalasoft.PdfDoc.PdfAPdfAImageAndColorSpaceException

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PdfAImageAndColorSpaceException : PdfAException
<SerializableAttribute>
Public Class PdfAImageAndColorSpaceException
    Inherits PdfAException

The PdfAImageAndColorSpaceException type exposes the following members.

Constructors
 | Name | Description
Public method | PdfAImageAndColorSpaceException | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Public method | PdfAImageAndColorSpaceException(String) | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Protected method | PdfAImageAndColorSpaceException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Public method | PdfAImageAndColorSpaceException(String, Exception) | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Constructor

Overload List
 | Name | Description
Public method | PdfAImageAndColorSpaceException | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Public method | PdfAImageAndColorSpaceException(String) | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Protected method | PdfAImageAndColorSpaceException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Public method | PdfAImageAndColorSpaceException(String, Exception) | Initializes a new instance of the PdfAImageAndColorSpaceException class.
Top
See Also

Reference

PdfAImageAndColorSpaceException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Constructor

Initializes a new instance of the PdfAImageAndColorSpaceException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAImageAndColorSpaceException()
Public Sub New
See Also

Reference

PdfAImageAndColorSpaceException Class
PdfAImageAndColorSpaceException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Constructor (String)

Initializes a new instance of the PdfAImageAndColorSpaceException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAImageAndColorSpaceException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message.
See Also

Reference

PdfAImageAndColorSpaceException Class
PdfAImageAndColorSpaceException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PdfAImageAndColorSpaceException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected PdfAImageAndColorSpaceException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).
See Also

Reference

PdfAImageAndColorSpaceException Class
PdfAImageAndColorSpaceException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Constructor (String, Exception)

Initializes a new instance of the PdfAImageAndColorSpaceException class.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfAImageAndColorSpaceException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

PdfAImageAndColorSpaceException Class
PdfAImageAndColorSpaceException Overload
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Properties

The PdfAImageAndColorSpaceException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAImageAndColorSpaceException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Methods

The PdfAImageAndColorSpaceException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAImageAndColorSpaceException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfAImageAndColorSpaceException Events

The PdfAImageAndColorSpaceException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PdfAImageAndColorSpaceException Class
Atalasoft.PdfDoc.PdfA Namespace


PdfASavingBehavior Enumeration

Specifies the behavior of PdfDocument on saving PDF/A documents.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfASavingBehavior
Public Enumeration PdfASavingBehavior
Members
Member name | Description
PreserveOriginalPdfType | The PDF/A document will be saved or will be thrown PdfAException, if all source documents are PDF/A. Otherwise regular PDF document will be saved. The default value.
SavePdfA | The PDF/A document will be saved. If one of the source documents is not PDF/A or have color profile with different color space, then PdfAException will be thrown.
SavePdf | The regular PDF document without PDF/A metadata will be saved, regardless of the source document.
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


PdfAVersion Enumeration

Version and conformance level of PDF/A standard.

Namespace: Atalasoft.PdfDoc.PdfA
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum PdfAVersion
Public Enumeration PdfAVersion
Members
Member name | Description
NotPdfA | Regular PDF.
PdfA1a | The first part of PDF/A standard, Level A conformance.
PdfA1b | The first part of PDF/A standard, Level B conformance.
PdfA2a | The second part of PDF/A standard, Level A conformance.
PdfA2b | The second part of PDF/A standard, Level B conformance.
PdfA2u | The second part of PDF/A standard, Level U conformance.
PdfA3a | The third part of PDF/A standard, Level A conformance.
PdfA3b | The third part of PDF/A standard, Level B conformance.
PdfA3u | The third part of PDF/A standard, Level U conformance.
See Also

Reference

Atalasoft.PdfDoc.PdfA Namespace


Atalasoft.PdfDoc.Repair Namespace

Classes
 | Class | Description
Public class | ArrayRepairOptions | ArrayRepairOptions represents the set of options that can be used for repairing array definitions.
Public class | PropertyRepairOptions | PropertyRepairOptions is a class that is used to determine how repairs of PDF dictionary properties are managed. Damaged properties are typically the result of incorrect PDF.
Public class | RepairOptions | RepairOptions defines a set of choices that can be to automatically repair elements in PDF documents
Public class | StructureRepairOptions | StructureRepairOptions describe options for repairing gross structural problems in a PDF document. These problems are usually encountered early in working with the document and require rewriting the document.
Delegates
 | Delegate | Description
Public delegate | ArrayRepairOptionsArrayElementReplacer | This delegate is used to replace a missing or damaged array element.
Public delegate | ProblemSelector | This delegate will be called to select if a problem is a candidate for repair.
Public delegate | PropertyRepairOptionsPropertyValueReplacer | The PropertyValueReplacer is called when a property repair is being made. If the delegate wishes to replace the recommended value for a property.
Public delegate | RepairSelector | This delegate will get called to select if a repair should be enacted.
Public delegate | StructureRepairOptionsNameReplacer | A delegate that is used to rename an existing name.
Enumerations
 | Enumeration | Description
Public enumeration | BadDestinationRepairAction | Determines how a bad destination in a "go to" action should be repaired
Public enumeration | DuplicateNameTreeEntryRepairAction | Determines the action to take
Public enumeration | ProblemAction | ProblemSelector is used to determine if a problem should be accepted for repair or not.
Public enumeration | RepairAction | Describes the action to take on a repair.
Public enumeration | RepairChoice | Represents a choice on whether a repair should be made


ArrayRepairOptions Class

ArrayRepairOptions represents the set of options that can be used for repairing array definitions.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.RepairArrayRepairOptions

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ArrayRepairOptions
Public Class ArrayRepairOptions

The ArrayRepairOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayRepairOptions | Initializes a new instance of the ArrayRepairOptions class.
Top
Properties
 | Name | Description
Public property | ElementReplacer | Gets or sets a delegate used to replace missing elements in arrays.
Public property | RepairDamagedElements | Gets or sets a value indicating whether to repair missing references.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


ArrayRepairOptions Constructor

Initializes a new instance of the ArrayRepairOptions class.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ArrayRepairOptions()
Public Sub New
See Also

Reference

ArrayRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


ArrayRepairOptions Properties

The ArrayRepairOptions type exposes the following members.

Properties
 | Name | Description
Public property | ElementReplacer | Gets or sets a delegate used to replace missing elements in arrays.
Public property | RepairDamagedElements | Gets or sets a value indicating whether to repair missing references.
Top
See Also

Reference

ArrayRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


ArrayRepairOptions.ElementReplacer Property

ArrayRepairOptionsElementReplacer Property

Gets or sets a delegate used to replace missing elements in arrays.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ArrayRepairOptionsArrayElementReplacer ElementReplacer { get; set; }
Public Property ElementReplacer As ArrayRepairOptionsArrayElementReplacer
    Get
    Set

Property Value

Type: ArrayRepairOptionsArrayElementReplacer
The element replacer.
See Also

Reference

ArrayRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


ArrayRepairOptions.RepairDamagedElements Property

ArrayRepairOptionsRepairDamagedElements Property

Gets or sets a value indicating whether to repair missing references.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RepairDamagedElements { get; set; }
Public Property RepairDamagedElements As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf will attempt to repair missing references; otherwise, false.
Remarks
If true, arrays that contain objects that can't be parsed or realized will be either set to null (default) or replaced with a value supplied by the value replacer.
See Also

Reference

ArrayRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


ArrayRepairOptions Methods

The ArrayRepairOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArrayRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


ArrayRepairOptions.ArrayElementReplacer Delegate

ArrayRepairOptionsArrayElementReplacer Delegate

This delegate is used to replace a missing or damaged array element.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate bool ArrayElementReplacer(
    Array arr,
    int index,
    Object fileParsedValue,
    ref Object replacementValue
)
Public Delegate Function ArrayElementReplacer (
    arr As Array,
    index As Integer,
    fileParsedValue As Object,
    ByRef replacementValue As Object
) As Boolean

Parameters

arr
Type: SystemArray
The array that needs repair.
index
Type: SystemInt32
The index of the damaged element.
fileParsedValue
Type: SystemObject
The value parsed from the file. This may be null.
replacementValue
Type: SystemObject
The replacement value.

Return Value

Type: Boolean
true if the value should be replaced with replacementValue, false otherwise
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


BadDestinationRepairAction Enumeration

Determines how a bad destination in a "go to" action should be repaired

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BadDestinationRepairAction
Public Enumeration BadDestinationRepairAction
Members
Member name | Description
None | No repair - this will cause an exception to be thrown
Remove | Remove the action containing the destination
PinToNearest | The pin to the nearest page, either first or last
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


DuplicateNameTreeEntryRepairAction Enumeration

Determines the action to take

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DuplicateNameTreeEntryRepairAction
Public Enumeration DuplicateNameTreeEntryRepairAction
Members
Member name | Description
None | Perform no repair
RemoveNewer | Remove the newer element
RemoveOlder | Remove the older element
RenameNewer | Rename the newer element
RenameOlder | Rename the older element
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


ProblemAction Enumeration

ProblemSelector is used to determine if a problem should be accepted for repair or not.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ProblemAction
Public Enumeration ProblemAction
Members
Member name | Description
Default | Use the internal default selector (if present).
Accept | Accept the problem for later repair.
Reject | Reject the problem (which in turn will likely case an exception to be thrown.
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


ProblemSelector Delegate

This delegate will be called to select if a problem is a candidate for repair.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate ProblemAction ProblemSelector(
    Object sender,
    BaseProblem problem
)
Public Delegate Function ProblemSelector (
    sender As Object,
    problem As BaseProblem
) As ProblemAction

Parameters

sender
Type: SystemObject
The object reporting the problem.
problem
Type: Atalasoft.Shared.ValidationBaseProblem
The problem that has been detected.

Return Value

Type: ProblemAction
ProblemAction.Accept if the problem should be repaired, ProblemAction.Reject if the problem should be not be repaired (this will cause an exception), or ProblemAction.Default to use the internal mechanism.
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


PropertyRepairOptions Class

PropertyRepairOptions is a class that is used to determine how repairs of PDF dictionary properties are managed. Damaged properties are typically the result of incorrect PDF.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.RepairPropertyRepairOptions

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PropertyRepairOptions
Public Class PropertyRepairOptions

The PropertyRepairOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyRepairOptions | Initializes a new instance of the PropertyRepairOptions class.
Top
Properties
 | Name | Description
Public property | Replacer | Gets or sets the delegate that will be called to replace the value of a damaged PDF property. This method is not recommended for general use as it requires thorough understanding of the PDF specification.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


PropertyRepairOptions Constructor

Initializes a new instance of the PropertyRepairOptions class.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PropertyRepairOptions()
Public Sub New
See Also

Reference

PropertyRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


PropertyRepairOptions Properties

The PropertyRepairOptions type exposes the following members.

Properties
 | Name | Description
Public property | Replacer | Gets or sets the delegate that will be called to replace the value of a damaged PDF property. This method is not recommended for general use as it requires thorough understanding of the PDF specification.
Top
See Also

Reference

PropertyRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


PropertyRepairOptions.Replacer Property

PropertyRepairOptionsReplacer Property

Gets or sets the delegate that will be called to replace the value of a damaged PDF property. This method is not recommended for general use as it requires thorough understanding of the PDF specification.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PropertyRepairOptionsPropertyValueReplacer Replacer { get; set; }
Public Property Replacer As PropertyRepairOptionsPropertyValueReplacer
    Get
    Set

Property Value

Type: PropertyRepairOptionsPropertyValueReplacer
The replacer for properties.
See Also

Reference

PropertyRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


PropertyRepairOptions Methods

The PropertyRepairOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


PropertyRepairOptions.PropertyValueReplacer Delegate

PropertyRepairOptionsPropertyValueReplacer Delegate

The PropertyValueReplacer is called when a property repair is being made. If the delegate wishes to replace the recommended value for a property.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate bool PropertyValueReplacer(
    PropertyInfo property,
    string propertyName,
    Object propertyOwner,
    Object defaultValue,
    Object fileParsedValue,
    Object fileSuppliedValue,
    ref Object replacementValue
)
Public Delegate Function PropertyValueReplacer (
    property As PropertyInfo,
    propertyName As String,
    propertyOwner As Object,
    defaultValue As Object,
    fileParsedValue As Object,
    fileSuppliedValue As Object,
    ByRef replacementValue As Object
) As Boolean

Parameters

property
Type: System.ReflectionPropertyInfo
The property that is being repaired. May be null.
propertyName
Type: SystemString
The name of the property, or if property is null, the name of the "extra" entry.
propertyOwner
Type: SystemObject
The object that owns the property.
defaultValue
Type: SystemObject
The default value for the property.
fileParsedValue
Type: SystemObject
The value parsed from the file for the property (may be null).
fileSuppliedValue
Type: SystemObject
The converted value for the property (may be null).
replacementValue
Type: SystemObject
The value to be used as a replacement.

Return Value

Type: Boolean
true if the value should be replaced with replacementValue, false otherwise
Remarks
the replacementValue must be assignable to the property type. If the type is not appropriate, DotPdf will throw a PdfException.
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


RepairAction Enumeration

Describes the action to take on a repair.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RepairAction
Public Enumeration RepairAction
Members
Member name | Description
Default | Perform the internal default repair action.
NoRepair | The problem will not be repaired, which will result in an exception.
Repair | The problem will be repaired.
Skip | The problem will not be repaired, but instead will be skipped. This may result in incorrect PDF or a later exception.
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


RepairChoice Enumeration

Represents a choice on whether a repair should be made

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RepairChoice
Public Enumeration RepairChoice
Members
Member name | Description
None | No repairs will be done.
All | All values will be repaired using default mechanisms
Select | Client code can select the problems that will be repaired
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


RepairOptions Class

RepairOptions defines a set of choices that can be to automatically repair elements in PDF documents
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.RepairRepairOptions

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RepairOptions
Public Class RepairOptions

The RepairOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RepairOptions | Initializes a new instance of the RepairOptions class.
Top
Properties
 | Name | Description
Public property | ArrayOptions | Gets the array repair options.
Public property | MaximumAllowableSeverity | Gets or sets the maximum allowable severity for problems. This property is used by the internal repair selection process. If the Severity of the PdfRepairConsequences exceeds this value, then the problem will be marked as "do not repair" which will cause an exception to be thrown. The default is Serious
Public property | ProblemSelector | Gets or sets the problem selector for dictionary properties. This selector, if present, will be called to determine if a problem should be selected.
Public property | PropertyOptions | Gets the property repair options.
Public property | RepairSelector | Gets or sets the repair selector for problems. This delegate will be used to decide if a property will be repaired.
Public property | StructureOptions | Gets the structure repair options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProblemEncountered | Raises the ProblemEncountered event.
Protected method | OnProblemRepaired | Raises the ProblemRepaired event.
Protected method | OnProblemSkipped | Raises the ProblemSkipped event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ProblemEncountered | When a problem has been encountered in a PDF document, this event will be fired.
Public event | ProblemRepaired | Occurs when a previously reported problem has been repaired.
Public event | ProblemSkipped | Occurs when a problem has been skipped for repair.
Top
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


RepairOptions Constructor

Initializes a new instance of the RepairOptions class.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairOptions()
Public Sub New
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions Properties

The RepairOptions type exposes the following members.

Properties
 | Name | Description
Public property | ArrayOptions | Gets the array repair options.
Public property | MaximumAllowableSeverity | Gets or sets the maximum allowable severity for problems. This property is used by the internal repair selection process. If the Severity of the PdfRepairConsequences exceeds this value, then the problem will be marked as "do not repair" which will cause an exception to be thrown. The default is Serious
Public property | ProblemSelector | Gets or sets the problem selector for dictionary properties. This selector, if present, will be called to determine if a problem should be selected.
Public property | PropertyOptions | Gets the property repair options.
Public property | RepairSelector | Gets or sets the repair selector for problems. This delegate will be used to decide if a property will be repaired.
Public property | StructureOptions | Gets the structure repair options.
Top
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.ArrayOptions Property

RepairOptionsArrayOptions Property

Gets the array repair options.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ArrayRepairOptions ArrayOptions { get; }
Public ReadOnly Property ArrayOptions As ArrayRepairOptions
    Get

Property Value

Type: ArrayRepairOptions
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.MaximumAllowableSeverity Property

RepairOptionsMaximumAllowableSeverity Property

Gets or sets the maximum allowable severity for problems. This property is used by the internal repair selection process. If the Severity of the PdfRepairConsequences exceeds this value, then the problem will be marked as "do not repair" which will cause an exception to be thrown. The default is Serious

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Severity MaximumAllowableSeverity { get; set; }
Public Property MaximumAllowableSeverity As Severity
    Get
    Set

Property Value

Type: Severity
The maximum allowable severity for problems used in the default handler.
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.ProblemSelector Property

RepairOptionsProblemSelector Property

Gets or sets the problem selector for dictionary properties. This selector, if present, will be called to determine if a problem should be selected.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProblemSelector ProblemSelector { get; set; }
Public Property ProblemSelector As ProblemSelector
    Get
    Set

Property Value

Type: ProblemSelector
The problem selector.
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.PropertyOptions Property

RepairOptionsPropertyOptions Property

Gets the property repair options.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PropertyRepairOptions PropertyOptions { get; }
Public ReadOnly Property PropertyOptions As PropertyRepairOptions
    Get

Property Value

Type: PropertyRepairOptions
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.RepairSelector Property

RepairOptionsRepairSelector Property

Gets or sets the repair selector for problems. This delegate will be used to decide if a property will be repaired.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairSelector RepairSelector { get; set; }
Public Property RepairSelector As RepairSelector
    Get
    Set

Property Value

Type: RepairSelector
The repair selector.
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.StructureOptions Property

RepairOptionsStructureOptions Property

Gets the structure repair options.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StructureRepairOptions StructureOptions { get; }
Public ReadOnly Property StructureOptions As StructureRepairOptions
    Get

Property Value

Type: StructureRepairOptions
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions Methods

The RepairOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProblemEncountered | Raises the ProblemEncountered event.
Protected method | OnProblemRepaired | Raises the ProblemRepaired event.
Protected method | OnProblemSkipped | Raises the ProblemSkipped event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.OnProblemEncountered Method

RepairOptionsOnProblemEncountered Method

Raises the ProblemEncountered event.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnProblemEncountered(
    ProblemEventArgs e
)
Protected Overridable Sub OnProblemEncountered (
    e As ProblemEventArgs
)

Parameters

e
Type: Atalasoft.Shared.ValidationProblemEventArgs
The ProblemEventArgs instance containing the event data.
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.OnProblemRepaired Method

RepairOptionsOnProblemRepaired Method

Raises the ProblemRepaired event.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnProblemRepaired(
    ProblemEventArgs e
)
Protected Overridable Sub OnProblemRepaired (
    e As ProblemEventArgs
)

Parameters

e
Type: Atalasoft.Shared.ValidationProblemEventArgs
The ProblemEventArgs instance containing the event data.
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.OnProblemSkipped Method

RepairOptionsOnProblemSkipped Method

Raises the ProblemSkipped event.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnProblemSkipped(
    ProblemEventArgs e
)
Protected Overridable Sub OnProblemSkipped (
    e As ProblemEventArgs
)

Parameters

e
Type: Atalasoft.Shared.ValidationProblemEventArgs
The ProblemEventArgs instance containing the event data.
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions Events

The RepairOptions type exposes the following members.

Events
 | Name | Description
Public event | ProblemEncountered | When a problem has been encountered in a PDF document, this event will be fired.
Public event | ProblemRepaired | Occurs when a previously reported problem has been repaired.
Public event | ProblemSkipped | Occurs when a problem has been skipped for repair.
Top
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.ProblemEncountered Event

RepairOptionsProblemEncountered Event

When a problem has been encountered in a PDF document, this event will be fired.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ProblemEventArgs> ProblemEncountered
Public Event ProblemEncountered As EventHandler(Of ProblemEventArgs)

Value

Type: SystemEventHandlerProblemEventArgs
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.ProblemRepaired Event

RepairOptionsProblemRepaired Event

Occurs when a previously reported problem has been repaired.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ProblemEventArgs> ProblemRepaired
Public Event ProblemRepaired As EventHandler(Of ProblemEventArgs)

Value

Type: SystemEventHandlerProblemEventArgs
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairOptions.ProblemSkipped Event

RepairOptionsProblemSkipped Event

Occurs when a problem has been skipped for repair.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ProblemEventArgs> ProblemSkipped
Public Event ProblemSkipped As EventHandler(Of ProblemEventArgs)

Value

Type: SystemEventHandlerProblemEventArgs
See Also

Reference

RepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


RepairSelector Delegate

This delegate will get called to select if a repair should be enacted.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate RepairAction RepairSelector(
    Object sender,
    BaseProblem problem
)
Public Delegate Function RepairSelector (
    sender As Object,
    problem As BaseProblem
) As RepairAction

Parameters

sender
Type: SystemObject
The object reporting the problem.
problem
Type: Atalasoft.Shared.ValidationBaseProblem
The problem that needs to be repaired.

Return Value

Type: RepairAction
NoRepair if the problem will not be repaired, Repair if it will be repaired, and Skip to ignore the problem.
Remarks
If the problem is not repaired, it may cause a PdfExceptionto be thrown later.
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions Class

StructureRepairOptions describe options for repairing gross structural problems in a PDF document. These problems are usually encountered early in working with the document and require rewriting the document.
Inheritance Hierarchy
SystemObject
Atalasoft.PdfDoc.RepairStructureRepairOptions

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class StructureRepairOptions
Public Class StructureRepairOptions

The StructureRepairOptions type exposes the following members.

Constructors
 | Name | Description
Public method | StructureRepairOptions | Initializes a new instance of the StructureRepairOptions class. This creates a default StructureRepairOptions object with the StoredStreamProvider set to a TempFileStreamProvider.
Top
Properties
 | Name | Description
Public property | AllowPartialNameTrees | Gets or sets a value indicating whether to allow partial name trees.
Public property | CorrectInvalidDataStreamLengths | Gets or sets a value indicating whether DotPdf will correct invalid data stream lengths.
Public property | CreateBlankPageIfNoPagesFound | Gets or sets a value indicating whether to create blank page if no pages were found in the PDF.
Public property | DestinationAction | Gets or sets the destination action for repairing a bad destination
Public property | DuplicateNameTreeEntryRepairAction | Gets or sets the name tree repair action. When a duplicate name is found in a name tree, this will be used to decide the action for that item. If an empty or null name is found, any value except for None will cause the value to be either renamed or discarded.
Public property | ForceRebuildCrossReferenceTable | Gets or sets a value indicating whether to rebuild a cross reference table. Default value is false.
Public property | NameSelector | Gets or sets the name selector.
Public property | RebuildCrossReferenceTable | Gets or sets a value indicating whether to rebuild a damaged cross reference table.
Public property | RepairedStoredStream | Gets the stored stream that was used for the repaired file. If, after repair, this property is non-null, the owning document should be saved to a new file and this object should be disposed.
Public property | RepairNameTrees | Gets or sets a value indicating whether DotPdf will repair name trees.
Public property | RestoreOrphanedPages | Gets or sets a value indicating whether pages no longer directly referenced by the PDF document will be restored to the document.
Public property | StoredStreamProvider | Gets or sets the stored stream provider that will be used for creating a temporary file for storing the new PDF with the repaired cross reference table.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions Constructor

Initializes a new instance of the StructureRepairOptions class. This creates a default StructureRepairOptions object with the StoredStreamProvider set to a TempFileStreamProvider.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StructureRepairOptions()
Public Sub New
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions Properties

The StructureRepairOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowPartialNameTrees | Gets or sets a value indicating whether to allow partial name trees.
Public property | CorrectInvalidDataStreamLengths | Gets or sets a value indicating whether DotPdf will correct invalid data stream lengths.
Public property | CreateBlankPageIfNoPagesFound | Gets or sets a value indicating whether to create blank page if no pages were found in the PDF.
Public property | DestinationAction | Gets or sets the destination action for repairing a bad destination
Public property | DuplicateNameTreeEntryRepairAction | Gets or sets the name tree repair action. When a duplicate name is found in a name tree, this will be used to decide the action for that item. If an empty or null name is found, any value except for None will cause the value to be either renamed or discarded.
Public property | ForceRebuildCrossReferenceTable | Gets or sets a value indicating whether to rebuild a cross reference table. Default value is false.
Public property | NameSelector | Gets or sets the name selector.
Public property | RebuildCrossReferenceTable | Gets or sets a value indicating whether to rebuild a damaged cross reference table.
Public property | RepairedStoredStream | Gets the stored stream that was used for the repaired file. If, after repair, this property is non-null, the owning document should be saved to a new file and this object should be disposed.
Public property | RepairNameTrees | Gets or sets a value indicating whether DotPdf will repair name trees.
Public property | RestoreOrphanedPages | Gets or sets a value indicating whether pages no longer directly referenced by the PDF document will be restored to the document.
Public property | StoredStreamProvider | Gets or sets the stored stream provider that will be used for creating a temporary file for storing the new PDF with the repaired cross reference table.
Top
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.AllowPartialNameTrees Property

StructureRepairOptionsAllowPartialNameTrees Property

Gets or sets a value indicating whether to allow partial name trees.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AllowPartialNameTrees { get; set; }
Public Property AllowPartialNameTrees As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf should allow partial name trees; otherwise, false.
Remarks
If an error occurs while parsing a name tree, instead of failing, this property will allow the name tree, as parsed, to remain.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.CorrectInvalidDataStreamLengths Property

StructureRepairOptionsCorrectInvalidDataStreamLengths Property

Gets or sets a value indicating whether DotPdf will correct invalid data stream lengths.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CorrectInvalidDataStreamLengths { get; set; }
Public Property CorrectInvalidDataStreamLengths As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf will correct invalid data stream lengths; otherwise, false.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.CreateBlankPageIfNoPagesFound Property

StructureRepairOptionsCreateBlankPageIfNoPagesFound Property

Gets or sets a value indicating whether to create blank page if no pages were found in the PDF.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CreateBlankPageIfNoPagesFound { get; set; }
Public Property CreateBlankPageIfNoPagesFound As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf will create a blank page if no pages found; otherwise, false.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.DestinationAction Property

StructureRepairOptionsDestinationAction Property

Gets or sets the destination action for repairing a bad destination

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BadDestinationRepairAction DestinationAction { get; set; }
Public Property DestinationAction As BadDestinationRepairAction
    Get
    Set

Property Value

Type: BadDestinationRepairAction
The destination repair action.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.DuplicateNameTreeEntryRepairAction Property

StructureRepairOptionsDuplicateNameTreeEntryRepairAction Property

Gets or sets the name tree repair action. When a duplicate name is found in a name tree, this will be used to decide the action for that item. If an empty or null name is found, any value except for None will cause the value to be either renamed or discarded.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DuplicateNameTreeEntryRepairAction DuplicateNameTreeEntryRepairAction { get; set; }
Public Property DuplicateNameTreeEntryRepairAction As DuplicateNameTreeEntryRepairAction
    Get
    Set

Property Value

Type: DuplicateNameTreeEntryRepairAction
The name tree repair action.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.ForceRebuildCrossReferenceTable Property

StructureRepairOptionsForceRebuildCrossReferenceTable Property

Gets or sets a value indicating whether to rebuild a cross reference table. Default value is false.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ForceRebuildCrossReferenceTable { get; set; }
Public Property ForceRebuildCrossReferenceTable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the cross reference table will be rebuilt; otherwise, false.
Remarks
The cross reference table is an index of all contents within a PDF document used to efficiently access document elements. If it is damaged, it is not possible to locate these elements. The repair is enacted on the Stream provided, therefore the Stream should be writable and it should be a copy of the document to be repaired. This way, if the repair process fails, the original document will be preserved.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.NameSelector Property

StructureRepairOptionsNameSelector Property

Gets or sets the name selector.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StructureRepairOptionsNameReplacer NameSelector { get; set; }
Public Property NameSelector As StructureRepairOptionsNameReplacer
    Get
    Set

Property Value

Type: StructureRepairOptionsNameReplacer
The name selector.
Remarks
This delegate will be used (if present) to select a replacement name for an empty or duplicate name.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.RebuildCrossReferenceTable Property

StructureRepairOptionsRebuildCrossReferenceTable Property

Gets or sets a value indicating whether to rebuild a damaged cross reference table.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RebuildCrossReferenceTable { get; set; }
Public Property RebuildCrossReferenceTable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the cross reference table will be rebuilt; otherwise, false.
Remarks
The cross reference table is an index of all contents within a PDF document used to efficiently access document elements. If it is damaged, it is not possible to locate these elements. The repair is enacted on the Stream provided, therefore the Stream should be writable and it should be a copy of the document to be repaired. This way, if the repair process fails, the original document will be preserved.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.RepairedStoredStream Property

StructureRepairOptionsRepairedStoredStream Property

Gets the stored stream that was used for the repaired file. If, after repair, this property is non-null, the owning document should be saved to a new file and this object should be disposed.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StoredStream RepairedStoredStream { get; }
Public ReadOnly Property RepairedStoredStream As StoredStream
    Get

Property Value

Type: StoredStream
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.RepairNameTrees Property

StructureRepairOptionsRepairNameTrees Property

Gets or sets a value indicating whether DotPdf will repair name trees.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RepairNameTrees { get; set; }
Public Property RepairNameTrees As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DotPdf will repair name trees; otherwise, false.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.RestoreOrphanedPages Property

StructureRepairOptionsRestoreOrphanedPages Property

Gets or sets a value indicating whether pages no longer directly referenced by the PDF document will be restored to the document.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool RestoreOrphanedPages { get; set; }
Public Property RestoreOrphanedPages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if orphaned pages will be restored; otherwise, false.
Remarks
Orphaned pages represent pages that were removed from the document's page collection but were left in the file. Removed pages may have been deleted or the page collection may be been damaged.

Setting this property requires scanning the entire file.

See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.StoredStreamProvider Property

StructureRepairOptionsStoredStreamProvider Property

Gets or sets the stored stream provider that will be used for creating a temporary file for storing the new PDF with the repaired cross reference table.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IStoredStreamProvider StoredStreamProvider { get; set; }
Public Property StoredStreamProvider As IStoredStreamProvider
    Get
    Set

Property Value

Type: IStoredStreamProvider
The stored stream provider.
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions Methods

The StructureRepairOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StructureRepairOptions Class
Atalasoft.PdfDoc.Repair Namespace


StructureRepairOptions.NameReplacer Delegate

StructureRepairOptionsNameReplacer Delegate

A delegate that is used to rename an existing name.

Namespace: Atalasoft.PdfDoc.Repair
Assembly: Atalasoft.PdfDoc (in Atalasoft.PdfDoc.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate string NameReplacer(
    string name,
    IList<string> existing
)
Public Delegate Function NameReplacer (
    name As String,
    existing As IList(Of String)
) As String

Parameters

name
Type: SystemString
The name to be renamed. May be null or empty.
existing
Type: System.Collections.GenericIListString
The existing names in the name tree.

Return Value

Type: String
A non-empty, non-null string for the new name. If the returned value is in the existing list, this will throw a PdfException.
See Also

Reference

Atalasoft.PdfDoc.Repair Namespace


Atalasoft.Shared Namespace

Classes
 | Class | Description
 | AtalasoftConfigSection | Atalasoft product configuration object which operates with app.config.
 | HeifDecoderConfigElement | Represents a HeifDecoder component configuration element.
Public class | OcrEnginesConfigSection | Represents OCR engines configuration section.
 | OmniPageEngineConfigElement | Represents a OmniPageEngine component configuration element.
 | PdfDecoderConfigElement | Represents a PdfDecoder component configuration element.
 | RawDecoderConfigElement | Represents a RawDecoder component configuration element.
 | Tesseract3EngineConfigElement | Represents a Tesseract3 component configuration element.
 | Tesseract5EngineConfigElement | Represents a Tesseract5 component configuration element.
 | XpsDecoderConfigElement | Represents a XpsDecoder component configuration element.
Enumerations
 | Enumeration | Description
Public enumeration | NativeLibValidationType | When a native library with same name already exists, this enum determines how libraries will be compared.
Public enumeration | RawEngine | Describes rendering engine to be used by RawDecoder.


AtalasoftConfigSection Class

Atalasoft product configuration object which operates with app.config.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
Atalasoft.SharedAtalasoftConfigSection

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AtalasoftConfigSection : ConfigurationSection
Public Class AtalasoftConfigSection
    Inherits ConfigurationSection

The AtalasoftConfigSection type exposes the following members.

Constructors
 | Name | Description
Public method | AtalasoftConfigSection | Initializes a new instance of the AtalasoftConfigSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
 | HeifDecoder | Gets a HeifDecoder component configuration section.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | LicenseManagerLocker | Gets a License Manager component configuration section.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | OcrEngines | Gets a OCR engines configuration section.
Public property | OfficeDecoder | Gets a OfficeDecoder component configuration section.
 | PdfDecoder | Gets a PdfDecoder component configuration section.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RawDecoder | Gets a RawDecoder component configuration section.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
 | XpsDecoder | Gets a XpsDecoder component configuration section.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfig | Gets an Atalasoft DotImage config.
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Protected method | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Examples
Sample of app.config file.
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <!--Components sections-->
    ...
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


AtalasoftConfigSection Constructor

Initializes a new instance of the AtalasoftConfigSection class

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AtalasoftConfigSection()
Public Sub New
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection Properties

The AtalasoftConfigSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
 | HeifDecoder | Gets a HeifDecoder component configuration section.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
 | LicenseManagerLocker | Gets a License Manager component configuration section.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
 | OcrEngines | Gets a OCR engines configuration section.
Public property | OfficeDecoder | Gets a OfficeDecoder component configuration section.
 | PdfDecoder | Gets a PdfDecoder component configuration section.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
 | RawDecoder | Gets a RawDecoder component configuration section.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
 | XpsDecoder | Gets a XpsDecoder component configuration section.
Top
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.HeifDecoder Property

AtalasoftConfigSectionHeifDecoder Property

Gets a HeifDecoder component configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HeifDecoderConfigElement HeifDecoder { get; }
Public ReadOnly Property HeifDecoder As HeifDecoderConfigElement
    Get

Property Value

Type: HeifDecoderConfigElement
Examples
HeifDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <HeifDecoder HeifLibLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.LicenseManagerLocker Property

AtalasoftConfigSectionLicenseManagerLocker Property

Gets a License Manager component configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LicenseManagerConfigSection LicenseManagerLocker { get; }
Public ReadOnly Property LicenseManagerLocker As LicenseManagerConfigSection
    Get

Property Value

Type: LicenseManagerConfigSection
Examples
To configure a number of lock attempts and delay between attempts, you should create app.config file as in the following example:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <LicenseManager LockRetryTimeout="3000" LockRetryCount="10"/>
  </Atalasoft>
</configuration>
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.OcrEngines Property

AtalasoftConfigSectionOcrEngines Property

Gets a OCR engines configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEnginesConfigSection OcrEngines { get; }
Public ReadOnly Property OcrEngines As OcrEnginesConfigSection
    Get

Property Value

Type: OcrEnginesConfigSection
Examples
OCR engines configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <OcrEngines>
      <Tesseract3Engine Tesseract3Location="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
    <OcrEngines>
  </Atalasoft>
</configuration>
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.OfficeDecoder Property

AtalasoftConfigSectionOfficeDecoder Property

Gets a OfficeDecoder component configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OfficeDecoderConfigElement OfficeDecoder { get; }
Public ReadOnly Property OfficeDecoder As OfficeDecoderConfigElement
    Get

Property Value

Type: OfficeDecoderConfigElement
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.PdfDecoder Property

AtalasoftConfigSectionPdfDecoder Property

Gets a PdfDecoder component configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDecoderConfigElement PdfDecoder { get; }
Public ReadOnly Property PdfDecoder As PdfDecoderConfigElement
    Get

Property Value

Type: PdfDecoderConfigElement
Examples
PdfDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <PdfDecoder PdfiumLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.RawDecoder Property

AtalasoftConfigSectionRawDecoder Property

Gets a RawDecoder component configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawDecoderConfigElement RawDecoder { get; }
Public ReadOnly Property RawDecoder As RawDecoderConfigElement
    Get

Property Value

Type: RawDecoderConfigElement
Examples
In order to use custom libraw.dll the following configuration should be used (LibRawLocation should point to a folder where desired libraw.dll is located):
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <RawDecoder UserDefinedLibRaw=true LibRawLocation="C:\Folder\Subfolder\SubSubFolder "/>
  </Atalasoft>
</configuration>
Examples
RawDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <RawDecoder LibRawLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.XpsDecoder Property

AtalasoftConfigSectionXpsDecoder Property

Gets a XpsDecoder component configuration section.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XpsDecoderConfigElement XpsDecoder { get; }
Public ReadOnly Property XpsDecoder As XpsDecoderConfigElement
    Get

Property Value

Type: XpsDecoderConfigElement
Examples
XpsDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <XpsDecoder XpsLibLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection Methods

The AtalasoftConfigSection type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfig | Gets an Atalasoft DotImage config.
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Protected method | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


AtalasoftConfigSection.GetConfig Method

AtalasoftConfigSectionGetConfig Method

Gets an Atalasoft DotImage config.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static AtalasoftConfigSection GetConfig()
Public Shared Function GetConfig As AtalasoftConfigSection

Return Value

Type: AtalasoftConfigSection
An AtalasoftConfigSection instance from app.config or default one.
See Also

Reference

AtalasoftConfigSection Class
Atalasoft.Shared Namespace


HeifDecoderConfigElement Class

Represents a HeifDecoder component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedHeifDecoderConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class HeifDecoderConfigElement : ConfigurationElement
Public Class HeifDecoderConfigElement
    Inherits ConfigurationElement

The HeifDecoderConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | HeifDecoderConfigElement | Initializes a new instance of the HeifDecoderConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Public property | HeifLibLocation | Gets an absolute path where HeifDecoder should unpack heif.dll and libde265.dll modules.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Examples
HeifDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <HeifDecoder HeifLibLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


HeifDecoderConfigElement Constructor

Initializes a new instance of the HeifDecoderConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public HeifDecoderConfigElement()
Public Sub New
See Also

Reference

HeifDecoderConfigElement Class
Atalasoft.Shared Namespace


HeifDecoderConfigElement Properties

The HeifDecoderConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Public property | HeifLibLocation | Gets an absolute path where HeifDecoder should unpack heif.dll and libde265.dll modules.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Top
See Also

Reference

HeifDecoderConfigElement Class
Atalasoft.Shared Namespace


HeifDecoderConfigElement.HeifLibLocation Property

HeifDecoderConfigElementHeifLibLocation Property

Gets an absolute path where HeifDecoder should unpack heif.dll and libde265.dll modules.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string HeifLibLocation { get; }
Public ReadOnly Property HeifLibLocation As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

HeifDecoderConfigElement Class
Atalasoft.Shared Namespace


HeifDecoderConfigElement.NativeLibValidationType Property

HeifDecoderConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

HeifDecoderConfigElement Class
Atalasoft.Shared Namespace


HeifDecoderConfigElement Methods

The HeifDecoderConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

HeifDecoderConfigElement Class
Atalasoft.Shared Namespace


NativeLibValidationType Enumeration

When a native library with same name already exists, this enum determines how libraries will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum NativeLibValidationType
Public Enumeration NativeLibValidationType
Members
Member name | Description
CheckSum | Compares library checksums.
Signature | Compares library signatures.
None | Do not replace an existing library.
See Also

Reference

Atalasoft.Shared Namespace


OcrEnginesConfigSection Class

Represents OCR engines configuration section.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedOcrEnginesConfigSection

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OcrEnginesConfigSection : ConfigurationElement
Public Class OcrEnginesConfigSection
    Inherits ConfigurationElement

The OcrEnginesConfigSection type exposes the following members.

Constructors
 | Name | Description
Public method | OcrEnginesConfigSection | Initializes a new instance of the OcrEnginesConfigSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | OmniPageEngine | Gets a OmniPageEngine component configuration element.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Tesseract3Engine | Gets a Tesseract3 component configuration element.
Public property | Tesseract5Engine | Gets a Tesseract5 component configuration element.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

Atalasoft.Shared Namespace


OcrEnginesConfigSection Constructor

Initializes a new instance of the OcrEnginesConfigSection class

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OcrEnginesConfigSection()
Public Sub New
See Also

Reference

OcrEnginesConfigSection Class
Atalasoft.Shared Namespace


OcrEnginesConfigSection Properties

The OcrEnginesConfigSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | OmniPageEngine | Gets a OmniPageEngine component configuration element.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Tesseract3Engine | Gets a Tesseract3 component configuration element.
Public property | Tesseract5Engine | Gets a Tesseract5 component configuration element.
Top
See Also

Reference

OcrEnginesConfigSection Class
Atalasoft.Shared Namespace


OcrEnginesConfigSection.OmniPageEngine Property

OcrEnginesConfigSectionOmniPageEngine Property

Gets a OmniPageEngine component configuration element.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageEngineConfigElement OmniPageEngine { get; }
Public ReadOnly Property OmniPageEngine As OmniPageEngineConfigElement
    Get

Property Value

Type: OmniPageEngineConfigElement
See Also

Reference

OcrEnginesConfigSection Class
Atalasoft.Shared Namespace


OcrEnginesConfigSection.Tesseract3Engine Property

OcrEnginesConfigSectionTesseract3Engine Property

Gets a Tesseract3 component configuration element.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract3EngineConfigElement Tesseract3Engine { get; }
Public ReadOnly Property Tesseract3Engine As Tesseract3EngineConfigElement
    Get

Property Value

Type: Tesseract3EngineConfigElement
See Also

Reference

OcrEnginesConfigSection Class
Atalasoft.Shared Namespace


OcrEnginesConfigSection.Tesseract5Engine Property

OcrEnginesConfigSectionTesseract5Engine Property

Gets a Tesseract5 component configuration element.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract5EngineConfigElement Tesseract5Engine { get; }
Public ReadOnly Property Tesseract5Engine As Tesseract5EngineConfigElement
    Get

Property Value

Type: Tesseract5EngineConfigElement
See Also

Reference

OcrEnginesConfigSection Class
Atalasoft.Shared Namespace


OcrEnginesConfigSection Methods

The OcrEnginesConfigSection type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

OcrEnginesConfigSection Class
Atalasoft.Shared Namespace


OmniPageEngineConfigElement Class

Represents a OmniPageEngine component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedOmniPageEngineConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class OmniPageEngineConfigElement : ConfigurationElement
Public Class OmniPageEngineConfigElement
    Inherits ConfigurationElement

The OmniPageEngineConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | OmniPageEngineConfigElement | Initializes a new instance of the OmniPageEngineConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Public property | OmniPageLocation | Gets an absolute path where OmniPageEngine should unpack Atalasoft.OmniPage.dll assembly.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Examples
OmniPageEngine library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <OcrEngines>
      <OmniPageEngine OmniPageLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
    <OcrEngines>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


OmniPageEngineConfigElement Constructor

Initializes a new instance of the OmniPageEngineConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OmniPageEngineConfigElement()
Public Sub New
See Also

Reference

OmniPageEngineConfigElement Class
Atalasoft.Shared Namespace


OmniPageEngineConfigElement Properties

The OmniPageEngineConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Public property | OmniPageLocation | Gets an absolute path where OmniPageEngine should unpack Atalasoft.OmniPage.dll assembly.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Top
See Also

Reference

OmniPageEngineConfigElement Class
Atalasoft.Shared Namespace


OmniPageEngineConfigElement.NativeLibValidationType Property

OmniPageEngineConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

OmniPageEngineConfigElement Class
Atalasoft.Shared Namespace


OmniPageEngineConfigElement.OmniPageLocation Property

OmniPageEngineConfigElementOmniPageLocation Property

Gets an absolute path where OmniPageEngine should unpack Atalasoft.OmniPage.dll assembly.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string OmniPageLocation { get; }
Public ReadOnly Property OmniPageLocation As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

OmniPageEngineConfigElement Class
Atalasoft.Shared Namespace


OmniPageEngineConfigElement Methods

The OmniPageEngineConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

OmniPageEngineConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement Class

Represents a PdfDecoder component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedPdfDecoderConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class PdfDecoderConfigElement : ConfigurationElement
Public Class PdfDecoderConfigElement
    Inherits ConfigurationElement

The PdfDecoderConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDecoderConfigElement | Initializes a new instance of the PdfDecoderConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Public property | PdfiumLocation | Gets an absolute path where PdfDecoder should unpack Atalasoft.Pdfium.dll assembly.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | UseForMultipleAppDomains | Gets a flag indicating whether PdfDecoder is supposed to be used in multiple app domains environment.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Fields
Name | Description
DefaultUseForMultipleAppDomains |
Top
Examples
PdfDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <PdfDecoder PdfiumLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


PdfDecoderConfigElement Constructor

Initializes a new instance of the PdfDecoderConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PdfDecoderConfigElement()
Public Sub New
See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement Properties

The PdfDecoderConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Public property | PdfiumLocation | Gets an absolute path where PdfDecoder should unpack Atalasoft.Pdfium.dll assembly.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | UseForMultipleAppDomains | Gets a flag indicating whether PdfDecoder is supposed to be used in multiple app domains environment.
Top
See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement.NativeLibValidationType Property

PdfDecoderConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement.PdfiumLocation Property

PdfDecoderConfigElementPdfiumLocation Property

Gets an absolute path where PdfDecoder should unpack Atalasoft.Pdfium.dll assembly.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string PdfiumLocation { get; }
Public ReadOnly Property PdfiumLocation As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement.UseForMultipleAppDomains Property

PdfDecoderConfigElementUseForMultipleAppDomains Property

Gets a flag indicating whether PdfDecoder is supposed to be used in multiple app domains environment.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UseForMultipleAppDomains { get; }
Public ReadOnly Property UseForMultipleAppDomains As Boolean
    Get

Property Value

Type: Boolean
Remarks
In case of multiple app domains the library uses different thread synchronization mechanism, because regular Critical Section based mechanism does not work between different app domains.
See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement Methods

The PdfDecoderConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement Fields

The PdfDecoderConfigElement type exposes the following members.

Fields
Name | Description
DefaultUseForMultipleAppDomains |
Top
See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


PdfDecoderConfigElement.DefaultUseForMultipleAppDomains Field

PdfDecoderConfigElementDefaultUseForMultipleAppDomains Field

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const bool DefaultUseForMultipleAppDomains = false
Public Const DefaultUseForMultipleAppDomains As Boolean = False

Field Value

Type: Boolean
See Also

Reference

PdfDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement Class

Represents a RawDecoder component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedRawDecoderConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RawDecoderConfigElement : ConfigurationElement
Public Class RawDecoderConfigElement
    Inherits ConfigurationElement

The RawDecoderConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | RawDecoderConfigElement | Initializes a new instance of the RawDecoderConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LibRawLocation | Gets an absolute path where RawDecoder should unpack libraw.lib.dll module.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | RenderingEngine | Gets RAW data rendering engine to be used by RawDecoder.
Public property | UserDefinedLibRaw | Gets a flag indicating whether to use user defined libraw.dll rather than build in version.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Fields
Name | Description
DefaultEngine | Default RAW data rendering engine.
Top
Examples
RawDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <RawDecoder LibRawLocation="C:\Folder\Subfolder\SubSubFolder" UserDefinedLibRaw="false" NativeLibValidationType="Signature" RenderingEngine="Auto"/>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


RawDecoderConfigElement Constructor

Initializes a new instance of the RawDecoderConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawDecoderConfigElement()
Public Sub New
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement Properties

The RawDecoderConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LibRawLocation | Gets an absolute path where RawDecoder should unpack libraw.lib.dll module.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | RenderingEngine | Gets RAW data rendering engine to be used by RawDecoder.
Public property | UserDefinedLibRaw | Gets a flag indicating whether to use user defined libraw.dll rather than build in version.
Top
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement.LibRawLocation Property

RawDecoderConfigElementLibRawLocation Property

Gets an absolute path where RawDecoder should unpack libraw.lib.dll module.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string LibRawLocation { get; }
Public ReadOnly Property LibRawLocation As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement.NativeLibValidationType Property

RawDecoderConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement.RenderingEngine Property

RawDecoderConfigElementRenderingEngine Property

Gets RAW data rendering engine to be used by RawDecoder.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RawEngine RenderingEngine { get; }
Public ReadOnly Property RenderingEngine As RawEngine
    Get

Property Value

Type: RawEngine
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement.UserDefinedLibRaw Property

RawDecoderConfigElementUserDefinedLibRaw Property

Gets a flag indicating whether to use user defined libraw.dll rather than build in version.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool UserDefinedLibRaw { get; }
Public ReadOnly Property UserDefinedLibRaw As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement Methods

The RawDecoderConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement Fields

The RawDecoderConfigElement type exposes the following members.

Fields
Name | Description
DefaultEngine | Default RAW data rendering engine.
Top
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawDecoderConfigElement.DefaultEngine Field

RawDecoderConfigElementDefaultEngine Field

Default RAW data rendering engine.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public const RawEngine DefaultEngine = RawEngine.Auto
Public Const DefaultEngine As RawEngine = RawEngine.Auto

Field Value

Type: RawEngine
See Also

Reference

RawDecoderConfigElement Class
Atalasoft.Shared Namespace


RawEngine Enumeration

Describes rendering engine to be used by RawDecoder.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum RawEngine
Public Enumeration RawEngine
Members
Member name | Description
DcRaw | DcRaw library is used to render RAW images.
LibRaw | LibRaw library is used to render RAW images.
Auto | RawDecoder selects library automatically.
See Also

Reference

Atalasoft.Shared Namespace


Tesseract3EngineConfigElement Class

Represents a Tesseract3 component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedTesseract3EngineConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Tesseract3EngineConfigElement : ConfigurationElement
Public Class Tesseract3EngineConfigElement
    Inherits ConfigurationElement

The Tesseract3EngineConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | Tesseract3EngineConfigElement | Initializes a new instance of the Tesseract3EngineConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Tesseract3Location | Gets an absolute path where Tesseract3 should unpack Atalasoft.Tesserac3.dll assembly.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Examples
Tesseract3 library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <OcrEngines>
      <Tesseract3Engine Tesseract3Location="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
    <OcrEngines>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


Tesseract3EngineConfigElement Constructor

Initializes a new instance of the Tesseract3EngineConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract3EngineConfigElement()
Public Sub New
See Also

Reference

Tesseract3EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract3EngineConfigElement Properties

The Tesseract3EngineConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Tesseract3Location | Gets an absolute path where Tesseract3 should unpack Atalasoft.Tesserac3.dll assembly.
Top
See Also

Reference

Tesseract3EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract3EngineConfigElement.NativeLibValidationType Property

Tesseract3EngineConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

Tesseract3EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract3EngineConfigElement.Tesseract3Location Property

Tesseract3EngineConfigElementTesseract3Location Property

Gets an absolute path where Tesseract3 should unpack Atalasoft.Tesserac3.dll assembly.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Tesseract3Location { get; }
Public ReadOnly Property Tesseract3Location As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

Tesseract3EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract3EngineConfigElement Methods

The Tesseract3EngineConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

Tesseract3EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract5EngineConfigElement Class

Represents a Tesseract5 component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedTesseract5EngineConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Tesseract5EngineConfigElement : ConfigurationElement
Public Class Tesseract5EngineConfigElement
    Inherits ConfigurationElement

The Tesseract5EngineConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | Tesseract5EngineConfigElement | Initializes a new instance of the Tesseract5EngineConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Tesseract5Location | Gets an absolute path where Tesseract5 should unpack Atalasoft.Tesseract5.dll assembly.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Examples
Tesseract5 library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <OcrEngines>
      <Tesseract5Engine Tesseract5Location="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
    <OcrEngines>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


Tesseract5EngineConfigElement Constructor

Initializes a new instance of the Tesseract5EngineConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Tesseract5EngineConfigElement()
Public Sub New
See Also

Reference

Tesseract5EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract5EngineConfigElement Properties

The Tesseract5EngineConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Tesseract5Location | Gets an absolute path where Tesseract5 should unpack Atalasoft.Tesseract5.dll assembly.
Top
See Also

Reference

Tesseract5EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract5EngineConfigElement.NativeLibValidationType Property

Tesseract5EngineConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

Tesseract5EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract5EngineConfigElement.Tesseract5Location Property

Tesseract5EngineConfigElementTesseract5Location Property

Gets an absolute path where Tesseract5 should unpack Atalasoft.Tesseract5.dll assembly.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Tesseract5Location { get; }
Public ReadOnly Property Tesseract5Location As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

Tesseract5EngineConfigElement Class
Atalasoft.Shared Namespace


Tesseract5EngineConfigElement Methods

The Tesseract5EngineConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

Tesseract5EngineConfigElement Class
Atalasoft.Shared Namespace


XpsDecoderConfigElement Class

Represents a XpsDecoder component configuration element.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Atalasoft.SharedXpsDecoderConfigElement

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class XpsDecoderConfigElement : ConfigurationElement
Public Class XpsDecoderConfigElement
    Inherits ConfigurationElement

The XpsDecoderConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | XpsDecoderConfigElement | Initializes a new instance of the XpsDecoderConfigElement class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | XpsLibLocation | Gets an absolute path where XpsDecoder should unpack Atalasoft.XPS.lib.dll module.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Examples
XpsDecoder library configuration sample:
Copy
<?xml version="1.0" encoding="utf-8" ?>
 <configuration>
   <configSections>
     <section name="Atalasoft"
                 type="Atalasoft.Shared.AtalasoftConfigSection, Atalasoft.Shared"/>
  </configSections>

  <Atalasoft>
    <XpsDecoder XpsLibLocation="C:\Folder\Subfolder\SubSubFolder" NativeLibValidationType="Signature"/>
  </Atalasoft>
</configuration>
See Also

Reference

Atalasoft.Shared Namespace


XpsDecoderConfigElement Constructor

Initializes a new instance of the XpsDecoderConfigElement class.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public XpsDecoderConfigElement()
Public Sub New
See Also

Reference

XpsDecoderConfigElement Class
Atalasoft.Shared Namespace


XpsDecoderConfigElement Properties

The XpsDecoderConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NativeLibValidationType | Gets a flag that identify how assemblies will be compared.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | XpsLibLocation | Gets an absolute path where XpsDecoder should unpack Atalasoft.XPS.lib.dll module.
Top
See Also

Reference

XpsDecoderConfigElement Class
Atalasoft.Shared Namespace


XpsDecoderConfigElement.NativeLibValidationType Property

XpsDecoderConfigElementNativeLibValidationType Property

Gets a flag that identify how assemblies will be compared.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NativeLibValidationType NativeLibValidationType { get; }
Public ReadOnly Property NativeLibValidationType As NativeLibValidationType
    Get

Property Value

Type: NativeLibValidationType
Remarks

If this property doesn't set in config file, CheckSum will be returned.

When a native library with the same name already exists, this value determines how libraries will be compared. As a result, the existing library will be updated or not.

See Also

Reference

XpsDecoderConfigElement Class
Atalasoft.Shared Namespace


XpsDecoderConfigElement.XpsLibLocation Property

XpsDecoderConfigElementXpsLibLocation Property

Gets an absolute path where XpsDecoder should unpack Atalasoft.XPS.lib.dll module.

Namespace: Atalasoft.Shared
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string XpsLibLocation { get; }
Public ReadOnly Property XpsLibLocation As String
    Get

Property Value

Type: String
Remarks

If this property doesn't set in config file, the "%TEMP%\Atalasoft\DotImage\<Version>\<Platform>" will be returned.

This property in config file can be either absolute path, or relative. All missed subfolders will be created automatically if application user has necessary permissions.

See Also

Reference

XpsDecoderConfigElement Class
Atalasoft.Shared Namespace


XpsDecoderConfigElement Methods

The XpsDecoderConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
See Also

Reference

XpsDecoderConfigElement Class
Atalasoft.Shared Namespace


Atalasoft.Shared.Diagnostics Namespace

Classes
 | Class | Description
 | ActivityScope | Helper class that simplifies work with activities.
Public class | Logger | The class provides all necessary log operations.
Public class | LoggerBase | The class provides all necessary log operations.


ActivityScope Class

Helper class that simplifies work with activities.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.DiagnosticsActivityScope

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ActivityScope : IDisposable
Public Class ActivityScope
    Implements IDisposable

The ActivityScope type exposes the following members.

Constructors
 | Name | Description
Protected method | ActivityScope | Initializes a new instance of the ActivityScope class.
Public method | ActivityScope(TraceSource, String) | Initializes a new instance of the ActivityScope class. Sets new activity id, trace transfer to the new activity and start new logical operation.
Top
Properties
 | Name | Description
Public property | ActivityName | Gets name of the current activity.
 | NullScope | Gets null activity scope that does nothing (it does not use Correlation Manager at all).
Top
Methods
 | Name | Description
Public method | Dispose | Dispose method implementation. Stops current logical operation, transfer to the previous activity and sets previous activity id.
Protected method | Dispose(Boolean) | Correct implementation of Dispose pattern.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
TraceSource trace = ...
using (var scope = new ActivityScope(trace, "Some Interesting Activity"))
{
   // ...
   using (var scope = new ActivityScope(trace, "Nested Activity"))
   {
      // ...
   }
   // ...
}
See Also

Reference

Atalasoft.Shared.Diagnostics Namespace


ActivityScope Constructor

Overload List
 | Name | Description
Protected method | ActivityScope | Initializes a new instance of the ActivityScope class.
Public method | ActivityScope(TraceSource, String) | Initializes a new instance of the ActivityScope class. Sets new activity id, trace transfer to the new activity and start new logical operation.
Top
See Also

Reference

ActivityScope Class
Atalasoft.Shared.Diagnostics Namespace


ActivityScope Constructor

Initializes a new instance of the ActivityScope class.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected ActivityScope()
Protected Sub New
See Also

Reference

ActivityScope Class
ActivityScope Overload
Atalasoft.Shared.Diagnostics Namespace


ActivityScope Constructor (TraceSource, String)

Initializes a new instance of the ActivityScope class.

Sets new activity id, trace transfer to the new activity and start new logical operation.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ActivityScope(
    TraceSource ts,
    string activityName
)
Public Sub New (
    ts As TraceSource,
    activityName As String
)

Parameters

ts
Type: System.DiagnosticsTraceSource
Trace source
activityName
Type: SystemString
Activity name
See Also

Reference

ActivityScope Class
ActivityScope Overload
Atalasoft.Shared.Diagnostics Namespace


ActivityScope Properties

The ActivityScope type exposes the following members.

Properties
 | Name | Description
Public property | ActivityName | Gets name of the current activity.
 | NullScope | Gets null activity scope that does nothing (it does not use Correlation Manager at all).
Top
See Also

Reference

ActivityScope Class
Atalasoft.Shared.Diagnostics Namespace


ActivityScope.ActivityName Property

ActivityScopeActivityName Property

Gets name of the current activity.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ActivityName { get; }
Public ReadOnly Property ActivityName As String
    Get

Property Value

Type: String
See Also

Reference

ActivityScope Class
Atalasoft.Shared.Diagnostics Namespace


ActivityScope.NullScope Property

ActivityScopeNullScope Property

Gets null activity scope that does nothing (it does not use Correlation Manager at all).

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static ActivityScope NullScope { get; }
Public Shared ReadOnly Property NullScope As ActivityScope
    Get

Property Value

Type: ActivityScope
Remarks
We need this to optimize situations when activity logging is turned off.
See Also

Reference

ActivityScope Class
Atalasoft.Shared.Diagnostics Namespace


ActivityScope Methods

The ActivityScope type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose method implementation. Stops current logical operation, transfer to the previous activity and sets previous activity id.
Protected method | Dispose(Boolean) | Correct implementation of Dispose pattern.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivityScope Class
Atalasoft.Shared.Diagnostics Namespace


ActivityScope.Dispose Method

ActivityScopeDispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose method implementation. Stops current logical operation, transfer to the previous activity and sets previous activity id.
Protected method | Dispose(Boolean) | Correct implementation of Dispose pattern.
Top
See Also

Reference

ActivityScope Class
Atalasoft.Shared.Diagnostics Namespace


ActivityScope.Dispose Method

ActivityScopeDispose Method

Dispose method implementation. Stops current logical operation, transfer to the previous activity and sets previous activity id.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ActivityScope Class
Dispose Overload
Atalasoft.Shared.Diagnostics Namespace


ActivityScope.Dispose Method (Boolean)

ActivityScopeDispose Method (Boolean)

Correct implementation of Dispose pattern.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
Whether object is currently being disposed or not.
See Also

Reference

ActivityScope Class
Dispose Overload
Atalasoft.Shared.Diagnostics Namespace


Logger Class

The class provides all necessary log operations.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.DiagnosticsLoggerBase
Atalasoft.Shared.DiagnosticsLogger

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Logger : LoggerBase
Public Class Logger
    Inherits LoggerBase

The Logger type exposes the following members.

Properties
 | Name | Description
Public property | Source | Gets trace source that is used to write messages to. (Inherited from LoggerBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAssemblyLogger | Fabric method that returns new instance of the logger initialized with calling assembly name.
 | GetAssemblyLogger(String) | TODO
 | GetAssemblyLoggerT | Fabric method that returns new instance of the logger initialized with assembly name of the specified type.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLogged | (Inherited from LoggerBase.)
Public method | LogAssemblyInformation | Logs basic information about calling assembly, such as full name and file version.
Public method | LogError(String) | Writes an error message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogError(String, Object) | Writes an error message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Public method | LogInfo(String) | Writes an informational message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogInfo(String, Object) | Writes an informational message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Protected method | LogMessage(TraceEventType, String) | Writes message of specified type to the log using specified message. (Inherited from LoggerBase.)
Protected method | LogMessage(TraceEventType, String, Object) | Writes message of specified type to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Public method | LogVerbose(String) | Writes a verbose message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogVerbose(String, Object) | Writes a verbose message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Public method | LogWarning(String) | Writes a warning message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogWarning(String, Object) | Writes a warning message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartNewActivity(String) | Convenient method that returns new activity scope with specified name. (Inherited from LoggerBase.)
 | StartNewActivity(String, Object) | Convenient method that returns new activity scope with specified name. (Inherited from LoggerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Diagnostics Namespace


Logger Properties

The Logger type exposes the following members.

Properties
 | Name | Description
Public property | Source | Gets trace source that is used to write messages to. (Inherited from LoggerBase.)
Top
See Also

Reference

Logger Class
Atalasoft.Shared.Diagnostics Namespace


Logger Methods

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAssemblyLogger | Fabric method that returns new instance of the logger initialized with calling assembly name.
 | GetAssemblyLogger(String) | TODO
 | GetAssemblyLoggerT | Fabric method that returns new instance of the logger initialized with assembly name of the specified type.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLogged | (Inherited from LoggerBase.)
Public method | LogAssemblyInformation | Logs basic information about calling assembly, such as full name and file version.
Public method | LogError(String) | Writes an error message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogError(String, Object) | Writes an error message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Public method | LogInfo(String) | Writes an informational message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogInfo(String, Object) | Writes an informational message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Protected method | LogMessage(TraceEventType, String) | Writes message of specified type to the log using specified message. (Inherited from LoggerBase.)
Protected method | LogMessage(TraceEventType, String, Object) | Writes message of specified type to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Public method | LogVerbose(String) | Writes a verbose message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogVerbose(String, Object) | Writes a verbose message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Public method | LogWarning(String) | Writes a warning message to the log using specified message. (Inherited from LoggerBase.)
Public method | LogWarning(String, Object) | Writes a warning message to the log using the specified array of objects and formatting information. (Inherited from LoggerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartNewActivity(String) | Convenient method that returns new activity scope with specified name. (Inherited from LoggerBase.)
 | StartNewActivity(String, Object) | Convenient method that returns new activity scope with specified name. (Inherited from LoggerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Logger Class
Atalasoft.Shared.Diagnostics Namespace


Logger.GetAssemblyLogger Method

LoggerGetAssemblyLogger Method

Overload List
Name | Description
GetAssemblyLoggerT | Fabric method that returns new instance of the logger initialized with assembly name of the specified type.
GetAssemblyLogger | Fabric method that returns new instance of the logger initialized with calling assembly name.
GetAssemblyLogger(String) | TODO
Top
See Also

Reference

Logger Class
Atalasoft.Shared.Diagnostics Namespace


Logger.GetAssemblyLogger(T) Method

LoggerGetAssemblyLoggerT Method

Fabric method that returns new instance of the logger initialized with assembly name of the specified type.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Logger GetAssemblyLogger<T>()

Public Shared Function GetAssemblyLogger(Of T) As Logger

Type Parameters

T
Trace source name will be equal to name of the assembly that contains specified type.

Return Value

Type: Logger
Configured instance of the logger.
See Also

Reference

Logger Class
GetAssemblyLogger Overload
Atalasoft.Shared.Diagnostics Namespace


Logger.GetAssemblyLogger Method

LoggerGetAssemblyLogger Method

Fabric method that returns new instance of the logger initialized with calling assembly name.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Logger GetAssemblyLogger()
Public Shared Function GetAssemblyLogger As Logger

Return Value

Type: Logger
Configured instance of the logger.
See Also

Reference

Logger Class
GetAssemblyLogger Overload
Atalasoft.Shared.Diagnostics Namespace


Logger.GetAssemblyLogger Method (String)

LoggerGetAssemblyLogger Method (String)

TODO

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static Logger GetAssemblyLogger(
    string name
)
Public Shared Function GetAssemblyLogger (
    name As String
) As Logger

Parameters

name
Type: SystemString
TODO

Return Value

Type: Logger
TODO
See Also

Reference

Logger Class
GetAssemblyLogger Overload
Atalasoft.Shared.Diagnostics Namespace


Logger.LogAssemblyInformation Method

LoggerLogAssemblyInformation Method

Logs basic information about calling assembly, such as full name and file version.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogAssemblyInformation()
Public Sub LogAssemblyInformation
See Also

Reference

Logger Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase Class

The class provides all necessary log operations.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.DiagnosticsLoggerBase
Atalasoft.Shared.DiagnosticsLogger

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class LoggerBase
Public MustInherit Class LoggerBase

The LoggerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LoggerBase | Initializes a new instance of the LoggerBase class.
Top
Properties
 | Name | Description
Public property | Source | Gets trace source that is used to write messages to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLogged |
Public method | LogError(String) | Writes an error message to the log using specified message.
Public method | LogError(String, Object) | Writes an error message to the log using the specified array of objects and formatting information.
Public method | LogInfo(String) | Writes an informational message to the log using specified message.
Public method | LogInfo(String, Object) | Writes an informational message to the log using the specified array of objects and formatting information.
Protected method | LogMessage(TraceEventType, String) | Writes message of specified type to the log using specified message.
Protected method | LogMessage(TraceEventType, String, Object) | Writes message of specified type to the log using the specified array of objects and formatting information.
Public method | LogVerbose(String) | Writes a verbose message to the log using specified message.
Public method | LogVerbose(String, Object) | Writes a verbose message to the log using the specified array of objects and formatting information.
Public method | LogWarning(String) | Writes a warning message to the log using specified message.
Public method | LogWarning(String, Object) | Writes a warning message to the log using the specified array of objects and formatting information.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartNewActivity(String) | Convenient method that returns new activity scope with specified name.
 | StartNewActivity(String, Object) | Convenient method that returns new activity scope with specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Diagnostics Namespace


LoggerBase Constructor

Initializes a new instance of the LoggerBase class.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected LoggerBase(
    TraceSource trace
)
Protected Sub New (
    trace As TraceSource
)

Parameters

trace
Type: System.DiagnosticsTraceSource
Trace source to use.
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase Properties

The LoggerBase type exposes the following members.

Properties
 | Name | Description
Public property | Source | Gets trace source that is used to write messages to.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.Source Property

LoggerBaseSource Property

Gets trace source that is used to write messages to.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TraceSource Source { get; }
Public ReadOnly Property Source As TraceSource
    Get

Property Value

Type: TraceSource
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase Methods

The LoggerBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLogged |
Public method | LogError(String) | Writes an error message to the log using specified message.
Public method | LogError(String, Object) | Writes an error message to the log using the specified array of objects and formatting information.
Public method | LogInfo(String) | Writes an informational message to the log using specified message.
Public method | LogInfo(String, Object) | Writes an informational message to the log using the specified array of objects and formatting information.
Protected method | LogMessage(TraceEventType, String) | Writes message of specified type to the log using specified message.
Protected method | LogMessage(TraceEventType, String, Object) | Writes message of specified type to the log using the specified array of objects and formatting information.
Public method | LogVerbose(String) | Writes a verbose message to the log using specified message.
Public method | LogVerbose(String, Object) | Writes a verbose message to the log using the specified array of objects and formatting information.
Public method | LogWarning(String) | Writes a warning message to the log using specified message.
Public method | LogWarning(String, Object) | Writes a warning message to the log using the specified array of objects and formatting information.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartNewActivity(String) | Convenient method that returns new activity scope with specified name.
 | StartNewActivity(String, Object) | Convenient method that returns new activity scope with specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.IsLogged Method

LoggerBaseIsLogged Method

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsLogged(
    TraceEventType eventType
)
Public Function IsLogged (
    eventType As TraceEventType
) As Boolean

Parameters

eventType
Type: System.DiagnosticsTraceEventType

Return Value

Type: Boolean
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogError Method

LoggerBaseLogError Method

Overload List
 | Name | Description
Public method | LogError(String) | Writes an error message to the log using specified message.
Public method | LogError(String, Object) | Writes an error message to the log using the specified array of objects and formatting information.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogError Method (String)

LoggerBaseLogError Method (String)

Writes an error message to the log using specified message.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogError(
    string message
)
Public Sub LogError (
    message As String
)

Parameters

message
Type: SystemString
The informative message to write.
See Also

Reference

LoggerBase Class
LogError Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogError Method (String, Object[])

LoggerBaseLogError Method (String, Object)

Writes an error message to the log using the specified array of objects and formatting information.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogError(
    string format,
    params Object[] args
)
Public Sub LogError (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
A format string that contains zero or more format items, which correspond to objects in the args array.
args
Type: SystemObject
An object array containing zero or more objects to format.
See Also

Reference

LoggerBase Class
LogError Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogInfo Method

LoggerBaseLogInfo Method

Overload List
 | Name | Description
Public method | LogInfo(String) | Writes an informational message to the log using specified message.
Public method | LogInfo(String, Object) | Writes an informational message to the log using the specified array of objects and formatting information.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogInfo Method (String)

LoggerBaseLogInfo Method (String)

Writes an informational message to the log using specified message.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogInfo(
    string message
)
Public Sub LogInfo (
    message As String
)

Parameters

message
Type: SystemString
The informative message to write.
See Also

Reference

LoggerBase Class
LogInfo Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogInfo Method (String, Object[])

LoggerBaseLogInfo Method (String, Object)

Writes an informational message to the log using the specified array of objects and formatting information.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogInfo(
    string format,
    params Object[] args
)
Public Sub LogInfo (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
A format string that contains zero or more format items, which correspond to objects in the args array.
args
Type: SystemObject
An object array containing zero or more objects to format.
See Also

Reference

LoggerBase Class
LogInfo Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogMessage Method

LoggerBaseLogMessage Method

Overload List
 | Name | Description
Protected method | LogMessage(TraceEventType, String) | Writes message of specified type to the log using specified message.
Protected method | LogMessage(TraceEventType, String, Object) | Writes message of specified type to the log using the specified array of objects and formatting information.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogMessage Method (TraceEventType, String)

LoggerBaseLogMessage Method (TraceEventType, String)

Writes message of specified type to the log using specified message.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LogMessage(
    TraceEventType eventType,
    string message
)
Protected Overridable Sub LogMessage (
    eventType As TraceEventType,
    message As String
)

Parameters

eventType
Type: System.DiagnosticsTraceEventType
Type of the message.
message
Type: SystemString
The informative message to write.
See Also

Reference

LoggerBase Class
LogMessage Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogMessage Method (TraceEventType, String, Object[])

LoggerBaseLogMessage Method (TraceEventType, String, Object)

Writes message of specified type to the log using the specified array of objects and formatting information.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void LogMessage(
    TraceEventType eventType,
    string format,
    params Object[] args
)
Protected Overridable Sub LogMessage (
    eventType As TraceEventType,
    format As String,
    ParamArray args As Object()
)

Parameters

eventType
Type: System.DiagnosticsTraceEventType
Type of the message.
format
Type: SystemString
A format string that contains zero or more format items, which correspond to objects in the args array.
args
Type: SystemObject
An object array containing zero or more objects to format.
See Also

Reference

LoggerBase Class
LogMessage Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogVerbose Method

LoggerBaseLogVerbose Method

Overload List
 | Name | Description
Public method | LogVerbose(String) | Writes a verbose message to the log using specified message.
Public method | LogVerbose(String, Object) | Writes a verbose message to the log using the specified array of objects and formatting information.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogVerbose Method (String)

LoggerBaseLogVerbose Method (String)

Writes a verbose message to the log using specified message.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogVerbose(
    string message
)
Public Sub LogVerbose (
    message As String
)

Parameters

message
Type: SystemString
The informative message to write.
See Also

Reference

LoggerBase Class
LogVerbose Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogVerbose Method (String, Object[])

LoggerBaseLogVerbose Method (String, Object)

Writes a verbose message to the log using the specified array of objects and formatting information.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogVerbose(
    string format,
    params Object[] args
)
Public Sub LogVerbose (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
A format string that contains zero or more format items, which correspond to objects in the args array.
args
Type: SystemObject
An object array containing zero or more objects to format.
See Also

Reference

LoggerBase Class
LogVerbose Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogWarning Method

LoggerBaseLogWarning Method

Overload List
 | Name | Description
Public method | LogWarning(String) | Writes a warning message to the log using specified message.
Public method | LogWarning(String, Object) | Writes a warning message to the log using the specified array of objects and formatting information.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogWarning Method (String)

LoggerBaseLogWarning Method (String)

Writes a warning message to the log using specified message.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogWarning(
    string message
)
Public Sub LogWarning (
    message As String
)

Parameters

message
Type: SystemString
The informative message to write.
See Also

Reference

LoggerBase Class
LogWarning Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.LogWarning Method (String, Object[])

LoggerBaseLogWarning Method (String, Object)

Writes a warning message to the log using the specified array of objects and formatting information.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LogWarning(
    string format,
    params Object[] args
)
Public Sub LogWarning (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
A format string that contains zero or more format items, which correspond to objects in the args array.
args
Type: SystemObject
An object array containing zero or more objects to format.
See Also

Reference

LoggerBase Class
LogWarning Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.StartNewActivity Method

LoggerBaseStartNewActivity Method

Overload List
Name | Description
StartNewActivity(String) | Convenient method that returns new activity scope with specified name.
StartNewActivity(String, Object) | Convenient method that returns new activity scope with specified name.
Top
See Also

Reference

LoggerBase Class
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.StartNewActivity Method (String)

LoggerBaseStartNewActivity Method (String)

Convenient method that returns new activity scope with specified name.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ActivityScope StartNewActivity(
    string activityName
)
Public Overridable Function StartNewActivity (
    activityName As String
) As ActivityScope

Parameters

activityName
Type: SystemString
New activity name.

Return Value

Type: ActivityScope
Activity scope
Examples
Copy
Logger log = ...
using(log.StartNewActivity("Some Interesting Activity"))
{
   // ...
}
See Also

Reference

LoggerBase Class
StartNewActivity Overload
Atalasoft.Shared.Diagnostics Namespace


LoggerBase.StartNewActivity Method (String, Object[])

LoggerBaseStartNewActivity Method (String, Object)

Convenient method that returns new activity scope with specified name.

Namespace: Atalasoft.Shared.Diagnostics
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public virtual ActivityScope StartNewActivity(
    string activityNameFormat,
    params Object[] args
)
Public Overridable Function StartNewActivity (
    activityNameFormat As String,
    ParamArray args As Object()
) As ActivityScope

Parameters

activityNameFormat
Type: SystemString
A format string that contains zero or more format items, which correspond to objects in the args array.
args
Type: SystemObject
An object array containing zero or more objects to format.

Return Value

Type: ActivityScope
Activity scope
Examples
Copy
Logger log = ...
using(log.StartNewActivity("Some Interesting Activity"))
{
   // ...
}
See Also

Reference

LoggerBase Class
StartNewActivity Overload
Atalasoft.Shared.Diagnostics Namespace


Atalasoft.Shared.IO Namespace

Classes
Class | Description
DisposableTempFile | A class for managing a temporary file. The name is based off a Guid with an optional prefix or suffix. The file is deleted when this object is disposed.


DisposableTempFile Class

A class for managing a temporary file. The name is based off a Guid with an optional prefix or suffix. The file is deleted when this object is disposed.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.IODisposableTempFile

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class DisposableTempFile : IDisposable
Public NotInheritable Class DisposableTempFile
    Implements IDisposable

The DisposableTempFile type exposes the following members.

Constructors
 | Name | Description
Public method | DisposableTempFile | Creates a new temporary file which uses a Guid as the name.
Public method | DisposableTempFile(String) | Creates a new temporary file which uses a Guid as the name.
Public method | DisposableTempFile(String, String) | Creates a new DisposableTempFile which uses a Guid as the name.
Public method | DisposableTempFile(String, String, Boolean) | Initializes a new instance of the DisposableTempFile class.
Public method | DisposableTempFile(String, String, String) | Initializes a new instance of the DisposableTempFile class.
Public method | DisposableTempFile(String, String, String, Boolean) | Initializes a new instance of the DisposableTempFile class.
Top
Properties
 | Name | Description
Public property | FullName | Gets the full file name that was generated for this instance.
Public property | IsCreated | Gets a value indicating whether the file has been created. Sets a value which if true, will create the file (If it hasn't already been created) else will delete the file (If it has been created).
Top
Methods
 | Name | Description
Public method | Create | Creates / overwrites the temporary file.
Public method | Delete | Delete the temporary file.
Public method | Dispose | Releases all resources used by the DisposableTempFile
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
 | FromName | Creates a DisposableTempFile from a known full path to a file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Open | Opens the temporary file with the specified mode, access and share.
Public method | OpenRead | Opens the temporary file for reading. Requires that IsCreated is true.
Public method | OpenWrite | Opens the temporary file for writing. Requires that IsCreated is true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Creates a temporary file, writes the byte '42' to it, proves that '42' was written and finally proves that the file was deleted when disposed.
Copy
String fullName = null;

// Prepares a new temporary .txt file located in a subdirectory called "MySubFolder" within the system temp directory.
using(DisposableTempFile tempFile = new DisposableTempFile("MySubFolder\\", ".txt"))
{
    // Stores the full name that was generated for the temp file.
    fullName = tempFile.FullName;

    // Creates the temp file.
    tempFile.IsCreated = true;

    // Writes the byte '42'
    using(Stream stream = tempFile.OpenWrite())
    {
        stream.WriteByte(42);
    }

    // Opens the same temp file that was just written for read.
    using(Stream stream = tempFile.OpenRead())
    {
        // This should pass... (Reads first byte, ensures it is 42).
        Debug.Assert(stream.ReadByte() == 42);
    }
} // Disposes tempFile.

// This should also pass... (Demonstrates that after TemporaryFile is disposed, the file is deleted).
Debug.Assert(File.Exists(fullName) == false);
See Also

Reference

Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor

Overload List
 | Name | Description
Public method | DisposableTempFile | Creates a new temporary file which uses a Guid as the name.
Public method | DisposableTempFile(String) | Creates a new temporary file which uses a Guid as the name.
Public method | DisposableTempFile(String, String) | Creates a new DisposableTempFile which uses a Guid as the name.
Public method | DisposableTempFile(String, String, Boolean) | Initializes a new instance of the DisposableTempFile class.
Public method | DisposableTempFile(String, String, String) | Initializes a new instance of the DisposableTempFile class.
Public method | DisposableTempFile(String, String, String, Boolean) | Initializes a new instance of the DisposableTempFile class.
Top
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor

Creates a new temporary file which uses a Guid as the name.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableTempFile()
Public Sub New
See Also

Reference

DisposableTempFile Class
DisposableTempFile Overload
Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor (String)

Creates a new temporary file which uses a Guid as the name.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableTempFile(
    string fileNamePrefix
)
Public Sub New (
    fileNamePrefix As String
)

Parameters

fileNamePrefix
Type: SystemString
A string to prefix the Guid with.
See Also

Reference

DisposableTempFile Class
DisposableTempFile Overload
Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor (String, String)

Creates a new DisposableTempFile which uses a Guid as the name.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableTempFile(
    string fileNamePrefix,
    string fileNameSuffix
)
Public Sub New (
    fileNamePrefix As String,
    fileNameSuffix As String
)

Parameters

fileNamePrefix
Type: SystemString
A string to prefix the Guid with.
fileNameSuffix
Type: SystemString
A string to suffix the Guid with.
Remarks
Temporary files are created in the system temporary directory returned by GetTempPath.
See Also

Reference

DisposableTempFile Class
DisposableTempFile Overload
Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor (String, String, Boolean)

Initializes a new instance of the DisposableTempFile class.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableTempFile(
    string fileNamePrefix,
    string fileNameSuffix,
    bool create
)
Public Sub New (
    fileNamePrefix As String,
    fileNameSuffix As String,
    create As Boolean
)

Parameters

fileNamePrefix
Type: SystemString
The file name prefix.
fileNameSuffix
Type: SystemString
The file name suffix.
create
Type: SystemBoolean
if set to true the file.
See Also

Reference

DisposableTempFile Class
DisposableTempFile Overload
Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor (String, String, String)

Initializes a new instance of the DisposableTempFile class.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableTempFile(
    string tempDirectory,
    string fileNamePrefix,
    string fileNameSuffix
)
Public Sub New (
    tempDirectory As String,
    fileNamePrefix As String,
    fileNameSuffix As String
)

Parameters

tempDirectory
Type: SystemString
The temporary directory.
fileNamePrefix
Type: SystemString
The file name prefix.
fileNameSuffix
Type: SystemString
The file name suffix.
Exceptions
Exception | Condition
ArgumentNullException | fileNamePrefix or fileNameSuffix
See Also

Reference

DisposableTempFile Class
DisposableTempFile Overload
Atalasoft.Shared.IO Namespace


DisposableTempFile Constructor (String, String, String, Boolean)

Initializes a new instance of the DisposableTempFile class.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DisposableTempFile(
    string tempDirectory,
    string fileNamePrefix,
    string fileNameSuffix,
    bool create
)
Public Sub New (
    tempDirectory As String,
    fileNamePrefix As String,
    fileNameSuffix As String,
    create As Boolean
)

Parameters

tempDirectory
Type: SystemString
The temporary directory.
fileNamePrefix
Type: SystemString
The file name prefix.
fileNameSuffix
Type: SystemString
The file name suffix.
create
Type: SystemBoolean
if set to true the file.
Exceptions
Exception | Condition
ArgumentNullException | fileNamePrefix or fileNameSuffix
See Also

Reference

DisposableTempFile Class
DisposableTempFile Overload
Atalasoft.Shared.IO Namespace


DisposableTempFile Properties

The DisposableTempFile type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full file name that was generated for this instance.
Public property | IsCreated | Gets a value indicating whether the file has been created. Sets a value which if true, will create the file (If it hasn't already been created) else will delete the file (If it has been created).
Top
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.FullName Property

DisposableTempFileFullName Property

Gets the full file name that was generated for this instance.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get

Property Value

Type: String
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.IsCreated Property

DisposableTempFileIsCreated Property

Gets a value indicating whether the file has been created. Sets a value which if true, will create the file (If it hasn't already been created) else will delete the file (If it has been created).

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsCreated { get; set; }
Public Property IsCreated As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile Methods

The DisposableTempFile type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates / overwrites the temporary file.
Public method | Delete | Delete the temporary file.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
 | FromName | Creates a DisposableTempFile from a known full path to a file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Open | Opens the temporary file with the specified mode, access and share.
Public method | OpenRead | Opens the temporary file for reading. Requires that IsCreated is true.
Public method | OpenWrite | Opens the temporary file for writing. Requires that IsCreated is true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.Create Method

DisposableTempFileCreate Method

Creates / overwrites the temporary file.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Create()
Public Sub Create
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.Delete Method

DisposableTempFileDelete Method

Delete the temporary file.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Delete()
Public Sub Delete
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.Dispose Method

DisposableTempFileDispose Method

Releases all resources used by the DisposableTempFile

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.Finalize Method

DisposableTempFileFinalize Method

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.FromName Method

DisposableTempFileFromName Method

Creates a DisposableTempFile from a known full path to a file.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public static DisposableTempFile FromName(
    string fileName,
    bool create
)
Public Shared Function FromName (
    fileName As String,
    create As Boolean
) As DisposableTempFile

Parameters

fileName
Type: SystemString
create
Type: SystemBoolean

Return Value

Type: DisposableTempFile
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.Open Method

DisposableTempFileOpen Method

Opens the temporary file with the specified mode, access and share.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream Open(
    FileMode mode,
    FileAccess access,
    FileShare share
)
Public Function Open (
    mode As FileMode,
    access As FileAccess,
    share As FileShare
) As Stream

Parameters

mode
Type: System.IOFileMode
The file open mode.
access
Type: System.IOFileAccess
The file access.
share
Type: System.IOFileShare
The file share permissions.

Return Value

Type: Stream
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.OpenRead Method

DisposableTempFileOpenRead Method

Opens the temporary file for reading. Requires that IsCreated is true.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream OpenRead()
Public Function OpenRead As Stream

Return Value

Type: Stream
A stream which can be used to read from the temporary file.
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


DisposableTempFile.OpenWrite Method

DisposableTempFileOpenWrite Method

Opens the temporary file for writing. Requires that IsCreated is true.

Namespace: Atalasoft.Shared.IO
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream OpenWrite()
Public Function OpenWrite As Stream

Return Value

Type: Stream
A stream which can be used to write to the temporary file.
See Also

Reference

DisposableTempFile Class
Atalasoft.Shared.IO Namespace


Atalasoft.Shared.Validation Namespace

Classes
 | Class | Description
Public class | BaseProblem | An abstract class that defines a problem located in an object and a mechanism to repair it.
Public class | BaseRepairConsequences | This class represents the consequences of performing a particular repair. This class is never constructed directly and is instead defined by the package that requires validation as the meaning of repair consequences will vary based on the package's needs.
Public class | BasicRepairContextT | A basic RepairContext object meant for holding one piece of content.
Public class | ProblemT, U | Defines a problem found in the internal state of an object.
Public class | ProblemEventArgs | Represents an event fired when a problem has been repaired.
Public class | ProblemList | A list of problems that need to be repaired.
Public class | RepairContext | A base context for repairing problems.
Interfaces
 | Interface | Description
Public interface | IValidatable | IValidatable is an interface that declares that an object knows how to check itself for internal consistency errors, report the errors and possibly repair them.
Delegates
 | Delegate | Description
Public delegate | ProblemT, UReparationMechanism | This delegate represents a method which can enact a repair for this type of problem.
Public delegate | RepairChooser | RepairChooser is a delegate that decides, given a problem, if the problem should be repaired or not.


BaseProblem Class

An abstract class that defines a problem located in an object and a mechanism to repair it.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationBaseProblem
Atalasoft.Shared.ValidationProblemT, U

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract class BaseProblem
Public MustInherit Class BaseProblem

The BaseProblem type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseProblem | Initializes a new instance of the BaseProblem class.
Top
Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs.
Public property | Description | Gets or sets the description of the problem.
Public property | Name | Gets the name of the problem.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs the problem.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


BaseProblem Constructor

Initializes a new instance of the BaseProblem class.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseProblem(
    string name,
    string description,
    BaseRepairConsequences consequences
)
Protected Sub New (
    name As String,
    description As String,
    consequences As BaseRepairConsequences
)

Parameters

name
Type: SystemString
The name of the property or element that is causing the problem.
description
Type: SystemString
The description of the problem.
consequences
Type: Atalasoft.Shared.ValidationBaseRepairConsequences
The consequences of the repair.
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseProblem Properties

The BaseProblem type exposes the following members.

Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs.
Public property | Description | Gets or sets the description of the problem.
Public property | Name | Gets the name of the problem.
Top
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseProblem.Consequences Property

BaseProblemConsequences Property

Gets the consequences object that represents the impact, if any, of performing the repairs.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BaseRepairConsequences Consequences { get; }
Public ReadOnly Property Consequences As BaseRepairConsequences
    Get

Property Value

Type: BaseRepairConsequences
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseProblem.Description Property

BaseProblemDescription Property

Gets or sets the description of the problem.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description.
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseProblem.Name Property

BaseProblemName Property

Gets the name of the problem.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseProblem Methods

The BaseProblem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs the problem.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseProblem.Repair Method

BaseProblemRepair Method

Repairs the problem.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public abstract void Repair()
Public MustOverride Sub Repair
See Also

Reference

BaseProblem Class
Atalasoft.Shared.Validation Namespace


BaseRepairConsequences Class

This class represents the consequences of performing a particular repair. This class is never constructed directly and is instead defined by the package that requires validation as the meaning of repair consequences will vary based on the package's needs.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationBaseRepairConsequences
Atalasoft.PdfDoc.Generating.ValidationPdfRepairConsequences

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BaseRepairConsequences
Public Class BaseRepairConsequences

The BaseRepairConsequences type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseRepairConsequences | Initializes a new instance of the BaseRepairConsequences class.
Top
Properties
 | Name | Description
Public property | Description | Gets the description of the possible consequences of making the repair.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


BaseRepairConsequences Constructor

Initializes a new instance of the BaseRepairConsequences class.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BaseRepairConsequences(
    string description
)
Protected Sub New (
    description As String
)

Parameters

description
Type: SystemString
The description of the possible consequences of making the repair.
Remarks
The description must be non-null.
See Also

Reference

BaseRepairConsequences Class
Atalasoft.Shared.Validation Namespace


BaseRepairConsequences Properties

The BaseRepairConsequences type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the possible consequences of making the repair.
Top
See Also

Reference

BaseRepairConsequences Class
Atalasoft.Shared.Validation Namespace


BaseRepairConsequences.Description Property

BaseRepairConsequencesDescription Property

Gets the description of the possible consequences of making the repair.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

BaseRepairConsequences Class
Atalasoft.Shared.Validation Namespace


BaseRepairConsequences Methods

The BaseRepairConsequences type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseRepairConsequences Class
Atalasoft.Shared.Validation Namespace


BasicRepairContext(T) Class

BasicRepairContextT Class

A basic RepairContext object meant for holding one piece of content.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationRepairContext
Atalasoft.Shared.ValidationBasicRepairContextT
Atalasoft.PdfDoc.Generating.ValidationAnnotationRepairContext
Atalasoft.PdfDoc.Generating.ValidationDocumentRepairContext
Atalasoft.PdfDoc.Generating.ValidationPageRepairContext
Atalasoft.PdfDoc.Generating.ValidationPdfFormRepairContext

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class BasicRepairContext<T> : RepairContext

Public Class BasicRepairContext(Of T)
    Inherits RepairContext

Type Parameters

T
The type of content this context will repair.

The BasicRepairContextT type exposes the following members.

Constructors
 | Name | Description
Protected method | BasicRepairContextT | Initializes a new instance of the BasicRepairContextT class.
Top
Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Typically, client code will subclass this object and expose the specialized content in a public property.
See Also

Reference

Atalasoft.Shared.Validation Namespace


BasicRepairContext(T) Constructor

BasicRepairContextT Constructor

Initializes a new instance of the BasicRepairContextT class.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected BasicRepairContext(
    T content
)
Protected Sub New (
    content As T
)

Parameters

content
Type: T
The content for the repair context.
See Also

Reference

BasicRepairContextT Class
Atalasoft.Shared.Validation Namespace


BasicRepairContext(T) Properties

BasicRepairContextT Properties

The BasicRepairContextT generic type exposes the following members.

Properties
 | Name | Description
Protected property | Content | Gets the content of the repair context.
Top
See Also

Reference

BasicRepairContextT Class
Atalasoft.Shared.Validation Namespace


BasicRepairContext(T).Content Property

BasicRepairContextTContent Property

Gets the content of the repair context.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected T Content { get; }
Protected ReadOnly Property Content As T
    Get

Property Value

Type: T
See Also

Reference

BasicRepairContextT Class
Atalasoft.Shared.Validation Namespace


BasicRepairContext(T) Methods

BasicRepairContextT Methods

The BasicRepairContextT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicRepairContextT Class
Atalasoft.Shared.Validation Namespace


IValidatable Interface

IValidatable is an interface that declares that an object knows how to check itself for internal consistency errors, report the errors and possibly repair them.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public interface IValidatable
Public Interface IValidatable

The IValidatable type exposes the following members.

Methods
 | Name | Description
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


IValidatable Methods

The IValidatable type exposes the following members.

Methods
 | Name | Description
Public method | MakeRepairContext | Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.
Public method | Validate | Validates the object and accumulates any problems in the problems list.
Top
See Also

Reference

IValidatable Interface
Atalasoft.Shared.Validation Namespace


IValidatable.MakeRepairContext Method

IValidatableMakeRepairContext Method

Makes the repair context for repairing problems in this object. An object implementing IValidatable should at least return an empty RepairContext object.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
RepairContext MakeRepairContext(
    Object o
)
Function MakeRepairContext (
    o As Object
) As RepairContext

Parameters

o
Type: SystemObject
An object used to make the repair context.

Return Value

Type: RepairContext
A new repair context for repairing problems.
See Also

Reference

IValidatable Interface
Atalasoft.Shared.Validation Namespace


IValidatable.Validate Method

IValidatableValidate Method

Validates the object and accumulates any problems in the problems list.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
void Validate(
    ProblemList problems,
    RepairContext repairContext
)
Sub Validate (
    problems As ProblemList,
    repairContext As RepairContext
)

Parameters

problems
Type: Atalasoft.Shared.ValidationProblemList
The problems.
repairContext
Type: Atalasoft.Shared.ValidationRepairContext
The repair context.
See Also

Reference

IValidatable Interface
Atalasoft.Shared.Validation Namespace


Problem(T, U) Class

ProblemT, U Class

Defines a problem found in the internal state of an object.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationBaseProblem
Atalasoft.Shared.ValidationProblemT, U
Atalasoft.PdfDoc.Generating.AnnotationsAnnotationPropertyProblemT
Atalasoft.PdfDoc.Generating.FormsPdfFormPropertyProblem

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Problem<T, U> : BaseProblem
where U : RepairContext

Public Class Problem(Of T, U As RepairContext)
    Inherits BaseProblem

Type Parameters

T
This is the class of object which has generated a problem
U
This is a repair context used when repairs are made to the object

The ProblemT, U type exposes the following members.

Constructors
 | Name | Description
Public method | ProblemT, U | Initializes a new instance of the ProblemT, U class.
Top
Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs. (Inherited from BaseProblem.)
Public property | Description | Gets or sets the description of the problem. (Inherited from BaseProblem.)
Public property | Name | Gets the name of the problem. (Inherited from BaseProblem.)
Public property | Source | Gets the source of the problem.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs this problem. (Overrides BaseProblemRepair.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


Problem(T, U) Constructor

ProblemT, U Constructor

Initializes a new instance of the ProblemT, U class.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Problem(
    T source,
    string elementName,
    string description,
    BaseRepairConsequences consequences,
    U repairContext,
    ProblemT, UReparationMechanism reparation
)
Public Sub New (
    source As T,
    elementName As String,
    description As String,
    consequences As BaseRepairConsequences,
    repairContext As U,
    reparation As ProblemT, UReparationMechanism
)

Parameters

source
Type: T
The source of the problem. Required.
elementName
Type: SystemString
Name of the property causing the problem. Required.
description
Type: SystemString
The description of the problem. Required.
consequences
Type: Atalasoft.Shared.ValidationBaseRepairConsequences
The consequences of the repair. Required.
repairContext
Type: U
The repair context.
reparation
Type: Atalasoft.Shared.ValidationProblemT, UReparationMechanism
The reparation to fix the problem. Required.
See Also

Reference

ProblemT, U Class
Atalasoft.Shared.Validation Namespace


Problem(T, U) Properties

ProblemT, U Properties

The ProblemT, U generic type exposes the following members.

Properties
 | Name | Description
Public property | Consequences | Gets the consequences object that represents the impact, if any, of performing the repairs. (Inherited from BaseProblem.)
Public property | Description | Gets or sets the description of the problem. (Inherited from BaseProblem.)
Public property | Name | Gets the name of the problem. (Inherited from BaseProblem.)
Public property | Source | Gets the source of the problem.
Top
See Also

Reference

ProblemT, U Class
Atalasoft.Shared.Validation Namespace


Problem(T, U).Source Property

ProblemT, USource Property

Gets the source of the problem.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public T Source { get; }
Public ReadOnly Property Source As T
    Get

Property Value

Type: T
See Also

Reference

ProblemT, U Class
Atalasoft.Shared.Validation Namespace


Problem(T, U) Methods

ProblemT, U Methods

The ProblemT, U generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Repair | Repairs this problem. (Overrides BaseProblemRepair.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProblemT, U Class
Atalasoft.Shared.Validation Namespace


Problem(T, U).Repair Method

ProblemT, URepair Method

Repairs this problem.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override void Repair()
Public Overrides Sub Repair
See Also

Reference

ProblemT, U Class
Atalasoft.Shared.Validation Namespace


Problem(T, U).ReparationMechanism Delegate

ProblemT, UReparationMechanism Delegate

This delegate represents a method which can enact a repair for this type of problem.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void ReparationMechanism(
    Problem<T, U> problem,
    U repairContext
)
Public Delegate Sub ReparationMechanism (
    problem As Problem(Of T, U),
    repairContext As U
)

Parameters

problem
Type: Atalasoft.Shared.ValidationProblem T, U
The problem.
repairContext
Type: U
The repair context.
See Also

Reference

Atalasoft.Shared.Validation Namespace


ProblemEventArgs Class

Represents an event fired when a problem has been repaired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.Shared.ValidationProblemEventArgs

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProblemEventArgs : EventArgs
Public Class ProblemEventArgs
    Inherits EventArgs

The ProblemEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProblemEventArgs | Initializes a new instance of the ProblemEventArgs class.
Top
Properties
 | Name | Description
Public property | Problem | Gets the problem that was fixed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


ProblemEventArgs Constructor

Initializes a new instance of the ProblemEventArgs class.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProblemEventArgs(
    BaseProblem problem
)
Public Sub New (
    problem As BaseProblem
)

Parameters

problem
Type: Atalasoft.Shared.ValidationBaseProblem
The problem.
See Also

Reference

ProblemEventArgs Class
Atalasoft.Shared.Validation Namespace


ProblemEventArgs Properties

The ProblemEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Problem | Gets the problem that was fixed.
Top
See Also

Reference

ProblemEventArgs Class
Atalasoft.Shared.Validation Namespace


ProblemEventArgs.Problem Property

ProblemEventArgsProblem Property

Gets the problem that was fixed.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BaseProblem Problem { get; }
Public ReadOnly Property Problem As BaseProblem
    Get

Property Value

Type: BaseProblem
See Also

Reference

ProblemEventArgs Class
Atalasoft.Shared.Validation Namespace


ProblemEventArgs Methods

The ProblemEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProblemEventArgs Class
Atalasoft.Shared.Validation Namespace


ProblemList Class

A list of problems that need to be repaired.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListBaseProblem
Atalasoft.Shared.ValidationProblemList

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class ProblemList : List<BaseProblem>
Public Class ProblemList
    Inherits List(Of BaseProblem)

The ProblemList type exposes the following members.

Constructors
 | Name | Description
Public method | ProblemList | Initializes a new instance of the ProblemList class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListBaseProblem .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListBaseProblem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListBaseProblem .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListBaseProblem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListBaseProblem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListBaseProblem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListBaseProblem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseProblem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseProblem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListBaseProblem .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListBaseProblem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListBaseProblem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListBaseProblem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseProblem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseProblem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseProblem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseProblem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseProblem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseProblem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListBaseProblem .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListBaseProblem .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListBaseProblem .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseProblem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseProblem .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListBaseProblem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListBaseProblem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseProblem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseProblem .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProblemRepaired | Raises the [E:ProblemRepaired] event.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListBaseProblem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListBaseProblem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListBaseProblem .)
Public method | Repair | Repairs all the BaseProblem objects in the list that are authorized by the RepairChooser.
Public method | RepairAll | Repairs all the problems in the list, blindly accepting the consequences of repairing them.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListBaseProblem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListBaseProblem .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListBaseProblem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListBaseProblem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListBaseProblem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListBaseProblem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListBaseProblem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListBaseProblem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Top
Events
 | Name | Description
Public event | ProblemRepaired | Occurs when a BaseProblem has been repaired.
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


ProblemList Constructor

Initializes a new instance of the ProblemList class

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ProblemList()
Public Sub New
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList Properties

The ProblemList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListBaseProblem .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListBaseProblem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListBaseProblem .)
Top
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList Methods

The ProblemList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListBaseProblem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListBaseProblem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListBaseProblem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListBaseProblem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseProblem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListBaseProblem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListBaseProblem .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListBaseProblem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListBaseProblem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListBaseProblem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseProblem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListBaseProblem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseProblem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseProblem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseProblem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseProblem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListBaseProblem .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListBaseProblem .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListBaseProblem .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListBaseProblem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListBaseProblem .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListBaseProblem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListBaseProblem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListBaseProblem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListBaseProblem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListBaseProblem .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProblemRepaired | Raises the [E:ProblemRepaired] event.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListBaseProblem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListBaseProblem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListBaseProblem .)
Public method | Repair | Repairs all the BaseProblem objects in the list that are authorized by the RepairChooser.
Public method | RepairAll | Repairs all the problems in the list, blindly accepting the consequences of repairing them.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListBaseProblem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListBaseProblem .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListBaseProblem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListBaseProblem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListBaseProblem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListBaseProblem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListBaseProblem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListBaseProblem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListBaseProblem .)
Top
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList.OnProblemRepaired Method

ProblemListOnProblemRepaired Method

Raises the [E:ProblemRepaired] event.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected virtual void OnProblemRepaired(
    ProblemEventArgs e
)
Protected Overridable Sub OnProblemRepaired (
    e As ProblemEventArgs
)

Parameters

e
Type: Atalasoft.Shared.ValidationProblemEventArgs
The [!:Atalasoft.PdfDoc.Generating.Validation.ProblemEventArgs] instance containing the event data.
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList.Repair Method

ProblemListRepair Method

Repairs all the BaseProblem objects in the list that are authorized by the RepairChooser.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Repair(
    RepairChooser chooser
)
Public Sub Repair (
    chooser As RepairChooser
)

Parameters

chooser
Type: Atalasoft.Shared.ValidationRepairChooser
The chooser.
Remarks
The RepairChooser will be called for each item in turn. If the RepairChooser returns true, it will invoke the item's Repair method and then fire the ProblemRepaired event. After processing each item, the repaired items will be removed from the list.
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList.RepairAll Method

ProblemListRepairAll Method

Repairs all the problems in the list, blindly accepting the consequences of repairing them.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RepairAll()
Public Sub RepairAll
Remarks
Since the repair mechanisms may cause the loss of information, this method is not recommended.
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList Events

The ProblemList type exposes the following members.

Events
 | Name | Description
Public event | ProblemRepaired | Occurs when a BaseProblem has been repaired.
Top
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


ProblemList.ProblemRepaired Event

ProblemListProblemRepaired Event

Occurs when a BaseProblem has been repaired.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler<ProblemEventArgs> ProblemRepaired
Public Event ProblemRepaired As EventHandler(Of ProblemEventArgs)

Value

Type: SystemEventHandlerProblemEventArgs
See Also

Reference

ProblemList Class
Atalasoft.Shared.Validation Namespace


RepairChooser Delegate

RepairChooser is a delegate that decides, given a problem, if the problem should be repaired or not.

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate bool RepairChooser(
    BaseProblem p
)
Public Delegate Function RepairChooser (
    p As BaseProblem
) As Boolean

Parameters

p
Type: Atalasoft.Shared.ValidationBaseProblem
The problem to be repaired.

Return Value

Type: Boolean
The delegate returns true if the problem should be repaired; otherwise false.
See Also

Reference

Atalasoft.Shared.Validation Namespace


RepairContext Class

A base context for repairing problems.
Inheritance Hierarchy
SystemObject
Atalasoft.Shared.ValidationRepairContext
Atalasoft.Shared.ValidationBasicRepairContextT

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class RepairContext
Public Class RepairContext

The RepairContext type exposes the following members.

Constructors
 | Name | Description
Public method | RepairContext | Initializes a new instance of the RepairContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Shared.Validation Namespace


RepairContext Constructor

Initializes a new instance of the RepairContext class

Namespace: Atalasoft.Shared.Validation
Assembly: Atalasoft.Shared (in Atalasoft.Shared.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RepairContext()
Public Sub New
See Also

Reference

RepairContext Class
Atalasoft.Shared.Validation Namespace


RepairContext Methods

The RepairContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RepairContext Class
Atalasoft.Shared.Validation Namespace


Atalasoft.Twain Namespace

Classes
 | Class | Description
Public class | AcquireEventArgs | Contains information about the image just acquired.
 | Acquisition | This is the main class for image acquisitions. Use this class by itself for standard acquires, or use it to get a Device object for more control over the acquire operation. For low level access to Twain, use the TwainController object.
 | AsynchronousExceptionEventArgs | This class is passed to an AsynchronousExceptionEventHandler when there is an exception during an asynchronous acquisition.
 | Device | Contains information about a single device and handles the acquisition of images from that device.
Public class | DeviceCollection | Contains a collection of all Device objects on the system.
Public class | DeviceEventArgs | Contains information about a device event.
Public class | DocumentFeeder | Gives control over the document feeder used by a scanner.
Public class | FileInformation | Contains information about a specific file in the FileSystem.
Public class | FileSystem | Contains methods which can navigate the file system of a camera.
Public class | FileTransferEventArgs | Contains information about the file transfer used in the FileTransfer event.
Public class | FormDataCollection | The FormDataCollection is used with the HttpPost class to send form information to a web server.
 | HttpPost | This class allows can post image data to a server without user interaction.
Public class | InvalidStateException | This exception is fired when an action, such as setting a property, has been taken before the device is in the proper state.
Public class | MemoryDataTransferEventArgs | This class is used with the MemoryDataTransfer event of the TwainController.
Public class | MemoryFileTransferEventArgs | This class contains information for a memory file transfer.
Public class | TwainBarCode | This class provides access to barcode and patchcode specific methods.
 | TwainCapability | This class is used with SendCommand to get or set device capabilities.
Public class | TwainController | The TwainController class allows for lower level access to Twain, providing greater control over the acquisition and access to custom device properties.
Public class | TwainCustomData | This class is used with SendCommand to query the device for its current settings or to restore previously saved settings.
Public class | TwainDataImageInfoEventArgs | This class is passed to the BeforeTwainDataTransfer event to supply general information about the image about to be acquired.
Public class | TwainDataTransferEventArgs | This class is used with the TwainDataTransfer event to allow the acquired data to be handled by the developer instead of by DotTwain.
Public class | TwainDeviceCallbackEventArgs | This class is used with the TwainDeviceCallbackEventHandler and provides information passed from the device to the application.
 | TwainDeviceEvent | This class is used with SendCommand to obtain information about a device event when the TwainEventMessage retrieved from ProcessEvent(Message, TwainEventMessage) is MSG_DEVICEEVENT.
Public class | TwainEvent | This class is used with SendCommand to process Windows messages during an acquisition.
Public class | TwainException | This is a general exception due to an error while using DotTwain.
Public class | TwainExtendedImageInformation | This class is used with SendCommand to get extended image information from the device.
Public class | TwainFileSystem | This class is used with SendCommand to control the file system of a Twain compatible camera.
Public class | TwainHandle | This class is used with SendCommand to pass a handle to Twain.
Public class | TwainIdentity | This class is used to identify your application to Twain and to provide information about each Twain compatible device found on the system.
Public class | TwainImageInfo | This class is used with SendCommand to get information about the image about to be scanned or the one that was just acquired.
Public class | TwainImageLayout | This class is used with the SendCommand method to get or set image layout data.
Public class | TwainManager | The TwainManager class is used to control which version of TWAIN is used by DotTwain. TWAIN 2.x (twaindsm.dll) will be used by default if it exists on the system, otherwise TWAIN version 1.x (twain_32.dll) is used. Some drivers will not work with TWAIN 2.x, such as WIA drivers. To use these drivers you can force DotTwain to use version 1.x by setting the ForceTwain1xBehavior property to true before creating an instance of Acquisition or TwainController.
 | TwainMemory | This class represents a memory object passed into TWAIN or returned from TWAIN.
 | TwainResolution | Describes the horizontal and vertical resolution.
Public class | TwainUserInterface | This class is used with the SendCommand method to display or hide the driver interface.
Public class | UnsupportedCapabilityException | This exception is caused when trying to use features of Twain which are unsupported by the device. For instance, if you try to perform an acquire directly to file and the device does not support this feature, an UnsupportedCapabilityException will be generated.
Interfaces
Interface | Description
ITwainDataStructure | This interface is used for data classes sent to the SendCommand(TwainTriplet, TwainIdentity, ITwainDataStructure) method.
Delegates
 | Delegate | Description
Public delegate | AsynchronousExceptionEventHandler | This event handler is used to notify the application of any exceptions during an asynchronous acquisition.
Public delegate | BeforeTwainDataTransferEventHandler | This event handler is used to provide information about the data that is about to be scanned.
Public delegate | DeviceEventHandler | This event handler is used to pass the DeviceEventFlagss to the application.
Public delegate | FileTransferEventHandler | This event handler is used when acquiring images directly to a file.
Public delegate | ImageAcquiredEventHandler | This event handler is used to notify the application when an image has been acquired.
Public delegate | MemoryDataTransferEventHandler | This event handler is used in the TwainController to capture a memory transfer as data is being sent from the driver.
Public delegate | MemoryFileTransferEventHandler | This event handler is used in the TwainController and Acquisition objects to request a file format and Stream for saving the scanned image.
Public delegate | TwainDataTransferEventHandler | This event handler is used to allow the data retrieved from the device to be handled by the developer instead of by DotTwain.
Public delegate | TwainDeviceCallbackEventHandler | This delegate is used with the RegisterTwainCallback(TwainDeviceCallbackEventHandler) method to allow the use of a callback instead of a message loop for device communication. This feature is only available when using TWAIN 2.0 or higher.
Enumerations
 | Enumeration | Description
Public enumeration | AlarmTypeFlags | The type of alarm used for the Alarms property of the Device.
Public enumeration | AutoDiscardMode | Used with AutoDiscardBlankPages to enable or disable this feature in the driver.
Public enumeration | BarCodeSearchMode | Specifies the search mode for barcode recognition.
Public enumeration | BarCodeType | Specifies the bar code type priority for the SetSearchPriorities(BarCodeType) method.
Public enumeration | BatchJobControl | Used to set the batch mode of the device.
Public enumeration | BitDepthReductionMode | The bit depth reduction mode for the Source.
Public enumeration | ClearBufferMode | These values are used to determine how the device will clear its internal buffer.
Public enumeration | ColorFilterFlags | The filter values for the ColorFilter device property.
Public enumeration | CompressionMode | Compression modes used during file and memory transfers.
Public enumeration | CountryCode | A list of country codes used by Twain devices.
Public enumeration | DeviceCapability | The device capabilities which can be tested with the QueryCapability(DeviceCapability, Boolean) method. This enumeration is also used with the low level TwainController.
Public enumeration | DeviceEventFlags | A set of bit flags used to indicate which device events you want to receive.
Public enumeration | DocumentFeederAlignment | Used to determine the alignment of the paper in a document feeder.
Public enumeration | DocumentFeederOrder | Used to set the page order of the document feeder.
Public enumeration | DuplexMode | The duplex mode supported by the device.
Public enumeration | FileItemType | Indicates the type of file or device camera position.
Public enumeration | FlashMode | Specifies the type of flash, if any, was used by the device.
Public enumeration | FlipRotationMode | Specifies the type of flip rotation the Source will perform.
Public enumeration | ImageFilterMode | A list of filter the source can apply to the image.
Public enumeration | ImagePixelType | Used to determine the type of image being transferred.
Public enumeration | ImprinterEndorserMode | Used with SetImprinterEndorser to specify the type of string to use.
Public enumeration | ImprinterEndorserType | Bit flags used to indicate which printers for imprinting or endorsing are available.
Public enumeration | LanguageType | Languages used by the source device.
Public enumeration | LightPathMode | Specifies the type of light path used.
Public enumeration | LightSourceMode | Specifies the light characteristics used for the acquisition.
Public enumeration | NoiseFilterMode | Specifies the noise filter to use for the acquisition.
Public enumeration | OrientationMode | Used to set the orientation of the image.
Public enumeration | OverscanMode | Specifies the type of Overscan used by the device.
Public enumeration | PatchCodeType | Specifies the type of patchcode to work with.
Public enumeration | PowerSupplyMode | Specifies the type of power supply being used by the device.
Public enumeration | QueryOperation | Specifies the type of operation that can be performed on a specific capability.
Public enumeration | SourceImageFormat | Specifies the type of image format to use when saving directly from the source device.
Public enumeration | StaticFrameSizeType | An enumeration of standard frame sizes used by FrameSize.
Public enumeration | TwainAutoSize | Specifies the type of auto sizing to perform.
Public enumeration | TwainCameraSide | Specifies which camera to enable or disable in the EnableCamera(TwainCameraSide, Boolean) method.
Public enumeration | TwainConditionCode | These codes are returned from the GetConditionCode method in the Device and TwainController classes.
Public enumeration | TwainContainer | Specifies the type of container used for capabilities in the TwainCapability class.
Public enumeration | TwainDataGroupFlags | Indicates the control groups supported by the device. The TwainIdentity class provides this information about the device.
Public enumeration | TwainEventMessage | These messages are passed to the WndProc during acquisition to indicate events from the device.
Public enumeration | TwainExtendedImageInfoID | Used to specify which extended parameters are requested from the driver.
Public enumeration | TwainFeederPocket | Specifies feeder pockets available for page ouput.
Public enumeration | TwainFeederType | Specifies the feeder type to use with the specified parameters.
Public enumeration | TwainIccProfileOption | Specifies the type of ICC profile support to use.
Public enumeration | TwainItemType | Specifies the item type used for item data in TWAIN.
Public enumeration | TwainPixelFlavor | Determines whether Black or White is represented by the value zero.
Public enumeration | TwainReturnCode | These values are returned from Twain and the device. The LastReturnCode property of the Device object provides this value as do the methods in the TwainController class.
Public enumeration | TwainState | Indicates the current Twain state. This value can be retrieved from the State property of the Device and TwainController classes.
Public enumeration | TwainTransferMethod | Specifies the transfer method used. This can be set with the TransferMethod property of the Device object.
Public enumeration | TwainTriplet | Specifies the Twain operation to perform in the SendCommand method of TwainController. See the Twain specification for more information about these operations.
Public enumeration | UnitType | Used to set the units of measure for the acquire.


AcquireEventArgs Class

Contains information about the image just acquired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.TwainAcquireEventArgs

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AcquireEventArgs : EventArgs
Public Class AcquireEventArgs
    Inherits EventArgs

The AcquireEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CancelPending | Gets or sets a value which determines if the pending images will be acquired.
Public property | EndOfJob | Gets a value indicating whether this is the last image in a batch job.
Public property | ExtendedImageInfo | Gets a Hashtable containing extended image information retrieved from the device for this acquisition.
 | FileName | Gets the filename of the image when acquired to file.
 | Image | Gets the Bitmap image acquired.
Public property | OutputStream | Gets the Stream where image data was saved from a TWSX_MEMORY or TWSX_MEMFILE transfer.
Public property | PendingImages | Gets the number of images waiting to be acquired.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Twain Namespace


AcquireEventArgs Properties

The AcquireEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CancelPending | Gets or sets a value which determines if the pending images will be acquired.
Public property | EndOfJob | Gets a value indicating whether this is the last image in a batch job.
Public property | ExtendedImageInfo | Gets a Hashtable containing extended image information retrieved from the device for this acquisition.
 | FileName | Gets the filename of the image when acquired to file.
 | Image | Gets the Bitmap image acquired.
Public property | OutputStream | Gets the Stream where image data was saved from a TWSX_MEMORY or TWSX_MEMFILE transfer.
Public property | PendingImages | Gets the number of images waiting to be acquired.
Top
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs.CancelPending Property

AcquireEventArgsCancelPending Property

Gets or sets a value which determines if the pending images will be acquired.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CancelPending { get; set; }
Public Property CancelPending As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the rest of the images waiting to be acquired should be canceled.
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs.EndOfJob Property

AcquireEventArgsEndOfJob Property

Gets a value indicating whether this is the last image in a batch job.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EndOfJob { get; }
Public ReadOnly Property EndOfJob As Boolean
    Get

Property Value

Type: Boolean
True if this is the last image in a batch job.
Remarks
Batch jobs are negotiated using the JobControl property of the Device class.
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace
DeviceGetSupportedJobControls
DeviceJobControl


AcquireEventArgs.ExtendedImageInfo Property

AcquireEventArgsExtendedImageInfo Property

Gets a Hashtable containing extended image information retrieved from the device for this acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Hashtable ExtendedImageInfo { get; }
Public ReadOnly Property ExtendedImageInfo As Hashtable
    Get

Property Value

Type: Hashtable
A Hashtable containing the extended information. The table keys are the TwainExtendedImageInfoID values set with SetExtendedImageInfoOptions(TwainExtendedImageInfoID) method. If no items were retrieved this property will return null (Nothing in VB).
Remarks
This is an advanced feature and requires some knowledge of the Twain specification. The object values in the Hashtable may be a single value or an array of values if multiple items for a TwainExtendedImageInfoID is available for the page.
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs.FileName Property

AcquireEventArgsFileName Property

Gets the filename of the image when acquired to file.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The filename of the acquired image.
Examples
AcquireEventArgs Class
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs.Image Property

AcquireEventArgsImage Property

Gets the Bitmap image acquired.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get

Property Value

Type: Bitmap
The acquired image.
Remarks
It is the responsibility of the application to free this image when it's no longer needed.
Examples
AcquireEventArgs Class
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs.OutputStream Property

AcquireEventArgsOutputStream Property

Gets the Stream where image data was saved from a TWSX_MEMORY or TWSX_MEMFILE transfer.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Stream OutputStream { get; }
Public ReadOnly Property OutputStream As Stream
    Get

Property Value

Type: Stream
The Stream provided by the application to save the image data into.
Remarks
To provide a stream for saving the image data, handle the MemoryDataTransfer or MemoryFileTransfer event (depending on which transfer method is used).
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs.PendingImages Property

AcquireEventArgsPendingImages Property

Gets the number of images waiting to be acquired.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int PendingImages { get; }
Public ReadOnly Property PendingImages As Integer
    Get

Property Value

Type: Int32
Number of images waiting to be acquired. If this value is -1, there are more images to be acquired but the device does not know how many.
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


AcquireEventArgs Methods

The AcquireEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AcquireEventArgs Class
Atalasoft.Twain Namespace


Acquisition Class

This is the main class for image acquisitions. Use this class by itself for standard acquires, or use it to get a Device object for more control over the acquire operation. For low level access to Twain, use the TwainController object.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Atalasoft.TwainAcquisition

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class Acquisition : Component
Public Class Acquisition
    Inherits Component

The Acquisition type exposes the following members.

Constructors
 | Name | Description
Public method | Acquisition | Creates a new instance of Acquisition.
Public method | Acquisition(IWin32Window) | Creates an instance of Acquisition specifying the parent window.
Top
Properties
 | Name | Description
Public property | ApplicationIdentity | Gets the TwainIdentity object containing application information that is sent to Twain.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Devices | Gets a collection of installed Device for this system.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a value indicating whether this class has been disposed.
Public property | Parent | Gets or sets the parent window for the acquisition.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SystemHasTwain | Gets a value indicating if the system has twain_32.dll installed.
Top
Methods
 | Name | Description
 | Acquire | Acquires an image from the system default device.
 | AcquireModal | Obsolete. Acquires a single image synchronously instead of using the ImageAcquired event.
Public method | CreateDeviceSession | Returns a new Device class that uses its own TwainController instead of the controller used by the Acquisition object for a single session scan. This may be required for some remote systems such as Citrix.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Closes any TWAIN connections and releases resources back to the system. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Calls Dispose(). (Overrides ComponentFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | ShowSelectSource | Displays the "Select Source" dialog, allowing end users to select the device they want to use.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Events
 | Name | Description
 | AcquireCanceled | This event will fire if the user has canceled the acquisition.
 | AcquireFinished | This event will fire when all of the images have been acquired. This is useful when a document feeder is used.
 | AsynchronousException | This event is raised when an exception is thrown during an asynchronous acquisition.
 | BeforeTwainDataTransfer | This event will fire before the data is transferred from the device, allow the transfer to be canceled.
 | DeviceEvent | This event will fire when the device sends one of the DeviceEventFlags.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
 | FileTransfer | This event will fire just before acquiring an image directly to file. You must fill in the FileName property of the FileTransferEventArgs object.
 | ImageAcquired | This event will fire for each image acquired.
Public event | MemoryDataTransfer | Raised during a memory transfer to allow custom handling of the image data.
Public event | MemoryFileTransfer | Raised during a file transfer to allow custom handling of the image data.
 | TwainDataTransfer | This event fires after the data has been transferred but before it has been processed by DotTwain.
Top
Remarks

Acquisition is also a component which can be added to the Visual Studio .NET toolbox. This enables properties and events to be established at design time.

Examples
Acquire an image (C#)
Copy
// Create an instance of Acquisition and set the ImageAcquired event.
Acquisition acquisition = new Acquisition(this);
acquisition.ImageAcquired += new ImageAcquiredEventHandler(OnImageAcquired);

private void AcquireImage()
{
    // Acquire an image.
    acquisition.Acquire();
}

private void OnImageAcquired(object sender, AcquireEventArgs e)
{
    // Make sure the acquire was successful.
    // If so, load it into a PictureBox.
    if (e.Image != null)
        this.picture1.Image = e.Image;
}
Acquire an image (Visual Basic)
Copy
' Create an instance of Acquisition and set the ImageAcquired event.
Dim acquisition As Acquisition =  New Acquisition(Me)
acquisition.ImageAcquired += New ImageAcquiredEventHandler(OnImageAcquired)

Private  Sub AcquireImage()
    ' Acquire an image.
    acquisition.Acquire()
End Sub

Private  Sub OnImageAcquired(ByVal sender As Object, ByVal e As AcquireEventArgs)
    ' Make sure the acquire was successful.
    ' If so, load it into a PictureBox.
    If Not e.Image Is Nothing Then
        Me.picture1.Image = e.Image
    End If
End Sub
See Also

Reference

Atalasoft.Twain Namespace


Acquisition Constructor

These constructors create an instance of the Acquisition object.
Overload List
 | Name | Description
Public method | Acquisition | Creates a new instance of Acquisition.
Public method | Acquisition(IWin32Window) | Creates an instance of Acquisition specifying the parent window.
Top
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition Constructor

Creates a new instance of Acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Acquisition()
Public Sub New
Remarks
You must set the Parent property of the Acquisition object before you can use any of the methods or properties.
See Also

Reference

Acquisition Class
Acquisition Overload
Atalasoft.Twain Namespace
AcquisitionParent


Acquisition Constructor (IWin32Window)

Creates an instance of Acquisition specifying the parent window.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Acquisition(
    IWin32Window parent
)
Public Sub New (
    parent As IWin32Window
)

Parameters

parent
Type: System.Windows.FormsIWin32Window
The window that will act as the parent. The parent must derive from System.Windows.Forms.Control for background threading during a scan.
Exceptions
Exception | Condition
 | This will be thrown if the parent parameter is null.
Remarks
Twain uses the parent's message loop to pass instructions from the device to DotTwain. If a parent window is not provided, DotTwain will create a hidden window for Twain to use. Be aware that some devices will fail if the parent window is hidden, so whenever possible it's best to provide a visible parent window.
See Also

Reference

Acquisition Class
Acquisition Overload
Atalasoft.Twain Namespace


Acquisition Properties

The Acquisition type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationIdentity | Gets the TwainIdentity object containing application information that is sent to Twain.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Devices | Gets a collection of installed Device for this system.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a value indicating whether this class has been disposed.
Public property | Parent | Gets or sets the parent window for the acquisition.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SystemHasTwain | Gets a value indicating if the system has twain_32.dll installed.
Top
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.ApplicationIdentity Property

AcquisitionApplicationIdentity Property

Gets the TwainIdentity object containing application information that is sent to Twain.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public TwainIdentity ApplicationIdentity { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Property ApplicationIdentity As TwainIdentity
    Get
    Set

Property Value

Type: TwainIdentity
A TwainIdentity object for application information.
Remarks
This information should only be set or modified before or after a Twain session.
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.Devices Property

AcquisitionDevices Property

Gets a collection of installed Device for this system.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeviceCollection Devices { get; }
Public ReadOnly Property Devices As DeviceCollection
    Get

Property Value

Type: DeviceCollection
A DeviceCollection object containing Twain compatible devices found on the system.
Remarks
It's possible a device may be listed even when it's not connected.
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace
Atalasoft.TwainDevice


Acquisition.IsDisposed Property

AcquisitionIsDisposed Property

Gets a value indicating whether this class has been disposed.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether this class has been disposed.
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.Parent Property

AcquisitionParent Property

Gets or sets the parent window for the acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public IWin32Window Parent { get; set; }
Public Property Parent As IWin32Window
    Get
    Set

Property Value

Type: IWin32Window
The parent window used for the acquisition. The parent must derive from System.Windows.Forms.Control for background threading during a scan.
Remarks

If a parent window is not provided, DotTwain will create a hidden window to act as the parent.

Because some drivers do not function properly with hidden windows, this property should be set to a visible window whenever possible.

See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.SystemHasTwain Property

AcquisitionSystemHasTwain Property

Gets a value indicating if the system has twain_32.dll installed.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SystemHasTwain { get; }
Public ReadOnly Property SystemHasTwain As Boolean
    Get

Property Value

Type: Boolean
True if the system has the twain_32.dll.
Remarks
The Twain library has been installed with Windows since Windows 98, so it's rare that a system will not have it installed. Any scanning features in your application should be disabled if this property returns false.
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition Methods

The Acquisition type exposes the following members.

Methods
 | Name | Description
 | Acquire | Acquires an image from the system default device.
 | AcquireModal | Obsolete. Acquires a single image synchronously instead of using the ImageAcquired event.
Public method | CreateDeviceSession | Returns a new Device class that uses its own TwainController instead of the controller used by the Acquisition object for a single session scan. This may be required for some remote systems such as Citrix.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Closes any TWAIN connections and releases resources back to the system. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Calls Dispose(). (Overrides ComponentFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | ShowSelectSource | Displays the "Select Source" dialog, allowing end users to select the device they want to use.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.Acquire Method

AcquisitionAcquire Method

Acquires an image from the system default device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Acquire()
Public Sub Acquire
Remarks
The ImageAcquired event must be handled as it is raised for each image that is acquired.
Examples
Acquisition Class
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.AcquireModal Method

AcquisitionAcquireModal Method

Note: This API is now obsolete.

Acquires a single image synchronously instead of using the ImageAcquired event.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("This overload of Acquire is obsolete.", true)]
public Bitmap AcquireModal(
    bool hideInterface
)
<ObsoleteAttribute("This overload of Acquire is obsolete.", true)>
Public Function AcquireModal (
    hideInterface As Boolean
) As Bitmap

Parameters

hideInterface
Type: SystemBoolean
Determines if the driver interface is displayed.

Return Value

Type: Bitmap
The acquired image.
Remarks

This is useful if you want a quick and easy acquire of a single image.

The ImageAcquired and AcquireFinished events do not fire when using this method.

Examples
Modal Acquisition (C#)
Copy
// Create an instance of Acquisition.
Acquisition acquisition = new Acquisition();

// Acquire the image, but do not show the scanner interface.
Bitmap bmp = acquisition.AcquireModal(true, false);

// Free the Acquisition object.
acquisition.Dispose();
Modal Acquisition (Visual Basic)
Copy
' Create an instance of Acquisition.
Dim acquisition As Acquisition =  New Acquisition()

' Acquire the image, but don't show the scanner interface.
Dim bmp As Bitmap =  acquisition.AcquireModal(True,False)

' Free the Acquisition object.
acquisition.Dispose()
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.CreateDeviceSession Method

AcquisitionCreateDeviceSession Method

Returns a new Device class that uses its own TwainController instead of the controller used by the Acquisition object for a single session scan. This may be required for some remote systems such as Citrix.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Device CreateDeviceSession(
    string productName
)
Public Function CreateDeviceSession (
    productName As String
) As Device

Parameters

productName
Type: SystemString
The product name of the scanner to connect to

Return Value

Type: Device
A new Device object. You must Dispose this object when you are done with it.
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.Dispose Method

AcquisitionDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Closes any TWAIN connections and releases resources back to the system. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.Dispose Method (Boolean)

AcquisitionDispose Method (Boolean)

Closes any TWAIN connections and releases resources back to the system.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Dispose(
    bool isDisposing
)
Protected Overrides Sub Dispose (
    isDisposing As Boolean
)

Parameters

isDisposing
Type: SystemBoolean
Indicates whether this method was called from Dispose or the Finalizer.
Remarks
When you are finished using the Acquisition object, you can call this method to make sure all of the connections and resources have been closed and freed.
See Also

Reference

Acquisition Class
Dispose Overload
Atalasoft.Twain Namespace


Acquisition.Finalize Method

AcquisitionFinalize Method

Calls Dispose().

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.ShowSelectSource Method

AcquisitionShowSelectSource Method

Displays the "Select Source" dialog, allowing end users to select the device they want to use.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Device ShowSelectSource()
Public Function ShowSelectSource As Device

Return Value

Type: Device
The device selected by the user.
Exceptions
Exception | Condition
 | Thrown if twain does not exist on the system.
 | Thrown is there is a Twain error during this process.
Remarks
If the user presses the "Cancel" button, this will return the current system default device. If no devices are listed in the dialog, this will return null (Nothing in VB).
Examples
ShowSelectCS (C#)
Copy
this.device = this.acquisition.ShowSelectSource();
if (this.device == null)
{
    MessageBox.Show(this, "No Twain devices were found on your system.");
    return;
}
ShowSelectVB (Visual Basic)
Copy
Me.device = Me.acquisition.ShowSelectSource()
If Me.device Is Nothing Then
    MessageBox.Show(Me, "No Twain devices were found on your system.")
    Return
End If
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition Events

The Acquisition type exposes the following members.

Events
 | Name | Description
 | AcquireCanceled | This event will fire if the user has canceled the acquisition.
 | AcquireFinished | This event will fire when all of the images have been acquired. This is useful when a document feeder is used.
 | AsynchronousException | This event is raised when an exception is thrown during an asynchronous acquisition.
 | BeforeTwainDataTransfer | This event will fire before the data is transferred from the device, allow the transfer to be canceled.
 | DeviceEvent | This event will fire when the device sends one of the DeviceEventFlags.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
 | FileTransfer | This event will fire just before acquiring an image directly to file. You must fill in the FileName property of the FileTransferEventArgs object.
 | ImageAcquired | This event will fire for each image acquired.
Public event | MemoryDataTransfer | Raised during a memory transfer to allow custom handling of the image data.
Public event | MemoryFileTransfer | Raised during a file transfer to allow custom handling of the image data.
 | TwainDataTransfer | This event fires after the data has been transferred but before it has been processed by DotTwain.
Top
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.AcquireCanceled Event

AcquisitionAcquireCanceled Event

This event will fire if the user has canceled the acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AcquireCanceled
Public Event AcquireCanceled As EventHandler

Value

Type: SystemEventHandler
Examples
AcquireCanceledCS (C#)
Copy
private void acquisition_AcquireCanceled(object sender, System.EventArgs e)
{
    this.device.Close();
    MessageBox.Show(this, "Acquisition was canceled.");
}
AcquireCanceledVB (Visual Basic)
Copy
Private  Sub acquisition_AcquireCanceled(ByVal sender As Object, ByVal e As System.EventArgs)
    Me.device.Close()
    MessageBox.Show(Me, "Acquisition was canceled.")
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.AcquireFinished Event

AcquisitionAcquireFinished Event

This event will fire when all of the images have been acquired. This is useful when a document feeder is used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event EventHandler AcquireFinished
Public Event AcquireFinished As EventHandler

Value

Type: SystemEventHandler
Examples
AcquireFinishedCS (C#)
Copy
private void acquisition_AcquireFinished(object sender, System.EventArgs e)
{
    // This is the only event where you should call the Close method.
    // AcquireFinished fires after all images have been acquired.
    // Note that you can call Close anytime if you need to cancel
    // any pending transfers and do a quick shutdown of your application.
    this.device.Close();
}
AcquireFinishedVB (Visual Basic)
Copy
Private  Sub acquisition_AcquireFinished(ByVal sender As Object, ByVal e As System.EventArgs)
    ' This is the only event where you should call the Close method.
    ' AcquireFinished fires after all images have been acquired.
    ' Note that you can call Close anytime if you need to cancel
    ' any pending transfers and do a quick shutdown of your application.
    Me.device.Close()
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.AsynchronousException Event

AcquisitionAsynchronousException Event

This event is raised when an exception is thrown during an asynchronous acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event AsynchronousExceptionEventHandler AsynchronousException
Public Event AsynchronousException As AsynchronousExceptionEventHandler

Value

Type: Atalasoft.TwainAsynchronousExceptionEventHandler
Examples
AsynchronousExceptionCS (C#)
Copy
private void acquisition_AsynchronousException(object sender, Atalasoft.Twain.AsynchronousExceptionEventArgs e)
{
    ' Let the user know something happened.
    MessageBox.Show(this, e.Exception.Message, "Asynchronous Exception");
}
AsynchronousExceptionVB (Visual Basic)
Copy
Private  Sub acquisition_AsynchronousException(ByVal sender As Object, ByVal e As Atalasoft.Twain.AsynchronousExceptionEventArgs)
    ' Let the user know something happened.
    MessageBox.Show(this, e.Exception.Message, "Asynchronous Exception")
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace
Atalasoft.TwainAsynchronousExceptionEventHandler


Acquisition.BeforeTwainDataTransfer Event

AcquisitionBeforeTwainDataTransfer Event

This event will fire before the data is transferred from the device, allow the transfer to be canceled.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event BeforeTwainDataTransferEventHandler BeforeTwainDataTransfer
Public Event BeforeTwainDataTransfer As BeforeTwainDataTransferEventHandler

Value

Type: Atalasoft.TwainBeforeTwainDataTransferEventHandler
Remarks
The image information may not be exactly what the resulting image will be, since a device doesn't know for sure until it has performed the scan.
Examples
BeforeTwainDataTransferCS (C#)
Copy
private void acquisition_BeforeTwainDataTransfer(object sender, TwainDataImageInfoArgs e)
{
    // Only scan 1-bit images.
    if (e.ImageInfo.PixelType != ImagePixelType.BlackAndWhite)
        e.Cancel = true;
}
BeforeTwainDataTransferVB (Visual Basic)
Copy
Private  Sub acquisition_BeforeTwainDataTransfer(ByVal sender As Object, ByVal e As TwainDataImageInfoArgs)
    ' Only scan 1-bit images.
    If e.ImageInfo.PixelType <> ImagePixelType.BlackAndWhite Then
        e.Cancel = True
    End If
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.DeviceEvent Event

AcquisitionDeviceEvent Event

This event will fire when the device sends one of the DeviceEventFlags.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event DeviceEventHandler DeviceEvent
Public Event DeviceEvent As DeviceEventHandler

Value

Type: Atalasoft.TwainDeviceEventHandler
Remarks
You have to setup which events you want to receive, if any, by setting the DeviceEvents property of a Device object.
Examples
DeviceEventCS (C#)
Copy
private void acquisition_DeviceEvent(object sender, Atalasoft.Twain.DeviceEventArgs e)
{
    // One of the many device events has fired.
    // You will only receive the events you have set using
    // the Device.DeviceEvents property.
    if (e.Event == DeviceEventFlags.PaperJam)
        MessageBox.Show(this, "Paper jam!!!");
    else
        MessageBox.Show(this, "Device Event:  " + e.Event.ToString());
}
DeviceEventVB (Visual Basic)
Copy
Private  Sub acquisition_DeviceEvent(ByVal sender As Object, ByVal e As Atalasoft.Twain.DeviceEventArgs)
    ' One of the many device events has fired.
    ' You will only receive the events you have set using
    ' the Device.DeviceEvents property.
    If e.Event = DeviceEventFlags.PaperJam Then
        MessageBox.Show(Me, "Paper jam!!!")
    Else
        MessageBox.Show(Me, "Device Event:  " + e.Event.ToString())
    End If
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace
Atalasoft.TwainDevice
Atalasoft.TwainDeviceEventFlags
Atalasoft.TwainDeviceEventArgs


Acquisition.FileTransfer Event

AcquisitionFileTransfer Event

This event will fire just before acquiring an image directly to file. You must fill in the FileName property of the FileTransferEventArgs object.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event FileTransferEventHandler FileTransfer
Public Event FileTransfer As FileTransferEventHandler

Value

Type: Atalasoft.TwainFileTransferEventHandler
Remarks
You can cancel the acquisition by setting the CancelPending property of the FileTransferEventArgs to true.
Examples
Scan to file (C#)
Copy
// Create an instance of Acquisition and set the FileTransfer event.
Acquisition acquisition = new Acquisition(this);
acquisition.FileTransfer += new FileTransferEventHandler(OnFileTransfer);

// We use the AcquireFinished event to know when to close the device.
acquisition.AcquireFinished += new System.EventHandler(OnAcquireFinished);

// The call is asynchronous, so hold onto the device object.
Device dev = null;

// A count variable used to create unique filenames.
int fileCount = 0;

private void AcquireImageToFile()
{
    // We are going to acquire from the default device.
    this.dev = this.acquisition.Devices.Default;

    // You have to open the device before you can get property values.
    this.dev.Open();

    // See if the device supports the TIFF format.
    SourceFileFormats[] formats = this.dev.GetSupportedImageFormats();
    bool canSaveToFile = false;

    foreach(SourceFileFormats format in formats) {
        if (format == SourceFileFormats.Tiff)
        {
            // Tell the device which format to use.
            this.dev.FileFormat = format;
            canSaveToFile = true;
            break;
        }
    }

    if (canSaveToFile == false)
    {
        // Be sure to close the device connection.
        this.dev.Close();
        MessageBox.Show(this, "This device doesn't allow saving to TIFF.");
        return;
    }

    // Acquire the image to file.
    this.dev.Acquire(false, true);
}

private void OnFileTransfer(object sender, FileTransferEventArgs e)
{
    // Set the filename for this image.
    fileCount++;
    e.FileName = imageFolder + "image" + fileCount.ToString() + ".tif";
}

private void OnAcquireFinished(object sender, System.EventArgs e)
{
    // Do not forget to close the device.
    if (this.dev != null)
        this.dev.Close();
}
Scan to file (Visual Basic)
Copy
' Create an instance of Acquisition and set the FileTransfer event.
Dim acquisition As Acquisition = New Acquisition(Me)
acquisition.FileTransfer += New FileTransferEventHandler(OnFileTransfer)

' We use the AcquireFinished event to know when to close the device.
acquisition.AcquireFinished += New System.EventHandler(OnAcquireFinished)

' The call is asynchronous, so hold onto the device object.
Dim dev As Device = Nothing

' A count variable used to create unique filenames.
Dim fileCount As Integer =  0

Private  Sub AcquireImageToFile()
    ' We are going to acquire from the default device.
    Me.dev = Me.acquisition.Devices.Default

    ' You have to open the device before you can get property values.
    Me.dev.Open()

    ' See if the device supports the TIFF format.
    Dim formats() As SourceFileFormats = Me.dev.GetSupportedImageFormats()
    Dim canSaveToFile As Boolean = False

    Dim Format As SourceFileFormats
    For Each Format In formats
        If Format = SourceFileFormats.Tiff Then
            ' Tell the device which format to use.
            Me.dev.FileFormat = Format
            canSaveToFile = True
            Exit For
        End If
    Next

    If canSaveToFile = False Then
        ' Be sure to close the device connection.
        Me.dev.Close()
        MessageBox.Show(this, "This device doesn't allow saving to TIFF.")
        Return
    End If

    ' Acquire the image to file.
    Me.dev.Acquire(False, True)
End Sub

Private  Sub OnFileTransfer(ByVal sender As Object, ByVal e As FileTransferEventArgs)
    ' Set the filename for this image.
    fileCount = fileCount + 1
    e.FileName = imageFolder & "image" & fileCount.ToString() & ".tif"
End Sub

Private  Sub OnAcquireFinished(ByVal sender As Object, ByVal e As System.EventArgs)
    ' Do not forget to close the device.
    If Not Me.dev Is Nothing Then
        Me.dev.Close()
    End If
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.ImageAcquired Event

AcquisitionImageAcquired Event

This event will fire for each image acquired.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event ImageAcquiredEventHandler ImageAcquired
Public Event ImageAcquired As ImageAcquiredEventHandler

Value

Type: Atalasoft.TwainImageAcquiredEventHandler
Remarks

All pending image acquisitions can be cancelled by setting the CancelPending property of the AcquireEventArgs to true.

To transfer the returned Bitmap to an AtalaImage when integrating with DotImage, use the AtalaImage.FromBitmap method.

When scanning multiple pages at once, this method can be used to compose a multipage image by invoking the Images.Add method of the Workspace object in DotImage.

Examples
Acquisition Class
Examples
ImageAcquiredCS (C#)
Copy
private void acquisition_ImageAcquired(object sender, Atalasoft.Twain.AcquireEventArgs e)
{
    if (e.Image != null)
        this.pictureBox1.Image = e.Image;
    else if (e.FileName != null && File.Exists(e.FileName))
        this.pictureBox1.Image = Image.FromFile(e.FileName);
}
ImageAcquiredVB (Visual Basic)
Copy
Private  Sub acquisition_ImageAcquired(ByVal sender As Object, ByVal e As Atalasoft.Twain.AcquireEventArgs)
    If Not e.Image Is Nothing Then
        Me.pictureBox1.Image = e.Image
    Else If e.FileName <> Nothing And File.Exists(e.FileName) Then
        Me.pictureBox1.Image = Image.FromFile(e.FileName)
    End If
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace
Atalasoft.TwainAcquireEventArgs


Acquisition.MemoryDataTransfer Event

AcquisitionMemoryDataTransfer Event

Raised during a memory transfer to allow custom handling of the image data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MemoryDataTransferEventHandler MemoryDataTransfer
Public Event MemoryDataTransfer As MemoryDataTransferEventHandler

Value

Type: Atalasoft.TwainMemoryDataTransferEventHandler
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.MemoryFileTransfer Event

AcquisitionMemoryFileTransfer Event

Raised during a file transfer to allow custom handling of the image data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event MemoryFileTransferEventHandler MemoryFileTransfer
Public Event MemoryFileTransfer As MemoryFileTransferEventHandler

Value

Type: Atalasoft.TwainMemoryFileTransferEventHandler
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


Acquisition.TwainDataTransfer Event

AcquisitionTwainDataTransfer Event

This event fires after the data has been transferred but before it has been processed by DotTwain.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public event TwainDataTransferEventHandler TwainDataTransfer
Public Event TwainDataTransfer As TwainDataTransferEventHandler

Value

Type: Atalasoft.TwainTwainDataTransferEventHandler
Remarks
This event allows for processing of data DotTwain does not support, such as unique image formats. If this data should not be processed by DotTwain, set the DataHandled property of the MemoryDataTransferEventArgs to true.
Examples
TwainDataTransferCS (C#)
Copy
private void acquisition_TwainDataTransfer(object sender, TwainDataTransferArgs e)
{
    // Process the data instead of letting DotTwain do it.
    e.DataHandled = true;

    // ... processing ...

    // Free the memory.
    System.Runtime.InteropServices.Marshal.FreeHGlobal(e.Data);
}
TwainDataTransferVB (Visual Basic)
Copy
Private  Sub acquisition_TwainDataTransfer(ByVal sender As Object, ByVal e As TwainDataTransferArgs)
    ' Process the data instead of letting DotTwain do it.
    e.DataHandled = True

    ' ... processing ...

    ' Free the memory.
    System.Runtime.InteropServices.Marshal.FreeHGlobal(e.Data)
End Sub
See Also

Reference

Acquisition Class
Atalasoft.Twain Namespace


AlarmTypeFlags Enumeration

The type of alarm used for the Alarms property of the Device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum AlarmTypeFlags
<FlagsAttribute>
Public Enumeration AlarmTypeFlags
Members
Member name | Description
AllAlarms | A catchall for alarms not explicitly listed. It is also used where a device only provides control over a single, multi-use alarm.
BarCode | Generates alarms when an image with this kind of data is recognized.
DoubleFeed | Generates alarms when more than one sheet is pulled into the scanning area.
FeederError | Covers paper handling errors such as jams, double-feeds, skewing and the like; conditions that most likely stop scanning.
FeederWarning | Covers non-fatal events, such as feeder empty.
Jam | Generates alarms when there is a paper jam.
PatchCode | Generates alarms when an image with this kind of data is recognized.
Power | Generates alarms for any changes in power to the device.
Skew | Generates alarms when the paper in not inserted correctly.
See Also

Reference

Atalasoft.Twain Namespace


AsynchronousExceptionEventArgs Class

This class is passed to an AsynchronousExceptionEventHandler when there is an exception during an asynchronous acquisition.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.TwainAsynchronousExceptionEventArgs

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class AsynchronousExceptionEventArgs : EventArgs
Public Class AsynchronousExceptionEventArgs
    Inherits EventArgs

The AsynchronousExceptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | The exception which occurred during an asynchronous acquisition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
AsynchronousException Event
See Also

Reference

Atalasoft.Twain Namespace
Atalasoft.TwainAsynchronousExceptionEventHandler
AcquisitionAsynchronousException


AsynchronousExceptionEventArgs Properties

The AsynchronousExceptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | The exception which occurred during an asynchronous acquisition.
Top
See Also

Reference

AsynchronousExceptionEventArgs Class
Atalasoft.Twain Namespace


AsynchronousExceptionEventArgs.Exception Property

AsynchronousExceptionEventArgsException Property

The exception which occurred during an asynchronous acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get

Property Value

Type: Exception
The exception that was thrown.
See Also

Reference

AsynchronousExceptionEventArgs Class
Atalasoft.Twain Namespace


AsynchronousExceptionEventArgs Methods

The AsynchronousExceptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AsynchronousExceptionEventArgs Class
Atalasoft.Twain Namespace


AsynchronousExceptionEventHandler Delegate

This event handler is used to notify the application of any exceptions during an asynchronous acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void AsynchronousExceptionEventHandler(
    Object sender,
    AsynchronousExceptionEventArgs e
)
Public Delegate Sub AsynchronousExceptionEventHandler (
    sender As Object,
    e As AsynchronousExceptionEventArgs
)

Parameters

sender
Type: SystemObject
The Acquisition object.
e
Type: Atalasoft.TwainAsynchronousExceptionEventArgs
An AsynchronousExceptionEventArgs class containing the exception.
See Also

Reference

Atalasoft.Twain Namespace


AutoDiscardMode Enumeration

Used with AutoDiscardBlankPages to enable or disable this feature in the driver.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum AutoDiscardMode
Public Enumeration AutoDiscardMode
Members
Member name | Description
Disabled | Turns off this feature.
Auto | Turns on this feature and allows the driver to decide if the page is blank or not.
Remarks
In addition to these settings, a value from 0 to 2147483647 can be used to determine the byte size cutoff point to identify which images are to be discarded.
See Also

Reference

Atalasoft.Twain Namespace


BarCodeSearchMode Enumeration

Specifies the search mode for barcode recognition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BarCodeSearchMode
Public Enumeration BarCodeSearchMode
Members
Member name | Description
TWBD_HORZ | Horizontal orientation.
TWBD_VERT | Vertical orientation.
TWBD_HORZVERT | Search both directions giving priority to the horizontal search.
TWBD_VERTHORZ | Search both directions giving priority to the vertical search.
See Also

Reference

Atalasoft.Twain Namespace
TwainBarCodeSearchMode


BarCodeType Enumeration

Specifies the bar code type priority for the SetSearchPriorities(BarCodeType) method.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BarCodeType
Public Enumeration BarCodeType
Members
Member name | Description
TWBT_2OF5DATALOGIC | Symbolic constant used in capability access methods.
TWBT_2OF5IATA | Symbolic constant used in capability access methods.
TWBT_2OF5INDUSTRIAL | Symbolic constant used in capability access methods.
TWBT_2OF5INTERLEAVED | Symbolic constant used in capability access methods.
TWBT_2OF5NONINTERLEAVED | Symbolic constant used in capability access methods.
TWBT_2OF5MATRIX | Symbolic constant used in capability access methods.
TWBT_3OF9 | Symbolic constant used in capability access methods.
TWBT_3OF9FULLASCII | Symbolic constant used in capability access methods.
TWBT_CODABAR | Symbolic constant used in capability access methods.
TWBT_CODABARWITHSTARTSTOP | Symbolic constant used in capability access methods.
TWBT_CODE93 | Symbolic constant used in capability access methods.
TWBT_CODE128 | Symbolic constant used in capability access methods.
TWBT_EAN8 | Symbolic constant used in capability access methods.
TWBT_EAN13 | Symbolic constant used in capability access methods.
TWBT_MAXICODE | Symbolic constant used in capability access methods.
TWBT_PDF417 | Symbolic constant used in capability access methods.
TWBT_POSTNET | Symbolic constant used in capability access methods.
TWBT_UCC128 | Symbolic constant used in capability access methods.
TWBT_UPCA | Symbolic constant used in capability access methods.
TWBT_UPCE | Symbolic constant used in capability access methods.
See Also

Reference

Atalasoft.Twain Namespace


BatchJobControl Enumeration

Used to set the batch mode of the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BatchJobControl
Public Enumeration BatchJobControl
Members
Member name | Description
TWJC_NONE | No job control.
TWJC_JSIC | Detect and include job separator and continue scanning.
TWJC_JSIS | Detect and include job separator and stop scanning.
TWJC_JSXC | Detect and exclude job separator and continue scanning.
TWJC_JSXS | Detect and exclude job separator and stop scanning.
See Also

Reference

Atalasoft.Twain Namespace
DeviceGetSupportedJobControls


BeforeTwainDataTransferEventHandler Delegate

This event handler is used to provide information about the data that is about to be scanned.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void BeforeTwainDataTransferEventHandler(
    Object sender,
    TwainDataImageInfoEventArgs e
)
Public Delegate Sub BeforeTwainDataTransferEventHandler (
    sender As Object,
    e As TwainDataImageInfoEventArgs
)

Parameters

sender
Type: SystemObject
The object sending this event. This may be a TwainController or Device object.
e
Type: Atalasoft.TwainTwainDataImageInfoEventArgs
The event args containing information on the image about to be scanned.
See Also

Reference

Atalasoft.Twain Namespace


BitDepthReductionMode Enumeration

The bit depth reduction mode for the Source.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum BitDepthReductionMode
Public Enumeration BitDepthReductionMode
Members
Member name | Description
Diffusion | Uses a type of diffusion to reduce the bit depth.
Halftones | Uses a halftone algorithm to reduce the colors.
Threshold | Uses a set value to determine the reduced color. See the Threshold property.
See Also

Reference

Atalasoft.Twain Namespace
DeviceBitDepthReduction


ClearBufferMode Enumeration

These values are used to determine how the device will clear its internal buffer.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum ClearBufferMode
Public Enumeration ClearBufferMode
Members
Member name | Description
Auto | Causes the Source to automatically clear the buffers when it transitions from state 4 to state 5, or from state 5 to state 4.
Clear | Causes the Source to immediately clear its buffers.
NoClear | Causes the Source to preserve images in the buffers.
See Also

Reference

Atalasoft.Twain Namespace
DeviceClearBuffers(ClearBufferMode)


ColorFilterFlags Enumeration

The filter values for the ColorFilter device property.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum ColorFilterFlags
<FlagsAttribute>
Public Enumeration ColorFilterFlags
Members
Member name | Description
None | No color characteristic is used.
Red | Adds a Red characteristic of the subtractive filter applied to the image data.
Green | Adds a Green characteristic of the subtractive filter applied to the image data.
Blue | Adds a Blue characteristic of the subtractive filter applied to the image data.
White | Adds a White characteristic of the subtractive filter applied to the image data.
Cyan | Adds a Cyan characteristic of the subtractive filter applied to the image data.
Magenta | Adds a Magenta characteristic of the subtractive filter applied to the image data.
Yellow | Adds a Yellow characteristic of the subtractive filter applied to the image data.
Black | Adds a Black characteristic of the subtractive filter applied to the image data.
See Also

Reference

Atalasoft.Twain Namespace
DeviceColorFilter


CompressionMode Enumeration

Compression modes used during file and memory transfers.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CompressionMode
Public Enumeration CompressionMode
Members
Member name | Description
None | No compression.
BitFields | Used only with Bitmaps.
Group3 | CCITT Group 3 2-dimensional encoding, intended for document images (can be used with TIFF).
Group4 | CCITT Group 4 fax encoding, intended for document images (can be used with TIFF).
Jbig | Intended for bi-tonal and grayscale document images (can be used with TIFF or SPIFF).
Jpeg | Intended for the compression of color photographs (can be used with TIFF, JFIF or SPIFF).
Lzw | A compression licensed by UNISYS (can be used with TIFF).
PackBits | Macintosh PackBits format, (can be used with TIFF or PICT).
Png | Portable Network Graphic.
Rle4 | Run-Length encoding used with Bitmaps.
Rle8 | Run-Length encoding used with Bitmaps.
See Also

Reference

Atalasoft.Twain Namespace
DeviceCompression


CountryCode Enumeration

A list of country codes used by Twain devices.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum CountryCode
Public Enumeration CountryCode
Members
Member name | Description
Afghanistan | Country code constant
Algeria | Country code constant
AmericanSamoa | Country code constant
Andorra | Country code constant
Angola | Country code constant
Anguilla | Country code constant
Antigua | Country code constant
Argentina | Country code constant
Aruba | Country code constant
Ascensioni | Country code constant
Australia | Country code constant
Austria | Country code constant
Bahamas | Country code constant
Bahrain | Country code constant
Bangladesh | Country code constant
Barbados | Country code constant
Belgium | Country code constant
Belize | Country code constant
Benin | Country code constant
Bermuda | Country code constant
Bhutan | Country code constant
Bolivia | Country code constant
Botswana | Country code constant
Britain | Country code constant
Britvirginsis | Country code constant
Brazil | Country code constant
Brunei | Country code constant
Bulgaria | Country code constant
Burkinafaso | Country code constant
Burma | Country code constant
Burundi | Country code constant
Camaroon | Country code constant
Canada | Country code constant
CapeVerdeis | Country code constant
Caymanis | Country code constant
CentralAfrep | Country code constant
Chad | Country code constant
Chile | Country code constant
China | Country code constant
Christmasis | Country code constant
Cocosis | Country code constant
Colombia | Country code constant
Comoros | Country code constant
Congo | Country code constant
Cookis | Country code constant
Costarica | Country code constant
Cuba | Country code constant
Cyprus | Country code constant
Czechoslovakia | Country code constant
Denmark | Country code constant
Djibouti | Country code constant
Dominica | Country code constant
Domincanrep | Country code constant
Easteris | Country code constant
Ecuador | Country code constant
Egypt | Country code constant
Elsalvador | Country code constant
Eqguinea | Country code constant
Ethiopia | Country code constant
Falklandis | Country code constant
Faeroeis | Country code constant
Fijiislands | Country code constant
Finland | Country code constant
France | Country code constant
Frantilles | Country code constant
Frguiana | Country code constant
Frpolyneisa | Country code constant
Futanais | Country code constant
Gabon | Country code constant
Gambia | Country code constant
Germany | Country code constant
Ghana | Country code constant
Gibralter | Country code constant
Greece | Country code constant
Greenland | Country code constant
Grenada | Country code constant
Grenedines | Country code constant
Guadeloupe | Country code constant
Guam | Country code constant
Guantanamobay | Country code constant
Guatemala | Country code constant
Guinea | Country code constant
Guineabissau | Country code constant
Guyana | Country code constant
Haiti | Country code constant
Honduras | Country code constant
HongKong | Country code constant
Hungary | Country code constant
Iceland | Country code constant
India | Country code constant
Indonesia | Country code constant
Iran | Country code constant
Iraq | Country code constant
Ireland | Country code constant
Israel | Country code constant
Italy | Country code constant
IvoryCoast | Country code constant
Jamaica | Country code constant
Japan | Country code constant
Jordan | Country code constant
Kenya | Country code constant
Kiribati | Country code constant
Korea | Country code constant
Kuwait | Country code constant
Laos | Country code constant
Lebanon | Country code constant
Liberia | Country code constant
Libya | Country code constant
Liechtenstein | Country code constant
Luxenbourg | Country code constant
Macao | Country code constant
Madagascar | Country code constant
Malawi | Country code constant
Malaysia | Country code constant
Maldives | Country code constant
Mali | Country code constant
Malta | Country code constant
Marshallis | Country code constant
Mauritania | Country code constant
Mauritius | Country code constant
Mexico | Country code constant
Micronesia | Country code constant
Miquelon | Country code constant
Monaco | Country code constant
Mongolia | Country code constant
Montserrat | Country code constant
Morocco | Country code constant
Mozambique | Country code constant
Namibia | Country code constant
Nauru | Country code constant
Nepal | Country code constant
Netherlands | Country code constant
Nethantilles | Country code constant
Nevis | Country code constant
Newcaledonia | Country code constant
Newzealand | Country code constant
Nicaragua | Country code constant
Niger | Country code constant
Nigeria | Country code constant
Niue | Country code constant
Norfolki | Country code constant
Norway | Country code constant
Oman | Country code constant
Pakistan | Country code constant
Palau | Country code constant
Panama | Country code constant
Paraguay | Country code constant
Peru | Country code constant
Phillippines | Country code constant
Pitcairnis | Country code constant
Pnewguinea | Country code constant
Poland | Country code constant
Portugal | Country code constant
Qatar | Country code constant
Reunioni | Country code constant
Romania | Country code constant
Rwanda | Country code constant
Saipan | Country code constant
Sanmarino | Country code constant
Saotome | Country code constant
Saudiarabia | Country code constant
Senegal | Country code constant
Seychellesis | Country code constant
Sierraleone | Country code constant
Singapore | Country code constant
Solomonis | Country code constant
Somali | Country code constant
SouthAfrica | Country code constant
Spain | Country code constant
Srilanka | Country code constant
Sthelena | Country code constant
Stkitts | Country code constant
StLucia | Country code constant
StPierre | Country code constant
StVincent | Country code constant
Sudan | Country code constant
Suriname | Country code constant
Swaziland | Country code constant
Sweden | Country code constant
Switzerland | Country code constant
Syria | Country code constant
Taiwan | Country code constant
Tanzania | Country code constant
Thailand | Country code constant
Tobago | Country code constant
Togo | Country code constant
Tongais | Country code constant
Trinidad | Country code constant
Tunisia | Country code constant
Turkey | Country code constant
Turkscaicos | Country code constant
Tuvalu | Country code constant
Uganda | Country code constant
Ussr | Country code constant
Uaemirates | Country code constant
UnitedKingdom | Country code constant
Usa | Country code constant
Uruguay | Country code constant
Vanuatu | Country code constant
VaticanCity | Country code constant
Venezuela | Country code constant
Wake | Country code constant
Wallisis | Country code constant
WesternSahara | Country code constant
WesternSamoa | Country code constant
Yemen | Country code constant
Yugoslavia | Country code constant
Zaire | Country code constant
Zambia | Country code constant
Zimbabwe | Country code constant
Albania | Country code constant, added =for 1.8
Armenia | Country code constant, added =for 1.8
Azerbaijan | Country code constant, added =for 1.8
Belarus | Country code constant, added =for 1.8
Bosniaherzgo | Country code constant, added =for 1.8
Cambodia | Country code constant, added =for 1.8
Croatia | Country code constant, added =for 1.8
CzechRepublic | Country code constant, added =for 1.8
Diegogarcia | Country code constant, added =for 1.8
Eritrea | Country code constant, added =for 1.8
Estonia | Country code constant, added =for 1.8
Georgia | Country code constant, added =for 1.8
Latvia | Country code constant, added =for 1.8
Lesotho | Country code constant, added =for 1.8
Lithuania | Country code constant, added =for 1.8
Macedonia | Country code constant, added =for 1.8
Mayotteis | Country code constant, added =for 1.8
Moldova | Country code constant, added =for 1.8
Myanmar | Country code constant, added =for 1.8
NorthKorea | Country code constant, added =for 1.8
PuertoRico | Country code constant, added =for 1.8
Russia | Country code constant, added =for 1.8
Serbia | Country code constant, added =for 1.8
Slovakia | Country code constant, added =for 1.8
Slovenia | Country code constant, added =for 1.8
SouthKorea | Country code constant, added =for 1.8
Ukraine | Country code constant, added =for 1.8
USVirginis | Country code constant, added =for 1.8
Vietnam | Country code constant, added =for 1.8
See Also

Reference

Atalasoft.Twain Namespace
TwainIdentityCountry


Device Class

Contains information about a single device and handles the acquisition of images from that device.

Inheritance Hierarchy
SystemObject
Atalasoft.TwainDevice

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class Device : IMessageFilter,
    IDisposable
Public NotInheritable Class Device
    Implements IMessageFilter, IDisposable

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Alarms | Gets or sets a value which indicates if specific audible alarms are on or off.
Public property | AlarmVolume | Gets or sets the volume of alarms.
Public property | Author | Gets or sets the name or other identifying information about the Author of the image.
Public property | AutoBrightness | Gets or sets a value indicating if the AutoBrightness feature of the Source will be used.
 | AutoDiscardBlankPages | Gets or sets a value indicating whether the driver will automatically discard blank pages.
Public property | AutomaticBorderDetection | Gets or sets a value to indicate if the automatic border detection feature of the source should be used.
Public property | AutomaticDeskew | Gets or sets a value indicating if the automatic deskew feature of the source should be used.
Public property | AutomaticRotate | Gets or sets a value indicating if the automatic rotate feature of the source should be used.
Public property | AutoScan | Gets or sets a value to indicate if the device should automatically acquire one image after another.
Public property | AutoSize | Gets or sets the ICAP_AUTOSIZE capability which determines whether the driver is forced to output image dimensions to match the FrameSize or its closest supported frame size.
Public property | BarCode | Gets the TwainBarCode object used to control barcode features of the device.
Public property | BatteryMinutes | Gets the number of battery minutes remaining in the device.
Public property | BatteryPercentage | Gets the percentage of remaining battery power.
Public property | BitDepth | Gets or sets the bit depth for the acquisition.
Public property | BitDepthReduction | Gets or sets the BitDepthReductionMode the Source should use to reduce the bit depth of the data.
Public property | Brightness | Gets or sets the amount of brightness the Source will add to the image.
Public property | CameraPreviewInterface | Gets a value indicating if the device supports a preview interface.
Public property | Caption | Gets or sets a general note about the acquired image.
Public property | CcittKFactor | Gets or sets the K factor indicating how often the new compression baseline should be re-established.
Public property | ColorFilter | Gets or sets the color characteristic of the subtractive filter applied to the image data.
Public property | Compression | Gets or sets the compression used during a file or memory transfer.
Public property | Contrast | Gets or sets the amount of contrast the Source will add to the image.
Public property | Controller | Gets the TwainController used by the Device class.
Public property | CustomDataSupported | Gets a value indicating whether the device supported functionality used by the LoadParameters(Stream) and SaveParameters(Stream) methods.
Public property | DateTime | Gets or sets the date and time of the device's clock.
Public property | DeviceEvents | Gets or sets the device events you want to receive.
Public property | DisplayProgressIndicator | Gets or sets a value to indicate if the source will display a progress bar during an acquisition.
Public property | DocumentFeeder | Gets the DocumentFeeder object for the device if supported.
Public property | Duplex | Gets the duplex mode supported by this device.
Public property | DuplexEnabled | Gets or sets a value indicating if the duplex feature is enabled.
Public property | EnableInterfaceOnly | Gets a value indicating if the source will allow you to display the source interface without acquiring an image. If the device does support this feature, you can use the ShowUserInterface method to display the device interface and allow the user to select their options without acquiring an image.
Public property | EndorserNumber | Gets or sets the starting endorser / imprinter number.
Public property | ExposureTime | Gets or sets the exposure time used to capture the image in seconds.
 | FileFormat | Gets or sets the file format used when saving the acquired image directly to a file.
Public property | FileSystem | Gets the FileSystem for the device if supported. The FileSystem is used for navigating through the folders and files of some cameras and scanners.
Public property | Filter | Gets or sets the algorithm used to improve the quality of the image.
Public property | FlashUsed | Gets or sets the type of flash, if any, is used.
Public property | FlipRotation | Gets or sets a value which is used to properly orient images that flip orientation every other image.
Public property | Frame | Gets or sets the rectangular area of the scanning bed to acquire. If you know ahead of time the location and size of the object to scan, and the device supports this feature, you can decrease the amount of scanning time by setting this property.
Public property | FrameSize | Gets or sets the static frame size for the acquire.
Public property | Gamma | Gets or sets the Source gamma correction value for the image data.
Public property | Halftone | Gets or sets the halftone used by the device during the acquisition.
Public property | HideInterface | Gets or sets a value indicating whether the device interface is shown when acquiring.
Public property | Highlight | Gets or sets which value in an image should be interpreted as the lightest highlight.
Public property | IccProfile | Gets or sets the ICAP_ICCPROFILE capability which determines if the device will link or embed an ICC profile with the image.
Public property | Identity | Gets the device identity information.
Public property | ImageCount | Gets the number of available images. This is only valid for devices which contain an internal buffer. You can find out if there are any pending images during an acquisition by checking the PendingImages property of the AcquireEventArgs class.
Public property | ImageLayout | Gets or sets the layout used when acquiring image data.
Public property | InterfaceControllable | Gets a value indicating if the interface can be hidden during an acquire. If supported, you can hide the interface by setting the hideInterface parameter of the Acquire method.
Public property | JobControl | Gets or sets the type of batch acquisition job to perform.
Public property | JpegPixelType | Gets or sets the pixel type used when Jpeg data is acquired.
Public property | JpegQuality | Gets or sets the Jpeg quality used during a file or memory transfer.
Public property | LampState | Gets or sets a value indicating if the lamp is currently, or should be to ON.
Public property | Language | Gets or sets the language to use for the source device.
Public property | LastReturnCode | Gets the last TwainReturnCode from getting or setting a property.
Public property | LightPath | Gets or sets a value which describes whether the image was captured transmissively or reflectively.
Public property | LightSource | Gets or sets a value that describes the general color characteristic of the light source used to acquire the image.
Public property | MaxBatchBuffers | Gets or sets the number of pages that the scanner can buffer when AutoScan is enabled.
Public property | MaxFrames | Gets or sets the maximum number of frames the device or application can accept.
Public property | MicrEnabled | Gets or sets the CAP_MICRENABLED capability which indicates if the scanner is enabled for MICR check scanning.
Public property | MinimumHeight | Gets the minimum height the source can acquire in Units.
Public property | MinimumWidth | Gets the minimum width the source can acquire in Units.
Public property | ModalAcquire | Gets or sets a value indicating whether the Acquire method is synchronous or asynchronous.
Public property | NativeResolution | Gets the native optical resolution of the device.
Public property | NoiseFilter | Gets or sets the noise filter the source will use.
Public property | Online | Gets a value indicating if the device is powered up and ready to use.
Public property | Orientation | Gets or sets the orientation of the acquired image.
Public property | Overscan | Gets or sets a value indicating the type of overscan the source should perform.
Public property | PaperDetectable | Gets a value indicating if the device has a paper sensor.
Public property | PatchCode | Gets the TwainBarCode object used to control patchcode features of the device.
Public property | PhysicalHeight | Gets the maximum height in Units the source can acquire.
Public property | PhysicalWidth | Gets the maximum width in Units the source can acquire.
Public property | PixelFlavor | Gets or sets a value indicating whether the image data uses the value 0 for the darkest color or the lightest color.
Public property | PixelType | Gets or sets the pixel format to acquire. You should set this property before setting BitDepth.
Public property | PowerSupply | Gets the type of power supply used for this camera.
Public property | ReacquireAllowed | Gets a value indicating whether the physical hardware is capable of acquiring multiple images of the same page without changes to the physical registration of that page.
Public property | Resolution | Gets or sets the number of pixels per unit as specified by the Units property.
Public property | Rotation | Gets or sets the amount to rotate the image by the Source.
Public property | Scaling | Gets or sets the amount of scaling the Source will perform on the image.
Public property | SerialNumber | Gets a string containing the serial number of this device.
Public property | Shadow | Gets or sets the value in an image which should be interpreted as the darkest shadow.
Public property | State | Gets a value indicating the current Twain state.
Public property | ThreadingEnabled | Gets or sets a value indicating whether to perform the scanning in a separate thread. See the remarks below for threading limitations.
Public property | Threshold | Gets or sets the dividing line between black and white for 1-bit acquires.
Public property | ThumbnailEnabled | Gets or sets a value indicating if a thumbnail should be returned instead of the full size image.
Public property | TransferCount | Gets or sets the number of images your application is willing to accept.
Public property | TransferMethod | Gets or sets the transfer method used when acquiring data.
Public property | Units | Gets or sets a value indicating the units of measure for this acquire.
Public property | ZoomFactor | Gets or sets the zoom factor to use for the acquire. Valid values for this property are source defined.
Top
Methods
 | Name | Description
 | Acquire | Acquires an image from this device.
Public method | CanOpen | Obsolete. This method may be removed in a future version. New applications should use the TryOpen method instead. Returns a value indicating whether or not the Open method can currently be used on the device.
Public method | ClearBuffers | This lets you choose how the device should handle its buffer clearing procedure.
Public method | Close | Closes the connection with the device previously opened. Calling this method when an image is being acquired will cancel the acquisition and any pending transfers. If you want to close the connection after all images have been transferred, you should do so in the AcquireFinished event.
Public method | Disable | This method will disable and hide the device interface. This only needs to be called if the Enable method is used to display the interface or invoke scanning.
Public method | Dispose | Releases resources used by the device when created from the CreateDeviceSession(String) method. This should not be used for Device objects in the DeviceCollection.
Public method | Enable | This method can be used to display the device interface and invoke an acquisition instead of using Acquire.
Public method | EnableCamera | Use this method to enable or disable cameras used when scanning.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Calls Close() (Overrides ObjectFinalize.)
Public method | GetConditionCode | Returns the condition code from the last Twain operation. This can provide more information about a failure when getting or setting a Device property.
Public method | GetFrames | Returns an array containing the current frames set for a device.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetQueryOperations | Returns the operations supported for a specific capability.
Public method | GetSupportedBarCodes | Returns the barcodes supported by the device.
Public method | GetSupportedBitDepthReductionModes | Returns the BitDepthReductionModes supported by the device.
Public method | GetSupportedBitDepths | Returns the supported bit depth values for the current PixelType.
Public method | GetSupportedBrightnessValues | Returns the brightness values supported by the device.
Public method | GetSupportedCapabilities | Returns a list of all the capabilities for which the Source will answer inquiries.
Public method | GetSupportedCompressionModes | Returns the supported compression modes for this device.
Public method | GetSupportedContrastValues | Returns the contrast values supported by the device.
Public method | GetSupportedExposureTimes | Returns an array of exposure times supported by the device.
Public method | GetSupportedExtendedCapabilities | Returns the extended capabilities supported by the device.
Public method | GetSupportedFlashModes | Returns the flash modes supported by the device.
Public method | GetSupportedFrameSizes | Returns the frame sizes supported by the device.
Public method | GetSupportedHalftones | Returns the halftone values supported by the device.
Public method | GetSupportedHighlightValues | Returns the highlight values supported by the device.
Public method | GetSupportedIccProfileOptions | Returns an array of TwainIccProfileOption values indicating what type of ICC profiles are supported by the device.
Public method | GetSupportedImageFilters | Returns the image filters supported by the device.
 | GetSupportedImageFormats | Returns a list of the file formats supported by this device.
Public method | GetSupportedJobControls | Returns the job controls supported by the device.
Public method | GetSupportedJpegPixelTypes | Returns the Jpeg pixel types supported by the device.
Public method | GetSupportedJpegQualityValues | Returns the Jpeg quality values supported by the device.
Public method | GetSupportedLanguageTypes | Returns the language types supported by the device.
Public method | GetSupportedLightPathModes | Returns the light path modes supported by the device.
Public method | GetSupportedLightSourceModes | Returns the light source modes supported by the device.
Public method | GetSupportedMaxBatchBuffers | Returns the supported maximum batch buffers for the device.
Public method | GetSupportedNativeResolutions | Returns the native resolution values for the device.
Public method | GetSupportedNoiseFilterModes | Returns the noise filter modes supported by the device.
Public method | GetSupportedOrientationModes | Returns the orientation modes supported by the device.
Public method | GetSupportedOverscanModes | Returns the overscan modes supported by the device.
Public method | GetSupportedPatchCodes | Returns the patchcodes supported by the device.
Public method | GetSupportedPixelTypes | Returns the pixel types supported by the device.
Public method | GetSupportedPowerSupplies | Returns the supported power supplies for the device.
Public method | GetSupportedPrinterModes | Returns the printer modes supported by the device.
Public method | GetSupportedPrinters | Finds the type of imprinter or endorser supported by this device. These can be used to set which imprinter or endorser to use in the SetImprinterEndorser method.
Public method | GetSupportedResolutions | Returns supported resolution values for the device.
Public method | GetSupportedRotations | Returns the rotations supported by the device.
Public method | GetSupportedScalingValues | Returns scaling values supported by the device.
Public method | GetSupportedShadowValues | Returns the shadow values supported by the device.
Public method | GetSupportedThresholdValues | Returns the threshold values supported by the device.
Public method | GetSupportedTransferMethods | Returns the transfer methods supported by the device.
Public method | GetSupportedUnitTypes | Returns the unit values supported by the device.
Public method | GetSupportedZoomFactors | Returns an array of valid zoom factors for this device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadParameters | Loads previously saved device parameters into the device.
Public method | LoadXmlParameters | Load device parameter data saved with the SaveXmlParameters(Stream) method.
Public method | Open | Opens a connection to this device. You must open a connection to the device before getting or setting any device properties. If you don't need to get or set any properties, you can call the Acquire method without using the Open or Close methods. TryOpen is the preferred way to open a connection to the device.
Public method | PreFilterMessage | Filters out a message before it is dispatched.
 | QueryCapability | Determines if a capability is available from the device. It's unlikely that any one device supports all of the properties and features. You can use this method to find out if a property is get-able and/or set-able. This can also be used to help determine if the device is a camera by checking for camera specific properties, such as FlashUsed or BatteryPercentage.
Public method | SaveParameters | Saves the current device parameters to a stream.
Public method | SaveXmlParameters | Saves device property values into XML format.
Public method | SetCameraPixelOrder | Sets the pixel order for each enabled camera.
Public method | SetExtendedCapabilities | Sets the extended capabilities your application needs to negotiate during states 5 and 6 of a Twain session.
Public method | SetExtendedImageInfoOptions | Sets the extended image information options to obtain after acquiring the data.
Public method | SetFrames | Sets multiple frames to acquire from when scanning.
Public method | SetImageDataset | Sets the indices of the images you want to acquire. This is useful when you want to acquire multiple images from a camera with a single call to the Acquire method.
Public method | SetImprinterEndorser(ImprinterEndorserType, Boolean) | Use this method to enable or disable an imprinter or endorser.
Public method | SetImprinterEndorser(ImprinterEndorserType, ImprinterEndorserMode, String, Int32, String) | Use this method to enable an imprinter or endorser and set its parameters.
Public method | ShowUserInterface | Displays the device interface. This operation is used by applications that wish to display the device user interface to allow the user to manipulate the devices current settings for resolution, paper size, etc. but not acquire an image.
Public method | StartAutomaticCapture | Starts an automatic capture process. This method does not acquire the images. Automatic capture implies that the device is capable of capturing images without the presence of the Application. This means that it must be possible for the Application to close the device and reopen it later, after the images have been captured.
Public method | ToString | A string which describes this object. (Overrides ObjectToString.)
 | TryOpen | This method will attempt to open a connection to the device and will return true if it was successful. It's preferred to use this method instead of the Open method. The Close method must be called when you are finished using the device.
Top
Remarks

This class controls how the image will be acquired and to learn more about the device and its capabilities. The Open method must be invoked before gaining access to the device properties and information. The Close method must be invoked when finished with the device.

To find out which properties you can obtain from the device, invoke the QueryCapability(DeviceCapability, Boolean) method or get a list of property names from the GetSupportedCapabilities method.
Examples
Acquire() Method
See Also

Reference

Atalasoft.Twain Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | Alarms | Gets or sets a value which indicates if specific audible alarms are on or off.
Public property | AlarmVolume | Gets or sets the volume of alarms.
Public property | Author | Gets or sets the name or other identifying information about the Author of the image.
Public property | AutoBrightness | Gets or sets a value indicating if the AutoBrightness feature of the Source will be used.
 | AutoDiscardBlankPages | Gets or sets a value indicating whether the driver will automatically discard blank pages.
Public property | AutomaticBorderDetection | Gets or sets a value to indicate if the automatic border detection feature of the source should be used.
Public property | AutomaticDeskew | Gets or sets a value indicating if the automatic deskew feature of the source should be used.
Public property | AutomaticRotate | Gets or sets a value indicating if the automatic rotate feature of the source should be used.
Public property | AutoScan | Gets or sets a value to indicate if the device should automatically acquire one image after another.
Public property | AutoSize | Gets or sets the ICAP_AUTOSIZE capability which determines whether the driver is forced to output image dimensions to match the FrameSize or its closest supported frame size.
Public property | BarCode | Gets the TwainBarCode object used to control barcode features of the device.
Public property | BatteryMinutes | Gets the number of battery minutes remaining in the device.
Public property | BatteryPercentage | Gets the percentage of remaining battery power.
Public property | BitDepth | Gets or sets the bit depth for the acquisition.
Public property | BitDepthReduction | Gets or sets the BitDepthReductionMode the Source should use to reduce the bit depth of the data.
Public property | Brightness | Gets or sets the amount of brightness the Source will add to the image.
Public property | CameraPreviewInterface | Gets a value indicating if the device supports a preview interface.
Public property | Caption | Gets or sets a general note about the acquired image.
Public property | CcittKFactor | Gets or sets the K factor indicating how often the new compression baseline should be re-established.
Public property | ColorFilter | Gets or sets the color characteristic of the subtractive filter applied to the image data.
Public property | Compression | Gets or sets the compression used during a file or memory transfer.
Public property | Contrast | Gets or sets the amount of contrast the Source will add to the image.
Public property | Controller | Gets the TwainController used by the Device class.
Public property | CustomDataSupported | Gets a value indicating whether the device supported functionality used by the LoadParameters(Stream) and SaveParameters(Stream) methods.
Public property | DateTime | Gets or sets the date and time of the device's clock.
Public property | DeviceEvents | Gets or sets the device events you want to receive.
Public property | DisplayProgressIndicator | Gets or sets a value to indicate if the source will display a progress bar during an acquisition.
Public property | DocumentFeeder | Gets the DocumentFeeder object for the device if supported.
Public property | Duplex | Gets the duplex mode supported by this device.
Public property | DuplexEnabled | Gets or sets a value indicating if the duplex feature is enabled.
Public property | EnableInterfaceOnly | Gets a value indicating if the source will allow you to display the source interface without acquiring an image. If the device does support this feature, you can use the ShowUserInterface method to display the device interface and allow the user to select their options without acquiring an image.
Public property | EndorserNumber | Gets or sets the starting endorser / imprinter number.
Public property | ExposureTime | Gets or sets the exposure time used to capture the image in seconds.
 | FileFormat | Gets or sets the file format used when saving the acquired image directly to a file.
Public property | FileSystem | Gets the FileSystem for the device if supported. The FileSystem is used for navigating through the folders and files of some cameras and scanners.
Public property | Filter | Gets or sets the algorithm used to improve the quality of the image.
Public property | FlashUsed | Gets or sets the type of flash, if any, is used.
Public property | FlipRotation | Gets or sets a value which is used to properly orient images that flip orientation every other image.
Public property | Frame | Gets or sets the rectangular area of the scanning bed to acquire. If you know ahead of time the location and size of the object to scan, and the device supports this feature, you can decrease the amount of scanning time by setting this property.
Public property | FrameSize | Gets or sets the static frame size for the acquire.
Public property | Gamma | Gets or sets the Source gamma correction value for the image data.
Public property | Halftone | Gets or sets the halftone used by the device during the acquisition.
Public property | HideInterface | Gets or sets a value indicating whether the device interface is shown when acquiring.
Public property | Highlight | Gets or sets which value in an image should be interpreted as the lightest highlight.
Public property | IccProfile | Gets or sets the ICAP_ICCPROFILE capability which determines if the device will link or embed an ICC profile with the image.
Public property | Identity | Gets the device identity information.
Public property | ImageCount | Gets the number of available images. This is only valid for devices which contain an internal buffer. You can find out if there are any pending images during an acquisition by checking the PendingImages property of the AcquireEventArgs class.
Public property | ImageLayout | Gets or sets the layout used when acquiring image data.
Public property | InterfaceControllable | Gets a value indicating if the interface can be hidden during an acquire. If supported, you can hide the interface by setting the hideInterface parameter of the Acquire method.
Public property | JobControl | Gets or sets the type of batch acquisition job to perform.
Public property | JpegPixelType | Gets or sets the pixel type used when Jpeg data is acquired.
Public property | JpegQuality | Gets or sets the Jpeg quality used during a file or memory transfer.
Public property | LampState | Gets or sets a value indicating if the lamp is currently, or should be to ON.
Public property | Language | Gets or sets the language to use for the source device.
Public property | LastReturnCode | Gets the last TwainReturnCode from getting or setting a property.
Public property | LightPath | Gets or sets a value which describes whether the image was captured transmissively or reflectively.
Public property | LightSource | Gets or sets a value that describes the general color characteristic of the light source used to acquire the image.
Public property | MaxBatchBuffers | Gets or sets the number of pages that the scanner can buffer when AutoScan is enabled.
Public property | MaxFrames | Gets or sets the maximum number of frames the device or application can accept.
Public property | MicrEnabled | Gets or sets the CAP_MICRENABLED capability which indicates if the scanner is enabled for MICR check scanning.
Public property | MinimumHeight | Gets the minimum height the source can acquire in Units.
Public property | MinimumWidth | Gets the minimum width the source can acquire in Units.
Public property | ModalAcquire | Gets or sets a value indicating whether the Acquire method is synchronous or asynchronous.
Public property | NativeResolution | Gets the native optical resolution of the device.
Public property | NoiseFilter | Gets or sets the noise filter the source will use.
Public property | Online | Gets a value indicating if the device is powered up and ready to use.
Public property | Orientation | Gets or sets the orientation of the acquired image.
Public property | Overscan | Gets or sets a value indicating the type of overscan the source should perform.
Public property | PaperDetectable | Gets a value indicating if the device has a paper sensor.
Public property | PatchCode | Gets the TwainBarCode object used to control patchcode features of the device.
Public property | PhysicalHeight | Gets the maximum height in Units the source can acquire.
Public property | PhysicalWidth | Gets the maximum width in Units the source can acquire.
Public property | PixelFlavor | Gets or sets a value indicating whether the image data uses the value 0 for the darkest color or the lightest color.
Public property | PixelType | Gets or sets the pixel format to acquire. You should set this property before setting BitDepth.
Public property | PowerSupply | Gets the type of power supply used for this camera.
Public property | ReacquireAllowed | Gets a value indicating whether the physical hardware is capable of acquiring multiple images of the same page without changes to the physical registration of that page.
Public property | Resolution | Gets or sets the number of pixels per unit as specified by the Units property.
Public property | Rotation | Gets or sets the amount to rotate the image by the Source.
Public property | Scaling | Gets or sets the amount of scaling the Source will perform on the image.
Public property | SerialNumber | Gets a string containing the serial number of this device.
Public property | Shadow | Gets or sets the value in an image which should be interpreted as the darkest shadow.
Public property | State | Gets a value indicating the current Twain state.
Public property | ThreadingEnabled | Gets or sets a value indicating whether to perform the scanning in a separate thread. See the remarks below for threading limitations.
Public property | Threshold | Gets or sets the dividing line between black and white for 1-bit acquires.
Public property | ThumbnailEnabled | Gets or sets a value indicating if a thumbnail should be returned instead of the full size image.
Public property | TransferCount | Gets or sets the number of images your application is willing to accept.
Public property | TransferMethod | Gets or sets the transfer method used when acquiring data.
Public property | Units | Gets or sets a value indicating the units of measure for this acquire.
Public property | ZoomFactor | Gets or sets the zoom factor to use for the acquire. Valid values for this property are source defined.
Top
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Alarms Property

DeviceAlarms Property

Gets or sets a value which indicates if specific audible alarms are on or off.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AlarmTypeFlags Alarms { get; set; }
Public Property Alarms As AlarmTypeFlags
    Get
    Set

Property Value

Type: AlarmTypeFlags
The current AlarmTypeFlags set for the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AlarmVolume Property

DeviceAlarmVolume Property

Gets or sets the volume of alarms.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AlarmVolume { get; set; }
Public Property AlarmVolume As Integer
    Get
    Set

Property Value

Type: Int32
The current volume of the alarms.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Valid values are from 0 to 100.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Author Property

DeviceAuthor Property

Gets or sets the name or other identifying information about the Author of the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set

Property Value

Type: String
The current name of the image author.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutoBrightness Property

DeviceAutoBrightness Property

Gets or sets a value indicating if the AutoBrightness feature of the Source will be used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoBrightness { get; set; }
Public Property AutoBrightness As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the auto brightness feature of the driver is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutoDiscardBlankPages Property

DeviceAutoDiscardBlankPages Property

Gets or sets a value indicating whether the driver will automatically discard blank pages.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public AutoDiscardMode AutoDiscardBlankPages { get; set; }
Public Property AutoDiscardBlankPages As AutoDiscardMode
    Get
    Set

Property Value

Type: AutoDiscardMode
A value indicating whether blank pages will be discarded.
Remarks

In addition to the AutoDiscardMode options, a value from 0 to 2147483647 can be used to determine the byte size cutoff point to identify which images are to be discarded.

Use QueryCapability(DeviceCapability, Boolean) with the ICAP_AUTODISCARDBLANKPAGES capability to determine whether the driver supports this feature.

Examples
AutoDiscardBlankPages (C#)
Copy
// Set the blank page detection to discard anything less than 200 bytes.
this.device.AutoDiscardBlankPages = (AutoDiscardMode)200;
AutoDiscardBlankPagesVB (Visual Basic)
Copy
' Set the blank page detection to discard anything less than 200 bytes.
Me.device.AutoDiscardBlankPages = CType(200, AutoDiscardMode)
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutomaticBorderDetection Property

DeviceAutomaticBorderDetection Property

Gets or sets a value to indicate if the automatic border detection feature of the source should be used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutomaticBorderDetection { get; set; }
Public Property AutomaticBorderDetection As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the automatic border detection feature is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutomaticDeskew Property

DeviceAutomaticDeskew Property

Gets or sets a value indicating if the automatic deskew feature of the source should be used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutomaticDeskew { get; set; }
Public Property AutomaticDeskew As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the automatic deskew feature is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutomaticRotate Property

DeviceAutomaticRotate Property

Gets or sets a value indicating if the automatic rotate feature of the source should be used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutomaticRotate { get; set; }
Public Property AutomaticRotate As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the automatic rotate feature is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutoScan Property

DeviceAutoScan Property

Gets or sets a value to indicate if the device should automatically acquire one image after another.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoScan { get; set; }
Public Property AutoScan As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the automatic scan feature is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
This capability is intended to boost the performance of a Source. The fundamental assumption behind AutoScan is that the device is able to capture the number of images indicated by the value of TransferCount without waiting for the Application to request the image transfers.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.AutoSize Property

DeviceAutoSize Property

Gets or sets the ICAP_AUTOSIZE capability which determines whether the driver is forced to output image dimensions to match the FrameSize or its closest supported frame size.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainAutoSize AutoSize { get; set; }
Public Property AutoSize As TwainAutoSize
    Get
    Set

Property Value

Type: TwainAutoSize
A value indicating whether the output image dimensions will be forced to a specific size.
Exceptions
Exception | Condition
 | Thrown if the state is less than SourceOpen for getting the value, or is not equal to SourceOpen when setting the value.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.BarCode Property

DeviceBarCode Property

Gets the TwainBarCode object used to control barcode features of the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainBarCode BarCode { get; }
Public ReadOnly Property BarCode As TwainBarCode
    Get

Property Value

Type: TwainBarCode
A TwainBarCode object.
Remarks
The DetectionEnabled property should be set to true before accessing any barcode features.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.BatteryMinutes Property

DeviceBatteryMinutes Property

Gets the number of battery minutes remaining in the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BatteryMinutes { get; }
Public ReadOnly Property BatteryMinutes As Integer
    Get

Property Value

Type: Int32

The number of minutes remaining or one of the following values:

-2Indicates infinite power.-1Indicates that the device cannot report the remaining battery power.

Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.BatteryPercentage Property

DeviceBatteryPercentage Property

Gets the percentage of remaining battery power.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BatteryPercentage { get; }
Public ReadOnly Property BatteryPercentage As Integer
    Get

Property Value

Type: Int32

The percentage remaining or one of the following values:

-2Indicates infinite power.-1Indicates that the device cannot report the remaining battery power.

Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.BitDepth Property

DeviceBitDepth Property

Gets or sets the bit depth for the acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BitDepth { get; set; }
Public Property BitDepth As Integer
    Get
    Set

Property Value

Type: Int32
The bit depth for the acquisition.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
You should set the PixelType property before setting the bit depth. For a list of valid bit depth values supported by a device use the GetSupportedBitDepths method.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedBitDepths
DevicePixelType


Device.BitDepthReduction Property

DeviceBitDepthReduction Property

Gets or sets the BitDepthReductionMode the Source should use to reduce the bit depth of the data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitDepthReductionMode BitDepthReduction { get; set; }
Public Property BitDepthReduction As BitDepthReductionMode
    Get
    Set

Property Value

Type: BitDepthReductionMode
The BitDepthReductionMode the Source should use to reduce the bit depth of the data.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use the GetSupportedBitDepthReductionModes method to find values supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedBitDepthReductionModes


Device.Brightness Property

DeviceBrightness Property

Gets or sets the amount of brightness the Source will add to the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Brightness { get; set; }
Public Property Brightness As Single
    Get
    Set

Property Value

Type: Single
The amount of brightness the Source will add to the image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Normal values are from -1000 to 1000 but can very from scanner to scanner. Use the GetSupportedBrightnessValues method to find the values supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedBrightnessValues


Device.CameraPreviewInterface Property

DeviceCameraPreviewInterface Property

Gets a value indicating if the device supports a preview interface.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CameraPreviewInterface { get; }
Public ReadOnly Property CameraPreviewInterface As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the device supports a preview interface.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Caption Property

DeviceCaption Property

Gets or sets a general note about the acquired image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String
A general note about the acquired image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.CcittKFactor Property

DeviceCcittKFactor Property

Gets or sets the K factor indicating how often the new compression baseline should be re-established.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int CcittKFactor { get; set; }
Public Property CcittKFactor As Integer
    Get
    Set

Property Value

Type: Int32
The K factor indicating how often the new compression baseline should be re-established.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
This is only used for CCITT Group 3 2-dimensional compression. A value of 2 or 4 is common in facsimile communication. A value of zero will indicate an infinite K factor (the baseline is only calculated at the beginning of the transfer).
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceCompression


Device.ColorFilter Property

DeviceColorFilter Property

Gets or sets the color characteristic of the subtractive filter applied to the image data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ColorFilterFlags ColorFilter { get; set; }
Public Property ColorFilter As ColorFilterFlags
    Get
    Set

Property Value

Type: ColorFilterFlags
The color characteristic of the subtractive filter applied to the image data.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Multiple filters may be applied to a single acquisition.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Compression Property

DeviceCompression Property

Gets or sets the compression used during a file or memory transfer.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CompressionMode Compression { get; set; }
Public Property Compression As CompressionMode
    Get
    Set

Property Value

Type: CompressionMode
The compression used during a transfer.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

You can use the GetSupportedCompressionModes method to find out which compressions are supported by the device. Some devices require the TransferMethod be set to File, File2 or Memory before setting this property.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedCompressionModes


Device.Contrast Property

DeviceContrast Property

Gets or sets the amount of contrast the Source will add to the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Contrast { get; set; }
Public Property Contrast As Single
    Get
    Set

Property Value

Type: Single
The amount of contrast the Source will add to the image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Normal values are from -1000 to 1000 but can vary from scanner to scanner. Use the GetSupportedContrastValues method to find values supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedContrastValues


Device.Controller Property

DeviceController Property

Gets the TwainController used by the Device class.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainController Controller { get; }
Public ReadOnly Property Controller As TwainController
    Get

Property Value

Type: TwainController
The TwainController used by the device class.
Remarks
The controller should only be used by developers familiar with the Twain specification. The TwainController was exposed to allow developers to work with low level coding without having to write their own device class.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.CustomDataSupported Property

DeviceCustomDataSupported Property

Gets a value indicating whether the device supported functionality used by the LoadParameters(Stream) and SaveParameters(Stream) methods.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CustomDataSupported { get; }
Public ReadOnly Property CustomDataSupported As Boolean
    Get

Property Value

Type: Boolean
A value indication support for loading and saving device parameters.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Twain and DotTwain have no knowledge of the data format used if this feature is available. The data is specific to each device driver.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceLoadParameters(Stream)
DeviceSaveParameters(Stream)


Device.DateTime Property

DeviceDateTime Property

Gets or sets the date and time of the device's clock.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DateTime { get; set; }
Public Property DateTime As String
    Get
    Set

Property Value

Type: String
The date and time of the device's clock.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Managed in the form YYYY/MM/DD HH:mm:SS:sss where YYYY is the year, MM is the numerical month, DD is the numerical day, HH is the hour, mm is the minute, SS is the second, and sss is the millisecond.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.DeviceEvents Property

DeviceDeviceEvents Property

Gets or sets the device events you want to receive.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeviceEventFlags DeviceEvents { get; set; }
Public Property DeviceEvents As DeviceEventFlags
    Get
    Set

Property Value

Type: DeviceEventFlags
The device events you want to receive.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
These events will be received through the DeviceEvent event.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.DisplayProgressIndicator Property

DeviceDisplayProgressIndicator Property

Gets or sets a value to indicate if the source will display a progress bar during an acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DisplayProgressIndicator { get; set; }
Public Property DisplayProgressIndicator As Boolean
    Get
    Set

Property Value

Type: Boolean
A value to indicate if the source will display a progress bar during an acquisition.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.DocumentFeeder Property

DeviceDocumentFeeder Property

Gets the DocumentFeeder object for the device if supported.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentFeeder DocumentFeeder { get; }
Public ReadOnly Property DocumentFeeder As DocumentFeeder
    Get

Property Value

Type: DocumentFeeder
The DocumentFeeder object for the device if supported.
Remarks
The Enabled property should be set to true before accessing any other DocumentFeeder properties.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Duplex Property

DeviceDuplex Property

Gets the duplex mode supported by this device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DuplexMode Duplex { get; }
Public ReadOnly Property Duplex As DuplexMode
    Get

Property Value

Type: DuplexMode
The duplex mode for this device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceDuplexEnabled


Device.DuplexEnabled Property

DeviceDuplexEnabled Property

Gets or sets a value indicating if the duplex feature is enabled.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool DuplexEnabled { get; set; }
Public Property DuplexEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the duplex feature is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceDuplex


Device.EnableInterfaceOnly Property

DeviceEnableInterfaceOnly Property

Gets a value indicating if the source will allow you to display the source interface without acquiring an image.

If the device does support this feature, you can use the ShowUserInterface method to display the device interface and allow the user to select their options without acquiring an image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableInterfaceOnly { get; }
Public ReadOnly Property EnableInterfaceOnly As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the source will allow you to display the source interface without acquiring an image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceShowUserInterface


Device.EndorserNumber Property

DeviceEndorserNumber Property

Gets or sets the starting endorser / imprinter number.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int EndorserNumber { get; set; }
Public Property EndorserNumber As Integer
    Get
    Set

Property Value

Type: Int32
The starting endorser / imprinter number.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
The Twain specification states that all other endorser/imprinter properties should be handled through the device s user interface. However, you can attempt to set these values through code using the SetImprinterEndorser(ImprinterEndorserType, Boolean) method.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceSetImprinterEndorser(ImprinterEndorserType, Boolean)


Device.ExposureTime Property

DeviceExposureTime Property

Gets or sets the exposure time used to capture the image in seconds.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ExposureTime { get; set; }
Public Property ExposureTime As Integer
    Get
    Set

Property Value

Type: Int32
The exposure time used to capture the image in seconds.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

Use the GetSupportedExposureTimes method to find out supported times for this device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedExposureTimes


Device.FileFormat Property

DeviceFileFormat Property

Gets or sets the file format used when saving the acquired image directly to a file.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SourceImageFormat FileFormat { get; set; }
Public Property FileFormat As SourceImageFormat
    Get
    Set

Property Value

Type: SourceImageFormat
The file format used when saving the acquired image directly to a file.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

Use the GetSupportedImageFormats method to find out which formats are supported by the device. Some devices require the TransferMethod be set to TWSX_FILE or TWSX_FILE2 before this property can be set.

Examples
FileTransfer Event
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedImageFormats


Device.FileSystem Property

DeviceFileSystem Property

Gets the FileSystem for the device if supported.

The FileSystem is used for navigating through the folders and files of some cameras and scanners.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileSystem FileSystem { get; }
Public ReadOnly Property FileSystem As FileSystem
    Get

Property Value

Type: FileSystem
The FileSystem for the device if supported.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceFileSystem


Device.Filter Property

DeviceFilter Property

Gets or sets the algorithm used to improve the quality of the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageFilterMode Filter { get; set; }
Public Property Filter As ImageFilterMode
    Get
    Set

Property Value

Type: ImageFilterMode
The algorithm used to improve the quality of the image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedImageFilters to find out which modes are supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedImageFilters


Device.FlashUsed Property

DeviceFlashUsed Property

Gets or sets the type of flash, if any, is used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlashMode FlashUsed { get; set; }
Public Property FlashUsed As FlashMode
    Get
    Set

Property Value

Type: FlashMode
The type of flash, if any, is used.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedFlashModes to find out which modes the device supports.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedFlashModes


Device.FlipRotation Property

DeviceFlipRotation Property

Gets or sets a value which is used to properly orient images that flip orientation every other image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlipRotationMode FlipRotation { get; set; }
Public Property FlipRotation As FlipRotationMode
    Get
    Set

Property Value

Type: FlipRotationMode
A value which is used to properly orient images that flip orientation every other image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Frame Property

DeviceFrame Property

Gets or sets the rectangular area of the scanning bed to acquire.

If you know ahead of time the location and size of the object to scan, and the device supports this feature, you can decrease the amount of scanning time by setting this property.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF Frame { get; set; }
Public Property Frame As RectangleF
    Get
    Set

Property Value

Type: RectangleF
The rectangular area of the scanning bed to acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
If the device supports multiple frames, the GetFrames and SetFrames(RectangleF) can be used in place of this property.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceFrameSize
DeviceGetFrames
DeviceSetFrames(RectangleF)
DeviceImageLayout


Device.FrameSize Property

DeviceFrameSize Property

Gets or sets the static frame size for the acquire.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StaticFrameSizeType FrameSize { get; set; }
Public Property FrameSize As StaticFrameSizeType
    Get
    Set

Property Value

Type: StaticFrameSizeType
The static frame size for the acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

This is similar to the Frame property, but provides static sized frames to choose from. If the device supports this feature, use the GetSupportedFrameSizes method to find out which sizes are supported by the device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedFrameSizes
DeviceFrame


Device.Gamma Property

DeviceGamma Property

Gets or sets the Source gamma correction value for the image data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Gamma { get; set; }
Public Property Gamma As Single
    Get
    Set

Property Value

Type: Single
The Source gamma correction value for the image data.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
There is no set range of values for this property, however many devices default to a value of 2.2.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Halftone Property

DeviceHalftone Property

Gets or sets the halftone used by the device during the acquisition.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string Halftone { get; set; }
Public Property Halftone As String
    Get
    Set

Property Value

Type: String
The name of the halftone used.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use the GetSupportedHalftones to find out what values are supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedHalftones


Device.HideInterface Property

DeviceHideInterface Property

Gets or sets a value indicating whether the device interface is shown when acquiring.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool HideInterface { get; set; }
Public Property HideInterface As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the device interface is shown.
Remarks

Setting this property is only a request that the device show or hide its interface. Devices are free to ignore this request, though most will comply.

This property can be set before opening a connection to the device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceModalAcquire


Device.Highlight Property

DeviceHighlight Property

Gets or sets which value in an image should be interpreted as the lightest highlight.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Highlight { get; set; }
Public Property Highlight As Single
    Get
    Set

Property Value

Type: Single
A value in an image should be interpreted as the lightest highlight.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
All values lighter than this value will be clipped to this value. Valid values are usually from 0 to 255. GetSupportedHighlightValues can be used to determine valid values for the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceShadow
DeviceGetSupportedHighlightValues


Device.IccProfile Property

DeviceIccProfile Property

Gets or sets the ICAP_ICCPROFILE capability which determines if the device will link or embed an ICC profile with the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainIccProfileOption IccProfile { get; set; }
Public Property IccProfile As TwainIccProfileOption
    Get
    Set

Property Value

Type: TwainIccProfileOption
A value indicating whether the device will link or embed an ICC profile in the image.
Exceptions
Exception | Condition
 | Thrown if the state is less than SourceOpen for getting the value, or is not equal to SourceOpen when setting the value.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Identity Property

DeviceIdentity Property

Gets the device identity information.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainIdentity Identity { get; }
Public ReadOnly Property Identity As TwainIdentity
    Get

Property Value

Type: TwainIdentity
A TwainIdentity object containing information about the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.ImageCount Property

DeviceImageCount Property

Gets the number of available images.

This is only valid for devices which contain an internal buffer. You can find out if there are any pending images during an acquisition by checking the PendingImages property of the AcquireEventArgs class.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ImageCount { get; }
Public ReadOnly Property ImageCount As Integer
    Get

Property Value

Type: Int32
The number of available images.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.ImageLayout Property

DeviceImageLayout Property

Gets or sets the layout used when acquiring image data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainImageLayout ImageLayout { get; set; }
Public Property ImageLayout As TwainImageLayout
    Get
    Set

Property Value

Type: TwainImageLayout
The current image layout used.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
This is an extension to the Frame property to provide more information about the acquisition.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceFrame


Device.InterfaceControllable Property

DeviceInterfaceControllable Property

Gets a value indicating if the interface can be hidden during an acquire. If supported, you can hide the interface by setting the hideInterface parameter of the Acquire method.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool InterfaceControllable { get; }
Public ReadOnly Property InterfaceControllable As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the interface can be hidden during an acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceAcquire


Device.JobControl Property

DeviceJobControl Property

Gets or sets the type of batch acquisition job to perform.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchJobControl JobControl { get; set; }
Public Property JobControl As BatchJobControl
    Get
    Set

Property Value

Type: BatchJobControl
The current batch job format.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

Use the GetSupportedJobControls method to find out which, if any, batch types are supported by the device.

When processing a batch job, watch the EndOfJob property of the AcquireEventArgs to know when a batch has finished.

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.JpegPixelType Property

DeviceJpegPixelType Property

Gets or sets the pixel type used when Jpeg data is acquired.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePixelType JpegPixelType { get; set; }
Public Property JpegPixelType As ImagePixelType
    Get
    Set

Property Value

Type: ImagePixelType
The pixel type used.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

This property has no affect when the TransferMethod is Native. Some devices may require setting the TransferMethod before accessing this property.

Use the GetSupportedJpegPixelTypes to find valid values for the device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedJpegPixelTypes


Device.JpegQuality Property

DeviceJpegQuality Property

Gets or sets the Jpeg quality used during a file or memory transfer.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int JpegQuality { get; set; }
Public Property JpegQuality As Integer
    Get
    Set

Property Value

Type: Int32
The Jpeg quality used during a transfer.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Valid values are normally from 0 to 100. Use the GetSupportedJpegQualityValues to find valid values for the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedJpegQualityValues


Device.LampState Property

DeviceLampState Property

Gets or sets a value indicating if the lamp is currently, or should be to ON.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool LampState { get; set; }
Public Property LampState As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the lamp is currently, or should be to ON.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Language Property

DeviceLanguage Property

Gets or sets the language to use for the source device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LanguageType Language { get; set; }
Public Property Language As LanguageType
    Get
    Set

Property Value

Type: LanguageType
The language to use for the source device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.LastReturnCode Property

DeviceLastReturnCode Property

Gets the last TwainReturnCode from getting or setting a property.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainReturnCode LastReturnCode { get; }
Public ReadOnly Property LastReturnCode As TwainReturnCode
    Get

Property Value

Type: TwainReturnCode
The last return code from getting or setting a property.
Remarks

This property is used as a way to determine whether getting or setting a property value succeeded, rather than throwing an exception. By using a property it simplifies coding and there is no slow down when trying to access unsupported properties.

Use GetConditionCode to learn the reason for a failure.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetConditionCode


Device.LightPath Property

DeviceLightPath Property

Gets or sets a value which describes whether the image was captured transmissively or reflectively.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LightPathMode LightPath { get; set; }
Public Property LightPath As LightPathMode
    Get
    Set

Property Value

Type: LightPathMode
A value which describes whether the image was captured transmissively or reflectively.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedLightPathModes to find the modes supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedLightPathModes


Device.LightSource Property

DeviceLightSource Property

Gets or sets a value that describes the general color characteristic of the light source used to acquire the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LightSourceMode LightSource { get; set; }
Public Property LightSource As LightSourceMode
    Get
    Set

Property Value

Type: LightSourceMode
A value that describes the general color characteristic of the light source used to acquire the image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedLightSourceModes to find the modes supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedLightSourceModes


Device.MaxBatchBuffers Property

DeviceMaxBatchBuffers Property

Gets or sets the number of pages that the scanner can buffer when AutoScan is enabled.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxBatchBuffers { get; set; }
Public Property MaxBatchBuffers As Integer
    Get
    Set

Property Value

Type: Int32
The number of pages that the scanner can buffer when AutoScan is enabled.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedMaxBatchBuffers


Device.MaxFrames Property

DeviceMaxFrames Property

Gets or sets the maximum number of frames the device or application can accept.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int MaxFrames { get; set; }
Public Property MaxFrames As Integer
    Get
    Set

Property Value

Type: Int32
The number of frames the device can accept.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use the GetFrames and SetFrames(RectangleF) methods when dealing with multiple frames.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetFrames
DeviceSetFrames(RectangleF)
DeviceFrame


Device.MicrEnabled Property

DeviceMicrEnabled Property

Gets or sets the CAP_MICRENABLED capability which indicates if the scanner is enabled for MICR check scanning.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool MicrEnabled { get; set; }
Public Property MicrEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether MICR check scanning is enabled.
Exceptions
Exception | Condition
 | Thrown if the state is less than SourceOpen for getting the value, or is not equal to SourceOpen when setting the value.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.MinimumHeight Property

DeviceMinimumHeight Property

Gets the minimum height the source can acquire in Units.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float MinimumHeight { get; }
Public ReadOnly Property MinimumHeight As Single
    Get

Property Value

Type: Single
The minimum height the source can acquire in Units.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.MinimumWidth Property

DeviceMinimumWidth Property

Gets the minimum width the source can acquire in Units.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float MinimumWidth { get; }
Public ReadOnly Property MinimumWidth As Single
    Get

Property Value

Type: Single
The minimum width the source can acquire in Units.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.ModalAcquire Property

DeviceModalAcquire Property

Gets or sets a value indicating whether the Acquire method is synchronous or asynchronous.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ModalAcquire { get; set; }
Public Property ModalAcquire As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the Acquire method is synchronous.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceHideInterface


Device.NativeResolution Property

DeviceNativeResolution Property

Gets the native optical resolution of the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainResolution NativeResolution { get; }
Public ReadOnly Property NativeResolution As TwainResolution
    Get

Property Value

Type: TwainResolution
The native optical resolution of the device in pixels per Units.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedNativeResolutions to find the optic resolutions for the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedNativeResolutions


Device.NoiseFilter Property

DeviceNoiseFilter Property

Gets or sets the noise filter the source will use.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseFilterMode NoiseFilter { get; set; }
Public Property NoiseFilter As NoiseFilterMode
    Get
    Set

Property Value

Type: NoiseFilterMode
The noise filter the source will use.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use the GetSupportedNoiseFilterModes to find the filters supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedNoiseFilterModes


Device.Online Property

DeviceOnline Property

Gets a value indicating if the device is powered up and ready to use.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Online { get; }
Public ReadOnly Property Online As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the device is powered up and ready to use.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Orientation Property

DeviceOrientation Property

Gets or sets the orientation of the acquired image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OrientationMode Orientation { get; set; }
Public Property Orientation As OrientationMode
    Get
    Set

Property Value

Type: OrientationMode
The orientation of the acquired image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedOrientationModes to find the modes supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedOrientationModes


Device.Overscan Property

DeviceOverscan Property

Gets or sets a value indicating the type of overscan the source should perform.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverscanMode Overscan { get; set; }
Public Property Overscan As OverscanMode
    Get
    Set

Property Value

Type: OverscanMode
A value indicating the type of overscan the source should perform.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

Overscan is used to scan outside of the boundaries described by Frame, and is used to help acquire image data that may be lost because of skewing.

Use GetSupportedOverscanModes to find the modes supported by the device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedOverscanModes


Device.PaperDetectable Property

DevicePaperDetectable Property

Gets a value indicating if the device has a paper sensor.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PaperDetectable { get; }
Public ReadOnly Property PaperDetectable As Boolean
    Get

Property Value

Type: Boolean
A value indicating if the device has a paper sensor.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.PatchCode Property

DevicePatchCode Property

Gets the TwainBarCode object used to control patchcode features of the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainBarCode PatchCode { get; }
Public ReadOnly Property PatchCode As TwainBarCode
    Get

Property Value

Type: TwainBarCode
A TwainBarCode object.
Remarks
The DetectionEnabled property should be set to true before accessing any patchcode features.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceBarCode


Device.PhysicalHeight Property

DevicePhysicalHeight Property

Gets the maximum height in Units the source can acquire.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float PhysicalHeight { get; }
Public ReadOnly Property PhysicalHeight As Single
    Get

Property Value

Type: Single
The maximum height in Units the source can acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DevicePhysicalWidth


Device.PhysicalWidth Property

DevicePhysicalWidth Property

Gets the maximum width in Units the source can acquire.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float PhysicalWidth { get; }
Public ReadOnly Property PhysicalWidth As Single
    Get

Property Value

Type: Single
The maximum width in Units the source can acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DevicePhysicalHeight


Device.PixelFlavor Property

DevicePixelFlavor Property

Gets or sets a value indicating whether the image data uses the value 0 for the darkest color or the lightest color.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainPixelFlavor PixelFlavor { get; set; }
Public Property PixelFlavor As TwainPixelFlavor
    Get
    Set

Property Value

Type: TwainPixelFlavor
A value indicating the value of 0 in the image data.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Normally this is only used for 1-bit scans, though some devices allow its use for 8-bit grayscale as well.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.PixelType Property

DevicePixelType Property

Gets or sets the pixel format to acquire.

You should set this property before setting BitDepth.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePixelType PixelType { get; set; }
Public Property PixelType As ImagePixelType
    Get
    Set

Property Value

Type: ImagePixelType
The pixel format to acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

Do not assume the source will return the pixel format you ask for. This is only requesting that the image be returned in this format.

Use GetSupportedPixelTypes to find out which pixel types are supported by the device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedPixelTypes


Device.PowerSupply Property

DevicePowerSupply Property

Gets the type of power supply used for this camera.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PowerSupplyMode PowerSupply { get; }
Public ReadOnly Property PowerSupply As PowerSupplyMode
    Get

Property Value

Type: PowerSupplyMode
The type of power supply used for this camera.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedPowerSupplies to find the modes supported by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedPowerSupplies


Device.ReacquireAllowed Property

DeviceReacquireAllowed Property

Gets a value indicating whether the physical hardware is capable of acquiring multiple images of the same page without changes to the physical registration of that page.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ReacquireAllowed { get; }
Public ReadOnly Property ReacquireAllowed As Boolean
    Get

Property Value

Type: Boolean
A value indicating whether the physical hardware is capable of acquiring multiple images of the same page without changes to the physical registration of that page.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Resolution Property

DeviceResolution Property

Gets or sets the number of pixels per unit as specified by the Units property.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainResolution Resolution { get; set; }
Public Property Resolution As TwainResolution
    Get
    Set

Property Value

Type: TwainResolution
The number of pixels per unit as specified by the Units property.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

When setting this property, the Units property will also be set automatically.

Use GetSupportedResolutions to find the resolutions supported by the device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedResolutions


Device.Rotation Property

DeviceRotation Property

Gets or sets the amount to rotate the image by the Source.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Rotation { get; set; }
Public Property Rotation As Single
    Get
    Set

Property Value

Type: Single
The amount to rotate the image by the Source.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
This amount is additive to any rotation done in Orientation. Normal values are in degrees from -360 to 360, but GetSupportedRotations should be used to find the valid values for the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedRotations


Device.Scaling Property

DeviceScaling Property

Gets or sets the amount of scaling the Source will perform on the image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF Scaling { get; set; }
Public Property Scaling As SizeF
    Get
    Set

Property Value

Type: SizeF
The amount of scaling the Source will perform on the image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

Units does not affect this property. A value of 1.0 is equivalent to 100% (no change).

Use GetSupportedScalingValues to find valid values for this device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedScalingValues


Device.SerialNumber Property

DeviceSerialNumber Property

Gets a string containing the serial number of this device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get

Property Value

Type: String
A string containing the serial number of this device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Multiple devices may all report the same serial number.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Shadow Property

DeviceShadow Property

Gets or sets the value in an image which should be interpreted as the darkest shadow.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Shadow { get; set; }
Public Property Shadow As Single
    Get
    Set

Property Value

Type: Single
The value in an image which should be interpreted as the darkest shadow.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
All values darker than this value will be clipped to this value. Valid values are usually from 0 to 255, but GetSupportedShadowValues should be used to find valid values for the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceHighlight
DeviceGetSupportedShadowValues


Device.State Property

DeviceState Property

Gets a value indicating the current Twain state.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainState State { get; }
Public ReadOnly Property State As TwainState
    Get

Property Value

Type: TwainState
The current Twain state.
Remarks
This can be used to help keep track of where the device is at in the acquisition. Some states will change based on the actions of the developer, such as calling the Open method. Other states are controlled by the device, such as ReadyToTransfer and Transferring.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.ThreadingEnabled Property

DeviceThreadingEnabled Property

Gets or sets a value indicating whether to perform the scanning in a separate thread. See the remarks below for threading limitations.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ThreadingEnabled { get; set; }
Public Property ThreadingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether the scanning will run in a separate thread.
Remarks

In order for threading to be enabled, the following items are required:

The ModalAcquire property must be set to false.The parent control provided to the Acquisition object must derive from System.Windows.Forms.Control. If the parent is set to null (Nothing in VB), DotTwain will create a compatible hidden window: Be aware that some drivers will fail to function when the window is hidden.The driver must not be WIA.

NOTE: To run the scanning in a separate thread, the Device will be closed and a new Device instance will be created for scanning in the worker thread: This is required by the TWAIN specification. You will not be able to access any device properties or methods during the scan and will have to re-open the device after the scan if access to properties or methods are needed.

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Threshold Property

DeviceThreshold Property

Gets or sets the dividing line between black and white for 1-bit acquires.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float Threshold { get; set; }
Public Property Threshold As Single
    Get
    Set

Property Value

Type: Single
The dividing line between black and white for 1-bit acquires.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Valid values are usually from 0 to 255. Use GetSupportedThresholdValues to find valid values for the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedThresholdValues


Device.ThumbnailEnabled Property

DeviceThumbnailEnabled Property

Gets or sets a value indicating if a thumbnail should be returned instead of the full size image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ThumbnailEnabled { get; set; }
Public Property ThumbnailEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if a thumbnail should be returned instead of the full size image.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.TransferCount Property

DeviceTransferCount Property

Gets or sets the number of images your application is willing to accept.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TransferCount { get; set; }
Public Property TransferCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of images your application is willing to accept.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Set this value to -1 for unlimited acquires during a single session.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.TransferMethod Property

DeviceTransferMethod Property

Gets or sets the transfer method used when acquiring data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainTransferMethod TransferMethod { get; set; }
Public Property TransferMethod As TwainTransferMethod
    Get
    Set

Property Value

Type: TwainTransferMethod
The transfer method used by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
This property should be set before calling the Acquire method. Some drivers require setting this property before allowing access to other properties; such as setting TransferMethod to File before setting the FileFormat property.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Units Property

DeviceUnits Property

Gets or sets a value indicating the units of measure for this acquire.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnitType Units { get; set; }
Public Property Units As UnitType
    Get
    Set

Property Value

Type: UnitType
A value indicating the units of measure for this acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks

This property affects the values of other measurement properties for the source.

Use GetSupportedUnitTypes to find valid units for this device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedUnitTypes


Device.ZoomFactor Property

DeviceZoomFactor Property

Gets or sets the zoom factor to use for the acquire.

Valid values for this property are source defined.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int ZoomFactor { get; set; }
Public Property ZoomFactor As Integer
    Get
    Set

Property Value

Type: Int32
The zoom factor to use for the acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
Use GetSupportedZoomFactors to obtain an array of valid values.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedZoomFactors


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
 | Acquire | Acquires an image from this device.
Public method | CanOpen | Obsolete. This method may be removed in a future version. New applications should use the TryOpen method instead. Returns a value indicating whether or not the Open method can currently be used on the device.
Public method | ClearBuffers | This lets you choose how the device should handle its buffer clearing procedure.
Public method | Close | Closes the connection with the device previously opened. Calling this method when an image is being acquired will cancel the acquisition and any pending transfers. If you want to close the connection after all images have been transferred, you should do so in the AcquireFinished event.
Public method | Disable | This method will disable and hide the device interface. This only needs to be called if the Enable method is used to display the interface or invoke scanning.
Public method | Dispose | Releases resources used by the device when created from the CreateDeviceSession(String) method. This should not be used for Device objects in the DeviceCollection.
Public method | Enable | This method can be used to display the device interface and invoke an acquisition instead of using Acquire.
Public method | EnableCamera | Use this method to enable or disable cameras used when scanning.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Calls Close() (Overrides ObjectFinalize.)
Public method | GetConditionCode | Returns the condition code from the last Twain operation. This can provide more information about a failure when getting or setting a Device property.
Public method | GetFrames | Returns an array containing the current frames set for a device.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetQueryOperations | Returns the operations supported for a specific capability.
Public method | GetSupportedBarCodes | Returns the barcodes supported by the device.
Public method | GetSupportedBitDepthReductionModes | Returns the BitDepthReductionModes supported by the device.
Public method | GetSupportedBitDepths | Returns the supported bit depth values for the current PixelType.
Public method | GetSupportedBrightnessValues | Returns the brightness values supported by the device.
Public method | GetSupportedCapabilities | Returns a list of all the capabilities for which the Source will answer inquiries.
Public method | GetSupportedCompressionModes | Returns the supported compression modes for this device.
Public method | GetSupportedContrastValues | Returns the contrast values supported by the device.
Public method | GetSupportedExposureTimes | Returns an array of exposure times supported by the device.
Public method | GetSupportedExtendedCapabilities | Returns the extended capabilities supported by the device.
Public method | GetSupportedFlashModes | Returns the flash modes supported by the device.
Public method | GetSupportedFrameSizes | Returns the frame sizes supported by the device.
Public method | GetSupportedHalftones | Returns the halftone values supported by the device.
Public method | GetSupportedHighlightValues | Returns the highlight values supported by the device.
Public method | GetSupportedIccProfileOptions | Returns an array of TwainIccProfileOption values indicating what type of ICC profiles are supported by the device.
Public method | GetSupportedImageFilters | Returns the image filters supported by the device.
 | GetSupportedImageFormats | Returns a list of the file formats supported by this device.
Public method | GetSupportedJobControls | Returns the job controls supported by the device.
Public method | GetSupportedJpegPixelTypes | Returns the Jpeg pixel types supported by the device.
Public method | GetSupportedJpegQualityValues | Returns the Jpeg quality values supported by the device.
Public method | GetSupportedLanguageTypes | Returns the language types supported by the device.
Public method | GetSupportedLightPathModes | Returns the light path modes supported by the device.
Public method | GetSupportedLightSourceModes | Returns the light source modes supported by the device.
Public method | GetSupportedMaxBatchBuffers | Returns the supported maximum batch buffers for the device.
Public method | GetSupportedNativeResolutions | Returns the native resolution values for the device.
Public method | GetSupportedNoiseFilterModes | Returns the noise filter modes supported by the device.
Public method | GetSupportedOrientationModes | Returns the orientation modes supported by the device.
Public method | GetSupportedOverscanModes | Returns the overscan modes supported by the device.
Public method | GetSupportedPatchCodes | Returns the patchcodes supported by the device.
Public method | GetSupportedPixelTypes | Returns the pixel types supported by the device.
Public method | GetSupportedPowerSupplies | Returns the supported power supplies for the device.
Public method | GetSupportedPrinterModes | Returns the printer modes supported by the device.
Public method | GetSupportedPrinters | Finds the type of imprinter or endorser supported by this device. These can be used to set which imprinter or endorser to use in the SetImprinterEndorser method.
Public method | GetSupportedResolutions | Returns supported resolution values for the device.
Public method | GetSupportedRotations | Returns the rotations supported by the device.
Public method | GetSupportedScalingValues | Returns scaling values supported by the device.
Public method | GetSupportedShadowValues | Returns the shadow values supported by the device.
Public method | GetSupportedThresholdValues | Returns the threshold values supported by the device.
Public method | GetSupportedTransferMethods | Returns the transfer methods supported by the device.
Public method | GetSupportedUnitTypes | Returns the unit values supported by the device.
Public method | GetSupportedZoomFactors | Returns an array of valid zoom factors for this device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadParameters | Loads previously saved device parameters into the device.
Public method | LoadXmlParameters | Load device parameter data saved with the SaveXmlParameters(Stream) method.
Public method | Open | Opens a connection to this device. You must open a connection to the device before getting or setting any device properties. If you don't need to get or set any properties, you can call the Acquire method without using the Open or Close methods. TryOpen is the preferred way to open a connection to the device.
Public method | PreFilterMessage | Filters out a message before it is dispatched.
 | QueryCapability | Determines if a capability is available from the device. It's unlikely that any one device supports all of the properties and features. You can use this method to find out if a property is get-able and/or set-able. This can also be used to help determine if the device is a camera by checking for camera specific properties, such as FlashUsed or BatteryPercentage.
Public method | SaveParameters | Saves the current device parameters to a stream.
Public method | SaveXmlParameters | Saves device property values into XML format.
Public method | SetCameraPixelOrder | Sets the pixel order for each enabled camera.
Public method | SetExtendedCapabilities | Sets the extended capabilities your application needs to negotiate during states 5 and 6 of a Twain session.
Public method | SetExtendedImageInfoOptions | Sets the extended image information options to obtain after acquiring the data.
Public method | SetFrames | Sets multiple frames to acquire from when scanning.
Public method | SetImageDataset | Sets the indices of the images you want to acquire. This is useful when you want to acquire multiple images from a camera with a single call to the Acquire method.
Public method | SetImprinterEndorser(ImprinterEndorserType, Boolean) | Use this method to enable or disable an imprinter or endorser.
Public method | SetImprinterEndorser(ImprinterEndorserType, ImprinterEndorserMode, String, Int32, String) | Use this method to enable an imprinter or endorser and set its parameters.
Public method | ShowUserInterface | Displays the device interface. This operation is used by applications that wish to display the device user interface to allow the user to manipulate the devices current settings for resolution, paper size, etc. but not acquire an image.
Public method | StartAutomaticCapture | Starts an automatic capture process. This method does not acquire the images. Automatic capture implies that the device is capable of capturing images without the presence of the Application. This means that it must be possible for the Application to close the device and reopen it later, after the images have been captured.
Public method | ToString | A string which describes this object. (Overrides ObjectToString.)
 | TryOpen | This method will attempt to open a connection to the device and will return true if it was successful. It's preferred to use this method instead of the Open method. The Close method must be called when you are finished using the device.
Top
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Acquire Method

DeviceAcquire Method

Acquires an image from this device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Acquire()
Public Sub Acquire
Remarks

NOTE: If ThreadingEnabled is set to true, the Device will be closed and a new Device instance will be created for scanning in the worker thread: This is required by the TWAIN specification. You will not be able to access any device properties or methods during the scan and will have to re-open the device after the scan if access to properties or methods are needed.

Examples
FileTransfer Event
Examples
AcquireCS (C#)
Copy
private void menuAcquire_Click(object sender, System.EventArgs e)
{
    if (this.device == null)
        this.device = this.acquisition.Devices.Default;

    try
    {
        this.device.Open();

    }
    catch (Exception ex)
    {
        MessageBox.Show(ex.Message);
        return;
    }

    if (!SetTransferMethod())
    {
        this.device.Close();
        return;
    }

    this.device.Frame = this.scanRect.ToRectangleF();
    if (this.scanResolution != null)
        this.device.Resolution = new TwainResolution(this.scanResolution.X, this.scanResolution.Y, this.scanResolution.Units);

    this.device.HideInterface = this.menuHideInterface.Checked;
    this.device.ModalAcquire = this.menuAcquireModal.Checked;

    this.device.Acquire();
}
AcquireVB (Visual Basic)
Copy
Private  Sub menuAcquire_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    If Me.device Is Nothing Then
        Me.device = Me.acquisition.Devices.Default
    End If

    Try
        Me.device.Open()

    Catch ex As Exception
        MessageBox.Show(ex.Message)
        Return
    End Try

    If Not SetTransferMethod() Then
        Me.device.Close()
        Return
    End If

    Me.device.Frame = Me.scanRect.ToRectangleF()
    If Not Me.scanResolution Is Nothing Then
        Me.device.Resolution = New TwainResolution(Me.scanResolution.X, Me.scanResolution.Y, Me.scanResolution.Units)
    End If

    Me.device.HideInterface = Me.menuHideInterface.Checked
    Me.device.ModalAcquire = Me.menuAcquireModal.Checked

    Me.device.Acquire()
End Sub
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.CanOpen Method

DeviceCanOpen Method

Note: This API is now obsolete.

This method may be removed in a future version. New applications should use the TryOpen method instead.

Returns a value indicating whether or not the Open method can currently be used on the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[ObsoleteAttribute("CanOpen may be removed in a future release. Use TryOpen instead.",
    false)]
public bool CanOpen()
<ObsoleteAttribute("CanOpen may be removed in a future release. Use TryOpen instead.",
    false)>
Public Function CanOpen As Boolean

Return Value

Type: Boolean
True if the Open method can currently be used on the device.
Remarks

Use this method to test if a device is available instead of using the Open method and catching the exception if it fails.

This method will return false if the device is already open.

Some drivers will display a message box when the device is not connected or powered off. DotTwain has no control over this message box

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.ClearBuffers Method

DeviceClearBuffers Method

This lets you choose how the device should handle its buffer clearing procedure.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearBuffers(
    ClearBufferMode mode
)
Public Sub ClearBuffers (
    mode As ClearBufferMode
)

Parameters

mode
Type: Atalasoft.TwainClearBufferMode
The clear mode to use.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Remarks
This only has affect on devices with internal memory buffers.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Close Method

DeviceClose Method

Closes the connection with the device previously opened.

Calling this method when an image is being acquired will cancel the acquisition and any pending transfers. If you want to close the connection after all images have been transferred, you should do so in the AcquireFinished event.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
Remarks
If you call the Open method, you must call the Close method when finished with the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceOpen


Device.Disable Method

DeviceDisable Method

This method will disable and hide the device interface. This only needs to be called if the Enable method is used to display the interface or invoke scanning.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Disable()
Public Sub Disable
Exceptions
Exception | Condition
 | Thrown if there is a Twain error while closing the interface.
Remarks
The user will have to click the 'Cancel' button to close the interface when Enable is used. The Disable method should be called in the AcquireCanceled event before using the Close method.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Dispose Method

DeviceDispose Method

Releases resources used by the device when created from the CreateDeviceSession(String) method. This should not be used for Device objects in the DeviceCollection.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Enable Method

DeviceEnable Method

This method can be used to display the device interface and invoke an acquisition instead of using Acquire.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Enable()
Public Sub Enable
Exceptions
Exception | Condition
 | Thrown if the current State is not TwainState.SourceOpen.
 | Thrown if there is a Twain error while enabling the interface.
Remarks

The normal Acquire method will close the device interface after all items have been transferred. Using the Enable method allows the device interface to remain open after the acquire, and will only close when the Disable method is called.

By default, Enable is an asynchronous method and will return before the transfer has completed. Setting the ModalAcquire property can force this method to wait until the acquisition has finished before returning.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceDisable


Device.EnableCamera Method

DeviceEnableCamera Method

Use this method to enable or disable cameras used when scanning.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool EnableCamera(
    TwainCameraSide camera,
    bool enabled
)
Public Function EnableCamera (
    camera As TwainCameraSide,
    enabled As Boolean
) As Boolean

Parameters

camera
Type: Atalasoft.TwainTwainCameraSide
The camera to affect.
enabled
Type: SystemBoolean
A value indicating whether the camera should be enabled. Pass in false to disable the camera.

Return Value

Type: Boolean
Exceptions
Exception | Condition
 | Thrown if the state is not SourceOpen.
Remarks
In addition to enabling a camera, some scanners allow each camera to have different capability values. However, there is no way to query whether a device supports this. For a best guess, try setting one capability after enabling a camera, then enable another camera to see if that property value has also changed. If the other camera capability has changed, the device does not support individual camera settings.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Finalize Method

DeviceFinalize Method

Calls Close()

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.GetConditionCode Method

DeviceGetConditionCode Method

Returns the condition code from the last Twain operation. This can provide more information about a failure when getting or setting a Device property.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainConditionCode GetConditionCode()
Public Function GetConditionCode As TwainConditionCode

Return Value

Type: TwainConditionCode
A condition code providing more information about the last Twain operation.
Exceptions
Exception | Condition
 | Thrown if the source manager is not open.
Remarks
This method is useful if the LastReturnCode property is not TWRC_SUCCESS after getting or setting a property.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceLastReturnCode


Device.GetFrames Method

DeviceGetFrames Method

Returns an array containing the current frames set for a device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public RectangleF[] GetFrames()
Public Function GetFrames As RectangleF()

Return Value

Type: RectangleF
An array of RectangleF representing the device frames.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Remarks

Some devices allow multiple areas of a document to be scanned and returned as separate images. This method returns all of the frames currently set to be acquired.

To specify multiple frames to acquire, use the SetFrames(RectangleF) method.

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.GetQueryOperations Method

DeviceGetQueryOperations Method

Returns the operations supported for a specific capability.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public QueryOperation GetQueryOperations(
    DeviceCapability capability
)
Public Function GetQueryOperations (
    capability As DeviceCapability
) As QueryOperation

Parameters

capability
Type: Atalasoft.TwainDeviceCapability
The capability to test.

Return Value

Type: QueryOperation
A QueryOperation value for all supported operations.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.GetSupportedBarCodes Method

DeviceGetSupportedBarCodes Method

Returns the barcodes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BarCodeType[] GetSupportedBarCodes()
Public Function GetSupportedBarCodes As BarCodeType()

Return Value

Type: BarCodeType
An array of BarCodeType specifying which barcodes can be detected by the device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedPatchCodes


Device.GetSupportedBitDepthReductionModes Method

DeviceGetSupportedBitDepthReductionModes Method

Returns the BitDepthReductionModes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BitDepthReductionMode[] GetSupportedBitDepthReductionModes()
Public Function GetSupportedBitDepthReductionModes As BitDepthReductionMode()

Return Value

Type: BitDepthReductionMode
An array of BitDepthReductionMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Remarks
If the device supports the BitDepthReduction property, this method will provide a list of valid values for this property.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.GetSupportedBitDepths Method

DeviceGetSupportedBitDepths Method

Returns the supported bit depth values for the current PixelType.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedBitDepths()
Public Function GetSupportedBitDepths As Integer()

Return Value

Type: Int32
An array of bit depth values for the current PixelType.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Remarks
This method only returns the bit depth values supported by the current PixelType. To get all possible bit depths, call this method for each PixelType.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceBitDepth
DevicePixelType


Device.GetSupportedBrightnessValues Method

DeviceGetSupportedBrightnessValues Method

Returns the brightness values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] GetSupportedBrightnessValues()
Public Function GetSupportedBrightnessValues As Single()

Return Value

Type: Single
An array of brightness values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceBrightness


Device.GetSupportedCapabilities Method

DeviceGetSupportedCapabilities Method

Returns a list of all the capabilities for which the Source will answer inquiries.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeviceCapability[] GetSupportedCapabilities()
Public Function GetSupportedCapabilities As DeviceCapability()

Return Value

Type: DeviceCapability
An array of DeviceCapability values.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Remarks
This does not indicate which capabilities the Source will allow to be set by the application. Some capabilities can only be set if certain setup work has been done, so the Source cannot globally answer which capabilities are set-able.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.GetSupportedCompressionModes Method

DeviceGetSupportedCompressionModes Method

Returns the supported compression modes for this device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public CompressionMode[] GetSupportedCompressionModes()
Public Function GetSupportedCompressionModes As CompressionMode()

Return Value

Type: CompressionMode
An array of CompressionMode.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceCompression


Device.GetSupportedContrastValues Method

DeviceGetSupportedContrastValues Method

Returns the contrast values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] GetSupportedContrastValues()
Public Function GetSupportedContrastValues As Single()

Return Value

Type: Single
An array of contrast values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceContrast


Device.GetSupportedExposureTimes Method

DeviceGetSupportedExposureTimes Method

Returns an array of exposure times supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedExposureTimes()
Public Function GetSupportedExposureTimes As Integer()

Return Value

Type: Int32
An array of exposure times supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceExposureTime


Device.GetSupportedExtendedCapabilities Method

DeviceGetSupportedExtendedCapabilities Method

Returns the extended capabilities supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeviceCapability[] GetSupportedExtendedCapabilities()
Public Function GetSupportedExtendedCapabilities As DeviceCapability()

Return Value

Type: DeviceCapability
An array of DeviceCapabilities the device will allow.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Remarks
Extended capabilities are used in the SourceEnabled and ReadyToTransfer states.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceSetExtendedCapabilities(DeviceCapability)


Device.GetSupportedFlashModes Method

DeviceGetSupportedFlashModes Method

Returns the flash modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlashMode[] GetSupportedFlashModes()
Public Function GetSupportedFlashModes As FlashMode()

Return Value

Type: FlashMode
An array of FlashMode supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Remarks
This represents the ICAP_FLASHUSED2 device capability.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceFlashUsed


Device.GetSupportedFrameSizes Method

DeviceGetSupportedFrameSizes Method

Returns the frame sizes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public StaticFrameSizeType[] GetSupportedFrameSizes()
Public Function GetSupportedFrameSizes As StaticFrameSizeType()

Return Value

Type: StaticFrameSizeType
An array of StaticFrameSizeType specifying the supported sizes for the source.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
Atalasoft.TwainStaticFrameSizeType


Device.GetSupportedHalftones Method

DeviceGetSupportedHalftones Method

Returns the halftone values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string[] GetSupportedHalftones()
Public Function GetSupportedHalftones As String()

Return Value

Type: String
An array of string values specifying the halftones supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceHalftone


Device.GetSupportedHighlightValues Method

DeviceGetSupportedHighlightValues Method

Returns the highlight values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] GetSupportedHighlightValues()
Public Function GetSupportedHighlightValues As Single()

Return Value

Type: Single
An array of values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceHighlight


Device.GetSupportedIccProfileOptions Method

DeviceGetSupportedIccProfileOptions Method

Returns an array of TwainIccProfileOption values indicating what type of ICC profiles are supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainIccProfileOption[] GetSupportedIccProfileOptions()
Public Function GetSupportedIccProfileOptions As TwainIccProfileOption()

Return Value

Type: TwainIccProfileOption
An array of supported ICC profile options.
Exceptions
Exception | Condition
 | Thrown if the state is less than SourceOpen.
Remarks
If the device supports linking or embedding ICC profiles, this feature can be set using the IccProfile property.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceIccProfile


Device.GetSupportedImageFilters Method

DeviceGetSupportedImageFilters Method

Returns the image filters supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImageFilterMode[] GetSupportedImageFilters()
Public Function GetSupportedImageFilters As ImageFilterMode()

Return Value

Type: ImageFilterMode
An array of ImageFilterMode supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceFilter


Device.GetSupportedImageFormats Method

DeviceGetSupportedImageFormats Method

Returns a list of the file formats supported by this device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SourceImageFormat[] GetSupportedImageFormats()
Public Function GetSupportedImageFormats As SourceImageFormat()

Return Value

Type: SourceImageFormat
An array of supported SourceImageFormat.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
Examples
FileTransfer Event
See Also

Reference

Device Class
Atalasoft.Twain Namespace
Atalasoft.TwainSourceImageFormat


Device.GetSupportedJobControls Method

DeviceGetSupportedJobControls Method

Returns the job controls supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public BatchJobControl[] GetSupportedJobControls()
Public Function GetSupportedJobControls As BatchJobControl()

Return Value

Type: BatchJobControl
An array of BatchJobControl values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceJobControl


Device.GetSupportedJpegPixelTypes Method

DeviceGetSupportedJpegPixelTypes Method

Returns the Jpeg pixel types supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePixelType[] GetSupportedJpegPixelTypes()
Public Function GetSupportedJpegPixelTypes As ImagePixelType()

Return Value

Type: ImagePixelType
An array of ImagePixelType supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceJpegPixelType


Device.GetSupportedJpegQualityValues Method

DeviceGetSupportedJpegQualityValues Method

Returns the Jpeg quality values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedJpegQualityValues()
Public Function GetSupportedJpegQualityValues As Integer()

Return Value

Type: Int32
An array of Jpeg quality values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceJpegQuality


Device.GetSupportedLanguageTypes Method

DeviceGetSupportedLanguageTypes Method

Returns the language types supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LanguageType[] GetSupportedLanguageTypes()
Public Function GetSupportedLanguageTypes As LanguageType()

Return Value

Type: LanguageType
An array of LanguageType indicating the languages supported by the device driver.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceLanguage


Device.GetSupportedLightPathModes Method

DeviceGetSupportedLightPathModes Method

Returns the light path modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LightPathMode[] GetSupportedLightPathModes()
Public Function GetSupportedLightPathModes As LightPathMode()

Return Value

Type: LightPathMode
An array of LightPathMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceLightPath


Device.GetSupportedLightSourceModes Method

DeviceGetSupportedLightSourceModes Method

Returns the light source modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public LightSourceMode[] GetSupportedLightSourceModes()
Public Function GetSupportedLightSourceModes As LightSourceMode()

Return Value

Type: LightSourceMode
An array of LightSourceMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceLightSource


Device.GetSupportedMaxBatchBuffers Method

DeviceGetSupportedMaxBatchBuffers Method

Returns the supported maximum batch buffers for the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedMaxBatchBuffers()
Public Function GetSupportedMaxBatchBuffers As Integer()

Return Value

Type: Int32
An array of values indicating the supported maximum batch buffers.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceMaxBatchBuffers


Device.GetSupportedNativeResolutions Method

DeviceGetSupportedNativeResolutions Method

Returns the native resolution values for the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainResolution[] GetSupportedNativeResolutions()
Public Function GetSupportedNativeResolutions As TwainResolution()

Return Value

Type: TwainResolution
An array of TwainResolution containing the supported native resolution values.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceNativeResolution


Device.GetSupportedNoiseFilterModes Method

DeviceGetSupportedNoiseFilterModes Method

Returns the noise filter modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public NoiseFilterMode[] GetSupportedNoiseFilterModes()
Public Function GetSupportedNoiseFilterModes As NoiseFilterMode()

Return Value

Type: NoiseFilterMode
An array of NoiseFilterMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceNoiseFilter


Device.GetSupportedOrientationModes Method

DeviceGetSupportedOrientationModes Method

Returns the orientation modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OrientationMode[] GetSupportedOrientationModes()
Public Function GetSupportedOrientationModes As OrientationMode()

Return Value

Type: OrientationMode
An array of OrientationMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceOrientation


Device.GetSupportedOverscanModes Method

DeviceGetSupportedOverscanModes Method

Returns the overscan modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public OverscanMode[] GetSupportedOverscanModes()
Public Function GetSupportedOverscanModes As OverscanMode()

Return Value

Type: OverscanMode
An array of OverscanMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceOverscan


Device.GetSupportedPatchCodes Method

DeviceGetSupportedPatchCodes Method

Returns the patchcodes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PatchCodeType[] GetSupportedPatchCodes()
Public Function GetSupportedPatchCodes As PatchCodeType()

Return Value

Type: PatchCodeType
An array of PatchCodeType specifying the patchcodes the device can detect.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedBarCodes


Device.GetSupportedPixelTypes Method

DeviceGetSupportedPixelTypes Method

Returns the pixel types supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImagePixelType[] GetSupportedPixelTypes()
Public Function GetSupportedPixelTypes As ImagePixelType()

Return Value

Type: ImagePixelType
An array of ImagePixelType values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DevicePixelType


Device.GetSupportedPowerSupplies Method

DeviceGetSupportedPowerSupplies Method

Returns the supported power supplies for the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PowerSupplyMode[] GetSupportedPowerSupplies()
Public Function GetSupportedPowerSupplies As PowerSupplyMode()

Return Value

Type: PowerSupplyMode
An array of PowerSupplyModes supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DevicePowerSupply


Device.GetSupportedPrinterModes Method

DeviceGetSupportedPrinterModes Method

Returns the printer modes supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImprinterEndorserMode[] GetSupportedPrinterModes()
Public Function GetSupportedPrinterModes As ImprinterEndorserMode()

Return Value

Type: ImprinterEndorserMode
An array of ImprinterEndorserMode values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
[M:SetImprinterEndorser]


Device.GetSupportedPrinters Method

DeviceGetSupportedPrinters Method

Finds the type of imprinter or endorser supported by this device. These can be used to set which imprinter or endorser to use in the SetImprinterEndorser method.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public ImprinterEndorserType[] GetSupportedPrinters()
Public Function GetSupportedPrinters As ImprinterEndorserType()

Return Value

Type: ImprinterEndorserType
A bit flag value of ImprinterEndorserType specifying which printers are supported.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
Device.SetImprinterEndorser


Device.GetSupportedResolutions Method

DeviceGetSupportedResolutions Method

Returns supported resolution values for the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainResolution[] GetSupportedResolutions()
Public Function GetSupportedResolutions As TwainResolution()

Return Value

Type: TwainResolution
An array of valid resolutions for this source.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceResolution


Device.GetSupportedRotations Method

DeviceGetSupportedRotations Method

Returns the rotations supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] GetSupportedRotations()
Public Function GetSupportedRotations As Single()

Return Value

Type: Single
An array of supported rotation values.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceRotation


Device.GetSupportedScalingValues Method

DeviceGetSupportedScalingValues Method

Returns scaling values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public SizeF[] GetSupportedScalingValues()
Public Function GetSupportedScalingValues As SizeF()

Return Value

Type: SizeF
An array of SizeF values specifying the supported scaling.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceScaling


Device.GetSupportedShadowValues Method

DeviceGetSupportedShadowValues Method

Returns the shadow values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] GetSupportedShadowValues()
Public Function GetSupportedShadowValues As Single()

Return Value

Type: Single
An array of shadow values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceShadow


Device.GetSupportedThresholdValues Method

DeviceGetSupportedThresholdValues Method

Returns the threshold values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public float[] GetSupportedThresholdValues()
Public Function GetSupportedThresholdValues As Single()

Return Value

Type: Single
An array of threshold values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceThreshold


Device.GetSupportedTransferMethods Method

DeviceGetSupportedTransferMethods Method

Returns the transfer methods supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainTransferMethod[] GetSupportedTransferMethods()
Public Function GetSupportedTransferMethods As TwainTransferMethod()

Return Value

Type: TwainTransferMethod
An array of TwainTransferMethod values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceTransferMethod


Device.GetSupportedUnitTypes Method

DeviceGetSupportedUnitTypes Method

Returns the unit values supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public UnitType[] GetSupportedUnitTypes()
Public Function GetSupportedUnitTypes As UnitType()

Return Value

Type: UnitType
An array of UnitType values supported by the device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceUnits


Device.GetSupportedZoomFactors Method

DeviceGetSupportedZoomFactors Method

Returns an array of valid zoom factors for this device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int[] GetSupportedZoomFactors()
Public Function GetSupportedZoomFactors As Integer()

Return Value

Type: Int32
An array of valid zoom factors for this device.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is a Twain error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceZoomFactor


Device.LoadParameters Method

DeviceLoadParameters Method

Loads previously saved device parameters into the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadParameters(
    Stream stream
)
Public Sub LoadParameters (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing the device parameters.
Exceptions
Exception | Condition
 | Thrown if the stream argument is null.
 | Thrown if the stream is not seekable or if it does not have read access.
 | Thrown is there is an error loading these parameters.
 | Thrown if a connection to the device is not open.
Remarks

Use this method along with SaveParameters(Stream) to hold onto the property settings users have selected for a device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceSaveParameters(Stream)


Device.LoadXmlParameters Method

DeviceLoadXmlParameters Method

Load device parameter data saved with the SaveXmlParameters(Stream) method.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void LoadXmlParameters(
    Stream stream
)
Public Sub LoadXmlParameters (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream containing the data.
Remarks
When using this method be sure to call it after each Open, otherwise the device may revert to its default settings.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.Open Method

DeviceOpen Method

Opens a connection to this device.

You must open a connection to the device before getting or setting any device properties. If you don't need to get or set any properties, you can call the Acquire method without using the Open or Close methods.

TryOpen is the preferred way to open a connection to the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void Open()
Public Sub Open
Exceptions
Exception | Condition
 | Thrown if there is an error while opening the device connection.
Remarks

A preferred method may be to use TryOpen instead of catching an exception if Open fails.

You must Close a connection to the device if you open it.

Use the CanOpen method to determine if a device is currently in use.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceClose


Device.PreFilterMessage Method

DevicePreFilterMessage Method

Filters out a message before it is dispatched.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool PreFilterMessage(
    ref Message m
)
Public Function PreFilterMessage (
    ByRef m As Message
) As Boolean

Parameters

m
Type: System.Windows.FormsMessage
The message to be dispatched. You cannot modify this message.

Return Value

Type: Boolean
true to filter the message and stop it from being dispatched; false to allow the message to continue to the next filter or control.

Implements

IMessageFilterPreFilterMessage(Message)
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.QueryCapability Method

DeviceQueryCapability Method

Determines if a capability is available from the device.

It's unlikely that any one device supports all of the properties and features. You can use this method to find out if a property is get-able and/or set-able. This can also be used to help determine if the device is a camera by checking for camera specific properties, such as FlashUsed or BatteryPercentage.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool QueryCapability(
    DeviceCapability capability,
    bool canSet
)
Public Function QueryCapability (
    capability As DeviceCapability,
    canSet As Boolean
) As Boolean

Parameters

capability
Type: Atalasoft.TwainDeviceCapability
The capability you want to check.
canSet
Type: SystemBoolean
If true, this method checks to see if this capability can also be set.

Return Value

Type: Boolean
True if the capability is available.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
Examples
QueryCapability (C#)
Copy
Device dev = this.acquisition.Devices.Default;
dev.Open();

// See if you can set the Resolution.
bool canSetRes = dev.QueryCapability(DeviceCapability.ResolutionX, true);

dev.Close();
QueryCapability (Visual Basic)
Copy
Dim dev As Device =  Me.acquisition.Devices.Default
dev.Open()

' See if you can set the Resolution.
Dim canSetRes As Boolean =  dev.QueryCapability(DeviceCapability.ResolutionX,True)

dev.Close()
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.SaveParameters Method

DeviceSaveParameters Method

Saves the current device parameters to a stream.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int SaveParameters(
    Stream stream
)
Public Function SaveParameters (
    stream As Stream
) As Integer

Parameters

stream
Type: System.IOStream
The stream where device data will be saved.

Return Value

Type: Int32
The number of bytes saved into the stream.
Exceptions
Exception | Condition
 | Thrown if the stream is null (Nothing in VB).
 | Thrown if the stream does not have write access.
 | Thrown if there is an error during processing.
 | Thrown if a connection to the device is not open.
Remarks

Use this method along with LoadParameters(Stream) to hold onto the property settings users have selected for a device.

See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceLoadParameters(Stream)


Device.SaveXmlParameters Method

DeviceSaveXmlParameters Method

Saves device property values into XML format.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SaveXmlParameters(
    Stream stream
)
Public Sub SaveXmlParameters (
    stream As Stream
)

Parameters

stream
Type: System.IOStream
A stream where the XML data will be saved.
Remarks

This methods saves all settable properties, including custom capabilities. The XML data should not be modified manually unless valid values for the capabilities are known.

Use the LoadXmlParameters(Stream) method to restore these device settings.

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.SetCameraPixelOrder Method

DeviceSetCameraPixelOrder Method

Sets the pixel order for each enabled camera.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetCameraPixelOrder(
    ImagePixelType[] pixelOrder
)
Public Function SetCameraPixelOrder (
    pixelOrder As ImagePixelType()
) As Boolean

Parameters

pixelOrder
Type: Atalasoft.TwainImagePixelType

An array indicating the pixel type for each camera.

If null (Nothing in VB) or an empty array are provided, the camera order will be reset to its startup value.

Return Value

Type: Boolean
True if the request was successful.
Exceptions
Exception | Condition
 | Thrown if the device is not in state SourceOpen.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.SetExtendedCapabilities Method

DeviceSetExtendedCapabilities Method

Sets the extended capabilities your application needs to negotiate during states 5 and 6 of a Twain session.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetExtendedCapabilities(
    DeviceCapability[] caps
)
Public Sub SetExtendedCapabilities (
    caps As DeviceCapability()
)

Parameters

caps
Type: Atalasoft.TwainDeviceCapability
Device capabilities the application needs to use during states 5 (SourceEnabled) and 6 (ReadyToTransfer).
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if there is an error during processing.
Remarks
Use the GetSupportedExtendedCapabilities to learn which capabilities the device supports.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetSupportedExtendedCapabilities


Device.SetExtendedImageInfoOptions Method

DeviceSetExtendedImageInfoOptions Method

Sets the extended image information options to obtain after acquiring the data.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetExtendedImageInfoOptions(
    params TwainExtendedImageInfoID[] info
)
Public Sub SetExtendedImageInfoOptions (
    ParamArray info As TwainExtendedImageInfoID()
)

Parameters

info
Type: Atalasoft.TwainTwainExtendedImageInfoID
The extended image information option to get from the device.
Remarks

This information is part of the AcquireEventArgs in the ImageAcquired event and MemoryDataTransferEventArgs in the TwainDataTransfer event.

This method should only be called before the Open method.

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.SetFrames Method

DeviceSetFrames Method

Sets multiple frames to acquire from when scanning.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetFrames(
    RectangleF[] frames
)
Public Sub SetFrames (
    frames As RectangleF()
)

Parameters

frames
Type: System.DrawingRectangleF
An array of RectangleF structures representing the frames to acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if the frames parameter is null (Nothing in VB).
 | Thrown if there is an error during processing.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceGetFrames


Device.SetImageDataset Method

DeviceSetImageDataset Method

Sets the indices of the images you want to acquire.

This is useful when you want to acquire multiple images from a camera with a single call to the Acquire method.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetImageDataset(
    int[] indices
)
Public Sub SetImageDataset (
    indices As Integer()
)

Parameters

indices
Type: SystemInt32
An array of image index values you want to acquire.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.SetImprinterEndorser Method

DeviceSetImprinterEndorser Method

Prepares the device to use it's imprinter/endorser for future acquisitions.
Overload List
 | Name | Description
Public method | SetImprinterEndorser(ImprinterEndorserType, Boolean) | Use this method to enable or disable an imprinter or endorser.
Public method | SetImprinterEndorser(ImprinterEndorserType, ImprinterEndorserMode, String, Int32, String) | Use this method to enable an imprinter or endorser and set its parameters.
Top
Remarks

This will raise an UnsupportedCapabilityException if the Printer, PrinterEnabled or PrinterMode DeviceCapability fail.

These methods are used to set the scanner imprinter or endorser values.

See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.SetImprinterEndorser Method (ImprinterEndorserType, Boolean)

DeviceSetImprinterEndorser Method (ImprinterEndorserType, Boolean)

Use this method to enable or disable an imprinter or endorser.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetImprinterEndorser(
    ImprinterEndorserType printer,
    bool enabled
)
Public Sub SetImprinterEndorser (
    printer As ImprinterEndorserType,
    enabled As Boolean
)

Parameters

printer
Type: Atalasoft.TwainImprinterEndorserType
The printer to use. Call GetSupportedPrinters to find out which printers are available.
enabled
Type: SystemBoolean
A value indicating whether the imprinter or endorser is enabled or disabled.
See Also

Reference

Device Class
SetImprinterEndorser Overload
Atalasoft.Twain Namespace


Device.SetImprinterEndorser Method (ImprinterEndorserType, ImprinterEndorserMode, String, Int32, String)

DeviceSetImprinterEndorser Method (ImprinterEndorserType, ImprinterEndorserMode, String, Int32, String)

Use this method to enable an imprinter or endorser and set its parameters.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void SetImprinterEndorser(
    ImprinterEndorserType printer,
    ImprinterEndorserMode mode,
    string text,
    int index,
    string suffix
)
Public Sub SetImprinterEndorser (
    printer As ImprinterEndorserType,
    mode As ImprinterEndorserMode,
    text As String,
    index As Integer,
    suffix As String
)

Parameters

printer
Type: Atalasoft.TwainImprinterEndorserType
The printer to use. Call GetSupportedPrinters to find out which printers are available.
mode
Type: Atalasoft.TwainImprinterEndorserMode
The text mode to use.
text
Type: SystemString
The text to print.
index
Type: SystemInt32
The starting index for the page.
suffix
Type: SystemString
An optional suffix used when mode is Compound.

Return Value

Type:
To disable an imprinter or endorser, use the overload for SetImprinterEndorser(ImprinterEndorserType, Boolean).
See Also

Reference

Device Class
SetImprinterEndorser Overload
Atalasoft.Twain Namespace


Device.ShowUserInterface Method

DeviceShowUserInterface Method

Displays the device interface.

This operation is used by applications that wish to display the device user interface to allow the user to manipulate the devices current settings for resolution, paper size, etc. but not acquire an image.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool ShowUserInterface()
Public Function ShowUserInterface As Boolean

Return Value

Type: Boolean
False if the user canceled the dialog.
Exceptions
Exception | Condition
 | Thrown if the current state is other than SourceOpen.
Remarks
You should check the EnableInterfaceOnly property to see if this feature is supported.
See Also

Reference

Device Class
Atalasoft.Twain Namespace
DeviceEnableInterfaceOnly


Device.StartAutomaticCapture Method

DeviceStartAutomaticCapture Method

Starts an automatic capture process.

This method does not acquire the images. Automatic capture implies that the device is capable of capturing images without the presence of the Application. This means that it must be possible for the Application to close the device and reopen it later, after the images have been captured.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void StartAutomaticCapture(
    string captureDirectory,
    int timeBeforeFirstCapture,
    int timeBetweenCaptures,
    int imageCount
)
Public Sub StartAutomaticCapture (
    captureDirectory As String,
    timeBeforeFirstCapture As Integer,
    timeBetweenCaptures As Integer,
    imageCount As Integer
)

Parameters

captureDirectory
Type: SystemString
The directory to save the captured image into.
timeBeforeFirstCapture
Type: SystemInt32
The number of milliseconds before the first image is captured.
timeBetweenCaptures
Type: SystemInt32
The number of milliseconds between captures.
imageCount
Type: SystemInt32
The number of images to capture.
Exceptions
Exception | Condition
 | Thrown if a connection to the device is not open.
 | Thrown if timeBeforeFirstCapture or timeBetweenCaptures is less than zero, or if imageCount is less than 1.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.ToString Method

DeviceToString Method

A string which describes this object.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
The ProductName of this device.
See Also

Reference

Device Class
Atalasoft.Twain Namespace


Device.TryOpen Method

DeviceTryOpen Method

This method will attempt to open a connection to the device and will return true if it was successful. It's preferred to use this method instead of the Open method.

The Close method must be called when you are finished using the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool TryOpen()
Public Function TryOpen As Boolean

Return Value

Type: Boolean
True if the device connection was a success.
Remarks
This method will suppress exceptions and instead return true or false to indicate if the device was already open or has been successfully opened.
Examples
C#
VB
Copy
if (this.device.TryOpen())
{
    this.device.Resolution = new TwainResolution(200, 200);
    this.device.HideInterface = true;
    this.device.Acquire();
}
If Me.device.TryOpen() Then
    Me.device.Resolution = New TwainResolution(200, 200)
    Me.device.HideInterface = True
    Me.device.Acquire()
End If
See Also

Reference

Device Class
Atalasoft.Twain Namespace


DeviceCapability Enumeration

The device capabilities which can be tested with the QueryCapability(DeviceCapability, Boolean) method. This enumeration is also used with the low level TwainController.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DeviceCapability
Public Enumeration DeviceCapability
Members
Member name | Description
ACAP_AUDIOFILEFORMAT | Used to specify the audio file format when acquiring audio.
ACAP_XFERMECH | Allows the Application and Source to identify which audio transfer mechanisms they have in common.
CAP_ALARMS | Indicates if specific audible alarms are on or off.
CAP_ALARMVOLUME | Allows you to control the volume of any alarms.
CAP_AUTHOR | The name or other identifying information about the Author of the image.
CAP_AUTOMATICCAPTURE | Indicates if the device supports automatic capture.
CAP_AUTOFEED | Indicates if the feeder will automatically load the pages.
CAP_AUTOSCAN | Indicates if the device supports AutoScan.
CAP_BATTERYMINUTES | Indicates if the device can report the number of battery minutes remaining.
CAP_BATTERYPERCENTAGE | Indicates if the device can report the percentage of battery available.
CAP_CAMERAENABLED | Indicates whether the current CAP_CAMERASIDE is enabled.
CAP_CAMERAORDER | Indicates the order of the images returned when more than one camera is enabled.
CAP_CAMERAPREVIEWUI | Indicates if the device supports a camera preview interface. This is a good indicator that the device is a camera.
CAP_CAMERASIDE | Used to control if the front (top) or back (bottom) camera is enabled for a duplex scan. The EnableCamera(TwainCameraSide, Boolean) method can be used for this functionality.
CAP_CAPTION | A general note about the acquired image.
CAP_CLEARBUFFERS | Allows you to set the mode the source uses to clear it's internal buffer.
CAP_CLEARPAGE | Ejects the current page being acquired and leaves the feeder acquire area empty.
CAP_CUSTOMBASE | Indicates if custom capabilities are supported.
CAP_CUSTOMDSDATA | Allows the application to query the data source to see if it supports the SaveParameters(Stream) and LoadParameters(Stream) methods.
CAP_DEVICEEVENT | Indicates that the device supports device event callbacks.
CAP_DEVICEONLINE | Indicates if the device is powered up and ready to use.
CAP_DEVICETIMEDATE | Allows you to get the date and time of the device.
CAP_DUPLEX | Allows you to specify the type of duplex to use.
CAP_DUPLEXENABLED | Allows you to turn duplex on or off.
CAP_ENABLEDSUIONLY | Indicates if the interface can be displayed without acquiring an image. This is required to use ShowUserInterface.
CAP_ENDORSER | Allows you to set the starting endorser number.
CAP_EXTENDEDCAPS | Indicates if the device has extended capabilities.
CAP_FEEDERALIGNMENT | Allows you to set the paper alignment in a document feeder.
CAP_FEEDERENABLED | Indicates if the document feeder is enabled.
CAP_FEEDERLOADED | Indicates if the document feeder has pages loaded.
CAP_FEEDERORDER | Allows you to set the page order in a document feeder.
CAP_FEEDERPOCKET | Indicates which feeder output pocket will be used.
CAP_FEEDERPREP | Improves the movement of the paper through the scanner.
CAP_FEEDPAGE | Forces the document feeder to eject the current page and load the next page.
CAP_INDICATORS | Indicates if the source will display a progress bar during an acquisition.
CAP_JOBCONTROL | Allows multiple jobs in batch mode.
CAP_LANGUAGE | Allows you to specify the language to use.
CAP_MAXBATCHBUFFERS | Allows you to set the number of pages that the scanner can buffer when AutoScan is enabled.
CAP_MICRENABLED | Enables MICR check scanning.
CAP_PAPERDETECTABLE | Indicates if the device has a paper sensor.
CAP_POWERSUPPLY | Allows you to get the type of power supply being used.
CAP_PRINTER | Indicates that the device supports an imprinter or endorser.
CAP_PRINTERENABLED | Allows you to turn the imprinter/endorser on or off.
CAP_PRINTERINDEX | Allows you to specify the endorser starting number.
CAP_PRINTERMODE | Allows you to specify the type of imprinter/endorser to use.
CAP_PRINTERSTRING | Allows you to specify the imprinter/endorser text.
CAP_PRINTERSUFFIX | Allows you to specify the imprinter/endorser suffix text.
CAP_REACQUIREALLOWED | Indicates whether the physical hardware is capable of acquiring multiple images of the same page.
CAP_REWINDPAGE | Forces the document feeder to return the current page to the input area and bring the last page scanned back into the scan area.
CAP_SEGMENTED | Describes the segmentation settings for captured images.
CAP_SERIALNUMBER | A string containing the serial number of this device.
CAP_SUPPORTEDCAPS | Indicates if the device can use the GetSupportedCapabilities method.
CAP_THUMBNAILSENABLED | Indicates if a thumbnail should be returned instead of the full size image.
CAP_TIMEBEFOREFIRSTCAPTURE | The amount of time before the first capture. This is used in StartAutomaticCapture(String, Int32, Int32, Int32).
CAP_TIMEBETWEENCAPTURES | The amount of time between captures. This is used in StartAutomaticCapture(String, Int32, Int32, Int32).
CAP_TIMEDATE | The date and time of the image.
CAP_UICONTROLLABLE | Indicates if the interface can be hidden during an acquire.
CAP_XFERCOUNT | The number of images your application is willing to accept.
ICAP_AUTOBRIGHT | Indicates if the device supports the AutoBrightness feature.
ICAP_AUTODISCARDBLANKPAGES | Indicates if the device supports the AutoDiscardBlankPages property.
ICAP_AUTOMATICBORDERDETECTION | Allows you to turn AutomaticBorderDetection on or off.
ICAP_AUTOMATICDESKEW | Allows you to turn the automatic deskew on or off.
ICAP_AUTOMATICROTATE | Allows you to turn the automatic rotation on or off.
ICAP_AUTOSIZE | Forces the output image size to match either the ICAP_SUPPORTEDSIZES or any supported value.
ICAP_BARCODEDETECTIONENABLED | Turns bar code detection on and off.
ICAP_BARCODEMAXRETRIES | Restricts the number of times a search will be retried if none are found on each page.
ICAP_BARCODEMAXSEARCHPRIORITIES | Determines how many bar code detection priorities can be set.
ICAP_BARCODESEARCHMODE | Restricts bar code searching to certain orientations, or prioritizes one orientation over the other.
ICAP_BARCODESEARCHPRIORITIES | A prioritized list of bar code types dictating the order in which bar codes will be sought.
ICAP_BARCODETIMEOUT | Restricts the total time spent on searching for a bar code on each page.
ICAP_BITDEPTH | Allows you to specify the bitdepth of the acquisition.
ICAP_BITDEPTHREDUCTION | Allows you to specify the type of bit depth reduction used by the source.
ICAP_BITORDER | Specifies how bytes in an image are filled by the source.
ICAP_BITORDERCODES | Used for CCITT data compression only. Indicates the bit order representation of the stored,compressed codes.
ICAP_BRIGHTNESS | Allows you to specify the amount of brightness the source applies to the image.
ICAP_CCITTKFACTOR | Indicates if the device supports Group 3 compression and allows you to specify the K factor.
ICAP_COMPRESSION | Indicates that the device supports compression when acquiring to file.
ICAP_CONTRAST | Allows you to specify the contrast of the image.
ICAP_CUSTHALFTONE | Specifies the halftone matrix the source device should use.
ICAP_EXPOSURETIME | Indicates that the device supports an exposure time. This is a good indication that the device is a camera.
ICAP_EXTIMAGEINFO | Determines if the device supports the SetExtendedCapabilities(DeviceCapability) method.
ICAP_FEEDERTYPE | Allows setting scan parameters depending upon the type of feeder.
ICAP_FILTER | Allows you to specify a color filter to apply to the image.
ICAP_FLASHUSED | Indicates that a flash was used. This is a good indication that the device is a camera.
ICAP_FLASHUSED2 | Indicates that a flash was used. This was added to the Twain specification to enhance the Flash property.
ICAP_FLIPROTATION | Allows you to specify how pages are to be scanned.
ICAP_FRAMES | Allows you to specify that only a section of the scanning bed be acquired.
ICAP_GAMMA | Allows you to apply gamma to the image when acquired.
ICAP_HALFTONES | Specifies the halftone to be used by the source.
ICAP_HIGHLIGHT | Allows you to set the maximum highlight value in the image.
ICAP_ICCPROFILE | Indicates if the driver supports linking or embedding an ICC profile.
ICAP_IMAGEDATASET | Allows you to specify which images to acquire. This is used with SetImageDataset(Int32).
ICAP_IMAGEFILEFORMAT | Indicates if the device supports saving directly to file.
ICAP_IMAGEFILTER | Indicates that a filter can be applied to the image when acquired.
ICAP_JPEGPIXELTYPE | Allows the application and source to agree on a pixel type used during a compressed memory transfer.
ICAP_JPEGQUALITY | Allows you to specify the JPEG quality to use when acquiring directly to file.
ICAP_LAMPSTATE | Indicates if the lamp is currently, or should be on or off.
ICAP_LIGHTPATH | Describes whether the image was captured transmissively or reflectively.
ICAP_LIGHTSOURCE | Describes the general color characteristic of the light source used to acquire the image.
ICAP_MAXFRAMES | The maximum number of frames the source can provide or the application can accept.
ICAP_MINIMUMHEIGHT | Allows you to retrieve the minimum acquisition height.
ICAP_MINIMUMWIDTH | Allows you to retrieve the minimum acquisition width.
ICAP_NOISEFILTER | Allows you to specify a noise filter to use during an acquire.
ICAP_ORIENTATION | Allows you to specify the orientation of the acquire.
ICAP_OVERSCAN | Allows you to turn Overscan on or off.
ICAP_PATCHCODEDETECTIONENABLED | Turns patch code detection on and off.
ICAP_PATCHCODEMAXRETRIES | Restricts the number of times a search will be retried if none are found on each page.
ICAP_PATCHCODEMAXSEARCHPRIORITIES | Determines how many patch code detection priorities can be set.
ICAP_PATCHCODESEARCHMODE | Restricts patch code searching to certain orientations, or prioritizes one orientation over the other.
ICAP_PATCHCODESEARCHPRIORITIES | A prioritized list of patch code types dictating the order in which patch codes will be sought.
ICAP_PATCHCODETIMEOUT | Restricts the total time spent on searching for a patch code on each page.
ICAP_PHYSICALWIDTH | Indicates that the device can return its physical width.
ICAP_PHYSICALHEIGHT | Indicates that the device can return its physical height.
ICAP_PIXELFLAVOR | Used to indicate whether black or white has a value of zero in an image.
ICAP_PIXELFLAVORCODES | Used only for CCITT data compression. Specifies whether the compressed codes? pixel ?sense?,will be inverted from the Current value of ICAP_PIXELFLAVOR prior to transfer.
ICAP_PIXELTYPE | Allows you to specify the pixel format of the image.
ICAP_PLANARCHUNKY | Allows image data to be transferred in planar or chunky format.
ICAP_ROTATION | The amount to rotate the image by the Source.
ICAP_SHADOW | The value in an image which should be interpreted as the darkest shadow.
ICAP_SUPPORTEDBARCODETYPES | Provides a list of bar codes that can be detected by the device.
ICAP_SUPPORTEDPATCHCODETYPES | Provides a list of patch codes that can be detected by the device.
ICAP_SUPPORTEDSIZES | Allows predefined frame sizes to be set.
ICAP_THRESHOLD | The dividing line between black and white for 1-bit acquires.
ICAP_TILES | Used with buffered memory transfers to indicate whether the image data is transferred in tiles or strips.
ICAP_TIMEFILL | Used only with CCITT data compression. Specifies the minimum number of words of,compressed codes (compressed data) to be transmitted per line.
ICAP_UNDEFINEDIMAGESIZE | Used by the application to notify the Source that the application accepts -1 as the image width,or -length in the BeforeTwainDataTransfer event.
ICAP_UNITS | The units of measure for this acquire.
ICAP_XFERMECH | The transfer method used to acquire images.
ICAP_XNATIVERESOLUTION | The native optical resolution of the device along the X-axis.
ICAP_XRESOLUTION | The number of pixels per unit for the horizontal direction as specified by the Units property.
ICAP_XSCALING | The amount of scaling in the horizontal direction the Source will perform on the image.
ICAP_YNATIVERESOLUTION | The native optical resolution of the device along the Y-axis.
ICAP_YRESOLUTION | The number of pixels per unit in the vertical direction as specified by the Units property.
ICAP_YSCALING | The amount of scaling in the vertical direction the Source will perform on the image.
ICAP_ZOOMFACTOR | The zoom factor to use for the acquire.
See Also

Reference

Atalasoft.Twain Namespace


DeviceCollection Class

Contains a collection of all Device objects on the system.

Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.TwainDeviceCollection

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class DeviceCollection : ReadOnlyCollectionBase
Public NotInheritable Class DeviceCollection
    Inherits ReadOnlyCollectionBase

The DeviceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
 | Default | Gets the system default device.
Public property | Item | Gets a Device from the collection at the specified index.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDevice | Returns a specific Device object.
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ScanForChanges | Checks the system for any device changes and regenerates the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

This information can be used to look for a device which fits the needs of your application, or to create a custom interface for selecting a device instead of using the Twain dialog displayed by ShowSelectSource.

See Also

Reference

Atalasoft.Twain Namespace


DeviceCollection Properties

The DeviceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
 | Default | Gets the system default device.
Public property | Item | Gets a Device from the collection at the specified index.
Top
See Also

Reference

DeviceCollection Class
Atalasoft.Twain Namespace


DeviceCollection.Default Property

DeviceCollectionDefault Property

Gets the system default device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Device Default { get; }
Public ReadOnly Property Default As Device
    Get

Property Value

Type: Device
The system default device.
Remarks
This property performs a TWAIN query to obtain the current default device. Since the system default device can change at any time, never call methods directly on this property.
Examples
C#
VB
Copy
Device dev = this.acquisition1.Devices.Default;
if (dev.TryOpen())
{
    dev.PixelType = ImagePixelType.BlackAndWhite;
    dev.ModalAcquire = true;
    dev.Acquire();
    dev.Close();
}
Dim dev As Device = Me.acquisition1.Devices.Default
If dev.TryOpen() Then
    dev.PixelType = ImagePixelType.BlackAndWhite
    dev.ModalAcquire = True
    dev.Acquire()
    dev.Close()
End If
See Also

Reference

DeviceCollection Class
Atalasoft.Twain Namespace


DeviceCollection.Item Property

DeviceCollectionItem Property

Gets a Device from the collection at the specified index.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Device this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Device
    Get

Parameters

index
Type: SystemInt32
The collection index of the device.

Property Value

Type: Device
A Device from the collection at the specified index.
See Also

Reference

DeviceCollection Class
Atalasoft.Twain Namespace


DeviceCollection Methods

The DeviceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDevice | Returns a specific Device object.
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ScanForChanges | Checks the system for any device changes and regenerates the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceCollection Class
Atalasoft.Twain Namespace


DeviceCollection.GetDevice Method

DeviceCollectionGetDevice Method

Returns a specific Device object.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public Device GetDevice(
    string productName
)
Public Function GetDevice (
    productName As String
) As Device

Parameters

productName
Type: SystemString
The product name of the Device. This is the name that shows in the Select Source dialog.

Return Value

Type: Device
A Device object that matches the product name or null (Nothing in Visual Basic).
See Also

Reference

DeviceCollection Class
Atalasoft.Twain Namespace
Atalasoft.TwainDevice


DeviceCollection.ScanForChanges Method

DeviceCollectionScanForChanges Method

Checks the system for any device changes and regenerates the collection.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ScanForChanges()
Public Sub ScanForChanges
Remarks
This method is automatically called the first time you access the Devices property of the Acquisition object.
See Also

Reference

DeviceCollection Class
Atalasoft.Twain Namespace


DeviceEventArgs Class

Contains information about a device event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Atalasoft.TwainDeviceEventArgs

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class DeviceEventArgs : EventArgs
Public Class DeviceEventArgs
    Inherits EventArgs

The DeviceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AutomaticCaptureCount | Gets the number of images that will be automatically captured by the device.
Public property | BatteryMinutes | Gets the number of battery minutes remaining.
Public property | BatteryPercentage | Gets the percentage of the battery remaining.
Public property | CancelPending | Gets or sets a value which determines if the pending images will be acquired.
Public property | DeviceName | Gets the product name of the device which fired the event.
Public property | Event | Gets the event that was triggered.
Public property | Flash | Gets the flash mode of the device.
Public property | PowerSupply | Gets the type of power supply being used.
Public property | Resolution | Gets the resolution of the device.
Public property | TimeBeforeFirstCapture | Gets the number of milliseconds before the first capture will take place.
Public property | TimeBetweenCaptures | Gets the number of milliseconds between captures.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Which properties are filled depends on the DeviceEventFlags which fired.
See Also

Reference

Atalasoft.Twain Namespace
Atalasoft.TwainDeviceEventFlags


DeviceEventArgs Properties

The DeviceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AutomaticCaptureCount | Gets the number of images that will be automatically captured by the device.
Public property | BatteryMinutes | Gets the number of battery minutes remaining.
Public property | BatteryPercentage | Gets the percentage of the battery remaining.
Public property | CancelPending | Gets or sets a value which determines if the pending images will be acquired.
Public property | DeviceName | Gets the product name of the device which fired the event.
Public property | Event | Gets the event that was triggered.
Public property | Flash | Gets the flash mode of the device.
Public property | PowerSupply | Gets the type of power supply being used.
Public property | Resolution | Gets the resolution of the device.
Public property | TimeBeforeFirstCapture | Gets the number of milliseconds before the first capture will take place.
Public property | TimeBetweenCaptures | Gets the number of milliseconds between captures.
Top
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.AutomaticCaptureCount Property

DeviceEventArgsAutomaticCaptureCount Property

Gets the number of images that will be automatically captured by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int AutomaticCaptureCount { get; }
Public ReadOnly Property AutomaticCaptureCount As Integer
    Get

Property Value

Type: Int32
The number of images that will be acquired.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.BatteryMinutes Property

DeviceEventArgsBatteryMinutes Property

Gets the number of battery minutes remaining.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BatteryMinutes { get; }
Public ReadOnly Property BatteryMinutes As Integer
    Get

Property Value

Type: Int32
The battery minutes remaining.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.BatteryPercentage Property

DeviceEventArgsBatteryPercentage Property

Gets the percentage of the battery remaining.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int BatteryPercentage { get; }
Public ReadOnly Property BatteryPercentage As Integer
    Get

Property Value

Type: Int32
The percentage of battery remaining.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.CancelPending Property

DeviceEventArgsCancelPending Property

Gets or sets a value which determines if the pending images will be acquired.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool CancelPending { get; set; }
Public Property CancelPending As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating whether any pending pages are canceled.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.DeviceName Property

DeviceEventArgsDeviceName Property

Gets the product name of the device which fired the event.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string DeviceName { get; }
Public ReadOnly Property DeviceName As String
    Get

Property Value

Type: String
The name of the device.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.Event Property

DeviceEventArgsEvent Property

Gets the event that was triggered.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DeviceEventFlags Event { get; }
Public ReadOnly Property Event As DeviceEventFlags
    Get

Property Value

Type: DeviceEventFlags
The event that was triggered.
Remarks
For events such as PaperJam or PaperDoubleFeed, you may want to cancel any pending acquisitions.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.Flash Property

DeviceEventArgsFlash Property

Gets the flash mode of the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FlashMode Flash { get; }
Public ReadOnly Property Flash As FlashMode
    Get

Property Value

Type: FlashMode
The flash mode.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.PowerSupply Property

DeviceEventArgsPowerSupply Property

Gets the type of power supply being used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public PowerSupplyMode PowerSupply { get; }
Public ReadOnly Property PowerSupply As PowerSupplyMode
    Get

Property Value

Type: PowerSupplyMode
The power supply mode.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.Resolution Property

DeviceEventArgsResolution Property

Gets the resolution of the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainResolution Resolution { get; }
Public ReadOnly Property Resolution As TwainResolution
    Get

Property Value

Type: TwainResolution
The resolution of the device.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.TimeBeforeFirstCapture Property

DeviceEventArgsTimeBeforeFirstCapture Property

Gets the number of milliseconds before the first capture will take place.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TimeBeforeFirstCapture { get; }
Public ReadOnly Property TimeBeforeFirstCapture As Integer
    Get

Property Value

Type: Int32
The number of milliseconds before the first capture.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs.TimeBetweenCaptures Property

DeviceEventArgsTimeBetweenCaptures Property

Gets the number of milliseconds between captures.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int TimeBetweenCaptures { get; }
Public ReadOnly Property TimeBetweenCaptures As Integer
    Get

Property Value

Type: Int32
The number of milliseconds between captures.

Property Value

Type: Int32
The number of milliseconds between captures.
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventArgs Methods

The DeviceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceEventArgs Class
Atalasoft.Twain Namespace


DeviceEventFlags Enumeration

A set of bit flags used to indicate which device events you want to receive.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum DeviceEventFlags
<FlagsAttribute>
Public Enumeration DeviceEventFlags
Members
Member name | Description
None | Disable device events.
AutomaticCapture | The automatic capture settings on the device have been changed by the user.
Battery | The status of the battery has changed.
CheckDeviceOnline | Indicates that a device has become unavailable.
CustomEvents | Baseline for events specific to a given Source.
DeviceAdded | The user has added a device (for instance a memory card in a digital camera).
DeviceOffline | A device has become unavailable, but has not been removed.
DeviceReady | The device is ready to capture an image.
DeviceRemoved | The user has removed a device.
Flash | The flash setting on the device has been changed by the user.
ImageCaptured | The user has captured an image to the device s internal storage.
ImageDeleted | The user has removed an image from the device s internal storage.
LampFailure | The device s light source has failed.
PaperDoubleFeed | Two or more sheets of paper have been fed together.
PaperJam | The device s document feeder has jammed.
PowerSupply | The power supply has been changed (for instance, the user may have just connected AC to a device that was running on battery power).
Resolution | The x/y resolution setting on the device has been changed by the user.
PowerDown | The device is about to power down to save energy.
PowerSaveNotify | Indicates that the device has switched to a power save mode.
See Also

Reference

Atalasoft.Twain Namespace


DeviceEventHandler Delegate

This event handler is used to pass the DeviceEventFlagss to the application.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public delegate void DeviceEventHandler(
    Object sender,
    DeviceEventArgs e
)
Public Delegate Sub DeviceEventHandler (
    sender As Object,
    e As DeviceEventArgs
)

Parameters

sender
Type: SystemObject
The Acquisition object which sent the event.
e
Type: Atalasoft.TwainDeviceEventArgs
A DeviceEventArgs object containing information about the event.
See Also

Reference

Atalasoft.Twain Namespace
Atalasoft.TwainDeviceEventFlags


DocumentFeeder Class

Gives control over the document feeder used by a scanner.
Inheritance Hierarchy
SystemObject
Atalasoft.TwainDocumentFeeder

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class DocumentFeeder
Public NotInheritable Class DocumentFeeder

The DocumentFeeder type exposes the following members.

Properties
 | Name | Description
Public property | AutoFeed | Gets or sets a value indicating if the feeder will automatically load the pages.
Public property | Enabled | Gets or sets a value indicating if the document feeder is enabled. You should set this property to true before getting or setting any other DocumentFeeder properties.
Public property | FeederPrep | Gets or sets the CAP_FEEDERPREP capability, which is used to improve movement of the page through the feeder.
Public property | FeederType | Gets or sets the ICAP_FEEDERTYPE capability which determines which feeder type is used.
Public property | Loaded | Gets a value indicating if the document feeder has pages loaded.
Public property | PageAlignment | Gets or sets the positioning of the page on the scanner.
Public property | PageOrder | Gets or sets a value stating the order in which the pages will be scanned.
Top
Methods
 | Name | Description
Public method | ClearPage | Ejects the current page being acquired and leaves the feeder acquire area empty.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FeedPage | Forces the document feeder to eject the current page and load the next page.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetOutputFeederPockets | Gets the feeder pockets for the device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NegotiateCapabilities | Use this method to notify the device driver that control over the document feeder is requested.
Public method | RewindPage | Forces the document feeder to return the current page to the input area and bring the last page scanned back into the scan area.
Public method | SetOutputFeederPockets | Sets the feeder pockets used for page output.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Twain Namespace


DocumentFeeder Properties

The DocumentFeeder type exposes the following members.

Properties
 | Name | Description
Public property | AutoFeed | Gets or sets a value indicating if the feeder will automatically load the pages.
Public property | Enabled | Gets or sets a value indicating if the document feeder is enabled. You should set this property to true before getting or setting any other DocumentFeeder properties.
Public property | FeederPrep | Gets or sets the CAP_FEEDERPREP capability, which is used to improve movement of the page through the feeder.
Public property | FeederType | Gets or sets the ICAP_FEEDERTYPE capability which determines which feeder type is used.
Public property | Loaded | Gets a value indicating if the document feeder has pages loaded.
Public property | PageAlignment | Gets or sets the positioning of the page on the scanner.
Public property | PageOrder | Gets or sets a value stating the order in which the pages will be scanned.
Top
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.AutoFeed Property

DocumentFeederAutoFeed Property

Gets or sets a value indicating if the feeder will automatically load the pages.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool AutoFeed { get; set; }
Public Property AutoFeed As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the feeder will automatically load the pages.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.Enabled Property

DocumentFeederEnabled Property

Gets or sets a value indicating if the document feeder is enabled.

You should set this property to true before getting or setting any other DocumentFeeder properties.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the document feeder is enabled.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.FeederPrep Property

DocumentFeederFeederPrep Property

Gets or sets the CAP_FEEDERPREP capability, which is used to improve movement of the page through the feeder.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool FeederPrep { get; set; }
Public Property FeederPrep As Boolean
    Get
    Set

Property Value

Type: Boolean
A value indicating if the device can improve movement of the page through the feeder.
Exceptions
Exception | Condition
 | Thrown if the state is less than SourceOpen for getting the value, or is not equal to SourceOpen when setting the value.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.FeederType Property

DocumentFeederFeederType Property

Gets or sets the ICAP_FEEDERTYPE capability which determines which feeder type is used.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainFeederType FeederType { get; set; }
Public Property FeederType As TwainFeederType
    Get
    Set

Property Value

Type: TwainFeederType
Indicates which feeder type is used.
Exceptions
Exception | Condition
 | Thrown if the state is less than SourceOpen for getting the value, or is not equal to SourceOpen when setting the value.
Remarks
It's advised that this capability be set before image capabilities such as resolution and pixel type.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.Loaded Property

DocumentFeederLoaded Property

Gets a value indicating if the document feeder has pages loaded.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool Loaded { get; }
Public ReadOnly Property Loaded As Boolean
    Get

Property Value

Type: Boolean
A value indicating if there are pages in the feeder.
Remarks
In most cases this property can be used to find out if a scanner has a document feeder; however there are some scanners that always return true.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.PageAlignment Property

DocumentFeederPageAlignment Property

Gets or sets the positioning of the page on the scanner.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentFeederAlignment PageAlignment { get; set; }
Public Property PageAlignment As DocumentFeederAlignment
    Get
    Set

Property Value

Type: DocumentFeederAlignment
The positioning of the page on the scanner.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.PageOrder Property

DocumentFeederPageOrder Property

Gets or sets a value stating the order in which the pages will be scanned.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public DocumentFeederOrder PageOrder { get; set; }
Public Property PageOrder As DocumentFeederOrder
    Get
    Set

Property Value

Type: DocumentFeederOrder
A value stating the order in which the pages will be scanned.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder Methods

The DocumentFeeder type exposes the following members.

Methods
 | Name | Description
Public method | ClearPage | Ejects the current page being acquired and leaves the feeder acquire area empty.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FeedPage | Forces the document feeder to eject the current page and load the next page.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetOutputFeederPockets | Gets the feeder pockets for the device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NegotiateCapabilities | Use this method to notify the device driver that control over the document feeder is requested.
Public method | RewindPage | Forces the document feeder to return the current page to the input area and bring the last page scanned back into the scan area.
Public method | SetOutputFeederPockets | Sets the feeder pockets used for page output.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.ClearPage Method

DocumentFeederClearPage Method

Ejects the current page being acquired and leaves the feeder acquire area empty.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void ClearPage()
Public Sub ClearPage
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace
DocumentFeederFeedPage
DocumentFeederRewindPage


DocumentFeeder.FeedPage Method

DocumentFeederFeedPage Method

Forces the document feeder to eject the current page and load the next page.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void FeedPage()
Public Sub FeedPage
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace
DocumentFeederClearPage
DocumentFeederRewindPage


DocumentFeeder.GetOutputFeederPockets Method

DocumentFeederGetOutputFeederPockets Method

Gets the feeder pockets for the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainFeederPocket[] GetOutputFeederPockets()
Public Function GetOutputFeederPockets As TwainFeederPocket()

Return Value

Type: TwainFeederPocket
An array of feeder pockets for the device.
Exceptions
Exception | Condition
 | Thrown if the state is not SourceOpen.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.NegotiateCapabilities Method

DocumentFeederNegotiateCapabilities Method

Use this method to notify the device driver that control over the document feeder is requested.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public TwainReturnCode NegotiateCapabilities()
Public Function NegotiateCapabilities As TwainReturnCode

Return Value

Type: TwainReturnCode
The code returned from the driver.
Remarks
This method only needs to be called if the ClearPage, FeedPage or RewindPage methods will be used. The Enabled property must be set to true before calling NegotiateCapabilities.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeeder.RewindPage Method

DocumentFeederRewindPage Method

Forces the document feeder to return the current page to the input area and bring the last page scanned back into the scan area.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public void RewindPage()
Public Sub RewindPage
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace
DocumentFeederClearPage
DocumentFeederFeedPage


DocumentFeeder.SetOutputFeederPockets Method

DocumentFeederSetOutputFeederPockets Method

Sets the feeder pockets used for page output.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public bool SetOutputFeederPockets(
    TwainFeederPocket[] pockets
)
Public Function SetOutputFeederPockets (
    pockets As TwainFeederPocket()
) As Boolean

Parameters

pockets
Type: Atalasoft.TwainTwainFeederPocket
An array of TwainFeederPocket where pages should be placed after scanning.

Return Value

Type: Boolean
True if the operation was a success.
Exceptions
Exception | Condition
 | Thrown if the state is not SourceOpen.
See Also

Reference

DocumentFeeder Class
Atalasoft.Twain Namespace


DocumentFeederAlignment Enumeration

Used to determine the alignment of the paper in a document feeder.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DocumentFeederAlignment
Public Enumeration DocumentFeederAlignment
Members
Member name | Description
None | The alignment is free-floating.
Left | The alignment is to the left.
Center | The alignment is centered.
Right | The alignment is to the right.
See Also

Reference

Atalasoft.Twain Namespace
Atalasoft.TwainDocumentFeeder


DocumentFeederOrder Enumeration

Used to set the page order of the document feeder.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DocumentFeederOrder
Public Enumeration DocumentFeederOrder
Members
Member name | Description
FirstPageFirst | The first page will be acquired first.
LastPageFirst | The last page will be acquired first.
See Also

Reference

Atalasoft.Twain Namespace
DocumentFeederPageOrder
Atalasoft.TwainDocumentFeeder


DuplexMode Enumeration

The duplex mode supported by the device.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum DuplexMode
Public Enumeration DuplexMode
Members
Member name | Description
None | No duplex is supported.
OnePass | Single-pass duplex will be used. Both sides are scanned in a single pass.
TwoPass | Double-pass duplex will be used. Only one side at a time is scanned.
See Also

Reference

Atalasoft.Twain Namespace
DeviceDuplex


FileInformation Class

Contains information about a specific file in the FileSystem.
Inheritance Hierarchy
SystemObject
Atalasoft.TwainFileInformation

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public sealed class FileInformation
Public NotInheritable Class FileInformation

The FileInformation type exposes the following members.

Properties
 | Name | Description
Public property | CreateTimeDate | Gets the file creation time.
Public property | FileName | Gets the full path and name of the file.
Public property | FileSize | Gets the file size in bytes.
Public property | FileType | Gets a value indicating if this is an image, directory or other item.
Public property | ModifyTimeDate | Gets the file modify time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Twain Namespace
Atalasoft.TwainFileSystem


FileInformation Properties

The FileInformation type exposes the following members.

Properties
 | Name | Description
Public property | CreateTimeDate | Gets the file creation time.
Public property | FileName | Gets the full path and name of the file.
Public property | FileSize | Gets the file size in bytes.
Public property | FileType | Gets a value indicating if this is an image, directory or other item.
Public property | ModifyTimeDate | Gets the file modify time.
Top
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileInformation.CreateTimeDate Property

FileInformationCreateTimeDate Property

Gets the file creation time.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CreateTimeDate { get; }
Public ReadOnly Property CreateTimeDate As String
    Get

Property Value

Type: String
The file creation time.
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileInformation.FileName Property

FileInformationFileName Property

Gets the full path and name of the file.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The full path and name of the file.
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileInformation.FileSize Property

FileInformationFileSize Property

Gets the file size in bytes.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public int FileSize { get; }
Public ReadOnly Property FileSize As Integer
    Get

Property Value

Type: Int32
The file size in bytes.
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileInformation.FileType Property

FileInformationFileType Property

Gets a value indicating if this is an image, directory or other item.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileItemType FileType { get; }
Public ReadOnly Property FileType As FileItemType
    Get

Property Value

Type: FileItemType
A value indicating if this is an image, directory or other item.
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileInformation.ModifyTimeDate Property

FileInformationModifyTimeDate Property

Gets the file modify time.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string ModifyTimeDate { get; }
Public ReadOnly Property ModifyTimeDate As String
    Get

Property Value

Type: String
The file modify time.
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileInformation Methods

The FileInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileInformation Class
Atalasoft.Twain Namespace


FileItemType Enumeration

Indicates the type of file or device camera position.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public enum FileItemType
Public Enumeration FileItemType
Members
Member name | Description
Camera | The default camera used in a FileSystem.
CameraTop | The camera which will acquire the top of the page.
CameraBottom | The camera which will acquire the back side of the page.
CameraReview | A logical device that performs camera live preview functionality.
Directory | A directory can contain other directories and/or images.
Domain | This is the root of the device. A domain can only contains Host directories.
Host | The host is a branch of the domain and can only contain directories.
Image | The file is an image.
Unknown | The type of file is unknown.
See Also

Reference

Atalasoft.Twain Namespace
FileInformationFileType
Atalasoft.TwainFileInformation
Atalasoft.TwainFileSystem


FileSystem Class

Contains methods which can navigate the file system of a camera.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Atalasoft.TwainFileSystem

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public class FileSystem : ReadOnlyCollectionBase
Public Class FileSystem
    Inherits ReadOnlyCollectionBase

The FileSystem type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | CurrentDirectory | Gets or sets the current directory.
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Allows you to enumerate through the directories and files in the FileSystem.
Top
Methods
 | Name | Description
Public method | CollectFileInformation | Refreshes the list of directories and files.
Public method | Copy | Copies a file or directory from one location to another.
Public method | CreateDirectory | Creates a new directory in the current directory.
Public method | Delete | Deletes a file or directory from the current directory.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatMedia | Removes all files and folders from the file system.
Public method | GetClose | Frees an internal context which is generated by calling GetFirstFile.
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetFirstFile | Finds the first file in the current directory and returns information about it.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextFile | Finds the next file in the current directory and returns information about it.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rename | Renames a file or directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Atalasoft.Twain Namespace


FileSystem Properties

The FileSystem type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | CurrentDirectory | Gets or sets the current directory.
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Allows you to enumerate through the directories and files in the FileSystem.
Top
See Also

Reference

FileSystem Class
Atalasoft.Twain Namespace


FileSystem.CurrentDirectory Property

FileSystemCurrentDirectory Property

Gets or sets the current directory.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public string CurrentDirectory { get; set; }
Public Property CurrentDirectory As String
    Get
    Set

Property Value

Type: String
The current directory.
See Also

Reference

FileSystem Class
Atalasoft.Twain Namespace


FileSystem.Item Property

FileSystemItem Property

Allows you to enumerate through the directories and files in the FileSystem.

Namespace: Atalasoft.Twain
Assembly: Atalasoft.DotTwain (in Atalasoft.DotTwain.dll) Version: 11.4.0.9.0.377 (.NET 4.5.2, x86)
Syntax
C#
VB
Copy
public FileInformation this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As FileInformation
    Get

Parameters

index
Type: SystemInt32
The index of the file you want information about.

Property Value

Type: FileInformation
A FileInformation object containing data about the file or directory.
See Also

Reference

FileSystem Class
Atalasoft.Twain Namespace